What is NotateXpress

Pegasus Imaging NotateXpress™ version 9 control is an invisible-at-runtime (windowless) control that adds powerful annotation functionality to the Pegasus Imaging ImagXpress component. NotateXpress enables annotation capability both programmatically and through application end-user interaction.

New in NotateXpress Version 9.0

  • XML multi-page support for import and export of annotations via file or memory
  • PDF annotation import and export using XFDF via file or memory
  • Use with PDF Xpress™ to annotate PDF files
  • Note Tool
  • Block Hightlight Tool
  • Tooltip text support for individual annotations
  • Custom cursors
  • New arrowheads
  • Improved autosizing
  • Improved unicode support for annotations

Primary Features Include:

  • Fully-programmable annotation support
  • Add annotation and redaction capability to applications
  • Standard annotation objects include ruler, freehand, text, rectangle, ellipse, polygon, line, polyline, image and rubber-stamp
  • Create, display, save, restore, and password-protect annotations in independent layers
  • Brand annotations into images
  • Print annotations with the image
  • Add, delete, query, and manipulate annotation elements programmatically
  • Read and write the Wang/Kodak TIFF annotation format, and store all annotations in either TIFF files or in external files
  • Unicode (double-byte) characters are supported for languages with extended character sets
  • Supports opaque, translucent, and fully transparent backgrounds for notations
  • Supports opaque and translucent notations, useful for water-marking
  • Multiple layer support
  • .ANN annotation file format support
  • Lock and unlock annotation data to the control rather than the image, enabling navigation of medical images (and others) without moving the annotations, such as patient name and ID.

ImagXpress v9 Product Family includes the following Components:

  • ImagXpress v9 - image compression, decompression, viewing, and processing
  • NotatateXpress v9 - image annotation support
  • ThumbnailXpress v2 - thumbnail image support
  • TwainPRO v5 - TWAIN image acquisition support
  • PrintPRO v4 - image printing support

Additional Pegasus Imaging Components: Additional components are available for purchase separately, and integrate easily with to provide a comprehensive imaging solution:

  • PDFXpress™ – PDF creation, viewing, and annotating
  • OCRXpress™ – full page OCR
  • Barcode Xpress™ – recognize barcodes
  • ScanFix Xpress™ – advanced image cleanup
  • FormFix™ – form ID, dropout, and OMR
  • SmartZone™ ICR / OCR – character recognition
See Also

Pegasus Imaging Corporation | Getting Support and Samples | Operating Requirements

© 1997 - 2008, Pegasus Imaging Corporation, All Rights Reserved.


Getting Support and Samples

Benefits of Registering your Development Kit Purchase

Purchasers of development kits need to register with Pegasus in order to be notified of updates and receive support now or in the future. Registration is automatic when purchased directly from the Pegasus web site. If purchased through a Pegasus re-seller, please register your purchase by filling out the form at PegasusImaging.com/Registration.htm.

Vehicles for Support

Samples

Samples are available in either the trial or the registered, paid license edition. Downloading NotateXpress installs a common sample folder in your Program Files directory: Pegasus Imaging\NotateXpress\V8.0\Samples.

Samples are included in the downloaded installation.

The product installation program installs a common sample folder accessible via the Start Menu.

Samples for the .NET framework:

  • Microsoft VisualBasic.Net
  • Microsoft C#

Access the samples

  • Through the Windows Start menu: Start | Programs | Pegasus Imaging | NotateXpress| Samples.
  • Sample image files install in your Program Files directory: Pegasus Imaging\Common\Images.

Sample Newsgroups

Customers create samples of great benefit to other developers, so we created a Sample Code Newsgroup. This is a newsgroup for our customers and potential customers. They post and receive sample code from our development team and other developers to expedite their development. Go online at:
http://www.PegasusImaging.com/samplecode.htm

Web Support

Visit the Pegasus Imaging web site frequently asked questions page (PegasusImaging.com/faq.htm) for the fastest answers to common questions. The web site also provides other support options that are accessible at PegasusImaging.com/supportagree.htm.

E-mail Support

Both pre-sale and post-sale e-mail support is offered free of charge. Questions are answered on a First-Come-First-Served basis. Support@JPG.com responds instantly to e-mail received with a helpful set of locations to find additional information on Pegasus products including FAQ's, sample code, newsgroup locations and other current information pertaining to the use of the products. The support request is then added to the queue of outstanding requests. The goal of the support team to respond to each e-mail within 1 business day.

The sales team is always available as a backup to the support team. If you feel you have an urgent support or sales issue please contact Sales@JPG.com. They will assist you promptly.

Newsgroup Support

The Publicly accessible NNTP news groups located at News.PegasusImaging.com are available for each of the controls as well as advanced imaging technology and a sample code group. We expect that the development community will freely access and search these newsgroups to find common questions and answers regarding specific uses of the controls.

On-Demand Phone Support

On-demand priority phone support can be purchased in 15 minute increments with a credit card via the Pegasus Imaging Corporation web site Support, General Info page. If you decide to purchase "on-demand" phone support, instructions will immediately be e-mailed upon receipt of your purchase.

Additionally, Pegasus offers three support plans for those customers whose commercial products or projects are sensitive or critical in nature, where immediate response and 'latest release' code are important.

1. Chariot Support

All Pegasus Imaging customers are given the opportunity to purchase a Chariot Support agreement. This is a maintenance and upgrade agreement that entitles customers to priority e-mail service, direct phone support from the support and development staff and free product upgrades for the covered products. Since upgrades are included for Chariot customers at no additional charge, Chariot customers can frequently save money, plus obtain the benefits of phone and expedited support. Pegasus Imaging reserves the right to change the terms of this service at any renewal period. Contact Sales via the web at www.PegasusImaging.com/contactform.htm for more information.

2. Galleon Support

Customers are given the opportunity to purchase Galleon Support for Pegasus Imaging products that are applications and for products that require runtime licensing. Galleon Support includes licensing of product upgrades for deployed installations at no additional license fee cost.Pegasus Imaging reserves the right to change the terms of this service at any renewal period. Contact Sales via the web at www.PegasusImaging.com/contactform.htm for more information.

3. Atlas Support

All Pegasus Imaging Prizm Viewer and ScanFix Application customers are given the opportunity to purchase an Atlas Support agreement on currently supported products. This is an agreement that entitles customers to priority e-mail service and direct phone support from the support and development staff. It differs from Chariot Support in that it does not include version upgrades free of charge. Pegasus Imaging reserves the right to change the terms of this service at any renewal period. Contact Sales via the web at www.PegasusImaging.com/contactform.htm for more information.

To determine if you have the latest version of a Pegasus Imaging development toolkit, please download the PegConnect utility program. Please note that a Help File for each product may be found on the Start bar under Pegasus or in C:\Windows\Help.

For the latest and most up-to-date support information, access PegasusImaging.com/contact.htm


Pegasus Imaging Corporation

Pegasus Imaging is uniquely positioned to serve as your leading imaging technology supplier. A full suite of document imaging toolkits, forms processing technology, medical image compression SDKs, photo editing and compression libraries, browser-based image viewers, and video codecs provide advanced technology designed to enhance imaging software solutions. Fully functional trial downloads and customer-acclaimed support allow you to be certain your requirements will be met before purchase. Work with the best. Choose Pegasus Imaging for all your imaging needs.

Visit www.pegasusimaging.com for full product descriptions, FAQ's, downloads, demos, and contact information.

Pegasus Imaging

4001 North Riverside Drive

Tampa, FL 33603

Sales: 813-875-7575

Fax: 813-875-7705

Copyrights & Trademarks

Pegasus and the Pegasus Horse Logo are registered marks (®) of Pegasus Imaging Corporation.

Barcode Xpress, CapturePRO, FilePrinter, FormAssist, FormDirector, FormSuite, ISIS Xpress, The JPEG Wizard, MedXpress, NotateXpress, OCR Xpress, PDF Xpress, PICTools, ePIC, PICVideo, PrintPRO, SmartScan Xpress, SmartZone, ThumbnailXpress, and TwainPRO are trademarks (™) of Pegasus Imaging Corporation.

ImagXpress, FormFix, ScanFix, Prizm, ColorDrop, ColorEnhance, ColorFind, ColorForms, CompressDirector, Digital Mark Recognition (DMR), Image Detergent, ViewDirector and Virtual Scoring Center (VSC) by assignment are trademarks (™) or registered trademarks (®) of Pegasus Imaging Corporation.

Pegasus Imaging and/or its agents use these marks and brand names in connection with its goods and/or services, in the United States and other countries. Information in this document is subject to change without notice. No part of this document may be reproduced or transmitted in any form or by any means, electronic or mechanical, for any purpose, without the express written permission of Pegasus Imaging Corporation.

Microsoft, Microsoft.NET, Visual Basic, Visual Studio and Visual Studio.NET are trademarks of Microsoft Corporation in the USA and/or other countries. All other product and brand names are the property of their respective owners.

See Also

What is NotateXpress


Operating Requirements

NotateXpress Operating Requirements

NotateXpress runs on 32-bit Microsoft Windows operating systems: Vista, 2000 Professional and Server, XP Home and Professional, Server 2003, and Windows Server 2008. It works with 32-bit Windows versions running on 32 and 64-bit processors.

It runs in 32-bit executables running under 64-bit Windows 2000 Server, 2003 Server and Windows Server 2008.

Threading

Pegasus considers thread-safe to be when an application using this component can use multiple controls running in the same process, where they don't interfere with each other. The thread creating the control owns the control and is the only thread that can interact with it.

Development environment

Microsoft .NET Framework 2.0, 3.0, 3.5

Microsoft Visual Studio 2005

Microsoft Visual Studio 2008

Borland Delphi 8

Borland Delphi 2005

Borland Delphi 2006


Installing on a Development Machine

To Install NotateXpress™ Component

Run the downloaded setup program which installs the development kit on your development machine.

The downloaded development kit includes code samples for supported platforms. Samples are available through the Start|Programs|Pegasus Imaging|NotateXpress menu.

By default this will register trial licensing which allows you to develop applications but not to distribute them. The trial license allows testing of all the functions and features.

Please see the topic 'Distributing with Your .NET Application' to understand the limits and details to converting licensing editions.
In order to distribute your finished application you must purchase and install a fully paid license from Pegasus Imaging Corporation. The paid licenses override trial licenses.

To Use NotateXpress Help Files

Stand-alone Help file "PegasusImaging.WinForms.NotateXpress9.chm"

Access the NotateXpress stand-alone help through the Windows Start menu: Start | Programs | Pegasus Imaging | NotateXpress

The stand-alone complied Help chm file is created with MS Help system version 1. To view Help 1 files, you must have:

  • Windows 2000 (to view the file via the Windows HTML Help Viewer)
  • Internet Explorer 4 or higher
  • MS HTML Help Viewer

From within your Visual Studio Development Environment, compiled collection help file "PegasusImaging.WinForms.NotateXpress9.hxs"

Help 2 collection files install into Visual Studio.NET (VS). To view Help 2 files, you must have:

  • Windows 2000 or higher
  • Internet Explorer 6 or higher
  • Visual Studio .NET 2002 or higher
  • MS Help version 2

When NotateXpress installs, if the system installation requirements for Help 2 files are met, the Help 2 file is included on the Start shortcut menu. If the installation requirements for Help 2 files are not met, then the Help 1 file installs on the Start shortcut.

Plugging NotateXpress Help into Visual Studio

NotateXpress Help 2 files integrate within the Help system in Visual Studio .NET. To access NotateXpress Help within Visual Studio, do the following:

  • Ensure that the MSDN Library is installed in your Visual Studio environment. If it is not installed, re-install it from your VS.NET disc.
  • Ensure that MS Help Integration Kit is installed in your Visual Studio environment. If you do not have it installed:

1. Download the Help Integration kit from MSDN

2. Close Visual Studio.

  • Re-open Visual Studio, select the Help Menu and the Contents submenu. Verify Help files for Pegasus Imaging controls are listed.

If Pegasus Help is not listed:

  1. Search for "VSCC" in Visual Studio Help, leaving the "Filtered by:" list box blank. Select the "Visual Studio .NET Combined Help Collection Manager" topic.
  2. Select the Help 2 collections available on your PC under the heading "Collections available for inclusion in VSCC."
  3. Take care when excluding Help collections from the default VSCC collection. These collections may be necessary to view required documentation. Instead, use the "Filtered by:" field on the Contents tab of the Help panel to focus searches on Pegasus Imaging topics. Leave the "Filtered by:" list box empty to view the entire Pegasus Imaging Help files.
  4. Select the Update VSCC button.
  5. Close all instances of Visual Studio and Microsoft Document Explorer. When you restart Visual Studio, the VSCC Help collection revises with your changes. (Note: this may take several minutes.)
  6. Check the Visual Studio Help/Contents tab again to see the Help collections available to you.
  • Select the NotateXpress Help file to view Help content.
See Also

Operating Requirements


Trial Mode

Default Installation

The default installation installs Trial Mode licensing. This allows you to test features and functions and develop applications but not distribute them. Installing ImagXpress® in trial mode provides you with access to all features and functionality of the ImagXpress product, including NotateXpress.

When using the trial version of NotateXpress, an evaluation dialog box displays periodically. Applications built with a trial license can only be run on a computer that has NotateXpress Licensing installed on it.

Changing Trial Mode Behavior

You have the flexibility to change the behavior of NotateXpress in evaluation mode as follows:

To facilitate server/service mode evaluations, you can choose to halt the component processing after 5 minutes in lieu of displaying an evaluation dialog box periodically. This is the TimeOut setting for the EvaluationMode property within ImagXpress.

See Also

License Agreement


Development Mode

NotateXpress™ does not maintain licensing separate from ImagXpress®. To suppress the ImagXpress evaluation dialog box and deploy your application, or attain technical support (beyond email), as well as future product updates and upgrade notifications, you must update from a trial version to a paid version of the ImagXpress development kit.

1. Purchase Development Kit(s)

To purchase licensing of the NotateXpress development kit, use one of the following options:

  • Purchase online at http://www.PegasusImaging.com/. Contact Sales@PegasusImaging.com.
  • Contact a Pegasus Imaging Corporation reseller.

When the development kit is purchased, we email a serial number & registration code to you. You need these codes to upgrade from trial to paid licensing.

2. Register the NotateXpress Product

NotateXpress is automatically licensed with ImagXpress. For more information on ImagXpress licensing, see ImagXpress or contact Sales@JPG.com, your product ownership is automatically registered.

To register products purchased through a reseller, use the form found at http://www.PegasusImaging.com/registration.htm.

If your registration information should change, visit http://www.PegasusImaging.com/contact.htm for forms to update registration information.

3. Update Your ImagXpress product version from trial to paid licensing

Updating your ImagXpress from trial to paid licensing will suppress the evaluation dialog box or timeout. This must be done for each licensed component within the ImagXpress toolkit that you are using (for example, ImagXpress or ThumbnailXpress). The email you receive when you purchase the product will include entries for each component.

To update components from trial to paid licensing

  • Enter your new license codes using one of the following options:
    • Enter licensing information (serial number, registration code and personal registration information) during component installation while downloading the latest release from www.PegasusImaging.com (the recommended approach).
    • Alternatively, licensing information (serial number, registration code and personal registration information) can be entered through the Visual Development Environment in response to the dialog display.
  • Rebuild any applications that used the components with trial licensing

To distribute ImagXpress (including NotateXpress) in an application, you must acquire runtime unlock codes (See Distributing with Your .NET Application).

See Also

Trial Mode | License Agreement | Getting Support and Samples


Runtime Licensing

Runtime & Deployment Licensing

All copyrights to Pegasus Imaging development kits and software are retained by Pegasus Imaging Corporation. ALL RIGHTS RESERVED. Your use of any of Pegasus Imaging software or run-times created with Pegasus Imaging software is allowed under license terms granted by Pegasus Imaging. It is the Licensee's responsibility to honor the terms of such license grants.

Locking Mechanism

ImagXpress® contains a locking mechanism that does not permit you to distribute applications created with evaluation versions of ImagXpress and NotateXpress. Prior to distributing an application that utilizes ImagXpress, you must purchase and enable run-time licensing. If the application will be delivered on the web, you must also purchase and enable web application licensing.

Obtaining Appropriate Licensing

The Licensee is required to purchase one copy of our development kit(s) for each developer in addition to obtaining the appropriate license agreement prior to deploying applications which contain Pegasus code.

Pegasus Imaging software applications and development tools are limited for use on a single CPU. Any runtimes or copies created must be granted by a direct license from Pegasus Imaging Corporation. These "end user" licenses provide the terms and limits of number and usage.

All prospective customers have every opportunity to evaluate Pegasus Imaging's products prior to purchasing. Product licensing is priced to cover what is considered to be normal (and even high) use. In addition, Pegasus Imaging fully supports and warrants its code and pricing reflects those costs as well. The larger and more valuable an application deployment is, the higher the support and warranty risk is for Pegasus.

Review the licensing categories, and select the one that matches your deployment. Special circumstances should be discussed with a Pegasus Imaging representative.

For more information on Runtime licensing, see the Pegasus Imaging website for more detailed information regarding Runtimes and Deployment Licensing.

See Also

Getting Support and Samples | Development Mode | License Agreement


License Agreement

Pegasus Imaging Corporation

SOFTWARE LICENSE AGREEMENT

GRANT OF LICENSE

This Pegasus Imaging Corporation, ("PEGASUS") Agreement ("License") permits Licensee ("LICENSEE") the right to use one copy of a properly registered Pegasus Development Toolkit ("TOOLKIT") for development purposes on any single computer, provided the TOOLKIT is in use on only one computer at any time. TOOLKIT is "in-use" on a computer when it loads into temporary memory (i.e., RAM) or installed into the permanent memory (i.e., hard disk, CD-ROM, or other storage device) of that computer.

REDISTRIBUTION OF THE TOOLKIT RUNTIMES

PEGASUS does NOT grant any runtime licenses with the TOOLKIT purchase, except by specific exemptions described on our licensing web pages. For Runtime Licensing information, please visit our web site ( http://www.PegasusImaging.com/licensing.htm), or contact our sales staff. Any rights to distribute TOOLKIT run times as part of the LICENSEE's software application or derivative works ("PRODUCT"), require you to acknowledge and uphold this License Agreement and agree to notify PEGASUS immediately of any changes in status or violations. In cases where PEGASUS grants the LICENSEE a right to use, reproduce, display or otherwise distribute or transfer copies of TOOLKIT run times, LICENSEE agrees and affirms the following:

a) LICENSEE is not using PEGASUS' name, logo, or trademarks to market PRODUCT without prior written approval of PEGASUS.

b) LICENSEE agrees to indemnify, hold harmless, and defend PEGASUS from and against any claims or lawsuits, including attorney's fees, that arise or result from the use or distribution of PRODUCT.

c) Only the TOOLKIT run times can be distributed. Distribution of the TOOLKIT development kit, documentation, source code, or the distribution unlock codes, is a violation of this agreement.

d) LICENSEE includes a statement substantially similar to the following within derivative work's documentation and about box: "This product contains portions of imaging code owned by Pegasus Imaging Corporation, Tampa, FL, (www.PegasusImaging.com). ALL RIGHTS RESERVED."

If ANY of the above terms are not applicable to LICENSEE's situation, or any of the above cannot be complied with, or LICENSEE needs modifications to this license, for any reason; then LICENSEE shall obtain an expanded direct license from PEGASUS for derivative works, (available by phone at: 813-875-7575, x321, by e-mail at: Sales@JPG.comor by fax at: 813-875-7705).

PEGASUS reserves the right to charge the LICENSEE up to ten times the normal license price for the use of each unlicensed copy of PRODUCT. The license granted herein and all of your rights to use or maintain possession of TOOLKIT shall terminate immediately upon breach of any material provisions of this Agreement.

This license grants rights to LICENSEE for only the PEGASUS code (TOOLKIT) mentioned above and does not convey any other rights of use or distribution to PEGASUS technology.

COPYRIGHT

The Software is owned by PEGASUS or Pegasus Imaging Corporation and is protected by United States copyright laws and international treaty provisions. LICENSEE may not remove or alter the copyright notice from any copy of the Software or any copy of the written materials, accompanying the Software.

OTHER RESTRICTIONS

This PEGASUS License Agreement is LICENSEE's proof of license to exercise the rights granted herein and must be retained by LICENSEE. LICENSEE may not rent, lease or transfer TOOLKIT or parts thereof. LICENSEE may not reverse engineer, decompile or disassemble TOOLKIT.

NO WARRANTY

ANY USE BY LICENSEE OF THE SOFTWARE IS AT THE LICENSEE'S OWN RISK. THE SOFTWARE IS PROVIDED FOR USE ONLY WITH WINDOWS PRODUCTS AND RELATED APPLICATION SOFTWARE AND/OR HARDWARE PRODUCTS. THE SOFTWARE IS PROVIDED FOR USE "AS IS" WITHOUT WARRANTY OF ANY KIND. TO THE MAXIMUM EXTENT PERMITTED BY LAW, PEGASUS DISCLAIMS ALL WARRANTIES OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, WITHOUT LIMITATION, IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. PEGASUS IS NOT OBLIGATED TO PROVIDE ANY UPDATES TO THE SOFTWARE.

NO LIABILITY FOR CONSEQUENTIAL DAMAGES

In no event shall PEGASUS be liable for any damages whatsoever (including, without limitation, incidental, direct, indirect and consequential damages, damages for loss of business profits, business interruption, loss of business information, or other pecuniary loss) arising out of the use or inability to use this PEGASUS product, even if PEGASUS has been advised of the possibility of such damages. Because some states/countries do not allow the exclusion or limitation of liability for consequential or incidental damages, the above limitation may not apply to LICENSEE.

INDEMNIFICATION BY LICENSEE

If LICENSEE distributes TOOLKIT in violation of this Agreement, LICENSEE agrees to indemnify, hold harmless and defend PEGASUS and its suppliers from and against any claims or lawsuits, including attorney's fees that arise or result from the use or distribution of TOOLKIT in violation of this Agreement.

This Agreement is governed by the laws of the State of Florida. The program and data contained in this TOOLKIT Product are provided with Restricted Rights. Use, duplication, or disclosure by the U.S. Government is subject to restrictions as set forth in FAR 52.227-14 (Alternate III) or subparagraph (c)(1)(II) of the rights in technical data and computer software clause at 252.227-7013. Manufacturer is Pegasus Imaging Corporation, 4001 Riverside Drive, Tampa, FL, 33603 .

For questions concerning this Agreement, or to contact PEGASUS for any reason, please contact Pegasus Imaging Corporation by phone 1-813-875-7575 x321 or send an e-mail to Sales@JPG.com.


Verify You Are Using the Latest Service Pack

Service pack updates will not overwrite paid licensing. Your paid licensing will continue to work and you will not be required to re-enter your purchased registration codes. Service pack updates do not include any changes that could "break" previously developed and/or deployed code.

Verify Latest Development Components

To verify you are using the latest version of a Pegasus Imaging Development Component or Components, please use the PegConnect utility program. Please note that a Help File for each product may be found on the Start Bar under Pegasus, or in C:\Windows\Help.

PegConnect is installed by all component product installers and is accessible through the Windows Start menu:

Start | Programs | Pegasus Imaging | Common | Utilities

PegConnect Allows You To:

  1. Check with Pegasus Imaging via online connection and verify that the installed version of the component includes all the most recent updates
  2. Update to the latest version automatically with your permission
  3. Determine if a control is registered or unregistered on the machine
  4. Easily change the registration status from registered to non-registered, or non-registered to registered

Alternatively, you can see the currently released product build numbers at www.PegasusImaging.com/latestbuilds.htm.

If you require further assistance or have questions or comments, please see the topic on Getting Support for more detailed information.

See Also

Getting Support and Samples | License Agreement


Distributing with Your .NET Application

Check for Proper Licensing and Unlock Codes

Applications that utilize NotateXpress™ must license ImagXPress®. ImagXpress contains a locking mechanism that does not permit you to distribute applications created with evaluation versions of ImagXpress. Prior to distributing an application that utilizes ImagXpress, you must purchase and enable run-time licensing. If the application will be delivered on the web, you must also enable web application licensing.

DLL Files to Distribute

Distribute the appropriate assembly DLL files with applications using the NotateXpress.

  • PegasusImaging.WinForms.ImagXpress9.dll — ImagXpress .NET Windows Forms Control - Needed for image viewing, and required for annotating using NotateXpress.
  • PegasusImaging.WinForms.NotateXpress9.dll — NotateXpress .NET Windows Forms Control
See Also

Trial Mode | Runtime Licensing | Verify You Are Using the Latest Service Pack


Definitions, Acronyms and Abbreviations

Pegasus Imaging Definitions

ANN Legacy Annotation File Format: The .ANN file format is a proprietary format of TMSSequoia now owned by Pegasus. This support is important because it offers customers who already utilize the .ANN file format a clear upgrade path to ImagXpress. NotateXpress contains the ability to read and write the .ANN file format from file or buffer. NotateXpress converts annotations from .ANN to the corresponding NotateXpress type.

NotateXpress XML (NXXML): format for saving and restoring annotations in an open format. This format supports single and multiple page annotations.

PIC: Pegasus Imaging Corporation

Thread-safe: an application using this component can use multiple controls running in the same process, where they don't interfere with each other. The thread creating the control owns the control and is the only thread that can interact with it.

Industry Terms:

Bates Stamping: Bates Stamping is used in the legal and business fields to sequentially number or date/time mark images or documents as they are scanned or processed. Bates Stamping can be used to mark and identify images with copyrights by putting a company name, logo and/or legal copyright on them. This process provides identification, protection, and auto-increment numbering of the images.

Bitonal: 1 bit per pixel black and white image.

Binarize: the process of creating a bitonal image from a color or grayscale image.

BPP: Bits Per Pixel

Electronic Document: a document that has been scanned, or was originally created on a computer.

PDF: the standard PDF format that contains text and images. The appearance may differ slightly from the original image.

Unicode: a character set that can support a wide range of international characters. Unicode requires 16-bits to encode a character, unlike ASCII, which requires only 8 but supports only a small subset of characters beyond latin.

UI (User Interface): the controls or API provided for user interaction with an application or component.

XFDF (XML Forms Data Format): XFDF is an XML-based file format for representing form data and annotations that are contained in a PDF form. NotateXpress supports a variety of XFDF technologies. See the XFDF topic for more information.

XML (Extensible Markup Language): is a general-purpose specification for creating custom markup languages. It allows users to define their own elements. Its primary purpose is to facilitate the sharing of structured data across different information systems, particularly via the Internet, and it is used both to encode documents and to serialize data.


Object Overview

NotateXpress encapsulates powerful annotation capabilities within a set of classes, described below:

NotateXpress Class

NotateXpress is a windowless control that provides annotation capability to an ImagXpress client. In order to annotate an image being viewed with ImagXpress, the application must declare a NotateXpress object. When the ClientWindow property is set, the NotateXpress object is associated with a client ImageXView object to annotate.

The properties and methods within the NotateXpress class also enable the application programmer to specify global annotation behaviors, such as definition of the toolbar menus, cursors and icons to be displayed, and annotation loading and saving options.

Each NotateXpress object has an associated collection of Layers, on which annotations are placed.

Layer Class

NotateXpress maintains annotations on layers. Layers act like transparent overlays to the image, and can be used to separate annotations. For example, a separate annotation layer could be established for each different end-user (e.g. legal department comments vs. marketing department comments on a proposal), or for each different function (e.g. plumbing notes vs. wiring notes on a house blueprint). Layers can be viewed simultaneously, or alone. (For example, view only legal department comment layer, or view legal department and marketing department comment layers). A layer must exist before annotations can be created. Each annotation (or element) that is created must reside on a layer, and cannot reside on more than one layer.

The LayerCollection and Layer classes enable the application programmer to access and manage the layers on which annotations are stored. The LayerCollection methods are used to load annotations from file or variant and save annotations to file or variant.

Each layer has an associated collection of elements and groups.

Element Class

Annotations (also called elements) are textual or graphical notations that can be attached to an image. Annotations can be viewed with the image, but are not part of the image. (The Brand method can be used to make the annotation a permanent part of the image being viewed if desired.)

The ElementCollection and Element classes enable the application programmer to access and manage the annotations (elements) on a layer.

Group Class

Within a layer, elements may be grouped. Grouping annotation elements lets you manipulate these items together. An element on a layer can be associated with only one group at any time, or may be associated with no group.

The GroupCollection and Group classes enable the application program to access and manage the groups on a layer.

Toolbar Class

The NotateXpress toolbar contains a set of annotation tools, enabling the application end user to annotate the image. An annotation element is created by the application end user when a tool is selected in the toolbar and applied to the viewed image.

Each tool within the toolbar has a menu, which enables the application end-user to specify properties of the tool. For example, the application end-user may use the tool’s menu to specify that the line color of the rectangle tool should be blue. Then each time the tool is selected and applied to the image, a blue rectangle will be drawn.

Attributes of the NotateXpress toolbar and tools can be set globally to apply on all layers, or they can be set on a specific layer.

When a tool attribute is specified both globally and locally to a specific layer, the local (layer) value has precedence.

The Toolbar class defines the global defaults for the toolbars on each layer.


Connect to ImagXpress Client

NotateXpress is a windowless control that provides annotation capability to an ImagXpress viewer. Each NotateXpress control can have only one client ImageXView component. The Client ImagXpress control may use multiple image buffers, however only one is being viewed at a time. NotateXpress deals only with the annotations of the image currently being viewed.

To connect a NotateXpress object to an ImagXpress object, set the NotateXpress.ClientWindow property to the window handle of the ImagXpress View Window to which you wish to add annotation capability.

C# Example:

NotateXpress1.ClientWindow = ImageXView1.Handle;

See Also

Configure Toolbars | Define Cursors | Specifying End-User Interaction Mode | Debug and Troubleshooting | Configure Menus | Specify Text Editor


Synchronize Multiple NotateXpress Controls

Each NotateXpress component can have only one ImageXView client component. However, an application may have multiple ImageXView components, each with an associated NotateXpress component. If multiple ImageXView components are pointing to the same image (ImageX object), the user may need a means to ensure that the annotation data in all the associated NotateXpress components is the same.

When multiple ImageXView objects are pointed to the same ImageX image, the ForceAllUpdate method synchronizes all NotateXpress components to the current NotateXpress's data.


Retrieve annotations stored in a TIFF file

When loading a TIFF file into ImagXpress, the annotations stored in the TIFF file can be automatically loaded into NotateXpress.

Prior to loading an image, set the ImagXpressLoad property to establish whether annotations are loaded from a TIFF file when the TIFF file containing annotations is loaded by ImagXpress. Call the SetLoadOptions method to set the load options, including the desired annotation format (Wang/Imaging for Windows compatible format or NotateXpress format) to be retrieved from the TIFF file.

Once the image is loaded using ImagXpress (ImageX object), the annotations are available in the NotateXpress Layers collection.


Retrieve annotations stored in a PDF file

PDF Xpress v2 may be used to retrieve annotations stored in a PDF file, and save them to an xfdf file, which is read by NotateXpress v9. The annotations are then available within NotateXpress to be viewed or modified. Annotations that are created or modified during the NotateXpress annotation session can be stored by NotateXpress to xfdf, and saved to the pdf file using PDF Xpress v2.


Retrieve annotations from .nxp file or memory

Specify Load Options

Prior to loading the annotations, first specify LoadOptions to provide specific loading instructions. Set the AnnType to NotateXpress to retrieve annotations from a .nxp file.

Retrieve from a Disk File

Use the LayerCollection.FromFile method to retrieve the layer collection from an annotation file:

Retrieve from a Byte Array

Use the LayerCollection.FromByteArray to save annotations from a byte array to a specified layer:

Retrieve from a Memory Stream

Use the LayerCollection.FromMemoryStream to retrieve annotations from a memory stream:

Retrieve from a Layer Collection

A layer collection can also be copied from another layer collection:

Retrieve Password Protected Layers

When an application end user opens an annotation file that includes encrypted layers, a NotateXpress.RequestLayerPassword event invokes to request the password for each encrypted layer. The user supplies a password through an application defined dialog. If the correct password is supplied by the application end-user, the layer decrypts and is available for viewing. If an incorrect or null password is supplied, the layer discards from memory (the layer still exists in the file, but may be subsequently overwritten).


Retrieve annotations from xfdf

Annotations in an xfdf file or memory are loaded using the same methods as those used for loading NotateXpress annotation data from file or memory:

Retrieve Annotations from XFDF File:

LoadOptions can be used, if desired, to provide specific instructions for loading the annotations.

  • Set the AnnType to Xfdf, to indicate that NotateXpress xml annotations are being retrieved.

Use the LayerCollection. FromFile method to retrieve the layer collection from an annotation file. If the xfdf is a multi-page file, set the PageNumber property to specify from which page annotations should be loaded. Attempting to load a page that does not exist will cause a PageNotFound error.

Retrieve Annotations from XFDF via Memory

LoadOptions can be used, if desired, to provide specific instructions for loading the annotations.

  • Set the AnnType to Xfdf, to indicate that NotateXpress xml annotations are being retrieved.

Use the LayerCollection.FromByteArray to save annotations from a byte array to a specified layer, or

use the LayerCollection.FromMemoryStream to retrieve annotations from a memory stream.

Translation of XFDF Supported Annotations to NotateXpress Annotations

Many of the annotations that can be expressed in an xfdf file have a direct corresponding annotation within NotateXpress. These annotations are imported without modification:

XFDF Annotation | NotateXpress Annotation
Circle | Ellipse
Square | Rectangle
Polygon | Polygon
Line | Line
Ink | Freehand
Highlight | BlockHighlight
FreeText | Text
Text | Note

The following xfdf supported annotations do not have a direct equivalent within NotateXpress. These are translated to NotateXpress as follows:

XFDF Annotation | NotateXpress Annotation | Translation / Modification
Stamp

Stamp

Image

The XFDF stamps that are available by default in Acrobat are converted to NotateXpress Stamp annotations that contain the annotation text. The stamp data is stored by NotateXpress so that if these stamps are written back to XFDF, no stamp data is lost.

Uncompressed bitmap XFDF stamps (including all stamps originally written from NotateXpress to XFDF) are converted to NotateXpress images and are displayed by NotateXpress.

All other XFDF stamps are converted to NotateXpress stamps with the text "?". The stamp data is stored by NotateXpress so that if these stamps are written back to XFDF, no stamp data is lost.

Underline

Strikeout

Squiggly

Caret

 Line Squiggly annotation lines are displayed as dotted lines, and caret annotation lines are displayed as arrows. The type of the line is stored by NotateXpress so that if the annotation is written back to XFDF it is written with the same type. For example, if an underline annotation is loaded and then saved to an XFDF file, it will be saved as an XFDF underline annotation.
Popup | Note | An XFDF popup annotation is loaded as a NotateXpress Note annotation grouped with the annotation that contains the popup.

Translation of XFDF Annotation Position to NotateXpress

Use the MappingInput event to access the original XFDF X and Y values and the new NotateXpress mapped X and Y values for an annotation. You can set the new mapped values to modify the position of the loaded annotation.

Translation of XFDF Supported Annotation Attributes to NotateXpress

The following xfdf supported annotation attributes do not have a direct equivalent within NotateXpress. These attributes are translated to NotateXpress as follows:

XFDF Annotation

Attribute

NotateXpress Annotation

Attribute

 Translation / Modification
Title

ToolTipText

Name

ItemName
Flags

Visible

Locked

If the XFDF flag is set to "noview" or "hidden", the NotateXpress Visible annotation attribute is set to "false"

If the XFDF flag is set to "locked" or "readonly", the NotateXpress Locked annotation attribute will be set to true

Width | PenWidth | The XFDF width attribute is half that of the NotateXpress PenWidth. Therefore, an XFDF width of 3.5 will be loaded into NotateXpress as a PenWidth of 7.
Opacity | Opacity | An XDFDF annotation with an opacity greater than 0.9 will be converted to NotateXpress as opaque. An XFDF annotation with an opacity less than 0.1 will be converted as transparent. An XFDF annotation with an opacity between 0.1 and 0.9 will be converted as translucent.

Annotations Not Supported by NotateXpress

All other xfdf annotation types will be dropped by NotateXpress. A Dropped event will be fired to enable the application to access and store the data associated with unsupported annotations.


Retrieve annotations from NX xml

Annotations in a NotateXpress xml file or variant are loaded using the same methods as those used for loading .nxp annotation data from file or variant:

Retrieve Annotations from NotateXpress XML File

LoadOptions can be used, if desired, to provide specific instructions for loading the annotations.

  • Set the AnnType to NotateXpressXml, to indicate that NotateXpress xml annotations are being retrieved.
  • Set LoadUserData to indicate whether or not unknown (user specified) attributes should be read when loading the NotateXpress xml.
  • Set UnicodeMode to indicate whether or not annotations load in Unicode.

Call the FromFile method to load the NotateXpress xml file into the NotateXpress layer collection. If the NotateXpress xml file is a multi-page file, set the PageNumber property to specify from which page annotations should be loaded. Attempting to load a page that does not exist will cause a PageNotFoundException.

Retrieve Annotations from NotateXpress XML via Byte Array

LoadOptions can be used, if desired, to provide specific instructions for loading the annotations.

  • Set the AnnType to NotateXpressXml, to indicate that NotateXpress xml annotations are being retrieved.
  • Set LoadUserData to indicate whether or not unknown (user specified) attributes should be read when loading the NotateXpress xml.
  • Set UnicodeMode to indicate whether or not annotations load in Unicode.

Call FromByteArray to save annotations from a byte array to a specified layer, or

Call FromMemoryStream to retrieve annotations from a memory stream.

Retrieve Password Protected Layers

Annotations loaded from a NotateXpress XML file may be password protected by layer. When annotations are loaded from a file or variant, the LayerRestored event is raised. Additionally, if the layer was saved with a password, the RequestLayerPassword event is raised. This provides a trigger for the application to provide the password, or display a dialog to the end user requesting the password. If the correct password is supplied during the RequestLayerPassword event, the layer is decrypted and loaded into NotateXpress.


Display Annotations

Paint

The AllowPaint property sets or returns whether to paint annotations (render to the display). Setting AllowPaint to False stops paint messages. The last set of annotations are left on the screen. If something forces them to change, the screen will go blank. This can be useful when you are loading a TIFF file that contains multiple layers and you only want to show one layer at a time.

The Update property gets and sets whether annotations paint (render to the display). Setting Update to False stops paint messages and blanks the annotations from the screen.

Scale and Map Annotations

The FontScaling property determines how a font is scaled relative to the image's vertical resolution dots per inch (dpi).

However, when ImagXpress is not attached to NotateXpress and you load an annotation file, NotateXpress cannot query ImagXpress for the image dimensions when mapping annotation coordinates. Use GetImageMappingDimensions and SetImageMappingDimensions methods to get and set a mapping width and height for this circumstance. Use these values only when ImagXpress is not attached to NotateXpress.


Configure Toolbars

The NotateXpress toolbar contains annotation tools, enabling the application end user to annotate the image. An annotation is created by the application end user when a tool is selected in the toolbar and applied to the viewed image.

Co-existing with the ImagXpress Toolbar

It is common to have NotateXpress' toolbar visible while ImagXpress' toolbar is also visible. If ImagXpress' toolbar is currently set to a tool other than the pointer, the NotateXpress toolbar tools will not activate.

Inform the user to set the ImagXpress tool to the pointer to be able to use the NotateXpress toolbar.

Configuring the NotateXpress Toolbar

Each annotation layer has its own toolbar, with attributes that define that toolbar's appearance and behavior.

When a new layer is created, the NotateXpress.ToolbarDefaults specify the attributes of the toolbar created on that new layer.

To manage the toolbar attributes on an individual existing layer, access the Toolbar associated with that Layer. Each tool within the layer's toolbar has a set of associated attributes that define the characteristics of the annotations it creates when applied to the viewed image. These tool attributes are specified by setting the ToolbarDefaults properties on the layer's toolbar.

See Also

Connect to ImagXpress Client | Define Cursors | Specifying End-User Interaction Mode | Debug and Troubleshooting | Configure Menus | Specify Text Editor


Configure Menus

NotateXpress provides the capability to define a menu for each tool on the toolbar. The menu is invoked when the application end-user clicks the right mouse button over a tool in the toolbar, and provides the end-user with the ability to modify tool settings. When the user right clicks on a toolbar menu, a A NotateXpress.MenuSelect event raises.

The menu for each tool is defined globally, using the "Menu" methods in the NotateXpress class.

See Also

Connect to ImagXpress Client | Configure Toolbars | Define Cursors | Specifying End-User Interaction Mode | Debug and Troubleshooting | Specify Text Editor


Define Cursors

Use NotateXpress Built-In Cursors

By default, NotateXpress applies a tool specific cursor when creating, moving, and selecting annotations of that tool type. If desired, these built-in cursors can be turned off, and a system default cursor applied instead. Call the SetUseCursorType and GetUseCursorType methods to specify whether a system default cursor should be used instead of the tool-specific cursors while creating, moving, and selecting annotations.

Specify Custom Cursors

The user may specify custom cursors to be used instead. By calling SetUseCustomCursorType and GetUseCustomCursorType methods, a custom cursor can be specified for each tool and each action (creating, selecting, moving).

C# Example:

// define custom cursor

private Cursor mynewcursor;
mynewcursor = new Cursor("c:\\images\\test.cur");
NotateXpress1.SetUseCustomCursorType(CursorSelection.Creating, AnnotationTool.BlockHighlightTool, mynewcursor);

See Also

Connect to ImagXpress Client | Configure Toolbars | Specifying End-User Interaction Mode | Debug and Troubleshooting | Configure Menus | Specify Text Editor


Specify Text Editor

Specify the editor that should be used by setting NotateXpress.MultilineEdit. If True, the standard windows multi-line edit control is used. If False, the NotateXpress internal text editor is used.

See Also

Connect to ImagXpress Client | Configure Toolbars | Define Cursors | Specifying End-User Interaction Mode | Debug and Troubleshooting | Configure Menus


Specifying End-User Interaction Mode

The NotateXpress.InteractMode property governs the interactive state of annotations:

  • In Interactive Mode, application end-users can interact with, but not edit, annotations. They cannot see the toolbar, annotation elements cannot be selected, and user interaction generates mouse click events: NotateXpress.MouseDown, NotateXpress.MouseMove, NotateXpress.MouseUp, NotateXpress.Click, NotateXpress.DoubleClick.
  • In Edit Mode, application end-users can edit annotations. The toolbar can be visible, users can create, select, resize, and move objects, and the events generated reflect these annotation actions (see Modify Elements through User Interaction, and Group Elements Through User Interaction).

See Also

Connect to ImagXpress Client | Configure Toolbars | Define Cursors | Debug and Troubleshooting | Configure Menus | Specify Text Editor


Creating, Selecting, and Modifying Annotations

NotateXpress provides annotation tools for creating and manipulating annotation objects. End-users select a tool from the NotateXpress toolbar, then apply the tool to the Client view using mouse or keyboard controls.

To enable the application end-user to annotate using NotateXpress, the application must ensure that:

  • NotateXpress has a valid Client
  • A layer has been created (CreateLayer)
  • The InteractMode property is set to Edit Mode.
  • The ToolbarActivated property is True.
  • The Toolbar.Visible property is True for each layer you wish to make accessible to end-users (default)

Create Annotations

New annotations are created by application end-users by:

  • Selecting a layer. A CurrentLayerChange event raises whenever a different layer is selected as the current layer.
  • Making selections on the toolbar menu to set the attributes of the tool . The new annotation will be created with these attributes.
  • Selecting a tool on the toolbar. A Toolbar event raises to alert the application that a tool has been selected.
If the Stamptool is selected, a Stamping event raises to provide an opportunity to change the stamp text or other attributes of the annotation before it is added to the layer.
  • Clicking on the layer to place the annotation on the layer. The annotation is painted (displayed on the user's monitor). An AnnotationAdded event raises to notify the application.
If the element is a rectangle, and the element's UserDraw attribute is True, the rectangle will not paint. Instead a UserDraw event raises to notify the application that the user needs to draw.

Select Annotations

Annotations are selected by application end-users by clicking on them. An AnnotationSelected event is raised to notify the application.

Deselect Annotations

Annotations are deselected by clicking in an area not occupied by an element. An AnnotationEndSelected event raises to notify the application.

Move Annotations

Annotations are moved or resized by application end-users by dragging the mouse to the desired size and location. An AnnotationMoved event raises to notify the application.

Modify Annotations

Annotations are modified by application end users by using the context menu. The ItemChanged event raises when an annotation element changes.

If text is being modified, a TextEditStart event and a TextEditEnd are also raised to notify the application.

Delete Annotations

Annotations are deleted by application end-users by using the context menu.

  • An AnnotationDeleted event raises to notify the application.

See Also

Group Annotations


Grouping Annotations

To enable application end-users to group annotation elements, the application program must set the AllowUserGrouping property to True. The AllowUserGrouping property sets or returns whether end users can create and destroy groups.

The default value of this property is False.

End user grouping actions are monitored by the application using events as follows:

Create a group

The end-user selects multiple annotations by clicking within the bounding rectangle of the annotation and holding down the shift key. The end-user presses Ctrl-G to create a new group which includes each of the selected annotations. The new groups's yoked property is automatically set to True, allowing immediate user manipulation of the group. The UserGroupCreated event is raised to notify the application that a new group has been created.

Select a group

The end-user selects a group by clicking within the bounding rectangle of a deselected group. A GroupSelected event is raised to notify the application.

Deselect a group

The end-user de-selects a group by clicking again outside the bounding rectangle of a selected group. A GroupDeselected event is raised.

Destroy a group

The end-user selects one or more groups to destroy. The end-user then presses Ctrl-U to destroy the selected group. The UserGroupDestroyed event is raised.

See Also

Creating, Selecting, and Modifying Annotations | Group Annotations


Create or Delete a Layer

NotateXpress maintains annotations on layers. Layers act like transparent overlays to the image, and can be used to separate annotations. For example, a separate annotation layer could be established for each different end-user (e.g. legal department comments vs. marketing department comments on a proposal), or for each different function (e.g. plumbing notes vs. wiring notes on a house blueprint). Layers can be viewed simultaneously, or alone. (For example, view only legal department comment layer, or view legal department and marketing department comment layers).

Create a New Layer

Each NotateXpress object has an associated layer collection, accessed via the Layers property. Use the LayerCollection methods to add a new layer (Add), or insert a layer at a specified index (Insert). Alternatively, the application can copy existing layer(s) using the CopyTo, Paste, and Copy methods.

Make sure that NotateXpress has an associated valid ImagXpress ClientWindow prior to creating a layer.

Delete (Remove) a Layer

A layer (and its associated annotations) can be deleted, or removed, from the NotateXpress object's layer collection by calling the LayerCollection.Remove method. Calling LayerCollection.Clear removes all layers and their associated annotations from the collection.


Create, Select, and Modify Annotations

Each layer has an associated collection of annotations (elements). Annotations are programmatically added, deleted, selected, and modified by calling methods in the Element and ElementCollection classes.

Create an Annotation

Annotations are created programmatically by creating an instance of the tool to be applied, setting the tool characteristics, then adding the annotation to the layer.

Prior to annotating, make sure that NotateXpress has a valid associated ImagXpress Client, and that a Layer has been created programmatically, or retrieved from annotation file.

C# Example:

// Define the characteristics of the text annotation to be added

PegasusImaging.WinForms.NotateXpress9.TextTool text = new PegasusImaging.WinForms.NotateXpress9.TextTool();

text.TextJustification = PegasusImaging.WinForms.NotateXpress9.TextJustification.Center;

text.Text = "NotateXpress";

text.BackColor = System.Drawing.Color.Red;

text.BoundingRectangle = rect;

text.PenWidth = 2;

text.BackStyle = PegasusImaging.WinForms.NotateXpress8.BackStyle.Translucent;

text.PenWidth = 2;

// Add a text annotation to the layer

layer.Elements.Add(text);

Bates Stamping with NotateXpress

Bates Stamping is used in the legal and business fields to sequentially number or date/time mark images or documents as they are scanned or processed. Bates Stamping can be used to mark and identify images with copyrights by putting a company name, logo and/or legal copyright on them. This process provides identification, protection, and auto-increment numbering of the images. Manual Bates Stamping used a stamp that incremented a sequential number each time it was pressed down on a document. Pegasus Imaging suggests using a NotateXpress stamp to automate this function. The developer needs to create a stamptool at a specific location on the document then set the text field with an appropriate string. Branding the stamp onto the document is considered optional.

Select, Modify, or Delete an Annotation

Once an annotation has been added to a layer, it is available to be selected, modified, or deleted as part of the layer's element collection.

Reorder Annotations

The Z-order of annotations on a layer can be modified using the Element and ElementCollection methods:

  • Nudge Up - The NudgeUp method moves the specified annotation object one level up (towards the front) in the painting order. Use this to display the moved element "in front of" or "on top of" other annotation objects that may overlap this one.
  • Nudge Down - The NudgeDn method moves the specified annotation object one level down (towards the back) in the painting order. Use this to display the moved element "behind" or "under" other annotation objects that may overlap this one.
  • Reverse - To reverse the visual z-order of all the annotations on the layer, call the Reverse method.
  • Send to Back - To send elements to the back of the display order, call SendToBack
  • Bring to Front - To bring elements to the front of the display order call BringToFront.


Group Annotations

Group Annotations

To group annotations on a layer programmatically, create a new group within the layer's group collection. Then add the annotation to the new group.

C# Example:

// create a new group on the layer

Layer layer = notateXpress1.Layers.Selected();

if(layer == null)

{

MessageBox.Show("A Layer must be selected before a Group operation can be performed");

return;

}

PegasusImaging.WinForms.NotateXpress9.Group group = new PegasusImaging.WinForms.NotateXpress9.Group();

layer.Groups.Add(group);

// add all selected annotations to the new group

Element element = layer.Elements.FirstSelected();

while(element != null)

{

if(element.Selected)

group.GroupElements.Add(element);

element = layer.Elements.NextSelected();

}

Move the Annotations in the Group

If the annotations in a group are yoked, they can be selected and moved or sized as a group. Selecting, moving, or sizing one annotation in the group automatically applies to all annotations in the group.

C# Example:

// ensure that the group is yoked

group.Yoked = true;

// move the group

Deleting an annotation in a yoked group, or modifying the attributes (e.g. color) of an annotation in a yoked group has no effect on the other annotations in the group.

UnGroup Annotations

To disassociate one or more annotations from the group, call the GroupElementCollection methods: Remove, RemoveAt, and Clear methods. The annotations that are removed from the group remain on the layer, but no longer are associated.

C# Example:

// remove selected annotations from the group

// these annotations remain on the layer, but are no longer associated with the group

Element element = layer.Elements.FirstSelected();

while(element != null)

{

if(element.Selected)

group.GroupElements.Remove(element);

element = layer.Elements.NextSelected();

}

See Also

Grouping Annotations | Creating, Selecting, and Modifying Annotations


Save Annotations as Part of the Image

Call the Layers.Brand method to 'brand' or draw the currently visible annotations directly into the client image. The existing annotations are not deleted.


Save Annotations as Tags in a TIFF file

To save annotations as tags in a TIFF file, enable annotation saving by ensuring that the ImagXpress.SaveOptions.Annotations.Save property is set to true and the NotateXpress.ImagXpressSave property is set to true. If either of these is not set, annotations will not be saved to the file.

Then specify the NotateXpress.SaveOptions to provide specific instructions for saving the annotations with the image. Only annotations of type ImagingForWindows (WANG) and NotateXpress can be saved as part of the TIFF file.

C# Example:

// When a TIFF file is saved by ImagXpress, the associated annotations should be saved with it

myImageX.SaveOptions.Annotations.Save = true;

notateXpress1.ImagXpressSave = true;

// Annotations should be saved as notateXpress tags in the TIFF file

notateXpress1.saveOptions.AnnType = AnnotationType.NotateXpress;

// Save the TIFF file with annotations

myImageX.Save(myTIFFfile, myIXSaveOptions);


Save Annotations to File, Array, or Stream

To save annotations to a file, array, or stream, first specify SaveOptions to provide specific instructions for saving the annotations.

Specifying Save Options

Prior to storing the annotations, first specify SaveOptions to provide specific saving instructions.

C# example:

// save all annotation layers

mysaveOptions.AllLayers = true;

// as NotateXpress annotations

mysaveOptions.AnnType = AnnotationType.NotateXpress;

// provide some information about the annotations

notateXpress1.Layers.Comments = "This file was saved today";

notateXpress1.Layers.Subject = "my annotations";

notateXpress1.Layers.Title = "One awesome annotation file";

Storing to a Disk File

Use the LayerCollection. SaveToFile method to save the layer collection to an annotation file:

C# example:

// store to a .nxp annotation file

notateXpress1.Layers.SaveToFile(myFileName, mysaveOptions);

Storing to a Byte Array

Use the LayerCollection. SaveToByteArray to save annotations to a byte array:

C# example:

// store to a byte array

mybytearray = notateXpress1.Layers.SaveToByteArray(mysaveOptions);

Storing to Memory Stream

Use the LayerCollection. SaveToMemoryStream to save annotations to a memory stream:

C# example:

// store to a byte array

mymemorystream = notateXpress1.Layers.SaveToMemoryStream(mysaveOptions);

Storing to a Layer Collection

A layer collection can also be copied to another layer collection as follows:

C# example:

//copy the layers from one notateXpress control to another

Notatexpress1.Layers = NotateXpress2.Layers;

See Also

Free Memory used by NotateXpress


Save Annotations to PDF

PDF Xpress v2 may be used to save annotations to a PDF file. First Use NotateXpress to save annotations to an xfdf file. Then use PDF Xpress v2 to read in the xfdf file and save the annotations to a PDF file.


Save annotations to xfdf

Annotations are stored to an xfdf file or memory using the same methods as those used for saving annotation data to a .nxp file or memory. Prior to storing the annotations, specify SaveOptions to provide specific saving instructions. Ensure that SaveOptions.AnnType is set to Xfdf.

Save Annotations To An XFDF File

Use the LayerCollection.SaveToFile method to save the layer collection to an annotation file. If the xfdf is a multi-page file, set the PageNumber property to specify to which page annotations should be saved. If the file exists, NotateXpress will replace the specified page's annotations with the annotations being saved. NotateXpress will add the annotations, if the page does not exist.

Save Annotations to XFDF Via Byte Array

Use the LayerCollection.SaveToByteArray to save annotations to a byte array.

Save Annotations to XFDF Via Memory Stream

Use the LayerCollection.SaveToMemoryStream to save annotations to a memory stream:

Translation of NotateXpress annotations to XFDF Supported Annotations

Many of the annotations that can be expressed in NotateXpress have a direct corresponding annotation within XFDF. These annotations are saved to XFDF without modification:

NotateXpress Annotation | XFDF Annotation
Ellipse | Ellipse
Rectangle | Rectangle
Polygon | Polygon
Line | Line
Freehand | Ink
BlockHighlight | Highlight
Text | FreeText
Note | Text

The following NotateXpress annotations do not have a direct equivalent within XFDF. These are translated to XFDF as follows:

NotateXpress Annotation | XFDF Annotation | Translation / Modification
Stamp | FreeText |
Image | Stamp |
Button | FreeText |
Ruler | Line |
Note | Popup | An annotation that is grouped with one Note annotation will be converted to an annotation containing an XFDF popup. This does not apply to an annotation that is converted to an XFDF text or XFDF freetext annotation, as these XFDF annotations do not support containing popup annotations.

Translation of NotateXpress Annotation Position to XFDF

Use the MappingOutput event to access the original NotateXpress X and Y values and the new XFDF mapped X and Y values for an annotation. You can set the new mapped values to modify the position of the saved annotation.

Translation of NotateXpress Supported Annotation Attributes to XFDF

The following NotateXpress supported annotation attributes do not have a direct equivalent within XFDF. These attributes are translated to XFDF as follows:

NotateXpress

Annotation

Attribute

XFDF

Annotation

Attribute

 Translation / Modification
ToolTipText

Title

ItemName

Name

Visible

Flags

The NotateXpress Visible annotation attribute is saved to the XFDF flags attribute as "noview".

Locked | Flags | The NotateXpress Locked annotation attribute is saved to the XFDF flags attribute as "locked".
PenWidth | Width | The NotateXpress penwidth attribute is twice that of the XFDF Width. Therefore, a NotateXpress PenWidth of 7 will be saved as an XFDF width of 3.5.
Opacity Opacity

A NotateXpress annotation with an opacity of opaque will be converted to an XFDF annotation with an opacity of 1.0.

A NotateXpress annotation with an opacity of transparent will be converted to an XFDF annotation with an opacity of 0.0.

A NotateXpress annotation with an opacity of translucent will be converted to an XFDF annotation with an opacity of 5.0.


Save annotations to NX xml

Annotations are stored to a NotateXpress xml file or memory using the same methods as those used for saving annotation data to a .nxp file or memory. First specify SaveOptions to provide specific instructions for saving the annotations. Ensure that SaveOptions.AnnType is set to NotateXpressXml. Also, specify whether unknown (user specified) attributes should be stored in the NX xml.

Save Annotations To a NotateXpressXml File:

Call the LayerCollection.SaveToFile method to save annotations to a NotateXpress xml file. If saving to a multipage NX xml annotation file, set the PageNumber property to specify which page to save the annotations to. If the file exists, NotateXpress will replace the specified page's annotations with the annotations being saved. NotateXpress will add the annotations, if the page does not exist.

Save Annotations to NotateXpressXml Via Byte Array:

Use the LayerCollection.SaveToByteArray to save annotations to a byte array.

Save Annotations to NotateXpressXml via Memory Stream

Use the LayerCollection.SaveToMemoryStream to save annotations to a memory stream.


Free Memory used by NotateXpress

The NotateXpress component implements the Dispose pattern which is defined by the IDisposable interface. Because the NotateXpress component encapsulates unmanaged resources and is non-windowed, the Dispose method must be called for each instance of the component, to allow the release of all resources. A recommended approach is to dispose NotateXpress components when their container is disposed. To do this, call the Dispose method from the container.

C# Example

// in all .NET Windows Forms applications, you will find a generated call to Dispose, which can be modified as follows

protected override void Dispose (bool disposing)

{

if (disposing)

{

if (components != NULL)

{

components.Dispose();

}

// added for NotateXpress

// The application developer is not required to call Dispose at this location.

// The developer can make the call to clean up these resources any time during the container's lifetime.

NotateXpress.Dispose();

}

base.Disposing(disposing);

}

In addition, any objects that are created dynamically at runtime (e.g. ElementCollection, GroupCollection, LayerCollection), must call their Dispose method to allow resources to be released when the object is no longer needed.

See Also

Save Annotations to File, Array, or Stream


Debug and Troubleshooting

Disconnect

It is important to disconnect NotateXpress™ from ImagXpress® before exiting the application, otherwise resource and memory leaks can result.

  • If you connected using the Client property, set the Client property to a null string.

  • If you connected with a call to SetClientWindow, call it again with null or, call InterfaceDisconnect.

Generate a Debug Log

To generate a debug log file, set Debug to true. The log file is kept at the location specified by DebugLogFile. Set the DebugErrorLevel to indicate the level of detail logged. Setting ErrorLevel to Development or Detailed offers more information than Production level.

See Also

Debug Property | DebugErrorLevel Property | DebugLogFile Property


See Also

PegasusImaging.WinForms.NotateXpress9 Assembly

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PegasusImaging.WinForms.NotateXpress9 Namespace

Inheritance Hierarchy

Classes

Class | Description
AnnotationAddedEventArgs | Contains data for NotateXpress.AnnotationAdded events.
AnnotationDeletedEventArgs | Contains event data for NotateXpress.AnnotationDeleted events.
AnnotationMovedEventArgs | Contains event data for AnnotationMoved events.
AnnotationSelectedEventArgs | Contains event data for AnnotationSelected events.
BaseToolbarDefaults | Base class for the Toolbar classes.
BlockHighlightTool | This class is used to create BlockHighlight annotations.
BlockHighlightToolbarDefaults | This class is used to create BlockHighlight annotations.
BrandingException | Exception class that is raise when branding errors occur.
BrandingSourceDibException | Exception class which is raised when there are errors that occur with branding the source DIB (Device Independent Bitmap).
ButtonTool | The ButtonTool is used to create button annotations, which behave and respond like form buttons.
ButtonToolbarDefaults | This class is used to create Button annotations.
ClickEventArgs | Raises when an annotation object is clicked in Interactive Mode.
ClipboardException | Exception class which is raised when there are errors with the clipboard.
ContextMenuEventArgs | Contains data for ContextMenu events.
CurrentLayerChangeEventArgs | Contains event data for NotateXpress.CurrentLayerChange events.
DoubleClickEventArgs | Contains event data for DoubleClick events in Interactive Mode.
DroppedEventArgs | Contains event data for Dropped events. This will be fired for unsupported XFDF annotations, such as sound and file attachment annotations
DuplicateItemException | Exception class which is raised when there are duplicate items.
DuplicateMenuIdException | Exception class which is raised when there are errors with duplicate menu IDs.
Element | This class defines attributes of NotateXpress element objects.
ElementCollection | The base class that manages selected elements in a collection.
EllipseTool | This class is used to create ellipse annotations.
EllipseToolbarDefaults | Implements the default toolbar values used to create Ellipse annotations.
FileOpenException | Exception class raised when there are errors opening files.
FileSecurityException | Exception class raised when the filename path or extension are not secure.
FileWriteException | Exception class raised when there are errors writing to files.
FreeHandTool | This class is used to create line annotations freely drawn by the user, which can have two or more points.
FreehandToolbarDefaults | This class implements the default toolbar values for the Freehand annotations.
GetLayerPasswordEventArgs | Arguments for RequestLayerPassword event
Group | This class defines attributes of a group of elements for annotation.
GroupCollection | This class manages groups in the collection.
GroupCreationException | Exception class which is raised when there are errors with groups.
GroupElementCollection | This class is used as a collection to manage elements in groups.
GroupSelectedEventArgs | Arguments for GroupSelected event
ImageTool | The ImageTool class is used to create image annotations, which display images.
ImageToolbarDefaults | The ImageToolDefaults class is the default class used to create Image annotations.
InvalidAnnotationFileException | Exception class raised when there are errors with the annotation files.
InvalidAttributeException | Exception class which is raised when there are errors with attributes.
InvalidColorTypeException | Exception class which is raised when there are errors with color types.
InvalidContextException | Exception class which is raised when there are errors with context.
InvalidContextIdException | Exception class which is raised when there are errors with context IDs.
InvalidCursorTypeException | Exception class which is raised when there are errors with cursor types.
InvalidErrorLevelException | This class implements exceptions for error levels.
InvalidFontException | Exception class which is raised when there are errors with fonts.
InvalidGroupException | Exception class which is raised when there are invalid groups.
InvalidHatchStyleException | Exception class which is raised when there are errors with hatch styles.
InvalidItemException | Exception class which is raised when there are errors with elements.
InvalidLayerException | Exception class which is raised when there are errors with layers.
InvalidModeException | Exception class which is raised when there are errors with modes.
InvalidParameterException | This class implements exceptions for invalid parameters.
InvalidPasswordException | Exception class which is raised when there are errors with passwords.
InvalidPointException | Exception class which is raised when there are invalid point errors.
InvalidTiffAnnTypeException | Exception class which is raised when there are TIFF annotation type errors.
InvalidToolException | Exception class raised when there is an error with a tool.
InvalidVariantException | Exception class which is raised when a variant is not allowed.
InvalidWangTypeException | Exception class which is raised when there are Wang type not allowed errors.
InvalidWindowHandleException | Exception class raised when a passed in window handle is not valid.
ItemChangedEventArgs | Arguments for ItemChanged event
ItemNotFoundException | Exception class which is raised when there are errors with elements not found.
Layer | The Layer class contains attributes for elements, groups and toolbars.
LayerCollection | The LayerCollection class manages layers.
LayerRestoredEventArgs | Arguments for LayerRestored event
LineTool | The LineTool class is used to create single-line annotations with 2 points.
LineToolbarDefaults | The TextTool is used to create Line annotations.
LoadOptions | This class provides options when loading in annotations.
MappingInputEventArgs | Contains event data for MappingInput events.
MappingOutputEventArgs | Contains event data for MappingOutput events.
MenuEventArgs | Arguments for MenuSelect event
MouseDownEventArgs | Arguments for RunmodeEvent event. Used for mouse events during interactive mode.
MouseMoveEventArgs | Arguments for RunmodeEvent event. Used for mouse events during interactive mode.
MouseUpEventArgs | Arguments for RunmodeEvent event. Used for mouse events during interactive mode.
NoCurrentLayerException | Exception class raised when there is an error with the current layer, or no current layer was created.
NoSelectionException | Exception class which is raised when there is a no found selection error.
NotateXpress | Summary description for NotateXpress.
NotateXpressException | Error class of exceptions raised or returned by the NotateXpress class.
NoteTool | This class implements objects used to create Note annotations, which can edit and display text when double clicked.
NoteToolbarDefaults | This class implements methods and properties used to create note annotations.
NotSupportedException | Exception class which is raised when an object is not supported and an error is returned by NotateXpress properties and methods.
ObjectNotConnectedException | This class implements exceptions for object not connected errors.
OutOfMemoryException | Exception class which is raised when there are memory limit errors.
PageNotFoundException | Exception class raised when the current PageNumber is not found in the annotation file being loaded.
PolygonTool | The PolyLineTool class is used to create polygon-shaped annotations.
PolygonToolbarDefaults | The TextTool is used to create Polygon annotations.
PolyLineTool | The PolyLineTool class is used to create line annotations with 2 or more points.
PolyLineToolbarDefaults | The TextTool is used to create PolyLine annotations.
RectangleTool | The RectangleTool class is used to create rectangle annotations.
RectangleToolbarDefaults | The TextTool is used to create Rectangle annotations.
RulerTool | The RulerTool is used to create ruler annotations.
RulerToolbarDefaults | The TextTool is used to create Ruler annotations.
SaveFileOneLayerException | This class implements exceptions when saving a file on one layer.
SaveOptions | This class implements methods and properties for controlling how the annotations are saved.
StampTool | The StampTool is used to create stamp annotations. Stamp annotations resemble text annotations in that they have text displayed with an optional background and border. However, stamp annotations have static text, which cannot be edited directly by the user.
StampToolbarDefaults | The StampTool is used to create stamp annotations. Stamp annotations resemble text annotations in that they have text displayed with an optional background and border. However, stamp annotations have static text, which cannot be edited directly by the user.
StorageStreamException | Exception class which is raised when there are storage errors.
TextEditEndEventArgs | Arguments for TextEditEnd event
TextEditStartEventArgs | Arguments for TextEditStart event
TextTool | The TextTool is used to create text annotations, which display text with an optional background and border.
TextToolbarDefaults | The TextTool is used to create Text annotations.
TmsAnnotationBadActivateCodeException | Exception class raised when the TMS annotation activation flag is invalid.
TmsAnnotationBadAlignmentException | Exception class raised when the TMS annotation alignment field is invalid.
TmsAnnotationBadArrowsException | Exception class raised when the TMS annotation arrows field is invalid.
TmsAnnotationBadBorderStyleException | Exception class raised when the TMS annotation border style field is invalid.
TmsAnnotationBadColorMapFlagException | Exception class raised when the TMS annotation color mapping flag is invalid.
TmsAnnotationBadCoordinateException | Exception class raised when there are invalid TMS annotation coordinates.
TmsAnnotationBadDirectionException | Exception class raised when the TMS annotation line direction field is invalid.
TmsAnnotationBadHeaderException | Exception class raised when the TMS annotation header record is illegally formed.
TmsAnnotationBadRecordException | Exception class raised when all of the TMS annotation fields are not specified or a required field has no data.
TmsAnnotationBadRedactionFlagException | Exception class raised when the TMS annotation redaction flag is invalid.
TmsAnnotationBadTransparentFlagException | Exception class raised when the TMS annotation transparency flag is invalid.
TmsAnnotationBadVersionException | Exception class raised when the TMS annotation version is not supported.
Toolbar | This class implements methods and properties used to control the Toolbar.
ToolbarDefaults | This class implements methods and properties used to control the defaults for the built in NotateXpress Toolbar
ToolbarEventArgs | Arguments for ToolbarSelect event
UnableLoadAnnotationDllException | Base exception class raised when unable to load assembly dll.
UnableToCreateStorageException | Exception class which is raised when there are errors creating storage.
UserDrawEventArgs | Arguments for UserDraw event
UserGroupCreatedEventArgs | Arguments for UserGroupCreated event
UserGroupDestroyedEventArgs | Arguments for UserGroupDestroyed event
XmlFatalException | Exception class raised when there is a fatal XML error.
XmlGeneralException | Exception class raised when there is a general XML error.
XmlInvalidHeaderException | Exception class raised when the XML file header is invalid.
XmlInvalidPageDataException | Exception class raised when there is invalid XML page data.

Enumerations

Enumeration | Description
AnnotationMode | Contains constants for use with the NotateXpress.InteractMode property.
AnnotationTool | Contains which tools are used with the ToolbarEvents and MenuEvent arguments.
AnnotationType | Option values which determine the type of annotations that NotateXpress can process.
AutoSize | Contains options for how to bound annotations.
BackStyle | Contains constants for use with the BackStyle properties.
CursorSelection | The types of cursors to use in selecting elements.
DebugErrorLevelInfo | The amount of error information to write to the NotateXpress.DebugLogFile.
EndPointStyle | Contains options for how the end of a line should display.
ErrorLevelInfo | The amount of error information to write to the NotateXpress.DebugLogFile.
FontScaling | Specifies how fonts are scaled with the NotateXpress.FontScaling property.
HatchStyle | Contains constants for use with the HatchStyle properties.
LineScaling | Specifies how lines are scaled with the NotateXpress.LineScaling property.
Mapping | Contains constants for use with the SaveOptions.Mapping property.
MeasurementUnit | Contains options for how the ruler displays lengths.
MenuType | Contains options for which menu to use.
NotateTrait | Contains options for changing the OnItemChanged event annotation attribute.
PenFillStyle | Contains options for how the background should displayed for annotations.
PenStyle | Contains constants for use with the PenStyle properties. These only affect PenWidths of 1
SubMenuId | Contains options for how to access the built-in submenus.
TextJustification | Contains options for the text alignment.
TextOrientation | Contains options for the orientation of the text.
TopMenuId | Contains options for how to access the built-in menus.
WangType | Contains options for use with the WangType property.

Delegates

Delegate | Description
NotateXpress.AnnotationAddedEventHandler | Fires when an annotation has been added.
NotateXpress.AnnotationDeletedEventHandler | Fires when an annotation has been deleted.
NotateXpress.AnnotationEndSelectedEventHandler | Fires when no annotations are selected.
NotateXpress.AnnotationMovedEventHandler | Fires when an annotation has been moved.
NotateXpress.AnnotationSelectedEventHandler | Fires when an annotation has been selected.
NotateXpress.ClickEventHandler | Raises when an annotation object is clicked in Interactive Mode.
NotateXpress.ContextMenuEventHandler | Contains event data for ContextMenu events when the NotateXpress Menu is turned off in Edit Mode.
NotateXpress.CurrentLayerChangeEventHandler | The CurrentLayerChange Event is fired whenever the current layer changes.
NotateXpress.DoubleClickEventHandler | Raises when an annotation object is double clicked in Interactive Mode.
NotateXpress.DroppedEventHandler | Fires when xfdf annotations that are not supported by NotateXpress are read in.
NotateXpress.GetLayerPasswordEventHandler | The RequestLayerPassword event is sent during the loading of an annotation file for all layers that were saved with a password.
NotateXpress.GroupDeselectedEventHandler | Fired when an annotation group is unselected
NotateXpress.GroupSelectedEventHandler | Fired when an annotation group is selected
NotateXpress.ItemChangedEventHandler | The ItemChanged event is sent when an annotation object changes. When an object is moved or resized by the user, an AnnotationMoved is fired.
NotateXpress.LayerRestoredEventHandler | The LayerRestored Event is fired for each layer restored during the loading of a previously saved annotation file.
NotateXpress.MappingInputEventHandler | This event is for an advanced user who wants to change how NotateXpress does its coordinate conversions.
NotateXpress.MappingOutputEventHandler | This event is for an advanced user who wants to change how NotateXpress does its coordinate conversions.
NotateXpress.MenuEventHandler | The MenuSelect event is fired when a user chooses any of the items on the NotateXpress context menu while over an annotation or on the toolbar.
NotateXpress.MouseDownEventHandler | Raises when an annotation object receives a MouseDown event in Interactive Mode.
NotateXpress.MouseMoveEventHandler | Raises when the mouse is moved over an annotation object in Interactive Mode.
NotateXpress.MouseUpEventHandler | Raises when an annotation object receives a MouseUp event in Interactive Mode.
NotateXpress.StampingEventHandler | The Stamping event is sent immediately before each stamp tool use, providing an opportunity to change the stamp text of the annotation object before it is added.
NotateXpress.TextEditEndEventHandler | Fired when text editing has ended. Editing is now disabled
NotateXpress.TextEditStartEventHandler | Fired when The user has double-clicked a text item and editing is now enabled.
NotateXpress.ToolbarEventHandler | The ToolbarSelect event is fired when a selection changes for the current tool on the toolbar.
NotateXpress.UserDrawEventHandler | The UserDraw event is raised for a Rectangle object during its paint when the Rectangle’s UserDraw attribute is True.
NotateXpress.UserGroupCreatedEventHandler | The UserGroupCreated event is sent when a user creates a new group by selecting multiple objects and then pressing Ctrl-G.
NotateXpress.UserGroupDestroyedEventHandler | The UserGroupDestroyed event is sent when a user destroys a selected group by pressing Ctrl-U.

See Also

PegasusImaging.WinForms.NotateXpress9 Assembly


AnnotationAddedEventArgs Class

AnnotationAddedEventArgs Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

AnnotationAddedEventArgs Class

PegasusImaging.WinForms.NotateXpress9 Namespace : AnnotationAddedEventArgs Class

Contains data for NotateXpress.AnnotationAdded events.

For a list of all members of this type, see AnnotationAddedEventArgs members.

Object Model

Inheritance Hierarchy

System.Object
System.EventArgs
PegasusImaging.WinForms.NotateXpress9.AnnotationAddedEventArgs

Syntax

[Visual Basic]
Public Class AnnotationAddedEventArgs
   Inherits EventArgs
[C#]
public class AnnotationAddedEventArgs : EventArgs
[C++]
public __gc class AnnotationAddedEventArgs : public EventArgs
[C++/CLI]
public ref class AnnotationAddedEventArgs : public EventArgs

See Also

AnnotationAddedEventArgs Members | PegasusImaging.WinForms.NotateXpress9 Namespace


AnnotationAddedEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

AnnotationAddedEventArgs Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : AnnotationAddedEventArgs Class

AnnotationAddedEventArgs overview

Public Constructors

Public Constructor AnnotationAddedEventArgs Constructor

Public Properties

Public Property Element | Gets the element that was added.
Public Property Layer | Gets the layer on which the element was added.

See Also

AnnotationAddedEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace


AnnotationAddedEventArgs Constructor

AnnotationAddedEventArgs Class | AnnotationAddedEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

AnnotationAddedEventArgs Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > AnnotationAddedEventArgs Class : AnnotationAddedEventArgs Constructor (AnnotationAddedEventArgs)
[Visual Basic]
Public Function New()
[C#]
public AnnotationAddedEventArgs();
[C++]
public: AnnotationAddedEventArgs();
[C++/CLI]
public:
AnnotationAddedEventArgs();

See Also

AnnotationAddedEventArgs Class | AnnotationAddedEventArgs Members


AnnotationAddedEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

AnnotationAddedEventArgs Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : AnnotationAddedEventArgs Class

For a list of all members of this type, see AnnotationAddedEventArgs members.

Public Properties

Public Property Element | Gets the element that was added.
Public Property Layer | Gets the layer on which the element was added.

See Also

AnnotationAddedEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Element Property

AnnotationAddedEventArgs Class | AnnotationAddedEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Element Property

PegasusImaging.WinForms.NotateXpress9 Namespace > AnnotationAddedEventArgs Class : Element Property (AnnotationAddedEventArgs)

Gets the element that was added.

[Visual Basic]
Public Property Element As Element
[C#]
public Element Element {get; set;}
[C++]
public: __property Element* get_Element();
public: __property void set_Element(
   Element* value
);
[C++/CLI]
public:
property Element^ Element {
   Element^ get();
   void set (Element^ value);
}

See Also

AnnotationAddedEventArgs Class | AnnotationAddedEventArgs Members


Layer Property

AnnotationAddedEventArgs Class | AnnotationAddedEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Layer Property

PegasusImaging.WinForms.NotateXpress9 Namespace > AnnotationAddedEventArgs Class : Layer Property (AnnotationAddedEventArgs)

Gets the layer on which the element was added.

[Visual Basic]
Public Property Layer As Layer
[C#]
public Layer Layer {get; set;}
[C++]
public: __property Layer* get_Layer();
public: __property void set_Layer(
   Layer* value
);
[C++/CLI]
public:
property Layer^ Layer {
   Layer^ get();
   void set (Layer^ value);
}

See Also

AnnotationAddedEventArgs Class | AnnotationAddedEventArgs Members


AnnotationDeletedEventArgs Class

AnnotationDeletedEventArgs Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

AnnotationDeletedEventArgs Class

PegasusImaging.WinForms.NotateXpress9 Namespace : AnnotationDeletedEventArgs Class

Contains event data for NotateXpress.AnnotationDeleted events.

For a list of all members of this type, see AnnotationDeletedEventArgs members.

Object Model

Inheritance Hierarchy

System.Object
System.EventArgs
PegasusImaging.WinForms.NotateXpress9.AnnotationDeletedEventArgs

Syntax

[Visual Basic]
Public Class AnnotationDeletedEventArgs
   Inherits EventArgs
[C#]
public class AnnotationDeletedEventArgs : EventArgs
[C++]
public __gc class AnnotationDeletedEventArgs : public EventArgs
[C++/CLI]
public ref class AnnotationDeletedEventArgs : public EventArgs

See Also

AnnotationDeletedEventArgs Members | PegasusImaging.WinForms.NotateXpress9 Namespace


AnnotationDeletedEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

AnnotationDeletedEventArgs Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : AnnotationDeletedEventArgs Class

AnnotationDeletedEventArgs overview

Public Constructors

Public Constructor AnnotationDeletedEventArgs Constructor

Public Properties

Public Property Element | Gets the element that was deleted.
Public Property Layer | Gets the layer that the deleted element was on.

See Also

AnnotationDeletedEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace


AnnotationDeletedEventArgs Constructor

AnnotationDeletedEventArgs Class | AnnotationDeletedEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

AnnotationDeletedEventArgs Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > AnnotationDeletedEventArgs Class : AnnotationDeletedEventArgs Constructor (AnnotationDeletedEventArgs)
[Visual Basic]
Public Function New()
[C#]
public AnnotationDeletedEventArgs();
[C++]
public: AnnotationDeletedEventArgs();
[C++/CLI]
public:
AnnotationDeletedEventArgs();

See Also

AnnotationDeletedEventArgs Class | AnnotationDeletedEventArgs Members


AnnotationDeletedEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

AnnotationDeletedEventArgs Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : AnnotationDeletedEventArgs Class

For a list of all members of this type, see AnnotationDeletedEventArgs members.

Public Properties

Public Property Element | Gets the element that was deleted.
Public Property Layer | Gets the layer that the deleted element was on.

See Also

AnnotationDeletedEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Element Property

AnnotationDeletedEventArgs Class | AnnotationDeletedEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Element Property

PegasusImaging.WinForms.NotateXpress9 Namespace > AnnotationDeletedEventArgs Class : Element Property (AnnotationDeletedEventArgs)

Gets the element that was deleted.

[Visual Basic]
Public Property Element As Element
[C#]
public Element Element {get; set;}
[C++]
public: __property Element* get_Element();
public: __property void set_Element(
   Element* value
);
[C++/CLI]
public:
property Element^ Element {
   Element^ get();
   void set (Element^ value);
}

See Also

AnnotationDeletedEventArgs Class | AnnotationDeletedEventArgs Members


Layer Property

AnnotationDeletedEventArgs Class | AnnotationDeletedEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Layer Property

PegasusImaging.WinForms.NotateXpress9 Namespace > AnnotationDeletedEventArgs Class : Layer Property (AnnotationDeletedEventArgs)

Gets the layer that the deleted element was on.

[Visual Basic]
Public Property Layer As Layer
[C#]
public Layer Layer {get; set;}
[C++]
public: __property Layer* get_Layer();
public: __property void set_Layer(
   Layer* value
);
[C++/CLI]
public:
property Layer^ Layer {
   Layer^ get();
   void set (Layer^ value);
}

See Also

AnnotationDeletedEventArgs Class | AnnotationDeletedEventArgs Members


AnnotationMovedEventArgs Class

AnnotationMovedEventArgs Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

AnnotationMovedEventArgs Class

PegasusImaging.WinForms.NotateXpress9 Namespace : AnnotationMovedEventArgs Class

Contains event data for AnnotationMoved events.

For a list of all members of this type, see AnnotationMovedEventArgs members.

Object Model

Inheritance Hierarchy

System.Object
System.EventArgs
PegasusImaging.WinForms.NotateXpress9.AnnotationMovedEventArgs

Syntax

[Visual Basic]
Public Class AnnotationMovedEventArgs
   Inherits EventArgs
[C#]
public class AnnotationMovedEventArgs : EventArgs
[C++]
public __gc class AnnotationMovedEventArgs : public EventArgs
[C++/CLI]
public ref class AnnotationMovedEventArgs : public EventArgs

See Also

AnnotationMovedEventArgs Members | PegasusImaging.WinForms.NotateXpress9 Namespace


AnnotationMovedEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

AnnotationMovedEventArgs Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : AnnotationMovedEventArgs Class

AnnotationMovedEventArgs overview

Public Constructors

Public Constructor AnnotationMovedEventArgs Constructor

Public Properties

Public Property Element | Gets the element that was moved.
Public Property Layer | Gets the layer on which the element moved.

See Also

AnnotationMovedEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace


AnnotationMovedEventArgs Constructor

AnnotationMovedEventArgs Class | AnnotationMovedEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

AnnotationMovedEventArgs Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > AnnotationMovedEventArgs Class : AnnotationMovedEventArgs Constructor (AnnotationMovedEventArgs)
[Visual Basic]
Public Function New()
[C#]
public AnnotationMovedEventArgs();
[C++]
public: AnnotationMovedEventArgs();
[C++/CLI]
public:
AnnotationMovedEventArgs();

See Also

AnnotationMovedEventArgs Class | AnnotationMovedEventArgs Members


AnnotationMovedEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

AnnotationMovedEventArgs Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : AnnotationMovedEventArgs Class

For a list of all members of this type, see AnnotationMovedEventArgs members.

Public Properties

Public Property Element | Gets the element that was moved.
Public Property Layer | Gets the layer on which the element moved.

See Also

AnnotationMovedEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Element Property

AnnotationMovedEventArgs Class | AnnotationMovedEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Element Property

PegasusImaging.WinForms.NotateXpress9 Namespace > AnnotationMovedEventArgs Class : Element Property (AnnotationMovedEventArgs)

Gets the element that was moved.

[Visual Basic]
Public Property Element As Element
[C#]
public Element Element {get; set;}
[C++]
public: __property Element* get_Element();
public: __property void set_Element(
   Element* value
);
[C++/CLI]
public:
property Element^ Element {
   Element^ get();
   void set (Element^ value);
}

See Also

AnnotationMovedEventArgs Class | AnnotationMovedEventArgs Members


Layer Property

AnnotationMovedEventArgs Class | AnnotationMovedEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Layer Property

PegasusImaging.WinForms.NotateXpress9 Namespace > AnnotationMovedEventArgs Class : Layer Property (AnnotationMovedEventArgs)

Gets the layer on which the element moved.

[Visual Basic]
Public Property Layer As Layer
[C#]
public Layer Layer {get; set;}
[C++]
public: __property Layer* get_Layer();
public: __property void set_Layer(
   Layer* value
);
[C++/CLI]
public:
property Layer^ Layer {
   Layer^ get();
   void set (Layer^ value);
}

See Also

AnnotationMovedEventArgs Class | AnnotationMovedEventArgs Members


AnnotationSelectedEventArgs Class

AnnotationSelectedEventArgs Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

AnnotationSelectedEventArgs Class

PegasusImaging.WinForms.NotateXpress9 Namespace : AnnotationSelectedEventArgs Class

Contains event data for AnnotationSelected events.

For a list of all members of this type, see AnnotationSelectedEventArgs members.

Object Model

Inheritance Hierarchy

System.Object
System.EventArgs
PegasusImaging.WinForms.NotateXpress9.AnnotationSelectedEventArgs

Syntax

[Visual Basic]
Public Class AnnotationSelectedEventArgs
   Inherits EventArgs
[C#]
public class AnnotationSelectedEventArgs : EventArgs
[C++]
public __gc class AnnotationSelectedEventArgs : public EventArgs
[C++/CLI]
public ref class AnnotationSelectedEventArgs : public EventArgs

See Also

AnnotationSelectedEventArgs Members | PegasusImaging.WinForms.NotateXpress9 Namespace


AnnotationSelectedEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

AnnotationSelectedEventArgs Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : AnnotationSelectedEventArgs Class

AnnotationSelectedEventArgs overview

Public Constructors

Public Constructor AnnotationSelectedEventArgs Constructor

Public Properties

Public Property Element | Gets the element that was selected.
Public Property Layer | Gets the layer on which the element was selected.

See Also

AnnotationSelectedEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace


AnnotationSelectedEventArgs Constructor

AnnotationSelectedEventArgs Class | AnnotationSelectedEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

AnnotationSelectedEventArgs Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > AnnotationSelectedEventArgs Class : AnnotationSelectedEventArgs Constructor (AnnotationSelectedEventArgs)
[Visual Basic]
Public Function New()
[C#]
public AnnotationSelectedEventArgs();
[C++]
public: AnnotationSelectedEventArgs();
[C++/CLI]
public:
AnnotationSelectedEventArgs();

See Also

AnnotationSelectedEventArgs Class | AnnotationSelectedEventArgs Members


AnnotationSelectedEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

AnnotationSelectedEventArgs Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : AnnotationSelectedEventArgs Class

For a list of all members of this type, see AnnotationSelectedEventArgs members.

Public Properties

Public Property Element | Gets the element that was selected.
Public Property Layer | Gets the layer on which the element was selected.

See Also

AnnotationSelectedEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Element Property

AnnotationSelectedEventArgs Class | AnnotationSelectedEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Element Property

PegasusImaging.WinForms.NotateXpress9 Namespace > AnnotationSelectedEventArgs Class : Element Property (AnnotationSelectedEventArgs)

Gets the element that was selected.

[Visual Basic]
Public Property Element As Element
[C#]
public Element Element {get; set;}
[C++]
public: __property Element* get_Element();
public: __property void set_Element(
   Element* value
);
[C++/CLI]
public:
property Element^ Element {
   Element^ get();
   void set (Element^ value);
}

See Also

AnnotationSelectedEventArgs Class | AnnotationSelectedEventArgs Members


Layer Property

AnnotationSelectedEventArgs Class | AnnotationSelectedEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Layer Property

PegasusImaging.WinForms.NotateXpress9 Namespace > AnnotationSelectedEventArgs Class : Layer Property (AnnotationSelectedEventArgs)

Gets the layer on which the element was selected.

[Visual Basic]
Public Property Layer As Layer
[C#]
public Layer Layer {get; set;}
[C++]
public: __property Layer* get_Layer();
public: __property void set_Layer(
   Layer* value
);
[C++/CLI]
public:
property Layer^ Layer {
   Layer^ get();
   void set (Layer^ value);
}

See Also

AnnotationSelectedEventArgs Class | AnnotationSelectedEventArgs Members


BaseToolbarDefaults Class

BaseToolbarDefaults Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BaseToolbarDefaults Class

PegasusImaging.WinForms.NotateXpress9 Namespace : BaseToolbarDefaults Class

Base class for the Toolbar classes.

For a list of all members of this type, see BaseToolbarDefaults members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.NotateXpress9.BaseToolbarDefaults
PegasusImaging.WinForms.NotateXpress9.BlockHighlightToolbarDefaults
PegasusImaging.WinForms.NotateXpress9.ButtonToolbarDefaults
PegasusImaging.WinForms.NotateXpress9.EllipseToolbarDefaults
PegasusImaging.WinForms.NotateXpress9.FreehandToolbarDefaults
PegasusImaging.WinForms.NotateXpress9.ImageToolbarDefaults
PegasusImaging.WinForms.NotateXpress9.LineToolbarDefaults
PegasusImaging.WinForms.NotateXpress9.NoteToolbarDefaults
PegasusImaging.WinForms.NotateXpress9.PolygonToolbarDefaults
PegasusImaging.WinForms.NotateXpress9.PolyLineToolbarDefaults
PegasusImaging.WinForms.NotateXpress9.RectangleToolbarDefaults
PegasusImaging.WinForms.NotateXpress9.RulerToolbarDefaults
PegasusImaging.WinForms.NotateXpress9.StampToolbarDefaults
PegasusImaging.WinForms.NotateXpress9.TextToolbarDefaults

Syntax

[Visual Basic]
Public Class BaseToolbarDefaults
[C#]
public class BaseToolbarDefaults
[C++]
public __gc class BaseToolbarDefaults
[C++/CLI]
public ref class BaseToolbarDefaults

Remarks

These methods and properties control how an element will look when created from the Toolbar.

See Also

BaseToolbarDefaults Members | PegasusImaging.WinForms.NotateXpress9 Namespace


BaseToolbarDefaults Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BaseToolbarDefaults Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : BaseToolbarDefaults Class

BaseToolbarDefaults overview

Public Constructors

Public Constructor BaseToolbarDefaults Constructor Constructor for the Base class for the Toolbar classes.

Public Properties

Public Property Fixed | Gets and sets whether an element is tied to the view instead of the image.
Public Property Locked | Gets and sets an indicator to lock an element so it cannot be selected or moved by a user in Edit mode.
Public Property Moveable | Gets and sets whether an element can be moved interactively during EditMode.
Public Property Selected | Gets and sets whether an element is automatically selected.
Public Property ShowHandles | Gets and sets whether selection handles are displayed for an element.
Public Property Sizeable | Gets and sets whether an element can be sized interactively during EditMode.
Public Property ToolTipText | Gets or sets a string value in the element that will become the ToolTipText value associated with the annotation once it is created.
Public Property UserLong | Gets and sets a long value in the element that will become the UserLong value associated with the element once it is created.
Public Property UserString | Gets and sets a string value in the element that will become the UserString value associated with the object once it is created.
Public Property Visible | Gets and sets the Visible attribute of an element.

See Also

BaseToolbarDefaults Class | PegasusImaging.WinForms.NotateXpress9 Namespace


BaseToolbarDefaults Constructor

BaseToolbarDefaults Class | BaseToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BaseToolbarDefaults Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > BaseToolbarDefaults Class : BaseToolbarDefaults Constructor (BaseToolbarDefaults)

Constructor for the Base class for the Toolbar classes.

[Visual Basic]
Public Function New()
[C#]
public BaseToolbarDefaults();
[C++]
public: BaseToolbarDefaults();
[C++/CLI]
public:
BaseToolbarDefaults();

See Also

BaseToolbarDefaults Class | BaseToolbarDefaults Members


BaseToolbarDefaults Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BaseToolbarDefaults Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : BaseToolbarDefaults Class

For a list of all members of this type, see BaseToolbarDefaults members.

Public Properties

Public Property Fixed | Gets and sets whether an element is tied to the view instead of the image.
Public Property Locked | Gets and sets an indicator to lock an element so it cannot be selected or moved by a user in Edit mode.
Public Property Moveable | Gets and sets whether an element can be moved interactively during EditMode.
Public Property Selected | Gets and sets whether an element is automatically selected.
Public Property ShowHandles | Gets and sets whether selection handles are displayed for an element.
Public Property Sizeable | Gets and sets whether an element can be sized interactively during EditMode.
Public Property ToolTipText | Gets or sets a string value in the element that will become the ToolTipText value associated with the annotation once it is created.
Public Property UserLong | Gets and sets a long value in the element that will become the UserLong value associated with the element once it is created.
Public Property UserString | Gets and sets a string value in the element that will become the UserString value associated with the object once it is created.
Public Property Visible | Gets and sets the Visible attribute of an element.

See Also

BaseToolbarDefaults Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Fixed Property

BaseToolbarDefaults Class | BaseToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Fixed Property

PegasusImaging.WinForms.NotateXpress9 Namespace > BaseToolbarDefaults Class : Fixed Property (BaseToolbarDefaults)

Gets and sets whether an element is tied to the view instead of the image.

[Visual Basic]
Public Property Fixed As Boolean
[C#]
public bool Fixed {get; set;}
[C++]
public: __property bool get_Fixed();
public: __property void set_Fixed(
   bool value
);
[C++/CLI]
public:
property bool Fixed {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true for the annotation to be fixed. Otherwise, false is returned.

Remarks

The default value is false.

The Fixed attribute of an annotation object determines whether or not an object is tied to the viewer instead of the image. This can be used in cases where you want information always floating above the image, instead of tied to it. For example, a medical image where you always want the patient name displayed.

Note: Fixed annotations are 'locked'to the view (the part of the image that is displayed in the current window), not the entire image. When a fixed annotation is created outside of the current view, the user will never be able to see it.

If the scrollbars are on when the fixed annotation is created, factor in the position to be able to get back to the fixed annotation in the view.

For example: NotateXpress9.ElementSetBoundingRect e, ImagXpress9.ScrollX + 10, ImagXpress9.ScrollY + 10, ImagXpress9.ScrollX + 800, ImagXpress9.ScrollY + 100

See Also

BaseToolbarDefaults Class | BaseToolbarDefaults Members


Locked Property

BaseToolbarDefaults Class | BaseToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Locked Property

PegasusImaging.WinForms.NotateXpress9 Namespace > BaseToolbarDefaults Class : Locked Property (BaseToolbarDefaults)

Gets and sets an indicator to lock an element so it cannot be selected or moved by a user in Edit mode.

[Visual Basic]
Public Property Locked As Boolean
[C#]
public bool Locked {get; set;}
[C++]
public: __property bool get_Locked();
public: __property void set_Locked(
   bool value
);
[C++/CLI]
public:
property bool Locked {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true to lock the element. Otherwise, false is returned.

Remarks

The default value is false.

See Also

BaseToolbarDefaults Class | BaseToolbarDefaults Members


Moveable Property

BaseToolbarDefaults Class | BaseToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Moveable Property

PegasusImaging.WinForms.NotateXpress9 Namespace > BaseToolbarDefaults Class : Moveable Property (BaseToolbarDefaults)

Gets and sets whether an element can be moved interactively during EditMode.

[Visual Basic]
Public Property Moveable As Boolean
[C#]
public bool Moveable {get; set;}
[C++]
public: __property bool get_Moveable();
public: __property void set_Moveable(
   bool value
);
[C++/CLI]
public:
property bool Moveable {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true if the object can be moved in edit mode. Otherwise, false is returned.

Remarks

The default value is true.

The Moveable attribute of an element determines whether or not an element can be moved interactively when the control is in EditMode.

See Also

BaseToolbarDefaults Class | BaseToolbarDefaults Members


Selected Property

BaseToolbarDefaults Class | BaseToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Selected Property

PegasusImaging.WinForms.NotateXpress9 Namespace > BaseToolbarDefaults Class : Selected Property (BaseToolbarDefaults)

Gets and sets whether an element is automatically selected.

[Visual Basic]
Public Property Selected As Boolean
[C#]
public bool Selected {get; set;}
[C++]
public: __property bool get_Selected();
public: __property void set_Selected(
   bool value
);
[C++/CLI]
public:
property bool Selected {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true to automatically select an elemen when created. Otherwise, false is returned.

Remarks

The default value is false .

The Selected attribute of an annotation object determines whether or not an object will be automatically selected.

Visibly you can determine if an element is selected as you can see the squares on the edges of the element if ShowHandles is true.

See Also

BaseToolbarDefaults Class | BaseToolbarDefaults Members


ShowHandles Property

BaseToolbarDefaults Class | BaseToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ShowHandles Property

PegasusImaging.WinForms.NotateXpress9 Namespace > BaseToolbarDefaults Class : ShowHandles Property (BaseToolbarDefaults)

Gets and sets whether selection handles are displayed for an element.

[Visual Basic]
Public Property ShowHandles As Boolean
[C#]
public bool ShowHandles {get; set;}
[C++]
public: __property bool get_ShowHandles();
public: __property void set_ShowHandles(
   bool value
);
[C++/CLI]
public:
property bool ShowHandles {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true to show the handles on an object. Otherwise, false is returned and no handles are displayed.

Remarks

The default value is true.

The ShowHandles attribute of an annotation object determines whether or not selection handles are displayed on an object when it is Selected.

See Also

BaseToolbarDefaults Class | BaseToolbarDefaults Members


Sizeable Property

BaseToolbarDefaults Class | BaseToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Sizeable Property

PegasusImaging.WinForms.NotateXpress9 Namespace > BaseToolbarDefaults Class : Sizeable Property (BaseToolbarDefaults)

Gets and sets whether an element can be sized interactively during EditMode.

[Visual Basic]
Public Overridable Property Sizeable As Boolean
[C#]
public virtual bool Sizeable {get; set;}
[C++]
public: __property virtual bool get_Sizeable();
public: __property virtual void set_Sizeable(
   bool value
);
[C++/CLI]
public:
virtual property bool Sizeable {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true if an annotation object can be sized interactively. Otherwise, false is returned.

Remarks

The default value is true.

The Sizeable attribute of an annotation object determines whether or not an element can be sized interactively when the control is in EditMode.

See Also

BaseToolbarDefaults Class | BaseToolbarDefaults Members


ToolTipText Property

BaseToolbarDefaults Class | BaseToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToolTipText Property

PegasusImaging.WinForms.NotateXpress9 Namespace > BaseToolbarDefaults Class : ToolTipText Property (BaseToolbarDefaults)

Gets or sets a string value in the element that will become the ToolTipText value associated with the annotation once it is created.

[Visual Basic]
Public Property ToolTipText As String
[C#]
public string ToolTipText {get; set;}
[C++]
public: __property string* get_ToolTipText();
public: __property void set_ToolTipText(
   string* value
);
[C++/CLI]
public:
property String^ ToolTipText {
   String^ get();
   void set (String^ value);
}

Value

A string value which represents the tooltip text.

Remarks

This property is a string allocated by each annotation and will display as a standard tool tip over the element.

See Also

BaseToolbarDefaults Class | BaseToolbarDefaults Members


UserLong Property

BaseToolbarDefaults Class | BaseToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

UserLong Property

PegasusImaging.WinForms.NotateXpress9 Namespace > BaseToolbarDefaults Class : UserLong Property (BaseToolbarDefaults)

Gets and sets a long value in the element that will become the UserLong value associated with the element once it is created.

[Visual Basic]
Public Property UserLong As Integer
[C#]
public int UserLong {get; set;}
[C++]
public: __property int get_UserLong();
public: __property void set_UserLong(
   int value
);
[C++/CLI]
public:
property int UserLong {
   int get();
   void set (int value);
}

Value

An integer value which represents a private value to be used by each element.

Remarks

The default value is 0.

The UserLong is a long value allocated by each object and reserved for use by the application to store a private long value.

See Also

BaseToolbarDefaults Class | BaseToolbarDefaults Members


UserString Property

BaseToolbarDefaults Class | BaseToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

UserString Property

PegasusImaging.WinForms.NotateXpress9 Namespace > BaseToolbarDefaults Class : UserString Property (BaseToolbarDefaults)

Gets and sets a string value in the element that will become the UserString value associated with the object once it is created.

[Visual Basic]
Public Property UserString As String
[C#]
public string UserString {get; set;}
[C++]
public: __property string* get_UserString();
public: __property void set_UserString(
   string* value
);
[C++/CLI]
public:
property String^ UserString {
   String^ get();
   void set (String^ value);
}

Value

A string value which represents a private description for use by the application.

Remarks

The default value is an empty string "".

The UserString is a string allocated by each object and reserved for use by the application to store a private string value.

See Also

BaseToolbarDefaults Class | BaseToolbarDefaults Members


Visible Property

BaseToolbarDefaults Class | BaseToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Visible Property

PegasusImaging.WinForms.NotateXpress9 Namespace > BaseToolbarDefaults Class : Visible Property (BaseToolbarDefaults)

Gets and sets the Visible attribute of an element.

[Visual Basic]
Public Property Visible As Boolean
[C#]
public bool Visible {get; set;}
[C++]
public: __property bool get_Visible();
public: __property void set_Visible(
   bool value
);
[C++/CLI]
public:
property bool Visible {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true to make the element visible. Otherwise, false is returned.

Remarks

The default value is true.

The Visible property sets or returns the visibility state of an element.

See Also

BaseToolbarDefaults Class | BaseToolbarDefaults Members


BlockHighlightTool Class

BlockHighlightTool Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BlockHighlightTool Class

PegasusImaging.WinForms.NotateXpress9 Namespace : BlockHighlightTool Class

This class is used to create BlockHighlight annotations.

For a list of all members of this type, see BlockHighlightTool members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.NotateXpress9.Element
PegasusImaging.WinForms.NotateXpress9.BlockHighlightTool

Syntax

[Visual Basic]
Public Class BlockHighlightTool
   Inherits Element
[C#]
public class BlockHighlightTool : Element
[C++]
public __gc class BlockHighlightTool : public Element
[C++/CLI]
public ref class BlockHighlightTool : public Element

See Also

BlockHighlightTool Members | PegasusImaging.WinForms.NotateXpress9 Namespace


BlockHighlightTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BlockHighlightTool Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : BlockHighlightTool Class

BlockHighlightTool overview

Public Constructors

Public Constructor BlockHighlightTool Constructor Default constructor for the BlockHighlightTool class.

Public Properties

Public Property BoundingRectangle (Inherited from Element) | Gets and sets the rectangle boundary for the element.
Public Property CreateTime (Inherited from Element) | A Read only property that gets the time when the element was created.
Public Property FillColor | Gets and sets the color used to fill in the area of the BlockHighlight annotation.
Public Property Fixed (Inherited from Element) | Gets and sets whether an annotation has a fixed position with respect to the control window.
Public Property GroupMember (Inherited from Element) | Gets the group which the element belongs to.
Public Property IsGroupMember (Inherited from Element) | A read only property that gets a value which determines if the element is a member of a group or not.
Public Property Locked (Inherited from Element) | Gets and sets an indicator whether an annotation element can be selected or moved by a user in Edit mode.
Public Property Moveable (Inherited from Element) | Gets and sets whether the element can be moved by a user in Edit mode.
Public Property NumberPoints (Inherited from Element) | A Read only property that gets the number of points currently used to define the element.
Public Property Selected (Inherited from Element) | Gets and sets whether the element has been selected.
Public Property ShowHandles (Inherited from Element) | Gets and sets whether selection handles are displayed on an object when it is selected.
Public Property Sizeable (Inherited from Element) | Gets and sets whether the element can be resized.
Public Property ToolTipText (Inherited from Element) | Gets and sets a string value in the element that will become the ToolTipText value associated with the element.
Public Property UserLong (Inherited from Element) | Gets and sets a user defined long value associated with the element.
Public Property UserString (Inherited from Element) | Gets and sets a user-defined string associated with the element.
Public Property Visible (Inherited from Element) | Gets and sets whether the element is visible.

Public Methods

Public Method NudgeDown (Inherited from Element) | Moves the specified annotation object one level down, towards the back, in the painting order of the specified layer.
Public Method NudgeUp (Inherited from Element) | Moves the specified annotation object one level up, towards the front, in the painting order of the specified layer.
Public Method UserDataAdd (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataDelete (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFind (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFindFirst (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFindNext (Inherited from Element) | User data can be added to each element in a key value pair.

See Also

BlockHighlightTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace


BlockHighlightTool Constructor

BlockHighlightTool Class | BlockHighlightTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BlockHighlightTool Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > BlockHighlightTool Class : BlockHighlightTool Constructor (BlockHighlightTool)

Default constructor for the BlockHighlightTool class.

[Visual Basic]
Public Function New()
[C#]
public BlockHighlightTool();
[C++]
public: BlockHighlightTool();
[C++/CLI]
public:
BlockHighlightTool();

See Also

BlockHighlightTool Class | BlockHighlightTool Members


BlockHighlightTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BlockHighlightTool Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : BlockHighlightTool Class

For a list of all members of this type, see BlockHighlightTool members.

Public Properties

Public Property BoundingRectangle (Inherited from Element) | Gets and sets the rectangle boundary for the element.
Public Property CreateTime (Inherited from Element) | A Read only property that gets the time when the element was created.
Public Property FillColor | Gets and sets the color used to fill in the area of the BlockHighlight annotation.
Public Property Fixed (Inherited from Element) | Gets and sets whether an annotation has a fixed position with respect to the control window.
Public Property GroupMember (Inherited from Element) | Gets the group which the element belongs to.
Public Property IsGroupMember (Inherited from Element) | A read only property that gets a value which determines if the element is a member of a group or not.
Public Property Locked (Inherited from Element) | Gets and sets an indicator whether an annotation element can be selected or moved by a user in Edit mode.
Public Property Moveable (Inherited from Element) | Gets and sets whether the element can be moved by a user in Edit mode.
Public Property NumberPoints (Inherited from Element) | A Read only property that gets the number of points currently used to define the element.
Public Property Selected (Inherited from Element) | Gets and sets whether the element has been selected.
Public Property ShowHandles (Inherited from Element) | Gets and sets whether selection handles are displayed on an object when it is selected.
Public Property Sizeable (Inherited from Element) | Gets and sets whether the element can be resized.
Public Property ToolTipText (Inherited from Element) | Gets and sets a string value in the element that will become the ToolTipText value associated with the element.
Public Property UserLong (Inherited from Element) | Gets and sets a user defined long value associated with the element.
Public Property UserString (Inherited from Element) | Gets and sets a user-defined string associated with the element.
Public Property Visible (Inherited from Element) | Gets and sets whether the element is visible.

See Also

BlockHighlightTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace


FillColor Property

BlockHighlightTool Class | BlockHighlightTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

FillColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > BlockHighlightTool Class : FillColor Property (BlockHighlightTool)

Gets and sets the color used to fill in the area of the BlockHighlight annotation.

[Visual Basic]
Public Property FillColor As Color
[C#]
public Color FillColor {get; set;}
[C++]
public: __property Color get_FillColor();
public: __property void set_FillColor(
   Color value
);
[C++/CLI]
public:
property Color FillColor {
   Color get();
   void set (Color value);
}

Value

A Color which represents the selected color.

Remarks

The FillColor is always be shown as translucent.

See Also

BlockHighlightTool Class | BlockHighlightTool Members


BlockHighlightToolbarDefaults Class

BlockHighlightToolbarDefaults Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BlockHighlightToolbarDefaults Class

PegasusImaging.WinForms.NotateXpress9 Namespace : BlockHighlightToolbarDefaults Class (PegasusImaging.WinForms.NotateXpress9)

This class is used to create BlockHighlight annotations.

For a list of all members of this type, see BlockHighlightToolbarDefaults members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.NotateXpress9.BaseToolbarDefaults
PegasusImaging.WinForms.NotateXpress9.BlockHighlightToolbarDefaults

Syntax

[Visual Basic]
Public Class BlockHighlightToolbarDefaults
   Inherits BaseToolbarDefaults
[C#]
public class BlockHighlightToolbarDefaults : BaseToolbarDefaults
[C++]
public __gc class BlockHighlightToolbarDefaults : public BaseToolbarDefaults
[C++/CLI]
public ref class BlockHighlightToolbarDefaults : public BaseToolbarDefaults

See Also

BlockHighlightToolbarDefaults Members | PegasusImaging.WinForms.NotateXpress9 Namespace


BlockHighlightToolbarDefaults Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BlockHighlightToolbarDefaults Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : BlockHighlightToolbarDefaults Class (PegasusImaging.WinForms.NotateXpress9)

BlockHighlightToolbarDefaults overview

Public Constructors

Public Constructor BlockHighlightToolbarDefaults Constructor Default constructor for the BlockHighlightToolbarDefaults class.

Public Properties

Public Property FillColor | Gets or sets the color of the fill used within the BlockHighlight annotation.
Public Property Fixed (Inherited from BaseToolbarDefaults) | Gets and sets whether an element is tied to the view instead of the image.
Public Property Locked (Inherited from BaseToolbarDefaults) | Gets and sets an indicator to lock an element so it cannot be selected or moved by a user in Edit mode.
Public Property Moveable (Inherited from BaseToolbarDefaults) | Gets and sets whether an element can be moved interactively during EditMode.
Public Property Selected (Inherited from BaseToolbarDefaults) | Gets and sets whether an element is automatically selected.
Public Property ShowHandles (Inherited from BaseToolbarDefaults) | Gets and sets whether selection handles are displayed for an element.
Public Property Sizeable (Inherited from BaseToolbarDefaults) | Gets and sets whether an element can be sized interactively during EditMode.
Public Property ToolTipText (Inherited from BaseToolbarDefaults) | Gets or sets a string value in the element that will become the ToolTipText value associated with the annotation once it is created.
Public Property UserLong (Inherited from BaseToolbarDefaults) | Gets and sets a long value in the element that will become the UserLong value associated with the element once it is created.
Public Property UserString (Inherited from BaseToolbarDefaults) | Gets and sets a string value in the element that will become the UserString value associated with the object once it is created.
Public Property Visible (Inherited from BaseToolbarDefaults) | Gets and sets the Visible attribute of an element.

See Also

BlockHighlightToolbarDefaults Class | PegasusImaging.WinForms.NotateXpress9 Namespace


BlockHighlightToolbarDefaults Constructor

BlockHighlightToolbarDefaults Class | BlockHighlightToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BlockHighlightToolbarDefaults Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > BlockHighlightToolbarDefaults Class : BlockHighlightToolbarDefaults Constructor (BlockHighlightToolbarDefaults)

Default constructor for the BlockHighlightToolbarDefaults class.

[Visual Basic]
Public Function New()
[C#]
public BlockHighlightToolbarDefaults();
[C++]
public: BlockHighlightToolbarDefaults();
[C++/CLI]
public:
BlockHighlightToolbarDefaults();

See Also

BlockHighlightToolbarDefaults Class | BlockHighlightToolbarDefaults Members


BlockHighlightToolbarDefaults Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BlockHighlightToolbarDefaults Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : BlockHighlightToolbarDefaults Class (PegasusImaging.WinForms.NotateXpress9)

For a list of all members of this type, see BlockHighlightToolbarDefaults members.

Public Properties

Public Property FillColor | Gets or sets the color of the fill used within the BlockHighlight annotation.
Public Property Fixed (Inherited from BaseToolbarDefaults) | Gets and sets whether an element is tied to the view instead of the image.
Public Property Locked (Inherited from BaseToolbarDefaults) | Gets and sets an indicator to lock an element so it cannot be selected or moved by a user in Edit mode.
Public Property Moveable (Inherited from BaseToolbarDefaults) | Gets and sets whether an element can be moved interactively during EditMode.
Public Property Selected (Inherited from BaseToolbarDefaults) | Gets and sets whether an element is automatically selected.
Public Property ShowHandles (Inherited from BaseToolbarDefaults) | Gets and sets whether selection handles are displayed for an element.
Public Property Sizeable (Inherited from BaseToolbarDefaults) | Gets and sets whether an element can be sized interactively during EditMode.
Public Property ToolTipText (Inherited from BaseToolbarDefaults) | Gets or sets a string value in the element that will become the ToolTipText value associated with the annotation once it is created.
Public Property UserLong (Inherited from BaseToolbarDefaults) | Gets and sets a long value in the element that will become the UserLong value associated with the element once it is created.
Public Property UserString (Inherited from BaseToolbarDefaults) | Gets and sets a string value in the element that will become the UserString value associated with the object once it is created.
Public Property Visible (Inherited from BaseToolbarDefaults) | Gets and sets the Visible attribute of an element.

See Also

BlockHighlightToolbarDefaults Class | PegasusImaging.WinForms.NotateXpress9 Namespace


FillColor Property

BlockHighlightToolbarDefaults Class | BlockHighlightToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

FillColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > BlockHighlightToolbarDefaults Class : FillColor Property (BlockHighlightToolbarDefaults)

Gets or sets the color of the fill used within the BlockHighlight annotation.

[Visual Basic]
Public Property FillColor As Color
[C#]
public Color FillColor {get; set;}
[C++]
public: __property Color get_FillColor();
public: __property void set_FillColor(
   Color value
);
[C++/CLI]
public:
property Color FillColor {
   Color get();
   void set (Color value);
}

Value

A Color which represents the selected color.

Remarks

The FillColor is always shown as translucent.

See Also

BlockHighlightToolbarDefaults Class | BlockHighlightToolbarDefaults Members


BrandingException Class

BrandingException Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BrandingException Class

PegasusImaging.WinForms.NotateXpress9 Namespace : BrandingException Class

Exception class that is raise when branding errors occur.

For a list of all members of this type, see BrandingException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.NotateXpress9.NotateXpressException
PegasusImaging.WinForms.NotateXpress9.BrandingException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class BrandingException
   Inherits NotateXpressException
   Implements ISerializable, _Exception
[C#]
[SerializableAttribute()]
public sealed class BrandingException : NotateXpressException, ISerializable, _Exception
[C++]
[SerializableAttribute()]
public __gc __sealed class BrandingException : public NotateXpressException, ISerializable, _Exception
[C++/CLI]
[SerializableAttribute()]
public ref class BrandingException sealed : public NotateXpressException, ISerializable, _Exception

See Also

BrandingException Members | PegasusImaging.WinForms.NotateXpress9 Namespace


BrandingException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BrandingException Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : BrandingException Class

BrandingException overview

Public Constructors

Public Constructor BrandingException Constructor Overloaded. Main constructor for BrandingException class when branding errors occur.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

BrandingException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


BrandingException Constructor

BrandingException Class | BrandingException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BrandingException Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > BrandingException Class : BrandingException Constructor (BrandingException)

Main constructor for BrandingException class when branding errors occur.

Overload List

Main constructor for BrandingException class when branding errors occur.

[Visual Basic] Public Sub New()

[C#] public BrandingException();

[C++] public BrandingException();

[C++/CLI] public BrandingException();

Exception which allows passing in an error number when branding errors occur.

[Visual Basic] Public Sub New(Integer)

[C#] public BrandingException(int);

[C++] public BrandingException(int);

[C++/CLI] public BrandingException(int);

Exception which allows passing in a message when branding errors occur.

[Visual Basic] Public Sub New(String)

[C#] public BrandingException(string);

[C++] public BrandingException(string*);

[C++/CLI] public BrandingException(String^);

Exception which allows passing in an error number and message when branding errors occur.

[Visual Basic] Public Sub New(Integer,String)

[C#] public BrandingException(int,string);

[C++] public BrandingException(int,string*);

[C++/CLI] public BrandingException(int,String^);

Exception which allows passing in a message and inner exception when branding errors occur.

[Visual Basic] Public Sub New(String,Exception)

[C#] public BrandingException(string,Exception);

[C++] public BrandingException(string*,Exception*);

[C++/CLI] public BrandingException(String^,Exception^);

See Also

BrandingException Class | BrandingException Members


BrandingException Constructor()

BrandingException Class | BrandingException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BrandingException Constructor()

PegasusImaging.WinForms.NotateXpress9 Namespace > BrandingException Class > BrandingException Constructor : BrandingException Constructor()

Main constructor for BrandingException class when branding errors occur.

[Visual Basic]
Public Function New()
[C#]
public BrandingException();
[C++]
public: BrandingException();
[C++/CLI]
public:
BrandingException();

See Also

BrandingException Class | BrandingException Members | Overload List


BrandingException Constructor(Int32)

BrandingException Class | BrandingException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BrandingException Constructor(Int32)

PegasusImaging.WinForms.NotateXpress9 Namespace > BrandingException Class > BrandingException Constructor : BrandingException Constructor(Int32)

Exception which allows passing in an error number when branding errors occur.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public BrandingException(
   int errorNumber
);
[C++]
public: BrandingException(
   int errorNumber
)
[C++/CLI]
public:
BrandingException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

BrandingException Class | BrandingException Members | Overload List


BrandingException Constructor(Int32,String)

BrandingException Class | BrandingException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BrandingException Constructor(Int32,String)

PegasusImaging.WinForms.NotateXpress9 Namespace > BrandingException Class > BrandingException Constructor : BrandingException Constructor(Int32,String)

Exception which allows passing in an error number and message when branding errors occur.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public BrandingException(
   int errorNumber,
   string message
);
[C++]
public: BrandingException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
BrandingException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

BrandingException Class | BrandingException Members | Overload List


BrandingException Constructor(String)

BrandingException Class | BrandingException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BrandingException Constructor(String)

PegasusImaging.WinForms.NotateXpress9 Namespace > BrandingException Class > BrandingException Constructor : BrandingException Constructor(String)

Exception which allows passing in a message when branding errors occur.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public BrandingException(
   string message
);
[C++]
public: BrandingException(
   string* message
)
[C++/CLI]
public:
BrandingException(
   String^ message
)

Parameters

message
A string which represents the message.

See Also

BrandingException Class | BrandingException Members | Overload List


BrandingException Constructor(String,Exception)

BrandingException Class | BrandingException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BrandingException Constructor(String,Exception)

PegasusImaging.WinForms.NotateXpress9 Namespace > BrandingException Class > BrandingException Constructor : BrandingException Constructor(String,Exception)

Exception which allows passing in a message and inner exception when branding errors occur.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public BrandingException(
   string message,
   Exception innerException
);
[C++]
public: BrandingException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
BrandingException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception.

See Also

BrandingException Class | BrandingException Members | Overload List


BrandingSourceDibException Class

BrandingSourceDibException Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BrandingSourceDibException Class

PegasusImaging.WinForms.NotateXpress9 Namespace : BrandingSourceDibException Class

Exception class which is raised when there are errors that occur with branding the source DIB (Device Independent Bitmap).

For a list of all members of this type, see BrandingSourceDibException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.NotateXpress9.NotateXpressException
PegasusImaging.WinForms.NotateXpress9.BrandingSourceDibException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class BrandingSourceDibException
   Inherits NotateXpressException
   Implements ISerializable, _Exception
[C#]
[SerializableAttribute()]
public sealed class BrandingSourceDibException : NotateXpressException, ISerializable, _Exception
[C++]
[SerializableAttribute()]
public __gc __sealed class BrandingSourceDibException : public NotateXpressException, ISerializable, _Exception
[C++/CLI]
[SerializableAttribute()]
public ref class BrandingSourceDibException sealed : public NotateXpressException, ISerializable, _Exception

See Also

BrandingSourceDibException Members | PegasusImaging.WinForms.NotateXpress9 Namespace


BrandingSourceDibException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BrandingSourceDibException Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : BrandingSourceDibException Class

BrandingSourceDibException overview

Public Constructors

Public Constructor BrandingSourceDibException Constructor Overloaded. Main constructor for the BrandingSourceDibException class when there are errors that occur with branding the source DIB.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

BrandingSourceDibException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


BrandingSourceDibException Constructor

BrandingSourceDibException Class | BrandingSourceDibException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BrandingSourceDibException Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > BrandingSourceDibException Class : BrandingSourceDibException Constructor (BrandingSourceDibException)

Main constructor for the BrandingSourceDibException class when there are errors that occur with branding the source DIB.

Overload List

Main constructor for the BrandingSourceDibException class when there are errors that occur with branding the source DIB.

[Visual Basic] Public Sub New()

[C#] public BrandingSourceDibException();

[C++] public BrandingSourceDibException();

[C++/CLI] public BrandingSourceDibException();

Exception which allows passing in an error number when there are errors that occur with branding the source DIB.

[Visual Basic] Public Sub New(Integer)

[C#] public BrandingSourceDibException(int);

[C++] public BrandingSourceDibException(int);

[C++/CLI] public BrandingSourceDibException(int);

Exception which allows passing in a message when there are errors that occur with branding the source DIB.

[Visual Basic] Public Sub New(String)

[C#] public BrandingSourceDibException(string);

[C++] public BrandingSourceDibException(string*);

[C++/CLI] public BrandingSourceDibException(String^);

Exception which allows passing in an error number and message when there are errors that occur with branding the source DIB.

[Visual Basic] Public Sub New(Integer,String)

[C#] public BrandingSourceDibException(int,string);

[C++] public BrandingSourceDibException(int,string*);

[C++/CLI] public BrandingSourceDibException(int,String^);

Exception which allows passing in a message and inner exception when there are errors that occur with branding the source DIB.

[Visual Basic] Public Sub New(String,Exception)

[C#] public BrandingSourceDibException(string,Exception);

[C++] public BrandingSourceDibException(string*,Exception*);

[C++/CLI] public BrandingSourceDibException(String^,Exception^);

See Also

BrandingSourceDibException Class | BrandingSourceDibException Members


BrandingSourceDibException Constructor()

BrandingSourceDibException Class | BrandingSourceDibException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BrandingSourceDibException Constructor()

PegasusImaging.WinForms.NotateXpress9 Namespace > BrandingSourceDibException Class > BrandingSourceDibException Constructor : BrandingSourceDibException Constructor()

Main constructor for the BrandingSourceDibException class when there are errors that occur with branding the source DIB.

[Visual Basic]
Public Function New()
[C#]
public BrandingSourceDibException();
[C++]
public: BrandingSourceDibException();
[C++/CLI]
public:
BrandingSourceDibException();

See Also

BrandingSourceDibException Class | BrandingSourceDibException Members | Overload List


BrandingSourceDibException Constructor(Int32)

BrandingSourceDibException Class | BrandingSourceDibException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BrandingSourceDibException Constructor(Int32)

PegasusImaging.WinForms.NotateXpress9 Namespace > BrandingSourceDibException Class > BrandingSourceDibException Constructor : BrandingSourceDibException Constructor(Int32)

Exception which allows passing in an error number when there are errors that occur with branding the source DIB.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public BrandingSourceDibException(
   int errorNumber
);
[C++]
public: BrandingSourceDibException(
   int errorNumber
)
[C++/CLI]
public:
BrandingSourceDibException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

BrandingSourceDibException Class | BrandingSourceDibException Members | Overload List


BrandingSourceDibException Constructor(Int32,String)

BrandingSourceDibException Class | BrandingSourceDibException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BrandingSourceDibException Constructor(Int32,String)

PegasusImaging.WinForms.NotateXpress9 Namespace > BrandingSourceDibException Class > BrandingSourceDibException Constructor : BrandingSourceDibException Constructor(Int32,String)

Exception which allows passing in an error number and message when there are errors that occur with branding the source DIB.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public BrandingSourceDibException(
   int errorNumber,
   string message
);
[C++]
public: BrandingSourceDibException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
BrandingSourceDibException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

BrandingSourceDibException Class | BrandingSourceDibException Members | Overload List


BrandingSourceDibException Constructor(String)

BrandingSourceDibException Class | BrandingSourceDibException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BrandingSourceDibException Constructor(String)

PegasusImaging.WinForms.NotateXpress9 Namespace > BrandingSourceDibException Class > BrandingSourceDibException Constructor : BrandingSourceDibException Constructor(String)

Exception which allows passing in a message when there are errors that occur with branding the source DIB.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public BrandingSourceDibException(
   string message
);
[C++]
public: BrandingSourceDibException(
   string* message
)
[C++/CLI]
public:
BrandingSourceDibException(
   String^ message
)

Parameters

message
A string which represents the message.

See Also

BrandingSourceDibException Class | BrandingSourceDibException Members | Overload List


BrandingSourceDibException Constructor(String,Exception)

BrandingSourceDibException Class | BrandingSourceDibException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BrandingSourceDibException Constructor(String,Exception)

PegasusImaging.WinForms.NotateXpress9 Namespace > BrandingSourceDibException Class > BrandingSourceDibException Constructor : BrandingSourceDibException Constructor(String,Exception)

Exception which allows passing in a message and inner exception when there are errors that occur with branding the source DIB.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public BrandingSourceDibException(
   string message,
   Exception innerException
);
[C++]
public: BrandingSourceDibException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
BrandingSourceDibException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception.

See Also

BrandingSourceDibException Class | BrandingSourceDibException Members | Overload List


ButtonTool Class

ButtonTool Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ButtonTool Class

PegasusImaging.WinForms.NotateXpress9 Namespace : ButtonTool Class

The ButtonTool is used to create button annotations, which behave and respond like form buttons.

For a list of all members of this type, see ButtonTool members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.NotateXpress9.Element
PegasusImaging.WinForms.NotateXpress9.ButtonTool

Syntax

[Visual Basic]
Public Class ButtonTool
   Inherits Element
   Implements IDisposable
[C#]
public class ButtonTool : Element, IDisposable
[C++]
public __gc class ButtonTool : public Element, IDisposable
[C++/CLI]
public ref class ButtonTool : public Element, IDisposable

See Also

ButtonTool Members | PegasusImaging.WinForms.NotateXpress9 Namespace


ButtonTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ButtonTool Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : ButtonTool Class

ButtonTool overview

Public Constructors

Public Constructor ButtonTool Constructor Default constructor for the ButtonTool class.

Public Properties

Public Property AutoSize | Gets and sets whether or not the annotation size will be automatically expanded to fit the given text within the button annotation.
Public Property BackColor | Gets and sets the color of the backgroud used within the button annotation.
Public Property BevelLightColor | Gets and sets the color of the left and top edges of a button annotation.
Public Property BevelShadowColor | Gets and sets the color of the right and bottom edges of a button annotation.
Public Property BoundingRectangle (Inherited from Element) | Gets and sets the rectangle boundary for the element.
Public Property CreateTime (Inherited from Element) | A Read only property that gets the time when the element was created.
Public Property Fixed (Inherited from Element) | Gets and sets whether an annotation has a fixed position with respect to the control window.
Public Property GroupMember (Inherited from Element) | Gets the group which the element belongs to.
Public Property IsGroupMember (Inherited from Element) | A read only property that gets a value which determines if the element is a member of a group or not.
Public Property Locked (Inherited from Element) | Gets and sets an indicator whether an annotation element can be selected or moved by a user in Edit mode.
Public Property Moveable (Inherited from Element) | Gets and sets whether the element can be moved by a user in Edit mode.
Public Property NumberPoints (Inherited from Element) | A Read only property that gets the number of points currently used to define the element.
Public Property PenWidth | Gets and sets the width of the pen used to draw the button annotation.
Public Property Selected (Inherited from Element) | Gets and sets whether the element has been selected.
Public Property ShowHandles (Inherited from Element) | Gets and sets whether selection handles are displayed on an object when it is selected.
Public Property Sizeable (Inherited from Element) | Gets and sets whether the element can be resized.
Public Property Text | Gets and sets the text which is displayed upon the button annotation.
Public Property TextColor | Gets and sets the color of the text used to display text on the button annotation.
Public Property TextFont | Gets and sets the font of the text used to display text on the button annotation.
Public Property ToolTipText (Inherited from Element) | Gets and sets a string value in the element that will become the ToolTipText value associated with the element.
Public Property UserLong (Inherited from Element) | Gets and sets a user defined long value associated with the element.
Public Property UserString (Inherited from Element) | Gets and sets a user-defined string associated with the element.
Public Property Visible (Inherited from Element) | Gets and sets whether the element is visible.

Public Methods

Public Method Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public Method NudgeDown (Inherited from Element) | Moves the specified annotation object one level down, towards the back, in the painting order of the specified layer.
Public Method NudgeUp (Inherited from Element) | Moves the specified annotation object one level up, towards the front, in the painting order of the specified layer.
Public Method UserDataAdd (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataDelete (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFind (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFindFirst (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFindNext (Inherited from Element) | User data can be added to each element in a key value pair.

See Also

ButtonTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace


ButtonTool Constructor

ButtonTool Class | ButtonTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ButtonTool Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > ButtonTool Class : ButtonTool Constructor (ButtonTool)

Default constructor for the ButtonTool class.

[Visual Basic]
Public Function New()
[C#]
public ButtonTool();
[C++]
public: ButtonTool();
[C++/CLI]
public:
ButtonTool();

See Also

ButtonTool Class | ButtonTool Members


Dispose Method

ButtonTool Class | ButtonTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Dispose Method

PegasusImaging.WinForms.NotateXpress9 Namespace > ButtonTool Class : Dispose Method (ButtonTool)

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();
[C++]
public: void Dispose();
[C++/CLI]
public:
void Dispose();

See Also

ButtonTool Class | ButtonTool Members


ButtonTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ButtonTool Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : ButtonTool Class

For a list of all members of this type, see ButtonTool members.

Public Properties

Public Property AutoSize | Gets and sets whether or not the annotation size will be automatically expanded to fit the given text within the button annotation.
Public Property BackColor | Gets and sets the color of the backgroud used within the button annotation.
Public Property BevelLightColor | Gets and sets the color of the left and top edges of a button annotation.
Public Property BevelShadowColor | Gets and sets the color of the right and bottom edges of a button annotation.
Public Property BoundingRectangle (Inherited from Element) | Gets and sets the rectangle boundary for the element.
Public Property CreateTime (Inherited from Element) | A Read only property that gets the time when the element was created.
Public Property Fixed (Inherited from Element) | Gets and sets whether an annotation has a fixed position with respect to the control window.
Public Property GroupMember (Inherited from Element) | Gets the group which the element belongs to.
Public Property IsGroupMember (Inherited from Element) | A read only property that gets a value which determines if the element is a member of a group or not.
Public Property Locked (Inherited from Element) | Gets and sets an indicator whether an annotation element can be selected or moved by a user in Edit mode.
Public Property Moveable (Inherited from Element) | Gets and sets whether the element can be moved by a user in Edit mode.
Public Property NumberPoints (Inherited from Element) | A Read only property that gets the number of points currently used to define the element.
Public Property PenWidth | Gets and sets the width of the pen used to draw the button annotation.
Public Property Selected (Inherited from Element) | Gets and sets whether the element has been selected.
Public Property ShowHandles (Inherited from Element) | Gets and sets whether selection handles are displayed on an object when it is selected.
Public Property Sizeable (Inherited from Element) | Gets and sets whether the element can be resized.
Public Property Text | Gets and sets the text which is displayed upon the button annotation.
Public Property TextColor | Gets and sets the color of the text used to display text on the button annotation.
Public Property TextFont | Gets and sets the font of the text used to display text on the button annotation.
Public Property ToolTipText (Inherited from Element) | Gets and sets a string value in the element that will become the ToolTipText value associated with the element.
Public Property UserLong (Inherited from Element) | Gets and sets a user defined long value associated with the element.
Public Property UserString (Inherited from Element) | Gets and sets a user-defined string associated with the element.
Public Property Visible (Inherited from Element) | Gets and sets whether the element is visible.

See Also

ButtonTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace


AutoSize Property

ButtonTool Class | ButtonTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

AutoSize Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ButtonTool Class : AutoSize Property (ButtonTool)

Gets and sets whether or not the annotation size will be automatically expanded to fit the given text within the button annotation.

[Visual Basic]
Public Property AutoSize As AutoSize
[C#]
public AutoSize AutoSize {get; set;}
[C++]
public: __property AutoSize get_AutoSize();
public: __property void set_AutoSize(
   AutoSize value
);
[C++/CLI]
public:
property AutoSize AutoSize {
   AutoSize get();
   void set (AutoSize value);
}

Value

The AutoSize value set.

Remarks

The default value is none.

The AutoSize attribute will tell the control to size the element based on the text displayed.

When AutoSize is turned on the control can not be manually Sized

See Also

ButtonTool Class | ButtonTool Members


BackColor Property

ButtonTool Class | ButtonTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BackColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ButtonTool Class : BackColor Property (ButtonTool)

Gets and sets the color of the backgroud used within the button annotation.

[Visual Basic]
Public Property BackColor As Color
[C#]
public Color BackColor {get; set;}
[C++]
public: __property Color get_BackColor();
public: __property void set_BackColor(
   Color value
);
[C++/CLI]
public:
property Color BackColor {
   Color get();
   void set (Color value);
}

Value

The Color value set.

See Also

ButtonTool Class | ButtonTool Members


BevelLightColor Property

ButtonTool Class | ButtonTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BevelLightColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ButtonTool Class : BevelLightColor Property (ButtonTool)

Gets and sets the color of the left and top edges of a button annotation.

[Visual Basic]
Public Property BevelLightColor As Color
[C#]
public Color BevelLightColor {get; set;}
[C++]
public: __property Color get_BevelLightColor();
public: __property void set_BevelLightColor(
   Color value
);
[C++/CLI]
public:
property Color BevelLightColor {
   Color get();
   void set (Color value);
}

Value

The Color value set.

Remarks

The BevelLightColor is the color value of the left and top bevel edges of a Button object.

See Also

ButtonTool Class | ButtonTool Members


BevelShadowColor Property

ButtonTool Class | ButtonTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BevelShadowColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ButtonTool Class : BevelShadowColor Property (ButtonTool)

Gets and sets the color of the right and bottom edges of a button annotation.

[Visual Basic]
Public Property BevelShadowColor As Color
[C#]
public Color BevelShadowColor {get; set;}
[C++]
public: __property Color get_BevelShadowColor();
public: __property void set_BevelShadowColor(
   Color value
);
[C++/CLI]
public:
property Color BevelShadowColor {
   Color get();
   void set (Color value);
}

Value

The Color value set.

Remarks

The BevelShadowColor is the color value of the bottom and right bevel edges of a Button object.

See Also

ButtonTool Class | ButtonTool Members


PenWidth Property

ButtonTool Class | ButtonTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PenWidth Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ButtonTool Class : PenWidth Property (ButtonTool)

Gets and sets the width of the pen used to draw the button annotation.

[Visual Basic]
Public Property PenWidth As Integer
[C#]
public int PenWidth {get; set;}
[C++]
public: __property int get_PenWidth();
public: __property void set_PenWidth(
   int value
);
[C++/CLI]
public:
property int PenWidth {
   int get();
   void set (int value);
}

Value

An integer which represents the width in pixels.

Remarks

The default value is 4.

See Also

ButtonTool Class | ButtonTool Members


Text Property

ButtonTool Class | ButtonTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Text Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ButtonTool Class : Text Property (ButtonTool)

Gets and sets the text which is displayed upon the button annotation.

[Visual Basic]
Public Property Text As String
[C#]
public string Text {get; set;}
[C++]
public: __property string* get_Text();
public: __property void set_Text(
   string* value
);
[C++/CLI]
public:
property String^ Text {
   String^ get();
   void set (String^ value);
}

Value

A string value which is used within the button annotation.

Remarks

The default value is an empty string "".

See Also

ButtonTool Class | ButtonTool Members


TextColor Property

ButtonTool Class | ButtonTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TextColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ButtonTool Class : TextColor Property (ButtonTool)

Gets and sets the color of the text used to display text on the button annotation.

[Visual Basic]
Public Property TextColor As Color
[C#]
public Color TextColor {get; set;}
[C++]
public: __property Color get_TextColor();
public: __property void set_TextColor(
   Color value
);
[C++/CLI]
public:
property Color TextColor {
   Color get();
   void set (Color value);
}

Value

A Color which represents the color value set.

Remarks

The default value is Black.

See Also

ButtonTool Class | ButtonTool Members


TextFont Property

ButtonTool Class | ButtonTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TextFont Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ButtonTool Class : TextFont Property (ButtonTool)

Gets and sets the font of the text used to display text on the button annotation.

[Visual Basic]
Public Property TextFont As Font
[C#]
public Font TextFont {get; set;}
[C++]
public: __property Font* get_TextFont();
public: __property void set_TextFont(
   Font* value
);
[C++/CLI]
public:
property Font^ TextFont {
   Font^ get();
   void set (Font^ value);
}

Value

The text font.

See Also

ButtonTool Class | ButtonTool Members


ButtonToolbarDefaults Class

ButtonToolbarDefaults Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ButtonToolbarDefaults Class

PegasusImaging.WinForms.NotateXpress9 Namespace : ButtonToolbarDefaults Class (PegasusImaging.WinForms.NotateXpress9)

This class is used to create Button annotations.

For a list of all members of this type, see ButtonToolbarDefaults members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.NotateXpress9.BaseToolbarDefaults
PegasusImaging.WinForms.NotateXpress9.ButtonToolbarDefaults

Syntax

[Visual Basic]
Public Class ButtonToolbarDefaults
   Inherits BaseToolbarDefaults
[C#]
public class ButtonToolbarDefaults : BaseToolbarDefaults
[C++]
public __gc class ButtonToolbarDefaults : public BaseToolbarDefaults
[C++/CLI]
public ref class ButtonToolbarDefaults : public BaseToolbarDefaults

See Also

ButtonToolbarDefaults Members | PegasusImaging.WinForms.NotateXpress9 Namespace


ButtonToolbarDefaults Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ButtonToolbarDefaults Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : ButtonToolbarDefaults Class (PegasusImaging.WinForms.NotateXpress9)

ButtonToolbarDefaults overview

Public Constructors

Public Constructor ButtonToolbarDefaults Constructor Default constructor for the ButtonToolbarDefaults class.

Public Properties

Public Property AutoSize | This property sets or returns whether or not the annotation size will be automatically expanded to fit the given text within the Button annotation.
Public Property BackColor | This property sets or returns the color of the backgroud used within the Button annotation.
Public Property BevelLightColor | This property sets or returns the color of the bevel light used to draw the border around the Button annotation .
Public Property BevelShadowColor | This property sets or returns the color of the bevel shadow used within the Button annotation.
Public Property Fixed (Inherited from BaseToolbarDefaults) | Gets and sets whether an element is tied to the view instead of the image.
Public Property Locked (Inherited from BaseToolbarDefaults) | Gets and sets an indicator to lock an element so it cannot be selected or moved by a user in Edit mode.
Public Property Moveable (Inherited from BaseToolbarDefaults) | Gets and sets whether an element can be moved interactively during EditMode.
Public Property PenWidth | This property sets or returns the width of the pen used to draw the Button annotation.
Public Property Selected (Inherited from BaseToolbarDefaults) | Gets and sets whether an element is automatically selected.
Public Property ShowHandles (Inherited from BaseToolbarDefaults) | Gets and sets whether selection handles are displayed for an element.
Public Property Sizeable (Inherited from BaseToolbarDefaults) | Gets and sets whether an element can be sized interactively during EditMode.
Public Property Text | This property sets or returns the string value used within the Button annotation.
Public Property TextColor | This property sets or returns the color of the text used within the Button annotation.
Public Property TextFont | This property sets or returns the font of the text used within the Button annotation.
Public Property ToolTipText (Inherited from BaseToolbarDefaults) | Gets or sets a string value in the element that will become the ToolTipText value associated with the annotation once it is created.
Public Property UserLong (Inherited from BaseToolbarDefaults) | Gets and sets a long value in the element that will become the UserLong value associated with the element once it is created.
Public Property UserString (Inherited from BaseToolbarDefaults) | Gets and sets a string value in the element that will become the UserString value associated with the object once it is created.
Public Property Visible (Inherited from BaseToolbarDefaults) | Gets and sets the Visible attribute of an element.

See Also

ButtonToolbarDefaults Class | PegasusImaging.WinForms.NotateXpress9 Namespace


ButtonToolbarDefaults Constructor

ButtonToolbarDefaults Class | ButtonToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ButtonToolbarDefaults Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > ButtonToolbarDefaults Class : ButtonToolbarDefaults Constructor (ButtonToolbarDefaults)

Default constructor for the ButtonToolbarDefaults class.

[Visual Basic]
Public Function New()
[C#]
public ButtonToolbarDefaults();
[C++]
public: ButtonToolbarDefaults();
[C++/CLI]
public:
ButtonToolbarDefaults();

See Also

ButtonToolbarDefaults Class | ButtonToolbarDefaults Members


ButtonToolbarDefaults Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ButtonToolbarDefaults Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : ButtonToolbarDefaults Class (PegasusImaging.WinForms.NotateXpress9)

For a list of all members of this type, see ButtonToolbarDefaults members.

Public Properties

Public Property AutoSize | This property sets or returns whether or not the annotation size will be automatically expanded to fit the given text within the Button annotation.
Public Property BackColor | This property sets or returns the color of the backgroud used within the Button annotation.
Public Property BevelLightColor | This property sets or returns the color of the bevel light used to draw the border around the Button annotation .
Public Property BevelShadowColor | This property sets or returns the color of the bevel shadow used within the Button annotation.
Public Property Fixed (Inherited from BaseToolbarDefaults) | Gets and sets whether an element is tied to the view instead of the image.
Public Property Locked (Inherited from BaseToolbarDefaults) | Gets and sets an indicator to lock an element so it cannot be selected or moved by a user in Edit mode.
Public Property Moveable (Inherited from BaseToolbarDefaults) | Gets and sets whether an element can be moved interactively during EditMode.
Public Property PenWidth | This property sets or returns the width of the pen used to draw the Button annotation.
Public Property Selected (Inherited from BaseToolbarDefaults) | Gets and sets whether an element is automatically selected.
Public Property ShowHandles (Inherited from BaseToolbarDefaults) | Gets and sets whether selection handles are displayed for an element.
Public Property Sizeable (Inherited from BaseToolbarDefaults) | Gets and sets whether an element can be sized interactively during EditMode.
Public Property Text | This property sets or returns the string value used within the Button annotation.
Public Property TextColor | This property sets or returns the color of the text used within the Button annotation.
Public Property TextFont | This property sets or returns the font of the text used within the Button annotation.
Public Property ToolTipText (Inherited from BaseToolbarDefaults) | Gets or sets a string value in the element that will become the ToolTipText value associated with the annotation once it is created.
Public Property UserLong (Inherited from BaseToolbarDefaults) | Gets and sets a long value in the element that will become the UserLong value associated with the element once it is created.
Public Property UserString (Inherited from BaseToolbarDefaults) | Gets and sets a string value in the element that will become the UserString value associated with the object once it is created.
Public Property Visible (Inherited from BaseToolbarDefaults) | Gets and sets the Visible attribute of an element.

See Also

ButtonToolbarDefaults Class | PegasusImaging.WinForms.NotateXpress9 Namespace


AutoSize Property

ButtonToolbarDefaults Class | ButtonToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

AutoSize Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ButtonToolbarDefaults Class : AutoSize Property (ButtonToolbarDefaults)

This property sets or returns whether or not the annotation size will be automatically expanded to fit the given text within the Button annotation.

[Visual Basic]
Public Property AutoSize As AutoSize
[C#]
public AutoSize AutoSize {get; set;}
[C++]
public: __property AutoSize get_AutoSize();
public: __property void set_AutoSize(
   AutoSize value
);
[C++/CLI]
public:
property AutoSize AutoSize {
   AutoSize get();
   void set (AutoSize value);
}

Value

The AutoSize value set.

Remarks

The default value is none.

The AutoSize attribute will tell the control to size the element based on the text displayed.

When AutoSize is turned on the control can not be manually Sized

See Also

ButtonToolbarDefaults Class | ButtonToolbarDefaults Members


BackColor Property

ButtonToolbarDefaults Class | ButtonToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BackColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ButtonToolbarDefaults Class : BackColor Property (ButtonToolbarDefaults)

This property sets or returns the color of the backgroud used within the Button annotation.

[Visual Basic]
Public Property BackColor As Color
[C#]
public Color BackColor {get; set;}
[C++]
public: __property Color get_BackColor();
public: __property void set_BackColor(
   Color value
);
[C++/CLI]
public:
property Color BackColor {
   Color get();
   void set (Color value);
}

Value

The Color value set.

See Also

ButtonToolbarDefaults Class | ButtonToolbarDefaults Members


BevelLightColor Property

ButtonToolbarDefaults Class | ButtonToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BevelLightColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ButtonToolbarDefaults Class : BevelLightColor Property (ButtonToolbarDefaults)

This property sets or returns the color of the bevel light used to draw the border around the Button annotation .

[Visual Basic]
Public Property BevelLightColor As Color
[C#]
public Color BevelLightColor {get; set;}
[C++]
public: __property Color get_BevelLightColor();
public: __property void set_BevelLightColor(
   Color value
);
[C++/CLI]
public:
property Color BevelLightColor {
   Color get();
   void set (Color value);
}

Value

A Color which represents the color value set.

See Also

ButtonToolbarDefaults Class | ButtonToolbarDefaults Members


BevelShadowColor Property

ButtonToolbarDefaults Class | ButtonToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BevelShadowColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ButtonToolbarDefaults Class : BevelShadowColor Property (ButtonToolbarDefaults)

This property sets or returns the color of the bevel shadow used within the Button annotation.

[Visual Basic]
Public Property BevelShadowColor As Color
[C#]
public Color BevelShadowColor {get; set;}
[C++]
public: __property Color get_BevelShadowColor();
public: __property void set_BevelShadowColor(
   Color value
);
[C++/CLI]
public:
property Color BevelShadowColor {
   Color get();
   void set (Color value);
}

See Also

ButtonToolbarDefaults Class | ButtonToolbarDefaults Members


PenWidth Property

ButtonToolbarDefaults Class | ButtonToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PenWidth Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ButtonToolbarDefaults Class : PenWidth Property (ButtonToolbarDefaults)

This property sets or returns the width of the pen used to draw the Button annotation.

[Visual Basic]
Public Property PenWidth As Integer
[C#]
public int PenWidth {get; set;}
[C++]
public: __property int get_PenWidth();
public: __property void set_PenWidth(
   int value
);
[C++/CLI]
public:
property int PenWidth {
   int get();
   void set (int value);
}

Value

An integer which represents the width in pixels.

Remarks

The default value is 4.

See Also

ButtonToolbarDefaults Class | ButtonToolbarDefaults Members


Text Property

ButtonToolbarDefaults Class | ButtonToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Text Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ButtonToolbarDefaults Class : Text Property (ButtonToolbarDefaults)

This property sets or returns the string value used within the Button annotation.

[Visual Basic]
Public Property Text As String
[C#]
public string Text {get; set;}
[C++]
public: __property string* get_Text();
public: __property void set_Text(
   string* value
);
[C++/CLI]
public:
property String^ Text {
   String^ get();
   void set (String^ value);
}

Value

A string value which is used within the button annotation.

Remarks

The default value is an empty string "".

See Also

ButtonToolbarDefaults Class | ButtonToolbarDefaults Members


TextColor Property

ButtonToolbarDefaults Class | ButtonToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TextColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ButtonToolbarDefaults Class : TextColor Property (ButtonToolbarDefaults)

This property sets or returns the color of the text used within the Button annotation.

[Visual Basic]
Public Property TextColor As Color
[C#]
public Color TextColor {get; set;}
[C++]
public: __property Color get_TextColor();
public: __property void set_TextColor(
   Color value
);
[C++/CLI]
public:
property Color TextColor {
   Color get();
   void set (Color value);
}

Value

A Color value which represents the color used to display text on the button annotation.

See Also

ButtonToolbarDefaults Class | ButtonToolbarDefaults Members


TextFont Property

ButtonToolbarDefaults Class | ButtonToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TextFont Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ButtonToolbarDefaults Class : TextFont Property (ButtonToolbarDefaults)

This property sets or returns the font of the text used within the Button annotation.

[Visual Basic]
Public Property TextFont As Font
[C#]
public Font TextFont {get; set;}
[C++]
public: __property Font* get_TextFont();
public: __property void set_TextFont(
   Font* value
);
[C++/CLI]
public:
property Font^ TextFont {
   Font^ get();
   void set (Font^ value);
}

Value

The text font.

See Also

ButtonToolbarDefaults Class | ButtonToolbarDefaults Members


ClickEventArgs Class

ClickEventArgs Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ClickEventArgs Class

PegasusImaging.WinForms.NotateXpress9 Namespace : ClickEventArgs Class

Raises when an annotation object is clicked in Interactive Mode.

For a list of all members of this type, see ClickEventArgs members.

Object Model

Inheritance Hierarchy

System.Object
System.EventArgs
PegasusImaging.WinForms.NotateXpress9.ClickEventArgs

Syntax

[Visual Basic]
Public Class ClickEventArgs
   Inherits EventArgs
[C#]
public class ClickEventArgs : EventArgs
[C++]
public __gc class ClickEventArgs : public EventArgs
[C++/CLI]
public ref class ClickEventArgs : public EventArgs

See Also

ClickEventArgs Members | PegasusImaging.WinForms.NotateXpress9 Namespace


ClickEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ClickEventArgs Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : ClickEventArgs Class

ClickEventArgs overview

Public Constructors

Public Constructor ClickEventArgs Constructor

Public Properties

Public Property Element | Gets the element for the click events.
Public Property Layer | Gets the layer for the click events.

See Also

ClickEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace


ClickEventArgs Constructor

ClickEventArgs Class | ClickEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ClickEventArgs Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > ClickEventArgs Class : ClickEventArgs Constructor (ClickEventArgs)
[Visual Basic]
Public Function New()
[C#]
public ClickEventArgs();
[C++]
public: ClickEventArgs();
[C++/CLI]
public:
ClickEventArgs();

See Also

ClickEventArgs Class | ClickEventArgs Members


ClickEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ClickEventArgs Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : ClickEventArgs Class

For a list of all members of this type, see ClickEventArgs members.

Public Properties

Public Property Element | Gets the element for the click events.
Public Property Layer | Gets the layer for the click events.

See Also

ClickEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Element Property

ClickEventArgs Class | ClickEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Element Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ClickEventArgs Class : Element Property (ClickEventArgs)

Gets the element for the click events.

[Visual Basic]
Public Property Element As Element
[C#]
public Element Element {get; set;}
[C++]
public: __property Element* get_Element();
public: __property void set_Element(
   Element* value
);
[C++/CLI]
public:
property Element^ Element {
   Element^ get();
   void set (Element^ value);
}

See Also

ClickEventArgs Class | ClickEventArgs Members


Layer Property

ClickEventArgs Class | ClickEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Layer Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ClickEventArgs Class : Layer Property (ClickEventArgs)

Gets the layer for the click events.

[Visual Basic]
Public Property Layer As Layer
[C#]
public Layer Layer {get; set;}
[C++]
public: __property Layer* get_Layer();
public: __property void set_Layer(
   Layer* value
);
[C++/CLI]
public:
property Layer^ Layer {
   Layer^ get();
   void set (Layer^ value);
}

See Also

ClickEventArgs Class | ClickEventArgs Members


ClipboardException Class

ClipboardException Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ClipboardException Class

PegasusImaging.WinForms.NotateXpress9 Namespace : ClipboardException Class

Exception class which is raised when there are errors with the clipboard.

For a list of all members of this type, see ClipboardException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.NotateXpress9.NotateXpressException
PegasusImaging.WinForms.NotateXpress9.ClipboardException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class ClipboardException
   Inherits NotateXpressException
   Implements ISerializable, _Exception
[C#]
[SerializableAttribute()]
public sealed class ClipboardException : NotateXpressException, ISerializable, _Exception
[C++]
[SerializableAttribute()]
public __gc __sealed class ClipboardException : public NotateXpressException, ISerializable, _Exception
[C++/CLI]
[SerializableAttribute()]
public ref class ClipboardException sealed : public NotateXpressException, ISerializable, _Exception

See Also

ClipboardException Members | PegasusImaging.WinForms.NotateXpress9 Namespace


ClipboardException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ClipboardException Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : ClipboardException Class

ClipboardException overview

Public Constructors

Public Constructor ClipboardException Constructor Overloaded. Main constructor for the ClipboardException class when there are errors with the clipboard.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

ClipboardException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


ClipboardException Constructor

ClipboardException Class | ClipboardException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ClipboardException Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > ClipboardException Class : ClipboardException Constructor (ClipboardException)

Main constructor for the ClipboardException class when there are errors with the clipboard.

Overload List

Main constructor for the ClipboardException class when there are errors with the clipboard.

[Visual Basic] Public Sub New()

[C#] public ClipboardException();

[C++] public ClipboardException();

[C++/CLI] public ClipboardException();

Exception which allows passing in an error number when there are errors with the clipboard.

[Visual Basic] Public Sub New(Integer)

[C#] public ClipboardException(int);

[C++] public ClipboardException(int);

[C++/CLI] public ClipboardException(int);

Exception which allows passing in a message when there are errors with the clipboard.

[Visual Basic] Public Sub New(String)

[C#] public ClipboardException(string);

[C++] public ClipboardException(string*);

[C++/CLI] public ClipboardException(String^);

Exception which allows passing in an error number and message when there are errors with the clipboard.

[Visual Basic] Public Sub New(Integer,String)

[C#] public ClipboardException(int,string);

[C++] public ClipboardException(int,string*);

[C++/CLI] public ClipboardException(int,String^);

Exception which allows passing in a message and inner exception when there are errors with the clipboard.

[Visual Basic] Public Sub New(String,Exception)

[C#] public ClipboardException(string,Exception);

[C++] public ClipboardException(string*,Exception*);

[C++/CLI] public ClipboardException(String^,Exception^);

See Also

ClipboardException Class | ClipboardException Members


ClipboardException Constructor()

ClipboardException Class | ClipboardException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ClipboardException Constructor()

PegasusImaging.WinForms.NotateXpress9 Namespace > ClipboardException Class > ClipboardException Constructor : ClipboardException Constructor()

Main constructor for the ClipboardException class when there are errors with the clipboard.

[Visual Basic]
Public Function New()
[C#]
public ClipboardException();
[C++]
public: ClipboardException();
[C++/CLI]
public:
ClipboardException();

See Also

ClipboardException Class | ClipboardException Members | Overload List


ClipboardException Constructor(Int32)

ClipboardException Class | ClipboardException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ClipboardException Constructor(Int32)

PegasusImaging.WinForms.NotateXpress9 Namespace > ClipboardException Class > ClipboardException Constructor : ClipboardException Constructor(Int32)

Exception which allows passing in an error number when there are errors with the clipboard.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public ClipboardException(
   int errorNumber
);
[C++]
public: ClipboardException(
   int errorNumber
)
[C++/CLI]
public:
ClipboardException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

ClipboardException Class | ClipboardException Members | Overload List


ClipboardException Constructor(Int32,String)

ClipboardException Class | ClipboardException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ClipboardException Constructor(Int32,String)

PegasusImaging.WinForms.NotateXpress9 Namespace > ClipboardException Class > ClipboardException Constructor : ClipboardException Constructor(Int32,String)

Exception which allows passing in an error number and message when there are errors with the clipboard.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public ClipboardException(
   int errorNumber,
   string message
);
[C++]
public: ClipboardException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
ClipboardException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

ClipboardException Class | ClipboardException Members | Overload List


ClipboardException Constructor(String)

ClipboardException Class | ClipboardException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ClipboardException Constructor(String)

PegasusImaging.WinForms.NotateXpress9 Namespace > ClipboardException Class > ClipboardException Constructor : ClipboardException Constructor(String)

Exception which allows passing in a message when there are errors with the clipboard.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public ClipboardException(
   string message
);
[C++]
public: ClipboardException(
   string* message
)
[C++/CLI]
public:
ClipboardException(
   String^ message
)

Parameters

message
A string which represents the message.

See Also

ClipboardException Class | ClipboardException Members | Overload List


ClipboardException Constructor(String,Exception)

ClipboardException Class | ClipboardException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ClipboardException Constructor(String,Exception)

PegasusImaging.WinForms.NotateXpress9 Namespace > ClipboardException Class > ClipboardException Constructor : ClipboardException Constructor(String,Exception)

Exception which allows passing in a message and inner exception when there are errors with the clipboard.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public ClipboardException(
   string message,
   Exception innerException
);
[C++]
public: ClipboardException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
ClipboardException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception.

See Also

ClipboardException Class | ClipboardException Members | Overload List


ContextMenuEventArgs Class

ContextMenuEventArgs Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ContextMenuEventArgs Class

PegasusImaging.WinForms.NotateXpress9 Namespace : ContextMenuEventArgs Class

Contains data for ContextMenu events.

For a list of all members of this type, see ContextMenuEventArgs members.

Object Model

Inheritance Hierarchy

System.Object
System.EventArgs
PegasusImaging.WinForms.NotateXpress9.ContextMenuEventArgs

Syntax

[Visual Basic]
Public Class ContextMenuEventArgs
   Inherits EventArgs
[C#]
public class ContextMenuEventArgs : EventArgs
[C++]
public __gc class ContextMenuEventArgs : public EventArgs
[C++/CLI]
public ref class ContextMenuEventArgs : public EventArgs

Remarks

This is fired in edit mode when the built in context menu is turned off

See Also

ContextMenuEventArgs Members | PegasusImaging.WinForms.NotateXpress9 Namespace


ContextMenuEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ContextMenuEventArgs Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : ContextMenuEventArgs Class

ContextMenuEventArgs overview

Public Constructors

Public Constructor ContextMenuEventArgs Constructor

Public Properties

Public Property Element | Gets the element that was clicked.
Public Property Layer | Gets the layer on which the element was clicked.

See Also

ContextMenuEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace


ContextMenuEventArgs Constructor

ContextMenuEventArgs Class | ContextMenuEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ContextMenuEventArgs Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > ContextMenuEventArgs Class : ContextMenuEventArgs Constructor (ContextMenuEventArgs)
[Visual Basic]
Public Function New()
[C#]
public ContextMenuEventArgs();
[C++]
public: ContextMenuEventArgs();
[C++/CLI]
public:
ContextMenuEventArgs();

See Also

ContextMenuEventArgs Class | ContextMenuEventArgs Members


ContextMenuEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ContextMenuEventArgs Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : ContextMenuEventArgs Class

For a list of all members of this type, see ContextMenuEventArgs members.

Public Properties

Public Property Element | Gets the element that was clicked.
Public Property Layer | Gets the layer on which the element was clicked.

See Also

ContextMenuEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Element Property

ContextMenuEventArgs Class | ContextMenuEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Element Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ContextMenuEventArgs Class : Element Property (ContextMenuEventArgs)

Gets the element that was clicked.

[Visual Basic]
Public Property Element As Element
[C#]
public Element Element {get; set;}
[C++]
public: __property Element* get_Element();
public: __property void set_Element(
   Element* value
);
[C++/CLI]
public:
property Element^ Element {
   Element^ get();
   void set (Element^ value);
}

See Also

ContextMenuEventArgs Class | ContextMenuEventArgs Members


Layer Property

ContextMenuEventArgs Class | ContextMenuEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Layer Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ContextMenuEventArgs Class : Layer Property (ContextMenuEventArgs)

Gets the layer on which the element was clicked.

[Visual Basic]
Public Property Layer As Layer
[C#]
public Layer Layer {get; set;}
[C++]
public: __property Layer* get_Layer();
public: __property void set_Layer(
   Layer* value
);
[C++/CLI]
public:
property Layer^ Layer {
   Layer^ get();
   void set (Layer^ value);
}

See Also

ContextMenuEventArgs Class | ContextMenuEventArgs Members


CurrentLayerChangeEventArgs Class

CurrentLayerChangeEventArgs Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

CurrentLayerChangeEventArgs Class

PegasusImaging.WinForms.NotateXpress9 Namespace : CurrentLayerChangeEventArgs Class

Contains event data for NotateXpress.CurrentLayerChange events.

For a list of all members of this type, see CurrentLayerChangeEventArgs members.

Object Model

Inheritance Hierarchy

System.Object
System.EventArgs
PegasusImaging.WinForms.NotateXpress9.CurrentLayerChangeEventArgs

Syntax

[Visual Basic]
Public Class CurrentLayerChangeEventArgs
   Inherits EventArgs
[C#]
public class CurrentLayerChangeEventArgs : EventArgs
[C++]
public __gc class CurrentLayerChangeEventArgs : public EventArgs
[C++/CLI]
public ref class CurrentLayerChangeEventArgs : public EventArgs

See Also

CurrentLayerChangeEventArgs Members | PegasusImaging.WinForms.NotateXpress9 Namespace


CurrentLayerChangeEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

CurrentLayerChangeEventArgs Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : CurrentLayerChangeEventArgs Class

CurrentLayerChangeEventArgs overview

Public Constructors

Public Constructor CurrentLayerChangeEventArgs Constructor

Public Properties

Public Property Layer Gets the layer that was changed to.

See Also

CurrentLayerChangeEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace


CurrentLayerChangeEventArgs Constructor

CurrentLayerChangeEventArgs Class | CurrentLayerChangeEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

CurrentLayerChangeEventArgs Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > CurrentLayerChangeEventArgs Class : CurrentLayerChangeEventArgs Constructor (CurrentLayerChangeEventArgs)
[Visual Basic]
Public Function New()
[C#]
public CurrentLayerChangeEventArgs();
[C++]
public: CurrentLayerChangeEventArgs();
[C++/CLI]
public:
CurrentLayerChangeEventArgs();

See Also

CurrentLayerChangeEventArgs Class | CurrentLayerChangeEventArgs Members


CurrentLayerChangeEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

CurrentLayerChangeEventArgs Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : CurrentLayerChangeEventArgs Class

For a list of all members of this type, see CurrentLayerChangeEventArgs members.

Public Properties

Public Property Layer Gets the layer that was changed to.

See Also

CurrentLayerChangeEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Layer Property

CurrentLayerChangeEventArgs Class | CurrentLayerChangeEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Layer Property

PegasusImaging.WinForms.NotateXpress9 Namespace > CurrentLayerChangeEventArgs Class : Layer Property (CurrentLayerChangeEventArgs)

Gets the layer that was changed to.

[Visual Basic]
Public Property Layer As Layer
[C#]
public Layer Layer {get; set;}
[C++]
public: __property Layer* get_Layer();
public: __property void set_Layer(
   Layer* value
);
[C++/CLI]
public:
property Layer^ Layer {
   Layer^ get();
   void set (Layer^ value);
}

Remarks

The Layer.

See Also

CurrentLayerChangeEventArgs Class | CurrentLayerChangeEventArgs Members


DoubleClickEventArgs Class

DoubleClickEventArgs Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

DoubleClickEventArgs Class

PegasusImaging.WinForms.NotateXpress9 Namespace : DoubleClickEventArgs Class

Contains event data for DoubleClick events in Interactive Mode.

For a list of all members of this type, see DoubleClickEventArgs members.

Object Model

Inheritance Hierarchy

System.Object
System.EventArgs
PegasusImaging.WinForms.NotateXpress9.DoubleClickEventArgs

Syntax

[Visual Basic]
Public Class DoubleClickEventArgs
   Inherits EventArgs
[C#]
public class DoubleClickEventArgs : EventArgs
[C++]
public __gc class DoubleClickEventArgs : public EventArgs
[C++/CLI]
public ref class DoubleClickEventArgs : public EventArgs

Remarks

The DoubleClick event is normally raised when an annotation object is double-clicked in Interactive Mode.

The DoubleClick is also sent when the NXPEditors property is false and you are in Edit Mode.

See Also

DoubleClickEventArgs Members | PegasusImaging.WinForms.NotateXpress9 Namespace


DoubleClickEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

DoubleClickEventArgs Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : DoubleClickEventArgs Class

DoubleClickEventArgs overview

Public Constructors

Public Constructor DoubleClickEventArgs Constructor

Public Properties

Public Property Element | Gets the element for the double click event.
Public Property Layer | Gets the layer for the double click event.

See Also

DoubleClickEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace


DoubleClickEventArgs Constructor

DoubleClickEventArgs Class | DoubleClickEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

DoubleClickEventArgs Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > DoubleClickEventArgs Class : DoubleClickEventArgs Constructor (DoubleClickEventArgs)
[Visual Basic]
Public Function New()
[C#]
public DoubleClickEventArgs();
[C++]
public: DoubleClickEventArgs();
[C++/CLI]
public:
DoubleClickEventArgs();

See Also

DoubleClickEventArgs Class | DoubleClickEventArgs Members


DoubleClickEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

DoubleClickEventArgs Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : DoubleClickEventArgs Class

For a list of all members of this type, see DoubleClickEventArgs members.

Public Properties

Public Property Element | Gets the element for the double click event.
Public Property Layer | Gets the layer for the double click event.

See Also

DoubleClickEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Element Property

DoubleClickEventArgs Class | DoubleClickEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Element Property

PegasusImaging.WinForms.NotateXpress9 Namespace > DoubleClickEventArgs Class : Element Property (DoubleClickEventArgs)

Gets the element for the double click event.

[Visual Basic]
Public Property Element As Element
[C#]
public Element Element {get; set;}
[C++]
public: __property Element* get_Element();
public: __property void set_Element(
   Element* value
);
[C++/CLI]
public:
property Element^ Element {
   Element^ get();
   void set (Element^ value);
}

See Also

DoubleClickEventArgs Class | DoubleClickEventArgs Members


Layer Property

DoubleClickEventArgs Class | DoubleClickEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Layer Property

PegasusImaging.WinForms.NotateXpress9 Namespace > DoubleClickEventArgs Class : Layer Property (DoubleClickEventArgs)

Gets the layer for the double click event.

[Visual Basic]
Public Property Layer As Layer
[C#]
public Layer Layer {get; set;}
[C++]
public: __property Layer* get_Layer();
public: __property void set_Layer(
   Layer* value
);
[C++/CLI]
public:
property Layer^ Layer {
   Layer^ get();
   void set (Layer^ value);
}

See Also

DoubleClickEventArgs Class | DoubleClickEventArgs Members


DroppedEventArgs Class

DroppedEventArgs Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

DroppedEventArgs Class

PegasusImaging.WinForms.NotateXpress9 Namespace : DroppedEventArgs Class

Contains event data for Dropped events.

This will be fired for unsupported XFDF annotations, such as sound and file attachment annotations

For a list of all members of this type, see DroppedEventArgs members.

Object Model

Inheritance Hierarchy

System.Object
System.EventArgs
PegasusImaging.WinForms.NotateXpress9.DroppedEventArgs

Syntax

[Visual Basic]
Public Class DroppedEventArgs
   Inherits EventArgs
[C#]
public class DroppedEventArgs : EventArgs
[C++]
public __gc class DroppedEventArgs : public EventArgs
[C++/CLI]
public ref class DroppedEventArgs : public EventArgs

See Also

DroppedEventArgs Members | PegasusImaging.WinForms.NotateXpress9 Namespace


DroppedEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

DroppedEventArgs Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : DroppedEventArgs Class

DroppedEventArgs overview

Public Constructors

Public Constructor DroppedEventArgs Constructor

Public Properties

Public Property DroppedData Gets the data for unsupported XFDF annotations, such as sound and fileattachment annotations.

See Also

DroppedEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace


DroppedEventArgs Constructor

DroppedEventArgs Class | DroppedEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

DroppedEventArgs Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > DroppedEventArgs Class : DroppedEventArgs Constructor (DroppedEventArgs)
[Visual Basic]
Public Function New()
[C#]
public DroppedEventArgs();
[C++]
public: DroppedEventArgs();
[C++/CLI]
public:
DroppedEventArgs();

See Also

DroppedEventArgs Class | DroppedEventArgs Members


DroppedEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

DroppedEventArgs Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : DroppedEventArgs Class

For a list of all members of this type, see DroppedEventArgs members.

Public Properties

Public Property DroppedData Gets the data for unsupported XFDF annotations, such as sound and fileattachment annotations.

See Also

DroppedEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace


DroppedData Property

DroppedEventArgs Class | DroppedEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

DroppedData Property

PegasusImaging.WinForms.NotateXpress9 Namespace > DroppedEventArgs Class : DroppedData Property

Gets the data for unsupported XFDF annotations, such as sound and fileattachment annotations.

[Visual Basic]
Public Property DroppedData As String
[C#]
public string DroppedData {get; set;}
[C++]
public: __property string* get_DroppedData();
public: __property void set_DroppedData(
   string* value
);
[C++/CLI]
public:
property String^ DroppedData {
   String^ get();
   void set (String^ value);
}

See Also

DroppedEventArgs Class | DroppedEventArgs Members


DuplicateItemException Class

DuplicateItemException Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

DuplicateItemException Class

PegasusImaging.WinForms.NotateXpress9 Namespace : DuplicateItemException Class

Exception class which is raised when there are duplicate items.

For a list of all members of this type, see DuplicateItemException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.NotateXpress9.NotateXpressException
PegasusImaging.WinForms.NotateXpress9.DuplicateItemException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class DuplicateItemException
   Inherits NotateXpressException
   Implements ISerializable, _Exception
[C#]
[SerializableAttribute()]
public sealed class DuplicateItemException : NotateXpressException, ISerializable, _Exception
[C++]
[SerializableAttribute()]
public __gc __sealed class DuplicateItemException : public NotateXpressException, ISerializable, _Exception
[C++/CLI]
[SerializableAttribute()]
public ref class DuplicateItemException sealed : public NotateXpressException, ISerializable, _Exception

See Also

DuplicateItemException Members | PegasusImaging.WinForms.NotateXpress9 Namespace


DuplicateItemException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

DuplicateItemException Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : DuplicateItemException Class

DuplicateItemException overview

Public Constructors

Public Constructor DuplicateItemException Constructor Overloaded. Main constructor for the DuplicateItemException class when there are duplicate items.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

DuplicateItemException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


DuplicateItemException Constructor

DuplicateItemException Class | DuplicateItemException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

DuplicateItemException Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > DuplicateItemException Class : DuplicateItemException Constructor (DuplicateItemException)

Main constructor for the DuplicateItemException class when there are duplicate items.

Overload List

Main constructor for the DuplicateItemException class when there are duplicate items.

[Visual Basic] Public Sub New()

[C#] public DuplicateItemException();

[C++] public DuplicateItemException();

[C++/CLI] public DuplicateItemException();

Exception which allows passing in an error number when there are duplicate items.

[Visual Basic] Public Sub New(Integer)

[C#] public DuplicateItemException(int);

[C++] public DuplicateItemException(int);

[C++/CLI] public DuplicateItemException(int);

Exception which allows passing in a message when there are duplicate items.

[Visual Basic] Public Sub New(String)

[C#] public DuplicateItemException(string);

[C++] public DuplicateItemException(string*);

[C++/CLI] public DuplicateItemException(String^);

Exception which allows passing in an error number and message when there are duplicate items.

[Visual Basic] Public Sub New(Integer,String)

[C#] public DuplicateItemException(int,string);

[C++] public DuplicateItemException(int,string*);

[C++/CLI] public DuplicateItemException(int,String^);

Exception which allows passing in a message and inner exception when there are duplicate items.

[Visual Basic] Public Sub New(String,Exception)

[C#] public DuplicateItemException(string,Exception);

[C++] public DuplicateItemException(string*,Exception*);

[C++/CLI] public DuplicateItemException(String^,Exception^);

See Also

DuplicateItemException Class | DuplicateItemException Members


DuplicateItemException Constructor()

DuplicateItemException Class | DuplicateItemException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

DuplicateItemException Constructor()

PegasusImaging.WinForms.NotateXpress9 Namespace > DuplicateItemException Class > DuplicateItemException Constructor : DuplicateItemException Constructor()

Main constructor for the DuplicateItemException class when there are duplicate items.

[Visual Basic]
Public Function New()
[C#]
public DuplicateItemException();
[C++]
public: DuplicateItemException();
[C++/CLI]
public:
DuplicateItemException();

See Also

DuplicateItemException Class | DuplicateItemException Members | Overload List


DuplicateItemException Constructor(Int32)

DuplicateItemException Class | DuplicateItemException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

DuplicateItemException Constructor(Int32)

PegasusImaging.WinForms.NotateXpress9 Namespace > DuplicateItemException Class > DuplicateItemException Constructor : DuplicateItemException Constructor(Int32)

Exception which allows passing in an error number when there are duplicate items.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public DuplicateItemException(
   int errorNumber
);
[C++]
public: DuplicateItemException(
   int errorNumber
)
[C++/CLI]
public:
DuplicateItemException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

DuplicateItemException Class | DuplicateItemException Members | Overload List


DuplicateItemException Constructor(Int32,String)

DuplicateItemException Class | DuplicateItemException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

DuplicateItemException Constructor(Int32,String)

PegasusImaging.WinForms.NotateXpress9 Namespace > DuplicateItemException Class > DuplicateItemException Constructor : DuplicateItemException Constructor(Int32,String)

Exception which allows passing in an error number and message when there are duplicate items.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public DuplicateItemException(
   int errorNumber,
   string message
);
[C++]
public: DuplicateItemException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
DuplicateItemException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

DuplicateItemException Class | DuplicateItemException Members | Overload List


DuplicateItemException Constructor(String)

DuplicateItemException Class | DuplicateItemException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

DuplicateItemException Constructor(String)

PegasusImaging.WinForms.NotateXpress9 Namespace > DuplicateItemException Class > DuplicateItemException Constructor : DuplicateItemException Constructor(String)

Exception which allows passing in a message when there are duplicate items.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public DuplicateItemException(
   string message
);
[C++]
public: DuplicateItemException(
   string* message
)
[C++/CLI]
public:
DuplicateItemException(
   String^ message
)

Parameters

message
A string which represents the message.

See Also

DuplicateItemException Class | DuplicateItemException Members | Overload List


DuplicateItemException Constructor(String,Exception)

DuplicateItemException Class | DuplicateItemException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

DuplicateItemException Constructor(String,Exception)

PegasusImaging.WinForms.NotateXpress9 Namespace > DuplicateItemException Class > DuplicateItemException Constructor : DuplicateItemException Constructor(String,Exception)

Exception which allows passing in a message and inner exception when there are duplicate items.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public DuplicateItemException(
   string message,
   Exception innerException
);
[C++]
public: DuplicateItemException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
DuplicateItemException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception.

See Also

DuplicateItemException Class | DuplicateItemException Members | Overload List


DuplicateMenuIdException Class

DuplicateMenuIdException Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

DuplicateMenuIdException Class

PegasusImaging.WinForms.NotateXpress9 Namespace : DuplicateMenuIdException Class

Exception class which is raised when there are errors with duplicate menu IDs.

For a list of all members of this type, see DuplicateMenuIdException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.NotateXpress9.NotateXpressException
PegasusImaging.WinForms.NotateXpress9.DuplicateMenuIdException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class DuplicateMenuIdException
   Inherits NotateXpressException
   Implements ISerializable, _Exception
[C#]
[SerializableAttribute()]
public sealed class DuplicateMenuIdException : NotateXpressException, ISerializable, _Exception
[C++]
[SerializableAttribute()]
public __gc __sealed class DuplicateMenuIdException : public NotateXpressException, ISerializable, _Exception
[C++/CLI]
[SerializableAttribute()]
public ref class DuplicateMenuIdException sealed : public NotateXpressException, ISerializable, _Exception

See Also

DuplicateMenuIdException Members | PegasusImaging.WinForms.NotateXpress9 Namespace


DuplicateMenuIdException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

DuplicateMenuIdException Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : DuplicateMenuIdException Class

DuplicateMenuIdException overview

Public Constructors

Public Constructor DuplicateMenuIdException Constructor Overloaded. Main constructor for the DuplicateMenuIdException class when there are errors with duplicate menu IDs.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

DuplicateMenuIdException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


DuplicateMenuIdException Constructor

DuplicateMenuIdException Class | DuplicateMenuIdException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

DuplicateMenuIdException Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > DuplicateMenuIdException Class : DuplicateMenuIdException Constructor (DuplicateMenuIdException)

Main constructor for the DuplicateMenuIdException class when there are errors with duplicate menu IDs.

Overload List

Main constructor for the DuplicateMenuIdException class when there are errors with duplicate menu IDs.

[Visual Basic] Public Sub New()

[C#] public DuplicateMenuIdException();

[C++] public DuplicateMenuIdException();

[C++/CLI] public DuplicateMenuIdException();

Exception which allows passing in an error number when there are errors with duplicate menu IDs.

[Visual Basic] Public Sub New(Integer)

[C#] public DuplicateMenuIdException(int);

[C++] public DuplicateMenuIdException(int);

[C++/CLI] public DuplicateMenuIdException(int);

Exception which allows passing in a message when there are errors with duplicate menu IDs.

[Visual Basic] Public Sub New(String)

[C#] public DuplicateMenuIdException(string);

[C++] public DuplicateMenuIdException(string*);

[C++/CLI] public DuplicateMenuIdException(String^);

Exception which allows passing in an error number and message when there are errors with duplicate menu IDs.

[Visual Basic] Public Sub New(Integer,String)

[C#] public DuplicateMenuIdException(int,string);

[C++] public DuplicateMenuIdException(int,string*);

[C++/CLI] public DuplicateMenuIdException(int,String^);

Exception which allows passing in a message and inner exception when there are errors with duplicate menu IDs.

[Visual Basic] Public Sub New(String,Exception)

[C#] public DuplicateMenuIdException(string,Exception);

[C++] public DuplicateMenuIdException(string*,Exception*);

[C++/CLI] public DuplicateMenuIdException(String^,Exception^);

See Also

DuplicateMenuIdException Class | DuplicateMenuIdException Members


DuplicateMenuIdException Constructor()

DuplicateMenuIdException Class | DuplicateMenuIdException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

DuplicateMenuIdException Constructor()

PegasusImaging.WinForms.NotateXpress9 Namespace > DuplicateMenuIdException Class > DuplicateMenuIdException Constructor : DuplicateMenuIdException Constructor()

Main constructor for the DuplicateMenuIdException class when there are errors with duplicate menu IDs.

[Visual Basic]
Public Function New()
[C#]
public DuplicateMenuIdException();
[C++]
public: DuplicateMenuIdException();
[C++/CLI]
public:
DuplicateMenuIdException();

See Also

DuplicateMenuIdException Class | DuplicateMenuIdException Members | Overload List


DuplicateMenuIdException Constructor(Int32)

DuplicateMenuIdException Class | DuplicateMenuIdException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

DuplicateMenuIdException Constructor(Int32)

PegasusImaging.WinForms.NotateXpress9 Namespace > DuplicateMenuIdException Class > DuplicateMenuIdException Constructor : DuplicateMenuIdException Constructor(Int32)

Exception which allows passing in an error number when there are errors with duplicate menu IDs.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public DuplicateMenuIdException(
   int errorNumber
);
[C++]
public: DuplicateMenuIdException(
   int errorNumber
)
[C++/CLI]
public:
DuplicateMenuIdException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

DuplicateMenuIdException Class | DuplicateMenuIdException Members | Overload List


DuplicateMenuIdException Constructor(Int32,String)

DuplicateMenuIdException Class | DuplicateMenuIdException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

DuplicateMenuIdException Constructor(Int32,String)

PegasusImaging.WinForms.NotateXpress9 Namespace > DuplicateMenuIdException Class > DuplicateMenuIdException Constructor : DuplicateMenuIdException Constructor(Int32,String)

Exception which allows passing in an error number and message when there are errors with duplicate menu IDs.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public DuplicateMenuIdException(
   int errorNumber,
   string message
);
[C++]
public: DuplicateMenuIdException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
DuplicateMenuIdException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

DuplicateMenuIdException Class | DuplicateMenuIdException Members | Overload List


DuplicateMenuIdException Constructor(String)

DuplicateMenuIdException Class | DuplicateMenuIdException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

DuplicateMenuIdException Constructor(String)

PegasusImaging.WinForms.NotateXpress9 Namespace > DuplicateMenuIdException Class > DuplicateMenuIdException Constructor : DuplicateMenuIdException Constructor(String)

Exception which allows passing in a message when there are errors with duplicate menu IDs.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public DuplicateMenuIdException(
   string message
);
[C++]
public: DuplicateMenuIdException(
   string* message
)
[C++/CLI]
public:
DuplicateMenuIdException(
   String^ message
)

Parameters

message
A string which represents the message.

See Also

DuplicateMenuIdException Class | DuplicateMenuIdException Members | Overload List


DuplicateMenuIdException Constructor(String,Exception)

DuplicateMenuIdException Class | DuplicateMenuIdException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

DuplicateMenuIdException Constructor(String,Exception)

PegasusImaging.WinForms.NotateXpress9 Namespace > DuplicateMenuIdException Class > DuplicateMenuIdException Constructor : DuplicateMenuIdException Constructor(String,Exception)

Exception which allows passing in a message and inner exception when there are errors with duplicate menu IDs.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public DuplicateMenuIdException(
   string message,
   Exception innerException
);
[C++]
public: DuplicateMenuIdException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
DuplicateMenuIdException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception.

See Also

DuplicateMenuIdException Class | DuplicateMenuIdException Members | Overload List


Element Class

Element Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Element Class

PegasusImaging.WinForms.NotateXpress9 Namespace : Element Class (PegasusImaging.WinForms.NotateXpress9)

This class defines attributes of NotateXpress element objects.

For a list of all members of this type, see Element members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.NotateXpress9.Element
PegasusImaging.WinForms.NotateXpress9.BlockHighlightTool
PegasusImaging.WinForms.NotateXpress9.ButtonTool
PegasusImaging.WinForms.NotateXpress9.EllipseTool
PegasusImaging.WinForms.NotateXpress9.FreeHandTool
PegasusImaging.WinForms.NotateXpress9.ImageTool
PegasusImaging.WinForms.NotateXpress9.LineTool
PegasusImaging.WinForms.NotateXpress9.NoteTool
PegasusImaging.WinForms.NotateXpress9.PolygonTool
PegasusImaging.WinForms.NotateXpress9.PolyLineTool
PegasusImaging.WinForms.NotateXpress9.RectangleTool
PegasusImaging.WinForms.NotateXpress9.RulerTool
PegasusImaging.WinForms.NotateXpress9.StampTool
PegasusImaging.WinForms.NotateXpress9.TextTool

Syntax

[Visual Basic]
Public Class Element
[C#]
public class Element
[C++]
public __gc class Element
[C++/CLI]
public ref class Element

Remarks

Note: Before an element is added to an element collection it must be using a valid layer that was added to the LayerCollection.

Some methods rely on the element being a part of the element collection. If they are called, an ObjectNotConnectedException is raised.

See Also

Element Members | PegasusImaging.WinForms.NotateXpress9 Namespace


Element Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Element Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : Element Class (PegasusImaging.WinForms.NotateXpress9)

Element overview

Public Constructors

Public Constructor Element Constructor The base constructor for the Element class.

Public Properties

Public Property BoundingRectangle | Gets and sets the rectangle boundary for the element.
Public Property CreateTime | A Read only property that gets the time when the element was created.
Public Property Fixed | Gets and sets whether an annotation has a fixed position with respect to the control window.
Public Property GroupMember | Gets the group which the element belongs to.
Public Property IsGroupMember | A read only property that gets a value which determines if the element is a member of a group or not.
Public Property Locked | Gets and sets an indicator whether an annotation element can be selected or moved by a user in Edit mode.
Public Property Moveable | Gets and sets whether the element can be moved by a user in Edit mode.
Public Property NumberPoints | A Read only property that gets the number of points currently used to define the element.
Public Property Selected | Gets and sets whether the element has been selected.
Public Property ShowHandles | Gets and sets whether selection handles are displayed on an object when it is selected.
Public Property Sizeable | Gets and sets whether the element can be resized.
Public Property ToolTipText | Gets and sets a string value in the element that will become the ToolTipText value associated with the element.
Public Property UserLong | Gets and sets a user defined long value associated with the element.
Public Property UserString | Gets and sets a user-defined string associated with the element.
Public Property Visible | Gets and sets whether the element is visible.

Public Methods

Public Method NudgeDown | Moves the specified annotation object one level down, towards the back, in the painting order of the specified layer.
Public Method NudgeUp | Moves the specified annotation object one level up, towards the front, in the painting order of the specified layer.
Public Method UserDataAdd | User data can be added to each element in a key value pair.
Public Method UserDataDelete | User data can be added to each element in a key value pair.
Public Method UserDataFind | User data can be added to each element in a key value pair.
Public Method UserDataFindFirst | User data can be added to each element in a key value pair.
Public Method UserDataFindNext | User data can be added to each element in a key value pair.

See Also

Element Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Element Constructor

Element Class | Element Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Element Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > Element Class : Element Constructor (Element)

The base constructor for the Element class.

[Visual Basic]
Public Function New()
[C#]
public Element();
[C++]
public: Element();
[C++/CLI]
public:
Element();

See Also

Element Class | Element Members


NudgeDown Method

Element Class | Element Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NudgeDown Method

PegasusImaging.WinForms.NotateXpress9 Namespace > Element Class : NudgeDown Method

Moves the specified annotation object one level down, towards the back, in the painting order of the specified layer.

[Visual Basic]
Public Sub NudgeDown()
[C#]
public void NudgeDown();
[C++]
public: void NudgeDown();
[C++/CLI]
public:
void NudgeDown();

Remarks

Use this method to display the moved element "behind" or "under"other annotation objects that may overlap this one.

See Also

Element Class | Element Members


NudgeUp Method

Element Class | Element Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NudgeUp Method

PegasusImaging.WinForms.NotateXpress9 Namespace > Element Class : NudgeUp Method

Moves the specified annotation object one level up, towards the front, in the painting order of the specified layer.

[Visual Basic]
Public Sub NudgeUp()
[C#]
public void NudgeUp();
[C++]
public: void NudgeUp();
[C++/CLI]
public:
void NudgeUp();

Remarks

Use this to display the moved element "in front of" or "on top of" other annotation objects that may overlap this one.

See Also

Element Class | Element Members


UserDataAdd Method

Element Class | Element Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

key
A string value which represents the new key.
newVal
A string value which represents the new value.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

UserDataAdd Method

PegasusImaging.WinForms.NotateXpress9 Namespace > Element Class : UserDataAdd Method (Element)

User data can be added to each element in a key value pair.

[Visual Basic]
Public Sub UserDataAdd( _
   ByVal key As String, _
   ByVal newVal As String _
)
[C#]
public void UserDataAdd(
   string key,
   string newVal
);
[C++]
public: void UserDataAdd(
   string* key,
   string* newVal
)
[C++/CLI]
public:
void UserDataAdd(
   String^ key,
   String^ newVal
)

Parameters

key
A string value which represents the new key.
newVal
A string value which represents the new value.

Remarks

This method adds in a new key value pair.

See Also

Element Class | Element Members


UserDataDelete Method

Element Class | Element Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

key
A string value which represents the key to remove.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

UserDataDelete Method

PegasusImaging.WinForms.NotateXpress9 Namespace > Element Class : UserDataDelete Method (Element)

User data can be added to each element in a key value pair.

[Visual Basic]
Public Sub UserDataDelete( _
   ByVal key As String _
)
[C#]
public void UserDataDelete(
   string key
);
[C++]
public: void UserDataDelete(
   string* key
)
[C++/CLI]
public:
void UserDataDelete(
   String^ key
)

Parameters

key
A string value which represents the key to remove.

Remarks

This method removes an existing key value pair for the entered key.

See Also

Element Class | Element Members


UserDataFind Method

Element Class | Element Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

key
A string value which represents the user data key to search for.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

UserDataFind Method

PegasusImaging.WinForms.NotateXpress9 Namespace > Element Class : UserDataFind Method (Element)

User data can be added to each element in a key value pair.

[Visual Basic]
Public Function UserDataFind( _
   ByVal key As String _
) As String
[C#]
public string UserDataFind(
   string key
);
[C++]
public: string* UserDataFind(
   string* key
)
[C++/CLI]
public:
String^ UserDataFind(
   String^ key
)

Parameters

key
A string value which represents the user data key to search for.

Return Type

A string which represents the user data from the matching key.

Remarks

This method returns the value of an existing key.

See Also

Element Class | Element Members


UserDataFindFirst Method

Element Class | Element Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

key
A string value which represents the first key.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

UserDataFindFirst Method

PegasusImaging.WinForms.NotateXpress9 Namespace > Element Class : UserDataFindFirst Method (Element)

User data can be added to each element in a key value pair.

[Visual Basic]
Public Function UserDataFindFirst( _
   ByRef key As String _
) As String
[C#]
public string UserDataFindFirst(
   out string key
);
[C++]
public: string* UserDataFindFirst(
   [PARAMFLAG::Out] string* key
)
[C++/CLI]
public:
String^ UserDataFindFirst(
   [Out] String^ key
)

Parameters

key
A string value which represents the first key.

Return Type

A string which represents the first value from the matching key.

Remarks

This will find the first key value pair.

See Also

Element Class | Element Members


UserDataFindNext Method

Element Class | Element Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

key
A string value which represents the next key.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

UserDataFindNext Method

PegasusImaging.WinForms.NotateXpress9 Namespace > Element Class : UserDataFindNext Method (Element)

User data can be added to each element in a key value pair.

[Visual Basic]
Public Function UserDataFindNext( _
   ByRef key As String _
) As String
[C#]
public string UserDataFindNext(
   out string key
);
[C++]
public: string* UserDataFindNext(
   [PARAMFLAG::Out] string* key
)
[C++/CLI]
public:
String^ UserDataFindNext(
   [Out] String^ key
)

Parameters

key
A string value which represents the next key.

Return Type

A string which represents the next value from the matching key.

Remarks

The returned value from this method is the next key value pair, in the list.

See Also

Element Class | Element Members


Element Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Element Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : Element Class (PegasusImaging.WinForms.NotateXpress9)

For a list of all members of this type, see Element members.

Public Properties

Public Property BoundingRectangle | Gets and sets the rectangle boundary for the element.
Public Property CreateTime | A Read only property that gets the time when the element was created.
Public Property Fixed | Gets and sets whether an annotation has a fixed position with respect to the control window.
Public Property GroupMember | Gets the group which the element belongs to.
Public Property IsGroupMember | A read only property that gets a value which determines if the element is a member of a group or not.
Public Property Locked | Gets and sets an indicator whether an annotation element can be selected or moved by a user in Edit mode.
Public Property Moveable | Gets and sets whether the element can be moved by a user in Edit mode.
Public Property NumberPoints | A Read only property that gets the number of points currently used to define the element.
Public Property Selected | Gets and sets whether the element has been selected.
Public Property ShowHandles | Gets and sets whether selection handles are displayed on an object when it is selected.
Public Property Sizeable | Gets and sets whether the element can be resized.
Public Property ToolTipText | Gets and sets a string value in the element that will become the ToolTipText value associated with the element.
Public Property UserLong | Gets and sets a user defined long value associated with the element.
Public Property UserString | Gets and sets a user-defined string associated with the element.
Public Property Visible | Gets and sets whether the element is visible.

See Also

Element Class | PegasusImaging.WinForms.NotateXpress9 Namespace


BoundingRectangle Property

Element Class | Element Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BoundingRectangle Property

PegasusImaging.WinForms.NotateXpress9 Namespace > Element Class : BoundingRectangle Property

Gets and sets the rectangle boundary for the element.

[Visual Basic]
Public Property BoundingRectangle As Rectangle
[C#]
public Rectangle BoundingRectangle {get; set;}
[C++]
public: __property Rectangle get_BoundingRectangle();
public: __property void set_BoundingRectangle(
   Rectangle value
);
[C++/CLI]
public:
property Rectangle BoundingRectangle {
   Rectangle get();
   void set (Rectangle value);
}

Value

The Rectangle value which represents the rectangle boundary for the element set.

See Also

Element Class | Element Members


CreateTime Property

Element Class | Element Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

CreateTime Property

PegasusImaging.WinForms.NotateXpress9 Namespace > Element Class : CreateTime Property

A Read only property that gets the time when the element was created.

[Visual Basic]
Public ReadOnly Property CreateTime As Date
[C#]
public DateTime CreateTime {get;}
[C++]
public: __property DateTime get_CreateTime();
[C++/CLI]
public:
property DateTime CreateTime {
   DateTime get();
}

Value

The DateTime when the element was created.

See Also

Element Class | Element Members


Fixed Property

Element Class | Element Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Fixed Property

PegasusImaging.WinForms.NotateXpress9 Namespace > Element Class : Fixed Property (Element)

Gets and sets whether an annotation has a fixed position with respect to the control window.

[Visual Basic]
Public Property Fixed As Boolean
[C#]
public bool Fixed {get; set;}
[C++]
public: __property bool get_Fixed();
public: __property void set_Fixed(
   bool value
);
[C++/CLI]
public:
property bool Fixed {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true to fix an annotation to the window. Otherwise, false is returned.

Remarks

The default value is false.

A fixed annotation object has a fixed position with respect to the control window, regardless of the position of the image within the window. This is useful when viewing medical images, to ensure that annotations such as patient information are stationary in the view window when the image is navigated.

Note: When a fixed annotation is created outside of the current view, the user will never be able to see it.

If the scrollbars are on when the fixed annotation is created, factor in the position to be able to get back to the fixed annotation in the view.

For example: NotateXpress9.ElementSetBoudubg/rect e, ImagXpress9.ScrollX + 10, ImagXpress9.ScrollY + 10, ImagXpress9.ScrollX + 800, ImagXpress9.ScrollY + 100

See Also

Element Class | Element Members


GroupMember Property

Element Class | Element Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GroupMember Property

PegasusImaging.WinForms.NotateXpress9 Namespace > Element Class : GroupMember Property

Gets the group which the element belongs to.

[Visual Basic]
Public ReadOnly Property GroupMember As Group
[C#]
public Group GroupMember {get;}
[C++]
public: __property Group* get_GroupMember();
[C++/CLI]
public:
property Group^ GroupMember {
   Group^ get();
}

Value

The Group the element belongs to.

Remarks

The default value is null.

This property gets the Group that the element currently belongs to if it does belong to a group.

See Also

Element Class | Element Members


IsGroupMember Property

Element Class | Element Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

IsGroupMember Property

PegasusImaging.WinForms.NotateXpress9 Namespace > Element Class : IsGroupMember Property

A read only property that gets a value which determines if the element is a member of a group or not.

[Visual Basic]
Public ReadOnly Property IsGroupMember As Boolean
[C#]
public bool IsGroupMember {get;}
[C++]
public: __property bool get_IsGroupMember();
[C++/CLI]
public:
property bool IsGroupMember {
   bool get();
}

Value

A boolean value which is true if the element is a member of a group. Otherwise, false is returned.

See Also

Element Class | Element Members


Locked Property

Element Class | Element Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Locked Property

PegasusImaging.WinForms.NotateXpress9 Namespace > Element Class : Locked Property (Element)

Gets and sets an indicator whether an annotation element can be selected or moved by a user in Edit mode.

[Visual Basic]
Public Property Locked As Boolean
[C#]
public bool Locked {get; set;}
[C++]
public: __property bool get_Locked();
public: __property void set_Locked(
   bool value
);
[C++/CLI]
public:
property bool Locked {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true when the element is locked and cannot be selected or moved by a user in Edit mode. Otherwise, false is returned.

Remarks

The default value is false.

See Also

Element Class | Element Members


Moveable Property

Element Class | Element Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Moveable Property

PegasusImaging.WinForms.NotateXpress9 Namespace > Element Class : Moveable Property (Element)

Gets and sets whether the element can be moved by a user in Edit mode.

[Visual Basic]
Public Property Moveable As Boolean
[C#]
public bool Moveable {get; set;}
[C++]
public: __property bool get_Moveable();
public: __property void set_Moveable(
   bool value
);
[C++/CLI]
public:
property bool Moveable {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true if the element can be moved by a user in edit mode. Otherwise, false is returned.

Remarks

The default value is true.

See Also

Element Class | Element Members


NumberPoints Property

Element Class | Element Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NumberPoints Property

PegasusImaging.WinForms.NotateXpress9 Namespace > Element Class : NumberPoints Property

A Read only property that gets the number of points currently used to define the element.

[Visual Basic]
Public ReadOnly Property NumberPoints As Integer
[C#]
public int NumberPoints {get;}
[C++]
public: __property int get_NumberPoints();
[C++/CLI]
public:
property int NumberPoints {
   int get();
}

Value

An integer value which represents the number of points used to define the element.

See Also

Element Class | Element Members


Selected Property

Element Class | Element Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Selected Property

PegasusImaging.WinForms.NotateXpress9 Namespace > Element Class : Selected Property (Element)

Gets and sets whether the element has been selected.

[Visual Basic]
Public Property Selected As Boolean
[C#]
public bool Selected {get; set;}
[C++]
public: __property bool get_Selected();
public: __property void set_Selected(
   bool value
);
[C++/CLI]
public:
property bool Selected {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true if the element is selected. Otherwise, false is returned.

Remarks

The default value is false.

See Also

Element Class | Element Members


ShowHandles Property

Element Class | Element Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ShowHandles Property

PegasusImaging.WinForms.NotateXpress9 Namespace > Element Class : ShowHandles Property (Element)

Gets and sets whether selection handles are displayed on an object when it is selected.

[Visual Basic]
Public Property ShowHandles As Boolean
[C#]
public bool ShowHandles {get; set;}
[C++]
public: __property bool get_ShowHandles();
public: __property void set_ShowHandles(
   bool value
);
[C++/CLI]
public:
property bool ShowHandles {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true if selection handles are displayed. Otherwise, false is returned.

Remarks

The default value is true.

See Also

Element Class | Element Members


Sizeable Property

Element Class | Element Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Sizeable Property

PegasusImaging.WinForms.NotateXpress9 Namespace > Element Class : Sizeable Property (Element)

Gets and sets whether the element can be resized.

[Visual Basic]
Public Overridable Property Sizeable As Boolean
[C#]
public virtual bool Sizeable {get; set;}
[C++]
public: __property virtual bool get_Sizeable();
public: __property virtual void set_Sizeable(
   bool value
);
[C++/CLI]
public:
virtual property bool Sizeable {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true when the element is enabled to be resized. Otherwise, false is returned.

Remarks

The default value is true.

The Sizeable attribute of an annotation object determines whether or not an object can be sized interactively when the control is in AnnotationMode.Edit

See Also

Element Class | Element Members


ToolTipText Property

Element Class | Element Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToolTipText Property

PegasusImaging.WinForms.NotateXpress9 Namespace > Element Class : ToolTipText Property (Element)

Gets and sets a string value in the element that will become the ToolTipText value associated with the element.

[Visual Basic]
Public Property ToolTipText As String
[C#]
public string ToolTipText {get; set;}
[C++]
public: __property string* get_ToolTipText();
public: __property void set_ToolTipText(
   string* value
);
[C++/CLI]
public:
property String^ ToolTipText {
   String^ get();
   void set (String^ value);
}

Value

A string value which represents the tooltip text.

Remarks

The ToolTipText will display as a standard tool tip over the element.

See Also

Element Class | Element Members


UserLong Property

Element Class | Element Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

UserLong Property

PegasusImaging.WinForms.NotateXpress9 Namespace > Element Class : UserLong Property (Element)

Gets and sets a user defined long value associated with the element.

[Visual Basic]
Public Property UserLong As Integer
[C#]
public int UserLong {get; set;}
[C++]
public: __property int get_UserLong();
public: __property void set_UserLong(
   int value
);
[C++/CLI]
public:
property int UserLong {
   int get();
   void set (int value);
}

Value

An integer value which is associated with the element.

Remarks

The default value is 0.

See Also

Element Class | Element Members


UserString Property

Element Class | Element Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

UserString Property

PegasusImaging.WinForms.NotateXpress9 Namespace > Element Class : UserString Property (Element)

Gets and sets a user-defined string associated with the element.

[Visual Basic]
Public Property UserString As String
[C#]
public string UserString {get; set;}
[C++]
public: __property string* get_UserString();
public: __property void set_UserString(
   string* value
);
[C++/CLI]
public:
property String^ UserString {
   String^ get();
   void set (String^ value);
}

Value

A string value which is associated with the element.

Remarks

The default value is an empty string "".

See Also

Element Class | Element Members


Visible Property

Element Class | Element Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Visible Property

PegasusImaging.WinForms.NotateXpress9 Namespace > Element Class : Visible Property (Element)

Gets and sets whether the element is visible.

[Visual Basic]
Public Property Visible As Boolean
[C#]
public bool Visible {get; set;}
[C++]
public: __property bool get_Visible();
public: __property void set_Visible(
   bool value
);
[C++/CLI]
public:
property bool Visible {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true if the element is visible. Otherwise, false is returned.

Remarks

The default value is true.

See Also

Element Class | Element Members


ElementCollection Class

ElementCollection Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ElementCollection Class

PegasusImaging.WinForms.NotateXpress9 Namespace : ElementCollection Class

The base class that manages selected elements in a collection.

For a list of all members of this type, see ElementCollection members.

Object Model

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
PegasusImaging.WinForms.NotateXpress9.ElementCollection

Syntax

[Visual Basic]
<DefaultMemberAttribute("Item")>
Public Class ElementCollection
   Inherits CollectionBase
   Implements IList, ICollection, IEnumerable, IDisposable
[C#]
[DefaultMemberAttribute("Item")]
public class ElementCollection : CollectionBase, IList, ICollection, IEnumerable, IDisposable
[C++]
[DefaultMemberAttribute("Item")]
public __gc class ElementCollection : public CollectionBase, IList, ICollection, IEnumerable, IDisposable
[C++/CLI]
[DefaultMemberAttribute("Item")]
public ref class ElementCollection : public CollectionBase, IList, ICollection, IEnumerable, IDisposable

Remarks

Note: Before an element is added to an element collection it must be using a valid layer that was added to the LayerCollection.

Some methods rely on the element being part of the element collection. If they are called, an ObjectNotConnectedException is raised.

See Also

ElementCollection Members | PegasusImaging.WinForms.NotateXpress9 Namespace


ElementCollection Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ElementCollection Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : ElementCollection Class

ElementCollection overview

Public Properties

Public Property Capacity (Inherited from System.Collections.CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Public Property Count (Inherited from System.Collections.CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
Public Property IsPasteAvailable | A read only property that gets a value which determines if there are annotation elements available on the clipboard.
Public Property IsSelection | A read only property that gets a value which determines if there are elements selected in this element collection.
Public Property Item | Gets or sets the Element at the specified index.

Public Methods

Public Method Add | Adds the given element to the element collection.
Public Method BringToFront | Brings the selected elements to the front in the visual display order.
Public Method Clear | Clears the entire collection as well as calls the Clear function of the base class.
Public Method Contains | Determines if the collection contains the given Element.
Public Method Copy | Copies the currently selected elements to the clipboard.
Public Method CopyTo | Copies the entire collection to an array, starting at index of the target array.
Public Method Cut | Copies the currently selected elements to the clipboard and then deletes them from their original location.
Public Method DeleteSelected | Deletes all currently selected items from the collection.
Public Method Dispose | Releases all resources used by the ElementCollection object.
Public Method FirstSelected | Returns the first selected element in the collection.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) | Returns an enumerator that iterates through the CollectionBase instance.
Public Method IndexOf | Searches for the specified Element and returns the zero-based index of the first occurrence within the entire ElementCollection.
Public Method Insert | Inserts an Element at the specified index.
Public Method NextSelected | Returns the next selected element in the current layer.
Public Method Paste | Pastes the annotation elements from the clipboard into the current element collection.
Public Method Remove | Removes the given Element from the collection.
Public Method RemoveAt | Removes the element at the given index within the collection.
Public Method Reverse | Reverses the visual display order (z-order) of all the elements in the element collection.
Public Method SelectAll | Selects all the elements in the given collection.
Public Method SendToBack | Sends all selected elements in the collection to the back of the display order.

See Also

ElementCollection Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Add Method

ElementCollection Class | ElementCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

element
The Element to add to the collection.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Add Method

PegasusImaging.WinForms.NotateXpress9 Namespace > ElementCollection Class : Add Method (ElementCollection)

Adds the given element to the element collection.

[Visual Basic]
Public Function Add( _
   ByVal element As Element _
) As Integer
[C#]
public int Add(
   Element element
);
[C++]
public: int Add(
   Element* element
)
[C++/CLI]
public:
int Add(
   Element^ element
)

Parameters

element
The Element to add to the collection.

Return Type

An integer value which represents the index position of the newly added element.

Remarks

Note: Before an element is added to an element collection it must be using a valid layer that was added to the LayerCollection.

See Also

ElementCollection Class | ElementCollection Members


BringToFront Method

ElementCollection Class | ElementCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BringToFront Method

PegasusImaging.WinForms.NotateXpress9 Namespace > ElementCollection Class : BringToFront Method

Brings the selected elements to the front in the visual display order.

[Visual Basic]
Public Sub BringToFront()
[C#]
public void BringToFront();
[C++]
public: void BringToFront();
[C++/CLI]
public:
void BringToFront();

See Also

ElementCollection Class | ElementCollection Members


Clear Method

ElementCollection Class | ElementCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Clear Method

PegasusImaging.WinForms.NotateXpress9 Namespace > ElementCollection Class : Clear Method (ElementCollection)

Clears the entire collection as well as calls the Clear function of the base class.

[Visual Basic]
Public Sub Clear()
[C#]
public void Clear();
[C++]
public: void Clear();
[C++/CLI]
public:
void Clear();

See Also

ElementCollection Class | ElementCollection Members


Contains Method

ElementCollection Class | ElementCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

element
The element.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Contains Method

PegasusImaging.WinForms.NotateXpress9 Namespace > ElementCollection Class : Contains Method (ElementCollection)

Determines if the collection contains the given Element.

[Visual Basic]
Public Function Contains( _
   ByVal element As Element _
) As Boolean
[C#]
public bool Contains(
   Element element
);
[C++]
public: bool Contains(
   Element* element
)
[C++/CLI]
public:
bool Contains(
   Element^ element
)

Parameters

element
The element.

Return Type

true if the collection contains the specified Element; otherwise, false. Implements

See Also

ElementCollection Class | ElementCollection Members


Copy Method

ElementCollection Class | ElementCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Copy Method

PegasusImaging.WinForms.NotateXpress9 Namespace > ElementCollection Class : Copy Method (ElementCollection)

Copies the currently selected elements to the clipboard.

[Visual Basic]
Public Sub Copy()
[C#]
public void Copy();
[C++]
public: void Copy();
[C++/CLI]
public:
void Copy();

Remarks

Once these items are available on the clipboard they can be used elsewhere.

See Also

ElementCollection Class | ElementCollection Members


CopyTo Method

ElementCollection Class | ElementCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

array
The one-dimensional Array that is the destination of the elements copied from DocumentCollection. The Array must have zero-based indexing.
index
The zero-based index in array at which copying begins.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

CopyTo Method

PegasusImaging.WinForms.NotateXpress9 Namespace > ElementCollection Class : CopyTo Method (ElementCollection)

Copies the entire collection to an array, starting at index of the target array.

[Visual Basic]
Public Sub CopyTo( _
   ByVal array() As Element, _
   ByVal index As Integer _
)
[C#]
public void CopyTo(
   Element[] array,
   int index
);
[C++]
public: void CopyTo(
   Element*[]* array,
   int index
)
[C++/CLI]
public:
void CopyTo(
   Element^array<array>^ array,
   int index
)

Parameters

array
The one-dimensional Array that is the destination of the elements copied from DocumentCollection. The Array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

See Also

ElementCollection Class | ElementCollection Members


Cut Method

ElementCollection Class | ElementCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Cut Method

PegasusImaging.WinForms.NotateXpress9 Namespace > ElementCollection Class : Cut Method

Copies the currently selected elements to the clipboard and then deletes them from their original location.

[Visual Basic]
Public Sub Cut()
[C#]
public void Cut();
[C++]
public: void Cut();
[C++/CLI]
public:
void Cut();

Remarks

Once these items are available on the clipboard they can be used elsewhere.

See Also

ElementCollection Class | ElementCollection Members


DeleteSelected Method

ElementCollection Class | ElementCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

DeleteSelected Method

PegasusImaging.WinForms.NotateXpress9 Namespace > ElementCollection Class : DeleteSelected Method

Deletes all currently selected items from the collection.

[Visual Basic]
Public Sub DeleteSelected()
[C#]
public void DeleteSelected();
[C++]
public: void DeleteSelected();
[C++/CLI]
public:
void DeleteSelected();

Remarks

After all items are deleted in the collecion, the collection is reset to null.

See Also

ElementCollection Class | ElementCollection Members


Dispose Method

ElementCollection Class | ElementCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Dispose Method

PegasusImaging.WinForms.NotateXpress9 Namespace > ElementCollection Class : Dispose Method (ElementCollection)

Releases all resources used by the ElementCollection object.

[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();
[C++]
public: void Dispose();
[C++/CLI]
public:
void Dispose();

See Also

ElementCollection Class | ElementCollection Members


FirstSelected Method

ElementCollection Class | ElementCollection Members | NextSelected Method | Element Class

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

FirstSelected Method

PegasusImaging.WinForms.NotateXpress9 Namespace > ElementCollection Class : FirstSelected Method

Returns the first selected element in the collection.

[Visual Basic]
Public Function FirstSelected() As Element
[C#]
public Element FirstSelected();
[C++]
public: Element* FirstSelected();
[C++/CLI]
public:
Element^ FirstSelected();

Return Type

The first selected Element. If there are none, this method returns null.

Remarks

To retrieve the remaining selected items after calling this method, call the NextSelected method.

See Also

ElementCollection Class | ElementCollection Members | NextSelected Method | Element Class


IndexOf Method

ElementCollection Class | ElementCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

value
An Element to locate in the collection.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

IndexOf Method

PegasusImaging.WinForms.NotateXpress9 Namespace > ElementCollection Class : IndexOf Method (ElementCollection)

Searches for the specified Element and returns the zero-based index of the first occurrence within the entire ElementCollection.

[Visual Basic]
Public Function IndexOf( _
   ByVal value As Element _
) As Integer
[C#]
public int IndexOf(
   Element value
);
[C++]
public: int IndexOf(
   Element* value
)
[C++/CLI]
public:
int IndexOf(
   Element^ value
)

Parameters

value
An Element to locate in the collection.

See Also

ElementCollection Class | ElementCollection Members


Insert Method

ElementCollection Class | ElementCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

index
An integer value which represents the zero-based index at which the Element should be inserted.
element
The Element to insert into the collection.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Insert Method

PegasusImaging.WinForms.NotateXpress9 Namespace > ElementCollection Class : Insert Method (ElementCollection)

Inserts an Element at the specified index.

[Visual Basic]
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal element As Element _
)
[C#]
public void Insert(
   int index,
   Element element
);
[C++]
public: void Insert(
   int index,
   Element* element
)
[C++/CLI]
public:
void Insert(
   int index,
   Element^ element
)

Parameters

index
An integer value which represents the zero-based index at which the Element should be inserted.
element
The Element to insert into the collection.

See Also

ElementCollection Class | ElementCollection Members


NextSelected Method

ElementCollection Class | ElementCollection Members | Element Class | FirstSelected Method

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NextSelected Method

PegasusImaging.WinForms.NotateXpress9 Namespace > ElementCollection Class : NextSelected Method

Returns the next selected element in the current layer.

[Visual Basic]
Public Function NextSelected() As Element
[C#]
public Element NextSelected();
[C++]
public: Element* NextSelected();
[C++/CLI]
public:
Element^ NextSelected();

Return Type

The next selected Element in the collection. If there are no more items, null is returned.

Remarks

To initiate the sequence, call the FirstSelected method.

See Also

ElementCollection Class | ElementCollection Members | Element Class | FirstSelected Method


Paste Method

ElementCollection Class | ElementCollection Members | Cut Method | Copy Method

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Paste Method

PegasusImaging.WinForms.NotateXpress9 Namespace > ElementCollection Class : Paste Method (ElementCollection)

Pastes the annotation elements from the clipboard into the current element collection.

[Visual Basic]
Public Sub Paste()
[C#]
public void Paste();
[C++]
public: void Paste();
[C++/CLI]
public:
void Paste();

Remarks

Annotation elements are available for pasting when previously selected by using the Cut or Copy methods.

See Also

ElementCollection Class | ElementCollection Members | Cut Method | Copy Method


Remove Method

ElementCollection Class | ElementCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

element
The element.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Remove Method

PegasusImaging.WinForms.NotateXpress9 Namespace > ElementCollection Class : Remove Method (ElementCollection)

Removes the given Element from the collection.

[Visual Basic]
Public Sub Remove( _
   ByVal element As Element _
)
[C#]
public void Remove(
   Element element
);
[C++]
public: void Remove(
   Element* element
)
[C++/CLI]
public:
void Remove(
   Element^ element
)

Parameters

element
The element.

See Also

ElementCollection Class | ElementCollection Members


RemoveAt Method

ElementCollection Class | ElementCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

index
The zero-based index of the element to remove from the collection.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

RemoveAt Method

PegasusImaging.WinForms.NotateXpress9 Namespace > ElementCollection Class : RemoveAt Method (ElementCollection)

Removes the element at the given index within the collection.

[Visual Basic]
Public Sub RemoveAt( _
   ByVal index As Integer _
)
[C#]
public void RemoveAt(
   int index
);
[C++]
public: void RemoveAt(
   int index
)
[C++/CLI]
public:
void RemoveAt(
   int index
)

Parameters

index
The zero-based index of the element to remove from the collection.

See Also

ElementCollection Class | ElementCollection Members


Reverse Method

ElementCollection Class | ElementCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Reverse Method

PegasusImaging.WinForms.NotateXpress9 Namespace > ElementCollection Class : Reverse Method

Reverses the visual display order (z-order) of all the elements in the element collection.

[Visual Basic]
Public Sub Reverse()
[C#]
public void Reverse();
[C++]
public: void Reverse();
[C++/CLI]
public:
void Reverse();

See Also

ElementCollection Class | ElementCollection Members


SelectAll Method

ElementCollection Class | ElementCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

selection
A boolean value set to true for all the elements in the collection to be selected. Otherwise, false.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

SelectAll Method

PegasusImaging.WinForms.NotateXpress9 Namespace > ElementCollection Class : SelectAll Method

Selects all the elements in the given collection.

[Visual Basic]
Public Sub SelectAll( _
   ByVal selection As Boolean _
)
[C#]
public void SelectAll(
   bool selection
);
[C++]
public: void SelectAll(
   bool selection
)
[C++/CLI]
public:
void SelectAll(
   bool selection
)

Parameters

selection
A boolean value set to true for all the elements in the collection to be selected. Otherwise, false.

See Also

ElementCollection Class | ElementCollection Members


SendToBack Method

ElementCollection Class | ElementCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

SendToBack Method

PegasusImaging.WinForms.NotateXpress9 Namespace > ElementCollection Class : SendToBack Method

Sends all selected elements in the collection to the back of the display order.

[Visual Basic]
Public Sub SendToBack()
[C#]
public void SendToBack();
[C++]
public: void SendToBack();
[C++/CLI]
public:
void SendToBack();

See Also

ElementCollection Class | ElementCollection Members


ElementCollection Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ElementCollection Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : ElementCollection Class

For a list of all members of this type, see ElementCollection members.

Public Properties

Public Property Capacity (Inherited from System.Collections.CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Public Property Count (Inherited from System.Collections.CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
Public Property IsPasteAvailable | A read only property that gets a value which determines if there are annotation elements available on the clipboard.
Public Property IsSelection | A read only property that gets a value which determines if there are elements selected in this element collection.
Public Property Item | Gets or sets the Element at the specified index.

See Also

ElementCollection Class | PegasusImaging.WinForms.NotateXpress9 Namespace


IsPasteAvailable Property

ElementCollection Class | ElementCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

IsPasteAvailable Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ElementCollection Class : IsPasteAvailable Property (ElementCollection)

A read only property that gets a value which determines if there are annotation elements available on the clipboard.

[Visual Basic]
Public ReadOnly Property IsPasteAvailable As Boolean
[C#]
public bool IsPasteAvailable {get;}
[C++]
public: __property bool get_IsPasteAvailable();
[C++/CLI]
public:
property bool IsPasteAvailable {
   bool get();
}

Value

A boolean value which is true when there are elements available on the clipboard. Otherwise, false is returned.

See Also

ElementCollection Class | ElementCollection Members


IsSelection Property

ElementCollection Class | ElementCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

IsSelection Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ElementCollection Class : IsSelection Property

A read only property that gets a value which determines if there are elements selected in this element collection.

[Visual Basic]
Public ReadOnly Property IsSelection As Boolean
[C#]
public bool IsSelection {get;}
[C++]
public: __property bool get_IsSelection();
[C++/CLI]
public:
property bool IsSelection {
   bool get();
}

Value

A boolean value which is true if there are one or more elements selected in the collection. Otherwise, false is returned.

See Also

ElementCollection Class | ElementCollection Members


Item Property

ElementCollection Class | ElementCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

index
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Item Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ElementCollection Class : Item Property (ElementCollection)

Gets or sets the Element at the specified index.

[Visual Basic]
Public Default Property Item( _
   ByVal index As Integer _
) As Element
[C#]
public Element this[
   int index
]; {get; set;}
[C++]
public: __property Element* get_Item(
   int index
);
public: __property void set_Item(
   int index,
   Element* value
);
[C++/CLI]
public:
 property Element^ default [int] {
   Element^ get(int index);
   void set (int index, Element^ value);
}

Parameters

index

Value

An integer value which represents the zero-based index of the Element to access.

See Also

ElementCollection Class | ElementCollection Members


EllipseTool Class

EllipseTool Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

EllipseTool Class

PegasusImaging.WinForms.NotateXpress9 Namespace : EllipseTool Class

This class is used to create ellipse annotations.

For a list of all members of this type, see EllipseTool members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.NotateXpress9.Element
PegasusImaging.WinForms.NotateXpress9.EllipseTool

Syntax

[Visual Basic]
Public Class EllipseTool
   Inherits Element
[C#]
public class EllipseTool : Element
[C++]
public __gc class EllipseTool : public Element
[C++/CLI]
public ref class EllipseTool : public Element

See Also

EllipseTool Members | PegasusImaging.WinForms.NotateXpress9 Namespace


EllipseTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

EllipseTool Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : EllipseTool Class

EllipseTool overview

Public Constructors

Public Constructor EllipseTool Constructor The default constructor for the EllipseTool class.

Public Properties

Public Property BackStyle | Gets and sets the back style used by the ellipse tool.
Public Property BoundingRectangle (Inherited from Element) | Gets and sets the rectangle boundary for the element.
Public Property CreateTime (Inherited from Element) | A Read only property that gets the time when the element was created.
Public Property FillColor | Gets and sets the fill color used by the ellipse tool.
Public Property Fixed (Inherited from Element) | Gets and sets whether an annotation has a fixed position with respect to the control window.
Public Property GroupMember (Inherited from Element) | Gets the group which the element belongs to.
Public Property HatchColor | Gets and sets the hatch color used by the ellipse tool.
Public Property HatchStyle | Gets and sets the hatch style used by the ellipse tool.
Public Property IsGroupMember (Inherited from Element) | A read only property that gets a value which determines if the element is a member of a group or not.
Public Property Locked (Inherited from Element) | Gets and sets an indicator whether an annotation element can be selected or moved by a user in Edit mode.
Public Property Moveable (Inherited from Element) | Gets and sets whether the element can be moved by a user in Edit mode.
Public Property NumberPoints (Inherited from Element) | A Read only property that gets the number of points currently used to define the element.
Public Property PenColor | Gets and sets the color of the pen used by the ellipse tool.
Public Property PenWidth | Gets and sets the width of the pen, in pixels, used by the ellipse tool.
Public Property Selected (Inherited from Element) | Gets and sets whether the element has been selected.
Public Property ShowHandles (Inherited from Element) | Gets and sets whether selection handles are displayed on an object when it is selected.
Public Property Sizeable (Inherited from Element) | Gets and sets whether the element can be resized.
Public Property ToolTipText (Inherited from Element) | Gets and sets a string value in the element that will become the ToolTipText value associated with the element.
Public Property UserLong (Inherited from Element) | Gets and sets a user defined long value associated with the element.
Public Property UserString (Inherited from Element) | Gets and sets a user-defined string associated with the element.
Public Property Visible (Inherited from Element) | Gets and sets whether the element is visible.

Public Methods

Public Method NudgeDown (Inherited from Element) | Moves the specified annotation object one level down, towards the back, in the painting order of the specified layer.
Public Method NudgeUp (Inherited from Element) | Moves the specified annotation object one level up, towards the front, in the painting order of the specified layer.
Public Method UserDataAdd (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataDelete (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFind (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFindFirst (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFindNext (Inherited from Element) | User data can be added to each element in a key value pair.

See Also

EllipseTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace


EllipseTool Constructor

EllipseTool Class | EllipseTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

EllipseTool Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > EllipseTool Class : EllipseTool Constructor (EllipseTool)

The default constructor for the EllipseTool class.

[Visual Basic]
Public Function New()
[C#]
public EllipseTool();
[C++]
public: EllipseTool();
[C++/CLI]
public:
EllipseTool();

See Also

EllipseTool Class | EllipseTool Members


EllipseTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

EllipseTool Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : EllipseTool Class

For a list of all members of this type, see EllipseTool members.

Public Properties

Public Property BackStyle | Gets and sets the back style used by the ellipse tool.
Public Property BoundingRectangle (Inherited from Element) | Gets and sets the rectangle boundary for the element.
Public Property CreateTime (Inherited from Element) | A Read only property that gets the time when the element was created.
Public Property FillColor | Gets and sets the fill color used by the ellipse tool.
Public Property Fixed (Inherited from Element) | Gets and sets whether an annotation has a fixed position with respect to the control window.
Public Property GroupMember (Inherited from Element) | Gets the group which the element belongs to.
Public Property HatchColor | Gets and sets the hatch color used by the ellipse tool.
Public Property HatchStyle | Gets and sets the hatch style used by the ellipse tool.
Public Property IsGroupMember (Inherited from Element) | A read only property that gets a value which determines if the element is a member of a group or not.
Public Property Locked (Inherited from Element) | Gets and sets an indicator whether an annotation element can be selected or moved by a user in Edit mode.
Public Property Moveable (Inherited from Element) | Gets and sets whether the element can be moved by a user in Edit mode.
Public Property NumberPoints (Inherited from Element) | A Read only property that gets the number of points currently used to define the element.
Public Property PenColor | Gets and sets the color of the pen used by the ellipse tool.
Public Property PenWidth | Gets and sets the width of the pen, in pixels, used by the ellipse tool.
Public Property Selected (Inherited from Element) | Gets and sets whether the element has been selected.
Public Property ShowHandles (Inherited from Element) | Gets and sets whether selection handles are displayed on an object when it is selected.
Public Property Sizeable (Inherited from Element) | Gets and sets whether the element can be resized.
Public Property ToolTipText (Inherited from Element) | Gets and sets a string value in the element that will become the ToolTipText value associated with the element.
Public Property UserLong (Inherited from Element) | Gets and sets a user defined long value associated with the element.
Public Property UserString (Inherited from Element) | Gets and sets a user-defined string associated with the element.
Public Property Visible (Inherited from Element) | Gets and sets whether the element is visible.

See Also

EllipseTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace


BackStyle Property

EllipseTool Class | EllipseTool Members | BackStyle Property

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BackStyle Property

PegasusImaging.WinForms.NotateXpress9 Namespace > EllipseTool Class : BackStyle Property (EllipseTool)

Gets and sets the back style used by the ellipse tool.

[Visual Basic]
Public Property BackStyle As BackStyle
[C#]
public BackStyle BackStyle {get; set;}
[C++]
public: __property BackStyle get_BackStyle();
public: __property void set_BackStyle(
   BackStyle value
);
[C++/CLI]
public:
property BackStyle BackStyle {
   BackStyle get();
   void set (BackStyle value);
}

Value

The BackStyle enumeration value set.

See Also

EllipseTool Class | EllipseTool Members | BackStyle Property


FillColor Property

EllipseTool Class | EllipseTool Members | Color

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

FillColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > EllipseTool Class : FillColor Property (EllipseTool)

Gets and sets the fill color used by the ellipse tool.

[Visual Basic]
Public Property FillColor As Color
[C#]
public Color FillColor {get; set;}
[C++]
public: __property Color get_FillColor();
public: __property void set_FillColor(
   Color value
);
[C++/CLI]
public:
property Color FillColor {
   Color get();
   void set (Color value);
}

Value

The Color which represents the fill color used by the ellipse tool.

See Also

EllipseTool Class | EllipseTool Members | Color


HatchColor Property

EllipseTool Class | EllipseTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HatchColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > EllipseTool Class : HatchColor Property (EllipseTool)

Gets and sets the hatch color used by the ellipse tool.

[Visual Basic]
Public Property HatchColor As Color
[C#]
public Color HatchColor {get; set;}
[C++]
public: __property Color get_HatchColor();
public: __property void set_HatchColor(
   Color value
);
[C++/CLI]
public:
property Color HatchColor {
   Color get();
   void set (Color value);
}

Value

The Color value set.

See Also

EllipseTool Class | EllipseTool Members


HatchStyle Property

EllipseTool Class | EllipseTool Members | HatchStyle Property

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HatchStyle Property

PegasusImaging.WinForms.NotateXpress9 Namespace > EllipseTool Class : HatchStyle Property (EllipseTool)

Gets and sets the hatch style used by the ellipse tool.

[Visual Basic]
Public Property HatchStyle As HatchStyle
[C#]
public HatchStyle HatchStyle {get; set;}
[C++]
public: __property HatchStyle get_HatchStyle();
public: __property void set_HatchStyle(
   HatchStyle value
);
[C++/CLI]
public:
property HatchStyle HatchStyle {
   HatchStyle get();
   void set (HatchStyle value);
}

Value

The HatchStyle enumeration value set.

See Also

EllipseTool Class | EllipseTool Members | HatchStyle Property


PenColor Property

EllipseTool Class | EllipseTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PenColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > EllipseTool Class : PenColor Property (EllipseTool)

Gets and sets the color of the pen used by the ellipse tool.

[Visual Basic]
Public Property PenColor As Color
[C#]
public Color PenColor {get; set;}
[C++]
public: __property Color get_PenColor();
public: __property void set_PenColor(
   Color value
);
[C++/CLI]
public:
property Color PenColor {
   Color get();
   void set (Color value);
}

Value

The Color which represents the pen used by the ellipse tool.

Remarks

The default value is Blue.

See Also

EllipseTool Class | EllipseTool Members


PenWidth Property

EllipseTool Class | EllipseTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PenWidth Property

PegasusImaging.WinForms.NotateXpress9 Namespace > EllipseTool Class : PenWidth Property (EllipseTool)

Gets and sets the width of the pen, in pixels, used by the ellipse tool.

[Visual Basic]
Public Property PenWidth As Integer
[C#]
public int PenWidth {get; set;}
[C++]
public: __property int get_PenWidth();
public: __property void set_PenWidth(
   int value
);
[C++/CLI]
public:
property int PenWidth {
   int get();
   void set (int value);
}

Value

An integer value which represents the pen width.

Remarks

The default value is 1.

See Also

EllipseTool Class | EllipseTool Members


EllipseToolbarDefaults Class

EllipseToolbarDefaults Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

EllipseToolbarDefaults Class

PegasusImaging.WinForms.NotateXpress9 Namespace : EllipseToolbarDefaults Class (PegasusImaging.WinForms.NotateXpress9)

Implements the default toolbar values used to create Ellipse annotations.

For a list of all members of this type, see EllipseToolbarDefaults members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.NotateXpress9.BaseToolbarDefaults
PegasusImaging.WinForms.NotateXpress9.EllipseToolbarDefaults

Syntax

[Visual Basic]
Public Class EllipseToolbarDefaults
   Inherits BaseToolbarDefaults
[C#]
public class EllipseToolbarDefaults : BaseToolbarDefaults
[C++]
public __gc class EllipseToolbarDefaults : public BaseToolbarDefaults
[C++/CLI]
public ref class EllipseToolbarDefaults : public BaseToolbarDefaults

See Also

EllipseToolbarDefaults Members | PegasusImaging.WinForms.NotateXpress9 Namespace


EllipseToolbarDefaults Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

EllipseToolbarDefaults Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : EllipseToolbarDefaults Class (PegasusImaging.WinForms.NotateXpress9)

EllipseToolbarDefaults overview

Public Constructors

Public Constructor EllipseToolbarDefaults Constructor The default constructor for the EllipseToolbarDefaults class.

Public Properties

Public Property BackStyle | Gets and sets the style of the background used within the Ellipse annotation.
Public Property FillColor | Gets and sets the color of the fill used within the Ellipse annotation.
Public Property Fixed (Inherited from BaseToolbarDefaults) | Gets and sets whether an element is tied to the view instead of the image.
Public Property HatchColor | Gets and sets the color of the hatch style used within the Ellipse annotation.
Public Property HatchStyle | Gets and sets the hatch style used within the Ellipse annotation.
Public Property Locked (Inherited from BaseToolbarDefaults) | Gets and sets an indicator to lock an element so it cannot be selected or moved by a user in Edit mode.
Public Property Moveable (Inherited from BaseToolbarDefaults) | Gets and sets whether an element can be moved interactively during EditMode.
Public Property PenColor | Gets and sets the color of the pen used to draw the border around the Ellipse annotation.
Public Property PenWidth | Gets and sets the width of the pen, in pixels, used to draw the Ellipse annotation.
Public Property Selected (Inherited from BaseToolbarDefaults) | Gets and sets whether an element is automatically selected.
Public Property ShowHandles (Inherited from BaseToolbarDefaults) | Gets and sets whether selection handles are displayed for an element.
Public Property Sizeable (Inherited from BaseToolbarDefaults) | Gets and sets whether an element can be sized interactively during EditMode.
Public Property ToolTipText (Inherited from BaseToolbarDefaults) | Gets or sets a string value in the element that will become the ToolTipText value associated with the annotation once it is created.
Public Property UserLong (Inherited from BaseToolbarDefaults) | Gets and sets a long value in the element that will become the UserLong value associated with the element once it is created.
Public Property UserString (Inherited from BaseToolbarDefaults) | Gets and sets a string value in the element that will become the UserString value associated with the object once it is created.
Public Property Visible (Inherited from BaseToolbarDefaults) | Gets and sets the Visible attribute of an element.

See Also

EllipseToolbarDefaults Class | PegasusImaging.WinForms.NotateXpress9 Namespace


EllipseToolbarDefaults Constructor

EllipseToolbarDefaults Class | EllipseToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

EllipseToolbarDefaults Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > EllipseToolbarDefaults Class : EllipseToolbarDefaults Constructor (EllipseToolbarDefaults)

The default constructor for the EllipseToolbarDefaults class.

[Visual Basic]
Public Function New()
[C#]
public EllipseToolbarDefaults();
[C++]
public: EllipseToolbarDefaults();
[C++/CLI]
public:
EllipseToolbarDefaults();

See Also

EllipseToolbarDefaults Class | EllipseToolbarDefaults Members


EllipseToolbarDefaults Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

EllipseToolbarDefaults Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : EllipseToolbarDefaults Class (PegasusImaging.WinForms.NotateXpress9)

For a list of all members of this type, see EllipseToolbarDefaults members.

Public Properties

Public Property BackStyle | Gets and sets the style of the background used within the Ellipse annotation.
Public Property FillColor | Gets and sets the color of the fill used within the Ellipse annotation.
Public Property Fixed (Inherited from BaseToolbarDefaults) | Gets and sets whether an element is tied to the view instead of the image.
Public Property HatchColor | Gets and sets the color of the hatch style used within the Ellipse annotation.
Public Property HatchStyle | Gets and sets the hatch style used within the Ellipse annotation.
Public Property Locked (Inherited from BaseToolbarDefaults) | Gets and sets an indicator to lock an element so it cannot be selected or moved by a user in Edit mode.
Public Property Moveable (Inherited from BaseToolbarDefaults) | Gets and sets whether an element can be moved interactively during EditMode.
Public Property PenColor | Gets and sets the color of the pen used to draw the border around the Ellipse annotation.
Public Property PenWidth | Gets and sets the width of the pen, in pixels, used to draw the Ellipse annotation.
Public Property Selected (Inherited from BaseToolbarDefaults) | Gets and sets whether an element is automatically selected.
Public Property ShowHandles (Inherited from BaseToolbarDefaults) | Gets and sets whether selection handles are displayed for an element.
Public Property Sizeable (Inherited from BaseToolbarDefaults) | Gets and sets whether an element can be sized interactively during EditMode.
Public Property ToolTipText (Inherited from BaseToolbarDefaults) | Gets or sets a string value in the element that will become the ToolTipText value associated with the annotation once it is created.
Public Property UserLong (Inherited from BaseToolbarDefaults) | Gets and sets a long value in the element that will become the UserLong value associated with the element once it is created.
Public Property UserString (Inherited from BaseToolbarDefaults) | Gets and sets a string value in the element that will become the UserString value associated with the object once it is created.
Public Property Visible (Inherited from BaseToolbarDefaults) | Gets and sets the Visible attribute of an element.

See Also

EllipseToolbarDefaults Class | PegasusImaging.WinForms.NotateXpress9 Namespace


BackStyle Property

EllipseToolbarDefaults Class | EllipseToolbarDefaults Members | BackStyle Property

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BackStyle Property

PegasusImaging.WinForms.NotateXpress9 Namespace > EllipseToolbarDefaults Class : BackStyle Property (EllipseToolbarDefaults)

Gets and sets the style of the background used within the Ellipse annotation.

[Visual Basic]
Public Property BackStyle As BackStyle
[C#]
public BackStyle BackStyle {get; set;}
[C++]
public: __property BackStyle get_BackStyle();
public: __property void set_BackStyle(
   BackStyle value
);
[C++/CLI]
public:
property BackStyle BackStyle {
   BackStyle get();
   void set (BackStyle value);
}

Value

The BackStyle enumeration value set.

See Also

EllipseToolbarDefaults Class | EllipseToolbarDefaults Members | BackStyle Property


FillColor Property

EllipseToolbarDefaults Class | EllipseToolbarDefaults Members | Color

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

FillColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > EllipseToolbarDefaults Class : FillColor Property (EllipseToolbarDefaults)

Gets and sets the color of the fill used within the Ellipse annotation.

[Visual Basic]
Public Property FillColor As Color
[C#]
public Color FillColor {get; set;}
[C++]
public: __property Color get_FillColor();
public: __property void set_FillColor(
   Color value
);
[C++/CLI]
public:
property Color FillColor {
   Color get();
   void set (Color value);
}

Value

The Color value set.

See Also

EllipseToolbarDefaults Class | EllipseToolbarDefaults Members | Color


HatchColor Property

EllipseToolbarDefaults Class | EllipseToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HatchColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > EllipseToolbarDefaults Class : HatchColor Property (EllipseToolbarDefaults)

Gets and sets the color of the hatch style used within the Ellipse annotation.

[Visual Basic]
Public Property HatchColor As Color
[C#]
public Color HatchColor {get; set;}
[C++]
public: __property Color get_HatchColor();
public: __property void set_HatchColor(
   Color value
);
[C++/CLI]
public:
property Color HatchColor {
   Color get();
   void set (Color value);
}

Value

The Color value set.

Remarks

The HatchColor is the color of the hatch strokes on a filled object whose HatchStyle attribute is something other than HatchStyle.None.

See Also

EllipseToolbarDefaults Class | EllipseToolbarDefaults Members


HatchStyle Property

EllipseToolbarDefaults Class | EllipseToolbarDefaults Members | HatchStyle Property

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HatchStyle Property

PegasusImaging.WinForms.NotateXpress9 Namespace > EllipseToolbarDefaults Class : HatchStyle Property (EllipseToolbarDefaults)

Gets and sets the hatch style used within the Ellipse annotation.

[Visual Basic]
Public Property HatchStyle As HatchStyle
[C#]
public HatchStyle HatchStyle {get; set;}
[C++]
public: __property HatchStyle get_HatchStyle();
public: __property void set_HatchStyle(
   HatchStyle value
);
[C++/CLI]
public:
property HatchStyle HatchStyle {
   HatchStyle get();
   void set (HatchStyle value);
}

Value

The HatchStyle enumeration value set.

See Also

EllipseToolbarDefaults Class | EllipseToolbarDefaults Members | HatchStyle Property


PenColor Property

EllipseToolbarDefaults Class | EllipseToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PenColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > EllipseToolbarDefaults Class : PenColor Property (EllipseToolbarDefaults)

Gets and sets the color of the pen used to draw the border around the Ellipse annotation.

[Visual Basic]
Public Property PenColor As Color
[C#]
public Color PenColor {get; set;}
[C++]
public: __property Color get_PenColor();
public: __property void set_PenColor(
   Color value
);
[C++/CLI]
public:
property Color PenColor {
   Color get();
   void set (Color value);
}

Remarks

The default value is Blue.

See Also

EllipseToolbarDefaults Class | EllipseToolbarDefaults Members


PenWidth Property

EllipseToolbarDefaults Class | EllipseToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PenWidth Property

PegasusImaging.WinForms.NotateXpress9 Namespace > EllipseToolbarDefaults Class : PenWidth Property (EllipseToolbarDefaults)

Gets and sets the width of the pen, in pixels, used to draw the Ellipse annotation.

[Visual Basic]
Public Property PenWidth As Integer
[C#]
public int PenWidth {get; set;}
[C++]
public: __property int get_PenWidth();
public: __property void set_PenWidth(
   int value
);
[C++/CLI]
public:
property int PenWidth {
   int get();
   void set (int value);
}

Value

An integer value which represents the pen width in pixels.

Remarks

The default value is 1.

See Also

EllipseToolbarDefaults Class | EllipseToolbarDefaults Members


FileOpenException Class

FileOpenException Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

FileOpenException Class

PegasusImaging.WinForms.NotateXpress9 Namespace : FileOpenException Class

Exception class raised when there are errors opening files.

For a list of all members of this type, see FileOpenException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.NotateXpress9.NotateXpressException
PegasusImaging.WinForms.NotateXpress9.FileOpenException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class FileOpenException
   Inherits NotateXpressException
   Implements ISerializable, _Exception
[C#]
[SerializableAttribute()]
public sealed class FileOpenException : NotateXpressException, ISerializable, _Exception
[C++]
[SerializableAttribute()]
public __gc __sealed class FileOpenException : public NotateXpressException, ISerializable, _Exception
[C++/CLI]
[SerializableAttribute()]
public ref class FileOpenException sealed : public NotateXpressException, ISerializable, _Exception

See Also

FileOpenException Members | PegasusImaging.WinForms.NotateXpress9 Namespace


FileOpenException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

FileOpenException Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : FileOpenException Class

FileOpenException overview

Public Constructors

Public Constructor FileOpenException Constructor Overloaded. Main constructor for the FileOpenException class when there are errors opening files.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

FileOpenException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


FileOpenException Constructor

FileOpenException Class | FileOpenException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

FileOpenException Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > FileOpenException Class : FileOpenException Constructor (FileOpenException)

Main constructor for the FileOpenException class when there are errors opening files.

Overload List

Main constructor for the FileOpenException class when there are errors opening files.

[Visual Basic] Public Sub New()

[C#] public FileOpenException();

[C++] public FileOpenException();

[C++/CLI] public FileOpenException();

Exception which allows passing in an error number when there are errors opening files.

[Visual Basic] Public Sub New(Integer)

[C#] public FileOpenException(int);

[C++] public FileOpenException(int);

[C++/CLI] public FileOpenException(int);

Exception which allows passing in a message when there are errors opening files.

[Visual Basic] Public Sub New(String)

[C#] public FileOpenException(string);

[C++] public FileOpenException(string*);

[C++/CLI] public FileOpenException(String^);

Exception which allows passing in an error number and a message when there are errors opening files.

[Visual Basic] Public Sub New(Integer,String)

[C#] public FileOpenException(int,string);

[C++] public FileOpenException(int,string*);

[C++/CLI] public FileOpenException(int,String^);

Exception which allows passing in a message and inner exception when there are errors opening files.

[Visual Basic] Public Sub New(String,Exception)

[C#] public FileOpenException(string,Exception);

[C++] public FileOpenException(string*,Exception*);

[C++/CLI] public FileOpenException(String^,Exception^);

See Also

FileOpenException Class | FileOpenException Members


FileOpenException Constructor()

FileOpenException Class | FileOpenException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

FileOpenException Constructor()

PegasusImaging.WinForms.NotateXpress9 Namespace > FileOpenException Class > FileOpenException Constructor : FileOpenException Constructor()

Main constructor for the FileOpenException class when there are errors opening files.

[Visual Basic]
Public Function New()
[C#]
public FileOpenException();
[C++]
public: FileOpenException();
[C++/CLI]
public:
FileOpenException();

See Also

FileOpenException Class | FileOpenException Members | Overload List


FileOpenException Constructor(Int32)

FileOpenException Class | FileOpenException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

FileOpenException Constructor(Int32)

PegasusImaging.WinForms.NotateXpress9 Namespace > FileOpenException Class > FileOpenException Constructor : FileOpenException Constructor(Int32)

Exception which allows passing in an error number when there are errors opening files.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public FileOpenException(
   int errorNumber
);
[C++]
public: FileOpenException(
   int errorNumber
)
[C++/CLI]
public:
FileOpenException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

FileOpenException Class | FileOpenException Members | Overload List


FileOpenException Constructor(Int32,String)

FileOpenException Class | FileOpenException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

FileOpenException Constructor(Int32,String)

PegasusImaging.WinForms.NotateXpress9 Namespace > FileOpenException Class > FileOpenException Constructor : FileOpenException Constructor(Int32,String)

Exception which allows passing in an error number and a message when there are errors opening files.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public FileOpenException(
   int errorNumber,
   string message
);
[C++]
public: FileOpenException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
FileOpenException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

FileOpenException Class | FileOpenException Members | Overload List


FileOpenException Constructor(String)

FileOpenException Class | FileOpenException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

FileOpenException Constructor(String)

PegasusImaging.WinForms.NotateXpress9 Namespace > FileOpenException Class > FileOpenException Constructor : FileOpenException Constructor(String)

Exception which allows passing in a message when there are errors opening files.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public FileOpenException(
   string message
);
[C++]
public: FileOpenException(
   string* message
)
[C++/CLI]
public:
FileOpenException(
   String^ message
)

Parameters

message
A string which represents the message.

See Also

FileOpenException Class | FileOpenException Members | Overload List


FileOpenException Constructor(String,Exception)

FileOpenException Class | FileOpenException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

FileOpenException Constructor(String,Exception)

PegasusImaging.WinForms.NotateXpress9 Namespace > FileOpenException Class > FileOpenException Constructor : FileOpenException Constructor(String,Exception)

Exception which allows passing in a message and inner exception when there are errors opening files.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public FileOpenException(
   string message,
   Exception innerException
);
[C++]
public: FileOpenException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
FileOpenException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception.

See Also

FileOpenException Class | FileOpenException Members | Overload List


FileSecurityException Class

FileSecurityException Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

FileSecurityException Class

PegasusImaging.WinForms.NotateXpress9 Namespace : FileSecurityException Class

Exception class raised when the filename path or extension are not secure.

For a list of all members of this type, see FileSecurityException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.NotateXpress9.NotateXpressException
PegasusImaging.WinForms.NotateXpress9.FileSecurityException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class FileSecurityException
   Inherits NotateXpressException
   Implements ISerializable, _Exception
[C#]
[SerializableAttribute()]
public sealed class FileSecurityException : NotateXpressException, ISerializable, _Exception
[C++]
[SerializableAttribute()]
public __gc __sealed class FileSecurityException : public NotateXpressException, ISerializable, _Exception
[C++/CLI]
[SerializableAttribute()]
public ref class FileSecurityException sealed : public NotateXpressException, ISerializable, _Exception

See Also

FileSecurityException Members | PegasusImaging.WinForms.NotateXpress9 Namespace


FileSecurityException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

FileSecurityException Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : FileSecurityException Class

FileSecurityException overview

Public Constructors

Public Constructor FileSecurityException Constructor Overloaded. Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

FileSecurityException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


FileSecurityException Constructor

FileSecurityException Class | FileSecurityException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

FileSecurityException Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > FileSecurityException Class : FileSecurityException Constructor (FileSecurityException)

Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

Overload List

Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

[Visual Basic] Public Sub New()

[C#] public FileSecurityException();

[C++] public FileSecurityException();

[C++/CLI] public FileSecurityException();

Exception which allows passing in an error number when there are errors with the annotation files.

[Visual Basic] Public Sub New(Integer)

[C#] public FileSecurityException(int);

[C++] public FileSecurityException(int);

[C++/CLI] public FileSecurityException(int);

Exception which allows passing in a message when thee are errors with the annotation files.

[Visual Basic] Public Sub New(String)

[C#] public FileSecurityException(string);

[C++] public FileSecurityException(string*);

[C++/CLI] public FileSecurityException(String^);

Exception which allows passing in an error number and message when there are errors with the annotation files.

[Visual Basic] Public Sub New(Integer,String)

[C#] public FileSecurityException(int,string);

[C++] public FileSecurityException(int,string*);

[C++/CLI] public FileSecurityException(int,String^);

Exception which allows passing in a message and inner exception when there are errors with the annotation files.

[Visual Basic] Public Sub New(String,Exception)

[C#] public FileSecurityException(string,Exception);

[C++] public FileSecurityException(string*,Exception*);

[C++/CLI] public FileSecurityException(String^,Exception^);

See Also

FileSecurityException Class | FileSecurityException Members


FileSecurityException Constructor()

FileSecurityException Class | FileSecurityException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

FileSecurityException Constructor()

PegasusImaging.WinForms.NotateXpress9 Namespace > FileSecurityException Class > FileSecurityException Constructor : FileSecurityException Constructor()

Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

[Visual Basic]
Public Function New()
[C#]
public FileSecurityException();
[C++]
public: FileSecurityException();
[C++/CLI]
public:
FileSecurityException();

See Also

FileSecurityException Class | FileSecurityException Members | Overload List


FileSecurityException Constructor(Int32)

FileSecurityException Class | FileSecurityException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

FileSecurityException Constructor(Int32)

PegasusImaging.WinForms.NotateXpress9 Namespace > FileSecurityException Class > FileSecurityException Constructor : FileSecurityException Constructor(Int32)

Exception which allows passing in an error number when there are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public FileSecurityException(
   int errorNumber
);
[C++]
public: FileSecurityException(
   int errorNumber
)
[C++/CLI]
public:
FileSecurityException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

FileSecurityException Class | FileSecurityException Members | Overload List


FileSecurityException Constructor(Int32,String)

FileSecurityException Class | FileSecurityException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

FileSecurityException Constructor(Int32,String)

PegasusImaging.WinForms.NotateXpress9 Namespace > FileSecurityException Class > FileSecurityException Constructor : FileSecurityException Constructor(Int32,String)

Exception which allows passing in an error number and message when there are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public FileSecurityException(
   int errorNumber,
   string message
);
[C++]
public: FileSecurityException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
FileSecurityException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

FileSecurityException Class | FileSecurityException Members | Overload List


FileSecurityException Constructor(String)

FileSecurityException Class | FileSecurityException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

FileSecurityException Constructor(String)

PegasusImaging.WinForms.NotateXpress9 Namespace > FileSecurityException Class > FileSecurityException Constructor : FileSecurityException Constructor(String)

Exception which allows passing in a message when thee are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public FileSecurityException(
   string message
);
[C++]
public: FileSecurityException(
   string* message
)
[C++/CLI]
public:
FileSecurityException(
   String^ message
)

Parameters

message
A string which represents the message.

See Also

FileSecurityException Class | FileSecurityException Members | Overload List


FileSecurityException Constructor(String,Exception)

FileSecurityException Class | FileSecurityException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

FileSecurityException Constructor(String,Exception)

PegasusImaging.WinForms.NotateXpress9 Namespace > FileSecurityException Class > FileSecurityException Constructor : FileSecurityException Constructor(String,Exception)

Exception which allows passing in a message and inner exception when there are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public FileSecurityException(
   string message,
   Exception innerException
);
[C++]
public: FileSecurityException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
FileSecurityException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception.

See Also

FileSecurityException Class | FileSecurityException Members | Overload List


FileWriteException Class

FileWriteException Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

FileWriteException Class

PegasusImaging.WinForms.NotateXpress9 Namespace : FileWriteException Class

Exception class raised when there are errors writing to files.

For a list of all members of this type, see FileWriteException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.NotateXpress9.NotateXpressException
PegasusImaging.WinForms.NotateXpress9.FileWriteException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class FileWriteException
   Inherits NotateXpressException
   Implements ISerializable, _Exception
[C#]
[SerializableAttribute()]
public sealed class FileWriteException : NotateXpressException, ISerializable, _Exception
[C++]
[SerializableAttribute()]
public __gc __sealed class FileWriteException : public NotateXpressException, ISerializable, _Exception
[C++/CLI]
[SerializableAttribute()]
public ref class FileWriteException sealed : public NotateXpressException, ISerializable, _Exception

See Also

FileWriteException Members | PegasusImaging.WinForms.NotateXpress9 Namespace


FileWriteException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

FileWriteException Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : FileWriteException Class

FileWriteException overview

Public Constructors

Public Constructor FileWriteException Constructor Overloaded. Main constructor for the FileWriteException class when there are errors writing to files.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

FileWriteException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


FileWriteException Constructor

FileWriteException Class | FileWriteException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

FileWriteException Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > FileWriteException Class : FileWriteException Constructor (FileWriteException)

Main constructor for the FileWriteException class when there are errors writing to files.

Overload List

Main constructor for the FileWriteException class when there are errors writing to files.

[Visual Basic] Public Sub New()

[C#] public FileWriteException();

[C++] public FileWriteException();

[C++/CLI] public FileWriteException();

Exception which allows passing in an error number when there are errors writing to files.

[Visual Basic] Public Sub New(Integer)

[C#] public FileWriteException(int);

[C++] public FileWriteException(int);

[C++/CLI] public FileWriteException(int);

Exception which allows passing in a message when there are errors writing to files.

[Visual Basic] Public Sub New(String)

[C#] public FileWriteException(string);

[C++] public FileWriteException(string*);

[C++/CLI] public FileWriteException(String^);

Exception which allows passing in an error number and message when there are errors writing to files.

[Visual Basic] Public Sub New(Integer,String)

[C#] public FileWriteException(int,string);

[C++] public FileWriteException(int,string*);

[C++/CLI] public FileWriteException(int,String^);

Exception which allows passing in a message and inner exception when there are errors writing to files.

[Visual Basic] Public Sub New(String,Exception)

[C#] public FileWriteException(string,Exception);

[C++] public FileWriteException(string*,Exception*);

[C++/CLI] public FileWriteException(String^,Exception^);

See Also

FileWriteException Class | FileWriteException Members


FileWriteException Constructor()

FileWriteException Class | FileWriteException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

FileWriteException Constructor()

PegasusImaging.WinForms.NotateXpress9 Namespace > FileWriteException Class > FileWriteException Constructor : FileWriteException Constructor()

Main constructor for the FileWriteException class when there are errors writing to files.

[Visual Basic]
Public Function New()
[C#]
public FileWriteException();
[C++]
public: FileWriteException();
[C++/CLI]
public:
FileWriteException();

See Also

FileWriteException Class | FileWriteException Members | Overload List


FileWriteException Constructor(Int32)

FileWriteException Class | FileWriteException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

FileWriteException Constructor(Int32)

PegasusImaging.WinForms.NotateXpress9 Namespace > FileWriteException Class > FileWriteException Constructor : FileWriteException Constructor(Int32)

Exception which allows passing in an error number when there are errors writing to files.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public FileWriteException(
   int errorNumber
);
[C++]
public: FileWriteException(
   int errorNumber
)
[C++/CLI]
public:
FileWriteException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

FileWriteException Class | FileWriteException Members | Overload List


FileWriteException Constructor(Int32,String)

FileWriteException Class | FileWriteException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

FileWriteException Constructor(Int32,String)

PegasusImaging.WinForms.NotateXpress9 Namespace > FileWriteException Class > FileWriteException Constructor : FileWriteException Constructor(Int32,String)

Exception which allows passing in an error number and message when there are errors writing to files.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public FileWriteException(
   int errorNumber,
   string message
);
[C++]
public: FileWriteException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
FileWriteException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

FileWriteException Class | FileWriteException Members | Overload List


FileWriteException Constructor(String)

FileWriteException Class | FileWriteException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

FileWriteException Constructor(String)

PegasusImaging.WinForms.NotateXpress9 Namespace > FileWriteException Class > FileWriteException Constructor : FileWriteException Constructor(String)

Exception which allows passing in a message when there are errors writing to files.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public FileWriteException(
   string message
);
[C++]
public: FileWriteException(
   string* message
)
[C++/CLI]
public:
FileWriteException(
   String^ message
)

Parameters

message
A string which represents the message.

See Also

FileWriteException Class | FileWriteException Members | Overload List


FileWriteException Constructor(String,Exception)

FileWriteException Class | FileWriteException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

FileWriteException Constructor(String,Exception)

PegasusImaging.WinForms.NotateXpress9 Namespace > FileWriteException Class > FileWriteException Constructor : FileWriteException Constructor(String,Exception)

Exception which allows passing in a message and inner exception when there are errors writing to files.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public FileWriteException(
   string message,
   Exception innerException
);
[C++]
public: FileWriteException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
FileWriteException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception.

See Also

FileWriteException Class | FileWriteException Members | Overload List


FreeHandTool Class

FreeHandTool Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

FreeHandTool Class

PegasusImaging.WinForms.NotateXpress9 Namespace : FreeHandTool Class

This class is used to create line annotations freely drawn by the user, which can have two or more points.

For a list of all members of this type, see FreeHandTool members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.NotateXpress9.Element
PegasusImaging.WinForms.NotateXpress9.FreeHandTool

Syntax

[Visual Basic]
Public Class FreeHandTool
   Inherits Element
[C#]
public class FreeHandTool : Element
[C++]
public __gc class FreeHandTool : public Element
[C++/CLI]
public ref class FreeHandTool : public Element

See Also

FreeHandTool Members | PegasusImaging.WinForms.NotateXpress9 Namespace


FreeHandTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

FreeHandTool Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : FreeHandTool Class

FreeHandTool overview

Public Constructors

Public Constructor FreeHandTool Constructor The default constructor for the FreeHandTool class.

Public Properties

Public Property BoundingRectangle (Inherited from Element) | Gets and sets the rectangle boundary for the element.
Public Property CreateTime (Inherited from Element) | A Read only property that gets the time when the element was created.
Public Property Fixed (Inherited from Element) | Gets and sets whether an annotation has a fixed position with respect to the control window.
Public Property GroupMember (Inherited from Element) | Gets the group which the element belongs to.
Public Property IsGroupMember (Inherited from Element) | A read only property that gets a value which determines if the element is a member of a group or not.
Public Property Locked (Inherited from Element) | Gets and sets an indicator whether an annotation element can be selected or moved by a user in Edit mode.
Public Property Moveable (Inherited from Element) | Gets and sets whether the element can be moved by a user in Edit mode.
Public Property NumberPoints (Inherited from Element) | A Read only property that gets the number of points currently used to define the element.
Public Property PenColor | Gets and sets the color of the pen used to draw the line.
Public Property PenFillStyle | Gets and sets the pens fill style used to draw the line.
Public Property PenStyle | Gets and sets the pen style used to draw the line.
Public Property PenWidth | Gets and sets the width of the pen, in pixels, used to draw the line.
Public Property Selected (Inherited from Element) | Gets and sets whether the element has been selected.
Public Property ShowHandles (Inherited from Element) | Gets and sets whether selection handles are displayed on an object when it is selected.
Public Property Sizeable (Inherited from Element) | Gets and sets whether the element can be resized.
Public Property ToolTipText (Inherited from Element) | Gets and sets a string value in the element that will become the ToolTipText value associated with the element.
Public Property UserLong (Inherited from Element) | Gets and sets a user defined long value associated with the element.
Public Property UserString (Inherited from Element) | Gets and sets a user-defined string associated with the element.
Public Property Visible (Inherited from Element) | Gets and sets whether the element is visible.

Public Methods

Public Method GetPoints | Gets an array of points that is used to draw the line for the freehand.
Public Method NudgeDown (Inherited from Element) | Moves the specified annotation object one level down, towards the back, in the painting order of the specified layer.
Public Method NudgeUp (Inherited from Element) | Moves the specified annotation object one level up, towards the front, in the painting order of the specified layer.
Public Method SetPoints | Sets an array of given points used to draw the line.
Public Method UserDataAdd (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataDelete (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFind (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFindFirst (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFindNext (Inherited from Element) | User data can be added to each element in a key value pair.

See Also

FreeHandTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace


FreeHandTool Constructor

FreeHandTool Class | FreeHandTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

FreeHandTool Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > FreeHandTool Class : FreeHandTool Constructor (FreeHandTool)

The default constructor for the FreeHandTool class.

[Visual Basic]
Public Function New()
[C#]
public FreeHandTool();
[C++]
public: FreeHandTool();
[C++/CLI]
public:
FreeHandTool();

See Also

FreeHandTool Class | FreeHandTool Members


GetPoints Method

FreeHandTool Class | FreeHandTool Members | Point

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetPoints Method

PegasusImaging.WinForms.NotateXpress9 Namespace > FreeHandTool Class : GetPoints Method (FreeHandTool)

Gets an array of points that is used to draw the line for the freehand.

[Visual Basic]
Public Function GetPoints() As Point()
[C#]
public Point[] GetPoints();
[C++]
public: Point[]* GetPoints();
[C++/CLI]
public:
array<Point>^ GetPoints();

See Also

FreeHandTool Class | FreeHandTool Members | Point


SetPoints Method

FreeHandTool Class | FreeHandTool Members | Point

Language

Visual Basic

C#

C++

C++/CLI

Show All

points
An array of Point to use to draw the line for the freehand.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

SetPoints Method

PegasusImaging.WinForms.NotateXpress9 Namespace > FreeHandTool Class : SetPoints Method (FreeHandTool)

Sets an array of given points used to draw the line.

[Visual Basic]
Public Sub SetPoints( _
   ByVal points() As Point _
)
[C#]
public void SetPoints(
   Point[] points
);
[C++]
public: void SetPoints(
   Point[]* points
)
[C++/CLI]
public:
void SetPoints(
   Pointarray<points>^ points
)

Parameters

points
An array of Point to use to draw the line for the freehand.

See Also

FreeHandTool Class | FreeHandTool Members | Point


FreeHandTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

FreeHandTool Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : FreeHandTool Class

For a list of all members of this type, see FreeHandTool members.

Public Properties

Public Property BoundingRectangle (Inherited from Element) | Gets and sets the rectangle boundary for the element.
Public Property CreateTime (Inherited from Element) | A Read only property that gets the time when the element was created.
Public Property Fixed (Inherited from Element) | Gets and sets whether an annotation has a fixed position with respect to the control window.
Public Property GroupMember (Inherited from Element) | Gets the group which the element belongs to.
Public Property IsGroupMember (Inherited from Element) | A read only property that gets a value which determines if the element is a member of a group or not.
Public Property Locked (Inherited from Element) | Gets and sets an indicator whether an annotation element can be selected or moved by a user in Edit mode.
Public Property Moveable (Inherited from Element) | Gets and sets whether the element can be moved by a user in Edit mode.
Public Property NumberPoints (Inherited from Element) | A Read only property that gets the number of points currently used to define the element.
Public Property PenColor | Gets and sets the color of the pen used to draw the line.
Public Property PenFillStyle | Gets and sets the pens fill style used to draw the line.
Public Property PenStyle | Gets and sets the pen style used to draw the line.
Public Property PenWidth | Gets and sets the width of the pen, in pixels, used to draw the line.
Public Property Selected (Inherited from Element) | Gets and sets whether the element has been selected.
Public Property ShowHandles (Inherited from Element) | Gets and sets whether selection handles are displayed on an object when it is selected.
Public Property Sizeable (Inherited from Element) | Gets and sets whether the element can be resized.
Public Property ToolTipText (Inherited from Element) | Gets and sets a string value in the element that will become the ToolTipText value associated with the element.
Public Property UserLong (Inherited from Element) | Gets and sets a user defined long value associated with the element.
Public Property UserString (Inherited from Element) | Gets and sets a user-defined string associated with the element.
Public Property Visible (Inherited from Element) | Gets and sets whether the element is visible.

See Also

FreeHandTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace


PenColor Property

FreeHandTool Class | FreeHandTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PenColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > FreeHandTool Class : PenColor Property (FreeHandTool)

Gets and sets the color of the pen used to draw the line.

[Visual Basic]
Public Property PenColor As Color
[C#]
public Color PenColor {get; set;}
[C++]
public: __property Color get_PenColor();
public: __property void set_PenColor(
   Color value
);
[C++/CLI]
public:
property Color PenColor {
   Color get();
   void set (Color value);
}

See Also

FreeHandTool Class | FreeHandTool Members


PenFillStyle Property

FreeHandTool Class | FreeHandTool Members | PenFillStyle Property

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PenFillStyle Property

PegasusImaging.WinForms.NotateXpress9 Namespace > FreeHandTool Class : PenFillStyle Property (FreeHandTool)

Gets and sets the pens fill style used to draw the line.

[Visual Basic]
Public Property PenFillStyle As PenFillStyle
[C#]
public PenFillStyle PenFillStyle {get; set;}
[C++]
public: __property PenFillStyle get_PenFillStyle();
public: __property void set_PenFillStyle(
   PenFillStyle value
);
[C++/CLI]
public:
property PenFillStyle PenFillStyle {
   PenFillStyle get();
   void set (PenFillStyle value);
}

Value

The PenFillStyle enumeration value set.

See Also

FreeHandTool Class | FreeHandTool Members | PenFillStyle Property


PenStyle Property

FreeHandTool Class | FreeHandTool Members | PenStyle Property

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PenStyle Property

PegasusImaging.WinForms.NotateXpress9 Namespace > FreeHandTool Class : PenStyle Property (FreeHandTool)

Gets and sets the pen style used to draw the line.

[Visual Basic]
Public Property PenStyle As PenStyle
[C#]
public PenStyle PenStyle {get; set;}
[C++]
public: __property PenStyle get_PenStyle();
public: __property void set_PenStyle(
   PenStyle value
);
[C++/CLI]
public:
property PenStyle PenStyle {
   PenStyle get();
   void set (PenStyle value);
}

Value

The PenStyle enumeration value set.

Remarks

Note: The PenStyle can be anything when the pen is one pixel. The PenStyle will only show Solid when the width is more than one pixel.

See Also

FreeHandTool Class | FreeHandTool Members | PenStyle Property


PenWidth Property

FreeHandTool Class | FreeHandTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PenWidth Property

PegasusImaging.WinForms.NotateXpress9 Namespace > FreeHandTool Class : PenWidth Property (FreeHandTool)

Gets and sets the width of the pen, in pixels, used to draw the line.

[Visual Basic]
Public Property PenWidth As Integer
[C#]
public int PenWidth {get; set;}
[C++]
public: __property int get_PenWidth();
public: __property void set_PenWidth(
   int value
);
[C++/CLI]
public:
property int PenWidth {
   int get();
   void set (int value);
}

Value

An integer value which represents the pen width in pixels.

Remarks

The default value is 1.

See Also

FreeHandTool Class | FreeHandTool Members


FreehandToolbarDefaults Class

FreehandToolbarDefaults Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

FreehandToolbarDefaults Class

PegasusImaging.WinForms.NotateXpress9 Namespace : FreehandToolbarDefaults Class (PegasusImaging.WinForms.NotateXpress9)

This class implements the default toolbar values for the Freehand annotations.

For a list of all members of this type, see FreehandToolbarDefaults members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.NotateXpress9.BaseToolbarDefaults
PegasusImaging.WinForms.NotateXpress9.FreehandToolbarDefaults

Syntax

[Visual Basic]
Public Class FreehandToolbarDefaults
   Inherits BaseToolbarDefaults
[C#]
public class FreehandToolbarDefaults : BaseToolbarDefaults
[C++]
public __gc class FreehandToolbarDefaults : public BaseToolbarDefaults
[C++/CLI]
public ref class FreehandToolbarDefaults : public BaseToolbarDefaults

See Also

FreehandToolbarDefaults Members | PegasusImaging.WinForms.NotateXpress9 Namespace


FreehandToolbarDefaults Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

FreehandToolbarDefaults Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : FreehandToolbarDefaults Class (PegasusImaging.WinForms.NotateXpress9)

FreehandToolbarDefaults overview

Public Constructors

Public Constructor FreehandToolbarDefaults Constructor The default constructor for the Freehand ToolbarDefaults class.

Public Properties

Public Property Fixed (Inherited from BaseToolbarDefaults) | Gets and sets whether an element is tied to the view instead of the image.
Public Property Locked (Inherited from BaseToolbarDefaults) | Gets and sets an indicator to lock an element so it cannot be selected or moved by a user in Edit mode.
Public Property Moveable (Inherited from BaseToolbarDefaults) | Gets and sets whether an element can be moved interactively during EditMode.
Public Property PenColor | Gets and sets the color of the pen used to draw the border around the Freehand annotation.
Public Property PenFillStyle | Gets and sets the pen fill style used within the Freehand annotation.
Public Property PenStyle | Gets and sets the style of the background used within the Freehand annotation.
Public Property PenWidth | Gets and sets the width of the pen used to draw the Freehand annotation.
Public Property Selected (Inherited from BaseToolbarDefaults) | Gets and sets whether an element is automatically selected.
Public Property ShowHandles (Inherited from BaseToolbarDefaults) | Gets and sets whether selection handles are displayed for an element.
Public Property Sizeable (Inherited from BaseToolbarDefaults) | Gets and sets whether an element can be sized interactively during EditMode.
Public Property ToolTipText (Inherited from BaseToolbarDefaults) | Gets or sets a string value in the element that will become the ToolTipText value associated with the annotation once it is created.
Public Property UserLong (Inherited from BaseToolbarDefaults) | Gets and sets a long value in the element that will become the UserLong value associated with the element once it is created.
Public Property UserString (Inherited from BaseToolbarDefaults) | Gets and sets a string value in the element that will become the UserString value associated with the object once it is created.
Public Property Visible (Inherited from BaseToolbarDefaults) | Gets and sets the Visible attribute of an element.

See Also

FreehandToolbarDefaults Class | PegasusImaging.WinForms.NotateXpress9 Namespace


FreehandToolbarDefaults Constructor

FreehandToolbarDefaults Class | FreehandToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

FreehandToolbarDefaults Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > FreehandToolbarDefaults Class : FreehandToolbarDefaults Constructor (FreehandToolbarDefaults)

The default constructor for the Freehand ToolbarDefaults class.

[Visual Basic]
Public Function New()
[C#]
public FreehandToolbarDefaults();
[C++]
public: FreehandToolbarDefaults();
[C++/CLI]
public:
FreehandToolbarDefaults();

See Also

FreehandToolbarDefaults Class | FreehandToolbarDefaults Members


FreehandToolbarDefaults Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

FreehandToolbarDefaults Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : FreehandToolbarDefaults Class (PegasusImaging.WinForms.NotateXpress9)

For a list of all members of this type, see FreehandToolbarDefaults members.

Public Properties

Public Property Fixed (Inherited from BaseToolbarDefaults) | Gets and sets whether an element is tied to the view instead of the image.
Public Property Locked (Inherited from BaseToolbarDefaults) | Gets and sets an indicator to lock an element so it cannot be selected or moved by a user in Edit mode.
Public Property Moveable (Inherited from BaseToolbarDefaults) | Gets and sets whether an element can be moved interactively during EditMode.
Public Property PenColor | Gets and sets the color of the pen used to draw the border around the Freehand annotation.
Public Property PenFillStyle | Gets and sets the pen fill style used within the Freehand annotation.
Public Property PenStyle | Gets and sets the style of the background used within the Freehand annotation.
Public Property PenWidth | Gets and sets the width of the pen used to draw the Freehand annotation.
Public Property Selected (Inherited from BaseToolbarDefaults) | Gets and sets whether an element is automatically selected.
Public Property ShowHandles (Inherited from BaseToolbarDefaults) | Gets and sets whether selection handles are displayed for an element.
Public Property Sizeable (Inherited from BaseToolbarDefaults) | Gets and sets whether an element can be sized interactively during EditMode.
Public Property ToolTipText (Inherited from BaseToolbarDefaults) | Gets or sets a string value in the element that will become the ToolTipText value associated with the annotation once it is created.
Public Property UserLong (Inherited from BaseToolbarDefaults) | Gets and sets a long value in the element that will become the UserLong value associated with the element once it is created.
Public Property UserString (Inherited from BaseToolbarDefaults) | Gets and sets a string value in the element that will become the UserString value associated with the object once it is created.
Public Property Visible (Inherited from BaseToolbarDefaults) | Gets and sets the Visible attribute of an element.

See Also

FreehandToolbarDefaults Class | PegasusImaging.WinForms.NotateXpress9 Namespace


PenColor Property

FreehandToolbarDefaults Class | FreehandToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PenColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > FreehandToolbarDefaults Class : PenColor Property (FreehandToolbarDefaults)

Gets and sets the color of the pen used to draw the border around the Freehand annotation.

[Visual Basic]
Public Property PenColor As Color
[C#]
public Color PenColor {get; set;}
[C++]
public: __property Color get_PenColor();
public: __property void set_PenColor(
   Color value
);
[C++/CLI]
public:
property Color PenColor {
   Color get();
   void set (Color value);
}

See Also

FreehandToolbarDefaults Class | FreehandToolbarDefaults Members


PenFillStyle Property

FreehandToolbarDefaults Class | FreehandToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PenFillStyle Property

PegasusImaging.WinForms.NotateXpress9 Namespace > FreehandToolbarDefaults Class : PenFillStyle Property (FreehandToolbarDefaults)

Gets and sets the pen fill style used within the Freehand annotation.

[Visual Basic]
Public Property PenFillStyle As PenFillStyle
[C#]
public PenFillStyle PenFillStyle {get; set;}
[C++]
public: __property PenFillStyle get_PenFillStyle();
public: __property void set_PenFillStyle(
   PenFillStyle value
);
[C++/CLI]
public:
property PenFillStyle PenFillStyle {
   PenFillStyle get();
   void set (PenFillStyle value);
}

Value

The PenFillStyle enumeration value set.

See Also

FreehandToolbarDefaults Class | FreehandToolbarDefaults Members


PenStyle Property

FreehandToolbarDefaults Class | FreehandToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PenStyle Property

PegasusImaging.WinForms.NotateXpress9 Namespace > FreehandToolbarDefaults Class : PenStyle Property (FreehandToolbarDefaults)

Gets and sets the style of the background used within the Freehand annotation.

[Visual Basic]
Public Property PenStyle As PenStyle
[C#]
public PenStyle PenStyle {get; set;}
[C++]
public: __property PenStyle get_PenStyle();
public: __property void set_PenStyle(
   PenStyle value
);
[C++/CLI]
public:
property PenStyle PenStyle {
   PenStyle get();
   void set (PenStyle value);
}

Value

The PenStyle enumeration value which represents the style of the background used within the Freehand annotation.

Remarks

Note: The PenStyle can be anything when the pen is one pixel. The PenStyle will display as PenStyle.Solid when the width is more than one pixel.

See Also

FreehandToolbarDefaults Class | FreehandToolbarDefaults Members


PenWidth Property

FreehandToolbarDefaults Class | FreehandToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PenWidth Property

PegasusImaging.WinForms.NotateXpress9 Namespace > FreehandToolbarDefaults Class : PenWidth Property (FreehandToolbarDefaults)

Gets and sets the width of the pen used to draw the Freehand annotation.

[Visual Basic]
Public Property PenWidth As Integer
[C#]
public int PenWidth {get; set;}
[C++]
public: __property int get_PenWidth();
public: __property void set_PenWidth(
   int value
);
[C++/CLI]
public:
property int PenWidth {
   int get();
   void set (int value);
}

Remarks

The default value is 1.

See Also

FreehandToolbarDefaults Class | FreehandToolbarDefaults Members


GetLayerPasswordEventArgs Class

GetLayerPasswordEventArgs Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetLayerPasswordEventArgs Class

PegasusImaging.WinForms.NotateXpress9 Namespace : GetLayerPasswordEventArgs Class

Arguments for RequestLayerPassword event

For a list of all members of this type, see GetLayerPasswordEventArgs members.

Object Model

Inheritance Hierarchy

System.Object
System.EventArgs
PegasusImaging.WinForms.NotateXpress9.GetLayerPasswordEventArgs

Syntax

[Visual Basic]
Public Class GetLayerPasswordEventArgs
   Inherits EventArgs
[C#]
public class GetLayerPasswordEventArgs : EventArgs
[C++]
public __gc class GetLayerPasswordEventArgs : public EventArgs
[C++/CLI]
public ref class GetLayerPasswordEventArgs : public EventArgs

Remarks

When an annotation file is stored, layers that have a non-null LayerPassword are encrypted. When this file is opened, a GetLayerPassword event is invoked to request the password for each encrypted layer. If the correct password is supplied for this event, the layer is decrypted and available for viewing. If an incorrect or null password is supplied, the layer is discarded from memory (the layer still exists in the file but may be subsequently overwritten).

See Also

GetLayerPasswordEventArgs Members | PegasusImaging.WinForms.NotateXpress9 Namespace


GetLayerPasswordEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetLayerPasswordEventArgs Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : GetLayerPasswordEventArgs Class

GetLayerPasswordEventArgs overview

Public Constructors

Public Constructor GetLayerPasswordEventArgs Constructor

Public Properties

Public Property LayerName | Gets the layer name of the layer that needs a password.
Public Property LayerPassword | SETS the password for the current layer.

See Also

GetLayerPasswordEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace


GetLayerPasswordEventArgs Constructor

GetLayerPasswordEventArgs Class | GetLayerPasswordEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetLayerPasswordEventArgs Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > GetLayerPasswordEventArgs Class : GetLayerPasswordEventArgs Constructor (GetLayerPasswordEventArgs)
[Visual Basic]
Public Function New()
[C#]
public GetLayerPasswordEventArgs();
[C++]
public: GetLayerPasswordEventArgs();
[C++/CLI]
public:
GetLayerPasswordEventArgs();

See Also

GetLayerPasswordEventArgs Class | GetLayerPasswordEventArgs Members


GetLayerPasswordEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetLayerPasswordEventArgs Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : GetLayerPasswordEventArgs Class

For a list of all members of this type, see GetLayerPasswordEventArgs members.

Public Properties

Public Property LayerName | Gets the layer name of the layer that needs a password.
Public Property LayerPassword | SETS the password for the current layer.

See Also

GetLayerPasswordEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace


LayerName Property

GetLayerPasswordEventArgs Class | GetLayerPasswordEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

LayerName Property

PegasusImaging.WinForms.NotateXpress9 Namespace > GetLayerPasswordEventArgs Class : LayerName Property

Gets the layer name of the layer that needs a password.

[Visual Basic]
Public Property LayerName As String
[C#]
public string LayerName {get; set;}
[C++]
public: __property string* get_LayerName();
public: __property void set_LayerName(
   string* value
);
[C++/CLI]
public:
property String^ LayerName {
   String^ get();
   void set (String^ value);
}

See Also

GetLayerPasswordEventArgs Class | GetLayerPasswordEventArgs Members


LayerPassword Property

GetLayerPasswordEventArgs Class | GetLayerPasswordEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

LayerPassword Property

PegasusImaging.WinForms.NotateXpress9 Namespace > GetLayerPasswordEventArgs Class : LayerPassword Property

SETS the password for the current layer.

[Visual Basic]
Public Property LayerPassword As String
[C#]
public string LayerPassword {get; set;}
[C++]
public: __property string* get_LayerPassword();
public: __property void set_LayerPassword(
   string* value
);
[C++/CLI]
public:
property String^ LayerPassword {
   String^ get();
   void set (String^ value);
}

See Also

GetLayerPasswordEventArgs Class | GetLayerPasswordEventArgs Members


Group Class

Group Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Group Class

PegasusImaging.WinForms.NotateXpress9 Namespace : Group Class (PegasusImaging.WinForms.NotateXpress9)

This class defines attributes of a group of elements for annotation.

For a list of all members of this type, see Group members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.NotateXpress9.Group

Syntax

[Visual Basic]
Public Class Group
   Implements IDisposable
[C#]
public class Group : IDisposable
[C++]
public __gc class Group : public IDisposable
[C++/CLI]
public ref class Group : public IDisposable

See Also

Group Members | PegasusImaging.WinForms.NotateXpress9 Namespace


Group Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Group Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : Group Class (PegasusImaging.WinForms.NotateXpress9)

Group overview

Public Constructors

Public Constructor Group Constructor The default constructor for the group class.

Public Properties

Public Property GroupElements | Gets the group elements within the GroupElementCollection.
Public Property Name | Gets and sets the name of the element group.
Public Property UserLong | Gets and sets a user defined long value, available for you to define.
Public Property UserString | Gets and sets a user defined string.
Public Property Yoked | Gets and sets whether the elements in the group are yoked.

Public Methods

Public Method Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public Method UserDataAdd | User data can be added to each group in a key value pair. This will add in a new key value pair.
Public Method UserDataDelete | User data can be added to each element in a key value pair.
Public Method UserDataFind | User data can be added to each group in a key value pair.
Public Method UserDataFindFirst | User data can be added to each group in a key value pair.
Public Method UserDataFindNext | User data can be added to each group in a key value pair.

See Also

Group Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Group Constructor

Group Class | Group Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Group Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > Group Class : Group Constructor (Group)

The default constructor for the group class.

[Visual Basic]
Public Function New()
[C#]
public Group();
[C++]
public: Group();
[C++/CLI]
public:
Group();

See Also

Group Class | Group Members


Dispose Method

Group Class | Group Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Dispose Method

PegasusImaging.WinForms.NotateXpress9 Namespace > Group Class : Dispose Method (Group)

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();
[C++]
public: void Dispose();
[C++/CLI]
public:
void Dispose();

See Also

Group Class | Group Members


UserDataAdd Method

Group Class | Group Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

key
A string value which represents the new key.
newVal
A string value which represents the new value.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

UserDataAdd Method

PegasusImaging.WinForms.NotateXpress9 Namespace > Group Class : UserDataAdd Method (Group)

User data can be added to each group in a key value pair. This will add in a new key value pair.

[Visual Basic]
Public Sub UserDataAdd( _
   ByVal key As String, _
   ByVal newVal As String _
)
[C#]
public void UserDataAdd(
   string key,
   string newVal
);
[C++]
public: void UserDataAdd(
   string* key,
   string* newVal
)
[C++/CLI]
public:
void UserDataAdd(
   String^ key,
   String^ newVal
)

Parameters

key
A string value which represents the new key.
newVal
A string value which represents the new value.

Remarks

This method adds a new key value pair.

See Also

Group Class | Group Members


UserDataDelete Method

Group Class | Group Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

key
A string value which represents the key to remove.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

UserDataDelete Method

PegasusImaging.WinForms.NotateXpress9 Namespace > Group Class : UserDataDelete Method (Group)

User data can be added to each element in a key value pair.

[Visual Basic]
Public Sub UserDataDelete( _
   ByVal key As String _
)
[C#]
public void UserDataDelete(
   string key
);
[C++]
public: void UserDataDelete(
   string* key
)
[C++/CLI]
public:
void UserDataDelete(
   String^ key
)

Parameters

key
A string value which represents the key to remove.

Remarks

This method removes an existing key value pair for the entered key.

See Also

Group Class | Group Members


UserDataFind Method

Group Class | Group Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

key
A string value which represents the user data key to search for.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

UserDataFind Method

PegasusImaging.WinForms.NotateXpress9 Namespace > Group Class : UserDataFind Method (Group)

User data can be added to each group in a key value pair.

[Visual Basic]
Public Function UserDataFind( _
   ByVal key As String _
) As String
[C#]
public string UserDataFind(
   string key
);
[C++]
public: string* UserDataFind(
   string* key
)
[C++/CLI]
public:
String^ UserDataFind(
   String^ key
)

Parameters

key
A string value which represents the user data key to search for.

Return Type

The user data from the matching key.

Remarks

The default value is an empty string "".

This method returns the string value of an existing key.

See Also

Group Class | Group Members


UserDataFindFirst Method

Group Class | Group Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

key
A string value which represents the first key.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

UserDataFindFirst Method

PegasusImaging.WinForms.NotateXpress9 Namespace > Group Class : UserDataFindFirst Method (Group)

User data can be added to each group in a key value pair.

[Visual Basic]
Public Function UserDataFindFirst( _
   ByRef key As String _
) As String
[C#]
public string UserDataFindFirst(
   out string key
);
[C++]
public: string* UserDataFindFirst(
   [PARAMFLAG::Out] string* key
)
[C++/CLI]
public:
String^ UserDataFindFirst(
   [Out] String^ key
)

Parameters

key
A string value which represents the first key.

Return Type

The first value from the matching key.

Remarks

This method finds the first key value pair.

See Also

Group Class | Group Members


UserDataFindNext Method

Group Class | Group Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

key
A string value which represents the next key.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

UserDataFindNext Method

PegasusImaging.WinForms.NotateXpress9 Namespace > Group Class : UserDataFindNext Method (Group)

User data can be added to each group in a key value pair.

[Visual Basic]
Public Function UserDataFindNext( _
   ByRef key As String _
) As String
[C#]
public string UserDataFindNext(
   out string key
);
[C++]
public: string* UserDataFindNext(
   [PARAMFLAG::Out] string* key
)
[C++/CLI]
public:
String^ UserDataFindNext(
   [Out] String^ key
)

Parameters

key
A string value which represents the next key.

Return Type

The next value from the matching key.

Remarks

This method finds the next key value pair.

See Also

Group Class | Group Members


Group Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Group Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : Group Class (PegasusImaging.WinForms.NotateXpress9)

For a list of all members of this type, see Group members.

Public Properties

Public Property GroupElements | Gets the group elements within the GroupElementCollection.
Public Property Name | Gets and sets the name of the element group.
Public Property UserLong | Gets and sets a user defined long value, available for you to define.
Public Property UserString | Gets and sets a user defined string.
Public Property Yoked | Gets and sets whether the elements in the group are yoked.

See Also

Group Class | PegasusImaging.WinForms.NotateXpress9 Namespace


GroupElements Property

Group Class | Group Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GroupElements Property

PegasusImaging.WinForms.NotateXpress9 Namespace > Group Class : GroupElements Property

Gets the group elements within the GroupElementCollection.

[Visual Basic]
Public ReadOnly Property GroupElements As GroupElementCollection
[C#]
public GroupElementCollection GroupElements {get;}
[C++]
public: __property GroupElementCollection* get_GroupElements();
[C++/CLI]
public:
property GroupElementCollection^ GroupElements {
   GroupElementCollection^ get();
}

Value

The GroupElementCollection values.

See Also

Group Class | Group Members


Name Property

Group Class | Group Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Name Property

PegasusImaging.WinForms.NotateXpress9 Namespace > Group Class : Name Property (Group)

Gets and sets the name of the element group.

[Visual Basic]
Public Property Name As String
[C#]
public string Name {get; set;}
[C++]
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
[C++/CLI]
public:
property String^ Name {
   String^ get();
   void set (String^ value);
}

Value

A string value which represents the name of the group.

Remarks

The default value is an empty string "".

See Also

Group Class | Group Members


UserLong Property

Group Class | Group Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

UserLong Property

PegasusImaging.WinForms.NotateXpress9 Namespace > Group Class : UserLong Property (Group)

Gets and sets a user defined long value, available for you to define.

[Visual Basic]
Public Property UserLong As Integer
[C#]
public int UserLong {get; set;}
[C++]
public: __property int get_UserLong();
public: __property void set_UserLong(
   int value
);
[C++/CLI]
public:
property int UserLong {
   int get();
   void set (int value);
}

Value

An integer value which is associated to the group.

Remarks

The default value is 0.

See Also

Group Class | Group Members


UserString Property

Group Class | Group Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

UserString Property

PegasusImaging.WinForms.NotateXpress9 Namespace > Group Class : UserString Property (Group)

Gets and sets a user defined string.

[Visual Basic]
Public Property UserString As String
[C#]
public string UserString {get; set;}
[C++]
public: __property string* get_UserString();
public: __property void set_UserString(
   string* value
);
[C++/CLI]
public:
property String^ UserString {
   String^ get();
   void set (String^ value);
}

Value

A string value which is associated with the group.

Remarks

The default value is an empty string "".

See Also

Group Class | Group Members


Yoked Property

Group Class | Group Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Yoked Property

PegasusImaging.WinForms.NotateXpress9 Namespace > Group Class : Yoked Property

Gets and sets whether the elements in the group are yoked.

[Visual Basic]
Public Property Yoked As Boolean
[C#]
public bool Yoked {get; set;}
[C++]
public: __property bool get_Yoked();
public: __property void set_Yoked(
   bool value
);
[C++/CLI]
public:
property bool Yoked {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true if the elements in the group are tied together. Otherwise, false is returned.

Remarks

The default value is false.

This property identifies whether the elements in the group are tied together. When group elements are yoked, they can be selected and manipulated (moved, sized), as a group. When a group is yoked, selecting an element within a group automatically selects all other elements

See Also

Group Class | Group Members


GroupCollection Class

GroupCollection Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GroupCollection Class

PegasusImaging.WinForms.NotateXpress9 Namespace : GroupCollection Class

This class manages groups in the collection.

For a list of all members of this type, see GroupCollection members.

Object Model

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
PegasusImaging.WinForms.NotateXpress9.GroupCollection

Syntax

[Visual Basic]
<DefaultMemberAttribute("Item")>
Public Class GroupCollection
   Inherits CollectionBase
   Implements IList, ICollection, IEnumerable, IDisposable
[C#]
[DefaultMemberAttribute("Item")]
public class GroupCollection : CollectionBase, IList, ICollection, IEnumerable, IDisposable
[C++]
[DefaultMemberAttribute("Item")]
public __gc class GroupCollection : public CollectionBase, IList, ICollection, IEnumerable, IDisposable
[C++/CLI]
[DefaultMemberAttribute("Item")]
public ref class GroupCollection : public CollectionBase, IList, ICollection, IEnumerable, IDisposable

See Also

GroupCollection Members | PegasusImaging.WinForms.NotateXpress9 Namespace


GroupCollection Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GroupCollection Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : GroupCollection Class

GroupCollection overview

Public Properties

Public Property AllowUserGrouping | Gets and sets whether users can create and destroy groups by keyboard commands.
Public Property Capacity (Inherited from System.Collections.CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Public Property Count (Inherited from System.Collections.CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
Public Property Item | Gets and sets the given group within the group collection.

Public Methods

Public Method Add | Adds the given group to the current GroupCollection.
Public Method Clear | Clears the entire collection as well as calls the Clear function of the base class.
Public Method Contains | Determines if the group collection contains the given Group.
Public Method CopyTo | Copies the entire group collection to the given array, starting at given index of the target array.
Public Method Dispose | Releases all resources used by this GroupCollection object.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) | Returns an enumerator that iterates through the CollectionBase instance.
Public Method IndexOf | Searches for a group based on the given value and returns the index position of the first occurrence within the entire GroupCollection.
Public Method Insert | Inserts a Group at the given index location within the group collection.
Public Method Remove | Removes the given Group from the group collection.
Public Method RemoveAt | Removes a group within the group collection located at the given index.

See Also

GroupCollection Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Add Method

GroupCollection Class | GroupCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

group
The Group to add to the group collection.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Add Method

PegasusImaging.WinForms.NotateXpress9 Namespace > GroupCollection Class : Add Method (GroupCollection)

Adds the given group to the current GroupCollection.

[Visual Basic]
Public Function Add( _
   ByVal group As Group _
) As Integer
[C#]
public int Add(
   Group group
);
[C++]
public: int Add(
   Group* group
)
[C++/CLI]
public:
int Add(
   Group^ group
)

Parameters

group
The Group to add to the group collection.

Return Type

An integer value which evaluates the index position of the newly added group within the group collection.

Remarks

When adding to a group collection, the associated layer must be in a LayerCollection.

See Also

GroupCollection Class | GroupCollection Members


Clear Method

GroupCollection Class | GroupCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Clear Method

PegasusImaging.WinForms.NotateXpress9 Namespace > GroupCollection Class : Clear Method (GroupCollection)

Clears the entire collection as well as calls the Clear function of the base class.

[Visual Basic]
Public Sub Clear()
[C#]
public void Clear();
[C++]
public: void Clear();
[C++/CLI]
public:
void Clear();

See Also

GroupCollection Class | GroupCollection Members


Contains Method

GroupCollection Class | GroupCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

group
The Group to search for in the collection.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Contains Method

PegasusImaging.WinForms.NotateXpress9 Namespace > GroupCollection Class : Contains Method (GroupCollection)

Determines if the group collection contains the given Group.

[Visual Basic]
Public Function Contains( _
   ByVal group As Group _
) As Boolean
[C#]
public bool Contains(
   Group group
);
[C++]
public: bool Contains(
   Group* group
)
[C++/CLI]
public:
bool Contains(
   Group^ group
)

Parameters

group
The Group to search for in the collection.

Return Type

true if the collection contains the specified Group; otherwise, false. Implements

See Also

GroupCollection Class | GroupCollection Members


CopyTo Method

GroupCollection Class | GroupCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

array
The one-dimensional Array that is the destination of the groups copied from DocumentCollection. The Array must have zero-based indexing.
index
The zero-based index in array at which copying begins.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

CopyTo Method

PegasusImaging.WinForms.NotateXpress9 Namespace > GroupCollection Class : CopyTo Method (GroupCollection)

Copies the entire group collection to the given array, starting at given index of the target array.

[Visual Basic]
Public Sub CopyTo( _
   ByVal array() As Group, _
   ByVal index As Integer _
)
[C#]
public void CopyTo(
   Group[] array,
   int index
);
[C++]
public: void CopyTo(
   Group*[]* array,
   int index
)
[C++/CLI]
public:
void CopyTo(
   Group^array<array>^ array,
   int index
)

Parameters

array
The one-dimensional Array that is the destination of the groups copied from DocumentCollection. The Array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

See Also

GroupCollection Class | GroupCollection Members


Dispose Method

GroupCollection Class | GroupCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Dispose Method

PegasusImaging.WinForms.NotateXpress9 Namespace > GroupCollection Class : Dispose Method (GroupCollection)

Releases all resources used by this GroupCollection object.

[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();
[C++]
public: void Dispose();
[C++/CLI]
public:
void Dispose();

See Also

GroupCollection Class | GroupCollection Members


IndexOf Method

GroupCollection Class | GroupCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

value
Object to locate in the collection.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

IndexOf Method

PegasusImaging.WinForms.NotateXpress9 Namespace > GroupCollection Class : IndexOf Method (GroupCollection)

Searches for a group based on the given value and returns the index position of the first occurrence within the entire GroupCollection.

[Visual Basic]
Public Function IndexOf( _
   ByVal value As Group _
) As Integer
[C#]
public int IndexOf(
   Group value
);
[C++]
public: int IndexOf(
   Group* value
)
[C++/CLI]
public:
int IndexOf(
   Group^ value
)

Parameters

value
Object to locate in the collection.

See Also

GroupCollection Class | GroupCollection Members


Insert Method

GroupCollection Class | GroupCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

index
The zero-based index at which the Group should be inserted.
group
A Group which represents the group to add to the collection.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Insert Method

PegasusImaging.WinForms.NotateXpress9 Namespace > GroupCollection Class : Insert Method (GroupCollection)

Inserts a Group at the given index location within the group collection.

[Visual Basic]
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal group As Group _
)
[C#]
public void Insert(
   int index,
   Group group
);
[C++]
public: void Insert(
   int index,
   Group* group
)
[C++/CLI]
public:
void Insert(
   int index,
   Group^ group
)

Parameters

index
The zero-based index at which the Group should be inserted.
group
A Group which represents the group to add to the collection.

See Also

GroupCollection Class | GroupCollection Members


Remove Method

GroupCollection Class | GroupCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

group
A Group which represents the group to remove from the collection.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Remove Method

PegasusImaging.WinForms.NotateXpress9 Namespace > GroupCollection Class : Remove Method (GroupCollection)

Removes the given Group from the group collection.

[Visual Basic]
Public Sub Remove( _
   ByVal group As Group _
)
[C#]
public void Remove(
   Group group
);
[C++]
public: void Remove(
   Group* group
)
[C++/CLI]
public:
void Remove(
   Group^ group
)

Parameters

group
A Group which represents the group to remove from the collection.

See Also

GroupCollection Class | GroupCollection Members


RemoveAt Method

GroupCollection Class | GroupCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

index
A zero-based value which determines the location of the group to remove.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

RemoveAt Method

PegasusImaging.WinForms.NotateXpress9 Namespace > GroupCollection Class : RemoveAt Method (GroupCollection)

Removes a group within the group collection located at the given index.

[Visual Basic]
Public Sub RemoveAt( _
   ByVal index As Integer _
)
[C#]
public void RemoveAt(
   int index
);
[C++]
public: void RemoveAt(
   int index
)
[C++/CLI]
public:
void RemoveAt(
   int index
)

Parameters

index
A zero-based value which determines the location of the group to remove.

See Also

GroupCollection Class | GroupCollection Members


GroupCollection Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GroupCollection Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : GroupCollection Class

For a list of all members of this type, see GroupCollection members.

Public Properties

Public Property AllowUserGrouping | Gets and sets whether users can create and destroy groups by keyboard commands.
Public Property Capacity (Inherited from System.Collections.CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Public Property Count (Inherited from System.Collections.CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
Public Property Item | Gets and sets the given group within the group collection.

See Also

GroupCollection Class | PegasusImaging.WinForms.NotateXpress9 Namespace


AllowUserGrouping Property

GroupCollection Class | GroupCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

AllowUserGrouping Property

PegasusImaging.WinForms.NotateXpress9 Namespace > GroupCollection Class : AllowUserGrouping Property

Gets and sets whether users can create and destroy groups by keyboard commands.

[Visual Basic]
Public Property AllowUserGrouping As Boolean
[C#]
public bool AllowUserGrouping {get; set;}
[C++]
public: __property bool get_AllowUserGrouping();
public: __property void set_AllowUserGrouping(
   bool value
);
[C++/CLI]
public:
property bool AllowUserGrouping {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true when users can create and destroy groups. Otherwise, false is returned.

Remarks

When this property is set to true, and multiple items are selected in a layer, when Ctrl-G is pressed, a new group is created and each of the selected items is added to the group. The new group's yoked property is set to true, allowing immediate user manipulation of the group. When a single group is selected and the user presses Ctrl-U, the selected group is destroyed.

When a group is created by the user, a NotateXpress.UserGroupCreated event is raised. Likewise, when a group is destroyed by the user, a NotateXpress.UserGroupDestroyed event is raised.

See Also

GroupCollection Class | GroupCollection Members


Item Property

GroupCollection Class | GroupCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

index
A zero-based value which determines the location a group is within a group collection.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Item Property

PegasusImaging.WinForms.NotateXpress9 Namespace > GroupCollection Class : Item Property (GroupCollection)

Gets and sets the given group within the group collection.

[Visual Basic]
Public Default Property Item( _
   ByVal index As Integer _
) As Group
[C#]
public Group this[
   int index
]; {get; set;}
[C++]
public: __property Group* get_Item(
   int index
);
public: __property void set_Item(
   int index,
   Group* value
);
[C++/CLI]
public:
 property Group^ default [int] {
   Group^ get(int index);
   void set (int index, Group^ value);
}

Parameters

index
A zero-based value which determines the location a group is within a group collection.

Remarks

Note: VB.NET uses the item. myCollection.Item(1)

Note: C# .NET uses it differently - myCollection[1].

See Also

GroupCollection Class | GroupCollection Members


GroupCreationException Class

GroupCreationException Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GroupCreationException Class

PegasusImaging.WinForms.NotateXpress9 Namespace : GroupCreationException Class

Exception class which is raised when there are errors with groups.

For a list of all members of this type, see GroupCreationException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.NotateXpress9.NotateXpressException
PegasusImaging.WinForms.NotateXpress9.GroupCreationException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class GroupCreationException
   Inherits NotateXpressException
   Implements ISerializable, _Exception
[C#]
[SerializableAttribute()]
public sealed class GroupCreationException : NotateXpressException, ISerializable, _Exception
[C++]
[SerializableAttribute()]
public __gc __sealed class GroupCreationException : public NotateXpressException, ISerializable, _Exception
[C++/CLI]
[SerializableAttribute()]
public ref class GroupCreationException sealed : public NotateXpressException, ISerializable, _Exception

See Also

GroupCreationException Members | PegasusImaging.WinForms.NotateXpress9 Namespace


GroupCreationException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GroupCreationException Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : GroupCreationException Class

GroupCreationException overview

Public Constructors

Public Constructor GroupCreationException Constructor Overloaded. Main constructor for the GroupCreationException class when there are errors with groups.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

GroupCreationException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


GroupCreationException Constructor

GroupCreationException Class | GroupCreationException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GroupCreationException Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > GroupCreationException Class : GroupCreationException Constructor (GroupCreationException)

Main constructor for the GroupCreationException class when there are errors with groups.

Overload List

Main constructor for the GroupCreationException class when there are errors with groups.

[Visual Basic] Public Sub New()

[C#] public GroupCreationException();

[C++] public GroupCreationException();

[C++/CLI] public GroupCreationException();

Exception which allows passing in an error number when there are errors with groups.

[Visual Basic] Public Sub New(Integer)

[C#] public GroupCreationException(int);

[C++] public GroupCreationException(int);

[C++/CLI] public GroupCreationException(int);

Exception which allows passing in a message when there are errors with groups.

[Visual Basic] Public Sub New(String)

[C#] public GroupCreationException(string);

[C++] public GroupCreationException(string*);

[C++/CLI] public GroupCreationException(String^);

Exception which allows passing in an error number and message when there are errors with groups.

[Visual Basic] Public Sub New(Integer,String)

[C#] public GroupCreationException(int,string);

[C++] public GroupCreationException(int,string*);

[C++/CLI] public GroupCreationException(int,String^);

Exception which allows passing in a message and inner exception when there are errors with groups.

[Visual Basic] Public Sub New(String,Exception)

[C#] public GroupCreationException(string,Exception);

[C++] public GroupCreationException(string*,Exception*);

[C++/CLI] public GroupCreationException(String^,Exception^);

See Also

GroupCreationException Class | GroupCreationException Members


GroupCreationException Constructor()

GroupCreationException Class | GroupCreationException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GroupCreationException Constructor()

PegasusImaging.WinForms.NotateXpress9 Namespace > GroupCreationException Class > GroupCreationException Constructor : GroupCreationException Constructor()

Main constructor for the GroupCreationException class when there are errors with groups.

[Visual Basic]
Public Function New()
[C#]
public GroupCreationException();
[C++]
public: GroupCreationException();
[C++/CLI]
public:
GroupCreationException();

See Also

GroupCreationException Class | GroupCreationException Members | Overload List


GroupCreationException Constructor(Int32)

GroupCreationException Class | GroupCreationException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GroupCreationException Constructor(Int32)

PegasusImaging.WinForms.NotateXpress9 Namespace > GroupCreationException Class > GroupCreationException Constructor : GroupCreationException Constructor(Int32)

Exception which allows passing in an error number when there are errors with groups.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public GroupCreationException(
   int errorNumber
);
[C++]
public: GroupCreationException(
   int errorNumber
)
[C++/CLI]
public:
GroupCreationException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

GroupCreationException Class | GroupCreationException Members | Overload List


GroupCreationException Constructor(Int32,String)

GroupCreationException Class | GroupCreationException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GroupCreationException Constructor(Int32,String)

PegasusImaging.WinForms.NotateXpress9 Namespace > GroupCreationException Class > GroupCreationException Constructor : GroupCreationException Constructor(Int32,String)

Exception which allows passing in an error number and message when there are errors with groups.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public GroupCreationException(
   int errorNumber,
   string message
);
[C++]
public: GroupCreationException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
GroupCreationException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

GroupCreationException Class | GroupCreationException Members | Overload List


GroupCreationException Constructor(String)

GroupCreationException Class | GroupCreationException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A sring which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GroupCreationException Constructor(String)

PegasusImaging.WinForms.NotateXpress9 Namespace > GroupCreationException Class > GroupCreationException Constructor : GroupCreationException Constructor(String)

Exception which allows passing in a message when there are errors with groups.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public GroupCreationException(
   string message
);
[C++]
public: GroupCreationException(
   string* message
)
[C++/CLI]
public:
GroupCreationException(
   String^ message
)

Parameters

message
A sring which represents the message.

See Also

GroupCreationException Class | GroupCreationException Members | Overload List


GroupCreationException Constructor(String,Exception)

GroupCreationException Class | GroupCreationException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GroupCreationException Constructor(String,Exception)

PegasusImaging.WinForms.NotateXpress9 Namespace > GroupCreationException Class > GroupCreationException Constructor : GroupCreationException Constructor(String,Exception)

Exception which allows passing in a message and inner exception when there are errors with groups.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public GroupCreationException(
   string message,
   Exception innerException
);
[C++]
public: GroupCreationException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
GroupCreationException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception.

See Also

GroupCreationException Class | GroupCreationException Members | Overload List


GroupElementCollection Class

GroupElementCollection Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GroupElementCollection Class

PegasusImaging.WinForms.NotateXpress9 Namespace : GroupElementCollection Class

This class is used as a collection to manage elements in groups.

For a list of all members of this type, see GroupElementCollection members.

Object Model

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
PegasusImaging.WinForms.NotateXpress9.GroupElementCollection

Syntax

[Visual Basic]
<DefaultMemberAttribute("Item")>
Public Class GroupElementCollection
   Inherits CollectionBase
   Implements IList, ICollection, IEnumerable, IDisposable
[C#]
[DefaultMemberAttribute("Item")]
public class GroupElementCollection : CollectionBase, IList, ICollection, IEnumerable, IDisposable
[C++]
[DefaultMemberAttribute("Item")]
public __gc class GroupElementCollection : public CollectionBase, IList, ICollection, IEnumerable, IDisposable
[C++/CLI]
[DefaultMemberAttribute("Item")]
public ref class GroupElementCollection : public CollectionBase, IList, ICollection, IEnumerable, IDisposable

See Also

GroupElementCollection Members | PegasusImaging.WinForms.NotateXpress9 Namespace


GroupElementCollection Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GroupElementCollection Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : GroupElementCollection Class

GroupElementCollection overview

Public Properties

Public Property Capacity (Inherited from System.Collections.CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Public Property Count (Inherited from System.Collections.CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
Public Property GroupBoundingRectangle | Gets and sets the rectangle boundary area for elements in a group.
Public Property GroupSelected | Gets and sets an indication of whether the elements that belong to the group have been selected.
Public Property Item | Gets or sets the Element at the specified index.

Public Methods

Public Method Add | Adds the given element to the group element collection.
Public Method Clear | Clears the entire collection as well as calls the Clear function of the base class.
Public Method Contains | Determines if the collection contains this Element.
Public Method CopyTo | Copies the entire collection to an array, starting at index of the target array.
Public Method Dispose | Releases all resources used by this PegasusImaging.WinForms.NotateXpress9.ElementCollection object.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) | Returns an enumerator that iterates through the CollectionBase instance.
Public Method GroupInvert | Inverts the arrangement of all annotation items in a yoked annotation group.
Public Method GroupMirror | Mirrors the arrangement of all annotation items in a yoked annotation group.
Public Method IndexOf | Searches for the specified Object and returns the zero-based index of the first occurrence within the entire PageCollection.
Public Method Insert | Inserts a Element at the specified index.
Public Method Remove | Removes the Element from the collection.
Public Method RemoveAt | Remove operation for the document collection. Call the document destructor to free the document then remove the document from the collection.

See Also

GroupElementCollection Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Add Method

GroupElementCollection Class | GroupElementCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

element
The Element to add to the collection.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Add Method

PegasusImaging.WinForms.NotateXpress9 Namespace > GroupElementCollection Class : Add Method (GroupElementCollection)

Adds the given element to the group element collection.

[Visual Basic]
Public Function Add( _
   ByVal element As Element _
) As Integer
[C#]
public int Add(
   Element element
);
[C++]
public: int Add(
   Element* element
)
[C++/CLI]
public:
int Add(
   Element^ element
)

Parameters

element
The Element to add to the collection.

Return Type

An integer value which represents the index position of the newly added element.

Remarks

When adding to the group element collection, the associated group must be in a group collection, and the associated element must be in an element collection.

See Also

GroupElementCollection Class | GroupElementCollection Members


Clear Method

GroupElementCollection Class | GroupElementCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Clear Method

PegasusImaging.WinForms.NotateXpress9 Namespace > GroupElementCollection Class : Clear Method (GroupElementCollection)

Clears the entire collection as well as calls the Clear function of the base class.

[Visual Basic]
Public Sub Clear()
[C#]
public void Clear();
[C++]
public: void Clear();
[C++/CLI]
public:
void Clear();

See Also

GroupElementCollection Class | GroupElementCollection Members


Contains Method

GroupElementCollection Class | GroupElementCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

element
The Element to search for in the collection.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Contains Method

PegasusImaging.WinForms.NotateXpress9 Namespace > GroupElementCollection Class : Contains Method (GroupElementCollection)

Determines if the collection contains this Element.

[Visual Basic]
Public Function Contains( _
   ByVal element As Element _
) As Boolean
[C#]
public bool Contains(
   Element element
);
[C++]
public: bool Contains(
   Element* element
)
[C++/CLI]
public:
bool Contains(
   Element^ element
)

Parameters

element
The Element to search for in the collection.

Return Type

true if the collection contains the specified Element; otherwise, false. Implements

See Also

GroupElementCollection Class | GroupElementCollection Members


CopyTo Method

GroupElementCollection Class | GroupElementCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

array
The one-dimensional Array that is the destination of the elements copied from DocumentCollection. The Array must have zero-based indexing.
index
The zero-based index in array at which copying begins.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

CopyTo Method

PegasusImaging.WinForms.NotateXpress9 Namespace > GroupElementCollection Class : CopyTo Method (GroupElementCollection)

Copies the entire collection to an array, starting at index of the target array.

[Visual Basic]
Public Sub CopyTo( _
   ByVal array() As Element, _
   ByVal index As Integer _
)
[C#]
public void CopyTo(
   Element[] array,
   int index
);
[C++]
public: void CopyTo(
   Element*[]* array,
   int index
)
[C++/CLI]
public:
void CopyTo(
   Element^array<array>^ array,
   int index
)

Parameters

array
The one-dimensional Array that is the destination of the elements copied from DocumentCollection. The Array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

See Also

GroupElementCollection Class | GroupElementCollection Members


Dispose Method

GroupElementCollection Class | GroupElementCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Dispose Method

PegasusImaging.WinForms.NotateXpress9 Namespace > GroupElementCollection Class : Dispose Method (GroupElementCollection)

Releases all resources used by this PegasusImaging.WinForms.NotateXpress9.ElementCollection object.

[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();
[C++]
public: void Dispose();
[C++/CLI]
public:
void Dispose();

See Also

GroupElementCollection Class | GroupElementCollection Members


GroupInvert Method

GroupElementCollection Class | GroupElementCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GroupInvert Method

PegasusImaging.WinForms.NotateXpress9 Namespace > GroupElementCollection Class : GroupInvert Method

Inverts the arrangement of all annotation items in a yoked annotation group.

[Visual Basic]
Public Sub GroupInvert()
[C#]
public void GroupInvert();
[C++]
public: void GroupInvert();
[C++/CLI]
public:
void GroupInvert();

See Also

GroupElementCollection Class | GroupElementCollection Members


GroupMirror Method

GroupElementCollection Class | GroupElementCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GroupMirror Method

PegasusImaging.WinForms.NotateXpress9 Namespace > GroupElementCollection Class : GroupMirror Method

Mirrors the arrangement of all annotation items in a yoked annotation group.

[Visual Basic]
Public Sub GroupMirror()
[C#]
public void GroupMirror();
[C++]
public: void GroupMirror();
[C++/CLI]
public:
void GroupMirror();

See Also

GroupElementCollection Class | GroupElementCollection Members


IndexOf Method

GroupElementCollection Class | GroupElementCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

value
Object to locate in the collection.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

IndexOf Method

PegasusImaging.WinForms.NotateXpress9 Namespace > GroupElementCollection Class : IndexOf Method (GroupElementCollection)

Searches for the specified Object and returns the zero-based index of the first occurrence within the entire PageCollection.

[Visual Basic]
Public Function IndexOf( _
   ByVal value As Element _
) As Integer
[C#]
public int IndexOf(
   Element value
);
[C++]
public: int IndexOf(
   Element* value
)
[C++/CLI]
public:
int IndexOf(
   Element^ value
)

Parameters

value
Object to locate in the collection.

See Also

GroupElementCollection Class | GroupElementCollection Members


Insert Method

GroupElementCollection Class | GroupElementCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

index
The zero-based index at which the Element should be inserted.
element
The element.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Insert Method

PegasusImaging.WinForms.NotateXpress9 Namespace > GroupElementCollection Class : Insert Method (GroupElementCollection)

Inserts a Element at the specified index.

[Visual Basic]
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal element As Element _
)
[C#]
public void Insert(
   int index,
   Element element
);
[C++]
public: void Insert(
   int index,
   Element* element
)
[C++/CLI]
public:
void Insert(
   int index,
   Element^ element
)

Parameters

index
The zero-based index at which the Element should be inserted.
element
The element.

See Also

GroupElementCollection Class | GroupElementCollection Members


Remove Method

GroupElementCollection Class | GroupElementCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

element
The Element to remove from the collection.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Remove Method

PegasusImaging.WinForms.NotateXpress9 Namespace > GroupElementCollection Class : Remove Method (GroupElementCollection)

Removes the Element from the collection.

[Visual Basic]
Public Sub Remove( _
   ByVal element As Element _
)
[C#]
public void Remove(
   Element element
);
[C++]
public: void Remove(
   Element* element
)
[C++/CLI]
public:
void Remove(
   Element^ element
)

Parameters

element
The Element to remove from the collection.

See Also

GroupElementCollection Class | GroupElementCollection Members


RemoveAt Method

GroupElementCollection Class | GroupElementCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

index
An integer which represents the zero-based index position of the element within the collection.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

RemoveAt Method

PegasusImaging.WinForms.NotateXpress9 Namespace > GroupElementCollection Class : RemoveAt Method (GroupElementCollection)

Remove operation for the document collection. Call the document destructor to free the document then remove the document from the collection.

[Visual Basic]
Public Sub RemoveAt( _
   ByVal index As Integer _
)
[C#]
public void RemoveAt(
   int index
);
[C++]
public: void RemoveAt(
   int index
)
[C++/CLI]
public:
void RemoveAt(
   int index
)

Parameters

index
An integer which represents the zero-based index position of the element within the collection.

See Also

GroupElementCollection Class | GroupElementCollection Members


GroupElementCollection Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GroupElementCollection Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : GroupElementCollection Class

For a list of all members of this type, see GroupElementCollection members.

Public Properties

Public Property Capacity (Inherited from System.Collections.CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Public Property Count (Inherited from System.Collections.CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
Public Property GroupBoundingRectangle | Gets and sets the rectangle boundary area for elements in a group.
Public Property GroupSelected | Gets and sets an indication of whether the elements that belong to the group have been selected.
Public Property Item | Gets or sets the Element at the specified index.

See Also

GroupElementCollection Class | PegasusImaging.WinForms.NotateXpress9 Namespace


GroupBoundingRectangle Property

GroupElementCollection Class | GroupElementCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GroupBoundingRectangle Property

PegasusImaging.WinForms.NotateXpress9 Namespace > GroupElementCollection Class : GroupBoundingRectangle Property

Gets and sets the rectangle boundary area for elements in a group.

[Visual Basic]
Public Property GroupBoundingRectangle As Rectangle
[C#]
public Rectangle GroupBoundingRectangle {get; set;}
[C++]
public: __property Rectangle get_GroupBoundingRectangle();
public: __property void set_GroupBoundingRectangle(
   Rectangle value
);
[C++/CLI]
public:
property Rectangle GroupBoundingRectangle {
   Rectangle get();
   void set (Rectangle value);
}

Value

A Rectangle which defines the area.

See Also

GroupElementCollection Class | GroupElementCollection Members


GroupSelected Property

GroupElementCollection Class | GroupElementCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GroupSelected Property

PegasusImaging.WinForms.NotateXpress9 Namespace > GroupElementCollection Class : GroupSelected Property (GroupElementCollection)

Gets and sets an indication of whether the elements that belong to the group have been selected.

[Visual Basic]
Public Property GroupSelected As Boolean
[C#]
public bool GroupSelected {get; set;}
[C++]
public: __property bool get_GroupSelected();
public: __property void set_GroupSelected(
   bool value
);
[C++/CLI]
public:
property bool GroupSelected {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true if the group is selected. Otherwise, false is returned.

See Also

GroupElementCollection Class | GroupElementCollection Members


Item Property

GroupElementCollection Class | GroupElementCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

index
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Item Property

PegasusImaging.WinForms.NotateXpress9 Namespace > GroupElementCollection Class : Item Property (GroupElementCollection)

Gets or sets the Element at the specified index.

[Visual Basic]
Public Default Property Item( _
   ByVal index As Integer _
) As Element
[C#]
public Element this[
   int index
]; {get; set;}
[C++]
public: __property Element* get_Item(
   int index
);
public: __property void set_Item(
   int index,
   Element* value
);
[C++/CLI]
public:
 property Element^ default [int] {
   Element^ get(int index);
   void set (int index, Element^ value);
}

Parameters

index

Value

An integer value which represents the index which matches the Element.

See Also

GroupElementCollection Class | GroupElementCollection Members


GroupSelectedEventArgs Class

GroupSelectedEventArgs Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GroupSelectedEventArgs Class

PegasusImaging.WinForms.NotateXpress9 Namespace : GroupSelectedEventArgs Class

Arguments for GroupSelected event

For a list of all members of this type, see GroupSelectedEventArgs members.

Object Model

Inheritance Hierarchy

System.Object
System.EventArgs
PegasusImaging.WinForms.NotateXpress9.GroupSelectedEventArgs

Syntax

[Visual Basic]
Public Class GroupSelectedEventArgs
   Inherits EventArgs
[C#]
public class GroupSelectedEventArgs : EventArgs
[C++]
public __gc class GroupSelectedEventArgs : public EventArgs
[C++/CLI]
public ref class GroupSelectedEventArgs : public EventArgs

See Also

GroupSelectedEventArgs Members | PegasusImaging.WinForms.NotateXpress9 Namespace


GroupSelectedEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GroupSelectedEventArgs Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : GroupSelectedEventArgs Class

GroupSelectedEventArgs overview

Public Constructors

Public Constructor GroupSelectedEventArgs Constructor

Public Properties

Public Property Group Gets the group that was selected.

See Also

GroupSelectedEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace


GroupSelectedEventArgs Constructor

GroupSelectedEventArgs Class | GroupSelectedEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GroupSelectedEventArgs Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > GroupSelectedEventArgs Class : GroupSelectedEventArgs Constructor (GroupSelectedEventArgs)
[Visual Basic]
Public Function New()
[C#]
public GroupSelectedEventArgs();
[C++]
public: GroupSelectedEventArgs();
[C++/CLI]
public:
GroupSelectedEventArgs();

See Also

GroupSelectedEventArgs Class | GroupSelectedEventArgs Members


GroupSelectedEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GroupSelectedEventArgs Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : GroupSelectedEventArgs Class

For a list of all members of this type, see GroupSelectedEventArgs members.

Public Properties

Public Property Group Gets the group that was selected.

See Also

GroupSelectedEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Group Property

GroupSelectedEventArgs Class | GroupSelectedEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Group Property

PegasusImaging.WinForms.NotateXpress9 Namespace > GroupSelectedEventArgs Class : Group Property (GroupSelectedEventArgs)

Gets the group that was selected.

[Visual Basic]
Public Property Group As Group
[C#]
public Group Group {get; set;}
[C++]
public: __property Group* get_Group();
public: __property void set_Group(
   Group* value
);
[C++/CLI]
public:
property Group^ Group {
   Group^ get();
   void set (Group^ value);
}

See Also

GroupSelectedEventArgs Class | GroupSelectedEventArgs Members


ImageTool Class

ImageTool Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ImageTool Class

PegasusImaging.WinForms.NotateXpress9 Namespace : ImageTool Class

The ImageTool class is used to create image annotations, which display images.

For a list of all members of this type, see ImageTool members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.NotateXpress9.Element
PegasusImaging.WinForms.NotateXpress9.ImageTool

Syntax

[Visual Basic]
Public Class ImageTool
   Inherits Element
[C#]
public class ImageTool : Element
[C++]
public __gc class ImageTool : public Element
[C++/CLI]
public ref class ImageTool : public Element

See Also

ImageTool Members | PegasusImaging.WinForms.NotateXpress9 Namespace


ImageTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ImageTool Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : ImageTool Class

ImageTool overview

Public Constructors

Public Constructor ImageTool Constructor The default constructor for the ImageTool class.

Public Properties

Public Property AutoSize | Gets and sets whether or not the annotation size will be automatically expanded to fit the default image size.
Public Property BackStyle | Gets and sets the style of the background used within the image annotation.
Public Property BoundingRectangle (Inherited from Element) | Gets and sets the rectangle boundary for the element.
Public Property CreateTime (Inherited from Element) | A Read only property that gets the time when the element was created.
Public Property DibHandle | Gets and sets the DIB (Device Independent Bitmap) handle of the image displayed within the image annotation.
Public Property FillColor | Gets and sets the Color used to fill in the area of the image annotation.
Public Property Fixed (Inherited from Element) | Gets and sets whether an annotation has a fixed position with respect to the control window.
Public Property GroupMember (Inherited from Element) | Gets the group which the element belongs to.
Public Property HatchColor | Gets and sets the color of the hatch style used within the image annotation.
Public Property HatchStyle | Gets and sets the hatch style used within the image annotation.
Public Property IsGroupMember (Inherited from Element) | A read only property that gets a value which determines if the element is a member of a group or not.
Public Property Locked (Inherited from Element) | Gets and sets an indicator whether an annotation element can be selected or moved by a user in Edit mode.
Public Property Moveable (Inherited from Element) | Gets and sets whether the element can be moved by a user in Edit mode.
Public Property NumberPoints (Inherited from Element) | A Read only property that gets the number of points currently used to define the element.
Public Property PenColor | Gets and sets the color of the pen used to draw the border around the image annotation.
Public Property PenWidth | Gets and sets the width of the pen used to draw the border of the image annotation.
Public Property Selected (Inherited from Element) | Gets and sets whether the element has been selected.
Public Property ShowHandles (Inherited from Element) | Gets and sets whether selection handles are displayed on an object when it is selected.
Public Property Sizeable (Inherited from Element) | Gets and sets whether the element can be resized.
Public Property ToolTipText (Inherited from Element) | Gets and sets a string value in the element that will become the ToolTipText value associated with the element.
Public Property TransparentColor | Gets and sets the Color which will be transparent within the image displayed in the image annotation.
Public Property UserLong (Inherited from Element) | Gets and sets a user defined long value associated with the element.
Public Property UserString (Inherited from Element) | Gets and sets a user-defined string associated with the element.
Public Property Visible (Inherited from Element) | Gets and sets whether the element is visible.

Public Methods

Public Method NudgeDown (Inherited from Element) | Moves the specified annotation object one level down, towards the back, in the painting order of the specified layer.
Public Method NudgeUp (Inherited from Element) | Moves the specified annotation object one level up, towards the front, in the painting order of the specified layer.
Public Method UserDataAdd (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataDelete (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFind (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFindFirst (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFindNext (Inherited from Element) | User data can be added to each element in a key value pair.

See Also

ImageTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace


ImageTool Constructor

ImageTool Class | ImageTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ImageTool Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > ImageTool Class : ImageTool Constructor (ImageTool)

The default constructor for the ImageTool class.

[Visual Basic]
Public Function New()
[C#]
public ImageTool();
[C++]
public: ImageTool();
[C++/CLI]
public:
ImageTool();

See Also

ImageTool Class | ImageTool Members


ImageTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ImageTool Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : ImageTool Class

For a list of all members of this type, see ImageTool members.

Public Properties

Public Property AutoSize | Gets and sets whether or not the annotation size will be automatically expanded to fit the default image size.
Public Property BackStyle | Gets and sets the style of the background used within the image annotation.
Public Property BoundingRectangle (Inherited from Element) | Gets and sets the rectangle boundary for the element.
Public Property CreateTime (Inherited from Element) | A Read only property that gets the time when the element was created.
Public Property DibHandle | Gets and sets the DIB (Device Independent Bitmap) handle of the image displayed within the image annotation.
Public Property FillColor | Gets and sets the Color used to fill in the area of the image annotation.
Public Property Fixed (Inherited from Element) | Gets and sets whether an annotation has a fixed position with respect to the control window.
Public Property GroupMember (Inherited from Element) | Gets the group which the element belongs to.
Public Property HatchColor | Gets and sets the color of the hatch style used within the image annotation.
Public Property HatchStyle | Gets and sets the hatch style used within the image annotation.
Public Property IsGroupMember (Inherited from Element) | A read only property that gets a value which determines if the element is a member of a group or not.
Public Property Locked (Inherited from Element) | Gets and sets an indicator whether an annotation element can be selected or moved by a user in Edit mode.
Public Property Moveable (Inherited from Element) | Gets and sets whether the element can be moved by a user in Edit mode.
Public Property NumberPoints (Inherited from Element) | A Read only property that gets the number of points currently used to define the element.
Public Property PenColor | Gets and sets the color of the pen used to draw the border around the image annotation.
Public Property PenWidth | Gets and sets the width of the pen used to draw the border of the image annotation.
Public Property Selected (Inherited from Element) | Gets and sets whether the element has been selected.
Public Property ShowHandles (Inherited from Element) | Gets and sets whether selection handles are displayed on an object when it is selected.
Public Property Sizeable (Inherited from Element) | Gets and sets whether the element can be resized.
Public Property ToolTipText (Inherited from Element) | Gets and sets a string value in the element that will become the ToolTipText value associated with the element.
Public Property TransparentColor | Gets and sets the Color which will be transparent within the image displayed in the image annotation.
Public Property UserLong (Inherited from Element) | Gets and sets a user defined long value associated with the element.
Public Property UserString (Inherited from Element) | Gets and sets a user-defined string associated with the element.
Public Property Visible (Inherited from Element) | Gets and sets whether the element is visible.

See Also

ImageTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace


AutoSize Property

ImageTool Class | ImageTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

AutoSize Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ImageTool Class : AutoSize Property (ImageTool)

Gets and sets whether or not the annotation size will be automatically expanded to fit the default image size.

[Visual Basic]
Public Property AutoSize As AutoSize
[C#]
public AutoSize AutoSize {get; set;}
[C++]
public: __property AutoSize get_AutoSize();
public: __property void set_AutoSize(
   AutoSize value
);
[C++/CLI]
public:
property AutoSize AutoSize {
   AutoSize get();
   void set (AutoSize value);
}

Value

The type of bounding to the image.

See Also

ImageTool Class | ImageTool Members


BackStyle Property

ImageTool Class | ImageTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BackStyle Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ImageTool Class : BackStyle Property (ImageTool)

Gets and sets the style of the background used within the image annotation.

[Visual Basic]
Public Property BackStyle As BackStyle
[C#]
public BackStyle BackStyle {get; set;}
[C++]
public: __property BackStyle get_BackStyle();
public: __property void set_BackStyle(
   BackStyle value
);
[C++/CLI]
public:
property BackStyle BackStyle {
   BackStyle get();
   void set (BackStyle value);
}

Value

The BackStyle enumeration value which represents the background style.

See Also

ImageTool Class | ImageTool Members


DibHandle Property

ImageTool Class | ImageTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

DibHandle Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ImageTool Class : DibHandle Property (ImageTool)

Gets and sets the DIB (Device Independent Bitmap) handle of the image displayed within the image annotation.

[Visual Basic]
Public Property DibHandle As IntPtr
[C#]
public IntPtr DibHandle {get; set;}
[C++]
public: __property IntPtr get_DibHandle();
public: __property void set_DibHandle(
   IntPtr value
);
[C++/CLI]
public:
property IntPtr DibHandle {
   IntPtr get();
   void set (IntPtr value);
}

Value

An integer pointer value which represents the DIB handle.

Remarks

The DIB handle attribute of an image tool determines what will be copied as the DIB handle for every image object created with this programmable element.

The easy way of getting a DIB handle is to use the ImagXpress component.

See Also

ImageTool Class | ImageTool Members


FillColor Property

ImageTool Class | ImageTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

FillColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ImageTool Class : FillColor Property (ImageTool)

Gets and sets the Color used to fill in the area of the image annotation.

[Visual Basic]
Public Property FillColor As Color
[C#]
public Color FillColor {get; set;}
[C++]
public: __property Color get_FillColor();
public: __property void set_FillColor(
   Color value
);
[C++/CLI]
public:
property Color FillColor {
   Color get();
   void set (Color value);
}

Value

The Color value set.

See Also

ImageTool Class | ImageTool Members


HatchColor Property

ImageTool Class | ImageTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HatchColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ImageTool Class : HatchColor Property (ImageTool)

Gets and sets the color of the hatch style used within the image annotation.

[Visual Basic]
Public Property HatchColor As Color
[C#]
public Color HatchColor {get; set;}
[C++]
public: __property Color get_HatchColor();
public: __property void set_HatchColor(
   Color value
);
[C++/CLI]
public:
property Color HatchColor {
   Color get();
   void set (Color value);
}

Value

A Color value which represents the color of the hatch style.

Remarks

The HatchColor is the color of the hatch strokes on a filled object whose HatchStyle attribute is something other than HatchStyle_None.

See Also

ImageTool Class | ImageTool Members


HatchStyle Property

ImageTool Class | ImageTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HatchStyle Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ImageTool Class : HatchStyle Property (ImageTool)

Gets and sets the hatch style used within the image annotation.

[Visual Basic]
Public Property HatchStyle As HatchStyle
[C#]
public HatchStyle HatchStyle {get; set;}
[C++]
public: __property HatchStyle get_HatchStyle();
public: __property void set_HatchStyle(
   HatchStyle value
);
[C++/CLI]
public:
property HatchStyle HatchStyle {
   HatchStyle get();
   void set (HatchStyle value);
}

Value

The HatchStyle enumeration value which represents the hatch style used within the image annotation.

See Also

ImageTool Class | ImageTool Members


PenColor Property

ImageTool Class | ImageTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PenColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ImageTool Class : PenColor Property (ImageTool)

Gets and sets the color of the pen used to draw the border around the image annotation.

[Visual Basic]
Public Property PenColor As Color
[C#]
public Color PenColor {get; set;}
[C++]
public: __property Color get_PenColor();
public: __property void set_PenColor(
   Color value
);
[C++/CLI]
public:
property Color PenColor {
   Color get();
   void set (Color value);
}

Value

The Color value set.

See Also

ImageTool Class | ImageTool Members


PenWidth Property

ImageTool Class | ImageTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PenWidth Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ImageTool Class : PenWidth Property (ImageTool)

Gets and sets the width of the pen used to draw the border of the image annotation.

[Visual Basic]
Public Property PenWidth As Integer
[C#]
public int PenWidth {get; set;}
[C++]
public: __property int get_PenWidth();
public: __property void set_PenWidth(
   int value
);
[C++/CLI]
public:
property int PenWidth {
   int get();
   void set (int value);
}

Value

An integer value which represents the pen width, in pixels.

Remarks

The default value is 1.

See Also

ImageTool Class | ImageTool Members


TransparentColor Property

ImageTool Class | ImageTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TransparentColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ImageTool Class : TransparentColor Property (ImageTool)

Gets and sets the Color which will be transparent within the image displayed in the image annotation.

[Visual Basic]
Public Property TransparentColor As Color
[C#]
public Color TransparentColor {get; set;}
[C++]
public: __property Color get_TransparentColor();
public: __property void set_TransparentColor(
   Color value
);
[C++/CLI]
public:
property Color TransparentColor {
   Color get();
   void set (Color value);
}

Value

The Color value set.

Remarks

The TransparentColor is the color in the image that will show through to what is underneath the object.

See Also

ImageTool Class | ImageTool Members


ImageToolbarDefaults Class

ImageToolbarDefaults Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ImageToolbarDefaults Class

PegasusImaging.WinForms.NotateXpress9 Namespace : ImageToolbarDefaults Class (PegasusImaging.WinForms.NotateXpress9)

The ImageToolDefaults class is the default class used to create Image annotations.

For a list of all members of this type, see ImageToolbarDefaults members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.NotateXpress9.BaseToolbarDefaults
PegasusImaging.WinForms.NotateXpress9.ImageToolbarDefaults

Syntax

[Visual Basic]
Public Class ImageToolbarDefaults
   Inherits BaseToolbarDefaults
[C#]
public class ImageToolbarDefaults : BaseToolbarDefaults
[C++]
public __gc class ImageToolbarDefaults : public BaseToolbarDefaults
[C++/CLI]
public ref class ImageToolbarDefaults : public BaseToolbarDefaults

See Also

ImageToolbarDefaults Members | PegasusImaging.WinForms.NotateXpress9 Namespace


ImageToolbarDefaults Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ImageToolbarDefaults Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : ImageToolbarDefaults Class (PegasusImaging.WinForms.NotateXpress9)

ImageToolbarDefaults overview

Public Constructors

Public Constructor ImageToolbarDefaults Constructor The default constructor for the ImageToolbarDefaults class.

Public Properties

Public Property AutoSize | This property sets or returns whether or not the annotation size will be automatically expanded to fit the default image size.
Public Property BackStyle | Gets and sets the style of the background used within the image annotation.
Public Property DibHandle | Gets and sets the DIB (Device Independent Bitmap) handle of the image displayed within the image annotation.
Public Property FillColor | Gets and sets the Color used to fill in the area of the image annotation.
Public Property Fixed (Inherited from BaseToolbarDefaults) | Gets and sets whether an element is tied to the view instead of the image.
Public Property HatchColor | Gets and sets the color of the hatch color used within the image annotation.
Public Property HatchStyle | Gets and sets the hatch style used within the image annotation.
Public Property Locked (Inherited from BaseToolbarDefaults) | Gets and sets an indicator to lock an element so it cannot be selected or moved by a user in Edit mode.
Public Property Moveable (Inherited from BaseToolbarDefaults) | Gets and sets whether an element can be moved interactively during EditMode.
Public Property PenColor | Gets and sets the color of the pen used to draw the border around the image annotation.
Public Property PenWidth | Gets and sets the width of the pen used to draw the border of the image annotation.
Public Property Selected (Inherited from BaseToolbarDefaults) | Gets and sets whether an element is automatically selected.
Public Property ShowHandles (Inherited from BaseToolbarDefaults) | Gets and sets whether selection handles are displayed for an element.
Public Property Sizeable (Inherited from BaseToolbarDefaults) | Gets and sets whether an element can be sized interactively during EditMode.
Public Property ToolTipText (Inherited from BaseToolbarDefaults) | Gets or sets a string value in the element that will become the ToolTipText value associated with the annotation once it is created.
Public Property TransparentColor | Gets and sets the Color which will be transparent within the image displayed in the image annotation.
Public Property UserLong (Inherited from BaseToolbarDefaults) | Gets and sets a long value in the element that will become the UserLong value associated with the element once it is created.
Public Property UserString (Inherited from BaseToolbarDefaults) | Gets and sets a string value in the element that will become the UserString value associated with the object once it is created.
Public Property Visible (Inherited from BaseToolbarDefaults) | Gets and sets the Visible attribute of an element.

See Also

ImageToolbarDefaults Class | PegasusImaging.WinForms.NotateXpress9 Namespace


ImageToolbarDefaults Constructor

ImageToolbarDefaults Class | ImageToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ImageToolbarDefaults Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > ImageToolbarDefaults Class : ImageToolbarDefaults Constructor (ImageToolbarDefaults)

The default constructor for the ImageToolbarDefaults class.

[Visual Basic]
Public Function New()
[C#]
public ImageToolbarDefaults();
[C++]
public: ImageToolbarDefaults();
[C++/CLI]
public:
ImageToolbarDefaults();

See Also

ImageToolbarDefaults Class | ImageToolbarDefaults Members


ImageToolbarDefaults Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ImageToolbarDefaults Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : ImageToolbarDefaults Class (PegasusImaging.WinForms.NotateXpress9)

For a list of all members of this type, see ImageToolbarDefaults members.

Public Properties

Public Property AutoSize | This property sets or returns whether or not the annotation size will be automatically expanded to fit the default image size.
Public Property BackStyle | Gets and sets the style of the background used within the image annotation.
Public Property DibHandle | Gets and sets the DIB (Device Independent Bitmap) handle of the image displayed within the image annotation.
Public Property FillColor | Gets and sets the Color used to fill in the area of the image annotation.
Public Property Fixed (Inherited from BaseToolbarDefaults) | Gets and sets whether an element is tied to the view instead of the image.
Public Property HatchColor | Gets and sets the color of the hatch color used within the image annotation.
Public Property HatchStyle | Gets and sets the hatch style used within the image annotation.
Public Property Locked (Inherited from BaseToolbarDefaults) | Gets and sets an indicator to lock an element so it cannot be selected or moved by a user in Edit mode.
Public Property Moveable (Inherited from BaseToolbarDefaults) | Gets and sets whether an element can be moved interactively during EditMode.
Public Property PenColor | Gets and sets the color of the pen used to draw the border around the image annotation.
Public Property PenWidth | Gets and sets the width of the pen used to draw the border of the image annotation.
Public Property Selected (Inherited from BaseToolbarDefaults) | Gets and sets whether an element is automatically selected.
Public Property ShowHandles (Inherited from BaseToolbarDefaults) | Gets and sets whether selection handles are displayed for an element.
Public Property Sizeable (Inherited from BaseToolbarDefaults) | Gets and sets whether an element can be sized interactively during EditMode.
Public Property ToolTipText (Inherited from BaseToolbarDefaults) | Gets or sets a string value in the element that will become the ToolTipText value associated with the annotation once it is created.
Public Property TransparentColor | Gets and sets the Color which will be transparent within the image displayed in the image annotation.
Public Property UserLong (Inherited from BaseToolbarDefaults) | Gets and sets a long value in the element that will become the UserLong value associated with the element once it is created.
Public Property UserString (Inherited from BaseToolbarDefaults) | Gets and sets a string value in the element that will become the UserString value associated with the object once it is created.
Public Property Visible (Inherited from BaseToolbarDefaults) | Gets and sets the Visible attribute of an element.

See Also

ImageToolbarDefaults Class | PegasusImaging.WinForms.NotateXpress9 Namespace


AutoSize Property

ImageToolbarDefaults Class | ImageToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

AutoSize Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ImageToolbarDefaults Class : AutoSize Property (ImageToolbarDefaults)

This property sets or returns whether or not the annotation size will be automatically expanded to fit the default image size.

[Visual Basic]
Public Property AutoSize As AutoSize
[C#]
public AutoSize AutoSize {get; set;}
[C++]
public: __property AutoSize get_AutoSize();
public: __property void set_AutoSize(
   AutoSize value
);
[C++/CLI]
public:
property AutoSize AutoSize {
   AutoSize get();
   void set (AutoSize value);
}

Value

The type of bounding to the image.

See Also

ImageToolbarDefaults Class | ImageToolbarDefaults Members


BackStyle Property

ImageToolbarDefaults Class | ImageToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BackStyle Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ImageToolbarDefaults Class : BackStyle Property (ImageToolbarDefaults)

Gets and sets the style of the background used within the image annotation.

[Visual Basic]
Public Property BackStyle As BackStyle
[C#]
public BackStyle BackStyle {get; set;}
[C++]
public: __property BackStyle get_BackStyle();
public: __property void set_BackStyle(
   BackStyle value
);
[C++/CLI]
public:
property BackStyle BackStyle {
   BackStyle get();
   void set (BackStyle value);
}

Value

The BackStyle enumeration value set.

See Also

ImageToolbarDefaults Class | ImageToolbarDefaults Members


DibHandle Property

ImageToolbarDefaults Class | ImageToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

DibHandle Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ImageToolbarDefaults Class : DibHandle Property (ImageToolbarDefaults)

Gets and sets the DIB (Device Independent Bitmap) handle of the image displayed within the image annotation.

[Visual Basic]
Public Property DibHandle As IntPtr
[C#]
public IntPtr DibHandle {get; set;}
[C++]
public: __property IntPtr get_DibHandle();
public: __property void set_DibHandle(
   IntPtr value
);
[C++/CLI]
public:
property IntPtr DibHandle {
   IntPtr get();
   void set (IntPtr value);
}

Value

An integer pointer value which represents the DIB handle.

Remarks

The DIB handle attribute of an image tool determines what will be copied as the DIB handle for every image object created with this programmable element.

The easy way of getting a DIB handle is to use the ImagXpress component.

See Also

ImageToolbarDefaults Class | ImageToolbarDefaults Members


FillColor Property

ImageToolbarDefaults Class | ImageToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

FillColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ImageToolbarDefaults Class : FillColor Property (ImageToolbarDefaults)

Gets and sets the Color used to fill in the area of the image annotation.

[Visual Basic]
Public Property FillColor As Color
[C#]
public Color FillColor {get; set;}
[C++]
public: __property Color get_FillColor();
public: __property void set_FillColor(
   Color value
);
[C++/CLI]
public:
property Color FillColor {
   Color get();
   void set (Color value);
}

Value

The Color value which is used to fill in the area of the image annotation.

See Also

ImageToolbarDefaults Class | ImageToolbarDefaults Members


HatchColor Property

ImageToolbarDefaults Class | ImageToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HatchColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ImageToolbarDefaults Class : HatchColor Property (ImageToolbarDefaults)

Gets and sets the color of the hatch color used within the image annotation.

[Visual Basic]
Public Property HatchColor As Color
[C#]
public Color HatchColor {get; set;}
[C++]
public: __property Color get_HatchColor();
public: __property void set_HatchColor(
   Color value
);
[C++/CLI]
public:
property Color HatchColor {
   Color get();
   void set (Color value);
}

Value

The Color of the hatch.

Remarks

The HatchColor is the color of the hatch strokes on a filled object whose HatchStyle attribute is something other than HatchStyle_None.

See Also

ImageToolbarDefaults Class | ImageToolbarDefaults Members


HatchStyle Property

ImageToolbarDefaults Class | ImageToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HatchStyle Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ImageToolbarDefaults Class : HatchStyle Property (ImageToolbarDefaults)

Gets and sets the hatch style used within the image annotation.

[Visual Basic]
Public Property HatchStyle As HatchStyle
[C#]
public HatchStyle HatchStyle {get; set;}
[C++]
public: __property HatchStyle get_HatchStyle();
public: __property void set_HatchStyle(
   HatchStyle value
);
[C++/CLI]
public:
property HatchStyle HatchStyle {
   HatchStyle get();
   void set (HatchStyle value);
}

Value

The HatchStyle enumeration value set.

See Also

ImageToolbarDefaults Class | ImageToolbarDefaults Members


PenColor Property

ImageToolbarDefaults Class | ImageToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PenColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ImageToolbarDefaults Class : PenColor Property (ImageToolbarDefaults)

Gets and sets the color of the pen used to draw the border around the image annotation.

[Visual Basic]
Public Property PenColor As Color
[C#]
public Color PenColor {get; set;}
[C++]
public: __property Color get_PenColor();
public: __property void set_PenColor(
   Color value
);
[C++/CLI]
public:
property Color PenColor {
   Color get();
   void set (Color value);
}

Value

The Color value which represents the color of the pen used to draw the border around the image annotation.

See Also

ImageToolbarDefaults Class | ImageToolbarDefaults Members


PenWidth Property

ImageToolbarDefaults Class | ImageToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PenWidth Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ImageToolbarDefaults Class : PenWidth Property (ImageToolbarDefaults)

Gets and sets the width of the pen used to draw the border of the image annotation.

[Visual Basic]
Public Property PenWidth As Integer
[C#]
public int PenWidth {get; set;}
[C++]
public: __property int get_PenWidth();
public: __property void set_PenWidth(
   int value
);
[C++/CLI]
public:
property int PenWidth {
   int get();
   void set (int value);
}

Value

An integer value which represents the pen width, in pixels.

Remarks

The default value is 1.

See Also

ImageToolbarDefaults Class | ImageToolbarDefaults Members


TransparentColor Property

ImageToolbarDefaults Class | ImageToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TransparentColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ImageToolbarDefaults Class : TransparentColor Property (ImageToolbarDefaults)

Gets and sets the Color which will be transparent within the image displayed in the image annotation.

[Visual Basic]
Public Property TransparentColor As Color
[C#]
public Color TransparentColor {get; set;}
[C++]
public: __property Color get_TransparentColor();
public: __property void set_TransparentColor(
   Color value
);
[C++/CLI]
public:
property Color TransparentColor {
   Color get();
   void set (Color value);
}

Value

The Color value set.

Remarks

The TransparentColor is the color in the image that will show through to what is underneath the object.

See Also

ImageToolbarDefaults Class | ImageToolbarDefaults Members


InvalidAnnotationFileException Class

InvalidAnnotationFileException Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidAnnotationFileException Class

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidAnnotationFileException Class

Exception class raised when there are errors with the annotation files.

For a list of all members of this type, see InvalidAnnotationFileException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.NotateXpress9.NotateXpressException
PegasusImaging.WinForms.NotateXpress9.InvalidAnnotationFileException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class InvalidAnnotationFileException
   Inherits NotateXpressException
   Implements ISerializable, _Exception
[C#]
[SerializableAttribute()]
public sealed class InvalidAnnotationFileException : NotateXpressException, ISerializable, _Exception
[C++]
[SerializableAttribute()]
public __gc __sealed class InvalidAnnotationFileException : public NotateXpressException, ISerializable, _Exception
[C++/CLI]
[SerializableAttribute()]
public ref class InvalidAnnotationFileException sealed : public NotateXpressException, ISerializable, _Exception

See Also

InvalidAnnotationFileException Members | PegasusImaging.WinForms.NotateXpress9 Namespace


InvalidAnnotationFileException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidAnnotationFileException Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidAnnotationFileException Class

InvalidAnnotationFileException overview

Public Constructors

Public Constructor InvalidAnnotationFileException Constructor Overloaded. Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InvalidAnnotationFileException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


InvalidAnnotationFileException Constructor

InvalidAnnotationFileException Class | InvalidAnnotationFileException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidAnnotationFileException Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidAnnotationFileException Class : InvalidAnnotationFileException Constructor (InvalidAnnotationFileException)

Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

Overload List

Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

[Visual Basic] Public Sub New()

[C#] public InvalidAnnotationFileException();

[C++] public InvalidAnnotationFileException();

[C++/CLI] public InvalidAnnotationFileException();

Exception which allows passing in an error number when there are errors with the annotation files.

[Visual Basic] Public Sub New(Integer)

[C#] public InvalidAnnotationFileException(int);

[C++] public InvalidAnnotationFileException(int);

[C++/CLI] public InvalidAnnotationFileException(int);

Exception which allows passing in a message when thee are errors with the annotation files.

[Visual Basic] Public Sub New(String)

[C#] public InvalidAnnotationFileException(string);

[C++] public InvalidAnnotationFileException(string*);

[C++/CLI] public InvalidAnnotationFileException(String^);

Exception which allows passing in an error number and message when there are errors with the annotation files.

[Visual Basic] Public Sub New(Integer,String)

[C#] public InvalidAnnotationFileException(int,string);

[C++] public InvalidAnnotationFileException(int,string*);

[C++/CLI] public InvalidAnnotationFileException(int,String^);

Exception which allows passing in a message and inner exception when there are errors with the annotation files.

[Visual Basic] Public Sub New(String,Exception)

[C#] public InvalidAnnotationFileException(string,Exception);

[C++] public InvalidAnnotationFileException(string*,Exception*);

[C++/CLI] public InvalidAnnotationFileException(String^,Exception^);

See Also

InvalidAnnotationFileException Class | InvalidAnnotationFileException Members


InvalidAnnotationFileException Constructor()

InvalidAnnotationFileException Class | InvalidAnnotationFileException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidAnnotationFileException Constructor()

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidAnnotationFileException Class > InvalidAnnotationFileException Constructor : InvalidAnnotationFileException Constructor()

Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

[Visual Basic]
Public Function New()
[C#]
public InvalidAnnotationFileException();
[C++]
public: InvalidAnnotationFileException();
[C++/CLI]
public:
InvalidAnnotationFileException();

See Also

InvalidAnnotationFileException Class | InvalidAnnotationFileException Members | Overload List


InvalidAnnotationFileException Constructor(Int32)

InvalidAnnotationFileException Class | InvalidAnnotationFileException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidAnnotationFileException Constructor(Int32)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidAnnotationFileException Class > InvalidAnnotationFileException Constructor : InvalidAnnotationFileException Constructor(Int32)

Exception which allows passing in an error number when there are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public InvalidAnnotationFileException(
   int errorNumber
);
[C++]
public: InvalidAnnotationFileException(
   int errorNumber
)
[C++/CLI]
public:
InvalidAnnotationFileException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

InvalidAnnotationFileException Class | InvalidAnnotationFileException Members | Overload List


InvalidAnnotationFileException Constructor(Int32,String)

InvalidAnnotationFileException Class | InvalidAnnotationFileException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidAnnotationFileException Constructor(Int32,String)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidAnnotationFileException Class > InvalidAnnotationFileException Constructor : InvalidAnnotationFileException Constructor(Int32,String)

Exception which allows passing in an error number and message when there are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public InvalidAnnotationFileException(
   int errorNumber,
   string message
);
[C++]
public: InvalidAnnotationFileException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
InvalidAnnotationFileException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

InvalidAnnotationFileException Class | InvalidAnnotationFileException Members | Overload List


InvalidAnnotationFileException Constructor(String)

InvalidAnnotationFileException Class | InvalidAnnotationFileException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidAnnotationFileException Constructor(String)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidAnnotationFileException Class > InvalidAnnotationFileException Constructor : InvalidAnnotationFileException Constructor(String)

Exception which allows passing in a message when thee are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public InvalidAnnotationFileException(
   string message
);
[C++]
public: InvalidAnnotationFileException(
   string* message
)
[C++/CLI]
public:
InvalidAnnotationFileException(
   String^ message
)

Parameters

message
A string which represents the message.

See Also

InvalidAnnotationFileException Class | InvalidAnnotationFileException Members | Overload List


InvalidAnnotationFileException Constructor(String,Exception)

InvalidAnnotationFileException Class | InvalidAnnotationFileException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidAnnotationFileException Constructor(String,Exception)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidAnnotationFileException Class > InvalidAnnotationFileException Constructor : InvalidAnnotationFileException Constructor(String,Exception)

Exception which allows passing in a message and inner exception when there are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public InvalidAnnotationFileException(
   string message,
   Exception innerException
);
[C++]
public: InvalidAnnotationFileException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
InvalidAnnotationFileException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception.

See Also

InvalidAnnotationFileException Class | InvalidAnnotationFileException Members | Overload List


InvalidAttributeException Class

InvalidAttributeException Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidAttributeException Class

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidAttributeException Class

Exception class which is raised when there are errors with attributes.

For a list of all members of this type, see InvalidAttributeException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.NotateXpress9.NotateXpressException
PegasusImaging.WinForms.NotateXpress9.InvalidAttributeException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class InvalidAttributeException
   Inherits NotateXpressException
   Implements ISerializable, _Exception
[C#]
[SerializableAttribute()]
public sealed class InvalidAttributeException : NotateXpressException, ISerializable, _Exception
[C++]
[SerializableAttribute()]
public __gc __sealed class InvalidAttributeException : public NotateXpressException, ISerializable, _Exception
[C++/CLI]
[SerializableAttribute()]
public ref class InvalidAttributeException sealed : public NotateXpressException, ISerializable, _Exception

See Also

InvalidAttributeException Members | PegasusImaging.WinForms.NotateXpress9 Namespace


InvalidAttributeException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidAttributeException Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidAttributeException Class

InvalidAttributeException overview

Public Constructors

Public Constructor InvalidAttributeException Constructor Overloaded. Main constructor for the InvalidAttributeException class when there are errors with attributes.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InvalidAttributeException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


InvalidAttributeException Constructor

InvalidAttributeException Class | InvalidAttributeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidAttributeException Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidAttributeException Class : InvalidAttributeException Constructor (InvalidAttributeException)

Main constructor for the InvalidAttributeException class when there are errors with attributes.

Overload List

Main constructor for the InvalidAttributeException class when there are errors with attributes.

[Visual Basic] Public Sub New()

[C#] public InvalidAttributeException();

[C++] public InvalidAttributeException();

[C++/CLI] public InvalidAttributeException();

Exception which allows passing in an error number when there are errors with attributes.

[Visual Basic] Public Sub New(Integer)

[C#] public InvalidAttributeException(int);

[C++] public InvalidAttributeException(int);

[C++/CLI] public InvalidAttributeException(int);

Exception which allows passing in a message when there are errors with attributes.

[Visual Basic] Public Sub New(String)

[C#] public InvalidAttributeException(string);

[C++] public InvalidAttributeException(string*);

[C++/CLI] public InvalidAttributeException(String^);

Exception which allows passing in an error number and message when there are errors with attributes.

[Visual Basic] Public Sub New(Integer,String)

[C#] public InvalidAttributeException(int,string);

[C++] public InvalidAttributeException(int,string*);

[C++/CLI] public InvalidAttributeException(int,String^);

Exception which allows passing in a message and inner exception when there are errors with attributes.

[Visual Basic] Public Sub New(String,Exception)

[C#] public InvalidAttributeException(string,Exception);

[C++] public InvalidAttributeException(string*,Exception*);

[C++/CLI] public InvalidAttributeException(String^,Exception^);

See Also

InvalidAttributeException Class | InvalidAttributeException Members


InvalidAttributeException Constructor()

InvalidAttributeException Class | InvalidAttributeException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidAttributeException Constructor()

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidAttributeException Class > InvalidAttributeException Constructor : InvalidAttributeException Constructor()

Main constructor for the InvalidAttributeException class when there are errors with attributes.

[Visual Basic]
Public Function New()
[C#]
public InvalidAttributeException();
[C++]
public: InvalidAttributeException();
[C++/CLI]
public:
InvalidAttributeException();

See Also

InvalidAttributeException Class | InvalidAttributeException Members | Overload List


InvalidAttributeException Constructor(Int32)

InvalidAttributeException Class | InvalidAttributeException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidAttributeException Constructor(Int32)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidAttributeException Class > InvalidAttributeException Constructor : InvalidAttributeException Constructor(Int32)

Exception which allows passing in an error number when there are errors with attributes.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public InvalidAttributeException(
   int errorNumber
);
[C++]
public: InvalidAttributeException(
   int errorNumber
)
[C++/CLI]
public:
InvalidAttributeException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

InvalidAttributeException Class | InvalidAttributeException Members | Overload List


InvalidAttributeException Constructor(Int32,String)

InvalidAttributeException Class | InvalidAttributeException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidAttributeException Constructor(Int32,String)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidAttributeException Class > InvalidAttributeException Constructor : InvalidAttributeException Constructor(Int32,String)

Exception which allows passing in an error number and message when there are errors with attributes.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public InvalidAttributeException(
   int errorNumber,
   string message
);
[C++]
public: InvalidAttributeException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
InvalidAttributeException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

InvalidAttributeException Class | InvalidAttributeException Members | Overload List


InvalidAttributeException Constructor(String)

InvalidAttributeException Class | InvalidAttributeException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidAttributeException Constructor(String)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidAttributeException Class > InvalidAttributeException Constructor : InvalidAttributeException Constructor(String)

Exception which allows passing in a message when there are errors with attributes.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public InvalidAttributeException(
   string message
);
[C++]
public: InvalidAttributeException(
   string* message
)
[C++/CLI]
public:
InvalidAttributeException(
   String^ message
)

Parameters

message
A string which represents the message.

See Also

InvalidAttributeException Class | InvalidAttributeException Members | Overload List


InvalidAttributeException Constructor(String,Exception)

InvalidAttributeException Class | InvalidAttributeException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidAttributeException Constructor(String,Exception)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidAttributeException Class > InvalidAttributeException Constructor : InvalidAttributeException Constructor(String,Exception)

Exception which allows passing in a message and inner exception when there are errors with attributes.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public InvalidAttributeException(
   string message,
   Exception innerException
);
[C++]
public: InvalidAttributeException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
InvalidAttributeException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception.

See Also

InvalidAttributeException Class | InvalidAttributeException Members | Overload List


InvalidColorTypeException Class

InvalidColorTypeException Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidColorTypeException Class

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidColorTypeException Class

Exception class which is raised when there are errors with color types.

For a list of all members of this type, see InvalidColorTypeException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.NotateXpress9.NotateXpressException
PegasusImaging.WinForms.NotateXpress9.InvalidColorTypeException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class InvalidColorTypeException
   Inherits NotateXpressException
   Implements ISerializable, _Exception
[C#]
[SerializableAttribute()]
public sealed class InvalidColorTypeException : NotateXpressException, ISerializable, _Exception
[C++]
[SerializableAttribute()]
public __gc __sealed class InvalidColorTypeException : public NotateXpressException, ISerializable, _Exception
[C++/CLI]
[SerializableAttribute()]
public ref class InvalidColorTypeException sealed : public NotateXpressException, ISerializable, _Exception

See Also

InvalidColorTypeException Members | PegasusImaging.WinForms.NotateXpress9 Namespace


InvalidColorTypeException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidColorTypeException Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidColorTypeException Class

InvalidColorTypeException overview

Public Constructors

Public Constructor InvalidColorTypeException Constructor Overloaded. Main constructor for the InvalidColorTypeException class when there are errors with color types.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InvalidColorTypeException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


InvalidColorTypeException Constructor

InvalidColorTypeException Class | InvalidColorTypeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidColorTypeException Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidColorTypeException Class : InvalidColorTypeException Constructor (InvalidColorTypeException)

Main constructor for the InvalidColorTypeException class when there are errors with color types.

Overload List

Main constructor for the InvalidColorTypeException class when there are errors with color types.

[Visual Basic] Public Sub New()

[C#] public InvalidColorTypeException();

[C++] public InvalidColorTypeException();

[C++/CLI] public InvalidColorTypeException();

Exception which allows passing in an error number when there are errors with color types.

[Visual Basic] Public Sub New(Integer)

[C#] public InvalidColorTypeException(int);

[C++] public InvalidColorTypeException(int);

[C++/CLI] public InvalidColorTypeException(int);

Exception which allows passing in a message when there are errors with color types.

[Visual Basic] Public Sub New(String)

[C#] public InvalidColorTypeException(string);

[C++] public InvalidColorTypeException(string*);

[C++/CLI] public InvalidColorTypeException(String^);

Exception which allows passing in an error number and message when there are errors with color types.

[Visual Basic] Public Sub New(Integer,String)

[C#] public InvalidColorTypeException(int,string);

[C++] public InvalidColorTypeException(int,string*);

[C++/CLI] public InvalidColorTypeException(int,String^);

Exception which allows passing in a message and inner exception when there are errors with color types.

[Visual Basic] Public Sub New(String,Exception)

[C#] public InvalidColorTypeException(string,Exception);

[C++] public InvalidColorTypeException(string*,Exception*);

[C++/CLI] public InvalidColorTypeException(String^,Exception^);

See Also

InvalidColorTypeException Class | InvalidColorTypeException Members


InvalidColorTypeException Constructor()

InvalidColorTypeException Class | InvalidColorTypeException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidColorTypeException Constructor()

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidColorTypeException Class > InvalidColorTypeException Constructor : InvalidColorTypeException Constructor()

Main constructor for the InvalidColorTypeException class when there are errors with color types.

[Visual Basic]
Public Function New()
[C#]
public InvalidColorTypeException();
[C++]
public: InvalidColorTypeException();
[C++/CLI]
public:
InvalidColorTypeException();

See Also

InvalidColorTypeException Class | InvalidColorTypeException Members | Overload List


InvalidColorTypeException Constructor(Int32)

InvalidColorTypeException Class | InvalidColorTypeException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidColorTypeException Constructor(Int32)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidColorTypeException Class > InvalidColorTypeException Constructor : InvalidColorTypeException Constructor(Int32)

Exception which allows passing in an error number when there are errors with color types.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public InvalidColorTypeException(
   int errorNumber
);
[C++]
public: InvalidColorTypeException(
   int errorNumber
)
[C++/CLI]
public:
InvalidColorTypeException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

InvalidColorTypeException Class | InvalidColorTypeException Members | Overload List


InvalidColorTypeException Constructor(Int32,String)

InvalidColorTypeException Class | InvalidColorTypeException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidColorTypeException Constructor(Int32,String)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidColorTypeException Class > InvalidColorTypeException Constructor : InvalidColorTypeException Constructor(Int32,String)

Exception which allows passing in an error number and message when there are errors with color types.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public InvalidColorTypeException(
   int errorNumber,
   string message
);
[C++]
public: InvalidColorTypeException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
InvalidColorTypeException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

InvalidColorTypeException Class | InvalidColorTypeException Members | Overload List


InvalidColorTypeException Constructor(String)

InvalidColorTypeException Class | InvalidColorTypeException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidColorTypeException Constructor(String)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidColorTypeException Class > InvalidColorTypeException Constructor : InvalidColorTypeException Constructor(String)

Exception which allows passing in a message when there are errors with color types.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public InvalidColorTypeException(
   string message
);
[C++]
public: InvalidColorTypeException(
   string* message
)
[C++/CLI]
public:
InvalidColorTypeException(
   String^ message
)

Parameters

message
A string which represents the message.

See Also

InvalidColorTypeException Class | InvalidColorTypeException Members | Overload List


InvalidColorTypeException Constructor(String,Exception)

InvalidColorTypeException Class | InvalidColorTypeException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidColorTypeException Constructor(String,Exception)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidColorTypeException Class > InvalidColorTypeException Constructor : InvalidColorTypeException Constructor(String,Exception)

Exception which allows passing in a message and inner exception when there are errors with color types.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public InvalidColorTypeException(
   string message,
   Exception innerException
);
[C++]
public: InvalidColorTypeException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
InvalidColorTypeException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception.

See Also

InvalidColorTypeException Class | InvalidColorTypeException Members | Overload List


InvalidContextException Class

InvalidContextException Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidContextException Class

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidContextException Class

Exception class which is raised when there are errors with context.

For a list of all members of this type, see InvalidContextException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.NotateXpress9.NotateXpressException
PegasusImaging.WinForms.NotateXpress9.InvalidContextException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class InvalidContextException
   Inherits NotateXpressException
   Implements ISerializable, _Exception
[C#]
[SerializableAttribute()]
public sealed class InvalidContextException : NotateXpressException, ISerializable, _Exception
[C++]
[SerializableAttribute()]
public __gc __sealed class InvalidContextException : public NotateXpressException, ISerializable, _Exception
[C++/CLI]
[SerializableAttribute()]
public ref class InvalidContextException sealed : public NotateXpressException, ISerializable, _Exception

See Also

InvalidContextException Members | PegasusImaging.WinForms.NotateXpress9 Namespace


InvalidContextException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidContextException Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidContextException Class

InvalidContextException overview

Public Constructors

Public Constructor InvalidContextException Constructor Overloaded. Main constructor for the InvalidContextException class when there are errors with context.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InvalidContextException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


InvalidContextException Constructor

InvalidContextException Class | InvalidContextException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidContextException Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidContextException Class : InvalidContextException Constructor (InvalidContextException)

Main constructor for the InvalidContextException class when there are errors with context.

Overload List

Main constructor for the InvalidContextException class when there are errors with context.

[Visual Basic] Public Sub New()

[C#] public InvalidContextException();

[C++] public InvalidContextException();

[C++/CLI] public InvalidContextException();

Exception which allows passing in an error number when there are errors with context.

[Visual Basic] Public Sub New(Integer)

[C#] public InvalidContextException(int);

[C++] public InvalidContextException(int);

[C++/CLI] public InvalidContextException(int);

Exception which allows passing in a message when there are errors with context.

[Visual Basic] Public Sub New(String)

[C#] public InvalidContextException(string);

[C++] public InvalidContextException(string*);

[C++/CLI] public InvalidContextException(String^);

Exception which allows passing in an error number and message when there are errors with context.

[Visual Basic] Public Sub New(Integer,String)

[C#] public InvalidContextException(int,string);

[C++] public InvalidContextException(int,string*);

[C++/CLI] public InvalidContextException(int,String^);

Exception which allows passing in a message and inner exception when there are errors with context.

[Visual Basic] Public Sub New(String,Exception)

[C#] public InvalidContextException(string,Exception);

[C++] public InvalidContextException(string*,Exception*);

[C++/CLI] public InvalidContextException(String^,Exception^);

See Also

InvalidContextException Class | InvalidContextException Members


InvalidContextException Constructor()

InvalidContextException Class | InvalidContextException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidContextException Constructor()

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidContextException Class > InvalidContextException Constructor : InvalidContextException Constructor()

Main constructor for the InvalidContextException class when there are errors with context.

[Visual Basic]
Public Function New()
[C#]
public InvalidContextException();
[C++]
public: InvalidContextException();
[C++/CLI]
public:
InvalidContextException();

See Also

InvalidContextException Class | InvalidContextException Members | Overload List


InvalidContextException Constructor(Int32)

InvalidContextException Class | InvalidContextException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidContextException Constructor(Int32)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidContextException Class > InvalidContextException Constructor : InvalidContextException Constructor(Int32)

Exception which allows passing in an error number when there are errors with context.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public InvalidContextException(
   int errorNumber
);
[C++]
public: InvalidContextException(
   int errorNumber
)
[C++/CLI]
public:
InvalidContextException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

InvalidContextException Class | InvalidContextException Members | Overload List


InvalidContextException Constructor(Int32,String)

InvalidContextException Class | InvalidContextException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidContextException Constructor(Int32,String)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidContextException Class > InvalidContextException Constructor : InvalidContextException Constructor(Int32,String)

Exception which allows passing in an error number and message when there are errors with context.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public InvalidContextException(
   int errorNumber,
   string message
);
[C++]
public: InvalidContextException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
InvalidContextException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

InvalidContextException Class | InvalidContextException Members | Overload List


InvalidContextException Constructor(String)

InvalidContextException Class | InvalidContextException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidContextException Constructor(String)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidContextException Class > InvalidContextException Constructor : InvalidContextException Constructor(String)

Exception which allows passing in a message when there are errors with context.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public InvalidContextException(
   string message
);
[C++]
public: InvalidContextException(
   string* message
)
[C++/CLI]
public:
InvalidContextException(
   String^ message
)

Parameters

message
A string which represents the message.

See Also

InvalidContextException Class | InvalidContextException Members | Overload List


InvalidContextException Constructor(String,Exception)

InvalidContextException Class | InvalidContextException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidContextException Constructor(String,Exception)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidContextException Class > InvalidContextException Constructor : InvalidContextException Constructor(String,Exception)

Exception which allows passing in a message and inner exception when there are errors with context.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public InvalidContextException(
   string message,
   Exception innerException
);
[C++]
public: InvalidContextException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
InvalidContextException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception.

See Also

InvalidContextException Class | InvalidContextException Members | Overload List


InvalidContextIdException Class

InvalidContextIdException Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidContextIdException Class

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidContextIdException Class

Exception class which is raised when there are errors with context IDs.

For a list of all members of this type, see InvalidContextIdException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.NotateXpress9.NotateXpressException
PegasusImaging.WinForms.NotateXpress9.InvalidContextIdException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class InvalidContextIdException
   Inherits NotateXpressException
   Implements ISerializable, _Exception
[C#]
[SerializableAttribute()]
public sealed class InvalidContextIdException : NotateXpressException, ISerializable, _Exception
[C++]
[SerializableAttribute()]
public __gc __sealed class InvalidContextIdException : public NotateXpressException, ISerializable, _Exception
[C++/CLI]
[SerializableAttribute()]
public ref class InvalidContextIdException sealed : public NotateXpressException, ISerializable, _Exception

See Also

InvalidContextIdException Members | PegasusImaging.WinForms.NotateXpress9 Namespace


InvalidContextIdException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidContextIdException Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidContextIdException Class

InvalidContextIdException overview

Public Constructors

Public Constructor InvalidContextIdException Constructor Overloaded. Main constructor for the InvalidContextIdException class when there are errors with context IDs.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InvalidContextIdException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


InvalidContextIdException Constructor

InvalidContextIdException Class | InvalidContextIdException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidContextIdException Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidContextIdException Class : InvalidContextIdException Constructor (InvalidContextIdException)

Main constructor for the InvalidContextIdException class when there are errors with context IDs.

Overload List

Main constructor for the InvalidContextIdException class when there are errors with context IDs.

[Visual Basic] Public Sub New()

[C#] public InvalidContextIdException();

[C++] public InvalidContextIdException();

[C++/CLI] public InvalidContextIdException();

Exception which allows passing in an error number when there are errors with context IDs.

[Visual Basic] Public Sub New(Integer)

[C#] public InvalidContextIdException(int);

[C++] public InvalidContextIdException(int);

[C++/CLI] public InvalidContextIdException(int);

Exception which allows passing in a message when there are errors with context IDs.

[Visual Basic] Public Sub New(String)

[C#] public InvalidContextIdException(string);

[C++] public InvalidContextIdException(string*);

[C++/CLI] public InvalidContextIdException(String^);

Exception which allows passing in an error number and message when there are errors with context IDs.

[Visual Basic] Public Sub New(Integer,String)

[C#] public InvalidContextIdException(int,string);

[C++] public InvalidContextIdException(int,string*);

[C++/CLI] public InvalidContextIdException(int,String^);

Exception which allows passing in a message and inner exception when there are errors with context IDs.

[Visual Basic] Public Sub New(String,Exception)

[C#] public InvalidContextIdException(string,Exception);

[C++] public InvalidContextIdException(string*,Exception*);

[C++/CLI] public InvalidContextIdException(String^,Exception^);

See Also

InvalidContextIdException Class | InvalidContextIdException Members


InvalidContextIdException Constructor()

InvalidContextIdException Class | InvalidContextIdException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidContextIdException Constructor()

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidContextIdException Class > InvalidContextIdException Constructor : InvalidContextIdException Constructor()

Main constructor for the InvalidContextIdException class when there are errors with context IDs.

[Visual Basic]
Public Function New()
[C#]
public InvalidContextIdException();
[C++]
public: InvalidContextIdException();
[C++/CLI]
public:
InvalidContextIdException();

See Also

InvalidContextIdException Class | InvalidContextIdException Members | Overload List


InvalidContextIdException Constructor(Int32)

InvalidContextIdException Class | InvalidContextIdException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidContextIdException Constructor(Int32)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidContextIdException Class > InvalidContextIdException Constructor : InvalidContextIdException Constructor(Int32)

Exception which allows passing in an error number when there are errors with context IDs.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public InvalidContextIdException(
   int errorNumber
);
[C++]
public: InvalidContextIdException(
   int errorNumber
)
[C++/CLI]
public:
InvalidContextIdException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

InvalidContextIdException Class | InvalidContextIdException Members | Overload List


InvalidContextIdException Constructor(Int32,String)

InvalidContextIdException Class | InvalidContextIdException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidContextIdException Constructor(Int32,String)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidContextIdException Class > InvalidContextIdException Constructor : InvalidContextIdException Constructor(Int32,String)

Exception which allows passing in an error number and message when there are errors with context IDs.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public InvalidContextIdException(
   int errorNumber,
   string message
);
[C++]
public: InvalidContextIdException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
InvalidContextIdException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

InvalidContextIdException Class | InvalidContextIdException Members | Overload List


InvalidContextIdException Constructor(String)

InvalidContextIdException Class | InvalidContextIdException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidContextIdException Constructor(String)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidContextIdException Class > InvalidContextIdException Constructor : InvalidContextIdException Constructor(String)

Exception which allows passing in a message when there are errors with context IDs.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public InvalidContextIdException(
   string message
);
[C++]
public: InvalidContextIdException(
   string* message
)
[C++/CLI]
public:
InvalidContextIdException(
   String^ message
)

Parameters

message
A string which represents the message.

See Also

InvalidContextIdException Class | InvalidContextIdException Members | Overload List


InvalidContextIdException Constructor(String,Exception)

InvalidContextIdException Class | InvalidContextIdException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidContextIdException Constructor(String,Exception)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidContextIdException Class > InvalidContextIdException Constructor : InvalidContextIdException Constructor(String,Exception)

Exception which allows passing in a message and inner exception when there are errors with context IDs.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public InvalidContextIdException(
   string message,
   Exception innerException
);
[C++]
public: InvalidContextIdException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
InvalidContextIdException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception.

See Also

InvalidContextIdException Class | InvalidContextIdException Members | Overload List


InvalidCursorTypeException Class

InvalidCursorTypeException Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidCursorTypeException Class

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidCursorTypeException Class

Exception class which is raised when there are errors with cursor types.

For a list of all members of this type, see InvalidCursorTypeException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.NotateXpress9.NotateXpressException
PegasusImaging.WinForms.NotateXpress9.InvalidCursorTypeException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class InvalidCursorTypeException
   Inherits NotateXpressException
   Implements ISerializable, _Exception
[C#]
[SerializableAttribute()]
public sealed class InvalidCursorTypeException : NotateXpressException, ISerializable, _Exception
[C++]
[SerializableAttribute()]
public __gc __sealed class InvalidCursorTypeException : public NotateXpressException, ISerializable, _Exception
[C++/CLI]
[SerializableAttribute()]
public ref class InvalidCursorTypeException sealed : public NotateXpressException, ISerializable, _Exception

See Also

InvalidCursorTypeException Members | PegasusImaging.WinForms.NotateXpress9 Namespace


InvalidCursorTypeException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidCursorTypeException Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidCursorTypeException Class

InvalidCursorTypeException overview

Public Constructors

Public Constructor InvalidCursorTypeException Constructor Overloaded. Main constructor for the InvalidCursorTypeException class when there are errors with cursor types.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InvalidCursorTypeException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


InvalidCursorTypeException Constructor

InvalidCursorTypeException Class | InvalidCursorTypeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidCursorTypeException Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidCursorTypeException Class : InvalidCursorTypeException Constructor (InvalidCursorTypeException)

Main constructor for the InvalidCursorTypeException class when there are errors with cursor types.

Overload List

Main constructor for the InvalidCursorTypeException class when there are errors with cursor types.

[Visual Basic] Public Sub New()

[C#] public InvalidCursorTypeException();

[C++] public InvalidCursorTypeException();

[C++/CLI] public InvalidCursorTypeException();

Exception which allows passing in an error number when there are errors with cursor types.

[Visual Basic] Public Sub New(Integer)

[C#] public InvalidCursorTypeException(int);

[C++] public InvalidCursorTypeException(int);

[C++/CLI] public InvalidCursorTypeException(int);

Exception which allows passing in a message when there are errors with cursor types.

[Visual Basic] Public Sub New(String)

[C#] public InvalidCursorTypeException(string);

[C++] public InvalidCursorTypeException(string*);

[C++/CLI] public InvalidCursorTypeException(String^);

Exception which allows passing in an error number when there are errors with cursor types.

[Visual Basic] Public Sub New(Integer,String)

[C#] public InvalidCursorTypeException(int,string);

[C++] public InvalidCursorTypeException(int,string*);

[C++/CLI] public InvalidCursorTypeException(int,String^);

Exception which allows passing in a message and inner exception when there are errors with cursor types.

[Visual Basic] Public Sub New(String,Exception)

[C#] public InvalidCursorTypeException(string,Exception);

[C++] public InvalidCursorTypeException(string*,Exception*);

[C++/CLI] public InvalidCursorTypeException(String^,Exception^);

See Also

InvalidCursorTypeException Class | InvalidCursorTypeException Members


InvalidCursorTypeException Constructor()

InvalidCursorTypeException Class | InvalidCursorTypeException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidCursorTypeException Constructor()

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidCursorTypeException Class > InvalidCursorTypeException Constructor : InvalidCursorTypeException Constructor()

Main constructor for the InvalidCursorTypeException class when there are errors with cursor types.

[Visual Basic]
Public Function New()
[C#]
public InvalidCursorTypeException();
[C++]
public: InvalidCursorTypeException();
[C++/CLI]
public:
InvalidCursorTypeException();

See Also

InvalidCursorTypeException Class | InvalidCursorTypeException Members | Overload List


InvalidCursorTypeException Constructor(Int32)

InvalidCursorTypeException Class | InvalidCursorTypeException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidCursorTypeException Constructor(Int32)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidCursorTypeException Class > InvalidCursorTypeException Constructor : InvalidCursorTypeException Constructor(Int32)

Exception which allows passing in an error number when there are errors with cursor types.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public InvalidCursorTypeException(
   int errorNumber
);
[C++]
public: InvalidCursorTypeException(
   int errorNumber
)
[C++/CLI]
public:
InvalidCursorTypeException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

InvalidCursorTypeException Class | InvalidCursorTypeException Members | Overload List


InvalidCursorTypeException Constructor(Int32,String)

InvalidCursorTypeException Class | InvalidCursorTypeException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidCursorTypeException Constructor(Int32,String)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidCursorTypeException Class > InvalidCursorTypeException Constructor : InvalidCursorTypeException Constructor(Int32,String)

Exception which allows passing in an error number when there are errors with cursor types.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public InvalidCursorTypeException(
   int errorNumber,
   string message
);
[C++]
public: InvalidCursorTypeException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
InvalidCursorTypeException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

InvalidCursorTypeException Class | InvalidCursorTypeException Members | Overload List


InvalidCursorTypeException Constructor(String)

InvalidCursorTypeException Class | InvalidCursorTypeException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidCursorTypeException Constructor(String)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidCursorTypeException Class > InvalidCursorTypeException Constructor : InvalidCursorTypeException Constructor(String)

Exception which allows passing in a message when there are errors with cursor types.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public InvalidCursorTypeException(
   string message
);
[C++]
public: InvalidCursorTypeException(
   string* message
)
[C++/CLI]
public:
InvalidCursorTypeException(
   String^ message
)

Parameters

message
A string which represents the message.

See Also

InvalidCursorTypeException Class | InvalidCursorTypeException Members | Overload List


InvalidCursorTypeException Constructor(String,Exception)

InvalidCursorTypeException Class | InvalidCursorTypeException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidCursorTypeException Constructor(String,Exception)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidCursorTypeException Class > InvalidCursorTypeException Constructor : InvalidCursorTypeException Constructor(String,Exception)

Exception which allows passing in a message and inner exception when there are errors with cursor types.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public InvalidCursorTypeException(
   string message,
   Exception innerException
);
[C++]
public: InvalidCursorTypeException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
InvalidCursorTypeException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception.

See Also

InvalidCursorTypeException Class | InvalidCursorTypeException Members | Overload List


InvalidErrorLevelException Class

InvalidErrorLevelException Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidErrorLevelException Class

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidErrorLevelException Class

This class implements exceptions for error levels.

For a list of all members of this type, see InvalidErrorLevelException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.NotateXpress9.NotateXpressException
PegasusImaging.WinForms.NotateXpress9.InvalidErrorLevelException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class InvalidErrorLevelException
   Inherits NotateXpressException
   Implements ISerializable, _Exception
[C#]
[SerializableAttribute()]
public sealed class InvalidErrorLevelException : NotateXpressException, ISerializable, _Exception
[C++]
[SerializableAttribute()]
public __gc __sealed class InvalidErrorLevelException : public NotateXpressException, ISerializable, _Exception
[C++/CLI]
[SerializableAttribute()]
public ref class InvalidErrorLevelException sealed : public NotateXpressException, ISerializable, _Exception

See Also

InvalidErrorLevelException Members | PegasusImaging.WinForms.NotateXpress9 Namespace


InvalidErrorLevelException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidErrorLevelException Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidErrorLevelException Class

InvalidErrorLevelException overview

Public Constructors

Public Constructor InvalidErrorLevelException Constructor Overloaded. Base exception for error level issues.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InvalidErrorLevelException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


InvalidErrorLevelException Constructor

InvalidErrorLevelException Class | InvalidErrorLevelException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidErrorLevelException Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidErrorLevelException Class : InvalidErrorLevelException Constructor (InvalidErrorLevelException)

Base exception for error level issues.

Overload List

Base exception for error level issues.

[Visual Basic] Public Sub New()

[C#] public InvalidErrorLevelException();

[C++] public InvalidErrorLevelException();

[C++/CLI] public InvalidErrorLevelException();

Exception which allows passing in an error number when there are error level issues.

[Visual Basic] Public Sub New(Integer)

[C#] public InvalidErrorLevelException(int);

[C++] public InvalidErrorLevelException(int);

[C++/CLI] public InvalidErrorLevelException(int);

Exception which allows passing in an error message when there are error level issues.

[Visual Basic] Public Sub New(String)

[C#] public InvalidErrorLevelException(string);

[C++] public InvalidErrorLevelException(string*);

[C++/CLI] public InvalidErrorLevelException(String^);

Exception which allows passing in an error number and message when there are error level issues.

[Visual Basic] Public Sub New(Integer,String)

[C#] public InvalidErrorLevelException(int,string);

[C++] public InvalidErrorLevelException(int,string*);

[C++/CLI] public InvalidErrorLevelException(int,String^);

Exception which allows passing in an error message and an inner exception when there are error level issues.

[Visual Basic] Public Sub New(String,Exception)

[C#] public InvalidErrorLevelException(string,Exception);

[C++] public InvalidErrorLevelException(string*,Exception*);

[C++/CLI] public InvalidErrorLevelException(String^,Exception^);

See Also

InvalidErrorLevelException Class | InvalidErrorLevelException Members


InvalidErrorLevelException Constructor()

InvalidErrorLevelException Class | InvalidErrorLevelException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidErrorLevelException Constructor()

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidErrorLevelException Class > InvalidErrorLevelException Constructor : InvalidErrorLevelException Constructor()

Base exception for error level issues.

[Visual Basic]
Public Function New()
[C#]
public InvalidErrorLevelException();
[C++]
public: InvalidErrorLevelException();
[C++/CLI]
public:
InvalidErrorLevelException();

See Also

InvalidErrorLevelException Class | InvalidErrorLevelException Members | Overload List


InvalidErrorLevelException Constructor(Int32)

InvalidErrorLevelException Class | InvalidErrorLevelException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer value which represents the error number.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidErrorLevelException Constructor(Int32)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidErrorLevelException Class > InvalidErrorLevelException Constructor : InvalidErrorLevelException Constructor(Int32)

Exception which allows passing in an error number when there are error level issues.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public InvalidErrorLevelException(
   int errorNumber
);
[C++]
public: InvalidErrorLevelException(
   int errorNumber
)
[C++/CLI]
public:
InvalidErrorLevelException(
   int errorNumber
)

Parameters

errorNumber
An integer value which represents the error number.

See Also

InvalidErrorLevelException Class | InvalidErrorLevelException Members | Overload List


InvalidErrorLevelException Constructor(Int32,String)

InvalidErrorLevelException Class | InvalidErrorLevelException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer value which represents the error number.
message
A string value which represents the error message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidErrorLevelException Constructor(Int32,String)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidErrorLevelException Class > InvalidErrorLevelException Constructor : InvalidErrorLevelException Constructor(Int32,String)

Exception which allows passing in an error number and message when there are error level issues.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public InvalidErrorLevelException(
   int errorNumber,
   string message
);
[C++]
public: InvalidErrorLevelException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
InvalidErrorLevelException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer value which represents the error number.
message
A string value which represents the error message.

See Also

InvalidErrorLevelException Class | InvalidErrorLevelException Members | Overload List


InvalidErrorLevelException Constructor(String)

InvalidErrorLevelException Class | InvalidErrorLevelException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string value which represents the error message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidErrorLevelException Constructor(String)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidErrorLevelException Class > InvalidErrorLevelException Constructor : InvalidErrorLevelException Constructor(String)

Exception which allows passing in an error message when there are error level issues.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public InvalidErrorLevelException(
   string message
);
[C++]
public: InvalidErrorLevelException(
   string* message
)
[C++/CLI]
public:
InvalidErrorLevelException(
   String^ message
)

Parameters

message
A string value which represents the error message.

See Also

InvalidErrorLevelException Class | InvalidErrorLevelException Members | Overload List


InvalidErrorLevelException Constructor(String,Exception)

InvalidErrorLevelException Class | InvalidErrorLevelException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string value which represents the error message.
innerException
An inner exception.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidErrorLevelException Constructor(String,Exception)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidErrorLevelException Class > InvalidErrorLevelException Constructor : InvalidErrorLevelException Constructor(String,Exception)

Exception which allows passing in an error message and an inner exception when there are error level issues.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public InvalidErrorLevelException(
   string message,
   Exception innerException
);
[C++]
public: InvalidErrorLevelException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
InvalidErrorLevelException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string value which represents the error message.
innerException
An inner exception.

See Also

InvalidErrorLevelException Class | InvalidErrorLevelException Members | Overload List


InvalidFontException Class

InvalidFontException Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidFontException Class

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidFontException Class

Exception class which is raised when there are errors with fonts.

For a list of all members of this type, see InvalidFontException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.NotateXpress9.NotateXpressException
PegasusImaging.WinForms.NotateXpress9.InvalidFontException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class InvalidFontException
   Inherits NotateXpressException
   Implements ISerializable, _Exception
[C#]
[SerializableAttribute()]
public sealed class InvalidFontException : NotateXpressException, ISerializable, _Exception
[C++]
[SerializableAttribute()]
public __gc __sealed class InvalidFontException : public NotateXpressException, ISerializable, _Exception
[C++/CLI]
[SerializableAttribute()]
public ref class InvalidFontException sealed : public NotateXpressException, ISerializable, _Exception

See Also

InvalidFontException Members | PegasusImaging.WinForms.NotateXpress9 Namespace


InvalidFontException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidFontException Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidFontException Class

InvalidFontException overview

Public Constructors

Public Constructor InvalidFontException Constructor Overloaded. Main constructor for InvalidFontException when there are errors with fonts.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InvalidFontException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


InvalidFontException Constructor

InvalidFontException Class | InvalidFontException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidFontException Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidFontException Class : InvalidFontException Constructor (InvalidFontException)

Main constructor for InvalidFontException when there are errors with fonts.

Overload List

Main constructor for InvalidFontException when there are errors with fonts.

[Visual Basic] Public Sub New()

[C#] public InvalidFontException();

[C++] public InvalidFontException();

[C++/CLI] public InvalidFontException();

Exception which allows passing in an error number when there are errors with fonts.

[Visual Basic] Public Sub New(Integer)

[C#] public InvalidFontException(int);

[C++] public InvalidFontException(int);

[C++/CLI] public InvalidFontException(int);

Exception which allows passing in a message when there are errors with fonts.

[Visual Basic] Public Sub New(String)

[C#] public InvalidFontException(string);

[C++] public InvalidFontException(string*);

[C++/CLI] public InvalidFontException(String^);

Exception which allows passing in an error number and message when there are errors with fonts.

[Visual Basic] Public Sub New(Integer,String)

[C#] public InvalidFontException(int,string);

[C++] public InvalidFontException(int,string*);

[C++/CLI] public InvalidFontException(int,String^);

Exception which allows passing in a message and inner exception when there are errors with fonts.

[Visual Basic] Public Sub New(String,Exception)

[C#] public InvalidFontException(string,Exception);

[C++] public InvalidFontException(string*,Exception*);

[C++/CLI] public InvalidFontException(String^,Exception^);

See Also

InvalidFontException Class | InvalidFontException Members


InvalidFontException Constructor()

InvalidFontException Class | InvalidFontException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidFontException Constructor()

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidFontException Class > InvalidFontException Constructor : InvalidFontException Constructor()

Main constructor for InvalidFontException when there are errors with fonts.

[Visual Basic]
Public Function New()
[C#]
public InvalidFontException();
[C++]
public: InvalidFontException();
[C++/CLI]
public:
InvalidFontException();

See Also

InvalidFontException Class | InvalidFontException Members | Overload List


InvalidFontException Constructor(Int32)

InvalidFontException Class | InvalidFontException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidFontException Constructor(Int32)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidFontException Class > InvalidFontException Constructor : InvalidFontException Constructor(Int32)

Exception which allows passing in an error number when there are errors with fonts.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public InvalidFontException(
   int errorNumber
);
[C++]
public: InvalidFontException(
   int errorNumber
)
[C++/CLI]
public:
InvalidFontException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

InvalidFontException Class | InvalidFontException Members | Overload List


InvalidFontException Constructor(Int32,String)

InvalidFontException Class | InvalidFontException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidFontException Constructor(Int32,String)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidFontException Class > InvalidFontException Constructor : InvalidFontException Constructor(Int32,String)

Exception which allows passing in an error number and message when there are errors with fonts.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public InvalidFontException(
   int errorNumber,
   string message
);
[C++]
public: InvalidFontException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
InvalidFontException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

InvalidFontException Class | InvalidFontException Members | Overload List


InvalidFontException Constructor(String)

InvalidFontException Class | InvalidFontException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidFontException Constructor(String)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidFontException Class > InvalidFontException Constructor : InvalidFontException Constructor(String)

Exception which allows passing in a message when there are errors with fonts.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public InvalidFontException(
   string message
);
[C++]
public: InvalidFontException(
   string* message
)
[C++/CLI]
public:
InvalidFontException(
   String^ message
)

Parameters

message
A string which represents the message.

See Also

InvalidFontException Class | InvalidFontException Members | Overload List


InvalidFontException Constructor(String,Exception)

InvalidFontException Class | InvalidFontException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidFontException Constructor(String,Exception)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidFontException Class > InvalidFontException Constructor : InvalidFontException Constructor(String,Exception)

Exception which allows passing in a message and inner exception when there are errors with fonts.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public InvalidFontException(
   string message,
   Exception innerException
);
[C++]
public: InvalidFontException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
InvalidFontException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception.

See Also

InvalidFontException Class | InvalidFontException Members | Overload List


InvalidGroupException Class

InvalidGroupException Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidGroupException Class

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidGroupException Class

Exception class which is raised when there are invalid groups.

For a list of all members of this type, see InvalidGroupException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.NotateXpress9.NotateXpressException
PegasusImaging.WinForms.NotateXpress9.InvalidGroupException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class InvalidGroupException
   Inherits NotateXpressException
   Implements ISerializable, _Exception
[C#]
[SerializableAttribute()]
public sealed class InvalidGroupException : NotateXpressException, ISerializable, _Exception
[C++]
[SerializableAttribute()]
public __gc __sealed class InvalidGroupException : public NotateXpressException, ISerializable, _Exception
[C++/CLI]
[SerializableAttribute()]
public ref class InvalidGroupException sealed : public NotateXpressException, ISerializable, _Exception

See Also

InvalidGroupException Members | PegasusImaging.WinForms.NotateXpress9 Namespace


InvalidGroupException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidGroupException Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidGroupException Class

InvalidGroupException overview

Public Constructors

Public Constructor InvalidGroupException Constructor Overloaded. Main constructor for the InvalidGroupException class when there are invalid groups.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InvalidGroupException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


InvalidGroupException Constructor

InvalidGroupException Class | InvalidGroupException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidGroupException Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidGroupException Class : InvalidGroupException Constructor (InvalidGroupException)

Main constructor for the InvalidGroupException class when there are invalid groups.

Overload List

Main constructor for the InvalidGroupException class when there are invalid groups.

[Visual Basic] Public Sub New()

[C#] public InvalidGroupException();

[C++] public InvalidGroupException();

[C++/CLI] public InvalidGroupException();

Exception which allows passing in an error number when there are invalid groups.

[Visual Basic] Public Sub New(Integer)

[C#] public InvalidGroupException(int);

[C++] public InvalidGroupException(int);

[C++/CLI] public InvalidGroupException(int);

Exception which allows passing in a message when there are invalid groups.

[Visual Basic] Public Sub New(String)

[C#] public InvalidGroupException(string);

[C++] public InvalidGroupException(string*);

[C++/CLI] public InvalidGroupException(String^);

Exception which allows passing in an error number and a message to describe the exception.

[Visual Basic] Public Sub New(Integer,String)

[C#] public InvalidGroupException(int,string);

[C++] public InvalidGroupException(int,string*);

[C++/CLI] public InvalidGroupException(int,String^);

Exception which allows passing in a message and inner exception when there are invalid groups.

[Visual Basic] Public Sub New(String,Exception)

[C#] public InvalidGroupException(string,Exception);

[C++] public InvalidGroupException(string*,Exception*);

[C++/CLI] public InvalidGroupException(String^,Exception^);

See Also

InvalidGroupException Class | InvalidGroupException Members


InvalidGroupException Constructor()

InvalidGroupException Class | InvalidGroupException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidGroupException Constructor()

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidGroupException Class > InvalidGroupException Constructor : InvalidGroupException Constructor()

Main constructor for the InvalidGroupException class when there are invalid groups.

[Visual Basic]
Public Function New()
[C#]
public InvalidGroupException();
[C++]
public: InvalidGroupException();
[C++/CLI]
public:
InvalidGroupException();

See Also

InvalidGroupException Class | InvalidGroupException Members | Overload List


InvalidGroupException Constructor(Int32)

InvalidGroupException Class | InvalidGroupException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidGroupException Constructor(Int32)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidGroupException Class > InvalidGroupException Constructor : InvalidGroupException Constructor(Int32)

Exception which allows passing in an error number when there are invalid groups.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public InvalidGroupException(
   int errorNumber
);
[C++]
public: InvalidGroupException(
   int errorNumber
)
[C++/CLI]
public:
InvalidGroupException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

InvalidGroupException Class | InvalidGroupException Members | Overload List


InvalidGroupException Constructor(Int32,String)

InvalidGroupException Class | InvalidGroupException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer value which represents the error number.
message
A string value which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidGroupException Constructor(Int32,String)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidGroupException Class > InvalidGroupException Constructor : InvalidGroupException Constructor(Int32,String)

Exception which allows passing in an error number and a message to describe the exception.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public InvalidGroupException(
   int errorNumber,
   string message
);
[C++]
public: InvalidGroupException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
InvalidGroupException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer value which represents the error number.
message
A string value which represents the message.

See Also

InvalidGroupException Class | InvalidGroupException Members | Overload List


InvalidGroupException Constructor(String)

InvalidGroupException Class | InvalidGroupException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidGroupException Constructor(String)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidGroupException Class > InvalidGroupException Constructor : InvalidGroupException Constructor(String)

Exception which allows passing in a message when there are invalid groups.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public InvalidGroupException(
   string message
);
[C++]
public: InvalidGroupException(
   string* message
)
[C++/CLI]
public:
InvalidGroupException(
   String^ message
)

Parameters

message
A string which represents the message.

See Also

InvalidGroupException Class | InvalidGroupException Members | Overload List


InvalidGroupException Constructor(String,Exception)

InvalidGroupException Class | InvalidGroupException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidGroupException Constructor(String,Exception)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidGroupException Class > InvalidGroupException Constructor : InvalidGroupException Constructor(String,Exception)

Exception which allows passing in a message and inner exception when there are invalid groups.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public InvalidGroupException(
   string message,
   Exception innerException
);
[C++]
public: InvalidGroupException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
InvalidGroupException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception.

See Also

InvalidGroupException Class | InvalidGroupException Members | Overload List


InvalidHatchStyleException Class

InvalidHatchStyleException Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidHatchStyleException Class

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidHatchStyleException Class

Exception class which is raised when there are errors with hatch styles.

For a list of all members of this type, see InvalidHatchStyleException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.NotateXpress9.NotateXpressException
PegasusImaging.WinForms.NotateXpress9.InvalidHatchStyleException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class InvalidHatchStyleException
   Inherits NotateXpressException
   Implements ISerializable, _Exception
[C#]
[SerializableAttribute()]
public sealed class InvalidHatchStyleException : NotateXpressException, ISerializable, _Exception
[C++]
[SerializableAttribute()]
public __gc __sealed class InvalidHatchStyleException : public NotateXpressException, ISerializable, _Exception
[C++/CLI]
[SerializableAttribute()]
public ref class InvalidHatchStyleException sealed : public NotateXpressException, ISerializable, _Exception

See Also

InvalidHatchStyleException Members | PegasusImaging.WinForms.NotateXpress9 Namespace


InvalidHatchStyleException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidHatchStyleException Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidHatchStyleException Class

InvalidHatchStyleException overview

Public Constructors

Public Constructor InvalidHatchStyleException Constructor Overloaded. Main constructor for the InvalidHatchSytleException class when there are errors with hatch styles.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InvalidHatchStyleException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


InvalidHatchStyleException Constructor

InvalidHatchStyleException Class | InvalidHatchStyleException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidHatchStyleException Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidHatchStyleException Class : InvalidHatchStyleException Constructor (InvalidHatchStyleException)

Main constructor for the InvalidHatchSytleException class when there are errors with hatch styles.

Overload List

Main constructor for the InvalidHatchSytleException class when there are errors with hatch styles.

[Visual Basic] Public Sub New()

[C#] public InvalidHatchStyleException();

[C++] public InvalidHatchStyleException();

[C++/CLI] public InvalidHatchStyleException();

Exception which allows passing in an error number when there are errors with hatch styles.

[Visual Basic] Public Sub New(Integer)

[C#] public InvalidHatchStyleException(int);

[C++] public InvalidHatchStyleException(int);

[C++/CLI] public InvalidHatchStyleException(int);

Exception which allows passing in a message when there are errors with hatch styles.

[Visual Basic] Public Sub New(String)

[C#] public InvalidHatchStyleException(string);

[C++] public InvalidHatchStyleException(string*);

[C++/CLI] public InvalidHatchStyleException(String^);

Exception which allows passing in an error number and message when there are errors with hatch styles.

[Visual Basic] Public Sub New(Integer,String)

[C#] public InvalidHatchStyleException(int,string);

[C++] public InvalidHatchStyleException(int,string*);

[C++/CLI] public InvalidHatchStyleException(int,String^);

Exception which allows passing in a message and inner exception when there are errors with hatch styles.

[Visual Basic] Public Sub New(String,Exception)

[C#] public InvalidHatchStyleException(string,Exception);

[C++] public InvalidHatchStyleException(string*,Exception*);

[C++/CLI] public InvalidHatchStyleException(String^,Exception^);

See Also

InvalidHatchStyleException Class | InvalidHatchStyleException Members


InvalidHatchStyleException Constructor()

InvalidHatchStyleException Class | InvalidHatchStyleException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidHatchStyleException Constructor()

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidHatchStyleException Class > InvalidHatchStyleException Constructor : InvalidHatchStyleException Constructor()

Main constructor for the InvalidHatchSytleException class when there are errors with hatch styles.

[Visual Basic]
Public Function New()
[C#]
public InvalidHatchStyleException();
[C++]
public: InvalidHatchStyleException();
[C++/CLI]
public:
InvalidHatchStyleException();

See Also

InvalidHatchStyleException Class | InvalidHatchStyleException Members | Overload List


InvalidHatchStyleException Constructor(Int32)

InvalidHatchStyleException Class | InvalidHatchStyleException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidHatchStyleException Constructor(Int32)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidHatchStyleException Class > InvalidHatchStyleException Constructor : InvalidHatchStyleException Constructor(Int32)

Exception which allows passing in an error number when there are errors with hatch styles.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public InvalidHatchStyleException(
   int errorNumber
);
[C++]
public: InvalidHatchStyleException(
   int errorNumber
)
[C++/CLI]
public:
InvalidHatchStyleException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

InvalidHatchStyleException Class | InvalidHatchStyleException Members | Overload List


InvalidHatchStyleException Constructor(Int32,String)

InvalidHatchStyleException Class | InvalidHatchStyleException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidHatchStyleException Constructor(Int32,String)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidHatchStyleException Class > InvalidHatchStyleException Constructor : InvalidHatchStyleException Constructor(Int32,String)

Exception which allows passing in an error number and message when there are errors with hatch styles.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public InvalidHatchStyleException(
   int errorNumber,
   string message
);
[C++]
public: InvalidHatchStyleException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
InvalidHatchStyleException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

InvalidHatchStyleException Class | InvalidHatchStyleException Members | Overload List


InvalidHatchStyleException Constructor(String)

InvalidHatchStyleException Class | InvalidHatchStyleException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidHatchStyleException Constructor(String)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidHatchStyleException Class > InvalidHatchStyleException Constructor : InvalidHatchStyleException Constructor(String)

Exception which allows passing in a message when there are errors with hatch styles.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public InvalidHatchStyleException(
   string message
);
[C++]
public: InvalidHatchStyleException(
   string* message
)
[C++/CLI]
public:
InvalidHatchStyleException(
   String^ message
)

Parameters

message
A string which represents the message.

See Also

InvalidHatchStyleException Class | InvalidHatchStyleException Members | Overload List


InvalidHatchStyleException Constructor(String,Exception)

InvalidHatchStyleException Class | InvalidHatchStyleException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidHatchStyleException Constructor(String,Exception)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidHatchStyleException Class > InvalidHatchStyleException Constructor : InvalidHatchStyleException Constructor(String,Exception)

Exception which allows passing in a message and inner exception when there are errors with hatch styles.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public InvalidHatchStyleException(
   string message,
   Exception innerException
);
[C++]
public: InvalidHatchStyleException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
InvalidHatchStyleException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception.

See Also

InvalidHatchStyleException Class | InvalidHatchStyleException Members | Overload List


InvalidItemException Class

InvalidItemException Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidItemException Class

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidItemException Class

Exception class which is raised when there are errors with elements.

For a list of all members of this type, see InvalidItemException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.NotateXpress9.NotateXpressException
PegasusImaging.WinForms.NotateXpress9.InvalidItemException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class InvalidItemException
   Inherits NotateXpressException
   Implements ISerializable, _Exception
[C#]
[SerializableAttribute()]
public sealed class InvalidItemException : NotateXpressException, ISerializable, _Exception
[C++]
[SerializableAttribute()]
public __gc __sealed class InvalidItemException : public NotateXpressException, ISerializable, _Exception
[C++/CLI]
[SerializableAttribute()]
public ref class InvalidItemException sealed : public NotateXpressException, ISerializable, _Exception

See Also

InvalidItemException Members | PegasusImaging.WinForms.NotateXpress9 Namespace


InvalidItemException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidItemException Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidItemException Class

InvalidItemException overview

Public Constructors

Public Constructor InvalidItemException Constructor Overloaded. Main constructor for the InvalidItemException class when there are errors with elements.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InvalidItemException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


InvalidItemException Constructor

InvalidItemException Class | InvalidItemException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidItemException Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidItemException Class : InvalidItemException Constructor (InvalidItemException)

Main constructor for the InvalidItemException class when there are errors with elements.

Overload List

Main constructor for the InvalidItemException class when there are errors with elements.

[Visual Basic] Public Sub New()

[C#] public InvalidItemException();

[C++] public InvalidItemException();

[C++/CLI] public InvalidItemException();

Exception which allows passing in an error number when there are errors with elements.

[Visual Basic] Public Sub New(Integer)

[C#] public InvalidItemException(int);

[C++] public InvalidItemException(int);

[C++/CLI] public InvalidItemException(int);

Exception which allows passing in a message when there are errors with elements.

[Visual Basic] Public Sub New(String)

[C#] public InvalidItemException(string);

[C++] public InvalidItemException(string*);

[C++/CLI] public InvalidItemException(String^);

Exception which allows passing in an error number and message when there are errors with elements.

[Visual Basic] Public Sub New(Integer,String)

[C#] public InvalidItemException(int,string);

[C++] public InvalidItemException(int,string*);

[C++/CLI] public InvalidItemException(int,String^);

Exception which allows passing in a message and inner exception when there are errors with elements.

[Visual Basic] Public Sub New(String,Exception)

[C#] public InvalidItemException(string,Exception);

[C++] public InvalidItemException(string*,Exception*);

[C++/CLI] public InvalidItemException(String^,Exception^);

See Also

InvalidItemException Class | InvalidItemException Members


InvalidItemException Constructor()

InvalidItemException Class | InvalidItemException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidItemException Constructor()

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidItemException Class > InvalidItemException Constructor : InvalidItemException Constructor()

Main constructor for the InvalidItemException class when there are errors with elements.

[Visual Basic]
Public Function New()
[C#]
public InvalidItemException();
[C++]
public: InvalidItemException();
[C++/CLI]
public:
InvalidItemException();

See Also

InvalidItemException Class | InvalidItemException Members | Overload List


InvalidItemException Constructor(Int32)

InvalidItemException Class | InvalidItemException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidItemException Constructor(Int32)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidItemException Class > InvalidItemException Constructor : InvalidItemException Constructor(Int32)

Exception which allows passing in an error number when there are errors with elements.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public InvalidItemException(
   int errorNumber
);
[C++]
public: InvalidItemException(
   int errorNumber
)
[C++/CLI]
public:
InvalidItemException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

InvalidItemException Class | InvalidItemException Members | Overload List


InvalidItemException Constructor(Int32,String)

InvalidItemException Class | InvalidItemException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidItemException Constructor(Int32,String)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidItemException Class > InvalidItemException Constructor : InvalidItemException Constructor(Int32,String)

Exception which allows passing in an error number and message when there are errors with elements.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public InvalidItemException(
   int errorNumber,
   string message
);
[C++]
public: InvalidItemException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
InvalidItemException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

InvalidItemException Class | InvalidItemException Members | Overload List


InvalidItemException Constructor(String)

InvalidItemException Class | InvalidItemException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidItemException Constructor(String)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidItemException Class > InvalidItemException Constructor : InvalidItemException Constructor(String)

Exception which allows passing in a message when there are errors with elements.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public InvalidItemException(
   string message
);
[C++]
public: InvalidItemException(
   string* message
)
[C++/CLI]
public:
InvalidItemException(
   String^ message
)

Parameters

message
A string which represents the message.

See Also

InvalidItemException Class | InvalidItemException Members | Overload List


InvalidItemException Constructor(String,Exception)

InvalidItemException Class | InvalidItemException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidItemException Constructor(String,Exception)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidItemException Class > InvalidItemException Constructor : InvalidItemException Constructor(String,Exception)

Exception which allows passing in a message and inner exception when there are errors with elements.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public InvalidItemException(
   string message,
   Exception innerException
);
[C++]
public: InvalidItemException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
InvalidItemException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception.

See Also

InvalidItemException Class | InvalidItemException Members | Overload List


InvalidLayerException Class

InvalidLayerException Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidLayerException Class

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidLayerException Class

Exception class which is raised when there are errors with layers.

For a list of all members of this type, see InvalidLayerException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.NotateXpress9.NotateXpressException
PegasusImaging.WinForms.NotateXpress9.InvalidLayerException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class InvalidLayerException
   Inherits NotateXpressException
   Implements ISerializable, _Exception
[C#]
[SerializableAttribute()]
public sealed class InvalidLayerException : NotateXpressException, ISerializable, _Exception
[C++]
[SerializableAttribute()]
public __gc __sealed class InvalidLayerException : public NotateXpressException, ISerializable, _Exception
[C++/CLI]
[SerializableAttribute()]
public ref class InvalidLayerException sealed : public NotateXpressException, ISerializable, _Exception

See Also

InvalidLayerException Members | PegasusImaging.WinForms.NotateXpress9 Namespace


InvalidLayerException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidLayerException Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidLayerException Class

InvalidLayerException overview

Public Constructors

Public Constructor InvalidLayerException Constructor Overloaded. Main constructor for the InvalidLayerException class when there are errors with layers.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InvalidLayerException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


InvalidLayerException Constructor

InvalidLayerException Class | InvalidLayerException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidLayerException Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidLayerException Class : InvalidLayerException Constructor (InvalidLayerException)

Main constructor for the InvalidLayerException class when there are errors with layers.

Overload List

Main constructor for the InvalidLayerException class when there are errors with layers.

[Visual Basic] Public Sub New()

[C#] public InvalidLayerException();

[C++] public InvalidLayerException();

[C++/CLI] public InvalidLayerException();

Exception which allows passing in an error number when there are errors with layers.

[Visual Basic] Public Sub New(Integer)

[C#] public InvalidLayerException(int);

[C++] public InvalidLayerException(int);

[C++/CLI] public InvalidLayerException(int);

Exception which allows passing in a message when there are errors with layers.

[Visual Basic] Public Sub New(String)

[C#] public InvalidLayerException(string);

[C++] public InvalidLayerException(string*);

[C++/CLI] public InvalidLayerException(String^);

Exception which allows passing in an error number and message when there are errors with layers.

[Visual Basic] Public Sub New(Integer,String)

[C#] public InvalidLayerException(int,string);

[C++] public InvalidLayerException(int,string*);

[C++/CLI] public InvalidLayerException(int,String^);

Exception which allows passing in a message and inner exception when there are errors with layers.

[Visual Basic] Public Sub New(String,Exception)

[C#] public InvalidLayerException(string,Exception);

[C++] public InvalidLayerException(string*,Exception*);

[C++/CLI] public InvalidLayerException(String^,Exception^);

See Also

InvalidLayerException Class | InvalidLayerException Members


InvalidLayerException Constructor()

InvalidLayerException Class | InvalidLayerException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidLayerException Constructor()

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidLayerException Class > InvalidLayerException Constructor : InvalidLayerException Constructor()

Main constructor for the InvalidLayerException class when there are errors with layers.

[Visual Basic]
Public Function New()
[C#]
public InvalidLayerException();
[C++]
public: InvalidLayerException();
[C++/CLI]
public:
InvalidLayerException();

See Also

InvalidLayerException Class | InvalidLayerException Members | Overload List


InvalidLayerException Constructor(Int32)

InvalidLayerException Class | InvalidLayerException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidLayerException Constructor(Int32)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidLayerException Class > InvalidLayerException Constructor : InvalidLayerException Constructor(Int32)

Exception which allows passing in an error number when there are errors with layers.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public InvalidLayerException(
   int errorNumber
);
[C++]
public: InvalidLayerException(
   int errorNumber
)
[C++/CLI]
public:
InvalidLayerException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

InvalidLayerException Class | InvalidLayerException Members | Overload List


InvalidLayerException Constructor(Int32,String)

InvalidLayerException Class | InvalidLayerException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidLayerException Constructor(Int32,String)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidLayerException Class > InvalidLayerException Constructor : InvalidLayerException Constructor(Int32,String)

Exception which allows passing in an error number and message when there are errors with layers.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public InvalidLayerException(
   int errorNumber,
   string message
);
[C++]
public: InvalidLayerException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
InvalidLayerException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

InvalidLayerException Class | InvalidLayerException Members | Overload List


InvalidLayerException Constructor(String)

InvalidLayerException Class | InvalidLayerException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidLayerException Constructor(String)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidLayerException Class > InvalidLayerException Constructor : InvalidLayerException Constructor(String)

Exception which allows passing in a message when there are errors with layers.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public InvalidLayerException(
   string message
);
[C++]
public: InvalidLayerException(
   string* message
)
[C++/CLI]
public:
InvalidLayerException(
   String^ message
)

Parameters

message
A string which represents the message.

See Also

InvalidLayerException Class | InvalidLayerException Members | Overload List


InvalidLayerException Constructor(String,Exception)

InvalidLayerException Class | InvalidLayerException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidLayerException Constructor(String,Exception)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidLayerException Class > InvalidLayerException Constructor : InvalidLayerException Constructor(String,Exception)

Exception which allows passing in a message and inner exception when there are errors with layers.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public InvalidLayerException(
   string message,
   Exception innerException
);
[C++]
public: InvalidLayerException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
InvalidLayerException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception.

See Also

InvalidLayerException Class | InvalidLayerException Members | Overload List


InvalidModeException Class

InvalidModeException Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidModeException Class

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidModeException Class

Exception class which is raised when there are errors with modes.

For a list of all members of this type, see InvalidModeException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.NotateXpress9.NotateXpressException
PegasusImaging.WinForms.NotateXpress9.InvalidModeException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class InvalidModeException
   Inherits NotateXpressException
   Implements ISerializable, _Exception
[C#]
[SerializableAttribute()]
public sealed class InvalidModeException : NotateXpressException, ISerializable, _Exception
[C++]
[SerializableAttribute()]
public __gc __sealed class InvalidModeException : public NotateXpressException, ISerializable, _Exception
[C++/CLI]
[SerializableAttribute()]
public ref class InvalidModeException sealed : public NotateXpressException, ISerializable, _Exception

See Also

InvalidModeException Members | PegasusImaging.WinForms.NotateXpress9 Namespace


InvalidModeException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidModeException Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidModeException Class

InvalidModeException overview

Public Constructors

Public Constructor InvalidModeException Constructor Overloaded. Main constructor for the InvalidModeException class when there are errors with modes.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InvalidModeException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


InvalidModeException Constructor

InvalidModeException Class | InvalidModeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidModeException Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidModeException Class : InvalidModeException Constructor (InvalidModeException)

Main constructor for the InvalidModeException class when there are errors with modes.

Overload List

Main constructor for the InvalidModeException class when there are errors with modes.

[Visual Basic] Public Sub New()

[C#] public InvalidModeException();

[C++] public InvalidModeException();

[C++/CLI] public InvalidModeException();

Exception which allows passing in an error number when there are errors with modes.

[Visual Basic] Public Sub New(Integer)

[C#] public InvalidModeException(int);

[C++] public InvalidModeException(int);

[C++/CLI] public InvalidModeException(int);

Exception which allows passing in a message when there are errors with modes.

[Visual Basic] Public Sub New(String)

[C#] public InvalidModeException(string);

[C++] public InvalidModeException(string*);

[C++/CLI] public InvalidModeException(String^);

Exception which allows passing in an error number and message when there are errors with modes.

[Visual Basic] Public Sub New(Integer,String)

[C#] public InvalidModeException(int,string);

[C++] public InvalidModeException(int,string*);

[C++/CLI] public InvalidModeException(int,String^);

Exception which allows passing in a message and inner exception when there are errors with modes.

[Visual Basic] Public Sub New(String,Exception)

[C#] public InvalidModeException(string,Exception);

[C++] public InvalidModeException(string*,Exception*);

[C++/CLI] public InvalidModeException(String^,Exception^);

See Also

InvalidModeException Class | InvalidModeException Members


InvalidModeException Constructor()

InvalidModeException Class | InvalidModeException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidModeException Constructor()

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidModeException Class > InvalidModeException Constructor : InvalidModeException Constructor()

Main constructor for the InvalidModeException class when there are errors with modes.

[Visual Basic]
Public Function New()
[C#]
public InvalidModeException();
[C++]
public: InvalidModeException();
[C++/CLI]
public:
InvalidModeException();

See Also

InvalidModeException Class | InvalidModeException Members | Overload List


InvalidModeException Constructor(Int32)

InvalidModeException Class | InvalidModeException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidModeException Constructor(Int32)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidModeException Class > InvalidModeException Constructor : InvalidModeException Constructor(Int32)

Exception which allows passing in an error number when there are errors with modes.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public InvalidModeException(
   int errorNumber
);
[C++]
public: InvalidModeException(
   int errorNumber
)
[C++/CLI]
public:
InvalidModeException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

InvalidModeException Class | InvalidModeException Members | Overload List


InvalidModeException Constructor(Int32,String)

InvalidModeException Class | InvalidModeException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidModeException Constructor(Int32,String)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidModeException Class > InvalidModeException Constructor : InvalidModeException Constructor(Int32,String)

Exception which allows passing in an error number and message when there are errors with modes.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public InvalidModeException(
   int errorNumber,
   string message
);
[C++]
public: InvalidModeException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
InvalidModeException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

InvalidModeException Class | InvalidModeException Members | Overload List


InvalidModeException Constructor(String)

InvalidModeException Class | InvalidModeException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidModeException Constructor(String)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidModeException Class > InvalidModeException Constructor : InvalidModeException Constructor(String)

Exception which allows passing in a message when there are errors with modes.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public InvalidModeException(
   string message
);
[C++]
public: InvalidModeException(
   string* message
)
[C++/CLI]
public:
InvalidModeException(
   String^ message
)

Parameters

message
A string which represents the message.

See Also

InvalidModeException Class | InvalidModeException Members | Overload List


InvalidModeException Constructor(String,Exception)

InvalidModeException Class | InvalidModeException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidModeException Constructor(String,Exception)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidModeException Class > InvalidModeException Constructor : InvalidModeException Constructor(String,Exception)

Exception which allows passing in a message and inner exception when there are errors with modes.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public InvalidModeException(
   string message,
   Exception innerException
);
[C++]
public: InvalidModeException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
InvalidModeException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception.

See Also

InvalidModeException Class | InvalidModeException Members | Overload List


InvalidParameterException Class

InvalidParameterException Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidParameterException Class

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidParameterException Class

This class implements exceptions for invalid parameters.

For a list of all members of this type, see InvalidParameterException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.NotateXpress9.NotateXpressException
PegasusImaging.WinForms.NotateXpress9.InvalidParameterException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class InvalidParameterException
   Inherits NotateXpressException
   Implements ISerializable, _Exception
[C#]
[SerializableAttribute()]
public sealed class InvalidParameterException : NotateXpressException, ISerializable, _Exception
[C++]
[SerializableAttribute()]
public __gc __sealed class InvalidParameterException : public NotateXpressException, ISerializable, _Exception
[C++/CLI]
[SerializableAttribute()]
public ref class InvalidParameterException sealed : public NotateXpressException, ISerializable, _Exception

See Also

InvalidParameterException Members | PegasusImaging.WinForms.NotateXpress9 Namespace


InvalidParameterException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidParameterException Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidParameterException Class

InvalidParameterException overview

Public Constructors

Public Constructor InvalidParameterException Constructor Overloaded. Exception for invalid parameters.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InvalidParameterException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


InvalidParameterException Constructor

InvalidParameterException Class | InvalidParameterException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidParameterException Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidParameterException Class : InvalidParameterException Constructor (InvalidParameterException)

Exception for invalid parameters.

Overload List

Exception for invalid parameters.

[Visual Basic] Public Sub New()

[C#] public InvalidParameterException();

[C++] public InvalidParameterException();

[C++/CLI] public InvalidParameterException();

Exception which allows passing in an error number for invalid parameters.

[Visual Basic] Public Sub New(Integer)

[C#] public InvalidParameterException(int);

[C++] public InvalidParameterException(int);

[C++/CLI] public InvalidParameterException(int);

Exception which allows passing in an error message for invalid parameters.

[Visual Basic] Public Sub New(String)

[C#] public InvalidParameterException(string);

[C++] public InvalidParameterException(string*);

[C++/CLI] public InvalidParameterException(String^);

Exception which allows passing in an error number and message for invalid parameters.

[Visual Basic] Public Sub New(Integer,String)

[C#] public InvalidParameterException(int,string);

[C++] public InvalidParameterException(int,string*);

[C++/CLI] public InvalidParameterException(int,String^);

Exception which allows passing in an error message and an inner exception.

[Visual Basic] Public Sub New(String,Exception)

[C#] public InvalidParameterException(string,Exception);

[C++] public InvalidParameterException(string*,Exception*);

[C++/CLI] public InvalidParameterException(String^,Exception^);

See Also

InvalidParameterException Class | InvalidParameterException Members


InvalidParameterException Constructor()

InvalidParameterException Class | InvalidParameterException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidParameterException Constructor()

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidParameterException Class > InvalidParameterException Constructor : InvalidParameterException Constructor()

Exception for invalid parameters.

[Visual Basic]
Public Function New()
[C#]
public InvalidParameterException();
[C++]
public: InvalidParameterException();
[C++/CLI]
public:
InvalidParameterException();

See Also

InvalidParameterException Class | InvalidParameterException Members | Overload List


InvalidParameterException Constructor(Int32)

InvalidParameterException Class | InvalidParameterException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer value which represents the error number.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidParameterException Constructor(Int32)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidParameterException Class > InvalidParameterException Constructor : InvalidParameterException Constructor(Int32)

Exception which allows passing in an error number for invalid parameters.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public InvalidParameterException(
   int errorNumber
);
[C++]
public: InvalidParameterException(
   int errorNumber
)
[C++/CLI]
public:
InvalidParameterException(
   int errorNumber
)

Parameters

errorNumber
An integer value which represents the error number.

See Also

InvalidParameterException Class | InvalidParameterException Members | Overload List


InvalidParameterException Constructor(Int32,String)

InvalidParameterException Class | InvalidParameterException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer value which represents the error number.
message
A string value which represents the error message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidParameterException Constructor(Int32,String)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidParameterException Class > InvalidParameterException Constructor : InvalidParameterException Constructor(Int32,String)

Exception which allows passing in an error number and message for invalid parameters.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public InvalidParameterException(
   int errorNumber,
   string message
);
[C++]
public: InvalidParameterException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
InvalidParameterException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer value which represents the error number.
message
A string value which represents the error message.

See Also

InvalidParameterException Class | InvalidParameterException Members | Overload List


InvalidParameterException Constructor(String)

InvalidParameterException Class | InvalidParameterException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string value which represents the error message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidParameterException Constructor(String)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidParameterException Class > InvalidParameterException Constructor : InvalidParameterException Constructor(String)

Exception which allows passing in an error message for invalid parameters.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public InvalidParameterException(
   string message
);
[C++]
public: InvalidParameterException(
   string* message
)
[C++/CLI]
public:
InvalidParameterException(
   String^ message
)

Parameters

message
A string value which represents the error message.

See Also

InvalidParameterException Class | InvalidParameterException Members | Overload List


InvalidParameterException Constructor(String,Exception)

InvalidParameterException Class | InvalidParameterException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string value which represents the error message.
innerException
An inner exception that further describes the error.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidParameterException Constructor(String,Exception)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidParameterException Class > InvalidParameterException Constructor : InvalidParameterException Constructor(String,Exception)

Exception which allows passing in an error message and an inner exception.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public InvalidParameterException(
   string message,
   Exception innerException
);
[C++]
public: InvalidParameterException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
InvalidParameterException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string value which represents the error message.
innerException
An inner exception that further describes the error.

See Also

InvalidParameterException Class | InvalidParameterException Members | Overload List


InvalidPasswordException Class

InvalidPasswordException Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidPasswordException Class

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidPasswordException Class

Exception class which is raised when there are errors with passwords.

For a list of all members of this type, see InvalidPasswordException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.NotateXpress9.NotateXpressException
PegasusImaging.WinForms.NotateXpress9.InvalidPasswordException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class InvalidPasswordException
   Inherits NotateXpressException
   Implements ISerializable, _Exception
[C#]
[SerializableAttribute()]
public sealed class InvalidPasswordException : NotateXpressException, ISerializable, _Exception
[C++]
[SerializableAttribute()]
public __gc __sealed class InvalidPasswordException : public NotateXpressException, ISerializable, _Exception
[C++/CLI]
[SerializableAttribute()]
public ref class InvalidPasswordException sealed : public NotateXpressException, ISerializable, _Exception

See Also

InvalidPasswordException Members | PegasusImaging.WinForms.NotateXpress9 Namespace


InvalidPasswordException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidPasswordException Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidPasswordException Class

InvalidPasswordException overview

Public Constructors

Public Constructor InvalidPasswordException Constructor Overloaded. Main constructor for the InvalidPasswordException class when there are errors with passwords.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InvalidPasswordException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


InvalidPasswordException Constructor

InvalidPasswordException Class | InvalidPasswordException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidPasswordException Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidPasswordException Class : InvalidPasswordException Constructor (InvalidPasswordException)

Main constructor for the InvalidPasswordException class when there are errors with passwords.

Overload List

Main constructor for the InvalidPasswordException class when there are errors with passwords.

[Visual Basic] Public Sub New()

[C#] public InvalidPasswordException();

[C++] public InvalidPasswordException();

[C++/CLI] public InvalidPasswordException();

Excepion which allows passing in an error number when there are errors with passwords.

[Visual Basic] Public Sub New(Integer)

[C#] public InvalidPasswordException(int);

[C++] public InvalidPasswordException(int);

[C++/CLI] public InvalidPasswordException(int);

Exception which allows passing in a message when there are errors with passwords.

[Visual Basic] Public Sub New(String)

[C#] public InvalidPasswordException(string);

[C++] public InvalidPasswordException(string*);

[C++/CLI] public InvalidPasswordException(String^);

Exception which allows passing in an error number and message when there are errors with passwords.

[Visual Basic] Public Sub New(Integer,String)

[C#] public InvalidPasswordException(int,string);

[C++] public InvalidPasswordException(int,string*);

[C++/CLI] public InvalidPasswordException(int,String^);

Exception which allows passing in a message and inner exception when there are errors with passwords.

[Visual Basic] Public Sub New(String,Exception)

[C#] public InvalidPasswordException(string,Exception);

[C++] public InvalidPasswordException(string*,Exception*);

[C++/CLI] public InvalidPasswordException(String^,Exception^);

See Also

InvalidPasswordException Class | InvalidPasswordException Members


InvalidPasswordException Constructor()

InvalidPasswordException Class | InvalidPasswordException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidPasswordException Constructor()

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidPasswordException Class > InvalidPasswordException Constructor : InvalidPasswordException Constructor()

Main constructor for the InvalidPasswordException class when there are errors with passwords.

[Visual Basic]
Public Function New()
[C#]
public InvalidPasswordException();
[C++]
public: InvalidPasswordException();
[C++/CLI]
public:
InvalidPasswordException();

See Also

InvalidPasswordException Class | InvalidPasswordException Members | Overload List


InvalidPasswordException Constructor(Int32)

InvalidPasswordException Class | InvalidPasswordException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidPasswordException Constructor(Int32)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidPasswordException Class > InvalidPasswordException Constructor : InvalidPasswordException Constructor(Int32)

Excepion which allows passing in an error number when there are errors with passwords.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public InvalidPasswordException(
   int errorNumber
);
[C++]
public: InvalidPasswordException(
   int errorNumber
)
[C++/CLI]
public:
InvalidPasswordException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

InvalidPasswordException Class | InvalidPasswordException Members | Overload List


InvalidPasswordException Constructor(Int32,String)

InvalidPasswordException Class | InvalidPasswordException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidPasswordException Constructor(Int32,String)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidPasswordException Class > InvalidPasswordException Constructor : InvalidPasswordException Constructor(Int32,String)

Exception which allows passing in an error number and message when there are errors with passwords.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public InvalidPasswordException(
   int errorNumber,
   string message
);
[C++]
public: InvalidPasswordException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
InvalidPasswordException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

InvalidPasswordException Class | InvalidPasswordException Members | Overload List


InvalidPasswordException Constructor(String)

InvalidPasswordException Class | InvalidPasswordException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidPasswordException Constructor(String)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidPasswordException Class > InvalidPasswordException Constructor : InvalidPasswordException Constructor(String)

Exception which allows passing in a message when there are errors with passwords.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public InvalidPasswordException(
   string message
);
[C++]
public: InvalidPasswordException(
   string* message
)
[C++/CLI]
public:
InvalidPasswordException(
   String^ message
)

Parameters

message
A string which represents the message.

See Also

InvalidPasswordException Class | InvalidPasswordException Members | Overload List


InvalidPasswordException Constructor(String,Exception)

InvalidPasswordException Class | InvalidPasswordException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidPasswordException Constructor(String,Exception)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidPasswordException Class > InvalidPasswordException Constructor : InvalidPasswordException Constructor(String,Exception)

Exception which allows passing in a message and inner exception when there are errors with passwords.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public InvalidPasswordException(
   string message,
   Exception innerException
);
[C++]
public: InvalidPasswordException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
InvalidPasswordException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception.

See Also

InvalidPasswordException Class | InvalidPasswordException Members | Overload List


InvalidPointException Class

InvalidPointException Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidPointException Class

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidPointException Class

Exception class which is raised when there are invalid point errors.

For a list of all members of this type, see InvalidPointException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.NotateXpress9.NotateXpressException
PegasusImaging.WinForms.NotateXpress9.InvalidPointException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class InvalidPointException
   Inherits NotateXpressException
   Implements ISerializable, _Exception
[C#]
[SerializableAttribute()]
public sealed class InvalidPointException : NotateXpressException, ISerializable, _Exception
[C++]
[SerializableAttribute()]
public __gc __sealed class InvalidPointException : public NotateXpressException, ISerializable, _Exception
[C++/CLI]
[SerializableAttribute()]
public ref class InvalidPointException sealed : public NotateXpressException, ISerializable, _Exception

See Also

InvalidPointException Members | PegasusImaging.WinForms.NotateXpress9 Namespace


InvalidPointException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidPointException Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidPointException Class

InvalidPointException overview

Public Constructors

Public Constructor InvalidPointException Constructor Overloaded. Main constructor for the InvalidPointException class when there are invalid point errors.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InvalidPointException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


InvalidPointException Constructor

InvalidPointException Class | InvalidPointException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidPointException Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidPointException Class : InvalidPointException Constructor (InvalidPointException)

Main constructor for the InvalidPointException class when there are invalid point errors.

Overload List

Main constructor for the InvalidPointException class when there are invalid point errors.

[Visual Basic] Public Sub New()

[C#] public InvalidPointException();

[C++] public InvalidPointException();

[C++/CLI] public InvalidPointException();

Exception which allows passing in an error number when there are invalid point errors.

[Visual Basic] Public Sub New(Integer)

[C#] public InvalidPointException(int);

[C++] public InvalidPointException(int);

[C++/CLI] public InvalidPointException(int);

Exception which allows passing in a message when there are invalid point errors.

[Visual Basic] Public Sub New(String)

[C#] public InvalidPointException(string);

[C++] public InvalidPointException(string*);

[C++/CLI] public InvalidPointException(String^);

Exception which allows passing in an error number and message when there are invalid point errors.

[Visual Basic] Public Sub New(Integer,String)

[C#] public InvalidPointException(int,string);

[C++] public InvalidPointException(int,string*);

[C++/CLI] public InvalidPointException(int,String^);

Exception which allows passing in a message and inner exception when there are invalid point errors.

[Visual Basic] Public Sub New(String,Exception)

[C#] public InvalidPointException(string,Exception);

[C++] public InvalidPointException(string*,Exception*);

[C++/CLI] public InvalidPointException(String^,Exception^);

See Also

InvalidPointException Class | InvalidPointException Members


InvalidPointException Constructor()

InvalidPointException Class | InvalidPointException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidPointException Constructor()

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidPointException Class > InvalidPointException Constructor : InvalidPointException Constructor()

Main constructor for the InvalidPointException class when there are invalid point errors.

[Visual Basic]
Public Function New()
[C#]
public InvalidPointException();
[C++]
public: InvalidPointException();
[C++/CLI]
public:
InvalidPointException();

See Also

InvalidPointException Class | InvalidPointException Members | Overload List


InvalidPointException Constructor(Int32)

InvalidPointException Class | InvalidPointException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidPointException Constructor(Int32)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidPointException Class > InvalidPointException Constructor : InvalidPointException Constructor(Int32)

Exception which allows passing in an error number when there are invalid point errors.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public InvalidPointException(
   int errorNumber
);
[C++]
public: InvalidPointException(
   int errorNumber
)
[C++/CLI]
public:
InvalidPointException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

InvalidPointException Class | InvalidPointException Members | Overload List


InvalidPointException Constructor(Int32,String)

InvalidPointException Class | InvalidPointException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidPointException Constructor(Int32,String)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidPointException Class > InvalidPointException Constructor : InvalidPointException Constructor(Int32,String)

Exception which allows passing in an error number and message when there are invalid point errors.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public InvalidPointException(
   int errorNumber,
   string message
);
[C++]
public: InvalidPointException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
InvalidPointException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

InvalidPointException Class | InvalidPointException Members | Overload List


InvalidPointException Constructor(String)

InvalidPointException Class | InvalidPointException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidPointException Constructor(String)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidPointException Class > InvalidPointException Constructor : InvalidPointException Constructor(String)

Exception which allows passing in a message when there are invalid point errors.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public InvalidPointException(
   string message
);
[C++]
public: InvalidPointException(
   string* message
)
[C++/CLI]
public:
InvalidPointException(
   String^ message
)

Parameters

message
A string which represents the message.

See Also

InvalidPointException Class | InvalidPointException Members | Overload List


InvalidPointException Constructor(String,Exception)

InvalidPointException Class | InvalidPointException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidPointException Constructor(String,Exception)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidPointException Class > InvalidPointException Constructor : InvalidPointException Constructor(String,Exception)

Exception which allows passing in a message and inner exception when there are invalid point errors.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public InvalidPointException(
   string message,
   Exception innerException
);
[C++]
public: InvalidPointException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
InvalidPointException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception.

See Also

InvalidPointException Class | InvalidPointException Members | Overload List


InvalidTiffAnnTypeException Class

InvalidTiffAnnTypeException Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidTiffAnnTypeException Class

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidTiffAnnTypeException Class

Exception class which is raised when there are TIFF annotation type errors.

For a list of all members of this type, see InvalidTiffAnnTypeException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.NotateXpress9.NotateXpressException
PegasusImaging.WinForms.NotateXpress9.InvalidTiffAnnTypeException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class InvalidTiffAnnTypeException
   Inherits NotateXpressException
   Implements ISerializable, _Exception
[C#]
[SerializableAttribute()]
public sealed class InvalidTiffAnnTypeException : NotateXpressException, ISerializable, _Exception
[C++]
[SerializableAttribute()]
public __gc __sealed class InvalidTiffAnnTypeException : public NotateXpressException, ISerializable, _Exception
[C++/CLI]
[SerializableAttribute()]
public ref class InvalidTiffAnnTypeException sealed : public NotateXpressException, ISerializable, _Exception

See Also

InvalidTiffAnnTypeException Members | PegasusImaging.WinForms.NotateXpress9 Namespace


InvalidTiffAnnTypeException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidTiffAnnTypeException Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidTiffAnnTypeException Class

InvalidTiffAnnTypeException overview

Public Constructors

Public Constructor InvalidTiffAnnTypeException Constructor Overloaded. Main constructor for the InvalidTiffAnnTypeException class when there are TIFF annotation type errors.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InvalidTiffAnnTypeException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


InvalidTiffAnnTypeException Constructor

InvalidTiffAnnTypeException Class | InvalidTiffAnnTypeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidTiffAnnTypeException Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidTiffAnnTypeException Class : InvalidTiffAnnTypeException Constructor (InvalidTiffAnnTypeException)

Main constructor for the InvalidTiffAnnTypeException class when there are TIFF annotation type errors.

Overload List

Main constructor for the InvalidTiffAnnTypeException class when there are TIFF annotation type errors.

[Visual Basic] Public Sub New()

[C#] public InvalidTiffAnnTypeException();

[C++] public InvalidTiffAnnTypeException();

[C++/CLI] public InvalidTiffAnnTypeException();

Exception which allows passing in an error number when there are TIFF annotation type errors.

[Visual Basic] Public Sub New(Integer)

[C#] public InvalidTiffAnnTypeException(int);

[C++] public InvalidTiffAnnTypeException(int);

[C++/CLI] public InvalidTiffAnnTypeException(int);

Exception which allows passing in a message when there are TIFF annotation type errors.

[Visual Basic] Public Sub New(String)

[C#] public InvalidTiffAnnTypeException(string);

[C++] public InvalidTiffAnnTypeException(string*);

[C++/CLI] public InvalidTiffAnnTypeException(String^);

Exception which allows passing in an error number and message when there are TIFF annotation type errors.

[Visual Basic] Public Sub New(Integer,String)

[C#] public InvalidTiffAnnTypeException(int,string);

[C++] public InvalidTiffAnnTypeException(int,string*);

[C++/CLI] public InvalidTiffAnnTypeException(int,String^);

Exception which allows passing in a message and inner exception when there are TIFF annotation type errors.

[Visual Basic] Public Sub New(String,Exception)

[C#] public InvalidTiffAnnTypeException(string,Exception);

[C++] public InvalidTiffAnnTypeException(string*,Exception*);

[C++/CLI] public InvalidTiffAnnTypeException(String^,Exception^);

See Also

InvalidTiffAnnTypeException Class | InvalidTiffAnnTypeException Members


InvalidTiffAnnTypeException Constructor()

InvalidTiffAnnTypeException Class | InvalidTiffAnnTypeException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidTiffAnnTypeException Constructor()

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidTiffAnnTypeException Class > InvalidTiffAnnTypeException Constructor : InvalidTiffAnnTypeException Constructor()

Main constructor for the InvalidTiffAnnTypeException class when there are TIFF annotation type errors.

[Visual Basic]
Public Function New()
[C#]
public InvalidTiffAnnTypeException();
[C++]
public: InvalidTiffAnnTypeException();
[C++/CLI]
public:
InvalidTiffAnnTypeException();

See Also

InvalidTiffAnnTypeException Class | InvalidTiffAnnTypeException Members | Overload List


InvalidTiffAnnTypeException Constructor(Int32)

InvalidTiffAnnTypeException Class | InvalidTiffAnnTypeException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents an error number.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidTiffAnnTypeException Constructor(Int32)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidTiffAnnTypeException Class > InvalidTiffAnnTypeException Constructor : InvalidTiffAnnTypeException Constructor(Int32)

Exception which allows passing in an error number when there are TIFF annotation type errors.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public InvalidTiffAnnTypeException(
   int errorNumber
);
[C++]
public: InvalidTiffAnnTypeException(
   int errorNumber
)
[C++/CLI]
public:
InvalidTiffAnnTypeException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents an error number.

See Also

InvalidTiffAnnTypeException Class | InvalidTiffAnnTypeException Members | Overload List


InvalidTiffAnnTypeException Constructor(Int32,String)

InvalidTiffAnnTypeException Class | InvalidTiffAnnTypeException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidTiffAnnTypeException Constructor(Int32,String)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidTiffAnnTypeException Class > InvalidTiffAnnTypeException Constructor : InvalidTiffAnnTypeException Constructor(Int32,String)

Exception which allows passing in an error number and message when there are TIFF annotation type errors.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public InvalidTiffAnnTypeException(
   int errorNumber,
   string message
);
[C++]
public: InvalidTiffAnnTypeException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
InvalidTiffAnnTypeException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

InvalidTiffAnnTypeException Class | InvalidTiffAnnTypeException Members | Overload List


InvalidTiffAnnTypeException Constructor(String)

InvalidTiffAnnTypeException Class | InvalidTiffAnnTypeException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidTiffAnnTypeException Constructor(String)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidTiffAnnTypeException Class > InvalidTiffAnnTypeException Constructor : InvalidTiffAnnTypeException Constructor(String)

Exception which allows passing in a message when there are TIFF annotation type errors.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public InvalidTiffAnnTypeException(
   string message
);
[C++]
public: InvalidTiffAnnTypeException(
   string* message
)
[C++/CLI]
public:
InvalidTiffAnnTypeException(
   String^ message
)

Parameters

message
A string which represents the message.

See Also

InvalidTiffAnnTypeException Class | InvalidTiffAnnTypeException Members | Overload List


InvalidTiffAnnTypeException Constructor(String,Exception)

InvalidTiffAnnTypeException Class | InvalidTiffAnnTypeException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidTiffAnnTypeException Constructor(String,Exception)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidTiffAnnTypeException Class > InvalidTiffAnnTypeException Constructor : InvalidTiffAnnTypeException Constructor(String,Exception)

Exception which allows passing in a message and inner exception when there are TIFF annotation type errors.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public InvalidTiffAnnTypeException(
   string message,
   Exception innerException
);
[C++]
public: InvalidTiffAnnTypeException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
InvalidTiffAnnTypeException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception.

See Also

InvalidTiffAnnTypeException Class | InvalidTiffAnnTypeException Members | Overload List


InvalidToolException Class

InvalidToolException Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidToolException Class

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidToolException Class

Exception class raised when there is an error with a tool.

For a list of all members of this type, see InvalidToolException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.NotateXpress9.NotateXpressException
PegasusImaging.WinForms.NotateXpress9.InvalidToolException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class InvalidToolException
   Inherits NotateXpressException
   Implements ISerializable, _Exception
[C#]
[SerializableAttribute()]
public sealed class InvalidToolException : NotateXpressException, ISerializable, _Exception
[C++]
[SerializableAttribute()]
public __gc __sealed class InvalidToolException : public NotateXpressException, ISerializable, _Exception
[C++/CLI]
[SerializableAttribute()]
public ref class InvalidToolException sealed : public NotateXpressException, ISerializable, _Exception

See Also

InvalidToolException Members | PegasusImaging.WinForms.NotateXpress9 Namespace


InvalidToolException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidToolException Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidToolException Class

InvalidToolException overview

Public Constructors

Public Constructor InvalidToolException Constructor Overloaded. Base constructor for the InvalidToolException class.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InvalidToolException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


InvalidToolException Constructor

InvalidToolException Class | InvalidToolException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidToolException Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidToolException Class : InvalidToolException Constructor (InvalidToolException)

Base constructor for the InvalidToolException class.

Overload List

Base constructor for the InvalidToolException class.

[Visual Basic] Public Sub New()

[C#] public InvalidToolException();

[C++] public InvalidToolException();

[C++/CLI] public InvalidToolException();

Exception which allows passing in an error number when there is a tool error.

[Visual Basic] Public Sub New(Integer)

[C#] public InvalidToolException(int);

[C++] public InvalidToolException(int);

[C++/CLI] public InvalidToolException(int);

Exception which allows passing in a message when there is a tool error.

[Visual Basic] Public Sub New(String)

[C#] public InvalidToolException(string);

[C++] public InvalidToolException(string*);

[C++/CLI] public InvalidToolException(String^);

Exception which allows passing in an error number and a message when there is a tool error.

[Visual Basic] Public Sub New(Integer,String)

[C#] public InvalidToolException(int,string);

[C++] public InvalidToolException(int,string*);

[C++/CLI] public InvalidToolException(int,String^);

Exception which allows passing in a message and inner exception when there is a tool error.

[Visual Basic] Public Sub New(String,Exception)

[C#] public InvalidToolException(string,Exception);

[C++] public InvalidToolException(string*,Exception*);

[C++/CLI] public InvalidToolException(String^,Exception^);

See Also

InvalidToolException Class | InvalidToolException Members


InvalidToolException Constructor()

InvalidToolException Class | InvalidToolException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidToolException Constructor()

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidToolException Class > InvalidToolException Constructor : InvalidToolException Constructor()

Base constructor for the InvalidToolException class.

[Visual Basic]
Public Function New()
[C#]
public InvalidToolException();
[C++]
public: InvalidToolException();
[C++/CLI]
public:
InvalidToolException();

See Also

InvalidToolException Class | InvalidToolException Members | Overload List


InvalidToolException Constructor(Int32)

InvalidToolException Class | InvalidToolException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidToolException Constructor(Int32)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidToolException Class > InvalidToolException Constructor : InvalidToolException Constructor(Int32)

Exception which allows passing in an error number when there is a tool error.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public InvalidToolException(
   int errorNumber
);
[C++]
public: InvalidToolException(
   int errorNumber
)
[C++/CLI]
public:
InvalidToolException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

InvalidToolException Class | InvalidToolException Members | Overload List


InvalidToolException Constructor(Int32,String)

InvalidToolException Class | InvalidToolException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidToolException Constructor(Int32,String)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidToolException Class > InvalidToolException Constructor : InvalidToolException Constructor(Int32,String)

Exception which allows passing in an error number and a message when there is a tool error.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public InvalidToolException(
   int errorNumber,
   string message
);
[C++]
public: InvalidToolException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
InvalidToolException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

InvalidToolException Class | InvalidToolException Members | Overload List


InvalidToolException Constructor(String)

InvalidToolException Class | InvalidToolException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidToolException Constructor(String)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidToolException Class > InvalidToolException Constructor : InvalidToolException Constructor(String)

Exception which allows passing in a message when there is a tool error.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public InvalidToolException(
   string message
);
[C++]
public: InvalidToolException(
   string* message
)
[C++/CLI]
public:
InvalidToolException(
   String^ message
)

Parameters

message

See Also

InvalidToolException Class | InvalidToolException Members | Overload List


InvalidToolException Constructor(String,Exception)

InvalidToolException Class | InvalidToolException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidToolException Constructor(String,Exception)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidToolException Class > InvalidToolException Constructor : InvalidToolException Constructor(String,Exception)

Exception which allows passing in a message and inner exception when there is a tool error.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public InvalidToolException(
   string message,
   Exception innerException
);
[C++]
public: InvalidToolException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
InvalidToolException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception.

See Also

InvalidToolException Class | InvalidToolException Members | Overload List


InvalidVariantException Class

InvalidVariantException Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidVariantException Class

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidVariantException Class

Exception class which is raised when a variant is not allowed.

For a list of all members of this type, see InvalidVariantException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.NotateXpress9.NotateXpressException
PegasusImaging.WinForms.NotateXpress9.InvalidVariantException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class InvalidVariantException
   Inherits NotateXpressException
   Implements ISerializable, _Exception
[C#]
[SerializableAttribute()]
public sealed class InvalidVariantException : NotateXpressException, ISerializable, _Exception
[C++]
[SerializableAttribute()]
public __gc __sealed class InvalidVariantException : public NotateXpressException, ISerializable, _Exception
[C++/CLI]
[SerializableAttribute()]
public ref class InvalidVariantException sealed : public NotateXpressException, ISerializable, _Exception

See Also

InvalidVariantException Members | PegasusImaging.WinForms.NotateXpress9 Namespace


InvalidVariantException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidVariantException Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidVariantException Class

InvalidVariantException overview

Public Constructors

Public Constructor InvalidVariantException Constructor Overloaded. Main constructor for the InvalidVariantException class when a variant is not allowed.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InvalidVariantException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


InvalidVariantException Constructor

InvalidVariantException Class | InvalidVariantException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidVariantException Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidVariantException Class : InvalidVariantException Constructor (InvalidVariantException)

Main constructor for the InvalidVariantException class when a variant is not allowed.

Overload List

Main constructor for the InvalidVariantException class when a variant is not allowed.

[Visual Basic] Public Sub New()

[C#] public InvalidVariantException();

[C++] public InvalidVariantException();

[C++/CLI] public InvalidVariantException();

Exception which allows passing in an error number when a variant is not allowed.

[Visual Basic] Public Sub New(Integer)

[C#] public InvalidVariantException(int);

[C++] public InvalidVariantException(int);

[C++/CLI] public InvalidVariantException(int);

Exception which allows passing in a message when a variant is not allowed.

[Visual Basic] Public Sub New(String)

[C#] public InvalidVariantException(string);

[C++] public InvalidVariantException(string*);

[C++/CLI] public InvalidVariantException(String^);

Exception which allows passing in an error number and message when a variant is not allowed.

[Visual Basic] Public Sub New(Integer,String)

[C#] public InvalidVariantException(int,string);

[C++] public InvalidVariantException(int,string*);

[C++/CLI] public InvalidVariantException(int,String^);

Exception which allows passing in a message and inner exception when a variant is not allowed.

[Visual Basic] Public Sub New(String,Exception)

[C#] public InvalidVariantException(string,Exception);

[C++] public InvalidVariantException(string*,Exception*);

[C++/CLI] public InvalidVariantException(String^,Exception^);

See Also

InvalidVariantException Class | InvalidVariantException Members


InvalidVariantException Constructor()

InvalidVariantException Class | InvalidVariantException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidVariantException Constructor()

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidVariantException Class > InvalidVariantException Constructor : InvalidVariantException Constructor()

Main constructor for the InvalidVariantException class when a variant is not allowed.

[Visual Basic]
Public Function New()
[C#]
public InvalidVariantException();
[C++]
public: InvalidVariantException();
[C++/CLI]
public:
InvalidVariantException();

See Also

InvalidVariantException Class | InvalidVariantException Members | Overload List


InvalidVariantException Constructor(Int32)

InvalidVariantException Class | InvalidVariantException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidVariantException Constructor(Int32)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidVariantException Class > InvalidVariantException Constructor : InvalidVariantException Constructor(Int32)

Exception which allows passing in an error number when a variant is not allowed.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public InvalidVariantException(
   int errorNumber
);
[C++]
public: InvalidVariantException(
   int errorNumber
)
[C++/CLI]
public:
InvalidVariantException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

InvalidVariantException Class | InvalidVariantException Members | Overload List


InvalidVariantException Constructor(Int32,String)

InvalidVariantException Class | InvalidVariantException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidVariantException Constructor(Int32,String)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidVariantException Class > InvalidVariantException Constructor : InvalidVariantException Constructor(Int32,String)

Exception which allows passing in an error number and message when a variant is not allowed.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public InvalidVariantException(
   int errorNumber,
   string message
);
[C++]
public: InvalidVariantException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
InvalidVariantException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

InvalidVariantException Class | InvalidVariantException Members | Overload List


InvalidVariantException Constructor(String)

InvalidVariantException Class | InvalidVariantException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidVariantException Constructor(String)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidVariantException Class > InvalidVariantException Constructor : InvalidVariantException Constructor(String)

Exception which allows passing in a message when a variant is not allowed.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public InvalidVariantException(
   string message
);
[C++]
public: InvalidVariantException(
   string* message
)
[C++/CLI]
public:
InvalidVariantException(
   String^ message
)

Parameters

message
A string which represents the message.

See Also

InvalidVariantException Class | InvalidVariantException Members | Overload List


InvalidVariantException Constructor(String,Exception)

InvalidVariantException Class | InvalidVariantException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents a message.
innerException
An inner exception.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidVariantException Constructor(String,Exception)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidVariantException Class > InvalidVariantException Constructor : InvalidVariantException Constructor(String,Exception)

Exception which allows passing in a message and inner exception when a variant is not allowed.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public InvalidVariantException(
   string message,
   Exception innerException
);
[C++]
public: InvalidVariantException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
InvalidVariantException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents a message.
innerException
An inner exception.

See Also

InvalidVariantException Class | InvalidVariantException Members | Overload List


InvalidWangTypeException Class

InvalidWangTypeException Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidWangTypeException Class

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidWangTypeException Class

Exception class which is raised when there are Wang type not allowed errors.

For a list of all members of this type, see InvalidWangTypeException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.NotateXpress9.NotateXpressException
PegasusImaging.WinForms.NotateXpress9.InvalidWangTypeException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class InvalidWangTypeException
   Inherits NotateXpressException
   Implements ISerializable, _Exception
[C#]
[SerializableAttribute()]
public sealed class InvalidWangTypeException : NotateXpressException, ISerializable, _Exception
[C++]
[SerializableAttribute()]
public __gc __sealed class InvalidWangTypeException : public NotateXpressException, ISerializable, _Exception
[C++/CLI]
[SerializableAttribute()]
public ref class InvalidWangTypeException sealed : public NotateXpressException, ISerializable, _Exception

See Also

InvalidWangTypeException Members | PegasusImaging.WinForms.NotateXpress9 Namespace


InvalidWangTypeException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidWangTypeException Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidWangTypeException Class

InvalidWangTypeException overview

Public Constructors

Public Constructor InvalidWangTypeException Constructor Overloaded. Main constructor for the InvalidWangTypeException class when there are Wang type not allowed errors.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InvalidWangTypeException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


InvalidWangTypeException Constructor

InvalidWangTypeException Class | InvalidWangTypeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidWangTypeException Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidWangTypeException Class : InvalidWangTypeException Constructor (InvalidWangTypeException)

Main constructor for the InvalidWangTypeException class when there are Wang type not allowed errors.

Overload List

Main constructor for the InvalidWangTypeException class when there are Wang type not allowed errors.

[Visual Basic] Public Sub New()

[C#] public InvalidWangTypeException();

[C++] public InvalidWangTypeException();

[C++/CLI] public InvalidWangTypeException();

Exception which allows passing in an error number when there are Wang type not allowed errors.

[Visual Basic] Public Sub New(Integer)

[C#] public InvalidWangTypeException(int);

[C++] public InvalidWangTypeException(int);

[C++/CLI] public InvalidWangTypeException(int);

Exception which allows passing in a message when thee are Wang type not allowed errors.

[Visual Basic] Public Sub New(String)

[C#] public InvalidWangTypeException(string);

[C++] public InvalidWangTypeException(string*);

[C++/CLI] public InvalidWangTypeException(String^);

Exception which allows passing in an error number and message when there are Wang type not allowed errors.

[Visual Basic] Public Sub New(Integer,String)

[C#] public InvalidWangTypeException(int,string);

[C++] public InvalidWangTypeException(int,string*);

[C++/CLI] public InvalidWangTypeException(int,String^);

Exception which allows passing in a message and inner exception when there are Wang type not allowed errors.

[Visual Basic] Public Sub New(String,Exception)

[C#] public InvalidWangTypeException(string,Exception);

[C++] public InvalidWangTypeException(string*,Exception*);

[C++/CLI] public InvalidWangTypeException(String^,Exception^);

See Also

InvalidWangTypeException Class | InvalidWangTypeException Members


InvalidWangTypeException Constructor()

InvalidWangTypeException Class | InvalidWangTypeException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidWangTypeException Constructor()

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidWangTypeException Class > InvalidWangTypeException Constructor : InvalidWangTypeException Constructor()

Main constructor for the InvalidWangTypeException class when there are Wang type not allowed errors.

[Visual Basic]
Public Function New()
[C#]
public InvalidWangTypeException();
[C++]
public: InvalidWangTypeException();
[C++/CLI]
public:
InvalidWangTypeException();

See Also

InvalidWangTypeException Class | InvalidWangTypeException Members | Overload List


InvalidWangTypeException Constructor(Int32)

InvalidWangTypeException Class | InvalidWangTypeException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidWangTypeException Constructor(Int32)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidWangTypeException Class > InvalidWangTypeException Constructor : InvalidWangTypeException Constructor(Int32)

Exception which allows passing in an error number when there are Wang type not allowed errors.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public InvalidWangTypeException(
   int errorNumber
);
[C++]
public: InvalidWangTypeException(
   int errorNumber
)
[C++/CLI]
public:
InvalidWangTypeException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

InvalidWangTypeException Class | InvalidWangTypeException Members | Overload List


InvalidWangTypeException Constructor(Int32,String)

InvalidWangTypeException Class | InvalidWangTypeException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidWangTypeException Constructor(Int32,String)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidWangTypeException Class > InvalidWangTypeException Constructor : InvalidWangTypeException Constructor(Int32,String)

Exception which allows passing in an error number and message when there are Wang type not allowed errors.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public InvalidWangTypeException(
   int errorNumber,
   string message
);
[C++]
public: InvalidWangTypeException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
InvalidWangTypeException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

InvalidWangTypeException Class | InvalidWangTypeException Members | Overload List


InvalidWangTypeException Constructor(String)

InvalidWangTypeException Class | InvalidWangTypeException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidWangTypeException Constructor(String)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidWangTypeException Class > InvalidWangTypeException Constructor : InvalidWangTypeException Constructor(String)

Exception which allows passing in a message when thee are Wang type not allowed errors.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public InvalidWangTypeException(
   string message
);
[C++]
public: InvalidWangTypeException(
   string* message
)
[C++/CLI]
public:
InvalidWangTypeException(
   String^ message
)

Parameters

message
A string which represents the message.

See Also

InvalidWangTypeException Class | InvalidWangTypeException Members | Overload List


InvalidWangTypeException Constructor(String,Exception)

InvalidWangTypeException Class | InvalidWangTypeException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidWangTypeException Constructor(String,Exception)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidWangTypeException Class > InvalidWangTypeException Constructor : InvalidWangTypeException Constructor(String,Exception)

Exception which allows passing in a message and inner exception when there are Wang type not allowed errors.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public InvalidWangTypeException(
   string message,
   Exception innerException
);
[C++]
public: InvalidWangTypeException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
InvalidWangTypeException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception.

See Also

InvalidWangTypeException Class | InvalidWangTypeException Members | Overload List


InvalidWindowHandleException Class

InvalidWindowHandleException Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidWindowHandleException Class

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidWindowHandleException Class

Exception class raised when a passed in window handle is not valid.

For a list of all members of this type, see InvalidWindowHandleException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.NotateXpress9.NotateXpressException
PegasusImaging.WinForms.NotateXpress9.InvalidWindowHandleException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class InvalidWindowHandleException
   Inherits NotateXpressException
   Implements ISerializable, _Exception
[C#]
[SerializableAttribute()]
public sealed class InvalidWindowHandleException : NotateXpressException, ISerializable, _Exception
[C++]
[SerializableAttribute()]
public __gc __sealed class InvalidWindowHandleException : public NotateXpressException, ISerializable, _Exception
[C++/CLI]
[SerializableAttribute()]
public ref class InvalidWindowHandleException sealed : public NotateXpressException, ISerializable, _Exception

See Also

InvalidWindowHandleException Members | PegasusImaging.WinForms.NotateXpress9 Namespace


InvalidWindowHandleException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidWindowHandleException Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidWindowHandleException Class

InvalidWindowHandleException overview

Public Constructors

Public Constructor InvalidWindowHandleException Constructor Overloaded. Main constructor for the InvalidWindowHandleException class.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InvalidWindowHandleException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


InvalidWindowHandleException Constructor

InvalidWindowHandleException Class | InvalidWindowHandleException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidWindowHandleException Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidWindowHandleException Class : InvalidWindowHandleException Constructor (InvalidWindowHandleException)

Main constructor for the InvalidWindowHandleException class.

Overload List

Main constructor for the InvalidWindowHandleException class.

[Visual Basic] Public Sub New()

[C#] public InvalidWindowHandleException();

[C++] public InvalidWindowHandleException();

[C++/CLI] public InvalidWindowHandleException();

Exception which allows passing in an error number when a passed in window handle is not valid.

[Visual Basic] Public Sub New(Integer)

[C#] public InvalidWindowHandleException(int);

[C++] public InvalidWindowHandleException(int);

[C++/CLI] public InvalidWindowHandleException(int);

Exception which allows passing in a message when a passed in window handle is not valid.

[Visual Basic] Public Sub New(String)

[C#] public InvalidWindowHandleException(string);

[C++] public InvalidWindowHandleException(string*);

[C++/CLI] public InvalidWindowHandleException(String^);

Exception which allows passing in an error number and message when a passed in window handle is not valid.

[Visual Basic] Public Sub New(Integer,String)

[C#] public InvalidWindowHandleException(int,string);

[C++] public InvalidWindowHandleException(int,string*);

[C++/CLI] public InvalidWindowHandleException(int,String^);

Exception which allows passing in a message an inner exception when a passed in window handle is not valid.

[Visual Basic] Public Sub New(String,Exception)

[C#] public InvalidWindowHandleException(string,Exception);

[C++] public InvalidWindowHandleException(string*,Exception*);

[C++/CLI] public InvalidWindowHandleException(String^,Exception^);

See Also

InvalidWindowHandleException Class | InvalidWindowHandleException Members


InvalidWindowHandleException Constructor()

InvalidWindowHandleException Class | InvalidWindowHandleException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidWindowHandleException Constructor()

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidWindowHandleException Class > InvalidWindowHandleException Constructor : InvalidWindowHandleException Constructor()

Main constructor for the InvalidWindowHandleException class.

[Visual Basic]
Public Function New()
[C#]
public InvalidWindowHandleException();
[C++]
public: InvalidWindowHandleException();
[C++/CLI]
public:
InvalidWindowHandleException();

See Also

InvalidWindowHandleException Class | InvalidWindowHandleException Members | Overload List


InvalidWindowHandleException Constructor(Int32)

InvalidWindowHandleException Class | InvalidWindowHandleException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidWindowHandleException Constructor(Int32)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidWindowHandleException Class > InvalidWindowHandleException Constructor : InvalidWindowHandleException Constructor(Int32)

Exception which allows passing in an error number when a passed in window handle is not valid.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public InvalidWindowHandleException(
   int errorNumber
);
[C++]
public: InvalidWindowHandleException(
   int errorNumber
)
[C++/CLI]
public:
InvalidWindowHandleException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

InvalidWindowHandleException Class | InvalidWindowHandleException Members | Overload List


InvalidWindowHandleException Constructor(Int32,String)

InvalidWindowHandleException Class | InvalidWindowHandleException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidWindowHandleException Constructor(Int32,String)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidWindowHandleException Class > InvalidWindowHandleException Constructor : InvalidWindowHandleException Constructor(Int32,String)

Exception which allows passing in an error number and message when a passed in window handle is not valid.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public InvalidWindowHandleException(
   int errorNumber,
   string message
);
[C++]
public: InvalidWindowHandleException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
InvalidWindowHandleException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

InvalidWindowHandleException Class | InvalidWindowHandleException Members | Overload List


InvalidWindowHandleException Constructor(String)

InvalidWindowHandleException Class | InvalidWindowHandleException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidWindowHandleException Constructor(String)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidWindowHandleException Class > InvalidWindowHandleException Constructor : InvalidWindowHandleException Constructor(String)

Exception which allows passing in a message when a passed in window handle is not valid.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public InvalidWindowHandleException(
   string message
);
[C++]
public: InvalidWindowHandleException(
   string* message
)
[C++/CLI]
public:
InvalidWindowHandleException(
   String^ message
)

Parameters

message
A string which represents the message.

See Also

InvalidWindowHandleException Class | InvalidWindowHandleException Members | Overload List


InvalidWindowHandleException Constructor(String,Exception)

InvalidWindowHandleException Class | InvalidWindowHandleException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidWindowHandleException Constructor(String,Exception)

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidWindowHandleException Class > InvalidWindowHandleException Constructor : InvalidWindowHandleException Constructor(String,Exception)

Exception which allows passing in a message an inner exception when a passed in window handle is not valid.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public InvalidWindowHandleException(
   string message,
   Exception innerException
);
[C++]
public: InvalidWindowHandleException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
InvalidWindowHandleException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception.

See Also

InvalidWindowHandleException Class | InvalidWindowHandleException Members | Overload List


ItemChangedEventArgs Class

ItemChangedEventArgs Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ItemChangedEventArgs Class

PegasusImaging.WinForms.NotateXpress9 Namespace : ItemChangedEventArgs Class

Arguments for ItemChanged event

For a list of all members of this type, see ItemChangedEventArgs members.

Object Model

Inheritance Hierarchy

System.Object
System.EventArgs
PegasusImaging.WinForms.NotateXpress9.ItemChangedEventArgs

Syntax

[Visual Basic]
Public Class ItemChangedEventArgs
   Inherits EventArgs
[C#]
public class ItemChangedEventArgs : EventArgs
[C++]
public __gc class ItemChangedEventArgs : public EventArgs
[C++/CLI]
public ref class ItemChangedEventArgs : public EventArgs

See Also

ItemChangedEventArgs Members | PegasusImaging.WinForms.NotateXpress9 Namespace


ItemChangedEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ItemChangedEventArgs Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : ItemChangedEventArgs Class

ItemChangedEventArgs overview

Public Constructors

Public Constructor ItemChangedEventArgs Constructor

Public Properties

Public Property Attribute | Gets the NotateTrait enumeration value of the attribute that changed.
Public Property Element | Gets the Element that changed.
Public Property Layer | Gets the layer on which the element that changed resides.

See Also

ItemChangedEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace


ItemChangedEventArgs Constructor

ItemChangedEventArgs Class | ItemChangedEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ItemChangedEventArgs Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > ItemChangedEventArgs Class : ItemChangedEventArgs Constructor (ItemChangedEventArgs)
[Visual Basic]
Public Function New()
[C#]
public ItemChangedEventArgs();
[C++]
public: ItemChangedEventArgs();
[C++/CLI]
public:
ItemChangedEventArgs();

See Also

ItemChangedEventArgs Class | ItemChangedEventArgs Members


ItemChangedEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ItemChangedEventArgs Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : ItemChangedEventArgs Class

For a list of all members of this type, see ItemChangedEventArgs members.

Public Properties

Public Property Attribute | Gets the NotateTrait enumeration value of the attribute that changed.
Public Property Element | Gets the Element that changed.
Public Property Layer | Gets the layer on which the element that changed resides.

See Also

ItemChangedEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Attribute Property

ItemChangedEventArgs Class | ItemChangedEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Attribute Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ItemChangedEventArgs Class : Attribute Property

Gets the NotateTrait enumeration value of the attribute that changed.

[Visual Basic]
Public Property Attribute As NotateTrait
[C#]
public NotateTrait Attribute {get; set;}
[C++]
public: __property NotateTrait get_Attribute();
public: __property void set_Attribute(
   NotateTrait value
);
[C++/CLI]
public:
property NotateTrait Attribute {
   NotateTrait get();
   void set (NotateTrait value);
}

Remarks

The NotateTrait.

See Also

ItemChangedEventArgs Class | ItemChangedEventArgs Members


Element Property

ItemChangedEventArgs Class | ItemChangedEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Element Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ItemChangedEventArgs Class : Element Property (ItemChangedEventArgs)

Gets the Element that changed.

[Visual Basic]
Public Property Element As Element
[C#]
public Element Element {get; set;}
[C++]
public: __property Element* get_Element();
public: __property void set_Element(
   Element* value
);
[C++/CLI]
public:
property Element^ Element {
   Element^ get();
   void set (Element^ value);
}

Remarks

The Element.

See Also

ItemChangedEventArgs Class | ItemChangedEventArgs Members


Layer Property

ItemChangedEventArgs Class | ItemChangedEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Layer Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ItemChangedEventArgs Class : Layer Property (ItemChangedEventArgs)

Gets the layer on which the element that changed resides.

[Visual Basic]
Public Property Layer As Layer
[C#]
public Layer Layer {get; set;}
[C++]
public: __property Layer* get_Layer();
public: __property void set_Layer(
   Layer* value
);
[C++/CLI]
public:
property Layer^ Layer {
   Layer^ get();
   void set (Layer^ value);
}

Remarks

The Layer.

See Also

ItemChangedEventArgs Class | ItemChangedEventArgs Members


ItemNotFoundException Class

ItemNotFoundException Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ItemNotFoundException Class

PegasusImaging.WinForms.NotateXpress9 Namespace : ItemNotFoundException Class

Exception class which is raised when there are errors with elements not found.

For a list of all members of this type, see ItemNotFoundException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.NotateXpress9.NotateXpressException
PegasusImaging.WinForms.NotateXpress9.ItemNotFoundException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class ItemNotFoundException
   Inherits NotateXpressException
   Implements ISerializable, _Exception
[C#]
[SerializableAttribute()]
public sealed class ItemNotFoundException : NotateXpressException, ISerializable, _Exception
[C++]
[SerializableAttribute()]
public __gc __sealed class ItemNotFoundException : public NotateXpressException, ISerializable, _Exception
[C++/CLI]
[SerializableAttribute()]
public ref class ItemNotFoundException sealed : public NotateXpressException, ISerializable, _Exception

See Also

ItemNotFoundException Members | PegasusImaging.WinForms.NotateXpress9 Namespace


ItemNotFoundException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ItemNotFoundException Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : ItemNotFoundException Class

ItemNotFoundException overview

Public Constructors

Public Constructor ItemNotFoundException Constructor Overloaded. Main constructor for the ItemNotFoundException class when there are errors with elements not found.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

ItemNotFoundException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


ItemNotFoundException Constructor

ItemNotFoundException Class | ItemNotFoundException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ItemNotFoundException Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > ItemNotFoundException Class : ItemNotFoundException Constructor (ItemNotFoundException)

Main constructor for the ItemNotFoundException class when there are errors with elements not found.

Overload List

Main constructor for the ItemNotFoundException class when there are errors with elements not found.

[Visual Basic] Public Sub New()

[C#] public ItemNotFoundException();

[C++] public ItemNotFoundException();

[C++/CLI] public ItemNotFoundException();

Exception which allows passing in an error number when there are errors with elements not found.

[Visual Basic] Public Sub New(Integer)

[C#] public ItemNotFoundException(int);

[C++] public ItemNotFoundException(int);

[C++/CLI] public ItemNotFoundException(int);

Exception which allows passing in a message when there are errors with elements not found.

[Visual Basic] Public Sub New(String)

[C#] public ItemNotFoundException(string);

[C++] public ItemNotFoundException(string*);

[C++/CLI] public ItemNotFoundException(String^);

Exception which allows passing in an error number and message when there are errors with elements not found.

[Visual Basic] Public Sub New(Integer,String)

[C#] public ItemNotFoundException(int,string);

[C++] public ItemNotFoundException(int,string*);

[C++/CLI] public ItemNotFoundException(int,String^);

Exception which allows passing in a message and inner exception when there are errors with elements not found.

[Visual Basic] Public Sub New(String,Exception)

[C#] public ItemNotFoundException(string,Exception);

[C++] public ItemNotFoundException(string*,Exception*);

[C++/CLI] public ItemNotFoundException(String^,Exception^);

See Also

ItemNotFoundException Class | ItemNotFoundException Members


ItemNotFoundException Constructor()

ItemNotFoundException Class | ItemNotFoundException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ItemNotFoundException Constructor()

PegasusImaging.WinForms.NotateXpress9 Namespace > ItemNotFoundException Class > ItemNotFoundException Constructor : ItemNotFoundException Constructor()

Main constructor for the ItemNotFoundException class when there are errors with elements not found.

[Visual Basic]
Public Function New()
[C#]
public ItemNotFoundException();
[C++]
public: ItemNotFoundException();
[C++/CLI]
public:
ItemNotFoundException();

See Also

ItemNotFoundException Class | ItemNotFoundException Members | Overload List


ItemNotFoundException Constructor(Int32)

ItemNotFoundException Class | ItemNotFoundException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ItemNotFoundException Constructor(Int32)

PegasusImaging.WinForms.NotateXpress9 Namespace > ItemNotFoundException Class > ItemNotFoundException Constructor : ItemNotFoundException Constructor(Int32)

Exception which allows passing in an error number when there are errors with elements not found.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public ItemNotFoundException(
   int errorNumber
);
[C++]
public: ItemNotFoundException(
   int errorNumber
)
[C++/CLI]
public:
ItemNotFoundException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

ItemNotFoundException Class | ItemNotFoundException Members | Overload List


ItemNotFoundException Constructor(Int32,String)

ItemNotFoundException Class | ItemNotFoundException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ItemNotFoundException Constructor(Int32,String)

PegasusImaging.WinForms.NotateXpress9 Namespace > ItemNotFoundException Class > ItemNotFoundException Constructor : ItemNotFoundException Constructor(Int32,String)

Exception which allows passing in an error number and message when there are errors with elements not found.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public ItemNotFoundException(
   int errorNumber,
   string message
);
[C++]
public: ItemNotFoundException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
ItemNotFoundException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

ItemNotFoundException Class | ItemNotFoundException Members | Overload List


ItemNotFoundException Constructor(String)

ItemNotFoundException Class | ItemNotFoundException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ItemNotFoundException Constructor(String)

PegasusImaging.WinForms.NotateXpress9 Namespace > ItemNotFoundException Class > ItemNotFoundException Constructor : ItemNotFoundException Constructor(String)

Exception which allows passing in a message when there are errors with elements not found.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public ItemNotFoundException(
   string message
);
[C++]
public: ItemNotFoundException(
   string* message
)
[C++/CLI]
public:
ItemNotFoundException(
   String^ message
)

Parameters

message
A string which represents the message.

See Also

ItemNotFoundException Class | ItemNotFoundException Members | Overload List


ItemNotFoundException Constructor(String,Exception)

ItemNotFoundException Class | ItemNotFoundException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ItemNotFoundException Constructor(String,Exception)

PegasusImaging.WinForms.NotateXpress9 Namespace > ItemNotFoundException Class > ItemNotFoundException Constructor : ItemNotFoundException Constructor(String,Exception)

Exception which allows passing in a message and inner exception when there are errors with elements not found.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public ItemNotFoundException(
   string message,
   Exception innerException
);
[C++]
public: ItemNotFoundException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
ItemNotFoundException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception.

See Also

ItemNotFoundException Class | ItemNotFoundException Members | Overload List


Layer Class

Layer Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Layer Class

PegasusImaging.WinForms.NotateXpress9 Namespace : Layer Class (PegasusImaging.WinForms.NotateXpress9)

The Layer class contains attributes for elements, groups and toolbars.

For a list of all members of this type, see Layer members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.NotateXpress9.Layer

Syntax

[Visual Basic]
Public Class Layer
   Implements IDisposable
[C#]
public class Layer : IDisposable
[C++]
public __gc class Layer : public IDisposable
[C++/CLI]
public ref class Layer : public IDisposable

See Also

Layer Members | PegasusImaging.WinForms.NotateXpress9 Namespace


Layer Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Layer Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : Layer Class (PegasusImaging.WinForms.NotateXpress9)

Layer overview

Public Constructors

Public Constructor Layer Constructor The default constructor for the Layer class.

Public Properties

Public Property Active | Gets and sets the user interactive state of the current layer.
Public Property Description | Gets and sets the description text for the current layer.
Public Property Elements | Gets the ElementCollection for this layer.
Public Property Groups | Gets the GroupCollection for this layer.
Public Property Name | Gets and sets the name text for the current layer.
Public Property Password | Gets or sets the password.
Public Property Toolbar | Gets and sets the Toolbar based on which layer is selected.
Public Property Visible | Gets and sets whether the layer is visible.

Public Methods

Public Method Copy | Copies the layer to the clipboard.
Public Method Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public Method Select | Make the selected layer the current active layer.
Public Method UserDataAdd | Adds a new key value pair to the layer.
Public Method UserDataDelete | Removes the given key value pair on the layer.
Public Method UserDataFind | User data can be added to each layer in a key value pair. This will return the value of an existing key.
Public Method UserDataFindFirst | User data can be added to each layer in a key value pair. This will find the first key value pair.
Public Method UserDataFindNext | User data can be added to each layer in a key value pair. This will next key value pair, in the list.

See Also

Layer Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Layer Constructor

Layer Class | Layer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Layer Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > Layer Class : Layer Constructor (Layer)

The default constructor for the Layer class.

[Visual Basic]
Public Function New()
[C#]
public Layer();
[C++]
public: Layer();
[C++/CLI]
public:
Layer();

See Also

Layer Class | Layer Members


Copy Method

Layer Class | Layer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Copy Method

PegasusImaging.WinForms.NotateXpress9 Namespace > Layer Class : Copy Method (Layer)

Copies the layer to the clipboard.

[Visual Basic]
Public Sub Copy()
[C#]
public void Copy();
[C++]
public: void Copy();
[C++/CLI]
public:
void Copy();

See Also

Layer Class | Layer Members


Dispose Method

Layer Class | Layer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Dispose Method

PegasusImaging.WinForms.NotateXpress9 Namespace > Layer Class : Dispose Method (Layer)

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();
[C++]
public: void Dispose();
[C++/CLI]
public:
void Dispose();

See Also

Layer Class | Layer Members


Select Method

Layer Class | Layer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Select Method

PegasusImaging.WinForms.NotateXpress9 Namespace > Layer Class : Select Method

Make the selected layer the current active layer.

[Visual Basic]
Public Sub Select()
[C#]
public void Select();
[C++]
public: void Select();
[C++/CLI]
public:
void Select();

See Also

Layer Class | Layer Members


UserDataAdd Method

Layer Class | Layer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

key
A string value which represents the new key.
newVal
A string which represents the new key value for the layer.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

UserDataAdd Method

PegasusImaging.WinForms.NotateXpress9 Namespace > Layer Class : UserDataAdd Method (Layer)

Adds a new key value pair to the layer.

[Visual Basic]
Public Sub UserDataAdd( _
   ByVal key As String, _
   ByVal newVal As String _
)
[C#]
public void UserDataAdd(
   string key,
   string newVal
);
[C++]
public: void UserDataAdd(
   string* key,
   string* newVal
)
[C++/CLI]
public:
void UserDataAdd(
   String^ key,
   String^ newVal
)

Parameters

key
A string value which represents the new key.
newVal
A string which represents the new key value for the layer.

See Also

Layer Class | Layer Members


UserDataDelete Method

Layer Class | Layer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

key
A string value which represents the existing key to remove.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

UserDataDelete Method

PegasusImaging.WinForms.NotateXpress9 Namespace > Layer Class : UserDataDelete Method (Layer)

Removes the given key value pair on the layer.

[Visual Basic]
Public Sub UserDataDelete( _
   ByVal key As String _
)
[C#]
public void UserDataDelete(
   string key
);
[C++]
public: void UserDataDelete(
   string* key
)
[C++/CLI]
public:
void UserDataDelete(
   String^ key
)

Parameters

key
A string value which represents the existing key to remove.

See Also

Layer Class | Layer Members


UserDataFind Method

Layer Class | Layer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

key
The user data key to search for.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

UserDataFind Method

PegasusImaging.WinForms.NotateXpress9 Namespace > Layer Class : UserDataFind Method (Layer)

User data can be added to each layer in a key value pair. This will return the value of an existing key.

[Visual Basic]
Public Function UserDataFind( _
   ByVal key As String _
) As String
[C#]
public string UserDataFind(
   string key
);
[C++]
public: string* UserDataFind(
   string* key
)
[C++/CLI]
public:
String^ UserDataFind(
   String^ key
)

Parameters

key
The user data key to search for.

Return Type

The user data from the matching key.

See Also

Layer Class | Layer Members


UserDataFindFirst Method

Layer Class | Layer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

key
A string value which represents the first key.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

UserDataFindFirst Method

PegasusImaging.WinForms.NotateXpress9 Namespace > Layer Class : UserDataFindFirst Method (Layer)

User data can be added to each layer in a key value pair. This will find the first key value pair.

[Visual Basic]
Public Function UserDataFindFirst( _
   ByRef key As String _
) As String
[C#]
public string UserDataFindFirst(
   out string key
);
[C++]
public: string* UserDataFindFirst(
   [PARAMFLAG::Out] string* key
)
[C++/CLI]
public:
String^ UserDataFindFirst(
   [Out] String^ key
)

Parameters

key
A string value which represents the first key.

Return Type

The first value from the matching key.

See Also

Layer Class | Layer Members


UserDataFindNext Method

Layer Class | Layer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

key
A string value which represents the next key.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

UserDataFindNext Method

PegasusImaging.WinForms.NotateXpress9 Namespace > Layer Class : UserDataFindNext Method (Layer)

User data can be added to each layer in a key value pair. This will next key value pair, in the list.

[Visual Basic]
Public Function UserDataFindNext( _
   ByRef key As String _
) As String
[C#]
public string UserDataFindNext(
   out string key
);
[C++]
public: string* UserDataFindNext(
   [PARAMFLAG::Out] string* key
)
[C++/CLI]
public:
String^ UserDataFindNext(
   [Out] String^ key
)

Parameters

key
A string value which represents the next key.

Return Type

The next value from the matching key.

See Also

Layer Class | Layer Members


Layer Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Layer Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : Layer Class (PegasusImaging.WinForms.NotateXpress9)

For a list of all members of this type, see Layer members.

Public Properties

Public Property Active | Gets and sets the user interactive state of the current layer.
Public Property Description | Gets and sets the description text for the current layer.
Public Property Elements | Gets the ElementCollection for this layer.
Public Property Groups | Gets the GroupCollection for this layer.
Public Property Name | Gets and sets the name text for the current layer.
Public Property Password | Gets or sets the password.
Public Property Toolbar | Gets and sets the Toolbar based on which layer is selected.
Public Property Visible | Gets and sets whether the layer is visible.

See Also

Layer Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Active Property

Layer Class | Layer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Active Property

PegasusImaging.WinForms.NotateXpress9 Namespace > Layer Class : Active Property

Gets and sets the user interactive state of the current layer.

[Visual Basic]
Public Property Active As Boolean
[C#]
public bool Active {get; set;}
[C++]
public: __property bool get_Active();
public: __property void set_Active(
   bool value
);
[C++/CLI]
public:
property bool Active {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true if the current layer is active. Otherwise, false is returned.

Remarks

The default value is true.

When a layer is the current layer and its Active property is set to true, the annotation tools are enabled. Setting a layer's Active property to false disables all annotation tools. If you want to display an annotation file and not allow editing, set the Active property to false for all layers. You can allow editing on selective layers by setting a layer's Active property to true.

See Also

Layer Class | Layer Members


Description Property

Layer Class | Layer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Description Property

PegasusImaging.WinForms.NotateXpress9 Namespace > Layer Class : Description Property

Gets and sets the description text for the current layer.

[Visual Basic]
Public Property Description As String
[C#]
public string Description {get; set;}
[C++]
public: __property string* get_Description();
public: __property void set_Description(
   string* value
);
[C++/CLI]
public:
property String^ Description {
   String^ get();
   void set (String^ value);
}

Value

A string value which represents the description of a layer.

Remarks

The default value is an empty string "".

The description is a convenient way to store a brief description of a layer.

See Also

Layer Class | Layer Members


Elements Property

Layer Class | Layer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Elements Property

PegasusImaging.WinForms.NotateXpress9 Namespace > Layer Class : Elements Property

Gets the ElementCollection for this layer.

[Visual Basic]
Public ReadOnly Property Elements As ElementCollection
[C#]
public ElementCollection Elements {get;}
[C++]
public: __property ElementCollection* get_Elements();
[C++/CLI]
public:
property ElementCollection^ Elements {
   ElementCollection^ get();
}

Value

The ElementCollection value set.

See Also

Layer Class | Layer Members


Groups Property

Layer Class | Layer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Groups Property

PegasusImaging.WinForms.NotateXpress9 Namespace > Layer Class : Groups Property

Gets the GroupCollection for this layer.

[Visual Basic]
Public ReadOnly Property Groups As GroupCollection
[C#]
public GroupCollection Groups {get;}
[C++]
public: __property GroupCollection* get_Groups();
[C++/CLI]
public:
property GroupCollection^ Groups {
   GroupCollection^ get();
}

Value

The GroupCollection value set for the layer.

See Also

Layer Class | Layer Members


Name Property

Layer Class | Layer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Name Property

PegasusImaging.WinForms.NotateXpress9 Namespace > Layer Class : Name Property (Layer)

Gets and sets the name text for the current layer.

[Visual Basic]
Public Property Name As String
[C#]
public string Name {get; set;}
[C++]
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
[C++/CLI]
public:
property String^ Name {
   String^ get();
   void set (String^ value);
}

Value

A string value which represents the description of a layer.

Remarks

The default value is an empty string "".

The description is a convenient way to store a name of the layer.

See Also

Layer Class | Layer Members


Password Property

Layer Class | Layer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Password Property

PegasusImaging.WinForms.NotateXpress9 Namespace > Layer Class : Password Property

Gets or sets the password.

[Visual Basic]
Public Property Password As String
[C#]
public string Password {get; set;}
[C++]
public: __property string* get_Password();
public: __property void set_Password(
   string* value
);
[C++/CLI]
public:
property String^ Password {
   String^ get();
   void set (String^ value);
}

Value

A string value which represents the password.

Remarks

The password will be automatically encoded for nxp and nxxml files.

When reading in a nxp or nxxml file, a NotateXpress.RequestLayerPassword event will be fired.

See Also

Layer Class | Layer Members


Toolbar Property

Layer Class | Layer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Toolbar Property

PegasusImaging.WinForms.NotateXpress9 Namespace > Layer Class : Toolbar Property (Layer)

Gets and sets the Toolbar based on which layer is selected.

[Visual Basic]
Public Property Toolbar As Toolbar
[C#]
public Toolbar Toolbar {get; set;}
[C++]
public: __property Toolbar* get_Toolbar();
public: __property void set_Toolbar(
   Toolbar* value
);
[C++/CLI]
public:
property Toolbar^ Toolbar {
   Toolbar^ get();
   void set (Toolbar^ value);
}

Value

The Toolbar value for the layer.

See Also

Layer Class | Layer Members


Visible Property

Layer Class | Layer Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Visible Property

PegasusImaging.WinForms.NotateXpress9 Namespace > Layer Class : Visible Property (Layer)

Gets and sets whether the layer is visible.

[Visual Basic]
Public Property Visible As Boolean
[C#]
public bool Visible {get; set;}
[C++]
public: __property bool get_Visible();
public: __property void set_Visible(
   bool value
);
[C++/CLI]
public:
property bool Visible {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true if the current layer is visible. Otherwise, false is returned.

Remarks

The default value is true.

See Also

Layer Class | Layer Members


LayerCollection Class

LayerCollection Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

LayerCollection Class

PegasusImaging.WinForms.NotateXpress9 Namespace : LayerCollection Class

The LayerCollection class manages layers.

For a list of all members of this type, see LayerCollection members.

Object Model

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
PegasusImaging.WinForms.NotateXpress9.LayerCollection

Syntax

[Visual Basic]
<DefaultMemberAttribute("Item")>
Public Class LayerCollection
   Inherits CollectionBase
   Implements IList, ICollection, IEnumerable, IDisposable
[C#]
[DefaultMemberAttribute("Item")]
public class LayerCollection : CollectionBase, IList, ICollection, IEnumerable, IDisposable
[C++]
[DefaultMemberAttribute("Item")]
public __gc class LayerCollection : public CollectionBase, IList, ICollection, IEnumerable, IDisposable
[C++/CLI]
[DefaultMemberAttribute("Item")]
public ref class LayerCollection : public CollectionBase, IList, ICollection, IEnumerable, IDisposable

See Also

LayerCollection Members | PegasusImaging.WinForms.NotateXpress9 Namespace


LayerCollection Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

LayerCollection Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : LayerCollection Class

LayerCollection overview

Public Properties

Public Property Author | Gets and sets a string value representing the author that can be saved with your annotation file.
Public Property Capacity (Inherited from System.Collections.CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Public Property Comments | Gets and sets a string value that can be saved with your annotation file.
Public Property Count (Inherited from System.Collections.CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
Public Property IsPasteAvailable | Gets a boolean value which indicates whether there is a layer available on the clipboard.
Public Property Item | Gets or sets the Layer at the specified index.
Public Property Subject | Gets and sets a string value representing the subject that can be saved with your annotation file.
Public Property Title | Gets and sets a title string value that can be saved with your annotation file.

Public Methods

Public Method Add | Adds the given Layer to the layer collection.
Public Method Brand | Brands or permanently draws the currently visible annotations directly into the client image according to the given bits per pixel.
Public Method Clear | Clears the entire collection as well as calls the clear method of the base class.
Public Method Contains | Searches for and returns a value which determines if the collection contains the given Layer in the layer collection.
Public Method CopyTo | Copies the entire collection to an array, starting at the given index of the specified target array.
Public Method Dispose | Releases all resources used by this LayerCollection object.
Public Method FromByteArray | Loads annotations from the given byte array based on instructions passed by the load options.
Public Method FromFile | Allows loading of a specific page contained within the given file.
Public Method FromMemoryStream | Loads an image from the given stream, based on the provided LoadOptions.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) | Returns an enumerator that iterates through the CollectionBase instance.
Public Method IndexOf | Searches for the specified layer and returns the zero-based index of the first occurrence within the layer collection.
Public Method Insert | Inserts the given Layer at the specified index.
Public Method Paste | Pastes the layer that is on the clipboard.
Public Method Remove | Removes the given Layer from the layer collection.
Public Method RemoveAt | Removes the matching layer to the given index within the layer collection.
Public Method SaveToByteArray | Saves the given annotations to a byte array.
Public Method SaveToFile | Saves the given annotations to the given file name.
Public Method SaveToMemoryStream | Saves the given annotations to a memory stream.
Public Method Selected | Gets the currently selected layer within the layer collection.
Public Method SetLoadOptions | Sets the options to use when loading annotations.
Public Method SetSaveOptions | Sets the options to use when saving annotations.

See Also

LayerCollection Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Add Method

LayerCollection Class | LayerCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

layer
A Layer to add to the layer collection.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Add Method

PegasusImaging.WinForms.NotateXpress9 Namespace > LayerCollection Class : Add Method (LayerCollection)

Adds the given Layer to the layer collection.

[Visual Basic]
Public Function Add( _
   ByVal layer As Layer _
) As Integer
[C#]
public int Add(
   Layer layer
);
[C++]
public: int Add(
   Layer* layer
)
[C++/CLI]
public:
int Add(
   Layer^ layer
)

Parameters

layer
A Layer to add to the layer collection.

Return Type

An integer that represents the index position of the newly added layer.

See Also

LayerCollection Class | LayerCollection Members


Brand Method

LayerCollection Class | LayerCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

bitsPerPixel
An integer which represents the bits per pixel for the resulting image. For example, if you set this number to 24, the resulting image created in the ImagXpress control is a 24-bit image. The other valid values are 1, 4, and 8.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Brand Method

PegasusImaging.WinForms.NotateXpress9 Namespace > LayerCollection Class : Brand Method

Brands or permanently draws the currently visible annotations directly into the client image according to the given bits per pixel.

[Visual Basic]
Public Sub Brand( _
   ByVal bitsPerPixel As Integer _
)
[C#]
public void Brand(
   int bitsPerPixel
);
[C++]
public: void Brand(
   int bitsPerPixel
)
[C++/CLI]
public:
void Brand(
   int bitsPerPixel
)

Parameters

bitsPerPixel
An integer which represents the bits per pixel for the resulting image. For example, if you set this number to 24, the resulting image created in the ImagXpress control is a 24-bit image. The other valid values are 1, 4, and 8.

See Also

LayerCollection Class | LayerCollection Members


Clear Method

LayerCollection Class | LayerCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Clear Method

PegasusImaging.WinForms.NotateXpress9 Namespace > LayerCollection Class : Clear Method (LayerCollection)

Clears the entire collection as well as calls the clear method of the base class.

[Visual Basic]
Public Sub Clear()
[C#]
public void Clear();
[C++]
public: void Clear();
[C++/CLI]
public:
void Clear();

See Also

LayerCollection Class | LayerCollection Members


Contains Method

LayerCollection Class | LayerCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

layer
The Layer to locate in the collection.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Contains Method

PegasusImaging.WinForms.NotateXpress9 Namespace > LayerCollection Class : Contains Method (LayerCollection)

Searches for and returns a value which determines if the collection contains the given Layer in the layer collection.

[Visual Basic]
Public Function Contains( _
   ByVal layer As Layer _
) As Boolean
[C#]
public bool Contains(
   Layer layer
);
[C++]
public: bool Contains(
   Layer* layer
)
[C++/CLI]
public:
bool Contains(
   Layer^ layer
)

Parameters

layer
The Layer to locate in the collection.

Return Type

true if the collection contains the specified Layer; otherwise, false. Implements

See Also

LayerCollection Class | LayerCollection Members


CopyTo Method

LayerCollection Class | LayerCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

array
The one-dimensional Array that is the destination of the elements copied from DocumentCollection. The Array must have zero-based indexing.
index
The zero-based index in array at which copying begins.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

CopyTo Method

PegasusImaging.WinForms.NotateXpress9 Namespace > LayerCollection Class : CopyTo Method (LayerCollection)

Copies the entire collection to an array, starting at the given index of the specified target array.

[Visual Basic]
Public Sub CopyTo( _
   ByVal array() As Layer, _
   ByVal index As Integer _
)
[C#]
public void CopyTo(
   Layer[] array,
   int index
);
[C++]
public: void CopyTo(
   Layer*[]* array,
   int index
)
[C++/CLI]
public:
void CopyTo(
   Layer^array<array>^ array,
   int index
)

Parameters

array
The one-dimensional Array that is the destination of the elements copied from DocumentCollection. The Array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

Remarks

This method copies all the layers in the layer collection to the given array starting at the given index.

See Also

LayerCollection Class | LayerCollection Members


Dispose Method

LayerCollection Class | LayerCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Dispose Method

PegasusImaging.WinForms.NotateXpress9 Namespace > LayerCollection Class : Dispose Method (LayerCollection)

Releases all resources used by this LayerCollection object.

[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();
[C++]
public: void Dispose();
[C++/CLI]
public:
void Dispose();

See Also

LayerCollection Class | LayerCollection Members


FromByteArray Method

LayerCollection Class | LayerCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

bytearray
A byte array which contains the annotations to load.
loadOptions
The LoadOptions which contain the instructions on how to load the annotations from the byte array.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

FromByteArray Method

PegasusImaging.WinForms.NotateXpress9 Namespace > LayerCollection Class : FromByteArray Method

Loads annotations from the given byte array based on instructions passed by the load options.

[Visual Basic]
Public Function FromByteArray( _
   ByVal bytearray() As Byte, _
   ByVal loadOptions As LoadOptions _
) As Layer
[C#]
public Layer FromByteArray(
   byte[] bytearray,
   LoadOptions loadOptions
);
[C++]
public: Layer* FromByteArray(
   byte[]* bytearray,
   LoadOptions* loadOptions
)
[C++/CLI]
public:
Layer^ FromByteArray(
   bytearray<bytearray>^ bytearray,
   LoadOptions^ loadOptions
)

Parameters

bytearray
A byte array which contains the annotations to load.
loadOptions
The LoadOptions which contain the instructions on how to load the annotations from the byte array.

Return Type

The Layer that evaluates to the loaded image.

Remarks

This method loads an image from the given byte array, based on the provided LoadOptions and returns the Layer that matches the loaded image.

See Also

LayerCollection Class | LayerCollection Members


FromFile Method

LayerCollection Class | LayerCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

filename
A string which represents the windows file path.
loadOptions
The LoadOptions values set.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

FromFile Method

PegasusImaging.WinForms.NotateXpress9 Namespace > LayerCollection Class : FromFile Method

Allows loading of a specific page contained within the given file.

[Visual Basic]
Public Sub FromFile( _
   ByVal filename As String, _
   ByVal loadOptions As LoadOptions _
)
[C#]
public void FromFile(
   string filename,
   LoadOptions loadOptions
);
[C++]
public: void FromFile(
   string* filename,
   LoadOptions* loadOptions
)
[C++/CLI]
public:
void FromFile(
   String^ filename,
   LoadOptions^ loadOptions
)

Parameters

filename
A string which represents the windows file path.
loadOptions
The LoadOptions values set.

Remarks

This method loads a specific page by the given filename and LoadOptions.

See Also

LayerCollection Class | LayerCollection Members


FromMemoryStream Method

LayerCollection Class | LayerCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

stream
A MemoryStream to get the image from.
loadOptions
The LoadOptions values set.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

FromMemoryStream Method

PegasusImaging.WinForms.NotateXpress9 Namespace > LayerCollection Class : FromMemoryStream Method

Loads an image from the given stream, based on the provided LoadOptions.

[Visual Basic]
Public Function FromMemoryStream( _
   ByVal stream As MemoryStream, _
   ByVal loadOptions As LoadOptions _
) As Layer
[C#]
public Layer FromMemoryStream(
   MemoryStream stream,
   LoadOptions loadOptions
);
[C++]
public: Layer* FromMemoryStream(
   MemoryStream* stream,
   LoadOptions* loadOptions
)
[C++/CLI]
public:
Layer^ FromMemoryStream(
   MemoryStream^ stream,
   LoadOptions^ loadOptions
)

Parameters

stream
A MemoryStream to get the image from.
loadOptions
The LoadOptions values set.

Return Type

The Layer that evaluates to the loaded image.

Remarks

This method loads an image from the given MemoryStream, based on the provided LoadOptions and returns the Layer that matches the loaded image.

See Also

LayerCollection Class | LayerCollection Members


IndexOf Method

LayerCollection Class | LayerCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

value
Object to locate in the collection.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

IndexOf Method

PegasusImaging.WinForms.NotateXpress9 Namespace > LayerCollection Class : IndexOf Method (LayerCollection)

Searches for the specified layer and returns the zero-based index of the first occurrence within the layer collection.

[Visual Basic]
Public Function IndexOf( _
   ByVal value As Layer _
) As Integer
[C#]
public int IndexOf(
   Layer value
);
[C++]
public: int IndexOf(
   Layer* value
)
[C++/CLI]
public:
int IndexOf(
   Layer^ value
)

Parameters

value
Object to locate in the collection.

See Also

LayerCollection Class | LayerCollection Members


Insert Method

LayerCollection Class | LayerCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

index
The zero-based index at which the Layer should be inserted.
layer
The Layer to insert.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Insert Method

PegasusImaging.WinForms.NotateXpress9 Namespace > LayerCollection Class : Insert Method (LayerCollection)

Inserts the given Layer at the specified index.

[Visual Basic]
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal layer As Layer _
)
[C#]
public void Insert(
   int index,
   Layer layer
);
[C++]
public: void Insert(
   int index,
   Layer* layer
)
[C++/CLI]
public:
void Insert(
   int index,
   Layer^ layer
)

Parameters

index
The zero-based index at which the Layer should be inserted.
layer
The Layer to insert.

See Also

LayerCollection Class | LayerCollection Members


Paste Method

LayerCollection Class | LayerCollection Members | Copy Method

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Paste Method

PegasusImaging.WinForms.NotateXpress9 Namespace > LayerCollection Class : Paste Method (LayerCollection)

Pastes the layer that is on the clipboard.

[Visual Basic]
Public Function Paste() As Layer
[C#]
public Layer Paste();
[C++]
public: Layer* Paste();
[C++/CLI]
public:
Layer^ Paste();

Return Type

The Layer the annotations are pasted on.

Remarks

This method pastes annotation items which are currently available on the clipboard to the current layer. These annotations are generally available from previously calling the Layer.Copy method.

See Also

LayerCollection Class | LayerCollection Members | Copy Method


Remove Method

LayerCollection Class | LayerCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

layer
The Layer to remove from the layer collection.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Remove Method

PegasusImaging.WinForms.NotateXpress9 Namespace > LayerCollection Class : Remove Method (LayerCollection)

Removes the given Layer from the layer collection.

[Visual Basic]
Public Sub Remove( _
   ByVal layer As Layer _
)
[C#]
public void Remove(
   Layer layer
);
[C++]
public: void Remove(
   Layer* layer
)
[C++/CLI]
public:
void Remove(
   Layer^ layer
)

Parameters

layer
The Layer to remove from the layer collection.

See Also

LayerCollection Class | LayerCollection Members


RemoveAt Method

LayerCollection Class | LayerCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

index
An integer which represents the location of the layer to remove from the layer collection.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

RemoveAt Method

PegasusImaging.WinForms.NotateXpress9 Namespace > LayerCollection Class : RemoveAt Method (LayerCollection)

Removes the matching layer to the given index within the layer collection.

[Visual Basic]
Public Sub RemoveAt( _
   ByVal index As Integer _
)
[C#]
public void RemoveAt(
   int index
);
[C++]
public: void RemoveAt(
   int index
)
[C++/CLI]
public:
void RemoveAt(
   int index
)

Parameters

index
An integer which represents the location of the layer to remove from the layer collection.

See Also

LayerCollection Class | LayerCollection Members


SaveToByteArray Method

LayerCollection Class | LayerCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

saveOptions
The SaveOptions values set.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

SaveToByteArray Method

PegasusImaging.WinForms.NotateXpress9 Namespace > LayerCollection Class : SaveToByteArray Method

Saves the given annotations to a byte array.

[Visual Basic]
Public Function SaveToByteArray( _
   ByVal saveOptions As SaveOptions _
) As Byte()
[C#]
public byte[] SaveToByteArray(
   SaveOptions saveOptions
);
[C++]
public: byte[]* SaveToByteArray(
   SaveOptions* saveOptions
)
[C++/CLI]
public:
array<byte>^ SaveToByteArray(
   SaveOptions^ saveOptions
)

Parameters

saveOptions
The SaveOptions values set.

Return Type

The byte array with the given annotations.

Remarks

This method saves the given page of annotations into a byte array that is returned.

See Also

LayerCollection Class | LayerCollection Members


SaveToFile Method

LayerCollection Class | LayerCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

filename
A string value which represents the file to save to.
saveOptions
The SaveOptions set.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

SaveToFile Method

PegasusImaging.WinForms.NotateXpress9 Namespace > LayerCollection Class : SaveToFile Method

Saves the given annotations to the given file name.

[Visual Basic]
Public Sub SaveToFile( _
   ByVal filename As String, _
   ByVal saveOptions As SaveOptions _
)
[C#]
public void SaveToFile(
   string filename,
   SaveOptions saveOptions
);
[C++]
public: void SaveToFile(
   string* filename,
   SaveOptions* saveOptions
)
[C++/CLI]
public:
void SaveToFile(
   String^ filename,
   SaveOptions^ saveOptions
)

Parameters

filename
A string value which represents the file to save to.
saveOptions
The SaveOptions set.

Remarks

This method saves the given annotations to the specified filename.

See Also

LayerCollection Class | LayerCollection Members


SaveToMemoryStream Method

LayerCollection Class | LayerCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

saveOptions
The SaveOptions set.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

SaveToMemoryStream Method

PegasusImaging.WinForms.NotateXpress9 Namespace > LayerCollection Class : SaveToMemoryStream Method

Saves the given annotations to a memory stream.

[Visual Basic]
Public Function SaveToMemoryStream( _
   ByVal saveOptions As SaveOptions _
) As MemoryStream
[C#]
public MemoryStream SaveToMemoryStream(
   SaveOptions saveOptions
);
[C++]
public: MemoryStream* SaveToMemoryStream(
   SaveOptions* saveOptions
)
[C++/CLI]
public:
MemoryStream^ SaveToMemoryStream(
   SaveOptions^ saveOptions
)

Parameters

saveOptions
The SaveOptions set.

Return Type

This method saves the given page of annotations to a memory steam.

See Also

LayerCollection Class | LayerCollection Members


Selected Method

LayerCollection Class | LayerCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Selected Method

PegasusImaging.WinForms.NotateXpress9 Namespace > LayerCollection Class : Selected Method (LayerCollection)

Gets the currently selected layer within the layer collection.

[Visual Basic]
Public Function Selected() As Layer
[C#]
public Layer Selected();
[C++]
public: Layer* Selected();
[C++/CLI]
public:
Layer^ Selected();

Return Type

The Layer within the layer collection.

See Also

LayerCollection Class | LayerCollection Members


SetLoadOptions Method

LayerCollection Class | LayerCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

loadOptions
The LoadOptions set.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

SetLoadOptions Method

PegasusImaging.WinForms.NotateXpress9 Namespace > LayerCollection Class : SetLoadOptions Method

Sets the options to use when loading annotations.

[Visual Basic]
Public Sub SetLoadOptions( _
   ByVal loadOptions As LoadOptions _
)
[C#]
public void SetLoadOptions(
   LoadOptions loadOptions
);
[C++]
public: void SetLoadOptions(
   LoadOptions* loadOptions
)
[C++/CLI]
public:
void SetLoadOptions(
   LoadOptions^ loadOptions
)

Parameters

loadOptions
The LoadOptions set.

Remarks

This method loads options which are contained in the LoadOptions class.

See Also

LayerCollection Class | LayerCollection Members


SetSaveOptions Method

LayerCollection Class | LayerCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

saveOptions
The SaveOptions set.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

SetSaveOptions Method

PegasusImaging.WinForms.NotateXpress9 Namespace > LayerCollection Class : SetSaveOptions Method

Sets the options to use when saving annotations.

[Visual Basic]
Public Sub SetSaveOptions( _
   ByVal saveOptions As SaveOptions _
)
[C#]
public void SetSaveOptions(
   SaveOptions saveOptions
);
[C++]
public: void SetSaveOptions(
   SaveOptions* saveOptions
)
[C++/CLI]
public:
void SetSaveOptions(
   SaveOptions^ saveOptions
)

Parameters

saveOptions
The SaveOptions set.

Remarks

This method saves options which are contained in the SaveOptions class.

See Also

LayerCollection Class | LayerCollection Members


LayerCollection Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

LayerCollection Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : LayerCollection Class

For a list of all members of this type, see LayerCollection members.

Public Properties

Public Property Author | Gets and sets a string value representing the author that can be saved with your annotation file.
Public Property Capacity (Inherited from System.Collections.CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Public Property Comments | Gets and sets a string value that can be saved with your annotation file.
Public Property Count (Inherited from System.Collections.CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
Public Property IsPasteAvailable | Gets a boolean value which indicates whether there is a layer available on the clipboard.
Public Property Item | Gets or sets the Layer at the specified index.
Public Property Subject | Gets and sets a string value representing the subject that can be saved with your annotation file.
Public Property Title | Gets and sets a title string value that can be saved with your annotation file.

See Also

LayerCollection Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Author Property

LayerCollection Class | LayerCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Author Property

PegasusImaging.WinForms.NotateXpress9 Namespace > LayerCollection Class : Author Property

Gets and sets a string value representing the author that can be saved with your annotation file.

[Visual Basic]
Public Property Author As String
[C#]
public string Author {get; set;}
[C++]
public: __property string* get_Author();
public: __property void set_Author(
   string* value
);
[C++/CLI]
public:
property String^ Author {
   String^ get();
   void set (String^ value);
}

Value

A string value which represents the author for the annotation file.

Remarks

This author string is displayed in Windows Explorer when you right-click an annotation file, select 'Properties', and display the Summary page.

See Also

LayerCollection Class | LayerCollection Members


Comments Property

LayerCollection Class | LayerCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Comments Property

PegasusImaging.WinForms.NotateXpress9 Namespace > LayerCollection Class : Comments Property

Gets and sets a string value that can be saved with your annotation file.

[Visual Basic]
Public Property Comments As String
[C#]
public string Comments {get; set;}
[C++]
public: __property string* get_Comments();
public: __property void set_Comments(
   string* value
);
[C++/CLI]
public:
property String^ Comments {
   String^ get();
   void set (String^ value);
}

Value

A string which represents comments associated with your annotation file.

Remarks

This comments string is displayed in Windows Explorer when you right-click an annotation file, select 'Properties', and display the Summary page.

See Also

LayerCollection Class | LayerCollection Members


IsPasteAvailable Property

LayerCollection Class | LayerCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

IsPasteAvailable Property

PegasusImaging.WinForms.NotateXpress9 Namespace > LayerCollection Class : IsPasteAvailable Property (LayerCollection)

Gets a boolean value which indicates whether there is a layer available on the clipboard.

[Visual Basic]
Public ReadOnly Property IsPasteAvailable As Boolean
[C#]
public bool IsPasteAvailable {get;}
[C++]
public: __property bool get_IsPasteAvailable();
[C++/CLI]
public:
property bool IsPasteAvailable {
   bool get();
}

Value

A boolean value which is true when a layer is available on the clipboard. Otherwise, false is returned.

Remarks

Note: Normally, you would cut or copy the layer first.

See Also

LayerCollection Class | LayerCollection Members


Item Property

LayerCollection Class | LayerCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

index
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Item Property

PegasusImaging.WinForms.NotateXpress9 Namespace > LayerCollection Class : Item Property (LayerCollection)

Gets or sets the Layer at the specified index.

[Visual Basic]
Public Default Property Item( _
   ByVal index As Integer _
) As Layer
[C#]
public Layer this[
   int index
]; {get; set;}
[C++]
public: __property Layer* get_Item(
   int index
);
public: __property void set_Item(
   int index,
   Layer* value
);
[C++/CLI]
public:
 property Layer^ default [int] {
   Layer^ get(int index);
   void set (int index, Layer^ value);
}

Parameters

index

Value

An integer value which represents the layer index.

See Also

LayerCollection Class | LayerCollection Members


Subject Property

LayerCollection Class | LayerCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Subject Property

PegasusImaging.WinForms.NotateXpress9 Namespace > LayerCollection Class : Subject Property

Gets and sets a string value representing the subject that can be saved with your annotation file.

[Visual Basic]
Public Property Subject As String
[C#]
public string Subject {get; set;}
[C++]
public: __property string* get_Subject();
public: __property void set_Subject(
   string* value
);
[C++/CLI]
public:
property String^ Subject {
   String^ get();
   void set (String^ value);
}

Value

A string value which represents the subject for the annotation file.

Remarks

This subject string is displayed in Windows Explorer when you right-click an annotation file, select 'Properties', and display the Summary page.

See Also

LayerCollection Class | LayerCollection Members


Title Property

LayerCollection Class | LayerCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Title Property

PegasusImaging.WinForms.NotateXpress9 Namespace > LayerCollection Class : Title Property

Gets and sets a title string value that can be saved with your annotation file.

[Visual Basic]
Public Property Title As String
[C#]
public string Title {get; set;}
[C++]
public: __property string* get_Title();
public: __property void set_Title(
   string* value
);
[C++/CLI]
public:
property String^ Title {
   String^ get();
   void set (String^ value);
}

Value

A string value which represents the title for the annotation file.

Remarks

This title string is displayed in Windows Explorer when you right-click an annotation file, select 'Properties', and display the Summary page.

See Also

LayerCollection Class | LayerCollection Members


LayerRestoredEventArgs Class

LayerRestoredEventArgs Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

LayerRestoredEventArgs Class

PegasusImaging.WinForms.NotateXpress9 Namespace : LayerRestoredEventArgs Class

Arguments for LayerRestored event

For a list of all members of this type, see LayerRestoredEventArgs members.

Object Model

Inheritance Hierarchy

System.Object
System.EventArgs
PegasusImaging.WinForms.NotateXpress9.LayerRestoredEventArgs

Syntax

[Visual Basic]
Public Class LayerRestoredEventArgs
   Inherits EventArgs
[C#]
public class LayerRestoredEventArgs : EventArgs
[C++]
public __gc class LayerRestoredEventArgs : public EventArgs
[C++/CLI]
public ref class LayerRestoredEventArgs : public EventArgs

See Also

LayerRestoredEventArgs Members | PegasusImaging.WinForms.NotateXpress9 Namespace


LayerRestoredEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

LayerRestoredEventArgs Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : LayerRestoredEventArgs Class

LayerRestoredEventArgs overview

Public Constructors

Public Constructor LayerRestoredEventArgs Constructor

Public Properties

Public Property Layer Gets the layer which was restored.

See Also

LayerRestoredEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace


LayerRestoredEventArgs Constructor

LayerRestoredEventArgs Class | LayerRestoredEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

LayerRestoredEventArgs Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > LayerRestoredEventArgs Class : LayerRestoredEventArgs Constructor (LayerRestoredEventArgs)
[Visual Basic]
Public Function New()
[C#]
public LayerRestoredEventArgs();
[C++]
public: LayerRestoredEventArgs();
[C++/CLI]
public:
LayerRestoredEventArgs();

See Also

LayerRestoredEventArgs Class | LayerRestoredEventArgs Members


LayerRestoredEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

LayerRestoredEventArgs Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : LayerRestoredEventArgs Class

For a list of all members of this type, see LayerRestoredEventArgs members.

Public Properties

Public Property Layer Gets the layer which was restored.

See Also

LayerRestoredEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Layer Property

LayerRestoredEventArgs Class | LayerRestoredEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Layer Property

PegasusImaging.WinForms.NotateXpress9 Namespace > LayerRestoredEventArgs Class : Layer Property (LayerRestoredEventArgs)

Gets the layer which was restored.

[Visual Basic]
Public Property Layer As Layer
[C#]
public Layer Layer {get; set;}
[C++]
public: __property Layer* get_Layer();
public: __property void set_Layer(
   Layer* value
);
[C++/CLI]
public:
property Layer^ Layer {
   Layer^ get();
   void set (Layer^ value);
}

Remarks

The Layer.

See Also

LayerRestoredEventArgs Class | LayerRestoredEventArgs Members


LineTool Class

LineTool Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

LineTool Class

PegasusImaging.WinForms.NotateXpress9 Namespace : LineTool Class

The LineTool class is used to create single-line annotations with 2 points.

For a list of all members of this type, see LineTool members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.NotateXpress9.Element
PegasusImaging.WinForms.NotateXpress9.LineTool

Syntax

[Visual Basic]
Public Class LineTool
   Inherits Element
[C#]
public class LineTool : Element
[C++]
public __gc class LineTool : public Element
[C++/CLI]
public ref class LineTool : public Element

See Also

LineTool Members | PegasusImaging.WinForms.NotateXpress9 Namespace


LineTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

LineTool Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : LineTool Class

LineTool overview

Public Constructors

Public Constructor LineTool Constructor Default constructor for the PolyLineTool class.

Public Properties

Public Property BeginPointStyle | This is used for displaying arrowheads on the begining of a line.
Public Property BoundingRectangle (Inherited from Element) | Gets and sets the rectangle boundary for the element.
Public Property CreateTime (Inherited from Element) | A Read only property that gets the time when the element was created.
Public Property EndPointStyle | This property sets or returns the EndPointStyle used to draw the line.
Public Property Fixed (Inherited from Element) | Gets and sets whether an annotation has a fixed position with respect to the control window.
Public Property GroupMember (Inherited from Element) | Gets the group which the element belongs to.
Public Property IsGroupMember (Inherited from Element) | A read only property that gets a value which determines if the element is a member of a group or not.
Public Property Locked (Inherited from Element) | Gets and sets an indicator whether an annotation element can be selected or moved by a user in Edit mode.
Public Property Moveable (Inherited from Element) | Gets and sets whether the element can be moved by a user in Edit mode.
Public Property NumberPoints (Inherited from Element) | A Read only property that gets the number of points currently used to define the element.
Public Property PenColor | This property sets or returns the color of the pen used to draw the line.
Public Property PenFillStyle | This property sets or returns the PenFillStyle used to draw the line.
Public Property PenStyle | This property sets or returns the PenStyle used to draw the line.
Public Property PenWidth | This property sets or returns the width of the pen, in pixels, used to draw the line.
Public Property Selected (Inherited from Element) | Gets and sets whether the element has been selected.
Public Property ShowHandles (Inherited from Element) | Gets and sets whether selection handles are displayed on an object when it is selected.
Public Property Sizeable (Inherited from Element) | Gets and sets whether the element can be resized.
Public Property ToolTipText (Inherited from Element) | Gets and sets a string value in the element that will become the ToolTipText value associated with the element.
Public Property UserLong (Inherited from Element) | Gets and sets a user defined long value associated with the element.
Public Property UserString (Inherited from Element) | Gets and sets a user-defined string associated with the element.
Public Property Visible (Inherited from Element) | Gets and sets whether the element is visible.

Public Methods

Public Method GetPoints | This method returns an array of Points used to draw the line.
Public Method NudgeDown (Inherited from Element) | Moves the specified annotation object one level down, towards the back, in the painting order of the specified layer.
Public Method NudgeUp (Inherited from Element) | Moves the specified annotation object one level up, towards the front, in the painting order of the specified layer.
Public Method SetPoints | This method sets an array of Points used to draw the line.
Public Method UserDataAdd (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataDelete (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFind (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFindFirst (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFindNext (Inherited from Element) | User data can be added to each element in a key value pair.

See Also

LineTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace


LineTool Constructor

LineTool Class | LineTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

LineTool Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > LineTool Class : LineTool Constructor (LineTool)

Default constructor for the PolyLineTool class.

[Visual Basic]
Public Function New()
[C#]
public LineTool();
[C++]
public: LineTool();
[C++/CLI]
public:
LineTool();

See Also

LineTool Class | LineTool Members


GetPoints Method

LineTool Class | LineTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetPoints Method

PegasusImaging.WinForms.NotateXpress9 Namespace > LineTool Class : GetPoints Method (LineTool)

This method returns an array of Points used to draw the line.

[Visual Basic]
Public Function GetPoints() As Point()
[C#]
public Point[] GetPoints();
[C++]
public: Point[]* GetPoints();
[C++/CLI]
public:
array<Point>^ GetPoints();

Return Type

An array of points.

See Also

LineTool Class | LineTool Members


SetPoints Method

LineTool Class | LineTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

points
An array of point used to draw a line.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

SetPoints Method

PegasusImaging.WinForms.NotateXpress9 Namespace > LineTool Class : SetPoints Method (LineTool)

This method sets an array of Points used to draw the line.

[Visual Basic]
Public Sub SetPoints( _
   ByVal points() As Point _
)
[C#]
public void SetPoints(
   Point[] points
);
[C++]
public: void SetPoints(
   Point[]* points
)
[C++/CLI]
public:
void SetPoints(
   Pointarray<points>^ points
)

Parameters

points
An array of point used to draw a line.

See Also

LineTool Class | LineTool Members


LineTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

LineTool Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : LineTool Class

For a list of all members of this type, see LineTool members.

Public Properties

Public Property BeginPointStyle | This is used for displaying arrowheads on the begining of a line.
Public Property BoundingRectangle (Inherited from Element) | Gets and sets the rectangle boundary for the element.
Public Property CreateTime (Inherited from Element) | A Read only property that gets the time when the element was created.
Public Property EndPointStyle | This property sets or returns the EndPointStyle used to draw the line.
Public Property Fixed (Inherited from Element) | Gets and sets whether an annotation has a fixed position with respect to the control window.
Public Property GroupMember (Inherited from Element) | Gets the group which the element belongs to.
Public Property IsGroupMember (Inherited from Element) | A read only property that gets a value which determines if the element is a member of a group or not.
Public Property Locked (Inherited from Element) | Gets and sets an indicator whether an annotation element can be selected or moved by a user in Edit mode.
Public Property Moveable (Inherited from Element) | Gets and sets whether the element can be moved by a user in Edit mode.
Public Property NumberPoints (Inherited from Element) | A Read only property that gets the number of points currently used to define the element.
Public Property PenColor | This property sets or returns the color of the pen used to draw the line.
Public Property PenFillStyle | This property sets or returns the PenFillStyle used to draw the line.
Public Property PenStyle | This property sets or returns the PenStyle used to draw the line.
Public Property PenWidth | This property sets or returns the width of the pen, in pixels, used to draw the line.
Public Property Selected (Inherited from Element) | Gets and sets whether the element has been selected.
Public Property ShowHandles (Inherited from Element) | Gets and sets whether selection handles are displayed on an object when it is selected.
Public Property Sizeable (Inherited from Element) | Gets and sets whether the element can be resized.
Public Property ToolTipText (Inherited from Element) | Gets and sets a string value in the element that will become the ToolTipText value associated with the element.
Public Property UserLong (Inherited from Element) | Gets and sets a user defined long value associated with the element.
Public Property UserString (Inherited from Element) | Gets and sets a user-defined string associated with the element.
Public Property Visible (Inherited from Element) | Gets and sets whether the element is visible.

See Also

LineTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace


BeginPointStyle Property

LineTool Class | LineTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BeginPointStyle Property

PegasusImaging.WinForms.NotateXpress9 Namespace > LineTool Class : BeginPointStyle Property (LineTool)

This is used for displaying arrowheads on the begining of a line.

[Visual Basic]
Public Property BeginPointStyle As EndPointStyle
[C#]
public EndPointStyle BeginPointStyle {get; set;}
[C++]
public: __property EndPointStyle get_BeginPointStyle();
public: __property void set_BeginPointStyle(
   EndPointStyle value
);
[C++/CLI]
public:
property EndPointStyle BeginPointStyle {
   EndPointStyle get();
   void set (EndPointStyle value);
}

Value

The begin point style.

See Also

LineTool Class | LineTool Members


EndPointStyle Property

LineTool Class | LineTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

EndPointStyle Property

PegasusImaging.WinForms.NotateXpress9 Namespace > LineTool Class : EndPointStyle Property (LineTool)

This property sets or returns the EndPointStyle used to draw the line.

[Visual Basic]
Public Property EndPointStyle As EndPointStyle
[C#]
public EndPointStyle EndPointStyle {get; set;}
[C++]
public: __property EndPointStyle get_EndPointStyle();
public: __property void set_EndPointStyle(
   EndPointStyle value
);
[C++/CLI]
public:
property EndPointStyle EndPointStyle {
   EndPointStyle get();
   void set (EndPointStyle value);
}

Value

The end point style.

See Also

LineTool Class | LineTool Members


PenColor Property

LineTool Class | LineTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PenColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > LineTool Class : PenColor Property (LineTool)

This property sets or returns the color of the pen used to draw the line.

[Visual Basic]
Public Property PenColor As Color
[C#]
public Color PenColor {get; set;}
[C++]
public: __property Color get_PenColor();
public: __property void set_PenColor(
   Color value
);
[C++/CLI]
public:
property Color PenColor {
   Color get();
   void set (Color value);
}

Value

The Color of the pen.

See Also

LineTool Class | LineTool Members


PenFillStyle Property

LineTool Class | LineTool Members | PenFillStyle Property

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PenFillStyle Property

PegasusImaging.WinForms.NotateXpress9 Namespace > LineTool Class : PenFillStyle Property (LineTool)

This property sets or returns the PenFillStyle used to draw the line.

[Visual Basic]
Public Property PenFillStyle As PenFillStyle
[C#]
public PenFillStyle PenFillStyle {get; set;}
[C++]
public: __property PenFillStyle get_PenFillStyle();
public: __property void set_PenFillStyle(
   PenFillStyle value
);
[C++/CLI]
public:
property PenFillStyle PenFillStyle {
   PenFillStyle get();
   void set (PenFillStyle value);
}

Value

The PenFillStyle enumeration value set.

Remarks

The default value is PenFillStyle.Opaque.

See Also

LineTool Class | LineTool Members | PenFillStyle Property


PenStyle Property

LineTool Class | LineTool Members | PenStyle Property

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PenStyle Property

PegasusImaging.WinForms.NotateXpress9 Namespace > LineTool Class : PenStyle Property (LineTool)

This property sets or returns the PenStyle used to draw the line.

[Visual Basic]
Public Property PenStyle As PenStyle
[C#]
public PenStyle PenStyle {get; set;}
[C++]
public: __property PenStyle get_PenStyle();
public: __property void set_PenStyle(
   PenStyle value
);
[C++/CLI]
public:
property PenStyle PenStyle {
   PenStyle get();
   void set (PenStyle value);
}

Value

The PenStyle enumeration value set.

Remarks

Note: The PenStyle can be anything when the pen is one pixel. The PenStyle will only show Solid when the width is more than one pixel.

See Also

LineTool Class | LineTool Members | PenStyle Property


PenWidth Property

LineTool Class | LineTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PenWidth Property

PegasusImaging.WinForms.NotateXpress9 Namespace > LineTool Class : PenWidth Property (LineTool)

This property sets or returns the width of the pen, in pixels, used to draw the line.

[Visual Basic]
Public Property PenWidth As Integer
[C#]
public int PenWidth {get; set;}
[C++]
public: __property int get_PenWidth();
public: __property void set_PenWidth(
   int value
);
[C++/CLI]
public:
property int PenWidth {
   int get();
   void set (int value);
}

Value

An integer value which represents the width of the pen.

See Also

LineTool Class | LineTool Members


LineToolbarDefaults Class

LineToolbarDefaults Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

LineToolbarDefaults Class

PegasusImaging.WinForms.NotateXpress9 Namespace : LineToolbarDefaults Class (PegasusImaging.WinForms.NotateXpress9)

The TextTool is used to create Line annotations.

For a list of all members of this type, see LineToolbarDefaults members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.NotateXpress9.BaseToolbarDefaults
PegasusImaging.WinForms.NotateXpress9.LineToolbarDefaults

Syntax

[Visual Basic]
Public Class LineToolbarDefaults
   Inherits BaseToolbarDefaults
[C#]
public class LineToolbarDefaults : BaseToolbarDefaults
[C++]
public __gc class LineToolbarDefaults : public BaseToolbarDefaults
[C++/CLI]
public ref class LineToolbarDefaults : public BaseToolbarDefaults

See Also

LineToolbarDefaults Members | PegasusImaging.WinForms.NotateXpress9 Namespace


LineToolbarDefaults Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

LineToolbarDefaults Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : LineToolbarDefaults Class (PegasusImaging.WinForms.NotateXpress9)

LineToolbarDefaults overview

Public Constructors

Public Constructor LineToolbarDefaults Constructor Default constructor for the LineToolbarDefaults class.

Public Properties

Public Property BeginPointStyle | This is used for displaying arrowheads on the begining of a line.
Public Property EndPointStyle | Gets and sets the end point style used for displaying arrowheads on the end of a line.
Public Property Fixed (Inherited from BaseToolbarDefaults) | Gets and sets whether an element is tied to the view instead of the image.
Public Property Locked (Inherited from BaseToolbarDefaults) | Gets and sets an indicator to lock an element so it cannot be selected or moved by a user in Edit mode.
Public Property Moveable (Inherited from BaseToolbarDefaults) | Gets and sets whether an element can be moved interactively during EditMode.
Public Property PenColor | This property sets or returns the color of the pen used to draw the border around the Line annotation .
Public Property PenFillStyle | This property sets or returns the hatch style used within the Line annotation.
Public Property PenStyle | This property sets or returns the style of the background used within the Line annotation.
Public Property PenWidth | This property sets or returns the width of the pen used to draw the Line annotation.
Public Property Selected (Inherited from BaseToolbarDefaults) | Gets and sets whether an element is automatically selected.
Public Property ShowHandles (Inherited from BaseToolbarDefaults) | Gets and sets whether selection handles are displayed for an element.
Public Property Sizeable (Inherited from BaseToolbarDefaults) | Gets and sets whether an element can be sized interactively during EditMode.
Public Property ToolTipText (Inherited from BaseToolbarDefaults) | Gets or sets a string value in the element that will become the ToolTipText value associated with the annotation once it is created.
Public Property UserLong (Inherited from BaseToolbarDefaults) | Gets and sets a long value in the element that will become the UserLong value associated with the element once it is created.
Public Property UserString (Inherited from BaseToolbarDefaults) | Gets and sets a string value in the element that will become the UserString value associated with the object once it is created.
Public Property Visible (Inherited from BaseToolbarDefaults) | Gets and sets the Visible attribute of an element.

See Also

LineToolbarDefaults Class | PegasusImaging.WinForms.NotateXpress9 Namespace


LineToolbarDefaults Constructor

LineToolbarDefaults Class | LineToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

LineToolbarDefaults Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > LineToolbarDefaults Class : LineToolbarDefaults Constructor (LineToolbarDefaults)

Default constructor for the LineToolbarDefaults class.

[Visual Basic]
Public Function New()
[C#]
public LineToolbarDefaults();
[C++]
public: LineToolbarDefaults();
[C++/CLI]
public:
LineToolbarDefaults();

See Also

LineToolbarDefaults Class | LineToolbarDefaults Members


LineToolbarDefaults Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

LineToolbarDefaults Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : LineToolbarDefaults Class (PegasusImaging.WinForms.NotateXpress9)

For a list of all members of this type, see LineToolbarDefaults members.

Public Properties

Public Property BeginPointStyle | This is used for displaying arrowheads on the begining of a line.
Public Property EndPointStyle | Gets and sets the end point style used for displaying arrowheads on the end of a line.
Public Property Fixed (Inherited from BaseToolbarDefaults) | Gets and sets whether an element is tied to the view instead of the image.
Public Property Locked (Inherited from BaseToolbarDefaults) | Gets and sets an indicator to lock an element so it cannot be selected or moved by a user in Edit mode.
Public Property Moveable (Inherited from BaseToolbarDefaults) | Gets and sets whether an element can be moved interactively during EditMode.
Public Property PenColor | This property sets or returns the color of the pen used to draw the border around the Line annotation .
Public Property PenFillStyle | This property sets or returns the hatch style used within the Line annotation.
Public Property PenStyle | This property sets or returns the style of the background used within the Line annotation.
Public Property PenWidth | This property sets or returns the width of the pen used to draw the Line annotation.
Public Property Selected (Inherited from BaseToolbarDefaults) | Gets and sets whether an element is automatically selected.
Public Property ShowHandles (Inherited from BaseToolbarDefaults) | Gets and sets whether selection handles are displayed for an element.
Public Property Sizeable (Inherited from BaseToolbarDefaults) | Gets and sets whether an element can be sized interactively during EditMode.
Public Property ToolTipText (Inherited from BaseToolbarDefaults) | Gets or sets a string value in the element that will become the ToolTipText value associated with the annotation once it is created.
Public Property UserLong (Inherited from BaseToolbarDefaults) | Gets and sets a long value in the element that will become the UserLong value associated with the element once it is created.
Public Property UserString (Inherited from BaseToolbarDefaults) | Gets and sets a string value in the element that will become the UserString value associated with the object once it is created.
Public Property Visible (Inherited from BaseToolbarDefaults) | Gets and sets the Visible attribute of an element.

See Also

LineToolbarDefaults Class | PegasusImaging.WinForms.NotateXpress9 Namespace


BeginPointStyle Property

LineToolbarDefaults Class | LineToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BeginPointStyle Property

PegasusImaging.WinForms.NotateXpress9 Namespace > LineToolbarDefaults Class : BeginPointStyle Property (LineToolbarDefaults)

This is used for displaying arrowheads on the begining of a line.

[Visual Basic]
Public Property BeginPointStyle As EndPointStyle
[C#]
public EndPointStyle BeginPointStyle {get; set;}
[C++]
public: __property EndPointStyle get_BeginPointStyle();
public: __property void set_BeginPointStyle(
   EndPointStyle value
);
[C++/CLI]
public:
property EndPointStyle BeginPointStyle {
   EndPointStyle get();
   void set (EndPointStyle value);
}

Value

The begin point style.

See Also

LineToolbarDefaults Class | LineToolbarDefaults Members


EndPointStyle Property

LineToolbarDefaults Class | LineToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

EndPointStyle Property

PegasusImaging.WinForms.NotateXpress9 Namespace > LineToolbarDefaults Class : EndPointStyle Property (LineToolbarDefaults)

Gets and sets the end point style used for displaying arrowheads on the end of a line.

[Visual Basic]
Public Property EndPointStyle As EndPointStyle
[C#]
public EndPointStyle EndPointStyle {get; set;}
[C++]
public: __property EndPointStyle get_EndPointStyle();
public: __property void set_EndPointStyle(
   EndPointStyle value
);
[C++/CLI]
public:
property EndPointStyle EndPointStyle {
   EndPointStyle get();
   void set (EndPointStyle value);
}

Value

The end point style.

See Also

LineToolbarDefaults Class | LineToolbarDefaults Members


PenColor Property

LineToolbarDefaults Class | LineToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PenColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > LineToolbarDefaults Class : PenColor Property (LineToolbarDefaults)

This property sets or returns the color of the pen used to draw the border around the Line annotation .

[Visual Basic]
Public Property PenColor As Color
[C#]
public Color PenColor {get; set;}
[C++]
public: __property Color get_PenColor();
public: __property void set_PenColor(
   Color value
);
[C++/CLI]
public:
property Color PenColor {
   Color get();
   void set (Color value);
}

Value

The Color value set.

See Also

LineToolbarDefaults Class | LineToolbarDefaults Members


PenFillStyle Property

LineToolbarDefaults Class | LineToolbarDefaults Members | PenFillStyle Property

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PenFillStyle Property

PegasusImaging.WinForms.NotateXpress9 Namespace > LineToolbarDefaults Class : PenFillStyle Property (LineToolbarDefaults)

This property sets or returns the hatch style used within the Line annotation.

[Visual Basic]
Public Property PenFillStyle As PenFillStyle
[C#]
public PenFillStyle PenFillStyle {get; set;}
[C++]
public: __property PenFillStyle get_PenFillStyle();
public: __property void set_PenFillStyle(
   PenFillStyle value
);
[C++/CLI]
public:
property PenFillStyle PenFillStyle {
   PenFillStyle get();
   void set (PenFillStyle value);
}

Value

The PenFillStyle enumeration value set.

Remarks

The default value is PenFillStyle.Opaque.

See Also

LineToolbarDefaults Class | LineToolbarDefaults Members | PenFillStyle Property


PenStyle Property

LineToolbarDefaults Class | LineToolbarDefaults Members | PenStyle Property

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PenStyle Property

PegasusImaging.WinForms.NotateXpress9 Namespace > LineToolbarDefaults Class : PenStyle Property (LineToolbarDefaults)

This property sets or returns the style of the background used within the Line annotation.

[Visual Basic]
Public Property PenStyle As PenStyle
[C#]
public PenStyle PenStyle {get; set;}
[C++]
public: __property PenStyle get_PenStyle();
public: __property void set_PenStyle(
   PenStyle value
);
[C++/CLI]
public:
property PenStyle PenStyle {
   PenStyle get();
   void set (PenStyle value);
}

Value

The PenStyle enumeration value set.

Remarks

Note: The PenStyle can be anything when the pen is one pixel. The PenStyle will only show Solid when the width is more than one pixel.

See Also

LineToolbarDefaults Class | LineToolbarDefaults Members | PenStyle Property


PenWidth Property

LineToolbarDefaults Class | LineToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PenWidth Property

PegasusImaging.WinForms.NotateXpress9 Namespace > LineToolbarDefaults Class : PenWidth Property (LineToolbarDefaults)

This property sets or returns the width of the pen used to draw the Line annotation.

[Visual Basic]
Public Property PenWidth As Integer
[C#]
public int PenWidth {get; set;}
[C++]
public: __property int get_PenWidth();
public: __property void set_PenWidth(
   int value
);
[C++/CLI]
public:
property int PenWidth {
   int get();
   void set (int value);
}

Value

An integer which represents the pen width in pixels.

See Also

LineToolbarDefaults Class | LineToolbarDefaults Members


LoadOptions Class

LoadOptions Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

LoadOptions Class

PegasusImaging.WinForms.NotateXpress9 Namespace : LoadOptions Class

This class provides options when loading in annotations.

For a list of all members of this type, see LoadOptions members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.NotateXpress9.LoadOptions

Syntax

[Visual Basic]
Public Class LoadOptions
[C#]
public class LoadOptions
[C++]
public __gc class LoadOptions
[C++/CLI]
public ref class LoadOptions

See Also

LoadOptions Members | PegasusImaging.WinForms.NotateXpress9 Namespace


LoadOptions Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

LoadOptions Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : LoadOptions Class

LoadOptions overview

Public Constructors

Public Constructor LoadOptions Constructor Initializes a new instance of the LoadOptions class.

Public Properties

Public Property AllLayers | Gets or sets a value indicating whether all layers are read in, or only a specific layer.
Public Property AnnType | Gets or sets the type of annotations that you are expecting.
Public Property LoadUserData | Gets and sets an indicator to attempt to read unknown attributes when loading XML.
Public Property PreserveWangLayers | The PreserveWTLayers affects the way that NotateXpress objects are stored in Wang annotation-compatible Tiff files.
Public Property UnicodeMode | Gets or sets a value indicating whether NotateXpress will treat all files as Unicode.

See Also

LoadOptions Class | PegasusImaging.WinForms.NotateXpress9 Namespace


LoadOptions Constructor

LoadOptions Class | LoadOptions Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

LoadOptions Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > LoadOptions Class : LoadOptions Constructor (LoadOptions)

Initializes a new instance of the LoadOptions class.

[Visual Basic]
Public Function New()
[C#]
public LoadOptions();
[C++]
public: LoadOptions();
[C++/CLI]
public:
LoadOptions();

See Also

LoadOptions Class | LoadOptions Members


LoadOptions Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

LoadOptions Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : LoadOptions Class

For a list of all members of this type, see LoadOptions members.

Public Properties

Public Property AllLayers | Gets or sets a value indicating whether all layers are read in, or only a specific layer.
Public Property AnnType | Gets or sets the type of annotations that you are expecting.
Public Property LoadUserData | Gets and sets an indicator to attempt to read unknown attributes when loading XML.
Public Property PreserveWangLayers | The PreserveWTLayers affects the way that NotateXpress objects are stored in Wang annotation-compatible Tiff files.
Public Property UnicodeMode | Gets or sets a value indicating whether NotateXpress will treat all files as Unicode.

See Also

LoadOptions Class | PegasusImaging.WinForms.NotateXpress9 Namespace


AllLayers Property

LoadOptions Class | LoadOptions Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

AllLayers Property

PegasusImaging.WinForms.NotateXpress9 Namespace > LoadOptions Class : AllLayers Property (LoadOptions)

Gets or sets a value indicating whether all layers are read in, or only a specific layer.

[Visual Basic]
Public Property AllLayers As Boolean
[C#]
public bool AllLayers {get; set;}
[C++]
public: __property bool get_AllLayers();
public: __property void set_AllLayers(
   bool value
);
[C++/CLI]
public:
property bool AllLayers {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true if all layers are read in. Otherwise, false is used and only a specific layer is read in.

See Also

LoadOptions Class | LoadOptions Members


AnnType Property

LoadOptions Class | LoadOptions Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

AnnType Property

PegasusImaging.WinForms.NotateXpress9 Namespace > LoadOptions Class : AnnType Property (LoadOptions)

Gets or sets the type of annotations that you are expecting.

[Visual Basic]
Public Property AnnType As AnnotationType
[C#]
public AnnotationType AnnType {get; set;}
[C++]
public: __property AnnotationType get_AnnType();
public: __property void set_AnnType(
   AnnotationType value
);
[C++/CLI]
public:
property AnnotationType AnnType {
   AnnotationType get();
   void set (AnnotationType value);
}

Value

The type of the annotations.

Remarks

Choices are ImagingForWindows (aka Wang or Kodak), NotateXpress, TMSSequoia, NotateXpressXml, and XFDF.

See Also

LoadOptions Class | LoadOptions Members


LoadUserData Property

LoadOptions Class | LoadOptions Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

LoadUserData Property

PegasusImaging.WinForms.NotateXpress9 Namespace > LoadOptions Class : LoadUserData Property

Gets and sets an indicator to attempt to read unknown attributes when loading XML.

[Visual Basic]
Public Property LoadUserData As Boolean
[C#]
public bool LoadUserData {get; set;}
[C++]
public: __property bool get_LoadUserData();
public: __property void set_LoadUserData(
   bool value
);
[C++/CLI]
public:
property bool LoadUserData {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true to attempt to read unknown attributes when loading XML. Otherwise, false .

Remarks

The default value is true.

All unknown data will be put in the UserData fields depending on where the xml was found (page, layer, group, element)

See Also

LoadOptions Class | LoadOptions Members


PreserveWangLayers Property

LoadOptions Class | LoadOptions Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PreserveWangLayers Property

PegasusImaging.WinForms.NotateXpress9 Namespace > LoadOptions Class : PreserveWangLayers Property (LoadOptions)

The PreserveWTLayers affects the way that NotateXpress objects are stored in Wang annotation-compatible Tiff files.

[Visual Basic]
Public Property PreserveWangLayers As Boolean
[C#]
public bool PreserveWangLayers {get; set;}
[C++]
public: __property bool get_PreserveWangLayers();
public: __property void set_PreserveWangLayers(
   bool value
);
[C++/CLI]
public:
property bool PreserveWangLayers {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true if preserve Wang layers. Otherwise, false to not preserve Wang layers.

Remarks

When PreserveWTLayers is True, NotateXpress will store items from a layer together under one Group tag. When PreserveWTLayers is False, NotateXpress will store each object in a separate Group tag. When reading a Tiff file, NotateXpress will create a separate layer for each Group tag encountered if PreserveWTLayers is True, otherwise only 1 layer will be created and all objects placed in that layer. The default value is False, meaning NotateXpress will not preserve layers when writing annotations to a Tiff file.

See Also

LoadOptions Class | LoadOptions Members


UnicodeMode Property

LoadOptions Class | LoadOptions Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

UnicodeMode Property

PegasusImaging.WinForms.NotateXpress9 Namespace > LoadOptions Class : UnicodeMode Property

Gets or sets a value indicating whether NotateXpress will treat all files as Unicode.

[Visual Basic]
Public Property UnicodeMode As Boolean
[C#]
public bool UnicodeMode {get; set;}
[C++]
public: __property bool get_UnicodeMode();
public: __property void set_UnicodeMode(
   bool value
);
[C++/CLI]
public:
property bool UnicodeMode {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true if all files are treated as Unicode. Otherwise, false is used and all files are not treated as Unicode.

See Also

LoadOptions Class | LoadOptions Members


MappingInputEventArgs Class

MappingInputEventArgs Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

MappingInputEventArgs Class

PegasusImaging.WinForms.NotateXpress9 Namespace : MappingInputEventArgs Class

Contains event data for MappingInput events.

For a list of all members of this type, see MappingInputEventArgs members.

Object Model

Inheritance Hierarchy

System.Object
System.EventArgs
PegasusImaging.WinForms.NotateXpress9.MappingInputEventArgs

Syntax

[Visual Basic]
Public Class MappingInputEventArgs
   Inherits EventArgs
[C#]
public class MappingInputEventArgs : EventArgs
[C++]
public __gc class MappingInputEventArgs : public EventArgs
[C++/CLI]
public ref class MappingInputEventArgs : public EventArgs

See Also

MappingInputEventArgs Members | PegasusImaging.WinForms.NotateXpress9 Namespace


MappingInputEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

MappingInputEventArgs Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : MappingInputEventArgs Class

MappingInputEventArgs overview

Public Constructors

Public Constructor MappingInputEventArgs Constructor

Public Properties

Public Property NewX | Gets the mapped x coordinate of the annotation currently being imported. Setting this property will modify x position of the imported annotation.
Public Property NewY | Gets the mapped y coordinate of the annotation currently being imported. Setting this property will modify the y position of the imported annotation.
Public Property X | Gets the unmapped x coordinate of the annotation currently being imported.
Public Property Y | Gets the unmapped y coordinate of the annotation currently being imported.

See Also

MappingInputEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace


MappingInputEventArgs Constructor

MappingInputEventArgs Class | MappingInputEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

MappingInputEventArgs Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > MappingInputEventArgs Class : MappingInputEventArgs Constructor (MappingInputEventArgs)
[Visual Basic]
Public Function New()
[C#]
public MappingInputEventArgs();
[C++]
public: MappingInputEventArgs();
[C++/CLI]
public:
MappingInputEventArgs();

See Also

MappingInputEventArgs Class | MappingInputEventArgs Members


MappingInputEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

MappingInputEventArgs Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : MappingInputEventArgs Class

For a list of all members of this type, see MappingInputEventArgs members.

Public Properties

Public Property NewX | Gets the mapped x coordinate of the annotation currently being imported. Setting this property will modify x position of the imported annotation.
Public Property NewY | Gets the mapped y coordinate of the annotation currently being imported. Setting this property will modify the y position of the imported annotation.
Public Property X | Gets the unmapped x coordinate of the annotation currently being imported.
Public Property Y | Gets the unmapped y coordinate of the annotation currently being imported.

See Also

MappingInputEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace


NewX Property

MappingInputEventArgs Class | MappingInputEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NewX Property

PegasusImaging.WinForms.NotateXpress9 Namespace > MappingInputEventArgs Class : NewX Property (MappingInputEventArgs)

Gets the mapped x coordinate of the annotation currently being imported. Setting this property will modify x position of the imported annotation.

[Visual Basic]
Public Property NewX As Integer
[C#]
public int NewX {get; set;}
[C++]
public: __property int get_NewX();
public: __property void set_NewX(
   int value
);
[C++/CLI]
public:
property int NewX {
   int get();
   void set (int value);
}

See Also

MappingInputEventArgs Class | MappingInputEventArgs Members


NewY Property

MappingInputEventArgs Class | MappingInputEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NewY Property

PegasusImaging.WinForms.NotateXpress9 Namespace > MappingInputEventArgs Class : NewY Property (MappingInputEventArgs)

Gets the mapped y coordinate of the annotation currently being imported. Setting this property will modify the y position of the imported annotation.

[Visual Basic]
Public Property NewY As Integer
[C#]
public int NewY {get; set;}
[C++]
public: __property int get_NewY();
public: __property void set_NewY(
   int value
);
[C++/CLI]
public:
property int NewY {
   int get();
   void set (int value);
}

See Also

MappingInputEventArgs Class | MappingInputEventArgs Members


X Property

MappingInputEventArgs Class | MappingInputEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

X Property

PegasusImaging.WinForms.NotateXpress9 Namespace > MappingInputEventArgs Class : X Property (MappingInputEventArgs)

Gets the unmapped x coordinate of the annotation currently being imported.

[Visual Basic]
Public Property X As Double
[C#]
public double X {get; set;}
[C++]
public: __property double get_X();
public: __property void set_X(
   double value
);
[C++/CLI]
public:
property double X {
   double get();
   void set (double value);
}

See Also

MappingInputEventArgs Class | MappingInputEventArgs Members


Y Property

MappingInputEventArgs Class | MappingInputEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Y Property

PegasusImaging.WinForms.NotateXpress9 Namespace > MappingInputEventArgs Class : Y Property (MappingInputEventArgs)

Gets the unmapped y coordinate of the annotation currently being imported.

[Visual Basic]
Public Property Y As Double
[C#]
public double Y {get; set;}
[C++]
public: __property double get_Y();
public: __property void set_Y(
   double value
);
[C++/CLI]
public:
property double Y {
   double get();
   void set (double value);
}

See Also

MappingInputEventArgs Class | MappingInputEventArgs Members


MappingOutputEventArgs Class

MappingOutputEventArgs Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

MappingOutputEventArgs Class

PegasusImaging.WinForms.NotateXpress9 Namespace : MappingOutputEventArgs Class

Contains event data for MappingOutput events.

For a list of all members of this type, see MappingOutputEventArgs members.

Object Model

Inheritance Hierarchy

System.Object
System.EventArgs
PegasusImaging.WinForms.NotateXpress9.MappingOutputEventArgs

Syntax

[Visual Basic]
Public Class MappingOutputEventArgs
   Inherits EventArgs
[C#]
public class MappingOutputEventArgs : EventArgs
[C++]
public __gc class MappingOutputEventArgs : public EventArgs
[C++/CLI]
public ref class MappingOutputEventArgs : public EventArgs

See Also

MappingOutputEventArgs Members | PegasusImaging.WinForms.NotateXpress9 Namespace


MappingOutputEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

MappingOutputEventArgs Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : MappingOutputEventArgs Class

MappingOutputEventArgs overview

Public Constructors

Public Constructor MappingOutputEventArgs Constructor

Public Properties

Public Property NewX | Gets the mapped x coordinate of the annotation currently being exported. Setting this property will modify the x position of the exported annotation.
Public Property NewY | Gets the mapped y coordinate of the annotation currently being exported. Setting this property will modify the y position of the exported annotation.
Public Property X | Gets the unmapped x coordinate of the annotation currently being exported.
Public Property Y | Gets the unmapped y coordinate of the annotation currently being exported.

See Also

MappingOutputEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace


MappingOutputEventArgs Constructor

MappingOutputEventArgs Class | MappingOutputEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

MappingOutputEventArgs Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > MappingOutputEventArgs Class : MappingOutputEventArgs Constructor (MappingOutputEventArgs)
[Visual Basic]
Public Function New()
[C#]
public MappingOutputEventArgs();
[C++]
public: MappingOutputEventArgs();
[C++/CLI]
public:
MappingOutputEventArgs();

See Also

MappingOutputEventArgs Class | MappingOutputEventArgs Members


MappingOutputEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

MappingOutputEventArgs Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : MappingOutputEventArgs Class

For a list of all members of this type, see MappingOutputEventArgs members.

Public Properties

Public Property NewX | Gets the mapped x coordinate of the annotation currently being exported. Setting this property will modify the x position of the exported annotation.
Public Property NewY | Gets the mapped y coordinate of the annotation currently being exported. Setting this property will modify the y position of the exported annotation.
Public Property X | Gets the unmapped x coordinate of the annotation currently being exported.
Public Property Y | Gets the unmapped y coordinate of the annotation currently being exported.

See Also

MappingOutputEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace


NewX Property

MappingOutputEventArgs Class | MappingOutputEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NewX Property

PegasusImaging.WinForms.NotateXpress9 Namespace > MappingOutputEventArgs Class : NewX Property (MappingOutputEventArgs)

Gets the mapped x coordinate of the annotation currently being exported. Setting this property will modify the x position of the exported annotation.

[Visual Basic]
Public Property NewX As Double
[C#]
public double NewX {get; set;}
[C++]
public: __property double get_NewX();
public: __property void set_NewX(
   double value
);
[C++/CLI]
public:
property double NewX {
   double get();
   void set (double value);
}

See Also

MappingOutputEventArgs Class | MappingOutputEventArgs Members


NewY Property

MappingOutputEventArgs Class | MappingOutputEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NewY Property

PegasusImaging.WinForms.NotateXpress9 Namespace > MappingOutputEventArgs Class : NewY Property (MappingOutputEventArgs)

Gets the mapped y coordinate of the annotation currently being exported. Setting this property will modify the y position of the exported annotation.

[Visual Basic]
Public Property NewY As Double
[C#]
public double NewY {get; set;}
[C++]
public: __property double get_NewY();
public: __property void set_NewY(
   double value
);
[C++/CLI]
public:
property double NewY {
   double get();
   void set (double value);
}

See Also

MappingOutputEventArgs Class | MappingOutputEventArgs Members


X Property

MappingOutputEventArgs Class | MappingOutputEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

X Property

PegasusImaging.WinForms.NotateXpress9 Namespace > MappingOutputEventArgs Class : X Property (MappingOutputEventArgs)

Gets the unmapped x coordinate of the annotation currently being exported.

[Visual Basic]
Public Property X As Integer
[C#]
public int X {get; set;}
[C++]
public: __property int get_X();
public: __property void set_X(
   int value
);
[C++/CLI]
public:
property int X {
   int get();
   void set (int value);
}

See Also

MappingOutputEventArgs Class | MappingOutputEventArgs Members


Y Property

MappingOutputEventArgs Class | MappingOutputEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Y Property

PegasusImaging.WinForms.NotateXpress9 Namespace > MappingOutputEventArgs Class : Y Property (MappingOutputEventArgs)

Gets the unmapped y coordinate of the annotation currently being exported.

[Visual Basic]
Public Property Y As Integer
[C#]
public int Y {get; set;}
[C++]
public: __property int get_Y();
public: __property void set_Y(
   int value
);
[C++/CLI]
public:
property int Y {
   int get();
   void set (int value);
}

See Also

MappingOutputEventArgs Class | MappingOutputEventArgs Members


MenuEventArgs Class

MenuEventArgs Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

MenuEventArgs Class

PegasusImaging.WinForms.NotateXpress9 Namespace : MenuEventArgs Class

Arguments for MenuSelect event

For a list of all members of this type, see MenuEventArgs members.

Object Model

Inheritance Hierarchy

System.Object
System.EventArgs
PegasusImaging.WinForms.NotateXpress9.MenuEventArgs

Syntax

[Visual Basic]
Public Class MenuEventArgs
   Inherits EventArgs
[C#]
public class MenuEventArgs : EventArgs
[C++]
public __gc class MenuEventArgs : public EventArgs
[C++/CLI]
public ref class MenuEventArgs : public EventArgs

See Also

MenuEventArgs Members | PegasusImaging.WinForms.NotateXpress9 Namespace


MenuEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

MenuEventArgs Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : MenuEventArgs Class

MenuEventArgs overview

Public Constructors

Public Constructor MenuEventArgs Constructor

Public Properties

Public Property Element | Gets the element in which the menu is associated.
Public Property Layer | Gets the layer on which the element which triggered the menu resides.
Public Property Menu | Gets the type of menu (context or toolbar) selected at the time of the event.
Public Property SubMenuId | Gets the sub menu ID of the item selected at the time of the event.
Public Property Tool | Gets the toolbar tool with which the menu is associated.
Public Property TopMenuId | Gets the top menu ID of the item selected at the time of the event.
Public Property User1 | Gets the first user defined property associated with a menu item.
Public Property User2 | Gets the second user defined property associated with a menu item.

See Also

MenuEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace


MenuEventArgs Constructor

MenuEventArgs Class | MenuEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

MenuEventArgs Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > MenuEventArgs Class : MenuEventArgs Constructor (MenuEventArgs)
[Visual Basic]
Public Function New()
[C#]
public MenuEventArgs();
[C++]
public: MenuEventArgs();
[C++/CLI]
public:
MenuEventArgs();

See Also

MenuEventArgs Class | MenuEventArgs Members


MenuEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

MenuEventArgs Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : MenuEventArgs Class

For a list of all members of this type, see MenuEventArgs members.

Public Properties

Public Property Element | Gets the element in which the menu is associated.
Public Property Layer | Gets the layer on which the element which triggered the menu resides.
Public Property Menu | Gets the type of menu (context or toolbar) selected at the time of the event.
Public Property SubMenuId | Gets the sub menu ID of the item selected at the time of the event.
Public Property Tool | Gets the toolbar tool with which the menu is associated.
Public Property TopMenuId | Gets the top menu ID of the item selected at the time of the event.
Public Property User1 | Gets the first user defined property associated with a menu item.
Public Property User2 | Gets the second user defined property associated with a menu item.

See Also

MenuEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Element Property

MenuEventArgs Class | MenuEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Element Property

PegasusImaging.WinForms.NotateXpress9 Namespace > MenuEventArgs Class : Element Property (MenuEventArgs)

Gets the element in which the menu is associated.

[Visual Basic]
Public Property Element As Element
[C#]
public Element Element {get; set;}
[C++]
public: __property Element* get_Element();
public: __property void set_Element(
   Element* value
);
[C++/CLI]
public:
property Element^ Element {
   Element^ get();
   void set (Element^ value);
}

Remarks

The Element .

See Also

MenuEventArgs Class | MenuEventArgs Members


Layer Property

MenuEventArgs Class | MenuEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Layer Property

PegasusImaging.WinForms.NotateXpress9 Namespace > MenuEventArgs Class : Layer Property (MenuEventArgs)

Gets the layer on which the element which triggered the menu resides.

[Visual Basic]
Public Property Layer As Layer
[C#]
public Layer Layer {get; set;}
[C++]
public: __property Layer* get_Layer();
public: __property void set_Layer(
   Layer* value
);
[C++/CLI]
public:
property Layer^ Layer {
   Layer^ get();
   void set (Layer^ value);
}

Remarks

The Layer.

See Also

MenuEventArgs Class | MenuEventArgs Members


Menu Property

MenuEventArgs Class | MenuEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Menu Property

PegasusImaging.WinForms.NotateXpress9 Namespace > MenuEventArgs Class : Menu Property

Gets the type of menu (context or toolbar) selected at the time of the event.

[Visual Basic]
Public Property Menu As MenuType
[C#]
public MenuType Menu {get; set;}
[C++]
public: __property MenuType get_Menu();
public: __property void set_Menu(
   MenuType value
);
[C++/CLI]
public:
property MenuType Menu {
   MenuType get();
   void set (MenuType value);
}

Remarks

The MenuType.

See Also

MenuEventArgs Class | MenuEventArgs Members


SubMenuId Property

MenuEventArgs Class | MenuEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

SubMenuId Property

PegasusImaging.WinForms.NotateXpress9 Namespace > MenuEventArgs Class : SubMenuId Property (MenuEventArgs)

Gets the sub menu ID of the item selected at the time of the event.

[Visual Basic]
Public Property SubMenuId As Integer
[C#]
public int SubMenuId {get; set;}
[C++]
public: __property int get_SubMenuId();
public: __property void set_SubMenuId(
   int value
);
[C++/CLI]
public:
property int SubMenuId {
   int get();
   void set (int value);
}

Remarks

An integer which represents the sub menu ID.

See Also

MenuEventArgs Class | MenuEventArgs Members


Tool Property

MenuEventArgs Class | MenuEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Tool Property

PegasusImaging.WinForms.NotateXpress9 Namespace > MenuEventArgs Class : Tool Property (MenuEventArgs)

Gets the toolbar tool with which the menu is associated.

[Visual Basic]
Public Property Tool As AnnotationTool
[C#]
public AnnotationTool Tool {get; set;}
[C++]
public: __property AnnotationTool get_Tool();
public: __property void set_Tool(
   AnnotationTool value
);
[C++/CLI]
public:
property AnnotationTool Tool {
   AnnotationTool get();
   void set (AnnotationTool value);
}

Remarks

The AnnotationTool.

See Also

MenuEventArgs Class | MenuEventArgs Members


TopMenuId Property

MenuEventArgs Class | MenuEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TopMenuId Property

PegasusImaging.WinForms.NotateXpress9 Namespace > MenuEventArgs Class : TopMenuId Property (MenuEventArgs)

Gets the top menu ID of the item selected at the time of the event.

[Visual Basic]
Public Property TopMenuId As Integer
[C#]
public int TopMenuId {get; set;}
[C++]
public: __property int get_TopMenuId();
public: __property void set_TopMenuId(
   int value
);
[C++/CLI]
public:
property int TopMenuId {
   int get();
   void set (int value);
}

Remarks

An integer which represents the top menu ID.

See Also

MenuEventArgs Class | MenuEventArgs Members


User1 Property

MenuEventArgs Class | MenuEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

User1 Property

PegasusImaging.WinForms.NotateXpress9 Namespace > MenuEventArgs Class : User1 Property

Gets the first user defined property associated with a menu item.

[Visual Basic]
Public Property User1 As Integer
[C#]
public int User1 {get; set;}
[C++]
public: __property int get_User1();
public: __property void set_User1(
   int value
);
[C++/CLI]
public:
property int User1 {
   int get();
   void set (int value);
}

Remarks

An integer which represents the user.

See Also

MenuEventArgs Class | MenuEventArgs Members


User2 Property

MenuEventArgs Class | MenuEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

User2 Property

PegasusImaging.WinForms.NotateXpress9 Namespace > MenuEventArgs Class : User2 Property

Gets the second user defined property associated with a menu item.

[Visual Basic]
Public Property User2 As Integer
[C#]
public int User2 {get; set;}
[C++]
public: __property int get_User2();
public: __property void set_User2(
   int value
);
[C++/CLI]
public:
property int User2 {
   int get();
   void set (int value);
}

Remarks

An integer which represents the user.

See Also

MenuEventArgs Class | MenuEventArgs Members


MouseDownEventArgs Class

MouseDownEventArgs Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

MouseDownEventArgs Class

PegasusImaging.WinForms.NotateXpress9 Namespace : MouseDownEventArgs Class

Arguments for RunmodeEvent event. Used for mouse events during interactive mode.

For a list of all members of this type, see MouseDownEventArgs members.

Object Model

Inheritance Hierarchy

System.Object
System.EventArgs
PegasusImaging.WinForms.NotateXpress9.MouseDownEventArgs

Syntax

[Visual Basic]
Public Class MouseDownEventArgs
   Inherits EventArgs
[C#]
public class MouseDownEventArgs : EventArgs
[C++]
public __gc class MouseDownEventArgs : public EventArgs
[C++/CLI]
public ref class MouseDownEventArgs : public EventArgs

See Also

MouseDownEventArgs Members | PegasusImaging.WinForms.NotateXpress9 Namespace


MouseDownEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

MouseDownEventArgs Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : MouseDownEventArgs Class

MouseDownEventArgs overview

Public Constructors

Public Constructor MouseDownEventArgs Constructor

Public Properties

Public Property Element | Gets the element that was selected at the time of the mouse down event.
Public Property Layer | Gets the layer that was selected at the time of the mouse down event.
Public Property MouseButtons | Gets the mouse button that was selected at the time of the mouse down event.
Public Property Shift | Gets the shift key state that was selected at the time of the mouse down event.
Public Property X | Gets the x coordinate of the cursor at the time of the mouse down event.
Public Property Y | Gets the y coordinate of the cursor at the time of the mouse down event.

See Also

MouseDownEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace


MouseDownEventArgs Constructor

MouseDownEventArgs Class | MouseDownEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

MouseDownEventArgs Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > MouseDownEventArgs Class : MouseDownEventArgs Constructor (MouseDownEventArgs)
[Visual Basic]
Public Function New()
[C#]
public MouseDownEventArgs();
[C++]
public: MouseDownEventArgs();
[C++/CLI]
public:
MouseDownEventArgs();

See Also

MouseDownEventArgs Class | MouseDownEventArgs Members


MouseDownEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

MouseDownEventArgs Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : MouseDownEventArgs Class

For a list of all members of this type, see MouseDownEventArgs members.

Public Properties

Public Property Element | Gets the element that was selected at the time of the mouse down event.
Public Property Layer | Gets the layer that was selected at the time of the mouse down event.
Public Property MouseButtons | Gets the mouse button that was selected at the time of the mouse down event.
Public Property Shift | Gets the shift key state that was selected at the time of the mouse down event.
Public Property X | Gets the x coordinate of the cursor at the time of the mouse down event.
Public Property Y | Gets the y coordinate of the cursor at the time of the mouse down event.

See Also

MouseDownEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Element Property

MouseDownEventArgs Class | MouseDownEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Element Property

PegasusImaging.WinForms.NotateXpress9 Namespace > MouseDownEventArgs Class : Element Property (MouseDownEventArgs)

Gets the element that was selected at the time of the mouse down event.

[Visual Basic]
Public Property Element As Element
[C#]
public Element Element {get; set;}
[C++]
public: __property Element* get_Element();
public: __property void set_Element(
   Element* value
);
[C++/CLI]
public:
property Element^ Element {
   Element^ get();
   void set (Element^ value);
}

See Also

MouseDownEventArgs Class | MouseDownEventArgs Members


Layer Property

MouseDownEventArgs Class | MouseDownEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Layer Property

PegasusImaging.WinForms.NotateXpress9 Namespace > MouseDownEventArgs Class : Layer Property (MouseDownEventArgs)

Gets the layer that was selected at the time of the mouse down event.

[Visual Basic]
Public Property Layer As Layer
[C#]
public Layer Layer {get; set;}
[C++]
public: __property Layer* get_Layer();
public: __property void set_Layer(
   Layer* value
);
[C++/CLI]
public:
property Layer^ Layer {
   Layer^ get();
   void set (Layer^ value);
}

See Also

MouseDownEventArgs Class | MouseDownEventArgs Members


MouseButtons Property

MouseDownEventArgs Class | MouseDownEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

MouseButtons Property

PegasusImaging.WinForms.NotateXpress9 Namespace > MouseDownEventArgs Class : MouseButtons Property (MouseDownEventArgs)

Gets the mouse button that was selected at the time of the mouse down event.

[Visual Basic]
Public Property MouseButtons As MouseButtons
[C#]
public MouseButtons MouseButtons {get; set;}
[C++]
public: __property MouseButtons get_MouseButtons();
public: __property void set_MouseButtons(
   MouseButtons value
);
[C++/CLI]
public:
property MouseButtons MouseButtons {
   MouseButtons get();
   void set (MouseButtons value);
}

See Also

MouseDownEventArgs Class | MouseDownEventArgs Members


Shift Property

MouseDownEventArgs Class | MouseDownEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Shift Property

PegasusImaging.WinForms.NotateXpress9 Namespace > MouseDownEventArgs Class : Shift Property (MouseDownEventArgs)

Gets the shift key state that was selected at the time of the mouse down event.

[Visual Basic]
Public Property Shift As Integer
[C#]
public int Shift {get; set;}
[C++]
public: __property int get_Shift();
public: __property void set_Shift(
   int value
);
[C++/CLI]
public:
property int Shift {
   int get();
   void set (int value);
}

See Also

MouseDownEventArgs Class | MouseDownEventArgs Members


X Property

MouseDownEventArgs Class | MouseDownEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

X Property

PegasusImaging.WinForms.NotateXpress9 Namespace > MouseDownEventArgs Class : X Property (MouseDownEventArgs)

Gets the x coordinate of the cursor at the time of the mouse down event.

[Visual Basic]
Public Property X As Integer
[C#]
public int X {get; set;}
[C++]
public: __property int get_X();
public: __property void set_X(
   int value
);
[C++/CLI]
public:
property int X {
   int get();
   void set (int value);
}

See Also

MouseDownEventArgs Class | MouseDownEventArgs Members


Y Property

MouseDownEventArgs Class | MouseDownEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Y Property

PegasusImaging.WinForms.NotateXpress9 Namespace > MouseDownEventArgs Class : Y Property (MouseDownEventArgs)

Gets the y coordinate of the cursor at the time of the mouse down event.

[Visual Basic]
Public Property Y As Integer
[C#]
public int Y {get; set;}
[C++]
public: __property int get_Y();
public: __property void set_Y(
   int value
);
[C++/CLI]
public:
property int Y {
   int get();
   void set (int value);
}

See Also

MouseDownEventArgs Class | MouseDownEventArgs Members


MouseMoveEventArgs Class

MouseMoveEventArgs Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

MouseMoveEventArgs Class

PegasusImaging.WinForms.NotateXpress9 Namespace : MouseMoveEventArgs Class

Arguments for RunmodeEvent event. Used for mouse events during interactive mode.

For a list of all members of this type, see MouseMoveEventArgs members.

Object Model

Inheritance Hierarchy

System.Object
System.EventArgs
PegasusImaging.WinForms.NotateXpress9.MouseMoveEventArgs

Syntax

[Visual Basic]
Public Class MouseMoveEventArgs
   Inherits EventArgs
[C#]
public class MouseMoveEventArgs : EventArgs
[C++]
public __gc class MouseMoveEventArgs : public EventArgs
[C++/CLI]
public ref class MouseMoveEventArgs : public EventArgs

See Also

MouseMoveEventArgs Members | PegasusImaging.WinForms.NotateXpress9 Namespace


MouseMoveEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

MouseMoveEventArgs Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : MouseMoveEventArgs Class

MouseMoveEventArgs overview

Public Constructors

Public Constructor MouseMoveEventArgs Constructor

Public Properties

Public Property Element | Gets the element that was clicked on to create the event.
Public Property Layer | Gets the layer that was active at the time of the mouse move event.
Public Property MouseButtons | Gets the mouse button which generated the event.
Public Property Shift | Gets the shift key state when the event was generated.
Public Property X | Gets the x coordinate of the cursor at the end of the mouse move event.
Public Property Y | Gets the y coordinate of the cursor at the end of the mouse move event.

See Also

MouseMoveEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace


MouseMoveEventArgs Constructor

MouseMoveEventArgs Class | MouseMoveEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

MouseMoveEventArgs Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > MouseMoveEventArgs Class : MouseMoveEventArgs Constructor (MouseMoveEventArgs)
[Visual Basic]
Public Function New()
[C#]
public MouseMoveEventArgs();
[C++]
public: MouseMoveEventArgs();
[C++/CLI]
public:
MouseMoveEventArgs();

See Also

MouseMoveEventArgs Class | MouseMoveEventArgs Members


MouseMoveEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

MouseMoveEventArgs Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : MouseMoveEventArgs Class

For a list of all members of this type, see MouseMoveEventArgs members.

Public Properties

Public Property Element | Gets the element that was clicked on to create the event.
Public Property Layer | Gets the layer that was active at the time of the mouse move event.
Public Property MouseButtons | Gets the mouse button which generated the event.
Public Property Shift | Gets the shift key state when the event was generated.
Public Property X | Gets the x coordinate of the cursor at the end of the mouse move event.
Public Property Y | Gets the y coordinate of the cursor at the end of the mouse move event.

See Also

MouseMoveEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Element Property

MouseMoveEventArgs Class | MouseMoveEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Element Property

PegasusImaging.WinForms.NotateXpress9 Namespace > MouseMoveEventArgs Class : Element Property (MouseMoveEventArgs)

Gets the element that was clicked on to create the event.

[Visual Basic]
Public Property Element As Element
[C#]
public Element Element {get; set;}
[C++]
public: __property Element* get_Element();
public: __property void set_Element(
   Element* value
);
[C++/CLI]
public:
property Element^ Element {
   Element^ get();
   void set (Element^ value);
}

See Also

MouseMoveEventArgs Class | MouseMoveEventArgs Members


Layer Property

MouseMoveEventArgs Class | MouseMoveEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Layer Property

PegasusImaging.WinForms.NotateXpress9 Namespace > MouseMoveEventArgs Class : Layer Property (MouseMoveEventArgs)

Gets the layer that was active at the time of the mouse move event.

[Visual Basic]
Public Property Layer As Layer
[C#]
public Layer Layer {get; set;}
[C++]
public: __property Layer* get_Layer();
public: __property void set_Layer(
   Layer* value
);
[C++/CLI]
public:
property Layer^ Layer {
   Layer^ get();
   void set (Layer^ value);
}

See Also

MouseMoveEventArgs Class | MouseMoveEventArgs Members


MouseButtons Property

MouseMoveEventArgs Class | MouseMoveEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

MouseButtons Property

PegasusImaging.WinForms.NotateXpress9 Namespace > MouseMoveEventArgs Class : MouseButtons Property (MouseMoveEventArgs)

Gets the mouse button which generated the event.

[Visual Basic]
Public Property MouseButtons As MouseButtons
[C#]
public MouseButtons MouseButtons {get; set;}
[C++]
public: __property MouseButtons get_MouseButtons();
public: __property void set_MouseButtons(
   MouseButtons value
);
[C++/CLI]
public:
property MouseButtons MouseButtons {
   MouseButtons get();
   void set (MouseButtons value);
}

See Also

MouseMoveEventArgs Class | MouseMoveEventArgs Members


Shift Property

MouseMoveEventArgs Class | MouseMoveEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Shift Property

PegasusImaging.WinForms.NotateXpress9 Namespace > MouseMoveEventArgs Class : Shift Property (MouseMoveEventArgs)

Gets the shift key state when the event was generated.

[Visual Basic]
Public Property Shift As Integer
[C#]
public int Shift {get; set;}
[C++]
public: __property int get_Shift();
public: __property void set_Shift(
   int value
);
[C++/CLI]
public:
property int Shift {
   int get();
   void set (int value);
}

See Also

MouseMoveEventArgs Class | MouseMoveEventArgs Members


X Property

MouseMoveEventArgs Class | MouseMoveEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

X Property

PegasusImaging.WinForms.NotateXpress9 Namespace > MouseMoveEventArgs Class : X Property (MouseMoveEventArgs)

Gets the x coordinate of the cursor at the end of the mouse move event.

[Visual Basic]
Public Property X As Integer
[C#]
public int X {get; set;}
[C++]
public: __property int get_X();
public: __property void set_X(
   int value
);
[C++/CLI]
public:
property int X {
   int get();
   void set (int value);
}

See Also

MouseMoveEventArgs Class | MouseMoveEventArgs Members


Y Property

MouseMoveEventArgs Class | MouseMoveEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Y Property

PegasusImaging.WinForms.NotateXpress9 Namespace > MouseMoveEventArgs Class : Y Property (MouseMoveEventArgs)

Gets the y coordinate of the cursor at the end of the mouse move event.

[Visual Basic]
Public Property Y As Integer
[C#]
public int Y {get; set;}
[C++]
public: __property int get_Y();
public: __property void set_Y(
   int value
);
[C++/CLI]
public:
property int Y {
   int get();
   void set (int value);
}

See Also

MouseMoveEventArgs Class | MouseMoveEventArgs Members


MouseUpEventArgs Class

MouseUpEventArgs Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

MouseUpEventArgs Class

PegasusImaging.WinForms.NotateXpress9 Namespace : MouseUpEventArgs Class

Arguments for RunmodeEvent event. Used for mouse events during interactive mode.

For a list of all members of this type, see MouseUpEventArgs members.

Object Model

Inheritance Hierarchy

System.Object
System.EventArgs
PegasusImaging.WinForms.NotateXpress9.MouseUpEventArgs

Syntax

[Visual Basic]
Public Class MouseUpEventArgs
   Inherits EventArgs
[C#]
public class MouseUpEventArgs : EventArgs
[C++]
public __gc class MouseUpEventArgs : public EventArgs
[C++/CLI]
public ref class MouseUpEventArgs : public EventArgs

See Also

MouseUpEventArgs Members | PegasusImaging.WinForms.NotateXpress9 Namespace


MouseUpEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

MouseUpEventArgs Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : MouseUpEventArgs Class

MouseUpEventArgs overview

Public Constructors

Public Constructor MouseUpEventArgs Constructor

Public Properties

Public Property Element | Gets the element that was clicked on to generate the event.
Public Property Layer | Gets the layer that was active at the time of the mouse up event.
Public Property MouseButtons | Gets the mouse button that was used to generate the mouse up event.
Public Property Shift | Gets the shift key state when the event was generated.
Public Property X | Gets the x coordinate of the cursor where the mouse up event occured.
Public Property Y | Gets the y coordinate of the cursor where the mouse up event occured.

See Also

MouseUpEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace


MouseUpEventArgs Constructor

MouseUpEventArgs Class | MouseUpEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

MouseUpEventArgs Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > MouseUpEventArgs Class : MouseUpEventArgs Constructor (MouseUpEventArgs)
[Visual Basic]
Public Function New()
[C#]
public MouseUpEventArgs();
[C++]
public: MouseUpEventArgs();
[C++/CLI]
public:
MouseUpEventArgs();

See Also

MouseUpEventArgs Class | MouseUpEventArgs Members


MouseUpEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

MouseUpEventArgs Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : MouseUpEventArgs Class

For a list of all members of this type, see MouseUpEventArgs members.

Public Properties

Public Property Element | Gets the element that was clicked on to generate the event.
Public Property Layer | Gets the layer that was active at the time of the mouse up event.
Public Property MouseButtons | Gets the mouse button that was used to generate the mouse up event.
Public Property Shift | Gets the shift key state when the event was generated.
Public Property X | Gets the x coordinate of the cursor where the mouse up event occured.
Public Property Y | Gets the y coordinate of the cursor where the mouse up event occured.

See Also

MouseUpEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Element Property

MouseUpEventArgs Class | MouseUpEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Element Property

PegasusImaging.WinForms.NotateXpress9 Namespace > MouseUpEventArgs Class : Element Property (MouseUpEventArgs)

Gets the element that was clicked on to generate the event.

[Visual Basic]
Public Property Element As Element
[C#]
public Element Element {get; set;}
[C++]
public: __property Element* get_Element();
public: __property void set_Element(
   Element* value
);
[C++/CLI]
public:
property Element^ Element {
   Element^ get();
   void set (Element^ value);
}

See Also

MouseUpEventArgs Class | MouseUpEventArgs Members


Layer Property

MouseUpEventArgs Class | MouseUpEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Layer Property

PegasusImaging.WinForms.NotateXpress9 Namespace > MouseUpEventArgs Class : Layer Property (MouseUpEventArgs)

Gets the layer that was active at the time of the mouse up event.

[Visual Basic]
Public Property Layer As Layer
[C#]
public Layer Layer {get; set;}
[C++]
public: __property Layer* get_Layer();
public: __property void set_Layer(
   Layer* value
);
[C++/CLI]
public:
property Layer^ Layer {
   Layer^ get();
   void set (Layer^ value);
}

See Also

MouseUpEventArgs Class | MouseUpEventArgs Members


MouseButtons Property

MouseUpEventArgs Class | MouseUpEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

MouseButtons Property

PegasusImaging.WinForms.NotateXpress9 Namespace > MouseUpEventArgs Class : MouseButtons Property (MouseUpEventArgs)

Gets the mouse button that was used to generate the mouse up event.

[Visual Basic]
Public Property MouseButtons As MouseButtons
[C#]
public MouseButtons MouseButtons {get; set;}
[C++]
public: __property MouseButtons get_MouseButtons();
public: __property void set_MouseButtons(
   MouseButtons value
);
[C++/CLI]
public:
property MouseButtons MouseButtons {
   MouseButtons get();
   void set (MouseButtons value);
}

See Also

MouseUpEventArgs Class | MouseUpEventArgs Members


Shift Property

MouseUpEventArgs Class | MouseUpEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Shift Property

PegasusImaging.WinForms.NotateXpress9 Namespace > MouseUpEventArgs Class : Shift Property (MouseUpEventArgs)

Gets the shift key state when the event was generated.

[Visual Basic]
Public Property Shift As Integer
[C#]
public int Shift {get; set;}
[C++]
public: __property int get_Shift();
public: __property void set_Shift(
   int value
);
[C++/CLI]
public:
property int Shift {
   int get();
   void set (int value);
}

See Also

MouseUpEventArgs Class | MouseUpEventArgs Members


X Property

MouseUpEventArgs Class | MouseUpEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

X Property

PegasusImaging.WinForms.NotateXpress9 Namespace > MouseUpEventArgs Class : X Property (MouseUpEventArgs)

Gets the x coordinate of the cursor where the mouse up event occured.

[Visual Basic]
Public Property X As Integer
[C#]
public int X {get; set;}
[C++]
public: __property int get_X();
public: __property void set_X(
   int value
);
[C++/CLI]
public:
property int X {
   int get();
   void set (int value);
}

See Also

MouseUpEventArgs Class | MouseUpEventArgs Members


Y Property

MouseUpEventArgs Class | MouseUpEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Y Property

PegasusImaging.WinForms.NotateXpress9 Namespace > MouseUpEventArgs Class : Y Property (MouseUpEventArgs)

Gets the y coordinate of the cursor where the mouse up event occured.

[Visual Basic]
Public Property Y As Integer
[C#]
public int Y {get; set;}
[C++]
public: __property int get_Y();
public: __property void set_Y(
   int value
);
[C++/CLI]
public:
property int Y {
   int get();
   void set (int value);
}

See Also

MouseUpEventArgs Class | MouseUpEventArgs Members


NoCurrentLayerException Class

NoCurrentLayerException Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NoCurrentLayerException Class

PegasusImaging.WinForms.NotateXpress9 Namespace : NoCurrentLayerException Class

Exception class raised when there is an error with the current layer, or no current layer was created.

For a list of all members of this type, see NoCurrentLayerException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.NotateXpress9.NotateXpressException
PegasusImaging.WinForms.NotateXpress9.NoCurrentLayerException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class NoCurrentLayerException
   Inherits NotateXpressException
   Implements ISerializable, _Exception
[C#]
[SerializableAttribute()]
public sealed class NoCurrentLayerException : NotateXpressException, ISerializable, _Exception
[C++]
[SerializableAttribute()]
public __gc __sealed class NoCurrentLayerException : public NotateXpressException, ISerializable, _Exception
[C++/CLI]
[SerializableAttribute()]
public ref class NoCurrentLayerException sealed : public NotateXpressException, ISerializable, _Exception

See Also

NoCurrentLayerException Members | PegasusImaging.WinForms.NotateXpress9 Namespace


NoCurrentLayerException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NoCurrentLayerException Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : NoCurrentLayerException Class

NoCurrentLayerException overview

Public Constructors

Public Constructor NoCurrentLayerException Constructor Overloaded. Base constructor for the no current layer exception.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

NoCurrentLayerException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


NoCurrentLayerException Constructor

NoCurrentLayerException Class | NoCurrentLayerException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NoCurrentLayerException Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > NoCurrentLayerException Class : NoCurrentLayerException Constructor (NoCurrentLayerException)

Base constructor for the no current layer exception.

Overload List

Base constructor for the no current layer exception.

[Visual Basic] Public Sub New()

[C#] public NoCurrentLayerException();

[C++] public NoCurrentLayerException();

[C++/CLI] public NoCurrentLayerException();

Exception which allows passing in an error number when there is an error with the current layer.

[Visual Basic] Public Sub New(Integer)

[C#] public NoCurrentLayerException(int);

[C++] public NoCurrentLayerException(int);

[C++/CLI] public NoCurrentLayerException(int);

Exception which allows passing in a message when there is an error with the current layer.

[Visual Basic] Public Sub New(String)

[C#] public NoCurrentLayerException(string);

[C++] public NoCurrentLayerException(string*);

[C++/CLI] public NoCurrentLayerException(String^);

Exception which allows passing in an error number and a message when there is an error with the current layer.

[Visual Basic] Public Sub New(Integer,String)

[C#] public NoCurrentLayerException(int,string);

[C++] public NoCurrentLayerException(int,string*);

[C++/CLI] public NoCurrentLayerException(int,String^);

Exception which allows passing in a message and inner exception when there is an error with the current layer.

[Visual Basic] Public Sub New(String,Exception)

[C#] public NoCurrentLayerException(string,Exception);

[C++] public NoCurrentLayerException(string*,Exception*);

[C++/CLI] public NoCurrentLayerException(String^,Exception^);

See Also

NoCurrentLayerException Class | NoCurrentLayerException Members


NoCurrentLayerException Constructor()

NoCurrentLayerException Class | NoCurrentLayerException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NoCurrentLayerException Constructor()

PegasusImaging.WinForms.NotateXpress9 Namespace > NoCurrentLayerException Class > NoCurrentLayerException Constructor : NoCurrentLayerException Constructor()

Base constructor for the no current layer exception.

[Visual Basic]
Public Function New()
[C#]
public NoCurrentLayerException();
[C++]
public: NoCurrentLayerException();
[C++/CLI]
public:
NoCurrentLayerException();

See Also

NoCurrentLayerException Class | NoCurrentLayerException Members | Overload List


NoCurrentLayerException Constructor(Int32)

NoCurrentLayerException Class | NoCurrentLayerException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NoCurrentLayerException Constructor(Int32)

PegasusImaging.WinForms.NotateXpress9 Namespace > NoCurrentLayerException Class > NoCurrentLayerException Constructor : NoCurrentLayerException Constructor(Int32)

Exception which allows passing in an error number when there is an error with the current layer.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public NoCurrentLayerException(
   int errorNumber
);
[C++]
public: NoCurrentLayerException(
   int errorNumber
)
[C++/CLI]
public:
NoCurrentLayerException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

NoCurrentLayerException Class | NoCurrentLayerException Members | Overload List


NoCurrentLayerException Constructor(Int32,String)

NoCurrentLayerException Class | NoCurrentLayerException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NoCurrentLayerException Constructor(Int32,String)

PegasusImaging.WinForms.NotateXpress9 Namespace > NoCurrentLayerException Class > NoCurrentLayerException Constructor : NoCurrentLayerException Constructor(Int32,String)

Exception which allows passing in an error number and a message when there is an error with the current layer.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public NoCurrentLayerException(
   int errorNumber,
   string message
);
[C++]
public: NoCurrentLayerException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
NoCurrentLayerException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

NoCurrentLayerException Class | NoCurrentLayerException Members | Overload List


NoCurrentLayerException Constructor(String)

NoCurrentLayerException Class | NoCurrentLayerException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NoCurrentLayerException Constructor(String)

PegasusImaging.WinForms.NotateXpress9 Namespace > NoCurrentLayerException Class > NoCurrentLayerException Constructor : NoCurrentLayerException Constructor(String)

Exception which allows passing in a message when there is an error with the current layer.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public NoCurrentLayerException(
   string message
);
[C++]
public: NoCurrentLayerException(
   string* message
)
[C++/CLI]
public:
NoCurrentLayerException(
   String^ message
)

Parameters

message
A string which represents the message.

See Also

NoCurrentLayerException Class | NoCurrentLayerException Members | Overload List


NoCurrentLayerException Constructor(String,Exception)

NoCurrentLayerException Class | NoCurrentLayerException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NoCurrentLayerException Constructor(String,Exception)

PegasusImaging.WinForms.NotateXpress9 Namespace > NoCurrentLayerException Class > NoCurrentLayerException Constructor : NoCurrentLayerException Constructor(String,Exception)

Exception which allows passing in a message and inner exception when there is an error with the current layer.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public NoCurrentLayerException(
   string message,
   Exception innerException
);
[C++]
public: NoCurrentLayerException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
NoCurrentLayerException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception.

See Also

NoCurrentLayerException Class | NoCurrentLayerException Members | Overload List


NoSelectionException Class

NoSelectionException Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NoSelectionException Class

PegasusImaging.WinForms.NotateXpress9 Namespace : NoSelectionException Class

Exception class which is raised when there is a no found selection error.

For a list of all members of this type, see NoSelectionException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.NotateXpress9.NotateXpressException
PegasusImaging.WinForms.NotateXpress9.NoSelectionException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class NoSelectionException
   Inherits NotateXpressException
   Implements ISerializable, _Exception
[C#]
[SerializableAttribute()]
public sealed class NoSelectionException : NotateXpressException, ISerializable, _Exception
[C++]
[SerializableAttribute()]
public __gc __sealed class NoSelectionException : public NotateXpressException, ISerializable, _Exception
[C++/CLI]
[SerializableAttribute()]
public ref class NoSelectionException sealed : public NotateXpressException, ISerializable, _Exception

See Also

NoSelectionException Members | PegasusImaging.WinForms.NotateXpress9 Namespace


NoSelectionException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NoSelectionException Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : NoSelectionException Class

NoSelectionException overview

Public Constructors

Public Constructor NoSelectionException Constructor Overloaded. Main constructor for the NoSelectionException class when there is a no found selection error.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

NoSelectionException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


NoSelectionException Constructor

NoSelectionException Class | NoSelectionException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NoSelectionException Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > NoSelectionException Class : NoSelectionException Constructor (NoSelectionException)

Main constructor for the NoSelectionException class when there is a no found selection error.

Overload List

Main constructor for the NoSelectionException class when there is a no found selection error.

[Visual Basic] Public Sub New()

[C#] public NoSelectionException();

[C++] public NoSelectionException();

[C++/CLI] public NoSelectionException();

Exception which allows passing in an error number when there is a no found selection error.

[Visual Basic] Public Sub New(Integer)

[C#] public NoSelectionException(int);

[C++] public NoSelectionException(int);

[C++/CLI] public NoSelectionException(int);

Exception which allows passing in a message when there is a no found selection error.

[Visual Basic] Public Sub New(String)

[C#] public NoSelectionException(string);

[C++] public NoSelectionException(string*);

[C++/CLI] public NoSelectionException(String^);

Exception which allows passing in an error number and message when there is a no found selection error.

[Visual Basic] Public Sub New(Integer,String)

[C#] public NoSelectionException(int,string);

[C++] public NoSelectionException(int,string*);

[C++/CLI] public NoSelectionException(int,String^);

Exception which allows passing in a message and inner exception when there is a no found selection error.

[Visual Basic] Public Sub New(String,Exception)

[C#] public NoSelectionException(string,Exception);

[C++] public NoSelectionException(string*,Exception*);

[C++/CLI] public NoSelectionException(String^,Exception^);

See Also

NoSelectionException Class | NoSelectionException Members


NoSelectionException Constructor()

NoSelectionException Class | NoSelectionException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NoSelectionException Constructor()

PegasusImaging.WinForms.NotateXpress9 Namespace > NoSelectionException Class > NoSelectionException Constructor : NoSelectionException Constructor()

Main constructor for the NoSelectionException class when there is a no found selection error.

[Visual Basic]
Public Function New()
[C#]
public NoSelectionException();
[C++]
public: NoSelectionException();
[C++/CLI]
public:
NoSelectionException();

See Also

NoSelectionException Class | NoSelectionException Members | Overload List


NoSelectionException Constructor(Int32)

NoSelectionException Class | NoSelectionException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NoSelectionException Constructor(Int32)

PegasusImaging.WinForms.NotateXpress9 Namespace > NoSelectionException Class > NoSelectionException Constructor : NoSelectionException Constructor(Int32)

Exception which allows passing in an error number when there is a no found selection error.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public NoSelectionException(
   int errorNumber
);
[C++]
public: NoSelectionException(
   int errorNumber
)
[C++/CLI]
public:
NoSelectionException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

NoSelectionException Class | NoSelectionException Members | Overload List


NoSelectionException Constructor(Int32,String)

NoSelectionException Class | NoSelectionException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NoSelectionException Constructor(Int32,String)

PegasusImaging.WinForms.NotateXpress9 Namespace > NoSelectionException Class > NoSelectionException Constructor : NoSelectionException Constructor(Int32,String)

Exception which allows passing in an error number and message when there is a no found selection error.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public NoSelectionException(
   int errorNumber,
   string message
);
[C++]
public: NoSelectionException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
NoSelectionException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

NoSelectionException Class | NoSelectionException Members | Overload List


NoSelectionException Constructor(String)

NoSelectionException Class | NoSelectionException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NoSelectionException Constructor(String)

PegasusImaging.WinForms.NotateXpress9 Namespace > NoSelectionException Class > NoSelectionException Constructor : NoSelectionException Constructor(String)

Exception which allows passing in a message when there is a no found selection error.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public NoSelectionException(
   string message
);
[C++]
public: NoSelectionException(
   string* message
)
[C++/CLI]
public:
NoSelectionException(
   String^ message
)

Parameters

message
A string which represents the message.

See Also

NoSelectionException Class | NoSelectionException Members | Overload List


NoSelectionException Constructor(String,Exception)

NoSelectionException Class | NoSelectionException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NoSelectionException Constructor(String,Exception)

PegasusImaging.WinForms.NotateXpress9 Namespace > NoSelectionException Class > NoSelectionException Constructor : NoSelectionException Constructor(String,Exception)

Exception which allows passing in a message and inner exception when there is a no found selection error.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public NoSelectionException(
   string message,
   Exception innerException
);
[C++]
public: NoSelectionException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
NoSelectionException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception.

See Also

NoSelectionException Class | NoSelectionException Members | Overload List


NotateXpress Class

NotateXpress Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NotateXpress Class

PegasusImaging.WinForms.NotateXpress9 Namespace : NotateXpress Class

Summary description for NotateXpress.

For a list of all members of this type, see NotateXpress members.

Object Model

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
PegasusImaging.WinForms.NotateXpress9.NotateXpress

Syntax

[Visual Basic]
<ToolboxBitmapAttribute()>
Public Class NotateXpress
   Inherits Component
   Implements IComponent, IDisposable
[C#]
[ToolboxBitmapAttribute()]
public class NotateXpress : Component, IComponent, IDisposable
[C++]
[ToolboxBitmapAttribute()]
public __gc class NotateXpress : public Component, IComponent, IDisposable
[C++/CLI]
[ToolboxBitmapAttribute()]
public ref class NotateXpress : public Component, IComponent, IDisposable

See Also

NotateXpress Members | PegasusImaging.WinForms.NotateXpress9 Namespace


NotateXpress Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NotateXpress Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : NotateXpress Class

NotateXpress overview

Public Constructors

Public Constructor NotateXpress Constructor Overloaded. The default constructor for the NotateXpress class.

Public Properties

Public Property AllowPaint | Gets and sets whether annotations are painted and rendered to the display.
Public Property ClientWindow | Gets and sets which ImagXpress viewer (ImageXView object) to annotate.
Public Property Container (Inherited from System.ComponentModel.Component) | Gets the IContainer that contains the Component.
Public Property Debug | Gets and sets whether NotateXpress is in debug mode.
Public Property DebugErrorLevel | Gets and sets the level of detail to record in the NotateXpress.DebugLogFile.
Public Property DebugLogFile | Gets and sets the debug log file for writting debug information.
Public Property ErrorLevel | Obsolete function Please use DebugErrorLevel instead. Gets and sets the level of detail to record in the NotateXpress.DebugLogFile.
Public Property FontScaling | FontScaling is an enumerated type that determines how a font is scaled relative to an image’s vertical resolution DPI.
Public Property ImagXpressLoad | The ImagXpressLoad property sets or returns whether annotations are loaded from a Tiff file when a Tiff file containing annotations is loaded by ImagXpress.
Public Property ImagXpressSave | Gets or sets whether annotations are saved into a Tiff file when the ImagXpress Save method is executed.
Public Property InteractMode | Gets and sets whether the annotations are in interactive mode or not.
Public Property Layers | The Layer class contains attributes for elements, groups and toolbars.
Public Property LineScaling | Gets and sets how all lines are scaled relative to an image’s vertical resolution DPI.
Public Property MultiLineEdit | Gets and sets whether to use a standard Multi-line edit control to edit text.
Public Property NoteIcon | Gets and sets the icon associated with the Notetool.
Public Property PageNumber | Gets and sets the page number.
Public Property RecalibrateXdpi | Gets and sets the x (horizontal) coordinate value for the DPI (dots per inch).
Public Property RecalibrateYdpi | Gets and sets the y (vertical) coordinate value for the DPI (dots per inch).
Public Property Site (Inherited from System.ComponentModel.Component) | Gets or sets the ISite of the Component.
Public Property ToolbarDefaults | Gets and sets access to all of the global toolbar defaults.
Public Property ToolTipTimeEdit | Gets or sets the amount of time to display tooltip window in Edit mode.
Public Property ToolTipTimeInteractive | Gets or sets the amount of time a tooltip window remains visible.
Public Property Update | Gets and sets whether annotations render to the display.

Public Methods

Public Method AboutBox | Displays an information dialog box describing the NotateXpress component.
Public Method ClientDisconnect | Disconnects the NotateXpress object from the client ImageXView object.
Public Method CreateObjRef (Inherited from System.MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Public Method Dispose (Inherited from System.ComponentModel.Component) | Releases all resources used by the Component.
Public Method ForceAllUpdate | When multiple ImageXView objects are pointed to the same ImageX image, ForceAllUpdate synchronizes all NotateXpress objects to the current NotateXpress' data.
Public Method GetImageMappingDimensions | Gets the mapping width and height coordinates when NotateXpress cannot query ImagXpress for current image dimensions.
Public Method GetLifetimeService (Inherited from System.MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
Public Method GetUseCursorType | Returns a value indicating if a distinctive cursor is used for a specific type of operation (creating, moving, or selecting objects).
Public Method GetUseCustomCursorType | Uses custom cursors instead of built in ones.
Public Method InitializeLifetimeService (Inherited from System.MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Public Method MenuAddItem | Adds a user-defined item to the Context Menu. This method lets you add new items to the Context Menu and receive event notifications when these items are selected.
Public Method MenuChangeItem | This changes the specified menu item from the specified menu.
Public Method MenuDeleteItem | Removes the specified item from the specified menu.
Public Method MenuGetEnabled | Returns whether or not the specified menu will display when the right mouse button is clicked over the appropriate area
Public Method MenuGetFirstItemId | Gets the first menuId on the specified level from the specified menu.
Public Method MenuGetItem | Returns the text that will be displayed for the specified topMenuID and subMenuID on the menu.
Public Method MenuGetItemChecked | Returns the Checked attribute of the specified menu item on the specified menu item.
Public Method MenuGetItemEnabled | Gets the Enabled attribute of the specified menu item on the specified menu item.
Public Method MenuGetItemVisible | Gets the Visible attribute of the specified menu item on the specified menu item.
Public Method MenuGetNextItemId | Gets the subsequent menuId on the specified level from the specified menu after a calling MenuGetFirstItemId.
Public Method MenuSetEnabled | Sets whether or not the specified menu will display when the right mouse button is clicked over the appropriate area.
Public Method MenuSetItemChecked | Sets the Checked attribute of the specified menu item on the specified menu item.
Public Method MenuSetItemEnabled | Sets the Enabled attribute of the specified menu item on the specified menu item.
Public Method MenuSetItemVisible | Sets the Visible attribute of the specified menu item on the specified menu item.
Public Method SetImageMappingDimensions | Sets a given mapping width and height.
Public Method SetUseCursorType | Returns an indicator if a distinctive cursor is used for a specific type of operation (creating, moving, or selecting objects).
Public Method SetUseCustomCursorType | This is for replacing the built in cursors that are created by turning on SetUseCursorType.
Public Method ToString (Inherited from System.ComponentModel.Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Public Method UserDataAdd | Adds the specified key value pair to the list.
Public Method UserDataDelete | Deletes an existing key value pair which matches the given key.
Public Method UserDataFind | User data can be added to each page in a key value pair.
Public Method UserDataFindFirst | Finds the first key value pair in the list.
Public Method UserDataFindNext | Finds the next key value pair in the list.

Public Events

Public Event AnnotationAdded | Fires when an annotation has been added.
Public Event AnnotationDeleted | Fires when an annotation has been deleted.
Public Event AnnotationEndSelected | Fires when no annotations are selected.
Public Event AnnotationMoved | Fires when an annotation has been moved.
Public Event AnnotationSelected | Fires when an annotation has been selected.
Public Event Click | Occurs when an annotation object is clicked in Interactive Mode.
Public Event ContextMenu | Occurs when an element is right clicked in edit mode, and the built in NotateXpress context menu is turned off.
Public Event CurrentLayerChange | The CurrentLayerChange Event is fired whenever the current layer changes.
Public Event Disposed (Inherited from System.ComponentModel.Component) | Adds an event handler to listen to the Disposed event on the component.
Public Event DoubleClick | Occurs when an annotation object is double clicked in Interactive Mode.
Public Event Dropped | Fires when xfdf annotations that are not supported by NotateXpress are read in.
Public Event GroupDeselected | Fired when an annotation group is unselected
Public Event GroupSelected | Fired when an annotation group is selected
Public Event ItemChanged | The ItemChanged event is sent when an annotation object changes. When an object is moved or resized by the user, an AnnotationMoved is fired.
Public Event LayerRestored | The LayerRestored Event is fired for each layer restored during the loading of a previously saved annotation file.
Public Event MappingInput | This event is for an advanced user who wants to change how NotateXpress does its coordinate conversions.
Public Event MappingOutput | This event is for an advanced user who wants to change how NotateXpress does its coordinate conversions.
Public Event MenuSelect | The MenuSelect event is fired when a user chooses any of the items on the NotateXpress context menu while over an annotation or on the toolbar.
Public Event MouseDown | Occurs when an annotation object receives a MouseDown event in Interactive Mode.
Public Event MouseMove | Occurs when the mouse is moved over an annotation object in Interactive Mode.
Public Event MouseUp | Occurs when an annotation object receives a MouseUp event in Interactive Mode.
Public Event RequestLayerPassword | The RequestLayerPassword event is sent during the loading of an annotation file for all layers that were saved with a password.
Public Event Stamping | The Stamping event is sent immediately before each stamp tool use, providing an opportunity to change the stamp text of the annotation object before it is added.
Public Event TextEditEnd | Fired when text editing has ended. Editing is now disabled
Public Event TextEditStart | Fired when The user has double-clicked a text item and editing is now enabled.
Public Event ToolbarSelect | The ToolbarSelect event is fired when a selection changes for the current tool on the toolbar.
Public Event UserDraw | The UserDraw event is raised for a Rectangle object during its paint when the Rectangle’s UserDraw attribute is True.
Public Event UserGroupCreated | The UserGroupCreated event is sent when a user creates a new group by selecting multiple objects and then pressing Ctrl-G.
Public Event UserGroupDestroyed | The UserGroupDestroyed event is sent when a user destroys a selected group by pressing Ctrl-U.

See Also

NotateXpress Class | PegasusImaging.WinForms.NotateXpress9 Namespace


NotateXpress Constructor

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NotateXpress Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : NotateXpress Constructor (NotateXpress)

The default constructor for the NotateXpress class.

Overload List

The default constructor for the NotateXpress class.

[Visual Basic] Public Sub New()

[C#] public NotateXpress();

[C++] public NotateXpress();

[C++/CLI] public NotateXpress();

Initializes the container.

[Visual Basic] Public Sub New(IContainer)

[C#] public NotateXpress(IContainer);

[C++] public NotateXpress(IContainer*);

[C++/CLI] public NotateXpress(IContainer^);

See Also

NotateXpress Class | NotateXpress Members


NotateXpress Constructor()

NotateXpress Class | NotateXpress Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NotateXpress Constructor()

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class > NotateXpress Constructor : NotateXpress Constructor()

The default constructor for the NotateXpress class.

[Visual Basic]
Public Function New()
[C#]
public NotateXpress();
[C++]
public: NotateXpress();
[C++/CLI]
public:
NotateXpress();

Remarks

This is the main class for using annotations.

See Also

NotateXpress Class | NotateXpress Members | Overload List


NotateXpress Constructor(IContainer)

NotateXpress Class | NotateXpress Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

container
The container.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NotateXpress Constructor(IContainer)

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class > NotateXpress Constructor : NotateXpress Constructor(IContainer)

Initializes the container.

[Visual Basic]
Public Function New( _
   ByVal container As IContainer _
)
[C#]
public NotateXpress(
   IContainer container
);
[C++]
public: NotateXpress(
   IContainer* container
)
[C++/CLI]
public:
NotateXpress(
   IContainer^ container
)

Parameters

container
The container.

See Also

NotateXpress Class | NotateXpress Members | Overload List


AboutBox Method

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

AboutBox Method

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : AboutBox Method

Displays an information dialog box describing the NotateXpress component.

[Visual Basic]
Public Sub AboutBox()
[C#]
public void AboutBox();
[C++]
public: void AboutBox();
[C++/CLI]
public:
void AboutBox();

See Also

NotateXpress Class | NotateXpress Members


ClientDisconnect Method

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ClientDisconnect Method

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : ClientDisconnect Method

Disconnects the NotateXpress object from the client ImageXView object.

[Visual Basic]
Public Sub ClientDisconnect()
[C#]
public void ClientDisconnect();
[C++]
public: void ClientDisconnect();
[C++/CLI]
public:
void ClientDisconnect();

Remarks

Note: This is equivalent to setting the ClientWindow to Zero.

See Also

NotateXpress Class | NotateXpress Members


ForceAllUpdate Method

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ForceAllUpdate Method

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : ForceAllUpdate Method

When multiple ImageXView objects are pointed to the same ImageX image, ForceAllUpdate synchronizes all NotateXpress objects to the current NotateXpress' data.

[Visual Basic]
Public Sub ForceAllUpdate()
[C#]
public void ForceAllUpdate();
[C++]
public: void ForceAllUpdate();
[C++/CLI]
public:
void ForceAllUpdate();

Example

How to syncronize two views

[C#]

notateXpress1.ClientWindow = imageXView1.Handle;
notateXpress2.ClientWindow = imageXView2.Handle;
imageXView1.Image = PegasusImaging.WinForms.ImagXpress9.ImageX.FromFile(ImagXpress1, "c:\\images\\MyFirstImage.tif");

// Make sure the second image is not loaded, but referenced to the first image
imageXView2.Image =
imageXView1.Image;
PegasusImaging.WinForms.NotateXpress9.Layer layer1 = new PegasusImaging.WinForms.NotateXpress9.Layer();
notateXpress1.Layers.Add(layer1);

// Turn on the toolbar on the first imagXView for drawing
notateXpress1.ToolbarDefaults.ToolbarActivated = true;

// AFTER interactive or programmatic drawing is complete

// call ForceAllUpdate to send annotations from notateXpress1 to notateXpress2
private void
buttonFAU_Click(object sender, EventArgs e)
{
notateXpress1.ForceAllUpdate();
}

See Also

NotateXpress Class | NotateXpress Members


GetImageMappingDimensions Method

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

width
An integer which represents the width, in pixels, to use to map annotation coordinates.
height
An integer which represents the height, in pixels, to use to map annotation coordinates.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetImageMappingDimensions Method

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : GetImageMappingDimensions Method

Gets the mapping width and height coordinates when NotateXpress cannot query ImagXpress for current image dimensions.

[Visual Basic]
Public Sub GetImageMappingDimensions( _
   ByRef width As Integer, _
   ByRef height As Integer _
)
[C#]
public void GetImageMappingDimensions(
   out int width,
   out int height
);
[C++]
public: void GetImageMappingDimensions(
   [PARAMFLAG::Out] int width,
   [PARAMFLAG::Out] int height
)
[C++/CLI]
public:
void GetImageMappingDimensions(
   [Out] int width,
   [Out] int height
)

Parameters

width
An integer which represents the width, in pixels, to use to map annotation coordinates.
height
An integer which represents the height, in pixels, to use to map annotation coordinates.

Remarks

When ImagXpress is not attached to NotateXpress and you load an annotation file, NotateXpress cannot query ImagXpress for its current image dimensions when mapping annotation coordinates. The SetImageMappingDimensions lets you set a mapping width and height for this circumstance. The values set by this method will only be used when ImagXpress is not attached to NotateXpress.

This should be an exceptional case.

See Also

NotateXpress Class | NotateXpress Members


GetUseCursorType Method

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

cursorType
The CursorSelection enumeration value set.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetUseCursorType Method

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : GetUseCursorType Method

Returns a value indicating if a distinctive cursor is used for a specific type of operation (creating, moving, or selecting objects).

[Visual Basic]
Public Function GetUseCursorType( _
   ByVal cursorType As CursorSelection _
) As Boolean
[C#]
public bool GetUseCursorType(
   CursorSelection cursorType
);
[C++]
public: bool GetUseCursorType(
   CursorSelection cursorType
)
[C++/CLI]
public:
bool GetUseCursorType(
   CursorSelection cursorType
)

Parameters

cursorType
The CursorSelection enumeration value set.

Return Type

A boolean value which is true to use a distinctive cursor. Otherwise, false is returned.

Remarks

The default value is true.

See Also

NotateXpress Class | NotateXpress Members


GetUseCustomCursorType Method

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

cursorType
The CursorSelection type of the cursor to use.
tool
The AnnotationTool for the specified cursor type.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetUseCustomCursorType Method

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : GetUseCustomCursorType Method

Uses custom cursors instead of built in ones.

[Visual Basic]
Public Function GetUseCustomCursorType( _
   ByVal cursorType As CursorSelection, _
   ByVal tool As AnnotationTool _
) As IntPtr
[C#]
public IntPtr GetUseCustomCursorType(
   CursorSelection cursorType,
   AnnotationTool tool
);
[C++]
public: IntPtr GetUseCustomCursorType(
   CursorSelection cursorType,
   AnnotationTool tool
)
[C++/CLI]
public:
IntPtr GetUseCustomCursorType(
   CursorSelection cursorType,
   AnnotationTool tool
)

Parameters

cursorType
The CursorSelection type of the cursor to use.
tool
The AnnotationTool for the specified cursor type.

Return Type

The handle to a cursor.

Remarks

This returns the handle that the user passed in during SetUseCustomCursorType.

See Also

NotateXpress Class | NotateXpress Members


MenuAddItem Method

NotateXpress Class | NotateXpress Members | TopMenuId Enumeration | SubMenuId Enumeration | TopMenuId Enumeration | SubMenuId Enumeration | TopMenuId Enumeration | SubMenuId Enumeration | TopMenuId Enumeration | SubMenuId Enumeration | TopMenuId Enumeration | SubMenuId Enumeration | TopMenuId Enumeration | SubMenuId Enumeration | TopMenuId Enumeration | SubMenuId Enumeration | TopMenuId Enumeration | SubMenuId Enumeration | TopMenuId Enumeration | SubMenuId Enumeration | TopMenuId Enumeration | SubMenuId Enumeration | TopMenuId Enumeration | SubMenuId Enumeration

Language

Visual Basic

C#

C++

C++/CLI

Show All

menuType
The MenuType Context or Toolbar.
tool
If the menuType is Toolbar, then the Tool parameter is the Tool Id that the menu is associated with. An annotationTOOL enumeration. If the menuType is Context, the Tool parameter has no meaning and can be any value.
topMenuId
Top-level menu Id for this menu item. A menu id of 4100-4200 is reserved for adding a menu separator bar. The topMenuId of the new item MUST be 20000 or greater for user added items.
subMenuId
Sub-level menu Id for this menu item, if this is to add a sub-level menu item otherwise this parameter should be 0.
menuText
The text that will be displayed for this menu item
user1
A long value that will be passed back in a MenuSelect event.
user2
A long value that will be passed back in a MenuSelect event.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

MenuAddItem Method

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : MenuAddItem Method

Adds a user-defined item to the Context Menu. This method lets you add new items to the Context Menu and receive event notifications when these items are selected.

[Visual Basic]
Public Sub MenuAddItem( _
   ByVal menuType As MenuType, _
   ByVal tool As AnnotationTool, _
   ByVal topMenuId As Integer, _
   ByVal subMenuId As Integer, _
   ByVal menuText As String, _
   ByVal user1 As Integer, _
   ByVal user2 As Integer _
)
[C#]
public void MenuAddItem(
   MenuType menuType,
   AnnotationTool tool,
   int topMenuId,
   int subMenuId,
   string menuText,
   int user1,
   int user2
);
[C++]
public: void MenuAddItem(
   MenuType menuType,
   AnnotationTool tool,
   int topMenuId,
   int subMenuId,
   string* menuText,
   int user1,
   int user2
)
[C++/CLI]
public:
void MenuAddItem(
   MenuType menuType,
   AnnotationTool tool,
   int topMenuId,
   int subMenuId,
   String^ menuText,
   int user1,
   int user2
)

Parameters

menuType
The MenuType Context or Toolbar.
tool
If the menuType is Toolbar, then the Tool parameter is the Tool Id that the menu is associated with. An annotationTOOL enumeration. If the menuType is Context, the Tool parameter has no meaning and can be any value.
topMenuId
Top-level menu Id for this menu item. A menu id of 4100-4200 is reserved for adding a menu separator bar. The topMenuId of the new item MUST be 20000 or greater for user added items.
subMenuId
Sub-level menu Id for this menu item, if this is to add a sub-level menu item otherwise this parameter should be 0.
menuText
The text that will be displayed for this menu item
user1
A long value that will be passed back in a MenuSelect event.
user2
A long value that will be passed back in a MenuSelect event.

Remarks

See the TopMenuId and SubMenuId enumerations for a list of predefined data.

See Also

NotateXpress Class | NotateXpress Members | TopMenuId Enumeration | SubMenuId Enumeration | TopMenuId Enumeration | SubMenuId Enumeration | TopMenuId Enumeration | SubMenuId Enumeration | TopMenuId Enumeration | SubMenuId Enumeration | TopMenuId Enumeration | SubMenuId Enumeration | TopMenuId Enumeration | SubMenuId Enumeration | TopMenuId Enumeration | SubMenuId Enumeration | TopMenuId Enumeration | SubMenuId Enumeration | TopMenuId Enumeration | SubMenuId Enumeration | TopMenuId Enumeration | SubMenuId Enumeration | TopMenuId Enumeration | SubMenuId Enumeration


MenuChangeItem Method

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

menuType
The MenuType enumeration which contains the item to change.
tool
If the menuType is Toolbar, then the Tool parameter is the Tool Id that the menu is associated with. An annotationTOOL enumeration. If the menuType is Context, the Tool parameter has no meaning and can be any value.
topMenuId
An integer which represents the top-level menu ID of the item in the menu. For built in menus, see the TopMenuId enumeration.
subMenuId
An integer which represents the item in the menu (subMenuId is 0 when the item is a top menu item). For built in menus, see the SubMenuId enumeration.
menuText
The new text.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

MenuChangeItem Method

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : MenuChangeItem Method

This changes the specified menu item from the specified menu.

[Visual Basic]
Public Function MenuChangeItem( _
   ByVal menuType As MenuType, _
   ByVal tool As AnnotationTool, _
   ByVal topMenuId As Integer, _
   ByVal subMenuId As Integer, _
   ByVal menuText As String _
) As Boolean
[C#]
public bool MenuChangeItem(
   MenuType menuType,
   AnnotationTool tool,
   int topMenuId,
   int subMenuId,
   string menuText
);
[C++]
public: bool MenuChangeItem(
   MenuType menuType,
   AnnotationTool tool,
   int topMenuId,
   int subMenuId,
   string* menuText
)
[C++/CLI]
public:
bool MenuChangeItem(
   MenuType menuType,
   AnnotationTool tool,
   int topMenuId,
   int subMenuId,
   String^ menuText
)

Parameters

menuType
The MenuType enumeration which contains the item to change.
tool
If the menuType is Toolbar, then the Tool parameter is the Tool Id that the menu is associated with. An annotationTOOL enumeration. If the menuType is Context, the Tool parameter has no meaning and can be any value.
topMenuId
An integer which represents the top-level menu ID of the item in the menu. For built in menus, see the TopMenuId enumeration.
subMenuId
An integer which represents the item in the menu (subMenuId is 0 when the item is a top menu item). For built in menus, see the SubMenuId enumeration.
menuText
The new text.

See Also

NotateXpress Class | NotateXpress Members


MenuDeleteItem Method

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

menuType
The MenuType enumeration to remove from.
tool
If the menuType is Toolbar, then the Tool parameter is the Tool Id that the menu is associated with. An annotationTOOL enumeration. If the menuType is Context, the Tool parameter has no meaning and can be any value.
topMenuId
An integer which represents the top-level menu ID of the item in the menu. For built in menus, see the TopMenuId enumeration.
subMenuId
An integer which represents the item in the menu (subMenuId is 0 when the item is a top menu item). For built in menus, see the SubMenuId enumeration.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

MenuDeleteItem Method

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : MenuDeleteItem Method

Removes the specified item from the specified menu.

[Visual Basic]
Public Function MenuDeleteItem( _
   ByVal menuType As MenuType, _
   ByVal tool As AnnotationTool, _
   ByVal topMenuId As Integer, _
   ByVal subMenuId As Integer _
) As Boolean
[C#]
public bool MenuDeleteItem(
   MenuType menuType,
   AnnotationTool tool,
   int topMenuId,
   int subMenuId
);
[C++]
public: bool MenuDeleteItem(
   MenuType menuType,
   AnnotationTool tool,
   int topMenuId,
   int subMenuId
)
[C++/CLI]
public:
bool MenuDeleteItem(
   MenuType menuType,
   AnnotationTool tool,
   int topMenuId,
   int subMenuId
)

Parameters

menuType
The MenuType enumeration to remove from.
tool
If the menuType is Toolbar, then the Tool parameter is the Tool Id that the menu is associated with. An annotationTOOL enumeration. If the menuType is Context, the Tool parameter has no meaning and can be any value.
topMenuId
An integer which represents the top-level menu ID of the item in the menu. For built in menus, see the TopMenuId enumeration.
subMenuId
An integer which represents the item in the menu (subMenuId is 0 when the item is a top menu item). For built in menus, see the SubMenuId enumeration.

Remarks

If a top-level menu item is deleted, all sub-level menu items are deleted as well.

If the TopMenuId and SubLevelId are both set to 0, then the entire menu is cleared.

See Also

NotateXpress Class | NotateXpress Members


MenuGetEnabled Method

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

menuType
The MenuType to display.
tool
If the menuType is Toolbar, then the Tool parameter is the Tool Id that the menu is associated with. An annotationTOOL enumeration. If the menuType is Context, the Tool parameter has no meaning and can be any value.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

MenuGetEnabled Method

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : MenuGetEnabled Method

Returns whether or not the specified menu will display when the right mouse button is clicked over the appropriate area

[Visual Basic]
Public Function MenuGetEnabled( _
   ByVal menuType As MenuType, _
   ByVal tool As AnnotationTool _
) As Boolean
[C#]
public bool MenuGetEnabled(
   MenuType menuType,
   AnnotationTool tool
);
[C++]
public: bool MenuGetEnabled(
   MenuType menuType,
   AnnotationTool tool
)
[C++/CLI]
public:
bool MenuGetEnabled(
   MenuType menuType,
   AnnotationTool tool
)

Parameters

menuType
The MenuType to display.
tool
If the menuType is Toolbar, then the Tool parameter is the Tool Id that the menu is associated with. An annotationTOOL enumeration. If the menuType is Context, the Tool parameter has no meaning and can be any value.

See Also

NotateXpress Class | NotateXpress Members


MenuGetFirstItemId Method

NotateXpress Class | NotateXpress Members | MenuGetNextItemId Method | MenuGetNextItemId Method | MenuGetNextItemId Method | MenuGetNextItemId Method | MenuGetNextItemId Method | MenuGetNextItemId Method | MenuGetNextItemId Method

Language

Visual Basic

C#

C++

C++/CLI

Show All

menuType
A MenuType enumeration value.
tool
If the menuType is Toolbar, then the Tool parameter is the Tool Id that the menu is associated with. An annotationTOOL enumeration. If the menuType is Context, the Tool parameter has no meaning and can be any value.
topMenuId
An integer which represents the top-level menu ID of the item in the menu. For built in menus, see the TopMenuId enumeration.
subMenuId
An integer which represents the item in the menu (subMenuId is 0 when the item is a top menu item). For built in menus, see the SubMenuId enumeration.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

MenuGetFirstItemId Method

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : MenuGetFirstItemId Method

Gets the first menuId on the specified level from the specified menu.

[Visual Basic]
Public Sub MenuGetFirstItemId( _
   ByVal menuType As MenuType, _
   ByVal tool As AnnotationTool, _
   ByRef topMenuId As Integer, _
   ByRef subMenuId As Integer _
)
[C#]
public void MenuGetFirstItemId(
   MenuType menuType,
   AnnotationTool tool,
   out int topMenuId,
   out int subMenuId
);
[C++]
public: void MenuGetFirstItemId(
   MenuType menuType,
   AnnotationTool tool,
   [PARAMFLAG::Out] int topMenuId,
   [PARAMFLAG::Out] int subMenuId
)
[C++/CLI]
public:
void MenuGetFirstItemId(
   MenuType menuType,
   AnnotationTool tool,
   [Out] int topMenuId,
   [Out] int subMenuId
)

Parameters

menuType
A MenuType enumeration value.
tool
If the menuType is Toolbar, then the Tool parameter is the Tool Id that the menu is associated with. An annotationTOOL enumeration. If the menuType is Context, the Tool parameter has no meaning and can be any value.
topMenuId
An integer which represents the top-level menu ID of the item in the menu. For built in menus, see the TopMenuId enumeration.
subMenuId
An integer which represents the item in the menu (subMenuId is 0 when the item is a top menu item). For built in menus, see the SubMenuId enumeration.

See Also

NotateXpress Class | NotateXpress Members | MenuGetNextItemId Method | MenuGetNextItemId Method | MenuGetNextItemId Method | MenuGetNextItemId Method | MenuGetNextItemId Method | MenuGetNextItemId Method | MenuGetNextItemId Method


MenuGetItem Method

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

menuType
A MenuType enumeration value.
tool
If the menuType is Toolbar, then the Tool parameter is the Tool Id that the menu is associated with. An annotationTOOL enumeration. If the menuType is Context, the Tool parameter has no meaning and can be any value.
topMenuId
An integer which represents the top-level menu ID of the item in the menu. For built in menus, see the TopMenuId enumeration.
subMenuId
An integer which represents the item in the menu (subMenuId is 0 when the item is a top menu item). For built in menus, see the SubMenuId enumeration.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

MenuGetItem Method

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : MenuGetItem Method

Returns the text that will be displayed for the specified topMenuID and subMenuID on the menu.

[Visual Basic]
Public Function MenuGetItem( _
   ByVal menuType As MenuType, _
   ByVal tool As AnnotationTool, _
   ByVal topMenuId As Integer, _
   ByVal subMenuId As Integer _
) As String
[C#]
public string MenuGetItem(
   MenuType menuType,
   AnnotationTool tool,
   int topMenuId,
   int subMenuId
);
[C++]
public: string* MenuGetItem(
   MenuType menuType,
   AnnotationTool tool,
   int topMenuId,
   int subMenuId
)
[C++/CLI]
public:
String^ MenuGetItem(
   MenuType menuType,
   AnnotationTool tool,
   int topMenuId,
   int subMenuId
)

Parameters

menuType
A MenuType enumeration value.
tool
If the menuType is Toolbar, then the Tool parameter is the Tool Id that the menu is associated with. An annotationTOOL enumeration. If the menuType is Context, the Tool parameter has no meaning and can be any value.
topMenuId
An integer which represents the top-level menu ID of the item in the menu. For built in menus, see the TopMenuId enumeration.
subMenuId
An integer which represents the item in the menu (subMenuId is 0 when the item is a top menu item). For built in menus, see the SubMenuId enumeration.

See Also

NotateXpress Class | NotateXpress Members


MenuGetItemChecked Method

NotateXpress Class | NotateXpress Members | MenuSetItemChecked Method | MenuGetItemEnabled Method | MenuSetItemEnabled Method | MenuGetItemVisible Method | MenuSetItemVisible Method | MenuSetEnabled Method | MenuSetItemChecked Method | MenuGetItemEnabled Method | MenuSetItemEnabled Method | MenuGetItemVisible Method | MenuSetItemVisible Method | MenuSetEnabled Method | MenuSetItemChecked Method | MenuGetItemEnabled Method | MenuSetItemEnabled Method | MenuGetItemVisible Method | MenuSetItemVisible Method | MenuSetEnabled Method | MenuSetItemChecked Method | MenuGetItemEnabled Method | MenuSetItemEnabled Method | MenuGetItemVisible Method | MenuSetItemVisible Method | MenuSetEnabled Method | MenuSetItemChecked Method | MenuGetItemEnabled Method | MenuSetItemEnabled Method | MenuGetItemVisible Method | MenuSetItemVisible Method | MenuSetEnabled Method | MenuSetItemChecked Method | MenuGetItemEnabled Method | MenuSetItemEnabled Method | MenuGetItemVisible Method | MenuSetItemVisible Method | MenuSetEnabled Method | MenuSetItemChecked Method | MenuGetItemEnabled Method | MenuSetItemEnabled Method | MenuGetItemVisible Method | MenuSetItemVisible Method | MenuSetEnabled Method

Language

Visual Basic

C#

C++

C++/CLI

Show All

menuType
A MenuType enumeration value.
tool
If the menuType is Toolbar, then the Tool parameter is the Tool Id that the menu is associated with. An annotationTOOL enumeration. If the menuType is Context, the Tool parameter has no meaning and can be any value.
topMenuId
An integer which represents the top-level menu ID of the item in the menu. For built in menus, see the TopMenuId enumeration.
subMenuId
An integer which represents the item in the menu (subMenuId is 0 when the item is a top menu item). For built in menus, see the SubMenuId enumeration.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

MenuGetItemChecked Method

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : MenuGetItemChecked Method

Returns the Checked attribute of the specified menu item on the specified menu item.

[Visual Basic]
Public Function MenuGetItemChecked( _
   ByVal menuType As MenuType, _
   ByVal tool As AnnotationTool, _
   ByVal topMenuId As Integer, _
   ByVal subMenuId As Integer _
) As Boolean
[C#]
public bool MenuGetItemChecked(
   MenuType menuType,
   AnnotationTool tool,
   int topMenuId,
   int subMenuId
);
[C++]
public: bool MenuGetItemChecked(
   MenuType menuType,
   AnnotationTool tool,
   int topMenuId,
   int subMenuId
)
[C++/CLI]
public:
bool MenuGetItemChecked(
   MenuType menuType,
   AnnotationTool tool,
   int topMenuId,
   int subMenuId
)

Parameters

menuType
A MenuType enumeration value.
tool
If the menuType is Toolbar, then the Tool parameter is the Tool Id that the menu is associated with. An annotationTOOL enumeration. If the menuType is Context, the Tool parameter has no meaning and can be any value.
topMenuId
An integer which represents the top-level menu ID of the item in the menu. For built in menus, see the TopMenuId enumeration.
subMenuId
An integer which represents the item in the menu (subMenuId is 0 when the item is a top menu item). For built in menus, see the SubMenuId enumeration.

See Also

NotateXpress Class | NotateXpress Members | MenuSetItemChecked Method | MenuGetItemEnabled Method | MenuSetItemEnabled Method | MenuGetItemVisible Method | MenuSetItemVisible Method | MenuSetEnabled Method | MenuSetItemChecked Method | MenuGetItemEnabled Method | MenuSetItemEnabled Method | MenuGetItemVisible Method | MenuSetItemVisible Method | MenuSetEnabled Method | MenuSetItemChecked Method | MenuGetItemEnabled Method | MenuSetItemEnabled Method | MenuGetItemVisible Method | MenuSetItemVisible Method | MenuSetEnabled Method | MenuSetItemChecked Method | MenuGetItemEnabled Method | MenuSetItemEnabled Method | MenuGetItemVisible Method | MenuSetItemVisible Method | MenuSetEnabled Method | MenuSetItemChecked Method | MenuGetItemEnabled Method | MenuSetItemEnabled Method | MenuGetItemVisible Method | MenuSetItemVisible Method | MenuSetEnabled Method | MenuSetItemChecked Method | MenuGetItemEnabled Method | MenuSetItemEnabled Method | MenuGetItemVisible Method | MenuSetItemVisible Method | MenuSetEnabled Method | MenuSetItemChecked Method | MenuGetItemEnabled Method | MenuSetItemEnabled Method | MenuGetItemVisible Method | MenuSetItemVisible Method | MenuSetEnabled Method


MenuGetItemEnabled Method

NotateXpress Class | NotateXpress Members | MenuGetItemChecked Method | MenuSetItemChecked Method | MenuSetItemEnabled Method | MenuGetItemVisible Method | MenuSetItemVisible Method | MenuSetEnabled Method | MenuGetItemChecked Method | MenuSetItemChecked Method | MenuSetItemEnabled Method | MenuGetItemVisible Method | MenuSetItemVisible Method | MenuSetEnabled Method | MenuGetItemChecked Method | MenuSetItemChecked Method | MenuSetItemEnabled Method | MenuGetItemVisible Method | MenuSetItemVisible Method | MenuSetEnabled Method | MenuGetItemChecked Method | MenuSetItemChecked Method | MenuSetItemEnabled Method | MenuGetItemVisible Method | MenuSetItemVisible Method | MenuSetEnabled Method | MenuGetItemChecked Method | MenuSetItemChecked Method | MenuSetItemEnabled Method | MenuGetItemVisible Method | MenuSetItemVisible Method | MenuSetEnabled Method | MenuGetItemChecked Method | MenuSetItemChecked Method | MenuSetItemEnabled Method | MenuGetItemVisible Method | MenuSetItemVisible Method | MenuSetEnabled Method | MenuGetItemChecked Method | MenuSetItemChecked Method | MenuSetItemEnabled Method | MenuGetItemVisible Method | MenuSetItemVisible Method | MenuSetEnabled Method

Language

Visual Basic

C#

C++

C++/CLI

Show All

menuType
A MenuType enumeration value.
tool
If the menuType is Toolbar, then the Tool parameter is the Tool Id that the menu is associated with. An annotationTOOL enumeration. If the menuType is Context, the Tool parameter has no meaning and can be any value.
topMenuId
An integer which represents the top-level menu ID of the item in the menu. For built in menus, see the TopMenuId enumeration.
subMenuId
An integer which represents the item in the menu (subMenuId is 0 when the item is a top menu item). For built in menus, see the SubMenuId enumeration.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

MenuGetItemEnabled Method

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : MenuGetItemEnabled Method

Gets the Enabled attribute of the specified menu item on the specified menu item.

[Visual Basic]
Public Function MenuGetItemEnabled( _
   ByVal menuType As MenuType, _
   ByVal tool As AnnotationTool, _
   ByVal topMenuId As Integer, _
   ByVal subMenuId As Integer _
) As Boolean
[C#]
public bool MenuGetItemEnabled(
   MenuType menuType,
   AnnotationTool tool,
   int topMenuId,
   int subMenuId
);
[C++]
public: bool MenuGetItemEnabled(
   MenuType menuType,
   AnnotationTool tool,
   int topMenuId,
   int subMenuId
)
[C++/CLI]
public:
bool MenuGetItemEnabled(
   MenuType menuType,
   AnnotationTool tool,
   int topMenuId,
   int subMenuId
)

Parameters

menuType
A MenuType enumeration value.
tool
If the menuType is Toolbar, then the Tool parameter is the Tool Id that the menu is associated with. An annotationTOOL enumeration. If the menuType is Context, the Tool parameter has no meaning and can be any value.
topMenuId
An integer which represents the top-level menu ID of the item in the menu. For built in menus, see the TopMenuId enumeration.
subMenuId
An integer which represents the item in the menu (subMenuId is 0 when the item is a top menu item). For built in menus, see the SubMenuId enumeration.

See Also

NotateXpress Class | NotateXpress Members | MenuGetItemChecked Method | MenuSetItemChecked Method | MenuSetItemEnabled Method | MenuGetItemVisible Method | MenuSetItemVisible Method | MenuSetEnabled Method | MenuGetItemChecked Method | MenuSetItemChecked Method | MenuSetItemEnabled Method | MenuGetItemVisible Method | MenuSetItemVisible Method | MenuSetEnabled Method | MenuGetItemChecked Method | MenuSetItemChecked Method | MenuSetItemEnabled Method | MenuGetItemVisible Method | MenuSetItemVisible Method | MenuSetEnabled Method | MenuGetItemChecked Method | MenuSetItemChecked Method | MenuSetItemEnabled Method | MenuGetItemVisible Method | MenuSetItemVisible Method | MenuSetEnabled Method | MenuGetItemChecked Method | MenuSetItemChecked Method | MenuSetItemEnabled Method | MenuGetItemVisible Method | MenuSetItemVisible Method | MenuSetEnabled Method | MenuGetItemChecked Method | MenuSetItemChecked Method | MenuSetItemEnabled Method | MenuGetItemVisible Method | MenuSetItemVisible Method | MenuSetEnabled Method | MenuGetItemChecked Method | MenuSetItemChecked Method | MenuSetItemEnabled Method | MenuGetItemVisible Method | MenuSetItemVisible Method | MenuSetEnabled Method


MenuGetItemVisible Method

NotateXpress Class | NotateXpress Members | MenuGetItemChecked Method | MenuSetItemChecked Method | MenuGetItemEnabled Method | MenuSetItemEnabled Method | MenuSetItemVisible Method | MenuSetEnabled Method | MenuGetItemChecked Method | MenuSetItemChecked Method | MenuGetItemEnabled Method | MenuSetItemEnabled Method | MenuSetItemVisible Method | MenuSetEnabled Method | MenuGetItemChecked Method | MenuSetItemChecked Method | MenuGetItemEnabled Method | MenuSetItemEnabled Method | MenuSetItemVisible Method | MenuSetEnabled Method | MenuGetItemChecked Method | MenuSetItemChecked Method | MenuGetItemEnabled Method | MenuSetItemEnabled Method | MenuSetItemVisible Method | MenuSetEnabled Method | MenuGetItemChecked Method | MenuSetItemChecked Method | MenuGetItemEnabled Method | MenuSetItemEnabled Method | MenuSetItemVisible Method | MenuSetEnabled Method | MenuGetItemChecked Method | MenuSetItemChecked Method | MenuGetItemEnabled Method | MenuSetItemEnabled Method | MenuSetItemVisible Method | MenuSetEnabled Method | MenuGetItemChecked Method | MenuSetItemChecked Method | MenuGetItemEnabled Method | MenuSetItemEnabled Method | MenuSetItemVisible Method | MenuSetEnabled Method

Language

Visual Basic

C#

C++

C++/CLI

Show All

menuType
A MenuType enumeration value.
tool
If the menuType is Toolbar, then the Tool parameter is the Tool Id that the menu is associated with. An annotationTOOL enumeration. If the menuType is Context, the Tool parameter has no meaning and can be any value.
topMenuId
An integer which represents the top-level menu ID of the item in the menu. For built in menus, see the TopMenuId enumeration.
subMenuId
An integer which represents the item in the menu (subMenuId is 0 when the item is a top menu item). For built in menus, see the SubMenuId enumeration.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

MenuGetItemVisible Method

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : MenuGetItemVisible Method

Gets the Visible attribute of the specified menu item on the specified menu item.

[Visual Basic]
Public Function MenuGetItemVisible( _
   ByVal menuType As MenuType, _
   ByVal tool As AnnotationTool, _
   ByVal topMenuId As Integer, _
   ByVal subMenuId As Integer _
) As Boolean
[C#]
public bool MenuGetItemVisible(
   MenuType menuType,
   AnnotationTool tool,
   int topMenuId,
   int subMenuId
);
[C++]
public: bool MenuGetItemVisible(
   MenuType menuType,
   AnnotationTool tool,
   int topMenuId,
   int subMenuId
)
[C++/CLI]
public:
bool MenuGetItemVisible(
   MenuType menuType,
   AnnotationTool tool,
   int topMenuId,
   int subMenuId
)

Parameters

menuType
A MenuType enumeration value.
tool
If the menuType is Toolbar, then the Tool parameter is the Tool Id that the menu is associated with. An annotationTOOL enumeration. If the menuType is Context, the Tool parameter has no meaning and can be any value.
topMenuId
An integer which represents the top-level menu ID of the item in the menu. For built in menus, see the TopMenuId enumeration.
subMenuId
An integer which represents the item in the menu (subMenuId is 0 when the item is a top menu item). For built in menus, see the SubMenuId enumeration.

See Also

NotateXpress Class | NotateXpress Members | MenuGetItemChecked Method | MenuSetItemChecked Method | MenuGetItemEnabled Method | MenuSetItemEnabled Method | MenuSetItemVisible Method | MenuSetEnabled Method | MenuGetItemChecked Method | MenuSetItemChecked Method | MenuGetItemEnabled Method | MenuSetItemEnabled Method | MenuSetItemVisible Method | MenuSetEnabled Method | MenuGetItemChecked Method | MenuSetItemChecked Method | MenuGetItemEnabled Method | MenuSetItemEnabled Method | MenuSetItemVisible Method | MenuSetEnabled Method | MenuGetItemChecked Method | MenuSetItemChecked Method | MenuGetItemEnabled Method | MenuSetItemEnabled Method | MenuSetItemVisible Method | MenuSetEnabled Method | MenuGetItemChecked Method | MenuSetItemChecked Method | MenuGetItemEnabled Method | MenuSetItemEnabled Method | MenuSetItemVisible Method | MenuSetEnabled Method | MenuGetItemChecked Method | MenuSetItemChecked Method | MenuGetItemEnabled Method | MenuSetItemEnabled Method | MenuSetItemVisible Method | MenuSetEnabled Method | MenuGetItemChecked Method | MenuSetItemChecked Method | MenuGetItemEnabled Method | MenuSetItemEnabled Method | MenuSetItemVisible Method | MenuSetEnabled Method


MenuGetNextItemId Method

NotateXpress Class | NotateXpress Members | MenuGetFirstItemId Method | MenuGetFirstItemId Method | MenuGetFirstItemId Method | MenuGetFirstItemId Method | MenuGetFirstItemId Method | MenuGetFirstItemId Method | MenuGetFirstItemId Method

Language

Visual Basic

C#

C++

C++/CLI

Show All

menuType
A MenuType enumeration value.
tool
If the menuType is Toolbar, then the Tool parameter is the Tool Id that the menu is associated with. An annotationTOOL enumeration. If the menuType is Context, the Tool parameter has no meaning and can be any value.
topMenuId
An integer which represents the top-level menu ID of the item in the menu. For built in menus, see the TopMenuId enumeration.
subMenuId
An integer which represents the item in the menu (subMenuId is 0 when the item is a top menu item). For built in menus, see the SubMenuId enumeration.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

MenuGetNextItemId Method

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : MenuGetNextItemId Method

Gets the subsequent menuId on the specified level from the specified menu after a calling MenuGetFirstItemId.

[Visual Basic]
Public Sub MenuGetNextItemId( _
   ByVal menuType As MenuType, _
   ByVal tool As AnnotationTool, _
   ByRef topMenuId As Integer, _
   ByRef subMenuId As Integer _
)
[C#]
public void MenuGetNextItemId(
   MenuType menuType,
   AnnotationTool tool,
   out int topMenuId,
   out int subMenuId
);
[C++]
public: void MenuGetNextItemId(
   MenuType menuType,
   AnnotationTool tool,
   [PARAMFLAG::Out] int topMenuId,
   [PARAMFLAG::Out] int subMenuId
)
[C++/CLI]
public:
void MenuGetNextItemId(
   MenuType menuType,
   AnnotationTool tool,
   [Out] int topMenuId,
   [Out] int subMenuId
)

Parameters

menuType
A MenuType enumeration value.
tool
If the menuType is Toolbar, then the Tool parameter is the Tool Id that the menu is associated with. An annotationTOOL enumeration. If the menuType is Context, the Tool parameter has no meaning and can be any value.
topMenuId
An integer which represents the top-level menu ID of the item in the menu. For built in menus, see the TopMenuId enumeration.
subMenuId
An integer which represents the item in the menu (subMenuId is 0 when the item is a top menu item). For built in menus, see the SubMenuId enumeration.

Remarks

Make a call to MenuGetFirstItemId to start the process.

See Also

NotateXpress Class | NotateXpress Members | MenuGetFirstItemId Method | MenuGetFirstItemId Method | MenuGetFirstItemId Method | MenuGetFirstItemId Method | MenuGetFirstItemId Method | MenuGetFirstItemId Method | MenuGetFirstItemId Method


MenuSetEnabled Method

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

menuType
The MenuType to display.
tool
If the menuType is Toolbar, then the Tool parameter is the Tool Id that the menu is associated with. An annotationTOOL enumeration. If the menuType is Context, the Tool parameter has no meaning and can be any value.
enabled
A boolean value which is true when the menu is enabled, and displays when the right mouse button is clicked over the appropriate tool or element. Otherwise, false is used and the menu should be disabled.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

MenuSetEnabled Method

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : MenuSetEnabled Method

Sets whether or not the specified menu will display when the right mouse button is clicked over the appropriate area.

[Visual Basic]
Public Sub MenuSetEnabled( _
   ByVal menuType As MenuType, _
   ByVal tool As AnnotationTool, _
   ByVal enabled As Boolean _
)
[C#]
public void MenuSetEnabled(
   MenuType menuType,
   AnnotationTool tool,
   bool enabled
);
[C++]
public: void MenuSetEnabled(
   MenuType menuType,
   AnnotationTool tool,
   bool enabled
)
[C++/CLI]
public:
void MenuSetEnabled(
   MenuType menuType,
   AnnotationTool tool,
   bool enabled
)

Parameters

menuType
The MenuType to display.
tool
If the menuType is Toolbar, then the Tool parameter is the Tool Id that the menu is associated with. An annotationTOOL enumeration. If the menuType is Context, the Tool parameter has no meaning and can be any value.
enabled
A boolean value which is true when the menu is enabled, and displays when the right mouse button is clicked over the appropriate tool or element. Otherwise, false is used and the menu should be disabled.

See Also

NotateXpress Class | NotateXpress Members


MenuSetItemChecked Method

NotateXpress Class | NotateXpress Members | MenuGetItemChecked Method | MenuGetItemEnabled Method | MenuSetItemEnabled Method | MenuGetItemVisible Method | MenuSetItemVisible Method | MenuSetEnabled Method | MenuGetItemChecked Method | MenuGetItemEnabled Method | MenuSetItemEnabled Method | MenuGetItemVisible Method | MenuSetItemVisible Method | MenuSetEnabled Method | MenuGetItemChecked Method | MenuGetItemEnabled Method | MenuSetItemEnabled Method | MenuGetItemVisible Method | MenuSetItemVisible Method | MenuSetEnabled Method | MenuGetItemChecked Method | MenuGetItemEnabled Method | MenuSetItemEnabled Method | MenuGetItemVisible Method | MenuSetItemVisible Method | MenuSetEnabled Method | MenuGetItemChecked Method | MenuGetItemEnabled Method | MenuSetItemEnabled Method | MenuGetItemVisible Method | MenuSetItemVisible Method | MenuSetEnabled Method | MenuGetItemChecked Method | MenuGetItemEnabled Method | MenuSetItemEnabled Method | MenuGetItemVisible Method | MenuSetItemVisible Method | MenuSetEnabled Method | MenuGetItemChecked Method | MenuGetItemEnabled Method | MenuSetItemEnabled Method | MenuGetItemVisible Method | MenuSetItemVisible Method | MenuSetEnabled Method

Language

Visual Basic

C#

C++

C++/CLI

Show All

menuType
A MenuType enumeration value.
tool
If the menuType is Toolbar, then the Tool parameter is the Tool Id that the menu is associated with. An annotationTOOL enumeration. If the menuType is Context, the Tool parameter has no meaning and can be any value.
topMenuId
An integer which represents the top-level menu ID of the item in the menu. For built in menus, see the TopMenuId enumeration.
subMenuId
An integer which represents the item in the menu (subMenuId is 0 when the item is a top menu item). For built in menus, see the SubMenuId enumeration.
checkedItem
A boolean value which represents the checked state of the menu item.
exclusive
If True and checkedItem is True, the method will un-check all other items on the same menu level.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

MenuSetItemChecked Method

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : MenuSetItemChecked Method

Sets the Checked attribute of the specified menu item on the specified menu item.

[Visual Basic]
Public Sub MenuSetItemChecked( _
   ByVal menuType As MenuType, _
   ByVal tool As AnnotationTool, _
   ByVal topMenuId As Integer, _
   ByVal subMenuId As Integer, _
   ByVal checkedItem As Boolean, _
   ByVal exclusive As Boolean _
)
[C#]
public void MenuSetItemChecked(
   MenuType menuType,
   AnnotationTool tool,
   int topMenuId,
   int subMenuId,
   bool checkedItem,
   bool exclusive
);
[C++]
public: void MenuSetItemChecked(
   MenuType menuType,
   AnnotationTool tool,
   int topMenuId,
   int subMenuId,
   bool checkedItem,
   bool exclusive
)
[C++/CLI]
public:
void MenuSetItemChecked(
   MenuType menuType,
   AnnotationTool tool,
   int topMenuId,
   int subMenuId,
   bool checkedItem,
   bool exclusive
)

Parameters

menuType
A MenuType enumeration value.
tool
If the menuType is Toolbar, then the Tool parameter is the Tool Id that the menu is associated with. An annotationTOOL enumeration. If the menuType is Context, the Tool parameter has no meaning and can be any value.
topMenuId
An integer which represents the top-level menu ID of the item in the menu. For built in menus, see the TopMenuId enumeration.
subMenuId
An integer which represents the item in the menu (subMenuId is 0 when the item is a top menu item). For built in menus, see the SubMenuId enumeration.
checkedItem
A boolean value which represents the checked state of the menu item.
exclusive
If True and checkedItem is True, the method will un-check all other items on the same menu level.

See Also

NotateXpress Class | NotateXpress Members | MenuGetItemChecked Method | MenuGetItemEnabled Method | MenuSetItemEnabled Method | MenuGetItemVisible Method | MenuSetItemVisible Method | MenuSetEnabled Method | MenuGetItemChecked Method | MenuGetItemEnabled Method | MenuSetItemEnabled Method | MenuGetItemVisible Method | MenuSetItemVisible Method | MenuSetEnabled Method | MenuGetItemChecked Method | MenuGetItemEnabled Method | MenuSetItemEnabled Method | MenuGetItemVisible Method | MenuSetItemVisible Method | MenuSetEnabled Method | MenuGetItemChecked Method | MenuGetItemEnabled Method | MenuSetItemEnabled Method | MenuGetItemVisible Method | MenuSetItemVisible Method | MenuSetEnabled Method | MenuGetItemChecked Method | MenuGetItemEnabled Method | MenuSetItemEnabled Method | MenuGetItemVisible Method | MenuSetItemVisible Method | MenuSetEnabled Method | MenuGetItemChecked Method | MenuGetItemEnabled Method | MenuSetItemEnabled Method | MenuGetItemVisible Method | MenuSetItemVisible Method | MenuSetEnabled Method | MenuGetItemChecked Method | MenuGetItemEnabled Method | MenuSetItemEnabled Method | MenuGetItemVisible Method | MenuSetItemVisible Method | MenuSetEnabled Method


MenuSetItemEnabled Method

NotateXpress Class | NotateXpress Members | MenuGetItemChecked Method | MenuSetItemChecked Method | MenuGetItemEnabled Method | MenuGetItemVisible Method | MenuSetItemVisible Method | MenuSetEnabled Method | MenuGetItemChecked Method | MenuSetItemChecked Method | MenuGetItemEnabled Method | MenuGetItemVisible Method | MenuSetItemVisible Method | MenuSetEnabled Method | MenuGetItemChecked Method | MenuSetItemChecked Method | MenuGetItemEnabled Method | MenuGetItemVisible Method | MenuSetItemVisible Method | MenuSetEnabled Method | MenuGetItemChecked Method | MenuSetItemChecked Method | MenuGetItemEnabled Method | MenuGetItemVisible Method | MenuSetItemVisible Method | MenuSetEnabled Method | MenuGetItemChecked Method | MenuSetItemChecked Method | MenuGetItemEnabled Method | MenuGetItemVisible Method | MenuSetItemVisible Method | MenuSetEnabled Method | MenuGetItemChecked Method | MenuSetItemChecked Method | MenuGetItemEnabled Method | MenuGetItemVisible Method | MenuSetItemVisible Method | MenuSetEnabled Method | MenuGetItemChecked Method | MenuSetItemChecked Method | MenuGetItemEnabled Method | MenuGetItemVisible Method | MenuSetItemVisible Method | MenuSetEnabled Method

Language

Visual Basic

C#

C++

C++/CLI

Show All

menuType
A MenuType enumeration value.
tool
If the menuType is Toolbar, then the Tool parameter is the Tool Id that the menu is associated with. An annotationTOOL enumeration. If the menuType is Context, the Tool parameter has no meaning and can be any value.
topMenuId
An integer which represents the top-level menu ID of the item in the menu. For built in menus, see the TopMenuId enumeration.
subMenuId
An integer which represents the item in the menu (subMenuId is 0 when the item is a top menu item). For built in menus, see the SubMenuId enumeration.
enabled
A boolean value which is true if the item is enabled and the application end-user can select it. Otherwise, false is returned.
exclusive
If True and enabled is True, the method will un-check all other items on the same menu level.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

MenuSetItemEnabled Method

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : MenuSetItemEnabled Method

Sets the Enabled attribute of the specified menu item on the specified menu item.

[Visual Basic]
Public Sub MenuSetItemEnabled( _
   ByVal menuType As MenuType, _
   ByVal tool As AnnotationTool, _
   ByVal topMenuId As Integer, _
   ByVal subMenuId As Integer, _
   ByVal enabled As Boolean, _
   ByVal exclusive As Boolean _
)
[C#]
public void MenuSetItemEnabled(
   MenuType menuType,
   AnnotationTool tool,
   int topMenuId,
   int subMenuId,
   bool enabled,
   bool exclusive
);
[C++]
public: void MenuSetItemEnabled(
   MenuType menuType,
   AnnotationTool tool,
   int topMenuId,
   int subMenuId,
   bool enabled,
   bool exclusive
)
[C++/CLI]
public:
void MenuSetItemEnabled(
   MenuType menuType,
   AnnotationTool tool,
   int topMenuId,
   int subMenuId,
   bool enabled,
   bool exclusive
)

Parameters

menuType
A MenuType enumeration value.
tool
If the menuType is Toolbar, then the Tool parameter is the Tool Id that the menu is associated with. An annotationTOOL enumeration. If the menuType is Context, the Tool parameter has no meaning and can be any value.
topMenuId
An integer which represents the top-level menu ID of the item in the menu. For built in menus, see the TopMenuId enumeration.
subMenuId
An integer which represents the item in the menu (subMenuId is 0 when the item is a top menu item). For built in menus, see the SubMenuId enumeration.
enabled
A boolean value which is true if the item is enabled and the application end-user can select it. Otherwise, false is returned.
exclusive
If True and enabled is True, the method will un-check all other items on the same menu level.

See Also

NotateXpress Class | NotateXpress Members | MenuGetItemChecked Method | MenuSetItemChecked Method | MenuGetItemEnabled Method | MenuGetItemVisible Method | MenuSetItemVisible Method | MenuSetEnabled Method | MenuGetItemChecked Method | MenuSetItemChecked Method | MenuGetItemEnabled Method | MenuGetItemVisible Method | MenuSetItemVisible Method | MenuSetEnabled Method | MenuGetItemChecked Method | MenuSetItemChecked Method | MenuGetItemEnabled Method | MenuGetItemVisible Method | MenuSetItemVisible Method | MenuSetEnabled Method | MenuGetItemChecked Method | MenuSetItemChecked Method | MenuGetItemEnabled Method | MenuGetItemVisible Method | MenuSetItemVisible Method | MenuSetEnabled Method | MenuGetItemChecked Method | MenuSetItemChecked Method | MenuGetItemEnabled Method | MenuGetItemVisible Method | MenuSetItemVisible Method | MenuSetEnabled Method | MenuGetItemChecked Method | MenuSetItemChecked Method | MenuGetItemEnabled Method | MenuGetItemVisible Method | MenuSetItemVisible Method | MenuSetEnabled Method | MenuGetItemChecked Method | MenuSetItemChecked Method | MenuGetItemEnabled Method | MenuGetItemVisible Method | MenuSetItemVisible Method | MenuSetEnabled Method


MenuSetItemVisible Method

NotateXpress Class | NotateXpress Members | MenuGetItemChecked Method | MenuSetItemChecked Method | MenuGetItemEnabled Method | MenuSetItemEnabled Method | MenuGetItemVisible Method | MenuSetEnabled Method | MenuGetItemChecked Method | MenuSetItemChecked Method | MenuGetItemEnabled Method | MenuSetItemEnabled Method | MenuGetItemVisible Method | MenuSetEnabled Method | MenuGetItemChecked Method | MenuSetItemChecked Method | MenuGetItemEnabled Method | MenuSetItemEnabled Method | MenuGetItemVisible Method | MenuSetEnabled Method | MenuGetItemChecked Method | MenuSetItemChecked Method | MenuGetItemEnabled Method | MenuSetItemEnabled Method | MenuGetItemVisible Method | MenuSetEnabled Method | MenuGetItemChecked Method | MenuSetItemChecked Method | MenuGetItemEnabled Method | MenuSetItemEnabled Method | MenuGetItemVisible Method | MenuSetEnabled Method | MenuGetItemChecked Method | MenuSetItemChecked Method | MenuGetItemEnabled Method | MenuSetItemEnabled Method | MenuGetItemVisible Method | MenuSetEnabled Method | MenuGetItemChecked Method | MenuSetItemChecked Method | MenuGetItemEnabled Method | MenuSetItemEnabled Method | MenuGetItemVisible Method | MenuSetEnabled Method

Language

Visual Basic

C#

C++

C++/CLI

Show All

menuType
A MenuType enumeration value.
tool
If the menuType is Toolbar, then the Tool parameter is the Tool Id that the menu is associated with. An annotationTOOL enumeration. If the menuType is Context, the Tool parameter has no meaning and can be any value.
topMenuId
An integer which represents the top-level menu ID of the item in the menu. For built in menus, see the TopMenuId enumeration.
subMenuId
An integer which represents the item in the menu (subMenuId is 0 when the item is a top menu item). For built in menus, see the SubMenuId enumeration.
visible
A boolean value which represents if the item is visible or not.
exclusive
If True and visible is True, the method will un-check all other items on the same menu level.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

MenuSetItemVisible Method

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : MenuSetItemVisible Method

Sets the Visible attribute of the specified menu item on the specified menu item.

[Visual Basic]
Public Sub MenuSetItemVisible( _
   ByVal menuType As MenuType, _
   ByVal tool As AnnotationTool, _
   ByVal topMenuId As Integer, _
   ByVal subMenuId As Integer, _
   ByVal visible As Boolean, _
   ByVal exclusive As Boolean _
)
[C#]
public void MenuSetItemVisible(
   MenuType menuType,
   AnnotationTool tool,
   int topMenuId,
   int subMenuId,
   bool visible,
   bool exclusive
);
[C++]
public: void MenuSetItemVisible(
   MenuType menuType,
   AnnotationTool tool,
   int topMenuId,
   int subMenuId,
   bool visible,
   bool exclusive
)
[C++/CLI]
public:
void MenuSetItemVisible(
   MenuType menuType,
   AnnotationTool tool,
   int topMenuId,
   int subMenuId,
   bool visible,
   bool exclusive
)

Parameters

menuType
A MenuType enumeration value.
tool
If the menuType is Toolbar, then the Tool parameter is the Tool Id that the menu is associated with. An annotationTOOL enumeration. If the menuType is Context, the Tool parameter has no meaning and can be any value.
topMenuId
An integer which represents the top-level menu ID of the item in the menu. For built in menus, see the TopMenuId enumeration.
subMenuId
An integer which represents the item in the menu (subMenuId is 0 when the item is a top menu item). For built in menus, see the SubMenuId enumeration.
visible
A boolean value which represents if the item is visible or not.
exclusive
If True and visible is True, the method will un-check all other items on the same menu level.

See Also

NotateXpress Class | NotateXpress Members | MenuGetItemChecked Method | MenuSetItemChecked Method | MenuGetItemEnabled Method | MenuSetItemEnabled Method | MenuGetItemVisible Method | MenuSetEnabled Method | MenuGetItemChecked Method | MenuSetItemChecked Method | MenuGetItemEnabled Method | MenuSetItemEnabled Method | MenuGetItemVisible Method | MenuSetEnabled Method | MenuGetItemChecked Method | MenuSetItemChecked Method | MenuGetItemEnabled Method | MenuSetItemEnabled Method | MenuGetItemVisible Method | MenuSetEnabled Method | MenuGetItemChecked Method | MenuSetItemChecked Method | MenuGetItemEnabled Method | MenuSetItemEnabled Method | MenuGetItemVisible Method | MenuSetEnabled Method | MenuGetItemChecked Method | MenuSetItemChecked Method | MenuGetItemEnabled Method | MenuSetItemEnabled Method | MenuGetItemVisible Method | MenuSetEnabled Method | MenuGetItemChecked Method | MenuSetItemChecked Method | MenuGetItemEnabled Method | MenuSetItemEnabled Method | MenuGetItemVisible Method | MenuSetEnabled Method | MenuGetItemChecked Method | MenuSetItemChecked Method | MenuGetItemEnabled Method | MenuSetItemEnabled Method | MenuGetItemVisible Method | MenuSetEnabled Method


SetImageMappingDimensions Method

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

width
An integer which represents the width in pixels to use to map annotation coordinates.
height
An integer which represents the height in pixels to use to map annotation coordinates.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

SetImageMappingDimensions Method

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : SetImageMappingDimensions Method

Sets a given mapping width and height.

[Visual Basic]
Public Sub SetImageMappingDimensions( _
   ByVal width As Integer, _
   ByVal height As Integer _
)
[C#]
public void SetImageMappingDimensions(
   int width,
   int height
);
[C++]
public: void SetImageMappingDimensions(
   int width,
   int height
)
[C++/CLI]
public:
void SetImageMappingDimensions(
   int width,
   int height
)

Parameters

width
An integer which represents the width in pixels to use to map annotation coordinates.
height
An integer which represents the height in pixels to use to map annotation coordinates.

Remarks

When ImagXpress is not atached to NotateXpress and you load an annotation file, NotateXpress cannot query ImagXpress for its current image dimenstions when mapping annotation coordinates. This method allows you to set a mapping width and height for this circumstance. The values set by this method will only be used when ImageXpress is not attached to NotateXpress.

This should be an exceptional case.

See Also

NotateXpress Class | NotateXpress Members


SetUseCursorType Method

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

cursorType
The CursorSelection enumeration value set.
use
A boolean value which determines if a distinctive cursor is used or not.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

SetUseCursorType Method

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : SetUseCursorType Method

Returns an indicator if a distinctive cursor is used for a specific type of operation (creating, moving, or selecting objects).

[Visual Basic]
Public Sub SetUseCursorType( _
   ByVal cursorType As CursorSelection, _
   ByVal use As Boolean _
)
[C#]
public void SetUseCursorType(
   CursorSelection cursorType,
   bool use
);
[C++]
public: void SetUseCursorType(
   CursorSelection cursorType,
   bool use
)
[C++/CLI]
public:
void SetUseCursorType(
   CursorSelection cursorType,
   bool use
)

Parameters

cursorType
The CursorSelection enumeration value set.
use
A boolean value which determines if a distinctive cursor is used or not.

Remarks

The default value is to use tool specific cursors for creating, moving and selecting.

See Also

NotateXpress Class | NotateXpress Members


SetUseCustomCursorType Method

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

cursorType
Type of the cursor.
tool
The Annotation tool.
customCursor
The custom cursor handle.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

SetUseCustomCursorType Method

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : SetUseCustomCursorType Method

This is for replacing the built in cursors that are created by turning on SetUseCursorType.

[Visual Basic]
Public Sub SetUseCustomCursorType( _
   ByVal cursorType As CursorSelection, _
   ByVal tool As AnnotationTool, _
   ByVal customCursor As IntPtr _
)
[C#]
public void SetUseCustomCursorType(
   CursorSelection cursorType,
   AnnotationTool tool,
   IntPtr customCursor
);
[C++]
public: void SetUseCustomCursorType(
   CursorSelection cursorType,
   AnnotationTool tool,
   IntPtr customCursor
)
[C++/CLI]
public:
void SetUseCustomCursorType(
   CursorSelection cursorType,
   AnnotationTool tool,
   IntPtr customCursor
)

Parameters

cursorType
Type of the cursor.
tool
The Annotation tool.
customCursor
The custom cursor handle.

Remarks

Note: This should be set once as its associated with the NotateXpress object.

Make sure that the icon does not go out of scope, as the application controls ownership of the icon. .NET cursors only support Black and White.

If you want to use color cursors one option is to use the win32 LoadCursorFromFile

Example

How to load in a cursor handle

[C#]

private Cursor mynewcursor;
mynewcursor = new Cursor("c:\\images\\test.cur");
NotateXpress1.SetUseCustomCursorType(CursorSelection.Creating, AnnotationTool.BlockHighlightTool, mynewcursor);

See Also

NotateXpress Class | NotateXpress Members


UserDataAdd Method

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

key
A string value which represents the key to add.
newVal
A string value which represents the new value.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

UserDataAdd Method

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : UserDataAdd Method (NotateXpress)

Adds the specified key value pair to the list.

[Visual Basic]
Public Sub UserDataAdd( _
   ByVal key As String, _
   ByVal newVal As String _
)
[C#]
public void UserDataAdd(
   string key,
   string newVal
);
[C++]
public: void UserDataAdd(
   string* key,
   string* newVal
)
[C++/CLI]
public:
void UserDataAdd(
   String^ key,
   String^ newVal
)

Parameters

key
A string value which represents the key to add.
newVal
A string value which represents the new value.

Remarks

This method adds a key value pair.

See Also

NotateXpress Class | NotateXpress Members


UserDataDelete Method

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

key
A string value which represents the key to remove.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

UserDataDelete Method

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : UserDataDelete Method (NotateXpress)

Deletes an existing key value pair which matches the given key.

[Visual Basic]
Public Sub UserDataDelete( _
   ByVal key As String _
)
[C#]
public void UserDataDelete(
   string key
);
[C++]
public: void UserDataDelete(
   string* key
)
[C++/CLI]
public:
void UserDataDelete(
   String^ key
)

Parameters

key
A string value which represents the key to remove.

See Also

NotateXpress Class | NotateXpress Members


UserDataFind Method

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

key
A string value which represents the user data key to search for.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

UserDataFind Method

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : UserDataFind Method (NotateXpress)

User data can be added to each page in a key value pair.

[Visual Basic]
Public Function UserDataFind( _
   ByVal key As String _
) As String
[C#]
public string UserDataFind(
   string key
);
[C++]
public: string* UserDataFind(
   string* key
)
[C++/CLI]
public:
String^ UserDataFind(
   String^ key
)

Parameters

key
A string value which represents the user data key to search for.

Return Type

A String which represents the user data from the matching key.

Remarks

This will return the value of an existing key.

See Also

NotateXpress Class | NotateXpress Members


UserDataFindFirst Method

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

key
A string value which represents the first key.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

UserDataFindFirst Method

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : UserDataFindFirst Method (NotateXpress)

Finds the first key value pair in the list.

[Visual Basic]
Public Function UserDataFindFirst( _
   ByRef key As String _
) As String
[C#]
public string UserDataFindFirst(
   out string key
);
[C++]
public: string* UserDataFindFirst(
   [PARAMFLAG::Out] string* key
)
[C++/CLI]
public:
String^ UserDataFindFirst(
   [Out] String^ key
)

Parameters

key
A string value which represents the first key.

Return Type

A string which represents the first value.

Remarks

This method returns the first key value pair, in the list.

See Also

NotateXpress Class | NotateXpress Members


UserDataFindNext Method

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

key
A string value which represents the next key.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

UserDataFindNext Method

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : UserDataFindNext Method (NotateXpress)

Finds the next key value pair in the list.

[Visual Basic]
Public Function UserDataFindNext( _
   ByRef key As String _
) As String
[C#]
public string UserDataFindNext(
   out string key
);
[C++]
public: string* UserDataFindNext(
   [PARAMFLAG::Out] string* key
)
[C++/CLI]
public:
String^ UserDataFindNext(
   [Out] String^ key
)

Parameters

key
A string value which represents the next key.

Return Type

A string which represents the next value.

Remarks

This method returns the next key value pair in the list.

See Also

NotateXpress Class | NotateXpress Members


NotateXpress Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NotateXpress Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : NotateXpress Class

For a list of all members of this type, see NotateXpress members.

Public Properties

Public Property AllowPaint | Gets and sets whether annotations are painted and rendered to the display.
Public Property ClientWindow | Gets and sets which ImagXpress viewer (ImageXView object) to annotate.
Public Property Container (Inherited from System.ComponentModel.Component) | Gets the IContainer that contains the Component.
Public Property Debug | Gets and sets whether NotateXpress is in debug mode.
Public Property DebugErrorLevel | Gets and sets the level of detail to record in the NotateXpress.DebugLogFile.
Public Property DebugLogFile | Gets and sets the debug log file for writting debug information.
Public Property ErrorLevel | Obsolete function Please use DebugErrorLevel instead. Gets and sets the level of detail to record in the NotateXpress.DebugLogFile.
Public Property FontScaling | FontScaling is an enumerated type that determines how a font is scaled relative to an image’s vertical resolution DPI.
Public Property ImagXpressLoad | The ImagXpressLoad property sets or returns whether annotations are loaded from a Tiff file when a Tiff file containing annotations is loaded by ImagXpress.
Public Property ImagXpressSave | Gets or sets whether annotations are saved into a Tiff file when the ImagXpress Save method is executed.
Public Property InteractMode | Gets and sets whether the annotations are in interactive mode or not.
Public Property Layers | The Layer class contains attributes for elements, groups and toolbars.
Public Property LineScaling | Gets and sets how all lines are scaled relative to an image’s vertical resolution DPI.
Public Property MultiLineEdit | Gets and sets whether to use a standard Multi-line edit control to edit text.
Public Property NoteIcon | Gets and sets the icon associated with the Notetool.
Public Property PageNumber | Gets and sets the page number.
Public Property RecalibrateXdpi | Gets and sets the x (horizontal) coordinate value for the DPI (dots per inch).
Public Property RecalibrateYdpi | Gets and sets the y (vertical) coordinate value for the DPI (dots per inch).
Public Property Site (Inherited from System.ComponentModel.Component) | Gets or sets the ISite of the Component.
Public Property ToolbarDefaults | Gets and sets access to all of the global toolbar defaults.
Public Property ToolTipTimeEdit | Gets or sets the amount of time to display tooltip window in Edit mode.
Public Property ToolTipTimeInteractive | Gets or sets the amount of time a tooltip window remains visible.
Public Property Update | Gets and sets whether annotations render to the display.

See Also

NotateXpress Class | PegasusImaging.WinForms.NotateXpress9 Namespace


AllowPaint Property

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

AllowPaint Property

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : AllowPaint Property

Gets and sets whether annotations are painted and rendered to the display.

[Visual Basic]
<CategoryAttribute("NotateXpress")>
<BrowsableAttribute(True)>
<DescriptionAttribute("Inidciates whether annotations are painted and rendered to the display")>
Public Property AllowPaint As Boolean
[C#]
[CategoryAttribute("NotateXpress")]
[BrowsableAttribute(true)]
[DescriptionAttribute("Inidciates whether annotations are painted and rendered to the display")]
public bool AllowPaint {get; set;}
[C++]
[CategoryAttribute("NotateXpress")]
[BrowsableAttribute(true)]
[DescriptionAttribute("Inidciates whether annotations are painted and rendered to the display")]
public: __property bool get_AllowPaint();
public: __property void set_AllowPaint(
   bool value
);
[C++/CLI]
[CategoryAttribute("NotateXpress")]
[BrowsableAttribute(true)]
[DescriptionAttribute("Inidciates whether annotations are painted and rendered to the display")]
public:
property bool AllowPaint {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true to paint annotations. Otherwise, false is returned and annotations are no longer rendered to the display.

Remarks

This property is useful when you are loading a TIFF file that contains multiple layers and you only want to show one layer at a time. You can set this property to false, load the TIFF file, then iterate through the layers using the Layer.Select method and setting the layers' Layer.Visible property. When you have iterated through all the layers, you can then set the AllowPaint to true.

See Also

NotateXpress Class | NotateXpress Members


ClientWindow Property

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ClientWindow Property

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : ClientWindow Property

Gets and sets which ImagXpress viewer (ImageXView object) to annotate.

[Visual Basic]
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Property ClientWindow As IntPtr
[C#]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public IntPtr ClientWindow {get; set;}
[C++]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property IntPtr get_ClientWindow();
public: __property void set_ClientWindow(
   IntPtr value
);
[C++/CLI]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property IntPtr ClientWindow {
   IntPtr get();
   void set (IntPtr value);
}

Value

An integer pointer which represents the ImageXView object window handle.

Remarks

To connect a NotateXpress object to an ImagXpress object, set the ClientWindow property to the window handle of the ImagXpress View window to which you want to add annotation capability. See the example below.

To disconnect a NotateXpress object from an ImagXpress object, set the ClientWindow property to Zero. This is identical to calling the ClientDisconnect method.

Example

NotateXpress1.ClientWindow = ImageXView1.Handle;

See Also

NotateXpress Class | NotateXpress Members


Debug Property

NotateXpress Class | NotateXpress Members | DebugLogFile Property | DebugErrorLevel Property

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Debug Property

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : Debug Property

Gets and sets whether NotateXpress is in debug mode.

[Visual Basic]
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Property Debug As Boolean
[C#]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public bool Debug {get; set;}
[C++]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property bool get_Debug();
public: __property void set_Debug(
   bool value
);
[C++/CLI]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property bool Debug {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true when in debug mode. Otherwise, false is used and no debug information is written to the debug log file.

See Also

NotateXpress Class | NotateXpress Members | DebugLogFile Property | DebugErrorLevel Property


DebugErrorLevel Property

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

DebugErrorLevel Property

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : DebugErrorLevel Property

Gets and sets the level of detail to record in the NotateXpress.DebugLogFile.

[Visual Basic]
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Property DebugErrorLevel As DebugErrorLevelInfo
[C#]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public DebugErrorLevelInfo DebugErrorLevel {get; set;}
[C++]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property DebugErrorLevelInfo get_DebugErrorLevel();
public: __property void set_DebugErrorLevel(
   DebugErrorLevelInfo value
);
[C++/CLI]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property DebugErrorLevelInfo DebugErrorLevel {
   DebugErrorLevelInfo get();
   void set (DebugErrorLevelInfo value);
}

Value

The DebugErrorLevelInfo enumeration value set.

Remarks

The NotateXpress.Debug property must be set to true for debug information to be logged to the NotateXpress.DebugLogFile.

Setting the error level to Development or Detailed requires more resources, but offers more information than Production level.

See Also

NotateXpress Class | NotateXpress Members


DebugLogFile Property

NotateXpress Class | NotateXpress Members | Debug Property | DebugErrorLevel Property

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

DebugLogFile Property

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : DebugLogFile Property

Gets and sets the debug log file for writting debug information.

[Visual Basic]
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Property DebugLogFile As String
[C#]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public string DebugLogFile {get; set;}
[C++]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property string* get_DebugLogFile();
public: __property void set_DebugLogFile(
   string* value
);
[C++/CLI]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property String^ DebugLogFile {
   String^ get();
   void set (String^ value);
}

Value

A string value which represents the filename of the debug log file.

Remarks

The NotateXpress.Debug property must be set to true to log data to the debug file.

See Also

NotateXpress Class | NotateXpress Members | Debug Property | DebugErrorLevel Property


ErrorLevel Property

NotateXpress Class | NotateXpress Members | DebugErrorLevel Property

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ErrorLevel Property

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : ErrorLevel Property

Obsolete function Please use DebugErrorLevel instead.

Gets and sets the level of detail to record in the NotateXpress.DebugLogFile.

[Visual Basic]
<ObsoleteAttribute("Please use DebugErrorLevel instead")>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Property ErrorLevel As ErrorLevelInfo
[C#]
[ObsoleteAttribute("Please use DebugErrorLevel instead")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public ErrorLevelInfo ErrorLevel {get; set;}
[C++]
[ObsoleteAttribute("Please use DebugErrorLevel instead")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property ErrorLevelInfo get_ErrorLevel();
public: __property void set_ErrorLevel(
   ErrorLevelInfo value
);
[C++/CLI]
[ObsoleteAttribute("Please use DebugErrorLevel instead")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property ErrorLevelInfo ErrorLevel {
   ErrorLevelInfo get();
   void set (ErrorLevelInfo value);
}

Value

The ErrorLevelInfo enumeration value set.

Remarks

The NotateXpress.Debug property must be set to true for debug information to be logged to the NotateXpress.DebugLogFile.

Setting the error level to Development or Detailed requires more resources, but offers more information than Production level.

See Also

NotateXpress Class | NotateXpress Members | DebugErrorLevel Property


FontScaling Property

NotateXpress Class | NotateXpress Members | FontScaling Property

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

FontScaling Property

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : FontScaling Property (NotateXpress)

FontScaling is an enumerated type that determines how a font is scaled relative to an image’s vertical resolution DPI.

[Visual Basic]
<BrowsableAttribute(True)>
<CategoryAttribute("NotateXpress")>
<DescriptionAttribute("Inidciates how a font is scaled relative to an image’s vertical resolution")>
Public Property FontScaling As FontScaling
[C#]
[BrowsableAttribute(true)]
[CategoryAttribute("NotateXpress")]
[DescriptionAttribute("Inidciates how a font is scaled relative to an image’s vertical resolution")]
public FontScaling FontScaling {get; set;}
[C++]
[BrowsableAttribute(true)]
[CategoryAttribute("NotateXpress")]
[DescriptionAttribute("Inidciates how a font is scaled relative to an image’s vertical resolution")]
public: __property FontScaling get_FontScaling();
public: __property void set_FontScaling(
   FontScaling value
);
[C++/CLI]
[BrowsableAttribute(true)]
[CategoryAttribute("NotateXpress")]
[DescriptionAttribute("Inidciates how a font is scaled relative to an image’s vertical resolution")]
public:
property FontScaling FontScaling {
   FontScaling get();
   void set (FontScaling value);
}

Value

The FontScaling enumeration value set.

Remarks

The size of the text is determined in the Font's size member. How that size is rendered is determined by this property.

When FontScaling is Normal, a font is simply scaled by the current zoom percentage of the image. This is the default of NotateXpress. When FontScaling is set to YResolution and ImagXpress contains a valid value for the Resolution Y property, a font is scaled to take this vertical DPI value into account.

See Also

NotateXpress Class | NotateXpress Members | FontScaling Property


ImagXpressLoad Property

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ImagXpressLoad Property

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : ImagXpressLoad Property

The ImagXpressLoad property sets or returns whether annotations are loaded from a Tiff file when a Tiff file containing annotations is loaded by ImagXpress.

[Visual Basic]
<BrowsableAttribute(True)>
<DescriptionAttribute("Inidciates whether annotations are loaded from a Tiff file")>
<CategoryAttribute("NotateXpress")>
Public Property ImagXpressLoad As Boolean
[C#]
[BrowsableAttribute(true)]
[DescriptionAttribute("Inidciates whether annotations are loaded from a Tiff file")]
[CategoryAttribute("NotateXpress")]
public bool ImagXpressLoad {get; set;}
[C++]
[BrowsableAttribute(true)]
[DescriptionAttribute("Inidciates whether annotations are loaded from a Tiff file")]
[CategoryAttribute("NotateXpress")]
public: __property bool get_ImagXpressLoad();
public: __property void set_ImagXpressLoad(
   bool value
);
[C++/CLI]
[BrowsableAttribute(true)]
[DescriptionAttribute("Inidciates whether annotations are loaded from a Tiff file")]
[CategoryAttribute("NotateXpress")]
public:
property bool ImagXpressLoad {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true when annotations load to NotateXpress when ImagXpress loads a TIFF file. Otherwise, false is returned.

Remarks

The default value is true.

The default is True, which means that when you load a Tiff file in ImagXpress, and ImagXpress is linked to NotateXpress, and there are annotations present, the annotations will be loaded from the Tiff file as either Wang/Kodak Imaging for Windows compatible annotations or in native NotateXpress format, depending on the state of the AnnType property.

See Also

NotateXpress Class | NotateXpress Members


ImagXpressSave Property

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ImagXpressSave Property

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : ImagXpressSave Property

Gets or sets whether annotations are saved into a Tiff file when the ImagXpress Save method is executed.

[Visual Basic]
<DescriptionAttribute("Inidciates whether annotations are saved into a Tiff file")>
<CategoryAttribute("NotateXpress")>
<BrowsableAttribute(True)>
Public Property ImagXpressSave As Boolean
[C#]
[DescriptionAttribute("Inidciates whether annotations are saved into a Tiff file")]
[CategoryAttribute("NotateXpress")]
[BrowsableAttribute(true)]
public bool ImagXpressSave {get; set;}
[C++]
[DescriptionAttribute("Inidciates whether annotations are saved into a Tiff file")]
[CategoryAttribute("NotateXpress")]
[BrowsableAttribute(true)]
public: __property bool get_ImagXpressSave();
public: __property void set_ImagXpressSave(
   bool value
);
[C++/CLI]
[DescriptionAttribute("Inidciates whether annotations are saved into a Tiff file")]
[CategoryAttribute("NotateXpress")]
[BrowsableAttribute(true)]
public:
property bool ImagXpressSave {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true to save annotations with the image when ImagXpress saves to a TIFF file. Otherwise, false is returned.

Remarks

The default value is true.

When this property is set to true, and you save a Tiff file in ImagXpress, and ImagXpress is linked to NotateXpress, and there are annotations present, the annotations will be saved in the Tiff file as either Wang/Kodak Imaging for Windows compatible annotations or in native NotateXpress format, depending on the state of the SaveOptions.AnnType property.

Note: To enable annotations to be saved, ensure that the ImagXpressSave property is set to true and the ImagXpress ImageX.SaveOptions.Annotations.Save property is set to true. If either of these properties are false, annotations will not be saved in the file.

Note: Only annotations of type AnnotationType.ImagingForWindows and AnnotationType.NotateXpress can be saved inside an image.

See Also

NotateXpress Class | NotateXpress Members


InteractMode Property

NotateXpress Class | NotateXpress Members | AnnotationMode Enumeration

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InteractMode Property

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : InteractMode Property

Gets and sets whether the annotations are in interactive mode or not.

[Visual Basic]
<CategoryAttribute("NotateXpress")>
<BrowsableAttribute(True)>
<DescriptionAttribute("Inidciates whether the annotations are in interactive mode or edit mode.")>
Public Property InteractMode As AnnotationMode
[C#]
[CategoryAttribute("NotateXpress")]
[BrowsableAttribute(true)]
[DescriptionAttribute("Inidciates whether the annotations are in interactive mode or edit mode.")]
public AnnotationMode InteractMode {get; set;}
[C++]
[CategoryAttribute("NotateXpress")]
[BrowsableAttribute(true)]
[DescriptionAttribute("Inidciates whether the annotations are in interactive mode or edit mode.")]
public: __property AnnotationMode get_InteractMode();
public: __property void set_InteractMode(
   AnnotationMode value
);
[C++/CLI]
[CategoryAttribute("NotateXpress")]
[BrowsableAttribute(true)]
[DescriptionAttribute("Inidciates whether the annotations are in interactive mode or edit mode.")]
public:
property AnnotationMode InteractMode {
   AnnotationMode get();
   void set (AnnotationMode value);
}

Value

The AnnotationMode enumeration value set.

Remarks

The InteractMode property sets or returns the interactive state of the annotations. The default value is EditMode.

In EditMode, the ToolPalette can be visible, users can create, select, resize and move objects, and the events generated reflect these actions.

In InteractiveMode the ToolPalette is hidden, objects cannot be selected, and user interaction generates MouseDown, MouseMove, MouseUp, Click, and DoubleClick events.

See Also

NotateXpress Class | NotateXpress Members | AnnotationMode Enumeration


Layers Property

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Layers Property

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : Layers Property

The Layer class contains attributes for elements, groups and toolbars.

[Visual Basic]
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public ReadOnly Property Layers As LayerCollection
[C#]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public LayerCollection Layers {get;}
[C++]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property LayerCollection* get_Layers();
[C++/CLI]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property LayerCollection^ Layers {
   LayerCollection^ get();
}

Value

The LayerCollection which contains layer objects and information about those layers.

Remarks

A Layer must exist in order to draw annotations.

See Also

NotateXpress Class | NotateXpress Members


LineScaling Property

NotateXpress Class | NotateXpress Members | LineScaling Property

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

LineScaling Property

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : LineScaling Property (NotateXpress)

Gets and sets how all lines are scaled relative to an image’s vertical resolution DPI.

[Visual Basic]
<DescriptionAttribute("Inidciates how all lines are scaled relative to an image’s vertical resolution.")>
<CategoryAttribute("NotateXpress")>
<BrowsableAttribute(True)>
Public Property LineScaling As LineScaling
[C#]
[DescriptionAttribute("Inidciates how all lines are scaled relative to an image’s vertical resolution.")]
[CategoryAttribute("NotateXpress")]
[BrowsableAttribute(true)]
public LineScaling LineScaling {get; set;}
[C++]
[DescriptionAttribute("Inidciates how all lines are scaled relative to an image’s vertical resolution.")]
[CategoryAttribute("NotateXpress")]
[BrowsableAttribute(true)]
public: __property LineScaling get_LineScaling();
public: __property void set_LineScaling(
   LineScaling value
);
[C++/CLI]
[DescriptionAttribute("Inidciates how all lines are scaled relative to an image’s vertical resolution.")]
[CategoryAttribute("NotateXpress")]
[BrowsableAttribute(true)]
public:
property LineScaling LineScaling {
   LineScaling get();
   void set (LineScaling value);
}

Value

The LineScaling enumeration value set.

Remarks

This property determines how the size of the line is rendered.

When LineScaling is Normal, a line is simply scaled by the current zoom percentage of the image. This is the default of NotateXpress, and the only option prior to version 9. When LineScaling is set to YResolution and ImagXpress contains a valid value for the Resolution Y property, a line is scaled to take this vertical dpi value into account.

See Also

NotateXpress Class | NotateXpress Members | LineScaling Property


MultiLineEdit Property

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

MultiLineEdit Property

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : MultiLineEdit Property

Gets and sets whether to use a standard Multi-line edit control to edit text.

[Visual Basic]
<BrowsableAttribute(True)>
<CategoryAttribute("NotateXpress")>
<DescriptionAttribute("Inidciates whether the TextTool uses a standard Multi-line edit control to edit text.")>
Public Property MultiLineEdit As Boolean
[C#]
[BrowsableAttribute(true)]
[CategoryAttribute("NotateXpress")]
[DescriptionAttribute("Inidciates whether the TextTool uses a standard Multi-line edit control to edit text.")]
public bool MultiLineEdit {get; set;}
[C++]
[BrowsableAttribute(true)]
[CategoryAttribute("NotateXpress")]
[DescriptionAttribute("Inidciates whether the TextTool uses a standard Multi-line edit control to edit text.")]
public: __property bool get_MultiLineEdit();
public: __property void set_MultiLineEdit(
   bool value
);
[C++/CLI]
[BrowsableAttribute(true)]
[CategoryAttribute("NotateXpress")]
[DescriptionAttribute("Inidciates whether the TextTool uses a standard Multi-line edit control to edit text.")]
public:
property bool MultiLineEdit {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true when NotateXpress uses a standard Windows Multi-line edit control to edit existing text. Otherwise, false is returned when NotateXpress uses its own built-in editing features.

Remarks

The default value is false.

See Also

NotateXpress Class | NotateXpress Members


NoteIcon Property

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NoteIcon Property

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : NoteIcon Property

Gets and sets the icon associated with the Notetool.

[Visual Basic]
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Property NoteIcon As IntPtr
[C#]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public IntPtr NoteIcon {get; set;}
[C++]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property IntPtr get_NoteIcon();
public: __property void set_NoteIcon(
   IntPtr value
);
[C++/CLI]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property IntPtr NoteIcon {
   IntPtr get();
   void set (IntPtr value);
}

Value

The handle to an icon.

Remarks

Make sure that the icon does not go out of scope, as the application controls ownership of the icon.

Note: This property should be set once as its associated with the NotateXpress object.

Example

How to load in an icon handle

[C#]

private System.Drawing.Icon mynewicon; nope
mynewicon = new System.Drawing.Icon("c:\\images\\test.ico");
NotateXpress1.NoteIcon = mynewicon.Handle;

See Also

NotateXpress Class | NotateXpress Members


PageNumber Property

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PageNumber Property

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : PageNumber Property

Gets and sets the page number.

[Visual Basic]
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Property PageNumber As Integer
[C#]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public int PageNumber {get; set;}
[C++]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property int get_PageNumber();
public: __property void set_PageNumber(
   int value
);
[C++/CLI]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property int PageNumber {
   int get();
   void set (int value);
}

Value

An integer value which represents the page number.

Remarks

Note: This property is only valid for nxxml and xfdf files.

See Also

NotateXpress Class | NotateXpress Members


RecalibrateXdpi Property

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

RecalibrateXdpi Property

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : RecalibrateXdpi Property

Gets and sets the x (horizontal) coordinate value for the DPI (dots per inch).

[Visual Basic]
<BrowsableAttribute(True)>
<DescriptionAttribute("Inidciates the x DPI if the user should need to scale the ruler.")>
<CategoryAttribute("NotateXpress")>
Public Property RecalibrateXdpi As Integer
[C#]
[BrowsableAttribute(true)]
[DescriptionAttribute("Inidciates the x DPI if the user should need to scale the ruler.")]
[CategoryAttribute("NotateXpress")]
public int RecalibrateXdpi {get; set;}
[C++]
[BrowsableAttribute(true)]
[DescriptionAttribute("Inidciates the x DPI if the user should need to scale the ruler.")]
[CategoryAttribute("NotateXpress")]
public: __property int get_RecalibrateXdpi();
public: __property void set_RecalibrateXdpi(
   int value
);
[C++/CLI]
[BrowsableAttribute(true)]
[DescriptionAttribute("Inidciates the x DPI if the user should need to scale the ruler.")]
[CategoryAttribute("NotateXpress")]
public:
property int RecalibrateXdpi {
   int get();
   void set (int value);
}

Value

An integer value which represents the x coordinate value for the DPI.

Remarks

Note: This is only used for the ruler annotation calculating the size of the ruler.

Normally a user would not have to set this as NotateXpress automatically gets this from ImagXpress. A user may want to use this if they need to scale the ruler or if ImagXpress should ever produce an incorrect value.

See Also

NotateXpress Class | NotateXpress Members


RecalibrateYdpi Property

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

RecalibrateYdpi Property

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : RecalibrateYdpi Property

Gets and sets the y (vertical) coordinate value for the DPI (dots per inch).

[Visual Basic]
<DescriptionAttribute("Inidciates the x dpi if the user should need to scale the ruler.")>
<BrowsableAttribute(True)>
<CategoryAttribute("NotateXpress")>
Public Property RecalibrateYdpi As Integer
[C#]
[DescriptionAttribute("Inidciates the x dpi if the user should need to scale the ruler.")]
[BrowsableAttribute(true)]
[CategoryAttribute("NotateXpress")]
public int RecalibrateYdpi {get; set;}
[C++]
[DescriptionAttribute("Inidciates the x dpi if the user should need to scale the ruler.")]
[BrowsableAttribute(true)]
[CategoryAttribute("NotateXpress")]
public: __property int get_RecalibrateYdpi();
public: __property void set_RecalibrateYdpi(
   int value
);
[C++/CLI]
[DescriptionAttribute("Inidciates the x dpi if the user should need to scale the ruler.")]
[BrowsableAttribute(true)]
[CategoryAttribute("NotateXpress")]
public:
property int RecalibrateYdpi {
   int get();
   void set (int value);
}

Value

An integer value which represents the y coordinate value for the DPI.

Remarks

This is only used for the ruler annotation calculating the size of the ruler.

Normally, a user would not have to set this as NotateXpress automatically gets this from ImagXpress. A user may want to use this if they need to scale the ruler or if ImagXpress should ever produce an incorrect value.

See Also

NotateXpress Class | NotateXpress Members


ToolbarDefaults Property

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToolbarDefaults Property

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : ToolbarDefaults Property (NotateXpress)

Gets and sets access to all of the global toolbar defaults.

[Visual Basic]
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Property ToolbarDefaults As ToolbarDefaults
[C#]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public ToolbarDefaults ToolbarDefaults {get; set;}
[C++]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property ToolbarDefaults* get_ToolbarDefaults();
public: __property void set_ToolbarDefaults(
   ToolbarDefaults* value
);
[C++/CLI]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property ToolbarDefaults^ ToolbarDefaults {
   ToolbarDefaults^ get();
   void set (ToolbarDefaults^ value);
}

Value

The ToolbarDefaults set.

See Also

NotateXpress Class | NotateXpress Members


ToolTipTimeEdit Property

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToolTipTimeEdit Property

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : ToolTipTimeEdit Property

Gets or sets the amount of time to display tooltip window in Edit mode.

[Visual Basic]
<BrowsableAttribute(True)>
<DescriptionAttribute("Inidciates the amount of time a ToolTip window remains visible if the pointer is stationary within a tool's bounding rectangle in Edit mode.")>
<CategoryAttribute("NotateXpress")>
Public Property ToolTipTimeEdit As Integer
[C#]
[BrowsableAttribute(true)]
[DescriptionAttribute("Inidciates the amount of time a ToolTip window remains visible if the pointer is stationary within a tool's bounding rectangle in Edit mode.")]
[CategoryAttribute("NotateXpress")]
public int ToolTipTimeEdit {get; set;}
[C++]
[BrowsableAttribute(true)]
[DescriptionAttribute("Inidciates the amount of time a ToolTip window remains visible if the pointer is stationary within a tool's bounding rectangle in Edit mode.")]
[CategoryAttribute("NotateXpress")]
public: __property int get_ToolTipTimeEdit();
public: __property void set_ToolTipTimeEdit(
   int value
);
[C++/CLI]
[BrowsableAttribute(true)]
[DescriptionAttribute("Inidciates the amount of time a ToolTip window remains visible if the pointer is stationary within a tool's bounding rectangle in Edit mode.")]
[CategoryAttribute("NotateXpress")]
public:
property int ToolTipTimeEdit {
   int get();
   void set (int value);
}

Value

An integer which represents the amount of time to display the tooltip window.

Remarks

A value of -1 will cause the tooltip to not be displayed.

This controls the amount of time a ToolTip window remains visible if the pointer is stationary within a tool's bounding rectangle in Edit mode.

See Also

NotateXpress Class | NotateXpress Members


ToolTipTimeInteractive Property

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToolTipTimeInteractive Property

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : ToolTipTimeInteractive Property

Gets or sets the amount of time a tooltip window remains visible.

[Visual Basic]
<DescriptionAttribute("Inidciates the amount of time a ToolTip window remains visible if the pointer is stationary within a tool's bounding rectangle in Interactive mode.")>
<CategoryAttribute("NotateXpress")>
<BrowsableAttribute(True)>
Public Property ToolTipTimeInteractive As Integer
[C#]
[DescriptionAttribute("Inidciates the amount of time a ToolTip window remains visible if the pointer is stationary within a tool's bounding rectangle in Interactive mode.")]
[CategoryAttribute("NotateXpress")]
[BrowsableAttribute(true)]
public int ToolTipTimeInteractive {get; set;}
[C++]
[DescriptionAttribute("Inidciates the amount of time a ToolTip window remains visible if the pointer is stationary within a tool's bounding rectangle in Interactive mode.")]
[CategoryAttribute("NotateXpress")]
[BrowsableAttribute(true)]
public: __property int get_ToolTipTimeInteractive();
public: __property void set_ToolTipTimeInteractive(
   int value
);
[C++/CLI]
[DescriptionAttribute("Inidciates the amount of time a ToolTip window remains visible if the pointer is stationary within a tool's bounding rectangle in Interactive mode.")]
[CategoryAttribute("NotateXpress")]
[BrowsableAttribute(true)]
public:
property int ToolTipTimeInteractive {
   int get();
   void set (int value);
}

Value

The ToolTipTimeInteractive.

Remarks

A value of -1 will cause the tooltip to not be displayed.

This controls the amount of time a ToolTip window remains visible if the pointer is stationary within a tool's bounding rectangle in Interactive mode.

See Also

NotateXpress Class | NotateXpress Members


Update Property

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Update Property

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : Update Property

Gets and sets whether annotations render to the display.

[Visual Basic]
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Property Update As Boolean
[C#]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public bool Update {get; set;}
[C++]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property bool get_Update();
public: __property void set_Update(
   bool value
);
[C++/CLI]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property bool Update {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true to render annotations to the display. Otherwise, false is returned.

Remarks

Sets whether annotations will paint. Setting Update to False prevents annotations from painting. When Update is subsequently set to True, the annotations are invalidated and immediately painted.

See Also

NotateXpress Class | NotateXpress Members


NotateXpress Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NotateXpress Class Events

PegasusImaging.WinForms.NotateXpress9 Namespace : NotateXpress Class

For a list of all members of this type, see NotateXpress members.

Public Events

Public Event AnnotationAdded | Fires when an annotation has been added.
Public Event AnnotationDeleted | Fires when an annotation has been deleted.
Public Event AnnotationEndSelected | Fires when no annotations are selected.
Public Event AnnotationMoved | Fires when an annotation has been moved.
Public Event AnnotationSelected | Fires when an annotation has been selected.
Public Event Click | Occurs when an annotation object is clicked in Interactive Mode.
Public Event ContextMenu | Occurs when an element is right clicked in edit mode, and the built in NotateXpress context menu is turned off.
Public Event CurrentLayerChange | The CurrentLayerChange Event is fired whenever the current layer changes.
Public Event Disposed (Inherited from System.ComponentModel.Component) | Adds an event handler to listen to the Disposed event on the component.
Public Event DoubleClick | Occurs when an annotation object is double clicked in Interactive Mode.
Public Event Dropped | Fires when xfdf annotations that are not supported by NotateXpress are read in.
Public Event GroupDeselected | Fired when an annotation group is unselected
Public Event GroupSelected | Fired when an annotation group is selected
Public Event ItemChanged | The ItemChanged event is sent when an annotation object changes. When an object is moved or resized by the user, an AnnotationMoved is fired.
Public Event LayerRestored | The LayerRestored Event is fired for each layer restored during the loading of a previously saved annotation file.
Public Event MappingInput | This event is for an advanced user who wants to change how NotateXpress does its coordinate conversions.
Public Event MappingOutput | This event is for an advanced user who wants to change how NotateXpress does its coordinate conversions.
Public Event MenuSelect | The MenuSelect event is fired when a user chooses any of the items on the NotateXpress context menu while over an annotation or on the toolbar.
Public Event MouseDown | Occurs when an annotation object receives a MouseDown event in Interactive Mode.
Public Event MouseMove | Occurs when the mouse is moved over an annotation object in Interactive Mode.
Public Event MouseUp | Occurs when an annotation object receives a MouseUp event in Interactive Mode.
Public Event RequestLayerPassword | The RequestLayerPassword event is sent during the loading of an annotation file for all layers that were saved with a password.
Public Event Stamping | The Stamping event is sent immediately before each stamp tool use, providing an opportunity to change the stamp text of the annotation object before it is added.
Public Event TextEditEnd | Fired when text editing has ended. Editing is now disabled
Public Event TextEditStart | Fired when The user has double-clicked a text item and editing is now enabled.
Public Event ToolbarSelect | The ToolbarSelect event is fired when a selection changes for the current tool on the toolbar.
Public Event UserDraw | The UserDraw event is raised for a Rectangle object during its paint when the Rectangle’s UserDraw attribute is True.
Public Event UserGroupCreated | The UserGroupCreated event is sent when a user creates a new group by selecting multiple objects and then pressing Ctrl-G.
Public Event UserGroupDestroyed | The UserGroupDestroyed event is sent when a user destroys a selected group by pressing Ctrl-U.

See Also

NotateXpress Class | PegasusImaging.WinForms.NotateXpress9 Namespace


AnnotationAdded Event

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

AnnotationAdded Event

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : AnnotationAdded Event

Fires when an annotation has been added.

[Visual Basic]
<CategoryAttribute("NotateXpress")>
Public Event AnnotationAdded() As NotateXpress.AnnotationAddedEventHandler
[C#]
[CategoryAttribute("NotateXpress")]
public event NotateXpress.AnnotationAddedEventHandler AnnotationAdded();
[C++]
[CategoryAttribute("NotateXpress")]
public: __event NotateXpress.AnnotationAddedEventHandler* AnnotationAdded();
[C++/CLI]
[CategoryAttribute("NotateXpress")]
public:
event NotateXpress::AnnotationAddedEventHandler^ AnnotationAdded();

Event Data

The event handler receives an argument of type AnnotationAddedEventArgs containing data related to this event. The following AnnotationAddedEventArgs properties provide information specific to this event.

Property | Description
Element | Gets the element that was added.
Layer | Gets the layer on which the element was added.

See Also

NotateXpress Class | NotateXpress Members


AnnotationDeleted Event

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

AnnotationDeleted Event

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : AnnotationDeleted Event

Fires when an annotation has been deleted.

[Visual Basic]
<CategoryAttribute("NotateXpress")>
Public Event AnnotationDeleted() As NotateXpress.AnnotationDeletedEventHandler
[C#]
[CategoryAttribute("NotateXpress")]
public event NotateXpress.AnnotationDeletedEventHandler AnnotationDeleted();
[C++]
[CategoryAttribute("NotateXpress")]
public: __event NotateXpress.AnnotationDeletedEventHandler* AnnotationDeleted();
[C++/CLI]
[CategoryAttribute("NotateXpress")]
public:
event NotateXpress::AnnotationDeletedEventHandler^ AnnotationDeleted();

Event Data

The event handler receives an argument of type AnnotationDeletedEventArgs containing data related to this event. The following AnnotationDeletedEventArgs properties provide information specific to this event.

Property | Description
Element | Gets the element that was deleted.
Layer | Gets the layer that the deleted element was on.

See Also

NotateXpress Class | NotateXpress Members


AnnotationEndSelected Event

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

AnnotationEndSelected Event

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : AnnotationEndSelected Event

Fires when no annotations are selected.

[Visual Basic]
<CategoryAttribute("NotateXpress")>
Public Event AnnotationEndSelected() As NotateXpress.AnnotationEndSelectedEventHandler
[C#]
[CategoryAttribute("NotateXpress")]
public event NotateXpress.AnnotationEndSelectedEventHandler AnnotationEndSelected();
[C++]
[CategoryAttribute("NotateXpress")]
public: __event NotateXpress.AnnotationEndSelectedEventHandler* AnnotationEndSelected();
[C++/CLI]
[CategoryAttribute("NotateXpress")]
public:
event NotateXpress::AnnotationEndSelectedEventHandler^ AnnotationEndSelected();

See Also

NotateXpress Class | NotateXpress Members


AnnotationMoved Event

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

AnnotationMoved Event

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : AnnotationMoved Event

Fires when an annotation has been moved.

[Visual Basic]
<CategoryAttribute("NotateXpress")>
Public Event AnnotationMoved() As NotateXpress.AnnotationMovedEventHandler
[C#]
[CategoryAttribute("NotateXpress")]
public event NotateXpress.AnnotationMovedEventHandler AnnotationMoved();
[C++]
[CategoryAttribute("NotateXpress")]
public: __event NotateXpress.AnnotationMovedEventHandler* AnnotationMoved();
[C++/CLI]
[CategoryAttribute("NotateXpress")]
public:
event NotateXpress::AnnotationMovedEventHandler^ AnnotationMoved();

Event Data

The event handler receives an argument of type AnnotationMovedEventArgs containing data related to this event. The following AnnotationMovedEventArgs properties provide information specific to this event.

Property | Description
Element | Gets the element that was moved.
Layer | Gets the layer on which the element moved.

See Also

NotateXpress Class | NotateXpress Members


AnnotationSelected Event

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

AnnotationSelected Event

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : AnnotationSelected Event

Fires when an annotation has been selected.

[Visual Basic]
<CategoryAttribute("NotateXpress")>
Public Event AnnotationSelected() As NotateXpress.AnnotationSelectedEventHandler
[C#]
[CategoryAttribute("NotateXpress")]
public event NotateXpress.AnnotationSelectedEventHandler AnnotationSelected();
[C++]
[CategoryAttribute("NotateXpress")]
public: __event NotateXpress.AnnotationSelectedEventHandler* AnnotationSelected();
[C++/CLI]
[CategoryAttribute("NotateXpress")]
public:
event NotateXpress::AnnotationSelectedEventHandler^ AnnotationSelected();

Event Data

The event handler receives an argument of type AnnotationSelectedEventArgs containing data related to this event. The following AnnotationSelectedEventArgs properties provide information specific to this event.

Property | Description
Element | Gets the element that was selected.
Layer | Gets the layer on which the element was selected.

See Also

NotateXpress Class | NotateXpress Members


Click Event

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Click Event

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : Click Event

Occurs when an annotation object is clicked in Interactive Mode.

[Visual Basic]
<CategoryAttribute("NotateXpress")>
Public Event Click() As NotateXpress.ClickEventHandler
[C#]
[CategoryAttribute("NotateXpress")]
public event NotateXpress.ClickEventHandler Click();
[C++]
[CategoryAttribute("NotateXpress")]
public: __event NotateXpress.ClickEventHandler* Click();
[C++/CLI]
[CategoryAttribute("NotateXpress")]
public:
event NotateXpress::ClickEventHandler^ Click();

Event Data

The event handler receives an argument of type ClickEventArgs containing data related to this event. The following ClickEventArgs properties provide information specific to this event.

Property | Description
Element | Gets the element for the click events.
Layer | Gets the layer for the click events.

See Also

NotateXpress Class | NotateXpress Members


ContextMenu Event

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ContextMenu Event

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : ContextMenu Event

Occurs when an element is right clicked in edit mode, and the built in NotateXpress context menu is turned off.

[Visual Basic]
<CategoryAttribute("NotateXpress")>
Public Event ContextMenu() As NotateXpress.ContextMenuEventHandler
[C#]
[CategoryAttribute("NotateXpress")]
public event NotateXpress.ContextMenuEventHandler ContextMenu();
[C++]
[CategoryAttribute("NotateXpress")]
public: __event NotateXpress.ContextMenuEventHandler* ContextMenu();
[C++/CLI]
[CategoryAttribute("NotateXpress")]
public:
event NotateXpress::ContextMenuEventHandler^ ContextMenu();

Event Data

The event handler receives an argument of type ContextMenuEventArgs containing data related to this event. The following ContextMenuEventArgs properties provide information specific to this event.

Property | Description
Element | Gets the element that was clicked.
Layer | Gets the layer on which the element was clicked.

See Also

NotateXpress Class | NotateXpress Members


CurrentLayerChange Event

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

CurrentLayerChange Event

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : CurrentLayerChange Event

The CurrentLayerChange Event is fired whenever the current layer changes.

[Visual Basic]
<CategoryAttribute("NotateXpress")>
Public Event CurrentLayerChange() As NotateXpress.CurrentLayerChangeEventHandler
[C#]
[CategoryAttribute("NotateXpress")]
public event NotateXpress.CurrentLayerChangeEventHandler CurrentLayerChange();
[C++]
[CategoryAttribute("NotateXpress")]
public: __event NotateXpress.CurrentLayerChangeEventHandler* CurrentLayerChange();
[C++/CLI]
[CategoryAttribute("NotateXpress")]
public:
event NotateXpress::CurrentLayerChangeEventHandler^ CurrentLayerChange();

Event Data

The event handler receives an argument of type CurrentLayerChangeEventArgs containing data related to this event. The following CurrentLayerChangeEventArgs properties provide information specific to this event.

Property | Description
Layer | Gets the layer that was changed to.

See Also

NotateXpress Class | NotateXpress Members


DoubleClick Event

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

DoubleClick Event

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : DoubleClick Event

Occurs when an annotation object is double clicked in Interactive Mode.

[Visual Basic]
<CategoryAttribute("NotateXpress")>
Public Event DoubleClick() As NotateXpress.DoubleClickEventHandler
[C#]
[CategoryAttribute("NotateXpress")]
public event NotateXpress.DoubleClickEventHandler DoubleClick();
[C++]
[CategoryAttribute("NotateXpress")]
public: __event NotateXpress.DoubleClickEventHandler* DoubleClick();
[C++/CLI]
[CategoryAttribute("NotateXpress")]
public:
event NotateXpress::DoubleClickEventHandler^ DoubleClick();

Event Data

The event handler receives an argument of type DoubleClickEventArgs containing data related to this event. The following DoubleClickEventArgs properties provide information specific to this event.

Property | Description
Element | Gets the element for the double click event.
Layer | Gets the layer for the double click event.

See Also

NotateXpress Class | NotateXpress Members


Dropped Event

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Dropped Event

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : Dropped Event

Fires when xfdf annotations that are not supported by NotateXpress are read in.

[Visual Basic]
<CategoryAttribute("NotateXpress")>
Public Event Dropped() As NotateXpress.DroppedEventHandler
[C#]
[CategoryAttribute("NotateXpress")]
public event NotateXpress.DroppedEventHandler Dropped();
[C++]
[CategoryAttribute("NotateXpress")]
public: __event NotateXpress.DroppedEventHandler* Dropped();
[C++/CLI]
[CategoryAttribute("NotateXpress")]
public:
event NotateXpress::DroppedEventHandler^ Dropped();

Event Data

The event handler receives an argument of type DroppedEventArgs containing data related to this event. The following DroppedEventArgs properties provide information specific to this event.

Property | Description
DroppedData | Gets the data for unsupported XFDF annotations, such as sound and fileattachment annotations.

Remarks

One type that is currently unsupported is video.

See Also

NotateXpress Class | NotateXpress Members


GroupDeselected Event

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GroupDeselected Event

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : GroupDeselected Event

Fired when an annotation group is unselected

[Visual Basic]
<CategoryAttribute("NotateXpress")>
Public Event GroupDeselected() As NotateXpress.GroupDeselectedEventHandler
[C#]
[CategoryAttribute("NotateXpress")]
public event NotateXpress.GroupDeselectedEventHandler GroupDeselected();
[C++]
[CategoryAttribute("NotateXpress")]
public: __event NotateXpress.GroupDeselectedEventHandler* GroupDeselected();
[C++/CLI]
[CategoryAttribute("NotateXpress")]
public:
event NotateXpress::GroupDeselectedEventHandler^ GroupDeselected();

See Also

NotateXpress Class | NotateXpress Members


GroupSelected Event

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GroupSelected Event

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : GroupSelected Event (NotateXpress)

Fired when an annotation group is selected

[Visual Basic]
<CategoryAttribute("NotateXpress")>
Public Event GroupSelected() As NotateXpress.GroupSelectedEventHandler
[C#]
[CategoryAttribute("NotateXpress")]
public event NotateXpress.GroupSelectedEventHandler GroupSelected();
[C++]
[CategoryAttribute("NotateXpress")]
public: __event NotateXpress.GroupSelectedEventHandler* GroupSelected();
[C++/CLI]
[CategoryAttribute("NotateXpress")]
public:
event NotateXpress::GroupSelectedEventHandler^ GroupSelected();

Event Data

The event handler receives an argument of type GroupSelectedEventArgs containing data related to this event. The following GroupSelectedEventArgs properties provide information specific to this event.

Property | Description
Group | Gets the group that was selected.

See Also

NotateXpress Class | NotateXpress Members


ItemChanged Event

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ItemChanged Event

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : ItemChanged Event

The ItemChanged event is sent when an annotation object changes. When an object is moved or resized by the user, an AnnotationMoved is fired.

[Visual Basic]
<CategoryAttribute("NotateXpress")>
Public Event ItemChanged() As NotateXpress.ItemChangedEventHandler
[C#]
[CategoryAttribute("NotateXpress")]
public event NotateXpress.ItemChangedEventHandler ItemChanged();
[C++]
[CategoryAttribute("NotateXpress")]
public: __event NotateXpress.ItemChangedEventHandler* ItemChanged();
[C++/CLI]
[CategoryAttribute("NotateXpress")]
public:
event NotateXpress::ItemChangedEventHandler^ ItemChanged();

Event Data

The event handler receives an argument of type ItemChangedEventArgs containing data related to this event. The following ItemChangedEventArgs properties provide information specific to this event.

Property | Description
Attribute | Gets the NotateTrait enumeration value of the attribute that changed.
Element | Gets the Element that changed.
Layer | Gets the layer on which the element that changed resides.

See Also

NotateXpress Class | NotateXpress Members


LayerRestored Event

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

LayerRestored Event

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : LayerRestored Event

The LayerRestored Event is fired for each layer restored during the loading of a previously saved annotation file.

[Visual Basic]
<CategoryAttribute("NotateXpress")>
Public Event LayerRestored() As NotateXpress.LayerRestoredEventHandler
[C#]
[CategoryAttribute("NotateXpress")]
public event NotateXpress.LayerRestoredEventHandler LayerRestored();
[C++]
[CategoryAttribute("NotateXpress")]
public: __event NotateXpress.LayerRestoredEventHandler* LayerRestored();
[C++/CLI]
[CategoryAttribute("NotateXpress")]
public:
event NotateXpress::LayerRestoredEventHandler^ LayerRestored();

Event Data

The event handler receives an argument of type LayerRestoredEventArgs containing data related to this event. The following LayerRestoredEventArgs properties provide information specific to this event.

Property | Description
Layer | Gets the layer which was restored.

See Also

NotateXpress Class | NotateXpress Members


MappingInput Event

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

MappingInput Event

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : MappingInput Event

This event is for an advanced user who wants to change how NotateXpress does its coordinate conversions.

[Visual Basic]
<CategoryAttribute("NotateXpress")>
Public Event MappingInput() As NotateXpress.MappingInputEventHandler
[C#]
[CategoryAttribute("NotateXpress")]
public event NotateXpress.MappingInputEventHandler MappingInput();
[C++]
[CategoryAttribute("NotateXpress")]
public: __event NotateXpress.MappingInputEventHandler* MappingInput();
[C++/CLI]
[CategoryAttribute("NotateXpress")]
public:
event NotateXpress::MappingInputEventHandler^ MappingInput();

Event Data

The event handler receives an argument of type MappingInputEventArgs containing data related to this event. The following MappingInputEventArgs properties provide information specific to this event.

Property | Description
NewX | Gets the mapped x coordinate of the annotation currently being imported. Setting this property will modify x position of the imported annotation.
NewY | Gets the mapped y coordinate of the annotation currently being imported. Setting this property will modify the y position of the imported annotation.
X | Gets the unmapped x coordinate of the annotation currently being imported.
Y | Gets the unmapped y coordinate of the annotation currently being imported.

Remarks

This event is fired when reading in an xml based annotation format that is specified for a coordinate system that is calculated. The nxxml would have to been saved using SaveOptions.Mapping of PDF or User for this to fire in nxxml. This will always fire when reading in a xfdf.

See Also

NotateXpress Class | NotateXpress Members


MappingOutput Event

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

MappingOutput Event

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : MappingOutput Event

This event is for an advanced user who wants to change how NotateXpress does its coordinate conversions.

[Visual Basic]
<CategoryAttribute("NotateXpress")>
Public Event MappingOutput() As NotateXpress.MappingOutputEventHandler
[C#]
[CategoryAttribute("NotateXpress")]
public event NotateXpress.MappingOutputEventHandler MappingOutput();
[C++]
[CategoryAttribute("NotateXpress")]
public: __event NotateXpress.MappingOutputEventHandler* MappingOutput();
[C++/CLI]
[CategoryAttribute("NotateXpress")]
public:
event NotateXpress::MappingOutputEventHandler^ MappingOutput();

Event Data

The event handler receives an argument of type MappingOutputEventArgs containing data related to this event. The following MappingOutputEventArgs properties provide information specific to this event.

Property | Description
NewX | Gets the mapped x coordinate of the annotation currently being exported. Setting this property will modify the x position of the exported annotation.
NewY | Gets the mapped y coordinate of the annotation currently being exported. Setting this property will modify the y position of the exported annotation.
X | Gets the unmapped x coordinate of the annotation currently being exported.
Y | Gets the unmapped y coordinate of the annotation currently being exported.

Remarks

para>This event is fired when writing in an xml based annotation format that is specified for a coordinate system that is calculated. The nxxml would have to been set using SaveOptions.Mapping of PDF or User for this to fire in nxxml. This will always fire when reading in a xfdf.

See Also

NotateXpress Class | NotateXpress Members


MenuSelect Event

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

MenuSelect Event

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : MenuSelect Event

The MenuSelect event is fired when a user chooses any of the items on the NotateXpress context menu while over an annotation or on the toolbar.

[Visual Basic]
<CategoryAttribute("NotateXpress")>
Public Event MenuSelect() As NotateXpress.MenuEventHandler
[C#]
[CategoryAttribute("NotateXpress")]
public event NotateXpress.MenuEventHandler MenuSelect();
[C++]
[CategoryAttribute("NotateXpress")]
public: __event NotateXpress.MenuEventHandler* MenuSelect();
[C++/CLI]
[CategoryAttribute("NotateXpress")]
public:
event NotateXpress::MenuEventHandler^ MenuSelect();

Event Data

The event handler receives an argument of type MenuEventArgs containing data related to this event. The following MenuEventArgs properties provide information specific to this event.

Property | Description
Element | Gets the element in which the menu is associated.
Layer | Gets the layer on which the element which triggered the menu resides.
Menu | Gets the type of menu (context or toolbar) selected at the time of the event.
SubMenuId | Gets the sub menu ID of the item selected at the time of the event.
Tool | Gets the toolbar tool with which the menu is associated.
TopMenuId | Gets the top menu ID of the item selected at the time of the event.
User1 | Gets the first user defined property associated with a menu item.
User2 | Gets the second user defined property associated with a menu item.

See Also

NotateXpress Class | NotateXpress Members


MouseDown Event

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

MouseDown Event

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : MouseDown Event

Occurs when an annotation object receives a MouseDown event in Interactive Mode.

[Visual Basic]
<CategoryAttribute("NotateXpress")>
Public Event MouseDown() As NotateXpress.MouseDownEventHandler
[C#]
[CategoryAttribute("NotateXpress")]
public event NotateXpress.MouseDownEventHandler MouseDown();
[C++]
[CategoryAttribute("NotateXpress")]
public: __event NotateXpress.MouseDownEventHandler* MouseDown();
[C++/CLI]
[CategoryAttribute("NotateXpress")]
public:
event NotateXpress::MouseDownEventHandler^ MouseDown();

Event Data

The event handler receives an argument of type MouseDownEventArgs containing data related to this event. The following MouseDownEventArgs properties provide information specific to this event.

Property | Description
Element | Gets the element that was selected at the time of the mouse down event.
Layer | Gets the layer that was selected at the time of the mouse down event.
MouseButtons | Gets the mouse button that was selected at the time of the mouse down event.
Shift | Gets the shift key state that was selected at the time of the mouse down event.
X | Gets the x coordinate of the cursor at the time of the mouse down event.
Y | Gets the y coordinate of the cursor at the time of the mouse down event.

See Also

NotateXpress Class | NotateXpress Members


MouseMove Event

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

MouseMove Event

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : MouseMove Event

Occurs when the mouse is moved over an annotation object in Interactive Mode.

[Visual Basic]
<CategoryAttribute("NotateXpress")>
Public Event MouseMove() As NotateXpress.MouseMoveEventHandler
[C#]
[CategoryAttribute("NotateXpress")]
public event NotateXpress.MouseMoveEventHandler MouseMove();
[C++]
[CategoryAttribute("NotateXpress")]
public: __event NotateXpress.MouseMoveEventHandler* MouseMove();
[C++/CLI]
[CategoryAttribute("NotateXpress")]
public:
event NotateXpress::MouseMoveEventHandler^ MouseMove();

Event Data

The event handler receives an argument of type MouseMoveEventArgs containing data related to this event. The following MouseMoveEventArgs properties provide information specific to this event.

Property | Description
Element | Gets the element that was clicked on to create the event.
Layer | Gets the layer that was active at the time of the mouse move event.
MouseButtons | Gets the mouse button which generated the event.
Shift | Gets the shift key state when the event was generated.
X | Gets the x coordinate of the cursor at the end of the mouse move event.
Y | Gets the y coordinate of the cursor at the end of the mouse move event.

See Also

NotateXpress Class | NotateXpress Members


MouseUp Event

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

MouseUp Event

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : MouseUp Event

Occurs when an annotation object receives a MouseUp event in Interactive Mode.

[Visual Basic]
<CategoryAttribute("NotateXpress")>
Public Event MouseUp() As NotateXpress.MouseUpEventHandler
[C#]
[CategoryAttribute("NotateXpress")]
public event NotateXpress.MouseUpEventHandler MouseUp();
[C++]
[CategoryAttribute("NotateXpress")]
public: __event NotateXpress.MouseUpEventHandler* MouseUp();
[C++/CLI]
[CategoryAttribute("NotateXpress")]
public:
event NotateXpress::MouseUpEventHandler^ MouseUp();

Event Data

The event handler receives an argument of type MouseUpEventArgs containing data related to this event. The following MouseUpEventArgs properties provide information specific to this event.

Property | Description
Element | Gets the element that was clicked on to generate the event.
Layer | Gets the layer that was active at the time of the mouse up event.
MouseButtons | Gets the mouse button that was used to generate the mouse up event.
Shift | Gets the shift key state when the event was generated.
X | Gets the x coordinate of the cursor where the mouse up event occured.
Y | Gets the y coordinate of the cursor where the mouse up event occured.

See Also

NotateXpress Class | NotateXpress Members


RequestLayerPassword Event

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

RequestLayerPassword Event

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : RequestLayerPassword Event

The RequestLayerPassword event is sent during the loading of an annotation file for all layers that were saved with a password.

[Visual Basic]
<CategoryAttribute("NotateXpress")>
Public Event RequestLayerPassword() As NotateXpress.GetLayerPasswordEventHandler
[C#]
[CategoryAttribute("NotateXpress")]
public event NotateXpress.GetLayerPasswordEventHandler RequestLayerPassword();
[C++]
[CategoryAttribute("NotateXpress")]
public: __event NotateXpress.GetLayerPasswordEventHandler* RequestLayerPassword();
[C++/CLI]
[CategoryAttribute("NotateXpress")]
public:
event NotateXpress::GetLayerPasswordEventHandler^ RequestLayerPassword();

Event Data

The event handler receives an argument of type GetLayerPasswordEventArgs containing data related to this event. The following GetLayerPasswordEventArgs properties provide information specific to this event.

Property | Description
LayerName | Gets the layer name of the layer that needs a password.
LayerPassword | SETS the password for the current layer.

Remarks

If the correct password is returned from this event, the layer is decrypted and available for display.

The layer is discarded if an incorrect password is supplied.

The LayerName parameter supplied with the event is the name (if any) set as the name of this layer.

To set the correct password, modify the passed LayerPassword parameter.

See Also

NotateXpress Class | NotateXpress Members


Stamping Event

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Stamping Event

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : Stamping Event

The Stamping event is sent immediately before each stamp tool use, providing an opportunity to change the stamp text of the annotation object before it is added.

[Visual Basic]
<CategoryAttribute("NotateXpress")>
Public Event Stamping() As NotateXpress.StampingEventHandler
[C#]
[CategoryAttribute("NotateXpress")]
public event NotateXpress.StampingEventHandler Stamping();
[C++]
[CategoryAttribute("NotateXpress")]
public: __event NotateXpress.StampingEventHandler* Stamping();
[C++/CLI]
[CategoryAttribute("NotateXpress")]
public:
event NotateXpress::StampingEventHandler^ Stamping();

See Also

NotateXpress Class | NotateXpress Members


TextEditEnd Event

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TextEditEnd Event

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : TextEditEnd Event

Fired when text editing has ended. Editing is now disabled

[Visual Basic]
<CategoryAttribute("NotateXpress")>
Public Event TextEditEnd() As NotateXpress.TextEditEndEventHandler
[C#]
[CategoryAttribute("NotateXpress")]
public event NotateXpress.TextEditEndEventHandler TextEditEnd();
[C++]
[CategoryAttribute("NotateXpress")]
public: __event NotateXpress.TextEditEndEventHandler* TextEditEnd();
[C++/CLI]
[CategoryAttribute("NotateXpress")]
public:
event NotateXpress::TextEditEndEventHandler^ TextEditEnd();

Event Data

The event handler receives an argument of type TextEditEndEventArgs containing data related to this event. The following TextEditEndEventArgs properties provide information specific to this event.

Property | Description
Element | Gets the element that is being edited.
Layer | Gets the layer on which the text element resides.

See Also

NotateXpress Class | NotateXpress Members


TextEditStart Event

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TextEditStart Event

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : TextEditStart Event

Fired when The user has double-clicked a text item and editing is now enabled.

[Visual Basic]
<CategoryAttribute("NotateXpress")>
Public Event TextEditStart() As NotateXpress.TextEditStartEventHandler
[C#]
[CategoryAttribute("NotateXpress")]
public event NotateXpress.TextEditStartEventHandler TextEditStart();
[C++]
[CategoryAttribute("NotateXpress")]
public: __event NotateXpress.TextEditStartEventHandler* TextEditStart();
[C++/CLI]
[CategoryAttribute("NotateXpress")]
public:
event NotateXpress::TextEditStartEventHandler^ TextEditStart();

Event Data

The event handler receives an argument of type TextEditStartEventArgs containing data related to this event. The following TextEditStartEventArgs properties provide information specific to this event.

Property | Description
Element | Gets the element that is being edited.
Layer | Gets the layer on which the text element resides.

See Also

NotateXpress Class | NotateXpress Members


ToolbarSelect Event

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToolbarSelect Event

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : ToolbarSelect Event

The ToolbarSelect event is fired when a selection changes for the current tool on the toolbar.

[Visual Basic]
<CategoryAttribute("NotateXpress")>
Public Event ToolbarSelect() As NotateXpress.ToolbarEventHandler
[C#]
[CategoryAttribute("NotateXpress")]
public event NotateXpress.ToolbarEventHandler ToolbarSelect();
[C++]
[CategoryAttribute("NotateXpress")]
public: __event NotateXpress.ToolbarEventHandler* ToolbarSelect();
[C++/CLI]
[CategoryAttribute("NotateXpress")]
public:
event NotateXpress::ToolbarEventHandler^ ToolbarSelect();

Event Data

The event handler receives an argument of type ToolbarEventArgs containing data related to this event. The following ToolbarEventArgs properties provide information specific to this event.

Property | Description
Layer | Gets the current layer.
Tool | Gets the active tool.

See Also

NotateXpress Class | NotateXpress Members


UserDraw Event

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

UserDraw Event

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : UserDraw Event (NotateXpress)

The UserDraw event is raised for a Rectangle object during its paint when the Rectangle’s UserDraw attribute is True.

[Visual Basic]
<CategoryAttribute("NotateXpress")>
Public Event UserDraw() As NotateXpress.UserDrawEventHandler
[C#]
[CategoryAttribute("NotateXpress")]
public event NotateXpress.UserDrawEventHandler UserDraw();
[C++]
[CategoryAttribute("NotateXpress")]
public: __event NotateXpress.UserDrawEventHandler* UserDraw();
[C++/CLI]
[CategoryAttribute("NotateXpress")]
public:
event NotateXpress::UserDrawEventHandler^ UserDraw();

Event Data

The event handler receives an argument of type UserDrawEventArgs containing data related to this event. The following UserDrawEventArgs properties provide information specific to this event.

Property | Description
Element | Gets the rectangle element being drawn.
HandleDeviceContext | Gets the device context to draw to.
Height | Gets the height of the rectangle to draw.
Layer | Gets the layer on which the rectangle is drawn.
UserLong | Gets the user supplied data.
Width | Gets the width of the rectangle to draw.
X | Gets the x coordinate of the rectangle to draw.
Y | Gets the y coordinate of the rectangle to draw.

Remarks

When the UserDraw event is raised, the Rectangle does not perform its normal painting, but simply raises the event.

The event passes the device context, the Rectangle’s coordinates, Layer, Element, and UserLong.

See Also

NotateXpress Class | NotateXpress Members


UserGroupCreated Event

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

UserGroupCreated Event

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : UserGroupCreated Event

The UserGroupCreated event is sent when a user creates a new group by selecting multiple objects and then pressing Ctrl-G.

[Visual Basic]
<CategoryAttribute("NotateXpress")>
Public Event UserGroupCreated() As NotateXpress.UserGroupCreatedEventHandler
[C#]
[CategoryAttribute("NotateXpress")]
public event NotateXpress.UserGroupCreatedEventHandler UserGroupCreated();
[C++]
[CategoryAttribute("NotateXpress")]
public: __event NotateXpress.UserGroupCreatedEventHandler* UserGroupCreated();
[C++/CLI]
[CategoryAttribute("NotateXpress")]
public:
event NotateXpress::UserGroupCreatedEventHandler^ UserGroupCreated();

Event Data

The event handler receives an argument of type UserGroupCreatedEventArgs containing data related to this event. The following UserGroupCreatedEventArgs properties provide information specific to this event.

Property | Description
Group | Gets the group that was created.
Layer | Gets the layer on which the group resides.

Remarks

In order for the user to create a group in this manner, the property AllowUserGrouping must be set to true.

See Also

NotateXpress Class | NotateXpress Members


UserGroupDestroyed Event

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

UserGroupDestroyed Event

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : UserGroupDestroyed Event

The UserGroupDestroyed event is sent when a user destroys a selected group by pressing Ctrl-U.

[Visual Basic]
<CategoryAttribute("NotateXpress")>
Public Event UserGroupDestroyed() As NotateXpress.UserGroupDestroyedEventHandler
[C#]
[CategoryAttribute("NotateXpress")]
public event NotateXpress.UserGroupDestroyedEventHandler UserGroupDestroyed();
[C++]
[CategoryAttribute("NotateXpress")]
public: __event NotateXpress.UserGroupDestroyedEventHandler* UserGroupDestroyed();
[C++/CLI]
[CategoryAttribute("NotateXpress")]
public:
event NotateXpress::UserGroupDestroyedEventHandler^ UserGroupDestroyed();

Event Data

The event handler receives an argument of type UserGroupDestroyedEventArgs containing data related to this event. The following UserGroupDestroyedEventArgs properties provide information specific to this event.

Property | Description
Group | Gets the group that is destroyed.
Layer | Gets the layer on which the group resides.

Remarks

In order for the user to destroy a group in this manner, the property AllowUserGrouping must be set to true.

See Also

NotateXpress Class | NotateXpress Members


NotateXpressException Class

NotateXpressException Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NotateXpressException Class

PegasusImaging.WinForms.NotateXpress9 Namespace : NotateXpressException Class

Error class of exceptions raised or returned by the NotateXpress class.

For a list of all members of this type, see NotateXpressException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.NotateXpress9.NotateXpressException
PegasusImaging.WinForms.NotateXpress9.BrandingException
PegasusImaging.WinForms.NotateXpress9.BrandingSourceDibException
PegasusImaging.WinForms.NotateXpress9.ClipboardException
PegasusImaging.WinForms.NotateXpress9.DuplicateItemException
PegasusImaging.WinForms.NotateXpress9.DuplicateMenuIdException
PegasusImaging.WinForms.NotateXpress9.FileOpenException
PegasusImaging.WinForms.NotateXpress9.FileSecurityException
PegasusImaging.WinForms.NotateXpress9.FileWriteException
PegasusImaging.WinForms.NotateXpress9.GroupCreationException
PegasusImaging.WinForms.NotateXpress9.InvalidAnnotationFileException
PegasusImaging.WinForms.NotateXpress9.InvalidAttributeException
PegasusImaging.WinForms.NotateXpress9.InvalidColorTypeException
PegasusImaging.WinForms.NotateXpress9.InvalidContextException
PegasusImaging.WinForms.NotateXpress9.InvalidContextIdException
PegasusImaging.WinForms.NotateXpress9.InvalidCursorTypeException
PegasusImaging.WinForms.NotateXpress9.InvalidErrorLevelException
PegasusImaging.WinForms.NotateXpress9.InvalidFontException
PegasusImaging.WinForms.NotateXpress9.InvalidGroupException
PegasusImaging.WinForms.NotateXpress9.InvalidHatchStyleException
PegasusImaging.WinForms.NotateXpress9.InvalidItemException
PegasusImaging.WinForms.NotateXpress9.InvalidLayerException
PegasusImaging.WinForms.NotateXpress9.InvalidModeException
PegasusImaging.WinForms.NotateXpress9.InvalidParameterException
PegasusImaging.WinForms.NotateXpress9.InvalidPasswordException
PegasusImaging.WinForms.NotateXpress9.InvalidPointException
PegasusImaging.WinForms.NotateXpress9.InvalidTiffAnnTypeException
PegasusImaging.WinForms.NotateXpress9.InvalidToolException
PegasusImaging.WinForms.NotateXpress9.InvalidVariantException
PegasusImaging.WinForms.NotateXpress9.InvalidWangTypeException
PegasusImaging.WinForms.NotateXpress9.InvalidWindowHandleException
PegasusImaging.WinForms.NotateXpress9.ItemNotFoundException
PegasusImaging.WinForms.NotateXpress9.NoCurrentLayerException
PegasusImaging.WinForms.NotateXpress9.NoSelectionException
PegasusImaging.WinForms.NotateXpress9.NotSupportedException
PegasusImaging.WinForms.NotateXpress9.ObjectNotConnectedException
PegasusImaging.WinForms.NotateXpress9.OutOfMemoryException
PegasusImaging.WinForms.NotateXpress9.PageNotFoundException
PegasusImaging.WinForms.NotateXpress9.SaveFileOneLayerException
PegasusImaging.WinForms.NotateXpress9.StorageStreamException
PegasusImaging.WinForms.NotateXpress9.TmsAnnotationBadActivateCodeException
PegasusImaging.WinForms.NotateXpress9.TmsAnnotationBadAlignmentException
PegasusImaging.WinForms.NotateXpress9.TmsAnnotationBadArrowsException
PegasusImaging.WinForms.NotateXpress9.TmsAnnotationBadBorderStyleException
PegasusImaging.WinForms.NotateXpress9.TmsAnnotationBadColorMapFlagException
PegasusImaging.WinForms.NotateXpress9.TmsAnnotationBadCoordinateException
PegasusImaging.WinForms.NotateXpress9.TmsAnnotationBadDirectionException
PegasusImaging.WinForms.NotateXpress9.TmsAnnotationBadHeaderException
PegasusImaging.WinForms.NotateXpress9.TmsAnnotationBadRecordException
PegasusImaging.WinForms.NotateXpress9.TmsAnnotationBadRedactionFlagException
PegasusImaging.WinForms.NotateXpress9.TmsAnnotationBadTransparentFlagException
PegasusImaging.WinForms.NotateXpress9.TmsAnnotationBadVersionException
PegasusImaging.WinForms.NotateXpress9.UnableLoadAnnotationDllException
PegasusImaging.WinForms.NotateXpress9.UnableToCreateStorageException
PegasusImaging.WinForms.NotateXpress9.XmlFatalException
PegasusImaging.WinForms.NotateXpress9.XmlGeneralException
PegasusImaging.WinForms.NotateXpress9.XmlInvalidHeaderException
PegasusImaging.WinForms.NotateXpress9.XmlInvalidPageDataException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public Class NotateXpressException
   Inherits ApplicationException
   Implements ISerializable, _Exception
[C#]
[SerializableAttribute()]
public class NotateXpressException : ApplicationException, ISerializable, _Exception
[C++]
[SerializableAttribute()]
public __gc class NotateXpressException : public ApplicationException, ISerializable, _Exception
[C++/CLI]
[SerializableAttribute()]
public ref class NotateXpressException : public ApplicationException, ISerializable, _Exception

See Also

NotateXpressException Members | PegasusImaging.WinForms.NotateXpress9 Namespace


NotateXpressException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NotateXpressException Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : NotateXpressException Class

NotateXpressException overview

Public Constructors

Public Constructor NotateXpressException Constructor Overloaded. The main constructor for the NotateXpressException class.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

NotateXpressException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


NotateXpressException Constructor

NotateXpressException Class | NotateXpressException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NotateXpressException Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpressException Class : NotateXpressException Constructor (NotateXpressException)

The main constructor for the NotateXpressException class.

Overload List

The main constructor for the NotateXpressException class.

[Visual Basic] Public Sub New()

[C#] public NotateXpressException();

[C++] public NotateXpressException();

[C++/CLI] public NotateXpressException();

Base exception which allows you to pass in an error number.

[Visual Basic] Public Sub New(Integer)

[C#] public NotateXpressException(int);

[C++] public NotateXpressException(int);

[C++/CLI] public NotateXpressException(int);

Base exception which allows you to pass in a message.

[Visual Basic] Public Sub New(String)

[C#] public NotateXpressException(string);

[C++] public NotateXpressException(string*);

[C++/CLI] public NotateXpressException(String^);

Base exception which allows you to pass in an error number and message.

[Visual Basic] Public Sub New(Integer,String)

[C#] public NotateXpressException(int,string);

[C++] public NotateXpressException(int,string*);

[C++/CLI] public NotateXpressException(int,String^);

Base exception which allows you to pass in a message and inner exception.

[Visual Basic] Public Sub New(String,Exception)

[C#] public NotateXpressException(string,Exception);

[C++] public NotateXpressException(string*,Exception*);

[C++/CLI] public NotateXpressException(String^,Exception^);

See Also

NotateXpressException Class | NotateXpressException Members


NotateXpressException Constructor()

NotateXpressException Class | NotateXpressException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NotateXpressException Constructor()

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpressException Class > NotateXpressException Constructor : NotateXpressException Constructor()

The main constructor for the NotateXpressException class.

[Visual Basic]
Public Function New()
[C#]
public NotateXpressException();
[C++]
public: NotateXpressException();
[C++/CLI]
public:
NotateXpressException();

See Also

NotateXpressException Class | NotateXpressException Members | Overload List


NotateXpressException Constructor(Int32)

NotateXpressException Class | NotateXpressException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NotateXpressException Constructor(Int32)

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpressException Class > NotateXpressException Constructor : NotateXpressException Constructor(Int32)

Base exception which allows you to pass in an error number.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public NotateXpressException(
   int errorNumber
);
[C++]
public: NotateXpressException(
   int errorNumber
)
[C++/CLI]
public:
NotateXpressException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

NotateXpressException Class | NotateXpressException Members | Overload List


NotateXpressException Constructor(Int32,String)

NotateXpressException Class | NotateXpressException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NotateXpressException Constructor(Int32,String)

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpressException Class > NotateXpressException Constructor : NotateXpressException Constructor(Int32,String)

Base exception which allows you to pass in an error number and message.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public NotateXpressException(
   int errorNumber,
   string message
);
[C++]
public: NotateXpressException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
NotateXpressException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

NotateXpressException Class | NotateXpressException Members | Overload List


NotateXpressException Constructor(String)

NotateXpressException Class | NotateXpressException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the error message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NotateXpressException Constructor(String)

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpressException Class > NotateXpressException Constructor : NotateXpressException Constructor(String)

Base exception which allows you to pass in a message.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public NotateXpressException(
   string message
);
[C++]
public: NotateXpressException(
   string* message
)
[C++/CLI]
public:
NotateXpressException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

NotateXpressException Class | NotateXpressException Members | Overload List


NotateXpressException Constructor(String,Exception)

NotateXpressException Class | NotateXpressException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NotateXpressException Constructor(String,Exception)

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpressException Class > NotateXpressException Constructor : NotateXpressException Constructor(String,Exception)

Base exception which allows you to pass in a message and inner exception.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public NotateXpressException(
   string message,
   Exception innerException
);
[C++]
public: NotateXpressException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
NotateXpressException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception.

See Also

NotateXpressException Class | NotateXpressException Members | Overload List


NotateXpressException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NotateXpressException Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : NotateXpressException Class

For a list of all members of this type, see NotateXpressException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

NotateXpressException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Number Property

NotateXpressException Class | NotateXpressException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Number Property

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpressException Class : Number Property

Gets the error number raised by the exception.

[Visual Basic]
Public ReadOnly Property Number As Integer
[C#]
public int Number {get;}
[C++]
public: __property int get_Number();
[C++/CLI]
public:
property int Number {
   int get();
}

See Also

NotateXpressException Class | NotateXpressException Members


NoteTool Class

NoteTool Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NoteTool Class

PegasusImaging.WinForms.NotateXpress9 Namespace : NoteTool Class

This class implements objects used to create Note annotations, which can edit and display text when double clicked.

For a list of all members of this type, see NoteTool members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.NotateXpress9.Element
PegasusImaging.WinForms.NotateXpress9.NoteTool

Syntax

[Visual Basic]
Public Class NoteTool
   Inherits Element
   Implements IDisposable
[C#]
public class NoteTool : Element, IDisposable
[C++]
public __gc class NoteTool : public Element, IDisposable
[C++/CLI]
public ref class NoteTool : public Element, IDisposable

See Also

NoteTool Members | PegasusImaging.WinForms.NotateXpress9 Namespace


NoteTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NoteTool Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : NoteTool Class

NoteTool overview

Public Constructors

Public Constructor NoteTool Constructor Default constructor for the NoteTool class.

Public Properties

Public Property BackColor | Gets and sets the color of the background used within the note annotation.
Public Property BoundingRectangle (Inherited from Element) | Gets and sets the rectangle boundary for the element.
Public Property CreateTime (Inherited from Element) | A Read only property that gets the time when the element was created.
Public Property Fixed (Inherited from Element) | Gets and sets whether an annotation has a fixed position with respect to the control window.
Public Property GroupMember (Inherited from Element) | Gets the group which the element belongs to.
Public Property IsGroupMember (Inherited from Element) | A read only property that gets a value which determines if the element is a member of a group or not.
Public Property Locked (Inherited from Element) | Gets and sets an indicator whether an annotation element can be selected or moved by a user in Edit mode.
Public Property Moveable (Inherited from Element) | Gets and sets whether the element can be moved by a user in Edit mode.
Public Property NumberPoints (Inherited from Element) | A Read only property that gets the number of points currently used to define the element.
Public Property Selected (Inherited from Element) | Gets and sets whether the element has been selected.
Public Property ShowHandles (Inherited from Element) | Gets and sets whether selection handles are displayed on an object when it is selected.
Public Property Text | Gets and sets the string value used within the note annotation.
Public Property TextColor | Gets and sets the color of the text used within the note annotation.
Public Property TextFont | Gets and sets the font of the text used within the note annotation.
Public Property TextJustification | Gets and sets how the text within the note annotation is justified.
Public Property TextLocked | Gets and sets whether or not the text within the annotation are editable.
Public Property ToolTipText (Inherited from Element) | Gets and sets a string value in the element that will become the ToolTipText value associated with the element.
Public Property UserLong (Inherited from Element) | Gets and sets a user defined long value associated with the element.
Public Property UserString (Inherited from Element) | Gets and sets a user-defined string associated with the element.
Public Property Visible (Inherited from Element) | Gets and sets whether the element is visible.
Public Property WangType | Gets and sets if specific Eastman/Wang compatible attributes are applied to a text annotation.

Public Methods

Public Method Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public Method NudgeDown (Inherited from Element) | Moves the specified annotation object one level down, towards the back, in the painting order of the specified layer.
Public Method NudgeUp (Inherited from Element) | Moves the specified annotation object one level up, towards the front, in the painting order of the specified layer.
Public Method UserDataAdd (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataDelete (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFind (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFindFirst (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFindNext (Inherited from Element) | User data can be added to each element in a key value pair.

See Also

NoteTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace


NoteTool Constructor

NoteTool Class | NoteTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NoteTool Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > NoteTool Class : NoteTool Constructor (NoteTool)

Default constructor for the NoteTool class.

[Visual Basic]
Public Function New()
[C#]
public NoteTool();
[C++]
public: NoteTool();
[C++/CLI]
public:
NoteTool();

See Also

NoteTool Class | NoteTool Members


Dispose Method

NoteTool Class | NoteTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Dispose Method

PegasusImaging.WinForms.NotateXpress9 Namespace > NoteTool Class : Dispose Method (NoteTool)

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();
[C++]
public: void Dispose();
[C++/CLI]
public:
void Dispose();

See Also

NoteTool Class | NoteTool Members


NoteTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NoteTool Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : NoteTool Class

For a list of all members of this type, see NoteTool members.

Public Properties

Public Property BackColor | Gets and sets the color of the background used within the note annotation.
Public Property BoundingRectangle (Inherited from Element) | Gets and sets the rectangle boundary for the element.
Public Property CreateTime (Inherited from Element) | A Read only property that gets the time when the element was created.
Public Property Fixed (Inherited from Element) | Gets and sets whether an annotation has a fixed position with respect to the control window.
Public Property GroupMember (Inherited from Element) | Gets the group which the element belongs to.
Public Property IsGroupMember (Inherited from Element) | A read only property that gets a value which determines if the element is a member of a group or not.
Public Property Locked (Inherited from Element) | Gets and sets an indicator whether an annotation element can be selected or moved by a user in Edit mode.
Public Property Moveable (Inherited from Element) | Gets and sets whether the element can be moved by a user in Edit mode.
Public Property NumberPoints (Inherited from Element) | A Read only property that gets the number of points currently used to define the element.
Public Property Selected (Inherited from Element) | Gets and sets whether the element has been selected.
Public Property ShowHandles (Inherited from Element) | Gets and sets whether selection handles are displayed on an object when it is selected.
Public Property Text | Gets and sets the string value used within the note annotation.
Public Property TextColor | Gets and sets the color of the text used within the note annotation.
Public Property TextFont | Gets and sets the font of the text used within the note annotation.
Public Property TextJustification | Gets and sets how the text within the note annotation is justified.
Public Property TextLocked | Gets and sets whether or not the text within the annotation are editable.
Public Property ToolTipText (Inherited from Element) | Gets and sets a string value in the element that will become the ToolTipText value associated with the element.
Public Property UserLong (Inherited from Element) | Gets and sets a user defined long value associated with the element.
Public Property UserString (Inherited from Element) | Gets and sets a user-defined string associated with the element.
Public Property Visible (Inherited from Element) | Gets and sets whether the element is visible.
Public Property WangType | Gets and sets if specific Eastman/Wang compatible attributes are applied to a text annotation.

See Also

NoteTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace


BackColor Property

NoteTool Class | NoteTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BackColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > NoteTool Class : BackColor Property (NoteTool)

Gets and sets the color of the background used within the note annotation.

[Visual Basic]
Public Property BackColor As Color
[C#]
public Color BackColor {get; set;}
[C++]
public: __property Color get_BackColor();
public: __property void set_BackColor(
   Color value
);
[C++/CLI]
public:
property Color BackColor {
   Color get();
   void set (Color value);
}

Value

The Color of the background.

See Also

NoteTool Class | NoteTool Members


Text Property

NoteTool Class | NoteTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Text Property

PegasusImaging.WinForms.NotateXpress9 Namespace > NoteTool Class : Text Property (NoteTool)

Gets and sets the string value used within the note annotation.

[Visual Basic]
Public Property Text As String
[C#]
public string Text {get; set;}
[C++]
public: __property string* get_Text();
public: __property void set_Text(
   string* value
);
[C++/CLI]
public:
property String^ Text {
   String^ get();
   void set (String^ value);
}

Value

A string value which represents the text associated with the note.

See Also

NoteTool Class | NoteTool Members


TextColor Property

NoteTool Class | NoteTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TextColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > NoteTool Class : TextColor Property (NoteTool)

Gets and sets the color of the text used within the note annotation.

[Visual Basic]
Public Property TextColor As Color
[C#]
public Color TextColor {get; set;}
[C++]
public: __property Color get_TextColor();
public: __property void set_TextColor(
   Color value
);
[C++/CLI]
public:
property Color TextColor {
   Color get();
   void set (Color value);
}

Value

The Color of the text.

See Also

NoteTool Class | NoteTool Members


TextFont Property

NoteTool Class | NoteTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TextFont Property

PegasusImaging.WinForms.NotateXpress9 Namespace > NoteTool Class : TextFont Property (NoteTool)

Gets and sets the font of the text used within the note annotation.

[Visual Basic]
Public Property TextFont As Font
[C#]
public Font TextFont {get; set;}
[C++]
public: __property Font* get_TextFont();
public: __property void set_TextFont(
   Font* value
);
[C++/CLI]
public:
property Font^ TextFont {
   Font^ get();
   void set (Font^ value);
}

Value

A Font which represents the text font.

See Also

NoteTool Class | NoteTool Members


TextJustification Property

NoteTool Class | NoteTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TextJustification Property

PegasusImaging.WinForms.NotateXpress9 Namespace > NoteTool Class : TextJustification Property (NoteTool)

Gets and sets how the text within the note annotation is justified.

[Visual Basic]
Public Property TextJustification As TextJustification
[C#]
public TextJustification TextJustification {get; set;}
[C++]
public: __property TextJustification get_TextJustification();
public: __property void set_TextJustification(
   TextJustification value
);
[C++/CLI]
public:
property TextJustification TextJustification {
   TextJustification get();
   void set (TextJustification value);
}

Value

The TextJustification set.

See Also

NoteTool Class | NoteTool Members


TextLocked Property

NoteTool Class | NoteTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TextLocked Property

PegasusImaging.WinForms.NotateXpress9 Namespace > NoteTool Class : TextLocked Property (NoteTool)

Gets and sets whether or not the text within the annotation are editable.

[Visual Basic]
Public Property TextLocked As Boolean
[C#]
public bool TextLocked {get; set;}
[C++]
public: __property bool get_TextLocked();
public: __property void set_TextLocked(
   bool value
);
[C++/CLI]
public:
property bool TextLocked {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true if locked. Otherwise, false is used and the text is not locked.

See Also

NoteTool Class | NoteTool Members


WangType Property

NoteTool Class | NoteTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

WangType Property

PegasusImaging.WinForms.NotateXpress9 Namespace > NoteTool Class : WangType Property (NoteTool)

Gets and sets if specific Eastman/Wang compatible attributes are applied to a text annotation.

[Visual Basic]
Public Property WangType As WangType
[C#]
public WangType WangType {get; set;}
[C++]
public: __property WangType get_WangType();
public: __property void set_WangType(
   WangType value
);
[C++/CLI]
public:
property WangType WangType {
   WangType get();
   void set (WangType value);
}

Value

The WangType which represents how the annotation is processed into an Eastman/Wang image.

See Also

NoteTool Class | NoteTool Members


NoteToolbarDefaults Class

NoteToolbarDefaults Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NoteToolbarDefaults Class

PegasusImaging.WinForms.NotateXpress9 Namespace : NoteToolbarDefaults Class (PegasusImaging.WinForms.NotateXpress9)

This class implements methods and properties used to create note annotations.

For a list of all members of this type, see NoteToolbarDefaults members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.NotateXpress9.BaseToolbarDefaults
PegasusImaging.WinForms.NotateXpress9.NoteToolbarDefaults

Syntax

[Visual Basic]
Public Class NoteToolbarDefaults
   Inherits BaseToolbarDefaults
[C#]
public class NoteToolbarDefaults : BaseToolbarDefaults
[C++]
public __gc class NoteToolbarDefaults : public BaseToolbarDefaults
[C++/CLI]
public ref class NoteToolbarDefaults : public BaseToolbarDefaults

See Also

NoteToolbarDefaults Members | PegasusImaging.WinForms.NotateXpress9 Namespace


NoteToolbarDefaults Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NoteToolbarDefaults Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : NoteToolbarDefaults Class (PegasusImaging.WinForms.NotateXpress9)

NoteToolbarDefaults overview

Public Constructors

Public Constructor NoteToolbarDefaults Constructor Default constructor for the NoteToolbarDefaults class.

Public Properties

Public Property BackColor | Gets and sets the color of the background used within the note annotation.
Public Property Fixed (Inherited from BaseToolbarDefaults) | Gets and sets whether an element is tied to the view instead of the image.
Public Property Locked (Inherited from BaseToolbarDefaults) | Gets and sets an indicator to lock an element so it cannot be selected or moved by a user in Edit mode.
Public Property Moveable (Inherited from BaseToolbarDefaults) | Gets and sets whether an element can be moved interactively during EditMode.
Public Property Selected (Inherited from BaseToolbarDefaults) | Gets and sets whether an element is automatically selected.
Public Property ShowHandles (Inherited from BaseToolbarDefaults) | Gets and sets whether selection handles are displayed for an element.
Public Property TextColor | Gets and sets the color of the text used within the note annotation.
Public Property TextFont | Gets and sets the font of the text used within the note annotation.
Public Property TextJustification | Gets and sets how the text within the note annotation is justified.
Public Property TextLocked | Gets and sets whether text is locked for the note annotation.
Public Property ToolTipText (Inherited from BaseToolbarDefaults) | Gets or sets a string value in the element that will become the ToolTipText value associated with the annotation once it is created.
Public Property UserLong (Inherited from BaseToolbarDefaults) | Gets and sets a long value in the element that will become the UserLong value associated with the element once it is created.
Public Property UserString (Inherited from BaseToolbarDefaults) | Gets and sets a string value in the element that will become the UserString value associated with the object once it is created.
Public Property Visible (Inherited from BaseToolbarDefaults) | Gets and sets the Visible attribute of an element.
Public Property WangType | Gets and sets if specific Eastman/Wang compatible attributes are applied to a text annotation.

See Also

NoteToolbarDefaults Class | PegasusImaging.WinForms.NotateXpress9 Namespace


NoteToolbarDefaults Constructor

NoteToolbarDefaults Class | NoteToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NoteToolbarDefaults Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > NoteToolbarDefaults Class : NoteToolbarDefaults Constructor (NoteToolbarDefaults)

Default constructor for the NoteToolbarDefaults class.

[Visual Basic]
Public Function New()
[C#]
public NoteToolbarDefaults();
[C++]
public: NoteToolbarDefaults();
[C++/CLI]
public:
NoteToolbarDefaults();

See Also

NoteToolbarDefaults Class | NoteToolbarDefaults Members


NoteToolbarDefaults Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NoteToolbarDefaults Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : NoteToolbarDefaults Class (PegasusImaging.WinForms.NotateXpress9)

For a list of all members of this type, see NoteToolbarDefaults members.

Public Properties

Public Property BackColor | Gets and sets the color of the background used within the note annotation.
Public Property Fixed (Inherited from BaseToolbarDefaults) | Gets and sets whether an element is tied to the view instead of the image.
Public Property Locked (Inherited from BaseToolbarDefaults) | Gets and sets an indicator to lock an element so it cannot be selected or moved by a user in Edit mode.
Public Property Moveable (Inherited from BaseToolbarDefaults) | Gets and sets whether an element can be moved interactively during EditMode.
Public Property Selected (Inherited from BaseToolbarDefaults) | Gets and sets whether an element is automatically selected.
Public Property ShowHandles (Inherited from BaseToolbarDefaults) | Gets and sets whether selection handles are displayed for an element.
Public Property TextColor | Gets and sets the color of the text used within the note annotation.
Public Property TextFont | Gets and sets the font of the text used within the note annotation.
Public Property TextJustification | Gets and sets how the text within the note annotation is justified.
Public Property TextLocked | Gets and sets whether text is locked for the note annotation.
Public Property ToolTipText (Inherited from BaseToolbarDefaults) | Gets or sets a string value in the element that will become the ToolTipText value associated with the annotation once it is created.
Public Property UserLong (Inherited from BaseToolbarDefaults) | Gets and sets a long value in the element that will become the UserLong value associated with the element once it is created.
Public Property UserString (Inherited from BaseToolbarDefaults) | Gets and sets a string value in the element that will become the UserString value associated with the object once it is created.
Public Property Visible (Inherited from BaseToolbarDefaults) | Gets and sets the Visible attribute of an element.
Public Property WangType | Gets and sets if specific Eastman/Wang compatible attributes are applied to a text annotation.

See Also

NoteToolbarDefaults Class | PegasusImaging.WinForms.NotateXpress9 Namespace


BackColor Property

NoteToolbarDefaults Class | NoteToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BackColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > NoteToolbarDefaults Class : BackColor Property (NoteToolbarDefaults)

Gets and sets the color of the background used within the note annotation.

[Visual Basic]
Public Property BackColor As Color
[C#]
public Color BackColor {get; set;}
[C++]
public: __property Color get_BackColor();
public: __property void set_BackColor(
   Color value
);
[C++/CLI]
public:
property Color BackColor {
   Color get();
   void set (Color value);
}

Value

The Color of the background.

Remarks

The default value is Black.

See Also

NoteToolbarDefaults Class | NoteToolbarDefaults Members


TextColor Property

NoteToolbarDefaults Class | NoteToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TextColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > NoteToolbarDefaults Class : TextColor Property (NoteToolbarDefaults)

Gets and sets the color of the text used within the note annotation.

[Visual Basic]
Public Property TextColor As Color
[C#]
public Color TextColor {get; set;}
[C++]
public: __property Color get_TextColor();
public: __property void set_TextColor(
   Color value
);
[C++/CLI]
public:
property Color TextColor {
   Color get();
   void set (Color value);
}

Value

The Color of the note annotation text.

Remarks

The default value is Black.

See Also

NoteToolbarDefaults Class | NoteToolbarDefaults Members


TextFont Property

NoteToolbarDefaults Class | NoteToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TextFont Property

PegasusImaging.WinForms.NotateXpress9 Namespace > NoteToolbarDefaults Class : TextFont Property (NoteToolbarDefaults)

Gets and sets the font of the text used within the note annotation.

[Visual Basic]
Public Property TextFont As Font
[C#]
public Font TextFont {get; set;}
[C++]
public: __property Font* get_TextFont();
public: __property void set_TextFont(
   Font* value
);
[C++/CLI]
public:
property Font^ TextFont {
   Font^ get();
   void set (Font^ value);
}

Value

A Font which represents the font of the text used on the note annotation.

Remarks

The default value is Arial, 9, Bold.

See Also

NoteToolbarDefaults Class | NoteToolbarDefaults Members


TextJustification Property

NoteToolbarDefaults Class | NoteToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TextJustification Property

PegasusImaging.WinForms.NotateXpress9 Namespace > NoteToolbarDefaults Class : TextJustification Property (NoteToolbarDefaults)

Gets and sets how the text within the note annotation is justified.

[Visual Basic]
Public Property TextJustification As TextJustification
[C#]
public TextJustification TextJustification {get; set;}
[C++]
public: __property TextJustification get_TextJustification();
public: __property void set_TextJustification(
   TextJustification value
);
[C++/CLI]
public:
property TextJustification TextJustification {
   TextJustification get();
   void set (TextJustification value);
}

Value

The TextJustification to use for the note annotation.

See Also

NoteToolbarDefaults Class | NoteToolbarDefaults Members


TextLocked Property

NoteToolbarDefaults Class | NoteToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TextLocked Property

PegasusImaging.WinForms.NotateXpress9 Namespace > NoteToolbarDefaults Class : TextLocked Property (NoteToolbarDefaults)

Gets and sets whether text is locked for the note annotation.

[Visual Basic]
Public Property TextLocked As Boolean
[C#]
public bool TextLocked {get; set;}
[C++]
public: __property bool get_TextLocked();
public: __property void set_TextLocked(
   bool value
);
[C++/CLI]
public:
property bool TextLocked {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true to lock the text. Otherwise, false is used and the text is not locked.

See Also

NoteToolbarDefaults Class | NoteToolbarDefaults Members


WangType Property

NoteToolbarDefaults Class | NoteToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

WangType Property

PegasusImaging.WinForms.NotateXpress9 Namespace > NoteToolbarDefaults Class : WangType Property (NoteToolbarDefaults)

Gets and sets if specific Eastman/Wang compatible attributes are applied to a text annotation.

[Visual Basic]
Public Property WangType As WangType
[C#]
public WangType WangType {get; set;}
[C++]
public: __property WangType get_WangType();
public: __property void set_WangType(
   WangType value
);
[C++/CLI]
public:
property WangType WangType {
   WangType get();
   void set (WangType value);
}

Value

The WangType which determines how the annotation is processed into a Eastman/Wang image.

See Also

NoteToolbarDefaults Class | NoteToolbarDefaults Members


NotSupportedException Class

NotSupportedException Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NotSupportedException Class

PegasusImaging.WinForms.NotateXpress9 Namespace : NotSupportedException Class

Exception class which is raised when an object is not supported and an error is returned by NotateXpress properties and methods.

For a list of all members of this type, see NotSupportedException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.NotateXpress9.NotateXpressException
PegasusImaging.WinForms.NotateXpress9.NotSupportedException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class NotSupportedException
   Inherits NotateXpressException
   Implements ISerializable, _Exception
[C#]
[SerializableAttribute()]
public sealed class NotSupportedException : NotateXpressException, ISerializable, _Exception
[C++]
[SerializableAttribute()]
public __gc __sealed class NotSupportedException : public NotateXpressException, ISerializable, _Exception
[C++/CLI]
[SerializableAttribute()]
public ref class NotSupportedException sealed : public NotateXpressException, ISerializable, _Exception

See Also

NotSupportedException Members | PegasusImaging.WinForms.NotateXpress9 Namespace


NotSupportedException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NotSupportedException Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : NotSupportedException Class

NotSupportedException overview

Public Constructors

Public Constructor NotSupportedException Constructor Overloaded. Main constructor for the NotSupportedException class when an object is not supported and an error is generated.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

NotSupportedException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


NotSupportedException Constructor

NotSupportedException Class | NotSupportedException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NotSupportedException Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > NotSupportedException Class : NotSupportedException Constructor (NotSupportedException)

Main constructor for the NotSupportedException class when an object is not supported and an error is generated.

Overload List

Main constructor for the NotSupportedException class when an object is not supported and an error is generated.

[Visual Basic] Public Sub New()

[C#] public NotSupportedException();

[C++] public NotSupportedException();

[C++/CLI] public NotSupportedException();

Exception which allows passing in an error number when an object is not supported and an error is generated.

[Visual Basic] Public Sub New(Integer)

[C#] public NotSupportedException(int);

[C++] public NotSupportedException(int);

[C++/CLI] public NotSupportedException(int);

Exception which allows passing in a message when an object is not supported and an error is generated.

[Visual Basic] Public Sub New(String)

[C#] public NotSupportedException(string);

[C++] public NotSupportedException(string*);

[C++/CLI] public NotSupportedException(String^);

Exception which allows passing in an error number and message when an object is not supported and an error is generated.

[Visual Basic] Public Sub New(Integer,String)

[C#] public NotSupportedException(int,string);

[C++] public NotSupportedException(int,string*);

[C++/CLI] public NotSupportedException(int,String^);

Exception which allows passing in a message and inner exception when an object is not supported and an error is generated.

[Visual Basic] Public Sub New(String,Exception)

[C#] public NotSupportedException(string,Exception);

[C++] public NotSupportedException(string*,Exception*);

[C++/CLI] public NotSupportedException(String^,Exception^);

See Also

NotSupportedException Class | NotSupportedException Members


NotSupportedException Constructor()

NotSupportedException Class | NotSupportedException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NotSupportedException Constructor()

PegasusImaging.WinForms.NotateXpress9 Namespace > NotSupportedException Class > NotSupportedException Constructor : NotSupportedException Constructor()

Main constructor for the NotSupportedException class when an object is not supported and an error is generated.

[Visual Basic]
Public Function New()
[C#]
public NotSupportedException();
[C++]
public: NotSupportedException();
[C++/CLI]
public:
NotSupportedException();

See Also

NotSupportedException Class | NotSupportedException Members | Overload List


NotSupportedException Constructor(Int32)

NotSupportedException Class | NotSupportedException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NotSupportedException Constructor(Int32)

PegasusImaging.WinForms.NotateXpress9 Namespace > NotSupportedException Class > NotSupportedException Constructor : NotSupportedException Constructor(Int32)

Exception which allows passing in an error number when an object is not supported and an error is generated.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public NotSupportedException(
   int errorNumber
);
[C++]
public: NotSupportedException(
   int errorNumber
)
[C++/CLI]
public:
NotSupportedException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

NotSupportedException Class | NotSupportedException Members | Overload List


NotSupportedException Constructor(Int32,String)

NotSupportedException Class | NotSupportedException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NotSupportedException Constructor(Int32,String)

PegasusImaging.WinForms.NotateXpress9 Namespace > NotSupportedException Class > NotSupportedException Constructor : NotSupportedException Constructor(Int32,String)

Exception which allows passing in an error number and message when an object is not supported and an error is generated.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public NotSupportedException(
   int errorNumber,
   string message
);
[C++]
public: NotSupportedException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
NotSupportedException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

NotSupportedException Class | NotSupportedException Members | Overload List


NotSupportedException Constructor(String)

NotSupportedException Class | NotSupportedException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NotSupportedException Constructor(String)

PegasusImaging.WinForms.NotateXpress9 Namespace > NotSupportedException Class > NotSupportedException Constructor : NotSupportedException Constructor(String)

Exception which allows passing in a message when an object is not supported and an error is generated.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public NotSupportedException(
   string message
);
[C++]
public: NotSupportedException(
   string* message
)
[C++/CLI]
public:
NotSupportedException(
   String^ message
)

Parameters

message
A string which represents the message.

See Also

NotSupportedException Class | NotSupportedException Members | Overload List


NotSupportedException Constructor(String,Exception)

NotSupportedException Class | NotSupportedException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NotSupportedException Constructor(String,Exception)

PegasusImaging.WinForms.NotateXpress9 Namespace > NotSupportedException Class > NotSupportedException Constructor : NotSupportedException Constructor(String,Exception)

Exception which allows passing in a message and inner exception when an object is not supported and an error is generated.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public NotSupportedException(
   string message,
   Exception innerException
);
[C++]
public: NotSupportedException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
NotSupportedException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception.

See Also

NotSupportedException Class | NotSupportedException Members | Overload List


ObjectNotConnectedException Class

ObjectNotConnectedException Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ObjectNotConnectedException Class

PegasusImaging.WinForms.NotateXpress9 Namespace : ObjectNotConnectedException Class

This class implements exceptions for object not connected errors.

For a list of all members of this type, see ObjectNotConnectedException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.NotateXpress9.NotateXpressException
PegasusImaging.WinForms.NotateXpress9.ObjectNotConnectedException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class ObjectNotConnectedException
   Inherits NotateXpressException
   Implements ISerializable, _Exception
[C#]
[SerializableAttribute()]
public sealed class ObjectNotConnectedException : NotateXpressException, ISerializable, _Exception
[C++]
[SerializableAttribute()]
public __gc __sealed class ObjectNotConnectedException : public NotateXpressException, ISerializable, _Exception
[C++/CLI]
[SerializableAttribute()]
public ref class ObjectNotConnectedException sealed : public NotateXpressException, ISerializable, _Exception

See Also

ObjectNotConnectedException Members | PegasusImaging.WinForms.NotateXpress9 Namespace


ObjectNotConnectedException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ObjectNotConnectedException Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : ObjectNotConnectedException Class

ObjectNotConnectedException overview

Public Constructors

Public Constructor ObjectNotConnectedException Constructor Overloaded. Exception for object not connected errors.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

ObjectNotConnectedException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


ObjectNotConnectedException Constructor

ObjectNotConnectedException Class | ObjectNotConnectedException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ObjectNotConnectedException Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > ObjectNotConnectedException Class : ObjectNotConnectedException Constructor (ObjectNotConnectedException)

Exception for object not connected errors.

Overload List

Exception for object not connected errors.

[Visual Basic] Public Sub New()

[C#] public ObjectNotConnectedException();

[C++] public ObjectNotConnectedException();

[C++/CLI] public ObjectNotConnectedException();

Exception which allows passing in an error number for object not connected errors.

[Visual Basic] Public Sub New(Integer)

[C#] public ObjectNotConnectedException(int);

[C++] public ObjectNotConnectedException(int);

[C++/CLI] public ObjectNotConnectedException(int);

Exception which allows passing in an error message for object not connected errors.

[Visual Basic] Public Sub New(String)

[C#] public ObjectNotConnectedException(string);

[C++] public ObjectNotConnectedException(string*);

[C++/CLI] public ObjectNotConnectedException(String^);

Exception which allows passing in an error number and message for object not connected errors.

[Visual Basic] Public Sub New(Integer,String)

[C#] public ObjectNotConnectedException(int,string);

[C++] public ObjectNotConnectedException(int,string*);

[C++/CLI] public ObjectNotConnectedException(int,String^);

Exception which allows passing in an error message and inner exception.

[Visual Basic] Public Sub New(String,Exception)

[C#] public ObjectNotConnectedException(string,Exception);

[C++] public ObjectNotConnectedException(string*,Exception*);

[C++/CLI] public ObjectNotConnectedException(String^,Exception^);

See Also

ObjectNotConnectedException Class | ObjectNotConnectedException Members


ObjectNotConnectedException Constructor()

ObjectNotConnectedException Class | ObjectNotConnectedException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ObjectNotConnectedException Constructor()

PegasusImaging.WinForms.NotateXpress9 Namespace > ObjectNotConnectedException Class > ObjectNotConnectedException Constructor : ObjectNotConnectedException Constructor()

Exception for object not connected errors.

[Visual Basic]
Public Function New()
[C#]
public ObjectNotConnectedException();
[C++]
public: ObjectNotConnectedException();
[C++/CLI]
public:
ObjectNotConnectedException();

See Also

ObjectNotConnectedException Class | ObjectNotConnectedException Members | Overload List


ObjectNotConnectedException Constructor(Int32)

ObjectNotConnectedException Class | ObjectNotConnectedException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer value which represents the error number.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ObjectNotConnectedException Constructor(Int32)

PegasusImaging.WinForms.NotateXpress9 Namespace > ObjectNotConnectedException Class > ObjectNotConnectedException Constructor : ObjectNotConnectedException Constructor(Int32)

Exception which allows passing in an error number for object not connected errors.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public ObjectNotConnectedException(
   int errorNumber
);
[C++]
public: ObjectNotConnectedException(
   int errorNumber
)
[C++/CLI]
public:
ObjectNotConnectedException(
   int errorNumber
)

Parameters

errorNumber
An integer value which represents the error number.

See Also

ObjectNotConnectedException Class | ObjectNotConnectedException Members | Overload List


ObjectNotConnectedException Constructor(Int32,String)

ObjectNotConnectedException Class | ObjectNotConnectedException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer value which represents the error number.
message
A string value which represents the error message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ObjectNotConnectedException Constructor(Int32,String)

PegasusImaging.WinForms.NotateXpress9 Namespace > ObjectNotConnectedException Class > ObjectNotConnectedException Constructor : ObjectNotConnectedException Constructor(Int32,String)

Exception which allows passing in an error number and message for object not connected errors.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public ObjectNotConnectedException(
   int errorNumber,
   string message
);
[C++]
public: ObjectNotConnectedException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
ObjectNotConnectedException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer value which represents the error number.
message
A string value which represents the error message.

See Also

ObjectNotConnectedException Class | ObjectNotConnectedException Members | Overload List


ObjectNotConnectedException Constructor(String)

ObjectNotConnectedException Class | ObjectNotConnectedException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string value which represents the error message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ObjectNotConnectedException Constructor(String)

PegasusImaging.WinForms.NotateXpress9 Namespace > ObjectNotConnectedException Class > ObjectNotConnectedException Constructor : ObjectNotConnectedException Constructor(String)

Exception which allows passing in an error message for object not connected errors.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public ObjectNotConnectedException(
   string message
);
[C++]
public: ObjectNotConnectedException(
   string* message
)
[C++/CLI]
public:
ObjectNotConnectedException(
   String^ message
)

Parameters

message
A string value which represents the error message.

See Also

ObjectNotConnectedException Class | ObjectNotConnectedException Members | Overload List


ObjectNotConnectedException Constructor(String,Exception)

ObjectNotConnectedException Class | ObjectNotConnectedException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string value which represents the error message.
innerException
An inner exception which further describes the error.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ObjectNotConnectedException Constructor(String,Exception)

PegasusImaging.WinForms.NotateXpress9 Namespace > ObjectNotConnectedException Class > ObjectNotConnectedException Constructor : ObjectNotConnectedException Constructor(String,Exception)

Exception which allows passing in an error message and inner exception.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public ObjectNotConnectedException(
   string message,
   Exception innerException
);
[C++]
public: ObjectNotConnectedException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
ObjectNotConnectedException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string value which represents the error message.
innerException
An inner exception which further describes the error.

See Also

ObjectNotConnectedException Class | ObjectNotConnectedException Members | Overload List


OutOfMemoryException Class

OutOfMemoryException Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

OutOfMemoryException Class

PegasusImaging.WinForms.NotateXpress9 Namespace : OutOfMemoryException Class

Exception class which is raised when there are memory limit errors.

For a list of all members of this type, see OutOfMemoryException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.NotateXpress9.NotateXpressException
PegasusImaging.WinForms.NotateXpress9.OutOfMemoryException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class OutOfMemoryException
   Inherits NotateXpressException
   Implements ISerializable, _Exception
[C#]
[SerializableAttribute()]
public sealed class OutOfMemoryException : NotateXpressException, ISerializable, _Exception
[C++]
[SerializableAttribute()]
public __gc __sealed class OutOfMemoryException : public NotateXpressException, ISerializable, _Exception
[C++/CLI]
[SerializableAttribute()]
public ref class OutOfMemoryException sealed : public NotateXpressException, ISerializable, _Exception

See Also

OutOfMemoryException Members | PegasusImaging.WinForms.NotateXpress9 Namespace


OutOfMemoryException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

OutOfMemoryException Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : OutOfMemoryException Class

OutOfMemoryException overview

Public Constructors

Public Constructor OutOfMemoryException Constructor Overloaded. Main constructor for the OutOfMemoryException class when there are memory limit errors.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

OutOfMemoryException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


OutOfMemoryException Constructor

OutOfMemoryException Class | OutOfMemoryException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

OutOfMemoryException Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > OutOfMemoryException Class : OutOfMemoryException Constructor (OutOfMemoryException)

Main constructor for the OutOfMemoryException class when there are memory limit errors.

Overload List

Main constructor for the OutOfMemoryException class when there are memory limit errors.

[Visual Basic] Public Sub New()

[C#] public OutOfMemoryException();

[C++] public OutOfMemoryException();

[C++/CLI] public OutOfMemoryException();

Exception which allows passing in an error number when there are memory limit errors.

[Visual Basic] Public Sub New(Integer)

[C#] public OutOfMemoryException(int);

[C++] public OutOfMemoryException(int);

[C++/CLI] public OutOfMemoryException(int);

Exception which allows passing in a message when there are memory limit errors.

[Visual Basic] Public Sub New(String)

[C#] public OutOfMemoryException(string);

[C++] public OutOfMemoryException(string*);

[C++/CLI] public OutOfMemoryException(String^);

Exception which allows passing in an error number and message when there are memory limit errors.

[Visual Basic] Public Sub New(Integer,String)

[C#] public OutOfMemoryException(int,string);

[C++] public OutOfMemoryException(int,string*);

[C++/CLI] public OutOfMemoryException(int,String^);

Exception which allows passing in a message and inner exception when there are memory limit errors.

[Visual Basic] Public Sub New(String,Exception)

[C#] public OutOfMemoryException(string,Exception);

[C++] public OutOfMemoryException(string*,Exception*);

[C++/CLI] public OutOfMemoryException(String^,Exception^);

See Also

OutOfMemoryException Class | OutOfMemoryException Members


OutOfMemoryException Constructor()

OutOfMemoryException Class | OutOfMemoryException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

OutOfMemoryException Constructor()

PegasusImaging.WinForms.NotateXpress9 Namespace > OutOfMemoryException Class > OutOfMemoryException Constructor : OutOfMemoryException Constructor()

Main constructor for the OutOfMemoryException class when there are memory limit errors.

[Visual Basic]
Public Function New()
[C#]
public OutOfMemoryException();
[C++]
public: OutOfMemoryException();
[C++/CLI]
public:
OutOfMemoryException();

See Also

OutOfMemoryException Class | OutOfMemoryException Members | Overload List


OutOfMemoryException Constructor(Int32)

OutOfMemoryException Class | OutOfMemoryException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

OutOfMemoryException Constructor(Int32)

PegasusImaging.WinForms.NotateXpress9 Namespace > OutOfMemoryException Class > OutOfMemoryException Constructor : OutOfMemoryException Constructor(Int32)

Exception which allows passing in an error number when there are memory limit errors.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public OutOfMemoryException(
   int errorNumber
);
[C++]
public: OutOfMemoryException(
   int errorNumber
)
[C++/CLI]
public:
OutOfMemoryException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

OutOfMemoryException Class | OutOfMemoryException Members | Overload List


OutOfMemoryException Constructor(Int32,String)

OutOfMemoryException Class | OutOfMemoryException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

OutOfMemoryException Constructor(Int32,String)

PegasusImaging.WinForms.NotateXpress9 Namespace > OutOfMemoryException Class > OutOfMemoryException Constructor : OutOfMemoryException Constructor(Int32,String)

Exception which allows passing in an error number and message when there are memory limit errors.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public OutOfMemoryException(
   int errorNumber,
   string message
);
[C++]
public: OutOfMemoryException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
OutOfMemoryException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

OutOfMemoryException Class | OutOfMemoryException Members | Overload List


OutOfMemoryException Constructor(String)

OutOfMemoryException Class | OutOfMemoryException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

OutOfMemoryException Constructor(String)

PegasusImaging.WinForms.NotateXpress9 Namespace > OutOfMemoryException Class > OutOfMemoryException Constructor : OutOfMemoryException Constructor(String)

Exception which allows passing in a message when there are memory limit errors.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public OutOfMemoryException(
   string message
);
[C++]
public: OutOfMemoryException(
   string* message
)
[C++/CLI]
public:
OutOfMemoryException(
   String^ message
)

Parameters

message
A string which represents the message.

See Also

OutOfMemoryException Class | OutOfMemoryException Members | Overload List


OutOfMemoryException Constructor(String,Exception)

OutOfMemoryException Class | OutOfMemoryException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

OutOfMemoryException Constructor(String,Exception)

PegasusImaging.WinForms.NotateXpress9 Namespace > OutOfMemoryException Class > OutOfMemoryException Constructor : OutOfMemoryException Constructor(String,Exception)

Exception which allows passing in a message and inner exception when there are memory limit errors.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public OutOfMemoryException(
   string message,
   Exception innerException
);
[C++]
public: OutOfMemoryException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
OutOfMemoryException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception.

See Also

OutOfMemoryException Class | OutOfMemoryException Members | Overload List


PageNotFoundException Class

PageNotFoundException Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PageNotFoundException Class

PegasusImaging.WinForms.NotateXpress9 Namespace : PageNotFoundException Class

Exception class raised when the current PageNumber is not found in the annotation file being loaded.

For a list of all members of this type, see PageNotFoundException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.NotateXpress9.NotateXpressException
PegasusImaging.WinForms.NotateXpress9.PageNotFoundException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class PageNotFoundException
   Inherits NotateXpressException
   Implements ISerializable, _Exception
[C#]
[SerializableAttribute()]
public sealed class PageNotFoundException : NotateXpressException, ISerializable, _Exception
[C++]
[SerializableAttribute()]
public __gc __sealed class PageNotFoundException : public NotateXpressException, ISerializable, _Exception
[C++/CLI]
[SerializableAttribute()]
public ref class PageNotFoundException sealed : public NotateXpressException, ISerializable, _Exception

See Also

PageNotFoundException Members | PegasusImaging.WinForms.NotateXpress9 Namespace


PageNotFoundException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PageNotFoundException Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : PageNotFoundException Class

PageNotFoundException overview

Public Constructors

Public Constructor PageNotFoundException Constructor Overloaded. Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

PageNotFoundException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


PageNotFoundException Constructor

PageNotFoundException Class | PageNotFoundException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PageNotFoundException Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > PageNotFoundException Class : PageNotFoundException Constructor (PageNotFoundException)

Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

Overload List

Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

[Visual Basic] Public Sub New()

[C#] public PageNotFoundException();

[C++] public PageNotFoundException();

[C++/CLI] public PageNotFoundException();

Exception which allows passing in an error number when there are errors with the annotation files.

[Visual Basic] Public Sub New(Integer)

[C#] public PageNotFoundException(int);

[C++] public PageNotFoundException(int);

[C++/CLI] public PageNotFoundException(int);

Exception which allows passing in a message when thee are errors with the annotation files.

[Visual Basic] Public Sub New(String)

[C#] public PageNotFoundException(string);

[C++] public PageNotFoundException(string*);

[C++/CLI] public PageNotFoundException(String^);

Exception which allows passing in an error number and message when there are errors with the annotation files.

[Visual Basic] Public Sub New(Integer,String)

[C#] public PageNotFoundException(int,string);

[C++] public PageNotFoundException(int,string*);

[C++/CLI] public PageNotFoundException(int,String^);

Exception which allows passing in a message and inner exception when there are errors with the annotation files.

[Visual Basic] Public Sub New(String,Exception)

[C#] public PageNotFoundException(string,Exception);

[C++] public PageNotFoundException(string*,Exception*);

[C++/CLI] public PageNotFoundException(String^,Exception^);

See Also

PageNotFoundException Class | PageNotFoundException Members


PageNotFoundException Constructor()

PageNotFoundException Class | PageNotFoundException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PageNotFoundException Constructor()

PegasusImaging.WinForms.NotateXpress9 Namespace > PageNotFoundException Class > PageNotFoundException Constructor : PageNotFoundException Constructor()

Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

[Visual Basic]
Public Function New()
[C#]
public PageNotFoundException();
[C++]
public: PageNotFoundException();
[C++/CLI]
public:
PageNotFoundException();

See Also

PageNotFoundException Class | PageNotFoundException Members | Overload List


PageNotFoundException Constructor(Int32)

PageNotFoundException Class | PageNotFoundException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PageNotFoundException Constructor(Int32)

PegasusImaging.WinForms.NotateXpress9 Namespace > PageNotFoundException Class > PageNotFoundException Constructor : PageNotFoundException Constructor(Int32)

Exception which allows passing in an error number when there are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public PageNotFoundException(
   int errorNumber
);
[C++]
public: PageNotFoundException(
   int errorNumber
)
[C++/CLI]
public:
PageNotFoundException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

PageNotFoundException Class | PageNotFoundException Members | Overload List


PageNotFoundException Constructor(Int32,String)

PageNotFoundException Class | PageNotFoundException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PageNotFoundException Constructor(Int32,String)

PegasusImaging.WinForms.NotateXpress9 Namespace > PageNotFoundException Class > PageNotFoundException Constructor : PageNotFoundException Constructor(Int32,String)

Exception which allows passing in an error number and message when there are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public PageNotFoundException(
   int errorNumber,
   string message
);
[C++]
public: PageNotFoundException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
PageNotFoundException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

PageNotFoundException Class | PageNotFoundException Members | Overload List


PageNotFoundException Constructor(String)

PageNotFoundException Class | PageNotFoundException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PageNotFoundException Constructor(String)

PegasusImaging.WinForms.NotateXpress9 Namespace > PageNotFoundException Class > PageNotFoundException Constructor : PageNotFoundException Constructor(String)

Exception which allows passing in a message when thee are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public PageNotFoundException(
   string message
);
[C++]
public: PageNotFoundException(
   string* message
)
[C++/CLI]
public:
PageNotFoundException(
   String^ message
)

Parameters

message
A string which represents the message.

See Also

PageNotFoundException Class | PageNotFoundException Members | Overload List


PageNotFoundException Constructor(String,Exception)

PageNotFoundException Class | PageNotFoundException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PageNotFoundException Constructor(String,Exception)

PegasusImaging.WinForms.NotateXpress9 Namespace > PageNotFoundException Class > PageNotFoundException Constructor : PageNotFoundException Constructor(String,Exception)

Exception which allows passing in a message and inner exception when there are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public PageNotFoundException(
   string message,
   Exception innerException
);
[C++]
public: PageNotFoundException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
PageNotFoundException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception.

See Also

PageNotFoundException Class | PageNotFoundException Members | Overload List


PolygonTool Class

PolygonTool Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PolygonTool Class

PegasusImaging.WinForms.NotateXpress9 Namespace : PolygonTool Class

The PolyLineTool class is used to create polygon-shaped annotations.

For a list of all members of this type, see PolygonTool members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.NotateXpress9.Element
PegasusImaging.WinForms.NotateXpress9.PolygonTool

Syntax

[Visual Basic]
Public Class PolygonTool
   Inherits Element
[C#]
public class PolygonTool : Element
[C++]
public __gc class PolygonTool : public Element
[C++/CLI]
public ref class PolygonTool : public Element

See Also

PolygonTool Members | PegasusImaging.WinForms.NotateXpress9 Namespace


PolygonTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PolygonTool Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : PolygonTool Class

PolygonTool overview

Public Constructors

Public Constructor PolygonTool Constructor Default constructor for the PolyLineTool class.

Public Properties

Public Property BackStyle | This property sets or returns the back style used by the polygon tool.
Public Property BoundingRectangle (Inherited from Element) | Gets and sets the rectangle boundary for the element.
Public Property CreateTime (Inherited from Element) | A Read only property that gets the time when the element was created.
Public Property FillColor | This property sets or returns the fill color by the polygon tool.
Public Property Fixed (Inherited from Element) | Gets and sets whether an annotation has a fixed position with respect to the control window.
Public Property GroupMember (Inherited from Element) | Gets the group which the element belongs to.
Public Property HatchColor | This property sets or returns the hatch color used by the polygon tool.
Public Property HatchStyle | This property sets or returns the hatch style used by the polygon tool.
Public Property IsGroupMember (Inherited from Element) | A read only property that gets a value which determines if the element is a member of a group or not.
Public Property Locked (Inherited from Element) | Gets and sets an indicator whether an annotation element can be selected or moved by a user in Edit mode.
Public Property Moveable (Inherited from Element) | Gets and sets whether the element can be moved by a user in Edit mode.
Public Property NumberPoints (Inherited from Element) | A Read only property that gets the number of points currently used to define the element.
Public Property PenColor | This property sets or returns the color of the pen used by the polygon tool.
Public Property PenWidth | This property sets or returns the width of the pen, in pixels, used by the polygon tool.
Public Property Selected (Inherited from Element) | Gets and sets whether the element has been selected.
Public Property ShowHandles (Inherited from Element) | Gets and sets whether selection handles are displayed on an object when it is selected.
Public Property Sizeable (Inherited from Element) | Gets and sets whether the element can be resized.
Public Property ToolTipText (Inherited from Element) | Gets and sets a string value in the element that will become the ToolTipText value associated with the element.
Public Property UserLong (Inherited from Element) | Gets and sets a user defined long value associated with the element.
Public Property UserString (Inherited from Element) | Gets and sets a user-defined string associated with the element.
Public Property Visible (Inherited from Element) | Gets and sets whether the element is visible.

Public Methods

Public Method GetPoints | This method returns an array of Points used to draw the line.
Public Method NudgeDown (Inherited from Element) | Moves the specified annotation object one level down, towards the back, in the painting order of the specified layer.
Public Method NudgeUp (Inherited from Element) | Moves the specified annotation object one level up, towards the front, in the painting order of the specified layer.
Public Method SetPoints | This method sets an array of Points used to draw the line.
Public Method UserDataAdd (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataDelete (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFind (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFindFirst (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFindNext (Inherited from Element) | User data can be added to each element in a key value pair.

See Also

PolygonTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace


PolygonTool Constructor

PolygonTool Class | PolygonTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PolygonTool Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > PolygonTool Class : PolygonTool Constructor (PolygonTool)

Default constructor for the PolyLineTool class.

[Visual Basic]
Public Function New()
[C#]
public PolygonTool();
[C++]
public: PolygonTool();
[C++/CLI]
public:
PolygonTool();

See Also

PolygonTool Class | PolygonTool Members


GetPoints Method

PolygonTool Class | PolygonTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetPoints Method

PegasusImaging.WinForms.NotateXpress9 Namespace > PolygonTool Class : GetPoints Method (PolygonTool)

This method returns an array of Points used to draw the line.

[Visual Basic]
Public Function GetPoints() As Point()
[C#]
public Point[] GetPoints();
[C++]
public: Point[]* GetPoints();
[C++/CLI]
public:
array<Point>^ GetPoints();

Return Type

An array of Points used to draw the line.

See Also

PolygonTool Class | PolygonTool Members


SetPoints Method

PolygonTool Class | PolygonTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

points
An array of Points used to draw the line.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

SetPoints Method

PegasusImaging.WinForms.NotateXpress9 Namespace > PolygonTool Class : SetPoints Method (PolygonTool)

This method sets an array of Points used to draw the line.

[Visual Basic]
Public Sub SetPoints( _
   ByVal points() As Point _
)
[C#]
public void SetPoints(
   Point[] points
);
[C++]
public: void SetPoints(
   Point[]* points
)
[C++/CLI]
public:
void SetPoints(
   Pointarray<points>^ points
)

Parameters

points
An array of Points used to draw the line.

See Also

PolygonTool Class | PolygonTool Members


PolygonTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PolygonTool Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : PolygonTool Class

For a list of all members of this type, see PolygonTool members.

Public Properties

Public Property BackStyle | This property sets or returns the back style used by the polygon tool.
Public Property BoundingRectangle (Inherited from Element) | Gets and sets the rectangle boundary for the element.
Public Property CreateTime (Inherited from Element) | A Read only property that gets the time when the element was created.
Public Property FillColor | This property sets or returns the fill color by the polygon tool.
Public Property Fixed (Inherited from Element) | Gets and sets whether an annotation has a fixed position with respect to the control window.
Public Property GroupMember (Inherited from Element) | Gets the group which the element belongs to.
Public Property HatchColor | This property sets or returns the hatch color used by the polygon tool.
Public Property HatchStyle | This property sets or returns the hatch style used by the polygon tool.
Public Property IsGroupMember (Inherited from Element) | A read only property that gets a value which determines if the element is a member of a group or not.
Public Property Locked (Inherited from Element) | Gets and sets an indicator whether an annotation element can be selected or moved by a user in Edit mode.
Public Property Moveable (Inherited from Element) | Gets and sets whether the element can be moved by a user in Edit mode.
Public Property NumberPoints (Inherited from Element) | A Read only property that gets the number of points currently used to define the element.
Public Property PenColor | This property sets or returns the color of the pen used by the polygon tool.
Public Property PenWidth | This property sets or returns the width of the pen, in pixels, used by the polygon tool.
Public Property Selected (Inherited from Element) | Gets and sets whether the element has been selected.
Public Property ShowHandles (Inherited from Element) | Gets and sets whether selection handles are displayed on an object when it is selected.
Public Property Sizeable (Inherited from Element) | Gets and sets whether the element can be resized.
Public Property ToolTipText (Inherited from Element) | Gets and sets a string value in the element that will become the ToolTipText value associated with the element.
Public Property UserLong (Inherited from Element) | Gets and sets a user defined long value associated with the element.
Public Property UserString (Inherited from Element) | Gets and sets a user-defined string associated with the element.
Public Property Visible (Inherited from Element) | Gets and sets whether the element is visible.

See Also

PolygonTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace


BackStyle Property

PolygonTool Class | PolygonTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BackStyle Property

PegasusImaging.WinForms.NotateXpress9 Namespace > PolygonTool Class : BackStyle Property (PolygonTool)

This property sets or returns the back style used by the polygon tool.

[Visual Basic]
Public Property BackStyle As BackStyle
[C#]
public BackStyle BackStyle {get; set;}
[C++]
public: __property BackStyle get_BackStyle();
public: __property void set_BackStyle(
   BackStyle value
);
[C++/CLI]
public:
property BackStyle BackStyle {
   BackStyle get();
   void set (BackStyle value);
}

Value

The BackStyle to be used by the polygon tool.

See Also

PolygonTool Class | PolygonTool Members


FillColor Property

PolygonTool Class | PolygonTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

FillColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > PolygonTool Class : FillColor Property (PolygonTool)

This property sets or returns the fill color by the polygon tool.

[Visual Basic]
Public Property FillColor As Color
[C#]
public Color FillColor {get; set;}
[C++]
public: __property Color get_FillColor();
public: __property void set_FillColor(
   Color value
);
[C++/CLI]
public:
property Color FillColor {
   Color get();
   void set (Color value);
}

Value

The Color of the fill.

See Also

PolygonTool Class | PolygonTool Members


HatchColor Property

PolygonTool Class | PolygonTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HatchColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > PolygonTool Class : HatchColor Property (PolygonTool)

This property sets or returns the hatch color used by the polygon tool.

[Visual Basic]
Public Property HatchColor As Color
[C#]
public Color HatchColor {get; set;}
[C++]
public: __property Color get_HatchColor();
public: __property void set_HatchColor(
   Color value
);
[C++/CLI]
public:
property Color HatchColor {
   Color get();
   void set (Color value);
}

Value

The Color of the hatch.

Remarks

The HatchColor is the color of the hatch strokes on a filled object whose HatchStyle attribute is something other than HatchStyle_None.

See Also

PolygonTool Class | PolygonTool Members


HatchStyle Property

PolygonTool Class | PolygonTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HatchStyle Property

PegasusImaging.WinForms.NotateXpress9 Namespace > PolygonTool Class : HatchStyle Property (PolygonTool)

This property sets or returns the hatch style used by the polygon tool.

[Visual Basic]
Public Property HatchStyle As HatchStyle
[C#]
public HatchStyle HatchStyle {get; set;}
[C++]
public: __property HatchStyle get_HatchStyle();
public: __property void set_HatchStyle(
   HatchStyle value
);
[C++/CLI]
public:
property HatchStyle HatchStyle {
   HatchStyle get();
   void set (HatchStyle value);
}

Value

The HatchStyle to be used by the polygon tool.

See Also

PolygonTool Class | PolygonTool Members


PenColor Property

PolygonTool Class | PolygonTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PenColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > PolygonTool Class : PenColor Property (PolygonTool)

This property sets or returns the color of the pen used by the polygon tool.

[Visual Basic]
Public Property PenColor As Color
[C#]
public Color PenColor {get; set;}
[C++]
public: __property Color get_PenColor();
public: __property void set_PenColor(
   Color value
);
[C++/CLI]
public:
property Color PenColor {
   Color get();
   void set (Color value);
}

Value

The Color of the pen.

See Also

PolygonTool Class | PolygonTool Members


PenWidth Property

PolygonTool Class | PolygonTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PenWidth Property

PegasusImaging.WinForms.NotateXpress9 Namespace > PolygonTool Class : PenWidth Property (PolygonTool)

This property sets or returns the width of the pen, in pixels, used by the polygon tool.

[Visual Basic]
Public Property PenWidth As Integer
[C#]
public int PenWidth {get; set;}
[C++]
public: __property int get_PenWidth();
public: __property void set_PenWidth(
   int value
);
[C++/CLI]
public:
property int PenWidth {
   int get();
   void set (int value);
}

Value

An integer value which represents the width of the pen.

See Also

PolygonTool Class | PolygonTool Members


PolygonToolbarDefaults Class

PolygonToolbarDefaults Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PolygonToolbarDefaults Class

PegasusImaging.WinForms.NotateXpress9 Namespace : PolygonToolbarDefaults Class (PegasusImaging.WinForms.NotateXpress9)

The TextTool is used to create Polygon annotations.

For a list of all members of this type, see PolygonToolbarDefaults members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.NotateXpress9.BaseToolbarDefaults
PegasusImaging.WinForms.NotateXpress9.PolygonToolbarDefaults

Syntax

[Visual Basic]
Public Class PolygonToolbarDefaults
   Inherits BaseToolbarDefaults
[C#]
public class PolygonToolbarDefaults : BaseToolbarDefaults
[C++]
public __gc class PolygonToolbarDefaults : public BaseToolbarDefaults
[C++/CLI]
public ref class PolygonToolbarDefaults : public BaseToolbarDefaults

See Also

PolygonToolbarDefaults Members | PegasusImaging.WinForms.NotateXpress9 Namespace


PolygonToolbarDefaults Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PolygonToolbarDefaults Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : PolygonToolbarDefaults Class (PegasusImaging.WinForms.NotateXpress9)

PolygonToolbarDefaults overview

Public Constructors

Public Constructor PolygonToolbarDefaults Constructor Default constructor for the PolygonToolbarDefaults class.

Public Properties

Public Property BackStyle | This property sets or returns the style of the background used within the Polygon annotation.
Public Property FillColor | This property sets or returns the color of the fill used within the Polygon annotation.
Public Property Fixed (Inherited from BaseToolbarDefaults) | Gets and sets whether an element is tied to the view instead of the image.
Public Property HatchColor | This property sets or returns the color of the hatch style used within the Polygon annotation.
Public Property HatchStyle | This property sets or returns the hatch style used within the Polygon annotation.
Public Property Locked (Inherited from BaseToolbarDefaults) | Gets and sets an indicator to lock an element so it cannot be selected or moved by a user in Edit mode.
Public Property Moveable (Inherited from BaseToolbarDefaults) | Gets and sets whether an element can be moved interactively during EditMode.
Public Property PenColor | This property sets or returns the color of the pen used to draw the border around the Polygon annotation .
Public Property PenWidth | This property sets or returns the width of the pen used to draw the Polygon annotation.
Public Property Selected (Inherited from BaseToolbarDefaults) | Gets and sets whether an element is automatically selected.
Public Property ShowHandles (Inherited from BaseToolbarDefaults) | Gets and sets whether selection handles are displayed for an element.
Public Property Sizeable (Inherited from BaseToolbarDefaults) | Gets and sets whether an element can be sized interactively during EditMode.
Public Property ToolTipText (Inherited from BaseToolbarDefaults) | Gets or sets a string value in the element that will become the ToolTipText value associated with the annotation once it is created.
Public Property UserLong (Inherited from BaseToolbarDefaults) | Gets and sets a long value in the element that will become the UserLong value associated with the element once it is created.
Public Property UserString (Inherited from BaseToolbarDefaults) | Gets and sets a string value in the element that will become the UserString value associated with the object once it is created.
Public Property Visible (Inherited from BaseToolbarDefaults) | Gets and sets the Visible attribute of an element.

See Also

PolygonToolbarDefaults Class | PegasusImaging.WinForms.NotateXpress9 Namespace


PolygonToolbarDefaults Constructor

PolygonToolbarDefaults Class | PolygonToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PolygonToolbarDefaults Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > PolygonToolbarDefaults Class : PolygonToolbarDefaults Constructor (PolygonToolbarDefaults)

Default constructor for the PolygonToolbarDefaults class.

[Visual Basic]
Public Function New()
[C#]
public PolygonToolbarDefaults();
[C++]
public: PolygonToolbarDefaults();
[C++/CLI]
public:
PolygonToolbarDefaults();

See Also

PolygonToolbarDefaults Class | PolygonToolbarDefaults Members


PolygonToolbarDefaults Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PolygonToolbarDefaults Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : PolygonToolbarDefaults Class (PegasusImaging.WinForms.NotateXpress9)

For a list of all members of this type, see PolygonToolbarDefaults members.

Public Properties

Public Property BackStyle | This property sets or returns the style of the background used within the Polygon annotation.
Public Property FillColor | This property sets or returns the color of the fill used within the Polygon annotation.
Public Property Fixed (Inherited from BaseToolbarDefaults) | Gets and sets whether an element is tied to the view instead of the image.
Public Property HatchColor | This property sets or returns the color of the hatch style used within the Polygon annotation.
Public Property HatchStyle | This property sets or returns the hatch style used within the Polygon annotation.
Public Property Locked (Inherited from BaseToolbarDefaults) | Gets and sets an indicator to lock an element so it cannot be selected or moved by a user in Edit mode.
Public Property Moveable (Inherited from BaseToolbarDefaults) | Gets and sets whether an element can be moved interactively during EditMode.
Public Property PenColor | This property sets or returns the color of the pen used to draw the border around the Polygon annotation .
Public Property PenWidth | This property sets or returns the width of the pen used to draw the Polygon annotation.
Public Property Selected (Inherited from BaseToolbarDefaults) | Gets and sets whether an element is automatically selected.
Public Property ShowHandles (Inherited from BaseToolbarDefaults) | Gets and sets whether selection handles are displayed for an element.
Public Property Sizeable (Inherited from BaseToolbarDefaults) | Gets and sets whether an element can be sized interactively during EditMode.
Public Property ToolTipText (Inherited from BaseToolbarDefaults) | Gets or sets a string value in the element that will become the ToolTipText value associated with the annotation once it is created.
Public Property UserLong (Inherited from BaseToolbarDefaults) | Gets and sets a long value in the element that will become the UserLong value associated with the element once it is created.
Public Property UserString (Inherited from BaseToolbarDefaults) | Gets and sets a string value in the element that will become the UserString value associated with the object once it is created.
Public Property Visible (Inherited from BaseToolbarDefaults) | Gets and sets the Visible attribute of an element.

See Also

PolygonToolbarDefaults Class | PegasusImaging.WinForms.NotateXpress9 Namespace


BackStyle Property

PolygonToolbarDefaults Class | PolygonToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BackStyle Property

PegasusImaging.WinForms.NotateXpress9 Namespace > PolygonToolbarDefaults Class : BackStyle Property (PolygonToolbarDefaults)

This property sets or returns the style of the background used within the Polygon annotation.

[Visual Basic]
Public Property BackStyle As BackStyle
[C#]
public BackStyle BackStyle {get; set;}
[C++]
public: __property BackStyle get_BackStyle();
public: __property void set_BackStyle(
   BackStyle value
);
[C++/CLI]
public:
property BackStyle BackStyle {
   BackStyle get();
   void set (BackStyle value);
}

Value

The back style.

See Also

PolygonToolbarDefaults Class | PolygonToolbarDefaults Members


FillColor Property

PolygonToolbarDefaults Class | PolygonToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

FillColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > PolygonToolbarDefaults Class : FillColor Property (PolygonToolbarDefaults)

This property sets or returns the color of the fill used within the Polygon annotation.

[Visual Basic]
Public Property FillColor As Color
[C#]
public Color FillColor {get; set;}
[C++]
public: __property Color get_FillColor();
public: __property void set_FillColor(
   Color value
);
[C++/CLI]
public:
property Color FillColor {
   Color get();
   void set (Color value);
}

Value

The color of the fill.

See Also

PolygonToolbarDefaults Class | PolygonToolbarDefaults Members


HatchColor Property

PolygonToolbarDefaults Class | PolygonToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HatchColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > PolygonToolbarDefaults Class : HatchColor Property (PolygonToolbarDefaults)

This property sets or returns the color of the hatch style used within the Polygon annotation.

[Visual Basic]
Public Property HatchColor As Color
[C#]
public Color HatchColor {get; set;}
[C++]
public: __property Color get_HatchColor();
public: __property void set_HatchColor(
   Color value
);
[C++/CLI]
public:
property Color HatchColor {
   Color get();
   void set (Color value);
}

Value

The color of the hatch.

Remarks

The HatchColor is the color of the hatch strokes on a filled object whose HatchStyle attribute is something other than HatchStyle_None.

See Also

PolygonToolbarDefaults Class | PolygonToolbarDefaults Members


HatchStyle Property

PolygonToolbarDefaults Class | PolygonToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HatchStyle Property

PegasusImaging.WinForms.NotateXpress9 Namespace > PolygonToolbarDefaults Class : HatchStyle Property (PolygonToolbarDefaults)

This property sets or returns the hatch style used within the Polygon annotation.

[Visual Basic]
Public Property HatchStyle As HatchStyle
[C#]
public HatchStyle HatchStyle {get; set;}
[C++]
public: __property HatchStyle get_HatchStyle();
public: __property void set_HatchStyle(
   HatchStyle value
);
[C++/CLI]
public:
property HatchStyle HatchStyle {
   HatchStyle get();
   void set (HatchStyle value);
}

Value

The hatch style.

See Also

PolygonToolbarDefaults Class | PolygonToolbarDefaults Members


PenColor Property

PolygonToolbarDefaults Class | PolygonToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PenColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > PolygonToolbarDefaults Class : PenColor Property (PolygonToolbarDefaults)

This property sets or returns the color of the pen used to draw the border around the Polygon annotation .

[Visual Basic]
Public Property PenColor As Color
[C#]
public Color PenColor {get; set;}
[C++]
public: __property Color get_PenColor();
public: __property void set_PenColor(
   Color value
);
[C++/CLI]
public:
property Color PenColor {
   Color get();
   void set (Color value);
}

Value

The color of the pen.

See Also

PolygonToolbarDefaults Class | PolygonToolbarDefaults Members


PenWidth Property

PolygonToolbarDefaults Class | PolygonToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PenWidth Property

PegasusImaging.WinForms.NotateXpress9 Namespace > PolygonToolbarDefaults Class : PenWidth Property (PolygonToolbarDefaults)

This property sets or returns the width of the pen used to draw the Polygon annotation.

[Visual Basic]
Public Property PenWidth As Integer
[C#]
public int PenWidth {get; set;}
[C++]
public: __property int get_PenWidth();
public: __property void set_PenWidth(
   int value
);
[C++/CLI]
public:
property int PenWidth {
   int get();
   void set (int value);
}

Value

The width of the pen.

See Also

PolygonToolbarDefaults Class | PolygonToolbarDefaults Members


PolyLineTool Class

PolyLineTool Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PolyLineTool Class

PegasusImaging.WinForms.NotateXpress9 Namespace : PolyLineTool Class

The PolyLineTool class is used to create line annotations with 2 or more points.

For a list of all members of this type, see PolyLineTool members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.NotateXpress9.Element
PegasusImaging.WinForms.NotateXpress9.PolyLineTool

Syntax

[Visual Basic]
Public Class PolyLineTool
   Inherits Element
[C#]
public class PolyLineTool : Element
[C++]
public __gc class PolyLineTool : public Element
[C++/CLI]
public ref class PolyLineTool : public Element

See Also

PolyLineTool Members | PegasusImaging.WinForms.NotateXpress9 Namespace


PolyLineTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PolyLineTool Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : PolyLineTool Class

PolyLineTool overview

Public Constructors

Public Constructor PolyLineTool Constructor Default constructor for the PolyLineTool class.

Public Properties

Public Property BoundingRectangle (Inherited from Element) | Gets and sets the rectangle boundary for the element.
Public Property CreateTime (Inherited from Element) | A Read only property that gets the time when the element was created.
Public Property Fixed (Inherited from Element) | Gets and sets whether an annotation has a fixed position with respect to the control window.
Public Property GroupMember (Inherited from Element) | Gets the group which the element belongs to.
Public Property IsGroupMember (Inherited from Element) | A read only property that gets a value which determines if the element is a member of a group or not.
Public Property Locked (Inherited from Element) | Gets and sets an indicator whether an annotation element can be selected or moved by a user in Edit mode.
Public Property Moveable (Inherited from Element) | Gets and sets whether the element can be moved by a user in Edit mode.
Public Property NumberPoints (Inherited from Element) | A Read only property that gets the number of points currently used to define the element.
Public Property PenColor | This property sets or returns the color of the pen used to draw the line.
Public Property PenFillStyle | This property sets or returns the pen fill style used to draw the line.
Public Property PenStyle | This property sets or returns the pen style used to draw the line.
Public Property PenWidth | This property sets or returns the width of the pen, in pixels, used to draw the line.
Public Property Selected (Inherited from Element) | Gets and sets whether the element has been selected.
Public Property ShowHandles (Inherited from Element) | Gets and sets whether selection handles are displayed on an object when it is selected.
Public Property Sizeable (Inherited from Element) | Gets and sets whether the element can be resized.
Public Property ToolTipText (Inherited from Element) | Gets and sets a string value in the element that will become the ToolTipText value associated with the element.
Public Property UserLong (Inherited from Element) | Gets and sets a user defined long value associated with the element.
Public Property UserString (Inherited from Element) | Gets and sets a user-defined string associated with the element.
Public Property Visible (Inherited from Element) | Gets and sets whether the element is visible.

Public Methods

Public Method GetPoints | This method returns an array of Points used to draw the line.
Public Method NudgeDown (Inherited from Element) | Moves the specified annotation object one level down, towards the back, in the painting order of the specified layer.
Public Method NudgeUp (Inherited from Element) | Moves the specified annotation object one level up, towards the front, in the painting order of the specified layer.
Public Method SetPoints | This method sets an array of Points used to draw the line.
Public Method UserDataAdd (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataDelete (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFind (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFindFirst (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFindNext (Inherited from Element) | User data can be added to each element in a key value pair.

See Also

PolyLineTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace


PolyLineTool Constructor

PolyLineTool Class | PolyLineTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PolyLineTool Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > PolyLineTool Class : PolyLineTool Constructor (PolyLineTool)

Default constructor for the PolyLineTool class.

[Visual Basic]
Public Function New()
[C#]
public PolyLineTool();
[C++]
public: PolyLineTool();
[C++/CLI]
public:
PolyLineTool();

See Also

PolyLineTool Class | PolyLineTool Members


GetPoints Method

PolyLineTool Class | PolyLineTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetPoints Method

PegasusImaging.WinForms.NotateXpress9 Namespace > PolyLineTool Class : GetPoints Method (PolyLineTool)

This method returns an array of Points used to draw the line.

[Visual Basic]
Public Function GetPoints() As Point()
[C#]
public Point[] GetPoints();
[C++]
public: Point[]* GetPoints();
[C++/CLI]
public:
array<Point>^ GetPoints();

Return Type

An array of Points used to draw the line.

See Also

PolyLineTool Class | PolyLineTool Members


SetPoints Method

PolyLineTool Class | PolyLineTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

points
An array of Points used to draw the line.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

SetPoints Method

PegasusImaging.WinForms.NotateXpress9 Namespace > PolyLineTool Class : SetPoints Method (PolyLineTool)

This method sets an array of Points used to draw the line.

[Visual Basic]
Public Sub SetPoints( _
   ByVal points() As Point _
)
[C#]
public void SetPoints(
   Point[] points
);
[C++]
public: void SetPoints(
   Point[]* points
)
[C++/CLI]
public:
void SetPoints(
   Pointarray<points>^ points
)

Parameters

points
An array of Points used to draw the line.

See Also

PolyLineTool Class | PolyLineTool Members


PolyLineTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PolyLineTool Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : PolyLineTool Class

For a list of all members of this type, see PolyLineTool members.

Public Properties

Public Property BoundingRectangle (Inherited from Element) | Gets and sets the rectangle boundary for the element.
Public Property CreateTime (Inherited from Element) | A Read only property that gets the time when the element was created.
Public Property Fixed (Inherited from Element) | Gets and sets whether an annotation has a fixed position with respect to the control window.
Public Property GroupMember (Inherited from Element) | Gets the group which the element belongs to.
Public Property IsGroupMember (Inherited from Element) | A read only property that gets a value which determines if the element is a member of a group or not.
Public Property Locked (Inherited from Element) | Gets and sets an indicator whether an annotation element can be selected or moved by a user in Edit mode.
Public Property Moveable (Inherited from Element) | Gets and sets whether the element can be moved by a user in Edit mode.
Public Property NumberPoints (Inherited from Element) | A Read only property that gets the number of points currently used to define the element.
Public Property PenColor | This property sets or returns the color of the pen used to draw the line.
Public Property PenFillStyle | This property sets or returns the pen fill style used to draw the line.
Public Property PenStyle | This property sets or returns the pen style used to draw the line.
Public Property PenWidth | This property sets or returns the width of the pen, in pixels, used to draw the line.
Public Property Selected (Inherited from Element) | Gets and sets whether the element has been selected.
Public Property ShowHandles (Inherited from Element) | Gets and sets whether selection handles are displayed on an object when it is selected.
Public Property Sizeable (Inherited from Element) | Gets and sets whether the element can be resized.
Public Property ToolTipText (Inherited from Element) | Gets and sets a string value in the element that will become the ToolTipText value associated with the element.
Public Property UserLong (Inherited from Element) | Gets and sets a user defined long value associated with the element.
Public Property UserString (Inherited from Element) | Gets and sets a user-defined string associated with the element.
Public Property Visible (Inherited from Element) | Gets and sets whether the element is visible.

See Also

PolyLineTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace


PenColor Property

PolyLineTool Class | PolyLineTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PenColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > PolyLineTool Class : PenColor Property (PolyLineTool)

This property sets or returns the color of the pen used to draw the line.

[Visual Basic]
Public Property PenColor As Color
[C#]
public Color PenColor {get; set;}
[C++]
public: __property Color get_PenColor();
public: __property void set_PenColor(
   Color value
);
[C++/CLI]
public:
property Color PenColor {
   Color get();
   void set (Color value);
}

Value

The Color of the pen used to draw the line.

See Also

PolyLineTool Class | PolyLineTool Members


PenFillStyle Property

PolyLineTool Class | PolyLineTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PenFillStyle Property

PegasusImaging.WinForms.NotateXpress9 Namespace > PolyLineTool Class : PenFillStyle Property (PolyLineTool)

This property sets or returns the pen fill style used to draw the line.

[Visual Basic]
Public Property PenFillStyle As PenFillStyle
[C#]
public PenFillStyle PenFillStyle {get; set;}
[C++]
public: __property PenFillStyle get_PenFillStyle();
public: __property void set_PenFillStyle(
   PenFillStyle value
);
[C++/CLI]
public:
property PenFillStyle PenFillStyle {
   PenFillStyle get();
   void set (PenFillStyle value);
}

Value

The PenFill style used to draw the line.

See Also

PolyLineTool Class | PolyLineTool Members


PenStyle Property

PolyLineTool Class | PolyLineTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PenStyle Property

PegasusImaging.WinForms.NotateXpress9 Namespace > PolyLineTool Class : PenStyle Property (PolyLineTool)

This property sets or returns the pen style used to draw the line.

[Visual Basic]
Public Property PenStyle As PenStyle
[C#]
public PenStyle PenStyle {get; set;}
[C++]
public: __property PenStyle get_PenStyle();
public: __property void set_PenStyle(
   PenStyle value
);
[C++/CLI]
public:
property PenStyle PenStyle {
   PenStyle get();
   void set (PenStyle value);
}

Value

The PenStyle used to draw the line.

See Also

PolyLineTool Class | PolyLineTool Members


PenWidth Property

PolyLineTool Class | PolyLineTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PenWidth Property

PegasusImaging.WinForms.NotateXpress9 Namespace > PolyLineTool Class : PenWidth Property (PolyLineTool)

This property sets or returns the width of the pen, in pixels, used to draw the line.

[Visual Basic]
Public Property PenWidth As Integer
[C#]
public int PenWidth {get; set;}
[C++]
public: __property int get_PenWidth();
public: __property void set_PenWidth(
   int value
);
[C++/CLI]
public:
property int PenWidth {
   int get();
   void set (int value);
}

Value

An integer value which represents the width of the pen.

See Also

PolyLineTool Class | PolyLineTool Members


PolyLineToolbarDefaults Class

PolyLineToolbarDefaults Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PolyLineToolbarDefaults Class

PegasusImaging.WinForms.NotateXpress9 Namespace : PolyLineToolbarDefaults Class (PegasusImaging.WinForms.NotateXpress9)

The TextTool is used to create PolyLine annotations.

For a list of all members of this type, see PolyLineToolbarDefaults members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.NotateXpress9.BaseToolbarDefaults
PegasusImaging.WinForms.NotateXpress9.PolyLineToolbarDefaults

Syntax

[Visual Basic]
Public Class PolyLineToolbarDefaults
   Inherits BaseToolbarDefaults
[C#]
public class PolyLineToolbarDefaults : BaseToolbarDefaults
[C++]
public __gc class PolyLineToolbarDefaults : public BaseToolbarDefaults
[C++/CLI]
public ref class PolyLineToolbarDefaults : public BaseToolbarDefaults

See Also

PolyLineToolbarDefaults Members | PegasusImaging.WinForms.NotateXpress9 Namespace


PolyLineToolbarDefaults Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PolyLineToolbarDefaults Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : PolyLineToolbarDefaults Class (PegasusImaging.WinForms.NotateXpress9)

PolyLineToolbarDefaults overview

Public Constructors

Public Constructor PolyLineToolbarDefaults Constructor Default constructor for the PolyLineToolbarDefaults class.

Public Properties

Public Property Fixed (Inherited from BaseToolbarDefaults) | Gets and sets whether an element is tied to the view instead of the image.
Public Property Locked (Inherited from BaseToolbarDefaults) | Gets and sets an indicator to lock an element so it cannot be selected or moved by a user in Edit mode.
Public Property Moveable (Inherited from BaseToolbarDefaults) | Gets and sets whether an element can be moved interactively during EditMode.
Public Property PenColor | This property sets or returns the color of the pen used to draw the border around the PolyLine annotation .
Public Property PenFillStyle | This property sets or returns the hatch style used within the PolyLine annotation.
Public Property PenStyle | This property sets or returns the style of the background used within the PolyLine annotation.
Public Property PenWidth | This property sets or returns the width of the pen used to draw the PolyLine annotation.
Public Property Selected (Inherited from BaseToolbarDefaults) | Gets and sets whether an element is automatically selected.
Public Property ShowHandles (Inherited from BaseToolbarDefaults) | Gets and sets whether selection handles are displayed for an element.
Public Property Sizeable (Inherited from BaseToolbarDefaults) | Gets and sets whether an element can be sized interactively during EditMode.
Public Property ToolTipText (Inherited from BaseToolbarDefaults) | Gets or sets a string value in the element that will become the ToolTipText value associated with the annotation once it is created.
Public Property UserLong (Inherited from BaseToolbarDefaults) | Gets and sets a long value in the element that will become the UserLong value associated with the element once it is created.
Public Property UserString (Inherited from BaseToolbarDefaults) | Gets and sets a string value in the element that will become the UserString value associated with the object once it is created.
Public Property Visible (Inherited from BaseToolbarDefaults) | Gets and sets the Visible attribute of an element.

See Also

PolyLineToolbarDefaults Class | PegasusImaging.WinForms.NotateXpress9 Namespace


PolyLineToolbarDefaults Constructor

PolyLineToolbarDefaults Class | PolyLineToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PolyLineToolbarDefaults Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > PolyLineToolbarDefaults Class : PolyLineToolbarDefaults Constructor (PolyLineToolbarDefaults)

Default constructor for the PolyLineToolbarDefaults class.

[Visual Basic]
Public Function New()
[C#]
public PolyLineToolbarDefaults();
[C++]
public: PolyLineToolbarDefaults();
[C++/CLI]
public:
PolyLineToolbarDefaults();

See Also

PolyLineToolbarDefaults Class | PolyLineToolbarDefaults Members


PolyLineToolbarDefaults Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PolyLineToolbarDefaults Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : PolyLineToolbarDefaults Class (PegasusImaging.WinForms.NotateXpress9)

For a list of all members of this type, see PolyLineToolbarDefaults members.

Public Properties

Public Property Fixed (Inherited from BaseToolbarDefaults) | Gets and sets whether an element is tied to the view instead of the image.
Public Property Locked (Inherited from BaseToolbarDefaults) | Gets and sets an indicator to lock an element so it cannot be selected or moved by a user in Edit mode.
Public Property Moveable (Inherited from BaseToolbarDefaults) | Gets and sets whether an element can be moved interactively during EditMode.
Public Property PenColor | This property sets or returns the color of the pen used to draw the border around the PolyLine annotation .
Public Property PenFillStyle | This property sets or returns the hatch style used within the PolyLine annotation.
Public Property PenStyle | This property sets or returns the style of the background used within the PolyLine annotation.
Public Property PenWidth | This property sets or returns the width of the pen used to draw the PolyLine annotation.
Public Property Selected (Inherited from BaseToolbarDefaults) | Gets and sets whether an element is automatically selected.
Public Property ShowHandles (Inherited from BaseToolbarDefaults) | Gets and sets whether selection handles are displayed for an element.
Public Property Sizeable (Inherited from BaseToolbarDefaults) | Gets and sets whether an element can be sized interactively during EditMode.
Public Property ToolTipText (Inherited from BaseToolbarDefaults) | Gets or sets a string value in the element that will become the ToolTipText value associated with the annotation once it is created.
Public Property UserLong (Inherited from BaseToolbarDefaults) | Gets and sets a long value in the element that will become the UserLong value associated with the element once it is created.
Public Property UserString (Inherited from BaseToolbarDefaults) | Gets and sets a string value in the element that will become the UserString value associated with the object once it is created.
Public Property Visible (Inherited from BaseToolbarDefaults) | Gets and sets the Visible attribute of an element.

See Also

PolyLineToolbarDefaults Class | PegasusImaging.WinForms.NotateXpress9 Namespace


PenColor Property

PolyLineToolbarDefaults Class | PolyLineToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PenColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > PolyLineToolbarDefaults Class : PenColor Property (PolyLineToolbarDefaults)

This property sets or returns the color of the pen used to draw the border around the PolyLine annotation .

[Visual Basic]
Public Property PenColor As Color
[C#]
public Color PenColor {get; set;}
[C++]
public: __property Color get_PenColor();
public: __property void set_PenColor(
   Color value
);
[C++/CLI]
public:
property Color PenColor {
   Color get();
   void set (Color value);
}

Value

The color of the pen.

See Also

PolyLineToolbarDefaults Class | PolyLineToolbarDefaults Members


PenFillStyle Property

PolyLineToolbarDefaults Class | PolyLineToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PenFillStyle Property

PegasusImaging.WinForms.NotateXpress9 Namespace > PolyLineToolbarDefaults Class : PenFillStyle Property (PolyLineToolbarDefaults)

This property sets or returns the hatch style used within the PolyLine annotation.

[Visual Basic]
Public Property PenFillStyle As PenFillStyle
[C#]
public PenFillStyle PenFillStyle {get; set;}
[C++]
public: __property PenFillStyle get_PenFillStyle();
public: __property void set_PenFillStyle(
   PenFillStyle value
);
[C++/CLI]
public:
property PenFillStyle PenFillStyle {
   PenFillStyle get();
   void set (PenFillStyle value);
}

Value

The PenFillStyle style used for the PolyLine annotation.

See Also

PolyLineToolbarDefaults Class | PolyLineToolbarDefaults Members


PenStyle Property

PolyLineToolbarDefaults Class | PolyLineToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PenStyle Property

PegasusImaging.WinForms.NotateXpress9 Namespace > PolyLineToolbarDefaults Class : PenStyle Property (PolyLineToolbarDefaults)

This property sets or returns the style of the background used within the PolyLine annotation.

[Visual Basic]
Public Property PenStyle As PenStyle
[C#]
public PenStyle PenStyle {get; set;}
[C++]
public: __property PenStyle get_PenStyle();
public: __property void set_PenStyle(
   PenStyle value
);
[C++/CLI]
public:
property PenStyle PenStyle {
   PenStyle get();
   void set (PenStyle value);
}

Value

The PenStyle used for the PolyLine annotation.

See Also

PolyLineToolbarDefaults Class | PolyLineToolbarDefaults Members


PenWidth Property

PolyLineToolbarDefaults Class | PolyLineToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PenWidth Property

PegasusImaging.WinForms.NotateXpress9 Namespace > PolyLineToolbarDefaults Class : PenWidth Property (PolyLineToolbarDefaults)

This property sets or returns the width of the pen used to draw the PolyLine annotation.

[Visual Basic]
Public Property PenWidth As Integer
[C#]
public int PenWidth {get; set;}
[C++]
public: __property int get_PenWidth();
public: __property void set_PenWidth(
   int value
);
[C++/CLI]
public:
property int PenWidth {
   int get();
   void set (int value);
}

Value

The width of the pen.

See Also

PolyLineToolbarDefaults Class | PolyLineToolbarDefaults Members


RectangleTool Class

RectangleTool Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

RectangleTool Class

PegasusImaging.WinForms.NotateXpress9 Namespace : RectangleTool Class

The RectangleTool class is used to create rectangle annotations.

For a list of all members of this type, see RectangleTool members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.NotateXpress9.Element
PegasusImaging.WinForms.NotateXpress9.RectangleTool

Syntax

[Visual Basic]
Public Class RectangleTool
   Inherits Element
[C#]
public class RectangleTool : Element
[C++]
public __gc class RectangleTool : public Element
[C++/CLI]
public ref class RectangleTool : public Element

See Also

RectangleTool Members | PegasusImaging.WinForms.NotateXpress9 Namespace


RectangleTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

RectangleTool Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : RectangleTool Class

RectangleTool overview

Public Constructors

Public Constructor RectangleTool Constructor Default constructor for the RectangleTool class.

Public Properties

Public Property BackStyle | This property sets or returns the style of the background used within the rectangle annotation.
Public Property BoundingRectangle (Inherited from Element) | Gets and sets the rectangle boundary for the element.
Public Property CreateTime (Inherited from Element) | A Read only property that gets the time when the element was created.
Public Property FillColor | This property sets or returns the color used to fill in the area of the rectangle annotation.
Public Property Fixed (Inherited from Element) | Gets and sets whether an annotation has a fixed position with respect to the control window.
Public Property GroupMember (Inherited from Element) | Gets the group which the element belongs to.
Public Property HatchColor | This property sets or returns the color of the hatch style used within the rectangle annotation.
Public Property HatchStyle | This property sets or returns the hatch style used within the rectangle annotation.
Public Property HighlightFill | This property sets or returns whether or not the background of the rectangle annotation will be translucent.
Public Property IsGroupMember (Inherited from Element) | A read only property that gets a value which determines if the element is a member of a group or not.
Public Property Locked (Inherited from Element) | Gets and sets an indicator whether an annotation element can be selected or moved by a user in Edit mode.
Public Property Moveable (Inherited from Element) | Gets and sets whether the element can be moved by a user in Edit mode.
Public Property NumberPoints (Inherited from Element) | A Read only property that gets the number of points currently used to define the element.
Public Property PenColor | This property sets or returns the color of the pen used to draw the border around the rectangle annotation .
Public Property PenWidth | This property sets or returns the width of the pen used to draw the rectangle annotation.
Public Property Selected (Inherited from Element) | Gets and sets whether the element has been selected.
Public Property ShowHandles (Inherited from Element) | Gets and sets whether selection handles are displayed on an object when it is selected.
Public Property Sizeable (Inherited from Element) | Gets and sets whether the element can be resized.
Public Property ToolTipText (Inherited from Element) | Gets and sets a string value in the element that will become the ToolTipText value associated with the element.
Public Property UserDraw | This property sets or returns whether or not the UserDraw event is raised.
Public Property UserLong (Inherited from Element) | Gets and sets a user defined long value associated with the element.
Public Property UserString (Inherited from Element) | Gets and sets a user-defined string associated with the element.
Public Property Visible (Inherited from Element) | Gets and sets whether the element is visible.

Public Methods

Public Method NudgeDown (Inherited from Element) | Moves the specified annotation object one level down, towards the back, in the painting order of the specified layer.
Public Method NudgeUp (Inherited from Element) | Moves the specified annotation object one level up, towards the front, in the painting order of the specified layer.
Public Method UserDataAdd (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataDelete (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFind (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFindFirst (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFindNext (Inherited from Element) | User data can be added to each element in a key value pair.

See Also

RectangleTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace


RectangleTool Constructor

RectangleTool Class | RectangleTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

RectangleTool Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > RectangleTool Class : RectangleTool Constructor (RectangleTool)

Default constructor for the RectangleTool class.

[Visual Basic]
Public Function New()
[C#]
public RectangleTool();
[C++]
public: RectangleTool();
[C++/CLI]
public:
RectangleTool();

See Also

RectangleTool Class | RectangleTool Members


RectangleTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

RectangleTool Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : RectangleTool Class

For a list of all members of this type, see RectangleTool members.

Public Properties

Public Property BackStyle | This property sets or returns the style of the background used within the rectangle annotation.
Public Property BoundingRectangle (Inherited from Element) | Gets and sets the rectangle boundary for the element.
Public Property CreateTime (Inherited from Element) | A Read only property that gets the time when the element was created.
Public Property FillColor | This property sets or returns the color used to fill in the area of the rectangle annotation.
Public Property Fixed (Inherited from Element) | Gets and sets whether an annotation has a fixed position with respect to the control window.
Public Property GroupMember (Inherited from Element) | Gets the group which the element belongs to.
Public Property HatchColor | This property sets or returns the color of the hatch style used within the rectangle annotation.
Public Property HatchStyle | This property sets or returns the hatch style used within the rectangle annotation.
Public Property HighlightFill | This property sets or returns whether or not the background of the rectangle annotation will be translucent.
Public Property IsGroupMember (Inherited from Element) | A read only property that gets a value which determines if the element is a member of a group or not.
Public Property Locked (Inherited from Element) | Gets and sets an indicator whether an annotation element can be selected or moved by a user in Edit mode.
Public Property Moveable (Inherited from Element) | Gets and sets whether the element can be moved by a user in Edit mode.
Public Property NumberPoints (Inherited from Element) | A Read only property that gets the number of points currently used to define the element.
Public Property PenColor | This property sets or returns the color of the pen used to draw the border around the rectangle annotation .
Public Property PenWidth | This property sets or returns the width of the pen used to draw the rectangle annotation.
Public Property Selected (Inherited from Element) | Gets and sets whether the element has been selected.
Public Property ShowHandles (Inherited from Element) | Gets and sets whether selection handles are displayed on an object when it is selected.
Public Property Sizeable (Inherited from Element) | Gets and sets whether the element can be resized.
Public Property ToolTipText (Inherited from Element) | Gets and sets a string value in the element that will become the ToolTipText value associated with the element.
Public Property UserDraw | This property sets or returns whether or not the UserDraw event is raised.
Public Property UserLong (Inherited from Element) | Gets and sets a user defined long value associated with the element.
Public Property UserString (Inherited from Element) | Gets and sets a user-defined string associated with the element.
Public Property Visible (Inherited from Element) | Gets and sets whether the element is visible.

See Also

RectangleTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace


BackStyle Property

RectangleTool Class | RectangleTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BackStyle Property

PegasusImaging.WinForms.NotateXpress9 Namespace > RectangleTool Class : BackStyle Property (RectangleTool)

This property sets or returns the style of the background used within the rectangle annotation.

[Visual Basic]
Public Property BackStyle As BackStyle
[C#]
public BackStyle BackStyle {get; set;}
[C++]
public: __property BackStyle get_BackStyle();
public: __property void set_BackStyle(
   BackStyle value
);
[C++/CLI]
public:
property BackStyle BackStyle {
   BackStyle get();
   void set (BackStyle value);
}

Value

The BackStyle used on the rectangle annotation.

See Also

RectangleTool Class | RectangleTool Members


FillColor Property

RectangleTool Class | RectangleTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

FillColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > RectangleTool Class : FillColor Property (RectangleTool)

This property sets or returns the color used to fill in the area of the rectangle annotation.

[Visual Basic]
Public Property FillColor As Color
[C#]
public Color FillColor {get; set;}
[C++]
public: __property Color get_FillColor();
public: __property void set_FillColor(
   Color value
);
[C++/CLI]
public:
property Color FillColor {
   Color get();
   void set (Color value);
}

Value

The Color of the fill.

See Also

RectangleTool Class | RectangleTool Members


HatchColor Property

RectangleTool Class | RectangleTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HatchColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > RectangleTool Class : HatchColor Property (RectangleTool)

This property sets or returns the color of the hatch style used within the rectangle annotation.

[Visual Basic]
Public Property HatchColor As Color
[C#]
public Color HatchColor {get; set;}
[C++]
public: __property Color get_HatchColor();
public: __property void set_HatchColor(
   Color value
);
[C++/CLI]
public:
property Color HatchColor {
   Color get();
   void set (Color value);
}

Value

The Color of the hatch.

Remarks

The HatchColor is the color of the hatch strokes on a filled object whose HatchStyle attribute is something other than HatchStyle_None.

See Also

RectangleTool Class | RectangleTool Members


HatchStyle Property

RectangleTool Class | RectangleTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HatchStyle Property

PegasusImaging.WinForms.NotateXpress9 Namespace > RectangleTool Class : HatchStyle Property (RectangleTool)

This property sets or returns the hatch style used within the rectangle annotation.

[Visual Basic]
Public Property HatchStyle As HatchStyle
[C#]
public HatchStyle HatchStyle {get; set;}
[C++]
public: __property HatchStyle get_HatchStyle();
public: __property void set_HatchStyle(
   HatchStyle value
);
[C++/CLI]
public:
property HatchStyle HatchStyle {
   HatchStyle get();
   void set (HatchStyle value);
}

Value

The HatchStyle used on the rectangle annotation.

See Also

RectangleTool Class | RectangleTool Members


HighlightFill Property

RectangleTool Class | RectangleTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HighlightFill Property

PegasusImaging.WinForms.NotateXpress9 Namespace > RectangleTool Class : HighlightFill Property (RectangleTool)

This property sets or returns whether or not the background of the rectangle annotation will be translucent.

[Visual Basic]
Public Property HighlightFill As Boolean
[C#]
public bool HighlightFill {get; set;}
[C++]
public: __property bool get_HighlightFill();
public: __property void set_HighlightFill(
   bool value
);
[C++/CLI]
public:
property bool HighlightFill {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true to fill the annotation translucent. Otherwise, false is used and the background is opaque.

See Also

RectangleTool Class | RectangleTool Members


PenColor Property

RectangleTool Class | RectangleTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PenColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > RectangleTool Class : PenColor Property (RectangleTool)

This property sets or returns the color of the pen used to draw the border around the rectangle annotation .

[Visual Basic]
Public Property PenColor As Color
[C#]
public Color PenColor {get; set;}
[C++]
public: __property Color get_PenColor();
public: __property void set_PenColor(
   Color value
);
[C++/CLI]
public:
property Color PenColor {
   Color get();
   void set (Color value);
}

Value

The Color of the pen to draw the border around the rectangle annotation.

See Also

RectangleTool Class | RectangleTool Members


PenWidth Property

RectangleTool Class | RectangleTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PenWidth Property

PegasusImaging.WinForms.NotateXpress9 Namespace > RectangleTool Class : PenWidth Property (RectangleTool)

This property sets or returns the width of the pen used to draw the rectangle annotation.

[Visual Basic]
Public Property PenWidth As Integer
[C#]
public int PenWidth {get; set;}
[C++]
public: __property int get_PenWidth();
public: __property void set_PenWidth(
   int value
);
[C++/CLI]
public:
property int PenWidth {
   int get();
   void set (int value);
}

Value

The width of the pen.

See Also

RectangleTool Class | RectangleTool Members


UserDraw Property

RectangleTool Class | RectangleTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

UserDraw Property

PegasusImaging.WinForms.NotateXpress9 Namespace > RectangleTool Class : UserDraw Property (RectangleTool)

This property sets or returns whether or not the UserDraw event is raised.

[Visual Basic]
Public Property UserDraw As Boolean
[C#]
public bool UserDraw {get; set;}
[C++]
public: __property bool get_UserDraw();
public: __property void set_UserDraw(
   bool value
);
[C++/CLI]
public:
property bool UserDraw {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true to raise the UserDraw event. Otherwise, false is used and the UserDraw event is not raised.

See Also

RectangleTool Class | RectangleTool Members


RectangleToolbarDefaults Class

RectangleToolbarDefaults Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

RectangleToolbarDefaults Class

PegasusImaging.WinForms.NotateXpress9 Namespace : RectangleToolbarDefaults Class (PegasusImaging.WinForms.NotateXpress9)

The TextTool is used to create Rectangle annotations.

For a list of all members of this type, see RectangleToolbarDefaults members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.NotateXpress9.BaseToolbarDefaults
PegasusImaging.WinForms.NotateXpress9.RectangleToolbarDefaults

Syntax

[Visual Basic]
Public Class RectangleToolbarDefaults
   Inherits BaseToolbarDefaults
[C#]
public class RectangleToolbarDefaults : BaseToolbarDefaults
[C++]
public __gc class RectangleToolbarDefaults : public BaseToolbarDefaults
[C++/CLI]
public ref class RectangleToolbarDefaults : public BaseToolbarDefaults

See Also

RectangleToolbarDefaults Members | PegasusImaging.WinForms.NotateXpress9 Namespace


RectangleToolbarDefaults Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

RectangleToolbarDefaults Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : RectangleToolbarDefaults Class (PegasusImaging.WinForms.NotateXpress9)

RectangleToolbarDefaults overview

Public Constructors

Public Constructor RectangleToolbarDefaults Constructor Default constructor for the RectangleToolbarDefaults class.

Public Properties

Public Property BackStyle | This property sets or returns the style of the background used within the Rectangle annotation.
Public Property FillColor | This property sets or returns the color of the fill used within the Rectangle annotation.
Public Property Fixed (Inherited from BaseToolbarDefaults) | Gets and sets whether an element is tied to the view instead of the image.
Public Property HatchColor | This property sets or returns the color of the hatch style used within the Rectangle annotation.
Public Property HatchStyle | This property sets or returns the hatch style used within the Rectangle annotation.
Public Property HighlightFill | Gets and sets whether whether the fill color for the current tool is displayed as highlighted (translucent), or as an opaque color.
Public Property Locked (Inherited from BaseToolbarDefaults) | Gets and sets an indicator to lock an element so it cannot be selected or moved by a user in Edit mode.
Public Property Moveable (Inherited from BaseToolbarDefaults) | Gets and sets whether an element can be moved interactively during EditMode.
Public Property PenColor | This property sets or returns the color of the pen used to draw the border around the Rectangle annotation .
Public Property PenWidth | This property sets or returns the width of the pen used to draw the Rectangle annotation.
Public Property Selected (Inherited from BaseToolbarDefaults) | Gets and sets whether an element is automatically selected.
Public Property ShowHandles (Inherited from BaseToolbarDefaults) | Gets and sets whether selection handles are displayed for an element.
Public Property Sizeable (Inherited from BaseToolbarDefaults) | Gets and sets whether an element can be sized interactively during EditMode.
Public Property ToolTipText (Inherited from BaseToolbarDefaults) | Gets or sets a string value in the element that will become the ToolTipText value associated with the annotation once it is created.
Public Property UserDraw | The UserDraw event is raised for a Rectangle object during its paint when the Rectangle’s UserDraw attribute is True. When the UserDraw event is raised, the Rectangle does not perform its normal painting, but just raises the event
Public Property UserLong (Inherited from BaseToolbarDefaults) | Gets and sets a long value in the element that will become the UserLong value associated with the element once it is created.
Public Property UserString (Inherited from BaseToolbarDefaults) | Gets and sets a string value in the element that will become the UserString value associated with the object once it is created.
Public Property Visible (Inherited from BaseToolbarDefaults) | Gets and sets the Visible attribute of an element.

See Also

RectangleToolbarDefaults Class | PegasusImaging.WinForms.NotateXpress9 Namespace


RectangleToolbarDefaults Constructor

RectangleToolbarDefaults Class | RectangleToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

RectangleToolbarDefaults Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > RectangleToolbarDefaults Class : RectangleToolbarDefaults Constructor (RectangleToolbarDefaults)

Default constructor for the RectangleToolbarDefaults class.

[Visual Basic]
Public Function New()
[C#]
public RectangleToolbarDefaults();
[C++]
public: RectangleToolbarDefaults();
[C++/CLI]
public:
RectangleToolbarDefaults();

See Also

RectangleToolbarDefaults Class | RectangleToolbarDefaults Members


RectangleToolbarDefaults Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

RectangleToolbarDefaults Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : RectangleToolbarDefaults Class (PegasusImaging.WinForms.NotateXpress9)

For a list of all members of this type, see RectangleToolbarDefaults members.

Public Properties

Public Property BackStyle | This property sets or returns the style of the background used within the Rectangle annotation.
Public Property FillColor | This property sets or returns the color of the fill used within the Rectangle annotation.
Public Property Fixed (Inherited from BaseToolbarDefaults) | Gets and sets whether an element is tied to the view instead of the image.
Public Property HatchColor | This property sets or returns the color of the hatch style used within the Rectangle annotation.
Public Property HatchStyle | This property sets or returns the hatch style used within the Rectangle annotation.
Public Property HighlightFill | Gets and sets whether whether the fill color for the current tool is displayed as highlighted (translucent), or as an opaque color.
Public Property Locked (Inherited from BaseToolbarDefaults) | Gets and sets an indicator to lock an element so it cannot be selected or moved by a user in Edit mode.
Public Property Moveable (Inherited from BaseToolbarDefaults) | Gets and sets whether an element can be moved interactively during EditMode.
Public Property PenColor | This property sets or returns the color of the pen used to draw the border around the Rectangle annotation .
Public Property PenWidth | This property sets or returns the width of the pen used to draw the Rectangle annotation.
Public Property Selected (Inherited from BaseToolbarDefaults) | Gets and sets whether an element is automatically selected.
Public Property ShowHandles (Inherited from BaseToolbarDefaults) | Gets and sets whether selection handles are displayed for an element.
Public Property Sizeable (Inherited from BaseToolbarDefaults) | Gets and sets whether an element can be sized interactively during EditMode.
Public Property ToolTipText (Inherited from BaseToolbarDefaults) | Gets or sets a string value in the element that will become the ToolTipText value associated with the annotation once it is created.
Public Property UserDraw | The UserDraw event is raised for a Rectangle object during its paint when the Rectangle’s UserDraw attribute is True. When the UserDraw event is raised, the Rectangle does not perform its normal painting, but just raises the event
Public Property UserLong (Inherited from BaseToolbarDefaults) | Gets and sets a long value in the element that will become the UserLong value associated with the element once it is created.
Public Property UserString (Inherited from BaseToolbarDefaults) | Gets and sets a string value in the element that will become the UserString value associated with the object once it is created.
Public Property Visible (Inherited from BaseToolbarDefaults) | Gets and sets the Visible attribute of an element.

See Also

RectangleToolbarDefaults Class | PegasusImaging.WinForms.NotateXpress9 Namespace


BackStyle Property

RectangleToolbarDefaults Class | RectangleToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BackStyle Property

PegasusImaging.WinForms.NotateXpress9 Namespace > RectangleToolbarDefaults Class : BackStyle Property (RectangleToolbarDefaults)

This property sets or returns the style of the background used within the Rectangle annotation.

[Visual Basic]
Public Property BackStyle As BackStyle
[C#]
public BackStyle BackStyle {get; set;}
[C++]
public: __property BackStyle get_BackStyle();
public: __property void set_BackStyle(
   BackStyle value
);
[C++/CLI]
public:
property BackStyle BackStyle {
   BackStyle get();
   void set (BackStyle value);
}

Value

The BackStyle used for the rectangle annotation as a default.

See Also

RectangleToolbarDefaults Class | RectangleToolbarDefaults Members


FillColor Property

RectangleToolbarDefaults Class | RectangleToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

FillColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > RectangleToolbarDefaults Class : FillColor Property (RectangleToolbarDefaults)

This property sets or returns the color of the fill used within the Rectangle annotation.

[Visual Basic]
Public Property FillColor As Color
[C#]
public Color FillColor {get; set;}
[C++]
public: __property Color get_FillColor();
public: __property void set_FillColor(
   Color value
);
[C++/CLI]
public:
property Color FillColor {
   Color get();
   void set (Color value);
}

Value

The color of the fill.

See Also

RectangleToolbarDefaults Class | RectangleToolbarDefaults Members


HatchColor Property

RectangleToolbarDefaults Class | RectangleToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HatchColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > RectangleToolbarDefaults Class : HatchColor Property (RectangleToolbarDefaults)

This property sets or returns the color of the hatch style used within the Rectangle annotation.

[Visual Basic]
Public Property HatchColor As Color
[C#]
public Color HatchColor {get; set;}
[C++]
public: __property Color get_HatchColor();
public: __property void set_HatchColor(
   Color value
);
[C++/CLI]
public:
property Color HatchColor {
   Color get();
   void set (Color value);
}

Value

The color of the hatch.

Remarks

The HatchColor is the color of the hatch strokes on a filled object whose HatchStyle attribute is something other than HatchStyle_None.

See Also

RectangleToolbarDefaults Class | RectangleToolbarDefaults Members


HatchStyle Property

RectangleToolbarDefaults Class | RectangleToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HatchStyle Property

PegasusImaging.WinForms.NotateXpress9 Namespace > RectangleToolbarDefaults Class : HatchStyle Property (RectangleToolbarDefaults)

This property sets or returns the hatch style used within the Rectangle annotation.

[Visual Basic]
Public Property HatchStyle As HatchStyle
[C#]
public HatchStyle HatchStyle {get; set;}
[C++]
public: __property HatchStyle get_HatchStyle();
public: __property void set_HatchStyle(
   HatchStyle value
);
[C++/CLI]
public:
property HatchStyle HatchStyle {
   HatchStyle get();
   void set (HatchStyle value);
}

Value

The HatchStyle used as a default for the rectangle annotation.

See Also

RectangleToolbarDefaults Class | RectangleToolbarDefaults Members


HighlightFill Property

RectangleToolbarDefaults Class | RectangleToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HighlightFill Property

PegasusImaging.WinForms.NotateXpress9 Namespace > RectangleToolbarDefaults Class : HighlightFill Property (RectangleToolbarDefaults)

Gets and sets whether whether the fill color for the current tool is displayed as highlighted (translucent), or as an opaque color.

[Visual Basic]
Public Property HighlightFill As Boolean
[C#]
public bool HighlightFill {get; set;}
[C++]
public: __property bool get_HighlightFill();
public: __property void set_HighlightFill(
   bool value
);
[C++/CLI]
public:
property bool HighlightFill {
   bool get();
   void set (bool value);
}

Value

true if HighlightFill otherwise, false.

See Also

RectangleToolbarDefaults Class | RectangleToolbarDefaults Members


PenColor Property

RectangleToolbarDefaults Class | RectangleToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PenColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > RectangleToolbarDefaults Class : PenColor Property (RectangleToolbarDefaults)

This property sets or returns the color of the pen used to draw the border around the Rectangle annotation .

[Visual Basic]
Public Property PenColor As Color
[C#]
public Color PenColor {get; set;}
[C++]
public: __property Color get_PenColor();
public: __property void set_PenColor(
   Color value
);
[C++/CLI]
public:
property Color PenColor {
   Color get();
   void set (Color value);
}

Value

The Color of the pen.

See Also

RectangleToolbarDefaults Class | RectangleToolbarDefaults Members


PenWidth Property

RectangleToolbarDefaults Class | RectangleToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PenWidth Property

PegasusImaging.WinForms.NotateXpress9 Namespace > RectangleToolbarDefaults Class : PenWidth Property (RectangleToolbarDefaults)

This property sets or returns the width of the pen used to draw the Rectangle annotation.

[Visual Basic]
Public Property PenWidth As Integer
[C#]
public int PenWidth {get; set;}
[C++]
public: __property int get_PenWidth();
public: __property void set_PenWidth(
   int value
);
[C++/CLI]
public:
property int PenWidth {
   int get();
   void set (int value);
}

Value

The width of the pen.

See Also

RectangleToolbarDefaults Class | RectangleToolbarDefaults Members


UserDraw Property

RectangleToolbarDefaults Class | RectangleToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

UserDraw Property

PegasusImaging.WinForms.NotateXpress9 Namespace > RectangleToolbarDefaults Class : UserDraw Property (RectangleToolbarDefaults)

The UserDraw event is raised for a Rectangle object during its paint when the Rectangle’s UserDraw attribute is True. When the UserDraw event is raised, the Rectangle does not perform its normal painting, but just raises the event

[Visual Basic]
Public Property UserDraw As Boolean
[C#]
public bool UserDraw {get; set;}
[C++]
public: __property bool get_UserDraw();
public: __property void set_UserDraw(
   bool value
);
[C++/CLI]
public:
property bool UserDraw {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true to raise the UserDraw event. Otherwise, false is used and the UserDraw event is not raised.

Remarks

When the UserDraw event is raised, the Rectangle does not perform its normal painting, but just raises the event.

See Also

RectangleToolbarDefaults Class | RectangleToolbarDefaults Members


RulerTool Class

RulerTool Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

RulerTool Class

PegasusImaging.WinForms.NotateXpress9 Namespace : RulerTool Class

The RulerTool is used to create ruler annotations.

For a list of all members of this type, see RulerTool members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.NotateXpress9.Element
PegasusImaging.WinForms.NotateXpress9.RulerTool

Syntax

[Visual Basic]
Public Class RulerTool
   Inherits Element
   Implements IDisposable
[C#]
public class RulerTool : Element, IDisposable
[C++]
public __gc class RulerTool : public Element, IDisposable
[C++/CLI]
public ref class RulerTool : public Element, IDisposable

See Also

RulerTool Members | PegasusImaging.WinForms.NotateXpress9 Namespace


RulerTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

RulerTool Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : RulerTool Class

RulerTool overview

Public Constructors

Public Constructor RulerTool Constructor Default constructor for the RulerTool class.

Public Properties

Public Property BackColor | This property sets or returns the color of the backgroud displayed behind the text showing the length of the ruler annotation.
Public Property BackStyle | This property sets or returns the style of the background used with the ruler annotation.
Public Property BeginPointStyle | Gets and sets the arrowhead used to draw the ruler.
Public Property BoundingRectangle (Inherited from Element) | Gets and sets the rectangle boundary for the element.
Public Property CreateTime (Inherited from Element) | A Read only property that gets the time when the element was created.
Public Property EndPointStyle | This property sets or returns the EndPointStyle used to draw the ruler.
Public Property Fixed (Inherited from Element) | Gets and sets whether an annotation has a fixed position with respect to the control window.
Public Property GaugeLength | This property sets or returns the length of the gauge draw at the endpoints of the ruler annotation.
Public Property GroupMember (Inherited from Element) | Gets the group which the element belongs to.
Public Property IsGroupMember (Inherited from Element) | A read only property that gets a value which determines if the element is a member of a group or not.
Public Property Locked (Inherited from Element) | Gets and sets an indicator whether an annotation element can be selected or moved by a user in Edit mode.
Public Property MeasurementUnit | This property sets or returns the measurement unit of the ruler annotation.
Public Property Moveable (Inherited from Element) | Gets and sets whether the element can be moved by a user in Edit mode.
Public Property NumberPoints (Inherited from Element) | A Read only property that gets the number of points currently used to define the element.
Public Property PenColor | This property sets or returns the color of the pen used to draw the ruler annotation .
Public Property PenFillStyle | This property sets or returns the PenFillStyle used to draw the line.
Public Property PenStyle | This property sets or returns the PenStyle used to draw the line.
Public Property PenWidth | This property sets or returns the width of the pen used to draw the ruler annotation.
Public Property Precision | This property sets or returns the number of decimal places to show for the ruler annotation length.
Public Property RulerLength | Gets the length of the ruler.
Public Property Selected (Inherited from Element) | Gets and sets whether the element has been selected.
Public Property ShowAbbreviation | This property sets or returns whether or not the length unit text will be abbreviated.
Public Property ShowGauge | This property sets or returns whether or not the gauge lines will be displayed on the endpoints of the ruler annotation.
Public Property ShowHandles (Inherited from Element) | Gets and sets whether selection handles are displayed on an object when it is selected.
Public Property ShowLength | This property sets or returns whether or not the length will be displayed adjacent to the ruler annotation.
Public Property Sizeable (Inherited from Element) | Gets and sets whether the element can be resized.
Public Property TextColor | This property sets or returns the color of the text used to display the length of the ruler annotation.
Public Property TextFont | This property sets or returns the font of the length text used with the ruler annotation.
Public Property ToolTipText (Inherited from Element) | Gets and sets a string value in the element that will become the ToolTipText value associated with the element.
Public Property UserLong (Inherited from Element) | Gets and sets a user defined long value associated with the element.
Public Property UserString (Inherited from Element) | Gets and sets a user-defined string associated with the element.
Public Property Visible (Inherited from Element) | Gets and sets whether the element is visible.

Public Methods

Public Method Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public Method GetAbbreviation | Gets the abbreviation for the given MeasurementUnit.
Public Method NudgeDown (Inherited from Element) | Moves the specified annotation object one level down, towards the back, in the painting order of the specified layer.
Public Method NudgeUp (Inherited from Element) | Moves the specified annotation object one level up, towards the front, in the painting order of the specified layer.
Public Method SetAbbreviation | This public function sets the specified abbreviation for the given tool. If this object is connected, it will call into the worker and update real-time. If not connected however, the information will be stored, and the abbreviations will be updated when connected.
Public Method UserDataAdd (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataDelete (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFind (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFindFirst (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFindNext (Inherited from Element) | User data can be added to each element in a key value pair.

See Also

RulerTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace


RulerTool Constructor

RulerTool Class | RulerTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

RulerTool Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > RulerTool Class : RulerTool Constructor (RulerTool)

Default constructor for the RulerTool class.

[Visual Basic]
Public Function New()
[C#]
public RulerTool();
[C++]
public: RulerTool();
[C++/CLI]
public:
RulerTool();

See Also

RulerTool Class | RulerTool Members


Dispose Method

RulerTool Class | RulerTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Dispose Method

PegasusImaging.WinForms.NotateXpress9 Namespace > RulerTool Class : Dispose Method (RulerTool)

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();
[C++]
public: void Dispose();
[C++/CLI]
public:
void Dispose();

See Also

RulerTool Class | RulerTool Members


GetAbbreviation Method

RulerTool Class | RulerTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

measurementUnit
The MeasurementUnit.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetAbbreviation Method

PegasusImaging.WinForms.NotateXpress9 Namespace > RulerTool Class : GetAbbreviation Method

Gets the abbreviation for the given MeasurementUnit.

[Visual Basic]
Public Function GetAbbreviation( _
   ByVal measurementUnit As MeasurementUnit _
) As String
[C#]
public string GetAbbreviation(
   MeasurementUnit measurementUnit
);
[C++]
public: string* GetAbbreviation(
   MeasurementUnit measurementUnit
)
[C++/CLI]
public:
String^ GetAbbreviation(
   MeasurementUnit measurementUnit
)

Parameters

measurementUnit
The MeasurementUnit.

Return Type

The string representing the given MeasurementUnit.

See Also

RulerTool Class | RulerTool Members


SetAbbreviation Method

RulerTool Class | RulerTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

measurementUnit
The measurement unit which to apply the abbreviation
abbreviation
The new abbreviation string
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

SetAbbreviation Method

PegasusImaging.WinForms.NotateXpress9 Namespace > RulerTool Class : SetAbbreviation Method

This public function sets the specified abbreviation for the given tool. If this object is connected, it will call into the worker and update real-time. If not connected however, the information will be stored, and the abbreviations will be updated when connected.

[Visual Basic]
Public Sub SetAbbreviation( _
   ByVal measurementUnit As MeasurementUnit, _
   ByVal abbreviation As String _
)
[C#]
public void SetAbbreviation(
   MeasurementUnit measurementUnit,
   string abbreviation
);
[C++]
public: void SetAbbreviation(
   MeasurementUnit measurementUnit,
   string* abbreviation
)
[C++/CLI]
public:
void SetAbbreviation(
   MeasurementUnit measurementUnit,
   String^ abbreviation
)

Parameters

measurementUnit
The measurement unit which to apply the abbreviation
abbreviation
The new abbreviation string

See Also

RulerTool Class | RulerTool Members


RulerTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

RulerTool Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : RulerTool Class

For a list of all members of this type, see RulerTool members.

Public Properties

Public Property BackColor | This property sets or returns the color of the backgroud displayed behind the text showing the length of the ruler annotation.
Public Property BackStyle | This property sets or returns the style of the background used with the ruler annotation.
Public Property BeginPointStyle | Gets and sets the arrowhead used to draw the ruler.
Public Property BoundingRectangle (Inherited from Element) | Gets and sets the rectangle boundary for the element.
Public Property CreateTime (Inherited from Element) | A Read only property that gets the time when the element was created.
Public Property EndPointStyle | This property sets or returns the EndPointStyle used to draw the ruler.
Public Property Fixed (Inherited from Element) | Gets and sets whether an annotation has a fixed position with respect to the control window.
Public Property GaugeLength | This property sets or returns the length of the gauge draw at the endpoints of the ruler annotation.
Public Property GroupMember (Inherited from Element) | Gets the group which the element belongs to.
Public Property IsGroupMember (Inherited from Element) | A read only property that gets a value which determines if the element is a member of a group or not.
Public Property Locked (Inherited from Element) | Gets and sets an indicator whether an annotation element can be selected or moved by a user in Edit mode.
Public Property MeasurementUnit | This property sets or returns the measurement unit of the ruler annotation.
Public Property Moveable (Inherited from Element) | Gets and sets whether the element can be moved by a user in Edit mode.
Public Property NumberPoints (Inherited from Element) | A Read only property that gets the number of points currently used to define the element.
Public Property PenColor | This property sets or returns the color of the pen used to draw the ruler annotation .
Public Property PenFillStyle | This property sets or returns the PenFillStyle used to draw the line.
Public Property PenStyle | This property sets or returns the PenStyle used to draw the line.
Public Property PenWidth | This property sets or returns the width of the pen used to draw the ruler annotation.
Public Property Precision | This property sets or returns the number of decimal places to show for the ruler annotation length.
Public Property RulerLength | Gets the length of the ruler.
Public Property Selected (Inherited from Element) | Gets and sets whether the element has been selected.
Public Property ShowAbbreviation | This property sets or returns whether or not the length unit text will be abbreviated.
Public Property ShowGauge | This property sets or returns whether or not the gauge lines will be displayed on the endpoints of the ruler annotation.
Public Property ShowHandles (Inherited from Element) | Gets and sets whether selection handles are displayed on an object when it is selected.
Public Property ShowLength | This property sets or returns whether or not the length will be displayed adjacent to the ruler annotation.
Public Property Sizeable (Inherited from Element) | Gets and sets whether the element can be resized.
Public Property TextColor | This property sets or returns the color of the text used to display the length of the ruler annotation.
Public Property TextFont | This property sets or returns the font of the length text used with the ruler annotation.
Public Property ToolTipText (Inherited from Element) | Gets and sets a string value in the element that will become the ToolTipText value associated with the element.
Public Property UserLong (Inherited from Element) | Gets and sets a user defined long value associated with the element.
Public Property UserString (Inherited from Element) | Gets and sets a user-defined string associated with the element.
Public Property Visible (Inherited from Element) | Gets and sets whether the element is visible.

See Also

RulerTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace


BackColor Property

RulerTool Class | RulerTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BackColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > RulerTool Class : BackColor Property (RulerTool)

This property sets or returns the color of the backgroud displayed behind the text showing the length of the ruler annotation.

[Visual Basic]
Public Property BackColor As Color
[C#]
public Color BackColor {get; set;}
[C++]
public: __property Color get_BackColor();
public: __property void set_BackColor(
   Color value
);
[C++/CLI]
public:
property Color BackColor {
   Color get();
   void set (Color value);
}

Value

The Color of the background.

See Also

RulerTool Class | RulerTool Members


BackStyle Property

RulerTool Class | RulerTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BackStyle Property

PegasusImaging.WinForms.NotateXpress9 Namespace > RulerTool Class : BackStyle Property (RulerTool)

This property sets or returns the style of the background used with the ruler annotation.

[Visual Basic]
Public Property BackStyle As BackStyle
[C#]
public BackStyle BackStyle {get; set;}
[C++]
public: __property BackStyle get_BackStyle();
public: __property void set_BackStyle(
   BackStyle value
);
[C++/CLI]
public:
property BackStyle BackStyle {
   BackStyle get();
   void set (BackStyle value);
}

Value

The BackStyle used with the ruler annotation.

See Also

RulerTool Class | RulerTool Members


BeginPointStyle Property

RulerTool Class | RulerTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BeginPointStyle Property

PegasusImaging.WinForms.NotateXpress9 Namespace > RulerTool Class : BeginPointStyle Property (RulerTool)

Gets and sets the arrowhead used to draw the ruler.

[Visual Basic]
Public Property BeginPointStyle As EndPointStyle
[C#]
public EndPointStyle BeginPointStyle {get; set;}
[C++]
public: __property EndPointStyle get_BeginPointStyle();
public: __property void set_BeginPointStyle(
   EndPointStyle value
);
[C++/CLI]
public:
property EndPointStyle BeginPointStyle {
   EndPointStyle get();
   void set (EndPointStyle value);
}

Value

The begin point style.

Remarks

This property is in addition to the built-in guage.

See Also

RulerTool Class | RulerTool Members


EndPointStyle Property

RulerTool Class | RulerTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

EndPointStyle Property

PegasusImaging.WinForms.NotateXpress9 Namespace > RulerTool Class : EndPointStyle Property (RulerTool)

This property sets or returns the EndPointStyle used to draw the ruler.

[Visual Basic]
Public Property EndPointStyle As EndPointStyle
[C#]
public EndPointStyle EndPointStyle {get; set;}
[C++]
public: __property EndPointStyle get_EndPointStyle();
public: __property void set_EndPointStyle(
   EndPointStyle value
);
[C++/CLI]
public:
property EndPointStyle EndPointStyle {
   EndPointStyle get();
   void set (EndPointStyle value);
}

Value

The begin point style.

Remarks

This property is in addition to the built-in guage.

See Also

RulerTool Class | RulerTool Members


GaugeLength Property

RulerTool Class | RulerTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GaugeLength Property

PegasusImaging.WinForms.NotateXpress9 Namespace > RulerTool Class : GaugeLength Property (RulerTool)

This property sets or returns the length of the gauge draw at the endpoints of the ruler annotation.

[Visual Basic]
Public Property GaugeLength As Integer
[C#]
public int GaugeLength {get; set;}
[C++]
public: __property int get_GaugeLength();
public: __property void set_GaugeLength(
   int value
);
[C++/CLI]
public:
property int GaugeLength {
   int get();
   void set (int value);
}

Value

An integer value which represents the length of the gauge.

See Also

RulerTool Class | RulerTool Members


MeasurementUnit Property

RulerTool Class | RulerTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

MeasurementUnit Property

PegasusImaging.WinForms.NotateXpress9 Namespace > RulerTool Class : MeasurementUnit Property (RulerTool)

This property sets or returns the measurement unit of the ruler annotation.

[Visual Basic]
Public Property MeasurementUnit As MeasurementUnit
[C#]
public MeasurementUnit MeasurementUnit {get; set;}
[C++]
public: __property MeasurementUnit get_MeasurementUnit();
public: __property void set_MeasurementUnit(
   MeasurementUnit value
);
[C++/CLI]
public:
property MeasurementUnit MeasurementUnit {
   MeasurementUnit get();
   void set (MeasurementUnit value);
}

Value

The MeasurementUnit for the ruler annotation.

See Also

RulerTool Class | RulerTool Members


PenColor Property

RulerTool Class | RulerTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PenColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > RulerTool Class : PenColor Property (RulerTool)

This property sets or returns the color of the pen used to draw the ruler annotation .

[Visual Basic]
Public Property PenColor As Color
[C#]
public Color PenColor {get; set;}
[C++]
public: __property Color get_PenColor();
public: __property void set_PenColor(
   Color value
);
[C++/CLI]
public:
property Color PenColor {
   Color get();
   void set (Color value);
}

Value

The Color of the pen.

See Also

RulerTool Class | RulerTool Members


PenFillStyle Property

RulerTool Class | RulerTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PenFillStyle Property

PegasusImaging.WinForms.NotateXpress9 Namespace > RulerTool Class : PenFillStyle Property (RulerTool)

This property sets or returns the PenFillStyle used to draw the line.

[Visual Basic]
Public Property PenFillStyle As PenFillStyle
[C#]
public PenFillStyle PenFillStyle {get; set;}
[C++]
public: __property PenFillStyle get_PenFillStyle();
public: __property void set_PenFillStyle(
   PenFillStyle value
);
[C++/CLI]
public:
property PenFillStyle PenFillStyle {
   PenFillStyle get();
   void set (PenFillStyle value);
}

Value

The PenFillStyle used to draw the line for the ruler annotation.

See Also

RulerTool Class | RulerTool Members


PenStyle Property

RulerTool Class | RulerTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PenStyle Property

PegasusImaging.WinForms.NotateXpress9 Namespace > RulerTool Class : PenStyle Property (RulerTool)

This property sets or returns the PenStyle used to draw the line.

[Visual Basic]
Public Property PenStyle As PenStyle
[C#]
public PenStyle PenStyle {get; set;}
[C++]
public: __property PenStyle get_PenStyle();
public: __property void set_PenStyle(
   PenStyle value
);
[C++/CLI]
public:
property PenStyle PenStyle {
   PenStyle get();
   void set (PenStyle value);
}

Value

The PenStyle used to draw the line.

See Also

RulerTool Class | RulerTool Members


PenWidth Property

RulerTool Class | RulerTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PenWidth Property

PegasusImaging.WinForms.NotateXpress9 Namespace > RulerTool Class : PenWidth Property (RulerTool)

This property sets or returns the width of the pen used to draw the ruler annotation.

[Visual Basic]
Public Property PenWidth As Integer
[C#]
public int PenWidth {get; set;}
[C++]
public: __property int get_PenWidth();
public: __property void set_PenWidth(
   int value
);
[C++/CLI]
public:
property int PenWidth {
   int get();
   void set (int value);
}

Value

An integer value which represents the width of the pen.

See Also

RulerTool Class | RulerTool Members


Precision Property

RulerTool Class | RulerTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Precision Property

PegasusImaging.WinForms.NotateXpress9 Namespace > RulerTool Class : Precision Property (RulerTool)

This property sets or returns the number of decimal places to show for the ruler annotation length.

[Visual Basic]
Public Property Precision As Integer
[C#]
public int Precision {get; set;}
[C++]
public: __property int get_Precision();
public: __property void set_Precision(
   int value
);
[C++/CLI]
public:
property int Precision {
   int get();
   void set (int value);
}

Value

An integer value which represents the precision.

See Also

RulerTool Class | RulerTool Members


RulerLength Property

RulerTool Class | RulerTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

RulerLength Property

PegasusImaging.WinForms.NotateXpress9 Namespace > RulerTool Class : RulerLength Property

Gets the length of the ruler.

[Visual Basic]
Public ReadOnly Property RulerLength As Single
[C#]
public float RulerLength {get;}
[C++]
public: __property float get_RulerLength();
[C++/CLI]
public:
property float RulerLength {
   float get();
}

Value

A single value which represents the length of the ruler.

See Also

RulerTool Class | RulerTool Members


ShowAbbreviation Property

RulerTool Class | RulerTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ShowAbbreviation Property

PegasusImaging.WinForms.NotateXpress9 Namespace > RulerTool Class : ShowAbbreviation Property (RulerTool)

This property sets or returns whether or not the length unit text will be abbreviated.

[Visual Basic]
Public Property ShowAbbreviation As Boolean
[C#]
public bool ShowAbbreviation {get; set;}
[C++]
public: __property bool get_ShowAbbreviation();
public: __property void set_ShowAbbreviation(
   bool value
);
[C++/CLI]
public:
property bool ShowAbbreviation {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true if the length unit text is abbreviated. Otherwise, false is used and the length unit text is not abbreviated.

See Also

RulerTool Class | RulerTool Members


ShowGauge Property

RulerTool Class | RulerTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ShowGauge Property

PegasusImaging.WinForms.NotateXpress9 Namespace > RulerTool Class : ShowGauge Property (RulerTool)

This property sets or returns whether or not the gauge lines will be displayed on the endpoints of the ruler annotation.

[Visual Basic]
Public Property ShowGauge As Boolean
[C#]
public bool ShowGauge {get; set;}
[C++]
public: __property bool get_ShowGauge();
public: __property void set_ShowGauge(
   bool value
);
[C++/CLI]
public:
property bool ShowGauge {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true to display the gauge lines on the endpoints of the ruler annotation. Otherwise, false is used.

See Also

RulerTool Class | RulerTool Members


ShowLength Property

RulerTool Class | RulerTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ShowLength Property

PegasusImaging.WinForms.NotateXpress9 Namespace > RulerTool Class : ShowLength Property (RulerTool)

This property sets or returns whether or not the length will be displayed adjacent to the ruler annotation.

[Visual Basic]
Public Property ShowLength As Boolean
[C#]
public bool ShowLength {get; set;}
[C++]
public: __property bool get_ShowLength();
public: __property void set_ShowLength(
   bool value
);
[C++/CLI]
public:
property bool ShowLength {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true to display the length adjacent to the ruler annotation. Otherwise, false is used and the length is not displayed adjacent to the ruler annotation.

See Also

RulerTool Class | RulerTool Members


TextColor Property

RulerTool Class | RulerTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TextColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > RulerTool Class : TextColor Property (RulerTool)

This property sets or returns the color of the text used to display the length of the ruler annotation.

[Visual Basic]
Public Property TextColor As Color
[C#]
public Color TextColor {get; set;}
[C++]
public: __property Color get_TextColor();
public: __property void set_TextColor(
   Color value
);
[C++/CLI]
public:
property Color TextColor {
   Color get();
   void set (Color value);
}

Value

The Color of the text.

See Also

RulerTool Class | RulerTool Members


TextFont Property

RulerTool Class | RulerTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TextFont Property

PegasusImaging.WinForms.NotateXpress9 Namespace > RulerTool Class : TextFont Property (RulerTool)

This property sets or returns the font of the length text used with the ruler annotation.

[Visual Basic]
Public Property TextFont As Font
[C#]
public Font TextFont {get; set;}
[C++]
public: __property Font* get_TextFont();
public: __property void set_TextFont(
   Font* value
);
[C++/CLI]
public:
property Font^ TextFont {
   Font^ get();
   void set (Font^ value);
}

Value

The Font for the length text used with the ruler annotation.

See Also

RulerTool Class | RulerTool Members


RulerToolbarDefaults Class

RulerToolbarDefaults Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

RulerToolbarDefaults Class

PegasusImaging.WinForms.NotateXpress9 Namespace : RulerToolbarDefaults Class (PegasusImaging.WinForms.NotateXpress9)

The TextTool is used to create Ruler annotations.

For a list of all members of this type, see RulerToolbarDefaults members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.NotateXpress9.BaseToolbarDefaults
PegasusImaging.WinForms.NotateXpress9.RulerToolbarDefaults

Syntax

[Visual Basic]
Public Class RulerToolbarDefaults
   Inherits BaseToolbarDefaults
[C#]
public class RulerToolbarDefaults : BaseToolbarDefaults
[C++]
public __gc class RulerToolbarDefaults : public BaseToolbarDefaults
[C++/CLI]
public ref class RulerToolbarDefaults : public BaseToolbarDefaults

See Also

RulerToolbarDefaults Members | PegasusImaging.WinForms.NotateXpress9 Namespace


RulerToolbarDefaults Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

RulerToolbarDefaults Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : RulerToolbarDefaults Class (PegasusImaging.WinForms.NotateXpress9)

RulerToolbarDefaults overview

Public Constructors

Public Constructor RulerToolbarDefaults Constructor Default constructor for the RulerToolbarDefaults class.

Public Properties

Public Property BackColor | This property sets or returns the color of the backgroud used within the Ruler annotation.
Public Property BackStyle | This property sets or returns the style of the background used within the Ruler annotation.
Public Property BeginPointStyle | Gets and sets the arrowhead used to draw the ruler.
Public Property EndPointStyle | This property sets or returns the EndPointStyle style used within the Ruler annotation.
Public Property Fixed (Inherited from BaseToolbarDefaults) | Gets and sets whether an element is tied to the view instead of the image.
Public Property GaugeLength | This property sets or returns the length of the gauge draw at the endpoints of the ruler annotation.
Public Property Locked (Inherited from BaseToolbarDefaults) | Gets and sets an indicator to lock an element so it cannot be selected or moved by a user in Edit mode.
Public Property MeasurementUnit | This property sets or returns the measurement unit of the ruler annotation.
Public Property Moveable (Inherited from BaseToolbarDefaults) | Gets and sets whether an element can be moved interactively during EditMode.
Public Property PenColor | This property sets or returns the color of the pen used to draw the border around the Ruler annotation .
Public Property PenFillStyle | This property sets or returns the hatch style used within the Ruler annotation.
Public Property PenStyle | This property sets or returns the style of the background used within the Ruler annotation.
Public Property PenWidth | This property sets or returns the width of the pen used to draw the Ruler annotation.
Public Property Precision | This property sets or returns the number of decimal places to show for the ruler annotation length.
Public Property Selected (Inherited from BaseToolbarDefaults) | Gets and sets whether an element is automatically selected.
Public Property ShowAbbreviation | This property sets or returns whether or not the length unit text will be abbreviated.
Public Property ShowGauge | This property sets or returns whether or not the gauge lines will be displayed on the endpoints of the ruler annotation.
Public Property ShowHandles (Inherited from BaseToolbarDefaults) | Gets and sets whether selection handles are displayed for an element.
Public Property ShowLength | This property sets or returns whether or not the length will be displayed adjacent to the ruler annotation.
Public Property Sizeable (Inherited from BaseToolbarDefaults) | Gets and sets whether an element can be sized interactively during EditMode.
Public Property TextColor | This property sets or returns the color of the text used within the Ruler annotation.
Public Property TextFont | This property sets or returns the font of the text used within the Ruler annotation.
Public Property ToolTipText (Inherited from BaseToolbarDefaults) | Gets or sets a string value in the element that will become the ToolTipText value associated with the annotation once it is created.
Public Property UserLong (Inherited from BaseToolbarDefaults) | Gets and sets a long value in the element that will become the UserLong value associated with the element once it is created.
Public Property UserString (Inherited from BaseToolbarDefaults) | Gets and sets a string value in the element that will become the UserString value associated with the object once it is created.
Public Property Visible (Inherited from BaseToolbarDefaults) | Gets and sets the Visible attribute of an element.

See Also

RulerToolbarDefaults Class | PegasusImaging.WinForms.NotateXpress9 Namespace


RulerToolbarDefaults Constructor

RulerToolbarDefaults Class | RulerToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

RulerToolbarDefaults Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > RulerToolbarDefaults Class : RulerToolbarDefaults Constructor (RulerToolbarDefaults)

Default constructor for the RulerToolbarDefaults class.

[Visual Basic]
Public Function New()
[C#]
public RulerToolbarDefaults();
[C++]
public: RulerToolbarDefaults();
[C++/CLI]
public:
RulerToolbarDefaults();

See Also

RulerToolbarDefaults Class | RulerToolbarDefaults Members


RulerToolbarDefaults Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

RulerToolbarDefaults Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : RulerToolbarDefaults Class (PegasusImaging.WinForms.NotateXpress9)

For a list of all members of this type, see RulerToolbarDefaults members.

Public Properties

Public Property BackColor | This property sets or returns the color of the backgroud used within the Ruler annotation.
Public Property BackStyle | This property sets or returns the style of the background used within the Ruler annotation.
Public Property BeginPointStyle | Gets and sets the arrowhead used to draw the ruler.
Public Property EndPointStyle | This property sets or returns the EndPointStyle style used within the Ruler annotation.
Public Property Fixed (Inherited from BaseToolbarDefaults) | Gets and sets whether an element is tied to the view instead of the image.
Public Property GaugeLength | This property sets or returns the length of the gauge draw at the endpoints of the ruler annotation.
Public Property Locked (Inherited from BaseToolbarDefaults) | Gets and sets an indicator to lock an element so it cannot be selected or moved by a user in Edit mode.
Public Property MeasurementUnit | This property sets or returns the measurement unit of the ruler annotation.
Public Property Moveable (Inherited from BaseToolbarDefaults) | Gets and sets whether an element can be moved interactively during EditMode.
Public Property PenColor | This property sets or returns the color of the pen used to draw the border around the Ruler annotation .
Public Property PenFillStyle | This property sets or returns the hatch style used within the Ruler annotation.
Public Property PenStyle | This property sets or returns the style of the background used within the Ruler annotation.
Public Property PenWidth | This property sets or returns the width of the pen used to draw the Ruler annotation.
Public Property Precision | This property sets or returns the number of decimal places to show for the ruler annotation length.
Public Property Selected (Inherited from BaseToolbarDefaults) | Gets and sets whether an element is automatically selected.
Public Property ShowAbbreviation | This property sets or returns whether or not the length unit text will be abbreviated.
Public Property ShowGauge | This property sets or returns whether or not the gauge lines will be displayed on the endpoints of the ruler annotation.
Public Property ShowHandles (Inherited from BaseToolbarDefaults) | Gets and sets whether selection handles are displayed for an element.
Public Property ShowLength | This property sets or returns whether or not the length will be displayed adjacent to the ruler annotation.
Public Property Sizeable (Inherited from BaseToolbarDefaults) | Gets and sets whether an element can be sized interactively during EditMode.
Public Property TextColor | This property sets or returns the color of the text used within the Ruler annotation.
Public Property TextFont | This property sets or returns the font of the text used within the Ruler annotation.
Public Property ToolTipText (Inherited from BaseToolbarDefaults) | Gets or sets a string value in the element that will become the ToolTipText value associated with the annotation once it is created.
Public Property UserLong (Inherited from BaseToolbarDefaults) | Gets and sets a long value in the element that will become the UserLong value associated with the element once it is created.
Public Property UserString (Inherited from BaseToolbarDefaults) | Gets and sets a string value in the element that will become the UserString value associated with the object once it is created.
Public Property Visible (Inherited from BaseToolbarDefaults) | Gets and sets the Visible attribute of an element.

See Also

RulerToolbarDefaults Class | PegasusImaging.WinForms.NotateXpress9 Namespace


BackColor Property

RulerToolbarDefaults Class | RulerToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BackColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > RulerToolbarDefaults Class : BackColor Property (RulerToolbarDefaults)

This property sets or returns the color of the backgroud used within the Ruler annotation.

[Visual Basic]
Public Property BackColor As Color
[C#]
public Color BackColor {get; set;}
[C++]
public: __property Color get_BackColor();
public: __property void set_BackColor(
   Color value
);
[C++/CLI]
public:
property Color BackColor {
   Color get();
   void set (Color value);
}

Value

The color of the backgroud.

See Also

RulerToolbarDefaults Class | RulerToolbarDefaults Members


BackStyle Property

RulerToolbarDefaults Class | RulerToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BackStyle Property

PegasusImaging.WinForms.NotateXpress9 Namespace > RulerToolbarDefaults Class : BackStyle Property (RulerToolbarDefaults)

This property sets or returns the style of the background used within the Ruler annotation.

[Visual Basic]
Public Property BackStyle As BackStyle
[C#]
public BackStyle BackStyle {get; set;}
[C++]
public: __property BackStyle get_BackStyle();
public: __property void set_BackStyle(
   BackStyle value
);
[C++/CLI]
public:
property BackStyle BackStyle {
   BackStyle get();
   void set (BackStyle value);
}

Value

The BackStyle used for the ruler annotation.

See Also

RulerToolbarDefaults Class | RulerToolbarDefaults Members


BeginPointStyle Property

RulerToolbarDefaults Class | RulerToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BeginPointStyle Property

PegasusImaging.WinForms.NotateXpress9 Namespace > RulerToolbarDefaults Class : BeginPointStyle Property (RulerToolbarDefaults)

Gets and sets the arrowhead used to draw the ruler.

[Visual Basic]
Public Property BeginPointStyle As EndPointStyle
[C#]
public EndPointStyle BeginPointStyle {get; set;}
[C++]
public: __property EndPointStyle get_BeginPointStyle();
public: __property void set_BeginPointStyle(
   EndPointStyle value
);
[C++/CLI]
public:
property EndPointStyle BeginPointStyle {
   EndPointStyle get();
   void set (EndPointStyle value);
}

Value

The begin point style.

Remarks

This property is in addition to the built-in guage.

See Also

RulerToolbarDefaults Class | RulerToolbarDefaults Members


EndPointStyle Property

RulerToolbarDefaults Class | RulerToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

EndPointStyle Property

PegasusImaging.WinForms.NotateXpress9 Namespace > RulerToolbarDefaults Class : EndPointStyle Property (RulerToolbarDefaults)

This property sets or returns the EndPointStyle style used within the Ruler annotation.

[Visual Basic]
Public Property EndPointStyle As EndPointStyle
[C#]
public EndPointStyle EndPointStyle {get; set;}
[C++]
public: __property EndPointStyle get_EndPointStyle();
public: __property void set_EndPointStyle(
   EndPointStyle value
);
[C++/CLI]
public:
property EndPointStyle EndPointStyle {
   EndPointStyle get();
   void set (EndPointStyle value);
}

Value

The end point style.

Remarks

This property is in addition to the built-in guage.

See Also

RulerToolbarDefaults Class | RulerToolbarDefaults Members


GaugeLength Property

RulerToolbarDefaults Class | RulerToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GaugeLength Property

PegasusImaging.WinForms.NotateXpress9 Namespace > RulerToolbarDefaults Class : GaugeLength Property (RulerToolbarDefaults)

This property sets or returns the length of the gauge draw at the endpoints of the ruler annotation.

[Visual Basic]
Public Property GaugeLength As Integer
[C#]
public int GaugeLength {get; set;}
[C++]
public: __property int get_GaugeLength();
public: __property void set_GaugeLength(
   int value
);
[C++/CLI]
public:
property int GaugeLength {
   int get();
   void set (int value);
}

Value

An integer value which represents the length of the gauge.

See Also

RulerToolbarDefaults Class | RulerToolbarDefaults Members


MeasurementUnit Property

RulerToolbarDefaults Class | RulerToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

MeasurementUnit Property

PegasusImaging.WinForms.NotateXpress9 Namespace > RulerToolbarDefaults Class : MeasurementUnit Property (RulerToolbarDefaults)

This property sets or returns the measurement unit of the ruler annotation.

[Visual Basic]
Public Property MeasurementUnit As MeasurementUnit
[C#]
public MeasurementUnit MeasurementUnit {get; set;}
[C++]
public: __property MeasurementUnit get_MeasurementUnit();
public: __property void set_MeasurementUnit(
   MeasurementUnit value
);
[C++/CLI]
public:
property MeasurementUnit MeasurementUnit {
   MeasurementUnit get();
   void set (MeasurementUnit value);
}

Value

The MeasurementUnit for the ruler annotation.

See Also

RulerToolbarDefaults Class | RulerToolbarDefaults Members


PenColor Property

RulerToolbarDefaults Class | RulerToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PenColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > RulerToolbarDefaults Class : PenColor Property (RulerToolbarDefaults)

This property sets or returns the color of the pen used to draw the border around the Ruler annotation .

[Visual Basic]
Public Property PenColor As Color
[C#]
public Color PenColor {get; set;}
[C++]
public: __property Color get_PenColor();
public: __property void set_PenColor(
   Color value
);
[C++/CLI]
public:
property Color PenColor {
   Color get();
   void set (Color value);
}

Value

The color of the pen.

See Also

RulerToolbarDefaults Class | RulerToolbarDefaults Members


PenFillStyle Property

RulerToolbarDefaults Class | RulerToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PenFillStyle Property

PegasusImaging.WinForms.NotateXpress9 Namespace > RulerToolbarDefaults Class : PenFillStyle Property (RulerToolbarDefaults)

This property sets or returns the hatch style used within the Ruler annotation.

[Visual Basic]
Public Property PenFillStyle As PenFillStyle
[C#]
public PenFillStyle PenFillStyle {get; set;}
[C++]
public: __property PenFillStyle get_PenFillStyle();
public: __property void set_PenFillStyle(
   PenFillStyle value
);
[C++/CLI]
public:
property PenFillStyle PenFillStyle {
   PenFillStyle get();
   void set (PenFillStyle value);
}

Value

The PenFillStyle used for the ruler annotation.

See Also

RulerToolbarDefaults Class | RulerToolbarDefaults Members


PenStyle Property

RulerToolbarDefaults Class | RulerToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PenStyle Property

PegasusImaging.WinForms.NotateXpress9 Namespace > RulerToolbarDefaults Class : PenStyle Property (RulerToolbarDefaults)

This property sets or returns the style of the background used within the Ruler annotation.

[Visual Basic]
Public Property PenStyle As PenStyle
[C#]
public PenStyle PenStyle {get; set;}
[C++]
public: __property PenStyle get_PenStyle();
public: __property void set_PenStyle(
   PenStyle value
);
[C++/CLI]
public:
property PenStyle PenStyle {
   PenStyle get();
   void set (PenStyle value);
}

Value

The PenStyle used for the ruler annotation.

See Also

RulerToolbarDefaults Class | RulerToolbarDefaults Members


PenWidth Property

RulerToolbarDefaults Class | RulerToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PenWidth Property

PegasusImaging.WinForms.NotateXpress9 Namespace > RulerToolbarDefaults Class : PenWidth Property (RulerToolbarDefaults)

This property sets or returns the width of the pen used to draw the Ruler annotation.

[Visual Basic]
Public Property PenWidth As Integer
[C#]
public int PenWidth {get; set;}
[C++]
public: __property int get_PenWidth();
public: __property void set_PenWidth(
   int value
);
[C++/CLI]
public:
property int PenWidth {
   int get();
   void set (int value);
}

Value

An integer value which represents the width of the pen.

See Also

RulerToolbarDefaults Class | RulerToolbarDefaults Members


Precision Property

RulerToolbarDefaults Class | RulerToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Precision Property

PegasusImaging.WinForms.NotateXpress9 Namespace > RulerToolbarDefaults Class : Precision Property (RulerToolbarDefaults)

This property sets or returns the number of decimal places to show for the ruler annotation length.

[Visual Basic]
Public Property Precision As Integer
[C#]
public int Precision {get; set;}
[C++]
public: __property int get_Precision();
public: __property void set_Precision(
   int value
);
[C++/CLI]
public:
property int Precision {
   int get();
   void set (int value);
}

Value

An integer value which represents the precision.

See Also

RulerToolbarDefaults Class | RulerToolbarDefaults Members


ShowAbbreviation Property

RulerToolbarDefaults Class | RulerToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ShowAbbreviation Property

PegasusImaging.WinForms.NotateXpress9 Namespace > RulerToolbarDefaults Class : ShowAbbreviation Property (RulerToolbarDefaults)

This property sets or returns whether or not the length unit text will be abbreviated.

[Visual Basic]
Public Property ShowAbbreviation As Boolean
[C#]
public bool ShowAbbreviation {get; set;}
[C++]
public: __property bool get_ShowAbbreviation();
public: __property void set_ShowAbbreviation(
   bool value
);
[C++/CLI]
public:
property bool ShowAbbreviation {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true to abbreviate length unit text. Otherwise, false is used.

Remarks

The default value is false.

See Also

RulerToolbarDefaults Class | RulerToolbarDefaults Members


ShowGauge Property

RulerToolbarDefaults Class | RulerToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ShowGauge Property

PegasusImaging.WinForms.NotateXpress9 Namespace > RulerToolbarDefaults Class : ShowGauge Property (RulerToolbarDefaults)

This property sets or returns whether or not the gauge lines will be displayed on the endpoints of the ruler annotation.

[Visual Basic]
Public Property ShowGauge As Boolean
[C#]
public bool ShowGauge {get; set;}
[C++]
public: __property bool get_ShowGauge();
public: __property void set_ShowGauge(
   bool value
);
[C++/CLI]
public:
property bool ShowGauge {
   bool get();
   void set (bool value);
}

See Also

RulerToolbarDefaults Class | RulerToolbarDefaults Members


ShowLength Property

RulerToolbarDefaults Class | RulerToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ShowLength Property

PegasusImaging.WinForms.NotateXpress9 Namespace > RulerToolbarDefaults Class : ShowLength Property (RulerToolbarDefaults)

This property sets or returns whether or not the length will be displayed adjacent to the ruler annotation.

[Visual Basic]
Public Property ShowLength As Boolean
[C#]
public bool ShowLength {get; set;}
[C++]
public: __property bool get_ShowLength();
public: __property void set_ShowLength(
   bool value
);
[C++/CLI]
public:
property bool ShowLength {
   bool get();
   void set (bool value);
}

Value

true if ShowLength otherwise, false.

See Also

RulerToolbarDefaults Class | RulerToolbarDefaults Members


TextColor Property

RulerToolbarDefaults Class | RulerToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TextColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > RulerToolbarDefaults Class : TextColor Property (RulerToolbarDefaults)

This property sets or returns the color of the text used within the Ruler annotation.

[Visual Basic]
Public Property TextColor As Color
[C#]
public Color TextColor {get; set;}
[C++]
public: __property Color get_TextColor();
public: __property void set_TextColor(
   Color value
);
[C++/CLI]
public:
property Color TextColor {
   Color get();
   void set (Color value);
}

Value

The color of the text.

See Also

RulerToolbarDefaults Class | RulerToolbarDefaults Members


TextFont Property

RulerToolbarDefaults Class | RulerToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TextFont Property

PegasusImaging.WinForms.NotateXpress9 Namespace > RulerToolbarDefaults Class : TextFont Property (RulerToolbarDefaults)

This property sets or returns the font of the text used within the Ruler annotation.

[Visual Basic]
Public Property TextFont As Font
[C#]
public Font TextFont {get; set;}
[C++]
public: __property Font* get_TextFont();
public: __property void set_TextFont(
   Font* value
);
[C++/CLI]
public:
property Font^ TextFont {
   Font^ get();
   void set (Font^ value);
}

Value

The text font.

See Also

RulerToolbarDefaults Class | RulerToolbarDefaults Members


SaveFileOneLayerException Class

SaveFileOneLayerException Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

SaveFileOneLayerException Class

PegasusImaging.WinForms.NotateXpress9 Namespace : SaveFileOneLayerException Class

This class implements exceptions when saving a file on one layer.

For a list of all members of this type, see SaveFileOneLayerException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.NotateXpress9.NotateXpressException
PegasusImaging.WinForms.NotateXpress9.SaveFileOneLayerException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class SaveFileOneLayerException
   Inherits NotateXpressException
   Implements ISerializable, _Exception
[C#]
[SerializableAttribute()]
public sealed class SaveFileOneLayerException : NotateXpressException, ISerializable, _Exception
[C++]
[SerializableAttribute()]
public __gc __sealed class SaveFileOneLayerException : public NotateXpressException, ISerializable, _Exception
[C++/CLI]
[SerializableAttribute()]
public ref class SaveFileOneLayerException sealed : public NotateXpressException, ISerializable, _Exception

See Also

SaveFileOneLayerException Members | PegasusImaging.WinForms.NotateXpress9 Namespace


SaveFileOneLayerException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

SaveFileOneLayerException Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : SaveFileOneLayerException Class

SaveFileOneLayerException overview

Public Constructors

Public Constructor SaveFileOneLayerException Constructor Overloaded. Exception when saving a file on one layer error occur.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

SaveFileOneLayerException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


SaveFileOneLayerException Constructor

SaveFileOneLayerException Class | SaveFileOneLayerException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

SaveFileOneLayerException Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > SaveFileOneLayerException Class : SaveFileOneLayerException Constructor (SaveFileOneLayerException)

Exception when saving a file on one layer error occur.

Overload List

Exception when saving a file on one layer error occur.

[Visual Basic] Public Sub New()

[C#] public SaveFileOneLayerException();

[C++] public SaveFileOneLayerException();

[C++/CLI] public SaveFileOneLayerException();

Exception which allows passing in an error number for saving a file on one layer errors.

[Visual Basic] Public Sub New(Integer)

[C#] public SaveFileOneLayerException(int);

[C++] public SaveFileOneLayerException(int);

[C++/CLI] public SaveFileOneLayerException(int);

Exception which allows passing in an error message when saving a file on one layer errors.

[Visual Basic] Public Sub New(String)

[C#] public SaveFileOneLayerException(string);

[C++] public SaveFileOneLayerException(string*);

[C++/CLI] public SaveFileOneLayerException(String^);

Exception which allows passing in an error number and message when saving a file on one layer errors.

[Visual Basic] Public Sub New(Integer,String)

[C#] public SaveFileOneLayerException(int,string);

[C++] public SaveFileOneLayerException(int,string*);

[C++/CLI] public SaveFileOneLayerException(int,String^);

Exception which allows passing in an error message and inner exceptions when saving a file on one layer errors.

[Visual Basic] Public Sub New(String,Exception)

[C#] public SaveFileOneLayerException(string,Exception);

[C++] public SaveFileOneLayerException(string*,Exception*);

[C++/CLI] public SaveFileOneLayerException(String^,Exception^);

See Also

SaveFileOneLayerException Class | SaveFileOneLayerException Members


SaveFileOneLayerException Constructor()

SaveFileOneLayerException Class | SaveFileOneLayerException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

SaveFileOneLayerException Constructor()

PegasusImaging.WinForms.NotateXpress9 Namespace > SaveFileOneLayerException Class > SaveFileOneLayerException Constructor : SaveFileOneLayerException Constructor()

Exception when saving a file on one layer error occur.

[Visual Basic]
Public Function New()
[C#]
public SaveFileOneLayerException();
[C++]
public: SaveFileOneLayerException();
[C++/CLI]
public:
SaveFileOneLayerException();

See Also

SaveFileOneLayerException Class | SaveFileOneLayerException Members | Overload List


SaveFileOneLayerException Constructor(Int32)

SaveFileOneLayerException Class | SaveFileOneLayerException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer value which represents the error number.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

SaveFileOneLayerException Constructor(Int32)

PegasusImaging.WinForms.NotateXpress9 Namespace > SaveFileOneLayerException Class > SaveFileOneLayerException Constructor : SaveFileOneLayerException Constructor(Int32)

Exception which allows passing in an error number for saving a file on one layer errors.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public SaveFileOneLayerException(
   int errorNumber
);
[C++]
public: SaveFileOneLayerException(
   int errorNumber
)
[C++/CLI]
public:
SaveFileOneLayerException(
   int errorNumber
)

Parameters

errorNumber
An integer value which represents the error number.

See Also

SaveFileOneLayerException Class | SaveFileOneLayerException Members | Overload List


SaveFileOneLayerException Constructor(Int32,String)

SaveFileOneLayerException Class | SaveFileOneLayerException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer value which represents the error message.
message
A string value which represents the error message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

SaveFileOneLayerException Constructor(Int32,String)

PegasusImaging.WinForms.NotateXpress9 Namespace > SaveFileOneLayerException Class > SaveFileOneLayerException Constructor : SaveFileOneLayerException Constructor(Int32,String)

Exception which allows passing in an error number and message when saving a file on one layer errors.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public SaveFileOneLayerException(
   int errorNumber,
   string message
);
[C++]
public: SaveFileOneLayerException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
SaveFileOneLayerException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer value which represents the error message.
message
A string value which represents the error message.

See Also

SaveFileOneLayerException Class | SaveFileOneLayerException Members | Overload List


SaveFileOneLayerException Constructor(String)

SaveFileOneLayerException Class | SaveFileOneLayerException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string value which represents the error message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

SaveFileOneLayerException Constructor(String)

PegasusImaging.WinForms.NotateXpress9 Namespace > SaveFileOneLayerException Class > SaveFileOneLayerException Constructor : SaveFileOneLayerException Constructor(String)

Exception which allows passing in an error message when saving a file on one layer errors.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public SaveFileOneLayerException(
   string message
);
[C++]
public: SaveFileOneLayerException(
   string* message
)
[C++/CLI]
public:
SaveFileOneLayerException(
   String^ message
)

Parameters

message
A string value which represents the error message.

See Also

SaveFileOneLayerException Class | SaveFileOneLayerException Members | Overload List


SaveFileOneLayerException Constructor(String,Exception)

SaveFileOneLayerException Class | SaveFileOneLayerException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string value which represents the error message.
innerException
An inner exception which further describes the error.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

SaveFileOneLayerException Constructor(String,Exception)

PegasusImaging.WinForms.NotateXpress9 Namespace > SaveFileOneLayerException Class > SaveFileOneLayerException Constructor : SaveFileOneLayerException Constructor(String,Exception)

Exception which allows passing in an error message and inner exceptions when saving a file on one layer errors.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public SaveFileOneLayerException(
   string message,
   Exception innerException
);
[C++]
public: SaveFileOneLayerException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
SaveFileOneLayerException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string value which represents the error message.
innerException
An inner exception which further describes the error.

See Also

SaveFileOneLayerException Class | SaveFileOneLayerException Members | Overload List


SaveOptions Class

SaveOptions Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

SaveOptions Class

PegasusImaging.WinForms.NotateXpress9 Namespace : SaveOptions Class

This class implements methods and properties for controlling how the annotations are saved.

For a list of all members of this type, see SaveOptions members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.NotateXpress9.SaveOptions

Syntax

[Visual Basic]
Public Class SaveOptions
[C#]
public class SaveOptions
[C++]
public __gc class SaveOptions
[C++/CLI]
public ref class SaveOptions

See Also

SaveOptions Members | PegasusImaging.WinForms.NotateXpress9 Namespace


SaveOptions Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

SaveOptions Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : SaveOptions Class

SaveOptions overview

Public Constructors

Public Constructor SaveOptions Constructor Initializes a new instance of the SaveOptions class.

Public Properties

Public Property AllLayers | Gets or sets a value indicating whether all the layers are written.
Public Property AnnType | Gets or sets the type of the type of annotations that NotateXpress can process.
Public Property Mapping | Gets and sets the coordinate mapping conversion system that is used when saving annotations.
Public Property PreserveWangLayers | Gets and sets the way that NotateXpress objects are stored in Wang annotation-compatible TIFF files.
Public Property SaveLayer | Gets and sets which layer to pass when the AllLayers property is set to false.
Public Property SaveUserData | Gets and sets if NotateXpress should write unknown attributes when saving XML.

See Also

SaveOptions Class | PegasusImaging.WinForms.NotateXpress9 Namespace


SaveOptions Constructor

SaveOptions Class | SaveOptions Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

SaveOptions Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > SaveOptions Class : SaveOptions Constructor (SaveOptions)

Initializes a new instance of the SaveOptions class.

[Visual Basic]
Public Function New()
[C#]
public SaveOptions();
[C++]
public: SaveOptions();
[C++/CLI]
public:
SaveOptions();

See Also

SaveOptions Class | SaveOptions Members


SaveOptions Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

SaveOptions Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : SaveOptions Class

For a list of all members of this type, see SaveOptions members.

Public Properties

Public Property AllLayers | Gets or sets a value indicating whether all the layers are written.
Public Property AnnType | Gets or sets the type of the type of annotations that NotateXpress can process.
Public Property Mapping | Gets and sets the coordinate mapping conversion system that is used when saving annotations.
Public Property PreserveWangLayers | Gets and sets the way that NotateXpress objects are stored in Wang annotation-compatible TIFF files.
Public Property SaveLayer | Gets and sets which layer to pass when the AllLayers property is set to false.
Public Property SaveUserData | Gets and sets if NotateXpress should write unknown attributes when saving XML.

See Also

SaveOptions Class | PegasusImaging.WinForms.NotateXpress9 Namespace


AllLayers Property

SaveOptions Class | SaveOptions Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

AllLayers Property

PegasusImaging.WinForms.NotateXpress9 Namespace > SaveOptions Class : AllLayers Property (SaveOptions)

Gets or sets a value indicating whether all the layers are written.

[Visual Basic]
Public Property AllLayers As Boolean
[C#]
public bool AllLayers {get; set;}
[C++]
public: __property bool get_AllLayers();
public: __property void set_AllLayers(
   bool value
);
[C++/CLI]
public:
property bool AllLayers {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true to write all layers. Otherwise, false is used and the specific layer is taken from SaveLayer.

Remarks

Note: Not all ways of writing formats support this option.

See Also

SaveOptions Class | SaveOptions Members


AnnType Property

SaveOptions Class | SaveOptions Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

AnnType Property

PegasusImaging.WinForms.NotateXpress9 Namespace > SaveOptions Class : AnnType Property (SaveOptions)

Gets or sets the type of the type of annotations that NotateXpress can process.

[Visual Basic]
Public Property AnnType As AnnotationType
[C#]
public AnnotationType AnnType {get; set;}
[C++]
public: __property AnnotationType get_AnnType();
public: __property void set_AnnType(
   AnnotationType value
);
[C++/CLI]
public:
property AnnotationType AnnType {
   AnnotationType get();
   void set (AnnotationType value);
}

Value

The AnnotationType enumeration values which NotateXpress can process.

See Also

SaveOptions Class | SaveOptions Members


Mapping Property

SaveOptions Class | SaveOptions Members | Mapping Property

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Mapping Property

PegasusImaging.WinForms.NotateXpress9 Namespace > SaveOptions Class : Mapping Property (SaveOptions)

Gets and sets the coordinate mapping conversion system that is used when saving annotations.

[Visual Basic]
Public Property Mapping As Mapping
[C#]
public Mapping Mapping {get; set;}
[C++]
public: __property Mapping get_Mapping();
public: __property void set_Mapping(
   Mapping value
);
[C++/CLI]
public:
property Mapping Mapping {
   Mapping get();
   void set (Mapping value);
}

Value

The Mapping enumeration value set.

See Also

SaveOptions Class | SaveOptions Members | Mapping Property


PreserveWangLayers Property

SaveOptions Class | SaveOptions Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PreserveWangLayers Property

PegasusImaging.WinForms.NotateXpress9 Namespace > SaveOptions Class : PreserveWangLayers Property (SaveOptions)

Gets and sets the way that NotateXpress objects are stored in Wang annotation-compatible TIFF files.

[Visual Basic]
Public Property PreserveWangLayers As Boolean
[C#]
public bool PreserveWangLayers {get; set;}
[C++]
public: __property bool get_PreserveWangLayers();
public: __property void set_PreserveWangLayers(
   bool value
);
[C++/CLI]
public:
property bool PreserveWangLayers {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true to store items together in one group tag. Otherwise, false is used and NotateXpress will not preserve layers when writing annotations to a TIFF file.

Remarks

The default value is false.

When this property is set to true, NotateXpress stores items from a layer together under one Group tag. When set to false, NotateXpress stores each object in a separate Group tag.

When reading a TIFF file, NotateXpress creates a separate layer for each Group tag encountered if this property is set to true, otherwise only one layer is created and all objects placed in that layer.

See Also

SaveOptions Class | SaveOptions Members


SaveLayer Property

SaveOptions Class | SaveOptions Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

SaveLayer Property

PegasusImaging.WinForms.NotateXpress9 Namespace > SaveOptions Class : SaveLayer Property

Gets and sets which layer to pass when the AllLayers property is set to false.

[Visual Basic]
Public Property SaveLayer As Layer
[C#]
public Layer SaveLayer {get; set;}
[C++]
public: __property Layer* get_SaveLayer();
public: __property void set_SaveLayer(
   Layer* value
);
[C++/CLI]
public:
property Layer^ SaveLayer {
   Layer^ get();
   void set (Layer^ value);
}

Value

The Layer to be saved.

See Also

SaveOptions Class | SaveOptions Members


SaveUserData Property

SaveOptions Class | SaveOptions Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

SaveUserData Property

PegasusImaging.WinForms.NotateXpress9 Namespace > SaveOptions Class : SaveUserData Property

Gets and sets if NotateXpress should write unknown attributes when saving XML.

[Visual Basic]
Public Property SaveUserData As Boolean
[C#]
public bool SaveUserData {get; set;}
[C++]
public: __property bool get_SaveUserData();
public: __property void set_SaveUserData(
   bool value
);
[C++/CLI]
public:
property bool SaveUserData {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true to write unknown attributes when saving XML. Otherwise, false is returned.

See Also

SaveOptions Class | SaveOptions Members


StampTool Class

StampTool Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StampTool Class

PegasusImaging.WinForms.NotateXpress9 Namespace : StampTool Class

The StampTool is used to create stamp annotations. Stamp annotations resemble text annotations in that they have text displayed with an optional background and border. However, stamp annotations have static text, which cannot be edited directly by the user.

For a list of all members of this type, see StampTool members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.NotateXpress9.Element
PegasusImaging.WinForms.NotateXpress9.StampTool

Syntax

[Visual Basic]
Public Class StampTool
   Inherits Element
   Implements IDisposable
[C#]
public class StampTool : Element, IDisposable
[C++]
public __gc class StampTool : public Element, IDisposable
[C++/CLI]
public ref class StampTool : public Element, IDisposable

Remarks

Stamp annotations resemble text annotations in that they have text displayed with an optional background and border. However, stamp annotations have static text, which cannot be edited directly by the user.

See Also

StampTool Members | PegasusImaging.WinForms.NotateXpress9 Namespace


StampTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StampTool Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : StampTool Class

StampTool overview

Public Constructors

Public Constructor StampTool Constructor Default constructor for the StampTool class.

Public Properties

Public Property AutoSize | This property sets or returns whether or not the annotation size will be automatically expanded to fit the given text within the stamp annotation.
Public Property BackColor | This property sets or returns the color of the backgroud used within the stamp annotation.
Public Property BackStyle | This property sets or returns the style of the background used within the stamp annotation.
Public Property BoundingRectangle (Inherited from Element) | Gets and sets the rectangle boundary for the element.
Public Property CreateTime (Inherited from Element) | A Read only property that gets the time when the element was created.
Public Property Fixed (Inherited from Element) | Gets and sets whether an annotation has a fixed position with respect to the control window.
Public Property GroupMember (Inherited from Element) | Gets the group which the element belongs to.
Public Property HatchColor | This property sets or returns the color of the hatch style used within the stamp annotation.
Public Property HatchStyle | This property sets or returns the hatch style used within the stamp annotation.
Public Property HighlightBack | This property sets or returns whether or not the background of the stamp annotation will be translucent.
Public Property IsGroupMember (Inherited from Element) | A read only property that gets a value which determines if the element is a member of a group or not.
Public Property Locked (Inherited from Element) | Gets and sets an indicator whether an annotation element can be selected or moved by a user in Edit mode.
Public Property Moveable (Inherited from Element) | Gets and sets whether the element can be moved by a user in Edit mode.
Public Property NumberPoints (Inherited from Element) | A Read only property that gets the number of points currently used to define the element.
Public Property PenColor | This property sets or returns the color of the pen used to draw the border around the stamp annotation .
Public Property PenWidth | This property sets or returns the width of the pen used to draw the stamp annotation.
Public Property Selected (Inherited from Element) | Gets and sets whether the element has been selected.
Public Property ShowHandles (Inherited from Element) | Gets and sets whether selection handles are displayed on an object when it is selected.
Public Property Sizeable (Inherited from Element) | Gets and sets whether the element can be resized.
Public Property Text | This property sets or returns the string value used within the stamp annotation.
Public Property TextColor | This property sets or returns the color of the text used within the stamp annotation.
Public Property TextFont | This property sets or returns the font of the text used within the stamp annotation.
Public Property TextOrientation | This property sets or returns the orientation of the text displayed within the stamp annotation.
Public Property ToolTipText (Inherited from Element) | Gets and sets a string value in the element that will become the ToolTipText value associated with the element.
Public Property UserLong (Inherited from Element) | Gets and sets a user defined long value associated with the element.
Public Property UserString (Inherited from Element) | Gets and sets a user-defined string associated with the element.
Public Property Visible (Inherited from Element) | Gets and sets whether the element is visible.

Public Methods

Public Method Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public Method NudgeDown (Inherited from Element) | Moves the specified annotation object one level down, towards the back, in the painting order of the specified layer.
Public Method NudgeUp (Inherited from Element) | Moves the specified annotation object one level up, towards the front, in the painting order of the specified layer.
Public Method UserDataAdd (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataDelete (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFind (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFindFirst (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFindNext (Inherited from Element) | User data can be added to each element in a key value pair.

See Also

StampTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace


StampTool Constructor

StampTool Class | StampTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StampTool Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > StampTool Class : StampTool Constructor (StampTool)

Default constructor for the StampTool class.

[Visual Basic]
Public Function New()
[C#]
public StampTool();
[C++]
public: StampTool();
[C++/CLI]
public:
StampTool();

See Also

StampTool Class | StampTool Members


Dispose Method

StampTool Class | StampTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Dispose Method

PegasusImaging.WinForms.NotateXpress9 Namespace > StampTool Class : Dispose Method (StampTool)

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();
[C++]
public: void Dispose();
[C++/CLI]
public:
void Dispose();

See Also

StampTool Class | StampTool Members


StampTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StampTool Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : StampTool Class

For a list of all members of this type, see StampTool members.

Public Properties

Public Property AutoSize | This property sets or returns whether or not the annotation size will be automatically expanded to fit the given text within the stamp annotation.
Public Property BackColor | This property sets or returns the color of the backgroud used within the stamp annotation.
Public Property BackStyle | This property sets or returns the style of the background used within the stamp annotation.
Public Property BoundingRectangle (Inherited from Element) | Gets and sets the rectangle boundary for the element.
Public Property CreateTime (Inherited from Element) | A Read only property that gets the time when the element was created.
Public Property Fixed (Inherited from Element) | Gets and sets whether an annotation has a fixed position with respect to the control window.
Public Property GroupMember (Inherited from Element) | Gets the group which the element belongs to.
Public Property HatchColor | This property sets or returns the color of the hatch style used within the stamp annotation.
Public Property HatchStyle | This property sets or returns the hatch style used within the stamp annotation.
Public Property HighlightBack | This property sets or returns whether or not the background of the stamp annotation will be translucent.
Public Property IsGroupMember (Inherited from Element) | A read only property that gets a value which determines if the element is a member of a group or not.
Public Property Locked (Inherited from Element) | Gets and sets an indicator whether an annotation element can be selected or moved by a user in Edit mode.
Public Property Moveable (Inherited from Element) | Gets and sets whether the element can be moved by a user in Edit mode.
Public Property NumberPoints (Inherited from Element) | A Read only property that gets the number of points currently used to define the element.
Public Property PenColor | This property sets or returns the color of the pen used to draw the border around the stamp annotation .
Public Property PenWidth | This property sets or returns the width of the pen used to draw the stamp annotation.
Public Property Selected (Inherited from Element) | Gets and sets whether the element has been selected.
Public Property ShowHandles (Inherited from Element) | Gets and sets whether selection handles are displayed on an object when it is selected.
Public Property Sizeable (Inherited from Element) | Gets and sets whether the element can be resized.
Public Property Text | This property sets or returns the string value used within the stamp annotation.
Public Property TextColor | This property sets or returns the color of the text used within the stamp annotation.
Public Property TextFont | This property sets or returns the font of the text used within the stamp annotation.
Public Property TextOrientation | This property sets or returns the orientation of the text displayed within the stamp annotation.
Public Property ToolTipText (Inherited from Element) | Gets and sets a string value in the element that will become the ToolTipText value associated with the element.
Public Property UserLong (Inherited from Element) | Gets and sets a user defined long value associated with the element.
Public Property UserString (Inherited from Element) | Gets and sets a user-defined string associated with the element.
Public Property Visible (Inherited from Element) | Gets and sets whether the element is visible.

See Also

StampTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace


AutoSize Property

StampTool Class | StampTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

AutoSize Property

PegasusImaging.WinForms.NotateXpress9 Namespace > StampTool Class : AutoSize Property (StampTool)

This property sets or returns whether or not the annotation size will be automatically expanded to fit the given text within the stamp annotation.

[Visual Basic]
Public Property AutoSize As AutoSize
[C#]
public AutoSize AutoSize {get; set;}
[C++]
public: __property AutoSize get_AutoSize();
public: __property void set_AutoSize(
   AutoSize value
);
[C++/CLI]
public:
property AutoSize AutoSize {
   AutoSize get();
   void set (AutoSize value);
}

Value

The type of sizing to do.

See Also

StampTool Class | StampTool Members


BackColor Property

StampTool Class | StampTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BackColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > StampTool Class : BackColor Property (StampTool)

This property sets or returns the color of the backgroud used within the stamp annotation.

[Visual Basic]
Public Property BackColor As Color
[C#]
public Color BackColor {get; set;}
[C++]
public: __property Color get_BackColor();
public: __property void set_BackColor(
   Color value
);
[C++/CLI]
public:
property Color BackColor {
   Color get();
   void set (Color value);
}

Value

The color of the background.

See Also

StampTool Class | StampTool Members


BackStyle Property

StampTool Class | StampTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BackStyle Property

PegasusImaging.WinForms.NotateXpress9 Namespace > StampTool Class : BackStyle Property (StampTool)

This property sets or returns the style of the background used within the stamp annotation.

[Visual Basic]
Public Property BackStyle As BackStyle
[C#]
public BackStyle BackStyle {get; set;}
[C++]
public: __property BackStyle get_BackStyle();
public: __property void set_BackStyle(
   BackStyle value
);
[C++/CLI]
public:
property BackStyle BackStyle {
   BackStyle get();
   void set (BackStyle value);
}

Value

The background style.

See Also

StampTool Class | StampTool Members


HatchColor Property

StampTool Class | StampTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HatchColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > StampTool Class : HatchColor Property (StampTool)

This property sets or returns the color of the hatch style used within the stamp annotation.

[Visual Basic]
Public Property HatchColor As Color
[C#]
public Color HatchColor {get; set;}
[C++]
public: __property Color get_HatchColor();
public: __property void set_HatchColor(
   Color value
);
[C++/CLI]
public:
property Color HatchColor {
   Color get();
   void set (Color value);
}

Value

The color of the hatch.

Remarks

The HatchColor is the color of the hatch strokes on a filled object whose HatchStyle attribute is something other than HatchStyle_None.

See Also

StampTool Class | StampTool Members


HatchStyle Property

StampTool Class | StampTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HatchStyle Property

PegasusImaging.WinForms.NotateXpress9 Namespace > StampTool Class : HatchStyle Property (StampTool)

This property sets or returns the hatch style used within the stamp annotation.

[Visual Basic]
Public Property HatchStyle As HatchStyle
[C#]
public HatchStyle HatchStyle {get; set;}
[C++]
public: __property HatchStyle get_HatchStyle();
public: __property void set_HatchStyle(
   HatchStyle value
);
[C++/CLI]
public:
property HatchStyle HatchStyle {
   HatchStyle get();
   void set (HatchStyle value);
}

Value

The HatchStyle used for the stamp annotation.

See Also

StampTool Class | StampTool Members


HighlightBack Property

StampTool Class | StampTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HighlightBack Property

PegasusImaging.WinForms.NotateXpress9 Namespace > StampTool Class : HighlightBack Property (StampTool)

This property sets or returns whether or not the background of the stamp annotation will be translucent.

[Visual Basic]
Public Property HighlightBack As Boolean
[C#]
public bool HighlightBack {get; set;}
[C++]
public: __property bool get_HighlightBack();
public: __property void set_HighlightBack(
   bool value
);
[C++/CLI]
public:
property bool HighlightBack {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true to make the stamp annotation background translucent. Otherwise, false is used and the stamp annotation background is not translucent.

See Also

StampTool Class | StampTool Members


PenColor Property

StampTool Class | StampTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PenColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > StampTool Class : PenColor Property (StampTool)

This property sets or returns the color of the pen used to draw the border around the stamp annotation .

[Visual Basic]
Public Property PenColor As Color
[C#]
public Color PenColor {get; set;}
[C++]
public: __property Color get_PenColor();
public: __property void set_PenColor(
   Color value
);
[C++/CLI]
public:
property Color PenColor {
   Color get();
   void set (Color value);
}

Value

The of the pen.

See Also

StampTool Class | StampTool Members


PenWidth Property

StampTool Class | StampTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PenWidth Property

PegasusImaging.WinForms.NotateXpress9 Namespace > StampTool Class : PenWidth Property (StampTool)

This property sets or returns the width of the pen used to draw the stamp annotation.

[Visual Basic]
Public Property PenWidth As Integer
[C#]
public int PenWidth {get; set;}
[C++]
public: __property int get_PenWidth();
public: __property void set_PenWidth(
   int value
);
[C++/CLI]
public:
property int PenWidth {
   int get();
   void set (int value);
}

Value

An integer value which represents the width of the pen.

See Also

StampTool Class | StampTool Members


Text Property

StampTool Class | StampTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Text Property

PegasusImaging.WinForms.NotateXpress9 Namespace > StampTool Class : Text Property (StampTool)

This property sets or returns the string value used within the stamp annotation.

[Visual Basic]
Public Property Text As String
[C#]
public string Text {get; set;}
[C++]
public: __property string* get_Text();
public: __property void set_Text(
   string* value
);
[C++/CLI]
public:
property String^ Text {
   String^ get();
   void set (String^ value);
}

Value

A string value which represents the text for the stamp annotation.

See Also

StampTool Class | StampTool Members


TextColor Property

StampTool Class | StampTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TextColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > StampTool Class : TextColor Property (StampTool)

This property sets or returns the color of the text used within the stamp annotation.

[Visual Basic]
Public Property TextColor As Color
[C#]
public Color TextColor {get; set;}
[C++]
public: __property Color get_TextColor();
public: __property void set_TextColor(
   Color value
);
[C++/CLI]
public:
property Color TextColor {
   Color get();
   void set (Color value);
}

Value

The Color of the text.

See Also

StampTool Class | StampTool Members


TextFont Property

StampTool Class | StampTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TextFont Property

PegasusImaging.WinForms.NotateXpress9 Namespace > StampTool Class : TextFont Property (StampTool)

This property sets or returns the font of the text used within the stamp annotation.

[Visual Basic]
Public Property TextFont As Font
[C#]
public Font TextFont {get; set;}
[C++]
public: __property Font* get_TextFont();
public: __property void set_TextFont(
   Font* value
);
[C++/CLI]
public:
property Font^ TextFont {
   Font^ get();
   void set (Font^ value);
}

Value

The Font for the stamp annotation text font.

See Also

StampTool Class | StampTool Members


TextOrientation Property

StampTool Class | StampTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TextOrientation Property

PegasusImaging.WinForms.NotateXpress9 Namespace > StampTool Class : TextOrientation Property (StampTool)

This property sets or returns the orientation of the text displayed within the stamp annotation.

[Visual Basic]
Public Property TextOrientation As TextOrientation
[C#]
public TextOrientation TextOrientation {get; set;}
[C++]
public: __property TextOrientation get_TextOrientation();
public: __property void set_TextOrientation(
   TextOrientation value
);
[C++/CLI]
public:
property TextOrientation TextOrientation {
   TextOrientation get();
   void set (TextOrientation value);
}

Value

The TextOrientation of the text displayed for the stamp annotation.

See Also

StampTool Class | StampTool Members


StampToolbarDefaults Class

StampToolbarDefaults Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StampToolbarDefaults Class

PegasusImaging.WinForms.NotateXpress9 Namespace : StampToolbarDefaults Class (PegasusImaging.WinForms.NotateXpress9)

The StampTool is used to create stamp annotations. Stamp annotations resemble text annotations in that they have text displayed with an optional background and border. However, stamp annotations have static text, which cannot be edited directly by the user.

For a list of all members of this type, see StampToolbarDefaults members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.NotateXpress9.BaseToolbarDefaults
PegasusImaging.WinForms.NotateXpress9.StampToolbarDefaults

Syntax

[Visual Basic]
Public Class StampToolbarDefaults
   Inherits BaseToolbarDefaults
[C#]
public class StampToolbarDefaults : BaseToolbarDefaults
[C++]
public __gc class StampToolbarDefaults : public BaseToolbarDefaults
[C++/CLI]
public ref class StampToolbarDefaults : public BaseToolbarDefaults

Remarks

Stamp annotations resemble text annotations in that they have text displayed with an optional background and border. However, stamp annotations have static text, which cannot be edited directly by the user.

See Also

StampToolbarDefaults Members | PegasusImaging.WinForms.NotateXpress9 Namespace


StampToolbarDefaults Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StampToolbarDefaults Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : StampToolbarDefaults Class (PegasusImaging.WinForms.NotateXpress9)

StampToolbarDefaults overview

Public Constructors

Public Constructor StampToolbarDefaults Constructor Default constructor for the StampToolbarDefaults class.

Public Properties

Public Property AutoSize | This property sets or returns whether or not the annotation size will be automatically expanded to fit the given text within the stamp annotation.
Public Property BackColor | This property sets or returns the color of the backgroud used within the stamp annotation.
Public Property BackStyle | This property sets or returns the style of the background used within the stamp annotation.
Public Property Fixed (Inherited from BaseToolbarDefaults) | Gets and sets whether an element is tied to the view instead of the image.
Public Property HatchColor | This property sets or returns the color of the hatch style used within the stamp annotation.
Public Property HatchStyle | This property sets or returns the hatch style used within the stamp annotation.
Public Property HighlightBack | This property sets or returns whether or not the background of the stamp annotation will be translucent.
Public Property Locked (Inherited from BaseToolbarDefaults) | Gets and sets an indicator to lock an element so it cannot be selected or moved by a user in Edit mode.
Public Property Moveable (Inherited from BaseToolbarDefaults) | Gets and sets whether an element can be moved interactively during EditMode.
Public Property PenColor | This property sets or returns the color of the pen used to draw the border around the stamp annotation .
Public Property PenWidth | This property sets or returns the width of the pen used to draw the stamp annotation.
Public Property Selected (Inherited from BaseToolbarDefaults) | Gets and sets whether an element is automatically selected.
Public Property ShowHandles (Inherited from BaseToolbarDefaults) | Gets and sets whether selection handles are displayed for an element.
Public Property Sizeable (Inherited from BaseToolbarDefaults) | Gets and sets whether an element can be sized interactively during EditMode.
Public Property Text | This property sets or returns the string value used within the stamp annotation.
Public Property TextColor | This property sets or returns the color of the text used within the stamp annotation.
Public Property TextFont | This property sets or returns the font of the text used within the stamp annotation.
Public Property TextOrientation | Gets and sets the orientation of the text displayed within the stamp annotation.
Public Property ToolTipText (Inherited from BaseToolbarDefaults) | Gets or sets a string value in the element that will become the ToolTipText value associated with the annotation once it is created.
Public Property UserLong (Inherited from BaseToolbarDefaults) | Gets and sets a long value in the element that will become the UserLong value associated with the element once it is created.
Public Property UserString (Inherited from BaseToolbarDefaults) | Gets and sets a string value in the element that will become the UserString value associated with the object once it is created.
Public Property Visible (Inherited from BaseToolbarDefaults) | Gets and sets the Visible attribute of an element.

See Also

StampToolbarDefaults Class | PegasusImaging.WinForms.NotateXpress9 Namespace


StampToolbarDefaults Constructor

StampToolbarDefaults Class | StampToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StampToolbarDefaults Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > StampToolbarDefaults Class : StampToolbarDefaults Constructor (StampToolbarDefaults)

Default constructor for the StampToolbarDefaults class.

[Visual Basic]
Public Function New()
[C#]
public StampToolbarDefaults();
[C++]
public: StampToolbarDefaults();
[C++/CLI]
public:
StampToolbarDefaults();

See Also

StampToolbarDefaults Class | StampToolbarDefaults Members


StampToolbarDefaults Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StampToolbarDefaults Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : StampToolbarDefaults Class (PegasusImaging.WinForms.NotateXpress9)

For a list of all members of this type, see StampToolbarDefaults members.

Public Properties

Public Property AutoSize | This property sets or returns whether or not the annotation size will be automatically expanded to fit the given text within the stamp annotation.
Public Property BackColor | This property sets or returns the color of the backgroud used within the stamp annotation.
Public Property BackStyle | This property sets or returns the style of the background used within the stamp annotation.
Public Property Fixed (Inherited from BaseToolbarDefaults) | Gets and sets whether an element is tied to the view instead of the image.
Public Property HatchColor | This property sets or returns the color of the hatch style used within the stamp annotation.
Public Property HatchStyle | This property sets or returns the hatch style used within the stamp annotation.
Public Property HighlightBack | This property sets or returns whether or not the background of the stamp annotation will be translucent.
Public Property Locked (Inherited from BaseToolbarDefaults) | Gets and sets an indicator to lock an element so it cannot be selected or moved by a user in Edit mode.
Public Property Moveable (Inherited from BaseToolbarDefaults) | Gets and sets whether an element can be moved interactively during EditMode.
Public Property PenColor | This property sets or returns the color of the pen used to draw the border around the stamp annotation .
Public Property PenWidth | This property sets or returns the width of the pen used to draw the stamp annotation.
Public Property Selected (Inherited from BaseToolbarDefaults) | Gets and sets whether an element is automatically selected.
Public Property ShowHandles (Inherited from BaseToolbarDefaults) | Gets and sets whether selection handles are displayed for an element.
Public Property Sizeable (Inherited from BaseToolbarDefaults) | Gets and sets whether an element can be sized interactively during EditMode.
Public Property Text | This property sets or returns the string value used within the stamp annotation.
Public Property TextColor | This property sets or returns the color of the text used within the stamp annotation.
Public Property TextFont | This property sets or returns the font of the text used within the stamp annotation.
Public Property TextOrientation | Gets and sets the orientation of the text displayed within the stamp annotation.
Public Property ToolTipText (Inherited from BaseToolbarDefaults) | Gets or sets a string value in the element that will become the ToolTipText value associated with the annotation once it is created.
Public Property UserLong (Inherited from BaseToolbarDefaults) | Gets and sets a long value in the element that will become the UserLong value associated with the element once it is created.
Public Property UserString (Inherited from BaseToolbarDefaults) | Gets and sets a string value in the element that will become the UserString value associated with the object once it is created.
Public Property Visible (Inherited from BaseToolbarDefaults) | Gets and sets the Visible attribute of an element.

See Also

StampToolbarDefaults Class | PegasusImaging.WinForms.NotateXpress9 Namespace


AutoSize Property

StampToolbarDefaults Class | StampToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

AutoSize Property

PegasusImaging.WinForms.NotateXpress9 Namespace > StampToolbarDefaults Class : AutoSize Property (StampToolbarDefaults)

This property sets or returns whether or not the annotation size will be automatically expanded to fit the given text within the stamp annotation.

[Visual Basic]
Public Property AutoSize As AutoSize
[C#]
public AutoSize AutoSize {get; set;}
[C++]
public: __property AutoSize get_AutoSize();
public: __property void set_AutoSize(
   AutoSize value
);
[C++/CLI]
public:
property AutoSize AutoSize {
   AutoSize get();
   void set (AutoSize value);
}

Value

The type of sizing to do.

See Also

StampToolbarDefaults Class | StampToolbarDefaults Members


BackColor Property

StampToolbarDefaults Class | StampToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BackColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > StampToolbarDefaults Class : BackColor Property (StampToolbarDefaults)

This property sets or returns the color of the backgroud used within the stamp annotation.

[Visual Basic]
Public Property BackColor As Color
[C#]
public Color BackColor {get; set;}
[C++]
public: __property Color get_BackColor();
public: __property void set_BackColor(
   Color value
);
[C++/CLI]
public:
property Color BackColor {
   Color get();
   void set (Color value);
}

Value

The color of the background.

See Also

StampToolbarDefaults Class | StampToolbarDefaults Members


BackStyle Property

StampToolbarDefaults Class | StampToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BackStyle Property

PegasusImaging.WinForms.NotateXpress9 Namespace > StampToolbarDefaults Class : BackStyle Property (StampToolbarDefaults)

This property sets or returns the style of the background used within the stamp annotation.

[Visual Basic]
Public Property BackStyle As BackStyle
[C#]
public BackStyle BackStyle {get; set;}
[C++]
public: __property BackStyle get_BackStyle();
public: __property void set_BackStyle(
   BackStyle value
);
[C++/CLI]
public:
property BackStyle BackStyle {
   BackStyle get();
   void set (BackStyle value);
}

Value

The BackStyle used for the stamp annotation.

See Also

StampToolbarDefaults Class | StampToolbarDefaults Members


HatchColor Property

StampToolbarDefaults Class | StampToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HatchColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > StampToolbarDefaults Class : HatchColor Property (StampToolbarDefaults)

This property sets or returns the color of the hatch style used within the stamp annotation.

[Visual Basic]
Public Property HatchColor As Color
[C#]
public Color HatchColor {get; set;}
[C++]
public: __property Color get_HatchColor();
public: __property void set_HatchColor(
   Color value
);
[C++/CLI]
public:
property Color HatchColor {
   Color get();
   void set (Color value);
}

Value

The color of the hatch.

Remarks

The HatchColor is the color of the hatch strokes on a filled object whose HatchStyle attribute is something other than HatchStyle_None.

See Also

StampToolbarDefaults Class | StampToolbarDefaults Members


HatchStyle Property

StampToolbarDefaults Class | StampToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HatchStyle Property

PegasusImaging.WinForms.NotateXpress9 Namespace > StampToolbarDefaults Class : HatchStyle Property (StampToolbarDefaults)

This property sets or returns the hatch style used within the stamp annotation.

[Visual Basic]
Public Property HatchStyle As HatchStyle
[C#]
public HatchStyle HatchStyle {get; set;}
[C++]
public: __property HatchStyle get_HatchStyle();
public: __property void set_HatchStyle(
   HatchStyle value
);
[C++/CLI]
public:
property HatchStyle HatchStyle {
   HatchStyle get();
   void set (HatchStyle value);
}

Value

The HatchStyle used for the stamp annotation.

See Also

StampToolbarDefaults Class | StampToolbarDefaults Members


HighlightBack Property

StampToolbarDefaults Class | StampToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HighlightBack Property

PegasusImaging.WinForms.NotateXpress9 Namespace > StampToolbarDefaults Class : HighlightBack Property (StampToolbarDefaults)

This property sets or returns whether or not the background of the stamp annotation will be translucent.

[Visual Basic]
Public Property HighlightBack As Boolean
[C#]
public bool HighlightBack {get; set;}
[C++]
public: __property bool get_HighlightBack();
public: __property void set_HighlightBack(
   bool value
);
[C++/CLI]
public:
property bool HighlightBack {
   bool get();
   void set (bool value);
}

Value

true if HighlightBack otherwise, false.

See Also

StampToolbarDefaults Class | StampToolbarDefaults Members


PenColor Property

StampToolbarDefaults Class | StampToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PenColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > StampToolbarDefaults Class : PenColor Property (StampToolbarDefaults)

This property sets or returns the color of the pen used to draw the border around the stamp annotation .

[Visual Basic]
Public Property PenColor As Color
[C#]
public Color PenColor {get; set;}
[C++]
public: __property Color get_PenColor();
public: __property void set_PenColor(
   Color value
);
[C++/CLI]
public:
property Color PenColor {
   Color get();
   void set (Color value);
}

Value

The color of the pen.

See Also

StampToolbarDefaults Class | StampToolbarDefaults Members


PenWidth Property

StampToolbarDefaults Class | StampToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PenWidth Property

PegasusImaging.WinForms.NotateXpress9 Namespace > StampToolbarDefaults Class : PenWidth Property (StampToolbarDefaults)

This property sets or returns the width of the pen used to draw the stamp annotation.

[Visual Basic]
Public Property PenWidth As Integer
[C#]
public int PenWidth {get; set;}
[C++]
public: __property int get_PenWidth();
public: __property void set_PenWidth(
   int value
);
[C++/CLI]
public:
property int PenWidth {
   int get();
   void set (int value);
}

Value

An integer value which represents the width of the pen.

See Also

StampToolbarDefaults Class | StampToolbarDefaults Members


Text Property

StampToolbarDefaults Class | StampToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Text Property

PegasusImaging.WinForms.NotateXpress9 Namespace > StampToolbarDefaults Class : Text Property (StampToolbarDefaults)

This property sets or returns the string value used within the stamp annotation.

[Visual Basic]
Public Property Text As String
[C#]
public string Text {get; set;}
[C++]
public: __property string* get_Text();
public: __property void set_Text(
   string* value
);
[C++/CLI]
public:
property String^ Text {
   String^ get();
   void set (String^ value);
}

Value

The text.

See Also

StampToolbarDefaults Class | StampToolbarDefaults Members


TextColor Property

StampToolbarDefaults Class | StampToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TextColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > StampToolbarDefaults Class : TextColor Property (StampToolbarDefaults)

This property sets or returns the color of the text used within the stamp annotation.

[Visual Basic]
Public Property TextColor As Color
[C#]
public Color TextColor {get; set;}
[C++]
public: __property Color get_TextColor();
public: __property void set_TextColor(
   Color value
);
[C++/CLI]
public:
property Color TextColor {
   Color get();
   void set (Color value);
}

Value

The color of the text.

See Also

StampToolbarDefaults Class | StampToolbarDefaults Members


TextFont Property

StampToolbarDefaults Class | StampToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TextFont Property

PegasusImaging.WinForms.NotateXpress9 Namespace > StampToolbarDefaults Class : TextFont Property (StampToolbarDefaults)

This property sets or returns the font of the text used within the stamp annotation.

[Visual Basic]
Public Property TextFont As Font
[C#]
public Font TextFont {get; set;}
[C++]
public: __property Font* get_TextFont();
public: __property void set_TextFont(
   Font* value
);
[C++/CLI]
public:
property Font^ TextFont {
   Font^ get();
   void set (Font^ value);
}

Value

The Font used for the stamp annotation.

See Also

StampToolbarDefaults Class | StampToolbarDefaults Members


TextOrientation Property

StampToolbarDefaults Class | StampToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TextOrientation Property

PegasusImaging.WinForms.NotateXpress9 Namespace > StampToolbarDefaults Class : TextOrientation Property (StampToolbarDefaults)

Gets and sets the orientation of the text displayed within the stamp annotation.

[Visual Basic]
Public Property TextOrientation As TextOrientation
[C#]
public TextOrientation TextOrientation {get; set;}
[C++]
public: __property TextOrientation get_TextOrientation();
public: __property void set_TextOrientation(
   TextOrientation value
);
[C++/CLI]
public:
property TextOrientation TextOrientation {
   TextOrientation get();
   void set (TextOrientation value);
}

Value

The TextOrientation displayed for the stamp annotation.

See Also

StampToolbarDefaults Class | StampToolbarDefaults Members


StorageStreamException Class

StorageStreamException Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StorageStreamException Class

PegasusImaging.WinForms.NotateXpress9 Namespace : StorageStreamException Class

Exception class which is raised when there are storage errors.

For a list of all members of this type, see StorageStreamException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.NotateXpress9.NotateXpressException
PegasusImaging.WinForms.NotateXpress9.StorageStreamException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class StorageStreamException
   Inherits NotateXpressException
   Implements ISerializable, _Exception
[C#]
[SerializableAttribute()]
public sealed class StorageStreamException : NotateXpressException, ISerializable, _Exception
[C++]
[SerializableAttribute()]
public __gc __sealed class StorageStreamException : public NotateXpressException, ISerializable, _Exception
[C++/CLI]
[SerializableAttribute()]
public ref class StorageStreamException sealed : public NotateXpressException, ISerializable, _Exception

See Also

StorageStreamException Members | PegasusImaging.WinForms.NotateXpress9 Namespace


StorageStreamException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StorageStreamException Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : StorageStreamException Class

StorageStreamException overview

Public Constructors

Public Constructor StorageStreamException Constructor Overloaded. Main constructor for the StorageStreamException class raised when there are storage errors.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

StorageStreamException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


StorageStreamException Constructor

StorageStreamException Class | StorageStreamException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StorageStreamException Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > StorageStreamException Class : StorageStreamException Constructor (StorageStreamException)

Main constructor for the StorageStreamException class raised when there are storage errors.

Overload List

Main constructor for the StorageStreamException class raised when there are storage errors.

[Visual Basic] Public Sub New()

[C#] public StorageStreamException();

[C++] public StorageStreamException();

[C++/CLI] public StorageStreamException();

Exception which allows passing in an error number when there are storage errors.

[Visual Basic] Public Sub New(Integer)

[C#] public StorageStreamException(int);

[C++] public StorageStreamException(int);

[C++/CLI] public StorageStreamException(int);

Exception which allows passing in a message when there are storage errors.

[Visual Basic] Public Sub New(String)

[C#] public StorageStreamException(string);

[C++] public StorageStreamException(string*);

[C++/CLI] public StorageStreamException(String^);

Exception which allows passing in an error number and message when there are storage errors.

[Visual Basic] Public Sub New(Integer,String)

[C#] public StorageStreamException(int,string);

[C++] public StorageStreamException(int,string*);

[C++/CLI] public StorageStreamException(int,String^);

Exception which allows passing in a messag and inner exception when there are storage errors.

[Visual Basic] Public Sub New(String,Exception)

[C#] public StorageStreamException(string,Exception);

[C++] public StorageStreamException(string*,Exception*);

[C++/CLI] public StorageStreamException(String^,Exception^);

See Also

StorageStreamException Class | StorageStreamException Members


StorageStreamException Constructor()

StorageStreamException Class | StorageStreamException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StorageStreamException Constructor()

PegasusImaging.WinForms.NotateXpress9 Namespace > StorageStreamException Class > StorageStreamException Constructor : StorageStreamException Constructor()

Main constructor for the StorageStreamException class raised when there are storage errors.

[Visual Basic]
Public Function New()
[C#]
public StorageStreamException();
[C++]
public: StorageStreamException();
[C++/CLI]
public:
StorageStreamException();

See Also

StorageStreamException Class | StorageStreamException Members | Overload List


StorageStreamException Constructor(Int32)

StorageStreamException Class | StorageStreamException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StorageStreamException Constructor(Int32)

PegasusImaging.WinForms.NotateXpress9 Namespace > StorageStreamException Class > StorageStreamException Constructor : StorageStreamException Constructor(Int32)

Exception which allows passing in an error number when there are storage errors.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public StorageStreamException(
   int errorNumber
);
[C++]
public: StorageStreamException(
   int errorNumber
)
[C++/CLI]
public:
StorageStreamException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

StorageStreamException Class | StorageStreamException Members | Overload List


StorageStreamException Constructor(Int32,String)

StorageStreamException Class | StorageStreamException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StorageStreamException Constructor(Int32,String)

PegasusImaging.WinForms.NotateXpress9 Namespace > StorageStreamException Class > StorageStreamException Constructor : StorageStreamException Constructor(Int32,String)

Exception which allows passing in an error number and message when there are storage errors.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public StorageStreamException(
   int errorNumber,
   string message
);
[C++]
public: StorageStreamException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
StorageStreamException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

StorageStreamException Class | StorageStreamException Members | Overload List


StorageStreamException Constructor(String)

StorageStreamException Class | StorageStreamException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StorageStreamException Constructor(String)

PegasusImaging.WinForms.NotateXpress9 Namespace > StorageStreamException Class > StorageStreamException Constructor : StorageStreamException Constructor(String)

Exception which allows passing in a message when there are storage errors.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public StorageStreamException(
   string message
);
[C++]
public: StorageStreamException(
   string* message
)
[C++/CLI]
public:
StorageStreamException(
   String^ message
)

Parameters

message
A string which represents the message.

See Also

StorageStreamException Class | StorageStreamException Members | Overload List


StorageStreamException Constructor(String,Exception)

StorageStreamException Class | StorageStreamException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StorageStreamException Constructor(String,Exception)

PegasusImaging.WinForms.NotateXpress9 Namespace > StorageStreamException Class > StorageStreamException Constructor : StorageStreamException Constructor(String,Exception)

Exception which allows passing in a messag and inner exception when there are storage errors.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public StorageStreamException(
   string message,
   Exception innerException
);
[C++]
public: StorageStreamException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
StorageStreamException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception.

See Also

StorageStreamException Class | StorageStreamException Members | Overload List


TextEditEndEventArgs Class

TextEditEndEventArgs Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TextEditEndEventArgs Class

PegasusImaging.WinForms.NotateXpress9 Namespace : TextEditEndEventArgs Class

Arguments for TextEditEnd event

For a list of all members of this type, see TextEditEndEventArgs members.

Object Model

Inheritance Hierarchy

System.Object
System.EventArgs
PegasusImaging.WinForms.NotateXpress9.TextEditEndEventArgs

Syntax

[Visual Basic]
Public Class TextEditEndEventArgs
   Inherits EventArgs
[C#]
public class TextEditEndEventArgs : EventArgs
[C++]
public __gc class TextEditEndEventArgs : public EventArgs
[C++/CLI]
public ref class TextEditEndEventArgs : public EventArgs

See Also

TextEditEndEventArgs Members | PegasusImaging.WinForms.NotateXpress9 Namespace


TextEditEndEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TextEditEndEventArgs Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : TextEditEndEventArgs Class

TextEditEndEventArgs overview

Public Constructors

Public Constructor TextEditEndEventArgs Constructor

Public Properties

Public Property Element | Gets the element that is being edited.
Public Property Layer | Gets the layer on which the text element resides.

See Also

TextEditEndEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace


TextEditEndEventArgs Constructor

TextEditEndEventArgs Class | TextEditEndEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TextEditEndEventArgs Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > TextEditEndEventArgs Class : TextEditEndEventArgs Constructor (TextEditEndEventArgs)
[Visual Basic]
Public Function New()
[C#]
public TextEditEndEventArgs();
[C++]
public: TextEditEndEventArgs();
[C++/CLI]
public:
TextEditEndEventArgs();

See Also

TextEditEndEventArgs Class | TextEditEndEventArgs Members


TextEditEndEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TextEditEndEventArgs Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : TextEditEndEventArgs Class

For a list of all members of this type, see TextEditEndEventArgs members.

Public Properties

Public Property Element | Gets the element that is being edited.
Public Property Layer | Gets the layer on which the text element resides.

See Also

TextEditEndEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Element Property

TextEditEndEventArgs Class | TextEditEndEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Element Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TextEditEndEventArgs Class : Element Property (TextEditEndEventArgs)

Gets the element that is being edited.

[Visual Basic]
Public Property Element As Element
[C#]
public Element Element {get; set;}
[C++]
public: __property Element* get_Element();
public: __property void set_Element(
   Element* value
);
[C++/CLI]
public:
property Element^ Element {
   Element^ get();
   void set (Element^ value);
}

See Also

TextEditEndEventArgs Class | TextEditEndEventArgs Members


Layer Property

TextEditEndEventArgs Class | TextEditEndEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Layer Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TextEditEndEventArgs Class : Layer Property (TextEditEndEventArgs)

Gets the layer on which the text element resides.

[Visual Basic]
Public Property Layer As Layer
[C#]
public Layer Layer {get; set;}
[C++]
public: __property Layer* get_Layer();
public: __property void set_Layer(
   Layer* value
);
[C++/CLI]
public:
property Layer^ Layer {
   Layer^ get();
   void set (Layer^ value);
}

See Also

TextEditEndEventArgs Class | TextEditEndEventArgs Members


TextEditStartEventArgs Class

TextEditStartEventArgs Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TextEditStartEventArgs Class

PegasusImaging.WinForms.NotateXpress9 Namespace : TextEditStartEventArgs Class

Arguments for TextEditStart event

For a list of all members of this type, see TextEditStartEventArgs members.

Object Model

Inheritance Hierarchy

System.Object
System.EventArgs
PegasusImaging.WinForms.NotateXpress9.TextEditStartEventArgs

Syntax

[Visual Basic]
Public Class TextEditStartEventArgs
   Inherits EventArgs
[C#]
public class TextEditStartEventArgs : EventArgs
[C++]
public __gc class TextEditStartEventArgs : public EventArgs
[C++/CLI]
public ref class TextEditStartEventArgs : public EventArgs

See Also

TextEditStartEventArgs Members | PegasusImaging.WinForms.NotateXpress9 Namespace


TextEditStartEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TextEditStartEventArgs Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : TextEditStartEventArgs Class

TextEditStartEventArgs overview

Public Constructors

Public Constructor TextEditStartEventArgs Constructor

Public Properties

Public Property Element | Gets the element that is being edited.
Public Property Layer | Gets the layer on which the text element resides.

See Also

TextEditStartEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace


TextEditStartEventArgs Constructor

TextEditStartEventArgs Class | TextEditStartEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TextEditStartEventArgs Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > TextEditStartEventArgs Class : TextEditStartEventArgs Constructor (TextEditStartEventArgs)
[Visual Basic]
Public Function New()
[C#]
public TextEditStartEventArgs();
[C++]
public: TextEditStartEventArgs();
[C++/CLI]
public:
TextEditStartEventArgs();

See Also

TextEditStartEventArgs Class | TextEditStartEventArgs Members


TextEditStartEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TextEditStartEventArgs Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : TextEditStartEventArgs Class

For a list of all members of this type, see TextEditStartEventArgs members.

Public Properties

Public Property Element | Gets the element that is being edited.
Public Property Layer | Gets the layer on which the text element resides.

See Also

TextEditStartEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Element Property

TextEditStartEventArgs Class | TextEditStartEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Element Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TextEditStartEventArgs Class : Element Property (TextEditStartEventArgs)

Gets the element that is being edited.

[Visual Basic]
Public Property Element As Element
[C#]
public Element Element {get; set;}
[C++]
public: __property Element* get_Element();
public: __property void set_Element(
   Element* value
);
[C++/CLI]
public:
property Element^ Element {
   Element^ get();
   void set (Element^ value);
}

See Also

TextEditStartEventArgs Class | TextEditStartEventArgs Members


Layer Property

TextEditStartEventArgs Class | TextEditStartEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Layer Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TextEditStartEventArgs Class : Layer Property (TextEditStartEventArgs)

Gets the layer on which the text element resides.

[Visual Basic]
Public Property Layer As Layer
[C#]
public Layer Layer {get; set;}
[C++]
public: __property Layer* get_Layer();
public: __property void set_Layer(
   Layer* value
);
[C++/CLI]
public:
property Layer^ Layer {
   Layer^ get();
   void set (Layer^ value);
}

See Also

TextEditStartEventArgs Class | TextEditStartEventArgs Members


TextTool Class

TextTool Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TextTool Class

PegasusImaging.WinForms.NotateXpress9 Namespace : TextTool Class

The TextTool is used to create text annotations, which display text with an optional background and border.

For a list of all members of this type, see TextTool members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.NotateXpress9.Element
PegasusImaging.WinForms.NotateXpress9.TextTool

Syntax

[Visual Basic]
Public Class TextTool
   Inherits Element
   Implements IDisposable
[C#]
public class TextTool : Element, IDisposable
[C++]
public __gc class TextTool : public Element, IDisposable
[C++/CLI]
public ref class TextTool : public Element, IDisposable

See Also

TextTool Members | PegasusImaging.WinForms.NotateXpress9 Namespace


TextTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TextTool Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : TextTool Class

TextTool overview

Public Constructors

Public Constructor TextTool Constructor Default constructor for the TextTool class.

Public Properties

Public Property AutoSize | Gets and sets whether or not the annotation size will be automatically expanded (or shrunk) to fit the given text within the stamp annotation.
Public Property BackColor | This property sets or returns the color of the backgroud used within the text annotation.
Public Property BackStyle | This property sets or returns the style of the background used within the text annotation.
Public Property BoundingRectangle (Inherited from Element) | Gets and sets the rectangle boundary for the element.
Public Property CreateTime (Inherited from Element) | A Read only property that gets the time when the element was created.
Public Property Fixed (Inherited from Element) | Gets and sets whether an annotation has a fixed position with respect to the control window.
Public Property GroupMember (Inherited from Element) | Gets the group which the element belongs to.
Public Property HatchColor | This property sets or returns the color of the hatch style used within the text annotation.
Public Property HatchStyle | This property sets or returns the hatch style used within the text annotation.
Public Property HighlightBack | This property sets or returns whether or not the background of the text annotation will be translucent.
Public Property IsGroupMember (Inherited from Element) | A read only property that gets a value which determines if the element is a member of a group or not.
Public Property Locked (Inherited from Element) | Gets and sets an indicator whether an annotation element can be selected or moved by a user in Edit mode.
Public Property Moveable (Inherited from Element) | Gets and sets whether the element can be moved by a user in Edit mode.
Public Property NumberPoints (Inherited from Element) | A Read only property that gets the number of points currently used to define the element.
Public Property PenColor | This property sets or returns the color of the pen used to draw the border around the text annotation .
Public Property PenWidth | This property sets or returns the width of the pen used to draw the text annotation.
Public Property Selected (Inherited from Element) | Gets and sets whether the element has been selected.
Public Property ShowHandles (Inherited from Element) | Gets and sets whether selection handles are displayed on an object when it is selected.
Public Property Sizeable (Inherited from Element) | Gets and sets whether the element can be resized.
Public Property Text | This property sets or returns the string value used within the text annotation.
Public Property TextColor | This property sets or returns the color of the text used within the text annotation.
Public Property TextFont | This property sets or returns the font of the text used within the text annotation.
Public Property TextJustification | This property sets or returns how the text within the text annotation is justified.
Public Property TextLocked | This property sets or returns whether or not the text within the annotation will be editable.
Public Property TextOrientation | This property sets or returns the orientation of the text displayed within the text annotation.
Public Property TMSNote | This property sets or returns whether or not the the annotation will be treated on saving as a Note or text.
Public Property ToolTipText (Inherited from Element) | Gets and sets a string value in the element that will become the ToolTipText value associated with the element.
Public Property UserLong (Inherited from Element) | Gets and sets a user defined long value associated with the element.
Public Property UserString (Inherited from Element) | Gets and sets a user-defined string associated with the element.
Public Property Visible (Inherited from Element) | Gets and sets whether the element is visible.
Public Property WangType | This property sets or returns if specific Eastman/Wang compatible attributes are applied to a text annotation.

Public Methods

Public Method Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public Method NudgeDown (Inherited from Element) | Moves the specified annotation object one level down, towards the back, in the painting order of the specified layer.
Public Method NudgeUp (Inherited from Element) | Moves the specified annotation object one level up, towards the front, in the painting order of the specified layer.
Public Method UserDataAdd (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataDelete (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFind (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFindFirst (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFindNext (Inherited from Element) | User data can be added to each element in a key value pair.

See Also

TextTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace


TextTool Constructor

TextTool Class | TextTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TextTool Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > TextTool Class : TextTool Constructor (TextTool)

Default constructor for the TextTool class.

[Visual Basic]
Public Function New()
[C#]
public TextTool();
[C++]
public: TextTool();
[C++/CLI]
public:
TextTool();

See Also

TextTool Class | TextTool Members


Dispose Method

TextTool Class | TextTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Dispose Method

PegasusImaging.WinForms.NotateXpress9 Namespace > TextTool Class : Dispose Method (TextTool)

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();
[C++]
public: void Dispose();
[C++/CLI]
public:
void Dispose();

See Also

TextTool Class | TextTool Members


TextTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TextTool Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : TextTool Class

For a list of all members of this type, see TextTool members.

Public Properties

Public Property AutoSize | Gets and sets whether or not the annotation size will be automatically expanded (or shrunk) to fit the given text within the stamp annotation.
Public Property BackColor | This property sets or returns the color of the backgroud used within the text annotation.
Public Property BackStyle | This property sets or returns the style of the background used within the text annotation.
Public Property BoundingRectangle (Inherited from Element) | Gets and sets the rectangle boundary for the element.
Public Property CreateTime (Inherited from Element) | A Read only property that gets the time when the element was created.
Public Property Fixed (Inherited from Element) | Gets and sets whether an annotation has a fixed position with respect to the control window.
Public Property GroupMember (Inherited from Element) | Gets the group which the element belongs to.
Public Property HatchColor | This property sets or returns the color of the hatch style used within the text annotation.
Public Property HatchStyle | This property sets or returns the hatch style used within the text annotation.
Public Property HighlightBack | This property sets or returns whether or not the background of the text annotation will be translucent.
Public Property IsGroupMember (Inherited from Element) | A read only property that gets a value which determines if the element is a member of a group or not.
Public Property Locked (Inherited from Element) | Gets and sets an indicator whether an annotation element can be selected or moved by a user in Edit mode.
Public Property Moveable (Inherited from Element) | Gets and sets whether the element can be moved by a user in Edit mode.
Public Property NumberPoints (Inherited from Element) | A Read only property that gets the number of points currently used to define the element.
Public Property PenColor | This property sets or returns the color of the pen used to draw the border around the text annotation .
Public Property PenWidth | This property sets or returns the width of the pen used to draw the text annotation.
Public Property Selected (Inherited from Element) | Gets and sets whether the element has been selected.
Public Property ShowHandles (Inherited from Element) | Gets and sets whether selection handles are displayed on an object when it is selected.
Public Property Sizeable (Inherited from Element) | Gets and sets whether the element can be resized.
Public Property Text | This property sets or returns the string value used within the text annotation.
Public Property TextColor | This property sets or returns the color of the text used within the text annotation.
Public Property TextFont | This property sets or returns the font of the text used within the text annotation.
Public Property TextJustification | This property sets or returns how the text within the text annotation is justified.
Public Property TextLocked | This property sets or returns whether or not the text within the annotation will be editable.
Public Property TextOrientation | This property sets or returns the orientation of the text displayed within the text annotation.
Public Property TMSNote | This property sets or returns whether or not the the annotation will be treated on saving as a Note or text.
Public Property ToolTipText (Inherited from Element) | Gets and sets a string value in the element that will become the ToolTipText value associated with the element.
Public Property UserLong (Inherited from Element) | Gets and sets a user defined long value associated with the element.
Public Property UserString (Inherited from Element) | Gets and sets a user-defined string associated with the element.
Public Property Visible (Inherited from Element) | Gets and sets whether the element is visible.
Public Property WangType | This property sets or returns if specific Eastman/Wang compatible attributes are applied to a text annotation.

See Also

TextTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace


AutoSize Property

TextTool Class | TextTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

AutoSize Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TextTool Class : AutoSize Property (TextTool)

Gets and sets whether or not the annotation size will be automatically expanded (or shrunk) to fit the given text within the stamp annotation.

[Visual Basic]
Public Property AutoSize As AutoSize
[C#]
public AutoSize AutoSize {get; set;}
[C++]
public: __property AutoSize get_AutoSize();
public: __property void set_AutoSize(
   AutoSize value
);
[C++/CLI]
public:
property AutoSize AutoSize {
   AutoSize get();
   void set (AutoSize value);
}

Value

The type of sizing to do.

Remarks

The default value is false

See Also

TextTool Class | TextTool Members


BackColor Property

TextTool Class | TextTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BackColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TextTool Class : BackColor Property (TextTool)

This property sets or returns the color of the backgroud used within the text annotation.

[Visual Basic]
Public Property BackColor As Color
[C#]
public Color BackColor {get; set;}
[C++]
public: __property Color get_BackColor();
public: __property void set_BackColor(
   Color value
);
[C++/CLI]
public:
property Color BackColor {
   Color get();
   void set (Color value);
}

Value

The color of the background.

See Also

TextTool Class | TextTool Members


BackStyle Property

TextTool Class | TextTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BackStyle Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TextTool Class : BackStyle Property (TextTool)

This property sets or returns the style of the background used within the text annotation.

[Visual Basic]
Public Property BackStyle As BackStyle
[C#]
public BackStyle BackStyle {get; set;}
[C++]
public: __property BackStyle get_BackStyle();
public: __property void set_BackStyle(
   BackStyle value
);
[C++/CLI]
public:
property BackStyle BackStyle {
   BackStyle get();
   void set (BackStyle value);
}

Value

The background style.

See Also

TextTool Class | TextTool Members


HatchColor Property

TextTool Class | TextTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HatchColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TextTool Class : HatchColor Property (TextTool)

This property sets or returns the color of the hatch style used within the text annotation.

[Visual Basic]
Public Property HatchColor As Color
[C#]
public Color HatchColor {get; set;}
[C++]
public: __property Color get_HatchColor();
public: __property void set_HatchColor(
   Color value
);
[C++/CLI]
public:
property Color HatchColor {
   Color get();
   void set (Color value);
}

Value

The color of the hatch.

Remarks

The HatchColor is the color of the hatch strokes on a filled object whose HatchStyle attribute is something other than HatchStyle_None.

See Also

TextTool Class | TextTool Members


HatchStyle Property

TextTool Class | TextTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HatchStyle Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TextTool Class : HatchStyle Property (TextTool)

This property sets or returns the hatch style used within the text annotation.

[Visual Basic]
Public Property HatchStyle As HatchStyle
[C#]
public HatchStyle HatchStyle {get; set;}
[C++]
public: __property HatchStyle get_HatchStyle();
public: __property void set_HatchStyle(
   HatchStyle value
);
[C++/CLI]
public:
property HatchStyle HatchStyle {
   HatchStyle get();
   void set (HatchStyle value);
}

Value

The hatch style.

See Also

TextTool Class | TextTool Members


HighlightBack Property

TextTool Class | TextTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HighlightBack Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TextTool Class : HighlightBack Property (TextTool)

This property sets or returns whether or not the background of the text annotation will be translucent.

[Visual Basic]
Public Property HighlightBack As Boolean
[C#]
public bool HighlightBack {get; set;}
[C++]
public: __property bool get_HighlightBack();
public: __property void set_HighlightBack(
   bool value
);
[C++/CLI]
public:
property bool HighlightBack {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true to make the background translucent. Otherwise, false is used and the background is not translucent.

See Also

TextTool Class | TextTool Members


PenColor Property

TextTool Class | TextTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PenColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TextTool Class : PenColor Property (TextTool)

This property sets or returns the color of the pen used to draw the border around the text annotation .

[Visual Basic]
Public Property PenColor As Color
[C#]
public Color PenColor {get; set;}
[C++]
public: __property Color get_PenColor();
public: __property void set_PenColor(
   Color value
);
[C++/CLI]
public:
property Color PenColor {
   Color get();
   void set (Color value);
}

Value

The color of the pen.

See Also

TextTool Class | TextTool Members


PenWidth Property

TextTool Class | TextTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PenWidth Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TextTool Class : PenWidth Property (TextTool)

This property sets or returns the width of the pen used to draw the text annotation.

[Visual Basic]
Public Property PenWidth As Integer
[C#]
public int PenWidth {get; set;}
[C++]
public: __property int get_PenWidth();
public: __property void set_PenWidth(
   int value
);
[C++/CLI]
public:
property int PenWidth {
   int get();
   void set (int value);
}

Value

An integer value which represents the width of the pen.

See Also

TextTool Class | TextTool Members


Text Property

TextTool Class | TextTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Text Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TextTool Class : Text Property (TextTool)

This property sets or returns the string value used within the text annotation.

[Visual Basic]
Public Property Text As String
[C#]
public string Text {get; set;}
[C++]
public: __property string* get_Text();
public: __property void set_Text(
   string* value
);
[C++/CLI]
public:
property String^ Text {
   String^ get();
   void set (String^ value);
}

Value

A string value which represents the text for the annotation.

See Also

TextTool Class | TextTool Members


TextColor Property

TextTool Class | TextTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TextColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TextTool Class : TextColor Property (TextTool)

This property sets or returns the color of the text used within the text annotation.

[Visual Basic]
Public Property TextColor As Color
[C#]
public Color TextColor {get; set;}
[C++]
public: __property Color get_TextColor();
public: __property void set_TextColor(
   Color value
);
[C++/CLI]
public:
property Color TextColor {
   Color get();
   void set (Color value);
}

Value

The color of the text.

See Also

TextTool Class | TextTool Members


TextFont Property

TextTool Class | TextTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TextFont Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TextTool Class : TextFont Property (TextTool)

This property sets or returns the font of the text used within the text annotation.

[Visual Basic]
Public Property TextFont As Font
[C#]
public Font TextFont {get; set;}
[C++]
public: __property Font* get_TextFont();
public: __property void set_TextFont(
   Font* value
);
[C++/CLI]
public:
property Font^ TextFont {
   Font^ get();
   void set (Font^ value);
}

Value

The Font for the text annotation.

See Also

TextTool Class | TextTool Members


TextJustification Property

TextTool Class | TextTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TextJustification Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TextTool Class : TextJustification Property (TextTool)

This property sets or returns how the text within the text annotation is justified.

[Visual Basic]
Public Property TextJustification As TextJustification
[C#]
public TextJustification TextJustification {get; set;}
[C++]
public: __property TextJustification get_TextJustification();
public: __property void set_TextJustification(
   TextJustification value
);
[C++/CLI]
public:
property TextJustification TextJustification {
   TextJustification get();
   void set (TextJustification value);
}

Value

The TextJustification.

See Also

TextTool Class | TextTool Members


TextLocked Property

TextTool Class | TextTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TextLocked Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TextTool Class : TextLocked Property (TextTool)

This property sets or returns whether or not the text within the annotation will be editable.

[Visual Basic]
Public Property TextLocked As Boolean
[C#]
public bool TextLocked {get; set;}
[C++]
public: __property bool get_TextLocked();
public: __property void set_TextLocked(
   bool value
);
[C++/CLI]
public:
property bool TextLocked {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true to make the text within the annotation editable. Otherwise, false is used and the annotation is not editable.

See Also

TextTool Class | TextTool Members


TextOrientation Property

TextTool Class | TextTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TextOrientation Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TextTool Class : TextOrientation Property (TextTool)

This property sets or returns the orientation of the text displayed within the text annotation.

[Visual Basic]
Public Property TextOrientation As TextOrientation
[C#]
public TextOrientation TextOrientation {get; set;}
[C++]
public: __property TextOrientation get_TextOrientation();
public: __property void set_TextOrientation(
   TextOrientation value
);
[C++/CLI]
public:
property TextOrientation TextOrientation {
   TextOrientation get();
   void set (TextOrientation value);
}

Value

The TextOrientation used for the text annotation.

See Also

TextTool Class | TextTool Members


TMSNote Property

TextTool Class | TextTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TMSNote Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TextTool Class : TMSNote Property (TextTool)

This property sets or returns whether or not the the annotation will be treated on saving as a Note or text.

[Visual Basic]
Public Property TMSNote As Boolean
[C#]
public bool TMSNote {get; set;}
[C++]
public: __property bool get_TMSNote();
public: __property void set_TMSNote(
   bool value
);
[C++/CLI]
public:
property bool TMSNote {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true to save as a TMSNote. Otherwise, false is used and the annotation is not saved as a TMSNote.

Remarks

This only effects the Legacy TMS file format.

See Also

TextTool Class | TextTool Members


WangType Property

TextTool Class | TextTool Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

WangType Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TextTool Class : WangType Property (TextTool)

This property sets or returns if specific Eastman/Wang compatible attributes are applied to a text annotation.

[Visual Basic]
Public Property WangType As WangType
[C#]
public WangType WangType {get; set;}
[C++]
public: __property WangType get_WangType();
public: __property void set_WangType(
   WangType value
);
[C++/CLI]
public:
property WangType WangType {
   WangType get();
   void set (WangType value);
}

Value

The WangType which determines how the annotation is processed into an Eastman/Wang image.

See Also

TextTool Class | TextTool Members


TextToolbarDefaults Class

TextToolbarDefaults Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TextToolbarDefaults Class

PegasusImaging.WinForms.NotateXpress9 Namespace : TextToolbarDefaults Class (PegasusImaging.WinForms.NotateXpress9)

The TextTool is used to create Text annotations.

For a list of all members of this type, see TextToolbarDefaults members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.NotateXpress9.BaseToolbarDefaults
PegasusImaging.WinForms.NotateXpress9.TextToolbarDefaults

Syntax

[Visual Basic]
Public Class TextToolbarDefaults
   Inherits BaseToolbarDefaults
[C#]
public class TextToolbarDefaults : BaseToolbarDefaults
[C++]
public __gc class TextToolbarDefaults : public BaseToolbarDefaults
[C++/CLI]
public ref class TextToolbarDefaults : public BaseToolbarDefaults

See Also

TextToolbarDefaults Members | PegasusImaging.WinForms.NotateXpress9 Namespace


TextToolbarDefaults Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TextToolbarDefaults Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : TextToolbarDefaults Class (PegasusImaging.WinForms.NotateXpress9)

TextToolbarDefaults overview

Public Constructors

Public Constructor TextToolbarDefaults Constructor Default constructor for the TextToolbarDefaults class.

Public Properties

Public Property AutoSize | Gets and sets whether or not the annotation size will be automatically expanded (or shrunk) to fit the given text within the stamp annotation.
Public Property BackColor | This property sets or returns the color of the backgroud used within the Text annotation.
Public Property BackStyle | This property sets or returns the style of the background used within the Text annotation.
Public Property Fixed (Inherited from BaseToolbarDefaults) | Gets and sets whether an element is tied to the view instead of the image.
Public Property HatchColor | This property sets or returns the color of the hatch style used within the Text annotation.
Public Property HatchStyle | This property sets or returns the hatch style used within the Text annotation.
Public Property HighlightBack | This property sets or returns whether or not the background of the Text annotation will be translucent.
Public Property Locked (Inherited from BaseToolbarDefaults) | Gets and sets an indicator to lock an element so it cannot be selected or moved by a user in Edit mode.
Public Property Moveable (Inherited from BaseToolbarDefaults) | Gets and sets whether an element can be moved interactively during EditMode.
Public Property PenColor | This property sets or returns the color of the pen used to draw the border around the Text annotation .
Public Property PenWidth | This property sets or returns the width of the pen used to draw the Text annotation.
Public Property Selected (Inherited from BaseToolbarDefaults) | Gets and sets whether an element is automatically selected.
Public Property ShowHandles (Inherited from BaseToolbarDefaults) | Gets and sets whether selection handles are displayed for an element.
Public Property Sizeable (Inherited from BaseToolbarDefaults) | Gets and sets whether an element can be sized interactively during EditMode.
Public Property Text | This property sets or returns the string value used within the Text annotation.
Public Property TextColor | This property sets or returns the color of the text used within the Text annotation.
Public Property TextFont | This property sets or returns the font of the text used within the Text annotation.
Public Property TextJustification | This property sets or returns how the text within the text annotation is justified.
Public Property TextLocked | Gets or sets a value indicating whether the text is editable.
Public Property TextOrientation | This property sets or returns the orientation of the text displayed within the Text annotation.
Public Property TMSNote | This property sets or returns whether or not the annotation will be saved as a Note or Text.
Public Property ToolTipText (Inherited from BaseToolbarDefaults) | Gets or sets a string value in the element that will become the ToolTipText value associated with the annotation once it is created.
Public Property UserLong (Inherited from BaseToolbarDefaults) | Gets and sets a long value in the element that will become the UserLong value associated with the element once it is created.
Public Property UserString (Inherited from BaseToolbarDefaults) | Gets and sets a string value in the element that will become the UserString value associated with the object once it is created.
Public Property Visible (Inherited from BaseToolbarDefaults) | Gets and sets the Visible attribute of an element.
Public Property WangType | This property sets or returns if specific Eastman/Wang compatible attributes are applied to a text annotation.

See Also

TextToolbarDefaults Class | PegasusImaging.WinForms.NotateXpress9 Namespace


TextToolbarDefaults Constructor

TextToolbarDefaults Class | TextToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TextToolbarDefaults Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > TextToolbarDefaults Class : TextToolbarDefaults Constructor (TextToolbarDefaults)

Default constructor for the TextToolbarDefaults class.

[Visual Basic]
Public Function New()
[C#]
public TextToolbarDefaults();
[C++]
public: TextToolbarDefaults();
[C++/CLI]
public:
TextToolbarDefaults();

See Also

TextToolbarDefaults Class | TextToolbarDefaults Members


TextToolbarDefaults Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TextToolbarDefaults Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : TextToolbarDefaults Class (PegasusImaging.WinForms.NotateXpress9)

For a list of all members of this type, see TextToolbarDefaults members.

Public Properties

Public Property AutoSize | Gets and sets whether or not the annotation size will be automatically expanded (or shrunk) to fit the given text within the stamp annotation.
Public Property BackColor | This property sets or returns the color of the backgroud used within the Text annotation.
Public Property BackStyle | This property sets or returns the style of the background used within the Text annotation.
Public Property Fixed (Inherited from BaseToolbarDefaults) | Gets and sets whether an element is tied to the view instead of the image.
Public Property HatchColor | This property sets or returns the color of the hatch style used within the Text annotation.
Public Property HatchStyle | This property sets or returns the hatch style used within the Text annotation.
Public Property HighlightBack | This property sets or returns whether or not the background of the Text annotation will be translucent.
Public Property Locked (Inherited from BaseToolbarDefaults) | Gets and sets an indicator to lock an element so it cannot be selected or moved by a user in Edit mode.
Public Property Moveable (Inherited from BaseToolbarDefaults) | Gets and sets whether an element can be moved interactively during EditMode.
Public Property PenColor | This property sets or returns the color of the pen used to draw the border around the Text annotation .
Public Property PenWidth | This property sets or returns the width of the pen used to draw the Text annotation.
Public Property Selected (Inherited from BaseToolbarDefaults) | Gets and sets whether an element is automatically selected.
Public Property ShowHandles (Inherited from BaseToolbarDefaults) | Gets and sets whether selection handles are displayed for an element.
Public Property Sizeable (Inherited from BaseToolbarDefaults) | Gets and sets whether an element can be sized interactively during EditMode.
Public Property Text | This property sets or returns the string value used within the Text annotation.
Public Property TextColor | This property sets or returns the color of the text used within the Text annotation.
Public Property TextFont | This property sets or returns the font of the text used within the Text annotation.
Public Property TextJustification | This property sets or returns how the text within the text annotation is justified.
Public Property TextLocked | Gets or sets a value indicating whether the text is editable.
Public Property TextOrientation | This property sets or returns the orientation of the text displayed within the Text annotation.
Public Property TMSNote | This property sets or returns whether or not the annotation will be saved as a Note or Text.
Public Property ToolTipText (Inherited from BaseToolbarDefaults) | Gets or sets a string value in the element that will become the ToolTipText value associated with the annotation once it is created.
Public Property UserLong (Inherited from BaseToolbarDefaults) | Gets and sets a long value in the element that will become the UserLong value associated with the element once it is created.
Public Property UserString (Inherited from BaseToolbarDefaults) | Gets and sets a string value in the element that will become the UserString value associated with the object once it is created.
Public Property Visible (Inherited from BaseToolbarDefaults) | Gets and sets the Visible attribute of an element.
Public Property WangType | This property sets or returns if specific Eastman/Wang compatible attributes are applied to a text annotation.

See Also

TextToolbarDefaults Class | PegasusImaging.WinForms.NotateXpress9 Namespace


AutoSize Property

TextToolbarDefaults Class | TextToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

AutoSize Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TextToolbarDefaults Class : AutoSize Property (TextToolbarDefaults)

Gets and sets whether or not the annotation size will be automatically expanded (or shrunk) to fit the given text within the stamp annotation.

[Visual Basic]
Public Property AutoSize As AutoSize
[C#]
public AutoSize AutoSize {get; set;}
[C++]
public: __property AutoSize get_AutoSize();
public: __property void set_AutoSize(
   AutoSize value
);
[C++/CLI]
public:
property AutoSize AutoSize {
   AutoSize get();
   void set (AutoSize value);
}

Value

The type of sizing to do.

Remarks

The default value is false

.

See Also

TextToolbarDefaults Class | TextToolbarDefaults Members


BackColor Property

TextToolbarDefaults Class | TextToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BackColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TextToolbarDefaults Class : BackColor Property (TextToolbarDefaults)

This property sets or returns the color of the backgroud used within the Text annotation.

[Visual Basic]
Public Property BackColor As Color
[C#]
public Color BackColor {get; set;}
[C++]
public: __property Color get_BackColor();
public: __property void set_BackColor(
   Color value
);
[C++/CLI]
public:
property Color BackColor {
   Color get();
   void set (Color value);
}

Value

The color of the background.

See Also

TextToolbarDefaults Class | TextToolbarDefaults Members


BackStyle Property

TextToolbarDefaults Class | TextToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BackStyle Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TextToolbarDefaults Class : BackStyle Property (TextToolbarDefaults)

This property sets or returns the style of the background used within the Text annotation.

[Visual Basic]
Public Property BackStyle As BackStyle
[C#]
public BackStyle BackStyle {get; set;}
[C++]
public: __property BackStyle get_BackStyle();
public: __property void set_BackStyle(
   BackStyle value
);
[C++/CLI]
public:
property BackStyle BackStyle {
   BackStyle get();
   void set (BackStyle value);
}

Value

The background style.

See Also

TextToolbarDefaults Class | TextToolbarDefaults Members


HatchColor Property

TextToolbarDefaults Class | TextToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HatchColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TextToolbarDefaults Class : HatchColor Property (TextToolbarDefaults)

This property sets or returns the color of the hatch style used within the Text annotation.

[Visual Basic]
Public Property HatchColor As Color
[C#]
public Color HatchColor {get; set;}
[C++]
public: __property Color get_HatchColor();
public: __property void set_HatchColor(
   Color value
);
[C++/CLI]
public:
property Color HatchColor {
   Color get();
   void set (Color value);
}

Value

The color of the hatch.

Remarks

The HatchColor is the color of the hatch strokes on a filled object whose HatchStyle attribute is something other than HatchStyle_None.

See Also

TextToolbarDefaults Class | TextToolbarDefaults Members


HatchStyle Property

TextToolbarDefaults Class | TextToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HatchStyle Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TextToolbarDefaults Class : HatchStyle Property (TextToolbarDefaults)

This property sets or returns the hatch style used within the Text annotation.

[Visual Basic]
Public Property HatchStyle As HatchStyle
[C#]
public HatchStyle HatchStyle {get; set;}
[C++]
public: __property HatchStyle get_HatchStyle();
public: __property void set_HatchStyle(
   HatchStyle value
);
[C++/CLI]
public:
property HatchStyle HatchStyle {
   HatchStyle get();
   void set (HatchStyle value);
}

Value

The HatchStyle used for the text annotation.

See Also

TextToolbarDefaults Class | TextToolbarDefaults Members


HighlightBack Property

TextToolbarDefaults Class | TextToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HighlightBack Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TextToolbarDefaults Class : HighlightBack Property (TextToolbarDefaults)

This property sets or returns whether or not the background of the Text annotation will be translucent.

[Visual Basic]
Public Property HighlightBack As Boolean
[C#]
public bool HighlightBack {get; set;}
[C++]
public: __property bool get_HighlightBack();
public: __property void set_HighlightBack(
   bool value
);
[C++/CLI]
public:
property bool HighlightBack {
   bool get();
   void set (bool value);
}

Value

true if HighlightBack otherwise, false.

See Also

TextToolbarDefaults Class | TextToolbarDefaults Members


PenColor Property

TextToolbarDefaults Class | TextToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PenColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TextToolbarDefaults Class : PenColor Property (TextToolbarDefaults)

This property sets or returns the color of the pen used to draw the border around the Text annotation .

[Visual Basic]
Public Property PenColor As Color
[C#]
public Color PenColor {get; set;}
[C++]
public: __property Color get_PenColor();
public: __property void set_PenColor(
   Color value
);
[C++/CLI]
public:
property Color PenColor {
   Color get();
   void set (Color value);
}

Value

The color of the pen.

See Also

TextToolbarDefaults Class | TextToolbarDefaults Members


PenWidth Property

TextToolbarDefaults Class | TextToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PenWidth Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TextToolbarDefaults Class : PenWidth Property (TextToolbarDefaults)

This property sets or returns the width of the pen used to draw the Text annotation.

[Visual Basic]
Public Property PenWidth As Integer
[C#]
public int PenWidth {get; set;}
[C++]
public: __property int get_PenWidth();
public: __property void set_PenWidth(
   int value
);
[C++/CLI]
public:
property int PenWidth {
   int get();
   void set (int value);
}

Value

An integer value which represents the width of the pen.

See Also

TextToolbarDefaults Class | TextToolbarDefaults Members


Text Property

TextToolbarDefaults Class | TextToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Text Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TextToolbarDefaults Class : Text Property (TextToolbarDefaults)

This property sets or returns the string value used within the Text annotation.

[Visual Basic]
Public Property Text As String
[C#]
public string Text {get; set;}
[C++]
public: __property string* get_Text();
public: __property void set_Text(
   string* value
);
[C++/CLI]
public:
property String^ Text {
   String^ get();
   void set (String^ value);
}

Value

A string value which represents the text for the annotation.

See Also

TextToolbarDefaults Class | TextToolbarDefaults Members


TextColor Property

TextToolbarDefaults Class | TextToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TextColor Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TextToolbarDefaults Class : TextColor Property (TextToolbarDefaults)

This property sets or returns the color of the text used within the Text annotation.

[Visual Basic]
Public Property TextColor As Color
[C#]
public Color TextColor {get; set;}
[C++]
public: __property Color get_TextColor();
public: __property void set_TextColor(
   Color value
);
[C++/CLI]
public:
property Color TextColor {
   Color get();
   void set (Color value);
}

Value

The color of the text.

See Also

TextToolbarDefaults Class | TextToolbarDefaults Members


TextFont Property

TextToolbarDefaults Class | TextToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TextFont Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TextToolbarDefaults Class : TextFont Property (TextToolbarDefaults)

This property sets or returns the font of the text used within the Text annotation.

[Visual Basic]
Public Property TextFont As Font
[C#]
public Font TextFont {get; set;}
[C++]
public: __property Font* get_TextFont();
public: __property void set_TextFont(
   Font* value
);
[C++/CLI]
public:
property Font^ TextFont {
   Font^ get();
   void set (Font^ value);
}

Value

The text font.

See Also

TextToolbarDefaults Class | TextToolbarDefaults Members


TextJustification Property

TextToolbarDefaults Class | TextToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TextJustification Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TextToolbarDefaults Class : TextJustification Property (TextToolbarDefaults)

This property sets or returns how the text within the text annotation is justified.

[Visual Basic]
Public Property TextJustification As TextJustification
[C#]
public TextJustification TextJustification {get; set;}
[C++]
public: __property TextJustification get_TextJustification();
public: __property void set_TextJustification(
   TextJustification value
);
[C++/CLI]
public:
property TextJustification TextJustification {
   TextJustification get();
   void set (TextJustification value);
}

Value

The TextJustification.

See Also

TextToolbarDefaults Class | TextToolbarDefaults Members


TextLocked Property

TextToolbarDefaults Class | TextToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TextLocked Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TextToolbarDefaults Class : TextLocked Property (TextToolbarDefaults)

Gets or sets a value indicating whether the text is editable.

[Visual Basic]
Public Property TextLocked As Boolean
[C#]
public bool TextLocked {get; set;}
[C++]
public: __property bool get_TextLocked();
public: __property void set_TextLocked(
   bool value
);
[C++/CLI]
public:
property bool TextLocked {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true if the text is editable. Otherwise, false is used and the text is not editable.

Remarks

The default value is false.

See Also

TextToolbarDefaults Class | TextToolbarDefaults Members


TextOrientation Property

TextToolbarDefaults Class | TextToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TextOrientation Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TextToolbarDefaults Class : TextOrientation Property (TextToolbarDefaults)

This property sets or returns the orientation of the text displayed within the Text annotation.

[Visual Basic]
<ObsoleteAttribute("Text Orientation is not viable, as text is always edited in the zero degree orientation, This will be removed in v10")>
Public Property TextOrientation As TextOrientation
[C#]
[ObsoleteAttribute("Text Orientation is not viable, as text is always edited in the zero degree orientation, This will be removed in v10")]
public TextOrientation TextOrientation {get; set;}
[C++]
[ObsoleteAttribute("Text Orientation is not viable, as text is always edited in the zero degree orientation, This will be removed in v10")]
public: __property TextOrientation get_TextOrientation();
public: __property void set_TextOrientation(
   TextOrientation value
);
[C++/CLI]
[ObsoleteAttribute("Text Orientation is not viable, as text is always edited in the zero degree orientation, This will be removed in v10")]
public:
property TextOrientation TextOrientation {
   TextOrientation get();
   void set (TextOrientation value);
}

Value

The TextOrientation used for the text annotation.

Remarks

Note: This property is not necessarily useful as text is always edited in the zero degree orientation. This property will be removed in version 10.

See Also

TextToolbarDefaults Class | TextToolbarDefaults Members


TMSNote Property

TextToolbarDefaults Class | TextToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TMSNote Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TextToolbarDefaults Class : TMSNote Property (TextToolbarDefaults)

This property sets or returns whether or not the annotation will be saved as a Note or Text.

[Visual Basic]
Public Property TMSNote As Boolean
[C#]
public bool TMSNote {get; set;}
[C++]
public: __property bool get_TMSNote();
public: __property void set_TMSNote(
   bool value
);
[C++/CLI]
public:
property bool TMSNote {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true to save as a TMSNote. Otherwise, false is used and the annotation is not saved as a TMSNote.

Remarks

The default value is false.

This only effects the Legacy TMS file format.

See Also

TextToolbarDefaults Class | TextToolbarDefaults Members


WangType Property

TextToolbarDefaults Class | TextToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

WangType Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TextToolbarDefaults Class : WangType Property (TextToolbarDefaults)

This property sets or returns if specific Eastman/Wang compatible attributes are applied to a text annotation.

[Visual Basic]
Public Property WangType As WangType
[C#]
public WangType WangType {get; set;}
[C++]
public: __property WangType get_WangType();
public: __property void set_WangType(
   WangType value
);
[C++/CLI]
public:
property WangType WangType {
   WangType get();
   void set (WangType value);
}

Value

The WangType which determines how the anootation is processed into a Eastman/Wang image.

See Also

TextToolbarDefaults Class | TextToolbarDefaults Members


TmsAnnotationBadActivateCodeException Class

TmsAnnotationBadActivateCodeException Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadActivateCodeException Class

PegasusImaging.WinForms.NotateXpress9 Namespace : TmsAnnotationBadActivateCodeException Class

Exception class raised when the TMS annotation activation flag is invalid.

For a list of all members of this type, see TmsAnnotationBadActivateCodeException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.NotateXpress9.NotateXpressException
PegasusImaging.WinForms.NotateXpress9.TmsAnnotationBadActivateCodeException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class TmsAnnotationBadActivateCodeException
   Inherits NotateXpressException
   Implements ISerializable, _Exception
[C#]
[SerializableAttribute()]
public sealed class TmsAnnotationBadActivateCodeException : NotateXpressException, ISerializable, _Exception
[C++]
[SerializableAttribute()]
public __gc __sealed class TmsAnnotationBadActivateCodeException : public NotateXpressException, ISerializable, _Exception
[C++/CLI]
[SerializableAttribute()]
public ref class TmsAnnotationBadActivateCodeException sealed : public NotateXpressException, ISerializable, _Exception

See Also

TmsAnnotationBadActivateCodeException Members | PegasusImaging.WinForms.NotateXpress9 Namespace


TmsAnnotationBadActivateCodeException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadActivateCodeException Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : TmsAnnotationBadActivateCodeException Class

TmsAnnotationBadActivateCodeException overview

Public Constructors

Public Constructor TmsAnnotationBadActivateCodeException Constructor Overloaded. Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

TmsAnnotationBadActivateCodeException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


TmsAnnotationBadActivateCodeException Constructor

TmsAnnotationBadActivateCodeException Class | TmsAnnotationBadActivateCodeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadActivateCodeException Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadActivateCodeException Class : TmsAnnotationBadActivateCodeException Constructor (TmsAnnotationBadActivateCodeException)

Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

Overload List

Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

[Visual Basic] Public Sub New()

[C#] public TmsAnnotationBadActivateCodeException();

[C++] public TmsAnnotationBadActivateCodeException();

[C++/CLI] public TmsAnnotationBadActivateCodeException();

Exception which allows passing in an error number when there are errors with the annotation files.

[Visual Basic] Public Sub New(Integer)

[C#] public TmsAnnotationBadActivateCodeException(int);

[C++] public TmsAnnotationBadActivateCodeException(int);

[C++/CLI] public TmsAnnotationBadActivateCodeException(int);

Exception which allows passing in a message when thee are errors with the annotation files.

[Visual Basic] Public Sub New(String)

[C#] public TmsAnnotationBadActivateCodeException(string);

[C++] public TmsAnnotationBadActivateCodeException(string*);

[C++/CLI] public TmsAnnotationBadActivateCodeException(String^);

Exception which allows passing in an error number and message when there are errors with the annotation files.

[Visual Basic] Public Sub New(Integer,String)

[C#] public TmsAnnotationBadActivateCodeException(int,string);

[C++] public TmsAnnotationBadActivateCodeException(int,string*);

[C++/CLI] public TmsAnnotationBadActivateCodeException(int,String^);

Exception which allows passing in a message and inner exception when there are errors with the annotation files.

[Visual Basic] Public Sub New(String,Exception)

[C#] public TmsAnnotationBadActivateCodeException(string,Exception);

[C++] public TmsAnnotationBadActivateCodeException(string*,Exception*);

[C++/CLI] public TmsAnnotationBadActivateCodeException(String^,Exception^);

See Also

TmsAnnotationBadActivateCodeException Class | TmsAnnotationBadActivateCodeException Members


TmsAnnotationBadActivateCodeException Constructor()

TmsAnnotationBadActivateCodeException Class | TmsAnnotationBadActivateCodeException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadActivateCodeException Constructor()

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadActivateCodeException Class > TmsAnnotationBadActivateCodeException Constructor : TmsAnnotationBadActivateCodeException Constructor()

Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

[Visual Basic]
Public Function New()
[C#]
public TmsAnnotationBadActivateCodeException();
[C++]
public: TmsAnnotationBadActivateCodeException();
[C++/CLI]
public:
TmsAnnotationBadActivateCodeException();

See Also

TmsAnnotationBadActivateCodeException Class | TmsAnnotationBadActivateCodeException Members | Overload List


TmsAnnotationBadActivateCodeException Constructor(Int32)

TmsAnnotationBadActivateCodeException Class | TmsAnnotationBadActivateCodeException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadActivateCodeException Constructor(Int32)

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadActivateCodeException Class > TmsAnnotationBadActivateCodeException Constructor : TmsAnnotationBadActivateCodeException Constructor(Int32)

Exception which allows passing in an error number when there are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public TmsAnnotationBadActivateCodeException(
   int errorNumber
);
[C++]
public: TmsAnnotationBadActivateCodeException(
   int errorNumber
)
[C++/CLI]
public:
TmsAnnotationBadActivateCodeException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

TmsAnnotationBadActivateCodeException Class | TmsAnnotationBadActivateCodeException Members | Overload List


TmsAnnotationBadActivateCodeException Constructor(Int32,String)

TmsAnnotationBadActivateCodeException Class | TmsAnnotationBadActivateCodeException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadActivateCodeException Constructor(Int32,String)

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadActivateCodeException Class > TmsAnnotationBadActivateCodeException Constructor : TmsAnnotationBadActivateCodeException Constructor(Int32,String)

Exception which allows passing in an error number and message when there are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public TmsAnnotationBadActivateCodeException(
   int errorNumber,
   string message
);
[C++]
public: TmsAnnotationBadActivateCodeException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
TmsAnnotationBadActivateCodeException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

TmsAnnotationBadActivateCodeException Class | TmsAnnotationBadActivateCodeException Members | Overload List


TmsAnnotationBadActivateCodeException Constructor(String)

TmsAnnotationBadActivateCodeException Class | TmsAnnotationBadActivateCodeException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadActivateCodeException Constructor(String)

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadActivateCodeException Class > TmsAnnotationBadActivateCodeException Constructor : TmsAnnotationBadActivateCodeException Constructor(String)

Exception which allows passing in a message when thee are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public TmsAnnotationBadActivateCodeException(
   string message
);
[C++]
public: TmsAnnotationBadActivateCodeException(
   string* message
)
[C++/CLI]
public:
TmsAnnotationBadActivateCodeException(
   String^ message
)

Parameters

message
A string which represents the message.

See Also

TmsAnnotationBadActivateCodeException Class | TmsAnnotationBadActivateCodeException Members | Overload List


TmsAnnotationBadActivateCodeException Constructor(String,Exception)

TmsAnnotationBadActivateCodeException Class | TmsAnnotationBadActivateCodeException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadActivateCodeException Constructor(String,Exception)

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadActivateCodeException Class > TmsAnnotationBadActivateCodeException Constructor : TmsAnnotationBadActivateCodeException Constructor(String,Exception)

Exception which allows passing in a message and inner exception when there are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public TmsAnnotationBadActivateCodeException(
   string message,
   Exception innerException
);
[C++]
public: TmsAnnotationBadActivateCodeException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
TmsAnnotationBadActivateCodeException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception.

See Also

TmsAnnotationBadActivateCodeException Class | TmsAnnotationBadActivateCodeException Members | Overload List


TmsAnnotationBadAlignmentException Class

TmsAnnotationBadAlignmentException Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadAlignmentException Class

PegasusImaging.WinForms.NotateXpress9 Namespace : TmsAnnotationBadAlignmentException Class

Exception class raised when the TMS annotation alignment field is invalid.

For a list of all members of this type, see TmsAnnotationBadAlignmentException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.NotateXpress9.NotateXpressException
PegasusImaging.WinForms.NotateXpress9.TmsAnnotationBadAlignmentException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class TmsAnnotationBadAlignmentException
   Inherits NotateXpressException
   Implements ISerializable, _Exception
[C#]
[SerializableAttribute()]
public sealed class TmsAnnotationBadAlignmentException : NotateXpressException, ISerializable, _Exception
[C++]
[SerializableAttribute()]
public __gc __sealed class TmsAnnotationBadAlignmentException : public NotateXpressException, ISerializable, _Exception
[C++/CLI]
[SerializableAttribute()]
public ref class TmsAnnotationBadAlignmentException sealed : public NotateXpressException, ISerializable, _Exception

See Also

TmsAnnotationBadAlignmentException Members | PegasusImaging.WinForms.NotateXpress9 Namespace


TmsAnnotationBadAlignmentException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadAlignmentException Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : TmsAnnotationBadAlignmentException Class

TmsAnnotationBadAlignmentException overview

Public Constructors

Public Constructor TmsAnnotationBadAlignmentException Constructor Overloaded. Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

TmsAnnotationBadAlignmentException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


TmsAnnotationBadAlignmentException Constructor

TmsAnnotationBadAlignmentException Class | TmsAnnotationBadAlignmentException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadAlignmentException Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadAlignmentException Class : TmsAnnotationBadAlignmentException Constructor (TmsAnnotationBadAlignmentException)

Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

Overload List

Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

[Visual Basic] Public Sub New()

[C#] public TmsAnnotationBadAlignmentException();

[C++] public TmsAnnotationBadAlignmentException();

[C++/CLI] public TmsAnnotationBadAlignmentException();

Exception which allows passing in an error number when there are errors with the annotation files.

[Visual Basic] Public Sub New(Integer)

[C#] public TmsAnnotationBadAlignmentException(int);

[C++] public TmsAnnotationBadAlignmentException(int);

[C++/CLI] public TmsAnnotationBadAlignmentException(int);

Exception which allows passing in a message when thee are errors with the annotation files.

[Visual Basic] Public Sub New(String)

[C#] public TmsAnnotationBadAlignmentException(string);

[C++] public TmsAnnotationBadAlignmentException(string*);

[C++/CLI] public TmsAnnotationBadAlignmentException(String^);

Exception which allows passing in an error number and message when there are errors with the annotation files.

[Visual Basic] Public Sub New(Integer,String)

[C#] public TmsAnnotationBadAlignmentException(int,string);

[C++] public TmsAnnotationBadAlignmentException(int,string*);

[C++/CLI] public TmsAnnotationBadAlignmentException(int,String^);

Exception which allows passing in a message and inner exception when there are errors with the annotation files.

[Visual Basic] Public Sub New(String,Exception)

[C#] public TmsAnnotationBadAlignmentException(string,Exception);

[C++] public TmsAnnotationBadAlignmentException(string*,Exception*);

[C++/CLI] public TmsAnnotationBadAlignmentException(String^,Exception^);

See Also

TmsAnnotationBadAlignmentException Class | TmsAnnotationBadAlignmentException Members


TmsAnnotationBadAlignmentException Constructor()

TmsAnnotationBadAlignmentException Class | TmsAnnotationBadAlignmentException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadAlignmentException Constructor()

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadAlignmentException Class > TmsAnnotationBadAlignmentException Constructor : TmsAnnotationBadAlignmentException Constructor()

Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

[Visual Basic]
Public Function New()
[C#]
public TmsAnnotationBadAlignmentException();
[C++]
public: TmsAnnotationBadAlignmentException();
[C++/CLI]
public:
TmsAnnotationBadAlignmentException();

See Also

TmsAnnotationBadAlignmentException Class | TmsAnnotationBadAlignmentException Members | Overload List


TmsAnnotationBadAlignmentException Constructor(Int32)

TmsAnnotationBadAlignmentException Class | TmsAnnotationBadAlignmentException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadAlignmentException Constructor(Int32)

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadAlignmentException Class > TmsAnnotationBadAlignmentException Constructor : TmsAnnotationBadAlignmentException Constructor(Int32)

Exception which allows passing in an error number when there are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public TmsAnnotationBadAlignmentException(
   int errorNumber
);
[C++]
public: TmsAnnotationBadAlignmentException(
   int errorNumber
)
[C++/CLI]
public:
TmsAnnotationBadAlignmentException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

TmsAnnotationBadAlignmentException Class | TmsAnnotationBadAlignmentException Members | Overload List


TmsAnnotationBadAlignmentException Constructor(Int32,String)

TmsAnnotationBadAlignmentException Class | TmsAnnotationBadAlignmentException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadAlignmentException Constructor(Int32,String)

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadAlignmentException Class > TmsAnnotationBadAlignmentException Constructor : TmsAnnotationBadAlignmentException Constructor(Int32,String)

Exception which allows passing in an error number and message when there are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public TmsAnnotationBadAlignmentException(
   int errorNumber,
   string message
);
[C++]
public: TmsAnnotationBadAlignmentException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
TmsAnnotationBadAlignmentException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

TmsAnnotationBadAlignmentException Class | TmsAnnotationBadAlignmentException Members | Overload List


TmsAnnotationBadAlignmentException Constructor(String)

TmsAnnotationBadAlignmentException Class | TmsAnnotationBadAlignmentException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadAlignmentException Constructor(String)

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadAlignmentException Class > TmsAnnotationBadAlignmentException Constructor : TmsAnnotationBadAlignmentException Constructor(String)

Exception which allows passing in a message when thee are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public TmsAnnotationBadAlignmentException(
   string message
);
[C++]
public: TmsAnnotationBadAlignmentException(
   string* message
)
[C++/CLI]
public:
TmsAnnotationBadAlignmentException(
   String^ message
)

Parameters

message
A string which represents the message.

See Also

TmsAnnotationBadAlignmentException Class | TmsAnnotationBadAlignmentException Members | Overload List


TmsAnnotationBadAlignmentException Constructor(String,Exception)

TmsAnnotationBadAlignmentException Class | TmsAnnotationBadAlignmentException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadAlignmentException Constructor(String,Exception)

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadAlignmentException Class > TmsAnnotationBadAlignmentException Constructor : TmsAnnotationBadAlignmentException Constructor(String,Exception)

Exception which allows passing in a message and inner exception when there are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public TmsAnnotationBadAlignmentException(
   string message,
   Exception innerException
);
[C++]
public: TmsAnnotationBadAlignmentException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
TmsAnnotationBadAlignmentException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception.

See Also

TmsAnnotationBadAlignmentException Class | TmsAnnotationBadAlignmentException Members | Overload List


TmsAnnotationBadArrowsException Class

TmsAnnotationBadArrowsException Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadArrowsException Class

PegasusImaging.WinForms.NotateXpress9 Namespace : TmsAnnotationBadArrowsException Class

Exception class raised when the TMS annotation arrows field is invalid.

For a list of all members of this type, see TmsAnnotationBadArrowsException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.NotateXpress9.NotateXpressException
PegasusImaging.WinForms.NotateXpress9.TmsAnnotationBadArrowsException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class TmsAnnotationBadArrowsException
   Inherits NotateXpressException
   Implements ISerializable, _Exception
[C#]
[SerializableAttribute()]
public sealed class TmsAnnotationBadArrowsException : NotateXpressException, ISerializable, _Exception
[C++]
[SerializableAttribute()]
public __gc __sealed class TmsAnnotationBadArrowsException : public NotateXpressException, ISerializable, _Exception
[C++/CLI]
[SerializableAttribute()]
public ref class TmsAnnotationBadArrowsException sealed : public NotateXpressException, ISerializable, _Exception

See Also

TmsAnnotationBadArrowsException Members | PegasusImaging.WinForms.NotateXpress9 Namespace


TmsAnnotationBadArrowsException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadArrowsException Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : TmsAnnotationBadArrowsException Class

TmsAnnotationBadArrowsException overview

Public Constructors

Public Constructor TmsAnnotationBadArrowsException Constructor Overloaded. Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

TmsAnnotationBadArrowsException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


TmsAnnotationBadArrowsException Constructor

TmsAnnotationBadArrowsException Class | TmsAnnotationBadArrowsException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadArrowsException Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadArrowsException Class : TmsAnnotationBadArrowsException Constructor (TmsAnnotationBadArrowsException)

Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

Overload List

Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

[Visual Basic] Public Sub New()

[C#] public TmsAnnotationBadArrowsException();

[C++] public TmsAnnotationBadArrowsException();

[C++/CLI] public TmsAnnotationBadArrowsException();

Exception which allows passing in an error number when there are errors with the annotation files.

[Visual Basic] Public Sub New(Integer)

[C#] public TmsAnnotationBadArrowsException(int);

[C++] public TmsAnnotationBadArrowsException(int);

[C++/CLI] public TmsAnnotationBadArrowsException(int);

Exception which allows passing in a message when thee are errors with the annotation files.

[Visual Basic] Public Sub New(String)

[C#] public TmsAnnotationBadArrowsException(string);

[C++] public TmsAnnotationBadArrowsException(string*);

[C++/CLI] public TmsAnnotationBadArrowsException(String^);

Exception which allows passing in an error number and message when there are errors with the annotation files.

[Visual Basic] Public Sub New(Integer,String)

[C#] public TmsAnnotationBadArrowsException(int,string);

[C++] public TmsAnnotationBadArrowsException(int,string*);

[C++/CLI] public TmsAnnotationBadArrowsException(int,String^);

Exception which allows passing in a message and inner exception when there are errors with the annotation files.

[Visual Basic] Public Sub New(String,Exception)

[C#] public TmsAnnotationBadArrowsException(string,Exception);

[C++] public TmsAnnotationBadArrowsException(string*,Exception*);

[C++/CLI] public TmsAnnotationBadArrowsException(String^,Exception^);

See Also

TmsAnnotationBadArrowsException Class | TmsAnnotationBadArrowsException Members


TmsAnnotationBadArrowsException Constructor()

TmsAnnotationBadArrowsException Class | TmsAnnotationBadArrowsException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadArrowsException Constructor()

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadArrowsException Class > TmsAnnotationBadArrowsException Constructor : TmsAnnotationBadArrowsException Constructor()

Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

[Visual Basic]
Public Function New()
[C#]
public TmsAnnotationBadArrowsException();
[C++]
public: TmsAnnotationBadArrowsException();
[C++/CLI]
public:
TmsAnnotationBadArrowsException();

See Also

TmsAnnotationBadArrowsException Class | TmsAnnotationBadArrowsException Members | Overload List


TmsAnnotationBadArrowsException Constructor(Int32)

TmsAnnotationBadArrowsException Class | TmsAnnotationBadArrowsException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadArrowsException Constructor(Int32)

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadArrowsException Class > TmsAnnotationBadArrowsException Constructor : TmsAnnotationBadArrowsException Constructor(Int32)

Exception which allows passing in an error number when there are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public TmsAnnotationBadArrowsException(
   int errorNumber
);
[C++]
public: TmsAnnotationBadArrowsException(
   int errorNumber
)
[C++/CLI]
public:
TmsAnnotationBadArrowsException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

TmsAnnotationBadArrowsException Class | TmsAnnotationBadArrowsException Members | Overload List


TmsAnnotationBadArrowsException Constructor(Int32,String)

TmsAnnotationBadArrowsException Class | TmsAnnotationBadArrowsException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadArrowsException Constructor(Int32,String)

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadArrowsException Class > TmsAnnotationBadArrowsException Constructor : TmsAnnotationBadArrowsException Constructor(Int32,String)

Exception which allows passing in an error number and message when there are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public TmsAnnotationBadArrowsException(
   int errorNumber,
   string message
);
[C++]
public: TmsAnnotationBadArrowsException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
TmsAnnotationBadArrowsException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

TmsAnnotationBadArrowsException Class | TmsAnnotationBadArrowsException Members | Overload List


TmsAnnotationBadArrowsException Constructor(String)

TmsAnnotationBadArrowsException Class | TmsAnnotationBadArrowsException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadArrowsException Constructor(String)

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadArrowsException Class > TmsAnnotationBadArrowsException Constructor : TmsAnnotationBadArrowsException Constructor(String)

Exception which allows passing in a message when thee are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public TmsAnnotationBadArrowsException(
   string message
);
[C++]
public: TmsAnnotationBadArrowsException(
   string* message
)
[C++/CLI]
public:
TmsAnnotationBadArrowsException(
   String^ message
)

Parameters

message
A string which represents the message.

See Also

TmsAnnotationBadArrowsException Class | TmsAnnotationBadArrowsException Members | Overload List


TmsAnnotationBadArrowsException Constructor(String,Exception)

TmsAnnotationBadArrowsException Class | TmsAnnotationBadArrowsException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadArrowsException Constructor(String,Exception)

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadArrowsException Class > TmsAnnotationBadArrowsException Constructor : TmsAnnotationBadArrowsException Constructor(String,Exception)

Exception which allows passing in a message and inner exception when there are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public TmsAnnotationBadArrowsException(
   string message,
   Exception innerException
);
[C++]
public: TmsAnnotationBadArrowsException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
TmsAnnotationBadArrowsException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception.

See Also

TmsAnnotationBadArrowsException Class | TmsAnnotationBadArrowsException Members | Overload List


TmsAnnotationBadBorderStyleException Class

TmsAnnotationBadBorderStyleException Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadBorderStyleException Class

PegasusImaging.WinForms.NotateXpress9 Namespace : TmsAnnotationBadBorderStyleException Class

Exception class raised when the TMS annotation border style field is invalid.

For a list of all members of this type, see TmsAnnotationBadBorderStyleException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.NotateXpress9.NotateXpressException
PegasusImaging.WinForms.NotateXpress9.TmsAnnotationBadBorderStyleException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class TmsAnnotationBadBorderStyleException
   Inherits NotateXpressException
   Implements ISerializable, _Exception
[C#]
[SerializableAttribute()]
public sealed class TmsAnnotationBadBorderStyleException : NotateXpressException, ISerializable, _Exception
[C++]
[SerializableAttribute()]
public __gc __sealed class TmsAnnotationBadBorderStyleException : public NotateXpressException, ISerializable, _Exception
[C++/CLI]
[SerializableAttribute()]
public ref class TmsAnnotationBadBorderStyleException sealed : public NotateXpressException, ISerializable, _Exception

See Also

TmsAnnotationBadBorderStyleException Members | PegasusImaging.WinForms.NotateXpress9 Namespace


TmsAnnotationBadBorderStyleException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadBorderStyleException Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : TmsAnnotationBadBorderStyleException Class

TmsAnnotationBadBorderStyleException overview

Public Constructors

Public Constructor TmsAnnotationBadBorderStyleException Constructor Overloaded. Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

TmsAnnotationBadBorderStyleException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


TmsAnnotationBadBorderStyleException Constructor

TmsAnnotationBadBorderStyleException Class | TmsAnnotationBadBorderStyleException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadBorderStyleException Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadBorderStyleException Class : TmsAnnotationBadBorderStyleException Constructor (TmsAnnotationBadBorderStyleException)

Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

Overload List

Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

[Visual Basic] Public Sub New()

[C#] public TmsAnnotationBadBorderStyleException();

[C++] public TmsAnnotationBadBorderStyleException();

[C++/CLI] public TmsAnnotationBadBorderStyleException();

Exception which allows passing in an error number when there are errors with the annotation files.

[Visual Basic] Public Sub New(Integer)

[C#] public TmsAnnotationBadBorderStyleException(int);

[C++] public TmsAnnotationBadBorderStyleException(int);

[C++/CLI] public TmsAnnotationBadBorderStyleException(int);

Exception which allows passing in a message when thee are errors with the annotation files.

[Visual Basic] Public Sub New(String)

[C#] public TmsAnnotationBadBorderStyleException(string);

[C++] public TmsAnnotationBadBorderStyleException(string*);

[C++/CLI] public TmsAnnotationBadBorderStyleException(String^);

Exception which allows passing in an error number and message when there are errors with the annotation files.

[Visual Basic] Public Sub New(Integer,String)

[C#] public TmsAnnotationBadBorderStyleException(int,string);

[C++] public TmsAnnotationBadBorderStyleException(int,string*);

[C++/CLI] public TmsAnnotationBadBorderStyleException(int,String^);

Exception which allows passing in a message and inner exception when there are errors with the annotation files.

[Visual Basic] Public Sub New(String,Exception)

[C#] public TmsAnnotationBadBorderStyleException(string,Exception);

[C++] public TmsAnnotationBadBorderStyleException(string*,Exception*);

[C++/CLI] public TmsAnnotationBadBorderStyleException(String^,Exception^);

See Also

TmsAnnotationBadBorderStyleException Class | TmsAnnotationBadBorderStyleException Members


TmsAnnotationBadBorderStyleException Constructor()

TmsAnnotationBadBorderStyleException Class | TmsAnnotationBadBorderStyleException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadBorderStyleException Constructor()

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadBorderStyleException Class > TmsAnnotationBadBorderStyleException Constructor : TmsAnnotationBadBorderStyleException Constructor()

Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

[Visual Basic]
Public Function New()
[C#]
public TmsAnnotationBadBorderStyleException();
[C++]
public: TmsAnnotationBadBorderStyleException();
[C++/CLI]
public:
TmsAnnotationBadBorderStyleException();

See Also

TmsAnnotationBadBorderStyleException Class | TmsAnnotationBadBorderStyleException Members | Overload List


TmsAnnotationBadBorderStyleException Constructor(Int32)

TmsAnnotationBadBorderStyleException Class | TmsAnnotationBadBorderStyleException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadBorderStyleException Constructor(Int32)

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadBorderStyleException Class > TmsAnnotationBadBorderStyleException Constructor : TmsAnnotationBadBorderStyleException Constructor(Int32)

Exception which allows passing in an error number when there are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public TmsAnnotationBadBorderStyleException(
   int errorNumber
);
[C++]
public: TmsAnnotationBadBorderStyleException(
   int errorNumber
)
[C++/CLI]
public:
TmsAnnotationBadBorderStyleException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

TmsAnnotationBadBorderStyleException Class | TmsAnnotationBadBorderStyleException Members | Overload List


TmsAnnotationBadBorderStyleException Constructor(Int32,String)

TmsAnnotationBadBorderStyleException Class | TmsAnnotationBadBorderStyleException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadBorderStyleException Constructor(Int32,String)

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadBorderStyleException Class > TmsAnnotationBadBorderStyleException Constructor : TmsAnnotationBadBorderStyleException Constructor(Int32,String)

Exception which allows passing in an error number and message when there are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public TmsAnnotationBadBorderStyleException(
   int errorNumber,
   string message
);
[C++]
public: TmsAnnotationBadBorderStyleException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
TmsAnnotationBadBorderStyleException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

TmsAnnotationBadBorderStyleException Class | TmsAnnotationBadBorderStyleException Members | Overload List


TmsAnnotationBadBorderStyleException Constructor(String)

TmsAnnotationBadBorderStyleException Class | TmsAnnotationBadBorderStyleException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadBorderStyleException Constructor(String)

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadBorderStyleException Class > TmsAnnotationBadBorderStyleException Constructor : TmsAnnotationBadBorderStyleException Constructor(String)

Exception which allows passing in a message when thee are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public TmsAnnotationBadBorderStyleException(
   string message
);
[C++]
public: TmsAnnotationBadBorderStyleException(
   string* message
)
[C++/CLI]
public:
TmsAnnotationBadBorderStyleException(
   String^ message
)

Parameters

message
A string which represents the message.

See Also

TmsAnnotationBadBorderStyleException Class | TmsAnnotationBadBorderStyleException Members | Overload List


TmsAnnotationBadBorderStyleException Constructor(String,Exception)

TmsAnnotationBadBorderStyleException Class | TmsAnnotationBadBorderStyleException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadBorderStyleException Constructor(String,Exception)

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadBorderStyleException Class > TmsAnnotationBadBorderStyleException Constructor : TmsAnnotationBadBorderStyleException Constructor(String,Exception)

Exception which allows passing in a message and inner exception when there are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public TmsAnnotationBadBorderStyleException(
   string message,
   Exception innerException
);
[C++]
public: TmsAnnotationBadBorderStyleException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
TmsAnnotationBadBorderStyleException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception.

See Also

TmsAnnotationBadBorderStyleException Class | TmsAnnotationBadBorderStyleException Members | Overload List


TmsAnnotationBadColorMapFlagException Class

TmsAnnotationBadColorMapFlagException Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadColorMapFlagException Class

PegasusImaging.WinForms.NotateXpress9 Namespace : TmsAnnotationBadColorMapFlagException Class

Exception class raised when the TMS annotation color mapping flag is invalid.

For a list of all members of this type, see TmsAnnotationBadColorMapFlagException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.NotateXpress9.NotateXpressException
PegasusImaging.WinForms.NotateXpress9.TmsAnnotationBadColorMapFlagException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class TmsAnnotationBadColorMapFlagException
   Inherits NotateXpressException
   Implements ISerializable, _Exception
[C#]
[SerializableAttribute()]
public sealed class TmsAnnotationBadColorMapFlagException : NotateXpressException, ISerializable, _Exception
[C++]
[SerializableAttribute()]
public __gc __sealed class TmsAnnotationBadColorMapFlagException : public NotateXpressException, ISerializable, _Exception
[C++/CLI]
[SerializableAttribute()]
public ref class TmsAnnotationBadColorMapFlagException sealed : public NotateXpressException, ISerializable, _Exception

See Also

TmsAnnotationBadColorMapFlagException Members | PegasusImaging.WinForms.NotateXpress9 Namespace


TmsAnnotationBadColorMapFlagException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadColorMapFlagException Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : TmsAnnotationBadColorMapFlagException Class

TmsAnnotationBadColorMapFlagException overview

Public Constructors

Public Constructor TmsAnnotationBadColorMapFlagException Constructor Overloaded. Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

TmsAnnotationBadColorMapFlagException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


TmsAnnotationBadColorMapFlagException Constructor

TmsAnnotationBadColorMapFlagException Class | TmsAnnotationBadColorMapFlagException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadColorMapFlagException Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadColorMapFlagException Class : TmsAnnotationBadColorMapFlagException Constructor (TmsAnnotationBadColorMapFlagException)

Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

Overload List

Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

[Visual Basic] Public Sub New()

[C#] public TmsAnnotationBadColorMapFlagException();

[C++] public TmsAnnotationBadColorMapFlagException();

[C++/CLI] public TmsAnnotationBadColorMapFlagException();

Exception which allows passing in an error number when there are errors with the annotation files.

[Visual Basic] Public Sub New(Integer)

[C#] public TmsAnnotationBadColorMapFlagException(int);

[C++] public TmsAnnotationBadColorMapFlagException(int);

[C++/CLI] public TmsAnnotationBadColorMapFlagException(int);

Exception which allows passing in a message when thee are errors with the annotation files.

[Visual Basic] Public Sub New(String)

[C#] public TmsAnnotationBadColorMapFlagException(string);

[C++] public TmsAnnotationBadColorMapFlagException(string*);

[C++/CLI] public TmsAnnotationBadColorMapFlagException(String^);

Exception which allows passing in an error number and message when there are errors with the annotation files.

[Visual Basic] Public Sub New(Integer,String)

[C#] public TmsAnnotationBadColorMapFlagException(int,string);

[C++] public TmsAnnotationBadColorMapFlagException(int,string*);

[C++/CLI] public TmsAnnotationBadColorMapFlagException(int,String^);

Exception which allows passing in a message and inner exception when there are errors with the annotation files.

[Visual Basic] Public Sub New(String,Exception)

[C#] public TmsAnnotationBadColorMapFlagException(string,Exception);

[C++] public TmsAnnotationBadColorMapFlagException(string*,Exception*);

[C++/CLI] public TmsAnnotationBadColorMapFlagException(String^,Exception^);

See Also

TmsAnnotationBadColorMapFlagException Class | TmsAnnotationBadColorMapFlagException Members


TmsAnnotationBadColorMapFlagException Constructor()

TmsAnnotationBadColorMapFlagException Class | TmsAnnotationBadColorMapFlagException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadColorMapFlagException Constructor()

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadColorMapFlagException Class > TmsAnnotationBadColorMapFlagException Constructor : TmsAnnotationBadColorMapFlagException Constructor()

Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

[Visual Basic]
Public Function New()
[C#]
public TmsAnnotationBadColorMapFlagException();
[C++]
public: TmsAnnotationBadColorMapFlagException();
[C++/CLI]
public:
TmsAnnotationBadColorMapFlagException();

See Also

TmsAnnotationBadColorMapFlagException Class | TmsAnnotationBadColorMapFlagException Members | Overload List


TmsAnnotationBadColorMapFlagException Constructor(Int32)

TmsAnnotationBadColorMapFlagException Class | TmsAnnotationBadColorMapFlagException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadColorMapFlagException Constructor(Int32)

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadColorMapFlagException Class > TmsAnnotationBadColorMapFlagException Constructor : TmsAnnotationBadColorMapFlagException Constructor(Int32)

Exception which allows passing in an error number when there are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public TmsAnnotationBadColorMapFlagException(
   int errorNumber
);
[C++]
public: TmsAnnotationBadColorMapFlagException(
   int errorNumber
)
[C++/CLI]
public:
TmsAnnotationBadColorMapFlagException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

TmsAnnotationBadColorMapFlagException Class | TmsAnnotationBadColorMapFlagException Members | Overload List


TmsAnnotationBadColorMapFlagException Constructor(Int32,String)

TmsAnnotationBadColorMapFlagException Class | TmsAnnotationBadColorMapFlagException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadColorMapFlagException Constructor(Int32,String)

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadColorMapFlagException Class > TmsAnnotationBadColorMapFlagException Constructor : TmsAnnotationBadColorMapFlagException Constructor(Int32,String)

Exception which allows passing in an error number and message when there are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public TmsAnnotationBadColorMapFlagException(
   int errorNumber,
   string message
);
[C++]
public: TmsAnnotationBadColorMapFlagException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
TmsAnnotationBadColorMapFlagException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

TmsAnnotationBadColorMapFlagException Class | TmsAnnotationBadColorMapFlagException Members | Overload List


TmsAnnotationBadColorMapFlagException Constructor(String)

TmsAnnotationBadColorMapFlagException Class | TmsAnnotationBadColorMapFlagException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadColorMapFlagException Constructor(String)

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadColorMapFlagException Class > TmsAnnotationBadColorMapFlagException Constructor : TmsAnnotationBadColorMapFlagException Constructor(String)

Exception which allows passing in a message when thee are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public TmsAnnotationBadColorMapFlagException(
   string message
);
[C++]
public: TmsAnnotationBadColorMapFlagException(
   string* message
)
[C++/CLI]
public:
TmsAnnotationBadColorMapFlagException(
   String^ message
)

Parameters

message
A string which represents the message.

See Also

TmsAnnotationBadColorMapFlagException Class | TmsAnnotationBadColorMapFlagException Members | Overload List


TmsAnnotationBadColorMapFlagException Constructor(String,Exception)

TmsAnnotationBadColorMapFlagException Class | TmsAnnotationBadColorMapFlagException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadColorMapFlagException Constructor(String,Exception)

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadColorMapFlagException Class > TmsAnnotationBadColorMapFlagException Constructor : TmsAnnotationBadColorMapFlagException Constructor(String,Exception)

Exception which allows passing in a message and inner exception when there are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public TmsAnnotationBadColorMapFlagException(
   string message,
   Exception innerException
);
[C++]
public: TmsAnnotationBadColorMapFlagException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
TmsAnnotationBadColorMapFlagException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception.

See Also

TmsAnnotationBadColorMapFlagException Class | TmsAnnotationBadColorMapFlagException Members | Overload List


TmsAnnotationBadCoordinateException Class

TmsAnnotationBadCoordinateException Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadCoordinateException Class

PegasusImaging.WinForms.NotateXpress9 Namespace : TmsAnnotationBadCoordinateException Class

Exception class raised when there are invalid TMS annotation coordinates.

For a list of all members of this type, see TmsAnnotationBadCoordinateException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.NotateXpress9.NotateXpressException
PegasusImaging.WinForms.NotateXpress9.TmsAnnotationBadCoordinateException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class TmsAnnotationBadCoordinateException
   Inherits NotateXpressException
   Implements ISerializable, _Exception
[C#]
[SerializableAttribute()]
public sealed class TmsAnnotationBadCoordinateException : NotateXpressException, ISerializable, _Exception
[C++]
[SerializableAttribute()]
public __gc __sealed class TmsAnnotationBadCoordinateException : public NotateXpressException, ISerializable, _Exception
[C++/CLI]
[SerializableAttribute()]
public ref class TmsAnnotationBadCoordinateException sealed : public NotateXpressException, ISerializable, _Exception

See Also

TmsAnnotationBadCoordinateException Members | PegasusImaging.WinForms.NotateXpress9 Namespace


TmsAnnotationBadCoordinateException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadCoordinateException Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : TmsAnnotationBadCoordinateException Class

TmsAnnotationBadCoordinateException overview

Public Constructors

Public Constructor TmsAnnotationBadCoordinateException Constructor Overloaded. Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

TmsAnnotationBadCoordinateException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


TmsAnnotationBadCoordinateException Constructor

TmsAnnotationBadCoordinateException Class | TmsAnnotationBadCoordinateException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadCoordinateException Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadCoordinateException Class : TmsAnnotationBadCoordinateException Constructor (TmsAnnotationBadCoordinateException)

Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

Overload List

Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

[Visual Basic] Public Sub New()

[C#] public TmsAnnotationBadCoordinateException();

[C++] public TmsAnnotationBadCoordinateException();

[C++/CLI] public TmsAnnotationBadCoordinateException();

Exception which allows passing in an error number when there are errors with the annotation files.

[Visual Basic] Public Sub New(Integer)

[C#] public TmsAnnotationBadCoordinateException(int);

[C++] public TmsAnnotationBadCoordinateException(int);

[C++/CLI] public TmsAnnotationBadCoordinateException(int);

Exception which allows passing in a message when thee are errors with the annotation files.

[Visual Basic] Public Sub New(String)

[C#] public TmsAnnotationBadCoordinateException(string);

[C++] public TmsAnnotationBadCoordinateException(string*);

[C++/CLI] public TmsAnnotationBadCoordinateException(String^);

Exception which allows passing in an error number and message when there are errors with the annotation files.

[Visual Basic] Public Sub New(Integer,String)

[C#] public TmsAnnotationBadCoordinateException(int,string);

[C++] public TmsAnnotationBadCoordinateException(int,string*);

[C++/CLI] public TmsAnnotationBadCoordinateException(int,String^);

Exception which allows passing in a message and inner exception when there are errors with the annotation files.

[Visual Basic] Public Sub New(String,Exception)

[C#] public TmsAnnotationBadCoordinateException(string,Exception);

[C++] public TmsAnnotationBadCoordinateException(string*,Exception*);

[C++/CLI] public TmsAnnotationBadCoordinateException(String^,Exception^);

See Also

TmsAnnotationBadCoordinateException Class | TmsAnnotationBadCoordinateException Members


TmsAnnotationBadCoordinateException Constructor()

TmsAnnotationBadCoordinateException Class | TmsAnnotationBadCoordinateException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadCoordinateException Constructor()

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadCoordinateException Class > TmsAnnotationBadCoordinateException Constructor : TmsAnnotationBadCoordinateException Constructor()

Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

[Visual Basic]
Public Function New()
[C#]
public TmsAnnotationBadCoordinateException();
[C++]
public: TmsAnnotationBadCoordinateException();
[C++/CLI]
public:
TmsAnnotationBadCoordinateException();

See Also

TmsAnnotationBadCoordinateException Class | TmsAnnotationBadCoordinateException Members | Overload List


TmsAnnotationBadCoordinateException Constructor(Int32)

TmsAnnotationBadCoordinateException Class | TmsAnnotationBadCoordinateException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadCoordinateException Constructor(Int32)

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadCoordinateException Class > TmsAnnotationBadCoordinateException Constructor : TmsAnnotationBadCoordinateException Constructor(Int32)

Exception which allows passing in an error number when there are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public TmsAnnotationBadCoordinateException(
   int errorNumber
);
[C++]
public: TmsAnnotationBadCoordinateException(
   int errorNumber
)
[C++/CLI]
public:
TmsAnnotationBadCoordinateException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

TmsAnnotationBadCoordinateException Class | TmsAnnotationBadCoordinateException Members | Overload List


TmsAnnotationBadCoordinateException Constructor(Int32,String)

TmsAnnotationBadCoordinateException Class | TmsAnnotationBadCoordinateException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadCoordinateException Constructor(Int32,String)

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadCoordinateException Class > TmsAnnotationBadCoordinateException Constructor : TmsAnnotationBadCoordinateException Constructor(Int32,String)

Exception which allows passing in an error number and message when there are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public TmsAnnotationBadCoordinateException(
   int errorNumber,
   string message
);
[C++]
public: TmsAnnotationBadCoordinateException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
TmsAnnotationBadCoordinateException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

TmsAnnotationBadCoordinateException Class | TmsAnnotationBadCoordinateException Members | Overload List


TmsAnnotationBadCoordinateException Constructor(String)

TmsAnnotationBadCoordinateException Class | TmsAnnotationBadCoordinateException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadCoordinateException Constructor(String)

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadCoordinateException Class > TmsAnnotationBadCoordinateException Constructor : TmsAnnotationBadCoordinateException Constructor(String)

Exception which allows passing in a message when thee are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public TmsAnnotationBadCoordinateException(
   string message
);
[C++]
public: TmsAnnotationBadCoordinateException(
   string* message
)
[C++/CLI]
public:
TmsAnnotationBadCoordinateException(
   String^ message
)

Parameters

message
A string which represents the message.

See Also

TmsAnnotationBadCoordinateException Class | TmsAnnotationBadCoordinateException Members | Overload List


TmsAnnotationBadCoordinateException Constructor(String,Exception)

TmsAnnotationBadCoordinateException Class | TmsAnnotationBadCoordinateException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadCoordinateException Constructor(String,Exception)

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadCoordinateException Class > TmsAnnotationBadCoordinateException Constructor : TmsAnnotationBadCoordinateException Constructor(String,Exception)

Exception which allows passing in a message and inner exception when there are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public TmsAnnotationBadCoordinateException(
   string message,
   Exception innerException
);
[C++]
public: TmsAnnotationBadCoordinateException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
TmsAnnotationBadCoordinateException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception.

See Also

TmsAnnotationBadCoordinateException Class | TmsAnnotationBadCoordinateException Members | Overload List


TmsAnnotationBadDirectionException Class

TmsAnnotationBadDirectionException Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadDirectionException Class

PegasusImaging.WinForms.NotateXpress9 Namespace : TmsAnnotationBadDirectionException Class

Exception class raised when the TMS annotation line direction field is invalid.

For a list of all members of this type, see TmsAnnotationBadDirectionException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.NotateXpress9.NotateXpressException
PegasusImaging.WinForms.NotateXpress9.TmsAnnotationBadDirectionException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class TmsAnnotationBadDirectionException
   Inherits NotateXpressException
   Implements ISerializable, _Exception
[C#]
[SerializableAttribute()]
public sealed class TmsAnnotationBadDirectionException : NotateXpressException, ISerializable, _Exception
[C++]
[SerializableAttribute()]
public __gc __sealed class TmsAnnotationBadDirectionException : public NotateXpressException, ISerializable, _Exception
[C++/CLI]
[SerializableAttribute()]
public ref class TmsAnnotationBadDirectionException sealed : public NotateXpressException, ISerializable, _Exception

See Also

TmsAnnotationBadDirectionException Members | PegasusImaging.WinForms.NotateXpress9 Namespace


TmsAnnotationBadDirectionException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadDirectionException Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : TmsAnnotationBadDirectionException Class

TmsAnnotationBadDirectionException overview

Public Constructors

Public Constructor TmsAnnotationBadDirectionException Constructor Overloaded. Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

TmsAnnotationBadDirectionException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


TmsAnnotationBadDirectionException Constructor

TmsAnnotationBadDirectionException Class | TmsAnnotationBadDirectionException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadDirectionException Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadDirectionException Class : TmsAnnotationBadDirectionException Constructor (TmsAnnotationBadDirectionException)

Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

Overload List

Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

[Visual Basic] Public Sub New()

[C#] public TmsAnnotationBadDirectionException();

[C++] public TmsAnnotationBadDirectionException();

[C++/CLI] public TmsAnnotationBadDirectionException();

Exception which allows passing in an error number when there are errors with the annotation files.

[Visual Basic] Public Sub New(Integer)

[C#] public TmsAnnotationBadDirectionException(int);

[C++] public TmsAnnotationBadDirectionException(int);

[C++/CLI] public TmsAnnotationBadDirectionException(int);

Exception which allows passing in a message when thee are errors with the annotation files.

[Visual Basic] Public Sub New(String)

[C#] public TmsAnnotationBadDirectionException(string);

[C++] public TmsAnnotationBadDirectionException(string*);

[C++/CLI] public TmsAnnotationBadDirectionException(String^);

Exception which allows passing in an error number and message when there are errors with the annotation files.

[Visual Basic] Public Sub New(Integer,String)

[C#] public TmsAnnotationBadDirectionException(int,string);

[C++] public TmsAnnotationBadDirectionException(int,string*);

[C++/CLI] public TmsAnnotationBadDirectionException(int,String^);

Exception which allows passing in a message and inner exception when there are errors with the annotation files.

[Visual Basic] Public Sub New(String,Exception)

[C#] public TmsAnnotationBadDirectionException(string,Exception);

[C++] public TmsAnnotationBadDirectionException(string*,Exception*);

[C++/CLI] public TmsAnnotationBadDirectionException(String^,Exception^);

See Also

TmsAnnotationBadDirectionException Class | TmsAnnotationBadDirectionException Members


TmsAnnotationBadDirectionException Constructor()

TmsAnnotationBadDirectionException Class | TmsAnnotationBadDirectionException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadDirectionException Constructor()

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadDirectionException Class > TmsAnnotationBadDirectionException Constructor : TmsAnnotationBadDirectionException Constructor()

Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

[Visual Basic]
Public Function New()
[C#]
public TmsAnnotationBadDirectionException();
[C++]
public: TmsAnnotationBadDirectionException();
[C++/CLI]
public:
TmsAnnotationBadDirectionException();

See Also

TmsAnnotationBadDirectionException Class | TmsAnnotationBadDirectionException Members | Overload List


TmsAnnotationBadDirectionException Constructor(Int32)

TmsAnnotationBadDirectionException Class | TmsAnnotationBadDirectionException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadDirectionException Constructor(Int32)

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadDirectionException Class > TmsAnnotationBadDirectionException Constructor : TmsAnnotationBadDirectionException Constructor(Int32)

Exception which allows passing in an error number when there are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public TmsAnnotationBadDirectionException(
   int errorNumber
);
[C++]
public: TmsAnnotationBadDirectionException(
   int errorNumber
)
[C++/CLI]
public:
TmsAnnotationBadDirectionException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

TmsAnnotationBadDirectionException Class | TmsAnnotationBadDirectionException Members | Overload List


TmsAnnotationBadDirectionException Constructor(Int32,String)

TmsAnnotationBadDirectionException Class | TmsAnnotationBadDirectionException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadDirectionException Constructor(Int32,String)

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadDirectionException Class > TmsAnnotationBadDirectionException Constructor : TmsAnnotationBadDirectionException Constructor(Int32,String)

Exception which allows passing in an error number and message when there are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public TmsAnnotationBadDirectionException(
   int errorNumber,
   string message
);
[C++]
public: TmsAnnotationBadDirectionException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
TmsAnnotationBadDirectionException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

TmsAnnotationBadDirectionException Class | TmsAnnotationBadDirectionException Members | Overload List


TmsAnnotationBadDirectionException Constructor(String)

TmsAnnotationBadDirectionException Class | TmsAnnotationBadDirectionException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadDirectionException Constructor(String)

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadDirectionException Class > TmsAnnotationBadDirectionException Constructor : TmsAnnotationBadDirectionException Constructor(String)

Exception which allows passing in a message when thee are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public TmsAnnotationBadDirectionException(
   string message
);
[C++]
public: TmsAnnotationBadDirectionException(
   string* message
)
[C++/CLI]
public:
TmsAnnotationBadDirectionException(
   String^ message
)

Parameters

message
A string which represents the message.

See Also

TmsAnnotationBadDirectionException Class | TmsAnnotationBadDirectionException Members | Overload List


TmsAnnotationBadDirectionException Constructor(String,Exception)

TmsAnnotationBadDirectionException Class | TmsAnnotationBadDirectionException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadDirectionException Constructor(String,Exception)

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadDirectionException Class > TmsAnnotationBadDirectionException Constructor : TmsAnnotationBadDirectionException Constructor(String,Exception)

Exception which allows passing in a message and inner exception when there are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public TmsAnnotationBadDirectionException(
   string message,
   Exception innerException
);
[C++]
public: TmsAnnotationBadDirectionException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
TmsAnnotationBadDirectionException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception.

See Also

TmsAnnotationBadDirectionException Class | TmsAnnotationBadDirectionException Members | Overload List


TmsAnnotationBadHeaderException Class

TmsAnnotationBadHeaderException Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadHeaderException Class

PegasusImaging.WinForms.NotateXpress9 Namespace : TmsAnnotationBadHeaderException Class

Exception class raised when the TMS annotation header record is illegally formed.

For a list of all members of this type, see TmsAnnotationBadHeaderException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.NotateXpress9.NotateXpressException
PegasusImaging.WinForms.NotateXpress9.TmsAnnotationBadHeaderException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class TmsAnnotationBadHeaderException
   Inherits NotateXpressException
   Implements ISerializable, _Exception
[C#]
[SerializableAttribute()]
public sealed class TmsAnnotationBadHeaderException : NotateXpressException, ISerializable, _Exception
[C++]
[SerializableAttribute()]
public __gc __sealed class TmsAnnotationBadHeaderException : public NotateXpressException, ISerializable, _Exception
[C++/CLI]
[SerializableAttribute()]
public ref class TmsAnnotationBadHeaderException sealed : public NotateXpressException, ISerializable, _Exception

See Also

TmsAnnotationBadHeaderException Members | PegasusImaging.WinForms.NotateXpress9 Namespace


TmsAnnotationBadHeaderException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadHeaderException Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : TmsAnnotationBadHeaderException Class

TmsAnnotationBadHeaderException overview

Public Constructors

Public Constructor TmsAnnotationBadHeaderException Constructor Overloaded. Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

TmsAnnotationBadHeaderException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


TmsAnnotationBadHeaderException Constructor

TmsAnnotationBadHeaderException Class | TmsAnnotationBadHeaderException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadHeaderException Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadHeaderException Class : TmsAnnotationBadHeaderException Constructor (TmsAnnotationBadHeaderException)

Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

Overload List

Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

[Visual Basic] Public Sub New()

[C#] public TmsAnnotationBadHeaderException();

[C++] public TmsAnnotationBadHeaderException();

[C++/CLI] public TmsAnnotationBadHeaderException();

Exception which allows passing in an error number when there are errors with the annotation files.

[Visual Basic] Public Sub New(Integer)

[C#] public TmsAnnotationBadHeaderException(int);

[C++] public TmsAnnotationBadHeaderException(int);

[C++/CLI] public TmsAnnotationBadHeaderException(int);

Exception which allows passing in a message when thee are errors with the annotation files.

[Visual Basic] Public Sub New(String)

[C#] public TmsAnnotationBadHeaderException(string);

[C++] public TmsAnnotationBadHeaderException(string*);

[C++/CLI] public TmsAnnotationBadHeaderException(String^);

Exception which allows passing in an error number and message when there are errors with the annotation files.

[Visual Basic] Public Sub New(Integer,String)

[C#] public TmsAnnotationBadHeaderException(int,string);

[C++] public TmsAnnotationBadHeaderException(int,string*);

[C++/CLI] public TmsAnnotationBadHeaderException(int,String^);

Exception which allows passing in a message and inner exception when there are errors with the annotation files.

[Visual Basic] Public Sub New(String,Exception)

[C#] public TmsAnnotationBadHeaderException(string,Exception);

[C++] public TmsAnnotationBadHeaderException(string*,Exception*);

[C++/CLI] public TmsAnnotationBadHeaderException(String^,Exception^);

See Also

TmsAnnotationBadHeaderException Class | TmsAnnotationBadHeaderException Members


TmsAnnotationBadHeaderException Constructor()

TmsAnnotationBadHeaderException Class | TmsAnnotationBadHeaderException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadHeaderException Constructor()

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadHeaderException Class > TmsAnnotationBadHeaderException Constructor : TmsAnnotationBadHeaderException Constructor()

Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

[Visual Basic]
Public Function New()
[C#]
public TmsAnnotationBadHeaderException();
[C++]
public: TmsAnnotationBadHeaderException();
[C++/CLI]
public:
TmsAnnotationBadHeaderException();

See Also

TmsAnnotationBadHeaderException Class | TmsAnnotationBadHeaderException Members | Overload List


TmsAnnotationBadHeaderException Constructor(Int32)

TmsAnnotationBadHeaderException Class | TmsAnnotationBadHeaderException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadHeaderException Constructor(Int32)

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadHeaderException Class > TmsAnnotationBadHeaderException Constructor : TmsAnnotationBadHeaderException Constructor(Int32)

Exception which allows passing in an error number when there are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public TmsAnnotationBadHeaderException(
   int errorNumber
);
[C++]
public: TmsAnnotationBadHeaderException(
   int errorNumber
)
[C++/CLI]
public:
TmsAnnotationBadHeaderException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

TmsAnnotationBadHeaderException Class | TmsAnnotationBadHeaderException Members | Overload List


TmsAnnotationBadHeaderException Constructor(Int32,String)

TmsAnnotationBadHeaderException Class | TmsAnnotationBadHeaderException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadHeaderException Constructor(Int32,String)

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadHeaderException Class > TmsAnnotationBadHeaderException Constructor : TmsAnnotationBadHeaderException Constructor(Int32,String)

Exception which allows passing in an error number and message when there are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public TmsAnnotationBadHeaderException(
   int errorNumber,
   string message
);
[C++]
public: TmsAnnotationBadHeaderException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
TmsAnnotationBadHeaderException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

TmsAnnotationBadHeaderException Class | TmsAnnotationBadHeaderException Members | Overload List


TmsAnnotationBadHeaderException Constructor(String)

TmsAnnotationBadHeaderException Class | TmsAnnotationBadHeaderException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadHeaderException Constructor(String)

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadHeaderException Class > TmsAnnotationBadHeaderException Constructor : TmsAnnotationBadHeaderException Constructor(String)

Exception which allows passing in a message when thee are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public TmsAnnotationBadHeaderException(
   string message
);
[C++]
public: TmsAnnotationBadHeaderException(
   string* message
)
[C++/CLI]
public:
TmsAnnotationBadHeaderException(
   String^ message
)

Parameters

message
A string which represents the message.

See Also

TmsAnnotationBadHeaderException Class | TmsAnnotationBadHeaderException Members | Overload List


TmsAnnotationBadHeaderException Constructor(String,Exception)

TmsAnnotationBadHeaderException Class | TmsAnnotationBadHeaderException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadHeaderException Constructor(String,Exception)

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadHeaderException Class > TmsAnnotationBadHeaderException Constructor : TmsAnnotationBadHeaderException Constructor(String,Exception)

Exception which allows passing in a message and inner exception when there are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public TmsAnnotationBadHeaderException(
   string message,
   Exception innerException
);
[C++]
public: TmsAnnotationBadHeaderException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
TmsAnnotationBadHeaderException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception.

See Also

TmsAnnotationBadHeaderException Class | TmsAnnotationBadHeaderException Members | Overload List


TmsAnnotationBadRecordException Class

TmsAnnotationBadRecordException Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadRecordException Class

PegasusImaging.WinForms.NotateXpress9 Namespace : TmsAnnotationBadRecordException Class

Exception class raised when all of the TMS annotation fields are not specified or a required field has no data.

For a list of all members of this type, see TmsAnnotationBadRecordException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.NotateXpress9.NotateXpressException
PegasusImaging.WinForms.NotateXpress9.TmsAnnotationBadRecordException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class TmsAnnotationBadRecordException
   Inherits NotateXpressException
   Implements ISerializable, _Exception
[C#]
[SerializableAttribute()]
public sealed class TmsAnnotationBadRecordException : NotateXpressException, ISerializable, _Exception
[C++]
[SerializableAttribute()]
public __gc __sealed class TmsAnnotationBadRecordException : public NotateXpressException, ISerializable, _Exception
[C++/CLI]
[SerializableAttribute()]
public ref class TmsAnnotationBadRecordException sealed : public NotateXpressException, ISerializable, _Exception

See Also

TmsAnnotationBadRecordException Members | PegasusImaging.WinForms.NotateXpress9 Namespace


TmsAnnotationBadRecordException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadRecordException Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : TmsAnnotationBadRecordException Class

TmsAnnotationBadRecordException overview

Public Constructors

Public Constructor TmsAnnotationBadRecordException Constructor Overloaded. Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

TmsAnnotationBadRecordException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


TmsAnnotationBadRecordException Constructor

TmsAnnotationBadRecordException Class | TmsAnnotationBadRecordException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadRecordException Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadRecordException Class : TmsAnnotationBadRecordException Constructor (TmsAnnotationBadRecordException)

Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

Overload List

Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

[Visual Basic] Public Sub New()

[C#] public TmsAnnotationBadRecordException();

[C++] public TmsAnnotationBadRecordException();

[C++/CLI] public TmsAnnotationBadRecordException();

Exception which allows passing in an error number when there are errors with the annotation files.

[Visual Basic] Public Sub New(Integer)

[C#] public TmsAnnotationBadRecordException(int);

[C++] public TmsAnnotationBadRecordException(int);

[C++/CLI] public TmsAnnotationBadRecordException(int);

Exception which allows passing in a message when thee are errors with the annotation files.

[Visual Basic] Public Sub New(String)

[C#] public TmsAnnotationBadRecordException(string);

[C++] public TmsAnnotationBadRecordException(string*);

[C++/CLI] public TmsAnnotationBadRecordException(String^);

Exception which allows passing in an error number and message when there are errors with the annotation files.

[Visual Basic] Public Sub New(Integer,String)

[C#] public TmsAnnotationBadRecordException(int,string);

[C++] public TmsAnnotationBadRecordException(int,string*);

[C++/CLI] public TmsAnnotationBadRecordException(int,String^);

Exception which allows passing in a message and inner exception when there are errors with the annotation files.

[Visual Basic] Public Sub New(String,Exception)

[C#] public TmsAnnotationBadRecordException(string,Exception);

[C++] public TmsAnnotationBadRecordException(string*,Exception*);

[C++/CLI] public TmsAnnotationBadRecordException(String^,Exception^);

See Also

TmsAnnotationBadRecordException Class | TmsAnnotationBadRecordException Members


TmsAnnotationBadRecordException Constructor()

TmsAnnotationBadRecordException Class | TmsAnnotationBadRecordException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadRecordException Constructor()

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadRecordException Class > TmsAnnotationBadRecordException Constructor : TmsAnnotationBadRecordException Constructor()

Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

[Visual Basic]
Public Function New()
[C#]
public TmsAnnotationBadRecordException();
[C++]
public: TmsAnnotationBadRecordException();
[C++/CLI]
public:
TmsAnnotationBadRecordException();

See Also

TmsAnnotationBadRecordException Class | TmsAnnotationBadRecordException Members | Overload List


TmsAnnotationBadRecordException Constructor(Int32)

TmsAnnotationBadRecordException Class | TmsAnnotationBadRecordException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadRecordException Constructor(Int32)

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadRecordException Class > TmsAnnotationBadRecordException Constructor : TmsAnnotationBadRecordException Constructor(Int32)

Exception which allows passing in an error number when there are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public TmsAnnotationBadRecordException(
   int errorNumber
);
[C++]
public: TmsAnnotationBadRecordException(
   int errorNumber
)
[C++/CLI]
public:
TmsAnnotationBadRecordException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

TmsAnnotationBadRecordException Class | TmsAnnotationBadRecordException Members | Overload List


TmsAnnotationBadRecordException Constructor(Int32,String)

TmsAnnotationBadRecordException Class | TmsAnnotationBadRecordException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadRecordException Constructor(Int32,String)

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadRecordException Class > TmsAnnotationBadRecordException Constructor : TmsAnnotationBadRecordException Constructor(Int32,String)

Exception which allows passing in an error number and message when there are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public TmsAnnotationBadRecordException(
   int errorNumber,
   string message
);
[C++]
public: TmsAnnotationBadRecordException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
TmsAnnotationBadRecordException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

TmsAnnotationBadRecordException Class | TmsAnnotationBadRecordException Members | Overload List


TmsAnnotationBadRecordException Constructor(String)

TmsAnnotationBadRecordException Class | TmsAnnotationBadRecordException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadRecordException Constructor(String)

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadRecordException Class > TmsAnnotationBadRecordException Constructor : TmsAnnotationBadRecordException Constructor(String)

Exception which allows passing in a message when thee are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public TmsAnnotationBadRecordException(
   string message
);
[C++]
public: TmsAnnotationBadRecordException(
   string* message
)
[C++/CLI]
public:
TmsAnnotationBadRecordException(
   String^ message
)

Parameters

message
A string which represents the message.

See Also

TmsAnnotationBadRecordException Class | TmsAnnotationBadRecordException Members | Overload List


TmsAnnotationBadRecordException Constructor(String,Exception)

TmsAnnotationBadRecordException Class | TmsAnnotationBadRecordException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadRecordException Constructor(String,Exception)

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadRecordException Class > TmsAnnotationBadRecordException Constructor : TmsAnnotationBadRecordException Constructor(String,Exception)

Exception which allows passing in a message and inner exception when there are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public TmsAnnotationBadRecordException(
   string message,
   Exception innerException
);
[C++]
public: TmsAnnotationBadRecordException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
TmsAnnotationBadRecordException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception.

See Also

TmsAnnotationBadRecordException Class | TmsAnnotationBadRecordException Members | Overload List


TmsAnnotationBadRedactionFlagException Class

TmsAnnotationBadRedactionFlagException Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadRedactionFlagException Class

PegasusImaging.WinForms.NotateXpress9 Namespace : TmsAnnotationBadRedactionFlagException Class

Exception class raised when the TMS annotation redaction flag is invalid.

For a list of all members of this type, see TmsAnnotationBadRedactionFlagException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.NotateXpress9.NotateXpressException
PegasusImaging.WinForms.NotateXpress9.TmsAnnotationBadRedactionFlagException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class TmsAnnotationBadRedactionFlagException
   Inherits NotateXpressException
   Implements ISerializable, _Exception
[C#]
[SerializableAttribute()]
public sealed class TmsAnnotationBadRedactionFlagException : NotateXpressException, ISerializable, _Exception
[C++]
[SerializableAttribute()]
public __gc __sealed class TmsAnnotationBadRedactionFlagException : public NotateXpressException, ISerializable, _Exception
[C++/CLI]
[SerializableAttribute()]
public ref class TmsAnnotationBadRedactionFlagException sealed : public NotateXpressException, ISerializable, _Exception

See Also

TmsAnnotationBadRedactionFlagException Members | PegasusImaging.WinForms.NotateXpress9 Namespace


TmsAnnotationBadRedactionFlagException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadRedactionFlagException Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : TmsAnnotationBadRedactionFlagException Class

TmsAnnotationBadRedactionFlagException overview

Public Constructors

Public Constructor TmsAnnotationBadRedactionFlagException Constructor Overloaded. Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

TmsAnnotationBadRedactionFlagException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


TmsAnnotationBadRedactionFlagException Constructor

TmsAnnotationBadRedactionFlagException Class | TmsAnnotationBadRedactionFlagException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadRedactionFlagException Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadRedactionFlagException Class : TmsAnnotationBadRedactionFlagException Constructor (TmsAnnotationBadRedactionFlagException)

Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

Overload List

Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

[Visual Basic] Public Sub New()

[C#] public TmsAnnotationBadRedactionFlagException();

[C++] public TmsAnnotationBadRedactionFlagException();

[C++/CLI] public TmsAnnotationBadRedactionFlagException();

Exception which allows passing in an error number when there are errors with the annotation files.

[Visual Basic] Public Sub New(Integer)

[C#] public TmsAnnotationBadRedactionFlagException(int);

[C++] public TmsAnnotationBadRedactionFlagException(int);

[C++/CLI] public TmsAnnotationBadRedactionFlagException(int);

Exception which allows passing in a message when thee are errors with the annotation files.

[Visual Basic] Public Sub New(String)

[C#] public TmsAnnotationBadRedactionFlagException(string);

[C++] public TmsAnnotationBadRedactionFlagException(string*);

[C++/CLI] public TmsAnnotationBadRedactionFlagException(String^);

Exception which allows passing in an error number and message when there are errors with the annotation files.

[Visual Basic] Public Sub New(Integer,String)

[C#] public TmsAnnotationBadRedactionFlagException(int,string);

[C++] public TmsAnnotationBadRedactionFlagException(int,string*);

[C++/CLI] public TmsAnnotationBadRedactionFlagException(int,String^);

Exception which allows passing in a message and inner exception when there are errors with the annotation files.

[Visual Basic] Public Sub New(String,Exception)

[C#] public TmsAnnotationBadRedactionFlagException(string,Exception);

[C++] public TmsAnnotationBadRedactionFlagException(string*,Exception*);

[C++/CLI] public TmsAnnotationBadRedactionFlagException(String^,Exception^);

See Also

TmsAnnotationBadRedactionFlagException Class | TmsAnnotationBadRedactionFlagException Members


TmsAnnotationBadRedactionFlagException Constructor()

TmsAnnotationBadRedactionFlagException Class | TmsAnnotationBadRedactionFlagException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadRedactionFlagException Constructor()

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadRedactionFlagException Class > TmsAnnotationBadRedactionFlagException Constructor : TmsAnnotationBadRedactionFlagException Constructor()

Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

[Visual Basic]
Public Function New()
[C#]
public TmsAnnotationBadRedactionFlagException();
[C++]
public: TmsAnnotationBadRedactionFlagException();
[C++/CLI]
public:
TmsAnnotationBadRedactionFlagException();

See Also

TmsAnnotationBadRedactionFlagException Class | TmsAnnotationBadRedactionFlagException Members | Overload List


TmsAnnotationBadRedactionFlagException Constructor(Int32)

TmsAnnotationBadRedactionFlagException Class | TmsAnnotationBadRedactionFlagException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadRedactionFlagException Constructor(Int32)

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadRedactionFlagException Class > TmsAnnotationBadRedactionFlagException Constructor : TmsAnnotationBadRedactionFlagException Constructor(Int32)

Exception which allows passing in an error number when there are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public TmsAnnotationBadRedactionFlagException(
   int errorNumber
);
[C++]
public: TmsAnnotationBadRedactionFlagException(
   int errorNumber
)
[C++/CLI]
public:
TmsAnnotationBadRedactionFlagException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

TmsAnnotationBadRedactionFlagException Class | TmsAnnotationBadRedactionFlagException Members | Overload List


TmsAnnotationBadRedactionFlagException Constructor(Int32,String)

TmsAnnotationBadRedactionFlagException Class | TmsAnnotationBadRedactionFlagException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadRedactionFlagException Constructor(Int32,String)

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadRedactionFlagException Class > TmsAnnotationBadRedactionFlagException Constructor : TmsAnnotationBadRedactionFlagException Constructor(Int32,String)

Exception which allows passing in an error number and message when there are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public TmsAnnotationBadRedactionFlagException(
   int errorNumber,
   string message
);
[C++]
public: TmsAnnotationBadRedactionFlagException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
TmsAnnotationBadRedactionFlagException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

TmsAnnotationBadRedactionFlagException Class | TmsAnnotationBadRedactionFlagException Members | Overload List


TmsAnnotationBadRedactionFlagException Constructor(String)

TmsAnnotationBadRedactionFlagException Class | TmsAnnotationBadRedactionFlagException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadRedactionFlagException Constructor(String)

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadRedactionFlagException Class > TmsAnnotationBadRedactionFlagException Constructor : TmsAnnotationBadRedactionFlagException Constructor(String)

Exception which allows passing in a message when thee are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public TmsAnnotationBadRedactionFlagException(
   string message
);
[C++]
public: TmsAnnotationBadRedactionFlagException(
   string* message
)
[C++/CLI]
public:
TmsAnnotationBadRedactionFlagException(
   String^ message
)

Parameters

message
A string which represents the message.

See Also

TmsAnnotationBadRedactionFlagException Class | TmsAnnotationBadRedactionFlagException Members | Overload List


TmsAnnotationBadRedactionFlagException Constructor(String,Exception)

TmsAnnotationBadRedactionFlagException Class | TmsAnnotationBadRedactionFlagException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadRedactionFlagException Constructor(String,Exception)

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadRedactionFlagException Class > TmsAnnotationBadRedactionFlagException Constructor : TmsAnnotationBadRedactionFlagException Constructor(String,Exception)

Exception which allows passing in a message and inner exception when there are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public TmsAnnotationBadRedactionFlagException(
   string message,
   Exception innerException
);
[C++]
public: TmsAnnotationBadRedactionFlagException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
TmsAnnotationBadRedactionFlagException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception.

See Also

TmsAnnotationBadRedactionFlagException Class | TmsAnnotationBadRedactionFlagException Members | Overload List


TmsAnnotationBadTransparentFlagException Class

TmsAnnotationBadTransparentFlagException Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadTransparentFlagException Class

PegasusImaging.WinForms.NotateXpress9 Namespace : TmsAnnotationBadTransparentFlagException Class

Exception class raised when the TMS annotation transparency flag is invalid.

For a list of all members of this type, see TmsAnnotationBadTransparentFlagException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.NotateXpress9.NotateXpressException
PegasusImaging.WinForms.NotateXpress9.TmsAnnotationBadTransparentFlagException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class TmsAnnotationBadTransparentFlagException
   Inherits NotateXpressException
   Implements ISerializable, _Exception
[C#]
[SerializableAttribute()]
public sealed class TmsAnnotationBadTransparentFlagException : NotateXpressException, ISerializable, _Exception
[C++]
[SerializableAttribute()]
public __gc __sealed class TmsAnnotationBadTransparentFlagException : public NotateXpressException, ISerializable, _Exception
[C++/CLI]
[SerializableAttribute()]
public ref class TmsAnnotationBadTransparentFlagException sealed : public NotateXpressException, ISerializable, _Exception

See Also

TmsAnnotationBadTransparentFlagException Members | PegasusImaging.WinForms.NotateXpress9 Namespace


TmsAnnotationBadTransparentFlagException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadTransparentFlagException Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : TmsAnnotationBadTransparentFlagException Class

TmsAnnotationBadTransparentFlagException overview

Public Constructors

Public Constructor TmsAnnotationBadTransparentFlagException Constructor Overloaded. Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

TmsAnnotationBadTransparentFlagException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


TmsAnnotationBadTransparentFlagException Constructor

TmsAnnotationBadTransparentFlagException Class | TmsAnnotationBadTransparentFlagException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadTransparentFlagException Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadTransparentFlagException Class : TmsAnnotationBadTransparentFlagException Constructor (TmsAnnotationBadTransparentFlagException)

Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

Overload List

Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

[Visual Basic] Public Sub New()

[C#] public TmsAnnotationBadTransparentFlagException();

[C++] public TmsAnnotationBadTransparentFlagException();

[C++/CLI] public TmsAnnotationBadTransparentFlagException();

Exception which allows passing in an error number when there are errors with the annotation files.

[Visual Basic] Public Sub New(Integer)

[C#] public TmsAnnotationBadTransparentFlagException(int);

[C++] public TmsAnnotationBadTransparentFlagException(int);

[C++/CLI] public TmsAnnotationBadTransparentFlagException(int);

Exception which allows passing in a message when thee are errors with the annotation files.

[Visual Basic] Public Sub New(String)

[C#] public TmsAnnotationBadTransparentFlagException(string);

[C++] public TmsAnnotationBadTransparentFlagException(string*);

[C++/CLI] public TmsAnnotationBadTransparentFlagException(String^);

Exception which allows passing in an error number and message when there are errors with the annotation files.

[Visual Basic] Public Sub New(Integer,String)

[C#] public TmsAnnotationBadTransparentFlagException(int,string);

[C++] public TmsAnnotationBadTransparentFlagException(int,string*);

[C++/CLI] public TmsAnnotationBadTransparentFlagException(int,String^);

Exception which allows passing in a message and inner exception when there are errors with the annotation files.

[Visual Basic] Public Sub New(String,Exception)

[C#] public TmsAnnotationBadTransparentFlagException(string,Exception);

[C++] public TmsAnnotationBadTransparentFlagException(string*,Exception*);

[C++/CLI] public TmsAnnotationBadTransparentFlagException(String^,Exception^);

See Also

TmsAnnotationBadTransparentFlagException Class | TmsAnnotationBadTransparentFlagException Members


TmsAnnotationBadTransparentFlagException Constructor()

TmsAnnotationBadTransparentFlagException Class | TmsAnnotationBadTransparentFlagException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadTransparentFlagException Constructor()

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadTransparentFlagException Class > TmsAnnotationBadTransparentFlagException Constructor : TmsAnnotationBadTransparentFlagException Constructor()

Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

[Visual Basic]
Public Function New()
[C#]
public TmsAnnotationBadTransparentFlagException();
[C++]
public: TmsAnnotationBadTransparentFlagException();
[C++/CLI]
public:
TmsAnnotationBadTransparentFlagException();

See Also

TmsAnnotationBadTransparentFlagException Class | TmsAnnotationBadTransparentFlagException Members | Overload List


TmsAnnotationBadTransparentFlagException Constructor(Int32)

TmsAnnotationBadTransparentFlagException Class | TmsAnnotationBadTransparentFlagException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadTransparentFlagException Constructor(Int32)

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadTransparentFlagException Class > TmsAnnotationBadTransparentFlagException Constructor : TmsAnnotationBadTransparentFlagException Constructor(Int32)

Exception which allows passing in an error number when there are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public TmsAnnotationBadTransparentFlagException(
   int errorNumber
);
[C++]
public: TmsAnnotationBadTransparentFlagException(
   int errorNumber
)
[C++/CLI]
public:
TmsAnnotationBadTransparentFlagException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

TmsAnnotationBadTransparentFlagException Class | TmsAnnotationBadTransparentFlagException Members | Overload List


TmsAnnotationBadTransparentFlagException Constructor(Int32,String)

TmsAnnotationBadTransparentFlagException Class | TmsAnnotationBadTransparentFlagException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadTransparentFlagException Constructor(Int32,String)

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadTransparentFlagException Class > TmsAnnotationBadTransparentFlagException Constructor : TmsAnnotationBadTransparentFlagException Constructor(Int32,String)

Exception which allows passing in an error number and message when there are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public TmsAnnotationBadTransparentFlagException(
   int errorNumber,
   string message
);
[C++]
public: TmsAnnotationBadTransparentFlagException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
TmsAnnotationBadTransparentFlagException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

TmsAnnotationBadTransparentFlagException Class | TmsAnnotationBadTransparentFlagException Members | Overload List


TmsAnnotationBadTransparentFlagException Constructor(String)

TmsAnnotationBadTransparentFlagException Class | TmsAnnotationBadTransparentFlagException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadTransparentFlagException Constructor(String)

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadTransparentFlagException Class > TmsAnnotationBadTransparentFlagException Constructor : TmsAnnotationBadTransparentFlagException Constructor(String)

Exception which allows passing in a message when thee are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public TmsAnnotationBadTransparentFlagException(
   string message
);
[C++]
public: TmsAnnotationBadTransparentFlagException(
   string* message
)
[C++/CLI]
public:
TmsAnnotationBadTransparentFlagException(
   String^ message
)

Parameters

message
A string which represents the message.

See Also

TmsAnnotationBadTransparentFlagException Class | TmsAnnotationBadTransparentFlagException Members | Overload List


TmsAnnotationBadTransparentFlagException Constructor(String,Exception)

TmsAnnotationBadTransparentFlagException Class | TmsAnnotationBadTransparentFlagException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadTransparentFlagException Constructor(String,Exception)

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadTransparentFlagException Class > TmsAnnotationBadTransparentFlagException Constructor : TmsAnnotationBadTransparentFlagException Constructor(String,Exception)

Exception which allows passing in a message and inner exception when there are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public TmsAnnotationBadTransparentFlagException(
   string message,
   Exception innerException
);
[C++]
public: TmsAnnotationBadTransparentFlagException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
TmsAnnotationBadTransparentFlagException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception.

See Also

TmsAnnotationBadTransparentFlagException Class | TmsAnnotationBadTransparentFlagException Members | Overload List


TmsAnnotationBadVersionException Class

TmsAnnotationBadVersionException Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadVersionException Class

PegasusImaging.WinForms.NotateXpress9 Namespace : TmsAnnotationBadVersionException Class

Exception class raised when the TMS annotation version is not supported.

For a list of all members of this type, see TmsAnnotationBadVersionException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.NotateXpress9.NotateXpressException
PegasusImaging.WinForms.NotateXpress9.TmsAnnotationBadVersionException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class TmsAnnotationBadVersionException
   Inherits NotateXpressException
   Implements ISerializable, _Exception
[C#]
[SerializableAttribute()]
public sealed class TmsAnnotationBadVersionException : NotateXpressException, ISerializable, _Exception
[C++]
[SerializableAttribute()]
public __gc __sealed class TmsAnnotationBadVersionException : public NotateXpressException, ISerializable, _Exception
[C++/CLI]
[SerializableAttribute()]
public ref class TmsAnnotationBadVersionException sealed : public NotateXpressException, ISerializable, _Exception

See Also

TmsAnnotationBadVersionException Members | PegasusImaging.WinForms.NotateXpress9 Namespace


TmsAnnotationBadVersionException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadVersionException Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : TmsAnnotationBadVersionException Class

TmsAnnotationBadVersionException overview

Public Constructors

Public Constructor TmsAnnotationBadVersionException Constructor Overloaded. Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

TmsAnnotationBadVersionException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


TmsAnnotationBadVersionException Constructor

TmsAnnotationBadVersionException Class | TmsAnnotationBadVersionException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadVersionException Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadVersionException Class : TmsAnnotationBadVersionException Constructor (TmsAnnotationBadVersionException)

Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

Overload List

Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

[Visual Basic] Public Sub New()

[C#] public TmsAnnotationBadVersionException();

[C++] public TmsAnnotationBadVersionException();

[C++/CLI] public TmsAnnotationBadVersionException();

Exception which allows passing in an error number when there are errors with the annotation files.

[Visual Basic] Public Sub New(Integer)

[C#] public TmsAnnotationBadVersionException(int);

[C++] public TmsAnnotationBadVersionException(int);

[C++/CLI] public TmsAnnotationBadVersionException(int);

Exception which allows passing in a message when thee are errors with the annotation files.

[Visual Basic] Public Sub New(String)

[C#] public TmsAnnotationBadVersionException(string);

[C++] public TmsAnnotationBadVersionException(string*);

[C++/CLI] public TmsAnnotationBadVersionException(String^);

Exception which allows passing in an error number and message when there are errors with the annotation files.

[Visual Basic] Public Sub New(Integer,String)

[C#] public TmsAnnotationBadVersionException(int,string);

[C++] public TmsAnnotationBadVersionException(int,string*);

[C++/CLI] public TmsAnnotationBadVersionException(int,String^);

Exception which allows passing in a message and inner exception when there are errors with the annotation files.

[Visual Basic] Public Sub New(String,Exception)

[C#] public TmsAnnotationBadVersionException(string,Exception);

[C++] public TmsAnnotationBadVersionException(string*,Exception*);

[C++/CLI] public TmsAnnotationBadVersionException(String^,Exception^);

See Also

TmsAnnotationBadVersionException Class | TmsAnnotationBadVersionException Members


TmsAnnotationBadVersionException Constructor()

TmsAnnotationBadVersionException Class | TmsAnnotationBadVersionException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadVersionException Constructor()

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadVersionException Class > TmsAnnotationBadVersionException Constructor : TmsAnnotationBadVersionException Constructor()

Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

[Visual Basic]
Public Function New()
[C#]
public TmsAnnotationBadVersionException();
[C++]
public: TmsAnnotationBadVersionException();
[C++/CLI]
public:
TmsAnnotationBadVersionException();

See Also

TmsAnnotationBadVersionException Class | TmsAnnotationBadVersionException Members | Overload List


TmsAnnotationBadVersionException Constructor(Int32)

TmsAnnotationBadVersionException Class | TmsAnnotationBadVersionException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadVersionException Constructor(Int32)

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadVersionException Class > TmsAnnotationBadVersionException Constructor : TmsAnnotationBadVersionException Constructor(Int32)

Exception which allows passing in an error number when there are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public TmsAnnotationBadVersionException(
   int errorNumber
);
[C++]
public: TmsAnnotationBadVersionException(
   int errorNumber
)
[C++/CLI]
public:
TmsAnnotationBadVersionException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

TmsAnnotationBadVersionException Class | TmsAnnotationBadVersionException Members | Overload List


TmsAnnotationBadVersionException Constructor(Int32,String)

TmsAnnotationBadVersionException Class | TmsAnnotationBadVersionException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadVersionException Constructor(Int32,String)

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadVersionException Class > TmsAnnotationBadVersionException Constructor : TmsAnnotationBadVersionException Constructor(Int32,String)

Exception which allows passing in an error number and message when there are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public TmsAnnotationBadVersionException(
   int errorNumber,
   string message
);
[C++]
public: TmsAnnotationBadVersionException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
TmsAnnotationBadVersionException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

TmsAnnotationBadVersionException Class | TmsAnnotationBadVersionException Members | Overload List


TmsAnnotationBadVersionException Constructor(String)

TmsAnnotationBadVersionException Class | TmsAnnotationBadVersionException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadVersionException Constructor(String)

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadVersionException Class > TmsAnnotationBadVersionException Constructor : TmsAnnotationBadVersionException Constructor(String)

Exception which allows passing in a message when thee are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public TmsAnnotationBadVersionException(
   string message
);
[C++]
public: TmsAnnotationBadVersionException(
   string* message
)
[C++/CLI]
public:
TmsAnnotationBadVersionException(
   String^ message
)

Parameters

message
A string which represents the message.

See Also

TmsAnnotationBadVersionException Class | TmsAnnotationBadVersionException Members | Overload List


TmsAnnotationBadVersionException Constructor(String,Exception)

TmsAnnotationBadVersionException Class | TmsAnnotationBadVersionException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadVersionException Constructor(String,Exception)

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadVersionException Class > TmsAnnotationBadVersionException Constructor : TmsAnnotationBadVersionException Constructor(String,Exception)

Exception which allows passing in a message and inner exception when there are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public TmsAnnotationBadVersionException(
   string message,
   Exception innerException
);
[C++]
public: TmsAnnotationBadVersionException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
TmsAnnotationBadVersionException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception.

See Also

TmsAnnotationBadVersionException Class | TmsAnnotationBadVersionException Members | Overload List


Toolbar Class

Toolbar Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Toolbar Class

PegasusImaging.WinForms.NotateXpress9 Namespace : Toolbar Class (PegasusImaging.WinForms.NotateXpress9)

This class implements methods and properties used to control the Toolbar.

For a list of all members of this type, see Toolbar members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.NotateXpress9.Toolbar

Syntax

[Visual Basic]
Public Class Toolbar
[C#]
public class Toolbar
[C++]
public __gc class Toolbar
[C++/CLI]
public ref class Toolbar

See Also

Toolbar Members | PegasusImaging.WinForms.NotateXpress9 Namespace


Toolbar Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Toolbar Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : Toolbar Class (PegasusImaging.WinForms.NotateXpress9)

Toolbar overview

Public Constructors

Public Constructor Toolbar Constructor Initializes a new instance of the Toolbar class.

Public Properties

Public Property BlockHighlightToolbarDefaults | Gets and sets the default settings of the Block Highlight tool.
Public Property ButtonToolbarDefaults | Gets and sets the default settings of the button tool.
Public Property EllipseToolbarDefaults | Gets and sets the default settings of the Ellipse tool.
Public Property Enabled | Gets and sets the enabled status of the toolbar.
Public Property FreehandToolbarDefaults | Gets and sets the default settings of the freehand tool.
Public Property ImageToolbarDefaults | Gets and sets the default settings for the image tool.
Public Property LineToolbarDefaults | Gets and sets the default settings of the line tool.
Public Property NoteToolbarDefaults | Gets and sets the default settings of the Note tool.
Public Property PolygonToolbarDefaults | Gets and sets the default settings of the polygon tool.
Public Property PolyLineToolbarDefaults | Gets and sets the default settings of the polyline tool.
Public Property RectangleToolbarDefaults | Gets and sets the default settings of the rectangle tool.
Public Property RulerToolbarDefaults | Gets and sets the default settings of the Ruler tool.
Public Property Selected | Gets and sets the tool that has been selected in the toolbar.
Public Property StampToolbarDefaults | Gets and sets the default settings of the stamp tool.
Public Property TextToolbarDefaults | Gets and sets the default settings of the text tool.
Public Property Visible | Gets and sets the toolbar's visible state.

Public Methods

Public Method GetToolEnabled | Returns the enabled status of the specified tool.
Public Method GetToolVisible | Determines a specific tool's visible state on the toolbar.
Public Method SetToolEnabled | Sets the enabled state of the given tool in the toolbar.
Public Method SetToolVisible | Sets the visible state of the tool.
Public Method ToolDelete | Deletes the specified tool from the toolbar.

See Also

Toolbar Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Toolbar Constructor

Toolbar Class | Toolbar Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Toolbar Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > Toolbar Class : Toolbar Constructor (Toolbar)

Initializes a new instance of the Toolbar class.

[Visual Basic]
Public Function New()
[C#]
public Toolbar();
[C++]
public: Toolbar();
[C++/CLI]
public:
Toolbar();

See Also

Toolbar Class | Toolbar Members


GetToolEnabled Method

Toolbar Class | Toolbar Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

tool
The AnnotationTool enumeration value.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetToolEnabled Method

PegasusImaging.WinForms.NotateXpress9 Namespace > Toolbar Class : GetToolEnabled Method

Returns the enabled status of the specified tool.

[Visual Basic]
Public Function GetToolEnabled( _
   ByVal tool As AnnotationTool _
) As Boolean
[C#]
public bool GetToolEnabled(
   AnnotationTool tool
);
[C++]
public: bool GetToolEnabled(
   AnnotationTool tool
)
[C++/CLI]
public:
bool GetToolEnabled(
   AnnotationTool tool
)

Parameters

tool
The AnnotationTool enumeration value.

Return Type

A boolean value which is true to enable the tool for application end-users. Otherwise, false is returned.

See Also

Toolbar Class | Toolbar Members


GetToolVisible Method

Toolbar Class | Toolbar Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

tool
The AnnotationTool enumeration value.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetToolVisible Method

PegasusImaging.WinForms.NotateXpress9 Namespace > Toolbar Class : GetToolVisible Method

Determines a specific tool's visible state on the toolbar.

[Visual Basic]
Public Function GetToolVisible( _
   ByVal tool As AnnotationTool _
) As Boolean
[C#]
public bool GetToolVisible(
   AnnotationTool tool
);
[C++]
public: bool GetToolVisible(
   AnnotationTool tool
)
[C++/CLI]
public:
bool GetToolVisible(
   AnnotationTool tool
)

Parameters

tool
The AnnotationTool enumeration value.

Return Type

A boolean value which is true for the tool to be visible in the toolbar to the application end-user. Otherwise, false is returned.

See Also

Toolbar Class | Toolbar Members


SetToolEnabled Method

Toolbar Class | Toolbar Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

tool
The AnnotationTool enumeration value to set the enabled state for.
enabled
A boolean value which should be set to true to enable to the tool and false to disable the tool and gray out the tool icon.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

SetToolEnabled Method

PegasusImaging.WinForms.NotateXpress9 Namespace > Toolbar Class : SetToolEnabled Method

Sets the enabled state of the given tool in the toolbar.

[Visual Basic]
Public Sub SetToolEnabled( _
   ByVal tool As AnnotationTool, _
   ByVal enabled As Boolean _
)
[C#]
public void SetToolEnabled(
   AnnotationTool tool,
   bool enabled
);
[C++]
public: void SetToolEnabled(
   AnnotationTool tool,
   bool enabled
)
[C++/CLI]
public:
void SetToolEnabled(
   AnnotationTool tool,
   bool enabled
)

Parameters

tool
The AnnotationTool enumeration value to set the enabled state for.
enabled
A boolean value which should be set to true to enable to the tool and false to disable the tool and gray out the tool icon.

See Also

Toolbar Class | Toolbar Members


SetToolVisible Method

Toolbar Class | Toolbar Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

tool
The AnnotationTool enumeration value.
visible
A boolean value which should be true to make the given tool visible in the toolbar to the application end-user. Otherwise, false should be set.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

SetToolVisible Method

PegasusImaging.WinForms.NotateXpress9 Namespace > Toolbar Class : SetToolVisible Method

Sets the visible state of the tool.

[Visual Basic]
Public Sub SetToolVisible( _
   ByVal tool As AnnotationTool, _
   ByVal visible As Boolean _
)
[C#]
public void SetToolVisible(
   AnnotationTool tool,
   bool visible
);
[C++]
public: void SetToolVisible(
   AnnotationTool tool,
   bool visible
)
[C++/CLI]
public:
void SetToolVisible(
   AnnotationTool tool,
   bool visible
)

Parameters

tool
The AnnotationTool enumeration value.
visible
A boolean value which should be true to make the given tool visible in the toolbar to the application end-user. Otherwise, false should be set.

See Also

Toolbar Class | Toolbar Members


ToolDelete Method

Toolbar Class | Toolbar Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

tool
An AnnotationTool value to delete from the toolbar.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToolDelete Method

PegasusImaging.WinForms.NotateXpress9 Namespace > Toolbar Class : ToolDelete Method

Deletes the specified tool from the toolbar.

[Visual Basic]
Public Sub ToolDelete( _
   ByVal tool As AnnotationTool _
)
[C#]
public void ToolDelete(
   AnnotationTool tool
);
[C++]
public: void ToolDelete(
   AnnotationTool tool
)
[C++/CLI]
public:
void ToolDelete(
   AnnotationTool tool
)

Parameters

tool
An AnnotationTool value to delete from the toolbar.

Remarks

When a tool is deleted from the toolbar, it is removed and no longer visible.

Future calls to GetToolEnabled will return false, and calls to GetToolVisible will return false.

See Also

Toolbar Class | Toolbar Members


Toolbar Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Toolbar Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : Toolbar Class (PegasusImaging.WinForms.NotateXpress9)

For a list of all members of this type, see Toolbar members.

Public Properties

Public Property BlockHighlightToolbarDefaults | Gets and sets the default settings of the Block Highlight tool.
Public Property ButtonToolbarDefaults | Gets and sets the default settings of the button tool.
Public Property EllipseToolbarDefaults | Gets and sets the default settings of the Ellipse tool.
Public Property Enabled | Gets and sets the enabled status of the toolbar.
Public Property FreehandToolbarDefaults | Gets and sets the default settings of the freehand tool.
Public Property ImageToolbarDefaults | Gets and sets the default settings for the image tool.
Public Property LineToolbarDefaults | Gets and sets the default settings of the line tool.
Public Property NoteToolbarDefaults | Gets and sets the default settings of the Note tool.
Public Property PolygonToolbarDefaults | Gets and sets the default settings of the polygon tool.
Public Property PolyLineToolbarDefaults | Gets and sets the default settings of the polyline tool.
Public Property RectangleToolbarDefaults | Gets and sets the default settings of the rectangle tool.
Public Property RulerToolbarDefaults | Gets and sets the default settings of the Ruler tool.
Public Property Selected | Gets and sets the tool that has been selected in the toolbar.
Public Property StampToolbarDefaults | Gets and sets the default settings of the stamp tool.
Public Property TextToolbarDefaults | Gets and sets the default settings of the text tool.
Public Property Visible | Gets and sets the toolbar's visible state.

See Also

Toolbar Class | PegasusImaging.WinForms.NotateXpress9 Namespace


BlockHighlightToolbarDefaults Property

Toolbar Class | Toolbar Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BlockHighlightToolbarDefaults Property

PegasusImaging.WinForms.NotateXpress9 Namespace > Toolbar Class : BlockHighlightToolbarDefaults Property (Toolbar)

Gets and sets the default settings of the Block Highlight tool.

[Visual Basic]
Public Property BlockHighlightToolbarDefaults As BlockHighlightToolbarDefaults
[C#]
public BlockHighlightToolbarDefaults BlockHighlightToolbarDefaults {get; set;}
[C++]
public: __property BlockHighlightToolbarDefaults* get_BlockHighlightToolbarDefaults();
public: __property void set_BlockHighlightToolbarDefaults(
   BlockHighlightToolbarDefaults* value
);
[C++/CLI]
public:
property BlockHighlightToolbarDefaults^ BlockHighlightToolbarDefaults {
   BlockHighlightToolbarDefaults^ get();
   void set (BlockHighlightToolbarDefaults^ value);
}

Value

The BlockHighlightToolbarDefaults default settings.

See Also

Toolbar Class | Toolbar Members


ButtonToolbarDefaults Property

Toolbar Class | Toolbar Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ButtonToolbarDefaults Property

PegasusImaging.WinForms.NotateXpress9 Namespace > Toolbar Class : ButtonToolbarDefaults Property (Toolbar)

Gets and sets the default settings of the button tool.

[Visual Basic]
Public Property ButtonToolbarDefaults As ButtonToolbarDefaults
[C#]
public ButtonToolbarDefaults ButtonToolbarDefaults {get; set;}
[C++]
public: __property ButtonToolbarDefaults* get_ButtonToolbarDefaults();
public: __property void set_ButtonToolbarDefaults(
   ButtonToolbarDefaults* value
);
[C++/CLI]
public:
property ButtonToolbarDefaults^ ButtonToolbarDefaults {
   ButtonToolbarDefaults^ get();
   void set (ButtonToolbarDefaults^ value);
}

Value

The ButtonToolbarDefaults default settings.

See Also

Toolbar Class | Toolbar Members


EllipseToolbarDefaults Property

Toolbar Class | Toolbar Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

EllipseToolbarDefaults Property

PegasusImaging.WinForms.NotateXpress9 Namespace > Toolbar Class : EllipseToolbarDefaults Property (Toolbar)

Gets and sets the default settings of the Ellipse tool.

[Visual Basic]
Public Property EllipseToolbarDefaults As EllipseToolbarDefaults
[C#]
public EllipseToolbarDefaults EllipseToolbarDefaults {get; set;}
[C++]
public: __property EllipseToolbarDefaults* get_EllipseToolbarDefaults();
public: __property void set_EllipseToolbarDefaults(
   EllipseToolbarDefaults* value
);
[C++/CLI]
public:
property EllipseToolbarDefaults^ EllipseToolbarDefaults {
   EllipseToolbarDefaults^ get();
   void set (EllipseToolbarDefaults^ value);
}

Value

The EllipseToolbarDefaults default settings.

See Also

Toolbar Class | Toolbar Members


Enabled Property

Toolbar Class | Toolbar Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Enabled Property

PegasusImaging.WinForms.NotateXpress9 Namespace > Toolbar Class : Enabled Property

Gets and sets the enabled status of the toolbar.

[Visual Basic]
Public Property Enabled As Boolean
[C#]
public bool Enabled {get; set;}
[C++]
public: __property bool get_Enabled();
public: __property void set_Enabled(
   bool value
);
[C++/CLI]
public:
property bool Enabled {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true when the toolbar is enabled and can be used by application end-users. Otherwise, false is returned and tool icons are grayed out.

See Also

Toolbar Class | Toolbar Members


FreehandToolbarDefaults Property

Toolbar Class | Toolbar Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

FreehandToolbarDefaults Property

PegasusImaging.WinForms.NotateXpress9 Namespace > Toolbar Class : FreehandToolbarDefaults Property (Toolbar)

Gets and sets the default settings of the freehand tool.

[Visual Basic]
Public Property FreehandToolbarDefaults As FreehandToolbarDefaults
[C#]
public FreehandToolbarDefaults FreehandToolbarDefaults {get; set;}
[C++]
public: __property FreehandToolbarDefaults* get_FreehandToolbarDefaults();
public: __property void set_FreehandToolbarDefaults(
   FreehandToolbarDefaults* value
);
[C++/CLI]
public:
property FreehandToolbarDefaults^ FreehandToolbarDefaults {
   FreehandToolbarDefaults^ get();
   void set (FreehandToolbarDefaults^ value);
}

Value

The FreehandToolbarDefaults default settings.

See Also

Toolbar Class | Toolbar Members


ImageToolbarDefaults Property

Toolbar Class | Toolbar Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ImageToolbarDefaults Property

PegasusImaging.WinForms.NotateXpress9 Namespace > Toolbar Class : ImageToolbarDefaults Property (Toolbar)

Gets and sets the default settings for the image tool.

[Visual Basic]
Public Property ImageToolbarDefaults As ImageToolbarDefaults
[C#]
public ImageToolbarDefaults ImageToolbarDefaults {get; set;}
[C++]
public: __property ImageToolbarDefaults* get_ImageToolbarDefaults();
public: __property void set_ImageToolbarDefaults(
   ImageToolbarDefaults* value
);
[C++/CLI]
public:
property ImageToolbarDefaults^ ImageToolbarDefaults {
   ImageToolbarDefaults^ get();
   void set (ImageToolbarDefaults^ value);
}

Value

The ImageToolbarDefaults default settings.

See Also

Toolbar Class | Toolbar Members


LineToolbarDefaults Property

Toolbar Class | Toolbar Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

LineToolbarDefaults Property

PegasusImaging.WinForms.NotateXpress9 Namespace > Toolbar Class : LineToolbarDefaults Property (Toolbar)

Gets and sets the default settings of the line tool.

[Visual Basic]
Public Property LineToolbarDefaults As LineToolbarDefaults
[C#]
public LineToolbarDefaults LineToolbarDefaults {get; set;}
[C++]
public: __property LineToolbarDefaults* get_LineToolbarDefaults();
public: __property void set_LineToolbarDefaults(
   LineToolbarDefaults* value
);
[C++/CLI]
public:
property LineToolbarDefaults^ LineToolbarDefaults {
   LineToolbarDefaults^ get();
   void set (LineToolbarDefaults^ value);
}

Value

The LineToolbarDefaults default settings.

See Also

Toolbar Class | Toolbar Members


NoteToolbarDefaults Property

Toolbar Class | Toolbar Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NoteToolbarDefaults Property

PegasusImaging.WinForms.NotateXpress9 Namespace > Toolbar Class : NoteToolbarDefaults Property (Toolbar)

Gets and sets the default settings of the Note tool.

[Visual Basic]
Public Property NoteToolbarDefaults As NoteToolbarDefaults
[C#]
public NoteToolbarDefaults NoteToolbarDefaults {get; set;}
[C++]
public: __property NoteToolbarDefaults* get_NoteToolbarDefaults();
public: __property void set_NoteToolbarDefaults(
   NoteToolbarDefaults* value
);
[C++/CLI]
public:
property NoteToolbarDefaults^ NoteToolbarDefaults {
   NoteToolbarDefaults^ get();
   void set (NoteToolbarDefaults^ value);
}

Value

The NoteToolbarDefaults default settings.

See Also

Toolbar Class | Toolbar Members


PolygonToolbarDefaults Property

Toolbar Class | Toolbar Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PolygonToolbarDefaults Property

PegasusImaging.WinForms.NotateXpress9 Namespace > Toolbar Class : PolygonToolbarDefaults Property (Toolbar)

Gets and sets the default settings of the polygon tool.

[Visual Basic]
Public Property PolygonToolbarDefaults As PolygonToolbarDefaults
[C#]
public PolygonToolbarDefaults PolygonToolbarDefaults {get; set;}
[C++]
public: __property PolygonToolbarDefaults* get_PolygonToolbarDefaults();
public: __property void set_PolygonToolbarDefaults(
   PolygonToolbarDefaults* value
);
[C++/CLI]
public:
property PolygonToolbarDefaults^ PolygonToolbarDefaults {
   PolygonToolbarDefaults^ get();
   void set (PolygonToolbarDefaults^ value);
}

Value

The PolygonToolbarDefaults default settings.

See Also

Toolbar Class | Toolbar Members


PolyLineToolbarDefaults Property

Toolbar Class | Toolbar Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PolyLineToolbarDefaults Property

PegasusImaging.WinForms.NotateXpress9 Namespace > Toolbar Class : PolyLineToolbarDefaults Property (Toolbar)

Gets and sets the default settings of the polyline tool.

[Visual Basic]
Public Property PolyLineToolbarDefaults As PolyLineToolbarDefaults
[C#]
public PolyLineToolbarDefaults PolyLineToolbarDefaults {get; set;}
[C++]
public: __property PolyLineToolbarDefaults* get_PolyLineToolbarDefaults();
public: __property void set_PolyLineToolbarDefaults(
   PolyLineToolbarDefaults* value
);
[C++/CLI]
public:
property PolyLineToolbarDefaults^ PolyLineToolbarDefaults {
   PolyLineToolbarDefaults^ get();
   void set (PolyLineToolbarDefaults^ value);
}

Value

The PolyLineToolbarDefaults default settings.

See Also

Toolbar Class | Toolbar Members


RectangleToolbarDefaults Property

Toolbar Class | Toolbar Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

RectangleToolbarDefaults Property

PegasusImaging.WinForms.NotateXpress9 Namespace > Toolbar Class : RectangleToolbarDefaults Property (Toolbar)

Gets and sets the default settings of the rectangle tool.

[Visual Basic]
Public Property RectangleToolbarDefaults As RectangleToolbarDefaults
[C#]
public RectangleToolbarDefaults RectangleToolbarDefaults {get; set;}
[C++]
public: __property RectangleToolbarDefaults* get_RectangleToolbarDefaults();
public: __property void set_RectangleToolbarDefaults(
   RectangleToolbarDefaults* value
);
[C++/CLI]
public:
property RectangleToolbarDefaults^ RectangleToolbarDefaults {
   RectangleToolbarDefaults^ get();
   void set (RectangleToolbarDefaults^ value);
}

Value

The RectangleToolbarDefaults default settings.

See Also

Toolbar Class | Toolbar Members


RulerToolbarDefaults Property

Toolbar Class | Toolbar Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

RulerToolbarDefaults Property

PegasusImaging.WinForms.NotateXpress9 Namespace > Toolbar Class : RulerToolbarDefaults Property (Toolbar)

Gets and sets the default settings of the Ruler tool.

[Visual Basic]
Public Property RulerToolbarDefaults As RulerToolbarDefaults
[C#]
public RulerToolbarDefaults RulerToolbarDefaults {get; set;}
[C++]
public: __property RulerToolbarDefaults* get_RulerToolbarDefaults();
public: __property void set_RulerToolbarDefaults(
   RulerToolbarDefaults* value
);
[C++/CLI]
public:
property RulerToolbarDefaults^ RulerToolbarDefaults {
   RulerToolbarDefaults^ get();
   void set (RulerToolbarDefaults^ value);
}

Value

The RulerToolbarDefaults default settings.

See Also

Toolbar Class | Toolbar Members


Selected Property

Toolbar Class | Toolbar Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Selected Property

PegasusImaging.WinForms.NotateXpress9 Namespace > Toolbar Class : Selected Property (Toolbar)

Gets and sets the tool that has been selected in the toolbar.

[Visual Basic]
Public Property Selected As AnnotationTool
[C#]
public AnnotationTool Selected {get; set;}
[C++]
public: __property AnnotationTool get_Selected();
public: __property void set_Selected(
   AnnotationTool value
);
[C++/CLI]
public:
property AnnotationTool Selected {
   AnnotationTool get();
   void set (AnnotationTool value);
}

Value

The AnnotationTool value set.

Remarks

This property gets and sets the currently selected tool.

See Also

Toolbar Class | Toolbar Members


StampToolbarDefaults Property

Toolbar Class | Toolbar Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StampToolbarDefaults Property

PegasusImaging.WinForms.NotateXpress9 Namespace > Toolbar Class : StampToolbarDefaults Property (Toolbar)

Gets and sets the default settings of the stamp tool.

[Visual Basic]
Public Property StampToolbarDefaults As StampToolbarDefaults
[C#]
public StampToolbarDefaults StampToolbarDefaults {get; set;}
[C++]
public: __property StampToolbarDefaults* get_StampToolbarDefaults();
public: __property void set_StampToolbarDefaults(
   StampToolbarDefaults* value
);
[C++/CLI]
public:
property StampToolbarDefaults^ StampToolbarDefaults {
   StampToolbarDefaults^ get();
   void set (StampToolbarDefaults^ value);
}

Value

The StampToolbarDefaults enumeration value set.

See Also

Toolbar Class | Toolbar Members


TextToolbarDefaults Property

Toolbar Class | Toolbar Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TextToolbarDefaults Property

PegasusImaging.WinForms.NotateXpress9 Namespace > Toolbar Class : TextToolbarDefaults Property (Toolbar)

Gets and sets the default settings of the text tool.

[Visual Basic]
Public Property TextToolbarDefaults As TextToolbarDefaults
[C#]
public TextToolbarDefaults TextToolbarDefaults {get; set;}
[C++]
public: __property TextToolbarDefaults* get_TextToolbarDefaults();
public: __property void set_TextToolbarDefaults(
   TextToolbarDefaults* value
);
[C++/CLI]
public:
property TextToolbarDefaults^ TextToolbarDefaults {
   TextToolbarDefaults^ get();
   void set (TextToolbarDefaults^ value);
}

Value

The TextToolbarDefaults default settings.

See Also

Toolbar Class | Toolbar Members


Visible Property

Toolbar Class | Toolbar Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Visible Property

PegasusImaging.WinForms.NotateXpress9 Namespace > Toolbar Class : Visible Property (Toolbar)

Gets and sets the toolbar's visible state.

[Visual Basic]
Public Property Visible As Boolean
[C#]
public bool Visible {get; set;}
[C++]
public: __property bool get_Visible();
public: __property void set_Visible(
   bool value
);
[C++/CLI]
public:
property bool Visible {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true when the toolbar is visible to the application end-user. Otherwise, false is returned.

See Also

Toolbar Class | Toolbar Members


ToolbarDefaults Class

ToolbarDefaults Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToolbarDefaults Class

PegasusImaging.WinForms.NotateXpress9 Namespace : ToolbarDefaults Class (PegasusImaging.WinForms.NotateXpress9)

This class implements methods and properties used to control the defaults for the built in NotateXpress Toolbar

For a list of all members of this type, see ToolbarDefaults members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.NotateXpress9.ToolbarDefaults

Syntax

[Visual Basic]
Public Class ToolbarDefaults
[C#]
public class ToolbarDefaults
[C++]
public __gc class ToolbarDefaults
[C++/CLI]
public ref class ToolbarDefaults

See Also

ToolbarDefaults Members | PegasusImaging.WinForms.NotateXpress9 Namespace


ToolbarDefaults Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToolbarDefaults Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : ToolbarDefaults Class (PegasusImaging.WinForms.NotateXpress9)

ToolbarDefaults overview

Public Constructors

Public Constructor ToolbarDefaults Constructor Initializes a new instance of the ToolbarDefaults class.

Public Properties

Public Property BlockHighlightToolbarDefaults | Gets and sets the default settings of the block highlight tool for the toolbar.
Public Property ButtonToolbarDefaults | Gets and sets the default settings of the button tool for the toolbar.
Public Property EllipseToolbarDefaults | Gets and sets the default settings of the ellipse tool for the toolbar.
Public Property FreehandToolbarDefaults | Gets and sets the default settings of the freehand tool for the toolbar.
Public Property ImageToolbarDefaults | Gets and sets the default settings of the image tool for the toolbar.
Public Property LineToolbarDefaults | Gets and sets the default settings of the line tool for the toolbar.
Public Property NoteToolbarDefaults | Gets and sets the default settings of the note tool for the toolbar.
Public Property PolygonToolbarDefaults | Gets and sets the default settings of the polygon tool for the toolbar.
Public Property PolyLineToolbarDefaults | Gets and sets the default settings of the polyline tool for the toolbar.
Public Property RectangleToolbarDefaults | Gets and sets the default settings of the rectangle tool for the toolbar.
Public Property RulerToolbarDefaults | Gets and sets the default settings of the ruler tool for the toolbar.
Public Property StampToolbarDefaults | Gets and sets the default settings of the toolbars stamp tool.
Public Property TextToolbarDefaults | Gets and sets the default settings of the text tool for the toolbar.
Public Property ToolbarActivated | Gets and sets whether the NotateXpress toolbar is available for use.
Public Property ToolbarHeight | Gets and sets the height of the toolbar.
Public Property ToolbarLargeIcons | Gets and sets if large (32x32) or small (24x24) icons are used in the toolbar.
Public Property ToolbarWidth | Gets and sets the width of the toolbar.
Public Property ToolbarWindowHandle | Gets the window handle of the toolbar.

Public Methods

Public Method GetToolTip | Gets the tooltip for the specified tool on the toolbar.
Public Method SetToolTip | Sets the given tooltip for the given tool on the toolbar.

See Also

ToolbarDefaults Class | PegasusImaging.WinForms.NotateXpress9 Namespace


ToolbarDefaults Constructor

ToolbarDefaults Class | ToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToolbarDefaults Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > ToolbarDefaults Class : ToolbarDefaults Constructor (ToolbarDefaults)

Initializes a new instance of the ToolbarDefaults class.

[Visual Basic]
Public Function New()
[C#]
public ToolbarDefaults();
[C++]
public: ToolbarDefaults();
[C++/CLI]
public:
ToolbarDefaults();

See Also

ToolbarDefaults Class | ToolbarDefaults Members


GetToolTip Method

ToolbarDefaults Class | ToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

tool
The AnnotationTool to get the tooltip for.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetToolTip Method

PegasusImaging.WinForms.NotateXpress9 Namespace > ToolbarDefaults Class : GetToolTip Method

Gets the tooltip for the specified tool on the toolbar.

[Visual Basic]
Public Function GetToolTip( _
   ByVal tool As AnnotationTool _
) As String
[C#]
public string GetToolTip(
   AnnotationTool tool
);
[C++]
public: string* GetToolTip(
   AnnotationTool tool
)
[C++/CLI]
public:
String^ GetToolTip(
   AnnotationTool tool
)

Parameters

tool
The AnnotationTool to get the tooltip for.

Return Type

A string which represents the tooltip.

See Also

ToolbarDefaults Class | ToolbarDefaults Members


SetToolTip Method

ToolbarDefaults Class | ToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

tool
The AnnotationTool to set the tooltip for.
toolTip
A string which represents the tool tip to set.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

SetToolTip Method

PegasusImaging.WinForms.NotateXpress9 Namespace > ToolbarDefaults Class : SetToolTip Method

Sets the given tooltip for the given tool on the toolbar.

[Visual Basic]
Public Sub SetToolTip( _
   ByVal tool As AnnotationTool, _
   ByVal toolTip As String _
)
[C#]
public void SetToolTip(
   AnnotationTool tool,
   string toolTip
);
[C++]
public: void SetToolTip(
   AnnotationTool tool,
   string* toolTip
)
[C++/CLI]
public:
void SetToolTip(
   AnnotationTool tool,
   String^ toolTip
)

Parameters

tool
The AnnotationTool to set the tooltip for.
toolTip
A string which represents the tool tip to set.

See Also

ToolbarDefaults Class | ToolbarDefaults Members


ToolbarDefaults Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToolbarDefaults Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : ToolbarDefaults Class (PegasusImaging.WinForms.NotateXpress9)

For a list of all members of this type, see ToolbarDefaults members.

Public Properties

Public Property BlockHighlightToolbarDefaults | Gets and sets the default settings of the block highlight tool for the toolbar.
Public Property ButtonToolbarDefaults | Gets and sets the default settings of the button tool for the toolbar.
Public Property EllipseToolbarDefaults | Gets and sets the default settings of the ellipse tool for the toolbar.
Public Property FreehandToolbarDefaults | Gets and sets the default settings of the freehand tool for the toolbar.
Public Property ImageToolbarDefaults | Gets and sets the default settings of the image tool for the toolbar.
Public Property LineToolbarDefaults | Gets and sets the default settings of the line tool for the toolbar.
Public Property NoteToolbarDefaults | Gets and sets the default settings of the note tool for the toolbar.
Public Property PolygonToolbarDefaults | Gets and sets the default settings of the polygon tool for the toolbar.
Public Property PolyLineToolbarDefaults | Gets and sets the default settings of the polyline tool for the toolbar.
Public Property RectangleToolbarDefaults | Gets and sets the default settings of the rectangle tool for the toolbar.
Public Property RulerToolbarDefaults | Gets and sets the default settings of the ruler tool for the toolbar.
Public Property StampToolbarDefaults | Gets and sets the default settings of the toolbars stamp tool.
Public Property TextToolbarDefaults | Gets and sets the default settings of the text tool for the toolbar.
Public Property ToolbarActivated | Gets and sets whether the NotateXpress toolbar is available for use.
Public Property ToolbarHeight | Gets and sets the height of the toolbar.
Public Property ToolbarLargeIcons | Gets and sets if large (32x32) or small (24x24) icons are used in the toolbar.
Public Property ToolbarWidth | Gets and sets the width of the toolbar.
Public Property ToolbarWindowHandle | Gets the window handle of the toolbar.

See Also

ToolbarDefaults Class | PegasusImaging.WinForms.NotateXpress9 Namespace


BlockHighlightToolbarDefaults Property

ToolbarDefaults Class | ToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BlockHighlightToolbarDefaults Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ToolbarDefaults Class : BlockHighlightToolbarDefaults Property (ToolbarDefaults)

Gets and sets the default settings of the block highlight tool for the toolbar.

[Visual Basic]
Public Property BlockHighlightToolbarDefaults As BlockHighlightToolbarDefaults
[C#]
public BlockHighlightToolbarDefaults BlockHighlightToolbarDefaults {get; set;}
[C++]
public: __property BlockHighlightToolbarDefaults* get_BlockHighlightToolbarDefaults();
public: __property void set_BlockHighlightToolbarDefaults(
   BlockHighlightToolbarDefaults* value
);
[C++/CLI]
public:
property BlockHighlightToolbarDefaults^ BlockHighlightToolbarDefaults {
   BlockHighlightToolbarDefaults^ get();
   void set (BlockHighlightToolbarDefaults^ value);
}

Value

The BlockHighlightToolbarDefaults default settings.

See Also

ToolbarDefaults Class | ToolbarDefaults Members


ButtonToolbarDefaults Property

ToolbarDefaults Class | ToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ButtonToolbarDefaults Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ToolbarDefaults Class : ButtonToolbarDefaults Property (ToolbarDefaults)

Gets and sets the default settings of the button tool for the toolbar.

[Visual Basic]
Public Property ButtonToolbarDefaults As ButtonToolbarDefaults
[C#]
public ButtonToolbarDefaults ButtonToolbarDefaults {get; set;}
[C++]
public: __property ButtonToolbarDefaults* get_ButtonToolbarDefaults();
public: __property void set_ButtonToolbarDefaults(
   ButtonToolbarDefaults* value
);
[C++/CLI]
public:
property ButtonToolbarDefaults^ ButtonToolbarDefaults {
   ButtonToolbarDefaults^ get();
   void set (ButtonToolbarDefaults^ value);
}

Value

The ButtonToolbarDefaults default settings.

See Also

ToolbarDefaults Class | ToolbarDefaults Members


EllipseToolbarDefaults Property

ToolbarDefaults Class | ToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

EllipseToolbarDefaults Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ToolbarDefaults Class : EllipseToolbarDefaults Property (ToolbarDefaults)

Gets and sets the default settings of the ellipse tool for the toolbar.

[Visual Basic]
Public Property EllipseToolbarDefaults As EllipseToolbarDefaults
[C#]
public EllipseToolbarDefaults EllipseToolbarDefaults {get; set;}
[C++]
public: __property EllipseToolbarDefaults* get_EllipseToolbarDefaults();
public: __property void set_EllipseToolbarDefaults(
   EllipseToolbarDefaults* value
);
[C++/CLI]
public:
property EllipseToolbarDefaults^ EllipseToolbarDefaults {
   EllipseToolbarDefaults^ get();
   void set (EllipseToolbarDefaults^ value);
}

Value

The EllipseToolbarDefaults default settings.

See Also

ToolbarDefaults Class | ToolbarDefaults Members


FreehandToolbarDefaults Property

ToolbarDefaults Class | ToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

FreehandToolbarDefaults Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ToolbarDefaults Class : FreehandToolbarDefaults Property (ToolbarDefaults)

Gets and sets the default settings of the freehand tool for the toolbar.

[Visual Basic]
Public Property FreehandToolbarDefaults As FreehandToolbarDefaults
[C#]
public FreehandToolbarDefaults FreehandToolbarDefaults {get; set;}
[C++]
public: __property FreehandToolbarDefaults* get_FreehandToolbarDefaults();
public: __property void set_FreehandToolbarDefaults(
   FreehandToolbarDefaults* value
);
[C++/CLI]
public:
property FreehandToolbarDefaults^ FreehandToolbarDefaults {
   FreehandToolbarDefaults^ get();
   void set (FreehandToolbarDefaults^ value);
}

Value

The FreehandToolbarDefaults default settings.

See Also

ToolbarDefaults Class | ToolbarDefaults Members


ImageToolbarDefaults Property

ToolbarDefaults Class | ToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ImageToolbarDefaults Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ToolbarDefaults Class : ImageToolbarDefaults Property (ToolbarDefaults)

Gets and sets the default settings of the image tool for the toolbar.

[Visual Basic]
Public Property ImageToolbarDefaults As ImageToolbarDefaults
[C#]
public ImageToolbarDefaults ImageToolbarDefaults {get; set;}
[C++]
public: __property ImageToolbarDefaults* get_ImageToolbarDefaults();
public: __property void set_ImageToolbarDefaults(
   ImageToolbarDefaults* value
);
[C++/CLI]
public:
property ImageToolbarDefaults^ ImageToolbarDefaults {
   ImageToolbarDefaults^ get();
   void set (ImageToolbarDefaults^ value);
}

Value

The ImageToolbarDefaults default settings.

See Also

ToolbarDefaults Class | ToolbarDefaults Members


LineToolbarDefaults Property

ToolbarDefaults Class | ToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

LineToolbarDefaults Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ToolbarDefaults Class : LineToolbarDefaults Property (ToolbarDefaults)

Gets and sets the default settings of the line tool for the toolbar.

[Visual Basic]
Public Property LineToolbarDefaults As LineToolbarDefaults
[C#]
public LineToolbarDefaults LineToolbarDefaults {get; set;}
[C++]
public: __property LineToolbarDefaults* get_LineToolbarDefaults();
public: __property void set_LineToolbarDefaults(
   LineToolbarDefaults* value
);
[C++/CLI]
public:
property LineToolbarDefaults^ LineToolbarDefaults {
   LineToolbarDefaults^ get();
   void set (LineToolbarDefaults^ value);
}

Value

The LineToolbarDefaults default settings.

See Also

ToolbarDefaults Class | ToolbarDefaults Members


NoteToolbarDefaults Property

ToolbarDefaults Class | ToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NoteToolbarDefaults Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ToolbarDefaults Class : NoteToolbarDefaults Property (ToolbarDefaults)

Gets and sets the default settings of the note tool for the toolbar.

[Visual Basic]
Public Property NoteToolbarDefaults As NoteToolbarDefaults
[C#]
public NoteToolbarDefaults NoteToolbarDefaults {get; set;}
[C++]
public: __property NoteToolbarDefaults* get_NoteToolbarDefaults();
public: __property void set_NoteToolbarDefaults(
   NoteToolbarDefaults* value
);
[C++/CLI]
public:
property NoteToolbarDefaults^ NoteToolbarDefaults {
   NoteToolbarDefaults^ get();
   void set (NoteToolbarDefaults^ value);
}

Value

The NoteToolbarDefaults default settings.

See Also

ToolbarDefaults Class | ToolbarDefaults Members


PolygonToolbarDefaults Property

ToolbarDefaults Class | ToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PolygonToolbarDefaults Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ToolbarDefaults Class : PolygonToolbarDefaults Property (ToolbarDefaults)

Gets and sets the default settings of the polygon tool for the toolbar.

[Visual Basic]
Public Property PolygonToolbarDefaults As PolygonToolbarDefaults
[C#]
public PolygonToolbarDefaults PolygonToolbarDefaults {get; set;}
[C++]
public: __property PolygonToolbarDefaults* get_PolygonToolbarDefaults();
public: __property void set_PolygonToolbarDefaults(
   PolygonToolbarDefaults* value
);
[C++/CLI]
public:
property PolygonToolbarDefaults^ PolygonToolbarDefaults {
   PolygonToolbarDefaults^ get();
   void set (PolygonToolbarDefaults^ value);
}

Value

The PolygonToolbarDefaults default settings.

See Also

ToolbarDefaults Class | ToolbarDefaults Members


PolyLineToolbarDefaults Property

ToolbarDefaults Class | ToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PolyLineToolbarDefaults Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ToolbarDefaults Class : PolyLineToolbarDefaults Property (ToolbarDefaults)

Gets and sets the default settings of the polyline tool for the toolbar.

[Visual Basic]
Public Property PolyLineToolbarDefaults As PolyLineToolbarDefaults
[C#]
public PolyLineToolbarDefaults PolyLineToolbarDefaults {get; set;}
[C++]
public: __property PolyLineToolbarDefaults* get_PolyLineToolbarDefaults();
public: __property void set_PolyLineToolbarDefaults(
   PolyLineToolbarDefaults* value
);
[C++/CLI]
public:
property PolyLineToolbarDefaults^ PolyLineToolbarDefaults {
   PolyLineToolbarDefaults^ get();
   void set (PolyLineToolbarDefaults^ value);
}

Value

The PolyLineToolbarDefaults default settings.

See Also

ToolbarDefaults Class | ToolbarDefaults Members


RectangleToolbarDefaults Property

ToolbarDefaults Class | ToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

RectangleToolbarDefaults Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ToolbarDefaults Class : RectangleToolbarDefaults Property (ToolbarDefaults)

Gets and sets the default settings of the rectangle tool for the toolbar.

[Visual Basic]
Public Property RectangleToolbarDefaults As RectangleToolbarDefaults
[C#]
public RectangleToolbarDefaults RectangleToolbarDefaults {get; set;}
[C++]
public: __property RectangleToolbarDefaults* get_RectangleToolbarDefaults();
public: __property void set_RectangleToolbarDefaults(
   RectangleToolbarDefaults* value
);
[C++/CLI]
public:
property RectangleToolbarDefaults^ RectangleToolbarDefaults {
   RectangleToolbarDefaults^ get();
   void set (RectangleToolbarDefaults^ value);
}

Value

The RectangleToolbarDefaults default settings.

See Also

ToolbarDefaults Class | ToolbarDefaults Members


RulerToolbarDefaults Property

ToolbarDefaults Class | ToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

RulerToolbarDefaults Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ToolbarDefaults Class : RulerToolbarDefaults Property (ToolbarDefaults)

Gets and sets the default settings of the ruler tool for the toolbar.

[Visual Basic]
Public Property RulerToolbarDefaults As RulerToolbarDefaults
[C#]
public RulerToolbarDefaults RulerToolbarDefaults {get; set;}
[C++]
public: __property RulerToolbarDefaults* get_RulerToolbarDefaults();
public: __property void set_RulerToolbarDefaults(
   RulerToolbarDefaults* value
);
[C++/CLI]
public:
property RulerToolbarDefaults^ RulerToolbarDefaults {
   RulerToolbarDefaults^ get();
   void set (RulerToolbarDefaults^ value);
}

Value

The RulerToolbarDefaults default settings.

See Also

ToolbarDefaults Class | ToolbarDefaults Members


StampToolbarDefaults Property

ToolbarDefaults Class | ToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StampToolbarDefaults Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ToolbarDefaults Class : StampToolbarDefaults Property (ToolbarDefaults)

Gets and sets the default settings of the toolbars stamp tool.

[Visual Basic]
Public Property StampToolbarDefaults As StampToolbarDefaults
[C#]
public StampToolbarDefaults StampToolbarDefaults {get; set;}
[C++]
public: __property StampToolbarDefaults* get_StampToolbarDefaults();
public: __property void set_StampToolbarDefaults(
   StampToolbarDefaults* value
);
[C++/CLI]
public:
property StampToolbarDefaults^ StampToolbarDefaults {
   StampToolbarDefaults^ get();
   void set (StampToolbarDefaults^ value);
}

Value

The StampToolbarDefaults default settings.

See Also

ToolbarDefaults Class | ToolbarDefaults Members


TextToolbarDefaults Property

ToolbarDefaults Class | ToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TextToolbarDefaults Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ToolbarDefaults Class : TextToolbarDefaults Property (ToolbarDefaults)

Gets and sets the default settings of the text tool for the toolbar.

[Visual Basic]
Public Property TextToolbarDefaults As TextToolbarDefaults
[C#]
public TextToolbarDefaults TextToolbarDefaults {get; set;}
[C++]
public: __property TextToolbarDefaults* get_TextToolbarDefaults();
public: __property void set_TextToolbarDefaults(
   TextToolbarDefaults* value
);
[C++/CLI]
public:
property TextToolbarDefaults^ TextToolbarDefaults {
   TextToolbarDefaults^ get();
   void set (TextToolbarDefaults^ value);
}

Value

The TextToolbarDefaults default settings.

See Also

ToolbarDefaults Class | ToolbarDefaults Members


ToolbarActivated Property

ToolbarDefaults Class | ToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToolbarActivated Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ToolbarDefaults Class : ToolbarActivated Property

Gets and sets whether the NotateXpress toolbar is available for use.

[Visual Basic]
Public Property ToolbarActivated As Boolean
[C#]
public bool ToolbarActivated {get; set;}
[C++]
public: __property bool get_ToolbarActivated();
public: __property void set_ToolbarActivated(
   bool value
);
[C++/CLI]
public:
property bool ToolbarActivated {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true if the toolbar is available for use. Otherwise, false is returned.

Remarks

The default value is true.

Note: If you do not intend to use the toolbar, setting this property to false conserves system resources.

See Also

ToolbarDefaults Class | ToolbarDefaults Members


ToolbarHeight Property

ToolbarDefaults Class | ToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToolbarHeight Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ToolbarDefaults Class : ToolbarHeight Property

Gets and sets the height of the toolbar.

[Visual Basic]
Public Property ToolbarHeight As Integer
[C#]
public int ToolbarHeight {get; set;}
[C++]
public: __property int get_ToolbarHeight();
public: __property void set_ToolbarHeight(
   int value
);
[C++/CLI]
public:
property int ToolbarHeight {
   int get();
   void set (int value);
}

Value

An integer which represents the height of the toolbar measured in tools.

See Also

ToolbarDefaults Class | ToolbarDefaults Members


ToolbarLargeIcons Property

ToolbarDefaults Class | ToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToolbarLargeIcons Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ToolbarDefaults Class : ToolbarLargeIcons Property

Gets and sets if large (32x32) or small (24x24) icons are used in the toolbar.

[Visual Basic]
Public Property ToolbarLargeIcons As Boolean
[C#]
public bool ToolbarLargeIcons {get; set;}
[C++]
public: __property bool get_ToolbarLargeIcons();
public: __property void set_ToolbarLargeIcons(
   bool value
);
[C++/CLI]
public:
property bool ToolbarLargeIcons {
   bool get();
   void set (bool value);
}

Value

A boolean value which is true if large icons are used in the toolbar. Otherwise, false is returned.

See Also

ToolbarDefaults Class | ToolbarDefaults Members


ToolbarWidth Property

ToolbarDefaults Class | ToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToolbarWidth Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ToolbarDefaults Class : ToolbarWidth Property

Gets and sets the width of the toolbar.

[Visual Basic]
Public Property ToolbarWidth As Integer
[C#]
public int ToolbarWidth {get; set;}
[C++]
public: __property int get_ToolbarWidth();
public: __property void set_ToolbarWidth(
   int value
);
[C++/CLI]
public:
property int ToolbarWidth {
   int get();
   void set (int value);
}

Value

An integer which represents the width of the toolbar measured in tools.

See Also

ToolbarDefaults Class | ToolbarDefaults Members


ToolbarWindowHandle Property

ToolbarDefaults Class | ToolbarDefaults Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToolbarWindowHandle Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ToolbarDefaults Class : ToolbarWindowHandle Property

Gets the window handle of the toolbar.

[Visual Basic]
Public Property ToolbarWindowHandle As Integer
[C#]
public int ToolbarWindowHandle {get; set;}
[C++]
public: __property int get_ToolbarWindowHandle();
public: __property void set_ToolbarWindowHandle(
   int value
);
[C++/CLI]
public:
property int ToolbarWindowHandle {
   int get();
   void set (int value);
}

Value

An integer which represents the window handle of the toolbar.

Remarks

Since NotateXpress works hard to keep the toolbar synchronized with the state of the control, you should restrict your manipulation of the window to such things as repositioning it.

See Also

ToolbarDefaults Class | ToolbarDefaults Members


ToolbarEventArgs Class

ToolbarEventArgs Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToolbarEventArgs Class

PegasusImaging.WinForms.NotateXpress9 Namespace : ToolbarEventArgs Class

Arguments for ToolbarSelect event

For a list of all members of this type, see ToolbarEventArgs members.

Object Model

Inheritance Hierarchy

System.Object
System.EventArgs
PegasusImaging.WinForms.NotateXpress9.ToolbarEventArgs

Syntax

[Visual Basic]
Public Class ToolbarEventArgs
   Inherits EventArgs
[C#]
public class ToolbarEventArgs : EventArgs
[C++]
public __gc class ToolbarEventArgs : public EventArgs
[C++/CLI]
public ref class ToolbarEventArgs : public EventArgs

See Also

ToolbarEventArgs Members | PegasusImaging.WinForms.NotateXpress9 Namespace


ToolbarEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToolbarEventArgs Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : ToolbarEventArgs Class

ToolbarEventArgs overview

Public Constructors

Public Constructor ToolbarEventArgs Constructor

Public Properties

Public Property Layer | Gets the current layer.
Public Property Tool | Gets the active tool.

See Also

ToolbarEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace


ToolbarEventArgs Constructor

ToolbarEventArgs Class | ToolbarEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToolbarEventArgs Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > ToolbarEventArgs Class : ToolbarEventArgs Constructor (ToolbarEventArgs)
[Visual Basic]
Public Function New()
[C#]
public ToolbarEventArgs();
[C++]
public: ToolbarEventArgs();
[C++/CLI]
public:
ToolbarEventArgs();

See Also

ToolbarEventArgs Class | ToolbarEventArgs Members


ToolbarEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToolbarEventArgs Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : ToolbarEventArgs Class

For a list of all members of this type, see ToolbarEventArgs members.

Public Properties

Public Property Layer | Gets the current layer.
Public Property Tool | Gets the active tool.

See Also

ToolbarEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Layer Property

ToolbarEventArgs Class | ToolbarEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Layer Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ToolbarEventArgs Class : Layer Property (ToolbarEventArgs)

Gets the current layer.

[Visual Basic]
Public Property Layer As Layer
[C#]
public Layer Layer {get; set;}
[C++]
public: __property Layer* get_Layer();
public: __property void set_Layer(
   Layer* value
);
[C++/CLI]
public:
property Layer^ Layer {
   Layer^ get();
   void set (Layer^ value);
}

Remarks

The Layer.

See Also

ToolbarEventArgs Class | ToolbarEventArgs Members


Tool Property

ToolbarEventArgs Class | ToolbarEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Tool Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ToolbarEventArgs Class : Tool Property (ToolbarEventArgs)

Gets the active tool.

[Visual Basic]
Public Property Tool As AnnotationTool
[C#]
public AnnotationTool Tool {get; set;}
[C++]
public: __property AnnotationTool get_Tool();
public: __property void set_Tool(
   AnnotationTool value
);
[C++/CLI]
public:
property AnnotationTool Tool {
   AnnotationTool get();
   void set (AnnotationTool value);
}

Remarks

The AnnotationTool.

See Also

ToolbarEventArgs Class | ToolbarEventArgs Members


UnableLoadAnnotationDllException Class

UnableLoadAnnotationDllException Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

UnableLoadAnnotationDllException Class

PegasusImaging.WinForms.NotateXpress9 Namespace : UnableLoadAnnotationDllException Class

Base exception class raised when unable to load assembly dll.

For a list of all members of this type, see UnableLoadAnnotationDllException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.NotateXpress9.NotateXpressException
PegasusImaging.WinForms.NotateXpress9.UnableLoadAnnotationDllException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class UnableLoadAnnotationDllException
   Inherits NotateXpressException
   Implements ISerializable, _Exception
[C#]
[SerializableAttribute()]
public sealed class UnableLoadAnnotationDllException : NotateXpressException, ISerializable, _Exception
[C++]
[SerializableAttribute()]
public __gc __sealed class UnableLoadAnnotationDllException : public NotateXpressException, ISerializable, _Exception
[C++/CLI]
[SerializableAttribute()]
public ref class UnableLoadAnnotationDllException sealed : public NotateXpressException, ISerializable, _Exception

See Also

UnableLoadAnnotationDllException Members | PegasusImaging.WinForms.NotateXpress9 Namespace


UnableLoadAnnotationDllException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

UnableLoadAnnotationDllException Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : UnableLoadAnnotationDllException Class

UnableLoadAnnotationDllException overview

Public Constructors

Public Constructor UnableLoadAnnotationDllException Constructor Overloaded. Base exception constructor when unable to load assembly dll.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

UnableLoadAnnotationDllException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


UnableLoadAnnotationDllException Constructor

UnableLoadAnnotationDllException Class | UnableLoadAnnotationDllException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

UnableLoadAnnotationDllException Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > UnableLoadAnnotationDllException Class : UnableLoadAnnotationDllException Constructor (UnableLoadAnnotationDllException)

Base exception constructor when unable to load assembly dll.

Overload List

Base exception constructor when unable to load assembly dll.

[Visual Basic] Public Sub New()

[C#] public UnableLoadAnnotationDllException();

[C++] public UnableLoadAnnotationDllException();

[C++/CLI] public UnableLoadAnnotationDllException();

Exception which allows passing in an error number when unable to load the assembly dll.

[Visual Basic] Public Sub New(Integer)

[C#] public UnableLoadAnnotationDllException(int);

[C++] public UnableLoadAnnotationDllException(int);

[C++/CLI] public UnableLoadAnnotationDllException(int);

Exception which allows passing in a message when unable to load the assembly dll.

[Visual Basic] Public Sub New(String)

[C#] public UnableLoadAnnotationDllException(string);

[C++] public UnableLoadAnnotationDllException(string*);

[C++/CLI] public UnableLoadAnnotationDllException(String^);

Exception which allows passing in an error number and message when unable to load the assembly dll.

[Visual Basic] Public Sub New(Integer,String)

[C#] public UnableLoadAnnotationDllException(int,string);

[C++] public UnableLoadAnnotationDllException(int,string*);

[C++/CLI] public UnableLoadAnnotationDllException(int,String^);

Exception which allows passing in a message and inner exception when unable to load the assembly dll.

[Visual Basic] Public Sub New(String,Exception)

[C#] public UnableLoadAnnotationDllException(string,Exception);

[C++] public UnableLoadAnnotationDllException(string*,Exception*);

[C++/CLI] public UnableLoadAnnotationDllException(String^,Exception^);

See Also

UnableLoadAnnotationDllException Class | UnableLoadAnnotationDllException Members


UnableLoadAnnotationDllException Constructor()

UnableLoadAnnotationDllException Class | UnableLoadAnnotationDllException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

UnableLoadAnnotationDllException Constructor()

PegasusImaging.WinForms.NotateXpress9 Namespace > UnableLoadAnnotationDllException Class > UnableLoadAnnotationDllException Constructor : UnableLoadAnnotationDllException Constructor()

Base exception constructor when unable to load assembly dll.

[Visual Basic]
Public Function New()
[C#]
public UnableLoadAnnotationDllException();
[C++]
public: UnableLoadAnnotationDllException();
[C++/CLI]
public:
UnableLoadAnnotationDllException();

See Also

UnableLoadAnnotationDllException Class | UnableLoadAnnotationDllException Members | Overload List


UnableLoadAnnotationDllException Constructor(Int32)

UnableLoadAnnotationDllException Class | UnableLoadAnnotationDllException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

UnableLoadAnnotationDllException Constructor(Int32)

PegasusImaging.WinForms.NotateXpress9 Namespace > UnableLoadAnnotationDllException Class > UnableLoadAnnotationDllException Constructor : UnableLoadAnnotationDllException Constructor(Int32)

Exception which allows passing in an error number when unable to load the assembly dll.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public UnableLoadAnnotationDllException(
   int errorNumber
);
[C++]
public: UnableLoadAnnotationDllException(
   int errorNumber
)
[C++/CLI]
public:
UnableLoadAnnotationDllException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

UnableLoadAnnotationDllException Class | UnableLoadAnnotationDllException Members | Overload List


UnableLoadAnnotationDllException Constructor(Int32,String)

UnableLoadAnnotationDllException Class | UnableLoadAnnotationDllException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

UnableLoadAnnotationDllException Constructor(Int32,String)

PegasusImaging.WinForms.NotateXpress9 Namespace > UnableLoadAnnotationDllException Class > UnableLoadAnnotationDllException Constructor : UnableLoadAnnotationDllException Constructor(Int32,String)

Exception which allows passing in an error number and message when unable to load the assembly dll.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public UnableLoadAnnotationDllException(
   int errorNumber,
   string message
);
[C++]
public: UnableLoadAnnotationDllException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
UnableLoadAnnotationDllException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

UnableLoadAnnotationDllException Class | UnableLoadAnnotationDllException Members | Overload List


UnableLoadAnnotationDllException Constructor(String)

UnableLoadAnnotationDllException Class | UnableLoadAnnotationDllException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

UnableLoadAnnotationDllException Constructor(String)

PegasusImaging.WinForms.NotateXpress9 Namespace > UnableLoadAnnotationDllException Class > UnableLoadAnnotationDllException Constructor : UnableLoadAnnotationDllException Constructor(String)

Exception which allows passing in a message when unable to load the assembly dll.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public UnableLoadAnnotationDllException(
   string message
);
[C++]
public: UnableLoadAnnotationDllException(
   string* message
)
[C++/CLI]
public:
UnableLoadAnnotationDllException(
   String^ message
)

Parameters

message
A string which represents the message.

See Also

UnableLoadAnnotationDllException Class | UnableLoadAnnotationDllException Members | Overload List


UnableLoadAnnotationDllException Constructor(String,Exception)

UnableLoadAnnotationDllException Class | UnableLoadAnnotationDllException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

UnableLoadAnnotationDllException Constructor(String,Exception)

PegasusImaging.WinForms.NotateXpress9 Namespace > UnableLoadAnnotationDllException Class > UnableLoadAnnotationDllException Constructor : UnableLoadAnnotationDllException Constructor(String,Exception)

Exception which allows passing in a message and inner exception when unable to load the assembly dll.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public UnableLoadAnnotationDllException(
   string message,
   Exception innerException
);
[C++]
public: UnableLoadAnnotationDllException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
UnableLoadAnnotationDllException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception.

See Also

UnableLoadAnnotationDllException Class | UnableLoadAnnotationDllException Members | Overload List


UnableToCreateStorageException Class

UnableToCreateStorageException Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

UnableToCreateStorageException Class

PegasusImaging.WinForms.NotateXpress9 Namespace : UnableToCreateStorageException Class

Exception class which is raised when there are errors creating storage.

For a list of all members of this type, see UnableToCreateStorageException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.NotateXpress9.NotateXpressException
PegasusImaging.WinForms.NotateXpress9.UnableToCreateStorageException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class UnableToCreateStorageException
   Inherits NotateXpressException
   Implements ISerializable, _Exception
[C#]
[SerializableAttribute()]
public sealed class UnableToCreateStorageException : NotateXpressException, ISerializable, _Exception
[C++]
[SerializableAttribute()]
public __gc __sealed class UnableToCreateStorageException : public NotateXpressException, ISerializable, _Exception
[C++/CLI]
[SerializableAttribute()]
public ref class UnableToCreateStorageException sealed : public NotateXpressException, ISerializable, _Exception

See Also

UnableToCreateStorageException Members | PegasusImaging.WinForms.NotateXpress9 Namespace


UnableToCreateStorageException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

UnableToCreateStorageException Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : UnableToCreateStorageException Class

UnableToCreateStorageException overview

Public Constructors

Public Constructor UnableToCreateStorageException Constructor Overloaded. Main constructor for the exception class UnableToCreateStorage raised when there are errors creating storage.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

UnableToCreateStorageException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


UnableToCreateStorageException Constructor

UnableToCreateStorageException Class | UnableToCreateStorageException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

UnableToCreateStorageException Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > UnableToCreateStorageException Class : UnableToCreateStorageException Constructor (UnableToCreateStorageException)

Main constructor for the exception class UnableToCreateStorage raised when there are errors creating storage.

Overload List

Main constructor for the exception class UnableToCreateStorage raised when there are errors creating storage.

[Visual Basic] Public Sub New()

[C#] public UnableToCreateStorageException();

[C++] public UnableToCreateStorageException();

[C++/CLI] public UnableToCreateStorageException();

Exception which allows passing in an error number when there are errors creating storage.

[Visual Basic] Public Sub New(Integer)

[C#] public UnableToCreateStorageException(int);

[C++] public UnableToCreateStorageException(int);

[C++/CLI] public UnableToCreateStorageException(int);

Exception which allows passing in a message when there are errors creating storage.

[Visual Basic] Public Sub New(String)

[C#] public UnableToCreateStorageException(string);

[C++] public UnableToCreateStorageException(string*);

[C++/CLI] public UnableToCreateStorageException(String^);

Exception which allows passing in an error number and a message when there are errors creating storage.

[Visual Basic] Public Sub New(Integer,String)

[C#] public UnableToCreateStorageException(int,string);

[C++] public UnableToCreateStorageException(int,string*);

[C++/CLI] public UnableToCreateStorageException(int,String^);

Exception which allows passing in a message and inner exception when there are errors creating storage.

[Visual Basic] Public Sub New(String,Exception)

[C#] public UnableToCreateStorageException(string,Exception);

[C++] public UnableToCreateStorageException(string*,Exception*);

[C++/CLI] public UnableToCreateStorageException(String^,Exception^);

See Also

UnableToCreateStorageException Class | UnableToCreateStorageException Members


UnableToCreateStorageException Constructor()

UnableToCreateStorageException Class | UnableToCreateStorageException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

UnableToCreateStorageException Constructor()

PegasusImaging.WinForms.NotateXpress9 Namespace > UnableToCreateStorageException Class > UnableToCreateStorageException Constructor : UnableToCreateStorageException Constructor()

Main constructor for the exception class UnableToCreateStorage raised when there are errors creating storage.

[Visual Basic]
Public Function New()
[C#]
public UnableToCreateStorageException();
[C++]
public: UnableToCreateStorageException();
[C++/CLI]
public:
UnableToCreateStorageException();

See Also

UnableToCreateStorageException Class | UnableToCreateStorageException Members | Overload List


UnableToCreateStorageException Constructor(Int32)

UnableToCreateStorageException Class | UnableToCreateStorageException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

UnableToCreateStorageException Constructor(Int32)

PegasusImaging.WinForms.NotateXpress9 Namespace > UnableToCreateStorageException Class > UnableToCreateStorageException Constructor : UnableToCreateStorageException Constructor(Int32)

Exception which allows passing in an error number when there are errors creating storage.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public UnableToCreateStorageException(
   int errorNumber
);
[C++]
public: UnableToCreateStorageException(
   int errorNumber
)
[C++/CLI]
public:
UnableToCreateStorageException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

UnableToCreateStorageException Class | UnableToCreateStorageException Members | Overload List


UnableToCreateStorageException Constructor(Int32,String)

UnableToCreateStorageException Class | UnableToCreateStorageException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

UnableToCreateStorageException Constructor(Int32,String)

PegasusImaging.WinForms.NotateXpress9 Namespace > UnableToCreateStorageException Class > UnableToCreateStorageException Constructor : UnableToCreateStorageException Constructor(Int32,String)

Exception which allows passing in an error number and a message when there are errors creating storage.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public UnableToCreateStorageException(
   int errorNumber,
   string message
);
[C++]
public: UnableToCreateStorageException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
UnableToCreateStorageException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

UnableToCreateStorageException Class | UnableToCreateStorageException Members | Overload List


UnableToCreateStorageException Constructor(String)

UnableToCreateStorageException Class | UnableToCreateStorageException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

UnableToCreateStorageException Constructor(String)

PegasusImaging.WinForms.NotateXpress9 Namespace > UnableToCreateStorageException Class > UnableToCreateStorageException Constructor : UnableToCreateStorageException Constructor(String)

Exception which allows passing in a message when there are errors creating storage.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public UnableToCreateStorageException(
   string message
);
[C++]
public: UnableToCreateStorageException(
   string* message
)
[C++/CLI]
public:
UnableToCreateStorageException(
   String^ message
)

Parameters

message
A string which represents the message.

See Also

UnableToCreateStorageException Class | UnableToCreateStorageException Members | Overload List


UnableToCreateStorageException Constructor(String,Exception)

UnableToCreateStorageException Class | UnableToCreateStorageException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

UnableToCreateStorageException Constructor(String,Exception)

PegasusImaging.WinForms.NotateXpress9 Namespace > UnableToCreateStorageException Class > UnableToCreateStorageException Constructor : UnableToCreateStorageException Constructor(String,Exception)

Exception which allows passing in a message and inner exception when there are errors creating storage.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public UnableToCreateStorageException(
   string message,
   Exception innerException
);
[C++]
public: UnableToCreateStorageException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
UnableToCreateStorageException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception.

See Also

UnableToCreateStorageException Class | UnableToCreateStorageException Members | Overload List


UserDrawEventArgs Class

UserDrawEventArgs Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

UserDrawEventArgs Class

PegasusImaging.WinForms.NotateXpress9 Namespace : UserDrawEventArgs Class

Arguments for UserDraw event

For a list of all members of this type, see UserDrawEventArgs members.

Object Model

Inheritance Hierarchy

System.Object
System.EventArgs
PegasusImaging.WinForms.NotateXpress9.UserDrawEventArgs

Syntax

[Visual Basic]
Public Class UserDrawEventArgs
   Inherits EventArgs
[C#]
public class UserDrawEventArgs : EventArgs
[C++]
public __gc class UserDrawEventArgs : public EventArgs
[C++/CLI]
public ref class UserDrawEventArgs : public EventArgs

See Also

UserDrawEventArgs Members | PegasusImaging.WinForms.NotateXpress9 Namespace


UserDrawEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

UserDrawEventArgs Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : UserDrawEventArgs Class

UserDrawEventArgs overview

Public Constructors

Public Constructor UserDrawEventArgs Constructor

Public Properties

Public Property Element | Gets the rectangle element being drawn.
Public Property HandleDeviceContext | Gets the device context to draw to.
Public Property Height | Gets the height of the rectangle to draw.
Public Property Layer | Gets the layer on which the rectangle is drawn.
Public Property UserLong | Gets the user supplied data.
Public Property Width | Gets the width of the rectangle to draw.
Public Property X | Gets the x coordinate of the rectangle to draw.
Public Property Y | Gets the y coordinate of the rectangle to draw.

See Also

UserDrawEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace


UserDrawEventArgs Constructor

UserDrawEventArgs Class | UserDrawEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

UserDrawEventArgs Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > UserDrawEventArgs Class : UserDrawEventArgs Constructor (UserDrawEventArgs)
[Visual Basic]
Public Function New()
[C#]
public UserDrawEventArgs();
[C++]
public: UserDrawEventArgs();
[C++/CLI]
public:
UserDrawEventArgs();

See Also

UserDrawEventArgs Class | UserDrawEventArgs Members


UserDrawEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

UserDrawEventArgs Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : UserDrawEventArgs Class

For a list of all members of this type, see UserDrawEventArgs members.

Public Properties

Public Property Element | Gets the rectangle element being drawn.
Public Property HandleDeviceContext | Gets the device context to draw to.
Public Property Height | Gets the height of the rectangle to draw.
Public Property Layer | Gets the layer on which the rectangle is drawn.
Public Property UserLong | Gets the user supplied data.
Public Property Width | Gets the width of the rectangle to draw.
Public Property X | Gets the x coordinate of the rectangle to draw.
Public Property Y | Gets the y coordinate of the rectangle to draw.

See Also

UserDrawEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Element Property

UserDrawEventArgs Class | UserDrawEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Element Property

PegasusImaging.WinForms.NotateXpress9 Namespace > UserDrawEventArgs Class : Element Property (UserDrawEventArgs)

Gets the rectangle element being drawn.

[Visual Basic]
Public Property Element As Element
[C#]
public Element Element {get; set;}
[C++]
public: __property Element* get_Element();
public: __property void set_Element(
   Element* value
);
[C++/CLI]
public:
property Element^ Element {
   Element^ get();
   void set (Element^ value);
}

Remarks

The Element.

See Also

UserDrawEventArgs Class | UserDrawEventArgs Members


HandleDeviceContext Property

UserDrawEventArgs Class | UserDrawEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HandleDeviceContext Property

PegasusImaging.WinForms.NotateXpress9 Namespace > UserDrawEventArgs Class : HandleDeviceContext Property

Gets the device context to draw to.

[Visual Basic]
Public Property HandleDeviceContext As Integer
[C#]
public int HandleDeviceContext {get; set;}
[C++]
public: __property int get_HandleDeviceContext();
public: __property void set_HandleDeviceContext(
   int value
);
[C++/CLI]
public:
property int HandleDeviceContext {
   int get();
   void set (int value);
}

See Also

UserDrawEventArgs Class | UserDrawEventArgs Members


Height Property

UserDrawEventArgs Class | UserDrawEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Height Property

PegasusImaging.WinForms.NotateXpress9 Namespace > UserDrawEventArgs Class : Height Property

Gets the height of the rectangle to draw.

[Visual Basic]
Public Property Height As Integer
[C#]
public int Height {get; set;}
[C++]
public: __property int get_Height();
public: __property void set_Height(
   int value
);
[C++/CLI]
public:
property int Height {
   int get();
   void set (int value);
}

See Also

UserDrawEventArgs Class | UserDrawEventArgs Members


Layer Property

UserDrawEventArgs Class | UserDrawEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Layer Property

PegasusImaging.WinForms.NotateXpress9 Namespace > UserDrawEventArgs Class : Layer Property (UserDrawEventArgs)

Gets the layer on which the rectangle is drawn.

[Visual Basic]
Public Property Layer As Layer
[C#]
public Layer Layer {get; set;}
[C++]
public: __property Layer* get_Layer();
public: __property void set_Layer(
   Layer* value
);
[C++/CLI]
public:
property Layer^ Layer {
   Layer^ get();
   void set (Layer^ value);
}

Remarks

The Layer .

See Also

UserDrawEventArgs Class | UserDrawEventArgs Members


UserLong Property

UserDrawEventArgs Class | UserDrawEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

UserLong Property

PegasusImaging.WinForms.NotateXpress9 Namespace > UserDrawEventArgs Class : UserLong Property (UserDrawEventArgs)

Gets the user supplied data.

[Visual Basic]
Public Property UserLong As Integer
[C#]
public int UserLong {get; set;}
[C++]
public: __property int get_UserLong();
public: __property void set_UserLong(
   int value
);
[C++/CLI]
public:
property int UserLong {
   int get();
   void set (int value);
}

Remarks

An integer which represents the user supplied data via the UserLong property.

See Also

UserDrawEventArgs Class | UserDrawEventArgs Members


Width Property

UserDrawEventArgs Class | UserDrawEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Width Property

PegasusImaging.WinForms.NotateXpress9 Namespace > UserDrawEventArgs Class : Width Property

Gets the width of the rectangle to draw.

[Visual Basic]
Public Property Width As Integer
[C#]
public int Width {get; set;}
[C++]
public: __property int get_Width();
public: __property void set_Width(
   int value
);
[C++/CLI]
public:
property int Width {
   int get();
   void set (int value);
}

See Also

UserDrawEventArgs Class | UserDrawEventArgs Members


X Property

UserDrawEventArgs Class | UserDrawEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

X Property

PegasusImaging.WinForms.NotateXpress9 Namespace > UserDrawEventArgs Class : X Property (UserDrawEventArgs)

Gets the x coordinate of the rectangle to draw.

[Visual Basic]
Public Property X As Integer
[C#]
public int X {get; set;}
[C++]
public: __property int get_X();
public: __property void set_X(
   int value
);
[C++/CLI]
public:
property int X {
   int get();
   void set (int value);
}

See Also

UserDrawEventArgs Class | UserDrawEventArgs Members


Y Property

UserDrawEventArgs Class | UserDrawEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Y Property

PegasusImaging.WinForms.NotateXpress9 Namespace > UserDrawEventArgs Class : Y Property (UserDrawEventArgs)

Gets the y coordinate of the rectangle to draw.

[Visual Basic]
Public Property Y As Integer
[C#]
public int Y {get; set;}
[C++]
public: __property int get_Y();
public: __property void set_Y(
   int value
);
[C++/CLI]
public:
property int Y {
   int get();
   void set (int value);
}

See Also

UserDrawEventArgs Class | UserDrawEventArgs Members


UserGroupCreatedEventArgs Class

UserGroupCreatedEventArgs Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

UserGroupCreatedEventArgs Class

PegasusImaging.WinForms.NotateXpress9 Namespace : UserGroupCreatedEventArgs Class

Arguments for UserGroupCreated event

For a list of all members of this type, see UserGroupCreatedEventArgs members.

Object Model

Inheritance Hierarchy

System.Object
System.EventArgs
PegasusImaging.WinForms.NotateXpress9.UserGroupCreatedEventArgs

Syntax

[Visual Basic]
Public Class UserGroupCreatedEventArgs
   Inherits EventArgs
[C#]
public class UserGroupCreatedEventArgs : EventArgs
[C++]
public __gc class UserGroupCreatedEventArgs : public EventArgs
[C++/CLI]
public ref class UserGroupCreatedEventArgs : public EventArgs

See Also

UserGroupCreatedEventArgs Members | PegasusImaging.WinForms.NotateXpress9 Namespace


UserGroupCreatedEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

UserGroupCreatedEventArgs Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : UserGroupCreatedEventArgs Class

UserGroupCreatedEventArgs overview

Public Constructors

Public Constructor UserGroupCreatedEventArgs Constructor

Public Properties

Public Property Group | Gets the group that was created.
Public Property Layer | Gets the layer on which the group resides.

See Also

UserGroupCreatedEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace


UserGroupCreatedEventArgs Constructor

UserGroupCreatedEventArgs Class | UserGroupCreatedEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

UserGroupCreatedEventArgs Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > UserGroupCreatedEventArgs Class : UserGroupCreatedEventArgs Constructor (UserGroupCreatedEventArgs)
[Visual Basic]
Public Function New()
[C#]
public UserGroupCreatedEventArgs();
[C++]
public: UserGroupCreatedEventArgs();
[C++/CLI]
public:
UserGroupCreatedEventArgs();

See Also

UserGroupCreatedEventArgs Class | UserGroupCreatedEventArgs Members


UserGroupCreatedEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

UserGroupCreatedEventArgs Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : UserGroupCreatedEventArgs Class

For a list of all members of this type, see UserGroupCreatedEventArgs members.

Public Properties

Public Property Group | Gets the group that was created.
Public Property Layer | Gets the layer on which the group resides.

See Also

UserGroupCreatedEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Group Property

UserGroupCreatedEventArgs Class | UserGroupCreatedEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Group Property

PegasusImaging.WinForms.NotateXpress9 Namespace > UserGroupCreatedEventArgs Class : Group Property (UserGroupCreatedEventArgs)

Gets the group that was created.

[Visual Basic]
Public Property Group As Group
[C#]
public Group Group {get; set;}
[C++]
public: __property Group* get_Group();
public: __property void set_Group(
   Group* value
);
[C++/CLI]
public:
property Group^ Group {
   Group^ get();
   void set (Group^ value);
}

Remarks

The Group .

See Also

UserGroupCreatedEventArgs Class | UserGroupCreatedEventArgs Members


Layer Property

UserGroupCreatedEventArgs Class | UserGroupCreatedEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Layer Property

PegasusImaging.WinForms.NotateXpress9 Namespace > UserGroupCreatedEventArgs Class : Layer Property (UserGroupCreatedEventArgs)

Gets the layer on which the group resides.

[Visual Basic]
Public Property Layer As Layer
[C#]
public Layer Layer {get; set;}
[C++]
public: __property Layer* get_Layer();
public: __property void set_Layer(
   Layer* value
);
[C++/CLI]
public:
property Layer^ Layer {
   Layer^ get();
   void set (Layer^ value);
}

Remarks

The Layer.

See Also

UserGroupCreatedEventArgs Class | UserGroupCreatedEventArgs Members


UserGroupDestroyedEventArgs Class

UserGroupDestroyedEventArgs Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

UserGroupDestroyedEventArgs Class

PegasusImaging.WinForms.NotateXpress9 Namespace : UserGroupDestroyedEventArgs Class

Arguments for UserGroupDestroyed event

For a list of all members of this type, see UserGroupDestroyedEventArgs members.

Object Model

Inheritance Hierarchy

System.Object
System.EventArgs
PegasusImaging.WinForms.NotateXpress9.UserGroupDestroyedEventArgs

Syntax

[Visual Basic]
Public Class UserGroupDestroyedEventArgs
   Inherits EventArgs
[C#]
public class UserGroupDestroyedEventArgs : EventArgs
[C++]
public __gc class UserGroupDestroyedEventArgs : public EventArgs
[C++/CLI]
public ref class UserGroupDestroyedEventArgs : public EventArgs

See Also

UserGroupDestroyedEventArgs Members | PegasusImaging.WinForms.NotateXpress9 Namespace


UserGroupDestroyedEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

UserGroupDestroyedEventArgs Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : UserGroupDestroyedEventArgs Class

UserGroupDestroyedEventArgs overview

Public Constructors

Public Constructor UserGroupDestroyedEventArgs Constructor

Public Properties

Public Property Group | Gets the group that is destroyed.
Public Property Layer | Gets the layer on which the group resides.

See Also

UserGroupDestroyedEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace


UserGroupDestroyedEventArgs Constructor

UserGroupDestroyedEventArgs Class | UserGroupDestroyedEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

UserGroupDestroyedEventArgs Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > UserGroupDestroyedEventArgs Class : UserGroupDestroyedEventArgs Constructor (UserGroupDestroyedEventArgs)
[Visual Basic]
Public Function New()
[C#]
public UserGroupDestroyedEventArgs();
[C++]
public: UserGroupDestroyedEventArgs();
[C++/CLI]
public:
UserGroupDestroyedEventArgs();

See Also

UserGroupDestroyedEventArgs Class | UserGroupDestroyedEventArgs Members


UserGroupDestroyedEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

UserGroupDestroyedEventArgs Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : UserGroupDestroyedEventArgs Class

For a list of all members of this type, see UserGroupDestroyedEventArgs members.

Public Properties

Public Property Group | Gets the group that is destroyed.
Public Property Layer | Gets the layer on which the group resides.

See Also

UserGroupDestroyedEventArgs Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Group Property

UserGroupDestroyedEventArgs Class | UserGroupDestroyedEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Group Property

PegasusImaging.WinForms.NotateXpress9 Namespace > UserGroupDestroyedEventArgs Class : Group Property (UserGroupDestroyedEventArgs)

Gets the group that is destroyed.

[Visual Basic]
Public Property Group As Group
[C#]
public Group Group {get; set;}
[C++]
public: __property Group* get_Group();
public: __property void set_Group(
   Group* value
);
[C++/CLI]
public:
property Group^ Group {
   Group^ get();
   void set (Group^ value);
}

Remarks

The Group set.

See Also

UserGroupDestroyedEventArgs Class | UserGroupDestroyedEventArgs Members


Layer Property

UserGroupDestroyedEventArgs Class | UserGroupDestroyedEventArgs Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Layer Property

PegasusImaging.WinForms.NotateXpress9 Namespace > UserGroupDestroyedEventArgs Class : Layer Property (UserGroupDestroyedEventArgs)

Gets the layer on which the group resides.

[Visual Basic]
Public Property Layer As Layer
[C#]
public Layer Layer {get; set;}
[C++]
public: __property Layer* get_Layer();
public: __property void set_Layer(
   Layer* value
);
[C++/CLI]
public:
property Layer^ Layer {
   Layer^ get();
   void set (Layer^ value);
}

Remarks

The Layer set.

See Also

UserGroupDestroyedEventArgs Class | UserGroupDestroyedEventArgs Members


XmlFatalException Class

XmlFatalException Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

XmlFatalException Class

PegasusImaging.WinForms.NotateXpress9 Namespace : XmlFatalException Class

Exception class raised when there is a fatal XML error.

For a list of all members of this type, see XmlFatalException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.NotateXpress9.NotateXpressException
PegasusImaging.WinForms.NotateXpress9.XmlFatalException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class XmlFatalException
   Inherits NotateXpressException
   Implements ISerializable, _Exception
[C#]
[SerializableAttribute()]
public sealed class XmlFatalException : NotateXpressException, ISerializable, _Exception
[C++]
[SerializableAttribute()]
public __gc __sealed class XmlFatalException : public NotateXpressException, ISerializable, _Exception
[C++/CLI]
[SerializableAttribute()]
public ref class XmlFatalException sealed : public NotateXpressException, ISerializable, _Exception

See Also

XmlFatalException Members | PegasusImaging.WinForms.NotateXpress9 Namespace


XmlFatalException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

XmlFatalException Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : XmlFatalException Class

XmlFatalException overview

Public Constructors

Public Constructor XmlFatalException Constructor Overloaded. Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

XmlFatalException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


XmlFatalException Constructor

XmlFatalException Class | XmlFatalException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

XmlFatalException Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlFatalException Class : XmlFatalException Constructor (XmlFatalException)

Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

Overload List

Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

[Visual Basic] Public Sub New()

[C#] public XmlFatalException();

[C++] public XmlFatalException();

[C++/CLI] public XmlFatalException();

Exception which allows passing in an error number when there are errors with the annotation files.

[Visual Basic] Public Sub New(Integer)

[C#] public XmlFatalException(int);

[C++] public XmlFatalException(int);

[C++/CLI] public XmlFatalException(int);

Exception which allows passing in a message when thee are errors with the annotation files.

[Visual Basic] Public Sub New(String)

[C#] public XmlFatalException(string);

[C++] public XmlFatalException(string*);

[C++/CLI] public XmlFatalException(String^);

Exception which allows passing in an error number and message when there are errors with the annotation files.

[Visual Basic] Public Sub New(Integer,String)

[C#] public XmlFatalException(int,string);

[C++] public XmlFatalException(int,string*);

[C++/CLI] public XmlFatalException(int,String^);

Exception which allows passing in a message and inner exception when there are errors with the annotation files.

[Visual Basic] Public Sub New(String,Exception)

[C#] public XmlFatalException(string,Exception);

[C++] public XmlFatalException(string*,Exception*);

[C++/CLI] public XmlFatalException(String^,Exception^);

See Also

XmlFatalException Class | XmlFatalException Members


XmlFatalException Constructor()

XmlFatalException Class | XmlFatalException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

XmlFatalException Constructor()

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlFatalException Class > XmlFatalException Constructor : XmlFatalException Constructor()

Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

[Visual Basic]
Public Function New()
[C#]
public XmlFatalException();
[C++]
public: XmlFatalException();
[C++/CLI]
public:
XmlFatalException();

See Also

XmlFatalException Class | XmlFatalException Members | Overload List


XmlFatalException Constructor(Int32)

XmlFatalException Class | XmlFatalException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

XmlFatalException Constructor(Int32)

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlFatalException Class > XmlFatalException Constructor : XmlFatalException Constructor(Int32)

Exception which allows passing in an error number when there are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public XmlFatalException(
   int errorNumber
);
[C++]
public: XmlFatalException(
   int errorNumber
)
[C++/CLI]
public:
XmlFatalException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

XmlFatalException Class | XmlFatalException Members | Overload List


XmlFatalException Constructor(Int32,String)

XmlFatalException Class | XmlFatalException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

XmlFatalException Constructor(Int32,String)

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlFatalException Class > XmlFatalException Constructor : XmlFatalException Constructor(Int32,String)

Exception which allows passing in an error number and message when there are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public XmlFatalException(
   int errorNumber,
   string message
);
[C++]
public: XmlFatalException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
XmlFatalException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

XmlFatalException Class | XmlFatalException Members | Overload List


XmlFatalException Constructor(String)

XmlFatalException Class | XmlFatalException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

XmlFatalException Constructor(String)

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlFatalException Class > XmlFatalException Constructor : XmlFatalException Constructor(String)

Exception which allows passing in a message when thee are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public XmlFatalException(
   string message
);
[C++]
public: XmlFatalException(
   string* message
)
[C++/CLI]
public:
XmlFatalException(
   String^ message
)

Parameters

message
A string which represents the message.

See Also

XmlFatalException Class | XmlFatalException Members | Overload List


XmlFatalException Constructor(String,Exception)

XmlFatalException Class | XmlFatalException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

XmlFatalException Constructor(String,Exception)

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlFatalException Class > XmlFatalException Constructor : XmlFatalException Constructor(String,Exception)

Exception which allows passing in a message and inner exception when there are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public XmlFatalException(
   string message,
   Exception innerException
);
[C++]
public: XmlFatalException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
XmlFatalException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception.

See Also

XmlFatalException Class | XmlFatalException Members | Overload List


XmlGeneralException Class

XmlGeneralException Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

XmlGeneralException Class

PegasusImaging.WinForms.NotateXpress9 Namespace : XmlGeneralException Class

Exception class raised when there is a general XML error.

For a list of all members of this type, see XmlGeneralException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.NotateXpress9.NotateXpressException
PegasusImaging.WinForms.NotateXpress9.XmlGeneralException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class XmlGeneralException
   Inherits NotateXpressException
   Implements ISerializable, _Exception
[C#]
[SerializableAttribute()]
public sealed class XmlGeneralException : NotateXpressException, ISerializable, _Exception
[C++]
[SerializableAttribute()]
public __gc __sealed class XmlGeneralException : public NotateXpressException, ISerializable, _Exception
[C++/CLI]
[SerializableAttribute()]
public ref class XmlGeneralException sealed : public NotateXpressException, ISerializable, _Exception

See Also

XmlGeneralException Members | PegasusImaging.WinForms.NotateXpress9 Namespace


XmlGeneralException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

XmlGeneralException Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : XmlGeneralException Class

XmlGeneralException overview

Public Constructors

Public Constructor XmlGeneralException Constructor Overloaded. Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

XmlGeneralException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


XmlGeneralException Constructor

XmlGeneralException Class | XmlGeneralException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

XmlGeneralException Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlGeneralException Class : XmlGeneralException Constructor (XmlGeneralException)

Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

Overload List

Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

[Visual Basic] Public Sub New()

[C#] public XmlGeneralException();

[C++] public XmlGeneralException();

[C++/CLI] public XmlGeneralException();

Exception which allows passing in an error number when there are errors with the annotation files.

[Visual Basic] Public Sub New(Integer)

[C#] public XmlGeneralException(int);

[C++] public XmlGeneralException(int);

[C++/CLI] public XmlGeneralException(int);

Exception which allows passing in a message when thee are errors with the annotation files.

[Visual Basic] Public Sub New(String)

[C#] public XmlGeneralException(string);

[C++] public XmlGeneralException(string*);

[C++/CLI] public XmlGeneralException(String^);

Exception which allows passing in an error number and message when there are errors with the annotation files.

[Visual Basic] Public Sub New(Integer,String)

[C#] public XmlGeneralException(int,string);

[C++] public XmlGeneralException(int,string*);

[C++/CLI] public XmlGeneralException(int,String^);

Exception which allows passing in a message and inner exception when there are errors with the annotation files.

[Visual Basic] Public Sub New(String,Exception)

[C#] public XmlGeneralException(string,Exception);

[C++] public XmlGeneralException(string*,Exception*);

[C++/CLI] public XmlGeneralException(String^,Exception^);

See Also

XmlGeneralException Class | XmlGeneralException Members


XmlGeneralException Constructor()

XmlGeneralException Class | XmlGeneralException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

XmlGeneralException Constructor()

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlGeneralException Class > XmlGeneralException Constructor : XmlGeneralException Constructor()

Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

[Visual Basic]
Public Function New()
[C#]
public XmlGeneralException();
[C++]
public: XmlGeneralException();
[C++/CLI]
public:
XmlGeneralException();

See Also

XmlGeneralException Class | XmlGeneralException Members | Overload List


XmlGeneralException Constructor(Int32)

XmlGeneralException Class | XmlGeneralException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

XmlGeneralException Constructor(Int32)

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlGeneralException Class > XmlGeneralException Constructor : XmlGeneralException Constructor(Int32)

Exception which allows passing in an error number when there are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public XmlGeneralException(
   int errorNumber
);
[C++]
public: XmlGeneralException(
   int errorNumber
)
[C++/CLI]
public:
XmlGeneralException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

XmlGeneralException Class | XmlGeneralException Members | Overload List


XmlGeneralException Constructor(Int32,String)

XmlGeneralException Class | XmlGeneralException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

XmlGeneralException Constructor(Int32,String)

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlGeneralException Class > XmlGeneralException Constructor : XmlGeneralException Constructor(Int32,String)

Exception which allows passing in an error number and message when there are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public XmlGeneralException(
   int errorNumber,
   string message
);
[C++]
public: XmlGeneralException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
XmlGeneralException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

XmlGeneralException Class | XmlGeneralException Members | Overload List


XmlGeneralException Constructor(String)

XmlGeneralException Class | XmlGeneralException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

XmlGeneralException Constructor(String)

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlGeneralException Class > XmlGeneralException Constructor : XmlGeneralException Constructor(String)

Exception which allows passing in a message when thee are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public XmlGeneralException(
   string message
);
[C++]
public: XmlGeneralException(
   string* message
)
[C++/CLI]
public:
XmlGeneralException(
   String^ message
)

Parameters

message
A string which represents the message.

See Also

XmlGeneralException Class | XmlGeneralException Members | Overload List


XmlGeneralException Constructor(String,Exception)

XmlGeneralException Class | XmlGeneralException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

XmlGeneralException Constructor(String,Exception)

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlGeneralException Class > XmlGeneralException Constructor : XmlGeneralException Constructor(String,Exception)

Exception which allows passing in a message and inner exception when there are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public XmlGeneralException(
   string message,
   Exception innerException
);
[C++]
public: XmlGeneralException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
XmlGeneralException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception.

See Also

XmlGeneralException Class | XmlGeneralException Members | Overload List


XmlInvalidHeaderException Class

XmlInvalidHeaderException Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

XmlInvalidHeaderException Class

PegasusImaging.WinForms.NotateXpress9 Namespace : XmlInvalidHeaderException Class

Exception class raised when the XML file header is invalid.

For a list of all members of this type, see XmlInvalidHeaderException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.NotateXpress9.NotateXpressException
PegasusImaging.WinForms.NotateXpress9.XmlInvalidHeaderException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class XmlInvalidHeaderException
   Inherits NotateXpressException
   Implements ISerializable, _Exception
[C#]
[SerializableAttribute()]
public sealed class XmlInvalidHeaderException : NotateXpressException, ISerializable, _Exception
[C++]
[SerializableAttribute()]
public __gc __sealed class XmlInvalidHeaderException : public NotateXpressException, ISerializable, _Exception
[C++/CLI]
[SerializableAttribute()]
public ref class XmlInvalidHeaderException sealed : public NotateXpressException, ISerializable, _Exception

See Also

XmlInvalidHeaderException Members | PegasusImaging.WinForms.NotateXpress9 Namespace


XmlInvalidHeaderException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

XmlInvalidHeaderException Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : XmlInvalidHeaderException Class

XmlInvalidHeaderException overview

Public Constructors

Public Constructor XmlInvalidHeaderException Constructor Overloaded. Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

XmlInvalidHeaderException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


XmlInvalidHeaderException Constructor

XmlInvalidHeaderException Class | XmlInvalidHeaderException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

XmlInvalidHeaderException Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlInvalidHeaderException Class : XmlInvalidHeaderException Constructor (XmlInvalidHeaderException)

Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

Overload List

Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

[Visual Basic] Public Sub New()

[C#] public XmlInvalidHeaderException();

[C++] public XmlInvalidHeaderException();

[C++/CLI] public XmlInvalidHeaderException();

Exception which allows passing in an error number when there are errors with the annotation files.

[Visual Basic] Public Sub New(Integer)

[C#] public XmlInvalidHeaderException(int);

[C++] public XmlInvalidHeaderException(int);

[C++/CLI] public XmlInvalidHeaderException(int);

Exception which allows passing in a message when thee are errors with the annotation files.

[Visual Basic] Public Sub New(String)

[C#] public XmlInvalidHeaderException(string);

[C++] public XmlInvalidHeaderException(string*);

[C++/CLI] public XmlInvalidHeaderException(String^);

Exception which allows passing in an error number and message when there are errors with the annotation files.

[Visual Basic] Public Sub New(Integer,String)

[C#] public XmlInvalidHeaderException(int,string);

[C++] public XmlInvalidHeaderException(int,string*);

[C++/CLI] public XmlInvalidHeaderException(int,String^);

Exception which allows passing in a message and inner exception when there are errors with the annotation files.

[Visual Basic] Public Sub New(String,Exception)

[C#] public XmlInvalidHeaderException(string,Exception);

[C++] public XmlInvalidHeaderException(string*,Exception*);

[C++/CLI] public XmlInvalidHeaderException(String^,Exception^);

See Also

XmlInvalidHeaderException Class | XmlInvalidHeaderException Members


XmlInvalidHeaderException Constructor()

XmlInvalidHeaderException Class | XmlInvalidHeaderException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

XmlInvalidHeaderException Constructor()

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlInvalidHeaderException Class > XmlInvalidHeaderException Constructor : XmlInvalidHeaderException Constructor()

Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

[Visual Basic]
Public Function New()
[C#]
public XmlInvalidHeaderException();
[C++]
public: XmlInvalidHeaderException();
[C++/CLI]
public:
XmlInvalidHeaderException();

See Also

XmlInvalidHeaderException Class | XmlInvalidHeaderException Members | Overload List


XmlInvalidHeaderException Constructor(Int32)

XmlInvalidHeaderException Class | XmlInvalidHeaderException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

XmlInvalidHeaderException Constructor(Int32)

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlInvalidHeaderException Class > XmlInvalidHeaderException Constructor : XmlInvalidHeaderException Constructor(Int32)

Exception which allows passing in an error number when there are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public XmlInvalidHeaderException(
   int errorNumber
);
[C++]
public: XmlInvalidHeaderException(
   int errorNumber
)
[C++/CLI]
public:
XmlInvalidHeaderException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

XmlInvalidHeaderException Class | XmlInvalidHeaderException Members | Overload List


XmlInvalidHeaderException Constructor(Int32,String)

XmlInvalidHeaderException Class | XmlInvalidHeaderException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

XmlInvalidHeaderException Constructor(Int32,String)

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlInvalidHeaderException Class > XmlInvalidHeaderException Constructor : XmlInvalidHeaderException Constructor(Int32,String)

Exception which allows passing in an error number and message when there are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public XmlInvalidHeaderException(
   int errorNumber,
   string message
);
[C++]
public: XmlInvalidHeaderException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
XmlInvalidHeaderException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

XmlInvalidHeaderException Class | XmlInvalidHeaderException Members | Overload List


XmlInvalidHeaderException Constructor(String)

XmlInvalidHeaderException Class | XmlInvalidHeaderException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

XmlInvalidHeaderException Constructor(String)

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlInvalidHeaderException Class > XmlInvalidHeaderException Constructor : XmlInvalidHeaderException Constructor(String)

Exception which allows passing in a message when thee are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public XmlInvalidHeaderException(
   string message
);
[C++]
public: XmlInvalidHeaderException(
   string* message
)
[C++/CLI]
public:
XmlInvalidHeaderException(
   String^ message
)

Parameters

message
A string which represents the message.

See Also

XmlInvalidHeaderException Class | XmlInvalidHeaderException Members | Overload List


XmlInvalidHeaderException Constructor(String,Exception)

XmlInvalidHeaderException Class | XmlInvalidHeaderException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

XmlInvalidHeaderException Constructor(String,Exception)

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlInvalidHeaderException Class > XmlInvalidHeaderException Constructor : XmlInvalidHeaderException Constructor(String,Exception)

Exception which allows passing in a message and inner exception when there are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public XmlInvalidHeaderException(
   string message,
   Exception innerException
);
[C++]
public: XmlInvalidHeaderException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
XmlInvalidHeaderException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception.

See Also

XmlInvalidHeaderException Class | XmlInvalidHeaderException Members | Overload List


XmlInvalidPageDataException Class

XmlInvalidPageDataException Members | PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

XmlInvalidPageDataException Class

PegasusImaging.WinForms.NotateXpress9 Namespace : XmlInvalidPageDataException Class

Exception class raised when there is invalid XML page data.

For a list of all members of this type, see XmlInvalidPageDataException members.

Object Model

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.NotateXpress9.NotateXpressException
PegasusImaging.WinForms.NotateXpress9.XmlInvalidPageDataException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class XmlInvalidPageDataException
   Inherits NotateXpressException
   Implements ISerializable, _Exception
[C#]
[SerializableAttribute()]
public sealed class XmlInvalidPageDataException : NotateXpressException, ISerializable, _Exception
[C++]
[SerializableAttribute()]
public __gc __sealed class XmlInvalidPageDataException : public NotateXpressException, ISerializable, _Exception
[C++/CLI]
[SerializableAttribute()]
public ref class XmlInvalidPageDataException sealed : public NotateXpressException, ISerializable, _Exception

See Also

XmlInvalidPageDataException Members | PegasusImaging.WinForms.NotateXpress9 Namespace


XmlInvalidPageDataException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

XmlInvalidPageDataException Class Members

PegasusImaging.WinForms.NotateXpress9 Namespace : XmlInvalidPageDataException Class

XmlInvalidPageDataException overview

Public Constructors

Public Constructor XmlInvalidPageDataException Constructor Overloaded. Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

XmlInvalidPageDataException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


XmlInvalidPageDataException Constructor

XmlInvalidPageDataException Class | XmlInvalidPageDataException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

XmlInvalidPageDataException Constructor

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlInvalidPageDataException Class : XmlInvalidPageDataException Constructor (XmlInvalidPageDataException)

Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

Overload List

Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

[Visual Basic] Public Sub New()

[C#] public XmlInvalidPageDataException();

[C++] public XmlInvalidPageDataException();

[C++/CLI] public XmlInvalidPageDataException();

Exception which allows passing in an error number when there are errors with the annotation files.

[Visual Basic] Public Sub New(Integer)

[C#] public XmlInvalidPageDataException(int);

[C++] public XmlInvalidPageDataException(int);

[C++/CLI] public XmlInvalidPageDataException(int);

Exception which allows passing in a message when thee are errors with the annotation files.

[Visual Basic] Public Sub New(String)

[C#] public XmlInvalidPageDataException(string);

[C++] public XmlInvalidPageDataException(string*);

[C++/CLI] public XmlInvalidPageDataException(String^);

Exception which allows passing in an error number and message when there are errors with the annotation files.

[Visual Basic] Public Sub New(Integer,String)

[C#] public XmlInvalidPageDataException(int,string);

[C++] public XmlInvalidPageDataException(int,string*);

[C++/CLI] public XmlInvalidPageDataException(int,String^);

Exception which allows passing in a message and inner exception when there are errors with the annotation files.

[Visual Basic] Public Sub New(String,Exception)

[C#] public XmlInvalidPageDataException(string,Exception);

[C++] public XmlInvalidPageDataException(string*,Exception*);

[C++/CLI] public XmlInvalidPageDataException(String^,Exception^);

See Also

XmlInvalidPageDataException Class | XmlInvalidPageDataException Members


XmlInvalidPageDataException Constructor()

XmlInvalidPageDataException Class | XmlInvalidPageDataException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

XmlInvalidPageDataException Constructor()

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlInvalidPageDataException Class > XmlInvalidPageDataException Constructor : XmlInvalidPageDataException Constructor()

Base constructor for the InvalidAnnoationFileException class when there are errors with the annotation files.

[Visual Basic]
Public Function New()
[C#]
public XmlInvalidPageDataException();
[C++]
public: XmlInvalidPageDataException();
[C++/CLI]
public:
XmlInvalidPageDataException();

See Also

XmlInvalidPageDataException Class | XmlInvalidPageDataException Members | Overload List


XmlInvalidPageDataException Constructor(Int32)

XmlInvalidPageDataException Class | XmlInvalidPageDataException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

XmlInvalidPageDataException Constructor(Int32)

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlInvalidPageDataException Class > XmlInvalidPageDataException Constructor : XmlInvalidPageDataException Constructor(Int32)

Exception which allows passing in an error number when there are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public XmlInvalidPageDataException(
   int errorNumber
);
[C++]
public: XmlInvalidPageDataException(
   int errorNumber
)
[C++/CLI]
public:
XmlInvalidPageDataException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

XmlInvalidPageDataException Class | XmlInvalidPageDataException Members | Overload List


XmlInvalidPageDataException Constructor(Int32,String)

XmlInvalidPageDataException Class | XmlInvalidPageDataException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
An integer which represents the error number.
message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

XmlInvalidPageDataException Constructor(Int32,String)

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlInvalidPageDataException Class > XmlInvalidPageDataException Constructor : XmlInvalidPageDataException Constructor(Int32,String)

Exception which allows passing in an error number and message when there are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public XmlInvalidPageDataException(
   int errorNumber,
   string message
);
[C++]
public: XmlInvalidPageDataException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
XmlInvalidPageDataException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

XmlInvalidPageDataException Class | XmlInvalidPageDataException Members | Overload List


XmlInvalidPageDataException Constructor(String)

XmlInvalidPageDataException Class | XmlInvalidPageDataException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

XmlInvalidPageDataException Constructor(String)

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlInvalidPageDataException Class > XmlInvalidPageDataException Constructor : XmlInvalidPageDataException Constructor(String)

Exception which allows passing in a message when thee are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public XmlInvalidPageDataException(
   string message
);
[C++]
public: XmlInvalidPageDataException(
   string* message
)
[C++/CLI]
public:
XmlInvalidPageDataException(
   String^ message
)

Parameters

message
A string which represents the message.

See Also

XmlInvalidPageDataException Class | XmlInvalidPageDataException Members | Overload List


XmlInvalidPageDataException Constructor(String,Exception)

XmlInvalidPageDataException Class | XmlInvalidPageDataException Members | Overload List

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string which represents the message.
innerException
An inner exception.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

XmlInvalidPageDataException Constructor(String,Exception)

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlInvalidPageDataException Class > XmlInvalidPageDataException Constructor : XmlInvalidPageDataException Constructor(String,Exception)

Exception which allows passing in a message and inner exception when there are errors with the annotation files.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public XmlInvalidPageDataException(
   string message,
   Exception innerException
);
[C++]
public: XmlInvalidPageDataException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
XmlInvalidPageDataException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception.

See Also

XmlInvalidPageDataException Class | XmlInvalidPageDataException Members | Overload List


AnnotationMode Enumeration

PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

AnnotationMode Enumeration

PegasusImaging.WinForms.NotateXpress9 Namespace : AnnotationMode Enumeration

Contains constants for use with the NotateXpress.InteractMode property.

Members

Member | Description
Edit | 0 - The Toolbar can be visible, users can create, select, resize and move objects, and the events generated reflect these actions.
Interactive | 1 - The Toolbar is hidden, objects cannot be selected, and user interaction generates MouseDown, MouseMove, MouseUp, Click, and DoubleClick events.

Remarks

The default value is Edit.

See Also

PegasusImaging.WinForms.NotateXpress9 Namespace


AnnotationTool Enumeration

PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

AnnotationTool Enumeration

PegasusImaging.WinForms.NotateXpress9 Namespace : AnnotationTool Enumeration

Contains which tools are used with the ToolbarEvents and MenuEvent arguments.

Members

Member | Description
NoTool | 0x0 - No tool.
PointerTool | 0x1000 - Pointer tool.
TextTool | 0x1001 - Text tool.
RectangleTool | 0x1002 - Rectangle tool.
EllipseTool | 0x1003 - Ellipse tool.
PolygonTool | 0x1004 - Polygon tool.
PolyLineTool | 0x1005 - Ploy line tool.
LineTool | 0x1006 - Line tool.
FreehandTool | 0x1007 - Freehand tool.
StampTool | 0x1008 - Stamp tool.
ImageTool | 0x1009 - Image tool.
ButtonTool | 0x100a - Button tool.
RulerTool | 0x100b - Ruler tool.
BlockHighlightTool | 0x100c - Block Hightlight tool.
NoteTool | 0x100d - Note tool.

See Also

PegasusImaging.WinForms.NotateXpress9 Namespace


AnnotationType Enumeration

PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

AnnotationType Enumeration

PegasusImaging.WinForms.NotateXpress9 Namespace : AnnotationType Enumeration

Option values which determine the type of annotations that NotateXpress can process.

Members

Member | Description
ImagingForWindows | Old School, Kodak/Wang original annotation specification Limited types and attributes, best for compatibility with most other systems.
NotateXpress | Tight binary format. Best for file size and speed.
TMSSequoia | Compatibility with the old TMS Sequoia ann file format. Best for reading ann legacy files.
NotateXpressXml | The XML way of doing things. Considered to be the direction of future enhancements. Best for long term compatibility and open standards.
Xfdf | Adobe's PDF format. Best for transferring data to and from PDF.

See Also

PegasusImaging.WinForms.NotateXpress9 Namespace


AutoSize Enumeration

PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

AutoSize Enumeration

PegasusImaging.WinForms.NotateXpress9 Namespace : AutoSize Enumeration (PegasusImaging.WinForms.NotateXpress9)

Contains options for how to bound annotations.

Members

Member | Description
None | 0 - Annotations are not bound.
ToContents | 1 - Annotations are bound to contents.

See Also

PegasusImaging.WinForms.NotateXpress9 Namespace


BackStyle Enumeration

PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BackStyle Enumeration

PegasusImaging.WinForms.NotateXpress9 Namespace : BackStyle Enumeration (PegasusImaging.WinForms.NotateXpress9)

Contains constants for use with the BackStyle properties.

Members

Member | Description
Transparent | 3001 - Tha back style is transparent.
Opaque | 3002 - The back style is opaque.
Translucent | 3003 - The back style is translucent.

See Also

PegasusImaging.WinForms.NotateXpress9 Namespace


CursorSelection Enumeration

PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

CursorSelection Enumeration

PegasusImaging.WinForms.NotateXpress9 Namespace : CursorSelection Enumeration

The types of cursors to use in selecting elements.

Members

Member | Description
Creating | 0 - The cursor in creating type.
Selecting | 1 - The cursor in selecting type.
Moving | 2 - The cursor in moving type.

See Also

PegasusImaging.WinForms.NotateXpress9 Namespace


DebugErrorLevelInfo Enumeration

PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

DebugErrorLevelInfo Enumeration

PegasusImaging.WinForms.NotateXpress9 Namespace : DebugErrorLevelInfo Enumeration

The amount of error information to write to the NotateXpress.DebugLogFile.

Members

Member | Description
Production | 0 - The default error level. This setting produces the minimum amount of error information.
Development | 1 - This setting produces additional error information that is useful during the development process.
Detailed | 2 - This setting produces detailed error information that is useful when debugging a problem during the development process.

Remarks

The default value is Production.

This enumeration is set using the NotateXpress.DebugErrorLevel property. The NotateXpress.Debug property must be set to true to log any information.

See Also

PegasusImaging.WinForms.NotateXpress9 Namespace


EndPointStyle Enumeration

PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

EndPointStyle Enumeration

PegasusImaging.WinForms.NotateXpress9 Namespace : EndPointStyle Enumeration (PegasusImaging.WinForms.NotateXpress9)

Contains options for how the end of a line should display.

Members

Member | Description
Plain | 0 - The end of a line displays plain.
Arrow | 1 - The end of a line displays an arrow.
ClosedArrow | 2 - The end of a line displays a closed arrow.
ReverseArrow | 3 - The end of a line displays a reverse arrow.
ReverseClosedArrow | 4 - The end of a line displays a reverse closed arrow.
Butt | 5 - The end of a line displays a perpendicular line.
Square | 6 - The end of a line displays a square.
Diamond | 7 - The end of a line displays a diamond.
Circle | 8 - The end of a line displays a circle.
Slash | 9 - The end of a line displays a slash.

See Also

PegasusImaging.WinForms.NotateXpress9 Namespace


ErrorLevelInfo Enumeration

PegasusImaging.WinForms.NotateXpress9 Namespace | DebugLogFile Property

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ErrorLevelInfo Enumeration

PegasusImaging.WinForms.NotateXpress9 Namespace : ErrorLevelInfo Enumeration

The amount of error information to write to the NotateXpress.DebugLogFile.

Members

Member | Description
Production | 0 - The default error level. This setting produces the minimum amount of error information.
Development | 1 - This setting produces additional error information that is useful during the development process.
Detailed | 2 - This setting produces detailed error information that is useful when debugging a problem during the development process.

Remarks

The default value is Production.

This enumeration is set using the NotateXpress.DebugErrorLevel property. The NotateXpress.Debug property must be set to true to log any information.

See Also

PegasusImaging.WinForms.NotateXpress9 Namespace | DebugLogFile Property


FontScaling Enumeration

PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

FontScaling Enumeration

PegasusImaging.WinForms.NotateXpress9 Namespace : FontScaling Enumeration (PegasusImaging.WinForms.NotateXpress9)

Specifies how fonts are scaled with the NotateXpress.FontScaling property.

Members

Member | Description
Normal | 0 - A font is scaled by the current zoom percentage of the image.
ResolutionY | 1 - A font is scaled to take the vertical dpi value into account. ImagXpress must contain a valid value for the Resolution property.

See Also

PegasusImaging.WinForms.NotateXpress9 Namespace


HatchStyle Enumeration

PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HatchStyle Enumeration

PegasusImaging.WinForms.NotateXpress9 Namespace : HatchStyle Enumeration (PegasusImaging.WinForms.NotateXpress9)

Contains constants for use with the HatchStyle properties.

Members

Member | Description
None | 5999 - None.
Horizontal | 6000 - Horizontal display.
Vertical | 6001 - Vertical display.
ForwardDiagonal | 6002 - Forward diagonal display.
BackwardDiagonal | 6003 - Backward diagonal display.
Cross | 6004 - Cross display.
DiagonalCross | 6005 - Diagonal cross display.

See Also

PegasusImaging.WinForms.NotateXpress9 Namespace


LineScaling Enumeration

PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

LineScaling Enumeration

PegasusImaging.WinForms.NotateXpress9 Namespace : LineScaling Enumeration (PegasusImaging.WinForms.NotateXpress9)

Specifies how lines are scaled with the NotateXpress.LineScaling property.

Members

Member | Description
Normal | 0 - All lines are scaled by the current zoom percentage of the image.
ResolutionY | 1 - All line are scaled to take the vertical dpi value into account. ImagXpress must contain a valid value for the Resolution property.

See Also

PegasusImaging.WinForms.NotateXpress9 Namespace


Mapping Enumeration

PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Mapping Enumeration

PegasusImaging.WinForms.NotateXpress9 Namespace : Mapping Enumeration (PegasusImaging.WinForms.NotateXpress9)

Contains constants for use with the SaveOptions.Mapping property.

Members

Member | Description
None | 0 - No mapping.
Pdf | 1 - PDF mapping not rotated.
Pdf90 | 2 - PDF mapping rotated 90 degrees clockwise.
Pdf180 | 3 - PDF mapping rotated 180 degrees.
Pdf270 | 4 - PDF mapping rotated 270 degrees clockwise.
User | 5 - User mapping.

See Also

PegasusImaging.WinForms.NotateXpress9 Namespace


MeasurementUnit Enumeration

PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

MeasurementUnit Enumeration

PegasusImaging.WinForms.NotateXpress9 Namespace : MeasurementUnit Enumeration (PegasusImaging.WinForms.NotateXpress9)

Contains options for how the ruler displays lengths.

Members

Member | Description
Inches | 2049 - In inches.
Feet | 2050 - In feet.
Yards | 2051 - In yards.
Miles | 2052 - In miles.
MicroMeters | 2053 - In micro meters.
Millimeters | 2054 - In millimeters.
Centimeters | 2055 - In centimeters.
Decimeters | 2056 - In decimeters.
Meters | 2057 - In meters.
Dekameters | 2058 - In dakameters.
Kilometers | 2059 - In kilometers
Pixels | 2061 - In pixels.
Twips | 2062 - In twips.

See Also

PegasusImaging.WinForms.NotateXpress9 Namespace


MenuType Enumeration

PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

MenuType Enumeration

PegasusImaging.WinForms.NotateXpress9 Namespace : MenuType Enumeration

Contains options for which menu to use.

Members

Member | Description
Context | 1 - Context menu.
Toolbar | 2 - Toolbar menu.

See Also

PegasusImaging.WinForms.NotateXpress9 Namespace


NotateTrait Enumeration

PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NotateTrait Enumeration

PegasusImaging.WinForms.NotateXpress9 Namespace : NotateTrait Enumeration

Contains options for changing the OnItemChanged event annotation attribute.

Members

Member | Description
PenColor | 0x1 - Pen color.
TextColor | 0x2 - Text color.
BackColor | 0x3 - Back color.
FillColor | 0x4 - Fill color.
PenWidth | 0x5 - Pen width.
BoundingRectangle | 0x7 - Bounding rectangle.
HighlightBack | 0x8 - Highlight back
HighlightFill | 0x9 - Highlight fill.
Text | 0xa - Text.
LogFont | 0xb - Log font.
NumPoints | 0xc - Number of points.
BeginPointStyle | 0xd - Begin point style.
EndPointStyle | 0xe - End point style.
TransparentColor | 0xf - Transparent color.
BackStyle | 0x10 - Back style.
DibPtr | 0x11 - DIB pointer.
Locked | 0x13 - Locked.
ShowHandles | 0x18 - Show handles.
AutoSize | 0x14 - Auto size.
Visible | 0x15 - Visible.
BevelLightColor | 0x16 - Bevel light color.
BevelShadowColor | 0x17 - Bevel shadow color.
Moveable | 0x19 - Moveable.
PenStyle | 0x1a - Pen style.
PenFillStyle | 0x1b - Pen fill style.
TextOrientation | 0x1c - Text orientation.
Selected | 0x1d - Selected.
Sizeable | 0x21 - Sizeable.
CreateTime | 0x22 - Create time.
UserDraw | 0x24 - User draw.
TextLocked | 0x25 - Text locked.
HatchStyle | 0x26 - Hatch style.
HatchColor | 0x27 - Hatch color.
TextJustification | 0x29 - Text justification.
ElementType | 0x80 - Element type.
ToolType | 0x81 - Tool type.
InteractMode | 0x82 - Interact mode.
SaveAnnotations | 0x84 - Save annotations.
LoadAnnotations | 0x86 - Load annotations.
FontScaling | 0x87 - Font scaling.
MleCompatible | 0x88 - MLE compatible.
UnicodeMode | 0x8a - Unicode mode.
RecalibrateXdpi | 0x8c - Recalibrate x (horizontal) dpi.
RecalibrateYdpi | 0x8d - Recalibrate y (vertical) dpi.
LineScaling | 0x200 - Line Scaling.
LayerName | 0x200 - Layer name.
Active | 0x201 - Active.
Author | 0x300 - Author.
Comments | 0x301 - Comments.
Subject | 0x302 - Subject.
Title | 0x303 - Title.
Description | 0x304 - Description.
PageNumber | 0x305 - Page number.
Points | 0x400 - Points.
UserLong | 0x500 - User long.
UserString | 0x501 - User string.
Abbreviation | 0x820 - Abbreviation.
InchesAbbreviation | 0x821 - Inches abbreviation.
FeetAbbreviation | 0x822 - Feet abbreviation.
YardsAbbreviation | 0x823 - Yards abbreviation.
MilesAbbreviation | 0x824 - Miles abbreviation.
MicroMetersAbbreviation | 0x825 - Micro meters abbreviation.
MillimetersAbbreviation | 0x826 - Millimeters abbreviation.
CentimetersAbbreviation | 0x827 - Centimeters abbreviation.
DecimetersAbbreviation | 0x828 - Decimeters abbreviation.
MetersAbbreviation | 0x828 - Meters abbreviation.
DekametersAbbreviation | 0x82a - Dekameters abbreviation.
KilometersAbbreviation | 0x82b - Kilometers abbreviation.
PixelsAbbreviation | 0x82d - Pixels abbreviation.
TwipsAbbreviation | 0x82e - Twips abbreviation.
MeasureChoice | 0x841 - Measure choice.
ShowAbbreviation | 0x840 - Show abbreviation.
ShowLength | 0x842 - Show length.
GaugeLength | 0x843 - Gauge length.
Precision | 0x844 - Precision.
ShowGauge | 0x845 - Show gauge.
Fixed | 0x880 - Fixed.
NoteIcon | 0x882 - Note icon.
ToolTipText | 0x883 - Tool tip text.
ToolTipTimeEdit | 0x884 - Tool tip time edit.
ToolTipTimeInteractive | 0x885 - Tool tip time interactive.
WangType | 0x8f6f - Wang type.
TMSNote | 0x9000 - TMS note.

See Also

PegasusImaging.WinForms.NotateXpress9 Namespace


PenFillStyle Enumeration

PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PenFillStyle Enumeration

PegasusImaging.WinForms.NotateXpress9 Namespace : PenFillStyle Enumeration (PegasusImaging.WinForms.NotateXpress9)

Contains options for how the background should displayed for annotations.

Members

Member | Description
Opaque | 5513 - Display opaque.
Translucent | 5509 - Display translucent.
Invert | 5507 - Displays inverted.

See Also

PegasusImaging.WinForms.NotateXpress9 Namespace


PenStyle Enumeration

PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PenStyle Enumeration

PegasusImaging.WinForms.NotateXpress9 Namespace : PenStyle Enumeration (PegasusImaging.WinForms.NotateXpress9)

Contains constants for use with the PenStyle properties.

These only affect PenWidths of 1

Members

Member | Description
Solid | 5000 - Solid pen style.
Dash | 5001 - Dash pen style.
Dot | 5002 - Dotted pen style.
DashDot | 5003 - Dash dot pen style.
DashDotDot | 5004 - Dash dot dot pen style.

See Also

PegasusImaging.WinForms.NotateXpress9 Namespace


SubMenuId Enumeration

PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

SubMenuId Enumeration

PegasusImaging.WinForms.NotateXpress9 Namespace : SubMenuId Enumeration (PegasusImaging.WinForms.NotateXpress9)

Contains options for how to access the built-in submenus.

Members

Member | Description
PenWidth0 | 2000 - Pen width 0.
PenWidth1 | 2001 - Pen width 1.
PenWidth2 | 2002 - Pen width 2.
PenWidth3 | 2003 - Pen width 3.
PenWidth4 | 2004 - Pen width 4.
PenWidth5 | 2005 - Pen width 5.
PenWidth6 | 2006 - Pen width 6.
PenWidth7 | 2007 - Pen width 7.
PenWidth8 | 2008 - Pen width 8.
PenWidth9 | 2009 - Pen width 9.
RulerInches | 2049 - Ruler in inches.
RulerFeet | 2050 - Ruler in feet.
RulerYards | 2051 - Ruler in yards.
RulerMiles | 2052 - Ruler in miles.
RulerMicroMeters | 2053 - Ruler in micro meters.
RulerMillimeters | 2054 - Ruler in millimeters.
RulerCentimeters | 2055 - Ruler in centimeters.
RulerDecimeters | 2056 - Ruler in decimeters.
RulerMeters | 2057 - Ruler in meters.
RulerDekameters | 2058 - Ruler in dekameters.
RulerKilometers | 2059 - Ruler in kilometers.
RulerPixels | 2061 - Ruler in pixels.
RulerTwips | 2062 - Ruler in twips.
BackStyleTransparent | 3001 - Back style is transparent.
BackStyleOpaque | 3002 - Back style is opaque.
BackStyleTranslucent | 3003 - Back style is translucent.
AutoSizeNone | 3100 - Annotations are not bound.
AutoSizeToContents | 3101 - Annotations are bound to contents.
PenStyleSolid | 5000 - Pen style is solid.
PenStyleDash | 5001 - Pen style is dash.
PenStyleDot | 5002 - Pen style is dot.
PenStyleDashDot | 5003 - Pen style is dash dot.
PenStyleDashDotDot | 5004 - Pen style is dash dot dot.
PenFillStyleOpaque | 5513 - Pen fill style is opaque.
PenFillStyleTranslucent | 5509 - Pen fill style is translucent.
PenFillStyleInvert | 5507 - Pen fill style is inverted.
HatchStyleNone | 5999 - Hatch style is none.
HatchStyleHorizontal | 6000 - Hatch style is horizontal.
HatchStyleVertical | 6002 - Hatch style is vertical.
HatchStyleForwardDiagonal | 6002 - Hatch style is forward diagonal.
HatchStyleBackwardDiagonal | 6003 - Hatch style is backward diagonal.
HatchStyleCross | 6004 - Hatch style is cross.
HatchStyleDiagonalCross | 6005 - Hatch style is diagonal cross.
TextJustificationLeft | 7000 - Text justification is left.
TextJustificationRight | 7001 - Text justification is right.
TextJustificationCenter | 7002 - Text justification is center.
TextOrientation0 | 7100 - Text orientation is 0.
TextOrientation90 | 7190 - Text orientation is 90.
TextOrientation180 | 7280 - Text orientation is 180.
TextOrientation270 | 7370 - Text orientation is 270.

See Also

PegasusImaging.WinForms.NotateXpress9 Namespace


TextJustification Enumeration

PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TextJustification Enumeration

PegasusImaging.WinForms.NotateXpress9 Namespace : TextJustification Enumeration (PegasusImaging.WinForms.NotateXpress9)

Contains options for the text alignment.

Members

Member | Description
Left | 7000 - Left justified.
Right | 7001 - Right justified.
Center | 7002 - Center justified.

See Also

PegasusImaging.WinForms.NotateXpress9 Namespace


TextOrientation Enumeration

PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TextOrientation Enumeration

PegasusImaging.WinForms.NotateXpress9 Namespace : TextOrientation Enumeration (PegasusImaging.WinForms.NotateXpress9)

Contains options for the orientation of the text.

Members

Member | Description
Degree0 | 0 - 0 degrees.
Degree90 | 900 - 90 degrees.
Degree180 | 1800 - 180 degrees.
Degree270 | 2700 - 270 degrees.

See Also

PegasusImaging.WinForms.NotateXpress9 Namespace


TopMenuId Enumeration

PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TopMenuId Enumeration

PegasusImaging.WinForms.NotateXpress9 Namespace : TopMenuId Enumeration (PegasusImaging.WinForms.NotateXpress9)

Contains options for how to access the built-in menus.

Members

Member | Description
PenColor | 0x1 - Pen color.
TextColor | 0x2 - Text color.
BackColor | 0x3 - Back color.
FillColor | 0x4 - Fill color.
PenWidth | 0x5 - Pen width.
Font | 0xb - Font.
TransparentColor | 0xf - Transparent color.
BackStyle | 0x10 - Back style.
Locked | 0x13 - Locked.
AutoSize | 0x14 - Auto size.
BevelLightColor | 0x16 - Bevel light color.
BevelShadowColor | 0x17 - Bevel shadow color.
Moveable | 0x19 - Movable.
PenStyle | 0x1a - Pen style.
PenFillStyle | 0x1b - Pen fill style.
TextOrientation | 0x1c - Text orientation.
Sizeable | 0x21 - Sizeable.
TextLocked | 0x25 - Text locked.
HatchStyle | 0x26 - Hatch style.
HatchColor | 0x26 - Hatch color.
TextJustification | 0x29 - Text justification.
Cut | 0x3e8 - Cut.
Copy | 0x3e9 - Copy.
Paste | 0x3ea - Paste.
Delete | 0x3ef - Delete.
SeparatorBar | 0x3f2 - Separator Bar.
NudgeUp | 0x600 - Nudge up.
NudgeDown | 0x601 - Nudge down.
BringItemToFront | 0x602 - Bring item to front.
SendItemToBack | 0x603 - Send item to back.
MeasureChoice | 0x841 - Measure choice.
ShowAbbreviation | 0x840 - Show abbreviation.
ShowLength | 0x842 - Show length.
ShowGauge | 0x845 - Show gauge.
Fixed | 0x880 - Fixed.

See Also

PegasusImaging.WinForms.NotateXpress9 Namespace


WangType Enumeration

PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

WangType Enumeration

PegasusImaging.WinForms.NotateXpress9 Namespace : WangType Enumeration (PegasusImaging.WinForms.NotateXpress9)

Contains options for use with the WangType property.

Members

Member | Description
TypedText | 7 - Typed text.
Note | 10 - Note

See Also

PegasusImaging.WinForms.NotateXpress9 Namespace


NotateXpress.AnnotationAddedEventHandler Delegate

PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
Object that fired the event.
e
Contains information of the event that fired.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NotateXpress.AnnotationAddedEventHandler Delegate

PegasusImaging.WinForms.NotateXpress9 Namespace : NotateXpress.AnnotationAddedEventHandler Delegate

Fires when an annotation has been added.

[Visual Basic]
Public Delegate Sub NotateXpress.AnnotationAddedEventHandler( _
   ByVal sender As Object, _
   ByVal e As AnnotationAddedEventArgs _
)
[C#]
public delegate void NotateXpress.AnnotationAddedEventHandler(
   object sender,
   AnnotationAddedEventArgs e
);
[C++]
public: __gc __delegate void NotateXpress.AnnotationAddedEventHandler(
   Object* sender,
   AnnotationAddedEventArgs* e
)
[C++/CLI]
public delegate void NotateXpress.AnnotationAddedEventHandler(
   Object^ sender,
   AnnotationAddedEventArgs^ e
)

Parameters

sender
Object that fired the event.
e
Contains information of the event that fired.

See Also

PegasusImaging.WinForms.NotateXpress9 Namespace


NotateXpress.AnnotationDeletedEventHandler Delegate

PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
Object that fired the event.
e
Contains information of the event that fired.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NotateXpress.AnnotationDeletedEventHandler Delegate

PegasusImaging.WinForms.NotateXpress9 Namespace : NotateXpress.AnnotationDeletedEventHandler Delegate

Fires when an annotation has been deleted.

[Visual Basic]
Public Delegate Sub NotateXpress.AnnotationDeletedEventHandler( _
   ByVal sender As Object, _
   ByVal e As AnnotationDeletedEventArgs _
)
[C#]
public delegate void NotateXpress.AnnotationDeletedEventHandler(
   object sender,
   AnnotationDeletedEventArgs e
);
[C++]
public: __gc __delegate void NotateXpress.AnnotationDeletedEventHandler(
   Object* sender,
   AnnotationDeletedEventArgs* e
)
[C++/CLI]
public delegate void NotateXpress.AnnotationDeletedEventHandler(
   Object^ sender,
   AnnotationDeletedEventArgs^ e
)

Parameters

sender
Object that fired the event.
e
Contains information of the event that fired.

See Also

PegasusImaging.WinForms.NotateXpress9 Namespace


NotateXpress.AnnotationEndSelectedEventHandler Delegate

PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
Object that fired the event.
e
Contains information of the event that fired.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NotateXpress.AnnotationEndSelectedEventHandler Delegate

PegasusImaging.WinForms.NotateXpress9 Namespace : NotateXpress.AnnotationEndSelectedEventHandler Delegate

Fires when no annotations are selected.

[Visual Basic]
Public Delegate Sub NotateXpress.AnnotationEndSelectedEventHandler( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
[C#]
public delegate void NotateXpress.AnnotationEndSelectedEventHandler(
   object sender,
   EventArgs e
);
[C++]
public: __gc __delegate void NotateXpress.AnnotationEndSelectedEventHandler(
   Object* sender,
   EventArgs* e
)
[C++/CLI]
public delegate void NotateXpress.AnnotationEndSelectedEventHandler(
   Object^ sender,
   EventArgs^ e
)

Parameters

sender
Object that fired the event.
e
Contains information of the event that fired.

See Also

PegasusImaging.WinForms.NotateXpress9 Namespace


NotateXpress.AnnotationMovedEventHandler Delegate

PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
Object that fired the event.
e
Contains information of the event that fired.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NotateXpress.AnnotationMovedEventHandler Delegate

PegasusImaging.WinForms.NotateXpress9 Namespace : NotateXpress.AnnotationMovedEventHandler Delegate

Fires when an annotation has been moved.

[Visual Basic]
Public Delegate Sub NotateXpress.AnnotationMovedEventHandler( _
   ByVal sender As Object, _
   ByVal e As AnnotationMovedEventArgs _
)
[C#]
public delegate void NotateXpress.AnnotationMovedEventHandler(
   object sender,
   AnnotationMovedEventArgs e
);
[C++]
public: __gc __delegate void NotateXpress.AnnotationMovedEventHandler(
   Object* sender,
   AnnotationMovedEventArgs* e
)
[C++/CLI]
public delegate void NotateXpress.AnnotationMovedEventHandler(
   Object^ sender,
   AnnotationMovedEventArgs^ e
)

Parameters

sender
Object that fired the event.
e
Contains information of the event that fired.

See Also

PegasusImaging.WinForms.NotateXpress9 Namespace


NotateXpress.AnnotationSelectedEventHandler Delegate

PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
Object that fired the event.
e
Contains information of the event that fired.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NotateXpress.AnnotationSelectedEventHandler Delegate

PegasusImaging.WinForms.NotateXpress9 Namespace : NotateXpress.AnnotationSelectedEventHandler Delegate

Fires when an annotation has been selected.

[Visual Basic]
Public Delegate Sub NotateXpress.AnnotationSelectedEventHandler( _
   ByVal sender As Object, _
   ByVal e As AnnotationSelectedEventArgs _
)
[C#]
public delegate void NotateXpress.AnnotationSelectedEventHandler(
   object sender,
   AnnotationSelectedEventArgs e
);
[C++]
public: __gc __delegate void NotateXpress.AnnotationSelectedEventHandler(
   Object* sender,
   AnnotationSelectedEventArgs* e
)
[C++/CLI]
public delegate void NotateXpress.AnnotationSelectedEventHandler(
   Object^ sender,
   AnnotationSelectedEventArgs^ e
)

Parameters

sender
Object that fired the event.
e
Contains information of the event that fired.

See Also

PegasusImaging.WinForms.NotateXpress9 Namespace


NotateXpress.ClickEventHandler Delegate

PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
Object that fired the event.
e
Contains information of the event that fired.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NotateXpress.ClickEventHandler Delegate

PegasusImaging.WinForms.NotateXpress9 Namespace : NotateXpress.ClickEventHandler Delegate

Raises when an annotation object is clicked in Interactive Mode.

[Visual Basic]
Public Delegate Sub NotateXpress.ClickEventHandler( _
   ByVal sender As Object, _
   ByVal e As ClickEventArgs _
)
[C#]
public delegate void NotateXpress.ClickEventHandler(
   object sender,
   ClickEventArgs e
);
[C++]
public: __gc __delegate void NotateXpress.ClickEventHandler(
   Object* sender,
   ClickEventArgs* e
)
[C++/CLI]
public delegate void NotateXpress.ClickEventHandler(
   Object^ sender,
   ClickEventArgs^ e
)

Parameters

sender
Object that fired the event.
e
Contains information of the event that fired.

See Also

PegasusImaging.WinForms.NotateXpress9 Namespace


NotateXpress.ContextMenuEventHandler Delegate

PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
Object that fired the event.
e
Contains information of the event that fired.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NotateXpress.ContextMenuEventHandler Delegate

PegasusImaging.WinForms.NotateXpress9 Namespace : NotateXpress.ContextMenuEventHandler Delegate

Contains event data for ContextMenu events when the NotateXpress Menu is turned off in Edit Mode.

[Visual Basic]
Public Delegate Sub NotateXpress.ContextMenuEventHandler( _
   ByVal sender As Object, _
   ByVal e As ContextMenuEventArgs _
)
[C#]
public delegate void NotateXpress.ContextMenuEventHandler(
   object sender,
   ContextMenuEventArgs e
);
[C++]
public: __gc __delegate void NotateXpress.ContextMenuEventHandler(
   Object* sender,
   ContextMenuEventArgs* e
)
[C++/CLI]
public delegate void NotateXpress.ContextMenuEventHandler(
   Object^ sender,
   ContextMenuEventArgs^ e
)

Parameters

sender
Object that fired the event.
e
Contains information of the event that fired.

See Also

PegasusImaging.WinForms.NotateXpress9 Namespace


NotateXpress.CurrentLayerChangeEventHandler Delegate

PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
Object that fired the event.
e
Contains information of the event that fired.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NotateXpress.CurrentLayerChangeEventHandler Delegate

PegasusImaging.WinForms.NotateXpress9 Namespace : NotateXpress.CurrentLayerChangeEventHandler Delegate

The CurrentLayerChange Event is fired whenever the current layer changes.

[Visual Basic]
Public Delegate Sub NotateXpress.CurrentLayerChangeEventHandler( _
   ByVal sender As Object, _
   ByVal e As CurrentLayerChangeEventArgs _
)
[C#]
public delegate void NotateXpress.CurrentLayerChangeEventHandler(
   object sender,
   CurrentLayerChangeEventArgs e
);
[C++]
public: __gc __delegate void NotateXpress.CurrentLayerChangeEventHandler(
   Object* sender,
   CurrentLayerChangeEventArgs* e
)
[C++/CLI]
public delegate void NotateXpress.CurrentLayerChangeEventHandler(
   Object^ sender,
   CurrentLayerChangeEventArgs^ e
)

Parameters

sender
Object that fired the event.
e
Contains information of the event that fired.

See Also

PegasusImaging.WinForms.NotateXpress9 Namespace


NotateXpress.DoubleClickEventHandler Delegate

PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
Object that fired the event.
e
Contains information of the event that fired.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NotateXpress.DoubleClickEventHandler Delegate

PegasusImaging.WinForms.NotateXpress9 Namespace : NotateXpress.DoubleClickEventHandler Delegate

Raises when an annotation object is double clicked in Interactive Mode.

[Visual Basic]
Public Delegate Sub NotateXpress.DoubleClickEventHandler( _
   ByVal sender As Object, _
   ByVal e As DoubleClickEventArgs _
)
[C#]
public delegate void NotateXpress.DoubleClickEventHandler(
   object sender,
   DoubleClickEventArgs e
);
[C++]
public: __gc __delegate void NotateXpress.DoubleClickEventHandler(
   Object* sender,
   DoubleClickEventArgs* e
)
[C++/CLI]
public delegate void NotateXpress.DoubleClickEventHandler(
   Object^ sender,
   DoubleClickEventArgs^ e
)

Parameters

sender
Object that fired the event.
e
Contains information of the event that fired.

See Also

PegasusImaging.WinForms.NotateXpress9 Namespace


NotateXpress.DroppedEventHandler Delegate

PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
Object that fired the event.
e
Contains information of the event that fired.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NotateXpress.DroppedEventHandler Delegate

PegasusImaging.WinForms.NotateXpress9 Namespace : NotateXpress.DroppedEventHandler Delegate

Fires when xfdf annotations that are not supported by NotateXpress are read in.

[Visual Basic]
Public Delegate Sub NotateXpress.DroppedEventHandler( _
   ByVal sender As Object, _
   ByVal e As DroppedEventArgs _
)
[C#]
public delegate void NotateXpress.DroppedEventHandler(
   object sender,
   DroppedEventArgs e
);
[C++]
public: __gc __delegate void NotateXpress.DroppedEventHandler(
   Object* sender,
   DroppedEventArgs* e
)
[C++/CLI]
public delegate void NotateXpress.DroppedEventHandler(
   Object^ sender,
   DroppedEventArgs^ e
)

Parameters

sender
Object that fired the event.
e
Contains information of the event that fired.

Remarks

One type that is currently unsupported is video.

See Also

PegasusImaging.WinForms.NotateXpress9 Namespace


NotateXpress.GetLayerPasswordEventHandler Delegate

PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
Object that fired the event.
e
Contains information of the event that fired.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NotateXpress.GetLayerPasswordEventHandler Delegate

PegasusImaging.WinForms.NotateXpress9 Namespace : NotateXpress.GetLayerPasswordEventHandler Delegate

The RequestLayerPassword event is sent during the loading of an annotation file for all layers that were saved with a password.

[Visual Basic]
Public Delegate Sub NotateXpress.GetLayerPasswordEventHandler( _
   ByVal sender As Object, _
   ByVal e As GetLayerPasswordEventArgs _
)
[C#]
public delegate void NotateXpress.GetLayerPasswordEventHandler(
   object sender,
   GetLayerPasswordEventArgs e
);
[C++]
public: __gc __delegate void NotateXpress.GetLayerPasswordEventHandler(
   Object* sender,
   GetLayerPasswordEventArgs* e
)
[C++/CLI]
public delegate void NotateXpress.GetLayerPasswordEventHandler(
   Object^ sender,
   GetLayerPasswordEventArgs^ e
)

Parameters

sender
Object that fired the event.
e
Contains information of the event that fired.

Remarks

If the correct password is returned from this event, the layer is decrypted and available for display. The layer is discarded if an incorrect password is supplied.

The LayerName parameter supplied with the event is the name (if any) set as the name of this layer.

To set the correct password, modify the passed LayerPassword parameter.

See Also

PegasusImaging.WinForms.NotateXpress9 Namespace


NotateXpress.GroupDeselectedEventHandler Delegate

PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
Object that fired the event.
e
Contains information of the event that fired.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NotateXpress.GroupDeselectedEventHandler Delegate

PegasusImaging.WinForms.NotateXpress9 Namespace : NotateXpress.GroupDeselectedEventHandler Delegate

Fired when an annotation group is unselected

[Visual Basic]
Public Delegate Sub NotateXpress.GroupDeselectedEventHandler( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
[C#]
public delegate void NotateXpress.GroupDeselectedEventHandler(
   object sender,
   EventArgs e
);
[C++]
public: __gc __delegate void NotateXpress.GroupDeselectedEventHandler(
   Object* sender,
   EventArgs* e
)
[C++/CLI]
public delegate void NotateXpress.GroupDeselectedEventHandler(
   Object^ sender,
   EventArgs^ e
)

Parameters

sender
Object that fired the event.
e
Contains information of the event that fired.

See Also

PegasusImaging.WinForms.NotateXpress9 Namespace


NotateXpress.GroupSelectedEventHandler Delegate

PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
Object that fired the event.
e
Contains information of the event that fired.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NotateXpress.GroupSelectedEventHandler Delegate

PegasusImaging.WinForms.NotateXpress9 Namespace : NotateXpress.GroupSelectedEventHandler Delegate

Fired when an annotation group is selected

[Visual Basic]
Public Delegate Sub NotateXpress.GroupSelectedEventHandler( _
   ByVal sender As Object, _
   ByVal e As GroupSelectedEventArgs _
)
[C#]
public delegate void NotateXpress.GroupSelectedEventHandler(
   object sender,
   GroupSelectedEventArgs e
);
[C++]
public: __gc __delegate void NotateXpress.GroupSelectedEventHandler(
   Object* sender,
   GroupSelectedEventArgs* e
)
[C++/CLI]
public delegate void NotateXpress.GroupSelectedEventHandler(
   Object^ sender,
   GroupSelectedEventArgs^ e
)

Parameters

sender
Object that fired the event.
e
Contains information of the event that fired.

See Also

PegasusImaging.WinForms.NotateXpress9 Namespace


NotateXpress.ItemChangedEventHandler Delegate

PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
Object that fired the event.
e
Contains information of the event that fired.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NotateXpress.ItemChangedEventHandler Delegate

PegasusImaging.WinForms.NotateXpress9 Namespace : NotateXpress.ItemChangedEventHandler Delegate

The ItemChanged event is sent when an annotation object changes. When an object is moved or resized by the user, an AnnotationMoved is fired.

[Visual Basic]
Public Delegate Sub NotateXpress.ItemChangedEventHandler( _
   ByVal sender As Object, _
   ByVal e As ItemChangedEventArgs _
)
[C#]
public delegate void NotateXpress.ItemChangedEventHandler(
   object sender,
   ItemChangedEventArgs e
);
[C++]
public: __gc __delegate void NotateXpress.ItemChangedEventHandler(
   Object* sender,
   ItemChangedEventArgs* e
)
[C++/CLI]
public delegate void NotateXpress.ItemChangedEventHandler(
   Object^ sender,
   ItemChangedEventArgs^ e
)

Parameters

sender
Object that fired the event.
e
Contains information of the event that fired.

See Also

PegasusImaging.WinForms.NotateXpress9 Namespace


NotateXpress.LayerRestoredEventHandler Delegate

PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
Object that fired the event.
e
Contains information of the event that fired.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NotateXpress.LayerRestoredEventHandler Delegate

PegasusImaging.WinForms.NotateXpress9 Namespace : NotateXpress.LayerRestoredEventHandler Delegate

The LayerRestored Event is fired for each layer restored during the loading of a previously saved annotation file.

[Visual Basic]
Public Delegate Sub NotateXpress.LayerRestoredEventHandler( _
   ByVal sender As Object, _
   ByVal e As LayerRestoredEventArgs _
)
[C#]
public delegate void NotateXpress.LayerRestoredEventHandler(
   object sender,
   LayerRestoredEventArgs e
);
[C++]
public: __gc __delegate void NotateXpress.LayerRestoredEventHandler(
   Object* sender,
   LayerRestoredEventArgs* e
)
[C++/CLI]
public delegate void NotateXpress.LayerRestoredEventHandler(
   Object^ sender,
   LayerRestoredEventArgs^ e
)

Parameters

sender
Object that fired the event.
e
Contains information of the event that fired.

See Also

PegasusImaging.WinForms.NotateXpress9 Namespace


NotateXpress.MappingInputEventHandler Delegate

PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
Object that fired the event.
e
Contains information of the event that fired.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NotateXpress.MappingInputEventHandler Delegate

PegasusImaging.WinForms.NotateXpress9 Namespace : NotateXpress.MappingInputEventHandler Delegate

This event is for an advanced user who wants to change how NotateXpress does its coordinate conversions.

[Visual Basic]
Public Delegate Sub NotateXpress.MappingInputEventHandler( _
   ByVal sender As Object, _
   ByVal e As MappingInputEventArgs _
)
[C#]
public delegate void NotateXpress.MappingInputEventHandler(
   object sender,
   MappingInputEventArgs e
);
[C++]
public: __gc __delegate void NotateXpress.MappingInputEventHandler(
   Object* sender,
   MappingInputEventArgs* e
)
[C++/CLI]
public delegate void NotateXpress.MappingInputEventHandler(
   Object^ sender,
   MappingInputEventArgs^ e
)

Parameters

sender
Object that fired the event.
e
Contains information of the event that fired.

Remarks

This event is fired when reading in an xml based annotation format that is specified for a coordinate system that is calculated. The nxxml would have to been saved using SaveOptions.Mapping of PDF or User for this to fire in nxxml. This will always fire when reading in a xfdf.

See Also

PegasusImaging.WinForms.NotateXpress9 Namespace


NotateXpress.MappingOutputEventHandler Delegate

PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
Object that fired the event.
e
Contains information of the event that fired.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NotateXpress.MappingOutputEventHandler Delegate

PegasusImaging.WinForms.NotateXpress9 Namespace : NotateXpress.MappingOutputEventHandler Delegate

This event is for an advanced user who wants to change how NotateXpress does its coordinate conversions.

[Visual Basic]
Public Delegate Sub NotateXpress.MappingOutputEventHandler( _
   ByVal sender As Object, _
   ByVal e As MappingOutputEventArgs _
)
[C#]
public delegate void NotateXpress.MappingOutputEventHandler(
   object sender,
   MappingOutputEventArgs e
);
[C++]
public: __gc __delegate void NotateXpress.MappingOutputEventHandler(
   Object* sender,
   MappingOutputEventArgs* e
)
[C++/CLI]
public delegate void NotateXpress.MappingOutputEventHandler(
   Object^ sender,
   MappingOutputEventArgs^ e
)

Parameters

sender
Object that fired the event.
e
Contains information of the event that fired.

Remarks

This event is fired when writing in an xml based annotation format that is specified for a coordinate system that is calculated. The nxxml would have to been set using SaveOptions.Mapping of PDF or User for this to fire in nxxml. This will always fire when reading in a xfdf.

See Also

PegasusImaging.WinForms.NotateXpress9 Namespace


NotateXpress.MenuEventHandler Delegate

PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
Object that fired the event.
e
Contains information of the event that fired.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NotateXpress.MenuEventHandler Delegate

PegasusImaging.WinForms.NotateXpress9 Namespace : NotateXpress.MenuEventHandler Delegate

The MenuSelect event is fired when a user chooses any of the items on the NotateXpress context menu while over an annotation or on the toolbar.

[Visual Basic]
Public Delegate Sub NotateXpress.MenuEventHandler( _
   ByVal sender As Object, _
   ByVal e As MenuEventArgs _
)
[C#]
public delegate void NotateXpress.MenuEventHandler(
   object sender,
   MenuEventArgs e
);
[C++]
public: __gc __delegate void NotateXpress.MenuEventHandler(
   Object* sender,
   MenuEventArgs* e
)
[C++/CLI]
public delegate void NotateXpress.MenuEventHandler(
   Object^ sender,
   MenuEventArgs^ e
)

Parameters

sender
Object that fired the event.
e
Contains information of the event that fired.

See Also

PegasusImaging.WinForms.NotateXpress9 Namespace


NotateXpress.MouseDownEventHandler Delegate

PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
Object that fired the event.
e
Contains information of the event that fired.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NotateXpress.MouseDownEventHandler Delegate

PegasusImaging.WinForms.NotateXpress9 Namespace : NotateXpress.MouseDownEventHandler Delegate

Raises when an annotation object receives a MouseDown event in Interactive Mode.

[Visual Basic]
Public Delegate Sub NotateXpress.MouseDownEventHandler( _
   ByVal sender As Object, _
   ByVal e As MouseDownEventArgs _
)
[C#]
public delegate void NotateXpress.MouseDownEventHandler(
   object sender,
   MouseDownEventArgs e
);
[C++]
public: __gc __delegate void NotateXpress.MouseDownEventHandler(
   Object* sender,
   MouseDownEventArgs* e
)
[C++/CLI]
public delegate void NotateXpress.MouseDownEventHandler(
   Object^ sender,
   MouseDownEventArgs^ e
)

Parameters

sender
Object that fired the event.
e
Contains information of the event that fired.

See Also

PegasusImaging.WinForms.NotateXpress9 Namespace


NotateXpress.MouseMoveEventHandler Delegate

PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
Object that fired the event.
e
Contains information of the event that fired.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NotateXpress.MouseMoveEventHandler Delegate

PegasusImaging.WinForms.NotateXpress9 Namespace : NotateXpress.MouseMoveEventHandler Delegate

Raises when the mouse is moved over an annotation object in Interactive Mode.

[Visual Basic]
Public Delegate Sub NotateXpress.MouseMoveEventHandler( _
   ByVal sender As Object, _
   ByVal e As MouseMoveEventArgs _
)
[C#]
public delegate void NotateXpress.MouseMoveEventHandler(
   object sender,
   MouseMoveEventArgs e
);
[C++]
public: __gc __delegate void NotateXpress.MouseMoveEventHandler(
   Object* sender,
   MouseMoveEventArgs* e
)
[C++/CLI]
public delegate void NotateXpress.MouseMoveEventHandler(
   Object^ sender,
   MouseMoveEventArgs^ e
)

Parameters

sender
Object that fired the event.
e
Contains information of the event that fired.

See Also

PegasusImaging.WinForms.NotateXpress9 Namespace


NotateXpress.MouseUpEventHandler Delegate

PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
Object that fired the event.
e
Contains information of the event that fired.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NotateXpress.MouseUpEventHandler Delegate

PegasusImaging.WinForms.NotateXpress9 Namespace : NotateXpress.MouseUpEventHandler Delegate

Raises when an annotation object receives a MouseUp event in Interactive Mode.

[Visual Basic]
Public Delegate Sub NotateXpress.MouseUpEventHandler( _
   ByVal sender As Object, _
   ByVal e As MouseUpEventArgs _
)
[C#]
public delegate void NotateXpress.MouseUpEventHandler(
   object sender,
   MouseUpEventArgs e
);
[C++]
public: __gc __delegate void NotateXpress.MouseUpEventHandler(
   Object* sender,
   MouseUpEventArgs* e
)
[C++/CLI]
public delegate void NotateXpress.MouseUpEventHandler(
   Object^ sender,
   MouseUpEventArgs^ e
)

Parameters

sender
Object that fired the event.
e
Contains information of the event that fired.

See Also

PegasusImaging.WinForms.NotateXpress9 Namespace


NotateXpress.StampingEventHandler Delegate

PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
Object that fired the event.
e
Contains information of the event that fired.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NotateXpress.StampingEventHandler Delegate

PegasusImaging.WinForms.NotateXpress9 Namespace : NotateXpress.StampingEventHandler Delegate

The Stamping event is sent immediately before each stamp tool use, providing an opportunity to change the stamp text of the annotation object before it is added.

[Visual Basic]
Public Delegate Sub NotateXpress.StampingEventHandler( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
[C#]
public delegate void NotateXpress.StampingEventHandler(
   object sender,
   EventArgs e
);
[C++]
public: __gc __delegate void NotateXpress.StampingEventHandler(
   Object* sender,
   EventArgs* e
)
[C++/CLI]
public delegate void NotateXpress.StampingEventHandler(
   Object^ sender,
   EventArgs^ e
)

Parameters

sender
Object that fired the event.
e
Contains information of the event that fired.

See Also

PegasusImaging.WinForms.NotateXpress9 Namespace


NotateXpress.TextEditEndEventHandler Delegate

PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
Object that fired the event.
e
Contains information of the event that fired.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NotateXpress.TextEditEndEventHandler Delegate

PegasusImaging.WinForms.NotateXpress9 Namespace : NotateXpress.TextEditEndEventHandler Delegate

Fired when text editing has ended. Editing is now disabled

[Visual Basic]
Public Delegate Sub NotateXpress.TextEditEndEventHandler( _
   ByVal sender As Object, _
   ByVal e As TextEditEndEventArgs _
)
[C#]
public delegate void NotateXpress.TextEditEndEventHandler(
   object sender,
   TextEditEndEventArgs e
);
[C++]
public: __gc __delegate void NotateXpress.TextEditEndEventHandler(
   Object* sender,
   TextEditEndEventArgs* e
)
[C++/CLI]
public delegate void NotateXpress.TextEditEndEventHandler(
   Object^ sender,
   TextEditEndEventArgs^ e
)

Parameters

sender
Object that fired the event.
e
Contains information of the event that fired.

See Also

PegasusImaging.WinForms.NotateXpress9 Namespace


NotateXpress.TextEditStartEventHandler Delegate

PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
Object that fired the event.
e
Contains information of the event that fired.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NotateXpress.TextEditStartEventHandler Delegate

PegasusImaging.WinForms.NotateXpress9 Namespace : NotateXpress.TextEditStartEventHandler Delegate

Fired when The user has double-clicked a text item and editing is now enabled.

[Visual Basic]
Public Delegate Sub NotateXpress.TextEditStartEventHandler( _
   ByVal sender As Object, _
   ByVal e As TextEditStartEventArgs _
)
[C#]
public delegate void NotateXpress.TextEditStartEventHandler(
   object sender,
   TextEditStartEventArgs e
);
[C++]
public: __gc __delegate void NotateXpress.TextEditStartEventHandler(
   Object* sender,
   TextEditStartEventArgs* e
)
[C++/CLI]
public delegate void NotateXpress.TextEditStartEventHandler(
   Object^ sender,
   TextEditStartEventArgs^ e
)

Parameters

sender
Object that fired the event.
e
Contains information of the event that fired.

See Also

PegasusImaging.WinForms.NotateXpress9 Namespace


NotateXpress.ToolbarEventHandler Delegate

PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
Object that fired the event.
e
Contains information of the event that fired.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NotateXpress.ToolbarEventHandler Delegate

PegasusImaging.WinForms.NotateXpress9 Namespace : NotateXpress.ToolbarEventHandler Delegate

The ToolbarSelect event is fired when a selection changes for the current tool on the toolbar.

[Visual Basic]
Public Delegate Sub NotateXpress.ToolbarEventHandler( _
   ByVal sender As Object, _
   ByVal e As ToolbarEventArgs _
)
[C#]
public delegate void NotateXpress.ToolbarEventHandler(
   object sender,
   ToolbarEventArgs e
);
[C++]
public: __gc __delegate void NotateXpress.ToolbarEventHandler(
   Object* sender,
   ToolbarEventArgs* e
)
[C++/CLI]
public delegate void NotateXpress.ToolbarEventHandler(
   Object^ sender,
   ToolbarEventArgs^ e
)

Parameters

sender
Object that fired the event.
e
Contains information of the event that fired.

See Also

PegasusImaging.WinForms.NotateXpress9 Namespace


NotateXpress.UserDrawEventHandler Delegate

PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
Object that fired the event.
e
Contains information of the event that fired.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NotateXpress.UserDrawEventHandler Delegate

PegasusImaging.WinForms.NotateXpress9 Namespace : NotateXpress.UserDrawEventHandler Delegate

The UserDraw event is raised for a Rectangle object during its paint when the Rectangle’s UserDraw attribute is True.

[Visual Basic]
Public Delegate Sub NotateXpress.UserDrawEventHandler( _
   ByVal sender As Object, _
   ByVal e As UserDrawEventArgs _
)
[C#]
public delegate void NotateXpress.UserDrawEventHandler(
   object sender,
   UserDrawEventArgs e
);
[C++]
public: __gc __delegate void NotateXpress.UserDrawEventHandler(
   Object* sender,
   UserDrawEventArgs* e
)
[C++/CLI]
public delegate void NotateXpress.UserDrawEventHandler(
   Object^ sender,
   UserDrawEventArgs^ e
)

Parameters

sender
Object that fired the event.
e
Contains information of the event that fired.

Remarks

When the UserDraw event is raised, the Rectangle does not perform its normal painting, but simply raises the event.

The event passes the device context, the Rectangle’s coordinates, Layer, Element, and UserLong.

See Also

PegasusImaging.WinForms.NotateXpress9 Namespace


NotateXpress.UserGroupCreatedEventHandler Delegate

PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
Object that fired the event.
e
Contains information of the event that fired.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NotateXpress.UserGroupCreatedEventHandler Delegate

PegasusImaging.WinForms.NotateXpress9 Namespace : NotateXpress.UserGroupCreatedEventHandler Delegate

The UserGroupCreated event is sent when a user creates a new group by selecting multiple objects and then pressing Ctrl-G.

[Visual Basic]
Public Delegate Sub NotateXpress.UserGroupCreatedEventHandler( _
   ByVal sender As Object, _
   ByVal e As UserGroupCreatedEventArgs _
)
[C#]
public delegate void NotateXpress.UserGroupCreatedEventHandler(
   object sender,
   UserGroupCreatedEventArgs e
);
[C++]
public: __gc __delegate void NotateXpress.UserGroupCreatedEventHandler(
   Object* sender,
   UserGroupCreatedEventArgs* e
)
[C++/CLI]
public delegate void NotateXpress.UserGroupCreatedEventHandler(
   Object^ sender,
   UserGroupCreatedEventArgs^ e
)

Parameters

sender
Object that fired the event.
e
Contains information of the event that fired.

Remarks

In order for the user to create a group in this manner, the property AllowUserGrouping must be set to true.

See Also

PegasusImaging.WinForms.NotateXpress9 Namespace


NotateXpress.UserGroupDestroyedEventHandler Delegate

PegasusImaging.WinForms.NotateXpress9 Namespace

Language

Visual Basic

C#

C++

C++/CLI

Show All

sender
Object that fired the event.
e
Contains information of the event that fired.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NotateXpress.UserGroupDestroyedEventHandler Delegate

PegasusImaging.WinForms.NotateXpress9 Namespace : NotateXpress.UserGroupDestroyedEventHandler Delegate

The UserGroupDestroyed event is sent when a user destroys a selected group by pressing Ctrl-U.

[Visual Basic]
Public Delegate Sub NotateXpress.UserGroupDestroyedEventHandler( _
   ByVal sender As Object, _
   ByVal e As UserGroupDestroyedEventArgs _
)
[C#]
public delegate void NotateXpress.UserGroupDestroyedEventHandler(
   object sender,
   UserGroupDestroyedEventArgs e
);
[C++]
public: __gc __delegate void NotateXpress.UserGroupDestroyedEventHandler(
   Object* sender,
   UserGroupDestroyedEventArgs* e
)
[C++/CLI]
public delegate void NotateXpress.UserGroupDestroyedEventHandler(
   Object^ sender,
   UserGroupDestroyedEventArgs^ e
)

Parameters

sender
Object that fired the event.
e
Contains information of the event that fired.

Remarks

In order for the user to destroy a group in this manner, the property AllowUserGrouping must be set to true.

See Also

PegasusImaging.WinForms.NotateXpress9 Namespace


Glossary

A | B | C | D | E | F | G | H | I | J | K | L | M | N | O | P | Q | R | S | T | U | V | W | X | Y | Z

A

Aspect Ratio
There are two kinds of aspect ratio that you need to be aware of when working with 2D images; the image aspect ratio and the pixel aspect ratio.The image aspect ratio is the ratio of the width of the image to the height of the image. It's important when resizing an image to keep this ratio as close to unchanged as possible or the image may become distorted.The pixel aspect ratio is the shape of the pixels in the image. For computers this is normally square (1:1) or close to it depending on the monitor settings. For some video sources, however, the pixels may be slightly rectangular.

B

Black on Edge
The minimum or maximum number of pixels on the vertical or horizontal edge of an image or document.

BMP
The Microsoft Windows Bitmap file format is based on the Microsoft Windows internal bitmap data structures. The BMP format is very widely used and it is quick and easy to read. Although most BMP files are uncompressed, a type of run length encoding is supported.

BPP
Bits per pixel

Brightness
A Pegasus Imaging method that enhances the brightness attributes of the pixels in the bitmap. Positive settings produce brighter pixels while negative settings produce darker pixels.

C

CCITT
CCITT is the most widely used compression scheme for transmitting binary (black and white) image data. CCITT was established by the International Telegraph and Telephone Consultative Committee. The Group 3 and Group 4 CCITT compression standards are widely used for transmitting fax data. CCITT compressed images are typically stored in the TIFF image format.

CIELAB
Three dimensional color space defined by the Commission Internationale de L'Eclairage, or CIE. L describes relative lightness; A represents relative redness-greenness,and B represents relative yellowness-blueness.

Container
Gets the container for the component. An object implementing the IContainer interface that represents the component's container, or a null reference (Nothing in Visual Basic) if the component does not have a site.

Contrast
An Pegasus Imaging method that enhances the contrast attributes of the pixels in the bitmap. Positive settings produce a higher contrast image while negative settings produce a lower contrast image. Images with a higher contrast have a higher frequency of pixel intensities near the ends of the intensity spectrum while images with a lower contrast have a higher frequency of pixels near the middle of the intensity spectrum.

Cosited
Specifies horizontally coincident positioning of subsampled chrominance components relative to luminance sample.

CreateObjRef
Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.

D

DCOM
Microsoft's extension of their Component Object Model (COM) to support objects distributed across a network. DCOM is currently implemented only by Microsoft for Microsoft Windows; and by Software AG, under the name "EntireX", for Unix and IBM mainframes. DCOM serves the same purpose as IBM's DSOM protocol. DCOM is an object model, but has no provisions for inheritance.

DCX
An image format containing multiple PCX images. A DCX file can contain a maximum of 1024 images.

DDB
Microsoft Device Dependent Bitmap. The actual in-memory information used to display an image.

DEP
Data Execution Prevention (computer security)

Despeckle
A modified median filter primarily used for reducing noise in document images. Despeckling divides the image into pixel groups and uses the brightness value to adjust brightness spikes. This filter will reduce noise in a black and white document image with minimal distortion of document text.

Device Context
A device context is a structure that defines a set of graphic objects and their associated attributes, as well as the graphic modes that affect output. The graphic objects include a pen for line drawing, a brush for painting and filling, a bitmap for copying or scrolling parts of the screen, a palette for defining the set of available colors, a region for clipping and other operations, and a path for painting and drawing operations.

DIB
Microsoft Device Independent Bitmap. An alternative file extension used by the Microsoft Windows Bitmap.

DICOM
Digital Imaging and Communication, a standard for handling digital medical images.

Dispose
Releases the resources used by the Component.

Disposed
Adds an event handler to listen to the Disposed event on the component. When you create a Disposed delegate, you identify the method that handles the event.

Dithering
A technique used in computer graphics to create the illusion of varying shades of gray on a monochrome display or printer, or additional colors on a color display or printer. Dithering relies on treating areas of an image as groups of dots that are colored in different patterns. Akin to the print images called halftones, dithering takes advantage of the eye’s tendency to blur spots of different colors by averaging their effects and merging them into a single perceived shade or color. Depending on the ratio of black dots to white dots within a given area, the overall effect is of a particular shade of gray. Dithering is used to add realism to computer graphics and to soften jagged edges in curves and diagonal lines at low resolutions.

E

Emboss
A Pegasus Imaging method that causes the foreground of an image to appear raised from background. Embossing gives the image a raised metallic-like look

ePIC
Pegasus Imaging enhanced PIC image format. This high performance image compression combines the patented ELS arithmetic coder with the high performance Pegasus JPEG libraries. The result is a new and unbeatable compression technology. The ePIC compression has significant advantages over standard JPEG. Most importantly it produces smaller file sizes and decompresses extremely quickly. ePIC images can be password encrypted. These images can also be 'zoomed' or scaled to larger, arbitrary sizes.

Equalize
An Pegasus Imaging method that is a point process used for adjusting the contrast of an image. A frequency histogram of the colors of the image is computed and adjusted to equalize the colors across the full spectrum of intensity values. The equalized colors are applied to each pixel in the image.

EXIF
EXchangeable Image File format (Japan Electronic Industry Development Association, JEIDA), compressed image format used in digital cameras.

F

Flate
The lossless deflate compression algorithm is based on two other compression algorithms: huffman encoding and LZ77 compression.

Float
Denotes a simple type that stores 32-bit floating-point values.

G

Gamma
A non-linear brightness transform. Gamma values greater than 0 and less that 1.0 generate exponential curves that dim and image. Gamma values greater than 1.0 generate exponential curves that brighten an image.

Gamut
In graphics, the gamut of a monitor is the range of colours it can display. There are some colours which can't be made up of a mixture of red, green and blue phosphor emissions and so can't be displayed by any monitor.

GDI
Acronym for Graphical Device Interface. In Windows, a graphics display system used by applications to display or print bitmapped text (TrueType fonts), images, and other graphical elements. The GDI is responsible for drawing dialog boxes, buttons, and other elements in a consistent style on screen by calling the appropriate screen drivers and passing them the information on the item to be drawn. The GDI also works with GDI printers, which have limited ability to prepare a page for printing. Instead, the GDI handles that task by calling the appropriate printer drivers and moving the image or document directly to the printer, rather than reformatting the image or document in PostScript or another printer language.

GetLifetimeService
Retrieves the current lifetime service object that controls the lifetime policy for this instance.

GIF
Graphical Interchange File, originally developed by CompuServe as a machine independent format. GIF is one of the most popular image formats for storing 8-bit digitized images. GIF files are typically smaller than uncompressed formats like BMP due to the LZW compression algorithm that GIF uses.

Greyscale
If the pixels of a grey-scale image have N bits, they may take values from zero, representing black up to 2^N-1, representing white with intermediate values representing increasingly light shades of grey. If N=1, the image is not called grey-scale, but could be called monochrome.

H

Halftone
Pertaining to pictures in which gradation of tone in the photograph is reproduced by a graduated system of dotted and checkered spots, usually nearly invisible to the unaided eye, produced by the interposition between the camera and the object of a screen. The name alludes to the fact that this process was the first that was practically successful in reproducing the half tones of the photograph.

hDIB
Handle to a Device Independent Bitmap. An operation affecting the image may cause the hDIB before the operation to become invalid.

Hue
One of the 3 components of the HSL (Hue, Saturation and Luminance ) color space. The hue component controls the overall color space of an image. Adjusting the hue of the image adjusts the color spectrum from red through yellow, green, blue, and violet.

I

ICO
Microsoft Windows Icon file format.

Inverse
To reverse something or change it to its opposite. For example, to invert the colors on a monochrome display means to change light to dark and dark to light. In a digital electrical signal, to replace a high level by a low level and vice versa. This type of operation is the electronic equivalent of a Boolean NOT operation.

IOD
Information Object Definition.

J

JIF
An alternative image file extension used for a JFIF compliant JPEG file. Because many early versions of JPEG contained a JPG extension but did not adhere to the JFIF specifications, the JIF extension was created to identify JPEG files that are JFIF compliant. As the popularity of JPEG grew, JFIF compliance became synonymous with the JPG extension and thus the JIF extension is rarely used.

JPEG
The JPEG (Joint Photographic Experts Group) standard is one of the most important image data compression standards. It is widely used in many industries including graphic arts, desktop publishing, medical imaging, and many more. It is also becoming one of the most widely used image formats on the Internet. Although JPEG supports a lossless mode, it most commonly uses lossy compression. This allows JPEG to achieve very high compression ratios. JPEG compression uses several compression modes. First, an image is transformed to the frequency domain using the discrete cosine transform. The smaller valued frequency components are discarded leaving only the larger valued components. The remaining components are DPCM coded and then Huffman coded. Fortunately, ImagXpress handles all of this for you! The compression level is adjustable. Higher quality settings produce a larger image file size with higher image quality. Lower quality settings produce a smaller image file size with lower image quality. Typically, we have found that compression ratios of 10:1 or 15:1 (A 640x480x24-bit image is 921,600 bytes; a 15:1 compressed image would compress to only 61k) produce generally acceptable image quality for photographic type images. Images compressed at higher ratios begin to show more noticeable and sometimes objectionable artifacts and clarity loss. JPEG is a 24-bit format and works only with 24-bit images. If you compress an 8-bit image, ImagXpress automatically converts it to 24-bit to do the compression, however, you will obtain better quality when the source image is 24-bit because 8-bit images only contain 256 colors. JPEG works best with photographic type images. It does not work well with solid colors, 16-color images, cartoon like images, or drawings. Progressive JPEG is a multiple-scan sequential JPEG format that is becoming popular on the Internet for the ability to display images in progressively clearer segments.

L

Little-endian
Describes a computer architecture in which, within a given 16- or 32-bit word, bytes at lower addresses have lower significance (the word is stored "little-end-first"). The PDP-11/VAX families of computers, Intel microprocessors, plus a lot of communications and networking hardware, are little-endian. The term is sometimes used to describe the ordering of units other than bytes; most often, bits within a byte.

Lock
A lock, represented by the Visual Basic keyword "SyncLock Statement," or the C# keyword "lock Statement", allows a single thread of execution to obtain exclusive execution rights on an object. Although using locks will guarantee that multiple threads do not simultaneously access an object, they can cause significant performance degradation.

Luminance
One of the 3 components of the HSL (Hue, Saturation and Luminance) color space. Luminance controls the overall brightness (energy/whiteness) of an image.

LUT
Look Up Table.

LZW
Lempel-Ziv-Welch (algorithm)

M

Matrix
A matrix filter, also called convolution, alters each pixel's color based on its current color and the colors of any neighboring pixels. The ImagXpress Matrix method uses a 3x3 matrix. The numbers in the matrix are coefficients. When a pixel is processed, its color value is multiplied by the coefficient in the center of the matrix, and any pixels within the 3x3 grid are multiplied by the corresponding coefficients in the matrix. The sum of the products becomes the target pixel's new value. The Divisor is simply the coefficient denominator. The matrix method is typically used for sharpening, softening, and edge enhancement.

Mosaic
A mosaic divides the bitmap into tiles of a specified size. All of the pixels in each tile are averaged and changed to the average color.

Multithreading
Multithreading, or free threading, refers to the ability of a program to execute multiple threads of operation simultaneously. In a single-threaded application, a user might spend idle time waiting for the calculations or database updates to finish. In a multithreaded application, these processes can proceed in the background so user time is not wasted. An example of a multithreaded application might be a program that receives user input on one thread, performs a variety of complex calculations on a second thread, and updates a database on a third thread. In a single-threaded application, a user might spend idle time waiting for the calculations or database updates to finish. In a multithreaded application, these processes can proceed in the background so user time is not wasted. Multithreading can be a powerful tool to use in component programming. By writing multithreaded components, you can create components that perform complex calculations in the background while leaving the user interface free to respond to user input. Although multithreading can be a powerful tool, it can also be difficult to apply correctly. Improperly implemented multithreaded code can degrade application performance, or even cause frozen applications. (See MSDN)

N

Negate
An ImagXpress method that creates a color negative of an image.

Noise
An ImagXpress method that adds random pixels to the bitmap.

O

Orthogonal
Used loosely to mean mutually independent or well separated. It describes sets of primitives or capabilities that, like linearly independent vectors in geometry, span the entire "capability space" and are in some sense non-overlapping or mutually independent. For example, in logic, the set of operators "not" and "or" is described as orthogonal, but the set "and", "or", and "not" is not (because any one of these can be expressed in terms of the others).

P

PBM
Portable bitmap image format, a very simple uncompressed 1-bit (black and white) image format. Data can be stored in either binary or ASCII format.

PGM
Portable Graymap image format. PGM is a very simple uncompressed 8-bit grayscale image format. Data can be stored in either binary or ASCII format.

Pica
A printer's unit of type size, equal to 12 points or about 1/6 of an inch. An equivalent unit of composition measurement used in determining the dimensions of lines, illustrations, or printed pages. A type size for typewriters, providing ten characters to the inch. (Probably from Medieval Latin "pca," a list of church services (perhaps from the typeface used to print it).

PNG
Portable Network Graphics (pronounced "ping") provides a portable, legally unencumbered (royalty-free), well-compressed, well-specified standard for lossless bitmapped image files. The initial motivation for developing PNG was to provide a royalty-free alternative to GIF. The design retains many of the features of GIF that make it an attractive format for transmission of images, such as lossless compression and progressive display capabilities. Additionally, it provides several advantages including 24-bit image support and generally better compression, although decompression is typically somewhat slower than GIF. PNG's success will be ultimately determined by its acceptability on the Internet. At the time of this writing, however, PNG has not been incorporated as part of the major Internet browsers.

PPM
Portable Pixmap image format, a very simple uncompressed 24-bit image format. Data is stored in RGB triplets and can be stored in either binary or ASCII format.

R

RGB
Red, Green Blue. Bitmapped images are most generally stored as RGB data. Each pixel or data point in a true color (24-bit) image contains 3 components, red, green and blue, that describe the color of the pixel. Each of the components can have a value between 0 and 255, 0 being the darkest shade of color and 255 being the lightest shade of color. Since each component can be stored in one byte (8-bits), the 3 components take up 3 bytes or 24-bits per pixel. 8-bit images contain one byte (8-bit) indexes for each pixel that map to a color table called a palette which contains a maximum of 256 RGB entries. Likewise, 4-bit images contain 4-bit indexes for each pixel that map to a palette which contains a maximum of 16 RGB entries. 1-bit images contain 1-bit per pixel. Each bit in a 1-bit image represents either black or white.

RLE
RLE stands for Run Length Encoding. It is a lossless algorithm that only offers decent compression ratios in specific types of data.

S

Saturation
One of the 3 components of the HSL (Hue, Saturation, and Luminance) color space. Saturation controls the purity of a color. Higher saturations result in richer, deeper colors. Lower saturations result in paler colors.

Scalar
In programming, any data type that stores a single value (a number or Boolean), as opposed to an aggregate data type that has many elements. A string is regarded as a scalar in some languages (PERL) and a vector of characters in others (C).

Sharpen
An ImagXpress method that is used to sharpen an image. The sharpen filter uses a high-pass convolution matrix filter to accentuate high frequency detail in the image.

Single
Value type represents a single-precision 32-bit number with values ranging from negative 3.402823e38 to positive 3.402823e38, as well as positive or negative zero, PositiveInfinity, NegativeInfinity, and not a number (NaN).

Soften
An ImagXpress method that is used to soften an image. The soften filter uses a low-pass convolution matrix filter to accentuate low frequency detail in the image.

Sprite
A small bitmap image, often used in animated games but also sometimes used as a synonym for icon.

sRGB
In 1996, Hewlett-Packard and Microsoft proposed a standard color space, sRGB, within Microsoft operating systems, HP products, the Internet, and all other interested vendors.

T

TGA
Targa Image File) format was developed by TrueVision for its Targa line of products. TGA is one of the earliest image formats and was the first popular format to support 24-bit color. TGA supports uncompressed and RLE compressed formats.

TIFF
Tag Image File Format, originally released by Aldus Corporation is a standard file format found in most paint, imaging, and desktop publishing programs. TIFF is extremely powerful, flexible, and extensible. However, because of its many nuances and its wide scope, TIFF can be a difficult format to understand as well as a difficult format to support. ImagXpress supports a wide range of TIFF 6.0 formats including uncompressed, CCITT RLE, CCITT Group 3 Fax, CCITT Group 4 Fax, LZW, Pack Bits, JPEG, and deflate compression types. ImagXpress supports black and white, RGB, and RGB palette images but it does not support transparency mask, CMYK, YCbCr, or CIELab.

TWAIN
TWAIN (Technology Without An Interesting Name) is a standard for controlling and acquiring image data from raster-generating devices such as scanners, digital cameras, and video digitizers. Manufacturers write the TWAIN driver (called the Source) for their device. Applications that are TWAIN compliant can be used with any TWAIN compliant Source. Likewise, a TWAIN compliant Source can be used with any TWAIN compliant application. Applications that you build with ImagXpress can be used to interface TWAIN compliant Sources to acquire image data. TWAIN compliant applications should provide the following: The capability to select the Source. This is required because you may have more than one TWAIN device connected to a computer. Use the TWAINSelect method to select the source. The ability to acquire image data. Use the TWAINAcquire method to acquire the image data. If Pegasus' TWAIN Acquire method is successful, the image data is converted to a DIB and the control's hDIB property is set to the resulting DIB handle. Once the image is acquired, you may use any of the image processing methods to alter or save the DIB. The TWAIN sample in the SAMPLES directory and the ImagXpress Demo application demonstrate how easy it is to add TWAIN support to your applications.

twip
Twips describe the sizes of characters produced by dot matrix printers, which were constrained to multiples of either 12 or 10 dots per inch.

V

VCL
A application framework library for Microsoft Windows and Borland Software Corp.'s Delphi and C++Builder rapid application development software. VCL was originally designed for Delphi but is now also used for C++Builder. This replaces Object Windows Library (OWL) as Borland's Windows C++ framework of choice. VCL encapsulates the C-based Win32 API into a much easier to use, object-oriented form. Like its direct rival, Microsoft Foundation Class Library (MFC), VCL includes classes to create Windows programs. The VCL component class can be inherited to create new VCL components, which are the building blocks of Delphi and C++Builder applications. VCL components compete somewhat with ActiveX controls, though a VCL wrapper can be created to make an ActiveX control seem like a VCL component.

VOI
Value Of Interest

Void structure
Indicates a method that does not return a value; that is, the method has the void return type.

W

Wintel
A term describing the combination of Microsoft Windows operating sytem running on PCs with Intel or compatible processors. Dominance of the wintel platform began with MS-DOS on PCs with Intel's 8-bit 8088 processors in 1979.

WMF
The Microsoft Windows Metafile format is used to store vector and bitmap image data. Because of its popularity and wide use, many Windows and non-Windows applications support WMF.

WSQ
Wavelet Scalar Quantization (WSQ) Gray-Scale Fingerprint Image Compression Specification based on the results of the NIST (National Institute of Standards and Technology) review. The benefit of WSQ fingerprint-specific compression is reduced file size. A sample fingerprint with a resolution of 589 pixels by 605 pixels, 8-bit grayscale results in a file size of 325 KB when compressed with the standard lossless compression technology LZW.

WYSIWYG
What You See Is What You Get; realsitic display of final print or screen image

X

XP
Microsoft says the Windows "XP" designation originates from the word "experience". Windows XP brings many features previously available only in the server- and workstation-oriented Windows NT and Windows 2000 families, such as greater stability and efficiency due to its pure 32-bit kernel, instead of the hybrid 16-bit/32-bit kernel in prior consumer versions of Windows. (The version number of Windows XP is 5.1 just as Windows 2000 was version 5.0, to denote two OS as descendants of Windows NT 4.0.)

Y

YCbCr
Family of color spaces used in video systems. Y is the luma component; Cb and Cr are the chroma components. YCbCr is often confused with the YUV color space; typically the terms YCbCr and YUV are used interchangeably, leading to confusion. In fact, digital signals, the term "YUV" probably really means "YCbCr." The term YCbCr is sometimes abbreviated to YCC. YCbCr signals (prior to scaling and offsets to place the signals into digital form) are created from the corresponding gamma-adjusted RGB (red, green and blue).


Assembly Overview

Namespaces

Namespace | Description
PegasusImaging.WinForms.NotateXpress9 |


Getting Started - PegasusImaging.WinForms.NotateXpress9

PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Getting Started

© 1997 - 2008, Pegasus Imaging Corporation, All Rights Reserved.


Introduction - PegasusImaging.WinForms.NotateXpress9

PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Introduction

© 1997 - 2008, Pegasus Imaging Corporation, All Rights Reserved.


BlockHighlightTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BlockHighlightTool Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : BlockHighlightTool Class

For a list of all members of this type, see BlockHighlightTool members.

Public Methods

Public Method NudgeDown (Inherited from Element) | Moves the specified annotation object one level down, towards the back, in the painting order of the specified layer.
Public Method NudgeUp (Inherited from Element) | Moves the specified annotation object one level up, towards the front, in the painting order of the specified layer.
Public Method UserDataAdd (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataDelete (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFind (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFindFirst (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFindNext (Inherited from Element) | User data can be added to each element in a key value pair.

See Also

BlockHighlightTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace


BrandingException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BrandingException Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : BrandingException Class

For a list of all members of this type, see BrandingException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

BrandingException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


BrandingException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BrandingException Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : BrandingException Class

For a list of all members of this type, see BrandingException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

BrandingException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Data Property

BrandingException Class | BrandingException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Data Property

PegasusImaging.WinForms.NotateXpress9 Namespace > BrandingException Class : Data Property (BrandingException)

Gets a collection of key/value pairs that provide additional, user-defined information about the exception.

[Visual Basic]
Public ReadOnly Property Data As IDictionary
[C#]
public IDictionary Data {get;}
[C++]
public: __property IDictionary* get_Data();
[C++/CLI]
public:
property IDictionary^ Data {
   IDictionary^ get();
}

See Also

BrandingException Class | BrandingException Members


GetBaseException Method

BrandingException Class | BrandingException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetBaseException Method

PegasusImaging.WinForms.NotateXpress9 Namespace > BrandingException Class : GetBaseException Method (BrandingException)

When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.

[Visual Basic]
Public Function GetBaseException() As Exception
[C#]
public Exception GetBaseException();
[C++]
public: Exception* GetBaseException();
[C++/CLI]
public:
Exception^ GetBaseException();

Return Type

The first exception thrown in a chain of exceptions. If the InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

See Also

BrandingException Class | BrandingException Members


GetObjectData Method

BrandingException Class | BrandingException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetObjectData Method

PegasusImaging.WinForms.NotateXpress9 Namespace > BrandingException Class : GetObjectData Method (BrandingException)

When overridden in a derived class, sets the SerializationInfo with information about the exception.

[Visual Basic]
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
[C++/CLI]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

BrandingException Class | BrandingException Members


GetType Method

BrandingException Class | BrandingException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetType Method

PegasusImaging.WinForms.NotateXpress9 Namespace > BrandingException Class : GetType Method (BrandingException)

Gets the runtime type of the current instance.

[Visual Basic]
Public Function GetType() As Type
[C#]
public Type GetType();
[C++]
public: Type* GetType();
[C++/CLI]
public:
Type^ GetType();

Return Type

A Type object that represents the exact runtime type of the current instance.

See Also

BrandingException Class | BrandingException Members


HelpLink Property

BrandingException Class | BrandingException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HelpLink Property

PegasusImaging.WinForms.NotateXpress9 Namespace > BrandingException Class : HelpLink Property (BrandingException)

Gets or sets a link to the help file associated with this exception.

[Visual Basic]
Public Property HelpLink As String
[C#]
public string HelpLink {get; set;}
[C++]
public: __property string* get_HelpLink();
public: __property void set_HelpLink(
   string* value
);
[C++/CLI]
public:
property String^ HelpLink {
   String^ get();
   void set (String^ value);
}

See Also

BrandingException Class | BrandingException Members


InnerException Property

BrandingException Class | BrandingException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InnerException Property

PegasusImaging.WinForms.NotateXpress9 Namespace > BrandingException Class : InnerException Property (BrandingException)

Gets the Exception instance that caused the current exception.

[Visual Basic]
Public ReadOnly Property InnerException As Exception
[C#]
public Exception InnerException {get;}
[C++]
public: __property Exception* get_InnerException();
[C++/CLI]
public:
property Exception^ InnerException {
   Exception^ get();
}

See Also

BrandingException Class | BrandingException Members


Message Property

BrandingException Class | BrandingException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Message Property

PegasusImaging.WinForms.NotateXpress9 Namespace > BrandingException Class : Message Property (BrandingException)

Gets a message that describes the current exception.

[Visual Basic]
Public ReadOnly Property Message As String
[C#]
public string Message {get;}
[C++]
public: __property string* get_Message();
[C++/CLI]
public:
property String^ Message {
   String^ get();
}

See Also

BrandingException Class | BrandingException Members


Source Property

BrandingException Class | BrandingException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Source Property

PegasusImaging.WinForms.NotateXpress9 Namespace > BrandingException Class : Source Property (BrandingException)

Gets or sets the name of the application or the object that causes the error.

[Visual Basic]
Public Property Source As String
[C#]
public string Source {get; set;}
[C++]
public: __property string* get_Source();
public: __property void set_Source(
   string* value
);
[C++/CLI]
public:
property String^ Source {
   String^ get();
   void set (String^ value);
}

See Also

BrandingException Class | BrandingException Members


StackTrace Property

BrandingException Class | BrandingException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StackTrace Property

PegasusImaging.WinForms.NotateXpress9 Namespace > BrandingException Class : StackTrace Property (BrandingException)

Gets a string representation of the frames on the call stack at the time the current exception was thrown.

[Visual Basic]
Public ReadOnly Property StackTrace As String
[C#]
public string StackTrace {get;}
[C++]
public: __property string* get_StackTrace();
[C++/CLI]
public:
property String^ StackTrace {
   String^ get();
}

See Also

BrandingException Class | BrandingException Members


TargetSite Property

BrandingException Class | BrandingException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TargetSite Property

PegasusImaging.WinForms.NotateXpress9 Namespace > BrandingException Class : TargetSite Property (BrandingException)

Gets the method that throws the current exception.

[Visual Basic]
Public ReadOnly Property TargetSite As MethodBase
[C#]
public MethodBase TargetSite {get;}
[C++]
public: __property MethodBase* get_TargetSite();
[C++/CLI]
public:
property MethodBase^ TargetSite {
   MethodBase^ get();
}

See Also

BrandingException Class | BrandingException Members


ToString Method

BrandingException Class | BrandingException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToString Method

PegasusImaging.WinForms.NotateXpress9 Namespace > BrandingException Class : ToString Method (BrandingException)

Creates and returns a string representation of the current exception.

[Visual Basic]
Public Function ToString() As String
[C#]
public string ToString();
[C++]
public: string* ToString();
[C++/CLI]
public:
String^ ToString();

Return Type

A string representation of the current exception.

See Also

BrandingException Class | BrandingException Members


BrandingSourceDibException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BrandingSourceDibException Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : BrandingSourceDibException Class

For a list of all members of this type, see BrandingSourceDibException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

BrandingSourceDibException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


BrandingSourceDibException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

BrandingSourceDibException Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : BrandingSourceDibException Class

For a list of all members of this type, see BrandingSourceDibException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

BrandingSourceDibException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Data Property

BrandingSourceDibException Class | BrandingSourceDibException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Data Property

PegasusImaging.WinForms.NotateXpress9 Namespace > BrandingSourceDibException Class : Data Property (BrandingSourceDibException)

Gets a collection of key/value pairs that provide additional, user-defined information about the exception.

[Visual Basic]
Public ReadOnly Property Data As IDictionary
[C#]
public IDictionary Data {get;}
[C++]
public: __property IDictionary* get_Data();
[C++/CLI]
public:
property IDictionary^ Data {
   IDictionary^ get();
}

See Also

BrandingSourceDibException Class | BrandingSourceDibException Members


GetBaseException Method

BrandingSourceDibException Class | BrandingSourceDibException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetBaseException Method

PegasusImaging.WinForms.NotateXpress9 Namespace > BrandingSourceDibException Class : GetBaseException Method (BrandingSourceDibException)

When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.

[Visual Basic]
Public Function GetBaseException() As Exception
[C#]
public Exception GetBaseException();
[C++]
public: Exception* GetBaseException();
[C++/CLI]
public:
Exception^ GetBaseException();

Return Type

The first exception thrown in a chain of exceptions. If the InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

See Also

BrandingSourceDibException Class | BrandingSourceDibException Members


GetObjectData Method

BrandingSourceDibException Class | BrandingSourceDibException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetObjectData Method

PegasusImaging.WinForms.NotateXpress9 Namespace > BrandingSourceDibException Class : GetObjectData Method (BrandingSourceDibException)

When overridden in a derived class, sets the SerializationInfo with information about the exception.

[Visual Basic]
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
[C++/CLI]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

BrandingSourceDibException Class | BrandingSourceDibException Members


GetType Method

BrandingSourceDibException Class | BrandingSourceDibException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetType Method

PegasusImaging.WinForms.NotateXpress9 Namespace > BrandingSourceDibException Class : GetType Method (BrandingSourceDibException)

Gets the runtime type of the current instance.

[Visual Basic]
Public Function GetType() As Type
[C#]
public Type GetType();
[C++]
public: Type* GetType();
[C++/CLI]
public:
Type^ GetType();

Return Type

A Type object that represents the exact runtime type of the current instance.

See Also

BrandingSourceDibException Class | BrandingSourceDibException Members


HelpLink Property

BrandingSourceDibException Class | BrandingSourceDibException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HelpLink Property

PegasusImaging.WinForms.NotateXpress9 Namespace > BrandingSourceDibException Class : HelpLink Property (BrandingSourceDibException)

Gets or sets a link to the help file associated with this exception.

[Visual Basic]
Public Property HelpLink As String
[C#]
public string HelpLink {get; set;}
[C++]
public: __property string* get_HelpLink();
public: __property void set_HelpLink(
   string* value
);
[C++/CLI]
public:
property String^ HelpLink {
   String^ get();
   void set (String^ value);
}

See Also

BrandingSourceDibException Class | BrandingSourceDibException Members


InnerException Property

BrandingSourceDibException Class | BrandingSourceDibException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InnerException Property

PegasusImaging.WinForms.NotateXpress9 Namespace > BrandingSourceDibException Class : InnerException Property (BrandingSourceDibException)

Gets the Exception instance that caused the current exception.

[Visual Basic]
Public ReadOnly Property InnerException As Exception
[C#]
public Exception InnerException {get;}
[C++]
public: __property Exception* get_InnerException();
[C++/CLI]
public:
property Exception^ InnerException {
   Exception^ get();
}

See Also

BrandingSourceDibException Class | BrandingSourceDibException Members


Message Property

BrandingSourceDibException Class | BrandingSourceDibException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Message Property

PegasusImaging.WinForms.NotateXpress9 Namespace > BrandingSourceDibException Class : Message Property (BrandingSourceDibException)

Gets a message that describes the current exception.

[Visual Basic]
Public ReadOnly Property Message As String
[C#]
public string Message {get;}
[C++]
public: __property string* get_Message();
[C++/CLI]
public:
property String^ Message {
   String^ get();
}

See Also

BrandingSourceDibException Class | BrandingSourceDibException Members


Source Property

BrandingSourceDibException Class | BrandingSourceDibException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Source Property

PegasusImaging.WinForms.NotateXpress9 Namespace > BrandingSourceDibException Class : Source Property (BrandingSourceDibException)

Gets or sets the name of the application or the object that causes the error.

[Visual Basic]
Public Property Source As String
[C#]
public string Source {get; set;}
[C++]
public: __property string* get_Source();
public: __property void set_Source(
   string* value
);
[C++/CLI]
public:
property String^ Source {
   String^ get();
   void set (String^ value);
}

See Also

BrandingSourceDibException Class | BrandingSourceDibException Members


StackTrace Property

BrandingSourceDibException Class | BrandingSourceDibException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StackTrace Property

PegasusImaging.WinForms.NotateXpress9 Namespace > BrandingSourceDibException Class : StackTrace Property (BrandingSourceDibException)

Gets a string representation of the frames on the call stack at the time the current exception was thrown.

[Visual Basic]
Public ReadOnly Property StackTrace As String
[C#]
public string StackTrace {get;}
[C++]
public: __property string* get_StackTrace();
[C++/CLI]
public:
property String^ StackTrace {
   String^ get();
}

See Also

BrandingSourceDibException Class | BrandingSourceDibException Members


TargetSite Property

BrandingSourceDibException Class | BrandingSourceDibException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TargetSite Property

PegasusImaging.WinForms.NotateXpress9 Namespace > BrandingSourceDibException Class : TargetSite Property (BrandingSourceDibException)

Gets the method that throws the current exception.

[Visual Basic]
Public ReadOnly Property TargetSite As MethodBase
[C#]
public MethodBase TargetSite {get;}
[C++]
public: __property MethodBase* get_TargetSite();
[C++/CLI]
public:
property MethodBase^ TargetSite {
   MethodBase^ get();
}

See Also

BrandingSourceDibException Class | BrandingSourceDibException Members


ToString Method

BrandingSourceDibException Class | BrandingSourceDibException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToString Method

PegasusImaging.WinForms.NotateXpress9 Namespace > BrandingSourceDibException Class : ToString Method (BrandingSourceDibException)

Creates and returns a string representation of the current exception.

[Visual Basic]
Public Function ToString() As String
[C#]
public string ToString();
[C++]
public: string* ToString();
[C++/CLI]
public:
String^ ToString();

Return Type

A string representation of the current exception.

See Also

BrandingSourceDibException Class | BrandingSourceDibException Members


ButtonTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ButtonTool Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : ButtonTool Class

For a list of all members of this type, see ButtonTool members.

Public Methods

Public Method Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public Method NudgeDown (Inherited from Element) | Moves the specified annotation object one level down, towards the back, in the painting order of the specified layer.
Public Method NudgeUp (Inherited from Element) | Moves the specified annotation object one level up, towards the front, in the painting order of the specified layer.
Public Method UserDataAdd (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataDelete (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFind (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFindFirst (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFindNext (Inherited from Element) | User data can be added to each element in a key value pair.

See Also

ButtonTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace


ClipboardException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ClipboardException Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : ClipboardException Class

For a list of all members of this type, see ClipboardException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

ClipboardException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


ClipboardException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ClipboardException Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : ClipboardException Class

For a list of all members of this type, see ClipboardException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

ClipboardException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Data Property

ClipboardException Class | ClipboardException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Data Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ClipboardException Class : Data Property (ClipboardException)

Gets a collection of key/value pairs that provide additional, user-defined information about the exception.

[Visual Basic]
Public ReadOnly Property Data As IDictionary
[C#]
public IDictionary Data {get;}
[C++]
public: __property IDictionary* get_Data();
[C++/CLI]
public:
property IDictionary^ Data {
   IDictionary^ get();
}

See Also

ClipboardException Class | ClipboardException Members


GetBaseException Method

ClipboardException Class | ClipboardException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetBaseException Method

PegasusImaging.WinForms.NotateXpress9 Namespace > ClipboardException Class : GetBaseException Method (ClipboardException)

When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.

[Visual Basic]
Public Function GetBaseException() As Exception
[C#]
public Exception GetBaseException();
[C++]
public: Exception* GetBaseException();
[C++/CLI]
public:
Exception^ GetBaseException();

Return Type

The first exception thrown in a chain of exceptions. If the InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

See Also

ClipboardException Class | ClipboardException Members


GetObjectData Method

ClipboardException Class | ClipboardException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetObjectData Method

PegasusImaging.WinForms.NotateXpress9 Namespace > ClipboardException Class : GetObjectData Method (ClipboardException)

When overridden in a derived class, sets the SerializationInfo with information about the exception.

[Visual Basic]
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
[C++/CLI]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

ClipboardException Class | ClipboardException Members


GetType Method

ClipboardException Class | ClipboardException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetType Method

PegasusImaging.WinForms.NotateXpress9 Namespace > ClipboardException Class : GetType Method (ClipboardException)

Gets the runtime type of the current instance.

[Visual Basic]
Public Function GetType() As Type
[C#]
public Type GetType();
[C++]
public: Type* GetType();
[C++/CLI]
public:
Type^ GetType();

Return Type

A Type object that represents the exact runtime type of the current instance.

See Also

ClipboardException Class | ClipboardException Members


HelpLink Property

ClipboardException Class | ClipboardException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HelpLink Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ClipboardException Class : HelpLink Property (ClipboardException)

Gets or sets a link to the help file associated with this exception.

[Visual Basic]
Public Property HelpLink As String
[C#]
public string HelpLink {get; set;}
[C++]
public: __property string* get_HelpLink();
public: __property void set_HelpLink(
   string* value
);
[C++/CLI]
public:
property String^ HelpLink {
   String^ get();
   void set (String^ value);
}

See Also

ClipboardException Class | ClipboardException Members


InnerException Property

ClipboardException Class | ClipboardException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InnerException Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ClipboardException Class : InnerException Property (ClipboardException)

Gets the Exception instance that caused the current exception.

[Visual Basic]
Public ReadOnly Property InnerException As Exception
[C#]
public Exception InnerException {get;}
[C++]
public: __property Exception* get_InnerException();
[C++/CLI]
public:
property Exception^ InnerException {
   Exception^ get();
}

See Also

ClipboardException Class | ClipboardException Members


Message Property

ClipboardException Class | ClipboardException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Message Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ClipboardException Class : Message Property (ClipboardException)

Gets a message that describes the current exception.

[Visual Basic]
Public ReadOnly Property Message As String
[C#]
public string Message {get;}
[C++]
public: __property string* get_Message();
[C++/CLI]
public:
property String^ Message {
   String^ get();
}

See Also

ClipboardException Class | ClipboardException Members


Source Property

ClipboardException Class | ClipboardException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Source Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ClipboardException Class : Source Property (ClipboardException)

Gets or sets the name of the application or the object that causes the error.

[Visual Basic]
Public Property Source As String
[C#]
public string Source {get; set;}
[C++]
public: __property string* get_Source();
public: __property void set_Source(
   string* value
);
[C++/CLI]
public:
property String^ Source {
   String^ get();
   void set (String^ value);
}

See Also

ClipboardException Class | ClipboardException Members


StackTrace Property

ClipboardException Class | ClipboardException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StackTrace Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ClipboardException Class : StackTrace Property (ClipboardException)

Gets a string representation of the frames on the call stack at the time the current exception was thrown.

[Visual Basic]
Public ReadOnly Property StackTrace As String
[C#]
public string StackTrace {get;}
[C++]
public: __property string* get_StackTrace();
[C++/CLI]
public:
property String^ StackTrace {
   String^ get();
}

See Also

ClipboardException Class | ClipboardException Members


TargetSite Property

ClipboardException Class | ClipboardException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TargetSite Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ClipboardException Class : TargetSite Property (ClipboardException)

Gets the method that throws the current exception.

[Visual Basic]
Public ReadOnly Property TargetSite As MethodBase
[C#]
public MethodBase TargetSite {get;}
[C++]
public: __property MethodBase* get_TargetSite();
[C++/CLI]
public:
property MethodBase^ TargetSite {
   MethodBase^ get();
}

See Also

ClipboardException Class | ClipboardException Members


ToString Method

ClipboardException Class | ClipboardException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToString Method

PegasusImaging.WinForms.NotateXpress9 Namespace > ClipboardException Class : ToString Method (ClipboardException)

Creates and returns a string representation of the current exception.

[Visual Basic]
Public Function ToString() As String
[C#]
public string ToString();
[C++]
public: string* ToString();
[C++/CLI]
public:
String^ ToString();

Return Type

A string representation of the current exception.

See Also

ClipboardException Class | ClipboardException Members


DuplicateItemException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

DuplicateItemException Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : DuplicateItemException Class

For a list of all members of this type, see DuplicateItemException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

DuplicateItemException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


DuplicateItemException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

DuplicateItemException Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : DuplicateItemException Class

For a list of all members of this type, see DuplicateItemException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

DuplicateItemException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Data Property

DuplicateItemException Class | DuplicateItemException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Data Property

PegasusImaging.WinForms.NotateXpress9 Namespace > DuplicateItemException Class : Data Property (DuplicateItemException)

Gets a collection of key/value pairs that provide additional, user-defined information about the exception.

[Visual Basic]
Public ReadOnly Property Data As IDictionary
[C#]
public IDictionary Data {get;}
[C++]
public: __property IDictionary* get_Data();
[C++/CLI]
public:
property IDictionary^ Data {
   IDictionary^ get();
}

See Also

DuplicateItemException Class | DuplicateItemException Members


GetBaseException Method

DuplicateItemException Class | DuplicateItemException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetBaseException Method

PegasusImaging.WinForms.NotateXpress9 Namespace > DuplicateItemException Class : GetBaseException Method (DuplicateItemException)

When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.

[Visual Basic]
Public Function GetBaseException() As Exception
[C#]
public Exception GetBaseException();
[C++]
public: Exception* GetBaseException();
[C++/CLI]
public:
Exception^ GetBaseException();

Return Type

The first exception thrown in a chain of exceptions. If the InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

See Also

DuplicateItemException Class | DuplicateItemException Members


GetObjectData Method

DuplicateItemException Class | DuplicateItemException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetObjectData Method

PegasusImaging.WinForms.NotateXpress9 Namespace > DuplicateItemException Class : GetObjectData Method (DuplicateItemException)

When overridden in a derived class, sets the SerializationInfo with information about the exception.

[Visual Basic]
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
[C++/CLI]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

DuplicateItemException Class | DuplicateItemException Members


GetType Method

DuplicateItemException Class | DuplicateItemException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetType Method

PegasusImaging.WinForms.NotateXpress9 Namespace > DuplicateItemException Class : GetType Method (DuplicateItemException)

Gets the runtime type of the current instance.

[Visual Basic]
Public Function GetType() As Type
[C#]
public Type GetType();
[C++]
public: Type* GetType();
[C++/CLI]
public:
Type^ GetType();

Return Type

A Type object that represents the exact runtime type of the current instance.

See Also

DuplicateItemException Class | DuplicateItemException Members


HelpLink Property

DuplicateItemException Class | DuplicateItemException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HelpLink Property

PegasusImaging.WinForms.NotateXpress9 Namespace > DuplicateItemException Class : HelpLink Property (DuplicateItemException)

Gets or sets a link to the help file associated with this exception.

[Visual Basic]
Public Property HelpLink As String
[C#]
public string HelpLink {get; set;}
[C++]
public: __property string* get_HelpLink();
public: __property void set_HelpLink(
   string* value
);
[C++/CLI]
public:
property String^ HelpLink {
   String^ get();
   void set (String^ value);
}

See Also

DuplicateItemException Class | DuplicateItemException Members


InnerException Property

DuplicateItemException Class | DuplicateItemException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InnerException Property

PegasusImaging.WinForms.NotateXpress9 Namespace > DuplicateItemException Class : InnerException Property (DuplicateItemException)

Gets the Exception instance that caused the current exception.

[Visual Basic]
Public ReadOnly Property InnerException As Exception
[C#]
public Exception InnerException {get;}
[C++]
public: __property Exception* get_InnerException();
[C++/CLI]
public:
property Exception^ InnerException {
   Exception^ get();
}

See Also

DuplicateItemException Class | DuplicateItemException Members


Message Property

DuplicateItemException Class | DuplicateItemException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Message Property

PegasusImaging.WinForms.NotateXpress9 Namespace > DuplicateItemException Class : Message Property (DuplicateItemException)

Gets a message that describes the current exception.

[Visual Basic]
Public ReadOnly Property Message As String
[C#]
public string Message {get;}
[C++]
public: __property string* get_Message();
[C++/CLI]
public:
property String^ Message {
   String^ get();
}

See Also

DuplicateItemException Class | DuplicateItemException Members


Source Property

DuplicateItemException Class | DuplicateItemException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Source Property

PegasusImaging.WinForms.NotateXpress9 Namespace > DuplicateItemException Class : Source Property (DuplicateItemException)

Gets or sets the name of the application or the object that causes the error.

[Visual Basic]
Public Property Source As String
[C#]
public string Source {get; set;}
[C++]
public: __property string* get_Source();
public: __property void set_Source(
   string* value
);
[C++/CLI]
public:
property String^ Source {
   String^ get();
   void set (String^ value);
}

See Also

DuplicateItemException Class | DuplicateItemException Members


StackTrace Property

DuplicateItemException Class | DuplicateItemException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StackTrace Property

PegasusImaging.WinForms.NotateXpress9 Namespace > DuplicateItemException Class : StackTrace Property (DuplicateItemException)

Gets a string representation of the frames on the call stack at the time the current exception was thrown.

[Visual Basic]
Public ReadOnly Property StackTrace As String
[C#]
public string StackTrace {get;}
[C++]
public: __property string* get_StackTrace();
[C++/CLI]
public:
property String^ StackTrace {
   String^ get();
}

See Also

DuplicateItemException Class | DuplicateItemException Members


TargetSite Property

DuplicateItemException Class | DuplicateItemException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TargetSite Property

PegasusImaging.WinForms.NotateXpress9 Namespace > DuplicateItemException Class : TargetSite Property (DuplicateItemException)

Gets the method that throws the current exception.

[Visual Basic]
Public ReadOnly Property TargetSite As MethodBase
[C#]
public MethodBase TargetSite {get;}
[C++]
public: __property MethodBase* get_TargetSite();
[C++/CLI]
public:
property MethodBase^ TargetSite {
   MethodBase^ get();
}

See Also

DuplicateItemException Class | DuplicateItemException Members


ToString Method

DuplicateItemException Class | DuplicateItemException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToString Method

PegasusImaging.WinForms.NotateXpress9 Namespace > DuplicateItemException Class : ToString Method (DuplicateItemException)

Creates and returns a string representation of the current exception.

[Visual Basic]
Public Function ToString() As String
[C#]
public string ToString();
[C++]
public: string* ToString();
[C++/CLI]
public:
String^ ToString();

Return Type

A string representation of the current exception.

See Also

DuplicateItemException Class | DuplicateItemException Members


DuplicateMenuIdException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

DuplicateMenuIdException Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : DuplicateMenuIdException Class

For a list of all members of this type, see DuplicateMenuIdException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

DuplicateMenuIdException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


DuplicateMenuIdException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

DuplicateMenuIdException Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : DuplicateMenuIdException Class

For a list of all members of this type, see DuplicateMenuIdException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

DuplicateMenuIdException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Data Property

DuplicateMenuIdException Class | DuplicateMenuIdException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Data Property

PegasusImaging.WinForms.NotateXpress9 Namespace > DuplicateMenuIdException Class : Data Property (DuplicateMenuIdException)

Gets a collection of key/value pairs that provide additional, user-defined information about the exception.

[Visual Basic]
Public ReadOnly Property Data As IDictionary
[C#]
public IDictionary Data {get;}
[C++]
public: __property IDictionary* get_Data();
[C++/CLI]
public:
property IDictionary^ Data {
   IDictionary^ get();
}

See Also

DuplicateMenuIdException Class | DuplicateMenuIdException Members


GetBaseException Method

DuplicateMenuIdException Class | DuplicateMenuIdException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetBaseException Method

PegasusImaging.WinForms.NotateXpress9 Namespace > DuplicateMenuIdException Class : GetBaseException Method (DuplicateMenuIdException)

When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.

[Visual Basic]
Public Function GetBaseException() As Exception
[C#]
public Exception GetBaseException();
[C++]
public: Exception* GetBaseException();
[C++/CLI]
public:
Exception^ GetBaseException();

Return Type

The first exception thrown in a chain of exceptions. If the InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

See Also

DuplicateMenuIdException Class | DuplicateMenuIdException Members


GetObjectData Method

DuplicateMenuIdException Class | DuplicateMenuIdException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetObjectData Method

PegasusImaging.WinForms.NotateXpress9 Namespace > DuplicateMenuIdException Class : GetObjectData Method (DuplicateMenuIdException)

When overridden in a derived class, sets the SerializationInfo with information about the exception.

[Visual Basic]
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
[C++/CLI]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

DuplicateMenuIdException Class | DuplicateMenuIdException Members


GetType Method

DuplicateMenuIdException Class | DuplicateMenuIdException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetType Method

PegasusImaging.WinForms.NotateXpress9 Namespace > DuplicateMenuIdException Class : GetType Method (DuplicateMenuIdException)

Gets the runtime type of the current instance.

[Visual Basic]
Public Function GetType() As Type
[C#]
public Type GetType();
[C++]
public: Type* GetType();
[C++/CLI]
public:
Type^ GetType();

Return Type

A Type object that represents the exact runtime type of the current instance.

See Also

DuplicateMenuIdException Class | DuplicateMenuIdException Members


HelpLink Property

DuplicateMenuIdException Class | DuplicateMenuIdException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HelpLink Property

PegasusImaging.WinForms.NotateXpress9 Namespace > DuplicateMenuIdException Class : HelpLink Property (DuplicateMenuIdException)

Gets or sets a link to the help file associated with this exception.

[Visual Basic]
Public Property HelpLink As String
[C#]
public string HelpLink {get; set;}
[C++]
public: __property string* get_HelpLink();
public: __property void set_HelpLink(
   string* value
);
[C++/CLI]
public:
property String^ HelpLink {
   String^ get();
   void set (String^ value);
}

See Also

DuplicateMenuIdException Class | DuplicateMenuIdException Members


InnerException Property

DuplicateMenuIdException Class | DuplicateMenuIdException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InnerException Property

PegasusImaging.WinForms.NotateXpress9 Namespace > DuplicateMenuIdException Class : InnerException Property (DuplicateMenuIdException)

Gets the Exception instance that caused the current exception.

[Visual Basic]
Public ReadOnly Property InnerException As Exception
[C#]
public Exception InnerException {get;}
[C++]
public: __property Exception* get_InnerException();
[C++/CLI]
public:
property Exception^ InnerException {
   Exception^ get();
}

See Also

DuplicateMenuIdException Class | DuplicateMenuIdException Members


Message Property

DuplicateMenuIdException Class | DuplicateMenuIdException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Message Property

PegasusImaging.WinForms.NotateXpress9 Namespace > DuplicateMenuIdException Class : Message Property (DuplicateMenuIdException)

Gets a message that describes the current exception.

[Visual Basic]
Public ReadOnly Property Message As String
[C#]
public string Message {get;}
[C++]
public: __property string* get_Message();
[C++/CLI]
public:
property String^ Message {
   String^ get();
}

See Also

DuplicateMenuIdException Class | DuplicateMenuIdException Members


Source Property

DuplicateMenuIdException Class | DuplicateMenuIdException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Source Property

PegasusImaging.WinForms.NotateXpress9 Namespace > DuplicateMenuIdException Class : Source Property (DuplicateMenuIdException)

Gets or sets the name of the application or the object that causes the error.

[Visual Basic]
Public Property Source As String
[C#]
public string Source {get; set;}
[C++]
public: __property string* get_Source();
public: __property void set_Source(
   string* value
);
[C++/CLI]
public:
property String^ Source {
   String^ get();
   void set (String^ value);
}

See Also

DuplicateMenuIdException Class | DuplicateMenuIdException Members


StackTrace Property

DuplicateMenuIdException Class | DuplicateMenuIdException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StackTrace Property

PegasusImaging.WinForms.NotateXpress9 Namespace > DuplicateMenuIdException Class : StackTrace Property (DuplicateMenuIdException)

Gets a string representation of the frames on the call stack at the time the current exception was thrown.

[Visual Basic]
Public ReadOnly Property StackTrace As String
[C#]
public string StackTrace {get;}
[C++]
public: __property string* get_StackTrace();
[C++/CLI]
public:
property String^ StackTrace {
   String^ get();
}

See Also

DuplicateMenuIdException Class | DuplicateMenuIdException Members


TargetSite Property

DuplicateMenuIdException Class | DuplicateMenuIdException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TargetSite Property

PegasusImaging.WinForms.NotateXpress9 Namespace > DuplicateMenuIdException Class : TargetSite Property (DuplicateMenuIdException)

Gets the method that throws the current exception.

[Visual Basic]
Public ReadOnly Property TargetSite As MethodBase
[C#]
public MethodBase TargetSite {get;}
[C++]
public: __property MethodBase* get_TargetSite();
[C++/CLI]
public:
property MethodBase^ TargetSite {
   MethodBase^ get();
}

See Also

DuplicateMenuIdException Class | DuplicateMenuIdException Members


ToString Method

DuplicateMenuIdException Class | DuplicateMenuIdException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToString Method

PegasusImaging.WinForms.NotateXpress9 Namespace > DuplicateMenuIdException Class : ToString Method (DuplicateMenuIdException)

Creates and returns a string representation of the current exception.

[Visual Basic]
Public Function ToString() As String
[C#]
public string ToString();
[C++]
public: string* ToString();
[C++/CLI]
public:
String^ ToString();

Return Type

A string representation of the current exception.

See Also

DuplicateMenuIdException Class | DuplicateMenuIdException Members


Element Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Element Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : Element Class (PegasusImaging.WinForms.NotateXpress9)

For a list of all members of this type, see Element members.

Public Methods

Public Method NudgeDown | Moves the specified annotation object one level down, towards the back, in the painting order of the specified layer.
Public Method NudgeUp | Moves the specified annotation object one level up, towards the front, in the painting order of the specified layer.
Public Method UserDataAdd | User data can be added to each element in a key value pair.
Public Method UserDataDelete | User data can be added to each element in a key value pair.
Public Method UserDataFind | User data can be added to each element in a key value pair.
Public Method UserDataFindFirst | User data can be added to each element in a key value pair.
Public Method UserDataFindNext | User data can be added to each element in a key value pair.

See Also

Element Class | PegasusImaging.WinForms.NotateXpress9 Namespace


ElementCollection Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ElementCollection Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : ElementCollection Class

For a list of all members of this type, see ElementCollection members.

Public Methods

Public Method Add | Adds the given element to the element collection.
Public Method BringToFront | Brings the selected elements to the front in the visual display order.
Public Method Clear | Clears the entire collection as well as calls the Clear function of the base class.
Public Method Contains | Determines if the collection contains the given Element.
Public Method Copy | Copies the currently selected elements to the clipboard.
Public Method CopyTo | Copies the entire collection to an array, starting at index of the target array.
Public Method Cut | Copies the currently selected elements to the clipboard and then deletes them from their original location.
Public Method DeleteSelected | Deletes all currently selected items from the collection.
Public Method Dispose | Releases all resources used by the ElementCollection object.
Public Method FirstSelected | Returns the first selected element in the collection.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) | Returns an enumerator that iterates through the CollectionBase instance.
Public Method IndexOf | Searches for the specified Element and returns the zero-based index of the first occurrence within the entire ElementCollection.
Public Method Insert | Inserts an Element at the specified index.
Public Method NextSelected | Returns the next selected element in the current layer.
Public Method Paste | Pastes the annotation elements from the clipboard into the current element collection.
Public Method Remove | Removes the given Element from the collection.
Public Method RemoveAt | Removes the element at the given index within the collection.
Public Method Reverse | Reverses the visual display order (z-order) of all the elements in the element collection.
Public Method SelectAll | Selects all the elements in the given collection.
Public Method SendToBack | Sends all selected elements in the collection to the back of the display order.

See Also

ElementCollection Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Capacity Property

ElementCollection Class | ElementCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Capacity Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ElementCollection Class : Capacity Property (ElementCollection)

Gets or sets the number of elements that the CollectionBase can contain.

[Visual Basic]
<ComVisibleAttribute(False)>
Public Property Capacity As Integer
[C#]
[ComVisibleAttribute(false)]
public int Capacity {get; set;}
[C++]
[ComVisibleAttribute(false)]
public: __property int get_Capacity();
public: __property void set_Capacity(
   int value
);
[C++/CLI]
[ComVisibleAttribute(false)]
public:
property int Capacity {
   int get();
   void set (int value);
}

Exceptions

Exception | Description
ArgumentOutOfRangeException | Capacity is set to a value that is less than Count.

See Also

ElementCollection Class | ElementCollection Members


Count Property

ElementCollection Class | ElementCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Count Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ElementCollection Class : Count Property (ElementCollection)

Gets the number of elements contained in the CollectionBase instance.

[Visual Basic]
Public ReadOnly Property Count As Integer
[C#]
public int Count {get;}
[C++]
public: __property int get_Count();
[C++/CLI]
public:
property int Count {
   int get();
}

See Also

ElementCollection Class | ElementCollection Members


GetEnumerator Method

ElementCollection Class | ElementCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetEnumerator Method

PegasusImaging.WinForms.NotateXpress9 Namespace > ElementCollection Class : GetEnumerator Method (ElementCollection)

Returns an enumerator that iterates through the CollectionBase instance.

[Visual Basic]
Public Function GetEnumerator() As IEnumerator
[C#]
public IEnumerator GetEnumerator();
[C++]
public: IEnumerator* GetEnumerator();
[C++/CLI]
public:
IEnumerator^ GetEnumerator();

Return Type

An IEnumerator for the CollectionBase instance.

See Also

ElementCollection Class | ElementCollection Members


EllipseTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

EllipseTool Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : EllipseTool Class

For a list of all members of this type, see EllipseTool members.

Public Methods

Public Method NudgeDown (Inherited from Element) | Moves the specified annotation object one level down, towards the back, in the painting order of the specified layer.
Public Method NudgeUp (Inherited from Element) | Moves the specified annotation object one level up, towards the front, in the painting order of the specified layer.
Public Method UserDataAdd (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataDelete (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFind (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFindFirst (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFindNext (Inherited from Element) | User data can be added to each element in a key value pair.

See Also

EllipseTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace


FileOpenException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

FileOpenException Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : FileOpenException Class

For a list of all members of this type, see FileOpenException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

FileOpenException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


FileOpenException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

FileOpenException Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : FileOpenException Class

For a list of all members of this type, see FileOpenException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

FileOpenException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Data Property

FileOpenException Class | FileOpenException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Data Property

PegasusImaging.WinForms.NotateXpress9 Namespace > FileOpenException Class : Data Property (FileOpenException)

Gets a collection of key/value pairs that provide additional, user-defined information about the exception.

[Visual Basic]
Public ReadOnly Property Data As IDictionary
[C#]
public IDictionary Data {get;}
[C++]
public: __property IDictionary* get_Data();
[C++/CLI]
public:
property IDictionary^ Data {
   IDictionary^ get();
}

See Also

FileOpenException Class | FileOpenException Members


GetBaseException Method

FileOpenException Class | FileOpenException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetBaseException Method

PegasusImaging.WinForms.NotateXpress9 Namespace > FileOpenException Class : GetBaseException Method (FileOpenException)

When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.

[Visual Basic]
Public Function GetBaseException() As Exception
[C#]
public Exception GetBaseException();
[C++]
public: Exception* GetBaseException();
[C++/CLI]
public:
Exception^ GetBaseException();

Return Type

The first exception thrown in a chain of exceptions. If the InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

See Also

FileOpenException Class | FileOpenException Members


GetObjectData Method

FileOpenException Class | FileOpenException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetObjectData Method

PegasusImaging.WinForms.NotateXpress9 Namespace > FileOpenException Class : GetObjectData Method (FileOpenException)

When overridden in a derived class, sets the SerializationInfo with information about the exception.

[Visual Basic]
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
[C++/CLI]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

FileOpenException Class | FileOpenException Members


GetType Method

FileOpenException Class | FileOpenException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetType Method

PegasusImaging.WinForms.NotateXpress9 Namespace > FileOpenException Class : GetType Method (FileOpenException)

Gets the runtime type of the current instance.

[Visual Basic]
Public Function GetType() As Type
[C#]
public Type GetType();
[C++]
public: Type* GetType();
[C++/CLI]
public:
Type^ GetType();

Return Type

A Type object that represents the exact runtime type of the current instance.

See Also

FileOpenException Class | FileOpenException Members


HelpLink Property

FileOpenException Class | FileOpenException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HelpLink Property

PegasusImaging.WinForms.NotateXpress9 Namespace > FileOpenException Class : HelpLink Property (FileOpenException)

Gets or sets a link to the help file associated with this exception.

[Visual Basic]
Public Property HelpLink As String
[C#]
public string HelpLink {get; set;}
[C++]
public: __property string* get_HelpLink();
public: __property void set_HelpLink(
   string* value
);
[C++/CLI]
public:
property String^ HelpLink {
   String^ get();
   void set (String^ value);
}

See Also

FileOpenException Class | FileOpenException Members


InnerException Property

FileOpenException Class | FileOpenException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InnerException Property

PegasusImaging.WinForms.NotateXpress9 Namespace > FileOpenException Class : InnerException Property (FileOpenException)

Gets the Exception instance that caused the current exception.

[Visual Basic]
Public ReadOnly Property InnerException As Exception
[C#]
public Exception InnerException {get;}
[C++]
public: __property Exception* get_InnerException();
[C++/CLI]
public:
property Exception^ InnerException {
   Exception^ get();
}

See Also

FileOpenException Class | FileOpenException Members


Message Property

FileOpenException Class | FileOpenException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Message Property

PegasusImaging.WinForms.NotateXpress9 Namespace > FileOpenException Class : Message Property (FileOpenException)

Gets a message that describes the current exception.

[Visual Basic]
Public ReadOnly Property Message As String
[C#]
public string Message {get;}
[C++]
public: __property string* get_Message();
[C++/CLI]
public:
property String^ Message {
   String^ get();
}

See Also

FileOpenException Class | FileOpenException Members


Source Property

FileOpenException Class | FileOpenException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Source Property

PegasusImaging.WinForms.NotateXpress9 Namespace > FileOpenException Class : Source Property (FileOpenException)

Gets or sets the name of the application or the object that causes the error.

[Visual Basic]
Public Property Source As String
[C#]
public string Source {get; set;}
[C++]
public: __property string* get_Source();
public: __property void set_Source(
   string* value
);
[C++/CLI]
public:
property String^ Source {
   String^ get();
   void set (String^ value);
}

See Also

FileOpenException Class | FileOpenException Members


StackTrace Property

FileOpenException Class | FileOpenException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StackTrace Property

PegasusImaging.WinForms.NotateXpress9 Namespace > FileOpenException Class : StackTrace Property (FileOpenException)

Gets a string representation of the frames on the call stack at the time the current exception was thrown.

[Visual Basic]
Public ReadOnly Property StackTrace As String
[C#]
public string StackTrace {get;}
[C++]
public: __property string* get_StackTrace();
[C++/CLI]
public:
property String^ StackTrace {
   String^ get();
}

See Also

FileOpenException Class | FileOpenException Members


TargetSite Property

FileOpenException Class | FileOpenException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TargetSite Property

PegasusImaging.WinForms.NotateXpress9 Namespace > FileOpenException Class : TargetSite Property (FileOpenException)

Gets the method that throws the current exception.

[Visual Basic]
Public ReadOnly Property TargetSite As MethodBase
[C#]
public MethodBase TargetSite {get;}
[C++]
public: __property MethodBase* get_TargetSite();
[C++/CLI]
public:
property MethodBase^ TargetSite {
   MethodBase^ get();
}

See Also

FileOpenException Class | FileOpenException Members


ToString Method

FileOpenException Class | FileOpenException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToString Method

PegasusImaging.WinForms.NotateXpress9 Namespace > FileOpenException Class : ToString Method (FileOpenException)

Creates and returns a string representation of the current exception.

[Visual Basic]
Public Function ToString() As String
[C#]
public string ToString();
[C++]
public: string* ToString();
[C++/CLI]
public:
String^ ToString();

Return Type

A string representation of the current exception.

See Also

FileOpenException Class | FileOpenException Members


FileSecurityException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

FileSecurityException Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : FileSecurityException Class

For a list of all members of this type, see FileSecurityException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

FileSecurityException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


FileSecurityException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

FileSecurityException Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : FileSecurityException Class

For a list of all members of this type, see FileSecurityException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

FileSecurityException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Data Property

FileSecurityException Class | FileSecurityException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Data Property

PegasusImaging.WinForms.NotateXpress9 Namespace > FileSecurityException Class : Data Property (FileSecurityException)

Gets a collection of key/value pairs that provide additional, user-defined information about the exception.

[Visual Basic]
Public ReadOnly Property Data As IDictionary
[C#]
public IDictionary Data {get;}
[C++]
public: __property IDictionary* get_Data();
[C++/CLI]
public:
property IDictionary^ Data {
   IDictionary^ get();
}

See Also

FileSecurityException Class | FileSecurityException Members


GetBaseException Method

FileSecurityException Class | FileSecurityException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetBaseException Method

PegasusImaging.WinForms.NotateXpress9 Namespace > FileSecurityException Class : GetBaseException Method (FileSecurityException)

When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.

[Visual Basic]
Public Function GetBaseException() As Exception
[C#]
public Exception GetBaseException();
[C++]
public: Exception* GetBaseException();
[C++/CLI]
public:
Exception^ GetBaseException();

Return Type

The first exception thrown in a chain of exceptions. If the InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

See Also

FileSecurityException Class | FileSecurityException Members


GetObjectData Method

FileSecurityException Class | FileSecurityException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetObjectData Method

PegasusImaging.WinForms.NotateXpress9 Namespace > FileSecurityException Class : GetObjectData Method (FileSecurityException)

When overridden in a derived class, sets the SerializationInfo with information about the exception.

[Visual Basic]
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
[C++/CLI]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

FileSecurityException Class | FileSecurityException Members


GetType Method

FileSecurityException Class | FileSecurityException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetType Method

PegasusImaging.WinForms.NotateXpress9 Namespace > FileSecurityException Class : GetType Method (FileSecurityException)

Gets the runtime type of the current instance.

[Visual Basic]
Public Function GetType() As Type
[C#]
public Type GetType();
[C++]
public: Type* GetType();
[C++/CLI]
public:
Type^ GetType();

Return Type

A Type object that represents the exact runtime type of the current instance.

See Also

FileSecurityException Class | FileSecurityException Members


HelpLink Property

FileSecurityException Class | FileSecurityException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HelpLink Property

PegasusImaging.WinForms.NotateXpress9 Namespace > FileSecurityException Class : HelpLink Property (FileSecurityException)

Gets or sets a link to the help file associated with this exception.

[Visual Basic]
Public Property HelpLink As String
[C#]
public string HelpLink {get; set;}
[C++]
public: __property string* get_HelpLink();
public: __property void set_HelpLink(
   string* value
);
[C++/CLI]
public:
property String^ HelpLink {
   String^ get();
   void set (String^ value);
}

See Also

FileSecurityException Class | FileSecurityException Members


InnerException Property

FileSecurityException Class | FileSecurityException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InnerException Property

PegasusImaging.WinForms.NotateXpress9 Namespace > FileSecurityException Class : InnerException Property (FileSecurityException)

Gets the Exception instance that caused the current exception.

[Visual Basic]
Public ReadOnly Property InnerException As Exception
[C#]
public Exception InnerException {get;}
[C++]
public: __property Exception* get_InnerException();
[C++/CLI]
public:
property Exception^ InnerException {
   Exception^ get();
}

See Also

FileSecurityException Class | FileSecurityException Members


Message Property

FileSecurityException Class | FileSecurityException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Message Property

PegasusImaging.WinForms.NotateXpress9 Namespace > FileSecurityException Class : Message Property (FileSecurityException)

Gets a message that describes the current exception.

[Visual Basic]
Public ReadOnly Property Message As String
[C#]
public string Message {get;}
[C++]
public: __property string* get_Message();
[C++/CLI]
public:
property String^ Message {
   String^ get();
}

See Also

FileSecurityException Class | FileSecurityException Members


Source Property

FileSecurityException Class | FileSecurityException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Source Property

PegasusImaging.WinForms.NotateXpress9 Namespace > FileSecurityException Class : Source Property (FileSecurityException)

Gets or sets the name of the application or the object that causes the error.

[Visual Basic]
Public Property Source As String
[C#]
public string Source {get; set;}
[C++]
public: __property string* get_Source();
public: __property void set_Source(
   string* value
);
[C++/CLI]
public:
property String^ Source {
   String^ get();
   void set (String^ value);
}

See Also

FileSecurityException Class | FileSecurityException Members


StackTrace Property

FileSecurityException Class | FileSecurityException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StackTrace Property

PegasusImaging.WinForms.NotateXpress9 Namespace > FileSecurityException Class : StackTrace Property (FileSecurityException)

Gets a string representation of the frames on the call stack at the time the current exception was thrown.

[Visual Basic]
Public ReadOnly Property StackTrace As String
[C#]
public string StackTrace {get;}
[C++]
public: __property string* get_StackTrace();
[C++/CLI]
public:
property String^ StackTrace {
   String^ get();
}

See Also

FileSecurityException Class | FileSecurityException Members


TargetSite Property

FileSecurityException Class | FileSecurityException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TargetSite Property

PegasusImaging.WinForms.NotateXpress9 Namespace > FileSecurityException Class : TargetSite Property (FileSecurityException)

Gets the method that throws the current exception.

[Visual Basic]
Public ReadOnly Property TargetSite As MethodBase
[C#]
public MethodBase TargetSite {get;}
[C++]
public: __property MethodBase* get_TargetSite();
[C++/CLI]
public:
property MethodBase^ TargetSite {
   MethodBase^ get();
}

See Also

FileSecurityException Class | FileSecurityException Members


ToString Method

FileSecurityException Class | FileSecurityException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToString Method

PegasusImaging.WinForms.NotateXpress9 Namespace > FileSecurityException Class : ToString Method (FileSecurityException)

Creates and returns a string representation of the current exception.

[Visual Basic]
Public Function ToString() As String
[C#]
public string ToString();
[C++]
public: string* ToString();
[C++/CLI]
public:
String^ ToString();

Return Type

A string representation of the current exception.

See Also

FileSecurityException Class | FileSecurityException Members


FileWriteException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

FileWriteException Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : FileWriteException Class

For a list of all members of this type, see FileWriteException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

FileWriteException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


FileWriteException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

FileWriteException Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : FileWriteException Class

For a list of all members of this type, see FileWriteException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

FileWriteException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Data Property

FileWriteException Class | FileWriteException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Data Property

PegasusImaging.WinForms.NotateXpress9 Namespace > FileWriteException Class : Data Property (FileWriteException)

Gets a collection of key/value pairs that provide additional, user-defined information about the exception.

[Visual Basic]
Public ReadOnly Property Data As IDictionary
[C#]
public IDictionary Data {get;}
[C++]
public: __property IDictionary* get_Data();
[C++/CLI]
public:
property IDictionary^ Data {
   IDictionary^ get();
}

See Also

FileWriteException Class | FileWriteException Members


GetBaseException Method

FileWriteException Class | FileWriteException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetBaseException Method

PegasusImaging.WinForms.NotateXpress9 Namespace > FileWriteException Class : GetBaseException Method (FileWriteException)

When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.

[Visual Basic]
Public Function GetBaseException() As Exception
[C#]
public Exception GetBaseException();
[C++]
public: Exception* GetBaseException();
[C++/CLI]
public:
Exception^ GetBaseException();

Return Type

The first exception thrown in a chain of exceptions. If the InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

See Also

FileWriteException Class | FileWriteException Members


GetObjectData Method

FileWriteException Class | FileWriteException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetObjectData Method

PegasusImaging.WinForms.NotateXpress9 Namespace > FileWriteException Class : GetObjectData Method (FileWriteException)

When overridden in a derived class, sets the SerializationInfo with information about the exception.

[Visual Basic]
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
[C++/CLI]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

FileWriteException Class | FileWriteException Members


GetType Method

FileWriteException Class | FileWriteException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetType Method

PegasusImaging.WinForms.NotateXpress9 Namespace > FileWriteException Class : GetType Method (FileWriteException)

Gets the runtime type of the current instance.

[Visual Basic]
Public Function GetType() As Type
[C#]
public Type GetType();
[C++]
public: Type* GetType();
[C++/CLI]
public:
Type^ GetType();

Return Type

A Type object that represents the exact runtime type of the current instance.

See Also

FileWriteException Class | FileWriteException Members


HelpLink Property

FileWriteException Class | FileWriteException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HelpLink Property

PegasusImaging.WinForms.NotateXpress9 Namespace > FileWriteException Class : HelpLink Property (FileWriteException)

Gets or sets a link to the help file associated with this exception.

[Visual Basic]
Public Property HelpLink As String
[C#]
public string HelpLink {get; set;}
[C++]
public: __property string* get_HelpLink();
public: __property void set_HelpLink(
   string* value
);
[C++/CLI]
public:
property String^ HelpLink {
   String^ get();
   void set (String^ value);
}

See Also

FileWriteException Class | FileWriteException Members


InnerException Property

FileWriteException Class | FileWriteException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InnerException Property

PegasusImaging.WinForms.NotateXpress9 Namespace > FileWriteException Class : InnerException Property (FileWriteException)

Gets the Exception instance that caused the current exception.

[Visual Basic]
Public ReadOnly Property InnerException As Exception
[C#]
public Exception InnerException {get;}
[C++]
public: __property Exception* get_InnerException();
[C++/CLI]
public:
property Exception^ InnerException {
   Exception^ get();
}

See Also

FileWriteException Class | FileWriteException Members


Message Property

FileWriteException Class | FileWriteException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Message Property

PegasusImaging.WinForms.NotateXpress9 Namespace > FileWriteException Class : Message Property (FileWriteException)

Gets a message that describes the current exception.

[Visual Basic]
Public ReadOnly Property Message As String
[C#]
public string Message {get;}
[C++]
public: __property string* get_Message();
[C++/CLI]
public:
property String^ Message {
   String^ get();
}

See Also

FileWriteException Class | FileWriteException Members


Source Property

FileWriteException Class | FileWriteException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Source Property

PegasusImaging.WinForms.NotateXpress9 Namespace > FileWriteException Class : Source Property (FileWriteException)

Gets or sets the name of the application or the object that causes the error.

[Visual Basic]
Public Property Source As String
[C#]
public string Source {get; set;}
[C++]
public: __property string* get_Source();
public: __property void set_Source(
   string* value
);
[C++/CLI]
public:
property String^ Source {
   String^ get();
   void set (String^ value);
}

See Also

FileWriteException Class | FileWriteException Members


StackTrace Property

FileWriteException Class | FileWriteException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StackTrace Property

PegasusImaging.WinForms.NotateXpress9 Namespace > FileWriteException Class : StackTrace Property (FileWriteException)

Gets a string representation of the frames on the call stack at the time the current exception was thrown.

[Visual Basic]
Public ReadOnly Property StackTrace As String
[C#]
public string StackTrace {get;}
[C++]
public: __property string* get_StackTrace();
[C++/CLI]
public:
property String^ StackTrace {
   String^ get();
}

See Also

FileWriteException Class | FileWriteException Members


TargetSite Property

FileWriteException Class | FileWriteException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TargetSite Property

PegasusImaging.WinForms.NotateXpress9 Namespace > FileWriteException Class : TargetSite Property (FileWriteException)

Gets the method that throws the current exception.

[Visual Basic]
Public ReadOnly Property TargetSite As MethodBase
[C#]
public MethodBase TargetSite {get;}
[C++]
public: __property MethodBase* get_TargetSite();
[C++/CLI]
public:
property MethodBase^ TargetSite {
   MethodBase^ get();
}

See Also

FileWriteException Class | FileWriteException Members


ToString Method

FileWriteException Class | FileWriteException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToString Method

PegasusImaging.WinForms.NotateXpress9 Namespace > FileWriteException Class : ToString Method (FileWriteException)

Creates and returns a string representation of the current exception.

[Visual Basic]
Public Function ToString() As String
[C#]
public string ToString();
[C++]
public: string* ToString();
[C++/CLI]
public:
String^ ToString();

Return Type

A string representation of the current exception.

See Also

FileWriteException Class | FileWriteException Members


FreeHandTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

FreeHandTool Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : FreeHandTool Class

For a list of all members of this type, see FreeHandTool members.

Public Methods

Public Method GetPoints | Gets an array of points that is used to draw the line for the freehand.
Public Method NudgeDown (Inherited from Element) | Moves the specified annotation object one level down, towards the back, in the painting order of the specified layer.
Public Method NudgeUp (Inherited from Element) | Moves the specified annotation object one level up, towards the front, in the painting order of the specified layer.
Public Method SetPoints | Sets an array of given points used to draw the line.
Public Method UserDataAdd (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataDelete (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFind (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFindFirst (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFindNext (Inherited from Element) | User data can be added to each element in a key value pair.

See Also

FreeHandTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Group Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Group Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : Group Class (PegasusImaging.WinForms.NotateXpress9)

For a list of all members of this type, see Group members.

Public Methods

Public Method Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public Method UserDataAdd | User data can be added to each group in a key value pair. This will add in a new key value pair.
Public Method UserDataDelete | User data can be added to each element in a key value pair.
Public Method UserDataFind | User data can be added to each group in a key value pair.
Public Method UserDataFindFirst | User data can be added to each group in a key value pair.
Public Method UserDataFindNext | User data can be added to each group in a key value pair.

See Also

Group Class | PegasusImaging.WinForms.NotateXpress9 Namespace


GroupCollection Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GroupCollection Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : GroupCollection Class

For a list of all members of this type, see GroupCollection members.

Public Methods

Public Method Add | Adds the given group to the current GroupCollection.
Public Method Clear | Clears the entire collection as well as calls the Clear function of the base class.
Public Method Contains | Determines if the group collection contains the given Group.
Public Method CopyTo | Copies the entire group collection to the given array, starting at given index of the target array.
Public Method Dispose | Releases all resources used by this GroupCollection object.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) | Returns an enumerator that iterates through the CollectionBase instance.
Public Method IndexOf | Searches for a group based on the given value and returns the index position of the first occurrence within the entire GroupCollection.
Public Method Insert | Inserts a Group at the given index location within the group collection.
Public Method Remove | Removes the given Group from the group collection.
Public Method RemoveAt | Removes a group within the group collection located at the given index.

See Also

GroupCollection Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Capacity Property

GroupCollection Class | GroupCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Capacity Property

PegasusImaging.WinForms.NotateXpress9 Namespace > GroupCollection Class : Capacity Property (GroupCollection)

Gets or sets the number of elements that the CollectionBase can contain.

[Visual Basic]
<ComVisibleAttribute(False)>
Public Property Capacity As Integer
[C#]
[ComVisibleAttribute(false)]
public int Capacity {get; set;}
[C++]
[ComVisibleAttribute(false)]
public: __property int get_Capacity();
public: __property void set_Capacity(
   int value
);
[C++/CLI]
[ComVisibleAttribute(false)]
public:
property int Capacity {
   int get();
   void set (int value);
}

Exceptions

Exception | Description
ArgumentOutOfRangeException | Capacity is set to a value that is less than Count.

See Also

GroupCollection Class | GroupCollection Members


Count Property

GroupCollection Class | GroupCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Count Property

PegasusImaging.WinForms.NotateXpress9 Namespace > GroupCollection Class : Count Property (GroupCollection)

Gets the number of elements contained in the CollectionBase instance.

[Visual Basic]
Public ReadOnly Property Count As Integer
[C#]
public int Count {get;}
[C++]
public: __property int get_Count();
[C++/CLI]
public:
property int Count {
   int get();
}

See Also

GroupCollection Class | GroupCollection Members


GetEnumerator Method

GroupCollection Class | GroupCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetEnumerator Method

PegasusImaging.WinForms.NotateXpress9 Namespace > GroupCollection Class : GetEnumerator Method (GroupCollection)

Returns an enumerator that iterates through the CollectionBase instance.

[Visual Basic]
Public Function GetEnumerator() As IEnumerator
[C#]
public IEnumerator GetEnumerator();
[C++]
public: IEnumerator* GetEnumerator();
[C++/CLI]
public:
IEnumerator^ GetEnumerator();

Return Type

An IEnumerator for the CollectionBase instance.

See Also

GroupCollection Class | GroupCollection Members


GroupCreationException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GroupCreationException Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : GroupCreationException Class

For a list of all members of this type, see GroupCreationException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

GroupCreationException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


GroupCreationException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GroupCreationException Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : GroupCreationException Class

For a list of all members of this type, see GroupCreationException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

GroupCreationException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Data Property

GroupCreationException Class | GroupCreationException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Data Property

PegasusImaging.WinForms.NotateXpress9 Namespace > GroupCreationException Class : Data Property (GroupCreationException)

Gets a collection of key/value pairs that provide additional, user-defined information about the exception.

[Visual Basic]
Public ReadOnly Property Data As IDictionary
[C#]
public IDictionary Data {get;}
[C++]
public: __property IDictionary* get_Data();
[C++/CLI]
public:
property IDictionary^ Data {
   IDictionary^ get();
}

See Also

GroupCreationException Class | GroupCreationException Members


GetBaseException Method

GroupCreationException Class | GroupCreationException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetBaseException Method

PegasusImaging.WinForms.NotateXpress9 Namespace > GroupCreationException Class : GetBaseException Method (GroupCreationException)

When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.

[Visual Basic]
Public Function GetBaseException() As Exception
[C#]
public Exception GetBaseException();
[C++]
public: Exception* GetBaseException();
[C++/CLI]
public:
Exception^ GetBaseException();

Return Type

The first exception thrown in a chain of exceptions. If the InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

See Also

GroupCreationException Class | GroupCreationException Members


GetObjectData Method

GroupCreationException Class | GroupCreationException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetObjectData Method

PegasusImaging.WinForms.NotateXpress9 Namespace > GroupCreationException Class : GetObjectData Method (GroupCreationException)

When overridden in a derived class, sets the SerializationInfo with information about the exception.

[Visual Basic]
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
[C++/CLI]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

GroupCreationException Class | GroupCreationException Members


GetType Method

GroupCreationException Class | GroupCreationException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetType Method

PegasusImaging.WinForms.NotateXpress9 Namespace > GroupCreationException Class : GetType Method (GroupCreationException)

Gets the runtime type of the current instance.

[Visual Basic]
Public Function GetType() As Type
[C#]
public Type GetType();
[C++]
public: Type* GetType();
[C++/CLI]
public:
Type^ GetType();

Return Type

A Type object that represents the exact runtime type of the current instance.

See Also

GroupCreationException Class | GroupCreationException Members


HelpLink Property

GroupCreationException Class | GroupCreationException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HelpLink Property

PegasusImaging.WinForms.NotateXpress9 Namespace > GroupCreationException Class : HelpLink Property (GroupCreationException)

Gets or sets a link to the help file associated with this exception.

[Visual Basic]
Public Property HelpLink As String
[C#]
public string HelpLink {get; set;}
[C++]
public: __property string* get_HelpLink();
public: __property void set_HelpLink(
   string* value
);
[C++/CLI]
public:
property String^ HelpLink {
   String^ get();
   void set (String^ value);
}

See Also

GroupCreationException Class | GroupCreationException Members


InnerException Property

GroupCreationException Class | GroupCreationException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InnerException Property

PegasusImaging.WinForms.NotateXpress9 Namespace > GroupCreationException Class : InnerException Property (GroupCreationException)

Gets the Exception instance that caused the current exception.

[Visual Basic]
Public ReadOnly Property InnerException As Exception
[C#]
public Exception InnerException {get;}
[C++]
public: __property Exception* get_InnerException();
[C++/CLI]
public:
property Exception^ InnerException {
   Exception^ get();
}

See Also

GroupCreationException Class | GroupCreationException Members


Message Property

GroupCreationException Class | GroupCreationException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Message Property

PegasusImaging.WinForms.NotateXpress9 Namespace > GroupCreationException Class : Message Property (GroupCreationException)

Gets a message that describes the current exception.

[Visual Basic]
Public ReadOnly Property Message As String
[C#]
public string Message {get;}
[C++]
public: __property string* get_Message();
[C++/CLI]
public:
property String^ Message {
   String^ get();
}

See Also

GroupCreationException Class | GroupCreationException Members


Source Property

GroupCreationException Class | GroupCreationException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Source Property

PegasusImaging.WinForms.NotateXpress9 Namespace > GroupCreationException Class : Source Property (GroupCreationException)

Gets or sets the name of the application or the object that causes the error.

[Visual Basic]
Public Property Source As String
[C#]
public string Source {get; set;}
[C++]
public: __property string* get_Source();
public: __property void set_Source(
   string* value
);
[C++/CLI]
public:
property String^ Source {
   String^ get();
   void set (String^ value);
}

See Also

GroupCreationException Class | GroupCreationException Members


StackTrace Property

GroupCreationException Class | GroupCreationException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StackTrace Property

PegasusImaging.WinForms.NotateXpress9 Namespace > GroupCreationException Class : StackTrace Property (GroupCreationException)

Gets a string representation of the frames on the call stack at the time the current exception was thrown.

[Visual Basic]
Public ReadOnly Property StackTrace As String
[C#]
public string StackTrace {get;}
[C++]
public: __property string* get_StackTrace();
[C++/CLI]
public:
property String^ StackTrace {
   String^ get();
}

See Also

GroupCreationException Class | GroupCreationException Members


TargetSite Property

GroupCreationException Class | GroupCreationException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TargetSite Property

PegasusImaging.WinForms.NotateXpress9 Namespace > GroupCreationException Class : TargetSite Property (GroupCreationException)

Gets the method that throws the current exception.

[Visual Basic]
Public ReadOnly Property TargetSite As MethodBase
[C#]
public MethodBase TargetSite {get;}
[C++]
public: __property MethodBase* get_TargetSite();
[C++/CLI]
public:
property MethodBase^ TargetSite {
   MethodBase^ get();
}

See Also

GroupCreationException Class | GroupCreationException Members


ToString Method

GroupCreationException Class | GroupCreationException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToString Method

PegasusImaging.WinForms.NotateXpress9 Namespace > GroupCreationException Class : ToString Method (GroupCreationException)

Creates and returns a string representation of the current exception.

[Visual Basic]
Public Function ToString() As String
[C#]
public string ToString();
[C++]
public: string* ToString();
[C++/CLI]
public:
String^ ToString();

Return Type

A string representation of the current exception.

See Also

GroupCreationException Class | GroupCreationException Members


GroupElementCollection Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GroupElementCollection Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : GroupElementCollection Class

For a list of all members of this type, see GroupElementCollection members.

Public Methods

Public Method Add | Adds the given element to the group element collection.
Public Method Clear | Clears the entire collection as well as calls the Clear function of the base class.
Public Method Contains | Determines if the collection contains this Element.
Public Method CopyTo | Copies the entire collection to an array, starting at index of the target array.
Public Method Dispose | Releases all resources used by this PegasusImaging.WinForms.NotateXpress9.ElementCollection object.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) | Returns an enumerator that iterates through the CollectionBase instance.
Public Method GroupInvert | Inverts the arrangement of all annotation items in a yoked annotation group.
Public Method GroupMirror | Mirrors the arrangement of all annotation items in a yoked annotation group.
Public Method IndexOf | Searches for the specified Object and returns the zero-based index of the first occurrence within the entire PageCollection.
Public Method Insert | Inserts a Element at the specified index.
Public Method Remove | Removes the Element from the collection.
Public Method RemoveAt | Remove operation for the document collection. Call the document destructor to free the document then remove the document from the collection.

See Also

GroupElementCollection Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Capacity Property

GroupElementCollection Class | GroupElementCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Capacity Property

PegasusImaging.WinForms.NotateXpress9 Namespace > GroupElementCollection Class : Capacity Property (GroupElementCollection)

Gets or sets the number of elements that the CollectionBase can contain.

[Visual Basic]
<ComVisibleAttribute(False)>
Public Property Capacity As Integer
[C#]
[ComVisibleAttribute(false)]
public int Capacity {get; set;}
[C++]
[ComVisibleAttribute(false)]
public: __property int get_Capacity();
public: __property void set_Capacity(
   int value
);
[C++/CLI]
[ComVisibleAttribute(false)]
public:
property int Capacity {
   int get();
   void set (int value);
}

Exceptions

Exception | Description
ArgumentOutOfRangeException | Capacity is set to a value that is less than Count.

See Also

GroupElementCollection Class | GroupElementCollection Members


Count Property

GroupElementCollection Class | GroupElementCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Count Property

PegasusImaging.WinForms.NotateXpress9 Namespace > GroupElementCollection Class : Count Property (GroupElementCollection)

Gets the number of elements contained in the CollectionBase instance.

[Visual Basic]
Public ReadOnly Property Count As Integer
[C#]
public int Count {get;}
[C++]
public: __property int get_Count();
[C++/CLI]
public:
property int Count {
   int get();
}

See Also

GroupElementCollection Class | GroupElementCollection Members


GetEnumerator Method

GroupElementCollection Class | GroupElementCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetEnumerator Method

PegasusImaging.WinForms.NotateXpress9 Namespace > GroupElementCollection Class : GetEnumerator Method (GroupElementCollection)

Returns an enumerator that iterates through the CollectionBase instance.

[Visual Basic]
Public Function GetEnumerator() As IEnumerator
[C#]
public IEnumerator GetEnumerator();
[C++]
public: IEnumerator* GetEnumerator();
[C++/CLI]
public:
IEnumerator^ GetEnumerator();

Return Type

An IEnumerator for the CollectionBase instance.

See Also

GroupElementCollection Class | GroupElementCollection Members


ImageTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ImageTool Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : ImageTool Class

For a list of all members of this type, see ImageTool members.

Public Methods

Public Method NudgeDown (Inherited from Element) | Moves the specified annotation object one level down, towards the back, in the painting order of the specified layer.
Public Method NudgeUp (Inherited from Element) | Moves the specified annotation object one level up, towards the front, in the painting order of the specified layer.
Public Method UserDataAdd (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataDelete (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFind (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFindFirst (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFindNext (Inherited from Element) | User data can be added to each element in a key value pair.

See Also

ImageTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace


InvalidAnnotationFileException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidAnnotationFileException Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidAnnotationFileException Class

For a list of all members of this type, see InvalidAnnotationFileException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InvalidAnnotationFileException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


InvalidAnnotationFileException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidAnnotationFileException Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidAnnotationFileException Class

For a list of all members of this type, see InvalidAnnotationFileException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

InvalidAnnotationFileException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Data Property

InvalidAnnotationFileException Class | InvalidAnnotationFileException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Data Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidAnnotationFileException Class : Data Property (InvalidAnnotationFileException)

Gets a collection of key/value pairs that provide additional, user-defined information about the exception.

[Visual Basic]
Public ReadOnly Property Data As IDictionary
[C#]
public IDictionary Data {get;}
[C++]
public: __property IDictionary* get_Data();
[C++/CLI]
public:
property IDictionary^ Data {
   IDictionary^ get();
}

See Also

InvalidAnnotationFileException Class | InvalidAnnotationFileException Members


GetBaseException Method

InvalidAnnotationFileException Class | InvalidAnnotationFileException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetBaseException Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidAnnotationFileException Class : GetBaseException Method (InvalidAnnotationFileException)

When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.

[Visual Basic]
Public Function GetBaseException() As Exception
[C#]
public Exception GetBaseException();
[C++]
public: Exception* GetBaseException();
[C++/CLI]
public:
Exception^ GetBaseException();

Return Type

The first exception thrown in a chain of exceptions. If the InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

See Also

InvalidAnnotationFileException Class | InvalidAnnotationFileException Members


GetObjectData Method

InvalidAnnotationFileException Class | InvalidAnnotationFileException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetObjectData Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidAnnotationFileException Class : GetObjectData Method (InvalidAnnotationFileException)

When overridden in a derived class, sets the SerializationInfo with information about the exception.

[Visual Basic]
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
[C++/CLI]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

InvalidAnnotationFileException Class | InvalidAnnotationFileException Members


GetType Method

InvalidAnnotationFileException Class | InvalidAnnotationFileException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetType Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidAnnotationFileException Class : GetType Method (InvalidAnnotationFileException)

Gets the runtime type of the current instance.

[Visual Basic]
Public Function GetType() As Type
[C#]
public Type GetType();
[C++]
public: Type* GetType();
[C++/CLI]
public:
Type^ GetType();

Return Type

A Type object that represents the exact runtime type of the current instance.

See Also

InvalidAnnotationFileException Class | InvalidAnnotationFileException Members


HelpLink Property

InvalidAnnotationFileException Class | InvalidAnnotationFileException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HelpLink Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidAnnotationFileException Class : HelpLink Property (InvalidAnnotationFileException)

Gets or sets a link to the help file associated with this exception.

[Visual Basic]
Public Property HelpLink As String
[C#]
public string HelpLink {get; set;}
[C++]
public: __property string* get_HelpLink();
public: __property void set_HelpLink(
   string* value
);
[C++/CLI]
public:
property String^ HelpLink {
   String^ get();
   void set (String^ value);
}

See Also

InvalidAnnotationFileException Class | InvalidAnnotationFileException Members


InnerException Property

InvalidAnnotationFileException Class | InvalidAnnotationFileException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InnerException Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidAnnotationFileException Class : InnerException Property (InvalidAnnotationFileException)

Gets the Exception instance that caused the current exception.

[Visual Basic]
Public ReadOnly Property InnerException As Exception
[C#]
public Exception InnerException {get;}
[C++]
public: __property Exception* get_InnerException();
[C++/CLI]
public:
property Exception^ InnerException {
   Exception^ get();
}

See Also

InvalidAnnotationFileException Class | InvalidAnnotationFileException Members


Message Property

InvalidAnnotationFileException Class | InvalidAnnotationFileException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Message Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidAnnotationFileException Class : Message Property (InvalidAnnotationFileException)

Gets a message that describes the current exception.

[Visual Basic]
Public ReadOnly Property Message As String
[C#]
public string Message {get;}
[C++]
public: __property string* get_Message();
[C++/CLI]
public:
property String^ Message {
   String^ get();
}

See Also

InvalidAnnotationFileException Class | InvalidAnnotationFileException Members


Source Property

InvalidAnnotationFileException Class | InvalidAnnotationFileException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Source Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidAnnotationFileException Class : Source Property (InvalidAnnotationFileException)

Gets or sets the name of the application or the object that causes the error.

[Visual Basic]
Public Property Source As String
[C#]
public string Source {get; set;}
[C++]
public: __property string* get_Source();
public: __property void set_Source(
   string* value
);
[C++/CLI]
public:
property String^ Source {
   String^ get();
   void set (String^ value);
}

See Also

InvalidAnnotationFileException Class | InvalidAnnotationFileException Members


StackTrace Property

InvalidAnnotationFileException Class | InvalidAnnotationFileException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StackTrace Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidAnnotationFileException Class : StackTrace Property (InvalidAnnotationFileException)

Gets a string representation of the frames on the call stack at the time the current exception was thrown.

[Visual Basic]
Public ReadOnly Property StackTrace As String
[C#]
public string StackTrace {get;}
[C++]
public: __property string* get_StackTrace();
[C++/CLI]
public:
property String^ StackTrace {
   String^ get();
}

See Also

InvalidAnnotationFileException Class | InvalidAnnotationFileException Members


TargetSite Property

InvalidAnnotationFileException Class | InvalidAnnotationFileException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TargetSite Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidAnnotationFileException Class : TargetSite Property (InvalidAnnotationFileException)

Gets the method that throws the current exception.

[Visual Basic]
Public ReadOnly Property TargetSite As MethodBase
[C#]
public MethodBase TargetSite {get;}
[C++]
public: __property MethodBase* get_TargetSite();
[C++/CLI]
public:
property MethodBase^ TargetSite {
   MethodBase^ get();
}

See Also

InvalidAnnotationFileException Class | InvalidAnnotationFileException Members


ToString Method

InvalidAnnotationFileException Class | InvalidAnnotationFileException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToString Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidAnnotationFileException Class : ToString Method (InvalidAnnotationFileException)

Creates and returns a string representation of the current exception.

[Visual Basic]
Public Function ToString() As String
[C#]
public string ToString();
[C++]
public: string* ToString();
[C++/CLI]
public:
String^ ToString();

Return Type

A string representation of the current exception.

See Also

InvalidAnnotationFileException Class | InvalidAnnotationFileException Members


InvalidAttributeException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidAttributeException Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidAttributeException Class

For a list of all members of this type, see InvalidAttributeException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InvalidAttributeException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


InvalidAttributeException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidAttributeException Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidAttributeException Class

For a list of all members of this type, see InvalidAttributeException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

InvalidAttributeException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Data Property

InvalidAttributeException Class | InvalidAttributeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Data Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidAttributeException Class : Data Property (InvalidAttributeException)

Gets a collection of key/value pairs that provide additional, user-defined information about the exception.

[Visual Basic]
Public ReadOnly Property Data As IDictionary
[C#]
public IDictionary Data {get;}
[C++]
public: __property IDictionary* get_Data();
[C++/CLI]
public:
property IDictionary^ Data {
   IDictionary^ get();
}

See Also

InvalidAttributeException Class | InvalidAttributeException Members


GetBaseException Method

InvalidAttributeException Class | InvalidAttributeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetBaseException Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidAttributeException Class : GetBaseException Method (InvalidAttributeException)

When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.

[Visual Basic]
Public Function GetBaseException() As Exception
[C#]
public Exception GetBaseException();
[C++]
public: Exception* GetBaseException();
[C++/CLI]
public:
Exception^ GetBaseException();

Return Type

The first exception thrown in a chain of exceptions. If the InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

See Also

InvalidAttributeException Class | InvalidAttributeException Members


GetObjectData Method

InvalidAttributeException Class | InvalidAttributeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetObjectData Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidAttributeException Class : GetObjectData Method (InvalidAttributeException)

When overridden in a derived class, sets the SerializationInfo with information about the exception.

[Visual Basic]
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
[C++/CLI]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

InvalidAttributeException Class | InvalidAttributeException Members


GetType Method

InvalidAttributeException Class | InvalidAttributeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetType Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidAttributeException Class : GetType Method (InvalidAttributeException)

Gets the runtime type of the current instance.

[Visual Basic]
Public Function GetType() As Type
[C#]
public Type GetType();
[C++]
public: Type* GetType();
[C++/CLI]
public:
Type^ GetType();

Return Type

A Type object that represents the exact runtime type of the current instance.

See Also

InvalidAttributeException Class | InvalidAttributeException Members


HelpLink Property

InvalidAttributeException Class | InvalidAttributeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HelpLink Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidAttributeException Class : HelpLink Property (InvalidAttributeException)

Gets or sets a link to the help file associated with this exception.

[Visual Basic]
Public Property HelpLink As String
[C#]
public string HelpLink {get; set;}
[C++]
public: __property string* get_HelpLink();
public: __property void set_HelpLink(
   string* value
);
[C++/CLI]
public:
property String^ HelpLink {
   String^ get();
   void set (String^ value);
}

See Also

InvalidAttributeException Class | InvalidAttributeException Members


InnerException Property

InvalidAttributeException Class | InvalidAttributeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InnerException Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidAttributeException Class : InnerException Property (InvalidAttributeException)

Gets the Exception instance that caused the current exception.

[Visual Basic]
Public ReadOnly Property InnerException As Exception
[C#]
public Exception InnerException {get;}
[C++]
public: __property Exception* get_InnerException();
[C++/CLI]
public:
property Exception^ InnerException {
   Exception^ get();
}

See Also

InvalidAttributeException Class | InvalidAttributeException Members


Message Property

InvalidAttributeException Class | InvalidAttributeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Message Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidAttributeException Class : Message Property (InvalidAttributeException)

Gets a message that describes the current exception.

[Visual Basic]
Public ReadOnly Property Message As String
[C#]
public string Message {get;}
[C++]
public: __property string* get_Message();
[C++/CLI]
public:
property String^ Message {
   String^ get();
}

See Also

InvalidAttributeException Class | InvalidAttributeException Members


Source Property

InvalidAttributeException Class | InvalidAttributeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Source Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidAttributeException Class : Source Property (InvalidAttributeException)

Gets or sets the name of the application or the object that causes the error.

[Visual Basic]
Public Property Source As String
[C#]
public string Source {get; set;}
[C++]
public: __property string* get_Source();
public: __property void set_Source(
   string* value
);
[C++/CLI]
public:
property String^ Source {
   String^ get();
   void set (String^ value);
}

See Also

InvalidAttributeException Class | InvalidAttributeException Members


StackTrace Property

InvalidAttributeException Class | InvalidAttributeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StackTrace Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidAttributeException Class : StackTrace Property (InvalidAttributeException)

Gets a string representation of the frames on the call stack at the time the current exception was thrown.

[Visual Basic]
Public ReadOnly Property StackTrace As String
[C#]
public string StackTrace {get;}
[C++]
public: __property string* get_StackTrace();
[C++/CLI]
public:
property String^ StackTrace {
   String^ get();
}

See Also

InvalidAttributeException Class | InvalidAttributeException Members


TargetSite Property

InvalidAttributeException Class | InvalidAttributeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TargetSite Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidAttributeException Class : TargetSite Property (InvalidAttributeException)

Gets the method that throws the current exception.

[Visual Basic]
Public ReadOnly Property TargetSite As MethodBase
[C#]
public MethodBase TargetSite {get;}
[C++]
public: __property MethodBase* get_TargetSite();
[C++/CLI]
public:
property MethodBase^ TargetSite {
   MethodBase^ get();
}

See Also

InvalidAttributeException Class | InvalidAttributeException Members


ToString Method

InvalidAttributeException Class | InvalidAttributeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToString Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidAttributeException Class : ToString Method (InvalidAttributeException)

Creates and returns a string representation of the current exception.

[Visual Basic]
Public Function ToString() As String
[C#]
public string ToString();
[C++]
public: string* ToString();
[C++/CLI]
public:
String^ ToString();

Return Type

A string representation of the current exception.

See Also

InvalidAttributeException Class | InvalidAttributeException Members


InvalidColorTypeException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidColorTypeException Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidColorTypeException Class

For a list of all members of this type, see InvalidColorTypeException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InvalidColorTypeException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


InvalidColorTypeException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidColorTypeException Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidColorTypeException Class

For a list of all members of this type, see InvalidColorTypeException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

InvalidColorTypeException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Data Property

InvalidColorTypeException Class | InvalidColorTypeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Data Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidColorTypeException Class : Data Property (InvalidColorTypeException)

Gets a collection of key/value pairs that provide additional, user-defined information about the exception.

[Visual Basic]
Public ReadOnly Property Data As IDictionary
[C#]
public IDictionary Data {get;}
[C++]
public: __property IDictionary* get_Data();
[C++/CLI]
public:
property IDictionary^ Data {
   IDictionary^ get();
}

See Also

InvalidColorTypeException Class | InvalidColorTypeException Members


GetBaseException Method

InvalidColorTypeException Class | InvalidColorTypeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetBaseException Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidColorTypeException Class : GetBaseException Method (InvalidColorTypeException)

When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.

[Visual Basic]
Public Function GetBaseException() As Exception
[C#]
public Exception GetBaseException();
[C++]
public: Exception* GetBaseException();
[C++/CLI]
public:
Exception^ GetBaseException();

Return Type

The first exception thrown in a chain of exceptions. If the InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

See Also

InvalidColorTypeException Class | InvalidColorTypeException Members


GetObjectData Method

InvalidColorTypeException Class | InvalidColorTypeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetObjectData Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidColorTypeException Class : GetObjectData Method (InvalidColorTypeException)

When overridden in a derived class, sets the SerializationInfo with information about the exception.

[Visual Basic]
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
[C++/CLI]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

InvalidColorTypeException Class | InvalidColorTypeException Members


GetType Method

InvalidColorTypeException Class | InvalidColorTypeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetType Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidColorTypeException Class : GetType Method (InvalidColorTypeException)

Gets the runtime type of the current instance.

[Visual Basic]
Public Function GetType() As Type
[C#]
public Type GetType();
[C++]
public: Type* GetType();
[C++/CLI]
public:
Type^ GetType();

Return Type

A Type object that represents the exact runtime type of the current instance.

See Also

InvalidColorTypeException Class | InvalidColorTypeException Members


HelpLink Property

InvalidColorTypeException Class | InvalidColorTypeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HelpLink Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidColorTypeException Class : HelpLink Property (InvalidColorTypeException)

Gets or sets a link to the help file associated with this exception.

[Visual Basic]
Public Property HelpLink As String
[C#]
public string HelpLink {get; set;}
[C++]
public: __property string* get_HelpLink();
public: __property void set_HelpLink(
   string* value
);
[C++/CLI]
public:
property String^ HelpLink {
   String^ get();
   void set (String^ value);
}

See Also

InvalidColorTypeException Class | InvalidColorTypeException Members


InnerException Property

InvalidColorTypeException Class | InvalidColorTypeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InnerException Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidColorTypeException Class : InnerException Property (InvalidColorTypeException)

Gets the Exception instance that caused the current exception.

[Visual Basic]
Public ReadOnly Property InnerException As Exception
[C#]
public Exception InnerException {get;}
[C++]
public: __property Exception* get_InnerException();
[C++/CLI]
public:
property Exception^ InnerException {
   Exception^ get();
}

See Also

InvalidColorTypeException Class | InvalidColorTypeException Members


Message Property

InvalidColorTypeException Class | InvalidColorTypeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Message Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidColorTypeException Class : Message Property (InvalidColorTypeException)

Gets a message that describes the current exception.

[Visual Basic]
Public ReadOnly Property Message As String
[C#]
public string Message {get;}
[C++]
public: __property string* get_Message();
[C++/CLI]
public:
property String^ Message {
   String^ get();
}

See Also

InvalidColorTypeException Class | InvalidColorTypeException Members


Source Property

InvalidColorTypeException Class | InvalidColorTypeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Source Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidColorTypeException Class : Source Property (InvalidColorTypeException)

Gets or sets the name of the application or the object that causes the error.

[Visual Basic]
Public Property Source As String
[C#]
public string Source {get; set;}
[C++]
public: __property string* get_Source();
public: __property void set_Source(
   string* value
);
[C++/CLI]
public:
property String^ Source {
   String^ get();
   void set (String^ value);
}

See Also

InvalidColorTypeException Class | InvalidColorTypeException Members


StackTrace Property

InvalidColorTypeException Class | InvalidColorTypeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StackTrace Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidColorTypeException Class : StackTrace Property (InvalidColorTypeException)

Gets a string representation of the frames on the call stack at the time the current exception was thrown.

[Visual Basic]
Public ReadOnly Property StackTrace As String
[C#]
public string StackTrace {get;}
[C++]
public: __property string* get_StackTrace();
[C++/CLI]
public:
property String^ StackTrace {
   String^ get();
}

See Also

InvalidColorTypeException Class | InvalidColorTypeException Members


TargetSite Property

InvalidColorTypeException Class | InvalidColorTypeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TargetSite Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidColorTypeException Class : TargetSite Property (InvalidColorTypeException)

Gets the method that throws the current exception.

[Visual Basic]
Public ReadOnly Property TargetSite As MethodBase
[C#]
public MethodBase TargetSite {get;}
[C++]
public: __property MethodBase* get_TargetSite();
[C++/CLI]
public:
property MethodBase^ TargetSite {
   MethodBase^ get();
}

See Also

InvalidColorTypeException Class | InvalidColorTypeException Members


ToString Method

InvalidColorTypeException Class | InvalidColorTypeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToString Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidColorTypeException Class : ToString Method (InvalidColorTypeException)

Creates and returns a string representation of the current exception.

[Visual Basic]
Public Function ToString() As String
[C#]
public string ToString();
[C++]
public: string* ToString();
[C++/CLI]
public:
String^ ToString();

Return Type

A string representation of the current exception.

See Also

InvalidColorTypeException Class | InvalidColorTypeException Members


InvalidContextException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidContextException Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidContextException Class

For a list of all members of this type, see InvalidContextException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InvalidContextException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


InvalidContextException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidContextException Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidContextException Class

For a list of all members of this type, see InvalidContextException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

InvalidContextException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Data Property

InvalidContextException Class | InvalidContextException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Data Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidContextException Class : Data Property (InvalidContextException)

Gets a collection of key/value pairs that provide additional, user-defined information about the exception.

[Visual Basic]
Public ReadOnly Property Data As IDictionary
[C#]
public IDictionary Data {get;}
[C++]
public: __property IDictionary* get_Data();
[C++/CLI]
public:
property IDictionary^ Data {
   IDictionary^ get();
}

See Also

InvalidContextException Class | InvalidContextException Members


GetBaseException Method

InvalidContextException Class | InvalidContextException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetBaseException Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidContextException Class : GetBaseException Method (InvalidContextException)

When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.

[Visual Basic]
Public Function GetBaseException() As Exception
[C#]
public Exception GetBaseException();
[C++]
public: Exception* GetBaseException();
[C++/CLI]
public:
Exception^ GetBaseException();

Return Type

The first exception thrown in a chain of exceptions. If the InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

See Also

InvalidContextException Class | InvalidContextException Members


GetObjectData Method

InvalidContextException Class | InvalidContextException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetObjectData Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidContextException Class : GetObjectData Method (InvalidContextException)

When overridden in a derived class, sets the SerializationInfo with information about the exception.

[Visual Basic]
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
[C++/CLI]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

InvalidContextException Class | InvalidContextException Members


GetType Method

InvalidContextException Class | InvalidContextException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetType Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidContextException Class : GetType Method (InvalidContextException)

Gets the runtime type of the current instance.

[Visual Basic]
Public Function GetType() As Type
[C#]
public Type GetType();
[C++]
public: Type* GetType();
[C++/CLI]
public:
Type^ GetType();

Return Type

A Type object that represents the exact runtime type of the current instance.

See Also

InvalidContextException Class | InvalidContextException Members


HelpLink Property

InvalidContextException Class | InvalidContextException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HelpLink Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidContextException Class : HelpLink Property (InvalidContextException)

Gets or sets a link to the help file associated with this exception.

[Visual Basic]
Public Property HelpLink As String
[C#]
public string HelpLink {get; set;}
[C++]
public: __property string* get_HelpLink();
public: __property void set_HelpLink(
   string* value
);
[C++/CLI]
public:
property String^ HelpLink {
   String^ get();
   void set (String^ value);
}

See Also

InvalidContextException Class | InvalidContextException Members


InnerException Property

InvalidContextException Class | InvalidContextException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InnerException Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidContextException Class : InnerException Property (InvalidContextException)

Gets the Exception instance that caused the current exception.

[Visual Basic]
Public ReadOnly Property InnerException As Exception
[C#]
public Exception InnerException {get;}
[C++]
public: __property Exception* get_InnerException();
[C++/CLI]
public:
property Exception^ InnerException {
   Exception^ get();
}

See Also

InvalidContextException Class | InvalidContextException Members


Message Property

InvalidContextException Class | InvalidContextException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Message Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidContextException Class : Message Property (InvalidContextException)

Gets a message that describes the current exception.

[Visual Basic]
Public ReadOnly Property Message As String
[C#]
public string Message {get;}
[C++]
public: __property string* get_Message();
[C++/CLI]
public:
property String^ Message {
   String^ get();
}

See Also

InvalidContextException Class | InvalidContextException Members


Source Property

InvalidContextException Class | InvalidContextException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Source Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidContextException Class : Source Property (InvalidContextException)

Gets or sets the name of the application or the object that causes the error.

[Visual Basic]
Public Property Source As String
[C#]
public string Source {get; set;}
[C++]
public: __property string* get_Source();
public: __property void set_Source(
   string* value
);
[C++/CLI]
public:
property String^ Source {
   String^ get();
   void set (String^ value);
}

See Also

InvalidContextException Class | InvalidContextException Members


StackTrace Property

InvalidContextException Class | InvalidContextException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StackTrace Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidContextException Class : StackTrace Property (InvalidContextException)

Gets a string representation of the frames on the call stack at the time the current exception was thrown.

[Visual Basic]
Public ReadOnly Property StackTrace As String
[C#]
public string StackTrace {get;}
[C++]
public: __property string* get_StackTrace();
[C++/CLI]
public:
property String^ StackTrace {
   String^ get();
}

See Also

InvalidContextException Class | InvalidContextException Members


TargetSite Property

InvalidContextException Class | InvalidContextException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TargetSite Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidContextException Class : TargetSite Property (InvalidContextException)

Gets the method that throws the current exception.

[Visual Basic]
Public ReadOnly Property TargetSite As MethodBase
[C#]
public MethodBase TargetSite {get;}
[C++]
public: __property MethodBase* get_TargetSite();
[C++/CLI]
public:
property MethodBase^ TargetSite {
   MethodBase^ get();
}

See Also

InvalidContextException Class | InvalidContextException Members


ToString Method

InvalidContextException Class | InvalidContextException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToString Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidContextException Class : ToString Method (InvalidContextException)

Creates and returns a string representation of the current exception.

[Visual Basic]
Public Function ToString() As String
[C#]
public string ToString();
[C++]
public: string* ToString();
[C++/CLI]
public:
String^ ToString();

Return Type

A string representation of the current exception.

See Also

InvalidContextException Class | InvalidContextException Members


InvalidContextIdException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidContextIdException Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidContextIdException Class

For a list of all members of this type, see InvalidContextIdException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InvalidContextIdException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


InvalidContextIdException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidContextIdException Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidContextIdException Class

For a list of all members of this type, see InvalidContextIdException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

InvalidContextIdException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Data Property

InvalidContextIdException Class | InvalidContextIdException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Data Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidContextIdException Class : Data Property (InvalidContextIdException)

Gets a collection of key/value pairs that provide additional, user-defined information about the exception.

[Visual Basic]
Public ReadOnly Property Data As IDictionary
[C#]
public IDictionary Data {get;}
[C++]
public: __property IDictionary* get_Data();
[C++/CLI]
public:
property IDictionary^ Data {
   IDictionary^ get();
}

See Also

InvalidContextIdException Class | InvalidContextIdException Members


GetBaseException Method

InvalidContextIdException Class | InvalidContextIdException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetBaseException Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidContextIdException Class : GetBaseException Method (InvalidContextIdException)

When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.

[Visual Basic]
Public Function GetBaseException() As Exception
[C#]
public Exception GetBaseException();
[C++]
public: Exception* GetBaseException();
[C++/CLI]
public:
Exception^ GetBaseException();

Return Type

The first exception thrown in a chain of exceptions. If the InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

See Also

InvalidContextIdException Class | InvalidContextIdException Members


GetObjectData Method

InvalidContextIdException Class | InvalidContextIdException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetObjectData Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidContextIdException Class : GetObjectData Method (InvalidContextIdException)

When overridden in a derived class, sets the SerializationInfo with information about the exception.

[Visual Basic]
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
[C++/CLI]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

InvalidContextIdException Class | InvalidContextIdException Members


GetType Method

InvalidContextIdException Class | InvalidContextIdException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetType Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidContextIdException Class : GetType Method (InvalidContextIdException)

Gets the runtime type of the current instance.

[Visual Basic]
Public Function GetType() As Type
[C#]
public Type GetType();
[C++]
public: Type* GetType();
[C++/CLI]
public:
Type^ GetType();

Return Type

A Type object that represents the exact runtime type of the current instance.

See Also

InvalidContextIdException Class | InvalidContextIdException Members


HelpLink Property

InvalidContextIdException Class | InvalidContextIdException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HelpLink Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidContextIdException Class : HelpLink Property (InvalidContextIdException)

Gets or sets a link to the help file associated with this exception.

[Visual Basic]
Public Property HelpLink As String
[C#]
public string HelpLink {get; set;}
[C++]
public: __property string* get_HelpLink();
public: __property void set_HelpLink(
   string* value
);
[C++/CLI]
public:
property String^ HelpLink {
   String^ get();
   void set (String^ value);
}

See Also

InvalidContextIdException Class | InvalidContextIdException Members


InnerException Property

InvalidContextIdException Class | InvalidContextIdException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InnerException Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidContextIdException Class : InnerException Property (InvalidContextIdException)

Gets the Exception instance that caused the current exception.

[Visual Basic]
Public ReadOnly Property InnerException As Exception
[C#]
public Exception InnerException {get;}
[C++]
public: __property Exception* get_InnerException();
[C++/CLI]
public:
property Exception^ InnerException {
   Exception^ get();
}

See Also

InvalidContextIdException Class | InvalidContextIdException Members


Message Property

InvalidContextIdException Class | InvalidContextIdException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Message Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidContextIdException Class : Message Property (InvalidContextIdException)

Gets a message that describes the current exception.

[Visual Basic]
Public ReadOnly Property Message As String
[C#]
public string Message {get;}
[C++]
public: __property string* get_Message();
[C++/CLI]
public:
property String^ Message {
   String^ get();
}

See Also

InvalidContextIdException Class | InvalidContextIdException Members


Source Property

InvalidContextIdException Class | InvalidContextIdException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Source Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidContextIdException Class : Source Property (InvalidContextIdException)

Gets or sets the name of the application or the object that causes the error.

[Visual Basic]
Public Property Source As String
[C#]
public string Source {get; set;}
[C++]
public: __property string* get_Source();
public: __property void set_Source(
   string* value
);
[C++/CLI]
public:
property String^ Source {
   String^ get();
   void set (String^ value);
}

See Also

InvalidContextIdException Class | InvalidContextIdException Members


StackTrace Property

InvalidContextIdException Class | InvalidContextIdException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StackTrace Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidContextIdException Class : StackTrace Property (InvalidContextIdException)

Gets a string representation of the frames on the call stack at the time the current exception was thrown.

[Visual Basic]
Public ReadOnly Property StackTrace As String
[C#]
public string StackTrace {get;}
[C++]
public: __property string* get_StackTrace();
[C++/CLI]
public:
property String^ StackTrace {
   String^ get();
}

See Also

InvalidContextIdException Class | InvalidContextIdException Members


TargetSite Property

InvalidContextIdException Class | InvalidContextIdException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TargetSite Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidContextIdException Class : TargetSite Property (InvalidContextIdException)

Gets the method that throws the current exception.

[Visual Basic]
Public ReadOnly Property TargetSite As MethodBase
[C#]
public MethodBase TargetSite {get;}
[C++]
public: __property MethodBase* get_TargetSite();
[C++/CLI]
public:
property MethodBase^ TargetSite {
   MethodBase^ get();
}

See Also

InvalidContextIdException Class | InvalidContextIdException Members


ToString Method

InvalidContextIdException Class | InvalidContextIdException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToString Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidContextIdException Class : ToString Method (InvalidContextIdException)

Creates and returns a string representation of the current exception.

[Visual Basic]
Public Function ToString() As String
[C#]
public string ToString();
[C++]
public: string* ToString();
[C++/CLI]
public:
String^ ToString();

Return Type

A string representation of the current exception.

See Also

InvalidContextIdException Class | InvalidContextIdException Members


InvalidCursorTypeException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidCursorTypeException Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidCursorTypeException Class

For a list of all members of this type, see InvalidCursorTypeException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InvalidCursorTypeException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


InvalidCursorTypeException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidCursorTypeException Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidCursorTypeException Class

For a list of all members of this type, see InvalidCursorTypeException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

InvalidCursorTypeException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Data Property

InvalidCursorTypeException Class | InvalidCursorTypeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Data Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidCursorTypeException Class : Data Property (InvalidCursorTypeException)

Gets a collection of key/value pairs that provide additional, user-defined information about the exception.

[Visual Basic]
Public ReadOnly Property Data As IDictionary
[C#]
public IDictionary Data {get;}
[C++]
public: __property IDictionary* get_Data();
[C++/CLI]
public:
property IDictionary^ Data {
   IDictionary^ get();
}

See Also

InvalidCursorTypeException Class | InvalidCursorTypeException Members


GetBaseException Method

InvalidCursorTypeException Class | InvalidCursorTypeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetBaseException Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidCursorTypeException Class : GetBaseException Method (InvalidCursorTypeException)

When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.

[Visual Basic]
Public Function GetBaseException() As Exception
[C#]
public Exception GetBaseException();
[C++]
public: Exception* GetBaseException();
[C++/CLI]
public:
Exception^ GetBaseException();

Return Type

The first exception thrown in a chain of exceptions. If the InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

See Also

InvalidCursorTypeException Class | InvalidCursorTypeException Members


GetObjectData Method

InvalidCursorTypeException Class | InvalidCursorTypeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetObjectData Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidCursorTypeException Class : GetObjectData Method (InvalidCursorTypeException)

When overridden in a derived class, sets the SerializationInfo with information about the exception.

[Visual Basic]
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
[C++/CLI]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

InvalidCursorTypeException Class | InvalidCursorTypeException Members


GetType Method

InvalidCursorTypeException Class | InvalidCursorTypeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetType Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidCursorTypeException Class : GetType Method (InvalidCursorTypeException)

Gets the runtime type of the current instance.

[Visual Basic]
Public Function GetType() As Type
[C#]
public Type GetType();
[C++]
public: Type* GetType();
[C++/CLI]
public:
Type^ GetType();

Return Type

A Type object that represents the exact runtime type of the current instance.

See Also

InvalidCursorTypeException Class | InvalidCursorTypeException Members


HelpLink Property

InvalidCursorTypeException Class | InvalidCursorTypeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HelpLink Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidCursorTypeException Class : HelpLink Property (InvalidCursorTypeException)

Gets or sets a link to the help file associated with this exception.

[Visual Basic]
Public Property HelpLink As String
[C#]
public string HelpLink {get; set;}
[C++]
public: __property string* get_HelpLink();
public: __property void set_HelpLink(
   string* value
);
[C++/CLI]
public:
property String^ HelpLink {
   String^ get();
   void set (String^ value);
}

See Also

InvalidCursorTypeException Class | InvalidCursorTypeException Members


InnerException Property

InvalidCursorTypeException Class | InvalidCursorTypeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InnerException Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidCursorTypeException Class : InnerException Property (InvalidCursorTypeException)

Gets the Exception instance that caused the current exception.

[Visual Basic]
Public ReadOnly Property InnerException As Exception
[C#]
public Exception InnerException {get;}
[C++]
public: __property Exception* get_InnerException();
[C++/CLI]
public:
property Exception^ InnerException {
   Exception^ get();
}

See Also

InvalidCursorTypeException Class | InvalidCursorTypeException Members


Message Property

InvalidCursorTypeException Class | InvalidCursorTypeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Message Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidCursorTypeException Class : Message Property (InvalidCursorTypeException)

Gets a message that describes the current exception.

[Visual Basic]
Public ReadOnly Property Message As String
[C#]
public string Message {get;}
[C++]
public: __property string* get_Message();
[C++/CLI]
public:
property String^ Message {
   String^ get();
}

See Also

InvalidCursorTypeException Class | InvalidCursorTypeException Members


Source Property

InvalidCursorTypeException Class | InvalidCursorTypeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Source Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidCursorTypeException Class : Source Property (InvalidCursorTypeException)

Gets or sets the name of the application or the object that causes the error.

[Visual Basic]
Public Property Source As String
[C#]
public string Source {get; set;}
[C++]
public: __property string* get_Source();
public: __property void set_Source(
   string* value
);
[C++/CLI]
public:
property String^ Source {
   String^ get();
   void set (String^ value);
}

See Also

InvalidCursorTypeException Class | InvalidCursorTypeException Members


StackTrace Property

InvalidCursorTypeException Class | InvalidCursorTypeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StackTrace Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidCursorTypeException Class : StackTrace Property (InvalidCursorTypeException)

Gets a string representation of the frames on the call stack at the time the current exception was thrown.

[Visual Basic]
Public ReadOnly Property StackTrace As String
[C#]
public string StackTrace {get;}
[C++]
public: __property string* get_StackTrace();
[C++/CLI]
public:
property String^ StackTrace {
   String^ get();
}

See Also

InvalidCursorTypeException Class | InvalidCursorTypeException Members


TargetSite Property

InvalidCursorTypeException Class | InvalidCursorTypeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TargetSite Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidCursorTypeException Class : TargetSite Property (InvalidCursorTypeException)

Gets the method that throws the current exception.

[Visual Basic]
Public ReadOnly Property TargetSite As MethodBase
[C#]
public MethodBase TargetSite {get;}
[C++]
public: __property MethodBase* get_TargetSite();
[C++/CLI]
public:
property MethodBase^ TargetSite {
   MethodBase^ get();
}

See Also

InvalidCursorTypeException Class | InvalidCursorTypeException Members


ToString Method

InvalidCursorTypeException Class | InvalidCursorTypeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToString Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidCursorTypeException Class : ToString Method (InvalidCursorTypeException)

Creates and returns a string representation of the current exception.

[Visual Basic]
Public Function ToString() As String
[C#]
public string ToString();
[C++]
public: string* ToString();
[C++/CLI]
public:
String^ ToString();

Return Type

A string representation of the current exception.

See Also

InvalidCursorTypeException Class | InvalidCursorTypeException Members


InvalidErrorLevelException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidErrorLevelException Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidErrorLevelException Class

For a list of all members of this type, see InvalidErrorLevelException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InvalidErrorLevelException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


InvalidErrorLevelException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidErrorLevelException Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidErrorLevelException Class

For a list of all members of this type, see InvalidErrorLevelException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

InvalidErrorLevelException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Data Property

InvalidErrorLevelException Class | InvalidErrorLevelException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Data Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidErrorLevelException Class : Data Property (InvalidErrorLevelException)

Gets a collection of key/value pairs that provide additional, user-defined information about the exception.

[Visual Basic]
Public ReadOnly Property Data As IDictionary
[C#]
public IDictionary Data {get;}
[C++]
public: __property IDictionary* get_Data();
[C++/CLI]
public:
property IDictionary^ Data {
   IDictionary^ get();
}

See Also

InvalidErrorLevelException Class | InvalidErrorLevelException Members


GetBaseException Method

InvalidErrorLevelException Class | InvalidErrorLevelException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetBaseException Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidErrorLevelException Class : GetBaseException Method (InvalidErrorLevelException)

When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.

[Visual Basic]
Public Function GetBaseException() As Exception
[C#]
public Exception GetBaseException();
[C++]
public: Exception* GetBaseException();
[C++/CLI]
public:
Exception^ GetBaseException();

Return Type

The first exception thrown in a chain of exceptions. If the InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

See Also

InvalidErrorLevelException Class | InvalidErrorLevelException Members


GetObjectData Method

InvalidErrorLevelException Class | InvalidErrorLevelException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetObjectData Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidErrorLevelException Class : GetObjectData Method (InvalidErrorLevelException)

When overridden in a derived class, sets the SerializationInfo with information about the exception.

[Visual Basic]
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
[C++/CLI]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

InvalidErrorLevelException Class | InvalidErrorLevelException Members


GetType Method

InvalidErrorLevelException Class | InvalidErrorLevelException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetType Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidErrorLevelException Class : GetType Method (InvalidErrorLevelException)

Gets the runtime type of the current instance.

[Visual Basic]
Public Function GetType() As Type
[C#]
public Type GetType();
[C++]
public: Type* GetType();
[C++/CLI]
public:
Type^ GetType();

Return Type

A Type object that represents the exact runtime type of the current instance.

See Also

InvalidErrorLevelException Class | InvalidErrorLevelException Members


HelpLink Property

InvalidErrorLevelException Class | InvalidErrorLevelException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HelpLink Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidErrorLevelException Class : HelpLink Property (InvalidErrorLevelException)

Gets or sets a link to the help file associated with this exception.

[Visual Basic]
Public Property HelpLink As String
[C#]
public string HelpLink {get; set;}
[C++]
public: __property string* get_HelpLink();
public: __property void set_HelpLink(
   string* value
);
[C++/CLI]
public:
property String^ HelpLink {
   String^ get();
   void set (String^ value);
}

See Also

InvalidErrorLevelException Class | InvalidErrorLevelException Members


InnerException Property

InvalidErrorLevelException Class | InvalidErrorLevelException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InnerException Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidErrorLevelException Class : InnerException Property (InvalidErrorLevelException)

Gets the Exception instance that caused the current exception.

[Visual Basic]
Public ReadOnly Property InnerException As Exception
[C#]
public Exception InnerException {get;}
[C++]
public: __property Exception* get_InnerException();
[C++/CLI]
public:
property Exception^ InnerException {
   Exception^ get();
}

See Also

InvalidErrorLevelException Class | InvalidErrorLevelException Members


Message Property

InvalidErrorLevelException Class | InvalidErrorLevelException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Message Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidErrorLevelException Class : Message Property (InvalidErrorLevelException)

Gets a message that describes the current exception.

[Visual Basic]
Public ReadOnly Property Message As String
[C#]
public string Message {get;}
[C++]
public: __property string* get_Message();
[C++/CLI]
public:
property String^ Message {
   String^ get();
}

See Also

InvalidErrorLevelException Class | InvalidErrorLevelException Members


Source Property

InvalidErrorLevelException Class | InvalidErrorLevelException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Source Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidErrorLevelException Class : Source Property (InvalidErrorLevelException)

Gets or sets the name of the application or the object that causes the error.

[Visual Basic]
Public Property Source As String
[C#]
public string Source {get; set;}
[C++]
public: __property string* get_Source();
public: __property void set_Source(
   string* value
);
[C++/CLI]
public:
property String^ Source {
   String^ get();
   void set (String^ value);
}

See Also

InvalidErrorLevelException Class | InvalidErrorLevelException Members


StackTrace Property

InvalidErrorLevelException Class | InvalidErrorLevelException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StackTrace Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidErrorLevelException Class : StackTrace Property (InvalidErrorLevelException)

Gets a string representation of the frames on the call stack at the time the current exception was thrown.

[Visual Basic]
Public ReadOnly Property StackTrace As String
[C#]
public string StackTrace {get;}
[C++]
public: __property string* get_StackTrace();
[C++/CLI]
public:
property String^ StackTrace {
   String^ get();
}

See Also

InvalidErrorLevelException Class | InvalidErrorLevelException Members


TargetSite Property

InvalidErrorLevelException Class | InvalidErrorLevelException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TargetSite Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidErrorLevelException Class : TargetSite Property (InvalidErrorLevelException)

Gets the method that throws the current exception.

[Visual Basic]
Public ReadOnly Property TargetSite As MethodBase
[C#]
public MethodBase TargetSite {get;}
[C++]
public: __property MethodBase* get_TargetSite();
[C++/CLI]
public:
property MethodBase^ TargetSite {
   MethodBase^ get();
}

See Also

InvalidErrorLevelException Class | InvalidErrorLevelException Members


ToString Method

InvalidErrorLevelException Class | InvalidErrorLevelException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToString Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidErrorLevelException Class : ToString Method (InvalidErrorLevelException)

Creates and returns a string representation of the current exception.

[Visual Basic]
Public Function ToString() As String
[C#]
public string ToString();
[C++]
public: string* ToString();
[C++/CLI]
public:
String^ ToString();

Return Type

A string representation of the current exception.

See Also

InvalidErrorLevelException Class | InvalidErrorLevelException Members


InvalidFontException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidFontException Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidFontException Class

For a list of all members of this type, see InvalidFontException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InvalidFontException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


InvalidFontException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidFontException Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidFontException Class

For a list of all members of this type, see InvalidFontException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

InvalidFontException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Data Property

InvalidFontException Class | InvalidFontException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Data Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidFontException Class : Data Property (InvalidFontException)

Gets a collection of key/value pairs that provide additional, user-defined information about the exception.

[Visual Basic]
Public ReadOnly Property Data As IDictionary
[C#]
public IDictionary Data {get;}
[C++]
public: __property IDictionary* get_Data();
[C++/CLI]
public:
property IDictionary^ Data {
   IDictionary^ get();
}

See Also

InvalidFontException Class | InvalidFontException Members


GetBaseException Method

InvalidFontException Class | InvalidFontException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetBaseException Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidFontException Class : GetBaseException Method (InvalidFontException)

When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.

[Visual Basic]
Public Function GetBaseException() As Exception
[C#]
public Exception GetBaseException();
[C++]
public: Exception* GetBaseException();
[C++/CLI]
public:
Exception^ GetBaseException();

Return Type

The first exception thrown in a chain of exceptions. If the InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

See Also

InvalidFontException Class | InvalidFontException Members


GetObjectData Method

InvalidFontException Class | InvalidFontException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetObjectData Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidFontException Class : GetObjectData Method (InvalidFontException)

When overridden in a derived class, sets the SerializationInfo with information about the exception.

[Visual Basic]
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
[C++/CLI]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

InvalidFontException Class | InvalidFontException Members


GetType Method

InvalidFontException Class | InvalidFontException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetType Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidFontException Class : GetType Method (InvalidFontException)

Gets the runtime type of the current instance.

[Visual Basic]
Public Function GetType() As Type
[C#]
public Type GetType();
[C++]
public: Type* GetType();
[C++/CLI]
public:
Type^ GetType();

Return Type

A Type object that represents the exact runtime type of the current instance.

See Also

InvalidFontException Class | InvalidFontException Members


HelpLink Property

InvalidFontException Class | InvalidFontException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HelpLink Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidFontException Class : HelpLink Property (InvalidFontException)

Gets or sets a link to the help file associated with this exception.

[Visual Basic]
Public Property HelpLink As String
[C#]
public string HelpLink {get; set;}
[C++]
public: __property string* get_HelpLink();
public: __property void set_HelpLink(
   string* value
);
[C++/CLI]
public:
property String^ HelpLink {
   String^ get();
   void set (String^ value);
}

See Also

InvalidFontException Class | InvalidFontException Members


InnerException Property

InvalidFontException Class | InvalidFontException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InnerException Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidFontException Class : InnerException Property (InvalidFontException)

Gets the Exception instance that caused the current exception.

[Visual Basic]
Public ReadOnly Property InnerException As Exception
[C#]
public Exception InnerException {get;}
[C++]
public: __property Exception* get_InnerException();
[C++/CLI]
public:
property Exception^ InnerException {
   Exception^ get();
}

See Also

InvalidFontException Class | InvalidFontException Members


Message Property

InvalidFontException Class | InvalidFontException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Message Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidFontException Class : Message Property (InvalidFontException)

Gets a message that describes the current exception.

[Visual Basic]
Public ReadOnly Property Message As String
[C#]
public string Message {get;}
[C++]
public: __property string* get_Message();
[C++/CLI]
public:
property String^ Message {
   String^ get();
}

See Also

InvalidFontException Class | InvalidFontException Members


Source Property

InvalidFontException Class | InvalidFontException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Source Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidFontException Class : Source Property (InvalidFontException)

Gets or sets the name of the application or the object that causes the error.

[Visual Basic]
Public Property Source As String
[C#]
public string Source {get; set;}
[C++]
public: __property string* get_Source();
public: __property void set_Source(
   string* value
);
[C++/CLI]
public:
property String^ Source {
   String^ get();
   void set (String^ value);
}

See Also

InvalidFontException Class | InvalidFontException Members


StackTrace Property

InvalidFontException Class | InvalidFontException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StackTrace Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidFontException Class : StackTrace Property (InvalidFontException)

Gets a string representation of the frames on the call stack at the time the current exception was thrown.

[Visual Basic]
Public ReadOnly Property StackTrace As String
[C#]
public string StackTrace {get;}
[C++]
public: __property string* get_StackTrace();
[C++/CLI]
public:
property String^ StackTrace {
   String^ get();
}

See Also

InvalidFontException Class | InvalidFontException Members


TargetSite Property

InvalidFontException Class | InvalidFontException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TargetSite Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidFontException Class : TargetSite Property (InvalidFontException)

Gets the method that throws the current exception.

[Visual Basic]
Public ReadOnly Property TargetSite As MethodBase
[C#]
public MethodBase TargetSite {get;}
[C++]
public: __property MethodBase* get_TargetSite();
[C++/CLI]
public:
property MethodBase^ TargetSite {
   MethodBase^ get();
}

See Also

InvalidFontException Class | InvalidFontException Members


ToString Method

InvalidFontException Class | InvalidFontException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToString Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidFontException Class : ToString Method (InvalidFontException)

Creates and returns a string representation of the current exception.

[Visual Basic]
Public Function ToString() As String
[C#]
public string ToString();
[C++]
public: string* ToString();
[C++/CLI]
public:
String^ ToString();

Return Type

A string representation of the current exception.

See Also

InvalidFontException Class | InvalidFontException Members


InvalidGroupException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidGroupException Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidGroupException Class

For a list of all members of this type, see InvalidGroupException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InvalidGroupException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


InvalidGroupException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidGroupException Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidGroupException Class

For a list of all members of this type, see InvalidGroupException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

InvalidGroupException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Data Property

InvalidGroupException Class | InvalidGroupException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Data Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidGroupException Class : Data Property (InvalidGroupException)

Gets a collection of key/value pairs that provide additional, user-defined information about the exception.

[Visual Basic]
Public ReadOnly Property Data As IDictionary
[C#]
public IDictionary Data {get;}
[C++]
public: __property IDictionary* get_Data();
[C++/CLI]
public:
property IDictionary^ Data {
   IDictionary^ get();
}

See Also

InvalidGroupException Class | InvalidGroupException Members


GetBaseException Method

InvalidGroupException Class | InvalidGroupException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetBaseException Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidGroupException Class : GetBaseException Method (InvalidGroupException)

When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.

[Visual Basic]
Public Function GetBaseException() As Exception
[C#]
public Exception GetBaseException();
[C++]
public: Exception* GetBaseException();
[C++/CLI]
public:
Exception^ GetBaseException();

Return Type

The first exception thrown in a chain of exceptions. If the InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

See Also

InvalidGroupException Class | InvalidGroupException Members


GetObjectData Method

InvalidGroupException Class | InvalidGroupException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetObjectData Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidGroupException Class : GetObjectData Method (InvalidGroupException)

When overridden in a derived class, sets the SerializationInfo with information about the exception.

[Visual Basic]
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
[C++/CLI]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

InvalidGroupException Class | InvalidGroupException Members


GetType Method

InvalidGroupException Class | InvalidGroupException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetType Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidGroupException Class : GetType Method (InvalidGroupException)

Gets the runtime type of the current instance.

[Visual Basic]
Public Function GetType() As Type
[C#]
public Type GetType();
[C++]
public: Type* GetType();
[C++/CLI]
public:
Type^ GetType();

Return Type

A Type object that represents the exact runtime type of the current instance.

See Also

InvalidGroupException Class | InvalidGroupException Members


HelpLink Property

InvalidGroupException Class | InvalidGroupException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HelpLink Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidGroupException Class : HelpLink Property (InvalidGroupException)

Gets or sets a link to the help file associated with this exception.

[Visual Basic]
Public Property HelpLink As String
[C#]
public string HelpLink {get; set;}
[C++]
public: __property string* get_HelpLink();
public: __property void set_HelpLink(
   string* value
);
[C++/CLI]
public:
property String^ HelpLink {
   String^ get();
   void set (String^ value);
}

See Also

InvalidGroupException Class | InvalidGroupException Members


InnerException Property

InvalidGroupException Class | InvalidGroupException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InnerException Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidGroupException Class : InnerException Property (InvalidGroupException)

Gets the Exception instance that caused the current exception.

[Visual Basic]
Public ReadOnly Property InnerException As Exception
[C#]
public Exception InnerException {get;}
[C++]
public: __property Exception* get_InnerException();
[C++/CLI]
public:
property Exception^ InnerException {
   Exception^ get();
}

See Also

InvalidGroupException Class | InvalidGroupException Members


Message Property

InvalidGroupException Class | InvalidGroupException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Message Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidGroupException Class : Message Property (InvalidGroupException)

Gets a message that describes the current exception.

[Visual Basic]
Public ReadOnly Property Message As String
[C#]
public string Message {get;}
[C++]
public: __property string* get_Message();
[C++/CLI]
public:
property String^ Message {
   String^ get();
}

See Also

InvalidGroupException Class | InvalidGroupException Members


Source Property

InvalidGroupException Class | InvalidGroupException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Source Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidGroupException Class : Source Property (InvalidGroupException)

Gets or sets the name of the application or the object that causes the error.

[Visual Basic]
Public Property Source As String
[C#]
public string Source {get; set;}
[C++]
public: __property string* get_Source();
public: __property void set_Source(
   string* value
);
[C++/CLI]
public:
property String^ Source {
   String^ get();
   void set (String^ value);
}

See Also

InvalidGroupException Class | InvalidGroupException Members


StackTrace Property

InvalidGroupException Class | InvalidGroupException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StackTrace Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidGroupException Class : StackTrace Property (InvalidGroupException)

Gets a string representation of the frames on the call stack at the time the current exception was thrown.

[Visual Basic]
Public ReadOnly Property StackTrace As String
[C#]
public string StackTrace {get;}
[C++]
public: __property string* get_StackTrace();
[C++/CLI]
public:
property String^ StackTrace {
   String^ get();
}

See Also

InvalidGroupException Class | InvalidGroupException Members


TargetSite Property

InvalidGroupException Class | InvalidGroupException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TargetSite Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidGroupException Class : TargetSite Property (InvalidGroupException)

Gets the method that throws the current exception.

[Visual Basic]
Public ReadOnly Property TargetSite As MethodBase
[C#]
public MethodBase TargetSite {get;}
[C++]
public: __property MethodBase* get_TargetSite();
[C++/CLI]
public:
property MethodBase^ TargetSite {
   MethodBase^ get();
}

See Also

InvalidGroupException Class | InvalidGroupException Members


ToString Method

InvalidGroupException Class | InvalidGroupException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToString Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidGroupException Class : ToString Method (InvalidGroupException)

Creates and returns a string representation of the current exception.

[Visual Basic]
Public Function ToString() As String
[C#]
public string ToString();
[C++]
public: string* ToString();
[C++/CLI]
public:
String^ ToString();

Return Type

A string representation of the current exception.

See Also

InvalidGroupException Class | InvalidGroupException Members


InvalidHatchStyleException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidHatchStyleException Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidHatchStyleException Class

For a list of all members of this type, see InvalidHatchStyleException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InvalidHatchStyleException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


InvalidHatchStyleException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidHatchStyleException Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidHatchStyleException Class

For a list of all members of this type, see InvalidHatchStyleException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

InvalidHatchStyleException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Data Property

InvalidHatchStyleException Class | InvalidHatchStyleException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Data Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidHatchStyleException Class : Data Property (InvalidHatchStyleException)

Gets a collection of key/value pairs that provide additional, user-defined information about the exception.

[Visual Basic]
Public ReadOnly Property Data As IDictionary
[C#]
public IDictionary Data {get;}
[C++]
public: __property IDictionary* get_Data();
[C++/CLI]
public:
property IDictionary^ Data {
   IDictionary^ get();
}

See Also

InvalidHatchStyleException Class | InvalidHatchStyleException Members


GetBaseException Method

InvalidHatchStyleException Class | InvalidHatchStyleException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetBaseException Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidHatchStyleException Class : GetBaseException Method (InvalidHatchStyleException)

When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.

[Visual Basic]
Public Function GetBaseException() As Exception
[C#]
public Exception GetBaseException();
[C++]
public: Exception* GetBaseException();
[C++/CLI]
public:
Exception^ GetBaseException();

Return Type

The first exception thrown in a chain of exceptions. If the InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

See Also

InvalidHatchStyleException Class | InvalidHatchStyleException Members


GetObjectData Method

InvalidHatchStyleException Class | InvalidHatchStyleException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetObjectData Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidHatchStyleException Class : GetObjectData Method (InvalidHatchStyleException)

When overridden in a derived class, sets the SerializationInfo with information about the exception.

[Visual Basic]
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
[C++/CLI]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

InvalidHatchStyleException Class | InvalidHatchStyleException Members


GetType Method

InvalidHatchStyleException Class | InvalidHatchStyleException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetType Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidHatchStyleException Class : GetType Method (InvalidHatchStyleException)

Gets the runtime type of the current instance.

[Visual Basic]
Public Function GetType() As Type
[C#]
public Type GetType();
[C++]
public: Type* GetType();
[C++/CLI]
public:
Type^ GetType();

Return Type

A Type object that represents the exact runtime type of the current instance.

See Also

InvalidHatchStyleException Class | InvalidHatchStyleException Members


HelpLink Property

InvalidHatchStyleException Class | InvalidHatchStyleException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HelpLink Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidHatchStyleException Class : HelpLink Property (InvalidHatchStyleException)

Gets or sets a link to the help file associated with this exception.

[Visual Basic]
Public Property HelpLink As String
[C#]
public string HelpLink {get; set;}
[C++]
public: __property string* get_HelpLink();
public: __property void set_HelpLink(
   string* value
);
[C++/CLI]
public:
property String^ HelpLink {
   String^ get();
   void set (String^ value);
}

See Also

InvalidHatchStyleException Class | InvalidHatchStyleException Members


InnerException Property

InvalidHatchStyleException Class | InvalidHatchStyleException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InnerException Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidHatchStyleException Class : InnerException Property (InvalidHatchStyleException)

Gets the Exception instance that caused the current exception.

[Visual Basic]
Public ReadOnly Property InnerException As Exception
[C#]
public Exception InnerException {get;}
[C++]
public: __property Exception* get_InnerException();
[C++/CLI]
public:
property Exception^ InnerException {
   Exception^ get();
}

See Also

InvalidHatchStyleException Class | InvalidHatchStyleException Members


Message Property

InvalidHatchStyleException Class | InvalidHatchStyleException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Message Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidHatchStyleException Class : Message Property (InvalidHatchStyleException)

Gets a message that describes the current exception.

[Visual Basic]
Public ReadOnly Property Message As String
[C#]
public string Message {get;}
[C++]
public: __property string* get_Message();
[C++/CLI]
public:
property String^ Message {
   String^ get();
}

See Also

InvalidHatchStyleException Class | InvalidHatchStyleException Members


Source Property

InvalidHatchStyleException Class | InvalidHatchStyleException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Source Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidHatchStyleException Class : Source Property (InvalidHatchStyleException)

Gets or sets the name of the application or the object that causes the error.

[Visual Basic]
Public Property Source As String
[C#]
public string Source {get; set;}
[C++]
public: __property string* get_Source();
public: __property void set_Source(
   string* value
);
[C++/CLI]
public:
property String^ Source {
   String^ get();
   void set (String^ value);
}

See Also

InvalidHatchStyleException Class | InvalidHatchStyleException Members


StackTrace Property

InvalidHatchStyleException Class | InvalidHatchStyleException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StackTrace Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidHatchStyleException Class : StackTrace Property (InvalidHatchStyleException)

Gets a string representation of the frames on the call stack at the time the current exception was thrown.

[Visual Basic]
Public ReadOnly Property StackTrace As String
[C#]
public string StackTrace {get;}
[C++]
public: __property string* get_StackTrace();
[C++/CLI]
public:
property String^ StackTrace {
   String^ get();
}

See Also

InvalidHatchStyleException Class | InvalidHatchStyleException Members


TargetSite Property

InvalidHatchStyleException Class | InvalidHatchStyleException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TargetSite Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidHatchStyleException Class : TargetSite Property (InvalidHatchStyleException)

Gets the method that throws the current exception.

[Visual Basic]
Public ReadOnly Property TargetSite As MethodBase
[C#]
public MethodBase TargetSite {get;}
[C++]
public: __property MethodBase* get_TargetSite();
[C++/CLI]
public:
property MethodBase^ TargetSite {
   MethodBase^ get();
}

See Also

InvalidHatchStyleException Class | InvalidHatchStyleException Members


ToString Method

InvalidHatchStyleException Class | InvalidHatchStyleException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToString Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidHatchStyleException Class : ToString Method (InvalidHatchStyleException)

Creates and returns a string representation of the current exception.

[Visual Basic]
Public Function ToString() As String
[C#]
public string ToString();
[C++]
public: string* ToString();
[C++/CLI]
public:
String^ ToString();

Return Type

A string representation of the current exception.

See Also

InvalidHatchStyleException Class | InvalidHatchStyleException Members


InvalidItemException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidItemException Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidItemException Class

For a list of all members of this type, see InvalidItemException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InvalidItemException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


InvalidItemException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidItemException Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidItemException Class

For a list of all members of this type, see InvalidItemException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

InvalidItemException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Data Property

InvalidItemException Class | InvalidItemException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Data Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidItemException Class : Data Property (InvalidItemException)

Gets a collection of key/value pairs that provide additional, user-defined information about the exception.

[Visual Basic]
Public ReadOnly Property Data As IDictionary
[C#]
public IDictionary Data {get;}
[C++]
public: __property IDictionary* get_Data();
[C++/CLI]
public:
property IDictionary^ Data {
   IDictionary^ get();
}

See Also

InvalidItemException Class | InvalidItemException Members


GetBaseException Method

InvalidItemException Class | InvalidItemException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetBaseException Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidItemException Class : GetBaseException Method (InvalidItemException)

When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.

[Visual Basic]
Public Function GetBaseException() As Exception
[C#]
public Exception GetBaseException();
[C++]
public: Exception* GetBaseException();
[C++/CLI]
public:
Exception^ GetBaseException();

Return Type

The first exception thrown in a chain of exceptions. If the InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

See Also

InvalidItemException Class | InvalidItemException Members


GetObjectData Method

InvalidItemException Class | InvalidItemException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetObjectData Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidItemException Class : GetObjectData Method (InvalidItemException)

When overridden in a derived class, sets the SerializationInfo with information about the exception.

[Visual Basic]
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
[C++/CLI]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

InvalidItemException Class | InvalidItemException Members


GetType Method

InvalidItemException Class | InvalidItemException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetType Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidItemException Class : GetType Method (InvalidItemException)

Gets the runtime type of the current instance.

[Visual Basic]
Public Function GetType() As Type
[C#]
public Type GetType();
[C++]
public: Type* GetType();
[C++/CLI]
public:
Type^ GetType();

Return Type

A Type object that represents the exact runtime type of the current instance.

See Also

InvalidItemException Class | InvalidItemException Members


HelpLink Property

InvalidItemException Class | InvalidItemException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HelpLink Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidItemException Class : HelpLink Property (InvalidItemException)

Gets or sets a link to the help file associated with this exception.

[Visual Basic]
Public Property HelpLink As String
[C#]
public string HelpLink {get; set;}
[C++]
public: __property string* get_HelpLink();
public: __property void set_HelpLink(
   string* value
);
[C++/CLI]
public:
property String^ HelpLink {
   String^ get();
   void set (String^ value);
}

See Also

InvalidItemException Class | InvalidItemException Members


InnerException Property

InvalidItemException Class | InvalidItemException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InnerException Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidItemException Class : InnerException Property (InvalidItemException)

Gets the Exception instance that caused the current exception.

[Visual Basic]
Public ReadOnly Property InnerException As Exception
[C#]
public Exception InnerException {get;}
[C++]
public: __property Exception* get_InnerException();
[C++/CLI]
public:
property Exception^ InnerException {
   Exception^ get();
}

See Also

InvalidItemException Class | InvalidItemException Members


Message Property

InvalidItemException Class | InvalidItemException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Message Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidItemException Class : Message Property (InvalidItemException)

Gets a message that describes the current exception.

[Visual Basic]
Public ReadOnly Property Message As String
[C#]
public string Message {get;}
[C++]
public: __property string* get_Message();
[C++/CLI]
public:
property String^ Message {
   String^ get();
}

See Also

InvalidItemException Class | InvalidItemException Members


Source Property

InvalidItemException Class | InvalidItemException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Source Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidItemException Class : Source Property (InvalidItemException)

Gets or sets the name of the application or the object that causes the error.

[Visual Basic]
Public Property Source As String
[C#]
public string Source {get; set;}
[C++]
public: __property string* get_Source();
public: __property void set_Source(
   string* value
);
[C++/CLI]
public:
property String^ Source {
   String^ get();
   void set (String^ value);
}

See Also

InvalidItemException Class | InvalidItemException Members


StackTrace Property

InvalidItemException Class | InvalidItemException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StackTrace Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidItemException Class : StackTrace Property (InvalidItemException)

Gets a string representation of the frames on the call stack at the time the current exception was thrown.

[Visual Basic]
Public ReadOnly Property StackTrace As String
[C#]
public string StackTrace {get;}
[C++]
public: __property string* get_StackTrace();
[C++/CLI]
public:
property String^ StackTrace {
   String^ get();
}

See Also

InvalidItemException Class | InvalidItemException Members


TargetSite Property

InvalidItemException Class | InvalidItemException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TargetSite Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidItemException Class : TargetSite Property (InvalidItemException)

Gets the method that throws the current exception.

[Visual Basic]
Public ReadOnly Property TargetSite As MethodBase
[C#]
public MethodBase TargetSite {get;}
[C++]
public: __property MethodBase* get_TargetSite();
[C++/CLI]
public:
property MethodBase^ TargetSite {
   MethodBase^ get();
}

See Also

InvalidItemException Class | InvalidItemException Members


ToString Method

InvalidItemException Class | InvalidItemException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToString Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidItemException Class : ToString Method (InvalidItemException)

Creates and returns a string representation of the current exception.

[Visual Basic]
Public Function ToString() As String
[C#]
public string ToString();
[C++]
public: string* ToString();
[C++/CLI]
public:
String^ ToString();

Return Type

A string representation of the current exception.

See Also

InvalidItemException Class | InvalidItemException Members


InvalidLayerException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidLayerException Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidLayerException Class

For a list of all members of this type, see InvalidLayerException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InvalidLayerException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


InvalidLayerException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidLayerException Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidLayerException Class

For a list of all members of this type, see InvalidLayerException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

InvalidLayerException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Data Property

InvalidLayerException Class | InvalidLayerException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Data Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidLayerException Class : Data Property (InvalidLayerException)

Gets a collection of key/value pairs that provide additional, user-defined information about the exception.

[Visual Basic]
Public ReadOnly Property Data As IDictionary
[C#]
public IDictionary Data {get;}
[C++]
public: __property IDictionary* get_Data();
[C++/CLI]
public:
property IDictionary^ Data {
   IDictionary^ get();
}

See Also

InvalidLayerException Class | InvalidLayerException Members


GetBaseException Method

InvalidLayerException Class | InvalidLayerException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetBaseException Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidLayerException Class : GetBaseException Method (InvalidLayerException)

When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.

[Visual Basic]
Public Function GetBaseException() As Exception
[C#]
public Exception GetBaseException();
[C++]
public: Exception* GetBaseException();
[C++/CLI]
public:
Exception^ GetBaseException();

Return Type

The first exception thrown in a chain of exceptions. If the InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

See Also

InvalidLayerException Class | InvalidLayerException Members


GetObjectData Method

InvalidLayerException Class | InvalidLayerException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetObjectData Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidLayerException Class : GetObjectData Method (InvalidLayerException)

When overridden in a derived class, sets the SerializationInfo with information about the exception.

[Visual Basic]
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
[C++/CLI]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

InvalidLayerException Class | InvalidLayerException Members


GetType Method

InvalidLayerException Class | InvalidLayerException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetType Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidLayerException Class : GetType Method (InvalidLayerException)

Gets the runtime type of the current instance.

[Visual Basic]
Public Function GetType() As Type
[C#]
public Type GetType();
[C++]
public: Type* GetType();
[C++/CLI]
public:
Type^ GetType();

Return Type

A Type object that represents the exact runtime type of the current instance.

See Also

InvalidLayerException Class | InvalidLayerException Members


HelpLink Property

InvalidLayerException Class | InvalidLayerException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HelpLink Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidLayerException Class : HelpLink Property (InvalidLayerException)

Gets or sets a link to the help file associated with this exception.

[Visual Basic]
Public Property HelpLink As String
[C#]
public string HelpLink {get; set;}
[C++]
public: __property string* get_HelpLink();
public: __property void set_HelpLink(
   string* value
);
[C++/CLI]
public:
property String^ HelpLink {
   String^ get();
   void set (String^ value);
}

See Also

InvalidLayerException Class | InvalidLayerException Members


InnerException Property

InvalidLayerException Class | InvalidLayerException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InnerException Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidLayerException Class : InnerException Property (InvalidLayerException)

Gets the Exception instance that caused the current exception.

[Visual Basic]
Public ReadOnly Property InnerException As Exception
[C#]
public Exception InnerException {get;}
[C++]
public: __property Exception* get_InnerException();
[C++/CLI]
public:
property Exception^ InnerException {
   Exception^ get();
}

See Also

InvalidLayerException Class | InvalidLayerException Members


Message Property

InvalidLayerException Class | InvalidLayerException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Message Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidLayerException Class : Message Property (InvalidLayerException)

Gets a message that describes the current exception.

[Visual Basic]
Public ReadOnly Property Message As String
[C#]
public string Message {get;}
[C++]
public: __property string* get_Message();
[C++/CLI]
public:
property String^ Message {
   String^ get();
}

See Also

InvalidLayerException Class | InvalidLayerException Members


Source Property

InvalidLayerException Class | InvalidLayerException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Source Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidLayerException Class : Source Property (InvalidLayerException)

Gets or sets the name of the application or the object that causes the error.

[Visual Basic]
Public Property Source As String
[C#]
public string Source {get; set;}
[C++]
public: __property string* get_Source();
public: __property void set_Source(
   string* value
);
[C++/CLI]
public:
property String^ Source {
   String^ get();
   void set (String^ value);
}

See Also

InvalidLayerException Class | InvalidLayerException Members


StackTrace Property

InvalidLayerException Class | InvalidLayerException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StackTrace Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidLayerException Class : StackTrace Property (InvalidLayerException)

Gets a string representation of the frames on the call stack at the time the current exception was thrown.

[Visual Basic]
Public ReadOnly Property StackTrace As String
[C#]
public string StackTrace {get;}
[C++]
public: __property string* get_StackTrace();
[C++/CLI]
public:
property String^ StackTrace {
   String^ get();
}

See Also

InvalidLayerException Class | InvalidLayerException Members


TargetSite Property

InvalidLayerException Class | InvalidLayerException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TargetSite Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidLayerException Class : TargetSite Property (InvalidLayerException)

Gets the method that throws the current exception.

[Visual Basic]
Public ReadOnly Property TargetSite As MethodBase
[C#]
public MethodBase TargetSite {get;}
[C++]
public: __property MethodBase* get_TargetSite();
[C++/CLI]
public:
property MethodBase^ TargetSite {
   MethodBase^ get();
}

See Also

InvalidLayerException Class | InvalidLayerException Members


ToString Method

InvalidLayerException Class | InvalidLayerException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToString Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidLayerException Class : ToString Method (InvalidLayerException)

Creates and returns a string representation of the current exception.

[Visual Basic]
Public Function ToString() As String
[C#]
public string ToString();
[C++]
public: string* ToString();
[C++/CLI]
public:
String^ ToString();

Return Type

A string representation of the current exception.

See Also

InvalidLayerException Class | InvalidLayerException Members


InvalidModeException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidModeException Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidModeException Class

For a list of all members of this type, see InvalidModeException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InvalidModeException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


InvalidModeException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidModeException Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidModeException Class

For a list of all members of this type, see InvalidModeException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

InvalidModeException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Data Property

InvalidModeException Class | InvalidModeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Data Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidModeException Class : Data Property (InvalidModeException)

Gets a collection of key/value pairs that provide additional, user-defined information about the exception.

[Visual Basic]
Public ReadOnly Property Data As IDictionary
[C#]
public IDictionary Data {get;}
[C++]
public: __property IDictionary* get_Data();
[C++/CLI]
public:
property IDictionary^ Data {
   IDictionary^ get();
}

See Also

InvalidModeException Class | InvalidModeException Members


GetBaseException Method

InvalidModeException Class | InvalidModeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetBaseException Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidModeException Class : GetBaseException Method (InvalidModeException)

When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.

[Visual Basic]
Public Function GetBaseException() As Exception
[C#]
public Exception GetBaseException();
[C++]
public: Exception* GetBaseException();
[C++/CLI]
public:
Exception^ GetBaseException();

Return Type

The first exception thrown in a chain of exceptions. If the InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

See Also

InvalidModeException Class | InvalidModeException Members


GetObjectData Method

InvalidModeException Class | InvalidModeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetObjectData Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidModeException Class : GetObjectData Method (InvalidModeException)

When overridden in a derived class, sets the SerializationInfo with information about the exception.

[Visual Basic]
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
[C++/CLI]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

InvalidModeException Class | InvalidModeException Members


GetType Method

InvalidModeException Class | InvalidModeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetType Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidModeException Class : GetType Method (InvalidModeException)

Gets the runtime type of the current instance.

[Visual Basic]
Public Function GetType() As Type
[C#]
public Type GetType();
[C++]
public: Type* GetType();
[C++/CLI]
public:
Type^ GetType();

Return Type

A Type object that represents the exact runtime type of the current instance.

See Also

InvalidModeException Class | InvalidModeException Members


HelpLink Property

InvalidModeException Class | InvalidModeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HelpLink Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidModeException Class : HelpLink Property (InvalidModeException)

Gets or sets a link to the help file associated with this exception.

[Visual Basic]
Public Property HelpLink As String
[C#]
public string HelpLink {get; set;}
[C++]
public: __property string* get_HelpLink();
public: __property void set_HelpLink(
   string* value
);
[C++/CLI]
public:
property String^ HelpLink {
   String^ get();
   void set (String^ value);
}

See Also

InvalidModeException Class | InvalidModeException Members


InnerException Property

InvalidModeException Class | InvalidModeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InnerException Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidModeException Class : InnerException Property (InvalidModeException)

Gets the Exception instance that caused the current exception.

[Visual Basic]
Public ReadOnly Property InnerException As Exception
[C#]
public Exception InnerException {get;}
[C++]
public: __property Exception* get_InnerException();
[C++/CLI]
public:
property Exception^ InnerException {
   Exception^ get();
}

See Also

InvalidModeException Class | InvalidModeException Members


Message Property

InvalidModeException Class | InvalidModeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Message Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidModeException Class : Message Property (InvalidModeException)

Gets a message that describes the current exception.

[Visual Basic]
Public ReadOnly Property Message As String
[C#]
public string Message {get;}
[C++]
public: __property string* get_Message();
[C++/CLI]
public:
property String^ Message {
   String^ get();
}

See Also

InvalidModeException Class | InvalidModeException Members


Source Property

InvalidModeException Class | InvalidModeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Source Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidModeException Class : Source Property (InvalidModeException)

Gets or sets the name of the application or the object that causes the error.

[Visual Basic]
Public Property Source As String
[C#]
public string Source {get; set;}
[C++]
public: __property string* get_Source();
public: __property void set_Source(
   string* value
);
[C++/CLI]
public:
property String^ Source {
   String^ get();
   void set (String^ value);
}

See Also

InvalidModeException Class | InvalidModeException Members


StackTrace Property

InvalidModeException Class | InvalidModeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StackTrace Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidModeException Class : StackTrace Property (InvalidModeException)

Gets a string representation of the frames on the call stack at the time the current exception was thrown.

[Visual Basic]
Public ReadOnly Property StackTrace As String
[C#]
public string StackTrace {get;}
[C++]
public: __property string* get_StackTrace();
[C++/CLI]
public:
property String^ StackTrace {
   String^ get();
}

See Also

InvalidModeException Class | InvalidModeException Members


TargetSite Property

InvalidModeException Class | InvalidModeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TargetSite Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidModeException Class : TargetSite Property (InvalidModeException)

Gets the method that throws the current exception.

[Visual Basic]
Public ReadOnly Property TargetSite As MethodBase
[C#]
public MethodBase TargetSite {get;}
[C++]
public: __property MethodBase* get_TargetSite();
[C++/CLI]
public:
property MethodBase^ TargetSite {
   MethodBase^ get();
}

See Also

InvalidModeException Class | InvalidModeException Members


ToString Method

InvalidModeException Class | InvalidModeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToString Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidModeException Class : ToString Method (InvalidModeException)

Creates and returns a string representation of the current exception.

[Visual Basic]
Public Function ToString() As String
[C#]
public string ToString();
[C++]
public: string* ToString();
[C++/CLI]
public:
String^ ToString();

Return Type

A string representation of the current exception.

See Also

InvalidModeException Class | InvalidModeException Members


InvalidParameterException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidParameterException Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidParameterException Class

For a list of all members of this type, see InvalidParameterException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InvalidParameterException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


InvalidParameterException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidParameterException Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidParameterException Class

For a list of all members of this type, see InvalidParameterException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

InvalidParameterException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Data Property

InvalidParameterException Class | InvalidParameterException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Data Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidParameterException Class : Data Property (InvalidParameterException)

Gets a collection of key/value pairs that provide additional, user-defined information about the exception.

[Visual Basic]
Public ReadOnly Property Data As IDictionary
[C#]
public IDictionary Data {get;}
[C++]
public: __property IDictionary* get_Data();
[C++/CLI]
public:
property IDictionary^ Data {
   IDictionary^ get();
}

See Also

InvalidParameterException Class | InvalidParameterException Members


GetBaseException Method

InvalidParameterException Class | InvalidParameterException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetBaseException Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidParameterException Class : GetBaseException Method (InvalidParameterException)

When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.

[Visual Basic]
Public Function GetBaseException() As Exception
[C#]
public Exception GetBaseException();
[C++]
public: Exception* GetBaseException();
[C++/CLI]
public:
Exception^ GetBaseException();

Return Type

The first exception thrown in a chain of exceptions. If the InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

See Also

InvalidParameterException Class | InvalidParameterException Members


GetObjectData Method

InvalidParameterException Class | InvalidParameterException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetObjectData Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidParameterException Class : GetObjectData Method (InvalidParameterException)

When overridden in a derived class, sets the SerializationInfo with information about the exception.

[Visual Basic]
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
[C++/CLI]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

InvalidParameterException Class | InvalidParameterException Members


GetType Method

InvalidParameterException Class | InvalidParameterException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetType Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidParameterException Class : GetType Method (InvalidParameterException)

Gets the runtime type of the current instance.

[Visual Basic]
Public Function GetType() As Type
[C#]
public Type GetType();
[C++]
public: Type* GetType();
[C++/CLI]
public:
Type^ GetType();

Return Type

A Type object that represents the exact runtime type of the current instance.

See Also

InvalidParameterException Class | InvalidParameterException Members


HelpLink Property

InvalidParameterException Class | InvalidParameterException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HelpLink Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidParameterException Class : HelpLink Property (InvalidParameterException)

Gets or sets a link to the help file associated with this exception.

[Visual Basic]
Public Property HelpLink As String
[C#]
public string HelpLink {get; set;}
[C++]
public: __property string* get_HelpLink();
public: __property void set_HelpLink(
   string* value
);
[C++/CLI]
public:
property String^ HelpLink {
   String^ get();
   void set (String^ value);
}

See Also

InvalidParameterException Class | InvalidParameterException Members


InnerException Property

InvalidParameterException Class | InvalidParameterException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InnerException Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidParameterException Class : InnerException Property (InvalidParameterException)

Gets the Exception instance that caused the current exception.

[Visual Basic]
Public ReadOnly Property InnerException As Exception
[C#]
public Exception InnerException {get;}
[C++]
public: __property Exception* get_InnerException();
[C++/CLI]
public:
property Exception^ InnerException {
   Exception^ get();
}

See Also

InvalidParameterException Class | InvalidParameterException Members


Message Property

InvalidParameterException Class | InvalidParameterException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Message Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidParameterException Class : Message Property (InvalidParameterException)

Gets a message that describes the current exception.

[Visual Basic]
Public ReadOnly Property Message As String
[C#]
public string Message {get;}
[C++]
public: __property string* get_Message();
[C++/CLI]
public:
property String^ Message {
   String^ get();
}

See Also

InvalidParameterException Class | InvalidParameterException Members


Source Property

InvalidParameterException Class | InvalidParameterException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Source Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidParameterException Class : Source Property (InvalidParameterException)

Gets or sets the name of the application or the object that causes the error.

[Visual Basic]
Public Property Source As String
[C#]
public string Source {get; set;}
[C++]
public: __property string* get_Source();
public: __property void set_Source(
   string* value
);
[C++/CLI]
public:
property String^ Source {
   String^ get();
   void set (String^ value);
}

See Also

InvalidParameterException Class | InvalidParameterException Members


StackTrace Property

InvalidParameterException Class | InvalidParameterException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StackTrace Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidParameterException Class : StackTrace Property (InvalidParameterException)

Gets a string representation of the frames on the call stack at the time the current exception was thrown.

[Visual Basic]
Public ReadOnly Property StackTrace As String
[C#]
public string StackTrace {get;}
[C++]
public: __property string* get_StackTrace();
[C++/CLI]
public:
property String^ StackTrace {
   String^ get();
}

See Also

InvalidParameterException Class | InvalidParameterException Members


TargetSite Property

InvalidParameterException Class | InvalidParameterException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TargetSite Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidParameterException Class : TargetSite Property (InvalidParameterException)

Gets the method that throws the current exception.

[Visual Basic]
Public ReadOnly Property TargetSite As MethodBase
[C#]
public MethodBase TargetSite {get;}
[C++]
public: __property MethodBase* get_TargetSite();
[C++/CLI]
public:
property MethodBase^ TargetSite {
   MethodBase^ get();
}

See Also

InvalidParameterException Class | InvalidParameterException Members


ToString Method

InvalidParameterException Class | InvalidParameterException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToString Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidParameterException Class : ToString Method (InvalidParameterException)

Creates and returns a string representation of the current exception.

[Visual Basic]
Public Function ToString() As String
[C#]
public string ToString();
[C++]
public: string* ToString();
[C++/CLI]
public:
String^ ToString();

Return Type

A string representation of the current exception.

See Also

InvalidParameterException Class | InvalidParameterException Members


InvalidPasswordException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidPasswordException Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidPasswordException Class

For a list of all members of this type, see InvalidPasswordException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InvalidPasswordException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


InvalidPasswordException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidPasswordException Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidPasswordException Class

For a list of all members of this type, see InvalidPasswordException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

InvalidPasswordException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Data Property

InvalidPasswordException Class | InvalidPasswordException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Data Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidPasswordException Class : Data Property (InvalidPasswordException)

Gets a collection of key/value pairs that provide additional, user-defined information about the exception.

[Visual Basic]
Public ReadOnly Property Data As IDictionary
[C#]
public IDictionary Data {get;}
[C++]
public: __property IDictionary* get_Data();
[C++/CLI]
public:
property IDictionary^ Data {
   IDictionary^ get();
}

See Also

InvalidPasswordException Class | InvalidPasswordException Members


GetBaseException Method

InvalidPasswordException Class | InvalidPasswordException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetBaseException Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidPasswordException Class : GetBaseException Method (InvalidPasswordException)

When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.

[Visual Basic]
Public Function GetBaseException() As Exception
[C#]
public Exception GetBaseException();
[C++]
public: Exception* GetBaseException();
[C++/CLI]
public:
Exception^ GetBaseException();

Return Type

The first exception thrown in a chain of exceptions. If the InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

See Also

InvalidPasswordException Class | InvalidPasswordException Members


GetObjectData Method

InvalidPasswordException Class | InvalidPasswordException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetObjectData Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidPasswordException Class : GetObjectData Method (InvalidPasswordException)

When overridden in a derived class, sets the SerializationInfo with information about the exception.

[Visual Basic]
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
[C++/CLI]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

InvalidPasswordException Class | InvalidPasswordException Members


GetType Method

InvalidPasswordException Class | InvalidPasswordException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetType Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidPasswordException Class : GetType Method (InvalidPasswordException)

Gets the runtime type of the current instance.

[Visual Basic]
Public Function GetType() As Type
[C#]
public Type GetType();
[C++]
public: Type* GetType();
[C++/CLI]
public:
Type^ GetType();

Return Type

A Type object that represents the exact runtime type of the current instance.

See Also

InvalidPasswordException Class | InvalidPasswordException Members


HelpLink Property

InvalidPasswordException Class | InvalidPasswordException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HelpLink Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidPasswordException Class : HelpLink Property (InvalidPasswordException)

Gets or sets a link to the help file associated with this exception.

[Visual Basic]
Public Property HelpLink As String
[C#]
public string HelpLink {get; set;}
[C++]
public: __property string* get_HelpLink();
public: __property void set_HelpLink(
   string* value
);
[C++/CLI]
public:
property String^ HelpLink {
   String^ get();
   void set (String^ value);
}

See Also

InvalidPasswordException Class | InvalidPasswordException Members


InnerException Property

InvalidPasswordException Class | InvalidPasswordException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InnerException Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidPasswordException Class : InnerException Property (InvalidPasswordException)

Gets the Exception instance that caused the current exception.

[Visual Basic]
Public ReadOnly Property InnerException As Exception
[C#]
public Exception InnerException {get;}
[C++]
public: __property Exception* get_InnerException();
[C++/CLI]
public:
property Exception^ InnerException {
   Exception^ get();
}

See Also

InvalidPasswordException Class | InvalidPasswordException Members


Message Property

InvalidPasswordException Class | InvalidPasswordException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Message Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidPasswordException Class : Message Property (InvalidPasswordException)

Gets a message that describes the current exception.

[Visual Basic]
Public ReadOnly Property Message As String
[C#]
public string Message {get;}
[C++]
public: __property string* get_Message();
[C++/CLI]
public:
property String^ Message {
   String^ get();
}

See Also

InvalidPasswordException Class | InvalidPasswordException Members


Source Property

InvalidPasswordException Class | InvalidPasswordException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Source Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidPasswordException Class : Source Property (InvalidPasswordException)

Gets or sets the name of the application or the object that causes the error.

[Visual Basic]
Public Property Source As String
[C#]
public string Source {get; set;}
[C++]
public: __property string* get_Source();
public: __property void set_Source(
   string* value
);
[C++/CLI]
public:
property String^ Source {
   String^ get();
   void set (String^ value);
}

See Also

InvalidPasswordException Class | InvalidPasswordException Members


StackTrace Property

InvalidPasswordException Class | InvalidPasswordException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StackTrace Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidPasswordException Class : StackTrace Property (InvalidPasswordException)

Gets a string representation of the frames on the call stack at the time the current exception was thrown.

[Visual Basic]
Public ReadOnly Property StackTrace As String
[C#]
public string StackTrace {get;}
[C++]
public: __property string* get_StackTrace();
[C++/CLI]
public:
property String^ StackTrace {
   String^ get();
}

See Also

InvalidPasswordException Class | InvalidPasswordException Members


TargetSite Property

InvalidPasswordException Class | InvalidPasswordException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TargetSite Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidPasswordException Class : TargetSite Property (InvalidPasswordException)

Gets the method that throws the current exception.

[Visual Basic]
Public ReadOnly Property TargetSite As MethodBase
[C#]
public MethodBase TargetSite {get;}
[C++]
public: __property MethodBase* get_TargetSite();
[C++/CLI]
public:
property MethodBase^ TargetSite {
   MethodBase^ get();
}

See Also

InvalidPasswordException Class | InvalidPasswordException Members


ToString Method

InvalidPasswordException Class | InvalidPasswordException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToString Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidPasswordException Class : ToString Method (InvalidPasswordException)

Creates and returns a string representation of the current exception.

[Visual Basic]
Public Function ToString() As String
[C#]
public string ToString();
[C++]
public: string* ToString();
[C++/CLI]
public:
String^ ToString();

Return Type

A string representation of the current exception.

See Also

InvalidPasswordException Class | InvalidPasswordException Members


InvalidPointException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidPointException Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidPointException Class

For a list of all members of this type, see InvalidPointException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InvalidPointException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


InvalidPointException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidPointException Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidPointException Class

For a list of all members of this type, see InvalidPointException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

InvalidPointException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Data Property

InvalidPointException Class | InvalidPointException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Data Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidPointException Class : Data Property (InvalidPointException)

Gets a collection of key/value pairs that provide additional, user-defined information about the exception.

[Visual Basic]
Public ReadOnly Property Data As IDictionary
[C#]
public IDictionary Data {get;}
[C++]
public: __property IDictionary* get_Data();
[C++/CLI]
public:
property IDictionary^ Data {
   IDictionary^ get();
}

See Also

InvalidPointException Class | InvalidPointException Members


GetBaseException Method

InvalidPointException Class | InvalidPointException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetBaseException Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidPointException Class : GetBaseException Method (InvalidPointException)

When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.

[Visual Basic]
Public Function GetBaseException() As Exception
[C#]
public Exception GetBaseException();
[C++]
public: Exception* GetBaseException();
[C++/CLI]
public:
Exception^ GetBaseException();

Return Type

The first exception thrown in a chain of exceptions. If the InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

See Also

InvalidPointException Class | InvalidPointException Members


GetObjectData Method

InvalidPointException Class | InvalidPointException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetObjectData Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidPointException Class : GetObjectData Method (InvalidPointException)

When overridden in a derived class, sets the SerializationInfo with information about the exception.

[Visual Basic]
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
[C++/CLI]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

InvalidPointException Class | InvalidPointException Members


GetType Method

InvalidPointException Class | InvalidPointException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetType Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidPointException Class : GetType Method (InvalidPointException)

Gets the runtime type of the current instance.

[Visual Basic]
Public Function GetType() As Type
[C#]
public Type GetType();
[C++]
public: Type* GetType();
[C++/CLI]
public:
Type^ GetType();

Return Type

A Type object that represents the exact runtime type of the current instance.

See Also

InvalidPointException Class | InvalidPointException Members


HelpLink Property

InvalidPointException Class | InvalidPointException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HelpLink Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidPointException Class : HelpLink Property (InvalidPointException)

Gets or sets a link to the help file associated with this exception.

[Visual Basic]
Public Property HelpLink As String
[C#]
public string HelpLink {get; set;}
[C++]
public: __property string* get_HelpLink();
public: __property void set_HelpLink(
   string* value
);
[C++/CLI]
public:
property String^ HelpLink {
   String^ get();
   void set (String^ value);
}

See Also

InvalidPointException Class | InvalidPointException Members


InnerException Property

InvalidPointException Class | InvalidPointException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InnerException Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidPointException Class : InnerException Property (InvalidPointException)

Gets the Exception instance that caused the current exception.

[Visual Basic]
Public ReadOnly Property InnerException As Exception
[C#]
public Exception InnerException {get;}
[C++]
public: __property Exception* get_InnerException();
[C++/CLI]
public:
property Exception^ InnerException {
   Exception^ get();
}

See Also

InvalidPointException Class | InvalidPointException Members


Message Property

InvalidPointException Class | InvalidPointException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Message Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidPointException Class : Message Property (InvalidPointException)

Gets a message that describes the current exception.

[Visual Basic]
Public ReadOnly Property Message As String
[C#]
public string Message {get;}
[C++]
public: __property string* get_Message();
[C++/CLI]
public:
property String^ Message {
   String^ get();
}

See Also

InvalidPointException Class | InvalidPointException Members


Source Property

InvalidPointException Class | InvalidPointException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Source Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidPointException Class : Source Property (InvalidPointException)

Gets or sets the name of the application or the object that causes the error.

[Visual Basic]
Public Property Source As String
[C#]
public string Source {get; set;}
[C++]
public: __property string* get_Source();
public: __property void set_Source(
   string* value
);
[C++/CLI]
public:
property String^ Source {
   String^ get();
   void set (String^ value);
}

See Also

InvalidPointException Class | InvalidPointException Members


StackTrace Property

InvalidPointException Class | InvalidPointException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StackTrace Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidPointException Class : StackTrace Property (InvalidPointException)

Gets a string representation of the frames on the call stack at the time the current exception was thrown.

[Visual Basic]
Public ReadOnly Property StackTrace As String
[C#]
public string StackTrace {get;}
[C++]
public: __property string* get_StackTrace();
[C++/CLI]
public:
property String^ StackTrace {
   String^ get();
}

See Also

InvalidPointException Class | InvalidPointException Members


TargetSite Property

InvalidPointException Class | InvalidPointException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TargetSite Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidPointException Class : TargetSite Property (InvalidPointException)

Gets the method that throws the current exception.

[Visual Basic]
Public ReadOnly Property TargetSite As MethodBase
[C#]
public MethodBase TargetSite {get;}
[C++]
public: __property MethodBase* get_TargetSite();
[C++/CLI]
public:
property MethodBase^ TargetSite {
   MethodBase^ get();
}

See Also

InvalidPointException Class | InvalidPointException Members


ToString Method

InvalidPointException Class | InvalidPointException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToString Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidPointException Class : ToString Method (InvalidPointException)

Creates and returns a string representation of the current exception.

[Visual Basic]
Public Function ToString() As String
[C#]
public string ToString();
[C++]
public: string* ToString();
[C++/CLI]
public:
String^ ToString();

Return Type

A string representation of the current exception.

See Also

InvalidPointException Class | InvalidPointException Members


InvalidTiffAnnTypeException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidTiffAnnTypeException Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidTiffAnnTypeException Class

For a list of all members of this type, see InvalidTiffAnnTypeException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InvalidTiffAnnTypeException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


InvalidTiffAnnTypeException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidTiffAnnTypeException Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidTiffAnnTypeException Class

For a list of all members of this type, see InvalidTiffAnnTypeException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

InvalidTiffAnnTypeException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Data Property

InvalidTiffAnnTypeException Class | InvalidTiffAnnTypeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Data Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidTiffAnnTypeException Class : Data Property (InvalidTiffAnnTypeException)

Gets a collection of key/value pairs that provide additional, user-defined information about the exception.

[Visual Basic]
Public ReadOnly Property Data As IDictionary
[C#]
public IDictionary Data {get;}
[C++]
public: __property IDictionary* get_Data();
[C++/CLI]
public:
property IDictionary^ Data {
   IDictionary^ get();
}

See Also

InvalidTiffAnnTypeException Class | InvalidTiffAnnTypeException Members


GetBaseException Method

InvalidTiffAnnTypeException Class | InvalidTiffAnnTypeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetBaseException Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidTiffAnnTypeException Class : GetBaseException Method (InvalidTiffAnnTypeException)

When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.

[Visual Basic]
Public Function GetBaseException() As Exception
[C#]
public Exception GetBaseException();
[C++]
public: Exception* GetBaseException();
[C++/CLI]
public:
Exception^ GetBaseException();

Return Type

The first exception thrown in a chain of exceptions. If the InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

See Also

InvalidTiffAnnTypeException Class | InvalidTiffAnnTypeException Members


GetObjectData Method

InvalidTiffAnnTypeException Class | InvalidTiffAnnTypeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetObjectData Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidTiffAnnTypeException Class : GetObjectData Method (InvalidTiffAnnTypeException)

When overridden in a derived class, sets the SerializationInfo with information about the exception.

[Visual Basic]
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
[C++/CLI]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

InvalidTiffAnnTypeException Class | InvalidTiffAnnTypeException Members


GetType Method

InvalidTiffAnnTypeException Class | InvalidTiffAnnTypeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetType Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidTiffAnnTypeException Class : GetType Method (InvalidTiffAnnTypeException)

Gets the runtime type of the current instance.

[Visual Basic]
Public Function GetType() As Type
[C#]
public Type GetType();
[C++]
public: Type* GetType();
[C++/CLI]
public:
Type^ GetType();

Return Type

A Type object that represents the exact runtime type of the current instance.

See Also

InvalidTiffAnnTypeException Class | InvalidTiffAnnTypeException Members


HelpLink Property

InvalidTiffAnnTypeException Class | InvalidTiffAnnTypeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HelpLink Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidTiffAnnTypeException Class : HelpLink Property (InvalidTiffAnnTypeException)

Gets or sets a link to the help file associated with this exception.

[Visual Basic]
Public Property HelpLink As String
[C#]
public string HelpLink {get; set;}
[C++]
public: __property string* get_HelpLink();
public: __property void set_HelpLink(
   string* value
);
[C++/CLI]
public:
property String^ HelpLink {
   String^ get();
   void set (String^ value);
}

See Also

InvalidTiffAnnTypeException Class | InvalidTiffAnnTypeException Members


InnerException Property

InvalidTiffAnnTypeException Class | InvalidTiffAnnTypeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InnerException Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidTiffAnnTypeException Class : InnerException Property (InvalidTiffAnnTypeException)

Gets the Exception instance that caused the current exception.

[Visual Basic]
Public ReadOnly Property InnerException As Exception
[C#]
public Exception InnerException {get;}
[C++]
public: __property Exception* get_InnerException();
[C++/CLI]
public:
property Exception^ InnerException {
   Exception^ get();
}

See Also

InvalidTiffAnnTypeException Class | InvalidTiffAnnTypeException Members


Message Property

InvalidTiffAnnTypeException Class | InvalidTiffAnnTypeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Message Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidTiffAnnTypeException Class : Message Property (InvalidTiffAnnTypeException)

Gets a message that describes the current exception.

[Visual Basic]
Public ReadOnly Property Message As String
[C#]
public string Message {get;}
[C++]
public: __property string* get_Message();
[C++/CLI]
public:
property String^ Message {
   String^ get();
}

See Also

InvalidTiffAnnTypeException Class | InvalidTiffAnnTypeException Members


Source Property

InvalidTiffAnnTypeException Class | InvalidTiffAnnTypeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Source Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidTiffAnnTypeException Class : Source Property (InvalidTiffAnnTypeException)

Gets or sets the name of the application or the object that causes the error.

[Visual Basic]
Public Property Source As String
[C#]
public string Source {get; set;}
[C++]
public: __property string* get_Source();
public: __property void set_Source(
   string* value
);
[C++/CLI]
public:
property String^ Source {
   String^ get();
   void set (String^ value);
}

See Also

InvalidTiffAnnTypeException Class | InvalidTiffAnnTypeException Members


StackTrace Property

InvalidTiffAnnTypeException Class | InvalidTiffAnnTypeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StackTrace Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidTiffAnnTypeException Class : StackTrace Property (InvalidTiffAnnTypeException)

Gets a string representation of the frames on the call stack at the time the current exception was thrown.

[Visual Basic]
Public ReadOnly Property StackTrace As String
[C#]
public string StackTrace {get;}
[C++]
public: __property string* get_StackTrace();
[C++/CLI]
public:
property String^ StackTrace {
   String^ get();
}

See Also

InvalidTiffAnnTypeException Class | InvalidTiffAnnTypeException Members


TargetSite Property

InvalidTiffAnnTypeException Class | InvalidTiffAnnTypeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TargetSite Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidTiffAnnTypeException Class : TargetSite Property (InvalidTiffAnnTypeException)

Gets the method that throws the current exception.

[Visual Basic]
Public ReadOnly Property TargetSite As MethodBase
[C#]
public MethodBase TargetSite {get;}
[C++]
public: __property MethodBase* get_TargetSite();
[C++/CLI]
public:
property MethodBase^ TargetSite {
   MethodBase^ get();
}

See Also

InvalidTiffAnnTypeException Class | InvalidTiffAnnTypeException Members


ToString Method

InvalidTiffAnnTypeException Class | InvalidTiffAnnTypeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToString Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidTiffAnnTypeException Class : ToString Method (InvalidTiffAnnTypeException)

Creates and returns a string representation of the current exception.

[Visual Basic]
Public Function ToString() As String
[C#]
public string ToString();
[C++]
public: string* ToString();
[C++/CLI]
public:
String^ ToString();

Return Type

A string representation of the current exception.

See Also

InvalidTiffAnnTypeException Class | InvalidTiffAnnTypeException Members


InvalidToolException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidToolException Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidToolException Class

For a list of all members of this type, see InvalidToolException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InvalidToolException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


InvalidToolException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidToolException Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidToolException Class

For a list of all members of this type, see InvalidToolException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

InvalidToolException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Data Property

InvalidToolException Class | InvalidToolException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Data Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidToolException Class : Data Property (InvalidToolException)

Gets a collection of key/value pairs that provide additional, user-defined information about the exception.

[Visual Basic]
Public ReadOnly Property Data As IDictionary
[C#]
public IDictionary Data {get;}
[C++]
public: __property IDictionary* get_Data();
[C++/CLI]
public:
property IDictionary^ Data {
   IDictionary^ get();
}

See Also

InvalidToolException Class | InvalidToolException Members


GetBaseException Method

InvalidToolException Class | InvalidToolException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetBaseException Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidToolException Class : GetBaseException Method (InvalidToolException)

When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.

[Visual Basic]
Public Function GetBaseException() As Exception
[C#]
public Exception GetBaseException();
[C++]
public: Exception* GetBaseException();
[C++/CLI]
public:
Exception^ GetBaseException();

Return Type

The first exception thrown in a chain of exceptions. If the InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

See Also

InvalidToolException Class | InvalidToolException Members


GetObjectData Method

InvalidToolException Class | InvalidToolException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetObjectData Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidToolException Class : GetObjectData Method (InvalidToolException)

When overridden in a derived class, sets the SerializationInfo with information about the exception.

[Visual Basic]
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
[C++/CLI]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

InvalidToolException Class | InvalidToolException Members


GetType Method

InvalidToolException Class | InvalidToolException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetType Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidToolException Class : GetType Method (InvalidToolException)

Gets the runtime type of the current instance.

[Visual Basic]
Public Function GetType() As Type
[C#]
public Type GetType();
[C++]
public: Type* GetType();
[C++/CLI]
public:
Type^ GetType();

Return Type

A Type object that represents the exact runtime type of the current instance.

See Also

InvalidToolException Class | InvalidToolException Members


HelpLink Property

InvalidToolException Class | InvalidToolException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HelpLink Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidToolException Class : HelpLink Property (InvalidToolException)

Gets or sets a link to the help file associated with this exception.

[Visual Basic]
Public Property HelpLink As String
[C#]
public string HelpLink {get; set;}
[C++]
public: __property string* get_HelpLink();
public: __property void set_HelpLink(
   string* value
);
[C++/CLI]
public:
property String^ HelpLink {
   String^ get();
   void set (String^ value);
}

See Also

InvalidToolException Class | InvalidToolException Members


InnerException Property

InvalidToolException Class | InvalidToolException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InnerException Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidToolException Class : InnerException Property (InvalidToolException)

Gets the Exception instance that caused the current exception.

[Visual Basic]
Public ReadOnly Property InnerException As Exception
[C#]
public Exception InnerException {get;}
[C++]
public: __property Exception* get_InnerException();
[C++/CLI]
public:
property Exception^ InnerException {
   Exception^ get();
}

See Also

InvalidToolException Class | InvalidToolException Members


Message Property

InvalidToolException Class | InvalidToolException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Message Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidToolException Class : Message Property (InvalidToolException)

Gets a message that describes the current exception.

[Visual Basic]
Public ReadOnly Property Message As String
[C#]
public string Message {get;}
[C++]
public: __property string* get_Message();
[C++/CLI]
public:
property String^ Message {
   String^ get();
}

See Also

InvalidToolException Class | InvalidToolException Members


Source Property

InvalidToolException Class | InvalidToolException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Source Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidToolException Class : Source Property (InvalidToolException)

Gets or sets the name of the application or the object that causes the error.

[Visual Basic]
Public Property Source As String
[C#]
public string Source {get; set;}
[C++]
public: __property string* get_Source();
public: __property void set_Source(
   string* value
);
[C++/CLI]
public:
property String^ Source {
   String^ get();
   void set (String^ value);
}

See Also

InvalidToolException Class | InvalidToolException Members


StackTrace Property

InvalidToolException Class | InvalidToolException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StackTrace Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidToolException Class : StackTrace Property (InvalidToolException)

Gets a string representation of the frames on the call stack at the time the current exception was thrown.

[Visual Basic]
Public ReadOnly Property StackTrace As String
[C#]
public string StackTrace {get;}
[C++]
public: __property string* get_StackTrace();
[C++/CLI]
public:
property String^ StackTrace {
   String^ get();
}

See Also

InvalidToolException Class | InvalidToolException Members


TargetSite Property

InvalidToolException Class | InvalidToolException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TargetSite Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidToolException Class : TargetSite Property (InvalidToolException)

Gets the method that throws the current exception.

[Visual Basic]
Public ReadOnly Property TargetSite As MethodBase
[C#]
public MethodBase TargetSite {get;}
[C++]
public: __property MethodBase* get_TargetSite();
[C++/CLI]
public:
property MethodBase^ TargetSite {
   MethodBase^ get();
}

See Also

InvalidToolException Class | InvalidToolException Members


ToString Method

InvalidToolException Class | InvalidToolException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToString Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidToolException Class : ToString Method (InvalidToolException)

Creates and returns a string representation of the current exception.

[Visual Basic]
Public Function ToString() As String
[C#]
public string ToString();
[C++]
public: string* ToString();
[C++/CLI]
public:
String^ ToString();

Return Type

A string representation of the current exception.

See Also

InvalidToolException Class | InvalidToolException Members


InvalidVariantException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidVariantException Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidVariantException Class

For a list of all members of this type, see InvalidVariantException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InvalidVariantException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


InvalidVariantException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidVariantException Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidVariantException Class

For a list of all members of this type, see InvalidVariantException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

InvalidVariantException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Data Property

InvalidVariantException Class | InvalidVariantException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Data Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidVariantException Class : Data Property (InvalidVariantException)

Gets a collection of key/value pairs that provide additional, user-defined information about the exception.

[Visual Basic]
Public ReadOnly Property Data As IDictionary
[C#]
public IDictionary Data {get;}
[C++]
public: __property IDictionary* get_Data();
[C++/CLI]
public:
property IDictionary^ Data {
   IDictionary^ get();
}

See Also

InvalidVariantException Class | InvalidVariantException Members


GetBaseException Method

InvalidVariantException Class | InvalidVariantException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetBaseException Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidVariantException Class : GetBaseException Method (InvalidVariantException)

When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.

[Visual Basic]
Public Function GetBaseException() As Exception
[C#]
public Exception GetBaseException();
[C++]
public: Exception* GetBaseException();
[C++/CLI]
public:
Exception^ GetBaseException();

Return Type

The first exception thrown in a chain of exceptions. If the InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

See Also

InvalidVariantException Class | InvalidVariantException Members


GetObjectData Method

InvalidVariantException Class | InvalidVariantException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetObjectData Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidVariantException Class : GetObjectData Method (InvalidVariantException)

When overridden in a derived class, sets the SerializationInfo with information about the exception.

[Visual Basic]
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
[C++/CLI]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

InvalidVariantException Class | InvalidVariantException Members


GetType Method

InvalidVariantException Class | InvalidVariantException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetType Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidVariantException Class : GetType Method (InvalidVariantException)

Gets the runtime type of the current instance.

[Visual Basic]
Public Function GetType() As Type
[C#]
public Type GetType();
[C++]
public: Type* GetType();
[C++/CLI]
public:
Type^ GetType();

Return Type

A Type object that represents the exact runtime type of the current instance.

See Also

InvalidVariantException Class | InvalidVariantException Members


HelpLink Property

InvalidVariantException Class | InvalidVariantException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HelpLink Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidVariantException Class : HelpLink Property (InvalidVariantException)

Gets or sets a link to the help file associated with this exception.

[Visual Basic]
Public Property HelpLink As String
[C#]
public string HelpLink {get; set;}
[C++]
public: __property string* get_HelpLink();
public: __property void set_HelpLink(
   string* value
);
[C++/CLI]
public:
property String^ HelpLink {
   String^ get();
   void set (String^ value);
}

See Also

InvalidVariantException Class | InvalidVariantException Members


InnerException Property

InvalidVariantException Class | InvalidVariantException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InnerException Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidVariantException Class : InnerException Property (InvalidVariantException)

Gets the Exception instance that caused the current exception.

[Visual Basic]
Public ReadOnly Property InnerException As Exception
[C#]
public Exception InnerException {get;}
[C++]
public: __property Exception* get_InnerException();
[C++/CLI]
public:
property Exception^ InnerException {
   Exception^ get();
}

See Also

InvalidVariantException Class | InvalidVariantException Members


Message Property

InvalidVariantException Class | InvalidVariantException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Message Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidVariantException Class : Message Property (InvalidVariantException)

Gets a message that describes the current exception.

[Visual Basic]
Public ReadOnly Property Message As String
[C#]
public string Message {get;}
[C++]
public: __property string* get_Message();
[C++/CLI]
public:
property String^ Message {
   String^ get();
}

See Also

InvalidVariantException Class | InvalidVariantException Members


Source Property

InvalidVariantException Class | InvalidVariantException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Source Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidVariantException Class : Source Property (InvalidVariantException)

Gets or sets the name of the application or the object that causes the error.

[Visual Basic]
Public Property Source As String
[C#]
public string Source {get; set;}
[C++]
public: __property string* get_Source();
public: __property void set_Source(
   string* value
);
[C++/CLI]
public:
property String^ Source {
   String^ get();
   void set (String^ value);
}

See Also

InvalidVariantException Class | InvalidVariantException Members


StackTrace Property

InvalidVariantException Class | InvalidVariantException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StackTrace Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidVariantException Class : StackTrace Property (InvalidVariantException)

Gets a string representation of the frames on the call stack at the time the current exception was thrown.

[Visual Basic]
Public ReadOnly Property StackTrace As String
[C#]
public string StackTrace {get;}
[C++]
public: __property string* get_StackTrace();
[C++/CLI]
public:
property String^ StackTrace {
   String^ get();
}

See Also

InvalidVariantException Class | InvalidVariantException Members


TargetSite Property

InvalidVariantException Class | InvalidVariantException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TargetSite Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidVariantException Class : TargetSite Property (InvalidVariantException)

Gets the method that throws the current exception.

[Visual Basic]
Public ReadOnly Property TargetSite As MethodBase
[C#]
public MethodBase TargetSite {get;}
[C++]
public: __property MethodBase* get_TargetSite();
[C++/CLI]
public:
property MethodBase^ TargetSite {
   MethodBase^ get();
}

See Also

InvalidVariantException Class | InvalidVariantException Members


ToString Method

InvalidVariantException Class | InvalidVariantException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToString Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidVariantException Class : ToString Method (InvalidVariantException)

Creates and returns a string representation of the current exception.

[Visual Basic]
Public Function ToString() As String
[C#]
public string ToString();
[C++]
public: string* ToString();
[C++/CLI]
public:
String^ ToString();

Return Type

A string representation of the current exception.

See Also

InvalidVariantException Class | InvalidVariantException Members


InvalidWangTypeException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidWangTypeException Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidWangTypeException Class

For a list of all members of this type, see InvalidWangTypeException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InvalidWangTypeException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


InvalidWangTypeException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidWangTypeException Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidWangTypeException Class

For a list of all members of this type, see InvalidWangTypeException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

InvalidWangTypeException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Data Property

InvalidWangTypeException Class | InvalidWangTypeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Data Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidWangTypeException Class : Data Property (InvalidWangTypeException)

Gets a collection of key/value pairs that provide additional, user-defined information about the exception.

[Visual Basic]
Public ReadOnly Property Data As IDictionary
[C#]
public IDictionary Data {get;}
[C++]
public: __property IDictionary* get_Data();
[C++/CLI]
public:
property IDictionary^ Data {
   IDictionary^ get();
}

See Also

InvalidWangTypeException Class | InvalidWangTypeException Members


GetBaseException Method

InvalidWangTypeException Class | InvalidWangTypeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetBaseException Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidWangTypeException Class : GetBaseException Method (InvalidWangTypeException)

When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.

[Visual Basic]
Public Function GetBaseException() As Exception
[C#]
public Exception GetBaseException();
[C++]
public: Exception* GetBaseException();
[C++/CLI]
public:
Exception^ GetBaseException();

Return Type

The first exception thrown in a chain of exceptions. If the InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

See Also

InvalidWangTypeException Class | InvalidWangTypeException Members


GetObjectData Method

InvalidWangTypeException Class | InvalidWangTypeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetObjectData Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidWangTypeException Class : GetObjectData Method (InvalidWangTypeException)

When overridden in a derived class, sets the SerializationInfo with information about the exception.

[Visual Basic]
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
[C++/CLI]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

InvalidWangTypeException Class | InvalidWangTypeException Members


GetType Method

InvalidWangTypeException Class | InvalidWangTypeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetType Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidWangTypeException Class : GetType Method (InvalidWangTypeException)

Gets the runtime type of the current instance.

[Visual Basic]
Public Function GetType() As Type
[C#]
public Type GetType();
[C++]
public: Type* GetType();
[C++/CLI]
public:
Type^ GetType();

Return Type

A Type object that represents the exact runtime type of the current instance.

See Also

InvalidWangTypeException Class | InvalidWangTypeException Members


HelpLink Property

InvalidWangTypeException Class | InvalidWangTypeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HelpLink Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidWangTypeException Class : HelpLink Property (InvalidWangTypeException)

Gets or sets a link to the help file associated with this exception.

[Visual Basic]
Public Property HelpLink As String
[C#]
public string HelpLink {get; set;}
[C++]
public: __property string* get_HelpLink();
public: __property void set_HelpLink(
   string* value
);
[C++/CLI]
public:
property String^ HelpLink {
   String^ get();
   void set (String^ value);
}

See Also

InvalidWangTypeException Class | InvalidWangTypeException Members


InnerException Property

InvalidWangTypeException Class | InvalidWangTypeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InnerException Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidWangTypeException Class : InnerException Property (InvalidWangTypeException)

Gets the Exception instance that caused the current exception.

[Visual Basic]
Public ReadOnly Property InnerException As Exception
[C#]
public Exception InnerException {get;}
[C++]
public: __property Exception* get_InnerException();
[C++/CLI]
public:
property Exception^ InnerException {
   Exception^ get();
}

See Also

InvalidWangTypeException Class | InvalidWangTypeException Members


Message Property

InvalidWangTypeException Class | InvalidWangTypeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Message Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidWangTypeException Class : Message Property (InvalidWangTypeException)

Gets a message that describes the current exception.

[Visual Basic]
Public ReadOnly Property Message As String
[C#]
public string Message {get;}
[C++]
public: __property string* get_Message();
[C++/CLI]
public:
property String^ Message {
   String^ get();
}

See Also

InvalidWangTypeException Class | InvalidWangTypeException Members


Source Property

InvalidWangTypeException Class | InvalidWangTypeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Source Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidWangTypeException Class : Source Property (InvalidWangTypeException)

Gets or sets the name of the application or the object that causes the error.

[Visual Basic]
Public Property Source As String
[C#]
public string Source {get; set;}
[C++]
public: __property string* get_Source();
public: __property void set_Source(
   string* value
);
[C++/CLI]
public:
property String^ Source {
   String^ get();
   void set (String^ value);
}

See Also

InvalidWangTypeException Class | InvalidWangTypeException Members


StackTrace Property

InvalidWangTypeException Class | InvalidWangTypeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StackTrace Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidWangTypeException Class : StackTrace Property (InvalidWangTypeException)

Gets a string representation of the frames on the call stack at the time the current exception was thrown.

[Visual Basic]
Public ReadOnly Property StackTrace As String
[C#]
public string StackTrace {get;}
[C++]
public: __property string* get_StackTrace();
[C++/CLI]
public:
property String^ StackTrace {
   String^ get();
}

See Also

InvalidWangTypeException Class | InvalidWangTypeException Members


TargetSite Property

InvalidWangTypeException Class | InvalidWangTypeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TargetSite Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidWangTypeException Class : TargetSite Property (InvalidWangTypeException)

Gets the method that throws the current exception.

[Visual Basic]
Public ReadOnly Property TargetSite As MethodBase
[C#]
public MethodBase TargetSite {get;}
[C++]
public: __property MethodBase* get_TargetSite();
[C++/CLI]
public:
property MethodBase^ TargetSite {
   MethodBase^ get();
}

See Also

InvalidWangTypeException Class | InvalidWangTypeException Members


ToString Method

InvalidWangTypeException Class | InvalidWangTypeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToString Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidWangTypeException Class : ToString Method (InvalidWangTypeException)

Creates and returns a string representation of the current exception.

[Visual Basic]
Public Function ToString() As String
[C#]
public string ToString();
[C++]
public: string* ToString();
[C++/CLI]
public:
String^ ToString();

Return Type

A string representation of the current exception.

See Also

InvalidWangTypeException Class | InvalidWangTypeException Members


InvalidWindowHandleException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidWindowHandleException Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidWindowHandleException Class

For a list of all members of this type, see InvalidWindowHandleException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InvalidWindowHandleException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


InvalidWindowHandleException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InvalidWindowHandleException Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : InvalidWindowHandleException Class

For a list of all members of this type, see InvalidWindowHandleException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

InvalidWindowHandleException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Data Property

InvalidWindowHandleException Class | InvalidWindowHandleException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Data Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidWindowHandleException Class : Data Property (InvalidWindowHandleException)

Gets a collection of key/value pairs that provide additional, user-defined information about the exception.

[Visual Basic]
Public ReadOnly Property Data As IDictionary
[C#]
public IDictionary Data {get;}
[C++]
public: __property IDictionary* get_Data();
[C++/CLI]
public:
property IDictionary^ Data {
   IDictionary^ get();
}

See Also

InvalidWindowHandleException Class | InvalidWindowHandleException Members


GetBaseException Method

InvalidWindowHandleException Class | InvalidWindowHandleException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetBaseException Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidWindowHandleException Class : GetBaseException Method (InvalidWindowHandleException)

When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.

[Visual Basic]
Public Function GetBaseException() As Exception
[C#]
public Exception GetBaseException();
[C++]
public: Exception* GetBaseException();
[C++/CLI]
public:
Exception^ GetBaseException();

Return Type

The first exception thrown in a chain of exceptions. If the InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

See Also

InvalidWindowHandleException Class | InvalidWindowHandleException Members


GetObjectData Method

InvalidWindowHandleException Class | InvalidWindowHandleException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetObjectData Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidWindowHandleException Class : GetObjectData Method (InvalidWindowHandleException)

When overridden in a derived class, sets the SerializationInfo with information about the exception.

[Visual Basic]
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
[C++/CLI]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

InvalidWindowHandleException Class | InvalidWindowHandleException Members


GetType Method

InvalidWindowHandleException Class | InvalidWindowHandleException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetType Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidWindowHandleException Class : GetType Method (InvalidWindowHandleException)

Gets the runtime type of the current instance.

[Visual Basic]
Public Function GetType() As Type
[C#]
public Type GetType();
[C++]
public: Type* GetType();
[C++/CLI]
public:
Type^ GetType();

Return Type

A Type object that represents the exact runtime type of the current instance.

See Also

InvalidWindowHandleException Class | InvalidWindowHandleException Members


HelpLink Property

InvalidWindowHandleException Class | InvalidWindowHandleException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HelpLink Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidWindowHandleException Class : HelpLink Property (InvalidWindowHandleException)

Gets or sets a link to the help file associated with this exception.

[Visual Basic]
Public Property HelpLink As String
[C#]
public string HelpLink {get; set;}
[C++]
public: __property string* get_HelpLink();
public: __property void set_HelpLink(
   string* value
);
[C++/CLI]
public:
property String^ HelpLink {
   String^ get();
   void set (String^ value);
}

See Also

InvalidWindowHandleException Class | InvalidWindowHandleException Members


InnerException Property

InvalidWindowHandleException Class | InvalidWindowHandleException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InnerException Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidWindowHandleException Class : InnerException Property (InvalidWindowHandleException)

Gets the Exception instance that caused the current exception.

[Visual Basic]
Public ReadOnly Property InnerException As Exception
[C#]
public Exception InnerException {get;}
[C++]
public: __property Exception* get_InnerException();
[C++/CLI]
public:
property Exception^ InnerException {
   Exception^ get();
}

See Also

InvalidWindowHandleException Class | InvalidWindowHandleException Members


Message Property

InvalidWindowHandleException Class | InvalidWindowHandleException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Message Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidWindowHandleException Class : Message Property (InvalidWindowHandleException)

Gets a message that describes the current exception.

[Visual Basic]
Public ReadOnly Property Message As String
[C#]
public string Message {get;}
[C++]
public: __property string* get_Message();
[C++/CLI]
public:
property String^ Message {
   String^ get();
}

See Also

InvalidWindowHandleException Class | InvalidWindowHandleException Members


Source Property

InvalidWindowHandleException Class | InvalidWindowHandleException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Source Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidWindowHandleException Class : Source Property (InvalidWindowHandleException)

Gets or sets the name of the application or the object that causes the error.

[Visual Basic]
Public Property Source As String
[C#]
public string Source {get; set;}
[C++]
public: __property string* get_Source();
public: __property void set_Source(
   string* value
);
[C++/CLI]
public:
property String^ Source {
   String^ get();
   void set (String^ value);
}

See Also

InvalidWindowHandleException Class | InvalidWindowHandleException Members


StackTrace Property

InvalidWindowHandleException Class | InvalidWindowHandleException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StackTrace Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidWindowHandleException Class : StackTrace Property (InvalidWindowHandleException)

Gets a string representation of the frames on the call stack at the time the current exception was thrown.

[Visual Basic]
Public ReadOnly Property StackTrace As String
[C#]
public string StackTrace {get;}
[C++]
public: __property string* get_StackTrace();
[C++/CLI]
public:
property String^ StackTrace {
   String^ get();
}

See Also

InvalidWindowHandleException Class | InvalidWindowHandleException Members


TargetSite Property

InvalidWindowHandleException Class | InvalidWindowHandleException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TargetSite Property

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidWindowHandleException Class : TargetSite Property (InvalidWindowHandleException)

Gets the method that throws the current exception.

[Visual Basic]
Public ReadOnly Property TargetSite As MethodBase
[C#]
public MethodBase TargetSite {get;}
[C++]
public: __property MethodBase* get_TargetSite();
[C++/CLI]
public:
property MethodBase^ TargetSite {
   MethodBase^ get();
}

See Also

InvalidWindowHandleException Class | InvalidWindowHandleException Members


ToString Method

InvalidWindowHandleException Class | InvalidWindowHandleException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToString Method

PegasusImaging.WinForms.NotateXpress9 Namespace > InvalidWindowHandleException Class : ToString Method (InvalidWindowHandleException)

Creates and returns a string representation of the current exception.

[Visual Basic]
Public Function ToString() As String
[C#]
public string ToString();
[C++]
public: string* ToString();
[C++/CLI]
public:
String^ ToString();

Return Type

A string representation of the current exception.

See Also

InvalidWindowHandleException Class | InvalidWindowHandleException Members


ItemNotFoundException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ItemNotFoundException Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : ItemNotFoundException Class

For a list of all members of this type, see ItemNotFoundException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

ItemNotFoundException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


ItemNotFoundException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ItemNotFoundException Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : ItemNotFoundException Class

For a list of all members of this type, see ItemNotFoundException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

ItemNotFoundException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Data Property

ItemNotFoundException Class | ItemNotFoundException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Data Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ItemNotFoundException Class : Data Property (ItemNotFoundException)

Gets a collection of key/value pairs that provide additional, user-defined information about the exception.

[Visual Basic]
Public ReadOnly Property Data As IDictionary
[C#]
public IDictionary Data {get;}
[C++]
public: __property IDictionary* get_Data();
[C++/CLI]
public:
property IDictionary^ Data {
   IDictionary^ get();
}

See Also

ItemNotFoundException Class | ItemNotFoundException Members


GetBaseException Method

ItemNotFoundException Class | ItemNotFoundException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetBaseException Method

PegasusImaging.WinForms.NotateXpress9 Namespace > ItemNotFoundException Class : GetBaseException Method (ItemNotFoundException)

When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.

[Visual Basic]
Public Function GetBaseException() As Exception
[C#]
public Exception GetBaseException();
[C++]
public: Exception* GetBaseException();
[C++/CLI]
public:
Exception^ GetBaseException();

Return Type

The first exception thrown in a chain of exceptions. If the InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

See Also

ItemNotFoundException Class | ItemNotFoundException Members


GetObjectData Method

ItemNotFoundException Class | ItemNotFoundException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetObjectData Method

PegasusImaging.WinForms.NotateXpress9 Namespace > ItemNotFoundException Class : GetObjectData Method (ItemNotFoundException)

When overridden in a derived class, sets the SerializationInfo with information about the exception.

[Visual Basic]
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
[C++/CLI]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

ItemNotFoundException Class | ItemNotFoundException Members


GetType Method

ItemNotFoundException Class | ItemNotFoundException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetType Method

PegasusImaging.WinForms.NotateXpress9 Namespace > ItemNotFoundException Class : GetType Method (ItemNotFoundException)

Gets the runtime type of the current instance.

[Visual Basic]
Public Function GetType() As Type
[C#]
public Type GetType();
[C++]
public: Type* GetType();
[C++/CLI]
public:
Type^ GetType();

Return Type

A Type object that represents the exact runtime type of the current instance.

See Also

ItemNotFoundException Class | ItemNotFoundException Members


HelpLink Property

ItemNotFoundException Class | ItemNotFoundException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HelpLink Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ItemNotFoundException Class : HelpLink Property (ItemNotFoundException)

Gets or sets a link to the help file associated with this exception.

[Visual Basic]
Public Property HelpLink As String
[C#]
public string HelpLink {get; set;}
[C++]
public: __property string* get_HelpLink();
public: __property void set_HelpLink(
   string* value
);
[C++/CLI]
public:
property String^ HelpLink {
   String^ get();
   void set (String^ value);
}

See Also

ItemNotFoundException Class | ItemNotFoundException Members


InnerException Property

ItemNotFoundException Class | ItemNotFoundException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InnerException Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ItemNotFoundException Class : InnerException Property (ItemNotFoundException)

Gets the Exception instance that caused the current exception.

[Visual Basic]
Public ReadOnly Property InnerException As Exception
[C#]
public Exception InnerException {get;}
[C++]
public: __property Exception* get_InnerException();
[C++/CLI]
public:
property Exception^ InnerException {
   Exception^ get();
}

See Also

ItemNotFoundException Class | ItemNotFoundException Members


Message Property

ItemNotFoundException Class | ItemNotFoundException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Message Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ItemNotFoundException Class : Message Property (ItemNotFoundException)

Gets a message that describes the current exception.

[Visual Basic]
Public ReadOnly Property Message As String
[C#]
public string Message {get;}
[C++]
public: __property string* get_Message();
[C++/CLI]
public:
property String^ Message {
   String^ get();
}

See Also

ItemNotFoundException Class | ItemNotFoundException Members


Source Property

ItemNotFoundException Class | ItemNotFoundException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Source Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ItemNotFoundException Class : Source Property (ItemNotFoundException)

Gets or sets the name of the application or the object that causes the error.

[Visual Basic]
Public Property Source As String
[C#]
public string Source {get; set;}
[C++]
public: __property string* get_Source();
public: __property void set_Source(
   string* value
);
[C++/CLI]
public:
property String^ Source {
   String^ get();
   void set (String^ value);
}

See Also

ItemNotFoundException Class | ItemNotFoundException Members


StackTrace Property

ItemNotFoundException Class | ItemNotFoundException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StackTrace Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ItemNotFoundException Class : StackTrace Property (ItemNotFoundException)

Gets a string representation of the frames on the call stack at the time the current exception was thrown.

[Visual Basic]
Public ReadOnly Property StackTrace As String
[C#]
public string StackTrace {get;}
[C++]
public: __property string* get_StackTrace();
[C++/CLI]
public:
property String^ StackTrace {
   String^ get();
}

See Also

ItemNotFoundException Class | ItemNotFoundException Members


TargetSite Property

ItemNotFoundException Class | ItemNotFoundException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TargetSite Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ItemNotFoundException Class : TargetSite Property (ItemNotFoundException)

Gets the method that throws the current exception.

[Visual Basic]
Public ReadOnly Property TargetSite As MethodBase
[C#]
public MethodBase TargetSite {get;}
[C++]
public: __property MethodBase* get_TargetSite();
[C++/CLI]
public:
property MethodBase^ TargetSite {
   MethodBase^ get();
}

See Also

ItemNotFoundException Class | ItemNotFoundException Members


ToString Method

ItemNotFoundException Class | ItemNotFoundException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToString Method

PegasusImaging.WinForms.NotateXpress9 Namespace > ItemNotFoundException Class : ToString Method (ItemNotFoundException)

Creates and returns a string representation of the current exception.

[Visual Basic]
Public Function ToString() As String
[C#]
public string ToString();
[C++]
public: string* ToString();
[C++/CLI]
public:
String^ ToString();

Return Type

A string representation of the current exception.

See Also

ItemNotFoundException Class | ItemNotFoundException Members


Layer Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Layer Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : Layer Class (PegasusImaging.WinForms.NotateXpress9)

For a list of all members of this type, see Layer members.

Public Methods

Public Method Copy | Copies the layer to the clipboard.
Public Method Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public Method Select | Make the selected layer the current active layer.
Public Method UserDataAdd | Adds a new key value pair to the layer.
Public Method UserDataDelete | Removes the given key value pair on the layer.
Public Method UserDataFind | User data can be added to each layer in a key value pair. This will return the value of an existing key.
Public Method UserDataFindFirst | User data can be added to each layer in a key value pair. This will find the first key value pair.
Public Method UserDataFindNext | User data can be added to each layer in a key value pair. This will next key value pair, in the list.

See Also

Layer Class | PegasusImaging.WinForms.NotateXpress9 Namespace


LayerCollection Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

LayerCollection Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : LayerCollection Class

For a list of all members of this type, see LayerCollection members.

Public Methods

Public Method Add | Adds the given Layer to the layer collection.
Public Method Brand | Brands or permanently draws the currently visible annotations directly into the client image according to the given bits per pixel.
Public Method Clear | Clears the entire collection as well as calls the clear method of the base class.
Public Method Contains | Searches for and returns a value which determines if the collection contains the given Layer in the layer collection.
Public Method CopyTo | Copies the entire collection to an array, starting at the given index of the specified target array.
Public Method Dispose | Releases all resources used by this LayerCollection object.
Public Method FromByteArray | Loads annotations from the given byte array based on instructions passed by the load options.
Public Method FromFile | Allows loading of a specific page contained within the given file.
Public Method FromMemoryStream | Loads an image from the given stream, based on the provided LoadOptions.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) | Returns an enumerator that iterates through the CollectionBase instance.
Public Method IndexOf | Searches for the specified layer and returns the zero-based index of the first occurrence within the layer collection.
Public Method Insert | Inserts the given Layer at the specified index.
Public Method Paste | Pastes the layer that is on the clipboard.
Public Method Remove | Removes the given Layer from the layer collection.
Public Method RemoveAt | Removes the matching layer to the given index within the layer collection.
Public Method SaveToByteArray | Saves the given annotations to a byte array.
Public Method SaveToFile | Saves the given annotations to the given file name.
Public Method SaveToMemoryStream | Saves the given annotations to a memory stream.
Public Method Selected | Gets the currently selected layer within the layer collection.
Public Method SetLoadOptions | Sets the options to use when loading annotations.
Public Method SetSaveOptions | Sets the options to use when saving annotations.

See Also

LayerCollection Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Capacity Property

LayerCollection Class | LayerCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Capacity Property

PegasusImaging.WinForms.NotateXpress9 Namespace > LayerCollection Class : Capacity Property (LayerCollection)

Gets or sets the number of elements that the CollectionBase can contain.

[Visual Basic]
<ComVisibleAttribute(False)>
Public Property Capacity As Integer
[C#]
[ComVisibleAttribute(false)]
public int Capacity {get; set;}
[C++]
[ComVisibleAttribute(false)]
public: __property int get_Capacity();
public: __property void set_Capacity(
   int value
);
[C++/CLI]
[ComVisibleAttribute(false)]
public:
property int Capacity {
   int get();
   void set (int value);
}

Exceptions

Exception | Description
ArgumentOutOfRangeException | Capacity is set to a value that is less than Count.

See Also

LayerCollection Class | LayerCollection Members


Count Property

LayerCollection Class | LayerCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Count Property

PegasusImaging.WinForms.NotateXpress9 Namespace > LayerCollection Class : Count Property (LayerCollection)

Gets the number of elements contained in the CollectionBase instance.

[Visual Basic]
Public ReadOnly Property Count As Integer
[C#]
public int Count {get;}
[C++]
public: __property int get_Count();
[C++/CLI]
public:
property int Count {
   int get();
}

See Also

LayerCollection Class | LayerCollection Members


GetEnumerator Method

LayerCollection Class | LayerCollection Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetEnumerator Method

PegasusImaging.WinForms.NotateXpress9 Namespace > LayerCollection Class : GetEnumerator Method (LayerCollection)

Returns an enumerator that iterates through the CollectionBase instance.

[Visual Basic]
Public Function GetEnumerator() As IEnumerator
[C#]
public IEnumerator GetEnumerator();
[C++]
public: IEnumerator* GetEnumerator();
[C++/CLI]
public:
IEnumerator^ GetEnumerator();

Return Type

An IEnumerator for the CollectionBase instance.

See Also

LayerCollection Class | LayerCollection Members


LineTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

LineTool Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : LineTool Class

For a list of all members of this type, see LineTool members.

Public Methods

Public Method GetPoints | This method returns an array of Points used to draw the line.
Public Method NudgeDown (Inherited from Element) | Moves the specified annotation object one level down, towards the back, in the painting order of the specified layer.
Public Method NudgeUp (Inherited from Element) | Moves the specified annotation object one level up, towards the front, in the painting order of the specified layer.
Public Method SetPoints | This method sets an array of Points used to draw the line.
Public Method UserDataAdd (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataDelete (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFind (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFindFirst (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFindNext (Inherited from Element) | User data can be added to each element in a key value pair.

See Also

LineTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace


NoCurrentLayerException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NoCurrentLayerException Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : NoCurrentLayerException Class

For a list of all members of this type, see NoCurrentLayerException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

NoCurrentLayerException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


NoCurrentLayerException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NoCurrentLayerException Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : NoCurrentLayerException Class

For a list of all members of this type, see NoCurrentLayerException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

NoCurrentLayerException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Data Property

NoCurrentLayerException Class | NoCurrentLayerException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Data Property

PegasusImaging.WinForms.NotateXpress9 Namespace > NoCurrentLayerException Class : Data Property (NoCurrentLayerException)

Gets a collection of key/value pairs that provide additional, user-defined information about the exception.

[Visual Basic]
Public ReadOnly Property Data As IDictionary
[C#]
public IDictionary Data {get;}
[C++]
public: __property IDictionary* get_Data();
[C++/CLI]
public:
property IDictionary^ Data {
   IDictionary^ get();
}

See Also

NoCurrentLayerException Class | NoCurrentLayerException Members


GetBaseException Method

NoCurrentLayerException Class | NoCurrentLayerException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetBaseException Method

PegasusImaging.WinForms.NotateXpress9 Namespace > NoCurrentLayerException Class : GetBaseException Method (NoCurrentLayerException)

When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.

[Visual Basic]
Public Function GetBaseException() As Exception
[C#]
public Exception GetBaseException();
[C++]
public: Exception* GetBaseException();
[C++/CLI]
public:
Exception^ GetBaseException();

Return Type

The first exception thrown in a chain of exceptions. If the InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

See Also

NoCurrentLayerException Class | NoCurrentLayerException Members


GetObjectData Method

NoCurrentLayerException Class | NoCurrentLayerException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetObjectData Method

PegasusImaging.WinForms.NotateXpress9 Namespace > NoCurrentLayerException Class : GetObjectData Method (NoCurrentLayerException)

When overridden in a derived class, sets the SerializationInfo with information about the exception.

[Visual Basic]
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
[C++/CLI]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

NoCurrentLayerException Class | NoCurrentLayerException Members


GetType Method

NoCurrentLayerException Class | NoCurrentLayerException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetType Method

PegasusImaging.WinForms.NotateXpress9 Namespace > NoCurrentLayerException Class : GetType Method (NoCurrentLayerException)

Gets the runtime type of the current instance.

[Visual Basic]
Public Function GetType() As Type
[C#]
public Type GetType();
[C++]
public: Type* GetType();
[C++/CLI]
public:
Type^ GetType();

Return Type

A Type object that represents the exact runtime type of the current instance.

See Also

NoCurrentLayerException Class | NoCurrentLayerException Members


HelpLink Property

NoCurrentLayerException Class | NoCurrentLayerException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HelpLink Property

PegasusImaging.WinForms.NotateXpress9 Namespace > NoCurrentLayerException Class : HelpLink Property (NoCurrentLayerException)

Gets or sets a link to the help file associated with this exception.

[Visual Basic]
Public Property HelpLink As String
[C#]
public string HelpLink {get; set;}
[C++]
public: __property string* get_HelpLink();
public: __property void set_HelpLink(
   string* value
);
[C++/CLI]
public:
property String^ HelpLink {
   String^ get();
   void set (String^ value);
}

See Also

NoCurrentLayerException Class | NoCurrentLayerException Members


InnerException Property

NoCurrentLayerException Class | NoCurrentLayerException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InnerException Property

PegasusImaging.WinForms.NotateXpress9 Namespace > NoCurrentLayerException Class : InnerException Property (NoCurrentLayerException)

Gets the Exception instance that caused the current exception.

[Visual Basic]
Public ReadOnly Property InnerException As Exception
[C#]
public Exception InnerException {get;}
[C++]
public: __property Exception* get_InnerException();
[C++/CLI]
public:
property Exception^ InnerException {
   Exception^ get();
}

See Also

NoCurrentLayerException Class | NoCurrentLayerException Members


Message Property

NoCurrentLayerException Class | NoCurrentLayerException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Message Property

PegasusImaging.WinForms.NotateXpress9 Namespace > NoCurrentLayerException Class : Message Property (NoCurrentLayerException)

Gets a message that describes the current exception.

[Visual Basic]
Public ReadOnly Property Message As String
[C#]
public string Message {get;}
[C++]
public: __property string* get_Message();
[C++/CLI]
public:
property String^ Message {
   String^ get();
}

See Also

NoCurrentLayerException Class | NoCurrentLayerException Members


Source Property

NoCurrentLayerException Class | NoCurrentLayerException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Source Property

PegasusImaging.WinForms.NotateXpress9 Namespace > NoCurrentLayerException Class : Source Property (NoCurrentLayerException)

Gets or sets the name of the application or the object that causes the error.

[Visual Basic]
Public Property Source As String
[C#]
public string Source {get; set;}
[C++]
public: __property string* get_Source();
public: __property void set_Source(
   string* value
);
[C++/CLI]
public:
property String^ Source {
   String^ get();
   void set (String^ value);
}

See Also

NoCurrentLayerException Class | NoCurrentLayerException Members


StackTrace Property

NoCurrentLayerException Class | NoCurrentLayerException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StackTrace Property

PegasusImaging.WinForms.NotateXpress9 Namespace > NoCurrentLayerException Class : StackTrace Property (NoCurrentLayerException)

Gets a string representation of the frames on the call stack at the time the current exception was thrown.

[Visual Basic]
Public ReadOnly Property StackTrace As String
[C#]
public string StackTrace {get;}
[C++]
public: __property string* get_StackTrace();
[C++/CLI]
public:
property String^ StackTrace {
   String^ get();
}

See Also

NoCurrentLayerException Class | NoCurrentLayerException Members


TargetSite Property

NoCurrentLayerException Class | NoCurrentLayerException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TargetSite Property

PegasusImaging.WinForms.NotateXpress9 Namespace > NoCurrentLayerException Class : TargetSite Property (NoCurrentLayerException)

Gets the method that throws the current exception.

[Visual Basic]
Public ReadOnly Property TargetSite As MethodBase
[C#]
public MethodBase TargetSite {get;}
[C++]
public: __property MethodBase* get_TargetSite();
[C++/CLI]
public:
property MethodBase^ TargetSite {
   MethodBase^ get();
}

See Also

NoCurrentLayerException Class | NoCurrentLayerException Members


ToString Method

NoCurrentLayerException Class | NoCurrentLayerException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToString Method

PegasusImaging.WinForms.NotateXpress9 Namespace > NoCurrentLayerException Class : ToString Method (NoCurrentLayerException)

Creates and returns a string representation of the current exception.

[Visual Basic]
Public Function ToString() As String
[C#]
public string ToString();
[C++]
public: string* ToString();
[C++/CLI]
public:
String^ ToString();

Return Type

A string representation of the current exception.

See Also

NoCurrentLayerException Class | NoCurrentLayerException Members


NoSelectionException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NoSelectionException Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : NoSelectionException Class

For a list of all members of this type, see NoSelectionException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

NoSelectionException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


NoSelectionException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NoSelectionException Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : NoSelectionException Class

For a list of all members of this type, see NoSelectionException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

NoSelectionException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Data Property

NoSelectionException Class | NoSelectionException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Data Property

PegasusImaging.WinForms.NotateXpress9 Namespace > NoSelectionException Class : Data Property (NoSelectionException)

Gets a collection of key/value pairs that provide additional, user-defined information about the exception.

[Visual Basic]
Public ReadOnly Property Data As IDictionary
[C#]
public IDictionary Data {get;}
[C++]
public: __property IDictionary* get_Data();
[C++/CLI]
public:
property IDictionary^ Data {
   IDictionary^ get();
}

See Also

NoSelectionException Class | NoSelectionException Members


GetBaseException Method

NoSelectionException Class | NoSelectionException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetBaseException Method

PegasusImaging.WinForms.NotateXpress9 Namespace > NoSelectionException Class : GetBaseException Method (NoSelectionException)

When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.

[Visual Basic]
Public Function GetBaseException() As Exception
[C#]
public Exception GetBaseException();
[C++]
public: Exception* GetBaseException();
[C++/CLI]
public:
Exception^ GetBaseException();

Return Type

The first exception thrown in a chain of exceptions. If the InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

See Also

NoSelectionException Class | NoSelectionException Members


GetObjectData Method

NoSelectionException Class | NoSelectionException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetObjectData Method

PegasusImaging.WinForms.NotateXpress9 Namespace > NoSelectionException Class : GetObjectData Method (NoSelectionException)

When overridden in a derived class, sets the SerializationInfo with information about the exception.

[Visual Basic]
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
[C++/CLI]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

NoSelectionException Class | NoSelectionException Members


GetType Method

NoSelectionException Class | NoSelectionException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetType Method

PegasusImaging.WinForms.NotateXpress9 Namespace > NoSelectionException Class : GetType Method (NoSelectionException)

Gets the runtime type of the current instance.

[Visual Basic]
Public Function GetType() As Type
[C#]
public Type GetType();
[C++]
public: Type* GetType();
[C++/CLI]
public:
Type^ GetType();

Return Type

A Type object that represents the exact runtime type of the current instance.

See Also

NoSelectionException Class | NoSelectionException Members


HelpLink Property

NoSelectionException Class | NoSelectionException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HelpLink Property

PegasusImaging.WinForms.NotateXpress9 Namespace > NoSelectionException Class : HelpLink Property (NoSelectionException)

Gets or sets a link to the help file associated with this exception.

[Visual Basic]
Public Property HelpLink As String
[C#]
public string HelpLink {get; set;}
[C++]
public: __property string* get_HelpLink();
public: __property void set_HelpLink(
   string* value
);
[C++/CLI]
public:
property String^ HelpLink {
   String^ get();
   void set (String^ value);
}

See Also

NoSelectionException Class | NoSelectionException Members


InnerException Property

NoSelectionException Class | NoSelectionException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InnerException Property

PegasusImaging.WinForms.NotateXpress9 Namespace > NoSelectionException Class : InnerException Property (NoSelectionException)

Gets the Exception instance that caused the current exception.

[Visual Basic]
Public ReadOnly Property InnerException As Exception
[C#]
public Exception InnerException {get;}
[C++]
public: __property Exception* get_InnerException();
[C++/CLI]
public:
property Exception^ InnerException {
   Exception^ get();
}

See Also

NoSelectionException Class | NoSelectionException Members


Message Property

NoSelectionException Class | NoSelectionException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Message Property

PegasusImaging.WinForms.NotateXpress9 Namespace > NoSelectionException Class : Message Property (NoSelectionException)

Gets a message that describes the current exception.

[Visual Basic]
Public ReadOnly Property Message As String
[C#]
public string Message {get;}
[C++]
public: __property string* get_Message();
[C++/CLI]
public:
property String^ Message {
   String^ get();
}

See Also

NoSelectionException Class | NoSelectionException Members


Source Property

NoSelectionException Class | NoSelectionException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Source Property

PegasusImaging.WinForms.NotateXpress9 Namespace > NoSelectionException Class : Source Property (NoSelectionException)

Gets or sets the name of the application or the object that causes the error.

[Visual Basic]
Public Property Source As String
[C#]
public string Source {get; set;}
[C++]
public: __property string* get_Source();
public: __property void set_Source(
   string* value
);
[C++/CLI]
public:
property String^ Source {
   String^ get();
   void set (String^ value);
}

See Also

NoSelectionException Class | NoSelectionException Members


StackTrace Property

NoSelectionException Class | NoSelectionException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StackTrace Property

PegasusImaging.WinForms.NotateXpress9 Namespace > NoSelectionException Class : StackTrace Property (NoSelectionException)

Gets a string representation of the frames on the call stack at the time the current exception was thrown.

[Visual Basic]
Public ReadOnly Property StackTrace As String
[C#]
public string StackTrace {get;}
[C++]
public: __property string* get_StackTrace();
[C++/CLI]
public:
property String^ StackTrace {
   String^ get();
}

See Also

NoSelectionException Class | NoSelectionException Members


TargetSite Property

NoSelectionException Class | NoSelectionException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TargetSite Property

PegasusImaging.WinForms.NotateXpress9 Namespace > NoSelectionException Class : TargetSite Property (NoSelectionException)

Gets the method that throws the current exception.

[Visual Basic]
Public ReadOnly Property TargetSite As MethodBase
[C#]
public MethodBase TargetSite {get;}
[C++]
public: __property MethodBase* get_TargetSite();
[C++/CLI]
public:
property MethodBase^ TargetSite {
   MethodBase^ get();
}

See Also

NoSelectionException Class | NoSelectionException Members


ToString Method

NoSelectionException Class | NoSelectionException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToString Method

PegasusImaging.WinForms.NotateXpress9 Namespace > NoSelectionException Class : ToString Method (NoSelectionException)

Creates and returns a string representation of the current exception.

[Visual Basic]
Public Function ToString() As String
[C#]
public string ToString();
[C++]
public: string* ToString();
[C++/CLI]
public:
String^ ToString();

Return Type

A string representation of the current exception.

See Also

NoSelectionException Class | NoSelectionException Members


NotateXpress Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NotateXpress Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : NotateXpress Class

For a list of all members of this type, see NotateXpress members.

Public Methods

Public Method AboutBox | Displays an information dialog box describing the NotateXpress component.
Public Method ClientDisconnect | Disconnects the NotateXpress object from the client ImageXView object.
Public Method CreateObjRef (Inherited from System.MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Public Method Dispose (Inherited from System.ComponentModel.Component) | Releases all resources used by the Component.
Public Method ForceAllUpdate | When multiple ImageXView objects are pointed to the same ImageX image, ForceAllUpdate synchronizes all NotateXpress objects to the current NotateXpress' data.
Public Method GetImageMappingDimensions | Gets the mapping width and height coordinates when NotateXpress cannot query ImagXpress for current image dimensions.
Public Method GetLifetimeService (Inherited from System.MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
Public Method GetUseCursorType | Returns a value indicating if a distinctive cursor is used for a specific type of operation (creating, moving, or selecting objects).
Public Method GetUseCustomCursorType | Uses custom cursors instead of built in ones.
Public Method InitializeLifetimeService (Inherited from System.MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Public Method MenuAddItem | Adds a user-defined item to the Context Menu. This method lets you add new items to the Context Menu and receive event notifications when these items are selected.
Public Method MenuChangeItem | This changes the specified menu item from the specified menu.
Public Method MenuDeleteItem | Removes the specified item from the specified menu.
Public Method MenuGetEnabled | Returns whether or not the specified menu will display when the right mouse button is clicked over the appropriate area
Public Method MenuGetFirstItemId | Gets the first menuId on the specified level from the specified menu.
Public Method MenuGetItem | Returns the text that will be displayed for the specified topMenuID and subMenuID on the menu.
Public Method MenuGetItemChecked | Returns the Checked attribute of the specified menu item on the specified menu item.
Public Method MenuGetItemEnabled | Gets the Enabled attribute of the specified menu item on the specified menu item.
Public Method MenuGetItemVisible | Gets the Visible attribute of the specified menu item on the specified menu item.
Public Method MenuGetNextItemId | Gets the subsequent menuId on the specified level from the specified menu after a calling MenuGetFirstItemId.
Public Method MenuSetEnabled | Sets whether or not the specified menu will display when the right mouse button is clicked over the appropriate area.
Public Method MenuSetItemChecked | Sets the Checked attribute of the specified menu item on the specified menu item.
Public Method MenuSetItemEnabled | Sets the Enabled attribute of the specified menu item on the specified menu item.
Public Method MenuSetItemVisible | Sets the Visible attribute of the specified menu item on the specified menu item.
Public Method SetImageMappingDimensions | Sets a given mapping width and height.
Public Method SetUseCursorType | Returns an indicator if a distinctive cursor is used for a specific type of operation (creating, moving, or selecting objects).
Public Method SetUseCustomCursorType | This is for replacing the built in cursors that are created by turning on SetUseCursorType.
Public Method ToString (Inherited from System.ComponentModel.Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Public Method UserDataAdd | Adds the specified key value pair to the list.
Public Method UserDataDelete | Deletes an existing key value pair which matches the given key.
Public Method UserDataFind | User data can be added to each page in a key value pair.
Public Method UserDataFindFirst | Finds the first key value pair in the list.
Public Method UserDataFindNext | Finds the next key value pair in the list.

See Also

NotateXpress Class | PegasusImaging.WinForms.NotateXpress9 Namespace


NotateXpressException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NotateXpressException Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : NotateXpressException Class

For a list of all members of this type, see NotateXpressException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

NotateXpressException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Data Property

NotateXpressException Class | NotateXpressException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Data Property

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpressException Class : Data Property (NotateXpressException)

Gets a collection of key/value pairs that provide additional, user-defined information about the exception.

[Visual Basic]
Public Overridable ReadOnly Property Data As IDictionary
[C#]
public virtual IDictionary Data {get;}
[C++]
public: __property virtual IDictionary* get_Data();
[C++/CLI]
public:
virtual property IDictionary^ Data {
   IDictionary^ get();
}

See Also

NotateXpressException Class | NotateXpressException Members


GetBaseException Method

NotateXpressException Class | NotateXpressException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetBaseException Method

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpressException Class : GetBaseException Method (NotateXpressException)

When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.

[Visual Basic]
Public Overridable Function GetBaseException() As Exception
[C#]
public virtual Exception GetBaseException();
[C++]
public: virtual Exception* GetBaseException();
[C++/CLI]
public:
virtual Exception^ GetBaseException();

Return Type

The first exception thrown in a chain of exceptions. If the InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

See Also

NotateXpressException Class | NotateXpressException Members


GetObjectData Method

NotateXpressException Class | NotateXpressException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetObjectData Method

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpressException Class : GetObjectData Method (NotateXpressException)

When overridden in a derived class, sets the SerializationInfo with information about the exception.

[Visual Basic]
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Public Overridable Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public virtual void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public: virtual void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
[C++/CLI]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public:
virtual void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

NotateXpressException Class | NotateXpressException Members


GetType Method

NotateXpressException Class | NotateXpressException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetType Method

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpressException Class : GetType Method (NotateXpressException)

Gets the runtime type of the current instance.

[Visual Basic]
Public Function GetType() As Type
[C#]
public Type GetType();
[C++]
public: Type* GetType();
[C++/CLI]
public:
Type^ GetType();

Return Type

A Type object that represents the exact runtime type of the current instance.

See Also

NotateXpressException Class | NotateXpressException Members


HelpLink Property

NotateXpressException Class | NotateXpressException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HelpLink Property

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpressException Class : HelpLink Property (NotateXpressException)

Gets or sets a link to the help file associated with this exception.

[Visual Basic]
Public Overridable Property HelpLink As String
[C#]
public virtual string HelpLink {get; set;}
[C++]
public: __property virtual string* get_HelpLink();
public: __property virtual void set_HelpLink(
   string* value
);
[C++/CLI]
public:
virtual property String^ HelpLink {
   String^ get();
   void set (String^ value);
}

See Also

NotateXpressException Class | NotateXpressException Members


InnerException Property

NotateXpressException Class | NotateXpressException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InnerException Property

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpressException Class : InnerException Property (NotateXpressException)

Gets the Exception instance that caused the current exception.

[Visual Basic]
Public ReadOnly Property InnerException As Exception
[C#]
public Exception InnerException {get;}
[C++]
public: __property Exception* get_InnerException();
[C++/CLI]
public:
property Exception^ InnerException {
   Exception^ get();
}

See Also

NotateXpressException Class | NotateXpressException Members


Message Property

NotateXpressException Class | NotateXpressException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Message Property

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpressException Class : Message Property (NotateXpressException)

Gets a message that describes the current exception.

[Visual Basic]
Public Overridable ReadOnly Property Message As String
[C#]
public virtual string Message {get;}
[C++]
public: __property virtual string* get_Message();
[C++/CLI]
public:
virtual property String^ Message {
   String^ get();
}

See Also

NotateXpressException Class | NotateXpressException Members


Source Property

NotateXpressException Class | NotateXpressException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Source Property

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpressException Class : Source Property (NotateXpressException)

Gets or sets the name of the application or the object that causes the error.

[Visual Basic]
Public Overridable Property Source As String
[C#]
public virtual string Source {get; set;}
[C++]
public: __property virtual string* get_Source();
public: __property virtual void set_Source(
   string* value
);
[C++/CLI]
public:
virtual property String^ Source {
   String^ get();
   void set (String^ value);
}

See Also

NotateXpressException Class | NotateXpressException Members


StackTrace Property

NotateXpressException Class | NotateXpressException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StackTrace Property

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpressException Class : StackTrace Property (NotateXpressException)

Gets a string representation of the frames on the call stack at the time the current exception was thrown.

[Visual Basic]
Public Overridable ReadOnly Property StackTrace As String
[C#]
public virtual string StackTrace {get;}
[C++]
public: __property virtual string* get_StackTrace();
[C++/CLI]
public:
virtual property String^ StackTrace {
   String^ get();
}

See Also

NotateXpressException Class | NotateXpressException Members


TargetSite Property

NotateXpressException Class | NotateXpressException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TargetSite Property

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpressException Class : TargetSite Property (NotateXpressException)

Gets the method that throws the current exception.

[Visual Basic]
Public ReadOnly Property TargetSite As MethodBase
[C#]
public MethodBase TargetSite {get;}
[C++]
public: __property MethodBase* get_TargetSite();
[C++/CLI]
public:
property MethodBase^ TargetSite {
   MethodBase^ get();
}

See Also

NotateXpressException Class | NotateXpressException Members


ToString Method

NotateXpressException Class | NotateXpressException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToString Method

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpressException Class : ToString Method (NotateXpressException)

Creates and returns a string representation of the current exception.

[Visual Basic]
Public Overridable Function ToString() As String
[C#]
public virtual string ToString();
[C++]
public: virtual string* ToString();
[C++/CLI]
public:
virtual String^ ToString();

Return Type

A string representation of the current exception.

See Also

NotateXpressException Class | NotateXpressException Members


Container Property

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Container Property

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : Container Property

Gets the IContainer that contains the Component.

[Visual Basic]
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public ReadOnly Property Container As IContainer
[C#]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public IContainer Container {get;}
[C++]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property IContainer* get_Container();
[C++/CLI]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property IContainer^ Container {
   IContainer^ get();
}

See Also

NotateXpress Class | NotateXpress Members


CreateObjRef Method

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

requestedType
The Type of the object that the new ObjRef will reference.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

CreateObjRef Method

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : CreateObjRef Method

Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.

[Visual Basic]
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=False,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=True,
   BindingRedirects=False,
   Unrestricted=False)>
Public Overridable Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
[C#]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=true,
   BindingRedirects=false,
   Unrestricted=false)]
public virtual ObjRef CreateObjRef(
   Type requestedType
);
[C++]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=true,
   BindingRedirects=false,
   Unrestricted=false)]
public: virtual ObjRef* CreateObjRef(
   Type* requestedType
)
[C++/CLI]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=true,
   BindingRedirects=false,
   Unrestricted=false)]
public:
virtual ObjRef^ CreateObjRef(
   Type^ requestedType
)

Parameters

requestedType
The Type of the object that the new ObjRef will reference.

Return Type

Information required to generate a proxy.

Exceptions

Exception | Description
SecurityException | The immediate caller does not have infrastructure permission.
RemotingException | This instance is not a valid remoting object.

See Also

NotateXpress Class | NotateXpress Members


Dispose Method

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Dispose Method

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : Dispose Method (NotateXpress)

Releases all resources used by the Component.

[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();
[C++]
public: void Dispose();
[C++/CLI]
public:
void Dispose();

See Also

NotateXpress Class | NotateXpress Members


Disposed Event

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Disposed Event

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : Disposed Event

Adds an event handler to listen to the Disposed event on the component.

[Visual Basic]
<BrowsableAttribute(False)>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Event Disposed() As EventHandler
[C#]
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public event EventHandler Disposed();
[C++]
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __event EventHandler* Disposed();
[C++/CLI]
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
event EventHandler^ Disposed();

See Also

NotateXpress Class | NotateXpress Members


GetLifetimeService Method

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetLifetimeService Method

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : GetLifetimeService Method

Retrieves the current lifetime service object that controls the lifetime policy for this instance.

[Visual Basic]
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=False,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=True,
   BindingRedirects=False,
   Unrestricted=False)>
Public Function GetLifetimeService() As Object
[C#]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=true,
   BindingRedirects=false,
   Unrestricted=false)]
public object GetLifetimeService();
[C++]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=true,
   BindingRedirects=false,
   Unrestricted=false)]
public: Object* GetLifetimeService();
[C++/CLI]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=true,
   BindingRedirects=false,
   Unrestricted=false)]
public:
Object^ GetLifetimeService();

Return Type

An object of type ILease used to control the lifetime policy for this instance.

Exceptions

Exception | Description
SecurityException | The immediate caller does not have infrastructure permission.

See Also

NotateXpress Class | NotateXpress Members


InitializeLifetimeService Method

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InitializeLifetimeService Method

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : InitializeLifetimeService Method

Obtains a lifetime service object to control the lifetime policy for this instance.

[Visual Basic]
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=False,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=True,
   BindingRedirects=False,
   Unrestricted=False)>
Public Overridable Function InitializeLifetimeService() As Object
[C#]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=true,
   BindingRedirects=false,
   Unrestricted=false)]
public virtual object InitializeLifetimeService();
[C++]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=true,
   BindingRedirects=false,
   Unrestricted=false)]
public: virtual Object* InitializeLifetimeService();
[C++/CLI]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=true,
   BindingRedirects=false,
   Unrestricted=false)]
public:
virtual Object^ InitializeLifetimeService();

Return Type

An object of type ILease used to control the lifetime policy for this instance. This is the current lifetime service object for this instance if one exists; otherwise, a new lifetime service object initialized to the value of the LeaseManagerPollTime property.

Exceptions

Exception | Description
SecurityException | The immediate caller does not have infrastructure permission.

See Also

NotateXpress Class | NotateXpress Members


Site Property

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Site Property

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : Site Property

Gets or sets the ISite of the Component.

[Visual Basic]
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Overridable Property Site As ISite
[C#]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public virtual ISite Site {get; set;}
[C++]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property virtual ISite* get_Site();
public: __property virtual void set_Site(
   ISite* value
);
[C++/CLI]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
virtual property ISite^ Site {
   ISite^ get();
   void set (ISite^ value);
}

See Also

NotateXpress Class | NotateXpress Members


ToString Method

NotateXpress Class | NotateXpress Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToString Method

PegasusImaging.WinForms.NotateXpress9 Namespace > NotateXpress Class : ToString Method (NotateXpress)

Returns a String containing the name of the Component, if any. This method should not be overridden.

[Visual Basic]
Public Overridable Function ToString() As String
[C#]
public virtual string ToString();
[C++]
public: virtual string* ToString();
[C++/CLI]
public:
virtual String^ ToString();

Return Type

A String containing the name of the Component, if any, or null if the Component is unnamed.

See Also

NotateXpress Class | NotateXpress Members


NoteTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NoteTool Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : NoteTool Class

For a list of all members of this type, see NoteTool members.

Public Methods

Public Method Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public Method NudgeDown (Inherited from Element) | Moves the specified annotation object one level down, towards the back, in the painting order of the specified layer.
Public Method NudgeUp (Inherited from Element) | Moves the specified annotation object one level up, towards the front, in the painting order of the specified layer.
Public Method UserDataAdd (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataDelete (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFind (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFindFirst (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFindNext (Inherited from Element) | User data can be added to each element in a key value pair.

See Also

NoteTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace


NotSupportedException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NotSupportedException Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : NotSupportedException Class

For a list of all members of this type, see NotSupportedException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

NotSupportedException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


NotSupportedException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

NotSupportedException Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : NotSupportedException Class

For a list of all members of this type, see NotSupportedException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

NotSupportedException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Data Property

NotSupportedException Class | NotSupportedException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Data Property

PegasusImaging.WinForms.NotateXpress9 Namespace > NotSupportedException Class : Data Property (NotSupportedException)

Gets a collection of key/value pairs that provide additional, user-defined information about the exception.

[Visual Basic]
Public ReadOnly Property Data As IDictionary
[C#]
public IDictionary Data {get;}
[C++]
public: __property IDictionary* get_Data();
[C++/CLI]
public:
property IDictionary^ Data {
   IDictionary^ get();
}

See Also

NotSupportedException Class | NotSupportedException Members


GetBaseException Method

NotSupportedException Class | NotSupportedException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetBaseException Method

PegasusImaging.WinForms.NotateXpress9 Namespace > NotSupportedException Class : GetBaseException Method (NotSupportedException)

When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.

[Visual Basic]
Public Function GetBaseException() As Exception
[C#]
public Exception GetBaseException();
[C++]
public: Exception* GetBaseException();
[C++/CLI]
public:
Exception^ GetBaseException();

Return Type

The first exception thrown in a chain of exceptions. If the InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

See Also

NotSupportedException Class | NotSupportedException Members


GetObjectData Method

NotSupportedException Class | NotSupportedException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetObjectData Method

PegasusImaging.WinForms.NotateXpress9 Namespace > NotSupportedException Class : GetObjectData Method (NotSupportedException)

When overridden in a derived class, sets the SerializationInfo with information about the exception.

[Visual Basic]
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
[C++/CLI]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

NotSupportedException Class | NotSupportedException Members


GetType Method

NotSupportedException Class | NotSupportedException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetType Method

PegasusImaging.WinForms.NotateXpress9 Namespace > NotSupportedException Class : GetType Method (NotSupportedException)

Gets the runtime type of the current instance.

[Visual Basic]
Public Function GetType() As Type
[C#]
public Type GetType();
[C++]
public: Type* GetType();
[C++/CLI]
public:
Type^ GetType();

Return Type

A Type object that represents the exact runtime type of the current instance.

See Also

NotSupportedException Class | NotSupportedException Members


HelpLink Property

NotSupportedException Class | NotSupportedException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HelpLink Property

PegasusImaging.WinForms.NotateXpress9 Namespace > NotSupportedException Class : HelpLink Property (NotSupportedException)

Gets or sets a link to the help file associated with this exception.

[Visual Basic]
Public Property HelpLink As String
[C#]
public string HelpLink {get; set;}
[C++]
public: __property string* get_HelpLink();
public: __property void set_HelpLink(
   string* value
);
[C++/CLI]
public:
property String^ HelpLink {
   String^ get();
   void set (String^ value);
}

See Also

NotSupportedException Class | NotSupportedException Members


InnerException Property

NotSupportedException Class | NotSupportedException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InnerException Property

PegasusImaging.WinForms.NotateXpress9 Namespace > NotSupportedException Class : InnerException Property (NotSupportedException)

Gets the Exception instance that caused the current exception.

[Visual Basic]
Public ReadOnly Property InnerException As Exception
[C#]
public Exception InnerException {get;}
[C++]
public: __property Exception* get_InnerException();
[C++/CLI]
public:
property Exception^ InnerException {
   Exception^ get();
}

See Also

NotSupportedException Class | NotSupportedException Members


Message Property

NotSupportedException Class | NotSupportedException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Message Property

PegasusImaging.WinForms.NotateXpress9 Namespace > NotSupportedException Class : Message Property (NotSupportedException)

Gets a message that describes the current exception.

[Visual Basic]
Public ReadOnly Property Message As String
[C#]
public string Message {get;}
[C++]
public: __property string* get_Message();
[C++/CLI]
public:
property String^ Message {
   String^ get();
}

See Also

NotSupportedException Class | NotSupportedException Members


Source Property

NotSupportedException Class | NotSupportedException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Source Property

PegasusImaging.WinForms.NotateXpress9 Namespace > NotSupportedException Class : Source Property (NotSupportedException)

Gets or sets the name of the application or the object that causes the error.

[Visual Basic]
Public Property Source As String
[C#]
public string Source {get; set;}
[C++]
public: __property string* get_Source();
public: __property void set_Source(
   string* value
);
[C++/CLI]
public:
property String^ Source {
   String^ get();
   void set (String^ value);
}

See Also

NotSupportedException Class | NotSupportedException Members


StackTrace Property

NotSupportedException Class | NotSupportedException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StackTrace Property

PegasusImaging.WinForms.NotateXpress9 Namespace > NotSupportedException Class : StackTrace Property (NotSupportedException)

Gets a string representation of the frames on the call stack at the time the current exception was thrown.

[Visual Basic]
Public ReadOnly Property StackTrace As String
[C#]
public string StackTrace {get;}
[C++]
public: __property string* get_StackTrace();
[C++/CLI]
public:
property String^ StackTrace {
   String^ get();
}

See Also

NotSupportedException Class | NotSupportedException Members


TargetSite Property

NotSupportedException Class | NotSupportedException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TargetSite Property

PegasusImaging.WinForms.NotateXpress9 Namespace > NotSupportedException Class : TargetSite Property (NotSupportedException)

Gets the method that throws the current exception.

[Visual Basic]
Public ReadOnly Property TargetSite As MethodBase
[C#]
public MethodBase TargetSite {get;}
[C++]
public: __property MethodBase* get_TargetSite();
[C++/CLI]
public:
property MethodBase^ TargetSite {
   MethodBase^ get();
}

See Also

NotSupportedException Class | NotSupportedException Members


ToString Method

NotSupportedException Class | NotSupportedException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToString Method

PegasusImaging.WinForms.NotateXpress9 Namespace > NotSupportedException Class : ToString Method (NotSupportedException)

Creates and returns a string representation of the current exception.

[Visual Basic]
Public Function ToString() As String
[C#]
public string ToString();
[C++]
public: string* ToString();
[C++/CLI]
public:
String^ ToString();

Return Type

A string representation of the current exception.

See Also

NotSupportedException Class | NotSupportedException Members


ObjectNotConnectedException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ObjectNotConnectedException Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : ObjectNotConnectedException Class

For a list of all members of this type, see ObjectNotConnectedException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

ObjectNotConnectedException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


ObjectNotConnectedException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ObjectNotConnectedException Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : ObjectNotConnectedException Class

For a list of all members of this type, see ObjectNotConnectedException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

ObjectNotConnectedException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Data Property

ObjectNotConnectedException Class | ObjectNotConnectedException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Data Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ObjectNotConnectedException Class : Data Property (ObjectNotConnectedException)

Gets a collection of key/value pairs that provide additional, user-defined information about the exception.

[Visual Basic]
Public ReadOnly Property Data As IDictionary
[C#]
public IDictionary Data {get;}
[C++]
public: __property IDictionary* get_Data();
[C++/CLI]
public:
property IDictionary^ Data {
   IDictionary^ get();
}

See Also

ObjectNotConnectedException Class | ObjectNotConnectedException Members


GetBaseException Method

ObjectNotConnectedException Class | ObjectNotConnectedException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetBaseException Method

PegasusImaging.WinForms.NotateXpress9 Namespace > ObjectNotConnectedException Class : GetBaseException Method (ObjectNotConnectedException)

When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.

[Visual Basic]
Public Function GetBaseException() As Exception
[C#]
public Exception GetBaseException();
[C++]
public: Exception* GetBaseException();
[C++/CLI]
public:
Exception^ GetBaseException();

Return Type

The first exception thrown in a chain of exceptions. If the InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

See Also

ObjectNotConnectedException Class | ObjectNotConnectedException Members


GetObjectData Method

ObjectNotConnectedException Class | ObjectNotConnectedException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetObjectData Method

PegasusImaging.WinForms.NotateXpress9 Namespace > ObjectNotConnectedException Class : GetObjectData Method (ObjectNotConnectedException)

When overridden in a derived class, sets the SerializationInfo with information about the exception.

[Visual Basic]
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
[C++/CLI]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

ObjectNotConnectedException Class | ObjectNotConnectedException Members


GetType Method

ObjectNotConnectedException Class | ObjectNotConnectedException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetType Method

PegasusImaging.WinForms.NotateXpress9 Namespace > ObjectNotConnectedException Class : GetType Method (ObjectNotConnectedException)

Gets the runtime type of the current instance.

[Visual Basic]
Public Function GetType() As Type
[C#]
public Type GetType();
[C++]
public: Type* GetType();
[C++/CLI]
public:
Type^ GetType();

Return Type

A Type object that represents the exact runtime type of the current instance.

See Also

ObjectNotConnectedException Class | ObjectNotConnectedException Members


HelpLink Property

ObjectNotConnectedException Class | ObjectNotConnectedException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HelpLink Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ObjectNotConnectedException Class : HelpLink Property (ObjectNotConnectedException)

Gets or sets a link to the help file associated with this exception.

[Visual Basic]
Public Property HelpLink As String
[C#]
public string HelpLink {get; set;}
[C++]
public: __property string* get_HelpLink();
public: __property void set_HelpLink(
   string* value
);
[C++/CLI]
public:
property String^ HelpLink {
   String^ get();
   void set (String^ value);
}

See Also

ObjectNotConnectedException Class | ObjectNotConnectedException Members


InnerException Property

ObjectNotConnectedException Class | ObjectNotConnectedException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InnerException Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ObjectNotConnectedException Class : InnerException Property (ObjectNotConnectedException)

Gets the Exception instance that caused the current exception.

[Visual Basic]
Public ReadOnly Property InnerException As Exception
[C#]
public Exception InnerException {get;}
[C++]
public: __property Exception* get_InnerException();
[C++/CLI]
public:
property Exception^ InnerException {
   Exception^ get();
}

See Also

ObjectNotConnectedException Class | ObjectNotConnectedException Members


Message Property

ObjectNotConnectedException Class | ObjectNotConnectedException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Message Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ObjectNotConnectedException Class : Message Property (ObjectNotConnectedException)

Gets a message that describes the current exception.

[Visual Basic]
Public ReadOnly Property Message As String
[C#]
public string Message {get;}
[C++]
public: __property string* get_Message();
[C++/CLI]
public:
property String^ Message {
   String^ get();
}

See Also

ObjectNotConnectedException Class | ObjectNotConnectedException Members


Source Property

ObjectNotConnectedException Class | ObjectNotConnectedException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Source Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ObjectNotConnectedException Class : Source Property (ObjectNotConnectedException)

Gets or sets the name of the application or the object that causes the error.

[Visual Basic]
Public Property Source As String
[C#]
public string Source {get; set;}
[C++]
public: __property string* get_Source();
public: __property void set_Source(
   string* value
);
[C++/CLI]
public:
property String^ Source {
   String^ get();
   void set (String^ value);
}

See Also

ObjectNotConnectedException Class | ObjectNotConnectedException Members


StackTrace Property

ObjectNotConnectedException Class | ObjectNotConnectedException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StackTrace Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ObjectNotConnectedException Class : StackTrace Property (ObjectNotConnectedException)

Gets a string representation of the frames on the call stack at the time the current exception was thrown.

[Visual Basic]
Public ReadOnly Property StackTrace As String
[C#]
public string StackTrace {get;}
[C++]
public: __property string* get_StackTrace();
[C++/CLI]
public:
property String^ StackTrace {
   String^ get();
}

See Also

ObjectNotConnectedException Class | ObjectNotConnectedException Members


TargetSite Property

ObjectNotConnectedException Class | ObjectNotConnectedException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TargetSite Property

PegasusImaging.WinForms.NotateXpress9 Namespace > ObjectNotConnectedException Class : TargetSite Property (ObjectNotConnectedException)

Gets the method that throws the current exception.

[Visual Basic]
Public ReadOnly Property TargetSite As MethodBase
[C#]
public MethodBase TargetSite {get;}
[C++]
public: __property MethodBase* get_TargetSite();
[C++/CLI]
public:
property MethodBase^ TargetSite {
   MethodBase^ get();
}

See Also

ObjectNotConnectedException Class | ObjectNotConnectedException Members


ToString Method

ObjectNotConnectedException Class | ObjectNotConnectedException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToString Method

PegasusImaging.WinForms.NotateXpress9 Namespace > ObjectNotConnectedException Class : ToString Method (ObjectNotConnectedException)

Creates and returns a string representation of the current exception.

[Visual Basic]
Public Function ToString() As String
[C#]
public string ToString();
[C++]
public: string* ToString();
[C++/CLI]
public:
String^ ToString();

Return Type

A string representation of the current exception.

See Also

ObjectNotConnectedException Class | ObjectNotConnectedException Members


OutOfMemoryException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

OutOfMemoryException Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : OutOfMemoryException Class

For a list of all members of this type, see OutOfMemoryException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

OutOfMemoryException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


OutOfMemoryException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

OutOfMemoryException Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : OutOfMemoryException Class

For a list of all members of this type, see OutOfMemoryException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

OutOfMemoryException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Data Property

OutOfMemoryException Class | OutOfMemoryException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Data Property

PegasusImaging.WinForms.NotateXpress9 Namespace > OutOfMemoryException Class : Data Property (OutOfMemoryException)

Gets a collection of key/value pairs that provide additional, user-defined information about the exception.

[Visual Basic]
Public ReadOnly Property Data As IDictionary
[C#]
public IDictionary Data {get;}
[C++]
public: __property IDictionary* get_Data();
[C++/CLI]
public:
property IDictionary^ Data {
   IDictionary^ get();
}

See Also

OutOfMemoryException Class | OutOfMemoryException Members


GetBaseException Method

OutOfMemoryException Class | OutOfMemoryException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetBaseException Method

PegasusImaging.WinForms.NotateXpress9 Namespace > OutOfMemoryException Class : GetBaseException Method (OutOfMemoryException)

When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.

[Visual Basic]
Public Function GetBaseException() As Exception
[C#]
public Exception GetBaseException();
[C++]
public: Exception* GetBaseException();
[C++/CLI]
public:
Exception^ GetBaseException();

Return Type

The first exception thrown in a chain of exceptions. If the InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

See Also

OutOfMemoryException Class | OutOfMemoryException Members


GetObjectData Method

OutOfMemoryException Class | OutOfMemoryException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetObjectData Method

PegasusImaging.WinForms.NotateXpress9 Namespace > OutOfMemoryException Class : GetObjectData Method (OutOfMemoryException)

When overridden in a derived class, sets the SerializationInfo with information about the exception.

[Visual Basic]
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
[C++/CLI]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

OutOfMemoryException Class | OutOfMemoryException Members


GetType Method

OutOfMemoryException Class | OutOfMemoryException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetType Method

PegasusImaging.WinForms.NotateXpress9 Namespace > OutOfMemoryException Class : GetType Method (OutOfMemoryException)

Gets the runtime type of the current instance.

[Visual Basic]
Public Function GetType() As Type
[C#]
public Type GetType();
[C++]
public: Type* GetType();
[C++/CLI]
public:
Type^ GetType();

Return Type

A Type object that represents the exact runtime type of the current instance.

See Also

OutOfMemoryException Class | OutOfMemoryException Members


HelpLink Property

OutOfMemoryException Class | OutOfMemoryException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HelpLink Property

PegasusImaging.WinForms.NotateXpress9 Namespace > OutOfMemoryException Class : HelpLink Property (OutOfMemoryException)

Gets or sets a link to the help file associated with this exception.

[Visual Basic]
Public Property HelpLink As String
[C#]
public string HelpLink {get; set;}
[C++]
public: __property string* get_HelpLink();
public: __property void set_HelpLink(
   string* value
);
[C++/CLI]
public:
property String^ HelpLink {
   String^ get();
   void set (String^ value);
}

See Also

OutOfMemoryException Class | OutOfMemoryException Members


InnerException Property

OutOfMemoryException Class | OutOfMemoryException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InnerException Property

PegasusImaging.WinForms.NotateXpress9 Namespace > OutOfMemoryException Class : InnerException Property (OutOfMemoryException)

Gets the Exception instance that caused the current exception.

[Visual Basic]
Public ReadOnly Property InnerException As Exception
[C#]
public Exception InnerException {get;}
[C++]
public: __property Exception* get_InnerException();
[C++/CLI]
public:
property Exception^ InnerException {
   Exception^ get();
}

See Also

OutOfMemoryException Class | OutOfMemoryException Members


Message Property

OutOfMemoryException Class | OutOfMemoryException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Message Property

PegasusImaging.WinForms.NotateXpress9 Namespace > OutOfMemoryException Class : Message Property (OutOfMemoryException)

Gets a message that describes the current exception.

[Visual Basic]
Public ReadOnly Property Message As String
[C#]
public string Message {get;}
[C++]
public: __property string* get_Message();
[C++/CLI]
public:
property String^ Message {
   String^ get();
}

See Also

OutOfMemoryException Class | OutOfMemoryException Members


Source Property

OutOfMemoryException Class | OutOfMemoryException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Source Property

PegasusImaging.WinForms.NotateXpress9 Namespace > OutOfMemoryException Class : Source Property (OutOfMemoryException)

Gets or sets the name of the application or the object that causes the error.

[Visual Basic]
Public Property Source As String
[C#]
public string Source {get; set;}
[C++]
public: __property string* get_Source();
public: __property void set_Source(
   string* value
);
[C++/CLI]
public:
property String^ Source {
   String^ get();
   void set (String^ value);
}

See Also

OutOfMemoryException Class | OutOfMemoryException Members


StackTrace Property

OutOfMemoryException Class | OutOfMemoryException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StackTrace Property

PegasusImaging.WinForms.NotateXpress9 Namespace > OutOfMemoryException Class : StackTrace Property (OutOfMemoryException)

Gets a string representation of the frames on the call stack at the time the current exception was thrown.

[Visual Basic]
Public ReadOnly Property StackTrace As String
[C#]
public string StackTrace {get;}
[C++]
public: __property string* get_StackTrace();
[C++/CLI]
public:
property String^ StackTrace {
   String^ get();
}

See Also

OutOfMemoryException Class | OutOfMemoryException Members


TargetSite Property

OutOfMemoryException Class | OutOfMemoryException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TargetSite Property

PegasusImaging.WinForms.NotateXpress9 Namespace > OutOfMemoryException Class : TargetSite Property (OutOfMemoryException)

Gets the method that throws the current exception.

[Visual Basic]
Public ReadOnly Property TargetSite As MethodBase
[C#]
public MethodBase TargetSite {get;}
[C++]
public: __property MethodBase* get_TargetSite();
[C++/CLI]
public:
property MethodBase^ TargetSite {
   MethodBase^ get();
}

See Also

OutOfMemoryException Class | OutOfMemoryException Members


ToString Method

OutOfMemoryException Class | OutOfMemoryException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToString Method

PegasusImaging.WinForms.NotateXpress9 Namespace > OutOfMemoryException Class : ToString Method (OutOfMemoryException)

Creates and returns a string representation of the current exception.

[Visual Basic]
Public Function ToString() As String
[C#]
public string ToString();
[C++]
public: string* ToString();
[C++/CLI]
public:
String^ ToString();

Return Type

A string representation of the current exception.

See Also

OutOfMemoryException Class | OutOfMemoryException Members


PageNotFoundException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PageNotFoundException Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : PageNotFoundException Class

For a list of all members of this type, see PageNotFoundException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

PageNotFoundException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


PageNotFoundException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PageNotFoundException Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : PageNotFoundException Class

For a list of all members of this type, see PageNotFoundException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

PageNotFoundException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Data Property

PageNotFoundException Class | PageNotFoundException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Data Property

PegasusImaging.WinForms.NotateXpress9 Namespace > PageNotFoundException Class : Data Property (PageNotFoundException)

Gets a collection of key/value pairs that provide additional, user-defined information about the exception.

[Visual Basic]
Public ReadOnly Property Data As IDictionary
[C#]
public IDictionary Data {get;}
[C++]
public: __property IDictionary* get_Data();
[C++/CLI]
public:
property IDictionary^ Data {
   IDictionary^ get();
}

See Also

PageNotFoundException Class | PageNotFoundException Members


GetBaseException Method

PageNotFoundException Class | PageNotFoundException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetBaseException Method

PegasusImaging.WinForms.NotateXpress9 Namespace > PageNotFoundException Class : GetBaseException Method (PageNotFoundException)

When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.

[Visual Basic]
Public Function GetBaseException() As Exception
[C#]
public Exception GetBaseException();
[C++]
public: Exception* GetBaseException();
[C++/CLI]
public:
Exception^ GetBaseException();

Return Type

The first exception thrown in a chain of exceptions. If the InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

See Also

PageNotFoundException Class | PageNotFoundException Members


GetObjectData Method

PageNotFoundException Class | PageNotFoundException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetObjectData Method

PegasusImaging.WinForms.NotateXpress9 Namespace > PageNotFoundException Class : GetObjectData Method (PageNotFoundException)

When overridden in a derived class, sets the SerializationInfo with information about the exception.

[Visual Basic]
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
[C++/CLI]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

PageNotFoundException Class | PageNotFoundException Members


GetType Method

PageNotFoundException Class | PageNotFoundException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetType Method

PegasusImaging.WinForms.NotateXpress9 Namespace > PageNotFoundException Class : GetType Method (PageNotFoundException)

Gets the runtime type of the current instance.

[Visual Basic]
Public Function GetType() As Type
[C#]
public Type GetType();
[C++]
public: Type* GetType();
[C++/CLI]
public:
Type^ GetType();

Return Type

A Type object that represents the exact runtime type of the current instance.

See Also

PageNotFoundException Class | PageNotFoundException Members


HelpLink Property

PageNotFoundException Class | PageNotFoundException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HelpLink Property

PegasusImaging.WinForms.NotateXpress9 Namespace > PageNotFoundException Class : HelpLink Property (PageNotFoundException)

Gets or sets a link to the help file associated with this exception.

[Visual Basic]
Public Property HelpLink As String
[C#]
public string HelpLink {get; set;}
[C++]
public: __property string* get_HelpLink();
public: __property void set_HelpLink(
   string* value
);
[C++/CLI]
public:
property String^ HelpLink {
   String^ get();
   void set (String^ value);
}

See Also

PageNotFoundException Class | PageNotFoundException Members


InnerException Property

PageNotFoundException Class | PageNotFoundException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InnerException Property

PegasusImaging.WinForms.NotateXpress9 Namespace > PageNotFoundException Class : InnerException Property (PageNotFoundException)

Gets the Exception instance that caused the current exception.

[Visual Basic]
Public ReadOnly Property InnerException As Exception
[C#]
public Exception InnerException {get;}
[C++]
public: __property Exception* get_InnerException();
[C++/CLI]
public:
property Exception^ InnerException {
   Exception^ get();
}

See Also

PageNotFoundException Class | PageNotFoundException Members


Message Property

PageNotFoundException Class | PageNotFoundException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Message Property

PegasusImaging.WinForms.NotateXpress9 Namespace > PageNotFoundException Class : Message Property (PageNotFoundException)

Gets a message that describes the current exception.

[Visual Basic]
Public ReadOnly Property Message As String
[C#]
public string Message {get;}
[C++]
public: __property string* get_Message();
[C++/CLI]
public:
property String^ Message {
   String^ get();
}

See Also

PageNotFoundException Class | PageNotFoundException Members


Source Property

PageNotFoundException Class | PageNotFoundException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Source Property

PegasusImaging.WinForms.NotateXpress9 Namespace > PageNotFoundException Class : Source Property (PageNotFoundException)

Gets or sets the name of the application or the object that causes the error.

[Visual Basic]
Public Property Source As String
[C#]
public string Source {get; set;}
[C++]
public: __property string* get_Source();
public: __property void set_Source(
   string* value
);
[C++/CLI]
public:
property String^ Source {
   String^ get();
   void set (String^ value);
}

See Also

PageNotFoundException Class | PageNotFoundException Members


StackTrace Property

PageNotFoundException Class | PageNotFoundException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StackTrace Property

PegasusImaging.WinForms.NotateXpress9 Namespace > PageNotFoundException Class : StackTrace Property (PageNotFoundException)

Gets a string representation of the frames on the call stack at the time the current exception was thrown.

[Visual Basic]
Public ReadOnly Property StackTrace As String
[C#]
public string StackTrace {get;}
[C++]
public: __property string* get_StackTrace();
[C++/CLI]
public:
property String^ StackTrace {
   String^ get();
}

See Also

PageNotFoundException Class | PageNotFoundException Members


TargetSite Property

PageNotFoundException Class | PageNotFoundException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TargetSite Property

PegasusImaging.WinForms.NotateXpress9 Namespace > PageNotFoundException Class : TargetSite Property (PageNotFoundException)

Gets the method that throws the current exception.

[Visual Basic]
Public ReadOnly Property TargetSite As MethodBase
[C#]
public MethodBase TargetSite {get;}
[C++]
public: __property MethodBase* get_TargetSite();
[C++/CLI]
public:
property MethodBase^ TargetSite {
   MethodBase^ get();
}

See Also

PageNotFoundException Class | PageNotFoundException Members


ToString Method

PageNotFoundException Class | PageNotFoundException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToString Method

PegasusImaging.WinForms.NotateXpress9 Namespace > PageNotFoundException Class : ToString Method (PageNotFoundException)

Creates and returns a string representation of the current exception.

[Visual Basic]
Public Function ToString() As String
[C#]
public string ToString();
[C++]
public: string* ToString();
[C++/CLI]
public:
String^ ToString();

Return Type

A string representation of the current exception.

See Also

PageNotFoundException Class | PageNotFoundException Members


PolygonTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PolygonTool Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : PolygonTool Class

For a list of all members of this type, see PolygonTool members.

Public Methods

Public Method GetPoints | This method returns an array of Points used to draw the line.
Public Method NudgeDown (Inherited from Element) | Moves the specified annotation object one level down, towards the back, in the painting order of the specified layer.
Public Method NudgeUp (Inherited from Element) | Moves the specified annotation object one level up, towards the front, in the painting order of the specified layer.
Public Method SetPoints | This method sets an array of Points used to draw the line.
Public Method UserDataAdd (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataDelete (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFind (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFindFirst (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFindNext (Inherited from Element) | User data can be added to each element in a key value pair.

See Also

PolygonTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace


PolyLineTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PolyLineTool Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : PolyLineTool Class

For a list of all members of this type, see PolyLineTool members.

Public Methods

Public Method GetPoints | This method returns an array of Points used to draw the line.
Public Method NudgeDown (Inherited from Element) | Moves the specified annotation object one level down, towards the back, in the painting order of the specified layer.
Public Method NudgeUp (Inherited from Element) | Moves the specified annotation object one level up, towards the front, in the painting order of the specified layer.
Public Method SetPoints | This method sets an array of Points used to draw the line.
Public Method UserDataAdd (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataDelete (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFind (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFindFirst (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFindNext (Inherited from Element) | User data can be added to each element in a key value pair.

See Also

PolyLineTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace


RectangleTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

RectangleTool Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : RectangleTool Class

For a list of all members of this type, see RectangleTool members.

Public Methods

Public Method NudgeDown (Inherited from Element) | Moves the specified annotation object one level down, towards the back, in the painting order of the specified layer.
Public Method NudgeUp (Inherited from Element) | Moves the specified annotation object one level up, towards the front, in the painting order of the specified layer.
Public Method UserDataAdd (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataDelete (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFind (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFindFirst (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFindNext (Inherited from Element) | User data can be added to each element in a key value pair.

See Also

RectangleTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace


RulerTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

RulerTool Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : RulerTool Class

For a list of all members of this type, see RulerTool members.

Public Methods

Public Method Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public Method GetAbbreviation | Gets the abbreviation for the given MeasurementUnit.
Public Method NudgeDown (Inherited from Element) | Moves the specified annotation object one level down, towards the back, in the painting order of the specified layer.
Public Method NudgeUp (Inherited from Element) | Moves the specified annotation object one level up, towards the front, in the painting order of the specified layer.
Public Method SetAbbreviation | This public function sets the specified abbreviation for the given tool. If this object is connected, it will call into the worker and update real-time. If not connected however, the information will be stored, and the abbreviations will be updated when connected.
Public Method UserDataAdd (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataDelete (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFind (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFindFirst (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFindNext (Inherited from Element) | User data can be added to each element in a key value pair.

See Also

RulerTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace


SaveFileOneLayerException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

SaveFileOneLayerException Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : SaveFileOneLayerException Class

For a list of all members of this type, see SaveFileOneLayerException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

SaveFileOneLayerException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


SaveFileOneLayerException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

SaveFileOneLayerException Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : SaveFileOneLayerException Class

For a list of all members of this type, see SaveFileOneLayerException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

SaveFileOneLayerException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Data Property

SaveFileOneLayerException Class | SaveFileOneLayerException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Data Property

PegasusImaging.WinForms.NotateXpress9 Namespace > SaveFileOneLayerException Class : Data Property (SaveFileOneLayerException)

Gets a collection of key/value pairs that provide additional, user-defined information about the exception.

[Visual Basic]
Public ReadOnly Property Data As IDictionary
[C#]
public IDictionary Data {get;}
[C++]
public: __property IDictionary* get_Data();
[C++/CLI]
public:
property IDictionary^ Data {
   IDictionary^ get();
}

See Also

SaveFileOneLayerException Class | SaveFileOneLayerException Members


GetBaseException Method

SaveFileOneLayerException Class | SaveFileOneLayerException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetBaseException Method

PegasusImaging.WinForms.NotateXpress9 Namespace > SaveFileOneLayerException Class : GetBaseException Method (SaveFileOneLayerException)

When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.

[Visual Basic]
Public Function GetBaseException() As Exception
[C#]
public Exception GetBaseException();
[C++]
public: Exception* GetBaseException();
[C++/CLI]
public:
Exception^ GetBaseException();

Return Type

The first exception thrown in a chain of exceptions. If the InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

See Also

SaveFileOneLayerException Class | SaveFileOneLayerException Members


GetObjectData Method

SaveFileOneLayerException Class | SaveFileOneLayerException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetObjectData Method

PegasusImaging.WinForms.NotateXpress9 Namespace > SaveFileOneLayerException Class : GetObjectData Method (SaveFileOneLayerException)

When overridden in a derived class, sets the SerializationInfo with information about the exception.

[Visual Basic]
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
[C++/CLI]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

SaveFileOneLayerException Class | SaveFileOneLayerException Members


GetType Method

SaveFileOneLayerException Class | SaveFileOneLayerException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetType Method

PegasusImaging.WinForms.NotateXpress9 Namespace > SaveFileOneLayerException Class : GetType Method (SaveFileOneLayerException)

Gets the runtime type of the current instance.

[Visual Basic]
Public Function GetType() As Type
[C#]
public Type GetType();
[C++]
public: Type* GetType();
[C++/CLI]
public:
Type^ GetType();

Return Type

A Type object that represents the exact runtime type of the current instance.

See Also

SaveFileOneLayerException Class | SaveFileOneLayerException Members


HelpLink Property

SaveFileOneLayerException Class | SaveFileOneLayerException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HelpLink Property

PegasusImaging.WinForms.NotateXpress9 Namespace > SaveFileOneLayerException Class : HelpLink Property (SaveFileOneLayerException)

Gets or sets a link to the help file associated with this exception.

[Visual Basic]
Public Property HelpLink As String
[C#]
public string HelpLink {get; set;}
[C++]
public: __property string* get_HelpLink();
public: __property void set_HelpLink(
   string* value
);
[C++/CLI]
public:
property String^ HelpLink {
   String^ get();
   void set (String^ value);
}

See Also

SaveFileOneLayerException Class | SaveFileOneLayerException Members


InnerException Property

SaveFileOneLayerException Class | SaveFileOneLayerException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InnerException Property

PegasusImaging.WinForms.NotateXpress9 Namespace > SaveFileOneLayerException Class : InnerException Property (SaveFileOneLayerException)

Gets the Exception instance that caused the current exception.

[Visual Basic]
Public ReadOnly Property InnerException As Exception
[C#]
public Exception InnerException {get;}
[C++]
public: __property Exception* get_InnerException();
[C++/CLI]
public:
property Exception^ InnerException {
   Exception^ get();
}

See Also

SaveFileOneLayerException Class | SaveFileOneLayerException Members


Message Property

SaveFileOneLayerException Class | SaveFileOneLayerException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Message Property

PegasusImaging.WinForms.NotateXpress9 Namespace > SaveFileOneLayerException Class : Message Property (SaveFileOneLayerException)

Gets a message that describes the current exception.

[Visual Basic]
Public ReadOnly Property Message As String
[C#]
public string Message {get;}
[C++]
public: __property string* get_Message();
[C++/CLI]
public:
property String^ Message {
   String^ get();
}

See Also

SaveFileOneLayerException Class | SaveFileOneLayerException Members


Source Property

SaveFileOneLayerException Class | SaveFileOneLayerException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Source Property

PegasusImaging.WinForms.NotateXpress9 Namespace > SaveFileOneLayerException Class : Source Property (SaveFileOneLayerException)

Gets or sets the name of the application or the object that causes the error.

[Visual Basic]
Public Property Source As String
[C#]
public string Source {get; set;}
[C++]
public: __property string* get_Source();
public: __property void set_Source(
   string* value
);
[C++/CLI]
public:
property String^ Source {
   String^ get();
   void set (String^ value);
}

See Also

SaveFileOneLayerException Class | SaveFileOneLayerException Members


StackTrace Property

SaveFileOneLayerException Class | SaveFileOneLayerException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StackTrace Property

PegasusImaging.WinForms.NotateXpress9 Namespace > SaveFileOneLayerException Class : StackTrace Property (SaveFileOneLayerException)

Gets a string representation of the frames on the call stack at the time the current exception was thrown.

[Visual Basic]
Public ReadOnly Property StackTrace As String
[C#]
public string StackTrace {get;}
[C++]
public: __property string* get_StackTrace();
[C++/CLI]
public:
property String^ StackTrace {
   String^ get();
}

See Also

SaveFileOneLayerException Class | SaveFileOneLayerException Members


TargetSite Property

SaveFileOneLayerException Class | SaveFileOneLayerException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TargetSite Property

PegasusImaging.WinForms.NotateXpress9 Namespace > SaveFileOneLayerException Class : TargetSite Property (SaveFileOneLayerException)

Gets the method that throws the current exception.

[Visual Basic]
Public ReadOnly Property TargetSite As MethodBase
[C#]
public MethodBase TargetSite {get;}
[C++]
public: __property MethodBase* get_TargetSite();
[C++/CLI]
public:
property MethodBase^ TargetSite {
   MethodBase^ get();
}

See Also

SaveFileOneLayerException Class | SaveFileOneLayerException Members


ToString Method

SaveFileOneLayerException Class | SaveFileOneLayerException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToString Method

PegasusImaging.WinForms.NotateXpress9 Namespace > SaveFileOneLayerException Class : ToString Method (SaveFileOneLayerException)

Creates and returns a string representation of the current exception.

[Visual Basic]
Public Function ToString() As String
[C#]
public string ToString();
[C++]
public: string* ToString();
[C++/CLI]
public:
String^ ToString();

Return Type

A string representation of the current exception.

See Also

SaveFileOneLayerException Class | SaveFileOneLayerException Members


StampTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StampTool Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : StampTool Class

For a list of all members of this type, see StampTool members.

Public Methods

Public Method Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public Method NudgeDown (Inherited from Element) | Moves the specified annotation object one level down, towards the back, in the painting order of the specified layer.
Public Method NudgeUp (Inherited from Element) | Moves the specified annotation object one level up, towards the front, in the painting order of the specified layer.
Public Method UserDataAdd (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataDelete (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFind (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFindFirst (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFindNext (Inherited from Element) | User data can be added to each element in a key value pair.

See Also

StampTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace


StorageStreamException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StorageStreamException Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : StorageStreamException Class

For a list of all members of this type, see StorageStreamException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

StorageStreamException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


StorageStreamException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StorageStreamException Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : StorageStreamException Class

For a list of all members of this type, see StorageStreamException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

StorageStreamException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Data Property

StorageStreamException Class | StorageStreamException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Data Property

PegasusImaging.WinForms.NotateXpress9 Namespace > StorageStreamException Class : Data Property (StorageStreamException)

Gets a collection of key/value pairs that provide additional, user-defined information about the exception.

[Visual Basic]
Public ReadOnly Property Data As IDictionary
[C#]
public IDictionary Data {get;}
[C++]
public: __property IDictionary* get_Data();
[C++/CLI]
public:
property IDictionary^ Data {
   IDictionary^ get();
}

See Also

StorageStreamException Class | StorageStreamException Members


GetBaseException Method

StorageStreamException Class | StorageStreamException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetBaseException Method

PegasusImaging.WinForms.NotateXpress9 Namespace > StorageStreamException Class : GetBaseException Method (StorageStreamException)

When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.

[Visual Basic]
Public Function GetBaseException() As Exception
[C#]
public Exception GetBaseException();
[C++]
public: Exception* GetBaseException();
[C++/CLI]
public:
Exception^ GetBaseException();

Return Type

The first exception thrown in a chain of exceptions. If the InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

See Also

StorageStreamException Class | StorageStreamException Members


GetObjectData Method

StorageStreamException Class | StorageStreamException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetObjectData Method

PegasusImaging.WinForms.NotateXpress9 Namespace > StorageStreamException Class : GetObjectData Method (StorageStreamException)

When overridden in a derived class, sets the SerializationInfo with information about the exception.

[Visual Basic]
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
[C++/CLI]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

StorageStreamException Class | StorageStreamException Members


GetType Method

StorageStreamException Class | StorageStreamException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetType Method

PegasusImaging.WinForms.NotateXpress9 Namespace > StorageStreamException Class : GetType Method (StorageStreamException)

Gets the runtime type of the current instance.

[Visual Basic]
Public Function GetType() As Type
[C#]
public Type GetType();
[C++]
public: Type* GetType();
[C++/CLI]
public:
Type^ GetType();

Return Type

A Type object that represents the exact runtime type of the current instance.

See Also

StorageStreamException Class | StorageStreamException Members


HelpLink Property

StorageStreamException Class | StorageStreamException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HelpLink Property

PegasusImaging.WinForms.NotateXpress9 Namespace > StorageStreamException Class : HelpLink Property (StorageStreamException)

Gets or sets a link to the help file associated with this exception.

[Visual Basic]
Public Property HelpLink As String
[C#]
public string HelpLink {get; set;}
[C++]
public: __property string* get_HelpLink();
public: __property void set_HelpLink(
   string* value
);
[C++/CLI]
public:
property String^ HelpLink {
   String^ get();
   void set (String^ value);
}

See Also

StorageStreamException Class | StorageStreamException Members


InnerException Property

StorageStreamException Class | StorageStreamException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InnerException Property

PegasusImaging.WinForms.NotateXpress9 Namespace > StorageStreamException Class : InnerException Property (StorageStreamException)

Gets the Exception instance that caused the current exception.

[Visual Basic]
Public ReadOnly Property InnerException As Exception
[C#]
public Exception InnerException {get;}
[C++]
public: __property Exception* get_InnerException();
[C++/CLI]
public:
property Exception^ InnerException {
   Exception^ get();
}

See Also

StorageStreamException Class | StorageStreamException Members


Message Property

StorageStreamException Class | StorageStreamException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Message Property

PegasusImaging.WinForms.NotateXpress9 Namespace > StorageStreamException Class : Message Property (StorageStreamException)

Gets a message that describes the current exception.

[Visual Basic]
Public ReadOnly Property Message As String
[C#]
public string Message {get;}
[C++]
public: __property string* get_Message();
[C++/CLI]
public:
property String^ Message {
   String^ get();
}

See Also

StorageStreamException Class | StorageStreamException Members


Source Property

StorageStreamException Class | StorageStreamException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Source Property

PegasusImaging.WinForms.NotateXpress9 Namespace > StorageStreamException Class : Source Property (StorageStreamException)

Gets or sets the name of the application or the object that causes the error.

[Visual Basic]
Public Property Source As String
[C#]
public string Source {get; set;}
[C++]
public: __property string* get_Source();
public: __property void set_Source(
   string* value
);
[C++/CLI]
public:
property String^ Source {
   String^ get();
   void set (String^ value);
}

See Also

StorageStreamException Class | StorageStreamException Members


StackTrace Property

StorageStreamException Class | StorageStreamException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StackTrace Property

PegasusImaging.WinForms.NotateXpress9 Namespace > StorageStreamException Class : StackTrace Property (StorageStreamException)

Gets a string representation of the frames on the call stack at the time the current exception was thrown.

[Visual Basic]
Public ReadOnly Property StackTrace As String
[C#]
public string StackTrace {get;}
[C++]
public: __property string* get_StackTrace();
[C++/CLI]
public:
property String^ StackTrace {
   String^ get();
}

See Also

StorageStreamException Class | StorageStreamException Members


TargetSite Property

StorageStreamException Class | StorageStreamException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TargetSite Property

PegasusImaging.WinForms.NotateXpress9 Namespace > StorageStreamException Class : TargetSite Property (StorageStreamException)

Gets the method that throws the current exception.

[Visual Basic]
Public ReadOnly Property TargetSite As MethodBase
[C#]
public MethodBase TargetSite {get;}
[C++]
public: __property MethodBase* get_TargetSite();
[C++/CLI]
public:
property MethodBase^ TargetSite {
   MethodBase^ get();
}

See Also

StorageStreamException Class | StorageStreamException Members


ToString Method

StorageStreamException Class | StorageStreamException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToString Method

PegasusImaging.WinForms.NotateXpress9 Namespace > StorageStreamException Class : ToString Method (StorageStreamException)

Creates and returns a string representation of the current exception.

[Visual Basic]
Public Function ToString() As String
[C#]
public string ToString();
[C++]
public: string* ToString();
[C++/CLI]
public:
String^ ToString();

Return Type

A string representation of the current exception.

See Also

StorageStreamException Class | StorageStreamException Members


TextTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TextTool Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : TextTool Class

For a list of all members of this type, see TextTool members.

Public Methods

Public Method Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public Method NudgeDown (Inherited from Element) | Moves the specified annotation object one level down, towards the back, in the painting order of the specified layer.
Public Method NudgeUp (Inherited from Element) | Moves the specified annotation object one level up, towards the front, in the painting order of the specified layer.
Public Method UserDataAdd (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataDelete (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFind (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFindFirst (Inherited from Element) | User data can be added to each element in a key value pair.
Public Method UserDataFindNext (Inherited from Element) | User data can be added to each element in a key value pair.

See Also

TextTool Class | PegasusImaging.WinForms.NotateXpress9 Namespace


TmsAnnotationBadActivateCodeException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadActivateCodeException Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : TmsAnnotationBadActivateCodeException Class

For a list of all members of this type, see TmsAnnotationBadActivateCodeException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

TmsAnnotationBadActivateCodeException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


TmsAnnotationBadActivateCodeException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadActivateCodeException Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : TmsAnnotationBadActivateCodeException Class

For a list of all members of this type, see TmsAnnotationBadActivateCodeException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

TmsAnnotationBadActivateCodeException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Data Property

TmsAnnotationBadActivateCodeException Class | TmsAnnotationBadActivateCodeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Data Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadActivateCodeException Class : Data Property (TmsAnnotationBadActivateCodeException)

Gets a collection of key/value pairs that provide additional, user-defined information about the exception.

[Visual Basic]
Public ReadOnly Property Data As IDictionary
[C#]
public IDictionary Data {get;}
[C++]
public: __property IDictionary* get_Data();
[C++/CLI]
public:
property IDictionary^ Data {
   IDictionary^ get();
}

See Also

TmsAnnotationBadActivateCodeException Class | TmsAnnotationBadActivateCodeException Members


GetBaseException Method

TmsAnnotationBadActivateCodeException Class | TmsAnnotationBadActivateCodeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetBaseException Method

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadActivateCodeException Class : GetBaseException Method (TmsAnnotationBadActivateCodeException)

When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.

[Visual Basic]
Public Function GetBaseException() As Exception
[C#]
public Exception GetBaseException();
[C++]
public: Exception* GetBaseException();
[C++/CLI]
public:
Exception^ GetBaseException();

Return Type

The first exception thrown in a chain of exceptions. If the InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

See Also

TmsAnnotationBadActivateCodeException Class | TmsAnnotationBadActivateCodeException Members


GetObjectData Method

TmsAnnotationBadActivateCodeException Class | TmsAnnotationBadActivateCodeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetObjectData Method

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadActivateCodeException Class : GetObjectData Method (TmsAnnotationBadActivateCodeException)

When overridden in a derived class, sets the SerializationInfo with information about the exception.

[Visual Basic]
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
[C++/CLI]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

TmsAnnotationBadActivateCodeException Class | TmsAnnotationBadActivateCodeException Members


GetType Method

TmsAnnotationBadActivateCodeException Class | TmsAnnotationBadActivateCodeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetType Method

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadActivateCodeException Class : GetType Method (TmsAnnotationBadActivateCodeException)

Gets the runtime type of the current instance.

[Visual Basic]
Public Function GetType() As Type
[C#]
public Type GetType();
[C++]
public: Type* GetType();
[C++/CLI]
public:
Type^ GetType();

Return Type

A Type object that represents the exact runtime type of the current instance.

See Also

TmsAnnotationBadActivateCodeException Class | TmsAnnotationBadActivateCodeException Members


HelpLink Property

TmsAnnotationBadActivateCodeException Class | TmsAnnotationBadActivateCodeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HelpLink Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadActivateCodeException Class : HelpLink Property (TmsAnnotationBadActivateCodeException)

Gets or sets a link to the help file associated with this exception.

[Visual Basic]
Public Property HelpLink As String
[C#]
public string HelpLink {get; set;}
[C++]
public: __property string* get_HelpLink();
public: __property void set_HelpLink(
   string* value
);
[C++/CLI]
public:
property String^ HelpLink {
   String^ get();
   void set (String^ value);
}

See Also

TmsAnnotationBadActivateCodeException Class | TmsAnnotationBadActivateCodeException Members


InnerException Property

TmsAnnotationBadActivateCodeException Class | TmsAnnotationBadActivateCodeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InnerException Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadActivateCodeException Class : InnerException Property (TmsAnnotationBadActivateCodeException)

Gets the Exception instance that caused the current exception.

[Visual Basic]
Public ReadOnly Property InnerException As Exception
[C#]
public Exception InnerException {get;}
[C++]
public: __property Exception* get_InnerException();
[C++/CLI]
public:
property Exception^ InnerException {
   Exception^ get();
}

See Also

TmsAnnotationBadActivateCodeException Class | TmsAnnotationBadActivateCodeException Members


Message Property

TmsAnnotationBadActivateCodeException Class | TmsAnnotationBadActivateCodeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Message Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadActivateCodeException Class : Message Property (TmsAnnotationBadActivateCodeException)

Gets a message that describes the current exception.

[Visual Basic]
Public ReadOnly Property Message As String
[C#]
public string Message {get;}
[C++]
public: __property string* get_Message();
[C++/CLI]
public:
property String^ Message {
   String^ get();
}

See Also

TmsAnnotationBadActivateCodeException Class | TmsAnnotationBadActivateCodeException Members


Source Property

TmsAnnotationBadActivateCodeException Class | TmsAnnotationBadActivateCodeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Source Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadActivateCodeException Class : Source Property (TmsAnnotationBadActivateCodeException)

Gets or sets the name of the application or the object that causes the error.

[Visual Basic]
Public Property Source As String
[C#]
public string Source {get; set;}
[C++]
public: __property string* get_Source();
public: __property void set_Source(
   string* value
);
[C++/CLI]
public:
property String^ Source {
   String^ get();
   void set (String^ value);
}

See Also

TmsAnnotationBadActivateCodeException Class | TmsAnnotationBadActivateCodeException Members


StackTrace Property

TmsAnnotationBadActivateCodeException Class | TmsAnnotationBadActivateCodeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StackTrace Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadActivateCodeException Class : StackTrace Property (TmsAnnotationBadActivateCodeException)

Gets a string representation of the frames on the call stack at the time the current exception was thrown.

[Visual Basic]
Public ReadOnly Property StackTrace As String
[C#]
public string StackTrace {get;}
[C++]
public: __property string* get_StackTrace();
[C++/CLI]
public:
property String^ StackTrace {
   String^ get();
}

See Also

TmsAnnotationBadActivateCodeException Class | TmsAnnotationBadActivateCodeException Members


TargetSite Property

TmsAnnotationBadActivateCodeException Class | TmsAnnotationBadActivateCodeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TargetSite Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadActivateCodeException Class : TargetSite Property (TmsAnnotationBadActivateCodeException)

Gets the method that throws the current exception.

[Visual Basic]
Public ReadOnly Property TargetSite As MethodBase
[C#]
public MethodBase TargetSite {get;}
[C++]
public: __property MethodBase* get_TargetSite();
[C++/CLI]
public:
property MethodBase^ TargetSite {
   MethodBase^ get();
}

See Also

TmsAnnotationBadActivateCodeException Class | TmsAnnotationBadActivateCodeException Members


ToString Method

TmsAnnotationBadActivateCodeException Class | TmsAnnotationBadActivateCodeException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToString Method

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadActivateCodeException Class : ToString Method (TmsAnnotationBadActivateCodeException)

Creates and returns a string representation of the current exception.

[Visual Basic]
Public Function ToString() As String
[C#]
public string ToString();
[C++]
public: string* ToString();
[C++/CLI]
public:
String^ ToString();

Return Type

A string representation of the current exception.

See Also

TmsAnnotationBadActivateCodeException Class | TmsAnnotationBadActivateCodeException Members


TmsAnnotationBadAlignmentException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadAlignmentException Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : TmsAnnotationBadAlignmentException Class

For a list of all members of this type, see TmsAnnotationBadAlignmentException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

TmsAnnotationBadAlignmentException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


TmsAnnotationBadAlignmentException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadAlignmentException Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : TmsAnnotationBadAlignmentException Class

For a list of all members of this type, see TmsAnnotationBadAlignmentException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

TmsAnnotationBadAlignmentException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Data Property

TmsAnnotationBadAlignmentException Class | TmsAnnotationBadAlignmentException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Data Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadAlignmentException Class : Data Property (TmsAnnotationBadAlignmentException)

Gets a collection of key/value pairs that provide additional, user-defined information about the exception.

[Visual Basic]
Public ReadOnly Property Data As IDictionary
[C#]
public IDictionary Data {get;}
[C++]
public: __property IDictionary* get_Data();
[C++/CLI]
public:
property IDictionary^ Data {
   IDictionary^ get();
}

See Also

TmsAnnotationBadAlignmentException Class | TmsAnnotationBadAlignmentException Members


GetBaseException Method

TmsAnnotationBadAlignmentException Class | TmsAnnotationBadAlignmentException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetBaseException Method

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadAlignmentException Class : GetBaseException Method (TmsAnnotationBadAlignmentException)

When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.

[Visual Basic]
Public Function GetBaseException() As Exception
[C#]
public Exception GetBaseException();
[C++]
public: Exception* GetBaseException();
[C++/CLI]
public:
Exception^ GetBaseException();

Return Type

The first exception thrown in a chain of exceptions. If the InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

See Also

TmsAnnotationBadAlignmentException Class | TmsAnnotationBadAlignmentException Members


GetObjectData Method

TmsAnnotationBadAlignmentException Class | TmsAnnotationBadAlignmentException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetObjectData Method

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadAlignmentException Class : GetObjectData Method (TmsAnnotationBadAlignmentException)

When overridden in a derived class, sets the SerializationInfo with information about the exception.

[Visual Basic]
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
[C++/CLI]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

TmsAnnotationBadAlignmentException Class | TmsAnnotationBadAlignmentException Members


GetType Method

TmsAnnotationBadAlignmentException Class | TmsAnnotationBadAlignmentException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetType Method

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadAlignmentException Class : GetType Method (TmsAnnotationBadAlignmentException)

Gets the runtime type of the current instance.

[Visual Basic]
Public Function GetType() As Type
[C#]
public Type GetType();
[C++]
public: Type* GetType();
[C++/CLI]
public:
Type^ GetType();

Return Type

A Type object that represents the exact runtime type of the current instance.

See Also

TmsAnnotationBadAlignmentException Class | TmsAnnotationBadAlignmentException Members


HelpLink Property

TmsAnnotationBadAlignmentException Class | TmsAnnotationBadAlignmentException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HelpLink Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadAlignmentException Class : HelpLink Property (TmsAnnotationBadAlignmentException)

Gets or sets a link to the help file associated with this exception.

[Visual Basic]
Public Property HelpLink As String
[C#]
public string HelpLink {get; set;}
[C++]
public: __property string* get_HelpLink();
public: __property void set_HelpLink(
   string* value
);
[C++/CLI]
public:
property String^ HelpLink {
   String^ get();
   void set (String^ value);
}

See Also

TmsAnnotationBadAlignmentException Class | TmsAnnotationBadAlignmentException Members


InnerException Property

TmsAnnotationBadAlignmentException Class | TmsAnnotationBadAlignmentException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InnerException Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadAlignmentException Class : InnerException Property (TmsAnnotationBadAlignmentException)

Gets the Exception instance that caused the current exception.

[Visual Basic]
Public ReadOnly Property InnerException As Exception
[C#]
public Exception InnerException {get;}
[C++]
public: __property Exception* get_InnerException();
[C++/CLI]
public:
property Exception^ InnerException {
   Exception^ get();
}

See Also

TmsAnnotationBadAlignmentException Class | TmsAnnotationBadAlignmentException Members


Message Property

TmsAnnotationBadAlignmentException Class | TmsAnnotationBadAlignmentException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Message Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadAlignmentException Class : Message Property (TmsAnnotationBadAlignmentException)

Gets a message that describes the current exception.

[Visual Basic]
Public ReadOnly Property Message As String
[C#]
public string Message {get;}
[C++]
public: __property string* get_Message();
[C++/CLI]
public:
property String^ Message {
   String^ get();
}

See Also

TmsAnnotationBadAlignmentException Class | TmsAnnotationBadAlignmentException Members


Source Property

TmsAnnotationBadAlignmentException Class | TmsAnnotationBadAlignmentException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Source Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadAlignmentException Class : Source Property (TmsAnnotationBadAlignmentException)

Gets or sets the name of the application or the object that causes the error.

[Visual Basic]
Public Property Source As String
[C#]
public string Source {get; set;}
[C++]
public: __property string* get_Source();
public: __property void set_Source(
   string* value
);
[C++/CLI]
public:
property String^ Source {
   String^ get();
   void set (String^ value);
}

See Also

TmsAnnotationBadAlignmentException Class | TmsAnnotationBadAlignmentException Members


StackTrace Property

TmsAnnotationBadAlignmentException Class | TmsAnnotationBadAlignmentException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StackTrace Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadAlignmentException Class : StackTrace Property (TmsAnnotationBadAlignmentException)

Gets a string representation of the frames on the call stack at the time the current exception was thrown.

[Visual Basic]
Public ReadOnly Property StackTrace As String
[C#]
public string StackTrace {get;}
[C++]
public: __property string* get_StackTrace();
[C++/CLI]
public:
property String^ StackTrace {
   String^ get();
}

See Also

TmsAnnotationBadAlignmentException Class | TmsAnnotationBadAlignmentException Members


TargetSite Property

TmsAnnotationBadAlignmentException Class | TmsAnnotationBadAlignmentException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TargetSite Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadAlignmentException Class : TargetSite Property (TmsAnnotationBadAlignmentException)

Gets the method that throws the current exception.

[Visual Basic]
Public ReadOnly Property TargetSite As MethodBase
[C#]
public MethodBase TargetSite {get;}
[C++]
public: __property MethodBase* get_TargetSite();
[C++/CLI]
public:
property MethodBase^ TargetSite {
   MethodBase^ get();
}

See Also

TmsAnnotationBadAlignmentException Class | TmsAnnotationBadAlignmentException Members


ToString Method

TmsAnnotationBadAlignmentException Class | TmsAnnotationBadAlignmentException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToString Method

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadAlignmentException Class : ToString Method (TmsAnnotationBadAlignmentException)

Creates and returns a string representation of the current exception.

[Visual Basic]
Public Function ToString() As String
[C#]
public string ToString();
[C++]
public: string* ToString();
[C++/CLI]
public:
String^ ToString();

Return Type

A string representation of the current exception.

See Also

TmsAnnotationBadAlignmentException Class | TmsAnnotationBadAlignmentException Members


TmsAnnotationBadArrowsException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadArrowsException Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : TmsAnnotationBadArrowsException Class

For a list of all members of this type, see TmsAnnotationBadArrowsException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

TmsAnnotationBadArrowsException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


TmsAnnotationBadArrowsException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadArrowsException Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : TmsAnnotationBadArrowsException Class

For a list of all members of this type, see TmsAnnotationBadArrowsException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

TmsAnnotationBadArrowsException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Data Property

TmsAnnotationBadArrowsException Class | TmsAnnotationBadArrowsException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Data Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadArrowsException Class : Data Property (TmsAnnotationBadArrowsException)

Gets a collection of key/value pairs that provide additional, user-defined information about the exception.

[Visual Basic]
Public ReadOnly Property Data As IDictionary
[C#]
public IDictionary Data {get;}
[C++]
public: __property IDictionary* get_Data();
[C++/CLI]
public:
property IDictionary^ Data {
   IDictionary^ get();
}

See Also

TmsAnnotationBadArrowsException Class | TmsAnnotationBadArrowsException Members


GetBaseException Method

TmsAnnotationBadArrowsException Class | TmsAnnotationBadArrowsException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetBaseException Method

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadArrowsException Class : GetBaseException Method (TmsAnnotationBadArrowsException)

When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.

[Visual Basic]
Public Function GetBaseException() As Exception
[C#]
public Exception GetBaseException();
[C++]
public: Exception* GetBaseException();
[C++/CLI]
public:
Exception^ GetBaseException();

Return Type

The first exception thrown in a chain of exceptions. If the InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

See Also

TmsAnnotationBadArrowsException Class | TmsAnnotationBadArrowsException Members


GetObjectData Method

TmsAnnotationBadArrowsException Class | TmsAnnotationBadArrowsException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetObjectData Method

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadArrowsException Class : GetObjectData Method (TmsAnnotationBadArrowsException)

When overridden in a derived class, sets the SerializationInfo with information about the exception.

[Visual Basic]
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
[C++/CLI]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

TmsAnnotationBadArrowsException Class | TmsAnnotationBadArrowsException Members


GetType Method

TmsAnnotationBadArrowsException Class | TmsAnnotationBadArrowsException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetType Method

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadArrowsException Class : GetType Method (TmsAnnotationBadArrowsException)

Gets the runtime type of the current instance.

[Visual Basic]
Public Function GetType() As Type
[C#]
public Type GetType();
[C++]
public: Type* GetType();
[C++/CLI]
public:
Type^ GetType();

Return Type

A Type object that represents the exact runtime type of the current instance.

See Also

TmsAnnotationBadArrowsException Class | TmsAnnotationBadArrowsException Members


HelpLink Property

TmsAnnotationBadArrowsException Class | TmsAnnotationBadArrowsException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HelpLink Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadArrowsException Class : HelpLink Property (TmsAnnotationBadArrowsException)

Gets or sets a link to the help file associated with this exception.

[Visual Basic]
Public Property HelpLink As String
[C#]
public string HelpLink {get; set;}
[C++]
public: __property string* get_HelpLink();
public: __property void set_HelpLink(
   string* value
);
[C++/CLI]
public:
property String^ HelpLink {
   String^ get();
   void set (String^ value);
}

See Also

TmsAnnotationBadArrowsException Class | TmsAnnotationBadArrowsException Members


InnerException Property

TmsAnnotationBadArrowsException Class | TmsAnnotationBadArrowsException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InnerException Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadArrowsException Class : InnerException Property (TmsAnnotationBadArrowsException)

Gets the Exception instance that caused the current exception.

[Visual Basic]
Public ReadOnly Property InnerException As Exception
[C#]
public Exception InnerException {get;}
[C++]
public: __property Exception* get_InnerException();
[C++/CLI]
public:
property Exception^ InnerException {
   Exception^ get();
}

See Also

TmsAnnotationBadArrowsException Class | TmsAnnotationBadArrowsException Members


Message Property

TmsAnnotationBadArrowsException Class | TmsAnnotationBadArrowsException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Message Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadArrowsException Class : Message Property (TmsAnnotationBadArrowsException)

Gets a message that describes the current exception.

[Visual Basic]
Public ReadOnly Property Message As String
[C#]
public string Message {get;}
[C++]
public: __property string* get_Message();
[C++/CLI]
public:
property String^ Message {
   String^ get();
}

See Also

TmsAnnotationBadArrowsException Class | TmsAnnotationBadArrowsException Members


Source Property

TmsAnnotationBadArrowsException Class | TmsAnnotationBadArrowsException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Source Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadArrowsException Class : Source Property (TmsAnnotationBadArrowsException)

Gets or sets the name of the application or the object that causes the error.

[Visual Basic]
Public Property Source As String
[C#]
public string Source {get; set;}
[C++]
public: __property string* get_Source();
public: __property void set_Source(
   string* value
);
[C++/CLI]
public:
property String^ Source {
   String^ get();
   void set (String^ value);
}

See Also

TmsAnnotationBadArrowsException Class | TmsAnnotationBadArrowsException Members


StackTrace Property

TmsAnnotationBadArrowsException Class | TmsAnnotationBadArrowsException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StackTrace Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadArrowsException Class : StackTrace Property (TmsAnnotationBadArrowsException)

Gets a string representation of the frames on the call stack at the time the current exception was thrown.

[Visual Basic]
Public ReadOnly Property StackTrace As String
[C#]
public string StackTrace {get;}
[C++]
public: __property string* get_StackTrace();
[C++/CLI]
public:
property String^ StackTrace {
   String^ get();
}

See Also

TmsAnnotationBadArrowsException Class | TmsAnnotationBadArrowsException Members


TargetSite Property

TmsAnnotationBadArrowsException Class | TmsAnnotationBadArrowsException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TargetSite Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadArrowsException Class : TargetSite Property (TmsAnnotationBadArrowsException)

Gets the method that throws the current exception.

[Visual Basic]
Public ReadOnly Property TargetSite As MethodBase
[C#]
public MethodBase TargetSite {get;}
[C++]
public: __property MethodBase* get_TargetSite();
[C++/CLI]
public:
property MethodBase^ TargetSite {
   MethodBase^ get();
}

See Also

TmsAnnotationBadArrowsException Class | TmsAnnotationBadArrowsException Members


ToString Method

TmsAnnotationBadArrowsException Class | TmsAnnotationBadArrowsException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToString Method

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadArrowsException Class : ToString Method (TmsAnnotationBadArrowsException)

Creates and returns a string representation of the current exception.

[Visual Basic]
Public Function ToString() As String
[C#]
public string ToString();
[C++]
public: string* ToString();
[C++/CLI]
public:
String^ ToString();

Return Type

A string representation of the current exception.

See Also

TmsAnnotationBadArrowsException Class | TmsAnnotationBadArrowsException Members


TmsAnnotationBadBorderStyleException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadBorderStyleException Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : TmsAnnotationBadBorderStyleException Class

For a list of all members of this type, see TmsAnnotationBadBorderStyleException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

TmsAnnotationBadBorderStyleException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


TmsAnnotationBadBorderStyleException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadBorderStyleException Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : TmsAnnotationBadBorderStyleException Class

For a list of all members of this type, see TmsAnnotationBadBorderStyleException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

TmsAnnotationBadBorderStyleException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Data Property

TmsAnnotationBadBorderStyleException Class | TmsAnnotationBadBorderStyleException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Data Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadBorderStyleException Class : Data Property (TmsAnnotationBadBorderStyleException)

Gets a collection of key/value pairs that provide additional, user-defined information about the exception.

[Visual Basic]
Public ReadOnly Property Data As IDictionary
[C#]
public IDictionary Data {get;}
[C++]
public: __property IDictionary* get_Data();
[C++/CLI]
public:
property IDictionary^ Data {
   IDictionary^ get();
}

See Also

TmsAnnotationBadBorderStyleException Class | TmsAnnotationBadBorderStyleException Members


GetBaseException Method

TmsAnnotationBadBorderStyleException Class | TmsAnnotationBadBorderStyleException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetBaseException Method

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadBorderStyleException Class : GetBaseException Method (TmsAnnotationBadBorderStyleException)

When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.

[Visual Basic]
Public Function GetBaseException() As Exception
[C#]
public Exception GetBaseException();
[C++]
public: Exception* GetBaseException();
[C++/CLI]
public:
Exception^ GetBaseException();

Return Type

The first exception thrown in a chain of exceptions. If the InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

See Also

TmsAnnotationBadBorderStyleException Class | TmsAnnotationBadBorderStyleException Members


GetObjectData Method

TmsAnnotationBadBorderStyleException Class | TmsAnnotationBadBorderStyleException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetObjectData Method

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadBorderStyleException Class : GetObjectData Method (TmsAnnotationBadBorderStyleException)

When overridden in a derived class, sets the SerializationInfo with information about the exception.

[Visual Basic]
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
[C++/CLI]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

TmsAnnotationBadBorderStyleException Class | TmsAnnotationBadBorderStyleException Members


GetType Method

TmsAnnotationBadBorderStyleException Class | TmsAnnotationBadBorderStyleException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetType Method

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadBorderStyleException Class : GetType Method (TmsAnnotationBadBorderStyleException)

Gets the runtime type of the current instance.

[Visual Basic]
Public Function GetType() As Type
[C#]
public Type GetType();
[C++]
public: Type* GetType();
[C++/CLI]
public:
Type^ GetType();

Return Type

A Type object that represents the exact runtime type of the current instance.

See Also

TmsAnnotationBadBorderStyleException Class | TmsAnnotationBadBorderStyleException Members


HelpLink Property

TmsAnnotationBadBorderStyleException Class | TmsAnnotationBadBorderStyleException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HelpLink Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadBorderStyleException Class : HelpLink Property (TmsAnnotationBadBorderStyleException)

Gets or sets a link to the help file associated with this exception.

[Visual Basic]
Public Property HelpLink As String
[C#]
public string HelpLink {get; set;}
[C++]
public: __property string* get_HelpLink();
public: __property void set_HelpLink(
   string* value
);
[C++/CLI]
public:
property String^ HelpLink {
   String^ get();
   void set (String^ value);
}

See Also

TmsAnnotationBadBorderStyleException Class | TmsAnnotationBadBorderStyleException Members


InnerException Property

TmsAnnotationBadBorderStyleException Class | TmsAnnotationBadBorderStyleException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InnerException Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadBorderStyleException Class : InnerException Property (TmsAnnotationBadBorderStyleException)

Gets the Exception instance that caused the current exception.

[Visual Basic]
Public ReadOnly Property InnerException As Exception
[C#]
public Exception InnerException {get;}
[C++]
public: __property Exception* get_InnerException();
[C++/CLI]
public:
property Exception^ InnerException {
   Exception^ get();
}

See Also

TmsAnnotationBadBorderStyleException Class | TmsAnnotationBadBorderStyleException Members


Message Property

TmsAnnotationBadBorderStyleException Class | TmsAnnotationBadBorderStyleException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Message Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadBorderStyleException Class : Message Property (TmsAnnotationBadBorderStyleException)

Gets a message that describes the current exception.

[Visual Basic]
Public ReadOnly Property Message As String
[C#]
public string Message {get;}
[C++]
public: __property string* get_Message();
[C++/CLI]
public:
property String^ Message {
   String^ get();
}

See Also

TmsAnnotationBadBorderStyleException Class | TmsAnnotationBadBorderStyleException Members


Source Property

TmsAnnotationBadBorderStyleException Class | TmsAnnotationBadBorderStyleException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Source Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadBorderStyleException Class : Source Property (TmsAnnotationBadBorderStyleException)

Gets or sets the name of the application or the object that causes the error.

[Visual Basic]
Public Property Source As String
[C#]
public string Source {get; set;}
[C++]
public: __property string* get_Source();
public: __property void set_Source(
   string* value
);
[C++/CLI]
public:
property String^ Source {
   String^ get();
   void set (String^ value);
}

See Also

TmsAnnotationBadBorderStyleException Class | TmsAnnotationBadBorderStyleException Members


StackTrace Property

TmsAnnotationBadBorderStyleException Class | TmsAnnotationBadBorderStyleException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StackTrace Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadBorderStyleException Class : StackTrace Property (TmsAnnotationBadBorderStyleException)

Gets a string representation of the frames on the call stack at the time the current exception was thrown.

[Visual Basic]
Public ReadOnly Property StackTrace As String
[C#]
public string StackTrace {get;}
[C++]
public: __property string* get_StackTrace();
[C++/CLI]
public:
property String^ StackTrace {
   String^ get();
}

See Also

TmsAnnotationBadBorderStyleException Class | TmsAnnotationBadBorderStyleException Members


TargetSite Property

TmsAnnotationBadBorderStyleException Class | TmsAnnotationBadBorderStyleException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TargetSite Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadBorderStyleException Class : TargetSite Property (TmsAnnotationBadBorderStyleException)

Gets the method that throws the current exception.

[Visual Basic]
Public ReadOnly Property TargetSite As MethodBase
[C#]
public MethodBase TargetSite {get;}
[C++]
public: __property MethodBase* get_TargetSite();
[C++/CLI]
public:
property MethodBase^ TargetSite {
   MethodBase^ get();
}

See Also

TmsAnnotationBadBorderStyleException Class | TmsAnnotationBadBorderStyleException Members


ToString Method

TmsAnnotationBadBorderStyleException Class | TmsAnnotationBadBorderStyleException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToString Method

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadBorderStyleException Class : ToString Method (TmsAnnotationBadBorderStyleException)

Creates and returns a string representation of the current exception.

[Visual Basic]
Public Function ToString() As String
[C#]
public string ToString();
[C++]
public: string* ToString();
[C++/CLI]
public:
String^ ToString();

Return Type

A string representation of the current exception.

See Also

TmsAnnotationBadBorderStyleException Class | TmsAnnotationBadBorderStyleException Members


TmsAnnotationBadColorMapFlagException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadColorMapFlagException Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : TmsAnnotationBadColorMapFlagException Class

For a list of all members of this type, see TmsAnnotationBadColorMapFlagException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

TmsAnnotationBadColorMapFlagException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


TmsAnnotationBadColorMapFlagException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadColorMapFlagException Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : TmsAnnotationBadColorMapFlagException Class

For a list of all members of this type, see TmsAnnotationBadColorMapFlagException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

TmsAnnotationBadColorMapFlagException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Data Property

TmsAnnotationBadColorMapFlagException Class | TmsAnnotationBadColorMapFlagException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Data Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadColorMapFlagException Class : Data Property (TmsAnnotationBadColorMapFlagException)

Gets a collection of key/value pairs that provide additional, user-defined information about the exception.

[Visual Basic]
Public ReadOnly Property Data As IDictionary
[C#]
public IDictionary Data {get;}
[C++]
public: __property IDictionary* get_Data();
[C++/CLI]
public:
property IDictionary^ Data {
   IDictionary^ get();
}

See Also

TmsAnnotationBadColorMapFlagException Class | TmsAnnotationBadColorMapFlagException Members


GetBaseException Method

TmsAnnotationBadColorMapFlagException Class | TmsAnnotationBadColorMapFlagException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetBaseException Method

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadColorMapFlagException Class : GetBaseException Method (TmsAnnotationBadColorMapFlagException)

When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.

[Visual Basic]
Public Function GetBaseException() As Exception
[C#]
public Exception GetBaseException();
[C++]
public: Exception* GetBaseException();
[C++/CLI]
public:
Exception^ GetBaseException();

Return Type

The first exception thrown in a chain of exceptions. If the InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

See Also

TmsAnnotationBadColorMapFlagException Class | TmsAnnotationBadColorMapFlagException Members


GetObjectData Method

TmsAnnotationBadColorMapFlagException Class | TmsAnnotationBadColorMapFlagException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetObjectData Method

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadColorMapFlagException Class : GetObjectData Method (TmsAnnotationBadColorMapFlagException)

When overridden in a derived class, sets the SerializationInfo with information about the exception.

[Visual Basic]
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
[C++/CLI]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

TmsAnnotationBadColorMapFlagException Class | TmsAnnotationBadColorMapFlagException Members


GetType Method

TmsAnnotationBadColorMapFlagException Class | TmsAnnotationBadColorMapFlagException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetType Method

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadColorMapFlagException Class : GetType Method (TmsAnnotationBadColorMapFlagException)

Gets the runtime type of the current instance.

[Visual Basic]
Public Function GetType() As Type
[C#]
public Type GetType();
[C++]
public: Type* GetType();
[C++/CLI]
public:
Type^ GetType();

Return Type

A Type object that represents the exact runtime type of the current instance.

See Also

TmsAnnotationBadColorMapFlagException Class | TmsAnnotationBadColorMapFlagException Members


HelpLink Property

TmsAnnotationBadColorMapFlagException Class | TmsAnnotationBadColorMapFlagException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HelpLink Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadColorMapFlagException Class : HelpLink Property (TmsAnnotationBadColorMapFlagException)

Gets or sets a link to the help file associated with this exception.

[Visual Basic]
Public Property HelpLink As String
[C#]
public string HelpLink {get; set;}
[C++]
public: __property string* get_HelpLink();
public: __property void set_HelpLink(
   string* value
);
[C++/CLI]
public:
property String^ HelpLink {
   String^ get();
   void set (String^ value);
}

See Also

TmsAnnotationBadColorMapFlagException Class | TmsAnnotationBadColorMapFlagException Members


InnerException Property

TmsAnnotationBadColorMapFlagException Class | TmsAnnotationBadColorMapFlagException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InnerException Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadColorMapFlagException Class : InnerException Property (TmsAnnotationBadColorMapFlagException)

Gets the Exception instance that caused the current exception.

[Visual Basic]
Public ReadOnly Property InnerException As Exception
[C#]
public Exception InnerException {get;}
[C++]
public: __property Exception* get_InnerException();
[C++/CLI]
public:
property Exception^ InnerException {
   Exception^ get();
}

See Also

TmsAnnotationBadColorMapFlagException Class | TmsAnnotationBadColorMapFlagException Members


Message Property

TmsAnnotationBadColorMapFlagException Class | TmsAnnotationBadColorMapFlagException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Message Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadColorMapFlagException Class : Message Property (TmsAnnotationBadColorMapFlagException)

Gets a message that describes the current exception.

[Visual Basic]
Public ReadOnly Property Message As String
[C#]
public string Message {get;}
[C++]
public: __property string* get_Message();
[C++/CLI]
public:
property String^ Message {
   String^ get();
}

See Also

TmsAnnotationBadColorMapFlagException Class | TmsAnnotationBadColorMapFlagException Members


Source Property

TmsAnnotationBadColorMapFlagException Class | TmsAnnotationBadColorMapFlagException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Source Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadColorMapFlagException Class : Source Property (TmsAnnotationBadColorMapFlagException)

Gets or sets the name of the application or the object that causes the error.

[Visual Basic]
Public Property Source As String
[C#]
public string Source {get; set;}
[C++]
public: __property string* get_Source();
public: __property void set_Source(
   string* value
);
[C++/CLI]
public:
property String^ Source {
   String^ get();
   void set (String^ value);
}

See Also

TmsAnnotationBadColorMapFlagException Class | TmsAnnotationBadColorMapFlagException Members


StackTrace Property

TmsAnnotationBadColorMapFlagException Class | TmsAnnotationBadColorMapFlagException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StackTrace Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadColorMapFlagException Class : StackTrace Property (TmsAnnotationBadColorMapFlagException)

Gets a string representation of the frames on the call stack at the time the current exception was thrown.

[Visual Basic]
Public ReadOnly Property StackTrace As String
[C#]
public string StackTrace {get;}
[C++]
public: __property string* get_StackTrace();
[C++/CLI]
public:
property String^ StackTrace {
   String^ get();
}

See Also

TmsAnnotationBadColorMapFlagException Class | TmsAnnotationBadColorMapFlagException Members


TargetSite Property

TmsAnnotationBadColorMapFlagException Class | TmsAnnotationBadColorMapFlagException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TargetSite Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadColorMapFlagException Class : TargetSite Property (TmsAnnotationBadColorMapFlagException)

Gets the method that throws the current exception.

[Visual Basic]
Public ReadOnly Property TargetSite As MethodBase
[C#]
public MethodBase TargetSite {get;}
[C++]
public: __property MethodBase* get_TargetSite();
[C++/CLI]
public:
property MethodBase^ TargetSite {
   MethodBase^ get();
}

See Also

TmsAnnotationBadColorMapFlagException Class | TmsAnnotationBadColorMapFlagException Members


ToString Method

TmsAnnotationBadColorMapFlagException Class | TmsAnnotationBadColorMapFlagException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToString Method

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadColorMapFlagException Class : ToString Method (TmsAnnotationBadColorMapFlagException)

Creates and returns a string representation of the current exception.

[Visual Basic]
Public Function ToString() As String
[C#]
public string ToString();
[C++]
public: string* ToString();
[C++/CLI]
public:
String^ ToString();

Return Type

A string representation of the current exception.

See Also

TmsAnnotationBadColorMapFlagException Class | TmsAnnotationBadColorMapFlagException Members


TmsAnnotationBadCoordinateException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadCoordinateException Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : TmsAnnotationBadCoordinateException Class

For a list of all members of this type, see TmsAnnotationBadCoordinateException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

TmsAnnotationBadCoordinateException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


TmsAnnotationBadCoordinateException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadCoordinateException Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : TmsAnnotationBadCoordinateException Class

For a list of all members of this type, see TmsAnnotationBadCoordinateException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

TmsAnnotationBadCoordinateException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Data Property

TmsAnnotationBadCoordinateException Class | TmsAnnotationBadCoordinateException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Data Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadCoordinateException Class : Data Property (TmsAnnotationBadCoordinateException)

Gets a collection of key/value pairs that provide additional, user-defined information about the exception.

[Visual Basic]
Public ReadOnly Property Data As IDictionary
[C#]
public IDictionary Data {get;}
[C++]
public: __property IDictionary* get_Data();
[C++/CLI]
public:
property IDictionary^ Data {
   IDictionary^ get();
}

See Also

TmsAnnotationBadCoordinateException Class | TmsAnnotationBadCoordinateException Members


GetBaseException Method

TmsAnnotationBadCoordinateException Class | TmsAnnotationBadCoordinateException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetBaseException Method

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadCoordinateException Class : GetBaseException Method (TmsAnnotationBadCoordinateException)

When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.

[Visual Basic]
Public Function GetBaseException() As Exception
[C#]
public Exception GetBaseException();
[C++]
public: Exception* GetBaseException();
[C++/CLI]
public:
Exception^ GetBaseException();

Return Type

The first exception thrown in a chain of exceptions. If the InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

See Also

TmsAnnotationBadCoordinateException Class | TmsAnnotationBadCoordinateException Members


GetObjectData Method

TmsAnnotationBadCoordinateException Class | TmsAnnotationBadCoordinateException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetObjectData Method

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadCoordinateException Class : GetObjectData Method (TmsAnnotationBadCoordinateException)

When overridden in a derived class, sets the SerializationInfo with information about the exception.

[Visual Basic]
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
[C++/CLI]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

TmsAnnotationBadCoordinateException Class | TmsAnnotationBadCoordinateException Members


GetType Method

TmsAnnotationBadCoordinateException Class | TmsAnnotationBadCoordinateException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetType Method

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadCoordinateException Class : GetType Method (TmsAnnotationBadCoordinateException)

Gets the runtime type of the current instance.

[Visual Basic]
Public Function GetType() As Type
[C#]
public Type GetType();
[C++]
public: Type* GetType();
[C++/CLI]
public:
Type^ GetType();

Return Type

A Type object that represents the exact runtime type of the current instance.

See Also

TmsAnnotationBadCoordinateException Class | TmsAnnotationBadCoordinateException Members


HelpLink Property

TmsAnnotationBadCoordinateException Class | TmsAnnotationBadCoordinateException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HelpLink Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadCoordinateException Class : HelpLink Property (TmsAnnotationBadCoordinateException)

Gets or sets a link to the help file associated with this exception.

[Visual Basic]
Public Property HelpLink As String
[C#]
public string HelpLink {get; set;}
[C++]
public: __property string* get_HelpLink();
public: __property void set_HelpLink(
   string* value
);
[C++/CLI]
public:
property String^ HelpLink {
   String^ get();
   void set (String^ value);
}

See Also

TmsAnnotationBadCoordinateException Class | TmsAnnotationBadCoordinateException Members


InnerException Property

TmsAnnotationBadCoordinateException Class | TmsAnnotationBadCoordinateException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InnerException Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadCoordinateException Class : InnerException Property (TmsAnnotationBadCoordinateException)

Gets the Exception instance that caused the current exception.

[Visual Basic]
Public ReadOnly Property InnerException As Exception
[C#]
public Exception InnerException {get;}
[C++]
public: __property Exception* get_InnerException();
[C++/CLI]
public:
property Exception^ InnerException {
   Exception^ get();
}

See Also

TmsAnnotationBadCoordinateException Class | TmsAnnotationBadCoordinateException Members


Message Property

TmsAnnotationBadCoordinateException Class | TmsAnnotationBadCoordinateException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Message Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadCoordinateException Class : Message Property (TmsAnnotationBadCoordinateException)

Gets a message that describes the current exception.

[Visual Basic]
Public ReadOnly Property Message As String
[C#]
public string Message {get;}
[C++]
public: __property string* get_Message();
[C++/CLI]
public:
property String^ Message {
   String^ get();
}

See Also

TmsAnnotationBadCoordinateException Class | TmsAnnotationBadCoordinateException Members


Source Property

TmsAnnotationBadCoordinateException Class | TmsAnnotationBadCoordinateException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Source Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadCoordinateException Class : Source Property (TmsAnnotationBadCoordinateException)

Gets or sets the name of the application or the object that causes the error.

[Visual Basic]
Public Property Source As String
[C#]
public string Source {get; set;}
[C++]
public: __property string* get_Source();
public: __property void set_Source(
   string* value
);
[C++/CLI]
public:
property String^ Source {
   String^ get();
   void set (String^ value);
}

See Also

TmsAnnotationBadCoordinateException Class | TmsAnnotationBadCoordinateException Members


StackTrace Property

TmsAnnotationBadCoordinateException Class | TmsAnnotationBadCoordinateException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StackTrace Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadCoordinateException Class : StackTrace Property (TmsAnnotationBadCoordinateException)

Gets a string representation of the frames on the call stack at the time the current exception was thrown.

[Visual Basic]
Public ReadOnly Property StackTrace As String
[C#]
public string StackTrace {get;}
[C++]
public: __property string* get_StackTrace();
[C++/CLI]
public:
property String^ StackTrace {
   String^ get();
}

See Also

TmsAnnotationBadCoordinateException Class | TmsAnnotationBadCoordinateException Members


TargetSite Property

TmsAnnotationBadCoordinateException Class | TmsAnnotationBadCoordinateException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TargetSite Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadCoordinateException Class : TargetSite Property (TmsAnnotationBadCoordinateException)

Gets the method that throws the current exception.

[Visual Basic]
Public ReadOnly Property TargetSite As MethodBase
[C#]
public MethodBase TargetSite {get;}
[C++]
public: __property MethodBase* get_TargetSite();
[C++/CLI]
public:
property MethodBase^ TargetSite {
   MethodBase^ get();
}

See Also

TmsAnnotationBadCoordinateException Class | TmsAnnotationBadCoordinateException Members


ToString Method

TmsAnnotationBadCoordinateException Class | TmsAnnotationBadCoordinateException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToString Method

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadCoordinateException Class : ToString Method (TmsAnnotationBadCoordinateException)

Creates and returns a string representation of the current exception.

[Visual Basic]
Public Function ToString() As String
[C#]
public string ToString();
[C++]
public: string* ToString();
[C++/CLI]
public:
String^ ToString();

Return Type

A string representation of the current exception.

See Also

TmsAnnotationBadCoordinateException Class | TmsAnnotationBadCoordinateException Members


TmsAnnotationBadDirectionException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadDirectionException Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : TmsAnnotationBadDirectionException Class

For a list of all members of this type, see TmsAnnotationBadDirectionException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

TmsAnnotationBadDirectionException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


TmsAnnotationBadDirectionException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadDirectionException Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : TmsAnnotationBadDirectionException Class

For a list of all members of this type, see TmsAnnotationBadDirectionException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

TmsAnnotationBadDirectionException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Data Property

TmsAnnotationBadDirectionException Class | TmsAnnotationBadDirectionException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Data Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadDirectionException Class : Data Property (TmsAnnotationBadDirectionException)

Gets a collection of key/value pairs that provide additional, user-defined information about the exception.

[Visual Basic]
Public ReadOnly Property Data As IDictionary
[C#]
public IDictionary Data {get;}
[C++]
public: __property IDictionary* get_Data();
[C++/CLI]
public:
property IDictionary^ Data {
   IDictionary^ get();
}

See Also

TmsAnnotationBadDirectionException Class | TmsAnnotationBadDirectionException Members


GetBaseException Method

TmsAnnotationBadDirectionException Class | TmsAnnotationBadDirectionException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetBaseException Method

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadDirectionException Class : GetBaseException Method (TmsAnnotationBadDirectionException)

When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.

[Visual Basic]
Public Function GetBaseException() As Exception
[C#]
public Exception GetBaseException();
[C++]
public: Exception* GetBaseException();
[C++/CLI]
public:
Exception^ GetBaseException();

Return Type

The first exception thrown in a chain of exceptions. If the InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

See Also

TmsAnnotationBadDirectionException Class | TmsAnnotationBadDirectionException Members


GetObjectData Method

TmsAnnotationBadDirectionException Class | TmsAnnotationBadDirectionException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetObjectData Method

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadDirectionException Class : GetObjectData Method (TmsAnnotationBadDirectionException)

When overridden in a derived class, sets the SerializationInfo with information about the exception.

[Visual Basic]
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
[C++/CLI]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

TmsAnnotationBadDirectionException Class | TmsAnnotationBadDirectionException Members


GetType Method

TmsAnnotationBadDirectionException Class | TmsAnnotationBadDirectionException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetType Method

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadDirectionException Class : GetType Method (TmsAnnotationBadDirectionException)

Gets the runtime type of the current instance.

[Visual Basic]
Public Function GetType() As Type
[C#]
public Type GetType();
[C++]
public: Type* GetType();
[C++/CLI]
public:
Type^ GetType();

Return Type

A Type object that represents the exact runtime type of the current instance.

See Also

TmsAnnotationBadDirectionException Class | TmsAnnotationBadDirectionException Members


HelpLink Property

TmsAnnotationBadDirectionException Class | TmsAnnotationBadDirectionException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HelpLink Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadDirectionException Class : HelpLink Property (TmsAnnotationBadDirectionException)

Gets or sets a link to the help file associated with this exception.

[Visual Basic]
Public Property HelpLink As String
[C#]
public string HelpLink {get; set;}
[C++]
public: __property string* get_HelpLink();
public: __property void set_HelpLink(
   string* value
);
[C++/CLI]
public:
property String^ HelpLink {
   String^ get();
   void set (String^ value);
}

See Also

TmsAnnotationBadDirectionException Class | TmsAnnotationBadDirectionException Members


InnerException Property

TmsAnnotationBadDirectionException Class | TmsAnnotationBadDirectionException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InnerException Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadDirectionException Class : InnerException Property (TmsAnnotationBadDirectionException)

Gets the Exception instance that caused the current exception.

[Visual Basic]
Public ReadOnly Property InnerException As Exception
[C#]
public Exception InnerException {get;}
[C++]
public: __property Exception* get_InnerException();
[C++/CLI]
public:
property Exception^ InnerException {
   Exception^ get();
}

See Also

TmsAnnotationBadDirectionException Class | TmsAnnotationBadDirectionException Members


Message Property

TmsAnnotationBadDirectionException Class | TmsAnnotationBadDirectionException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Message Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadDirectionException Class : Message Property (TmsAnnotationBadDirectionException)

Gets a message that describes the current exception.

[Visual Basic]
Public ReadOnly Property Message As String
[C#]
public string Message {get;}
[C++]
public: __property string* get_Message();
[C++/CLI]
public:
property String^ Message {
   String^ get();
}

See Also

TmsAnnotationBadDirectionException Class | TmsAnnotationBadDirectionException Members


Source Property

TmsAnnotationBadDirectionException Class | TmsAnnotationBadDirectionException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Source Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadDirectionException Class : Source Property (TmsAnnotationBadDirectionException)

Gets or sets the name of the application or the object that causes the error.

[Visual Basic]
Public Property Source As String
[C#]
public string Source {get; set;}
[C++]
public: __property string* get_Source();
public: __property void set_Source(
   string* value
);
[C++/CLI]
public:
property String^ Source {
   String^ get();
   void set (String^ value);
}

See Also

TmsAnnotationBadDirectionException Class | TmsAnnotationBadDirectionException Members


StackTrace Property

TmsAnnotationBadDirectionException Class | TmsAnnotationBadDirectionException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StackTrace Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadDirectionException Class : StackTrace Property (TmsAnnotationBadDirectionException)

Gets a string representation of the frames on the call stack at the time the current exception was thrown.

[Visual Basic]
Public ReadOnly Property StackTrace As String
[C#]
public string StackTrace {get;}
[C++]
public: __property string* get_StackTrace();
[C++/CLI]
public:
property String^ StackTrace {
   String^ get();
}

See Also

TmsAnnotationBadDirectionException Class | TmsAnnotationBadDirectionException Members


TargetSite Property

TmsAnnotationBadDirectionException Class | TmsAnnotationBadDirectionException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TargetSite Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadDirectionException Class : TargetSite Property (TmsAnnotationBadDirectionException)

Gets the method that throws the current exception.

[Visual Basic]
Public ReadOnly Property TargetSite As MethodBase
[C#]
public MethodBase TargetSite {get;}
[C++]
public: __property MethodBase* get_TargetSite();
[C++/CLI]
public:
property MethodBase^ TargetSite {
   MethodBase^ get();
}

See Also

TmsAnnotationBadDirectionException Class | TmsAnnotationBadDirectionException Members


ToString Method

TmsAnnotationBadDirectionException Class | TmsAnnotationBadDirectionException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToString Method

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadDirectionException Class : ToString Method (TmsAnnotationBadDirectionException)

Creates and returns a string representation of the current exception.

[Visual Basic]
Public Function ToString() As String
[C#]
public string ToString();
[C++]
public: string* ToString();
[C++/CLI]
public:
String^ ToString();

Return Type

A string representation of the current exception.

See Also

TmsAnnotationBadDirectionException Class | TmsAnnotationBadDirectionException Members


TmsAnnotationBadHeaderException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadHeaderException Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : TmsAnnotationBadHeaderException Class

For a list of all members of this type, see TmsAnnotationBadHeaderException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

TmsAnnotationBadHeaderException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


TmsAnnotationBadHeaderException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadHeaderException Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : TmsAnnotationBadHeaderException Class

For a list of all members of this type, see TmsAnnotationBadHeaderException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

TmsAnnotationBadHeaderException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Data Property

TmsAnnotationBadHeaderException Class | TmsAnnotationBadHeaderException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Data Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadHeaderException Class : Data Property (TmsAnnotationBadHeaderException)

Gets a collection of key/value pairs that provide additional, user-defined information about the exception.

[Visual Basic]
Public ReadOnly Property Data As IDictionary
[C#]
public IDictionary Data {get;}
[C++]
public: __property IDictionary* get_Data();
[C++/CLI]
public:
property IDictionary^ Data {
   IDictionary^ get();
}

See Also

TmsAnnotationBadHeaderException Class | TmsAnnotationBadHeaderException Members


GetBaseException Method

TmsAnnotationBadHeaderException Class | TmsAnnotationBadHeaderException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetBaseException Method

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadHeaderException Class : GetBaseException Method (TmsAnnotationBadHeaderException)

When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.

[Visual Basic]
Public Function GetBaseException() As Exception
[C#]
public Exception GetBaseException();
[C++]
public: Exception* GetBaseException();
[C++/CLI]
public:
Exception^ GetBaseException();

Return Type

The first exception thrown in a chain of exceptions. If the InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

See Also

TmsAnnotationBadHeaderException Class | TmsAnnotationBadHeaderException Members


GetObjectData Method

TmsAnnotationBadHeaderException Class | TmsAnnotationBadHeaderException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetObjectData Method

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadHeaderException Class : GetObjectData Method (TmsAnnotationBadHeaderException)

When overridden in a derived class, sets the SerializationInfo with information about the exception.

[Visual Basic]
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
[C++/CLI]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

TmsAnnotationBadHeaderException Class | TmsAnnotationBadHeaderException Members


GetType Method

TmsAnnotationBadHeaderException Class | TmsAnnotationBadHeaderException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetType Method

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadHeaderException Class : GetType Method (TmsAnnotationBadHeaderException)

Gets the runtime type of the current instance.

[Visual Basic]
Public Function GetType() As Type
[C#]
public Type GetType();
[C++]
public: Type* GetType();
[C++/CLI]
public:
Type^ GetType();

Return Type

A Type object that represents the exact runtime type of the current instance.

See Also

TmsAnnotationBadHeaderException Class | TmsAnnotationBadHeaderException Members


HelpLink Property

TmsAnnotationBadHeaderException Class | TmsAnnotationBadHeaderException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HelpLink Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadHeaderException Class : HelpLink Property (TmsAnnotationBadHeaderException)

Gets or sets a link to the help file associated with this exception.

[Visual Basic]
Public Property HelpLink As String
[C#]
public string HelpLink {get; set;}
[C++]
public: __property string* get_HelpLink();
public: __property void set_HelpLink(
   string* value
);
[C++/CLI]
public:
property String^ HelpLink {
   String^ get();
   void set (String^ value);
}

See Also

TmsAnnotationBadHeaderException Class | TmsAnnotationBadHeaderException Members


InnerException Property

TmsAnnotationBadHeaderException Class | TmsAnnotationBadHeaderException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InnerException Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadHeaderException Class : InnerException Property (TmsAnnotationBadHeaderException)

Gets the Exception instance that caused the current exception.

[Visual Basic]
Public ReadOnly Property InnerException As Exception
[C#]
public Exception InnerException {get;}
[C++]
public: __property Exception* get_InnerException();
[C++/CLI]
public:
property Exception^ InnerException {
   Exception^ get();
}

See Also

TmsAnnotationBadHeaderException Class | TmsAnnotationBadHeaderException Members


Message Property

TmsAnnotationBadHeaderException Class | TmsAnnotationBadHeaderException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Message Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadHeaderException Class : Message Property (TmsAnnotationBadHeaderException)

Gets a message that describes the current exception.

[Visual Basic]
Public ReadOnly Property Message As String
[C#]
public string Message {get;}
[C++]
public: __property string* get_Message();
[C++/CLI]
public:
property String^ Message {
   String^ get();
}

See Also

TmsAnnotationBadHeaderException Class | TmsAnnotationBadHeaderException Members


Source Property

TmsAnnotationBadHeaderException Class | TmsAnnotationBadHeaderException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Source Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadHeaderException Class : Source Property (TmsAnnotationBadHeaderException)

Gets or sets the name of the application or the object that causes the error.

[Visual Basic]
Public Property Source As String
[C#]
public string Source {get; set;}
[C++]
public: __property string* get_Source();
public: __property void set_Source(
   string* value
);
[C++/CLI]
public:
property String^ Source {
   String^ get();
   void set (String^ value);
}

See Also

TmsAnnotationBadHeaderException Class | TmsAnnotationBadHeaderException Members


StackTrace Property

TmsAnnotationBadHeaderException Class | TmsAnnotationBadHeaderException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StackTrace Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadHeaderException Class : StackTrace Property (TmsAnnotationBadHeaderException)

Gets a string representation of the frames on the call stack at the time the current exception was thrown.

[Visual Basic]
Public ReadOnly Property StackTrace As String
[C#]
public string StackTrace {get;}
[C++]
public: __property string* get_StackTrace();
[C++/CLI]
public:
property String^ StackTrace {
   String^ get();
}

See Also

TmsAnnotationBadHeaderException Class | TmsAnnotationBadHeaderException Members


TargetSite Property

TmsAnnotationBadHeaderException Class | TmsAnnotationBadHeaderException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TargetSite Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadHeaderException Class : TargetSite Property (TmsAnnotationBadHeaderException)

Gets the method that throws the current exception.

[Visual Basic]
Public ReadOnly Property TargetSite As MethodBase
[C#]
public MethodBase TargetSite {get;}
[C++]
public: __property MethodBase* get_TargetSite();
[C++/CLI]
public:
property MethodBase^ TargetSite {
   MethodBase^ get();
}

See Also

TmsAnnotationBadHeaderException Class | TmsAnnotationBadHeaderException Members


ToString Method

TmsAnnotationBadHeaderException Class | TmsAnnotationBadHeaderException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToString Method

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadHeaderException Class : ToString Method (TmsAnnotationBadHeaderException)

Creates and returns a string representation of the current exception.

[Visual Basic]
Public Function ToString() As String
[C#]
public string ToString();
[C++]
public: string* ToString();
[C++/CLI]
public:
String^ ToString();

Return Type

A string representation of the current exception.

See Also

TmsAnnotationBadHeaderException Class | TmsAnnotationBadHeaderException Members


TmsAnnotationBadRecordException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadRecordException Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : TmsAnnotationBadRecordException Class

For a list of all members of this type, see TmsAnnotationBadRecordException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

TmsAnnotationBadRecordException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


TmsAnnotationBadRecordException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadRecordException Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : TmsAnnotationBadRecordException Class

For a list of all members of this type, see TmsAnnotationBadRecordException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

TmsAnnotationBadRecordException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Data Property

TmsAnnotationBadRecordException Class | TmsAnnotationBadRecordException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Data Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadRecordException Class : Data Property (TmsAnnotationBadRecordException)

Gets a collection of key/value pairs that provide additional, user-defined information about the exception.

[Visual Basic]
Public ReadOnly Property Data As IDictionary
[C#]
public IDictionary Data {get;}
[C++]
public: __property IDictionary* get_Data();
[C++/CLI]
public:
property IDictionary^ Data {
   IDictionary^ get();
}

See Also

TmsAnnotationBadRecordException Class | TmsAnnotationBadRecordException Members


GetBaseException Method

TmsAnnotationBadRecordException Class | TmsAnnotationBadRecordException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetBaseException Method

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadRecordException Class : GetBaseException Method (TmsAnnotationBadRecordException)

When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.

[Visual Basic]
Public Function GetBaseException() As Exception
[C#]
public Exception GetBaseException();
[C++]
public: Exception* GetBaseException();
[C++/CLI]
public:
Exception^ GetBaseException();

Return Type

The first exception thrown in a chain of exceptions. If the InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

See Also

TmsAnnotationBadRecordException Class | TmsAnnotationBadRecordException Members


GetObjectData Method

TmsAnnotationBadRecordException Class | TmsAnnotationBadRecordException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetObjectData Method

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadRecordException Class : GetObjectData Method (TmsAnnotationBadRecordException)

When overridden in a derived class, sets the SerializationInfo with information about the exception.

[Visual Basic]
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
[C++/CLI]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

TmsAnnotationBadRecordException Class | TmsAnnotationBadRecordException Members


GetType Method

TmsAnnotationBadRecordException Class | TmsAnnotationBadRecordException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetType Method

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadRecordException Class : GetType Method (TmsAnnotationBadRecordException)

Gets the runtime type of the current instance.

[Visual Basic]
Public Function GetType() As Type
[C#]
public Type GetType();
[C++]
public: Type* GetType();
[C++/CLI]
public:
Type^ GetType();

Return Type

A Type object that represents the exact runtime type of the current instance.

See Also

TmsAnnotationBadRecordException Class | TmsAnnotationBadRecordException Members


HelpLink Property

TmsAnnotationBadRecordException Class | TmsAnnotationBadRecordException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HelpLink Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadRecordException Class : HelpLink Property (TmsAnnotationBadRecordException)

Gets or sets a link to the help file associated with this exception.

[Visual Basic]
Public Property HelpLink As String
[C#]
public string HelpLink {get; set;}
[C++]
public: __property string* get_HelpLink();
public: __property void set_HelpLink(
   string* value
);
[C++/CLI]
public:
property String^ HelpLink {
   String^ get();
   void set (String^ value);
}

See Also

TmsAnnotationBadRecordException Class | TmsAnnotationBadRecordException Members


InnerException Property

TmsAnnotationBadRecordException Class | TmsAnnotationBadRecordException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InnerException Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadRecordException Class : InnerException Property (TmsAnnotationBadRecordException)

Gets the Exception instance that caused the current exception.

[Visual Basic]
Public ReadOnly Property InnerException As Exception
[C#]
public Exception InnerException {get;}
[C++]
public: __property Exception* get_InnerException();
[C++/CLI]
public:
property Exception^ InnerException {
   Exception^ get();
}

See Also

TmsAnnotationBadRecordException Class | TmsAnnotationBadRecordException Members


Message Property

TmsAnnotationBadRecordException Class | TmsAnnotationBadRecordException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Message Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadRecordException Class : Message Property (TmsAnnotationBadRecordException)

Gets a message that describes the current exception.

[Visual Basic]
Public ReadOnly Property Message As String
[C#]
public string Message {get;}
[C++]
public: __property string* get_Message();
[C++/CLI]
public:
property String^ Message {
   String^ get();
}

See Also

TmsAnnotationBadRecordException Class | TmsAnnotationBadRecordException Members


Source Property

TmsAnnotationBadRecordException Class | TmsAnnotationBadRecordException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Source Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadRecordException Class : Source Property (TmsAnnotationBadRecordException)

Gets or sets the name of the application or the object that causes the error.

[Visual Basic]
Public Property Source As String
[C#]
public string Source {get; set;}
[C++]
public: __property string* get_Source();
public: __property void set_Source(
   string* value
);
[C++/CLI]
public:
property String^ Source {
   String^ get();
   void set (String^ value);
}

See Also

TmsAnnotationBadRecordException Class | TmsAnnotationBadRecordException Members


StackTrace Property

TmsAnnotationBadRecordException Class | TmsAnnotationBadRecordException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StackTrace Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadRecordException Class : StackTrace Property (TmsAnnotationBadRecordException)

Gets a string representation of the frames on the call stack at the time the current exception was thrown.

[Visual Basic]
Public ReadOnly Property StackTrace As String
[C#]
public string StackTrace {get;}
[C++]
public: __property string* get_StackTrace();
[C++/CLI]
public:
property String^ StackTrace {
   String^ get();
}

See Also

TmsAnnotationBadRecordException Class | TmsAnnotationBadRecordException Members


TargetSite Property

TmsAnnotationBadRecordException Class | TmsAnnotationBadRecordException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TargetSite Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadRecordException Class : TargetSite Property (TmsAnnotationBadRecordException)

Gets the method that throws the current exception.

[Visual Basic]
Public ReadOnly Property TargetSite As MethodBase
[C#]
public MethodBase TargetSite {get;}
[C++]
public: __property MethodBase* get_TargetSite();
[C++/CLI]
public:
property MethodBase^ TargetSite {
   MethodBase^ get();
}

See Also

TmsAnnotationBadRecordException Class | TmsAnnotationBadRecordException Members


ToString Method

TmsAnnotationBadRecordException Class | TmsAnnotationBadRecordException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToString Method

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadRecordException Class : ToString Method (TmsAnnotationBadRecordException)

Creates and returns a string representation of the current exception.

[Visual Basic]
Public Function ToString() As String
[C#]
public string ToString();
[C++]
public: string* ToString();
[C++/CLI]
public:
String^ ToString();

Return Type

A string representation of the current exception.

See Also

TmsAnnotationBadRecordException Class | TmsAnnotationBadRecordException Members


TmsAnnotationBadRedactionFlagException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadRedactionFlagException Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : TmsAnnotationBadRedactionFlagException Class

For a list of all members of this type, see TmsAnnotationBadRedactionFlagException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

TmsAnnotationBadRedactionFlagException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


TmsAnnotationBadRedactionFlagException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadRedactionFlagException Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : TmsAnnotationBadRedactionFlagException Class

For a list of all members of this type, see TmsAnnotationBadRedactionFlagException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

TmsAnnotationBadRedactionFlagException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Data Property

TmsAnnotationBadRedactionFlagException Class | TmsAnnotationBadRedactionFlagException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Data Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadRedactionFlagException Class : Data Property (TmsAnnotationBadRedactionFlagException)

Gets a collection of key/value pairs that provide additional, user-defined information about the exception.

[Visual Basic]
Public ReadOnly Property Data As IDictionary
[C#]
public IDictionary Data {get;}
[C++]
public: __property IDictionary* get_Data();
[C++/CLI]
public:
property IDictionary^ Data {
   IDictionary^ get();
}

See Also

TmsAnnotationBadRedactionFlagException Class | TmsAnnotationBadRedactionFlagException Members


GetBaseException Method

TmsAnnotationBadRedactionFlagException Class | TmsAnnotationBadRedactionFlagException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetBaseException Method

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadRedactionFlagException Class : GetBaseException Method (TmsAnnotationBadRedactionFlagException)

When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.

[Visual Basic]
Public Function GetBaseException() As Exception
[C#]
public Exception GetBaseException();
[C++]
public: Exception* GetBaseException();
[C++/CLI]
public:
Exception^ GetBaseException();

Return Type

The first exception thrown in a chain of exceptions. If the InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

See Also

TmsAnnotationBadRedactionFlagException Class | TmsAnnotationBadRedactionFlagException Members


GetObjectData Method

TmsAnnotationBadRedactionFlagException Class | TmsAnnotationBadRedactionFlagException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetObjectData Method

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadRedactionFlagException Class : GetObjectData Method (TmsAnnotationBadRedactionFlagException)

When overridden in a derived class, sets the SerializationInfo with information about the exception.

[Visual Basic]
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
[C++/CLI]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

TmsAnnotationBadRedactionFlagException Class | TmsAnnotationBadRedactionFlagException Members


GetType Method

TmsAnnotationBadRedactionFlagException Class | TmsAnnotationBadRedactionFlagException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetType Method

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadRedactionFlagException Class : GetType Method (TmsAnnotationBadRedactionFlagException)

Gets the runtime type of the current instance.

[Visual Basic]
Public Function GetType() As Type
[C#]
public Type GetType();
[C++]
public: Type* GetType();
[C++/CLI]
public:
Type^ GetType();

Return Type

A Type object that represents the exact runtime type of the current instance.

See Also

TmsAnnotationBadRedactionFlagException Class | TmsAnnotationBadRedactionFlagException Members


HelpLink Property

TmsAnnotationBadRedactionFlagException Class | TmsAnnotationBadRedactionFlagException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HelpLink Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadRedactionFlagException Class : HelpLink Property (TmsAnnotationBadRedactionFlagException)

Gets or sets a link to the help file associated with this exception.

[Visual Basic]
Public Property HelpLink As String
[C#]
public string HelpLink {get; set;}
[C++]
public: __property string* get_HelpLink();
public: __property void set_HelpLink(
   string* value
);
[C++/CLI]
public:
property String^ HelpLink {
   String^ get();
   void set (String^ value);
}

See Also

TmsAnnotationBadRedactionFlagException Class | TmsAnnotationBadRedactionFlagException Members


InnerException Property

TmsAnnotationBadRedactionFlagException Class | TmsAnnotationBadRedactionFlagException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InnerException Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadRedactionFlagException Class : InnerException Property (TmsAnnotationBadRedactionFlagException)

Gets the Exception instance that caused the current exception.

[Visual Basic]
Public ReadOnly Property InnerException As Exception
[C#]
public Exception InnerException {get;}
[C++]
public: __property Exception* get_InnerException();
[C++/CLI]
public:
property Exception^ InnerException {
   Exception^ get();
}

See Also

TmsAnnotationBadRedactionFlagException Class | TmsAnnotationBadRedactionFlagException Members


Message Property

TmsAnnotationBadRedactionFlagException Class | TmsAnnotationBadRedactionFlagException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Message Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadRedactionFlagException Class : Message Property (TmsAnnotationBadRedactionFlagException)

Gets a message that describes the current exception.

[Visual Basic]
Public ReadOnly Property Message As String
[C#]
public string Message {get;}
[C++]
public: __property string* get_Message();
[C++/CLI]
public:
property String^ Message {
   String^ get();
}

See Also

TmsAnnotationBadRedactionFlagException Class | TmsAnnotationBadRedactionFlagException Members


Source Property

TmsAnnotationBadRedactionFlagException Class | TmsAnnotationBadRedactionFlagException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Source Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadRedactionFlagException Class : Source Property (TmsAnnotationBadRedactionFlagException)

Gets or sets the name of the application or the object that causes the error.

[Visual Basic]
Public Property Source As String
[C#]
public string Source {get; set;}
[C++]
public: __property string* get_Source();
public: __property void set_Source(
   string* value
);
[C++/CLI]
public:
property String^ Source {
   String^ get();
   void set (String^ value);
}

See Also

TmsAnnotationBadRedactionFlagException Class | TmsAnnotationBadRedactionFlagException Members


StackTrace Property

TmsAnnotationBadRedactionFlagException Class | TmsAnnotationBadRedactionFlagException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StackTrace Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadRedactionFlagException Class : StackTrace Property (TmsAnnotationBadRedactionFlagException)

Gets a string representation of the frames on the call stack at the time the current exception was thrown.

[Visual Basic]
Public ReadOnly Property StackTrace As String
[C#]
public string StackTrace {get;}
[C++]
public: __property string* get_StackTrace();
[C++/CLI]
public:
property String^ StackTrace {
   String^ get();
}

See Also

TmsAnnotationBadRedactionFlagException Class | TmsAnnotationBadRedactionFlagException Members


TargetSite Property

TmsAnnotationBadRedactionFlagException Class | TmsAnnotationBadRedactionFlagException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TargetSite Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadRedactionFlagException Class : TargetSite Property (TmsAnnotationBadRedactionFlagException)

Gets the method that throws the current exception.

[Visual Basic]
Public ReadOnly Property TargetSite As MethodBase
[C#]
public MethodBase TargetSite {get;}
[C++]
public: __property MethodBase* get_TargetSite();
[C++/CLI]
public:
property MethodBase^ TargetSite {
   MethodBase^ get();
}

See Also

TmsAnnotationBadRedactionFlagException Class | TmsAnnotationBadRedactionFlagException Members


ToString Method

TmsAnnotationBadRedactionFlagException Class | TmsAnnotationBadRedactionFlagException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToString Method

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadRedactionFlagException Class : ToString Method (TmsAnnotationBadRedactionFlagException)

Creates and returns a string representation of the current exception.

[Visual Basic]
Public Function ToString() As String
[C#]
public string ToString();
[C++]
public: string* ToString();
[C++/CLI]
public:
String^ ToString();

Return Type

A string representation of the current exception.

See Also

TmsAnnotationBadRedactionFlagException Class | TmsAnnotationBadRedactionFlagException Members


TmsAnnotationBadTransparentFlagException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadTransparentFlagException Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : TmsAnnotationBadTransparentFlagException Class

For a list of all members of this type, see TmsAnnotationBadTransparentFlagException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

TmsAnnotationBadTransparentFlagException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


TmsAnnotationBadTransparentFlagException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadTransparentFlagException Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : TmsAnnotationBadTransparentFlagException Class

For a list of all members of this type, see TmsAnnotationBadTransparentFlagException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

TmsAnnotationBadTransparentFlagException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Data Property

TmsAnnotationBadTransparentFlagException Class | TmsAnnotationBadTransparentFlagException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Data Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadTransparentFlagException Class : Data Property (TmsAnnotationBadTransparentFlagException)

Gets a collection of key/value pairs that provide additional, user-defined information about the exception.

[Visual Basic]
Public ReadOnly Property Data As IDictionary
[C#]
public IDictionary Data {get;}
[C++]
public: __property IDictionary* get_Data();
[C++/CLI]
public:
property IDictionary^ Data {
   IDictionary^ get();
}

See Also

TmsAnnotationBadTransparentFlagException Class | TmsAnnotationBadTransparentFlagException Members


GetBaseException Method

TmsAnnotationBadTransparentFlagException Class | TmsAnnotationBadTransparentFlagException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetBaseException Method

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadTransparentFlagException Class : GetBaseException Method (TmsAnnotationBadTransparentFlagException)

When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.

[Visual Basic]
Public Function GetBaseException() As Exception
[C#]
public Exception GetBaseException();
[C++]
public: Exception* GetBaseException();
[C++/CLI]
public:
Exception^ GetBaseException();

Return Type

The first exception thrown in a chain of exceptions. If the InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

See Also

TmsAnnotationBadTransparentFlagException Class | TmsAnnotationBadTransparentFlagException Members


GetObjectData Method

TmsAnnotationBadTransparentFlagException Class | TmsAnnotationBadTransparentFlagException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetObjectData Method

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadTransparentFlagException Class : GetObjectData Method (TmsAnnotationBadTransparentFlagException)

When overridden in a derived class, sets the SerializationInfo with information about the exception.

[Visual Basic]
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
[C++/CLI]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

TmsAnnotationBadTransparentFlagException Class | TmsAnnotationBadTransparentFlagException Members


GetType Method

TmsAnnotationBadTransparentFlagException Class | TmsAnnotationBadTransparentFlagException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetType Method

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadTransparentFlagException Class : GetType Method (TmsAnnotationBadTransparentFlagException)

Gets the runtime type of the current instance.

[Visual Basic]
Public Function GetType() As Type
[C#]
public Type GetType();
[C++]
public: Type* GetType();
[C++/CLI]
public:
Type^ GetType();

Return Type

A Type object that represents the exact runtime type of the current instance.

See Also

TmsAnnotationBadTransparentFlagException Class | TmsAnnotationBadTransparentFlagException Members


HelpLink Property

TmsAnnotationBadTransparentFlagException Class | TmsAnnotationBadTransparentFlagException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HelpLink Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadTransparentFlagException Class : HelpLink Property (TmsAnnotationBadTransparentFlagException)

Gets or sets a link to the help file associated with this exception.

[Visual Basic]
Public Property HelpLink As String
[C#]
public string HelpLink {get; set;}
[C++]
public: __property string* get_HelpLink();
public: __property void set_HelpLink(
   string* value
);
[C++/CLI]
public:
property String^ HelpLink {
   String^ get();
   void set (String^ value);
}

See Also

TmsAnnotationBadTransparentFlagException Class | TmsAnnotationBadTransparentFlagException Members


InnerException Property

TmsAnnotationBadTransparentFlagException Class | TmsAnnotationBadTransparentFlagException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InnerException Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadTransparentFlagException Class : InnerException Property (TmsAnnotationBadTransparentFlagException)

Gets the Exception instance that caused the current exception.

[Visual Basic]
Public ReadOnly Property InnerException As Exception
[C#]
public Exception InnerException {get;}
[C++]
public: __property Exception* get_InnerException();
[C++/CLI]
public:
property Exception^ InnerException {
   Exception^ get();
}

See Also

TmsAnnotationBadTransparentFlagException Class | TmsAnnotationBadTransparentFlagException Members


Message Property

TmsAnnotationBadTransparentFlagException Class | TmsAnnotationBadTransparentFlagException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Message Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadTransparentFlagException Class : Message Property (TmsAnnotationBadTransparentFlagException)

Gets a message that describes the current exception.

[Visual Basic]
Public ReadOnly Property Message As String
[C#]
public string Message {get;}
[C++]
public: __property string* get_Message();
[C++/CLI]
public:
property String^ Message {
   String^ get();
}

See Also

TmsAnnotationBadTransparentFlagException Class | TmsAnnotationBadTransparentFlagException Members


Source Property

TmsAnnotationBadTransparentFlagException Class | TmsAnnotationBadTransparentFlagException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Source Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadTransparentFlagException Class : Source Property (TmsAnnotationBadTransparentFlagException)

Gets or sets the name of the application or the object that causes the error.

[Visual Basic]
Public Property Source As String
[C#]
public string Source {get; set;}
[C++]
public: __property string* get_Source();
public: __property void set_Source(
   string* value
);
[C++/CLI]
public:
property String^ Source {
   String^ get();
   void set (String^ value);
}

See Also

TmsAnnotationBadTransparentFlagException Class | TmsAnnotationBadTransparentFlagException Members


StackTrace Property

TmsAnnotationBadTransparentFlagException Class | TmsAnnotationBadTransparentFlagException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StackTrace Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadTransparentFlagException Class : StackTrace Property (TmsAnnotationBadTransparentFlagException)

Gets a string representation of the frames on the call stack at the time the current exception was thrown.

[Visual Basic]
Public ReadOnly Property StackTrace As String
[C#]
public string StackTrace {get;}
[C++]
public: __property string* get_StackTrace();
[C++/CLI]
public:
property String^ StackTrace {
   String^ get();
}

See Also

TmsAnnotationBadTransparentFlagException Class | TmsAnnotationBadTransparentFlagException Members


TargetSite Property

TmsAnnotationBadTransparentFlagException Class | TmsAnnotationBadTransparentFlagException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TargetSite Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadTransparentFlagException Class : TargetSite Property (TmsAnnotationBadTransparentFlagException)

Gets the method that throws the current exception.

[Visual Basic]
Public ReadOnly Property TargetSite As MethodBase
[C#]
public MethodBase TargetSite {get;}
[C++]
public: __property MethodBase* get_TargetSite();
[C++/CLI]
public:
property MethodBase^ TargetSite {
   MethodBase^ get();
}

See Also

TmsAnnotationBadTransparentFlagException Class | TmsAnnotationBadTransparentFlagException Members


ToString Method

TmsAnnotationBadTransparentFlagException Class | TmsAnnotationBadTransparentFlagException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToString Method

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadTransparentFlagException Class : ToString Method (TmsAnnotationBadTransparentFlagException)

Creates and returns a string representation of the current exception.

[Visual Basic]
Public Function ToString() As String
[C#]
public string ToString();
[C++]
public: string* ToString();
[C++/CLI]
public:
String^ ToString();

Return Type

A string representation of the current exception.

See Also

TmsAnnotationBadTransparentFlagException Class | TmsAnnotationBadTransparentFlagException Members


TmsAnnotationBadVersionException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadVersionException Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : TmsAnnotationBadVersionException Class

For a list of all members of this type, see TmsAnnotationBadVersionException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

TmsAnnotationBadVersionException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


TmsAnnotationBadVersionException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TmsAnnotationBadVersionException Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : TmsAnnotationBadVersionException Class

For a list of all members of this type, see TmsAnnotationBadVersionException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

TmsAnnotationBadVersionException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Data Property

TmsAnnotationBadVersionException Class | TmsAnnotationBadVersionException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Data Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadVersionException Class : Data Property (TmsAnnotationBadVersionException)

Gets a collection of key/value pairs that provide additional, user-defined information about the exception.

[Visual Basic]
Public ReadOnly Property Data As IDictionary
[C#]
public IDictionary Data {get;}
[C++]
public: __property IDictionary* get_Data();
[C++/CLI]
public:
property IDictionary^ Data {
   IDictionary^ get();
}

See Also

TmsAnnotationBadVersionException Class | TmsAnnotationBadVersionException Members


GetBaseException Method

TmsAnnotationBadVersionException Class | TmsAnnotationBadVersionException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetBaseException Method

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadVersionException Class : GetBaseException Method (TmsAnnotationBadVersionException)

When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.

[Visual Basic]
Public Function GetBaseException() As Exception
[C#]
public Exception GetBaseException();
[C++]
public: Exception* GetBaseException();
[C++/CLI]
public:
Exception^ GetBaseException();

Return Type

The first exception thrown in a chain of exceptions. If the InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

See Also

TmsAnnotationBadVersionException Class | TmsAnnotationBadVersionException Members


GetObjectData Method

TmsAnnotationBadVersionException Class | TmsAnnotationBadVersionException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetObjectData Method

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadVersionException Class : GetObjectData Method (TmsAnnotationBadVersionException)

When overridden in a derived class, sets the SerializationInfo with information about the exception.

[Visual Basic]
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
[C++/CLI]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

TmsAnnotationBadVersionException Class | TmsAnnotationBadVersionException Members


GetType Method

TmsAnnotationBadVersionException Class | TmsAnnotationBadVersionException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetType Method

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadVersionException Class : GetType Method (TmsAnnotationBadVersionException)

Gets the runtime type of the current instance.

[Visual Basic]
Public Function GetType() As Type
[C#]
public Type GetType();
[C++]
public: Type* GetType();
[C++/CLI]
public:
Type^ GetType();

Return Type

A Type object that represents the exact runtime type of the current instance.

See Also

TmsAnnotationBadVersionException Class | TmsAnnotationBadVersionException Members


HelpLink Property

TmsAnnotationBadVersionException Class | TmsAnnotationBadVersionException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HelpLink Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadVersionException Class : HelpLink Property (TmsAnnotationBadVersionException)

Gets or sets a link to the help file associated with this exception.

[Visual Basic]
Public Property HelpLink As String
[C#]
public string HelpLink {get; set;}
[C++]
public: __property string* get_HelpLink();
public: __property void set_HelpLink(
   string* value
);
[C++/CLI]
public:
property String^ HelpLink {
   String^ get();
   void set (String^ value);
}

See Also

TmsAnnotationBadVersionException Class | TmsAnnotationBadVersionException Members


InnerException Property

TmsAnnotationBadVersionException Class | TmsAnnotationBadVersionException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InnerException Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadVersionException Class : InnerException Property (TmsAnnotationBadVersionException)

Gets the Exception instance that caused the current exception.

[Visual Basic]
Public ReadOnly Property InnerException As Exception
[C#]
public Exception InnerException {get;}
[C++]
public: __property Exception* get_InnerException();
[C++/CLI]
public:
property Exception^ InnerException {
   Exception^ get();
}

See Also

TmsAnnotationBadVersionException Class | TmsAnnotationBadVersionException Members


Message Property

TmsAnnotationBadVersionException Class | TmsAnnotationBadVersionException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Message Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadVersionException Class : Message Property (TmsAnnotationBadVersionException)

Gets a message that describes the current exception.

[Visual Basic]
Public ReadOnly Property Message As String
[C#]
public string Message {get;}
[C++]
public: __property string* get_Message();
[C++/CLI]
public:
property String^ Message {
   String^ get();
}

See Also

TmsAnnotationBadVersionException Class | TmsAnnotationBadVersionException Members


Source Property

TmsAnnotationBadVersionException Class | TmsAnnotationBadVersionException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Source Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadVersionException Class : Source Property (TmsAnnotationBadVersionException)

Gets or sets the name of the application or the object that causes the error.

[Visual Basic]
Public Property Source As String
[C#]
public string Source {get; set;}
[C++]
public: __property string* get_Source();
public: __property void set_Source(
   string* value
);
[C++/CLI]
public:
property String^ Source {
   String^ get();
   void set (String^ value);
}

See Also

TmsAnnotationBadVersionException Class | TmsAnnotationBadVersionException Members


StackTrace Property

TmsAnnotationBadVersionException Class | TmsAnnotationBadVersionException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StackTrace Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadVersionException Class : StackTrace Property (TmsAnnotationBadVersionException)

Gets a string representation of the frames on the call stack at the time the current exception was thrown.

[Visual Basic]
Public ReadOnly Property StackTrace As String
[C#]
public string StackTrace {get;}
[C++]
public: __property string* get_StackTrace();
[C++/CLI]
public:
property String^ StackTrace {
   String^ get();
}

See Also

TmsAnnotationBadVersionException Class | TmsAnnotationBadVersionException Members


TargetSite Property

TmsAnnotationBadVersionException Class | TmsAnnotationBadVersionException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TargetSite Property

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadVersionException Class : TargetSite Property (TmsAnnotationBadVersionException)

Gets the method that throws the current exception.

[Visual Basic]
Public ReadOnly Property TargetSite As MethodBase
[C#]
public MethodBase TargetSite {get;}
[C++]
public: __property MethodBase* get_TargetSite();
[C++/CLI]
public:
property MethodBase^ TargetSite {
   MethodBase^ get();
}

See Also

TmsAnnotationBadVersionException Class | TmsAnnotationBadVersionException Members


ToString Method

TmsAnnotationBadVersionException Class | TmsAnnotationBadVersionException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToString Method

PegasusImaging.WinForms.NotateXpress9 Namespace > TmsAnnotationBadVersionException Class : ToString Method (TmsAnnotationBadVersionException)

Creates and returns a string representation of the current exception.

[Visual Basic]
Public Function ToString() As String
[C#]
public string ToString();
[C++]
public: string* ToString();
[C++/CLI]
public:
String^ ToString();

Return Type

A string representation of the current exception.

See Also

TmsAnnotationBadVersionException Class | TmsAnnotationBadVersionException Members


Toolbar Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Toolbar Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : Toolbar Class (PegasusImaging.WinForms.NotateXpress9)

For a list of all members of this type, see Toolbar members.

Public Methods

Public Method GetToolEnabled | Returns the enabled status of the specified tool.
Public Method GetToolVisible | Determines a specific tool's visible state on the toolbar.
Public Method SetToolEnabled | Sets the enabled state of the given tool in the toolbar.
Public Method SetToolVisible | Sets the visible state of the tool.
Public Method ToolDelete | Deletes the specified tool from the toolbar.

See Also

Toolbar Class | PegasusImaging.WinForms.NotateXpress9 Namespace


ToolbarDefaults Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToolbarDefaults Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : ToolbarDefaults Class (PegasusImaging.WinForms.NotateXpress9)

For a list of all members of this type, see ToolbarDefaults members.

Public Methods

Public Method GetToolTip | Gets the tooltip for the specified tool on the toolbar.
Public Method SetToolTip | Sets the given tooltip for the given tool on the toolbar.

See Also

ToolbarDefaults Class | PegasusImaging.WinForms.NotateXpress9 Namespace


UnableLoadAnnotationDllException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

UnableLoadAnnotationDllException Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : UnableLoadAnnotationDllException Class

For a list of all members of this type, see UnableLoadAnnotationDllException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

UnableLoadAnnotationDllException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


UnableLoadAnnotationDllException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

UnableLoadAnnotationDllException Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : UnableLoadAnnotationDllException Class

For a list of all members of this type, see UnableLoadAnnotationDllException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

UnableLoadAnnotationDllException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Data Property

UnableLoadAnnotationDllException Class | UnableLoadAnnotationDllException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Data Property

PegasusImaging.WinForms.NotateXpress9 Namespace > UnableLoadAnnotationDllException Class : Data Property (UnableLoadAnnotationDllException)

Gets a collection of key/value pairs that provide additional, user-defined information about the exception.

[Visual Basic]
Public ReadOnly Property Data As IDictionary
[C#]
public IDictionary Data {get;}
[C++]
public: __property IDictionary* get_Data();
[C++/CLI]
public:
property IDictionary^ Data {
   IDictionary^ get();
}

See Also

UnableLoadAnnotationDllException Class | UnableLoadAnnotationDllException Members


GetBaseException Method

UnableLoadAnnotationDllException Class | UnableLoadAnnotationDllException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetBaseException Method

PegasusImaging.WinForms.NotateXpress9 Namespace > UnableLoadAnnotationDllException Class : GetBaseException Method (UnableLoadAnnotationDllException)

When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.

[Visual Basic]
Public Function GetBaseException() As Exception
[C#]
public Exception GetBaseException();
[C++]
public: Exception* GetBaseException();
[C++/CLI]
public:
Exception^ GetBaseException();

Return Type

The first exception thrown in a chain of exceptions. If the InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

See Also

UnableLoadAnnotationDllException Class | UnableLoadAnnotationDllException Members


GetObjectData Method

UnableLoadAnnotationDllException Class | UnableLoadAnnotationDllException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetObjectData Method

PegasusImaging.WinForms.NotateXpress9 Namespace > UnableLoadAnnotationDllException Class : GetObjectData Method (UnableLoadAnnotationDllException)

When overridden in a derived class, sets the SerializationInfo with information about the exception.

[Visual Basic]
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
[C++/CLI]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

UnableLoadAnnotationDllException Class | UnableLoadAnnotationDllException Members


GetType Method

UnableLoadAnnotationDllException Class | UnableLoadAnnotationDllException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetType Method

PegasusImaging.WinForms.NotateXpress9 Namespace > UnableLoadAnnotationDllException Class : GetType Method (UnableLoadAnnotationDllException)

Gets the runtime type of the current instance.

[Visual Basic]
Public Function GetType() As Type
[C#]
public Type GetType();
[C++]
public: Type* GetType();
[C++/CLI]
public:
Type^ GetType();

Return Type

A Type object that represents the exact runtime type of the current instance.

See Also

UnableLoadAnnotationDllException Class | UnableLoadAnnotationDllException Members


HelpLink Property

UnableLoadAnnotationDllException Class | UnableLoadAnnotationDllException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HelpLink Property

PegasusImaging.WinForms.NotateXpress9 Namespace > UnableLoadAnnotationDllException Class : HelpLink Property (UnableLoadAnnotationDllException)

Gets or sets a link to the help file associated with this exception.

[Visual Basic]
Public Property HelpLink As String
[C#]
public string HelpLink {get; set;}
[C++]
public: __property string* get_HelpLink();
public: __property void set_HelpLink(
   string* value
);
[C++/CLI]
public:
property String^ HelpLink {
   String^ get();
   void set (String^ value);
}

See Also

UnableLoadAnnotationDllException Class | UnableLoadAnnotationDllException Members


InnerException Property

UnableLoadAnnotationDllException Class | UnableLoadAnnotationDllException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InnerException Property

PegasusImaging.WinForms.NotateXpress9 Namespace > UnableLoadAnnotationDllException Class : InnerException Property (UnableLoadAnnotationDllException)

Gets the Exception instance that caused the current exception.

[Visual Basic]
Public ReadOnly Property InnerException As Exception
[C#]
public Exception InnerException {get;}
[C++]
public: __property Exception* get_InnerException();
[C++/CLI]
public:
property Exception^ InnerException {
   Exception^ get();
}

See Also

UnableLoadAnnotationDllException Class | UnableLoadAnnotationDllException Members


Message Property

UnableLoadAnnotationDllException Class | UnableLoadAnnotationDllException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Message Property

PegasusImaging.WinForms.NotateXpress9 Namespace > UnableLoadAnnotationDllException Class : Message Property (UnableLoadAnnotationDllException)

Gets a message that describes the current exception.

[Visual Basic]
Public ReadOnly Property Message As String
[C#]
public string Message {get;}
[C++]
public: __property string* get_Message();
[C++/CLI]
public:
property String^ Message {
   String^ get();
}

See Also

UnableLoadAnnotationDllException Class | UnableLoadAnnotationDllException Members


Source Property

UnableLoadAnnotationDllException Class | UnableLoadAnnotationDllException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Source Property

PegasusImaging.WinForms.NotateXpress9 Namespace > UnableLoadAnnotationDllException Class : Source Property (UnableLoadAnnotationDllException)

Gets or sets the name of the application or the object that causes the error.

[Visual Basic]
Public Property Source As String
[C#]
public string Source {get; set;}
[C++]
public: __property string* get_Source();
public: __property void set_Source(
   string* value
);
[C++/CLI]
public:
property String^ Source {
   String^ get();
   void set (String^ value);
}

See Also

UnableLoadAnnotationDllException Class | UnableLoadAnnotationDllException Members


StackTrace Property

UnableLoadAnnotationDllException Class | UnableLoadAnnotationDllException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StackTrace Property

PegasusImaging.WinForms.NotateXpress9 Namespace > UnableLoadAnnotationDllException Class : StackTrace Property (UnableLoadAnnotationDllException)

Gets a string representation of the frames on the call stack at the time the current exception was thrown.

[Visual Basic]
Public ReadOnly Property StackTrace As String
[C#]
public string StackTrace {get;}
[C++]
public: __property string* get_StackTrace();
[C++/CLI]
public:
property String^ StackTrace {
   String^ get();
}

See Also

UnableLoadAnnotationDllException Class | UnableLoadAnnotationDllException Members


TargetSite Property

UnableLoadAnnotationDllException Class | UnableLoadAnnotationDllException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TargetSite Property

PegasusImaging.WinForms.NotateXpress9 Namespace > UnableLoadAnnotationDllException Class : TargetSite Property (UnableLoadAnnotationDllException)

Gets the method that throws the current exception.

[Visual Basic]
Public ReadOnly Property TargetSite As MethodBase
[C#]
public MethodBase TargetSite {get;}
[C++]
public: __property MethodBase* get_TargetSite();
[C++/CLI]
public:
property MethodBase^ TargetSite {
   MethodBase^ get();
}

See Also

UnableLoadAnnotationDllException Class | UnableLoadAnnotationDllException Members


ToString Method

UnableLoadAnnotationDllException Class | UnableLoadAnnotationDllException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToString Method

PegasusImaging.WinForms.NotateXpress9 Namespace > UnableLoadAnnotationDllException Class : ToString Method (UnableLoadAnnotationDllException)

Creates and returns a string representation of the current exception.

[Visual Basic]
Public Function ToString() As String
[C#]
public string ToString();
[C++]
public: string* ToString();
[C++/CLI]
public:
String^ ToString();

Return Type

A string representation of the current exception.

See Also

UnableLoadAnnotationDllException Class | UnableLoadAnnotationDllException Members


UnableToCreateStorageException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

UnableToCreateStorageException Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : UnableToCreateStorageException Class

For a list of all members of this type, see UnableToCreateStorageException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

UnableToCreateStorageException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


UnableToCreateStorageException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

UnableToCreateStorageException Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : UnableToCreateStorageException Class

For a list of all members of this type, see UnableToCreateStorageException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

UnableToCreateStorageException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Data Property

UnableToCreateStorageException Class | UnableToCreateStorageException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Data Property

PegasusImaging.WinForms.NotateXpress9 Namespace > UnableToCreateStorageException Class : Data Property (UnableToCreateStorageException)

Gets a collection of key/value pairs that provide additional, user-defined information about the exception.

[Visual Basic]
Public ReadOnly Property Data As IDictionary
[C#]
public IDictionary Data {get;}
[C++]
public: __property IDictionary* get_Data();
[C++/CLI]
public:
property IDictionary^ Data {
   IDictionary^ get();
}

See Also

UnableToCreateStorageException Class | UnableToCreateStorageException Members


GetBaseException Method

UnableToCreateStorageException Class | UnableToCreateStorageException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetBaseException Method

PegasusImaging.WinForms.NotateXpress9 Namespace > UnableToCreateStorageException Class : GetBaseException Method (UnableToCreateStorageException)

When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.

[Visual Basic]
Public Function GetBaseException() As Exception
[C#]
public Exception GetBaseException();
[C++]
public: Exception* GetBaseException();
[C++/CLI]
public:
Exception^ GetBaseException();

Return Type

The first exception thrown in a chain of exceptions. If the InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

See Also

UnableToCreateStorageException Class | UnableToCreateStorageException Members


GetObjectData Method

UnableToCreateStorageException Class | UnableToCreateStorageException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetObjectData Method

PegasusImaging.WinForms.NotateXpress9 Namespace > UnableToCreateStorageException Class : GetObjectData Method (UnableToCreateStorageException)

When overridden in a derived class, sets the SerializationInfo with information about the exception.

[Visual Basic]
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
[C++/CLI]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

UnableToCreateStorageException Class | UnableToCreateStorageException Members


GetType Method

UnableToCreateStorageException Class | UnableToCreateStorageException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetType Method

PegasusImaging.WinForms.NotateXpress9 Namespace > UnableToCreateStorageException Class : GetType Method (UnableToCreateStorageException)

Gets the runtime type of the current instance.

[Visual Basic]
Public Function GetType() As Type
[C#]
public Type GetType();
[C++]
public: Type* GetType();
[C++/CLI]
public:
Type^ GetType();

Return Type

A Type object that represents the exact runtime type of the current instance.

See Also

UnableToCreateStorageException Class | UnableToCreateStorageException Members


HelpLink Property

UnableToCreateStorageException Class | UnableToCreateStorageException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HelpLink Property

PegasusImaging.WinForms.NotateXpress9 Namespace > UnableToCreateStorageException Class : HelpLink Property (UnableToCreateStorageException)

Gets or sets a link to the help file associated with this exception.

[Visual Basic]
Public Property HelpLink As String
[C#]
public string HelpLink {get; set;}
[C++]
public: __property string* get_HelpLink();
public: __property void set_HelpLink(
   string* value
);
[C++/CLI]
public:
property String^ HelpLink {
   String^ get();
   void set (String^ value);
}

See Also

UnableToCreateStorageException Class | UnableToCreateStorageException Members


InnerException Property

UnableToCreateStorageException Class | UnableToCreateStorageException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InnerException Property

PegasusImaging.WinForms.NotateXpress9 Namespace > UnableToCreateStorageException Class : InnerException Property (UnableToCreateStorageException)

Gets the Exception instance that caused the current exception.

[Visual Basic]
Public ReadOnly Property InnerException As Exception
[C#]
public Exception InnerException {get;}
[C++]
public: __property Exception* get_InnerException();
[C++/CLI]
public:
property Exception^ InnerException {
   Exception^ get();
}

See Also

UnableToCreateStorageException Class | UnableToCreateStorageException Members


Message Property

UnableToCreateStorageException Class | UnableToCreateStorageException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Message Property

PegasusImaging.WinForms.NotateXpress9 Namespace > UnableToCreateStorageException Class : Message Property (UnableToCreateStorageException)

Gets a message that describes the current exception.

[Visual Basic]
Public ReadOnly Property Message As String
[C#]
public string Message {get;}
[C++]
public: __property string* get_Message();
[C++/CLI]
public:
property String^ Message {
   String^ get();
}

See Also

UnableToCreateStorageException Class | UnableToCreateStorageException Members


Source Property

UnableToCreateStorageException Class | UnableToCreateStorageException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Source Property

PegasusImaging.WinForms.NotateXpress9 Namespace > UnableToCreateStorageException Class : Source Property (UnableToCreateStorageException)

Gets or sets the name of the application or the object that causes the error.

[Visual Basic]
Public Property Source As String
[C#]
public string Source {get; set;}
[C++]
public: __property string* get_Source();
public: __property void set_Source(
   string* value
);
[C++/CLI]
public:
property String^ Source {
   String^ get();
   void set (String^ value);
}

See Also

UnableToCreateStorageException Class | UnableToCreateStorageException Members


StackTrace Property

UnableToCreateStorageException Class | UnableToCreateStorageException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StackTrace Property

PegasusImaging.WinForms.NotateXpress9 Namespace > UnableToCreateStorageException Class : StackTrace Property (UnableToCreateStorageException)

Gets a string representation of the frames on the call stack at the time the current exception was thrown.

[Visual Basic]
Public ReadOnly Property StackTrace As String
[C#]
public string StackTrace {get;}
[C++]
public: __property string* get_StackTrace();
[C++/CLI]
public:
property String^ StackTrace {
   String^ get();
}

See Also

UnableToCreateStorageException Class | UnableToCreateStorageException Members


TargetSite Property

UnableToCreateStorageException Class | UnableToCreateStorageException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TargetSite Property

PegasusImaging.WinForms.NotateXpress9 Namespace > UnableToCreateStorageException Class : TargetSite Property (UnableToCreateStorageException)

Gets the method that throws the current exception.

[Visual Basic]
Public ReadOnly Property TargetSite As MethodBase
[C#]
public MethodBase TargetSite {get;}
[C++]
public: __property MethodBase* get_TargetSite();
[C++/CLI]
public:
property MethodBase^ TargetSite {
   MethodBase^ get();
}

See Also

UnableToCreateStorageException Class | UnableToCreateStorageException Members


ToString Method

UnableToCreateStorageException Class | UnableToCreateStorageException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToString Method

PegasusImaging.WinForms.NotateXpress9 Namespace > UnableToCreateStorageException Class : ToString Method (UnableToCreateStorageException)

Creates and returns a string representation of the current exception.

[Visual Basic]
Public Function ToString() As String
[C#]
public string ToString();
[C++]
public: string* ToString();
[C++/CLI]
public:
String^ ToString();

Return Type

A string representation of the current exception.

See Also

UnableToCreateStorageException Class | UnableToCreateStorageException Members


XmlFatalException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

XmlFatalException Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : XmlFatalException Class

For a list of all members of this type, see XmlFatalException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

XmlFatalException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


XmlFatalException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

XmlFatalException Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : XmlFatalException Class

For a list of all members of this type, see XmlFatalException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

XmlFatalException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Data Property

XmlFatalException Class | XmlFatalException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Data Property

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlFatalException Class : Data Property (XmlFatalException)

Gets a collection of key/value pairs that provide additional, user-defined information about the exception.

[Visual Basic]
Public ReadOnly Property Data As IDictionary
[C#]
public IDictionary Data {get;}
[C++]
public: __property IDictionary* get_Data();
[C++/CLI]
public:
property IDictionary^ Data {
   IDictionary^ get();
}

See Also

XmlFatalException Class | XmlFatalException Members


GetBaseException Method

XmlFatalException Class | XmlFatalException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetBaseException Method

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlFatalException Class : GetBaseException Method (XmlFatalException)

When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.

[Visual Basic]
Public Function GetBaseException() As Exception
[C#]
public Exception GetBaseException();
[C++]
public: Exception* GetBaseException();
[C++/CLI]
public:
Exception^ GetBaseException();

Return Type

The first exception thrown in a chain of exceptions. If the InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

See Also

XmlFatalException Class | XmlFatalException Members


GetObjectData Method

XmlFatalException Class | XmlFatalException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetObjectData Method

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlFatalException Class : GetObjectData Method (XmlFatalException)

When overridden in a derived class, sets the SerializationInfo with information about the exception.

[Visual Basic]
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
[C++/CLI]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

XmlFatalException Class | XmlFatalException Members


GetType Method

XmlFatalException Class | XmlFatalException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetType Method

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlFatalException Class : GetType Method (XmlFatalException)

Gets the runtime type of the current instance.

[Visual Basic]
Public Function GetType() As Type
[C#]
public Type GetType();
[C++]
public: Type* GetType();
[C++/CLI]
public:
Type^ GetType();

Return Type

A Type object that represents the exact runtime type of the current instance.

See Also

XmlFatalException Class | XmlFatalException Members


HelpLink Property

XmlFatalException Class | XmlFatalException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HelpLink Property

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlFatalException Class : HelpLink Property (XmlFatalException)

Gets or sets a link to the help file associated with this exception.

[Visual Basic]
Public Property HelpLink As String
[C#]
public string HelpLink {get; set;}
[C++]
public: __property string* get_HelpLink();
public: __property void set_HelpLink(
   string* value
);
[C++/CLI]
public:
property String^ HelpLink {
   String^ get();
   void set (String^ value);
}

See Also

XmlFatalException Class | XmlFatalException Members


InnerException Property

XmlFatalException Class | XmlFatalException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InnerException Property

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlFatalException Class : InnerException Property (XmlFatalException)

Gets the Exception instance that caused the current exception.

[Visual Basic]
Public ReadOnly Property InnerException As Exception
[C#]
public Exception InnerException {get;}
[C++]
public: __property Exception* get_InnerException();
[C++/CLI]
public:
property Exception^ InnerException {
   Exception^ get();
}

See Also

XmlFatalException Class | XmlFatalException Members


Message Property

XmlFatalException Class | XmlFatalException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Message Property

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlFatalException Class : Message Property (XmlFatalException)

Gets a message that describes the current exception.

[Visual Basic]
Public ReadOnly Property Message As String
[C#]
public string Message {get;}
[C++]
public: __property string* get_Message();
[C++/CLI]
public:
property String^ Message {
   String^ get();
}

See Also

XmlFatalException Class | XmlFatalException Members


Source Property

XmlFatalException Class | XmlFatalException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Source Property

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlFatalException Class : Source Property (XmlFatalException)

Gets or sets the name of the application or the object that causes the error.

[Visual Basic]
Public Property Source As String
[C#]
public string Source {get; set;}
[C++]
public: __property string* get_Source();
public: __property void set_Source(
   string* value
);
[C++/CLI]
public:
property String^ Source {
   String^ get();
   void set (String^ value);
}

See Also

XmlFatalException Class | XmlFatalException Members


StackTrace Property

XmlFatalException Class | XmlFatalException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StackTrace Property

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlFatalException Class : StackTrace Property (XmlFatalException)

Gets a string representation of the frames on the call stack at the time the current exception was thrown.

[Visual Basic]
Public ReadOnly Property StackTrace As String
[C#]
public string StackTrace {get;}
[C++]
public: __property string* get_StackTrace();
[C++/CLI]
public:
property String^ StackTrace {
   String^ get();
}

See Also

XmlFatalException Class | XmlFatalException Members


TargetSite Property

XmlFatalException Class | XmlFatalException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TargetSite Property

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlFatalException Class : TargetSite Property (XmlFatalException)

Gets the method that throws the current exception.

[Visual Basic]
Public ReadOnly Property TargetSite As MethodBase
[C#]
public MethodBase TargetSite {get;}
[C++]
public: __property MethodBase* get_TargetSite();
[C++/CLI]
public:
property MethodBase^ TargetSite {
   MethodBase^ get();
}

See Also

XmlFatalException Class | XmlFatalException Members


ToString Method

XmlFatalException Class | XmlFatalException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToString Method

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlFatalException Class : ToString Method (XmlFatalException)

Creates and returns a string representation of the current exception.

[Visual Basic]
Public Function ToString() As String
[C#]
public string ToString();
[C++]
public: string* ToString();
[C++/CLI]
public:
String^ ToString();

Return Type

A string representation of the current exception.

See Also

XmlFatalException Class | XmlFatalException Members


XmlGeneralException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

XmlGeneralException Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : XmlGeneralException Class

For a list of all members of this type, see XmlGeneralException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

XmlGeneralException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


XmlGeneralException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

XmlGeneralException Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : XmlGeneralException Class

For a list of all members of this type, see XmlGeneralException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

XmlGeneralException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Data Property

XmlGeneralException Class | XmlGeneralException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Data Property

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlGeneralException Class : Data Property (XmlGeneralException)

Gets a collection of key/value pairs that provide additional, user-defined information about the exception.

[Visual Basic]
Public ReadOnly Property Data As IDictionary
[C#]
public IDictionary Data {get;}
[C++]
public: __property IDictionary* get_Data();
[C++/CLI]
public:
property IDictionary^ Data {
   IDictionary^ get();
}

See Also

XmlGeneralException Class | XmlGeneralException Members


GetBaseException Method

XmlGeneralException Class | XmlGeneralException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetBaseException Method

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlGeneralException Class : GetBaseException Method (XmlGeneralException)

When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.

[Visual Basic]
Public Function GetBaseException() As Exception
[C#]
public Exception GetBaseException();
[C++]
public: Exception* GetBaseException();
[C++/CLI]
public:
Exception^ GetBaseException();

Return Type

The first exception thrown in a chain of exceptions. If the InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

See Also

XmlGeneralException Class | XmlGeneralException Members


GetObjectData Method

XmlGeneralException Class | XmlGeneralException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetObjectData Method

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlGeneralException Class : GetObjectData Method (XmlGeneralException)

When overridden in a derived class, sets the SerializationInfo with information about the exception.

[Visual Basic]
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
[C++/CLI]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

XmlGeneralException Class | XmlGeneralException Members


GetType Method

XmlGeneralException Class | XmlGeneralException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetType Method

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlGeneralException Class : GetType Method (XmlGeneralException)

Gets the runtime type of the current instance.

[Visual Basic]
Public Function GetType() As Type
[C#]
public Type GetType();
[C++]
public: Type* GetType();
[C++/CLI]
public:
Type^ GetType();

Return Type

A Type object that represents the exact runtime type of the current instance.

See Also

XmlGeneralException Class | XmlGeneralException Members


HelpLink Property

XmlGeneralException Class | XmlGeneralException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HelpLink Property

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlGeneralException Class : HelpLink Property (XmlGeneralException)

Gets or sets a link to the help file associated with this exception.

[Visual Basic]
Public Property HelpLink As String
[C#]
public string HelpLink {get; set;}
[C++]
public: __property string* get_HelpLink();
public: __property void set_HelpLink(
   string* value
);
[C++/CLI]
public:
property String^ HelpLink {
   String^ get();
   void set (String^ value);
}

See Also

XmlGeneralException Class | XmlGeneralException Members


InnerException Property

XmlGeneralException Class | XmlGeneralException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InnerException Property

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlGeneralException Class : InnerException Property (XmlGeneralException)

Gets the Exception instance that caused the current exception.

[Visual Basic]
Public ReadOnly Property InnerException As Exception
[C#]
public Exception InnerException {get;}
[C++]
public: __property Exception* get_InnerException();
[C++/CLI]
public:
property Exception^ InnerException {
   Exception^ get();
}

See Also

XmlGeneralException Class | XmlGeneralException Members


Message Property

XmlGeneralException Class | XmlGeneralException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Message Property

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlGeneralException Class : Message Property (XmlGeneralException)

Gets a message that describes the current exception.

[Visual Basic]
Public ReadOnly Property Message As String
[C#]
public string Message {get;}
[C++]
public: __property string* get_Message();
[C++/CLI]
public:
property String^ Message {
   String^ get();
}

See Also

XmlGeneralException Class | XmlGeneralException Members


Source Property

XmlGeneralException Class | XmlGeneralException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Source Property

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlGeneralException Class : Source Property (XmlGeneralException)

Gets or sets the name of the application or the object that causes the error.

[Visual Basic]
Public Property Source As String
[C#]
public string Source {get; set;}
[C++]
public: __property string* get_Source();
public: __property void set_Source(
   string* value
);
[C++/CLI]
public:
property String^ Source {
   String^ get();
   void set (String^ value);
}

See Also

XmlGeneralException Class | XmlGeneralException Members


StackTrace Property

XmlGeneralException Class | XmlGeneralException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StackTrace Property

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlGeneralException Class : StackTrace Property (XmlGeneralException)

Gets a string representation of the frames on the call stack at the time the current exception was thrown.

[Visual Basic]
Public ReadOnly Property StackTrace As String
[C#]
public string StackTrace {get;}
[C++]
public: __property string* get_StackTrace();
[C++/CLI]
public:
property String^ StackTrace {
   String^ get();
}

See Also

XmlGeneralException Class | XmlGeneralException Members


TargetSite Property

XmlGeneralException Class | XmlGeneralException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TargetSite Property

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlGeneralException Class : TargetSite Property (XmlGeneralException)

Gets the method that throws the current exception.

[Visual Basic]
Public ReadOnly Property TargetSite As MethodBase
[C#]
public MethodBase TargetSite {get;}
[C++]
public: __property MethodBase* get_TargetSite();
[C++/CLI]
public:
property MethodBase^ TargetSite {
   MethodBase^ get();
}

See Also

XmlGeneralException Class | XmlGeneralException Members


ToString Method

XmlGeneralException Class | XmlGeneralException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToString Method

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlGeneralException Class : ToString Method (XmlGeneralException)

Creates and returns a string representation of the current exception.

[Visual Basic]
Public Function ToString() As String
[C#]
public string ToString();
[C++]
public: string* ToString();
[C++/CLI]
public:
String^ ToString();

Return Type

A string representation of the current exception.

See Also

XmlGeneralException Class | XmlGeneralException Members


XmlInvalidHeaderException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

XmlInvalidHeaderException Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : XmlInvalidHeaderException Class

For a list of all members of this type, see XmlInvalidHeaderException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

XmlInvalidHeaderException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


XmlInvalidHeaderException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

XmlInvalidHeaderException Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : XmlInvalidHeaderException Class

For a list of all members of this type, see XmlInvalidHeaderException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

XmlInvalidHeaderException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Data Property

XmlInvalidHeaderException Class | XmlInvalidHeaderException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Data Property

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlInvalidHeaderException Class : Data Property (XmlInvalidHeaderException)

Gets a collection of key/value pairs that provide additional, user-defined information about the exception.

[Visual Basic]
Public ReadOnly Property Data As IDictionary
[C#]
public IDictionary Data {get;}
[C++]
public: __property IDictionary* get_Data();
[C++/CLI]
public:
property IDictionary^ Data {
   IDictionary^ get();
}

See Also

XmlInvalidHeaderException Class | XmlInvalidHeaderException Members


GetBaseException Method

XmlInvalidHeaderException Class | XmlInvalidHeaderException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetBaseException Method

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlInvalidHeaderException Class : GetBaseException Method (XmlInvalidHeaderException)

When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.

[Visual Basic]
Public Function GetBaseException() As Exception
[C#]
public Exception GetBaseException();
[C++]
public: Exception* GetBaseException();
[C++/CLI]
public:
Exception^ GetBaseException();

Return Type

The first exception thrown in a chain of exceptions. If the InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

See Also

XmlInvalidHeaderException Class | XmlInvalidHeaderException Members


GetObjectData Method

XmlInvalidHeaderException Class | XmlInvalidHeaderException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetObjectData Method

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlInvalidHeaderException Class : GetObjectData Method (XmlInvalidHeaderException)

When overridden in a derived class, sets the SerializationInfo with information about the exception.

[Visual Basic]
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
[C++/CLI]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

XmlInvalidHeaderException Class | XmlInvalidHeaderException Members


GetType Method

XmlInvalidHeaderException Class | XmlInvalidHeaderException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetType Method

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlInvalidHeaderException Class : GetType Method (XmlInvalidHeaderException)

Gets the runtime type of the current instance.

[Visual Basic]
Public Function GetType() As Type
[C#]
public Type GetType();
[C++]
public: Type* GetType();
[C++/CLI]
public:
Type^ GetType();

Return Type

A Type object that represents the exact runtime type of the current instance.

See Also

XmlInvalidHeaderException Class | XmlInvalidHeaderException Members


HelpLink Property

XmlInvalidHeaderException Class | XmlInvalidHeaderException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HelpLink Property

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlInvalidHeaderException Class : HelpLink Property (XmlInvalidHeaderException)

Gets or sets a link to the help file associated with this exception.

[Visual Basic]
Public Property HelpLink As String
[C#]
public string HelpLink {get; set;}
[C++]
public: __property string* get_HelpLink();
public: __property void set_HelpLink(
   string* value
);
[C++/CLI]
public:
property String^ HelpLink {
   String^ get();
   void set (String^ value);
}

See Also

XmlInvalidHeaderException Class | XmlInvalidHeaderException Members


InnerException Property

XmlInvalidHeaderException Class | XmlInvalidHeaderException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InnerException Property

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlInvalidHeaderException Class : InnerException Property (XmlInvalidHeaderException)

Gets the Exception instance that caused the current exception.

[Visual Basic]
Public ReadOnly Property InnerException As Exception
[C#]
public Exception InnerException {get;}
[C++]
public: __property Exception* get_InnerException();
[C++/CLI]
public:
property Exception^ InnerException {
   Exception^ get();
}

See Also

XmlInvalidHeaderException Class | XmlInvalidHeaderException Members


Message Property

XmlInvalidHeaderException Class | XmlInvalidHeaderException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Message Property

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlInvalidHeaderException Class : Message Property (XmlInvalidHeaderException)

Gets a message that describes the current exception.

[Visual Basic]
Public ReadOnly Property Message As String
[C#]
public string Message {get;}
[C++]
public: __property string* get_Message();
[C++/CLI]
public:
property String^ Message {
   String^ get();
}

See Also

XmlInvalidHeaderException Class | XmlInvalidHeaderException Members


Source Property

XmlInvalidHeaderException Class | XmlInvalidHeaderException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Source Property

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlInvalidHeaderException Class : Source Property (XmlInvalidHeaderException)

Gets or sets the name of the application or the object that causes the error.

[Visual Basic]
Public Property Source As String
[C#]
public string Source {get; set;}
[C++]
public: __property string* get_Source();
public: __property void set_Source(
   string* value
);
[C++/CLI]
public:
property String^ Source {
   String^ get();
   void set (String^ value);
}

See Also

XmlInvalidHeaderException Class | XmlInvalidHeaderException Members


StackTrace Property

XmlInvalidHeaderException Class | XmlInvalidHeaderException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StackTrace Property

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlInvalidHeaderException Class : StackTrace Property (XmlInvalidHeaderException)

Gets a string representation of the frames on the call stack at the time the current exception was thrown.

[Visual Basic]
Public ReadOnly Property StackTrace As String
[C#]
public string StackTrace {get;}
[C++]
public: __property string* get_StackTrace();
[C++/CLI]
public:
property String^ StackTrace {
   String^ get();
}

See Also

XmlInvalidHeaderException Class | XmlInvalidHeaderException Members


TargetSite Property

XmlInvalidHeaderException Class | XmlInvalidHeaderException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TargetSite Property

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlInvalidHeaderException Class : TargetSite Property (XmlInvalidHeaderException)

Gets the method that throws the current exception.

[Visual Basic]
Public ReadOnly Property TargetSite As MethodBase
[C#]
public MethodBase TargetSite {get;}
[C++]
public: __property MethodBase* get_TargetSite();
[C++/CLI]
public:
property MethodBase^ TargetSite {
   MethodBase^ get();
}

See Also

XmlInvalidHeaderException Class | XmlInvalidHeaderException Members


ToString Method

XmlInvalidHeaderException Class | XmlInvalidHeaderException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToString Method

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlInvalidHeaderException Class : ToString Method (XmlInvalidHeaderException)

Creates and returns a string representation of the current exception.

[Visual Basic]
Public Function ToString() As String
[C#]
public string ToString();
[C++]
public: string* ToString();
[C++/CLI]
public:
String^ ToString();

Return Type

A string representation of the current exception.

See Also

XmlInvalidHeaderException Class | XmlInvalidHeaderException Members


XmlInvalidPageDataException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

XmlInvalidPageDataException Class Methods

PegasusImaging.WinForms.NotateXpress9 Namespace : XmlInvalidPageDataException Class

For a list of all members of this type, see XmlInvalidPageDataException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

XmlInvalidPageDataException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


XmlInvalidPageDataException Class | PegasusImaging.WinForms.NotateXpress9 Namespace

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

XmlInvalidPageDataException Class Properties

PegasusImaging.WinForms.NotateXpress9 Namespace : XmlInvalidPageDataException Class

For a list of all members of this type, see XmlInvalidPageDataException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Number (Inherited from NotateXpressException) | Gets the error number raised by the exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

XmlInvalidPageDataException Class | PegasusImaging.WinForms.NotateXpress9 Namespace


Data Property

XmlInvalidPageDataException Class | XmlInvalidPageDataException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Data Property

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlInvalidPageDataException Class : Data Property (XmlInvalidPageDataException)

Gets a collection of key/value pairs that provide additional, user-defined information about the exception.

[Visual Basic]
Public ReadOnly Property Data As IDictionary
[C#]
public IDictionary Data {get;}
[C++]
public: __property IDictionary* get_Data();
[C++/CLI]
public:
property IDictionary^ Data {
   IDictionary^ get();
}

See Also

XmlInvalidPageDataException Class | XmlInvalidPageDataException Members


GetBaseException Method

XmlInvalidPageDataException Class | XmlInvalidPageDataException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetBaseException Method

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlInvalidPageDataException Class : GetBaseException Method (XmlInvalidPageDataException)

When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.

[Visual Basic]
Public Function GetBaseException() As Exception
[C#]
public Exception GetBaseException();
[C++]
public: Exception* GetBaseException();
[C++/CLI]
public:
Exception^ GetBaseException();

Return Type

The first exception thrown in a chain of exceptions. If the InnerException property of the current exception is a null reference (Nothing in Visual Basic), this property returns the current exception.

See Also

XmlInvalidPageDataException Class | XmlInvalidPageDataException Members


GetObjectData Method

XmlInvalidPageDataException Class | XmlInvalidPageDataException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.
See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetObjectData Method

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlInvalidPageDataException Class : GetObjectData Method (XmlInvalidPageDataException)

When overridden in a derived class, sets the SerializationInfo with information about the exception.

[Visual Basic]
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
[C#]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public void GetObjectData(
   SerializationInfo info,
   StreamingContext context
);
[C++]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
[C++/CLI]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Description
ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

XmlInvalidPageDataException Class | XmlInvalidPageDataException Members


GetType Method

XmlInvalidPageDataException Class | XmlInvalidPageDataException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

GetType Method

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlInvalidPageDataException Class : GetType Method (XmlInvalidPageDataException)

Gets the runtime type of the current instance.

[Visual Basic]
Public Function GetType() As Type
[C#]
public Type GetType();
[C++]
public: Type* GetType();
[C++/CLI]
public:
Type^ GetType();

Return Type

A Type object that represents the exact runtime type of the current instance.

See Also

XmlInvalidPageDataException Class | XmlInvalidPageDataException Members


HelpLink Property

XmlInvalidPageDataException Class | XmlInvalidPageDataException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

HelpLink Property

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlInvalidPageDataException Class : HelpLink Property (XmlInvalidPageDataException)

Gets or sets a link to the help file associated with this exception.

[Visual Basic]
Public Property HelpLink As String
[C#]
public string HelpLink {get; set;}
[C++]
public: __property string* get_HelpLink();
public: __property void set_HelpLink(
   string* value
);
[C++/CLI]
public:
property String^ HelpLink {
   String^ get();
   void set (String^ value);
}

See Also

XmlInvalidPageDataException Class | XmlInvalidPageDataException Members


InnerException Property

XmlInvalidPageDataException Class | XmlInvalidPageDataException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

InnerException Property

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlInvalidPageDataException Class : InnerException Property (XmlInvalidPageDataException)

Gets the Exception instance that caused the current exception.

[Visual Basic]
Public ReadOnly Property InnerException As Exception
[C#]
public Exception InnerException {get;}
[C++]
public: __property Exception* get_InnerException();
[C++/CLI]
public:
property Exception^ InnerException {
   Exception^ get();
}

See Also

XmlInvalidPageDataException Class | XmlInvalidPageDataException Members


Message Property

XmlInvalidPageDataException Class | XmlInvalidPageDataException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Message Property

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlInvalidPageDataException Class : Message Property (XmlInvalidPageDataException)

Gets a message that describes the current exception.

[Visual Basic]
Public ReadOnly Property Message As String
[C#]
public string Message {get;}
[C++]
public: __property string* get_Message();
[C++/CLI]
public:
property String^ Message {
   String^ get();
}

See Also

XmlInvalidPageDataException Class | XmlInvalidPageDataException Members


Source Property

XmlInvalidPageDataException Class | XmlInvalidPageDataException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

Source Property

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlInvalidPageDataException Class : Source Property (XmlInvalidPageDataException)

Gets or sets the name of the application or the object that causes the error.

[Visual Basic]
Public Property Source As String
[C#]
public string Source {get; set;}
[C++]
public: __property string* get_Source();
public: __property void set_Source(
   string* value
);
[C++/CLI]
public:
property String^ Source {
   String^ get();
   void set (String^ value);
}

See Also

XmlInvalidPageDataException Class | XmlInvalidPageDataException Members


StackTrace Property

XmlInvalidPageDataException Class | XmlInvalidPageDataException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

StackTrace Property

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlInvalidPageDataException Class : StackTrace Property (XmlInvalidPageDataException)

Gets a string representation of the frames on the call stack at the time the current exception was thrown.

[Visual Basic]
Public ReadOnly Property StackTrace As String
[C#]
public string StackTrace {get;}
[C++]
public: __property string* get_StackTrace();
[C++/CLI]
public:
property String^ StackTrace {
   String^ get();
}

See Also

XmlInvalidPageDataException Class | XmlInvalidPageDataException Members


TargetSite Property

XmlInvalidPageDataException Class | XmlInvalidPageDataException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

TargetSite Property

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlInvalidPageDataException Class : TargetSite Property (XmlInvalidPageDataException)

Gets the method that throws the current exception.

[Visual Basic]
Public ReadOnly Property TargetSite As MethodBase
[C#]
public MethodBase TargetSite {get;}
[C++]
public: __property MethodBase* get_TargetSite();
[C++/CLI]
public:
property MethodBase^ TargetSite {
   MethodBase^ get();
}

See Also

XmlInvalidPageDataException Class | XmlInvalidPageDataException Members


ToString Method

XmlInvalidPageDataException Class | XmlInvalidPageDataException Members

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

ToString Method

PegasusImaging.WinForms.NotateXpress9 Namespace > XmlInvalidPageDataException Class : ToString Method (XmlInvalidPageDataException)

Creates and returns a string representation of the current exception.

[Visual Basic]
Public Function ToString() As String
[C#]
public string ToString();
[C++]
public: string* ToString();
[C++/CLI]
public:
String^ ToString();

Return Type

A string representation of the current exception.

See Also

XmlInvalidPageDataException Class | XmlInvalidPageDataException Members


PegasusImaging.WinForms.NotateXpress9 Assembly

See Also PegasusImaging.WinForms.NotateXpress9 Send comments on this topic.

PegasusImaging.WinForms.NotateXpress9 Namespace Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.NotateXpress9.BaseToolbarDefaults
PegasusImaging.WinForms.NotateXpress9.BlockHighlightToolbarDefaults
PegasusImaging.WinForms.NotateXpress9.ButtonToolbarDefaults
PegasusImaging.WinForms.NotateXpress9.EllipseToolbarDefaults
PegasusImaging.WinForms.NotateXpress9.FreehandToolbarDefaults
PegasusImaging.WinForms.NotateXpress9.ImageToolbarDefaults
PegasusImaging.WinForms.NotateXpress9.LineToolbarDefaults
PegasusImaging.WinForms.NotateXpress9.NoteToolbarDefaults
PegasusImaging.WinForms.NotateXpress9.PolygonToolbarDefaults
PegasusImaging.WinForms.NotateXpress9.PolyLineToolbarDefaults
PegasusImaging.WinForms.NotateXpress9.RectangleToolbarDefaults
PegasusImaging.WinForms.NotateXpress9.RulerToolbarDefaults
PegasusImaging.WinForms.NotateXpress9.StampToolbarDefaults
PegasusImaging.WinForms.NotateXpress9.TextToolbarDefaults
PegasusImaging.WinForms.NotateXpress9.Element
PegasusImaging.WinForms.NotateXpress9.BlockHighlightTool
PegasusImaging.WinForms.NotateXpress9.ButtonTool
PegasusImaging.WinForms.NotateXpress9.EllipseTool
PegasusImaging.WinForms.NotateXpress9.FreeHandTool
PegasusImaging.WinForms.NotateXpress9.ImageTool
PegasusImaging.WinForms.NotateXpress9.LineTool
PegasusImaging.WinForms.NotateXpress9.NoteTool
PegasusImaging.WinForms.NotateXpress9.PolygonTool
PegasusImaging.WinForms.NotateXpress9.PolyLineTool
PegasusImaging.WinForms.NotateXpress9.RectangleTool
PegasusImaging.WinForms.NotateXpress9.RulerTool
PegasusImaging.WinForms.NotateXpress9.StampTool
PegasusImaging.WinForms.NotateXpress9.TextTool
PegasusImaging.WinForms.NotateXpress9.Group
PegasusImaging.WinForms.NotateXpress9.Layer
PegasusImaging.WinForms.NotateXpress9.LoadOptions
PegasusImaging.WinForms.NotateXpress9.SaveOptions
PegasusImaging.WinForms.NotateXpress9.Toolbar
PegasusImaging.WinForms.NotateXpress9.ToolbarDefaults
System.Collections.CollectionBase
PegasusImaging.WinForms.NotateXpress9.ElementCollection
PegasusImaging.WinForms.NotateXpress9.GroupCollection
PegasusImaging.WinForms.NotateXpress9.GroupElementCollection
PegasusImaging.WinForms.NotateXpress9.LayerCollection
System.EventArgs
PegasusImaging.WinForms.NotateXpress9.AnnotationAddedEventArgs
PegasusImaging.WinForms.NotateXpress9.AnnotationDeletedEventArgs
PegasusImaging.WinForms.NotateXpress9.AnnotationMovedEventArgs
PegasusImaging.WinForms.NotateXpress9.AnnotationSelectedEventArgs
PegasusImaging.WinForms.NotateXpress9.ClickEventArgs
PegasusImaging.WinForms.NotateXpress9.ContextMenuEventArgs
PegasusImaging.WinForms.NotateXpress9.CurrentLayerChangeEventArgs
PegasusImaging.WinForms.NotateXpress9.DoubleClickEventArgs
PegasusImaging.WinForms.NotateXpress9.DroppedEventArgs
PegasusImaging.WinForms.NotateXpress9.GetLayerPasswordEventArgs
PegasusImaging.WinForms.NotateXpress9.GroupSelectedEventArgs
PegasusImaging.WinForms.NotateXpress9.ItemChangedEventArgs
PegasusImaging.WinForms.NotateXpress9.LayerRestoredEventArgs
PegasusImaging.WinForms.NotateXpress9.MappingInputEventArgs
PegasusImaging.WinForms.NotateXpress9.MappingOutputEventArgs
PegasusImaging.WinForms.NotateXpress9.MenuEventArgs
PegasusImaging.WinForms.NotateXpress9.MouseDownEventArgs
PegasusImaging.WinForms.NotateXpress9.MouseMoveEventArgs
PegasusImaging.WinForms.NotateXpress9.MouseUpEventArgs
PegasusImaging.WinForms.NotateXpress9.TextEditEndEventArgs
PegasusImaging.WinForms.NotateXpress9.TextEditStartEventArgs
PegasusImaging.WinForms.NotateXpress9.ToolbarEventArgs
PegasusImaging.WinForms.NotateXpress9.UserDrawEventArgs
PegasusImaging.WinForms.NotateXpress9.UserGroupCreatedEventArgs
PegasusImaging.WinForms.NotateXpress9.UserGroupDestroyedEventArgs
System.Exception
System.ApplicationException
PegasusImaging.WinForms.NotateXpress9.NotateXpressException
PegasusImaging.WinForms.NotateXpress9.BrandingException
PegasusImaging.WinForms.NotateXpress9.BrandingSourceDibException
PegasusImaging.WinForms.NotateXpress9.ClipboardException
PegasusImaging.WinForms.NotateXpress9.DuplicateItemException
PegasusImaging.WinForms.NotateXpress9.DuplicateMenuIdException
PegasusImaging.WinForms.NotateXpress9.FileOpenException
PegasusImaging.WinForms.NotateXpress9.FileSecurityException
PegasusImaging.WinForms.NotateXpress9.FileWriteException
PegasusImaging.WinForms.NotateXpress9.GroupCreationException
PegasusImaging.WinForms.NotateXpress9.InvalidAnnotationFileException
PegasusImaging.WinForms.NotateXpress9.InvalidAttributeException
PegasusImaging.WinForms.NotateXpress9.InvalidColorTypeException
PegasusImaging.WinForms.NotateXpress9.InvalidContextException
PegasusImaging.WinForms.NotateXpress9.InvalidContextIdException
PegasusImaging.WinForms.NotateXpress9.InvalidCursorTypeException
PegasusImaging.WinForms.NotateXpress9.InvalidErrorLevelException
PegasusImaging.WinForms.NotateXpress9.InvalidFontException
PegasusImaging.WinForms.NotateXpress9.InvalidGroupException
PegasusImaging.WinForms.NotateXpress9.InvalidHatchStyleException
PegasusImaging.WinForms.NotateXpress9.InvalidItemException
PegasusImaging.WinForms.NotateXpress9.InvalidLayerException
PegasusImaging.WinForms.NotateXpress9.InvalidModeException
PegasusImaging.WinForms.NotateXpress9.InvalidParameterException
PegasusImaging.WinForms.NotateXpress9.InvalidPasswordException
PegasusImaging.WinForms.NotateXpress9.InvalidPointException
PegasusImaging.WinForms.NotateXpress9.InvalidTiffAnnTypeException
PegasusImaging.WinForms.NotateXpress9.InvalidToolException
PegasusImaging.WinForms.NotateXpress9.InvalidVariantException
PegasusImaging.WinForms.NotateXpress9.InvalidWangTypeException
PegasusImaging.WinForms.NotateXpress9.InvalidWindowHandleException
PegasusImaging.WinForms.NotateXpress9.ItemNotFoundException
PegasusImaging.WinForms.NotateXpress9.NoCurrentLayerException
PegasusImaging.WinForms.NotateXpress9.NoSelectionException
PegasusImaging.WinForms.NotateXpress9.NotSupportedException
PegasusImaging.WinForms.NotateXpress9.ObjectNotConnectedException
PegasusImaging.WinForms.NotateXpress9.OutOfMemoryException
PegasusImaging.WinForms.NotateXpress9.PageNotFoundException
PegasusImaging.WinForms.NotateXpress9.SaveFileOneLayerException
PegasusImaging.WinForms.NotateXpress9.StorageStreamException
PegasusImaging.WinForms.NotateXpress9.TmsAnnotationBadActivateCodeException
PegasusImaging.WinForms.NotateXpress9.TmsAnnotationBadAlignmentException
PegasusImaging.WinForms.NotateXpress9.TmsAnnotationBadArrowsException
PegasusImaging.WinForms.NotateXpress9.TmsAnnotationBadBorderStyleException
PegasusImaging.WinForms.NotateXpress9.TmsAnnotationBadColorMapFlagException
PegasusImaging.WinForms.NotateXpress9.TmsAnnotationBadCoordinateException
PegasusImaging.WinForms.NotateXpress9.TmsAnnotationBadDirectionException
PegasusImaging.WinForms.NotateXpress9.TmsAnnotationBadHeaderException
PegasusImaging.WinForms.NotateXpress9.TmsAnnotationBadRecordException
PegasusImaging.WinForms.NotateXpress9.TmsAnnotationBadRedactionFlagException
PegasusImaging.WinForms.NotateXpress9.TmsAnnotationBadTransparentFlagException
PegasusImaging.WinForms.NotateXpress9.TmsAnnotationBadVersionException
PegasusImaging.WinForms.NotateXpress9.UnableLoadAnnotationDllException
PegasusImaging.WinForms.NotateXpress9.UnableToCreateStorageException
PegasusImaging.WinForms.NotateXpress9.XmlFatalException
PegasusImaging.WinForms.NotateXpress9.XmlGeneralException
PegasusImaging.WinForms.NotateXpress9.XmlInvalidHeaderException
PegasusImaging.WinForms.NotateXpress9.XmlInvalidPageDataException
System.MarshalByRefObject
System.ComponentModel.Component
PegasusImaging.WinForms.NotateXpress9.NotateXpress

See Also

PegasusImaging.WinForms.NotateXpress9 Namespace | PegasusImaging.WinForms.NotateXpress9 Assembly