ImagXpress 13 User Assistance Dashboard

Accusoft.ImagXpress13.Net
ImagXpress 13 User Assistance Dashboard

Welcome

  • What is The ImagXpress Product Family?
  • What is the ImagXpress Component? (Includes a description of new features)

Getting Started

  • Operating Requirements & Installation
    • Operating Requirements
    • Upgrading from ImagXpress 12 to ImagXpress 13
    • Installing on a Development Machine
  • Licensing & Deployment
    • Licensing
    • Distributing ImagXpress
    • Software License Agreement
    • Accusoft Corporation Copyrights & Trademarks

Developer's Guide

  • User Guide
    • Concepts
      • Overview of ImagXpress
      • Supported File Formats
      • Glossary
    • How To
      • Query an Image File
      • Load an Image
        • Specify Load Options
        • Load Image from File
        • Load Image from Stream
        • Load Image from Bitmap or DIB
        • Load Image from Another ImageX Object
        • Cancel
      • Access and Modify a Loaded Image
        • Get Loaded Image Information
        • Modify Tags & Comments
        • Modify the Image Palette
        • Draw on the Image
      • View an Image
        • Create a Viewer
        • Define Viewer Properties
          • Set the View Window Size & Appearance
          • Set Toolbar & Cursors
          • Set Context Menus
          • Set Scrolling & Mousewheel Behavior
        • Specify How the Image Should Be Displayed
          • Align Image in Window
          • Zoom Image in Window
          • Enable Progressive Viewing
          • Enable Medical Viewing
          • Set Color Management
          • Set Image Display Palette
          • Set Display Bit Depth
          • Set Alpha Blending
          • Change Image Display Rendering
        • Display Image
        • Capture, Copy, and Paste
          • Capture an Image from Screen
          • Copy & Paste Image Using the Clipboard
          • Select a Section of the Displayed Image
        • Manage End-User Viewing Events
      • Process an Image
        • Create a Processor
        • Select an Area or Region to Process
        • Modify Image Size & Orientation
        • Modify Image Bit Depth
        • Correct Color & Contrast
        • Cleanup Images
        • Remove Redeye
        • Apply Image Effects
        • Modify Alpha Channel
        • Merge Images
        • Undo a Processing Action
      • Pass Image Data Between Different Accusoft Components
      • Use the New Multi-Page TIFF Edit API
        • Delete Multiple Pages
        • Insert Multiple Pages
      • Use the Touch Capability
        • Verify Support
        • Enable Touch Capabilities
        • Enable Built-in Touch Support
        • Use Tools and the Toolbar
        • Use Events
      • Reduce a JPEG Image
      • Reduce a PNG Image
      • Annotate an Image
      • Print an Image
      • Save an Image
        • Specify Save Options
        • Save Image to File
        • Save Image to Stream
        • Save Image to Bitmap or DIB
        • Cancel
      • Free the Control's Resources
      • Debug
  • API Reference Guide
    • Accusoft.ImagXpress13.Net Assembly

Additional Resources

  • Online Demo
  • Tech Specs
  • White papers & Case Studies
  • FAQs
  • Support Overview
  • Support Plans/Agreement

Feedback

  • Tell us what you think
    • Email us
    • Take our survey

©2016. Accusoft Corporation. All Rights Reserved.

Send Feedback


ImagXpress 13 for .NET - User Guide

ImagXpress 13 for .NET - User Guide

This User Guide provides information about the following:

  • Introduction
  • Getting Started
  • Licensing
  • Distributing Applications and Deployment
  • Concepts
  • How To


Introduction

Introduction
ImagXpress 13 for .NET - User Guide > Introduction

This section provides information about the following:

  • Introduction
    • What is The ImagXpress Product Family?
    • What is the ImagXpress Component?
    • Standard vs. Professional
    • Getting Support
    • Accusoft Corporation Copyrights & Trademarks


What is The ImagXpress Product Family?

What is The ImagXpress Product Family?
ImagXpress 13 for .NET - User Guide > Introduction > What is The ImagXpress Product Family?

ImagXpress® Version 13 lets you quickly add the world's most trusted imaging functions to your Windows application. With our powerful imaging tools, you can quickly develop applications that require complex imaging tasks for document imaging, photo processing, or medical applications, while you concentrate on the unique needs of your program.

ImagXpress is the image handling engine behind most of our advanced recognition and image processing products. It's the fastest way to develop professional applications involving images.

The ImagXpress v13 Product Family includes the following Components:

  • ImagXpress v13 – image compression, decompression, viewing, and processing
  • NotateXpress™ v13 – image annotation support
  • ThumbnailXpress™ v6 – thumbnail image support
  • TwainPRO™ v9 – TWAIN image acquisition support
  • PrintPRO™ v8 – image printing support

ImagXpress Editions

The components within the ImagXpress Product Family are available in two editions, designed to meet specific imaging needs:

  • Professional: includes ImagXpress, NotateXpress, TwainPRO, PrintPRO, and ThumbnailXpress
  • Standard: includes ImagXpress, TwainPRO, and ThumbnailXpress

Additional Accusoft Components

Additional components are available for purchase separately, and integrate easily to provide a comprehensive imaging solution:

  • ISIS® Xpress™ – ISIS image acquisition support; license sold separately
  • PDF Xpress™ – PDF creation, viewing, and annotating
  • Barcode Xpress™ – recognize barcodes
  • ScanFix Xpress™ – advanced image cleanup
  • FormFix™ – form ID, dropout, and OMR
  • SmartZone™ ICR / OCR – character recognition
  • ImageGear for .NET - Fully managed code to create cutting edge imaging applications

See www.accusoft.com for product packaging and sales information.

See Also
Getting Support
Software License Agreement
Operating Requirements


What is the ImagXpress Component?

What is the ImagXpress Component?
ImagXpress 13 for .NET - User Guide > Introduction > What is the ImagXpress Component?

The ImagXpress® Component is the flagship of the ImagXpress Product Family, offering the core imaging functionality of compression, decompression, viewing, and processing.

If you are upgrading from a previous version, see Upgrading from ImagXpress 12 to ImagXpress 13, which provides more detailed information about the new features introduced in ImagXpress Version 13.

New Features in Version 13

ImagXpress Version 13 Service Pack 1 introduces the following new features:

  • Added the ability to compress a PNG image to its optimal size while maintaining lossless fidelity to the input with the ImageReduce.PngReduce() method. Reduce a PNG Image provides additional information about this feature.
  • Added the ability to specify the Transform Mode of the JPEG Reduce operation with a new optional parameter of the ImageReduce.JpegReduce() methods and the new TransformMode enumeration. Reduce a JPEG Image provides additional information about this feature.

ImagXpress Version 13 introduced the following new feature:

  • Added the ImageReduce class to optimize compressed file formats. Use its JpegReduce method to recompress 8-bit grayscale and 24-bit color sequential JPEG using a quality factor that requantizes luminance and chrominance. This operation can substantially reduce the size of the source JPEG. This feature is available in ImagXpress Professional.

Please also refer to the Accusoft.ImagXpress13.Net.Changes.txt file for a description of the bug fixes and enhancements in this release.
See Also
Getting Support
Software License Agreement
Operating Requirements
Accusoft Corporation Copyrights & Trademarks


Standard vs. Professional

Standard vs. Professional
ImagXpress 13 for .NET - User Guide > Introduction > Standard vs. Professional

The following table delineates the features available in ImagXpress Standard vs. ImagXpress Professional:

Image Processing Function | Standard | Professional
Add alpha channel information to an image | Yes | Yes
Add noise to an image | Yes | Yes
Adjust HSL | Yes | Yes
Adjust RGB | Yes | Yes
Adjust the brightness of an image | Yes | Yes
Adjust the contrast of an image | Yes | Yes
Apply a mosaic effect to an image | Yes | Yes
Apply a motion blur effect to an image | Yes | Yes
Apply a parabolic transform to an image | Yes | Yes
Apply a perspective transform to an image | Yes | Yes
Apply a pinch effect to an image | Yes | Yes
Apply a polynomial warp transform to an image | Yes | Yes
Apply a ripple effect to an image | Yes | Yes
Apply a swirl effect to an image | Yes | Yes
Apply a twist effect to an image | Yes | Yes
Auto-binarize an image | Yes | Yes
Automatically adjust the contrast of an image | Yes | Yes
Automatically crop an image | Yes | Yes
Change the color depth of an image | Yes | Yes
Binarize an image | Yes | Yes
Blend an image | Yes | Yes
Blur an image | Yes | Yes
Buttonize an image | Yes | Yes
Count the number of times a particular color appears within an image | Yes | Yes
Count the number of unique colors within an image | Yes | Yes
Crop an image | Yes | Yes
Crop the borders of an image | Yes | Yes
Delete the active region | Yes | Yes
Deskew an image | Yes | Yes
Diffuse an image | Yes | Yes
Dilate an image | Yes | Yes
Emboss an image | Yes | Yes
Equalize an image | Yes | Yes
Erode an image | Yes | Yes
Fill the alpha channel with a particular byte value | Yes | Yes
Flatten the alpha channel into the image | Yes | Yes
Flip an image | Yes | Yes
Gamma correct an image | Yes | Yes
Get histogram counts of all the red green and blue shades within an image | Yes | Yes
Get the alpha value for a particular pixel | Yes | Yes
Invert the alpha channel data | Yes | Yes
Join separate colors stored in different image objects into a single image | Yes | Yes
Merge two images together | Yes | Yes
Mirror an image | Yes | Yes
Negate the colors within an image | Yes | Yes
Outline the edges within an image | Yes | Yes
Posterize an image | Yes | Yes
Remove the alpha channel from an image | Yes | Yes
Replace colors within an image | Yes | Yes
Resize a black and white image to a grayscale image | Yes | Yes
Resize an image | Yes | Yes
Return the alpha channel data within an image as a bitmap | Yes | Yes
Rotate an image by an arbitrary angle | Yes | Yes
Separate the colors of an image into separate images | Yes | Yes
Set the active area within an image | Yes | Yes
Set the active region within an image | Yes | Yes
Set the alpha value for a particular pixel | Yes | Yes
Sharpen an image | Yes | Yes
Soften an image | Yes | Yes
Solarize an image | Yes | Yes
Tile an image | Yes | Yes
Transform an image using a 3x3 matrix | Yes | Yes
Use a median filter to reduce noise within an image | Yes | Yes
Adjust the color balance | - | Yes
Adjust the lightness of an image | - | Yes
Automatically adjust the color balance | - | Yes
Automatically adjust the color balance of an image | - | Yes
Automatically adjust the lightness of an image | - | Yes
Automatically level an image | - | Yes
Automatically remove redeye within an image | - | Yes
Crop the borders of a document | - | Yes
Deskew a document | - | Yes
Despeckle a document | - | Yes
Despeckle an image | - | Yes
Detect a blank page for a document | - | Yes
Dilate a document | - | Yes
Erode a document | - | Yes
Process IPTC metadata | - | Yes
Process Tags for TIFF, CALS, and MODCA images | - | Yes
Reduce a grayscale image down to 8 bits per pixel | - | Yes
Reduce a grayscale image down to 8 bits per pixel according to the DICOM spec | - | Yes
Reduce an image (JPEG and PNG) | - | Yes
Remove a line from a document | - | Yes
Remove blobs from a document | - | Yes
Remove dust from an image | - | Yes
Remove redeye from an image | - | Yes
Remove scratches from an image | - | Yes
Shear a document | - | Yes
Smoothly double the size of a document via a smooth zoom operation | - | Yes
Unsharpen an image | - | Yes
Use Color Management in the loading, previewing, printing, and saving of images | - | Yes
For information about the File Formats supported by ImagXpress Standard vs. ImagXpress Professional, please refer to http://www.accusoft.com/imagxpressformats.htm.


Getting Support

Getting Support
ImagXpress 13 for .NET - User Guide > Introduction > Getting Support

For information about Accusoft Support, please refer to the Software Support and Maintenance Policy on the Accusoft web site or call Accusoft at 813-875-7575.

See Also
Operating Requirements
Installing on a Development Machine


Accusoft Corporation Copyrights & Trademarks

Accusoft Corporation Copyrights & Trademarks
ImagXpress 13 for .NET - User Guide > Introduction > Accusoft Corporation Copyrights & Trademarks

©1997-2016 Accusoft Corporation. All rights reserved.

Information in this document is subject to change without notice. No part of this document may be reproduced or transmitted in any form or by any means, electronic or mechanical, for any purpose, without the express written permission of Accusoft® Corporation.

This manual and the software described in it are both products of the USA.

Accusoft Corporation
4001 North Riverside Drive
Tampa, FL 33603
Sales: 813-875-7575
www.accusoft.com

Accusoft Trademarks

The following are trademarks (™) or registered marks (®) of Accusoft Corporation:

  • Accusoft®
  • Accusoft Logo™
  • Accusoft Pegasus Logo™
  • Adeptol®
  • AIMTools™
  • Barcode Xpress™
  • Accusoft® Barcode Scanner™
  • Barcode Xpress Mobile™
  • CapturePro™
  • Digital Mark Recognition® (DMR)
  • FolderBots™
  • FormAssist™
  • FormDirector™
  • FormFix™
  • FormSuite™
  • ImageGear® for .NET
  • ImageGear® for .NET Compact Framework
  • ImageGear® for Silverlight
  • ImageGear® for Java
  • ImageGear® Medical
  • ImageGear® Professional
  • ImageGear®
  • ImageTransport MD™
  • ImagXpress®
  • ISIS® Xpress™
    • ISIS is a registered trademark of EMC Corporation
    • ISIS Xpress is a trademark of Accusoft Corporation
  • MICR Xpress™
  • NetVue™
  • NotateXpress™
  • PDF Xpress™
  • Pegasus®
  • PICTools™
  • PICTools™ Document
  • PICTools™ Fingerprint
  • PICTools™ Medical
  • PICTools™ Photo
  • PICVideo™ M-JPEG Codec
  • PrintPRO™
  • Prizm®
  • Prizm® Content Connect™
  • Prizm® Content Connect™ for SharePoint
  • Prizm® Content Connect™ for Documentum
  • Prizm® Document Converter™
  • Prizm® Viewer™
  • Prizm® ActiveX Viewer™
  • Prizm® Cloud™
  • Prizm® Share™
  • Prizm® Image™
  • Prizm® Capture™
  • ScanFix® Xpress™
  • SmartZone™
  • The JPEG Wizard™
  • ThinPic™
  • ThumbnailXpress™
  • TwainPRO™
  • USB Scanner™
  • USB Scanner SDK™

Accusoft and/or its agents use these marks and brand names in connection with its goods and/or services, in the United States and other countries.

Microsoft, Internet Explorer, Microsoft.NET, Silverlight, Visual Basic, Visual Studio, and Visual Studio.NET are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries.

Itanium is a registered trademark of Intel Corporation in the United States and other countries.

All other product and brand names are the property of their respective owners.

Accusoft Patents

ImagXpress utilizes technology owned by Accusoft Corporation that is protected by U.S. Patents 5,579,414; 5,590,224; 5,594,814; 5,594,815; 5,625,719; 5,729,635; 5,778,103; 7,003,170; 7,209,594; 7,352,903; 7,409,100; 7,454,080; 7,756,340; 7,817,854; 8,351,699; 8,351,723; 8,437,565; 8,559,742 and U.S. Patents Pending.

See Also
What is the ImagXpress Component?
What is The ImagXpress Product Family?
Software License Agreement


Getting Started

Getting Started
ImagXpress 13 for .NET - User Guide > Getting Started

This section provides information about the following:

  • Getting Started
    • Operating Requirements
    • Installing on a Development Machine
    • Upgrading from ImagXpress 12 to ImagXpress 13
    • Upgrading Runtime Licensing
    • Add ImagXpress to Your Project


Operating Requirements

Operating Requirements
ImagXpress 13 for .NET - User Guide > Getting Started > Operating Requirements

Unless otherwise specified, the operating requirements delineated in this topic include service packs supported by Microsoft.

Operating Systems

ImagXpress® runs on supported Microsoft Operating Systems:

  • Windows Vista
  • Windows 7
  • Windows 8
  • Windows 10
  • Windows Server 2003 R2
  • Windows Server 2008
  • Windows Server 2012
  • ImagXpress runs in 64-bit, 32-bit, and AnyCPU-compiled executables.
  • Although it may run, ImagXpress is not supported on previous Windows versions (for example, Windows XP).

Threading

ImagXpress is a synchronous or asynchronous multi-threaded control.

Development Environments

  • Microsoft .NET Framework 2.0, 3.0, 3.5, 4.0, 4.5
  • Microsoft Visual Studio 2010, 2012, 2013
See Also
Getting Support
Installing on a Development Machine


Installing on a Development Machine

Installing on a Development Machine
ImagXpress 13 for .NET - User Guide > Getting Started > Installing on a Development Machine

To Install ImagXpress® Component

Run the downloaded setup program which installs the development kit on your development machine.

The downloaded development kit includes code samples for supported platforms. Samples are available through the Start | Programs | Accusoft | ImagXpress 13 menu.

By default this will register trial licensing which allows you to develop applications but not to distribute them. The trial license allows testing of all the functions and features.

In order to distribute your finished application you must purchase and install a fully paid license from Accusoft. The paid licenses override trial licenses.

To Use ImagXpress Help Files

Once you have installed ImagXpress, you will have access to the following stand-alone help file:

  • Accusoft.ImagXpress13.Net.chm - Access the ImagXpress stand-alone help through the Windows Start menu: Start | Programs | Accusoft | ImagXpress 13

In addition, you will have access to the following compiled collection help file:

  • AccusoftImagXpress13_Net.cab - MHV (Microsoft Help Viewer). If you have Visual Studio 2010, 2012, or 2013, these MHV files will be registered.
See Also
Operating Requirements
Software License Agreement
Distributing ImagXpress


Upgrading from ImagXpress 12 to ImagXpress 13

Upgrading from ImagXpress 12 to ImagXpress 13
ImagXpress 13 for .NET - User Guide > Getting Started > Upgrading from ImagXpress 12 to ImagXpress 13

This section describes how to upgrade from ImagXpress 12 to ImagXpress 13. While generally you'll be able to replace ImagXpress 12 with ImagXpress 13, there are a few important changes you may need to consider. This section provides information about those changes.

New and Modified API

ImagXpress 13 Service Pack 1 introduces the following new or modified ImagXpress API:

  • The PngReduce() method has been added to the ImageReduce class. This can compress a PNG to its optimal size while maintaining lossless fidelity to the input.
  • A new enumeration TransformMode has been added.
  • An optional parameter has been added to the JpegReduce() methods of the ImageReduce class. This allows you to specify the Transform Mode of the JPEG Reduce operation.
  • PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.
  • The ImageXFormat enumeration value Pdf is marked deprecated.
  • The Pdf property of the LoadOptions class is marked deprecated.
  • The LoadOptionsPdf class is marked deprecated.
  • The Pdf property of the SaveOptions class is marked deprecated.
  • The SaveOptionsPdf class is marked deprecated.
  • The GrayMode property of the ImageXView class is no longer displayed in the Properties Window and is no longer serialized by the designer in Visual Studio.
  • Tile-related TIFF tags from input TIFF files are now discarded during load to prevent producing invalid TIFF files during save.
  • The SetArea() method of the Processor class now throws an ArgumentException if any of the rectangle coordinates are negative.

ImagXpress 13 introduced the following new ImagXpress API:

  • Added the ImageReduce class to optimize compressed file formats. Use its JpegReduce method to recompress 8-bit grayscale and 24-bit color sequential JPEG using a quality factor that requantizes luminance and chrominance. This operation can substantially reduce the size of the source JPEG. This feature is available in ImagXpress Professional.

If you encounter any porting issues, please contact support@accusoft.com for assistance.


Upgrading Runtime Licensing

Upgrading Runtime Licensing
ImagXpress 13 for .NET - User Guide > Getting Started > Upgrading Runtime Licensing

This section describes how to upgrade to Accusoft's new Runtime Licensing.

Prior to ImagXpress 11, runtime licensing was accomplished using the UnlockRuntime method.

In ImagXpress 11 and later, the default licensing model is Automatically Reported Runtime Licensing. However, based on your contracted usage of this software, you may be eligible for Manually Reported Runtime Licensing. Your Accusoft Sales Representative (sales@accusoft.com) can help you determine which model is appropriate.

Refer to the following sections for information about upgrading to the new Runtime Licensing models:

  • Upgrading to Automatically Reported Runtime Licensing
  • Upgrading to Manually Reported Runtime Licensing

Upgrading to Automatically Reported Runtime Licensing

Automatically Reported Runtime Licensing requires a license to be installed on the end-user's machine. See the Licensing section for more information.

In your ImagXpress 10 codebase, find any existing calls to the UnlockRuntime method.

C#
Copy Code
 imagXpress1.Licensing.UnlockRuntime(12345,12345,12345,12345);
VB.NET
Copy Code
 imagXpress1.Licensing.UnlockRuntime(12345,12345,12345,12345)

In your ImagXpress 11 or later codebase, replace the UnlockRuntime method with calls to the SetSolutionName and SetSolutionKey methods.

C#
Copy Code
 imagXpress1.Licensing.SetSolutionName("YourSolutionName");
 imagXpress1.Licensing.SetSolutionKey(12345,12345,12345,12345);
VB.NET
Copy Code
 imagXpress1.Licensing.SetSolutionName("YourSolutionName")
 imagXpress1.Licensing.SetSolutionKey(12345,12345,12345,12345)

Upgrading to Manually Reported Runtime Licensing

In your ImagXpress 10 codebase, find any existing calls to the UnlockRuntime method.

C#
Copy Code
 imagXpress1.Licensing.UnlockRuntime(12345,12345,12345,12345);
VB.NET
Copy Code
 imagXpress1.Licensing.UnlockRuntime(12345,12345,12345,12345)

In your ImagXpress 11 or later codebase, replace the UnlockRuntime method with calls to the SetSolutionName, SetSolutionKey, and SetOEMLicenseKey methods.

C#
Copy Code
 imagXpress1.Licensing.SetSolutionName("YourSolutionName");
 imagXpress1.Licensing.SetSolutionKey(12345,12345,12345,12345);
 imagXpress1.Licensing.SetOEMLicenseKey("1.0.AStringForOEMLicensing…");
VB.NET
Copy Code
 imagXpress1.Licensing.SetSolutionName("YourSolutionName")
 imagXpress1.Licensing.SetSolutionKey(12345,12345,12345,12345)
 imagXpress1.Licensing.SetOEMLicenseKey("1.0.AStringForOEMLicensing…")

There is no longer a separate method for web licensing. That functionality has been integrated into the SetOEMLicenseKey method.

If you encounter any porting issues, please contact support@accusoft.com for assistance.


Add ImagXpress to Your Project

Add ImagXpress to Your Project
ImagXpress 13 for .NET - User Guide > Getting Started > Add ImagXpress to Your Project

To add ImagXpress to your project:

  1. Select an ImagXpress component from the toolbox and add to your project. The ImagXpress component manages licensing for the control and is required to enable all ImagXpress functionality. Add one and only one ImagXpress component to the project.
    You must have an ImagXpress component in your project to use ImagXpress. The ImagXpress component should be added before any other components in the ImagXpress family are added.
  2. Select an ImageXView component from the toolbox and add it to your project. The ImageXView component manages the interface to devices, such as monitors and printers and to other controls, such as NotateXpress™ and ThumbnailXpress™. ImageXView component is required to view, print, or annotate an image. Multiple ImageXView components can be added to the project to facilitate viewing and annotating multiple images, or multiple views of the same image.
  3. Select a Processor component from the toolbox and add it to your project. The Processor component manages all image processing. Multiple Processor components can be added to the project to facilitate parallel processing, within the constraints of your system.

Add Functionality from other Controls in the ImagXpress Family

  1. To enable annotation capability, add NotateXpress to your project. One NotateXpress component must be added for each ImageXView component in which annotation is required.
  2. To enable thumbnail capability, add ThumbnailXpress to your project. One ThumbnailXpress component must be added for each ImageXView component in which thumbnail capability is required.
  3. To enable TWAIN scanning, add TwainPRO™ to your project.
  4. To create a custom printer interface, add PrintPRO™ to your project.
See Also
Query an Image File


Licensing

Licensing
ImagXpress 13 for .NET - User Guide > Licensing

Accusoft has introduced a new licensing structure, which provides the following benefits:

  • Toolkit Licensing (also known as Developer or SDK licensing) has been simplified, no longer requiring manual entry of license registration codes.
  • Runtime Licensing (also known as Deployment licensing) has been made more flexible, enabling support for a number of different deployment scenarios.

During evaluation of Accusoft products, Evaluation Toolkit licenses can be used to try out products. However, the product behavior is limited by trial dialog pop-ups, timeouts, or evaluation watermarks.

Accusoft requires customers to purchase licenses for both development and deployment.

  • Development/Toolkit Licensing: When you determine the product is a good fit, you can purchase a Toolkit license to eliminate trial dialog pop-ups, timeouts, and evaluation watermarks while you develop your application.
  • Deployment/Runtime Licensing: Once you have an application that is ready for distribution, you have several options for deployment. Your own deployment scenario will dictate which option is the most appropriate. There are also cost considerations for each licensing model; see the product's "pricing" page or speak with an Accusoft Sales Representative (sales@accusoft.com) for more information.
    • Manually Reported Runtime Licensing: In this model, you embed all of the licensing information directly into your application. You must manually provide royalty reporting to Accusoft for the actual licenses deployed. This model will be the best choice for you if you are not connected to the Internet at runtime, as might be the case in an defense or financial application.
    • Automatically Reported Runtime Licensing using the Server Licensing Utility (SLU): In this model, you run a small GUI tool one time on each deployment target to configure licensing. This model will be the best choice for you if you handle the deployments yourself.
    • Automatically Reported Runtime Licensing using the Licensing Development Kit (LDK): In this model, you embed function calls into your application that perform the license verification at runtime. This model will be the best choice for you if you wish to hide licensing from your end users.

See Also
Licensing Glossary


Evaluation Licensing

Evaluation Licensing
ImagXpress 13 for .NET - User Guide > Licensing > Evaluation Licensing

The default installation for ImagXpress includes Evaluation licensing. This allows you to test all component features and functions and develop applications, but not distribute them. Installing ImagXpress in evaluation mode provides access to all features and functionality of ImagXpress. E-mail support is available with the evaluation license.

During evaluation of Accusoft products, Evaluation Toolkit licenses can be used to try out products. However, the product behavior is limited by trial dialog pop-ups, timeouts, or evaluation watermarks. When you determine the product is a good fit, you can purchase a Toolkit license to eliminate trial dialog pop-ups, timeouts, and evaluation watermarks.

Applications built with an evaluation license can only be run on a computer that has ImagXpress Licensing installed on it. See Runtime Licensing for information on licensing requirements to deploy applications built using ImagXpress.

An evaluation dialog similar to the following is displayed when you have a valid evaluation license:

However, if you attempt to execute a function that is not licensed in the edition license you are using (e.g., if you have a paid license for ImagXpress Standard and attempt to execute a function available only in ImagXpress Professional), an evaluation dialog similar to the following is displayed.

If no license is found in the registry, a dialog similar to the following will be displayed.

Changing Evaluation Mode Behavior

You have the flexibility to change the behavior of ImagXpress in evaluation mode. Evaluation mode behavior can be defined by setting the EvaluationMode property in the Licensing class to one of these values:

  • Automatic (default value) – When running under an IIS server, a watermark and all images passed through the component are watermarked, otherwise, the component regularly displays a dialog box stating it is in Trial Licensing mode.
  • Watermark – The images produced by ImagXpress will be stamped with the word “Evaluation”. This evaluation mode is suitable for use in applications that do or do not have a visible user interface.


Toolkit Licensing

Toolkit Licensing
ImagXpress 13 for .NET - User Guide > Licensing > Toolkit Licensing

Accusoft requires customers who are developing code that uses Accusoft components to have a Toolkit license for each developer.

This section provides information about the following:

  • Toolkit Licensing
    • Assigned Toolkit License
    • License Manager
    • Product Editions
    • Registration
      • Registering When Connected to the Internet
      • Registering When Disconnected from the Internet
    • Developing Code


Assigned Toolkit License

Assigned Toolkit License
ImagXpress 13 for .NET - User Guide > Licensing > Toolkit Licensing > Assigned Toolkit License

When licenses are purchased for developers at an organization, a representative is designated to assign the licenses to developers at the organization. Each developer must create an account on Accusoft’s website prior to the assignment of licenses. The organization’s designated representative may request that licenses be reassigned as a result of personnel changes.


License Manager

License Manager
ImagXpress 13 for .NET - User Guide > Licensing > Toolkit Licensing > License Manager

The License Manager is a GUI application that is used by a developer to register and activate Toolkit licenses on their development system. When a paid Toolkit license is registered, the License Manager:

  • Communicates the developer's credentials and the hardware information for the development system to the licensing web service.
  • Installs the returned license key on that system.

Activation involves choosing a Toolkit license, either evaluation or paid, so that the license is active on the system.

You can access the License Manager at: Start > All Programs > Accusoft > Common > License Manager.


Product Editions

Product Editions
ImagXpress 13 for .NET - User Guide > Licensing > Toolkit Licensing > Product Editions

Accusoft products may have multiple editions, each of which supports different features. Products that support multiple editions are installed with multiple evaluation Toolkit licenses, one evaluation Toolkit license per edition.

Selecting An Edition (Activating a Toolkit License)

Evaluation licenses allow developers to try features in different product editions. Since each license supports only a single edition of a product, you can switch between editions by activating the corresponding Toolkit license, either purchased or evaluation, using the License Manager.

When you download an evaluation Toolkit, the evaluation Toolkit license for the edition with the most features is installed by default. However, you may run the License Manager to change the Toolkit license to a lower edition in order to determine if that edition will serve your needs.

If you have purchased multiple editions of the same product, you may install both editions on a development system, but only one edition may be active at a time. Once a license has been activated for a particular system, it may be deactivated (replaced by activating another edition) or reactivated at any time. Similarly, customers who own a lower featured edition may activate a higher featured edition evaluation Toolkit license and then switch back to their paid, lower-featured Toolkit edition license at any time. For example, you can go from a paid Standard edition to an evaluation Professional edition by activating the Professional edition evaluation Toolkit license.


Registration

Registration
ImagXpress 13 for .NET - User Guide > Licensing > Toolkit Licensing > Registration

Registration is the process of creating a paid Toolkit license key for a particular system. Registration for Toolkit licenses is always done through the License Manager. This enables the features for the purchased edition to operate without nag dialogs or watermarks. Registration for each license is only required to be performed once per development system. After a license has been registered on a system, you can use the license without further interaction with the License Manager.

Also refer to the following sections:

  • Registration
    • Registering When Connected to the Internet
    • Registering When Disconnected from the Internet


Registering When Connected to the Internet

Registering When Connected to the Internet
ImagXpress 13 for .NET - User Guide > Licensing > Toolkit Licensing > Registration > Registering When Connected to the Internet

When the development system is connected to the Internet, registration is a fairly simple process.

  1. Start the License Manager.
  2. When prompted, enter your Accusoft login and password.

    The License Manager then displays the available evaluation and purchased licenses assigned to you.

  3. Select a toolkit and click the link to activate the license for that toolkit.

    The License Manager then requests a new license key from the licensing web service and installs it; this completes the registration process.

    If the selected license cannot be installed on the development system due to connection failures or other reasons, a temporary, 15 day "grace" license is installed so as not to interrupt development while a new license is obtained for the development system.


Registering When Disconnected from the Internet

Registering When Disconnected from the Internet
ImagXpress 13 for .NET - User Guide > Licensing > Toolkit Licensing > Registration > Registering When Disconnected from the Internet

When the development system is not connected to the Internet during registration, as is the case in some defense or financial institutions, registration is only slightly less simple.

  1. Run the License Manager and attempt to log in.
    The License Manager detects that the system is not registered and displays the following dialog:

  2. Select the Install Offline option to begin the offline registration process.

  3. Copy the URL to removable media, such as a thumb drive.

  4. Take the thumb drive to a system that is connected to the Internet.
  5. From the connected system, paste the URL into a browser, which automatically displays the toolkits available.
  6. Upon selecting a toolkit, a license is generated, which you then save to the removable media device.
  7. Return to the offline system where the new license is to be installed.
  8. Use the License Manager to browse to the file and install the Toolkit license.


Developing Code

Developing Code
ImagXpress 13 for .NET - User Guide > Licensing > Toolkit Licensing > Developing Code

Once an evaluation or paid Toolkit license has been activated on the development system, no additional code is required to use the Accusoft products on this system. If moving the resulting executable code to a new system, you will need to install Toolkit licenses or incorporate Runtime licenses into your code.


Runtime Licensing

Runtime Licensing
ImagXpress 13 for .NET - User Guide > Licensing > Runtime Licensing

When an application that uses one or more Accusoft products is deployed, it requires a Runtime License for each installation. There are two main types of Runtime Licenses:

  • Automatically Reported. Distribution of Automatically Reported Runtime licenses is handled automatically through the use of licensing software components and web services.
  • Manually Reported. Manually Reported Runtime licensing requires you to provide the number of licenses distributed on a contractually agreed upon basis.

These licensing types are each described in detail in the following sections:

  • Runtime Licensing
    • Automatically Reported Runtime (Node-Locked)
      • Licensing API
      • License Pools
      • License Configuration Files
      • LDK vs. SLU
        • Server Licensing Utility (SLU)
        • Licensing Development Kit (LDK)
      • Deployment Proxy Service (DPS)
    • Manually Reported Runtime (Non-Node-Locked)
      • Solution Name
      • Solution Key
      • OEM License Key
If you are upgrading from an earlier version of ImagXpress, please see the Upgrading Runtime Licensing section for important information.


Automatically Reported Runtime (Node-Locked)

Automatically Reported Runtime (Node-Locked)
ImagXpress 13 for .NET - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked)

Automatically Reported Runtime licenses use a mechanism similar to Toolkit licensing to activate a license for a particular system. In this case, each installation has a unique license that is pulled from the pool of licenses purchased by the customer. When the license key is generated, it contains hardware information that identifies the system on which the license is to be installed.

The Licensing Development Kit component, which interacts with the licensing web service and installs the newly generated license key, may be used directly by the application or it may be used through a simple tool known as the Server Licensing Utility.

  • The Licensing Development Kit requires integration with the application or installation utility to perform license activation.
  • The Server Licensing Utility is a stand-alone application that integrates the Licensing Development Kit to perform the registration.

This topic provides information about the following:

  • Automatically Reported Runtime (Node-Locked)
    • Licensing API
    • License Pools
    • License Configuration Files
    • LDK vs. SLU
      • Server Licensing Utility (SLU)
      • Licensing Development Kit (LDK)
    • Deployment Proxy Service (DPS)


Licensing API

Licensing API
ImagXpress 13 for .NET - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > Licensing API

The Licensing API is used in the developer’s code to specify Runtime Licensing deployment information. This is used to unlock the Accusoft products and enable all licensed features at runtime. Both the "Solution Name" and "Solution Key" values used in the API described below are provided by Accusoft, along with the License Configuration file, at the time of purchase of a Runtime License.

Solution Name

The solution name is the name assigned by Accusoft to the licenses purchased for runtime deployment. It is a character string that is set for a component prior to use in a deployment environment and is typically the name of the organization that purchased the runtime licenses. It is set via the SetSolutionName method of the component’s Licensing class. For example:

Copy Code
ImagXpress ix = new ImagXpress();
ix.Licensing.SetSolutionName("ACMEImaging");

The Solution Name must be set in order to use runtime licensing.

Solution Key

The Solution Key is a set of four numbers assigned when the licenses are purchased for runtime deployment; the Solution Key also identifies the organization that purchased the runtime licenses. The Solution Key is set via the SetSolutionKey method of the component’s Licensing class. For example:

Copy Code
ImagXpress ix = new ImagXpress();
ix.Licensing.SetSolutionName("ACMEImaging");
ix.Licensing.SetSolutionKey(0x1C3A023F, 0xA018F260, 0x37AF0E51, 0x557F2389);

The Solution Key must be set in order to use runtime licensing.


License Pools

License Pools
ImagXpress 13 for .NET - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > License Pools

When Automatically Reported Runtime licenses are purchased, they are organized into pools of a specific version and platform for a particular toolkit. For example, if a customer developed two applications using ImagXpress, one using 32-bit ActiveX and the other using .NET, they would purchase two pools of runtime licenses, one for the ActiveX platform and one for the .NET platform. At installation, a new license would be pulled from the appropriate pool, depending upon which platform the application is using.


License Configuration Files

License Configuration Files
ImagXpress 13 for .NET - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > License Configuration Files

When an Automatically Reported Runtime license is purchased, a License Configuration file is created and distributed to the customer along with their assigned Solution Name and Solution Key. The License Configuration file contains information about the Runtime licenses for a particular platform and version of a toolkit. It is used by the Server Licensing Utility or License Development Kit to activate licenses when the customer’s application is installed on their users' systems.

See Also
Licensing API


LDK vs. SLU

LDK vs. SLU
ImagXpress 13 for .NET - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > LDK vs. SLU

Both the Licensing Deployment Kit and the Server Licensing Utility perform the same function of registering the Runtime license for the system on which it will be run. Both are provided in order to give you some options.

When installing the license, the user you are running as must have Administrator access so that the Registry can be accessed and the license can be added to the system.
  • If you are deploying to your own systems (e.g., for enterprise IT staff), the use of an Accusoft branded Server Licensing Utility may meet your needs. Similarly, if you handle the deployment onto end users systems, you may also find the Server Licensing Utility to be sufficient.
  • If you wish to hide this licensing registration from end users, you will likely choose the Licensing Deployment Kit, which allows you to integrate the registration process into your application. The Licensing Deployment Kit also allows for the optional assignment of Access Keys to specific users, which lets you manage your licenses more directly and limits the distribution of licenses.


Server Licensing Utility (SLU)

Server Licensing Utility (SLU)
ImagXpress 13 for .NET - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > LDK vs. SLU > Server Licensing Utility (SLU)

The Server Licensing Utility is a simple Windows application that uses License Configuration Files to request a license key from the purchased Runtime licenses. The Server Licensing Utility registers that Runtime license on the system where your application will be running. This utility can be used by developers for testing, by your deployment team, or by your end users to register their Runtime license.

When installing the license, the user you are running as must have Administrator access so that the Registry can be accessed and the license can be added to the system.

In the Server Licensing Utility dialog, add your License Configuration file(s) as follows:

  1. Click Add and navigate to your License Configuration file(s).
  2. Select the appropriate License Configuration file(s) and click Open.
  3. After all applicable License Configuration files have been added, click Auto Register or Manually Register, depending on whether or not you are connected to the Internet. Refer to the sections below for more information.

Auto Register Toolkit (Connected to Internet)

Automatic registration works in much the same way as connected Toolkit registration and requires an Internet connection on the system where your application software will be deployed. The license information along with the system’s hardware information is sent over the Internet to the Accusoft licensing web service. If an unused license is available, a new license key containing information for the system is generated, returned, and is then automatically installed by the Server Licensing Utility.

Manually Register Toolkit (Disconnected from Internet)

Manual registration is used when the system where your application software will be deployed is not connected to the Internet and therefore cannot be registered automatically. This operation is similar to Disconnected Registration with the License Manager.

  1. Copy the Hardware Key and URL to a removable media device, such as a thumb drive, and then take it to a system that is connected to the Internet.
  2. From the connected system, paste the URL into a browser. A page will appear that contains a field into which you enter the hardware key.
  3. After this hardware key is entered, a license file with the license key is downloaded, which you then save to the removable media device.
  4. Return to the offline system with the removable media device onto which you have saved the license file.
  5. Click Open License File and navigate to the license file. Click OK in the file selection dialog.
    Alternatively, you can open the license file with a text editor, copy the license key to the clipboard, and click Paste License Key to paste the new license key into the License Key field.
  6. Click the License button; the new license will be installed.


Licensing Development Kit (LDK)

Licensing Development Kit (LDK)
ImagXpress 13 for .NET - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > LDK vs. SLU > Licensing Development Kit (LDK)

The Licensing Development Kit is an ActiveX component that may be used instead of the Server Licensing Utility. (Actually, the Server Licensing Utility is only a user interface for the Licensing Development Kit.) The Licensing Development Kit provides an interface for a developer to set the License Configuration File path and other properties as well as initiate requests to the licensing web service to generate license keys.

When installing the license, the user you are running as must have Administrator access so that the Registry can be accessed and the license can be added to the system.

This topic contains these sections:
  • AccuLicClient.DLL
  • Assigned Access Keys
  • Automatic (Connected) Mode Registration
  • Manual (Disconnected) Mode Registration
  • Evaluation
  • Licensing Development Kit Interface
  • Licensing Development Kit Properties
  • Licensing Development Kit Methods

AccuLicClient.DLL

The AccuLicClient.DLL is located with the Server Licensing Utility. It is a 32-bit ActiveX/COM DLL which is used to execute runtime licensing activation functions. The bulk of the functionality provided by the Server Licensing Utility (SLU) is contained within the AccuLicClient.DLL and can be used within your own custom applications to achieve the same thing.

Assigned Access Keys

Unlike the Server Licensing Utility, the Licensing Development Kit allows for the optional assignment of Access Keys to specific users. By doing this, you can specify which of your licenses are assigned to your users. This also limits the distribution of licenses. When Runtime licenses are purchased, a list of Access Keys is distributed to you for this use.

Automatic (Connected) Mode Registration

This mode corresponds to the Automatic (Connected) Registration section described in the Server Licensing Utility section. The process is shown in the C# sample code below:

Copy Code
// Instantiate the LDK ActiveX component
IDeploymentComponent ldk = new DeploymentComponent();

// Set the path to the configuration file provided
// when the runtime licenses were purchased.
ldk.ConfigPath = @"C:\config.txt";

// Attempt to get the next available license.
// Note that you may alternately pass an Access Key
ldk.GetLicKeyAuto("");

if (ldk.ResultCode != enumLdkErrorCodes.LDK_SUCCESS)
{
    // Automatic Registration Failed - A temporary license
    // has been installed but will expire in 15 days.
    // TODO add code to notify user of issue and 15 day expiration.

    if (ldk.ResultCode == enumLdkErrorCodes.LDK_ERR_INET_CONN_BROKEN)
    {
        // No Internet Connection – Optionally do manual registration
    }
}
else
{
    // The license has been registered and installed.
}

The registration process is then complete. If any part of the registration process fails, a temporary license key is installed and is typically valid for 15 days. During this time, you are allowed to use the product while resolving any licensing related problems.

Manual (Disconnected) Mode Registration

This mode corresponds to the Manual (Disconnected) Registration section described in the Server Licensing Utility section. The process is shown in the C# code below:

Copy Code
// Instantiate the LDK ActiveX component
IDeploymentComponent ldk = new DeploymentComponent();

// Set the path to the configuration file provided
// when the runtime licenses were purchased.
ldk.ConfigPath = @"C:\config.txt";

// Get the hardware key for the system.  Note
// that you may alternately pass an Access Key
string hardwareKey = ldk.GetHdwKey("");

// Write the hardware key to some type of removable media.
ApplicationSpecificMethodToWriteHardwareKey(hardwareKey);

At this point, you have the hardware key on some type of removable media. Take the media to a system that is connected to the Internet, acquire the license key by uploading the hardware key, write the new license key to the removable media, and then return to the disconnected system. The application then reads the license key from the removable media and installs the license key as shown below.

Copy Code
// After taking the hardware key to a system with an Internet
// connection and acquiring the license key string from the
// manual registration web site, read the key into your
// application.
string manuallyAcquiredLicenseKey = ApplicationSpecificMethodToReadLicenseKey();

// Install the license key
ldk.LicKey = manuallyAcquiredLicenseKey;

The manual license registration and installation is then complete. Like the automatic case above, if any error occurs during the setting of the license key, a temporary license is installed.

Evaluation

The Licensing Development Kit also has the ability to install an Evaluation License for purchased runtime products. This process is simply:

Copy Code
// Instantiate the LDK ActiveX component
IDeploymentComponent ldk = new DeploymentComponent();

// Set the path to the configuration file provided
// when the runtime licenses were purchased.
ldk.ConfigPath = @"C:\config.txt";

// Install an evaluation license
ldk.StartEvalPeriod();

Licensing Development Kit Interface

The interface to the Licensing Development Kit is shown below:

Copy Code
interface IDeploymentComponent : IDispatch
{
   [propget, id(1)] HRESULT LicKey([out, retval] BSTR* pVal);
   [propput, id(1)] HRESULT LicKey([in] BSTR newVal);
   [propget, id(2)] HRESULT srvURL([out, retval] BSTR* pVal);
   [propput, id(2)] HRESULT srvURL([in] BSTR newVal);
   [propget, id(3)] HRESULT ConfigPath([out, retval] BSTR* pVal);
   [propput, id(3)] HRESULT ConfigPath([in] BSTR newVal);
   [propget, id(4)] HRESULT ResultString([out, retval] BSTR* pVal);
   [propget, id(5)] HRESULT ResultCode([out, retval] enumLdkErrorCodes* pVal);
   [id(6)]           HRESULT GetLicKeyAuto([in] BSTR accKey);
   [id(7)]           HRESULT GetHdwKey([in] BSTR accKey, [out,retval] BSTR* hdwKey);
   [id(8)]           HRESULT StartEvalPeriod(void);
   [propget]         HRESULT LicenseInfo([out, retval] BSTR* pVal);
   [propput]         HRESULT LicenseInfo([in] BSTR newVal);
   [id(10)]          HRESULT GetEvalPeriod([out, retval] long* pVal);
};

Licensing Development Kit Properties

  • LicKey: Stores the License Key to the registry when it is set, and reads it from the registry during the get operation.
  • srvURL: Gets and sets the URL path to the licensing web service. The default is the URL path to Accusoft’s Deployment Licensing Service.
  • ConfigPath: Gets and sets a path to the deployment configuration file. Multiple products can be registered at one time by setting the filenames as a semicolon-delimited list: e.g., “c:\config.txt;c:\config2.txt”.
  • ResultString: Contains the string descriptions of any error that may have occurred during the last operation.
  • ResultCode: Can be used to contain any of the error codes described in Licensing Component Error Codes and Messages.
  • LicenseInfo: Used to transfer license information onto new system hardware. To transfer the license information into new system hardware, do the following:
  1. Get the LicenseInfo value and store it in a safe place.
  2. Change the system hardware.
  3. Set the LicenseInfo to the value you saved in step (1).
  4. Run the GetLicKeyAuto method (or perform its manual analog) to obtain a license for the new system hardware.

Licensing Development Kit Methods

  • GetLicKeyAuto: Obtains a License Key for the end user’s system using the automatic (or connected) scenario. It takes an Access Key as its input parameter, and stores the obtained license key in the registry. If you choose not to distribute individual Access Keys, the accKey argument should be an empty string.
  • GetHdwKey: Obtains a hardware key from the current machine and returns it (as hdwKey). If you choose not to distribute individual access keys, the accKey argument should be an empty string.
  • StartEvalPeriod: Sets an evaluation licensing mode for the product and starts an evaluation period. This method is provided so you can distribute an evaluation version of your application, without having to distribute Access Keys to people who would like to evaluate your software. Using this method you can license Accusoft components on the end user’s system for a limited time – the default is 30 days, but it can be customized per request to Accusoft. If the evaluators purchase your software, you can then issue them an access key using either the automatic or manual scenarios to obtain permanent component licenses, just as Accusoft does for its evaluators.
  • GetEvalPeriod: Obtains the remaining time on an evaluation (in days). It returns EvalPeriod < 0 if the evaluation period is expired.


Deployment Proxy Service (DPS)

Deployment Proxy Service (DPS)
ImagXpress 13 for .NET - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > Deployment Proxy Service (DPS)

For systems where the deployed application will not have direct access to the Accusoft licensing web services, you can use the Deployment Proxy Service as a bridge to reroute the licensing communication. The Proxy Service will act as a trusted "go-between" for the Accusoft licensing system and the deployed application. This tool can be useful if the application will be deployed in a secured environment, where limited systems have external network access.

Additionally, the Proxy Service allows Accusoft customers to manage license registration more directly. The source for the Deployment Proxy Service is provided, allowing users to integrate the licensing process into their CRM, ERP, or other systems for tracking Automatically Reported Runtime Licenses.

For more information about the Deployment Proxy Service, please contact our Support team.


Manually Reported Runtime (Non-Node-Locked)

Manually Reported Runtime (Non-Node-Locked)
ImagXpress 13 for .NET - User Guide > Licensing > Runtime Licensing > Manually Reported Runtime (Non-Node-Locked)

Manually Reported Runtime licensing embeds all of the licensing information directly into your application. Installation does not require any further licensing interaction. However, it is your responsibility to provide royalty reporting to Accusoft for the actual licenses deployed.

This section provides information about the following:

  • Manually Reported Runtime (Non-Node-Locked)
    • Solution Name
    • Solution Key
    • OEM License Key


Solution Name

Solution Name
ImagXpress 13 for .NET - User Guide > Licensing > Runtime Licensing > Manually Reported Runtime (Non-Node-Locked) > Solution Name

The solution name is

  • A name assigned by Accusoft to the licenses purchased for runtime deployment.
  • A character string that is set for a component prior to use in a deployment environment.
  • Typically the name of the organization that purchased the runtime licenses.
  • Set via the SetSolutionName method of the component’s Licensing class. For example:
Copy Code
ImagXpress ix = new ImagXpress();
ix.Licensing.SetSolutionName("ACMEImaging");

The Solution Name must be set in order to use runtime licensing.


Solution Key

Solution Key
ImagXpress 13 for .NET - User Guide > Licensing > Runtime Licensing > Manually Reported Runtime (Non-Node-Locked) > Solution Key

The Solution Key is

  • A set of four numbers assigned when the licenses are purchased for runtime deployment.
  • An identifier of the organization that purchased the runtime licenses.
  • Set via the SetSolutionKey method of the component’s Licensing class. For example:
Copy Code
ImagXpress ix = new ImagXpress();
ix.Licensing.SetSolutionName("ACMEImaging");
ix.Licensing.SetSolutionKey(0x1C3A023F, 0xA018F260, 0x37AF0E51, 0x557F2389);

The Solution Key must be set in order to use runtime licensing.


OEM License Key

OEM License Key
ImagXpress 13 for .NET - User Guide > Licensing > Runtime Licensing > Manually Reported Runtime (Non-Node-Locked) > OEM License Key

The OEMLicense Key is

  • For use only by customers who choose to use Manually Reported Runtime licensing.
  • A unique identifier of the customer, product, version, edition, and platforms for which the license is valid.

When this key is set via the SetOEMLicenseKey method of the component’s Licensing class, the component is completely licensed and can be distributed without any further licensing operations.

Copy Code
ImagXpress ix = new ImagXpress();
ix.Licensing.SetSolutionName("ACMEImaging");
ix.Licensing.SetSolutionKey(0x1C3A023F, 0xA018F260, 0x37AF0E51, 0x557F2389);
ix.Licensing.SetOEMLicenseKey("1.0.GQCC0EmUgONaI4QDZ32tpGWfpGW4gtbC0iIC0iN4bigYM3m3K5b487QOsAM38O24mUp5bOpD2O240OQ32U2YsUKDKA87MYPGgGgaptMiK5Nv8AI4mYg4m3QvW52DZCPGs4p784mtP4IUgOWiIG0AQYp4052iIAWvNCZfpGWC8vQ5P4ZGKaPAWfbiYfZOI303pOZAgisiNaWA27gGsf8Ob7Zvm5IaKGI4KC8GsG2CWYpGQAg5sUmYWvZCQANig48G2ap4bG0DsO240YsUmtptNiZamCPGbYMfMO83gANAZCN52YbY8U8f8DM4m3g7MYMYWGW5Q7QGWaMiN7MtZfmtgY8AN7NDP7Z4W7sCbGKUPa0im7EDPP");

This property is not required for Automatically Reported Runtime licensing.


Licensing Glossary

Licensing Glossary
ImagXpress 13 for .NET - User Guide > Licensing > Licensing Glossary
The following sections each describe a licensing term:
  • Access Key
  • Accusoft Products
  • Activation
  • Assigned Access Key
  • Automatically Reported Runtime Licensing
  • Customers, Developers, and Users
  • Edition
  • Evaluation License
  • Hardware Key
  • License Configuration File
  • Licensing Development Kit (LDK)
  • License Key
  • License Manager
  • Manually Reported Runtime Licensing
  • Node-Locked Licensing
  • Non-Node-Locked Licensing
  • Paid License
  • Registration
  • Runtime (Deployment) Licensing
  • Server Licensing Utility (SLU)
  • Toolkit Licensing
  • Web Services

Access Key

All licenses are assigned a unique identifier known as an Access Key. Access Keys are associated with the organization that purchased the license.

Accusoft Products

An Accusoft product may be licensed with either a Toolkit License or a Runtime License.

Activation

Activation is the process of selecting a previously registered toolkit license. Licenses may be paid (Toolkit) or evaluation, and may be for one of many product editions, for products with multiple editions.

Assigned Access Key

An assigned Access Key is one that is assigned to a specific user or users. The assignment of Access Keys to specific users can be done using the Licensing Development Kit (LDK).

Automatically Reported Runtime Licensing

Runtimes may be licensed in one of two ways: automatic reporting or manual reporting. With automatic reporting, you do not need to worry about royalty reporting; it is handled by the licensing layer.

Customers, Developers, and Users

Customers are simply any person who has purchased an Accusoft product. Developers are customers who possess a license for an Toolkit. Users are typically the customers of Accusoft's customers who use applications built around Accusoft components and are assigned a runtime license.

Edition

Some Accusoft products have multiple editions. Editions may offer multiple levels of product speed or product features, allowing customers to find a price-performance mix that is appropriate for them. Products that support multiple editions register multiple Toolkit licenses at installation time, one Toolkit license per edition. Developers must select an edition to activate using the License Manager.

Evaluation License

An evaluation license is a Toolkit license that is unpaid. When an Accusoft Toolkit is installed, evaluation licenses for all applicable product editions are installed and registered, and the edition with the most features is activated. Evaluation Toolkit licenses can be used to try out products. However, the product behavior is limited by trial dialog pop-ups, timeouts, or evaluation watermarks. When you determine the product is a good fit, you can purchase a Toolkit license to eliminate trial dialog pop-ups, timeouts, and evaluation watermarks.

Hardware Key

When a license is activated for a product, the system information that identifies the installation hardware is contained within an encrypted string and is used to generate the license key for the product. The string containing the encrypted hardware information is known as the Hardware Key.

License Configuration File

When a Toolkit or an Automatically Reported Runtime license is purchased, a configuration file is provided that contains information about the license that was purchased. This file is used by the licensing utilities (License Manager, Server License Utility, and License Development Kit) to install a license on the system.

Licensing Development Kit (LDK)

The Licensing Development Kit (LDK) is an ActiveX component that may be used for Runtime Licensing. The LDK is one mechanism for Automatically Reported Runtime Licensing; the Server Licensing Utility (SLU) is the other.

License Key

Each product license has a unique key associated with it that uniquely identifies the customer, product, version, edition, and platforms, and, in some cases, the hardware for which the license is valid.

License Manager

The License Manager is a GUI application that is used by a developer to register and activate Toolkit licenses on their development system.

Manually Reported Runtime Licensing

Runtimes may be licensed in one of two ways: automatic reporting or manual reporting. With Manually Reported Runtime Licensing, you embed all of the licensing information directly into your application. You must manually provide royalty reporting to Accusoft for the actual licenses deployed. This model will be the best choice for you if you are not connected to the Internet at runtime, as might be the case in an defense or financial application.

Node-Locked Licensing

Another name for Automatically Reported Runtime Licensing.

Non-Node-Locked Licensing

Another name for Manually Reported Runtime Licensing.

Paid License

A paid license is a Toolkit license that you have purchased from Accusoft. It is ready to be used in production, with no trial dialog pop-ups, timeouts, or evaluation watermarks. If you wish to test other editions of the Accusoft product for which you have purchased a Paid License, you may activate an Evaluation license for that edition; a complete set of Evaluation licenses for all editions is registered at installation time.

Registration

Registration is the process of informing the License Manager about a new Toolkit license you have purchased. It uses this information to create a license key on your system; this allows you to activate the product for development with no restrictions, such as trial dialog pop-ups, timeouts, or evaluation watermarks.

Runtime (Deployment) Licensing

When deploying an application, a Runtime License is also required for each user’s installation. You must purchase runtime licenses, which are consumed as licenses are registered. There are two Runtime licensing models: Automatically Reported Runtime License; and Manually Reported Runtime License.

Server Licensing Utility (SLU)

The Server Licensing Utility (SLU) is a small GUI application that allows you to request a license key from the Runtime licenses you have purchased. The SLU is one mechanism for Automatically Reported Runtime Licensing; the Licensing Development Kit (LDK) is the other.

Toolkit Licensing

Each Toolkit is assigned to a specific developer who has a registered account with Accusoft. When the developer installs the Toolkit, it is not fully functional until they have activated the license through the use of the License Manager application. When the developer starts the License Manager, they are required to provide login credentials that identify and allow them to activate their license on a development system. See Toolkit Licensing.

Web Services

When a license is registered, information that uniquely identifies the customer’s or user’s hardware is passed along with the license information over the Internet to a web service. The web service validates the licensing request, generates a key that includes the hardware information, and returns the new license key to the application that made the licensing request. The license key is then stored on the requested system and used by the component when it is executed. It is also possible to register systems that are not directly connected to the Internet through the use of removable media and a different system that is connected to the Internet.


Software License Agreement

Software License Agreement
ImagXpress 13 for .NET - User Guide > Licensing > Software License Agreement

PLEASE READ THE FOLLOWING SOFTWARE LICENSE AGREEMENT WHICH GOVERNS YOUR RIGHT TO USE OF THE TOOLKIT. YOU MUST ACCEPT THESE TERMS BEFORE YOU ARE ALLOWED TO INSTALL THE TOOLKIT. YOU EXPRESSLY AGREE THAT YOU HAVE THE AUTHORITY TO CONTRACTUALLY BIND THE ORGANIZATION AGREEING TO THESE TERMS.

BY CLICKING "I ACCEPT," OR INSTALLING TOOLKIT, OR PLACING TOOLKIT IN-USE, LICENSEE IS AGREEING TO BE BOUND BY THIS AGREEMENT.

1. GRANT OF AGREEMENT

This Accusoft Corporation, ("ACCUSOFT") Software License Agreement ("AGREEMENT") grants the organization contracting under this agreement as licensee ("LICENSEE") a limited, nontransferable, nonexclusive and non-assignable license to use the trial mode version of this ACCUSOFT Development Toolkit ("TOOLKIT") on a single computer for evaluation of fitness only and not for any commercial purpose; or to use a properly purchased and registered TOOLKIT, for development purposes only on a single computer, provided the TOOLKIT is IN-USE on only one computer at any time. (However additional TOOLKIT licenses may be purchased.) TOOLKIT is "IN-USE" on a computer when it becomes loaded by any means for any purpose into temporary memory (that is, including but not limited to RAM) or when it becomes copied or installed to less temporary storage by any means for any purpose (that is, including but not limited to hard disk, CD-ROM or other removable disk or tape, USB or other flash memory drive or card, or other local, networked, or cloud storage device) when it is accessible to that computer. The TOOLKIT is explicitly not to be used on a site-wide basis, via a server or other networked connection.

2. REDISTRIBUTION OF TOOLKIT RUNTIMES

ACCUSOFT does not grant LICENSEE any rights to deploy, license, sell, reproduce, copy, install, lease, timeshare, rent, or otherwise distribute or transfer TOOLKIT or any portion of TOOLKIT ("PORTION") except as provided in Section 1. GRANT OF AGREEMENT. For licensing information about any other distribution of TOOLKIT or PORTION, please visit our web site (www.accusoft.com/licensing.htm), or contact our sales staff. LICENSEE agrees to notify ACCUSOFT immediately of any violations or changes in status regarding LICENSEE's compliance with any term of this AGREEMENT.

In the event that ACCUSOFT grants LICENSEE in a written separate runtime license agreement ("RUNTIME AGREEMENT") a right to deploy, license, sell, reproduce, copy, install, lease, timeshare, rent, or otherwise distribute or transfer PORTIONS, the RUNTIME AGREEMENT will specify what PORTIONS may be distributed ("RUNTIME"). LICENSEE agrees to acknowledge and uphold the terms and conditions of this AGREEMENT as well as the terms of the RUNTIME AGREEMENT itself, which will be provided only in writing. In such event, LICENSEE may distribute RUNTIMES as part of the LICENSEE's software application or derivative works ("PRODUCT") upon additionally agreeing to the following:

a) LICENSEE understands and acknowledges that in order to receive any discounted pricing for RUNTIME distribution licensing fees based on the type of installation, it must either: 1) prepay for a number of RUNTIME licenses that is sufficient to qualify for ACCUSOFT's then-current published quantity discount, or 2) it must pay for the licenses in accordance with a written contract between LICENSEE and ACCUSOFT.

b) LICENSEE's PRODUCT shall not compete to any degree with the TOOLKIT. Such competitive PRODUCTS are defined as software development toolkits that include similar functionality as TOOLKIT and that are intended for use by software developers and/or system integrators.

c) LICENSEE's PRODUCT must be substantially greater in scope with greater functionality and features than those of the TOOLKIT.

d) LICENSEE will not use ACCUSOFT's name, logo, or trademarks to market PRODUCT without prior written approval of ACCUSOFT except LICENSEE will include a statement substantially similar to the following within PRODUCT documentation and about box: "Portions of this product contain imaging and other technology owned by Accusoft Corporation, Tampa, FL, (www.accusoft.com). ALL RIGHTS RESERVED."

e) LICENSEE agrees to only distribute the RUNTIMES. No license or other rights are granted to LICENSEE for any distribution of the TOOLKIT or PORTIONS including, but not limited to, documentation, source code, or the RUNTIME distribution unlock codes.

g) LICENSEE will only distribute the RUNTIMES on the hardware and operating system(s) for which the RUNTIMES are intended to be used according to the RUNTIME AGREEMENT.

If ANY of the terms of this AGREEMENT are not applicable to LICENSEE'S situation, or if any of the terms of this AGREEMENT cannot be complied with, or if LICENSEE needs modifications to this AGREEMENT or the license granted for any reason, LICENSEE must contact ACCUSOFT about obtaining an expanded license from ACCUSOFT (available by phone at: 813-875-7575, x321, by e-mail at: Sales@accusoft.com or by fax at: 813-875-7705).

This AGREEMENT grants rights to LICENSEE only for the TOOLKIT and does not convey any other rights of use or distribution to ACCUSOFT technology.

3. OWNERSHIP

LICENSEE acknowledges and agrees that ACCUSOFT owns all rights, title and interest in the TOOLKIT, in all forms, including without limitation any and all worldwide proprietary rights therein, including but not limited to trademarks, copyrights, patent rights, patent continuations, trade secrets and confidential information.

LICENSEE may not remove or alter the copyright notice from any copy of the TOOLKIT or any copy of the written materials, accompanying the TOOLKIT.

LICENSEE waives its right to contest any of ACCUSOFT's patents, trademarks, service marks, trade names, copyrights, and other intellectual property and proprietary rights in and to the TOOLKIT.

LICENSEE shall not use such trademarks, service marks, and trade names except where and as permitted under this AGREEMENT without receiving ACCUSOFT's prior written approval of such use. If such approval is granted, LICENSEE’s right to use such trademarks, service marks, and trade names shall end upon the termination of this AGREEMENT.

4. RESTRICTIONS AND RESERVATIONS.

All rights and licenses not expressly granted to LICENSEE are reserved to ACCUSOFT. LICENSEE is strictly prohibited from reproducing, copying, marketing, selling, distributing, licensing, sublicensing, leasing, timesharing or renting the TOOLKIT or PORTION, and LICENSEE is strictly prohibited from any use of the TOOLKIT or PORTION except as permitted by this AGREEMENT, and such actions are expressly prohibited. LICENSEE is strictly prohibited from incorporating or including the TOOLKIT or PORTION into or as part of any PRODUCT or service of LICENSEE except as provided by this AGREEMENT, regardless of the functionality of TOOLKIT (or lack thereof) within or as part of such PRODUCT or service of LICENSEE. LICENSEE shall not for any reason disassemble, decompile, decrypt or reverse engineer the TOOLKIT or PORTION or in any manner attempt to discover or reproduce the source code or any other copyrightable, proprietary, or trade secret aspect of the TOOLKIT or PORTION. Nor shall LICENSEE use the TOOLKIT or PORTION, directly or indirectly, in developing LICENSEE's own PRODUCT with, or including, similar functionality. LICENSEE shall not make any copies of the TOOLKIT or PORTION for any purpose whatsoever except as permitted by this AGREEMENT. Source code that is provided with TOOLKIT for sample or demonstration purposes may be used directly or indirectly in developing PRODUCT, however it may not be distributed in source form in whole or in part with or as part of PRODUCT.

5. WARRANTY DISCLAIMER

LICENSEE ACKNOWLEDGES AND AGREES THAT THE TOOLKIT IS PROVIDED "AS IS." ACCUSOFT DISCLAIMS ANY AND ALL REPRESENTATIONS AND WARRANTIES OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND AGAINST INFRINGEMENT.

6. LIMITATION OF LIABILITY

ACCUSOFT SHALL HAVE NO LIABILITY TO LICENSEE, LICENSEE AFFILIATES, SUBSIDIARIES, SHAREHOLDERS, OFFICERS, DIRECTORS, EMPLOYEES, REPRESENTATIVES OR ANY THIRD PARTY, WHETHER IN CONTRACT, TORT, NEGLIGENCE OR PRODUCTS LIABILITY, FOR ANY CLAIM, LOSS OR DAMAGE, INCLUDING BUT NOT LIMITED TO, LOST PROFITS, LOSS OF USE, BUSINESS INTERRUPTION, LOST DATA, LOST FILES, OR FOR ANY DIRECT, INDIRECT, SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES OF ANY KIND OR NATURE WHATSOEVER ARISING OUT OF OR IN CONNECTION WITH USE OF OR INABILITY TO USE THE TOOLKIT, OR THE PERFORMANCE OR OPERATION OF THE TOOLKIT, EVEN IF ACCUSOFT HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

7. INDEMNIFICATION BY LICENSEE

LICENSEE SHALL INDEMNIFY, HOLD HARMLESS AND DEFEND ACCUSOFT FOR ANY LOSS, CLAIM, ACTION OR PROCEEDING THAT ARISES OR RESULTS FROM ANY ACTIONS OR OMISSIONS OF LICENSEE PERTAINING TO THE PRODUCT OR THE TOOLKIT AND FROM ANY ACTIONS OF LICENSEE THAT ARE IN VIOLATION OF THIS AGREEMENT.

8. TERM AND TERMINATION

Unless otherwise agreed to by the parties, this AGREEMENT shall become effective upon the earlier of LICENSEE's clicking of "I Accept" or LICENSEE'S installing or placing TOOLKIT IN_USE ("Effective Date") and shall continue in full force and effect until terminated in accordance with the terms set forth in this AGREEMENT.

Any material breach of this AGREEMENT shall automatically and immediately terminate this AGREEMENT. In the event that LICENSEE ceases to do business or is adjudged bankrupt or insolvent, ACCUSOFT may, at its sole option, terminate this AGREEMENT, by giving ten (10) Business Days written notice of such termination, which notice shall identify and describe the basis for such termination.

In the event of any termination of this AGREEMENT, any RUNTIME AGREEMENT is simultaneously terminated and LICENSEE shall stop using the TOOLKIT and PORTION, shall cease manufacturing the PRODUCT containing TOOLKIT or PORTION, and shall cease distributing PRODUCT containing TOOLKIT or PORTION. LICENSEE shall also require its resellers, OEMs, and other distribution channels (if any) to likewise stop manufacturing and distributing the PRODUCT containing TOOLKIT or PORTION. Within ten (10) Business Days thereafter, LICENSEE shall return or, at ACCUSOFT's option, destroy, the TOOLKIT and all PORTIONS, whether or not incorporated in or with the PRODUCT, that are within LICENSEE’s possession, custody and control, and shall certify to ACCUSOFT in writing within ten (10) Business Days after that return or destruction that it has complied with the foregoing obligation.

All Sections except Section 1. GRANT OF LICENSE shall continue in full force and effect, notwithstanding any termination of this AGREEMENT.

9. LIQUIDATED DAMAGES

In the event LICENSEE (a) copies the TOOLKIT or PORTION except as permitted by this AGREEMENT, (b) uses the TOOLKIT or PORTION for any reason other than as permitted by this AGREEMENT, (c) installs or uses the TOOLKIT or PORTION on more than a single computer, or (d) otherwise violates or breaches this Agreement, LICENSEE agrees that ACCUSOFT is entitled to obtain as liquidated damages and not as a penalty the greater of the amount of (v) the published quantity one distribution price based upon the type of distribution, or (w) $99 per each user of each PRODUCT or service of LICENSEE in which the TOOLKIT or PORTION is included, copied, incorporated, embedded or accessible; (x) $100 per copy of TOOLKIT or PORTION; (y) $100 per copy of any PRODUCT in which TOOLKIT or PORTION is included, copied, incorporated, embedded or accessible; or (z) 3% of all revenues realized by LICENSEE pertaining to any PRODUCTS or services of LICENSEE in which TOOLKIT or PORTION is included, copied, incorporated, embedded or accessible. THE LICENSEE EXPRESSLY AGREES THAT THE FOREGOING LIQUIDATED DAMAGES ARE NOT A PENALTY.

10. CONFIDENTIALITY

LICENSEE acknowledges that the TOOLKIT contains ACCUSOFT know-how, confidential and trade secret information ("PROPRIETARY INFORMATION"). LICENSEE agrees: (a) to hold the PROPRIETARY INFORMATION in the strictest confidence, (b) not to, directly or indirectly, copy, reproduce, distribute, manufacture, duplicate, reveal, report, publish, disclose, cause to be disclosed, or otherwise transfer the PROPRIETARY INFORMATION to any third party, (c) not to make use of the PROPRIETARY INFORMATION other than as permitted by this AGREEMENT, and (d) to disclose the PROPRIETARY INFORMATION only to LICENSEE's representatives requiring such material for effective performance of this AGREEMENT and who have undertaken an obligation of confidentiality and limitation of use consistent with this AGREEMENT. This obligation shall continue as long as allowed under applicable law.

11. INJUNCTIVE RELIEF

LICENSEE agrees that any violation or threat of violation of this AGREEMENT will result in irreparable harm to ACCUSOFT for which damages would be an inadequate remedy. Therefore, in addition to its rights and remedies available at law (including but not limited to the recovery of damages for breach of this AGREEMENT), ACCUSOFT shall be entitled to immediate injunctive relief to prevent any violation of ACCUSOFT's copyright, trademark, trade secret rights regarding the TOOLKIT, or to prevent any violation of this AGREEMENT, including, but not limited to, unauthorized use, copying, distribution or disclosure of or regarding the TOOLKIT or PORTION, as well as any other equitable relief as the court may deem proper under the circumstances.

12. NO REDUCED PRICING

In any determination of ACCUSOFT's damages (whether liquidated damages or actual damages), or any determination of any licensing fees or royalties due ACCUSOFT under this AGREEMENT due to a breach by LICENSEE hereunder, LICENSEE shall not be entitled to any discounts (volume or otherwise) or reduced licensing fees or royalties. The foregoing sentence shall be applicable unless LICENSEE has negotiated and entered into a written, signed agreement with ACCUSOFT for such reduced or discounted licensing fees or royalties and paid ACCUSOFT such fees or royalties in advance of any: (a) distribution of the TOOLKIT or PORTION, (b) copying of the TOOLKIT or PORTION, or (c) incorporation or use of the TOOLKIT or PORTION in or pertaining to any PRODUCT or service of LICENSEE. Further, LICENSEE agrees that it shall not be entitled to reduced licensing fees or royalties when determining ACCUSOFT's damages due to any undertaking or activity by LICENSEE regarding the TOOLKIT or PORTION outside of or exceeding the scope of permission or other terms of this AGREEMENT, or LICENSEE's actions otherwise in violation of this AGREEMENT.

13. ATTORNEYS' FEES AND COSTS

In the event of any lawsuit or other proceeding brought as a result of any actual or alleged breach of this AGREEMENT, to enforce any provisions of this AGREEMENT, or to enforce any intellectual property or other rights in or pertaining to the TOOLKIT or PORTION, the prevailing party shall be entitled to an award of its reasonable attorneys’ fees and costs, including the costs of any expert witnesses, incurred at all levels of proceedings.

14. GOVERNING LAW

This AGREEMENT shall be construed, governed and enforced in accordance with the laws of the State of Florida, without regard to any conflicts of laws rules. Any action related to or arising out of this AGREEMENT will be filed only in the Florida courts and LICENSEE consents to the exclusive jurisdiction and venue of the state and federal courts located in Tampa, Florida.

15. SEVERABILITY

If any provision of this AGREEMENT is determined to be invalid by any court of final jurisdiction, then it shall be omitted and the remainder of the AGREEMENT shall continue to be binding and enforceable. In addition, the Court is hereby authorized to enforce any provision of the AGREEMENT that the Court otherwise deems unenforceable, to whatever lesser extent the Court deems reasonable and appropriate, rather than invalidating the entire provision. Without limiting the generality of the foregoing, LICENSEE expressly agrees that should LICENSEE be found to have breached the AGREEMENT, under no circumstances shall LICENSEE be entitled to any volume or other discount, or reduced licensing fee or royalty in the determination of ACCUSOFT's damages, or otherwise in the determination of any licensing fee or royalty owed to ACCUSOFT.

16. GOVERNMENT RIGHTS

The TOOLKIT and accompanying documentation have been developed at private expense and are sold commercially. They are provided under any U.S. government contracts or subcontracts with the most restricted and the most limited rights permitted by law and regulation. Whenever so permitted, the government and any intermediaries will obtain only those rights specified in ACCUSOFT's standard commercial license. Thus, the TOOLKIT referenced herein, and the documentation provided by Accusoft hereunder, which are provided to any agency of the U.S. Government or U.S. Government contractor or subcontractor at any tier shall be subject to the maximum restrictions on use as permitted by FAR 52.227-19 (June 1987) or DFARS 227.7202-3(a) (Jan. 1, 2000) or successor regulations. Manufacturer is Accusoft Corporation, 4001 N. Riverside Drive Tampa, FL 33603.

17. ENTIRE AGREEMENT

This AGREEMENT represents the entire understanding of the parties concerning the subject matter hereof and supersedes all prior communications and agreements, whether oral or written, relating to the subject matter of this AGREEMENT. Only a writing signed by the parties may modify this AGREEMENT. In the event of any modification in writing, of this AGREEMENT, including an expanded license agreement, all sections of this Agreement survive except Section 2. Limited License.

18. CONTACT US

Should you have any questions concerning this AGREEMENT, or if you desire to contact ACCUSOFT for any reason, please contact ACCUSOFT at 1-813-875-7575.

19. OTHER RESTRICTIONS

a) This AGREEMENT shall not be amended, altered, changed or modified in any way, unless agreed to in writing by both ACCUSOFT and LICENSEE. Such writing must be executed by a duly authorized representative of ACCUSOFT and a duly authorized representative of LICENSEE.

b) This AGREEMENT is not transferable or assignable by LICENSEE under any circumstances, without the prior written consent of ACCUSOFT. ACCUSOFT will not unreasonably withhold such consent. This AGREEMENT shall be binding upon, and is made for the benefit of, each party, its successors, and permitted assignees (if any). For the purposes of this AGREEMENT, any change in control of LICENSEE shall constitute an assignment or transfer of this AGREEMENT requiring prior written consent of ACCUSOFT. As used in this section, a change in control is defined as (i) any change in ownership of more than fifty percent (50%) of the voting interest in LICENSEE, whether by merger, purchase, foreclosure of a security interest or other transaction, or (ii) a sale of all or substantially all of the assets of LICENSEE.

c) The relationship established by this AGREEMENT between LICENSEE and ACCUSOFT shall be that of Licensee and Licensor. Nothing contained in this AGREEMENT shall be construed as creating a relationship of agency, joint venture or partnership between LICENSEE and ACCUSOFT. Neither party shall have any right whatsoever to incur any liabilities or obligations on behalf of the other party.

d) ACCUSOFT's failure to perform any term or condition of this AGREEMENT as a result of conditions beyond its control such as, but not limited to, war, strikes, fires, floods, acts of God, governmental restrictions, power failures, or damage or destruction of any network facilities or servers, shall not be deemed a breach of this AGREEMENT.

e) The headings provided in this AGREEMENT are for convenience and reference purposes only. In the event of a conflict between the terms and conditions listed in this AGREEMENT, and any attached Schedules or Appendices, the terms and conditions of this AGREEMENT shall govern.

f) A waiver of a breach, violation, or default under this AGREEMENT shall not be a waiver of any subsequent breach, violation or default. Failure of either party to enforce compliance with any term or condition of this AGREEMENT shall not constitute a waiver by the party of such term or condition.

g) All notices and communications shall be in writing and shall be deemed to have been duly given the earlier of when delivered or three (3) Business Days after mailing by certified mail, return receipt requested, postage prepaid, or by international delivery service, addressed to the parties at their respective addresses set forth on the Order Form or at such other addresses as the parties may designate by written notice in accordance with this section.

Rev. 20120112

See Also
Distributing ImagXpress
Licensing


Distributing Applications and Deployment

Distributing Applications and Deployment
ImagXpress 13 for .NET - User Guide > Distributing Applications and Deployment

This section provides information about the following:

  • Verify You're Using the Latest Service Pack
  • Distributing ImagXpress


Verify You're Using the Latest Service Pack

Verify You're Using the Latest Service Pack
ImagXpress 13 for .NET - User Guide > Distributing Applications and Deployment > Verify You're Using the Latest Service Pack

Service pack updates will not overwrite paid licensing. Your paid licensing will continue to work and you will not be required to re-enter your purchased registration codes. Service pack updates do not include any changes that might "break" previously developed and/or deployed code.

Verify Latest Development Components

To verify you are using the latest version of an Accusoft Development Component or Components, please refer to the currently released product build numbers at www.accusoft.com/latestbuilds.htm.

If you require further assistance or have questions or comments, please see the section Getting Support for more detailed information.

See Also
Getting Support
Installing on a Development Machine


Distributing ImagXpress

Distributing ImagXpress
ImagXpress 13 for .NET - User Guide > Distributing Applications and Deployment > Distributing ImagXpress

Distribute the appropriate assembly DLL files with applications using the ImagXpress Product:

  • Accusoft.ImagXpress13.Net.dll
  • Accusoft.NotateXpress13.Net.dll
  • Accusoft.ThumbnailXpress6.Net.dll
  • Accusoft.TwainPro9.Net.dll
  • Accusoft.PrintPro8.Net.dll
See Also
Getting Support
Installing on a Development Machine
Software License Agreement
Verify You're Using the Latest Service Pack


Concepts

Concepts
ImagXpress 13 for .NET - User Guide > Concepts

This section provides information about the following:

  • Overview of ImagXpress
  • Supported File Formats
  • Glossary


Overview of ImagXpress

Overview of ImagXpress
ImagXpress 13 for .NET - User Guide > Concepts > Overview of ImagXpress

ImagXpress capabilities are encapsulated for the user in a set of powerful classes:

ImagXpress

The ImagXpress class provides methods and properties to manage licensing of the control.

ImageXView

The ImageXView class provides methods and properties to manage the interface to devices, such as monitors and printers and to other controls, such as NotateXpress™ and ThumbnailXpress™. ImageXView is required to view, print, or annotate an image.

There may be more than one viewer (ImageXView object) associated with a project:

  • To enable multiple views of the same image, create multiple ImageXView objects and assign the same image (ImageX object) to each.
  • To enable viewing multiple images, create multiple ImageXView objects and assign each to a different image (ImageX object).

Processor

The Processor class provides the properties, methods and events necessary to perform image processing on an image. There may be one or more processors associated with a project. Each processor can act on only one image at a time. The Processor class manages all image processing. Multiple Processor components can be added to the project to facilitate parallel processing, within the constraints of your system.

ImageX

The ImageX class provides the properties, methods and events necessary to load an image into ImagXpress, query image data and save the image. ImageX class objects are created during run time. Each ImageX object represents one image that is available in ImagXpress. Multiple ImageX objects can be created.

See Also
ImagXpress Class
ImageXView Class
Processor Class
ImageX Class


Supported File Formats

Supported File Formats
ImagXpress 13 for .NET - User Guide > Concepts > Supported File Formats

ImagXpress® supports the following file formats:

The asterisks (**) below denote the format option is available in the Professional Edition only.

BMP (Microsoft Windows Bitmap)

  • Reads 1, 4, 8, 16, 24 and 32-bit BMP.
  • Reads 1, 4 and 8-bit RLE compressed BMP.
  • Writes 1, 4, 8 and 24-bit BMP.
  • 16 and 32-bit BMP files are converted to 24-bit.

CALS (Type 1)**

  • Reads 1-bit CALS-1 TypeI.
  • Writes 1-bit CALS-1 TypeI.
  • Modify CALS tags.

Camera Raw**

  • Reads most vendor specific camera raw formats.

DCX (PC Paintbrush Multiple Page File Format)

  • Reads 1, 4, 8 and 24-bit DCX.
  • Writes 1, 4, 8 and 24-bit DCX.

DIB (Microsoft Windows Device Independent Bitmap)

  • Reads 1, 4, 8, 16, 24 and 32-bit DIB.
  • Writes 1, 4, 8 and 24-bit DIB as BMPs.
  • 16 and 32-bit DIB files are converted to 24-bit.

DWF (AutoCAD Design Web Format)**

  • Reads DWF.

DWG (AutoCAD Drawing Database)**

  • Reads DWG versions 2.5 through 2007.

DXF (AutoCAD Drawing Interchange Format)**

  • Reads DXF.

EMF (Microsoft Enhanced Metafile Format - also known as WMF)

  • Reads Windows Metafiles.
  • EMF may be displayed in Metafile format or optionally converted to device dependent bitmaps for display.

GIF (CompuServe Graphics Interchange Format)

  • Reads 1 through 8-bit GIF.
  • Writes 1, 4 and 8-bit GIF.
  • Reads and writes GIF89a and GIF87a formats.
  • Reads and writes interlaced and non-interlaced formats.
  • Reads and writes GIF with a transparent color.
  • Internally, 2 & 3-bit GIFs are converted to 4-bit, and 5, 6, and 7-bit GIFs are converted to 8-bit.

ICO (Microsoft Windows Icon)

  • Reads 1, 4, 8, 16, 24, and 32-bit ICO. Single and multiple image.
  • Writes 1, 4, 8, and 24-bit ICO. Single and multiple image.
  • 16 and 32-bit ICO files are converted to 24-bit.
  • Reading and writing a transparent color is supported.

JBIG2 (Joint Bi-level Image Experts Group)

  • Reads black and white (bi-tonal) images.
  • Writes black and white (bi-tonal) images.**
  • Supports standard lossless, lossy and lossy to lossless compression.

JEDMICS C4**

  • Reads JEDMICS C4.

JLS (JPEG LS Format)**

  • Reads 2 through 16-bit grayscale and 24-bit color JLS.
  • Writes 2 through 16-bit grayscale and 24-bit color JLS.

JP2, J2K (JPEG 2000 Format)

  • Reads 2 through 16-bit grayscale and 24-bit color JP2, J2K.
  • Writes 2 through 16-bit grayscale and 24-bit color JP2.
  • Supports lossless and lossy compression and decompression.

JPEG, JIF (JPEG File Interchange Format)

  • Reads 8 and 12-bit grayscale and 24-bit color JPEG.
  • Writes 8 and 12-bit grayscale and 24-bit color JPEG.
  • Reads and writes JFIF compliant JPEG and Progressive JPEG formats.
  • Reads and writes EXIF and IPTC metadata.**

JPEGXR (formerly Microsoft Windows Media Photo – known as HDP and WDP)

  • Reads 8-bit and 16-bit gray, RGB or RGBA (8-bits per channel unsigned integer).
  • Writes 8-bit and 16-bit gray, RGB or RGBA (8-bits per channel unsigned integer).**

LJP (Lossless JPEG)**

  • Reads 8 through 16-bit and 4-bit grayscale, and 24-bit color lossless JPEG.
  • Writes 8 through 16-bit and 4-bit grayscale, and 24-bit color lossless JPEG.
  • Supports RGB and YCBCR compression, and decompression.

MO:DCA**

  • Reads 1-bit MOD:CA.
  • Writes 1-bit MOD:CA.
  • Reads PTOCA and IOCA:
    o 1 bpp IBM MMR, 1 bpp G4, 1 bpp ABIC, 4 bpp Concatenated ABIC (Grayscale).
    o PTOCA Fonts: C0CHz00p0.
    o Codepages: Default to EBCIDIC codepages but also support codepage ‘T1001252’ for ASCII data.
    o Support internal overlays.

PBM (Portable Bitmap)

  • Reads 1-bit PBM.
  • Writes 1-bit PBM.

PCX (PC Paintbrush File Format)

  • Reads 1, 4, 8 and 24-bit PCX.
  • Writes 1, 4, 8 and 24-bit PCX.

PGM (Portable Graymap)

  • Reads 8-bit grayscale PGM.
  • Writes 8-bit grayscale PGM.

PIC, ePIC (Accusoft Enhanced PIC)

  • Reads 8-bit grayscale and 24-bit ePIC format.
  • Writes 8-bit grayscale and 24-bit ePIC format.
  • Reads and writes 24-bit ePIC.
  • Supports password image protection.

PNG (Portable Network Graphics)

  • Reads 1, 4, 8, 16 and 24-bit PNG.
  • Writes 1, 4, 8 and 24-bit PNG.
  • Reads and writes interlaced and non-interlaced formats.
  • 16-bit PNG files are decompressed to 24-bit.

PPM (Portable Pixmap)

  • Reads 24-bit PPM.
  • Writes 24-bit PPM.

RLE (Run-Length Encoded Bitmap)

  • Reads 1, 4 and 8-bit RLE.

RAW (Raw Image Data)

  • Reads 8 through 16-bit grayscale and 24-bit color.
  • Writes 1 through 16-bit grayscale and 24-bit color.
  • Supports RGB, RGB555, RGB565, RGBA, ARGB, BGR, BGRA, ABGR, CMYK, YUV, YUYV, UYVY, and YCBCR in both "big endian" and "little endian" formats.

TGA (Truevision Targa)

  • Reads 1, 8, 16, 24 and 32-bit TGA.
  • Writes 1, 8 and 24-bit TGA.
  • 16 and 32-bit TGA files are converted to 24-bit.
  • Reads compressed and uncompressed TGA.
  • Writes uncompressed TGA.

TIFF (Tagged Image File Format)

  • Reads 1, 4, 8, 16, 24 and 32-bit uncompressed TIFF.
  • Writes 1, 4, 8 and 24-bit uncompressed TIFF.
  • Reads and writes CCITT RLE, Group 3, and Group 4 compressed TIFF.
  • Reads and writes 1, 4, 8 and 24-bit Pack Bits TIFF.
  • Reads and writes 1, 4, 8 and 24-bit LZW TIFF.
  • Reads and writes 8-bit grayscale and 24-bit color (JPEG 6 and JPEG 7) TIFF.
  • Reads and writes 1, 4, 8 and 24-bit deflate TIFF.
  • Reads and writes multiple page TIFF.
  • 16 and 32-bit TIFF files are converted to 24-bit.
  • Reads CMYK TIFF.
  • Reads 9 to 16-bit gray scale TIFF.
  • Handles either "big endian" or "little endian" byte ordering.
  • Read tiled TIFF with LZW, JPEG, and G4 compression types.
  • Reads and writes IPTC and TIFF metadata.**

WBMP (Wireless Bitmap)

  • Reads 1-bit WBMP.
  • Writes 1-bit WBMP.

WDP (Microsoft Windows Media Photo – also known as HDP)

  • Reads 8-bit and 16-bit gray, RGB or RGBA (8-bits per channel unsigned integer).
  • Writes 8-bit and 16-bit gray, RGB or RGBA (8-bits per channel unsigned integer).**

WMF (Windows Metafile - also known as EMF)

  • Reads Windows Metafiles.
  • WMF may be displayed in Metafile format or optionally converted to device dependent bitmaps for display.

WSQ (WSQ Fingerprint File Format)

  • Reads 8-bit grayscale WSQ.
  • Writes 8-bit grayscale WSQ.**


Glossary

Glossary
ImagXpress 13 for .NET - User Guide > Concepts > Glossary
A | B | C | D | E | F | G | H | I | J | K | L | M | N | O | P | Q | R | S | T | U | V | W | X | Y | Z

A

Aspect Ratio
There are two kinds of aspect ratio that you need to be aware of when working with 2D images; the image aspect ratio and the pixel aspect ratio.The image aspect ratio is the ratio of the width of the image to the height of the image. It's important when resizing an image to keep this ratio as close to unchanged as possible or the image may become distorted.The pixel aspect ratio is the shape of the pixels in the image. For computers this is normally square (1:1) or close to it depending on the monitor settings. For some video sources and faxes, however, the pixels may be slightly rectangular.

B

Black on Edge
The minimum or maximum number of pixels on the vertical or horizontal edge of an image or document.

BMP
The Microsoft Windows Bitmap file format is based on the Microsoft Windows internal bitmap data structures. The BMP format is very widely used and it is quick and easy to read. Although most BMP files are uncompressed, a type of run length encoding is supported.

BPP
Bits per pixel.

Brightness
An ImagXpress method that enhances the brightness attributes of the pixels in the bitmap. Positive settings produce brighter pixels while negative settings produce darker pixels.

C

CCITT
CCITT is the most widely used compression scheme for transmitting binary (black and white) image data. CCITT was established by the International Telegraph and Telephone Consultative Committee. The Group 3 and Group 4 CCITT compression standards are widely used for transmitting fax data. CCITT compressed images are typically stored in the TIFF image format.

CIELAB
Three dimensional color space defined by the Commission Internationale de L'Eclairage, or CIE. L describes relative lightness; A represents relative redness-greenness,and B represents relative yellowness-blueness.

Container
Gets the container for the component. An object implementing the IContainer interface that represents the component's container, or a null reference (Nothing in Visual Basic) if the component does not have a site.

Contrast
An ImagXpress method that enhances the contrast attributes of the pixels in the bitmap. Positive settings produce a higher contrast image while negative settings produce a lower contrast image. Images with a higher contrast have a higher frequency of pixel intensities near the ends of the intensity spectrum while images with a lower contrast have a higher frequency of pixels near the middle of the intensity spectrum.

Cosited
Specifies horizontally coincident positioning of sub-sampled chrominance components relative to luminance sample.

CreateObjRef
Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.

D

DCOM
Microsoft's extension of their Component Object Model (COM) to support objects distributed across a network. DCOM is currently implemented only by Microsoft for Microsoft Windows; and by Software AG, under the name "EntireX", for Unix and IBM mainframes. DCOM serves the same purpose as IBM's DSOM protocol. DCOM is an object model, but has no provisions for inheritance.

DCX
An image format containing multiple PCX images. A DCX file can contain a maximum of 1024 images.

DDB
Microsoft Device Dependent Bitmap. The actual in-memory information used to display an image.

DEP
Data Execution Prevention (computer security).

Despeckle
A modified median filter primarily used for reducing noise in document images. Despeckling divides the image into pixel groups and uses the brightness value to adjust brightness spikes. This filter will reduce noise in a black and white document image with minimal distortion of document text.

Device Context
A device context is a structure that defines a set of graphic objects and their associated attributes, as well as the graphic modes that affect output. The graphic objects include a pen for line drawing, a brush for painting and filling, a bitmap for copying or scrolling parts of the screen, a palette for defining the set of available colors, a region for clipping and other operations, and a path for painting and drawing operations.

DIB
Microsoft Device Independent Bitmap. An alternative file extension used by the Microsoft Windows Bitmap.

DICOM
Digital Imaging and Communication, a standard for handling digital medical images.

Dithering
A technique used in computer graphics to create the illusion of varying shades of gray on a monochrome display or printer, or additional colors on a color display or printer. Dithering relies on treating areas of an image as groups of dots that are colored in different patterns. Akin to the print images called halftones, dithering takes advantage of the eye’s tendency to blur spots of different colors by averaging their effects and merging them into a single perceived shade or color. Depending on the ratio of black dots to white dots within a given area, the overall effect is of a particular shade of gray. Dithering is used to add realism to computer graphics and to soften jagged edges in curves and diagonal lines at low resolutions.

E

Emboss
An ImagXpress method that causes the foreground of an image to appear raised from background. Embossing gives the image a raised metallic-like look.

ePIC
Accusoft enhanced PIC image format. This high performance image compression combines the patented ELS arithmetic coder with the high performance Accusoft JPEG libraries. The result is a new and unbeatable compression technology. The ePIC compression has significant advantages over standard JPEG. Most importantly it produces smaller file sizes and decompresses extremely quickly. ePIC images can be password encrypted. These images can also be 'zoomed' or scaled to larger, arbitrary sizes.

Equalize
An ImagXpress method that is a point process used for adjusting the contrast of an image. A frequency histogram of the colors of the image is computed and adjusted to equalize the colors across the full spectrum of intensity values. The equalized colors are applied to each pixel in the image.

EXIF
EXchangeable Image File format (Japan Electronic Industry Development Association, JEIDA), compressed image format used in digital cameras.

F

Flate
The lossless deflate compression algorithm is based on two other compression algorithms: huffman encoding and LZ77 compression.

Float
Denotes a simple type that stores 32-bit floating-point values.

G

Gamma
A non-linear brightness transform. Gamma values greater than 0 and less that 1.0 generate exponential curves that dim and image. Gamma values greater than 1.0 generate exponential curves that brighten an image.

Gamut
In graphics, the gamut of a monitor is the range of colors it can display. There are some colors which can't be made up of a mixture of red, green and blue phosphor emissions and so can't be displayed by any monitor.

GDI
Acronym for Graphical Device Interface. In Windows, a graphics display system used by applications to display or print bitmapped text (TrueType fonts), images, and other graphical elements. The GDI is responsible for drawing dialog boxes, buttons, and other elements in a consistent style on screen by calling the appropriate screen drivers and passing them the information on the item to be drawn. The GDI also works with GDI printers, which have limited ability to prepare a page for printing. Instead, the GDI handles that task by calling the appropriate printer drivers and moving the image or document directly to the printer, rather than reformatting the image or document in PostScript or another printer language.

GetLifetimeService
Retrieves the current lifetime service object that controls the lifetime policy for this instance.

GIF
Graphical Interchange File, originally developed by CompuServe as a machine independent format. GIF is one of the most popular image formats for storing 8-bit digitized images. GIF files are typically smaller than uncompressed formats like BMP due to the LZW compression algorithm that GIF uses.

Greyscale
If the pixels of a grey-scale image have N bits, they may take values from zero, representing black up to 2^N-1, representing white with intermediate values representing increasingly light shades of grey. If N=1, the image is not called grey-scale, but could be called monochrome.

H

Halftone
Pertaining to pictures in which gradation of tone in the photograph is reproduced by a graduated system of dotted and checkered spots, usually nearly invisible to the unaided eye, produced by the interposition between the camera and the object of a screen. The name alludes to the fact that this process was the first that was practically successful in reproducing the half tones of the photograph.

hDIB
Handle to a Device Independent Bitmap. An operation affecting the image may cause the hDIB before the operation to become invalid.

Hue
One of the 3 components of the HSL (Hue, Saturation and Luminance ) color space. The hue component controls the overall color space of an image. Adjusting the hue of the image adjusts the color spectrum from red through yellow, green, blue, and violet.

I

ICC
International Color Consortium - This profile type is equivalent to the ICM (Integrated Color Management) profiles that are used with the Windows operating system. This profile type is from the Macintosh operating system environment but ICC and ICM profiles are interchangeable (cross platform) between either operating system. The only difference is that, if an ICC profile is going to be used with the Windows operating system, it must have a file extension of .ICM.

ICO
Microsoft Windows Icon file format.

Inverse
To reverse something or change it to its opposite. For example, to invert the colors on a monochrome display means to change light to dark and dark to light. In a digital electrical signal, to replace a high level by a low level and vice versa. This type of operation is the electronic equivalent of a Boolean NOT operation.

IOD
Information Object Definition.

J

JIF
An alternative image file extension used for a JFIF compliant JPEG file. Because many early versions of JPEG contained a JPG extension but did not adhere to the JFIF specifications, the JIF extension was created to identify JPEG files that are JFIF compliant. As the popularity of JPEG grew, JFIF compliance became synonymous with the JPG extension and thus the JIF extension is rarely used.

JPEG
The JPEG (Joint Photographic Experts Group) standard is one of the most important image data compression standards. It is widely used in many industries including graphic arts, desktop publishing, medical imaging, and many more. It is also becoming one of the most widely used image formats on the Internet. Although JPEG supports a lossless mode, it most commonly uses lossy compression. This allows JPEG to achieve very high compression ratios. JPEG compression uses several compression modes. First, an image is transformed to the frequency domain using the discrete cosine transform. The smaller valued frequency components are discarded leaving only the larger valued components. The remaining components are DPCM coded and then Huffman coded. Fortunately, ImagXpress handles all of this for you! The compression level is adjustable. Higher quality settings produce a larger image file size with higher image quality. Lower quality settings produce a smaller image file size with lower image quality. Typically, we have found that compression ratios of 10:1 or 15:1 (A 640x480x24-bit image is 921,600 bytes; a 15:1 compressed image would compress to only 61k) produce generally acceptable image quality for photographic type images. Images compressed at higher ratios begin to show more noticeable and sometimes objectionable artifacts and clarity loss. JPEG is a 24-bit format and works only with 24-bit images. If you compress an 8-bit image, ImagXpress automatically converts it to 24-bit to do the compression, however, you will obtain better quality when the source image is 24-bit because 8-bit images only contain 256 colors. JPEG works best with photographic type images. It does not work well with solid colors, 16-color images, cartoon like images, or drawings. Progressive JPEG is a multiple-scan sequential JPEG format that is becoming popular on the Internet for the ability to display images in progressively clearer segments.

L

Little-endian
Describes a computer architecture in which, within a given 16- or 32-bit word, bytes at lower addresses have lower significance (the word is stored "little-end-first"). Intel microprocessors, plus a lot of communications and networking hardware, are little-endian. The term is sometimes used to describe the ordering of units other than bytes; most often, bits within a byte.

Luminance
One of the 3 components of the HSL (Hue, Saturation and Luminance) color space. Luminance controls the overall brightness (energy/whiteness) of an image.

LUT
Look Up Table.

LZW
Lempel-Ziv-Welch (algorithm).

M

Matrix
A matrix filter, also called convolution, alters each pixel's color based on its current color and the colors of any neighboring pixels. The ImagXpress Matrix method uses a 3x3 matrix. The numbers in the matrix are coefficients. When a pixel is processed, its color value is multiplied by the coefficient in the center of the matrix, and any pixels within the 3x3 grid are multiplied by the corresponding coefficients in the matrix. The sum of the products becomes the target pixel's new value. The Divisor is simply the coefficient denominator. The matrix method is typically used for sharpening, softening, and edge enhancement.

Mosaic
A mosaic divides the bitmap into tiles of a specified size. All of the pixels in each tile are averaged and changed to the average color.

Multithreading
Multithreading, or free threading, refers to the ability of a program to execute multiple threads of operation simultaneously. In a single-threaded application, a user might spend idle time waiting for the calculations or database updates to finish. In a multithreaded application, these processes can proceed in the background so user time is not wasted. An example of a multithreaded application might be a program that receives user input on one thread, performs a variety of complex calculations on a second thread, and updates a database on a third thread. In a single-threaded application, a user might spend idle time waiting for the calculations or database updates to finish. In a multithreaded application, these processes can proceed in the background so user time is not wasted. Multithreading can be a powerful tool to use in component programming. By writing multithreaded components, you can create components that perform complex calculations in the background while leaving the user interface free to respond to user input. Although multithreading can be a powerful tool, it can also be difficult to apply correctly. Improperly implemented multithreaded code can degrade application performance, or even cause frozen applications. (See MSDN).

N

Negate
An ImagXpress method that creates a color negative of an image.

Noise
An ImagXpress method that adds random pixels to the bitmap.

O

Orthogonal
Used loosely to mean mutually independent or well separated. It describes sets of primitives or capabilities that, like linearly independent vectors in geometry, span the entire "capability space" and are in some sense non-overlapping or mutually independent. For example, in logic, the set of operators "not" and "or" is described as orthogonal, but the set "and", "or", and "not" is not (because any one of these can be expressed in terms of the others).

P

PBM
Portable bitmap image format, a very simple uncompressed 1-bit (black and white) image format.

PGM
Portable Graymap image format. PGM is a very simple uncompressed 8-bit grayscale image format.

PNG
Portable Network Graphics (pronounced "ping") provides a portable, legally unencumbered (royalty-free), well-compressed, well-specified standard for lossless bitmapped image files. The initial motivation for developing PNG was to provide a royalty-free alternative to GIF. The design retains many of the features of GIF that make it an attractive format for transmission of images, such as lossless compression and progressive display capabilities. Additionally, it provides several advantages including 24-bit image support and generally better compression, although decompression is typically somewhat slower than GIF.

PPM
Portable Pixmap image format, a very simple uncompressed 24-bit image format.

R

RGB
Red Green Blue. Bitmapped images are most generally stored as RGB data. Each pixel or data point in a true color (24-bit) image contains 3 components, red, green and blue, that describe the color of the pixel. Each of the components can have a value between 0 and 255, 0 being the darkest shade of color and 255 being the lightest shade of color. Since each component can be stored in one byte (8-bits), the 3 components take up 3 bytes or 24-bits per pixel. 8-bit images contain one byte (8-bit) indexes for each pixel that map to a color table called a palette which contains a maximum of 256 RGB entries. Likewise, 4-bit images contain 4-bit indexes for each pixel that map to a palette which contains a maximum of 16 RGB entries. 1-bit images contain 1-bit per pixel. Each bit in a 1-bit image represents either black or white.

RLE
Run Length Encoding. It is a lossless algorithm that only offers decent compression ratios in specific types of data.

S

Saturation
One of the 3 components of the HSL (Hue, Saturation, and Luminance) color space. Saturation controls the purity of a color. Higher saturations result in richer, deeper colors. Lower saturations result in paler colors.

Scalar
In programming, any data type that stores a single value (a number or Boolean), as opposed to an aggregate data type that has many elements. A string is regarded as a scalar in some languages (PERL) and a vector of characters in others (C).

Sharpen
An ImagXpress method that is used to sharpen an image. The sharpen filter uses a high-pass convolution matrix filter to accentuate high frequency detail in the image.

Single
Value type represents a single-precision 32-bit number with values ranging from negative 3.402823e38 to positive 3.402823e38, as well as positive or negative zero, PositiveInfinity, NegativeInfinity, and not a number (NaN).

Soften
An ImagXpress method that is used to soften an image. The soften filter uses a low-pass convolution matrix filter to accentuate low frequency detail in the image.

Sprite
A small bitmap image, often used in animated games but also sometimes used as a synonym for icon.

sRGB
In 1996, Hewlett-Packard and Microsoft proposed a standard color space, sRGB, within Microsoft operating systems, HP products, the Internet, and all other interested vendors.

T

TGA
Targa Image File) format was developed by TrueVision for its Targa line of products. TGA is one of the earliest image formats and was the first popular format to support 24-bit color. TGA supports uncompressed and RLE compressed formats.

TIFF
Tag Image File Format, originally released by Aldus Corporation is a standard file format found in most paint, imaging, and desktop publishing programs. TIFF is extremely powerful, flexible, and extensible. However, because of its many nuances and its wide scope, TIFF can be a difficult format to understand as well as a difficult format to support. ImagXpress supports a wide range of TIFF 6.0 formats including uncompressed, CCITT RLE, CCITT Group 3 Fax, CCITT Group 4 Fax, LZW, Pack Bits, JPEG, and deflate compression types. ImagXpress supports black and white, RGB, and RGB palette images but it does not support transparency mask, CMYK, YCbCr, or CIELab.

twip
A twip (abbreviation for "twentieth of a point") is 1/20 of a typographical point. Twips are screen-independent units to ensure that the proportion of screen elements are the same on all display systems. A twip is defined as being 1/1440 of an inch.

V

Virtual Image
A Virtual Image is essentially a non-image. ImagXpress allows an application to describe an image that does not exist to get a canvas that the application can then draw on. ImagXpress handles the coordinating of the window, scrollbars and interaction with NotateXpress. Presumably the application will draw some portion of a very large image into the view when ImagXpress request it to do so during one of the Paint events.

VOI
Value Of Interest.

void
Indicates a method that does not return a value; that is, the method has the void return type.

W

Wintel
A term describing the combination of Microsoft Windows operating system running on PCs with Intel or compatible processors. Dominance of the wintel platform began with MS-DOS on PCs with Intel's 8-bit 8088 processors in 1979.

WMF
The Microsoft Windows Metafile format is used to store vector and bitmap image data. Because of its popularity and wide use, many Windows and non-Windows applications support WMF.

WSQ
Wavelet Scalar Quantization (WSQ) Gray-Scale Fingerprint Image Compression Specification based on the results of the NIST (National Institute of Standards and Technology) review. The benefit of WSQ fingerprint-specific compression is reduced file size. A sample fingerprint with a resolution of 589 pixels by 605 pixels, 8-bit grayscale results in a file size of 325 KB when compressed with the standard lossless compression technology LZW.

WYSIWYG
What You See Is What You Get; realistic display of final print or screen image.

Y

YCbCr
Family of color spaces used in video systems. Y is the luma component;Cb and Cr are the chroma components. YCbCr is often confused with the YUV color space; typically the terms YCbCr and YUV are used interchangeably, leading to confusion. In fact, digital signals, the term "YUV" probably really means "YCbCr." The term YCbCr is sometimes abbreviated to YCC. YCbCr signals (prior to scaling and offsets to place the signals into digital form) are created from the corresponding gamma-adjusted RGB (red, green and blue).


How To

How To
ImagXpress 13 for .NET - User Guide > How To

This section provides information about the following:

  • How To
    • Query an Image File
    • Load an Image
      • Specify Load Options
      • Load Image from File
      • Load Image from Stream
      • Load Image from Bitmap or DIB
      • Load Image from Another ImageX Object
      • Cancel
    • Access and Modify a Loaded Image
      • Get Loaded Image Information
      • Modify Tags & Comments
      • Modify the Image Palette
      • Draw on the Image
    • View an Image
      • Create a Viewer
      • Define Viewer Properties
        • Set the View Window Size & Appearance
        • Set Toolbar & Cursors
        • Set Context Menus
        • Set Scrolling & Mousewheel Behavior
      • Specify How the Image Should Be Displayed
        • Align Image in Window
        • Zoom Image in Window
        • Enable Progressive Viewing
        • Enable Medical Viewing
        • Set Color Management
        • Set Image Display Palette
        • Set Display Bit Depth
        • Set Alpha Blending
        • Change Image Display Rendering
      • Display Image
      • Capture, Copy, and Paste
        • Capture an Image from Screen
        • Copy & Paste Image Using the Clipboard
        • Select a Section of the Displayed Image
      • Manage End-User Viewing Events
    • Process an Image
      • Create a Processor
      • Select an Area or Region to Process
      • Modify Image Size & Orientation
      • Modify Image Bit Depth
      • Correct Color & Contrast
      • Cleanup Images
      • Remove Redeye
      • Apply Image Effects
      • Modify Alpha Channel
      • Merge Images
      • Undo a Processing Action
    • Pass Image Data Between Different Accusoft Components
    • Use the New Multi-Page TIFF Edit API
      • Delete Multiple Pages
      • Insert Multiple Pages
    • Use the Touch Capability
      • Verify Support
      • Enable Touch Capabilities
      • Enable Built-in Touch Support
      • Use Tools and the Toolbar
      • Use Events
    • Reduce a JPEG Image
    • Reduce a PNG Image
    • Annotate an Image
    • Print an Image
    • Save an Image
      • Specify Save Options
      • Save Image to File
      • Save Image to Stream
      • Save Image to Bitmap or DIB
      • Cancel
    • Free the Control's Resources
    • Debug


Query an Image File

Query an Image File
ImagXpress 13 for .NET - User Guide > How To > Query an Image File

ImagXpress® provides the ability to query and modify images without loading them into ImagXpress.

The images may be remote or local, but may not have an HTTP or FTP address.

Query Image from File, Buffer, or Stream

Querying enables the user to gain information about the file before choosing to load or process it using ImagXpress. For example, the user may decide to load only images that are smaller than a threshold size, or images that are of a specified type. Querying is accomplished using methods within the ImageX class.

The QueryFile methods enable the user to obtain information about a specified page in a TIFF file. These methods return the ImageXData associated with the file. To query from buffer or stream, use the QueryBuffer or QueryFromStream methods.

The NumPages method enables the user to query a multiple page TIFF or DCX file to determine the number of pages in the file. This enables a user to query multiple pages, by iterating the page number in the ImageX.QueryFile methods.

Modify Image Files

Using ImagXpress (ImageX class), the user can make page-level modifications to TIFF files without loading the file. This enables the user to clean up or reduce the image size prior to loading.

  • The CompactFile method removes unused pages from the specified TIFF file.
  • The DeletePage and InsertPage methods delete/insert a specified page in the specified TIFF file.
  • The NumPages method enables the user to query a multiple page TIFF or DCX file to determine the number of pages in the file. This enables a user to delete or insert multiple pages in a TIFF file, by iterating the page number in the ImageX.DeletePage and ImageX.InsertPage methods.
  • ImagXpress enables users to set and get tags for TIFF and EXIF images without loading the image data, using the ReadAllMetaData and SaveAllMetaData methods.

Once an image is loaded into an ImageX object, the ReadAllMetaData and SaveAllMetaData methods do NOT update the ImageX object's image. Only the image at the specified filename is modified. To modify tags of an image loaded in an ImageX object, use the ImageX.Tags property.
These methods are only applicable to images stored in file, not for images in buffer or stream.

See Also
Add ImagXpress to Your Project


Load an Image

Load an Image
ImagXpress 13 for .NET - User Guide > How To > Load an Image

This section provides information about the following:

  • Specify Load Options
  • Load Image from File
  • Load Image from Stream
  • Load Image from Bitmap or DIB
  • Load Image from Another ImageX Object
  • Cancel


Specify Load Options

Specify Load Options
ImagXpress 13 for .NET - User Guide > How To > Load an Image > Specify Load Options

Load options (LoadOptions) can be used, if desired, to provide specific instructions when loading an image from file or from stream. If no load options are specified, ImagXpress® uses default values when loading the image.

General Load Options

  • The offset in the file or memory buffer where ImagXpress will begin reading image data (ImageOffset property).
  • Whether alpha channel data is to be loaded (LoadAlphaChannel).
  • Whether the image should be loaded as a thumbnail and the size of the desired thumbnail (ThumbnailSize).
  • Whether the image is scaled to gray when LoadResize is used to load the image. (ScaleToGray).
  • Whether preserve black will be applied to the image when loaded to increase readability. (PreserveBlack).
  • Whether the image will be cropped, resized and/or rotated upon loading (the ImageX object will get a modified version of the original image, based on the requested operations).
    LoadCrop, LoadResize and LoadRotate are not supported when loading an image from a stream as the entire image must be loaded before the ImageX object can be modified.

When more than one of these operations is requested, the order is:

  1. LoadCrop

    Image is cropped to the dimensions specified in CropRectangle. If the dimensions specified are all zeros or null, then no crop occurs when loading.

  2. LoadResize

    Whether the image resizes when loading (Resize). If the parameters are all zeros or null, then no resize occurs when loading. Whether the image aspect ratio will be preserved when loading an image (MaintainAspectRatio).

  3. LoadRotate

    Whether image is rotated upon loading (Rotation property).

Colorspace Conversions

CMYK Conversion - If a CMYK Tiff image file is loaded into ImagXpress, it is automatically converted to RGB. The application can use the ICM properties to control the CMYK conversion process.

Image Color Management Loading Options

When loading an image into an ImageX object, you can specify how color management is applied.

  • To avoid color management when loading, set UseEmbeddedColorManagement = False.
  • To perform color management using the color profile specified in the image metadata:
    1. Set LoadOptions.UseEmbeddedColorManagement = True
    2. Specify how profiles should be applied, by setting the ColorRenderIntent property (for example, Picture, Graphics, Business or Colorimetric interpretation.)
    3. The image is modified to reflect the color profile, then loaded.

  • To perform color management using a color profile specified in a file:
    1. Set LoadOptions.UseEmbeddedColorManagement = False.
    2. Specify how profiles should be applied, by setting the ColorRenderIntent property (for example, Picture, Graphics, Business or Colorimetric interpretation.)
    3. Set the SourceProfileName to the name of the color profile you wish to apply to the image being loaded
    4. The image is modified to reflect the color profile, then loaded.

FTP Loading Options

If username/passwords and proxy settings are needed, set InternetOptions.

Image Format-Specific Load Options

CAD (LoadOptionsCad)

  • Layers: The Layer method specifies the layer of the CAD drawing to load. LayoutToRender specifies the layout of the CAD drawing to load.
  • Rendering: The PaperBitDepth, PaperResolutionX, PaperResolutionY, PaperWidth, PaperHeight, and PaperResolutionUnits all specify how the CAD image should be rendered when loaded.

JBIG2 (LoadOptionsJbig2)

  • Swap Black and White: SwapBlackandWhite property specifies if the values for black and white use industry default or not.

JPEG (LoadOptionsJpeg)

  • Cosited: The Cosited property indicates whether image was compressed with cosited sub-sampling.
  • Enhanced: The Enhanced property specifies whether the JPEG decoder should use the Accusoft enhanced decomposition method.

JpegXR (LoadOptionsJpegXR)

  • Filter: the PostProcessingFilter property specifies the post processing filter to be used when loading the image.

PIC (LoadOptionsPic)

  • Password: Password to protect the .PIC file

Metafile (LoadOptionsMetafile)

  • Resolution: the Resolution property specifies the resolution to which the image is loaded.

TIFF (LoadOptionsTiff)

  • Offset: The IFDOffset in the source file or memory buffer where ImagXpress will begin reading image data.
  • Special: Whether this is a banking-vendor specific application requiring special tiff handling (SpecialHandling).

Difference Between RAW and Camera Raw

RAW files are uncompressed images that have the image data stored separately from the image header describing the data. This is common in medical and DICOM images. However it is not limited to that environment as the image header and image data may be stored separately in a database. Camera Raw is one of many camera manufacturer's proprietary image file format of the raw analog-to-digital conversion data. This is typically greater than 8-bits per channel. Most camera manufacturer's use a proprietary format that was adapted from an existing file format such as TIFF. For this reason, ImagXpress usually takes additional time verifying the file format when CameraRaw is enabled.

Using the LoadRaw method for loading in a RAW file:

  1. Set LoadOptions.LoadMode to raw, in order to treat the image data as a raw format when loading.
  2. Use the remaining properties within the LoadOptionsRaw class to specify how data loads from the raw data format.
  3. When the image is loaded, the data will be interpreted using the LoadOptionsRaw properties.

Versus...

Loading a camera manufacturer's proprietary raw image file format:

The ImagXpress control has the ability to inspect an image when loading to determine that an image is in a camera raw format, identify the specific camera raw format of the image, and load the image using that format.

  1. Make sure that the LoadOptions.LoadMode property is set to Normal, in order to inspect the image data when loading to determine format.
  2. Set LoadOptions.CameraRawEnabled = True to specify that the image should be examined on loading to see if the data is in a camera raw format, and to identify the raw format.
  3. Load the image, using one of the load methods (e.g. FromFile). The image will be inspected to see if it is in a CameraRaw format as part of the loading process. The image will be decoded using the specific camera raw format detected.

To optimize performance, set CameraRawEnabled to False when it is not needed.
When CameraRawEnabled = True, the image can only be loaded from a file. Loading from a stream is not supported as the entire image must be loaded before the raw format can be recognized.
See Also
Load Image from File
Load Image from Stream
Load Image from Another ImageX Object
Load Image from Bitmap or DIB
Get Loaded Image Information


Load Image from File

Load Image from File
ImagXpress 13 for .NET - User Guide > How To > Load an Image > Load Image from File

Prior to loading an image, set the LoadOptions to provide specific instructions for loading the image. If no load options are specified, ImagXpress uses default values when loading the image.

Load from a Local Disk File

To load an image from a file, use the ImageX.FromFile methods. When called, the FromFile methods store a copy of the original image in the ImageX object. ImagXpress® looks at the file extension of the specified filename parameter to recognize the filetype.

The ImageStatusEvent and ProgressEvent events are raised to provide feedback on the status of the loading process. Once loading is complete, the image is available in the ImageX object.

Load from an FTP, HTTP, or HTTPs Location

ImagXpress supports loading of image files from FTP, HTTP, and HTTP/S locations, as follows:

1. To specify passwords or proxy settings, set the Internet property within LoadOptions.

2. Call one of the following:

FromFile(ImagXpress,String,LoadOptions)

FromFile(ImagXpress,String,Int32,LoadOptions)

Make sure that the String parameter specifies the full Internet path and file name

3. A copy of the original image is stored in the ImageX object.

Load a Multi-page Image From File

ImagXpress® supports the following multi-page image formats: TIFF, ICO, and DCX. The NumPages method provides the number of pages in the file.

To load the entire multi-page file into one ImageX object, call either of the following:

FromFile(ImagXpress,String)

FromFile(ImagXpress,String,LoadOptions)

To load only one specified page of a multi-page file into the ImageX object, call one of the following:

FromFile(ImagXpress,String,Int32)

FromFile(ImagXpress,String,Int32,LoadOptions)

See Also
Load Image from Stream
Specify Load Options
Load Image from Another ImageX Object
Load Image from Bitmap or DIB
Get Loaded Image Information


Load Image from Stream

Load Image from Stream
ImagXpress 13 for .NET - User Guide > How To > Load an Image > Load Image from Stream

Prior to loading an image, set the LoadOptions to provide specific instructions for loading the image. If no load options are specified, ImagXpress® uses default values when loading the image.

Load from Stream

To load an image from a memory or file stream, use the ImageX.FromStream methods. When called, the FromStream methods store a copy of the original image in the ImageX object.

The ImageStatusEvent and ProgressEvent events are raised to provide feedback on the status of the loading process. Once loading is complete, the image is available in the ImageX object.

To load a BLOB (Binary Large Object), use the ImageX.FromStream method.
To load a file from an Internet stream, use the ImageX.FromFile method, specifying the full Internet path and file name, NOT the FromStream method.

Load a Multi-page Image From Stream

ImagXpress supports the following multi-page image formats: TIFF, ICO, and DCX. The NumPages method provides the number of pages in the file.

To load the entire multi-page file into an ImageX object, call any of the following:

FromStream(ImagXpress,Stream)

FromStream(ImagXpress,Stream,LoadOptions)

To load only one specified page of a multi-page image into the ImageX object, call one of the following:

FromStream(ImagXpress,Stream,Int32)

FromStream(ImagXpress,Stream,Int32,LoadOptions)

FromStream(ImagXpress,Stream,Int32,Int32)

FromStream(ImagXpress,Stream,Int32,Int32,LoadOptions)

See Also
Load Image from File
Specify Load Options
Load Image from Another ImageX Object
Load Image from Bitmap or DIB
Get Loaded Image Information


Load Image from Bitmap or DIB

Load Image from Bitmap or DIB
ImagXpress 13 for .NET - User Guide > How To > Load an Image > Load Image from Bitmap or DIB

Load an Image from HBitmap

If the image to load is a bitmap (device dependent), call ImageX.FromHbitmap or ImageX.FromBitmap methods to load the image into the ImageX object. A copy of the source image loads into the ImageX object.

The ImageX.ImageStatusEvent event is raised to provide feedback on the status of the loading process. Once loading is complete, the image is available in the ImageX object.

Load an Image from HDIB

If the image to load is a DIB, call ImageX.FromHdib method to load the image into the ImageX object.

  • To directly take control of the Hdib, set the ownDib parameter to true, for example: ImageX1.FromHdib(thehdib, true)
  • To make a copy of the DIB, prior to loading, set ownDib to false. (Default = false if not specified). For example: ImageX1.FromHdib(thehdib, false)
See Also
Load Image from File
Load Image from Stream
Specify Load Options
Load Image from Another ImageX Object
Get Loaded Image Information


Load Image from Another ImageX Object

Load Image from Another ImageX Object
ImagXpress 13 for .NET - User Guide > How To > Load an Image > Load Image from Another ImageX Object

An ImageX object can be loaded with a copy of a different ImageX object:

C# Example
Copy Code
// This code demonstrates how an ImageX object can be loaded with a copy of a different ImageX object
targetImageX = sourceImageX.Copy();
See Also
Load Image from File
Load Image from Stream
Specify Load Options
Load Image from Bitmap or DIB
Get Loaded Image Information


Cancel

Cancel
ImagXpress 13 for .NET - User Guide > How To > Load an Image > Cancel

The ImageX.Cancel method cancels the loading, decompression, compression, or saving of the ImageX image.

Whenever the Cancel method is called, it is considered a request to cancel. The operation may be to far along to cancel or the operation may have already completed. The application should verify the state of the image after the operation has been requested to be cancelled.

See Also
Undo a Processing Action
Save Image to File
Save Image to Bitmap or DIB
Save Image to Stream


Access and Modify a Loaded Image

Access and Modify a Loaded Image
ImagXpress 13 for .NET - User Guide > How To > Access and Modify a Loaded Image

This section provides information about the following:

  • Get Loaded Image Information
  • Modify Tags & Comments
  • Modify the Image Palette
  • Draw on the Image


Get Loaded Image Information

Get Loaded Image Information
ImagXpress 13 for .NET - User Guide > How To > Access and Modify a Loaded Image > Get Loaded Image Information

Once an image has been loaded into an ImageX object, information about the image is available through the properties and methods of the ImageX object.

Get Image Data

Number of Pages: To get the number of pages in the image, use ImageX.PageCount (read-only property).

The PageCount will not be valid if the image was loaded FromStream, since page count information is not available when streaming.

Current Page: To get or set the page to be viewed or processed, use the ImageX.Page property.

Resolution: Use one of the following to get the resolution of the image:

  • ImageX.Resolution (read only property) provides the image dimensions and resolution unit of measure.
  • ImageXData.Resolution (read only property) provides the image dimensions and resolution unit of measure. (Same as ImageX.Resolution)
  • ImageX.HorizontalResolution method and ImageX.VerticalResolution method provide the horizontal and vertical resolution, in the units specified by ImageX.ResolutionUnits methods.

Tags: To get the tag collection associated with the ImageX object, use the ImageX.Tags property.

Color Palette: To get the color palette used for the ImageX image, use the ImageX.Palette property.

Load Options Used: To get information on how the image was loaded, use ImageX.LoadOptions (read only property).

Image Data: To get other data about the image, such as bit depth, color space, compression of original image, file format and size, use the read-only properties in ImageXData

Monitoring the Status of an ImageX Object

The ImageX.ImageStatusEvent and ImageX.ProgressEvent events raise to provide feedback on the status of the image as it is viewed, processed, or saved.

See Also
Load Image from File
Load Image from Stream
Specify Load Options
Load Image from Another ImageX Object
Load Image from Bitmap or DIB


Modify Tags & Comments

Modify Tags & Comments
ImagXpress 13 for .NET - User Guide > How To > Access and Modify a Loaded Image > Modify Tags & Comments

Modify TIFF Tags without Loading the Image

Tags can be modified without loading the image, using the ImageX.ReadAllMetaData and ImageX.SaveAllMetaData methods. (See Query Images).

Modify TIFF Tags in a Loaded Image

Once a TIFF image has been loaded into an ImageX object, the tags can be modified by accessing the tag collection associated with the ImageX object (Tags).

Please see the TIFF and EXIF file specification for more information about tags.

Modify JPEG Comments

JPEG, JPEG2000, JLS, or WSQ files may have a list of comments. ImagXpress® enables you to modify comments of an image loaded into ImageX, as follows:

  • Count the comments: The JPEGCommentCount property returns the number of comments contained in the file.
  • Get the comment: The ReturnJpegComment method returns the text associated with a specified comment.
  • Add a comment: The AddJpegComment method adds a comment to the comment list.
  • Delete a comment: The DeleteJpegComment method deletes a comment from the comment list.
Undo does not undo changes to TIFF tags or JPEG Comments. Undo only applies to processing actions.

See Also
Modify the Image Palette


Modify the Image Palette

Modify the Image Palette
ImagXpress 13 for .NET - User Guide > How To > Access and Modify a Loaded Image > Modify the Image Palette

The ImageX.Palette property gets or sets the color palette associated with the ImageX image (if the image is 8 bpp or less). The ImageX.CreateColorPalette method can be used to create a new color palette, which can be assigned to the ImageX image.

C# Example
Copy Code
// This code demonstrates how to modify the first entry in the palette to red
System.Drawing.Imaging.ColorPalette palette;
palette = imageX.Palette;
if (palette.Entries.Length > 0)
{
palette.Entries[0] = System.Drawing.Color.Red;
imageX.Palette = palette;
}

The ImageX.Palette property cannot be modified on the fly. The following code will NOT change the first entry in the ImageX.Palette:

C# Example
Copy Code
// This code demonstrates what does not work
imageX.Palette.Entries[0] = System.Drawing.Color.Red

Undo does not undo changes to palette. Undo only applies to processing actions.
See Also
Modify Tags & Comments


Draw on the Image

Draw on the Image
ImagXpress 13 for .NET - User Guide > How To > Access and Modify a Loaded Image > Draw on the Image

To utilize the System.Drawing.Graphics capabilities to draw on an image:

  1. Call ImageX. GetGraphics method to get a System.Drawing.Graphics object and associate it with the ImageX image.
  2. The returned graphics object can be drawn upon using the standard System.Drawing.Graphics drawing methods.
  3. When drawing is complete and the graphics object is no longer needed, do one of the following:
  • Call ImageX. ReleaseGraphics method, to update the ImageX object with the image in the Graphics object, then release the memory associated with the graphics object.
  • Call ImageX.ReleaseGraphics(True) to update the ImageX object with the image in the graphics object, then release the memory associated with the graphics object.
  • Call ImageX.ReleaseGraphics(False), to release the memory associated with the graphics object without updating the ImageX object.

Undo does not undo Drawing actions. Undo only applies to processing actions.
See Also
Print an Image
Create a Viewer
Free the Control's Resources
Annotate an Image


View an Image

View an Image
ImagXpress 13 for .NET - User Guide > How To > View an Image

This section provides information about the following:

  • Create a Viewer
  • Define Viewer Properties
  • Specify How the Image Should Be Displayed
  • Display Image
  • Capture, Copy, and Paste
  • Manage End-User Viewing Events


Create a Viewer

Create a Viewer
ImagXpress 13 for .NET - User Guide > How To > View an Image > Create a Viewer

To create a viewer dynamically, define a New ImageXView object:

C# Example
Copy Code
// This code demonstrates that a viewer has been created
ImageXView imageXView1 = new ImageXView(ImagXpress1);

More than one ImageXView may be defined, to view different images, or different views of the same image. See Display Image for more information.
See Also
Print an Image
Free the Control's Resources
Annotate an Image
Draw on the Image


Define Viewer Properties

Define Viewer Properties
ImagXpress 13 for .NET - User Guide > How To > View an Image > Define Viewer Properties

This section provides information about the following:

  • Set the View Window Size & Appearance
  • Set Toolbar & Cursors
  • Set Context Menus
  • Set Scrolling & Mousewheel Behavior


Set the View Window Size & Appearance

Set the View Window Size & Appearance
ImagXpress 13 for .NET - User Guide > How To > View an Image > Define Viewer Properties > Set the View Window Size & Appearance

The ImageXView class inherits the System.Window.Forms.Control class, which provides capability to define a control window.

In addition to the inherited properties and methods, the ImageXView provides a specialized property to specify the BorderStyle, to provide ImagXpress®-specific border options.

See Also
Set Toolbar & Cursors
Set Context Menus
Set Image Display Palette
Set Color Management
Enable Medical Viewing
Enable Progressive Viewing
Set Alpha Blending


Set Toolbar & Cursors

Set Toolbar & Cursors
ImagXpress 13 for .NET - User Guide > How To > View an Image > Define Viewer Properties > Set Toolbar & Cursors

Defining Tools and Toolbars

Each ImageXView object (Viewer) supports one toolbar, which enables application end-users to access ImagXpress® capabilities. Toolbar attributes can be modified using the Toolbar properties and methods, or via ImageXView methods: ToolSet, ToolGet, ToolSetAttribute, ToolGetAttribute.

Using Custom Cursors

By default, the toolbar will use the ImagXpress supplied built-in cursors for each tool. Alternatively, custom cursors may be specified for each tool, using the SetToolCursor method.

See Also
Set the View Window Size & Appearance
Set Context Menus
Set Image Display Palette
Set Color Management
Enable Medical Viewing
Enable Progressive Viewing
Set Alpha Blending


Set Context Menus

Set Context Menus
ImagXpress 13 for .NET - User Guide > How To > View an Image > Define Viewer Properties > Set Context Menus

Viewer Context Menu

Each ImageXView object can have one associated context menu, which provides options to the user within the control window. To define a context menu for the viewer, call ImageXView.ContextMenu. The ContextMenu property inherits from System.Windows.Forms.Control. By default, this property is set to an instance of the ImagXpressDefaultContextMenu class. This class provides a default set of menu items that operate on the ImageXView.

The following code example demonstrates how to add a new item to the context menu:

C# Example
Copy Code
MenuItem menuBlack = new MenuItem();
menuBlack.Text = "Preserve Black";
menuBlack.Name = "Black";
menuBlack.Checked = false;
imageXView1.ContextMenu.MenuItems.Add(6, menuBlack);

The following code example demonstrates how to remove a menu item from the ImagXpress menu:

C# Example
Copy Code
imageXView1.ContextMenu.MenuItems[1].Visible = false;

The following code example demonstrates how to connect an event handler to a menu item:

C# Example
Copy Code
for (int i = 0; i < imageXView1.ContextMenu.MenuItems.Count; i++)
{

 imageXView1.ContextMenu.MenuItems[i].Click += new   EventHandler(ContextMenuClickEventHandler);
             ///must remove event handler during cleanup code
}
//event handler
private void ContextMenuClickEventHandler(object sender, EventArgs e)
{
           …
}

Toolbar Context Menu

Each ImageXView object also has one associated toolbar (Toolbar). The toolbar has an associated context menu, which provides application end-users with options for accessing each of the tools. The toolbar context menu is defined using the methods within the ImageXView.Toolbar.ContextMenu.

See Also
Set the View Window Size & Appearance
Set Toolbar & Cursors
Set Image Display Palette
Set Color Management
Enable Medical Viewing
Enable Progressive Viewing
Set Alpha Blending


Set Scrolling & Mousewheel Behavior

Set Scrolling & Mousewheel Behavior
ImagXpress 13 for .NET - User Guide > How To > View an Image > Define Viewer Properties > Set Scrolling & Mousewheel Behavior

The ImageXView class inherits the System.Window.Forms.Control class, which provides capability to define scrolling and mousewheel behavior.

In addition to the inherited properties, the ImageXView provides specialized properties:

  • Scrollbars turns on and off the scrollbars.
  • MouseWheelCapture turns on and off capturing mousewheel even when the control does not have focus.
See Also
Set the View Window Size & Appearance
Set Toolbar & Cursors
Set Context Menus


Specify How the Image Should Be Displayed

Specify How the Image Should Be Displayed
ImagXpress 13 for .NET - User Guide > How To > View an Image > Specify How the Image Should Be Displayed

This section provides information about the following:

  • Align Image in Window
  • Zoom Image in Window
  • Enable Progressive Viewing
  • Enable Medical Viewing
  • Set Color Management
  • Set Image Display Palette
  • Set Display Bit Depth
  • Set Alpha Blending
  • Change Image Display Rendering


Align Image in Window

Align Image in Window
ImagXpress 13 for .NET - User Guide > How To > View an Image > Specify How the Image Should Be Displayed > Align Image in Window

The ImageXView.AlignHorizontal and ImageXView.AlignVertical properties are set to specify the horizontal and vertical alignment of the image being viewed.

See Also
Zoom Image in Window
Enable Progressive Viewing
Enable Medical Viewing
Set Color Management
Set Image Display Palette
Set Display Bit Depth
Set Alpha Blending
Change Image Display Rendering


Zoom Image in Window

Zoom Image in Window
ImagXpress 13 for .NET - User Guide > How To > View an Image > Specify How the Image Should Be Displayed > Zoom Image in Window

The ImageXView methods modify only the image view, not the image itself. To modify the image, use the Processor.Resize methods.

AutoResize

The ImageXView.AutoResize property defines how an image will be sized and positioned within the display window each time the control paints. The ImageXView.Maximum and ImageXView.Minimum properties define the maximum and minimum dimensions that the control can be resized to when ImageXView.AutoResize specifies that the control should be resized to fit the image.

Zoom To Fit

Call the ImageXView.ZoomToFit method to fit the width and/or height of the displayed image to the control window. The image, the aspect ratio of the displayed image and the aspect ratio of the image's pixels remain unchanged.

Set the Zoom Factor

Zoom the displayed image, by setting the ImageXView.ZoomFactor property to the desired value. Zooming the image has no effect on the image, or the aspect ratio of the displayed image.

If the ImageXView.AutoResize property is set to 'BestFit' then the ImageXView. ZoomFactor property will be locked.

Change the Aspect Ratio

Change the aspect ratio of the displayed image by setting the ImageXView.AspectX and AspectY properties. Setting these properties defines the shape of each pixel in the display. This will change the aspect ratio of the displayed image, but will have no effect on the image itself.

To translate between the coordinates on the displayed image and the coordinates in the image, use the ImageXView.Translate method.

See Also
Align Image in Window
Enable Progressive Viewing
Enable Medical Viewing
Set Color Management
Set Image Display Palette
Set Display Bit Depth
Set Alpha Blending
Change Image Display Rendering


Enable Progressive Viewing

Enable Progressive Viewing
ImagXpress 13 for .NET - User Guide > How To > View an Image > Specify How the Image Should Be Displayed > Enable Progressive Viewing

Progressive viewing can be useful if loading is expected to take a long time (for example, remote loading of a large, highly compressed file). Set ImageXView.Progressive to specify whether or not images are displayed progressively.

See Also
Set the View Window Size & Appearance
Set Toolbar & Cursors
Set Context Menus
Set Image Display Palette
Set Color Management
Enable Medical Viewing
Set Alpha Blending


Enable Medical Viewing

Enable Medical Viewing
ImagXpress 13 for .NET - User Guide > How To > View an Image > Specify How the Image Should Be Displayed > Enable Medical Viewing

If the image to display is a medical image, set ImageXView.Medical to specify parameters specific to medical viewing.

See Also
Set the View Window Size & Appearance
Set Toolbar & Cursors
Set Context Menus
Set Image Display Palette
Set Color Management
Enable Progressive Viewing
Set Alpha Blending


Set Color Management

Set Color Management
ImagXpress 13 for .NET - User Guide > How To > View an Image > Specify How the Image Should Be Displayed > Set Color Management

Image Color Management (ICM) is performed to ensure that the image has a very similar appearance, regardless of the device on which it is displayed or printed. When displaying an image, the image must be converted to the device-specific color space of the specified monitor. This conversion can be done at a number of different points in the process:

  • Prior to loading the image into ImagXpress®
  • By ImagXpress
  • By the display device

To perform color management within ImagXpress:

1. Ensure that ImageXView.IcmEnabled is set to True.

2. Specify how to apply profiles, by setting the ImageXView.ColorRenderIntent property (for example, Picture, Graphics, Business or Colorimetric interpretation.)

3. Specify the color profile to be used when performing ICM on an image to be displayed (ImageXView.MonitorProfileName property).

Setting MonitorProfileName doesn't change the profile name stored with the monitor device context - it simply specifies the color profile ImagXpress uses when performing Image Color Management.

4. Color management will be applied when the image paints.

See Also
Zoom Image in Window
Enable Progressive Viewing
Enable Medical Viewing
Set Image Display Palette
Set Display Bit Depth
Set Alpha Blending
Change Image Display Rendering
Align Image in Window


Set Image Display Palette

Set Image Display Palette
ImagXpress 13 for .NET - User Guide > How To > View an Image > Specify How the Image Should Be Displayed > Set Image Display Palette

When the ImageXView.Image has a bit depth of 8 bits or less, the image's palette is realized by the display device. In other words, the image's palette combines with the display device's logical palette and is used to display the image.

You can specify a different behavior by setting the ImageXView.PaletteType property.

Setting the PaletteType property does not change the palette stored with the ImageXView.Image, but does change the palette realized by the display device.

If PaletteType is set to:

  • Null, then use the image's palette when displaying.
  • UserDefined, then use the ImageXView.GetPaletteColor and SetPaletteColor methods to define and access a user-defined palette.
  • PalFile, then use the ImageXView.PaletteFilename property to set and get the source for the palette.
  • Gray, then a fixed gray palette is used.
  • Fixed, then an ImageXView internally defined palette is used.
  • Optimized, then the image is analyzed and the best palette is used.
See Also
Set the View Window Size & Appearance
Set Toolbar & Cursors
Set Context Menus
Set Color Management
Enable Medical Viewing
Enable Progressive Viewing
Set Alpha Blending


Set Display Bit Depth

Set Display Bit Depth
ImagXpress 13 for .NET - User Guide > How To > View an Image > Specify How the Image Should Be Displayed > Set Display Bit Depth

If the ImageXView.Image property has a greater bit depth than the monitor supports, then the ImageXView object will down sample the image when sending it to the display device.

In some cases, it may be necessary for the application programmer to artificially set the display device to a lower bit depth than the hardware supports (for example, to simulate the application's performance and appearance on a VGA monitor). Use the ImageXView.DisplayMode property to get and set the maximum color depth to use on the display device:

  • If ImageXView.DisplayMode is set to TrueColor, 24-bit images can be rendered to display.
  • If DisplayMode is set to PaletteColor, 8-bit images can be rendered.
  • If DisplayMode is set to VGAColor, 4-bit images can be rendered.
See Also
Align Image in Window
Zoom Image in Window
Enable Progressive Viewing
Enable Medical Viewing
Set Color Management
Set Image Display Palette
Set Alpha Blending
Change Image Display Rendering


Set Alpha Blending

Set Alpha Blending
ImagXpress 13 for .NET - User Guide > How To > View an Image > Specify How the Image Should Be Displayed > Set Alpha Blending

Setting ImageXView.AlphaBlend property to True specifies that an image with an alpha channel should be blended to the background of the control when displayed.

See Also
Set the View Window Size & Appearance
Set Toolbar & Cursors
Set Context Menus
Set Image Display Palette
Set Color Management
Enable Medical Viewing
Enable Progressive Viewing


Change Image Display Rendering

Change Image Display Rendering
ImagXpress 13 for .NET - User Guide > How To > View an Image > Specify How the Image Should Be Displayed > Change Image Display Rendering

The ImagXpress® control provides advanced image display features. The following properties will alter the display of an image after it loads, without changing the image itself. These operations are faster than actually changing the image data and not permanent. They are particularly useful when using multiple views of one image. In that case, an operation on the image data would affect all views of that image buffer, while these operations will only affect one view.

The ImageXView methods modify only the image view, not the image itself. To modify the image, use the Processor methods.

Anti-Aliasing Effect

The ImageXView.Antialias property enables or disables the anti-alias effect. When the logical size of an image is reduced to less than the actual size of the image, then some of that image’s pixels will be lost. When Antialias is enabled, the pixels that would occupy the same area are averaged together; turning them into a level of gray for black and white images. For color images, all of the pixels are averaged. This prevents fine lines from being lost and allows a full page of printed text to be read clearly.

Brightness

The ImageXView.Brightness property sets the brightness level for the image. It allows the user to adjust the brightness of the displayed image.

Contrast

The ImageXView.Contrast property sets the contrast level for the image. It allows the user to adjust the contrast of the displayed image.

Gray Mode

The ImageXView.GrayMode property specifies whether a grayscale image should be displayed using a medical grayscale transform or a simple linear transform.

Smoothing

The ImageXView.Smoothing property enables or disables the view smoothing effect. When the logical size of an image is increased to more than the actual size of the image, the image starts to look boxy. When Smoothing is enabled, ImagXpress performs a leveling algorithm that evens out square edges.

Dithering

The ImageXView.Dithered property enables or disables the use of dithering.

PreserveBlack

The ImageXView.PreserveBlack property enables or disables the preserve black features, which enhances black objects (such as lines) to increase readability.

See Also
Select a Section of the Displayed Image
Display Image


Display Image

Display Image
ImagXpress 13 for .NET - User Guide > How To > View an Image > Display Image

Display an Image in the Viewer

To display an image in the viewer,

  1. Ensure that ImageXView.AllowUpdate property is set to True. AllowUpdate specifies that the viewer (ImageXView object) will update whenever there is a request to paint.
  2. Verify that ImageX.AutoInvalidate property is True. AutoInvalidate specifies that the image (ImageX object) will notify any ImageXView objects actively displaying the ImageX image to perform a repaint whenever there is a change to the image.
  3. Then assign ImageXView.Image property to an ImageX object. This image displays when the control window next paints.

Display a Part of an Image in the Viewer

To display a part of an image in the viewer, set the ClipRectangle property to the portion of the image to be displayed. The ClipRectangle property defines the portion of the image accessible to the viewer. If the ClipRectangle is smaller than the image, then the viewed image crops to the dimensions specified by ClipRectangle. This cropped image is then available in the viewer to be zoomed, scrolled, etc.

Display Different Images within one Viewer

To display a different image within a View window, assign ImageXView.Image to a different ImageX object. This image displays when the control window next paints.

Display Multiple Simultaneous Views of the Same Image

Each ImageXView object can display only one image at a time. Sometimes it is necessary to display multiple views of the same image. A typical use would be to display a "before" and "after" view (with some image rendering options changed) of an image.

To view the same image using multiple ImageXView objects, set the Image property within both ImageXView objects to the same image.

Display Image Information in the Control Window

To display a dialog box with information about the image being displayed, call the ImageXView.ShowImageInfo method. This method displays ImageXData characteristics for the image currently assigned to the ImageXView object.

See Also
Select a Section of the Displayed Image
Change Image Display Rendering


Capture, Copy, and Paste

Capture, Copy, and Paste
ImagXpress 13 for .NET - User Guide > How To > View an Image > Capture, Copy, and Paste

This section provides information about the following:

  • Capture an Image from Screen
  • Copy & Paste Image Using the Clipboard
  • Select a Section of the Displayed Image


Capture an Image from Screen

Capture an Image from Screen
ImagXpress 13 for .NET - User Guide > How To > View an Image > Capture, Copy, and Paste > Capture an Image from Screen

Capture the Screen Area Bounded by the ImageXView Window and Save to an ImageX Object

The following example illustrates how to capture the screen area bounded by the ImageXView Window:

C# Example
Copy Code
// This code demonstrates how to assign the image object to a viewer
ImageXView1.Image = targetImageX;
// capture the screen area within the viewer and save it to the target image object
ImageXView1.CaptureControl();
// targetImageX now contains the image in the screen area bounded by the control.

Capture the Entire Screen Area within a Specified Window

The following example illustrates how to capture the entire screen area within a specified window:

C# Example
Copy Code
// This code demonstrates how to assign the image object to a viewer
ImageXView1.Image = targetImageX;
// capture the screen area within the viewer and save it to the target image object
// if only a part of the window's screen area should be captured, specify a captureRectangle
ImageXView1.CaptureWindow(hWnd, captureRectangle);
// targetImageX now contains the image in the screen area bounded by the control.
See Also
Copy & Paste Image Using the Clipboard


Copy & Paste Image Using the Clipboard

Copy & Paste Image Using the Clipboard
ImagXpress 13 for .NET - User Guide > How To > View an Image > Capture, Copy, and Paste > Copy & Paste Image Using the Clipboard

Copy an ImageX Object to the Clipboard

The following example illustrates how to copy an image to the clipboard:

C# Example
Copy Code
// This code demonstrates how to assign an image object to a viewer
ImageXView1.Image = sourceImageX;
// copy the image to the clipboard
ImageXView1.CopyToClipboard();
// the clipboard now contains a copy of the sourceImageX object.

Paste an Object from the Clipboard to an ImageX Object

The following example illustrates how to paste an object from the clipboard to an ImageX object:

C# Example
Copy Code
// This code demonstrates how to assign an image object to a viewer
ImageXView1.Image = targetImageX;
// paste the image from the clipboard
ImageXView1.PasteFromClipboard();
// the targetImageX object now has the image from the clipboard.

See Also
Capture an Image from Screen


Select a Section of the Displayed Image

Select a Section of the Displayed Image
ImagXpress 13 for .NET - User Guide > How To > View an Image > Capture, Copy, and Paste > Select a Section of the Displayed Image

To select a section of the image, use a Rubberband or a Sprite:

Select with Rubberband

ImagXpress® enables the user to select a rectangular section of the image being viewed. This section, referred to as a Rubberband, can then be used to specify a region to process.

To use a rubberband:

  • Enable the rubberband capability by setting ImageXView.Rubberband.Enabled to True.
  • Define and modify a rubberband area, by calling ImageXView.Rubberband methods: Start, Stop, Update, and Clear.
  • Copy the content framed by the rubberband to an ImageX object using the Rubberband Copy method.

Select with Sprite

The ImageXView class provides capability to create and use a sprite. A sprite is created by copying a part of the displayed image into a transparent window. This window can be moved or pasted within the image view. To create and use a sprite:

  • Define a part of the displayed image to copy. (This can be done either by defining a Rubberband, Region, Area, or a graphics path.)
  • Create the sprite, by calling the Sprite Create method
  • Move the sprite, by calling the Sprite Move method
  • To permanently paste the sprite to the ImageX object, call the Sprite Paste method.

Even if the viewer is assigned a different image to display, the sprite remains in effect and can be moved or pasted in the new image being viewed. Therefore, sprites can be used to merge images.

  • Delete the sprite and free up its resources, by calling the Sprite Delete method.

Deleting the sprite does not result in any changes to the image being viewed.

See Also
Change Image Display Rendering
Display Image


Manage End-User Viewing Events

Manage End-User Viewing Events
ImagXpress 13 for .NET - User Guide > How To > View an Image > Manage End-User Viewing Events

ImageXView inherits events from System.Windows.Forms.UserControl and System.Windows.Forms.Control to monitor end-user actions and display changes, including mouse and keyboard actions. ImagXpress® also provides a few specialized events to provide additional information to the application:

  • When the AutoResize property is modified, the AutoResizeChanged event provides additional information on the new and old values of the AutoResize property.
  • When the ZoomFactor property is modified, the ZoomFactorChanged event provides additional information on the new and old values of the ZoomFactor property.
  • When the control is resized, the Resized event provides the new size of the control.
  • When an image paints, the PaintImage event provides information on the graphics, logical rectangle, user data, view rectangle, and zoom factor.
  • When the end-user scrolls, the ScrollEvent event provides information on the new location within the scroll range, the type of scroll event that occurred, and which scrollbar the event pertains to.

ImagXpress Toolbar Events

In addition to standard Control events, ImageXView offers specialized events to notify the application about end-user interaction with the ImagXpress toolbar.

  • When a tool is selected the ToolbarEvent event raises to tell the application which tool was selected.
  • When a tool is being used, a ToolEvent event raises to notify the application when the tool is clicked, when the tool is in action and when the tool is no longer in use.
  • When the toolbar window opens, the ToolbarOpenEvent raises.
  • When the toolbar window closes, the ToolbarCloseEvent raises.
  • When a menu item is selected, a ToolbarContextMenuSelectEvent raises to notify the application of the selection made. The menu ID is provided to the event handler when this event is raised.
See Also
Zoom Image in Window
Enable Progressive Viewing
Enable Medical Viewing
Set Color Management
Set Image Display Palette
Set Display Bit Depth
Set Alpha Blending
Change Image Display Rendering
Set Toolbar & Cursors
Set Context Menus
Set Image Display Palette
Set Color Management
Enable Medical Viewing
Enable Progressive Viewing
Set Alpha Blending


Process an Image

Process an Image
ImagXpress 13 for .NET - User Guide > How To > Process an Image

This section provides information about the following:

  • Create a Processor
  • Select an Area or Region to Process
  • Modify Image Size & Orientation
  • Modify Image Bit Depth
  • Correct Color & Contrast
  • Cleanup Images
  • Remove Redeye
  • Apply Image Effects
  • Modify Alpha Channel
  • Merge Images
  • Undo a Processing Action


Create a Processor

Create a Processor
ImagXpress 13 for .NET - User Guide > How To > Process an Image > Create a Processor

This code demonstrates how to create a processor and assign an image to be processed.

C# Example
Copy Code
ImagXpress imagXpress = new ImagXpress();
ImageX imageX = ImageX.FromFile(imagXpress, "C:\\image.jpg");
// This code demonstrates how to create a new processor
Processor processor = new Processor(imagXpress);
// This code demonstrates how to assign an image to be processed
processor.Image = imageX;

See Also
Select an Area or Region to Process
Modify Image Size & Orientation
Apply Image Effects
Merge Images
Modify Alpha Channel
Correct Color & Contrast
Cleanup Images
Remove Redeye


Select an Area or Region to Process

Select an Area or Region to Process
ImagXpress 13 for .NET - User Guide > How To > Process an Image > Select an Area or Region to Process

Prior to performing image processing on an image, you must specify whether the entire image, or a section of the image, should be processed. The Processor class provides two vehicles for specifying a section of the image to be processed:

  • Area (Limited to a rectangular area)
  • Region (not limited to a rectangular area)

If both an Area and a Region are enabled and defined, then the last one to be set will be used in processing.

If neither Area or Region are enabled and defined, then the entire image will be processed.

When Processor.EnableArea/EnableRegion is True, additional memory is required to store the original image to be merged with the area/region processed. If Area/Region processing is not needed, set Processor.EnableArea/EnableRegion to False to reduce memory usage.

Region

To process a region of an image:

  1. Define a part of the image to process, by specifying a graphics path, rectangle, ellipse, or polygon.
  2. Create a region, by calling the Processor.SetRegion method. Since only one region can be defined for each Processor, calling SetRegion deletes the previous region.
  3. Specify that the region should be used for processing, by setting the Processor EnableRegion property.
  4. When the region is no longer needed, call the Processor DeleteRegion method to delete the object and free up the associated memory.
A Rubberband can be created to define a rectangular region on the display. The resulting Rectangle can then be passed as a parameter in Processor.SetRegion.
Deleting a region has no impact on the source (ImageX) image.

Area

To process an area of an image:

  1. Create an area by calling the Processor SetArea method, with a specified rectangular bounding area. Since only one area can be defined for each Processor, calling SetArea will delete the previous area.
  2. Specify that the area should be used for processing, by setting the Processor EnableArea property. When the area has been enabled, all image processing methods act on the area instead of the entire image. Calling SetArea will replace the current area with a newly defined area.
A Rubberband can be created to define a rectangular area on the display. First select a rubberband area, then pass the resulting rectangle to Processor.SetArea.
There is no need to delete an area, as there are no resources to free.

The Processor methods: RemoveRedeye, RemoveDust, and RemoveScratches methods require that an area be set to specify the area to process. For all other methods and properties, setting an area is optional.

See Also
Modify Image Size & Orientation
Apply Image Effects
Merge Images
Modify Alpha Channel
Correct Color & Contrast
Cleanup Images
Create a Processor
Remove Redeye


Modify Image Size & Orientation

Modify Image Size & Orientation
ImagXpress 13 for .NET - User Guide > How To > Process an Image > Modify Image Size & Orientation

Image size and orientation can be modified in several ways using ImagXpress®:

  • Modify the size or orientation of an image during loading of the image into ImagXpress (see Specify Load Options). In this case, the image in the ImageX object is modified to the specified size and orientation, but the source image is not modified.
  • Modify the size or orientation of an image during saving of the image (See Specify Save Options). In this case, the image in the ImageX object is not modified, but the target image is modified.
  • Modify the size or orientation of an image in ImagXpress. In this case, the image in the ImageX object is modified to the specified size and orientation, but the source image is not modified.

Modify the Size or Orientation of an Image in ImagXpress

The size and orientation of an imageX object can be modified by assigning it to the processor, then invoking processor methods:

Resize: The Resize method resizes the image (in pixels) according to the specified algorithm (ResizeType enumeration).

Crop: The Crop method crops the current image to the specified size.

The AutoCrop and CropBorder methods also provide capability to crop a border from an image. These are generally used primarily to clean up the image, rather than resize it.

Flip: The Flip method vertically flips the image.

Mirror: The Mirror method horizontally mirrors the image.

Rotate: The Rotate method rotates the image by the specified angle.

See Also
Select an Area or Region to Process
Apply Image Effects
Merge Images
Modify Alpha Channel
Correct Color & Contrast
Cleanup Images
Create a Processor
Remove Redeye


Modify Image Bit Depth

Modify Image Bit Depth
ImagXpress 13 for .NET - User Guide > How To > Process an Image > Modify Image Bit Depth

The following Processor methods all can be used to reduce the bit depth of an image:

Change Color Depth

The ColorDepth method changes the bits per pixel of the current image.

The UniqueColors method returns the number of unique colors in the current image or region. This can be useful for determining if there is an opportunity to reduce the bit depth of the pixels without degrading the image.
If an image bit depth is modified from an image that is greater than 16 bits to an image that is 8 bits or less in depth, then a palette is associated with the image, as specified by the paletteType parameter when calling the ColorDepth method.

Reduce GrayScale Bit Depth

It may be advantageous to reduce the bit depth of a gray image, as most humans can only discern 256 shades of gray. To level an 8 through 16-bit image to an 8-bit gray image, call the ApplyGrayscaleTransform method to modify the image (permanently). To apply the DICOM standard transformation method to level a medical image, call ApplyGrayscaleTransform(Medical). To apply a simple linear method to level the image, call ApplyGrayscaleTransform(Int32,Int32).

Binarize

The Binarize method operates on 1-bit and 24-bit input images, permanently modifying the image to a 1-bit or 8-bit grayscale DIB of the same dimensions.

The Autobinarize method operates on 1-bit and 24-bit input images, automatically selecting the optimal binarize parameters to convert to a 1-bit monochrome image.

This is often done to clean up an image or apply an image effect.

See Also
Create a Processor
Select an Area or Region to Process
Modify Image Size & Orientation
Correct Color & Contrast
Cleanup Images
Remove Redeye
Apply Image Effects
Modify Alpha Channel
Merge Images
Undo a Processing Action


Correct Color & Contrast

Correct Color & Contrast
ImagXpress 13 for .NET - User Guide > How To > Process an Image > Correct Color & Contrast

ImagXpress® provides a suite of methods and properties that enable adjustment of image color. The color of each pixel in an image can be characterized using various color spaces. The Processor class enables the user to modify the color balance within an image by specifying either of the following color spaces:

  • RGB specifies the red, green and blue values within the pixel.
  • HSL specifies the hue (color tone), saturation (grayness), and luminance (intensity of light).

Modify RGB Levels

To change the levels of red, green and blue in the image, call AdjustRGB method, specifying the amount of change to the red, green and blue components of each pixel (in units or by percentage). Use the RGBColorCount method to identify the red, green, and blue color intensities of the image. This is useful in determining how to set parameters.

Modify HSL Levels

To change the levels of hue, saturation and luminance in the image, call AdjustHSL, specifying the amount of change to the hue, saturation and luminance components of each pixel (in units or by percentage).

Modify Luminance/Brightness

The Brightness method uniformly brightens the current image, by the percent specified. A brightened image has pixels with higher luminance values (in HSL color space), or higher RGB values (in RGB color space) than the original image.

Automatic Color Balance

The Processor object provides two alternative automatic color balance methods. Each uses a different algorithm to correct color balance. The user has the flexibility to use whichever method works best for the application and image:

  • To balance automatically, call AutoColorBalance. To override the default parameters used in the AutoColorBalance algorithm, call AdjustColorBalance instead of AutoColorBalance. The RGBColorCount method can be used to identify the red, green and blue color intensities of the image. This may be useful in determining how to set parameters specified in AdjustColorBalance.
  • To color balance automatically using an alternative algorithm, call AutoLevel.

Automatic Contrast Correction

The Processor class provides three alternative automatic contrast correction methods. Each uses a different algorithm to correct contrast within the image. The user has the flexibility to use whichever method works best for the application and image:

  • The AutoLightness method assesses and adjusts contrast in light and dark regions of the image separately. This can be especially useful for bringing more detail into the shadowy areas of the image, without washing out the light regions. To override the default parameters used in the AutoLightness algorithm, call AdjustLightness instead of AutoLightness.
  • The AutoContrast method adjusts the overall contrast of the image. To adjust the automatic contrast correction by a specified amount, call Contrast instead of AutoContrast.
  • The Equalize method adjusts contrast without changing the brightness range of the image. If the brightness values of the image were represented in a histogram, the Equalize method would have the effect of redistributing the brightness values within the image's brightness range, so that "clumps" of brightness values are spread out more evenly. For example, if an image has many pixels that have similar brightness, the Equalize method will introduce greater difference in brightness between these pixels, without changing the least bright or most bright pixels. The effect is that greater detail can be seen in areas that previously had very similar brightness.

Modify Gamma

Unfortunately, monitors may output pixel brightness in a non-linear fashion, so that when the image is displayed, the image brightness is not accurately portrayed. Adjusting gamma enables the user to adjust pixel brightness to compensate for the limitations of the display device. The gamma value represents the ratio of input vs. output brightness.

A gamma of one represents a linear relationship between input and output brightness - no change is made to the image. A gamma other than one represents a parabolic relationship between input and output brightness. Applying a gamma greater than one brightens the image, with mid-brightness levels increased more than extremely dark or light pixels. A gamma less than one darkens the image, with mid-brightness levels decreased more than extremely dark or light pixels.

The Gamma method adjusts the brightness of the image based on a parabolic transform, defined by the gamma value. A Gamma value that is greater than one will result in a convex parabolic transform, with the mid-range brightened more than high and low end. A Gamma value that is less than one will result in a concave parabolic transform, with the mid-range darkened more than the high and low end.

Join or Split RGB Values

The Processor class also provides the capability to split or join the RGB values of the pixels in the image. To separate the color components of the image, call ColorSeparation. To join the color components of the image, call ColorJoin.

You must free the resources associated with each color plane bitmap after it is no longer needed. Call ImageX.DisposeHbitmap to release the resources associated with the handles after use.

Count Colors

The ColorCount method returns the number of pixels of a specified color within the current image or region. This can be useful, for example, in determining whether a check box on a form is filled.

See Also
Create a Processor
Select an Area or Region to Process
Modify Image Size & Orientation
Modify Image Bit Depth
Cleanup Images
Remove Redeye
Apply Image Effects
Modify Alpha Channel
Merge Images
Undo a Processing Action


Cleanup Images

Cleanup Images
ImagXpress 13 for .NET - User Guide > How To > Process an Image > Cleanup Images

ImagXpress® provides methods and properties to support cleanup of photo and document images, using the Processor methods and properties:

Binarize

To facilitate cleanup or image recognition, it may be useful to convert an image to a 1-bit or 8-bit grayscale image. The Binarize method operates on 1-bit and 24-bit input DIB's, permanently modifying it to a 1-bit or 8-bit grayscale DIB of the same dimensions. The Autobinarize method operates on 1-bit and 24-bit input images, automatically selecting the optimal binarize parameters to convert to a 1-bit monochrome image.

Deskew

To adjust the rotation of the page to remove skew, use one of the following:

  • The Deskew method provides the option of specifying how the deskew performs (for example, whether the rotated image is cropped to original dimensions, or whether the image size adjusts based on the deskew).
  • If the image is a black and white document, you may wish to use the DocumentDeskew method, which has been optimized for 1-bit images and which provides feedback on confidence in the result (Confidence property) and rotation angle required to correct the skew (RotationAngle property.

Shear

To adjust the rotation of the body of the image in a document, use the DocumentShear method to correct rotation within the body of the image text. (For example, if an image, like a page of a book, was not flat when scanned, the resulting digital image text may be skewed. The Deskew method will correct rotation of the entire page, but will not address skew within the text body of the image. In this instance DocumentShear may be a more useful method.)

Remove Specks or Blobs

To eliminate small specks or larger black objects, use one of the following:

  • The Despeckle method removes black specks from an image.
  • To remove small specks from a black and white document, use the DocumentDespeckle method, which has been optimized for 1-bit images and which provides feedback on the number of specks found (CountOfSpecsFound).
  • To remove larger black objects from a black and white document, such as binder punch holes, use the DocumentBlobRemoval method. This method sets the CountOfObjectsFound property.
  • If the image is a photo, you may wish to use the RemoveDust method, which has been optimized to remove black or white specks from color images. (Note: You must define an area to be processed, using the SetArea method prior to using the RemoveDust method.)

Remove Lines or Scratches

To eliminate lines or scratches from the image, use one of the following:

  • If the image is a black and white document, use the DocumentLineRemoval method. This method sets the CountOfLinesFound property.
  • If the image is a photo, use the RemoveScratches method to remove scratches from the image. (Note: You must define an area to be processed, using the SetArea method prior to using the RemoveScratches method.)

Identify Blank Pages

To identify blank pages in a document, call the DocumentBlankPageDetect method. The BlankPageDetected and Confidence properties are set with the results of the DocumentBlankPageDetect method.

Clarify Letters and Lines

ImagXpress offers a number of methods, aimed at clarifying and smoothing letters and lines:

Dilate: To enhance/fill in divots in black letters and lines, use Dilate. If the image is black and white, you can use the DocumentDilate method, which has been enhanced for black and white images.

Erode: To reduce/erase protrusions from black letters and lines, use Erode. If the image is black and white, you can use the DocumentErode method, which has been enhanced for black and white images.

Smooth: If the image is black and white, you can use the DocumentZoomSmooth method. This method smooths letters and lines, by first doubling their width and height, then dilating and eroding as required.

Remove Edges or Borders

To remove borders of an image, use one of the following methods:

  • Crop borders using the CropBorder method, specifying the type of crop (cropType) and threshold for recognizing the border (percentToCrop).
  • Automatically crop edge space from an image, using the AutoCrop method.
  • If the image is black and white, the DocumentBorderCrop method can be used to automatically crop the borders of the document. This method has been enhanced for black and white images and sets the Confidence property to indicate the confidence of the DocumentBorderCrop result.
See Also
Select an Area or Region to Process
Modify Image Size & Orientation
Apply Image Effects
Merge Images
Modify Alpha Channel
Correct Color & Contrast
Create a Processor
Remove Redeye


Remove Redeye

Remove Redeye
ImagXpress 13 for .NET - User Guide > How To > Process an Image > Remove Redeye

To reduce the red reflection of the flash seen in the eyes of people in color flash photo images, use one of the following Processor methods:

Manual Red Eye Removal

Manually remove redeye from eyes in the image, using the RemoveRedeye method.

You must define an area to be processed, using the SetArea method prior to using the RemoveRedeye method.

Automatic Red Eye Removal

Automatically remove redeye from eyes in the image, using the AutoRemoveRedeye method.

The AutoRemoveRedeye method will accurately correct red eyes without modifying elements in the photo which are not eyes, in most cases without any intervention.

Optimized Red Eye Removal

As with any algorithm, there is a potential for false positives (modifications of areas that are not eyes), or red eyes that are not corrected in some images.

To provide the application with maximum control over this behavior, the AutoRemoveRedeye method returns all areas that have been corrected as a collection of rectangles. The rectangles identify areas in which red-eyes were detected and corrected and a value indicating the confidence that the area corrected was a red eye. This enables the application to set an acceptable level of false positives and optimize red-eye correction.

For example, an application could do the following:

1. Enable the undo method by setting ImageX.UndoEnabled = True.

2. Correct redeyes, by calling Processor.AutoRemoveRedeye, specifying desired eyeshade, desired eye glare and setting UseEditRectangles to False. (When UseEditRectangles is True, previously detected rectangles will be used to correct red eyes. When UseEditRectangles is False, existing rectangles are ignored.) The AutoRemoveRedeye method removes red eyes from the image and sets the rectangles property to the collection of rectangles in which red eyes were detected and corrected.

To correct redeyes without displaying the results, disable paint by setting ImageX.AutoInvalidate = False prior to calling Processor.AutoRemoveRedeye.

3. Search and reverse any false positives

A. Enumerate through the collection of rectangles, starting at "1" through Processor.Redeyes.Count.

B. Determine if a rectangle erroneously identified an area as containing red eyes, either by visual inspection or by determining that confidence values are below the desired threshold.

This threshold could be set by either the application end-user or the application programmer.

  • If the goal is to minimize false positives (modification of areas that aren't red eyes), keep only rectangles that have a very high confidence level. This will result in fewer red-eyes that are corrected, but may reduce the false positives.
  • If the goal is to maximize the number of red-eyes corrected, keep rectangles with a lower confidence level as well. This will result in more red-eyes corrected, but may increase the false positives.

C. Call Processor.Redeyes.RemoveRectangle to delete rectangles associated with any regions that should NOT be corrected.

4. Add red eyes that were not automatically corrected, if any, as follows:

A. Identify any remaining red eyes (visually).

B. Draw a rectangle around the remaining eyes. (Use rubberband, region, or area).

C. Add the rectangle to the rectangle collection, by calling Processor.Redeyes.

5. Modify redeye regions size or position, using the properties within the RedeyeRectangle class.

6. Correct red-eyes and display the image as follows:

A. Undo the previous AutoRemoveRedeye by calling Processor.ImageX.Undo.

B. Enable painting, by setting ImageX.AutoInvalidate = True

C. Correct redeyes, by calling Processor.AutoRemoveRedeye, setting UseEditRectangles to True.

See Also
Select an Area or Region to Process
Modify Image Size & Orientation
Apply Image Effects
Merge Images
Modify Alpha Channel
Correct Color & Contrast
Cleanup Images
Create a Processor


Apply Image Effects

Apply Image Effects
ImagXpress 13 for .NET - User Guide > How To > Process an Image > Apply Image Effects

ImagXpress® provides methods and properties to support a variety of image processing effects, using the methods within the Processor class:

Color & Lightness Effects

Binarize - The Binarize method operates on 1-bit and 24-bit input DIB's, permanently modifying it to a 1-bit or 8-bit grayscale DIB of the same dimensions. The Autobinarize method operates on 1-bit and 24-bit input images, automatically selecting the optimal binarize parameters to convert to a 1-bit monochrome image.

Negate - The Negate method creates a color negative of the image.

Solarize - The Solarize method negates the colors beyond the threshold value.

ReplaceColors - The ReplaceColors method replaces a range of colors in the current image.

Posterize - The Posterize method reduces the number of colors in the image, to give the effect of contours in the image.

Emboss - The Emboss method transforms the image to give it a raised metallic-like look.

Parabolic - The Parabolic method adjusts the brightness of the image based on either a convex or concave parabolic transform, as specified. The convex parabolic transform darkens the pixels at the high and low range of the image's brightness spectrum and brightens the pixels in the middle range. The concave parabolic transform brightens the pixels at the high and low range of the image's brightness spectrum and darkens pixels in the mid-range.

Blending Effects

Blend -The Blend method blends each pixel in the image with its neighboring pixels.

Diffuse - The Diffuse method replaces each pixel in the image with a randomly selected neighboring pixel.

Median - The Median method uses a 3x3 median filter to blend in the current image.

Sharpness Effects

Blur - The Blur method blurs the image to give it an 'out of focus' appearance.

MotionBlur - The MotionBlur method creates a motion blur effect in the image.

Sharpen - The Sharpen method sharpens the image by applying a high pass convolution filter.

Soften - The Soften method softens the image by applying a low pass convolution filter.

Unsharpen - The Unsharpen method sharpens edges within the image, but softens other areas.

Special Effects

Perspective - The Perspective method changes the aspect for each row and column of pixels to give the effect of an altered perspective.

Swirl - The Swirl method transforms the image, making it look as if it were swirled from the center.

Twist - The Twist method transforms the image, by dividing the image into square blocks and rotating each block.

Ripple - The Ripple method produces a wave-like ripple effect in the image.

Pinch - The Pinch method transforms the image to make it appear "pinched" in the center.

PolynomialWarp - The PolynomialWarp method resizes and warps the image based on four defined points within the image.

Buttonize - The Buttonize method transforms the image to make it look like a 3D button by adding translucent bevels to the edges of the image.

Outline - The Outline method enhances the edges in an image so that objects appear outlined.

Tile - The Tile method tiles the image.

Mosaic - The Mosaic method creates a pixelated version of the image.

Noise - The Noise method adds noise to the image.

See Also
Select an Area or Region to Process
Modify Image Size & Orientation
Merge Images
Modify Alpha Channel
Correct Color & Contrast
Cleanup Images
Create a Processor
Remove Redeye


Modify Alpha Channel

Modify Alpha Channel
ImagXpress 13 for .NET - User Guide > How To > Process an Image > Modify Alpha Channel

ImagXpress® supports processing alpha channel information to manage transparency in images. Alpha channels are supported for PNG, Targa, and TIFF files. While not typical, ImagXpress also supports alpha channel for BMP and ICO files. If the image is saved to a format which does not support alpha channel, the alpha channel will be dropped.

Adding Alpha Channel to an Image

To add an alpha channel to a 24-bit image, call Processor.AlphaAdd, specifying an hBitmap or bitmap with the desired alpha channel information. The Processor.Image property converts to a 32 bit image, including the new alpha channel.

The Processor.Image must be 24-bit prior to calling Processor.AlphaAdd, or an exception is thrown.

Removing an Alpha Channel from an Image

To remove an alpha channel from a 32 bit image, call Processor.AlphaRemove method, which converts the Processor.Image to a 24-bit image without an alpha channel. The alpha channel information is not saved.

The Processor.Image must be a 32 bit image including alpha information prior to calling Processor.AlphaRemove, or an exception is thrown.

Flattening an Alpha Channel Image

Call Processor.AlphaFlatten to blend the 32 bit alpha channel plane with a specified color to create a blended 24-bit image. The resulting image has transparency information stored in the specified color within the 24-bit color spectrum.

The Processor.Image must be a 32 bit image including alpha information prior to calling Processor.AlphaFlatten, or an exception is thrown.

Reading Alpha Channel Information

To get the alpha value at a specified X and Y location in the image, call Processor.AlphaGet.

To get the entire alpha channel plane associated with the image, call Processor.GetAlphaChannelAsBitmap or GetAlphaChannelAsHBitmap. The alpha plane stores to a bitmap or HBitmap, as specified.

Modifying Alpha Channel Information

To set an alpha value at a specified X and Y location in the image, call Processor.AlphaSet.

To modify transparency levels across the image, select one of the following options:

  • Call Processor.AlphaInvert to invert the alpha values throughout the image, so that what was opaque becomes transparent and vice versa.
  • Call Processor.AlphaFill to fill a specified region within the alpha image with a specified value.
    If no region is specified, the entire alpha channel is set with the specified value.
See Also
Select an Area or Region to Process
Modify Image Size & Orientation
Apply Image Effects
Merge Images
Correct Color & Contrast
Cleanup Images
Create a Processor
Remove Redeye


Merge Images

Merge Images
ImagXpress 13 for .NET - User Guide > How To > Process an Image > Merge Images

Merging is the operation of combining the current image being processed (Processor.Image property), with another ImageX image. The resulting merged image is stored in Processor.Image.

To merge images, call Processor.Merge.

If either of the images being merged has a bit depth of less than 24-bits, then both images are converted to 24-bit images, then merged. However a 1-bit image merged with another 1-bit image may result in a 1-bit image.
If either of the images being merged has an associated color profile, then each image's profile is applied, then the images are merged. No color profile is retained.
Using Sprite offers limited capability of merging a part of an image with another one.

See Also
Create a Processor
Select an Area or Region to Process
Modify Image Size & Orientation
Modify Image Bit Depth
Correct Color & Contrast
Cleanup Images
Remove Redeye
Apply Image Effects
Modify Alpha Channel
Undo a Processing Action


Undo a Processing Action
ImagXpress 13 for .NET - User Guide > How To > Process an Image > Undo a Processing Action

You can check Processor.ImageWasModified property at any time to determine whether the image was modified by the last processing action. (If an error occurs during processing, the processing action is discontinued and the image is not modified.)

Enable Undo Capability

The Undo capability enables you to undo the action of a processing method. To use the Undo capability, make sure ImageX.UndoEnabled property is set to True. This enables the undo feature for a specific image, prior to performing image processing.

When ImageX.UndoEnabled is True, additional memory is required to store the undo image.

If Undo is not needed, set ImageX.UndoEnabled to False to reduce memory usage.

Undo a Processing Action

To undo the image processing action, call the ImageX.Undo method. The current image is replaced with the Undo image, restoring the image to its original state.

Only image processing actions can be undone. Changes to ICM, loading and saving cannot be undone.

See Also
Save Image to File
Save Image to Bitmap or DIB
Cancel
Save Image to Stream


Pass Image Data Between Different Accusoft Components

Pass Image Data Between Different Accusoft Components
ImagXpress 13 for .NET - User Guide > How To > Pass Image Data Between Different Accusoft Components

Traditionally, transferring image data between Accusoft components has required passing the image data in a DIB format. But, beginning with the release of ImagXpress 11, we are adding new methods throughout our products which allow you to easily copy or transfer image data between different Accusoft objects with just a single method call.

Regardless of its product or component assembly, any Accusoft image class which supports easily sending its image data to another Accusoft object will implement two methods: CopyTo(object destination) and TransferTo(object destination). And any Accusoft image class which supports easily receiving this image data (that is, being the destination object) will be noted in its class documentation.

A CopyTo method makes a complete copy of the image data. When called, both the source and destination objects will contain their own separate copies of identical image data. A TransferTo method, on the other hand, completely transfers the image data from one object to another. When finished, the source object will no longer contain image data; the image will be owned by the destination object.

Within the ImagXpress Suite

Within the ImagXpress suite of components, there are four classes which support sending their image data via CopyTo and TransferTo methods:

  1. ImagXpress - Accusoft.ImagXpressSdk.ImageX
  2. TwainPRO - Accusoft.TwainProSdk.ScannedImage
  3. ISIS Xpress - Accusoft.ISISXpressSdk.Output
  4. ThumbnailXpress - Accusoft.ThumbnailXpressSdk.ThumbnailItem

And within the ImagXpress suite of components, there is only one class which supports receiving image data: the ImagXpress ImageX class.

Other Accusoft products may contain additional classes which can send and receive image data.

How to Transfer Image Data from One ImageX Object to Another

Even within just the ImagXpress component, you can use this new approach to easily copy or transfer image data from one ImageX object to another.

Here's an example:

C# Example
Copy Code
using System.Drawing;
using Accusoft.ImagXpressSdk;

namespace ConsoleExample
{
    class Program
    {
        static void Main(string[] args)
        {
            using (ImagXpress ix = new ImagXpress())
            using (ImageX redImage = new ImageX(ix, 400, 400, 24, Color.Red))
            using (ImageX whiteImage = new ImageX(ix, 1200, 1200, 1, Color.White))
            {
                redImage.Save("original.bmp");
                whiteImage.TransferTo(redImage);
                redImage.Save("transferred.bmp");
            }
        }
    }
}

In the above example, we create a small, 24-bit red image object named redImage and save its image data to disk as "original.bmp". If you open this file, you will see a small red image.

Then, we create a large, 1-bit white image named whiteImage. But, instead of saving its data to disk directly, we first transfer its image data to the redImage object and then save the redImage instance's image data again, this time as "transferred.bmp". Since the image data inside of the whiteImage object was completely transferred to the redImage object, if you open this second file you will see a large white image.

See Also
CopyTo Method
TransferTo Method


Use the New Multi-Page TIFF Edit API

Use the New Multi-Page TIFF Edit API
ImagXpress 13 for .NET - User Guide > How To > Use the New Multi-Page TIFF Edit API

The Multi-Page TIFF edit API supports insertion and deletion of multiple pages in TIFF image files in one operation. These APIs allow the developer to replace for loops with a single call. They also reduce the overhead of opening and closing a TIFF document multiple times and reduce the amount of traversing through a document. The previous API will remain to support existing code.

  • Use the New Multi-Page TIFF Edit API
    • Delete Multiple Pages
    • Insert Multiple Pages


Delete Multiple Pages

Delete Multiple Pages
ImagXpress 13 for .NET - User Guide > How To > Use the New Multi-Page TIFF Edit API > Delete Multiple Pages

The ImageX.DeletePage method deletes a single page at a time. The ImageX.DeletePages method allows the developer to specify the number of pages to delete.

The ImageX.DeletePage method looks like this:

C# Example
Copy Code
public static void DeletePage(
   ImagXpress imagXpress,
   string filename,
   int pageNumber
)
ImageX.DeletePage(imagXpress, filename, pageNumber);

The ImageX.DeletePages method looks like this:

C# Example
Copy Code
public static void DeletePages(
   ImagXpress imagXpress,
   string filename,
   int pageNumber,
   int numberOfPages
)
ImageX.DeletePages(imagXpress, filename, pageNumber, numberOfPages);

Deleting the First Three Pages in a TIFF Document

Using ImageX.DeletePage to delete the first 3 pages in a multipage TIFF document requires code similar to this:

Copy Code
for (int i = 0; i < 3; i++)
{
ImageX.DeletePage(imagXpress1, filename, 1);
}

Using ImageX.DeletePages, the previous example is done like this:

Copy Code
ImageX.DeletePages(imagXpress1, filename, 1, 3);

Deleting the Last Three Pages in a TIFF Document

Using ImageX.DeletePage to delete the last 3 pages in a multipage TIFF document requires code similar to this:

Copy Code
int numberOfPagesInDocument = ImageX.NumPages(imagXpress1, filename);
int pageToDelete = numberOfPagesInDocument ‐ 2;
for (int i = 0; i < 3; i++)
{
ImageX.DeletePage(imagXpress1, filename, pageToDelete);
}

Using the ImageX.DeletePages the previous example is done like this:

Copy Code
int numberOfPagesInDocument = ImageX.NumPages(imagXpress1, filename);
int startPageToDelete = numberOfPagesInDocument ‐ 2;
ImageX.DeletePages(imagXpress1, filename, startPageToDelete, 3);


Insert Multiple Pages

Insert Multiple Pages
ImagXpress 13 for .NET - User Guide > How To > Use the New Multi-Page TIFF Edit API > Insert Multiple Pages

The InsertPage method inserts a single page from one source TIFF file into another destination TIFF file. The InsertPage method allows the first page of a source multi-page TIFF file or a single page TIFF file to be inserted into a destination TIFF file.

The InsertPages method supports setting a starting page in a source multi-page TIFF file and setting the number of pages to be inserted from the source TIFF file into the destination TIFF file.

The ImageX.InsertPage method looks like this:

C# Example
Copy Code
public static void InsertPage(
   ImagXpress imagXpress,
   string srcFileName,
   string dstFileName,
   int pageNumber
)
ImageX.InsertPage(imagXpress, srcFileName, dstFileName, pageNumber);

The ImageX.InsertPages looks like this:

C# Example
Copy Code
public static void InsertPages(
   ImagXpress imagXpress,
   string sourceFilename,
   int sourcePageNumber,
   int numberOfPages,
   string destinationFilename,
   int destinationPageNumber
)
ImageX.InsertPages(imagXpress, sourceFilename, sourcePageNumber, numberOfPages, destinationFilename, destinationPageNumber);

Inserting the First Pages of One TIFF Document into Another

Using ImageX.InsertPage to insert the first 3 pages of a multipage TIFF document into another document requires code similar to the following:

Copy Code
System.IO.File.Copy(sourceFilename, tempSourceFilename);
for (int i = 1; i <= 3; i++)
{
    ImageX.InsertPage(imagXpress1, tempSourceFilename, destinationFilename, i);
    ImageX.DeletePage(imagXpress1, tempSourceFilename, 1);
}

The same task can be done with ImageX.InsertPages with the following code:

Copy Code
ImageX.InsertPages(imagXpress1, sourceFilename, 1, 3, destinationFilename, 1);

Appending Pages of One TIFF Document into Another

Using the ImageX.InsertPage method to append the first 3 pages of one TIFF document to the end of another TIFF document required code similar to this:

Copy Code
int numberOfPagesInDocument = ImageX.NumPages(imagXpress1, destinationFilename);
int startPageToAppend = numberOfPagesInDocument + 1;
System.IO.File.Copy(sourceFilename, tempSourceFilename);
for (int i = 0; i < 3; i++)
{
  ImageX.InsertPage(imagXpress1, tempSourceFilename, destinationFilename,
startPageToAppend + i);
  ImageX.DeletePage(imagXpress1, tempSourceFilename, 1);
}

The same task can be done using ImageX.InsertPages with the following code:

Copy Code
ImageX.InsertPages(imagXpress1, sourceFilename, 1, 3, destinationFilename, int.MaxValue);

Using the int.MaxValue above signals to the InsertPages method the intention to append to the end of the document. Setting any value greater than the number of pages in the destination file will append it to the end of the file.


Use the Touch Capability

Use the Touch Capability
ImagXpress 13 for .NET - User Guide > How To > Use the Touch Capability

ImagXpress has added the Windows 7 Touch capability. The Touch feature is controlled by the Touch property of the ImageXView class. The Touch property is a Touch class type. This class is only available through an ImageXView object. The Touch class provides the mechanism to control the behavior of the Touch support. The actual Touch events, Gestures and Flicks, occur on the ImageXView control.

This section provides information about how to do the following:

  • Verify Support
  • Enable Touch Capabilities
  • Enable Built-in Touch Support
  • Use Tools and the Toolbar
  • Use Events


Verify Support

Verify Support
ImagXpress 13 for .NET - User Guide > How To > Use the Touch Capability > Verify Support

The Touch class has two read-only properties to help you determine if the operating system is capable of supporting touch, and to determine if there is a touch device available.

  • Use the Touch.DoesOperatingSystemSupport property to query whether the operating system is capable of touch support.
  • Use the Touch.IsDeviceAvailable property to query whether there is a touch device connected to the computer system.


Enable Touch Capabilities

Enable Touch Capabilities
ImagXpress 13 for .NET - User Guide > How To > Use the Touch Capability > Enable Touch Capabilities

Touch support is enabled by the Touch class Mode property. The Touch.Mode property is an enumeration type called TouchMode, which provides the ability to turn off touch support completely, enable gestures only, enable flicks only, or enable them both. Enabling both can sometimes cause the operating system to have difficulty determining between a flick and a pan gesture. Although it is possible to have both enabled, the user may become frustrated if too many gestures are misinterpreted. For this reason, we have a property that requires two fingers for a panning gesture instead of the default of allowing one finger to control a pan. The property is a Boolean property called Touch.RequireTwoFingerPanning. The user should be informed if this is how the application controls touch panning support.


Enable Built-in Touch Support

Enable Built-in Touch Support
ImagXpress 13 for .NET - User Guide > How To > Use the Touch Capability > Enable Built-in Touch Support

If Touch support is enabled (gestures are enabled by default), the ImageXView control already has built-in support for responding to the gestures. There is no built-in support for flicks.

The gestures with built-in support are:

  • Panning
  • Rotating
  • Zooming
  • Context menu support through both the press and hold gesture and the press and tap gesture

For instance, if the user does a panning gesture, the image will pan in the same direction. If the user does a rotating gesture then the image will rotate in 90° increments in the direction that the user rotated. The rotation gesture is unique in that the developer can set both an angle threshold that specifies at what angles a 90° rotation should occur and also the minimum angle threshold that the user must rotate their fingers to specify that at least one rotation occurs. The property that determines what angles in the user’s rotation of their fingers triggers a 90° rotation of the image is called Touch.ImageRotationTriggerAngle. The property that determines the minimum threshold the user’s finger must rotate for at least one 90° rotation of the image to occur when the rotation gesture has ended is called Touch.ImageRotationMinimumAngle.

The built-in gesture support can be enabled or disabled individually so that the developer can choose the behavior. The following properties control whether the built-in support is turned on or off:

  • Touch.ImagePanningEnabled
  • Touch.ImageRotationEnabled
  • Touch.ImageZoomingEnabled
  • Touch.ImageContextMenuEnabled

The gesture’s event will fire whether built-in support is turned on or off for the gesture.


Use Tools and the Toolbar

Use Tools and the Toolbar
ImagXpress 13 for .NET - User Guide > How To > Use the Touch Capability > Use Tools and the Toolbar

The tools available in the toolbar will respond to touch as if the mouse were generating the clicks and movements. The tools will work whether gestures are enabled because they are controlled by the Window’s touch to mouse conversion and not by the gesture system. When the magnifier tool is selected, the PressAndHold and the single finger Panning gestures are not enabled. The magnifier tool will display above the finger for the region that is directly under the finger. This works similar to other environments that support a magnifier tool. The magnifier tool will maintain focus even if the user pans outside of the image past the magnifier window and the magnifier window closes. If the user brings their finger back over the image, the magnifier window will reappear.


Use Events

Use Events
ImagXpress 13 for .NET - User Guide > How To > Use the Touch Capability > Use Events

The touch events are either flicks or gestures, and they occur on the ImageXView control. These events will fire if the user has connected an event handler. The events will fire whether or not the built-in gesture support is enabled or disabled.

The touch events are:

  • PressAndHold
  • PressAndTap
  • TwoFingerTap
  • Flick
  • PanGestureOccurring
  • PanGestureOccurred
  • RotationGestureOccurring
  • RotationGestureOccurred
  • ZoomGestureOccurring
  • ZoomGestureOccurred

Each event has its own unique event argument class specific to that event. These event argument classes provide all of the information available from the Windows operating system about the touch event.

Some gestures support multiple events throughout the lifetime of the gesture. These events support the .NET event naming convention of ending with the suffix "Occurring" if the event has just started or is still continuing to occur. The event will end in "Occurred" when the event has finished. This gives the developer the choice to respond only to the last occurrence of the gesture. Sometimes these gestures that have multiple events will fire even when there is no change in the gesture. These extraneous events are filtered by default with the Touch.GestureOccurringEventsFiringMode property. The developer can change the setting on this property to see all of the events that are fired during the lifetime of the gesture.

Other events that fire just once will have a single event.


Reduce a JPEG Image

Reduce a JPEG Image
ImagXpress 13 for .NET - User Guide > How To > Reduce a JPEG Image

Use the JpegReduce method to reduce JPEGs in memory or on disk without first decompressing to a DIB, thereby saving processor time and system resources.

Only 8-bpp grayscale and 24-bpp color JPEGs are supported.

File size reduction is accomplished by requantizing the source JPEG.

Compression ratios and perceived image quality will vary depending on the source JPEG. Generally, higher JPEG compression comes at the cost of visual quality. For this reason, an optional qualityFactor argument is provided to balance compression versus visual quality trade-offs.

Larger qualityFactor values correspond to larger luminance and chrominance values, which may degrade visual quality. For example, consider the 2592x3872, 24-bit color sequential JPEG in Figure 1 that is reduced using various qualityFactor values:

  • QualityFactor 10 reduces file size from 2746 KB to 420 KB. (See Figure 2)
  • QualityFactor 22 reduces file size from 2746 KB to 246 KB. (See Figure 3)
  • QualityFactor 32 reduces file size from 2746 KB to 196 KB. (See Figure 4)

An optional transformMode argument is provided to save reduced JPEGs as either Sequential or Progressive JPEG.

A Progressive JPEG consists of multiple image scans in progressively higher detail. JPEG viewers that support Progressive JPEGs can display the lower quality scans while the remainder of the file is read into memory, which may improve the user experience for viewing large images.

Saving to Progressive JPEG may result in slightly larger files when compared to JPEGs reduced and saved as Sequential JPEG. For example, consider again the 2592x3872, 24-bit color sequential JPEG in Figure 1 that is reduced using various qualityFactor values and converted to Progressive JPEG:

  • QualityFactor 10, reduces file size from 2746 KB to 426 KB.
  • QualityFactor 22 reduces file size from 2746 KB to 254 KB.
  • QualityFactor 32 reduces file size from 2746 KB to 208 KB.

Figure 1: An example 24-bit color sequential JPEG. Dimensions 2592 x 3872. Original size is 2746 KB.

Figure 2: An example 24-bit color sequential JPEG, reduced from 2746 KB to 420 KB with qualityFactor 10.

Figure 3: An example 24-bit color sequential JPEG, reduced from 2746 KB to 246 KB with qualityFactor 22.

Figure 4: An example 24-bit color sequential JPEG, reduced from 2746 KB to 196 KB with qualityFactor 32.

To reduce JPEGs on disk, just specify the path to the source JPEG and the path to save the re-compressed JPEG:

C# Example
Copy Code
try
{
    using (Accusoft.ImagXpressSdk.ImagXpress ix =
        new Accusoft.ImagXpressSdk.ImagXpress())
    {
        Accusoft.ImagXpressSdk.ImageReduce.JpegReduce(
            ix, "Arches_Portrait.jpg", "Arches_Portrait.reduced.jpg");
    }
}
catch (Exception ex)
{
    Console.WriteLine(ex.ToString());
}

Optionally specify the qualityFactor to affect compression and image quality and transformMode to affect the JPEG format saved:

C# Example
Copy Code
try
{
    using (Accusoft.ImagXpressSdk.ImagXpress ix =
        new Accusoft.ImagXpressSdk.ImagXpress())
    {
        Int32 qualityFactor = 10;
        Accusoft.ImagXpressSdk.ImageReduce.JpegReduce(
            ix, "Arches_Portrait.jpg", "Arches_Portrait.reduced.jpg", qualityFactor,
            TransformMode.ToProgressiveJpeg);
    }
}
catch (Exception ex)
{
    Console.WriteLine(ex.ToString());
}

The JpegReduce method can use JPEGs expressed in memory. First read the source JPEG data into Byte array and then re-compress the JPEG data:

C# Example
Copy Code
try
{
    // Read JPEG file to a Byte array.
    String jpegPath = "Arches_Portrait.jpg";
    FileInfo fileInfo = new FileInfo(jpegPath);
    Byte[] original = new Byte[fileInfo.Length];
    using (FileStream fileStream = new FileStream(
        jpegPath, FileMode.Open, FileAccess.Read))
    {
        fileStream.Read(original, 0, (int)fileInfo.Length);
    }

    // Reduce JPEG to a Byte array.
    Int32 qualityFactor = 10;
    Byte[] reduced;
    using (Accusoft.ImagXpressSdk.ImagXpress ix =
        new Accusoft.ImagXpressSdk.ImagXpress())
    {
        Accusoft.ImagXpressSdk.ImageReduce.JpegReduce(
            ix, original, out reduced, qualityFactor, TransformMode.ToProgressiveJpeg);
        Console.Write("QualityFactor {0} reduced \"{1}\" from {2} bytes to {3} bytes.",
            qualityFactor, jpegPath, original.Length, reduced.Length );
    }
}
catch (Exception ex)
{
    Console.WriteLine(ex.ToString());
}


Reduce a PNG Image

Reduce a PNG Image
ImagXpress 13 for .NET - User Guide > How To > Reduce a PNG Image

Use the PngReduce method to losslessly reduce PNGs in memory or on disk without first decompressing to a DIB, thereby saving processor time and system resources.

Supports 1, 4, 8, 16, and 24-bpp PNGs.

File size reduction is accomplished by removing select pieces of metadata and other possible color and/or transparency reductions of the source PNG.

Compression ratios will vary depending on the source PNG. For example, applying PngReduce to a 1280x960, 24-bit color PNG reduces its size from 1754 KB to 1377 KB. However, applying PngReduce to the reduced PNG results in no further size improvements.

To reduce PNGs on disk, just specify the path to the source PNG and the path to save the re-compressed PNG:

C# Example
Copy Code
try
{
    using (Accusoft.ImagXpressSdk.ImagXpress ix =
        new Accusoft.ImagXpressSdk.ImagXpress())
    {
        Accusoft.ImagXpressSdk.ImageReduce.PngReduce(
            ix, "OwlAlpha.png", "OwlAlpha.reduced.png");
    }
}
catch (Exception ex)
{
    Console.WriteLine(ex.ToString());
}

The PngReduce method can use PNGs expressed in memory. First read the source PNG data into a byte array and then re-compress the PNG data:

C# Example
Copy Code
try
{
    // Read PNG file to a Byte array.
    String pngPath = "OwlAlpha.png";
    FileInfo fileInfo = new FileInfo(pngPath);
    Byte[] original = new Byte[fileInfo.Length];
    using (FileStream fileStream = new FileStream(
        pngPath, FileMode.Open, FileAccess.Read))
    {
        fileStream.Read(original, 0, (int)fileInfo.Length);
    }
    // Reduce PNG to a Byte array.
    Byte[] reduced;
    using (Accusoft.ImagXpressSdk.ImagXpress ix =
        new Accusoft.ImagXpressSdk.ImagXpress())
    {
        Accusoft.ImagXpressSdk.ImageReduce.PngReduce(
            ix, original, out reduced);
        Console.Write("Reduced \"{0}\" from {1} bytes to {2} bytes.",
            pngPath, original.Length, reduced.Length );
    }
}
catch (Exception ex)
{
    Console.WriteLine(ex.ToString());
}


Annotate an Image

Annotate an Image
ImagXpress 13 for .NET - User Guide > How To > Annotate an Image

Once an image has been loaded into ImagXpress®, it can be annotated using the NotateXpress™ control.

See Also
Print an Image
Create a Viewer
Free the Control's Resources
Draw on the Image


Print an Image

Print an Image
ImagXpress 13 for .NET - User Guide > How To > Print an Image

ImagXpress® enables you to print an image, using either ImagXpress or PrintPRO™:

Print the Image Using ImagXpress

The image is sent to a specified Graphics object using the ImageXView. Print method.

Color Management while Printing an Image Using ImageXpress

Image Color Management (ICM) is performed to ensure that the image has a very similar appearance, regardless of the device on which it is displayed or printed. When printing an image, the image must be converted to the device-specific color space of the specified printer. This conversion can be done at a number of different points in the process:

  • Prior to loading the image into ImagXpress
  • By ImagXpress
  • By PrintPRO
  • By the printing device

To perform color management within ImagXpress:

  1. Ensure that ImageXView.IcmEnabled is set to True.
  2. Specify how to apply profiles, by setting the ImageXView.ColorRenderIntent property (for example, Picture, Graphics, Business or Colorimetric interpretation.)
  3. Enable color management of an image to be proofed, by setting ImageXView.ICMProofingEnabled to True.
  4. Set the ImageXView.TargetProfileName to the profile to use when proofing the image. When ICMProofingEnabled is True, this profile overrides the ImageXView.PrinterProfileName property. This can be helpful if proofing occurs on a printer or ink different from the destination printer.
  5. Specify the color profile to use when performing ICM on an image to be printed (PrinterProfileName). Setting PrinterProfileName doesn't change the profile name stored with the printer device context - it simply specifies the color profile ImagXpress uses with ICM.
  6. Send the image to the specified device, or PrintPRO, for printing.

Print the Image Using PrintPRO

The ImageXView.Print method requires a graphics object. However, in some containers, this may not be available. In this case, PrintPRO provides a vehicle to print to a selected printing device. PrintPRO may also provide the best solution if you require a customized printer interface and programmatic control over printing functions.

To save the image using PrintPRO, pass the image from ImagXView to PrintPRO. Use PrintPRO to compose the printed page, select a printing device and print to that device.

See Also
Create a Viewer
Annotate an Image
Draw on the Image


Save an Image

Save an Image
ImagXpress 13 for .NET - User Guide > How To > Save an Image

This section provides information about the following:

  • Specify Save Options
  • Save Image to File
  • Save Image to Stream
  • Save Image to Bitmap or DIB
  • Cancel


Specify Save Options

Specify Save Options
ImagXpress 13 for .NET - User Guide > How To > Save an Image > Specify Save Options

Prior to saving an image, specify the image's save options, by setting the properties below. Save options specify critical image saving information, including:

General Saving Options

  • The SaveOptions.Format property specifies the type (format) of the saved file.

Image Color Management Saving Options

  • To perform no color management when saving, set SaveOptions. UseEmbeddedColorManagement = False.
  • To perform color management using the color profile specified in the ImageX image metadata:
  1. Set SaveOptions.UseEmbeddedColorManagement = True
  2. Specify how profiles should be applied, by setting the SaveOptions. ColorRenderIntent property (for example, Picture, Graphics, Business or Colorimetric interpretation.)
  3. The image is modified, to reflect the color profile, then saved.

To perform color management using a color profile specified in a file:

  1. Set SaveOptions.UseEmbeddedColorManagement = False.
  2. Specify how profiles should be applied, by setting the SaveOptions.ColorRenderIntent property (for example, Picture, Graphics, Business or Colorimetric interpretation.)
  3. Set the SaveOptions. TargetProfileName to the name of the color profile you wish to apply to the image being saved
  4. The image is modified to reflect the color profile, then saved.

FTP Saving Options:

To enable saving to a remote location, set the SaveOptions. Internet property as needed, to specify network credentials and proxy settings.

Annotation Saving Options

  • The SaveOptionsAnnotations.Save property specifies whether annotations should be saved when the image is saved.
  • The SaveOptionsAnnotations.View property specifies which view of the annotations should be saved (the annotations associated with the ImageXView object at a point in time). If View is null, the most recent ImageXView annotations are saved.

Image Format-Specific Save Options

DCX (SaveOptionsDcx)

  • Multi page file: The MultiPage property specifies that the image is being saved to a multi-page file.

EXIF (SaveOptionsExif)

  • Thumbnail Size: The ThumbnailSize specifies the size (in pixels) of the thumbnail to be saved.

Icon (SaveOptionsIcon)

  • Multi page file: The MultiPage property specifies that the image is being saved to a multi-page file.

JBIG2(SaveOptionsJbig2)

  • Encoding mode: The EncodeModeCompression property specifies the encoding mode to use when creating the JBIG2 file.
  • File organization: The FileOrganization property specifies the file organization of the JBIG2 bit stream.
  • Invert bits: The InvertedRegion property specifies whether the bits should be inverted prior to symbol analysis.
  • Looseness: The LoosenessCompression property specifies how loose to be when matching symbols and compressing text using either of the lossy text region encode modes.

JLS (SaveOptionsJls)

  • Interleave Mode: The Interleave property specifies the interleave mode for JLS compression.
  • Point Transform: The Point property specifies that an optional point transform should be applied to the image data for compressing JPEG-LS files.
  • Near: The Near property specifies the error tolerance for near-lossless compression.
  • MaxValue: The MaxValue property enables you to specify the desired setting for the MaxValue parameter used in compression.

JPEG, TIFF-JPEG and ePIC files (SaveOptionsJpeg)

  • Quality Level: The Chrominance property specifies the chrominance quality setting. The Luminance property specifies the luminance quality setting to use when saving the file. The SubSampling property specifies the sub-sampling type (which affects color sharpness).

For higher quality and lower compression, set Luminance and Chrominance in the low teens and set SubSampling to 1:1:1 compression.

For higher compression and lower quality, set Luminance and Chrominance in the low 20’s and set SubSampling to 4:1:1 compression

  • Gray Scale: The Grayscale property specifies whether the file is saved as a gray scale file. The SaveOptionsJpeg.Cosited property specifies whether the image is compressed with cosited subsampling when saved. The SaveOptionsJpeg.Progressive property specifies whether JPEG files are to be saved as standard or progressive files.
  • Color Space: The ColorSpace property specifies the image's color space.

JPEG 2000 (SaveOptionsJp2)

  • Compression Type: The Type property specifies whether the compression is lossy or lossless.
  • Compressed Size: The CompressSize property specifies the desired size of the target file.
  • Favor Speed: The FavorSpeed property specifies whether the speed of compression and subsequently decompression is to be favored instead of quality and compressed image size when saving to a JPEG 2000 image.
  • Progression Order: The Order specifies the progression order of the saved JPEG2000 file.
  • Tile Dimensions: The TileSize specifies the tile dimensions for the saved image.
  • Grayscale: The Grayscale property specifies whether the saved image will be grayscale or color.

JpegXR (SaveOptionsJpegXR)

  • Chroma Sub-Sampling: Save by using the options listed in the JpegXRSubSampling Enumeration with the ChromaSubSampling Property.
  • Frequency Order: Use the FrequencyOrdering Property to specify the frequency ordering.
  • Quantization: Use the Quantization Property to specify the quantization.

Lossless JPEG (SaveOptionsLjp)

  • The Type property specifies the type of compression used for saving a lossless JPEG file (Rgb, Ycbcr).

PIC (SaveOptionsPic)

  • Password: The Password property specifies the password for an ePIC (.PIC) format file.

PNG (SaveOptionsPng)

  • Format type: The Interlaced property specifies whether a PNG file is to be saved in the interlaced format.
  • Transparency: The TransparencyColor specifies the color used to represent transparency. The TransparencyMatch specifies how to match image pixels to the transparency color. Transparency can be applied on pixels that are an exact match to the TransparencyColor, the closest match to the TransparencyColor, or not at all.

GIF (SaveOptionsGif)

  • Format type: The Type property specifies the GIF format for saving a GIF file.
  • Transparency: The TransparencyMatch and SaveOptionsGif.TransparencyColor properties specify how transparency information will be saved in the file.
  • Interlaced: The Interlaced property indicates whether the GIF file is saved in the interlaced format.

TIFF (SaveOptionsTiff)

  • Byte order: The .ByteOrder property indicates the byte order for saving a TIFF file.
  • Compression type: The Compression property specifies the TIFF compression type for saving a TIFF file.
  • Rows: The RowsPerStrip property specifies the number of rows to save in each strip of a TIFF file.
  • Color space: The ColorSpace specifies the color space of the image being saved.
  • Multipage: The MultiPage property specifies whether the image is being saved to a multi-page file.

WSQ (SaveOptionsWsq)

  • Black and White Levels: The Black and White properties specify the level of black and white used in the compression of the saved WSQ file.
  • Quantization: The Quantization property specifies the quantization of the saved WSQ file.


Save Image to File

Save Image to File
ImagXpress 13 for .NET - User Guide > How To > Save an Image > Save Image to File

Prior to saving an image, set the SaveOptions to provide specific instructions for saving the image. If no save options are specified, ImagXpress® uses default values when saving the image.

Save to a Local Disk File

To save an image to a file, use the ImageX.Save methods. ImagXpress converts and compresses the image to the file format specified, and saves it to the target location. While ImagXpress is compressing and saving the image, the ImagXpress.ImageStatusEvent and ProgressEvent events provide information on the status of the operations.

Save to an FTP Location

ImagXpress supports saving image files to an FTP locations, as follows:

1. To specify passwords or proxy settings, set the Internet property within SaveOptions

2. Call one of the following:

ImageX.Save(String,SaveOptions)

ImageX.Save(String)

Make sure that the String parameter specifies the full Internet path and file name.

3. A copy of the ImageX image is stored in the target location.

Save a Multi-Page Image

ImagXpress supports the following multi-page image formats: TIFF, ICO and DCX. Multi-page images can be compressed and saved in both the Standard and Professional Editions.

C# Example
Copy Code
// This code demonstrates saving a multi-page image
SaveOptions soOpts = new SaveOptions();
soOpts.Format = ImageXFormat.Tiff;
soOpts.Tiff.Compression = Compression.Group4;
soOpts.Tiff.MultiPage = true;
ImgX.Image = ImageX.FromFile(strFileName);
for (int i = 1; i <=ImgX.Image.PageCount; i++)
{
  ImgX.Image.Page = i;
  ImgX.Image.Save("c:\\multipagetest.tif",Opts);
}

ImagXpress does not support saving to a multipage image at an HTTP or FTP location.

Fast Saving of Multi-page TIFF Files (generally over 1000 pages)

When the SaveOptionsTiff.UseIFDOffset property is false (default), the image is appended to the end of the multi-page TIFF. Due to the linked format of TIFF, the software must traverse all the link pointers to identify the location to which the new page will be appended. The greater the number of pages in the target TIFF file, the longer the write process takes. (Typically, if the target file has more than 1000 pages, the write speed will degrade substantially.

Setting the SaveOptionsTiff.UseIFDOffset property to true specifies that the control should write the image to the location stored in the SaveOptionsTiff.IFDOffset property. This enables much faster writing of TIFF files with many pages because the software can seek to that location without traversing all previous pointer links. This process gives very predictable speeds in adding pages to a multi-page TIFF file.

Important

If the file's IFDOffset ever became out of sync with the SaveOptionsTiff.IFDOffset property value, file corruption could occur. To protect the application from inadvertently corrupting a saved mutli-page file, the ImagXpress control takes the following measures:

  • If the application sets the SaveOptionsTiff.UseIFDOffset property to true or false, the SaveOptionsTiff.IFDOffset property is automatically set to zero. The application must then explicitly set the IFD Offset to be used.
  • Executing any Save method will automatically set the SaveOptionsTiff.UseIFDOffset property to false. The application must then explicitly set the value back to true as needed.
  • Executing any Load method will automatically set the SaveOptionsTiff.IFDOffset to zero, and SaveOptionsTiff.UseIFDOffset to false. The application must then explicitly set the SaveOptionsTiff.UseIFDOffset to true as needed.
  • When the SaveOptionsTiff.IFDOffset property is zero, a normal write (not fast TIFF write) will occur regardless of the SaveOptionsTiff.UseIFDOffset value. The fast write will take place only when SaveOptionsTiff.IFDOffset is set to non-zero and the SaveOptionsTiff.UseIFDOffset is set to true.

No other operation with the TIFF file should be done during the looping of saving the pages with a fast TIFF write. It would be detrimental to call either the ImageX.ReadAllMetaData, ImageX.SaveAllMetaData, ImageX.CompactFile, ImageX.DeletePage, or ImageX.InsertPage methods in the middle of doing a fast TIFF write as they would definitely affect the IFD offsets in the file.
See Also
Undo a Processing Action
Save Image to Bitmap or DIB
Cancel
Save Image to Stream


Save Image to Stream

Save Image to Stream
ImagXpress 13 for .NET - User Guide > How To > Save an Image > Save Image to Stream

Prior to saving an image, set the SaveOptions to provide specific instructions for saving the image. If no save options are specified, ImagXpress® uses default values when saving the image.

Save to Stream

To save an image to a memory or file stream, call ImageX.SaveStream. The ImageStatusEvent and ProgressEvent events are raised to provide feedback on the status of the saving process.

To save to a BLOB (Binary Large Object), use the ImageX.SaveStream method.
To save a file to an Internet stream, use the ImageX.Save method, specifying the full Internet path and file name, NOT the SaveStream method.

To save an ImageX image to stream:

  1. Create a stream object, derived from the System.IO.Stream
  2. Call the ImageX.SaveStream method.
C# Example
Copy Code
// This code demonstrates saving an image to a stream

using System.IO;
using Accusoft.ImagXpressSdk;
using (MemoryStream stream = new MemoryStream())
{
// Initialize the ImagXpress workspace component
using (ImagXpress imagXpress1 = new ImagXpress())
{
using (ImageX image = ImageX.FromFile(imagXpress1, "C:\\images\\somefile.tif"))
{
//Set up the SaveOptions
SaveOptions saveOptions = new SaveOptions();
saveOptions.Format = ImageXFormat.Tiff;
saveOptions.Tiff.Compression = Compression.Group4;
image.SaveStream(stream, saveOptions);
}
}

See Also
Undo a Processing Action
Save Image to File
Save Image to Bitmap or DIB
Cancel


Save Image to Bitmap or DIB

Save Image to Bitmap or DIB
ImagXpress 13 for .NET - User Guide > How To > Save an Image > Save Image to Bitmap or DIB

Images can be saved from ImagXpress® to a bitmap or DIB as follows:

  • Call the ImageX.ToBitmap method to save to a bitmap.
  • Call the ImageX.ToHbitmap method to save to a bitmap handle.
  • Call the ImageX.ToHdib method to transfer ownership of a DIB handle.

When calling these methods, you must specify whether the ImageX object retains ownership of the image or releases it.

  • If the release parameter is set to True, the image is deleted from the ImageX object. The ImageX object remains, but is empty.
  • If the release parameter is set to False, then the ImageX object continues to contain the image. A copy of the image is made and returned by the methods above.
See Also
Undo a Processing Action
Save Image to File
Cancel
Save Image to Stream


Free the Control's Resources

Free the Control's Resources
ImagXpress 13 for .NET - User Guide > How To > Free the Control's Resources

Because ImagXpress® encapsulates unmanaged resources, the Dispose method must be called for each instance of each component, to allow the release of all resources. A recommended approach is to dispose these objects when their container is disposed. To do this, call the Dispose method from the container. Since some of the components within the ImagXpress Product Family have dependencies on the ImagXpress component, you should dispose the ImagXpress objects last.

C# Example
Copy Code
// This code demonstrates that in all .NET Windows Forms applications, you will find a generated call to Dispose, which can be modified as follows:
protected override void Dispose (bool disposing)
{
if (disposing)
{
if (components != NULL)
{
components.Dispose();
}
// added for ImagXpress,
// dispose the ImagXpress control last.
// The application developer is not required to call Dispose at this location. The Developer can make the call to clean up these resources at any time during the container's lifetime.
PrintPRO.Dispose();
TwainPRO.Dispose();
NotateXpress.Dispose();
ThumbnailXpress.Dispose();
ImageXView.Dispose();
Processor.Dispose();
ImagXpress.Dispose();
}
base.Disposing(disposing);
}

In addition, any objects that are created dynamically at run time (e.g. ImageX), must call their Dispose method to allow resources to be released when the object is no longer needed.

C# Example
Copy Code
// When ColorSeparation is called with handles specified for each of the color planes,
// call ImageX.DisposeHbitmap to release the resources associated with the handles after use.
// When the ImageX object is not longer needed, Dispose it.
See Also
Print an Image
Create a Viewer
Annotate an Image
Draw on the Image
ImageX Class
Dispose Method


Debug

Debug
ImagXpress 13 for .NET - User Guide > How To > Debug

To generate a debug log file, set Debug to true. The log file is kept at the location specified by DebugLogFile. Set the DebugErrorLevel to Development or Detailed to indicate the level of detail logged.

To view Error Codes, go to Enumerations.Result.

See Also
Getting Support
Debug Property
DebugLogFile Property
DebugErrorLevel Property
Result Enumeration


ImagXpress 13 for .NET - API Reference

ImagXpress 13 for .NET - API Reference

This API Reference provides detailed information about all ImagXpress public API members.


Accusoft.ImagXpress13.Net Assembly

Accusoft.ImagXpress13.Net Assembly
Namespaces
Namespace | Description
Accusoft.ImagXpressSdk |


Accusoft.ImagXpressSdk Namespace

Accusoft.ImagXpressSdk Namespace
Inheritance Hierarchy
Classes
Class | Description
Class | AutoResizeChangedEventArgs | This class implements event data for AutoResizeChanged events.
Class | CadLayer | This class contains information about a layer in a CAD file.
Class | CadLayout | This class describes one Layout within a given CAD Data File.
Class | FlickEventArgs | This class implements event data for TouchFlick events.
Class | IcmException | This class implements exceptions for the Icm objects.
Class | ImageCalsCollection | This class implements a collection of ImageCalsTag objects.
Class | ImageCalsTag | This class implements methods and properties for the Cals tag data.
Class | ImageModcaCollection | Initializes a new instance of the ImageModcaTag class.
Class | ImageModcaTag | This class holds Modca tags.
Class | ImageReduce | Re-save compressed image formats without the resource overhead of presenting its decompressed pixel data as a DIB.
Class | ImageStatusEventArgs | This class contains object data for Image Status events.
Class | ImageX | This class implements basic operating functionality for the ImagXpress component.
Class | ImageXData | Implements image information pertaining to the current image.
Class | ImageXException | This class implements exceptions for the ImageX objects.
Class | ImageXIptcCollection | This class implements a collection of ImageXIptcData objects.
Class | ImageXIptcData | A class for IPTC meta-data information.
Class | ImageXTag | This class holds TIFF and EXIF tags.
Class | ImageXTagCollection | A collection of ImageXTag objects.
Class | ImageXView | Implements the properties, methods and events for the viewer control.
Class | ImageXViewException | This class implements exceptions for the ImageXView objects.
Class | ImagXpress | Implements methods and properties for the ImagXpress component. This is a workspace component to the other controls, components and classes for handling such items as licensing, debug logging, and and progress and status events for the ImageX objects.
Class | ImagXpressDefaultContextMenu | This class implements methods and properties for the ImageXView default context menu.
Class | ImagXpressException | This class implements handling errors and exceptions for ImagXpress objects.
Class | InternetException | This class implements exceptions for the Internet objects.
Class | InternetOptions | This class implements functionality for Internet options.
Class | Licensing | The Licensing class determines the license edition and behavior, and unlock methods.
Class | LoadOptions | The LoadOptions class includes various formats and image types to load into ImagXpress.
Class | LoadOptionsCad | This class contains the CAD data objects options when loading CAD files.
Class | LoadOptionsCameraRaw | This class implements load options for the CameraRaw images.
Class | LoadOptionsJbig2 | This class implements load options for the Jbig2 file format.
Class | LoadOptionsJpeg | This class implements load options for the JPEG file format.
Class | LoadOptionsJpegXR | This class implements load options for the JPEG-XR format.
Class | LoadOptionsMetafile | This class implements load options for metafiles.
Class | LoadOptionsPdf | This class implements load options for PDF files.
Class | LoadOptionsPic | This class implements the load options for the Pegasus Imaging Corporation file format.
Class | LoadOptionsRaw | This class specifies image information that cannot be detected when loading a RAW image format.
Class | LoadOptionsTiff | This class implements the load options for TIFF files.
Class | LookupTable | A class for specifying a lookup table to be used with the Medical class.
Class | Medical | The Medical class is an encapsulation of the properties needed to do a DICOM (Digital Imaging and Communications in Medicine) grayscale transformation.
Class | PaintImageEventArgs | Provides data for the ImageXView.PaintImage event.
Class | PanGestureOccurredEventArgs | This class implements event data for TouchPan events.
Class | PanGestureOccurringEventArgs | This class implements event data for PanGestureOccurring events.
Class | PressAndHoldEventArgs | This class implements event data for PressAndHold events.
Class | PressAndTapEventArgs | This class implements event data for PressAndTap events.
Class | PrintImageEventArgs | Provides data for the ImageXView.PaintImage Event.
Class | Processor | This class implements methods and properties to enhance, edit and modify images.
Class | ProcessorException | This class implements exceptions for the Processor objects.
Class | ProgressEventArgs | This class implements methods and properties for the progress events.
Class | RedeyeCollection | Summary description for RedeyeCollection.
Class | RedeyeRectangle | Summary description for RedeyeRectangle. AutoRemoveRedeye generates rectangle areas of objects thought to be redeyes and have been corrected (red removed). Because some objects looking like redeyes but are not are identified and corrected (false positives) and some redeyes not looking like what they are and are not corrected (missed negatives), a list of rectangles is automatically generated. These rectangles are available to the user (application) for analysis and corrective action. The user can redo the correction by editing the rectangle list, reload the picture and apply the AutoRemoveRedeye method again but indicating the method to use the existing list. Each RedeyeRectangle has five members describing the area of the redeye found and the likelyhood that the object was correctly identified. The X and Y position indicate the top left corner of the rectangle and The Width and Height denote the rectangle dimensions. The Confidence parameter indicates how likely the area identified is indeed a redeye object.
Class | ResizedEventArgs | This class implements event data for Resized events.
Class | Resolution | This class contains properties and methods for the resolution of an image.
Class | RotationGestureOccurredEventArgs | This class implements event data for the RotationGestureOccurred events.
Class | RotationGestureOccurringEventArgs | This class implements event data for RotationGestureOccurring events.
Class | Rubberband | This class implements methods and properties for part or all of an image to be selected within a dashed rectangular area.
Class | SaveOptions | This class implements file writing of image formats.
Class | SaveOptionsAnnotations | This class implements options required to save annotations with the image.
Class | SaveOptionsBmp | This class implements the SaveOptions for BMP files.
Class | SaveOptionsDcx | This class implements the SaveOptions for the DCX file format.
Class | SaveOptionsExif | This class implements the SaveOptions for the EXIF file format.
Class | SaveOptionsGif | This class implements the SaveOptions for the GIF file format.
Class | SaveOptionsIcon | This class implements SaveOptions for the Icon file format.
Class | SaveOptionsJbig2 | This class implements SaveOptions for the Jbig2 file format.
Class | SaveOptionsJls | This class implements SaveOptions for the JLS file format.
Class | SaveOptionsJp2 | This class implements SaveOptions for the JP2 file format.
Class | SaveOptionsJpeg | This class implements SaveOptions for the JPEG file format.
Class | SaveOptionsJpegXR | This class implements SaveOptions for the JPEG-XR file format.
Class | SaveOptionsLjp | This class implements the SaveOptions for the LJP file format.
Class | SaveOptionsModca | This class implements the SaveOptions for the Modca file format.
Class | SaveOptionsPdf | This class implements the SaveOptions for PDF files.
Class | SaveOptionsPic | This class implements SaveOptions for the PIC (Pegasus Imaging Corporation) file format.
Class | SaveOptionsPng | This class implements SaveOptions for the PNG file format.
Class | SaveOptionsTiff | This class implements the SaveOptions for TIFF formats.
Class | SaveOptionsWsq | Implements the SaveOptions for the WSQ file format.
Class | ScrollbarVisibleChangedEventArgs | This class implements event data for ScrollbarVisibleChanged events.
Class | ScrollEventArgs | This class implements event data for scroll events.
Class | Sprite | This class implements a temporary image area.
Class | Toolbar | This class implements toolbar functionality.
Class | ToolbarCloseEventArgs | This class contains information associated with a ToolbarCloseEvent.
Class | ToolbarContextMenu | This class implements the context menu associated with the ImagXpress toolbar.
Class | ToolbarContextMenuEventArgs | This class implements the event arguments for when a ToolbarContextMenuSelect event is fired.
Class | ToolbarEventArgs | This class implements event data for toolbar events.
Class | ToolbarOpenEventArgs | This class implements information associated with a ToolbarOpenEvent.
Class | ToolEventArgs | This class implements event data for tool events.
Class | Touch | This class implements methods and properties for Windows Touch support.
Class | TwoFingerTapEventArgs | This class implements event data for TwoFingerTap events.
Class | WorkerImports | Summary description for WorkerImports.
Class | ZoomFactorChangedEventArgs | This class implements event data for ZoomFactorChanged events.
Class | ZoomGestureOccurredEventArgs | This class implements event data for ZoomGestureOccurred events.
Class | ZoomGestureOccurringEventArgs | This class implements event data for ZoomGestureOccurring events.
Delegates
 | Delegate | Description
Delegate | ImageXView.AutoResizeChangedEventHandler | A handler for the auto resize changed event.
Delegate | ImageXView.FlickEventHandler | A handler for the flick event.
Delegate | ImageXView.PaintImageEventHandler | A handler for the paint event.
Delegate | ImageXView.PanGestureOccurredEventHandler | A handler for the pan gesture occurred event.
Delegate | ImageXView.PanGestureOccurringEventHandler | A handler for the pan gesture occurring event.
Delegate | ImageXView.PressAndHoldEventHandler | A handler for the press and hold event.
Delegate | ImageXView.PressAndTapEventHandler | A handler for the press and tap event.
Delegate | ImageXView.PrintImageEventHandler | Handler for the print image event.
Delegate | ImageXView.ResizedEventHandler | A handler for the resized event.
Delegate | ImageXView.RotationGestureOccurredEventHandler | A handler for the rotation gesture occurred event.
Delegate | ImageXView.RotationGestureOccurringEventHandler | A handler for the rotation gesture occurring event.
Delegate | ImageXView.ScrollbarVisibleChangedEventHandler | Fires when the scrollbar visible changed event occurs.
Delegate | ImageXView.ScrollEventHandler | A handler for the scroll event.
Delegate | ImageXView.ToolbarCloseEventHandler | Handler for the toolbar close event.
Delegate | ImageXView.ToolbarContextMenuSelectEventHandler | A handler for the toolbar context menu select event.
Delegate | ImageXView.ToolbarEventHandler | Handler for the toolbar event.
Delegate | ImageXView.ToolbarOpenEventHandler | Handler for the toolbar open event.
Delegate | ImageXView.ToolEventHandler | Handler for the tool event.
Delegate | ImageXView.TwoFingerTapEventHandler | A handler for the two finger tap event.
Delegate | ImageXView.ZoomFactorChangedEventHandler | A handler for the zoom factor event.
Delegate | ImageXView.ZoomGestureOccurredEventHandler | A handler for the zoom gesture occurred event.
Delegate | ImageXView.ZoomGestureOccurringEventHandler | A handler for the zoom gesture occurring event.
Delegate | ImagXpress.ImageStatusEventHandler | Fires when there are image status events.
Delegate | ImagXpress.ProgressEventHandler | Fires when there is a progress event.
Delegate | Processor.ProgressEventHandler | A handler for the progress events.
Enumerations
 | Enumeration | Description
Enumeration | AdjustType | Option values used to indicate the adjustment type.
Enumeration | AlignHorizontal | Option values indicating the horizontal alignment setting.
Enumeration | AlignVertical | Option values indicating the vertical alignment setting.
Enumeration | AreaRegionOption | Option values which determine the area and region settings.
Enumeration | AutoResizeType | Option values for use with the ImageXView.AutoResize property.
Enumeration | BinarizeBlur | Option values used to determine what type of blur functionality to use during the Processor.Binarize method.
Enumeration | BinarizeMode | Option values used to determine what Processor.Binarize functionality to use.
Enumeration | BorderType | Option values for use with the ImageXView.BorderType property.
Enumeration | ButtonStyle | Option values to indicate button display style.
Enumeration | ByteOrder | Option values used to specify the TIFF file byte order.
Enumeration | CadFileType | Option values which determine the CAD file type.
Enumeration | CadUnit | Option values which determine the CAD (Computer Aided Design) units of measure.
Enumeration | CadVersion | Option values which determine the CAD version.
Enumeration | ClipboardFormat | Option values of possible formats to use with the clipboard.
Enumeration | ColorSpace | Option values which designate the color space.
Enumeration | Compression | Option values which determine the image compression type.
Enumeration | ContrastMethod | Option values used to determine which Processor.ContrastMethod property value to use.
Enumeration | CropType | Option values which indicate what type of crop to perform.
Enumeration | DebugErrorLevel | Option value which determine the error level of items to place into the debug log.
Enumeration | DefectType | Option values to indicate the defect type to process.
Enumeration | DeskewType | Option values to indicate deskew settings for image correction.
Enumeration | DisplayMode | Option values indicating the maximum color depth used to render an image.
Enumeration | DitherType | Option values used to determine the dither type to perform.
Enumeration | EnhancementDirection | Option values used to determine enhancement direction.
Enumeration | EvaluationMode | Option values that indicate ImagXpress behavior when installed on a development machine when in evaluation mode.
Enumeration | FireGestureOccurringEvent | Option values which determine the gestures events firing mode.
Enumeration | FlickDirection | Option values used to determine the direction of the flick TouchFlick event.
Enumeration | FtpMode | Option values used for FTP (File Transfer Protocol) mode.
Enumeration | GifType | Option values for GIF file format.
Enumeration | GrayMode | Option values to indicate the type of Gray Mode to utilize.
Enumeration | ImageStatus | Option values which specify the status of an image.
Enumeration | ImageXFormat | Option values which specify the file format.
Enumeration | ImageXPixelFormat | Option values which determine the pixel formats currently being used.
Enumeration | ImageXViewBorderStyle | Option values for use with the ImageXView.BorderStyle property.
Enumeration | Jbig2EncodeModeCompression | Option values used to specify the encoding mode to use when creating the Jbig2 file.
Enumeration | Jbig2FileOrganization | Option values used to specify the file organization of the Jbig2 bit stream.
Enumeration | JoinType | Option values used to determine what type of Processor.ColorJoin method to use.
Enumeration | Jp2Type | Option values used to determine JP2 file types.
Enumeration | JpegXRPostProcessFilter | Open option filtering on JPEG-XR files, the strength specifies how aggressively the filtering is applied.
Enumeration | JpegXRSubSampling | Option values for subsampling type for a Jpeg-XR file format.
Enumeration | LicenseStatus | Options for the status of the license.
Enumeration | LjpMethod | Lossless Jpeg Compression Method
Enumeration | LjpType | Option values used to specify the type of compression used for saving a lossless JPEG file.
Enumeration | LoadMode | Option values used to indicate the LoadOptions.LoadMode property.
Enumeration | MedicalPhotometricInterpretation | Option values used to determines whether a zero in the image data is black or white.
Enumeration | MergeSize | An enumeration used to determine the area/size the merge image is to be.
Enumeration | MergeStyle | Option values used to specify the style of the merge.
Enumeration | MouseWheelAction | Option values used in determining what type of mouse wheel action to perform.
Enumeration | MouseWheelAttribute | Option values used to manipulate the mouse wheel.
Enumeration | Operation | Option values used in determining what type of image operation to perform.
Enumeration | PaletteType | Option values used to set the palette type of the Processor.ColorDepth method.
Enumeration | ParabolicType | Option values used to determine the type of parabolic transform to perform.
Enumeration | PerspectiveType | Option values used to determine the type of perspective filter to apply.
Enumeration | PhotometricInterpretation | The PhotometricInterpretation of a TIFF image.
Enumeration | PngFilter | The filters available for PNG compression.
Enumeration | PrintType | Option values to determine the type of the print.
Enumeration | ProgressionOrder | Option values used to determine the progression order of a JPEG 2000 file being saved.
Enumeration | RedeyeGlare | Option values used in the Processor.RemoveRedeye method.
Enumeration | RedeyePrecision | Option values used as parameters in the Processor.RemoveRedeye method.
Enumeration | RedeyeShade | Option values used as parameters in the Processor.RemoveRedeye method.
Enumeration | RefreshMode | Option values which determine the refresh mode for the ImageXView control.
Enumeration | RegionType | Option values that determine the type of shape a region takes.
Enumeration | RenderIntent | Option values for rendering colors by relative scale of spatial distnces, saturation, colors closest to inside values and distance to white point.
Enumeration | ResizeType | Option values used to determine what type of resize method to perform.
Enumeration | ResolutionUnits | Option values which determine the unit of measure for image reslution.
Enumeration | Result | Option values returned from image processing methods.
Enumeration | RippleDirection | Option values used with the Processor.Ripple method.
Enumeration | RotateAngle | Option values to determine what type of rotation, mirror, or image flipping functionality to invoke.
Enumeration | SeparationType | Option values used to determine what type of Processor.ColorSeparation functionality.
Enumeration | SharpenFilter | Option values used in determining which type of Sharpen Filter to use.
Enumeration | ShearType | Option values used to determine the document shear direction.
Enumeration | SoftenFilter | Option values used in determining which type of Soften Filter to employ.
Enumeration | SubSampling | Option values for subsampling type for a JPEG, TIFF-JPEG or ePIC file format.
Enumeration | TagTypes | Option values which determine the type of TIFF tag.
Enumeration | ThumbnailSize | Option values used to determine the thumbnail size.
Enumeration | Tool | Option values used to determine the tool selected.
Enumeration | ToolAction | Option values used to determine what type of tool event has occurred.
Enumeration | ToolAttribute | Option values used to determine a tool's attribute value.
Enumeration | ToolbarIconSize | Option values which determine the size of icons displayed in the toolbar.
Enumeration | ToolCursor | Option values which determines the tool cursor to change.
Enumeration | TouchMode | Option values which determine the mode of Touch interface.
Enumeration | TransformMode | The transform mode of the JPEG Reduce operation.
Enumeration | TranslateType | Option values used in determing what type of translation to perform.
Enumeration | TransparencyMatch | Option values used to determine the type of TransparencyMatch property to invoke.
Enumeration | TwistRotation | Option values used in evaluating the rotation angle.
Enumeration | UnsharpenFilter | Option values used in determining what type of Processor.Unsharpen method to apply.
Enumeration | WhiteBalanceMethod | Type of white-balancing to apply to the image.
Enumeration | ZoomToFitType | Option values to determine if the image fit is within the ImagXpress viewer control.
Remarks

See Also

Reference

Accusoft.ImagXpress13.Net Assembly


Accusoft.ImagXpressSdk Namespace Inheritance Hierarchy

Accusoft.ImagXpressSdk Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
Accusoft.ImagXpressSdk.CadLayer
Accusoft.ImagXpressSdk.CadLayout
Accusoft.ImagXpressSdk.ImageCalsTag
Accusoft.ImagXpressSdk.ImageModcaTag
Accusoft.ImagXpressSdk.ImageReduce
Accusoft.ImagXpressSdk.ImageXData
Accusoft.ImagXpressSdk.ImageXIptcData
Accusoft.ImagXpressSdk.ImageXTag
Accusoft.ImagXpressSdk.InternetOptions
Accusoft.ImagXpressSdk.Licensing
Accusoft.ImagXpressSdk.LoadOptions
Accusoft.ImagXpressSdk.LoadOptionsCad
Accusoft.ImagXpressSdk.LoadOptionsCameraRaw
Accusoft.ImagXpressSdk.LoadOptionsJbig2
Accusoft.ImagXpressSdk.LoadOptionsJpeg
Accusoft.ImagXpressSdk.LoadOptionsJpegXR
Accusoft.ImagXpressSdk.LoadOptionsMetafile
Accusoft.ImagXpressSdk.LoadOptionsPdf
Accusoft.ImagXpressSdk.LoadOptionsPic
Accusoft.ImagXpressSdk.LoadOptionsRaw
Accusoft.ImagXpressSdk.LoadOptionsTiff
Accusoft.ImagXpressSdk.LookupTable
Accusoft.ImagXpressSdk.Medical
Accusoft.ImagXpressSdk.RedeyeRectangle
Accusoft.ImagXpressSdk.Resolution
Accusoft.ImagXpressSdk.Rubberband
Accusoft.ImagXpressSdk.SaveOptions
Accusoft.ImagXpressSdk.SaveOptionsAnnotations
Accusoft.ImagXpressSdk.SaveOptionsBmp
Accusoft.ImagXpressSdk.SaveOptionsDcx
Accusoft.ImagXpressSdk.SaveOptionsExif
Accusoft.ImagXpressSdk.SaveOptionsGif
Accusoft.ImagXpressSdk.SaveOptionsIcon
Accusoft.ImagXpressSdk.SaveOptionsJbig2
Accusoft.ImagXpressSdk.SaveOptionsJls
Accusoft.ImagXpressSdk.SaveOptionsJp2
Accusoft.ImagXpressSdk.SaveOptionsJpeg
Accusoft.ImagXpressSdk.SaveOptionsJpegXR
Accusoft.ImagXpressSdk.SaveOptionsLjp
Accusoft.ImagXpressSdk.SaveOptionsModca
Accusoft.ImagXpressSdk.SaveOptionsPdf
Accusoft.ImagXpressSdk.SaveOptionsPic
Accusoft.ImagXpressSdk.SaveOptionsPng
Accusoft.ImagXpressSdk.SaveOptionsTiff
Accusoft.ImagXpressSdk.SaveOptionsWsq
Accusoft.ImagXpressSdk.Sprite
Accusoft.ImagXpressSdk.Toolbar
Accusoft.ImagXpressSdk.ToolbarContextMenu
Accusoft.ImagXpressSdk.Touch
Accusoft.ImagXpressSdk.WorkerImports
System.Collections.CollectionBase
Accusoft.ImagXpressSdk.ImageXTagCollection
Accusoft.ImagXpressSdk.RedeyeCollection
System.Collections.ObjectModel.Collection<T>
Accusoft.ImagXpressSdk.ImageCalsCollection
Accusoft.ImagXpressSdk.ImageModcaCollection
Accusoft.ImagXpressSdk.ImageXIptcCollection
System.EventArgs
Accusoft.ImagXpressSdk.AutoResizeChangedEventArgs
Accusoft.ImagXpressSdk.FlickEventArgs
Accusoft.ImagXpressSdk.ImageStatusEventArgs
Accusoft.ImagXpressSdk.PaintImageEventArgs
Accusoft.ImagXpressSdk.PanGestureOccurredEventArgs
Accusoft.ImagXpressSdk.PanGestureOccurringEventArgs
Accusoft.ImagXpressSdk.PressAndHoldEventArgs
Accusoft.ImagXpressSdk.PressAndTapEventArgs
Accusoft.ImagXpressSdk.PrintImageEventArgs
Accusoft.ImagXpressSdk.ProgressEventArgs
Accusoft.ImagXpressSdk.ResizedEventArgs
Accusoft.ImagXpressSdk.RotationGestureOccurredEventArgs
Accusoft.ImagXpressSdk.RotationGestureOccurringEventArgs
Accusoft.ImagXpressSdk.ScrollbarVisibleChangedEventArgs
Accusoft.ImagXpressSdk.ScrollEventArgs
Accusoft.ImagXpressSdk.ToolbarCloseEventArgs
Accusoft.ImagXpressSdk.ToolbarContextMenuEventArgs
Accusoft.ImagXpressSdk.ToolbarEventArgs
Accusoft.ImagXpressSdk.ToolbarOpenEventArgs
Accusoft.ImagXpressSdk.ToolEventArgs
Accusoft.ImagXpressSdk.TwoFingerTapEventArgs
Accusoft.ImagXpressSdk.ZoomFactorChangedEventArgs
Accusoft.ImagXpressSdk.ZoomGestureOccurredEventArgs
Accusoft.ImagXpressSdk.ZoomGestureOccurringEventArgs
System.Exception
Accusoft.ImagXpressSdk.ImagXpressException
Accusoft.ImagXpressSdk.IcmException
Accusoft.ImagXpressSdk.ImageXException
Accusoft.ImagXpressSdk.ImageXViewException
Accusoft.ImagXpressSdk.InternetException
Accusoft.ImagXpressSdk.ProcessorException
System.MarshalByRefObject
Accusoft.ImagXpressSdk.ImageX
System.ComponentModel.Component
Accusoft.ImagXpressSdk.ImagXpress
Accusoft.ImagXpressSdk.Processor
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
Accusoft.ImagXpressSdk.ImageXView
System.Windows.Forms.Menu
System.Windows.Forms.ContextMenu
Accusoft.ImagXpressSdk.ImagXpressDefaultContextMenu
See Also

Reference

Accusoft.ImagXpress13.Net Assembly


AutoResizeChangedEventArgs Class

AutoResizeChangedEventArgs Class
Members

Accusoft.ImagXpressSdk Namespace : AutoResizeChangedEventArgs Class
This class implements event data for AutoResizeChanged events.
Object Model
AutoResizeChangedEventArgs Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class AutoResizeChangedEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As AutoResizeChangedEventArgs
public class AutoResizeChangedEventArgs : System.EventArgs
public __gc class AutoResizeChangedEventArgs : public System.EventArgs
public ref class AutoResizeChangedEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
Accusoft.ImagXpressSdk.AutoResizeChangedEventArgs

See Also

Reference

AutoResizeChangedEventArgs Members
Accusoft.ImagXpressSdk Namespace


AutoResizeChangedEventArgs Class Members

AutoResizeChangedEventArgs Class Members
Properties

Accusoft.ImagXpressSdk Namespace : AutoResizeChangedEventArgs Class

The following tables list the members exposed by AutoResizeChangedEventArgs.

Public Constructors
 | Name | Description
Public Constructor | AutoResizeChangedEventArgs Constructor | The main constructor which initializes a new instance of the AutoResizeChangedEventArgs class.
Top
Public Properties
 | Name | Description
Public Property | NewValue | Gets the new value for the AutoResize property.
Public Property | OldValue | Gets the old value for the AutoResize property.
Top
See Also

Reference

AutoResizeChangedEventArgs Class
Accusoft.ImagXpressSdk Namespace


AutoResizeChangedEventArgs Constructor

AutoResizeChangedEventArgs Constructor

Accusoft.ImagXpressSdk Namespace > AutoResizeChangedEventArgs Class : AutoResizeChangedEventArgs Constructor
The main constructor which initializes a new instance of the AutoResizeChangedEventArgs class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New AutoResizeChangedEventArgs()
public AutoResizeChangedEventArgs()
public: AutoResizeChangedEventArgs();
public:
AutoResizeChangedEventArgs();
See Also

Reference

AutoResizeChangedEventArgs Class
AutoResizeChangedEventArgs Members


AutoResizeChangedEventArgs Class Properties

AutoResizeChangedEventArgs Class Properties

Accusoft.ImagXpressSdk Namespace : AutoResizeChangedEventArgs Class

For a list of all members of this type, see AutoResizeChangedEventArgs members.

Public Properties
 | Name | Description
Public Property | NewValue | Gets the new value for the AutoResize property.
Public Property | OldValue | Gets the old value for the AutoResize property.
Top
See Also

Reference

AutoResizeChangedEventArgs Class
Accusoft.ImagXpressSdk Namespace


AutoResizeChangedEventArgs Constructor

AutoResizeChangedEventArgs Constructor

Accusoft.ImagXpressSdk Namespace > AutoResizeChangedEventArgs Class : AutoResizeChangedEventArgs Constructor
Overload List
Overload | Description
AutoResizeChangedEventArgs Constructor | The main constructor which initializes a new instance of the AutoResizeChangedEventArgs class.
See Also

Reference

AutoResizeChangedEventArgs Class
AutoResizeChangedEventArgs Members


NewValue Property (AutoResizeChangedEventArgs)

NewValue Property (AutoResizeChangedEventArgs)

Accusoft.ImagXpressSdk Namespace > AutoResizeChangedEventArgs Class : NewValue Property
Gets the new value for the AutoResize property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property NewValue As AutoResizeType
'Usage

Dim instance As AutoResizeChangedEventArgs
Dim value As AutoResizeType

value = instance.NewValue
public AutoResizeType NewValue {get;}
public: __property AutoResizeType get_NewValue();
public:
property AutoResizeType NewValue {
   AutoResizeType get();
}

Property Value

An AutoResizeType enumeration value.
See Also

Reference

AutoResizeChangedEventArgs Class
AutoResizeChangedEventArgs Members


OldValue Property (AutoResizeChangedEventArgs)

OldValue Property (AutoResizeChangedEventArgs)

Accusoft.ImagXpressSdk Namespace > AutoResizeChangedEventArgs Class : OldValue Property
Gets the old value for the AutoResize property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property OldValue As AutoResizeType
'Usage

Dim instance As AutoResizeChangedEventArgs
Dim value As AutoResizeType

value = instance.OldValue
public AutoResizeType OldValue {get;}
public: __property AutoResizeType get_OldValue();
public:
property AutoResizeType OldValue {
   AutoResizeType get();
}

Property Value

An AutoResizeType enumeration value.
See Also

Reference

AutoResizeChangedEventArgs Class
AutoResizeChangedEventArgs Members


CadLayer Class

CadLayer Class
Members

Accusoft.ImagXpressSdk Namespace : CadLayer Class
This class contains information about a layer in a CAD file.
Object Model
CadLayer Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class CadLayer
'Usage

Dim instance As CadLayer
public class CadLayer
public __gc class CadLayer
public ref class CadLayer
Remarks

Note: Available in Professional edition.

Inheritance Hierarchy

System.Object
Accusoft.ImagXpressSdk.CadLayer

See Also

Reference

CadLayer Members
Accusoft.ImagXpressSdk Namespace


CadLayer Class Members

CadLayer Class Members
Properties Methods

Accusoft.ImagXpressSdk Namespace : CadLayer Class

The following tables list the members exposed by CadLayer.

Public Properties
 | Name | Description
Public Property | Frozen | Gets and indicator if the CAD File Layer is frozen by the author.
Public Property | InUse | Gets an indicator if the CAD file layer is in use at the time it was saved.
Public Property | LayerDescription | Gets the CAD layer description.
Public Property | LayerName | Gets the CAD layer name.
Public Property | LayerNumber | Gets and sets this layer's level.
Public Property | LayerOn | Gets and sets an indicator if the CAD layer is on thus rendered (viewable).
Public Property | Locked | Gets an indicator if the author has left the CAD layer locked.
Public Property | Plottable | Gets an indicator if the CAD layer is plottable.
Top
Public Methods
 | Name | Description
Public Method | Dispose | Releases all resources used by this object.
Top
See Also

Reference

CadLayer Class
Accusoft.ImagXpressSdk Namespace


CadLayer Class Methods

CadLayer Class Methods

Accusoft.ImagXpressSdk Namespace : CadLayer Class

For a list of all members of this type, see CadLayer members.

Public Methods
 | Name | Description
Public Method | Dispose | Releases all resources used by this object.
Top
See Also

Reference

CadLayer Class
Accusoft.ImagXpressSdk Namespace


Dispose Method (CadLayer)

Dispose Method (CadLayer)

Accusoft.ImagXpressSdk Namespace > CadLayer Class : Dispose Method
Releases all resources used by this object.
Overload List
Overload | Description
Dispose | Releases all resources used by this object.
See Also

Reference

CadLayer Class
CadLayer Members


Dispose() Method

Dispose() Method

Accusoft.ImagXpressSdk Namespace > CadLayer Class : Dispose() Method
Releases all resources used by this object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Dispose()
'Usage

Dim instance As CadLayer

instance.Dispose()
public void Dispose()
public: void Dispose();
public:
void Dispose();
See Also

Reference

CadLayer Class
CadLayer Members


CadLayer Class Properties

CadLayer Class Properties

Accusoft.ImagXpressSdk Namespace : CadLayer Class

For a list of all members of this type, see CadLayer members.

Public Properties
 | Name | Description
Public Property | Frozen | Gets and indicator if the CAD File Layer is frozen by the author.
Public Property | InUse | Gets an indicator if the CAD file layer is in use at the time it was saved.
Public Property | LayerDescription | Gets the CAD layer description.
Public Property | LayerName | Gets the CAD layer name.
Public Property | LayerNumber | Gets and sets this layer's level.
Public Property | LayerOn | Gets and sets an indicator if the CAD layer is on thus rendered (viewable).
Public Property | Locked | Gets an indicator if the author has left the CAD layer locked.
Public Property | Plottable | Gets an indicator if the CAD layer is plottable.
Top
See Also

Reference

CadLayer Class
Accusoft.ImagXpressSdk Namespace


Frozen Property

Frozen Property

Accusoft.ImagXpressSdk Namespace > CadLayer Class : Frozen Property
Gets and indicator if the CAD File Layer is frozen by the author.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Frozen As Boolean
'Usage

Dim instance As CadLayer
Dim value As Boolean

value = instance.Frozen
public bool Frozen {get;}
public: __property bool get_Frozen();
public:
property bool Frozen {
   bool get();
}

Property Value

A boolean value which is true if the CAD layer is frozen. Otherwise, false is returned.
Remarks

The default value is false.

Note: Available in Professional edition.

See Also

Reference

CadLayer Class
CadLayer Members


InUse Property

InUse Property

Accusoft.ImagXpressSdk Namespace > CadLayer Class : InUse Property
Gets an indicator if the CAD file layer is in use at the time it was saved.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property InUse As Boolean
'Usage

Dim instance As CadLayer
Dim value As Boolean

value = instance.InUse
public bool InUse {get;}
public: __property bool get_InUse();
public:
property bool InUse {
   bool get();
}

Property Value

A boolean value which is true when the CAD layer is in use. Otherwise, false is returned.
Remarks

The default value is false.

Note: Available in Professional edition.

See Also

Reference

CadLayer Class
CadLayer Members


LayerDescription Property

LayerDescription Property

Accusoft.ImagXpressSdk Namespace > CadLayer Class : LayerDescription Property
Gets the CAD layer description.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property LayerDescription As String
'Usage

Dim instance As CadLayer
Dim value As String

value = instance.LayerDescription
public string LayerDescription {get;}
public: __property string* get_LayerDescription();
public:
property String^ LayerDescription {
   String^ get();
}

Property Value

A string value which represents the CAD layer description.
Remarks

The default value is an empty string "".

Note: Available in Professional edition.

See Also

Reference

CadLayer Class
CadLayer Members


LayerName Property

LayerName Property

Accusoft.ImagXpressSdk Namespace > CadLayer Class : LayerName Property
Gets the CAD layer name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property LayerName As String
'Usage

Dim instance As CadLayer
Dim value As String

value = instance.LayerName
public string LayerName {get;}
public: __property string* get_LayerName();
public:
property String^ LayerName {
   String^ get();
}

Property Value

A string value which represents the name of the CAD layer.
Remarks

The default value is an empty string "".

Note: Available in Professional edition.

See Also

Reference

CadLayer Class
CadLayer Members


LayerNumber Property

LayerNumber Property

Accusoft.ImagXpressSdk Namespace > CadLayer Class : LayerNumber Property
Gets and sets this layer's level.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property LayerNumber As Integer
'Usage

Dim instance As CadLayer
Dim value As Integer

value = instance.LayerNumber
public int LayerNumber {get;}
public: __property int get_LayerNumber();
public:
property int LayerNumber {
   int get();
}

Property Value

An integer value which represents this layer's level.
Remarks

The default value is 0.

Note: Available in Professional edition.

See Also

Reference

CadLayer Class
CadLayer Members


LayerOn Property

LayerOn Property

Accusoft.ImagXpressSdk Namespace > CadLayer Class : LayerOn Property
Gets and sets an indicator if the CAD layer is on thus rendered (viewable).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LayerOn As Boolean
'Usage

Dim instance As CadLayer
Dim value As Boolean

instance.LayerOn = value

value = instance.LayerOn
public bool LayerOn {get; set;}
public: __property bool get_LayerOn();
public: __property void set_LayerOn(
   bool value
);
public:
property bool LayerOn {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true if the CAD layer is on. Otherwise, false is used.
Remarks

The default value is false.

Note: Available in Professional edition.

See Also

Reference

CadLayer Class
CadLayer Members


Locked Property

Locked Property

Accusoft.ImagXpressSdk Namespace > CadLayer Class : Locked Property
Gets an indicator if the author has left the CAD layer locked.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Locked As Boolean
'Usage

Dim instance As CadLayer
Dim value As Boolean

value = instance.Locked
public bool Locked {get;}
public: __property bool get_Locked();
public:
property bool Locked {
   bool get();
}

Property Value

A boolean value which is true if the CAD layer is locked. Otherwise, false is returned.
Remarks

The default value is false.

Note: Available in Professional edition.

See Also

Reference

CadLayer Class
CadLayer Members


Plottable Property

Plottable Property

Accusoft.ImagXpressSdk Namespace > CadLayer Class : Plottable Property
Gets an indicator if the CAD layer is plottable.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Plottable As Boolean
'Usage

Dim instance As CadLayer
Dim value As Boolean

value = instance.Plottable
public bool Plottable {get;}
public: __property bool get_Plottable();
public:
property bool Plottable {
   bool get();
}

Property Value

A boolean value which is true if the CAD layer is plottable. Otherwise, false is returned.
Remarks

The default value is false.

Note: Available in Professional edition.

See Also

Reference

CadLayer Class
CadLayer Members


CadLayout Class

CadLayout Class
Members

Accusoft.ImagXpressSdk Namespace : CadLayout Class
This class describes one Layout within a given CAD Data File.
Object Model
CadLayout Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class CadLayout
'Usage

Dim instance As CadLayout
public class CadLayout
public __gc class CadLayout
public ref class CadLayout
Remarks

It contains the name, width and height of the layout in terms of the layout CAD unit.

Note: Available in Professional edition.

Inheritance Hierarchy

System.Object
Accusoft.ImagXpressSdk.CadLayout

See Also

Reference

CadLayout Members
Accusoft.ImagXpressSdk Namespace


CadLayout Class Members

CadLayout Class Members
Properties

Accusoft.ImagXpressSdk Namespace : CadLayout Class

The following tables list the members exposed by CadLayout.

Public Properties
 | Name | Description
Public Property | Height | Gets the height of the CAD layout in CAD units.
Public Property | LayoutNumber | Gets the number designated for the CAD layout.
Public Property | Name | Gets the name of the CAD layout.
Public Property | Unit | Gets the units of measurement for the CAD layout.
Public Property | Width | Gets the width of the CAD layout in cad units.
Top
See Also

Reference

CadLayout Class
Accusoft.ImagXpressSdk Namespace


CadLayout Class Properties

CadLayout Class Properties

Accusoft.ImagXpressSdk Namespace : CadLayout Class

For a list of all members of this type, see CadLayout members.

Public Properties
 | Name | Description
Public Property | Height | Gets the height of the CAD layout in CAD units.
Public Property | LayoutNumber | Gets the number designated for the CAD layout.
Public Property | Name | Gets the name of the CAD layout.
Public Property | Unit | Gets the units of measurement for the CAD layout.
Public Property | Width | Gets the width of the CAD layout in cad units.
Top
See Also

Reference

CadLayout Class
Accusoft.ImagXpressSdk Namespace


Height Property (CadLayout)

Height Property (CadLayout)

Accusoft.ImagXpressSdk Namespace > CadLayout Class : Height Property
Gets the height of the CAD layout in CAD units.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Height As Double
'Usage

Dim instance As CadLayout
Dim value As Double

value = instance.Height
public double Height {get;}
public: __property double get_Height();
public:
property double Height {
   double get();
}

Property Value

A double value which represents the height.
Remarks

Note: Available in Professional edition.

See Also

Reference

CadLayout Class
CadLayout Members


LayoutNumber Property

LayoutNumber Property

Accusoft.ImagXpressSdk Namespace > CadLayout Class : LayoutNumber Property
Gets the number designated for the CAD layout.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property LayoutNumber As Integer
'Usage

Dim instance As CadLayout
Dim value As Integer

value = instance.LayoutNumber
public int LayoutNumber {get;}
public: __property int get_LayoutNumber();
public:
property int LayoutNumber {
   int get();
}
Remarks

Note: Available in Professional edition.

See Also

Reference

CadLayout Class
CadLayout Members


Name Property

Name Property

Accusoft.ImagXpressSdk Namespace > CadLayout Class : Name Property
Gets the name of the CAD layout.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Name As String
'Usage

Dim instance As CadLayout
Dim value As String

value = instance.Name
public string Name {get;}
public: __property string* get_Name();
public:
property String^ Name {
   String^ get();
}

Property Value

A string which represents the name of the CAD layout.
Remarks

Note: Available in Professional edition.

See Also

Reference

CadLayout Class
CadLayout Members


Unit Property

Unit Property

Accusoft.ImagXpressSdk Namespace > CadLayout Class : Unit Property
Gets the units of measurement for the CAD layout.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Unit As CadUnit
'Usage

Dim instance As CadLayout
Dim value As CadUnit

value = instance.Unit
public CadUnit Unit {get;}
public: __property CadUnit get_Unit();
public:
property CadUnit Unit {
   CadUnit get();
}

Property Value

The CadUnit enumeration value set for the CAD unit.
Remarks

Note: Available in Professional edition.

See Also

Reference

CadLayout Class
CadLayout Members


Width Property (CadLayout)

Width Property (CadLayout)

Accusoft.ImagXpressSdk Namespace > CadLayout Class : Width Property
Gets the width of the CAD layout in cad units.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Width As Double
'Usage

Dim instance As CadLayout
Dim value As Double

value = instance.Width
public double Width {get;}
public: __property double get_Width();
public:
property double Width {
   double get();
}

Property Value

A double value which represents the width.
Remarks

Note: Available in Professional edition.

See Also

Reference

CadLayout Class
CadLayout Members


FlickEventArgs Class

FlickEventArgs Class
Members

Accusoft.ImagXpressSdk Namespace : FlickEventArgs Class
This class implements event data for TouchFlick events.
Object Model
FlickEventArgs Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class FlickEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As FlickEventArgs
public class FlickEventArgs : System.EventArgs
public __gc class FlickEventArgs : public System.EventArgs
public ref class FlickEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
Accusoft.ImagXpressSdk.FlickEventArgs

See Also

Reference

FlickEventArgs Members
Accusoft.ImagXpressSdk Namespace


FlickEventArgs Class Members

FlickEventArgs Class Members
Properties

Accusoft.ImagXpressSdk Namespace : FlickEventArgs Class

The following tables list the members exposed by FlickEventArgs.

Public Constructors
 | Name | Description
Public Constructor | FlickEventArgs Constructor | The main constructor which initializes a new instance of the TouchFlickEventArgs class.
Top
Public Properties
 | Name | Description
Public Property | Direction | Gets the direction of the flick.
Public Property | FlickStartLocation | Gets the starting location for the flick during a flick motion with the touch interface.
Top
See Also

Reference

FlickEventArgs Class
Accusoft.ImagXpressSdk Namespace


FlickEventArgs Constructor

FlickEventArgs Constructor

Accusoft.ImagXpressSdk Namespace > FlickEventArgs Class : FlickEventArgs Constructor
The main constructor which initializes a new instance of the TouchFlickEventArgs class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New FlickEventArgs()
public FlickEventArgs()
public: FlickEventArgs();
public:
FlickEventArgs();
See Also

Reference

FlickEventArgs Class
FlickEventArgs Members


FlickEventArgs Class Properties

FlickEventArgs Class Properties

Accusoft.ImagXpressSdk Namespace : FlickEventArgs Class

For a list of all members of this type, see FlickEventArgs members.

Public Properties
 | Name | Description
Public Property | Direction | Gets the direction of the flick.
Public Property | FlickStartLocation | Gets the starting location for the flick during a flick motion with the touch interface.
Top
See Also

Reference

FlickEventArgs Class
Accusoft.ImagXpressSdk Namespace


FlickEventArgs Constructor

FlickEventArgs Constructor

Accusoft.ImagXpressSdk Namespace > FlickEventArgs Class : FlickEventArgs Constructor
Overload List
Overload | Description
FlickEventArgs Constructor | The main constructor which initializes a new instance of the TouchFlickEventArgs class.
See Also

Reference

FlickEventArgs Class
FlickEventArgs Members


Direction Property

Direction Property

Accusoft.ImagXpressSdk Namespace > FlickEventArgs Class : Direction Property
Gets the direction of the flick.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Direction As FlickDirection
'Usage

Dim instance As FlickEventArgs
Dim value As FlickDirection

value = instance.Direction
public FlickDirection Direction {get;}
public: __property FlickDirection get_Direction();
public:
property FlickDirection Direction {
   FlickDirection get();
}

Property Value

A FlickDirection enumeration value.
Remarks
Note: Some flick directions may not be available by default on a user's system. The flicks are controlled on a user's system in the Windows Control Panel under the Pen and Touch settings. There is a Flick tab in the Pen and Touch control panel applet that customizes flick settings for the entire system. Please review the Window's documentation on how to adjust these settings.
See Also

Reference

FlickEventArgs Class
FlickEventArgs Members


FlickStartLocation Property

FlickStartLocation Property

Accusoft.ImagXpressSdk Namespace > FlickEventArgs Class : FlickStartLocation Property
Gets the starting location for the flick during a flick motion with the touch interface.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property FlickStartLocation As Point
'Usage

Dim instance As FlickEventArgs
Dim value As Point

value = instance.FlickStartLocation
public Point FlickStartLocation {get;}
public: __property Point get_FlickStartLocation();
public:
property Point FlickStartLocation {
   Point get();
}

Property Value

A System.Drawing.Point value from the .NET Framework Class Library.
See Also

Reference

FlickEventArgs Class
FlickEventArgs Members


IcmException Class

IcmException Class
Members

Accusoft.ImagXpressSdk Namespace : IcmException Class
This class implements exceptions for the Icm objects.
Object Model
IcmException Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class IcmException
   Inherits ImagXpressException
'Usage

Dim instance As IcmException
[Serializable()]
public sealed class IcmException : ImagXpressException
[Serializable()]
public __gc __sealed class IcmException : public ImagXpressException
[Serializable()]
public ref class IcmException sealed : public ImagXpressException
Inheritance Hierarchy

System.Object
System.Exception
Accusoft.ImagXpressSdk.ImagXpressException
Accusoft.ImagXpressSdk.IcmException

See Also

Reference

IcmException Members
Accusoft.ImagXpressSdk Namespace


IcmException Class Members

IcmException Class Members
Properties Methods

Accusoft.ImagXpressSdk Namespace : IcmException Class

The following tables list the members exposed by IcmException.

Public Constructors
 | Name | Description
Public Constructor | IcmException Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Number | Gets the numerical equivalent for enumerated exception result. (Inherited from Accusoft.ImagXpressSdk.ImagXpressException)
Public Property | Result | Gets the enumerated exception result that has occurred. (Inherited from Accusoft.ImagXpressSdk.ImagXpressException)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

IcmException Class
Accusoft.ImagXpressSdk Namespace


IcmException Class Properties

IcmException Class Properties

Accusoft.ImagXpressSdk Namespace : IcmException Class

For a list of all members of this type, see IcmException members.

Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Number | Gets the numerical equivalent for enumerated exception result. (Inherited from Accusoft.ImagXpressSdk.ImagXpressException)
Public Property | Result | Gets the enumerated exception result that has occurred. (Inherited from Accusoft.ImagXpressSdk.ImagXpressException)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
See Also

Reference

IcmException Class
Accusoft.ImagXpressSdk Namespace


IcmException Class Methods

IcmException Class Methods

Accusoft.ImagXpressSdk Namespace : IcmException Class

For a list of all members of this type, see IcmException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

IcmException Class
Accusoft.ImagXpressSdk Namespace


IcmException Constructor

IcmException Constructor

Accusoft.ImagXpressSdk Namespace > IcmException Class : IcmException Constructor
Overload List
Overload | Description
IcmException Constructor() | The main constructor for the IcmException class.
IcmException Constructor(Result) | Constructor which allows passing in a result for the exception.
IcmException Constructor(String) | Constructor which allows passing in a message for the exception.
IcmException Constructor(Result,String) | Constructor which allows passing in a result and message for the exception.
IcmException Constructor(String,Exception) | Constructor which allows passing in a message and inner exception.
IcmException Constructor(Result,String,Exception) | Constructor which allows passing in a result, message and inner exception.
See Also

Reference

IcmException Class
IcmException Members


IcmException Constructor()

IcmException Constructor()

Accusoft.ImagXpressSdk Namespace > IcmException Class > IcmException Constructor : IcmException Constructor()
The main constructor for the IcmException class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New IcmException()
public IcmException()
public: IcmException();
public:
IcmException();
See Also

Reference

IcmException Class
IcmException Members
Overload List


IcmException Constructor(Result)

IcmException Constructor(Result)

Accusoft.ImagXpressSdk Namespace > IcmException Class > IcmException Constructor : IcmException Constructor(Result)
A Result enumeration value.
Constructor which allows passing in a result for the exception.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal result As Result _
)
'Usage

Dim result As Result

Dim instance As New IcmException(result)
public IcmException(
   Result result
)
public: IcmException(
   Result result
)
public:
IcmException(
   Result result
)

Parameters

result
A Result enumeration value.
See Also

Reference

IcmException Class
IcmException Members
Overload List
Result Enumeration


IcmException Constructor(String)

IcmException Constructor(String)

Accusoft.ImagXpressSdk Namespace > IcmException Class > IcmException Constructor : IcmException Constructor(String)
A string value which represents the error message.
Constructor which allows passing in a message for the exception.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New IcmException(message)
public IcmException(
   string message
)
public: IcmException(
   string* message
)
public:
IcmException(
   String^ message
)

Parameters

message
A string value which represents the error message.
See Also

Reference

IcmException Class
IcmException Members
Overload List


IcmException Constructor(Result,String)

IcmException Constructor(Result,String)

Accusoft.ImagXpressSdk Namespace > IcmException Class > IcmException Constructor : IcmException Constructor(Result,String)
A Result enumeration value.
A string value which represents the error message.
Constructor which allows passing in a result and message for the exception.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal result As Result, _
   ByVal message As String _
)
'Usage

Dim result As Result
Dim message As String

Dim instance As New IcmException(result, message)
public IcmException(
   Result result,
   string message
)
public: IcmException(
   Result result,
   string* message
)
public:
IcmException(
   Result result,
   String^ message
)

Parameters

result
A Result enumeration value.
message
A string value which represents the error message.
See Also

Reference

IcmException Class
IcmException Members
Overload List
Result Enumeration


IcmException Constructor(String,Exception)

IcmException Constructor(String,Exception)

Accusoft.ImagXpressSdk Namespace > IcmException Class > IcmException Constructor : IcmException Constructor(String,Exception)
A string value which represents the error message.
An System.Exception value.
Constructor which allows passing in a message and inner exception.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New IcmException(message, innerException)
public IcmException(
   string message,
   Exception innerException
)
public: IcmException(
   string* message,
   Exception* innerException
)
public:
IcmException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string value which represents the error message.
innerException
An System.Exception value.
See Also

Reference

IcmException Class
IcmException Members
Overload List


IcmException Constructor(Result,String,Exception)

IcmException Constructor(Result,String,Exception)

Accusoft.ImagXpressSdk Namespace > IcmException Class > IcmException Constructor : IcmException Constructor(Result,String,Exception)
A Result enumeration value.
A string value which represents the error message.
An System.Exception value.
Constructor which allows passing in a result, message and inner exception.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal result As Result, _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim result As Result
Dim message As String
Dim innerException As Exception

Dim instance As New IcmException(result, message, innerException)
public IcmException(
   Result result,
   string message,
   Exception innerException
)
public: IcmException(
   Result result,
   string* message,
   Exception* innerException
)
public:
IcmException(
   Result result,
   String^ message,
   Exception^ innerException
)

Parameters

result
A Result enumeration value.
message
A string value which represents the error message.
innerException
An System.Exception value.
See Also

Reference

IcmException Class
IcmException Members
Overload List


ImageCalsCollection Class

ImageCalsCollection Class
Members

Accusoft.ImagXpressSdk Namespace : ImageCalsCollection Class
This class implements a collection of ImageCalsTag objects.
Object Model
ImageCalsCollection ClassImageCalsTag Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImageCalsCollection
   Inherits System.Collections.ObjectModel.Collection(Of ImageCalsTag)
'Usage

Dim instance As ImageCalsCollection
public class ImageCalsCollection : System.Collections.ObjectModel.Collection<ImageCalsTag>
public __gc class ImageCalsCollection : public System.Collections.ObjectModel.Collection<ImageCalsTag>
public ref class ImageCalsCollection : public System.Collections.ObjectModel.Collection<ImageCalsTag>
Remarks

Note: Available in Professional edition.

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
Accusoft.ImagXpressSdk.ImageCalsCollection

See Also

Reference

ImageCalsCollection Members
Accusoft.ImagXpressSdk Namespace


ImageCalsCollection Class Members

ImageCalsCollection Class Members
Properties Methods

Accusoft.ImagXpressSdk Namespace : ImageCalsCollection Class

The following tables list the members exposed by ImageCalsCollection.

Public Constructors
 | Name | Description
Public Constructor | ImageCalsCollection Constructor |
Top
Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<ImageCalsTag>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<ImageCalsTag>)
Top
Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<ImageCalsTag>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<ImageCalsTag>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<ImageCalsTag>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<ImageCalsTag>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<ImageCalsTag>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<ImageCalsTag>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<ImageCalsTag>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<ImageCalsTag>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<ImageCalsTag>)
Top
See Also

Reference

ImageCalsCollection Class
Accusoft.ImagXpressSdk Namespace


ImageCalsCollection Class Properties

ImageCalsCollection Class Properties

Accusoft.ImagXpressSdk Namespace : ImageCalsCollection Class

For a list of all members of this type, see ImageCalsCollection members.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<ImageCalsTag>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<ImageCalsTag>)
Top
See Also

Reference

ImageCalsCollection Class
Accusoft.ImagXpressSdk Namespace


ImageCalsCollection Class Methods

ImageCalsCollection Class Methods

Accusoft.ImagXpressSdk Namespace : ImageCalsCollection Class

For a list of all members of this type, see ImageCalsCollection members.

Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<ImageCalsTag>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<ImageCalsTag>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<ImageCalsTag>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<ImageCalsTag>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<ImageCalsTag>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<ImageCalsTag>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<ImageCalsTag>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<ImageCalsTag>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<ImageCalsTag>)
Top
See Also

Reference

ImageCalsCollection Class
Accusoft.ImagXpressSdk Namespace


ImageCalsCollection Constructor

ImageCalsCollection Constructor

Accusoft.ImagXpressSdk Namespace > ImageCalsCollection Class : ImageCalsCollection Constructor
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImageCalsCollection()
public ImageCalsCollection()
public: ImageCalsCollection();
public:
ImageCalsCollection();
See Also

Reference

ImageCalsCollection Class
ImageCalsCollection Members


ImageCalsTag Class

ImageCalsTag Class
Members

Accusoft.ImagXpressSdk Namespace : ImageCalsTag Class
This class implements methods and properties for the Cals tag data.
Object Model
ImageCalsTag Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImageCalsTag
'Usage

Dim instance As ImageCalsTag
public class ImageCalsTag
public __gc class ImageCalsTag
public ref class ImageCalsTag
Remarks

Note: Available in Professional edition.

Inheritance Hierarchy

System.Object
Accusoft.ImagXpressSdk.ImageCalsTag

See Also

Reference

ImageCalsTag Members
Accusoft.ImagXpressSdk Namespace


ImageCalsTag Class Members

ImageCalsTag Class Members
Properties Methods

Accusoft.ImagXpressSdk Namespace : ImageCalsTag Class

The following tables list the members exposed by ImageCalsTag.

Public Constructors
 | Name | Description
Public Constructor | ImageCalsTag Constructor | Initializes a new instance of the ImageCalsTag class.
Top
Public Properties
 | Name | Description
Public Property | CalsData | Gets or sets the Cals data.
Public Property | CalsId | Gets or sets the Cals id.
Top
Public Methods
 | Name | Description
Public Method | CompareTo | Compares the current instance with another object of the same type.
Top
See Also

Reference

ImageCalsTag Class
Accusoft.ImagXpressSdk Namespace


ImageCalsTag Constructor

ImageCalsTag Constructor

Accusoft.ImagXpressSdk Namespace > ImageCalsTag Class : ImageCalsTag Constructor
A string value which represents the Cals ID.
A string value which represents the Cals data.
Initializes a new instance of the ImageCalsTag class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal CalsId As String, _
   ByVal CalsData As String _
)
'Usage

Dim CalsId As String
Dim CalsData As String

Dim instance As New ImageCalsTag(CalsId, CalsData)
public ImageCalsTag(
   string CalsId,
   string CalsData
)
public: ImageCalsTag(
   string* CalsId,
   string* CalsData
)
public:
ImageCalsTag(
   String^ CalsId,
   String^ CalsData
)

Parameters

CalsId
A string value which represents the Cals ID.
CalsData
A string value which represents the Cals data.
Remarks

Note: Available in Professional edition.

See Also

Reference

ImageCalsTag Class
ImageCalsTag Members


ImageCalsTag Class Methods

ImageCalsTag Class Methods

Accusoft.ImagXpressSdk Namespace : ImageCalsTag Class

For a list of all members of this type, see ImageCalsTag members.

Public Methods
 | Name | Description
Public Method | CompareTo | Compares the current instance with another object of the same type.
Top
See Also

Reference

ImageCalsTag Class
Accusoft.ImagXpressSdk Namespace


CompareTo Method (ImageCalsTag)

CompareTo Method (ImageCalsTag)

Accusoft.ImagXpressSdk Namespace > ImageCalsTag Class : CompareTo Method
An object to compare with this instance.
Compares the current instance with another object of the same type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CompareTo( _
   ByVal obj As Object _
) As Integer
'Usage

Dim instance As ImageCalsTag
Dim obj As Object
Dim value As Integer

value = instance.CompareTo(obj)
public int CompareTo(
   object obj
)
public: int CompareTo(
   Object* obj
)
public:
int CompareTo(
   Object^ obj
)

Parameters

obj
An object to compare with this instance.

Return Value

A 32-bit signed integer that indicates the relative order of the objects being compared. The return value has these meanings: Value Meaning Less than zero This instance is less than obj. Zero This instance is equal to obj. Greater than zero This instance is greater than obj.
Exceptions
Exception | Description
System.ArgumentException | obj is not the same type as this instance.
See Also

Reference

ImageCalsTag Class
ImageCalsTag Members


ImageCalsTag Class Properties

ImageCalsTag Class Properties

Accusoft.ImagXpressSdk Namespace : ImageCalsTag Class

For a list of all members of this type, see ImageCalsTag members.

Public Properties
 | Name | Description
Public Property | CalsData | Gets or sets the Cals data.
Public Property | CalsId | Gets or sets the Cals id.
Top
See Also

Reference

ImageCalsTag Class
Accusoft.ImagXpressSdk Namespace


CalsData Property

CalsData Property

Accusoft.ImagXpressSdk Namespace > ImageCalsTag Class : CalsData Property
Gets or sets the Cals data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CalsData As String
'Usage

Dim instance As ImageCalsTag
Dim value As String

instance.CalsData = value

value = instance.CalsData
public string CalsData {get; set;}
public: __property string* get_CalsData();
public: __property void set_CalsData(
   string* value
);
public:
property String^ CalsData {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value which represents the Cals data.
Remarks

Note: Available in Professional edition.

See Also

Reference

ImageCalsTag Class
ImageCalsTag Members


CalsId Property

CalsId Property

Accusoft.ImagXpressSdk Namespace > ImageCalsTag Class : CalsId Property
Gets or sets the Cals id.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CalsId As String
'Usage

Dim instance As ImageCalsTag
Dim value As String

instance.CalsId = value

value = instance.CalsId
public string CalsId {get; set;}
public: __property string* get_CalsId();
public: __property void set_CalsId(
   string* value
);
public:
property String^ CalsId {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value which represents the Cals ID.
Remarks

The following Ids are the only CalsIds that can be written into a Cals image file using ImagXpress:

  • dstdocid
  • txtfilid
  • figid
  • srcgph
  • doccls
  • rtype
  • rorient
  • rpelcnt
  • rdensity
  • notes

Note: Available in Professional edition.

See Also

Reference

ImageCalsTag Class
ImageCalsTag Members


ImageModcaCollection Class

ImageModcaCollection Class
Members

Accusoft.ImagXpressSdk Namespace : ImageModcaCollection Class
Initializes a new instance of the ImageModcaTag class.
Object Model
ImageModcaCollection ClassImageModcaTag Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImageModcaCollection
   Inherits System.Collections.ObjectModel.Collection(Of ImageModcaTag)
'Usage

Dim instance As ImageModcaCollection
public class ImageModcaCollection : System.Collections.ObjectModel.Collection<ImageModcaTag>
public __gc class ImageModcaCollection : public System.Collections.ObjectModel.Collection<ImageModcaTag>
public ref class ImageModcaCollection : public System.Collections.ObjectModel.Collection<ImageModcaTag>
Remarks

Note: Available in Professional edition.

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
Accusoft.ImagXpressSdk.ImageModcaCollection

See Also

Reference

ImageModcaCollection Members
Accusoft.ImagXpressSdk Namespace


ImageModcaCollection Class Members

ImageModcaCollection Class Members
Properties Methods

Accusoft.ImagXpressSdk Namespace : ImageModcaCollection Class

The following tables list the members exposed by ImageModcaCollection.

Public Constructors
 | Name | Description
Public Constructor | ImageModcaCollection Constructor |
Top
Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<ImageModcaTag>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<ImageModcaTag>)
Top
Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<ImageModcaTag>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<ImageModcaTag>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<ImageModcaTag>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<ImageModcaTag>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<ImageModcaTag>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<ImageModcaTag>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<ImageModcaTag>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<ImageModcaTag>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<ImageModcaTag>)
Top
See Also

Reference

ImageModcaCollection Class
Accusoft.ImagXpressSdk Namespace


ImageModcaCollection Class Properties

ImageModcaCollection Class Properties

Accusoft.ImagXpressSdk Namespace : ImageModcaCollection Class

For a list of all members of this type, see ImageModcaCollection members.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<ImageModcaTag>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<ImageModcaTag>)
Top
See Also

Reference

ImageModcaCollection Class
Accusoft.ImagXpressSdk Namespace


ImageModcaCollection Class Methods

ImageModcaCollection Class Methods

Accusoft.ImagXpressSdk Namespace : ImageModcaCollection Class

For a list of all members of this type, see ImageModcaCollection members.

Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<ImageModcaTag>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<ImageModcaTag>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<ImageModcaTag>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<ImageModcaTag>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<ImageModcaTag>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<ImageModcaTag>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<ImageModcaTag>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<ImageModcaTag>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<ImageModcaTag>)
Top
See Also

Reference

ImageModcaCollection Class
Accusoft.ImagXpressSdk Namespace


ImageModcaCollection Constructor

ImageModcaCollection Constructor

Accusoft.ImagXpressSdk Namespace > ImageModcaCollection Class : ImageModcaCollection Constructor
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImageModcaCollection()
public ImageModcaCollection()
public: ImageModcaCollection();
public:
ImageModcaCollection();
See Also

Reference

ImageModcaCollection Class
ImageModcaCollection Members


ImageModcaTag Class

ImageModcaTag Class
Members

Accusoft.ImagXpressSdk Namespace : ImageModcaTag Class
This class holds Modca tags.
Object Model
ImageModcaTag Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImageModcaTag
'Usage

Dim instance As ImageModcaTag
public class ImageModcaTag
public __gc class ImageModcaTag
public ref class ImageModcaTag
Remarks

Note: Available in Professional edition.

Inheritance Hierarchy

System.Object
Accusoft.ImagXpressSdk.ImageModcaTag

See Also

Reference

ImageModcaTag Members
Accusoft.ImagXpressSdk Namespace


ImageModcaTag Class Members

ImageModcaTag Class Members
Properties Methods

Accusoft.ImagXpressSdk Namespace : ImageModcaTag Class

The following tables list the members exposed by ImageModcaTag.

Public Constructors
 | Name | Description
Public Constructor | ImageModcaTag Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | ModcaDataField | Gets and sets the Modca binary blob field array.
Public Property | ModcaDataLength | Gets the length of the binary blob field.
Public Property | ModcaId | Gets and sets the Modca ID.
Top
Public Methods
 | Name | Description
Public Method | CompareTo | Compares the current instance with another object of the same type.
Top
See Also

Reference

ImageModcaTag Class
Accusoft.ImagXpressSdk Namespace


ImageModcaTag Constructor

ImageModcaTag Constructor

Accusoft.ImagXpressSdk Namespace > ImageModcaTag Class : ImageModcaTag Constructor
Overload List
Overload | Description
ImageModcaTag Constructor(Int32,Int32,Byte[]) | Initializes a new instance of the ImageModcaTag class allowing to pass in a ModcaID, count and Modca data field by byte array.
ImageModcaTag Constructor(Int32,Int32,Object) | Initializes a new instance of the ImageModcaTag class allowing to pass in a ModcaID, count and data field by object.
See Also

Reference

ImageModcaTag Class
ImageModcaTag Members


ImageModcaTag Constructor(Int32,Int32,Byte[])

ImageModcaTag Constructor(Int32,Int32,Byte[])

Accusoft.ImagXpressSdk Namespace > ImageModcaTag Class > ImageModcaTag Constructor : ImageModcaTag Constructor(Int32,Int32,Byte[])
An integer value which represents the Modca ID.
An integer value which represents the count of the Modca tags.
A byte array which represents the Modca data field.
Initializes a new instance of the ImageModcaTag class allowing to pass in a ModcaID, count and Modca data field by byte array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal ModcaID As Integer, _
   ByVal Count As Integer, _
   ByVal ModcaDataField() As Byte _
)
'Usage

Dim ModcaID As Integer
Dim Count As Integer
Dim ModcaDataField() As Byte

Dim instance As New ImageModcaTag(ModcaID, Count, ModcaDataField)
public ImageModcaTag(
   int ModcaID,
   int Count,
   byte[] ModcaDataField
)
public: ImageModcaTag(
   int ModcaID,
   int Count,
   byte[]* ModcaDataField
)
public:
ImageModcaTag(
   int ModcaID,
   int Count,
   array<byte>^ ModcaDataField
)

Parameters

ModcaID
An integer value which represents the Modca ID.
Count
An integer value which represents the count of the Modca tags.
ModcaDataField
A byte array which represents the Modca data field.
Remarks

Note: Available in Professional edition.

See Also

Reference

ImageModcaTag Class
ImageModcaTag Members
Overload List


ImageModcaTag Constructor(Int32,Int32,Object)

ImageModcaTag Constructor(Int32,Int32,Object)

Accusoft.ImagXpressSdk Namespace > ImageModcaTag Class > ImageModcaTag Constructor : ImageModcaTag Constructor(Int32,Int32,Object)
An integer value which represents the Modca ID.
An integer value which represents the count of the Modca tags.
An object which represents the data field.
Initializes a new instance of the ImageModcaTag class allowing to pass in a ModcaID, count and data field by object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal ModcaID As Integer, _
   ByVal Count As Integer, _
   ByVal ModcaDataField As Object _
)
'Usage

Dim ModcaID As Integer
Dim Count As Integer
Dim ModcaDataField As Object

Dim instance As New ImageModcaTag(ModcaID, Count, ModcaDataField)
public ImageModcaTag(
   int ModcaID,
   int Count,
   object ModcaDataField
)
public: ImageModcaTag(
   int ModcaID,
   int Count,
   Object* ModcaDataField
)
public:
ImageModcaTag(
   int ModcaID,
   int Count,
   Object^ ModcaDataField
)

Parameters

ModcaID
An integer value which represents the Modca ID.
Count
An integer value which represents the count of the Modca tags.
ModcaDataField
An object which represents the data field.
Remarks

Note: Available in Professional edition.

See Also

Reference

ImageModcaTag Class
ImageModcaTag Members
Overload List


ImageModcaTag Class Methods

ImageModcaTag Class Methods

Accusoft.ImagXpressSdk Namespace : ImageModcaTag Class

For a list of all members of this type, see ImageModcaTag members.

Public Methods
 | Name | Description
Public Method | CompareTo | Compares the current instance with another object of the same type.
Top
See Also

Reference

ImageModcaTag Class
Accusoft.ImagXpressSdk Namespace


CompareTo Method (ImageModcaTag)

CompareTo Method (ImageModcaTag)

Accusoft.ImagXpressSdk Namespace > ImageModcaTag Class : CompareTo Method
A System.Object to compare to.
Compares the current instance with another object of the same type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CompareTo( _
   ByVal obj As Object _
) As Integer
'Usage

Dim instance As ImageModcaTag
Dim obj As Object
Dim value As Integer

value = instance.CompareTo(obj)
public int CompareTo(
   object obj
)
public: int CompareTo(
   Object* obj
)
public:
int CompareTo(
   Object^ obj
)

Parameters

obj
A System.Object to compare to.

Return Value

A 32-bit signed integer which represents the result.

1 is returned if the object is null.

0 is returned if the given object is the same as the current one.

The Modca ID is returned if it is not the same.

See Also

Reference

ImageModcaTag Class
ImageModcaTag Members


ImageModcaTag Class Properties

ImageModcaTag Class Properties

Accusoft.ImagXpressSdk Namespace : ImageModcaTag Class

For a list of all members of this type, see ImageModcaTag members.

Public Properties
 | Name | Description
Public Property | ModcaDataField | Gets and sets the Modca binary blob field array.
Public Property | ModcaDataLength | Gets the length of the binary blob field.
Public Property | ModcaId | Gets and sets the Modca ID.
Top
See Also

Reference

ImageModcaTag Class
Accusoft.ImagXpressSdk Namespace


ModcaDataField Property

ModcaDataField Property

Accusoft.ImagXpressSdk Namespace > ImageModcaTag Class : ModcaDataField Property
Gets and sets the Modca binary blob field array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ModcaDataField As Byte()
'Usage

Dim instance As ImageModcaTag
Dim value() As Byte

instance.ModcaDataField = value

value = instance.ModcaDataField
public byte[] ModcaDataField {get; set;}
public: __property byte[]* get_ModcaDataField();
public: __property void set_ModcaDataField(
   byte[]* value
);
public:
property array<byte>^ ModcaDataField {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

Property Value

A byte array which represents the Modca binary blob field.
Remarks

Note: Available in Professional edition.

See Also

Reference

ImageModcaTag Class
ImageModcaTag Members


ModcaDataLength Property

ModcaDataLength Property

Accusoft.ImagXpressSdk Namespace > ImageModcaTag Class : ModcaDataLength Property
Gets the length of the binary blob field.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ModcaDataLength As Integer
'Usage

Dim instance As ImageModcaTag
Dim value As Integer

value = instance.ModcaDataLength
public int ModcaDataLength {get;}
public: __property int get_ModcaDataLength();
public:
property int ModcaDataLength {
   int get();
}

Property Value

An integer value which represents the Modca binary blob field length.
Remarks

Note: Available in Professional edition.

See Also

Reference

ImageModcaTag Class
ImageModcaTag Members


ModcaId Property

ModcaId Property

Accusoft.ImagXpressSdk Namespace > ImageModcaTag Class : ModcaId Property
Gets and sets the Modca ID.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ModcaId As Integer
'Usage

Dim instance As ImageModcaTag
Dim value As Integer

instance.ModcaId = value

value = instance.ModcaId
public int ModcaId {get; set;}
public: __property int get_ModcaId();
public: __property void set_ModcaId(
   int value
);
public:
property int ModcaId {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the Modca ID to get or set.
Remarks

Note: Available in Professional edition.

See Also

Reference

ImageModcaTag Class
ImageModcaTag Members


ImageReduce Class

ImageReduce Class
Members

Accusoft.ImagXpressSdk Namespace : ImageReduce Class
Re-save compressed image formats without the resource overhead of presenting its decompressed pixel data as a DIB.
Object Model
ImageReduce Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit NotInheritable Class ImageReduce
'Usage

Dim instance As ImageReduce
public static class ImageReduce
public __gc abstract __sealed class ImageReduce
public ref class ImageReduce abstract sealed
Inheritance Hierarchy

System.Object
Accusoft.ImagXpressSdk.ImageReduce

See Also

Reference

ImageReduce Members
Accusoft.ImagXpressSdk Namespace


ImageReduce Class Members

ImageReduce Class Members
Methods

Accusoft.ImagXpressSdk Namespace : ImageReduce Class

The following tables list the members exposed by ImageReduce.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | JpegReduce | Overloaded. This function requantizes a JPEG to compress its size without requiring decompression followed by recompression.
static (Shared in Visual Basic) | PngReduce | Overloaded. Compress a PNG to optimal size while maintaining lossless fidelity to the input image. The reduction is achieved by removing select pieces of metadata and other possible color and/or transparency reductions.
Top
See Also

Reference

ImageReduce Class
Accusoft.ImagXpressSdk Namespace


ImageReduce Class Methods

ImageReduce Class Methods

Accusoft.ImagXpressSdk Namespace : ImageReduce Class

For a list of all members of this type, see ImageReduce members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | JpegReduce | Overloaded. This function requantizes a JPEG to compress its size without requiring decompression followed by recompression.
static (Shared in Visual Basic) | PngReduce | Overloaded. Compress a PNG to optimal size while maintaining lossless fidelity to the input image. The reduction is achieved by removing select pieces of metadata and other possible color and/or transparency reductions.
Top
See Also

Reference

ImageReduce Class
Accusoft.ImagXpressSdk Namespace


JpegReduce Method

JpegReduce Method

Accusoft.ImagXpressSdk Namespace > ImageReduce Class : JpegReduce Method
This function requantizes a JPEG to compress its size without requiring decompression followed by recompression.
Overload List
Overload | Description
JpegReduce(ImagXpress,String,String,Int32,TransformMode) | This function requantizes a JPEG to compress its size without requiring decompression followed by recompression.
JpegReduce(ImagXpress,Byte[],Byte[],Int32,TransformMode) | This function requantizes a JPEG to compress its size without requiring decompression followed by recompression.
See Also

Reference

ImageReduce Class
ImageReduce Members


JpegReduce(ImagXpress,String,String,Int32,TransformMode) Method

JpegReduce(ImagXpress,String,String,Int32,TransformMode) Method

Accusoft.ImagXpressSdk Namespace > ImageReduce Class > JpegReduce Method : JpegReduce(ImagXpress,String,String,Int32,TransformMode) Method
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
The name of the input JPEG file.
The name of the output JPEG file.
The quality factor of the compression improvement.

Note: The default value is 22 for strong compression improvement while maintaining very good quality. The range is from 0-32, where 0 represents almost no compression improvement and 32 represents the most compression improvement with some quality loss.

The transform mode for the reduce operation.

Note: The default value is TransformMode.None.

When transformMode is TransformMode.None the output JPEG format will match the input JPEG format.

When transformMode is TransformMode.ToProgressiveJpeg, the output JPEG format will be progressive JPEG. Note: Transforming Sequential to Progressive may result in a small increase in size.

When transformMode is TransformMode.ToSequentialJpeg, the output JPEG format will be sequential JPEG. Note: Transforming Progressive to Sequential may result in a small increase in size.

This function requantizes a JPEG to compress its size without requiring decompression followed by recompression.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub JpegReduce( _
   ByVal imagXpress As ImagXpress, _
   ByVal inputFileName As String, _
   ByVal outputFileName As String, _
   Optional ByVal qualityFactor As Integer, _
   Optional ByVal transformMode As TransformMode _
)
'Usage

Dim imagXpress As ImagXpress
Dim inputFileName As String
Dim outputFileName As String
Dim qualityFactor As Integer
Dim transformMode As TransformMode

ImageReduce.JpegReduce(imagXpress, inputFileName, outputFileName, qualityFactor, transformMode)
public static void JpegReduce(
   ImagXpress imagXpress,
   string inputFileName,
   string outputFileName,
   int qualityFactor,
   TransformMode transformMode
)
public: static void JpegReduce(
   ImagXpress* imagXpress,
   string* inputFileName,
   string* outputFileName,
   int qualityFactor,
   TransformMode transformMode
)
public:
static void JpegReduce(
   ImagXpress^ imagXpress,
   String^ inputFileName,
   String^ outputFileName,
   int qualityFactor,
   TransformMode transformMode
)

Parameters

imagXpress
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
inputFileName
The name of the input JPEG file.
outputFileName
The name of the output JPEG file.
qualityFactor
The quality factor of the compression improvement.

Note: The default value is 22 for strong compression improvement while maintaining very good quality. The range is from 0-32, where 0 represents almost no compression improvement and 32 represents the most compression improvement with some quality loss.

transformMode
The transform mode for the reduce operation.

Note: The default value is TransformMode.None.

When transformMode is TransformMode.None the output JPEG format will match the input JPEG format.

When transformMode is TransformMode.ToProgressiveJpeg, the output JPEG format will be progressive JPEG. Note: Transforming Sequential to Progressive may result in a small increase in size.

When transformMode is TransformMode.ToSequentialJpeg, the output JPEG format will be sequential JPEG. Note: Transforming Progressive to Sequential may result in a small increase in size.

Exceptions
Exception | Description
System.ArgumentNullException | Thrown when imagXpress is null.
System.ArgumentNullException | Thrown when inputFileName is null.
System.ArgumentNullException | Thrown when outputFileName is null.
System.ArgumentOutOfRangeException | Thrown when qualityFactor is outside range [0, 32].
System.IO.FileNotFoundException | Thrown when inputFileName does not exist.
System.ArgumentException | Thrown when inputFileName is an HTTP or FTP URL.
System.ArgumentException | Thrown when outputFileName is an HTTP or FTP URL.
ImagXpressException | Thrown when imagXpress is not licensed for this feature.
ImagXpressException | Thrown when inputFileName refers to a damaged or incomplete JPEG.
ImagXpressException | Thrown when inputFileName does not refer to a 8-bit grayscale or 24-bit color JPEG.
System.UnauthorizedAccessException | Thrown when outputFileName cannot be created or modified.
Remarks

Note: Supports reading 8-bit grayscale and 24-bit color JPEGs.

See Also

Reference

ImageReduce Class
ImageReduce Members
Overload List


JpegReduce(ImagXpress,Byte[],Byte[],Int32,TransformMode) Method

JpegReduce(ImagXpress,Byte[],Byte[],Int32,TransformMode) Method

Accusoft.ImagXpressSdk Namespace > ImageReduce Class > JpegReduce Method : JpegReduce(ImagXpress,Byte[],Byte[],Int32,TransformMode) Method
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
The buffer holding the input JPEG file.
The buffer holding the output JPEG file.
The quality factor of the compression improvement.

Note: The default value is 22 for strong compression improvement while maintaining very good quality. The range is from 0-32, where 0 represents almost no compression improvement and 32 represents the most compression improvement with some quality loss.

The transform mode for the reduce operation.

Note: The default value is TransformMode.None.

When transformMode is TransformMode.None the output JPEG format will match the input JPEG format.

When transformMode is TransformMode.ToProgressiveJpeg, the output JPEG format will be progressive JPEG. Note: Transforming Sequential to Progressive may result in a small increase in size.

When transformMode is TransformMode.ToSequentialJpeg, the output JPEG format will be sequential JPEG. Note: Transforming Progressive to Sequential may result in a small increase in size.

This function requantizes a JPEG to compress its size without requiring decompression followed by recompression.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub JpegReduce( _
   ByVal imagXpress As ImagXpress, _
   ByVal inputJpegData() As Byte, _
   ByRef outputJpegData As Byte(), _
   Optional ByVal qualityFactor As Integer, _
   Optional ByVal transformMode As TransformMode _
)
'Usage

Dim imagXpress As ImagXpress
Dim inputJpegData() As Byte
Dim outputJpegData As Byte()
Dim qualityFactor As Integer
Dim transformMode As TransformMode

ImageReduce.JpegReduce(imagXpress, inputJpegData, outputJpegData, qualityFactor, transformMode)
public static void JpegReduce(
   ImagXpress imagXpress,
   byte[] inputJpegData,
   out byte[] outputJpegData,
   int qualityFactor,
   TransformMode transformMode
)
public: static void JpegReduce(
   ImagXpress* imagXpress,
   byte[]* inputJpegData,
   [PARAMFLAG::Out] byte[] outputJpegData,
   int qualityFactor,
   TransformMode transformMode
)
public:
static void JpegReduce(
   ImagXpress^ imagXpress,
   array<byte>^ inputJpegData,
   [Out] array<byte> outputJpegData,
   int qualityFactor,
   TransformMode transformMode
)

Parameters

imagXpress
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
inputJpegData
The buffer holding the input JPEG file.
outputJpegData
The buffer holding the output JPEG file.
qualityFactor
The quality factor of the compression improvement.

Note: The default value is 22 for strong compression improvement while maintaining very good quality. The range is from 0-32, where 0 represents almost no compression improvement and 32 represents the most compression improvement with some quality loss.

transformMode
The transform mode for the reduce operation.

Note: The default value is TransformMode.None.

When transformMode is TransformMode.None the output JPEG format will match the input JPEG format.

When transformMode is TransformMode.ToProgressiveJpeg, the output JPEG format will be progressive JPEG. Note: Transforming Sequential to Progressive may result in a small increase in size.

When transformMode is TransformMode.ToSequentialJpeg, the output JPEG format will be sequential JPEG. Note: Transforming Progressive to Sequential may result in a small increase in size.

Exceptions
Exception | Description
System.ArgumentNullException | Thrown when imagXpress is null.
System.ArgumentNullException | Thrown when inputJpegData is null.
System.ArgumentOutOfRangeException | Thrown when qualityFactor is outside range [0,32].
ImagXpressException | Thrown when imagXpress is not licensed for this feature.
ImagXpressException | Thrown when inputJpegData refers to a damaged or incomplete JPEG.
ImagXpressException | Thrown when inputJpegData does not refer to a 8-bit grayscale or 24-bit color JPEG.
Remarks

Note: Supports reading 8-bit grayscale and 24-bit color JPEGs.

See Also

Reference

ImageReduce Class
ImageReduce Members
Overload List


PngReduce Method

PngReduce Method

Accusoft.ImagXpressSdk Namespace > ImageReduce Class : PngReduce Method
Compress a PNG to optimal size while maintaining lossless fidelity to the input image. The reduction is achieved by removing select pieces of metadata and other possible color and/or transparency reductions.
Overload List
Overload | Description
PngReduce(ImagXpress,String,String) | Compress a PNG to optimal size while maintaining lossless fidelity to the input image. The reduction is achieved by removing select pieces of metadata and other possible color and/or transparency reductions.
PngReduce(ImagXpress,Byte[],Byte[]) | Compress a PNG to optimal size while maintaining lossless fidelity to the input image. The reduction is achieved by removing select pieces of metadata and other possible color and/or transparency reductions.
See Also

Reference

ImageReduce Class
ImageReduce Members


PngReduce(ImagXpress,String,String) Method

PngReduce(ImagXpress,String,String) Method

Accusoft.ImagXpressSdk Namespace > ImageReduce Class > PngReduce Method : PngReduce(ImagXpress,String,String) Method
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
The name of the input PNG file.
The name of the output PNG file.
Compress a PNG to optimal size while maintaining lossless fidelity to the input image. The reduction is achieved by removing select pieces of metadata and other possible color and/or transparency reductions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub PngReduce( _
   ByVal imagXpress As ImagXpress, _
   ByVal inputFileName As String, _
   ByVal outputFileName As String _
)
'Usage

Dim imagXpress As ImagXpress
Dim inputFileName As String
Dim outputFileName As String

ImageReduce.PngReduce(imagXpress, inputFileName, outputFileName)
public static void PngReduce(
   ImagXpress imagXpress,
   string inputFileName,
   string outputFileName
)
public: static void PngReduce(
   ImagXpress* imagXpress,
   string* inputFileName,
   string* outputFileName
)
public:
static void PngReduce(
   ImagXpress^ imagXpress,
   String^ inputFileName,
   String^ outputFileName
)

Parameters

imagXpress
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
inputFileName
The name of the input PNG file.
outputFileName
The name of the output PNG file.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when imagXpress is null.
System.ArgumentNullException | Thrown when inputFileName is null.
System.ArgumentNullException | Thrown when outputFileName is null.
System.IO.FileNotFoundException | Thrown when inputFileName does not exist.
System.ArgumentException | Thrown when inputFileName is an HTTP or FTP URL.
System.ArgumentException | Thrown when outputFileName is an HTTP or FTP URL.
ImagXpressException | Thrown when imagXpress is not licensed for this feature.
ImagXpressException | Thrown when inputFileName refers to a damaged or incomplete PNG.
System.UnauthorizedAccessException | Thrown when outputFileName cannot be created or modified.
See Also

Reference

ImageReduce Class
ImageReduce Members
Overload List


PngReduce(ImagXpress,Byte[],Byte[]) Method

PngReduce(ImagXpress,Byte[],Byte[]) Method

Accusoft.ImagXpressSdk Namespace > ImageReduce Class > PngReduce Method : PngReduce(ImagXpress,Byte[],Byte[]) Method
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
The buffer holding the input PNG file.
The buffer holding the output PNG file.
Compress a PNG to optimal size while maintaining lossless fidelity to the input image. The reduction is achieved by removing select pieces of metadata and other possible color and/or transparency reductions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub PngReduce( _
   ByVal imagXpress As ImagXpress, _
   ByVal inputPngData() As Byte, _
   ByRef outputPngData As Byte() _
)
'Usage

Dim imagXpress As ImagXpress
Dim inputPngData() As Byte
Dim outputPngData As Byte()

ImageReduce.PngReduce(imagXpress, inputPngData, outputPngData)
public static void PngReduce(
   ImagXpress imagXpress,
   byte[] inputPngData,
   out byte[] outputPngData
)
public: static void PngReduce(
   ImagXpress* imagXpress,
   byte[]* inputPngData,
   [PARAMFLAG::Out] byte[] outputPngData
)
public:
static void PngReduce(
   ImagXpress^ imagXpress,
   array<byte>^ inputPngData,
   [Out] array<byte> outputPngData
)

Parameters

imagXpress
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
inputPngData
The buffer holding the input PNG file.
outputPngData
The buffer holding the output PNG file.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown when imagXpress is null.
System.ArgumentNullException | Thrown when outputPngData is null.
ImagXpressException | Thrown when imagXpress is not licensed for this feature.
ImagXpressException | Thrown when inputPngData refers to a damaged or incomplete PNG.
See Also

Reference

ImageReduce Class
ImageReduce Members
Overload List


ImageStatusEventArgs Class

ImageStatusEventArgs Class
Members

Accusoft.ImagXpressSdk Namespace : ImageStatusEventArgs Class
This class contains object data for Image Status events.
Object Model
ImageStatusEventArgs ClassImageX ClassImageX ClassImageCalsCollection ClassImageCalsTag ClassImageX ClassImageX ClassImageX ClassImageX ClassImageX ClassImageX ClassImageX ClassImageXData ClassImageXIptcCollection ClassImageXIptcData ClassLoadOptions ClassImageModcaCollection ClassImageModcaTag ClassImageXData ClassImageXData ClassImageXData ClassImageX ClassResolution ClassImageXTagCollection ClassImageXTag Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImageStatusEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As ImageStatusEventArgs
public class ImageStatusEventArgs : System.EventArgs
public __gc class ImageStatusEventArgs : public System.EventArgs
public ref class ImageStatusEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
Accusoft.ImagXpressSdk.ImageStatusEventArgs

See Also

Reference

ImageStatusEventArgs Members
Accusoft.ImagXpressSdk Namespace


ImageStatusEventArgs Class Members

ImageStatusEventArgs Class Members
Properties

Accusoft.ImagXpressSdk Namespace : ImageStatusEventArgs Class

The following tables list the members exposed by ImageStatusEventArgs.

Public Constructors
 | Name | Description
Public Constructor | ImageStatusEventArgs Constructor | The main constructor for the ImageStatusEventArgs class.
Top
Public Properties
 | Name | Description
Public Property | Image | Gets the image for the event.
Public Property | Operation | Gets the current image operation.
Public Property | Status | Gets the status of the current image.
Top
See Also

Reference

ImageStatusEventArgs Class
Accusoft.ImagXpressSdk Namespace


ImageStatusEventArgs Constructor

ImageStatusEventArgs Constructor

Accusoft.ImagXpressSdk Namespace > ImageStatusEventArgs Class : ImageStatusEventArgs Constructor
The main constructor for the ImageStatusEventArgs class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImageStatusEventArgs()
public ImageStatusEventArgs()
public: ImageStatusEventArgs();
public:
ImageStatusEventArgs();
See Also

Reference

ImageStatusEventArgs Class
ImageStatusEventArgs Members


ImageStatusEventArgs Class Properties

ImageStatusEventArgs Class Properties

Accusoft.ImagXpressSdk Namespace : ImageStatusEventArgs Class

For a list of all members of this type, see ImageStatusEventArgs members.

Public Properties
 | Name | Description
Public Property | Image | Gets the image for the event.
Public Property | Operation | Gets the current image operation.
Public Property | Status | Gets the status of the current image.
Top
See Also

Reference

ImageStatusEventArgs Class
Accusoft.ImagXpressSdk Namespace


ImageStatusEventArgs Constructor

ImageStatusEventArgs Constructor

Accusoft.ImagXpressSdk Namespace > ImageStatusEventArgs Class : ImageStatusEventArgs Constructor
Overload List
Overload | Description
ImageStatusEventArgs Constructor | The main constructor for the ImageStatusEventArgs class.
See Also

Reference

ImageStatusEventArgs Class
ImageStatusEventArgs Members


Image Property (ImageStatusEventArgs)

Image Property (ImageStatusEventArgs)

Accusoft.ImagXpressSdk Namespace > ImageStatusEventArgs Class : Image Property
Gets the image for the event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Image As ImageX
'Usage

Dim instance As ImageStatusEventArgs
Dim value As ImageX

value = instance.Image
public ImageX Image {get;}
public: __property ImageX* get_Image();
public:
property ImageX^ Image {
   ImageX^ get();
}

Property Value

The image the event was returned for.
See Also

Reference

ImageStatusEventArgs Class
ImageStatusEventArgs Members


Operation Property (ImageStatusEventArgs)

Operation Property (ImageStatusEventArgs)

Accusoft.ImagXpressSdk Namespace > ImageStatusEventArgs Class : Operation Property
Gets the current image operation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Operation As Operation
'Usage

Dim instance As ImageStatusEventArgs
Dim value As Operation

value = instance.Operation
public Operation Operation {get;}
public: __property Operation get_Operation();
public:
property Operation Operation {
   Operation get();
}

Property Value

An Operation enumeration value.
See Also

Reference

ImageStatusEventArgs Class
ImageStatusEventArgs Members


Status Property

Status Property

Accusoft.ImagXpressSdk Namespace > ImageStatusEventArgs Class : Status Property
Gets the status of the current image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Status As ImageStatus
'Usage

Dim instance As ImageStatusEventArgs
Dim value As ImageStatus

value = instance.Status
public ImageStatus Status {get;}
public: __property ImageStatus get_Status();
public:
property ImageStatus Status {
   ImageStatus get();
}

Property Value

An ImageStatus enumeration value.
See Also

Reference

ImageStatusEventArgs Class
ImageStatusEventArgs Members


ImageX Class

ImageX Class
Members

Accusoft.ImagXpressSdk Namespace : ImageX Class
This class implements basic operating functionality for the ImagXpress component.
Object Model
ImageX ClassImageX ClassImageX ClassImageCalsCollection ClassImageCalsTag ClassImageX ClassImageX ClassImageX ClassImageX ClassImageX ClassImageX ClassImageX ClassImageXData ClassImageXIptcCollection ClassImageXIptcData ClassLoadOptions ClassImageModcaCollection ClassImageModcaTag ClassImageXData ClassImageXData ClassImageXData ClassImageX ClassResolution ClassImageXTagCollection ClassImageXTag ClassImageCalsCollection ClassImageCalsTag ClassImageX ClassImageX ClassImageCalsCollection ClassImageCalsTag ClassImageX ClassImageX ClassImageX ClassImageX ClassImageX ClassImageX ClassImageX ClassImageXData ClassImageXIptcCollection ClassImageXIptcData ClassLoadOptions ClassImageModcaCollection ClassImageModcaTag ClassImageXData ClassImageXData ClassImageXData ClassImageX ClassResolution ClassImageXTagCollection ClassImageXTag ClassImageX ClassImageX ClassImageCalsCollection ClassImageCalsTag ClassImageX ClassImageX ClassImageX ClassImageX ClassImageX ClassImageX ClassImageX ClassImageXData ClassImageXIptcCollection ClassImageXIptcData ClassLoadOptions ClassImageModcaCollection ClassImageModcaTag ClassImageXData ClassImageXData ClassImageXData ClassImageX ClassResolution ClassImageXTagCollection ClassImageXTag ClassImageX ClassImageX ClassImageCalsCollection ClassImageCalsTag ClassImageX ClassImageX ClassImageX ClassImageX ClassImageX ClassImageX ClassImageX ClassImageXData ClassImageXIptcCollection ClassImageXIptcData ClassLoadOptions ClassImageModcaCollection ClassImageModcaTag ClassImageXData ClassImageXData ClassImageXData ClassImageX ClassResolution ClassImageXTagCollection ClassImageXTag ClassImageX ClassImageX ClassImageCalsCollection ClassImageCalsTag ClassImageX ClassImageX ClassImageX ClassImageX ClassImageX ClassImageX ClassImageX ClassImageXData ClassImageXIptcCollection ClassImageXIptcData ClassLoadOptions ClassImageModcaCollection ClassImageModcaTag ClassImageXData ClassImageXData ClassImageXData ClassImageX ClassResolution ClassImageXTagCollection ClassImageXTag ClassImageX ClassImageX ClassImageCalsCollection ClassImageCalsTag ClassImageX ClassImageX ClassImageX ClassImageX ClassImageX ClassImageX ClassImageX ClassImageXData ClassImageXIptcCollection ClassImageXIptcData ClassLoadOptions ClassImageModcaCollection ClassImageModcaTag ClassImageXData ClassImageXData ClassImageXData ClassImageX ClassResolution ClassImageXTagCollection ClassImageXTag ClassImageX ClassImageX ClassImageCalsCollection ClassImageCalsTag ClassImageX ClassImageX ClassImageX ClassImageX ClassImageX ClassImageX ClassImageX ClassImageXData ClassImageXIptcCollection ClassImageXIptcData ClassLoadOptions ClassImageModcaCollection ClassImageModcaTag ClassImageXData ClassImageXData ClassImageXData ClassImageX ClassResolution ClassImageXTagCollection ClassImageXTag ClassImageX ClassImageX ClassImageCalsCollection ClassImageCalsTag ClassImageX ClassImageX ClassImageX ClassImageX ClassImageX ClassImageX ClassImageX ClassImageXData ClassImageXIptcCollection ClassImageXIptcData ClassLoadOptions ClassImageModcaCollection ClassImageModcaTag ClassImageXData ClassImageXData ClassImageXData ClassImageX ClassResolution ClassImageXTagCollection ClassImageXTag ClassImageXData ClassCadLayer ClassCadLayout ClassResolution ClassImageXIptcCollection ClassImageXIptcData ClassLoadOptions ClassLoadOptionsCad ClassLoadOptionsCameraRaw ClassInternetOptions ClassLoadOptionsJbig2 ClassLoadOptionsJpeg ClassLoadOptionsJpegXR ClassLoadOptionsMetafile ClassLoadOptionsPdf ClassLoadOptionsPic ClassLoadOptionsRaw ClassLoadOptionsTiff ClassImageModcaCollection ClassImageModcaTag ClassImageXData ClassCadLayer ClassCadLayout ClassResolution ClassImageXData ClassCadLayer ClassCadLayout ClassResolution ClassImageXData ClassCadLayer ClassCadLayout ClassResolution ClassImageX ClassImageX ClassImageCalsCollection ClassImageCalsTag ClassImageX ClassImageX ClassImageX ClassImageX ClassImageX ClassImageX ClassImageX ClassImageXData ClassImageXIptcCollection ClassImageXIptcData ClassLoadOptions ClassImageModcaCollection ClassImageModcaTag ClassImageXData ClassImageXData ClassImageXData ClassImageX ClassResolution ClassImageXTagCollection ClassImageXTag ClassResolution ClassImageXTagCollection ClassImageXTag Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImageX
   Inherits System.MarshalByRefObject
'Usage

Dim instance As ImageX
public class ImageX : System.MarshalByRefObject
public __gc class ImageX : public System.MarshalByRefObject
public ref class ImageX : public System.MarshalByRefObject
Remarks

This object implements the IDisposable interface and the application is required to call the Dispose method when the application is done with ImageX object, otherwise memory may leak.

Instances of this class can be used as the destination of Accusoft's standard methods for passing images between different components: CopyTo(object destination) and TransferTo(object destination).

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
Accusoft.ImagXpressSdk.ImageX

See Also

Reference

ImageX Members
Accusoft.ImagXpressSdk Namespace


ImageX Class Members

ImageX Class Members
Properties Methods

Accusoft.ImagXpressSdk Namespace : ImageX Class

The following tables list the members exposed by ImageX.

Public Constructors
 | Name | Description
Public Constructor | ImageX Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | AutoInvalidate | Gets and sets if the ImageXView object repaints whenever a change is made to the ImageX object.
Public Property | BitsPerPixel | Gets the number of bits per pixel.
Public Property | CalTags | Get and sets the String pair Modca/Cals Tags Cal Tags can only be obtainds from Modca/Cals images open by Load methods Presently, there is no way to edit Cal tags without loading and saving the image.
Public Property | ColorSpace | Gets the color space of the current image.
Public Property | Compression | Gets the compression employed on the current image.
Public Property | Filename | Gets the file name.
Public Property | Format | Gets the file format of the current image.
Public Property | Height | Gets the height value of the current image.
Public Property | HorizontalResolution | Returns the horizontal resolution of this ImageX image.
Public Property | ImageXData | Gets the ImageXData of the ImageX object.
Public Property | IptcDataSet | Gets or sets the iptc data set.
Public Property | JpegCommentCount | After opening a JPEG file, this property gets the number of JPEG App markers comments discovered.
Public Property | LoadOptions | Gets the additional load options from this ImageX object.
Public Property | ModcaTags | Gets and sets the ImageModcaCollection.
Public Property | Page | Gets and sets the page to be viewed or processed.
Public Property | PageCount | Gets the number of pages in the image beginning at 1.
Public Property | Palette | Gets or sets the color palette used for this ImageX object.
Public Property | Resolution | Gets the resolution of the ImageX image.
Public Property | ResolutionPrecision | Gets or sets the level of precision of the HorizontalResolution, VerticalResolution and Resolution returned.
Public Property | ResolutionUnits | Sets and returns the graphics units in which resolution information is specified.
Public Property | Tags | Gets and sets the tag collection associated with this ImageX image.
Public Property | UndoEnabled | Gets and sets the ability to perform the Undo method.
Public Property | VerticalResolution | Returns the vertical resolution of the ImageX image.
Public Property | Width | Gets the width value of the current image.
Top
Public Methods
 | Name | Description
Public Method | AddJpegComment | Adds a new comment from an opened JPEG file or a comment for a file to be saved as a JPEG file. The comment will be added when the current image is written out (saved) as a JPEG file.
Public Method | CadFileClose | Closes the CAD file.
static (Shared in Visual Basic) | CadFileOpen | Overloaded. Opens the CAD file for repeated renderings of differently selected layers and layouts.
Public Method | CadFileView | Overloaded. The CAD file view.
Public Method | Cancel | Cancels current loading, decompression, compression, or saving operations.
static (Shared in Visual Basic) | CompactFile | Compacts a multiple page file by removing unused pages.
Public Method | Copy | This method copies the current ImageX object into a newly created ImageX object.
Public Method | CopyTo | Designed to make passing image data between different Accusoft components easier, this method makes a copy of this object's image data and gives the new image data to another object which can be defined in a different Accusoft assembly. When finished, both this object and the destination object will contain separate copies of the same image data.
static (Shared in Visual Basic) | CreateColorPalette | Overloaded. Creates a System.Drawing.Imaging.ColorPalette object based on the number of bits per pixel.
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | DeleteJpegComment | Deletes an existing JPEG comment string at the index specified.
static (Shared in Visual Basic) | DeletePage | Deletes a page from a multi-page document.
static (Shared in Visual Basic) | DeletePages | Deletes one or more pages from a multi-page document.
Public Method | Dispose | Releases all resources used by this ImageX object.
static (Shared in Visual Basic) | DisposeHbitmap | Disposes an HBITMAP object.
static (Shared in Visual Basic) | DisposeHdib | Disposes an HDIB object.
static (Shared in Visual Basic) | FromBitmap | Creates an ImageX object from the given System.Drawing.Bitmap object.
static (Shared in Visual Basic) | FromByteArray | Overloaded. Returns an ImageX object from the given ImagXpress instance and byte array.
static (Shared in Visual Basic) | FromFile | Overloaded. This method allows the loading of a specific file.
static (Shared in Visual Basic) | FromHbitmap | Overloaded. Creates an ImageX object from the given Hbitmap object.
static (Shared in Visual Basic) | FromHdib | Overloaded. Creates an ImageX object from the given hdib object.
static (Shared in Visual Basic) | FromStream | Overloaded. Returns an ImageX object from the given ImagXpress instance and stream.
Public Method | GetGraphics | Gets a System.Drawing.Graphics object with the image selected into it for drawing on the image.
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
static (Shared in Visual Basic) | InsertPage | Inserts a new page into a multi-page document.
static (Shared in Visual Basic) | InsertPages | Inserts one or more new pages into a multi-page document.
static (Shared in Visual Basic) | NumPages | Returns the number of image pages from the given multiple page PDF, TIFF or DCX file.
static (Shared in Visual Basic) | QueryBuffer | Overloaded. Query buffer for image information such as width, height, bitdepth and image data type.
static (Shared in Visual Basic) | QueryFile | Overloaded. Returns information about an image file without loading the image into ImagXpress.
static (Shared in Visual Basic) | QueryFromStream | Overloaded. Query buffer stream for image information such as width, height, bitdepth and image data type.
static (Shared in Visual Basic) | ReadAllMetaData | Perferred method for obtaining all Meta-data items. Simply fetch the tag collections with ImageX.IptcDataSet and ImageX.Tags; Later that object can be passed to the SaveAllMetaData to save all edits
Public Method | ReleaseGraphics | Overloaded. Releases the previously received System.Drawing.Graphics object.
Public Method | ReturnJpegComment | Returns a JPEG String from the loaded JPEG file if one exists.
Public Method | Save | Overloaded. Save the image to a given filename.
static (Shared in Visual Basic) | SaveAllMetaData | The preferred method for saving Tiff, Exif, and Iptc meta-data.
Public Method | SaveStream | Overloaded. Saves the current ImageX object to a stream object in the specified file format.
Public Method | ToBitmap | Gets a System.Drawing.Bitmap object from the ImageX object.
Public Method | ToHbitmap | Gets a handle to a bitmap.
Public Method | ToHdib | Gets a handle to an DIB (Device Independent Bitmap).
Public Method | TransferTo | Designed to make passing image data between different Accusoft components easier, this method transfers this object's image data to another object which can be defined in a different Accusoft assembly. When finished, this object will no longer contain image data; the image data will be owned by the destination object.
Public Method | Undo | Undoes the action of the previous image processing method if the UndoEnabled property was set true prior to performing this method.
Top
See Also

Reference

ImageX Class
Accusoft.ImagXpressSdk Namespace


ImageX Constructor

ImageX Constructor

Accusoft.ImagXpressSdk Namespace > ImageX Class : ImageX Constructor
Overload List
Overload | Description
ImageX Constructor(ImagXpress) | To initialize a new instance of the ImagXpress object.
ImageX Constructor(ImagXpress,Int32,Int32,Int32,Color) | Initializes a new instance of the ImageX class.
ImageX Constructor(ImagXpress,Int32,Int32,Int32,Color,Resolution,Boolean) | Initializes a new instance of the ImageX class.
See Also

Reference

ImageX Class
ImageX Members


ImageX Constructor(ImagXpress)

ImageX Constructor(ImagXpress)

Accusoft.ImagXpressSdk Namespace > ImageX Class > ImageX Constructor : ImageX Constructor(ImagXpress)
A new ImagXpress object to initialize.
To initialize a new instance of the ImagXpress object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal imagXpress As ImagXpress _
)
'Usage

Dim imagXpress As ImagXpress

Dim instance As New ImageX(imagXpress)
public ImageX(
   ImagXpress imagXpress
)
public: ImageX(
   ImagXpress* imagXpress
)
public:
ImageX(
   ImagXpress^ imagXpress
)

Parameters

imagXpress
A new ImagXpress object to initialize.
Remarks

The ImageX object implements the IDisposable interface and the application is required to call the Dispose method when the application is done with ImageX object, otherwise memory may leak.

See Also

Reference

ImageX Class
ImageX Members
Overload List


ImageX Constructor(ImagXpress,Int32,Int32,Int32,Color)

ImageX Constructor(ImagXpress,Int32,Int32,Int32,Color)

Accusoft.ImagXpressSdk Namespace > ImageX Class > ImageX Constructor : ImageX Constructor(ImagXpress,Int32,Int32,Int32,Color)
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
An integer which represents the width.
An integer which represents the height.
An integer which represents the bits per pixel.
Color of the background.
Initializes a new instance of the ImageX class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal imagXpress As ImagXpress, _
   ByVal width As Integer, _
   ByVal height As Integer, _
   ByVal bitsPerPixel As Integer, _
   ByVal backColor As Color _
)
'Usage

Dim imagXpress As ImagXpress
Dim width As Integer
Dim height As Integer
Dim bitsPerPixel As Integer
Dim backColor As Color

Dim instance As New ImageX(imagXpress, width, height, bitsPerPixel, backColor)
public ImageX(
   ImagXpress imagXpress,
   int width,
   int height,
   int bitsPerPixel,
   Color backColor
)
public: ImageX(
   ImagXpress* imagXpress,
   int width,
   int height,
   int bitsPerPixel,
   Color backColor
)
public:
ImageX(
   ImagXpress^ imagXpress,
   int width,
   int height,
   int bitsPerPixel,
   Color backColor
)

Parameters

imagXpress
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
width
An integer which represents the width.
height
An integer which represents the height.
bitsPerPixel
An integer which represents the bits per pixel.
backColor
Color of the background.
Remarks

The ImageX object implements the IDisposable interface and the application is required to call the Dispose method when the application is done with ImageX object, otherwise memory may leak.

See Also

Reference

ImageX Class
ImageX Members
Overload List


ImageX Constructor(ImagXpress,Int32,Int32,Int32,Color,Resolution,Boolean)

ImageX Constructor(ImagXpress,Int32,Int32,Int32,Color,Resolution,Boolean)

Accusoft.ImagXpressSdk Namespace > ImageX Class > ImageX Constructor : ImageX Constructor(ImagXpress,Int32,Int32,Int32,Color,Resolution,Boolean)
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
An integer which represents the width.
An integer which represents the height.
An integer which represents the bits per pixel.
Color of the back.
The resolution.
A boolean value which, if set to true, indicates that a real image will not actually be used and image rendering will instead be handled exclusively through a custom implementation of the PaintImage event. This is an advanced option and should typically be set to false.
Initializes a new instance of the ImageX class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal imagXpress As ImagXpress, _
   ByVal width As Integer, _
   ByVal height As Integer, _
   ByVal bitsPerPixel As Integer, _
   ByVal backColor As Color, _
   ByVal resolution As Resolution, _
   ByVal virtualImage As Boolean _
)
'Usage

Dim imagXpress As ImagXpress
Dim width As Integer
Dim height As Integer
Dim bitsPerPixel As Integer
Dim backColor As Color
Dim resolution As Resolution
Dim virtualImage As Boolean

Dim instance As New ImageX(imagXpress, width, height, bitsPerPixel, backColor, resolution, virtualImage)
public ImageX(
   ImagXpress imagXpress,
   int width,
   int height,
   int bitsPerPixel,
   Color backColor,
   Resolution resolution,
   bool virtualImage
)
public: ImageX(
   ImagXpress* imagXpress,
   int width,
   int height,
   int bitsPerPixel,
   Color backColor,
   Resolution* resolution,
   bool virtualImage
)
public:
ImageX(
   ImagXpress^ imagXpress,
   int width,
   int height,
   int bitsPerPixel,
   Color backColor,
   Resolution^ resolution,
   bool virtualImage
)

Parameters

imagXpress
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
width
An integer which represents the width.
height
An integer which represents the height.
bitsPerPixel
An integer which represents the bits per pixel.
backColor
Color of the back.
resolution
The resolution.
virtualImage
A boolean value which, if set to true, indicates that a real image will not actually be used and image rendering will instead be handled exclusively through a custom implementation of the PaintImage event. This is an advanced option and should typically be set to false.
Remarks

A virtual image for all practical purposes is a blank canvas that the application can use in conjunction with the PaintImage event to control rendering of an image. The scrollbars, zoom factor and other attributes of the view are maintained by ImagXpress. This could be used to break a large image into smaller images or tiles for reducing the memory footprint of the application. This is advanced functionality and not recommended for use unless there is a extremely valid reason to use it.

The ImageX object implements the IDisposable interface and the application is required to call the Dispose method when the application is done with ImageX object, otherwise memory may leak.

See Also

Reference

ImageX Class
ImageX Members
Overload List


ImageX Class Methods

ImageX Class Methods

Accusoft.ImagXpressSdk Namespace : ImageX Class

For a list of all members of this type, see ImageX members.

Public Methods
 | Name | Description
Public Method | AddJpegComment | Adds a new comment from an opened JPEG file or a comment for a file to be saved as a JPEG file. The comment will be added when the current image is written out (saved) as a JPEG file.
Public Method | CadFileClose | Closes the CAD file.
static (Shared in Visual Basic) | CadFileOpen | Overloaded. Opens the CAD file for repeated renderings of differently selected layers and layouts.
Public Method | CadFileView | Overloaded. The CAD file view.
Public Method | Cancel | Cancels current loading, decompression, compression, or saving operations.
static (Shared in Visual Basic) | CompactFile | Compacts a multiple page file by removing unused pages.
Public Method | Copy | This method copies the current ImageX object into a newly created ImageX object.
Public Method | CopyTo | Designed to make passing image data between different Accusoft components easier, this method makes a copy of this object's image data and gives the new image data to another object which can be defined in a different Accusoft assembly. When finished, both this object and the destination object will contain separate copies of the same image data.
static (Shared in Visual Basic) | CreateColorPalette | Overloaded. Creates a System.Drawing.Imaging.ColorPalette object based on the number of bits per pixel.
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | DeleteJpegComment | Deletes an existing JPEG comment string at the index specified.
static (Shared in Visual Basic) | DeletePage | Deletes a page from a multi-page document.
static (Shared in Visual Basic) | DeletePages | Deletes one or more pages from a multi-page document.
Public Method | Dispose | Releases all resources used by this ImageX object.
static (Shared in Visual Basic) | DisposeHbitmap | Disposes an HBITMAP object.
static (Shared in Visual Basic) | DisposeHdib | Disposes an HDIB object.
static (Shared in Visual Basic) | FromBitmap | Creates an ImageX object from the given System.Drawing.Bitmap object.
static (Shared in Visual Basic) | FromByteArray | Overloaded. Returns an ImageX object from the given ImagXpress instance and byte array.
static (Shared in Visual Basic) | FromFile | Overloaded. This method allows the loading of a specific file.
static (Shared in Visual Basic) | FromHbitmap | Overloaded. Creates an ImageX object from the given Hbitmap object.
static (Shared in Visual Basic) | FromHdib | Overloaded. Creates an ImageX object from the given hdib object.
static (Shared in Visual Basic) | FromStream | Overloaded. Returns an ImageX object from the given ImagXpress instance and stream.
Public Method | GetGraphics | Gets a System.Drawing.Graphics object with the image selected into it for drawing on the image.
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
static (Shared in Visual Basic) | InsertPage | Inserts a new page into a multi-page document.
static (Shared in Visual Basic) | InsertPages | Inserts one or more new pages into a multi-page document.
static (Shared in Visual Basic) | NumPages | Returns the number of image pages from the given multiple page PDF, TIFF or DCX file.
static (Shared in Visual Basic) | QueryBuffer | Overloaded. Query buffer for image information such as width, height, bitdepth and image data type.
static (Shared in Visual Basic) | QueryFile | Overloaded. Returns information about an image file without loading the image into ImagXpress.
static (Shared in Visual Basic) | QueryFromStream | Overloaded. Query buffer stream for image information such as width, height, bitdepth and image data type.
static (Shared in Visual Basic) | ReadAllMetaData | Perferred method for obtaining all Meta-data items. Simply fetch the tag collections with ImageX.IptcDataSet and ImageX.Tags; Later that object can be passed to the SaveAllMetaData to save all edits
Public Method | ReleaseGraphics | Overloaded. Releases the previously received System.Drawing.Graphics object.
Public Method | ReturnJpegComment | Returns a JPEG String from the loaded JPEG file if one exists.
Public Method | Save | Overloaded. Save the image to a given filename.
static (Shared in Visual Basic) | SaveAllMetaData | The preferred method for saving Tiff, Exif, and Iptc meta-data.
Public Method | SaveStream | Overloaded. Saves the current ImageX object to a stream object in the specified file format.
Public Method | ToBitmap | Gets a System.Drawing.Bitmap object from the ImageX object.
Public Method | ToHbitmap | Gets a handle to a bitmap.
Public Method | ToHdib | Gets a handle to an DIB (Device Independent Bitmap).
Public Method | TransferTo | Designed to make passing image data between different Accusoft components easier, this method transfers this object's image data to another object which can be defined in a different Accusoft assembly. When finished, this object will no longer contain image data; the image data will be owned by the destination object.
Public Method | Undo | Undoes the action of the previous image processing method if the UndoEnabled property was set true prior to performing this method.
Top
See Also

Reference

ImageX Class
Accusoft.ImagXpressSdk Namespace


AddJpegComment Method

AddJpegComment Method

Accusoft.ImagXpressSdk Namespace > ImageX Class : AddJpegComment Method
An integer value which represents the index at which the comment is added.
A string value which represents the comment to be added to the list.
Adds a new comment from an opened JPEG file or a comment for a file to be saved as a JPEG file. The comment will be added when the current image is written out (saved) as a JPEG file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub AddJpegComment( _
   ByVal Index As Integer, _
   ByVal comment As String _
)
'Usage

Dim instance As ImageX
Dim Index As Integer
Dim comment As String

instance.AddJpegComment(Index, comment)
public void AddJpegComment(
   int Index,
   string comment
)
public: void AddJpegComment(
   int Index,
   string* comment
)
public:
void AddJpegComment(
   int Index,
   String^ comment
)

Parameters

Index
An integer value which represents the index at which the comment is added.
comment
A string value which represents the comment to be added to the list.
See Also

Reference

ImageX Class
ImageX Members


CadFileClose Method

CadFileClose Method

Accusoft.ImagXpressSdk Namespace > ImageX Class : CadFileClose Method
Closes the CAD file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub CadFileClose()
'Usage

Dim instance As ImageX

instance.CadFileClose()
public void CadFileClose()
public: void CadFileClose();
public:
void CadFileClose();
Remarks

Must be called after a CadFileOpen(ImagXpress,String) has been invoked to close the CAD file when finished viewing the various renderings from CadFileView.

Note: Available in Professional edition.

See Also

Reference

ImageX Class
ImageX Members


CadFileOpen Method

CadFileOpen Method

Accusoft.ImagXpressSdk Namespace > ImageX Class : CadFileOpen Method
Opens the CAD file for repeated renderings of differently selected layers and layouts.
Overload List
Overload | Description
CadFileOpen(ImagXpress,String) | Opens the CAD file for repeated renderings of differently selected layers and layouts.
CadFileOpen(ImagXpress,String,LoadOptions) | Opens the CAD file for repeated renderings of differently selected layers and layouts.
See Also

Reference

ImageX Class
ImageX Members


CadFileOpen(ImagXpress,String) Method

CadFileOpen(ImagXpress,String) Method

Accusoft.ImagXpressSdk Namespace > ImageX Class > CadFileOpen Method : CadFileOpen(ImagXpress,String) Method
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
The filename.
Opens the CAD file for repeated renderings of differently selected layers and layouts.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function CadFileOpen( _
   ByVal imagXpress As ImagXpress, _
   ByVal filename As String _
) As ImageX
'Usage

Dim imagXpress As ImagXpress
Dim filename As String
Dim value As ImageX

value = ImageX.CadFileOpen(imagXpress, filename)
public static ImageX CadFileOpen(
   ImagXpress imagXpress,
   string filename
)
public: static ImageX* CadFileOpen(
   ImagXpress* imagXpress,
   string* filename
)
public:
static ImageX^ CadFileOpen(
   ImagXpress^ imagXpress,
   String^ filename
)

Parameters

imagXpress
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
filename
The filename.

Return Value

An ImageX object containing a representation of the CAD file.
Remarks

Typically, an application calls the FromFile(ImagXpress,String) method to open a file but CAD files have many different perspective views depending on the selectiom of layouts and layers.

While FromFile(ImagXpress,String) works with CAD files, it is very inefficient because subsequent requests must rebuild internal data tables on each evocation. This method keeps the internal tables and reference objects available for subsequent viewing by CadFileView. Without any CAD loadoptions selected, the default layout and layers are rendered at the default paper size and resolution.

To terminate the viewing and remove the tables, call the CadFileClose method.

The ImageX object implements the IDisposable interface and the application is required to call the Dispose method when the application is done with ImageX object, otherwise memory may leak.

Note: This method does not support asynchronous operations nor support of annotations for adding or viewing.

Note: Available in Professional edition.

See Also

Reference

ImageX Class
ImageX Members
Overload List


CadFileOpen(ImagXpress,String,LoadOptions) Method

CadFileOpen(ImagXpress,String,LoadOptions) Method

Accusoft.ImagXpressSdk Namespace > ImageX Class > CadFileOpen Method : CadFileOpen(ImagXpress,String,LoadOptions) Method
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
A string value which represents the filename.
The load options.
Opens the CAD file for repeated renderings of differently selected layers and layouts.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function CadFileOpen( _
   ByVal imagXpress As ImagXpress, _
   ByVal filename As String, _
   ByVal loadOptions As LoadOptions _
) As ImageX
'Usage

Dim imagXpress As ImagXpress
Dim filename As String
Dim loadOptions As LoadOptions
Dim value As ImageX

value = ImageX.CadFileOpen(imagXpress, filename, loadOptions)
public static ImageX CadFileOpen(
   ImagXpress imagXpress,
   string filename,
   LoadOptions loadOptions
)
public: static ImageX* CadFileOpen(
   ImagXpress* imagXpress,
   string* filename,
   LoadOptions* loadOptions
)
public:
static ImageX^ CadFileOpen(
   ImagXpress^ imagXpress,
   String^ filename,
   LoadOptions^ loadOptions
)

Parameters

imagXpress
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
filename
A string value which represents the filename.
loadOptions
The load options.

Return Value

An ImageX object containing a representation of the CAD file.
Remarks

Typically, an application calls the FromFile(ImagXpress,String,LoadOptions) method to open a file but CAD files have many different perspective views depending on the selectiom of layouts and layers.

While FromFile(ImagXpress,String,LoadOptions) works with CAD files, it is very inefficient because subsequent requests must rebuild internal data tables on each evocation. This method keeps the internal tables and reference objects available for subsequent viewing by CadFileView(LoadOptions). Without any CAD loadoptions selected, the default layout and layers are rendered at the default paper size and resolution.

To terminate the viewing and remove the tables, call the CadFileClose method.

The ImageX object implements the IDisposable interface and the application is required to call the Dispose method when the application is done with ImageX object, otherwise memory may leak.

Note: This method does not support asynchronous operaions nor support of annotations for adding or viewing.

Note: Available in Professional edition.

See Also

Reference

ImageX Class
ImageX Members
Overload List


CadFileView Method

CadFileView Method

Accusoft.ImagXpressSdk Namespace > ImageX Class : CadFileView Method
The CAD file view.
Overload List
Overload | Description
CadFileView() | The CAD file view.
CadFileView(LoadOptions) | Changes the CAD file view.
See Also

Reference

ImageX Class
ImageX Members


CadFileView() Method

CadFileView() Method

Accusoft.ImagXpressSdk Namespace > ImageX Class > CadFileView Method : CadFileView() Method
The CAD file view.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub CadFileView()
'Usage

Dim instance As ImageX

instance.CadFileView()
public void CadFileView()
public: void CadFileView();
public:
void CadFileView();
Remarks

The loadoptions selects the layout and layers to be rendered. The paper size options determine the image width and height along with the crop parameters which select what portion of the image to render.

This method must have been preceded by calling the CadFileOpen(ImagXpress,String) method before it is called for the first time. It may be called multiple times since CadFileOpen(ImagXpress,String) but eventually succeeded with a CadFileClose method.

Note: This method does not support asynchronous operaions nor support of annotations for adding or viewing.

Note: Available in Professional edition.

See Also

Reference

ImageX Class
ImageX Members
Overload List


CadFileView(LoadOptions) Method

CadFileView(LoadOptions) Method

Accusoft.ImagXpressSdk Namespace > ImageX Class > CadFileView Method : CadFileView(LoadOptions) Method
The load options.
Changes the CAD file view.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub CadFileView( _
   ByVal loadOptions As LoadOptions _
)
'Usage

Dim instance As ImageX
Dim loadOptions As LoadOptions

instance.CadFileView(loadOptions)
public void CadFileView(
   LoadOptions loadOptions
)
public: void CadFileView(
   LoadOptions* loadOptions
)
public:
void CadFileView(
   LoadOptions^ loadOptions
)

Parameters

loadOptions
The load options.
Remarks

The loadoptions selects the layout and layers to be rendered. The paper size options determine the image width and height along with the crop parameters which select what portion of the image to render.

This method must have been preceded by calling the CadFileOpen(ImagXpress,String,LoadOptions) method before it is called for the first time. It may be called multiple times since CadFileOpen(ImagXpress,String,LoadOptions) but eventually succeeded with a CadFileClose method.

Note: This method does not support asynchronous operaions nor support of annotations for adding or viewing.

Note: Available in Professional edition.

See Also

Reference

ImageX Class
ImageX Members
Overload List


Cancel Method

Cancel Method

Accusoft.ImagXpressSdk Namespace > ImageX Class : Cancel Method
Cancels current loading, decompression, compression, or saving operations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Cancel()
'Usage

Dim instance As ImageX

instance.Cancel()
public void Cancel()
public: void Cancel();
public:
void Cancel();
Remarks
Whenever the Cancel method is called, it is considered a request to cancel. The operation may be to far along to cancel or the operation may have already completed. The application should verify the state of the image after the operation has been requested to be cancelled.
See Also

Reference

ImageX Class
ImageX Members


CompactFile Method

CompactFile Method

Accusoft.ImagXpressSdk Namespace > ImageX Class : CompactFile Method
An imagXpress workspace instance.
The source TIFF or EXIF file, which is examined for unused pages.
The destination TIFF or EXIF file name, which will get the compacted file.
Compacts a multiple page file by removing unused pages.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub CompactFile( _
   ByVal imagXpress As ImagXpress, _
   ByVal srcFileName As String, _
   ByVal dstFileName As String _
)
'Usage

Dim imagXpress As ImagXpress
Dim srcFileName As String
Dim dstFileName As String

ImageX.CompactFile(imagXpress, srcFileName, dstFileName)
public static void CompactFile(
   ImagXpress imagXpress,
   string srcFileName,
   string dstFileName
)
public: static void CompactFile(
   ImagXpress* imagXpress,
   string* srcFileName,
   string* dstFileName
)
public:
static void CompactFile(
   ImagXpress^ imagXpress,
   String^ srcFileName,
   String^ dstFileName
)

Parameters

imagXpress
An imagXpress workspace instance.
srcFileName
The source TIFF or EXIF file, which is examined for unused pages.
dstFileName
The destination TIFF or EXIF file name, which will get the compacted file.
Remarks

This method is for TIFF and EXIF file formats.

Note: Available in Professional edition.

See Also

Reference

ImageX Class
ImageX Members


Copy Method (ImageX)

Copy Method (ImageX)

Accusoft.ImagXpressSdk Namespace > ImageX Class : Copy Method
This method copies the current ImageX object into a newly created ImageX object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Copy() As ImageX
'Usage

Dim instance As ImageX
Dim value As ImageX

value = instance.Copy()
public ImageX Copy()
public: ImageX* Copy();
public:
ImageX^ Copy();

Return Value

A new ImageX object that is a copy of the given ImageX object.
Remarks

The ImageX object implements the IDisposable interface and the application is required to call the Dispose method when the application is done with ImageX object, otherwise memory may leak.

See Also

Reference

ImageX Class
ImageX Members


CopyTo Method (ImageX)

CopyTo Method (ImageX)

Accusoft.ImagXpressSdk Namespace > ImageX Class : CopyTo Method
The destination object.
Designed to make passing image data between different Accusoft components easier, this method makes a copy of this object's image data and gives the new image data to another object which can be defined in a different Accusoft assembly. When finished, both this object and the destination object will contain separate copies of the same image data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub CopyTo( _
   ByVal Destination As Object _
)
'Usage

Dim instance As ImageX
Dim Destination As Object

instance.CopyTo(Destination)
public void CopyTo(
   object Destination
)
public: void CopyTo(
   Object* Destination
)
public:
void CopyTo(
   Object^ Destination
)

Parameters

Destination
The destination object.
Exceptions
Exception | Description
System.ArgumentException | Thrown when the destination object does not support being copied to.
Remarks
Not all object types are valid destinations for this method. Refer to the documentation of a particular class to see if it officially supports being the destination of a CopyTo method.
See Also

Reference

ImageX Class
ImageX Members


CreateColorPalette Method

CreateColorPalette Method

Accusoft.ImagXpressSdk Namespace > ImageX Class : CreateColorPalette Method
Creates a System.Drawing.Imaging.ColorPalette object based on the number of bits per pixel.
Overload List
Overload | Description
CreateColorPalette(Int32) | Creates a System.Drawing.Imaging.ColorPalette object based on the number of bits per pixel.
CreateColorPalette(PixelFormat) | Creates a System.Drawing.Imaging.ColorPalette object based on the pixel format specified.
See Also

Reference

ImageX Class
ImageX Members


CreateColorPalette(Int32) Method

CreateColorPalette(Int32) Method

Accusoft.ImagXpressSdk Namespace > ImageX Class > CreateColorPalette Method : CreateColorPalette(Int32) Method
An integer which represents the bits per pixel.
Creates a System.Drawing.Imaging.ColorPalette object based on the number of bits per pixel.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function CreateColorPalette( _
   ByVal bitsPerPixel As Integer _
) As ColorPalette
'Usage

Dim bitsPerPixel As Integer
Dim value As ColorPalette

value = ImageX.CreateColorPalette(bitsPerPixel)
public static ColorPalette CreateColorPalette(
   int bitsPerPixel
)
public: static ColorPalette* CreateColorPalette(
   int bitsPerPixel
)
public:
static ColorPalette^ CreateColorPalette(
   int bitsPerPixel
)

Parameters

bitsPerPixel
An integer which represents the bits per pixel.

Return Value

A System.Drawing.Imaging.ColorPalette object.
Remarks

This helper function is for convenience and can be used as a class factory for the System.Drawing.Imaging.ColorPalette class since it is a sealed class that does not allow it to be dynamically created with a new.

If the bitsPerPixel is either 1, 4 or 8, then a ColorPalette is created with 2, 16, and 256 entries respectively. Any other value will return an empty ColorPalette with zero entries.

See Also

Reference

ImageX Class
ImageX Members
Overload List


CreateColorPalette(PixelFormat) Method

CreateColorPalette(PixelFormat) Method

Accusoft.ImagXpressSdk Namespace > ImageX Class > CreateColorPalette Method : CreateColorPalette(PixelFormat) Method
A PixelFormat to specify for the color palette.
Creates a System.Drawing.Imaging.ColorPalette object based on the pixel format specified.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function CreateColorPalette( _
   ByVal pixelFormat As PixelFormat _
) As ColorPalette
'Usage

Dim pixelFormat As PixelFormat
Dim value As ColorPalette

value = ImageX.CreateColorPalette(pixelFormat)
public static ColorPalette CreateColorPalette(
   PixelFormat pixelFormat
)
public: static ColorPalette* CreateColorPalette(
   PixelFormat pixelFormat
)
public:
static ColorPalette^ CreateColorPalette(
   PixelFormat pixelFormat
)

Parameters

pixelFormat
A PixelFormat to specify for the color palette.

Return Value

A System.Drawing.Imaging.ColorPalette object.
Remarks
This helper function is for convenience and can be used as a class factory for the System.Drawing.Imaging.ColorPalette class since it is a sealed class that does not allow it to be dynamically created with a new.
See Also

Reference

ImageX Class
ImageX Members
Overload List


DeleteJpegComment Method

DeleteJpegComment Method

Accusoft.ImagXpressSdk Namespace > ImageX Class : DeleteJpegComment Method
An integer value which represents the index for the comment to delete.
Deletes an existing JPEG comment string at the index specified.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub DeleteJpegComment( _
   ByVal Index As Integer _
)
'Usage

Dim instance As ImageX
Dim Index As Integer

instance.DeleteJpegComment(Index)
public void DeleteJpegComment(
   int Index
)
public: void DeleteJpegComment(
   int Index
)
public:
void DeleteJpegComment(
   int Index
)

Parameters

Index
An integer value which represents the index for the comment to delete.
See Also

Reference

ImageX Class
ImageX Members
ReturnJpegComment Method
JpegCommentCount Property


DeletePage Method

DeletePage Method

Accusoft.ImagXpressSdk Namespace > ImageX Class : DeletePage Method
An ImagXpress workspace instance.
A string which represents the TIFF or EXIF file name.
An integer value from 0 to 65535 which represents the page to delete.

This is a one-based index.

Note: 0 is treated the same as a 1.

Deletes a page from a multi-page document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub DeletePage( _
   ByVal imagXpress As ImagXpress, _
   ByVal filename As String, _
   ByVal pageNumber As Integer _
)
'Usage

Dim imagXpress As ImagXpress
Dim filename As String
Dim pageNumber As Integer

ImageX.DeletePage(imagXpress, filename, pageNumber)
public static void DeletePage(
   ImagXpress imagXpress,
   string filename,
   int pageNumber
)
public: static void DeletePage(
   ImagXpress* imagXpress,
   string* filename,
   int pageNumber
)
public:
static void DeletePage(
   ImagXpress^ imagXpress,
   String^ filename,
   int pageNumber
)

Parameters

imagXpress
An ImagXpress workspace instance.
filename
A string which represents the TIFF or EXIF file name.
pageNumber
An integer value from 0 to 65535 which represents the page to delete.

This is a one-based index.

Note: 0 is treated the same as a 1.

Remarks

This method is for TIFF and EXIF file formats. It does not physically delete the image page from the file. It adjusts the pointers in the TIFF IFDs to point around the deleted image.

This operation will leave unused images in the file and therefore wasted space in the file. Use the CompactFile method to physically remove all unused pages in a file.

  • If an invalid format is specified for the file then a "File format unsupported" ImageXException will be thrown.
  • If the file is read-only or in-use then an "Error opening the file" ImageXException will be thrown.
  • A page number less than 0, greater than 65535 or greater than the number of pages will cause an "Invalid page number or number of pages" ImageXException to be thrown.

Note: Available in Professional edition.

See Also

Reference

ImageX Class
ImageX Members


DeletePages Method

DeletePages Method

Accusoft.ImagXpressSdk Namespace > ImageX Class : DeletePages Method
An ImagXpress workspace instance.
A string which represents the TIFF or EXIF file name.
An integer value from 0 to 65535 which represents the starting page of the pages to delete.

This is a one-based index.

Note: 0 is treated the same as a 1.

An integer value from 1 to 65535 which represents the number of pages to delete.
Deletes one or more pages from a multi-page document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub DeletePages( _
   ByVal imagXpress As ImagXpress, _
   ByVal filename As String, _
   ByVal pageNumber As Integer, _
   ByVal numberOfPages As Integer _
)
'Usage

Dim imagXpress As ImagXpress
Dim filename As String
Dim pageNumber As Integer
Dim numberOfPages As Integer

ImageX.DeletePages(imagXpress, filename, pageNumber, numberOfPages)
public static void DeletePages(
   ImagXpress imagXpress,
   string filename,
   int pageNumber,
   int numberOfPages
)
public: static void DeletePages(
   ImagXpress* imagXpress,
   string* filename,
   int pageNumber,
   int numberOfPages
)
public:
static void DeletePages(
   ImagXpress^ imagXpress,
   String^ filename,
   int pageNumber,
   int numberOfPages
)

Parameters

imagXpress
An ImagXpress workspace instance.
filename
A string which represents the TIFF or EXIF file name.
pageNumber
An integer value from 0 to 65535 which represents the starting page of the pages to delete.

This is a one-based index.

Note: 0 is treated the same as a 1.

numberOfPages
An integer value from 1 to 65535 which represents the number of pages to delete.
Remarks

This method is for TIFF and EXIF file formats. It does not physically delete the image pages from the file. It adjusts the pointers in the TIFF IFDs to point around the deleted images.

This operation will leave unused images in the file and therefore wasted space in the file. Use the CompactFile method to physically remove all unused pages in a file.

  • If an invalid format is specified for the file then a "File format unsupported" ImageXException will be thrown.
  • If the file is read-only or in-use then an "Error opening the file" ImageXException will be thrown.
  • A page number less than 0, greater than 65535 or greater than the number of pages will cause an "Invalid page number or number of pages" ImageXException to be thrown.
  • A value for number of pages that is less than 1 or greater than 65535 will cause an "Invalid page number or number of pages" ImageXException to be thrown.
  • If the page number plus the number of pages exceeds the number of pages in the document an "Invalid page number or number of pages" ImageXException will be thrown.

Note: Available in Professional edition.

See Also

Reference

ImageX Class
ImageX Members


Dispose Method (ImageX)

Dispose Method (ImageX)

Accusoft.ImagXpressSdk Namespace > ImageX Class : Dispose Method
Releases all resources used by this ImageX object.
Overload List
Overload | Description
Dispose | Releases all resources used by this ImageX object.
See Also

Reference

ImageX Class
ImageX Members


Dispose() Method

Dispose() Method

Accusoft.ImagXpressSdk Namespace > ImageX Class : Dispose() Method
Releases all resources used by this ImageX object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Dispose()
'Usage

Dim instance As ImageX

instance.Dispose()
public void Dispose()
public: void Dispose();
public:
void Dispose();
See Also

Reference

ImageX Class
ImageX Members


DisposeHbitmap Method

DisposeHbitmap Method

Accusoft.ImagXpressSdk Namespace > ImageX Class : DisposeHbitmap Method
A System.IntPtr handle to an HBITMAP object to free.
Disposes an HBITMAP object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub DisposeHbitmap( _
   ByVal hbitmap As IntPtr _
)
'Usage

Dim hbitmap As IntPtr

ImageX.DisposeHbitmap(hbitmap)
public static void DisposeHbitmap(
   IntPtr hbitmap
)
public: static void DisposeHbitmap(
   IntPtr hbitmap
)
public:
static void DisposeHbitmap(
   IntPtr hbitmap
)

Parameters

hbitmap
A System.IntPtr handle to an HBITMAP object to free.
Remarks
This static function is a helper function so that the developer can use this function to free an HBITMAP object instead of having to call DeleteObject in gdi32.dll. This method should be called to free the HBITMAP object returned from the ToHbitmap method.
See Also

Reference

ImageX Class
ImageX Members


DisposeHdib Method

DisposeHdib Method

Accusoft.ImagXpressSdk Namespace > ImageX Class : DisposeHdib Method
A System.IntPtr handle to an HDIB object to free.
Disposes an HDIB object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub DisposeHdib( _
   ByVal Hdib As IntPtr _
)
'Usage

Dim Hdib As IntPtr

ImageX.DisposeHdib(Hdib)
public static void DisposeHdib(
   IntPtr Hdib
)
public: static void DisposeHdib(
   IntPtr Hdib
)
public:
static void DisposeHdib(
   IntPtr Hdib
)

Parameters

Hdib
A System.IntPtr handle to an HDIB object to free.
Remarks
This static function is a helper function so that the developer can use this function to free an HDIB instead of having to call GlobalFree in Kernel32.dll. Use this method for any HDIB's that have been returned from ToHdib(Boolean) and not assigned to another ImageX object with the FromHdib(ImagXpress,IntPtr,Boolean) (Accusoft.ImagXpressSdk.ImagXpress imagXpress, IntPtr hdib, System.Boolean ownDib) method with the ownDib parameter set to true.
See Also

Reference

ImageX Class
ImageX Members


FromBitmap Method

FromBitmap Method

Accusoft.ImagXpressSdk Namespace > ImageX Class : FromBitmap Method
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
The bitmap to convert from.
Creates an ImageX object from the given System.Drawing.Bitmap object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function FromBitmap( _
   ByVal imagXpress As ImagXpress, _
   ByVal bitmap As Bitmap _
) As ImageX
'Usage

Dim imagXpress As ImagXpress
Dim bitmap As Bitmap
Dim value As ImageX

value = ImageX.FromBitmap(imagXpress, bitmap)
public static ImageX FromBitmap(
   ImagXpress imagXpress,
   Bitmap bitmap
)
public: static ImageX* FromBitmap(
   ImagXpress* imagXpress,
   Bitmap* bitmap
)
public:
static ImageX^ FromBitmap(
   ImagXpress^ imagXpress,
   Bitmap^ bitmap
)

Parameters

imagXpress
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
bitmap
The bitmap to convert from.

Return Value

The newly created ImageX object.
Remarks

The ImageX object implements the IDisposable interface and the application is required to call the Dispose method when the application is done with ImageX object, otherwise memory may leak.

See Also

Reference

ImageX Class
ImageX Members


FromByteArray Method

FromByteArray Method

Accusoft.ImagXpressSdk Namespace > ImageX Class : FromByteArray Method
Returns an ImageX object from the given ImagXpress instance and byte array.
Overload List
Overload | Description
FromByteArray(ImagXpress,Byte[]) | Returns an ImageX object from the given ImagXpress instance and byte array.
FromByteArray(ImagXpress,Byte[],Int32) | Returns an ImageX object from the given ImagXpress instance, byte array and page number.
FromByteArray(ImagXpress,Byte[],LoadOptions) | Returns an ImageX object from the given ImagXpress instance, byte array and load options.
FromByteArray(ImagXpress,Byte[],Int32,LoadOptions) | Returns an ImageX object from the given ImagXpress instance, byte array, page number and load options.
See Also

Reference

ImageX Class
ImageX Members


FromByteArray(ImagXpress,Byte[]) Method

FromByteArray(ImagXpress,Byte[]) Method

Accusoft.ImagXpressSdk Namespace > ImageX Class > FromByteArray Method : FromByteArray(ImagXpress,Byte[]) Method
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
A byte array to obtain the image from.
Returns an ImageX object from the given ImagXpress instance and byte array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function FromByteArray( _
   ByVal imagXpress As ImagXpress, _
   ByVal buffer() As Byte _
) As ImageX
'Usage

Dim imagXpress As ImagXpress
Dim buffer() As Byte
Dim value As ImageX

value = ImageX.FromByteArray(imagXpress, buffer)
public static ImageX FromByteArray(
   ImagXpress imagXpress,
   byte[] buffer
)
public: static ImageX* FromByteArray(
   ImagXpress* imagXpress,
   byte[]* buffer
)
public:
static ImageX^ FromByteArray(
   ImagXpress^ imagXpress,
   array<byte>^ buffer
)

Parameters

imagXpress
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
buffer
A byte array to obtain the image from.

Return Value

The newly created ImageX object.
Remarks

The ImageX object implements the IDisposable interface and the application is required to call the Dispose method when the application is done with ImageX object, otherwise memory may leak.

See Also

Reference

ImageX Class
ImageX Members
Overload List


FromByteArray(ImagXpress,Byte[],Int32) Method

FromByteArray(ImagXpress,Byte[],Int32) Method

Accusoft.ImagXpressSdk Namespace > ImageX Class > FromByteArray Method : FromByteArray(ImagXpress,Byte[],Int32) Method
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
A byte array to obtain the image from.
An integer which represents the page number.
Returns an ImageX object from the given ImagXpress instance, byte array and page number.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function FromByteArray( _
   ByVal imagXpress As ImagXpress, _
   ByVal buffer() As Byte, _
   ByVal pageNumber As Integer _
) As ImageX
'Usage

Dim imagXpress As ImagXpress
Dim buffer() As Byte
Dim pageNumber As Integer
Dim value As ImageX

value = ImageX.FromByteArray(imagXpress, buffer, pageNumber)
public static ImageX FromByteArray(
   ImagXpress imagXpress,
   byte[] buffer,
   int pageNumber
)
public: static ImageX* FromByteArray(
   ImagXpress* imagXpress,
   byte[]* buffer,
   int pageNumber
)
public:
static ImageX^ FromByteArray(
   ImagXpress^ imagXpress,
   array<byte>^ buffer,
   int pageNumber
)

Parameters

imagXpress
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
buffer
A byte array to obtain the image from.
pageNumber
An integer which represents the page number.

Return Value

The newly created ImageX object.
Remarks

The ImageX object implements the IDisposable interface and the application is required to call the Dispose method when the application is done with ImageX object, otherwise memory may leak.

See Also

Reference

ImageX Class
ImageX Members
Overload List


FromByteArray(ImagXpress,Byte[],LoadOptions) Method

FromByteArray(ImagXpress,Byte[],LoadOptions) Method

Accusoft.ImagXpressSdk Namespace > ImageX Class > FromByteArray Method : FromByteArray(ImagXpress,Byte[],LoadOptions) Method
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
A byte array to obtain the image from.
Additional load options that pertain to the image.
Returns an ImageX object from the given ImagXpress instance, byte array and load options.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function FromByteArray( _
   ByVal imagXpress As ImagXpress, _
   ByVal buffer() As Byte, _
   ByVal loadOptions As LoadOptions _
) As ImageX
'Usage

Dim imagXpress As ImagXpress
Dim buffer() As Byte
Dim loadOptions As LoadOptions
Dim value As ImageX

value = ImageX.FromByteArray(imagXpress, buffer, loadOptions)
public static ImageX FromByteArray(
   ImagXpress imagXpress,
   byte[] buffer,
   LoadOptions loadOptions
)
public: static ImageX* FromByteArray(
   ImagXpress* imagXpress,
   byte[]* buffer,
   LoadOptions* loadOptions
)
public:
static ImageX^ FromByteArray(
   ImagXpress^ imagXpress,
   array<byte>^ buffer,
   LoadOptions^ loadOptions
)

Parameters

imagXpress
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
buffer
A byte array to obtain the image from.
loadOptions
Additional load options that pertain to the image.

Return Value

The newly created ImageX object.
Remarks

The ImageX object implements the IDisposable interface and the application is required to call the Dispose method when the application is done with ImageX object, otherwise memory may leak.

See Also

Reference

ImageX Class
ImageX Members
Overload List


FromByteArray(ImagXpress,Byte[],Int32,LoadOptions) Method

FromByteArray(ImagXpress,Byte[],Int32,LoadOptions) Method

Accusoft.ImagXpressSdk Namespace > ImageX Class > FromByteArray Method : FromByteArray(ImagXpress,Byte[],Int32,LoadOptions) Method
The ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
A byte array to obtain the image from.
An integer which represents the page number.
Additional load options that pertain to the image.
Returns an ImageX object from the given ImagXpress instance, byte array, page number and load options.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function FromByteArray( _
   ByVal imagXpress As ImagXpress, _
   ByVal buffer() As Byte, _
   ByVal pageNumber As Integer, _
   ByVal loadOptions As LoadOptions _
) As ImageX
'Usage

Dim imagXpress As ImagXpress
Dim buffer() As Byte
Dim pageNumber As Integer
Dim loadOptions As LoadOptions
Dim value As ImageX

value = ImageX.FromByteArray(imagXpress, buffer, pageNumber, loadOptions)
public static ImageX FromByteArray(
   ImagXpress imagXpress,
   byte[] buffer,
   int pageNumber,
   LoadOptions loadOptions
)
public: static ImageX* FromByteArray(
   ImagXpress* imagXpress,
   byte[]* buffer,
   int pageNumber,
   LoadOptions* loadOptions
)
public:
static ImageX^ FromByteArray(
   ImagXpress^ imagXpress,
   array<byte>^ buffer,
   int pageNumber,
   LoadOptions^ loadOptions
)

Parameters

imagXpress
The ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
buffer
A byte array to obtain the image from.
pageNumber
An integer which represents the page number.
loadOptions
Additional load options that pertain to the image.

Return Value

The newly created ImageX object.
Remarks

The ImageX object implements the IDisposable interface and the application is required to call the Dispose method when the application is done with ImageX object, otherwise memory may leak.

See Also

Reference

ImageX Class
ImageX Members
Overload List


FromFile Method

FromFile Method

Accusoft.ImagXpressSdk Namespace > ImageX Class : FromFile Method
This method allows the loading of a specific file.
Overload List
Overload | Description
FromFile(ImagXpress,String) | This method allows the loading of a specific file.
FromFile(ImagXpress,String,Int32) | Loads an Image from the specified file.
FromFile(ImagXpress,String,LoadOptions) | Loads from a file, additional loading options can be specified.
FromFile(ImagXpress,String,Int32,LoadOptions) | Loads from the given file and specified load options creating a new ImagXpress workspace component.
See Also

Reference

ImageX Class
ImageX Members


FromFile(ImagXpress,String) Method

FromFile(ImagXpress,String) Method

Accusoft.ImagXpressSdk Namespace > ImageX Class > FromFile Method : FromFile(ImagXpress,String) Method
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
String value that evaluates to a valid Windows file path.
This method allows the loading of a specific file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function FromFile( _
   ByVal imagXpress As ImagXpress, _
   ByVal filename As String _
) As ImageX
'Usage

Dim imagXpress As ImagXpress
Dim filename As String
Dim value As ImageX

value = ImageX.FromFile(imagXpress, filename)
public static ImageX FromFile(
   ImagXpress imagXpress,
   string filename
)
public: static ImageX* FromFile(
   ImagXpress* imagXpress,
   string* filename
)
public:
static ImageX^ FromFile(
   ImagXpress^ imagXpress,
   String^ filename
)

Parameters

imagXpress
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
filename
String value that evaluates to a valid Windows file path.

Return Value

A newly created ImageX object.
Remarks

The decompressed image is stored in the ImageX object.

The ImageX object implements the IDisposable interface and the application is required to call the Dispose method when the application is done with ImageX object, otherwise memory may leak.

Note: PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.

See Also

Reference

ImageX Class
ImageX Members
Overload List


FromFile(ImagXpress,String,Int32) Method

FromFile(ImagXpress,String,Int32) Method

Accusoft.ImagXpressSdk Namespace > ImageX Class > FromFile Method : FromFile(ImagXpress,String,Int32) Method
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
A string which represents the filename.
An integer value which represents the page number.
Loads an Image from the specified file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function FromFile( _
   ByVal imagXpress As ImagXpress, _
   ByVal filename As String, _
   ByVal pageNumber As Integer _
) As ImageX
'Usage

Dim imagXpress As ImagXpress
Dim filename As String
Dim pageNumber As Integer
Dim value As ImageX

value = ImageX.FromFile(imagXpress, filename, pageNumber)
public static ImageX FromFile(
   ImagXpress imagXpress,
   string filename,
   int pageNumber
)
public: static ImageX* FromFile(
   ImagXpress* imagXpress,
   string* filename,
   int pageNumber
)
public:
static ImageX^ FromFile(
   ImagXpress^ imagXpress,
   String^ filename,
   int pageNumber
)

Parameters

imagXpress
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
filename
A string which represents the filename.
pageNumber
An integer value which represents the page number.

Return Value

The newly created ImageX object.
Remarks

The decompressed image is stored in the ImageX object.

The ImageX object implements the IDisposable interface and the application is required to call the Dispose method when the application is done with ImageX object, otherwise memory may leak.

Note: PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.

See Also

Reference

ImageX Class
ImageX Members
Overload List


FromFile(ImagXpress,String,LoadOptions) Method

FromFile(ImagXpress,String,LoadOptions) Method

Accusoft.ImagXpressSdk Namespace > ImageX Class > FromFile Method : FromFile(ImagXpress,String,LoadOptions) Method
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
A string value that evaluates to a valid Windows file path.
Additional loading options as they pertain to the different file formats.
Loads from a file, additional loading options can be specified.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function FromFile( _
   ByVal imagXpress As ImagXpress, _
   ByVal filename As String, _
   ByVal loadOptions As LoadOptions _
) As ImageX
'Usage

Dim imagXpress As ImagXpress
Dim filename As String
Dim loadOptions As LoadOptions
Dim value As ImageX

value = ImageX.FromFile(imagXpress, filename, loadOptions)
public static ImageX FromFile(
   ImagXpress imagXpress,
   string filename,
   LoadOptions loadOptions
)
public: static ImageX* FromFile(
   ImagXpress* imagXpress,
   string* filename,
   LoadOptions* loadOptions
)
public:
static ImageX^ FromFile(
   ImagXpress^ imagXpress,
   String^ filename,
   LoadOptions^ loadOptions
)

Parameters

imagXpress
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
filename
A string value that evaluates to a valid Windows file path.
loadOptions
Additional loading options as they pertain to the different file formats.

Return Value

A newly created ImageX object.
Remarks

The decompressed image is stored in the ImageX object.

The ImageX object implements the IDisposable interface and the application is required to call the Dispose method when the application is done with ImageX object, otherwise memory may leak.

Note: PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.

See Also

Reference

ImageX Class
ImageX Members
Overload List


FromFile(ImagXpress,String,Int32,LoadOptions) Method

FromFile(ImagXpress,String,Int32,LoadOptions) Method

Accusoft.ImagXpressSdk Namespace > ImageX Class > FromFile Method : FromFile(ImagXpress,String,Int32,LoadOptions) Method
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
A string value that represents the filename.
An integer which represents the page number from the file.
Additional loading options as they pertain to the different file for formats.
Loads from the given file and specified load options creating a new ImagXpress workspace component.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function FromFile( _
   ByVal imagXpress As ImagXpress, _
   ByVal filename As String, _
   ByVal pageNumber As Integer, _
   ByVal loadOptions As LoadOptions _
) As ImageX
'Usage

Dim imagXpress As ImagXpress
Dim filename As String
Dim pageNumber As Integer
Dim loadOptions As LoadOptions
Dim value As ImageX

value = ImageX.FromFile(imagXpress, filename, pageNumber, loadOptions)
public static ImageX FromFile(
   ImagXpress imagXpress,
   string filename,
   int pageNumber,
   LoadOptions loadOptions
)
public: static ImageX* FromFile(
   ImagXpress* imagXpress,
   string* filename,
   int pageNumber,
   LoadOptions* loadOptions
)
public:
static ImageX^ FromFile(
   ImagXpress^ imagXpress,
   String^ filename,
   int pageNumber,
   LoadOptions^ loadOptions
)

Parameters

imagXpress
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
filename
A string value that represents the filename.
pageNumber
An integer which represents the page number from the file.
loadOptions
Additional loading options as they pertain to the different file for formats.

Return Value

A newly created ImageX object.
Remarks

The decompressed image is stored in the ImageX object.

The ImageX object implements the IDisposable interface and the application is required to call the Dispose method when the application is done with ImageX object, otherwise memory may leak.

Note: PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.

See Also

Reference

ImageX Class
ImageX Members
Overload List


FromHbitmap Method

FromHbitmap Method

Accusoft.ImagXpressSdk Namespace > ImageX Class : FromHbitmap Method
Creates an ImageX object from the given Hbitmap object.
Overload List
Overload | Description
FromHbitmap(ImagXpress,IntPtr) | Creates an ImageX object from the given Hbitmap object.
FromHbitmap(ImagXpress,IntPtr,IntPtr) | Creates an ImageX object from the given Hbitmap object.
See Also

Reference

ImageX Class
ImageX Members


FromHbitmap(ImagXpress,IntPtr) Method

FromHbitmap(ImagXpress,IntPtr) Method

Accusoft.ImagXpressSdk Namespace > ImageX Class > FromHbitmap Method : FromHbitmap(ImagXpress,IntPtr) Method
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
An IntPtr which represents the bitmap handle.
Creates an ImageX object from the given Hbitmap object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function FromHbitmap( _
   ByVal imagXpress As ImagXpress, _
   ByVal Hbitmap As IntPtr _
) As ImageX
'Usage

Dim imagXpress As ImagXpress
Dim Hbitmap As IntPtr
Dim value As ImageX

value = ImageX.FromHbitmap(imagXpress, Hbitmap)
public static ImageX FromHbitmap(
   ImagXpress imagXpress,
   IntPtr Hbitmap
)
public: static ImageX* FromHbitmap(
   ImagXpress* imagXpress,
   IntPtr Hbitmap
)
public:
static ImageX^ FromHbitmap(
   ImagXpress^ imagXpress,
   IntPtr Hbitmap
)

Parameters

imagXpress
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
Hbitmap
An IntPtr which represents the bitmap handle.

Return Value

The newly created ImageX object.
Remarks

The ImageX object implements the IDisposable interface and the application is required to call the Dispose method when the application is done with ImageX object, otherwise memory may leak.

See Also

Reference

ImageX Class
ImageX Members
Overload List


FromHbitmap(ImagXpress,IntPtr,IntPtr) Method

FromHbitmap(ImagXpress,IntPtr,IntPtr) Method

Accusoft.ImagXpressSdk Namespace > ImageX Class > FromHbitmap Method : FromHbitmap(ImagXpress,IntPtr,IntPtr) Method
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
An intptr which represents the bitmap handle.
An intptr which represents the palette handle.
Creates an ImageX object from the given Hbitmap object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function FromHbitmap( _
   ByVal imagXpress As ImagXpress, _
   ByVal Hbitmap As IntPtr, _
   ByVal Hpalette As IntPtr _
) As ImageX
'Usage

Dim imagXpress As ImagXpress
Dim Hbitmap As IntPtr
Dim Hpalette As IntPtr
Dim value As ImageX

value = ImageX.FromHbitmap(imagXpress, Hbitmap, Hpalette)
public static ImageX FromHbitmap(
   ImagXpress imagXpress,
   IntPtr Hbitmap,
   IntPtr Hpalette
)
public: static ImageX* FromHbitmap(
   ImagXpress* imagXpress,
   IntPtr Hbitmap,
   IntPtr Hpalette
)
public:
static ImageX^ FromHbitmap(
   ImagXpress^ imagXpress,
   IntPtr Hbitmap,
   IntPtr Hpalette
)

Parameters

imagXpress
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
Hbitmap
An intptr which represents the bitmap handle.
Hpalette
An intptr which represents the palette handle.

Return Value

The newly created ImageX object.
Remarks

The ImageX object implements the IDisposable interface and the application is required to call the Dispose method when the application is done with ImageX object, otherwise memory may leak.

See Also

Reference

ImageX Class
ImageX Members
Overload List


FromHdib Method

FromHdib Method

Accusoft.ImagXpressSdk Namespace > ImageX Class : FromHdib Method
Creates an ImageX object from the given hdib object.
Overload List
Overload | Description
FromHdib(ImagXpress,IntPtr) | Creates an ImageX object from the given hdib object.
FromHdib(ImagXpress,IntPtr,Boolean) | Creates an ImageX object from a handle to a DIB (Device Independent Bitmap).
See Also

Reference

ImageX Class
ImageX Members


FromHdib(ImagXpress,IntPtr) Method

FromHdib(ImagXpress,IntPtr) Method

Accusoft.ImagXpressSdk Namespace > ImageX Class > FromHdib Method : FromHdib(ImagXpress,IntPtr) Method
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
An handle to a DIB (Device Independent Bitmap).
Creates an ImageX object from the given hdib object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function FromHdib( _
   ByVal imagXpress As ImagXpress, _
   ByVal hdib As IntPtr _
) As ImageX
'Usage

Dim imagXpress As ImagXpress
Dim hdib As IntPtr
Dim value As ImageX

value = ImageX.FromHdib(imagXpress, hdib)
public static ImageX FromHdib(
   ImagXpress imagXpress,
   IntPtr hdib
)
public: static ImageX* FromHdib(
   ImagXpress* imagXpress,
   IntPtr hdib
)
public:
static ImageX^ FromHdib(
   ImagXpress^ imagXpress,
   IntPtr hdib
)

Parameters

imagXpress
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
hdib
An handle to a DIB (Device Independent Bitmap).

Return Value

The ImageX object that receives the given image.
Remarks

A copy of the original image is stored in the ImageX object.

The ImageX object implements the IDisposable interface and the application is required to call the Dispose method when the application is done with ImageX object, otherwise memory may leak.

The user is responsible for freeing the Hdib and should call DisposeHdib to free the Hdib.

See Also

Reference

ImageX Class
ImageX Members
Overload List


FromHdib(ImagXpress,IntPtr,Boolean) Method

FromHdib(ImagXpress,IntPtr,Boolean) Method

Accusoft.ImagXpressSdk Namespace > ImageX Class > FromHdib Method : FromHdib(ImagXpress,IntPtr,Boolean) Method
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
A handle to a DIB
Controls whether the Dib is owned by the ImageX object and can be freed at will or if the user would like to maintain ownership of the Dib. If set to true then the user does not need to free the Hdib supplied as a parameter. If set to false then the user is responsible for freeing the Hdib and should call DisposeHdib to free the Hdib.
Creates an ImageX object from a handle to a DIB (Device Independent Bitmap).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function FromHdib( _
   ByVal imagXpress As ImagXpress, _
   ByVal hdib As IntPtr, _
   ByVal ownDib As Boolean _
) As ImageX
'Usage

Dim imagXpress As ImagXpress
Dim hdib As IntPtr
Dim ownDib As Boolean
Dim value As ImageX

value = ImageX.FromHdib(imagXpress, hdib, ownDib)
public static ImageX FromHdib(
   ImagXpress imagXpress,
   IntPtr hdib,
   bool ownDib
)
public: static ImageX* FromHdib(
   ImagXpress* imagXpress,
   IntPtr hdib,
   bool ownDib
)
public:
static ImageX^ FromHdib(
   ImagXpress^ imagXpress,
   IntPtr hdib,
   bool ownDib
)

Parameters

imagXpress
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
hdib
A handle to a DIB
ownDib
Controls whether the Dib is owned by the ImageX object and can be freed at will or if the user would like to maintain ownership of the Dib. If set to true then the user does not need to free the Hdib supplied as a parameter. If set to false then the user is responsible for freeing the Hdib and should call DisposeHdib to free the Hdib.

Return Value

An ImageX object
Remarks

The ImageX object implements the IDisposable interface and the application is required to call the Dispose method when the application is done with ImageX object, otherwise memory may leak.

See Also

Reference

ImageX Class
ImageX Members
Overload List


FromStream Method

FromStream Method

Accusoft.ImagXpressSdk Namespace > ImageX Class : FromStream Method
Returns an ImageX object from the given ImagXpress instance and stream.
Overload List
Overload | Description
FromStream(ImagXpress,Stream) | Returns an ImageX object from the given ImagXpress instance and stream.
FromStream(ImagXpress,Stream,Int32) | Returns an ImageX object from the given ImagXpress instance, stream and page number.
FromStream(ImagXpress,Stream,Int32,Int32) | Returns an ImageX object from the given ImagXpress instance, stream and page number.
FromStream(ImagXpress,Stream,LoadOptions) | Returns an ImageX object from the given ImagXpress instance, stream and load options.
FromStream(ImagXpress,Stream,Int32,LoadOptions) | Returns an ImageX object from the given ImagXpress instance, stream, page number and load options.
FromStream(ImagXpress,Stream,Int32,Int32,LoadOptions) | Returns an ImageX object from the given ImagXpress instance, stream, page number and load options.
See Also

Reference

ImageX Class
ImageX Members


FromStream(ImagXpress,Stream) Method

FromStream(ImagXpress,Stream) Method

Accusoft.ImagXpressSdk Namespace > ImageX Class > FromStream Method : FromStream(ImagXpress,Stream) Method
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
A stream to obtain the image from.
Returns an ImageX object from the given ImagXpress instance and stream.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function FromStream( _
   ByVal imagXpress As ImagXpress, _
   ByVal stream As Stream _
) As ImageX
'Usage

Dim imagXpress As ImagXpress
Dim stream As Stream
Dim value As ImageX

value = ImageX.FromStream(imagXpress, stream)
public static ImageX FromStream(
   ImagXpress imagXpress,
   Stream stream
)
public: static ImageX* FromStream(
   ImagXpress* imagXpress,
   Stream* stream
)
public:
static ImageX^ FromStream(
   ImagXpress^ imagXpress,
   Stream^ stream
)

Parameters

imagXpress
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
stream
A stream to obtain the image from.

Return Value

The newly created ImageX object.
Remarks

The ImageX object implements the IDisposable interface and the application is required to call the Dispose method when the application is done with ImageX object, otherwise memory may leak.

Note: PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.

See Also

Reference

ImageX Class
ImageX Members
Overload List


FromStream(ImagXpress,Stream,Int32) Method

FromStream(ImagXpress,Stream,Int32) Method

Accusoft.ImagXpressSdk Namespace > ImageX Class > FromStream Method : FromStream(ImagXpress,Stream,Int32) Method
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
A stream to obtain the image from.
An integer which represents the page number.
Returns an ImageX object from the given ImagXpress instance, stream and page number.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function FromStream( _
   ByVal imagXpress As ImagXpress, _
   ByVal stream As Stream, _
   ByVal pageNumber As Integer _
) As ImageX
'Usage

Dim imagXpress As ImagXpress
Dim stream As Stream
Dim pageNumber As Integer
Dim value As ImageX

value = ImageX.FromStream(imagXpress, stream, pageNumber)
public static ImageX FromStream(
   ImagXpress imagXpress,
   Stream stream,
   int pageNumber
)
public: static ImageX* FromStream(
   ImagXpress* imagXpress,
   Stream* stream,
   int pageNumber
)
public:
static ImageX^ FromStream(
   ImagXpress^ imagXpress,
   Stream^ stream,
   int pageNumber
)

Parameters

imagXpress
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
stream
A stream to obtain the image from.
pageNumber
An integer which represents the page number.

Return Value

The newly created ImageX object.
Remarks

The ImageX object implements the IDisposable interface and the application is required to call the Dispose method when the application is done with ImageX object, otherwise memory may leak.

Note: PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.

See Also

Reference

ImageX Class
ImageX Members
Overload List


FromStream(ImagXpress,Stream,Int32,Int32) Method

FromStream(ImagXpress,Stream,Int32,Int32) Method

Accusoft.ImagXpressSdk Namespace > ImageX Class > FromStream Method : FromStream(ImagXpress,Stream,Int32,Int32) Method
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
A stream to obtain the image from.
An integer which represents the page number.
An integer which represents the number of bytes to read in at one time. The range for this parameter is from 4096 bytes to 1048576 bytes.
Returns an ImageX object from the given ImagXpress instance, stream and page number.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function FromStream( _
   ByVal imagXpress As ImagXpress, _
   ByVal stream As Stream, _
   ByVal pageNumber As Integer, _
   ByVal numberOfBytesToRequestAtEachRead As Integer _
) As ImageX
'Usage

Dim imagXpress As ImagXpress
Dim stream As Stream
Dim pageNumber As Integer
Dim numberOfBytesToRequestAtEachRead As Integer
Dim value As ImageX

value = ImageX.FromStream(imagXpress, stream, pageNumber, numberOfBytesToRequestAtEachRead)
public static ImageX FromStream(
   ImagXpress imagXpress,
   Stream stream,
   int pageNumber,
   int numberOfBytesToRequestAtEachRead
)
public: static ImageX* FromStream(
   ImagXpress* imagXpress,
   Stream* stream,
   int pageNumber,
   int numberOfBytesToRequestAtEachRead
)
public:
static ImageX^ FromStream(
   ImagXpress^ imagXpress,
   Stream^ stream,
   int pageNumber,
   int numberOfBytesToRequestAtEachRead
)

Parameters

imagXpress
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
stream
A stream to obtain the image from.
pageNumber
An integer which represents the page number.
numberOfBytesToRequestAtEachRead
An integer which represents the number of bytes to read in at one time. The range for this parameter is from 4096 bytes to 1048576 bytes.

Return Value

The newly created ImageX object.
Remarks

Note: Loading CameraRaw files from a stream is not supported as the entire image must be loaded before the CameraRaw format can be recognized. When LoadOptions.CameraRawEnabled = true, the CameraRaw image can only be loaded from a file.

The ImageX object implements the IDisposable interface and the application is required to call the Dispose method when the application is done with ImageX object, otherwise memory may leak.

Note: PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.

See Also

Reference

ImageX Class
ImageX Members
Overload List


FromStream(ImagXpress,Stream,LoadOptions) Method

FromStream(ImagXpress,Stream,LoadOptions) Method

Accusoft.ImagXpressSdk Namespace > ImageX Class > FromStream Method : FromStream(ImagXpress,Stream,LoadOptions) Method
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
A stream to obtain the image from.
Additional load options that pertain to the image.
Returns an ImageX object from the given ImagXpress instance, stream and load options.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function FromStream( _
   ByVal imagXpress As ImagXpress, _
   ByVal stream As Stream, _
   ByVal loadOptions As LoadOptions _
) As ImageX
'Usage

Dim imagXpress As ImagXpress
Dim stream As Stream
Dim loadOptions As LoadOptions
Dim value As ImageX

value = ImageX.FromStream(imagXpress, stream, loadOptions)
public static ImageX FromStream(
   ImagXpress imagXpress,
   Stream stream,
   LoadOptions loadOptions
)
public: static ImageX* FromStream(
   ImagXpress* imagXpress,
   Stream* stream,
   LoadOptions* loadOptions
)
public:
static ImageX^ FromStream(
   ImagXpress^ imagXpress,
   Stream^ stream,
   LoadOptions^ loadOptions
)

Parameters

imagXpress
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
stream
A stream to obtain the image from.
loadOptions
Additional load options that pertain to the image.

Return Value

The newly created ImageX object.
Remarks

Note: Loading CameraRaw files from a stream is not supported as the entire image must be loaded before the CameraRaw format can be recognized. When LoadOptions.CameraRawEnabled = true, the CameraRaw image can only be loaded from a file.

The ImageX object implements the IDisposable interface and the application is required to call the Dispose method when the application is done with ImageX object, otherwise memory may leak.

Note: PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.

See Also

Reference

ImageX Class
ImageX Members
Overload List


FromStream(ImagXpress,Stream,Int32,LoadOptions) Method

FromStream(ImagXpress,Stream,Int32,LoadOptions) Method

Accusoft.ImagXpressSdk Namespace > ImageX Class > FromStream Method : FromStream(ImagXpress,Stream,Int32,LoadOptions) Method
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
A stream to obtain the image from.
An integer which represents the page number.
Additional load options that pertain to the image.
Returns an ImageX object from the given ImagXpress instance, stream, page number and load options.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function FromStream( _
   ByVal imagXpress As ImagXpress, _
   ByVal stream As Stream, _
   ByVal pageNumber As Integer, _
   ByVal loadOptions As LoadOptions _
) As ImageX
'Usage

Dim imagXpress As ImagXpress
Dim stream As Stream
Dim pageNumber As Integer
Dim loadOptions As LoadOptions
Dim value As ImageX

value = ImageX.FromStream(imagXpress, stream, pageNumber, loadOptions)
public static ImageX FromStream(
   ImagXpress imagXpress,
   Stream stream,
   int pageNumber,
   LoadOptions loadOptions
)
public: static ImageX* FromStream(
   ImagXpress* imagXpress,
   Stream* stream,
   int pageNumber,
   LoadOptions* loadOptions
)
public:
static ImageX^ FromStream(
   ImagXpress^ imagXpress,
   Stream^ stream,
   int pageNumber,
   LoadOptions^ loadOptions
)

Parameters

imagXpress
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
stream
A stream to obtain the image from.
pageNumber
An integer which represents the page number.
loadOptions
Additional load options that pertain to the image.

Return Value

The newly created ImageX object.
Remarks

Note: Loading CameraRaw files from a stream is not supported as the entire image must be loaded before the CameraRaw format can be recognized. When LoadOptions.CameraRawEnabled = true, the CameraRaw image can only be loaded from a file.

The ImageX object implements the IDisposable interface and the application is required to call the Dispose method when the application is done with ImageX object, otherwise memory may leak.

Note: PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.

See Also

Reference

ImageX Class
ImageX Members
Overload List


FromStream(ImagXpress,Stream,Int32,Int32,LoadOptions) Method

FromStream(ImagXpress,Stream,Int32,Int32,LoadOptions) Method

Accusoft.ImagXpressSdk Namespace > ImageX Class > FromStream Method : FromStream(ImagXpress,Stream,Int32,Int32,LoadOptions) Method
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
A stream to obtain the image from.
An integer which represents the page number.
An integer which represents the number of bytes to read in at one time. The range for this parameter is from 4096 bytes to 1048576 bytes.
Additional load options that pertain to the image.
Returns an ImageX object from the given ImagXpress instance, stream, page number and load options.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function FromStream( _
   ByVal imagXpress As ImagXpress, _
   ByVal stream As Stream, _
   ByVal pageNumber As Integer, _
   ByVal numberOfBytesToRequestAtEachRead As Integer, _
   ByVal loadOptions As LoadOptions _
) As ImageX
'Usage

Dim imagXpress As ImagXpress
Dim stream As Stream
Dim pageNumber As Integer
Dim numberOfBytesToRequestAtEachRead As Integer
Dim loadOptions As LoadOptions
Dim value As ImageX

value = ImageX.FromStream(imagXpress, stream, pageNumber, numberOfBytesToRequestAtEachRead, loadOptions)
public static ImageX FromStream(
   ImagXpress imagXpress,
   Stream stream,
   int pageNumber,
   int numberOfBytesToRequestAtEachRead,
   LoadOptions loadOptions
)
public: static ImageX* FromStream(
   ImagXpress* imagXpress,
   Stream* stream,
   int pageNumber,
   int numberOfBytesToRequestAtEachRead,
   LoadOptions* loadOptions
)
public:
static ImageX^ FromStream(
   ImagXpress^ imagXpress,
   Stream^ stream,
   int pageNumber,
   int numberOfBytesToRequestAtEachRead,
   LoadOptions^ loadOptions
)

Parameters

imagXpress
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
stream
A stream to obtain the image from.
pageNumber
An integer which represents the page number.
numberOfBytesToRequestAtEachRead
An integer which represents the number of bytes to read in at one time. The range for this parameter is from 4096 bytes to 1048576 bytes.
loadOptions
Additional load options that pertain to the image.

Return Value

The newly created ImageX object.
Remarks

Note: Loading CameraRaw files from a stream is not supported as the entire image must be loaded before the CameraRaw format can be recognized. When LoadOptions.CameraRawEnabled = true, the CameraRaw image can only be loaded from a file.

The ImageX object implements the IDisposable interface and the application is required to call the Dispose method when the application is done with ImageX object, otherwise memory may leak.

Note: PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.

See Also

Reference

ImageX Class
ImageX Members
Overload List


GetGraphics Method

GetGraphics Method

Accusoft.ImagXpressSdk Namespace > ImageX Class : GetGraphics Method
Gets a System.Drawing.Graphics object with the image selected into it for drawing on the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetGraphics() As Graphics
'Usage

Dim instance As ImageX
Dim value As Graphics

value = instance.GetGraphics()
public Graphics GetGraphics()
public: Graphics* GetGraphics();
public:
Graphics^ GetGraphics();

Return Value

A System.Drawing.Graphics object
Remarks
This routine gets a System.Drawing.Graphics object with the image selected into it. The graphics object may then be drawn upon using the standard System.Drawing.Graphics drawing methods. Do not call Dispose on this Graphics object directly but instead call the ReleaseGraphics method. An exception will be generated if more than one call to GetGraphics is done without a ReleaseGraphics being called. The ImageX object may have a new bit depth after a GetGraphics/ReleaseGraphics set of calls.
See Also

Reference

ImageX Class
ImageX Members


InsertPage Method

InsertPage Method

Accusoft.ImagXpressSdk Namespace > ImageX Class : InsertPage Method
An imagXpress workspace instance.
A string which represents the TIFF or EXIF file containing a page to be inserted into the TIFF file.
The destination TIFF or EXIF file, which includes the inserted page.
The position in the destination file at which the page is added.

This is a one-based index.

Note: 0 is treated the same as a 1. The maximum page number supported is 65535.

Inserts a new page into a multi-page document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub InsertPage( _
   ByVal imagXpress As ImagXpress, _
   ByVal srcFileName As String, _
   ByVal dstFileName As String, _
   ByVal pageNumber As Integer _
)
'Usage

Dim imagXpress As ImagXpress
Dim srcFileName As String
Dim dstFileName As String
Dim pageNumber As Integer

ImageX.InsertPage(imagXpress, srcFileName, dstFileName, pageNumber)
public static void InsertPage(
   ImagXpress imagXpress,
   string srcFileName,
   string dstFileName,
   int pageNumber
)
public: static void InsertPage(
   ImagXpress* imagXpress,
   string* srcFileName,
   string* dstFileName,
   int pageNumber
)
public:
static void InsertPage(
   ImagXpress^ imagXpress,
   String^ srcFileName,
   String^ dstFileName,
   int pageNumber
)

Parameters

imagXpress
An imagXpress workspace instance.
srcFileName
A string which represents the TIFF or EXIF file containing a page to be inserted into the TIFF file.
dstFileName
The destination TIFF or EXIF file, which includes the inserted page.
pageNumber
The position in the destination file at which the page is added.

This is a one-based index.

Note: 0 is treated the same as a 1. The maximum page number supported is 65535.

Remarks

This method is for TIFF and EXIF file formats.

  • If an invalid format is specified for the source or destination files then a "File format unsupported" ImageXException will be thrown.
  • If the destination file is read-only or in-use then an "Error opening the file" ImageXException will be thrown.
  • A page number less than 0 will cause an "Invalid page number or number of pages" ImageXException to be thrown.
  • A page number greater than 65535 will be treated as the maximum value of 65535.
  • A page number greater than the number of pages in the destination file will result in the page being appended to the end of the destination image file.
  • If the application wishes to always append the source image to the destination file then the value of System.Int32.MaxValue can be used safely for the page number.

Note: Available in Professional edition.

See Also

Reference

ImageX Class
ImageX Members


InsertPages Method

InsertPages Method

Accusoft.ImagXpressSdk Namespace > ImageX Class : InsertPages Method
An imagXpress workspace instance.
A string which represents the TIFF or EXIF file containing the pages to be inserted into the TIFF/EXIF file.
The position in the source file from where the source pages start.

This is a one-based index.

Note: 0 is treated the same as a 1. Valid values are from 0 to 65535.

The number of pages from the source file that will be inserted. Valid values are from 1 to 65535
A string which represents the TIFF or EXIF file where the pages are to be inserted.
The position in the destination file at which the pages are inserted.

This is a one-based index.

Note: 0 is treated the same as a 1. The maximum destination page number supported is 65535.

Inserts one or more new pages into a multi-page document.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub InsertPages( _
   ByVal imagXpress As ImagXpress, _
   ByVal sourceFileName As String, _
   ByVal sourcePageNumber As Integer, _
   ByVal numberOfPages As Integer, _
   ByVal destinationFileName As String, _
   ByVal destinationPageNumber As Integer _
)
'Usage

Dim imagXpress As ImagXpress
Dim sourceFileName As String
Dim sourcePageNumber As Integer
Dim numberOfPages As Integer
Dim destinationFileName As String
Dim destinationPageNumber As Integer

ImageX.InsertPages(imagXpress, sourceFileName, sourcePageNumber, numberOfPages, destinationFileName, destinationPageNumber)
public static void InsertPages(
   ImagXpress imagXpress,
   string sourceFileName,
   int sourcePageNumber,
   int numberOfPages,
   string destinationFileName,
   int destinationPageNumber
)
public: static void InsertPages(
   ImagXpress* imagXpress,
   string* sourceFileName,
   int sourcePageNumber,
   int numberOfPages,
   string* destinationFileName,
   int destinationPageNumber
)
public:
static void InsertPages(
   ImagXpress^ imagXpress,
   String^ sourceFileName,
   int sourcePageNumber,
   int numberOfPages,
   String^ destinationFileName,
   int destinationPageNumber
)

Parameters

imagXpress
An imagXpress workspace instance.
sourceFileName
A string which represents the TIFF or EXIF file containing the pages to be inserted into the TIFF/EXIF file.
sourcePageNumber
The position in the source file from where the source pages start.

This is a one-based index.

Note: 0 is treated the same as a 1. Valid values are from 0 to 65535.

numberOfPages
The number of pages from the source file that will be inserted. Valid values are from 1 to 65535
destinationFileName
A string which represents the TIFF or EXIF file where the pages are to be inserted.
destinationPageNumber
The position in the destination file at which the pages are inserted.

This is a one-based index.

Note: 0 is treated the same as a 1. The maximum destination page number supported is 65535.

Remarks

This method is for TIFF and EXIF file formats.

  • If an invalid format is specified for the source or destination files then a "File format unsupported" ImageXException will be thrown.
  • If the destination file is read-only or in-use then an "Error opening the file" ImageXException will be thrown.
  • A source or destination page number less than 0 will cause an "Invalid page number or number of pages" ImageXException to be thrown.
  • A source page number greater than 65535 will cause an "Invalid page number or number of pages" ImageXException to be thrown.
  • If the number of pages is less than 1 or greater than 65535 then an "Invalid page number or number of pages" ImageXException will be thrown.
  • If the source page number plus the number of pages exceeds the number of pages in the source file an "Invalid page number or number of pages" ImageXException will be thrown.
  • A destination page number greater than 65535 will be treated as the maximum value of 65535.
  • A destination page number greater than the number of pages in the destination file will result in the page being appended to the end of the destination image file.
  • If the application wishes to always append the source pages to the destination file then the value of System.Int32.MaxValue can be used safely for the destination page number.

Note: Available in Professional edition.

See Also

Reference

ImageX Class
ImageX Members


NumPages Method

NumPages Method

Accusoft.ImagXpressSdk Namespace > ImageX Class : NumPages Method
An imagXpress workspace instance.
A string which represents the filename.
Returns the number of image pages from the given multiple page PDF, TIFF or DCX file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function NumPages( _
   ByVal imagXpress As ImagXpress, _
   ByVal fileName As String _
) As Integer
'Usage

Dim imagXpress As ImagXpress
Dim fileName As String
Dim value As Integer

value = ImageX.NumPages(imagXpress, fileName)
public static int NumPages(
   ImagXpress imagXpress,
   string fileName
)
public: static int NumPages(
   ImagXpress* imagXpress,
   string* fileName
)
public:
static int NumPages(
   ImagXpress^ imagXpress,
   String^ fileName
)

Parameters

imagXpress
An imagXpress workspace instance.
fileName
A string which represents the filename.

Return Value

Returns the number of image pages in the given multiple page PDF, TIFF or DCX file starting at 1.
Remarks

If an error occurs, ImagXpress throws an exception message, otherwise it returns this properties value.

Note: Streaming data does not always capture the correct page count and may return -1, thus requesting a page count on streaming data is discouraged.

Note: PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.

See Also

Reference

ImageX Class
ImageX Members


QueryBuffer Method

QueryBuffer Method

Accusoft.ImagXpressSdk Namespace > ImageX Class : QueryBuffer Method
Query buffer for image information such as width, height, bitdepth and image data type.
Overload List
Overload | Description
QueryBuffer(ImagXpress,Byte[],Int32,LoadOptions) | Query buffer for image information such as width, height, bitdepth and image data type.
QueryBuffer(ImagXpress,Byte[],Int32) | Query buffer for image information such as width, height, bitdepth and image data type.
See Also

Reference

ImageX Class
ImageX Members


QueryBuffer(ImagXpress,Byte[],Int32,LoadOptions) Method

QueryBuffer(ImagXpress,Byte[],Int32,LoadOptions) Method

Accusoft.ImagXpressSdk Namespace > ImageX Class > QueryBuffer Method : QueryBuffer(ImagXpress,Byte[],Int32,LoadOptions) Method
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
A byte array which contains image information.
An integer value which represents the page number.
Additional load options which contain information about loading the image.
Query buffer for image information such as width, height, bitdepth and image data type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function QueryBuffer( _
   ByVal imagXpress As ImagXpress, _
   ByVal buffer() As Byte, _
   ByVal pageNumber As Integer, _
   ByVal loadOptions As LoadOptions _
) As ImageXData
'Usage

Dim imagXpress As ImagXpress
Dim buffer() As Byte
Dim pageNumber As Integer
Dim loadOptions As LoadOptions
Dim value As ImageXData

value = ImageX.QueryBuffer(imagXpress, buffer, pageNumber, loadOptions)
public static ImageXData QueryBuffer(
   ImagXpress imagXpress,
   byte[] buffer,
   int pageNumber,
   LoadOptions loadOptions
)
public: static ImageXData* QueryBuffer(
   ImagXpress* imagXpress,
   byte[]* buffer,
   int pageNumber,
   LoadOptions* loadOptions
)
public:
static ImageXData^ QueryBuffer(
   ImagXpress^ imagXpress,
   array<byte>^ buffer,
   int pageNumber,
   LoadOptions^ loadOptions
)

Parameters

imagXpress
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
buffer
A byte array which contains image information.
pageNumber
An integer value which represents the page number.
loadOptions
Additional load options which contain information about loading the image.

Return Value

An ImageXData object containing information about the image being queried.
Remarks
Options can select to query for other options constraints.
See Also

Reference

ImageX Class
ImageX Members
Overload List


QueryBuffer(ImagXpress,Byte[],Int32) Method

QueryBuffer(ImagXpress,Byte[],Int32) Method

Accusoft.ImagXpressSdk Namespace > ImageX Class > QueryBuffer Method : QueryBuffer(ImagXpress,Byte[],Int32) Method
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
A byte array which contains image information.
An integer value which represents a page number.
Query buffer for image information such as width, height, bitdepth and image data type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function QueryBuffer( _
   ByVal imagXpress As ImagXpress, _
   ByVal buffer() As Byte, _
   ByVal pageNumber As Integer _
) As ImageXData
'Usage

Dim imagXpress As ImagXpress
Dim buffer() As Byte
Dim pageNumber As Integer
Dim value As ImageXData

value = ImageX.QueryBuffer(imagXpress, buffer, pageNumber)
public static ImageXData QueryBuffer(
   ImagXpress imagXpress,
   byte[] buffer,
   int pageNumber
)
public: static ImageXData* QueryBuffer(
   ImagXpress* imagXpress,
   byte[]* buffer,
   int pageNumber
)
public:
static ImageXData^ QueryBuffer(
   ImagXpress^ imagXpress,
   array<byte>^ buffer,
   int pageNumber
)

Parameters

imagXpress
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
buffer
A byte array which contains image information.
pageNumber
An integer value which represents a page number.

Return Value

Options can select to query for other options constraints.
See Also

Reference

ImageX Class
ImageX Members
Overload List


QueryFile Method

QueryFile Method

Accusoft.ImagXpressSdk Namespace > ImageX Class : QueryFile Method
Returns information about an image file without loading the image into ImagXpress.
Overload List
Overload | Description
QueryFile(ImagXpress,String) | Returns information about an image file without loading the image into ImagXpress.
QueryFile(ImagXpress,String,Int32) | Returns information about an image file from the given filename and page number.
QueryFile(ImagXpress,String,Int32,LoadOptions) | Returns an ImageXData object from the given filename, page number and load options.
See Also

Reference

ImageX Class
ImageX Members


QueryFile(ImagXpress,String) Method

QueryFile(ImagXpress,String) Method

Accusoft.ImagXpressSdk Namespace > ImageX Class > QueryFile Method : QueryFile(ImagXpress,String) Method
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
A string which represents the file name.
Returns information about an image file without loading the image into ImagXpress.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function QueryFile( _
   ByVal imagXpress As ImagXpress, _
   ByVal filename As String _
) As ImageXData
'Usage

Dim imagXpress As ImagXpress
Dim filename As String
Dim value As ImageXData

value = ImageX.QueryFile(imagXpress, filename)
public static ImageXData QueryFile(
   ImagXpress imagXpress,
   string filename
)
public: static ImageXData* QueryFile(
   ImagXpress* imagXpress,
   string* filename
)
public:
static ImageXData^ QueryFile(
   ImagXpress^ imagXpress,
   String^ filename
)

Parameters

imagXpress
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
filename
A string which represents the file name.

Return Value

An ImageXData object containing information about the image being queried.
See Also

Reference

ImageX Class
ImageX Members
Overload List


QueryFile(ImagXpress,String,Int32) Method

QueryFile(ImagXpress,String,Int32) Method

Accusoft.ImagXpressSdk Namespace > ImageX Class > QueryFile Method : QueryFile(ImagXpress,String,Int32) Method
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
A string which represents the file name.
An integer which represents the page number within the file.
Returns information about an image file from the given filename and page number.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function QueryFile( _
   ByVal imagXpress As ImagXpress, _
   ByVal filename As String, _
   ByVal pageNumber As Integer _
) As ImageXData
'Usage

Dim imagXpress As ImagXpress
Dim filename As String
Dim pageNumber As Integer
Dim value As ImageXData

value = ImageX.QueryFile(imagXpress, filename, pageNumber)
public static ImageXData QueryFile(
   ImagXpress imagXpress,
   string filename,
   int pageNumber
)
public: static ImageXData* QueryFile(
   ImagXpress* imagXpress,
   string* filename,
   int pageNumber
)
public:
static ImageXData^ QueryFile(
   ImagXpress^ imagXpress,
   String^ filename,
   int pageNumber
)

Parameters

imagXpress
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
filename
A string which represents the file name.
pageNumber
An integer which represents the page number within the file.

Return Value

An ImageXData object containing information about the image being queried.
See Also

Reference

ImageX Class
ImageX Members
Overload List


QueryFile(ImagXpress,String,Int32,LoadOptions) Method

QueryFile(ImagXpress,String,Int32,LoadOptions) Method

Accusoft.ImagXpressSdk Namespace > ImageX Class > QueryFile Method : QueryFile(ImagXpress,String,Int32,LoadOptions) Method
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
A string value which represents the file name.
An integer which represents the page number.
Load options associated with the given image.
Returns an ImageXData object from the given filename, page number and load options.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function QueryFile( _
   ByVal imagXpress As ImagXpress, _
   ByVal filename As String, _
   ByVal pageNumber As Integer, _
   ByVal loadOptions As LoadOptions _
) As ImageXData
'Usage

Dim imagXpress As ImagXpress
Dim filename As String
Dim pageNumber As Integer
Dim loadOptions As LoadOptions
Dim value As ImageXData

value = ImageX.QueryFile(imagXpress, filename, pageNumber, loadOptions)
public static ImageXData QueryFile(
   ImagXpress imagXpress,
   string filename,
   int pageNumber,
   LoadOptions loadOptions
)
public: static ImageXData* QueryFile(
   ImagXpress* imagXpress,
   string* filename,
   int pageNumber,
   LoadOptions* loadOptions
)
public:
static ImageXData^ QueryFile(
   ImagXpress^ imagXpress,
   String^ filename,
   int pageNumber,
   LoadOptions^ loadOptions
)

Parameters

imagXpress
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
filename
A string value which represents the file name.
pageNumber
An integer which represents the page number.
loadOptions
Load options associated with the given image.

Return Value

An ImageXData object containing information about the image being queried.
See Also

Reference

ImageX Class
ImageX Members
Overload List


QueryFromStream Method

QueryFromStream Method

Accusoft.ImagXpressSdk Namespace > ImageX Class : QueryFromStream Method
Query buffer stream for image information such as width, height, bitdepth and image data type.
Overload List
Overload | Description
QueryFromStream(ImagXpress,Stream,Int32) | Query buffer stream for image information such as width, height, bitdepth and image data type.
QueryFromStream(ImagXpress,Stream,Int32,LoadOptions) | Query buffer stream for image information such as width, height, bitdepth and image data type. Options can select to query for other options constraints.
See Also

Reference

ImageX Class
ImageX Members


QueryFromStream(ImagXpress,Stream,Int32) Method

QueryFromStream(ImagXpress,Stream,Int32) Method

Accusoft.ImagXpressSdk Namespace > ImageX Class > QueryFromStream Method : QueryFromStream(ImagXpress,Stream,Int32) Method
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
A stream which contains image information.
An integer value which represents the page number.
Query buffer stream for image information such as width, height, bitdepth and image data type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function QueryFromStream( _
   ByVal imagXpress As ImagXpress, _
   ByVal stream As Stream, _
   ByVal pageNumber As Integer _
) As ImageXData
'Usage

Dim imagXpress As ImagXpress
Dim stream As Stream
Dim pageNumber As Integer
Dim value As ImageXData

value = ImageX.QueryFromStream(imagXpress, stream, pageNumber)
public static ImageXData QueryFromStream(
   ImagXpress imagXpress,
   Stream stream,
   int pageNumber
)
public: static ImageXData* QueryFromStream(
   ImagXpress* imagXpress,
   Stream* stream,
   int pageNumber
)
public:
static ImageXData^ QueryFromStream(
   ImagXpress^ imagXpress,
   Stream^ stream,
   int pageNumber
)

Parameters

imagXpress
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
stream
A stream which contains image information.
pageNumber
An integer value which represents the page number.

Return Value

An ImageXData object containing information about the image being queried.
See Also

Reference

ImageX Class
ImageX Members
Overload List


QueryFromStream(ImagXpress,Stream,Int32,LoadOptions) Method

QueryFromStream(ImagXpress,Stream,Int32,LoadOptions) Method

Accusoft.ImagXpressSdk Namespace > ImageX Class > QueryFromStream Method : QueryFromStream(ImagXpress,Stream,Int32,LoadOptions) Method
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
A stream which contains image information.
An integer value which represents the page number.
Additional load options which contain data for loading the image.
Query buffer stream for image information such as width, height, bitdepth and image data type. Options can select to query for other options constraints.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function QueryFromStream( _
   ByVal imagXpress As ImagXpress, _
   ByVal stream As Stream, _
   ByVal pageNumber As Integer, _
   ByVal loadOptions As LoadOptions _
) As ImageXData
'Usage

Dim imagXpress As ImagXpress
Dim stream As Stream
Dim pageNumber As Integer
Dim loadOptions As LoadOptions
Dim value As ImageXData

value = ImageX.QueryFromStream(imagXpress, stream, pageNumber, loadOptions)
public static ImageXData QueryFromStream(
   ImagXpress imagXpress,
   Stream stream,
   int pageNumber,
   LoadOptions loadOptions
)
public: static ImageXData* QueryFromStream(
   ImagXpress* imagXpress,
   Stream* stream,
   int pageNumber,
   LoadOptions* loadOptions
)
public:
static ImageXData^ QueryFromStream(
   ImagXpress^ imagXpress,
   Stream^ stream,
   int pageNumber,
   LoadOptions^ loadOptions
)

Parameters

imagXpress
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
stream
A stream which contains image information.
pageNumber
An integer value which represents the page number.
loadOptions
Additional load options which contain data for loading the image.

Return Value

An ImageXData object containing information about the image being queried.
See Also

Reference

ImageX Class
ImageX Members
Overload List


ReadAllMetaData Method

ReadAllMetaData Method

Accusoft.ImagXpressSdk Namespace > ImageX Class : ReadAllMetaData Method
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
The filename.
The page number.
Perferred method for obtaining all Meta-data items. Simply fetch the tag collections with ImageX.IptcDataSet and ImageX.Tags; Later that object can be passed to the SaveAllMetaData to save all edits
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function ReadAllMetaData( _
   ByVal imagXpress As ImagXpress, _
   ByVal filename As String, _
   ByVal pageNumber As Integer _
) As ImageX
'Usage

Dim imagXpress As ImagXpress
Dim filename As String
Dim pageNumber As Integer
Dim value As ImageX

value = ImageX.ReadAllMetaData(imagXpress, filename, pageNumber)
public static ImageX ReadAllMetaData(
   ImagXpress imagXpress,
   string filename,
   int pageNumber
)
public: static ImageX* ReadAllMetaData(
   ImagXpress* imagXpress,
   string* filename,
   int pageNumber
)
public:
static ImageX^ ReadAllMetaData(
   ImagXpress^ imagXpress,
   String^ filename,
   int pageNumber
)

Parameters

imagXpress
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
filename
The filename.
pageNumber
The page number.
Remarks

The ImageX object implements the IDisposable interface and the application is required to call the Dispose method when the application is done with ImageX object, otherwise memory may leak.

Note: Available in Professional edition.

See Also

Reference

ImageX Class
ImageX Members


ReleaseGraphics Method

ReleaseGraphics Method

Accusoft.ImagXpressSdk Namespace > ImageX Class : ReleaseGraphics Method
Releases the previously received System.Drawing.Graphics object.
Overload List
Overload | Description
ReleaseGraphics() | Releases the previously received System.Drawing.Graphics object.
ReleaseGraphics(Boolean) | Releases the previously received System.Drawing.Graphics object.
See Also

Reference

ImageX Class
ImageX Members


ReleaseGraphics() Method

ReleaseGraphics() Method

Accusoft.ImagXpressSdk Namespace > ImageX Class > ReleaseGraphics Method : ReleaseGraphics() Method
Releases the previously received System.Drawing.Graphics object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub ReleaseGraphics()
'Usage

Dim instance As ImageX

instance.ReleaseGraphics()
public void ReleaseGraphics()
public: void ReleaseGraphics();
public:
void ReleaseGraphics();

Return Value

void
Remarks
Releases the previously received Graphics object and updates the ImageX object with the image in the Graphics object. The ImageX object may have a new bit depth after a GetGraphics/ReleaseGraphics set of calls. The previously returned Graphics object is Disposed and should no longer be used. An exception will be generated if this routine is called without a matching GetGraphics call. The ImageX object may have a new bit depth after a GetGraphics/ReleaseGraphics set of calls.
See Also

Reference

ImageX Class
ImageX Members
Overload List


ReleaseGraphics(Boolean) Method

ReleaseGraphics(Boolean) Method

Accusoft.ImagXpressSdk Namespace > ImageX Class > ReleaseGraphics Method : ReleaseGraphics(Boolean) Method
Controls whether the current image is updated with the image that has been drawn upon in the graphics object.
Releases the previously received System.Drawing.Graphics object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub ReleaseGraphics( _
   ByVal update As Boolean _
)
'Usage

Dim instance As ImageX
Dim update As Boolean

instance.ReleaseGraphics(update)
public void ReleaseGraphics(
   bool update
)
public: void ReleaseGraphics(
   bool update
)
public:
void ReleaseGraphics(
   bool update
)

Parameters

update
Controls whether the current image is updated with the image that has been drawn upon in the graphics object.

Return Value

void
Remarks
If the update parameter is true then the ImageX object is update to the image in the previously returned Graphics object. If the update parameter is false then the ImageX object is not updated. In either case, the previously returned Graphics object is Disposed and should no longer be used. The ImageX object may have a new bit depth after a GetGraphics/ReleaseGraphics set of calls. An exception will be generated if this routine is called without a matching GetGraphics call. The ImageX object may have a new bit depth after a GetGraphics/ReleaseGraphics set of calls.
See Also

Reference

ImageX Class
ImageX Members
Overload List


ReturnJpegComment Method

ReturnJpegComment Method

Accusoft.ImagXpressSdk Namespace > ImageX Class : ReturnJpegComment Method
An integer which represents the index within the JPEG comment list for which the comment text is returned.
Returns a JPEG String from the loaded JPEG file if one exists.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function ReturnJpegComment( _
   ByVal Index As Integer _
) As String
'Usage

Dim instance As ImageX
Dim Index As Integer
Dim value As String

value = instance.ReturnJpegComment(Index)
public string ReturnJpegComment(
   int Index
)
public: string* ReturnJpegComment(
   int Index
)
public:
String^ ReturnJpegComment(
   int Index
)

Parameters

Index
An integer which represents the index within the JPEG comment list for which the comment text is returned.

Return Value

A string value which represents the text associated with the given comment in the JPEG comment list.
Remarks

First, get the JpegCommentCount to determine how many JPEG comment strings were found.

The index parameter begins at 1 (if any exist) and ends at count found.

See Also

Reference

ImageX Class
ImageX Members


Save Method

Save Method

Accusoft.ImagXpressSdk Namespace > ImageX Class : Save Method
Save the image to a given filename.
Overload List
Overload | Description
Save(String) | Save the image to a given filename.
Save(String,SaveOptions) | Save the image to a file giving various saving options.
See Also

Reference

ImageX Class
ImageX Members


Save(String) Method

Save(String) Method

Accusoft.ImagXpressSdk Namespace > ImageX Class > Save Method : Save(String) Method
A string value which represents the file name to save the image to.
Save the image to a given filename.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Save( _
   ByVal filename As String _
)
'Usage

Dim instance As ImageX
Dim filename As String

instance.Save(filename)
public void Save(
   string filename
)
public: void Save(
   string* filename
)
public:
void Save(
   String^ filename
)

Parameters

filename
A string value which represents the file name to save the image to.
Remarks

To save an image over the intenet, you must use SaveOptions

Note: PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.

See Also

Reference

ImageX Class
ImageX Members
Overload List


Save(String,SaveOptions) Method

Save(String,SaveOptions) Method

Accusoft.ImagXpressSdk Namespace > ImageX Class > Save Method : Save(String,SaveOptions) Method
A string value which represents the file name to save the image to.
Save options which contain information about saving the image.
Save the image to a file giving various saving options.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Save( _
   ByVal filename As String, _
   ByVal saveOptions As SaveOptions _
)
'Usage

Dim instance As ImageX
Dim filename As String
Dim saveOptions As SaveOptions

instance.Save(filename, saveOptions)
public void Save(
   string filename,
   SaveOptions saveOptions
)
public: void Save(
   string* filename,
   SaveOptions* saveOptions
)
public:
void Save(
   String^ filename,
   SaveOptions^ saveOptions
)

Parameters

filename
A string value which represents the file name to save the image to.
saveOptions
Save options which contain information about saving the image.
Remarks

Note: PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.

See Also

Reference

ImageX Class
ImageX Members
Overload List


SaveAllMetaData Method

SaveAllMetaData Method

Accusoft.ImagXpressSdk Namespace > ImageX Class : SaveAllMetaData Method
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
The meta-data collection.
The filename.
The page number.
The preferred method for saving Tiff, Exif, and Iptc meta-data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub SaveAllMetaData( _
   ByVal imagXpress As ImagXpress, _
   ByVal dataCollection As ImageX, _
   ByVal filename As String, _
   ByVal pageNumber As Integer _
)
'Usage

Dim imagXpress As ImagXpress
Dim dataCollection As ImageX
Dim filename As String
Dim pageNumber As Integer

ImageX.SaveAllMetaData(imagXpress, dataCollection, filename, pageNumber)
public static void SaveAllMetaData(
   ImagXpress imagXpress,
   ImageX dataCollection,
   string filename,
   int pageNumber
)
public: static void SaveAllMetaData(
   ImagXpress* imagXpress,
   ImageX* dataCollection,
   string* filename,
   int pageNumber
)
public:
static void SaveAllMetaData(
   ImagXpress^ imagXpress,
   ImageX^ dataCollection,
   String^ filename,
   int pageNumber
)

Parameters

imagXpress
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
dataCollection
The meta-data collection.
filename
The filename.
pageNumber
The page number.
Remarks

You should have used ReadAllMetaData to get the ImageX object housing all the meta-data elements.

Note: Available in Professional edition.

See Also

Reference

ImageX Class
ImageX Members


SaveStream Method

SaveStream Method

Accusoft.ImagXpressSdk Namespace > ImageX Class : SaveStream Method
Saves the current ImageX object to a stream object in the specified file format.
Overload List
Overload | Description
SaveStream(Stream,ImageXFormat) | Saves the current ImageX object to a stream object in the specified file format.
SaveStream(Stream,SaveOptions) | Saves the current ImageX object to a stream object using the SaveOptions class to specify format and the format's specific parameters.
See Also

Reference

ImageX Class
ImageX Members


SaveStream(Stream,ImageXFormat) Method

SaveStream(Stream,ImageXFormat) Method
Example

Accusoft.ImagXpressSdk Namespace > ImageX Class > SaveStream Method : SaveStream(Stream,ImageXFormat) Method
An opened and writable System.IO.stream derived stream object
The image file format to save the ImageX object as
Saves the current ImageX object to a stream object in the specified file format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub SaveStream( _
   ByVal stream As Stream, _
   ByVal format As ImageXFormat _
)
'Usage

Dim instance As ImageX
Dim stream As Stream
Dim format As ImageXFormat

instance.SaveStream(stream, format)
public void SaveStream(
   Stream stream,
   ImageXFormat format
)
public: void SaveStream(
   Stream* stream,
   ImageXFormat format
)
public:
void SaveStream(
   Stream^ stream,
   ImageXFormat format
)

Parameters

stream
An opened and writable System.IO.stream derived stream object
format
The image file format to save the ImageX object as
Remarks
The stream passed can be any stream derived System.IO.Stream. The stream should be opened be calling this method. The stream should also allow writes.

Note: PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.

Example
  • C#
// assume that an ImageX object has been created and is valid
// create a memory stream that will grow as needed.
System.IO.MemoryStream memoryStream = new System.IO.MemoryStream( );
// Save an ImageX object to jpg format with default parameters
imageX.SaveStream( memoryStream, Accusoft.ImagXpressSdk.ImageXFormat.Jpeg );
memoryStream.Close( );
See Also

Reference

ImageX Class
ImageX Members
Overload List


SaveStream(Stream,SaveOptions) Method

SaveStream(Stream,SaveOptions) Method
Example

Accusoft.ImagXpressSdk Namespace > ImageX Class > SaveStream Method : SaveStream(Stream,SaveOptions) Method
An opened and writable System.IO.stream derived stream object
A SaveOptions object that specifies the format as well as the format's specific parameters
Saves the current ImageX object to a stream object using the SaveOptions class to specify format and the format's specific parameters.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub SaveStream( _
   ByVal stream As Stream, _
   ByVal saveOptions As SaveOptions _
)
'Usage

Dim instance As ImageX
Dim stream As Stream
Dim saveOptions As SaveOptions

instance.SaveStream(stream, saveOptions)
public void SaveStream(
   Stream stream,
   SaveOptions saveOptions
)
public: void SaveStream(
   Stream* stream,
   SaveOptions* saveOptions
)
public:
void SaveStream(
   Stream^ stream,
   SaveOptions^ saveOptions
)

Parameters

stream
An opened and writable System.IO.stream derived stream object
saveOptions
A SaveOptions object that specifies the format as well as the format's specific parameters
Remarks
The stream passed can be any stream derived System.IO.Stream. The stream should be opened be calling this method. The stream should also allow writes.

Note: PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.

Example
  • C#
// assume that an ImageX object has been created and is valid
// create a SaveOptions object to specify format and other parameters
Accusoft.ImagXpressSdk.SaveOptions saveOptions = new Accusoft.ImagXpressSdk.SaveOptions( );
// create a memory stream that will grow as needed.
System.IO.MemoryStream memoryStream = new System.IO.MemoryStream( );
// set the format as well as specific parameters for the format
saveOptions.Format = Accusoft.ImagXpressSdk.ImageXFormat.Jpeg;
saveOptions.Jpeg.Luminance = 24;
saveOptions.Jpeg.Chrominance = 30;
// Save an ImageX object to jpg format with luminance and chrominance
imageX.SaveStream( memoryStream, saveOptions );
memoryStream.Close( );
See Also

Reference

ImageX Class
ImageX Members
Overload List


ToBitmap Method

ToBitmap Method

Accusoft.ImagXpressSdk Namespace > ImageX Class : ToBitmap Method
Controls whether the current image is released from the ImageX object
Gets a System.Drawing.Bitmap object from the ImageX object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function ToBitmap( _
   ByVal release As Boolean _
) As Bitmap
'Usage

Dim instance As ImageX
Dim release As Boolean
Dim value As Bitmap

value = instance.ToBitmap(release)
public Bitmap ToBitmap(
   bool release
)
public: Bitmap* ToBitmap(
   bool release
)
public:
Bitmap^ ToBitmap(
   bool release
)

Parameters

release
Controls whether the current image is released from the ImageX object

Return Value

A System.Drawing.Bitmap object
Remarks
If the release parameter is true then the ImageX object no longer will have a underlying image. It will be an empty image.
See Also

Reference

ImageX Class
ImageX Members


ToHbitmap Method

ToHbitmap Method

Accusoft.ImagXpressSdk Namespace > ImageX Class : ToHbitmap Method
A boolean value which controls whether the current image is released from the ImageX object.
Gets a handle to a bitmap.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function ToHbitmap( _
   ByVal release As Boolean _
) As IntPtr
'Usage

Dim instance As ImageX
Dim release As Boolean
Dim value As IntPtr

value = instance.ToHbitmap(release)
public IntPtr ToHbitmap(
   bool release
)
public: IntPtr ToHbitmap(
   bool release
)
public:
IntPtr ToHbitmap(
   bool release
)

Parameters

release
A boolean value which controls whether the current image is released from the ImageX object.

Return Value

An HBITMAP.
Remarks

If the release parameter is true, then the ImageX object no longer has an underlying image. It will be an empty image. If the release parameter is false, then a copy of the image is put into an HBITMAP object.

The HBITMAP value passed back from the ToHbitmap function is a GDI memory object and needs to be manually freed by the calling application, otherwise memory resource leaks will occur. The DisposeHbitmap method should be called to free the HBITMAP object.

See Also

Reference

ImageX Class
ImageX Members


ToHdib Method

ToHdib Method

Accusoft.ImagXpressSdk Namespace > ImageX Class : ToHdib Method
Gets a handle to an DIB (Device Independent Bitmap).
Overload List
Overload | Description
ToHdib | Gets a handle to an DIB (Device Independent Bitmap).
See Also

Reference

ImageX Class
ImageX Members


ToHdib(Boolean) Method

ToHdib(Boolean) Method

Accusoft.ImagXpressSdk Namespace > ImageX Class : ToHdib(Boolean) Method
A boolean value which controls whether the current image is released from the ImageX object.
Gets a handle to an DIB (Device Independent Bitmap).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function ToHdib( _
   ByVal release As Boolean _
) As IntPtr
'Usage

Dim instance As ImageX
Dim release As Boolean
Dim value As IntPtr

value = instance.ToHdib(release)
public IntPtr ToHdib(
   bool release
)
public: IntPtr ToHdib(
   bool release
)
public:
IntPtr ToHdib(
   bool release
)

Parameters

release
A boolean value which controls whether the current image is released from the ImageX object.

Return Value

An HDIB
Remarks

If the release parameter is true, then the ImageX object no longer has an underlying image. It will be an empty image. Otherwise, false should be set to return a copy of the underlying ImageX's HDIB.

No matter what the release parameter is, the caller will be given an HDIB that they are responsible for freeing. This HDIB value passed back from the ToHdib function is a global memory object and needs to be manually freed by the calling application otherwise memory leaks could arise.

The easiest and less resource intensive way to free the returned HDIB is to use the static DisposeHdib method.

Another way of freeing of the HDIB can be done by creating a new ImageX object using FromHdib(ImagXpress,IntPtr,Boolean) (Accusoft.ImagXpressSdk.ImagXpress imagXpress, IntPtr hdib, System.Boolean ownDib) with the ownDib parameter set to true. This will ensure the new ImageX object will take ownership of the HDIB. Then the normal ImageX's Dispose method can be called to dispose of the ImageX object and the underlying HDIB.

Note: Calling DeleteObject() will not successfully release the HDIB.

See Also

Reference

ImageX Class
ImageX Members


TransferTo Method

TransferTo Method

Accusoft.ImagXpressSdk Namespace > ImageX Class : TransferTo Method
The desintation object.
Designed to make passing image data between different Accusoft components easier, this method transfers this object's image data to another object which can be defined in a different Accusoft assembly. When finished, this object will no longer contain image data; the image data will be owned by the destination object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub TransferTo( _
   ByVal Destination As Object _
)
'Usage

Dim instance As ImageX
Dim Destination As Object

instance.TransferTo(Destination)
public void TransferTo(
   object Destination
)
public: void TransferTo(
   Object* Destination
)
public:
void TransferTo(
   Object^ Destination
)

Parameters

Destination
The desintation object.
Exceptions
Exception | Description
System.ArgumentException | Thrown when the destination object does not support being transferred to.
Remarks
Not all object types are valid destinations for this method. Refer to the documentation of a particular class to see if it officially supports being the destination of a TransferTo method.
See Also

Reference

ImageX Class
ImageX Members


Undo Method

Undo Method

Accusoft.ImagXpressSdk Namespace > ImageX Class : Undo Method
Undoes the action of the previous image processing method if the UndoEnabled property was set true prior to performing this method.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Undo()
'Usage

Dim instance As ImageX

instance.Undo()
public void Undo()
public: void Undo();
public:
void Undo();
Remarks

Undoes the action of the previous image processing method if the UndoEnabled property was set to true prior to performing the method.

See Also

Reference

ImageX Class
ImageX Members


ImageX Class Properties

ImageX Class Properties

Accusoft.ImagXpressSdk Namespace : ImageX Class

For a list of all members of this type, see ImageX members.

Public Properties
 | Name | Description
Public Property | AutoInvalidate | Gets and sets if the ImageXView object repaints whenever a change is made to the ImageX object.
Public Property | BitsPerPixel | Gets the number of bits per pixel.
Public Property | CalTags | Get and sets the String pair Modca/Cals Tags Cal Tags can only be obtainds from Modca/Cals images open by Load methods Presently, there is no way to edit Cal tags without loading and saving the image.
Public Property | ColorSpace | Gets the color space of the current image.
Public Property | Compression | Gets the compression employed on the current image.
Public Property | Filename | Gets the file name.
Public Property | Format | Gets the file format of the current image.
Public Property | Height | Gets the height value of the current image.
Public Property | HorizontalResolution | Returns the horizontal resolution of this ImageX image.
Public Property | ImageXData | Gets the ImageXData of the ImageX object.
Public Property | IptcDataSet | Gets or sets the iptc data set.
Public Property | JpegCommentCount | After opening a JPEG file, this property gets the number of JPEG App markers comments discovered.
Public Property | LoadOptions | Gets the additional load options from this ImageX object.
Public Property | ModcaTags | Gets and sets the ImageModcaCollection.
Public Property | Page | Gets and sets the page to be viewed or processed.
Public Property | PageCount | Gets the number of pages in the image beginning at 1.
Public Property | Palette | Gets or sets the color palette used for this ImageX object.
Public Property | Resolution | Gets the resolution of the ImageX image.
Public Property | ResolutionPrecision | Gets or sets the level of precision of the HorizontalResolution, VerticalResolution and Resolution returned.
Public Property | ResolutionUnits | Sets and returns the graphics units in which resolution information is specified.
Public Property | Tags | Gets and sets the tag collection associated with this ImageX image.
Public Property | UndoEnabled | Gets and sets the ability to perform the Undo method.
Public Property | VerticalResolution | Returns the vertical resolution of the ImageX image.
Public Property | Width | Gets the width value of the current image.
Top
See Also

Reference

ImageX Class
Accusoft.ImagXpressSdk Namespace


AutoInvalidate Property

AutoInvalidate Property

Accusoft.ImagXpressSdk Namespace > ImageX Class : AutoInvalidate Property
Gets and sets if the ImageXView object repaints whenever a change is made to the ImageX object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AutoInvalidate As Boolean
'Usage

Dim instance As ImageX
Dim value As Boolean

instance.AutoInvalidate = value

value = instance.AutoInvalidate
public bool AutoInvalidate {get; set;}
public: __property bool get_AutoInvalidate();
public: __property void set_AutoInvalidate(
   bool value
);
public:
property bool AutoInvalidate {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true when the ImageXView object repaints whenever a change is made to the ImageX object. Otherwise, false is returned.
See Also

Reference

ImageX Class
ImageX Members


BitsPerPixel Property (ImageX)

BitsPerPixel Property (ImageX)

Accusoft.ImagXpressSdk Namespace > ImageX Class : BitsPerPixel Property
Gets the number of bits per pixel.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property BitsPerPixel As Integer
'Usage

Dim instance As ImageX
Dim value As Integer

value = instance.BitsPerPixel
public int BitsPerPixel {get;}
public: __property int get_BitsPerPixel();
public:
property int BitsPerPixel {
   int get();
}

Property Value

An integer value which represents the number of bits per pixel.
See Also

Reference

ImageX Class
ImageX Members


CalTags Property

CalTags Property

Accusoft.ImagXpressSdk Namespace > ImageX Class : CalTags Property
Get and sets the String pair Modca/Cals Tags Cal Tags can only be obtainds from Modca/Cals images open by Load methods Presently, there is no way to edit Cal tags without loading and saving the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CalTags As ImageCalsCollection
'Usage

Dim instance As ImageX
Dim value As ImageCalsCollection

instance.CalTags = value

value = instance.CalTags
public ImageCalsCollection CalTags {get; set;}
public: __property ImageCalsCollection* get_CalTags();
public: __property void set_CalTags(
   ImageCalsCollection* value
);
public:
property ImageCalsCollection^ CalTags {
   ImageCalsCollection^ get();
   void set (    ImageCalsCollection^ value);
}

Property Value

The Cals tags.
Remarks

Note: Available in Professional edition.

See Also

Reference

ImageX Class
ImageX Members


ColorSpace Property (ImageX)

ColorSpace Property (ImageX)

Accusoft.ImagXpressSdk Namespace > ImageX Class : ColorSpace Property
Gets the color space of the current image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ColorSpace As ColorSpace
'Usage

Dim instance As ImageX
Dim value As ColorSpace

value = instance.ColorSpace
public ColorSpace ColorSpace {get;}
public: __property ColorSpace get_ColorSpace();
public:
property ColorSpace ColorSpace {
   ColorSpace get();
}

Property Value

The ColorSpace enumeration value set.
See Also

Reference

ImageX Class
ImageX Members


Compression Property (ImageX)

Compression Property (ImageX)

Accusoft.ImagXpressSdk Namespace > ImageX Class : Compression Property
Gets the compression employed on the current image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Compression As Compression
'Usage

Dim instance As ImageX
Dim value As Compression

value = instance.Compression
public Compression Compression {get;}
public: __property Compression get_Compression();
public:
property Compression Compression {
   Compression get();
}

Property Value

The Compression enumeration value set.
See Also

Reference

ImageX Class
ImageX Members


Filename Property

Filename Property

Accusoft.ImagXpressSdk Namespace > ImageX Class : Filename Property
Gets the file name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Filename As String
'Usage

Dim instance As ImageX
Dim value As String

value = instance.Filename
public string Filename {get;}
public: __property string* get_Filename();
public:
property String^ Filename {
   String^ get();
}

Property Value

The file name of the file loaded using FromFile.
See Also

Reference

ImageX Class
ImageX Members


Format Property (ImageX)

Format Property (ImageX)

Accusoft.ImagXpressSdk Namespace > ImageX Class : Format Property
Gets the file format of the current image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Format As ImageXFormat
'Usage

Dim instance As ImageX
Dim value As ImageXFormat

value = instance.Format
public ImageXFormat Format {get;}
public: __property ImageXFormat get_Format();
public:
property ImageXFormat Format {
   ImageXFormat get();
}

Property Value

The ImageXFormat enumeration value set.
See Also

Reference

ImageX Class
ImageX Members


Height Property (ImageX)

Height Property (ImageX)

Accusoft.ImagXpressSdk Namespace > ImageX Class : Height Property
Gets the height value of the current image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Height As Integer
'Usage

Dim instance As ImageX
Dim value As Integer

value = instance.Height
public int Height {get;}
public: __property int get_Height();
public:
property int Height {
   int get();
}

Property Value

An integer value which represents the height.
See Also

Reference

ImageX Class
ImageX Members


HorizontalResolution Property

HorizontalResolution Property

Accusoft.ImagXpressSdk Namespace > ImageX Class : HorizontalResolution Property
Returns the horizontal resolution of this ImageX image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property HorizontalResolution As Single
'Usage

Dim instance As ImageX
Dim value As Single

value = instance.HorizontalResolution
public float HorizontalResolution {get;}
public: __property float get_HorizontalResolution();
public:
property float HorizontalResolution {
   float get();
}
Remarks

Applies to TIFF, PCX and BMP images only.

See Also

Reference

ImageX Class
ImageX Members


ImageXData Property

ImageXData Property

Accusoft.ImagXpressSdk Namespace > ImageX Class : ImageXData Property
Gets the ImageXData of the ImageX object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ImageXData As ImageXData
'Usage

Dim instance As ImageX
Dim value As ImageXData

value = instance.ImageXData
public ImageXData ImageXData {get;}
public: __property ImageXData* get_ImageXData();
public:
property ImageXData^ ImageXData {
   ImageXData^ get();
}

Property Value

The ImageXData value.
See Also

Reference

ImageX Class
ImageX Members


IptcDataSet Property

IptcDataSet Property

Accusoft.ImagXpressSdk Namespace > ImageX Class : IptcDataSet Property
Gets or sets the iptc data set.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IptcDataSet As ImageXIptcCollection
'Usage

Dim instance As ImageX
Dim value As ImageXIptcCollection

instance.IptcDataSet = value

value = instance.IptcDataSet
public ImageXIptcCollection IptcDataSet {get; set;}
public: __property ImageXIptcCollection* get_IptcDataSet();
public: __property void set_IptcDataSet(
   ImageXIptcCollection* value
);
public:
property ImageXIptcCollection^ IptcDataSet {
   ImageXIptcCollection^ get();
   void set (    ImageXIptcCollection^ value);
}

Property Value

The iptc data set.
Remarks

Note: Available in Professional edition.

See Also

Reference

ImageX Class
ImageX Members


JpegCommentCount Property

JpegCommentCount Property

Accusoft.ImagXpressSdk Namespace > ImageX Class : JpegCommentCount Property
After opening a JPEG file, this property gets the number of JPEG App markers comments discovered.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property JpegCommentCount As Integer
'Usage

Dim instance As ImageX
Dim value As Integer

value = instance.JpegCommentCount
public int JpegCommentCount {get;}
public: __property int get_JpegCommentCount();
public:
property int JpegCommentCount {
   int get();
}

Property Value

The JPEG comment count.
See Also

Reference

ImageX Class
ImageX Members


LoadOptions Property

LoadOptions Property

Accusoft.ImagXpressSdk Namespace > ImageX Class : LoadOptions Property
Gets the additional load options from this ImageX object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property LoadOptions As LoadOptions
'Usage

Dim instance As ImageX
Dim value As LoadOptions

value = instance.LoadOptions
public LoadOptions LoadOptions {get;}
public: __property LoadOptions* get_LoadOptions();
public:
property LoadOptions^ LoadOptions {
   LoadOptions^ get();
}

Property Value

The LoadOptions set.
See Also

Reference

ImageX Class
ImageX Members


ModcaTags Property

ModcaTags Property

Accusoft.ImagXpressSdk Namespace > ImageX Class : ModcaTags Property
Gets and sets the ImageModcaCollection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ModcaTags As ImageModcaCollection
'Usage

Dim instance As ImageX
Dim value As ImageModcaCollection

instance.ModcaTags = value

value = instance.ModcaTags
public ImageModcaCollection ModcaTags {get; set;}
public: __property ImageModcaCollection* get_ModcaTags();
public: __property void set_ModcaTags(
   ImageModcaCollection* value
);
public:
property ImageModcaCollection^ ModcaTags {
   ImageModcaCollection^ get();
   void set (    ImageModcaCollection^ value);
}

Property Value

A ImageModcaCollection which contains Modca tags.
Remarks

Note: Available in Professional edition.

See Also

Reference

ImageX Class
ImageX Members


Page Property

Page Property

Accusoft.ImagXpressSdk Namespace > ImageX Class : Page Property
Gets and sets the page to be viewed or processed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Page As Integer
'Usage

Dim instance As ImageX
Dim value As Integer

instance.Page = value

value = instance.Page
public int Page {get; set;}
public: __property int get_Page();
public: __property void set_Page(
   int value
);
public:
property int Page {
   int get();
   void set (    int value);
}

Property Value

A integer value which represents the page number.
Remarks

This property is one-based, meaning 'Page = 1' is the first page. However a value of 0 will return the first page or only page of the image as well.

This property is supported in multi-page file formats including: TIFF, ICO, MODCA, DCX and PDF.

Note: PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.

See Also

Reference

ImageX Class
ImageX Members


PageCount Property

PageCount Property

Accusoft.ImagXpressSdk Namespace > ImageX Class : PageCount Property
Gets the number of pages in the image beginning at 1.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PageCount As Integer
'Usage

Dim instance As ImageX
Dim value As Integer

value = instance.PageCount
public int PageCount {get;}
public: __property int get_PageCount();
public:
property int PageCount {
   int get();
}

Property Value

An integer value which represents the number of pages.
Remarks

The default value is -1.

Note: The number of pages cannot be determined when an image is loaded using the FromStream(ImagXpress,Stream) method. This property becomes invalid in this case.

See Also

Reference

ImageX Class
ImageX Members


Palette Property

Palette Property
Example

Accusoft.ImagXpressSdk Namespace > ImageX Class : Palette Property
Gets or sets the color palette used for this ImageX object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Palette As ColorPalette
'Usage

Dim instance As ImageX
Dim value As ColorPalette

instance.Palette = value

value = instance.Palette
public ColorPalette Palette {get; set;}
public: __property ColorPalette* get_Palette();
public: __property void set_Palette(
   ColorPalette* value
);
public:
property ColorPalette^ Palette {
   ColorPalette^ get();
   void set (    ColorPalette^ value);
}
Remarks

If the ImageX does not have a palette then an empty palette is returned.

The Palette property returns and sets a palette in one operation. Like the System.Drawing.Bitmap class, the Palette can not be modified on the fly.

Example
For instance, the following code does not change the first entry in ImageX's palette to Red.
  • C#
imageX.Palette.Entries[0] = System.Drawing.Color.Red;
The following code is the correct way to modify the first entry to Red.
  • C#
System.Drawing.Imaging.ColorPalette palette;
palette = imageX.Palette;
if ( palette.Entries.Length > 0 )
{
    palette.Entries[0] = System.Drawing.Color.Red;
    imageX.Palette = palette;
}
Requirements

See Also

Reference

ImageX Class
ImageX Members


Resolution Property (ImageX)

Resolution Property (ImageX)

Accusoft.ImagXpressSdk Namespace > ImageX Class : Resolution Property
Gets the resolution of the ImageX image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Resolution As Resolution
'Usage

Dim instance As ImageX
Dim value As Resolution

value = instance.Resolution
public Resolution Resolution {get;}
public: __property Resolution* get_Resolution();
public:
property Resolution^ Resolution {
   Resolution^ get();
}

Property Value

The Resolution value.
See Also

Reference

ImageX Class
ImageX Members


ResolutionPrecision Property

ResolutionPrecision Property

Accusoft.ImagXpressSdk Namespace > ImageX Class : ResolutionPrecision Property
Gets or sets the level of precision of the HorizontalResolution, VerticalResolution and Resolution returned.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ResolutionPrecision As Integer
'Usage

Dim instance As ImageX
Dim value As Integer

instance.ResolutionPrecision = value

value = instance.ResolutionPrecision
public int ResolutionPrecision {get; set;}
public: __property int get_ResolutionPrecision();
public: __property void set_ResolutionPrecision(
   int value
);
public:
property int ResolutionPrecision {
   int get();
   void set (    int value);
}

Property Value

The level of precision of the HorizontalResolution, VerticalResolution and Resolution returned. The default value for this property is 1. This property must be a value from Resolution.MinimumPrecision to Resolution.MaximumPrecision. Setting the precision is really a request for the precision level to be at a certain level. Because of the way floating-point numbers are stored in computers, ImagXpress can not guarantee that the precision is at a certain level. If the application needs 100% accuracy, then the application should set this value to Resolution.MaximumPrecision and handle any truncation or rounding itself.
See Also

Reference

ImageX Class
ImageX Members


ResolutionUnits Property

ResolutionUnits Property

Accusoft.ImagXpressSdk Namespace > ImageX Class : ResolutionUnits Property
Sets and returns the graphics units in which resolution information is specified.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ResolutionUnits As GraphicsUnit
'Usage

Dim instance As ImageX
Dim value As GraphicsUnit

instance.ResolutionUnits = value

value = instance.ResolutionUnits
public GraphicsUnit ResolutionUnits {get; set;}
public: __property GraphicsUnit get_ResolutionUnits();
public: __property void set_ResolutionUnits(
   GraphicsUnit value
);
public:
property GraphicsUnit ResolutionUnits {
   GraphicsUnit get();
   void set (    GraphicsUnit value);
}

Property Value

The unit of measure for the ImageX image resolution.
Remarks

Applies to resolution information provided by the VerticalResolution, HorizontalResolution and Resolution properties.

See Also

Reference

ImageX Class
ImageX Members


Tags Property

Tags Property

Accusoft.ImagXpressSdk Namespace > ImageX Class : Tags Property
Gets and sets the tag collection associated with this ImageX image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Tags As ImageXTagCollection
'Usage

Dim instance As ImageX
Dim value As ImageXTagCollection

instance.Tags = value

value = instance.Tags
public ImageXTagCollection Tags {get; set;}
public: __property ImageXTagCollection* get_Tags();
public: __property void set_Tags(
   ImageXTagCollection* value
);
public:
property ImageXTagCollection^ Tags {
   ImageXTagCollection^ get();
   void set (    ImageXTagCollection^ value);
}

Property Value

An ImageXTagCollection which contains the associated tags.
Remarks

Note: Available in Professional edition.

See Also

Reference

ImageX Class
ImageX Members


UndoEnabled Property

UndoEnabled Property

Accusoft.ImagXpressSdk Namespace > ImageX Class : UndoEnabled Property
Gets and sets the ability to perform the Undo method.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property UndoEnabled As Boolean
'Usage

Dim instance As ImageX
Dim value As Boolean

instance.UndoEnabled = value

value = instance.UndoEnabled
public bool UndoEnabled {get; set;}
public: __property bool get_UndoEnabled();
public: __property void set_UndoEnabled(
   bool value
);
public:
property bool UndoEnabled {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true to allow the Undo method to be processed. Otherwise, false is returned.
Remarks

This property controls the ability to perform the Undo method. The Undo method undoes the results of an image processing method.

True — When an image processing method is invoked, the current undo image is deleted and replaced by the current image. The current image is replaced by the image resulting from the image processing method.

False — When an image processing method is invoked, the current image is deleted and replaced by the image resulting from the image processing method.

See Also

Reference

ImageX Class
ImageX Members


VerticalResolution Property

VerticalResolution Property

Accusoft.ImagXpressSdk Namespace > ImageX Class : VerticalResolution Property
Returns the vertical resolution of the ImageX image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property VerticalResolution As Single
'Usage

Dim instance As ImageX
Dim value As Single

value = instance.VerticalResolution
public float VerticalResolution {get;}
public: __property float get_VerticalResolution();
public:
property float VerticalResolution {
   float get();
}
Remarks

Applies to TIFF, PCX and BMP image only.

See Also

Reference

ImageX Class
ImageX Members


Width Property (ImageX)

Width Property (ImageX)

Accusoft.ImagXpressSdk Namespace > ImageX Class : Width Property
Gets the width value of the current image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Width As Integer
'Usage

Dim instance As ImageX
Dim value As Integer

value = instance.Width
public int Width {get;}
public: __property int get_Width();
public:
property int Width {
   int get();
}

Property Value

An integer value which represents the width.
See Also

Reference

ImageX Class
ImageX Members


ImageXData Class

ImageXData Class
Members

Accusoft.ImagXpressSdk Namespace : ImageXData Class
Implements image information pertaining to the current image.
Object Model
ImageXData ClassCadLayer ClassCadLayout ClassResolution Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImageXData
'Usage

Dim instance As ImageXData
public class ImageXData
public __gc class ImageXData
public ref class ImageXData
Inheritance Hierarchy

System.Object
Accusoft.ImagXpressSdk.ImageXData

See Also

Reference

ImageXData Members
Accusoft.ImagXpressSdk Namespace


ImageXData Class Members

ImageXData Class Members
Properties Methods

Accusoft.ImagXpressSdk Namespace : ImageXData Class

The following tables list the members exposed by ImageXData.

Public Constructors
 | Name | Description
Public Constructor | ImageXData Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BitsPerPixel | Gets the number of bits per pixel.
Public Property | ColorSpace | Gets the color space of the current image.
Public Property | Compression | Gets the compression employed on the current image.
Public Property | Format | Gets the file format of the current image.
Public Property | Height | Gets the height value of the current image.
Public Property | PhotometricInterpretation | The Photometric Interpretation of the image.
Public Property | Progressive | Gets an indicator which determines if the current image is a progressive scan image.
Public Property | Resolution | Gets the resolution for the current image.
Public Property | Size | Gets the file size of the current image file.
Public Property | Stride | Gets the number of bytes needed to advance from the beginning of one row in an image to the beginning of the next row.
Public Property | Width | Gets the width value of the current image.
Top
Public Methods
 | Name | Description
Public Method | Dispose | Releases all resources used by this ImageXData object.
Public Method | Layer | Returns information for a specific layer.
Public Method | Layout | Returns CAD Layout information.
Public Method | QueryCadFormat | Returns general information on number of cad layouts, layers, version and filetype.
Top
See Also

Reference

ImageXData Class
Accusoft.ImagXpressSdk Namespace


ImageXData Constructor

ImageXData Constructor

Accusoft.ImagXpressSdk Namespace > ImageXData Class : ImageXData Constructor
Overload List
Overload | Description
ImageXData Constructor() | Initializes a new instance of the ImageXData class.
ImageXData Constructor(Int32,IntPtr) | Initializes a new instance of the ImageXData object passing in an image ID and image pointer.
See Also

Reference

ImageXData Class
ImageXData Members


ImageXData Constructor()

ImageXData Constructor()

Accusoft.ImagXpressSdk Namespace > ImageXData Class > ImageXData Constructor : ImageXData Constructor()
Initializes a new instance of the ImageXData class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImageXData()
public ImageXData()
public: ImageXData();
public:
ImageXData();
See Also

Reference

ImageXData Class
ImageXData Members
Overload List


ImageXData Constructor(Int32,IntPtr)

ImageXData Constructor(Int32,IntPtr)

Accusoft.ImagXpressSdk Namespace > ImageXData Class > ImageXData Constructor : ImageXData Constructor(Int32,IntPtr)
An integer value which represents a unique identifier of the current image.
An integer pointer which represents a location in memory corresponding to the current image.
Initializes a new instance of the ImageXData object passing in an image ID and image pointer.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal imageId As Integer, _
   ByVal imagePointer As IntPtr _
)
'Usage

Dim imageId As Integer
Dim imagePointer As IntPtr

Dim instance As New ImageXData(imageId, imagePointer)
public ImageXData(
   int imageId,
   IntPtr imagePointer
)
public: ImageXData(
   int imageId,
   IntPtr imagePointer
)
public:
ImageXData(
   int imageId,
   IntPtr imagePointer
)

Parameters

imageId
An integer value which represents a unique identifier of the current image.
imagePointer
An integer pointer which represents a location in memory corresponding to the current image.
See Also

Reference

ImageXData Class
ImageXData Members
Overload List


Dispose Method (ImageXData)

Dispose Method (ImageXData)

Accusoft.ImagXpressSdk Namespace > ImageXData Class : Dispose Method
Releases all resources used by this ImageXData object.
Overload List
Overload | Description
Dispose | Releases all resources used by this ImageXData object.
See Also

Reference

ImageXData Class
ImageXData Members


ImageXData Class Methods

ImageXData Class Methods

Accusoft.ImagXpressSdk Namespace : ImageXData Class

For a list of all members of this type, see ImageXData members.

Public Methods
 | Name | Description
Public Method | Dispose | Releases all resources used by this ImageXData object.
Public Method | Layer | Returns information for a specific layer.
Public Method | Layout | Returns CAD Layout information.
Public Method | QueryCadFormat | Returns general information on number of cad layouts, layers, version and filetype.
Top
See Also

Reference

ImageXData Class
Accusoft.ImagXpressSdk Namespace


Dispose() Method

Dispose() Method

Accusoft.ImagXpressSdk Namespace > ImageXData Class : Dispose() Method
Releases all resources used by this ImageXData object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Dispose()
'Usage

Dim instance As ImageXData

instance.Dispose()
public void Dispose()
public: void Dispose();
public:
void Dispose();
See Also

Reference

ImageXData Class
ImageXData Members


Layer Method

Layer Method

Accusoft.ImagXpressSdk Namespace > ImageXData Class : Layer Method
An integer which represents the index of the layer.
Returns information for a specific layer.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Layer( _
   ByVal LayerIndex As Integer _
) As CadLayer
'Usage

Dim instance As ImageXData
Dim LayerIndex As Integer
Dim value As CadLayer

value = instance.Layer(LayerIndex)
public CadLayer Layer(
   int LayerIndex
)
public: CadLayer* Layer(
   int LayerIndex
)
public:
CadLayer^ Layer(
   int LayerIndex
)

Parameters

LayerIndex
An integer which represents the index of the layer.

Return Value

A CadLayer object.
Remarks

Any layer can be loaded into the LoadOptionsCad class and all changes to all layers applied will take affect.

Note: Available in Professional edition.

See Also

Reference

ImageXData Class
ImageXData Members


Layout Method

Layout Method

Accusoft.ImagXpressSdk Namespace > ImageXData Class : Layout Method
Index of the layout.
Returns CAD Layout information.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Layout( _
   ByVal LayoutIndex As Integer _
) As CadLayout
'Usage

Dim instance As ImageXData
Dim LayoutIndex As Integer
Dim value As CadLayout

value = instance.Layout(LayoutIndex)
public CadLayout Layout(
   int LayoutIndex
)
public: CadLayout* Layout(
   int LayoutIndex
)
public:
CadLayout^ Layout(
   int LayoutIndex
)

Parameters

LayoutIndex
Index of the layout.

Return Value

A CadLayout object.
Remarks

Note: QueryCadFormat must be called before this method.

Note: Available in Professional edition.

See Also

Reference

ImageXData Class
ImageXData Members


QueryCadFormat Method

QueryCadFormat Method

Accusoft.ImagXpressSdk Namespace > ImageXData Class : QueryCadFormat Method
The CadFileType which represents the type of CAD file.
The CadVersion.
An integer value which represents the layer count.
An integer value which represents the layout count.
Returns general information on number of cad layouts, layers, version and filetype.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub QueryCadFormat( _
   ByRef cadFileType As CadFileType, _
   ByRef cadVersion As CadVersion, _
   ByRef layerCount As Integer, _
   ByRef layoutCount As Integer _
)
'Usage

Dim instance As ImageXData
Dim cadFileType As CadFileType
Dim cadVersion As CadVersion
Dim layerCount As Integer
Dim layoutCount As Integer

instance.QueryCadFormat(cadFileType, cadVersion, layerCount, layoutCount)
public void QueryCadFormat(
   out CadFileType cadFileType,
   out CadVersion cadVersion,
   out int layerCount,
   out int layoutCount
)
public: void QueryCadFormat(
   [PARAMFLAG::Out] CadFileType cadFileType,
   [PARAMFLAG::Out] CadVersion cadVersion,
   [PARAMFLAG::Out] int layerCount,
   [PARAMFLAG::Out] int layoutCount
)
public:
void QueryCadFormat(
   [Out] CadFileType cadFileType,
   [Out] CadVersion cadVersion,
   [Out] int layerCount,
   [Out] int layoutCount
)

Parameters

cadFileType
The CadFileType which represents the type of CAD file.
cadVersion
The CadVersion.
layerCount
An integer value which represents the layer count.
layoutCount
An integer value which represents the layout count.
Remarks

This object must have been returned from QueryFile, QueryFromStream or QueryBuffer and the format Accusoft.ImagXpressSdk.ImageXFormat.Cad.

Note: Available in Professional edition.

See Also

Reference

ImageXData Class
ImageXData Members


ImageXData Class Properties

ImageXData Class Properties

Accusoft.ImagXpressSdk Namespace : ImageXData Class

For a list of all members of this type, see ImageXData members.

Public Properties
 | Name | Description
Public Property | BitsPerPixel | Gets the number of bits per pixel.
Public Property | ColorSpace | Gets the color space of the current image.
Public Property | Compression | Gets the compression employed on the current image.
Public Property | Format | Gets the file format of the current image.
Public Property | Height | Gets the height value of the current image.
Public Property | PhotometricInterpretation | The Photometric Interpretation of the image.
Public Property | Progressive | Gets an indicator which determines if the current image is a progressive scan image.
Public Property | Resolution | Gets the resolution for the current image.
Public Property | Size | Gets the file size of the current image file.
Public Property | Stride | Gets the number of bytes needed to advance from the beginning of one row in an image to the beginning of the next row.
Public Property | Width | Gets the width value of the current image.
Top
See Also

Reference

ImageXData Class
Accusoft.ImagXpressSdk Namespace


BitsPerPixel Property (ImageXData)

BitsPerPixel Property (ImageXData)

Accusoft.ImagXpressSdk Namespace > ImageXData Class : BitsPerPixel Property
Gets the number of bits per pixel.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property BitsPerPixel As Integer
'Usage

Dim instance As ImageXData
Dim value As Integer

value = instance.BitsPerPixel
public int BitsPerPixel {get;}
public: __property int get_BitsPerPixel();
public:
property int BitsPerPixel {
   int get();
}

Property Value

An integer value which represents the number of bits per pixel.
See Also

Reference

ImageXData Class
ImageXData Members


ColorSpace Property (ImageXData)

ColorSpace Property (ImageXData)

Accusoft.ImagXpressSdk Namespace > ImageXData Class : ColorSpace Property
Gets the color space of the current image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ColorSpace As ColorSpace
'Usage

Dim instance As ImageXData
Dim value As ColorSpace

value = instance.ColorSpace
public ColorSpace ColorSpace {get;}
public: __property ColorSpace get_ColorSpace();
public:
property ColorSpace ColorSpace {
   ColorSpace get();
}

Property Value

The ColorSpace enumeration value set.
See Also

Reference

ImageXData Class
ImageXData Members


Compression Property (ImageXData)

Compression Property (ImageXData)

Accusoft.ImagXpressSdk Namespace > ImageXData Class : Compression Property
Gets the compression employed on the current image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Compression As Compression
'Usage

Dim instance As ImageXData
Dim value As Compression

value = instance.Compression
public Compression Compression {get;}
public: __property Compression get_Compression();
public:
property Compression Compression {
   Compression get();
}

Property Value

The Compression enumeration value set.
See Also

Reference

ImageXData Class
ImageXData Members


Format Property (ImageXData)

Format Property (ImageXData)

Accusoft.ImagXpressSdk Namespace > ImageXData Class : Format Property
Gets the file format of the current image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Format As ImageXFormat
'Usage

Dim instance As ImageXData
Dim value As ImageXFormat

value = instance.Format
public ImageXFormat Format {get;}
public: __property ImageXFormat get_Format();
public:
property ImageXFormat Format {
   ImageXFormat get();
}

Property Value

The ImageXFormat enumeration value set.
See Also

Reference

ImageXData Class
ImageXData Members


Height Property (ImageXData)

Height Property (ImageXData)

Accusoft.ImagXpressSdk Namespace > ImageXData Class : Height Property
Gets the height value of the current image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Height As Integer
'Usage

Dim instance As ImageXData
Dim value As Integer

value = instance.Height
public int Height {get;}
public: __property int get_Height();
public:
property int Height {
   int get();
}

Property Value

An integer value which represents the height.
See Also

Reference

ImageXData Class
ImageXData Members


PhotometricInterpretation Property (ImageXData)

PhotometricInterpretation Property (ImageXData)

Accusoft.ImagXpressSdk Namespace > ImageXData Class : PhotometricInterpretation Property
The Photometric Interpretation of the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PhotometricInterpretation As PhotometricInterpretation
'Usage

Dim instance As ImageXData
Dim value As PhotometricInterpretation

value = instance.PhotometricInterpretation
public PhotometricInterpretation PhotometricInterpretation {get;}
public: __property PhotometricInterpretation get_PhotometricInterpretation();
public:
property PhotometricInterpretation PhotometricInterpretation {
   PhotometricInterpretation get();
}
Remarks

Note: this is only relevant if the ImageXFormat is ImageXFormat.Tiff.

See Also

Reference

ImageXData Class
ImageXData Members


Progressive Property (ImageXData)

Progressive Property (ImageXData)

Accusoft.ImagXpressSdk Namespace > ImageXData Class : Progressive Property
Gets an indicator which determines if the current image is a progressive scan image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Progressive As Boolean
'Usage

Dim instance As ImageXData
Dim value As Boolean

value = instance.Progressive
public bool Progressive {get;}
public: __property bool get_Progressive();
public:
property bool Progressive {
   bool get();
}

Property Value

A boolean value which is true if the current image is progressive. Otherwise, false is returned.
See Also

Reference

ImageXData Class
ImageXData Members


Resolution Property (ImageXData)

Resolution Property (ImageXData)

Accusoft.ImagXpressSdk Namespace > ImageXData Class : Resolution Property
Gets the resolution for the current image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Resolution As Resolution
'Usage

Dim instance As ImageXData
Dim value As Resolution

value = instance.Resolution
public Resolution Resolution {get;}
public: __property Resolution* get_Resolution();
public:
property Resolution^ Resolution {
   Resolution^ get();
}

Property Value

The Resolution value set for the current image.
See Also

Reference

ImageXData Class
ImageXData Members


Size Property

Size Property

Accusoft.ImagXpressSdk Namespace > ImageXData Class : Size Property
Gets the file size of the current image file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Size As Integer
'Usage

Dim instance As ImageXData
Dim value As Integer

value = instance.Size
public int Size {get;}
public: __property int get_Size();
public:
property int Size {
   int get();
}

Property Value

An integer value which represents the file size of the current image file.
Remarks
NOTE: This is the size of compressed image file on disk. As such, if you load from a stream, this property will be 0. If the size of the image file is required, it should be calculated from the stream.
See Also

Reference

ImageXData Class
ImageXData Members


Stride Property (ImageXData)

Stride Property (ImageXData)

Accusoft.ImagXpressSdk Namespace > ImageXData Class : Stride Property
Gets the number of bytes needed to advance from the beginning of one row in an image to the beginning of the next row.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Stride As Integer
'Usage

Dim instance As ImageXData
Dim value As Integer

value = instance.Stride
public int Stride {get;}
public: __property int get_Stride();
public:
property int Stride {
   int get();
}

Property Value

An integer value which represents the number of bytes needed to advance.
Remarks

When a (GDI) Graphical Display Interface allocates a memory buffer for bitmaps, it may pad each row of pixels with extra bytes, in order to align them on some boundary. The width of the image, in bytes, plus the width of the extra padding, is called the stride.

See Also

Reference

ImageXData Class
ImageXData Members


Width Property (ImageXData)

Width Property (ImageXData)

Accusoft.ImagXpressSdk Namespace > ImageXData Class : Width Property
Gets the width value of the current image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Width As Integer
'Usage

Dim instance As ImageXData
Dim value As Integer

value = instance.Width
public int Width {get;}
public: __property int get_Width();
public:
property int Width {
   int get();
}

Property Value

An integer value which represents the width.
See Also

Reference

ImageXData Class
ImageXData Members


ImageXException Class

ImageXException Class
Members

Accusoft.ImagXpressSdk Namespace : ImageXException Class
This class implements exceptions for the ImageX objects.
Object Model
ImageXException Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class ImageXException
   Inherits ImagXpressException
'Usage

Dim instance As ImageXException
[Serializable()]
public sealed class ImageXException : ImagXpressException
[Serializable()]
public __gc __sealed class ImageXException : public ImagXpressException
[Serializable()]
public ref class ImageXException sealed : public ImagXpressException
Inheritance Hierarchy

System.Object
System.Exception
Accusoft.ImagXpressSdk.ImagXpressException
Accusoft.ImagXpressSdk.ImageXException

See Also

Reference

ImageXException Members
Accusoft.ImagXpressSdk Namespace


ImageXException Class Members

ImageXException Class Members
Properties Methods

Accusoft.ImagXpressSdk Namespace : ImageXException Class

The following tables list the members exposed by ImageXException.

Public Constructors
 | Name | Description
Public Constructor | ImageXException Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Number | Gets the numerical equivalent for enumerated exception result. (Inherited from Accusoft.ImagXpressSdk.ImagXpressException)
Public Property | Result | Gets the enumerated exception result that has occurred. (Inherited from Accusoft.ImagXpressSdk.ImagXpressException)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

ImageXException Class
Accusoft.ImagXpressSdk Namespace


ImageXException Class Properties

ImageXException Class Properties

Accusoft.ImagXpressSdk Namespace : ImageXException Class

For a list of all members of this type, see ImageXException members.

Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Number | Gets the numerical equivalent for enumerated exception result. (Inherited from Accusoft.ImagXpressSdk.ImagXpressException)
Public Property | Result | Gets the enumerated exception result that has occurred. (Inherited from Accusoft.ImagXpressSdk.ImagXpressException)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
See Also

Reference

ImageXException Class
Accusoft.ImagXpressSdk Namespace


ImageXException Class Methods

ImageXException Class Methods

Accusoft.ImagXpressSdk Namespace : ImageXException Class

For a list of all members of this type, see ImageXException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

ImageXException Class
Accusoft.ImagXpressSdk Namespace


ImageXException Constructor

ImageXException Constructor

Accusoft.ImagXpressSdk Namespace > ImageXException Class : ImageXException Constructor
Overload List
Overload | Description
ImageXException Constructor() | The main constructor for the ImageXException class.
ImageXException Constructor(Result) | Constructor which allows passing in a result for the ImageX exceptions.
ImageXException Constructor(String) | Constructor which allows passing in a message for the ImageX exceptions.
ImageXException Constructor(Result,String) | Constructor which allows passing in a result and message for the ImageX exception.
ImageXException Constructor(String,Exception) | Constructor which allows passing in a message and inner exception.
ImageXException Constructor(Result,String,Exception) | Constructor which allows passing in a result, message and inner exception.
See Also

Reference

ImageXException Class
ImageXException Members


ImageXException Constructor()

ImageXException Constructor()

Accusoft.ImagXpressSdk Namespace > ImageXException Class > ImageXException Constructor : ImageXException Constructor()
The main constructor for the ImageXException class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImageXException()
public ImageXException()
public: ImageXException();
public:
ImageXException();
See Also

Reference

ImageXException Class
ImageXException Members
Overload List


ImageXException Constructor(Result)

ImageXException Constructor(Result)

Accusoft.ImagXpressSdk Namespace > ImageXException Class > ImageXException Constructor : ImageXException Constructor(Result)
A Result enumeration value.
Constructor which allows passing in a result for the ImageX exceptions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal result As Result _
)
'Usage

Dim result As Result

Dim instance As New ImageXException(result)
public ImageXException(
   Result result
)
public: ImageXException(
   Result result
)
public:
ImageXException(
   Result result
)

Parameters

result
A Result enumeration value.
See Also

Reference

ImageXException Class
ImageXException Members
Overload List


ImageXException Constructor(String)

ImageXException Constructor(String)

Accusoft.ImagXpressSdk Namespace > ImageXException Class > ImageXException Constructor : ImageXException Constructor(String)
A string value which represents the error message for the exception.
Constructor which allows passing in a message for the ImageX exceptions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New ImageXException(message)
public ImageXException(
   string message
)
public: ImageXException(
   string* message
)
public:
ImageXException(
   String^ message
)

Parameters

message
A string value which represents the error message for the exception.
See Also

Reference

ImageXException Class
ImageXException Members
Overload List


ImageXException Constructor(Result,String)

ImageXException Constructor(Result,String)

Accusoft.ImagXpressSdk Namespace > ImageXException Class > ImageXException Constructor : ImageXException Constructor(Result,String)
A Result enumeration value.
A string value which represents the error message for the exception.
Constructor which allows passing in a result and message for the ImageX exception.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal result As Result, _
   ByVal message As String _
)
'Usage

Dim result As Result
Dim message As String

Dim instance As New ImageXException(result, message)
public ImageXException(
   Result result,
   string message
)
public: ImageXException(
   Result result,
   string* message
)
public:
ImageXException(
   Result result,
   String^ message
)

Parameters

result
A Result enumeration value.
message
A string value which represents the error message for the exception.
See Also

Reference

ImageXException Class
ImageXException Members
Overload List


ImageXException Constructor(String,Exception)

ImageXException Constructor(String,Exception)

Accusoft.ImagXpressSdk Namespace > ImageXException Class > ImageXException Constructor : ImageXException Constructor(String,Exception)
A string value which represents the error message.
A System.Exception.
Constructor which allows passing in a message and inner exception.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New ImageXException(message, innerException)
public ImageXException(
   string message,
   Exception innerException
)
public: ImageXException(
   string* message,
   Exception* innerException
)
public:
ImageXException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string value which represents the error message.
innerException
A System.Exception.
See Also

Reference

ImageXException Class
ImageXException Members
Overload List


ImageXException Constructor(Result,String,Exception)

ImageXException Constructor(Result,String,Exception)

Accusoft.ImagXpressSdk Namespace > ImageXException Class > ImageXException Constructor : ImageXException Constructor(Result,String,Exception)
A Result enumeration value.
A string value which represents the error message.
A System.Exception
Constructor which allows passing in a result, message and inner exception.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal result As Result, _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim result As Result
Dim message As String
Dim innerException As Exception

Dim instance As New ImageXException(result, message, innerException)
public ImageXException(
   Result result,
   string message,
   Exception innerException
)
public: ImageXException(
   Result result,
   string* message,
   Exception* innerException
)
public:
ImageXException(
   Result result,
   String^ message,
   Exception^ innerException
)

Parameters

result
A Result enumeration value.
message
A string value which represents the error message.
innerException
A System.Exception
See Also

Reference

ImageXException Class
ImageXException Members
Overload List


ImageXIptcCollection Class

ImageXIptcCollection Class
Members

Accusoft.ImagXpressSdk Namespace : ImageXIptcCollection Class
This class implements a collection of ImageXIptcData objects.
Object Model
ImageXIptcCollection ClassImageXIptcData Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<SerializableAttribute()>
Public Class ImageXIptcCollection
   Inherits System.Collections.ObjectModel.Collection(Of ImageXIptcData)
'Usage

Dim instance As ImageXIptcCollection
[Serializable()]
public class ImageXIptcCollection : System.Collections.ObjectModel.Collection<ImageXIptcData>
[Serializable()]
public __gc class ImageXIptcCollection : public System.Collections.ObjectModel.Collection<ImageXIptcData>
[Serializable()]
public ref class ImageXIptcCollection : public System.Collections.ObjectModel.Collection<ImageXIptcData>
Remarks

Note: Available in Professional edition.

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
Accusoft.ImagXpressSdk.ImageXIptcCollection

See Also

Reference

ImageXIptcCollection Members
Accusoft.ImagXpressSdk Namespace


ImageXIptcCollection Class Members

ImageXIptcCollection Class Members
Properties Methods

Accusoft.ImagXpressSdk Namespace : ImageXIptcCollection Class

The following tables list the members exposed by ImageXIptcCollection.

Public Constructors
 | Name | Description
Public Constructor | ImageXIptcCollection Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<ImageXIptcData>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<ImageXIptcData>)
Top
Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<ImageXIptcData>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<ImageXIptcData>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<ImageXIptcData>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<ImageXIptcData>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<ImageXIptcData>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<ImageXIptcData>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<ImageXIptcData>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<ImageXIptcData>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<ImageXIptcData>)
Top
See Also

Reference

ImageXIptcCollection Class
Accusoft.ImagXpressSdk Namespace


ImageXIptcCollection Class Properties

ImageXIptcCollection Class Properties

Accusoft.ImagXpressSdk Namespace : ImageXIptcCollection Class

For a list of all members of this type, see ImageXIptcCollection members.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<ImageXIptcData>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<ImageXIptcData>)
Top
See Also

Reference

ImageXIptcCollection Class
Accusoft.ImagXpressSdk Namespace


ImageXIptcCollection Class Methods

ImageXIptcCollection Class Methods

Accusoft.ImagXpressSdk Namespace : ImageXIptcCollection Class

For a list of all members of this type, see ImageXIptcCollection members.

Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<ImageXIptcData>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<ImageXIptcData>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<ImageXIptcData>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<ImageXIptcData>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<ImageXIptcData>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<ImageXIptcData>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<ImageXIptcData>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<ImageXIptcData>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<ImageXIptcData>)
Top
See Also

Reference

ImageXIptcCollection Class
Accusoft.ImagXpressSdk Namespace


ImageXIptcCollection Constructor

ImageXIptcCollection Constructor

Accusoft.ImagXpressSdk Namespace > ImageXIptcCollection Class : ImageXIptcCollection Constructor
Overload List
Overload | Description
ImageXIptcCollection Constructor() | Initializes a new instance of the ImageXIptcCollection class.
ImageXIptcCollection Constructor(ImageXIptcCollection) | Initializes a new instance of the ImageXIptcCollection class.
See Also

Reference

ImageXIptcCollection Class
ImageXIptcCollection Members


ImageXIptcCollection Constructor()

ImageXIptcCollection Constructor()

Accusoft.ImagXpressSdk Namespace > ImageXIptcCollection Class > ImageXIptcCollection Constructor : ImageXIptcCollection Constructor()
Initializes a new instance of the ImageXIptcCollection class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImageXIptcCollection()
public ImageXIptcCollection()
public: ImageXIptcCollection();
public:
ImageXIptcCollection();
Remarks

Note: Available in Professional edition.

See Also

Reference

ImageXIptcCollection Class
ImageXIptcCollection Members
Overload List


ImageXIptcCollection Constructor(ImageXIptcCollection)

ImageXIptcCollection Constructor(ImageXIptcCollection)

Accusoft.ImagXpressSdk Namespace > ImageXIptcCollection Class > ImageXIptcCollection Constructor : ImageXIptcCollection Constructor(ImageXIptcCollection)
The copytag.
Initializes a new instance of the ImageXIptcCollection class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal copytag As ImageXIptcCollection _
)
'Usage

Dim copytag As ImageXIptcCollection

Dim instance As New ImageXIptcCollection(copytag)
public ImageXIptcCollection(
   ImageXIptcCollection copytag
)
public: ImageXIptcCollection(
   ImageXIptcCollection* copytag
)
public:
ImageXIptcCollection(
   ImageXIptcCollection^ copytag
)

Parameters

copytag
The copytag.
Remarks

Note: Available in Professional edition.

See Also

Reference

ImageXIptcCollection Class
ImageXIptcCollection Members
Overload List


ImageXIptcData Class

ImageXIptcData Class
Members

Accusoft.ImagXpressSdk Namespace : ImageXIptcData Class
A class for IPTC meta-data information.
Object Model
ImageXIptcData Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImageXIptcData
'Usage

Dim instance As ImageXIptcData
public class ImageXIptcData
public __gc class ImageXIptcData
public ref class ImageXIptcData
Remarks

Note: Available in Professional edition.

Inheritance Hierarchy

System.Object
Accusoft.ImagXpressSdk.ImageXIptcData

See Also

Reference

ImageXIptcData Members
Accusoft.ImagXpressSdk Namespace


ImageXIptcData Class Members

ImageXIptcData Class Members
Properties Methods

Accusoft.ImagXpressSdk Namespace : ImageXIptcData Class

The following tables list the members exposed by ImageXIptcData.

Public Constructors
 | Name | Description
Public Constructor | ImageXIptcData Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | DataField | Gets or sets the data field.
Public Property | DataFieldString | Gets or sets the data field string.
Public Property | DataSet | Gets or sets the data set.
Public Property | DataSetLength | Gets the length of the data set.
Public Property | DataSetType | Gets or sets the type of the data set.
Public Property | Record | Gets or sets the record.
Top
Public Methods
 | Name | Description
Public Method | CompareTo | Compares the current instance with another object of the same type.
Top
See Also

Reference

ImageXIptcData Class
Accusoft.ImagXpressSdk Namespace


ImageXIptcData Constructor

ImageXIptcData Constructor

Accusoft.ImagXpressSdk Namespace > ImageXIptcData Class : ImageXIptcData Constructor
Overload List
Overload | Description
ImageXIptcData Constructor(Byte,Byte,Int64,Int64,Object) | Initializes a new instance of the ImageXIptcData class.
ImageXIptcData Constructor(Byte,Byte,Int64,String) | Initializes a new instance of the ImageXIptcData class.
ImageXIptcData Constructor(Byte,Byte,Int64,Byte[]) | Initializes a new instance of the ImageXIptcData class.
See Also

Reference

ImageXIptcData Class
ImageXIptcData Members


ImageXIptcData Constructor(Byte,Byte,Int64,Int64,Object)

ImageXIptcData Constructor(Byte,Byte,Int64,Int64,Object)

Accusoft.ImagXpressSdk Namespace > ImageXIptcData Class > ImageXIptcData Constructor : ImageXIptcData Constructor(Byte,Byte,Int64,Int64,Object)
A byte value which represents the record.
A byte value which represents the data set.
An integer which represents the type of data set.
An integer value which represents the length of the data set.
An object which contains the data.
Initializes a new instance of the ImageXIptcData class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal record As Byte, _
   ByVal dataSet As Byte, _
   ByVal dataSetType As Long, _
   ByVal dataSetLength As Long, _
   ByVal data As Object _
)
'Usage

Dim record As Byte
Dim dataSet As Byte
Dim dataSetType As Long
Dim dataSetLength As Long
Dim data As Object

Dim instance As New ImageXIptcData(record, dataSet, dataSetType, dataSetLength, data)
public ImageXIptcData(
   byte record,
   byte dataSet,
   long dataSetType,
   long dataSetLength,
   object data
)
public: ImageXIptcData(
   byte record,
   byte dataSet,
   long dataSetType,
   long dataSetLength,
   Object* data
)
public:
ImageXIptcData(
   byte record,
   byte dataSet,
   int64 dataSetType,
   int64 dataSetLength,
   Object^ data
)

Parameters

record
A byte value which represents the record.
dataSet
A byte value which represents the data set.
dataSetType
An integer which represents the type of data set.
dataSetLength
An integer value which represents the length of the data set.
data
An object which contains the data.
Remarks

Note: Available in Professional edition.

See Also

Reference

ImageXIptcData Class
ImageXIptcData Members
Overload List


ImageXIptcData Constructor(Byte,Byte,Int64,String)

ImageXIptcData Constructor(Byte,Byte,Int64,String)

Accusoft.ImagXpressSdk Namespace > ImageXIptcData Class > ImageXIptcData Constructor : ImageXIptcData Constructor(Byte,Byte,Int64,String)
A byte value which represents the record.
A byte value which represents the data set.
An integer which represents the type of data set.
A string value which represents the data field string.
Initializes a new instance of the ImageXIptcData class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal record As Byte, _
   ByVal dataSet As Byte, _
   ByVal dataSetType As Long, _
   ByVal data As String _
)
'Usage

Dim record As Byte
Dim dataSet As Byte
Dim dataSetType As Long
Dim data As String

Dim instance As New ImageXIptcData(record, dataSet, dataSetType, data)
public ImageXIptcData(
   byte record,
   byte dataSet,
   long dataSetType,
   string data
)
public: ImageXIptcData(
   byte record,
   byte dataSet,
   long dataSetType,
   string* data
)
public:
ImageXIptcData(
   byte record,
   byte dataSet,
   int64 dataSetType,
   String^ data
)

Parameters

record
A byte value which represents the record.
dataSet
A byte value which represents the data set.
dataSetType
An integer which represents the type of data set.
data
A string value which represents the data field string.
Remarks

Note: Available in Professional edition.

See Also

Reference

ImageXIptcData Class
ImageXIptcData Members
Overload List


ImageXIptcData Constructor(Byte,Byte,Int64,Byte[])

ImageXIptcData Constructor(Byte,Byte,Int64,Byte[])

Accusoft.ImagXpressSdk Namespace > ImageXIptcData Class > ImageXIptcData Constructor : ImageXIptcData Constructor(Byte,Byte,Int64,Byte[])
A byte value which represents the record.
A byte value which represents the data set.
An integer which represents the type of data set.
An byte array which contains the data.
Initializes a new instance of the ImageXIptcData class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal record As Byte, _
   ByVal dataSet As Byte, _
   ByVal dataSetType As Long, _
   ByVal data() As Byte _
)
'Usage

Dim record As Byte
Dim dataSet As Byte
Dim dataSetType As Long
Dim data() As Byte

Dim instance As New ImageXIptcData(record, dataSet, dataSetType, data)
public ImageXIptcData(
   byte record,
   byte dataSet,
   long dataSetType,
   byte[] data
)
public: ImageXIptcData(
   byte record,
   byte dataSet,
   long dataSetType,
   byte[]* data
)
public:
ImageXIptcData(
   byte record,
   byte dataSet,
   int64 dataSetType,
   array<byte>^ data
)

Parameters

record
A byte value which represents the record.
dataSet
A byte value which represents the data set.
dataSetType
An integer which represents the type of data set.
data
An byte array which contains the data.
Remarks

Note: Available in Professional edition.

See Also

Reference

ImageXIptcData Class
ImageXIptcData Members
Overload List


ImageXIptcData Class Methods

ImageXIptcData Class Methods

Accusoft.ImagXpressSdk Namespace : ImageXIptcData Class

For a list of all members of this type, see ImageXIptcData members.

Public Methods
 | Name | Description
Public Method | CompareTo | Compares the current instance with another object of the same type.
Top
See Also

Reference

ImageXIptcData Class
Accusoft.ImagXpressSdk Namespace


CompareTo Method (ImageXIptcData)

CompareTo Method (ImageXIptcData)

Accusoft.ImagXpressSdk Namespace > ImageXIptcData Class : CompareTo Method
An object to compare with this instance.
Compares the current instance with another object of the same type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CompareTo( _
   ByVal obj As Object _
) As Integer
'Usage

Dim instance As ImageXIptcData
Dim obj As Object
Dim value As Integer

value = instance.CompareTo(obj)
public int CompareTo(
   object obj
)
public: int CompareTo(
   Object* obj
)
public:
int CompareTo(
   Object^ obj
)

Parameters

obj
An object to compare with this instance.

Return Value

A 32-bit signed integer that indicates the relative order of the objects being compared. The return value has these meanings: Value Meaning Less than zero This instance is less than obj. Zero This instance is equal to obj. Greater than zero: This instance is greater than obj.
Exceptions
Exception | Description
System.ArgumentException | obj is not the same type as this instance.
Remarks

Note: Available in Professional edition.

See Also

Reference

ImageXIptcData Class
ImageXIptcData Members


ImageXIptcData Class Properties

ImageXIptcData Class Properties

Accusoft.ImagXpressSdk Namespace : ImageXIptcData Class

For a list of all members of this type, see ImageXIptcData members.

Public Properties
 | Name | Description
Public Property | DataField | Gets or sets the data field.
Public Property | DataFieldString | Gets or sets the data field string.
Public Property | DataSet | Gets or sets the data set.
Public Property | DataSetLength | Gets the length of the data set.
Public Property | DataSetType | Gets or sets the type of the data set.
Public Property | Record | Gets or sets the record.
Top
See Also

Reference

ImageXIptcData Class
Accusoft.ImagXpressSdk Namespace


DataField Property

DataField Property

Accusoft.ImagXpressSdk Namespace > ImageXIptcData Class : DataField Property
Gets or sets the data field.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DataField As Byte()
'Usage

Dim instance As ImageXIptcData
Dim value() As Byte

instance.DataField = value

value = instance.DataField
public byte[] DataField {get; set;}
public: __property byte[]* get_DataField();
public: __property void set_DataField(
   byte[]* value
);
public:
property array<byte>^ DataField {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

Property Value

A byte value which represents the data field.
Remarks

Note: Available in Professional edition.

See Also

Reference

ImageXIptcData Class
ImageXIptcData Members


DataFieldString Property

DataFieldString Property

Accusoft.ImagXpressSdk Namespace > ImageXIptcData Class : DataFieldString Property
Gets or sets the data field string.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DataFieldString As String
'Usage

Dim instance As ImageXIptcData
Dim value As String

instance.DataFieldString = value

value = instance.DataFieldString
public string DataFieldString {get; set;}
public: __property string* get_DataFieldString();
public: __property void set_DataFieldString(
   string* value
);
public:
property String^ DataFieldString {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value which represents the data field string.
Remarks

Note: Available in Professional edition.

See Also

Reference

ImageXIptcData Class
ImageXIptcData Members


DataSet Property

DataSet Property

Accusoft.ImagXpressSdk Namespace > ImageXIptcData Class : DataSet Property
Gets or sets the data set.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DataSet As Byte
'Usage

Dim instance As ImageXIptcData
Dim value As Byte

instance.DataSet = value

value = instance.DataSet
public byte DataSet {get; set;}
public: __property byte get_DataSet();
public: __property void set_DataSet(
   byte value
);
public:
property byte DataSet {
   byte get();
   void set (    byte value);
}

Property Value

A byte value which represents the data set.
Remarks

Note: Available in Professional edition.

See Also

Reference

ImageXIptcData Class
ImageXIptcData Members


DataSetLength Property

DataSetLength Property

Accusoft.ImagXpressSdk Namespace > ImageXIptcData Class : DataSetLength Property
Gets the length of the data set.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property DataSetLength As Long
'Usage

Dim instance As ImageXIptcData
Dim value As Long

value = instance.DataSetLength
public long DataSetLength {get;}
public: __property long get_DataSetLength();
public:
property int64 DataSetLength {
   int64 get();
}

Property Value

An integer value which represents the length of the data set.
Remarks

Note: Available in Professional edition.

See Also

Reference

ImageXIptcData Class
ImageXIptcData Members


DataSetType Property

DataSetType Property

Accusoft.ImagXpressSdk Namespace > ImageXIptcData Class : DataSetType Property
Gets or sets the type of the data set.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DataSetType As Long
'Usage

Dim instance As ImageXIptcData
Dim value As Long

instance.DataSetType = value

value = instance.DataSetType
public long DataSetType {get; set;}
public: __property long get_DataSetType();
public: __property void set_DataSetType(
   long value
);
public:
property int64 DataSetType {
   int64 get();
   void set (    int64 value);
}

Property Value

An integer value which represents the type of the data set.
Remarks

Note: Available in Professional edition.

See Also

Reference

ImageXIptcData Class
ImageXIptcData Members


Record Property

Record Property

Accusoft.ImagXpressSdk Namespace > ImageXIptcData Class : Record Property
Gets or sets the record.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Record As Byte
'Usage

Dim instance As ImageXIptcData
Dim value As Byte

instance.Record = value

value = instance.Record
public byte Record {get; set;}
public: __property byte get_Record();
public: __property void set_Record(
   byte value
);
public:
property byte Record {
   byte get();
   void set (    byte value);
}

Property Value

A byte value which represents the record.
Remarks

Note: Available in Professional edition.

See Also

Reference

ImageXIptcData Class
ImageXIptcData Members


ImageXTag Class

ImageXTag Class
Members

Accusoft.ImagXpressSdk Namespace : ImageXTag Class
This class holds TIFF and EXIF tags.
Object Model
ImageXTag Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImageXTag
'Usage

Dim instance As ImageXTag
public class ImageXTag
public __gc class ImageXTag
public ref class ImageXTag
Remarks

This class can be used to extract information contained within a specific tag entity as well as edit tage entity values. While tags can be bytes, short, long, rational, floats and doubles, they can also be signed or unsigned which is a problem with CLS compliance. Data is passed as CLS compliant data, but the TagType property indicates intent. That is, there are types indicating that the data should be considered signed or unsigned.

Note: The public "get" and "set" methods of the ImageXTag class obtain tags only of the appropriate types.

Note: Available in Professional edition.

Inheritance Hierarchy

System.Object
Accusoft.ImagXpressSdk.ImageXTag

See Also

Reference

ImageXTag Members
Accusoft.ImagXpressSdk Namespace


ImageXTag Class Members

ImageXTag Class Members
Properties Methods

Accusoft.ImagXpressSdk Namespace : ImageXTag Class

The following tables list the members exposed by ImageXTag.

Public Constructors
 | Name | Description
Public Constructor | ImageXTag Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | TagElementsCount | Gets and sets the number of data items in the tag.
Public Property | TagLevel | Gets and sets the nesting level at which the tag resides. Tag Level can be 0 - 4.
Public Property | TagNumber | Gets and sets the Tag ID Number.
Public Property | TagType | Gets and sets the type of data within the tag.
Top
Public Methods
 | Name | Description
Public Method | GetTagBytes | Gets tag data that are of the type Bytes.
Public Method | GetTagDouble | Gets tag data of type Double.
Public Method | GetTagFloat | Retrieves a float array of values contained within the ImageXTag.
Public Method | GetTagInt16 | Retrieves a short array of values contained within ImageXTag.
Public Method | GetTagInt32 | Gets tag data of type long or int32.
Public Method | GetTagRational | Gets Tag Rational data.
Public Method | GetTagSBytes | Retrieves signed short array of values contained within the ImageXTag.
Public Method | GetTagSRational | Gets tag SRational data.
Public Method | GetTagUInt16 | Retrieves a short array of values contained within the ImageXTag.
Public Method | GetTagUInt32 | Gets tag data of type unsigned long or UInt32.
Public Method | SetTagBytes | Sets Tag Data of based on byte array input.
Public Method | SetTagDouble | Sets tag data of type Double.
Public Method | SetTagFloat | Set Tag Data of type Float or Single.
Public Method | SetTagInt16 | Sets the ImageXTag data based on the short array input.
Public Method | SetTagInt32 | Overloaded. Sets Tag Data of type long or int32.
Public Method | SetTagRational | Sets Tag Rational Data.
Public Method | SetTagSBytes | Sets Tag Data based on the byte array input.
Public Method | SetTagSRational | Sets Tag Rational Data.
Public Method | SetTagUInt16 | Sets tag data of type UInt16.
Public Method | SetTagUInt32 | Sets tag data of type unsigned long or UInt32.
Top
See Also

Reference

ImageXTag Class
Accusoft.ImagXpressSdk Namespace


ImageXTag Constructor

ImageXTag Constructor

Accusoft.ImagXpressSdk Namespace > ImageXTag Class : ImageXTag Constructor
Overload List
Overload | Description
ImageXTag Constructor() | Initializes a new instance of the ImageXTag class.
ImageXTag Constructor(Int32,Byte,Object,TagTypes) | Can construct a fully qualified Tag from the constructor.
See Also

Reference

ImageXTag Class
ImageXTag Members


ImageXTag Constructor()

ImageXTag Constructor()

Accusoft.ImagXpressSdk Namespace > ImageXTag Class > ImageXTag Constructor : ImageXTag Constructor()
Initializes a new instance of the ImageXTag class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImageXTag()
public ImageXTag()
public: ImageXTag();
public:
ImageXTag();
Remarks

Note: Available in Professional edition.

See Also

Reference

ImageXTag Class
ImageXTag Members
Overload List


ImageXTag Constructor(Int32,Byte,Object,TagTypes)

ImageXTag Constructor(Int32,Byte,Object,TagTypes)

Accusoft.ImagXpressSdk Namespace > ImageXTag Class > ImageXTag Constructor : ImageXTag Constructor(Int32,Byte,Object,TagTypes)
An integer which represents the tag number.
A byte which represents the tag level.
A data object.
The TagTypes enumeration value set.
Can construct a fully qualified Tag from the constructor.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal TagNumber As Integer, _
   ByVal TagLevel As Byte, _
   ByVal Data As Object, _
   ByVal TagType As TagTypes _
)
'Usage

Dim TagNumber As Integer
Dim TagLevel As Byte
Dim Data As Object
Dim TagType As TagTypes

Dim instance As New ImageXTag(TagNumber, TagLevel, Data, TagType)
public ImageXTag(
   int TagNumber,
   byte TagLevel,
   object Data,
   TagTypes TagType
)
public: ImageXTag(
   int TagNumber,
   byte TagLevel,
   Object* Data,
   TagTypes TagType
)
public:
ImageXTag(
   int TagNumber,
   byte TagLevel,
   Object^ Data,
   TagTypes TagType
)

Parameters

TagNumber
An integer which represents the tag number.
TagLevel
A byte which represents the tag level.
Data
A data object.
TagType
The TagTypes enumeration value set.
Remarks

Note: Available in Professional edition.

See Also

Reference

ImageXTag Class
ImageXTag Members
Overload List


ImageXTag Class Methods

ImageXTag Class Methods

Accusoft.ImagXpressSdk Namespace : ImageXTag Class

For a list of all members of this type, see ImageXTag members.

Public Methods
 | Name | Description
Public Method | GetTagBytes | Gets tag data that are of the type Bytes.
Public Method | GetTagDouble | Gets tag data of type Double.
Public Method | GetTagFloat | Retrieves a float array of values contained within the ImageXTag.
Public Method | GetTagInt16 | Retrieves a short array of values contained within ImageXTag.
Public Method | GetTagInt32 | Gets tag data of type long or int32.
Public Method | GetTagRational | Gets Tag Rational data.
Public Method | GetTagSBytes | Retrieves signed short array of values contained within the ImageXTag.
Public Method | GetTagSRational | Gets tag SRational data.
Public Method | GetTagUInt16 | Retrieves a short array of values contained within the ImageXTag.
Public Method | GetTagUInt32 | Gets tag data of type unsigned long or UInt32.
Public Method | SetTagBytes | Sets Tag Data of based on byte array input.
Public Method | SetTagDouble | Sets tag data of type Double.
Public Method | SetTagFloat | Set Tag Data of type Float or Single.
Public Method | SetTagInt16 | Sets the ImageXTag data based on the short array input.
Public Method | SetTagInt32 | Overloaded. Sets Tag Data of type long or int32.
Public Method | SetTagRational | Sets Tag Rational Data.
Public Method | SetTagSBytes | Sets Tag Data based on the byte array input.
Public Method | SetTagSRational | Sets Tag Rational Data.
Public Method | SetTagUInt16 | Sets tag data of type UInt16.
Public Method | SetTagUInt32 | Sets tag data of type unsigned long or UInt32.
Top
See Also

Reference

ImageXTag Class
Accusoft.ImagXpressSdk Namespace


GetTagBytes Method

GetTagBytes Method

Accusoft.ImagXpressSdk Namespace > ImageXTag Class : GetTagBytes Method
Gets tag data that are of the type Bytes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetTagBytes() As Byte()
'Usage

Dim instance As ImageXTag
Dim value() As Byte

value = instance.GetTagBytes()
public byte[] GetTagBytes()
public: byte[]* GetTagBytes();
public:
array<byte>^ GetTagBytes();

Return Value

A byte array which contains the tag data.
Remarks

Note: The public "get" and "set" methods of the ImageXTag class only get or obtain tags of the appropriate types.

Note: Available in Professional edition.

See Also

Reference

ImageXTag Class
ImageXTag Members


GetTagDouble Method

GetTagDouble Method

Accusoft.ImagXpressSdk Namespace > ImageXTag Class : GetTagDouble Method
Gets tag data of type Double.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetTagDouble() As Double()
'Usage

Dim instance As ImageXTag
Dim value() As Double

value = instance.GetTagDouble()
public double[] GetTagDouble()
public: double[]* GetTagDouble();
public:
array<double>^ GetTagDouble();

Return Value

A double-precision floating point value which represents the tag data.
Remarks

Note: Available in Professional edition.

See Also

Reference

ImageXTag Class
ImageXTag Members


GetTagFloat Method

GetTagFloat Method

Accusoft.ImagXpressSdk Namespace > ImageXTag Class : GetTagFloat Method
Retrieves a float array of values contained within the ImageXTag.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetTagFloat() As Single()
'Usage

Dim instance As ImageXTag
Dim value() As Single

value = instance.GetTagFloat()
public float[] GetTagFloat()
public: float[]* GetTagFloat();
public:
array<float>^ GetTagFloat();

Return Value

A signed float array of values contained within the ImageXTag.
Remarks

Get tag data of type float or single.

Note: The public "get" and "set" methods of the ImageXTag class only get or obtain tags of the appropriate types.

Note: Available in Professional edition.

See Also

Reference

ImageXTag Class
ImageXTag Members


GetTagInt16 Method

GetTagInt16 Method

Accusoft.ImagXpressSdk Namespace > ImageXTag Class : GetTagInt16 Method
Retrieves a short array of values contained within ImageXTag.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetTagInt16() As Short()
'Usage

Dim instance As ImageXTag
Dim value() As Short

value = instance.GetTagInt16()
public short[] GetTagInt16()
public: short[]* GetTagInt16();
public:
array<short>^ GetTagInt16();

Return Value

Note: A short array of signed values contained within the ImageXTag.
Remarks

Get tag data of type short or int16 SByte data is returned as int16 as well because SByte is not CLS compliant.

Note: The public "get" and "set" methods of the ImageXTag class only get or obtain tags of the appropriate types.

Tag data of type short or int16. SByte data is returned as int16 as well because SByte is not CLS compliant.

Note: Available in Professional edition.

See Also

Reference

ImageXTag Class
ImageXTag Members


GetTagInt32 Method

GetTagInt32 Method

Accusoft.ImagXpressSdk Namespace > ImageXTag Class : GetTagInt32 Method
Gets tag data of type long or int32.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetTagInt32() As Integer()
'Usage

Dim instance As ImageXTag
Dim value() As Integer

value = instance.GetTagInt32()
public int[] GetTagInt32()
public: int[]* GetTagInt32();
public:
array<int>^ GetTagInt32();

Return Value

An integer 32 which represents the tag data converted from UInt16.
Remarks

Note: Tag type UInt16 (Tag_Short) is returned at Int32[] because UInt16 is not CLS complaint.

Note: Available in Professional edition.

See Also

Reference

ImageXTag Class
ImageXTag Members


GetTagRational Method

GetTagRational Method

Accusoft.ImagXpressSdk Namespace > ImageXTag Class : GetTagRational Method
Gets Tag Rational data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetTagRational() As Long()
'Usage

Dim instance As ImageXTag
Dim value() As Long

value = instance.GetTagRational()
public long[] GetTagRational()
public: long[]* GetTagRational();
public:
array<int64>^ GetTagRational();
Remarks

Rational is unsigned int32 but that is not CLS compliant. So, data is returned in the next highest compliant size to keep is positve and effectively unsigned. So data is returned long-long or Int64.

Note: Available in Professional edition.

See Also

Reference

ImageXTag Class
ImageXTag Members


GetTagSBytes Method

GetTagSBytes Method

Accusoft.ImagXpressSdk Namespace > ImageXTag Class : GetTagSBytes Method
Retrieves signed short array of values contained within the ImageXTag.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetTagSBytes() As Short()
'Usage

Dim instance As ImageXTag
Dim value() As Short

value = instance.GetTagSBytes()
public short[] GetTagSBytes()
public: short[]* GetTagSBytes();
public:
array<short>^ GetTagSBytes();

Return Value

A signed short array which contains values within the ImageXTag.
Remarks

Note: The public "get" and "set" methods of the ImageXTag class only get or obtain tags of the apropriate types.

Note: Available in Professional edition.

See Also

Reference

ImageXTag Class
ImageXTag Members


GetTagSRational Method

GetTagSRational Method

Accusoft.ImagXpressSdk Namespace > ImageXTag Class : GetTagSRational Method
Gets tag SRational data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetTagSRational() As Integer()
'Usage

Dim instance As ImageXTag
Dim value() As Integer

value = instance.GetTagSRational()
public int[] GetTagSRational()
public: int[]* GetTagSRational();
public:
array<int>^ GetTagSRational();

Return Value

An integer value which represents tag SRational data.
Remarks

SRational data are pairs of long or int32.

Note: Available in Professional edition.

See Also

Reference

ImageXTag Class
ImageXTag Members


GetTagUInt16 Method

GetTagUInt16 Method

Accusoft.ImagXpressSdk Namespace > ImageXTag Class : GetTagUInt16 Method
Retrieves a short array of values contained within the ImageXTag.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetTagUInt16() As Integer()
'Usage

Dim instance As ImageXTag
Dim value() As Integer

value = instance.GetTagUInt16()
public int[] GetTagUInt16()
public: int[]* GetTagUInt16();
public:
array<int>^ GetTagUInt16();

Return Value

A signed short array of values contained within the ImageXTag.
Remarks

Gets tag data of type short or int16 sbyte data is returned as int16 as well because sbyte is not CLS compliant.

Note: The public "get" and "set" methods of the ImageXTag class only get or obtain tags of the appropriate types.

Note: UInt16 is not CLS Compliant so it must be returned as Int32 data. The data is moved from UInt16 to Int32 internally so it remains positive and hence unsigned.

Note: Available in Professional edition.

See Also

Reference

ImageXTag Class
ImageXTag Members


GetTagUInt32 Method

GetTagUInt32 Method

Accusoft.ImagXpressSdk Namespace > ImageXTag Class : GetTagUInt32 Method
Gets tag data of type unsigned long or UInt32.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetTagUInt32() As Long()
'Usage

Dim instance As ImageXTag
Dim value() As Long

value = instance.GetTagUInt32()
public long[] GetTagUInt32()
public: long[]* GetTagUInt32();
public:
array<int64>^ GetTagUInt32();

Return Value

An integer 64 which represents the tag data.
Remarks

Note: Because UInt32 is not CLS compliant, it must be passed in the next largest type which is In64. It will be moved from UInt32 to Int64 internally.

Note: Available in Professional edition.

See Also

Reference

ImageXTag Class
ImageXTag Members


SetTagBytes Method

SetTagBytes Method

Accusoft.ImagXpressSdk Namespace > ImageXTag Class : SetTagBytes Method
An unsigned byte array which represents the tag data.
Sets Tag Data of based on byte array input.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetTagBytes( _
   ByVal TagData() As Byte _
)
'Usage

Dim instance As ImageXTag
Dim TagData() As Byte

instance.SetTagBytes(TagData)
public void SetTagBytes(
   byte[] TagData
)
public: void SetTagBytes(
   byte[]* TagData
)
public:
void SetTagBytes(
   array<byte>^ TagData
)

Parameters

TagData
An unsigned byte array which represents the tag data.
Remarks

Note: The public "get" and "set" methods of the ImageXTag class only get or obtain tags of the appropriate types.

Note: Available in Professional edition.

See Also

Reference

ImageXTag Class
ImageXTag Members


SetTagDouble Method

SetTagDouble Method

Accusoft.ImagXpressSdk Namespace > ImageXTag Class : SetTagDouble Method
A double-precision floating point value which represents the tag data.
Sets tag data of type Double.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetTagDouble( _
   ByVal TagData() As Double _
)
'Usage

Dim instance As ImageXTag
Dim TagData() As Double

instance.SetTagDouble(TagData)
public void SetTagDouble(
   double[] TagData
)
public: void SetTagDouble(
   double[]* TagData
)
public:
void SetTagDouble(
   array<double>^ TagData
)

Parameters

TagData
A double-precision floating point value which represents the tag data.
Remarks

Note: Available in Professional edition.

See Also

Reference

ImageXTag Class
ImageXTag Members


SetTagFloat Method

SetTagFloat Method

Accusoft.ImagXpressSdk Namespace > ImageXTag Class : SetTagFloat Method
A single-precision floating point value which represents tag data.
Set Tag Data of type Float or Single.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetTagFloat( _
   ByVal TagData() As Single _
)
'Usage

Dim instance As ImageXTag
Dim TagData() As Single

instance.SetTagFloat(TagData)
public void SetTagFloat(
   float[] TagData
)
public: void SetTagFloat(
   float[]* TagData
)
public:
void SetTagFloat(
   array<float>^ TagData
)

Parameters

TagData
A single-precision floating point value which represents tag data.
Remarks

Note: Available in Professional edition.

See Also

Reference

ImageXTag Class
ImageXTag Members


SetTagInt16 Method

SetTagInt16 Method

Accusoft.ImagXpressSdk Namespace > ImageXTag Class : SetTagInt16 Method
A signed short array consisting of values that the ImageXTag is to contain.
Sets the ImageXTag data based on the short array input.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetTagInt16( _
   ByVal TagData() As Short _
)
'Usage

Dim instance As ImageXTag
Dim TagData() As Short

instance.SetTagInt16(TagData)
public void SetTagInt16(
   short[] TagData
)
public: void SetTagInt16(
   short[]* TagData
)
public:
void SetTagInt16(
   array<short>^ TagData
)

Parameters

TagData
A signed short array consisting of values that the ImageXTag is to contain.
Remarks

The sbyte data is contained in the int16 arrays because it is not CLS compliant. If the tag type is sbyte, the int16 array is converted down to an sbyte array.

Note: The public "get" and "set" methods of the ImageXTag class only get or obtain tags of the appropriate types.

Note: Available in Professional edition.

See Also

Reference

ImageXTag Class
ImageXTag Members


SetTagInt32 Method

SetTagInt32 Method

Accusoft.ImagXpressSdk Namespace > ImageXTag Class : SetTagInt32 Method
Sets Tag Data of type long or int32.
Overload List
Overload | Description
SetTagInt32(Int32[]) | Sets Tag Data of type long or int32.
SetTagInt32(Single[]) | Sets tag data of type Float or Single.
SetTagInt32(Double[]) | Sets tag data of type Double.
See Also

Reference

ImageXTag Class
ImageXTag Members


SetTagInt32(Int32[]) Method

SetTagInt32(Int32[]) Method

Accusoft.ImagXpressSdk Namespace > ImageXTag Class > SetTagInt32 Method : SetTagInt32(Int32[]) Method
An integer 32 which represents the tag data.
Sets Tag Data of type long or int32.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub SetTagInt32( _
   ByVal TagData() As Integer _
)
'Usage

Dim instance As ImageXTag
Dim TagData() As Integer

instance.SetTagInt32(TagData)
public void SetTagInt32(
   int[] TagData
)
public: void SetTagInt32(
   int[]* TagData
)
public:
void SetTagInt32(
   array<int>^ TagData
)

Parameters

TagData
An integer 32 which represents the tag data.
Remarks

Note: Tag type UInt16 (Tag_Short) is returned at Int32[] because UInt16 is not CLS complaint.

Note: Available in Professional edition.

See Also

Reference

ImageXTag Class
ImageXTag Members
Overload List


SetTagInt32(Single[]) Method

SetTagInt32(Single[]) Method

Accusoft.ImagXpressSdk Namespace > ImageXTag Class > SetTagInt32 Method : SetTagInt32(Single[]) Method
A single-precision floating point value which represents tag data.
Sets tag data of type Float or Single.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub SetTagInt32( _
   ByVal TagData() As Single _
)
'Usage

Dim instance As ImageXTag
Dim TagData() As Single

instance.SetTagInt32(TagData)
public void SetTagInt32(
   float[] TagData
)
public: void SetTagInt32(
   float[]* TagData
)
public:
void SetTagInt32(
   array<float>^ TagData
)

Parameters

TagData
A single-precision floating point value which represents tag data.
Remarks

Note: Available in Professional edition.

See Also

Reference

ImageXTag Class
ImageXTag Members
Overload List


SetTagInt32(Double[]) Method

SetTagInt32(Double[]) Method

Accusoft.ImagXpressSdk Namespace > ImageXTag Class > SetTagInt32 Method : SetTagInt32(Double[]) Method
A double-precision floating point value which represents the tag data.
Sets tag data of type Double.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub SetTagInt32( _
   ByVal TagData() As Double _
)
'Usage

Dim instance As ImageXTag
Dim TagData() As Double

instance.SetTagInt32(TagData)
public void SetTagInt32(
   double[] TagData
)
public: void SetTagInt32(
   double[]* TagData
)
public:
void SetTagInt32(
   array<double>^ TagData
)

Parameters

TagData
A double-precision floating point value which represents the tag data.
Remarks

Note: Available in Professional edition.

See Also

Reference

ImageXTag Class
ImageXTag Members
Overload List


SetTagRational Method

SetTagRational Method

Accusoft.ImagXpressSdk Namespace > ImageXTag Class : SetTagRational Method
Sets Tag Rational Data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetTagRational( _
   ByVal TagData() As Long _
)
'Usage

Dim instance As ImageXTag
Dim TagData() As Long

instance.SetTagRational(TagData)
public void SetTagRational(
   long[] TagData
)
public: void SetTagRational(
   long[]* TagData
)
public:
void SetTagRational(
   array<int64>^ TagData
)

Parameters

TagData
Remarks

Data must be in pairs of long-long or int64. Because UInt32 is not CLS compliant and Rational is really unsigned, the data is returned in the next largest compliant form to remain positive and effectively unsigned.

Note: Available in Professional edition.

See Also

Reference

ImageXTag Class
ImageXTag Members


SetTagSBytes Method

SetTagSBytes Method

Accusoft.ImagXpressSdk Namespace > ImageXTag Class : SetTagSBytes Method
An unsigned byte array consisting of values ImageXTag contains.
Sets Tag Data based on the byte array input.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetTagSBytes( _
   ByVal TagData() As Short _
)
'Usage

Dim instance As ImageXTag
Dim TagData() As Short

instance.SetTagSBytes(TagData)
public void SetTagSBytes(
   short[] TagData
)
public: void SetTagSBytes(
   short[]* TagData
)
public:
void SetTagSBytes(
   array<short>^ TagData
)

Parameters

TagData
An unsigned byte array consisting of values ImageXTag contains.
Remarks

Note: The public "get" and "set" methods of the ImageXTag class only get or obtain tags of the appropriate types.

Note: Available in Professional edition.

See Also

Reference

ImageXTag Class
ImageXTag Members


SetTagSRational Method

SetTagSRational Method

Accusoft.ImagXpressSdk Namespace > ImageXTag Class : SetTagSRational Method
An integer value which represents tag SRational data.
Sets Tag Rational Data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetTagSRational( _
   ByVal TagData() As Integer _
)
'Usage

Dim instance As ImageXTag
Dim TagData() As Integer

instance.SetTagSRational(TagData)
public void SetTagSRational(
   int[] TagData
)
public: void SetTagSRational(
   int[]* TagData
)
public:
void SetTagSRational(
   array<int>^ TagData
)

Parameters

TagData
An integer value which represents tag SRational data.
Remarks

SRational data are pairs of long or int32.

Note: Available in Professional edition.

See Also

Reference

ImageXTag Class
ImageXTag Members


SetTagUInt16 Method

SetTagUInt16 Method

Accusoft.ImagXpressSdk Namespace > ImageXTag Class : SetTagUInt16 Method
An int32 which represents the tag data.
Sets tag data of type UInt16.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetTagUInt16( _
   ByVal TagData() As Integer _
)
'Usage

Dim instance As ImageXTag
Dim TagData() As Integer

instance.SetTagUInt16(TagData)
public void SetTagUInt16(
   int[] TagData
)
public: void SetTagUInt16(
   int[]* TagData
)
public:
void SetTagUInt16(
   array<int>^ TagData
)

Parameters

TagData
An int32 which represents the tag data.
Remarks

Note: UInt16 is not CLS Compliant so it must be passed in Int32 and internally converted to UInt16.

Note: Available in Professional edition.

See Also

Reference

ImageXTag Class
ImageXTag Members


SetTagUInt32 Method

SetTagUInt32 Method

Accusoft.ImagXpressSdk Namespace > ImageXTag Class : SetTagUInt32 Method
An integer 64 which represents tag data.
Sets tag data of type unsigned long or UInt32.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetTagUInt32( _
   ByVal TagData() As Long _
)
'Usage

Dim instance As ImageXTag
Dim TagData() As Long

instance.SetTagUInt32(TagData)
public void SetTagUInt32(
   long[] TagData
)
public: void SetTagUInt32(
   long[]* TagData
)
public:
void SetTagUInt32(
   array<int64>^ TagData
)

Parameters

TagData
An integer 64 which represents tag data.
Remarks

Because UInt32 is not CLS compliant, it must be passed in the next largest type which is In64. It will be moved to UInt32 internally.

Note: Available in Professional edition.

See Also

Reference

ImageXTag Class
ImageXTag Members


ImageXTag Class Properties

ImageXTag Class Properties

Accusoft.ImagXpressSdk Namespace : ImageXTag Class

For a list of all members of this type, see ImageXTag members.

Public Properties
 | Name | Description
Public Property | TagElementsCount | Gets and sets the number of data items in the tag.
Public Property | TagLevel | Gets and sets the nesting level at which the tag resides. Tag Level can be 0 - 4.
Public Property | TagNumber | Gets and sets the Tag ID Number.
Public Property | TagType | Gets and sets the type of data within the tag.
Top
See Also

Reference

ImageXTag Class
Accusoft.ImagXpressSdk Namespace


TagElementsCount Property

TagElementsCount Property

Accusoft.ImagXpressSdk Namespace > ImageXTag Class : TagElementsCount Property
Gets and sets the number of data items in the tag.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TagElementsCount As Integer
'Usage

Dim instance As ImageXTag
Dim value As Integer

instance.TagElementsCount = value

value = instance.TagElementsCount
public int TagElementsCount {get; set;}
public: __property int get_TagElementsCount();
public: __property void set_TagElementsCount(
   int value
);
public:
property int TagElementsCount {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the number of data items in the tag.
Remarks

For more information on querying and modifying tags, see the Modify Tags topic.

Note: Available in Professional edition.

See Also

Reference

ImageXTag Class
ImageXTag Members


TagLevel Property

TagLevel Property

Accusoft.ImagXpressSdk Namespace > ImageXTag Class : TagLevel Property
Gets and sets the nesting level at which the tag resides. Tag Level can be 0 - 4.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TagLevel As Byte
'Usage

Dim instance As ImageXTag
Dim value As Byte

instance.TagLevel = value

value = instance.TagLevel
public byte TagLevel {get; set;}
public: __property byte get_TagLevel();
public: __property void set_TagLevel(
   byte value
);
public:
property byte TagLevel {
   byte get();
   void set (    byte value);
}

Property Value

A byte value which represents the level.
Remarks

Valid values are 0 - 4.

For TIFF tags, the tag level should be = 0.

Some file formats have the ability to store metadata that includes sub-levels. For these file formats, the tag level provides access to these multiple levels.

Note: Available in Professional edition.

See Also

Reference

ImageXTag Class
ImageXTag Members


TagNumber Property

TagNumber Property

Accusoft.ImagXpressSdk Namespace > ImageXTag Class : TagNumber Property
Gets and sets the Tag ID Number.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TagNumber As Integer
'Usage

Dim instance As ImageXTag
Dim value As Integer

instance.TagNumber = value

value = instance.TagNumber
public int TagNumber {get; set;}
public: __property int get_TagNumber();
public: __property void set_TagNumber(
   int value
);
public:
property int TagNumber {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the tag ID number.
Remarks

Each tag in a TIFF or EXIF file has a corresponding number which identifies the information stored there. This property is a unique identifier of the tag within the tag collection.

Note: Available in Professional edition.

See Also

Reference

ImageXTag Class
ImageXTag Members


TagType Property

TagType Property

Accusoft.ImagXpressSdk Namespace > ImageXTag Class : TagType Property
Gets and sets the type of data within the tag.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TagType As TagTypes
'Usage

Dim instance As ImageXTag
Dim value As TagTypes

instance.TagType = value

value = instance.TagType
public TagTypes TagType {get; set;}
public: __property TagTypes get_TagType();
public: __property void set_TagType(
   TagTypes value
);
public:
property TagTypes TagType {
   TagTypes get();
   void set (    TagTypes value);
}

Property Value

The TagTypes enumeration value set.
Remarks

The Tag Type can be byte, short, long, rational and signed or unsigned.

Note: Available in Professional edition.

See Also

Reference

ImageXTag Class
ImageXTag Members


ImageXTagCollection Class

ImageXTagCollection Class
Members

Accusoft.ImagXpressSdk Namespace : ImageXTagCollection Class
A collection of ImageXTag objects.
Object Model
ImageXTagCollection ClassImageXTag Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultMemberAttribute("Item")>
Public Class ImageXTagCollection
   Inherits System.Collections.CollectionBase
'Usage

Dim instance As ImageXTagCollection
[DefaultMember("Item")]
public class ImageXTagCollection : System.Collections.CollectionBase
[DefaultMember("Item")]
public __gc class ImageXTagCollection : public System.Collections.CollectionBase
[DefaultMember("Item")]
public ref class ImageXTagCollection : public System.Collections.CollectionBase
Remarks

This collection is designed for use with the TIFF and EXIF file formats. This collection class can be used to add, copy, remove and insert tag entities into a loaded image.

Note: Available in Professional edition.

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Accusoft.ImagXpressSdk.ImageXTagCollection

See Also

Reference

ImageXTagCollection Members
Accusoft.ImagXpressSdk Namespace


ImageXTagCollection Class Members

ImageXTagCollection Class Members
Properties Methods

Accusoft.ImagXpressSdk Namespace : ImageXTagCollection Class

The following tables list the members exposed by ImageXTagCollection.

Public Constructors
 | Name | Description
Public Constructor | ImageXTagCollection Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets and sets the index values within the collection.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds an ImageXTag to the ImageXTagCollection.
Public Method | Clear | Clears the entire collection as well as calls the Clear function of the base class.
Public Method | Contains | Determines if the collection contains the specified ImageXTag.
Public Method | CopyTo | Copies the entire collection to an array, starting at index of the target array.
Public Method | Dispose | Releases all resources used by this Accusoft.ImagXpressSdk.ImageXTagCollection object.
Public Method | GetEnumerator | (Inherited from System.Collections.CollectionBase)
Public Method | GetTag | Retrieves the ImageXTag object from the ImageXTagCollection.
Public Method | IndexOf | Searches for the specified ImageXTag and returns the zero-based index of the first occurrence within the entire collection.
Public Method | Insert | Inserts an ImageXTag at the specified index.
Public Method | Remove | Removes the ImageXTag from the collection.
Public Method | RemoveAt | Removes the specified ImageXTag from the collection.
Public Method | RemoveTag | Removes an ImageXTag from the ImageXTagCollection.
Top
See Also

Reference

ImageXTagCollection Class
Accusoft.ImagXpressSdk Namespace


ImageXTagCollection Constructor

ImageXTagCollection Constructor

Accusoft.ImagXpressSdk Namespace > ImageXTagCollection Class : ImageXTagCollection Constructor
Overload List
Overload | Description
ImageXTagCollection Constructor() | The base constructor for the ImageXTagCollection class.
ImageXTagCollection Constructor(ImageXTagCollection) | Initializes a new instance of the ImageXTagCollection class.
See Also

Reference

ImageXTagCollection Class
ImageXTagCollection Members


ImageXTagCollection Constructor()

ImageXTagCollection Constructor()

Accusoft.ImagXpressSdk Namespace > ImageXTagCollection Class > ImageXTagCollection Constructor : ImageXTagCollection Constructor()
The base constructor for the ImageXTagCollection class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImageXTagCollection()
public ImageXTagCollection()
public: ImageXTagCollection();
public:
ImageXTagCollection();
Remarks

Note: Available in Professional edition.

See Also

Reference

ImageXTagCollection Class
ImageXTagCollection Members
Overload List


ImageXTagCollection Constructor(ImageXTagCollection)

ImageXTagCollection Constructor(ImageXTagCollection)

Accusoft.ImagXpressSdk Namespace > ImageXTagCollection Class > ImageXTagCollection Constructor : ImageXTagCollection Constructor(ImageXTagCollection)
The ImageXTagCollection from which to create a copy.
Initializes a new instance of the ImageXTagCollection class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal copytag As ImageXTagCollection _
)
'Usage

Dim copytag As ImageXTagCollection

Dim instance As New ImageXTagCollection(copytag)
public ImageXTagCollection(
   ImageXTagCollection copytag
)
public: ImageXTagCollection(
   ImageXTagCollection* copytag
)
public:
ImageXTagCollection(
   ImageXTagCollection^ copytag
)

Parameters

copytag
The ImageXTagCollection from which to create a copy.
Remarks

Note: Available in Professional edition.

See Also

Reference

ImageXTagCollection Class
ImageXTagCollection Members
Overload List


ImageXTagCollection Class Methods

ImageXTagCollection Class Methods

Accusoft.ImagXpressSdk Namespace : ImageXTagCollection Class

For a list of all members of this type, see ImageXTagCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds an ImageXTag to the ImageXTagCollection.
Public Method | Clear | Clears the entire collection as well as calls the Clear function of the base class.
Public Method | Contains | Determines if the collection contains the specified ImageXTag.
Public Method | CopyTo | Copies the entire collection to an array, starting at index of the target array.
Public Method | Dispose | Releases all resources used by this Accusoft.ImagXpressSdk.ImageXTagCollection object.
Public Method | GetEnumerator | (Inherited from System.Collections.CollectionBase)
Public Method | GetTag | Retrieves the ImageXTag object from the ImageXTagCollection.
Public Method | IndexOf | Searches for the specified ImageXTag and returns the zero-based index of the first occurrence within the entire collection.
Public Method | Insert | Inserts an ImageXTag at the specified index.
Public Method | Remove | Removes the ImageXTag from the collection.
Public Method | RemoveAt | Removes the specified ImageXTag from the collection.
Public Method | RemoveTag | Removes an ImageXTag from the ImageXTagCollection.
Top
See Also

Reference

ImageXTagCollection Class
Accusoft.ImagXpressSdk Namespace


Add Method (ImageXTagCollection)

Add Method (ImageXTagCollection)

Accusoft.ImagXpressSdk Namespace > ImageXTagCollection Class : Add Method
An ImageXTag object.
Adds an ImageXTag to the ImageXTagCollection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Add( _
   ByVal tag As ImageXTag _
) As Integer
'Usage

Dim instance As ImageXTagCollection
Dim tag As ImageXTag
Dim value As Integer

value = instance.Add(tag)
public int Add(
   ImageXTag tag
)
public: int Add(
   ImageXTag* tag
)
public:
int Add(
   ImageXTag^ tag
)

Parameters

tag
An ImageXTag object.

Return Value

An integer value which represents the index value within the list of the newly added ImageXTag.
Remarks

Note: Available in Professional edition.

See Also

Reference

ImageXTagCollection Class
ImageXTagCollection Members


Clear Method (ImageXTagCollection)

Clear Method (ImageXTagCollection)

Accusoft.ImagXpressSdk Namespace > ImageXTagCollection Class : Clear Method
Clears the entire collection as well as calls the Clear function of the base class.
Overload List
Overload | Description
Clear | Clears the entire collection as well as calls the Clear function of the base class.
See Also

Reference

ImageXTagCollection Class
ImageXTagCollection Members


Clear() Method

Clear() Method

Accusoft.ImagXpressSdk Namespace > ImageXTagCollection Class : Clear() Method
Clears the entire collection as well as calls the Clear function of the base class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shadows Sub Clear()
'Usage

Dim instance As ImageXTagCollection

instance.Clear()
public new void Clear()
public: new void Clear();
public:
new void Clear();
Remarks

Note: Available in Professional edition.

See Also

Reference

ImageXTagCollection Class
ImageXTagCollection Members


Contains Method (ImageXTagCollection)

Contains Method (ImageXTagCollection)

Accusoft.ImagXpressSdk Namespace > ImageXTagCollection Class : Contains Method
The ImageXTag to locate.
Determines if the collection contains the specified ImageXTag.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Contains( _
   ByVal tag As ImageXTag _
) As Boolean
'Usage

Dim instance As ImageXTagCollection
Dim tag As ImageXTag
Dim value As Boolean

value = instance.Contains(tag)
public bool Contains(
   ImageXTag tag
)
public: bool Contains(
   ImageXTag* tag
)
public:
bool Contains(
   ImageXTag^ tag
)

Parameters

tag
The ImageXTag to locate.

Return Value

A boolean value which is true if the collection contains the specified ImageXTag. Otherwise, false is returned.
Remarks

Note: Available in Professional edition.

See Also

Reference

ImageXTagCollection Class
ImageXTagCollection Members


CopyTo Method (ImageXTagCollection)

CopyTo Method (ImageXTagCollection)

Accusoft.ImagXpressSdk Namespace > ImageXTagCollection Class : CopyTo Method
The one-dimensional Array that is the destination of the elements copied from ImageXTagCollection. The Array must have zero-based indexing.
The zero-based index in array at which copying begins.
Copies the entire collection to an array, starting at index of the target array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub CopyTo( _
   ByVal array() As ImageXTag, _
   ByVal index As Integer _
)
'Usage

Dim instance As ImageXTagCollection
Dim array() As ImageXTag
Dim index As Integer

instance.CopyTo(array, index)
public void CopyTo(
   ImageXTag[] array,
   int index
)
public: void CopyTo(
   ImageXTag*[]* array,
   int index
)
public:
void CopyTo(
   array<ImageXTag^>^ array,
   int index
)

Parameters

array
The one-dimensional Array that is the destination of the elements copied from ImageXTagCollection. The Array must have zero-based indexing.
index
The zero-based index in array at which copying begins.
Remarks

Note: Available in Professional edition.

See Also

Reference

ImageXTagCollection Class
ImageXTagCollection Members


Dispose Method (ImageXTagCollection)

Dispose Method (ImageXTagCollection)

Accusoft.ImagXpressSdk Namespace > ImageXTagCollection Class : Dispose Method
Releases all resources used by this Accusoft.ImagXpressSdk.ImageXTagCollection object.
Overload List
Overload | Description
Dispose | Releases all resources used by this Accusoft.ImagXpressSdk.ImageXTagCollection object.
See Also

Reference

ImageXTagCollection Class
ImageXTagCollection Members


Dispose() Method

Dispose() Method

Accusoft.ImagXpressSdk Namespace > ImageXTagCollection Class : Dispose() Method
Releases all resources used by this Accusoft.ImagXpressSdk.ImageXTagCollection object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Dispose()
'Usage

Dim instance As ImageXTagCollection

instance.Dispose()
public void Dispose()
public: void Dispose();
public:
void Dispose();
See Also

Reference

ImageXTagCollection Class
ImageXTagCollection Members


GetTag Method

GetTag Method

Accusoft.ImagXpressSdk Namespace > ImageXTagCollection Class : GetTag Method
An integer value which represents the tag number to receive.
A byte which represents the tag level at which the requested tag resides.
Retrieves the ImageXTag object from the ImageXTagCollection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetTag( _
   ByVal TagNumber As Integer, _
   ByVal level As Byte _
) As ImageXTag
'Usage

Dim instance As ImageXTagCollection
Dim TagNumber As Integer
Dim level As Byte
Dim value As ImageXTag

value = instance.GetTag(TagNumber, level)
public ImageXTag GetTag(
   int TagNumber,
   byte level
)
public: ImageXTag* GetTag(
   int TagNumber,
   byte level
)
public:
ImageXTag^ GetTag(
   int TagNumber,
   byte level
)

Parameters

TagNumber
An integer value which represents the tag number to receive.
level
A byte which represents the tag level at which the requested tag resides.

Return Value

An ImageXTag object.
Remarks

This method is for multipage document formats such as TIFF and EXIF.

Note: Available in Professional edition.

See Also

Reference

ImageXTagCollection Class
ImageXTagCollection Members


IndexOf Method (ImageXTagCollection)

IndexOf Method (ImageXTagCollection)

Accusoft.ImagXpressSdk Namespace > ImageXTagCollection Class : IndexOf Method
The ImageXTag to locate in the collection.
Searches for the specified ImageXTag and returns the zero-based index of the first occurrence within the entire collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function IndexOf( _
   ByVal value As ImageXTag _
) As Integer
'Usage

Dim instance As ImageXTagCollection
Dim value As ImageXTag
Dim value As Integer

value = instance.IndexOf(value)
public int IndexOf(
   ImageXTag value
)
public: int IndexOf(
   ImageXTag* value
)
public:
int IndexOf(
   ImageXTag^ value
)

Parameters

value
The ImageXTag to locate in the collection.

Return Value

An integer value which represents the index of the first matching ImageXTag that was found.
Remarks

Note: Available in Professional edition.

See Also

Reference

ImageXTagCollection Class
ImageXTagCollection Members


Insert Method (ImageXTagCollection)

Insert Method (ImageXTagCollection)

Accusoft.ImagXpressSdk Namespace > ImageXTagCollection Class : Insert Method
The zero-based index at which the ImageXTag should be inserted.
The ImageXTag to be inserted.
Inserts an ImageXTag at the specified index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Insert( _
   ByVal index As Integer, _
   ByVal tag As ImageXTag _
)
'Usage

Dim instance As ImageXTagCollection
Dim index As Integer
Dim tag As ImageXTag

instance.Insert(index, tag)
public void Insert(
   int index,
   ImageXTag tag
)
public: void Insert(
   int index,
   ImageXTag* tag
)
public:
void Insert(
   int index,
   ImageXTag^ tag
)

Parameters

index
The zero-based index at which the ImageXTag should be inserted.
tag
The ImageXTag to be inserted.
Remarks

Note: Available in Professional edition.

See Also

Reference

ImageXTagCollection Class
ImageXTagCollection Members


Remove Method (ImageXTagCollection)

Remove Method (ImageXTagCollection)

Accusoft.ImagXpressSdk Namespace > ImageXTagCollection Class : Remove Method
The ImageXTag to be removed.
Removes the ImageXTag from the collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Remove( _
   ByVal tag As ImageXTag _
)
'Usage

Dim instance As ImageXTagCollection
Dim tag As ImageXTag

instance.Remove(tag)
public void Remove(
   ImageXTag tag
)
public: void Remove(
   ImageXTag* tag
)
public:
void Remove(
   ImageXTag^ tag
)

Parameters

tag
The ImageXTag to be removed.
Remarks

Note: Available in Professional edition.

See Also

Reference

ImageXTagCollection Class
ImageXTagCollection Members


RemoveAt Method (ImageXTagCollection)

RemoveAt Method (ImageXTagCollection)

Accusoft.ImagXpressSdk Namespace > ImageXTagCollection Class : RemoveAt Method
An integer value which represents the index which matches the ImageXTag object to remove from the collection.
Removes the specified ImageXTag from the collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shadows Sub RemoveAt( _
   ByVal index As Integer _
)
'Usage

Dim instance As ImageXTagCollection
Dim index As Integer

instance.RemoveAt(index)
public new void RemoveAt(
   int index
)
public: new void RemoveAt(
   int index
)
public:
new void RemoveAt(
   int index
)

Parameters

index
An integer value which represents the index which matches the ImageXTag object to remove from the collection.
Remarks

Call the ImageXTag destructor to free the ImageXTag then remove the ImageXTag from the collection.

Note: Available in Professional edition.

See Also

Reference

ImageXTagCollection Class
ImageXTagCollection Members


RemoveTag Method

RemoveTag Method

Accusoft.ImagXpressSdk Namespace > ImageXTagCollection Class : RemoveTag Method
An integer value which represents the number of the tag.
A byte value which represents the tag level at which the requested tag resides.
Removes an ImageXTag from the ImageXTagCollection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub RemoveTag( _
   ByVal TagNumber As Integer, _
   ByVal level As Byte _
)
'Usage

Dim instance As ImageXTagCollection
Dim TagNumber As Integer
Dim level As Byte

instance.RemoveTag(TagNumber, level)
public void RemoveTag(
   int TagNumber,
   byte level
)
public: void RemoveTag(
   int TagNumber,
   byte level
)
public:
void RemoveTag(
   int TagNumber,
   byte level
)

Parameters

TagNumber
An integer value which represents the number of the tag.
level
A byte value which represents the tag level at which the requested tag resides.
Remarks

This method is for multipage document formats such as TIFF and EXIF.

Note: Available in Professional edition.

See Also

Reference

ImageXTagCollection Class
ImageXTagCollection Members


ImageXTagCollection Class Properties

ImageXTagCollection Class Properties

Accusoft.ImagXpressSdk Namespace : ImageXTagCollection Class

For a list of all members of this type, see ImageXTagCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets and sets the index values within the collection.
Top
See Also

Reference

ImageXTagCollection Class
Accusoft.ImagXpressSdk Namespace


Item Property (ImageXTagCollection)

Item Property (ImageXTagCollection)

Accusoft.ImagXpressSdk Namespace > ImageXTagCollection Class : Item Property
Gets and sets the index values within the collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Default Property Item( _
   ByVal index As Integer _
) As ImageXTag
'Usage

Dim instance As ImageXTagCollection
Dim index As Integer
Dim value As ImageXTag

instance.Item(index) = value

value = instance.Item(index)
public ImageXTag this[
   int index
]; {get; set;}
public: __property ImageXTag* get_Item   int index
;
public: __property void set_Item   int index,
   ImageXTag* value
;
public:
property ImageXTag^ default [int] {
   ImageXTag^ get(int index);
   void set (int index, ImageXTag^ value);
}

Parameters

index

Property Value

An ImageXTag object to index.
Remarks

Note: Available in Professional edition.

See Also

Reference

ImageXTagCollection Class
ImageXTagCollection Members


ImageXView Class

ImageXView Class
Members

Accusoft.ImagXpressSdk Namespace : ImageXView Class
Implements the properties, methods and events for the viewer control.
Object Model
ImageXView ClassImageX ClassImageX ClassImageCalsCollection ClassImageCalsTag ClassImageX ClassImageX ClassImageX ClassImageX ClassImageX ClassImageX ClassImageX ClassImageXData ClassImageXIptcCollection ClassImageXIptcData ClassLoadOptions ClassImageModcaCollection ClassImageModcaTag ClassImageXData ClassImageXData ClassImageXData ClassImageX ClassResolution ClassImageXTagCollection ClassImageXTag ClassMedical ClassLookupTable ClassLookupTable ClassRubberband ClassImageX ClassSprite ClassToolbar ClassToolbarContextMenu ClassTouch ClassImagXpress ClassLicensing Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ToolboxBitmapAttribute()>
<DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="System.Windows.Forms.Design.ParentControlDesigner,System.Design")>
Public Class ImageXView
   Inherits System.Windows.Forms.UserControl
'Usage

Dim instance As ImageXView
[ToolboxBitmap()]
[Designer(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="System.Windows.Forms.Design.ParentControlDesigner,System.Design")]
public class ImageXView : System.Windows.Forms.UserControl
[ToolboxBitmap()]
[Designer(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="System.Windows.Forms.Design.ParentControlDesigner,System.Design")]
public __gc class ImageXView : public System.Windows.Forms.UserControl
[ToolboxBitmap()]
[Designer(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="System.Windows.Forms.Design.ParentControlDesigner,System.Design")]
public ref class ImageXView : public System.Windows.Forms.UserControl
Remarks

This class contains functionality for modifying an image's appearance as it is displayed in the viewer control.

If you create an ImageXView control at runtime then it is necessary to pass in an instance of an ImagXpress component either directly in the constructor or indirectly through the container or you must use the Workspace property. Please review each constructor's help page for a code example on how to properly use the constructor so that the ImageXView control is properly licensed.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
Accusoft.ImagXpressSdk.ImageXView

See Also

Reference

ImageXView Members
Accusoft.ImagXpressSdk Namespace


ImageXView Class Members

ImageXView Class Members
Properties Methods Events

Accusoft.ImagXpressSdk Namespace : ImageXView Class

The following tables list the members exposed by ImageXView.

Public Constructors
 | Name | Description
Public Constructor | ImageXView Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | AccessibilityObject | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | (Inherited from System.Windows.Forms.Control)
Public Property | ActiveControl | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AlignHorizontal | Gets and sets the horizontal alignment of the image being viewed.
Public Property | AlignVertical | Gets and sets the vertical alignment of the image being viewed.
Public Property | AllowDrop | (Inherited from System.Windows.Forms.Control)
Public Property | AllowUpdate | Gets and sets an indicator which determines if updates allow the control to be repainted.
Public Property | AlphaBlend | Gets and sets an indication of alpha blending an image to the background of the control when an alpha channel is present in the image.
Public Property | Anchor | (Inherited from System.Windows.Forms.Control)
Public Property | Antialias | Gets and sets the anti-alias effect.
Public Property | AspectX | Gets and sets the horizontal aspect ratio of the current image.
Public Property | AspectY | Gets and sets the vertical aspect ratio of the current image.
Public Property | AutoImageDispose | Gets and sets enabling the ImageXView's Dispose method to automatically call the ImageX's Dispose method.
Public Property | AutoResize | Gets and sets how the image is sized and positioned for display when painted.
Public Property | AutoScaleDimensions | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScaleMode | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollOffset | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollPosition | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoSizeMode | (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoValidate | (Inherited from System.Windows.Forms.UserControl)
Public Property | BackColor | Overridden. Sets the background color of the view window.
Public Property | BackgroundImage | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | BorderStyle | Gets and sets the border type of the ImageXView object.
Public Property | BorderType | Gets and sets the border type of the ImageXView object.
Public Property | Bottom | (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | (Inherited from System.Windows.Forms.Control)
Public Property | Brightness | Gets and sets the change of brightness of the current image.
Public Property | CanFocus | (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | (Inherited from System.Windows.Forms.Control)
Public Property | Capture | (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | (Inherited from System.Windows.Forms.Control)
Public Property | ClientRectangle | (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | (Inherited from System.Windows.Forms.Control)
Public Property | ClipRectangle | Gets and sets the rectangular portion of the image that is accessible to the viewer.
Public Property | ColorRenderIntent | Gets and sets how the color profiles should be applied.
Public Property | CompanyName | (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | Overridden. Gets or sets the shortcut menu associated with the control.
Public Property | ContextMenuStrip | (Inherited from System.Windows.Forms.Control)
Public Property | Contrast | Gets and sets the change of contrast level for the displayed image.
Public Property | Controls | (Inherited from System.Windows.Forms.Control)
Public Property | Created | (Inherited from System.Windows.Forms.Control)
Public Property | CurrentAutoScaleDimensions | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | Cursor | (Inherited from System.Windows.Forms.Control)
Public Property | CursorPosition | Gets the coordinates of the cursor position in the view window.
Public Property | DataBindings | (Inherited from System.Windows.Forms.Control)
Public Property | DisplayMode | Returns or sets a value indicating the maximum color depth used to render an image.
Public Property | DisplayRectangle | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Disposing | (Inherited from System.Windows.Forms.Control)
Public Property | Dithered | Gets and sets the display image dithering state.
Public Property | Dock | (Inherited from System.Windows.Forms.Control)
Public Property | Enabled | (Inherited from System.Windows.Forms.Control)
Public Property | Focused | (Inherited from System.Windows.Forms.Control)
Public Property | Font | (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | (Inherited from System.Windows.Forms.Control)
Public Property | GrayMode | Gets and sets the mode of gray used to display a grayscale image.
Public Property | Handle | (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | (Inherited from System.Windows.Forms.Control)
Public Property | Height | (Inherited from System.Windows.Forms.Control)
Public Property | HorizontalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | IcmEnabled | Gets and sets an enabled indicator for the color management.
Public Property | IcmProofingEnabled | Gets and sets an enabled indicator of the ICM target proofing.
Public Property | Image | Gets and sets the current image view.
Public Property | ImageCursorPosition | Gets the point at which the cursor is located within the image, in pixels.
Public Property | ImeMode | (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | (Inherited from System.Windows.Forms.Control)
Public Property | LayoutEngine | (Inherited from System.Windows.Forms.Control)
Public Property | Left | (Inherited from System.Windows.Forms.Control)
Public Property | Location | (Inherited from System.Windows.Forms.Control)
Public Property | Margin | (Inherited from System.Windows.Forms.Control)
Public Property | Maximum | Gets and sets the maximum dimensions the viewer control can obtain.
Public Property | MaximumSize | (Inherited from System.Windows.Forms.Control)
Public Property | Medical | Gets and sets information required to display medical images.
Public Property | Minimum | Gets and sets the minimum dimensions the viewer control can obtain.
Public Property | MinimumSize | (Inherited from System.Windows.Forms.Control)
Public Property | MonitorProfileName | Gets and sets the monitor’s color management profile.
Public Property | MouseWheelCapture | Gets and sets capturing the mousewheel even when the control does not have focus.
Public Property | Name | (Inherited from System.Windows.Forms.Control)
Public Property | Padding | (Inherited from System.Windows.Forms.Control)
Public Property | PaletteFilename | Specifies the filename that contains the palette for the control.
Public Property | PaletteType | Gets and sets the image display palette type.
Public Property | Parent | (Inherited from System.Windows.Forms.Control)
Public Property | ParentForm | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | PixelColor | Gets the color of the pixel within the client area of the view control at which the cursor is currently positioned.
Public Property | PreferredSize | (Inherited from System.Windows.Forms.Control)
Public Property | PreserveBlack | Gets and sets an indicator if black should be preserved and applied when viewing the image.
Public Property | PrinterProfileName | Gets and sets the printer’s profile filename.
Public Property | ProductName | (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | (Inherited from System.Windows.Forms.Control)
Public Property | Progressive | Gets and sets an indication if images are displayed progressively.
Public Property | RecreatingHandle | (Inherited from System.Windows.Forms.Control)
Public Property | RefreshMode | Gets and sets an indicator which specifies when the control is refreshed after an operation is completed on the attached Image.
Public Property | Region | (Inherited from System.Windows.Forms.Control)
Public Property | Right | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | (Inherited from System.Windows.Forms.Control)
Public Property | Rubberband | Gets the current Rubberband object.
Public Property | ScrollBars | Gets or sets the type of scroll bars to display in the ImageXView control.
Public Property | ScrollPosition | Gets and sets the current scrolling position of the cursor on the scrollbar.
Public Property | Site | (Inherited from System.Windows.Forms.Control)
Public Property | Size | (Inherited from System.Windows.Forms.Control)
Public Property | Smoothing | Gets and sets an indicator for the smoothing effect on the current color image.
Public Property | Sprite | Gets the Sprite object.
Public Property | TabIndex | (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | (Inherited from System.Windows.Forms.Control)
Public Property | Tag | (Inherited from System.Windows.Forms.Control)
Public Property | TargetProfileName | Gets and sets the target profile’s filename.
Public Property | ToolActive | Gets the currently active tool.
Public Property | Toolbar | Gets the current Toolbar object.
Public Property | Top | (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | (Inherited from System.Windows.Forms.Control)
Public Property | Touch | Gets the current Touch object for setting Touch behavior.
Public Property | UseWaitCursor | (Inherited from System.Windows.Forms.Control)
Public Property | VerticalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Visible | (Inherited from System.Windows.Forms.Control)
Public Property | Width | (Inherited from System.Windows.Forms.Control)
Public Property | Workspace | Gets or sets the ImagXpress workspace component.
Public Property | ZoomFactor | Gets and sets the zoom factor display for the current image.
Top
Public Methods
 | Name | Description
Public Method | BeginInvoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | (Inherited from System.Windows.Forms.Control)
Public Method | CaptureControl | Captures the screen area bounded by the control and saves it to the current image.
Public Method | CaptureWindow | Overloaded. Captures the screen area within the specified Window and saves it to the current Image.
Public Method | Contains | (Inherited from System.Windows.Forms.Control)
Public Method | CopyToClipboard | Overloaded. Copies the current image to the clipboard.
Public Method | CreateControl | (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose() | (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | (Inherited from System.Windows.Forms.Control)
Public Method | Focus | (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetPaletteColor | Retrieves the colors for a user defined palette for the control.
Public Method | GetPreferredSize | (Inherited from System.Windows.Forms.Control)
Public Method | Hide | (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | IsToolCursorBuiltin | Determines if the current cursor for a tool is the built-in default cursor.
Public Method | MouseWheelGet | Retrieves which MouseWheelAction is assigned to a given mousewheel/shift combination.
Public Method | MouseWheelGetAttribute | Retrieves the value of a specific mousewheel action's attribute.
Public Method | MouseWheelSet | Assigns a MouseWheelAction to a particular shift/mousewheel combination.
Public Method | MouseWheelSetAttribute | Sets the value of a specific mousewheel action's attribute.
Public Method | PasteFromClipboard | Pastes the image from the clipboard to the current image.
Public Method | PerformAutoScale | (Inherited from System.Windows.Forms.ContainerControl)
Public Method | PerformLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | (Inherited from System.Windows.Forms.Control)
Public Method | Print | Overloaded. Prints an image to the current graphics object given graphics and rectangle values.
Public Method | RectangleToClient | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | (Inherited from System.Windows.Forms.Control)
Public Method | ResetText | (Inherited from System.Windows.Forms.Control)
Public Method | ResetToolCursor | Resets the cursor for a specific tool cursor type back to the built-in default cursor.
Public Method | ResumeLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Scale | (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | Select | (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | (Inherited from System.Windows.Forms.Control)
Public Method | SetAutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | SetPaletteColor | Specifies the colors for a user defined palette for the control.
Public Method | SetToolCursor | Sets the cursor for a specific tool cursor type.
Public Method | Show | (Inherited from System.Windows.Forms.Control)
Public Method | ShowImageInfo | Invokes a dialog box displaying image information.
Public Method | SuspendLayout | (Inherited from System.Windows.Forms.Control)
Public Method | ToolGet | Retrieves which tool is assigned to a given mouse/shift combination.
Public Method | ToolGetAttribute | Retrieves the value of a specific tool's attribute.
Public Method | ToolIsAttributeSupported | Retrieves whether the attribute is supported for a specific tool.
Public Method | ToolSet | Assigns a tool to a particular shift/mouse combination.
Public Method | ToolSetAttribute | Sets the value of a specific tool's attribute.
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Translate | Translates values from one coordinate system to the other.
Public Method | Update | (Inherited from System.Windows.Forms.Control)
Public Method | Validate | Overloaded. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | ValidateChildren | Overloaded. (Inherited from System.Windows.Forms.UserControl)
Public Method | ZoomToFit | Zoom the image display to fit within the ImageXView control.
Top
Public Events
 | Name | Description
Public Event | AutoResizeChanged | Thrown when the AutoResize property changes.
Public Event | AutoSizeChanged | (Inherited from System.Windows.Forms.UserControl)
Public Event | AutoValidateChanged | (Inherited from System.Windows.Forms.UserControl)
Public Event | BackColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | (Inherited from System.Windows.Forms.Control)
Public Event | Click | (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Enter | (Inherited from System.Windows.Forms.Control)
Public Event | Flick | Thrown when the user performs a flick on the Touch interface.
Public Event | FontChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | (Inherited from System.Windows.Forms.Control)
Public Event | Layout | (Inherited from System.Windows.Forms.Control)
Public Event | Leave | (Inherited from System.Windows.Forms.Control)
Public Event | Load | (Inherited from System.Windows.Forms.UserControl)
Public Event | LocationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | (Inherited from System.Windows.Forms.Control)
Public Event | Move | (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Paint | (Inherited from System.Windows.Forms.Control)
Public Event | PaintImage | Thrown when the image is painted onto the screen.
Public Event | PanGestureOccurred | Thrown when the user has finished panning with the Touch interface.
Public Event | PanGestureOccurring | Thrown when the user is in the process of panning with the Touch interface.
Public Event | ParentChanged | (Inherited from System.Windows.Forms.Control)
Public Event | PressAndHold | Thrown when the user performs a press and hold with the Touch interface.
Public Event | PressAndTap | Thrown when the user performs a press and tap with the Touch interface.
Public Event | PreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | PrintImage | Thrown when the image is printed onto the paper.
Public Event | QueryAccessibilityHelp | (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Resize | (Inherited from System.Windows.Forms.Control)
Public Event | Resized | Thrown after the control has been completely resized.
Public Event | RightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Public Event | RotationGestureOccurred | Thrown when the user has finished rotating with the Touch interface.
Public Event | RotationGestureOccurring | Thrown when the user is in the process of rotating with the Touch interface.
Public Event | Scroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | ScrollbarVisibleChanged | Thrown when one or more scrollbars changes its visibility.
Public Event | ScrollEvent | Thrown during a scroll event.
Public Event | SizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ToolbarCloseEvent | Thrown when a toolbar close event occurs.
Public Event | ToolbarContextMenuSelectEvent | Thrown when the toolbar context menu is selected.
Public Event | ToolbarEvent | Thrown when a toolbar event occurs.
Public Event | ToolbarOpenEvent | Thrown when a toolbar open event occurs.
Public Event | ToolEvent | Thrown when a tool event occurs.
Public Event | TwoFingerTap | Thrown when the user performs a two finger tap on the Touch interface.
Public Event | Validated | (Inherited from System.Windows.Forms.Control)
Public Event | Validating | (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ZoomFactorChanged | Thrown when the ZoomFactor property changes.
Public Event | ZoomGestureOccurred | Thrown when the user has finished zooming with the Touch interface.
Public Event | ZoomGestureOccurring | Thrown when the user is in the process of zooming with the Touch interface.
Top
See Also

Reference

ImageXView Class
Accusoft.ImagXpressSdk Namespace


ImageXView Constructor

ImageXView Constructor

Accusoft.ImagXpressSdk Namespace > ImageXView Class : ImageXView Constructor
Overload List
Overload | Description
ImageXView Constructor() | Initializes a new unlicensed instance of the ImageXView class.
ImageXView Constructor(IContainer) | Initializes a new instance of the ImageXView class.
ImageXView Constructor(ImagXpress) | Initializes a new instance of the ImageXView class.
ImageXView Constructor(IContainer,ImagXpress) | Initializes a new instance of the ImageXView class.
See Also

Reference

ImageXView Class
ImageXView Members


ImageXView Constructor()

ImageXView Constructor()
Example

Accusoft.ImagXpressSdk Namespace > ImageXView Class > ImageXView Constructor : ImageXView Constructor()
Initializes a new unlicensed instance of the ImageXView class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImageXView()
public ImageXView()
public: ImageXView();
public:
ImageXView();
Remarks

This is the default constructor for the ImageXView class. If you need to create an ImageXView dynamically it is strongly recommended that you do so with one of the other constructors. If you use this constructor you will need to set the Workspace property before displaying the control on the form or calling one of its methods. See the example below on how to do this properly.

Note: Failure to set the Workspace property with a valid ImagXpress workspace component when you use this constructor will cause the control to display a warning message in its window as well as throw an exception on certain properties and methods.

Example
This sample shows how to use this constructor properly to avoid licensing issues.
  • C#
public partial class Form1 : Form
{
        public Form1()
        {
            InitializeComponent();
            // Create an ImagXpress object for licensing
            Accusoft.ImagXpressSdk.ImagXpress imagXpress1 = new Accusoft.ImagXpressSdk.ImagXpress();
         //***The SetSolutionName, SetSolutionKey and possibly the SetOEMLicenseKey methods must be called to distribute the runtime***
         imagXpress1.Licensing.SetSolutionName(“YourSolutionName”);
         imagXpress1.Licensing.SetSolutionKey(12345,12345,12345,12345);
         imagXpress1.Licensing.SetOEMLicenseKey(“1.0.AStringForOEMLicensingContactAccusoftSalesForMoreInformation…”);

            // if you use the default empty constructor, you must call the Workspace property before
            // displaying the control or calling one of its methods.
            Accusoft.ImagXpressSdk.ImageXView imageXView1 = new Accusoft.ImagXpressSdk.ImageXView();
            imageXView1.Workspace = imagXpress1;
        }
}
See Also

Reference

ImageXView Class
ImageXView Members
Overload List


ImageXView Constructor(IContainer)

ImageXView Constructor(IContainer)
Example

Accusoft.ImagXpressSdk Namespace > ImageXView Class > ImageXView Constructor : ImageXView Constructor(IContainer)
The container that implements the System.ComponentModel.IContainer interface which will contain this component.
Initializes a new instance of the ImageXView class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal container As IContainer _
)
'Usage

Dim container As IContainer

Dim instance As New ImageXView(container)
public ImageXView(
   IContainer container
)
public: ImageXView(
   IContainer* container
)
public:
ImageXView(
   IContainer^ container
)

Parameters

container
The container that implements the System.ComponentModel.IContainer interface which will contain this component.
Remarks

The container must also contain a ImagXpress workspace component for licensing.

Example
This sample shows how to use this constructor properly to avoid licensing issues.
  • C#
public partial class Form1 : Form
{
        public Form1()
        {
            InitializeComponent();
            // Create an ImagXpress object for licensing and pass in the IContainer of the form
            Accusoft.ImagXpressSdk.ImagXpress imagXpress1 = new Accusoft.ImagXpressSdk.ImagXpress(this.components);
         //***The SetSolutionName, SetSolutionKey and possibly the SetOEMLicenseKey methods must be called to distribute the runtime***
         imagXpress1.Licensing.SetSolutionName(“YourSolutionName”);
         imagXpress1.Licensing.SetSolutionKey(12345,12345,12345,12345);
         imagXpress1.Licensing.SetOEMLicenseKey(“1.0.AStringForOEMLicensingContactAccusoftSalesForMoreInformation…”);

            // Create an ImageXView object and pass in the IContainer of the form that contains the
            // ImagXpress workspace component.
            Accusoft.ImagXpressSdk.ImageXView imageXView1 = new Accusoft.ImagXpressSdk.ImageXView(this.components);
            this.Controls.Add(imageXView1);
        }
}
See Also

Reference

ImageXView Class
ImageXView Members
Overload List


ImageXView Constructor(ImagXpress)

ImageXView Constructor(ImagXpress)
Example

Accusoft.ImagXpressSdk Namespace > ImageXView Class > ImageXView Constructor : ImageXView Constructor(ImagXpress)
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
Initializes a new instance of the ImageXView class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal imagXpress As ImagXpress _
)
'Usage

Dim imagXpress As ImagXpress

Dim instance As New ImageXView(imagXpress)
public ImageXView(
   ImagXpress imagXpress
)
public: ImageXView(
   ImagXpress* imagXpress
)
public:
ImageXView(
   ImagXpress^ imagXpress
)

Parameters

imagXpress
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
Example
This sample shows how to use this constructor properly to avoid licensing issues.
  • C#
public partial class Form1 : Form
{
        public Form1()
        {
            InitializeComponent();
            // Create an ImagXpress object for licensing and pass in the IContainer of the form
            Accusoft.ImagXpressSdk.ImagXpress imagXpress1 = new Accusoft.ImagXpressSdk.ImagXpress(this.components);
         //***The SetSolutionName, SetSolutionKey and possibly the SetOEMLicenseKey methods must be called to distribute the runtime***
         imagXpress1.Licensing.SetSolutionName(“YourSolutionName”);
         imagXpress1.Licensing.SetSolutionKey(12345,12345,12345,12345);
         imagXpress1.Licensing.SetOEMLicenseKey(“1.0.AStringForOEMLicensingContactAccusoftSalesForMoreInformation…”);

            // Create an ImageXView object and pass in the ImagXpress workspace component.
            Accusoft.ImagXpressSdk.ImageXView imageXView1 = new Accusoft.ImagXpressSdk.ImageXView(imagXpress1);
            this.Controls.Add(imageXView1);
        }
}
See Also

Reference

ImageXView Class
ImageXView Members
Overload List


ImageXView Constructor(IContainer,ImagXpress)

ImageXView Constructor(IContainer,ImagXpress)
Example

Accusoft.ImagXpressSdk Namespace > ImageXView Class > ImageXView Constructor : ImageXView Constructor(IContainer,ImagXpress)
The container that implements the System.ComponentModel.IContainer interface which will contain this control.
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
Initializes a new instance of the ImageXView class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal container As IContainer, _
   ByVal imagXpress As ImagXpress _
)
'Usage

Dim container As IContainer
Dim imagXpress As ImagXpress

Dim instance As New ImageXView(container, imagXpress)
public ImageXView(
   IContainer container,
   ImagXpress imagXpress
)
public: ImageXView(
   IContainer* container,
   ImagXpress* imagXpress
)
public:
ImageXView(
   IContainer^ container,
   ImagXpress^ imagXpress
)

Parameters

container
The container that implements the System.ComponentModel.IContainer interface which will contain this control.
imagXpress
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
Example
This sample shows how to use this constructor properly to avoid licensing issues.
  • C#
public partial class Form1 : Form
{
        public Form1()
        {
            InitializeComponent();
            // Create an ImagXpress object for licensing and pass in the IContainer of the form
            Accusoft.ImagXpressSdk.ImagXpress imagXpress1 = new Accusoft.ImagXpressSdk.ImagXpress(this.components);
         //***The SetSolutionName, SetSolutionKey and possibly the SetOEMLicenseKey methods must be called to distribute the runtime***
         imagXpress1.Licensing.SetSolutionName(“YourSolutionName”);
         imagXpress1.Licensing.SetSolutionKey(12345,12345,12345,12345);
         imagXpress1.Licensing.SetOEMLicenseKey(“1.0.AStringForOEMLicensingContactAccusoftSalesForMoreInformation…”);

            // Create an ImageXView object and pass in the both the IContainer of the form and
            // the ImagXpress workspace component.
            Accusoft.ImagXpressSdk.ImageXView imageXView1 = new Accusoft.ImagXpressSdk.ImageXView(this.components, imagXpress1);
            this.Controls.Add(imageXView1);
        }
}
See Also

Reference

ImageXView Class
ImageXView Members
Overload List


ImageXView Class Methods

ImageXView Class Methods

Accusoft.ImagXpressSdk Namespace : ImageXView Class

For a list of all members of this type, see ImageXView members.

Public Methods
 | Name | Description
Public Method | BeginInvoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | (Inherited from System.Windows.Forms.Control)
Public Method | CaptureControl | Captures the screen area bounded by the control and saves it to the current image.
Public Method | CaptureWindow | Overloaded. Captures the screen area within the specified Window and saves it to the current Image.
Public Method | Contains | (Inherited from System.Windows.Forms.Control)
Public Method | CopyToClipboard | Overloaded. Copies the current image to the clipboard.
Public Method | CreateControl | (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose() | (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | (Inherited from System.Windows.Forms.Control)
Public Method | Focus | (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetPaletteColor | Retrieves the colors for a user defined palette for the control.
Public Method | GetPreferredSize | (Inherited from System.Windows.Forms.Control)
Public Method | Hide | (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | IsToolCursorBuiltin | Determines if the current cursor for a tool is the built-in default cursor.
Public Method | MouseWheelGet | Retrieves which MouseWheelAction is assigned to a given mousewheel/shift combination.
Public Method | MouseWheelGetAttribute | Retrieves the value of a specific mousewheel action's attribute.
Public Method | MouseWheelSet | Assigns a MouseWheelAction to a particular shift/mousewheel combination.
Public Method | MouseWheelSetAttribute | Sets the value of a specific mousewheel action's attribute.
Public Method | PasteFromClipboard | Pastes the image from the clipboard to the current image.
Public Method | PerformAutoScale | (Inherited from System.Windows.Forms.ContainerControl)
Public Method | PerformLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | (Inherited from System.Windows.Forms.Control)
Public Method | Print | Overloaded. Prints an image to the current graphics object given graphics and rectangle values.
Public Method | RectangleToClient | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | (Inherited from System.Windows.Forms.Control)
Public Method | ResetText | (Inherited from System.Windows.Forms.Control)
Public Method | ResetToolCursor | Resets the cursor for a specific tool cursor type back to the built-in default cursor.
Public Method | ResumeLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Scale | (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | Select | (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | (Inherited from System.Windows.Forms.Control)
Public Method | SetAutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | SetPaletteColor | Specifies the colors for a user defined palette for the control.
Public Method | SetToolCursor | Sets the cursor for a specific tool cursor type.
Public Method | Show | (Inherited from System.Windows.Forms.Control)
Public Method | ShowImageInfo | Invokes a dialog box displaying image information.
Public Method | SuspendLayout | (Inherited from System.Windows.Forms.Control)
Public Method | ToolGet | Retrieves which tool is assigned to a given mouse/shift combination.
Public Method | ToolGetAttribute | Retrieves the value of a specific tool's attribute.
Public Method | ToolIsAttributeSupported | Retrieves whether the attribute is supported for a specific tool.
Public Method | ToolSet | Assigns a tool to a particular shift/mouse combination.
Public Method | ToolSetAttribute | Sets the value of a specific tool's attribute.
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Translate | Translates values from one coordinate system to the other.
Public Method | Update | (Inherited from System.Windows.Forms.Control)
Public Method | Validate | Overloaded. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | ValidateChildren | Overloaded. (Inherited from System.Windows.Forms.UserControl)
Public Method | ZoomToFit | Zoom the image display to fit within the ImageXView control.
Top
See Also

Reference

ImageXView Class
Accusoft.ImagXpressSdk Namespace


CaptureControl Method

CaptureControl Method

Accusoft.ImagXpressSdk Namespace > ImageXView Class : CaptureControl Method
Captures the screen area bounded by the control and saves it to the current image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub CaptureControl()
'Usage

Dim instance As ImageXView

instance.CaptureControl()
public void CaptureControl()
public: void CaptureControl();
public:
void CaptureControl();
Remarks

This method captures the image data within the screen area bounded by the control and saved to ImageXView.Image.

See Also

Reference

ImageXView Class
ImageXView Members


CaptureWindow Method

CaptureWindow Method

Accusoft.ImagXpressSdk Namespace > ImageXView Class : CaptureWindow Method
Captures the screen area within the specified Window and saves it to the current Image.
Overload List
Overload | Description
CaptureWindow(IntPtr) | Captures the screen area within the specified Window and saves it to the current Image.
CaptureWindow(IntPtr,Rectangle) | Captures the screen area within the specified Window and saves it to the current Image.
See Also

Reference

ImageXView Class
ImageXView Members


CaptureWindow(IntPtr) Method

CaptureWindow(IntPtr) Method

Accusoft.ImagXpressSdk Namespace > ImageXView Class > CaptureWindow Method : CaptureWindow(IntPtr) Method
A value that evaluates to a Window handle.
Captures the screen area within the specified Window and saves it to the current Image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub CaptureWindow( _
   ByVal hWnd As IntPtr _
)
'Usage

Dim instance As ImageXView
Dim hWnd As IntPtr

instance.CaptureWindow(hWnd)
public void CaptureWindow(
   IntPtr hWnd
)
public: void CaptureWindow(
   IntPtr hWnd
)
public:
void CaptureWindow(
   IntPtr hWnd
)

Parameters

hWnd
A value that evaluates to a Window handle.
Remarks

The image data within the specified window is saved to ImageXView.Image.

See Also

Reference

ImageXView Class
ImageXView Members
Overload List


CaptureWindow(IntPtr,Rectangle) Method

CaptureWindow(IntPtr,Rectangle) Method

Accusoft.ImagXpressSdk Namespace > ImageXView Class > CaptureWindow Method : CaptureWindow(IntPtr,Rectangle) Method
A value that evaluates to a Window handle.
A System.Drawing.Rectangle area in pixels within the specified window.
Captures the screen area within the specified Window and saves it to the current Image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub CaptureWindow( _
   ByVal hWnd As IntPtr, _
   ByVal captureRectangle As Rectangle _
)
'Usage

Dim instance As ImageXView
Dim hWnd As IntPtr
Dim captureRectangle As Rectangle

instance.CaptureWindow(hWnd, captureRectangle)
public void CaptureWindow(
   IntPtr hWnd,
   Rectangle captureRectangle
)
public: void CaptureWindow(
   IntPtr hWnd,
   Rectangle captureRectangle
)
public:
void CaptureWindow(
   IntPtr hWnd,
   Rectangle captureRectangle
)

Parameters

hWnd
A value that evaluates to a Window handle.
captureRectangle
A System.Drawing.Rectangle area in pixels within the specified window.
Remarks

The image data within the specified window is saved to ImageXView.Image.

See Also

Reference

ImageXView Class
ImageXView Members
Overload List


CopyToClipboard Method

CopyToClipboard Method

Accusoft.ImagXpressSdk Namespace > ImageXView Class : CopyToClipboard Method
Copies the current image to the clipboard.
Overload List
Overload | Description
CopyToClipboard() | Copies the current image to the clipboard.
CopyToClipboard(ClipboardFormat) | Copies the current image to the clipboard in the format specified.
See Also

Reference

ImageXView Class
ImageXView Members


CopyToClipboard() Method

CopyToClipboard() Method

Accusoft.ImagXpressSdk Namespace > ImageXView Class > CopyToClipboard Method : CopyToClipboard() Method
Copies the current image to the clipboard.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub CopyToClipboard()
'Usage

Dim instance As ImageXView

instance.CopyToClipboard()
public void CopyToClipboard()
public: void CopyToClipboard();
public:
void CopyToClipboard();
Remarks

This method makes a copy of the Image in DIB format and places it on the clipboard.

See Also

Reference

ImageXView Class
ImageXView Members
Overload List


CopyToClipboard(ClipboardFormat) Method

CopyToClipboard(ClipboardFormat) Method

Accusoft.ImagXpressSdk Namespace > ImageXView Class > CopyToClipboard Method : CopyToClipboard(ClipboardFormat) Method
The format you wish to have placed in the clipboard.
Copies the current image to the clipboard in the format specified.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub CopyToClipboard( _
   ByVal format As ClipboardFormat _
)
'Usage

Dim instance As ImageXView
Dim format As ClipboardFormat

instance.CopyToClipboard(format)
public void CopyToClipboard(
   ClipboardFormat format
)
public: void CopyToClipboard(
   ClipboardFormat format
)
public:
void CopyToClipboard(
   ClipboardFormat format
)

Parameters

format
The format you wish to have placed in the clipboard.
Remarks

This method makes a copy of the Image in the format you specify and places it on the clipboard.

See Also

Reference

ImageXView Class
ImageXView Members
Overload List


Dispose Method (ImageXView)

Dispose Method (ImageXView)

Accusoft.ImagXpressSdk Namespace > ImageXView Class : Dispose Method
Clean up any resources being used.
Overload List
Overload | Description
Dispose() | (Inherited from System.ComponentModel.Component)
See Also

Reference

ImageXView Class
ImageXView Members


GetPaletteColor Method

GetPaletteColor Method

Accusoft.ImagXpressSdk Namespace > ImageXView Class : GetPaletteColor Method
An integer value which represents the index into the palette table. The minimum index is 0, the maximum Index is 255.
Retrieves the colors for a user defined palette for the control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetPaletteColor( _
   ByVal Index As Integer _
) As Color
'Usage

Dim instance As ImageXView
Dim Index As Integer
Dim value As Color

value = instance.GetPaletteColor(Index)
public Color GetPaletteColor(
   int Index
)
public: Color GetPaletteColor(
   int Index
)
public:
Color GetPaletteColor(
   int Index
)

Parameters

Index
An integer value which represents the index into the palette table. The minimum index is 0, the maximum Index is 255.

Return Value

A System.Drawing.Color value for that palette location.
Remarks

When the PaletteType property is set to PaletteType.UserDefined, images displayed during palettized display use the palette defined by this method.

Valid values are 0 to 255.

See Also

Reference

ImageXView Class
ImageXView Members


IsToolCursorBuiltin Method

IsToolCursorBuiltin Method

Accusoft.ImagXpressSdk Namespace > ImageXView Class : IsToolCursorBuiltin Method
Tool cursor type to check.
Determines if the current cursor for a tool is the built-in default cursor.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function IsToolCursorBuiltin( _
   ByVal cursorType As ToolCursor _
) As Boolean
'Usage

Dim instance As ImageXView
Dim cursorType As ToolCursor
Dim value As Boolean

value = instance.IsToolCursorBuiltin(cursorType)
public bool IsToolCursorBuiltin(
   ToolCursor cursorType
)
public: bool IsToolCursorBuiltin(
   ToolCursor cursorType
)
public:
bool IsToolCursorBuiltin(
   ToolCursor cursorType
)

Parameters

cursorType
Tool cursor type to check.

Return Value

A System.Boolean value for the built-in status of the tool cursor.
See Also

Reference

ImageXView Class
ImageXView Members


MouseWheelGet Method

MouseWheelGet Method

Accusoft.ImagXpressSdk Namespace > ImageXView Class : MouseWheelGet Method
The System.Windows.Forms.Keys value which represents the shift key to be pressed. Currently the only supported keys are shift, control, and alt key values.
Retrieves which MouseWheelAction is assigned to a given mousewheel/shift combination.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function MouseWheelGet( _
   ByVal key As Keys _
) As MouseWheelAction
'Usage

Dim instance As ImageXView
Dim key As Keys
Dim value As MouseWheelAction

value = instance.MouseWheelGet(key)
public MouseWheelAction MouseWheelGet(
   Keys key
)
public: MouseWheelAction MouseWheelGet(
   Keys key
)
public:
MouseWheelAction MouseWheelGet(
   Keys key
)

Parameters

key
The System.Windows.Forms.Keys value which represents the shift key to be pressed. Currently the only supported keys are shift, control, and alt key values.

Return Value

The MouseWheelAction assigned to mousewheel/shift combination.
See Also

Reference

ImageXView Class
ImageXView Members


MouseWheelGetAttribute Method

MouseWheelGetAttribute Method

Accusoft.ImagXpressSdk Namespace > ImageXView Class : MouseWheelGetAttribute Method
Specific attribute to get the value from.
Retrieves the value of a specific mousewheel action's attribute.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function MouseWheelGetAttribute( _
   ByVal attribute As MouseWheelAttribute _
) As Integer
'Usage

Dim instance As ImageXView
Dim attribute As MouseWheelAttribute
Dim value As Integer

value = instance.MouseWheelGetAttribute(attribute)
public int MouseWheelGetAttribute(
   MouseWheelAttribute attribute
)
public: int MouseWheelGetAttribute(
   MouseWheelAttribute attribute
)
public:
int MouseWheelGetAttribute(
   MouseWheelAttribute attribute
)

Parameters

attribute
Specific attribute to get the value from.

Return Value

An integer value for that tool's attribute.
See Also

Reference

ImageXView Class
ImageXView Members


MouseWheelSet Method

MouseWheelSet Method

Accusoft.ImagXpressSdk Namespace > ImageXView Class : MouseWheelSet Method
The MouseWheelAction to assign.
The System.Windows.Forms.Keys value which represents the shift key to be pressed. Currently the only supported keys are shift, control, and alt key values.
Assigns a MouseWheelAction to a particular shift/mousewheel combination.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub MouseWheelSet( _
   ByVal action As MouseWheelAction, _
   ByVal key As Keys _
)
'Usage

Dim instance As ImageXView
Dim action As MouseWheelAction
Dim key As Keys

instance.MouseWheelSet(action, key)
public void MouseWheelSet(
   MouseWheelAction action,
   Keys key
)
public: void MouseWheelSet(
   MouseWheelAction action,
   Keys key
)
public:
void MouseWheelSet(
   MouseWheelAction action,
   Keys key
)

Parameters

action
The MouseWheelAction to assign.
key
The System.Windows.Forms.Keys value which represents the shift key to be pressed. Currently the only supported keys are shift, control, and alt key values.
See Also

Reference

ImageXView Class
ImageXView Members


MouseWheelSetAttribute Method

MouseWheelSetAttribute Method

Accusoft.ImagXpressSdk Namespace > ImageXView Class : MouseWheelSetAttribute Method
Specific attribute to set the value on.
An integer value which represents the new attribute value.
Sets the value of a specific mousewheel action's attribute.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub MouseWheelSetAttribute( _
   ByVal attribute As MouseWheelAttribute, _
   ByVal newValue As Integer _
)
'Usage

Dim instance As ImageXView
Dim attribute As MouseWheelAttribute
Dim newValue As Integer

instance.MouseWheelSetAttribute(attribute, newValue)
public void MouseWheelSetAttribute(
   MouseWheelAttribute attribute,
   int newValue
)
public: void MouseWheelSetAttribute(
   MouseWheelAttribute attribute,
   int newValue
)
public:
void MouseWheelSetAttribute(
   MouseWheelAttribute attribute,
   int newValue
)

Parameters

attribute
Specific attribute to set the value on.
newValue
An integer value which represents the new attribute value.
See Also

Reference

ImageXView Class
ImageXView Members


PasteFromClipboard Method

PasteFromClipboard Method

Accusoft.ImagXpressSdk Namespace > ImageXView Class : PasteFromClipboard Method
Pastes the image from the clipboard to the current image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub PasteFromClipboard()
'Usage

Dim instance As ImageXView

instance.PasteFromClipboard()
public void PasteFromClipboard()
public: void PasteFromClipboard();
public:
void PasteFromClipboard();
Remarks

The image on the clipboard is pasted into an Image, overwriting any existing data in the Image object.

See Also

Reference

ImageXView Class
ImageXView Members


Print Method

Print Method

Accusoft.ImagXpressSdk Namespace > ImageXView Class : Print Method
Prints an image to the current graphics object given graphics and rectangle values.
Overload List
Overload | Description
Print(Graphics,Rectangle) | Prints an image to the current graphics object given graphics and rectangle values.
Print(Graphics,RectangleF) | Prints an image to the current graphics object given graphics and dimensions.
Print(Graphics,Rectangle,PrintType) | Prints an image to the current graphics object given graphics, dimensions and type of print.
Print(Graphics,RectangleF,PrintType) | Prints an image to the current graphics object given graphics, dimensions and type of print.
See Also

Reference

ImageXView Class
ImageXView Members


Print(Graphics,Rectangle) Method

Print(Graphics,Rectangle) Method

Accusoft.ImagXpressSdk Namespace > ImageXView Class > Print Method : Print(Graphics,Rectangle) Method
A System.Drawing.Graphics object.
A System.Drawing.Rectangle object.
Prints an image to the current graphics object given graphics and rectangle values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Print( _
   ByVal graphics As Graphics, _
   ByVal dimensions As Rectangle _
)
'Usage

Dim instance As ImageXView
Dim graphics As Graphics
Dim dimensions As Rectangle

instance.Print(graphics, dimensions)
public void Print(
   Graphics graphics,
   Rectangle dimensions
)
public: void Print(
   Graphics* graphics,
   Rectangle dimensions
)
public:
void Print(
   Graphics^ graphics,
   Rectangle dimensions
)

Parameters

graphics
A System.Drawing.Graphics object.
dimensions
A System.Drawing.Rectangle object.
See Also

Reference

ImageXView Class
ImageXView Members
Overload List


Print(Graphics,RectangleF) Method

Print(Graphics,RectangleF) Method

Accusoft.ImagXpressSdk Namespace > ImageXView Class > Print Method : Print(Graphics,RectangleF) Method
A System.Drawing.Graphics object.
A System.Drawing.RectangleF object.
Prints an image to the current graphics object given graphics and dimensions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Print( _
   ByVal graphics As Graphics, _
   ByVal dimensions As RectangleF _
)
'Usage

Dim instance As ImageXView
Dim graphics As Graphics
Dim dimensions As RectangleF

instance.Print(graphics, dimensions)
public void Print(
   Graphics graphics,
   RectangleF dimensions
)
public: void Print(
   Graphics* graphics,
   RectangleF dimensions
)
public:
void Print(
   Graphics^ graphics,
   RectangleF dimensions
)

Parameters

graphics
A System.Drawing.Graphics object.
dimensions
A System.Drawing.RectangleF object.
See Also

Reference

ImageXView Class
ImageXView Members
Overload List


Print(Graphics,Rectangle,PrintType) Method

Print(Graphics,Rectangle,PrintType) Method

Accusoft.ImagXpressSdk Namespace > ImageXView Class > Print Method : Print(Graphics,Rectangle,PrintType) Method
A System.Drawing.Graphics object.
A System.Drawing.Rectangle object.
A PrintType value.
Prints an image to the current graphics object given graphics, dimensions and type of print.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Print( _
   ByVal graphics As Graphics, _
   ByVal dimensions As Rectangle, _
   ByVal printType As PrintType _
)
'Usage

Dim instance As ImageXView
Dim graphics As Graphics
Dim dimensions As Rectangle
Dim printType As PrintType

instance.Print(graphics, dimensions, printType)
public void Print(
   Graphics graphics,
   Rectangle dimensions,
   PrintType printType
)
public: void Print(
   Graphics* graphics,
   Rectangle dimensions,
   PrintType printType
)
public:
void Print(
   Graphics^ graphics,
   Rectangle dimensions,
   PrintType printType
)

Parameters

graphics
A System.Drawing.Graphics object.
dimensions
A System.Drawing.Rectangle object.
printType
A PrintType value.
See Also

Reference

ImageXView Class
ImageXView Members
Overload List


Print(Graphics,RectangleF,PrintType) Method

Print(Graphics,RectangleF,PrintType) Method

Accusoft.ImagXpressSdk Namespace > ImageXView Class > Print Method : Print(Graphics,RectangleF,PrintType) Method
A System.Drawing.Graphics object.
A System.Drawing.RectangleF object.
A PrintType value.
Prints an image to the current graphics object given graphics, dimensions and type of print.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Print( _
   ByVal graphics As Graphics, _
   ByVal dimensions As RectangleF, _
   ByVal printType As PrintType _
)
'Usage

Dim instance As ImageXView
Dim graphics As Graphics
Dim dimensions As RectangleF
Dim printType As PrintType

instance.Print(graphics, dimensions, printType)
public void Print(
   Graphics graphics,
   RectangleF dimensions,
   PrintType printType
)
public: void Print(
   Graphics* graphics,
   RectangleF dimensions,
   PrintType printType
)
public:
void Print(
   Graphics^ graphics,
   RectangleF dimensions,
   PrintType printType
)

Parameters

graphics
A System.Drawing.Graphics object.
dimensions
A System.Drawing.RectangleF object.
printType
A PrintType value.
See Also

Reference

ImageXView Class
ImageXView Members
Overload List


ResetToolCursor Method

ResetToolCursor Method

Accusoft.ImagXpressSdk Namespace > ImageXView Class : ResetToolCursor Method
Tool cursor type to reset.
Resets the cursor for a specific tool cursor type back to the built-in default cursor.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub ResetToolCursor( _
   ByVal cursorType As ToolCursor _
)
'Usage

Dim instance As ImageXView
Dim cursorType As ToolCursor

instance.ResetToolCursor(cursorType)
public void ResetToolCursor(
   ToolCursor cursorType
)
public: void ResetToolCursor(
   ToolCursor cursorType
)
public:
void ResetToolCursor(
   ToolCursor cursorType
)

Parameters

cursorType
Tool cursor type to reset.
See Also

Reference

ImageXView Class
ImageXView Members


SetPaletteColor Method

SetPaletteColor Method

Accusoft.ImagXpressSdk Namespace > ImageXView Class : SetPaletteColor Method
An integer value which represents the index into the palette table. The minimum index is 0 and the maximum index is 255.
A System.Drawing.Color value for that palette location.
Specifies the colors for a user defined palette for the control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetPaletteColor( _
   ByVal Index As Integer, _
   ByVal color As Color _
)
'Usage

Dim instance As ImageXView
Dim Index As Integer
Dim color As Color

instance.SetPaletteColor(Index, color)
public void SetPaletteColor(
   int Index,
   Color color
)
public: void SetPaletteColor(
   int Index,
   Color color
)
public:
void SetPaletteColor(
   int Index,
   Color color
)

Parameters

Index
An integer value which represents the index into the palette table. The minimum index is 0 and the maximum index is 255.
color
A System.Drawing.Color value for that palette location.
Remarks

When the PaletteType property is set as PaletteType.UserDefined, images displayed during palettized display will use the palette defined by this method.

See Also

Reference

ImageXView Class
ImageXView Members


SetToolCursor Method

SetToolCursor Method

Accusoft.ImagXpressSdk Namespace > ImageXView Class : SetToolCursor Method
Tool cursor type to set.
New cursor.
Sets the cursor for a specific tool cursor type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetToolCursor( _
   ByVal cursorType As ToolCursor, _
   ByVal cursor As Cursor _
)
'Usage

Dim instance As ImageXView
Dim cursorType As ToolCursor
Dim cursor As Cursor

instance.SetToolCursor(cursorType, cursor)
public void SetToolCursor(
   ToolCursor cursorType,
   Cursor cursor
)
public: void SetToolCursor(
   ToolCursor cursorType,
   Cursor* cursor
)
public:
void SetToolCursor(
   ToolCursor cursorType,
   Cursor^ cursor
)

Parameters

cursorType
Tool cursor type to set.
cursor
New cursor.
See Also

Reference

ImageXView Class
ImageXView Members


ShowImageInfo Method

ShowImageInfo Method

Accusoft.ImagXpressSdk Namespace > ImageXView Class : ShowImageInfo Method
Invokes a dialog box displaying image information.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub ShowImageInfo()
'Usage

Dim instance As ImageXView

instance.ShowImageInfo()
public void ShowImageInfo()
public: void ShowImageInfo();
public:
void ShowImageInfo();
See Also

Reference

ImageXView Class
ImageXView Members


ToolGet Method

ToolGet Method

Accusoft.ImagXpressSdk Namespace > ImageXView Class : ToolGet Method
Mouse button to be pressed, currently only supports left, middle and right mouse buttons.
The System.Windows.Forms.Keys value which represents the shift key to be pressed. Currently, the only supported keys are shift, control, and alt key values.
Retrieves which tool is assigned to a given mouse/shift combination.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function ToolGet( _
   ByVal mouseButton As MouseButtons, _
   ByVal key As Keys _
) As Tool
'Usage

Dim instance As ImageXView
Dim mouseButton As MouseButtons
Dim key As Keys
Dim value As Tool

value = instance.ToolGet(mouseButton, key)
public Tool ToolGet(
   MouseButtons mouseButton,
   Keys key
)
public: Tool ToolGet(
   MouseButtons mouseButton,
   Keys key
)
public:
Tool ToolGet(
   MouseButtons mouseButton,
   Keys key
)

Parameters

mouseButton
Mouse button to be pressed, currently only supports left, middle and right mouse buttons.
key
The System.Windows.Forms.Keys value which represents the shift key to be pressed. Currently, the only supported keys are shift, control, and alt key values.

Return Value

Tool assigned to mouse/shift combination.
See Also

Reference

ImageXView Class
ImageXView Members


ToolGetAttribute Method

ToolGetAttribute Method

Accusoft.ImagXpressSdk Namespace > ImageXView Class : ToolGetAttribute Method
Tool to get the specific attribute from.
Specific attribute to get the value from.
Retrieves the value of a specific tool's attribute.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function ToolGetAttribute( _
   ByVal tool As Tool, _
   ByVal attribute As ToolAttribute _
) As Integer
'Usage

Dim instance As ImageXView
Dim tool As Tool
Dim attribute As ToolAttribute
Dim value As Integer

value = instance.ToolGetAttribute(tool, attribute)
public int ToolGetAttribute(
   Tool tool,
   ToolAttribute attribute
)
public: int ToolGetAttribute(
   Tool tool,
   ToolAttribute attribute
)
public:
int ToolGetAttribute(
   Tool tool,
   ToolAttribute attribute
)

Parameters

tool
Tool to get the specific attribute from.
attribute
Specific attribute to get the value from.

Return Value

Value for that tool's attribute.
See Also

Reference

ImageXView Class
ImageXView Members


ToolIsAttributeSupported Method

ToolIsAttributeSupported Method

Accusoft.ImagXpressSdk Namespace > ImageXView Class : ToolIsAttributeSupported Method
Tool to check the specific attribute on.
Specific attribute to determine if it is supported.
Retrieves whether the attribute is supported for a specific tool.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function ToolIsAttributeSupported( _
   ByVal tool As Tool, _
   ByVal attribute As ToolAttribute _
) As Boolean
'Usage

Dim instance As ImageXView
Dim tool As Tool
Dim attribute As ToolAttribute
Dim value As Boolean

value = instance.ToolIsAttributeSupported(tool, attribute)
public bool ToolIsAttributeSupported(
   Tool tool,
   ToolAttribute attribute
)
public: bool ToolIsAttributeSupported(
   Tool tool,
   ToolAttribute attribute
)
public:
bool ToolIsAttributeSupported(
   Tool tool,
   ToolAttribute attribute
)

Parameters

tool
Tool to check the specific attribute on.
attribute
Specific attribute to determine if it is supported.

Return Value

Value that specifies if the attribute is supported for the tool.
See Also

Reference

ImageXView Class
ImageXView Members


ToolSet Method

ToolSet Method

Accusoft.ImagXpressSdk Namespace > ImageXView Class : ToolSet Method
The Tool to assign.
The System.Windows.Forms.MouseButtons to be pressed. Currently this only supports left, middle and right mouse buttons.
The System.Windows.Forms.Keys value which represents the shift key to be pressed, currently only supports shift, control and alt key values.
Assigns a tool to a particular shift/mouse combination.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub ToolSet( _
   ByVal tool As Tool, _
   ByVal mouseButton As MouseButtons, _
   ByVal key As Keys _
)
'Usage

Dim instance As ImageXView
Dim tool As Tool
Dim mouseButton As MouseButtons
Dim key As Keys

instance.ToolSet(tool, mouseButton, key)
public void ToolSet(
   Tool tool,
   MouseButtons mouseButton,
   Keys key
)
public: void ToolSet(
   Tool tool,
   MouseButtons mouseButton,
   Keys key
)
public:
void ToolSet(
   Tool tool,
   MouseButtons mouseButton,
   Keys key
)

Parameters

tool
The Tool to assign.
mouseButton
The System.Windows.Forms.MouseButtons to be pressed. Currently this only supports left, middle and right mouse buttons.
key
The System.Windows.Forms.Keys value which represents the shift key to be pressed, currently only supports shift, control and alt key values.
See Also

Reference

ImageXView Class
ImageXView Members


ToolSetAttribute Method

ToolSetAttribute Method

Accusoft.ImagXpressSdk Namespace > ImageXView Class : ToolSetAttribute Method
The Tool to set the specific attribute on.
Specific attribute to set the value on.
An integer value which represents the new tool's attribute value.
Sets the value of a specific tool's attribute.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub ToolSetAttribute( _
   ByVal tool As Tool, _
   ByVal attribute As ToolAttribute, _
   ByVal newValue As Integer _
)
'Usage

Dim instance As ImageXView
Dim tool As Tool
Dim attribute As ToolAttribute
Dim newValue As Integer

instance.ToolSetAttribute(tool, attribute, newValue)
public void ToolSetAttribute(
   Tool tool,
   ToolAttribute attribute,
   int newValue
)
public: void ToolSetAttribute(
   Tool tool,
   ToolAttribute attribute,
   int newValue
)
public:
void ToolSetAttribute(
   Tool tool,
   ToolAttribute attribute,
   int newValue
)

Parameters

tool
The Tool to set the specific attribute on.
attribute
Specific attribute to set the value on.
newValue
An integer value which represents the new tool's attribute value.
See Also

Reference

ImageXView Class
ImageXView Members


Translate Method

Translate Method

Accusoft.ImagXpressSdk Namespace > ImageXView Class : Translate Method
A System.Drawing.Point value which represents the value to translate.
A TranslateType enumeration value which represents the type of translation.
Translates values from one coordinate system to the other.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Translate( _
   ByVal point As PointF, _
   ByVal translationType As TranslateType _
) As PointF
'Usage

Dim instance As ImageXView
Dim point As PointF
Dim translationType As TranslateType
Dim value As PointF

value = instance.Translate(point, translationType)
public PointF Translate(
   PointF point,
   TranslateType translationType
)
public: PointF Translate(
   PointF point,
   TranslateType translationType
)
public:
PointF Translate(
   PointF point,
   TranslateType translationType
)

Parameters

point
A System.Drawing.Point value which represents the value to translate.
translationType
A TranslateType enumeration value which represents the type of translation.

Return Value

A System.Drawing.Point value which represents the translated value.
See Also

Reference

ImageXView Class
ImageXView Members


ZoomToFit Method

ZoomToFit Method

Accusoft.ImagXpressSdk Namespace > ImageXView Class : ZoomToFit Method
A ZoomToFitType option.
Zoom the image display to fit within the ImageXView control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub ZoomToFit( _
   ByVal zoomToFitType As ZoomToFitType _
)
'Usage

Dim instance As ImageXView
Dim zoomToFitType As ZoomToFitType

instance.ZoomToFit(zoomToFitType)
public void ZoomToFit(
   ZoomToFitType zoomToFitType
)
public: void ZoomToFit(
   ZoomToFitType zoomToFitType
)
public:
void ZoomToFit(
   ZoomToFitType zoomToFitType
)

Parameters

zoomToFitType
A ZoomToFitType option.
Remarks

This is a one time zoom unlike some of the AutoResize property settings which will repeatedly set the ZoomFactor. In fact, the AutoResize property has precedence over the ZoomToFit method and not the other way around. Calling the ZoomToFit method with ZoomToFitType.FitHeight when the AutoResize property is set to AutoResizeType.FitWidth will do absolutely nothing. Therefore it is best to use this method when the AutoResize property is set to AutoResizeType.CropImage or AutoResizeType.CropImageToControl.

See Also

Reference

ImageXView Class
ImageXView Members


ImageXView Class Properties

ImageXView Class Properties

Accusoft.ImagXpressSdk Namespace : ImageXView Class

For a list of all members of this type, see ImageXView members.

Public Properties
 | Name | Description
Public Property | AccessibilityObject | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | (Inherited from System.Windows.Forms.Control)
Public Property | ActiveControl | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AlignHorizontal | Gets and sets the horizontal alignment of the image being viewed.
Public Property | AlignVertical | Gets and sets the vertical alignment of the image being viewed.
Public Property | AllowDrop | (Inherited from System.Windows.Forms.Control)
Public Property | AllowUpdate | Gets and sets an indicator which determines if updates allow the control to be repainted.
Public Property | AlphaBlend | Gets and sets an indication of alpha blending an image to the background of the control when an alpha channel is present in the image.
Public Property | Anchor | (Inherited from System.Windows.Forms.Control)
Public Property | Antialias | Gets and sets the anti-alias effect.
Public Property | AspectX | Gets and sets the horizontal aspect ratio of the current image.
Public Property | AspectY | Gets and sets the vertical aspect ratio of the current image.
Public Property | AutoImageDispose | Gets and sets enabling the ImageXView's Dispose method to automatically call the ImageX's Dispose method.
Public Property | AutoResize | Gets and sets how the image is sized and positioned for display when painted.
Public Property | AutoScaleDimensions | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScaleMode | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollOffset | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollPosition | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoSizeMode | (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoValidate | (Inherited from System.Windows.Forms.UserControl)
Public Property | BackColor | Overridden. Sets the background color of the view window.
Public Property | BackgroundImage | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | BorderStyle | Gets and sets the border type of the ImageXView object.
Public Property | BorderType | Gets and sets the border type of the ImageXView object.
Public Property | Bottom | (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | (Inherited from System.Windows.Forms.Control)
Public Property | Brightness | Gets and sets the change of brightness of the current image.
Public Property | CanFocus | (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | (Inherited from System.Windows.Forms.Control)
Public Property | Capture | (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | (Inherited from System.Windows.Forms.Control)
Public Property | ClientRectangle | (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | (Inherited from System.Windows.Forms.Control)
Public Property | ClipRectangle | Gets and sets the rectangular portion of the image that is accessible to the viewer.
Public Property | ColorRenderIntent | Gets and sets how the color profiles should be applied.
Public Property | CompanyName | (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | Overridden. Gets or sets the shortcut menu associated with the control.
Public Property | ContextMenuStrip | (Inherited from System.Windows.Forms.Control)
Public Property | Contrast | Gets and sets the change of contrast level for the displayed image.
Public Property | Controls | (Inherited from System.Windows.Forms.Control)
Public Property | Created | (Inherited from System.Windows.Forms.Control)
Public Property | CurrentAutoScaleDimensions | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | Cursor | (Inherited from System.Windows.Forms.Control)
Public Property | CursorPosition | Gets the coordinates of the cursor position in the view window.
Public Property | DataBindings | (Inherited from System.Windows.Forms.Control)
Public Property | DisplayMode | Returns or sets a value indicating the maximum color depth used to render an image.
Public Property | DisplayRectangle | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Disposing | (Inherited from System.Windows.Forms.Control)
Public Property | Dithered | Gets and sets the display image dithering state.
Public Property | Dock | (Inherited from System.Windows.Forms.Control)
Public Property | Enabled | (Inherited from System.Windows.Forms.Control)
Public Property | Focused | (Inherited from System.Windows.Forms.Control)
Public Property | Font | (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | (Inherited from System.Windows.Forms.Control)
Public Property | GrayMode | Gets and sets the mode of gray used to display a grayscale image.
Public Property | Handle | (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | (Inherited from System.Windows.Forms.Control)
Public Property | Height | (Inherited from System.Windows.Forms.Control)
Public Property | HorizontalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | IcmEnabled | Gets and sets an enabled indicator for the color management.
Public Property | IcmProofingEnabled | Gets and sets an enabled indicator of the ICM target proofing.
Public Property | Image | Gets and sets the current image view.
Public Property | ImageCursorPosition | Gets the point at which the cursor is located within the image, in pixels.
Public Property | ImeMode | (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | (Inherited from System.Windows.Forms.Control)
Public Property | LayoutEngine | (Inherited from System.Windows.Forms.Control)
Public Property | Left | (Inherited from System.Windows.Forms.Control)
Public Property | Location | (Inherited from System.Windows.Forms.Control)
Public Property | Margin | (Inherited from System.Windows.Forms.Control)
Public Property | Maximum | Gets and sets the maximum dimensions the viewer control can obtain.
Public Property | MaximumSize | (Inherited from System.Windows.Forms.Control)
Public Property | Medical | Gets and sets information required to display medical images.
Public Property | Minimum | Gets and sets the minimum dimensions the viewer control can obtain.
Public Property | MinimumSize | (Inherited from System.Windows.Forms.Control)
Public Property | MonitorProfileName | Gets and sets the monitor’s color management profile.
Public Property | MouseWheelCapture | Gets and sets capturing the mousewheel even when the control does not have focus.
Public Property | Name | (Inherited from System.Windows.Forms.Control)
Public Property | Padding | (Inherited from System.Windows.Forms.Control)
Public Property | PaletteFilename | Specifies the filename that contains the palette for the control.
Public Property | PaletteType | Gets and sets the image display palette type.
Public Property | Parent | (Inherited from System.Windows.Forms.Control)
Public Property | ParentForm | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | PixelColor | Gets the color of the pixel within the client area of the view control at which the cursor is currently positioned.
Public Property | PreferredSize | (Inherited from System.Windows.Forms.Control)
Public Property | PreserveBlack | Gets and sets an indicator if black should be preserved and applied when viewing the image.
Public Property | PrinterProfileName | Gets and sets the printer’s profile filename.
Public Property | ProductName | (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | (Inherited from System.Windows.Forms.Control)
Public Property | Progressive | Gets and sets an indication if images are displayed progressively.
Public Property | RecreatingHandle | (Inherited from System.Windows.Forms.Control)
Public Property | RefreshMode | Gets and sets an indicator which specifies when the control is refreshed after an operation is completed on the attached Image.
Public Property | Region | (Inherited from System.Windows.Forms.Control)
Public Property | Right | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | (Inherited from System.Windows.Forms.Control)
Public Property | Rubberband | Gets the current Rubberband object.
Public Property | ScrollBars | Gets or sets the type of scroll bars to display in the ImageXView control.
Public Property | ScrollPosition | Gets and sets the current scrolling position of the cursor on the scrollbar.
Public Property | Site | (Inherited from System.Windows.Forms.Control)
Public Property | Size | (Inherited from System.Windows.Forms.Control)
Public Property | Smoothing | Gets and sets an indicator for the smoothing effect on the current color image.
Public Property | Sprite | Gets the Sprite object.
Public Property | TabIndex | (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | (Inherited from System.Windows.Forms.Control)
Public Property | Tag | (Inherited from System.Windows.Forms.Control)
Public Property | TargetProfileName | Gets and sets the target profile’s filename.
Public Property | ToolActive | Gets the currently active tool.
Public Property | Toolbar | Gets the current Toolbar object.
Public Property | Top | (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | (Inherited from System.Windows.Forms.Control)
Public Property | Touch | Gets the current Touch object for setting Touch behavior.
Public Property | UseWaitCursor | (Inherited from System.Windows.Forms.Control)
Public Property | VerticalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Visible | (Inherited from System.Windows.Forms.Control)
Public Property | Width | (Inherited from System.Windows.Forms.Control)
Public Property | Workspace | Gets or sets the ImagXpress workspace component.
Public Property | ZoomFactor | Gets and sets the zoom factor display for the current image.
Top
See Also

Reference

ImageXView Class
Accusoft.ImagXpressSdk Namespace


AlignHorizontal Property

AlignHorizontal Property

Accusoft.ImagXpressSdk Namespace > ImageXView Class : AlignHorizontal Property
Gets and sets the horizontal alignment of the image being viewed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("The horizontal alignment of the image.")>
<DefaultValueAttribute()>
<BrowsableAttribute(True)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)>
Public Property AlignHorizontal As AlignHorizontal
'Usage

Dim instance As ImageXView
Dim value As AlignHorizontal

instance.AlignHorizontal = value

value = instance.AlignHorizontal
[Description("The horizontal alignment of the image.")]
[DefaultValue()]
[Browsable(true)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
public AlignHorizontal AlignHorizontal {get; set;}
[Description("The horizontal alignment of the image.")]
[DefaultValue()]
[Browsable(true)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
public: __property AlignHorizontal get_AlignHorizontal();
public: __property void set_AlignHorizontal(
   AlignHorizontal value
);
[Description("The horizontal alignment of the image.")]
[DefaultValue()]
[Browsable(true)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
public:
property AlignHorizontal AlignHorizontal {
   AlignHorizontal get();
   void set (    AlignHorizontal value);
}

Property Value

The AlignHorizontal enumeration value set.
Remarks

The default value is AlignHorizontal.Center.

When the displayed image is smaller than the viewing window, the image is horizontally aligned according to this setting.

See Also

Reference

ImageXView Class
ImageXView Members
AlignHorizontal Enumeration


AlignVertical Property

AlignVertical Property

Accusoft.ImagXpressSdk Namespace > ImageXView Class : AlignVertical Property
Gets and sets the vertical alignment of the image being viewed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)>
<DefaultValueAttribute()>
<DescriptionAttribute("The vertical alignment of the image.")>
<BrowsableAttribute(True)>
Public Property AlignVertical As AlignVertical
'Usage

Dim instance As ImageXView
Dim value As AlignVertical

instance.AlignVertical = value

value = instance.AlignVertical
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
[DefaultValue()]
[Description("The vertical alignment of the image.")]
[Browsable(true)]
public AlignVertical AlignVertical {get; set;}
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
[DefaultValue()]
[Description("The vertical alignment of the image.")]
[Browsable(true)]
public: __property AlignVertical get_AlignVertical();
public: __property void set_AlignVertical(
   AlignVertical value
);
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
[DefaultValue()]
[Description("The vertical alignment of the image.")]
[Browsable(true)]
public:
property AlignVertical AlignVertical {
   AlignVertical get();
   void set (    AlignVertical value);
}

Property Value

The AlignVertical enumeration value set.
Remarks

The default value is AlignVertical.Center.

When the displayed image is smaller than the viewing window, then image is vertically aligned according to this setting.

See Also

Reference

ImageXView Class
ImageXView Members
AlignVertical Enumeration


AllowUpdate Property

AllowUpdate Property

Accusoft.ImagXpressSdk Namespace > ImageXView Class : AllowUpdate Property
Gets and sets an indicator which determines if updates allow the control to be repainted.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DefaultValueAttribute()>
<DescriptionAttribute("Property that determines whether updates allow the control to be repainted.")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property AllowUpdate As Boolean
'Usage

Dim instance As ImageXView
Dim value As Boolean

instance.AllowUpdate = value

value = instance.AllowUpdate
[Browsable(false)]
[DefaultValue()]
[Description("Property that determines whether updates allow the control to be repainted.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
public bool AllowUpdate {get; set;}
[Browsable(false)]
[DefaultValue()]
[Description("Property that determines whether updates allow the control to be repainted.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
public: __property bool get_AllowUpdate();
public: __property void set_AllowUpdate(
   bool value
);
[Browsable(false)]
[DefaultValue()]
[Description("Property that determines whether updates allow the control to be repainted.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
public:
property bool AllowUpdate {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true to allow a repaint on updates. Otherwise, false is returned.
Remarks

If you set this property to false, then the control does not repaint when it needs updating.

See Also

Reference

ImageXView Class
ImageXView Members


AlphaBlend Property

AlphaBlend Property

Accusoft.ImagXpressSdk Namespace > ImageXView Class : AlphaBlend Property
Gets and sets an indication of alpha blending an image to the background of the control when an alpha channel is present in the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
<DescriptionAttribute("Enables/disables alpha blending an image to the background of the control when an alpha channel is present in the image.")>
<DefaultValueAttribute()>
Public Property AlphaBlend As Boolean
'Usage

Dim instance As ImageXView
Dim value As Boolean

instance.AlphaBlend = value

value = instance.AlphaBlend
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Browsable(false)]
[Description("Enables/disables alpha blending an image to the background of the control when an alpha channel is present in the image.")]
[DefaultValue()]
public bool AlphaBlend {get; set;}
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Browsable(false)]
[Description("Enables/disables alpha blending an image to the background of the control when an alpha channel is present in the image.")]
[DefaultValue()]
public: __property bool get_AlphaBlend();
public: __property void set_AlphaBlend(
   bool value
);
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Browsable(false)]
[Description("Enables/disables alpha blending an image to the background of the control when an alpha channel is present in the image.")]
[DefaultValue()]
public:
property bool AlphaBlend {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true to alpha blend the image to the background of the control. Otherwise, false is returned.
Remarks

The default value is false.

See Also

Reference

ImageXView Class
ImageXView Members


Antialias Property

Antialias Property

Accusoft.ImagXpressSdk Namespace > ImageXView Class : Antialias Property
Gets and sets the anti-alias effect.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(True)>
<DescriptionAttribute("Enables/disables antialiasing when resizing the image to the view.")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)>
<DefaultValueAttribute()>
Public Property Antialias As Boolean
'Usage

Dim instance As ImageXView
Dim value As Boolean

instance.Antialias = value

value = instance.Antialias
[Browsable(true)]
[Description("Enables/disables antialiasing when resizing the image to the view.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
[DefaultValue()]
public bool Antialias {get; set;}
[Browsable(true)]
[Description("Enables/disables antialiasing when resizing the image to the view.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
[DefaultValue()]
public: __property bool get_Antialias();
public: __property void set_Antialias(
   bool value
);
[Browsable(true)]
[Description("Enables/disables antialiasing when resizing the image to the view.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
[DefaultValue()]
public:
property bool Antialias {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true if antialias is enabled. Otherwise, false is returned.
Remarks

The default value is true.

When the logical size of an image is reduced to less than the actual size of the image, then some of that image's pixels get lost. When antialias is set to true, all of the pixels that would occupy the same area are averaged together turning them into a level of gray for black and white images. For color images, all of the pixels are averaged. This prevents fine lines from being lost, and allows a full page of printed text to be read clearly.

Note: Changing this property does not permanently affect the image loaded in memory.

See Also

Reference

ImageXView Class
ImageXView Members


AspectX Property

AspectX Property

Accusoft.ImagXpressSdk Namespace > ImageXView Class : AspectX Property
Gets and sets the horizontal aspect ratio of the current image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
Public Property AspectX As Integer
'Usage

Dim instance As ImageXView
Dim value As Integer

instance.AspectX = value

value = instance.AspectX
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Browsable(false)]
public int AspectX {get; set;}
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Browsable(false)]
public: __property int get_AspectX();
public: __property void set_AspectX(
   int value
);
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Browsable(false)]
public:
property int AspectX {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the horizontal aspect ratio of the image.
Remarks

The default value is 1.

The aspect ratio defines how many horizontal pixels are equal in size to a certain number of vertical pixels. Changing the aspect ratio of the image will change the appearance.

This function is useful when you are viewing a fax document in which the aspect ratio was incorrectly encoded. For example low-resolution fax images are scanned in at 200 horizontal and 100 dpi vertical. But the PCX file format does not provide aspect size information, so when the image is displayed, it appears squashed. By doubling the horizontal aspect, the image displays correctly.

Setting these properties defines the shape of each pixel in the display. This changes the aspect ratio of the displayed image, but has no effect on the image itself.

See Also

Reference

ImageXView Class
ImageXView Members


AspectY Property

AspectY Property

Accusoft.ImagXpressSdk Namespace > ImageXView Class : AspectY Property
Gets and sets the vertical aspect ratio of the current image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
Public Property AspectY As Integer
'Usage

Dim instance As ImageXView
Dim value As Integer

instance.AspectY = value

value = instance.AspectY
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Browsable(false)]
public int AspectY {get; set;}
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Browsable(false)]
public: __property int get_AspectY();
public: __property void set_AspectY(
   int value
);
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Browsable(false)]
public:
property int AspectY {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the vertical aspect ratio.
Remarks

The default value is 1.

The aspect ratio defines how many horizontal pixels are equal in size to a certain number of vertical pixels. Changing the aspect ratio of an image changes the image's appearance.

This function is useful when you are viewing a fax document, where the aspect ratio is incorrectly encoded. For example, low-resolution faxes scan in at 200 dpi horizontal pixels to vertical ones is 2:1. Increasing he vertical aspect lowers the ratio and improves the fax appearance. The PCX file format does not provide aspect size information, so when the image displays, it appears squashed. By doubling the vertical aspect, the image displays correctly.

See Also

Reference

ImageXView Class
ImageXView Members


AutoImageDispose Property

AutoImageDispose Property

Accusoft.ImagXpressSdk Namespace > ImageXView Class : AutoImageDispose Property
Gets and sets enabling the ImageXView's Dispose method to automatically call the ImageX's Dispose method.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<DefaultValueAttribute()>
<DescriptionAttribute("Enables or disables Dispose calling the current Image's Dispose method")>
<BrowsableAttribute(False)>
Public Property AutoImageDispose As Boolean
'Usage

Dim instance As ImageXView
Dim value As Boolean

instance.AutoImageDispose = value

value = instance.AutoImageDispose
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[DefaultValue()]
[Description("Enables or disables Dispose calling the current Image's Dispose method")]
[Browsable(false)]
public bool AutoImageDispose {get; set;}
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[DefaultValue()]
[Description("Enables or disables Dispose calling the current Image's Dispose method")]
[Browsable(false)]
public: __property bool get_AutoImageDispose();
public: __property void set_AutoImageDispose(
   bool value
);
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[DefaultValue()]
[Description("Enables or disables Dispose calling the current Image's Dispose method")]
[Browsable(false)]
public:
property bool AutoImageDispose {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true to turn on auto image dispose. Otherwise, false is used.
Remarks

The default value is false.

Because the default value is false, it is the programmer's responsiblity to call the Dispose(Boolean) method for the ImageX object after the ImageXView's Dispose method is called. Set this property to true if you would like ImageX's object connected to the ImageXView to be disposed of automatically when the ImageXView is disposed.

This is useful if you tend to tie one and only one image to a view.

See Also

Reference

ImageXView Class
ImageXView Members


AutoResize Property

AutoResize Property

Accusoft.ImagXpressSdk Namespace > ImageXView Class : AutoResize Property
Gets and sets how the image is sized and positioned for display when painted.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)>
<BrowsableAttribute(True)>
<DefaultValueAttribute()>
<DescriptionAttribute("Determines the method of viewing/sizing of the image to the control.")>
Public Property AutoResize As AutoResizeType
'Usage

Dim instance As ImageXView
Dim value As AutoResizeType

instance.AutoResize = value

value = instance.AutoResize
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
[Browsable(true)]
[DefaultValue()]
[Description("Determines the method of viewing/sizing of the image to the control.")]
public AutoResizeType AutoResize {get; set;}
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
[Browsable(true)]
[DefaultValue()]
[Description("Determines the method of viewing/sizing of the image to the control.")]
public: __property AutoResizeType get_AutoResize();
public: __property void set_AutoResize(
   AutoResizeType value
);
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
[Browsable(true)]
[DefaultValue()]
[Description("Determines the method of viewing/sizing of the image to the control.")]
public:
property AutoResizeType AutoResize {
   AutoResizeType get();
   void set (    AutoResizeType value);
}

Property Value

The AutoResizeType set.
Remarks

The default value is AutoResizeType.CropImage (5).

See the maximum and minimum for the range of dimensions that the control can be resized to when AutoSize specifies that the control should be resized to fit the image.

Note: AutoResize changes how the image is displayed. The image itself is not modified. To modify the image, see the Processor.Resize method. If the AutoResize property is set to BestFit, FitWidth, FitHeight or ResizeImage, then the ZoomFactor property becomes read-only.

See Also

Reference

ImageXView Class
ImageXView Members


BackColor Property

BackColor Property

Accusoft.ImagXpressSdk Namespace > ImageXView Class : BackColor Property
Sets the background color of the view window.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides WriteOnly Property BackColor As Color
'Usage

Dim instance As ImageXView

instance.BackColor = value
public override Color BackColor {set;}
public: __property void set_BackColor(
   Color value
) override;
public:
property Color BackColor {
   void set (    Color value) override;
}

Property Value

A System.Drawing.Color value which represents the background color.
See Also

Reference

ImageXView Class
ImageXView Members


BorderStyle Property

BorderStyle Property

Accusoft.ImagXpressSdk Namespace > ImageXView Class : BorderStyle Property
Gets and sets the border type of the ImageXView object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("Selects the window border style for the control.")>
<DefaultValueAttribute()>
<BrowsableAttribute(True)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)>
Public Shadows Property BorderStyle As ImageXViewBorderStyle
'Usage

Dim instance As ImageXView
Dim value As ImageXViewBorderStyle

instance.BorderStyle = value

value = instance.BorderStyle
[Description("Selects the window border style for the control.")]
[DefaultValue()]
[Browsable(true)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
public new ImageXViewBorderStyle BorderStyle {get; set;}
[Description("Selects the window border style for the control.")]
[DefaultValue()]
[Browsable(true)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
public: __property new ImageXViewBorderStyle get_BorderStyle();
public: __property new void set_BorderStyle(
   ImageXViewBorderStyle value
);
[Description("Selects the window border style for the control.")]
[DefaultValue()]
[Browsable(true)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
public:
new property ImageXViewBorderStyle BorderStyle {
   ImageXViewBorderStyle get();
   void set (    ImageXViewBorderStyle value);
}

Property Value

The ImageXViewBorderStyle enumeration value set.
Remarks

The default value is ImageXViewBorderStyle.Fixed3D.

See Also

Reference

ImageXView Class
ImageXView Members


BorderType Property

BorderType Property

Accusoft.ImagXpressSdk Namespace > ImageXView Class : BorderType Property
Gets and sets the border type of the ImageXView object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
<DefaultValueAttribute()>
<DescriptionAttribute("Selects the window border type for the control.")>
<ObsoleteAttribute()>
Public Property BorderType As BorderType
'Usage

Dim instance As ImageXView
Dim value As BorderType

instance.BorderType = value

value = instance.BorderType
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Browsable(false)]
[DefaultValue()]
[Description("Selects the window border type for the control.")]
[Obsolete()]
public BorderType BorderType {get; set;}
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Browsable(false)]
[DefaultValue()]
[Description("Selects the window border type for the control.")]
[Obsolete()]
public: __property BorderType get_BorderType();
public: __property void set_BorderType(
   BorderType value
);
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Browsable(false)]
[DefaultValue()]
[Description("Selects the window border type for the control.")]
[Obsolete()]
public:
property BorderType BorderType {
   BorderType get();
   void set (    BorderType value);
}

Property Value

The BorderType enumeration value set.
Remarks

The default value is BorderType.Inset.

See Also

Reference

ImageXView Class
ImageXView Members


Brightness Property

Brightness Property

Accusoft.ImagXpressSdk Namespace > ImageXView Class : Brightness Property
Gets and sets the change of brightness of the current image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
Public Property Brightness As Integer
'Usage

Dim instance As ImageXView
Dim value As Integer

instance.Brightness = value

value = instance.Brightness
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Browsable(false)]
public int Brightness {get; set;}
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Browsable(false)]
public: __property int get_Brightness();
public: __property void set_Brightness(
   int value
);
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Browsable(false)]
public:
property int Brightness {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the brightness of the image.
Remarks

The default value is 0.

Higher brightness values result in brighter images. Negative values darken images. This allows the user to adjust the brightness of the displayed image.

See Also

Reference

ImageXView Class
ImageXView Members


ClipRectangle Property

ClipRectangle Property

Accusoft.ImagXpressSdk Namespace > ImageXView Class : ClipRectangle Property
Gets and sets the rectangular portion of the image that is accessible to the viewer.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(True)>
<DefaultValueAttribute()>
<DescriptionAttribute("Selects the clipping rectangle for the image.")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)>
Public Property ClipRectangle As Rectangle
'Usage

Dim instance As ImageXView
Dim value As Rectangle

instance.ClipRectangle = value

value = instance.ClipRectangle
[Browsable(true)]
[DefaultValue()]
[Description("Selects the clipping rectangle for the image.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
public Rectangle ClipRectangle {get; set;}
[Browsable(true)]
[DefaultValue()]
[Description("Selects the clipping rectangle for the image.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
public: __property Rectangle get_ClipRectangle();
public: __property void set_ClipRectangle(
   Rectangle value
);
[Browsable(true)]
[DefaultValue()]
[Description("Selects the clipping rectangle for the image.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
public:
property Rectangle ClipRectangle {
   Rectangle get();
   void set (    Rectangle value);
}

Property Value

A System.Drawing.Rectangle area set.
Remarks

The default value is 0,0,0,0.

If the ClipRectangle is smaller than the image, then the viewed image is cropped to the dimensions specified by this property. This cropped image is then available in the viewer to be zoomed, scrolled, ect.

Note: There is no impact to the ImageX object - the image remains unchanged. Only the displayed image is cropped.

See Also

Reference

ImageXView Class
ImageXView Members


ColorRenderIntent Property (ImageXView)

ColorRenderIntent Property (ImageXView)

Accusoft.ImagXpressSdk Namespace > ImageXView Class : ColorRenderIntent Property
Gets and sets how the color profiles should be applied.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DefaultValueAttribute()>
<DescriptionAttribute("This property specifies how the color profiles should be applied.")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property ColorRenderIntent As RenderIntent
'Usage

Dim instance As ImageXView
Dim value As RenderIntent

instance.ColorRenderIntent = value

value = instance.ColorRenderIntent
[Browsable(false)]
[DefaultValue()]
[Description("This property specifies how the color profiles should be applied.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
public RenderIntent ColorRenderIntent {get; set;}
[Browsable(false)]
[DefaultValue()]
[Description("This property specifies how the color profiles should be applied.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
public: __property RenderIntent get_ColorRenderIntent();
public: __property void set_ColorRenderIntent(
   RenderIntent value
);
[Browsable(false)]
[DefaultValue()]
[Description("This property specifies how the color profiles should be applied.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
public:
property RenderIntent ColorRenderIntent {
   RenderIntent get();
   void set (    RenderIntent value);
}

Property Value

A RenderIntent enumeration value.
Remarks

The default value is RenderIntent.Images.

Note: Available in Professional edition.

See Also

Reference

ImageXView Class
ImageXView Members
RenderIntent Enumeration


ContextMenu Property (ImageXView)

ContextMenu Property (ImageXView)

Accusoft.ImagXpressSdk Namespace > ImageXView Class : ContextMenu Property
Gets or sets the shortcut menu associated with the control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property ContextMenu As ContextMenu
'Usage

Dim instance As ImageXView
Dim value As ContextMenu

instance.ContextMenu = value

value = instance.ContextMenu
public override ContextMenu ContextMenu {get; set;}
public: __property ContextMenu* get_ContextMenu() override;
public: __property void set_ContextMenu(
   ContextMenu* value
) override;
public:
property ContextMenu^ ContextMenu {
   ContextMenu^ get() override;
   void set (    ContextMenu^ value) override;
}

Property Value

A System.Windows.Forms.ContextMenu that represents the shortcut menu associated with the control.
Remarks
Use a shortcut menus to give context-specific menu options to users when they right-click on the control.
See Also

Reference

ImageXView Class
ImageXView Members


Contrast Property

Contrast Property

Accusoft.ImagXpressSdk Namespace > ImageXView Class : Contrast Property
Gets and sets the change of contrast level for the displayed image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property Contrast As Integer
'Usage

Dim instance As ImageXView
Dim value As Integer

instance.Contrast = value

value = instance.Contrast
[Browsable(false)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
public int Contrast {get; set;}
[Browsable(false)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
public: __property int get_Contrast();
public: __property void set_Contrast(
   int value
);
[Browsable(false)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
public:
property int Contrast {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the contrast level.
Remarks

The default value is 0.

Valid values are -100 to 100.

Higher values result in images with higher contrast.

This property allows adjustment of the contrast for the displayed image.

See Also

Reference

ImageXView Class
ImageXView Members


CursorPosition Property

CursorPosition Property

Accusoft.ImagXpressSdk Namespace > ImageXView Class : CursorPosition Property
Gets the coordinates of the cursor position in the view window.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public ReadOnly Property CursorPosition As Point
'Usage

Dim instance As ImageXView
Dim value As Point

value = instance.CursorPosition
[Browsable(false)]
public Point CursorPosition {get;}
[Browsable(false)]
public: __property Point get_CursorPosition();
[Browsable(false)]
public:
property Point CursorPosition {
   Point get();
}

Property Value

A System.Drawing.Point value which represents the cursor position in the view window.
See Also

Reference

ImageXView Class
ImageXView Members


DisplayMode Property

DisplayMode Property

Accusoft.ImagXpressSdk Namespace > ImageXView Class : DisplayMode Property
Returns or sets a value indicating the maximum color depth used to render an image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("Returns or sets a value indicating the maximum color depth used to render an image.")>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<DefaultValueAttribute()>
Public Property DisplayMode As DisplayMode
'Usage

Dim instance As ImageXView
Dim value As DisplayMode

instance.DisplayMode = value

value = instance.DisplayMode
[Description("Returns or sets a value indicating the maximum color depth used to render an image.")]
[Browsable(false)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[DefaultValue()]
public DisplayMode DisplayMode {get; set;}
[Description("Returns or sets a value indicating the maximum color depth used to render an image.")]
[Browsable(false)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[DefaultValue()]
public: __property DisplayMode get_DisplayMode();
public: __property void set_DisplayMode(
   DisplayMode value
);
[Description("Returns or sets a value indicating the maximum color depth used to render an image.")]
[Browsable(false)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[DefaultValue()]
public:
property DisplayMode DisplayMode {
   DisplayMode get();
   void set (    DisplayMode value);
}

Property Value

An DisplayMode enumeration value which represents the maximum color depth used to render the image.
See Also

Reference

ImageXView Class
ImageXView Members


Dithered Property

Dithered Property

Accusoft.ImagXpressSdk Namespace > ImageXView Class : Dithered Property
Gets and sets the display image dithering state.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(True)>
<DescriptionAttribute("Enables/disables dithering an the display image.")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)>
<DefaultValueAttribute()>
Public Property Dithered As Boolean
'Usage

Dim instance As ImageXView
Dim value As Boolean

instance.Dithered = value

value = instance.Dithered
[Browsable(true)]
[Description("Enables/disables dithering an the display image.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
[DefaultValue()]
public bool Dithered {get; set;}
[Browsable(true)]
[Description("Enables/disables dithering an the display image.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
[DefaultValue()]
public: __property bool get_Dithered();
public: __property void set_Dithered(
   bool value
);
[Browsable(true)]
[Description("Enables/disables dithering an the display image.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
[DefaultValue()]
public:
property bool Dithered {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true if the current image is dithered on the display. Otherwise, false is returned.
Remarks

The default value is true.

This property only has an effect if the display is 256 colors or less.

See Also

Reference

ImageXView Class
ImageXView Members


GrayMode Property

GrayMode Property

Accusoft.ImagXpressSdk Namespace > ImageXView Class : GrayMode Property
Gets and sets the mode of gray used to display a grayscale image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<DescriptionAttribute("The high grayscale transformation method.")>
<DefaultValueAttribute()>
<BrowsableAttribute(False)>
Public Property GrayMode As GrayMode
'Usage

Dim instance As ImageXView
Dim value As GrayMode

instance.GrayMode = value

value = instance.GrayMode
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Description("The high grayscale transformation method.")]
[DefaultValue()]
[Browsable(false)]
public GrayMode GrayMode {get; set;}
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Description("The high grayscale transformation method.")]
[DefaultValue()]
[Browsable(false)]
public: __property GrayMode get_GrayMode();
public: __property void set_GrayMode(
   GrayMode value
);
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Description("The high grayscale transformation method.")]
[DefaultValue()]
[Browsable(false)]
public:
property GrayMode GrayMode {
   GrayMode get();
   void set (    GrayMode value);
}

Property Value

A GrayMode enumeration value.
Remarks

The default value is GrayMode.Standard.

Note: Available in Professional edition.

See Also

Reference

ImageXView Class
ImageXView Members
GrayMode Enumeration


IcmEnabled Property

IcmEnabled Property

Accusoft.ImagXpressSdk Namespace > ImageXView Class : IcmEnabled Property
Gets and sets an enabled indicator for the color management.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
<DescriptionAttribute("This is the property that enables/disables color management.")>
<DefaultValueAttribute()>
Public Property IcmEnabled As Boolean
'Usage

Dim instance As ImageXView
Dim value As Boolean

instance.IcmEnabled = value

value = instance.IcmEnabled
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Browsable(false)]
[Description("This is the property that enables/disables color management.")]
[DefaultValue()]
public bool IcmEnabled {get; set;}
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Browsable(false)]
[Description("This is the property that enables/disables color management.")]
[DefaultValue()]
public: __property bool get_IcmEnabled();
public: __property void set_IcmEnabled(
   bool value
);
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Browsable(false)]
[Description("This is the property that enables/disables color management.")]
[DefaultValue()]
public:
property bool IcmEnabled {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true to enable color management. Otherwise, false is used.
Remarks

The default value is false.

No other ICM operation will take place until this property has been set to true.

Note: Available in Professional edition.

See Also

Reference

ImageXView Class
ImageXView Members


IcmProofingEnabled Property

IcmProofingEnabled Property

Accusoft.ImagXpressSdk Namespace > ImageXView Class : IcmProofingEnabled Property
Gets and sets an enabled indicator of the ICM target proofing.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<DefaultValueAttribute()>
<DescriptionAttribute("This property enables/disables ICM target proofing.")>
Public Property IcmProofingEnabled As Boolean
'Usage

Dim instance As ImageXView
Dim value As Boolean

instance.IcmProofingEnabled = value

value = instance.IcmProofingEnabled
[Browsable(false)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[DefaultValue()]
[Description("This property enables/disables ICM target proofing.")]
public bool IcmProofingEnabled {get; set;}
[Browsable(false)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[DefaultValue()]
[Description("This property enables/disables ICM target proofing.")]
public: __property bool get_IcmProofingEnabled();
public: __property void set_IcmProofingEnabled(
   bool value
);
[Browsable(false)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[DefaultValue()]
[Description("This property enables/disables ICM target proofing.")]
public:
property bool IcmProofingEnabled {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true to enable ICM target proofing.
Remarks

This property has no immediate affect unless the IcmEnabled property is also set to true.

Note: Available in Professional edition.

See Also

Reference

ImageXView Class
ImageXView Members
IcmEnabled Property


Image Property (ImageXView)

Image Property (ImageXView)

Accusoft.ImagXpressSdk Namespace > ImageXView Class : Image Property
Gets and sets the current image view.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
Public Property Image As ImageX
'Usage

Dim instance As ImageXView
Dim value As ImageX

instance.Image = value

value = instance.Image
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Browsable(false)]
public ImageX Image {get; set;}
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Browsable(false)]
public: __property ImageX* get_Image();
public: __property void set_Image(
   ImageX* value
);
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Browsable(false)]
public:
property ImageX^ Image {
   ImageX^ get();
   void set (    ImageX^ value);
}

Property Value

An ImageX object.
Remarks
Note: Disposing of the ImageXView object does not dispose of its Image property unless the AutoImageDispose property has been set to true. Anytime the Image property is assigned a new ImageX object, the previous ImageX object should have its Dispose method called to explicitly dispose of the ImageX object if the application is done with the ImageX object. Failure to call Dispose on the ImageX object may result in a memory leak.
See Also

Reference

ImageXView Class
ImageXView Members


ImageCursorPosition Property

ImageCursorPosition Property

Accusoft.ImagXpressSdk Namespace > ImageXView Class : ImageCursorPosition Property
Gets the point at which the cursor is located within the image, in pixels.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public ReadOnly Property ImageCursorPosition As Point
'Usage

Dim instance As ImageXView
Dim value As Point

value = instance.ImageCursorPosition
[Browsable(false)]
public Point ImageCursorPosition {get;}
[Browsable(false)]
public: __property Point get_ImageCursorPosition();
[Browsable(false)]
public:
property Point ImageCursorPosition {
   Point get();
}

Property Value

A System.Drawing.Point value which represents the cursor current location within the image.
See Also

Reference

ImageXView Class
ImageXView Members


Maximum Property

Maximum Property

Accusoft.ImagXpressSdk Namespace > ImageXView Class : Maximum Property
Gets and sets the maximum dimensions the viewer control can obtain.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)>
<DefaultValueAttribute()>
<DescriptionAttribute("The maximum bounding size of the control.")>
<BrowsableAttribute(True)>
Public Property Maximum As Size
'Usage

Dim instance As ImageXView
Dim value As Size

instance.Maximum = value

value = instance.Maximum
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
[DefaultValue()]
[Description("The maximum bounding size of the control.")]
[Browsable(true)]
public Size Maximum {get; set;}
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
[DefaultValue()]
[Description("The maximum bounding size of the control.")]
[Browsable(true)]
public: __property Size get_Maximum();
public: __property void set_Maximum(
   Size value
);
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
[DefaultValue()]
[Description("The maximum bounding size of the control.")]
[Browsable(true)]
public:
property Size Maximum {
   Size get();
   void set (    Size value);
}

Property Value

The System.Drawing.Size which represents the maximum the viewer control can obtain.
Remarks

The default value is 0,0.

See Also

Reference

ImageXView Class
ImageXView Members


Medical Property

Medical Property

Accusoft.ImagXpressSdk Namespace > ImageXView Class : Medical Property
Gets and sets information required to display medical images.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
Public Property Medical As Medical
'Usage

Dim instance As ImageXView
Dim value As Medical

instance.Medical = value

value = instance.Medical
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Browsable(false)]
public Medical Medical {get; set;}
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Browsable(false)]
public: __property Medical* get_Medical();
public: __property void set_Medical(
   Medical* value
);
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Browsable(false)]
public:
property Medical^ Medical {
   Medical^ get();
   void set (    Medical^ value);
}

Property Value

A Medical object.
Remarks

Note: Available in Professional edition.

See Also

Reference

ImageXView Class
ImageXView Members


Minimum Property

Minimum Property

Accusoft.ImagXpressSdk Namespace > ImageXView Class : Minimum Property
Gets and sets the minimum dimensions the viewer control can obtain.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(True)>
<DefaultValueAttribute()>
<DescriptionAttribute("The minimum bounding size of the control.")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)>
Public Property Minimum As Size
'Usage

Dim instance As ImageXView
Dim value As Size

instance.Minimum = value

value = instance.Minimum
[Browsable(true)]
[DefaultValue()]
[Description("The minimum bounding size of the control.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
public Size Minimum {get; set;}
[Browsable(true)]
[DefaultValue()]
[Description("The minimum bounding size of the control.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
public: __property Size get_Minimum();
public: __property void set_Minimum(
   Size value
);
[Browsable(true)]
[DefaultValue()]
[Description("The minimum bounding size of the control.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
public:
property Size Minimum {
   Size get();
   void set (    Size value);
}

Property Value

A System.Drawing.Size value which is the minimum the viewer control can obtain.
Remarks

The default value is 1.

See Also

Reference

ImageXView Class
ImageXView Members


MonitorProfileName Property

MonitorProfileName Property

Accusoft.ImagXpressSdk Namespace > ImageXView Class : MonitorProfileName Property
Gets and sets the monitor’s color management profile.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("This property supplies the monitor’s profile filename.")>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<DefaultValueAttribute()>
Public Property MonitorProfileName As String
'Usage

Dim instance As ImageXView
Dim value As String

instance.MonitorProfileName = value

value = instance.MonitorProfileName
[Description("This property supplies the monitor’s profile filename.")]
[Browsable(false)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[DefaultValue()]
public string MonitorProfileName {get; set;}
[Description("This property supplies the monitor’s profile filename.")]
[Browsable(false)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[DefaultValue()]
public: __property string* get_MonitorProfileName();
public: __property void set_MonitorProfileName(
   string* value
);
[Description("This property supplies the monitor’s profile filename.")]
[Browsable(false)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[DefaultValue()]
public:
property String^ MonitorProfileName {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value which represents the color profile.
Remarks

The default value is an empty string "".

Note: Available in Professional edition.

See Also

Reference

ImageXView Class
ImageXView Members


MouseWheelCapture Property

MouseWheelCapture Property

Accusoft.ImagXpressSdk Namespace > ImageXView Class : MouseWheelCapture Property
Gets and sets capturing the mousewheel even when the control does not have focus.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("Property that determines whether the mousewheel is capture even when the control does not have the focus.")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)>
<DefaultValueAttribute()>
<BrowsableAttribute(True)>
Public Property MouseWheelCapture As Boolean
'Usage

Dim instance As ImageXView
Dim value As Boolean

instance.MouseWheelCapture = value

value = instance.MouseWheelCapture
[Description("Property that determines whether the mousewheel is capture even when the control does not have the focus.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
[DefaultValue()]
[Browsable(true)]
public bool MouseWheelCapture {get; set;}
[Description("Property that determines whether the mousewheel is capture even when the control does not have the focus.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
[DefaultValue()]
[Browsable(true)]
public: __property bool get_MouseWheelCapture();
public: __property void set_MouseWheelCapture(
   bool value
);
[Description("Property that determines whether the mousewheel is capture even when the control does not have the focus.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
[DefaultValue()]
[Browsable(true)]
public:
property bool MouseWheelCapture {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true to capture the mousewheel. Otherwise, false should be used.
Remarks

The default value is false.

See Also

Reference

ImageXView Class
ImageXView Members


PaletteFilename Property

PaletteFilename Property

Accusoft.ImagXpressSdk Namespace > ImageXView Class : PaletteFilename Property
Specifies the filename that contains the palette for the control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
<BrowsableAttribute(False)>
<DescriptionAttribute("Specifies the filename that contains the palette for the control.")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property PaletteFilename As String
'Usage

Dim instance As ImageXView
Dim value As String

instance.PaletteFilename = value

value = instance.PaletteFilename
[DefaultValue()]
[Browsable(false)]
[Description("Specifies the filename that contains the palette for the control.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
public string PaletteFilename {get; set;}
[DefaultValue()]
[Browsable(false)]
[Description("Specifies the filename that contains the palette for the control.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
public: __property string* get_PaletteFilename();
public: __property void set_PaletteFilename(
   string* value
);
[DefaultValue()]
[Browsable(false)]
[Description("Specifies the filename that contains the palette for the control.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
public:
property String^ PaletteFilename {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value which represents the filename.
Remarks

Note: Palette file formats can be DIB, BMP, or PAL files.

When the PaletteType property is set as PaletteType.PalFile, images will be displayed during palettized display using the palette loaded from this property.

See Also

Reference

ImageXView Class
ImageXView Members


PaletteType Property

PaletteType Property

Accusoft.ImagXpressSdk Namespace > ImageXView Class : PaletteType Property
Gets and sets the image display palette type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property PaletteType As PaletteType
'Usage

Dim instance As ImageXView
Dim value As PaletteType

instance.PaletteType = value

value = instance.PaletteType
[Browsable(false)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
public PaletteType PaletteType {get; set;}
[Browsable(false)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
public: __property PaletteType get_PaletteType();
public: __property void set_PaletteType(
   PaletteType value
);
[Browsable(false)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
public:
property PaletteType PaletteType {
   PaletteType get();
   void set (    PaletteType value);
}

Property Value

The PaletteType enumeration value set.
Remarks

This property setting will only be valid if the current image is displayed using a palette.

When the Image has a bit depth of 8 bits or less, the image's palette will be realized by the display device. In other words, the image's palette is combined with the display device's logical palette and used to display the image.

You can specify a different behavior by modifying this property. Setting this property does not change the palette stored with the Image, but does change the palette that is realized by the display device.

  • If the PaletteType is set to null, then use the image's palette when displaying.
  • If the PaletteType is set to UserDefined, then use the GetPaletteColor and SetPaletteColor methods to define and access a user-defined palette.
  • If the PaletteType is set to PalFile, then use the PaletteFilename property to get and set the source for the palette.
  • If the PaletteType is set to Gray, a fixed gray palette is used.
  • If the PaletteType is set to Fixed, then an ImageXView internally defined palette is used.
  • If the PaletteType is set to Optimized, then the image is analyzed, and the best palette is used.
See Also

Reference

ImageXView Class
ImageXView Members


PixelColor Property

PixelColor Property

Accusoft.ImagXpressSdk Namespace > ImageXView Class : PixelColor Property
Gets the color of the pixel within the client area of the view control at which the cursor is currently positioned.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public ReadOnly Property PixelColor As Color
'Usage

Dim instance As ImageXView
Dim value As Color

value = instance.PixelColor
[Browsable(false)]
public Color PixelColor {get;}
[Browsable(false)]
public: __property Color get_PixelColor();
[Browsable(false)]
public:
property Color PixelColor {
   Color get();
}

Property Value

A System.Drawing.Color value which represents the color of the pixel within the client area of the view control.
See Also

Reference

ImageXView Class
ImageXView Members


PreserveBlack Property (ImageXView)

PreserveBlack Property (ImageXView)

Accusoft.ImagXpressSdk Namespace > ImageXView Class : PreserveBlack Property
Gets and sets an indicator if black should be preserved and applied when viewing the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("Enables/disables preserving black pixels when resizing a black and white image to the view.")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
<DefaultValueAttribute()>
Public Property PreserveBlack As Boolean
'Usage

Dim instance As ImageXView
Dim value As Boolean

instance.PreserveBlack = value

value = instance.PreserveBlack
[Description("Enables/disables preserving black pixels when resizing a black and white image to the view.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Browsable(false)]
[DefaultValue()]
public bool PreserveBlack {get; set;}
[Description("Enables/disables preserving black pixels when resizing a black and white image to the view.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Browsable(false)]
[DefaultValue()]
public: __property bool get_PreserveBlack();
public: __property void set_PreserveBlack(
   bool value
);
[Description("Enables/disables preserving black pixels when resizing a black and white image to the view.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Browsable(false)]
[DefaultValue()]
public:
property bool PreserveBlack {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true for black objects (such as lines) to be enhanced to increase readability. Otherwise, false is returned and no enhancement of black objects is applied.
Remarks

The default value is false.

This property is useful to maintain readability of images when the display size is very small and zoom is applied where dark pixels can be subsampled away.

Note: This property does not modify the image in memory.

See Also

Reference

ImageXView Class
ImageXView Members


PrinterProfileName Property

PrinterProfileName Property

Accusoft.ImagXpressSdk Namespace > ImageXView Class : PrinterProfileName Property
Gets and sets the printer’s profile filename.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("This property supplies the printer’s profile filename.")>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<DefaultValueAttribute()>
Public Property PrinterProfileName As String
'Usage

Dim instance As ImageXView
Dim value As String

instance.PrinterProfileName = value

value = instance.PrinterProfileName
[Description("This property supplies the printer’s profile filename.")]
[Browsable(false)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[DefaultValue()]
public string PrinterProfileName {get; set;}
[Description("This property supplies the printer’s profile filename.")]
[Browsable(false)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[DefaultValue()]
public: __property string* get_PrinterProfileName();
public: __property void set_PrinterProfileName(
   string* value
);
[Description("This property supplies the printer’s profile filename.")]
[Browsable(false)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[DefaultValue()]
public:
property String^ PrinterProfileName {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value which represents the printer's profile filename.
Remarks

The default value is an empty string "".

This property is overwriten by the TargetProfileName property in rendering the image with the intent that the caller desires proofing against a particular printer/ink that is different from his selected printer.

Note: Available in Professional edition.

See Also

Reference

ImageXView Class
ImageXView Members
TargetProfileName Property


Progressive Property (ImageXView)

Progressive Property (ImageXView)

Accusoft.ImagXpressSdk Namespace > ImageXView Class : Progressive Property
Gets and sets an indication if images are displayed progressively.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DescriptionAttribute("Enables/disables viewing an image progressively.")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<DefaultValueAttribute()>
Public Property Progressive As Boolean
'Usage

Dim instance As ImageXView
Dim value As Boolean

instance.Progressive = value

value = instance.Progressive
[Browsable(false)]
[Description("Enables/disables viewing an image progressively.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[DefaultValue()]
public bool Progressive {get; set;}
[Browsable(false)]
[Description("Enables/disables viewing an image progressively.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[DefaultValue()]
public: __property bool get_Progressive();
public: __property void set_Progressive(
   bool value
);
[Browsable(false)]
[Description("Enables/disables viewing an image progressively.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[DefaultValue()]
public:
property bool Progressive {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true when the image is displayed progressively. Otherwise, false is returned.
Remarks

The default value is false.

Progressive viewing can be useful if loading is expected to take a long time (e.g. remote loading of a large, highly compressed file).

See Also

Reference

ImageXView Class
ImageXView Members


RefreshMode Property

RefreshMode Property

Accusoft.ImagXpressSdk Namespace > ImageXView Class : RefreshMode Property
Gets and sets an indicator which specifies when the control is refreshed after an operation is completed on the attached Image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
<DescriptionAttribute("Property that determines whether the control is refreshed immediately or when the system is ready to paint.")>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property RefreshMode As RefreshMode
'Usage

Dim instance As ImageXView
Dim value As RefreshMode

instance.RefreshMode = value

value = instance.RefreshMode
[DefaultValue()]
[Description("Property that determines whether the control is refreshed immediately or when the system is ready to paint.")]
[Browsable(false)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
public RefreshMode RefreshMode {get; set;}
[DefaultValue()]
[Description("Property that determines whether the control is refreshed immediately or when the system is ready to paint.")]
[Browsable(false)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
public: __property RefreshMode get_RefreshMode();
public: __property void set_RefreshMode(
   RefreshMode value
);
[DefaultValue()]
[Description("Property that determines whether the control is refreshed immediately or when the system is ready to paint.")]
[Browsable(false)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
public:
property RefreshMode RefreshMode {
   RefreshMode get();
   void set (    RefreshMode value);
}

Property Value

The RefreshMode set.
Remarks

The default value is RefreshMode.Immediate (1).

Note: In RefreshMode.Standard, the ImageXView control is just invalidated and will update the next time a paint message is received. In RefreshMode.Immediate the control is updated immediately after an operation has completed on the attached Image.

Typically, you will want to use RefreshMode.Standard as this results in the least amount of screen updates and is the fastest, especially if multiple operations are performed back to back. Use RefreshMode.Immediate if you require the ImageXView to be updated after each and every operation.

See Also

Reference

ImageXView Class
ImageXView Members


Rubberband Property

Rubberband Property

Accusoft.ImagXpressSdk Namespace > ImageXView Class : Rubberband Property
Gets the current Rubberband object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public ReadOnly Property Rubberband As Rubberband
'Usage

Dim instance As ImageXView
Dim value As Rubberband

value = instance.Rubberband
[Browsable(false)]
public Rubberband Rubberband {get;}
[Browsable(false)]
public: __property Rubberband* get_Rubberband();
[Browsable(false)]
public:
property Rubberband^ Rubberband {
   Rubberband^ get();
}

Property Value

The Rubberband object set.
See Also

Reference

ImageXView Class
ImageXView Members
Rubberband Class


ScrollBars Property

ScrollBars Property

Accusoft.ImagXpressSdk Namespace > ImageXView Class : ScrollBars Property
Gets or sets the type of scroll bars to display in the ImageXView control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
<DescriptionAttribute("Defines the behavior of the scroll bars of the control.")>
Public Property ScrollBars As ScrollBars
'Usage

Dim instance As ImageXView
Dim value As ScrollBars

instance.ScrollBars = value

value = instance.ScrollBars
[DefaultValue()]
[Description("Defines the behavior of the scroll bars of the control.")]
public ScrollBars ScrollBars {get; set;}
[DefaultValue()]
[Description("Defines the behavior of the scroll bars of the control.")]
public: __property ScrollBars get_ScrollBars();
public: __property void set_ScrollBars(
   ScrollBars value
);
[DefaultValue()]
[Description("Defines the behavior of the scroll bars of the control.")]
public:
property ScrollBars ScrollBars {
   ScrollBars get();
   void set (    ScrollBars value);
}

Property Value

One of the System.Windows.Forms.ScrollBars values. The default is ScrollBars.Both.
Remarks

This property enables you to provide horizontal and vertical scroll bars to the user of the ImageXView control to enable scrolling the image within the control that is outside of the physical dimensions of the control. You can also use this property to remove scroll bars from the control to restrict scrolling the contents of the control.

Note: Scroll bars will not be shown at all if the AutoResize property is set to AutoResizeType.BestFit, regardless of the ScrollBars property. Horizontal scroll bars will not be shown if the AutoResize property is set to AutoResizeType.FitWidth. Vertical scroll bars will not be shown if the AutoResize property is set to AutoResizeType.FitHeight.

See Also

Reference

ImageXView Class
ImageXView Members


ScrollPosition Property

ScrollPosition Property

Accusoft.ImagXpressSdk Namespace > ImageXView Class : ScrollPosition Property
Gets and sets the current scrolling position of the cursor on the scrollbar.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("Property that determines whether updates allow the control to be repainted.")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
Public Property ScrollPosition As Point
'Usage

Dim instance As ImageXView
Dim value As Point

instance.ScrollPosition = value

value = instance.ScrollPosition
[Description("Property that determines whether updates allow the control to be repainted.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Browsable(false)]
public Point ScrollPosition {get; set;}
[Description("Property that determines whether updates allow the control to be repainted.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Browsable(false)]
public: __property Point get_ScrollPosition();
public: __property void set_ScrollPosition(
   Point value
);
[Description("Property that determines whether updates allow the control to be repainted.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Browsable(false)]
public:
property Point ScrollPosition {
   Point get();
   void set (    Point value);
}

Property Value

A System.Drawing.Point value which represents the scrolling position of the cursor on the scrollbar.
See Also

Reference

ImageXView Class
ImageXView Members


Smoothing Property

Smoothing Property

Accusoft.ImagXpressSdk Namespace > ImageXView Class : Smoothing Property
Gets and sets an indicator for the smoothing effect on the current color image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
<BrowsableAttribute(True)>
<DescriptionAttribute("Enables/disables the smoothing effect for the display image.")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)>
Public Property Smoothing As Boolean
'Usage

Dim instance As ImageXView
Dim value As Boolean

instance.Smoothing = value

value = instance.Smoothing
[DefaultValue()]
[Browsable(true)]
[Description("Enables/disables the smoothing effect for the display image.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
public bool Smoothing {get; set;}
[DefaultValue()]
[Browsable(true)]
[Description("Enables/disables the smoothing effect for the display image.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
public: __property bool get_Smoothing();
public: __property void set_Smoothing(
   bool value
);
[DefaultValue()]
[Browsable(true)]
[Description("Enables/disables the smoothing effect for the display image.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
public:
property bool Smoothing {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true when the smoothing effect is on the current color image. Otherwise, false is returned.
Remarks

The default value is true.

When the logical size of a color image is increased to more than the actual size of the image, the color image starts to look boxy. When Smoothing is enabled, ImagXpress performs an algorithm that smoothes out the square edges.

This property affects how the color image is displayed, but does not modify the image in memory.

See Also

Reference

ImageXView Class
ImageXView Members


Sprite Property

Sprite Property

Accusoft.ImagXpressSdk Namespace > ImageXView Class : Sprite Property
Gets the Sprite object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property Sprite As Sprite
'Usage

Dim instance As ImageXView
Dim value As Sprite

value = instance.Sprite
[Browsable(false)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
public Sprite Sprite {get;}
[Browsable(false)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
public: __property Sprite* get_Sprite();
[Browsable(false)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
public:
property Sprite^ Sprite {
   Sprite^ get();
}

Property Value

The Sprite object set.
See Also

Reference

ImageXView Class
ImageXView Members
Sprite Class


TargetProfileName Property (ImageXView)

TargetProfileName Property (ImageXView)

Accusoft.ImagXpressSdk Namespace > ImageXView Class : TargetProfileName Property
Gets and sets the target profile’s filename.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DescriptionAttribute("This property supplies the target profile’s filename.")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<DefaultValueAttribute()>
Public Property TargetProfileName As String
'Usage

Dim instance As ImageXView
Dim value As String

instance.TargetProfileName = value

value = instance.TargetProfileName
[Browsable(false)]
[Description("This property supplies the target profile’s filename.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[DefaultValue()]
public string TargetProfileName {get; set;}
[Browsable(false)]
[Description("This property supplies the target profile’s filename.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[DefaultValue()]
public: __property string* get_TargetProfileName();
public: __property void set_TargetProfileName(
   string* value
);
[Browsable(false)]
[Description("This property supplies the target profile’s filename.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[DefaultValue()]
public:
property String^ TargetProfileName {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value which represents the target profile's filename.
Remarks

This property overrides the PrinterProfileName property in rendering the image with the intent that the caller desires proofing against a particular printer/ink that is different from his selected printer.

Note: Available in Professional edition.

See Also

Reference

ImageXView Class
ImageXView Members
PrinterProfileName Property


ToolActive Property

ToolActive Property

Accusoft.ImagXpressSdk Namespace > ImageXView Class : ToolActive Property
Gets the currently active tool.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DescriptionAttribute("Retrieves the currently active tool.")>
Public ReadOnly Property ToolActive As Tool
'Usage

Dim instance As ImageXView
Dim value As Tool

value = instance.ToolActive
[Browsable(false)]
[Description("Retrieves the currently active tool.")]
public Tool ToolActive {get;}
[Browsable(false)]
[Description("Retrieves the currently active tool.")]
public: __property Tool get_ToolActive();
[Browsable(false)]
[Description("Retrieves the currently active tool.")]
public:
property Tool ToolActive {
   Tool get();
}

Property Value

The Tool enumeration value set.
Remarks

The default value is Tool.None.

See Also

Reference

ImageXView Class
ImageXView Members
Tool Enumeration


Toolbar Property

Toolbar Property

Accusoft.ImagXpressSdk Namespace > ImageXView Class : Toolbar Property
Gets the current Toolbar object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public ReadOnly Property Toolbar As Toolbar
'Usage

Dim instance As ImageXView
Dim value As Toolbar

value = instance.Toolbar
[Browsable(false)]
public Toolbar Toolbar {get;}
[Browsable(false)]
public: __property Toolbar* get_Toolbar();
[Browsable(false)]
public:
property Toolbar^ Toolbar {
   Toolbar^ get();
}

Property Value

The Toolbar object set.
See Also

Reference

ImageXView Class
ImageXView Members
Toolbar Class


Touch Property

Touch Property

Accusoft.ImagXpressSdk Namespace > ImageXView Class : Touch Property
Gets the current Touch object for setting Touch behavior.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public ReadOnly Property Touch As Touch
'Usage

Dim instance As ImageXView
Dim value As Touch

value = instance.Touch
[Browsable(false)]
public Touch Touch {get;}
[Browsable(false)]
public: __property Touch* get_Touch();
[Browsable(false)]
public:
property Touch^ Touch {
   Touch^ get();
}

Property Value

The Touch object.
See Also

Reference

ImageXView Class
ImageXView Members
Touch Class


Workspace Property (ImageXView)

Workspace Property (ImageXView)
Example

Accusoft.ImagXpressSdk Namespace > ImageXView Class : Workspace Property
Gets or sets the ImagXpress workspace component.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DescriptionAttribute("Gets or sets the ImagXpress workspace component.")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<DefaultValueAttribute()>
Public Property Workspace As ImagXpress
'Usage

Dim instance As ImageXView
Dim value As ImagXpress

instance.Workspace = value

value = instance.Workspace
[Browsable(false)]
[Description("Gets or sets the ImagXpress workspace component.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[DefaultValue()]
public ImagXpress Workspace {get; set;}
[Browsable(false)]
[Description("Gets or sets the ImagXpress workspace component.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[DefaultValue()]
public: __property ImagXpress* get_Workspace();
public: __property void set_Workspace(
   ImagXpress* value
);
[Browsable(false)]
[Description("Gets or sets the ImagXpress workspace component.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[DefaultValue()]
public:
property ImagXpress^ Workspace {
   ImagXpress^ get();
   void set (    ImagXpress^ value);
}

Property Value

The instance of the ImagXpress workspace component that the ImageXView control is tied to. This is the main ImagXpress component that typically must be dragged onto a form first.
Remarks

This property can only be set if the value is null. Once the ImageXView control has a ImagXpress workspace, it can NOT be changed.

This property only needs to be set if you use the ImageXView control in a WPF (Windows Presentation Framework) project or dynamically create an ImageXView instance with the default constructor. This property should NOT need to be set in any other instance. If the property already has a valid ImagXpress workspace because it has been set once before or the control was created through one of the other constructors setting this property will have no effect. Once an ImageXView has been set with its ImagXpress workspace it can NOT be changed to another ImagXpress workspace component.

Note: Failure to set this property with a valid ImagXpress workspace component when it is null as described above will cause the control to display a warning message in its window as well as throw an exception on certain properties and methods.

Example
This sample shows one way of using this property to avoid licensing issues.
  • C#
public partial class Form1 : Form
{
        public Form1()
        {
            InitializeComponent();
            // Create an ImagXpress object for licensing
            Accusoft.ImagXpressSdk.ImagXpress imagXpress1 = new Accusoft.ImagXpressSdk.ImagXpress();
         //***The SetSolutionName, SetSolutionKey and possibly the SetOEMLicenseKey methods must be called to distribute the runtime***
         imagXpress1.Licensing.SetSolutionName(“YourSolutionName”);
         imagXpress1.Licensing.SetSolutionKey(12345,12345,12345,12345);
         imagXpress1.Licensing.SetOEMLicenseKey(“1.0.AStringForOEMLicensingContactAccusoftSalesForMoreInformation…”);

            // if you use the default empty constructor, you must call the Workspace property before
            // displaying the control or calling one of its methods.
            Accusoft.ImagXpressSdk.ImageXView imageXView1 = new Accusoft.ImagXpressSdk.ImageXView();
            imageXView1.Workspace = imagXpress1;
        }
}
See Also

Reference

ImageXView Class
ImageXView Members


ZoomFactor Property (ImageXView)

ZoomFactor Property (ImageXView)

Accusoft.ImagXpressSdk Namespace > ImageXView Class : ZoomFactor Property
Gets and sets the zoom factor display for the current image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)>
<DescriptionAttribute("The zooming factor for the image to be displayed at.")>
<BrowsableAttribute(True)>
<DefaultValueAttribute()>
Public Property ZoomFactor As Double
'Usage

Dim instance As ImageXView
Dim value As Double

instance.ZoomFactor = value

value = instance.ZoomFactor
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
[Description("The zooming factor for the image to be displayed at.")]
[Browsable(true)]
[DefaultValue()]
public double ZoomFactor {get; set;}
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
[Description("The zooming factor for the image to be displayed at.")]
[Browsable(true)]
[DefaultValue()]
public: __property double get_ZoomFactor();
public: __property void set_ZoomFactor(
   double value
);
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
[Description("The zooming factor for the image to be displayed at.")]
[Browsable(true)]
[DefaultValue()]
public:
property double ZoomFactor {
   double get();
   void set (    double value);
}

Property Value

A double value which represents the zoom for the display of the image.
Remarks

The default value is 1.

Values greater than 1 result in the display image being enlarged. For example, a ZoomFactor = 2 doubles the display image height and width.

Values less than 1 result in the display image being reduced. For example, a ZoomFactor = .5 reduces the display image height and width by 50.

Zooming has no effect on the stored image, the aspect ratio of the displayed image, or the aspect ratio of the image's pixels.

Note: If the AutoResize property is set to BestFit, FitWidth, FitHeight or ResizeImage, then the ZoomFactor property is read-only. In the case that the property is set to ResizeImage then the ZoomFactor will always return a -1.0 as there is no uniform ZoomFactor applied to the image.

See Also

Reference

ImageXView Class
ImageXView Members


ImageXView Class Events

ImageXView Class Events

Accusoft.ImagXpressSdk Namespace : ImageXView Class

For a list of all members of this type, see ImageXView members.

Public Events
 | Name | Description
Public Event | AutoResizeChanged | Thrown when the AutoResize property changes.
Public Event | AutoSizeChanged | (Inherited from System.Windows.Forms.UserControl)
Public Event | AutoValidateChanged | (Inherited from System.Windows.Forms.UserControl)
Public Event | BackColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | (Inherited from System.Windows.Forms.Control)
Public Event | Click | (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Enter | (Inherited from System.Windows.Forms.Control)
Public Event | Flick | Thrown when the user performs a flick on the Touch interface.
Public Event | FontChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | (Inherited from System.Windows.Forms.Control)
Public Event | Layout | (Inherited from System.Windows.Forms.Control)
Public Event | Leave | (Inherited from System.Windows.Forms.Control)
Public Event | Load | (Inherited from System.Windows.Forms.UserControl)
Public Event | LocationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | (Inherited from System.Windows.Forms.Control)
Public Event | Move | (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Paint | (Inherited from System.Windows.Forms.Control)
Public Event | PaintImage | Thrown when the image is painted onto the screen.
Public Event | PanGestureOccurred | Thrown when the user has finished panning with the Touch interface.
Public Event | PanGestureOccurring | Thrown when the user is in the process of panning with the Touch interface.
Public Event | ParentChanged | (Inherited from System.Windows.Forms.Control)
Public Event | PressAndHold | Thrown when the user performs a press and hold with the Touch interface.
Public Event | PressAndTap | Thrown when the user performs a press and tap with the Touch interface.
Public Event | PreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | PrintImage | Thrown when the image is printed onto the paper.
Public Event | QueryAccessibilityHelp | (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Resize | (Inherited from System.Windows.Forms.Control)
Public Event | Resized | Thrown after the control has been completely resized.
Public Event | RightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Public Event | RotationGestureOccurred | Thrown when the user has finished rotating with the Touch interface.
Public Event | RotationGestureOccurring | Thrown when the user is in the process of rotating with the Touch interface.
Public Event | Scroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | ScrollbarVisibleChanged | Thrown when one or more scrollbars changes its visibility.
Public Event | ScrollEvent | Thrown during a scroll event.
Public Event | SizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ToolbarCloseEvent | Thrown when a toolbar close event occurs.
Public Event | ToolbarContextMenuSelectEvent | Thrown when the toolbar context menu is selected.
Public Event | ToolbarEvent | Thrown when a toolbar event occurs.
Public Event | ToolbarOpenEvent | Thrown when a toolbar open event occurs.
Public Event | ToolEvent | Thrown when a tool event occurs.
Public Event | TwoFingerTap | Thrown when the user performs a two finger tap on the Touch interface.
Public Event | Validated | (Inherited from System.Windows.Forms.Control)
Public Event | Validating | (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ZoomFactorChanged | Thrown when the ZoomFactor property changes.
Public Event | ZoomGestureOccurred | Thrown when the user has finished zooming with the Touch interface.
Public Event | ZoomGestureOccurring | Thrown when the user is in the process of zooming with the Touch interface.
Top
See Also

Reference

ImageXView Class
Accusoft.ImagXpressSdk Namespace


AutoResizeChanged Event

AutoResizeChanged Event

Accusoft.ImagXpressSdk Namespace > ImageXView Class : AutoResizeChanged Event
Thrown when the AutoResize property changes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event AutoResizeChanged As ImageXView.AutoResizeChangedEventHandler
'Usage

Dim instance As ImageXView
Dim handler As ImageXView.AutoResizeChangedEventHandler

AddHandler instance.AutoResizeChanged, handler
public event ImageXView.AutoResizeChangedEventHandler AutoResizeChanged
public: __event ImageXView.AutoResizeChangedEventHandler* AutoResizeChanged
public:
event ImageXView.AutoResizeChangedEventHandler^ AutoResizeChanged
Event Data

The event handler receives an argument of type AutoResizeChangedEventArgs containing data related to this event. The following AutoResizeChangedEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets the new value for the AutoResize property.
OldValue | Gets the old value for the AutoResize property.
See Also

Reference

ImageXView Class
ImageXView Members


Flick Event

Flick Event

Accusoft.ImagXpressSdk Namespace > ImageXView Class : Flick Event
Thrown when the user performs a flick on the Touch interface.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event Flick As ImageXView.FlickEventHandler
'Usage

Dim instance As ImageXView
Dim handler As ImageXView.FlickEventHandler

AddHandler instance.Flick, handler
public event ImageXView.FlickEventHandler Flick
public: __event ImageXView.FlickEventHandler* Flick
public:
event ImageXView.FlickEventHandler^ Flick
Event Data

The event handler receives an argument of type FlickEventArgs containing data related to this event. The following FlickEventArgs properties provide information specific to this event.

Property | Description
Direction | Gets the direction of the flick.
FlickStartLocation | Gets the starting location for the flick during a flick motion with the touch interface.
See Also

Reference

ImageXView Class
ImageXView Members


PaintImage Event

PaintImage Event

Accusoft.ImagXpressSdk Namespace > ImageXView Class : PaintImage Event
Thrown when the image is painted onto the screen.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PaintImage As ImageXView.PaintImageEventHandler
'Usage

Dim instance As ImageXView
Dim handler As ImageXView.PaintImageEventHandler

AddHandler instance.PaintImage, handler
public event ImageXView.PaintImageEventHandler PaintImage
public: __event ImageXView.PaintImageEventHandler* PaintImage
public:
event ImageXView.PaintImageEventHandler^ PaintImage
Event Data

The event handler receives an argument of type PaintImageEventArgs containing data related to this event. The following PaintImageEventArgs properties provide information specific to this event.

Property | Description
Graphics | Gets the System.Drawing.Graphics object.
LogicalRectangle | Gets the logical rectangle.
UpdateRectangle | Gets the update rectangle.
ViewRectangle | Gets the view's rectangle.
ZoomFactor | Gets the zoom factor.
See Also

Reference

ImageXView Class
ImageXView Members


PanGestureOccurred Event

PanGestureOccurred Event

Accusoft.ImagXpressSdk Namespace > ImageXView Class : PanGestureOccurred Event
Thrown when the user has finished panning with the Touch interface.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PanGestureOccurred As ImageXView.PanGestureOccurredEventHandler
'Usage

Dim instance As ImageXView
Dim handler As ImageXView.PanGestureOccurredEventHandler

AddHandler instance.PanGestureOccurred, handler
public event ImageXView.PanGestureOccurredEventHandler PanGestureOccurred
public: __event ImageXView.PanGestureOccurredEventHandler* PanGestureOccurred
public:
event ImageXView.PanGestureOccurredEventHandler^ PanGestureOccurred
Event Data

The event handler receives an argument of type PanGestureOccurredEventArgs containing data related to this event. The following PanGestureOccurredEventArgs properties provide information specific to this event.

Property | Description
TotalDelta | Gets the sum of all of the deltas from the start position during panning with the touch interface.
See Also

Reference

ImageXView Class
ImageXView Members


PanGestureOccurring Event

PanGestureOccurring Event

Accusoft.ImagXpressSdk Namespace > ImageXView Class : PanGestureOccurring Event
Thrown when the user is in the process of panning with the Touch interface.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PanGestureOccurring As ImageXView.PanGestureOccurringEventHandler
'Usage

Dim instance As ImageXView
Dim handler As ImageXView.PanGestureOccurringEventHandler

AddHandler instance.PanGestureOccurring, handler
public event ImageXView.PanGestureOccurringEventHandler PanGestureOccurring
public: __event ImageXView.PanGestureOccurringEventHandler* PanGestureOccurring
public:
event ImageXView.PanGestureOccurringEventHandler^ PanGestureOccurring
Event Data

The event handler receives an argument of type PanGestureOccurringEventArgs containing data related to this event. The following PanGestureOccurringEventArgs properties provide information specific to this event.

Property | Description
DeltaSinceLastEventFiring | Gets the difference or delta from the last position during a panning gesture with the touch interface.
HasInertia | Gets whether the panning gesture has inertia during a panning gesture with the touch interface.
InertialVector | Gets the inertial vector during a panning gesture with the touch interface.
See Also

Reference

ImageXView Class
ImageXView Members


PressAndHold Event

PressAndHold Event

Accusoft.ImagXpressSdk Namespace > ImageXView Class : PressAndHold Event
Thrown when the user performs a press and hold with the Touch interface.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PressAndHold As ImageXView.PressAndHoldEventHandler
'Usage

Dim instance As ImageXView
Dim handler As ImageXView.PressAndHoldEventHandler

AddHandler instance.PressAndHold, handler
public event ImageXView.PressAndHoldEventHandler PressAndHold
public: __event ImageXView.PressAndHoldEventHandler* PressAndHold
public:
event ImageXView.PressAndHoldEventHandler^ PressAndHold
Event Data

The event handler receives an argument of type PressAndHoldEventArgs containing data related to this event. The following PressAndHoldEventArgs properties provide information specific to this event.

Property | Description
HeldFingerLocation | Gets the location of the held finger during a press and hold with the touch interface.
See Also

Reference

ImageXView Class
ImageXView Members


PressAndTap Event

PressAndTap Event

Accusoft.ImagXpressSdk Namespace > ImageXView Class : PressAndTap Event
Thrown when the user performs a press and tap with the Touch interface.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PressAndTap As ImageXView.PressAndTapEventHandler
'Usage

Dim instance As ImageXView
Dim handler As ImageXView.PressAndTapEventHandler

AddHandler instance.PressAndTap, handler
public event ImageXView.PressAndTapEventHandler PressAndTap
public: __event ImageXView.PressAndTapEventHandler* PressAndTap
public:
event ImageXView.PressAndTapEventHandler^ PressAndTap
Event Data

The event handler receives an argument of type PressAndTapEventArgs containing data related to this event. The following PressAndTapEventArgs properties provide information specific to this event.

Property | Description
PressedFingerLocation | Gets the location of the pressed finger during a press and tap with the touch interface.
See Also

Reference

ImageXView Class
ImageXView Members


PrintImage Event

PrintImage Event

Accusoft.ImagXpressSdk Namespace > ImageXView Class : PrintImage Event
Thrown when the image is printed onto the paper.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PrintImage As ImageXView.PrintImageEventHandler
'Usage

Dim instance As ImageXView
Dim handler As ImageXView.PrintImageEventHandler

AddHandler instance.PrintImage, handler
public event ImageXView.PrintImageEventHandler PrintImage
public: __event ImageXView.PrintImageEventHandler* PrintImage
public:
event ImageXView.PrintImageEventHandler^ PrintImage
Event Data

The event handler receives an argument of type PrintImageEventArgs containing data related to this event. The following PrintImageEventArgs properties provide information specific to this event.

Property | Description
Graphics | Gets the System.Drawing.Graphics object.
GraphicsUnit | Gets the graphics unit.
ImageRectangle | Gets the image's rectangle.
PrintRectangle | Gets the printer's rectangle.
PrintType | Gets the type of the print that was performed.
See Also

Reference

ImageXView Class
ImageXView Members


Resized Event

Resized Event

Accusoft.ImagXpressSdk Namespace > ImageXView Class : Resized Event
Thrown after the control has been completely resized.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event Resized As ImageXView.ResizedEventHandler
'Usage

Dim instance As ImageXView
Dim handler As ImageXView.ResizedEventHandler

AddHandler instance.Resized, handler
public event ImageXView.ResizedEventHandler Resized
public: __event ImageXView.ResizedEventHandler* Resized
public:
event ImageXView.ResizedEventHandler^ Resized
Event Data

The event handler receives an argument of type ResizedEventArgs containing data related to this event. The following ResizedEventArgs properties provide information specific to this event.

Property | Description
NewSize | Gets the new size of the control.
See Also

Reference

ImageXView Class
ImageXView Members


RotationGestureOccurred Event

RotationGestureOccurred Event

Accusoft.ImagXpressSdk Namespace > ImageXView Class : RotationGestureOccurred Event
Thrown when the user has finished rotating with the Touch interface.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event RotationGestureOccurred As ImageXView.RotationGestureOccurredEventHandler
'Usage

Dim instance As ImageXView
Dim handler As ImageXView.RotationGestureOccurredEventHandler

AddHandler instance.RotationGestureOccurred, handler
public event ImageXView.RotationGestureOccurredEventHandler RotationGestureOccurred
public: __event ImageXView.RotationGestureOccurredEventHandler* RotationGestureOccurred
public:
event ImageXView.RotationGestureOccurredEventHandler^ RotationGestureOccurred
Event Data

The event handler receives an argument of type RotationGestureOccurredEventArgs containing data related to this event. The following RotationGestureOccurredEventArgs properties provide information specific to this event.

Property | Description
RotationCenterPoint | Gets the center of the fingers during rotation with the touch interface.
TotalDegreesRotated | Gets the angle (in degrees) of cumulative rotation during rotation with the touch interface.
See Also

Reference

ImageXView Class
ImageXView Members


RotationGestureOccurring Event

RotationGestureOccurring Event

Accusoft.ImagXpressSdk Namespace > ImageXView Class : RotationGestureOccurring Event
Thrown when the user is in the process of rotating with the Touch interface.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event RotationGestureOccurring As ImageXView.RotationGestureOccurringEventHandler
'Usage

Dim instance As ImageXView
Dim handler As ImageXView.RotationGestureOccurringEventHandler

AddHandler instance.RotationGestureOccurring, handler
public event ImageXView.RotationGestureOccurringEventHandler RotationGestureOccurring
public: __event ImageXView.RotationGestureOccurringEventHandler* RotationGestureOccurring
public:
event ImageXView.RotationGestureOccurringEventHandler^ RotationGestureOccurring
Event Data

The event handler receives an argument of type RotationGestureOccurringEventArgs containing data related to this event. The following RotationGestureOccurringEventArgs properties provide information specific to this event.

Property | Description
DegreesRotated | Gets the angle (in degrees) of cumulative rotation during rotation with the touch interface.
RotationCenterPoint | Gets the center of the fingers during rotation with the touch interface.
See Also

Reference

ImageXView Class
ImageXView Members


ScrollbarVisibleChanged Event

ScrollbarVisibleChanged Event

Accusoft.ImagXpressSdk Namespace > ImageXView Class : ScrollbarVisibleChanged Event
Thrown when one or more scrollbars changes its visibility.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event ScrollbarVisibleChanged As ImageXView.ScrollbarVisibleChangedEventHandler
'Usage

Dim instance As ImageXView
Dim handler As ImageXView.ScrollbarVisibleChangedEventHandler

AddHandler instance.ScrollbarVisibleChanged, handler
public event ImageXView.ScrollbarVisibleChangedEventHandler ScrollbarVisibleChanged
public: __event ImageXView.ScrollbarVisibleChangedEventHandler* ScrollbarVisibleChanged
public:
event ImageXView.ScrollbarVisibleChangedEventHandler^ ScrollbarVisibleChanged
Event Data

The event handler receives an argument of type ScrollbarVisibleChangedEventArgs containing data related to this event. The following ScrollbarVisibleChangedEventArgs properties provide information specific to this event.

Property | Description
ScrollBar | Gets which scrollbar the event pertains to.
Visible | Gets the visibility of the Scrollbar.
See Also

Reference

ImageXView Class
ImageXView Members


ScrollEvent Event

ScrollEvent Event

Accusoft.ImagXpressSdk Namespace > ImageXView Class : ScrollEvent Event
Thrown during a scroll event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event ScrollEvent As ImageXView.ScrollEventHandler
'Usage

Dim instance As ImageXView
Dim handler As ImageXView.ScrollEventHandler

AddHandler instance.ScrollEvent, handler
public event ImageXView.ScrollEventHandler ScrollEvent
public: __event ImageXView.ScrollEventHandler* ScrollEvent
public:
event ImageXView.ScrollEventHandler^ ScrollEvent
Event Data

The event handler receives an argument of type ScrollEventArgs containing data related to this event. The following ScrollEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets the new location within the scroll range.
ScrollBar | Gets which scrollbar the event pertains to.
Type | Gets the type of scroll event that occurred.
See Also

Reference

ImageXView Class
ImageXView Members


ToolbarCloseEvent Event

ToolbarCloseEvent Event

Accusoft.ImagXpressSdk Namespace > ImageXView Class : ToolbarCloseEvent Event
Thrown when a toolbar close event occurs.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event ToolbarCloseEvent As ImageXView.ToolbarCloseEventHandler
'Usage

Dim instance As ImageXView
Dim handler As ImageXView.ToolbarCloseEventHandler

AddHandler instance.ToolbarCloseEvent, handler
public event ImageXView.ToolbarCloseEventHandler ToolbarCloseEvent
public: __event ImageXView.ToolbarCloseEventHandler* ToolbarCloseEvent
public:
event ImageXView.ToolbarCloseEventHandler^ ToolbarCloseEvent
See Also

Reference

ImageXView Class
ImageXView Members


ToolbarContextMenuSelectEvent Event

ToolbarContextMenuSelectEvent Event

Accusoft.ImagXpressSdk Namespace > ImageXView Class : ToolbarContextMenuSelectEvent Event
Thrown when the toolbar context menu is selected.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event ToolbarContextMenuSelectEvent As ImageXView.ToolbarContextMenuSelectEventHandler
'Usage

Dim instance As ImageXView
Dim handler As ImageXView.ToolbarContextMenuSelectEventHandler

AddHandler instance.ToolbarContextMenuSelectEvent, handler
public event ImageXView.ToolbarContextMenuSelectEventHandler ToolbarContextMenuSelectEvent
public: __event ImageXView.ToolbarContextMenuSelectEventHandler* ToolbarContextMenuSelectEvent
public:
event ImageXView.ToolbarContextMenuSelectEventHandler^ ToolbarContextMenuSelectEvent
Event Data

The event handler receives an argument of type ToolbarContextMenuEventArgs containing data related to this event. The following ToolbarContextMenuEventArgs properties provide information specific to this event.

Property | Description
SubMenuId | Gets the sub-level menu ID for this menu item.
Tool | Gets the Tool associated with the context menu that fired the event.
TopMenuId | Gets the top-level menu ID for this menu ID.
User1 | Gets the first of two user-supplied values set when the menu was created.
User2 | Gets the second of two user-supplied values set when the menu was created.
See Also

Reference

ImageXView Class
ImageXView Members


ToolbarEvent Event

ToolbarEvent Event

Accusoft.ImagXpressSdk Namespace > ImageXView Class : ToolbarEvent Event
Thrown when a toolbar event occurs.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event ToolbarEvent As ImageXView.ToolbarEventHandler
'Usage

Dim instance As ImageXView
Dim handler As ImageXView.ToolbarEventHandler

AddHandler instance.ToolbarEvent, handler
public event ImageXView.ToolbarEventHandler ToolbarEvent
public: __event ImageXView.ToolbarEventHandler* ToolbarEvent
public:
event ImageXView.ToolbarEventHandler^ ToolbarEvent
Event Data

The event handler receives an argument of type ToolbarEventArgs containing data related to this event. The following ToolbarEventArgs properties provide information specific to this event.

Property | Description
Tool | Gets the selected tool.
User1 | Gets the numerical value associated with the Tool.
User2 | Gets the numerical value associated with the Tool.
See Also

Reference

ImageXView Class
ImageXView Members


ToolbarOpenEvent Event

ToolbarOpenEvent Event

Accusoft.ImagXpressSdk Namespace > ImageXView Class : ToolbarOpenEvent Event
Thrown when a toolbar open event occurs.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event ToolbarOpenEvent As ImageXView.ToolbarOpenEventHandler
'Usage

Dim instance As ImageXView
Dim handler As ImageXView.ToolbarOpenEventHandler

AddHandler instance.ToolbarOpenEvent, handler
public event ImageXView.ToolbarOpenEventHandler ToolbarOpenEvent
public: __event ImageXView.ToolbarOpenEventHandler* ToolbarOpenEvent
public:
event ImageXView.ToolbarOpenEventHandler^ ToolbarOpenEvent
Event Data

The event handler receives an argument of type ToolbarOpenEventArgs containing data related to this event. The following ToolbarOpenEventArgs properties provide information specific to this event.

Property | Description
Handle | Gets the handle of the toolbar.
See Also

Reference

ImageXView Class
ImageXView Members


ToolEvent Event

ToolEvent Event

Accusoft.ImagXpressSdk Namespace > ImageXView Class : ToolEvent Event
Thrown when a tool event occurs.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event ToolEvent As ImageXView.ToolEventHandler
'Usage

Dim instance As ImageXView
Dim handler As ImageXView.ToolEventHandler

AddHandler instance.ToolEvent, handler
public event ImageXView.ToolEventHandler ToolEvent
public: __event ImageXView.ToolEventHandler* ToolEvent
public:
event ImageXView.ToolEventHandler^ ToolEvent
Event Data

The event handler receives an argument of type ToolEventArgs containing data related to this event. The following ToolEventArgs properties provide information specific to this event.

Property | Description
Action | Gets the value of the action the tool performed.
Location | Gets the location at which the tool action was performed.
Tool | Gets the tool being used.
See Also

Reference

ImageXView Class
ImageXView Members


TwoFingerTap Event

TwoFingerTap Event

Accusoft.ImagXpressSdk Namespace > ImageXView Class : TwoFingerTap Event
Thrown when the user performs a two finger tap on the Touch interface.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event TwoFingerTap As ImageXView.TwoFingerTapEventHandler
'Usage

Dim instance As ImageXView
Dim handler As ImageXView.TwoFingerTapEventHandler

AddHandler instance.TwoFingerTap, handler
public event ImageXView.TwoFingerTapEventHandler TwoFingerTap
public: __event ImageXView.TwoFingerTapEventHandler* TwoFingerTap
public:
event ImageXView.TwoFingerTapEventHandler^ TwoFingerTap
Event Data

The event handler receives an argument of type TwoFingerTapEventArgs containing data related to this event. The following TwoFingerTapEventArgs properties provide information specific to this event.

Property | Description
FirstFingerLocation | Gets the location of the first finger during a two finger tap with the touch interface.
SecondFingerLocation | Gets the location of the second finger during a two finger tap with the touch interface.
See Also

Reference

ImageXView Class
ImageXView Members


ZoomFactorChanged Event

ZoomFactorChanged Event

Accusoft.ImagXpressSdk Namespace > ImageXView Class : ZoomFactorChanged Event
Thrown when the ZoomFactor property changes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event ZoomFactorChanged As ImageXView.ZoomFactorChangedEventHandler
'Usage

Dim instance As ImageXView
Dim handler As ImageXView.ZoomFactorChangedEventHandler

AddHandler instance.ZoomFactorChanged, handler
public event ImageXView.ZoomFactorChangedEventHandler ZoomFactorChanged
public: __event ImageXView.ZoomFactorChangedEventHandler* ZoomFactorChanged
public:
event ImageXView.ZoomFactorChangedEventHandler^ ZoomFactorChanged
Event Data

The event handler receives an argument of type ZoomFactorChangedEventArgs containing data related to this event. The following ZoomFactorChangedEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets the new value for the ZoomFactor property.
OldValue | Gets the old value for the ZoomFactor property.
See Also

Reference

ImageXView Class
ImageXView Members


ZoomGestureOccurred Event

ZoomGestureOccurred Event

Accusoft.ImagXpressSdk Namespace > ImageXView Class : ZoomGestureOccurred Event
Thrown when the user has finished zooming with the Touch interface.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event ZoomGestureOccurred As ImageXView.ZoomGestureOccurredEventHandler
'Usage

Dim instance As ImageXView
Dim handler As ImageXView.ZoomGestureOccurredEventHandler

AddHandler instance.ZoomGestureOccurred, handler
public event ImageXView.ZoomGestureOccurredEventHandler ZoomGestureOccurred
public: __event ImageXView.ZoomGestureOccurredEventHandler* ZoomGestureOccurred
public:
event ImageXView.ZoomGestureOccurredEventHandler^ ZoomGestureOccurred
Event Data

The event handler receives an argument of type ZoomGestureOccurredEventArgs containing data related to this event. The following ZoomGestureOccurredEventArgs properties provide information specific to this event.

Property | Description
TotalZoomCoefficient | Gets the total zoom coefficient since the beginning of the zoom gesture with the touch interface.
ZoomCenterPoint | Gets the center of the fingers during zooming with the touch interface.
See Also

Reference

ImageXView Class
ImageXView Members


ZoomGestureOccurring Event

ZoomGestureOccurring Event

Accusoft.ImagXpressSdk Namespace > ImageXView Class : ZoomGestureOccurring Event
Thrown when the user is in the process of zooming with the Touch interface.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event ZoomGestureOccurring As ImageXView.ZoomGestureOccurringEventHandler
'Usage

Dim instance As ImageXView
Dim handler As ImageXView.ZoomGestureOccurringEventHandler

AddHandler instance.ZoomGestureOccurring, handler
public event ImageXView.ZoomGestureOccurringEventHandler ZoomGestureOccurring
public: __event ImageXView.ZoomGestureOccurringEventHandler* ZoomGestureOccurring
public:
event ImageXView.ZoomGestureOccurringEventHandler^ ZoomGestureOccurring
Event Data

The event handler receives an argument of type ZoomGestureOccurringEventArgs containing data related to this event. The following ZoomGestureOccurringEventArgs properties provide information specific to this event.

Property | Description
ZoomCenterPoint | Gets the center of the fingers during zooming with the touch interface.
ZoomCoefficientSinceLastEventFiring | Gets the zoom coefficient since the last ZoomGestureOccurring event firing during zooming with the touch interface.
See Also

Reference

ImageXView Class
ImageXView Members


ImageXViewException Class

ImageXViewException Class
Members

Accusoft.ImagXpressSdk Namespace : ImageXViewException Class
This class implements exceptions for the ImageXView objects.
Object Model
ImageXViewException Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class ImageXViewException
   Inherits ImagXpressException
'Usage

Dim instance As ImageXViewException
[Serializable()]
public sealed class ImageXViewException : ImagXpressException
[Serializable()]
public __gc __sealed class ImageXViewException : public ImagXpressException
[Serializable()]
public ref class ImageXViewException sealed : public ImagXpressException
Inheritance Hierarchy

System.Object
System.Exception
Accusoft.ImagXpressSdk.ImagXpressException
Accusoft.ImagXpressSdk.ImageXViewException

See Also

Reference

ImageXViewException Members
Accusoft.ImagXpressSdk Namespace


ImageXViewException Class Members

ImageXViewException Class Members
Properties Methods

Accusoft.ImagXpressSdk Namespace : ImageXViewException Class

The following tables list the members exposed by ImageXViewException.

Public Constructors
 | Name | Description
Public Constructor | ImageXViewException Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Number | Gets the numerical equivalent for enumerated exception result. (Inherited from Accusoft.ImagXpressSdk.ImagXpressException)
Public Property | Result | Gets the enumerated exception result that has occurred. (Inherited from Accusoft.ImagXpressSdk.ImagXpressException)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

ImageXViewException Class
Accusoft.ImagXpressSdk Namespace


ImageXViewException Class Properties

ImageXViewException Class Properties

Accusoft.ImagXpressSdk Namespace : ImageXViewException Class

For a list of all members of this type, see ImageXViewException members.

Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Number | Gets the numerical equivalent for enumerated exception result. (Inherited from Accusoft.ImagXpressSdk.ImagXpressException)
Public Property | Result | Gets the enumerated exception result that has occurred. (Inherited from Accusoft.ImagXpressSdk.ImagXpressException)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
See Also

Reference

ImageXViewException Class
Accusoft.ImagXpressSdk Namespace


ImageXViewException Class Methods

ImageXViewException Class Methods

Accusoft.ImagXpressSdk Namespace : ImageXViewException Class

For a list of all members of this type, see ImageXViewException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

ImageXViewException Class
Accusoft.ImagXpressSdk Namespace


ImageXViewException Constructor

ImageXViewException Constructor

Accusoft.ImagXpressSdk Namespace > ImageXViewException Class : ImageXViewException Constructor
Overload List
Overload | Description
ImageXViewException Constructor() | The main constructor for ImageXView exceptions.
ImageXViewException Constructor(Result) | Constructor which allows passing in a result for the exception.
ImageXViewException Constructor(String) | Constructor which allows passing in a message for the exception.
ImageXViewException Constructor(Result,String) | Constructor which allows passing in a result and message.
ImageXViewException Constructor(String,Exception) | Constructor which allows passing in a message and inner exception.
ImageXViewException Constructor(Result,String,Exception) | Constructor which allows passing in a result, message and inner exception.
See Also

Reference

ImageXViewException Class
ImageXViewException Members


ImageXViewException Constructor()

ImageXViewException Constructor()

Accusoft.ImagXpressSdk Namespace > ImageXViewException Class > ImageXViewException Constructor : ImageXViewException Constructor()
The main constructor for ImageXView exceptions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImageXViewException()
public ImageXViewException()
public: ImageXViewException();
public:
ImageXViewException();
See Also

Reference

ImageXViewException Class
ImageXViewException Members
Overload List


ImageXViewException Constructor(Result)

ImageXViewException Constructor(Result)

Accusoft.ImagXpressSdk Namespace > ImageXViewException Class > ImageXViewException Constructor : ImageXViewException Constructor(Result)
A Result enumeration value.
Constructor which allows passing in a result for the exception.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal result As Result _
)
'Usage

Dim result As Result

Dim instance As New ImageXViewException(result)
public ImageXViewException(
   Result result
)
public: ImageXViewException(
   Result result
)
public:
ImageXViewException(
   Result result
)

Parameters

result
A Result enumeration value.
See Also

Reference

ImageXViewException Class
ImageXViewException Members
Overload List


ImageXViewException Constructor(String)

ImageXViewException Constructor(String)

Accusoft.ImagXpressSdk Namespace > ImageXViewException Class > ImageXViewException Constructor : ImageXViewException Constructor(String)
A string value which represents the error message.
Constructor which allows passing in a message for the exception.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New ImageXViewException(message)
public ImageXViewException(
   string message
)
public: ImageXViewException(
   string* message
)
public:
ImageXViewException(
   String^ message
)

Parameters

message
A string value which represents the error message.
See Also

Reference

ImageXViewException Class
ImageXViewException Members
Overload List


ImageXViewException Constructor(Result,String)

ImageXViewException Constructor(Result,String)

Accusoft.ImagXpressSdk Namespace > ImageXViewException Class > ImageXViewException Constructor : ImageXViewException Constructor(Result,String)
A Result enumeration value.
A string value which represents the error message.
Constructor which allows passing in a result and message.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal result As Result, _
   ByVal message As String _
)
'Usage

Dim result As Result
Dim message As String

Dim instance As New ImageXViewException(result, message)
public ImageXViewException(
   Result result,
   string message
)
public: ImageXViewException(
   Result result,
   string* message
)
public:
ImageXViewException(
   Result result,
   String^ message
)

Parameters

result
A Result enumeration value.
message
A string value which represents the error message.
See Also

Reference

ImageXViewException Class
ImageXViewException Members
Overload List


ImageXViewException Constructor(String,Exception)

ImageXViewException Constructor(String,Exception)

Accusoft.ImagXpressSdk Namespace > ImageXViewException Class > ImageXViewException Constructor : ImageXViewException Constructor(String,Exception)
A string value which represents the error message.
A System.Exception value.
Constructor which allows passing in a message and inner exception.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New ImageXViewException(message, innerException)
public ImageXViewException(
   string message,
   Exception innerException
)
public: ImageXViewException(
   string* message,
   Exception* innerException
)
public:
ImageXViewException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string value which represents the error message.
innerException
A System.Exception value.
See Also

Reference

ImageXViewException Class
ImageXViewException Members
Overload List


ImageXViewException Constructor(Result,String,Exception)

ImageXViewException Constructor(Result,String,Exception)

Accusoft.ImagXpressSdk Namespace > ImageXViewException Class > ImageXViewException Constructor : ImageXViewException Constructor(Result,String,Exception)
A Result enumeration value.
A string value which represents the error message.
An System.Exception.
Constructor which allows passing in a result, message and inner exception.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal result As Result, _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim result As Result
Dim message As String
Dim innerException As Exception

Dim instance As New ImageXViewException(result, message, innerException)
public ImageXViewException(
   Result result,
   string message,
   Exception innerException
)
public: ImageXViewException(
   Result result,
   string* message,
   Exception* innerException
)
public:
ImageXViewException(
   Result result,
   String^ message,
   Exception^ innerException
)

Parameters

result
A Result enumeration value.
message
A string value which represents the error message.
innerException
An System.Exception.
See Also

Reference

ImageXViewException Class
ImageXViewException Members
Overload List


ImagXpress Class

ImagXpress Class
Members

Accusoft.ImagXpressSdk Namespace : ImagXpress Class
Implements methods and properties for the ImagXpress component. This is a workspace component to the other controls, components and classes for handling such items as licensing, debug logging, and and progress and status events for the ImageX objects.
Object Model
ImagXpress ClassLicensing Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ComVisibleAttribute(True)>
<ToolboxBitmapAttribute()>
Public Class ImagXpress
   Inherits System.ComponentModel.Component
'Usage

Dim instance As ImagXpress
[ComVisible(true)]
[ToolboxBitmap()]
public class ImagXpress : System.ComponentModel.Component
[ComVisible(true)]
[ToolboxBitmap()]
public __gc class ImagXpress : public System.ComponentModel.Component
[ComVisible(true)]
[ToolboxBitmap()]
public ref class ImagXpress : public System.ComponentModel.Component
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Accusoft.ImagXpressSdk.ImagXpress

See Also

Reference

ImagXpress Members
Accusoft.ImagXpressSdk Namespace


ImagXpress Class Members

ImagXpress Class Members
Properties Methods Events

Accusoft.ImagXpressSdk Namespace : ImagXpress Class

The following tables list the members exposed by ImagXpress.

Public Constructors
 | Name | Description
Public Constructor | ImagXpress Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Debug | Gets and sets a flag to indicate if debug information is sent to a debug file.
Public Property | DebugErrorLevel | The error level of items to be written to the debug log file.
Public Property | DebugLogFile | The filename and path of the debug log file.
Public Property | Licensing | Gets the licensing information for the ImagXpress component.
Public Property | ProgressPercent | Gets or sets the progress percent.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Version | Returns the version of the ImagXpress control at run-time.
Top
Public Methods
 | Name | Description
Public Method | AboutBox | Displays a dialog box containing ImagXpress version and copyright information.
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose() | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top
Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | ImageStatusEvent | Thrown when the event handler receives data from ImageStatusEventArgs.
Public Event | ProgressEvent | Fires during progress events.
Top
See Also

Reference

ImagXpress Class
Accusoft.ImagXpressSdk Namespace


ImagXpress Constructor

ImagXpress Constructor

Accusoft.ImagXpressSdk Namespace > ImagXpress Class : ImagXpress Constructor
Overload List
Overload | Description
ImagXpress Constructor() | Initializes a new instance of the ImagXpress class.
ImagXpress Constructor(IContainer) | Initializes a new instance of the ImagXpress class.
See Also

Reference

ImagXpress Class
ImagXpress Members


ImagXpress Constructor()

ImagXpress Constructor()

Accusoft.ImagXpressSdk Namespace > ImagXpress Class > ImagXpress Constructor : ImagXpress Constructor()
Initializes a new instance of the ImagXpress class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImagXpress()
public ImagXpress()
public: ImagXpress();
public:
ImagXpress();
See Also

Reference

ImagXpress Class
ImagXpress Members
Overload List


ImagXpress Constructor(IContainer)

ImagXpress Constructor(IContainer)

Accusoft.ImagXpressSdk Namespace > ImagXpress Class > ImagXpress Constructor : ImagXpress Constructor(IContainer)
The container that implements the System.ComponentModel.IContainer interface which will contain this component.
Initializes a new instance of the ImagXpress class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal container As IContainer _
)
'Usage

Dim container As IContainer

Dim instance As New ImagXpress(container)
public ImagXpress(
   IContainer container
)
public: ImagXpress(
   IContainer* container
)
public:
ImagXpress(
   IContainer^ container
)

Parameters

container
The container that implements the System.ComponentModel.IContainer interface which will contain this component.
See Also

Reference

ImagXpress Class
ImagXpress Members
Overload List


ImagXpress Class Methods

ImagXpress Class Methods

Accusoft.ImagXpressSdk Namespace : ImagXpress Class

For a list of all members of this type, see ImagXpress members.

Public Methods
 | Name | Description
Public Method | AboutBox | Displays a dialog box containing ImagXpress version and copyright information.
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose() | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

ImagXpress Class
Accusoft.ImagXpressSdk Namespace


AboutBox Method

AboutBox Method

Accusoft.ImagXpressSdk Namespace > ImagXpress Class : AboutBox Method
Displays a dialog box containing ImagXpress version and copyright information.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub AboutBox()
'Usage

Dim instance As ImagXpress

instance.AboutBox()
public void AboutBox()
public: void AboutBox();
public:
void AboutBox();
See Also

Reference

ImagXpress Class
ImagXpress Members


Dispose Method (ImagXpress)

Dispose Method (ImagXpress)

Accusoft.ImagXpressSdk Namespace > ImagXpress Class : Dispose Method
Releases the unmanaged resources used by the System.ComponentModel.Component and optionally releases the managed resources.
Overload List
Overload | Description
Dispose() | (Inherited from System.ComponentModel.Component)
See Also

Reference

ImagXpress Class
ImagXpress Members


ImagXpress Class Properties

ImagXpress Class Properties

Accusoft.ImagXpressSdk Namespace : ImagXpress Class

For a list of all members of this type, see ImagXpress members.

Public Properties
 | Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Debug | Gets and sets a flag to indicate if debug information is sent to a debug file.
Public Property | DebugErrorLevel | The error level of items to be written to the debug log file.
Public Property | DebugLogFile | The filename and path of the debug log file.
Public Property | Licensing | Gets the licensing information for the ImagXpress component.
Public Property | ProgressPercent | Gets or sets the progress percent.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Version | Returns the version of the ImagXpress control at run-time.
Top
See Also

Reference

ImagXpress Class
Accusoft.ImagXpressSdk Namespace


Debug Property

Debug Property

Accusoft.ImagXpressSdk Namespace > ImagXpress Class : Debug Property
Gets and sets a flag to indicate if debug information is sent to a debug file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
Public Property Debug As Boolean
'Usage

Dim instance As ImagXpress
Dim value As Boolean

instance.Debug = value

value = instance.Debug
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Browsable(false)]
public bool Debug {get; set;}
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Browsable(false)]
public: __property bool get_Debug();
public: __property void set_Debug(
   bool value
);
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Browsable(false)]
public:
property bool Debug {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true to log data into the DebugLogFile. Otherwise, false is returned.
Remarks

The default value is false.

This property allows you to turn the debug log file on or off without changing any of the other debug settings. When this is true, the toolkit will write items to the debug log file, as specified by the DebugLogFile and DebugErrorLevel properties.

See Also

Reference

ImagXpress Class
ImagXpress Members
DebugLogFile Property


DebugErrorLevel Property

DebugErrorLevel Property

Accusoft.ImagXpressSdk Namespace > ImagXpress Class : DebugErrorLevel Property
The error level of items to be written to the debug log file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property DebugErrorLevel As DebugErrorLevel
'Usage

Dim instance As ImagXpress
Dim value As DebugErrorLevel

instance.DebugErrorLevel = value

value = instance.DebugErrorLevel
[Browsable(false)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
public DebugErrorLevel DebugErrorLevel {get; set;}
[Browsable(false)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
public: __property DebugErrorLevel get_DebugErrorLevel();
public: __property void set_DebugErrorLevel(
   DebugErrorLevel value
);
[Browsable(false)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
public:
property DebugErrorLevel DebugErrorLevel {
   DebugErrorLevel get();
   void set (    DebugErrorLevel value);
}
Remarks

The default value is Production.

Valid values are from the DebugErrorLevel enumeration which include Production, Development and Detailed..

This property allows you to control the amount of information that witten into the DebugLogFile.

Note: Since it takes some amount of time to generate and write debug log items, you should set this to write the least amount of information that you will find useful.

Note: This property will have no effect if you set the Debug property to false.

See Also

Reference

ImagXpress Class
ImagXpress Members
Debug Property


DebugLogFile Property

DebugLogFile Property

Accusoft.ImagXpressSdk Namespace > ImagXpress Class : DebugLogFile Property
The filename and path of the debug log file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
Public Property DebugLogFile As String
'Usage

Dim instance As ImagXpress
Dim value As String

instance.DebugLogFile = value

value = instance.DebugLogFile
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Browsable(false)]
public string DebugLogFile {get; set;}
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Browsable(false)]
public: __property string* get_DebugLogFile();
public: __property void set_DebugLogFile(
   string* value
);
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Browsable(false)]
public:
property String^ DebugLogFile {
   String^ get();
   void set (    String^ value);
}
Remarks

This property allows you to control the location of the debug log file.

The default value is "[Temp Files]\ImagXpress13.log".

Valid values are any valid filename.

The default value for this property is suitable for interactive use. If you are using the component in a service or other type of system that runs in the background, you should set the filename to a more suitable value.

Note: This property will have no effect if you set the Debug property to false.

See Also

Reference

ImagXpress Class
ImagXpress Members
Debug Property


Licensing Property

Licensing Property

Accusoft.ImagXpressSdk Namespace > ImagXpress Class : Licensing Property
Gets the licensing information for the ImagXpress component.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public ReadOnly Property Licensing As Licensing
'Usage

Dim instance As ImagXpress
Dim value As Licensing

value = instance.Licensing
[Browsable(false)]
public Licensing Licensing {get;}
[Browsable(false)]
public: __property Licensing* get_Licensing();
[Browsable(false)]
public:
property Licensing^ Licensing {
   Licensing^ get();
}

Property Value

The Licensing information.
See Also

Reference

ImagXpress Class
ImagXpress Members


ProgressPercent Property (ImagXpress)

ProgressPercent Property (ImagXpress)

Accusoft.ImagXpressSdk Namespace > ImagXpress Class : ProgressPercent Property
Gets or sets the progress percent.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("Gets or sets how often the progress event will fire.")>
<BrowsableAttribute(True)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)>
<DefaultValueAttribute()>
Public Property ProgressPercent As Integer
'Usage

Dim instance As ImagXpress
Dim value As Integer

instance.ProgressPercent = value

value = instance.ProgressPercent
[Description("Gets or sets how often the progress event will fire.")]
[Browsable(true)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
[DefaultValue()]
public int ProgressPercent {get; set;}
[Description("Gets or sets how often the progress event will fire.")]
[Browsable(true)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
[DefaultValue()]
public: __property int get_ProgressPercent();
public: __property void set_ProgressPercent(
   int value
);
[Description("Gets or sets how often the progress event will fire.")]
[Browsable(true)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
[DefaultValue()]
public:
property int ProgressPercent {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the progress percent.
Remarks

The default value is 10.

See Also

Reference

ImagXpress Class
ImagXpress Members


Version Property

Version Property

Accusoft.ImagXpressSdk Namespace > ImagXpress Class : Version Property
Returns the version of the ImagXpress control at run-time.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public ReadOnly Property Version As String
'Usage

Dim instance As ImagXpress
Dim value As String

value = instance.Version
[Browsable(false)]
public string Version {get;}
[Browsable(false)]
public: __property string* get_Version();
[Browsable(false)]
public:
property String^ Version {
   String^ get();
}
See Also

Reference

ImagXpress Class
ImagXpress Members


ImagXpress Class Events

ImagXpress Class Events

Accusoft.ImagXpressSdk Namespace : ImagXpress Class

For a list of all members of this type, see ImagXpress members.

Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | ImageStatusEvent | Thrown when the event handler receives data from ImageStatusEventArgs.
Public Event | ProgressEvent | Fires during progress events.
Top
See Also

Reference

ImagXpress Class
Accusoft.ImagXpressSdk Namespace


ImageStatusEvent Event

ImageStatusEvent Event

Accusoft.ImagXpressSdk Namespace > ImagXpress Class : ImageStatusEvent Event
Thrown when the event handler receives data from ImageStatusEventArgs.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event ImageStatusEvent As ImagXpress.ImageStatusEventHandler
'Usage

Dim instance As ImagXpress
Dim handler As ImagXpress.ImageStatusEventHandler

AddHandler instance.ImageStatusEvent, handler
public event ImagXpress.ImageStatusEventHandler ImageStatusEvent
public: __event ImagXpress.ImageStatusEventHandler* ImageStatusEvent
public:
event ImagXpress.ImageStatusEventHandler^ ImageStatusEvent
Event Data

The event handler receives an argument of type ImageStatusEventArgs containing data related to this event. The following ImageStatusEventArgs properties provide information specific to this event.

Property | Description
Image | Gets the image for the event.
Operation | Gets the current image operation.
Status | Gets the status of the current image.
Remarks

This event replaces the static ImageStatusEvent that was in the ImageX class.

See Also

Reference

ImagXpress Class
ImagXpress Members


ProgressEvent Event (ImagXpress)

ProgressEvent Event (ImagXpress)

Accusoft.ImagXpressSdk Namespace > ImagXpress Class : ProgressEvent Event
Fires during progress events.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event ProgressEvent As ImagXpress.ProgressEventHandler
'Usage

Dim instance As ImagXpress
Dim handler As ImagXpress.ProgressEventHandler

AddHandler instance.ProgressEvent, handler
public event ImagXpress.ProgressEventHandler ProgressEvent
public: __event ImagXpress.ProgressEventHandler* ProgressEvent
public:
event ImagXpress.ProgressEventHandler^ ProgressEvent
Event Data

The event handler receives an argument of type ProgressEventArgs containing data related to this event. The following ProgressEventArgs properties provide information specific to this event.

Property | Description
BytesProcessed | Gets the count of bytes processed.
Image | Gets the image for the event.
IsAsync | Gets an indicator whether subsequent image loading, processing or saving operations occur in a separate thread from the viewer control thread.
IsComplete | Gets an indicator whether the image processing is complete.
Operation | Gets the operation method being performed.
PercentDone | Gets the percentage complete value of the current image operation.
Result | Gets the result of the progress event.
TotalBytes | Gets the total bytes processed.
Remarks

This event replaces the static ProgressEvent that was in the ImageX class.

See Also

Reference

ImagXpress Class
ImagXpress Members


ImagXpressDefaultContextMenu Class

ImagXpressDefaultContextMenu Class
Members

Accusoft.ImagXpressSdk Namespace : ImagXpressDefaultContextMenu Class
This class implements methods and properties for the ImageXView default context menu.
Object Model
ImagXpressDefaultContextMenu Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DesignTimeVisibleAttribute()>
<ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")>
Public Class ImagXpressDefaultContextMenu
   Inherits System.Windows.Forms.ContextMenu
'Usage

Dim instance As ImagXpressDefaultContextMenu
[DesignTimeVisible()]
[ToolboxItem(ToolboxItemType=, ToolboxItemTypeName="")]
public class ImagXpressDefaultContextMenu : System.Windows.Forms.ContextMenu
[DesignTimeVisible()]
[ToolboxItem(ToolboxItemType=, ToolboxItemTypeName="")]
public __gc class ImagXpressDefaultContextMenu : public System.Windows.Forms.ContextMenu
[DesignTimeVisible()]
[ToolboxItem(ToolboxItemType=, ToolboxItemTypeName="")]
public ref class ImagXpressDefaultContextMenu : public System.Windows.Forms.ContextMenu
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Menu
System.Windows.Forms.ContextMenu
Accusoft.ImagXpressSdk.ImagXpressDefaultContextMenu

See Also

Reference

ImagXpressDefaultContextMenu Members
Accusoft.ImagXpressSdk Namespace


ImagXpressDefaultContextMenu Class Members

ImagXpressDefaultContextMenu Class Members
Properties Methods Events

Accusoft.ImagXpressSdk Namespace : ImagXpressDefaultContextMenu Class

The following tables list the members exposed by ImagXpressDefaultContextMenu.

Public Constructors
 | Name | Description
Public Constructor | ImagXpressDefaultContextMenu Constructor | Initializes a new instance of the ImagXpressDefaultContextMenu class.
Top
Public Properties
 | Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Handle | (Inherited from System.Windows.Forms.Menu)
Public Property | IsParent | (Inherited from System.Windows.Forms.Menu)
Public Property | MdiListItem | (Inherited from System.Windows.Forms.Menu)
Public Property | MenuItems | (Inherited from System.Windows.Forms.Menu)
Public Property | Name | (Inherited from System.Windows.Forms.Menu)
Public Property | RightToLeft | (Inherited from System.Windows.Forms.ContextMenu)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | SourceControl | (Inherited from System.Windows.Forms.ContextMenu)
Public Property | Tag | (Inherited from System.Windows.Forms.Menu)
Top
Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose() | (Inherited from System.ComponentModel.Component)
Public Method | FindMenuItem | (Inherited from System.Windows.Forms.Menu)
Public Method | GetContextMenu | (Inherited from System.Windows.Forms.Menu)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetMainMenu | (Inherited from System.Windows.Forms.Menu)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | MergeMenu | (Inherited from System.Windows.Forms.Menu)
Public Method | Show | Overloaded. (Inherited from System.Windows.Forms.ContextMenu)
Public Method | ToString | (Inherited from System.Windows.Forms.Menu)
Top
Public Events
 | Name | Description
Public Event | Collapse | (Inherited from System.Windows.Forms.ContextMenu)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | Popup | (Inherited from System.Windows.Forms.ContextMenu)
Top
See Also

Reference

ImagXpressDefaultContextMenu Class
Accusoft.ImagXpressSdk Namespace


ImagXpressDefaultContextMenu Class Properties

ImagXpressDefaultContextMenu Class Properties

Accusoft.ImagXpressSdk Namespace : ImagXpressDefaultContextMenu Class

For a list of all members of this type, see ImagXpressDefaultContextMenu members.

Public Properties
 | Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Handle | (Inherited from System.Windows.Forms.Menu)
Public Property | IsParent | (Inherited from System.Windows.Forms.Menu)
Public Property | MdiListItem | (Inherited from System.Windows.Forms.Menu)
Public Property | MenuItems | (Inherited from System.Windows.Forms.Menu)
Public Property | Name | (Inherited from System.Windows.Forms.Menu)
Public Property | RightToLeft | (Inherited from System.Windows.Forms.ContextMenu)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | SourceControl | (Inherited from System.Windows.Forms.ContextMenu)
Public Property | Tag | (Inherited from System.Windows.Forms.Menu)
Top
See Also

Reference

ImagXpressDefaultContextMenu Class
Accusoft.ImagXpressSdk Namespace


ImagXpressDefaultContextMenu Class Methods

ImagXpressDefaultContextMenu Class Methods

Accusoft.ImagXpressSdk Namespace : ImagXpressDefaultContextMenu Class

For a list of all members of this type, see ImagXpressDefaultContextMenu members.

Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose() | (Inherited from System.ComponentModel.Component)
Public Method | FindMenuItem | (Inherited from System.Windows.Forms.Menu)
Public Method | GetContextMenu | (Inherited from System.Windows.Forms.Menu)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetMainMenu | (Inherited from System.Windows.Forms.Menu)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | MergeMenu | (Inherited from System.Windows.Forms.Menu)
Public Method | Show | Overloaded. (Inherited from System.Windows.Forms.ContextMenu)
Public Method | ToString | (Inherited from System.Windows.Forms.Menu)
Top
See Also

Reference

ImagXpressDefaultContextMenu Class
Accusoft.ImagXpressSdk Namespace


ImagXpressDefaultContextMenu Class Events

ImagXpressDefaultContextMenu Class Events

Accusoft.ImagXpressSdk Namespace : ImagXpressDefaultContextMenu Class

For a list of all members of this type, see ImagXpressDefaultContextMenu members.

Public Events
 | Name | Description
Public Event | Collapse | (Inherited from System.Windows.Forms.ContextMenu)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | Popup | (Inherited from System.Windows.Forms.ContextMenu)
Top
See Also

Reference

ImagXpressDefaultContextMenu Class
Accusoft.ImagXpressSdk Namespace


ImagXpressDefaultContextMenu Constructor

ImagXpressDefaultContextMenu Constructor

Accusoft.ImagXpressSdk Namespace > ImagXpressDefaultContextMenu Class : ImagXpressDefaultContextMenu Constructor
Initializes a new instance of the ImagXpressDefaultContextMenu class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImagXpressDefaultContextMenu()
public ImagXpressDefaultContextMenu()
public: ImagXpressDefaultContextMenu();
public:
ImagXpressDefaultContextMenu();
See Also

Reference

ImagXpressDefaultContextMenu Class
ImagXpressDefaultContextMenu Members


Dispose Method (ImagXpressDefaultContextMenu)

Dispose Method (ImagXpressDefaultContextMenu)

Accusoft.ImagXpressSdk Namespace > ImagXpressDefaultContextMenu Class : Dispose Method
Clean up any resources being used.
Overload List
Overload | Description
Dispose() | (Inherited from System.ComponentModel.Component)
See Also

Reference

ImagXpressDefaultContextMenu Class
ImagXpressDefaultContextMenu Members


ImagXpressException Class

ImagXpressException Class
Members

Accusoft.ImagXpressSdk Namespace : ImagXpressException Class
This class implements handling errors and exceptions for ImagXpress objects.
Object Model
ImagXpressException Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ImagXpressException
   Inherits System.Exception
'Usage

Dim instance As ImagXpressException
public class ImagXpressException : System.Exception
public __gc class ImagXpressException : public System.Exception
public ref class ImagXpressException : public System.Exception
Inheritance Hierarchy

System.Object
System.Exception
Accusoft.ImagXpressSdk.ImagXpressException
Accusoft.ImagXpressSdk.IcmException
Accusoft.ImagXpressSdk.ImageXException
Accusoft.ImagXpressSdk.ImageXViewException
Accusoft.ImagXpressSdk.InternetException
Accusoft.ImagXpressSdk.ProcessorException

See Also

Reference

ImagXpressException Members
Accusoft.ImagXpressSdk Namespace


ImagXpressException Class Members

ImagXpressException Class Members
Properties Methods

Accusoft.ImagXpressSdk Namespace : ImagXpressException Class

The following tables list the members exposed by ImagXpressException.

Public Constructors
 | Name | Description
Public Constructor | ImagXpressException Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Number | Gets the numerical equivalent for enumerated exception result.
Public Property | Result | Gets the enumerated exception result that has occurred.
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

ImagXpressException Class
Accusoft.ImagXpressSdk Namespace


ImagXpressException Constructor

ImagXpressException Constructor

Accusoft.ImagXpressSdk Namespace > ImagXpressException Class : ImagXpressException Constructor
Overload List
Overload | Description
ImagXpressException Constructor() | The main constructor which initializes a new instance of the ImagXpressException class.
ImagXpressException Constructor(Result) | Constructor which allows passing in a result for ImagXpress exceptions.
ImagXpressException Constructor(String) | Constructor which allows passing in a message for ImagXpress exceptions.
ImagXpressException Constructor(Result,String) | Constructor which allows passing in a result and a message for ImagXpress exceptions.
ImagXpressException Constructor(String,Exception) | Constructor which allows passing in a message and inner exception.
ImagXpressException Constructor(Result,String,Exception) | Constructor which allows passing in a result, message and inner exception.
See Also

Reference

ImagXpressException Class
ImagXpressException Members


ImagXpressException Constructor()

ImagXpressException Constructor()

Accusoft.ImagXpressSdk Namespace > ImagXpressException Class > ImagXpressException Constructor : ImagXpressException Constructor()
The main constructor which initializes a new instance of the ImagXpressException class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImagXpressException()
public ImagXpressException()
public: ImagXpressException();
public:
ImagXpressException();
See Also

Reference

ImagXpressException Class
ImagXpressException Members
Overload List


ImagXpressException Constructor(Result)

ImagXpressException Constructor(Result)

Accusoft.ImagXpressSdk Namespace > ImagXpressException Class > ImagXpressException Constructor : ImagXpressException Constructor(Result)
A Result enumeration value.
Constructor which allows passing in a result for ImagXpress exceptions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal result As Result _
)
'Usage

Dim result As Result

Dim instance As New ImagXpressException(result)
public ImagXpressException(
   Result result
)
public: ImagXpressException(
   Result result
)
public:
ImagXpressException(
   Result result
)

Parameters

result
A Result enumeration value.
See Also

Reference

ImagXpressException Class
ImagXpressException Members
Overload List


ImagXpressException Constructor(String)

ImagXpressException Constructor(String)

Accusoft.ImagXpressSdk Namespace > ImagXpressException Class > ImagXpressException Constructor : ImagXpressException Constructor(String)
A string value which represents the error message for the exception.
Constructor which allows passing in a message for ImagXpress exceptions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New ImagXpressException(message)
public ImagXpressException(
   string message
)
public: ImagXpressException(
   string* message
)
public:
ImagXpressException(
   String^ message
)

Parameters

message
A string value which represents the error message for the exception.
See Also

Reference

ImagXpressException Class
ImagXpressException Members
Overload List


ImagXpressException Constructor(Result,String)

ImagXpressException Constructor(Result,String)

Accusoft.ImagXpressSdk Namespace > ImagXpressException Class > ImagXpressException Constructor : ImagXpressException Constructor(Result,String)
An Result enumeration value.
A string which represents the error message for the exception.
Constructor which allows passing in a result and a message for ImagXpress exceptions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal result As Result, _
   ByVal message As String _
)
'Usage

Dim result As Result
Dim message As String

Dim instance As New ImagXpressException(result, message)
public ImagXpressException(
   Result result,
   string message
)
public: ImagXpressException(
   Result result,
   string* message
)
public:
ImagXpressException(
   Result result,
   String^ message
)

Parameters

result
An Result enumeration value.
message
A string which represents the error message for the exception.
See Also

Reference

ImagXpressException Class
ImagXpressException Members
Overload List


ImagXpressException Constructor(String,Exception)

ImagXpressException Constructor(String,Exception)

Accusoft.ImagXpressSdk Namespace > ImagXpressException Class > ImagXpressException Constructor : ImagXpressException Constructor(String,Exception)
A string value which represents the error message for the exception.
An System.Exception.
Constructor which allows passing in a message and inner exception.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New ImagXpressException(message, innerException)
public ImagXpressException(
   string message,
   Exception innerException
)
public: ImagXpressException(
   string* message,
   Exception* innerException
)
public:
ImagXpressException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string value which represents the error message for the exception.
innerException
An System.Exception.
See Also

Reference

ImagXpressException Class
ImagXpressException Members
Overload List


ImagXpressException Constructor(Result,String,Exception)

ImagXpressException Constructor(Result,String,Exception)

Accusoft.ImagXpressSdk Namespace > ImagXpressException Class > ImagXpressException Constructor : ImagXpressException Constructor(Result,String,Exception)
A Result enumeration value.
A string value which represents the error message.
An inner System.Exception.
Constructor which allows passing in a result, message and inner exception.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal result As Result, _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim result As Result
Dim message As String
Dim innerException As Exception

Dim instance As New ImagXpressException(result, message, innerException)
public ImagXpressException(
   Result result,
   string message,
   Exception innerException
)
public: ImagXpressException(
   Result result,
   string* message,
   Exception* innerException
)
public:
ImagXpressException(
   Result result,
   String^ message,
   Exception^ innerException
)

Parameters

result
A Result enumeration value.
message
A string value which represents the error message.
innerException
An inner System.Exception.
See Also

Reference

ImagXpressException Class
ImagXpressException Members
Overload List


ImagXpressException Class Properties

ImagXpressException Class Properties

Accusoft.ImagXpressSdk Namespace : ImagXpressException Class

For a list of all members of this type, see ImagXpressException members.

Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Number | Gets the numerical equivalent for enumerated exception result.
Public Property | Result | Gets the enumerated exception result that has occurred.
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
See Also

Reference

ImagXpressException Class
Accusoft.ImagXpressSdk Namespace


ImagXpressException Class Methods

ImagXpressException Class Methods

Accusoft.ImagXpressSdk Namespace : ImagXpressException Class

For a list of all members of this type, see ImagXpressException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

ImagXpressException Class
Accusoft.ImagXpressSdk Namespace


Number Property

Number Property

Accusoft.ImagXpressSdk Namespace > ImagXpressException Class : Number Property
Gets the numerical equivalent for enumerated exception result.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Number As Integer
'Usage

Dim instance As ImagXpressException
Dim value As Integer

value = instance.Number
public int Number {get;}
public: __property int get_Number();
public:
property int Number {
   int get();
}

Property Value

An integer value which represents the error number for the exception.
Remarks

To get the result of the exception, use the Result property.

See Also

Reference

ImagXpressException Class
ImagXpressException Members
Result Property


Result Property (ImagXpressException)

Result Property (ImagXpressException)

Accusoft.ImagXpressSdk Namespace > ImagXpressException Class : Result Property
Gets the enumerated exception result that has occurred.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Result As Result
'Usage

Dim instance As ImagXpressException
Dim value As Result

value = instance.Result
public Result Result {get;}
public: __property Result get_Result();
public:
property Result Result {
   Result get();
}

Property Value

A Result enumeration value for the exception.
Remarks

To get the error number for the exception, use the Number property.

See Also

Reference

ImagXpressException Class
ImagXpressException Members
Number Property


InternetException Class

InternetException Class
Members

Accusoft.ImagXpressSdk Namespace : InternetException Class
This class implements exceptions for the Internet objects.
Object Model
InternetException Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class InternetException
   Inherits ImagXpressException
'Usage

Dim instance As InternetException
[Serializable()]
public sealed class InternetException : ImagXpressException
[Serializable()]
public __gc __sealed class InternetException : public ImagXpressException
[Serializable()]
public ref class InternetException sealed : public ImagXpressException
Inheritance Hierarchy

System.Object
System.Exception
Accusoft.ImagXpressSdk.ImagXpressException
Accusoft.ImagXpressSdk.InternetException

See Also

Reference

InternetException Members
Accusoft.ImagXpressSdk Namespace


InternetException Class Members

InternetException Class Members
Properties Methods

Accusoft.ImagXpressSdk Namespace : InternetException Class

The following tables list the members exposed by InternetException.

Public Constructors
 | Name | Description
Public Constructor | InternetException Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Number | Gets the numerical equivalent for enumerated exception result. (Inherited from Accusoft.ImagXpressSdk.ImagXpressException)
Public Property | Result | Gets the enumerated exception result that has occurred. (Inherited from Accusoft.ImagXpressSdk.ImagXpressException)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

InternetException Class
Accusoft.ImagXpressSdk Namespace


InternetException Class Properties

InternetException Class Properties

Accusoft.ImagXpressSdk Namespace : InternetException Class

For a list of all members of this type, see InternetException members.

Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Number | Gets the numerical equivalent for enumerated exception result. (Inherited from Accusoft.ImagXpressSdk.ImagXpressException)
Public Property | Result | Gets the enumerated exception result that has occurred. (Inherited from Accusoft.ImagXpressSdk.ImagXpressException)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
See Also

Reference

InternetException Class
Accusoft.ImagXpressSdk Namespace


InternetException Class Methods

InternetException Class Methods

Accusoft.ImagXpressSdk Namespace : InternetException Class

For a list of all members of this type, see InternetException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

InternetException Class
Accusoft.ImagXpressSdk Namespace


InternetException Constructor

InternetException Constructor

Accusoft.ImagXpressSdk Namespace > InternetException Class : InternetException Constructor
Overload List
Overload | Description
InternetException Constructor() | The main constructor for the InternetException class.
InternetException Constructor(Result) | Constructor which allows passing in a result for the exception.
InternetException Constructor(String) | Constructor which allows passing in a message for the exception.
InternetException Constructor(Result,String) | Constructor which allows passing in a result and message for the exception.
InternetException Constructor(String,Exception) | Constructor which allows passing in a message and inner exception.
InternetException Constructor(Result,String,Exception) | Constructor which allows passing in a result, message and inner exception.
See Also

Reference

InternetException Class
InternetException Members


InternetException Constructor()

InternetException Constructor()

Accusoft.ImagXpressSdk Namespace > InternetException Class > InternetException Constructor : InternetException Constructor()
The main constructor for the InternetException class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New InternetException()
public InternetException()
public: InternetException();
public:
InternetException();
See Also

Reference

InternetException Class
InternetException Members
Overload List


InternetException Constructor(Result)

InternetException Constructor(Result)

Accusoft.ImagXpressSdk Namespace > InternetException Class > InternetException Constructor : InternetException Constructor(Result)
A Result enumeration value.
Constructor which allows passing in a result for the exception.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal result As Result _
)
'Usage

Dim result As Result

Dim instance As New InternetException(result)
public InternetException(
   Result result
)
public: InternetException(
   Result result
)
public:
InternetException(
   Result result
)

Parameters

result
A Result enumeration value.
See Also

Reference

InternetException Class
InternetException Members
Overload List
Result Enumeration


InternetException Constructor(String)

InternetException Constructor(String)

Accusoft.ImagXpressSdk Namespace > InternetException Class > InternetException Constructor : InternetException Constructor(String)
A string which represents the error message.
Constructor which allows passing in a message for the exception.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New InternetException(message)
public InternetException(
   string message
)
public: InternetException(
   string* message
)
public:
InternetException(
   String^ message
)

Parameters

message
A string which represents the error message.
See Also

Reference

InternetException Class
InternetException Members
Overload List


InternetException Constructor(Result,String)

InternetException Constructor(Result,String)

Accusoft.ImagXpressSdk Namespace > InternetException Class > InternetException Constructor : InternetException Constructor(Result,String)
A Result enumeration value.
A string which represents the error message.
Constructor which allows passing in a result and message for the exception.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal result As Result, _
   ByVal message As String _
)
'Usage

Dim result As Result
Dim message As String

Dim instance As New InternetException(result, message)
public InternetException(
   Result result,
   string message
)
public: InternetException(
   Result result,
   string* message
)
public:
InternetException(
   Result result,
   String^ message
)

Parameters

result
A Result enumeration value.
message
A string which represents the error message.
See Also

Reference

InternetException Class
InternetException Members
Overload List
Result Enumeration


InternetException Constructor(String,Exception)

InternetException Constructor(String,Exception)

Accusoft.ImagXpressSdk Namespace > InternetException Class > InternetException Constructor : InternetException Constructor(String,Exception)
A string which represents the error message.
An System.Exception value.
Constructor which allows passing in a message and inner exception.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New InternetException(message, innerException)
public InternetException(
   string message,
   Exception innerException
)
public: InternetException(
   string* message,
   Exception* innerException
)
public:
InternetException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the error message.
innerException
An System.Exception value.
See Also

Reference

InternetException Class
InternetException Members
Overload List


InternetException Constructor(Result,String,Exception)

InternetException Constructor(Result,String,Exception)

Accusoft.ImagXpressSdk Namespace > InternetException Class > InternetException Constructor : InternetException Constructor(Result,String,Exception)
A Result enumeration value.
A string which represents the error message.
An System.Exception value.
Constructor which allows passing in a result, message and inner exception.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal result As Result, _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim result As Result
Dim message As String
Dim innerException As Exception

Dim instance As New InternetException(result, message, innerException)
public InternetException(
   Result result,
   string message,
   Exception innerException
)
public: InternetException(
   Result result,
   string* message,
   Exception* innerException
)
public:
InternetException(
   Result result,
   String^ message,
   Exception^ innerException
)

Parameters

result
A Result enumeration value.
message
A string which represents the error message.
innerException
An System.Exception value.
See Also

Reference

InternetException Class
InternetException Members
Overload List


InternetOptions Class

InternetOptions Class
Members

Accusoft.ImagXpressSdk Namespace : InternetOptions Class
This class implements functionality for Internet options.
Object Model
InternetOptions Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class InternetOptions
'Usage

Dim instance As InternetOptions
public class InternetOptions
public __gc class InternetOptions
public ref class InternetOptions
Inheritance Hierarchy

System.Object
Accusoft.ImagXpressSdk.InternetOptions

See Also

Reference

InternetOptions Members
Accusoft.ImagXpressSdk Namespace


InternetOptions Class Members

InternetOptions Class Members
Properties

Accusoft.ImagXpressSdk Namespace : InternetOptions Class

The following tables list the members exposed by InternetOptions.

Public Constructors
 | Name | Description
Public Constructor | InternetOptions Constructor | The main constructor which intializes a new instance of the InternetOptions class.
Top
Public Properties
 | Name | Description
Public Property | FtpMode | Gets and sets the ftp mode value.
Public Property | NetworkCredentials | Gets and sets the credentials for the password based authentication.
Public Property | ProxySettings | Gets and sets the proxy server name or ID.
Top
See Also

Reference

InternetOptions Class
Accusoft.ImagXpressSdk Namespace


InternetOptions Constructor

InternetOptions Constructor

Accusoft.ImagXpressSdk Namespace > InternetOptions Class : InternetOptions Constructor
The main constructor which intializes a new instance of the InternetOptions class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New InternetOptions()
public InternetOptions()
public: InternetOptions();
public:
InternetOptions();
See Also

Reference

InternetOptions Class
InternetOptions Members


InternetOptions Class Properties

InternetOptions Class Properties

Accusoft.ImagXpressSdk Namespace : InternetOptions Class

For a list of all members of this type, see InternetOptions members.

Public Properties
 | Name | Description
Public Property | FtpMode | Gets and sets the ftp mode value.
Public Property | NetworkCredentials | Gets and sets the credentials for the password based authentication.
Public Property | ProxySettings | Gets and sets the proxy server name or ID.
Top
See Also

Reference

InternetOptions Class
Accusoft.ImagXpressSdk Namespace


FtpMode Property

FtpMode Property

Accusoft.ImagXpressSdk Namespace > InternetOptions Class : FtpMode Property
Gets and sets the ftp mode value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FtpMode As FtpMode
'Usage

Dim instance As InternetOptions
Dim value As FtpMode

instance.FtpMode = value

value = instance.FtpMode
public FtpMode FtpMode {get; set;}
public: __property FtpMode get_FtpMode();
public: __property void set_FtpMode(
   FtpMode value
);
public:
property FtpMode FtpMode {
   FtpMode get();
   void set (    FtpMode value);
}

Property Value

The FtpMode enumeration value set.
See Also

Reference

InternetOptions Class
InternetOptions Members


NetworkCredentials Property

NetworkCredentials Property

Accusoft.ImagXpressSdk Namespace > InternetOptions Class : NetworkCredentials Property
Gets and sets the credentials for the password based authentication.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property NetworkCredentials As NetworkCredential
'Usage

Dim instance As InternetOptions
Dim value As NetworkCredential

instance.NetworkCredentials = value

value = instance.NetworkCredentials
public NetworkCredential NetworkCredentials {get; set;}
public: __property NetworkCredential* get_NetworkCredentials();
public: __property void set_NetworkCredentials(
   NetworkCredential* value
);
public:
property NetworkCredential^ NetworkCredentials {
   NetworkCredential^ get();
   void set (    NetworkCredential^ value);
}

Property Value

The System.Net.NetworkCredential
See Also

Reference

InternetOptions Class
InternetOptions Members
System.Net.NetworkCredential


ProxySettings Property

ProxySettings Property

Accusoft.ImagXpressSdk Namespace > InternetOptions Class : ProxySettings Property
Gets and sets the proxy server name or ID.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ProxySettings As WebProxy
'Usage

Dim instance As InternetOptions
Dim value As WebProxy

instance.ProxySettings = value

value = instance.ProxySettings
public WebProxy ProxySettings {get; set;}
public: __property WebProxy* get_ProxySettings();
public: __property void set_ProxySettings(
   WebProxy* value
);
public:
property WebProxy^ ProxySettings {
   WebProxy^ get();
   void set (    WebProxy^ value);
}

Property Value

The System.Net.WebProxy set.
See Also

Reference

InternetOptions Class
InternetOptions Members
System.Net.WebProxy


Licensing Class

Licensing Class
Members

Accusoft.ImagXpressSdk Namespace : Licensing Class
The Licensing class determines the license edition and behavior, and unlock methods.
Object Model
Licensing Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class Licensing
'Usage

Dim instance As Licensing
public class Licensing
public __gc class Licensing
public ref class Licensing
Inheritance Hierarchy

System.Object
Accusoft.ImagXpressSdk.Licensing

See Also

Reference

Licensing Members
Accusoft.ImagXpressSdk Namespace


Licensing Class Members

Licensing Class Members
Properties Methods

Accusoft.ImagXpressSdk Namespace : Licensing Class

The following tables list the members exposed by Licensing.

Public Constructors
 | Name | Description
Public Constructor | Licensing Constructor | The initial constructor for the licensing class passing in a workspace ID.
Top
Public Properties
 | Name | Description
Public Property | EvaluationMode | Gets and sets a watermark or dialog box to be displayed periodically.
Public Property | LicenseStatus | Gets the current license status of the component.
Top
Public Methods
 | Name | Description
Public Method | SetOEMLicenseKey | Sets the ImagXpress control runtime OEM license key.
Public Method | SetSolutionKey | Sets the ImagXpress control runtime license deployment key.
Public Method | SetSolutionName | Sets the ImagXpress control runtime license deployment solution name.
Top
See Also

Reference

Licensing Class
Accusoft.ImagXpressSdk Namespace


Licensing Constructor

Licensing Constructor

Accusoft.ImagXpressSdk Namespace > Licensing Class : Licensing Constructor
An ImagXpress workspace ID.
The initial constructor for the licensing class passing in a workspace ID.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal pWorkId As IntPtr _
)
'Usage

Dim pWorkId As IntPtr

Dim instance As New Licensing(pWorkId)
public Licensing(
   IntPtr pWorkId
)
public: Licensing(
   IntPtr pWorkId
)
public:
Licensing(
   IntPtr pWorkId
)

Parameters

pWorkId
An ImagXpress workspace ID.
See Also

Reference

Licensing Class
Licensing Members


Licensing Class Methods

Licensing Class Methods

Accusoft.ImagXpressSdk Namespace : Licensing Class

For a list of all members of this type, see Licensing members.

Public Methods
 | Name | Description
Public Method | SetOEMLicenseKey | Sets the ImagXpress control runtime OEM license key.
Public Method | SetSolutionKey | Sets the ImagXpress control runtime license deployment key.
Public Method | SetSolutionName | Sets the ImagXpress control runtime license deployment solution name.
Top
See Also

Reference

Licensing Class
Accusoft.ImagXpressSdk Namespace


SetOEMLicenseKey Method

SetOEMLicenseKey Method

Accusoft.ImagXpressSdk Namespace > Licensing Class : SetOEMLicenseKey Method
The OEM license key required for OEM licensing.
Sets the ImagXpress control runtime OEM license key.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetOEMLicenseKey( _
   ByVal oemKey As String _
)
'Usage

Dim instance As Licensing
Dim oemKey As String

instance.SetOEMLicenseKey(oemKey)
public void SetOEMLicenseKey(
   string oemKey
)
public: void SetOEMLicenseKey(
   string* oemKey
)
public:
void SetOEMLicenseKey(
   String^ oemKey
)

Parameters

oemKey
The OEM license key required for OEM licensing.
Remarks
When OEM runtime licenses are purchased, the OEM license key is provided in the purchase confirmation email.
See Also

Reference

Licensing Class
Licensing Members


SetSolutionKey Method

SetSolutionKey Method

Accusoft.ImagXpressSdk Namespace > Licensing Class : SetSolutionKey Method
Unlock key 1
Unlock key 2
Unlock key 3
Unlock key 4
Sets the ImagXpress control runtime license deployment key.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetSolutionKey( _
   ByVal key1 As Long, _
   ByVal key2 As Long, _
   ByVal key3 As Long, _
   ByVal key4 As Long _
)
'Usage

Dim instance As Licensing
Dim key1 As Long
Dim key2 As Long
Dim key3 As Long
Dim key4 As Long

instance.SetSolutionKey(key1, key2, key3, key4)
public void SetSolutionKey(
   long key1,
   long key2,
   long key3,
   long key4
)
public: void SetSolutionKey(
   long key1,
   long key2,
   long key3,
   long key4
)
public:
void SetSolutionKey(
   int64 key1,
   int64 key2,
   int64 key3,
   int64 key4
)

Parameters

key1
Unlock key 1
key2
Unlock key 2
key3
Unlock key 3
key4
Unlock key 4
Remarks
This is the solution key required for all runtime licensing. The four integers are provided at the time of purchase of the runtime licenses along with the solution name, which is set with the SetSolutionName method.
See Also

Reference

Licensing Class
Licensing Members


SetSolutionName Method

SetSolutionName Method

Accusoft.ImagXpressSdk Namespace > Licensing Class : SetSolutionName Method
The solution name.
Sets the ImagXpress control runtime license deployment solution name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetSolutionName( _
   ByVal solutionName As String _
)
'Usage

Dim instance As Licensing
Dim solutionName As String

instance.SetSolutionName(solutionName)
public void SetSolutionName(
   string solutionName
)
public: void SetSolutionName(
   string* solutionName
)
public:
void SetSolutionName(
   String^ solutionName
)

Parameters

solutionName
The solution name.
Remarks
This is the name of the runtime license solution. The solution name is provided in the purchase confirmation email when runtime licenses are purchased.
See Also

Reference

Licensing Class
Licensing Members


Licensing Class Properties

Licensing Class Properties

Accusoft.ImagXpressSdk Namespace : Licensing Class

For a list of all members of this type, see Licensing members.

Public Properties
 | Name | Description
Public Property | EvaluationMode | Gets and sets a watermark or dialog box to be displayed periodically.
Public Property | LicenseStatus | Gets the current license status of the component.
Top
See Also

Reference

Licensing Class
Accusoft.ImagXpressSdk Namespace


EvaluationMode Property

EvaluationMode Property

Accusoft.ImagXpressSdk Namespace > Licensing Class : EvaluationMode Property
Gets and sets a watermark or dialog box to be displayed periodically.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property EvaluationMode As EvaluationMode
'Usage

Dim instance As Licensing
Dim value As EvaluationMode

instance.EvaluationMode = value

value = instance.EvaluationMode
public EvaluationMode EvaluationMode {get; set;}
public: __property EvaluationMode get_EvaluationMode();
public: __property void set_EvaluationMode(
   EvaluationMode value
);
public:
property EvaluationMode EvaluationMode {
   EvaluationMode get();
   void set (    EvaluationMode value);
}

Property Value

The EvaluationMode value set.
See Also

Reference

Licensing Class
Licensing Members


LicenseStatus Property

LicenseStatus Property

Accusoft.ImagXpressSdk Namespace > Licensing Class : LicenseStatus Property
Gets the current license status of the component.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property LicenseStatus As LicenseStatus
'Usage

Dim instance As Licensing
Dim value As LicenseStatus

value = instance.LicenseStatus
public LicenseStatus LicenseStatus {get;}
public: __property LicenseStatus get_LicenseStatus();
public:
property LicenseStatus LicenseStatus {
   LicenseStatus get();
}

Property Value

The current LicenseStatus.
See Also

Reference

Licensing Class
Licensing Members


LoadOptions Class

LoadOptions Class
Members

Accusoft.ImagXpressSdk Namespace : LoadOptions Class
The LoadOptions class includes various formats and image types to load into ImagXpress.
Object Model
LoadOptions ClassLoadOptionsCad ClassImageXData ClassLoadOptionsCameraRaw ClassInternetOptions ClassLoadOptionsJbig2 ClassLoadOptionsJpeg ClassLoadOptionsJpegXR ClassLoadOptionsMetafile ClassResolution ClassLoadOptionsPdf ClassLoadOptionsPic ClassLoadOptionsRaw ClassLoadOptionsTiff Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class LoadOptions
'Usage

Dim instance As LoadOptions
public class LoadOptions
public __gc class LoadOptions
public ref class LoadOptions
Inheritance Hierarchy

System.Object
Accusoft.ImagXpressSdk.LoadOptions

See Also

Reference

LoadOptions Members
Accusoft.ImagXpressSdk Namespace


LoadOptions Class Members

LoadOptions Class Members
Properties

Accusoft.ImagXpressSdk Namespace : LoadOptions Class

The following tables list the members exposed by LoadOptions.

Public Constructors
 | Name | Description
Public Constructor | LoadOptions Constructor | Initial constructor for the LoadOptions class.
Top
Public Properties
 | Name | Description
Public Property | Cad | Gets and sets the CAD load options for the image.
Public Property | CameraRaw | Gets and sets the CameraRaw load options for the image.
Public Property | CameraRawEnabled | Gets and sets support for Camera RAW file format.
Public Property | ColorRenderIntent | Gets and sets how the color profiles should be applied.
Public Property | CropRectangle | Gets and sets the dimensions to which the image should be cropped when loaded.
Public Property | ImageOffset | Gets and sets the offset in the file or memory buffer where ImagXpress begins reading the image data.
Public Property | Internet | Gets and sets the InternetOptions settings.
Public Property | Jbig2 | Gets and sets the specific LoadOptionsJbig2 applicable to a Jbig2 file format.
Public Property | Jpeg | Gets and sets the specific LoadOptionsJpeg applicable to a JPEG file format.
Public Property | JpegXR | Gets and sets the JPEG-XR load options for the image.
Public Property | LibraryNumberOfThreadsAllowed | Gets or sets the library number of threads allowed.
Public Property | LoadAlphaChannel | Gets and sets if the alpha channel data is loaded.
Public Property | LoadMode | Gets and sets a load mode for how image data is interpreted as a raw image format or a standard format.
Public Property | LoadResizeAntiAlias | Gets or sets a value indicating whether anti-aliasing is enabled during a load resize.
Public Property | MaintainAspectRatio | Gets and sets the option to preserve image aspect ratio when resizing an image during the loading of the ImageX object.
Public Property | Metafile | Gets and sets the specific LoadOptionsMetafile applicable to a metafile.
Public Property | Pdf | Gets and sets the specific LoadOptionsPdf applicable to a PDF file format.
Public Property | Pic | Gets and sets the specific LoadOptionsPic applicable to a PIC (Pegasus Imaging Corporation) file format.
Public Property | PreserveBlack | Gets and sets an indicator that preserve black should be applied to the image when it is loaded.
Public Property | Raw | Gets and sets the specific LoadOptionsRaw applicable to a RAW file.
Public Property | Resize | Gets and sets the image height and width to which the image should be resized to when loading into an ImageX object.
Public Property | Rotation | Gets and sets the angle of rotation to apply to the image being loaded into the ImageX object.
Public Property | ScaleToGray | Gets and sets an indicator if anti-aliasing/conversion to grayscale for 1 bpp images during a resizing load operation is enabled.
Public Property | SourceProfileName | Gets and sets the name of the color profile to apply to the image being loaded.
Public Property | ThumbnailSize | Gets and sets if the image is loaded as a thumbnail with the thumbnail size (JPEG and ePIC images only).
Public Property | Tiff | Gets and sets the specific LoadOptionsTiff applicable to a TIFF file format.
Public Property | UseEmbeddedColorManagement | Gets and sets the color profile included in the image metadata applied when loading the image.
Top
See Also

Reference

LoadOptions Class
Accusoft.ImagXpressSdk Namespace


LoadOptions Constructor

LoadOptions Constructor

Accusoft.ImagXpressSdk Namespace > LoadOptions Class : LoadOptions Constructor
Initial constructor for the LoadOptions class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New LoadOptions()
public LoadOptions()
public: LoadOptions();
public:
LoadOptions();
See Also

Reference

LoadOptions Class
LoadOptions Members


LoadOptions Class Properties

LoadOptions Class Properties

Accusoft.ImagXpressSdk Namespace : LoadOptions Class

For a list of all members of this type, see LoadOptions members.

Public Properties
 | Name | Description
Public Property | Cad | Gets and sets the CAD load options for the image.
Public Property | CameraRaw | Gets and sets the CameraRaw load options for the image.
Public Property | CameraRawEnabled | Gets and sets support for Camera RAW file format.
Public Property | ColorRenderIntent | Gets and sets how the color profiles should be applied.
Public Property | CropRectangle | Gets and sets the dimensions to which the image should be cropped when loaded.
Public Property | ImageOffset | Gets and sets the offset in the file or memory buffer where ImagXpress begins reading the image data.
Public Property | Internet | Gets and sets the InternetOptions settings.
Public Property | Jbig2 | Gets and sets the specific LoadOptionsJbig2 applicable to a Jbig2 file format.
Public Property | Jpeg | Gets and sets the specific LoadOptionsJpeg applicable to a JPEG file format.
Public Property | JpegXR | Gets and sets the JPEG-XR load options for the image.
Public Property | LibraryNumberOfThreadsAllowed | Gets or sets the library number of threads allowed.
Public Property | LoadAlphaChannel | Gets and sets if the alpha channel data is loaded.
Public Property | LoadMode | Gets and sets a load mode for how image data is interpreted as a raw image format or a standard format.
Public Property | LoadResizeAntiAlias | Gets or sets a value indicating whether anti-aliasing is enabled during a load resize.
Public Property | MaintainAspectRatio | Gets and sets the option to preserve image aspect ratio when resizing an image during the loading of the ImageX object.
Public Property | Metafile | Gets and sets the specific LoadOptionsMetafile applicable to a metafile.
Public Property | Pdf | Gets and sets the specific LoadOptionsPdf applicable to a PDF file format.
Public Property | Pic | Gets and sets the specific LoadOptionsPic applicable to a PIC (Pegasus Imaging Corporation) file format.
Public Property | PreserveBlack | Gets and sets an indicator that preserve black should be applied to the image when it is loaded.
Public Property | Raw | Gets and sets the specific LoadOptionsRaw applicable to a RAW file.
Public Property | Resize | Gets and sets the image height and width to which the image should be resized to when loading into an ImageX object.
Public Property | Rotation | Gets and sets the angle of rotation to apply to the image being loaded into the ImageX object.
Public Property | ScaleToGray | Gets and sets an indicator if anti-aliasing/conversion to grayscale for 1 bpp images during a resizing load operation is enabled.
Public Property | SourceProfileName | Gets and sets the name of the color profile to apply to the image being loaded.
Public Property | ThumbnailSize | Gets and sets if the image is loaded as a thumbnail with the thumbnail size (JPEG and ePIC images only).
Public Property | Tiff | Gets and sets the specific LoadOptionsTiff applicable to a TIFF file format.
Public Property | UseEmbeddedColorManagement | Gets and sets the color profile included in the image metadata applied when loading the image.
Top
See Also

Reference

LoadOptions Class
Accusoft.ImagXpressSdk Namespace


Cad Property

Cad Property

Accusoft.ImagXpressSdk Namespace > LoadOptions Class : Cad Property
Gets and sets the CAD load options for the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Cad As LoadOptionsCad
'Usage

Dim instance As LoadOptions
Dim value As LoadOptionsCad

instance.Cad = value

value = instance.Cad
public LoadOptionsCad Cad {get; set;}
public: __property LoadOptionsCad* get_Cad();
public: __property void set_Cad(
   LoadOptionsCad* value
);
public:
property LoadOptionsCad^ Cad {
   LoadOptionsCad^ get();
   void set (    LoadOptionsCad^ value);
}
Remarks

Note: Available in Professional edition.

See Also

Reference

LoadOptions Class
LoadOptions Members


CameraRaw Property

CameraRaw Property

Accusoft.ImagXpressSdk Namespace > LoadOptions Class : CameraRaw Property
Gets and sets the CameraRaw load options for the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CameraRaw As LoadOptionsCameraRaw
'Usage

Dim instance As LoadOptions
Dim value As LoadOptionsCameraRaw

instance.CameraRaw = value

value = instance.CameraRaw
public LoadOptionsCameraRaw CameraRaw {get; set;}
public: __property LoadOptionsCameraRaw* get_CameraRaw();
public: __property void set_CameraRaw(
   LoadOptionsCameraRaw* value
);
public:
property LoadOptionsCameraRaw^ CameraRaw {
   LoadOptionsCameraRaw^ get();
   void set (    LoadOptionsCameraRaw^ value);
}

Property Value

The LoadOptionsCameraRaw options.
See Also

Reference

LoadOptions Class
LoadOptions Members


CameraRawEnabled Property

CameraRawEnabled Property

Accusoft.ImagXpressSdk Namespace > LoadOptions Class : CameraRawEnabled Property
Gets and sets support for Camera RAW file format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CameraRawEnabled As Boolean
'Usage

Dim instance As LoadOptions
Dim value As Boolean

instance.CameraRawEnabled = value

value = instance.CameraRawEnabled
public bool CameraRawEnabled {get; set;}
public: __property bool get_CameraRawEnabled();
public: __property void set_CameraRawEnabled(
   bool value
);
public:
property bool CameraRawEnabled {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true to check the loaded image for Camera RAW format. Otherwise, false should be set.
Remarks

When this property is set to true, the image is examined on loading to see if it is in Camera RAW format, and to identify the RAW format.

To optimize performance, this property should be set to false so the image is not examined on loading to inspect for RAW formats unnecessarily.

Note: Loading CameraRaw files from a stream is not supported as the entire image must be loaded before the CameraRaw format can be recognized. When LoadOptions.CameraRawEnabled = True, the CameraRaw image can only be loaded from a file.

Note: Available in Professional edition.

See Also

Reference

LoadOptions Class
LoadOptions Members


ColorRenderIntent Property (LoadOptions)

ColorRenderIntent Property (LoadOptions)

Accusoft.ImagXpressSdk Namespace > LoadOptions Class : ColorRenderIntent Property
Gets and sets how the color profiles should be applied.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ColorRenderIntent As RenderIntent
'Usage

Dim instance As LoadOptions
Dim value As RenderIntent

instance.ColorRenderIntent = value

value = instance.ColorRenderIntent
public RenderIntent ColorRenderIntent {get; set;}
public: __property RenderIntent get_ColorRenderIntent();
public: __property void set_ColorRenderIntent(
   RenderIntent value
);
public:
property RenderIntent ColorRenderIntent {
   RenderIntent get();
   void set (    RenderIntent value);
}

Property Value

The RenderIntent value set.
Remarks

This property specifies how color profiles are applied when performing Image Color Management.

Note: Available in Professional edition.

See Also

Reference

LoadOptions Class
LoadOptions Members


CropRectangle Property

CropRectangle Property

Accusoft.ImagXpressSdk Namespace > LoadOptions Class : CropRectangle Property
Gets and sets the dimensions to which the image should be cropped when loaded.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CropRectangle As Rectangle
'Usage

Dim instance As LoadOptions
Dim value As Rectangle

instance.CropRectangle = value

value = instance.CropRectangle
public Rectangle CropRectangle {get; set;}
public: __property Rectangle get_CropRectangle();
public: __property void set_CropRectangle(
   Rectangle value
);
public:
property Rectangle CropRectangle {
   Rectangle get();
   void set (    Rectangle value);
}

Property Value

The System.Drawing.Rectangle values set.
Remarks

Note: If the dimensions specified are all zeros or null, then no cropping occurs when loading.

Note: CameraRaw images do not support cropping during loading.

///
See Also

Reference

LoadOptions Class
LoadOptions Members


ImageOffset Property

ImageOffset Property

Accusoft.ImagXpressSdk Namespace > LoadOptions Class : ImageOffset Property
Gets and sets the offset in the file or memory buffer where ImagXpress begins reading the image data.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ImageOffset As Integer
'Usage

Dim instance As LoadOptions
Dim value As Integer

instance.ImageOffset = value

value = instance.ImageOffset
public int ImageOffset {get; set;}
public: __property int get_ImageOffset();
public: __property void set_ImageOffset(
   int value
);
public:
property int ImageOffset {
   int get();
   void set (    int value);
}

Property Value

An integer which represents the offset value.
See Also

Reference

LoadOptions Class
LoadOptions Members


Internet Property (LoadOptions)

Internet Property (LoadOptions)

Accusoft.ImagXpressSdk Namespace > LoadOptions Class : Internet Property
Gets and sets the InternetOptions settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Internet As InternetOptions
'Usage

Dim instance As LoadOptions
Dim value As InternetOptions

instance.Internet = value

value = instance.Internet
public InternetOptions Internet {get; set;}
public: __property InternetOptions* get_Internet();
public: __property void set_Internet(
   InternetOptions* value
);
public:
property InternetOptions^ Internet {
   InternetOptions^ get();
   void set (    InternetOptions^ value);
}

Property Value

The InternetOptions values set.
See Also

Reference

LoadOptions Class
LoadOptions Members


Jbig2 Property (LoadOptions)

Jbig2 Property (LoadOptions)

Accusoft.ImagXpressSdk Namespace > LoadOptions Class : Jbig2 Property
Gets and sets the specific LoadOptionsJbig2 applicable to a Jbig2 file format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Jbig2 As LoadOptionsJbig2
'Usage

Dim instance As LoadOptions
Dim value As LoadOptionsJbig2

instance.Jbig2 = value

value = instance.Jbig2
public LoadOptionsJbig2 Jbig2 {get; set;}
public: __property LoadOptionsJbig2* get_Jbig2();
public: __property void set_Jbig2(
   LoadOptionsJbig2* value
);
public:
property LoadOptionsJbig2^ Jbig2 {
   LoadOptionsJbig2^ get();
   void set (    LoadOptionsJbig2^ value);
}

Property Value

The LoadOptionsJbig2 values set.
See Also

Reference

LoadOptions Class
LoadOptions Members


Jpeg Property (LoadOptions)

Jpeg Property (LoadOptions)

Accusoft.ImagXpressSdk Namespace > LoadOptions Class : Jpeg Property
Gets and sets the specific LoadOptionsJpeg applicable to a JPEG file format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Jpeg As LoadOptionsJpeg
'Usage

Dim instance As LoadOptions
Dim value As LoadOptionsJpeg

instance.Jpeg = value

value = instance.Jpeg
public LoadOptionsJpeg Jpeg {get; set;}
public: __property LoadOptionsJpeg* get_Jpeg();
public: __property void set_Jpeg(
   LoadOptionsJpeg* value
);
public:
property LoadOptionsJpeg^ Jpeg {
   LoadOptionsJpeg^ get();
   void set (    LoadOptionsJpeg^ value);
}

Property Value

The LoadOptionsJpeg values set.
See Also

Reference

LoadOptions Class
LoadOptions Members


JpegXR Property (LoadOptions)

JpegXR Property (LoadOptions)

Accusoft.ImagXpressSdk Namespace > LoadOptions Class : JpegXR Property
Gets and sets the JPEG-XR load options for the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property JpegXR As LoadOptionsJpegXR
'Usage

Dim instance As LoadOptions
Dim value As LoadOptionsJpegXR

instance.JpegXR = value

value = instance.JpegXR
public LoadOptionsJpegXR JpegXR {get; set;}
public: __property LoadOptionsJpegXR* get_JpegXR();
public: __property void set_JpegXR(
   LoadOptionsJpegXR* value
);
public:
property LoadOptionsJpegXR^ JpegXR {
   LoadOptionsJpegXR^ get();
   void set (    LoadOptionsJpegXR^ value);
}

Property Value

The LoadOptionsJpegXR options.
See Also

Reference

LoadOptions Class
LoadOptions Members


LibraryNumberOfThreadsAllowed Property (LoadOptions)

LibraryNumberOfThreadsAllowed Property (LoadOptions)

Accusoft.ImagXpressSdk Namespace > LoadOptions Class : LibraryNumberOfThreadsAllowed Property
Gets or sets the library number of threads allowed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LibraryNumberOfThreadsAllowed As Integer
'Usage

Dim instance As LoadOptions
Dim value As Integer

instance.LibraryNumberOfThreadsAllowed = value

value = instance.LibraryNumberOfThreadsAllowed
public int LibraryNumberOfThreadsAllowed {get; set;}
public: __property int get_LibraryNumberOfThreadsAllowed();
public: __property void set_LibraryNumberOfThreadsAllowed(
   int value
);
public:
property int LibraryNumberOfThreadsAllowed {
   int get();
   void set (    int value);
}

Property Value

The library number of threads allowed.
Remarks
This value is specific to the lower level libraries that ImagXpress uses. This value may or may not be honored depending on the image type. For instance, JPEG2000 images do currently support this feature.
See Also

Reference

LoadOptions Class
LoadOptions Members


LoadAlphaChannel Property

LoadAlphaChannel Property

Accusoft.ImagXpressSdk Namespace > LoadOptions Class : LoadAlphaChannel Property
Gets and sets if the alpha channel data is loaded.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LoadAlphaChannel As Boolean
'Usage

Dim instance As LoadOptions
Dim value As Boolean

instance.LoadAlphaChannel = value

value = instance.LoadAlphaChannel
public bool LoadAlphaChannel {get; set;}
public: __property bool get_LoadAlphaChannel();
public: __property void set_LoadAlphaChannel(
   bool value
);
public:
property bool LoadAlphaChannel {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true to enable loading the alpha channel data. Otherwise, false is returned.
See Also

Reference

LoadOptions Class
LoadOptions Members


LoadMode Property

LoadMode Property

Accusoft.ImagXpressSdk Namespace > LoadOptions Class : LoadMode Property
Gets and sets a load mode for how image data is interpreted as a raw image format or a standard format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LoadMode As LoadMode
'Usage

Dim instance As LoadOptions
Dim value As LoadMode

instance.LoadMode = value

value = instance.LoadMode
public LoadMode LoadMode {get; set;}
public: __property LoadMode get_LoadMode();
public: __property void set_LoadMode(
   LoadMode value
);
public:
property LoadMode LoadMode {
   LoadMode get();
   void set (    LoadMode value);
}

Property Value

The LoadMode enumeration value set.
Remarks

When this property is set to Normal, the image is interpreted as having a standard image format, and image data is captured from the image upon loading into ImagXpress.

When this property is set to Raw, the image is interpreted as a raw image format when loading. The application must specify additional information required to interpret the raw data, using the LoadOptionsRaw class in the Raw property.

Note: The Raw value for this property and the Raw property have nothing to do with the CameraRawEnabled property. In order to use load CameraRaw images this property must be set to Normal.

Note: Using this property with a Raw value is available in Professional edition only.

See Also

Reference

LoadOptions Class
LoadOptions Members
LoadMode Enumeration


LoadResizeAntiAlias Property

LoadResizeAntiAlias Property

Accusoft.ImagXpressSdk Namespace > LoadOptions Class : LoadResizeAntiAlias Property
Gets or sets a value indicating whether anti-aliasing is enabled during a load resize.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LoadResizeAntiAlias As Boolean
'Usage

Dim instance As LoadOptions
Dim value As Boolean

instance.LoadResizeAntiAlias = value

value = instance.LoadResizeAntiAlias
public bool LoadResizeAntiAlias {get; set;}
public: __property bool get_LoadResizeAntiAlias();
public: __property void set_LoadResizeAntiAlias(
   bool value
);
public:
property bool LoadResizeAntiAlias {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true if anti-alias enabled during a load resize; otherwise, false.
See Also

Reference

LoadOptions Class
LoadOptions Members


MaintainAspectRatio Property

MaintainAspectRatio Property

Accusoft.ImagXpressSdk Namespace > LoadOptions Class : MaintainAspectRatio Property
Gets and sets the option to preserve image aspect ratio when resizing an image during the loading of the ImageX object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MaintainAspectRatio As Boolean
'Usage

Dim instance As LoadOptions
Dim value As Boolean

instance.MaintainAspectRatio = value

value = instance.MaintainAspectRatio
public bool MaintainAspectRatio {get; set;}
public: __property bool get_MaintainAspectRatio();
public: __property void set_MaintainAspectRatio(
   bool value
);
public:
property bool MaintainAspectRatio {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true to preserve the image aspect ratio when resizing the image during the loading of the ImageX object.

See Also

Reference

LoadOptions Class
LoadOptions Members


Metafile Property

Metafile Property

Accusoft.ImagXpressSdk Namespace > LoadOptions Class : Metafile Property
Gets and sets the specific LoadOptionsMetafile applicable to a metafile.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Metafile As LoadOptionsMetafile
'Usage

Dim instance As LoadOptions
Dim value As LoadOptionsMetafile

instance.Metafile = value

value = instance.Metafile
public LoadOptionsMetafile Metafile {get; set;}
public: __property LoadOptionsMetafile* get_Metafile();
public: __property void set_Metafile(
   LoadOptionsMetafile* value
);
public:
property LoadOptionsMetafile^ Metafile {
   LoadOptionsMetafile^ get();
   void set (    LoadOptionsMetafile^ value);
}

Property Value

The LoadOptionsMetafile values set.
See Also

Reference

LoadOptions Class
LoadOptions Members


Pdf Property (LoadOptions)

Pdf Property (LoadOptions)

Accusoft.ImagXpressSdk Namespace > LoadOptions Class : Pdf Property
Gets and sets the specific LoadOptionsPdf applicable to a PDF file format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.")>
Public Property Pdf As LoadOptionsPdf
'Usage

Dim instance As LoadOptions
Dim value As LoadOptionsPdf

instance.Pdf = value

value = instance.Pdf
[Obsolete("PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.")]
public LoadOptionsPdf Pdf {get; set;}
[Obsolete("PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.")]
public: __property LoadOptionsPdf* get_Pdf();
public: __property void set_Pdf(
   LoadOptionsPdf* value
);
[Obsolete("PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.")]
public:
property LoadOptionsPdf^ Pdf {
   LoadOptionsPdf^ get();
   void set (    LoadOptionsPdf^ value);
}

Property Value

The LoadOptionsPdf values set.
Remarks

Note: PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.

See Also

Reference

LoadOptions Class
LoadOptions Members


Pic Property (LoadOptions)

Pic Property (LoadOptions)

Accusoft.ImagXpressSdk Namespace > LoadOptions Class : Pic Property
Gets and sets the specific LoadOptionsPic applicable to a PIC (Pegasus Imaging Corporation) file format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Pic As LoadOptionsPic
'Usage

Dim instance As LoadOptions
Dim value As LoadOptionsPic

instance.Pic = value

value = instance.Pic
public LoadOptionsPic Pic {get; set;}
public: __property LoadOptionsPic* get_Pic();
public: __property void set_Pic(
   LoadOptionsPic* value
);
public:
property LoadOptionsPic^ Pic {
   LoadOptionsPic^ get();
   void set (    LoadOptionsPic^ value);
}

Property Value

The LoadOptionsPic values set.
See Also

Reference

LoadOptions Class
LoadOptions Members


PreserveBlack Property (LoadOptions)

PreserveBlack Property (LoadOptions)

Accusoft.ImagXpressSdk Namespace > LoadOptions Class : PreserveBlack Property
Gets and sets an indicator that preserve black should be applied to the image when it is loaded.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PreserveBlack As Boolean
'Usage

Dim instance As LoadOptions
Dim value As Boolean

instance.PreserveBlack = value

value = instance.PreserveBlack
public bool PreserveBlack {get; set;}
public: __property bool get_PreserveBlack();
public: __property void set_PreserveBlack(
   bool value
);
public:
property bool PreserveBlack {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true for black objects (such as lines) are to be enhanced to increase readability. Otherwise, false is returned and no black objects are applied.
Remarks

When this property is set to true, it enhances the black objects within an image to increase readability.

Note: This property permanently modifies the image stored in the ImageX object.

See Also

Reference

LoadOptions Class
LoadOptions Members


Raw Property

Raw Property

Accusoft.ImagXpressSdk Namespace > LoadOptions Class : Raw Property
Gets and sets the specific LoadOptionsRaw applicable to a RAW file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Raw As LoadOptionsRaw
'Usage

Dim instance As LoadOptions
Dim value As LoadOptionsRaw

instance.Raw = value

value = instance.Raw
public LoadOptionsRaw Raw {get; set;}
public: __property LoadOptionsRaw* get_Raw();
public: __property void set_Raw(
   LoadOptionsRaw* value
);
public:
property LoadOptionsRaw^ Raw {
   LoadOptionsRaw^ get();
   void set (    LoadOptionsRaw^ value);
}

Property Value

The LoadOptionsRaw values set.
Remarks

Note: Available in Professional edition.

See Also

Reference

LoadOptions Class
LoadOptions Members


Resize Property

Resize Property

Accusoft.ImagXpressSdk Namespace > LoadOptions Class : Resize Property
Gets and sets the image height and width to which the image should be resized to when loading into an ImageX object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Resize As Size
'Usage

Dim instance As LoadOptions
Dim value As Size

instance.Resize = value

value = instance.Resize
public Size Resize {get; set;}
public: __property Size get_Resize();
public: __property void set_Resize(
   Size value
);
public:
property Size Resize {
   Size get();
   void set (    Size value);
}

Property Value

The System.Drawing.Size set.
Remarks

Note: If the dimensions specified are all zeros or null, then no resizing occurs when loading.

Note: CameraRaw images do not support resizing during loading.

See Also

Reference

LoadOptions Class
LoadOptions Members


Rotation Property

Rotation Property

Accusoft.ImagXpressSdk Namespace > LoadOptions Class : Rotation Property
Gets and sets the angle of rotation to apply to the image being loaded into the ImageX object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Rotation As RotateAngle
'Usage

Dim instance As LoadOptions
Dim value As RotateAngle

instance.Rotation = value

value = instance.Rotation
public RotateAngle Rotation {get; set;}
public: __property RotateAngle get_Rotation();
public: __property void set_Rotation(
   RotateAngle value
);
public:
property RotateAngle Rotation {
   RotateAngle get();
   void set (    RotateAngle value);
}

Property Value

The RotateAngle enumeration value set.
Remarks

If the rotation is set to 0 or null, then the image will not be rotated when loaded.

Note: CameraRaw images do not support rotation during loading.

See Also

Reference

LoadOptions Class
LoadOptions Members


ScaleToGray Property

ScaleToGray Property

Accusoft.ImagXpressSdk Namespace > LoadOptions Class : ScaleToGray Property
Gets and sets an indicator if anti-aliasing/conversion to grayscale for 1 bpp images during a resizing load operation is enabled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ScaleToGray As Boolean
'Usage

Dim instance As LoadOptions
Dim value As Boolean

instance.ScaleToGray = value

value = instance.ScaleToGray
public bool ScaleToGray {get; set;}
public: __property bool get_ScaleToGray();
public: __property void set_ScaleToGray(
   bool value
);
public:
property bool ScaleToGray {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true to enable. Otherwise, false is returned.
Remarks

When this property is set to true, and the image is a 1 bit per pixel (black and white), the image is scaled to gray. The resulting image is an 8-bit per pixel grayscale image. Using this property is particularly useful when attempting to create a thumbnail image of the original that is visually pleasing.

See Also

Reference

LoadOptions Class
LoadOptions Members


SourceProfileName Property

SourceProfileName Property

Accusoft.ImagXpressSdk Namespace > LoadOptions Class : SourceProfileName Property
Gets and sets the name of the color profile to apply to the image being loaded.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SourceProfileName As String
'Usage

Dim instance As LoadOptions
Dim value As String

instance.SourceProfileName = value

value = instance.SourceProfileName
public string SourceProfileName {get; set;}
public: __property string* get_SourceProfileName();
public: __property void set_SourceProfileName(
   string* value
);
public:
property String^ SourceProfileName {
   String^ get();
   void set (    String^ value);
}

Property Value

A string which represents the source profile name.
Remarks

If the UseEmbeddedColorManagement property is set to false, then the source profile name specifies the file name of the color profile to apply to the image being loaded. If this property is null, and the UseEmbeddedColorManagement property is false, then no color management is performed when loading the image.

This property is useful to obtain a profile from a graphics device context if one is supported for the device.

Note: Available in Professional edition.

See Also

Reference

LoadOptions Class
LoadOptions Members


ThumbnailSize Property (LoadOptions)

ThumbnailSize Property (LoadOptions)

Accusoft.ImagXpressSdk Namespace > LoadOptions Class : ThumbnailSize Property
Gets and sets if the image is loaded as a thumbnail with the thumbnail size (JPEG and ePIC images only).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ThumbnailSize As ThumbnailSize
'Usage

Dim instance As LoadOptions
Dim value As ThumbnailSize

instance.ThumbnailSize = value

value = instance.ThumbnailSize
public ThumbnailSize ThumbnailSize {get; set;}
public: __property ThumbnailSize get_ThumbnailSize();
public: __property void set_ThumbnailSize(
   ThumbnailSize value
);
public:
property ThumbnailSize ThumbnailSize {
   ThumbnailSize get();
   void set (    ThumbnailSize value);
}

Property Value

The ThumbnailSize enumeration value set.
Remarks

In all cases the aspect ratio of the original image is maintained. ThumbnailSize applies to JPEG and ePIC images only.

See Also

Reference

LoadOptions Class
LoadOptions Members


Tiff Property (LoadOptions)

Tiff Property (LoadOptions)

Accusoft.ImagXpressSdk Namespace > LoadOptions Class : Tiff Property
Gets and sets the specific LoadOptionsTiff applicable to a TIFF file format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Tiff As LoadOptionsTiff
'Usage

Dim instance As LoadOptions
Dim value As LoadOptionsTiff

instance.Tiff = value

value = instance.Tiff
public LoadOptionsTiff Tiff {get; set;}
public: __property LoadOptionsTiff* get_Tiff();
public: __property void set_Tiff(
   LoadOptionsTiff* value
);
public:
property LoadOptionsTiff^ Tiff {
   LoadOptionsTiff^ get();
   void set (    LoadOptionsTiff^ value);
}

Property Value

The LoadOptionsTiff values set.
See Also

Reference

LoadOptions Class
LoadOptions Members


UseEmbeddedColorManagement Property (LoadOptions)

UseEmbeddedColorManagement Property (LoadOptions)

Accusoft.ImagXpressSdk Namespace > LoadOptions Class : UseEmbeddedColorManagement Property
Gets and sets the color profile included in the image metadata applied when loading the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property UseEmbeddedColorManagement As Boolean
'Usage

Dim instance As LoadOptions
Dim value As Boolean

instance.UseEmbeddedColorManagement = value

value = instance.UseEmbeddedColorManagement
public bool UseEmbeddedColorManagement {get; set;}
public: __property bool get_UseEmbeddedColorManagement();
public: __property void set_UseEmbeddedColorManagement(
   bool value
);
public:
property bool UseEmbeddedColorManagement {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true when the color profile specified in the image's metadata is applied to the image when the image is loaded. Otherwise, false is returned.
Remarks

When this property is set to true, the color profile specified in the image's matadata is applied to the image when the image is loaded. Set this property to false to not include the color profile specified in the image's metadata.

Note: Available in Professional edition.

See Also

Reference

LoadOptions Class
LoadOptions Members


LoadOptionsCad Class

LoadOptionsCad Class
Members

Accusoft.ImagXpressSdk Namespace : LoadOptionsCad Class
This class contains the CAD data objects options when loading CAD files.
Object Model
LoadOptionsCad ClassImageXData ClassCadLayer ClassCadLayout ClassResolution Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class LoadOptionsCad
'Usage

Dim instance As LoadOptionsCad
public class LoadOptionsCad
public __gc class LoadOptionsCad
public ref class LoadOptionsCad
Remarks

Note: Available in Professional edition.

Inheritance Hierarchy

System.Object
Accusoft.ImagXpressSdk.LoadOptionsCad

See Also

Reference

LoadOptionsCad Members
Accusoft.ImagXpressSdk Namespace


LoadOptionsCad Class Members

LoadOptionsCad Class Members
Properties

Accusoft.ImagXpressSdk Namespace : LoadOptionsCad Class

The following tables list the members exposed by LoadOptionsCad.

Public Constructors
 | Name | Description
Public Constructor | LoadOptionsCad Constructor | The main constructor for the LoadOptionsCad class.
Top
Public Properties
 | Name | Description
Public Property | CadData | Gets and sets worker metadata information exchange.
Public Property | LayoutToRender | Gets and sets the CAD layout to render.
Public Property | PaperBitDepth | Gets and sets the CAD paper bit depth.
Public Property | PaperHeight | Gets and sets the paper height for the CAD file.
Public Property | PaperResolutionUnits | Gets and sets the paper resolution unit type (inches or centimeters).
Public Property | PaperResolutionX | Gets and sets the dots per unit (inch, cm, etc.) for the paper horizontally.
Public Property | PaperResolutionY | Gets and sets the dots per unit (inch or cm) for the paper vertically.
Public Property | PaperWidth | Gets and sets the paper width for the CAD file.
Top
See Also

Reference

LoadOptionsCad Class
Accusoft.ImagXpressSdk Namespace


LoadOptionsCad Constructor

LoadOptionsCad Constructor

Accusoft.ImagXpressSdk Namespace > LoadOptionsCad Class : LoadOptionsCad Constructor
The main constructor for the LoadOptionsCad class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New LoadOptionsCad()
public LoadOptionsCad()
public: LoadOptionsCad();
public:
LoadOptionsCad();
Remarks

Note: Available in Professional edition.

See Also

Reference

LoadOptionsCad Class
LoadOptionsCad Members


LoadOptionsCad Class Properties

LoadOptionsCad Class Properties

Accusoft.ImagXpressSdk Namespace : LoadOptionsCad Class

For a list of all members of this type, see LoadOptionsCad members.

Public Properties
 | Name | Description
Public Property | CadData | Gets and sets worker metadata information exchange.
Public Property | LayoutToRender | Gets and sets the CAD layout to render.
Public Property | PaperBitDepth | Gets and sets the CAD paper bit depth.
Public Property | PaperHeight | Gets and sets the paper height for the CAD file.
Public Property | PaperResolutionUnits | Gets and sets the paper resolution unit type (inches or centimeters).
Public Property | PaperResolutionX | Gets and sets the dots per unit (inch, cm, etc.) for the paper horizontally.
Public Property | PaperResolutionY | Gets and sets the dots per unit (inch or cm) for the paper vertically.
Public Property | PaperWidth | Gets and sets the paper width for the CAD file.
Top
See Also

Reference

LoadOptionsCad Class
Accusoft.ImagXpressSdk Namespace


CadData Property

CadData Property

Accusoft.ImagXpressSdk Namespace > LoadOptionsCad Class : CadData Property
Gets and sets worker metadata information exchange.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CadData As ImageXData
'Usage

Dim instance As LoadOptionsCad
Dim value As ImageXData

instance.CadData = value

value = instance.CadData
public ImageXData CadData {get; set;}
public: __property ImageXData* get_CadData();
public: __property void set_CadData(
   ImageXData* value
);
public:
property ImageXData^ CadData {
   ImageXData^ get();
   void set (    ImageXData^ value);
}

Property Value

A ImageXData which contains metadata information.
Remarks

The DataObject from ImagX houses MetaData for Tiff, Exif and files with Iptc data.

Note: Available in Professional edition.

See Also

Reference

LoadOptionsCad Class
LoadOptionsCad Members


LayoutToRender Property

LayoutToRender Property

Accusoft.ImagXpressSdk Namespace > LoadOptionsCad Class : LayoutToRender Property
Gets and sets the CAD layout to render.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LayoutToRender As Integer
'Usage

Dim instance As LoadOptionsCad
Dim value As Integer

instance.LayoutToRender = value

value = instance.LayoutToRender
public int LayoutToRender {get; set;}
public: __property int get_LayoutToRender();
public: __property void set_LayoutToRender(
   int value
);
public:
property int LayoutToRender {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the CAD layout.
Remarks

CAD files present different objects or portions of objects and structures to render by layouts. This value should not exceed the total number of layouts within the CAD file.

Note: Available in Professional edition.

See Also

Reference

LoadOptionsCad Class
LoadOptionsCad Members


PaperBitDepth Property

PaperBitDepth Property

Accusoft.ImagXpressSdk Namespace > LoadOptionsCad Class : PaperBitDepth Property
Gets and sets the CAD paper bit depth.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PaperBitDepth As Integer
'Usage

Dim instance As LoadOptionsCad
Dim value As Integer

instance.PaperBitDepth = value

value = instance.PaperBitDepth
public int PaperBitDepth {get; set;}
public: __property int get_PaperBitDepth();
public: __property void set_PaperBitDepth(
   int value
);
public:
property int PaperBitDepth {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the CAD paper bit depth.
Remarks

Bitdepth affects image size and the maximum possible number of colors. Typically, 8 bit per color is sufficient for many 2D CAD drawings.

Note: Available in Professional edition.

See Also

Reference

LoadOptionsCad Class
LoadOptionsCad Members


PaperHeight Property

PaperHeight Property

Accusoft.ImagXpressSdk Namespace > LoadOptionsCad Class : PaperHeight Property
Gets and sets the paper height for the CAD file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PaperHeight As Double
'Usage

Dim instance As LoadOptionsCad
Dim value As Double

instance.PaperHeight = value

value = instance.PaperHeight
public double PaperHeight {get; set;}
public: __property double get_PaperHeight();
public: __property void set_PaperHeight(
   double value
);
public:
property double PaperHeight {
   double get();
   void set (    double value);
}

Property Value

A double value which represents the height of the paper.
Remarks

Works in conjunction with PaperResolutionY to set the image canvas neight in pixels.

Note: Available in Professional edition.

See Also

Reference

LoadOptionsCad Class
LoadOptionsCad Members


PaperResolutionUnits Property

PaperResolutionUnits Property

Accusoft.ImagXpressSdk Namespace > LoadOptionsCad Class : PaperResolutionUnits Property
Gets and sets the paper resolution unit type (inches or centimeters).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PaperResolutionUnits As ResolutionUnits
'Usage

Dim instance As LoadOptionsCad
Dim value As ResolutionUnits

instance.PaperResolutionUnits = value

value = instance.PaperResolutionUnits
public ResolutionUnits PaperResolutionUnits {get; set;}
public: __property ResolutionUnits get_PaperResolutionUnits();
public: __property void set_PaperResolutionUnits(
   ResolutionUnits value
);
public:
property ResolutionUnits PaperResolutionUnits {
   ResolutionUnits get();
   void set (    ResolutionUnits value);
}

Property Value

A ResolutionUnits enumeration value which represents the units type.
Remarks

Note: Available in Professional edition.

See Also

Reference

LoadOptionsCad Class
LoadOptionsCad Members


PaperResolutionX Property

PaperResolutionX Property

Accusoft.ImagXpressSdk Namespace > LoadOptionsCad Class : PaperResolutionX Property
Gets and sets the dots per unit (inch, cm, etc.) for the paper horizontally.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PaperResolutionX As Double
'Usage

Dim instance As LoadOptionsCad
Dim value As Double

instance.PaperResolutionX = value

value = instance.PaperResolutionX
public double PaperResolutionX {get; set;}
public: __property double get_PaperResolutionX();
public: __property void set_PaperResolutionX(
   double value
);
public:
property double PaperResolutionX {
   double get();
   void set (    double value);
}

Property Value

A double value which represents the x coordinate for the CAD paper.
Remarks

Works in conjunction with PaperWidth to set the image canvas width in pixels.

Note: Available in Professional edition.

See Also

Reference

LoadOptionsCad Class
LoadOptionsCad Members


PaperResolutionY Property

PaperResolutionY Property

Accusoft.ImagXpressSdk Namespace > LoadOptionsCad Class : PaperResolutionY Property
Gets and sets the dots per unit (inch or cm) for the paper vertically.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PaperResolutionY As Double
'Usage

Dim instance As LoadOptionsCad
Dim value As Double

instance.PaperResolutionY = value

value = instance.PaperResolutionY
public double PaperResolutionY {get; set;}
public: __property double get_PaperResolutionY();
public: __property void set_PaperResolutionY(
   double value
);
public:
property double PaperResolutionY {
   double get();
   void set (    double value);
}

Property Value

A double value which represents the y coordinate for the CAD paper.
Remarks

Works in conjunction with PaperHeight to set the image canvas width in pixels.

Note: Available in Professional edition.

See Also

Reference

LoadOptionsCad Class
LoadOptionsCad Members


PaperWidth Property

PaperWidth Property

Accusoft.ImagXpressSdk Namespace > LoadOptionsCad Class : PaperWidth Property
Gets and sets the paper width for the CAD file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PaperWidth As Double
'Usage

Dim instance As LoadOptionsCad
Dim value As Double

instance.PaperWidth = value

value = instance.PaperWidth
public double PaperWidth {get; set;}
public: __property double get_PaperWidth();
public: __property void set_PaperWidth(
   double value
);
public:
property double PaperWidth {
   double get();
   void set (    double value);
}

Property Value

A double value which represents the width of the paper.
Remarks

Works in conjunction with PaperResolutionX to set the image canvas width in pixels.

Note: Available in Professional edition.

See Also

Reference

LoadOptionsCad Class
LoadOptionsCad Members


LoadOptionsCameraRaw Class

LoadOptionsCameraRaw Class
Members

Accusoft.ImagXpressSdk Namespace : LoadOptionsCameraRaw Class
This class implements load options for the CameraRaw images.
Object Model
LoadOptionsCameraRaw Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class LoadOptionsCameraRaw
'Usage

Dim instance As LoadOptionsCameraRaw
public class LoadOptionsCameraRaw
public __gc class LoadOptionsCameraRaw
public ref class LoadOptionsCameraRaw
Inheritance Hierarchy

System.Object
Accusoft.ImagXpressSdk.LoadOptionsCameraRaw

See Also

Reference

LoadOptionsCameraRaw Members
Accusoft.ImagXpressSdk Namespace


LoadOptionsCameraRaw Class Members

LoadOptionsCameraRaw Class Members
Properties

Accusoft.ImagXpressSdk Namespace : LoadOptionsCameraRaw Class

The following tables list the members exposed by LoadOptionsCameraRaw.

Public Constructors
 | Name | Description
Public Constructor | LoadOptionsCameraRaw Constructor | The main constructor for the LoadOptionsCameraRaw class.
Top
Public Properties
 | Name | Description
Public Property | AutoBrightnessAndContrast | When loading a camera raw image, ImagXpress will normally adjust the brightness and contrast automatically. If you'd prefer this not to happen, or if you want to provide your own BrightnessFactor, set to false.
Public Property | BlueFactor | Blue samples in each pixel will be multiplied by this value after white balancing. This allows for white to be manually balanced or for additional adjustment to be applied after automatic processing. Valid values are 0 (indicating nothing should be done) or .01 to 100.0.
Public Property | BrightnessFactor | The brightness of each pixel will be multiplied using this factor. Valid values are 0 (indicating nothing should be done) or .01 to 100.0. To effectively use this parameter, AutoBrightnessAndContrast should be set to false.
Public Property | ClipHighlightsToWhite | Ordinarily ImagXpress will automatically adjust highlight data to compensate for differences in sensitivity between the individual red, green, and blue channels, ensuring that image highlights always look white. Within a single pixel, it is not uncommon for some color channels to saturate before others, typically resulting in image highlights that look slightly pink. If, instead of compensating to produce white highlights, you prefer to retain the additional data that’s available in the individual color channels of highlight pixels, set to false.
Public Property | ConvertTosRGB | Ordinarily ImagXpress will convert RGB camera images to sRGB. To leave the camera images in their native RGB colorspace and ignore possible camera color space differences, set this property to false.
Public Property | GammaCorrection | Gamma correction value to apply to each pixel. Valid values are 0.0 (indicating nothing should be done) or .1 to 10.0.
Public Property | RedFactor | Red samples in each pixel will be multiplied by this value after white balancing. This allows for white to be manually balanced or for additional adjustment to be applied after automatic processing. Valid values are 0 (indicating nothing should be done) or .01 to 100.0.
Public Property | RemoveRotation | Fuji Super CCD raw images are rotated 45 degrees due to the nature of the physical device used to capture the image. Normally ImagXpress removes the rotation. Set this property to false to leave the image rotated.
Public Property | ReturnThumbnail | Some raw images contain thumbnail images. When set to true, ImagXpress will return the thumbnail image instead of the full-size image.
Public Property | UseFastInterpolationMethod | Ordinarily ImagXpress uses a high-quality interpolation method. When this property is set to true a faster, but lower quality method is used. Interpolation affects boundaries and fine detail.
Public Property | UseHalfSizeImage | When true the resulting image is reduced by half in each dimension, resulting in one quarter of the original number of pixels. This can be much faster than producing a full size image.
Public Property | UseSecondaryPixels | Fuji Super CCD SR images have two sets of pixels: a primary set and a less sensitive secondary set. Normally ImagXpress will use the primary set, but the secondary set can be used by setting this property to true. Uses secondary pixels if available, which are less sensitive to light and will produce an image that is darker but which has more detail in bright areas.
Public Property | WhiteBalanceMethod | Gets or sets the white balance method which is used to balance the white in the image.
Top
See Also

Reference

LoadOptionsCameraRaw Class
Accusoft.ImagXpressSdk Namespace


LoadOptionsCameraRaw Constructor

LoadOptionsCameraRaw Constructor

Accusoft.ImagXpressSdk Namespace > LoadOptionsCameraRaw Class : LoadOptionsCameraRaw Constructor
The main constructor for the LoadOptionsCameraRaw class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New LoadOptionsCameraRaw()
public LoadOptionsCameraRaw()
public: LoadOptionsCameraRaw();
public:
LoadOptionsCameraRaw();
See Also

Reference

LoadOptionsCameraRaw Class
LoadOptionsCameraRaw Members


LoadOptionsCameraRaw Class Properties

LoadOptionsCameraRaw Class Properties

Accusoft.ImagXpressSdk Namespace : LoadOptionsCameraRaw Class

For a list of all members of this type, see LoadOptionsCameraRaw members.

Public Properties
 | Name | Description
Public Property | AutoBrightnessAndContrast | When loading a camera raw image, ImagXpress will normally adjust the brightness and contrast automatically. If you'd prefer this not to happen, or if you want to provide your own BrightnessFactor, set to false.
Public Property | BlueFactor | Blue samples in each pixel will be multiplied by this value after white balancing. This allows for white to be manually balanced or for additional adjustment to be applied after automatic processing. Valid values are 0 (indicating nothing should be done) or .01 to 100.0.
Public Property | BrightnessFactor | The brightness of each pixel will be multiplied using this factor. Valid values are 0 (indicating nothing should be done) or .01 to 100.0. To effectively use this parameter, AutoBrightnessAndContrast should be set to false.
Public Property | ClipHighlightsToWhite | Ordinarily ImagXpress will automatically adjust highlight data to compensate for differences in sensitivity between the individual red, green, and blue channels, ensuring that image highlights always look white. Within a single pixel, it is not uncommon for some color channels to saturate before others, typically resulting in image highlights that look slightly pink. If, instead of compensating to produce white highlights, you prefer to retain the additional data that’s available in the individual color channels of highlight pixels, set to false.
Public Property | ConvertTosRGB | Ordinarily ImagXpress will convert RGB camera images to sRGB. To leave the camera images in their native RGB colorspace and ignore possible camera color space differences, set this property to false.
Public Property | GammaCorrection | Gamma correction value to apply to each pixel. Valid values are 0.0 (indicating nothing should be done) or .1 to 10.0.
Public Property | RedFactor | Red samples in each pixel will be multiplied by this value after white balancing. This allows for white to be manually balanced or for additional adjustment to be applied after automatic processing. Valid values are 0 (indicating nothing should be done) or .01 to 100.0.
Public Property | RemoveRotation | Fuji Super CCD raw images are rotated 45 degrees due to the nature of the physical device used to capture the image. Normally ImagXpress removes the rotation. Set this property to false to leave the image rotated.
Public Property | ReturnThumbnail | Some raw images contain thumbnail images. When set to true, ImagXpress will return the thumbnail image instead of the full-size image.
Public Property | UseFastInterpolationMethod | Ordinarily ImagXpress uses a high-quality interpolation method. When this property is set to true a faster, but lower quality method is used. Interpolation affects boundaries and fine detail.
Public Property | UseHalfSizeImage | When true the resulting image is reduced by half in each dimension, resulting in one quarter of the original number of pixels. This can be much faster than producing a full size image.
Public Property | UseSecondaryPixels | Fuji Super CCD SR images have two sets of pixels: a primary set and a less sensitive secondary set. Normally ImagXpress will use the primary set, but the secondary set can be used by setting this property to true. Uses secondary pixels if available, which are less sensitive to light and will produce an image that is darker but which has more detail in bright areas.
Public Property | WhiteBalanceMethod | Gets or sets the white balance method which is used to balance the white in the image.
Top
See Also

Reference

LoadOptionsCameraRaw Class
Accusoft.ImagXpressSdk Namespace


AutoBrightnessAndContrast Property

AutoBrightnessAndContrast Property

Accusoft.ImagXpressSdk Namespace > LoadOptionsCameraRaw Class : AutoBrightnessAndContrast Property
When loading a camera raw image, ImagXpress will normally adjust the brightness and contrast automatically. If you'd prefer this not to happen, or if you want to provide your own BrightnessFactor, set to false.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AutoBrightnessAndContrast As Boolean
'Usage

Dim instance As LoadOptionsCameraRaw
Dim value As Boolean

instance.AutoBrightnessAndContrast = value

value = instance.AutoBrightnessAndContrast
public bool AutoBrightnessAndContrast {get; set;}
public: __property bool get_AutoBrightnessAndContrast();
public: __property void set_AutoBrightnessAndContrast(
   bool value
);
public:
property bool AutoBrightnessAndContrast {
   bool get();
   void set (    bool value);
}
Remarks
The default value is true.
See Also

Reference

LoadOptionsCameraRaw Class
LoadOptionsCameraRaw Members


BlueFactor Property

BlueFactor Property

Accusoft.ImagXpressSdk Namespace > LoadOptionsCameraRaw Class : BlueFactor Property
Blue samples in each pixel will be multiplied by this value after white balancing. This allows for white to be manually balanced or for additional adjustment to be applied after automatic processing. Valid values are 0 (indicating nothing should be done) or .01 to 100.0.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BlueFactor As Double
'Usage

Dim instance As LoadOptionsCameraRaw
Dim value As Double

instance.BlueFactor = value

value = instance.BlueFactor
public double BlueFactor {get; set;}
public: __property double get_BlueFactor();
public: __property void set_BlueFactor(
   double value
);
public:
property double BlueFactor {
   double get();
   void set (    double value);
}
Remarks
The default value is 0.
See Also

Reference

LoadOptionsCameraRaw Class
LoadOptionsCameraRaw Members


BrightnessFactor Property

BrightnessFactor Property

Accusoft.ImagXpressSdk Namespace > LoadOptionsCameraRaw Class : BrightnessFactor Property
The brightness of each pixel will be multiplied using this factor. Valid values are 0 (indicating nothing should be done) or .01 to 100.0. To effectively use this parameter, AutoBrightnessAndContrast should be set to false.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BrightnessFactor As Double
'Usage

Dim instance As LoadOptionsCameraRaw
Dim value As Double

instance.BrightnessFactor = value

value = instance.BrightnessFactor
public double BrightnessFactor {get; set;}
public: __property double get_BrightnessFactor();
public: __property void set_BrightnessFactor(
   double value
);
public:
property double BrightnessFactor {
   double get();
   void set (    double value);
}
Remarks
The default value is 0.
See Also

Reference

LoadOptionsCameraRaw Class
LoadOptionsCameraRaw Members


ClipHighlightsToWhite Property

ClipHighlightsToWhite Property

Accusoft.ImagXpressSdk Namespace > LoadOptionsCameraRaw Class : ClipHighlightsToWhite Property
Ordinarily ImagXpress will automatically adjust highlight data to compensate for differences in sensitivity between the individual red, green, and blue channels, ensuring that image highlights always look white. Within a single pixel, it is not uncommon for some color channels to saturate before others, typically resulting in image highlights that look slightly pink. If, instead of compensating to produce white highlights, you prefer to retain the additional data that’s available in the individual color channels of highlight pixels, set to false.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ClipHighlightsToWhite As Boolean
'Usage

Dim instance As LoadOptionsCameraRaw
Dim value As Boolean

instance.ClipHighlightsToWhite = value

value = instance.ClipHighlightsToWhite
public bool ClipHighlightsToWhite {get; set;}
public: __property bool get_ClipHighlightsToWhite();
public: __property void set_ClipHighlightsToWhite(
   bool value
);
public:
property bool ClipHighlightsToWhite {
   bool get();
   void set (    bool value);
}
Remarks
The default value is true.
See Also

Reference

LoadOptionsCameraRaw Class
LoadOptionsCameraRaw Members


ConvertTosRGB Property

ConvertTosRGB Property

Accusoft.ImagXpressSdk Namespace > LoadOptionsCameraRaw Class : ConvertTosRGB Property
Ordinarily ImagXpress will convert RGB camera images to sRGB. To leave the camera images in their native RGB colorspace and ignore possible camera color space differences, set this property to false.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ConvertTosRGB As Boolean
'Usage

Dim instance As LoadOptionsCameraRaw
Dim value As Boolean

instance.ConvertTosRGB = value

value = instance.ConvertTosRGB
public bool ConvertTosRGB {get; set;}
public: __property bool get_ConvertTosRGB();
public: __property void set_ConvertTosRGB(
   bool value
);
public:
property bool ConvertTosRGB {
   bool get();
   void set (    bool value);
}
Remarks
The default value is true.
See Also

Reference

LoadOptionsCameraRaw Class
LoadOptionsCameraRaw Members


GammaCorrection Property

GammaCorrection Property

Accusoft.ImagXpressSdk Namespace > LoadOptionsCameraRaw Class : GammaCorrection Property
Gamma correction value to apply to each pixel. Valid values are 0.0 (indicating nothing should be done) or .1 to 10.0.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property GammaCorrection As Double
'Usage

Dim instance As LoadOptionsCameraRaw
Dim value As Double

instance.GammaCorrection = value

value = instance.GammaCorrection
public double GammaCorrection {get; set;}
public: __property double get_GammaCorrection();
public: __property void set_GammaCorrection(
   double value
);
public:
property double GammaCorrection {
   double get();
   void set (    double value);
}
Remarks
The default value is 0.
See Also

Reference

LoadOptionsCameraRaw Class
LoadOptionsCameraRaw Members


RedFactor Property

RedFactor Property

Accusoft.ImagXpressSdk Namespace > LoadOptionsCameraRaw Class : RedFactor Property
Red samples in each pixel will be multiplied by this value after white balancing. This allows for white to be manually balanced or for additional adjustment to be applied after automatic processing. Valid values are 0 (indicating nothing should be done) or .01 to 100.0.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property RedFactor As Double
'Usage

Dim instance As LoadOptionsCameraRaw
Dim value As Double

instance.RedFactor = value

value = instance.RedFactor
public double RedFactor {get; set;}
public: __property double get_RedFactor();
public: __property void set_RedFactor(
   double value
);
public:
property double RedFactor {
   double get();
   void set (    double value);
}
Remarks
The default value is 0.
See Also

Reference

LoadOptionsCameraRaw Class
LoadOptionsCameraRaw Members


RemoveRotation Property

RemoveRotation Property

Accusoft.ImagXpressSdk Namespace > LoadOptionsCameraRaw Class : RemoveRotation Property
Fuji Super CCD raw images are rotated 45 degrees due to the nature of the physical device used to capture the image. Normally ImagXpress removes the rotation. Set this property to false to leave the image rotated.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property RemoveRotation As Boolean
'Usage

Dim instance As LoadOptionsCameraRaw
Dim value As Boolean

instance.RemoveRotation = value

value = instance.RemoveRotation
public bool RemoveRotation {get; set;}
public: __property bool get_RemoveRotation();
public: __property void set_RemoveRotation(
   bool value
);
public:
property bool RemoveRotation {
   bool get();
   void set (    bool value);
}
Remarks
The default value is true.
See Also

Reference

LoadOptionsCameraRaw Class
LoadOptionsCameraRaw Members


ReturnThumbnail Property

ReturnThumbnail Property

Accusoft.ImagXpressSdk Namespace > LoadOptionsCameraRaw Class : ReturnThumbnail Property
Some raw images contain thumbnail images. When set to true, ImagXpress will return the thumbnail image instead of the full-size image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ReturnThumbnail As Boolean
'Usage

Dim instance As LoadOptionsCameraRaw
Dim value As Boolean

instance.ReturnThumbnail = value

value = instance.ReturnThumbnail
public bool ReturnThumbnail {get; set;}
public: __property bool get_ReturnThumbnail();
public: __property void set_ReturnThumbnail(
   bool value
);
public:
property bool ReturnThumbnail {
   bool get();
   void set (    bool value);
}
Remarks
The default value is false.
See Also

Reference

LoadOptionsCameraRaw Class
LoadOptionsCameraRaw Members


UseFastInterpolationMethod Property

UseFastInterpolationMethod Property

Accusoft.ImagXpressSdk Namespace > LoadOptionsCameraRaw Class : UseFastInterpolationMethod Property
Ordinarily ImagXpress uses a high-quality interpolation method. When this property is set to true a faster, but lower quality method is used. Interpolation affects boundaries and fine detail.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property UseFastInterpolationMethod As Boolean
'Usage

Dim instance As LoadOptionsCameraRaw
Dim value As Boolean

instance.UseFastInterpolationMethod = value

value = instance.UseFastInterpolationMethod
public bool UseFastInterpolationMethod {get; set;}
public: __property bool get_UseFastInterpolationMethod();
public: __property void set_UseFastInterpolationMethod(
   bool value
);
public:
property bool UseFastInterpolationMethod {
   bool get();
   void set (    bool value);
}
Remarks
The default value is false.
See Also

Reference

LoadOptionsCameraRaw Class
LoadOptionsCameraRaw Members


UseHalfSizeImage Property

UseHalfSizeImage Property

Accusoft.ImagXpressSdk Namespace > LoadOptionsCameraRaw Class : UseHalfSizeImage Property
When true the resulting image is reduced by half in each dimension, resulting in one quarter of the original number of pixels. This can be much faster than producing a full size image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property UseHalfSizeImage As Boolean
'Usage

Dim instance As LoadOptionsCameraRaw
Dim value As Boolean

instance.UseHalfSizeImage = value

value = instance.UseHalfSizeImage
public bool UseHalfSizeImage {get; set;}
public: __property bool get_UseHalfSizeImage();
public: __property void set_UseHalfSizeImage(
   bool value
);
public:
property bool UseHalfSizeImage {
   bool get();
   void set (    bool value);
}
Remarks
The default value is false.
See Also

Reference

LoadOptionsCameraRaw Class
LoadOptionsCameraRaw Members


UseSecondaryPixels Property

UseSecondaryPixels Property

Accusoft.ImagXpressSdk Namespace > LoadOptionsCameraRaw Class : UseSecondaryPixels Property
Fuji Super CCD SR images have two sets of pixels: a primary set and a less sensitive secondary set. Normally ImagXpress will use the primary set, but the secondary set can be used by setting this property to true. Uses secondary pixels if available, which are less sensitive to light and will produce an image that is darker but which has more detail in bright areas.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property UseSecondaryPixels As Boolean
'Usage

Dim instance As LoadOptionsCameraRaw
Dim value As Boolean

instance.UseSecondaryPixels = value

value = instance.UseSecondaryPixels
public bool UseSecondaryPixels {get; set;}
public: __property bool get_UseSecondaryPixels();
public: __property void set_UseSecondaryPixels(
   bool value
);
public:
property bool UseSecondaryPixels {
   bool get();
   void set (    bool value);
}
Remarks
The default value is false.
See Also

Reference

LoadOptionsCameraRaw Class
LoadOptionsCameraRaw Members


WhiteBalanceMethod Property

WhiteBalanceMethod Property

Accusoft.ImagXpressSdk Namespace > LoadOptionsCameraRaw Class : WhiteBalanceMethod Property
Gets or sets the white balance method which is used to balance the white in the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property WhiteBalanceMethod As WhiteBalanceMethod
'Usage

Dim instance As LoadOptionsCameraRaw
Dim value As WhiteBalanceMethod

instance.WhiteBalanceMethod = value

value = instance.WhiteBalanceMethod
public WhiteBalanceMethod WhiteBalanceMethod {get; set;}
public: __property WhiteBalanceMethod get_WhiteBalanceMethod();
public: __property void set_WhiteBalanceMethod(
   WhiteBalanceMethod value
);
public:
property WhiteBalanceMethod WhiteBalanceMethod {
   WhiteBalanceMethod get();
   void set (    WhiteBalanceMethod value);
}

Property Value

The WhiteBalanceMethod which represents the white-balancing method.
Remarks
The default value is Camera.
See Also

Reference

LoadOptionsCameraRaw Class
LoadOptionsCameraRaw Members


LoadOptionsJbig2 Class

LoadOptionsJbig2 Class
Members

Accusoft.ImagXpressSdk Namespace : LoadOptionsJbig2 Class
This class implements load options for the Jbig2 file format.
Object Model
LoadOptionsJbig2 Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class LoadOptionsJbig2
'Usage

Dim instance As LoadOptionsJbig2
public class LoadOptionsJbig2
public __gc class LoadOptionsJbig2
public ref class LoadOptionsJbig2
Inheritance Hierarchy

System.Object
Accusoft.ImagXpressSdk.LoadOptionsJbig2

See Also

Reference

LoadOptionsJbig2 Members
Accusoft.ImagXpressSdk Namespace


LoadOptionsJbig2 Class Members

LoadOptionsJbig2 Class Members
Properties

Accusoft.ImagXpressSdk Namespace : LoadOptionsJbig2 Class

The following tables list the members exposed by LoadOptionsJbig2.

Public Constructors
 | Name | Description
Public Constructor | LoadOptionsJbig2 Constructor | The main constructor to initialize the LoadOptionsJbig2 object.
Top
Public Properties
 | Name | Description
Public Property | SwapBlackAndWhite | Gets and sets an indicator which determines to use industry black and white defaults.
Top
See Also

Reference

LoadOptionsJbig2 Class
Accusoft.ImagXpressSdk Namespace


LoadOptionsJbig2 Constructor

LoadOptionsJbig2 Constructor

Accusoft.ImagXpressSdk Namespace > LoadOptionsJbig2 Class : LoadOptionsJbig2 Constructor
The main constructor to initialize the LoadOptionsJbig2 object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New LoadOptionsJbig2()
public LoadOptionsJbig2()
public: LoadOptionsJbig2();
public:
LoadOptionsJbig2();
See Also

Reference

LoadOptionsJbig2 Class
LoadOptionsJbig2 Members


LoadOptionsJbig2 Class Properties

LoadOptionsJbig2 Class Properties

Accusoft.ImagXpressSdk Namespace : LoadOptionsJbig2 Class

For a list of all members of this type, see LoadOptionsJbig2 members.

Public Properties
 | Name | Description
Public Property | SwapBlackAndWhite | Gets and sets an indicator which determines to use industry black and white defaults.
Top
See Also

Reference

LoadOptionsJbig2 Class
Accusoft.ImagXpressSdk Namespace


SwapBlackAndWhite Property (LoadOptionsJbig2)

SwapBlackAndWhite Property (LoadOptionsJbig2)

Accusoft.ImagXpressSdk Namespace > LoadOptionsJbig2 Class : SwapBlackAndWhite Property
Gets and sets an indicator which determines to use industry black and white defaults.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SwapBlackAndWhite As Boolean
'Usage

Dim instance As LoadOptionsJbig2
Dim value As Boolean

instance.SwapBlackAndWhite = value

value = instance.SwapBlackAndWhite
public bool SwapBlackAndWhite {get; set;}
public: __property bool get_SwapBlackAndWhite();
public: __property void set_SwapBlackAndWhite(
   bool value
);
public:
property bool SwapBlackAndWhite {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true to use industry black and white defaults. Otherwise, false is returned.
Remarks

The default value is false.

false (0) - Black is zero and white is one.

true (1) - White is zero and black is one.

See Also

Reference

LoadOptionsJbig2 Class
LoadOptionsJbig2 Members


LoadOptionsJpeg Class

LoadOptionsJpeg Class
Members

Accusoft.ImagXpressSdk Namespace : LoadOptionsJpeg Class
This class implements load options for the JPEG file format.
Object Model
LoadOptionsJpeg Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class LoadOptionsJpeg
'Usage

Dim instance As LoadOptionsJpeg
public class LoadOptionsJpeg
public __gc class LoadOptionsJpeg
public ref class LoadOptionsJpeg
Inheritance Hierarchy

System.Object
Accusoft.ImagXpressSdk.LoadOptionsJpeg

See Also

Reference

LoadOptionsJpeg Members
Accusoft.ImagXpressSdk Namespace


LoadOptionsJpeg Class Members

LoadOptionsJpeg Class Members
Properties

Accusoft.ImagXpressSdk Namespace : LoadOptionsJpeg Class

The following tables list the members exposed by LoadOptionsJpeg.

Public Constructors
 | Name | Description
Public Constructor | LoadOptionsJpeg Constructor | The main constructor for the LoadOptionsJpeg class.
Top
Public Properties
 | Name | Description
Public Property | Cosited | Gets and sets if the image was compressed with cosited subsampling.
Public Property | Enhanced | Gets and sets the JPEG enhanced decompression flag indicating whether to use standard decoding or Accusoft enhanced decoding.
Top
See Also

Reference

LoadOptionsJpeg Class
Accusoft.ImagXpressSdk Namespace


LoadOptionsJpeg Constructor

LoadOptionsJpeg Constructor

Accusoft.ImagXpressSdk Namespace > LoadOptionsJpeg Class : LoadOptionsJpeg Constructor
The main constructor for the LoadOptionsJpeg class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New LoadOptionsJpeg()
public LoadOptionsJpeg()
public: LoadOptionsJpeg();
public:
LoadOptionsJpeg();
See Also

Reference

LoadOptionsJpeg Class
LoadOptionsJpeg Members


LoadOptionsJpeg Class Properties

LoadOptionsJpeg Class Properties

Accusoft.ImagXpressSdk Namespace : LoadOptionsJpeg Class

For a list of all members of this type, see LoadOptionsJpeg members.

Public Properties
 | Name | Description
Public Property | Cosited | Gets and sets if the image was compressed with cosited subsampling.
Public Property | Enhanced | Gets and sets the JPEG enhanced decompression flag indicating whether to use standard decoding or Accusoft enhanced decoding.
Top
See Also

Reference

LoadOptionsJpeg Class
Accusoft.ImagXpressSdk Namespace


Cosited Property (LoadOptionsJpeg)

Cosited Property (LoadOptionsJpeg)

Accusoft.ImagXpressSdk Namespace > LoadOptionsJpeg Class : Cosited Property
Gets and sets if the image was compressed with cosited subsampling.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Cosited As Boolean
'Usage

Dim instance As LoadOptionsJpeg
Dim value As Boolean

instance.Cosited = value

value = instance.Cosited
public bool Cosited {get; set;}
public: __property bool get_Cosited();
public: __property void set_Cosited(
   bool value
);
public:
property bool Cosited {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true if the image was compressed with cosited subsampling. Otherwise, false is returned.
Remarks

There is no flag in JPEG files to indicate compression with cosited (2-1-1) subsampling. Therefore, this fact must be determined independently by the application performing the file load method.

See Also

Reference

LoadOptionsJpeg Class
LoadOptionsJpeg Members


Enhanced Property

Enhanced Property

Accusoft.ImagXpressSdk Namespace > LoadOptionsJpeg Class : Enhanced Property
Gets and sets the JPEG enhanced decompression flag indicating whether to use standard decoding or Accusoft enhanced decoding.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Enhanced As Boolean
'Usage

Dim instance As LoadOptionsJpeg
Dim value As Boolean

instance.Enhanced = value

value = instance.Enhanced
public bool Enhanced {get; set;}
public: __property bool get_Enhanced();
public: __property void set_Enhanced(
   bool value
);
public:
property bool Enhanced {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true for the JPEG decoder to use the enhanced method to give a smoother image. If false is set, the JPEG decoder uses the standard method to decode the JPEG image.
Remarks

This property enables advanced Accusoft technology that provides significantly better image viewing for highly compressed sequential JPEG images.

The following features are enabled:

  • Clean up low frequency contouring.
  • Clean up low frequency artifacts.
  • Clean up block edge artifacts.
See Also

Reference

LoadOptionsJpeg Class
LoadOptionsJpeg Members


LoadOptionsJpegXR Class

LoadOptionsJpegXR Class
Members

Accusoft.ImagXpressSdk Namespace : LoadOptionsJpegXR Class
This class implements load options for the JPEG-XR format.
Object Model
LoadOptionsJpegXR Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class LoadOptionsJpegXR
'Usage

Dim instance As LoadOptionsJpegXR
public class LoadOptionsJpegXR
public __gc class LoadOptionsJpegXR
public ref class LoadOptionsJpegXR
Inheritance Hierarchy

System.Object
Accusoft.ImagXpressSdk.LoadOptionsJpegXR

See Also

Reference

LoadOptionsJpegXR Members
Accusoft.ImagXpressSdk Namespace


LoadOptionsJpegXR Class Members

LoadOptionsJpegXR Class Members
Properties

Accusoft.ImagXpressSdk Namespace : LoadOptionsJpegXR Class

The following tables list the members exposed by LoadOptionsJpegXR.

Public Constructors
 | Name | Description
Public Constructor | LoadOptionsJpegXR Constructor | The main constructor for the LoadOptionsJpegXR class.
Top
Public Properties
 | Name | Description
Public Property | PostProcessingFilter | Gets or sets the post processing filter which is used to smooth compression artificacts.
Top
See Also

Reference

LoadOptionsJpegXR Class
Accusoft.ImagXpressSdk Namespace


LoadOptionsJpegXR Constructor

LoadOptionsJpegXR Constructor

Accusoft.ImagXpressSdk Namespace > LoadOptionsJpegXR Class : LoadOptionsJpegXR Constructor
The main constructor for the LoadOptionsJpegXR class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New LoadOptionsJpegXR()
public LoadOptionsJpegXR()
public: LoadOptionsJpegXR();
public:
LoadOptionsJpegXR();
See Also

Reference

LoadOptionsJpegXR Class
LoadOptionsJpegXR Members


LoadOptionsJpegXR Class Properties

LoadOptionsJpegXR Class Properties

Accusoft.ImagXpressSdk Namespace : LoadOptionsJpegXR Class

For a list of all members of this type, see LoadOptionsJpegXR members.

Public Properties
 | Name | Description
Public Property | PostProcessingFilter | Gets or sets the post processing filter which is used to smooth compression artificacts.
Top
See Also

Reference

LoadOptionsJpegXR Class
Accusoft.ImagXpressSdk Namespace


PostProcessingFilter Property

PostProcessingFilter Property

Accusoft.ImagXpressSdk Namespace > LoadOptionsJpegXR Class : PostProcessingFilter Property
Gets or sets the post processing filter which is used to smooth compression artificacts.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PostProcessingFilter As JpegXRPostProcessFilter
'Usage

Dim instance As LoadOptionsJpegXR
Dim value As JpegXRPostProcessFilter

instance.PostProcessingFilter = value

value = instance.PostProcessingFilter
public JpegXRPostProcessFilter PostProcessingFilter {get; set;}
public: __property JpegXRPostProcessFilter get_PostProcessingFilter();
public: __property void set_PostProcessingFilter(
   JpegXRPostProcessFilter value
);
public:
property JpegXRPostProcessFilter PostProcessingFilter {
   JpegXRPostProcessFilter get();
   void set (    JpegXRPostProcessFilter value);
}

Property Value

The JpegXRPostProcessFilter which represents the post processing filter.
See Also

Reference

LoadOptionsJpegXR Class
LoadOptionsJpegXR Members


LoadOptionsMetafile Class

LoadOptionsMetafile Class
Members

Accusoft.ImagXpressSdk Namespace : LoadOptionsMetafile Class
This class implements load options for metafiles.
Object Model
LoadOptionsMetafile ClassResolution Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class LoadOptionsMetafile
'Usage

Dim instance As LoadOptionsMetafile
public class LoadOptionsMetafile
public __gc class LoadOptionsMetafile
public ref class LoadOptionsMetafile
Inheritance Hierarchy

System.Object
Accusoft.ImagXpressSdk.LoadOptionsMetafile

See Also

Reference

LoadOptionsMetafile Members
Accusoft.ImagXpressSdk Namespace


LoadOptionsMetafile Class Members

LoadOptionsMetafile Class Members
Fields Properties

Accusoft.ImagXpressSdk Namespace : LoadOptionsMetafile Class

The following tables list the members exposed by LoadOptionsMetafile.

Public Constructors
 | Name | Description
Public Constructor | LoadOptionsMetafile Constructor | The main constructor for initializing the LoadOptionsMetafile class.
Top
Public Fields
 | Name | Description
Public Field | DefaultHoriztonalResolution | A constant value which represents the default horizontal resolution.
Public Field | DefaultUnits | A constant value which represents the default graphics unit.
Public Field | DefaultVerticalResolution | A constant value which represents the default vertical resolution.
Top
Public Properties
 | Name | Description
Public Property | Resolution | Gets and sets the resolution at which to load the image.
Top
See Also

Reference

LoadOptionsMetafile Class
Accusoft.ImagXpressSdk Namespace


LoadOptionsMetafile Constructor

LoadOptionsMetafile Constructor

Accusoft.ImagXpressSdk Namespace > LoadOptionsMetafile Class : LoadOptionsMetafile Constructor
The main constructor for initializing the LoadOptionsMetafile class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New LoadOptionsMetafile()
public LoadOptionsMetafile()
public: LoadOptionsMetafile();
public:
LoadOptionsMetafile();
See Also

Reference

LoadOptionsMetafile Class
LoadOptionsMetafile Members


LoadOptionsMetafile Class Properties

LoadOptionsMetafile Class Properties

Accusoft.ImagXpressSdk Namespace : LoadOptionsMetafile Class

For a list of all members of this type, see LoadOptionsMetafile members.

Public Properties
 | Name | Description
Public Property | Resolution | Gets and sets the resolution at which to load the image.
Top
See Also

Reference

LoadOptionsMetafile Class
Accusoft.ImagXpressSdk Namespace


Resolution Property (LoadOptionsMetafile)

Resolution Property (LoadOptionsMetafile)

Accusoft.ImagXpressSdk Namespace > LoadOptionsMetafile Class : Resolution Property
Gets and sets the resolution at which to load the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Resolution As Resolution
'Usage

Dim instance As LoadOptionsMetafile
Dim value As Resolution

instance.Resolution = value

value = instance.Resolution
public Resolution Resolution {get; set;}
public: __property Resolution* get_Resolution();
public: __property void set_Resolution(
   Resolution* value
);
public:
property Resolution^ Resolution {
   Resolution^ get();
   void set (    Resolution^ value);
}

Property Value

The Resolution for loading the image.
See Also

Reference

LoadOptionsMetafile Class
LoadOptionsMetafile Members


LoadOptionsMetafile Class Fields

LoadOptionsMetafile Class Fields

Accusoft.ImagXpressSdk Namespace : LoadOptionsMetafile Class

For a list of all members of this type, see LoadOptionsMetafile members.

Public Fields
 | Name | Description
Public Field | DefaultHoriztonalResolution | A constant value which represents the default horizontal resolution.
Public Field | DefaultUnits | A constant value which represents the default graphics unit.
Public Field | DefaultVerticalResolution | A constant value which represents the default vertical resolution.
Top
See Also

Reference

LoadOptionsMetafile Class
Accusoft.ImagXpressSdk Namespace


DefaultHoriztonalResolution Field

DefaultHoriztonalResolution Field

Accusoft.ImagXpressSdk Namespace > LoadOptionsMetafile Class : DefaultHoriztonalResolution Field
A constant value which represents the default horizontal resolution.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Const DefaultHoriztonalResolution As Single
'Usage

Dim value As Single

value = LoadOptionsMetafile.DefaultHoriztonalResolution
public const float DefaultHoriztonalResolution
public: const float DefaultHoriztonalResolution
public:
const float DefaultHoriztonalResolution

Field Value

A float value which represents the horitonzal resolution.
Remarks

The default value is 100.0f.

See Also

Reference

LoadOptionsMetafile Class
LoadOptionsMetafile Members


DefaultUnits Field

DefaultUnits Field

Accusoft.ImagXpressSdk Namespace > LoadOptionsMetafile Class : DefaultUnits Field
A constant value which represents the default graphics unit.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Const DefaultUnits As GraphicsUnit
'Usage

Dim value As GraphicsUnit

value = LoadOptionsMetafile.DefaultUnits
public const GraphicsUnit DefaultUnits
public: const GraphicsUnit DefaultUnits
public:
const GraphicsUnit DefaultUnits

Field Value

A float value which represents the horitonzal resolution.
Remarks

The default value is 100.0f.

See Also

Reference

LoadOptionsMetafile Class
LoadOptionsMetafile Members


DefaultVerticalResolution Field

DefaultVerticalResolution Field

Accusoft.ImagXpressSdk Namespace > LoadOptionsMetafile Class : DefaultVerticalResolution Field
A constant value which represents the default vertical resolution.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Const DefaultVerticalResolution As Single
'Usage

Dim value As Single

value = LoadOptionsMetafile.DefaultVerticalResolution
public const float DefaultVerticalResolution
public: const float DefaultVerticalResolution
public:
const float DefaultVerticalResolution

Field Value

A System.Drawing.GraphicsUnit value which represents the default units.
Remarks

The default value is 100.0f.

See Also

Reference

LoadOptionsMetafile Class
LoadOptionsMetafile Members


LoadOptionsPdf Class

LoadOptionsPdf Class
Members

Accusoft.ImagXpressSdk Namespace : LoadOptionsPdf Class
This class implements load options for PDF files.
Object Model
LoadOptionsPdf Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.")>
Public Class LoadOptionsPdf
'Usage

Dim instance As LoadOptionsPdf
[Obsolete("PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.")]
public class LoadOptionsPdf
[Obsolete("PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.")]
public __gc class LoadOptionsPdf
[Obsolete("PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.")]
public ref class LoadOptionsPdf
Remarks

Note: PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.

Inheritance Hierarchy

System.Object
Accusoft.ImagXpressSdk.LoadOptionsPdf

See Also

Reference

LoadOptionsPdf Members
Accusoft.ImagXpressSdk Namespace


LoadOptionsPdf Class Members

LoadOptionsPdf Class Members
Properties

Accusoft.ImagXpressSdk Namespace : LoadOptionsPdf Class

The following tables list the members exposed by LoadOptionsPdf.

Public Constructors
 | Name | Description
Public Constructor | LoadOptionsPdf Constructor | The main constructor for the LoadOptionsPdf class.
Top
Public Properties
 | Name | Description
Public Property | SwapBlackAndWhite | Gets and sets a pixel value of zero to black or white.
Top
See Also

Reference

LoadOptionsPdf Class
Accusoft.ImagXpressSdk Namespace


LoadOptionsPdf Constructor

LoadOptionsPdf Constructor

Accusoft.ImagXpressSdk Namespace > LoadOptionsPdf Class : LoadOptionsPdf Constructor
The main constructor for the LoadOptionsPdf class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.")>
Public Function New()
'Usage

Dim instance As New LoadOptionsPdf()
[Obsolete("PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.")]
public LoadOptionsPdf()
[Obsolete("PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.")]
public: LoadOptionsPdf();
[Obsolete("PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.")]
public:
LoadOptionsPdf();
Remarks

Note: PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.

See Also

Reference

LoadOptionsPdf Class
LoadOptionsPdf Members


LoadOptionsPdf Class Properties

LoadOptionsPdf Class Properties

Accusoft.ImagXpressSdk Namespace : LoadOptionsPdf Class

For a list of all members of this type, see LoadOptionsPdf members.

Public Properties
 | Name | Description
Public Property | SwapBlackAndWhite | Gets and sets a pixel value of zero to black or white.
Top
See Also

Reference

LoadOptionsPdf Class
Accusoft.ImagXpressSdk Namespace


SwapBlackAndWhite Property (LoadOptionsPdf)

SwapBlackAndWhite Property (LoadOptionsPdf)

Accusoft.ImagXpressSdk Namespace > LoadOptionsPdf Class : SwapBlackAndWhite Property
Gets and sets a pixel value of zero to black or white.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.")>
Public Property SwapBlackAndWhite As Boolean
'Usage

Dim instance As LoadOptionsPdf
Dim value As Boolean

instance.SwapBlackAndWhite = value

value = instance.SwapBlackAndWhite
[Obsolete("PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.")]
public bool SwapBlackAndWhite {get; set;}
[Obsolete("PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.")]
public: __property bool get_SwapBlackAndWhite();
public: __property void set_SwapBlackAndWhite(
   bool value
);
[Obsolete("PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.")]
public:
property bool SwapBlackAndWhite {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true when the definition of black and white are reversed when loading the image: 1 = black and 0 = white. Otherwise, false is returned.
Remarks
This property pertains only to the G4 (CCITT fax protocol) compression type.

Note: PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.

See Also

Reference

LoadOptionsPdf Class
LoadOptionsPdf Members


LoadOptionsPic Class

LoadOptionsPic Class
Members

Accusoft.ImagXpressSdk Namespace : LoadOptionsPic Class
This class implements the load options for the Pegasus Imaging Corporation file format.
Object Model
LoadOptionsPic Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class LoadOptionsPic
'Usage

Dim instance As LoadOptionsPic
public class LoadOptionsPic
public __gc class LoadOptionsPic
public ref class LoadOptionsPic
Remarks

Use this class for PIC specific file reading functionality.

Inheritance Hierarchy

System.Object
Accusoft.ImagXpressSdk.LoadOptionsPic

See Also

Reference

LoadOptionsPic Members
Accusoft.ImagXpressSdk Namespace


LoadOptionsPic Class Members

LoadOptionsPic Class Members
Properties

Accusoft.ImagXpressSdk Namespace : LoadOptionsPic Class

The following tables list the members exposed by LoadOptionsPic.

Public Constructors
 | Name | Description
Public Constructor | LoadOptionsPic Constructor | The main constructor initializing the LoadOptionsPic class.
Top
Public Properties
 | Name | Description
Public Property | Password | Gets and sets the password for an encrypted Pegasus Imaging Corporation (ePIC) file format.
Top
See Also

Reference

LoadOptionsPic Class
Accusoft.ImagXpressSdk Namespace


LoadOptionsPic Constructor

LoadOptionsPic Constructor

Accusoft.ImagXpressSdk Namespace > LoadOptionsPic Class : LoadOptionsPic Constructor
The main constructor initializing the LoadOptionsPic class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New LoadOptionsPic()
public LoadOptionsPic()
public: LoadOptionsPic();
public:
LoadOptionsPic();
See Also

Reference

LoadOptionsPic Class
LoadOptionsPic Members


LoadOptionsPic Class Properties

LoadOptionsPic Class Properties

Accusoft.ImagXpressSdk Namespace : LoadOptionsPic Class

For a list of all members of this type, see LoadOptionsPic members.

Public Properties
 | Name | Description
Public Property | Password | Gets and sets the password for an encrypted Pegasus Imaging Corporation (ePIC) file format.
Top
See Also

Reference

LoadOptionsPic Class
Accusoft.ImagXpressSdk Namespace


Password Property (LoadOptionsPic)

Password Property (LoadOptionsPic)

Accusoft.ImagXpressSdk Namespace > LoadOptionsPic Class : Password Property
Gets and sets the password for an encrypted Pegasus Imaging Corporation (ePIC) file format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Password As String
'Usage

Dim instance As LoadOptionsPic
Dim value As String

instance.Password = value

value = instance.Password
public string Password {get; set;}
public: __property string* get_Password();
public: __property void set_Password(
   string* value
);
public:
property String^ Password {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value which represents the password.
Remarks

Note: The password can only be up to 8 characters.

See Also

Reference

LoadOptionsPic Class
LoadOptionsPic Members


LoadOptionsRaw Class

LoadOptionsRaw Class
Members

Accusoft.ImagXpressSdk Namespace : LoadOptionsRaw Class
This class specifies image information that cannot be detected when loading a RAW image format.
Object Model
LoadOptionsRaw Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class LoadOptionsRaw
'Usage

Dim instance As LoadOptionsRaw
public class LoadOptionsRaw
public __gc class LoadOptionsRaw
public ref class LoadOptionsRaw
Remarks

When the LoadOptions.LoadMode is set to Raw to indicate that the image being loaded is in a raw file format, the application must specify a bit depth, size, and pixel format to use when interpreting the image data, as these attributes are not available from the raw image file.

Note: Available in Professional edition.

Inheritance Hierarchy

System.Object
Accusoft.ImagXpressSdk.LoadOptionsRaw

See Also

Reference

LoadOptionsRaw Members
Accusoft.ImagXpressSdk Namespace


LoadOptionsRaw Class Members

LoadOptionsRaw Class Members
Properties

Accusoft.ImagXpressSdk Namespace : LoadOptionsRaw Class

The following tables list the members exposed by LoadOptionsRaw.

Public Constructors
 | Name | Description
Public Constructor | LoadOptionsRaw Constructor | The main constructor to initialize the class.
Top
Public Properties
 | Name | Description
Public Property | BitsPerPixel | Gets and sets the bit depth of the image being loaded.
Public Property | BytesPerPixel | Gets and sets the number of bytes in the image utilized to represent a single pixel.
Public Property | Height | Gets and sets the height, in pixels, of the image being loaded.
Public Property | HighBitIndex | Gets and sets the number of bits to process.
Public Property | PixelFormat | Gets and sets the type of pixel system employed with the current image.
Public Property | Stride | Gets and sets the length (in bytes) of a scan line of the image to be loaded.
Public Property | Width | Gets and sets the width, in pixels, of the image being loaded.
Top
See Also

Reference

LoadOptionsRaw Class
Accusoft.ImagXpressSdk Namespace


LoadOptionsRaw Constructor

LoadOptionsRaw Constructor

Accusoft.ImagXpressSdk Namespace > LoadOptionsRaw Class : LoadOptionsRaw Constructor
The main constructor to initialize the class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New LoadOptionsRaw()
public LoadOptionsRaw()
public: LoadOptionsRaw();
public:
LoadOptionsRaw();
Remarks

Note: Available in Professional edition.

See Also

Reference

LoadOptionsRaw Class
LoadOptionsRaw Members


LoadOptionsRaw Class Properties

LoadOptionsRaw Class Properties

Accusoft.ImagXpressSdk Namespace : LoadOptionsRaw Class

For a list of all members of this type, see LoadOptionsRaw members.

Public Properties
 | Name | Description
Public Property | BitsPerPixel | Gets and sets the bit depth of the image being loaded.
Public Property | BytesPerPixel | Gets and sets the number of bytes in the image utilized to represent a single pixel.
Public Property | Height | Gets and sets the height, in pixels, of the image being loaded.
Public Property | HighBitIndex | Gets and sets the number of bits to process.
Public Property | PixelFormat | Gets and sets the type of pixel system employed with the current image.
Public Property | Stride | Gets and sets the length (in bytes) of a scan line of the image to be loaded.
Public Property | Width | Gets and sets the width, in pixels, of the image being loaded.
Top
See Also

Reference

LoadOptionsRaw Class
Accusoft.ImagXpressSdk Namespace


BitsPerPixel Property (LoadOptionsRaw)

BitsPerPixel Property (LoadOptionsRaw)

Accusoft.ImagXpressSdk Namespace > LoadOptionsRaw Class : BitsPerPixel Property
Gets and sets the bit depth of the image being loaded.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BitsPerPixel As Integer
'Usage

Dim instance As LoadOptionsRaw
Dim value As Integer

instance.BitsPerPixel = value

value = instance.BitsPerPixel
public int BitsPerPixel {get; set;}
public: __property int get_BitsPerPixel();
public: __property void set_BitsPerPixel(
   int value
);
public:
property int BitsPerPixel {
   int get();
   void set (    int value);
}

Property Value

An integer which represents the bit depth of the image being loaded.
Remarks
Must be set to 1, 4, 8, 16, 24, or 32; or from 8-16 when PixelFormat is HighGray.

Note: Available in Professional edition.

See Also

Reference

LoadOptionsRaw Class
LoadOptionsRaw Members


BytesPerPixel Property

BytesPerPixel Property

Accusoft.ImagXpressSdk Namespace > LoadOptionsRaw Class : BytesPerPixel Property
Gets and sets the number of bytes in the image utilized to represent a single pixel.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BytesPerPixel As Integer
'Usage

Dim instance As LoadOptionsRaw
Dim value As Integer

instance.BytesPerPixel = value

value = instance.BytesPerPixel
public int BytesPerPixel {get; set;}
public: __property int get_BytesPerPixel();
public: __property void set_BytesPerPixel(
   int value
);
public:
property int BytesPerPixel {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the number of bytes in the image utilized to represent a single pixel.
Remarks
Must be set to a value from 1-4.

Note: Available in Professional edition.

See Also

Reference

LoadOptionsRaw Class
LoadOptionsRaw Members


Height Property (LoadOptionsRaw)

Height Property (LoadOptionsRaw)

Accusoft.ImagXpressSdk Namespace > LoadOptionsRaw Class : Height Property
Gets and sets the height, in pixels, of the image being loaded.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Height As Integer
'Usage

Dim instance As LoadOptionsRaw
Dim value As Integer

instance.Height = value

value = instance.Height
public int Height {get; set;}
public: __property int get_Height();
public: __property void set_Height(
   int value
);
public:
property int Height {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the height of the image being loaded.
Remarks
Must be set to a value greater than 0.

Note: Available in Professional edition.

See Also

Reference

LoadOptionsRaw Class
LoadOptionsRaw Members


HighBitIndex Property

HighBitIndex Property

Accusoft.ImagXpressSdk Namespace > LoadOptionsRaw Class : HighBitIndex Property
Gets and sets the number of bits to process.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HighBitIndex As Integer
'Usage

Dim instance As LoadOptionsRaw
Dim value As Integer

instance.HighBitIndex = value

value = instance.HighBitIndex
public int HighBitIndex {get; set;}
public: __property int get_HighBitIndex();
public: __property void set_HighBitIndex(
   int value
);
public:
property int HighBitIndex {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the number of bits to process.
Remarks

Valid values are 0 to 15.

When zero (0) is set, all bits are used. Any other value restricts the number of bits to interpret.

Note: Available in Professional edition.

See Also

Reference

LoadOptionsRaw Class
LoadOptionsRaw Members


PixelFormat Property

PixelFormat Property

Accusoft.ImagXpressSdk Namespace > LoadOptionsRaw Class : PixelFormat Property
Gets and sets the type of pixel system employed with the current image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PixelFormat As ImageXPixelFormat
'Usage

Dim instance As LoadOptionsRaw
Dim value As ImageXPixelFormat

instance.PixelFormat = value

value = instance.PixelFormat
public ImageXPixelFormat PixelFormat {get; set;}
public: __property ImageXPixelFormat get_PixelFormat();
public: __property void set_PixelFormat(
   ImageXPixelFormat value
);
public:
property ImageXPixelFormat PixelFormat {
   ImageXPixelFormat get();
   void set (    ImageXPixelFormat value);
}

Property Value

The ImageXPixelFormat enumeration option value set.
Remarks
Both Dib and Raw cannot be set at the same time. One of the following must be set and only one at a time: {Alpha, Argb, Cmyk, Colormapped, Gray, HighGray, Rgb, Rgb555 or Rgb565} For HighGray, the BitsPerPixel must be from 8-16 For Rgb555 or Rgb565, the BitsPerPixel must be 16. For Rgb, the BitsPerPixel must be 24. For Gray or ColorMapped, the BitsPerPixel must be 1, 4 or 8. For Alpha, the BitsPerPixel must be 8. For Cmyk or Argb, the BitsPerPixel must be 32.

Note: Available in Professional edition.

See Also

Reference

LoadOptionsRaw Class
LoadOptionsRaw Members


Stride Property (LoadOptionsRaw)

Stride Property (LoadOptionsRaw)

Accusoft.ImagXpressSdk Namespace > LoadOptionsRaw Class : Stride Property
Gets and sets the length (in bytes) of a scan line of the image to be loaded.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Stride As Integer
'Usage

Dim instance As LoadOptionsRaw
Dim value As Integer

instance.Stride = value

value = instance.Stride
public int Stride {get; set;}
public: __property int get_Stride();
public: __property void set_Stride(
   int value
);
public:
property int Stride {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the length of a scan line of the image being loaded.
Remarks
Must be set to a value greater than 0, and the minimum stride length is (Width * BitsPerPixel + 7)/8.

Note: Available in Professional edition.

See Also

Reference

LoadOptionsRaw Class
LoadOptionsRaw Members


Width Property (LoadOptionsRaw)

Width Property (LoadOptionsRaw)

Accusoft.ImagXpressSdk Namespace > LoadOptionsRaw Class : Width Property
Gets and sets the width, in pixels, of the image being loaded.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Width As Integer
'Usage

Dim instance As LoadOptionsRaw
Dim value As Integer

instance.Width = value

value = instance.Width
public int Width {get; set;}
public: __property int get_Width();
public: __property void set_Width(
   int value
);
public:
property int Width {
   int get();
   void set (    int value);
}

Property Value

An integer which represents the width of the image being loaded.
Remarks
Must be set to a value greater than 0.

Note: Available in Professional edition.

See Also

Reference

LoadOptionsRaw Class
LoadOptionsRaw Members


LoadOptionsTiff Class

LoadOptionsTiff Class
Members

Accusoft.ImagXpressSdk Namespace : LoadOptionsTiff Class
This class implements the load options for TIFF files.
Object Model
LoadOptionsTiff Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class LoadOptionsTiff
'Usage

Dim instance As LoadOptionsTiff
public class LoadOptionsTiff
public __gc class LoadOptionsTiff
public ref class LoadOptionsTiff
Remarks

Use this class for TIFF specific file reading functionality.

Inheritance Hierarchy

System.Object
Accusoft.ImagXpressSdk.LoadOptionsTiff

See Also

Reference

LoadOptionsTiff Members
Accusoft.ImagXpressSdk Namespace


LoadOptionsTiff Class Members

LoadOptionsTiff Class Members
Properties

Accusoft.ImagXpressSdk Namespace : LoadOptionsTiff Class

The following tables list the members exposed by LoadOptionsTiff.

Public Constructors
 | Name | Description
Public Constructor | LoadOptionsTiff Constructor | The main constructor to initialize a new instance of the LoadOptionsTiff class.
Top
Public Properties
 | Name | Description
Public Property | HonorOrientationTag | Gets and sets an indicator if the TIFF Orientation tag's value should be honored or not.
Public Property | IFDOffset | Gets and sets the number of bytes preceding the IFD (Image File Directory).
Public Property | SpecialHandling | Gets and sets an indicator if the image being loaded is an abnormally formatted TIFF file.
Top
See Also

Reference

LoadOptionsTiff Class
Accusoft.ImagXpressSdk Namespace


LoadOptionsTiff Constructor

LoadOptionsTiff Constructor

Accusoft.ImagXpressSdk Namespace > LoadOptionsTiff Class : LoadOptionsTiff Constructor
The main constructor to initialize a new instance of the LoadOptionsTiff class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New LoadOptionsTiff()
public LoadOptionsTiff()
public: LoadOptionsTiff();
public:
LoadOptionsTiff();
See Also

Reference

LoadOptionsTiff Class
LoadOptionsTiff Members


LoadOptionsTiff Class Properties

LoadOptionsTiff Class Properties

Accusoft.ImagXpressSdk Namespace : LoadOptionsTiff Class

For a list of all members of this type, see LoadOptionsTiff members.

Public Properties
 | Name | Description
Public Property | HonorOrientationTag | Gets and sets an indicator if the TIFF Orientation tag's value should be honored or not.
Public Property | IFDOffset | Gets and sets the number of bytes preceding the IFD (Image File Directory).
Public Property | SpecialHandling | Gets and sets an indicator if the image being loaded is an abnormally formatted TIFF file.
Top
See Also

Reference

LoadOptionsTiff Class
Accusoft.ImagXpressSdk Namespace


HonorOrientationTag Property

HonorOrientationTag Property

Accusoft.ImagXpressSdk Namespace > LoadOptionsTiff Class : HonorOrientationTag Property
Gets and sets an indicator if the TIFF Orientation tag's value should be honored or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HonorOrientationTag As Boolean
'Usage

Dim instance As LoadOptionsTiff
Dim value As Boolean

instance.HonorOrientationTag = value

value = instance.HonorOrientationTag
public bool HonorOrientationTag {get; set;}
public: __property bool get_HonorOrientationTag();
public: __property void set_HonorOrientationTag(
   bool value
);
public:
property bool HonorOrientationTag {
   bool get();
   void set (    bool value);
}
Remarks

When true, the image is displayed faithful to the Orientation tag's value.

When false, the image is always displayed rightside up no matter the Orientation tag's value.

See Also

Reference

LoadOptionsTiff Class
LoadOptionsTiff Members


IFDOffset Property (LoadOptionsTiff)

IFDOffset Property (LoadOptionsTiff)

Accusoft.ImagXpressSdk Namespace > LoadOptionsTiff Class : IFDOffset Property
Gets and sets the number of bytes preceding the IFD (Image File Directory).
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IFDOffset As Integer
'Usage

Dim instance As LoadOptionsTiff
Dim value As Integer

instance.IFDOffset = value

value = instance.IFDOffset
public int IFDOffset {get; set;}
public: __property int get_IFDOffset();
public: __property void set_IFDOffset(
   int value
);
public:
property int IFDOffset {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the number of bytes preceding the IFD.
Remarks

This property specifies where ImagXpress begins reading image data within the TIFF image file.

See Also

Reference

LoadOptionsTiff Class
LoadOptionsTiff Members


SpecialHandling Property

SpecialHandling Property

Accusoft.ImagXpressSdk Namespace > LoadOptionsTiff Class : SpecialHandling Property
Gets and sets an indicator if the image being loaded is an abnormally formatted TIFF file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SpecialHandling As Boolean
'Usage

Dim instance As LoadOptionsTiff
Dim value As Boolean

instance.SpecialHandling = value

value = instance.SpecialHandling
public bool SpecialHandling {get; set;}
public: __property bool get_SpecialHandling();
public: __property void set_SpecialHandling(
   bool value
);
public:
property bool SpecialHandling {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true if special handling is required. Otherwise, false.
See Also

Reference

LoadOptionsTiff Class
LoadOptionsTiff Members


LookupTable Class

LookupTable Class
Members

Accusoft.ImagXpressSdk Namespace : LookupTable Class
A class for specifying a lookup table to be used with the Medical class.
Object Model
LookupTable Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class LookupTable
'Usage

Dim instance As LookupTable
public class LookupTable
public __gc class LookupTable
public ref class LookupTable
Remarks

The lookup table contains an array of Bytes for the actual Table and also members to determine how that Table is to be interpreted.

Note: Available in Professional edition.

Inheritance Hierarchy

System.Object
Accusoft.ImagXpressSdk.LookupTable

See Also

Reference

LookupTable Members
Accusoft.ImagXpressSdk Namespace


LookupTable Class Members

LookupTable Class Members
Properties

Accusoft.ImagXpressSdk Namespace : LookupTable Class

The following tables list the members exposed by LookupTable.

Public Constructors
 | Name | Description
Public Constructor | LookupTable Constructor | The main constructor to initialize a new instance of the LookupTable class.
Top
Public Properties
 | Name | Description
Public Property | Enabled | Gets and sets a value to specify whether the Lookup Table should be used for non-linear conversion or wherever the properties should be used for a linear conversion.
Public Property | FirstValueMapped | Gets and sets the stored pixel value mapped to the first entry in the Lookup Table.
Public Property | NumberOfBits | Gets and sets the number of bits allocated for each entry in the lookup table.
Public Property | Table | Gets and set the look up table itself which is an array of bytes.
Top
See Also

Reference

LookupTable Class
Accusoft.ImagXpressSdk Namespace


LookupTable Constructor

LookupTable Constructor

Accusoft.ImagXpressSdk Namespace > LookupTable Class : LookupTable Constructor
The main constructor to initialize a new instance of the LookupTable class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New LookupTable()
public LookupTable()
public: LookupTable();
public:
LookupTable();
Remarks

Note: Available in Professional edition.

See Also

Reference

LookupTable Class
LookupTable Members


LookupTable Class Properties

LookupTable Class Properties

Accusoft.ImagXpressSdk Namespace : LookupTable Class

For a list of all members of this type, see LookupTable members.

Public Properties
 | Name | Description
Public Property | Enabled | Gets and sets a value to specify whether the Lookup Table should be used for non-linear conversion or wherever the properties should be used for a linear conversion.
Public Property | FirstValueMapped | Gets and sets the stored pixel value mapped to the first entry in the Lookup Table.
Public Property | NumberOfBits | Gets and sets the number of bits allocated for each entry in the lookup table.
Public Property | Table | Gets and set the look up table itself which is an array of bytes.
Top
See Also

Reference

LookupTable Class
Accusoft.ImagXpressSdk Namespace


LookupTable Constructor

LookupTable Constructor

Accusoft.ImagXpressSdk Namespace > LookupTable Class : LookupTable Constructor
Overload List
Overload | Description
LookupTable Constructor | The main constructor to initialize a new instance of the LookupTable class.
See Also

Reference

LookupTable Class
LookupTable Members


Enabled Property (LookupTable)

Enabled Property (LookupTable)

Accusoft.ImagXpressSdk Namespace > LookupTable Class : Enabled Property
Gets and sets a value to specify whether the Lookup Table should be used for non-linear conversion or wherever the properties should be used for a linear conversion.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Enabled As Boolean
'Usage

Dim instance As LookupTable
Dim value As Boolean

instance.Enabled = value

value = instance.Enabled
public bool Enabled {get; set;}
public: __property bool get_Enabled();
public: __property void set_Enabled(
   bool value
);
public:
property bool Enabled {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true to enable the lookup table. Otherwise, false is returned.
Remarks

Note: Available in Professional edition.

See Also

Reference

LookupTable Class
LookupTable Members


FirstValueMapped Property

FirstValueMapped Property

Accusoft.ImagXpressSdk Namespace > LookupTable Class : FirstValueMapped Property
Gets and sets the stored pixel value mapped to the first entry in the Lookup Table.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FirstValueMapped As Integer
'Usage

Dim instance As LookupTable
Dim value As Integer

instance.FirstValueMapped = value

value = instance.FirstValueMapped
public int FirstValueMapped {get; set;}
public: __property int get_FirstValueMapped();
public: __property void set_FirstValueMapped(
   int value
);
public:
property int FirstValueMapped {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the pixel value mapped to the first entry in the Lookup Table.
Remarks

All values less than this pixel value are also mapped to the first entry.

This value corresponds to the second value found in the LUT Descriptor (0028, 3002).

Note: Available in Professional edition.

See Also

Reference

LookupTable Class
LookupTable Members


NumberOfBits Property

NumberOfBits Property

Accusoft.ImagXpressSdk Namespace > LookupTable Class : NumberOfBits Property
Gets and sets the number of bits allocated for each entry in the lookup table.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property NumberOfBits As Integer
'Usage

Dim instance As LookupTable
Dim value As Integer

instance.NumberOfBits = value

value = instance.NumberOfBits
public int NumberOfBits {get; set;}
public: __property int get_NumberOfBits();
public: __property void set_NumberOfBits(
   int value
);
public:
property int NumberOfBits {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the number of bits allocated for each entry in the lookup table.
Remarks

Valid values are 8 or 16.

This value corresponds with the third value in the LUT (Look UP Table) Descriptor (0028, 3002).

Note: Available in Professional edition.

See Also

Reference

LookupTable Class
LookupTable Members


Table Property

Table Property

Accusoft.ImagXpressSdk Namespace > LookupTable Class : Table Property
Gets and set the look up table itself which is an array of bytes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Table As Byte()
'Usage

Dim instance As LookupTable
Dim value() As Byte

instance.Table = value

value = instance.Table
public byte[] Table {get; set;}
public: __property byte[]* get_Table();
public: __property void set_Table(
   byte[]* value
);
public:
property array<byte>^ Table {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

Property Value

A byte array which corresponds with the values found in the LUT Descriptor.
Remarks

LUT (Look Up Table) Data corresponding with DICOM tag (0028, 3006). Create an array of bytes with the number of entries which corresponds with the first value found in the LUT Descriptor (0028, 3002). If the NumberOfBits property is 16, then the array of bytes should be sized to twice the number of entries.

Note: Available in Professional edition.

See Also

Reference

LookupTable Class
LookupTable Members


Medical Class

Medical Class
Members

Accusoft.ImagXpressSdk Namespace : Medical Class
The Medical class is an encapsulation of the properties needed to do a DICOM (Digital Imaging and Communications in Medicine) grayscale transformation.
Object Model
Medical ClassLookupTable ClassLookupTable Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class Medical
'Usage

Dim instance As Medical
public class Medical
public __gc class Medical
public ref class Medical
Remarks

They can be used both for viewing and for applying the transformation permanently.

Note: Available in Professional edition.

Inheritance Hierarchy

System.Object
Accusoft.ImagXpressSdk.Medical

See Also

Reference

Medical Members
Accusoft.ImagXpressSdk Namespace


Medical Class Members

Medical Class Members
Properties

Accusoft.ImagXpressSdk Namespace : Medical Class

The following tables list the members exposed by Medical.

Public Constructors
 | Name | Description
Public Constructor | Medical Constructor | The main constructor to initialize a new instance of the Medical class.
Top
Public Properties
 | Name | Description
Public Property | ModalityLookupTable | Gets and sets a DICOM Modality Look Up Table.
Public Property | PhotometricInterpretation | Gets and sets whether a zero in the image data is black or white.
Public Property | RescaleIntercept | Gets and sets the intercept used to specify a linear conversion of pixel data in the DICOM grayscale transformation.
Public Property | RescaleSlope | Gets and sets the slope used to specify a linear conversion of pixel data in the DICOM grayscale transformation.
Public Property | ValuesOfInterestLookupTable | Gets and sets (VOI) Values of Interest for the DICOM Lookup Table.
Public Property | WindowCenter | Gets and sets the center value used to specify a linear conversion from stored pixel values to values to be displayed after any Modality LUT or Rescale Slope and Intercept conversions have been applied.
Public Property | WindowWidth | Gets and sets the width value used to specify a linear conversion from stored pixel values to values to be displayed after any Modality LUT or Rescale Slope and Intercept conversions have been applied.
Top
See Also

Reference

Medical Class
Accusoft.ImagXpressSdk Namespace


Medical Constructor

Medical Constructor

Accusoft.ImagXpressSdk Namespace > Medical Class : Medical Constructor
The main constructor to initialize a new instance of the Medical class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New Medical()
public Medical()
public: Medical();
public:
Medical();
Remarks

Note: Available in Professional edition.

See Also

Reference

Medical Class
Medical Members


Medical Class Properties

Medical Class Properties

Accusoft.ImagXpressSdk Namespace : Medical Class

For a list of all members of this type, see Medical members.

Public Properties
 | Name | Description
Public Property | ModalityLookupTable | Gets and sets a DICOM Modality Look Up Table.
Public Property | PhotometricInterpretation | Gets and sets whether a zero in the image data is black or white.
Public Property | RescaleIntercept | Gets and sets the intercept used to specify a linear conversion of pixel data in the DICOM grayscale transformation.
Public Property | RescaleSlope | Gets and sets the slope used to specify a linear conversion of pixel data in the DICOM grayscale transformation.
Public Property | ValuesOfInterestLookupTable | Gets and sets (VOI) Values of Interest for the DICOM Lookup Table.
Public Property | WindowCenter | Gets and sets the center value used to specify a linear conversion from stored pixel values to values to be displayed after any Modality LUT or Rescale Slope and Intercept conversions have been applied.
Public Property | WindowWidth | Gets and sets the width value used to specify a linear conversion from stored pixel values to values to be displayed after any Modality LUT or Rescale Slope and Intercept conversions have been applied.
Top
See Also

Reference

Medical Class
Accusoft.ImagXpressSdk Namespace


Medical Constructor

Medical Constructor

Accusoft.ImagXpressSdk Namespace > Medical Class : Medical Constructor
Overload List
Overload | Description
Medical Constructor | The main constructor to initialize a new instance of the Medical class.
See Also

Reference

Medical Class
Medical Members


ModalityLookupTable Property

ModalityLookupTable Property

Accusoft.ImagXpressSdk Namespace > Medical Class : ModalityLookupTable Property
Gets and sets a DICOM Modality Look Up Table.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ModalityLookupTable As LookupTable
'Usage

Dim instance As Medical
Dim value As LookupTable

instance.ModalityLookupTable = value

value = instance.ModalityLookupTable
public LookupTable ModalityLookupTable {get; set;}
public: __property LookupTable* get_ModalityLookupTable();
public: __property void set_ModalityLookupTable(
   LookupTable* value
);
public:
property LookupTable^ ModalityLookupTable {
   LookupTable^ get();
   void set (    LookupTable^ value);
}

Property Value

The LookupTable value set.
Remarks

This property allows you to set the Modality LUT information specified in the DICOM Modality LUT Sequence (0028, 3000) attribute.

Note: Available in Professional edition.

See Also

Reference

Medical Class
Medical Members
LookupTable Class


PhotometricInterpretation Property (Medical)

PhotometricInterpretation Property (Medical)

Accusoft.ImagXpressSdk Namespace > Medical Class : PhotometricInterpretation Property
Gets and sets whether a zero in the image data is black or white.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PhotometricInterpretation As MedicalPhotometricInterpretation
'Usage

Dim instance As Medical
Dim value As MedicalPhotometricInterpretation

instance.PhotometricInterpretation = value

value = instance.PhotometricInterpretation
public MedicalPhotometricInterpretation PhotometricInterpretation {get; set;}
public: __property MedicalPhotometricInterpretation get_PhotometricInterpretation();
public: __property void set_PhotometricInterpretation(
   MedicalPhotometricInterpretation value
);
public:
property MedicalPhotometricInterpretation PhotometricInterpretation {
   MedicalPhotometricInterpretation get();
   void set (    MedicalPhotometricInterpretation value);
}

Property Value

The PhotometricInterpretation enumeration value set.
Remarks

Note: This property should only be used when DICOM specific information is available.

Note: Available in Professional edition.

See Also

Reference

Medical Class
Medical Members
PhotometricInterpretation Property


RescaleIntercept Property

RescaleIntercept Property

Accusoft.ImagXpressSdk Namespace > Medical Class : RescaleIntercept Property
Gets and sets the intercept used to specify a linear conversion of pixel data in the DICOM grayscale transformation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property RescaleIntercept As Double
'Usage

Dim instance As Medical
Dim value As Double

instance.RescaleIntercept = value

value = instance.RescaleIntercept
public double RescaleIntercept {get; set;}
public: __property double get_RescaleIntercept();
public: __property void set_RescaleIntercept(
   double value
);
public:
property double RescaleIntercept {
   double get();
   void set (    double value);
}

Property Value

A double value which represents pixel data in the DICOM grayscale transformation.
Remarks

This value corresponds to DICOM attribute (0028, 1052).

This property specifies the intercept value (b) to be used in the equation: Output units = m * SV + b where SV is the stored values (pixel data) and the value m corresponds to the Where SV is the stored values (pixel data) and the value m corresponds to the slope specified using the RescaleSlope property. Both values are used together to specify the linear conversion of pixel data.

This property is only valid when the ModalityLookupTable property is set to False.

This property should only be used when DICOM specific information is available.

Note: Available in Professional edition.

See Also

Reference

Medical Class
Medical Members


RescaleSlope Property

RescaleSlope Property

Accusoft.ImagXpressSdk Namespace > Medical Class : RescaleSlope Property
Gets and sets the slope used to specify a linear conversion of pixel data in the DICOM grayscale transformation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property RescaleSlope As Double
'Usage

Dim instance As Medical
Dim value As Double

instance.RescaleSlope = value

value = instance.RescaleSlope
public double RescaleSlope {get; set;}
public: __property double get_RescaleSlope();
public: __property void set_RescaleSlope(
   double value
);
public:
property double RescaleSlope {
   double get();
   void set (    double value);
}

Property Value

A double value which represents pixel data in the DICOM grayscale transformation.
Remarks

This value corresponds to DICOM attribute (0028, 1053).

This property specifies the slope value (m) to be used in the equation: Output units = m * SV + b Where SV is the stored values (pixel data) and the value b corresponds to the intercept specified using the RescaleIntercept property. Both values are used together to specify the linear conversion of pixel data.

This property is only valid when ModalityLookupTable.Enabled is set to False.

This property should only be used when DICOM specific information is available.

Note: Available in Professional edition.

See Also

Reference

Medical Class
Medical Members


ValuesOfInterestLookupTable Property

ValuesOfInterestLookupTable Property

Accusoft.ImagXpressSdk Namespace > Medical Class : ValuesOfInterestLookupTable Property
Gets and sets (VOI) Values of Interest for the DICOM Lookup Table.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ValuesOfInterestLookupTable As LookupTable
'Usage

Dim instance As Medical
Dim value As LookupTable

instance.ValuesOfInterestLookupTable = value

value = instance.ValuesOfInterestLookupTable
public LookupTable ValuesOfInterestLookupTable {get; set;}
public: __property LookupTable* get_ValuesOfInterestLookupTable();
public: __property void set_ValuesOfInterestLookupTable(
   LookupTable* value
);
public:
property LookupTable^ ValuesOfInterestLookupTable {
   LookupTable^ get();
   void set (    LookupTable^ value);
}

Property Value

The LookupTable object.
Remarks

Sets the Values of Interest (VOI) LUT information specified in the DICOM VOI LUT Sequence (0028, 3010) attribute.

Note: Available in Professional edition.

See Also

Reference

Medical Class
Medical Members


WindowCenter Property

WindowCenter Property

Accusoft.ImagXpressSdk Namespace > Medical Class : WindowCenter Property
Gets and sets the center value used to specify a linear conversion from stored pixel values to values to be displayed after any Modality LUT or Rescale Slope and Intercept conversions have been applied.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property WindowCenter As Double
'Usage

Dim instance As Medical
Dim value As Double

instance.WindowCenter = value

value = instance.WindowCenter
public double WindowCenter {get; set;}
public: __property double get_WindowCenter();
public: __property void set_WindowCenter(
   double value
);
public:
property double WindowCenter {
   double get();
   void set (    double value);
}

Property Value

A double value which represents the window center.
Remarks

This value corresponds to DICOM attribute (0028, 1050).

WindowCenter is used along with WindowWidth to specify the linear conversion of pixel data during the VOI step of DICOM grayscale transformation. For more information see Part 3, Annex C.11.2.1.2 of the DICOM standard.

This property is only valid when ValuesOfInterestLookupTable is set to false.

Note: This property should only be used when DICOM specific information is available. To set both the Center and Width parameters simultaneously use the Processor.ApplyGrayscaleTransform method.

Note: Available in Professional edition.

See Also

Reference

Medical Class
Medical Members


WindowWidth Property

WindowWidth Property

Accusoft.ImagXpressSdk Namespace > Medical Class : WindowWidth Property
Gets and sets the width value used to specify a linear conversion from stored pixel values to values to be displayed after any Modality LUT or Rescale Slope and Intercept conversions have been applied.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property WindowWidth As Double
'Usage

Dim instance As Medical
Dim value As Double

instance.WindowWidth = value

value = instance.WindowWidth
public double WindowWidth {get; set;}
public: __property double get_WindowWidth();
public: __property void set_WindowWidth(
   double value
);
public:
property double WindowWidth {
   double get();
   void set (    double value);
}

Property Value

A double value which represents the window width.
Remarks

WindowWidth contains the width of the window and shall always be greater than or equal to 1. When this value is greater than 1, WindowWidth and WindowCenter specify that range of input values to be mapped to the range of the output device. If DWindowWidth is equal to 1, WindowWidth and WindowCenter specify a value where input values below this value should be displayed as the minimum output value. For more information see Part 3, Annex C.11.2.1.2 of the DICOM standard.

This property is only valid when ValuesOfInterestLookupTable is set to false.

This property should only be used when DICOM specific information is available.

To set both the Center and Width parameters simultaneously use the Processor.ApplyGrayscaleTransform method.

Note: Available in Professional edition.

See Also

Reference

Medical Class
Medical Members


PaintImageEventArgs Class

PaintImageEventArgs Class
Members

Accusoft.ImagXpressSdk Namespace : PaintImageEventArgs Class
Provides data for the ImageXView.PaintImage event.
Object Model
PaintImageEventArgs Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PaintImageEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As PaintImageEventArgs
public class PaintImageEventArgs : System.EventArgs
public __gc class PaintImageEventArgs : public System.EventArgs
public ref class PaintImageEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
Accusoft.ImagXpressSdk.PaintImageEventArgs

See Also

Reference

PaintImageEventArgs Members
Accusoft.ImagXpressSdk Namespace


PaintImageEventArgs Class Members

PaintImageEventArgs Class Members
Properties

Accusoft.ImagXpressSdk Namespace : PaintImageEventArgs Class

The following tables list the members exposed by PaintImageEventArgs.

Public Constructors
 | Name | Description
Public Constructor | PaintImageEventArgs Constructor | Initializes a new instance of the PaintImageEventArgs class.
Top
Public Properties
 | Name | Description
Public Property | Graphics | Gets the System.Drawing.Graphics object.
Public Property | LogicalRectangle | Gets the logical rectangle.
Public Property | UpdateRectangle | Gets the update rectangle.
Public Property | ViewRectangle | Gets the view's rectangle.
Public Property | ZoomFactor | Gets the zoom factor.
Top
See Also

Reference

PaintImageEventArgs Class
Accusoft.ImagXpressSdk Namespace


PaintImageEventArgs Constructor

PaintImageEventArgs Constructor

Accusoft.ImagXpressSdk Namespace > PaintImageEventArgs Class : PaintImageEventArgs Constructor
Initializes a new instance of the PaintImageEventArgs class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PaintImageEventArgs()
public PaintImageEventArgs()
public: PaintImageEventArgs();
public:
PaintImageEventArgs();
See Also

Reference

PaintImageEventArgs Class
PaintImageEventArgs Members


PaintImageEventArgs Class Properties

PaintImageEventArgs Class Properties

Accusoft.ImagXpressSdk Namespace : PaintImageEventArgs Class

For a list of all members of this type, see PaintImageEventArgs members.

Public Properties
 | Name | Description
Public Property | Graphics | Gets the System.Drawing.Graphics object.
Public Property | LogicalRectangle | Gets the logical rectangle.
Public Property | UpdateRectangle | Gets the update rectangle.
Public Property | ViewRectangle | Gets the view's rectangle.
Public Property | ZoomFactor | Gets the zoom factor.
Top
See Also

Reference

PaintImageEventArgs Class
Accusoft.ImagXpressSdk Namespace


PaintImageEventArgs Constructor

PaintImageEventArgs Constructor

Accusoft.ImagXpressSdk Namespace > PaintImageEventArgs Class : PaintImageEventArgs Constructor
Overload List
Overload | Description
PaintImageEventArgs Constructor | Initializes a new instance of the PaintImageEventArgs class.
See Also

Reference

PaintImageEventArgs Class
PaintImageEventArgs Members


Graphics Property (PaintImageEventArgs)

Graphics Property (PaintImageEventArgs)

Accusoft.ImagXpressSdk Namespace > PaintImageEventArgs Class : Graphics Property
Gets the System.Drawing.Graphics object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Graphics As Graphics
'Usage

Dim instance As PaintImageEventArgs
Dim value As Graphics

value = instance.Graphics
public Graphics Graphics {get;}
public: __property Graphics* get_Graphics();
public:
property Graphics^ Graphics {
   Graphics^ get();
}

Property Value

The System.Drawing.Graphics object.
See Also

Reference

PaintImageEventArgs Class
PaintImageEventArgs Members


LogicalRectangle Property

LogicalRectangle Property

Accusoft.ImagXpressSdk Namespace > PaintImageEventArgs Class : LogicalRectangle Property
Gets the logical rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property LogicalRectangle As Rectangle
'Usage

Dim instance As PaintImageEventArgs
Dim value As Rectangle

value = instance.LogicalRectangle
public Rectangle LogicalRectangle {get;}
public: __property Rectangle get_LogicalRectangle();
public:
property Rectangle LogicalRectangle {
   Rectangle get();
}

Property Value

The logical System.Drawing.Rectangle.
See Also

Reference

PaintImageEventArgs Class
PaintImageEventArgs Members


UpdateRectangle Property

UpdateRectangle Property

Accusoft.ImagXpressSdk Namespace > PaintImageEventArgs Class : UpdateRectangle Property
Gets the update rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property UpdateRectangle As Rectangle
'Usage

Dim instance As PaintImageEventArgs
Dim value As Rectangle

value = instance.UpdateRectangle
public Rectangle UpdateRectangle {get;}
public: __property Rectangle get_UpdateRectangle();
public:
property Rectangle UpdateRectangle {
   Rectangle get();
}

Property Value

The update System.Drawing.Rectangle.
See Also

Reference

PaintImageEventArgs Class
PaintImageEventArgs Members


ViewRectangle Property

ViewRectangle Property

Accusoft.ImagXpressSdk Namespace > PaintImageEventArgs Class : ViewRectangle Property
Gets the view's rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ViewRectangle As Rectangle
'Usage

Dim instance As PaintImageEventArgs
Dim value As Rectangle

value = instance.ViewRectangle
public Rectangle ViewRectangle {get;}
public: __property Rectangle get_ViewRectangle();
public:
property Rectangle ViewRectangle {
   Rectangle get();
}

Property Value

The view System.Drawing.Rectangle.
See Also

Reference

PaintImageEventArgs Class
PaintImageEventArgs Members


ZoomFactor Property (PaintImageEventArgs)

ZoomFactor Property (PaintImageEventArgs)

Accusoft.ImagXpressSdk Namespace > PaintImageEventArgs Class : ZoomFactor Property
Gets the zoom factor.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ZoomFactor As Double
'Usage

Dim instance As PaintImageEventArgs
Dim value As Double

value = instance.ZoomFactor
public double ZoomFactor {get;}
public: __property double get_ZoomFactor();
public:
property double ZoomFactor {
   double get();
}

Property Value

The zoom factor.
See Also

Reference

PaintImageEventArgs Class
PaintImageEventArgs Members


PanGestureOccurredEventArgs Class

PanGestureOccurredEventArgs Class
Members

Accusoft.ImagXpressSdk Namespace : PanGestureOccurredEventArgs Class
This class implements event data for TouchPan events.
Object Model
PanGestureOccurredEventArgs Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PanGestureOccurredEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As PanGestureOccurredEventArgs
public class PanGestureOccurredEventArgs : System.EventArgs
public __gc class PanGestureOccurredEventArgs : public System.EventArgs
public ref class PanGestureOccurredEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
Accusoft.ImagXpressSdk.PanGestureOccurredEventArgs

See Also

Reference

PanGestureOccurredEventArgs Members
Accusoft.ImagXpressSdk Namespace


PanGestureOccurredEventArgs Class Members

PanGestureOccurredEventArgs Class Members
Properties

Accusoft.ImagXpressSdk Namespace : PanGestureOccurredEventArgs Class

The following tables list the members exposed by PanGestureOccurredEventArgs.

Public Constructors
 | Name | Description
Public Constructor | PanGestureOccurredEventArgs Constructor | The main constructor which initializes a new instance of the TouchPanEventArgs class.
Top
Public Properties
 | Name | Description
Public Property | TotalDelta | Gets the sum of all of the deltas from the start position during panning with the touch interface.
Top
See Also

Reference

PanGestureOccurredEventArgs Class
Accusoft.ImagXpressSdk Namespace


PanGestureOccurredEventArgs Constructor

PanGestureOccurredEventArgs Constructor

Accusoft.ImagXpressSdk Namespace > PanGestureOccurredEventArgs Class : PanGestureOccurredEventArgs Constructor
The main constructor which initializes a new instance of the TouchPanEventArgs class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PanGestureOccurredEventArgs()
public PanGestureOccurredEventArgs()
public: PanGestureOccurredEventArgs();
public:
PanGestureOccurredEventArgs();
See Also

Reference

PanGestureOccurredEventArgs Class
PanGestureOccurredEventArgs Members


PanGestureOccurredEventArgs Class Properties

PanGestureOccurredEventArgs Class Properties

Accusoft.ImagXpressSdk Namespace : PanGestureOccurredEventArgs Class

For a list of all members of this type, see PanGestureOccurredEventArgs members.

Public Properties
 | Name | Description
Public Property | TotalDelta | Gets the sum of all of the deltas from the start position during panning with the touch interface.
Top
See Also

Reference

PanGestureOccurredEventArgs Class
Accusoft.ImagXpressSdk Namespace


PanGestureOccurredEventArgs Constructor

PanGestureOccurredEventArgs Constructor

Accusoft.ImagXpressSdk Namespace > PanGestureOccurredEventArgs Class : PanGestureOccurredEventArgs Constructor
Overload List
Overload | Description
PanGestureOccurredEventArgs Constructor | The main constructor which initializes a new instance of the TouchPanEventArgs class.
See Also

Reference

PanGestureOccurredEventArgs Class
PanGestureOccurredEventArgs Members


TotalDelta Property

TotalDelta Property

Accusoft.ImagXpressSdk Namespace > PanGestureOccurredEventArgs Class : TotalDelta Property
Gets the sum of all of the deltas from the start position during panning with the touch interface.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property TotalDelta As Point
'Usage

Dim instance As PanGestureOccurredEventArgs
Dim value As Point

value = instance.TotalDelta
public Point TotalDelta {get;}
public: __property Point get_TotalDelta();
public:
property Point TotalDelta {
   Point get();
}

Property Value

A System.Drawing.Point value from the .NET Framework Class Library.
See Also

Reference

PanGestureOccurredEventArgs Class
PanGestureOccurredEventArgs Members


PanGestureOccurringEventArgs Class

PanGestureOccurringEventArgs Class
Members

Accusoft.ImagXpressSdk Namespace : PanGestureOccurringEventArgs Class
This class implements event data for PanGestureOccurring events.
Object Model
PanGestureOccurringEventArgs Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PanGestureOccurringEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As PanGestureOccurringEventArgs
public class PanGestureOccurringEventArgs : System.EventArgs
public __gc class PanGestureOccurringEventArgs : public System.EventArgs
public ref class PanGestureOccurringEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
Accusoft.ImagXpressSdk.PanGestureOccurringEventArgs

See Also

Reference

PanGestureOccurringEventArgs Members
Accusoft.ImagXpressSdk Namespace


PanGestureOccurringEventArgs Class Members

PanGestureOccurringEventArgs Class Members
Properties

Accusoft.ImagXpressSdk Namespace : PanGestureOccurringEventArgs Class

The following tables list the members exposed by PanGestureOccurringEventArgs.

Public Constructors
 | Name | Description
Public Constructor | PanGestureOccurringEventArgs Constructor | The main constructor which initializes a new instance of the TouchPanEventArgs class.
Top
Public Properties
 | Name | Description
Public Property | DeltaSinceLastEventFiring | Gets the difference or delta from the last position during a panning gesture with the touch interface.
Public Property | HasInertia | Gets whether the panning gesture has inertia during a panning gesture with the touch interface.
Public Property | InertialVector | Gets the inertial vector during a panning gesture with the touch interface.
Top
See Also

Reference

PanGestureOccurringEventArgs Class
Accusoft.ImagXpressSdk Namespace


PanGestureOccurringEventArgs Constructor

PanGestureOccurringEventArgs Constructor

Accusoft.ImagXpressSdk Namespace > PanGestureOccurringEventArgs Class : PanGestureOccurringEventArgs Constructor
The main constructor which initializes a new instance of the TouchPanEventArgs class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PanGestureOccurringEventArgs()
public PanGestureOccurringEventArgs()
public: PanGestureOccurringEventArgs();
public:
PanGestureOccurringEventArgs();
See Also

Reference

PanGestureOccurringEventArgs Class
PanGestureOccurringEventArgs Members


PanGestureOccurringEventArgs Class Properties

PanGestureOccurringEventArgs Class Properties

Accusoft.ImagXpressSdk Namespace : PanGestureOccurringEventArgs Class

For a list of all members of this type, see PanGestureOccurringEventArgs members.

Public Properties
 | Name | Description
Public Property | DeltaSinceLastEventFiring | Gets the difference or delta from the last position during a panning gesture with the touch interface.
Public Property | HasInertia | Gets whether the panning gesture has inertia during a panning gesture with the touch interface.
Public Property | InertialVector | Gets the inertial vector during a panning gesture with the touch interface.
Top
See Also

Reference

PanGestureOccurringEventArgs Class
Accusoft.ImagXpressSdk Namespace


PanGestureOccurringEventArgs Constructor

PanGestureOccurringEventArgs Constructor

Accusoft.ImagXpressSdk Namespace > PanGestureOccurringEventArgs Class : PanGestureOccurringEventArgs Constructor
Overload List
Overload | Description
PanGestureOccurringEventArgs Constructor | The main constructor which initializes a new instance of the TouchPanEventArgs class.
See Also

Reference

PanGestureOccurringEventArgs Class
PanGestureOccurringEventArgs Members


DeltaSinceLastEventFiring Property

DeltaSinceLastEventFiring Property

Accusoft.ImagXpressSdk Namespace > PanGestureOccurringEventArgs Class : DeltaSinceLastEventFiring Property
Gets the difference or delta from the last position during a panning gesture with the touch interface.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property DeltaSinceLastEventFiring As Point
'Usage

Dim instance As PanGestureOccurringEventArgs
Dim value As Point

value = instance.DeltaSinceLastEventFiring
public Point DeltaSinceLastEventFiring {get;}
public: __property Point get_DeltaSinceLastEventFiring();
public:
property Point DeltaSinceLastEventFiring {
   Point get();
}

Property Value

A System.Drawing.Point value from the .NET Framework Class Library.
See Also

Reference

PanGestureOccurringEventArgs Class
PanGestureOccurringEventArgs Members


HasInertia Property

HasInertia Property

Accusoft.ImagXpressSdk Namespace > PanGestureOccurringEventArgs Class : HasInertia Property
Gets whether the panning gesture has inertia during a panning gesture with the touch interface.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property HasInertia As Boolean
'Usage

Dim instance As PanGestureOccurringEventArgs
Dim value As Boolean

value = instance.HasInertia
public bool HasInertia {get;}
public: __property bool get_HasInertia();
public:
property bool HasInertia {
   bool get();
}

Property Value

A System.Boolean value from the .NET Framework Class Library.
See Also

Reference

PanGestureOccurringEventArgs Class
PanGestureOccurringEventArgs Members


InertialVector Property

InertialVector Property

Accusoft.ImagXpressSdk Namespace > PanGestureOccurringEventArgs Class : InertialVector Property
Gets the inertial vector during a panning gesture with the touch interface.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property InertialVector As Point
'Usage

Dim instance As PanGestureOccurringEventArgs
Dim value As Point

value = instance.InertialVector
public Point InertialVector {get;}
public: __property Point get_InertialVector();
public:
property Point InertialVector {
   Point get();
}

Property Value

A System.Drawing.Point value from the .NET Framework Class Library.
See Also

Reference

PanGestureOccurringEventArgs Class
PanGestureOccurringEventArgs Members


PressAndHoldEventArgs Class

PressAndHoldEventArgs Class
Members

Accusoft.ImagXpressSdk Namespace : PressAndHoldEventArgs Class
This class implements event data for PressAndHold events.
Object Model
PressAndHoldEventArgs Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PressAndHoldEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As PressAndHoldEventArgs
public class PressAndHoldEventArgs : System.EventArgs
public __gc class PressAndHoldEventArgs : public System.EventArgs
public ref class PressAndHoldEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
Accusoft.ImagXpressSdk.PressAndHoldEventArgs

See Also

Reference

PressAndHoldEventArgs Members
Accusoft.ImagXpressSdk Namespace


PressAndHoldEventArgs Class Members

PressAndHoldEventArgs Class Members
Properties

Accusoft.ImagXpressSdk Namespace : PressAndHoldEventArgs Class

The following tables list the members exposed by PressAndHoldEventArgs.

Public Constructors
 | Name | Description
Public Constructor | PressAndHoldEventArgs Constructor | The main constructor which initializes a new instance of the PressAndHoldEventArgs class.
Top
Public Properties
 | Name | Description
Public Property | HeldFingerLocation | Gets the location of the held finger during a press and hold with the touch interface.
Top
See Also

Reference

PressAndHoldEventArgs Class
Accusoft.ImagXpressSdk Namespace


PressAndHoldEventArgs Constructor

PressAndHoldEventArgs Constructor

Accusoft.ImagXpressSdk Namespace > PressAndHoldEventArgs Class : PressAndHoldEventArgs Constructor
The main constructor which initializes a new instance of the PressAndHoldEventArgs class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PressAndHoldEventArgs()
public PressAndHoldEventArgs()
public: PressAndHoldEventArgs();
public:
PressAndHoldEventArgs();
See Also

Reference

PressAndHoldEventArgs Class
PressAndHoldEventArgs Members


PressAndHoldEventArgs Class Properties

PressAndHoldEventArgs Class Properties

Accusoft.ImagXpressSdk Namespace : PressAndHoldEventArgs Class

For a list of all members of this type, see PressAndHoldEventArgs members.

Public Properties
 | Name | Description
Public Property | HeldFingerLocation | Gets the location of the held finger during a press and hold with the touch interface.
Top
See Also

Reference

PressAndHoldEventArgs Class
Accusoft.ImagXpressSdk Namespace


PressAndHoldEventArgs Constructor

PressAndHoldEventArgs Constructor

Accusoft.ImagXpressSdk Namespace > PressAndHoldEventArgs Class : PressAndHoldEventArgs Constructor
Overload List
Overload | Description
PressAndHoldEventArgs Constructor | The main constructor which initializes a new instance of the PressAndHoldEventArgs class.
See Also

Reference

PressAndHoldEventArgs Class
PressAndHoldEventArgs Members


HeldFingerLocation Property

HeldFingerLocation Property

Accusoft.ImagXpressSdk Namespace > PressAndHoldEventArgs Class : HeldFingerLocation Property
Gets the location of the held finger during a press and hold with the touch interface.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property HeldFingerLocation As Point
'Usage

Dim instance As PressAndHoldEventArgs
Dim value As Point

value = instance.HeldFingerLocation
public Point HeldFingerLocation {get;}
public: __property Point get_HeldFingerLocation();
public:
property Point HeldFingerLocation {
   Point get();
}

Property Value

A System.Drawing.Point value from the .NET Framework Class Library.
See Also

Reference

PressAndHoldEventArgs Class
PressAndHoldEventArgs Members


PressAndTapEventArgs Class

PressAndTapEventArgs Class
Members

Accusoft.ImagXpressSdk Namespace : PressAndTapEventArgs Class
This class implements event data for PressAndTap events.
Object Model
PressAndTapEventArgs Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PressAndTapEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As PressAndTapEventArgs
public class PressAndTapEventArgs : System.EventArgs
public __gc class PressAndTapEventArgs : public System.EventArgs
public ref class PressAndTapEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
Accusoft.ImagXpressSdk.PressAndTapEventArgs

See Also

Reference

PressAndTapEventArgs Members
Accusoft.ImagXpressSdk Namespace


PressAndTapEventArgs Class Members

PressAndTapEventArgs Class Members
Properties

Accusoft.ImagXpressSdk Namespace : PressAndTapEventArgs Class

The following tables list the members exposed by PressAndTapEventArgs.

Public Constructors
 | Name | Description
Public Constructor | PressAndTapEventArgs Constructor | The main constructor which initializes a new instance of the PressAndTapEventArgs class.
Top
Public Properties
 | Name | Description
Public Property | PressedFingerLocation | Gets the location of the pressed finger during a press and tap with the touch interface.
Top
See Also

Reference

PressAndTapEventArgs Class
Accusoft.ImagXpressSdk Namespace


PressAndTapEventArgs Constructor

PressAndTapEventArgs Constructor

Accusoft.ImagXpressSdk Namespace > PressAndTapEventArgs Class : PressAndTapEventArgs Constructor
The main constructor which initializes a new instance of the PressAndTapEventArgs class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PressAndTapEventArgs()
public PressAndTapEventArgs()
public: PressAndTapEventArgs();
public:
PressAndTapEventArgs();
See Also

Reference

PressAndTapEventArgs Class
PressAndTapEventArgs Members


PressAndTapEventArgs Class Properties

PressAndTapEventArgs Class Properties

Accusoft.ImagXpressSdk Namespace : PressAndTapEventArgs Class

For a list of all members of this type, see PressAndTapEventArgs members.

Public Properties
 | Name | Description
Public Property | PressedFingerLocation | Gets the location of the pressed finger during a press and tap with the touch interface.
Top
See Also

Reference

PressAndTapEventArgs Class
Accusoft.ImagXpressSdk Namespace


PressAndTapEventArgs Constructor

PressAndTapEventArgs Constructor

Accusoft.ImagXpressSdk Namespace > PressAndTapEventArgs Class : PressAndTapEventArgs Constructor
Overload List
Overload | Description
PressAndTapEventArgs Constructor | The main constructor which initializes a new instance of the PressAndTapEventArgs class.
See Also

Reference

PressAndTapEventArgs Class
PressAndTapEventArgs Members


PressedFingerLocation Property

PressedFingerLocation Property

Accusoft.ImagXpressSdk Namespace > PressAndTapEventArgs Class : PressedFingerLocation Property
Gets the location of the pressed finger during a press and tap with the touch interface.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PressedFingerLocation As Point
'Usage

Dim instance As PressAndTapEventArgs
Dim value As Point

value = instance.PressedFingerLocation
public Point PressedFingerLocation {get;}
public: __property Point get_PressedFingerLocation();
public:
property Point PressedFingerLocation {
   Point get();
}

Property Value

A System.Drawing.Point value from the .NET Framework Class Library.
See Also

Reference

PressAndTapEventArgs Class
PressAndTapEventArgs Members


PrintImageEventArgs Class

PrintImageEventArgs Class
Members

Accusoft.ImagXpressSdk Namespace : PrintImageEventArgs Class
Provides data for the ImageXView.PaintImage Event.
Object Model
PrintImageEventArgs Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class PrintImageEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As PrintImageEventArgs
public class PrintImageEventArgs : System.EventArgs
public __gc class PrintImageEventArgs : public System.EventArgs
public ref class PrintImageEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
Accusoft.ImagXpressSdk.PrintImageEventArgs

See Also

Reference

PrintImageEventArgs Members
Accusoft.ImagXpressSdk Namespace


PrintImageEventArgs Class Members

PrintImageEventArgs Class Members
Properties

Accusoft.ImagXpressSdk Namespace : PrintImageEventArgs Class

The following tables list the members exposed by PrintImageEventArgs.

Public Constructors
 | Name | Description
Public Constructor | PrintImageEventArgs Constructor | Initializes a new instance of the PrintImageEventArgs class.
Top
Public Properties
 | Name | Description
Public Property | Graphics | Gets the System.Drawing.Graphics object.
Public Property | GraphicsUnit | Gets the graphics unit.
Public Property | ImageRectangle | Gets the image's rectangle.
Public Property | PrintRectangle | Gets the printer's rectangle.
Public Property | PrintType | Gets the type of the print that was performed.
Top
See Also

Reference

PrintImageEventArgs Class
Accusoft.ImagXpressSdk Namespace


PrintImageEventArgs Constructor

PrintImageEventArgs Constructor

Accusoft.ImagXpressSdk Namespace > PrintImageEventArgs Class : PrintImageEventArgs Constructor
Initializes a new instance of the PrintImageEventArgs class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PrintImageEventArgs()
public PrintImageEventArgs()
public: PrintImageEventArgs();
public:
PrintImageEventArgs();
See Also

Reference

PrintImageEventArgs Class
PrintImageEventArgs Members


PrintImageEventArgs Class Properties

PrintImageEventArgs Class Properties

Accusoft.ImagXpressSdk Namespace : PrintImageEventArgs Class

For a list of all members of this type, see PrintImageEventArgs members.

Public Properties
 | Name | Description
Public Property | Graphics | Gets the System.Drawing.Graphics object.
Public Property | GraphicsUnit | Gets the graphics unit.
Public Property | ImageRectangle | Gets the image's rectangle.
Public Property | PrintRectangle | Gets the printer's rectangle.
Public Property | PrintType | Gets the type of the print that was performed.
Top
See Also

Reference

PrintImageEventArgs Class
Accusoft.ImagXpressSdk Namespace


PrintImageEventArgs Constructor

PrintImageEventArgs Constructor

Accusoft.ImagXpressSdk Namespace > PrintImageEventArgs Class : PrintImageEventArgs Constructor
Overload List
Overload | Description
PrintImageEventArgs Constructor | Initializes a new instance of the PrintImageEventArgs class.
See Also

Reference

PrintImageEventArgs Class
PrintImageEventArgs Members


Graphics Property (PrintImageEventArgs)

Graphics Property (PrintImageEventArgs)

Accusoft.ImagXpressSdk Namespace > PrintImageEventArgs Class : Graphics Property
Gets the System.Drawing.Graphics object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Graphics As Graphics
'Usage

Dim instance As PrintImageEventArgs
Dim value As Graphics

value = instance.Graphics
public Graphics Graphics {get;}
public: __property Graphics* get_Graphics();
public:
property Graphics^ Graphics {
   Graphics^ get();
}

Property Value

The System.Drawing.Graphics object.
See Also

Reference

PrintImageEventArgs Class
PrintImageEventArgs Members


GraphicsUnit Property

GraphicsUnit Property

Accusoft.ImagXpressSdk Namespace > PrintImageEventArgs Class : GraphicsUnit Property
Gets the graphics unit.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property GraphicsUnit As GraphicsUnit
'Usage

Dim instance As PrintImageEventArgs
Dim value As GraphicsUnit

value = instance.GraphicsUnit
public GraphicsUnit GraphicsUnit {get;}
public: __property GraphicsUnit get_GraphicsUnit();
public:
property GraphicsUnit GraphicsUnit {
   GraphicsUnit get();
}

Property Value

The System.Drawing.GraphicsUnit.
See Also

Reference

PrintImageEventArgs Class
PrintImageEventArgs Members


ImageRectangle Property

ImageRectangle Property

Accusoft.ImagXpressSdk Namespace > PrintImageEventArgs Class : ImageRectangle Property
Gets the image's rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ImageRectangle As Rectangle
'Usage

Dim instance As PrintImageEventArgs
Dim value As Rectangle

value = instance.ImageRectangle
public Rectangle ImageRectangle {get;}
public: __property Rectangle get_ImageRectangle();
public:
property Rectangle ImageRectangle {
   Rectangle get();
}

Property Value

The image's System.Drawing.Rectangle.
See Also

Reference

PrintImageEventArgs Class
PrintImageEventArgs Members


PrintRectangle Property

PrintRectangle Property

Accusoft.ImagXpressSdk Namespace > PrintImageEventArgs Class : PrintRectangle Property
Gets the printer's rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PrintRectangle As Rectangle
'Usage

Dim instance As PrintImageEventArgs
Dim value As Rectangle

value = instance.PrintRectangle
public Rectangle PrintRectangle {get;}
public: __property Rectangle get_PrintRectangle();
public:
property Rectangle PrintRectangle {
   Rectangle get();
}

Property Value

The view System.Drawing.Rectangle.
See Also

Reference

PrintImageEventArgs Class
PrintImageEventArgs Members


PrintType Property

PrintType Property

Accusoft.ImagXpressSdk Namespace > PrintImageEventArgs Class : PrintType Property
Gets the type of the print that was performed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PrintType As PrintType
'Usage

Dim instance As PrintImageEventArgs
Dim value As PrintType

value = instance.PrintType
public PrintType PrintType {get;}
public: __property PrintType get_PrintType();
public:
property PrintType PrintType {
   PrintType get();
}

Property Value

The PrintType.
See Also

Reference

PrintImageEventArgs Class
PrintImageEventArgs Members


Processor Class

Processor Class
Members

Accusoft.ImagXpressSdk Namespace : Processor Class
This class implements methods and properties to enhance, edit and modify images.
Object Model
Processor ClassImageX ClassImageX ClassImageCalsCollection ClassImageCalsTag ClassImageX ClassImageX ClassImageX ClassImageX ClassImageX ClassImageX ClassImageX ClassImageXData ClassImageXIptcCollection ClassImageXIptcData ClassLoadOptions ClassImageModcaCollection ClassImageModcaTag ClassImageXData ClassImageXData ClassImageXData ClassImageX ClassResolution ClassImageXTagCollection ClassImageXTag ClassRedeyeCollection ClassRedeyeRectangle ClassImagXpress ClassLicensing Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ToolboxBitmapAttribute()>
Public Class Processor
   Inherits System.ComponentModel.Component
'Usage

Dim instance As Processor
[ToolboxBitmap()]
public class Processor : System.ComponentModel.Component
[ToolboxBitmap()]
public __gc class Processor : public System.ComponentModel.Component
[ToolboxBitmap()]
public ref class Processor : public System.ComponentModel.Component
Remarks

This class is the workhorse of ImagXpress. From redeye removal to image resizing, the Processor class contains many image processing methods for modifying the current image.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Accusoft.ImagXpressSdk.Processor

See Also

Reference

Processor Members
Accusoft.ImagXpressSdk Namespace


Processor Class Members

Processor Class Members
Properties Methods Events

Accusoft.ImagXpressSdk Namespace : Processor Class

The following tables list the members exposed by Processor.

Public Constructors
 | Name | Description
Public Constructor | Processor Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets and sets the background color of areas expanded by certain image processing operations.
Public Property | BinarizeBlur | Gets the BinarizeBlur value set by AutoBinarize or Binarize.
Public Property | BinarizeEccentricity | Gets the eccentricity value set by AutoBinarize or Binarize.
Public Property | BinarizeGridAngle | Gets the grid angle value set by AutoBinarize or Binarize.
Public Property | BinarizeGridPitch | Gets the grid pitch value set by AutoBinarize or Binarize.
Public Property | BinarizeHighThreshold | Gets the high threshold value set by AutoBinarize or Binarize.
Public Property | BinarizeLceFactor | Gets the local contrast enhancement factor set by AutoBinarize or Binarize.
Public Property | BinarizeLowThreshold | Gets the low threshold value set by AutoBinarize or Binarize.
Public Property | BinarizeMode | Gets the BinarizeMode value set by AutoBinarize or Binarize.
Public Property | BlankPageDetected | Gets an indicator if a blank page is detected.
Public Property | Confidence | Gets the confidence.
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContrastMethod | Gets and sets the contrast method to use.
Public Property | CountOfLinesFound | Gets the number of lines found.
Public Property | CountOfObjectsFound | Gets the number of objects found.
Public Property | CountOfSpecsFound | Gets the number of specs found.
Public Property | EnableArea | Gets and sets whether the area is enabled.
Public Property | EnableRegion | Gets and sets whether the region is enabled.
Public Property | Image | Gets and sets the image to be processed.
Public Property | ImageWasModified | Gets an indicator if the image was modified.
Public Property | LogPalette | Gets and sets the palette for use when the ColorDepth method is called.
Public Property | ProgressPercent | Gets and sets the ProgressEvent frequency.
Public Property | Redeyes | Gets and sets the redeye collection.
Public Property | RotationAngle | Gets the rotation angle.
Public Property | Site | Overridden. Gets and sets the System.ComponentModel.ISite of the Processor.
Public Property | Variation | Gets the variation.
Public Property | Workspace | Gets or sets the ImagXpress workspace component.
Top
Public Methods
 | Name | Description
Public Method | AdjustColorBalance | Overrides the default parameters when auto color balancing the image.
Public Method | AdjustHSL | Adjusts the hue, saturation, and luninance components of the current image.
Public Method | AdjustLightness | Automatically balances contrast in the image, adjusting the results of the auto lightness algorithm by a specified amount.
Public Method | AdjustRGB | Adjusts the red, green, and blue components of the current image.
Public Method | AlphaAdd | Overloaded. Adds a user created 8 bit alpha channel to an existing 24 bit channel thus promoting the image to 32 bits.
Public Method | AlphaBitmapReturn | Overloaded. This method is deprecated, use GetAlphaChannelAsHBitmap instead. Returns an 8 bit handle to an image.
Public Method | AlphaFill | Fills the alpha channel with the value specified.
Public Method | AlphaFlatten | A 32 bit image with an alpha channel (ARGB) will merge (alpha channel applied) to the specified background color resulting in a 24 bit RGB image.
Public Method | AlphaGet | Overloaded. This method has been marked as deprecated. Use the other AlphaGet(Int32,Int32) method instead. Returns the Alpha value specified by the x and y location.
Public Method | AlphaInvert | Inverts the alpha values throughout the current image, regions, or area.
Public Method | AlphaRemove | Strips an ARGB 32 bit image to just a 24 bit RGB image.
Public Method | AlphaSet | Allows the modification of an individual alpha value at the specified x and y coordinates.
Public Method | ApplyGrayscaleTransform | Overloaded. Permanently levels an 8 through 16-bit gray image to and 8-bit gray image.
Public Method | AutoBinarize | Automatically converts 8-bit and 24-bit images to a 1-bit image.
Public Method | AutoBinarize2 | Automatically converts 8-bit and 24-bit images to a 1-bit image.
Public Method | AutoColorBalance | Restores and balances the color quality within an image.
Public Method | AutoContrast | Adjusts the contrast in the current image.
Public Method | AutoCrop | Automatically crops the border space from an image.
Public Method | AutoLevel | Restores and balances color quality within an image.
Public Method | AutoLightness | Automatically assesses the adjusts contrast in light or dark regions of the image.
Public Method | AutoRemoveRedeye | Automatically reduces the red reflection of the flash seen in the eyes of people in color flash photo images.
Public Method | Binarize | Converts 8-bit and 24-bit images into a 1-bit monochrome or 8-bit grayscale output image, respectively.
Public Method | Blend | Blends each pixel in the current image with its neighboring pixels.
Public Method | Blur | Blurs the current image by averaging each pixel with each of its neighboring pixels giving it an 'out of focus' appearance.
Public Method | Brightness | Uniformly brightens the current image.
Public Method | Buttonize | Adds translucent bevels to the edges of the current image to give it the appearance of a 3D button.
Public Method | ColorCount | Returns the number of pixels of a specified color within the current image or image area.
Public Method | ColorDepth | Changes the bits per pixel of the current image.
Public Method | ColorJoin | Overloaded. Joins the colors as specified by the given parameters.
Public Method | ColorSeparation | Overloaded. Separates the color based on the given parameters.
Public Method | Contrast | Adjusts the contrast of the image.
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Crop | Crops the current image to the specified size.
Public Method | CropBorder | Performs border removal by cropping the edges of the current image.
Public Method | DeleteRegion | Deletes the current image processing region object.
Public Method | Deskew | Overloaded. Deskews the image using the specified DeskewType.
Public Method | Despeckle | Filters the image using a filter that attempts to eliminate noise in the image.
Public Method | Diffuse | Diffuses the current image by replacing each pixel with a randomly selected neighboring pixel.
Public Method | Dilate | Enlarges the boundaries of regions of foreground pixels in the current image using a 3x3 maximum filter.
Public Method | Dispose() | (Inherited from System.ComponentModel.Component)
Public Method | DocumentBlankPageDetect | Overloaded. Examines a rectangle on an image, determining if the page is considered blank, based on the amount of data on the page.
Public Method | DocumentBlobRemoval | Locates and removes large black objects in images such as binder punch holes.
Public Method | DocumentBorderCrop | Overloaded. Crops the borders of 1 bit per pixel documents.
Public Method | DocumentDeskew | Automatically detects and removes skew from current 1-bit depth images.
Public Method | DocumentDespeckle | Detects and removes specks from the current image.
Public Method | DocumentDilate | Examines pixels in the current image and expands the black ones by the given amount in a given direction.
Public Method | DocumentErode | Removes the black pixels in the current image by the given amount in the given direction.
Public Method | DocumentLineRemoval | Automatically detects and removes lines from the current image.
Public Method | DocumentShear | Shears current image clockwise or counter-clockwise.
Public Method | DocumentZoomSmooth | Replaces the current 1 bit-per-pixel image with an image whose width and height have been doubled and whose pixels have been smoothed.
Public Method | Emboss | Performs an emboss on the image causing it to look embellished with metal or embroidered look.
Public Method | Equalize | Equalizes the image by spreading its values across the full image.
Public Method | Erode | Erodes the image by eroding away the boundaries using a 3x3 minimum filter.
Public Method | Flip | Flips the current image from top to bottom.
Public Method | Gamma | Specifies the gamma correction.
Public Method | GetAlphaChannelAsBitmap | Returns a bitmap object of type System.Drawing.Imaging.PixelFormat.Format8bppIndexed which is an 8 bit gray scale image depicting the alpha channel data layer.
Public Method | GetAlphaChannelAsHBitmap | Returns an integer pointer which is a bitmap handle to a plane which is similar to an 8 bit gray scaled image.
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Matrix | Modifies the image using a 3x3 correlation matrix filter.
Public Method | Median | Reduces noise on an image by using a 3x3 median filter.
Public Method | Merge | Merges two images together such that the source image is merged with the current image specified in the processor. This method also specifies the type of merging.
Public Method | Mirror | Rotates the current DIB (Device Independent Bitmap) 180 degrees, then flips it to create a mirror image.
Public Method | Mosaic | Creates tiles or cells to represents the image.
Public Method | MotionBlur | Streaks or blurs objects on the image to display them as moving using the specified parameters.
Public Method | Negate | Creates a color negative of the current image.
Public Method | Noise | Creates more noise by the given parameters.
Public Method | Outline | Outlines the outter edges of the image by enhancing the edges.
Public Method | Parabolic | Modifies the image by the given ParabolicType.
Public Method | Perspective | Modifies the image using the given PerspectiveType and percent.
Public Method | Pinch | Modifies the image to look like it was pinched in the center using the given intensity.
Public Method | PolynomialWarp | Modifies and warps the image to the given points.
Public Method | Posterize | Reduces the number of colors to give it the effect of contours in the image.
Public Method | RemoveDust | Removes what appears to be dust on the image by the given parameters.
Public Method | RemoveRedeye | Removes what appears as red eye's in an image using the given parameters.
Public Method | RemoveScratches | Removes what appear to be scratches within color images along a line.
Public Method | ReplaceColors | Replaces a range of colors in the current image.
Public Method | Resize | Overloaded. Resizes the current image allowing passing in a new size and resize type.
Public Method | RGBColorCount | Returns three arrays, each containing 256 elements, which equate to a count of the red, green, and blue color intensities of the image.
Public Method | Ripple | Modifies the image to create a ripple effect as per the given parameters.
Public Method | Rotate | Rotates the current image.
Public Method | SetArea | Sets the area.
Public Method | SetRegion | Overloaded. Sets the given processing region for the image.
Public Method | Sharpen | Overloaded. Sharpens the image by the given intensity.
Public Method | Soften | Overloaded. Softens the image by the given intensity.
Public Method | Solarize | Modifies the image by inverting the pixel values to negative.
Public Method | Swirl | Modifies the image to appear in a swirl based on the given degrees.
Public Method | Tile | Modifies the image to appear in tiles based on the given tile size.
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Twist | Modifies the image to appear in a twist by the given block size and rotation.
Public Method | UniqueColors | Returns a count of unique colors in the current image.
Public Method | Unsharpen | Overloaded. Modifies the image to appear not as detailed based on the given intensity.
Top
Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | ProgressEvent | Notifies a change in progress status.
Top
See Also

Reference

Processor Class
Accusoft.ImagXpressSdk Namespace


Processor Constructor

Processor Constructor

Accusoft.ImagXpressSdk Namespace > Processor Class : Processor Constructor
Overload List
Overload | Description
Processor Constructor() | Initializes a new instance of the Processor class.
Processor Constructor(IContainer) | Initializes a new instance of the Processor class.
Processor Constructor(ImagXpress) | Initializes a new instance of the Processor class.
Processor Constructor(ImagXpress,ImageX) | Initializes a new instance of the Processor class.
Processor Constructor(IContainer,ImagXpress) | Initializes a new instance of the Processor class.
Processor Constructor(IContainer,ImagXpress,ImageX) | Initializes a new instance of the Processor class.
See Also

Reference

Processor Class
Processor Members


Processor Constructor()

Processor Constructor()

Accusoft.ImagXpressSdk Namespace > Processor Class > Processor Constructor : Processor Constructor()
Initializes a new instance of the Processor class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New Processor()
public Processor()
public: Processor();
public:
Processor();
Remarks

This is the default constructor for the Processor class. If you use this constructor you will need to set Workspace property before using the control. If you need to create a Processor dynamically it is recommended that you do so with one of the other constructors.

See Also

Reference

Processor Class
Processor Members
Overload List


Processor Constructor(IContainer)

Processor Constructor(IContainer)

Accusoft.ImagXpressSdk Namespace > Processor Class > Processor Constructor : Processor Constructor(IContainer)
The container that implements the System.ComponentModel.IContainer interface which will contain this component.
Initializes a new instance of the Processor class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal container As IContainer _
)
'Usage

Dim container As IContainer

Dim instance As New Processor(container)
public Processor(
   IContainer container
)
public: Processor(
   IContainer* container
)
public:
Processor(
   IContainer^ container
)

Parameters

container
The container that implements the System.ComponentModel.IContainer interface which will contain this component.
See Also

Reference

Processor Class
Processor Members
Overload List


Processor Constructor(ImagXpress)

Processor Constructor(ImagXpress)

Accusoft.ImagXpressSdk Namespace > Processor Class > Processor Constructor : Processor Constructor(ImagXpress)
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
Initializes a new instance of the Processor class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal imagXpress As ImagXpress _
)
'Usage

Dim imagXpress As ImagXpress

Dim instance As New Processor(imagXpress)
public Processor(
   ImagXpress imagXpress
)
public: Processor(
   ImagXpress* imagXpress
)
public:
Processor(
   ImagXpress^ imagXpress
)

Parameters

imagXpress
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
See Also

Reference

Processor Class
Processor Members
Overload List


Processor Constructor(ImagXpress,ImageX)

Processor Constructor(ImagXpress,ImageX)

Accusoft.ImagXpressSdk Namespace > Processor Class > Processor Constructor : Processor Constructor(ImagXpress,ImageX)
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
The ImageX class object.
Initializes a new instance of the Processor class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal imagXpress As ImagXpress, _
   ByVal image As ImageX _
)
'Usage

Dim imagXpress As ImagXpress
Dim image As ImageX

Dim instance As New Processor(imagXpress, image)
public Processor(
   ImagXpress imagXpress,
   ImageX image
)
public: Processor(
   ImagXpress* imagXpress,
   ImageX* image
)
public:
Processor(
   ImagXpress^ imagXpress,
   ImageX^ image
)

Parameters

imagXpress
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
image
The ImageX class object.
See Also

Reference

Processor Class
Processor Members
Overload List


Processor Constructor(IContainer,ImagXpress)

Processor Constructor(IContainer,ImagXpress)

Accusoft.ImagXpressSdk Namespace > Processor Class > Processor Constructor : Processor Constructor(IContainer,ImagXpress)
The container that implements the System.ComponentModel.IContainer interface which will contain this component.
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
Initializes a new instance of the Processor class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal container As IContainer, _
   ByVal imagXpress As ImagXpress _
)
'Usage

Dim container As IContainer
Dim imagXpress As ImagXpress

Dim instance As New Processor(container, imagXpress)
public Processor(
   IContainer container,
   ImagXpress imagXpress
)
public: Processor(
   IContainer* container,
   ImagXpress* imagXpress
)
public:
Processor(
   IContainer^ container,
   ImagXpress^ imagXpress
)

Parameters

container
The container that implements the System.ComponentModel.IContainer interface which will contain this component.
imagXpress
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
See Also

Reference

Processor Class
Processor Members
Overload List


Processor Constructor(IContainer,ImagXpress,ImageX)

Processor Constructor(IContainer,ImagXpress,ImageX)

Accusoft.ImagXpressSdk Namespace > Processor Class > Processor Constructor : Processor Constructor(IContainer,ImagXpress,ImageX)
The container that implements the System.ComponentModel.IContainer interface which will contain this component.
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
An ImageX class object.
Initializes a new instance of the Processor class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal container As IContainer, _
   ByVal imagXpress As ImagXpress, _
   ByVal Image As ImageX _
)
'Usage

Dim container As IContainer
Dim imagXpress As ImagXpress
Dim Image As ImageX

Dim instance As New Processor(container, imagXpress, Image)
public Processor(
   IContainer container,
   ImagXpress imagXpress,
   ImageX Image
)
public: Processor(
   IContainer* container,
   ImagXpress* imagXpress,
   ImageX* Image
)
public:
Processor(
   IContainer^ container,
   ImagXpress^ imagXpress,
   ImageX^ Image
)

Parameters

container
The container that implements the System.ComponentModel.IContainer interface which will contain this component.
imagXpress
An instance of the ImagXpress workspace component. This is the main ImagXpress component that typically must be dragged onto a form first.
Image
An ImageX class object.
See Also

Reference

Processor Class
Processor Members
Overload List


Processor Class Methods

Processor Class Methods

Accusoft.ImagXpressSdk Namespace : Processor Class

For a list of all members of this type, see Processor members.

Public Methods
 | Name | Description
Public Method | AdjustColorBalance | Overrides the default parameters when auto color balancing the image.
Public Method | AdjustHSL | Adjusts the hue, saturation, and luninance components of the current image.
Public Method | AdjustLightness | Automatically balances contrast in the image, adjusting the results of the auto lightness algorithm by a specified amount.
Public Method | AdjustRGB | Adjusts the red, green, and blue components of the current image.
Public Method | AlphaAdd | Overloaded. Adds a user created 8 bit alpha channel to an existing 24 bit channel thus promoting the image to 32 bits.
Public Method | AlphaBitmapReturn | Overloaded. This method is deprecated, use GetAlphaChannelAsHBitmap instead. Returns an 8 bit handle to an image.
Public Method | AlphaFill | Fills the alpha channel with the value specified.
Public Method | AlphaFlatten | A 32 bit image with an alpha channel (ARGB) will merge (alpha channel applied) to the specified background color resulting in a 24 bit RGB image.
Public Method | AlphaGet | Overloaded. This method has been marked as deprecated. Use the other AlphaGet(Int32,Int32) method instead. Returns the Alpha value specified by the x and y location.
Public Method | AlphaInvert | Inverts the alpha values throughout the current image, regions, or area.
Public Method | AlphaRemove | Strips an ARGB 32 bit image to just a 24 bit RGB image.
Public Method | AlphaSet | Allows the modification of an individual alpha value at the specified x and y coordinates.
Public Method | ApplyGrayscaleTransform | Overloaded. Permanently levels an 8 through 16-bit gray image to and 8-bit gray image.
Public Method | AutoBinarize | Automatically converts 8-bit and 24-bit images to a 1-bit image.
Public Method | AutoBinarize2 | Automatically converts 8-bit and 24-bit images to a 1-bit image.
Public Method | AutoColorBalance | Restores and balances the color quality within an image.
Public Method | AutoContrast | Adjusts the contrast in the current image.
Public Method | AutoCrop | Automatically crops the border space from an image.
Public Method | AutoLevel | Restores and balances color quality within an image.
Public Method | AutoLightness | Automatically assesses the adjusts contrast in light or dark regions of the image.
Public Method | AutoRemoveRedeye | Automatically reduces the red reflection of the flash seen in the eyes of people in color flash photo images.
Public Method | Binarize | Converts 8-bit and 24-bit images into a 1-bit monochrome or 8-bit grayscale output image, respectively.
Public Method | Blend | Blends each pixel in the current image with its neighboring pixels.
Public Method | Blur | Blurs the current image by averaging each pixel with each of its neighboring pixels giving it an 'out of focus' appearance.
Public Method | Brightness | Uniformly brightens the current image.
Public Method | Buttonize | Adds translucent bevels to the edges of the current image to give it the appearance of a 3D button.
Public Method | ColorCount | Returns the number of pixels of a specified color within the current image or image area.
Public Method | ColorDepth | Changes the bits per pixel of the current image.
Public Method | ColorJoin | Overloaded. Joins the colors as specified by the given parameters.
Public Method | ColorSeparation | Overloaded. Separates the color based on the given parameters.
Public Method | Contrast | Adjusts the contrast of the image.
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Crop | Crops the current image to the specified size.
Public Method | CropBorder | Performs border removal by cropping the edges of the current image.
Public Method | DeleteRegion | Deletes the current image processing region object.
Public Method | Deskew | Overloaded. Deskews the image using the specified DeskewType.
Public Method | Despeckle | Filters the image using a filter that attempts to eliminate noise in the image.
Public Method | Diffuse | Diffuses the current image by replacing each pixel with a randomly selected neighboring pixel.
Public Method | Dilate | Enlarges the boundaries of regions of foreground pixels in the current image using a 3x3 maximum filter.
Public Method | Dispose() | (Inherited from System.ComponentModel.Component)
Public Method | DocumentBlankPageDetect | Overloaded. Examines a rectangle on an image, determining if the page is considered blank, based on the amount of data on the page.
Public Method | DocumentBlobRemoval | Locates and removes large black objects in images such as binder punch holes.
Public Method | DocumentBorderCrop | Overloaded. Crops the borders of 1 bit per pixel documents.
Public Method | DocumentDeskew | Automatically detects and removes skew from current 1-bit depth images.
Public Method | DocumentDespeckle | Detects and removes specks from the current image.
Public Method | DocumentDilate | Examines pixels in the current image and expands the black ones by the given amount in a given direction.
Public Method | DocumentErode | Removes the black pixels in the current image by the given amount in the given direction.
Public Method | DocumentLineRemoval | Automatically detects and removes lines from the current image.
Public Method | DocumentShear | Shears current image clockwise or counter-clockwise.
Public Method | DocumentZoomSmooth | Replaces the current 1 bit-per-pixel image with an image whose width and height have been doubled and whose pixels have been smoothed.
Public Method | Emboss | Performs an emboss on the image causing it to look embellished with metal or embroidered look.
Public Method | Equalize | Equalizes the image by spreading its values across the full image.
Public Method | Erode | Erodes the image by eroding away the boundaries using a 3x3 minimum filter.
Public Method | Flip | Flips the current image from top to bottom.
Public Method | Gamma | Specifies the gamma correction.
Public Method | GetAlphaChannelAsBitmap | Returns a bitmap object of type System.Drawing.Imaging.PixelFormat.Format8bppIndexed which is an 8 bit gray scale image depicting the alpha channel data layer.
Public Method | GetAlphaChannelAsHBitmap | Returns an integer pointer which is a bitmap handle to a plane which is similar to an 8 bit gray scaled image.
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Matrix | Modifies the image using a 3x3 correlation matrix filter.
Public Method | Median | Reduces noise on an image by using a 3x3 median filter.
Public Method | Merge | Merges two images together such that the source image is merged with the current image specified in the processor. This method also specifies the type of merging.
Public Method | Mirror | Rotates the current DIB (Device Independent Bitmap) 180 degrees, then flips it to create a mirror image.
Public Method | Mosaic | Creates tiles or cells to represents the image.
Public Method | MotionBlur | Streaks or blurs objects on the image to display them as moving using the specified parameters.
Public Method | Negate | Creates a color negative of the current image.
Public Method | Noise | Creates more noise by the given parameters.
Public Method | Outline | Outlines the outter edges of the image by enhancing the edges.
Public Method | Parabolic | Modifies the image by the given ParabolicType.
Public Method | Perspective | Modifies the image using the given PerspectiveType and percent.
Public Method | Pinch | Modifies the image to look like it was pinched in the center using the given intensity.
Public Method | PolynomialWarp | Modifies and warps the image to the given points.
Public Method | Posterize | Reduces the number of colors to give it the effect of contours in the image.
Public Method | RemoveDust | Removes what appears to be dust on the image by the given parameters.
Public Method | RemoveRedeye | Removes what appears as red eye's in an image using the given parameters.
Public Method | RemoveScratches | Removes what appear to be scratches within color images along a line.
Public Method | ReplaceColors | Replaces a range of colors in the current image.
Public Method | Resize | Overloaded. Resizes the current image allowing passing in a new size and resize type.
Public Method | RGBColorCount | Returns three arrays, each containing 256 elements, which equate to a count of the red, green, and blue color intensities of the image.
Public Method | Ripple | Modifies the image to create a ripple effect as per the given parameters.
Public Method | Rotate | Rotates the current image.
Public Method | SetArea | Sets the area.
Public Method | SetRegion | Overloaded. Sets the given processing region for the image.
Public Method | Sharpen | Overloaded. Sharpens the image by the given intensity.
Public Method | Soften | Overloaded. Softens the image by the given intensity.
Public Method | Solarize | Modifies the image by inverting the pixel values to negative.
Public Method | Swirl | Modifies the image to appear in a swirl based on the given degrees.
Public Method | Tile | Modifies the image to appear in tiles based on the given tile size.
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Twist | Modifies the image to appear in a twist by the given block size and rotation.
Public Method | UniqueColors | Returns a count of unique colors in the current image.
Public Method | Unsharpen | Overloaded. Modifies the image to appear not as detailed based on the given intensity.
Top
See Also

Reference

Processor Class
Accusoft.ImagXpressSdk Namespace


AdjustColorBalance Method

AdjustColorBalance Method

Accusoft.ImagXpressSdk Namespace > Processor Class : AdjustColorBalance Method

An integer value which represents the color to balance.

The range is 0 - 100.

0 indicates no correction of the image.

Values greater than zero increase the amount of correction performed.

An integer which represents the red color of the auto color balance algorithm result.

0 indicates no change to the red component of the image. (Red component will be the same as in the original image.)

Values less than zero decrease the red component of the image.

Values greater than zero increase the red component of the image.

An integer which represents the green color of the auto color balance algorithm result.

0 indicates no change to the green component of the image. (Green component will be the same as in the original image.)

Values less than zero decrease the green component of the image.

Values greater than zero increase the green component of the image.

An integer which represents the blue color of the auto color balance algorithm result.

0 indicates no change to the blue component of the image. (Blue component will be the same as in the original image.)

Values less than zero decrease the blue component of the image.

Values greater than zero increase the blue component of the image.

Overrides the default parameters when auto color balancing the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub AdjustColorBalance( _
   ByVal color As Short, _
   ByVal red As Short, _
   ByVal green As Short, _
   ByVal blue As Short _
)
'Usage

Dim instance As Processor
Dim color As Short
Dim red As Short
Dim green As Short
Dim blue As Short

instance.AdjustColorBalance(color, red, green, blue)
public void AdjustColorBalance(
   short color,
   short red,
   short green,
   short blue
)
public: void AdjustColorBalance(
   short color,
   short red,
   short green,
   short blue
)
public:
void AdjustColorBalance(
   short color,
   short red,
   short green,
   short blue
)

Parameters

color

An integer value which represents the color to balance.

The range is 0 - 100.

0 indicates no correction of the image.

Values greater than zero increase the amount of correction performed.

red

An integer which represents the red color of the auto color balance algorithm result.

0 indicates no change to the red component of the image. (Red component will be the same as in the original image.)

Values less than zero decrease the red component of the image.

Values greater than zero increase the red component of the image.

green

An integer which represents the green color of the auto color balance algorithm result.

0 indicates no change to the green component of the image. (Green component will be the same as in the original image.)

Values less than zero decrease the green component of the image.

Values greater than zero increase the green component of the image.

blue

An integer which represents the blue color of the auto color balance algorithm result.

0 indicates no change to the blue component of the image. (Blue component will be the same as in the original image.)

Values less than zero decrease the blue component of the image.

Values greater than zero increase the blue component of the image.

Remarks

This method applies the same algorithm as the AutoColorBalance method to automatically balance color in the image, but enables the user to override the default parameters of the algorithm.

Since pixel values must fall within the range of 0 - 255, resulting pixel values less than 0 are set to 0 and resulting pixel values greater than 255 are set to 255.

Note: Available in Professional edition.

See Also

Reference

Processor Class
Processor Members


AdjustHSL Method

AdjustHSL Method

Accusoft.ImagXpressSdk Namespace > Processor Class : AdjustHSL Method
The AdjustType enumeration value set.
An integer value which represents the adjustment to the hue of the current image.

For adjustType = AsPercent (0), the valid range is -100 to 100 (percent).

For adjustType = InUnits (1), the valid range is -360 to 360 (units).

An integer value which represents the saturation of the current image.

For adjustType = AsPercent (0), the valid value range is -100 to 100 (percent).

For adjustType = InUnits (1), the valid range is -360 to 360 (units).

An integer value which represents the luminance of the current image.

For adjustType = AsPercent (0), the valid value range is -100 to 100 (percent).

For adjustType = InUnits (1), the valid value range is -360 to 360 (units).

Adjusts the hue, saturation, and luninance components of the current image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub AdjustHSL( _
   ByVal adjustType As AdjustType, _
   ByVal hue As Integer, _
   ByVal saturation As Integer, _
   ByVal luminance As Integer _
)
'Usage

Dim instance As Processor
Dim adjustType As AdjustType
Dim hue As Integer
Dim saturation As Integer
Dim luminance As Integer

instance.AdjustHSL(adjustType, hue, saturation, luminance)
public void AdjustHSL(
   AdjustType adjustType,
   int hue,
   int saturation,
   int luminance
)
public: void AdjustHSL(
   AdjustType adjustType,
   int hue,
   int saturation,
   int luminance
)
public:
void AdjustHSL(
   AdjustType adjustType,
   int hue,
   int saturation,
   int luminance
)

Parameters

adjustType
The AdjustType enumeration value set.
hue
An integer value which represents the adjustment to the hue of the current image.

For adjustType = AsPercent (0), the valid range is -100 to 100 (percent).

For adjustType = InUnits (1), the valid range is -360 to 360 (units).

saturation

An integer value which represents the saturation of the current image.

For adjustType = AsPercent (0), the valid value range is -100 to 100 (percent).

For adjustType = InUnits (1), the valid range is -360 to 360 (units).

luminance

An integer value which represents the luminance of the current image.

For adjustType = AsPercent (0), the valid value range is -100 to 100 (percent).

For adjustType = InUnits (1), the valid value range is -360 to 360 (units).

See Also

Reference

Processor Class
Processor Members


AdjustLightness Method

AdjustLightness Method

Accusoft.ImagXpressSdk Namespace > Processor Class : AdjustLightness Method

An integer value which represents the amount of brightening that is applied to shadowed image area.

The range for this parameter is 0 - 100.

A value of 0 results in no brightening. Higher values indicate a greater increase of brightness to be applied to the highlighted image area.

An integer value which repesents the amount of brightness decreasing that is applied to the highlighted image areas.

The range for this parameter is 0 - 100

A value of 0 results in no decrease in brightness. Higher values indicate a greater decrease of brightness in shadowed image areas.

Automatically balances contrast in the image, adjusting the results of the auto lightness algorithm by a specified amount.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub AdjustLightness( _
   ByVal shadows As Short, _
   ByVal highlights As Short _
)
'Usage

Dim instance As Processor
Dim shadows As Short
Dim highlights As Short

instance.AdjustLightness(shadows, highlights)
public void AdjustLightness(
   short shadows,
   short highlights
)
public: void AdjustLightness(
   short shadows,
   short highlights
)
public:
void AdjustLightness(
   short shadows,
   short highlights
)

Parameters

shadows

An integer value which represents the amount of brightening that is applied to shadowed image area.

The range for this parameter is 0 - 100.

A value of 0 results in no brightening. Higher values indicate a greater increase of brightness to be applied to the highlighted image area.

highlights

An integer value which repesents the amount of brightness decreasing that is applied to the highlighted image areas.

The range for this parameter is 0 - 100

A value of 0 results in no decrease in brightness. Higher values indicate a greater decrease of brightness in shadowed image areas.

Remarks

This method applies the same algorithm as the AutoLightness method to automatically balance color in the image, but enables the user to adjust the results of the algorithm by a specified amount.

Note: Available in Professional edition.

See Also

Reference

Processor Class
Processor Members


AdjustRGB Method

AdjustRGB Method
Example

Accusoft.ImagXpressSdk Namespace > Processor Class : AdjustRGB Method
The AdjustType enumeration value set. The AdjustType indicates whether the red, green, and blue parameters are specified in units or by percentage.
An integer value which represents the smount of adjustment to apply to the red color component.
An integer value which represents the amount of adjustment to apply to the green color component.
An integer value which represents the amount of adjustment to apply to the blue color component.
Adjusts the red, green, and blue components of the current image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub AdjustRGB( _
   ByVal adjustType As AdjustType, _
   ByVal red As Integer, _
   ByVal green As Integer, _
   ByVal blue As Integer _
)
'Usage

Dim instance As Processor
Dim adjustType As AdjustType
Dim red As Integer
Dim green As Integer
Dim blue As Integer

instance.AdjustRGB(adjustType, red, green, blue)
public void AdjustRGB(
   AdjustType adjustType,
   int red,
   int green,
   int blue
)
public: void AdjustRGB(
   AdjustType adjustType,
   int red,
   int green,
   int blue
)
public:
void AdjustRGB(
   AdjustType adjustType,
   int red,
   int green,
   int blue
)

Parameters

adjustType
The AdjustType enumeration value set. The AdjustType indicates whether the red, green, and blue parameters are specified in units or by percentage.
red
An integer value which represents the smount of adjustment to apply to the red color component.
green
An integer value which represents the amount of adjustment to apply to the green color component.
blue
An integer value which represents the amount of adjustment to apply to the blue color component.
Remarks

When adjustType = AsPercent (0), valid red, green, and blue values are between -100 and 100 (percent).

When adjustType = InUnits (1), valid RGB values are between -255 and 255 (units). Since pixel values must fall within the range 0-255, resulting pixel values less than 0 are set to 0 and resulting pixel values greater than 255 are set to 255.

Example

Sepia sample

The following example uses the AdjustRGB method and the ColorDepth method, to convert an image to Sepia.

  • C#
private void ConvertToSepia(ImageX image)
{
    using (Processor processor1 = new Processor(imagXpress1, image))
    {
        processor1.ColorDepth(8, PaletteType.Gray, DitherType.NoDither);
        processor1.ColorDepth(24, PaletteType.Optimized, DitherType.NoDither);
        processor1.AdjustRGB(AdjustType.InUnits, 40, 30, -10);
        processor1.Brightness(-10);
        processor1.Image = null;
    }
}
See Also

Reference

Processor Class
Processor Members


AlphaAdd Method

AlphaAdd Method

Accusoft.ImagXpressSdk Namespace > Processor Class : AlphaAdd Method
Adds a user created 8 bit alpha channel to an existing 24 bit channel thus promoting the image to 32 bits.
Overload List
Overload | Description
AlphaAdd(IntPtr) | Adds a user created 8 bit alpha channel to an existing 24 bit channel thus promoting the image to 32 bits.
AlphaAdd(Bitmap) | Adds alpha channel information to an image.
See Also

Reference

Processor Class
Processor Members


AlphaAdd(IntPtr) Method

AlphaAdd(IntPtr) Method

Accusoft.ImagXpressSdk Namespace > Processor Class > AlphaAdd Method : AlphaAdd(IntPtr) Method
Adds a user created 8 bit alpha channel to an existing 24 bit channel thus promoting the image to 32 bits.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub AlphaAdd( _
   ByVal hPlane As IntPtr _
)
'Usage

Dim instance As Processor
Dim hPlane As IntPtr

instance.AlphaAdd(hPlane)
public void AlphaAdd(
   IntPtr hPlane
)
public: void AlphaAdd(
   IntPtr hPlane
)
public:
void AlphaAdd(
   IntPtr hPlane
)

Parameters

hPlane
Remarks

The Bitmap handle must be an 8 bit gray scaled handle hPlane is a Bitmap handle and must be of the same dimensions of width and height to the image being modified

If the image is not 24 bit than an error is thrown.

See Also

Reference

Processor Class
Processor Members
Overload List


AlphaAdd(Bitmap) Method

AlphaAdd(Bitmap) Method

Accusoft.ImagXpressSdk Namespace > Processor Class > AlphaAdd Method : AlphaAdd(Bitmap) Method

A System.Drawing.Bitmap which represents the plane to add.

This plane should be the same width and height of the image it is being added to. It must be an 9 bit gray scale type with a uniform grayscale palette.

Adds alpha channel information to an image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub AlphaAdd( _
   ByVal Plane As Bitmap _
)
'Usage

Dim instance As Processor
Dim Plane As Bitmap

instance.AlphaAdd(Plane)
public void AlphaAdd(
   Bitmap Plane
)
public: void AlphaAdd(
   Bitmap* Plane
)
public:
void AlphaAdd(
   Bitmap^ Plane
)

Parameters

Plane

A System.Drawing.Bitmap which represents the plane to add.

This plane should be the same width and height of the image it is being added to. It must be an 9 bit gray scale type with a uniform grayscale palette.

Remarks

Note: The image bitmap should be of System.Drawing.Imaging.PixelFormat.Format8bppIndexed.

If the original image is not a 24-bit, an error is thrown.

See Also

Reference

Processor Class
Processor Members
Overload List


AlphaBitmapReturn Method

AlphaBitmapReturn Method

Accusoft.ImagXpressSdk Namespace > Processor Class : AlphaBitmapReturn Method

This method is deprecated, use GetAlphaChannelAsHBitmap instead.

Returns an 8 bit handle to an image.
Overload List
Overload | Description
AlphaBitmapReturn(IntPtr) | This method is deprecated, use GetAlphaChannelAsHBitmap instead. Returns an 8 bit handle to an image.
AlphaBitmapReturn(Bitmap) | This method is deprecated, please use GetAlphaChannelAsBitmap instead. Returns a bitmap object of type System.Drawing.Imaging.PixelFormat.Format8bppIndexed which is an 8 bit gray scale image depicting the alpha channel data layer.
See Also

Reference

Processor Class
Processor Members


AlphaBitmapReturn(IntPtr) Method

AlphaBitmapReturn(IntPtr) Method

Accusoft.ImagXpressSdk Namespace > Processor Class > AlphaBitmapReturn Method : AlphaBitmapReturn(IntPtr) Method
An integer pointer which is a bitmap handle to a plane which is similar to an 8 bit gray scaled image.

This method is deprecated, use GetAlphaChannelAsHBitmap instead.

Returns an 8 bit handle to an image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("This method is deprecated, use GetAlphaChannelAsHBitmap() instead.")>
Public Overloads Sub AlphaBitmapReturn( _
   ByRef hPlane As IntPtr _
)
'Usage

Dim instance As Processor
Dim hPlane As IntPtr

instance.AlphaBitmapReturn(hPlane)
[Obsolete("This method is deprecated, use GetAlphaChannelAsHBitmap() instead.")]
public void AlphaBitmapReturn(
   out IntPtr hPlane
)
[Obsolete("This method is deprecated, use GetAlphaChannelAsHBitmap() instead.")]
public: void AlphaBitmapReturn(
   [PARAMFLAG::Out] IntPtr hPlane
)
[Obsolete("This method is deprecated, use GetAlphaChannelAsHBitmap() instead.")]
public:
void AlphaBitmapReturn(
   [Out] IntPtr hPlane
)

Parameters

hPlane
An integer pointer which is a bitmap handle to a plane which is similar to an 8 bit gray scaled image.
Remarks

Returning the handle implicitly reduces the image down to 24 bit. The alpha layer may be modified and restored via the AlphaAdd(IntPtr) method.

The original image must be a 32 bit image where 8 bits are the alpha layer and 24 bits are rgb layer.

See Also

Reference

Processor Class
Processor Members
Overload List


AlphaBitmapReturn(Bitmap) Method

AlphaBitmapReturn(Bitmap) Method

Accusoft.ImagXpressSdk Namespace > Processor Class > AlphaBitmapReturn Method : AlphaBitmapReturn(Bitmap) Method
A System.Drawing.Bitmap value which represents the returned bitmap.

This method is deprecated, please use GetAlphaChannelAsBitmap instead.

Returns a bitmap object of type System.Drawing.Imaging.PixelFormat.Format8bppIndexed which is an 8 bit gray scale image depicting the alpha channel data layer.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("This method is deprecated, please use GetAlphaChannelAsBitmap() instead.")>
Public Overloads Sub AlphaBitmapReturn( _
   ByRef ReturnBitmap As Bitmap _
)
'Usage

Dim instance As Processor
Dim ReturnBitmap As Bitmap

instance.AlphaBitmapReturn(ReturnBitmap)
[Obsolete("This method is deprecated, please use GetAlphaChannelAsBitmap() instead.")]
public void AlphaBitmapReturn(
   out Bitmap ReturnBitmap
)
[Obsolete("This method is deprecated, please use GetAlphaChannelAsBitmap() instead.")]
public: void AlphaBitmapReturn(
   [PARAMFLAG::Out] Bitmap* ReturnBitmap
)
[Obsolete("This method is deprecated, please use GetAlphaChannelAsBitmap() instead.")]
public:
void AlphaBitmapReturn(
   [Out] Bitmap^ ReturnBitmap
)

Parameters

ReturnBitmap
A System.Drawing.Bitmap value which represents the returned bitmap.
Remarks

The original image must be a 32 bit image where 8 bits are the alpha layer and 24 bits are rgb color layer.

Returning the handle implicitly reduces the image down to 24 bit. The alpha object may be modified and restored via the AlphaAdd method.

See Also

Reference

Processor Class
Processor Members
Overload List


AlphaFill Method

AlphaFill Method

Accusoft.ImagXpressSdk Namespace > Processor Class : AlphaFill Method
A System.Byte which represents the alpha information to fill.
Fills the alpha channel with the value specified.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub AlphaFill( _
   ByVal AlphaValue As Byte _
)
'Usage

Dim instance As Processor
Dim AlphaValue As Byte

instance.AlphaFill(AlphaValue)
public void AlphaFill(
   byte AlphaValue
)
public: void AlphaFill(
   byte AlphaValue
)
public:
void AlphaFill(
   byte AlphaValue
)

Parameters

AlphaValue
A System.Byte which represents the alpha information to fill.
Remarks

If the region or area is set prior to this method, only that region or area will be filled with the value specified.

See Also

Reference

Processor Class
Processor Members


AlphaFlatten Method

AlphaFlatten Method

Accusoft.ImagXpressSdk Namespace > Processor Class : AlphaFlatten Method
A System.Drawing.Color value which represents the 24-bit color spectrum which will display as transparency.
A 32 bit image with an alpha channel (ARGB) will merge (alpha channel applied) to the specified background color resulting in a 24 bit RGB image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub AlphaFlatten( _
   ByVal color As Color _
)
'Usage

Dim instance As Processor
Dim color As Color

instance.AlphaFlatten(color)
public void AlphaFlatten(
   Color color
)
public: void AlphaFlatten(
   Color color
)
public:
void AlphaFlatten(
   Color color
)

Parameters

color
A System.Drawing.Color value which represents the 24-bit color spectrum which will display as transparency.
Remarks

The image must be a 32 bit image including alpha channel prior to calling this method, or an exception is thrown.

See Also

Reference

Processor Class
Processor Members


AlphaGet Method

AlphaGet Method

Accusoft.ImagXpressSdk Namespace > Processor Class : AlphaGet Method

This method has been marked as deprecated. Use the other AlphaGet(Int32,Int32) method instead.

Returns the Alpha value specified by the x and y location.
Overload List
Overload | Description
AlphaGet(Int32,Int32,Byte) | This method has been marked as deprecated. Use the other AlphaGet(Int32,Int32) method instead. Returns the Alpha value specified by the x and y location.
AlphaGet(Int32,Int32) | Returns the Alpha value specified by the x and y location.
See Also

Reference

Processor Class
Processor Members


AlphaGet(Int32,Int32,Byte) Method

AlphaGet(Int32,Int32,Byte) Method

Accusoft.ImagXpressSdk Namespace > Processor Class > AlphaGet Method : AlphaGet(Int32,Int32,Byte) Method
An integer value which represents the horizontal coordinate of the pixel to be modified within the image.
An integer value which represents the vertical coordinate of the pixel to be modified within the image.
A System.Byte which represents the alpha value returned.

This method has been marked as deprecated. Use the other AlphaGet(Int32,Int32) method instead.

Returns the Alpha value specified by the x and y location.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("This method is deprecated, use the other AlphaGet(Int32, Int32) method instead.")>
Public Overloads Sub AlphaGet( _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByRef pAlphaValue As Byte _
)
'Usage

Dim instance As Processor
Dim x As Integer
Dim y As Integer
Dim pAlphaValue As Byte

instance.AlphaGet(x, y, pAlphaValue)
[Obsolete("This method is deprecated, use the other AlphaGet(Int32, Int32) method instead.")]
public void AlphaGet(
   int x,
   int y,
   out byte pAlphaValue
)
[Obsolete("This method is deprecated, use the other AlphaGet(Int32, Int32) method instead.")]
public: void AlphaGet(
   int x,
   int y,
   [PARAMFLAG::Out] byte pAlphaValue
)
[Obsolete("This method is deprecated, use the other AlphaGet(Int32, Int32) method instead.")]
public:
void AlphaGet(
   int x,
   int y,
   [Out] byte pAlphaValue
)

Parameters

x
An integer value which represents the horizontal coordinate of the pixel to be modified within the image.
y
An integer value which represents the vertical coordinate of the pixel to be modified within the image.
pAlphaValue
A System.Byte which represents the alpha value returned.
Remarks

The value range is from 0 to 255.

The x and y coordinates must stay with the width and height dimensions of the image.

See Also

Reference

Processor Class
Processor Members
Overload List


AlphaGet(Int32,Int32) Method

AlphaGet(Int32,Int32) Method

Accusoft.ImagXpressSdk Namespace > Processor Class > AlphaGet Method : AlphaGet(Int32,Int32) Method
An integer value which represents the horizontal coordinate of the pixel to be modified within the image.
An integer value which represents the vertical coordinate of the pixel to be modified within the image.
Returns the Alpha value specified by the x and y location.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function AlphaGet( _
   ByVal x As Integer, _
   ByVal y As Integer _
) As Byte
'Usage

Dim instance As Processor
Dim x As Integer
Dim y As Integer
Dim value As Byte

value = instance.AlphaGet(x, y)
public byte AlphaGet(
   int x,
   int y
)
public: byte AlphaGet(
   int x,
   int y
)
public:
byte AlphaGet(
   int x,
   int y
)

Parameters

x
An integer value which represents the horizontal coordinate of the pixel to be modified within the image.
y
An integer value which represents the vertical coordinate of the pixel to be modified within the image.

Return Value

A System.Byte which represents the alpha value returned.
Remarks

The value range is from 0 to 255.

The x and y coordinates must stay with the width and height dimensions of the image.

See Also

Reference

Processor Class
Processor Members
Overload List


AlphaInvert Method

AlphaInvert Method

Accusoft.ImagXpressSdk Namespace > Processor Class : AlphaInvert Method
Inverts the alpha values throughout the current image, regions, or area.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub AlphaInvert()
'Usage

Dim instance As Processor

instance.AlphaInvert()
public void AlphaInvert()
public: void AlphaInvert();
public:
void AlphaInvert();
Remarks

A set region or area will confine the operation to just that area.

See Also

Reference

Processor Class
Processor Members


AlphaRemove Method

AlphaRemove Method

Accusoft.ImagXpressSdk Namespace > Processor Class : AlphaRemove Method
Strips an ARGB 32 bit image to just a 24 bit RGB image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub AlphaRemove()
'Usage

Dim instance As Processor

instance.AlphaRemove()
public void AlphaRemove()
public: void AlphaRemove();
public:
void AlphaRemove();
Remarks

The alpha channel is removed from a 32 bit image, to create a 24-bit image without an alpha channel. The alpha channel information is not saved.

Note: The current image must be a signed 32 bit image including alpha information prior to calling this method, or an exception is thrown.

See Also

Reference

Processor Class
Processor Members


AlphaSet Method

AlphaSet Method

Accusoft.ImagXpressSdk Namespace > Processor Class : AlphaSet Method
An integer value which represents the horizontal coordinate of the pixel to be modified within the image.
An integer value which represents the vertical coordinate of the pixel to be modified within the image.
A System.Byte which represents the alpha value to apply to the specified pixel.
Allows the modification of an individual alpha value at the specified x and y coordinates.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub AlphaSet( _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal AlphaValue As Byte _
)
'Usage

Dim instance As Processor
Dim x As Integer
Dim y As Integer
Dim AlphaValue As Byte

instance.AlphaSet(x, y, AlphaValue)
public void AlphaSet(
   int x,
   int y,
   byte AlphaValue
)
public: void AlphaSet(
   int x,
   int y,
   byte AlphaValue
)
public:
void AlphaSet(
   int x,
   int y,
   byte AlphaValue
)

Parameters

x
An integer value which represents the horizontal coordinate of the pixel to be modified within the image.
y
An integer value which represents the vertical coordinate of the pixel to be modified within the image.
AlphaValue
A System.Byte which represents the alpha value to apply to the specified pixel.
Remarks

The value ranges from 0 to 255.

The x and y coordinates must stay with the width and height dimensions of the image.

See Also

Reference

Processor Class
Processor Members


ApplyGrayscaleTransform Method

ApplyGrayscaleTransform Method

Accusoft.ImagXpressSdk Namespace > Processor Class : ApplyGrayscaleTransform Method
Permanently levels an 8 through 16-bit gray image to and 8-bit gray image.
Overload List
Overload | Description
ApplyGrayscaleTransform(Int32,Int32) | Permanently levels an 8 through 16-bit gray image to and 8-bit gray image.
ApplyGrayscaleTransform(Medical) | Permanently levels an 8 through 16-bit gray image to and 8-bit gray image in a manner consistent to the DICOM specification.
See Also

Reference

Processor Class
Processor Members


ApplyGrayscaleTransform(Int32,Int32) Method

ApplyGrayscaleTransform(Int32,Int32) Method
Example

Accusoft.ImagXpressSdk Namespace > Processor Class > ApplyGrayscaleTransform Method : ApplyGrayscaleTransform(Int32,Int32) Method
The brightness intensity from -100 to 100.
The contrast intensity from -100 to 100.
Permanently levels an 8 through 16-bit gray image to and 8-bit gray image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub ApplyGrayscaleTransform( _
   ByVal brightness As Integer, _
   ByVal contrast As Integer _
)
'Usage

Dim instance As Processor
Dim brightness As Integer
Dim contrast As Integer

instance.ApplyGrayscaleTransform(brightness, contrast)
public void ApplyGrayscaleTransform(
   int brightness,
   int contrast
)
public: void ApplyGrayscaleTransform(
   int brightness,
   int contrast
)
public:
void ApplyGrayscaleTransform(
   int brightness,
   int contrast
)

Parameters

brightness
The brightness intensity from -100 to 100.
contrast
The contrast intensity from -100 to 100.
Exceptions
Exception | Description
ProcessorException | A Processor exception.
Remarks

Some images describe more shades of gray than the human eye can discriminate. It is widely held that 256 shades are discernable. This method calculates a factor to multiply the values by to convert the selected range of grays to 256.

In order to further process or save 9-bit to 16-bit grayscale images, this method may need to be called first.

Note: Available in Professional edition.

Example
  • C#
// create the processor class
Accusoft.ImagXpressSdk.Processor processor = new Accusoft.ImagXpressSdk.Processor( );
// associate it with a 8 to 16 bit per pixel image
processor.Image = highGrayImageX;
// apply the standard grayscale transform making the image brighter and enhancing the contrast
processor.ApplyGrayscaleTransform( 30, 10 );
See Also

Reference

Processor Class
Processor Members
Overload List


ApplyGrayscaleTransform(Medical) Method

ApplyGrayscaleTransform(Medical) Method
Example

Accusoft.ImagXpressSdk Namespace > Processor Class > ApplyGrayscaleTransform Method : ApplyGrayscaleTransform(Medical) Method
A medical object that contains the necessary information to perform the grayscale transformation with regard to the DICOM specification.
Permanently levels an 8 through 16-bit gray image to and 8-bit gray image in a manner consistent to the DICOM specification.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub ApplyGrayscaleTransform( _
   ByVal medical As Medical _
)
'Usage

Dim instance As Processor
Dim medical As Medical

instance.ApplyGrayscaleTransform(medical)
public void ApplyGrayscaleTransform(
   Medical medical
)
public: void ApplyGrayscaleTransform(
   Medical* medical
)
public:
void ApplyGrayscaleTransform(
   Medical^ medical
)

Parameters

medical
A medical object that contains the necessary information to perform the grayscale transformation with regard to the DICOM specification.
Exceptions
Exception | Description
ProcessorException | A processor exception.
Remarks

Some images describe more shades of gray than the human eye can discriminate. It is widely held that 256 shades are discernable. This method uses a range and area of values you are interested in to select the 256 grays.

This method should only be used when the DICOM specific information is available.

In order to further process or save 9-bit to 16-bit grayscale images, this method may need to be called first.

Note: Available in Professional edition.

Example
  • C#
// create the processor class
Accusoft.ImagXpressSdk.Processor processor = new Accusoft.ImagXpressSdk.Processor( );
// associate it with a 8 to 16 bit per pixel image
processor.Image = highGrayImageX;
// create a medical object and fill in the DICOM information explicitly
Accusoft.ImagXpressSdk.Medical medical = new Accusoft.ImagXpressSdk.Medical( );
medical.WindowWidth = 128.0;
medical.WindowCenter = 128.0;
// apply the medical grayscale transform
processor.ApplyGrayscaleTransform( medical );
See Also

Reference

Processor Class
Processor Members
Overload List


AutoBinarize Method

AutoBinarize Method

Accusoft.ImagXpressSdk Namespace > Processor Class : AutoBinarize Method
Automatically converts 8-bit and 24-bit images to a 1-bit image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub AutoBinarize()
'Usage

Dim instance As Processor

instance.AutoBinarize()
public void AutoBinarize()
public: void AutoBinarize();
public:
void AutoBinarize();
Remarks

Binarization is often done to clean up an image (e.g. in preparation for OCR), or to create an image effect.

This method analyzes the image and sets the best parameters to binarize the image automatically.

Important Tip: Because the image is analyzed extensively it is much slower than calling Binarize directly. Use the following properties to pass into the Binarize method for faster processing of similar images.

This method sets the following properties with the values it used to binarize the image:

  • BinarizeMode
  • BinarizeLowThreshold
  • BinarizeHighThreshold
  • BinarizeGridAngle
  • BinarizeGridPitch
  • BinarizeEccentricity
  • BinarizeLceFactor
  • BinarizeBlur

Note: These properties are also set with the values that is passed into the Binarize method. If you call the Binarize method with some other value, those properties will reflect those new values.

For 1-bit output, this method modifies the color palette associated with the image, setting it to two colors, with black as color 0 and white as color 1.

See Also

Reference

Processor Class
Processor Members


AutoBinarize2 Method

AutoBinarize2 Method

Accusoft.ImagXpressSdk Namespace > Processor Class : AutoBinarize2 Method
Automatically converts 8-bit and 24-bit images to a 1-bit image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub AutoBinarize2()
'Usage

Dim instance As Processor

instance.AutoBinarize2()
public void AutoBinarize2()
public: void AutoBinarize2();
public:
void AutoBinarize2();
Remarks

Binarization is often done to clean up an image (e.g. in preparation for OCR), or to create an image effect.

This method automatically binarizes the image.

This version of automatic binarize is different than the AutoBinarize method. It uses a different and faster algorithm to binarize the image automatically. However it does not set any of the properties the AutoBinarize method sets for additional calls to the Binarize method.

See Also

Reference

Processor Class
Processor Members


AutoColorBalance Method

AutoColorBalance Method

Accusoft.ImagXpressSdk Namespace > Processor Class : AutoColorBalance Method
Restores and balances the color quality within an image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub AutoColorBalance()
'Usage

Dim instance As Processor

instance.AutoColorBalance()
public void AutoColorBalance()
public: void AutoColorBalance();
public:
void AutoColorBalance();
Remarks

Similar to AutoLevel, but a different algorithm. These methods function by centering the median of the Cb (of YCbCr, which is related to the blue minus the luminance) component histogram. AutoLevel and AutoColorBalance methods effect images differently, depending on their color content. This method is automatic.

Note: Available in Professional edition.

See Also

Reference

Processor Class
Processor Members


AutoContrast Method

AutoContrast Method

Accusoft.ImagXpressSdk Namespace > Processor Class : AutoContrast Method
Adjusts the contrast in the current image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub AutoContrast()
'Usage

Dim instance As Processor

instance.AutoContrast()
public void AutoContrast()
public: void AutoContrast();
public:
void AutoContrast();
Remarks

To override the default parameters used in the auto-contrast algorithm, call the Contrast method.

See Also

Reference

Processor Class
Processor Members


AutoCrop Method

AutoCrop Method

Accusoft.ImagXpressSdk Namespace > Processor Class : AutoCrop Method

A float value which represents the percentage of pixels that indicate that the inner edge of the border has been reached.

Valid values are 0.0 to 1.0

This value may be adjusted to compensate for noise that is typically found in scanned documents. Typically this value will be less than 0.1. For cleaner images this value should be even lower. In this instance, some value around or below 0.02 would be a good choice. For a computer generated image with no noise, 0.0 may be used. A value of 1.0 would never allow any cropping to occur.

A System.Drawing.Point value which represent the (left/right, top/bottom) size in pixels for the cropped image to maintain for a border.
Automatically crops the border space from an image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub AutoCrop( _
   ByVal percentCrop As Single, _
   ByVal border As Point _
)
'Usage

Dim instance As Processor
Dim percentCrop As Single
Dim border As Point

instance.AutoCrop(percentCrop, border)
public void AutoCrop(
   float percentCrop,
   Point border
)
public: void AutoCrop(
   float percentCrop,
   Point border
)
public:
void AutoCrop(
   float percentCrop,
   Point border
)

Parameters

percentCrop

A float value which represents the percentage of pixels that indicate that the inner edge of the border has been reached.

Valid values are 0.0 to 1.0

This value may be adjusted to compensate for noise that is typically found in scanned documents. Typically this value will be less than 0.1. For cleaner images this value should be even lower. In this instance, some value around or below 0.02 would be a good choice. For a computer generated image with no noise, 0.0 may be used. A value of 1.0 would never allow any cropping to occur.

border
A System.Drawing.Point value which represent the (left/right, top/bottom) size in pixels for the cropped image to maintain for a border.
Remarks

ImagXpress will examine the image to determine if the background color is black or white. ImagXpress will then determine whether it should automatically crop the foreground or background color. As an example consider a document with a white background that ImagXpress has determined the need for the white background color to be cropped. Beginning with the top row, each row is examined for black pixels. If the percentage of black pixels in that row is less than the given percentCrop, the row is eliminated and the next row is examined. The process continues until the number of black pixels exceeds the percentCrop, or until the border is reached. The same process is applied for rows from bottom to top and from the leftmost column to right and from the rightmost column to the left.

See Also

Reference

Processor Class
Processor Members


AutoLevel Method

AutoLevel Method

Accusoft.ImagXpressSdk Namespace > Processor Class : AutoLevel Method
Restores and balances color quality within an image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub AutoLevel()
'Usage

Dim instance As Processor

instance.AutoLevel()
public void AutoLevel()
public: void AutoLevel();
public:
void AutoLevel();
Remarks

This method functions by centering the median of the Cb (of YCbCr which is related to blue minus luminance) component histogram.

The AutoColorBalance method also restores and balance color quality, but uses a different algorithm.

Note: Available in Professional edition.

See Also

Reference

Processor Class
Processor Members


AutoLightness Method

AutoLightness Method

Accusoft.ImagXpressSdk Namespace > Processor Class : AutoLightness Method
Automatically assesses the adjusts contrast in light or dark regions of the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub AutoLightness()
'Usage

Dim instance As Processor

instance.AutoLightness()
public void AutoLightness()
public: void AutoLightness();
public:
void AutoLightness();
Remarks

This method can be useful for bringing more detail into shadowy areas of the image, without washing out the light regions, or correcting photos with silhouetted images due to strong backlighting.

Similar to the AutoContrast method, but uses a different algorithm to treat light and dark regions independently.

See the AdjustLightness method to override the default parameters of this method.

Note: Available in Professional Edition.

See Also

Reference

Processor Class
Processor Members


AutoRemoveRedeye Method

AutoRemoveRedeye Method

Accusoft.ImagXpressSdk Namespace > Processor Class : AutoRemoveRedeye Method

A RedeyeShade enumeration value to modify the shade of the red eye.

A RedeyeGlare enumeration value to modify the glare of the red eye.
A boolean value set to true to use redeye rectangles. Otherwise, use false.
Automatically reduces the red reflection of the flash seen in the eyes of people in color flash photo images.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub AutoRemoveRedeye( _
   ByVal eyeShade As RedeyeShade, _
   ByVal eyeGlare As RedeyeGlare, _
   ByVal bUseRedeyeRectangles As Boolean _
)
'Usage

Dim instance As Processor
Dim eyeShade As RedeyeShade
Dim eyeGlare As RedeyeGlare
Dim bUseRedeyeRectangles As Boolean

instance.AutoRemoveRedeye(eyeShade, eyeGlare, bUseRedeyeRectangles)
public void AutoRemoveRedeye(
   RedeyeShade eyeShade,
   RedeyeGlare eyeGlare,
   bool bUseRedeyeRectangles
)
public: void AutoRemoveRedeye(
   RedeyeShade eyeShade,
   RedeyeGlare eyeGlare,
   bool bUseRedeyeRectangles
)
public:
void AutoRemoveRedeye(
   RedeyeShade eyeShade,
   RedeyeGlare eyeGlare,
   bool bUseRedeyeRectangles
)

Parameters

eyeShade

A RedeyeShade enumeration value to modify the shade of the red eye.

eyeGlare
A RedeyeGlare enumeration value to modify the glare of the red eye.
bUseRedeyeRectangles
A boolean value set to true to use redeye rectangles. Otherwise, use false.
Remarks

The algorithm searches for rectangles containing red eyes and corrects them.

This method accurately corrects the red eyes without modifying non-eyes in most cases without any intervention. However, as with any algorithm, there is a potential for false postivies (modification of areas that are not eyes), or red eyes that are not corrected in some images.

To provide the application with maximum control over this behavior, this method stores in the Redeyes property all areas that have been corrected as a collection of rectangles with corresponding correction information. The rectangles identify areas in which red-eyes were detected and corrected, and a value indicating the confidence that the area corrected was a red eye. This enables the application to set an acceptable level of false positives, and optimize red-eye correction.

Note: Available in Professional edition.

See Also

Reference

Processor Class
Processor Members


Binarize Method

Binarize Method

Accusoft.ImagXpressSdk Namespace > Processor Class : Binarize Method
A BinarizeMode which determines the mode to use to binarize the image.

An integer value which controls background sensitivity.

Used in BinarizeMode.QuickText mode only.

The range is from 0 to 255.

This value should generally be as high as possible without exceeding the brightness of any part of the background.

Black noise appearing in the background can generally be eliminated by lowering this value.

Setting this value is applicable when the mode parameter is BinarizeMode.QuickText

An integer value which represents the high threshold which controls letter and figure thickness.

Used in BinarizeMode.QuickText mode only.

This value must be between lowThreshold and 255. A suggested value for this parameter is (lowThreshold + 255)/2. Letters and figures that render too thick can generally be improved by lowering this value. Letters and figures that render too thin can generally be improved by raising this value.

The range is from lowThreshold to 255.

An integer value which represents the orientation of the halftone grid from the horizontal, measured in degrees clockwise.

The range is from 0 to 360.

An integer value which represents the distance from the center of a black dot in the halftone grid to the nearest white dot, measured in pixels.

The range is from 1 to 32.

An integer value which represents the shape of the halftone grid.

The range is from -256 to 256. At the extreme values, -256 and 256, the grid becomes linear. At the midpoint, 0, the grid consists of circles/squares.

Intermediate values give intermediately shaped elliptical grid dots.

An integer value which represents the local contrast enhancement.

The range is from 0 to 255. Setting this value to 0 and local contrast is not performed.

Values from 1 to 255 control the sensitivity of local contrast enhancement to faint features; lower values yield less sensitivity.

This pre-processing operation increases the contrast in each region of the image. When used as a prelude to binarization, usually by setting Mode = QuickText, it increases the sensitivity of the binarization to detail in all regions of the image.

A BinarizeBlur value which determines the type of blur to invoke during the binarize method.
Converts 8-bit and 24-bit images into a 1-bit monochrome or 8-bit grayscale output image, respectively.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Binarize( _
   ByVal mode As BinarizeMode, _
   ByVal lowThreshold As Integer, _
   ByVal highThreshold As Integer, _
   ByVal gridAngle As Integer, _
   ByVal gridPitch As Integer, _
   ByVal eccentricity As Integer, _
   ByVal lceFactor As Integer, _
   ByVal blur As BinarizeBlur _
)
'Usage

Dim instance As Processor
Dim mode As BinarizeMode
Dim lowThreshold As Integer
Dim highThreshold As Integer
Dim gridAngle As Integer
Dim gridPitch As Integer
Dim eccentricity As Integer
Dim lceFactor As Integer
Dim blur As BinarizeBlur

instance.Binarize(mode, lowThreshold, highThreshold, gridAngle, gridPitch, eccentricity, lceFactor, blur)
public void Binarize(
   BinarizeMode mode,
   int lowThreshold,
   int highThreshold,
   int gridAngle,
   int gridPitch,
   int eccentricity,
   int lceFactor,
   BinarizeBlur blur
)
public: void Binarize(
   BinarizeMode mode,
   int lowThreshold,
   int highThreshold,
   int gridAngle,
   int gridPitch,
   int eccentricity,
   int lceFactor,
   BinarizeBlur blur
)
public:
void Binarize(
   BinarizeMode mode,
   int lowThreshold,
   int highThreshold,
   int gridAngle,
   int gridPitch,
   int eccentricity,
   int lceFactor,
   BinarizeBlur blur
)

Parameters

mode
A BinarizeMode which determines the mode to use to binarize the image.
lowThreshold

An integer value which controls background sensitivity.

Used in BinarizeMode.QuickText mode only.

The range is from 0 to 255.

This value should generally be as high as possible without exceeding the brightness of any part of the background.

Black noise appearing in the background can generally be eliminated by lowering this value.

Setting this value is applicable when the mode parameter is BinarizeMode.QuickText

highThreshold

An integer value which represents the high threshold which controls letter and figure thickness.

Used in BinarizeMode.QuickText mode only.

This value must be between lowThreshold and 255. A suggested value for this parameter is (lowThreshold + 255)/2. Letters and figures that render too thick can generally be improved by lowering this value. Letters and figures that render too thin can generally be improved by raising this value.

The range is from lowThreshold to 255.

gridAngle

An integer value which represents the orientation of the halftone grid from the horizontal, measured in degrees clockwise.

The range is from 0 to 360.

gridPitch

An integer value which represents the distance from the center of a black dot in the halftone grid to the nearest white dot, measured in pixels.

The range is from 1 to 32.

eccentricity

An integer value which represents the shape of the halftone grid.

The range is from -256 to 256. At the extreme values, -256 and 256, the grid becomes linear. At the midpoint, 0, the grid consists of circles/squares.

Intermediate values give intermediately shaped elliptical grid dots.

lceFactor

An integer value which represents the local contrast enhancement.

The range is from 0 to 255. Setting this value to 0 and local contrast is not performed.

Values from 1 to 255 control the sensitivity of local contrast enhancement to faint features; lower values yield less sensitivity.

This pre-processing operation increases the contrast in each region of the image. When used as a prelude to binarization, usually by setting Mode = QuickText, it increases the sensitivity of the binarization to detail in all regions of the image.

blur
A BinarizeBlur value which determines the type of blur to invoke during the binarize method.
Remarks

Binarize is often done to clean up an image (e.g. in preparation for OCR), or to create an image effect.

This method sets the following properties with the values it used to binarize the image:

  • BinarizeMode
  • BinarizeLowThreshold
  • BinarizeHighThreshold
  • BinarizeGridAngle
  • BinarizeGridPitch
  • BinarizeEccentricity
  • BinarizeLceFactor
  • BinarizeBlur
Important: These are the same properties that AutoBinarize sets.

For 1-bit output, this method modifies the color palette associated with the image, setting it to two colors, with black as color 0 and white as color 1.

See Also

Reference

Processor Class
Processor Members


Blend Method

Blend Method

Accusoft.ImagXpressSdk Namespace > Processor Class : Blend Method
An integer value which represents the percentage of pixel blending to perform. Valid values are 0 to 100.
Blends each pixel in the current image with its neighboring pixels.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Blend( _
   ByVal blendPercent As Integer _
)
'Usage

Dim instance As Processor
Dim blendPercent As Integer

instance.Blend(blendPercent)
public void Blend(
   int blendPercent
)
public: void Blend(
   int blendPercent
)
public:
void Blend(
   int blendPercent
)

Parameters

blendPercent
An integer value which represents the percentage of pixel blending to perform. Valid values are 0 to 100.
See Also

Reference

Processor Class
Processor Members


Blur Method

Blur Method

Accusoft.ImagXpressSdk Namespace > Processor Class : Blur Method
Blurs the current image by averaging each pixel with each of its neighboring pixels giving it an 'out of focus' appearance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Blur()
'Usage

Dim instance As Processor

instance.Blur()
public void Blur()
public: void Blur();
public:
void Blur();
See Also

Reference

Processor Class
Processor Members


Brightness Method

Brightness Method

Accusoft.ImagXpressSdk Namespace > Processor Class : Brightness Method

A short integer which represents the brightness level.

The range is from -100 to 100.

Uniformly brightens the current image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Brightness( _
   ByVal intensity As Short _
)
'Usage

Dim instance As Processor
Dim intensity As Short

instance.Brightness(intensity)
public void Brightness(
   short intensity
)
public: void Brightness(
   short intensity
)
public:
void Brightness(
   short intensity
)

Parameters

intensity

A short integer which represents the brightness level.

The range is from -100 to 100.

Remarks

Higher intensities result in brighter images. Negative intensities darken images.

An image that has been brightened has pixels that have higher luminance values (in the HSL color space), or higher RGB values (in RGB color space) than the original image.

See Also

Reference

Processor Class
Processor Members


Buttonize Method

Buttonize Method

Accusoft.ImagXpressSdk Namespace > Processor Class : Buttonize Method
A ButtonStyle enumeration value.
An integer value which represents the width of the bevels. Valid values are 0 to 32768.
An integer value which represents the percent of intensity of the bevels. Higher values result in more opaque bevels while lower percentages result in more translucent bevels. Valid values are 1 to 100.
Adds translucent bevels to the edges of the current image to give it the appearance of a 3D button.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Buttonize( _
   ByVal style As ButtonStyle, _
   ByVal bevelWidth As Integer, _
   ByVal bevelIntensity As Integer _
)
'Usage

Dim instance As Processor
Dim style As ButtonStyle
Dim bevelWidth As Integer
Dim bevelIntensity As Integer

instance.Buttonize(style, bevelWidth, bevelIntensity)
public void Buttonize(
   ButtonStyle style,
   int bevelWidth,
   int bevelIntensity
)
public: void Buttonize(
   ButtonStyle style,
   int bevelWidth,
   int bevelIntensity
)
public:
void Buttonize(
   ButtonStyle style,
   int bevelWidth,
   int bevelIntensity
)

Parameters

style
A ButtonStyle enumeration value.
bevelWidth
An integer value which represents the width of the bevels. Valid values are 0 to 32768.
bevelIntensity
An integer value which represents the percent of intensity of the bevels. Higher values result in more opaque bevels while lower percentages result in more translucent bevels. Valid values are 1 to 100.
See Also

Reference

Processor Class
Processor Members


ColorCount Method

ColorCount Method

Accusoft.ImagXpressSdk Namespace > Processor Class : ColorCount Method
A System.Drawing.Color specified. This parameter stores four, 8-bit components: alpha, red, green, and blue, respectively.
Returns the number of pixels of a specified color within the current image or image area.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function ColorCount( _
   ByVal color As Color _
) As Long
'Usage

Dim instance As Processor
Dim color As Color
Dim value As Long

value = instance.ColorCount(color)
public long ColorCount(
   Color color
)
public: long ColorCount(
   Color color
)
public:
int64 ColorCount(
   Color color
)

Parameters

color
A System.Drawing.Color specified. This parameter stores four, 8-bit components: alpha, red, green, and blue, respectively.

Return Value

A long value that represents the count of pixels of the specified color parameter.
Remarks

This method can be used to determine if a check box on a document image is filled or if a specific field on a form is filled.

See Also

Reference

Processor Class
Processor Members


ColorDepth Method

ColorDepth Method

Accusoft.ImagXpressSdk Namespace > Processor Class : ColorDepth Method
An integer value which represents the bits per pixel.

Valid values are 1, 4, 8, and 24.

The PaletteType enumeration value set.
The DitherType enumeration value set.
Changes the bits per pixel of the current image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub ColorDepth( _
   ByVal bitsPerPixel As Integer, _
   ByVal paletteType As PaletteType, _
   ByVal ditherType As DitherType _
)
'Usage

Dim instance As Processor
Dim bitsPerPixel As Integer
Dim paletteType As PaletteType
Dim ditherType As DitherType

instance.ColorDepth(bitsPerPixel, paletteType, ditherType)
public void ColorDepth(
   int bitsPerPixel,
   PaletteType paletteType,
   DitherType ditherType
)
public: void ColorDepth(
   int bitsPerPixel,
   PaletteType paletteType,
   DitherType ditherType
)
public:
void ColorDepth(
   int bitsPerPixel,
   PaletteType paletteType,
   DitherType ditherType
)

Parameters

bitsPerPixel
An integer value which represents the bits per pixel.

Valid values are 1, 4, 8, and 24.

paletteType
The PaletteType enumeration value set.
ditherType
The DitherType enumeration value set.
Remarks

For an example of how to use this method to do a Sepia effect, see the help for the AdjustRGB method.

Note: DitherType values of DitherType.BinarizeQuickText and DitherType.BinarizePhotoHalftone can only be used if bitsPerPixel is 1, otherwise a ProcessorException will occur because the image isn't being binarized.

See Also

Reference

Processor Class
Processor Members


ColorJoin Method

ColorJoin Method

Accusoft.ImagXpressSdk Namespace > Processor Class : ColorJoin Method
Joins the colors as specified by the given parameters.
Overload List
Overload | Description
ColorJoin(JoinType,IntPtr,IntPtr,IntPtr,IntPtr) | Joins the colors as specified by the given parameters.
ColorJoin(JoinType,Bitmap,Bitmap,Bitmap,Bitmap) | Joins the colors as specified by the given parameters.
See Also

Reference

Processor Class
Processor Members


ColorJoin(JoinType,IntPtr,IntPtr,IntPtr,IntPtr) Method

ColorJoin(JoinType,IntPtr,IntPtr,IntPtr,IntPtr) Method

Accusoft.ImagXpressSdk Namespace > Processor Class > ColorJoin Method : ColorJoin(JoinType,IntPtr,IntPtr,IntPtr,IntPtr) Method
A JoinType value which represents the join type to use to modify the image.
An integer which represents the resulting red, hue, or cyan component of the separated image, depending on the JoinType value.
An integer which represents the resulting green, saturation, or magenta component of the separated image, depending on the JoinType.
An integer which represents the resulting blue, luminance, or yellow component of the separated image, depending on the JoinType.
An integer which represents the resulting black component of the separated image. If the separation type is CMYK, or the Alpha component of the separated image, the separation type is RGBA. Otherwise, this value is null.
Joins the colors as specified by the given parameters.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub ColorJoin( _
   ByVal nJoinType As JoinType, _
   ByVal hPlane1 As IntPtr, _
   ByVal hPlane2 As IntPtr, _
   ByVal hPlane3 As IntPtr, _
   ByVal hPlane4 As IntPtr _
)
'Usage

Dim instance As Processor
Dim nJoinType As JoinType
Dim hPlane1 As IntPtr
Dim hPlane2 As IntPtr
Dim hPlane3 As IntPtr
Dim hPlane4 As IntPtr

instance.ColorJoin(nJoinType, hPlane1, hPlane2, hPlane3, hPlane4)
public void ColorJoin(
   JoinType nJoinType,
   IntPtr hPlane1,
   IntPtr hPlane2,
   IntPtr hPlane3,
   IntPtr hPlane4
)
public: void ColorJoin(
   JoinType nJoinType,
   IntPtr hPlane1,
   IntPtr hPlane2,
   IntPtr hPlane3,
   IntPtr hPlane4
)
public:
void ColorJoin(
   JoinType nJoinType,
   IntPtr hPlane1,
   IntPtr hPlane2,
   IntPtr hPlane3,
   IntPtr hPlane4
)

Parameters

nJoinType
A JoinType value which represents the join type to use to modify the image.
hPlane1
An integer which represents the resulting red, hue, or cyan component of the separated image, depending on the JoinType value.
hPlane2
An integer which represents the resulting green, saturation, or magenta component of the separated image, depending on the JoinType.
hPlane3
An integer which represents the resulting blue, luminance, or yellow component of the separated image, depending on the JoinType.
hPlane4
An integer which represents the resulting black component of the separated image. If the separation type is CMYK, or the Alpha component of the separated image, the separation type is RGBA. Otherwise, this value is null.
See Also

Reference

Processor Class
Processor Members
Overload List


ColorJoin(JoinType,Bitmap,Bitmap,Bitmap,Bitmap) Method

ColorJoin(JoinType,Bitmap,Bitmap,Bitmap,Bitmap) Method

Accusoft.ImagXpressSdk Namespace > Processor Class > ColorJoin Method : ColorJoin(JoinType,Bitmap,Bitmap,Bitmap,Bitmap) Method
A JoinType value which represents the join type to use to modify the image.
A bitmap which represents the resulting red, hue, or cyan component of the separated image, depending on the JoinType value.
A bitmap which represents the resulting green, saturation, or magenta component of the separated image, depending on the JoinType.
A bitmap which represents the resulting blue, luminance, or yellow component of the separated image, depending on the JoinType.
A bitmap which represents the resulting black component of the separated image. If the separation type is CMYK, or the Alpha component of the separated image, the separation type is RGBA. Otherwise, this value is null.
Joins the colors as specified by the given parameters.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub ColorJoin( _
   ByVal nJoinType As JoinType, _
   ByVal bitmap1 As Bitmap, _
   ByVal bitmap2 As Bitmap, _
   ByVal bitmap3 As Bitmap, _
   ByVal bitmap4 As Bitmap _
)
'Usage

Dim instance As Processor
Dim nJoinType As JoinType
Dim bitmap1 As Bitmap
Dim bitmap2 As Bitmap
Dim bitmap3 As Bitmap
Dim bitmap4 As Bitmap

instance.ColorJoin(nJoinType, bitmap1, bitmap2, bitmap3, bitmap4)
public void ColorJoin(
   JoinType nJoinType,
   Bitmap bitmap1,
   Bitmap bitmap2,
   Bitmap bitmap3,
   Bitmap bitmap4
)
public: void ColorJoin(
   JoinType nJoinType,
   Bitmap* bitmap1,
   Bitmap* bitmap2,
   Bitmap* bitmap3,
   Bitmap* bitmap4
)
public:
void ColorJoin(
   JoinType nJoinType,
   Bitmap^ bitmap1,
   Bitmap^ bitmap2,
   Bitmap^ bitmap3,
   Bitmap^ bitmap4
)

Parameters

nJoinType
A JoinType value which represents the join type to use to modify the image.
bitmap1
A bitmap which represents the resulting red, hue, or cyan component of the separated image, depending on the JoinType value.
bitmap2
A bitmap which represents the resulting green, saturation, or magenta component of the separated image, depending on the JoinType.
bitmap3
A bitmap which represents the resulting blue, luminance, or yellow component of the separated image, depending on the JoinType.
bitmap4
A bitmap which represents the resulting black component of the separated image. If the separation type is CMYK, or the Alpha component of the separated image, the separation type is RGBA. Otherwise, this value is null.
See Also

Reference

Processor Class
Processor Members
Overload List


ColorSeparation Method

ColorSeparation Method

Accusoft.ImagXpressSdk Namespace > Processor Class : ColorSeparation Method
Separates the color based on the given parameters.
Overload List
Overload | Description
ColorSeparation(SeparationType,IntPtr,IntPtr,IntPtr,IntPtr) | Separates the color based on the given parameters.
ColorSeparation(SeparationType,Bitmap,Bitmap,Bitmap,Bitmap) | Separates the color based on the given parameters.
See Also

Reference

Processor Class
Processor Members


ColorSeparation(SeparationType,IntPtr,IntPtr,IntPtr,IntPtr) Method

ColorSeparation(SeparationType,IntPtr,IntPtr,IntPtr,IntPtr) Method

Accusoft.ImagXpressSdk Namespace > Processor Class > ColorSeparation Method : ColorSeparation(SeparationType,IntPtr,IntPtr,IntPtr,IntPtr) Method
A SeparationType value which represents the type of separation to perform on the image.
An integer which represents the resulting red, hue, or cyan component of the separated image, depending on the SeparationType value.
An integer which represents the resulting green, saturation, or magenta component of the separated image, depending on the SeparationType.
An integer which represents the resulting blue, luminance, or yellow component of the separated image, depending on the SeparationType.
An integer which represents the resulting black component of the separated image. If the separation type is CMYK, or the Alpha component of the separated image, the separation type is RGBA. Otherwise, this value is null.
Separates the color based on the given parameters.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub ColorSeparation( _
   ByVal enumIPSeparationType As SeparationType, _
   ByRef hPlane1 As IntPtr, _
   ByRef hPlane2 As IntPtr, _
   ByRef hPlane3 As IntPtr, _
   ByRef hPlane4 As IntPtr _
)
'Usage

Dim instance As Processor
Dim enumIPSeparationType As SeparationType
Dim hPlane1 As IntPtr
Dim hPlane2 As IntPtr
Dim hPlane3 As IntPtr
Dim hPlane4 As IntPtr

instance.ColorSeparation(enumIPSeparationType, hPlane1, hPlane2, hPlane3, hPlane4)
public void ColorSeparation(
   SeparationType enumIPSeparationType,
   out IntPtr hPlane1,
   out IntPtr hPlane2,
   out IntPtr hPlane3,
   out IntPtr hPlane4
)
public: void ColorSeparation(
   SeparationType enumIPSeparationType,
   [PARAMFLAG::Out] IntPtr hPlane1,
   [PARAMFLAG::Out] IntPtr hPlane2,
   [PARAMFLAG::Out] IntPtr hPlane3,
   [PARAMFLAG::Out] IntPtr hPlane4
)
public:
void ColorSeparation(
   SeparationType enumIPSeparationType,
   [Out] IntPtr hPlane1,
   [Out] IntPtr hPlane2,
   [Out] IntPtr hPlane3,
   [Out] IntPtr hPlane4
)

Parameters

enumIPSeparationType
A SeparationType value which represents the type of separation to perform on the image.
hPlane1
An integer which represents the resulting red, hue, or cyan component of the separated image, depending on the SeparationType value.
hPlane2
An integer which represents the resulting green, saturation, or magenta component of the separated image, depending on the SeparationType.
hPlane3
An integer which represents the resulting blue, luminance, or yellow component of the separated image, depending on the SeparationType.
hPlane4
An integer which represents the resulting black component of the separated image. If the separation type is CMYK, or the Alpha component of the separated image, the separation type is RGBA. Otherwise, this value is null.
See Also

Reference

Processor Class
Processor Members
Overload List


ColorSeparation(SeparationType,Bitmap,Bitmap,Bitmap,Bitmap) Method

ColorSeparation(SeparationType,Bitmap,Bitmap,Bitmap,Bitmap) Method

Accusoft.ImagXpressSdk Namespace > Processor Class > ColorSeparation Method : ColorSeparation(SeparationType,Bitmap,Bitmap,Bitmap,Bitmap) Method
A SeparationType value which represents the type of separation to perform on the image.
A bitmap which represents the resulting red, hue, or cyan component of the separated image, depending on the SeparationType value.
A bitmap which represents the resulting green, saturation, or magenta component of the separated image, depending on the SeparationType.
A bitmap which represents the resulting blue, luminance, or yellow component of the separated image, depending on the SeparationType.
A bitmap which represents the resulting black component of the separated image. If the separation type is CMYK, or the Alpha component of the separated image, the separation type is RGBA. Otherwise, this value is null.
Separates the color based on the given parameters.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub ColorSeparation( _
   ByVal enumIPSeparationType As SeparationType, _
   ByRef bitmap1 As Bitmap, _
   ByRef bitmap2 As Bitmap, _
   ByRef bitmap3 As Bitmap, _
   ByRef bitmap4 As Bitmap _
)
'Usage

Dim instance As Processor
Dim enumIPSeparationType As SeparationType
Dim bitmap1 As Bitmap
Dim bitmap2 As Bitmap
Dim bitmap3 As Bitmap
Dim bitmap4 As Bitmap

instance.ColorSeparation(enumIPSeparationType, bitmap1, bitmap2, bitmap3, bitmap4)
public void ColorSeparation(
   SeparationType enumIPSeparationType,
   out Bitmap bitmap1,
   out Bitmap bitmap2,
   out Bitmap bitmap3,
   out Bitmap bitmap4
)
public: void ColorSeparation(
   SeparationType enumIPSeparationType,
   [PARAMFLAG::Out] Bitmap* bitmap1,
   [PARAMFLAG::Out] Bitmap* bitmap2,
   [PARAMFLAG::Out] Bitmap* bitmap3,
   [PARAMFLAG::Out] Bitmap* bitmap4
)
public:
void ColorSeparation(
   SeparationType enumIPSeparationType,
   [Out] Bitmap^ bitmap1,
   [Out] Bitmap^ bitmap2,
   [Out] Bitmap^ bitmap3,
   [Out] Bitmap^ bitmap4
)

Parameters

enumIPSeparationType
A SeparationType value which represents the type of separation to perform on the image.
bitmap1
A bitmap which represents the resulting red, hue, or cyan component of the separated image, depending on the SeparationType value.
bitmap2
A bitmap which represents the resulting green, saturation, or magenta component of the separated image, depending on the SeparationType.
bitmap3
A bitmap which represents the resulting blue, luminance, or yellow component of the separated image, depending on the SeparationType.
bitmap4
A bitmap which represents the resulting black component of the separated image. If the separation type is CMYK, or the Alpha component of the separated image, the separation type is RGBA. Otherwise, this value is null.
See Also

Reference

Processor Class
Processor Members
Overload List


Contrast Method

Contrast Method

Accusoft.ImagXpressSdk Namespace > Processor Class : Contrast Method

A short value which represents the intensity.

Adjusts the contrast of the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Contrast( _
   ByVal intensity As Short _
)
'Usage

Dim instance As Processor
Dim intensity As Short

instance.Contrast(intensity)
public void Contrast(
   short intensity
)
public: void Contrast(
   short intensity
)
public:
void Contrast(
   short intensity
)

Parameters

intensity

A short value which represents the intensity.

Remarks

Valid values are -100 to 100.

The value of 0 indicates that the contrast remains the same as in the original image.

Values greater than zero increase the contrast in the image. Values less than zero decrease the contra st in the image.

This method uses the same algorithm as AutoContrast, but enables the user to adjust the results of the algorithm by a specified percentage.

See Also

Reference

Processor Class
Processor Members


Crop Method

Crop Method

Accusoft.ImagXpressSdk Namespace > Processor Class : Crop Method
A System.Drawing.Rectangle coordinates which represent the cropping rectangle to use.
Crops the current image to the specified size.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Crop( _
   ByVal cropRectangle As Rectangle _
)
'Usage

Dim instance As Processor
Dim cropRectangle As Rectangle

instance.Crop(cropRectangle)
public void Crop(
   Rectangle cropRectangle
)
public: void Crop(
   Rectangle cropRectangle
)
public:
void Crop(
   Rectangle cropRectangle
)

Parameters

cropRectangle
A System.Drawing.Rectangle coordinates which represent the cropping rectangle to use.
Remarks

If the area defined by the crop parameters does not fall within the boundaries of the image, the image is not cropped and ImagXpress generates a ProcessorException message.

See Also

Reference

Processor Class
Processor Members


CropBorder Method

CropBorder Method

Accusoft.ImagXpressSdk Namespace > Processor Class : CropBorder Method
A float value which represents the percent to crop.

Valid values are 0.0 to 1.0

This value may be adjusted to compensate for noise that is typically found in scanned documents. Typically this value will be greater than 0.9. For cleaner images this value should be even greater. In this instance, some value around or above 0.98 would be a good choice. For a computer generated image with no noise, 1.0 may be used. A value of 0.0 would never allow any cropping to occur.

A CropType enumeration value which represents the type of crop to perform.
Performs border removal by cropping the edges of the current image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub CropBorder( _
   ByVal percentToCrop As Single, _
   ByVal cropType As CropType _
)
'Usage

Dim instance As Processor
Dim percentToCrop As Single
Dim cropType As CropType

instance.CropBorder(percentToCrop, cropType)
public void CropBorder(
   float percentToCrop,
   CropType cropType
)
public: void CropBorder(
   float percentToCrop,
   CropType cropType
)
public:
void CropBorder(
   float percentToCrop,
   CropType cropType
)

Parameters

percentToCrop
A float value which represents the percent to crop.

Valid values are 0.0 to 1.0

This value may be adjusted to compensate for noise that is typically found in scanned documents. Typically this value will be greater than 0.9. For cleaner images this value should be even greater. In this instance, some value around or above 0.98 would be a good choice. For a computer generated image with no noise, 1.0 may be used. A value of 0.0 would never allow any cropping to occur.

cropType
A CropType enumeration value which represents the type of crop to perform.
Remarks

Occassionally, scanned images possess edges where the selected scan area falls outside the scanned page. Use this method to remove these edges.

Use the DocumentBorderCrop(Boolean) method to trim these edges from documents.

Beginning with the top row, ImagXpress examines each row for pixels containing the border color. If the percentage pixels containing the border color in that row and its adjacent row is greater than the given percentToCrop, the row is eliminated and the next row is examined. The process continues until the number of pixels containing the border color is less than the percentToCrop.

The same process applies for rows from bottom to top, the leftmost column to the right and the rightmost column to the left. The specified percentToCrop argument can be adjusted to compensate for noise that is typically found in scanned documents.

See Also

Reference

Processor Class
Processor Members


DeleteRegion Method

DeleteRegion Method

Accusoft.ImagXpressSdk Namespace > Processor Class : DeleteRegion Method
Deletes the current image processing region object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub DeleteRegion()
'Usage

Dim instance As Processor

instance.DeleteRegion()
public void DeleteRegion()
public: void DeleteRegion();
public:
void DeleteRegion();
Remarks
The method deletes the region object set in the SetRegion call. This does not actually change any part of the image itself. You call this method when you are finished working with a region of the image.
See Also

Reference

Processor Class
Processor Members


Deskew Method

Deskew Method

Accusoft.ImagXpressSdk Namespace > Processor Class : Deskew Method
Deskews the image using the specified DeskewType.
Overload List
Overload | Description
Deskew(DeskewType) | Deskews the image using the specified DeskewType.
Deskew() | Deskews the image using the default DeskewType.Normal.
See Also

Reference

Processor Class
Processor Members


Deskew(DeskewType) Method

Deskew(DeskewType) Method

Accusoft.ImagXpressSdk Namespace > Processor Class > Deskew Method : Deskew(DeskewType) Method
The DeskewType to use to deskew.
Deskews the image using the specified DeskewType.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Deskew( _
   ByVal deskewType As DeskewType _
)
'Usage

Dim instance As Processor
Dim deskewType As DeskewType

instance.Deskew(deskewType)
public void Deskew(
   DeskewType deskewType
)
public: void Deskew(
   DeskewType deskewType
)
public:
void Deskew(
   DeskewType deskewType
)

Parameters

deskewType
The DeskewType to use to deskew.
Remarks

Use this method on images with a bit depth greater than one.

For bitonal (1-bit) images, use the DocumentDeskew method.

See Also

Reference

Processor Class
Processor Members
Overload List


Deskew() Method

Deskew() Method

Accusoft.ImagXpressSdk Namespace > Processor Class > Deskew Method : Deskew() Method
Deskews the image using the default DeskewType.Normal.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Deskew()
'Usage

Dim instance As Processor

instance.Deskew()
public void Deskew()
public: void Deskew();
public:
void Deskew();
Remarks

Use this method on images with a bit depth greater than one.

For bitonal (1-bit) images, use the DocumentDeskew method.

See Also

Reference

Processor Class
Processor Members
Overload List


Despeckle Method

Despeckle Method

Accusoft.ImagXpressSdk Namespace > Processor Class : Despeckle Method
Filters the image using a filter that attempts to eliminate noise in the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Despeckle()
'Usage

Dim instance As Processor

instance.Despeckle()
public void Despeckle()
public: void Despeckle();
public:
void Despeckle();
Remarks

The most typical use of this method is to eliminate noise or small black areas in an image. These areas are typically caused when the image is printed on a fax machine

Note: Available in Professional edition.

See Also

Reference

Processor Class
Processor Members


Diffuse Method

Diffuse Method

Accusoft.ImagXpressSdk Namespace > Processor Class : Diffuse Method
Diffuses the current image by replacing each pixel with a randomly selected neighboring pixel.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Diffuse()
'Usage

Dim instance As Processor

instance.Diffuse()
public void Diffuse()
public: void Diffuse();
public:
void Diffuse();
See Also

Reference

Processor Class
Processor Members


Dilate Method

Dilate Method

Accusoft.ImagXpressSdk Namespace > Processor Class : Dilate Method
Enlarges the boundaries of regions of foreground pixels in the current image using a 3x3 maximum filter.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Dilate()
'Usage

Dim instance As Processor

instance.Dilate()
public void Dilate()
public: void Dilate();
public:
void Dilate();
Remarks

This method enhances/fills in divets in black letters and lines on an image.

Use this method on images with a bit depth greater than 1. Use the DocumentDilate method for bitonal images.

See Also

Reference

Processor Class
Processor Members


Dispose Method (Processor)

Dispose Method (Processor)

Accusoft.ImagXpressSdk Namespace > Processor Class : Dispose Method
Releases the Processor object used in Accusoft.Common.ImagXpress13.
Overload List
Overload | Description
Dispose() | (Inherited from System.ComponentModel.Component)
See Also

Reference

Processor Class
Processor Members


DocumentBlankPageDetect Method

DocumentBlankPageDetect Method

Accusoft.ImagXpressSdk Namespace > Processor Class : DocumentBlankPageDetect Method
Examines a rectangle on an image, determining if the page is considered blank, based on the amount of data on the page.
Overload List
Overload | Description
DocumentBlankPageDetect(Int32,Int32,Int32,Boolean) | Examines a rectangle on an image, determining if the page is considered blank, based on the amount of data on the page.
DocumentBlankPageDetect(Int32,Int32,Int32,Int32,Int32,Int32,Boolean) | Examines a rectangle on an image, determining if the page is considered blank, based on the amount of data on the page.
See Also

Reference

Processor Class
Processor Members


DocumentBlankPageDetect(Int32,Int32,Int32,Boolean) Method

DocumentBlankPageDetect(Int32,Int32,Int32,Boolean) Method

Accusoft.ImagXpressSdk Namespace > Processor Class > DocumentBlankPageDetect Method : DocumentBlankPageDetect(Int32,Int32,Int32,Boolean) Method
An integer value which represents the number of rows of pixels to ignore on the edges (top, left, right and bottom) of the image. If IgnoreBorder is set to false, this margin applies to the sides of the original image. If IgnoreBorder is true, this margin is applied to the sides of the page, inside the detected border.
An integer value which represents the minimum width or height of a black object considered non-blank. Set it higher to ignore larger objects (causing more pages to be considered blank) or lower to notice smaller objects (causing more pages to be considered non-blank).
An integer value which represents the maximum spacing between black objects considered connected. Set it higher to cause broken objects to be considered as two parts of a larger object (causing more pages to be considered non-blank) or lower to cause neighboring black objects to be treated separately (causing more pages to be considered blank).
A boolean value which is true to do a quick search for over scan in the border, then moves the detection area inside the detected over scanned border. If this property is set to true and the image does not have an actual border, there is a possibility that the method will return a false positive.
Examines a rectangle on an image, determining if the page is considered blank, based on the amount of data on the page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DocumentBlankPageDetect( _
   ByVal Margin As Integer, _
   ByVal MinObjectDimension As Integer, _
   ByVal GapFill As Integer, _
   ByVal IgnoreBorder As Boolean _
)
'Usage

Dim instance As Processor
Dim Margin As Integer
Dim MinObjectDimension As Integer
Dim GapFill As Integer
Dim IgnoreBorder As Boolean

instance.DocumentBlankPageDetect(Margin, MinObjectDimension, GapFill, IgnoreBorder)
public void DocumentBlankPageDetect(
   int Margin,
   int MinObjectDimension,
   int GapFill,
   bool IgnoreBorder
)
public: void DocumentBlankPageDetect(
   int Margin,
   int MinObjectDimension,
   int GapFill,
   bool IgnoreBorder
)
public:
void DocumentBlankPageDetect(
   int Margin,
   int MinObjectDimension,
   int GapFill,
   bool IgnoreBorder
)

Parameters

Margin
An integer value which represents the number of rows of pixels to ignore on the edges (top, left, right and bottom) of the image. If IgnoreBorder is set to false, this margin applies to the sides of the original image. If IgnoreBorder is true, this margin is applied to the sides of the page, inside the detected border.
MinObjectDimension
An integer value which represents the minimum width or height of a black object considered non-blank. Set it higher to ignore larger objects (causing more pages to be considered blank) or lower to notice smaller objects (causing more pages to be considered non-blank).
GapFill
An integer value which represents the maximum spacing between black objects considered connected. Set it higher to cause broken objects to be considered as two parts of a larger object (causing more pages to be considered non-blank) or lower to cause neighboring black objects to be treated separately (causing more pages to be considered blank).
IgnoreBorder
A boolean value which is true to do a quick search for over scan in the border, then moves the detection area inside the detected over scanned border. If this property is set to true and the image does not have an actual border, there is a possibility that the method will return a false positive.
Remarks

When no object exceeding the size threshold is encountered on the page, BlankPageDetected is set to true to indicate the page is "blank". Low Confidence values on a "blank" determination indicate a significant number of objects near, but below the size threshold.

When an object exceeding the size threshold is encountered on the page, BlankPageDetected is set to false to indicate the page is "not blank". Low Confidence values on a "not blank" determination indicate a low number of objects over the size threshold.

Use this function for a single margin value for all margins.

ImagXpress examines an image and determines if it is blank or not, using parameters provided. The current image remains unchanged.

Note: Available in Professional edition.

See Also

Reference

Processor Class
Processor Members
Overload List


DocumentBlankPageDetect(Int32,Int32,Int32,Int32,Int32,Int32,Boolean) Method

DocumentBlankPageDetect(Int32,Int32,Int32,Int32,Int32,Int32,Boolean) Method

Accusoft.ImagXpressSdk Namespace > Processor Class > DocumentBlankPageDetect Method : DocumentBlankPageDetect(Int32,Int32,Int32,Int32,Int32,Int32,Boolean) Method
Integer values which represent the number of rows of pixels to ignore on the left edge of the image. If IgnoreBorder is set to false, the left margin is applied to the left side of the original image. If IgnoreBorder is true, the left margin is applied to the left side of the page, inside the detected border. The default value is 0.
Integer values which represent the number of rows of pixels to ignore on the top edge of the image. If IgnoreBorder is set to false, the top margin is applied to the top side of the original image. If IgnoreBorder is true, the top margin is applied to the top side of the page, inside the detected border. The default value is 0.
Integer values which represent the number of rows of pixels to ignore on the right edge of the image. If IgnoreBorder is set to false, the right margin is applied to the right side of the original image. If IgnoreBorder is true, the right margin is applied to the right side of the page, inside the detected border. The default value is 0.
Integer values which represent the number of rows of pixels to ignore on the bottom edge of the image. If IgnoreBorder is set to false, the bottom margin is applied to the bottom side of the original image. If IgnoreBorder is true, the bottom margin is applied to the bottom side of the page, inside the detected border. The default value is 0.
An integer value which represents the minimum width or height of a black object considered non-blank. Set it higher to ignore larger objects (causing more pages to be considered blank) or lower to notice smaller objects (causing more pages to be considered non-blank). The default value is 10.
An integer value which represents the maximum spacing between black objects considered connected. Set it higher to cause broken objects to be considered as two parts of a larger object (causing more pages to be considered non-blank) or lower to cause neighboring black objects to be treated separately (causing more pages to be considered blank). The default value is 5.
A boolean value which is true to do a quick search for over scan in the border, then moves the detection area inside the detected over scanned border. If this property is set to true and the image does not have an actual border, there is a possibility that the method will return a false positive. The default value is false.
Examines a rectangle on an image, determining if the page is considered blank, based on the amount of data on the page.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DocumentBlankPageDetect( _
   Optional ByVal LeftMargin As Integer, _
   Optional ByVal TopMargin As Integer, _
   Optional ByVal RightMargin As Integer, _
   Optional ByVal BottomMargin As Integer, _
   Optional ByVal MinObjectDimension As Integer, _
   Optional ByVal GapFill As Integer, _
   Optional ByVal IgnoreBorder As Boolean _
)
'Usage

Dim instance As Processor
Dim LeftMargin As Integer
Dim TopMargin As Integer
Dim RightMargin As Integer
Dim BottomMargin As Integer
Dim MinObjectDimension As Integer
Dim GapFill As Integer
Dim IgnoreBorder As Boolean

instance.DocumentBlankPageDetect(LeftMargin, TopMargin, RightMargin, BottomMargin, MinObjectDimension, GapFill, IgnoreBorder)
public void DocumentBlankPageDetect(
   int LeftMargin,
   int TopMargin,
   int RightMargin,
   int BottomMargin,
   int MinObjectDimension,
   int GapFill,
   bool IgnoreBorder
)
public: void DocumentBlankPageDetect(
   int LeftMargin,
   int TopMargin,
   int RightMargin,
   int BottomMargin,
   int MinObjectDimension,
   int GapFill,
   bool IgnoreBorder
)
public:
void DocumentBlankPageDetect(
   int LeftMargin,
   int TopMargin,
   int RightMargin,
   int BottomMargin,
   int MinObjectDimension,
   int GapFill,
   bool IgnoreBorder
)

Parameters

LeftMargin
Integer values which represent the number of rows of pixels to ignore on the left edge of the image. If IgnoreBorder is set to false, the left margin is applied to the left side of the original image. If IgnoreBorder is true, the left margin is applied to the left side of the page, inside the detected border. The default value is 0.
TopMargin
Integer values which represent the number of rows of pixels to ignore on the top edge of the image. If IgnoreBorder is set to false, the top margin is applied to the top side of the original image. If IgnoreBorder is true, the top margin is applied to the top side of the page, inside the detected border. The default value is 0.
RightMargin
Integer values which represent the number of rows of pixels to ignore on the right edge of the image. If IgnoreBorder is set to false, the right margin is applied to the right side of the original image. If IgnoreBorder is true, the right margin is applied to the right side of the page, inside the detected border. The default value is 0.
BottomMargin
Integer values which represent the number of rows of pixels to ignore on the bottom edge of the image. If IgnoreBorder is set to false, the bottom margin is applied to the bottom side of the original image. If IgnoreBorder is true, the bottom margin is applied to the bottom side of the page, inside the detected border. The default value is 0.
MinObjectDimension
An integer value which represents the minimum width or height of a black object considered non-blank. Set it higher to ignore larger objects (causing more pages to be considered blank) or lower to notice smaller objects (causing more pages to be considered non-blank). The default value is 10.
GapFill
An integer value which represents the maximum spacing between black objects considered connected. Set it higher to cause broken objects to be considered as two parts of a larger object (causing more pages to be considered non-blank) or lower to cause neighboring black objects to be treated separately (causing more pages to be considered blank). The default value is 5.
IgnoreBorder
A boolean value which is true to do a quick search for over scan in the border, then moves the detection area inside the detected over scanned border. If this property is set to true and the image does not have an actual border, there is a possibility that the method will return a false positive. The default value is false.
Remarks

When no object exceeding the size threshold is encountered on the page, BlankPageDetected is set to true to indicate the page is "blank". Low Confidence values on a "blank" determination indicate a significant number of objects near, but below the size threshold.

When an object exceeding the size threshold is encountered on the page, BlankPageDetected is set to false to indicate the page is "not blank". Low Confidence values on a "not blank" determination indicate a low number of objects over the size threshold.

Use this function for direct control over each margin value.

ImagXpress examines an image and determines if it is blank or not, using parameters provided. The current image remains unchanged.

Note: Available in Professional edition.

See Also

Reference

Processor Class
Processor Members
Overload List


DocumentBlobRemoval Method

DocumentBlobRemoval Method

Accusoft.ImagXpressSdk Namespace > Processor Class : DocumentBlobRemoval Method
A System.Drawing.Rectangle which represents the area to remove blobs from. Use an empty rectangle (0,0,0,0) to represent the entire image.
An integer value which represents the minimum number of pixels for an object to be considered a blob for removal purposes. This value should be an integer greater than 0. The default value is 300.
An integer value which represents the maximum number of pixels for an objet to be considered a blob for removal purposes. This value should be an integer greater than 0. The default value is 10000.
The minimum density, as a percentile in the range [0 – 100], that an object must have to be removed. The density is defined as the number of black pixels in the object divided by the area of the convex hull of the object. Solid convex objects such as circles and squares will have densities approaching 100 (with some variation due to rounding in the hull calculation), while hollow or concave objects like the letters "O" and "C" will have low densities. The default value is 50.
Locates and removes large black objects in images such as binder punch holes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub DocumentBlobRemoval( _
   ByVal Area As Rectangle, _
   Optional ByVal MinPixelCount As Integer, _
   Optional ByVal MaxPixelCount As Integer, _
   Optional ByVal MinDensity As Short _
)
'Usage

Dim instance As Processor
Dim Area As Rectangle
Dim MinPixelCount As Integer
Dim MaxPixelCount As Integer
Dim MinDensity As Short

instance.DocumentBlobRemoval(Area, MinPixelCount, MaxPixelCount, MinDensity)
public void DocumentBlobRemoval(
   Rectangle Area,
   int MinPixelCount,
   int MaxPixelCount,
   short MinDensity
)
public: void DocumentBlobRemoval(
   Rectangle Area,
   int MinPixelCount,
   int MaxPixelCount,
   short MinDensity
)
public:
void DocumentBlobRemoval(
   Rectangle Area,
   int MinPixelCount,
   int MaxPixelCount,
   short MinDensity
)

Parameters

Area
A System.Drawing.Rectangle which represents the area to remove blobs from. Use an empty rectangle (0,0,0,0) to represent the entire image.
MinPixelCount
An integer value which represents the minimum number of pixels for an object to be considered a blob for removal purposes. This value should be an integer greater than 0. The default value is 300.
MaxPixelCount
An integer value which represents the maximum number of pixels for an objet to be considered a blob for removal purposes. This value should be an integer greater than 0. The default value is 10000.
MinDensity
The minimum density, as a percentile in the range [0 – 100], that an object must have to be removed. The density is defined as the number of black pixels in the object divided by the area of the convex hull of the object. Solid convex objects such as circles and squares will have densities approaching 100 (with some variation due to rounding in the hull calculation), while hollow or concave objects like the letters "O" and "C" will have low densities. The default value is 50.
Remarks

ImagXpress removes only black images on a white image. To remove white pixels on a black image requires prior processing, to negate the bitonal image. You can specify a subset of the image to speed processing time and limit unwanted blob removal.

The image is examined for the blobs, such as the black holes left on copies by binder hole punches in the original image. Blobs within the specified region are removed from the current image.

ImagXpress finds black blobs meeting the specified minimum pixel count and yet not exceeding the specified maximum pixel count. The removed blobs are replaced with white pixels. Without a set detection area, the entire image is examined and updated if it meets the criteria. If a blob is detected on the boundaries of a sub-image, only the portion of the blob within the boundaries is removed.

Note: Available in Professional edition.

See Also

Reference

Processor Class
Processor Members


DocumentBorderCrop Method

DocumentBorderCrop Method

Accusoft.ImagXpressSdk Namespace > Processor Class : DocumentBorderCrop Method
Crops the borders of 1 bit per pixel documents.
Overload List
Overload | Description
DocumentBorderCrop() | Crops the borders of 1 bit per pixel documents.
DocumentBorderCrop(Boolean) | Crops the borders of 1 bit per pixel documents.
See Also

Reference

Processor Class
Processor Members


DocumentBorderCrop() Method

DocumentBorderCrop() Method

Accusoft.ImagXpressSdk Namespace > Processor Class > DocumentBorderCrop Method : DocumentBorderCrop() Method
Crops the borders of 1 bit per pixel documents.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("This method is deprecated, use DocumentBorderCrop(bool) instead.")>
Public Overloads Sub DocumentBorderCrop()
'Usage

Dim instance As Processor

instance.DocumentBorderCrop()
[Obsolete("This method is deprecated, use DocumentBorderCrop(bool) instead.")]
public void DocumentBorderCrop()
[Obsolete("This method is deprecated, use DocumentBorderCrop(bool) instead.")]
public: void DocumentBorderCrop();
[Obsolete("This method is deprecated, use DocumentBorderCrop(bool) instead.")]
public:
void DocumentBorderCrop();
Remarks

This method is the process of detecting and removing vertical and horizontal lines from the outside rim of a document. The method examines the current document to find dark exterior lines along the outside edge, modifying it to remove them. If the area defined by the crop parameters does not fall within the boundaries of the document, the document is not cropped and an error generates.

Note: Available in Professional edition.

See Also

Reference

Processor Class
Processor Members
Overload List


DocumentBorderCrop(Boolean) Method

DocumentBorderCrop(Boolean) Method

Accusoft.ImagXpressSdk Namespace > Processor Class > DocumentBorderCrop Method : DocumentBorderCrop(Boolean) Method
Indicates whether the image should be deskewed during border removal.
Crops the borders of 1 bit per pixel documents.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub DocumentBorderCrop( _
   Optional ByVal deskewBorder As Boolean _
)
'Usage

Dim instance As Processor
Dim deskewBorder As Boolean

instance.DocumentBorderCrop(deskewBorder)
public void DocumentBorderCrop(
   bool deskewBorder
)
public: void DocumentBorderCrop(
   bool deskewBorder
)
public:
void DocumentBorderCrop(
   bool deskewBorder
)

Parameters

deskewBorder
Indicates whether the image should be deskewed during border removal.
Remarks

This method is the process of detecting and removing vertical and horizontal lines from the outside rim of a document. The method examines the current document to find dark exterior lines along the outside edge, modifying it to remove them. If the area defined by the crop parameters does not fall within the boundaries of the document, the document is not cropped and an error generates.

Note: Available in Professional edition.

See Also

Reference

Processor Class
Processor Members
Overload List


DocumentDeskew Method

DocumentDeskew Method

Accusoft.ImagXpressSdk Namespace > Processor Class : DocumentDeskew Method
A double value which represents the minimum angle, in degrees, to deskew. This allows you to keep images with small amounts of skew untouched, potentially increasing performance in batch operations where some skew is acceptable. Angles less than or equal to this amount will not be corrected. This value should be floating point number from 0 to 5. A typical value is 0.2.
An integer value which represents the minimum detection confidence required before correction will proceed. This value should be an integer from 0 to 100. A typical value is 50.
A System.Drawing.Color value for the padding. Valid values are only Color.Black and Color.White. A typical value is Color.White.
A boolean value which is true to maintain the original size. Otherwise, false should be used. A typical value is false.
An integer value which indicates the amount of effort to expend analyzing the image to determine the correct skew. Set to a high value to ensure the most accurate possible result and to a low value for fastest operation. This value should be an integer from 1 to 100. A typical value is 80.
Automatically detects and removes skew from current 1-bit depth images.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub DocumentDeskew( _
   ByVal MinimumAngle As Double, _
   ByVal MinimumConfidence As Short, _
   ByVal PadColor As Color, _
   ByVal MaintainOriginalSize As Boolean, _
   ByVal Quality As Short _
)
'Usage

Dim instance As Processor
Dim MinimumAngle As Double
Dim MinimumConfidence As Short
Dim PadColor As Color
Dim MaintainOriginalSize As Boolean
Dim Quality As Short

instance.DocumentDeskew(MinimumAngle, MinimumConfidence, PadColor, MaintainOriginalSize, Quality)
public void DocumentDeskew(
   double MinimumAngle,
   short MinimumConfidence,
   Color PadColor,
   bool MaintainOriginalSize,
   short Quality
)
public: void DocumentDeskew(
   double MinimumAngle,
   short MinimumConfidence,
   Color PadColor,
   bool MaintainOriginalSize,
   short Quality
)
public:
void DocumentDeskew(
   double MinimumAngle,
   short MinimumConfidence,
   Color PadColor,
   bool MaintainOriginalSize,
   short Quality
)

Parameters

MinimumAngle
A double value which represents the minimum angle, in degrees, to deskew. This allows you to keep images with small amounts of skew untouched, potentially increasing performance in batch operations where some skew is acceptable. Angles less than or equal to this amount will not be corrected. This value should be floating point number from 0 to 5. A typical value is 0.2.
MinimumConfidence
An integer value which represents the minimum detection confidence required before correction will proceed. This value should be an integer from 0 to 100. A typical value is 50.
PadColor
A System.Drawing.Color value for the padding. Valid values are only Color.Black and Color.White. A typical value is Color.White.
MaintainOriginalSize
A boolean value which is true to maintain the original size. Otherwise, false should be used. A typical value is false.
Quality
An integer value which indicates the amount of effort to expend analyzing the image to determine the correct skew. Set to a high value to ensure the most accurate possible result and to a low value for fastest operation. This value should be an integer from 1 to 100. A typical value is 80.
Remarks

Deskew is the process of straightening an image by examining it and determining the appropriate amount of rotation needed for correct alignment.

The detection process focuses on the content of the image, such as text and drawings, rather than the border. Deskew adjusts along the vertical and horizontal axes, optimizing each to provide the best image.

If no image is present, an error is indicated. ImagXpress validates the input, detects the skew, corrects the skew (if necessary) and returns results from the process.

This method is only corrected if the detection confidence is greater than or equal to the MinimumConfidence input and the skew angle is greater than the MinimumAngle input.

If the skew is corrected and MaintainOriginalSize is False, then the previous current image is released and a new DIB is created to hold the new current image. No error is returned if the previous current image could not be released. If the operation fails, the current image is unchanged.

Note: Available in Professional edition.

See Also

Reference

Processor Class
Processor Members


DocumentDespeckle Method

DocumentDespeckle Method

Accusoft.ImagXpressSdk Namespace > Processor Class : DocumentDespeckle Method
An integer value from 1 to 100 which represents the maximum width an object is considered a speck. The default value is 2.
An integer value from 1 to 100 which represents the maximum height an object is considered a speck. The default value is 2.
Detects and removes specks from the current image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub DocumentDespeckle( _
   Optional ByVal SpeckWidth As Short, _
   Optional ByVal SpeckHeight As Short _
)
'Usage

Dim instance As Processor
Dim SpeckWidth As Short
Dim SpeckHeight As Short

instance.DocumentDespeckle(SpeckWidth, SpeckHeight)
public void DocumentDespeckle(
   short SpeckWidth,
   short SpeckHeight
)
public: void DocumentDespeckle(
   short SpeckWidth,
   short SpeckHeight
)
public:
void DocumentDespeckle(
   short SpeckWidth,
   short SpeckHeight
)

Parameters

SpeckWidth
An integer value from 1 to 100 which represents the maximum width an object is considered a speck. The default value is 2.
SpeckHeight
An integer value from 1 to 100 which represents the maximum height an object is considered a speck. The default value is 2.
Remarks

Despeckle is the process of removing random specks of noise from an image. The DocumentDespeckle method examines the current image to find objects meeting the current criteria for specks and then removes them. If no parameters are provided, the defaults are used.

Note: Available in Professional edition.

See Also

Reference

Processor Class
Processor Members


DocumentDilate Method

DocumentDilate Method

Accusoft.ImagXpressSdk Namespace > Processor Class : DocumentDilate Method
An integer which represents the the distance, in pixels, to extend the black pixels. This value should be an integer from 1 to 500. The default value is 1.
A EnhancementDirection value which determines the direction to apply the dilation. Black pixels are expanded in this direction. The default value is All.
Examines pixels in the current image and expands the black ones by the given amount in a given direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub DocumentDilate( _
   Optional ByVal Amount As Short, _
   Optional ByVal Direction As EnhancementDirection _
)
'Usage

Dim instance As Processor
Dim Amount As Short
Dim Direction As EnhancementDirection

instance.DocumentDilate(Amount, Direction)
public void DocumentDilate(
   short Amount,
   EnhancementDirection Direction
)
public: void DocumentDilate(
   short Amount,
   EnhancementDirection Direction
)
public:
void DocumentDilate(
   short Amount,
   EnhancementDirection Direction
)

Parameters

Amount
An integer which represents the the distance, in pixels, to extend the black pixels. This value should be an integer from 1 to 500. The default value is 1.
Direction
A EnhancementDirection value which determines the direction to apply the dilation. Black pixels are expanded in this direction. The default value is All.
Remarks

This method validates the input, examines the pixels, expands the black pixels, and returns results from the detection and correction process.

The Dilate object contains parameters that control the dilate process. If no parameters are provided, the current image has its black pixels expanded by one in all directions.

Note: Available in Professional edition.

See Also

Reference

Processor Class
Processor Members


DocumentErode Method

DocumentErode Method

Accusoft.ImagXpressSdk Namespace > Processor Class : DocumentErode Method
The distance to reduce the black pixels. This value should be an integer from 1 to 500. The default value is 1.
An EnhancementDirection which determines the direction to apply the erosion. Black pixels are removed in this direction. The default value is All.
Removes the black pixels in the current image by the given amount in the given direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub DocumentErode( _
   Optional ByVal Amount As Short, _
   Optional ByVal Direction As EnhancementDirection _
)
'Usage

Dim instance As Processor
Dim Amount As Short
Dim Direction As EnhancementDirection

instance.DocumentErode(Amount, Direction)
public void DocumentErode(
   short Amount,
   EnhancementDirection Direction
)
public: void DocumentErode(
   short Amount,
   EnhancementDirection Direction
)
public:
void DocumentErode(
   short Amount,
   EnhancementDirection Direction
)

Parameters

Amount
The distance to reduce the black pixels. This value should be an integer from 1 to 500. The default value is 1.
Direction
An EnhancementDirection which determines the direction to apply the erosion. Black pixels are removed in this direction. The default value is All.
Remarks

Erosion is the process of removing the specified number of black pixels from the existing black pixels on the specified edge or edges of an image.

Note: Available in Professional edition.

See Also

Reference

Processor Class
Processor Members


DocumentLineRemoval Method

DocumentLineRemoval Method

Accusoft.ImagXpressSdk Namespace > Processor Class : DocumentLineRemoval Method
An integer from 26 to 20,000 which represents the minimum pixel length of a line to meet removal criteria. The default value is 50.
An integer from 1 to 50 which represents the maximum pixel thickness of a line meeting the removal criteria. The default value is 20.
A double value which represents the ratio of the line length to the line width. Lines below this aspect ratio are removed. The ratio range is any floating point number between 1 and 1000. The default value is 10. This provides a ratio of 100 pixels in length for every 10 pixels in width.
An integer value which represents the maximum allowed gap in a line for the line to still be considered one object. This value should be an integer from 1 to 20. The default value is 1.
An integer value from 0 to 100 which represents the maximum character size to reconstruct intersected characters within the given size after performing line removal. This value should be a positive integer including zero. The default value is 20.
Automatically detects and removes lines from the current image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub DocumentLineRemoval( _
   Optional ByVal MinLength As Integer, _
   Optional ByVal MaxThickness As Short, _
   Optional ByVal MinAspectRatio As Double, _
   Optional ByVal MaxGap As Short, _
   Optional ByVal MaxCharRepairSize As Short _
)
'Usage

Dim instance As Processor
Dim MinLength As Integer
Dim MaxThickness As Short
Dim MinAspectRatio As Double
Dim MaxGap As Short
Dim MaxCharRepairSize As Short

instance.DocumentLineRemoval(MinLength, MaxThickness, MinAspectRatio, MaxGap, MaxCharRepairSize)
public void DocumentLineRemoval(
   int MinLength,
   short MaxThickness,
   double MinAspectRatio,
   short MaxGap,
   short MaxCharRepairSize
)
public: void DocumentLineRemoval(
   int MinLength,
   short MaxThickness,
   double MinAspectRatio,
   short MaxGap,
   short MaxCharRepairSize
)
public:
void DocumentLineRemoval(
   int MinLength,
   short MaxThickness,
   double MinAspectRatio,
   short MaxGap,
   short MaxCharRepairSize
)

Parameters

MinLength
An integer from 26 to 20,000 which represents the minimum pixel length of a line to meet removal criteria. The default value is 50.
MaxThickness
An integer from 1 to 50 which represents the maximum pixel thickness of a line meeting the removal criteria. The default value is 20.
MinAspectRatio
A double value which represents the ratio of the line length to the line width. Lines below this aspect ratio are removed. The ratio range is any floating point number between 1 and 1000. The default value is 10. This provides a ratio of 100 pixels in length for every 10 pixels in width.
MaxGap
An integer value which represents the maximum allowed gap in a line for the line to still be considered one object. This value should be an integer from 1 to 20. The default value is 1.
MaxCharRepairSize
An integer value from 0 to 100 which represents the maximum character size to reconstruct intersected characters within the given size after performing line removal. This value should be a positive integer including zero. The default value is 20.
Remarks

Line removal is the process of detecting and removing vertical and horizontal lines from an image. This method examines the current image to find lines and modifies the image to remove them.

Note: Available in Professional edition.

See Also

Reference

Processor Class
Processor Members


DocumentShear Method

DocumentShear Method

Accusoft.ImagXpressSdk Namespace > Processor Class : DocumentShear Method
A double value which represents the shear angle at which the image is sheared in degrees. Positive values shear counter-clockwise, while negative values shear clockwise. This value should be a double floating point value from -70 to 70.
A System.Drawing.Color value which is the pad color. A typical value is white.
A ShearType value which determines the type of shear to modify the image with.
Shears current image clockwise or counter-clockwise.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub DocumentShear( _
   ByVal ShearAngle As Double, _
   ByVal PadColor As Color, _
   ByVal ShearType As ShearType _
)
'Usage

Dim instance As Processor
Dim ShearAngle As Double
Dim PadColor As Color
Dim ShearType As ShearType

instance.DocumentShear(ShearAngle, PadColor, ShearType)
public void DocumentShear(
   double ShearAngle,
   Color PadColor,
   ShearType ShearType
)
public: void DocumentShear(
   double ShearAngle,
   Color PadColor,
   ShearType ShearType
)
public:
void DocumentShear(
   double ShearAngle,
   Color PadColor,
   ShearType ShearType
)

Parameters

ShearAngle
A double value which represents the shear angle at which the image is sheared in degrees. Positive values shear counter-clockwise, while negative values shear clockwise. This value should be a double floating point value from -70 to 70.
PadColor
A System.Drawing.Color value which is the pad color. A typical value is white.
ShearType
A ShearType value which determines the type of shear to modify the image with.
Remarks

Note: Available in Professional edition.

See Also

Reference

Processor Class
Processor Members


DocumentZoomSmooth Method

DocumentZoomSmooth Method

Accusoft.ImagXpressSdk Namespace > Processor Class : DocumentZoomSmooth Method
Replaces the current 1 bit-per-pixel image with an image whose width and height have been doubled and whose pixels have been smoothed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub DocumentZoomSmooth()
'Usage

Dim instance As Processor

instance.DocumentZoomSmooth()
public void DocumentZoomSmooth()
public: void DocumentZoomSmooth();
public:
void DocumentZoomSmooth();
Remarks

This method smooths letters and lines, by first doubling their width and height, then dilating and eroding as required. The result is a larger image, with clearer letters and lines.

Note: Available in Professional edition.

See Also

Reference

Processor Class
Processor Members


Emboss Method

Emboss Method

Accusoft.ImagXpressSdk Namespace > Processor Class : Emboss Method
Performs an emboss on the image causing it to look embellished with metal or embroidered look.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Emboss()
'Usage

Dim instance As Processor

instance.Emboss()
public void Emboss()
public: void Emboss();
public:
void Emboss();
See Also

Reference

Processor Class
Processor Members


Equalize Method

Equalize Method

Accusoft.ImagXpressSdk Namespace > Processor Class : Equalize Method
Equalizes the image by spreading its values across the full image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Equalize()
'Usage

Dim instance As Processor

instance.Equalize()
public void Equalize()
public: void Equalize();
public:
void Equalize();
Remarks

This method adjusts contrast without changing the brightness range of the image. If the brightness values of the image were represented in a histogram, the Equalize method would have the effect of redistributing the brightness values within the image's brightness range, so that blumps of brightness values are spread out more evenly.

For example, if an image has many pixels that have similar brightness, the Equalize method introduces greater difference in brightness between these pixels, without changing the least bright or most bright pixels.

The effect is that greater detail can be seen in areas that previously had very similar brightness.

See Also

Reference

Processor Class
Processor Members


Erode Method

Erode Method

Accusoft.ImagXpressSdk Namespace > Processor Class : Erode Method
Erodes the image by eroding away the boundaries using a 3x3 minimum filter.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Erode()
'Usage

Dim instance As Processor

instance.Erode()
public void Erode()
public: void Erode();
public:
void Erode();
Remarks

Reduces and/or erases protrusions from black letters and lines.

Use this method with images that are greater than 1 bit.

For bitonal images, use the DocumentErode method.

See Also

Reference

Processor Class
Processor Members


Flip Method

Flip Method

Accusoft.ImagXpressSdk Namespace > Processor Class : Flip Method
Flips the current image from top to bottom.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Flip()
'Usage

Dim instance As Processor

instance.Flip()
public void Flip()
public: void Flip();
public:
void Flip();
See Also

Reference

Processor Class
Processor Members


Gamma Method

Gamma Method

Accusoft.ImagXpressSdk Namespace > Processor Class : Gamma Method
A float value which represents a single value that determines the magnitude of the gamma correction.
Specifies the gamma correction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Gamma( _
   ByVal gamma As Single _
)
'Usage

Dim instance As Processor
Dim gamma As Single

instance.Gamma(gamma)
public void Gamma(
   float gamma
)
public: void Gamma(
   float gamma
)
public:
void Gamma(
   float gamma
)

Parameters

gamma
A float value which represents a single value that determines the magnitude of the gamma correction.
Remarks

Valid values are between 0.1 and 10.0.

Because monitors output pixel brightness in a non-linear fashion, the image brightness is not accurately portrayed. Adjusting the gamma enables you to adjust pixel brightness to compensate for the linitations of the display device. The gamma value represents the ratio of input vs. output brightness. A gamma of one represents a linear relationship between input and output brightness - no change is made to the image. A gamma other than one represents a parabolic relationship between input and output brightness.

Applying a gamma = 1 results in no change to the image.

Applying a gamma greater than one results in brightening the image, with mid-brightness levels increased more than extremely dark or light pixels.

Applying a gamma less than one results in darkening the image, with mid-brightness levels decreased more than extremely dark or light pixels.

See Also

Reference

Processor Class
Processor Members


GetAlphaChannelAsBitmap Method

GetAlphaChannelAsBitmap Method

Accusoft.ImagXpressSdk Namespace > Processor Class : GetAlphaChannelAsBitmap Method
Returns a bitmap object of type System.Drawing.Imaging.PixelFormat.Format8bppIndexed which is an 8 bit gray scale image depicting the alpha channel data layer.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetAlphaChannelAsBitmap() As Bitmap
'Usage

Dim instance As Processor
Dim value As Bitmap

value = instance.GetAlphaChannelAsBitmap()
public Bitmap GetAlphaChannelAsBitmap()
public: Bitmap* GetAlphaChannelAsBitmap();
public:
Bitmap^ GetAlphaChannelAsBitmap();

Return Value

A System.Drawing.Bitmap value which represents the returned bitmap.
Remarks

The original image must be a 32 bit image where 8 bits are the alpha layer and 24 bits are rgb color layer.

Returning the handle implicitly reduces the image down to 24 bit. The alpha object may be modified and restored via the AlphaAdd method.

See Also

Reference

Processor Class
Processor Members


GetAlphaChannelAsHBitmap Method

GetAlphaChannelAsHBitmap Method

Accusoft.ImagXpressSdk Namespace > Processor Class : GetAlphaChannelAsHBitmap Method

Returns an integer pointer which is a bitmap handle to a plane which is similar to an 8 bit gray scaled image.

Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetAlphaChannelAsHBitmap() As IntPtr
'Usage

Dim instance As Processor
Dim value As IntPtr

value = instance.GetAlphaChannelAsHBitmap()
public IntPtr GetAlphaChannelAsHBitmap()
public: IntPtr GetAlphaChannelAsHBitmap();
public:
IntPtr GetAlphaChannelAsHBitmap();
Remarks

Returning the handle implicitly reduces the image down to 24 bit. The alpha layer may be modified and restored via the AlphaAdd(IntPtr) method.

The original image must be a 32 bit image where 8 bits are the alpha layer and 24 bits are rgb layer.

See Also

Reference

Processor Class
Processor Members


Matrix Method

Matrix Method

Accusoft.ImagXpressSdk Namespace > Processor Class : Matrix Method
A 16-bit integer array with 9 elements.

The range of the elements is from -32768 to 32767.

The nIPMatrixV is mapped to a 3x3 array used for filtering the image.

A 16-bit integer which represents the divisor of the matrix filter values.

The range is from -999 to 999.

Note: An exception is thrown if 0 is used as it is not divisible by 0.

A 16-bit integer which represents the intensity of the matrix.

The range is from 0 to 10.

Modifies the image using a 3x3 correlation matrix filter.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Matrix( _
   ByVal nIPMatrixV() As Short, _
   ByVal nIPMatrixD As Short, _
   ByVal nIPMatrixI As Short _
)
'Usage

Dim instance As Processor
Dim nIPMatrixV() As Short
Dim nIPMatrixD As Short
Dim nIPMatrixI As Short

instance.Matrix(nIPMatrixV, nIPMatrixD, nIPMatrixI)
public void Matrix(
   short[] nIPMatrixV,
   short nIPMatrixD,
   short nIPMatrixI
)
public: void Matrix(
   short[]* nIPMatrixV,
   short nIPMatrixD,
   short nIPMatrixI
)
public:
void Matrix(
   array<short>^ nIPMatrixV,
   short nIPMatrixD,
   short nIPMatrixI
)

Parameters

nIPMatrixV
A 16-bit integer array with 9 elements.

The range of the elements is from -32768 to 32767.

The nIPMatrixV is mapped to a 3x3 array used for filtering the image.

nIPMatrixD

A 16-bit integer which represents the divisor of the matrix filter values.

The range is from -999 to 999.

Note: An exception is thrown if 0 is used as it is not divisible by 0.

nIPMatrixI

A 16-bit integer which represents the intensity of the matrix.

The range is from 0 to 10.

Remarks

The matrix filter alters each pixel's color based on its current color and the colors of any neighboring pixels. The array of nIPMatrixV matrix values are coefficients. When a pixel is processed, its color value is multiplied by the coefficient in the array's center and any pixels within the 3x3 grid are multiplied by the corresponding coefficients in the array. The sum of the products becomes the target pixel's new value.

The nIPMatrixD parameter is the coefficient denominator. Each coefficient in the filter matrix is divided by the divisor before being applied to a pixel.

If the nIPMatrixI parameter is not 10 then the difference of the original pixel value from the calculated target pixel's new value is multiplied by nIPMatrixI and divided by 10. This value is then added to the original pixel value and this is the target pixel's final value.

See Also

Reference

Processor Class
Processor Members


Median Method

Median Method

Accusoft.ImagXpressSdk Namespace > Processor Class : Median Method
Reduces noise on an image by using a 3x3 median filter.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Median()
'Usage

Dim instance As Processor

instance.Median()
public void Median()
public: void Median();
public:
void Median();
See Also

Reference

Processor Class
Processor Members


Merge Method

Merge Method

Accusoft.ImagXpressSdk Namespace > Processor Class : Merge Method
The image that is to be merged with the image in the processor
The area/size the image is to be merged
The style of merge that is to be performed
Merging occurs with transparency or none
The color that is to be the transparent color if transparency is enabled
Determines the upper range of the superimpose intensity when the MergeStyle is a superimpose style
Determines the lower range of the superimpose intenisty when the MergeStyle is a superimpose style
Merges two images together such that the source image is merged with the current image specified in the processor. This method also specifies the type of merging.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Merge( _
   ByRef sourceImage As ImageX, _
   ByVal mergeSize As MergeSize, _
   ByVal mergeStyle As MergeStyle, _
   ByVal transparent As Boolean, _
   ByVal transparentColor As Color, _
   ByVal mergePercentHigh As Integer, _
   ByVal mergePercentLow As Integer _
)
'Usage

Dim instance As Processor
Dim sourceImage As ImageX
Dim mergeSize As MergeSize
Dim mergeStyle As MergeStyle
Dim transparent As Boolean
Dim transparentColor As Color
Dim mergePercentHigh As Integer
Dim mergePercentLow As Integer

instance.Merge(sourceImage, mergeSize, mergeStyle, transparent, transparentColor, mergePercentHigh, mergePercentLow)
public void Merge(
   ref ImageX sourceImage,
   MergeSize mergeSize,
   MergeStyle mergeStyle,
   bool transparent,
   Color transparentColor,
   int mergePercentHigh,
   int mergePercentLow
)
public: void Merge(
   ref ImageX* sourceImage,
   MergeSize mergeSize,
   MergeStyle mergeStyle,
   bool transparent,
   Color transparentColor,
   int mergePercentHigh,
   int mergePercentLow
)
public:
void Merge(
   ImageX^% sourceImage,
   MergeSize mergeSize,
   MergeStyle mergeStyle,
   bool transparent,
   Color transparentColor,
   int mergePercentHigh,
   int mergePercentLow
)

Parameters

sourceImage
The image that is to be merged with the image in the processor
mergeSize
The area/size the image is to be merged
mergeStyle
The style of merge that is to be performed
transparent
Merging occurs with transparency or none
transparentColor
The color that is to be the transparent color if transparency is enabled
mergePercentHigh
Determines the upper range of the superimpose intensity when the MergeStyle is a superimpose style
mergePercentLow
Determines the lower range of the superimpose intenisty when the MergeStyle is a superimpose style
Remarks

Merging combines the current image being processed with another specified ImageX image. The resulting merged image is stored in Image.

If an area or region is active when the Merge method is called, then the source image is merged with the active region or area on the target image.

When the images being merged are both TIFF files that have tags, ensure that the tags are saved when merging, by first capturing the tags, then merging, then applying the tags again.

If either of the images being merged has a bit depth of less than 24 bits, then both images are converted to 24-bit images, then merged. However a 1-bit image merged with another 1-bit image may result in a 1-bit image.

If either of the images being merged has an associated color profile, then each image's profile is applied, then the images are merged. No color is retained.

Note: Sprites also offer the capability of merging a part of an image with another one, but it is more limited in capability.

See Also

Reference

Processor Class
Processor Members


Mirror Method

Mirror Method

Accusoft.ImagXpressSdk Namespace > Processor Class : Mirror Method
Rotates the current DIB (Device Independent Bitmap) 180 degrees, then flips it to create a mirror image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Mirror()
'Usage

Dim instance As Processor

instance.Mirror()
public void Mirror()
public: void Mirror();
public:
void Mirror();
See Also

Reference

Processor Class
Processor Members


Mosaic Method

Mosaic Method

Accusoft.ImagXpressSdk Namespace > Processor Class : Mosaic Method

An integer value which represents the block size.

The range is from 1 to 63.

Creates tiles or cells to represents the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Mosaic( _
   ByVal blockSize As Integer _
)
'Usage

Dim instance As Processor
Dim blockSize As Integer

instance.Mosaic(blockSize)
public void Mosaic(
   int blockSize
)
public: void Mosaic(
   int blockSize
)
public:
void Mosaic(
   int blockSize
)

Parameters

blockSize

An integer value which represents the block size.

The range is from 1 to 63.

See Also

Reference

Processor Class
Processor Members


MotionBlur Method

MotionBlur Method

Accusoft.ImagXpressSdk Namespace > Processor Class : MotionBlur Method

An integer which represents the intensity of the blur.

The range is from 1 to 25.

Larger values result in a larger blurring result.

An integer which represents the horizontal velocity.

The range is from -10 to 10.

Negaive values blur from right to left; postitive values blur from left to right.

An integer which represents the vertical velocity.

The range is from -10 to 10.

Negative values blur from bottom to top; positive values blur from top to bottom.

Streaks or blurs objects on the image to display them as moving using the specified parameters.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub MotionBlur( _
   ByVal intensity As Integer, _
   ByVal velocityX As Integer, _
   ByVal velocityY As Integer _
)
'Usage

Dim instance As Processor
Dim intensity As Integer
Dim velocityX As Integer
Dim velocityY As Integer

instance.MotionBlur(intensity, velocityX, velocityY)
public void MotionBlur(
   int intensity,
   int velocityX,
   int velocityY
)
public: void MotionBlur(
   int intensity,
   int velocityX,
   int velocityY
)
public:
void MotionBlur(
   int intensity,
   int velocityX,
   int velocityY
)

Parameters

intensity

An integer which represents the intensity of the blur.

The range is from 1 to 25.

Larger values result in a larger blurring result.

velocityX

An integer which represents the horizontal velocity.

The range is from -10 to 10.

Negaive values blur from right to left; postitive values blur from left to right.

velocityY

An integer which represents the vertical velocity.

The range is from -10 to 10.

Negative values blur from bottom to top; positive values blur from top to bottom.

See Also

Reference

Processor Class
Processor Members


Negate Method

Negate Method

Accusoft.ImagXpressSdk Namespace > Processor Class : Negate Method
Creates a color negative of the current image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Negate()
'Usage

Dim instance As Processor

instance.Negate()
public void Negate()
public: void Negate();
public:
void Negate();
See Also

Reference

Processor Class
Processor Members


Noise Method

Noise Method

Accusoft.ImagXpressSdk Namespace > Processor Class : Noise Method

An integer value which represents the frequency.

The range is from 1 to 20.

Larger values result in more frequent noise.

An integer value which represents the intensity.

The range is from 1 to 255.

Larger values result in more intense noise. The more intense the noise, the more visibly obvious the noise becomes.

Creates more noise by the given parameters.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Noise( _
   ByVal frequency As Integer, _
   ByVal intensity As Integer _
)
'Usage

Dim instance As Processor
Dim frequency As Integer
Dim intensity As Integer

instance.Noise(frequency, intensity)
public void Noise(
   int frequency,
   int intensity
)
public: void Noise(
   int frequency,
   int intensity
)
public:
void Noise(
   int frequency,
   int intensity
)

Parameters

frequency

An integer value which represents the frequency.

The range is from 1 to 20.

Larger values result in more frequent noise.

intensity

An integer value which represents the intensity.

The range is from 1 to 255.

Larger values result in more intense noise. The more intense the noise, the more visibly obvious the noise becomes.

Remarks

This method is useful for screen savers.

See Also

Reference

Processor Class
Processor Members


Outline Method

Outline Method

Accusoft.ImagXpressSdk Namespace > Processor Class : Outline Method
Outlines the outter edges of the image by enhancing the edges.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Outline()
'Usage

Dim instance As Processor

instance.Outline()
public void Outline()
public: void Outline();
public:
void Outline();
See Also

Reference

Processor Class
Processor Members


Parabolic Method

Parabolic Method

Accusoft.ImagXpressSdk Namespace > Processor Class : Parabolic Method
The ParabolicType to use to transform the image.
Modifies the image by the given ParabolicType.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Parabolic( _
   ByVal type As ParabolicType _
)
'Usage

Dim instance As Processor
Dim type As ParabolicType

instance.Parabolic(type)
public void Parabolic(
   ParabolicType type
)
public: void Parabolic(
   ParabolicType type
)
public:
void Parabolic(
   ParabolicType type
)

Parameters

type
The ParabolicType to use to transform the image.
Remarks

The Parabolic method adjusts the brightness of the image based on either a convex or concave parabolic transform, as specified. The convex parabolic transform darkens the pixels at the high and low range of the image's brightness spectrum, and brightens the pixels in the middle range. The concave parabolic transform brightens the pixels at the high and low range of the image's brightness spectrum, and darkens pixels in the mid-range.

See Also

Reference

Processor Class
Processor Members


Perspective Method

Perspective Method

Accusoft.ImagXpressSdk Namespace > Processor Class : Perspective Method
The PerspectiveType to use.

An integer which represents the percentage to modify the image.

The range is from 0 to 100.

Modifies the image using the given PerspectiveType and percent.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Perspective( _
   ByVal perspectiveType As PerspectiveType, _
   ByVal percent As Integer _
)
'Usage

Dim instance As Processor
Dim perspectiveType As PerspectiveType
Dim percent As Integer

instance.Perspective(perspectiveType, percent)
public void Perspective(
   PerspectiveType perspectiveType,
   int percent
)
public: void Perspective(
   PerspectiveType perspectiveType,
   int percent
)
public:
void Perspective(
   PerspectiveType perspectiveType,
   int percent
)

Parameters

perspectiveType
The PerspectiveType to use.
percent

An integer which represents the percentage to modify the image.

The range is from 0 to 100.

Remarks

This method gives the effect of an altered perspective.

See Also

Reference

Processor Class
Processor Members


Pinch Method

Pinch Method

Accusoft.ImagXpressSdk Namespace > Processor Class : Pinch Method

An integer value which represents the intensity of the pinch.

The range is from -100 to 100.

Modifies the image to look like it was pinched in the center using the given intensity.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Pinch( _
   ByVal intensity As Integer _
)
'Usage

Dim instance As Processor
Dim intensity As Integer

instance.Pinch(intensity)
public void Pinch(
   int intensity
)
public: void Pinch(
   int intensity
)
public:
void Pinch(
   int intensity
)

Parameters

intensity

An integer value which represents the intensity of the pinch.

The range is from -100 to 100.

Remarks

Positive intensity values give the current image an appearance of being pinched in the center. Negative values give the image an appearance of stretching from the center.

See Also

Reference

Processor Class
Processor Members


PolynomialWarp Method

PolynomialWarp Method

Accusoft.ImagXpressSdk Namespace > Processor Class : PolynomialWarp Method
A point value which represents the first bounding point.
A point value which represents the second bounding point.
A point value which represents the third bounding point.
A point value which represents the fourth bounding point.
Modifies and warps the image to the given points.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub PolynomialWarp( _
   ByVal boundingPoint1 As Point, _
   ByVal boundingPoint2 As Point, _
   ByVal boundingPoint3 As Point, _
   ByVal boundingPoint4 As Point _
)
'Usage

Dim instance As Processor
Dim boundingPoint1 As Point
Dim boundingPoint2 As Point
Dim boundingPoint3 As Point
Dim boundingPoint4 As Point

instance.PolynomialWarp(boundingPoint1, boundingPoint2, boundingPoint3, boundingPoint4)
public void PolynomialWarp(
   Point boundingPoint1,
   Point boundingPoint2,
   Point boundingPoint3,
   Point boundingPoint4
)
public: void PolynomialWarp(
   Point boundingPoint1,
   Point boundingPoint2,
   Point boundingPoint3,
   Point boundingPoint4
)
public:
void PolynomialWarp(
   Point boundingPoint1,
   Point boundingPoint2,
   Point boundingPoint3,
   Point boundingPoint4
)

Parameters

boundingPoint1
A point value which represents the first bounding point.
boundingPoint2
A point value which represents the second bounding point.
boundingPoint3
A point value which represents the third bounding point.
boundingPoint4
A point value which represents the fourth bounding point.
Remarks

The parameters affix coordinate points to boundary areas to warp the image.

See Also

Reference

Processor Class
Processor Members


Posterize Method

Posterize Method

Accusoft.ImagXpressSdk Namespace > Processor Class : Posterize Method
An integer value which represents the number of levels to posterize.
Reduces the number of colors to give it the effect of contours in the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Posterize( _
   ByVal numberOfLevels As Integer _
)
'Usage

Dim instance As Processor
Dim numberOfLevels As Integer

instance.Posterize(numberOfLevels)
public void Posterize(
   int numberOfLevels
)
public: void Posterize(
   int numberOfLevels
)
public:
void Posterize(
   int numberOfLevels
)

Parameters

numberOfLevels
An integer value which represents the number of levels to posterize.
Remarks

Valid values are between 2 and 255.

This method has the effect of creating posterized contours in the image. For example, a value of 3 indicates 3 levels or red, 3 levels of green, and 3 levels of blue.

See Also

Reference

Processor Class
Processor Members


RemoveDust Method

RemoveDust Method

Accusoft.ImagXpressSdk Namespace > Processor Class : RemoveDust Method

An integer value which represents the defect threshold.

The range is from -255 to 255.

An integer value which represents the defect filter adjustment.

The range is from -6 to 2.

An integer value which represents the defect smoothing adjustment.

The range is from -5 o 100.

A DefectType.
Removes what appears to be dust on the image by the given parameters.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub RemoveDust( _
   ByVal defectThreshold As Integer, _
   ByVal defectFilterAdjustment As Integer, _
   ByVal defectSmoothingAdjustment As Integer, _
   ByVal defectType As DefectType _
)
'Usage

Dim instance As Processor
Dim defectThreshold As Integer
Dim defectFilterAdjustment As Integer
Dim defectSmoothingAdjustment As Integer
Dim defectType As DefectType

instance.RemoveDust(defectThreshold, defectFilterAdjustment, defectSmoothingAdjustment, defectType)
public void RemoveDust(
   int defectThreshold,
   int defectFilterAdjustment,
   int defectSmoothingAdjustment,
   DefectType defectType
)
public: void RemoveDust(
   int defectThreshold,
   int defectFilterAdjustment,
   int defectSmoothingAdjustment,
   DefectType defectType
)
public:
void RemoveDust(
   int defectThreshold,
   int defectFilterAdjustment,
   int defectSmoothingAdjustment,
   DefectType defectType
)

Parameters

defectThreshold

An integer value which represents the defect threshold.

The range is from -255 to 255.

defectFilterAdjustment

An integer value which represents the defect filter adjustment.

The range is from -6 to 2.

defectSmoothingAdjustment

An integer value which represents the defect smoothing adjustment.

The range is from -5 o 100.

defectType
A DefectType.
Remarks

Before calling this method you must set an area using the SetArea method.

Note: Available in Professional edition.

See Also

Reference

Processor Class
Processor Members


RemoveRedeye Method

RemoveRedeye Method

Accusoft.ImagXpressSdk Namespace > Processor Class : RemoveRedeye Method
A RedeyePrecision value to modify the image.
A RedeyeShade to use to modify the shade of the eye.
A RedeyeGlare to modify the glare of the eye.
Removes what appears as red eye's in an image using the given parameters.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub RemoveRedeye( _
   ByVal precision As RedeyePrecision, _
   ByVal eyeShade As RedeyeShade, _
   ByVal eyeGlare As RedeyeGlare _
)
'Usage

Dim instance As Processor
Dim precision As RedeyePrecision
Dim eyeShade As RedeyeShade
Dim eyeGlare As RedeyeGlare

instance.RemoveRedeye(precision, eyeShade, eyeGlare)
public void RemoveRedeye(
   RedeyePrecision precision,
   RedeyeShade eyeShade,
   RedeyeGlare eyeGlare
)
public: void RemoveRedeye(
   RedeyePrecision precision,
   RedeyeShade eyeShade,
   RedeyeGlare eyeGlare
)
public:
void RemoveRedeye(
   RedeyePrecision precision,
   RedeyeShade eyeShade,
   RedeyeGlare eyeGlare
)

Parameters

precision
A RedeyePrecision value to modify the image.
eyeShade
A RedeyeShade to use to modify the shade of the eye.
eyeGlare
A RedeyeGlare to modify the glare of the eye.
Remarks

Before calling this method you must set an area using the SetArea method.

Note: Available in Professional edition.

See Also

Reference

Processor Class
Processor Members


RemoveScratches Method

RemoveScratches Method

Accusoft.ImagXpressSdk Namespace > Processor Class : RemoveScratches Method
A point value which represents the starting point of the scratch to be removed. The coordinate values of the point must be greater than or equal to 0.
A point value which represents the ending point of the scratch to be removed. The coordinate values of the point must be greater than or equal to 0.
An integer value which represents the width of the scratch in pixels. This value must be greater than or equal to 1.
An integer value which represents how bright a pixel must be before it is considered a scratch. This value must be between -255 and 255 inclusive.
An integer value which controls where the filter boundary begins relative to the scratch for smoothing to occur. Pixels near (not inside) the scratch are filtered to make a smooth transition. This value must be between -6 and 2 inclusive. A default value of 0 is recommended for a starting value.
An integer value which controls how much smoothing is applied to the pixels in the scratch. This value must be between -5 and 100 inclusive. A default value of 0 is recommended for a starting value.
The DefectType value used in determining the type of scratch to process, essentially either dark or light scratches.
Removes what appear to be scratches within color images along a line.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub RemoveScratches( _
   ByVal scratchStartingPoint As Point, _
   ByVal scratchEndingPoint As Point, _
   ByVal scratchLineWidth As Integer, _
   ByVal scratchThreshold As Integer, _
   ByVal scratchFilterAdjustment As Integer, _
   ByVal scratchSmoothingAdjustment As Integer, _
   ByVal scratchType As DefectType _
)
'Usage

Dim instance As Processor
Dim scratchStartingPoint As Point
Dim scratchEndingPoint As Point
Dim scratchLineWidth As Integer
Dim scratchThreshold As Integer
Dim scratchFilterAdjustment As Integer
Dim scratchSmoothingAdjustment As Integer
Dim scratchType As DefectType

instance.RemoveScratches(scratchStartingPoint, scratchEndingPoint, scratchLineWidth, scratchThreshold, scratchFilterAdjustment, scratchSmoothingAdjustment, scratchType)
public void RemoveScratches(
   Point scratchStartingPoint,
   Point scratchEndingPoint,
   int scratchLineWidth,
   int scratchThreshold,
   int scratchFilterAdjustment,
   int scratchSmoothingAdjustment,
   DefectType scratchType
)
public: void RemoveScratches(
   Point scratchStartingPoint,
   Point scratchEndingPoint,
   int scratchLineWidth,
   int scratchThreshold,
   int scratchFilterAdjustment,
   int scratchSmoothingAdjustment,
   DefectType scratchType
)
public:
void RemoveScratches(
   Point scratchStartingPoint,
   Point scratchEndingPoint,
   int scratchLineWidth,
   int scratchThreshold,
   int scratchFilterAdjustment,
   int scratchSmoothingAdjustment,
   DefectType scratchType
)

Parameters

scratchStartingPoint
A point value which represents the starting point of the scratch to be removed. The coordinate values of the point must be greater than or equal to 0.
scratchEndingPoint
A point value which represents the ending point of the scratch to be removed. The coordinate values of the point must be greater than or equal to 0.
scratchLineWidth
An integer value which represents the width of the scratch in pixels. This value must be greater than or equal to 1.
scratchThreshold
An integer value which represents how bright a pixel must be before it is considered a scratch. This value must be between -255 and 255 inclusive.
scratchFilterAdjustment
An integer value which controls where the filter boundary begins relative to the scratch for smoothing to occur. Pixels near (not inside) the scratch are filtered to make a smooth transition. This value must be between -6 and 2 inclusive. A default value of 0 is recommended for a starting value.
scratchSmoothingAdjustment
An integer value which controls how much smoothing is applied to the pixels in the scratch. This value must be between -5 and 100 inclusive. A default value of 0 is recommended for a starting value.
scratchType
The DefectType value used in determining the type of scratch to process, essentially either dark or light scratches.
Exceptions
Exception | Description
System.ArgumentException | Thrown when the scratch starting and ending points are the same.
Remarks

Before calling this method you must set an area using the SetArea method.

Note: Available in Professional edition.

Thrown when the scratch starting and ending points are the same.
See Also

Reference

Processor Class
Processor Members


ReplaceColors Method

ReplaceColors Method

Accusoft.ImagXpressSdk Namespace > Processor Class : ReplaceColors Method
The System.Drawing.Color that evaluates to the beginning color range.
The System.Drawing.Color that evaluates to the ending color range.
The System.Drawing.Color that evaluates to the replacement color.
Replaces a range of colors in the current image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub ReplaceColors( _
   ByVal fromColor As Color, _
   ByVal toColor As Color, _
   ByVal replacementColor As Color _
)
'Usage

Dim instance As Processor
Dim fromColor As Color
Dim toColor As Color
Dim replacementColor As Color

instance.ReplaceColors(fromColor, toColor, replacementColor)
public void ReplaceColors(
   Color fromColor,
   Color toColor,
   Color replacementColor
)
public: void ReplaceColors(
   Color fromColor,
   Color toColor,
   Color replacementColor
)
public:
void ReplaceColors(
   Color fromColor,
   Color toColor,
   Color replacementColor
)

Parameters

fromColor
The System.Drawing.Color that evaluates to the beginning color range.
toColor
The System.Drawing.Color that evaluates to the ending color range.
replacementColor
The System.Drawing.Color that evaluates to the replacement color.
See Also

Reference

Processor Class
Processor Members


Resize Method

Resize Method

Accusoft.ImagXpressSdk Namespace > Processor Class : Resize Method
Resizes the current image allowing passing in a new size and resize type.
Overload List
Overload | Description
Resize(Size,ResizeType) | Resizes the current image allowing passing in a new size and resize type.
Resize(Size,ResizeType,Boolean,Boolean) | Resizes the current image allowing passing in a new size, resize type, scale to gray and scale preserve black values.
See Also

Reference

Processor Class
Processor Members


Resize(Size,ResizeType) Method

Resize(Size,ResizeType) Method

Accusoft.ImagXpressSdk Namespace > Processor Class > Resize Method : Resize(Size,ResizeType) Method
System.Drawing.Size values which the image is resized to in twips.
A ResizeType enumeration value used to determine what type of resize method to perform during resizing.
Resizes the current image allowing passing in a new size and resize type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Resize( _
   ByVal newSize As Size, _
   ByVal resizeType As ResizeType _
)
'Usage

Dim instance As Processor
Dim newSize As Size
Dim resizeType As ResizeType

instance.Resize(newSize, resizeType)
public void Resize(
   Size newSize,
   ResizeType resizeType
)
public: void Resize(
   Size newSize,
   ResizeType resizeType
)
public:
void Resize(
   Size newSize,
   ResizeType resizeType
)

Parameters

newSize
System.Drawing.Size values which the image is resized to in twips.
resizeType
A ResizeType enumeration value used to determine what type of resize method to perform during resizing.
See Also

Reference

Processor Class
Processor Members
Overload List


Resize(Size,ResizeType,Boolean,Boolean) Method

Resize(Size,ResizeType,Boolean,Boolean) Method

Accusoft.ImagXpressSdk Namespace > Processor Class > Resize Method : Resize(Size,ResizeType,Boolean,Boolean) Method
System.Drawing.Size values which the image is resized to in twips.
A ResizeType enumeration value used to determine what type of resize method to perform during resizing.
A boolean value to set to true to scale to gray when resized. Otherwise, false should be set.
A boolean value to set to true to enhance dark lines in the image when the image is resized. Otherwise, false should be set and dark lines are not enhanced.
Resizes the current image allowing passing in a new size, resize type, scale to gray and scale preserve black values.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Resize( _
   ByVal newSize As Size, _
   ByVal resizeType As ResizeType, _
   ByVal scaleResizeToGray As Boolean, _
   ByVal scaleResizePreserveBlack As Boolean _
)
'Usage

Dim instance As Processor
Dim newSize As Size
Dim resizeType As ResizeType
Dim scaleResizeToGray As Boolean
Dim scaleResizePreserveBlack As Boolean

instance.Resize(newSize, resizeType, scaleResizeToGray, scaleResizePreserveBlack)
public void Resize(
   Size newSize,
   ResizeType resizeType,
   bool scaleResizeToGray,
   bool scaleResizePreserveBlack
)
public: void Resize(
   Size newSize,
   ResizeType resizeType,
   bool scaleResizeToGray,
   bool scaleResizePreserveBlack
)
public:
void Resize(
   Size newSize,
   ResizeType resizeType,
   bool scaleResizeToGray,
   bool scaleResizePreserveBlack
)

Parameters

newSize
System.Drawing.Size values which the image is resized to in twips.
resizeType
A ResizeType enumeration value used to determine what type of resize method to perform during resizing.
scaleResizeToGray
A boolean value to set to true to scale to gray when resized. Otherwise, false should be set.
scaleResizePreserveBlack
A boolean value to set to true to enhance dark lines in the image when the image is resized. Otherwise, false should be set and dark lines are not enhanced.
See Also

Reference

Processor Class
Processor Members
Overload List


RGBColorCount Method

RGBColorCount Method
Example

Accusoft.ImagXpressSdk Namespace > Processor Class : RGBColorCount Method
An integer array of red counts.
An integer array of green counts.
An integer array of blue counts.
Returns three arrays, each containing 256 elements, which equate to a count of the red, green, and blue color intensities of the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub RGBColorCount( _
   ByRef redCounts As Integer(), _
   ByRef greenCounts As Integer(), _
   ByRef blueCounts As Integer() _
)
'Usage

Dim instance As Processor
Dim redCounts As Integer()
Dim greenCounts As Integer()
Dim blueCounts As Integer()

instance.RGBColorCount(redCounts, greenCounts, blueCounts)
public void RGBColorCount(
   out int[] redCounts,
   out int[] greenCounts,
   out int[] blueCounts
)
public: void RGBColorCount(
   [PARAMFLAG::Out] int[] redCounts,
   [PARAMFLAG::Out] int[] greenCounts,
   [PARAMFLAG::Out] int[] blueCounts
)
public:
void RGBColorCount(
   [Out] array<int> redCounts,
   [Out] array<int> greenCounts,
   [Out] array<int> blueCounts
)

Parameters

redCounts
An integer array of red counts.
greenCounts
An integer array of green counts.
blueCounts
An integer array of blue counts.
Remarks

The returned arrays contain a histogram of intensity values for each of the red, green, and blue components of the current image.

Example
  • C#
int[] redCounts;
int[] greenCounts;
int[] blueCounts;
using (Processor processor = new Processor(imagXpress1, imageXView1.Image))
{
    processor.RGBColorCount(out redCounts, out greenCounts, out blueCounts);
}
See Also

Reference

Processor Class
Processor Members


Ripple Method

Ripple Method

Accusoft.ImagXpressSdk Namespace > Processor Class : Ripple Method

An integer value which represents the frequency.

The range is from 1 to 100.

Larger values result in more ripples.

An integer value which represents the intensity.

The range is from -100 to 100.

Larger values result in more intense ripples.

A RippleDirection enumeration value which determines the direction of the ripple.
Modifies the image to create a ripple effect as per the given parameters.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Ripple( _
   ByVal frequency As Integer, _
   ByVal intensity As Integer, _
   ByVal direction As RippleDirection _
)
'Usage

Dim instance As Processor
Dim frequency As Integer
Dim intensity As Integer
Dim direction As RippleDirection

instance.Ripple(frequency, intensity, direction)
public void Ripple(
   int frequency,
   int intensity,
   RippleDirection direction
)
public: void Ripple(
   int frequency,
   int intensity,
   RippleDirection direction
)
public:
void Ripple(
   int frequency,
   int intensity,
   RippleDirection direction
)

Parameters

frequency

An integer value which represents the frequency.

The range is from 1 to 100.

Larger values result in more ripples.

intensity

An integer value which represents the intensity.

The range is from -100 to 100.

Larger values result in more intense ripples.

direction
A RippleDirection enumeration value which determines the direction of the ripple.
See Also

Reference

Processor Class
Processor Members


Rotate Method

Rotate Method

Accusoft.ImagXpressSdk Namespace > Processor Class : Rotate Method
A double value that represents the angle by which the image will be rotated. Valid values are -360 to 360 degrees.
Rotates the current image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Rotate( _
   ByVal rotationAngle As Double _
)
'Usage

Dim instance As Processor
Dim rotationAngle As Double

instance.Rotate(rotationAngle)
public void Rotate(
   double rotationAngle
)
public: void Rotate(
   double rotationAngle
)
public:
void Rotate(
   double rotationAngle
)

Parameters

rotationAngle
A double value that represents the angle by which the image will be rotated. Valid values are -360 to 360 degrees.
Remarks

Note: Rotation is counter-clockwise.

See Also

Reference

Processor Class
Processor Members


SetArea Method

SetArea Method

Accusoft.ImagXpressSdk Namespace > Processor Class : SetArea Method
The System.Drawing.RectangleF to set as the bounding area for the image.
Sets the area.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetArea( _
   ByVal boundingArea As RectangleF _
)
'Usage

Dim instance As Processor
Dim boundingArea As RectangleF

instance.SetArea(boundingArea)
public void SetArea(
   RectangleF boundingArea
)
public: void SetArea(
   RectangleF boundingArea
)
public:
void SetArea(
   RectangleF boundingArea
)

Parameters

boundingArea
The System.Drawing.RectangleF to set as the bounding area for the image.
Exceptions
Exception | Description
System.ArgumentException | Thrown when a rectangle is specified with negative coordinates.
Remarks

There are two ways to specify a portion of the image to process: Region or Area.

There can only be one region, and one area specified per processor.

When EnableRegion is set to true, and a region has been defined using this method, all image processing actions apply to the region only.

When EnableArea has been set to true, and an area is defined using SetArea, all image processing actions apply to the area only.

When both a region and an area have been enabled and defined, image processing actions apply to whichever was most recently set.

When neither a region nor an area have been enabled and defined, image processing actions are applied to the entire image.

Note: If the X and the Y coordinates of the bounding area rectangle fall within the boundaries of the image but the Width or Height of the Rectangle exceeds the boundaries of the image, the update area is cropped to fit within the image boundaries.

See Also

Reference

Processor Class
Processor Members


SetRegion Method

SetRegion Method

Accusoft.ImagXpressSdk Namespace > Processor Class : SetRegion Method
Sets the given processing region for the image.
Overload List
Overload | Description
SetRegion(GraphicsPath) | Sets the given processing region for the image.
SetRegion(RectangleF,RegionType) | Sets the region using the given parameters.
See Also

Reference

Processor Class
Processor Members


SetRegion(GraphicsPath) Method

SetRegion(GraphicsPath) Method

Accusoft.ImagXpressSdk Namespace > Processor Class > SetRegion Method : SetRegion(GraphicsPath) Method
The System.Drawing.Drawing2D.GraphicsPath value which represents the region to set.
Sets the given processing region for the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub SetRegion( _
   ByVal region As GraphicsPath _
)
'Usage

Dim instance As Processor
Dim region As GraphicsPath

instance.SetRegion(region)
public void SetRegion(
   GraphicsPath region
)
public: void SetRegion(
   GraphicsPath* region
)
public:
void SetRegion(
   GraphicsPath^ region
)

Parameters

region
The System.Drawing.Drawing2D.GraphicsPath value which represents the region to set.
Remarks

There are two ways to specify a portion of the image to process: Region or Area.

There can only be one region, and one area specified per processor.

When EnableRegion is set to true, and a region has been defined using this method, all image processing actions apply to the region only.

When EnableArea has been set to true, and an area is defined using SetArea, all image processing actions apply to the area only.

When both a region and an area have been enabled and defined, image processing actions apply to whichever was most recently set.

When neither a region nor an area have been enabled and defined, image processing actions are applied to the entire image.

See Also

Reference

Processor Class
Processor Members
Overload List


SetRegion(RectangleF,RegionType) Method

SetRegion(RectangleF,RegionType) Method

Accusoft.ImagXpressSdk Namespace > Processor Class > SetRegion Method : SetRegion(RectangleF,RegionType) Method
A System.Drawing.RectangleF value which represents the bounding area.
A RegionType value which determines the region type to use when setting the region.
Sets the region using the given parameters.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub SetRegion( _
   ByVal boundingArea As RectangleF, _
   ByVal regionType As RegionType _
)
'Usage

Dim instance As Processor
Dim boundingArea As RectangleF
Dim regionType As RegionType

instance.SetRegion(boundingArea, regionType)
public void SetRegion(
   RectangleF boundingArea,
   RegionType regionType
)
public: void SetRegion(
   RectangleF boundingArea,
   RegionType regionType
)
public:
void SetRegion(
   RectangleF boundingArea,
   RegionType regionType
)

Parameters

boundingArea
A System.Drawing.RectangleF value which represents the bounding area.
regionType
A RegionType value which determines the region type to use when setting the region.
Remarks

There are two ways to specify a portion of the image to process: Region or Area.

There can only be one region, and one area specified per processor.

When EnableRegion is set to true, and a region has been defined using this method, all image processing actions apply to the region only.

When EnableArea has been set to true, and an area is defined using SetArea, all image processing actions apply to the area only.

When both a region and an area have been enabled and defined, image processing actions apply to whichever was most recently set.

When neither a region nor an area have been enabled and defined, image processing actions are applied to the entire image.

See Also

Reference

Processor Class
Processor Members
Overload List


Sharpen Method

Sharpen Method

Accusoft.ImagXpressSdk Namespace > Processor Class : Sharpen Method
Sharpens the image by the given intensity.
Overload List
Overload | Description
Sharpen(Int32) | Sharpens the image by the given intensity.
Sharpen(Int32,SharpenFilter) | Sharpens the image by the given intensity and filter.
See Also

Reference

Processor Class
Processor Members


Sharpen(Int32) Method

Sharpen(Int32) Method

Accusoft.ImagXpressSdk Namespace > Processor Class > Sharpen Method : Sharpen(Int32) Method

An integer value which represents the intensity.

The range is from 1 to 10.

Higher values result in sharper images.

Sharpens the image by the given intensity.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Sharpen( _
   ByVal intensity As Integer _
)
'Usage

Dim instance As Processor
Dim intensity As Integer

instance.Sharpen(intensity)
public void Sharpen(
   int intensity
)
public: void Sharpen(
   int intensity
)
public:
void Sharpen(
   int intensity
)

Parameters

intensity

An integer value which represents the intensity.

The range is from 1 to 10.

Higher values result in sharper images.

See Also

Reference

Processor Class
Processor Members
Overload List


Sharpen(Int32,SharpenFilter) Method

Sharpen(Int32,SharpenFilter) Method

Accusoft.ImagXpressSdk Namespace > Processor Class > Sharpen Method : Sharpen(Int32,SharpenFilter) Method

An integer value which represents the intensity.

The range is from 1 to 10.

Higher values result in sharper images.

A SharpenFilter value which represents the type of filter to use to sharpen the image.
Sharpens the image by the given intensity and filter.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Sharpen( _
   ByVal intensity As Integer, _
   ByVal filter As SharpenFilter _
)
'Usage

Dim instance As Processor
Dim intensity As Integer
Dim filter As SharpenFilter

instance.Sharpen(intensity, filter)
public void Sharpen(
   int intensity,
   SharpenFilter filter
)
public: void Sharpen(
   int intensity,
   SharpenFilter filter
)
public:
void Sharpen(
   int intensity,
   SharpenFilter filter
)

Parameters

intensity

An integer value which represents the intensity.

The range is from 1 to 10.

Higher values result in sharper images.

filter
A SharpenFilter value which represents the type of filter to use to sharpen the image.
See Also

Reference

Processor Class
Processor Members
Overload List


Soften Method

Soften Method

Accusoft.ImagXpressSdk Namespace > Processor Class : Soften Method
Softens the image by the given intensity.
Overload List
Overload | Description
Soften(Int32) | Softens the image by the given intensity.
Soften(Int32,SoftenFilter) | Softens the image by the given intensity and filter.
See Also

Reference

Processor Class
Processor Members


Soften(Int32) Method

Soften(Int32) Method

Accusoft.ImagXpressSdk Namespace > Processor Class > Soften Method : Soften(Int32) Method

An integer value which represents the intensity.

The range is from 1 to 10.

Higher values result in softer images.

Softens the image by the given intensity.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Soften( _
   ByVal intensity As Integer _
)
'Usage

Dim instance As Processor
Dim intensity As Integer

instance.Soften(intensity)
public void Soften(
   int intensity
)
public: void Soften(
   int intensity
)
public:
void Soften(
   int intensity
)

Parameters

intensity

An integer value which represents the intensity.

The range is from 1 to 10.

Higher values result in softer images.

See Also

Reference

Processor Class
Processor Members
Overload List


Soften(Int32,SoftenFilter) Method

Soften(Int32,SoftenFilter) Method

Accusoft.ImagXpressSdk Namespace > Processor Class > Soften Method : Soften(Int32,SoftenFilter) Method

An integer value which represents the intensity.

The range is from 1 to 10.

Higher values result in softer images.

A SoftenFilter which determines the soften filter to apply to the image.
Softens the image by the given intensity and filter.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Soften( _
   ByVal intensity As Integer, _
   ByVal filter As SoftenFilter _
)
'Usage

Dim instance As Processor
Dim intensity As Integer
Dim filter As SoftenFilter

instance.Soften(intensity, filter)
public void Soften(
   int intensity,
   SoftenFilter filter
)
public: void Soften(
   int intensity,
   SoftenFilter filter
)
public:
void Soften(
   int intensity,
   SoftenFilter filter
)

Parameters

intensity

An integer value which represents the intensity.

The range is from 1 to 10.

Higher values result in softer images.

filter
A SoftenFilter which determines the soften filter to apply to the image.
See Also

Reference

Processor Class
Processor Members
Overload List


Solarize Method

Solarize Method

Accusoft.ImagXpressSdk Namespace > Processor Class : Solarize Method

An integer value which represents the threshold value to use to solarize the image.

The range is from 0 to 255.

Modifies the image by inverting the pixel values to negative.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Solarize( _
   ByVal threshold As Integer _
)
'Usage

Dim instance As Processor
Dim threshold As Integer

instance.Solarize(threshold)
public void Solarize(
   int threshold
)
public: void Solarize(
   int threshold
)
public:
void Solarize(
   int threshold
)

Parameters

threshold

An integer value which represents the threshold value to use to solarize the image.

The range is from 0 to 255.

See Also

Reference

Processor Class
Processor Members


Swirl Method

Swirl Method

Accusoft.ImagXpressSdk Namespace > Processor Class : Swirl Method

A double value which represents the degrees to swirl.

The range is from 0 to 360 (degrees).

Modifies the image to appear in a swirl based on the given degrees.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Swirl( _
   ByVal degrees As Double _
)
'Usage

Dim instance As Processor
Dim degrees As Double

instance.Swirl(degrees)
public void Swirl(
   double degrees
)
public: void Swirl(
   double degrees
)
public:
void Swirl(
   double degrees
)

Parameters

degrees

A double value which represents the degrees to swirl.

The range is from 0 to 360 (degrees).

See Also

Reference

Processor Class
Processor Members


Tile Method

Tile Method

Accusoft.ImagXpressSdk Namespace > Processor Class : Tile Method
A System.Drawing.Size value which represents the tile size.
Modifies the image to appear in tiles based on the given tile size.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Tile( _
   ByVal tileSize As Size _
)
'Usage

Dim instance As Processor
Dim tileSize As Size

instance.Tile(tileSize)
public void Tile(
   Size tileSize
)
public: void Tile(
   Size tileSize
)
public:
void Tile(
   Size tileSize
)

Parameters

tileSize
A System.Drawing.Size value which represents the tile size.
Remarks

Entering large values in tileSize can create a large image and may increase processing time considerably.

See Also

Reference

Processor Class
Processor Members


Twist Method

Twist Method

Accusoft.ImagXpressSdk Namespace > Processor Class : Twist Method
An integer value which represents the block size of the twist. This value should be an integer from 2 to 63.
A TwistRotation which determines the type of twist to use to modify the image.
Modifies the image to appear in a twist by the given block size and rotation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Twist( _
   ByVal blockSize As Integer, _
   ByVal rotation As TwistRotation _
)
'Usage

Dim instance As Processor
Dim blockSize As Integer
Dim rotation As TwistRotation

instance.Twist(blockSize, rotation)
public void Twist(
   int blockSize,
   TwistRotation rotation
)
public: void Twist(
   int blockSize,
   TwistRotation rotation
)
public:
void Twist(
   int blockSize,
   TwistRotation rotation
)

Parameters

blockSize
An integer value which represents the block size of the twist. This value should be an integer from 2 to 63.
rotation
A TwistRotation which determines the type of twist to use to modify the image.
See Also

Reference

Processor Class
Processor Members


UniqueColors Method

UniqueColors Method

Accusoft.ImagXpressSdk Namespace > Processor Class : UniqueColors Method
Returns a count of unique colors in the current image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function UniqueColors() As Long
'Usage

Dim instance As Processor
Dim value As Long

value = instance.UniqueColors()
public long UniqueColors()
public: long UniqueColors();
public:
int64 UniqueColors();

Return Value

A long value which represents the number of unique colors contained in the current image.
See Also

Reference

Processor Class
Processor Members


Unsharpen Method

Unsharpen Method

Accusoft.ImagXpressSdk Namespace > Processor Class : Unsharpen Method
Modifies the image to appear not as detailed based on the given intensity.
Overload List
Overload | Description
Unsharpen(Int32) | Modifies the image to appear not as detailed based on the given intensity.
Unsharpen(Int32,UnsharpenFilter) | Modifies the image to appear not as detailed based on the given intensity and filter.
See Also

Reference

Processor Class
Processor Members


Unsharpen(Int32) Method

Unsharpen(Int32) Method

Accusoft.ImagXpressSdk Namespace > Processor Class > Unsharpen Method : Unsharpen(Int32) Method

An integer value which represents the intensity.

The range is from 1 to 10.

Higher values result in a larger magnitude of filter processing.

Modifies the image to appear not as detailed based on the given intensity.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Unsharpen( _
   ByVal intensity As Integer _
)
'Usage

Dim instance As Processor
Dim intensity As Integer

instance.Unsharpen(intensity)
public void Unsharpen(
   int intensity
)
public: void Unsharpen(
   int intensity
)
public:
void Unsharpen(
   int intensity
)

Parameters

intensity

An integer value which represents the intensity.

The range is from 1 to 10.

Higher values result in a larger magnitude of filter processing.

Remarks

Edges within the image are sharpened, while othes areas are softened.

Note: Available in Professional edition.

See Also

Reference

Processor Class
Processor Members
Overload List


Unsharpen(Int32,UnsharpenFilter) Method

Unsharpen(Int32,UnsharpenFilter) Method

Accusoft.ImagXpressSdk Namespace > Processor Class > Unsharpen Method : Unsharpen(Int32,UnsharpenFilter) Method

An integer value which represents the intensity.

The range is from 1 to 10.

Higher values result in a larger magnitude of filter processing.

A UnsharpenFilter value which determines the type of unsharpen to use on the image.
Modifies the image to appear not as detailed based on the given intensity and filter.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Unsharpen( _
   ByVal intensity As Integer, _
   ByVal filter As UnsharpenFilter _
)
'Usage

Dim instance As Processor
Dim intensity As Integer
Dim filter As UnsharpenFilter

instance.Unsharpen(intensity, filter)
public void Unsharpen(
   int intensity,
   UnsharpenFilter filter
)
public: void Unsharpen(
   int intensity,
   UnsharpenFilter filter
)
public:
void Unsharpen(
   int intensity,
   UnsharpenFilter filter
)

Parameters

intensity

An integer value which represents the intensity.

The range is from 1 to 10.

Higher values result in a larger magnitude of filter processing.

filter
A UnsharpenFilter value which determines the type of unsharpen to use on the image.
Remarks

Note: Available in Professional edition.

See Also

Reference

Processor Class
Processor Members
Overload List


Processor Class Properties

Processor Class Properties

Accusoft.ImagXpressSdk Namespace : Processor Class

For a list of all members of this type, see Processor members.

Public Properties
 | Name | Description
Public Property | BackgroundColor | Gets and sets the background color of areas expanded by certain image processing operations.
Public Property | BinarizeBlur | Gets the BinarizeBlur value set by AutoBinarize or Binarize.
Public Property | BinarizeEccentricity | Gets the eccentricity value set by AutoBinarize or Binarize.
Public Property | BinarizeGridAngle | Gets the grid angle value set by AutoBinarize or Binarize.
Public Property | BinarizeGridPitch | Gets the grid pitch value set by AutoBinarize or Binarize.
Public Property | BinarizeHighThreshold | Gets the high threshold value set by AutoBinarize or Binarize.
Public Property | BinarizeLceFactor | Gets the local contrast enhancement factor set by AutoBinarize or Binarize.
Public Property | BinarizeLowThreshold | Gets the low threshold value set by AutoBinarize or Binarize.
Public Property | BinarizeMode | Gets the BinarizeMode value set by AutoBinarize or Binarize.
Public Property | BlankPageDetected | Gets an indicator if a blank page is detected.
Public Property | Confidence | Gets the confidence.
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContrastMethod | Gets and sets the contrast method to use.
Public Property | CountOfLinesFound | Gets the number of lines found.
Public Property | CountOfObjectsFound | Gets the number of objects found.
Public Property | CountOfSpecsFound | Gets the number of specs found.
Public Property | EnableArea | Gets and sets whether the area is enabled.
Public Property | EnableRegion | Gets and sets whether the region is enabled.
Public Property | Image | Gets and sets the image to be processed.
Public Property | ImageWasModified | Gets an indicator if the image was modified.
Public Property | LogPalette | Gets and sets the palette for use when the ColorDepth method is called.
Public Property | ProgressPercent | Gets and sets the ProgressEvent frequency.
Public Property | Redeyes | Gets and sets the redeye collection.
Public Property | RotationAngle | Gets the rotation angle.
Public Property | Site | Overridden. Gets and sets the System.ComponentModel.ISite of the Processor.
Public Property | Variation | Gets the variation.
Public Property | Workspace | Gets or sets the ImagXpress workspace component.
Top
See Also

Reference

Processor Class
Accusoft.ImagXpressSdk Namespace


BackgroundColor Property

BackgroundColor Property

Accusoft.ImagXpressSdk Namespace > Processor Class : BackgroundColor Property
Gets and sets the background color of areas expanded by certain image processing operations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("Gets and sets the background color.")>
<BrowsableAttribute(True)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)>
<DefaultValueAttribute()>
Public Property BackgroundColor As Color
'Usage

Dim instance As Processor
Dim value As Color

instance.BackgroundColor = value

value = instance.BackgroundColor
[Description("Gets and sets the background color.")]
[Browsable(true)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
[DefaultValue()]
public Color BackgroundColor {get; set;}
[Description("Gets and sets the background color.")]
[Browsable(true)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
[DefaultValue()]
public: __property Color get_BackgroundColor();
public: __property void set_BackgroundColor(
   Color value
);
[Description("Gets and sets the background color.")]
[Browsable(true)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
[DefaultValue()]
public:
property Color BackgroundColor {
   Color get();
   void set (    Color value);
}

Property Value

A System.Drawing.Color which represents the background color to use.
Remarks

Certain image processing operations can expand regions of the image background when executed. This property provides the default color for the expanded background area.

Note: For images with a palette (e.g., 1-bit or 8-bit), if a particular background color is chosen that isn't part of the palette then the closest color is used instead.

See Also

Reference

Processor Class
Processor Members


BinarizeBlur Property

BinarizeBlur Property

Accusoft.ImagXpressSdk Namespace > Processor Class : BinarizeBlur Property
Gets the BinarizeBlur value set by AutoBinarize or Binarize.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DescriptionAttribute("Gets the blur value set by the AutoBinarize or Binarize methods.")>
Public ReadOnly Property BinarizeBlur As BinarizeBlur
'Usage

Dim instance As Processor
Dim value As BinarizeBlur

value = instance.BinarizeBlur
[Browsable(false)]
[Description("Gets the blur value set by the AutoBinarize or Binarize methods.")]
public BinarizeBlur BinarizeBlur {get;}
[Browsable(false)]
[Description("Gets the blur value set by the AutoBinarize or Binarize methods.")]
public: __property BinarizeBlur get_BinarizeBlur();
[Browsable(false)]
[Description("Gets the blur value set by the AutoBinarize or Binarize methods.")]
public:
property BinarizeBlur BinarizeBlur {
   BinarizeBlur get();
}

Property Value

The BinarizeBlur value which determines the type of blur that was invoked during the AutoBinarize or Binarize methods.

Remarks

The AutoBinarize method will set this value based on what it determined was the optimal setting for the image during the call. If you have similar images, you can call the Binarize method using this value as well as the other values set by the AutoBinarize method. This will be significantly faster than calling the AutoBinarize method for each image.

Note: This value is also set with the value that is passed into the Binarize method. If you call the Binarize method with some other value, this property will reflect that new value.

See Also

Reference

Processor Class
Processor Members


BinarizeEccentricity Property

BinarizeEccentricity Property

Accusoft.ImagXpressSdk Namespace > Processor Class : BinarizeEccentricity Property
Gets the eccentricity value set by AutoBinarize or Binarize.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DescriptionAttribute("Gets the eccentricity value set by the AutoBinarize or Binarize methods.")>
Public ReadOnly Property BinarizeEccentricity As Integer
'Usage

Dim instance As Processor
Dim value As Integer

value = instance.BinarizeEccentricity
[Browsable(false)]
[Description("Gets the eccentricity value set by the AutoBinarize or Binarize methods.")]
public int BinarizeEccentricity {get;}
[Browsable(false)]
[Description("Gets the eccentricity value set by the AutoBinarize or Binarize methods.")]
public: __property int get_BinarizeEccentricity();
[Browsable(false)]
[Description("Gets the eccentricity value set by the AutoBinarize or Binarize methods.")]
public:
property int BinarizeEccentricity {
   int get();
}

Property Value

The integer value which represents the shape of the halftone grid.

The range is from -256 to 256. At the extreme values, -256 and 256, the grid becomes linear. At the midpoint, 0, the grid consists of circles/squares.

Intermediate values give intermediately shaped elliptical grid dots.

Remarks

The AutoBinarize method will set this value based on what it determined was the optimal setting for the image during the call. If you have similar images, you can call the Binarize method using this value as well as the other values set by the AutoBinarize method. This will be significantly faster than calling the AutoBinarize method for each image.

Note: This value is also set with the value that is passed into the Binarize method. If you call the Binarize method with some other value, this property will reflect that new value.

See Also

Reference

Processor Class
Processor Members


BinarizeGridAngle Property

BinarizeGridAngle Property

Accusoft.ImagXpressSdk Namespace > Processor Class : BinarizeGridAngle Property
Gets the grid angle value set by AutoBinarize or Binarize.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DescriptionAttribute("Gets the grid angle value set by the AutoBinarize or Binarize methods.")>
Public ReadOnly Property BinarizeGridAngle As Integer
'Usage

Dim instance As Processor
Dim value As Integer

value = instance.BinarizeGridAngle
[Browsable(false)]
[Description("Gets the grid angle value set by the AutoBinarize or Binarize methods.")]
public int BinarizeGridAngle {get;}
[Browsable(false)]
[Description("Gets the grid angle value set by the AutoBinarize or Binarize methods.")]
public: __property int get_BinarizeGridAngle();
[Browsable(false)]
[Description("Gets the grid angle value set by the AutoBinarize or Binarize methods.")]
public:
property int BinarizeGridAngle {
   int get();
}

Property Value

The integer value which represents the orientation of the halftone grid from the horizontal, measured in degrees clockwise.

The range is from 0 to 360.

Remarks

The AutoBinarize method will set this value based on what it determined was the optimal setting for the image during the call. If you have similar images, you can call the Binarize method using this value as well as the other values set by the AutoBinarize method. This will be significantly faster than calling the AutoBinarize method for each image.

Note: This value is also set with the value that is passed into the Binarize method. If you call the Binarize method with some other value, this property will reflect that new value.

See Also

Reference

Processor Class
Processor Members


BinarizeGridPitch Property

BinarizeGridPitch Property

Accusoft.ImagXpressSdk Namespace > Processor Class : BinarizeGridPitch Property
Gets the grid pitch value set by AutoBinarize or Binarize.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("Gets the grid pitch value set by the AutoBinarize or Binarize methods.")>
<BrowsableAttribute(False)>
Public ReadOnly Property BinarizeGridPitch As Integer
'Usage

Dim instance As Processor
Dim value As Integer

value = instance.BinarizeGridPitch
[Description("Gets the grid pitch value set by the AutoBinarize or Binarize methods.")]
[Browsable(false)]
public int BinarizeGridPitch {get;}
[Description("Gets the grid pitch value set by the AutoBinarize or Binarize methods.")]
[Browsable(false)]
public: __property int get_BinarizeGridPitch();
[Description("Gets the grid pitch value set by the AutoBinarize or Binarize methods.")]
[Browsable(false)]
public:
property int BinarizeGridPitch {
   int get();
}

Property Value

The integer value which represents the distance from the center of a black dot in the halftone grid to the nearest white dot, measured in pixels.

The range is from 1 to 32.

Remarks

The AutoBinarize method will set this value based on what it determined was the optimal setting for the image during the call. If you have similar images, you can call the Binarize method using this value as well as the other values set by the AutoBinarize method. This will be significantly faster than calling the AutoBinarize method for each image.

Note: This value is also set with the value that is passed into the Binarize method. If you call the Binarize method with some other value, this property will reflect that new value.

See Also

Reference

Processor Class
Processor Members


BinarizeHighThreshold Property

BinarizeHighThreshold Property

Accusoft.ImagXpressSdk Namespace > Processor Class : BinarizeHighThreshold Property
Gets the high threshold value set by AutoBinarize or Binarize.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DescriptionAttribute("Gets the high threshold value set by the AutoBinarize or Binarize methods.")>
Public ReadOnly Property BinarizeHighThreshold As Integer
'Usage

Dim instance As Processor
Dim value As Integer

value = instance.BinarizeHighThreshold
[Browsable(false)]
[Description("Gets the high threshold value set by the AutoBinarize or Binarize methods.")]
public int BinarizeHighThreshold {get;}
[Browsable(false)]
[Description("Gets the high threshold value set by the AutoBinarize or Binarize methods.")]
public: __property int get_BinarizeHighThreshold();
[Browsable(false)]
[Description("Gets the high threshold value set by the AutoBinarize or Binarize methods.")]
public:
property int BinarizeHighThreshold {
   int get();
}

Property Value

The integer value which represents the high threshold which controls letter and figure thickness.

The range is from BinarizeLowThreshold to 255.

Remarks

The AutoBinarize method will set this value based on what it determined was the optimal setting for the image during the call. If you have similar images, you can call the Binarize method using this value as well as the other values set by the AutoBinarize method. This will be significantly faster than calling the AutoBinarize method for each image.

Note: This value is also set with the value that is passed into the Binarize method. If you call the Binarize method with some other value, this property will reflect that new value.

See Also

Reference

Processor Class
Processor Members


BinarizeLceFactor Property

BinarizeLceFactor Property

Accusoft.ImagXpressSdk Namespace > Processor Class : BinarizeLceFactor Property
Gets the local contrast enhancement factor set by AutoBinarize or Binarize.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("Gets the local contrast enhancement factor set by AutoBinarize or Binarize methods.")>
<BrowsableAttribute(False)>
Public ReadOnly Property BinarizeLceFactor As Integer
'Usage

Dim instance As Processor
Dim value As Integer

value = instance.BinarizeLceFactor
[Description("Gets the local contrast enhancement factor set by AutoBinarize or Binarize methods.")]
[Browsable(false)]
public int BinarizeLceFactor {get;}
[Description("Gets the local contrast enhancement factor set by AutoBinarize or Binarize methods.")]
[Browsable(false)]
public: __property int get_BinarizeLceFactor();
[Description("Gets the local contrast enhancement factor set by AutoBinarize or Binarize methods.")]
[Browsable(false)]
public:
property int BinarizeLceFactor {
   int get();
}

Property Value

An integer value which represents the local contrast enhancement.

The range is from 0 to 255. A setting of 0 for this value means local contrast enhancement was not performed.

Values from 1 to 255 control the sensitivity of local contrast enhancement to faint features; lower values yield less sensitivity.

This pre-processing operation increases the contrast in each region of the image. When used as a prelude to binarization, usually by setting Mode = QuickText, it increases the sensitivity of the binarization to detail in all regions of the image.

Remarks

The AutoBinarize method will set this value based on what it determined was the optimal setting for the image during the call. If you have similar images, you can call the Binarize method using this value as well as the other values set by the AutoBinarize method. This will be significantly faster than calling the AutoBinarize method for each image.

Note: This value is also set with the value that is passed into the Binarize method. If you call the Binarize method with some other value, this property will reflect that new value.

See Also

Reference

Processor Class
Processor Members


BinarizeLowThreshold Property

BinarizeLowThreshold Property

Accusoft.ImagXpressSdk Namespace > Processor Class : BinarizeLowThreshold Property
Gets the low threshold value set by AutoBinarize or Binarize.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("Gets the low threshold value set by the AutoBinarize or Binarize methods.")>
<BrowsableAttribute(False)>
Public ReadOnly Property BinarizeLowThreshold As Integer
'Usage

Dim instance As Processor
Dim value As Integer

value = instance.BinarizeLowThreshold
[Description("Gets the low threshold value set by the AutoBinarize or Binarize methods.")]
[Browsable(false)]
public int BinarizeLowThreshold {get;}
[Description("Gets the low threshold value set by the AutoBinarize or Binarize methods.")]
[Browsable(false)]
public: __property int get_BinarizeLowThreshold();
[Description("Gets the low threshold value set by the AutoBinarize or Binarize methods.")]
[Browsable(false)]
public:
property int BinarizeLowThreshold {
   int get();
}

Property Value

The integer value which represents the low threshold which controls background sensitivity.

The range is from 0 to 255.

Remarks

The AutoBinarize method will set this value based on what it determined was the optimal setting for the image during the call. If you have similar images, you can call the Binarize method using this value as well as the other values set by the AutoBinarize method. This will be significantly faster than calling the AutoBinarize method for each image.

Note: This value is also set with the value that is passed into the Binarize method. If you call the Binarize method with some other value, this property will reflect that new value.

See Also

Reference

Processor Class
Processor Members


BinarizeMode Property

BinarizeMode Property

Accusoft.ImagXpressSdk Namespace > Processor Class : BinarizeMode Property
Gets the BinarizeMode value set by AutoBinarize or Binarize.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DescriptionAttribute("Gets the binarize mode used in AutoBinarize or Binarize.")>
Public ReadOnly Property BinarizeMode As BinarizeMode
'Usage

Dim instance As Processor
Dim value As BinarizeMode

value = instance.BinarizeMode
[Browsable(false)]
[Description("Gets the binarize mode used in AutoBinarize or Binarize.")]
public BinarizeMode BinarizeMode {get;}
[Browsable(false)]
[Description("Gets the binarize mode used in AutoBinarize or Binarize.")]
public: __property BinarizeMode get_BinarizeMode();
[Browsable(false)]
[Description("Gets the binarize mode used in AutoBinarize or Binarize.")]
public:
property BinarizeMode BinarizeMode {
   BinarizeMode get();
}

Property Value

The BinarizeMode which represents the mode that the AutoBinarize or Binarize methods used to binarize the image.
Remarks

The AutoBinarize method will set this value based on what it determined was the optimal setting for the image during the call. If you have similar images, you can call the Binarize method using this value as well as the other values set by the AutoBinarize method. This will be significantly faster than calling the AutoBinarize method for each image.

Note: This value is also set with the value that is passed into the Binarize method. If you call the Binarize method with some other value, this property will reflect that new value.

See Also

Reference

Processor Class
Processor Members


BlankPageDetected Property

BlankPageDetected Property

Accusoft.ImagXpressSdk Namespace > Processor Class : BlankPageDetected Property
Gets an indicator if a blank page is detected.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public ReadOnly Property BlankPageDetected As Boolean
'Usage

Dim instance As Processor
Dim value As Boolean

value = instance.BlankPageDetected
[Browsable(false)]
public bool BlankPageDetected {get;}
[Browsable(false)]
public: __property bool get_BlankPageDetected();
[Browsable(false)]
public:
property bool BlankPageDetected {
   bool get();
}

Property Value

A boolean value which is true if a blank page is detected. Otherwise, false is returned.
Remarks

When no object exceeding the size threshold is encountered on the page, BlankPageDetected is set to true to indicate the page is "blank". Low Confidence values on a "blank" determination indicate a significant number of objects near, but below the size threshold.

When an object exceeding the size threshold is encountered on the page, BlankPageDetected is set to false to indicate the page is "not blank". Low Confidence values on a "not blank" determination indicate a low number of objects over the size threshold.

Note: Use this property for documents only.

Note: Available in Professional edition.

See Also

Reference

Processor Class
Processor Members


Confidence Property (Processor)

Confidence Property (Processor)

Accusoft.ImagXpressSdk Namespace > Processor Class : Confidence Property
Gets the confidence.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public ReadOnly Property Confidence As Short
'Usage

Dim instance As Processor
Dim value As Short

value = instance.Confidence
[Browsable(false)]
public short Confidence {get;}
[Browsable(false)]
public: __property short get_Confidence();
[Browsable(false)]
public:
property short Confidence {
   short get();
}

Property Value

An int16 which represents the confidence value.
Remarks

This property provides confidence levels from 1 to 100 of success of the operation.

Set by using the DocumentDeskew, DocumentBlankPageDetect(Int32,Int32,Int32,Boolean), and DocumentBorderCrop(Boolean) methods.

Note: Use this property for documents only.

Note: Available in Professional edition.

See Also

Reference

Processor Class
Processor Members


ContrastMethod Property

ContrastMethod Property

Accusoft.ImagXpressSdk Namespace > Processor Class : ContrastMethod Property
Gets and sets the contrast method to use.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
<DescriptionAttribute("Gets and sets the contrast method to use.")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)>
<BrowsableAttribute(True)>
Public Property ContrastMethod As ContrastMethod
'Usage

Dim instance As Processor
Dim value As ContrastMethod

instance.ContrastMethod = value

value = instance.ContrastMethod
[DefaultValue()]
[Description("Gets and sets the contrast method to use.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
[Browsable(true)]
public ContrastMethod ContrastMethod {get; set;}
[DefaultValue()]
[Description("Gets and sets the contrast method to use.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
[Browsable(true)]
public: __property ContrastMethod get_ContrastMethod();
public: __property void set_ContrastMethod(
   ContrastMethod value
);
[DefaultValue()]
[Description("Gets and sets the contrast method to use.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
[Browsable(true)]
public:
property ContrastMethod ContrastMethod {
   ContrastMethod get();
   void set (    ContrastMethod value);
}

Property Value

A ContrastMethod value which determines the method of contrast for the current image.
Remarks

The default value is ContrastMethod.DefaultContrast.

If this property is set to ViewCompatibleContrast, then the ImageXView.Contrast property is invoked. This ensures backward compatibility with existing users. It also allows the application to get and save the same image in the viewer when contrast is applied.

See Also

Reference

Processor Class
Processor Members


CountOfLinesFound Property

CountOfLinesFound Property

Accusoft.ImagXpressSdk Namespace > Processor Class : CountOfLinesFound Property
Gets the number of lines found.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public ReadOnly Property CountOfLinesFound As Integer
'Usage

Dim instance As Processor
Dim value As Integer

value = instance.CountOfLinesFound
[Browsable(false)]
public int CountOfLinesFound {get;}
[Browsable(false)]
public: __property int get_CountOfLinesFound();
[Browsable(false)]
public:
property int CountOfLinesFound {
   int get();
}

Property Value

An integer value which represents the number of lines found.
Remarks

Note: Available in Professional edition.

See Also

Reference

Processor Class
Processor Members


CountOfObjectsFound Property

CountOfObjectsFound Property

Accusoft.ImagXpressSdk Namespace > Processor Class : CountOfObjectsFound Property
Gets the number of objects found.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public ReadOnly Property CountOfObjectsFound As Integer
'Usage

Dim instance As Processor
Dim value As Integer

value = instance.CountOfObjectsFound
[Browsable(false)]
public int CountOfObjectsFound {get;}
[Browsable(false)]
public: __property int get_CountOfObjectsFound();
[Browsable(false)]
public:
property int CountOfObjectsFound {
   int get();
}

Property Value

An integer value which represents the number of objects found.
Remarks

Note: Available in Professional edition.

See Also

Reference

Processor Class
Processor Members


CountOfSpecsFound Property

CountOfSpecsFound Property

Accusoft.ImagXpressSdk Namespace > Processor Class : CountOfSpecsFound Property
Gets the number of specs found.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public ReadOnly Property CountOfSpecsFound As Integer
'Usage

Dim instance As Processor
Dim value As Integer

value = instance.CountOfSpecsFound
[Browsable(false)]
public int CountOfSpecsFound {get;}
[Browsable(false)]
public: __property int get_CountOfSpecsFound();
[Browsable(false)]
public:
property int CountOfSpecsFound {
   int get();
}

Property Value

An integer value which represents the number of specs found.
Remarks

A speck is a small dot, mark or discoloration on an image.

Note: Use this property for documents only.

Note: Available in Professional edition.

See Also

Reference

Processor Class
Processor Members


EnableArea Property

EnableArea Property

Accusoft.ImagXpressSdk Namespace > Processor Class : EnableArea Property
Gets and sets whether the area is enabled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
<BrowsableAttribute(False)>
<DescriptionAttribute("Gets and sets whether the area is enabled.")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property EnableArea As Boolean
'Usage

Dim instance As Processor
Dim value As Boolean

instance.EnableArea = value

value = instance.EnableArea
[DefaultValue()]
[Browsable(false)]
[Description("Gets and sets whether the area is enabled.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
public bool EnableArea {get; set;}
[DefaultValue()]
[Browsable(false)]
[Description("Gets and sets whether the area is enabled.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
public: __property bool get_EnableArea();
public: __property void set_EnableArea(
   bool value
);
[DefaultValue()]
[Browsable(false)]
[Description("Gets and sets whether the area is enabled.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
public:
property bool EnableArea {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true to enable to the area. Otherwise, false should be used.
Remarks

There are two ways to specify a portion of the image to process: Region or Area.

There can only be one region, and one area specified per processor.

When EnableRegion is set to true, and a region has been defined using this method, all image processing actions apply to the region only.

When EnableArea has been set to true, and an area is defined using SetArea, all image processing actions apply to the area only.

When both a region and an area have been enabled and defined, image processing actions apply to whichever was most recently set.

When neither a region nor an area have been enabled and defined, image processing actions are applied to the entire image.

See Also

Reference

Processor Class
Processor Members


EnableRegion Property

EnableRegion Property

Accusoft.ImagXpressSdk Namespace > Processor Class : EnableRegion Property
Gets and sets whether the region is enabled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
<BrowsableAttribute(False)>
<DescriptionAttribute("Gets and sets whether the region is enabled.")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property EnableRegion As Boolean
'Usage

Dim instance As Processor
Dim value As Boolean

instance.EnableRegion = value

value = instance.EnableRegion
[DefaultValue()]
[Browsable(false)]
[Description("Gets and sets whether the region is enabled.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
public bool EnableRegion {get; set;}
[DefaultValue()]
[Browsable(false)]
[Description("Gets and sets whether the region is enabled.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
public: __property bool get_EnableRegion();
public: __property void set_EnableRegion(
   bool value
);
[DefaultValue()]
[Browsable(false)]
[Description("Gets and sets whether the region is enabled.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
public:
property bool EnableRegion {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true to enable to the region. Otherwise, false should be used.
Remarks

There are two ways to specify a portion of the image to process: Region or Area.

There can only be one region, and one area specified per processor.

When EnableRegion is set to true, and a region has been defined using this method, all image processing actions apply to the region only.

When EnableArea has been set to true, and an area is defined using SetArea, all image processing actions apply to the area only.

When both a region and an area have been enabled and defined, image processing actions apply to whichever was most recently set.

When neither a region nor an area have been enabled and defined, image processing actions are applied to the entire image.

See Also

Reference

Processor Class
Processor Members


Image Property (Processor)

Image Property (Processor)

Accusoft.ImagXpressSdk Namespace > Processor Class : Image Property
Gets and sets the image to be processed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
Public Property Image As ImageX
'Usage

Dim instance As Processor
Dim value As ImageX

instance.Image = value

value = instance.Image
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Browsable(false)]
public ImageX Image {get; set;}
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Browsable(false)]
public: __property ImageX* get_Image();
public: __property void set_Image(
   ImageX* value
);
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Browsable(false)]
public:
property ImageX^ Image {
   ImageX^ get();
   void set (    ImageX^ value);
}

Property Value

An ImageX object.
Remarks
Note: Disposing of the Processor object does not dispose of its Image property. The Image must be explicitly disposed if it has been assigned a new ImageX object otherwise memory will leak.
See Also

Reference

Processor Class
Processor Members


ImageWasModified Property

ImageWasModified Property

Accusoft.ImagXpressSdk Namespace > Processor Class : ImageWasModified Property
Gets an indicator if the image was modified.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public ReadOnly Property ImageWasModified As Boolean
'Usage

Dim instance As Processor
Dim value As Boolean

value = instance.ImageWasModified
[Browsable(false)]
public bool ImageWasModified {get;}
[Browsable(false)]
public: __property bool get_ImageWasModified();
[Browsable(false)]
public:
property bool ImageWasModified {
   bool get();
}

Property Value

A boolean value which is true if the image was modified. Otherwise, false is returned.
Remarks

Note: Use this method for documents only.

Note: Available in Professional edition.

See Also

Reference

Processor Class
Processor Members


LogPalette Property

LogPalette Property

Accusoft.ImagXpressSdk Namespace > Processor Class : LogPalette Property
Gets and sets the palette for use when the ColorDepth method is called.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("Gets and sets the palette for use when the ColorDepth method is called.")>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<DefaultValueAttribute()>
Public Property LogPalette As IntPtr
'Usage

Dim instance As Processor
Dim value As IntPtr

instance.LogPalette = value

value = instance.LogPalette
[Description("Gets and sets the palette for use when the ColorDepth method is called.")]
[Browsable(false)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[DefaultValue()]
public IntPtr LogPalette {get; set;}
[Description("Gets and sets the palette for use when the ColorDepth method is called.")]
[Browsable(false)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[DefaultValue()]
public: __property IntPtr get_LogPalette();
public: __property void set_LogPalette(
   IntPtr value
);
[Description("Gets and sets the palette for use when the ColorDepth method is called.")]
[Browsable(false)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[DefaultValue()]
public:
property IntPtr LogPalette {
   IntPtr get();
   void set (    IntPtr value);
}

Property Value

An integer pointer which represents the log palette.
Remarks

When the ColorDepth method is called with paletteType = UserDefined, or PalFile, this property is used to display the image.

See Also

Reference

Processor Class
Processor Members


ProgressPercent Property (Processor)

ProgressPercent Property (Processor)

Accusoft.ImagXpressSdk Namespace > Processor Class : ProgressPercent Property
Gets and sets the ProgressEvent frequency.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)>
<BrowsableAttribute(True)>
<DescriptionAttribute("Gets and sets the ProgressEvent frequency.")>
Public Property ProgressPercent As Integer
'Usage

Dim instance As Processor
Dim value As Integer

instance.ProgressPercent = value

value = instance.ProgressPercent
[DefaultValue()]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
[Browsable(true)]
[Description("Gets and sets the ProgressEvent frequency.")]
public int ProgressPercent {get; set;}
[DefaultValue()]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
[Browsable(true)]
[Description("Gets and sets the ProgressEvent frequency.")]
public: __property int get_ProgressPercent();
public: __property void set_ProgressPercent(
   int value
);
[DefaultValue()]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Visible)]
[Browsable(true)]
[Description("Gets and sets the ProgressEvent frequency.")]
public:
property int ProgressPercent {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the frequency of the ProgressEvent event.

Remarks

Valid values are 1 to 100.

Lower values indicate more frequent events and higher value indicate less frequent events.

This property specifies the frequency at which the ProgressEvent fires and yields occur based on the percentage of completion of the load, save, or image processing operation.

For example; when this property is set to a value of 25, the control yields and issues a Progress event when the operation achieves:

  • 0 completion
  • at least 25 completion
  • at least 50 completion
  • at least 75 completion
  • and, at 100% completion

Depending upon the process ran, the Progress Event's pctDone parameter may start at a value other than zero, for example, one or two. And due to rounding errors, the increment may not be exactly the value of ProgressPct. For example, if ProgressPct is 10, the increments may be eleven or twelve.

See Also

Reference

Processor Class
Processor Members


Redeyes Property

Redeyes Property

Accusoft.ImagXpressSdk Namespace > Processor Class : Redeyes Property
Gets and sets the redeye collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property Redeyes As RedeyeCollection
'Usage

Dim instance As Processor
Dim value As RedeyeCollection

instance.Redeyes = value

value = instance.Redeyes
[Browsable(false)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
public RedeyeCollection Redeyes {get; set;}
[Browsable(false)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
public: __property RedeyeCollection* get_Redeyes();
public: __property void set_Redeyes(
   RedeyeCollection* value
);
[Browsable(false)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
public:
property RedeyeCollection^ Redeyes {
   RedeyeCollection^ get();
   void set (    RedeyeCollection^ value);
}

Property Value

The RedeyeCollection which contains redeye information.
Remarks

The AutoRemoveRedeye method detects and corrects red eyes within the image. One rectangle and corresponding correction information is generated for each corrected eye, and the collection of this information is stored in this property.

Note: This property is generally called after calling AutoRemoveRedeye.

Note: Available in Professional edition.

See Also

Reference

Processor Class
Processor Members


RotationAngle Property

RotationAngle Property

Accusoft.ImagXpressSdk Namespace > Processor Class : RotationAngle Property
Gets the rotation angle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public ReadOnly Property RotationAngle As Double
'Usage

Dim instance As Processor
Dim value As Double

value = instance.RotationAngle
[Browsable(false)]
public double RotationAngle {get;}
[Browsable(false)]
public: __property double get_RotationAngle();
[Browsable(false)]
public:
property double RotationAngle {
   double get();
}

Property Value

A double value which represents the rotation angle to get.
Remarks

Valid values are between -20 and 20.

Note: This property may be set to a value other than 0, even if the image is not modified. The image may not be modified if the detection Confidence property is less than minimum, or if the rotation angle is less than or equal to the minimum acceptable angle.

This property stores the angle of rotation required to correct skew using the DocumentDeskew method.

Note: Available in Professional edition.

See Also

Reference

Processor Class
Processor Members


Site Property

Site Property

Accusoft.ImagXpressSdk Namespace > Processor Class : Site Property
Gets and sets the System.ComponentModel.ISite of the Processor.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Site As ISite
'Usage

Dim instance As Processor
Dim value As ISite

instance.Site = value

value = instance.Site
public override ISite Site {get; set;}
public: __property ISite* get_Site() override;
public: __property void set_Site(
   ISite* value
) override;
public:
property ISite^ Site {
   ISite^ get() override;
   void set (    ISite^ value) override;
}

Property Value

The System.ComponentModel.ISite associated with the System.ComponentModel.Component, or null if the System.ComponentModel.Component is not encapsulated in an System.ComponentModel.IContainer, the System.ComponentModel.Component does not have an System.ComponentModel.ISite associated with it, or the System.ComponentModel.Component is removed from its System.ComponentModel.IContainer.
See Also

Reference

Processor Class
Processor Members


Variation Property

Variation Property

Accusoft.ImagXpressSdk Namespace > Processor Class : Variation Property
Gets the variation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public ReadOnly Property Variation As Short
'Usage

Dim instance As Processor
Dim value As Short

value = instance.Variation
[Browsable(false)]
public short Variation {get;}
[Browsable(false)]
public: __property short get_Variation();
[Browsable(false)]
public:
property short Variation {
   short get();
}

Property Value

An int16 value which represents the variation.
Remarks

Valid values are between 0 and 100.

Sets this property using the DocumentDeskew method.

Higher values indicate greater skew variation. This value is typically high if the horizontal and vertical skews do not match or if different parts of the image are skewed by different amounts.

Note: Use this property for documents only.

Note: Available in Professional edition.

See Also

Reference

Processor Class
Processor Members


Workspace Property (Processor)

Workspace Property (Processor)

Accusoft.ImagXpressSdk Namespace > Processor Class : Workspace Property
Gets or sets the ImagXpress workspace component.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DescriptionAttribute("Gets or sets the ImagXpress workspace component.")>
<DefaultValueAttribute()>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property Workspace As ImagXpress
'Usage

Dim instance As Processor
Dim value As ImagXpress

instance.Workspace = value

value = instance.Workspace
[Browsable(false)]
[Description("Gets or sets the ImagXpress workspace component.")]
[DefaultValue()]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
public ImagXpress Workspace {get; set;}
[Browsable(false)]
[Description("Gets or sets the ImagXpress workspace component.")]
[DefaultValue()]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
public: __property ImagXpress* get_Workspace();
public: __property void set_Workspace(
   ImagXpress* value
);
[Browsable(false)]
[Description("Gets or sets the ImagXpress workspace component.")]
[DefaultValue()]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
public:
property ImagXpress^ Workspace {
   ImagXpress^ get();
   void set (    ImagXpress^ value);
}

Property Value

The instance of the ImagXpress workspace component that the ImageXView control is tied to. This is the main ImagXpress component that typically must be dragged onto a form first.
Remarks

This property can only be set if the value is null. Once the Processor component has a ImagXpress workspace, it can NOT be changed.

This property only needs to be set if you use the Processor component in a WPF (Windows Presentation Framework) project or dynamically create an Processor instance with the default constructor. This property should NOT need to be set in any other instance. If the property already has a valid ImagXpress workspace because it has been set once before or the control was created through one of the other constructors setting this property will have no effect. Once a Processor has been set with its ImagXpress workspace it can NOT be changed to another ImagXpress workspace component.

Note: Failure to set this property with a valid ImagXpress workspace component when it is null as described above will cause the component throw an exception on a call to one of its methods.

See Also

Reference

Processor Class
Processor Members


Processor Class Events

Processor Class Events

Accusoft.ImagXpressSdk Namespace : Processor Class

For a list of all members of this type, see Processor members.

Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | ProgressEvent | Notifies a change in progress status.
Top
See Also

Reference

Processor Class
Accusoft.ImagXpressSdk Namespace


ProgressEvent Event (Processor)

ProgressEvent Event (Processor)

Accusoft.ImagXpressSdk Namespace > Processor Class : ProgressEvent Event
Notifies a change in progress status.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event ProgressEvent As Processor.ProgressEventHandler
'Usage

Dim instance As Processor
Dim handler As Processor.ProgressEventHandler

AddHandler instance.ProgressEvent, handler
public event Processor.ProgressEventHandler ProgressEvent
public: __event Processor.ProgressEventHandler* ProgressEvent
public:
event Processor.ProgressEventHandler^ ProgressEvent
Event Data

The event handler receives an argument of type ProgressEventArgs containing data related to this event. The following ProgressEventArgs properties provide information specific to this event.

Property | Description
BytesProcessed | Gets the count of bytes processed.
Image | Gets the image for the event.
IsAsync | Gets an indicator whether subsequent image loading, processing or saving operations occur in a separate thread from the viewer control thread.
IsComplete | Gets an indicator whether the image processing is complete.
Operation | Gets the operation method being performed.
PercentDone | Gets the percentage complete value of the current image operation.
Result | Gets the result of the progress event.
TotalBytes | Gets the total bytes processed.
See Also

Reference

Processor Class
Processor Members


ProcessorException Class

ProcessorException Class
Members

Accusoft.ImagXpressSdk Namespace : ProcessorException Class
This class implements exceptions for the Processor objects.
Object Model
ProcessorException Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class ProcessorException
   Inherits ImagXpressException
'Usage

Dim instance As ProcessorException
[Serializable()]
public sealed class ProcessorException : ImagXpressException
[Serializable()]
public __gc __sealed class ProcessorException : public ImagXpressException
[Serializable()]
public ref class ProcessorException sealed : public ImagXpressException
Inheritance Hierarchy

System.Object
System.Exception
Accusoft.ImagXpressSdk.ImagXpressException
Accusoft.ImagXpressSdk.ProcessorException

See Also

Reference

ProcessorException Members
Accusoft.ImagXpressSdk Namespace


ProcessorException Class Members

ProcessorException Class Members
Properties Methods

Accusoft.ImagXpressSdk Namespace : ProcessorException Class

The following tables list the members exposed by ProcessorException.

Public Constructors
 | Name | Description
Public Constructor | ProcessorException Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Number | Gets the numerical equivalent for enumerated exception result. (Inherited from Accusoft.ImagXpressSdk.ImagXpressException)
Public Property | Result | Gets the enumerated exception result that has occurred. (Inherited from Accusoft.ImagXpressSdk.ImagXpressException)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

ProcessorException Class
Accusoft.ImagXpressSdk Namespace


ProcessorException Class Properties

ProcessorException Class Properties

Accusoft.ImagXpressSdk Namespace : ProcessorException Class

For a list of all members of this type, see ProcessorException members.

Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Number | Gets the numerical equivalent for enumerated exception result. (Inherited from Accusoft.ImagXpressSdk.ImagXpressException)
Public Property | Result | Gets the enumerated exception result that has occurred. (Inherited from Accusoft.ImagXpressSdk.ImagXpressException)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
See Also

Reference

ProcessorException Class
Accusoft.ImagXpressSdk Namespace


ProcessorException Class Methods

ProcessorException Class Methods

Accusoft.ImagXpressSdk Namespace : ProcessorException Class

For a list of all members of this type, see ProcessorException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

ProcessorException Class
Accusoft.ImagXpressSdk Namespace


ProcessorException Constructor

ProcessorException Constructor

Accusoft.ImagXpressSdk Namespace > ProcessorException Class : ProcessorException Constructor
Overload List
Overload | Description
ProcessorException Constructor() | The main constructor for the ProcessorException class.
ProcessorException Constructor(Result) | Constructor which allows passing in a result for the exception.
ProcessorException Constructor(String) | Constructor which allows passing in a message for the exception.
ProcessorException Constructor(Result,String) | Constructor which allows passing in a result and message for the exception.
ProcessorException Constructor(String,Exception) | Constructor which allows passing in a message and inner exception.
ProcessorException Constructor(Result,String,Exception) | Constructor which allows passing in a result, message and inner exception.
See Also

Reference

ProcessorException Class
ProcessorException Members


ProcessorException Constructor()

ProcessorException Constructor()

Accusoft.ImagXpressSdk Namespace > ProcessorException Class > ProcessorException Constructor : ProcessorException Constructor()
The main constructor for the ProcessorException class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ProcessorException()
public ProcessorException()
public: ProcessorException();
public:
ProcessorException();
See Also

Reference

ProcessorException Class
ProcessorException Members
Overload List


ProcessorException Constructor(Result)

ProcessorException Constructor(Result)

Accusoft.ImagXpressSdk Namespace > ProcessorException Class > ProcessorException Constructor : ProcessorException Constructor(Result)
A Result enumeration value.
Constructor which allows passing in a result for the exception.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal result As Result _
)
'Usage

Dim result As Result

Dim instance As New ProcessorException(result)
public ProcessorException(
   Result result
)
public: ProcessorException(
   Result result
)
public:
ProcessorException(
   Result result
)

Parameters

result
A Result enumeration value.
See Also

Reference

ProcessorException Class
ProcessorException Members
Overload List


ProcessorException Constructor(String)

ProcessorException Constructor(String)

Accusoft.ImagXpressSdk Namespace > ProcessorException Class > ProcessorException Constructor : ProcessorException Constructor(String)
A string value which represents the message.
Constructor which allows passing in a message for the exception.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New ProcessorException(message)
public ProcessorException(
   string message
)
public: ProcessorException(
   string* message
)
public:
ProcessorException(
   String^ message
)

Parameters

message
A string value which represents the message.
See Also

Reference

ProcessorException Class
ProcessorException Members
Overload List


ProcessorException Constructor(Result,String)

ProcessorException Constructor(Result,String)

Accusoft.ImagXpressSdk Namespace > ProcessorException Class > ProcessorException Constructor : ProcessorException Constructor(Result,String)
A Result enumeration value.
A string value which represents the message.
Constructor which allows passing in a result and message for the exception.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal result As Result, _
   ByVal message As String _
)
'Usage

Dim result As Result
Dim message As String

Dim instance As New ProcessorException(result, message)
public ProcessorException(
   Result result,
   string message
)
public: ProcessorException(
   Result result,
   string* message
)
public:
ProcessorException(
   Result result,
   String^ message
)

Parameters

result
A Result enumeration value.
message
A string value which represents the message.
See Also

Reference

ProcessorException Class
ProcessorException Members
Overload List


ProcessorException Constructor(String,Exception)

ProcessorException Constructor(String,Exception)

Accusoft.ImagXpressSdk Namespace > ProcessorException Class > ProcessorException Constructor : ProcessorException Constructor(String,Exception)
A string value which represents the error message.
An System.Exception.
Constructor which allows passing in a message and inner exception.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New ProcessorException(message, innerException)
public ProcessorException(
   string message,
   Exception innerException
)
public: ProcessorException(
   string* message,
   Exception* innerException
)
public:
ProcessorException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string value which represents the error message.
innerException
An System.Exception.
See Also

Reference

ProcessorException Class
ProcessorException Members
Overload List


ProcessorException Constructor(Result,String,Exception)

ProcessorException Constructor(Result,String,Exception)

Accusoft.ImagXpressSdk Namespace > ProcessorException Class > ProcessorException Constructor : ProcessorException Constructor(Result,String,Exception)
A Result enumeration value.
A string value which represents the error message.
An System.Exception.
Constructor which allows passing in a result, message and inner exception.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal result As Result, _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim result As Result
Dim message As String
Dim innerException As Exception

Dim instance As New ProcessorException(result, message, innerException)
public ProcessorException(
   Result result,
   string message,
   Exception innerException
)
public: ProcessorException(
   Result result,
   string* message,
   Exception* innerException
)
public:
ProcessorException(
   Result result,
   String^ message,
   Exception^ innerException
)

Parameters

result
A Result enumeration value.
message
A string value which represents the error message.
innerException
An System.Exception.
See Also

Reference

ProcessorException Class
ProcessorException Members
Overload List


ProgressEventArgs Class

ProgressEventArgs Class
Members

Accusoft.ImagXpressSdk Namespace : ProgressEventArgs Class
This class implements methods and properties for the progress events.
Object Model
ProgressEventArgs ClassImageX ClassImageX ClassImageCalsCollection ClassImageCalsTag ClassImageX ClassImageX ClassImageX ClassImageX ClassImageX ClassImageX ClassImageX ClassImageXData ClassImageXIptcCollection ClassImageXIptcData ClassLoadOptions ClassImageModcaCollection ClassImageModcaTag ClassImageXData ClassImageXData ClassImageXData ClassImageX ClassResolution ClassImageXTagCollection ClassImageXTag Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ProgressEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As ProgressEventArgs
public class ProgressEventArgs : System.EventArgs
public __gc class ProgressEventArgs : public System.EventArgs
public ref class ProgressEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
Accusoft.ImagXpressSdk.ProgressEventArgs

See Also

Reference

ProgressEventArgs Members
Accusoft.ImagXpressSdk Namespace


ProgressEventArgs Class Members

ProgressEventArgs Class Members
Properties

Accusoft.ImagXpressSdk Namespace : ProgressEventArgs Class

The following tables list the members exposed by ProgressEventArgs.

Public Constructors
 | Name | Description
Public Constructor | ProgressEventArgs Constructor | Initializes a new instance of the ProgressEventArgs object.
Top
Public Properties
 | Name | Description
Public Property | BytesProcessed | Gets the count of bytes processed.
Public Property | Image | Gets the image for the event.
Public Property | IsAsync | Gets an indicator whether subsequent image loading, processing or saving operations occur in a separate thread from the viewer control thread.
Public Property | IsComplete | Gets an indicator whether the image processing is complete.
Public Property | Operation | Gets the operation method being performed.
Public Property | PercentDone | Gets the percentage complete value of the current image operation.
Public Property | Result | Gets the result of the progress event.
Public Property | TotalBytes | Gets the total bytes processed.
Top
See Also

Reference

ProgressEventArgs Class
Accusoft.ImagXpressSdk Namespace


ProgressEventArgs Constructor

ProgressEventArgs Constructor

Accusoft.ImagXpressSdk Namespace > ProgressEventArgs Class : ProgressEventArgs Constructor
Initializes a new instance of the ProgressEventArgs object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ProgressEventArgs()
public ProgressEventArgs()
public: ProgressEventArgs();
public:
ProgressEventArgs();
See Also

Reference

ProgressEventArgs Class
ProgressEventArgs Members


ProgressEventArgs Class Properties

ProgressEventArgs Class Properties

Accusoft.ImagXpressSdk Namespace : ProgressEventArgs Class

For a list of all members of this type, see ProgressEventArgs members.

Public Properties
 | Name | Description
Public Property | BytesProcessed | Gets the count of bytes processed.
Public Property | Image | Gets the image for the event.
Public Property | IsAsync | Gets an indicator whether subsequent image loading, processing or saving operations occur in a separate thread from the viewer control thread.
Public Property | IsComplete | Gets an indicator whether the image processing is complete.
Public Property | Operation | Gets the operation method being performed.
Public Property | PercentDone | Gets the percentage complete value of the current image operation.
Public Property | Result | Gets the result of the progress event.
Public Property | TotalBytes | Gets the total bytes processed.
Top
See Also

Reference

ProgressEventArgs Class
Accusoft.ImagXpressSdk Namespace


ProgressEventArgs Constructor

ProgressEventArgs Constructor

Accusoft.ImagXpressSdk Namespace > ProgressEventArgs Class : ProgressEventArgs Constructor
Overload List
Overload | Description
ProgressEventArgs Constructor | Initializes a new instance of the ProgressEventArgs object.
See Also

Reference

ProgressEventArgs Class
ProgressEventArgs Members


BytesProcessed Property

BytesProcessed Property

Accusoft.ImagXpressSdk Namespace > ProgressEventArgs Class : BytesProcessed Property
Gets the count of bytes processed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property BytesProcessed As Integer
'Usage

Dim instance As ProgressEventArgs
Dim value As Integer

value = instance.BytesProcessed
public int BytesProcessed {get;}
public: __property int get_BytesProcessed();
public:
property int BytesProcessed {
   int get();
}

Property Value

An integer value which represents the number of bytes processed in the uncompressed image.
See Also

Reference

ProgressEventArgs Class
ProgressEventArgs Members


Image Property (ProgressEventArgs)

Image Property (ProgressEventArgs)

Accusoft.ImagXpressSdk Namespace > ProgressEventArgs Class : Image Property
Gets the image for the event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Image As ImageX
'Usage

Dim instance As ProgressEventArgs
Dim value As ImageX

value = instance.Image
public ImageX Image {get;}
public: __property ImageX* get_Image();
public:
property ImageX^ Image {
   ImageX^ get();
}

Property Value

The image the event was returned for.
See Also

Reference

ProgressEventArgs Class
ProgressEventArgs Members


IsAsync Property

IsAsync Property

Accusoft.ImagXpressSdk Namespace > ProgressEventArgs Class : IsAsync Property
Gets an indicator whether subsequent image loading, processing or saving operations occur in a separate thread from the viewer control thread.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property IsAsync As Boolean
'Usage

Dim instance As ProgressEventArgs
Dim value As Boolean

value = instance.IsAsync
public bool IsAsync {get;}
public: __property bool get_IsAsync();
public:
property bool IsAsync {
   bool get();
}

Property Value

A boolean value which is true if separate threads are used. Otherwise, false is returned.
Remarks

The default value is false.

See Also

Reference

ProgressEventArgs Class
ProgressEventArgs Members


IsComplete Property

IsComplete Property

Accusoft.ImagXpressSdk Namespace > ProgressEventArgs Class : IsComplete Property
Gets an indicator whether the image processing is complete.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property IsComplete As Boolean
'Usage

Dim instance As ProgressEventArgs
Dim value As Boolean

value = instance.IsComplete
public bool IsComplete {get;}
public: __property bool get_IsComplete();
public:
property bool IsComplete {
   bool get();
}

Property Value

A boolean value which is true if the image is complete with processing. Otherwise, false is returned.
See Also

Reference

ProgressEventArgs Class
ProgressEventArgs Members


Operation Property (ProgressEventArgs)

Operation Property (ProgressEventArgs)

Accusoft.ImagXpressSdk Namespace > ProgressEventArgs Class : Operation Property
Gets the operation method being performed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Operation As Operation
'Usage

Dim instance As ProgressEventArgs
Dim value As Operation

value = instance.Operation
public Operation Operation {get;}
public: __property Operation get_Operation();
public:
property Operation Operation {
   Operation get();
}

Property Value

A Operation enumeration value which determines the type of operation being performed.
See Also

Reference

ProgressEventArgs Class
ProgressEventArgs Members


PercentDone Property

PercentDone Property

Accusoft.ImagXpressSdk Namespace > ProgressEventArgs Class : PercentDone Property
Gets the percentage complete value of the current image operation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property PercentDone As Integer
'Usage

Dim instance As ProgressEventArgs
Dim value As Integer

value = instance.PercentDone
public int PercentDone {get;}
public: __property int get_PercentDone();
public:
property int PercentDone {
   int get();
}

Property Value

An integer value which represents the percentage done.
See Also

Reference

ProgressEventArgs Class
ProgressEventArgs Members


Result Property (ProgressEventArgs)

Result Property (ProgressEventArgs)

Accusoft.ImagXpressSdk Namespace > ProgressEventArgs Class : Result Property
Gets the result of the progress event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Result As Integer
'Usage

Dim instance As ProgressEventArgs
Dim value As Integer

value = instance.Result
public int Result {get;}
public: __property int get_Result();
public:
property int Result {
   int get();
}

Property Value

An integer value which represents the event info error result.
See Also

Reference

ProgressEventArgs Class
ProgressEventArgs Members


TotalBytes Property

TotalBytes Property

Accusoft.ImagXpressSdk Namespace > ProgressEventArgs Class : TotalBytes Property
Gets the total bytes processed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property TotalBytes As Integer
'Usage

Dim instance As ProgressEventArgs
Dim value As Integer

value = instance.TotalBytes
public int TotalBytes {get;}
public: __property int get_TotalBytes();
public:
property int TotalBytes {
   int get();
}

Property Value

An integer value which represents the total number of bytes processed in the uncompressed image.
See Also

Reference

ProgressEventArgs Class
ProgressEventArgs Members


RedeyeCollection Class

RedeyeCollection Class
Members

Accusoft.ImagXpressSdk Namespace : RedeyeCollection Class
Summary description for RedeyeCollection.
Object Model
RedeyeCollection ClassRedeyeRectangle Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultMemberAttribute("Item")>
Public Class RedeyeCollection
   Inherits System.Collections.CollectionBase
'Usage

Dim instance As RedeyeCollection
[DefaultMember("Item")]
public class RedeyeCollection : System.Collections.CollectionBase
[DefaultMember("Item")]
public __gc class RedeyeCollection : public System.Collections.CollectionBase
[DefaultMember("Item")]
public ref class RedeyeCollection : public System.Collections.CollectionBase
Remarks

Note: Available in Professional edition.

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Accusoft.ImagXpressSdk.RedeyeCollection

See Also

Reference

RedeyeCollection Members
Accusoft.ImagXpressSdk Namespace


RedeyeCollection Class Members

RedeyeCollection Class Members
Properties Methods

Accusoft.ImagXpressSdk Namespace : RedeyeCollection Class

The following tables list the members exposed by RedeyeCollection.

Public Constructors
 | Name | Description
Public Constructor | RedeyeCollection Constructor | Initializes a new instance of the RedeyeCollection class.
Top
Public Properties
 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets the RedeyeRectangle at the specified index.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds the specified rectangle item.
Public Method | Clear | Clears the entire collection as well as calls the Clear function of the base class.
Public Method | Contains | Determines if the collection contains this RedeyeRectangle.
Public Method | CopyTo | Copies the entire collection to an array, starting at index of the target array.
Public Method | Dispose | Releases all resources used by this Accusoft.ImagXpressSdk.RedeyeCollection object.
Public Method | GetEnumerator | (Inherited from System.Collections.CollectionBase)
Public Method | GetRedeyeRectangle | Gets the redeye rectangle.
Public Method | IndexOf | Searches for the specified Object and returns the zero-based index of the first occurrence within the entire PageCollection.
Public Method | Insert | Inserts a RedeyeRectangle at the specified index.
Public Method | Remove | Removes the RedeyeRectangle from the collection.
Public Method | RemoveAt | Remove operation for the RedeyeRectangle collection. Call the RedeyeRectangle destructor to free the RedeyeRectangle then remove the RedeyeRectangle from the collection.
Public Method | RemoveRectangle | Removes the redeye rectangle.
Top
See Also

Reference

RedeyeCollection Class
Accusoft.ImagXpressSdk Namespace


RedeyeCollection Constructor

RedeyeCollection Constructor

Accusoft.ImagXpressSdk Namespace > RedeyeCollection Class : RedeyeCollection Constructor
Initializes a new instance of the RedeyeCollection class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New RedeyeCollection()
public RedeyeCollection()
public: RedeyeCollection();
public:
RedeyeCollection();
See Also

Reference

RedeyeCollection Class
RedeyeCollection Members


RedeyeCollection Class Methods

RedeyeCollection Class Methods

Accusoft.ImagXpressSdk Namespace : RedeyeCollection Class

For a list of all members of this type, see RedeyeCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds the specified rectangle item.
Public Method | Clear | Clears the entire collection as well as calls the Clear function of the base class.
Public Method | Contains | Determines if the collection contains this RedeyeRectangle.
Public Method | CopyTo | Copies the entire collection to an array, starting at index of the target array.
Public Method | Dispose | Releases all resources used by this Accusoft.ImagXpressSdk.RedeyeCollection object.
Public Method | GetEnumerator | (Inherited from System.Collections.CollectionBase)
Public Method | GetRedeyeRectangle | Gets the redeye rectangle.
Public Method | IndexOf | Searches for the specified Object and returns the zero-based index of the first occurrence within the entire PageCollection.
Public Method | Insert | Inserts a RedeyeRectangle at the specified index.
Public Method | Remove | Removes the RedeyeRectangle from the collection.
Public Method | RemoveAt | Remove operation for the RedeyeRectangle collection. Call the RedeyeRectangle destructor to free the RedeyeRectangle then remove the RedeyeRectangle from the collection.
Public Method | RemoveRectangle | Removes the redeye rectangle.
Top
See Also

Reference

RedeyeCollection Class
Accusoft.ImagXpressSdk Namespace


Add Method (RedeyeCollection)

Add Method (RedeyeCollection)

Accusoft.ImagXpressSdk Namespace > RedeyeCollection Class : Add Method
The rectangle item.
Adds the specified rectangle item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Add( _
   ByVal rectangleItem As RedeyeRectangle _
) As Integer
'Usage

Dim instance As RedeyeCollection
Dim rectangleItem As RedeyeRectangle
Dim value As Integer

value = instance.Add(rectangleItem)
public int Add(
   RedeyeRectangle rectangleItem
)
public: int Add(
   RedeyeRectangle* rectangleItem
)
public:
int Add(
   RedeyeRectangle^ rectangleItem
)

Parameters

rectangleItem
The rectangle item.

Return Value

The index at which the value has been added.
Remarks

Note: Available in Professional edition.

See Also

Reference

RedeyeCollection Class
RedeyeCollection Members


Clear Method (RedeyeCollection)

Clear Method (RedeyeCollection)

Accusoft.ImagXpressSdk Namespace > RedeyeCollection Class : Clear Method
Clears the entire collection as well as calls the Clear function of the base class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shadows Sub Clear()
'Usage

Dim instance As RedeyeCollection

instance.Clear()
public new void Clear()
public: new void Clear();
public:
new void Clear();
See Also

Reference

RedeyeCollection Class
RedeyeCollection Members


Contains Method (RedeyeCollection)

Contains Method (RedeyeCollection)

Accusoft.ImagXpressSdk Namespace > RedeyeCollection Class : Contains Method
The RedeyeRectangle to locate.
Determines if the collection contains this RedeyeRectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Contains( _
   ByVal rectangleItem As RedeyeRectangle _
) As Boolean
'Usage

Dim instance As RedeyeCollection
Dim rectangleItem As RedeyeRectangle
Dim value As Boolean

value = instance.Contains(rectangleItem)
public bool Contains(
   RedeyeRectangle rectangleItem
)
public: bool Contains(
   RedeyeRectangle* rectangleItem
)
public:
bool Contains(
   RedeyeRectangle^ rectangleItem
)

Parameters

rectangleItem
The RedeyeRectangle to locate.

Return Value

true if the collection contains the specified RedeyeRectangle; otherwise, false. Implements
See Also

Reference

RedeyeCollection Class
RedeyeCollection Members


CopyTo Method (RedeyeCollection)

CopyTo Method (RedeyeCollection)

Accusoft.ImagXpressSdk Namespace > RedeyeCollection Class : CopyTo Method
The one-dimensional Array that is the destination of the elements copied from RedeyeRectangleCollection. The Array must have zero-based indexing.
The zero-based index in array at which copying begins.
Copies the entire collection to an array, starting at index of the target array.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub CopyTo( _
   ByVal array() As RedeyeRectangle, _
   ByVal index As Integer _
)
'Usage

Dim instance As RedeyeCollection
Dim array() As RedeyeRectangle
Dim index As Integer

instance.CopyTo(array, index)
public void CopyTo(
   RedeyeRectangle[] array,
   int index
)
public: void CopyTo(
   RedeyeRectangle*[]* array,
   int index
)
public:
void CopyTo(
   array<RedeyeRectangle^>^ array,
   int index
)

Parameters

array
The one-dimensional Array that is the destination of the elements copied from RedeyeRectangleCollection. The Array must have zero-based indexing.
index
The zero-based index in array at which copying begins.
See Also

Reference

RedeyeCollection Class
RedeyeCollection Members


Dispose Method (RedeyeCollection)

Dispose Method (RedeyeCollection)

Accusoft.ImagXpressSdk Namespace > RedeyeCollection Class : Dispose Method
Releases all resources used by this Accusoft.ImagXpressSdk.RedeyeCollection object.
Overload List
Overload | Description
Dispose | Releases all resources used by this Accusoft.ImagXpressSdk.RedeyeCollection object.
See Also

Reference

RedeyeCollection Class
RedeyeCollection Members


Dispose() Method

Dispose() Method

Accusoft.ImagXpressSdk Namespace > RedeyeCollection Class : Dispose() Method
Releases all resources used by this Accusoft.ImagXpressSdk.RedeyeCollection object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Dispose()
'Usage

Dim instance As RedeyeCollection

instance.Dispose()
public void Dispose()
public: void Dispose();
public:
void Dispose();
See Also

Reference

RedeyeCollection Class
RedeyeCollection Members


GetRedeyeRectangle Method

GetRedeyeRectangle Method

Accusoft.ImagXpressSdk Namespace > RedeyeCollection Class : GetRedeyeRectangle Method
The rectangle ID.
Gets the redeye rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetRedeyeRectangle( _
   ByVal rectangleID As Integer _
) As RedeyeRectangle
'Usage

Dim instance As RedeyeCollection
Dim rectangleID As Integer
Dim value As RedeyeRectangle

value = instance.GetRedeyeRectangle(rectangleID)
public RedeyeRectangle GetRedeyeRectangle(
   int rectangleID
)
public: RedeyeRectangle* GetRedeyeRectangle(
   int rectangleID
)
public:
RedeyeRectangle^ GetRedeyeRectangle(
   int rectangleID
)

Parameters

rectangleID
The rectangle ID.

Return Value

The redeye rectangle
Remarks

Note: Available in Professional edition.

See Also

Reference

RedeyeCollection Class
RedeyeCollection Members


IndexOf Method (RedeyeCollection)

IndexOf Method (RedeyeCollection)

Accusoft.ImagXpressSdk Namespace > RedeyeCollection Class : IndexOf Method
Object to locate in the collection.
Searches for the specified Object and returns the zero-based index of the first occurrence within the entire PageCollection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function IndexOf( _
   ByVal value As RedeyeRectangle _
) As Integer
'Usage

Dim instance As RedeyeCollection
Dim value As RedeyeRectangle
Dim value As Integer

value = instance.IndexOf(value)
public int IndexOf(
   RedeyeRectangle value
)
public: int IndexOf(
   RedeyeRectangle* value
)
public:
int IndexOf(
   RedeyeRectangle^ value
)

Parameters

value
Object to locate in the collection.
See Also

Reference

RedeyeCollection Class
RedeyeCollection Members


Insert Method (RedeyeCollection)

Insert Method (RedeyeCollection)

Accusoft.ImagXpressSdk Namespace > RedeyeCollection Class : Insert Method
The zero-based index at which the RedeyeRectangle should be inserted.
The RedeyeRectangle to be inserted.
Inserts a RedeyeRectangle at the specified index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Insert( _
   ByVal index As Integer, _
   ByVal rectangleItem As RedeyeRectangle _
)
'Usage

Dim instance As RedeyeCollection
Dim index As Integer
Dim rectangleItem As RedeyeRectangle

instance.Insert(index, rectangleItem)
public void Insert(
   int index,
   RedeyeRectangle rectangleItem
)
public: void Insert(
   int index,
   RedeyeRectangle* rectangleItem
)
public:
void Insert(
   int index,
   RedeyeRectangle^ rectangleItem
)

Parameters

index
The zero-based index at which the RedeyeRectangle should be inserted.
rectangleItem
The RedeyeRectangle to be inserted.
See Also

Reference

RedeyeCollection Class
RedeyeCollection Members


Remove Method (RedeyeCollection)

Remove Method (RedeyeCollection)

Accusoft.ImagXpressSdk Namespace > RedeyeCollection Class : Remove Method
The RedeyeRectangle to be removed.
Removes the RedeyeRectangle from the collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Remove( _
   ByVal rectangleItem As RedeyeRectangle _
)
'Usage

Dim instance As RedeyeCollection
Dim rectangleItem As RedeyeRectangle

instance.Remove(rectangleItem)
public void Remove(
   RedeyeRectangle rectangleItem
)
public: void Remove(
   RedeyeRectangle* rectangleItem
)
public:
void Remove(
   RedeyeRectangle^ rectangleItem
)

Parameters

rectangleItem
The RedeyeRectangle to be removed.
See Also

Reference

RedeyeCollection Class
RedeyeCollection Members


RemoveAt Method (RedeyeCollection)

RemoveAt Method (RedeyeCollection)

Accusoft.ImagXpressSdk Namespace > RedeyeCollection Class : RemoveAt Method
Remove operation for the RedeyeRectangle collection. Call the RedeyeRectangle destructor to free the RedeyeRectangle then remove the RedeyeRectangle from the collection.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shadows Sub RemoveAt( _
   ByVal index As Integer _
)
'Usage

Dim instance As RedeyeCollection
Dim index As Integer

instance.RemoveAt(index)
public new void RemoveAt(
   int index
)
public: new void RemoveAt(
   int index
)
public:
new void RemoveAt(
   int index
)

Parameters

index
See Also

Reference

RedeyeCollection Class
RedeyeCollection Members


RemoveRectangle Method

RemoveRectangle Method

Accusoft.ImagXpressSdk Namespace > RedeyeCollection Class : RemoveRectangle Method
The rectangle ID.
Removes the redeye rectangle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub RemoveRectangle( _
   ByVal rectangleID As Integer _
)
'Usage

Dim instance As RedeyeCollection
Dim rectangleID As Integer

instance.RemoveRectangle(rectangleID)
public void RemoveRectangle(
   int rectangleID
)
public: void RemoveRectangle(
   int rectangleID
)
public:
void RemoveRectangle(
   int rectangleID
)

Parameters

rectangleID
The rectangle ID.
Remarks

Note: Available in Professional edition.

See Also

Reference

RedeyeCollection Class
RedeyeCollection Members


RedeyeCollection Class Properties

RedeyeCollection Class Properties

Accusoft.ImagXpressSdk Namespace : RedeyeCollection Class

For a list of all members of this type, see RedeyeCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets the RedeyeRectangle at the specified index.
Top
See Also

Reference

RedeyeCollection Class
Accusoft.ImagXpressSdk Namespace


Item Property (RedeyeCollection)

Item Property (RedeyeCollection)

Accusoft.ImagXpressSdk Namespace > RedeyeCollection Class : Item Property
Gets or sets the RedeyeRectangle at the specified index.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Default Property Item( _
   ByVal index As Integer _
) As RedeyeRectangle
'Usage

Dim instance As RedeyeCollection
Dim index As Integer
Dim value As RedeyeRectangle

instance.Item(index) = value

value = instance.Item(index)
public RedeyeRectangle this[
   int index
]; {get; set;}
public: __property RedeyeRectangle* get_Item   int index
;
public: __property void set_Item   int index,
   RedeyeRectangle* value
;
public:
property RedeyeRectangle^ default [int] {
   RedeyeRectangle^ get(int index);
   void set (int index, RedeyeRectangle^ value);
}

Parameters

index
Remarks

Note: Available in Professional edition.

See Also

Reference

RedeyeCollection Class
RedeyeCollection Members


RedeyeRectangle Class

RedeyeRectangle Class
Members

Accusoft.ImagXpressSdk Namespace : RedeyeRectangle Class
Summary description for RedeyeRectangle. AutoRemoveRedeye generates rectangle areas of objects thought to be redeyes and have been corrected (red removed). Because some objects looking like redeyes but are not are identified and corrected (false positives) and some redeyes not looking like what they are and are not corrected (missed negatives), a list of rectangles is automatically generated. These rectangles are available to the user (application) for analysis and corrective action. The user can redo the correction by editing the rectangle list, reload the picture and apply the AutoRemoveRedeye method again but indicating the method to use the existing list. Each RedeyeRectangle has five members describing the area of the redeye found and the likelyhood that the object was correctly identified. The X and Y position indicate the top left corner of the rectangle and The Width and Height denote the rectangle dimensions. The Confidence parameter indicates how likely the area identified is indeed a redeye object.
Object Model
RedeyeRectangle Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class RedeyeRectangle
'Usage

Dim instance As RedeyeRectangle
public class RedeyeRectangle
public __gc class RedeyeRectangle
public ref class RedeyeRectangle
Remarks

Note: Available in Professional edition.

Inheritance Hierarchy

System.Object
Accusoft.ImagXpressSdk.RedeyeRectangle

See Also

Reference

RedeyeRectangle Members
Accusoft.ImagXpressSdk Namespace


RedeyeRectangle Class Members

RedeyeRectangle Class Members
Properties

Accusoft.ImagXpressSdk Namespace : RedeyeRectangle Class

The following tables list the members exposed by RedeyeRectangle.

Public Constructors
 | Name | Description
Public Constructor | RedeyeRectangle Constructor | Initializes a new instance of the RedeyeRectangle class.
Top
Public Properties
 | Name | Description
Public Property | Confidence | Gets or sets the confidence.
Public Property | Height | Gets or sets the height.
Public Property | Width | Gets or sets the width.
Public Property | Xposition | Gets or sets the left position of the top-left point.
Public Property | Yposition | Gets or sets the top position of the top-left point.
Top
See Also

Reference

RedeyeRectangle Class
Accusoft.ImagXpressSdk Namespace


RedeyeRectangle Constructor

RedeyeRectangle Constructor

Accusoft.ImagXpressSdk Namespace > RedeyeRectangle Class : RedeyeRectangle Constructor
Initializes a new instance of the RedeyeRectangle class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New RedeyeRectangle()
public RedeyeRectangle()
public: RedeyeRectangle();
public:
RedeyeRectangle();
Remarks

Note: Available in Professional edition.

See Also

Reference

RedeyeRectangle Class
RedeyeRectangle Members


RedeyeRectangle Class Properties

RedeyeRectangle Class Properties

Accusoft.ImagXpressSdk Namespace : RedeyeRectangle Class

For a list of all members of this type, see RedeyeRectangle members.

Public Properties
 | Name | Description
Public Property | Confidence | Gets or sets the confidence.
Public Property | Height | Gets or sets the height.
Public Property | Width | Gets or sets the width.
Public Property | Xposition | Gets or sets the left position of the top-left point.
Public Property | Yposition | Gets or sets the top position of the top-left point.
Top
See Also

Reference

RedeyeRectangle Class
Accusoft.ImagXpressSdk Namespace


Confidence Property (RedeyeRectangle)

Confidence Property (RedeyeRectangle)

Accusoft.ImagXpressSdk Namespace > RedeyeRectangle Class : Confidence Property
Gets or sets the confidence.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Confidence As Integer
'Usage

Dim instance As RedeyeRectangle
Dim value As Integer

instance.Confidence = value

value = instance.Confidence
public int Confidence {get; set;}
public: __property int get_Confidence();
public: __property void set_Confidence(
   int value
);
public:
property int Confidence {
   int get();
   void set (    int value);
}

Property Value

The confidence.
Remarks

Note: Available in Professional edition.

See Also

Reference

RedeyeRectangle Class
RedeyeRectangle Members


Height Property (RedeyeRectangle)

Height Property (RedeyeRectangle)

Accusoft.ImagXpressSdk Namespace > RedeyeRectangle Class : Height Property
Gets or sets the height.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Height As Integer
'Usage

Dim instance As RedeyeRectangle
Dim value As Integer

instance.Height = value

value = instance.Height
public int Height {get; set;}
public: __property int get_Height();
public: __property void set_Height(
   int value
);
public:
property int Height {
   int get();
   void set (    int value);
}

Property Value

The height.
Remarks

Note: Available in Professional edition.

See Also

Reference

RedeyeRectangle Class
RedeyeRectangle Members


Width Property (RedeyeRectangle)

Width Property (RedeyeRectangle)

Accusoft.ImagXpressSdk Namespace > RedeyeRectangle Class : Width Property
Gets or sets the width.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Width As Integer
'Usage

Dim instance As RedeyeRectangle
Dim value As Integer

instance.Width = value

value = instance.Width
public int Width {get; set;}
public: __property int get_Width();
public: __property void set_Width(
   int value
);
public:
property int Width {
   int get();
   void set (    int value);
}

Property Value

The width.
Remarks

Note: Available in Professional edition.

See Also

Reference

RedeyeRectangle Class
RedeyeRectangle Members


Xposition Property

Xposition Property

Accusoft.ImagXpressSdk Namespace > RedeyeRectangle Class : Xposition Property
Gets or sets the left position of the top-left point.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Xposition As Integer
'Usage

Dim instance As RedeyeRectangle
Dim value As Integer

instance.Xposition = value

value = instance.Xposition
public int Xposition {get; set;}
public: __property int get_Xposition();
public: __property void set_Xposition(
   int value
);
public:
property int Xposition {
   int get();
   void set (    int value);
}

Property Value

The X position.
Remarks

Note: Available in Professional edition.

See Also

Reference

RedeyeRectangle Class
RedeyeRectangle Members


Yposition Property

Yposition Property

Accusoft.ImagXpressSdk Namespace > RedeyeRectangle Class : Yposition Property
Gets or sets the top position of the top-left point.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Yposition As Integer
'Usage

Dim instance As RedeyeRectangle
Dim value As Integer

instance.Yposition = value

value = instance.Yposition
public int Yposition {get; set;}
public: __property int get_Yposition();
public: __property void set_Yposition(
   int value
);
public:
property int Yposition {
   int get();
   void set (    int value);
}

Property Value

The Y position.
Remarks

Note: Available in Professional edition.

See Also

Reference

RedeyeRectangle Class
RedeyeRectangle Members


ResizedEventArgs Class

ResizedEventArgs Class
Members

Accusoft.ImagXpressSdk Namespace : ResizedEventArgs Class
This class implements event data for Resized events.
Object Model
ResizedEventArgs Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ResizedEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As ResizedEventArgs
public class ResizedEventArgs : System.EventArgs
public __gc class ResizedEventArgs : public System.EventArgs
public ref class ResizedEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
Accusoft.ImagXpressSdk.ResizedEventArgs

See Also

Reference

ResizedEventArgs Members
Accusoft.ImagXpressSdk Namespace


ResizedEventArgs Class Members

ResizedEventArgs Class Members
Properties

Accusoft.ImagXpressSdk Namespace : ResizedEventArgs Class

The following tables list the members exposed by ResizedEventArgs.

Public Constructors
 | Name | Description
Public Constructor | ResizedEventArgs Constructor | The main constructor which initializes a new instance of the ResizedEventArgs class.
Top
Public Properties
 | Name | Description
Public Property | NewSize | Gets the new size of the control.
Top
See Also

Reference

ResizedEventArgs Class
Accusoft.ImagXpressSdk Namespace


ResizedEventArgs Constructor

ResizedEventArgs Constructor

Accusoft.ImagXpressSdk Namespace > ResizedEventArgs Class : ResizedEventArgs Constructor
The main constructor which initializes a new instance of the ResizedEventArgs class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ResizedEventArgs()
public ResizedEventArgs()
public: ResizedEventArgs();
public:
ResizedEventArgs();
See Also

Reference

ResizedEventArgs Class
ResizedEventArgs Members


ResizedEventArgs Class Properties

ResizedEventArgs Class Properties

Accusoft.ImagXpressSdk Namespace : ResizedEventArgs Class

For a list of all members of this type, see ResizedEventArgs members.

Public Properties
 | Name | Description
Public Property | NewSize | Gets the new size of the control.
Top
See Also

Reference

ResizedEventArgs Class
Accusoft.ImagXpressSdk Namespace


ResizedEventArgs Constructor

ResizedEventArgs Constructor

Accusoft.ImagXpressSdk Namespace > ResizedEventArgs Class : ResizedEventArgs Constructor
Overload List
Overload | Description
ResizedEventArgs Constructor | The main constructor which initializes a new instance of the ResizedEventArgs class.
See Also

Reference

ResizedEventArgs Class
ResizedEventArgs Members


NewSize Property

NewSize Property

Accusoft.ImagXpressSdk Namespace > ResizedEventArgs Class : NewSize Property
Gets the new size of the control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property NewSize As Size
'Usage

Dim instance As ResizedEventArgs
Dim value As Size

value = instance.NewSize
public Size NewSize {get;}
public: __property Size get_NewSize();
public:
property Size NewSize {
   Size get();
}

Property Value

A System.Drawing.Size value from the .NET Framework Class Library.
See Also

Reference

ResizedEventArgs Class
ResizedEventArgs Members


Resolution Class

Resolution Class
Members

Accusoft.ImagXpressSdk Namespace : Resolution Class
This class contains properties and methods for the resolution of an image.
Object Model
Resolution Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class Resolution
'Usage

Dim instance As Resolution
public class Resolution
public __gc class Resolution
public ref class Resolution
Inheritance Hierarchy

System.Object
Accusoft.ImagXpressSdk.Resolution

See Also

Reference

Resolution Members
Accusoft.ImagXpressSdk Namespace


Resolution Class Members

Resolution Class Members
Fields Properties

Accusoft.ImagXpressSdk Namespace : Resolution Class

The following tables list the members exposed by Resolution.

Public Constructors
 | Name | Description
Public Constructor | Resolution Constructor | Overloaded.
Top
Public Fields
 | Name | Description
Public Field | DefaultPrecision | The default level of precision. This is the default value for the Precision property.
Public Field | MaximumPrecision | The maximum level of precision. This is the maximum value that the Precision property can be set.
Public Field | MinimumPrecision | The minimum level of precision. This is the minimum value that the Precision property can be set.
Top
Public Properties
 | Name | Description
Public Property | Dimensions | Gets and sets the dimensions of the image.
Public Property | Precision | Gets or sets the level of precision of the Dimensions returned.
Public Property | Units | Gets and sets the unit of measure in which the resolution dimensions are expressed.
Top
See Also

Reference

Resolution Class
Accusoft.ImagXpressSdk Namespace


Resolution Constructor

Resolution Constructor

Accusoft.ImagXpressSdk Namespace > Resolution Class : Resolution Constructor
Overload List
Overload | Description
Resolution Constructor() | The main constructor for the Resolution class.
Resolution Constructor(SizeF,GraphicsUnit) | Initializes a new instance of the Resolution class from the specified width, height and units.
Resolution Constructor(Single,Single,GraphicsUnit) | Initializes a new instance of the Resolution class from the specified width, height and units.
Resolution Constructor(SizeF,GraphicsUnit,Int32) | Initializes a new instance of the Resolution class from the specified width, height, units and precision.
Resolution Constructor(Single,Single,GraphicsUnit,Int32) | Initializes a new instance of the Resolution class from the specified width, height, units and precision.
Resolution Constructor(Resolution) | Initializes a new instance of the Resolution class.
Resolution Constructor(Resolution,Int32) | Initializes a new instance of the Resolution class.
See Also

Reference

Resolution Class
Resolution Members


Resolution Constructor()

Resolution Constructor()

Accusoft.ImagXpressSdk Namespace > Resolution Class > Resolution Constructor : Resolution Constructor()
The main constructor for the Resolution class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New Resolution()
public Resolution()
public: Resolution();
public:
Resolution();
See Also

Reference

Resolution Class
Resolution Members
Overload List


Resolution Constructor(SizeF,GraphicsUnit)

Resolution Constructor(SizeF,GraphicsUnit)

Accusoft.ImagXpressSdk Namespace > Resolution Class > Resolution Constructor : Resolution Constructor(SizeF,GraphicsUnit)
A System.Drawing.SizeF structure which evauluates to the region associated with the current image.
A System.Drawing.GraphicsUnit enumeration value which represents the unit of measure of the current image.
Initializes a new instance of the Resolution class from the specified width, height and units.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal dimensions As SizeF, _
   ByVal units As GraphicsUnit _
)
'Usage

Dim dimensions As SizeF
Dim units As GraphicsUnit

Dim instance As New Resolution(dimensions, units)
public Resolution(
   SizeF dimensions,
   GraphicsUnit units
)
public: Resolution(
   SizeF dimensions,
   GraphicsUnit units
)
public:
Resolution(
   SizeF dimensions,
   GraphicsUnit units
)

Parameters

dimensions
A System.Drawing.SizeF structure which evauluates to the region associated with the current image.
units
A System.Drawing.GraphicsUnit enumeration value which represents the unit of measure of the current image.
See Also

Reference

Resolution Class
Resolution Members
Overload List


Resolution Constructor(Single,Single,GraphicsUnit)

Resolution Constructor(Single,Single,GraphicsUnit)

Accusoft.ImagXpressSdk Namespace > Resolution Class > Resolution Constructor : Resolution Constructor(Single,Single,GraphicsUnit)
A float value which represents the width of the current image.
A float value which represents the height of the current image.
A System.Drawing.GraphicsUnit enumeration value which represents the unit of measure of the current image.
Initializes a new instance of the Resolution class from the specified width, height and units.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal units As GraphicsUnit _
)
'Usage

Dim width As Single
Dim height As Single
Dim units As GraphicsUnit

Dim instance As New Resolution(width, height, units)
public Resolution(
   float width,
   float height,
   GraphicsUnit units
)
public: Resolution(
   float width,
   float height,
   GraphicsUnit units
)
public:
Resolution(
   float width,
   float height,
   GraphicsUnit units
)

Parameters

width
A float value which represents the width of the current image.
height
A float value which represents the height of the current image.
units
A System.Drawing.GraphicsUnit enumeration value which represents the unit of measure of the current image.
See Also

Reference

Resolution Class
Resolution Members
Overload List


Resolution Constructor(SizeF,GraphicsUnit,Int32)

Resolution Constructor(SizeF,GraphicsUnit,Int32)

Accusoft.ImagXpressSdk Namespace > Resolution Class > Resolution Constructor : Resolution Constructor(SizeF,GraphicsUnit,Int32)
A System.Drawing.SizeF structure which evauluates to the region associated with the current image.
A System.Drawing.GraphicsUnit enumeration value which represents the unit of measure of the current image.
The level of precision of the Dimensions returned. This parameter must be a value from MinimumPrecision to MaximumPrecision. Setting the precision is really a request for the precision level to be at a certain level. Because of the way floating-point numbers are stored in computers, ImagXpress can not guarantee that the precision is at a certain level. If the application needs 100% accuracy, then the application should set this value to MaximumPrecision and handle any truncation or rounding itself.
Initializes a new instance of the Resolution class from the specified width, height, units and precision.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal dimensions As SizeF, _
   ByVal units As GraphicsUnit, _
   ByVal precision As Integer _
)
'Usage

Dim dimensions As SizeF
Dim units As GraphicsUnit
Dim precision As Integer

Dim instance As New Resolution(dimensions, units, precision)
public Resolution(
   SizeF dimensions,
   GraphicsUnit units,
   int precision
)
public: Resolution(
   SizeF dimensions,
   GraphicsUnit units,
   int precision
)
public:
Resolution(
   SizeF dimensions,
   GraphicsUnit units,
   int precision
)

Parameters

dimensions
A System.Drawing.SizeF structure which evauluates to the region associated with the current image.
units
A System.Drawing.GraphicsUnit enumeration value which represents the unit of measure of the current image.
precision
The level of precision of the Dimensions returned. This parameter must be a value from MinimumPrecision to MaximumPrecision. Setting the precision is really a request for the precision level to be at a certain level. Because of the way floating-point numbers are stored in computers, ImagXpress can not guarantee that the precision is at a certain level. If the application needs 100% accuracy, then the application should set this value to MaximumPrecision and handle any truncation or rounding itself.
See Also

Reference

Resolution Class
Resolution Members
Overload List


Resolution Constructor(Single,Single,GraphicsUnit,Int32)

Resolution Constructor(Single,Single,GraphicsUnit,Int32)

Accusoft.ImagXpressSdk Namespace > Resolution Class > Resolution Constructor : Resolution Constructor(Single,Single,GraphicsUnit,Int32)
A float value which represents the width of the current image.
A float value which represents the height of the current image.
A System.Drawing.GraphicsUnit enumeration value which represents the unit of measure of the current image.
The level of precision of the Dimensions returned. This parameter must be a value from MinimumPrecision to MaximumPrecision. Setting the precision is really a request for the precision level to be at a certain level. Because of the way floating-point numbers are stored in computers, ImagXpress can not guarantee that the precision is at a certain level. If the application needs 100% accuracy, then the application should set this value to MaximumPrecision and handle any truncation or rounding itself.
Initializes a new instance of the Resolution class from the specified width, height, units and precision.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal units As GraphicsUnit, _
   ByVal precision As Integer _
)
'Usage

Dim width As Single
Dim height As Single
Dim units As GraphicsUnit
Dim precision As Integer

Dim instance As New Resolution(width, height, units, precision)
public Resolution(
   float width,
   float height,
   GraphicsUnit units,
   int precision
)
public: Resolution(
   float width,
   float height,
   GraphicsUnit units,
   int precision
)
public:
Resolution(
   float width,
   float height,
   GraphicsUnit units,
   int precision
)

Parameters

width
A float value which represents the width of the current image.
height
A float value which represents the height of the current image.
units
A System.Drawing.GraphicsUnit enumeration value which represents the unit of measure of the current image.
precision
The level of precision of the Dimensions returned. This parameter must be a value from MinimumPrecision to MaximumPrecision. Setting the precision is really a request for the precision level to be at a certain level. Because of the way floating-point numbers are stored in computers, ImagXpress can not guarantee that the precision is at a certain level. If the application needs 100% accuracy, then the application should set this value to MaximumPrecision and handle any truncation or rounding itself.
See Also

Reference

Resolution Class
Resolution Members
Overload List


Resolution Constructor(Resolution)

Resolution Constructor(Resolution)

Accusoft.ImagXpressSdk Namespace > Resolution Class > Resolution Constructor : Resolution Constructor(Resolution)
The source resolution.
Initializes a new instance of the Resolution class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal sourceResolution As Resolution _
)
'Usage

Dim sourceResolution As Resolution

Dim instance As New Resolution(sourceResolution)
public Resolution(
   Resolution sourceResolution
)
public: Resolution(
   Resolution* sourceResolution
)
public:
Resolution(
   Resolution^ sourceResolution
)

Parameters

sourceResolution
The source resolution.
See Also

Reference

Resolution Class
Resolution Members
Overload List


Resolution Constructor(Resolution,Int32)

Resolution Constructor(Resolution,Int32)

Accusoft.ImagXpressSdk Namespace > Resolution Class > Resolution Constructor : Resolution Constructor(Resolution,Int32)
The source resolution.
The new level of precision for the copied Resolution object. This is the level of precision of the Dimensions returned. This parameter must be a value from MinimumPrecision to MaximumPrecision. Setting the precision is really a request for the precision level to be at a certain level. Because of the way floating-point numbers are stored in computers, ImagXpress can not guarantee that the precision is at a certain level. If the application needs 100% accuracy, then the application should set this value to MaximumPrecision and handle any truncation or rounding itself.
Initializes a new instance of the Resolution class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal sourceResolution As Resolution, _
   ByVal precision As Integer _
)
'Usage

Dim sourceResolution As Resolution
Dim precision As Integer

Dim instance As New Resolution(sourceResolution, precision)
public Resolution(
   Resolution sourceResolution,
   int precision
)
public: Resolution(
   Resolution* sourceResolution,
   int precision
)
public:
Resolution(
   Resolution^ sourceResolution,
   int precision
)

Parameters

sourceResolution
The source resolution.
precision
The new level of precision for the copied Resolution object. This is the level of precision of the Dimensions returned. This parameter must be a value from MinimumPrecision to MaximumPrecision. Setting the precision is really a request for the precision level to be at a certain level. Because of the way floating-point numbers are stored in computers, ImagXpress can not guarantee that the precision is at a certain level. If the application needs 100% accuracy, then the application should set this value to MaximumPrecision and handle any truncation or rounding itself.
See Also

Reference

Resolution Class
Resolution Members
Overload List


Resolution Class Properties

Resolution Class Properties

Accusoft.ImagXpressSdk Namespace : Resolution Class

For a list of all members of this type, see Resolution members.

Public Properties
 | Name | Description
Public Property | Dimensions | Gets and sets the dimensions of the image.
Public Property | Precision | Gets or sets the level of precision of the Dimensions returned.
Public Property | Units | Gets and sets the unit of measure in which the resolution dimensions are expressed.
Top
See Also

Reference

Resolution Class
Accusoft.ImagXpressSdk Namespace


Dimensions Property (Resolution)

Dimensions Property (Resolution)

Accusoft.ImagXpressSdk Namespace > Resolution Class : Dimensions Property
Gets and sets the dimensions of the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Dimensions As SizeF
'Usage

Dim instance As Resolution
Dim value As SizeF

instance.Dimensions = value

value = instance.Dimensions
public SizeF Dimensions {get; set;}
public: __property SizeF get_Dimensions();
public: __property void set_Dimensions(
   SizeF value
);
public:
property SizeF Dimensions {
   SizeF get();
   void set (    SizeF value);
}

Property Value

The System.Drawing.SizeF value set. The value returned from the get is rounded based on the Precision property. However, the actual value stored internally is based on what is set into this property. Setting the Precision property to MaximumPrecision will return the entire value stored.
See Also

Reference

Resolution Class
Resolution Members


Precision Property

Precision Property

Accusoft.ImagXpressSdk Namespace > Resolution Class : Precision Property
Gets or sets the level of precision of the Dimensions returned.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Precision As Integer
'Usage

Dim instance As Resolution
Dim value As Integer

instance.Precision = value

value = instance.Precision
public int Precision {get; set;}
public: __property int get_Precision();
public: __property void set_Precision(
   int value
);
public:
property int Precision {
   int get();
   void set (    int value);
}

Property Value

The level of precision of the Dimensions returned. The default value for this property is 1. This parameter must be a value from MinimumPrecision to MaximumPrecision. Setting the precision is really a request for the precision level to be at a certain level. Because of the way floating-point numbers are stored in computers, ImagXpress can not guarantee that the precision is at a certain level. If the application needs 100% accuracy, then the application should set this value to MaximumPrecision and handle any truncation or rounding itself.
See Also

Reference

Resolution Class
Resolution Members


Units Property

Units Property

Accusoft.ImagXpressSdk Namespace > Resolution Class : Units Property
Gets and sets the unit of measure in which the resolution dimensions are expressed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Units As GraphicsUnit
'Usage

Dim instance As Resolution
Dim value As GraphicsUnit

instance.Units = value

value = instance.Units
public GraphicsUnit Units {get; set;}
public: __property GraphicsUnit get_Units();
public: __property void set_Units(
   GraphicsUnit value
);
public:
property GraphicsUnit Units {
   GraphicsUnit get();
   void set (    GraphicsUnit value);
}

Property Value

The System.Drawing.GraphicsUnit value set.
See Also

Reference

Resolution Class
Resolution Members


Resolution Class Fields

Resolution Class Fields

Accusoft.ImagXpressSdk Namespace : Resolution Class

For a list of all members of this type, see Resolution members.

Public Fields
 | Name | Description
Public Field | DefaultPrecision | The default level of precision. This is the default value for the Precision property.
Public Field | MaximumPrecision | The maximum level of precision. This is the maximum value that the Precision property can be set.
Public Field | MinimumPrecision | The minimum level of precision. This is the minimum value that the Precision property can be set.
Top
See Also

Reference

Resolution Class
Accusoft.ImagXpressSdk Namespace


DefaultPrecision Field

DefaultPrecision Field

Accusoft.ImagXpressSdk Namespace > Resolution Class : DefaultPrecision Field
The default level of precision. This is the default value for the Precision property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Const DefaultPrecision As Integer
'Usage

Dim value As Integer

value = Resolution.DefaultPrecision
public const int DefaultPrecision
public: const int DefaultPrecision
public:
const int DefaultPrecision
See Also

Reference

Resolution Class
Resolution Members


MaximumPrecision Field

MaximumPrecision Field

Accusoft.ImagXpressSdk Namespace > Resolution Class : MaximumPrecision Field
The maximum level of precision. This is the maximum value that the Precision property can be set.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Const MaximumPrecision As Integer
'Usage

Dim value As Integer

value = Resolution.MaximumPrecision
public const int MaximumPrecision
public: const int MaximumPrecision
public:
const int MaximumPrecision
See Also

Reference

Resolution Class
Resolution Members


MinimumPrecision Field

MinimumPrecision Field

Accusoft.ImagXpressSdk Namespace > Resolution Class : MinimumPrecision Field
The minimum level of precision. This is the minimum value that the Precision property can be set.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Const MinimumPrecision As Integer
'Usage

Dim value As Integer

value = Resolution.MinimumPrecision
public const int MinimumPrecision
public: const int MinimumPrecision
public:
const int MinimumPrecision
See Also

Reference

Resolution Class
Resolution Members


RotationGestureOccurredEventArgs Class

RotationGestureOccurredEventArgs Class
Members

Accusoft.ImagXpressSdk Namespace : RotationGestureOccurredEventArgs Class
This class implements event data for the RotationGestureOccurred events.
Object Model
RotationGestureOccurredEventArgs Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class RotationGestureOccurredEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As RotationGestureOccurredEventArgs
public class RotationGestureOccurredEventArgs : System.EventArgs
public __gc class RotationGestureOccurredEventArgs : public System.EventArgs
public ref class RotationGestureOccurredEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
Accusoft.ImagXpressSdk.RotationGestureOccurredEventArgs

See Also

Reference

RotationGestureOccurredEventArgs Members
Accusoft.ImagXpressSdk Namespace


RotationGestureOccurredEventArgs Class Members

RotationGestureOccurredEventArgs Class Members
Properties

Accusoft.ImagXpressSdk Namespace : RotationGestureOccurredEventArgs Class

The following tables list the members exposed by RotationGestureOccurredEventArgs.

Public Constructors
 | Name | Description
Public Constructor | RotationGestureOccurredEventArgs Constructor | The main constructor which initializes a new instance of the TouchRotateEventArgs class.
Top
Public Properties
 | Name | Description
Public Property | RotationCenterPoint | Gets the center of the fingers during rotation with the touch interface.
Public Property | TotalDegreesRotated | Gets the angle (in degrees) of cumulative rotation during rotation with the touch interface.
Top
See Also

Reference

RotationGestureOccurredEventArgs Class
Accusoft.ImagXpressSdk Namespace


RotationGestureOccurredEventArgs Constructor

RotationGestureOccurredEventArgs Constructor

Accusoft.ImagXpressSdk Namespace > RotationGestureOccurredEventArgs Class : RotationGestureOccurredEventArgs Constructor
The main constructor which initializes a new instance of the TouchRotateEventArgs class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New RotationGestureOccurredEventArgs()
public RotationGestureOccurredEventArgs()
public: RotationGestureOccurredEventArgs();
public:
RotationGestureOccurredEventArgs();
See Also

Reference

RotationGestureOccurredEventArgs Class
RotationGestureOccurredEventArgs Members


RotationGestureOccurredEventArgs Class Properties

RotationGestureOccurredEventArgs Class Properties

Accusoft.ImagXpressSdk Namespace : RotationGestureOccurredEventArgs Class

For a list of all members of this type, see RotationGestureOccurredEventArgs members.

Public Properties
 | Name | Description
Public Property | RotationCenterPoint | Gets the center of the fingers during rotation with the touch interface.
Public Property | TotalDegreesRotated | Gets the angle (in degrees) of cumulative rotation during rotation with the touch interface.
Top
See Also

Reference

RotationGestureOccurredEventArgs Class
Accusoft.ImagXpressSdk Namespace


RotationGestureOccurredEventArgs Constructor

RotationGestureOccurredEventArgs Constructor

Accusoft.ImagXpressSdk Namespace > RotationGestureOccurredEventArgs Class : RotationGestureOccurredEventArgs Constructor
Overload List
Overload | Description
RotationGestureOccurredEventArgs Constructor | The main constructor which initializes a new instance of the TouchRotateEventArgs class.
See Also

Reference

RotationGestureOccurredEventArgs Class
RotationGestureOccurredEventArgs Members


RotationCenterPoint Property (RotationGestureOccurredEventArgs)

RotationCenterPoint Property (RotationGestureOccurredEventArgs)

Accusoft.ImagXpressSdk Namespace > RotationGestureOccurredEventArgs Class : RotationCenterPoint Property
Gets the center of the fingers during rotation with the touch interface.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property RotationCenterPoint As Point
'Usage

Dim instance As RotationGestureOccurredEventArgs
Dim value As Point

value = instance.RotationCenterPoint
public Point RotationCenterPoint {get;}
public: __property Point get_RotationCenterPoint();
public:
property Point RotationCenterPoint {
   Point get();
}

Property Value

A System.Drawing.Point value from the .NET Framework Class Library.
See Also

Reference

RotationGestureOccurredEventArgs Class
RotationGestureOccurredEventArgs Members


TotalDegreesRotated Property

TotalDegreesRotated Property

Accusoft.ImagXpressSdk Namespace > RotationGestureOccurredEventArgs Class : TotalDegreesRotated Property
Gets the angle (in degrees) of cumulative rotation during rotation with the touch interface.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property TotalDegreesRotated As Double
'Usage

Dim instance As RotationGestureOccurredEventArgs
Dim value As Double

value = instance.TotalDegreesRotated
public double TotalDegreesRotated {get;}
public: __property double get_TotalDegreesRotated();
public:
property double TotalDegreesRotated {
   double get();
}

Property Value

A System.Double value.
See Also

Reference

RotationGestureOccurredEventArgs Class
RotationGestureOccurredEventArgs Members


RotationGestureOccurringEventArgs Class

RotationGestureOccurringEventArgs Class
Members

Accusoft.ImagXpressSdk Namespace : RotationGestureOccurringEventArgs Class
This class implements event data for RotationGestureOccurring events.
Object Model
RotationGestureOccurringEventArgs Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class RotationGestureOccurringEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As RotationGestureOccurringEventArgs
public class RotationGestureOccurringEventArgs : System.EventArgs
public __gc class RotationGestureOccurringEventArgs : public System.EventArgs
public ref class RotationGestureOccurringEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
Accusoft.ImagXpressSdk.RotationGestureOccurringEventArgs

See Also

Reference

RotationGestureOccurringEventArgs Members
Accusoft.ImagXpressSdk Namespace


RotationGestureOccurringEventArgs Class Members

RotationGestureOccurringEventArgs Class Members
Properties

Accusoft.ImagXpressSdk Namespace : RotationGestureOccurringEventArgs Class

The following tables list the members exposed by RotationGestureOccurringEventArgs.

Public Constructors
 | Name | Description
Public Constructor | RotationGestureOccurringEventArgs Constructor | The main constructor which initializes a new instance of the TouchRotateEventArgs class.
Top
Public Properties
 | Name | Description
Public Property | DegreesRotated | Gets the angle (in degrees) of cumulative rotation during rotation with the touch interface.
Public Property | RotationCenterPoint | Gets the center of the fingers during rotation with the touch interface.
Top
See Also

Reference

RotationGestureOccurringEventArgs Class
Accusoft.ImagXpressSdk Namespace


RotationGestureOccurringEventArgs Constructor

RotationGestureOccurringEventArgs Constructor

Accusoft.ImagXpressSdk Namespace > RotationGestureOccurringEventArgs Class : RotationGestureOccurringEventArgs Constructor
The main constructor which initializes a new instance of the TouchRotateEventArgs class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New RotationGestureOccurringEventArgs()
public RotationGestureOccurringEventArgs()
public: RotationGestureOccurringEventArgs();
public:
RotationGestureOccurringEventArgs();
See Also

Reference

RotationGestureOccurringEventArgs Class
RotationGestureOccurringEventArgs Members


RotationGestureOccurringEventArgs Class Properties

RotationGestureOccurringEventArgs Class Properties

Accusoft.ImagXpressSdk Namespace : RotationGestureOccurringEventArgs Class

For a list of all members of this type, see RotationGestureOccurringEventArgs members.

Public Properties
 | Name | Description
Public Property | DegreesRotated | Gets the angle (in degrees) of cumulative rotation during rotation with the touch interface.
Public Property | RotationCenterPoint | Gets the center of the fingers during rotation with the touch interface.
Top
See Also

Reference

RotationGestureOccurringEventArgs Class
Accusoft.ImagXpressSdk Namespace


RotationGestureOccurringEventArgs Constructor

RotationGestureOccurringEventArgs Constructor

Accusoft.ImagXpressSdk Namespace > RotationGestureOccurringEventArgs Class : RotationGestureOccurringEventArgs Constructor
Overload List
Overload | Description
RotationGestureOccurringEventArgs Constructor | The main constructor which initializes a new instance of the TouchRotateEventArgs class.
See Also

Reference

RotationGestureOccurringEventArgs Class
RotationGestureOccurringEventArgs Members


DegreesRotated Property

DegreesRotated Property

Accusoft.ImagXpressSdk Namespace > RotationGestureOccurringEventArgs Class : DegreesRotated Property
Gets the angle (in degrees) of cumulative rotation during rotation with the touch interface.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property DegreesRotated As Double
'Usage

Dim instance As RotationGestureOccurringEventArgs
Dim value As Double

value = instance.DegreesRotated
public double DegreesRotated {get;}
public: __property double get_DegreesRotated();
public:
property double DegreesRotated {
   double get();
}

Property Value

A System.Double value.
See Also

Reference

RotationGestureOccurringEventArgs Class
RotationGestureOccurringEventArgs Members


RotationCenterPoint Property (RotationGestureOccurringEventArgs)

RotationCenterPoint Property (RotationGestureOccurringEventArgs)

Accusoft.ImagXpressSdk Namespace > RotationGestureOccurringEventArgs Class : RotationCenterPoint Property
Gets the center of the fingers during rotation with the touch interface.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property RotationCenterPoint As Point
'Usage

Dim instance As RotationGestureOccurringEventArgs
Dim value As Point

value = instance.RotationCenterPoint
public Point RotationCenterPoint {get;}
public: __property Point get_RotationCenterPoint();
public:
property Point RotationCenterPoint {
   Point get();
}

Property Value

A System.Drawing.Point value from the .NET Framework Class Library.
See Also

Reference

RotationGestureOccurringEventArgs Class
RotationGestureOccurringEventArgs Members


Rubberband Class

Rubberband Class
Members

Accusoft.ImagXpressSdk Namespace : Rubberband Class
This class implements methods and properties for part or all of an image to be selected within a dashed rectangular area.
Object Model
Rubberband ClassImageX ClassImageX ClassImageCalsCollection ClassImageCalsTag ClassImageX ClassImageX ClassImageX ClassImageX ClassImageX ClassImageX ClassImageX ClassImageXData ClassImageXIptcCollection ClassImageXIptcData ClassLoadOptions ClassImageModcaCollection ClassImageModcaTag ClassImageXData ClassImageXData ClassImageXData ClassImageX ClassResolution ClassImageXTagCollection ClassImageXTag Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class Rubberband
'Usage

Dim instance As Rubberband
public class Rubberband
public __gc class Rubberband
public ref class Rubberband
Inheritance Hierarchy

System.Object
Accusoft.ImagXpressSdk.Rubberband

See Also

Reference

Rubberband Members
Accusoft.ImagXpressSdk Namespace


Rubberband Class Members

Rubberband Class Members
Properties Methods

Accusoft.ImagXpressSdk Namespace : Rubberband Class

The following tables list the members exposed by Rubberband.

Public Properties
 | Name | Description
Public Property | Dimensions | Gets the Rubberband location and dimensions.
Public Property | Enabled | Gets and sets an indicator if the rubberband is enabled.
Public Property | Negate | Gets and sets an indicator if the Rubberband displays the area as a negative of the original.
Top
Public Methods
 | Name | Description
Public Method | Clear | Deletes the Rubberband and frees the memory associated with it.
Public Method | Copy | Copies the current rubber band area into a new ImageX object.
Public Method | Start | Overloaded. Sets the starting point for the Rubberband object.
Public Method | Stop | Stops (disables) the rubberband.
Public Method | Update | Updates the current rubber band ending point.
Top
See Also

Reference

Rubberband Class
Accusoft.ImagXpressSdk Namespace


Rubberband Class Methods

Rubberband Class Methods

Accusoft.ImagXpressSdk Namespace : Rubberband Class

For a list of all members of this type, see Rubberband members.

Public Methods
 | Name | Description
Public Method | Clear | Deletes the Rubberband and frees the memory associated with it.
Public Method | Copy | Copies the current rubber band area into a new ImageX object.
Public Method | Start | Overloaded. Sets the starting point for the Rubberband object.
Public Method | Stop | Stops (disables) the rubberband.
Public Method | Update | Updates the current rubber band ending point.
Top
See Also

Reference

Rubberband Class
Accusoft.ImagXpressSdk Namespace


Clear Method (Rubberband)

Clear Method (Rubberband)

Accusoft.ImagXpressSdk Namespace > Rubberband Class : Clear Method
Deletes the Rubberband and frees the memory associated with it.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Clear()
'Usage

Dim instance As Rubberband

instance.Clear()
public void Clear()
public: void Clear();
public:
void Clear();
Remarks

There is no impact to the displayed image, or the image in memory.

See Also

Reference

Rubberband Class
Rubberband Members


Copy Method (Rubberband)

Copy Method (Rubberband)

Accusoft.ImagXpressSdk Namespace > Rubberband Class : Copy Method
Copies the current rubber band area into a new ImageX object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Copy() As ImageX
'Usage

Dim instance As Rubberband
Dim value As ImageX

value = instance.Copy()
public ImageX Copy()
public: ImageX* Copy();
public:
ImageX^ Copy();

Return Value

An ImageX object.
See Also

Reference

Rubberband Class
Rubberband Members


Start Method

Start Method

Accusoft.ImagXpressSdk Namespace > Rubberband Class : Start Method
Sets the starting point for the Rubberband object.
Overload List
Overload | Description
Start(Point) | Sets the starting point for the Rubberband object.
Start(Point,Boolean) | Sets the starting point for the Rubberband object.
See Also

Reference

Rubberband Class
Rubberband Members


Start(Point) Method

Start(Point) Method

Accusoft.ImagXpressSdk Namespace > Rubberband Class > Start Method : Start(Point) Method
A System.Drawing.Point value which represents the starting point corner for the rubberband.
Sets the starting point for the Rubberband object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Start( _
   ByVal screenStartPoint As Point _
)
'Usage

Dim instance As Rubberband
Dim screenStartPoint As Point

instance.Start(screenStartPoint)
public void Start(
   Point screenStartPoint
)
public: void Start(
   Point screenStartPoint
)
public:
void Start(
   Point screenStartPoint
)

Parameters

screenStartPoint
A System.Drawing.Point value which represents the starting point corner for the rubberband.
See Also

Reference

Rubberband Class
Rubberband Members
Overload List


Start(Point,Boolean) Method

Start(Point,Boolean) Method

Accusoft.ImagXpressSdk Namespace > Rubberband Class > Start Method : Start(Point,Boolean) Method
A System.Drawing.Point value which represents the starting point corner for the rubberband.
A boolean value which is true to display the rubberband area as a negative of the original.
Sets the starting point for the Rubberband object.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Start( _
   ByVal screenStartPoint As Point, _
   ByVal negate As Boolean _
)
'Usage

Dim instance As Rubberband
Dim screenStartPoint As Point
Dim negate As Boolean

instance.Start(screenStartPoint, negate)
public void Start(
   Point screenStartPoint,
   bool negate
)
public: void Start(
   Point screenStartPoint,
   bool negate
)
public:
void Start(
   Point screenStartPoint,
   bool negate
)

Parameters

screenStartPoint
A System.Drawing.Point value which represents the starting point corner for the rubberband.
negate
A boolean value which is true to display the rubberband area as a negative of the original.
See Also

Reference

Rubberband Class
Rubberband Members
Overload List


Stop Method

Stop Method

Accusoft.ImagXpressSdk Namespace > Rubberband Class : Stop Method
Stops (disables) the rubberband.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Stop()
'Usage

Dim instance As Rubberband

instance.Stop()
public void Stop()
public: void Stop();
public:
void Stop();
See Also

Reference

Rubberband Class
Rubberband Members


Update Method

Update Method

Accusoft.ImagXpressSdk Namespace > Rubberband Class : Update Method
A System.Drawing.Point value to represent the current ending point of the Rubberband.
Updates the current rubber band ending point.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Update( _
   ByVal screenUpdatePoint As Point _
)
'Usage

Dim instance As Rubberband
Dim screenUpdatePoint As Point

instance.Update(screenUpdatePoint)
public void Update(
   Point screenUpdatePoint
)
public: void Update(
   Point screenUpdatePoint
)
public:
void Update(
   Point screenUpdatePoint
)

Parameters

screenUpdatePoint
A System.Drawing.Point value to represent the current ending point of the Rubberband.
See Also

Reference

Rubberband Class
Rubberband Members


Rubberband Class Properties

Rubberband Class Properties

Accusoft.ImagXpressSdk Namespace : Rubberband Class

For a list of all members of this type, see Rubberband members.

Public Properties
 | Name | Description
Public Property | Dimensions | Gets the Rubberband location and dimensions.
Public Property | Enabled | Gets and sets an indicator if the rubberband is enabled.
Public Property | Negate | Gets and sets an indicator if the Rubberband displays the area as a negative of the original.
Top
See Also

Reference

Rubberband Class
Accusoft.ImagXpressSdk Namespace


Dimensions Property (Rubberband)

Dimensions Property (Rubberband)

Accusoft.ImagXpressSdk Namespace > Rubberband Class : Dimensions Property
Gets the Rubberband location and dimensions.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Dimensions As Rectangle
'Usage

Dim instance As Rubberband
Dim value As Rectangle

value = instance.Dimensions
public Rectangle Dimensions {get;}
public: __property Rectangle get_Dimensions();
public:
property Rectangle Dimensions {
   Rectangle get();
}

Property Value

A System.Drawing.Rectangle value which represents the location and dimensions.
See Also

Reference

Rubberband Class
Rubberband Members


Enabled Property (Rubberband)

Enabled Property (Rubberband)

Accusoft.ImagXpressSdk Namespace > Rubberband Class : Enabled Property
Gets and sets an indicator if the rubberband is enabled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Enabled As Boolean
'Usage

Dim instance As Rubberband
Dim value As Boolean

instance.Enabled = value

value = instance.Enabled
public bool Enabled {get; set;}
public: __property bool get_Enabled();
public: __property void set_Enabled(
   bool value
);
public:
property bool Enabled {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true when the rubberband is enabled. Otherwise, false is used to disable rubberbanding.
See Also

Reference

Rubberband Class
Rubberband Members


Negate Property

Negate Property

Accusoft.ImagXpressSdk Namespace > Rubberband Class : Negate Property
Gets and sets an indicator if the Rubberband displays the area as a negative of the original.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Negate As Boolean
'Usage

Dim instance As Rubberband
Dim value As Boolean

instance.Negate = value

value = instance.Negate
public bool Negate {get; set;}
public: __property bool get_Negate();
public: __property void set_Negate(
   bool value
);
public:
property bool Negate {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true.
See Also

Reference

Rubberband Class
Rubberband Members


SaveOptions Class

SaveOptions Class
Members

Accusoft.ImagXpressSdk Namespace : SaveOptions Class
This class implements file writing of image formats.
Object Model
SaveOptions ClassSaveOptionsAnnotations ClassImageXView ClassSaveOptionsBmp ClassSaveOptionsDcx ClassSaveOptionsExif ClassSaveOptionsGif ClassSaveOptionsIcon ClassInternetOptions ClassSaveOptionsJbig2 ClassSaveOptionsJls ClassSaveOptionsJp2 ClassSaveOptionsJpeg ClassSaveOptionsJpegXR ClassSaveOptionsLjp ClassSaveOptionsModca ClassSaveOptionsPdf ClassSaveOptionsPic ClassSaveOptionsPng ClassSaveOptionsTiff ClassSaveOptionsWsq Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class SaveOptions
'Usage

Dim instance As SaveOptions
public class SaveOptions
public __gc class SaveOptions
public ref class SaveOptions
Inheritance Hierarchy

System.Object
Accusoft.ImagXpressSdk.SaveOptions

See Also

Reference

SaveOptions Members
Accusoft.ImagXpressSdk Namespace


SaveOptions Class Members

SaveOptions Class Members
Properties

Accusoft.ImagXpressSdk Namespace : SaveOptions Class

The following tables list the members exposed by SaveOptions.

Public Constructors
 | Name | Description
Public Constructor | SaveOptions Constructor | Initializes a new instance of the SaveOptions class.
Top
Public Properties
 | Name | Description
Public Property | Annotations | Gets the save options for annotations.
Public Property | Bmp | Gets the SaveOptionsBmp settings.
Public Property | BufferFtp | Gets and sets a boolean value that determines whether saving with FTP is buffered completely before sending.
Public Property | ColorRenderIntent | Gets and sets how the color profiles should be applied.
Public Property | Dcx | Gets the SaveOptionsDcx settings.
Public Property | Exif | Gets the SaveOptionsExif settings.
Public Property | Format | Gets and sets the format of the saved file.
Public Property | Gif | Gets the SaveOptionsGif settings.
Public Property | Icon | Gets the SaveOptionsIcon settings.
Public Property | Internet | Gets the InternetOptions object settings.
Public Property | Jbig2 | Gets the SaveOptionsJbig2 settings.
Public Property | Jls | Gets the SaveOptionsJls object settings.
Public Property | Jp2 | Gets the SaveOptionsJp2 settings.
Public Property | Jpeg | Gets the SaveOptionsJpeg settings.
Public Property | JpegXR | Gets the SaveOptionsJpegXR settings.
Public Property | LibraryNumberOfThreadsAllowed | Gets and sets the number of threads allowed.
Public Property | Ljp | Gets the SaveOptionsLjp settings.
Public Property | Modca | Gets the SaveOptionsModca settings.
Public Property | Pdf | Gets the SaveOptionsPdf settings.
Public Property | Pic | Gets the SaveOptionsPic settings.
Public Property | Png | Gets the SaveOptionsPng settings.
Public Property | TargetProfileName | Gets and sets the target profile’s filename.
Public Property | Tiff | Gets the SaveOptionsTiff settings.
Public Property | UseEmbeddedColorManagement | Gets and sets an indicator if color management is used during saving.
Public Property | Wsq | Gets the SaveOptionsWsq settings.
Top
See Also

Reference

SaveOptions Class
Accusoft.ImagXpressSdk Namespace


SaveOptions Constructor

SaveOptions Constructor

Accusoft.ImagXpressSdk Namespace > SaveOptions Class : SaveOptions Constructor
Initializes a new instance of the SaveOptions class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New SaveOptions()
public SaveOptions()
public: SaveOptions();
public:
SaveOptions();
See Also

Reference

SaveOptions Class
SaveOptions Members


SaveOptions Class Properties

SaveOptions Class Properties

Accusoft.ImagXpressSdk Namespace : SaveOptions Class

For a list of all members of this type, see SaveOptions members.

Public Properties
 | Name | Description
Public Property | Annotations | Gets the save options for annotations.
Public Property | Bmp | Gets the SaveOptionsBmp settings.
Public Property | BufferFtp | Gets and sets a boolean value that determines whether saving with FTP is buffered completely before sending.
Public Property | ColorRenderIntent | Gets and sets how the color profiles should be applied.
Public Property | Dcx | Gets the SaveOptionsDcx settings.
Public Property | Exif | Gets the SaveOptionsExif settings.
Public Property | Format | Gets and sets the format of the saved file.
Public Property | Gif | Gets the SaveOptionsGif settings.
Public Property | Icon | Gets the SaveOptionsIcon settings.
Public Property | Internet | Gets the InternetOptions object settings.
Public Property | Jbig2 | Gets the SaveOptionsJbig2 settings.
Public Property | Jls | Gets the SaveOptionsJls object settings.
Public Property | Jp2 | Gets the SaveOptionsJp2 settings.
Public Property | Jpeg | Gets the SaveOptionsJpeg settings.
Public Property | JpegXR | Gets the SaveOptionsJpegXR settings.
Public Property | LibraryNumberOfThreadsAllowed | Gets and sets the number of threads allowed.
Public Property | Ljp | Gets the SaveOptionsLjp settings.
Public Property | Modca | Gets the SaveOptionsModca settings.
Public Property | Pdf | Gets the SaveOptionsPdf settings.
Public Property | Pic | Gets the SaveOptionsPic settings.
Public Property | Png | Gets the SaveOptionsPng settings.
Public Property | TargetProfileName | Gets and sets the target profile’s filename.
Public Property | Tiff | Gets the SaveOptionsTiff settings.
Public Property | UseEmbeddedColorManagement | Gets and sets an indicator if color management is used during saving.
Public Property | Wsq | Gets the SaveOptionsWsq settings.
Top
See Also

Reference

SaveOptions Class
Accusoft.ImagXpressSdk Namespace


Annotations Property

Annotations Property

Accusoft.ImagXpressSdk Namespace > SaveOptions Class : Annotations Property
Gets the save options for annotations.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Annotations As SaveOptionsAnnotations
'Usage

Dim instance As SaveOptions
Dim value As SaveOptionsAnnotations

value = instance.Annotations
public SaveOptionsAnnotations Annotations {get;}
public: __property SaveOptionsAnnotations* get_Annotations();
public:
property SaveOptionsAnnotations^ Annotations {
   SaveOptionsAnnotations^ get();
}

Property Value

A SaveOptionsAnnotations object which contains information for saving the annotations.
Remarks

Note: Available in Professional edition.

See Also

Reference

SaveOptions Class
SaveOptions Members
SaveOptionsAnnotations Class


Bmp Property

Bmp Property

Accusoft.ImagXpressSdk Namespace > SaveOptions Class : Bmp Property
Gets the SaveOptionsBmp settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Bmp As SaveOptionsBmp
'Usage

Dim instance As SaveOptions
Dim value As SaveOptionsBmp

value = instance.Bmp
public SaveOptionsBmp Bmp {get;}
public: __property SaveOptionsBmp* get_Bmp();
public:
property SaveOptionsBmp^ Bmp {
   SaveOptionsBmp^ get();
}

Property Value

A SaveOptionsBmp object which contains the image settings.
See Also

Reference

SaveOptions Class
SaveOptions Members


BufferFtp Property

BufferFtp Property

Accusoft.ImagXpressSdk Namespace > SaveOptions Class : BufferFtp Property
Gets and sets a boolean value that determines whether saving with FTP is buffered completely before sending.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BufferFtp As Boolean
'Usage

Dim instance As SaveOptions
Dim value As Boolean

instance.BufferFtp = value

value = instance.BufferFtp
public bool BufferFtp {get; set;}
public: __property bool get_BufferFtp();
public: __property void set_BufferFtp(
   bool value
);
public:
property bool BufferFtp {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true to buffer the compressed image locally before transferring it to the FTP location. Otherwise, false should be used to immediately transfer the image as it is compressing.
See Also

Reference

SaveOptions Class
SaveOptions Members


ColorRenderIntent Property (SaveOptions)

ColorRenderIntent Property (SaveOptions)

Accusoft.ImagXpressSdk Namespace > SaveOptions Class : ColorRenderIntent Property
Gets and sets how the color profiles should be applied.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ColorRenderIntent As RenderIntent
'Usage

Dim instance As SaveOptions
Dim value As RenderIntent

instance.ColorRenderIntent = value

value = instance.ColorRenderIntent
public RenderIntent ColorRenderIntent {get; set;}
public: __property RenderIntent get_ColorRenderIntent();
public: __property void set_ColorRenderIntent(
   RenderIntent value
);
public:
property RenderIntent ColorRenderIntent {
   RenderIntent get();
   void set (    RenderIntent value);
}
Remarks

Note: Available in Professional edition.

See Also

Reference

SaveOptions Class
SaveOptions Members


Dcx Property

Dcx Property

Accusoft.ImagXpressSdk Namespace > SaveOptions Class : Dcx Property
Gets the SaveOptionsDcx settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Dcx As SaveOptionsDcx
'Usage

Dim instance As SaveOptions
Dim value As SaveOptionsDcx

value = instance.Dcx
public SaveOptionsDcx Dcx {get;}
public: __property SaveOptionsDcx* get_Dcx();
public:
property SaveOptionsDcx^ Dcx {
   SaveOptionsDcx^ get();
}

Property Value

A SaveOptionsDcx object which contains the image settings.
See Also

Reference

SaveOptions Class
SaveOptions Members


Exif Property

Exif Property

Accusoft.ImagXpressSdk Namespace > SaveOptions Class : Exif Property
Gets the SaveOptionsExif settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Exif As SaveOptionsExif
'Usage

Dim instance As SaveOptions
Dim value As SaveOptionsExif

value = instance.Exif
public SaveOptionsExif Exif {get;}
public: __property SaveOptionsExif* get_Exif();
public:
property SaveOptionsExif^ Exif {
   SaveOptionsExif^ get();
}

Property Value

A SaveOptionsExif object which contains the image settings.
See Also

Reference

SaveOptions Class
SaveOptions Members
SaveOptionsExif Class


Format Property (SaveOptions)

Format Property (SaveOptions)

Accusoft.ImagXpressSdk Namespace > SaveOptions Class : Format Property
Gets and sets the format of the saved file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Format As ImageXFormat
'Usage

Dim instance As SaveOptions
Dim value As ImageXFormat

instance.Format = value

value = instance.Format
public ImageXFormat Format {get; set;}
public: __property ImageXFormat get_Format();
public: __property void set_Format(
   ImageXFormat value
);
public:
property ImageXFormat Format {
   ImageXFormat get();
   void set (    ImageXFormat value);
}

Property Value

A ImageXFormat enumeration value which determines the format.
See Also

Reference

SaveOptions Class
SaveOptions Members
ImageXFormat Enumeration


Gif Property

Gif Property

Accusoft.ImagXpressSdk Namespace > SaveOptions Class : Gif Property
Gets the SaveOptionsGif settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Gif As SaveOptionsGif
'Usage

Dim instance As SaveOptions
Dim value As SaveOptionsGif

value = instance.Gif
public SaveOptionsGif Gif {get;}
public: __property SaveOptionsGif* get_Gif();
public:
property SaveOptionsGif^ Gif {
   SaveOptionsGif^ get();
}

Property Value

A SaveOptionsGif object which contains the image settings.
See Also

Reference

SaveOptions Class
SaveOptions Members
SaveOptionsGif Class


Icon Property

Icon Property

Accusoft.ImagXpressSdk Namespace > SaveOptions Class : Icon Property
Gets the SaveOptionsIcon settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Icon As SaveOptionsIcon
'Usage

Dim instance As SaveOptions
Dim value As SaveOptionsIcon

value = instance.Icon
public SaveOptionsIcon Icon {get;}
public: __property SaveOptionsIcon* get_Icon();
public:
property SaveOptionsIcon^ Icon {
   SaveOptionsIcon^ get();
}

Property Value

A SaveOptionsIcon object which contains the image settings.
See Also

Reference

SaveOptions Class
SaveOptions Members


Internet Property (SaveOptions)

Internet Property (SaveOptions)

Accusoft.ImagXpressSdk Namespace > SaveOptions Class : Internet Property
Gets the InternetOptions object settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Internet As InternetOptions
'Usage

Dim instance As SaveOptions
Dim value As InternetOptions

value = instance.Internet
public InternetOptions Internet {get;}
public: __property InternetOptions* get_Internet();
public:
property InternetOptions^ Internet {
   InternetOptions^ get();
}

Property Value

InternetOptions settings.
See Also

Reference

SaveOptions Class
SaveOptions Members
InternetOptions Class


Jbig2 Property (SaveOptions)

Jbig2 Property (SaveOptions)

Accusoft.ImagXpressSdk Namespace > SaveOptions Class : Jbig2 Property
Gets the SaveOptionsJbig2 settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Jbig2 As SaveOptionsJbig2
'Usage

Dim instance As SaveOptions
Dim value As SaveOptionsJbig2

value = instance.Jbig2
public SaveOptionsJbig2 Jbig2 {get;}
public: __property SaveOptionsJbig2* get_Jbig2();
public:
property SaveOptionsJbig2^ Jbig2 {
   SaveOptionsJbig2^ get();
}

Property Value

A SaveOptionsJbig2 object which contains the image settings.
Remarks

Note: Available in Professional edition.

See Also

Reference

SaveOptions Class
SaveOptions Members


Jls Property

Jls Property

Accusoft.ImagXpressSdk Namespace > SaveOptions Class : Jls Property
Gets the SaveOptionsJls object settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Jls As SaveOptionsJls
'Usage

Dim instance As SaveOptions
Dim value As SaveOptionsJls

value = instance.Jls
public SaveOptionsJls Jls {get;}
public: __property SaveOptionsJls* get_Jls();
public:
property SaveOptionsJls^ Jls {
   SaveOptionsJls^ get();
}

Property Value

A SaveOptionsJls object which contains the image settings.
Remarks

Note: Available in Professional edition.

See Also

Reference

SaveOptions Class
SaveOptions Members
SaveOptionsJls Class


Jp2 Property

Jp2 Property

Accusoft.ImagXpressSdk Namespace > SaveOptions Class : Jp2 Property
Gets the SaveOptionsJp2 settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Jp2 As SaveOptionsJp2
'Usage

Dim instance As SaveOptions
Dim value As SaveOptionsJp2

value = instance.Jp2
public SaveOptionsJp2 Jp2 {get;}
public: __property SaveOptionsJp2* get_Jp2();
public:
property SaveOptionsJp2^ Jp2 {
   SaveOptionsJp2^ get();
}

Property Value

A SaveOptionsJp2 object which contains the image settings.
See Also

Reference

SaveOptions Class
SaveOptions Members
SaveOptionsJp2 Class


Jpeg Property (SaveOptions)

Jpeg Property (SaveOptions)

Accusoft.ImagXpressSdk Namespace > SaveOptions Class : Jpeg Property
Gets the SaveOptionsJpeg settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Jpeg As SaveOptionsJpeg
'Usage

Dim instance As SaveOptions
Dim value As SaveOptionsJpeg

value = instance.Jpeg
public SaveOptionsJpeg Jpeg {get;}
public: __property SaveOptionsJpeg* get_Jpeg();
public:
property SaveOptionsJpeg^ Jpeg {
   SaveOptionsJpeg^ get();
}

Property Value

A SaveOptionsJpeg object which contains the image settings.
See Also

Reference

SaveOptions Class
SaveOptions Members


JpegXR Property (SaveOptions)

JpegXR Property (SaveOptions)

Accusoft.ImagXpressSdk Namespace > SaveOptions Class : JpegXR Property
Gets the SaveOptionsJpegXR settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property JpegXR As SaveOptionsJpegXR
'Usage

Dim instance As SaveOptions
Dim value As SaveOptionsJpegXR

value = instance.JpegXR
public SaveOptionsJpegXR JpegXR {get;}
public: __property SaveOptionsJpegXR* get_JpegXR();
public:
property SaveOptionsJpegXR^ JpegXR {
   SaveOptionsJpegXR^ get();
}

Property Value

A SaveOptionsJpegXR object which contains the image settings.
Remarks

Note: Available in Professional edition.

See Also

Reference

SaveOptions Class
SaveOptions Members


LibraryNumberOfThreadsAllowed Property (SaveOptions)

LibraryNumberOfThreadsAllowed Property (SaveOptions)

Accusoft.ImagXpressSdk Namespace > SaveOptions Class : LibraryNumberOfThreadsAllowed Property
Gets and sets the number of threads allowed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LibraryNumberOfThreadsAllowed As Integer
'Usage

Dim instance As SaveOptions
Dim value As Integer

instance.LibraryNumberOfThreadsAllowed = value

value = instance.LibraryNumberOfThreadsAllowed
public int LibraryNumberOfThreadsAllowed {get; set;}
public: __property int get_LibraryNumberOfThreadsAllowed();
public: __property void set_LibraryNumberOfThreadsAllowed(
   int value
);
public:
property int LibraryNumberOfThreadsAllowed {
   int get();
   void set (    int value);
}
See Also

Reference

SaveOptions Class
SaveOptions Members


Ljp Property

Ljp Property

Accusoft.ImagXpressSdk Namespace > SaveOptions Class : Ljp Property
Gets the SaveOptionsLjp settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Ljp As SaveOptionsLjp
'Usage

Dim instance As SaveOptions
Dim value As SaveOptionsLjp

value = instance.Ljp
public SaveOptionsLjp Ljp {get;}
public: __property SaveOptionsLjp* get_Ljp();
public:
property SaveOptionsLjp^ Ljp {
   SaveOptionsLjp^ get();
}

Property Value

A SaveOptionsLjp object which contains the image settings.
Remarks

Note: Available in Professional edition.

See Also

Reference

SaveOptions Class
SaveOptions Members


Modca Property

Modca Property

Accusoft.ImagXpressSdk Namespace > SaveOptions Class : Modca Property
Gets the SaveOptionsModca settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Modca As SaveOptionsModca
'Usage

Dim instance As SaveOptions
Dim value As SaveOptionsModca

value = instance.Modca
public SaveOptionsModca Modca {get;}
public: __property SaveOptionsModca* get_Modca();
public:
property SaveOptionsModca^ Modca {
   SaveOptionsModca^ get();
}

Property Value

A SaveOptionsModca object which contains the image settings.
Remarks

Note: Available in Professional edition.

See Also

Reference

SaveOptions Class
SaveOptions Members


Pdf Property (SaveOptions)

Pdf Property (SaveOptions)

Accusoft.ImagXpressSdk Namespace > SaveOptions Class : Pdf Property
Gets the SaveOptionsPdf settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.")>
Public ReadOnly Property Pdf As SaveOptionsPdf
'Usage

Dim instance As SaveOptions
Dim value As SaveOptionsPdf

value = instance.Pdf
[Obsolete("PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.")]
public SaveOptionsPdf Pdf {get;}
[Obsolete("PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.")]
public: __property SaveOptionsPdf* get_Pdf();
[Obsolete("PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.")]
public:
property SaveOptionsPdf^ Pdf {
   SaveOptionsPdf^ get();
}

Property Value

A SaveOptionsPdf object which contains the image settings.
Remarks

Note: PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.

See Also

Reference

SaveOptions Class
SaveOptions Members


Pic Property (SaveOptions)

Pic Property (SaveOptions)

Accusoft.ImagXpressSdk Namespace > SaveOptions Class : Pic Property
Gets the SaveOptionsPic settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Pic As SaveOptionsPic
'Usage

Dim instance As SaveOptions
Dim value As SaveOptionsPic

value = instance.Pic
public SaveOptionsPic Pic {get;}
public: __property SaveOptionsPic* get_Pic();
public:
property SaveOptionsPic^ Pic {
   SaveOptionsPic^ get();
}

Property Value

A SaveOptionsPic object which contains the image settings.
See Also

Reference

SaveOptions Class
SaveOptions Members


Png Property

Png Property

Accusoft.ImagXpressSdk Namespace > SaveOptions Class : Png Property
Gets the SaveOptionsPng settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Png As SaveOptionsPng
'Usage

Dim instance As SaveOptions
Dim value As SaveOptionsPng

value = instance.Png
public SaveOptionsPng Png {get;}
public: __property SaveOptionsPng* get_Png();
public:
property SaveOptionsPng^ Png {
   SaveOptionsPng^ get();
}

Property Value

A SaveOptionsPng object which contains the image settings.
See Also

Reference

SaveOptions Class
SaveOptions Members


TargetProfileName Property (SaveOptions)

TargetProfileName Property (SaveOptions)

Accusoft.ImagXpressSdk Namespace > SaveOptions Class : TargetProfileName Property
Gets and sets the target profile’s filename.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TargetProfileName As String
'Usage

Dim instance As SaveOptions
Dim value As String

instance.TargetProfileName = value

value = instance.TargetProfileName
public string TargetProfileName {get; set;}
public: __property string* get_TargetProfileName();
public: __property void set_TargetProfileName(
   string* value
);
public:
property String^ TargetProfileName {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value which represents the target profile's filename.
Remarks

When the image is saved, the specified profile is applied to the image, and the resulting converted image is saved.

Note: Available in Professional edition.

See Also

Reference

SaveOptions Class
SaveOptions Members


Tiff Property (SaveOptions)

Tiff Property (SaveOptions)

Accusoft.ImagXpressSdk Namespace > SaveOptions Class : Tiff Property
Gets the SaveOptionsTiff settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Tiff As SaveOptionsTiff
'Usage

Dim instance As SaveOptions
Dim value As SaveOptionsTiff

value = instance.Tiff
public SaveOptionsTiff Tiff {get;}
public: __property SaveOptionsTiff* get_Tiff();
public:
property SaveOptionsTiff^ Tiff {
   SaveOptionsTiff^ get();
}

Property Value

A SaveOptionsTiff object which contains the image settings.
See Also

Reference

SaveOptions Class
SaveOptions Members


UseEmbeddedColorManagement Property (SaveOptions)

UseEmbeddedColorManagement Property (SaveOptions)

Accusoft.ImagXpressSdk Namespace > SaveOptions Class : UseEmbeddedColorManagement Property
Gets and sets an indicator if color management is used during saving.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property UseEmbeddedColorManagement As Boolean
'Usage

Dim instance As SaveOptions
Dim value As Boolean

instance.UseEmbeddedColorManagement = value

value = instance.UseEmbeddedColorManagement
public bool UseEmbeddedColorManagement {get; set;}
public: __property bool get_UseEmbeddedColorManagement();
public: __property void set_UseEmbeddedColorManagement(
   bool value
);
public:
property bool UseEmbeddedColorManagement {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true to apply the color profile associated with the imageX image to the saved image. Otherwise, set to false to not apply the color profile to the saved image.
Remarks

Note: Available in Professional edition.

See Also

Reference

SaveOptions Class
SaveOptions Members


Wsq Property

Wsq Property

Accusoft.ImagXpressSdk Namespace > SaveOptions Class : Wsq Property
Gets the SaveOptionsWsq settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Wsq As SaveOptionsWsq
'Usage

Dim instance As SaveOptions
Dim value As SaveOptionsWsq

value = instance.Wsq
public SaveOptionsWsq Wsq {get;}
public: __property SaveOptionsWsq* get_Wsq();
public:
property SaveOptionsWsq^ Wsq {
   SaveOptionsWsq^ get();
}

Property Value

A SaveOptionsWsq object which contains the image settings.
Remarks

Note: Available in Professional edition.

See Also

Reference

SaveOptions Class
SaveOptions Members


SaveOptionsAnnotations Class

SaveOptionsAnnotations Class
Members

Accusoft.ImagXpressSdk Namespace : SaveOptionsAnnotations Class
This class implements options required to save annotations with the image.
Object Model
SaveOptionsAnnotations ClassImageXView ClassImageX ClassMedical ClassRubberband ClassSprite ClassToolbar ClassTouch ClassImagXpress Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class SaveOptionsAnnotations
'Usage

Dim instance As SaveOptionsAnnotations
public class SaveOptionsAnnotations
public __gc class SaveOptionsAnnotations
public ref class SaveOptionsAnnotations
Remarks

Note: Available in Professional edition.

Inheritance Hierarchy

System.Object
Accusoft.ImagXpressSdk.SaveOptionsAnnotations

See Also

Reference

SaveOptionsAnnotations Members
Accusoft.ImagXpressSdk Namespace


SaveOptionsAnnotations Class Members

SaveOptionsAnnotations Class Members
Properties

Accusoft.ImagXpressSdk Namespace : SaveOptionsAnnotations Class

The following tables list the members exposed by SaveOptionsAnnotations.

Public Constructors
 | Name | Description
Public Constructor | SaveOptionsAnnotations Constructor | Initializes a new instance of the SaveOptionsAnnotations class.
Top
Public Properties
 | Name | Description
Public Property | Save | Gets and sets an indicator to save annotations with the image or not.
Public Property | View | Gets and sets the specific set of annotations to save with the image.
Top
See Also

Reference

SaveOptionsAnnotations Class
Accusoft.ImagXpressSdk Namespace


SaveOptionsAnnotations Constructor

SaveOptionsAnnotations Constructor

Accusoft.ImagXpressSdk Namespace > SaveOptionsAnnotations Class : SaveOptionsAnnotations Constructor
Initializes a new instance of the SaveOptionsAnnotations class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New SaveOptionsAnnotations()
public SaveOptionsAnnotations()
public: SaveOptionsAnnotations();
public:
SaveOptionsAnnotations();
Remarks

Note: Available in Professional edition.

See Also

Reference

SaveOptionsAnnotations Class
SaveOptionsAnnotations Members


SaveOptionsAnnotations Class Properties

SaveOptionsAnnotations Class Properties

Accusoft.ImagXpressSdk Namespace : SaveOptionsAnnotations Class

For a list of all members of this type, see SaveOptionsAnnotations members.

Public Properties
 | Name | Description
Public Property | Save | Gets and sets an indicator to save annotations with the image or not.
Public Property | View | Gets and sets the specific set of annotations to save with the image.
Top
See Also

Reference

SaveOptionsAnnotations Class
Accusoft.ImagXpressSdk Namespace


Save Property

Save Property

Accusoft.ImagXpressSdk Namespace > SaveOptionsAnnotations Class : Save Property
Gets and sets an indicator to save annotations with the image or not.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Save As Boolean
'Usage

Dim instance As SaveOptionsAnnotations
Dim value As Boolean

instance.Save = value

value = instance.Save
public bool Save {get; set;}
public: __property bool get_Save();
public: __property void set_Save(
   bool value
);
public:
property bool Save {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true to save the annotations with the image. Otherwise, false should be used.
Remarks

The default value is true.

Note: Available in Professional edition.

See Also

Reference

SaveOptionsAnnotations Class
SaveOptionsAnnotations Members


View Property

View Property

Accusoft.ImagXpressSdk Namespace > SaveOptionsAnnotations Class : View Property
Gets and sets the specific set of annotations to save with the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property View As ImageXView
'Usage

Dim instance As SaveOptionsAnnotations
Dim value As ImageXView

instance.View = value

value = instance.View
public ImageXView View {get; set;}
public: __property ImageXView* get_View();
public: __property void set_View(
   ImageXView* value
);
public:
property ImageXView^ View {
   ImageXView^ get();
   void set (    ImageXView^ value);
}

Property Value

An ImageXView object.
Remarks

If the Save property is set to true , then annotations are saved with the image.

This property specifies the set of annotations to save with the image. If this property is null, the last set of annotations that was active in the view is saved.

Note: Available in Professional edition.

See Also

Reference

SaveOptionsAnnotations Class
SaveOptionsAnnotations Members
Save Property


SaveOptionsBmp Class

SaveOptionsBmp Class
Members

Accusoft.ImagXpressSdk Namespace : SaveOptionsBmp Class
This class implements the SaveOptions for BMP files.
Object Model
SaveOptionsBmp Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class SaveOptionsBmp
'Usage

Dim instance As SaveOptionsBmp
public class SaveOptionsBmp
public __gc class SaveOptionsBmp
public ref class SaveOptionsBmp
Inheritance Hierarchy

System.Object
Accusoft.ImagXpressSdk.SaveOptionsBmp

See Also

Reference

SaveOptionsBmp Members
Accusoft.ImagXpressSdk Namespace


SaveOptionsBmp Class Members

SaveOptionsBmp Class Members
Properties

Accusoft.ImagXpressSdk Namespace : SaveOptionsBmp Class

The following tables list the members exposed by SaveOptionsBmp.

Public Constructors
 | Name | Description
Public Constructor | SaveOptionsBmp Constructor | Initializes a new instance of the SaveOptionsBmp class.
Top
Public Properties
 | Name | Description
Public Property | Compression | Gets and sets the compression type employed for saving a Bmp file. Only NoCompression or Rle compression are supported.
Top
See Also

Reference

SaveOptionsBmp Class
Accusoft.ImagXpressSdk Namespace


SaveOptionsBmp Constructor

SaveOptionsBmp Constructor

Accusoft.ImagXpressSdk Namespace > SaveOptionsBmp Class : SaveOptionsBmp Constructor
Initializes a new instance of the SaveOptionsBmp class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New SaveOptionsBmp()
public SaveOptionsBmp()
public: SaveOptionsBmp();
public:
SaveOptionsBmp();
See Also

Reference

SaveOptionsBmp Class
SaveOptionsBmp Members


SaveOptionsBmp Class Properties

SaveOptionsBmp Class Properties

Accusoft.ImagXpressSdk Namespace : SaveOptionsBmp Class

For a list of all members of this type, see SaveOptionsBmp members.

Public Properties
 | Name | Description
Public Property | Compression | Gets and sets the compression type employed for saving a Bmp file. Only NoCompression or Rle compression are supported.
Top
See Also

Reference

SaveOptionsBmp Class
Accusoft.ImagXpressSdk Namespace


Compression Property (SaveOptionsBmp)

Compression Property (SaveOptionsBmp)

Accusoft.ImagXpressSdk Namespace > SaveOptionsBmp Class : Compression Property
Gets and sets the compression type employed for saving a Bmp file. Only NoCompression or Rle compression are supported.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Compression As Compression
'Usage

Dim instance As SaveOptionsBmp
Dim value As Compression

instance.Compression = value

value = instance.Compression
public Compression Compression {get; set;}
public: __property Compression get_Compression();
public: __property void set_Compression(
   Compression value
);
public:
property Compression Compression {
   Compression get();
   void set (    Compression value);
}

Property Value

A Compression enumeration value.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | The supported values are Rle or No compression.
See Also

Reference

SaveOptionsBmp Class
SaveOptionsBmp Members


SaveOptionsDcx Class

SaveOptionsDcx Class
Members

Accusoft.ImagXpressSdk Namespace : SaveOptionsDcx Class
This class implements the SaveOptions for the DCX file format.
Object Model
SaveOptionsDcx Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class SaveOptionsDcx
'Usage

Dim instance As SaveOptionsDcx
public class SaveOptionsDcx
public __gc class SaveOptionsDcx
public ref class SaveOptionsDcx
Inheritance Hierarchy

System.Object
Accusoft.ImagXpressSdk.SaveOptionsDcx

See Also

Reference

SaveOptionsDcx Members
Accusoft.ImagXpressSdk Namespace


SaveOptionsDcx Class Members

SaveOptionsDcx Class Members
Properties

Accusoft.ImagXpressSdk Namespace : SaveOptionsDcx Class

The following tables list the members exposed by SaveOptionsDcx.

Public Constructors
 | Name | Description
Public Constructor | SaveOptionsDcx Constructor | Initializes a new instance of the SaveOptionsDcs class.
Top
Public Properties
 | Name | Description
Public Property | MultiPage | Gets and sets an indicator if the image is saved to a multi-page file.
Top
See Also

Reference

SaveOptionsDcx Class
Accusoft.ImagXpressSdk Namespace


SaveOptionsDcx Constructor

SaveOptionsDcx Constructor

Accusoft.ImagXpressSdk Namespace > SaveOptionsDcx Class : SaveOptionsDcx Constructor
Initializes a new instance of the SaveOptionsDcs class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New SaveOptionsDcx()
public SaveOptionsDcx()
public: SaveOptionsDcx();
public:
SaveOptionsDcx();
See Also

Reference

SaveOptionsDcx Class
SaveOptionsDcx Members


SaveOptionsDcx Class Properties

SaveOptionsDcx Class Properties

Accusoft.ImagXpressSdk Namespace : SaveOptionsDcx Class

For a list of all members of this type, see SaveOptionsDcx members.

Public Properties
 | Name | Description
Public Property | MultiPage | Gets and sets an indicator if the image is saved to a multi-page file.
Top
See Also

Reference

SaveOptionsDcx Class
Accusoft.ImagXpressSdk Namespace


MultiPage Property (SaveOptionsDcx)

MultiPage Property (SaveOptionsDcx)

Accusoft.ImagXpressSdk Namespace > SaveOptionsDcx Class : MultiPage Property
Gets and sets an indicator if the image is saved to a multi-page file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MultiPage As Boolean
'Usage

Dim instance As SaveOptionsDcx
Dim value As Boolean

instance.MultiPage = value

value = instance.MultiPage
public bool MultiPage {get; set;}
public: __property bool get_MultiPage();
public: __property void set_MultiPage(
   bool value
);
public:
property bool MultiPage {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true if the image is saved to a multi-page file. Otherwise, false should be used.
See Also

Reference

SaveOptionsDcx Class
SaveOptionsDcx Members


SaveOptionsExif Class

SaveOptionsExif Class
Members

Accusoft.ImagXpressSdk Namespace : SaveOptionsExif Class
This class implements the SaveOptions for the EXIF file format.
Object Model
SaveOptionsExif Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class SaveOptionsExif
'Usage

Dim instance As SaveOptionsExif
public class SaveOptionsExif
public __gc class SaveOptionsExif
public ref class SaveOptionsExif
Inheritance Hierarchy

System.Object
Accusoft.ImagXpressSdk.SaveOptionsExif

See Also

Reference

SaveOptionsExif Members
Accusoft.ImagXpressSdk Namespace


SaveOptionsExif Class Members

SaveOptionsExif Class Members
Properties

Accusoft.ImagXpressSdk Namespace : SaveOptionsExif Class

The following tables list the members exposed by SaveOptionsExif.

Public Constructors
 | Name | Description
Public Constructor | SaveOptionsExif Constructor | Initializes a new instance of the SaveOptionsExif class.
Top
Public Properties
 | Name | Description
Public Property | ThumbnailSize | Gets and sets the size of the thumbnail image to be saved.
Top
See Also

Reference

SaveOptionsExif Class
Accusoft.ImagXpressSdk Namespace


SaveOptionsExif Constructor

SaveOptionsExif Constructor

Accusoft.ImagXpressSdk Namespace > SaveOptionsExif Class : SaveOptionsExif Constructor
Initializes a new instance of the SaveOptionsExif class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New SaveOptionsExif()
public SaveOptionsExif()
public: SaveOptionsExif();
public:
SaveOptionsExif();
See Also

Reference

SaveOptionsExif Class
SaveOptionsExif Members


SaveOptionsExif Class Properties

SaveOptionsExif Class Properties

Accusoft.ImagXpressSdk Namespace : SaveOptionsExif Class

For a list of all members of this type, see SaveOptionsExif members.

Public Properties
 | Name | Description
Public Property | ThumbnailSize | Gets and sets the size of the thumbnail image to be saved.
Top
See Also

Reference

SaveOptionsExif Class
Accusoft.ImagXpressSdk Namespace


ThumbnailSize Property (SaveOptionsExif)

ThumbnailSize Property (SaveOptionsExif)

Accusoft.ImagXpressSdk Namespace > SaveOptionsExif Class : ThumbnailSize Property
Gets and sets the size of the thumbnail image to be saved.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ThumbnailSize As Integer
'Usage

Dim instance As SaveOptionsExif
Dim value As Integer

instance.ThumbnailSize = value

value = instance.ThumbnailSize
public int ThumbnailSize {get; set;}
public: __property int get_ThumbnailSize();
public: __property void set_ThumbnailSize(
   int value
);
public:
property int ThumbnailSize {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the size of the thumbnail image.
Remarks

The integer values have the following meaning.

Value | Thumbnail size
0 | No thumbnail
1 | 1/4 image size
2 | 1/8 image size
3 | 1/16 image size
5 or greater | Actual size in pixels*

*Note: This size must be smaller than or equal to the largest dimension of the image or an exception will be thrown.

See Also

Reference

SaveOptionsExif Class
SaveOptionsExif Members


SaveOptionsGif Class

SaveOptionsGif Class
Members

Accusoft.ImagXpressSdk Namespace : SaveOptionsGif Class
This class implements the SaveOptions for the GIF file format.
Object Model
SaveOptionsGif Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class SaveOptionsGif
'Usage

Dim instance As SaveOptionsGif
public class SaveOptionsGif
public __gc class SaveOptionsGif
public ref class SaveOptionsGif
Inheritance Hierarchy

System.Object
Accusoft.ImagXpressSdk.SaveOptionsGif

See Also

Reference

SaveOptionsGif Members
Accusoft.ImagXpressSdk Namespace


SaveOptionsGif Class Members

SaveOptionsGif Class Members
Properties

Accusoft.ImagXpressSdk Namespace : SaveOptionsGif Class

The following tables list the members exposed by SaveOptionsGif.

Public Constructors
 | Name | Description
Public Constructor | SaveOptionsGif Constructor | Initializes a new instance of the SaveOptionsGifData class.
Top
Public Properties
 | Name | Description
Public Property | Interlaced | Gets and sets an indicator if the image is saved to a GIF file with interlaced format.
Public Property | TransparencyColor | Gets and sets the color value used to represent transparency in the saved image.
Public Property | TransparencyMatch | Gets and sets the type of transparency match to perform.
Public Property | Type | Gets and sets the type of GIF file format.
Top
See Also

Reference

SaveOptionsGif Class
Accusoft.ImagXpressSdk Namespace


SaveOptionsGif Constructor

SaveOptionsGif Constructor

Accusoft.ImagXpressSdk Namespace > SaveOptionsGif Class : SaveOptionsGif Constructor
Initializes a new instance of the SaveOptionsGifData class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New SaveOptionsGif()
public SaveOptionsGif()
public: SaveOptionsGif();
public:
SaveOptionsGif();
See Also

Reference

SaveOptionsGif Class
SaveOptionsGif Members


SaveOptionsGif Class Properties

SaveOptionsGif Class Properties

Accusoft.ImagXpressSdk Namespace : SaveOptionsGif Class

For a list of all members of this type, see SaveOptionsGif members.

Public Properties
 | Name | Description
Public Property | Interlaced | Gets and sets an indicator if the image is saved to a GIF file with interlaced format.
Public Property | TransparencyColor | Gets and sets the color value used to represent transparency in the saved image.
Public Property | TransparencyMatch | Gets and sets the type of transparency match to perform.
Public Property | Type | Gets and sets the type of GIF file format.
Top
See Also

Reference

SaveOptionsGif Class
Accusoft.ImagXpressSdk Namespace


Interlaced Property (SaveOptionsGif)

Interlaced Property (SaveOptionsGif)

Accusoft.ImagXpressSdk Namespace > SaveOptionsGif Class : Interlaced Property
Gets and sets an indicator if the image is saved to a GIF file with interlaced format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Interlaced As Boolean
'Usage

Dim instance As SaveOptionsGif
Dim value As Boolean

instance.Interlaced = value

value = instance.Interlaced
public bool Interlaced {get; set;}
public: __property bool get_Interlaced();
public: __property void set_Interlaced(
   bool value
);
public:
property bool Interlaced {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true to save the image to a GIF file with interlaced format.
See Also

Reference

SaveOptionsGif Class
SaveOptionsGif Members


TransparencyColor Property (SaveOptionsGif)

TransparencyColor Property (SaveOptionsGif)

Accusoft.ImagXpressSdk Namespace > SaveOptionsGif Class : TransparencyColor Property
Gets and sets the color value used to represent transparency in the saved image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TransparencyColor As Color
'Usage

Dim instance As SaveOptionsGif
Dim value As Color

instance.TransparencyColor = value

value = instance.TransparencyColor
public Color TransparencyColor {get; set;}
public: __property Color get_TransparencyColor();
public: __property void set_TransparencyColor(
   Color value
);
public:
property Color TransparencyColor {
   Color get();
   void set (    Color value);
}

Property Value

A System.Drawing.Color value which represents transparency in the saved image.
See Also

Reference

SaveOptionsGif Class
SaveOptionsGif Members


TransparencyMatch Property (SaveOptionsGif)

TransparencyMatch Property (SaveOptionsGif)

Accusoft.ImagXpressSdk Namespace > SaveOptionsGif Class : TransparencyMatch Property
Gets and sets the type of transparency match to perform.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TransparencyMatch As TransparencyMatch
'Usage

Dim instance As SaveOptionsGif
Dim value As TransparencyMatch

instance.TransparencyMatch = value

value = instance.TransparencyMatch
public TransparencyMatch TransparencyMatch {get; set;}
public: __property TransparencyMatch get_TransparencyMatch();
public: __property void set_TransparencyMatch(
   TransparencyMatch value
);
public:
property TransparencyMatch TransparencyMatch {
   TransparencyMatch get();
   void set (    TransparencyMatch value);
}

Property Value

A TransparencyMatch enumeration value.
See Also

Reference

SaveOptionsGif Class
SaveOptionsGif Members


Type Property (SaveOptionsGif)

Type Property (SaveOptionsGif)

Accusoft.ImagXpressSdk Namespace > SaveOptionsGif Class : Type Property
Gets and sets the type of GIF file format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Type As GifType
'Usage

Dim instance As SaveOptionsGif
Dim value As GifType

instance.Type = value

value = instance.Type
public GifType Type {get; set;}
public: __property GifType get_Type();
public: __property void set_Type(
   GifType value
);
public:
property GifType Type {
   GifType get();
   void set (    GifType value);
}

Property Value

A GifType enumeration value.
See Also

Reference

SaveOptionsGif Class
SaveOptionsGif Members


SaveOptionsIcon Class

SaveOptionsIcon Class
Members

Accusoft.ImagXpressSdk Namespace : SaveOptionsIcon Class
This class implements SaveOptions for the Icon file format.
Object Model
SaveOptionsIcon Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class SaveOptionsIcon
'Usage

Dim instance As SaveOptionsIcon
public class SaveOptionsIcon
public __gc class SaveOptionsIcon
public ref class SaveOptionsIcon
Inheritance Hierarchy

System.Object
Accusoft.ImagXpressSdk.SaveOptionsIcon

See Also

Reference

SaveOptionsIcon Members
Accusoft.ImagXpressSdk Namespace


SaveOptionsIcon Class Members

SaveOptionsIcon Class Members
Properties

Accusoft.ImagXpressSdk Namespace : SaveOptionsIcon Class

The following tables list the members exposed by SaveOptionsIcon.

Public Constructors
 | Name | Description
Public Constructor | SaveOptionsIcon Constructor | Initializes a new instance of the SaveOptionsIconData class.
Top
Public Properties
 | Name | Description
Public Property | MultiPage | Gets and sets an indicator if the image is being saved to a multi-page file.
Top
See Also

Reference

SaveOptionsIcon Class
Accusoft.ImagXpressSdk Namespace


SaveOptionsIcon Constructor

SaveOptionsIcon Constructor

Accusoft.ImagXpressSdk Namespace > SaveOptionsIcon Class : SaveOptionsIcon Constructor
Initializes a new instance of the SaveOptionsIconData class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New SaveOptionsIcon()
public SaveOptionsIcon()
public: SaveOptionsIcon();
public:
SaveOptionsIcon();
See Also

Reference

SaveOptionsIcon Class
SaveOptionsIcon Members


SaveOptionsIcon Class Properties

SaveOptionsIcon Class Properties

Accusoft.ImagXpressSdk Namespace : SaveOptionsIcon Class

For a list of all members of this type, see SaveOptionsIcon members.

Public Properties
 | Name | Description
Public Property | MultiPage | Gets and sets an indicator if the image is being saved to a multi-page file.
Top
See Also

Reference

SaveOptionsIcon Class
Accusoft.ImagXpressSdk Namespace


MultiPage Property (SaveOptionsIcon)

MultiPage Property (SaveOptionsIcon)

Accusoft.ImagXpressSdk Namespace > SaveOptionsIcon Class : MultiPage Property
Gets and sets an indicator if the image is being saved to a multi-page file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MultiPage As Boolean
'Usage

Dim instance As SaveOptionsIcon
Dim value As Boolean

instance.MultiPage = value

value = instance.MultiPage
public bool MultiPage {get; set;}
public: __property bool get_MultiPage();
public: __property void set_MultiPage(
   bool value
);
public:
property bool MultiPage {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true to save the image to a multi-page file.
See Also

Reference

SaveOptionsIcon Class
SaveOptionsIcon Members


SaveOptionsJbig2 Class

SaveOptionsJbig2 Class
Members

Accusoft.ImagXpressSdk Namespace : SaveOptionsJbig2 Class
This class implements SaveOptions for the Jbig2 file format.
Object Model
SaveOptionsJbig2 Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class SaveOptionsJbig2
'Usage

Dim instance As SaveOptionsJbig2
public class SaveOptionsJbig2
public __gc class SaveOptionsJbig2
public ref class SaveOptionsJbig2
Remarks

Note: Available in Professional edition.

Inheritance Hierarchy

System.Object
Accusoft.ImagXpressSdk.SaveOptionsJbig2

See Also

Reference

SaveOptionsJbig2 Members
Accusoft.ImagXpressSdk Namespace


SaveOptionsJbig2 Class Members

SaveOptionsJbig2 Class Members
Properties

Accusoft.ImagXpressSdk Namespace : SaveOptionsJbig2 Class

The following tables list the members exposed by SaveOptionsJbig2.

Public Constructors
 | Name | Description
Public Constructor | SaveOptionsJbig2 Constructor | The main constructor which intializes a new instance of the SaveOptionsJbig2 class.
Top
Public Properties
 | Name | Description
Public Property | EncodeModeCompression | Gets and sets the encoding mode to use when creating the JBIG2 file.
Public Property | FileOrganization | Gets and sets the file organization of the JBIG2 bitstream.
Public Property | InvertedRegion | Gets and sets whether the bits should be inverted prior to symbol analysis.
Public Property | LoosenessCompression | Gets and sets how loose to be when matching symbols and compressing text using either of the lossy text region encode modes.
Top
See Also

Reference

SaveOptionsJbig2 Class
Accusoft.ImagXpressSdk Namespace


SaveOptionsJbig2 Constructor

SaveOptionsJbig2 Constructor

Accusoft.ImagXpressSdk Namespace > SaveOptionsJbig2 Class : SaveOptionsJbig2 Constructor
The main constructor which intializes a new instance of the SaveOptionsJbig2 class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New SaveOptionsJbig2()
public SaveOptionsJbig2()
public: SaveOptionsJbig2();
public:
SaveOptionsJbig2();
Remarks

Note: Available in Professional edition.

See Also

Reference

SaveOptionsJbig2 Class
SaveOptionsJbig2 Members


SaveOptionsJbig2 Class Properties

SaveOptionsJbig2 Class Properties

Accusoft.ImagXpressSdk Namespace : SaveOptionsJbig2 Class

For a list of all members of this type, see SaveOptionsJbig2 members.

Public Properties
 | Name | Description
Public Property | EncodeModeCompression | Gets and sets the encoding mode to use when creating the JBIG2 file.
Public Property | FileOrganization | Gets and sets the file organization of the JBIG2 bitstream.
Public Property | InvertedRegion | Gets and sets whether the bits should be inverted prior to symbol analysis.
Public Property | LoosenessCompression | Gets and sets how loose to be when matching symbols and compressing text using either of the lossy text region encode modes.
Top
See Also

Reference

SaveOptionsJbig2 Class
Accusoft.ImagXpressSdk Namespace


EncodeModeCompression Property

EncodeModeCompression Property

Accusoft.ImagXpressSdk Namespace > SaveOptionsJbig2 Class : EncodeModeCompression Property
Gets and sets the encoding mode to use when creating the JBIG2 file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property EncodeModeCompression As Jbig2EncodeModeCompression
'Usage

Dim instance As SaveOptionsJbig2
Dim value As Jbig2EncodeModeCompression

instance.EncodeModeCompression = value

value = instance.EncodeModeCompression
public Jbig2EncodeModeCompression EncodeModeCompression {get; set;}
public: __property Jbig2EncodeModeCompression get_EncodeModeCompression();
public: __property void set_EncodeModeCompression(
   Jbig2EncodeModeCompression value
);
public:
property Jbig2EncodeModeCompression EncodeModeCompression {
   Jbig2EncodeModeCompression get();
   void set (    Jbig2EncodeModeCompression value);
}

Property Value

A Jbig2EncodeModeCompression enumeration value.
Remarks

Text regions can be encoded as lossless or as lossy according to the encoding mode specified. The lossy modes use the value in LoosenessCompression to control how loose to be when matching symbols and thereby increase compression and reduce file size. Compression means loss, however, and a consequence of higher compression is an increased risk of errors in the reconstructed image. Specify a larger value of looseness to reduce the compressed file size; use a smaller value to reduce the errors, if any.

Halftone regions can be encoded lossy by specifying one of the lossy halftone encoding modes. Alternatively, they can be encoded lossless by using the lossless generic encoding mode.

Note: Available in Professional edition.

See Also

Reference

SaveOptionsJbig2 Class
SaveOptionsJbig2 Members


FileOrganization Property

FileOrganization Property

Accusoft.ImagXpressSdk Namespace > SaveOptionsJbig2 Class : FileOrganization Property
Gets and sets the file organization of the JBIG2 bitstream.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FileOrganization As Jbig2FileOrganization
'Usage

Dim instance As SaveOptionsJbig2
Dim value As Jbig2FileOrganization

instance.FileOrganization = value

value = instance.FileOrganization
public Jbig2FileOrganization FileOrganization {get; set;}
public: __property Jbig2FileOrganization get_FileOrganization();
public: __property void set_FileOrganization(
   Jbig2FileOrganization value
);
public:
property Jbig2FileOrganization FileOrganization {
   Jbig2FileOrganization get();
   void set (    Jbig2FileOrganization value);
}

Property Value

A Jbig2FileOrganization enumeration value.
Remarks

A JBIG2 file may be organized in two ways: for sequential access or for random access. Sequential organization is intended for streaming applications, where the decoder reads and decodes the file in order as the data is received.

Random access organization permits the decoder to know the entire file structure without having to read the entire file and then use that information to access the required data in a random-access fashion; this would be useful for applications such as decoding only odd-number pages, for example.

Note: Available in Professional edition.

See Also

Reference

SaveOptionsJbig2 Class
SaveOptionsJbig2 Members


InvertedRegion Property

InvertedRegion Property

Accusoft.ImagXpressSdk Namespace > SaveOptionsJbig2 Class : InvertedRegion Property
Gets and sets whether the bits should be inverted prior to symbol analysis.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property InvertedRegion As Boolean
'Usage

Dim instance As SaveOptionsJbig2
Dim value As Boolean

instance.InvertedRegion = value

value = instance.InvertedRegion
public bool InvertedRegion {get; set;}
public: __property bool get_InvertedRegion();
public: __property void set_InvertedRegion(
   bool value
);
public:
property bool InvertedRegion {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true to invert the bits prior to symbol analysis.
Remarks

Inverting the bits prior to symbol analysis may provide better compression if the text is represented as light bits against a dark background instead of the opposite. This setting is only used by the text encode modes.

Note: Available in Professional edition.

See Also

Reference

SaveOptionsJbig2 Class
SaveOptionsJbig2 Members


LoosenessCompression Property

LoosenessCompression Property

Accusoft.ImagXpressSdk Namespace > SaveOptionsJbig2 Class : LoosenessCompression Property
Gets and sets how loose to be when matching symbols and compressing text using either of the lossy text region encode modes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LoosenessCompression As Integer
'Usage

Dim instance As SaveOptionsJbig2
Dim value As Integer

instance.LoosenessCompression = value

value = instance.LoosenessCompression
public int LoosenessCompression {get; set;}
public: __property int get_LoosenessCompression();
public: __property void set_LoosenessCompression(
   int value
);
public:
property int LoosenessCompression {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the looseness of matching symbols and compressing text.
Remarks

The default results in the lossless compression.

This property provides the ability to set how loose to be when matching symbols and compressing text using either of the lossy text region encoding modes. The larger the number, the greater the compression and the greater the risk of introducing errors.

Set to 50 for a reasonably small file size and low risk of error.

If set to 0, the compression will be lossless.

Note: Available in Professional edition.

See Also

Reference

SaveOptionsJbig2 Class
SaveOptionsJbig2 Members


SaveOptionsJls Class

SaveOptionsJls Class
Members

Accusoft.ImagXpressSdk Namespace : SaveOptionsJls Class
This class implements SaveOptions for the JLS file format.
Object Model
SaveOptionsJls Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class SaveOptionsJls
'Usage

Dim instance As SaveOptionsJls
public class SaveOptionsJls
public __gc class SaveOptionsJls
public ref class SaveOptionsJls
Remarks

Note: Available in Professional edition.

Inheritance Hierarchy

System.Object
Accusoft.ImagXpressSdk.SaveOptionsJls

See Also

Reference

SaveOptionsJls Members
Accusoft.ImagXpressSdk Namespace


SaveOptionsJls Class Members

SaveOptionsJls Class Members
Properties

Accusoft.ImagXpressSdk Namespace : SaveOptionsJls Class

The following tables list the members exposed by SaveOptionsJls.

Public Constructors
 | Name | Description
Public Constructor | SaveOptionsJls Constructor | The main constructor which initializes a new instance of the SaveOptionsJls class.
Top
Public Properties
 | Name | Description
Public Property | Interleave | Gets and sets the interleave mode for multi-component images.
Public Property | MaxValue | Gets and sets the maximum value of the MaxValue argument.
Public Property | Near | Gets and sets the error tolerance for near-lossless compression.
Public Property | Point | Gets and sets the precision of the point transform.
Top
See Also

Reference

SaveOptionsJls Class
Accusoft.ImagXpressSdk Namespace


SaveOptionsJls Constructor

SaveOptionsJls Constructor

Accusoft.ImagXpressSdk Namespace > SaveOptionsJls Class : SaveOptionsJls Constructor
The main constructor which initializes a new instance of the SaveOptionsJls class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New SaveOptionsJls()
public SaveOptionsJls()
public: SaveOptionsJls();
public:
SaveOptionsJls();
Remarks

Note: Available in Professional edition.

See Also

Reference

SaveOptionsJls Class
SaveOptionsJls Members


SaveOptionsJls Class Properties

SaveOptionsJls Class Properties

Accusoft.ImagXpressSdk Namespace : SaveOptionsJls Class

For a list of all members of this type, see SaveOptionsJls members.

Public Properties
 | Name | Description
Public Property | Interleave | Gets and sets the interleave mode for multi-component images.
Public Property | MaxValue | Gets and sets the maximum value of the MaxValue argument.
Public Property | Near | Gets and sets the error tolerance for near-lossless compression.
Public Property | Point | Gets and sets the precision of the point transform.
Top
See Also

Reference

SaveOptionsJls Class
Accusoft.ImagXpressSdk Namespace


Interleave Property

Interleave Property

Accusoft.ImagXpressSdk Namespace > SaveOptionsJls Class : Interleave Property
Gets and sets the interleave mode for multi-component images.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Interleave As Integer
'Usage

Dim instance As SaveOptionsJls
Dim value As Integer

instance.Interleave = value

value = instance.Interleave
public int Interleave {get; set;}
public: __property int get_Interleave();
public: __property void set_Interleave(
   int value
);
public:
property int Interleave {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the mode for images.
Remarks

Typical settings for an RGB image for Interleave are 0 or 1.

When Interleave = 2 it is a specialized and intended for synthetic graphics or computer-generated compound documents (i.el, images likely to contain large flat areas that are common to all the components).

When compression is lossless (the Near parameter is zero), all three modes decompress to the same image.

When compression is near-lossless (the Near property is nonzero), all three modes meet the error tolerance for all reconstructed samples but will not decompress to identical binary images.

Note: Available in Professional edition.

See Also

Reference

SaveOptionsJls Class
SaveOptionsJls Members


MaxValue Property

MaxValue Property

Accusoft.ImagXpressSdk Namespace > SaveOptionsJls Class : MaxValue Property
Gets and sets the maximum value of the MaxValue argument.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MaxValue As Integer
'Usage

Dim instance As SaveOptionsJls
Dim value As Integer

instance.MaxValue = value

value = instance.MaxValue
public int MaxValue {get; set;}
public: __property int get_MaxValue();
public: __property void set_MaxValue(
   int value
);
public:
property int MaxValue {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the maximum value of any channel in the image.
Remarks

Note: This property affects the maximum value of the Near argument.

The default value is 0 which sets the compression to (2 ^Bits-Per-Channel) -1.

Valid values are 0 to (2 ^ Bits-Per-Channel) - 1.

Note: This value should be left to the default of 0 or set to the maximum of (2 ^ Bits-Per-Channel) - 1, unless the Red, Green, and Blue channels of all the pixels of the image have been analyzed. Any value less than the maximum channel value over all of the pixels will result in an error. A typical 24-bit photographic image with a standard brightness or higher will probably have a Red, Green or Blue value of 255 in at least one pixel in the image. Thus this property could not be anything other than 0 or 255.

A 24-bit RGB image is 8 bits for each channel (Red, Green, and Blue each being separate channels). Images with less than 24-bit per pixel are converted to 24-bit if they are color, 4 or 8 bit grayscale otherwise.

Note: Available in Professional edition.

See Also

Reference

SaveOptionsJls Class
SaveOptionsJls Members


Near Property

Near Property

Accusoft.ImagXpressSdk Namespace > SaveOptionsJls Class : Near Property
Gets and sets the error tolerance for near-lossless compression.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Near As Integer
'Usage

Dim instance As SaveOptionsJls
Dim value As Integer

instance.Near = value

value = instance.Near
public int Near {get; set;}
public: __property int get_Near();
public: __property void set_Near(
   int value
);
public:
property int Near {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the error tolerance.
Remarks

The Near parameter defines the error tolerance for near-lossless compression.

Valid values is zero (lossless), one (near lossless) to 255 (very lossy).

Generally, Near should be set to zero or a small positive number, perhaps 4 or 5 with higher numbers leading to ugly streaking artifacts.

Note: The value of MaxValue affects the maximum value of Near which is either 255 or MaxValue/2 (rounded up) whichever is lower.

Note: Available in Professional edition.

See Also

Reference

SaveOptionsJls Class
SaveOptionsJls Members


Point Property

Point Property

Accusoft.ImagXpressSdk Namespace > SaveOptionsJls Class : Point Property
Gets and sets the precision of the point transform.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Point As Integer
'Usage

Dim instance As SaveOptionsJls
Dim value As Integer

instance.Point = value

value = instance.Point
public int Point {get; set;}
public: __property int get_Point();
public: __property void set_Point(
   int value
);
public:
property int Point {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the precision of the point transform.
Remarks

The point transform is the number of least significant bits truncated from each input sample prior to compression. A point transform is another way to use the JPEG-LS algorithm in a near-lossless mode. Non-zero values denote near-lossless compression; the source image no longer is reconstructed exactly from the compressed image. The allowed range for Point is zero (default value) or 2 to 16. The JPEG-LS standard allows input samples to range from 2 to 16 bits (called the Precision), hence the allowed range for Point.

Precision is the number of bits used for each sample in an image. For example, a 24-bit image uses 8 bits for each red, green and blue sample in each pixel. Point should be no greater than the actual Precision of the input samples. This affects the bits per channel of an image. So if you had a 24-bit RGB image, it has 8-bits per R, G, and B channel. For example, if Point = 2, then the image is effectively 6-bits per channel (8 - 2 = 6). This affects the calculations for MaxValue and therefore the maximum value for Near.

Note: Available in Professional edition.

See Also

Reference

SaveOptionsJls Class
SaveOptionsJls Members


SaveOptionsJp2 Class

SaveOptionsJp2 Class
Members

Accusoft.ImagXpressSdk Namespace : SaveOptionsJp2 Class
This class implements SaveOptions for the JP2 file format.
Object Model
SaveOptionsJp2 Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class SaveOptionsJp2
'Usage

Dim instance As SaveOptionsJp2
public class SaveOptionsJp2
public __gc class SaveOptionsJp2
public ref class SaveOptionsJp2
Inheritance Hierarchy

System.Object
Accusoft.ImagXpressSdk.SaveOptionsJp2

See Also

Reference

SaveOptionsJp2 Members
Accusoft.ImagXpressSdk Namespace


SaveOptionsJp2 Class Members

SaveOptionsJp2 Class Members
Properties

Accusoft.ImagXpressSdk Namespace : SaveOptionsJp2 Class

The following tables list the members exposed by SaveOptionsJp2.

Public Constructors
 | Name | Description
Public Constructor | SaveOptionsJp2 Constructor | The main constructor which initializes a new SaveOptionsJp2 instance.
Top
Public Properties
 | Name | Description
Public Property | CompressSize | Gets and sets the desired file size in bytes.
Public Property | FavorSpeed | Gets or sets a value indicating whether to favor speed when compressing and subsequently decompressing an image or to favor the quality and size of the compressed image.
Public Property | Grayscale | Gets and sets if the image is saved as grayscale or color.
Public Property | Order | Gets and sets the progression order.
Public Property | PeakSignalToNoiseRatio | Gets and sets the peak signal to noise ratio.
Public Property | TileSize | Gets and sets the tile size.
Public Property | Type | Gets and sets the format of the file.
Top
See Also

Reference

SaveOptionsJp2 Class
Accusoft.ImagXpressSdk Namespace


SaveOptionsJp2 Constructor

SaveOptionsJp2 Constructor

Accusoft.ImagXpressSdk Namespace > SaveOptionsJp2 Class : SaveOptionsJp2 Constructor
The main constructor which initializes a new SaveOptionsJp2 instance.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New SaveOptionsJp2()
public SaveOptionsJp2()
public: SaveOptionsJp2();
public:
SaveOptionsJp2();
See Also

Reference

SaveOptionsJp2 Class
SaveOptionsJp2 Members


SaveOptionsJp2 Class Properties

SaveOptionsJp2 Class Properties

Accusoft.ImagXpressSdk Namespace : SaveOptionsJp2 Class

For a list of all members of this type, see SaveOptionsJp2 members.

Public Properties
 | Name | Description
Public Property | CompressSize | Gets and sets the desired file size in bytes.
Public Property | FavorSpeed | Gets or sets a value indicating whether to favor speed when compressing and subsequently decompressing an image or to favor the quality and size of the compressed image.
Public Property | Grayscale | Gets and sets if the image is saved as grayscale or color.
Public Property | Order | Gets and sets the progression order.
Public Property | PeakSignalToNoiseRatio | Gets and sets the peak signal to noise ratio.
Public Property | TileSize | Gets and sets the tile size.
Public Property | Type | Gets and sets the format of the file.
Top
See Also

Reference

SaveOptionsJp2 Class
Accusoft.ImagXpressSdk Namespace


CompressSize Property

CompressSize Property

Accusoft.ImagXpressSdk Namespace > SaveOptionsJp2 Class : CompressSize Property
Gets and sets the desired file size in bytes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CompressSize As Integer
'Usage

Dim instance As SaveOptionsJp2
Dim value As Integer

instance.CompressSize = value

value = instance.CompressSize
public int CompressSize {get; set;}
public: __property int get_CompressSize();
public: __property void set_CompressSize(
   int value
);
public:
property int CompressSize {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the desired file size in bytes.
Remarks

This property is only a request for a specific size when the Type = Lossy (0).

See Also

Reference

SaveOptionsJp2 Class
SaveOptionsJp2 Members


FavorSpeed Property

FavorSpeed Property

Accusoft.ImagXpressSdk Namespace > SaveOptionsJp2 Class : FavorSpeed Property
Gets or sets a value indicating whether to favor speed when compressing and subsequently decompressing an image or to favor the quality and size of the compressed image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
Public Property FavorSpeed As Boolean
'Usage

Dim instance As SaveOptionsJp2
Dim value As Boolean

instance.FavorSpeed = value

value = instance.FavorSpeed
[DefaultValue()]
public bool FavorSpeed {get; set;}
[DefaultValue()]
public: __property bool get_FavorSpeed();
public: __property void set_FavorSpeed(
   bool value
);
[DefaultValue()]
public:
property bool FavorSpeed {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true to save the image favoring the speed of compression and decompression. Otherwise, false should be used to favor quality and the size of the compressed image.
Remarks

The default value is false.

Setting this value to true can have as much as a 10% to 40% speed improvement in the compression and decompression of images. Note: that when this flag is set, lossless encoded files may become slightly larger and lossy rate-controlled encoded files may decode to slightly lower quality.

See Also

Reference

SaveOptionsJp2 Class
SaveOptionsJp2 Members


Grayscale Property (SaveOptionsJp2)

Grayscale Property (SaveOptionsJp2)

Accusoft.ImagXpressSdk Namespace > SaveOptionsJp2 Class : Grayscale Property
Gets and sets if the image is saved as grayscale or color.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Grayscale As Boolean
'Usage

Dim instance As SaveOptionsJp2
Dim value As Boolean

instance.Grayscale = value

value = instance.Grayscale
public bool Grayscale {get; set;}
public: __property bool get_Grayscale();
public: __property void set_Grayscale(
   bool value
);
public:
property bool Grayscale {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true to save the image as grayscale. Otherwise, false should be used.
See Also

Reference

SaveOptionsJp2 Class
SaveOptionsJp2 Members


Order Property (SaveOptionsJp2)

Order Property (SaveOptionsJp2)

Accusoft.ImagXpressSdk Namespace > SaveOptionsJp2 Class : Order Property
Gets and sets the progression order.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Order As ProgressionOrder
'Usage

Dim instance As SaveOptionsJp2
Dim value As ProgressionOrder

instance.Order = value

value = instance.Order
public ProgressionOrder Order {get; set;}
public: __property ProgressionOrder get_Order();
public: __property void set_Order(
   ProgressionOrder value
);
public:
property ProgressionOrder Order {
   ProgressionOrder get();
   void set (    ProgressionOrder value);
}

Property Value

A ProgressionOrder enumeration value.
Remarks

The progression order of the saved JPEG 2000 file is the order of the compressed image data for the layer, the component, the resolution and the position.

See Also

Reference

SaveOptionsJp2 Class
SaveOptionsJp2 Members


PeakSignalToNoiseRatio Property

PeakSignalToNoiseRatio Property

Accusoft.ImagXpressSdk Namespace > SaveOptionsJp2 Class : PeakSignalToNoiseRatio Property
Gets and sets the peak signal to noise ratio.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PeakSignalToNoiseRatio As Double
'Usage

Dim instance As SaveOptionsJp2
Dim value As Double

instance.PeakSignalToNoiseRatio = value

value = instance.PeakSignalToNoiseRatio
public double PeakSignalToNoiseRatio {get; set;}
public: __property double get_PeakSignalToNoiseRatio();
public: __property void set_PeakSignalToNoiseRatio(
   double value
);
public:
property double PeakSignalToNoiseRatio {
   double get();
   void set (    double value);
}

Property Value

A double value which represents the peak signal to noise ratio.
See Also

Reference

SaveOptionsJp2 Class
SaveOptionsJp2 Members


TileSize Property

TileSize Property

Accusoft.ImagXpressSdk Namespace > SaveOptionsJp2 Class : TileSize Property
Gets and sets the tile size.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TileSize As Size
'Usage

Dim instance As SaveOptionsJp2
Dim value As Size

instance.TileSize = value

value = instance.TileSize
public Size TileSize {get; set;}
public: __property Size get_TileSize();
public: __property void set_TileSize(
   Size value
);
public:
property Size TileSize {
   Size get();
   void set (    Size value);
}

Property Value

A System.Drawing.Size value which represents the tile size.
Remarks

The default value is zero.

The recommended non-zero setting is 64, with the width and height arguments of the System.Drawing.Size property usually being equal.

See Also

Reference

SaveOptionsJp2 Class
SaveOptionsJp2 Members
System.Drawing.Size


Type Property (SaveOptionsJp2)

Type Property (SaveOptionsJp2)

Accusoft.ImagXpressSdk Namespace > SaveOptionsJp2 Class : Type Property
Gets and sets the format of the file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Type As Jp2Type
'Usage

Dim instance As SaveOptionsJp2
Dim value As Jp2Type

instance.Type = value

value = instance.Type
public Jp2Type Type {get; set;}
public: __property Jp2Type get_Type();
public: __property void set_Type(
   Jp2Type value
);
public:
property Jp2Type Type {
   Jp2Type get();
   void set (    Jp2Type value);
}

Property Value

A Jp2Type enumeration value.
See Also

Reference

SaveOptionsJp2 Class
SaveOptionsJp2 Members


SaveOptionsJpeg Class

SaveOptionsJpeg Class
Members

Accusoft.ImagXpressSdk Namespace : SaveOptionsJpeg Class
This class implements SaveOptions for the JPEG file format.
Object Model
SaveOptionsJpeg Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class SaveOptionsJpeg
'Usage

Dim instance As SaveOptionsJpeg
public class SaveOptionsJpeg
public __gc class SaveOptionsJpeg
public ref class SaveOptionsJpeg
Inheritance Hierarchy

System.Object
Accusoft.ImagXpressSdk.SaveOptionsJpeg

See Also

Reference

SaveOptionsJpeg Members
Accusoft.ImagXpressSdk Namespace


SaveOptionsJpeg Class Members

SaveOptionsJpeg Class Members
Properties

Accusoft.ImagXpressSdk Namespace : SaveOptionsJpeg Class

The following tables list the members exposed by SaveOptionsJpeg.

Public Constructors
 | Name | Description
Public Constructor | SaveOptionsJpeg Constructor | The main constructor which initializes a new instance of the SaveOptionsJpeg class.
Top
Public Properties
 | Name | Description
Public Property | Chrominance | Gets and sets the chrominance quality setting for saving JPEG, TIFF-JPEG, and ePIC files.
Public Property | ColorSpace | Gets and sets the color space of the image being saved.
Public Property | Cosited | Gets and sets if the image should be compressed with cosited subsampling when saving.
Public Property | Grayscale | Gets and sets if the image is saved as a gray scale file.
Public Property | Luminance | Gets and sets the luminance quality.
Public Property | Progressive | Gets and sets if an image file is saved in standard or progressive format.
Public Property | SubSampling | Gets and sets the sub-sampling type.
Public Property | UseCmyk | Gets and sets whether the CMYK color space is used.
Public Property | UseOptimizedHuffmanCodes | Indicates whether to use optimized Huffman codes during encoding instead of using default Huffman codes.
Top
See Also

Reference

SaveOptionsJpeg Class
Accusoft.ImagXpressSdk Namespace


SaveOptionsJpeg Constructor

SaveOptionsJpeg Constructor

Accusoft.ImagXpressSdk Namespace > SaveOptionsJpeg Class : SaveOptionsJpeg Constructor
The main constructor which initializes a new instance of the SaveOptionsJpeg class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New SaveOptionsJpeg()
public SaveOptionsJpeg()
public: SaveOptionsJpeg();
public:
SaveOptionsJpeg();
See Also

Reference

SaveOptionsJpeg Class
SaveOptionsJpeg Members


SaveOptionsJpeg Class Properties

SaveOptionsJpeg Class Properties

Accusoft.ImagXpressSdk Namespace : SaveOptionsJpeg Class

For a list of all members of this type, see SaveOptionsJpeg members.

Public Properties
 | Name | Description
Public Property | Chrominance | Gets and sets the chrominance quality setting for saving JPEG, TIFF-JPEG, and ePIC files.
Public Property | ColorSpace | Gets and sets the color space of the image being saved.
Public Property | Cosited | Gets and sets if the image should be compressed with cosited subsampling when saving.
Public Property | Grayscale | Gets and sets if the image is saved as a gray scale file.
Public Property | Luminance | Gets and sets the luminance quality.
Public Property | Progressive | Gets and sets if an image file is saved in standard or progressive format.
Public Property | SubSampling | Gets and sets the sub-sampling type.
Public Property | UseCmyk | Gets and sets whether the CMYK color space is used.
Public Property | UseOptimizedHuffmanCodes | Indicates whether to use optimized Huffman codes during encoding instead of using default Huffman codes.
Top
See Also

Reference

SaveOptionsJpeg Class
Accusoft.ImagXpressSdk Namespace


Chrominance Property

Chrominance Property

Accusoft.ImagXpressSdk Namespace > SaveOptionsJpeg Class : Chrominance Property
Gets and sets the chrominance quality setting for saving JPEG, TIFF-JPEG, and ePIC files.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Chrominance As Integer
'Usage

Dim instance As SaveOptionsJpeg
Dim value As Integer

instance.Chrominance = value

value = instance.Chrominance
public int Chrominance {get; set;}
public: __property int get_Chrominance();
public: __property void set_Chrominance(
   int value
);
public:
property int Chrominance {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the chrominance quality setting.
Remarks

The default value is 10.

Valid Chrominance values range from 0 to 255.

A value of zero meaning no compression (maximum color quality) 255 means maximum image color compression (minimal image color quality.

JPEG and ePIC images are stored in a compressed format. Compression is lossy which means when saving JPEG or ePIC files, there is always data loss. Data loss is the result of JPEG and ePICs ability to achieve high compression ratios. Higher quality settings result in less compresion, while lower quality settings result in higher compression. Quality versus compression is a tradeoff. The image compression ratio can be adjusted by setting the Luminance and Chrominance properties.

The Lunimance property adjusts the luninance or grayscale quality and the Chrominance property adjusts the chrominance or color quality. Lower settings for these properties result in higher quality images with less compression. Higher settings for these properties result in lower quality images wit more compression.

For general use photographic type images, setting Luminance = 24 and Chrominance = 30 provides about a 12:1 image compression ratio with minimal data loss. Compression ratios and perceived image quality will vary depending on the image.

Note: Chrominance should always have a value equal or higher than Luminance.

See Also

Reference

SaveOptionsJpeg Class
SaveOptionsJpeg Members


ColorSpace Property (SaveOptionsJpeg)

ColorSpace Property (SaveOptionsJpeg)

Accusoft.ImagXpressSdk Namespace > SaveOptionsJpeg Class : ColorSpace Property
Gets and sets the color space of the image being saved.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("This property is deprecated, please use UseCmyk to specify CMYK.")>
Public Property ColorSpace As ColorSpace
'Usage

Dim instance As SaveOptionsJpeg
Dim value As ColorSpace

instance.ColorSpace = value

value = instance.ColorSpace
[Obsolete("This property is deprecated, please use UseCmyk to specify CMYK.")]
public ColorSpace ColorSpace {get; set;}
[Obsolete("This property is deprecated, please use UseCmyk to specify CMYK.")]
public: __property ColorSpace get_ColorSpace();
public: __property void set_ColorSpace(
   ColorSpace value
);
[Obsolete("This property is deprecated, please use UseCmyk to specify CMYK.")]
public:
property ColorSpace ColorSpace {
   ColorSpace get();
   void set (    ColorSpace value);
}

Property Value

A ColorSpace enumeration value.
See Also

Reference

SaveOptionsJpeg Class
SaveOptionsJpeg Members


Cosited Property (SaveOptionsJpeg)

Cosited Property (SaveOptionsJpeg)

Accusoft.ImagXpressSdk Namespace > SaveOptionsJpeg Class : Cosited Property
Gets and sets if the image should be compressed with cosited subsampling when saving.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Cosited As Boolean
'Usage

Dim instance As SaveOptionsJpeg
Dim value As Boolean

instance.Cosited = value

value = instance.Cosited
public bool Cosited {get; set;}
public: __property bool get_Cosited();
public: __property void set_Cosited(
   bool value
);
public:
property bool Cosited {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true if the image should be compressed with cosited subsampling when saving. Otherwise, false should be set.
Remarks

The default value is false.

See Also

Reference

SaveOptionsJpeg Class
SaveOptionsJpeg Members


Grayscale Property (SaveOptionsJpeg)

Grayscale Property (SaveOptionsJpeg)

Accusoft.ImagXpressSdk Namespace > SaveOptionsJpeg Class : Grayscale Property
Gets and sets if the image is saved as a gray scale file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Grayscale As Boolean
'Usage

Dim instance As SaveOptionsJpeg
Dim value As Boolean

instance.Grayscale = value

value = instance.Grayscale
public bool Grayscale {get; set;}
public: __property bool get_Grayscale();
public: __property void set_Grayscale(
   bool value
);
public:
property bool Grayscale {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true to save the image as a gray scale file. Otherwise, false is used.
See Also

Reference

SaveOptionsJpeg Class
SaveOptionsJpeg Members


Luminance Property

Luminance Property

Accusoft.ImagXpressSdk Namespace > SaveOptionsJpeg Class : Luminance Property
Gets and sets the luminance quality.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Luminance As Integer
'Usage

Dim instance As SaveOptionsJpeg
Dim value As Integer

instance.Luminance = value

value = instance.Luminance
public int Luminance {get; set;}
public: __property int get_Luminance();
public: __property void set_Luminance(
   int value
);
public:
property int Luminance {
   int get();
   void set (    int value);
}

Property Value

An integer value that represents the luminance quality.
Remarks

Valid values range from 0 to 255.

JPEG and ePIC images are stored in a compresed format. Compression is lossy which means when saving JPEG or ePIC files, there will be data loss. Data loss is the results of JPEG and ePICs ability to achieve high compression ratios. Higher quality settings result in less compression, while lower quality settings result in higher compression. Quality versus compression is a tradeoff. The image compression ratio can be adjused by setting the Luminance and Chrominance properties.

The Luminance property adjusts the luminance or gray scale quality and the Chrominance property adjusts the chrominance or color quality. Lower settings for these properties result in higher quality images with less compression. Higher settins for these properties result in lower quality images with more compression.

For general use photographic type images, the settings of Luminance = 24 and Chrominance = 30 provides about a 12:1 image copression ratio with minimal data loss. Compression ratios and perceived image quality varies depending on the image.

Note: As a rule, Chrominance should always have a value equal or higher than Luminance.

See Also

Reference

SaveOptionsJpeg Class
SaveOptionsJpeg Members


Progressive Property (SaveOptionsJpeg)

Progressive Property (SaveOptionsJpeg)

Accusoft.ImagXpressSdk Namespace > SaveOptionsJpeg Class : Progressive Property
Gets and sets if an image file is saved in standard or progressive format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Progressive As Boolean
'Usage

Dim instance As SaveOptionsJpeg
Dim value As Boolean

instance.Progressive = value

value = instance.Progressive
public bool Progressive {get; set;}
public: __property bool get_Progressive();
public: __property void set_Progressive(
   bool value
);
public:
property bool Progressive {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true to save in progressive format. Otherwise, false should be used.
See Also

Reference

SaveOptionsJpeg Class
SaveOptionsJpeg Members


SubSampling Property

SubSampling Property

Accusoft.ImagXpressSdk Namespace > SaveOptionsJpeg Class : SubSampling Property
Gets and sets the sub-sampling type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SubSampling As SubSampling
'Usage

Dim instance As SaveOptionsJpeg
Dim value As SubSampling

instance.SubSampling = value

value = instance.SubSampling
public SubSampling SubSampling {get; set;}
public: __property SubSampling get_SubSampling();
public: __property void set_SubSampling(
   SubSampling value
);
public:
property SubSampling SubSampling {
   SubSampling get();
   void set (    SubSampling value);
}

Property Value

A SubSampling enumeration value.
Remarks

This applies to JPEG, TIFF-JPEG, and ePIC files. This property is used in conjunction with the Chrominance and Luminance properties to control the compression ratio and the compressed image quality.

For higher quality and lower compression, set Luminance and Chrominance in the low teens and set SubSampling to 1:1:1 compression.

For higher compression and lower quality, set Luminance and Chrominance in the low 20's and set SubSampling to 4:1:1 compression.

See Also

Reference

SaveOptionsJpeg Class
SaveOptionsJpeg Members


UseCmyk Property (SaveOptionsJpeg)

UseCmyk Property (SaveOptionsJpeg)

Accusoft.ImagXpressSdk Namespace > SaveOptionsJpeg Class : UseCmyk Property
Gets and sets whether the CMYK color space is used.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property UseCmyk As Boolean
'Usage

Dim instance As SaveOptionsJpeg
Dim value As Boolean

instance.UseCmyk = value

value = instance.UseCmyk
public bool UseCmyk {get; set;}
public: __property bool get_UseCmyk();
public: __property void set_UseCmyk(
   bool value
);
public:
property bool UseCmyk {
   bool get();
   void set (    bool value);
}
Remarks
Note: SaveOptions.UseEmbeddedColorManagement must be set to true and SaveOptions.TargetProfileName must be set to save as CMYK.

The default value is false.

See Also

Reference

SaveOptionsJpeg Class
SaveOptionsJpeg Members


UseOptimizedHuffmanCodes Property

UseOptimizedHuffmanCodes Property

Accusoft.ImagXpressSdk Namespace > SaveOptionsJpeg Class : UseOptimizedHuffmanCodes Property
Indicates whether to use optimized Huffman codes during encoding instead of using default Huffman codes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property UseOptimizedHuffmanCodes As Boolean
'Usage

Dim instance As SaveOptionsJpeg
Dim value As Boolean

instance.UseOptimizedHuffmanCodes = value

value = instance.UseOptimizedHuffmanCodes
public bool UseOptimizedHuffmanCodes {get; set;}
public: __property bool get_UseOptimizedHuffmanCodes();
public: __property void set_UseOptimizedHuffmanCodes(
   bool value
);
public:
property bool UseOptimizedHuffmanCodes {
   bool get();
   void set (    bool value);
}
See Also

Reference

SaveOptionsJpeg Class
SaveOptionsJpeg Members


SaveOptionsJpegXR Class

SaveOptionsJpegXR Class
Members

Accusoft.ImagXpressSdk Namespace : SaveOptionsJpegXR Class
This class implements SaveOptions for the JPEG-XR file format.
Object Model
SaveOptionsJpegXR Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class SaveOptionsJpegXR
'Usage

Dim instance As SaveOptionsJpegXR
public class SaveOptionsJpegXR
public __gc class SaveOptionsJpegXR
public ref class SaveOptionsJpegXR
Remarks

Note: Available in Professional edition.

Inheritance Hierarchy

System.Object
Accusoft.ImagXpressSdk.SaveOptionsJpegXR

See Also

Reference

SaveOptionsJpegXR Members
Accusoft.ImagXpressSdk Namespace


SaveOptionsJpegXR Class Members

SaveOptionsJpegXR Class Members
Properties

Accusoft.ImagXpressSdk Namespace : SaveOptionsJpegXR Class

The following tables list the members exposed by SaveOptionsJpegXR.

Public Constructors
 | Name | Description
Public Constructor | SaveOptionsJpegXR Constructor | Initializes a new instance of the SaveOptionsJpegXRData class.
Top
Public Properties
 | Name | Description
Public Property | ChromaSubSampling | Gets or sets the kind of subsampling that will be used.
Public Property | FrequencyOrdering | Gets or sets whether frequency ordering is used.
Public Property | Quantization | Gets or sets the amount of quantization that will be used. The value can be any number from 1 through 255, where 1 indicates lossless compression and higher values indicate more and more lossy compression.
Top
See Also

Reference

SaveOptionsJpegXR Class
Accusoft.ImagXpressSdk Namespace


SaveOptionsJpegXR Constructor

SaveOptionsJpegXR Constructor

Accusoft.ImagXpressSdk Namespace > SaveOptionsJpegXR Class : SaveOptionsJpegXR Constructor
Initializes a new instance of the SaveOptionsJpegXRData class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New SaveOptionsJpegXR()
public SaveOptionsJpegXR()
public: SaveOptionsJpegXR();
public:
SaveOptionsJpegXR();
Remarks

Note: Available in Professional edition.

See Also

Reference

SaveOptionsJpegXR Class
SaveOptionsJpegXR Members


SaveOptionsJpegXR Class Properties

SaveOptionsJpegXR Class Properties

Accusoft.ImagXpressSdk Namespace : SaveOptionsJpegXR Class

For a list of all members of this type, see SaveOptionsJpegXR members.

Public Properties
 | Name | Description
Public Property | ChromaSubSampling | Gets or sets the kind of subsampling that will be used.
Public Property | FrequencyOrdering | Gets or sets whether frequency ordering is used.
Public Property | Quantization | Gets or sets the amount of quantization that will be used. The value can be any number from 1 through 255, where 1 indicates lossless compression and higher values indicate more and more lossy compression.
Top
See Also

Reference

SaveOptionsJpegXR Class
Accusoft.ImagXpressSdk Namespace


ChromaSubSampling Property

ChromaSubSampling Property

Accusoft.ImagXpressSdk Namespace > SaveOptionsJpegXR Class : ChromaSubSampling Property
Gets or sets the kind of subsampling that will be used.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ChromaSubSampling As JpegXRSubSampling
'Usage

Dim instance As SaveOptionsJpegXR
Dim value As JpegXRSubSampling

instance.ChromaSubSampling = value

value = instance.ChromaSubSampling
public JpegXRSubSampling ChromaSubSampling {get; set;}
public: __property JpegXRSubSampling get_ChromaSubSampling();
public: __property void set_ChromaSubSampling(
   JpegXRSubSampling value
);
public:
property JpegXRSubSampling ChromaSubSampling {
   JpegXRSubSampling get();
   void set (    JpegXRSubSampling value);
}

Property Value

The chroma subsampling is used to reduce the resolution of the color information in an image (as contrasted with the luminance information) prior to the quantization process.
Remarks

Note: Available in Professional edition.

See Also

Reference

SaveOptionsJpegXR Class
SaveOptionsJpegXR Members


FrequencyOrdering Property

FrequencyOrdering Property

Accusoft.ImagXpressSdk Namespace > SaveOptionsJpegXR Class : FrequencyOrdering Property
Gets or sets whether frequency ordering is used.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FrequencyOrdering As Boolean
'Usage

Dim instance As SaveOptionsJpegXR
Dim value As Boolean

instance.FrequencyOrdering = value

value = instance.FrequencyOrdering
public bool FrequencyOrdering {get; set;}
public: __property bool get_FrequencyOrdering();
public: __property void set_FrequencyOrdering(
   bool value
);
public:
property bool FrequencyOrdering {
   bool get();
   void set (    bool value);
}

Property Value

JPEG XR makes it possible to organize the compressed image data sequentially in either spatial or frequency order. Frequency order groups the data in three different frequencies and places it sequentially in the file starting with the low frequency information, followed by the middle frequency, and finally by the high frequency. The Frequency order makes it more efficient to decode a low resolution or thumbnail version of the image.
Remarks

Note: Available in Professional edition.

See Also

Reference

SaveOptionsJpegXR Class
SaveOptionsJpegXR Members


Quantization Property (SaveOptionsJpegXR)

Quantization Property (SaveOptionsJpegXR)

Accusoft.ImagXpressSdk Namespace > SaveOptionsJpegXR Class : Quantization Property
Gets or sets the amount of quantization that will be used. The value can be any number from 1 through 255, where 1 indicates lossless compression and higher values indicate more and more lossy compression.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Quantization As Integer
'Usage

Dim instance As SaveOptionsJpegXR
Dim value As Integer

instance.Quantization = value

value = instance.Quantization
public int Quantization {get; set;}
public: __property int get_Quantization();
public: __property void set_Quantization(
   int value
);
public:
property int Quantization {
   int get();
   void set (    int value);
}

Property Value

The quantization determines the desired image quality by defining the amount of similar image data that can be discarded. The quantization can range from 1-255. A value of one is used to specify lossless compression.
Remarks

Note: Available in Professional edition.

See Also

Reference

SaveOptionsJpegXR Class
SaveOptionsJpegXR Members


SaveOptionsLjp Class

SaveOptionsLjp Class
Members

Accusoft.ImagXpressSdk Namespace : SaveOptionsLjp Class
This class implements the SaveOptions for the LJP file format.
Object Model
SaveOptionsLjp Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class SaveOptionsLjp
'Usage

Dim instance As SaveOptionsLjp
public class SaveOptionsLjp
public __gc class SaveOptionsLjp
public ref class SaveOptionsLjp
Remarks

Note: Available in Professional edition.

Inheritance Hierarchy

System.Object
Accusoft.ImagXpressSdk.SaveOptionsLjp

See Also

Reference

SaveOptionsLjp Members
Accusoft.ImagXpressSdk Namespace


SaveOptionsLjp Class Members

SaveOptionsLjp Class Members
Properties

Accusoft.ImagXpressSdk Namespace : SaveOptionsLjp Class

The following tables list the members exposed by SaveOptionsLjp.

Public Constructors
 | Name | Description
Public Constructor | SaveOptionsLjp Constructor | The main constructor for initializing a new instance of the SaveOptionsLjp class.
Top
Public Properties
 | Name | Description
Public Property | Method | Gets and sets the method for saving the Ljp file.
Public Property | Order | Gets and sets the compression order.
Public Property | Predictor | Gets and sets the selection value which determines the prediction formula.
Public Property | Type | Gets and sets the type of compression for lossless JPEG.
Top
See Also

Reference

SaveOptionsLjp Class
Accusoft.ImagXpressSdk Namespace


SaveOptionsLjp Constructor

SaveOptionsLjp Constructor

Accusoft.ImagXpressSdk Namespace > SaveOptionsLjp Class : SaveOptionsLjp Constructor
The main constructor for initializing a new instance of the SaveOptionsLjp class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New SaveOptionsLjp()
public SaveOptionsLjp()
public: SaveOptionsLjp();
public:
SaveOptionsLjp();
Remarks

Note: Available in Professional edition.

See Also

Reference

SaveOptionsLjp Class
SaveOptionsLjp Members


SaveOptionsLjp Class Properties

SaveOptionsLjp Class Properties

Accusoft.ImagXpressSdk Namespace : SaveOptionsLjp Class

For a list of all members of this type, see SaveOptionsLjp members.

Public Properties
 | Name | Description
Public Property | Method | Gets and sets the method for saving the Ljp file.
Public Property | Order | Gets and sets the compression order.
Public Property | Predictor | Gets and sets the selection value which determines the prediction formula.
Public Property | Type | Gets and sets the type of compression for lossless JPEG.
Top
See Also

Reference

SaveOptionsLjp Class
Accusoft.ImagXpressSdk Namespace


Method Property

Method Property

Accusoft.ImagXpressSdk Namespace > SaveOptionsLjp Class : Method Property
Gets and sets the method for saving the Ljp file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Method As LjpMethod
'Usage

Dim instance As SaveOptionsLjp
Dim value As LjpMethod

instance.Method = value

value = instance.Method
public LjpMethod Method {get; set;}
public: __property LjpMethod get_Method();
public: __property void set_Method(
   LjpMethod value
);
public:
property LjpMethod Method {
   LjpMethod get();
   void set (    LjpMethod value);
}

Property Value

A LjpMethod enumeration value which determines the method type to use during saving.
Remarks

Note: Available in Professional edition.

See Also

Reference

SaveOptionsLjp Class
SaveOptionsLjp Members


Order Property (SaveOptionsLjp)

Order Property (SaveOptionsLjp)

Accusoft.ImagXpressSdk Namespace > SaveOptionsLjp Class : Order Property
Gets and sets the compression order.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Order As Integer
'Usage

Dim instance As SaveOptionsLjp
Dim value As Integer

instance.Order = value

value = instance.Order
public int Order {get; set;}
public: __property int get_Order();
public: __property void set_Order(
   int value
);
public:
property int Order {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the compression order to use when Method is set to LjpMethod.Ppmd.
Remarks

This property is the order or length of the context which is to be used to predict the image pixels. The best value for this property will depend upon the characteristics of the image to be compressed.

Valid values are 1 through 4.

Note: Available in Professional edition.

See Also

Reference

SaveOptionsLjp Class
SaveOptionsLjp Members


Predictor Property

Predictor Property

Accusoft.ImagXpressSdk Namespace > SaveOptionsLjp Class : Predictor Property
Gets and sets the selection value which determines the prediction formula.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Predictor As Integer
'Usage

Dim instance As SaveOptionsLjp
Dim value As Integer

instance.Predictor = value

value = instance.Predictor
public int Predictor {get; set;}
public: __property int get_Predictor();
public: __property void set_Predictor(
   int value
);
public:
property int Predictor {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the prediction forumla to use when Method is set to LjpMethod.Jpeg.
Remarks

There is no way other than by trial and error to determine which selection value will provide the best compression. Most applications use a default value of 1.

Valid values are 1 through 7.

Note: Available in Professional edition.

See Also

Reference

SaveOptionsLjp Class
SaveOptionsLjp Members


Type Property (SaveOptionsLjp)

Type Property (SaveOptionsLjp)

Accusoft.ImagXpressSdk Namespace > SaveOptionsLjp Class : Type Property
Gets and sets the type of compression for lossless JPEG.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Type As LjpType
'Usage

Dim instance As SaveOptionsLjp
Dim value As LjpType

instance.Type = value

value = instance.Type
public LjpType Type {get; set;}
public: __property LjpType get_Type();
public: __property void set_Type(
   LjpType value
);
public:
property LjpType Type {
   LjpType get();
   void set (    LjpType value);
}

Property Value

A LjpType enumeration value.
Remarks

Note: Available in Professional edition.

See Also

Reference

SaveOptionsLjp Class
SaveOptionsLjp Members


SaveOptionsModca Class

SaveOptionsModca Class
Members

Accusoft.ImagXpressSdk Namespace : SaveOptionsModca Class
This class implements the SaveOptions for the Modca file format.
Object Model
SaveOptionsModca Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class SaveOptionsModca
'Usage

Dim instance As SaveOptionsModca
public class SaveOptionsModca
public __gc class SaveOptionsModca
public ref class SaveOptionsModca
Remarks

Note: Available in Professional edition.

Inheritance Hierarchy

System.Object
Accusoft.ImagXpressSdk.SaveOptionsModca

See Also

Reference

SaveOptionsModca Members
Accusoft.ImagXpressSdk Namespace


SaveOptionsModca Class Members

SaveOptionsModca Class Members
Properties

Accusoft.ImagXpressSdk Namespace : SaveOptionsModca Class

The following tables list the members exposed by SaveOptionsModca.

Public Constructors
 | Name | Description
Public Constructor | SaveOptionsModca Constructor | Initializes a new instance of the SaveOptionsModca class.
Top
Public Properties
 | Name | Description
Public Property | DocumentName | Gets and sets the Modca tag document name.
Public Property | MultiPage | Gets and sets if the image is being saved to a multi-page file.
Top
See Also

Reference

SaveOptionsModca Class
Accusoft.ImagXpressSdk Namespace


SaveOptionsModca Constructor

SaveOptionsModca Constructor

Accusoft.ImagXpressSdk Namespace > SaveOptionsModca Class : SaveOptionsModca Constructor
Initializes a new instance of the SaveOptionsModca class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New SaveOptionsModca()
public SaveOptionsModca()
public: SaveOptionsModca();
public:
SaveOptionsModca();
Remarks

Note: Available in Professional edition.

See Also

Reference

SaveOptionsModca Class
SaveOptionsModca Members


SaveOptionsModca Class Properties

SaveOptionsModca Class Properties

Accusoft.ImagXpressSdk Namespace : SaveOptionsModca Class

For a list of all members of this type, see SaveOptionsModca members.

Public Properties
 | Name | Description
Public Property | DocumentName | Gets and sets the Modca tag document name.
Public Property | MultiPage | Gets and sets if the image is being saved to a multi-page file.
Top
See Also

Reference

SaveOptionsModca Class
Accusoft.ImagXpressSdk Namespace


DocumentName Property

DocumentName Property

Accusoft.ImagXpressSdk Namespace > SaveOptionsModca Class : DocumentName Property
Gets and sets the Modca tag document name.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DocumentName As String
'Usage

Dim instance As SaveOptionsModca
Dim value As String

instance.DocumentName = value

value = instance.DocumentName
public string DocumentName {get; set;}
public: __property string* get_DocumentName();
public: __property void set_DocumentName(
   string* value
);
public:
property String^ DocumentName {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value which represents the Modca tag name to be saved.
Remarks

Note: Available in Professional edition.

See Also

Reference

SaveOptionsModca Class
SaveOptionsModca Members


MultiPage Property (SaveOptionsModca)

MultiPage Property (SaveOptionsModca)

Accusoft.ImagXpressSdk Namespace > SaveOptionsModca Class : MultiPage Property
Gets and sets if the image is being saved to a multi-page file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MultiPage As Boolean
'Usage

Dim instance As SaveOptionsModca
Dim value As Boolean

instance.MultiPage = value

value = instance.MultiPage
public bool MultiPage {get; set;}
public: __property bool get_MultiPage();
public: __property void set_MultiPage(
   bool value
);
public:
property bool MultiPage {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true to save the Modca file to a multi-page file. Otherwise, false is used.
See Also

Reference

SaveOptionsModca Class
SaveOptionsModca Members


SaveOptionsPdf Class

SaveOptionsPdf Class
Members

Accusoft.ImagXpressSdk Namespace : SaveOptionsPdf Class
This class implements the SaveOptions for PDF files.
Object Model
SaveOptionsPdf Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.")>
Public Class SaveOptionsPdf
'Usage

Dim instance As SaveOptionsPdf
[Obsolete("PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.")]
public class SaveOptionsPdf
[Obsolete("PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.")]
public __gc class SaveOptionsPdf
[Obsolete("PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.")]
public ref class SaveOptionsPdf
Remarks

Note: PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.

Inheritance Hierarchy

System.Object
Accusoft.ImagXpressSdk.SaveOptionsPdf

See Also

Reference

SaveOptionsPdf Members
Accusoft.ImagXpressSdk Namespace


SaveOptionsPdf Class Members

SaveOptionsPdf Class Members
Properties

Accusoft.ImagXpressSdk Namespace : SaveOptionsPdf Class

The following tables list the members exposed by SaveOptionsPdf.

Public Constructors
 | Name | Description
Public Constructor | SaveOptionsPdf Constructor | The main constructor which initializes a new instance of the SaveOptionsPdf class.
Top
Public Properties
 | Name | Description
Public Property | ColorSpace | Gets and sets the color space of the PDF image being saved.
Public Property | Compression | Gets and sets the compression type employed for saving a PDF file. The supported values are Group3Fax1d, Group3Fax2d, Group4, Jpeg, Jbig2, Jpeg2000, or no compression.
Public Property | MultiPage | Gets and sets if the image is saved to a multi-page file.
Public Property | SwapBlackAndWhite | Gets and sets a pixel value of zero to black or white.
Public Property | UseJpegCmyk | Gets and sets whether the CMYK color space is used for JPEG-compressed PDF.
Top
See Also

Reference

SaveOptionsPdf Class
Accusoft.ImagXpressSdk Namespace


SaveOptionsPdf Constructor

SaveOptionsPdf Constructor

Accusoft.ImagXpressSdk Namespace > SaveOptionsPdf Class : SaveOptionsPdf Constructor
The main constructor which initializes a new instance of the SaveOptionsPdf class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.")>
Public Function New()
'Usage

Dim instance As New SaveOptionsPdf()
[Obsolete("PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.")]
public SaveOptionsPdf()
[Obsolete("PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.")]
public: SaveOptionsPdf();
[Obsolete("PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.")]
public:
SaveOptionsPdf();
Remarks

Note: PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.

See Also

Reference

SaveOptionsPdf Class
SaveOptionsPdf Members


SaveOptionsPdf Class Properties

SaveOptionsPdf Class Properties

Accusoft.ImagXpressSdk Namespace : SaveOptionsPdf Class

For a list of all members of this type, see SaveOptionsPdf members.

Public Properties
 | Name | Description
Public Property | ColorSpace | Gets and sets the color space of the PDF image being saved.
Public Property | Compression | Gets and sets the compression type employed for saving a PDF file. The supported values are Group3Fax1d, Group3Fax2d, Group4, Jpeg, Jbig2, Jpeg2000, or no compression.
Public Property | MultiPage | Gets and sets if the image is saved to a multi-page file.
Public Property | SwapBlackAndWhite | Gets and sets a pixel value of zero to black or white.
Public Property | UseJpegCmyk | Gets and sets whether the CMYK color space is used for JPEG-compressed PDF.
Top
See Also

Reference

SaveOptionsPdf Class
Accusoft.ImagXpressSdk Namespace


ColorSpace Property (SaveOptionsPdf)

ColorSpace Property (SaveOptionsPdf)

Accusoft.ImagXpressSdk Namespace > SaveOptionsPdf Class : ColorSpace Property
Gets and sets the color space of the PDF image being saved.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("This property is deprecated, please use UseJpegCmyk to specify CMYK.
 PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.")>
Public Property ColorSpace As ColorSpace
'Usage

Dim instance As SaveOptionsPdf
Dim value As ColorSpace

instance.ColorSpace = value

value = instance.ColorSpace
[Obsolete("This property is deprecated, please use UseJpegCmyk to specify CMYK.
 PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.")]
public ColorSpace ColorSpace {get; set;}
[Obsolete("This property is deprecated, please use UseJpegCmyk to specify CMYK.
 PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.")]
public: __property ColorSpace get_ColorSpace();
public: __property void set_ColorSpace(
   ColorSpace value
);
[Obsolete("This property is deprecated, please use UseJpegCmyk to specify CMYK.
 PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.")]
public:
property ColorSpace ColorSpace {
   ColorSpace get();
   void set (    ColorSpace value);
}

Property Value

A ColorSpace enumeration value.
Remarks

Note: PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.

See Also

Reference

SaveOptionsPdf Class
SaveOptionsPdf Members


Compression Property (SaveOptionsPdf)

Compression Property (SaveOptionsPdf)

Accusoft.ImagXpressSdk Namespace > SaveOptionsPdf Class : Compression Property
Gets and sets the compression type employed for saving a PDF file. The supported values are Group3Fax1d, Group3Fax2d, Group4, Jpeg, Jbig2, Jpeg2000, or no compression.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.")>
Public Property Compression As Compression
'Usage

Dim instance As SaveOptionsPdf
Dim value As Compression

instance.Compression = value

value = instance.Compression
[Obsolete("PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.")]
public Compression Compression {get; set;}
[Obsolete("PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.")]
public: __property Compression get_Compression();
public: __property void set_Compression(
   Compression value
);
[Obsolete("PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.")]
public:
property Compression Compression {
   Compression get();
   void set (    Compression value);
}

Property Value

A Compression enumeration value.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | The supported values are Group3Fax1d, Group3Fax2d, Group4, Jpeg, Jbig2, Jpeg2000, or no compression.
Remarks

Note: PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.

See Also

Reference

SaveOptionsPdf Class
SaveOptionsPdf Members


MultiPage Property (SaveOptionsPdf)

MultiPage Property (SaveOptionsPdf)

Accusoft.ImagXpressSdk Namespace > SaveOptionsPdf Class : MultiPage Property
Gets and sets if the image is saved to a multi-page file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.")>
Public Property MultiPage As Boolean
'Usage

Dim instance As SaveOptionsPdf
Dim value As Boolean

instance.MultiPage = value

value = instance.MultiPage
[Obsolete("PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.")]
public bool MultiPage {get; set;}
[Obsolete("PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.")]
public: __property bool get_MultiPage();
public: __property void set_MultiPage(
   bool value
);
[Obsolete("PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.")]
public:
property bool MultiPage {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true if the image is saved to a multi-page file. Otherwise, false is used.
Remarks

Note: PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.

See Also

Reference

SaveOptionsPdf Class
SaveOptionsPdf Members


SwapBlackAndWhite Property (SaveOptionsPdf)

SwapBlackAndWhite Property (SaveOptionsPdf)

Accusoft.ImagXpressSdk Namespace > SaveOptionsPdf Class : SwapBlackAndWhite Property
Gets and sets a pixel value of zero to black or white.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.")>
Public Property SwapBlackAndWhite As Boolean
'Usage

Dim instance As SaveOptionsPdf
Dim value As Boolean

instance.SwapBlackAndWhite = value

value = instance.SwapBlackAndWhite
[Obsolete("PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.")]
public bool SwapBlackAndWhite {get; set;}
[Obsolete("PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.")]
public: __property bool get_SwapBlackAndWhite();
public: __property void set_SwapBlackAndWhite(
   bool value
);
[Obsolete("PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.")]
public:
property bool SwapBlackAndWhite {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true to define black = 1 and white = 0. Otherwise, false determines that white = 1 and black = 0.
Remarks

Note: This property pertains only to G4 Compression types.

Note: PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.

See Also

Reference

SaveOptionsPdf Class
SaveOptionsPdf Members


UseJpegCmyk Property

UseJpegCmyk Property

Accusoft.ImagXpressSdk Namespace > SaveOptionsPdf Class : UseJpegCmyk Property
Gets and sets whether the CMYK color space is used for JPEG-compressed PDF.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.")>
Public Property UseJpegCmyk As Boolean
'Usage

Dim instance As SaveOptionsPdf
Dim value As Boolean

instance.UseJpegCmyk = value

value = instance.UseJpegCmyk
[Obsolete("PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.")]
public bool UseJpegCmyk {get; set;}
[Obsolete("PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.")]
public: __property bool get_UseJpegCmyk();
public: __property void set_UseJpegCmyk(
   bool value
);
[Obsolete("PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.")]
public:
property bool UseJpegCmyk {
   bool get();
   void set (    bool value);
}
Remarks
Note: SaveOptions.UseEmbeddedColorManagement must be set to true and SaveOptions.TargetProfileName must be set to save as CMYK. Also, Compression must be set to Jpeg.

The default value is false.

Note: PDF support is deprecated in ImagXpress, please use PDF Xpress instead for PDF support.

See Also

Reference

SaveOptionsPdf Class
SaveOptionsPdf Members


SaveOptionsPic Class

SaveOptionsPic Class
Members

Accusoft.ImagXpressSdk Namespace : SaveOptionsPic Class
This class implements SaveOptions for the PIC (Pegasus Imaging Corporation) file format.
Object Model
SaveOptionsPic Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class SaveOptionsPic
'Usage

Dim instance As SaveOptionsPic
public class SaveOptionsPic
public __gc class SaveOptionsPic
public ref class SaveOptionsPic
Inheritance Hierarchy

System.Object
Accusoft.ImagXpressSdk.SaveOptionsPic

See Also

Reference

SaveOptionsPic Members
Accusoft.ImagXpressSdk Namespace


SaveOptionsPic Class Members

SaveOptionsPic Class Members
Properties

Accusoft.ImagXpressSdk Namespace : SaveOptionsPic Class

The following tables list the members exposed by SaveOptionsPic.

Public Constructors
 | Name | Description
Public Constructor | SaveOptionsPic Constructor | The main constructor which initializes a new instance of the SaveOptionsPic class.
Top
Public Properties
 | Name | Description
Public Property | Password | Gets and sets the password for the destination ePIC (.PIC) file format.
Top
See Also

Reference

SaveOptionsPic Class
Accusoft.ImagXpressSdk Namespace


SaveOptionsPic Constructor

SaveOptionsPic Constructor

Accusoft.ImagXpressSdk Namespace > SaveOptionsPic Class : SaveOptionsPic Constructor
The main constructor which initializes a new instance of the SaveOptionsPic class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New SaveOptionsPic()
public SaveOptionsPic()
public: SaveOptionsPic();
public:
SaveOptionsPic();
See Also

Reference

SaveOptionsPic Class
SaveOptionsPic Members


SaveOptionsPic Class Properties

SaveOptionsPic Class Properties

Accusoft.ImagXpressSdk Namespace : SaveOptionsPic Class

For a list of all members of this type, see SaveOptionsPic members.

Public Properties
 | Name | Description
Public Property | Password | Gets and sets the password for the destination ePIC (.PIC) file format.
Top
See Also

Reference

SaveOptionsPic Class
Accusoft.ImagXpressSdk Namespace


Password Property (SaveOptionsPic)

Password Property (SaveOptionsPic)

Accusoft.ImagXpressSdk Namespace > SaveOptionsPic Class : Password Property
Gets and sets the password for the destination ePIC (.PIC) file format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Password As String
'Usage

Dim instance As SaveOptionsPic
Dim value As String

instance.Password = value

value = instance.Password
public string Password {get; set;}
public: __property string* get_Password();
public: __property void set_Password(
   string* value
);
public:
property String^ Password {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value which represents the password for the destination PIC file.
Remarks

Note: The password can only be up to 8 characters.

See Also

Reference

SaveOptionsPic Class
SaveOptionsPic Members


SaveOptionsPng Class

SaveOptionsPng Class
Members

Accusoft.ImagXpressSdk Namespace : SaveOptionsPng Class
This class implements SaveOptions for the PNG file format.
Object Model
SaveOptionsPng Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class SaveOptionsPng
'Usage

Dim instance As SaveOptionsPng
public class SaveOptionsPng
public __gc class SaveOptionsPng
public ref class SaveOptionsPng
Inheritance Hierarchy

System.Object
Accusoft.ImagXpressSdk.SaveOptionsPng

See Also

Reference

SaveOptionsPng Members
Accusoft.ImagXpressSdk Namespace


SaveOptionsPng Class Members

SaveOptionsPng Class Members
Properties

Accusoft.ImagXpressSdk Namespace : SaveOptionsPng Class

The following tables list the members exposed by SaveOptionsPng.

Public Constructors
 | Name | Description
Public Constructor | SaveOptionsPng Constructor | The main constructor which initializes a new instance of the SaveOptionsPng class.
Top
Public Properties
 | Name | Description
Public Property | Filter | Gets and sets the filter used for PNG compression.
Public Property | Interlaced | Gets and sets if the image is saved in an interlaced or non-interlaced format.
Public Property | TransparencyColor | Gets and sets the color to be used to represent transparency in the stored image.
Public Property | TransparencyMatch | Gets and sets the type of TransparencyMatch to employ.
Top
See Also

Reference

SaveOptionsPng Class
Accusoft.ImagXpressSdk Namespace


SaveOptionsPng Constructor

SaveOptionsPng Constructor

Accusoft.ImagXpressSdk Namespace > SaveOptionsPng Class : SaveOptionsPng Constructor
The main constructor which initializes a new instance of the SaveOptionsPng class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New SaveOptionsPng()
public SaveOptionsPng()
public: SaveOptionsPng();
public:
SaveOptionsPng();
See Also

Reference

SaveOptionsPng Class
SaveOptionsPng Members


SaveOptionsPng Class Properties

SaveOptionsPng Class Properties

Accusoft.ImagXpressSdk Namespace : SaveOptionsPng Class

For a list of all members of this type, see SaveOptionsPng members.

Public Properties
 | Name | Description
Public Property | Filter | Gets and sets the filter used for PNG compression.
Public Property | Interlaced | Gets and sets if the image is saved in an interlaced or non-interlaced format.
Public Property | TransparencyColor | Gets and sets the color to be used to represent transparency in the stored image.
Public Property | TransparencyMatch | Gets and sets the type of TransparencyMatch to employ.
Top
See Also

Reference

SaveOptionsPng Class
Accusoft.ImagXpressSdk Namespace


Filter Property

Filter Property

Accusoft.ImagXpressSdk Namespace > SaveOptionsPng Class : Filter Property
Gets and sets the filter used for PNG compression.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Filter As PngFilter
'Usage

Dim instance As SaveOptionsPng
Dim value As PngFilter

instance.Filter = value

value = instance.Filter
public PngFilter Filter {get; set;}
public: __property PngFilter get_Filter();
public: __property void set_Filter(
   PngFilter value
);
public:
property PngFilter Filter {
   PngFilter get();
   void set (    PngFilter value);
}
See Also

Reference

SaveOptionsPng Class
SaveOptionsPng Members


Interlaced Property (SaveOptionsPng)

Interlaced Property (SaveOptionsPng)

Accusoft.ImagXpressSdk Namespace > SaveOptionsPng Class : Interlaced Property
Gets and sets if the image is saved in an interlaced or non-interlaced format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Interlaced As Boolean
'Usage

Dim instance As SaveOptionsPng
Dim value As Boolean

instance.Interlaced = value

value = instance.Interlaced
public bool Interlaced {get; set;}
public: __property bool get_Interlaced();
public: __property void set_Interlaced(
   bool value
);
public:
property bool Interlaced {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true to save the image in an interlaced format. Otherwise, false is used.
See Also

Reference

SaveOptionsPng Class
SaveOptionsPng Members


TransparencyColor Property (SaveOptionsPng)

TransparencyColor Property (SaveOptionsPng)

Accusoft.ImagXpressSdk Namespace > SaveOptionsPng Class : TransparencyColor Property
Gets and sets the color to be used to represent transparency in the stored image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TransparencyColor As Color
'Usage

Dim instance As SaveOptionsPng
Dim value As Color

instance.TransparencyColor = value

value = instance.TransparencyColor
public Color TransparencyColor {get; set;}
public: __property Color get_TransparencyColor();
public: __property void set_TransparencyColor(
   Color value
);
public:
property Color TransparencyColor {
   Color get();
   void set (    Color value);
}

Property Value

A System.Drawing.Color value.
See Also

Reference

SaveOptionsPng Class
SaveOptionsPng Members


TransparencyMatch Property (SaveOptionsPng)

TransparencyMatch Property (SaveOptionsPng)

Accusoft.ImagXpressSdk Namespace > SaveOptionsPng Class : TransparencyMatch Property
Gets and sets the type of TransparencyMatch to employ.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TransparencyMatch As TransparencyMatch
'Usage

Dim instance As SaveOptionsPng
Dim value As TransparencyMatch

instance.TransparencyMatch = value

value = instance.TransparencyMatch
public TransparencyMatch TransparencyMatch {get; set;}
public: __property TransparencyMatch get_TransparencyMatch();
public: __property void set_TransparencyMatch(
   TransparencyMatch value
);
public:
property TransparencyMatch TransparencyMatch {
   TransparencyMatch get();
   void set (    TransparencyMatch value);
}

Property Value

A TransparencyMatch enumeration value.
Remarks

The TransparencyMatch specifies how to match image pixels to the transparency color. Transparency can be applied on pixels that are an exact match to the TransparencyColor, the closest match to the TransparencyColor, or not at all.

See Also

Reference

SaveOptionsPng Class
SaveOptionsPng Members


SaveOptionsTiff Class

SaveOptionsTiff Class
Members

Accusoft.ImagXpressSdk Namespace : SaveOptionsTiff Class
This class implements the SaveOptions for TIFF formats.
Object Model
SaveOptionsTiff Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class SaveOptionsTiff
'Usage

Dim instance As SaveOptionsTiff
public class SaveOptionsTiff
public __gc class SaveOptionsTiff
public ref class SaveOptionsTiff
Inheritance Hierarchy

System.Object
Accusoft.ImagXpressSdk.SaveOptionsTiff

See Also

Reference

SaveOptionsTiff Members
Accusoft.ImagXpressSdk Namespace


SaveOptionsTiff Class Members

SaveOptionsTiff Class Members
Properties

Accusoft.ImagXpressSdk Namespace : SaveOptionsTiff Class

The following tables list the members exposed by SaveOptionsTiff.

Public Constructors
 | Name | Description
Public Constructor | SaveOptionsTiff Constructor | The main constructor which initializes a new instance of the SaveOptionsTiff class.
Top
Public Properties
 | Name | Description
Public Property | ByteOrder | Gets and sets the TIFF byte order to use when saving the image to a TIFF file.
Public Property | ColorSpace | Gets and sets the color space of the TIFF image being saved.
Public Property | Compression | Gets and sets the compression for the TIFF file being saved. The supported values are Rle, Lzw, Packbits, Deflate, Group3Fax1d, Group3Fax2d, Group4, Jpeg, Jpeg7, or no compression.
Public Property | IFDOffset | Gets and sets the location to append the next TIFF page when the UseIFDOffset property is set to true.
Public Property | MultiPage | Gets and sets if the image is being saved to a multi-page file.
Public Property | RowsPerStrip | Gets and sets the number of rows to save in each strip of a TIFF file.
Public Property | UseCmyk | Gets and sets whether the CMYK color space is used.
Public Property | UseIFDOffset | Gets and sets if TIFF files are set for fast saving of multi-page files.
Top
See Also

Reference

SaveOptionsTiff Class
Accusoft.ImagXpressSdk Namespace


SaveOptionsTiff Constructor

SaveOptionsTiff Constructor

Accusoft.ImagXpressSdk Namespace > SaveOptionsTiff Class : SaveOptionsTiff Constructor
The main constructor which initializes a new instance of the SaveOptionsTiff class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New SaveOptionsTiff()
public SaveOptionsTiff()
public: SaveOptionsTiff();
public:
SaveOptionsTiff();
See Also

Reference

SaveOptionsTiff Class
SaveOptionsTiff Members


SaveOptionsTiff Class Properties

SaveOptionsTiff Class Properties

Accusoft.ImagXpressSdk Namespace : SaveOptionsTiff Class

For a list of all members of this type, see SaveOptionsTiff members.

Public Properties
 | Name | Description
Public Property | ByteOrder | Gets and sets the TIFF byte order to use when saving the image to a TIFF file.
Public Property | ColorSpace | Gets and sets the color space of the TIFF image being saved.
Public Property | Compression | Gets and sets the compression for the TIFF file being saved. The supported values are Rle, Lzw, Packbits, Deflate, Group3Fax1d, Group3Fax2d, Group4, Jpeg, Jpeg7, or no compression.
Public Property | IFDOffset | Gets and sets the location to append the next TIFF page when the UseIFDOffset property is set to true.
Public Property | MultiPage | Gets and sets if the image is being saved to a multi-page file.
Public Property | RowsPerStrip | Gets and sets the number of rows to save in each strip of a TIFF file.
Public Property | UseCmyk | Gets and sets whether the CMYK color space is used.
Public Property | UseIFDOffset | Gets and sets if TIFF files are set for fast saving of multi-page files.
Top
See Also

Reference

SaveOptionsTiff Class
Accusoft.ImagXpressSdk Namespace


ByteOrder Property

ByteOrder Property

Accusoft.ImagXpressSdk Namespace > SaveOptionsTiff Class : ByteOrder Property
Gets and sets the TIFF byte order to use when saving the image to a TIFF file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ByteOrder As ByteOrder
'Usage

Dim instance As SaveOptionsTiff
Dim value As ByteOrder

instance.ByteOrder = value

value = instance.ByteOrder
public ByteOrder ByteOrder {get; set;}
public: __property ByteOrder get_ByteOrder();
public: __property void set_ByteOrder(
   ByteOrder value
);
public:
property ByteOrder ByteOrder {
   ByteOrder get();
   void set (    ByteOrder value);
}

Property Value

A ByteOrder enumeration value.
See Also

Reference

SaveOptionsTiff Class
SaveOptionsTiff Members


ColorSpace Property (SaveOptionsTiff)

ColorSpace Property (SaveOptionsTiff)

Accusoft.ImagXpressSdk Namespace > SaveOptionsTiff Class : ColorSpace Property
Gets and sets the color space of the TIFF image being saved.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<ObsoleteAttribute("This property is deprecated, please use UseCmyk to specify CMYK.")>
Public Property ColorSpace As ColorSpace
'Usage

Dim instance As SaveOptionsTiff
Dim value As ColorSpace

instance.ColorSpace = value

value = instance.ColorSpace
[Obsolete("This property is deprecated, please use UseCmyk to specify CMYK.")]
public ColorSpace ColorSpace {get; set;}
[Obsolete("This property is deprecated, please use UseCmyk to specify CMYK.")]
public: __property ColorSpace get_ColorSpace();
public: __property void set_ColorSpace(
   ColorSpace value
);
[Obsolete("This property is deprecated, please use UseCmyk to specify CMYK.")]
public:
property ColorSpace ColorSpace {
   ColorSpace get();
   void set (    ColorSpace value);
}

Property Value

A ColorSpace enumeration value.
See Also

Reference

SaveOptionsTiff Class
SaveOptionsTiff Members


Compression Property (SaveOptionsTiff)

Compression Property (SaveOptionsTiff)

Accusoft.ImagXpressSdk Namespace > SaveOptionsTiff Class : Compression Property
Gets and sets the compression for the TIFF file being saved. The supported values are Rle, Lzw, Packbits, Deflate, Group3Fax1d, Group3Fax2d, Group4, Jpeg, Jpeg7, or no compression.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Compression As Compression
'Usage

Dim instance As SaveOptionsTiff
Dim value As Compression

instance.Compression = value

value = instance.Compression
public Compression Compression {get; set;}
public: __property Compression get_Compression();
public: __property void set_Compression(
   Compression value
);
public:
property Compression Compression {
   Compression get();
   void set (    Compression value);
}

Property Value

A Compression enumeration value.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | The supported values are Rle, Lzw, Packbits, Deflate, Group3Fax1d, Group3Fax2d, Group4, Jpeg, Jpeg7, or no compression.
See Also

Reference

SaveOptionsTiff Class
SaveOptionsTiff Members


IFDOffset Property (SaveOptionsTiff)

IFDOffset Property (SaveOptionsTiff)

Accusoft.ImagXpressSdk Namespace > SaveOptionsTiff Class : IFDOffset Property
Gets and sets the location to append the next TIFF page when the UseIFDOffset property is set to true.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IFDOffset As Integer
'Usage

Dim instance As SaveOptionsTiff
Dim value As Integer

instance.IFDOffset = value

value = instance.IFDOffset
public int IFDOffset {get; set;}
public: __property int get_IFDOffset();
public: __property void set_IFDOffset(
   int value
);
public:
property int IFDOffset {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the TIFF page to append to.
Remarks

Note: No other operation with the TIFF file should be done during the looping of saving the pages with a fast TIFF write. It would be detrimental to call either the ReadAllMetaData, ImageX.SaveAllMetaData, CompactFile, ImageX.DeletePage, or ImageX.InsertPage methods in the middle of doing a fast TIFF write as they would definitely affect the IFD offsets in the file.

See Also

Reference

SaveOptionsTiff Class
SaveOptionsTiff Members


MultiPage Property (SaveOptionsTiff)

MultiPage Property (SaveOptionsTiff)

Accusoft.ImagXpressSdk Namespace > SaveOptionsTiff Class : MultiPage Property
Gets and sets if the image is being saved to a multi-page file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MultiPage As Boolean
'Usage

Dim instance As SaveOptionsTiff
Dim value As Boolean

instance.MultiPage = value

value = instance.MultiPage
public bool MultiPage {get; set;}
public: __property bool get_MultiPage();
public: __property void set_MultiPage(
   bool value
);
public:
property bool MultiPage {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true to save the TIFF file to a multi-page file. Otherwise, false is used.
See Also

Reference

SaveOptionsTiff Class
SaveOptionsTiff Members


RowsPerStrip Property

RowsPerStrip Property

Accusoft.ImagXpressSdk Namespace > SaveOptionsTiff Class : RowsPerStrip Property
Gets and sets the number of rows to save in each strip of a TIFF file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property RowsPerStrip As Integer
'Usage

Dim instance As SaveOptionsTiff
Dim value As Integer

instance.RowsPerStrip = value

value = instance.RowsPerStrip
public int RowsPerStrip {get; set;}
public: __property int get_RowsPerStrip();
public: __property void set_RowsPerStrip(
   int value
);
public:
property int RowsPerStrip {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the number of rows.
See Also

Reference

SaveOptionsTiff Class
SaveOptionsTiff Members


UseCmyk Property (SaveOptionsTiff)

UseCmyk Property (SaveOptionsTiff)

Accusoft.ImagXpressSdk Namespace > SaveOptionsTiff Class : UseCmyk Property
Gets and sets whether the CMYK color space is used.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property UseCmyk As Boolean
'Usage

Dim instance As SaveOptionsTiff
Dim value As Boolean

instance.UseCmyk = value

value = instance.UseCmyk
public bool UseCmyk {get; set;}
public: __property bool get_UseCmyk();
public: __property void set_UseCmyk(
   bool value
);
public:
property bool UseCmyk {
   bool get();
   void set (    bool value);
}
Remarks
Note: SaveOptions.UseEmbeddedColorManagement must be set to true and SaveOptions.TargetProfileName must be set to save as CMYK. Also, Compression must be set to NoCompression.

The default value is false.

See Also

Reference

SaveOptionsTiff Class
SaveOptionsTiff Members


UseIFDOffset Property

UseIFDOffset Property

Accusoft.ImagXpressSdk Namespace > SaveOptionsTiff Class : UseIFDOffset Property
Gets and sets if TIFF files are set for fast saving of multi-page files.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property UseIFDOffset As Boolean
'Usage

Dim instance As SaveOptionsTiff
Dim value As Boolean

instance.UseIFDOffset = value

value = instance.UseIFDOffset
public bool UseIFDOffset {get; set;}
public: __property bool get_UseIFDOffset();
public: __property void set_UseIFDOffset(
   bool value
);
public:
property bool UseIFDOffset {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true to use IFDOffset. Otherwise, false is used.
Remarks

Note: IFDOffset must be set explicitly after this property is set.

Note: No other operation with the TIFF file should be done during the looping of saving the pages with a fast TIFF write. It would be detrimental to call either the ReadAllMetaData, ImageX.SaveAllMetaData, CompactFile, ImageX.DeletePage, or ImageX.InsertPage methods in the middle of doing a fast TIFF write as they would definitely affect the IFD offsets in the file.

See Also

Reference

SaveOptionsTiff Class
SaveOptionsTiff Members


SaveOptionsWsq Class

SaveOptionsWsq Class
Members

Accusoft.ImagXpressSdk Namespace : SaveOptionsWsq Class
Implements the SaveOptions for the WSQ file format.
Object Model
SaveOptionsWsq Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class SaveOptionsWsq
'Usage

Dim instance As SaveOptionsWsq
public class SaveOptionsWsq
public __gc class SaveOptionsWsq
public ref class SaveOptionsWsq
Remarks

Note: Available in Professional edition.

Inheritance Hierarchy

System.Object
Accusoft.ImagXpressSdk.SaveOptionsWsq

See Also

Reference

SaveOptionsWsq Members
Accusoft.ImagXpressSdk Namespace


SaveOptionsWsq Class Members

SaveOptionsWsq Class Members
Properties

Accusoft.ImagXpressSdk Namespace : SaveOptionsWsq Class

The following tables list the members exposed by SaveOptionsWsq.

Public Constructors
 | Name | Description
Public Constructor | SaveOptionsWsq Constructor | The main constructor which initializes a new instance of the SaveOptionsWsq class.
Top
Public Properties
 | Name | Description
Public Property | Black | Gets and sets the level of black used in the WSQ file compression.
Public Property | Quantization | Gets and sets the quantization of the saved WSQ file.
Public Property | White | Gets and sets the level of white used in the WSQ file compression.
Top
See Also

Reference

SaveOptionsWsq Class
Accusoft.ImagXpressSdk Namespace


SaveOptionsWsq Constructor

SaveOptionsWsq Constructor

Accusoft.ImagXpressSdk Namespace > SaveOptionsWsq Class : SaveOptionsWsq Constructor
The main constructor which initializes a new instance of the SaveOptionsWsq class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New SaveOptionsWsq()
public SaveOptionsWsq()
public: SaveOptionsWsq();
public:
SaveOptionsWsq();
Remarks

Note: Available in Professional edition.

See Also

Reference

SaveOptionsWsq Class
SaveOptionsWsq Members


SaveOptionsWsq Class Properties

SaveOptionsWsq Class Properties

Accusoft.ImagXpressSdk Namespace : SaveOptionsWsq Class

For a list of all members of this type, see SaveOptionsWsq members.

Public Properties
 | Name | Description
Public Property | Black | Gets and sets the level of black used in the WSQ file compression.
Public Property | Quantization | Gets and sets the quantization of the saved WSQ file.
Public Property | White | Gets and sets the level of white used in the WSQ file compression.
Top
See Also

Reference

SaveOptionsWsq Class
Accusoft.ImagXpressSdk Namespace


Black Property

Black Property

Accusoft.ImagXpressSdk Namespace > SaveOptionsWsq Class : Black Property
Gets and sets the level of black used in the WSQ file compression.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Black As Integer
'Usage

Dim instance As SaveOptionsWsq
Dim value As Integer

instance.Black = value

value = instance.Black
public int Black {get; set;}
public: __property int get_Black();
public: __property void set_Black(
   int value
);
public:
property int Black {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the level of black used.
Remarks

The default value is 0.

Valid values are 0 to 255..

Note: Available in Professional edition.

See Also

Reference

SaveOptionsWsq Class
SaveOptionsWsq Members


Quantization Property (SaveOptionsWsq)

Quantization Property (SaveOptionsWsq)

Accusoft.ImagXpressSdk Namespace > SaveOptionsWsq Class : Quantization Property
Gets and sets the quantization of the saved WSQ file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Quantization As Double
'Usage

Dim instance As SaveOptionsWsq
Dim value As Double

instance.Quantization = value

value = instance.Quantization
public double Quantization {get; set;}
public: __property double get_Quantization();
public: __property void set_Quantization(
   double value
);
public:
property double Quantization {
   double get();
   void set (    double value);
}

Property Value

A double value which represents the quantization of the saved WSQ file.
Remarks

The default value is 0.75.

Valid values are anything greater than 0 and less than or equal to 32.

Note: Available in Professional edition.

See Also

Reference

SaveOptionsWsq Class
SaveOptionsWsq Members


White Property

White Property

Accusoft.ImagXpressSdk Namespace > SaveOptionsWsq Class : White Property
Gets and sets the level of white used in the WSQ file compression.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property White As Integer
'Usage

Dim instance As SaveOptionsWsq
Dim value As Integer

instance.White = value

value = instance.White
public int White {get; set;}
public: __property int get_White();
public: __property void set_White(
   int value
);
public:
property int White {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the level of white used.
Remarks

The default value is 255.

Valid values are 0 to 255..

Note: Available in Professional edition.

See Also

Reference

SaveOptionsWsq Class
SaveOptionsWsq Members


ScrollbarVisibleChangedEventArgs Class

ScrollbarVisibleChangedEventArgs Class
Members

Accusoft.ImagXpressSdk Namespace : ScrollbarVisibleChangedEventArgs Class
This class implements event data for ScrollbarVisibleChanged events.
Object Model
ScrollbarVisibleChangedEventArgs Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ScrollbarVisibleChangedEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As ScrollbarVisibleChangedEventArgs
public class ScrollbarVisibleChangedEventArgs : System.EventArgs
public __gc class ScrollbarVisibleChangedEventArgs : public System.EventArgs
public ref class ScrollbarVisibleChangedEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
Accusoft.ImagXpressSdk.ScrollbarVisibleChangedEventArgs

See Also

Reference

ScrollbarVisibleChangedEventArgs Members
Accusoft.ImagXpressSdk Namespace


ScrollbarVisibleChangedEventArgs Class Members

ScrollbarVisibleChangedEventArgs Class Members
Properties

Accusoft.ImagXpressSdk Namespace : ScrollbarVisibleChangedEventArgs Class

The following tables list the members exposed by ScrollbarVisibleChangedEventArgs.

Public Constructors
 | Name | Description
Public Constructor | ScrollbarVisibleChangedEventArgs Constructor | The main constructor which initializes a new instance of the ScrollbarVisibleChangedEventArgs class.
Top
Public Properties
 | Name | Description
Public Property | ScrollBar | Gets which scrollbar the event pertains to.
Public Property | Visible | Gets the visibility of the Scrollbar.
Top
See Also

Reference

ScrollbarVisibleChangedEventArgs Class
Accusoft.ImagXpressSdk Namespace


ScrollbarVisibleChangedEventArgs Constructor

ScrollbarVisibleChangedEventArgs Constructor

Accusoft.ImagXpressSdk Namespace > ScrollbarVisibleChangedEventArgs Class : ScrollbarVisibleChangedEventArgs Constructor
The main constructor which initializes a new instance of the ScrollbarVisibleChangedEventArgs class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ScrollbarVisibleChangedEventArgs()
public ScrollbarVisibleChangedEventArgs()
public: ScrollbarVisibleChangedEventArgs();
public:
ScrollbarVisibleChangedEventArgs();
See Also

Reference

ScrollbarVisibleChangedEventArgs Class
ScrollbarVisibleChangedEventArgs Members


ScrollbarVisibleChangedEventArgs Class Properties

ScrollbarVisibleChangedEventArgs Class Properties

Accusoft.ImagXpressSdk Namespace : ScrollbarVisibleChangedEventArgs Class

For a list of all members of this type, see ScrollbarVisibleChangedEventArgs members.

Public Properties
 | Name | Description
Public Property | ScrollBar | Gets which scrollbar the event pertains to.
Public Property | Visible | Gets the visibility of the Scrollbar.
Top
See Also

Reference

ScrollbarVisibleChangedEventArgs Class
Accusoft.ImagXpressSdk Namespace


ScrollbarVisibleChangedEventArgs Constructor

ScrollbarVisibleChangedEventArgs Constructor

Accusoft.ImagXpressSdk Namespace > ScrollbarVisibleChangedEventArgs Class : ScrollbarVisibleChangedEventArgs Constructor
Overload List
Overload | Description
ScrollbarVisibleChangedEventArgs Constructor | The main constructor which initializes a new instance of the ScrollbarVisibleChangedEventArgs class.
See Also

Reference

ScrollbarVisibleChangedEventArgs Class
ScrollbarVisibleChangedEventArgs Members


ScrollBar Property (ScrollbarVisibleChangedEventArgs)

ScrollBar Property (ScrollbarVisibleChangedEventArgs)

Accusoft.ImagXpressSdk Namespace > ScrollbarVisibleChangedEventArgs Class : ScrollBar Property
Gets which scrollbar the event pertains to.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ScrollBar As ScrollBars
'Usage

Dim instance As ScrollbarVisibleChangedEventArgs
Dim value As ScrollBars

value = instance.ScrollBar
public ScrollBars ScrollBar {get;}
public: __property ScrollBars get_ScrollBar();
public:
property ScrollBars ScrollBar {
   ScrollBars get();
}

Property Value

A System.Windows.Forms.ScrollBars enumeration value.
See Also

Reference

ScrollbarVisibleChangedEventArgs Class
ScrollbarVisibleChangedEventArgs Members


Visible Property (ScrollbarVisibleChangedEventArgs)

Visible Property (ScrollbarVisibleChangedEventArgs)

Accusoft.ImagXpressSdk Namespace > ScrollbarVisibleChangedEventArgs Class : Visible Property
Gets the visibility of the Scrollbar.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Visible As Boolean
'Usage

Dim instance As ScrollbarVisibleChangedEventArgs
Dim value As Boolean

value = instance.Visible
public bool Visible {get;}
public: __property bool get_Visible();
public:
property bool Visible {
   bool get();
}

Property Value

A System.Boolean value from the .NET Framework Class Library.
See Also

Reference

ScrollbarVisibleChangedEventArgs Class
ScrollbarVisibleChangedEventArgs Members


ScrollEventArgs Class

ScrollEventArgs Class
Members

Accusoft.ImagXpressSdk Namespace : ScrollEventArgs Class
This class implements event data for scroll events.
Object Model
ScrollEventArgs Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ScrollEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As ScrollEventArgs
public class ScrollEventArgs : System.EventArgs
public __gc class ScrollEventArgs : public System.EventArgs
public ref class ScrollEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
Accusoft.ImagXpressSdk.ScrollEventArgs

See Also

Reference

ScrollEventArgs Members
Accusoft.ImagXpressSdk Namespace


ScrollEventArgs Class Members

ScrollEventArgs Class Members
Properties

Accusoft.ImagXpressSdk Namespace : ScrollEventArgs Class

The following tables list the members exposed by ScrollEventArgs.

Public Constructors
 | Name | Description
Public Constructor | ScrollEventArgs Constructor | The main constructor which initializes a new instance of the ScrollEventArgs class.
Top
Public Properties
 | Name | Description
Public Property | NewValue | Gets the new location within the scroll range.
Public Property | ScrollBar | Gets which scrollbar the event pertains to.
Public Property | Type | Gets the type of scroll event that occurred.
Top
See Also

Reference

ScrollEventArgs Class
Accusoft.ImagXpressSdk Namespace


ScrollEventArgs Constructor

ScrollEventArgs Constructor

Accusoft.ImagXpressSdk Namespace > ScrollEventArgs Class : ScrollEventArgs Constructor
The main constructor which initializes a new instance of the ScrollEventArgs class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ScrollEventArgs()
public ScrollEventArgs()
public: ScrollEventArgs();
public:
ScrollEventArgs();
See Also

Reference

ScrollEventArgs Class
ScrollEventArgs Members


ScrollEventArgs Class Properties

ScrollEventArgs Class Properties

Accusoft.ImagXpressSdk Namespace : ScrollEventArgs Class

For a list of all members of this type, see ScrollEventArgs members.

Public Properties
 | Name | Description
Public Property | NewValue | Gets the new location within the scroll range.
Public Property | ScrollBar | Gets which scrollbar the event pertains to.
Public Property | Type | Gets the type of scroll event that occurred.
Top
See Also

Reference

ScrollEventArgs Class
Accusoft.ImagXpressSdk Namespace


ScrollEventArgs Constructor

ScrollEventArgs Constructor

Accusoft.ImagXpressSdk Namespace > ScrollEventArgs Class : ScrollEventArgs Constructor
Overload List
Overload | Description
ScrollEventArgs Constructor | The main constructor which initializes a new instance of the ScrollEventArgs class.
See Also

Reference

ScrollEventArgs Class
ScrollEventArgs Members


NewValue Property (ScrollEventArgs)

NewValue Property (ScrollEventArgs)

Accusoft.ImagXpressSdk Namespace > ScrollEventArgs Class : NewValue Property
Gets the new location within the scroll range.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property NewValue As Point
'Usage

Dim instance As ScrollEventArgs
Dim value As Point

value = instance.NewValue
public Point NewValue {get;}
public: __property Point get_NewValue();
public:
property Point NewValue {
   Point get();
}

Property Value

A System.Drawing.Point value.
See Also

Reference

ScrollEventArgs Class
ScrollEventArgs Members


ScrollBar Property (ScrollEventArgs)

ScrollBar Property (ScrollEventArgs)

Accusoft.ImagXpressSdk Namespace > ScrollEventArgs Class : ScrollBar Property
Gets which scrollbar the event pertains to.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ScrollBar As ScrollBars
'Usage

Dim instance As ScrollEventArgs
Dim value As ScrollBars

value = instance.ScrollBar
public ScrollBars ScrollBar {get;}
public: __property ScrollBars get_ScrollBar();
public:
property ScrollBars ScrollBar {
   ScrollBars get();
}

Property Value

A System.Windows.Forms.ScrollBars enumeration value.
See Also

Reference

ScrollEventArgs Class
ScrollEventArgs Members


Type Property (ScrollEventArgs)

Type Property (ScrollEventArgs)

Accusoft.ImagXpressSdk Namespace > ScrollEventArgs Class : Type Property
Gets the type of scroll event that occurred.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Type As ScrollEventType
'Usage

Dim instance As ScrollEventArgs
Dim value As ScrollEventType

value = instance.Type
public ScrollEventType Type {get;}
public: __property ScrollEventType get_Type();
public:
property ScrollEventType Type {
   ScrollEventType get();
}

Property Value

A System.Windows.Forms.ScrollEventType value from the .NET Framework Class Library.
See Also

Reference

ScrollEventArgs Class
ScrollEventArgs Members


Sprite Class

Sprite Class
Members

Accusoft.ImagXpressSdk Namespace : Sprite Class
This class implements a temporary image area.
Object Model
Sprite Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class Sprite
'Usage

Dim instance As Sprite
public class Sprite
public __gc class Sprite
public ref class Sprite
Remarks

This class allows you to implement temporary image regions, separate from the image region displayed in the viewer control. The region is the viewer content, not image pixel content. It is a rubberband area for the case where a Create is not specified. The sprite can be moved ver the current image by invoking the Move method and can be pasted into the current image by invoking the Paste method.

Note: This method fails if there is no current region defined.

Inheritance Hierarchy

System.Object
Accusoft.ImagXpressSdk.Sprite

See Also

Reference

Sprite Members
Accusoft.ImagXpressSdk Namespace
Create Method
Move Method
Paste Method


Sprite Class Members

Sprite Class Members
Methods

Accusoft.ImagXpressSdk Namespace : Sprite Class

The following tables list the members exposed by Sprite.

Public Methods
 | Name | Description
Public Method | Create | Overloaded. Creates a copy of the current region in a transparent window that can be moved or pasted into the image.
Public Method | Delete | Deletes the current sprite.
Public Method | Move | Moves the current sprite to a new position within the image.
Public Method | Paste | Pastes the current sprite into the image.
Top
See Also

Reference

Sprite Class
Accusoft.ImagXpressSdk Namespace
Create Method
Move Method
Paste Method


Sprite Class Methods

Sprite Class Methods

Accusoft.ImagXpressSdk Namespace : Sprite Class

For a list of all members of this type, see Sprite members.

Public Methods
 | Name | Description
Public Method | Create | Overloaded. Creates a copy of the current region in a transparent window that can be moved or pasted into the image.
Public Method | Delete | Deletes the current sprite.
Public Method | Move | Moves the current sprite to a new position within the image.
Public Method | Paste | Pastes the current sprite into the image.
Top
See Also

Reference

Sprite Class
Accusoft.ImagXpressSdk Namespace
Create Method
Move Method
Paste Method


Create Method

Create Method

Accusoft.ImagXpressSdk Namespace > Sprite Class : Create Method
Creates a copy of the current region in a transparent window that can be moved or pasted into the image.
Overload List
Overload | Description
Create() | Creates a copy of the current region in a transparent window that can be moved or pasted into the image.
Create(GraphicsPath) | Creates a copy of the passed in path which it uses to create the current region in a transparent window that can be moved or pasted into the image.
See Also

Reference

Sprite Class
Sprite Members


Create() Method

Create() Method

Accusoft.ImagXpressSdk Namespace > Sprite Class > Create Method : Create() Method
Creates a copy of the current region in a transparent window that can be moved or pasted into the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function Create() As Boolean
'Usage

Dim instance As Sprite
Dim value As Boolean

value = instance.Create()
public bool Create()
public: bool Create();
public:
bool Create();

Return Value

A boolean value which represents whether the sprite was created or not.
Remarks

Note: This method fails if there is no current region.

See Also

Reference

Sprite Class
Sprite Members
Overload List


Create(GraphicsPath) Method

Create(GraphicsPath) Method

Accusoft.ImagXpressSdk Namespace > Sprite Class > Create Method : Create(GraphicsPath) Method
A System.Drawing.Drawing2D.GraphicsPath value to convert to the current region.
Creates a copy of the passed in path which it uses to create the current region in a transparent window that can be moved or pasted into the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function Create( _
   ByVal path As GraphicsPath _
) As Boolean
'Usage

Dim instance As Sprite
Dim path As GraphicsPath
Dim value As Boolean

value = instance.Create(path)
public bool Create(
   GraphicsPath path
)
public: bool Create(
   GraphicsPath* path
)
public:
bool Create(
   GraphicsPath^ path
)

Parameters

path
A System.Drawing.Drawing2D.GraphicsPath value to convert to the current region.

Return Value

A boolean value which is true if the sprite was created. Otherwise, false is returned.
See Also

Reference

Sprite Class
Sprite Members
Overload List


Delete Method

Delete Method

Accusoft.ImagXpressSdk Namespace > Sprite Class : Delete Method
Deletes the current sprite.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Delete() As Boolean
'Usage

Dim instance As Sprite
Dim value As Boolean

value = instance.Delete()
public bool Delete()
public: bool Delete();
public:
bool Delete();

Return Value

A boolean value which is true if the sprite was deleted. Otherwise, false is returned.
Remarks

This method deletes the current sprite but not the current region.

Note: This method fails if there is no current sprite.

See Also

Reference

Sprite Class
Sprite Members


Move Method

Move Method

Accusoft.ImagXpressSdk Namespace > Sprite Class : Move Method
A System.Drawing.Point value which represents the top-left position of the sprite within the image.
Moves the current sprite to a new position within the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Move( _
   ByVal point As Point _
)
'Usage

Dim instance As Sprite
Dim point As Point

instance.Move(point)
public void Move(
   Point point
)
public: void Move(
   Point point
)
public:
void Move(
   Point point
)

Parameters

point
A System.Drawing.Point value which represents the top-left position of the sprite within the image.
Remarks

The point is in pixels and are relative to the image. Because a sprite may be a non rectangular region, the point is the top and left coordinates of a rectangle which bounds the sprite.

Note: This method fails if there is no current sprite.

See Also

Reference

Sprite Class
Sprite Members


Paste Method

Paste Method

Accusoft.ImagXpressSdk Namespace > Sprite Class : Paste Method
A System.Drawing.Point value which represents the top-left position of the sprite within the image.
Pastes the current sprite into the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Paste( _
   ByVal point As Point _
)
'Usage

Dim instance As Sprite
Dim point As Point

instance.Paste(point)
public void Paste(
   Point point
)
public: void Paste(
   Point point
)
public:
void Paste(
   Point point
)

Parameters

point
A System.Drawing.Point value which represents the top-left position of the sprite within the image.
Remarks

This method pastes a copy of the current sprite into the image. The current sprite is not deleted.

Note: This method fails if there is no current sprite.

See Also

Reference

Sprite Class
Sprite Members


Toolbar Class

Toolbar Class
Members

Accusoft.ImagXpressSdk Namespace : Toolbar Class
This class implements toolbar functionality.
Object Model
Toolbar ClassToolbarContextMenu Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class Toolbar
'Usage

Dim instance As Toolbar
public class Toolbar
public __gc class Toolbar
public ref class Toolbar
Remarks

The functionality enables the developer to create toolbars for use with the viewer control.

Inheritance Hierarchy

System.Object
Accusoft.ImagXpressSdk.Toolbar

See Also

Reference

Toolbar Members
Accusoft.ImagXpressSdk Namespace


Toolbar Class Members

Toolbar Class Members
Properties Methods

Accusoft.ImagXpressSdk Namespace : Toolbar Class

The following tables list the members exposed by Toolbar.

Public Constructors
 | Name | Description
Public Constructor | Toolbar Constructor | The main constructor which initializes a new instance of the Toolbar class.
Top
Public Properties
 | Name | Description
Public Property | Activated | Gets and sets if the toolbar is created and ready for use.
Public Property | ContextMenu | Gets the context menu for the toolbar.
Public Property | Enabled | Gets and sets if the toolbar is enabled.
Public Property | Height | Gets and sets the height of a toolbar in icons.
Public Property | Hwnd | Gets the windows handle of the toolbar.
Public Property | IconSize | Gets and sets the toolbar icon size.
Public Property | Visible | Gets and sets the toolbar visibility.
Public Property | Width | Gets and sets the width of the toolbar in icons.
Top
Public Methods
 | Name | Description
Public Method | DeleteTool | Deletes the specified tool from the toolbar.
Public Method | GetToolEnabled | Gets the enabled value of the given tool.
Public Method | GetToolTip | Gets the informational tip that is displayed to the end-user when the mouse is dragged over the given tool.
Public Method | GetToolVisible | Gets the tools visibility.
Public Method | SetToolEnabled | Enables the given tool.
Public Method | SetToolTip | Sets the given informational tip that displays to the end-user when the mouse is dragged over the specified tool.
Public Method | SetToolVisible | Sets the tools visibility.
Top
See Also

Reference

Toolbar Class
Accusoft.ImagXpressSdk Namespace


Toolbar Constructor

Toolbar Constructor

Accusoft.ImagXpressSdk Namespace > Toolbar Class : Toolbar Constructor
The main constructor which initializes a new instance of the Toolbar class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New Toolbar()
public Toolbar()
public: Toolbar();
public:
Toolbar();
See Also

Reference

Toolbar Class
Toolbar Members


Toolbar Class Methods

Toolbar Class Methods

Accusoft.ImagXpressSdk Namespace : Toolbar Class

For a list of all members of this type, see Toolbar members.

Public Methods
 | Name | Description
Public Method | DeleteTool | Deletes the specified tool from the toolbar.
Public Method | GetToolEnabled | Gets the enabled value of the given tool.
Public Method | GetToolTip | Gets the informational tip that is displayed to the end-user when the mouse is dragged over the given tool.
Public Method | GetToolVisible | Gets the tools visibility.
Public Method | SetToolEnabled | Enables the given tool.
Public Method | SetToolTip | Sets the given informational tip that displays to the end-user when the mouse is dragged over the specified tool.
Public Method | SetToolVisible | Sets the tools visibility.
Top
See Also

Reference

Toolbar Class
Accusoft.ImagXpressSdk Namespace


Toolbar Constructor

Toolbar Constructor

Accusoft.ImagXpressSdk Namespace > Toolbar Class : Toolbar Constructor
Overload List
Overload | Description
Toolbar Constructor | The main constructor which initializes a new instance of the Toolbar class.
See Also

Reference

Toolbar Class
Toolbar Members


DeleteTool Method

DeleteTool Method

Accusoft.ImagXpressSdk Namespace > Toolbar Class : DeleteTool Method
A Tool enumeration tool to delete from the toolbar.
Deletes the specified tool from the toolbar.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub DeleteTool( _
   ByVal tool As Tool _
)
'Usage

Dim instance As Toolbar
Dim tool As Tool

instance.DeleteTool(tool)
public void DeleteTool(
   Tool tool
)
public: void DeleteTool(
   Tool tool
)
public:
void DeleteTool(
   Tool tool
)

Parameters

tool
A Tool enumeration tool to delete from the toolbar.
Remarks

Note: Once a tool is deleted, it no longer appears in the toolbar.

See Also

Reference

Toolbar Class
Toolbar Members


GetToolEnabled Method

GetToolEnabled Method

Accusoft.ImagXpressSdk Namespace > Toolbar Class : GetToolEnabled Method
A Tool enumeration value which represents the tool to get the value of.
Gets the enabled value of the given tool.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetToolEnabled( _
   ByVal tool As Tool _
) As Boolean
'Usage

Dim instance As Toolbar
Dim tool As Tool
Dim value As Boolean

value = instance.GetToolEnabled(tool)
public bool GetToolEnabled(
   Tool tool
)
public: bool GetToolEnabled(
   Tool tool
)
public:
bool GetToolEnabled(
   Tool tool
)

Parameters

tool
A Tool enumeration value which represents the tool to get the value of.

Return Value

A boolean value which is true if the given tool is enabled. Otherwise, false is returned.
Remarks

Note: When a tool is enabled, the application end-user can then select it.

See Also

Reference

Toolbar Class
Toolbar Members


GetToolTip Method

GetToolTip Method

Accusoft.ImagXpressSdk Namespace > Toolbar Class : GetToolTip Method
The Tool enumeration value which represents the tool to get the tip of.
Gets the informational tip that is displayed to the end-user when the mouse is dragged over the given tool.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetToolTip( _
   ByVal tool As Tool _
) As String
'Usage

Dim instance As Toolbar
Dim tool As Tool
Dim value As String

value = instance.GetToolTip(tool)
public string GetToolTip(
   Tool tool
)
public: string* GetToolTip(
   Tool tool
)
public:
String^ GetToolTip(
   Tool tool
)

Parameters

tool
The Tool enumeration value which represents the tool to get the tip of.

Return Value

The string which represents the tip of the specified tool.
See Also

Reference

Toolbar Class
Toolbar Members


GetToolVisible Method

GetToolVisible Method

Accusoft.ImagXpressSdk Namespace > Toolbar Class : GetToolVisible Method
A Tool enumeration value which represents the tool to get the visibility on.
Gets the tools visibility.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetToolVisible( _
   ByVal tool As Tool _
) As Boolean
'Usage

Dim instance As Toolbar
Dim tool As Tool
Dim value As Boolean

value = instance.GetToolVisible(tool)
public bool GetToolVisible(
   Tool tool
)
public: bool GetToolVisible(
   Tool tool
)
public:
bool GetToolVisible(
   Tool tool
)

Parameters

tool
A Tool enumeration value which represents the tool to get the visibility on.

Return Value

A boolean value which is true if the given tool is visible. Otherwise, false is returned.
Remarks

When a tool is visible, it displays in the toolbar.

See Also

Reference

Toolbar Class
Toolbar Members


SetToolEnabled Method

SetToolEnabled Method

Accusoft.ImagXpressSdk Namespace > Toolbar Class : SetToolEnabled Method
A Tool enumeration value which represents the tool to enable.
A boolean value which is true to enable the given tool. Otherwise, false should be set.
Enables the given tool.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetToolEnabled( _
   ByVal tool As Tool, _
   ByVal enabled As Boolean _
)
'Usage

Dim instance As Toolbar
Dim tool As Tool
Dim enabled As Boolean

instance.SetToolEnabled(tool, enabled)
public void SetToolEnabled(
   Tool tool,
   bool enabled
)
public: void SetToolEnabled(
   Tool tool,
   bool enabled
)
public:
void SetToolEnabled(
   Tool tool,
   bool enabled
)

Parameters

tool
A Tool enumeration value which represents the tool to enable.
enabled
A boolean value which is true to enable the given tool. Otherwise, false should be set.
Remarks

Note: When a tool is enabled, the application end-user can then select it.

See Also

Reference

Toolbar Class
Toolbar Members


SetToolTip Method

SetToolTip Method

Accusoft.ImagXpressSdk Namespace > Toolbar Class : SetToolTip Method
The Tool enumeration value which represents the tool to set the tip on.
A string value which represents the information tip to display.
Sets the given informational tip that displays to the end-user when the mouse is dragged over the specified tool.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetToolTip( _
   ByVal tool As Tool, _
   ByVal tipText As String _
)
'Usage

Dim instance As Toolbar
Dim tool As Tool
Dim tipText As String

instance.SetToolTip(tool, tipText)
public void SetToolTip(
   Tool tool,
   string tipText
)
public: void SetToolTip(
   Tool tool,
   string* tipText
)
public:
void SetToolTip(
   Tool tool,
   String^ tipText
)

Parameters

tool
The Tool enumeration value which represents the tool to set the tip on.
tipText
A string value which represents the information tip to display.
See Also

Reference

Toolbar Class
Toolbar Members


SetToolVisible Method

SetToolVisible Method

Accusoft.ImagXpressSdk Namespace > Toolbar Class : SetToolVisible Method
The Tool enumeration value which represents the tool to set the visibility on.
A boolean value which is true to set the given tool to visible. Otherwise, false should be set.
Sets the tools visibility.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetToolVisible( _
   ByVal tool As Tool, _
   ByVal visible As Boolean _
)
'Usage

Dim instance As Toolbar
Dim tool As Tool
Dim visible As Boolean

instance.SetToolVisible(tool, visible)
public void SetToolVisible(
   Tool tool,
   bool visible
)
public: void SetToolVisible(
   Tool tool,
   bool visible
)
public:
void SetToolVisible(
   Tool tool,
   bool visible
)

Parameters

tool
The Tool enumeration value which represents the tool to set the visibility on.
visible
A boolean value which is true to set the given tool to visible. Otherwise, false should be set.
Remarks

Note: When a tool is visible, it displays on the toolbar.

See Also

Reference

Toolbar Class
Toolbar Members


Toolbar Class Properties

Toolbar Class Properties

Accusoft.ImagXpressSdk Namespace : Toolbar Class

For a list of all members of this type, see Toolbar members.

Public Properties
 | Name | Description
Public Property | Activated | Gets and sets if the toolbar is created and ready for use.
Public Property | ContextMenu | Gets the context menu for the toolbar.
Public Property | Enabled | Gets and sets if the toolbar is enabled.
Public Property | Height | Gets and sets the height of a toolbar in icons.
Public Property | Hwnd | Gets the windows handle of the toolbar.
Public Property | IconSize | Gets and sets the toolbar icon size.
Public Property | Visible | Gets and sets the toolbar visibility.
Public Property | Width | Gets and sets the width of the toolbar in icons.
Top
See Also

Reference

Toolbar Class
Accusoft.ImagXpressSdk Namespace


Activated Property

Activated Property

Accusoft.ImagXpressSdk Namespace > Toolbar Class : Activated Property
Gets and sets if the toolbar is created and ready for use.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Activated As Boolean
'Usage

Dim instance As Toolbar
Dim value As Boolean

instance.Activated = value

value = instance.Activated
public bool Activated {get; set;}
public: __property bool get_Activated();
public: __property void set_Activated(
   bool value
);
public:
property bool Activated {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true if the toolbar is created and ready for use. Otherwise, false is used.
See Also

Reference

Toolbar Class
Toolbar Members


ContextMenu Property (Toolbar)

ContextMenu Property (Toolbar)

Accusoft.ImagXpressSdk Namespace > Toolbar Class : ContextMenu Property
Gets the context menu for the toolbar.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ContextMenu As ToolbarContextMenu
'Usage

Dim instance As Toolbar
Dim value As ToolbarContextMenu

value = instance.ContextMenu
public ToolbarContextMenu ContextMenu {get;}
public: __property ToolbarContextMenu* get_ContextMenu();
public:
property ToolbarContextMenu^ ContextMenu {
   ToolbarContextMenu^ get();
}

Property Value

The ToolbarContextMenu object which contains the context menu data.
See Also

Reference

Toolbar Class
Toolbar Members


Enabled Property (Toolbar)

Enabled Property (Toolbar)

Accusoft.ImagXpressSdk Namespace > Toolbar Class : Enabled Property
Gets and sets if the toolbar is enabled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Enabled As Boolean
'Usage

Dim instance As Toolbar
Dim value As Boolean

instance.Enabled = value

value = instance.Enabled
public bool Enabled {get; set;}
public: __property bool get_Enabled();
public: __property void set_Enabled(
   bool value
);
public:
property bool Enabled {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true when the toolbar is enabled. Otherwise, false is used.
See Also

Reference

Toolbar Class
Toolbar Members


Height Property (Toolbar)

Height Property (Toolbar)

Accusoft.ImagXpressSdk Namespace > Toolbar Class : Height Property
Gets and sets the height of a toolbar in icons.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Height As Integer
'Usage

Dim instance As Toolbar
Dim value As Integer

instance.Height = value

value = instance.Height
public int Height {get; set;}
public: __property int get_Height();
public: __property void set_Height(
   int value
);
public:
property int Height {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the height of the toolbar in icons.
See Also

Reference

Toolbar Class
Toolbar Members


Hwnd Property

Hwnd Property

Accusoft.ImagXpressSdk Namespace > Toolbar Class : Hwnd Property
Gets the windows handle of the toolbar.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Hwnd As IntPtr
'Usage

Dim instance As Toolbar
Dim value As IntPtr

value = instance.Hwnd
public IntPtr Hwnd {get;}
public: __property IntPtr get_Hwnd();
public:
property IntPtr Hwnd {
   IntPtr get();
}

Property Value

An System.IntPtr value which represents the handle for the toolbar.
See Also

Reference

Toolbar Class
Toolbar Members


IconSize Property

IconSize Property

Accusoft.ImagXpressSdk Namespace > Toolbar Class : IconSize Property
Gets and sets the toolbar icon size.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IconSize As ToolbarIconSize
'Usage

Dim instance As Toolbar
Dim value As ToolbarIconSize

instance.IconSize = value

value = instance.IconSize
public ToolbarIconSize IconSize {get; set;}
public: __property ToolbarIconSize get_IconSize();
public: __property void set_IconSize(
   ToolbarIconSize value
);
public:
property ToolbarIconSize IconSize {
   ToolbarIconSize get();
   void set (    ToolbarIconSize value);
}

Property Value

An enumerated value which is one of Small, Medium, or Large.
Remarks

When the toolbar icon size is Small, it uses a 16x16 icon size for each toolbar button.

When the toolbar icon size is Medium, it uses a 24x24 icon size for each toolbar button.

When the toolbar icon size is Large, it uses a 32x32 icon size for each toolbar button. This is the default size.

See Also

Reference

Toolbar Class
Toolbar Members


Visible Property (Toolbar)

Visible Property (Toolbar)

Accusoft.ImagXpressSdk Namespace > Toolbar Class : Visible Property
Gets and sets the toolbar visibility.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Visible As Boolean
'Usage

Dim instance As Toolbar
Dim value As Boolean

instance.Visible = value

value = instance.Visible
public bool Visible {get; set;}
public: __property bool get_Visible();
public: __property void set_Visible(
   bool value
);
public:
property bool Visible {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true when the toolbar is visible. Otherwise, false is used.
Remarks

When the toolbar is visible, it appears in a display window.

See Also

Reference

Toolbar Class
Toolbar Members


Width Property (Toolbar)

Width Property (Toolbar)

Accusoft.ImagXpressSdk Namespace > Toolbar Class : Width Property
Gets and sets the width of the toolbar in icons.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Width As Integer
'Usage

Dim instance As Toolbar
Dim value As Integer

instance.Width = value

value = instance.Width
public int Width {get; set;}
public: __property int get_Width();
public: __property void set_Width(
   int value
);
public:
property int Width {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the width of the toolbar in icons.
See Also

Reference

Toolbar Class
Toolbar Members


ToolbarCloseEventArgs Class

ToolbarCloseEventArgs Class
Members

Accusoft.ImagXpressSdk Namespace : ToolbarCloseEventArgs Class
This class contains information associated with a ToolbarCloseEvent.
Object Model
ToolbarCloseEventArgs Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ToolbarCloseEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As ToolbarCloseEventArgs
public class ToolbarCloseEventArgs : System.EventArgs
public __gc class ToolbarCloseEventArgs : public System.EventArgs
public ref class ToolbarCloseEventArgs : public System.EventArgs
Remarks

A ImageXView.ToolbarCloseEvent occurs when the ImagXpress toolbar window closes.

Inheritance Hierarchy

System.Object
System.EventArgs
Accusoft.ImagXpressSdk.ToolbarCloseEventArgs

See Also

Reference

ToolbarCloseEventArgs Members
Accusoft.ImagXpressSdk Namespace


ToolbarCloseEventArgs Class Members

ToolbarCloseEventArgs Class Members

Accusoft.ImagXpressSdk Namespace : ToolbarCloseEventArgs Class

The following tables list the members exposed by ToolbarCloseEventArgs.

Public Constructors
 | Name | Description
Public Constructor | ToolbarCloseEventArgs Constructor | The main constructor which initializes a new instance of the ToolbarCloseEventArgs class.
Top
See Also

Reference

ToolbarCloseEventArgs Class
Accusoft.ImagXpressSdk Namespace


ToolbarCloseEventArgs Constructor

ToolbarCloseEventArgs Constructor

Accusoft.ImagXpressSdk Namespace > ToolbarCloseEventArgs Class : ToolbarCloseEventArgs Constructor
Overload List
Overload | Description
ToolbarCloseEventArgs Constructor | The main constructor which initializes a new instance of the ToolbarCloseEventArgs class.
See Also

Reference

ToolbarCloseEventArgs Class
ToolbarCloseEventArgs Members


ToolbarCloseEventArgs Constructor

ToolbarCloseEventArgs Constructor

Accusoft.ImagXpressSdk Namespace > ToolbarCloseEventArgs Class : ToolbarCloseEventArgs Constructor
The main constructor which initializes a new instance of the ToolbarCloseEventArgs class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ToolbarCloseEventArgs()
public ToolbarCloseEventArgs()
public: ToolbarCloseEventArgs();
public:
ToolbarCloseEventArgs();
See Also

Reference

ToolbarCloseEventArgs Class
ToolbarCloseEventArgs Members


ToolbarContextMenu Class

ToolbarContextMenu Class
Members

Accusoft.ImagXpressSdk Namespace : ToolbarContextMenu Class
This class implements the context menu associated with the ImagXpress toolbar.
Object Model
ToolbarContextMenu Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ToolbarContextMenu
'Usage

Dim instance As ToolbarContextMenu
public class ToolbarContextMenu
public __gc class ToolbarContextMenu
public ref class ToolbarContextMenu
Inheritance Hierarchy

System.Object
Accusoft.ImagXpressSdk.ToolbarContextMenu

See Also

Reference

ToolbarContextMenu Members
Accusoft.ImagXpressSdk Namespace


ToolbarContextMenu Class Members

ToolbarContextMenu Class Members
Methods

Accusoft.ImagXpressSdk Namespace : ToolbarContextMenu Class

The following tables list the members exposed by ToolbarContextMenu.

Public Constructors
 | Name | Description
Public Constructor | ToolbarContextMenu Constructor | The main constructor which initializes a new instance of the ToolbarContextMenu class.
Top
Public Methods
 | Name | Description
Public Method | AddItem | Adds an item to the specified menu.
Public Method | ChangeItem | Changes the text title of the specified menu item.
Public Method | DeleteItem | Deletes an item from the specified menu.
Public Method | GetEnabled | Gets the enabled value of the menu associated with the given tool.
Public Method | GetFirstItemId | Gets the topMenuId and subMenuId of the first item in the menu associated with the specified tool.
Public Method | GetItem | Gets the title of the menu item specified.
Public Method | GetItemChecked | Gets the checked status of the specified menu item.
Public Method | GetItemEnabled | Gets the enabled status of the specified menu item.
Public Method | GetItemVisible | Gets the visible status of the specified menu item.
Public Method | GetNextItemId | Gets the topMenuId and subMenuId of the next item in the menu associated with the specified tool.
Public Method | SetEnabled | Sets the enabled value of the menu associated with the given tool.
Public Method | SetItemChecked | Sets if a menu item should have a checkmark visible next to the item.
Public Method | SetItemEnabled | Sets if a menu item is enabled.
Public Method | SetItemVisible | Sets if a menu item should be visible when the menu is displayed.
Top
See Also

Reference

ToolbarContextMenu Class
Accusoft.ImagXpressSdk Namespace


ToolbarContextMenu Constructor

ToolbarContextMenu Constructor

Accusoft.ImagXpressSdk Namespace > ToolbarContextMenu Class : ToolbarContextMenu Constructor
The main constructor which initializes a new instance of the ToolbarContextMenu class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ToolbarContextMenu()
public ToolbarContextMenu()
public: ToolbarContextMenu();
public:
ToolbarContextMenu();
See Also

Reference

ToolbarContextMenu Class
ToolbarContextMenu Members


ToolbarContextMenu Class Methods

ToolbarContextMenu Class Methods

Accusoft.ImagXpressSdk Namespace : ToolbarContextMenu Class

For a list of all members of this type, see ToolbarContextMenu members.

Public Methods
 | Name | Description
Public Method | AddItem | Adds an item to the specified menu.
Public Method | ChangeItem | Changes the text title of the specified menu item.
Public Method | DeleteItem | Deletes an item from the specified menu.
Public Method | GetEnabled | Gets the enabled value of the menu associated with the given tool.
Public Method | GetFirstItemId | Gets the topMenuId and subMenuId of the first item in the menu associated with the specified tool.
Public Method | GetItem | Gets the title of the menu item specified.
Public Method | GetItemChecked | Gets the checked status of the specified menu item.
Public Method | GetItemEnabled | Gets the enabled status of the specified menu item.
Public Method | GetItemVisible | Gets the visible status of the specified menu item.
Public Method | GetNextItemId | Gets the topMenuId and subMenuId of the next item in the menu associated with the specified tool.
Public Method | SetEnabled | Sets the enabled value of the menu associated with the given tool.
Public Method | SetItemChecked | Sets if a menu item should have a checkmark visible next to the item.
Public Method | SetItemEnabled | Sets if a menu item is enabled.
Public Method | SetItemVisible | Sets if a menu item should be visible when the menu is displayed.
Top
See Also

Reference

ToolbarContextMenu Class
Accusoft.ImagXpressSdk Namespace


ToolbarContextMenu Constructor

ToolbarContextMenu Constructor

Accusoft.ImagXpressSdk Namespace > ToolbarContextMenu Class : ToolbarContextMenu Constructor
Overload List
Overload | Description
ToolbarContextMenu Constructor | The main constructor which initializes a new instance of the ToolbarContextMenu class.
See Also

Reference

ToolbarContextMenu Class
ToolbarContextMenu Members


AddItem Method

AddItem Method

Accusoft.ImagXpressSdk Namespace > ToolbarContextMenu Class : AddItem Method
The Tool enumeration value which represents the tool which the menu is associated.
An integer value which represents the top menu ID.
An intger value which represents the sub menu ID.
A string value which represents the menu text.
An integer value which represents a user defined field.
An integer value which represents a user defined field.
Adds an item to the specified menu.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub AddItem( _
   ByVal tool As Tool, _
   ByVal topMenuId As Integer, _
   ByVal subMenuId As Integer, _
   ByVal menuText As String, _
   ByVal user1 As Integer, _
   ByVal user2 As Integer _
)
'Usage

Dim instance As ToolbarContextMenu
Dim tool As Tool
Dim topMenuId As Integer
Dim subMenuId As Integer
Dim menuText As String
Dim user1 As Integer
Dim user2 As Integer

instance.AddItem(tool, topMenuId, subMenuId, menuText, user1, user2)
public void AddItem(
   Tool tool,
   int topMenuId,
   int subMenuId,
   string menuText,
   int user1,
   int user2
)
public: void AddItem(
   Tool tool,
   int topMenuId,
   int subMenuId,
   string* menuText,
   int user1,
   int user2
)
public:
void AddItem(
   Tool tool,
   int topMenuId,
   int subMenuId,
   String^ menuText,
   int user1,
   int user2
)

Parameters

tool
The Tool enumeration value which represents the tool which the menu is associated.
topMenuId
An integer value which represents the top menu ID.
subMenuId
An intger value which represents the sub menu ID.
menuText
A string value which represents the menu text.
user1
An integer value which represents a user defined field.
user2
An integer value which represents a user defined field.
Remarks

This method adds a new menu item to the specified menu. If the Menu is Toolbar, ten the Tool parameter is the Tool ID that the menu is associated with.

If the Menu is Context, the Tool parameter has no meaning and can be any value.

If the menu item is to be a top-level menu item, then the subMenuId should be 0. A subMenuID menu item can only be added when a topMenuId has been added with a previous subMenuId set to 0.

See Also

Reference

ToolbarContextMenu Class
ToolbarContextMenu Members


ChangeItem Method

ChangeItem Method

Accusoft.ImagXpressSdk Namespace > ToolbarContextMenu Class : ChangeItem Method
A Tool enumeration value which represents the tool that the menu item is associated to.
An integer value which represents the top-level menu in which the menu item resides.
An integer value which represents the sub-level menu in which the menu item resides.
A string value which represents the text to change the menu item to.
Changes the text title of the specified menu item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function ChangeItem( _
   ByVal tool As Tool, _
   ByVal topMenuId As Integer, _
   ByVal subMenuId As Integer, _
   ByVal menuText As String _
) As Boolean
'Usage

Dim instance As ToolbarContextMenu
Dim tool As Tool
Dim topMenuId As Integer
Dim subMenuId As Integer
Dim menuText As String
Dim value As Boolean

value = instance.ChangeItem(tool, topMenuId, subMenuId, menuText)
public bool ChangeItem(
   Tool tool,
   int topMenuId,
   int subMenuId,
   string menuText
)
public: bool ChangeItem(
   Tool tool,
   int topMenuId,
   int subMenuId,
   string* menuText
)
public:
bool ChangeItem(
   Tool tool,
   int topMenuId,
   int subMenuId,
   String^ menuText
)

Parameters

tool
A Tool enumeration value which represents the tool that the menu item is associated to.
topMenuId
An integer value which represents the top-level menu in which the menu item resides.
subMenuId
An integer value which represents the sub-level menu in which the menu item resides.
menuText
A string value which represents the text to change the menu item to.

Return Value

A boolean value which is true if the menu item text was changed. Otherwise, false is returned.
See Also

Reference

ToolbarContextMenu Class
ToolbarContextMenu Members


DeleteItem Method

DeleteItem Method

Accusoft.ImagXpressSdk Namespace > ToolbarContextMenu Class : DeleteItem Method
The Tool enumeration value which represents the tool that the menu is associated with.
An integer value which represents the top menu ID.
An intger value which represents the sub menu ID.
Deletes an item from the specified menu.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function DeleteItem( _
   ByVal tool As Tool, _
   ByVal topMenuId As Integer, _
   ByVal subMenuId As Integer _
) As Boolean
'Usage

Dim instance As ToolbarContextMenu
Dim tool As Tool
Dim topMenuId As Integer
Dim subMenuId As Integer
Dim value As Boolean

value = instance.DeleteItem(tool, topMenuId, subMenuId)
public bool DeleteItem(
   Tool tool,
   int topMenuId,
   int subMenuId
)
public: bool DeleteItem(
   Tool tool,
   int topMenuId,
   int subMenuId
)
public:
bool DeleteItem(
   Tool tool,
   int topMenuId,
   int subMenuId
)

Parameters

tool
The Tool enumeration value which represents the tool that the menu is associated with.
topMenuId
An integer value which represents the top menu ID.
subMenuId
An intger value which represents the sub menu ID.

Return Value

A boolean value which is true if the menu item text was deleted. Otherwise, false is returned.
Remarks

If the menu item is to be a top-level menu item, then the subMenuId should be 0. However, this will delete all sub-level menu items as well for that top-level menu item.

If the topMenuId and subLevelId are both 0, then the entire menu is cleared.

See Also

Reference

ToolbarContextMenu Class
ToolbarContextMenu Members


GetEnabled Method

GetEnabled Method

Accusoft.ImagXpressSdk Namespace > ToolbarContextMenu Class : GetEnabled Method
The Tool enumeration value which represents the tool to get the enabled value of.
Gets the enabled value of the menu associated with the given tool.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetEnabled( _
   ByVal tool As Tool _
) As Boolean
'Usage

Dim instance As ToolbarContextMenu
Dim tool As Tool
Dim value As Boolean

value = instance.GetEnabled(tool)
public bool GetEnabled(
   Tool tool
)
public: bool GetEnabled(
   Tool tool
)
public:
bool GetEnabled(
   Tool tool
)

Parameters

tool
The Tool enumeration value which represents the tool to get the enabled value of.

Return Value

A boolean value which is true if the given tool menu is enabled. Otherwise, false is returned.
See Also

Reference

ToolbarContextMenu Class
ToolbarContextMenu Members


GetFirstItemId Method

GetFirstItemId Method

Accusoft.ImagXpressSdk Namespace > ToolbarContextMenu Class : GetFirstItemId Method
A Tool enumeration value which represents the tool associated with the menu item.
An integer value which represents the top-level menu ID of the first item in the menu. A returned value of 0 indicates there are no menu items.
An integer value which represents the sub-level menu ID of the first item in the menu.
Gets the topMenuId and subMenuId of the first item in the menu associated with the specified tool.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub GetFirstItemId( _
   ByVal tool As Tool, _
   ByRef topMenuId As Integer, _
   ByRef subMenuId As Integer _
)
'Usage

Dim instance As ToolbarContextMenu
Dim tool As Tool
Dim topMenuId As Integer
Dim subMenuId As Integer

instance.GetFirstItemId(tool, topMenuId, subMenuId)
public void GetFirstItemId(
   Tool tool,
   out int topMenuId,
   out int subMenuId
)
public: void GetFirstItemId(
   Tool tool,
   [PARAMFLAG::Out] int topMenuId,
   [PARAMFLAG::Out] int subMenuId
)
public:
void GetFirstItemId(
   Tool tool,
   [Out] int topMenuId,
   [Out] int subMenuId
)

Parameters

tool
A Tool enumeration value which represents the tool associated with the menu item.
topMenuId
An integer value which represents the top-level menu ID of the first item in the menu. A returned value of 0 indicates there are no menu items.
subMenuId
An integer value which represents the sub-level menu ID of the first item in the menu.
Remarks

Use this method and the GetNextItemId method to iterate through the available menu items.

See Also

Reference

ToolbarContextMenu Class
ToolbarContextMenu Members


GetItem Method

GetItem Method

Accusoft.ImagXpressSdk Namespace > ToolbarContextMenu Class : GetItem Method
A Tool enumeration value which represents the tool associated with the menu item.
An integer value which represents the identifier of the top-level menu in which the menu item resides.
An integer value which represents the identifier of the sub-level menu in which the menu item resides.
Gets the title of the menu item specified.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetItem( _
   ByVal tool As Tool, _
   ByVal topMenuId As Integer, _
   ByVal subMenuId As Integer _
) As String
'Usage

Dim instance As ToolbarContextMenu
Dim tool As Tool
Dim topMenuId As Integer
Dim subMenuId As Integer
Dim value As String

value = instance.GetItem(tool, topMenuId, subMenuId)
public string GetItem(
   Tool tool,
   int topMenuId,
   int subMenuId
)
public: string* GetItem(
   Tool tool,
   int topMenuId,
   int subMenuId
)
public:
String^ GetItem(
   Tool tool,
   int topMenuId,
   int subMenuId
)

Parameters

tool
A Tool enumeration value which represents the tool associated with the menu item.
topMenuId
An integer value which represents the identifier of the top-level menu in which the menu item resides.
subMenuId
An integer value which represents the identifier of the sub-level menu in which the menu item resides.

Return Value

A string which represents the title of the menu item specified.
See Also

Reference

ToolbarContextMenu Class
ToolbarContextMenu Members


GetItemChecked Method

GetItemChecked Method

Accusoft.ImagXpressSdk Namespace > ToolbarContextMenu Class : GetItemChecked Method
A Tool enumeration value associated with the menu.
An integer value which represents the top-level menu ID.
An integer value which represents the sub-level menu ID.
Gets the checked status of the specified menu item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetItemChecked( _
   ByVal tool As Tool, _
   ByVal topMenuId As Integer, _
   ByVal subMenuId As Integer _
) As Boolean
'Usage

Dim instance As ToolbarContextMenu
Dim tool As Tool
Dim topMenuId As Integer
Dim subMenuId As Integer
Dim value As Boolean

value = instance.GetItemChecked(tool, topMenuId, subMenuId)
public bool GetItemChecked(
   Tool tool,
   int topMenuId,
   int subMenuId
)
public: bool GetItemChecked(
   Tool tool,
   int topMenuId,
   int subMenuId
)
public:
bool GetItemChecked(
   Tool tool,
   int topMenuId,
   int subMenuId
)

Parameters

tool
A Tool enumeration value associated with the menu.
topMenuId
An integer value which represents the top-level menu ID.
subMenuId
An integer value which represents the sub-level menu ID.

Return Value

A boolean value which is true if the given item is checked. Otherwise, false is returned.
Remarks

If an item is checked, a check-mark is visible next to the item.

See Also

Reference

ToolbarContextMenu Class
ToolbarContextMenu Members


GetItemEnabled Method

GetItemEnabled Method

Accusoft.ImagXpressSdk Namespace > ToolbarContextMenu Class : GetItemEnabled Method
A Tool enumeration value associated with the menu item.
An integer value which represents the top-level menu ID.
An integer value which represents the sub-level menu ID.
Gets the enabled status of the specified menu item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetItemEnabled( _
   ByVal tool As Tool, _
   ByVal topMenuId As Integer, _
   ByVal subMenuId As Integer _
) As Boolean
'Usage

Dim instance As ToolbarContextMenu
Dim tool As Tool
Dim topMenuId As Integer
Dim subMenuId As Integer
Dim value As Boolean

value = instance.GetItemEnabled(tool, topMenuId, subMenuId)
public bool GetItemEnabled(
   Tool tool,
   int topMenuId,
   int subMenuId
)
public: bool GetItemEnabled(
   Tool tool,
   int topMenuId,
   int subMenuId
)
public:
bool GetItemEnabled(
   Tool tool,
   int topMenuId,
   int subMenuId
)

Parameters

tool
A Tool enumeration value associated with the menu item.
topMenuId
An integer value which represents the top-level menu ID.
subMenuId
An integer value which represents the sub-level menu ID.

Return Value

A boolean value which is true when the menu item is enabled. Otherwise, false is returned.
Remarks

When a menu item is enabled, the application end-user can select the menu item. Items that are enabled appear in dark print. Items that are not enabled are grayed out.

See Also

Reference

ToolbarContextMenu Class
ToolbarContextMenu Members


GetItemVisible Method

GetItemVisible Method

Accusoft.ImagXpressSdk Namespace > ToolbarContextMenu Class : GetItemVisible Method
A Tool enumeration value associated with the menu item.
An integer value which represents the top-level menu in which the menu item resides.
An integer value which represents the sub-level menu in which the menu item resides.
Gets the visible status of the specified menu item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetItemVisible( _
   ByVal tool As Tool, _
   ByVal topMenuId As Integer, _
   ByVal subMenuId As Integer _
) As Boolean
'Usage

Dim instance As ToolbarContextMenu
Dim tool As Tool
Dim topMenuId As Integer
Dim subMenuId As Integer
Dim value As Boolean

value = instance.GetItemVisible(tool, topMenuId, subMenuId)
public bool GetItemVisible(
   Tool tool,
   int topMenuId,
   int subMenuId
)
public: bool GetItemVisible(
   Tool tool,
   int topMenuId,
   int subMenuId
)
public:
bool GetItemVisible(
   Tool tool,
   int topMenuId,
   int subMenuId
)

Parameters

tool
A Tool enumeration value associated with the menu item.
topMenuId
An integer value which represents the top-level menu in which the menu item resides.
subMenuId
An integer value which represents the sub-level menu in which the menu item resides.

Return Value

A boolean value which is true if the given menu item is visible. Otherwise, false is returned.
See Also

Reference

ToolbarContextMenu Class
ToolbarContextMenu Members


GetNextItemId Method

GetNextItemId Method

Accusoft.ImagXpressSdk Namespace > ToolbarContextMenu Class : GetNextItemId Method
A Tool enumeration value with which the menu is associated.
An integer value which represents the top-level menu ID of the first item in the menu.
An integer value which represents the sub-level menu ID of the first item in the menu.
Gets the topMenuId and subMenuId of the next item in the menu associated with the specified tool.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub GetNextItemId( _
   ByVal tool As Tool, _
   ByRef topMenuId As Integer, _
   ByRef subMenuId As Integer _
)
'Usage

Dim instance As ToolbarContextMenu
Dim tool As Tool
Dim topMenuId As Integer
Dim subMenuId As Integer

instance.GetNextItemId(tool, topMenuId, subMenuId)
public void GetNextItemId(
   Tool tool,
   out int topMenuId,
   out int subMenuId
)
public: void GetNextItemId(
   Tool tool,
   [PARAMFLAG::Out] int topMenuId,
   [PARAMFLAG::Out] int subMenuId
)
public:
void GetNextItemId(
   Tool tool,
   [Out] int topMenuId,
   [Out] int subMenuId
)

Parameters

tool
A Tool enumeration value with which the menu is associated.
topMenuId
An integer value which represents the top-level menu ID of the first item in the menu.
subMenuId
An integer value which represents the sub-level menu ID of the first item in the menu.
Remarks

Use this method and the GetFirstItemId method to iterate through the available menu items.

See Also

Reference

ToolbarContextMenu Class
ToolbarContextMenu Members


SetEnabled Method

SetEnabled Method

Accusoft.ImagXpressSdk Namespace > ToolbarContextMenu Class : SetEnabled Method
The Tool enumeration value which represents the tool to set the enabled value of.
A boolean value which should be set to true to enable the menu of the given tool. Otherwise, false should be set.
Sets the enabled value of the menu associated with the given tool.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetEnabled( _
   ByVal tool As Tool, _
   ByVal enabled As Boolean _
)
'Usage

Dim instance As ToolbarContextMenu
Dim tool As Tool
Dim enabled As Boolean

instance.SetEnabled(tool, enabled)
public void SetEnabled(
   Tool tool,
   bool enabled
)
public: void SetEnabled(
   Tool tool,
   bool enabled
)
public:
void SetEnabled(
   Tool tool,
   bool enabled
)

Parameters

tool
The Tool enumeration value which represents the tool to set the enabled value of.
enabled
A boolean value which should be set to true to enable the menu of the given tool. Otherwise, false should be set.
See Also

Reference

ToolbarContextMenu Class
ToolbarContextMenu Members


SetItemChecked Method

SetItemChecked Method

Accusoft.ImagXpressSdk Namespace > ToolbarContextMenu Class : SetItemChecked Method
A Tool enumeration value associated to the menu.
An integer value which represents the top-level menu ID.
An integer value which represents the sub-level menu ID.
A boolean value which is true to check visible next to the item and false to not have a check visible next to the item.
A boolean value which is true when the item is checked and all other items on the same menu level are not checked. If this parameter is false and the item is checked, the other items on the same menu level can be checked as well.
Sets if a menu item should have a checkmark visible next to the item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetItemChecked( _
   ByVal tool As Tool, _
   ByVal topMenuId As Integer, _
   ByVal subMenuId As Integer, _
   ByVal isChecked As Boolean, _
   ByVal exclusive As Boolean _
)
'Usage

Dim instance As ToolbarContextMenu
Dim tool As Tool
Dim topMenuId As Integer
Dim subMenuId As Integer
Dim isChecked As Boolean
Dim exclusive As Boolean

instance.SetItemChecked(tool, topMenuId, subMenuId, isChecked, exclusive)
public void SetItemChecked(
   Tool tool,
   int topMenuId,
   int subMenuId,
   bool isChecked,
   bool exclusive
)
public: void SetItemChecked(
   Tool tool,
   int topMenuId,
   int subMenuId,
   bool isChecked,
   bool exclusive
)
public:
void SetItemChecked(
   Tool tool,
   int topMenuId,
   int subMenuId,
   bool isChecked,
   bool exclusive
)

Parameters

tool
A Tool enumeration value associated to the menu.
topMenuId
An integer value which represents the top-level menu ID.
subMenuId
An integer value which represents the sub-level menu ID.
isChecked
A boolean value which is true to check visible next to the item and false to not have a check visible next to the item.
exclusive
A boolean value which is true when the item is checked and all other items on the same menu level are not checked. If this parameter is false and the item is checked, the other items on the same menu level can be checked as well.
See Also

Reference

ToolbarContextMenu Class
ToolbarContextMenu Members


SetItemEnabled Method

SetItemEnabled Method

Accusoft.ImagXpressSdk Namespace > ToolbarContextMenu Class : SetItemEnabled Method
A Tool enumeration value associated with the menu item.
An integer value which represents the top-level menu ID.
An integer value which represents the sub-level menu ID.
A boolean value which is true to enable the menu item. Otherwise, false should be set.
A boolean value which is true when the menu item is enabled and all other menu items on the same menu level are disabled. Otherwise, use false when the menu item is enabled and all other menu items on the same menu level do not have to be disabled.
Sets if a menu item is enabled.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetItemEnabled( _
   ByVal tool As Tool, _
   ByVal topMenuId As Integer, _
   ByVal subMenuId As Integer, _
   ByVal enabled As Boolean, _
   ByVal exclusive As Boolean _
)
'Usage

Dim instance As ToolbarContextMenu
Dim tool As Tool
Dim topMenuId As Integer
Dim subMenuId As Integer
Dim enabled As Boolean
Dim exclusive As Boolean

instance.SetItemEnabled(tool, topMenuId, subMenuId, enabled, exclusive)
public void SetItemEnabled(
   Tool tool,
   int topMenuId,
   int subMenuId,
   bool enabled,
   bool exclusive
)
public: void SetItemEnabled(
   Tool tool,
   int topMenuId,
   int subMenuId,
   bool enabled,
   bool exclusive
)
public:
void SetItemEnabled(
   Tool tool,
   int topMenuId,
   int subMenuId,
   bool enabled,
   bool exclusive
)

Parameters

tool
A Tool enumeration value associated with the menu item.
topMenuId
An integer value which represents the top-level menu ID.
subMenuId
An integer value which represents the sub-level menu ID.
enabled
A boolean value which is true to enable the menu item. Otherwise, false should be set.
exclusive
A boolean value which is true when the menu item is enabled and all other menu items on the same menu level are disabled. Otherwise, use false when the menu item is enabled and all other menu items on the same menu level do not have to be disabled.
Remarks

When a menu item is enabled, the application end-user can select the menu item. Items that are enabled appear in dark print. Items that are not enabled are grayed out.

See Also

Reference

ToolbarContextMenu Class
ToolbarContextMenu Members


SetItemVisible Method

SetItemVisible Method

Accusoft.ImagXpressSdk Namespace > ToolbarContextMenu Class : SetItemVisible Method
A Tool enumeration value associated with the menu item.
An integer value which represents the top-level menu ID.
An integer value which represents the sub-level menu ID.
A boolean value which is true to set the given menu item to visible. Otherwise, false should be set.
A boolean value which is true to set all other menu items on the same menu level as hidden. Otherwise, false should be set.
Sets if a menu item should be visible when the menu is displayed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetItemVisible( _
   ByVal tool As Tool, _
   ByVal topMenuId As Integer, _
   ByVal subMenuId As Integer, _
   ByVal visible As Boolean, _
   ByVal exclusive As Boolean _
)
'Usage

Dim instance As ToolbarContextMenu
Dim tool As Tool
Dim topMenuId As Integer
Dim subMenuId As Integer
Dim visible As Boolean
Dim exclusive As Boolean

instance.SetItemVisible(tool, topMenuId, subMenuId, visible, exclusive)
public void SetItemVisible(
   Tool tool,
   int topMenuId,
   int subMenuId,
   bool visible,
   bool exclusive
)
public: void SetItemVisible(
   Tool tool,
   int topMenuId,
   int subMenuId,
   bool visible,
   bool exclusive
)
public:
void SetItemVisible(
   Tool tool,
   int topMenuId,
   int subMenuId,
   bool visible,
   bool exclusive
)

Parameters

tool
A Tool enumeration value associated with the menu item.
topMenuId
An integer value which represents the top-level menu ID.
subMenuId
An integer value which represents the sub-level menu ID.
visible
A boolean value which is true to set the given menu item to visible. Otherwise, false should be set.
exclusive
A boolean value which is true to set all other menu items on the same menu level as hidden. Otherwise, false should be set.
See Also

Reference

ToolbarContextMenu Class
ToolbarContextMenu Members


ToolbarContextMenuEventArgs Class

ToolbarContextMenuEventArgs Class
Members

Accusoft.ImagXpressSdk Namespace : ToolbarContextMenuEventArgs Class
This class implements the event arguments for when a ToolbarContextMenuSelect event is fired.
Object Model
ToolbarContextMenuEventArgs Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ToolbarContextMenuEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As ToolbarContextMenuEventArgs
public class ToolbarContextMenuEventArgs : System.EventArgs
public __gc class ToolbarContextMenuEventArgs : public System.EventArgs
public ref class ToolbarContextMenuEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
Accusoft.ImagXpressSdk.ToolbarContextMenuEventArgs

See Also

Reference

ToolbarContextMenuEventArgs Members
Accusoft.ImagXpressSdk Namespace


ToolbarContextMenuEventArgs Class Members

ToolbarContextMenuEventArgs Class Members
Properties

Accusoft.ImagXpressSdk Namespace : ToolbarContextMenuEventArgs Class

The following tables list the members exposed by ToolbarContextMenuEventArgs.

Public Constructors
 | Name | Description
Public Constructor | ToolbarContextMenuEventArgs Constructor | The main constructor which initializes a new instance of the ToolbarContextMenuArgs class
Top
Public Properties
 | Name | Description
Public Property | SubMenuId | Gets the sub-level menu ID for this menu item.
Public Property | Tool | Gets the Tool associated with the context menu that fired the event.
Public Property | TopMenuId | Gets the top-level menu ID for this menu ID.
Public Property | User1 | Gets the first of two user-supplied values set when the menu was created.
Public Property | User2 | Gets the second of two user-supplied values set when the menu was created.
Top
See Also

Reference

ToolbarContextMenuEventArgs Class
Accusoft.ImagXpressSdk Namespace


ToolbarContextMenuEventArgs Constructor

ToolbarContextMenuEventArgs Constructor

Accusoft.ImagXpressSdk Namespace > ToolbarContextMenuEventArgs Class : ToolbarContextMenuEventArgs Constructor
The main constructor which initializes a new instance of the ToolbarContextMenuArgs class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ToolbarContextMenuEventArgs()
public ToolbarContextMenuEventArgs()
public: ToolbarContextMenuEventArgs();
public:
ToolbarContextMenuEventArgs();
See Also

Reference

ToolbarContextMenuEventArgs Class
ToolbarContextMenuEventArgs Members


ToolbarContextMenuEventArgs Class Properties

ToolbarContextMenuEventArgs Class Properties

Accusoft.ImagXpressSdk Namespace : ToolbarContextMenuEventArgs Class

For a list of all members of this type, see ToolbarContextMenuEventArgs members.

Public Properties
 | Name | Description
Public Property | SubMenuId | Gets the sub-level menu ID for this menu item.
Public Property | Tool | Gets the Tool associated with the context menu that fired the event.
Public Property | TopMenuId | Gets the top-level menu ID for this menu ID.
Public Property | User1 | Gets the first of two user-supplied values set when the menu was created.
Public Property | User2 | Gets the second of two user-supplied values set when the menu was created.
Top
See Also

Reference

ToolbarContextMenuEventArgs Class
Accusoft.ImagXpressSdk Namespace


ToolbarContextMenuEventArgs Constructor

ToolbarContextMenuEventArgs Constructor

Accusoft.ImagXpressSdk Namespace > ToolbarContextMenuEventArgs Class : ToolbarContextMenuEventArgs Constructor
Overload List
Overload | Description
ToolbarContextMenuEventArgs Constructor | The main constructor which initializes a new instance of the ToolbarContextMenuArgs class
See Also

Reference

ToolbarContextMenuEventArgs Class
ToolbarContextMenuEventArgs Members


SubMenuId Property

SubMenuId Property

Accusoft.ImagXpressSdk Namespace > ToolbarContextMenuEventArgs Class : SubMenuId Property
Gets the sub-level menu ID for this menu item.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property SubMenuId As Integer
'Usage

Dim instance As ToolbarContextMenuEventArgs
Dim value As Integer

value = instance.SubMenuId
public int SubMenuId {get;}
public: __property int get_SubMenuId();
public:
property int SubMenuId {
   int get();
}

Property Value

An integer value which represents the sub-level menu ID.
Remarks

This property will be 0 if the menu item was a top-level menu item.

See Also

Reference

ToolbarContextMenuEventArgs Class
ToolbarContextMenuEventArgs Members


Tool Property (ToolbarContextMenuEventArgs)

Tool Property (ToolbarContextMenuEventArgs)

Accusoft.ImagXpressSdk Namespace > ToolbarContextMenuEventArgs Class : Tool Property
Gets the Tool associated with the context menu that fired the event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Tool As Tool
'Usage

Dim instance As ToolbarContextMenuEventArgs
Dim value As Tool

value = instance.Tool
public Tool Tool {get;}
public: __property Tool get_Tool();
public:
property Tool Tool {
   Tool get();
}

Property Value

A Tool enumeration value associated with the event.
See Also

Reference

ToolbarContextMenuEventArgs Class
ToolbarContextMenuEventArgs Members


TopMenuId Property

TopMenuId Property

Accusoft.ImagXpressSdk Namespace > ToolbarContextMenuEventArgs Class : TopMenuId Property
Gets the top-level menu ID for this menu ID.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property TopMenuId As Integer
'Usage

Dim instance As ToolbarContextMenuEventArgs
Dim value As Integer

value = instance.TopMenuId
public int TopMenuId {get;}
public: __property int get_TopMenuId();
public:
property int TopMenuId {
   int get();
}

Property Value

An integer value which represents the top-level menu ID.
Remarks

A menu ID of 4100-4200 is reserved for adding a menu separator bar.

See Also

Reference

ToolbarContextMenuEventArgs Class
ToolbarContextMenuEventArgs Members


User1 Property (ToolbarContextMenuEventArgs)

User1 Property (ToolbarContextMenuEventArgs)

Accusoft.ImagXpressSdk Namespace > ToolbarContextMenuEventArgs Class : User1 Property
Gets the first of two user-supplied values set when the menu was created.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property User1 As Integer
'Usage

Dim instance As ToolbarContextMenuEventArgs
Dim value As Integer

value = instance.User1
public int User1 {get;}
public: __property int get_User1();
public:
property int User1 {
   int get();
}

Property Value

An integer value which represents the user-supplied values.
See Also

Reference

ToolbarContextMenuEventArgs Class
ToolbarContextMenuEventArgs Members


User2 Property (ToolbarContextMenuEventArgs)

User2 Property (ToolbarContextMenuEventArgs)

Accusoft.ImagXpressSdk Namespace > ToolbarContextMenuEventArgs Class : User2 Property
Gets the second of two user-supplied values set when the menu was created.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property User2 As Integer
'Usage

Dim instance As ToolbarContextMenuEventArgs
Dim value As Integer

value = instance.User2
public int User2 {get;}
public: __property int get_User2();
public:
property int User2 {
   int get();
}

Property Value

An integer value which represents the user-supplied values.
See Also

Reference

ToolbarContextMenuEventArgs Class
ToolbarContextMenuEventArgs Members


ToolbarEventArgs Class

ToolbarEventArgs Class
Members

Accusoft.ImagXpressSdk Namespace : ToolbarEventArgs Class
This class implements event data for toolbar events.
Object Model
ToolbarEventArgs Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ToolbarEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As ToolbarEventArgs
public class ToolbarEventArgs : System.EventArgs
public __gc class ToolbarEventArgs : public System.EventArgs
public ref class ToolbarEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
Accusoft.ImagXpressSdk.ToolbarEventArgs

See Also

Reference

ToolbarEventArgs Members
Accusoft.ImagXpressSdk Namespace


ToolbarEventArgs Class Members

ToolbarEventArgs Class Members
Properties

Accusoft.ImagXpressSdk Namespace : ToolbarEventArgs Class

The following tables list the members exposed by ToolbarEventArgs.

Public Constructors
 | Name | Description
Public Constructor | ToolbarEventArgs Constructor | The main constructor which intializes a new instance of the ToolbarEventArgs class.
Top
Public Properties
 | Name | Description
Public Property | Tool | Gets the selected tool.
Public Property | User1 | Gets the numerical value associated with the Tool.
Public Property | User2 | Gets the numerical value associated with the Tool.
Top
See Also

Reference

ToolbarEventArgs Class
Accusoft.ImagXpressSdk Namespace


ToolbarEventArgs Constructor

ToolbarEventArgs Constructor

Accusoft.ImagXpressSdk Namespace > ToolbarEventArgs Class : ToolbarEventArgs Constructor
The main constructor which intializes a new instance of the ToolbarEventArgs class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ToolbarEventArgs()
public ToolbarEventArgs()
public: ToolbarEventArgs();
public:
ToolbarEventArgs();
See Also

Reference

ToolbarEventArgs Class
ToolbarEventArgs Members


ToolbarEventArgs Class Properties

ToolbarEventArgs Class Properties

Accusoft.ImagXpressSdk Namespace : ToolbarEventArgs Class

For a list of all members of this type, see ToolbarEventArgs members.

Public Properties
 | Name | Description
Public Property | Tool | Gets the selected tool.
Public Property | User1 | Gets the numerical value associated with the Tool.
Public Property | User2 | Gets the numerical value associated with the Tool.
Top
See Also

Reference

ToolbarEventArgs Class
Accusoft.ImagXpressSdk Namespace


ToolbarEventArgs Constructor

ToolbarEventArgs Constructor

Accusoft.ImagXpressSdk Namespace > ToolbarEventArgs Class : ToolbarEventArgs Constructor
Overload List
Overload | Description
ToolbarEventArgs Constructor | The main constructor which intializes a new instance of the ToolbarEventArgs class.
See Also

Reference

ToolbarEventArgs Class
ToolbarEventArgs Members


Tool Property (ToolbarEventArgs)

Tool Property (ToolbarEventArgs)

Accusoft.ImagXpressSdk Namespace > ToolbarEventArgs Class : Tool Property
Gets the selected tool.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Tool As Tool
'Usage

Dim instance As ToolbarEventArgs
Dim value As Tool

value = instance.Tool
public Tool Tool {get;}
public: __property Tool get_Tool();
public:
property Tool Tool {
   Tool get();
}

Property Value

A Tool enumeration value associated to the event.
See Also

Reference

ToolbarEventArgs Class
ToolbarEventArgs Members


User1 Property (ToolbarEventArgs)

User1 Property (ToolbarEventArgs)

Accusoft.ImagXpressSdk Namespace > ToolbarEventArgs Class : User1 Property
Gets the numerical value associated with the Tool.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property User1 As Integer
'Usage

Dim instance As ToolbarEventArgs
Dim value As Integer

value = instance.User1
public int User1 {get;}
public: __property int get_User1();
public:
property int User1 {
   int get();
}

Property Value

An integer value which represents the Tool ID.
See Also

Reference

ToolbarEventArgs Class
ToolbarEventArgs Members


User2 Property (ToolbarEventArgs)

User2 Property (ToolbarEventArgs)

Accusoft.ImagXpressSdk Namespace > ToolbarEventArgs Class : User2 Property
Gets the numerical value associated with the Tool.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property User2 As Integer
'Usage

Dim instance As ToolbarEventArgs
Dim value As Integer

value = instance.User2
public int User2 {get;}
public: __property int get_User2();
public:
property int User2 {
   int get();
}

Property Value

An integer value which represents the Tool ID.
See Also

Reference

ToolbarEventArgs Class
ToolbarEventArgs Members


ToolbarOpenEventArgs Class

ToolbarOpenEventArgs Class
Members

Accusoft.ImagXpressSdk Namespace : ToolbarOpenEventArgs Class
This class implements information associated with a ToolbarOpenEvent.
Object Model
ToolbarOpenEventArgs Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ToolbarOpenEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As ToolbarOpenEventArgs
public class ToolbarOpenEventArgs : System.EventArgs
public __gc class ToolbarOpenEventArgs : public System.EventArgs
public ref class ToolbarOpenEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
Accusoft.ImagXpressSdk.ToolbarOpenEventArgs

See Also

Reference

ToolbarOpenEventArgs Members
Accusoft.ImagXpressSdk Namespace


ToolbarOpenEventArgs Class Members

ToolbarOpenEventArgs Class Members
Properties

Accusoft.ImagXpressSdk Namespace : ToolbarOpenEventArgs Class

The following tables list the members exposed by ToolbarOpenEventArgs.

Public Constructors
 | Name | Description
Public Constructor | ToolbarOpenEventArgs Constructor | The main constructor which initializes a new instance of the ToolbarOpenEventArgs class.
Top
Public Properties
 | Name | Description
Public Property | Handle | Gets the handle of the toolbar.
Top
See Also

Reference

ToolbarOpenEventArgs Class
Accusoft.ImagXpressSdk Namespace


ToolbarOpenEventArgs Constructor

ToolbarOpenEventArgs Constructor

Accusoft.ImagXpressSdk Namespace > ToolbarOpenEventArgs Class : ToolbarOpenEventArgs Constructor
The main constructor which initializes a new instance of the ToolbarOpenEventArgs class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ToolbarOpenEventArgs()
public ToolbarOpenEventArgs()
public: ToolbarOpenEventArgs();
public:
ToolbarOpenEventArgs();
See Also

Reference

ToolbarOpenEventArgs Class
ToolbarOpenEventArgs Members


ToolbarOpenEventArgs Class Properties

ToolbarOpenEventArgs Class Properties

Accusoft.ImagXpressSdk Namespace : ToolbarOpenEventArgs Class

For a list of all members of this type, see ToolbarOpenEventArgs members.

Public Properties
 | Name | Description
Public Property | Handle | Gets the handle of the toolbar.
Top
See Also

Reference

ToolbarOpenEventArgs Class
Accusoft.ImagXpressSdk Namespace


ToolbarOpenEventArgs Constructor

ToolbarOpenEventArgs Constructor

Accusoft.ImagXpressSdk Namespace > ToolbarOpenEventArgs Class : ToolbarOpenEventArgs Constructor
Overload List
Overload | Description
ToolbarOpenEventArgs Constructor | The main constructor which initializes a new instance of the ToolbarOpenEventArgs class.
See Also

Reference

ToolbarOpenEventArgs Class
ToolbarOpenEventArgs Members


Handle Property

Handle Property

Accusoft.ImagXpressSdk Namespace > ToolbarOpenEventArgs Class : Handle Property
Gets the handle of the toolbar.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Handle As IntPtr
'Usage

Dim instance As ToolbarOpenEventArgs
Dim value As IntPtr

value = instance.Handle
public IntPtr Handle {get;}
public: __property IntPtr get_Handle();
public:
property IntPtr Handle {
   IntPtr get();
}

Property Value

An System.IntPtr which represents the handle of the toolbar.
See Also

Reference

ToolbarOpenEventArgs Class
ToolbarOpenEventArgs Members


ToolEventArgs Class

ToolEventArgs Class
Members

Accusoft.ImagXpressSdk Namespace : ToolEventArgs Class
This class implements event data for tool events.
Object Model
ToolEventArgs Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ToolEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As ToolEventArgs
public class ToolEventArgs : System.EventArgs
public __gc class ToolEventArgs : public System.EventArgs
public ref class ToolEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
Accusoft.ImagXpressSdk.ToolEventArgs

See Also

Reference

ToolEventArgs Members
Accusoft.ImagXpressSdk Namespace


ToolEventArgs Class Members

ToolEventArgs Class Members
Properties

Accusoft.ImagXpressSdk Namespace : ToolEventArgs Class

The following tables list the members exposed by ToolEventArgs.

Public Constructors
 | Name | Description
Public Constructor | ToolEventArgs Constructor | The main constructor which intializes a new instance of the ToolEventArgs class.
Top
Public Properties
 | Name | Description
Public Property | Action | Gets the value of the action the tool performed.
Public Property | Location | Gets the location at which the tool action was performed.
Public Property | Tool | Gets the tool being used.
Top
See Also

Reference

ToolEventArgs Class
Accusoft.ImagXpressSdk Namespace


ToolEventArgs Constructor

ToolEventArgs Constructor

Accusoft.ImagXpressSdk Namespace > ToolEventArgs Class : ToolEventArgs Constructor
The main constructor which intializes a new instance of the ToolEventArgs class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ToolEventArgs()
public ToolEventArgs()
public: ToolEventArgs();
public:
ToolEventArgs();
See Also

Reference

ToolEventArgs Class
ToolEventArgs Members


ToolEventArgs Class Properties

ToolEventArgs Class Properties

Accusoft.ImagXpressSdk Namespace : ToolEventArgs Class

For a list of all members of this type, see ToolEventArgs members.

Public Properties
 | Name | Description
Public Property | Action | Gets the value of the action the tool performed.
Public Property | Location | Gets the location at which the tool action was performed.
Public Property | Tool | Gets the tool being used.
Top
See Also

Reference

ToolEventArgs Class
Accusoft.ImagXpressSdk Namespace


ToolEventArgs Constructor

ToolEventArgs Constructor

Accusoft.ImagXpressSdk Namespace > ToolEventArgs Class : ToolEventArgs Constructor
Overload List
Overload | Description
ToolEventArgs Constructor | The main constructor which intializes a new instance of the ToolEventArgs class.
See Also

Reference

ToolEventArgs Class
ToolEventArgs Members


Action Property

Action Property

Accusoft.ImagXpressSdk Namespace > ToolEventArgs Class : Action Property
Gets the value of the action the tool performed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Action As ToolAction
'Usage

Dim instance As ToolEventArgs
Dim value As ToolAction

value = instance.Action
public ToolAction Action {get;}
public: __property ToolAction get_Action();
public:
property ToolAction Action {
   ToolAction get();
}

Property Value

A ToolAction enumeration value.
See Also

Reference

ToolEventArgs Class
ToolEventArgs Members


Location Property

Location Property

Accusoft.ImagXpressSdk Namespace > ToolEventArgs Class : Location Property
Gets the location at which the tool action was performed.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Location As Point
'Usage

Dim instance As ToolEventArgs
Dim value As Point

value = instance.Location
public Point Location {get;}
public: __property Point get_Location();
public:
property Point Location {
   Point get();
}

Property Value

A System.Drawing.Point value which represents the location.
See Also

Reference

ToolEventArgs Class
ToolEventArgs Members


Tool Property (ToolEventArgs)

Tool Property (ToolEventArgs)

Accusoft.ImagXpressSdk Namespace > ToolEventArgs Class : Tool Property
Gets the tool being used.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Tool As Tool
'Usage

Dim instance As ToolEventArgs
Dim value As Tool

value = instance.Tool
public Tool Tool {get;}
public: __property Tool get_Tool();
public:
property Tool Tool {
   Tool get();
}

Property Value

A Tool enumeration value associated to the event.
See Also

Reference

ToolEventArgs Class
ToolEventArgs Members


Touch Class

Touch Class
Members

Accusoft.ImagXpressSdk Namespace : Touch Class
This class implements methods and properties for Windows Touch support.
Object Model
Touch Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class Touch
'Usage

Dim instance As Touch
public sealed class Touch
public __gc __sealed class Touch
public ref class Touch sealed
Inheritance Hierarchy

System.Object
Accusoft.ImagXpressSdk.Touch

See Also

Reference

Touch Members
Accusoft.ImagXpressSdk Namespace


Touch Class Members

Touch Class Members
Properties

Accusoft.ImagXpressSdk Namespace : Touch Class

The following tables list the members exposed by Touch.

Public Properties
 | Name | Description
Public Property | DoesOperatingSystemSupport | Gets whether the operating system supports touch.
Public Property | GestureOccurringEventsFiringMode | Gets and sets the mode for Touch to fire gesture occurring events.
Public Property | ImageContextMenuEnabled | Gets and sets whether the built-in touch operation to display the context menu is enabled for the current image.
Public Property | ImagePanningEnabled | Gets and sets whether the built-in touch panning operation is performed on the current image.
Public Property | ImageRotationEnabled | Gets and sets whether the built-in touch rotate operation is performed on the current image.
Public Property | ImageRotationMinimumAngle | Gets and sets the minimum angle that will trigger a rotation if no image rotation has occurred when a rotation gesture has ended.
Public Property | ImageRotationTriggerAngle | Gets and sets the angle that will trigger a rotation of the current image during a rotation gesture.
Public Property | ImageZoomingEnabled | Gets and sets whether the built-in touch zooming operation is performed on the current image.
Public Property | IsDeviceAvailable | Gets whether the computer system has a touch device.
Public Property | Mode | Gets and sets the mode for the Touch interface if one is available.
Public Property | RequireTwoFingerPanning | Gets and sets whether the panning requires two fingers.
Top
See Also

Reference

Touch Class
Accusoft.ImagXpressSdk Namespace


Touch Class Properties

Touch Class Properties

Accusoft.ImagXpressSdk Namespace : Touch Class

For a list of all members of this type, see Touch members.

Public Properties
 | Name | Description
Public Property | DoesOperatingSystemSupport | Gets whether the operating system supports touch.
Public Property | GestureOccurringEventsFiringMode | Gets and sets the mode for Touch to fire gesture occurring events.
Public Property | ImageContextMenuEnabled | Gets and sets whether the built-in touch operation to display the context menu is enabled for the current image.
Public Property | ImagePanningEnabled | Gets and sets whether the built-in touch panning operation is performed on the current image.
Public Property | ImageRotationEnabled | Gets and sets whether the built-in touch rotate operation is performed on the current image.
Public Property | ImageRotationMinimumAngle | Gets and sets the minimum angle that will trigger a rotation if no image rotation has occurred when a rotation gesture has ended.
Public Property | ImageRotationTriggerAngle | Gets and sets the angle that will trigger a rotation of the current image during a rotation gesture.
Public Property | ImageZoomingEnabled | Gets and sets whether the built-in touch zooming operation is performed on the current image.
Public Property | IsDeviceAvailable | Gets whether the computer system has a touch device.
Public Property | Mode | Gets and sets the mode for the Touch interface if one is available.
Public Property | RequireTwoFingerPanning | Gets and sets whether the panning requires two fingers.
Top
See Also

Reference

Touch Class
Accusoft.ImagXpressSdk Namespace


DoesOperatingSystemSupport Property

DoesOperatingSystemSupport Property

Accusoft.ImagXpressSdk Namespace > Touch Class : DoesOperatingSystemSupport Property
Gets whether the operating system supports touch.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DescriptionAttribute("This property returns whether the operating system supports touch.")>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property DoesOperatingSystemSupport As Boolean
'Usage

Dim instance As Touch
Dim value As Boolean

value = instance.DoesOperatingSystemSupport
[Description("This property returns whether the operating system supports touch.")]
[Browsable(false)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
public bool DoesOperatingSystemSupport {get;}
[Description("This property returns whether the operating system supports touch.")]
[Browsable(false)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
public: __property bool get_DoesOperatingSystemSupport();
[Description("This property returns whether the operating system supports touch.")]
[Browsable(false)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
public:
property bool DoesOperatingSystemSupport {
   bool get();
}

Property Value

A System.Boolean value.
See Also

Reference

Touch Class
Touch Members


GestureOccurringEventsFiringMode Property

GestureOccurringEventsFiringMode Property

Accusoft.ImagXpressSdk Namespace > Touch Class : GestureOccurringEventsFiringMode Property
Gets and sets the mode for Touch to fire gesture occurring events.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DefaultValueAttribute()>
<DescriptionAttribute("Gets and sets the mode for Touch to fire gesture occurring events.")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property GestureOccurringEventsFiringMode As FireGestureOccurringEvent
'Usage

Dim instance As Touch
Dim value As FireGestureOccurringEvent

instance.GestureOccurringEventsFiringMode = value

value = instance.GestureOccurringEventsFiringMode
[Browsable(false)]
[DefaultValue()]
[Description("Gets and sets the mode for Touch to fire gesture occurring events.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
public FireGestureOccurringEvent GestureOccurringEventsFiringMode {get; set;}
[Browsable(false)]
[DefaultValue()]
[Description("Gets and sets the mode for Touch to fire gesture occurring events.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
public: __property FireGestureOccurringEvent get_GestureOccurringEventsFiringMode();
public: __property void set_GestureOccurringEventsFiringMode(
   FireGestureOccurringEvent value
);
[Browsable(false)]
[DefaultValue()]
[Description("Gets and sets the mode for Touch to fire gesture occurring events.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
public:
property FireGestureOccurringEvent GestureOccurringEventsFiringMode {
   FireGestureOccurringEvent get();
   void set (    FireGestureOccurringEvent value);
}

Property Value

A FireGestureOccurringEvent enumeration value.
Remarks
The Window's touch system will send several extraneous events for touch gestures that show no movement. This property by default will allow the application to filter these events and only respond when there has been a change for the application to respond to. This will increase performance by not having so many extraneous gesture occurring events being generated and responded to.
See Also

Reference

Touch Class
Touch Members


ImageContextMenuEnabled Property

ImageContextMenuEnabled Property

Accusoft.ImagXpressSdk Namespace > Touch Class : ImageContextMenuEnabled Property
Gets and sets whether the built-in touch operation to display the context menu is enabled for the current image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
<BrowsableAttribute(False)>
<DescriptionAttribute("Gets and sets whether the built-in touch operation to display the context menu is enabled for the current image.")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property ImageContextMenuEnabled As Boolean
'Usage

Dim instance As Touch
Dim value As Boolean

instance.ImageContextMenuEnabled = value

value = instance.ImageContextMenuEnabled
[DefaultValue()]
[Browsable(false)]
[Description("Gets and sets whether the built-in touch operation to display the context menu is enabled for the current image.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
public bool ImageContextMenuEnabled {get; set;}
[DefaultValue()]
[Browsable(false)]
[Description("Gets and sets whether the built-in touch operation to display the context menu is enabled for the current image.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
public: __property bool get_ImageContextMenuEnabled();
public: __property void set_ImageContextMenuEnabled(
   bool value
);
[DefaultValue()]
[Browsable(false)]
[Description("Gets and sets whether the built-in touch operation to display the context menu is enabled for the current image.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
public:
property bool ImageContextMenuEnabled {
   bool get();
   void set (    bool value);
}

Property Value

A System.Boolean value.
See Also

Reference

Touch Class
Touch Members


ImagePanningEnabled Property

ImagePanningEnabled Property

Accusoft.ImagXpressSdk Namespace > Touch Class : ImagePanningEnabled Property
Gets and sets whether the built-in touch panning operation is performed on the current image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DescriptionAttribute("This property sets and returns whether the built-in touch panning operation is performed on the current image.")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<DefaultValueAttribute()>
Public Property ImagePanningEnabled As Boolean
'Usage

Dim instance As Touch
Dim value As Boolean

instance.ImagePanningEnabled = value

value = instance.ImagePanningEnabled
[Browsable(false)]
[Description("This property sets and returns whether the built-in touch panning operation is performed on the current image.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[DefaultValue()]
public bool ImagePanningEnabled {get; set;}
[Browsable(false)]
[Description("This property sets and returns whether the built-in touch panning operation is performed on the current image.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[DefaultValue()]
public: __property bool get_ImagePanningEnabled();
public: __property void set_ImagePanningEnabled(
   bool value
);
[Browsable(false)]
[Description("This property sets and returns whether the built-in touch panning operation is performed on the current image.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[DefaultValue()]
public:
property bool ImagePanningEnabled {
   bool get();
   void set (    bool value);
}

Property Value

A System.Boolean value.
See Also

Reference

Touch Class
Touch Members


ImageRotationEnabled Property

ImageRotationEnabled Property

Accusoft.ImagXpressSdk Namespace > Touch Class : ImageRotationEnabled Property
Gets and sets whether the built-in touch rotate operation is performed on the current image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<DefaultValueAttribute()>
<BrowsableAttribute(False)>
<DescriptionAttribute("This property sets and returns the built-in touch rotate operation is performed on the current image.")>
Public Property ImageRotationEnabled As Boolean
'Usage

Dim instance As Touch
Dim value As Boolean

instance.ImageRotationEnabled = value

value = instance.ImageRotationEnabled
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[DefaultValue()]
[Browsable(false)]
[Description("This property sets and returns the built-in touch rotate operation is performed on the current image.")]
public bool ImageRotationEnabled {get; set;}
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[DefaultValue()]
[Browsable(false)]
[Description("This property sets and returns the built-in touch rotate operation is performed on the current image.")]
public: __property bool get_ImageRotationEnabled();
public: __property void set_ImageRotationEnabled(
   bool value
);
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[DefaultValue()]
[Browsable(false)]
[Description("This property sets and returns the built-in touch rotate operation is performed on the current image.")]
public:
property bool ImageRotationEnabled {
   bool get();
   void set (    bool value);
}

Property Value

A System.Boolean value.
See Also

Reference

Touch Class
Touch Members


ImageRotationMinimumAngle Property

ImageRotationMinimumAngle Property

Accusoft.ImagXpressSdk Namespace > Touch Class : ImageRotationMinimumAngle Property
Gets and sets the minimum angle that will trigger a rotation if no image rotation has occurred when a rotation gesture has ended.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DefaultValueAttribute()>
<DescriptionAttribute("Gets and sets the minimum angle that will trigger a rotation if no image rotation has occurred when a rotation gesture has ended.")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
Public Property ImageRotationMinimumAngle As Double
'Usage

Dim instance As Touch
Dim value As Double

instance.ImageRotationMinimumAngle = value

value = instance.ImageRotationMinimumAngle
[DefaultValue()]
[Description("Gets and sets the minimum angle that will trigger a rotation if no image rotation has occurred when a rotation gesture has ended.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Browsable(false)]
public double ImageRotationMinimumAngle {get; set;}
[DefaultValue()]
[Description("Gets and sets the minimum angle that will trigger a rotation if no image rotation has occurred when a rotation gesture has ended.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Browsable(false)]
public: __property double get_ImageRotationMinimumAngle();
public: __property void set_ImageRotationMinimumAngle(
   double value
);
[DefaultValue()]
[Description("Gets and sets the minimum angle that will trigger a rotation if no image rotation has occurred when a rotation gesture has ended.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Browsable(false)]
public:
property double ImageRotationMinimumAngle {
   double get();
   void set (    double value);
}

Property Value

A System.Double value from 0.0° to 90.0°. The default value is 10.0°.
Remarks

Note: This property is only valid when the ImageRotationEnabled property is set to true.

This property allows a user to do a slight quick rotation gesture to initiate a single 90° rotation of the image. If this behavior is not desired then this property should be set equal to or greater than the ImageRotationTriggerAngle property.

See Also

Reference

Touch Class
Touch Members


ImageRotationTriggerAngle Property

ImageRotationTriggerAngle Property

Accusoft.ImagXpressSdk Namespace > Touch Class : ImageRotationTriggerAngle Property
Gets and sets the angle that will trigger a rotation of the current image during a rotation gesture.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<DefaultValueAttribute()>
<BrowsableAttribute(False)>
<DescriptionAttribute("Gets and sets the angle that will trigger a rotation of the current image during a rotation gesture.")>
Public Property ImageRotationTriggerAngle As Double
'Usage

Dim instance As Touch
Dim value As Double

instance.ImageRotationTriggerAngle = value

value = instance.ImageRotationTriggerAngle
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[DefaultValue()]
[Browsable(false)]
[Description("Gets and sets the angle that will trigger a rotation of the current image during a rotation gesture.")]
public double ImageRotationTriggerAngle {get; set;}
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[DefaultValue()]
[Browsable(false)]
[Description("Gets and sets the angle that will trigger a rotation of the current image during a rotation gesture.")]
public: __property double get_ImageRotationTriggerAngle();
public: __property void set_ImageRotationTriggerAngle(
   double value
);
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[DefaultValue()]
[Browsable(false)]
[Description("Gets and sets the angle that will trigger a rotation of the current image during a rotation gesture.")]
public:
property double ImageRotationTriggerAngle {
   double get();
   void set (    double value);
}

Property Value

A System.Double value from 0.0° to 90.0°. The default value is 45.0°.
Remarks

Note: This property is only valid when the ImageRotationEnabled property is set to true.

This property determines what angles will trigger a rotation of the current image during a rotation gesture. For instance, if this property were set to 30° then when the user rotated greater than 30° the image would rotate 90°. If the user rotated back below 30°, the image would rotate back the 90°. With 30° as an example, think of each place a rotation could occur as the numbers on a clock. If the user passed his fingers from the 12 o'clock position to across the 1 o'clock position, the image would rotate 90° clockwise. If the user went backwards so that his fingers crossed the 1 o'clock position towards the 12 o'clock position then the image would rotate back 90° counter-clockwise when the user's fingers had passed on the other side of the 1 o'clock position. If this behavior is not desired then the application can either set this value to 90.0° or set the ImageRotationEnabled property to false and handle the ImageXView.RotationGestureOccurring and ImageXView.RotationGestureOccurred events.

See Also

Reference

Touch Class
Touch Members


ImageZoomingEnabled Property

ImageZoomingEnabled Property

Accusoft.ImagXpressSdk Namespace > Touch Class : ImageZoomingEnabled Property
Gets and sets whether the built-in touch zooming operation is performed on the current image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DefaultValueAttribute()>
<DescriptionAttribute("This property sets and returns whether the built-in touch zooming operation is performed on the current image.")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property ImageZoomingEnabled As Boolean
'Usage

Dim instance As Touch
Dim value As Boolean

instance.ImageZoomingEnabled = value

value = instance.ImageZoomingEnabled
[Browsable(false)]
[DefaultValue()]
[Description("This property sets and returns whether the built-in touch zooming operation is performed on the current image.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
public bool ImageZoomingEnabled {get; set;}
[Browsable(false)]
[DefaultValue()]
[Description("This property sets and returns whether the built-in touch zooming operation is performed on the current image.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
public: __property bool get_ImageZoomingEnabled();
public: __property void set_ImageZoomingEnabled(
   bool value
);
[Browsable(false)]
[DefaultValue()]
[Description("This property sets and returns whether the built-in touch zooming operation is performed on the current image.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
public:
property bool ImageZoomingEnabled {
   bool get();
   void set (    bool value);
}

Property Value

A System.Boolean value.
See Also

Reference

Touch Class
Touch Members


IsDeviceAvailable Property

IsDeviceAvailable Property

Accusoft.ImagXpressSdk Namespace > Touch Class : IsDeviceAvailable Property
Gets whether the computer system has a touch device.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
<DescriptionAttribute("This property returns whether the computer system has a touch device.")>
Public ReadOnly Property IsDeviceAvailable As Boolean
'Usage

Dim instance As Touch
Dim value As Boolean

value = instance.IsDeviceAvailable
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Browsable(false)]
[Description("This property returns whether the computer system has a touch device.")]
public bool IsDeviceAvailable {get;}
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Browsable(false)]
[Description("This property returns whether the computer system has a touch device.")]
public: __property bool get_IsDeviceAvailable();
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[Browsable(false)]
[Description("This property returns whether the computer system has a touch device.")]
public:
property bool IsDeviceAvailable {
   bool get();
}

Property Value

A System.Boolean value.
See Also

Reference

Touch Class
Touch Members


Mode Property

Mode Property

Accusoft.ImagXpressSdk Namespace > Touch Class : Mode Property
Gets and sets the mode for the Touch interface if one is available.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<DefaultValueAttribute()>
<DescriptionAttribute("This property returns and sets the mode to the Touch interface.")>
Public Property Mode As TouchMode
'Usage

Dim instance As Touch
Dim value As TouchMode

instance.Mode = value

value = instance.Mode
[Browsable(false)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[DefaultValue()]
[Description("This property returns and sets the mode to the Touch interface.")]
public TouchMode Mode {get; set;}
[Browsable(false)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[DefaultValue()]
[Description("This property returns and sets the mode to the Touch interface.")]
public: __property TouchMode get_Mode();
public: __property void set_Mode(
   TouchMode value
);
[Browsable(false)]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
[DefaultValue()]
[Description("This property returns and sets the mode to the Touch interface.")]
public:
property TouchMode Mode {
   TouchMode get();
   void set (    TouchMode value);
}

Property Value

A TouchMode enumeration value.
See Also

Reference

Touch Class
Touch Members


RequireTwoFingerPanning Property

RequireTwoFingerPanning Property

Accusoft.ImagXpressSdk Namespace > Touch Class : RequireTwoFingerPanning Property
Gets and sets whether the panning requires two fingers.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DefaultValueAttribute()>
<DescriptionAttribute("Gets and sets whether the panning requires two fingers.")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property RequireTwoFingerPanning As Boolean
'Usage

Dim instance As Touch
Dim value As Boolean

instance.RequireTwoFingerPanning = value

value = instance.RequireTwoFingerPanning
[Browsable(false)]
[DefaultValue()]
[Description("Gets and sets whether the panning requires two fingers.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
public bool RequireTwoFingerPanning {get; set;}
[Browsable(false)]
[DefaultValue()]
[Description("Gets and sets whether the panning requires two fingers.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
public: __property bool get_RequireTwoFingerPanning();
public: __property void set_RequireTwoFingerPanning(
   bool value
);
[Browsable(false)]
[DefaultValue()]
[Description("Gets and sets whether the panning requires two fingers.")]
[DesignerSerializationVisibility(DesignerSerializationVisibility.Hidden)]
public:
property bool RequireTwoFingerPanning {
   bool get();
   void set (    bool value);
}

Property Value

A System.Boolean value.
Remarks
This property is useful if you wish to support flicks and gestures simultaneously. By requiring more than a single finger for panning, the Window's touch system is more easily able to identify between pan gestures and flicks. However, it is still possible to have both flicks and single finger panning. There will just be the occasional misinterpretation by the Window's touch system.
See Also

Reference

Touch Class
Touch Members


TwoFingerTapEventArgs Class

TwoFingerTapEventArgs Class
Members

Accusoft.ImagXpressSdk Namespace : TwoFingerTapEventArgs Class
This class implements event data for TwoFingerTap events.
Object Model
TwoFingerTapEventArgs Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class TwoFingerTapEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As TwoFingerTapEventArgs
public class TwoFingerTapEventArgs : System.EventArgs
public __gc class TwoFingerTapEventArgs : public System.EventArgs
public ref class TwoFingerTapEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
Accusoft.ImagXpressSdk.TwoFingerTapEventArgs

See Also

Reference

TwoFingerTapEventArgs Members
Accusoft.ImagXpressSdk Namespace


TwoFingerTapEventArgs Class Members

TwoFingerTapEventArgs Class Members
Properties

Accusoft.ImagXpressSdk Namespace : TwoFingerTapEventArgs Class

The following tables list the members exposed by TwoFingerTapEventArgs.

Public Constructors
 | Name | Description
Public Constructor | TwoFingerTapEventArgs Constructor | The main constructor which initializes a new instance of the TouchTwoFingerTapEventArgs class.
Top
Public Properties
 | Name | Description
Public Property | FirstFingerLocation | Gets the location of the first finger during a two finger tap with the touch interface.
Public Property | SecondFingerLocation | Gets the location of the second finger during a two finger tap with the touch interface.
Top
See Also

Reference

TwoFingerTapEventArgs Class
Accusoft.ImagXpressSdk Namespace


TwoFingerTapEventArgs Constructor

TwoFingerTapEventArgs Constructor

Accusoft.ImagXpressSdk Namespace > TwoFingerTapEventArgs Class : TwoFingerTapEventArgs Constructor
The main constructor which initializes a new instance of the TouchTwoFingerTapEventArgs class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New TwoFingerTapEventArgs()
public TwoFingerTapEventArgs()
public: TwoFingerTapEventArgs();
public:
TwoFingerTapEventArgs();
See Also

Reference

TwoFingerTapEventArgs Class
TwoFingerTapEventArgs Members


TwoFingerTapEventArgs Class Properties

TwoFingerTapEventArgs Class Properties

Accusoft.ImagXpressSdk Namespace : TwoFingerTapEventArgs Class

For a list of all members of this type, see TwoFingerTapEventArgs members.

Public Properties
 | Name | Description
Public Property | FirstFingerLocation | Gets the location of the first finger during a two finger tap with the touch interface.
Public Property | SecondFingerLocation | Gets the location of the second finger during a two finger tap with the touch interface.
Top
See Also

Reference

TwoFingerTapEventArgs Class
Accusoft.ImagXpressSdk Namespace


TwoFingerTapEventArgs Constructor

TwoFingerTapEventArgs Constructor

Accusoft.ImagXpressSdk Namespace > TwoFingerTapEventArgs Class : TwoFingerTapEventArgs Constructor
Overload List
Overload | Description
TwoFingerTapEventArgs Constructor | The main constructor which initializes a new instance of the TouchTwoFingerTapEventArgs class.
See Also

Reference

TwoFingerTapEventArgs Class
TwoFingerTapEventArgs Members


FirstFingerLocation Property

FirstFingerLocation Property

Accusoft.ImagXpressSdk Namespace > TwoFingerTapEventArgs Class : FirstFingerLocation Property
Gets the location of the first finger during a two finger tap with the touch interface.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property FirstFingerLocation As Point
'Usage

Dim instance As TwoFingerTapEventArgs
Dim value As Point

value = instance.FirstFingerLocation
public Point FirstFingerLocation {get;}
public: __property Point get_FirstFingerLocation();
public:
property Point FirstFingerLocation {
   Point get();
}

Property Value

A System.Drawing.Point value from the .NET Framework Class Library.
See Also

Reference

TwoFingerTapEventArgs Class
TwoFingerTapEventArgs Members


SecondFingerLocation Property

SecondFingerLocation Property

Accusoft.ImagXpressSdk Namespace > TwoFingerTapEventArgs Class : SecondFingerLocation Property
Gets the location of the second finger during a two finger tap with the touch interface.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property SecondFingerLocation As Point
'Usage

Dim instance As TwoFingerTapEventArgs
Dim value As Point

value = instance.SecondFingerLocation
public Point SecondFingerLocation {get;}
public: __property Point get_SecondFingerLocation();
public:
property Point SecondFingerLocation {
   Point get();
}

Property Value

A System.Drawing.Point value from the .NET Framework Class Library.
See Also

Reference

TwoFingerTapEventArgs Class
TwoFingerTapEventArgs Members


WorkerImports Class

WorkerImports Class
Members

Accusoft.ImagXpressSdk Namespace : WorkerImports Class
Summary description for WorkerImports.
Object Model
WorkerImports Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<SuppressUnmanagedCodeSecurityAttribute()>
Public Class WorkerImports
'Usage

Dim instance As WorkerImports
[SuppressUnmanagedCodeSecurity()]
public class WorkerImports
[SuppressUnmanagedCodeSecurity()]
public __gc class WorkerImports
[SuppressUnmanagedCodeSecurity()]
public ref class WorkerImports
Inheritance Hierarchy

System.Object
Accusoft.ImagXpressSdk.WorkerImports

See Also

Reference

WorkerImports Members
Accusoft.ImagXpressSdk Namespace


WorkerImports Class Members

WorkerImports Class Members

Accusoft.ImagXpressSdk Namespace : WorkerImports Class

The following tables list the members exposed by WorkerImports.

Public Constructors
 | Name | Description
Public Constructor | WorkerImports Constructor | Initializes a new instance of the WorkerImports class.
Top
See Also

Reference

WorkerImports Class
Accusoft.ImagXpressSdk Namespace


WorkerImports Constructor

WorkerImports Constructor

Accusoft.ImagXpressSdk Namespace > WorkerImports Class : WorkerImports Constructor
Initializes a new instance of the WorkerImports class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New WorkerImports()
public WorkerImports()
public: WorkerImports();
public:
WorkerImports();
See Also

Reference

WorkerImports Class
WorkerImports Members


ZoomFactorChangedEventArgs Class

ZoomFactorChangedEventArgs Class
Members

Accusoft.ImagXpressSdk Namespace : ZoomFactorChangedEventArgs Class
This class implements event data for ZoomFactorChanged events.
Object Model
ZoomFactorChangedEventArgs Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ZoomFactorChangedEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As ZoomFactorChangedEventArgs
public class ZoomFactorChangedEventArgs : System.EventArgs
public __gc class ZoomFactorChangedEventArgs : public System.EventArgs
public ref class ZoomFactorChangedEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
Accusoft.ImagXpressSdk.ZoomFactorChangedEventArgs

See Also

Reference

ZoomFactorChangedEventArgs Members
Accusoft.ImagXpressSdk Namespace


ZoomFactorChangedEventArgs Class Members

ZoomFactorChangedEventArgs Class Members
Properties

Accusoft.ImagXpressSdk Namespace : ZoomFactorChangedEventArgs Class

The following tables list the members exposed by ZoomFactorChangedEventArgs.

Public Constructors
 | Name | Description
Public Constructor | ZoomFactorChangedEventArgs Constructor | The main constructor which initializes a new instance of the ZoomFactorChangedEventArgs class.
Top
Public Properties
 | Name | Description
Public Property | NewValue | Gets the new value for the ZoomFactor property.
Public Property | OldValue | Gets the old value for the ZoomFactor property.
Top
See Also

Reference

ZoomFactorChangedEventArgs Class
Accusoft.ImagXpressSdk Namespace


ZoomFactorChangedEventArgs Constructor

ZoomFactorChangedEventArgs Constructor

Accusoft.ImagXpressSdk Namespace > ZoomFactorChangedEventArgs Class : ZoomFactorChangedEventArgs Constructor
The main constructor which initializes a new instance of the ZoomFactorChangedEventArgs class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ZoomFactorChangedEventArgs()
public ZoomFactorChangedEventArgs()
public: ZoomFactorChangedEventArgs();
public:
ZoomFactorChangedEventArgs();
See Also

Reference

ZoomFactorChangedEventArgs Class
ZoomFactorChangedEventArgs Members


ZoomFactorChangedEventArgs Class Properties

ZoomFactorChangedEventArgs Class Properties

Accusoft.ImagXpressSdk Namespace : ZoomFactorChangedEventArgs Class

For a list of all members of this type, see ZoomFactorChangedEventArgs members.

Public Properties
 | Name | Description
Public Property | NewValue | Gets the new value for the ZoomFactor property.
Public Property | OldValue | Gets the old value for the ZoomFactor property.
Top
See Also

Reference

ZoomFactorChangedEventArgs Class
Accusoft.ImagXpressSdk Namespace


ZoomFactorChangedEventArgs Constructor

ZoomFactorChangedEventArgs Constructor

Accusoft.ImagXpressSdk Namespace > ZoomFactorChangedEventArgs Class : ZoomFactorChangedEventArgs Constructor
Overload List
Overload | Description
ZoomFactorChangedEventArgs Constructor | The main constructor which initializes a new instance of the ZoomFactorChangedEventArgs class.
See Also

Reference

ZoomFactorChangedEventArgs Class
ZoomFactorChangedEventArgs Members


NewValue Property (ZoomFactorChangedEventArgs)

NewValue Property (ZoomFactorChangedEventArgs)

Accusoft.ImagXpressSdk Namespace > ZoomFactorChangedEventArgs Class : NewValue Property
Gets the new value for the ZoomFactor property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property NewValue As Double
'Usage

Dim instance As ZoomFactorChangedEventArgs
Dim value As Double

value = instance.NewValue
public double NewValue {get;}
public: __property double get_NewValue();
public:
property double NewValue {
   double get();
}

Property Value

A System.Double value from the .NET Framework Class Library.
See Also

Reference

ZoomFactorChangedEventArgs Class
ZoomFactorChangedEventArgs Members


OldValue Property (ZoomFactorChangedEventArgs)

OldValue Property (ZoomFactorChangedEventArgs)

Accusoft.ImagXpressSdk Namespace > ZoomFactorChangedEventArgs Class : OldValue Property
Gets the old value for the ZoomFactor property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property OldValue As Double
'Usage

Dim instance As ZoomFactorChangedEventArgs
Dim value As Double

value = instance.OldValue
public double OldValue {get;}
public: __property double get_OldValue();
public:
property double OldValue {
   double get();
}

Property Value

A System.Double value from the .NET Framework Class Library.
See Also

Reference

ZoomFactorChangedEventArgs Class
ZoomFactorChangedEventArgs Members


ZoomGestureOccurredEventArgs Class

ZoomGestureOccurredEventArgs Class
Members

Accusoft.ImagXpressSdk Namespace : ZoomGestureOccurredEventArgs Class
This class implements event data for ZoomGestureOccurred events.
Object Model
ZoomGestureOccurredEventArgs Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ZoomGestureOccurredEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As ZoomGestureOccurredEventArgs
public class ZoomGestureOccurredEventArgs : System.EventArgs
public __gc class ZoomGestureOccurredEventArgs : public System.EventArgs
public ref class ZoomGestureOccurredEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
Accusoft.ImagXpressSdk.ZoomGestureOccurredEventArgs

See Also

Reference

ZoomGestureOccurredEventArgs Members
Accusoft.ImagXpressSdk Namespace


ZoomGestureOccurredEventArgs Class Members

ZoomGestureOccurredEventArgs Class Members
Properties

Accusoft.ImagXpressSdk Namespace : ZoomGestureOccurredEventArgs Class

The following tables list the members exposed by ZoomGestureOccurredEventArgs.

Public Constructors
 | Name | Description
Public Constructor | ZoomGestureOccurredEventArgs Constructor | The main constructor which initializes a new instance of the ZoomGestureOccurredEventArgs class.
Top
Public Properties
 | Name | Description
Public Property | TotalZoomCoefficient | Gets the total zoom coefficient since the beginning of the zoom gesture with the touch interface.
Public Property | ZoomCenterPoint | Gets the center of the fingers during zooming with the touch interface.
Top
See Also

Reference

ZoomGestureOccurredEventArgs Class
Accusoft.ImagXpressSdk Namespace


ZoomGestureOccurredEventArgs Constructor

ZoomGestureOccurredEventArgs Constructor

Accusoft.ImagXpressSdk Namespace > ZoomGestureOccurredEventArgs Class : ZoomGestureOccurredEventArgs Constructor
The main constructor which initializes a new instance of the ZoomGestureOccurredEventArgs class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ZoomGestureOccurredEventArgs()
public ZoomGestureOccurredEventArgs()
public: ZoomGestureOccurredEventArgs();
public:
ZoomGestureOccurredEventArgs();
See Also

Reference

ZoomGestureOccurredEventArgs Class
ZoomGestureOccurredEventArgs Members


ZoomGestureOccurredEventArgs Class Properties

ZoomGestureOccurredEventArgs Class Properties

Accusoft.ImagXpressSdk Namespace : ZoomGestureOccurredEventArgs Class

For a list of all members of this type, see ZoomGestureOccurredEventArgs members.

Public Properties
 | Name | Description
Public Property | TotalZoomCoefficient | Gets the total zoom coefficient since the beginning of the zoom gesture with the touch interface.
Public Property | ZoomCenterPoint | Gets the center of the fingers during zooming with the touch interface.
Top
See Also

Reference

ZoomGestureOccurredEventArgs Class
Accusoft.ImagXpressSdk Namespace


ZoomGestureOccurredEventArgs Constructor

ZoomGestureOccurredEventArgs Constructor

Accusoft.ImagXpressSdk Namespace > ZoomGestureOccurredEventArgs Class : ZoomGestureOccurredEventArgs Constructor
Overload List
Overload | Description
ZoomGestureOccurredEventArgs Constructor | The main constructor which initializes a new instance of the ZoomGestureOccurredEventArgs class.
See Also

Reference

ZoomGestureOccurredEventArgs Class
ZoomGestureOccurredEventArgs Members


TotalZoomCoefficient Property

TotalZoomCoefficient Property

Accusoft.ImagXpressSdk Namespace > ZoomGestureOccurredEventArgs Class : TotalZoomCoefficient Property
Gets the total zoom coefficient since the beginning of the zoom gesture with the touch interface.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property TotalZoomCoefficient As Double
'Usage

Dim instance As ZoomGestureOccurredEventArgs
Dim value As Double

value = instance.TotalZoomCoefficient
public double TotalZoomCoefficient {get;}
public: __property double get_TotalZoomCoefficient();
public:
property double TotalZoomCoefficient {
   double get();
}

Property Value

A System.Drawing.Point value from the .NET Framework Class Library.
Remarks
The total zoom coefficient is usually multiplied with the starting zoom factor to get the new zoom factor.
See Also

Reference

ZoomGestureOccurredEventArgs Class
ZoomGestureOccurredEventArgs Members


ZoomCenterPoint Property (ZoomGestureOccurredEventArgs)

ZoomCenterPoint Property (ZoomGestureOccurredEventArgs)

Accusoft.ImagXpressSdk Namespace > ZoomGestureOccurredEventArgs Class : ZoomCenterPoint Property
Gets the center of the fingers during zooming with the touch interface.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ZoomCenterPoint As Point
'Usage

Dim instance As ZoomGestureOccurredEventArgs
Dim value As Point

value = instance.ZoomCenterPoint
public Point ZoomCenterPoint {get;}
public: __property Point get_ZoomCenterPoint();
public:
property Point ZoomCenterPoint {
   Point get();
}

Property Value

A System.Drawing.Point value from the .NET Framework Class Library.
See Also

Reference

ZoomGestureOccurredEventArgs Class
ZoomGestureOccurredEventArgs Members


ZoomGestureOccurringEventArgs Class

ZoomGestureOccurringEventArgs Class
Members

Accusoft.ImagXpressSdk Namespace : ZoomGestureOccurringEventArgs Class
This class implements event data for ZoomGestureOccurring events.
Object Model
ZoomGestureOccurringEventArgs Class
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ZoomGestureOccurringEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As ZoomGestureOccurringEventArgs
public class ZoomGestureOccurringEventArgs : System.EventArgs
public __gc class ZoomGestureOccurringEventArgs : public System.EventArgs
public ref class ZoomGestureOccurringEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
Accusoft.ImagXpressSdk.ZoomGestureOccurringEventArgs

See Also

Reference

ZoomGestureOccurringEventArgs Members
Accusoft.ImagXpressSdk Namespace


ZoomGestureOccurringEventArgs Class Members

ZoomGestureOccurringEventArgs Class Members
Properties

Accusoft.ImagXpressSdk Namespace : ZoomGestureOccurringEventArgs Class

The following tables list the members exposed by ZoomGestureOccurringEventArgs.

Public Constructors
 | Name | Description
Public Constructor | ZoomGestureOccurringEventArgs Constructor | The main constructor which initializes a new instance of the ZoomGestureOccurringEventArgs class.
Top
Public Properties
 | Name | Description
Public Property | ZoomCenterPoint | Gets the center of the fingers during zooming with the touch interface.
Public Property | ZoomCoefficientSinceLastEventFiring | Gets the zoom coefficient since the last ZoomGestureOccurring event firing during zooming with the touch interface.
Top
See Also

Reference

ZoomGestureOccurringEventArgs Class
Accusoft.ImagXpressSdk Namespace


ZoomGestureOccurringEventArgs Constructor

ZoomGestureOccurringEventArgs Constructor

Accusoft.ImagXpressSdk Namespace > ZoomGestureOccurringEventArgs Class : ZoomGestureOccurringEventArgs Constructor
The main constructor which initializes a new instance of the ZoomGestureOccurringEventArgs class.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ZoomGestureOccurringEventArgs()
public ZoomGestureOccurringEventArgs()
public: ZoomGestureOccurringEventArgs();
public:
ZoomGestureOccurringEventArgs();
See Also

Reference

ZoomGestureOccurringEventArgs Class
ZoomGestureOccurringEventArgs Members


ZoomGestureOccurringEventArgs Class Properties

ZoomGestureOccurringEventArgs Class Properties

Accusoft.ImagXpressSdk Namespace : ZoomGestureOccurringEventArgs Class

For a list of all members of this type, see ZoomGestureOccurringEventArgs members.

Public Properties
 | Name | Description
Public Property | ZoomCenterPoint | Gets the center of the fingers during zooming with the touch interface.
Public Property | ZoomCoefficientSinceLastEventFiring | Gets the zoom coefficient since the last ZoomGestureOccurring event firing during zooming with the touch interface.
Top
See Also

Reference

ZoomGestureOccurringEventArgs Class
Accusoft.ImagXpressSdk Namespace


ZoomGestureOccurringEventArgs Constructor

ZoomGestureOccurringEventArgs Constructor

Accusoft.ImagXpressSdk Namespace > ZoomGestureOccurringEventArgs Class : ZoomGestureOccurringEventArgs Constructor
Overload List
Overload | Description
ZoomGestureOccurringEventArgs Constructor | The main constructor which initializes a new instance of the ZoomGestureOccurringEventArgs class.
See Also

Reference

ZoomGestureOccurringEventArgs Class
ZoomGestureOccurringEventArgs Members


ZoomCenterPoint Property (ZoomGestureOccurringEventArgs)

ZoomCenterPoint Property (ZoomGestureOccurringEventArgs)

Accusoft.ImagXpressSdk Namespace > ZoomGestureOccurringEventArgs Class : ZoomCenterPoint Property
Gets the center of the fingers during zooming with the touch interface.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ZoomCenterPoint As Point
'Usage

Dim instance As ZoomGestureOccurringEventArgs
Dim value As Point

value = instance.ZoomCenterPoint
public Point ZoomCenterPoint {get;}
public: __property Point get_ZoomCenterPoint();
public:
property Point ZoomCenterPoint {
   Point get();
}

Property Value

A System.Drawing.Point value from the .NET Framework Class Library.
See Also

Reference

ZoomGestureOccurringEventArgs Class
ZoomGestureOccurringEventArgs Members


ZoomCoefficientSinceLastEventFiring Property

ZoomCoefficientSinceLastEventFiring Property

Accusoft.ImagXpressSdk Namespace > ZoomGestureOccurringEventArgs Class : ZoomCoefficientSinceLastEventFiring Property
Gets the zoom coefficient since the last ZoomGestureOccurring event firing during zooming with the touch interface.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ZoomCoefficientSinceLastEventFiring As Double
'Usage

Dim instance As ZoomGestureOccurringEventArgs
Dim value As Double

value = instance.ZoomCoefficientSinceLastEventFiring
public double ZoomCoefficientSinceLastEventFiring {get;}
public: __property double get_ZoomCoefficientSinceLastEventFiring();
public:
property double ZoomCoefficientSinceLastEventFiring {
   double get();
}

Property Value

A System.Drawing.Point value from the .NET Framework Class Library.
Remarks
The zoom coefficient is usually multiplied with the current zoom factor to get the new zoom factor.
See Also

Reference

ZoomGestureOccurringEventArgs Class
ZoomGestureOccurringEventArgs Members


AdjustType Enumeration

AdjustType Enumeration

Accusoft.ImagXpressSdk Namespace : AdjustType Enumeration
Option values used to indicate the adjustment type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum AdjustType
   Inherits System.Enum
'Usage

Dim instance As AdjustType
public enum AdjustType : System.Enum
__value public enum AdjustType : public System.Enum
public enum class AdjustType : public System.Enum
Members
Member | Value | Description
AsPercent | 0 | Adjustments made as percentage values.
InUnits | 1 | Adjustments made in units.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.AdjustType

See Also

Reference

Accusoft.ImagXpressSdk Namespace


AlignHorizontal Enumeration

AlignHorizontal Enumeration

Accusoft.ImagXpressSdk Namespace : AlignHorizontal Enumeration
Option values indicating the horizontal alignment setting.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum AlignHorizontal
   Inherits System.Enum
'Usage

Dim instance As AlignHorizontal
public enum AlignHorizontal : System.Enum
__value public enum AlignHorizontal : public System.Enum
public enum class AlignHorizontal : public System.Enum
Members
Member | Value | Description
Center | 1 | Align horizontally to the center of the view.
Left | 0 | Align horizontally to the left edge of the view.
Right | 2 | Align horizontally to the right edge of the view.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.AlignHorizontal

See Also

Reference

Accusoft.ImagXpressSdk Namespace


AlignVertical Enumeration

AlignVertical Enumeration

Accusoft.ImagXpressSdk Namespace : AlignVertical Enumeration
Option values indicating the vertical alignment setting.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum AlignVertical
   Inherits System.Enum
'Usage

Dim instance As AlignVertical
public enum AlignVertical : System.Enum
__value public enum AlignVertical : public System.Enum
public enum class AlignVertical : public System.Enum
Members
Member | Value | Description
Bottom | 2 | Align vertically to the bottom edge of the view.
Center | 1 | Align vertically to the center of the view.
Top | 0 | Align vertically to the top edge of the view.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.AlignVertical

See Also

Reference

Accusoft.ImagXpressSdk Namespace


AreaRegionOption Enumeration

AreaRegionOption Enumeration

Accusoft.ImagXpressSdk Namespace : AreaRegionOption Enumeration
Option values which determine the area and region settings.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum AreaRegionOption
   Inherits System.Enum
'Usage

Dim instance As AreaRegionOption
public enum AreaRegionOption : System.Enum
__value public enum AreaRegionOption : public System.Enum
public enum class AreaRegionOption : public System.Enum
Members
Member | Value | Description
Area | 1 | Area active.
None | 0 | No active area or region.
Region | 2 | Region active.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.AreaRegionOption

See Also

Reference

Accusoft.ImagXpressSdk Namespace


AutoResizeType Enumeration

AutoResizeType Enumeration

Accusoft.ImagXpressSdk Namespace : AutoResizeType Enumeration
Option values for use with the ImageXView.AutoResize property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum AutoResizeType
   Inherits System.Enum
'Usage

Dim instance As AutoResizeType
public enum AutoResizeType : System.Enum
__value public enum AutoResizeType : public System.Enum
public enum class AutoResizeType : public System.Enum
Members
Member | Value | Description
BestFit | 4 | The image is resized to fit the control and the aspect ratio is preserved.
CropImage | 5 | The image is cropped to the control size. Note: If the control size is larger than the image, the control is not resized to the image.
CropImageToControl | 0 | The image is cropped to the control size. Note: If the control size is larger than the image, the control is resized to the image.
FitHeight | 7 | Resize the image to fit the image height within the viewer control.
FitWidth | 6 | Resize the image to fit the image width within the viewer control.
ResizeControl | 1 | The control is resized to fit the image.
ResizeImage | 2 | The image is resized to fit the control.
TileImage | 3 | The image is tiled to fit the control.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.AutoResizeType

See Also

Reference

Accusoft.ImagXpressSdk Namespace


BinarizeBlur Enumeration

BinarizeBlur Enumeration

Accusoft.ImagXpressSdk Namespace : BinarizeBlur Enumeration
Option values used to determine what type of blur functionality to use during the Processor.Binarize method.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum BinarizeBlur
   Inherits System.Enum
'Usage

Dim instance As BinarizeBlur
public enum BinarizeBlur : System.Enum
__value public enum BinarizeBlur : public System.Enum
public enum class BinarizeBlur : public System.Enum
Members
Member | Value | Description
Gaussian | 1 | Blur the image before local contrast enhancement/binarize.
NoBlur | 0 | Don't blur.
Smart | 2 | Remove dither-like artifacts introduced into many images already binarized to 1-bit by other software of hardware operations.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.BinarizeBlur

See Also

Reference

Accusoft.ImagXpressSdk Namespace


BinarizeMode Enumeration

BinarizeMode Enumeration

Accusoft.ImagXpressSdk Namespace : BinarizeMode Enumeration
Option values used to determine what Processor.Binarize functionality to use.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum BinarizeMode
   Inherits System.Enum
'Usage

Dim instance As BinarizeMode
public enum BinarizeMode : System.Enum
__value public enum BinarizeMode : public System.Enum
public enum class BinarizeMode : public System.Enum
Members
Member | Value | Description
Gray | 2 | The goal of this mode is to generate an 8-bit grayscale image from the input. Useful for scaling to gray before another Binarize call with more options.
PhotoHalftone | 1 | The goal of this mode is to generate a 1-bit image from color or grayscale photographic-type images, reproducing the shades of gray in the image by black and white dots of various sizes. The angle and pitch of the halftone grid are controllable.
QuickText | 0 | Produces a clean 1-bit image for viewing and storage. This is generally used for document type images consisting of dark text and lines on a white or gray background. The result of the operation is to replace the text and lines in the image by black and the background by white. The controlling parameters for this mode are: LowThreshold, HighThreshold, LCEFactor, and Blur.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.BinarizeMode

See Also

Reference

Accusoft.ImagXpressSdk Namespace


BorderType Enumeration

BorderType Enumeration

Accusoft.ImagXpressSdk Namespace : BorderType Enumeration
Option values for use with the ImageXView.BorderType property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum BorderType
   Inherits System.Enum
'Usage

Dim instance As BorderType
public enum BorderType : System.Enum
__value public enum BorderType : public System.Enum
public enum class BorderType : public System.Enum
Members
Member | Value | Description
Flat | 3 | Flat: sets the border to a 2-pixel wide black border.
Inset | 1 | Inset: sets the border to a 2-pixel wide inset border.
InsetResizer | 5 | Inset resizer handles.
InsetThickResizer | 6 | Thick inset resizer handles.
None | 0 | None
Raised | 2 | Raised border
RaisedResizer | 4 | Raised resizer handles.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.BorderType

See Also

Reference

Accusoft.ImagXpressSdk Namespace


ButtonStyle Enumeration

ButtonStyle Enumeration

Accusoft.ImagXpressSdk Namespace : ButtonStyle Enumeration
Option values to indicate button display style.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ButtonStyle
   Inherits System.Enum
'Usage

Dim instance As ButtonStyle
public enum ButtonStyle : System.Enum
__value public enum ButtonStyle : public System.Enum
public enum class ButtonStyle : public System.Enum
Members
Member | Value | Description
Inset | 0 | The button appear inset.
Raised | 1 | The button appears raised.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.ButtonStyle

See Also

Reference

Accusoft.ImagXpressSdk Namespace


ByteOrder Enumeration

ByteOrder Enumeration

Accusoft.ImagXpressSdk Namespace : ByteOrder Enumeration
Option values used to specify the TIFF file byte order.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ByteOrder
   Inherits System.Enum
'Usage

Dim instance As ByteOrder
public enum ByteOrder : System.Enum
__value public enum ByteOrder : public System.Enum
public enum class ByteOrder : public System.Enum
Members
Member | Value | Description
Default | 0 | The byte order from the original image if it was a TIFF format.
Intel | 1 | Intel byte (LittleEndian) order (II or 0x4949; in hex notation).
Motorola | 2 | Motorola byte (BigEndian) order (MM or 0x4D4D; in hex notation).
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.ByteOrder

See Also

Reference

Accusoft.ImagXpressSdk Namespace


CadFileType Enumeration

CadFileType Enumeration

Accusoft.ImagXpressSdk Namespace : CadFileType Enumeration
Option values which determine the CAD file type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum CadFileType
   Inherits System.Enum
'Usage

Dim instance As CadFileType
public enum CadFileType : System.Enum
__value public enum CadFileType : public System.Enum
public enum class CadFileType : public System.Enum
Members
Member | Value | Description
Filetype_Unknown | -1 | Unknown file type.
FiletypeDwf | 3 | DWF (AutoCAD) file type.
FiletypeDwg | 0 | DWG (AutoCAD drawing) file type.
FiletypeDxb | 2 | DXB (AutoCAD Database) file type.
FiletypeDxf | 1 | DXF (AutoCAD Data Exchange File) file type.
Remarks

Note: Available in Professional edition.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.CadFileType

See Also

Reference

Accusoft.ImagXpressSdk Namespace


CadUnit Enumeration

CadUnit Enumeration

Accusoft.ImagXpressSdk Namespace : CadUnit Enumeration
Option values which determine the CAD (Computer Aided Design) units of measure.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum CadUnit
   Inherits System.Enum
'Usage

Dim instance As CadUnit
public enum CadUnit : System.Enum
__value public enum CadUnit : public System.Enum
public enum class CadUnit : public System.Enum
Members
Member | Value | Description
Angstroms | 11 | Angstroms.
Astronomical | 18 | Astronomical.
Centimeters | 5 | Centimeters.
Decimeters | 14 | Decimeters.
Dekameters | 15 | Dekameters.
Feet | 2 | Feet.
Gigameters | 17 | Gigameters.
Hectometers | 16 | Hectometers.
Inches | 1 | Inches.
Kilometers | 7 | Kilometers.
LightYears | 19 | Light years.
Meters | 6 | Meters.
Microinches | 8 | Microinches.
Microns | 13 | Microns.
Miles | 3 | Miles.
Millimeters | 4 | Millimeters.
Mils | 9 | Mils.
Nanometers | 12 | Nanometers.
Parsecs | 20 | Parsecs.
Undefined | 0 | Undefined.
Yards | 10 | Yards.
Remarks

Note: Available in Professional edition.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.CadUnit

See Also

Reference

Accusoft.ImagXpressSdk Namespace


CadVersion Enumeration

CadVersion Enumeration

Accusoft.ImagXpressSdk Namespace : CadVersion Enumeration
Option values which determine the CAD version.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum CadVersion
   Inherits System.Enum
'Usage

Dim instance As CadVersion
public enum CadVersion : System.Enum
__value public enum CadVersion : public System.Enum
public enum class CadVersion : public System.Enum
Members
Member | Value | Description
Version0v0 | 0 | No version.
Version1001 | 8 | Version 1001.
Version1002 | 9 | Version 1002.
Version1003 | 10 | Version 1003.
Version1004 | 11 | Version 1004.
Version1005 | 12 | Version 1005.
Version1006 | 13 | Version 1006.
Version1007 | 14 | Version 1007.
Version1008 | 15 | Version 1008.
Version1009 | 16 | Version 1009.
Version1010 | 17 | Version 1010.
Version1011 | 18 | Version 1011.
Version1012 | 19 | Version 1012.
Version1013 | 20 | Version 1013.
Version1014 | 21 | Version 1014.
Version1015 | 23 | Version 1015.
Version1021 | 27 | Version 1021.
Version1500 | 22 | Version 1500.
Version1800 | 25 | Version 1800.
Version1800a | 24 | Version 1800a.
Version1v2 | 1 | 1v2
Version1v40 | 2 | Version 1v40.
Version1v50 | 3 | Version 1v50.
Version2100a | 26 | Version 2100a.
Version2v10 | 5 | Version 2v10.
Version2v20 | 4 | Version 2v20.
Version2v21 | 6 | Version 2v21.
Version2v22 | 7 | Version 2v22.
VersionUnknown | 32766 | Version unknown.
Remarks

Note: Available in Professional edition.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.CadVersion

See Also

Reference

Accusoft.ImagXpressSdk Namespace


ClipboardFormat Enumeration

ClipboardFormat Enumeration

Accusoft.ImagXpressSdk Namespace : ClipboardFormat Enumeration
Option values of possible formats to use with the clipboard.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ClipboardFormat
   Inherits System.Enum
'Usage

Dim instance As ClipboardFormat
public enum ClipboardFormat : System.Enum
__value public enum ClipboardFormat : public System.Enum
public enum class ClipboardFormat : public System.Enum
Members
Member | Value | Description
All | 2 | Both the HBitmap and DIB formats.
Bitmap | 1 | GDI HBitmap format.
Dib | 0 | DIB (Device Independant Bitmap) format.
Remarks

The default value is Dib.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.ClipboardFormat

See Also

Reference

Accusoft.ImagXpressSdk Namespace


ColorSpace Enumeration

ColorSpace Enumeration

Accusoft.ImagXpressSdk Namespace : ColorSpace Enumeration
Option values which designate the color space.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ColorSpace
   Inherits System.Enum
'Usage

Dim instance As ColorSpace
public enum ColorSpace : System.Enum
__value public enum ColorSpace : public System.Enum
public enum class ColorSpace : public System.Enum
Members
Member | Value | Description
Cmyk | 1 | Cyan, Magenta, Yellow, Black (CMYK) color space.
Rgb | 0 | Red, Green, Blue (RGB) color space.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.ColorSpace

See Also

Reference

Accusoft.ImagXpressSdk Namespace


Compression Enumeration

Compression Enumeration

Accusoft.ImagXpressSdk Namespace : Compression Enumeration
Option values which determine the image compression type.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum Compression
   Inherits System.Enum
'Usage

Dim instance As Compression
public enum Compression : System.Enum
__value public enum Compression : public System.Enum
public enum class Compression : public System.Enum
Members
Member | Value | Description
Deflate | 4 | Lossless compression standard derived from LZ77.
Group3Fax1d | 5 | CCITT Group 3 one-dimensional fax compression.
Group3Fax2d | 6 | CCITT Group 3 two-dimensional standard fax compression.
Group4 | 7 | CCITT Group 4 fax compression.
Jbig2 | 10 | JBIG2 compression format.
Jpeg | 8 | JPEG compression format.
Jpeg2000 | 11 | JPEG2000 compression format.
Jpeg7 | 9 | JPEG7 compression format.
Lzw | 2 | Lempel, Ziv, Welch compression algorithm.
Native | 0 | Native file compression format.
NoCompression | 0 | No compression.
PackBits | 3 | Apple Macintosh PackBits compression.
Rle | 1 | Run length encoding.
Unknown | -1 | Unknown compression format.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.Compression

See Also

Reference

Accusoft.ImagXpressSdk Namespace


ContrastMethod Enumeration

ContrastMethod Enumeration

Accusoft.ImagXpressSdk Namespace : ContrastMethod Enumeration
Option values used to determine which Processor.ContrastMethod property value to use.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ContrastMethod
   Inherits System.Enum
'Usage

Dim instance As ContrastMethod
public enum ContrastMethod : System.Enum
__value public enum ContrastMethod : public System.Enum
public enum class ContrastMethod : public System.Enum
Members
Member | Value | Description
DefaultContrast | 0 | Use the Processor.ContrastMethod property.
ViewCompatibleContrast | 1 | Use the Processor.ContrastMethod property setting.
Remarks

The default value is DefaultContrast.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.ContrastMethod

See Also

Reference

Accusoft.ImagXpressSdk Namespace


CropType Enumeration

CropType Enumeration

Accusoft.ImagXpressSdk Namespace : CropType Enumeration
Option values which indicate what type of crop to perform.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum CropType
   Inherits System.Enum
'Usage

Dim instance As CropType
public enum CropType : System.Enum
__value public enum CropType : public System.Enum
public enum class CropType : public System.Enum
Members
Member | Value | Description
CropBorderBackgroundColor | 0 | Crop borders that are the same color as the image background.
CropBorderBlackColor | 2 | Crop black borders.
CropBorderForegroundColor | 1 | Crop borders that are the same color as the image foreground.
CropBorderWhiteColor | 3 | Crop white borders.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.CropType

See Also

Reference

Accusoft.ImagXpressSdk Namespace


DebugErrorLevel Enumeration

DebugErrorLevel Enumeration

Accusoft.ImagXpressSdk Namespace : DebugErrorLevel Enumeration
Option value which determine the error level of items to place into the debug log.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum DebugErrorLevel
   Inherits System.Enum
'Usage

Dim instance As DebugErrorLevel
public enum DebugErrorLevel : System.Enum
__value public enum DebugErrorLevel : public System.Enum
public enum class DebugErrorLevel : public System.Enum
Members
Member | Value | Description
Detailed | 2 | Place as much information into the debug log file as possible. You should use this option when you are tracking down a problem.
Development | 1 | Place information into the debug log file that is useful during normal development using this toolkit.
Production | 0 | Place minimal information into the debug log file.
Remarks

The default value is Production.

This enumeration allows you to specify the amount of detail to place into the debug log file.

Use these values with the ImagXpress.DebugErrorLevel property.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.DebugErrorLevel

See Also

Reference

Accusoft.ImagXpressSdk Namespace
DebugErrorLevel Property


DefectType Enumeration

DefectType Enumeration

Accusoft.ImagXpressSdk Namespace : DefectType Enumeration
Option values to indicate the defect type to process.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum DefectType
   Inherits System.Enum
'Usage

Dim instance As DefectType
public enum DefectType : System.Enum
__value public enum DefectType : public System.Enum
public enum class DefectType : public System.Enum
Members
Member | Value | Description
DarkDefect | 1 | A dark defect is to be removed.
LightDefect | 0 | A light defect is to be removed.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.DefectType

See Also

Reference

Accusoft.ImagXpressSdk Namespace


DeskewType Enumeration

DeskewType Enumeration

Accusoft.ImagXpressSdk Namespace : DeskewType Enumeration
Option values to indicate deskew settings for image correction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum DeskewType
   Inherits System.Enum
'Usage

Dim instance As DeskewType
public enum DeskewType : System.Enum
__value public enum DeskewType : public System.Enum
public enum class DeskewType : public System.Enum
Members
Member | Value | Description
AdjustSize | 1 | The image size grows or shrinks.
Normal | 0 | Normal
PhotoCrop | 6 | A special deskew routine specifically for color images.
PreserveCrop | 2 | The image stays the same size, a rotated image is cropped to original dimensions.
PreserveResample | 4 | The image stays the same size, a rotated image is resized to the original dimensions using a resampling method.
PreserveResize | 3 | The image stays the same size, a rotated image is resized to the original dimensions using the version of the Processor.Resize method that favors speed.
PreserveResizeQuality | 5 | The image stays the same size, a rotated image is resized to the original dimensions using the version of Processor.Resize method that favors quality.
Remarks

The default value is Normal.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.DeskewType

See Also

Reference

Accusoft.ImagXpressSdk Namespace


DisplayMode Enumeration

DisplayMode Enumeration

Accusoft.ImagXpressSdk Namespace : DisplayMode Enumeration
Option values indicating the maximum color depth used to render an image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum DisplayMode
   Inherits System.Enum
'Usage

Dim instance As DisplayMode
public enum DisplayMode : System.Enum
__value public enum DisplayMode : public System.Enum
public enum class DisplayMode : public System.Enum
Members
Member | Value | Description
PaletteColor | 1 | 256 color (8-bit) images rendered using 256 colors, unless the current display setting is 16 colors.
TrueColor | 0 | 24-bit images rendered at the maximum color depth supported by the current display setting.
VgaColor | 2 | 16 color (4-bit) images rendered using 16 colors.
Remarks

The default value is TrueColor.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.DisplayMode

See Also

Reference

Accusoft.ImagXpressSdk Namespace


DitherType Enumeration

DitherType Enumeration

Accusoft.ImagXpressSdk Namespace : DitherType Enumeration
Option values used to determine the dither type to perform.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum DitherType
   Inherits System.Enum
'Usage

Dim instance As DitherType
public enum DitherType : System.Enum
__value public enum DitherType : public System.Enum
public enum class DitherType : public System.Enum
Members
Member | Value | Description
Accusoft | 3 | Accusoft
BinarizePhotoHalftone | 5 | Binzarize photo halftone
BinarizeQuickText | 4 | Binarize quick text
Floyd | 1 | Floyd-Steinberg
NoDither | 0 | None
Ordered | 2 | Ordered
Pegasus | 3 | Pegasus - This value is obsolete. Please use the value Accusoft instead.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.DitherType

See Also

Reference

Accusoft.ImagXpressSdk Namespace


EnhancementDirection Enumeration

EnhancementDirection Enumeration

Accusoft.ImagXpressSdk Namespace : EnhancementDirection Enumeration
Option values used to determine enhancement direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum EnhancementDirection
   Inherits System.Enum
'Usage

Dim instance As EnhancementDirection
public enum EnhancementDirection : System.Enum
__value public enum EnhancementDirection : public System.Enum
public enum class EnhancementDirection : public System.Enum
Members
Member | Value | Description
All | 0 | Enhance all directions.
Down | 4 | Enhance down.
Left | 1 | Enhance left.
LeftDown | 6 | Enhance diagonally left down.
LeftDownBoth | 10 | Enhance left, down, and diagonally left down.
LeftUp | 5 | Enhance diagonally left up.
LeftUpBoth | 9 | Enhance left, up, and diagonally left up.
Right | 2 | Enhance right.
RightDown | 8 | Enhance diagonally right down.
RightDownBoth | 12 | Enhance right, down, and diagonally right down.
RightUp | 7 | Enhance diagonally right up.
RightUpBoth | 11 | Enhance right, up, and diagonally right up.
Up | 3 | Enhance up.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.EnhancementDirection

See Also

Reference

Accusoft.ImagXpressSdk Namespace


EvaluationMode Enumeration

EvaluationMode Enumeration

Accusoft.ImagXpressSdk Namespace : EvaluationMode Enumeration
Option values that indicate ImagXpress behavior when installed on a development machine when in evaluation mode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum EvaluationMode
   Inherits System.Enum
'Usage

Dim instance As EvaluationMode
public enum EvaluationMode : System.Enum
__value public enum EvaluationMode : public System.Enum
public enum class EvaluationMode : public System.Enum
Members
Member | Value | Description
Automatic | 0 | When running under an IIS server, a watermark and all images passed through the component are watermarked, otherwise, the component regularly displays a dialog box stating it is in Trial Licensing mode.
Watermark | 1 | All images opened in ImagXpress are permanently watermarked with the words Evaluation.
Remarks

The default value is Automatic.

In order to test the component in an application running as a service or other environments where the component does not have permissions to create a window, the application logic needs to set the EvaluationMode to Watermark. In this mode, the component does not attempt to create the Evaluation Mode dialog window, but permanently watermarks all image data passed through it.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.EvaluationMode

See Also

Reference

Accusoft.ImagXpressSdk Namespace


FireGestureOccurringEvent Enumeration

FireGestureOccurringEvent Enumeration

Accusoft.ImagXpressSdk Namespace : FireGestureOccurringEvent Enumeration
Option values which determine the gestures events firing mode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum FireGestureOccurringEvent
   Inherits System.Enum
'Usage

Dim instance As FireGestureOccurringEvent
public enum FireGestureOccurringEvent : System.Enum
__value public enum FireGestureOccurringEvent : public System.Enum
public enum class FireGestureOccurringEvent : public System.Enum
Members
Member | Value | Description
ContinuouslyThroughoutTheLifetimeOfTheGesture | 1 | Fire the gesture events continuously throughout the lifetime of the gesture.
OnlyWhenThereIsFingerMovement | 0 | Only fire the gesture events when there is finger movement.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.FireGestureOccurringEvent

See Also

Reference

Accusoft.ImagXpressSdk Namespace


FlickDirection Enumeration

FlickDirection Enumeration

Accusoft.ImagXpressSdk Namespace : FlickDirection Enumeration
Option values used to determine the direction of the flick TouchFlick event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum FlickDirection
   Inherits System.Enum
'Usage

Dim instance As FlickDirection
public enum FlickDirection : System.Enum
__value public enum FlickDirection : public System.Enum
public enum class FlickDirection : public System.Enum
Members
Member | Value | Description
Down | 6 | Flick down.
DownLeft | 5 | Flick down and to the left.
DownRight | 7 | Flick down and to the right.
Left | 4 | Flick to the left.
Right | 0 | Flick to the right.
Up | 2 | Flick up.
UpLeft | 3 | Flick up and to the left.
UpRight | 1 | Flick up and to the right.
Remarks
Note: Depending on the touch system not all directions may be returned. Some flick directions may not be available by default on a user's system and may need to be enabled. The flicks are controlled on a user's system in the Windows Control Panel under the Pen and Touch settings. There is a Flick tab in the Pen and Touch control panel applet that customizes flick settings for the entire system. The Pen and Touch control panel applet is available on Microsoft Windows operating systems that support either pen input or touch. Pen or touch hardware must be present for the Pen and Touch control panel applet to be available. Please review the Window's documentation on how to adjust these settings.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.FlickDirection

See Also

Reference

Accusoft.ImagXpressSdk Namespace


FtpMode Enumeration

FtpMode Enumeration

Accusoft.ImagXpressSdk Namespace : FtpMode Enumeration
Option values used for FTP (File Transfer Protocol) mode.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum FtpMode
   Inherits System.Enum
'Usage

Dim instance As FtpMode
public enum FtpMode : System.Enum
__value public enum FtpMode : public System.Enum
public enum class FtpMode : public System.Enum
Members
Member | Value | Description
Active | 0 | Active mode
Passive | 1 | Passive mode
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.FtpMode

See Also

Reference

Accusoft.ImagXpressSdk Namespace


GifType Enumeration

GifType Enumeration

Accusoft.ImagXpressSdk Namespace : GifType Enumeration
Option values for GIF file format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum GifType
   Inherits System.Enum
'Usage

Dim instance As GifType
public enum GifType : System.Enum
__value public enum GifType : public System.Enum
public enum class GifType : public System.Enum
Members
Member | Value | Description
Gif87a | 1 | GIF87a format.
Gif89a | 0 | GIF89a format.
Remarks

The version number identifies the minimum set of capabilities necessary to a decoder to fully process the contents of the data stream. Version numbers refer to dates: "87a" - May 1987, "89a" - July 1989. GIF89a format contains text, which is not part of the actual graphics in the GIF data stream.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.GifType

See Also

Reference

Accusoft.ImagXpressSdk Namespace


GrayMode Enumeration

GrayMode Enumeration

Accusoft.ImagXpressSdk Namespace : GrayMode Enumeration
Option values to indicate the type of Gray Mode to utilize.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum GrayMode
   Inherits System.Enum
'Usage

Dim instance As GrayMode
public enum GrayMode : System.Enum
__value public enum GrayMode : public System.Enum
public enum class GrayMode : public System.Enum
Members
Member | Value | Description
Medical | 1 | Use the DICOM standard method to level the image.
Standard | 0 | Use the simple linear method to level the image.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.GrayMode

See Also

Reference

Accusoft.ImagXpressSdk Namespace


ImageStatus Enumeration

ImageStatus Enumeration

Accusoft.ImagXpressSdk Namespace : ImageStatus Enumeration
Option values which specify the status of an image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<FlagsAttribute()>
Public Enum ImageStatus
   Inherits System.Enum
'Usage

Dim instance As ImageStatus
[Flags()]
public enum ImageStatus : System.Enum
[Flags()]
__value public enum ImageStatus : public System.Enum
[Flags()]
public enum class ImageStatus : public System.Enum
Members
Member | Value | Description
Canceled | 32 | Image process is cancelled.
Decoded | 4 | Image decoded.
Decoding | 8 | Image being decoded.
Defined | 1 | Image file set.
Empty | 0 | No image.
Error | 268435456 | Image error.
ImageProcessed | 512 | The image process is complete.
ImageProcessing | 256 | The image is being processed.
Opened | 2 | Image file opened.
Saved | 2048 | The image save is complete.
Saving | 1024 | The image is being saved.
Shutdown | 64 | Application shutdown.
Wait | 16 | Operation in process.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.ImageStatus

See Also

Reference

Accusoft.ImagXpressSdk Namespace


ImageXFormat Enumeration

ImageXFormat Enumeration

Accusoft.ImagXpressSdk Namespace : ImageXFormat Enumeration
Option values which specify the file format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImageXFormat
   Inherits System.Enum
'Usage

Dim instance As ImageXFormat
public enum ImageXFormat : System.Enum
__value public enum ImageXFormat : public System.Enum
public enum class ImageXFormat : public System.Enum
Members
Member | Value | Description
Bmp | 1 | OS/2 or Windows Bitmap.
C4 | 38 | JEDMICS C4 format - like modca data but read only
Cad | 35 | Computer Aided Design format.
Cals | 7 | Computer Aided Acquisition and Logistics Support Raster format.
CameraRaw | 34 | Camera Raw format.
Dcx | 16 | ZSoft multiple page file format.
Default | 0 | Default file format.
Dib | 17 | Device Independent Bitmap (DIB) format.
Emf | 20 | Microsoft Enhanced Metafile format.
Epic | 11 | Pegasus enhanced format.
Exif | 5 | JPG, EXIF format.
Gif | 12 | CompuServe Graphics Interchange Format.
Ico | 24 | Windows icon.
Ioca | 37 | Ioca format - like modca but just compact data Note: When performing a save as for this format, MODCA is written. The MODCA format is wrapped around the IOCA format.
Jbig2 | 33 | JBig2 file format.
Jpeg | 4 | JPG, JIF Compliant JPEG format.
Jpeg2000 | 21 | JPEG 2000 format.
Jpeg2000Headless | 22 | JPEG 2000 without header.
JpegLs | 9 | JPEG-LS format.
JpegXR | 39 | JPEG-XR file format.
LosslessJpeg | 8 | Lossless JPEG (LJP file extension).
Modca | 6 | MOD:CA format
Pbm | 27 | Portable Bitmap.
Pcx | 15 | ZSoft format.
Pdf | 3 | Portable Document format.
Pgm | 26 | Portable Graymap.
Pic | 10 | Pegasus Imaging Corporation (PIC) format.
Png | 13 | Portable Network Graphics format.
Ppm | 25 | Portable Pixmap.
Raw | 32 | RAW file format.
Tga | 14 | Truevision Targa format.
Tiff | 2 | Tagged image file format (Tiff).
Unknown | 0 | Unknown format.
WirelessBmp | 23 | Wireless Bitmap (WBMP extension).
Wmf | 19 | Windows Metafile format.
Wsq | 30 | WSQ fingerprint file.
Remarks

The default value is Default.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.ImageXFormat

See Also

Reference

Accusoft.ImagXpressSdk Namespace


ImageXPixelFormat Enumeration

ImageXPixelFormat Enumeration

Accusoft.ImagXpressSdk Namespace : ImageXPixelFormat Enumeration
Option values which determine the pixel formats currently being used.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<FlagsAttribute()>
<SerializableAttribute()>
Public Enum ImageXPixelFormat
   Inherits System.Enum
'Usage

Dim instance As ImageXPixelFormat
[Flags()]
[Serializable()]
public enum ImageXPixelFormat : System.Enum
[Flags()]
[Serializable()]
__value public enum ImageXPixelFormat : public System.Enum
[Flags()]
[Serializable()]
public enum class ImageXPixelFormat : public System.Enum
Members
Member | Value | Description
Alpha | 128 | Alpha channel.
Argb | 4096 | Alpha, red, green, blue byte order format.
BigEndian | 4 | Motorola byte order format.
Cmyk | 131072 | Cyan, yellow, magenta, black color format
ColorMapped | 65536 | 1-8 bit colormapped format.
Compressed | 1048576 | Compressed image format.
Dib | 1 | Device independent bitmap.
Gray | 32 | Grey scale image.
HighGray | 64 | DICOM Medical standard grey scale image format.
NoDibPad | 4194304 | DIB without padding.
NonInterleaved | 2097152 | Non-interleaved image format.
Raw | 2 | RAW image format.
Rgb | 256 | Red, Green, Blue byte order format.
Rgb555 | 1024 | RGB555 byte order format.
Rgb565 | 2048 | RGB565 byte order format.
Signed | 16 | Signed byte order format.
TopDown | 8 | Top down bitmap format.
Remarks

These values may be combined.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.ImageXPixelFormat

See Also

Reference

Accusoft.ImagXpressSdk Namespace


ImageXViewBorderStyle Enumeration

ImageXViewBorderStyle Enumeration

Accusoft.ImagXpressSdk Namespace : ImageXViewBorderStyle Enumeration
Option values for use with the ImageXView.BorderStyle property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ImageXViewBorderStyle
   Inherits System.Enum
'Usage

Dim instance As ImageXViewBorderStyle
public enum ImageXViewBorderStyle : System.Enum
__value public enum ImageXViewBorderStyle : public System.Enum
public enum class ImageXViewBorderStyle : public System.Enum
Members
Member | Value | Description
Fixed3D | 2 | Fixed3D: A three-dimensional border.
Fixed3DRaised | 3 | Fixed3DRaised: A three-dimensional raised border.
FixedSingle | 1 | FixedSingle: A single-line border.
None | 0 | None: No border.
Size3D | 4 | Size3D: A three-dimensional border that can be sized.
Size3DRaised | 5 | Sized3DRaised: A three-dimensional raised border that can be sized.
Size3DThick | 6 | Size3DThick: A thicker three-dimensional border.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.ImageXViewBorderStyle

See Also

Reference

Accusoft.ImagXpressSdk Namespace


Jbig2EncodeModeCompression Enumeration

Jbig2EncodeModeCompression Enumeration

Accusoft.ImagXpressSdk Namespace : Jbig2EncodeModeCompression Enumeration
Option values used to specify the encoding mode to use when creating the Jbig2 file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum Jbig2EncodeModeCompression
   Inherits System.Enum
'Usage

Dim instance As Jbig2EncodeModeCompression
public enum Jbig2EncodeModeCompression : System.Enum
__value public enum Jbig2EncodeModeCompression : public System.Enum
public enum class Jbig2EncodeModeCompression : public System.Enum
Members
Member | Value | Description
AutoDetect | 0 | Lossless Generic_MQ
LosslessGenericMmr | 2 | Fast, very good lossless compression similar to G4 coding, uses Huffman/MMRcoding. Use this option for any content.
LosslessGenericMq | 1 | Fast, great lossless compression which uses MQ arithmetic coding. Use this option for any content.
LosslessTextMmr | 4 | Very good lossless compression which uses Huffman/MMR coding. Use this option for text or symbols.
LosslessTextMq | 3 | Great lossless compression possible which uses MQ arithmetic coding. Use this option for text or symbols.
LosslessTextSpmMmr | 6 | The best lossless compression for text and symbols. This option uses Huffman/MMR coding plus MQ arithmetic coding.
LosslessTextSpmMq | 5 | The best lossless compression for text and symbols. This option uses MQ arithmetic coding.
LossyHalftoneMmr | 10 | Good lossy compression for halftones. This option uses Huffman/MMR coding.
LossyHalftoneMq | 9 | Good lossy compression for halftones. This option uses MQ arithmetic coding.
LossyTextMmr | 8 | Very good lossy compression for text or symbols. This option uses Huffman/MMR coding.
LossyTextMq | 7 | Great lossy compression for text or symbols. This option uses MQ arithmetic coding.
Remarks

The default value is AutoDetect.

Text regions can be encoded as lossless or as lossy according to the encoding mode specified. The lossy modes use the value in the SaveOptionsJbig2.LoosenessCompression value to control how loose to be when matching symbols and thereby increase compression and reduce file size. Compression means loss and a consequence of higher compression is an increased risk of errors in the reconstructed image.

Specify a larger value of looseness to reduce the compressed file size; use a smaller value to reduce the errors, if any. Halftone regions can be encoded lossy by specifying one of the lossy halftone encoding modes. Alternatively, they can be encoded lossless by using the lossless generic encoding mode.

Note: Available in Professional edition.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.Jbig2EncodeModeCompression

See Also

Reference

Accusoft.ImagXpressSdk Namespace


Jbig2FileOrganization Enumeration

Jbig2FileOrganization Enumeration

Accusoft.ImagXpressSdk Namespace : Jbig2FileOrganization Enumeration
Option values used to specify the file organization of the Jbig2 bit stream.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum Jbig2FileOrganization
   Inherits System.Enum
'Usage

Dim instance As Jbig2FileOrganization
public enum Jbig2FileOrganization : System.Enum
__value public enum Jbig2FileOrganization : public System.Enum
public enum class Jbig2FileOrganization : public System.Enum
Members
Member | Value | Description
Default | 0 | Default, sequential organization.
RandomAccess | 2 | Random access organization.
Sequential | 1 | Sequential organization.
Remarks

The default value is Default.

A JBIG2 file may be organized in two ways: sequential or random access. Sequential organization is intended for streaming applications, where the decoder reads and decodes the file in order as the data is received. Random access organization permits the decoder to know the entire file structure, without having to read the entire file, and then uses that information to access the required data in a random-access fashion. This organization is useful for applications such as decoding only odd-number pages.

Note: Available in Professional edition.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.Jbig2FileOrganization

See Also

Reference

Accusoft.ImagXpressSdk Namespace


JoinType Enumeration

JoinType Enumeration

Accusoft.ImagXpressSdk Namespace : JoinType Enumeration
Option values used to determine what type of Processor.ColorJoin method to use.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum JoinType
   Inherits System.Enum
'Usage

Dim instance As JoinType
public enum JoinType : System.Enum
__value public enum JoinType : public System.Enum
public enum class JoinType : public System.Enum
Members
Member | Value | Description
Argb | 4 | Join alpha, red, green, and blue image components.
Cmy | 2 | Join cyan, magenta, and yellow image components.
Cmyk | 3 | Join cyan, magenta, yellow, and black image components.
Hsl | 1 | Join hue, saturation, and luminance image components.
Rgb | 0 | Join red, green, and blue image components.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.JoinType

See Also

Reference

Accusoft.ImagXpressSdk Namespace


Jp2Type Enumeration

Jp2Type Enumeration

Accusoft.ImagXpressSdk Namespace : Jp2Type Enumeration
Option values used to determine JP2 file types.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum Jp2Type
   Inherits System.Enum
'Usage

Dim instance As Jp2Type
public enum Jp2Type : System.Enum
__value public enum Jp2Type : public System.Enum
public enum class Jp2Type : public System.Enum
Members
Member | Value | Description
Lossless | 1 | Lossless image compression format.
Lossy | 0 | Lossy image compression format.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.Jp2Type

See Also

Reference

Accusoft.ImagXpressSdk Namespace


JpegXRPostProcessFilter Enumeration

JpegXRPostProcessFilter Enumeration

Accusoft.ImagXpressSdk Namespace : JpegXRPostProcessFilter Enumeration
Open option filtering on JPEG-XR files, the strength specifies how aggressively the filtering is applied.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum JpegXRPostProcessFilter
   Inherits System.Enum
'Usage

Dim instance As JpegXRPostProcessFilter
public enum JpegXRPostProcessFilter : System.Enum
__value public enum JpegXRPostProcessFilter : public System.Enum
public enum class JpegXRPostProcessFilter : public System.Enum
Members
Member | Value | Description
Light | 1 | Light Filter
Medium | 2 | 2- Medium Filter
None | 0 | No Filter
Strong | 3 | Strong Filter
VeryStrong | 4 | Very Strong Filter
Remarks

The default value is None

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.JpegXRPostProcessFilter

See Also

Reference

Accusoft.ImagXpressSdk Namespace


JpegXRSubSampling Enumeration

JpegXRSubSampling Enumeration

Accusoft.ImagXpressSdk Namespace : JpegXRSubSampling Enumeration
Option values for subsampling type for a Jpeg-XR file format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum JpegXRSubSampling
   Inherits System.Enum
'Usage

Dim instance As JpegXRSubSampling
public enum JpegXRSubSampling : System.Enum
__value public enum JpegXRSubSampling : public System.Enum
public enum class JpegXRSubSampling : public System.Enum
Members
Member | Value | Description
ChromaSubSampling400 | 1 | No Color.
ChromaSubSampling420 | 2 | 2 to 1 vertical subsampling.
ChromaSubSampling422 | 3 | 2 to 1 horizontal subsampling.
ChromaSubSampling444 | 4 | No subsampling, default.
Remarks

The default value is ChromaSubSampling444.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.JpegXRSubSampling

See Also

Reference

Accusoft.ImagXpressSdk Namespace


LicenseStatus Enumeration

LicenseStatus Enumeration

Accusoft.ImagXpressSdk Namespace : LicenseStatus Enumeration
Options for the status of the license.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum LicenseStatus
   Inherits System.Enum
'Usage

Dim instance As LicenseStatus
public enum LicenseStatus : System.Enum
__value public enum LicenseStatus : public System.Enum
public enum class LicenseStatus : public System.Enum
Members
Member | Value | Description
EvaluationLicense | 1 | Evaluation license
LegalLicense | 2 | Legal license
NoLicense | 0 | No license
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.LicenseStatus

See Also

Reference

Accusoft.ImagXpressSdk Namespace


LjpMethod Enumeration

LjpMethod Enumeration

Accusoft.ImagXpressSdk Namespace : LjpMethod Enumeration
Lossless Jpeg Compression Method
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum LjpMethod
   Inherits System.Enum
'Usage

Dim instance As LjpMethod
public enum LjpMethod : System.Enum
__value public enum LjpMethod : public System.Enum
public enum class LjpMethod : public System.Enum
Members
Member | Value | Description
Jpeg | 0 | Image data is compressed in lossless Jpeg
Loco | 1 | Image data is compressed in favor of continuous tones format such as photographs or x-rays.
Ppmd | 2 | IMSTAR Compression is the more appropriate value for discrete images such as computer graphics or faxes.
Remarks

Note: Available in Professional edition.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.LjpMethod

See Also

Reference

Accusoft.ImagXpressSdk Namespace


LjpType Enumeration

LjpType Enumeration

Accusoft.ImagXpressSdk Namespace : LjpType Enumeration
Option values used to specify the type of compression used for saving a lossless JPEG file.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum LjpType
   Inherits System.Enum
'Usage

Dim instance As LjpType
public enum LjpType : System.Enum
__value public enum LjpType : public System.Enum
public enum class LjpType : public System.Enum
Members
Member | Value | Description
Rgb | 0 | Image data is compressed in RGB (Red Green Blue) format.
Ycbcr | 1 | Image data is compressed in YCBCR format.
Remarks

Note: Available in Professional edition.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.LjpType

See Also

Reference

Accusoft.ImagXpressSdk Namespace


LoadMode Enumeration

LoadMode Enumeration

Accusoft.ImagXpressSdk Namespace : LoadMode Enumeration
Option values used to indicate the LoadOptions.LoadMode property.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum LoadMode
   Inherits System.Enum
'Usage

Dim instance As LoadMode
public enum LoadMode : System.Enum
__value public enum LoadMode : public System.Enum
public enum class LoadMode : public System.Enum
Members
Member | Value | Description
Normal | 0 | Standard image format.
Raw | 1 | RAW image format.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.LoadMode

See Also

Reference

Accusoft.ImagXpressSdk Namespace


MedicalPhotometricInterpretation Enumeration

MedicalPhotometricInterpretation Enumeration

Accusoft.ImagXpressSdk Namespace : MedicalPhotometricInterpretation Enumeration
Option values used to determines whether a zero in the image data is black or white.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum MedicalPhotometricInterpretation
   Inherits System.Enum
'Usage

Dim instance As MedicalPhotometricInterpretation
public enum MedicalPhotometricInterpretation : System.Enum
__value public enum MedicalPhotometricInterpretation : public System.Enum
public enum class MedicalPhotometricInterpretation : public System.Enum
Members
Member | Value | Description
Monochrome1 | 0 | Positive image, 0 is white.
Monochrome2 | 1 | Negative image, 0 is black.
Remarks

Use the Medical.PhotometricInterpretation property only when DICOM specific information is available. Also, the GrayMode enumeration value must be set to Medical.

Note: Available in Professional edition.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.MedicalPhotometricInterpretation

See Also

Reference

Accusoft.ImagXpressSdk Namespace


MergeSize Enumeration

MergeSize Enumeration

Accusoft.ImagXpressSdk Namespace : MergeSize Enumeration
An enumeration used to determine the area/size the merge image is to be.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum MergeSize
   Inherits System.Enum
'Usage

Dim instance As MergeSize
public enum MergeSize : System.Enum
__value public enum MergeSize : public System.Enum
public enum class MergeSize : public System.Enum
Members
Member | Value | Description
Crop | 0 | The merge image is cropped to the size of the existing image or to the area specified by the Processor.SetArea method.
ResizeArea | 1 | The merge area is resized to the size of the merge image.
ResizeImage | 2 | The merge image is resized to the size of the current image or to the area specified by the Processor.SetArea method.
TileImage | 3 | The merge image is tiled to the size of the current image or to the area specified by the Processor.SetArea method.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.MergeSize

See Also

Reference

Accusoft.ImagXpressSdk Namespace


MergeStyle Enumeration

MergeStyle Enumeration

Accusoft.ImagXpressSdk Namespace : MergeStyle Enumeration
Option values used to specify the style of the merge.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum MergeStyle
   Inherits System.Enum
'Usage

Dim instance As MergeStyle
public enum MergeStyle : System.Enum
__value public enum MergeStyle : public System.Enum
public enum class MergeStyle : public System.Enum
Members
Member | Value | Description
Additive | 3 | Pixel values are added to the pixels in the existing image.
AlphaBackGroundOverForeGround | 15 | The normal way of viewing a merged alpha image. The alpha channel in the foreground image is used to blend the two image together. The alpha channel contains information as to which pixels are opaque and which pixels are transparent in the image, and the degree of transparency. An opaque pixel in the foreground hides the pixel in the background image. Likewise, a transparent pixel in the foreground image lets the background pixel show through.
AlphaForeGroundOverBackGround | 14 | This produces a fading effect where the center of the superimposed image is lighter than the top and bottom. High or low merge percentage determines the intensity range f the superimposition.
AlphaLeastOpaque | 17 | The least opaque pixel value is chosen from the foreground and background alpha channels and is used for the foreground image.
AlphaMostOpaque | 16 | The most opaque pixel value is chosen from the foreground and background alpha channels and is used for the foreground image.
IfDarker | 1 | Merges only pixels darker than the ones in the existing image.
IfLighter | 2 | Merges only pixels lighter than the ones in the existing image.
Normal | 0 | Pixels are merged with the existing image.
Subtractive | 4 | Pixel values are subtracted from the pixels in the existing image.
Superimpose | 5 | The image is superimposed onto the existing image. High merge superimposed image is lighter than the right side. The high or low merge percentage determines the intensity range of the superimposition.
SuperimposeBottomToTop | 11 | This produces a fading effect where the bottom of the superimposed image is lighter than the top. Here too, the merge percentage determines intensity superimposition.
SuperimposeHorizFromCenter | 12 | This produces a fading effect where the bottom of the superimposed image is lighter than the top. Here too, the merge percentage determines the intensity of superimposition.
SuperimposeHorizToCenter | 13 | This produces a fading effect where the top and bottom of the superimposed image is lighter than the top. Here too, the merge percentage determines the intensity of the superimposition.
SuperimposeLeftToRight | 6 | This produces a fading effect where the left side of the superimposed image is lighter than the right side. The high or low merge percentage determines the intensity range of the superimposition.
SuperimposeRightToLeft | 7 | This produces a fading effect where the right side of the superimposed image is lighter than the left side. The high or low merge percentage determines the intensity range of the superimposition.
SuperimposeTopToBottom | 10 | This produces a fading effect where the top of the superimposed image is lighter than the bottom. merge percentage determines intensity of superimposition.
SuperimposeVerticalFromCenter | 9 | This produces a fading effect where the center of the superimposed image is lighter than the right and left sides. Merge percentage determines the intensity of superimposition.
SuperimposeVerticalToCenter | 8 | This produces a fading effect where the right and left sides of the superimposed image are lighter than the center. Merge percentage determines the intensity range of the superimposition.
Remarks

Each option contains a set of named constants to superimpose the image onto the existing image: with only dark or light pixels, by adding or subtracting pixels, by percentage, by fading from one direction or another; including from or to the center of the image.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.MergeStyle

See Also

Reference

Accusoft.ImagXpressSdk Namespace


MouseWheelAction Enumeration

MouseWheelAction Enumeration

Accusoft.ImagXpressSdk Namespace : MouseWheelAction Enumeration
Option values used in determining what type of mouse wheel action to perform.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum MouseWheelAction
   Inherits System.Enum
'Usage

Dim instance As MouseWheelAction
public enum MouseWheelAction : System.Enum
__value public enum MouseWheelAction : public System.Enum
public enum class MouseWheelAction : public System.Enum
Members
Member | Value | Description
HorizontalScroll | 2 | Horizontal scroll.
None | 0 | No mouse wheel action.
VerticalScroll | 1 | Vertical scroll.
Zoom | 3 | Zoom.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.MouseWheelAction

See Also

Reference

Accusoft.ImagXpressSdk Namespace


MouseWheelAttribute Enumeration

MouseWheelAttribute Enumeration

Accusoft.ImagXpressSdk Namespace : MouseWheelAttribute Enumeration
Option values used to manipulate the mouse wheel.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum MouseWheelAttribute
   Inherits System.Enum
'Usage

Dim instance As MouseWheelAttribute
public enum MouseWheelAttribute : System.Enum
__value public enum MouseWheelAttribute : public System.Enum
public enum class MouseWheelAttribute : public System.Enum
Members
Member | Value | Description
HorizontalScroll | 1 | Horizontal scroll.
VerticalScroll | 0 | Vertical scroll.
ZoomPercent | 2 | Zoom percent.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.MouseWheelAttribute

See Also

Reference

Accusoft.ImagXpressSdk Namespace


Operation Enumeration

Operation Enumeration

Accusoft.ImagXpressSdk Namespace : Operation Enumeration
Option values used in determining what type of image operation to perform.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum Operation
   Inherits System.Enum
'Usage

Dim instance As Operation
public enum Operation : System.Enum
__value public enum Operation : public System.Enum
public enum class Operation : public System.Enum
Members
Member | Value | Description
AdjustColorBalance | 85 | Correct clor balance as specified.
AdjustHsl | 37 | Adjust the image hue, saturation and luminance components.
AdjustLightness | 86 | Adjust the image lightness as specified.
AdjustRgb | 34 | Adjust the color image.
ApplyGrayscaleTransform | 65 | Permanently levels an 8 through 16-bit gray image to an 8-bit gray image.
AutoBinarize | 90 | Similiar to Binarize but for text mode only and all parameters automatically chosen.
AutoBinarize2 | 91 | Similiar to Binarize but for text mode only and all parameters automatically chosen. It uses a different and faster algorithm than AutoBinarize to binarize the image automatically.
AutoColorBalance | 87 | Correct the image color balance automatically.
AutoContrast | 40 | Automatically adjust the image contrast uniformly.
AutoCrop | 57 | Crop the border space automatically.
AutoLevel | 67 | Restores and balances color quality within an image.
AutoLightness | 88 | Adjust the contrast in light and dark regions of the image separately. This is useful to bring more detail into the shadowy areas of the image, without washing out the light regions.
AutoRemoveRedeye | 89 | Remove red eye on an image.
Binarize | 60 | Modify the color palette associated with the image, setting it to two colors.
Blend | 44 | Blend with underlying pixels in the image.
Blur | 45 | Noise eliminated where significant color transitions occur. The blur filters smooth transitions by averaging the pixels next to the hard edges of defined lines and shaded areas.
Brightness | 21 | Apply brightness on the image.
Buttonize | 49 | Add translucent bevels to the edges of it to give it the appearance of a 3D button.
ColorCount | 59 | Color count.
ColorDepth1 | 10 | Color depth set to 1.
ColorDepth24 | 7 | Color depth set to 24.
ColorDepth4 | 9 | Color depth set to 4.
ColorDepth8 | 8 | Color depth set to 8.
ColorJoin | 61 | Joins the color components into a full image.
Contrast | 22 | Apply image contrast.
Copy | 36 | Copy the specified region or image.
CountUniqueColors | 64 | Count of the unique colors.
CreateColorImage | 63 | Create a color image from a non-color one.
Crop | 24 | Crop the specified region of the image. Cropping is the process of removing portions of an image to create focus or strengthen the compostion.
CropBorder | 58 | Crop the image borders.
Deskew | 56 | Correct skewing of an image.
Despeckle | 55 | Blur the selection on the image except those edges. This blurring removes noise while preserving detail.
Diffuse | 46 | The image displays as though it were viewed through a soft diffusion filter.
Dilate | 51 | Enhance and/or fill in divets in black letters and lines.
DocumentBlankPageDetect | 83 | Examines a rectangle on an image, determining if the page is considered blank, based on the amount of data on the page.
DocumentBlobRemoval | 82 | Locates and removes large black objects in images such as binder punch holes.
DocumentBorderCrop | 84 | Crops borders of documents.
DocumentDeskew | 75 | Automatically detects and removes skew from current 1-bt depth images.
DocumentDespeckle | 76 | Detects and removes specks from the current image.
DocumentDilate | 78 | Examines pixels in the current image and expands the black ones by a given amount in a given direction.
DocumentErode | 79 | Removes the black pixels in the current image by the given amount in the given direction.
DocumentLineRemoval | 77 | Automatically detects and removes lines from the current image.
DocumentShear | 81 | Shears current image clockwise or counter-clockwise.
DocumentZoomSmooth | 80 | Replaces current 1-bit per pixel image with an image whose width and height have been doubled and whose pixels have been smoothed.
Emboss | 25 | Apply an emboss effect to the image. Emboss makes a selection appear raised or stamped by converting it's fill color to gray.
Equalize | 19 | Apply the equalize effect to the image.
Erode | 52 | Reduce or erase protrusions from black letters and lines.
Flip | 1 | Flip the image vertically.
Gamma | 38 | Lighten or darken the image depending on the specified value given.
LoadImage | 15 | Load the image.
Matrix | 31 | Apply 3x3 convolution matrix filter added.
Median | 20 | Apply a median effect to the image.
Merge | 35 | Merge image with other loaded images.
Mirror | 2 | Flip the image horizontally.
Mosaic | 18 | Apply mosaic effect which clumps pixels into square blocks.
MotionBlur | 29 | Blur the image in the specified direction.
Negative | 6 | Negative image.
Noise | 27 | Adds noise (pixels with randomly distributed color levels. This helps to blend a selection into the surrounding pixels.
None | 0 | No operation is performed.
Outline | 17 | Apply the outline effect to the image.
Parabolic | 43 | Brightness is adjusted based on either a convex or concave transform as specified.
Perspective | 33 | The image has had the aspect changed for each row or column of pixels.
PicResize | 54 | Resize the picture.
Pinch | 50 | Apply pinch to the image which squeezes a selection.
PolynomialWarp | 47 | Distort the image to conform to a specified shape.
Posterize | 42 | Apply a specified number of brightness values altered. This is useful for creating special effects, such as large, flat areas in a photograph.
RemoveDust | 70 | Removes specks within color images.
RemoveNoise | 69 | Removes noise (pixels with randomly distributed color levels.
RemoveRedeye | 66 | Reduces the red reflection displayed in the eyes of people from which a color flash photo image was taken.
RemoveScratches | 71 | Removes scratches within color images along a line.
ReplColors | 30 | Replicate the colors on the image.
Resample | 39 | Change the image pixel dimensions (and therefore display size).
Resize | 23 | Resize the image.
RgbColorCount | 62 | Gives 3 array sets each containing 256 elements which equate to a count of red, green and blue color intensities of the image.
Ripple | 26 | The image has an undulating pattern on a selection, like ripples on the surface of a pond.
Rotate180 | 4 | Rotate the image clockwise 180 degrees.
Rotate270 | 5 | Rotate the image clockwise 270 degrees.
Rotate90 | 3 | Rotate the image clockwise 90 degrees.
RotateAngle | 14 | Rotate the image by a specified angle.
SaveImage | 16 | Save the image.
Separate | 53 | Perform color separation on an image.
Sharpen | 11 | Sharpen by focusing blurred regions by increasing the contrast of adjacent pixels.
SharpenEx | 72 | Sharpens the current DIB by applying a high pass 3x3 convolution filter selected by the user.
Soften | 12 | Soften the image edges.
SoftenEx | 74 | Softens the current DIB by applying a low pass 3x3 convolution filter.
Solarize | 41 | A negative and a positive image blended together.
Swirl | 48 | Transform the image from a swirling pattern from the center of the image.
Tile | 13 | Break the image up into a series of tiles, creating an offset between the selection and the original position.
Twist | 28 | Distort the image in a twisting motion.
Unsharpen | 68 | Combines a noise-cleaning filter with a sharpening filter applied to the image.
UnsharpenEx | 73 | Subtracts the low resolution image from a normal resolution image to create a masked image.
Zoom | 32 | Modify the image to fit the ImagXpress control.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.Operation

See Also

Reference

Accusoft.ImagXpressSdk Namespace


PaletteType Enumeration

PaletteType Enumeration

Accusoft.ImagXpressSdk Namespace : PaletteType Enumeration
Option values used to set the palette type of the Processor.ColorDepth method.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PaletteType
   Inherits System.Enum
'Usage

Dim instance As PaletteType
public enum PaletteType : System.Enum
__value public enum PaletteType : public System.Enum
public enum class PaletteType : public System.Enum
Members
Member | Value | Description
Fixed | 1 | The image is displayed using an internal fixed palette.
Gray | 2 | The image is displayed using a gray scale palette.
Optimized | 0 | The image is displayed using the best possible palette for each image.
PalFile | 3 | The image is displayed using a palette file.
UserDefined | 4 | The image is displayed using a user defined palette.
Remarks

When the ImageXView.PaletteType property is either PalFile or UserDefined, the Processor.LogPalette is used.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.PaletteType

See Also

Reference

Accusoft.ImagXpressSdk Namespace


ParabolicType Enumeration

ParabolicType Enumeration

Accusoft.ImagXpressSdk Namespace : ParabolicType Enumeration
Option values used to determine the type of parabolic transform to perform.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ParabolicType
   Inherits System.Enum
'Usage

Dim instance As ParabolicType
public enum ParabolicType : System.Enum
__value public enum ParabolicType : public System.Enum
public enum class ParabolicType : public System.Enum
Members
Member | Value | Description
Concave | 1 | Brightens the pixels at the high and low range of the current DIB's brightness spectrum. Darkens the pixels in the middle range of the current DIB's brightness spectrum.
Convex | 0 | Darkens the pixels at the high and low range of the current image's brightness spectrum. Brightens the pixels in the middle range of the current image's brightness spectrum.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.ParabolicType

See Also

Reference

Accusoft.ImagXpressSdk Namespace


PerspectiveType Enumeration

PerspectiveType Enumeration

Accusoft.ImagXpressSdk Namespace : PerspectiveType Enumeration
Option values used to determine the type of perspective filter to apply.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PerspectiveType
   Inherits System.Enum
'Usage

Dim instance As PerspectiveType
public enum PerspectiveType : System.Enum
__value public enum PerspectiveType : public System.Enum
public enum class PerspectiveType : public System.Enum
Members
Member | Value | Description
BottomToTop | 1 | Bottom to top.
LeftToRight | 2 | Left to right.
RightToLeft | 3 | Right to left.
TopToBottom | 0 | Top to bottom.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.PerspectiveType

See Also

Reference

Accusoft.ImagXpressSdk Namespace


PhotometricInterpretation Enumeration

PhotometricInterpretation Enumeration

Accusoft.ImagXpressSdk Namespace : PhotometricInterpretation Enumeration
The PhotometricInterpretation of a TIFF image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PhotometricInterpretation
   Inherits System.Enum
'Usage

Dim instance As PhotometricInterpretation
public enum PhotometricInterpretation : System.Enum
__value public enum PhotometricInterpretation : public System.Enum
public enum class PhotometricInterpretation : public System.Enum
Members
Member | Value | Description
BlackIsZero | 1 | For bilevel and grayscale images: 0 is imaged as black.
CIELab1976 | 8 | 1976 CIE L*a*b*, normal encoding.
ICCLab | 9 | ICCLab enocoding.
None | -1 | Loaded image is non-TIFF, or a TIFF image without a Photometric Interpretation specified.
PaletteColor | 3 | In this model, a color is described with a single component. The value of the component is used as an index into the red, green and blue curves in the ColorMap field to retrieve an RGB triplet that defines the color.
RGB | 2 | In the RGB model, a color is described as a combination of the three primary colors of light (red, green, and blue) in particular concentrations.
Separated | 5 | Usually CMYK.
TransparencyMask | 4 | This means that the image is used to define an irregularly shaped region of another image in the same TIFF file.
WhiteIsZero | 0 | For bilevel and grayscale images: 0 is imaged as white.
YCbCr | 6 | YCbCr.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.PhotometricInterpretation

See Also

Reference

Accusoft.ImagXpressSdk Namespace


PngFilter Enumeration

PngFilter Enumeration

Accusoft.ImagXpressSdk Namespace : PngFilter Enumeration
The filters available for PNG compression.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PngFilter
   Inherits System.Enum
'Usage

Dim instance As PngFilter
public enum PngFilter : System.Enum
__value public enum PngFilter : public System.Enum
public enum class PngFilter : public System.Enum
Members
Member | Value | Description
Average | 3 | The Average filter uses the average of the two neighboring pixels (left and above) to predict the value of a pixel.
None | 0 | Fastest, no filter is used.
Optimal | 5 | Optimal compressed file size, at the expense of speed.
Paeth | 4 | The Paeth filter computes a simple linear function of the three neighboring pixels (left, above, upper left), then chooses as predictor the neighboring pixel closest to the computed value. This technique is due to Alan W. Paeth.
Sub | 1 | The Sub filter transmits the difference between each byte and the value of the corresponding byte of the prior pixel.
Up | 2 | The Up filter is just like the Sub filter except that the pixel immediately above the current pixel, rather than just to its left, is used as the predictor.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.PngFilter

See Also

Reference

Accusoft.ImagXpressSdk Namespace


PrintType Enumeration

PrintType Enumeration

Accusoft.ImagXpressSdk Namespace : PrintType Enumeration
Option values to determine the type of the print.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum PrintType
   Inherits System.Enum
'Usage

Dim instance As PrintType
public enum PrintType : System.Enum
__value public enum PrintType : public System.Enum
public enum class PrintType : public System.Enum
Members
Member | Value | Description
FullImage | 0 | Print the Full Image
Rubberband | 2 | Print the image that is inside of the Rubberband
ViewCroppedImage | 1 | Print the image that is cropped by the ImageXView's crop rectangle
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.PrintType

See Also

Reference

Accusoft.ImagXpressSdk Namespace


ProgressionOrder Enumeration

ProgressionOrder Enumeration

Accusoft.ImagXpressSdk Namespace : ProgressionOrder Enumeration
Option values used to determine the progression order of a JPEG 2000 file being saved.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ProgressionOrder
   Inherits System.Enum
'Usage

Dim instance As ProgressionOrder
public enum ProgressionOrder : System.Enum
__value public enum ProgressionOrder : public System.Enum
public enum class ProgressionOrder : public System.Enum
Members
Member | Value | Description
ComponentPositionResolutionLayer | 5 | Component, position, resolution, layer progression order.
Default | 0 | Default progression order.
LayerResolutionComponentPosition | 1 | Layer, resolution, component, position progression order.
PositionComponentResolutionLayer | 4 | Position, component, resolution, layer progression order.
ResolutionLayerComponentPosition | 2 | Resolution, layer, component, position progression order.
ResolutionPositionComponentLayer | 3 | Resolution, layer, component, position progression order.
Remarks

The progression order of the saved JPEG 2000 file is the order of the compressed image data for the layer, the component, the resolution and the position.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.ProgressionOrder

See Also

Reference

Accusoft.ImagXpressSdk Namespace


RedeyeGlare Enumeration

RedeyeGlare Enumeration

Accusoft.ImagXpressSdk Namespace : RedeyeGlare Enumeration
Option values used in the Processor.RemoveRedeye method.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum RedeyeGlare
   Inherits System.Enum
'Usage

Dim instance As RedeyeGlare
public enum RedeyeGlare : System.Enum
__value public enum RedeyeGlare : public System.Enum
public enum class RedeyeGlare : public System.Enum
Members
Member | Value | Description
Full | 2 | Strong image glare.
None | 0 | No glare.
Slight | 1 | Slight image glare.
Remarks

Note: Available in Professional edition.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.RedeyeGlare

See Also

Reference

Accusoft.ImagXpressSdk Namespace


RedeyePrecision Enumeration

RedeyePrecision Enumeration

Accusoft.ImagXpressSdk Namespace : RedeyePrecision Enumeration
Option values used as parameters in the Processor.RemoveRedeye method.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum RedeyePrecision
   Inherits System.Enum
'Usage

Dim instance As RedeyePrecision
public enum RedeyePrecision : System.Enum
__value public enum RedeyePrecision : public System.Enum
public enum class RedeyePrecision : public System.Enum
Members
Member | Value | Description
Imprecise | 1 | Search the region for the specified red pixels.
ImpreciseRuddy | 2 | Search the region for the specified red pixels. Use this value if the subject's face has a rosy complexion.
Precise | 0 | Use the precise region to reduce the red color.
Remarks

Note: Available in Professional edition.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.RedeyePrecision

See Also

Reference

Accusoft.ImagXpressSdk Namespace


RedeyeShade Enumeration

RedeyeShade Enumeration

Accusoft.ImagXpressSdk Namespace : RedeyeShade Enumeration
Option values used as parameters in the Processor.RemoveRedeye method.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum RedeyeShade
   Inherits System.Enum
'Usage

Dim instance As RedeyeShade
public enum RedeyeShade : System.Enum
__value public enum RedeyeShade : public System.Enum
public enum class RedeyeShade : public System.Enum
Members
Member | Value | Description
Dark | 2 | Dark eye shading.
Light | 1 | Light eye shading.
Normal | 0 | Normal shade.
Remarks

Note: Available in Professional edition.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.RedeyeShade

See Also

Reference

Accusoft.ImagXpressSdk Namespace


RefreshMode Enumeration

RefreshMode Enumeration

Accusoft.ImagXpressSdk Namespace : RefreshMode Enumeration
Option values which determine the refresh mode for the ImageXView control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum RefreshMode
   Inherits System.Enum
'Usage

Dim instance As RefreshMode
public enum RefreshMode : System.Enum
__value public enum RefreshMode : public System.Enum
public enum class RefreshMode : public System.Enum
Members
Member | Value | Description
Immediate | 1 | Immediate refresh mode, view is updated immediately after an operation has completed.
Standard | 0 | Default refresh mode, view is invalidated and will update the next time a paint message is received.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.RefreshMode

See Also

Reference

Accusoft.ImagXpressSdk Namespace


RegionType Enumeration

RegionType Enumeration

Accusoft.ImagXpressSdk Namespace : RegionType Enumeration
Option values that determine the type of shape a region takes.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum RegionType
   Inherits System.Enum
'Usage

Dim instance As RegionType
public enum RegionType : System.Enum
__value public enum RegionType : public System.Enum
public enum class RegionType : public System.Enum
Members
Member | Value | Description
Elliptical | 1 | Elliptical region.
Polygon | 2 | Polygon region.
Rectangle | 0 | Rectangular region.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.RegionType

See Also

Reference

Accusoft.ImagXpressSdk Namespace


RenderIntent Enumeration

RenderIntent Enumeration

Accusoft.ImagXpressSdk Namespace : RenderIntent Enumeration
Option values for rendering colors by relative scale of spatial distnces, saturation, colors closest to inside values and distance to white point.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum RenderIntent
   Inherits System.Enum
'Usage

Dim instance As RenderIntent
public enum RenderIntent : System.Enum
__value public enum RenderIntent : public System.Enum
public enum class RenderIntent : public System.Enum
Members
Member | Value | Description
AbsoluteColormetric | 3 | Similar to Business, but white point is preserved. Spatial color distance to white point changes but not the white point itself. This is an accurate view, but potentially less pleasing one.
Business | 1 | Only colors outside of gamut moved to the closest
Graphics | 2 | Preserve the color saturation at the expense of hue and lightness. Vibrant but not accurate color is produced.
Images | 0 | Gamut of image fits, shrinks or expands, and fills the destination device gamut. Spatial distances of colors are relatively scaled for all color to fit within the gamut of the device
Remarks

Note: Available in Professional edition.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.RenderIntent

See Also

Reference

Accusoft.ImagXpressSdk Namespace


ResizeType Enumeration

ResizeType Enumeration

Accusoft.ImagXpressSdk Namespace : ResizeType Enumeration
Option values used to determine what type of resize method to perform.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ResizeType
   Inherits System.Enum
'Usage

Dim instance As ResizeType
public enum ResizeType : System.Enum
__value public enum ResizeType : public System.Enum
public enum class ResizeType : public System.Enum
Members
Member | Value | Description
Fast | 1 | Faster but lower quality resampling. The pixels in the image are resampled using a nearest neighbor interpolation algorithm which is fast, but produces a lower quality image.
Quality | 0 | Higher quality resampling but slower. An Accusoft developed algorithm which produces an extremely high quality image.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.ResizeType

See Also

Reference

Accusoft.ImagXpressSdk Namespace


ResolutionUnits Enumeration

ResolutionUnits Enumeration

Accusoft.ImagXpressSdk Namespace : ResolutionUnits Enumeration
Option values which determine the unit of measure for image reslution.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ResolutionUnits
   Inherits System.Enum
'Usage

Dim instance As ResolutionUnits
public enum ResolutionUnits : System.Enum
__value public enum ResolutionUnits : public System.Enum
public enum class ResolutionUnits : public System.Enum
Members
Member | Value | Description
Cm | 3 | Centimeters.
Inch | 2 | Inches.
None | 1 | None.
NotAvailable | 0 | No absolute unit of measurement.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.ResolutionUnits

See Also

Reference

Accusoft.ImagXpressSdk Namespace


Result Enumeration

Result Enumeration

Accusoft.ImagXpressSdk Namespace : Result Enumeration
Option values returned from image processing methods.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum Result
   Inherits System.Enum
'Usage

Dim instance As Result
public enum Result : System.Enum
__value public enum Result : public System.Enum
public enum class Result : public System.Enum
Members
Member | Value | Description
Error_ImageCanNotBeDeskewed
Error_InvalidUserSpecifiedRawData | 1070 | Invalid user specified data for raw images (non-camera).
ErrorBadAngle | 1016 | The operation failed because an invalid angle was specified.
ErrorBadRadius | 1017 | The operation failed because an invalid radius was specified.
ErrorBufferAccessTimeout | 1043 | Unable to access image buffer.
ErrorCadFileOpenNotCalled | 1066 | Operation not valid unless CadFileOpen is first called.
ErrorCanceled | 1010 | Image load or decompression was cancelled.
ErrorCaptureFailed | 1021 | Capture failed.
ErrorClipboardCopy | 1014 | Error copying image to the clipboard.
ErrorClipboardPaste | 1013 | Error pasting from clipboard.
ErrorCreateFile | 1005 | Cannot create file.
ErrorEventResponse | 1044 | Event handler error.
ErrorFileOpen | 1000 | Cannot find or cannot open the image file.
ErrorFileRead | 1003 | Error reading the file.
ErrorFileWrite | 1006 | Error writing file.
ErrorFormatUnknown | 1001 | The image file type is unknown or unable to read the image file type.
ErrorFtp | 1048 | FTP (File Transfer Protocol) error.
ErrorIcmNotEnabled | 1057 | Image color management not enabled.
ErrorImageAccessTimeout | 1038 | Unable to access requested image.
ErrorImageHasTasksPending | 1046 | Tasks currently in process must complete.
ErrorInternalFailure | 1042 | Internal failure.
ErrorInternetHttpToHttpsOnRedirect | 1053 | Invalid HTTP to HTTPS redirect.
ErrorInternetInValidCA | 1049 | Invalid Internet certificate.
ErrorInternetPostIsNonSecure | 1050 | Invalid post to unsecure HTTP address.
ErrorInternetSecurityCertificateCNInvalid | 1051 | Invalid security certificate.
ErrorInternetSecurityCertificateDateInvalid | 1052 | Invalid security certificate date.
ErrorInvalidAreaOrRegion | 1035 | Invalid region or area.
ErrorInvalidBitDepth | 1063 | The bit depth provided is invalid.
ErrorInvalidCrop | 1018 | Loading an image failed because the crop dimensions are out of range for the specified image.
ErrorInvalidFileName | 1020 | Invalid file name.
ErrorInvalidFormat | 1008 | Invalid image format.
ErrorInvalidHandle | 1033 | Invalid window handle.
ErrorInvalidIcmProfile | 1055 | Invalid image color management profile.
ErrorInvalidImageId | 1036 | Invalid image ID.
ErrorInvalidLicense | 1022 | Invalid license. Attempting to access functionality that is not covered under the license in effect.
ErrorInvalidOption | 1009 | Invalid option.
ErrorInvalidPage | 1069 | Invalid page number or number of pages.
ErrorInvalidPaletteFile | 1011 | Invalid palette file.
ErrorInvalidPicPassword | 1015 | Attempting to read a password protected PIC file and the password in the PICPassword property does not match the password on file.
ErrorInvalidPointer | 1034 | Invalid pointer.
ErrorInvalidPropertyValue | 1019 | Invalid property value.
ErrorInvalidWebIntegratorLicense | 1024 | Invalid web license.
ErrorJpegCommentAddFailure | 1030 | Unable to add a JPEG comment.
ErrorJpegCommentNotFound | 1029 | JPEG comment not found. The requested comment does not exist.
ErrorLoadLibraryFailForWinInet | 1047 | Library failed to load.
ErrorLoadWatermarkImage | 1026 | Unable to load watermark image.
ErrorMemoryAlloc | 1004 | Cannot allocate memory for the image.
ErrorMemoryLock | 1002 | Cannot lock memory.
ErrorMissingOrBadCmykProfile | 1056 | CMYK profile missing or corrupt.
ErrorNoCurrentBuffer | 1037 | No current image buffer found.
ErrorNoImage | 1007 | The operation failed because the control does not have an image.
ErrorNoLicense | 1023 | License not found.
ErrorNone | 0 | No error.
ErrorNoResources | 1058 | Image capture failed.
ErrorNoWindow | 1028 | No window handle.
ErrorOperationNotApplicableForRawImages | 1041 | Invalid image operation on RAW image formats.
ErrorOperationNotApplicableForVirtualImages | 1065 | The operation is not applicable for virtual images.
ErrorPaletteIndexOutOfRange | 1012 | The specified palette index does not lie within the number of palette entries for the current image.
ErrorPrintNotSupported | 1059 | Printer does not support the requested function.
ErrorPrintOutOfRange | 1060 | Cannot print outside the valid printer area.
ErrorResumeThreadFailure | 1039 | Resume thread failure.
ErrorShutdown | 1040 | Windows is shutting down.
ErrorTagAdd | 1061 | Unable to add tag.
ErrorTagItemNotFound | 1032 | Tag item not found.
ErrorTagModify | 1067 | Unable to modify a tag or tags.
ErrorTagNotFound | 1031 | Tag not found.
ErrorThreadCreation | 1045 | Unable to create thread.
ErrorUnableToCreateThumbnail 1068 Unable to create the thumbnail because it was either too large or unsupported for the bit depth.

A thumbnail must:

  • be able to fit inside of a 64K data structure
  • be smaller than the original image
  • not be a 12-bit grayscale image

ErrorUnableToCrop | 1027 | Unable to crop.
ErrorUnableToGetAnnotations | 1064 | Unable to get annotations.
ErrorUnsupportedPdf | 1062 | PDF not supported.
InternetHTTPNoConnection | 1054 | No Internet connection.
Ok | 0 | No error.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.Result

See Also

Reference

Accusoft.ImagXpressSdk Namespace


RippleDirection Enumeration

RippleDirection Enumeration

Accusoft.ImagXpressSdk Namespace : RippleDirection Enumeration
Option values used with the Processor.Ripple method.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum RippleDirection
   Inherits System.Enum
'Usage

Dim instance As RippleDirection
public enum RippleDirection : System.Enum
__value public enum RippleDirection : public System.Enum
public enum class RippleDirection : public System.Enum
Members
Member | Value | Description
Both | 2 | Horizontal and vertical ripple effect.
Horizontal | 0 | Horizontal ripple effect.
Vertical | 1 | Vertical ripple effect.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.RippleDirection

See Also

Reference

Accusoft.ImagXpressSdk Namespace


RotateAngle Enumeration

RotateAngle Enumeration

Accusoft.ImagXpressSdk Namespace : RotateAngle Enumeration
Option values to determine what type of rotation, mirror, or image flipping functionality to invoke.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum RotateAngle
   Inherits System.Enum
'Usage

Dim instance As RotateAngle
public enum RotateAngle : System.Enum
__value public enum RotateAngle : public System.Enum
public enum class RotateAngle : public System.Enum
Members
Member | Value | Description
Rotate0 | 0 | No rotation.
Rotate180 | 2 | Rotate clockwise 90 degrees.
Rotate270 | 3 | Rotate clockwise 90 degrees.
Rotate90 | 1 | Rotate clockwise 90 degrees.
RotateFlip | 4 | Flip the image.
RotateMirror | 5 | Mirror the image.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.RotateAngle

See Also

Reference

Accusoft.ImagXpressSdk Namespace


SeparationType Enumeration

SeparationType Enumeration

Accusoft.ImagXpressSdk Namespace : SeparationType Enumeration
Option values used to determine what type of Processor.ColorSeparation functionality.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum SeparationType
   Inherits System.Enum
'Usage

Dim instance As SeparationType
public enum SeparationType : System.Enum
__value public enum SeparationType : public System.Enum
public enum class SeparationType : public System.Enum
Members
Member | Value | Description
Cmy | 2 | Separate the cyan, magenta, and yellow image components.
Cmyk | 3 | Separate the cyan, magenta, yellow, and black image components.
Hsl | 1 | Separate the hue, saturation, and luminance image components.
Rgb | 0 | Separate the red, green, and blue image components.
Rgba | 4 | Separate the red, green, blue and alpha image components.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.SeparationType

See Also

Reference

Accusoft.ImagXpressSdk Namespace


SharpenFilter Enumeration

SharpenFilter Enumeration

Accusoft.ImagXpressSdk Namespace : SharpenFilter Enumeration
Option values used in determining which type of Sharpen Filter to use.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum SharpenFilter
   Inherits System.Enum
'Usage

Dim instance As SharpenFilter
public enum SharpenFilter : System.Enum
__value public enum SharpenFilter : public System.Enum
public enum class SharpenFilter : public System.Enum
Members
Member | Value | Description
SharpenFilter1 | 0 | Sharpen filter 1. Matrix: (0 -1 0 -1 5 -1 0 -1 0) / 1
SharpenFilter2 | 1 | Sharpen filter 2. Matrix: (-1 -1 -1 -1 9 -1 -1 -1 -1) / 6
SharpenFilter3 | 2 | Sharpen filter 3. Matrix: (1 -2 1 -2 5 -2 1 -2 1) / 1
Remarks
Sharpen filters use a 3x3 Convolution Matrix to apply the desired effect. Where A, B, C, and S are four values used: A B A B C B / S A B A S is used to normalize the value.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.SharpenFilter

See Also

Reference

Accusoft.ImagXpressSdk Namespace


ShearType Enumeration

ShearType Enumeration

Accusoft.ImagXpressSdk Namespace : ShearType Enumeration
Option values used to determine the document shear direction.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ShearType
   Inherits System.Enum
'Usage

Dim instance As ShearType
public enum ShearType : System.Enum
__value public enum ShearType : public System.Enum
public enum class ShearType : public System.Enum
Members
Member | Value | Description
Horizontal | 1 | Horizontal shearing.
Vertical | 0 | Vertical shearing.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.ShearType

See Also

Reference

Accusoft.ImagXpressSdk Namespace


SoftenFilter Enumeration

SoftenFilter Enumeration

Accusoft.ImagXpressSdk Namespace : SoftenFilter Enumeration
Option values used in determining which type of Soften Filter to employ.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum SoftenFilter
   Inherits System.Enum
'Usage

Dim instance As SoftenFilter
public enum SoftenFilter : System.Enum
__value public enum SoftenFilter : public System.Enum
public enum class SoftenFilter : public System.Enum
Members
Member | Value | Description
SoftenFilter0 | 0 | Soften filter 0. Matrix: (1 1 1 1 1 1 1 1 1) / 9
SoftenFilter1 | 1 | Soften filter 1. Matrix: (0 1 0 1 2 1 0 1 0) / 6
SoftenFilter2 | 2 | Soften filter 2. Matrix: (1 1 1 1 2 1 1 1 1) / 10
SoftenFilter3 | 3 | Soften filter 3. Matrix: (1 2 1 2 4 2 1 2 1) / 16
Remarks
Soften filters use a 3x3 Convolution Matrix to apply the desired effect. Where A, B, C, and S are four values used: A B A B C B / S A B A S is used to normalize the value.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.SoftenFilter

See Also

Reference

Accusoft.ImagXpressSdk Namespace


SubSampling Enumeration

SubSampling Enumeration

Accusoft.ImagXpressSdk Namespace : SubSampling Enumeration
Option values for subsampling type for a JPEG, TIFF-JPEG or ePIC file format.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum SubSampling
   Inherits System.Enum
'Usage

Dim instance As SubSampling
public enum SubSampling : System.Enum
__value public enum SubSampling : public System.Enum
public enum class SubSampling : public System.Enum
Members
Member | Value | Description
SubSampling111 | 0 | 1:1:1 - No subsampling.
SubSampling211 | 1 | 2:1:1 - 2 to 1 horizontal subsampling.
SubSampling211v | 3 | 2:1:1 Vertical only - 2 to 1 vertical subsampling.
SubSampling411 | 2 | 4:1:1 - 2 to 1 horizontal and vertical subsampling.
Remarks

The default value is SubSampling411.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.SubSampling

See Also

Reference

Accusoft.ImagXpressSdk Namespace


TagTypes Enumeration

TagTypes Enumeration

Accusoft.ImagXpressSdk Namespace : TagTypes Enumeration
Option values which determine the type of TIFF tag.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum TagTypes
   Inherits System.Enum
'Usage

Dim instance As TagTypes
public enum TagTypes : System.Enum
__value public enum TagTypes : public System.Enum
public enum class TagTypes : public System.Enum
Members
Member | Value | Description
Ascii | 2 | ASCII character
Byte | 1 | Byte
Double | 12 | Double (8 bytes)
Float | 11 | Float (4 bytes)
Long | 4 | Long
Rational | 5 | Rational
Sbyte | 6 | Signed byte
Short | 3 | Short
Slong | 9 | Signed long
Srational | 10 | Signed rational
Sshort | 8 | Signed short
Undefine | 7 | 8 bit byte
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.TagTypes

See Also

Reference

Accusoft.ImagXpressSdk Namespace


ThumbnailSize Enumeration

ThumbnailSize Enumeration

Accusoft.ImagXpressSdk Namespace : ThumbnailSize Enumeration
Option values used to determine the thumbnail size.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ThumbnailSize
   Inherits System.Enum
'Usage

Dim instance As ThumbnailSize
public enum ThumbnailSize : System.Enum
__value public enum ThumbnailSize : public System.Enum
public enum class ThumbnailSize : public System.Enum
Members
Member | Value | Description
None | 0 | The image is normal size.
OneQuarter | 1 | The image is 1/4 its normal size.
OneSixteenth | 2 | The image is 1/16 its normal size.
OneSixtyFourth | 3 | The image is 1/64 its normal size.
Remarks

The default valueis None.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.ThumbnailSize

See Also

Reference

Accusoft.ImagXpressSdk Namespace


Tool Enumeration

Tool Enumeration

Accusoft.ImagXpressSdk Namespace : Tool Enumeration
Option values used to determine the tool selected.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum Tool
   Inherits System.Enum
'Usage

Dim instance As Tool
public enum Tool : System.Enum
__value public enum Tool : public System.Enum
public enum class Tool : public System.Enum
Members
Member | Value | Description
Hand | 4 | Image panning tool.
Magnify | 5 | Magnifying window.
None | 0 | No tool is selected.
Pan | 7 | Panning tool.
Select | 6 | Window selection tool.
ZoomIn | 1 | Zoom in tool.
ZoomOut | 2 | Zoom out tool.
ZoomRect | 3 | Zoom rectangle tool.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.Tool

See Also

Reference

Accusoft.ImagXpressSdk Namespace


ToolAction Enumeration

ToolAction Enumeration

Accusoft.ImagXpressSdk Namespace : ToolAction Enumeration
Option values used to determine what type of tool event has occurred.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ToolAction
   Inherits System.Enum
'Usage

Dim instance As ToolAction
public enum ToolAction : System.Enum
__value public enum ToolAction : public System.Enum
public enum class ToolAction : public System.Enum
Members
Member | Value | Description
Begin | 1 | Begin the tool operation.
Clicked | 0 | The tool was clicked (activated).
End | 2 | The tool operation is complete.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.ToolAction

See Also

Reference

Accusoft.ImagXpressSdk Namespace


ToolAttribute Enumeration

ToolAttribute Enumeration

Accusoft.ImagXpressSdk Namespace : ToolAttribute Enumeration
Option values used to determine a tool's attribute value.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ToolAttribute
   Inherits System.Enum
'Usage

Dim instance As ToolAttribute
public enum ToolAttribute : System.Enum
__value public enum ToolAttribute : public System.Enum
public enum class ToolAttribute : public System.Enum
Members
Member | Value | Description
AllowNotateXpressToDisplayTooltips | 9 | Allow NotateXpress to Display Tooltips while using a tool.
MagFactor | 2 | Magnification factor.
MagHeight | 4 | Magnifier height value.
MagWidth | 3 | Magnifier width value.
MinimumArea | 8 | Minimum Area for a selection.
SelectShape | 7 | Select region shape.
ZoomInFactor | 0 | Zoom in factor.
ZoomOutFactor | 1 | Zoom out factor.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.ToolAttribute

See Also

Reference

Accusoft.ImagXpressSdk Namespace


ToolbarIconSize Enumeration

ToolbarIconSize Enumeration

Accusoft.ImagXpressSdk Namespace : ToolbarIconSize Enumeration
Option values which determine the size of icons displayed in the toolbar.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ToolbarIconSize
   Inherits System.Enum
'Usage

Dim instance As ToolbarIconSize
public enum ToolbarIconSize : System.Enum
__value public enum ToolbarIconSize : public System.Enum
public enum class ToolbarIconSize : public System.Enum
Members
Member | Value | Description
Large | 0 | Large (32 by 32 pixel) icons.
Medium | 1 | Medium (24 by 24 pixel) icons.
Small | 2 | Small (16 by 16 pixel) icons.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.ToolbarIconSize

See Also

Reference

Accusoft.ImagXpressSdk Namespace


ToolCursor Enumeration

ToolCursor Enumeration

Accusoft.ImagXpressSdk Namespace : ToolCursor Enumeration
Option values which determines the tool cursor to change.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ToolCursor
   Inherits System.Enum
'Usage

Dim instance As ToolCursor
public enum ToolCursor : System.Enum
__value public enum ToolCursor : public System.Enum
public enum class ToolCursor : public System.Enum
Members
Member | Value | Description
ToolHandClose | 4 | Hand tool close handed cursor
ToolHandOpen | 3 | Hand tool open handed cursor
ToolMagnifier | 5 | Magnifier tool cursor
ToolPanDefault | 15 | Pan tool default cursor
ToolPanEast | 13 | Pan tool Eest cursor
ToolPanNorth | 7 | Pan tool North cursor
ToolPanNortheast | 9 | Pan tool Northeast cursor
ToolPanNorthwest | 8 | Pan tool Northwest cursor
ToolPanSouth | 10 | Pan tool South cursor
ToolPanSoutheast | 11 | Pan tool Southeast cursor
ToolPanSouthwest | 12 | Pan tool Southwest cursor
ToolPanWest | 14 | Pan tool West cursor
ToolSelect | 6 | Select tool cursor
ToolZoomIn | 0 | ZoomIn tool cursor
ToolZoomOut | 1 | ZoomOut tool cursor
ToolZoomRect | 2 | ZoomRect tool cursor
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.ToolCursor

See Also

Reference

Accusoft.ImagXpressSdk Namespace


TouchMode Enumeration

TouchMode Enumeration

Accusoft.ImagXpressSdk Namespace : TouchMode Enumeration
Option values which determine the mode of Touch interface.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum TouchMode
   Inherits System.Enum
'Usage

Dim instance As TouchMode
public enum TouchMode : System.Enum
__value public enum TouchMode : public System.Enum
public enum class TouchMode : public System.Enum
Members
Member | Value | Description
AllEnabled | 3 | Both gestures and flicks are processed and received if a touch interface is present.
FlicksEnabled | 2 | Only flicks are processed and received if a touch interface is present.
GesturesEnabled | 1 | Default Touch mode, only gestures are processed and received if a touch interface is present.
Off | 0 | Touch interface is disabled.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.TouchMode

See Also

Reference

Accusoft.ImagXpressSdk Namespace


TransformMode Enumeration

TransformMode Enumeration

Accusoft.ImagXpressSdk Namespace : TransformMode Enumeration
The transform mode of the JPEG Reduce operation.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum TransformMode
   Inherits System.Enum
'Usage

Dim instance As TransformMode
public enum TransformMode : System.Enum
__value public enum TransformMode : public System.Enum
public enum class TransformMode : public System.Enum
Members
Member | Value | Description
None | 0 | No transform occurs.
ToProgressiveJpeg | 1 | Transforms a Sequential or Baseline JPEG to a Progressive JPEG.
ToSequentialJpeg | 2 | Transforms a Progressive JPEG to a Sequential or Baseline JPEG.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.TransformMode

See Also

Reference

Accusoft.ImagXpressSdk Namespace


TranslateType Enumeration

TranslateType Enumeration

Accusoft.ImagXpressSdk Namespace : TranslateType Enumeration
Option values used in determing what type of translation to perform.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum TranslateType
   Inherits System.Enum
'Usage

Dim instance As TranslateType
public enum TranslateType : System.Enum
__value public enum TranslateType : public System.Enum
public enum class TranslateType : public System.Enum
Members
Member | Value | Description
PixelToView | 1 | Pixels to view units of measure.
ViewToPixel | 0 | View units of measure to pixels.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.TranslateType

See Also

Reference

Accusoft.ImagXpressSdk Namespace


TransparencyMatch Enumeration

TransparencyMatch Enumeration

Accusoft.ImagXpressSdk Namespace : TransparencyMatch Enumeration
Option values used to determine the type of TransparencyMatch property to invoke.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum TransparencyMatch
   Inherits System.Enum
'Usage

Dim instance As TransparencyMatch
public enum TransparencyMatch : System.Enum
__value public enum TransparencyMatch : public System.Enum
public enum class TransparencyMatch : public System.Enum
Members
Member | Value | Description
Closest | 1 | Use the color in the image that is the closest match to the one specified in the SaveOptions class.
Exact | 2 | Use the color specified in the SaveOptions class.
None | 0 | No transparent color.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.TransparencyMatch

See Also

Reference

Accusoft.ImagXpressSdk Namespace


TwistRotation Enumeration

TwistRotation Enumeration

Accusoft.ImagXpressSdk Namespace : TwistRotation Enumeration
Option values used in evaluating the rotation angle.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum TwistRotation
   Inherits System.Enum
'Usage

Dim instance As TwistRotation
public enum TwistRotation : System.Enum
__value public enum TwistRotation : public System.Enum
public enum class TwistRotation : public System.Enum
Members
Member | Value | Description
Rotate180 | 1 | Rotate block 180 degrees.
Rotate270 | 2 | Rotate block 270 degrees.
Rotate90 | 0 | Rotate block 90 degrees.
RotateRandom | 3 | Rotate block randomly.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.TwistRotation

See Also

Reference

Accusoft.ImagXpressSdk Namespace


UnsharpenFilter Enumeration

UnsharpenFilter Enumeration

Accusoft.ImagXpressSdk Namespace : UnsharpenFilter Enumeration
Option values used in determining what type of Processor.Unsharpen method to apply.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum UnsharpenFilter
   Inherits System.Enum
'Usage

Dim instance As UnsharpenFilter
public enum UnsharpenFilter : System.Enum
__value public enum UnsharpenFilter : public System.Enum
public enum class UnsharpenFilter : public System.Enum
Members
Member | Value | Description
UnsharpenFilter1 | 0 | Unsharpen filter 1. Matrix: (-1 -1 -1 -1 17 -1 -1 -1 -1) / 9
UnsharpenFilter2 | 1 | Unsharpen filter 2. Matrix: (-2 -2 -2 -2 43 -2 -2 -2 -2) / 27
UnsharpenFilter3 | 2 | Unsharpen filter 3. Matrix: (1 -2 1 -2 24 -2 1 -2 1) / 12
Remarks

Note: Available in Professional edition.

Unsharpen filters use a 3x3 Convolution Matrix to apply the desired effect. Where A, B, C, and S are four values used: A B A B C B / S A B A S is used to normalize the value.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.UnsharpenFilter

See Also

Reference

Accusoft.ImagXpressSdk Namespace


WhiteBalanceMethod Enumeration

WhiteBalanceMethod Enumeration

Accusoft.ImagXpressSdk Namespace : WhiteBalanceMethod Enumeration
Type of white-balancing to apply to the image.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum WhiteBalanceMethod
   Inherits System.Enum
'Usage

Dim instance As WhiteBalanceMethod
public enum WhiteBalanceMethod : System.Enum
__value public enum WhiteBalanceMethod : public System.Enum
public enum class WhiteBalanceMethod : public System.Enum
Members
Member | Value | Description
Auto | 1 | Examines the image pixels and attempts to discern the best setting to balance the white.
Camera | 0 | Examines the raw file to determine the white balance information designated by the camera. If that information isn't present or can't be read then ImagXpress changes the setting to Auto and proceeds as if that was the original value.
Manual | 2 | Does nothing and relies on the user to manually set LoadOptionsCameraRaw.RedFactor and LoadOptionsCameraRaw.BlueFactor to do the white balancing.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.WhiteBalanceMethod

See Also

Reference

Accusoft.ImagXpressSdk Namespace


ZoomToFitType Enumeration

ZoomToFitType Enumeration

Accusoft.ImagXpressSdk Namespace : ZoomToFitType Enumeration
Option values to determine if the image fit is within the ImagXpress viewer control.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ZoomToFitType
   Inherits System.Enum
'Usage

Dim instance As ZoomToFitType
public enum ZoomToFitType : System.Enum
__value public enum ZoomToFitType : public System.Enum
public enum class ZoomToFitType : public System.Enum
Members
Member | Value | Description
FitBest | 2 | Fit such that the entire image appears within the control.
FitHeight | 1 | Fit to the height of the control.
FitWidth | 0 | Fit to the width of the control.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ImagXpressSdk.ZoomToFitType

See Also

Reference

Accusoft.ImagXpressSdk Namespace


ImageXView.AutoResizeChangedEventHandler Delegate

ImageXView.AutoResizeChangedEventHandler Delegate

Accusoft.ImagXpressSdk Namespace : ImageXView.AutoResizeChangedEventHandler Delegate
A System.Object that fired the event.
The AutoResizeChangedEventArgs which contains information about the event.
A handler for the auto resize changed event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub ImageXView.AutoResizeChangedEventHandler( _
   ByVal sender As Object, _
   ByVal e As AutoResizeChangedEventArgs _
)
'Usage

Dim instance As New ImageXView.AutoResizeChangedEventHandler(AddressOf HandlerMethod)
public delegate void ImageXView.AutoResizeChangedEventHandler(
   object sender,
   AutoResizeChangedEventArgs e
)
public: __gc __delegate void ImageXView.AutoResizeChangedEventHandler(
   Object* sender,
   AutoResizeChangedEventArgs* e
)
public delegate void ImageXView.AutoResizeChangedEventHandler(
   Object^ sender,
   AutoResizeChangedEventArgs^ e
)

Parameters

sender
A System.Object that fired the event.
e
The AutoResizeChangedEventArgs which contains information about the event.
See Also

Reference

ImageXView.AutoResizeChangedEventHandler Members
Accusoft.ImagXpressSdk Namespace


ImageXView.FlickEventHandler Delegate

ImageXView.FlickEventHandler Delegate

Accusoft.ImagXpressSdk Namespace : ImageXView.FlickEventHandler Delegate
A System.Object that fired the event.
The FlickEventArgs which contains information about the event.
A handler for the flick event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub ImageXView.FlickEventHandler( _
   ByVal sender As Object, _
   ByVal e As FlickEventArgs _
)
'Usage

Dim instance As New ImageXView.FlickEventHandler(AddressOf HandlerMethod)
public delegate void ImageXView.FlickEventHandler(
   object sender,
   FlickEventArgs e
)
public: __gc __delegate void ImageXView.FlickEventHandler(
   Object* sender,
   FlickEventArgs* e
)
public delegate void ImageXView.FlickEventHandler(
   Object^ sender,
   FlickEventArgs^ e
)

Parameters

sender
A System.Object that fired the event.
e
The FlickEventArgs which contains information about the event.
See Also

Reference

ImageXView.FlickEventHandler Members
Accusoft.ImagXpressSdk Namespace


ImageXView.PaintImageEventHandler Delegate

ImageXView.PaintImageEventHandler Delegate

Accusoft.ImagXpressSdk Namespace : ImageXView.PaintImageEventHandler Delegate
A System.Object that fired the event.
The PaintImageEventArgs which contains information about the event.
A handler for the paint event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub ImageXView.PaintImageEventHandler( _
   ByVal sender As Object, _
   ByVal e As PaintImageEventArgs _
)
'Usage

Dim instance As New ImageXView.PaintImageEventHandler(AddressOf HandlerMethod)
public delegate void ImageXView.PaintImageEventHandler(
   object sender,
   PaintImageEventArgs e
)
public: __gc __delegate void ImageXView.PaintImageEventHandler(
   Object* sender,
   PaintImageEventArgs* e
)
public delegate void ImageXView.PaintImageEventHandler(
   Object^ sender,
   PaintImageEventArgs^ e
)

Parameters

sender
A System.Object that fired the event.
e
The PaintImageEventArgs which contains information about the event.
See Also

Reference

ImageXView.PaintImageEventHandler Members
Accusoft.ImagXpressSdk Namespace


ImageXView.PanGestureOccurredEventHandler Delegate

ImageXView.PanGestureOccurredEventHandler Delegate

Accusoft.ImagXpressSdk Namespace : ImageXView.PanGestureOccurredEventHandler Delegate
A System.Object that fired the event.
The PanGestureOccurredEventArgs which contains information about the event.
A handler for the pan gesture occurred event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub ImageXView.PanGestureOccurredEventHandler( _
   ByVal sender As Object, _
   ByVal e As PanGestureOccurredEventArgs _
)
'Usage

Dim instance As New ImageXView.PanGestureOccurredEventHandler(AddressOf HandlerMethod)
public delegate void ImageXView.PanGestureOccurredEventHandler(
   object sender,
   PanGestureOccurredEventArgs e
)
public: __gc __delegate void ImageXView.PanGestureOccurredEventHandler(
   Object* sender,
   PanGestureOccurredEventArgs* e
)
public delegate void ImageXView.PanGestureOccurredEventHandler(
   Object^ sender,
   PanGestureOccurredEventArgs^ e
)

Parameters

sender
A System.Object that fired the event.
e
The PanGestureOccurredEventArgs which contains information about the event.
See Also

Reference

ImageXView.PanGestureOccurredEventHandler Members
Accusoft.ImagXpressSdk Namespace


ImageXView.PanGestureOccurringEventHandler Delegate

ImageXView.PanGestureOccurringEventHandler Delegate

Accusoft.ImagXpressSdk Namespace : ImageXView.PanGestureOccurringEventHandler Delegate
A System.Object that fired the event.
The PanGestureOccurringEventArgs which contains information about the event.
A handler for the pan gesture occurring event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub ImageXView.PanGestureOccurringEventHandler( _
   ByVal sender As Object, _
   ByVal e As PanGestureOccurringEventArgs _
)
'Usage

Dim instance As New ImageXView.PanGestureOccurringEventHandler(AddressOf HandlerMethod)
public delegate void ImageXView.PanGestureOccurringEventHandler(
   object sender,
   PanGestureOccurringEventArgs e
)
public: __gc __delegate void ImageXView.PanGestureOccurringEventHandler(
   Object* sender,
   PanGestureOccurringEventArgs* e
)
public delegate void ImageXView.PanGestureOccurringEventHandler(
   Object^ sender,
   PanGestureOccurringEventArgs^ e
)

Parameters

sender
A System.Object that fired the event.
e
The PanGestureOccurringEventArgs which contains information about the event.
See Also

Reference

ImageXView.PanGestureOccurringEventHandler Members
Accusoft.ImagXpressSdk Namespace


ImageXView.PressAndHoldEventHandler Delegate

ImageXView.PressAndHoldEventHandler Delegate

Accusoft.ImagXpressSdk Namespace : ImageXView.PressAndHoldEventHandler Delegate
A System.Object that fired the event.
The PressAndHoldEventArgs which contains information about the event.
A handler for the press and hold event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub ImageXView.PressAndHoldEventHandler( _
   ByVal sender As Object, _
   ByVal e As PressAndHoldEventArgs _
)
'Usage

Dim instance As New ImageXView.PressAndHoldEventHandler(AddressOf HandlerMethod)
public delegate void ImageXView.PressAndHoldEventHandler(
   object sender,
   PressAndHoldEventArgs e
)
public: __gc __delegate void ImageXView.PressAndHoldEventHandler(
   Object* sender,
   PressAndHoldEventArgs* e
)
public delegate void ImageXView.PressAndHoldEventHandler(
   Object^ sender,
   PressAndHoldEventArgs^ e
)

Parameters

sender
A System.Object that fired the event.
e
The PressAndHoldEventArgs which contains information about the event.
See Also

Reference

ImageXView.PressAndHoldEventHandler Members
Accusoft.ImagXpressSdk Namespace


ImageXView.PressAndTapEventHandler Delegate

ImageXView.PressAndTapEventHandler Delegate

Accusoft.ImagXpressSdk Namespace : ImageXView.PressAndTapEventHandler Delegate
A System.Object that fired the event.
The PressAndTapEventArgs which contains information about the event.
A handler for the press and tap event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub ImageXView.PressAndTapEventHandler( _
   ByVal sender As Object, _
   ByVal e As PressAndTapEventArgs _
)
'Usage

Dim instance As New ImageXView.PressAndTapEventHandler(AddressOf HandlerMethod)
public delegate void ImageXView.PressAndTapEventHandler(
   object sender,
   PressAndTapEventArgs e
)
public: __gc __delegate void ImageXView.PressAndTapEventHandler(
   Object* sender,
   PressAndTapEventArgs* e
)
public delegate void ImageXView.PressAndTapEventHandler(
   Object^ sender,
   PressAndTapEventArgs^ e
)

Parameters

sender
A System.Object that fired the event.
e
The PressAndTapEventArgs which contains information about the event.
See Also

Reference

ImageXView.PressAndTapEventHandler Members
Accusoft.ImagXpressSdk Namespace


ImageXView.PrintImageEventHandler Delegate

ImageXView.PrintImageEventHandler Delegate

Accusoft.ImagXpressSdk Namespace : ImageXView.PrintImageEventHandler Delegate
A System.Object that fired the event.
The PrintImageEventArgs which contains information about the event.
Handler for the print image event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub ImageXView.PrintImageEventHandler( _
   ByVal sender As Object, _
   ByVal e As PrintImageEventArgs _
)
'Usage

Dim instance As New ImageXView.PrintImageEventHandler(AddressOf HandlerMethod)
public delegate void ImageXView.PrintImageEventHandler(
   object sender,
   PrintImageEventArgs e
)
public: __gc __delegate void ImageXView.PrintImageEventHandler(
   Object* sender,
   PrintImageEventArgs* e
)
public delegate void ImageXView.PrintImageEventHandler(
   Object^ sender,
   PrintImageEventArgs^ e
)

Parameters

sender
A System.Object that fired the event.
e
The PrintImageEventArgs which contains information about the event.
See Also

Reference

ImageXView.PrintImageEventHandler Members
Accusoft.ImagXpressSdk Namespace


ImageXView.ResizedEventHandler Delegate

ImageXView.ResizedEventHandler Delegate

Accusoft.ImagXpressSdk Namespace : ImageXView.ResizedEventHandler Delegate
A System.Object that fired the event.
The ResizedEventArgs which contains information about the event.
A handler for the resized event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub ImageXView.ResizedEventHandler( _
   ByVal sender As Object, _
   ByVal e As ResizedEventArgs _
)
'Usage

Dim instance As New ImageXView.ResizedEventHandler(AddressOf HandlerMethod)
public delegate void ImageXView.ResizedEventHandler(
   object sender,
   ResizedEventArgs e
)
public: __gc __delegate void ImageXView.ResizedEventHandler(
   Object* sender,
   ResizedEventArgs* e
)
public delegate void ImageXView.ResizedEventHandler(
   Object^ sender,
   ResizedEventArgs^ e
)

Parameters

sender
A System.Object that fired the event.
e
The ResizedEventArgs which contains information about the event.
See Also

Reference

ImageXView.ResizedEventHandler Members
Accusoft.ImagXpressSdk Namespace


ImageXView.RotationGestureOccurredEventHandler Delegate

ImageXView.RotationGestureOccurredEventHandler Delegate

Accusoft.ImagXpressSdk Namespace : ImageXView.RotationGestureOccurredEventHandler Delegate
A System.Object that fired the event.
The RotationGestureOccurredEventArgs which contains information about the event.
A handler for the rotation gesture occurred event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub ImageXView.RotationGestureOccurredEventHandler( _
   ByVal sender As Object, _
   ByVal e As RotationGestureOccurredEventArgs _
)
'Usage

Dim instance As New ImageXView.RotationGestureOccurredEventHandler(AddressOf HandlerMethod)
public delegate void ImageXView.RotationGestureOccurredEventHandler(
   object sender,
   RotationGestureOccurredEventArgs e
)
public: __gc __delegate void ImageXView.RotationGestureOccurredEventHandler(
   Object* sender,
   RotationGestureOccurredEventArgs* e
)
public delegate void ImageXView.RotationGestureOccurredEventHandler(
   Object^ sender,
   RotationGestureOccurredEventArgs^ e
)

Parameters

sender
A System.Object that fired the event.
e
The RotationGestureOccurredEventArgs which contains information about the event.
See Also

Reference

ImageXView.RotationGestureOccurredEventHandler Members
Accusoft.ImagXpressSdk Namespace


ImageXView.RotationGestureOccurringEventHandler Delegate

ImageXView.RotationGestureOccurringEventHandler Delegate

Accusoft.ImagXpressSdk Namespace : ImageXView.RotationGestureOccurringEventHandler Delegate
A System.Object that fired the event.
The RotationGestureOccurringEventArgs which contains information about the event.
A handler for the rotation gesture occurring event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub ImageXView.RotationGestureOccurringEventHandler( _
   ByVal sender As Object, _
   ByVal e As RotationGestureOccurringEventArgs _
)
'Usage

Dim instance As New ImageXView.RotationGestureOccurringEventHandler(AddressOf HandlerMethod)
public delegate void ImageXView.RotationGestureOccurringEventHandler(
   object sender,
   RotationGestureOccurringEventArgs e
)
public: __gc __delegate void ImageXView.RotationGestureOccurringEventHandler(
   Object* sender,
   RotationGestureOccurringEventArgs* e
)
public delegate void ImageXView.RotationGestureOccurringEventHandler(
   Object^ sender,
   RotationGestureOccurringEventArgs^ e
)

Parameters

sender
A System.Object that fired the event.
e
The RotationGestureOccurringEventArgs which contains information about the event.
See Also

Reference

ImageXView.RotationGestureOccurringEventHandler Members
Accusoft.ImagXpressSdk Namespace


ImageXView.ScrollbarVisibleChangedEventHandler Delegate

ImageXView.ScrollbarVisibleChangedEventHandler Delegate

Accusoft.ImagXpressSdk Namespace : ImageXView.ScrollbarVisibleChangedEventHandler Delegate
A System.Object that fired the event.
The ZoomFactorChangedEventArgs which contains information about the event.
Fires when the scrollbar visible changed event occurs.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub ImageXView.ScrollbarVisibleChangedEventHandler( _
   ByVal sender As Object, _
   ByVal e As ScrollbarVisibleChangedEventArgs _
)
'Usage

Dim instance As New ImageXView.ScrollbarVisibleChangedEventHandler(AddressOf HandlerMethod)
public delegate void ImageXView.ScrollbarVisibleChangedEventHandler(
   object sender,
   ScrollbarVisibleChangedEventArgs e
)
public: __gc __delegate void ImageXView.ScrollbarVisibleChangedEventHandler(
   Object* sender,
   ScrollbarVisibleChangedEventArgs* e
)
public delegate void ImageXView.ScrollbarVisibleChangedEventHandler(
   Object^ sender,
   ScrollbarVisibleChangedEventArgs^ e
)

Parameters

sender
A System.Object that fired the event.
e
The ZoomFactorChangedEventArgs which contains information about the event.
See Also

Reference

ImageXView.ScrollbarVisibleChangedEventHandler Members
Accusoft.ImagXpressSdk Namespace


ImageXView.ScrollEventHandler Delegate

ImageXView.ScrollEventHandler Delegate

Accusoft.ImagXpressSdk Namespace : ImageXView.ScrollEventHandler Delegate
A System.Object that fired the event.
The ScrollEventArgs which contains information about the event.
A handler for the scroll event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub ImageXView.ScrollEventHandler( _
   ByVal sender As Object, _
   ByVal e As ScrollEventArgs _
)
'Usage

Dim instance As New ImageXView.ScrollEventHandler(AddressOf HandlerMethod)
public delegate void ImageXView.ScrollEventHandler(
   object sender,
   ScrollEventArgs e
)
public: __gc __delegate void ImageXView.ScrollEventHandler(
   Object* sender,
   ScrollEventArgs* e
)
public delegate void ImageXView.ScrollEventHandler(
   Object^ sender,
   ScrollEventArgs^ e
)

Parameters

sender
A System.Object that fired the event.
e
The ScrollEventArgs which contains information about the event.
See Also

Reference

ImageXView.ScrollEventHandler Members
Accusoft.ImagXpressSdk Namespace


ImageXView.ToolbarCloseEventHandler Delegate

ImageXView.ToolbarCloseEventHandler Delegate

Accusoft.ImagXpressSdk Namespace : ImageXView.ToolbarCloseEventHandler Delegate
A System.Object that fired the event.
The ToolbarCloseEventArgs which contains information about the event.
Handler for the toolbar close event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub ImageXView.ToolbarCloseEventHandler( _
   ByVal sender As Object, _
   ByVal e As ToolbarCloseEventArgs _
)
'Usage

Dim instance As New ImageXView.ToolbarCloseEventHandler(AddressOf HandlerMethod)
public delegate void ImageXView.ToolbarCloseEventHandler(
   object sender,
   ToolbarCloseEventArgs e
)
public: __gc __delegate void ImageXView.ToolbarCloseEventHandler(
   Object* sender,
   ToolbarCloseEventArgs* e
)
public delegate void ImageXView.ToolbarCloseEventHandler(
   Object^ sender,
   ToolbarCloseEventArgs^ e
)

Parameters

sender
A System.Object that fired the event.
e
The ToolbarCloseEventArgs which contains information about the event.
See Also

Reference

ImageXView.ToolbarCloseEventHandler Members
Accusoft.ImagXpressSdk Namespace


ImageXView.ToolbarContextMenuSelectEventHandler Delegate

ImageXView.ToolbarContextMenuSelectEventHandler Delegate

Accusoft.ImagXpressSdk Namespace : ImageXView.ToolbarContextMenuSelectEventHandler Delegate
A System.Object that fired the event.
The ToolbarContextMenuEventArgs which contains information about the event.
A handler for the toolbar context menu select event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub ImageXView.ToolbarContextMenuSelectEventHandler( _
   ByVal sender As Object, _
   ByVal e As ToolbarContextMenuEventArgs _
)
'Usage

Dim instance As New ImageXView.ToolbarContextMenuSelectEventHandler(AddressOf HandlerMethod)
public delegate void ImageXView.ToolbarContextMenuSelectEventHandler(
   object sender,
   ToolbarContextMenuEventArgs e
)
public: __gc __delegate void ImageXView.ToolbarContextMenuSelectEventHandler(
   Object* sender,
   ToolbarContextMenuEventArgs* e
)
public delegate void ImageXView.ToolbarContextMenuSelectEventHandler(
   Object^ sender,
   ToolbarContextMenuEventArgs^ e
)

Parameters

sender
A System.Object that fired the event.
e
The ToolbarContextMenuEventArgs which contains information about the event.
See Also

Reference

ImageXView.ToolbarContextMenuSelectEventHandler Members
Accusoft.ImagXpressSdk Namespace


ImageXView.ToolbarEventHandler Delegate

ImageXView.ToolbarEventHandler Delegate

Accusoft.ImagXpressSdk Namespace : ImageXView.ToolbarEventHandler Delegate
A System.Object that fired the event.
The ToolbarEventArgs which contains information about the event.
Handler for the toolbar event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub ImageXView.ToolbarEventHandler( _
   ByVal sender As Object, _
   ByVal e As ToolbarEventArgs _
)
'Usage

Dim instance As New ImageXView.ToolbarEventHandler(AddressOf HandlerMethod)
public delegate void ImageXView.ToolbarEventHandler(
   object sender,
   ToolbarEventArgs e
)
public: __gc __delegate void ImageXView.ToolbarEventHandler(
   Object* sender,
   ToolbarEventArgs* e
)
public delegate void ImageXView.ToolbarEventHandler(
   Object^ sender,
   ToolbarEventArgs^ e
)

Parameters

sender
A System.Object that fired the event.
e
The ToolbarEventArgs which contains information about the event.
See Also

Reference

ImageXView.ToolbarEventHandler Members
Accusoft.ImagXpressSdk Namespace


ImageXView.ToolbarOpenEventHandler Delegate

ImageXView.ToolbarOpenEventHandler Delegate

Accusoft.ImagXpressSdk Namespace : ImageXView.ToolbarOpenEventHandler Delegate
A System.Object that fired the event.
The ToolbarOpenEventArgs which contains information about the event.
Handler for the toolbar open event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub ImageXView.ToolbarOpenEventHandler( _
   ByVal sender As Object, _
   ByVal e As ToolbarOpenEventArgs _
)
'Usage

Dim instance As New ImageXView.ToolbarOpenEventHandler(AddressOf HandlerMethod)
public delegate void ImageXView.ToolbarOpenEventHandler(
   object sender,
   ToolbarOpenEventArgs e
)
public: __gc __delegate void ImageXView.ToolbarOpenEventHandler(
   Object* sender,
   ToolbarOpenEventArgs* e
)
public delegate void ImageXView.ToolbarOpenEventHandler(
   Object^ sender,
   ToolbarOpenEventArgs^ e
)

Parameters

sender
A System.Object that fired the event.
e
The ToolbarOpenEventArgs which contains information about the event.
See Also

Reference

ImageXView.ToolbarOpenEventHandler Members
Accusoft.ImagXpressSdk Namespace


ImageXView.ToolEventHandler Delegate

ImageXView.ToolEventHandler Delegate

Accusoft.ImagXpressSdk Namespace : ImageXView.ToolEventHandler Delegate
A System.Object that fired the event.
The ToolEventArgs which contains information about the event.
Handler for the tool event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub ImageXView.ToolEventHandler( _
   ByVal sender As Object, _
   ByVal e As ToolEventArgs _
)
'Usage

Dim instance As New ImageXView.ToolEventHandler(AddressOf HandlerMethod)
public delegate void ImageXView.ToolEventHandler(
   object sender,
   ToolEventArgs e
)
public: __gc __delegate void ImageXView.ToolEventHandler(
   Object* sender,
   ToolEventArgs* e
)
public delegate void ImageXView.ToolEventHandler(
   Object^ sender,
   ToolEventArgs^ e
)

Parameters

sender
A System.Object that fired the event.
e
The ToolEventArgs which contains information about the event.
See Also

Reference

ImageXView.ToolEventHandler Members
Accusoft.ImagXpressSdk Namespace


ImageXView.TwoFingerTapEventHandler Delegate

ImageXView.TwoFingerTapEventHandler Delegate

Accusoft.ImagXpressSdk Namespace : ImageXView.TwoFingerTapEventHandler Delegate
A System.Object that fired the event.
The TwoFingerTapEventArgs which contains information about the event.
A handler for the two finger tap event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub ImageXView.TwoFingerTapEventHandler( _
   ByVal sender As Object, _
   ByVal e As TwoFingerTapEventArgs _
)
'Usage

Dim instance As New ImageXView.TwoFingerTapEventHandler(AddressOf HandlerMethod)
public delegate void ImageXView.TwoFingerTapEventHandler(
   object sender,
   TwoFingerTapEventArgs e
)
public: __gc __delegate void ImageXView.TwoFingerTapEventHandler(
   Object* sender,
   TwoFingerTapEventArgs* e
)
public delegate void ImageXView.TwoFingerTapEventHandler(
   Object^ sender,
   TwoFingerTapEventArgs^ e
)

Parameters

sender
A System.Object that fired the event.
e
The TwoFingerTapEventArgs which contains information about the event.
See Also

Reference

ImageXView.TwoFingerTapEventHandler Members
Accusoft.ImagXpressSdk Namespace


ImageXView.ZoomFactorChangedEventHandler Delegate

ImageXView.ZoomFactorChangedEventHandler Delegate

Accusoft.ImagXpressSdk Namespace : ImageXView.ZoomFactorChangedEventHandler Delegate
A System.Object that fired the event.
The ZoomFactorChangedEventArgs which contains information about the event.
A handler for the zoom factor event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub ImageXView.ZoomFactorChangedEventHandler( _
   ByVal sender As Object, _
   ByVal e As ZoomFactorChangedEventArgs _
)
'Usage

Dim instance As New ImageXView.ZoomFactorChangedEventHandler(AddressOf HandlerMethod)
public delegate void ImageXView.ZoomFactorChangedEventHandler(
   object sender,
   ZoomFactorChangedEventArgs e
)
public: __gc __delegate void ImageXView.ZoomFactorChangedEventHandler(
   Object* sender,
   ZoomFactorChangedEventArgs* e
)
public delegate void ImageXView.ZoomFactorChangedEventHandler(
   Object^ sender,
   ZoomFactorChangedEventArgs^ e
)

Parameters

sender
A System.Object that fired the event.
e
The ZoomFactorChangedEventArgs which contains information about the event.
See Also

Reference

ImageXView.ZoomFactorChangedEventHandler Members
Accusoft.ImagXpressSdk Namespace


ImageXView.ZoomGestureOccurredEventHandler Delegate

ImageXView.ZoomGestureOccurredEventHandler Delegate

Accusoft.ImagXpressSdk Namespace : ImageXView.ZoomGestureOccurredEventHandler Delegate
A System.Object that fired the event.
The ZoomGestureOccurredEventArgs which contains information about the event.
A handler for the zoom gesture occurred event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub ImageXView.ZoomGestureOccurredEventHandler( _
   ByVal sender As Object, _
   ByVal e As ZoomGestureOccurredEventArgs _
)
'Usage

Dim instance As New ImageXView.ZoomGestureOccurredEventHandler(AddressOf HandlerMethod)
public delegate void ImageXView.ZoomGestureOccurredEventHandler(
   object sender,
   ZoomGestureOccurredEventArgs e
)
public: __gc __delegate void ImageXView.ZoomGestureOccurredEventHandler(
   Object* sender,
   ZoomGestureOccurredEventArgs* e
)
public delegate void ImageXView.ZoomGestureOccurredEventHandler(
   Object^ sender,
   ZoomGestureOccurredEventArgs^ e
)

Parameters

sender
A System.Object that fired the event.
e
The ZoomGestureOccurredEventArgs which contains information about the event.
See Also

Reference

ImageXView.ZoomGestureOccurredEventHandler Members
Accusoft.ImagXpressSdk Namespace


ImageXView.ZoomGestureOccurringEventHandler Delegate

ImageXView.ZoomGestureOccurringEventHandler Delegate

Accusoft.ImagXpressSdk Namespace : ImageXView.ZoomGestureOccurringEventHandler Delegate
A System.Object that fired the event.
The ZoomGestureOccurringEventArgs which contains information about the event.
A handler for the zoom gesture occurring event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub ImageXView.ZoomGestureOccurringEventHandler( _
   ByVal sender As Object, _
   ByVal e As ZoomGestureOccurringEventArgs _
)
'Usage

Dim instance As New ImageXView.ZoomGestureOccurringEventHandler(AddressOf HandlerMethod)
public delegate void ImageXView.ZoomGestureOccurringEventHandler(
   object sender,
   ZoomGestureOccurringEventArgs e
)
public: __gc __delegate void ImageXView.ZoomGestureOccurringEventHandler(
   Object* sender,
   ZoomGestureOccurringEventArgs* e
)
public delegate void ImageXView.ZoomGestureOccurringEventHandler(
   Object^ sender,
   ZoomGestureOccurringEventArgs^ e
)

Parameters

sender
A System.Object that fired the event.
e
The ZoomGestureOccurringEventArgs which contains information about the event.
See Also

Reference

ImageXView.ZoomGestureOccurringEventHandler Members
Accusoft.ImagXpressSdk Namespace


ImagXpress.ImageStatusEventHandler Delegate

ImagXpress.ImageStatusEventHandler Delegate

Accusoft.ImagXpressSdk Namespace : ImagXpress.ImageStatusEventHandler Delegate
A System.Object that fires the event.
A ImageStatusEventArgs object.
Fires when there are image status events.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub ImagXpress.ImageStatusEventHandler( _
   ByVal sender As Object, _
   ByVal e As ImageStatusEventArgs _
)
'Usage

Dim instance As New ImagXpress.ImageStatusEventHandler(AddressOf HandlerMethod)
public delegate void ImagXpress.ImageStatusEventHandler(
   object sender,
   ImageStatusEventArgs e
)
public: __gc __delegate void ImagXpress.ImageStatusEventHandler(
   Object* sender,
   ImageStatusEventArgs* e
)
public delegate void ImagXpress.ImageStatusEventHandler(
   Object^ sender,
   ImageStatusEventArgs^ e
)

Parameters

sender
A System.Object that fires the event.
e
A ImageStatusEventArgs object.
Remarks

This event handler replaces the static ImageStatusEventHandler that was in the ImageX class.

See Also

Reference

ImagXpress.ImageStatusEventHandler Members
Accusoft.ImagXpressSdk Namespace


ImagXpress.ProgressEventHandler Delegate

ImagXpress.ProgressEventHandler Delegate

Accusoft.ImagXpressSdk Namespace : ImagXpress.ProgressEventHandler Delegate
A System.Object that fires the event.
A ProgressEventArgs object which contains information about the event that fired.
Fires when there is a progress event.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub ImagXpress.ProgressEventHandler( _
   ByVal sender As Object, _
   ByVal e As ProgressEventArgs _
)
'Usage

Dim instance As New ImagXpress.ProgressEventHandler(AddressOf HandlerMethod)
public delegate void ImagXpress.ProgressEventHandler(
   object sender,
   ProgressEventArgs e
)
public: __gc __delegate void ImagXpress.ProgressEventHandler(
   Object* sender,
   ProgressEventArgs* e
)
public delegate void ImagXpress.ProgressEventHandler(
   Object^ sender,
   ProgressEventArgs^ e
)

Parameters

sender
A System.Object that fires the event.
e
A ProgressEventArgs object which contains information about the event that fired.
Remarks

This event handler replaces the static ProgressEventHandler that was in the ImageX class.

See Also

Reference

ImagXpress.ProgressEventHandler Members
Accusoft.ImagXpressSdk Namespace


Processor.ProgressEventHandler Delegate

Processor.ProgressEventHandler Delegate

Accusoft.ImagXpressSdk Namespace : Processor.ProgressEventHandler Delegate
An System.Object that fired the event.
The ProgressEventArgs that contains information about the event.
A handler for the progress events.
Syntax
  • Visual Basic
  • C#
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub Processor.ProgressEventHandler( _
   ByVal sender As Object, _
   ByVal e As ProgressEventArgs _
)
'Usage

Dim instance As New Processor.ProgressEventHandler(AddressOf HandlerMethod)
public delegate void Processor.ProgressEventHandler(
   object sender,
   ProgressEventArgs e
)
public: __gc __delegate void Processor.ProgressEventHandler(
   Object* sender,
   ProgressEventArgs* e
)
public delegate void Processor.ProgressEventHandler(
   Object^ sender,
   ProgressEventArgs^ e
)

Parameters

sender
An System.Object that fired the event.
e
The ProgressEventArgs that contains information about the event.
See Also

Reference

Processor.ProgressEventHandler Members
Accusoft.ImagXpressSdk Namespace