%%ItemTitle%%

Accusoft.TwainPro7.Net
TwainPRO User Assistance Dashboard
Send Feedback

Glossary Item Box

Welcome

  • Overview of Product Family
    • What is The ImagXpress Product Family?
  • New Features
    • What is TwainPRO?

Getting Started

  • Operating Requirements & Installation
    • Operating Requirements
    • Upgrading from TwainPRO 6 to TwainPRO 7
    • Installing on a Development Machine
  • Licensing & Deployment
    • Licensing
    • Distributing TwainPRO
    • Software License Agreement
    • Accusoft Corporation Copyrights & Trademarks

Developer's Guide

  • User Guide

    • Concepts

      • Overview of TwainPRO
      • Overview of TWAIN
      • Supported File Formats
      • Glossary
    • How To
      • Select the DSM Version
      • Quick Start - Acquire a TWAIN Image
      • Open a TWAIN Session
      • Negotiate Capabilities
      • Acquire Images and Image Information
      • Pass Image Data between Accusoft Components
      • End a TWAIN Session
      • Debug
  • API Reference Guide
    • Accusoft.TwainPro7.Net Assembly

Additional Resources

  • White papers & Case Studies
  • FAQs, TwainPRO 7 FAQs
  • Support Overview
  • Support Plans/Agreement

Feedback

  • Tell us what you think
    • Email us
    • Take our survey

©2012. Accusoft Corporation. All Rights Reserved.


%%ItemTitle%%

TwainPRO 7 for .NET - User Guide
Send Feedback

Glossary Item Box

This User Guide provides information about the following:

  • Introduction
  • Getting Started
  • Licensing
  • Distributing Applications & Deployment
  • Concepts
  • How To


%%ItemTitle%%

Introduction
Send Feedback
TwainPRO 7 for .NET - User Guide > Introduction

Glossary Item Box

This section provides information about the following:

  • What is TwainPRO?
  • What is The ImagXpress Product Family?
  • Getting Support
  • Accusoft Corporation Copyrights & Trademarks


%%ItemTitle%%

What is TwainPRO?
See Also Send Feedback
TwainPRO 7 for .NET - User Guide > Introduction > What is TwainPRO?

Glossary Item Box

TwainPRO™ Version 7 is a windowless control that enables creation of sophisticated TWAIN compliant imaging applications.

The TwainPRO control is designed to communicate with any acquisition device that supplies a standard TWAIN device driver. This includes devices such as flatbed scanners, handheld scanners, and digital cameras.

TwainPRO supports multiple image transfers and is compliant with TWAIN v2.0.

New Features in Version 7

  • Retrieve and set the Data Source Manager version used.
  • Easily copy or transfer image data to other Accusoft components without having to manually work with DIBs (with the CopyTo() and TransferTo methods); or use the ToHdib() method for direct access to the DIB.
  • Save scanned images in PNG format.
  • Save TIFF images with embedded JPG compression.
  • Return the version/build number programmatically.
  • Use Accusoft's new licensing model.

Primary Features

  • TWAIN data source selection and image acquisition
  • Option to select data source and acquire image without TWAIN user interface
  • TWAIN capability negotiation
  • File export including: TIFF, Bitmap, JPEG, PIC and PDF (encoded as TIFF, JBIG2, Sequential JPEG)
  • FTP transfer of file exports

See Also

Getting Support
Software License Agreement
Operating Requirements


%%ItemTitle%%

What is The ImagXpress Product Family?
See Also Send Feedback
TwainPRO 7 for .NET - User Guide > Introduction > What is The ImagXpress Product Family?

Glossary Item Box

ImagXpress® Version 11 lets you quickly add the world's most trusted imaging functions to your Windows application. With our powerful imaging tools, you can quickly develop applications that require complex imaging tasks for document imaging, photo processing, or medical applications, while you concentrate on the unique needs of your program.

ImagXpress is the image handling engine behind most of our advanced recognition and image processing products. It's the fastest way to develop professional applications involving images.

The ImagXpress v11 Product Family includes the following Components:

  • ImagXpress v11 – image compression, decompression, viewing, and processing
  • NotateXpress™ v11 – image annotation support
  • ThumbnailXpress™ v4 – thumbnail image support
  • TwainPRO™ v7 – TWAIN image acquisition support
  • PrintPRO™ v6 – image printing support

ImagXpress Editions

The components within the ImagXpress v11 Product Family are available in two editions, designed to meet specific imaging needs:

  • Professional: includes ImagXpress, NotateXpress, TwainPRO, PrintPRO, and ThumbnailXpress
  • Standard: includes ImagXpress, TwainPRO, and ThumbnailXpress

Additional Accusoft Components

Additional components are available for purchase separately, and integrate easily to provide a comprehensive imaging solution:

  • ISIS® Xpress™ – ISIS image acquisition support; license sold separately
  • PDF Xpress™ – PDF creation, viewing, and annotating
  • OCR Xpress™ – full page OCR
  • Barcode Xpress™ – recognize barcodes
  • ScanFix Xpress™ – advanced image cleanup
  • FormFix™ – form ID, dropout, and OMR
  • SmartZone™ ICR / OCR – character recognition
  • ImageGear for .NET - Fully managed code to create cutting edge imaging applications
  • ImageGear for Silverlight - Comprehensive SDK for building Web imaging applications
  • ImageGear for .NET Compact Framework - Create reliable and secure imaging applications for mobile devices

See www.accusoft.com for product packaging and sales information.

See Also

Getting Support
Software License Agreement
Operating Requirements


%%ItemTitle%%

Getting Support
See Also Send Feedback
TwainPRO 7 for .NET - User Guide > Introduction > Getting Support

Glossary Item Box

For information about Accusoft Support, please refer to the Software Support and Maintenance Policy on the Accusoft web site or call Accusoft at 813-875-7575.

See Also

Operating Requirements
Installing on a Development Machine


%%ItemTitle%%

Accusoft Corporation Copyrights & Trademarks
Send Feedback
TwainPRO 7 for .NET - User Guide > Introduction > Accusoft Corporation Copyrights & Trademarks

Glossary Item Box

©1997-2012 Accusoft Corporation. All rights reserved.

Information in this document is subject to change without notice. No part of this document may be reproduced or transmitted in any form or by any means, electronic or mechanical, for any purpose, without the express written permission of Accusoft® Corporation.

This manual and the software described in it are both products of the USA.

Accusoft Corporation
4001 North Riverside Drive
Tampa, FL 33603
Sales: 813-875-7575
www.accusoft.com

Accusoft Trademarks

The following are trademarks (™) or registered marks (®) of Accusoft Corporation:

  • Accusoft®
  • Accusoft Logo™
  • Accusoft Pegasus Logo™
  • Adeptol®
  • AIMTools™
  • Barcode Xpress™
  • CapturePro™
  • Digital Mark Recognition® (DMR)
  • FolderBots™
  • FormAssist™
  • FormDirector™
  • FormFix™
  • FormSuite™
  • ImageGear® for .NET
  • ImageGear® for .NET Compact Framework
  • ImageGear® for Silverlight
  • ImageGear® Medical
  • ImageGear® Professional
  • ImageGear®
  • ImageTransport MD™
  • ImagXpress®
  • ISIS® Xpress™
    • ISIS is a registered trademark of EMC Corporation
    • ISIS Xpress is a trademark of Accusoft Corporation
  • MICR Xpress™
  • NetVue™
  • NotateXpress™
  • PDF Xpress™
  • Pegasus®
  • PICTools™
  • PICTools™ Document
  • PICTools™ Fingerprint
  • PICTools™ Medical
  • PICTools™ Photo
  • PICVideo™ M-JPEG Codec
  • PrintPRO™
  • Prizm®
  • Prizm® Viewer
  • ScanFix® Xpress™
  • SmartZone™
  • The JPEG Wizard™
  • ThumbnailXpress™
  • TwainPRO™

Accusoft and/or its agents use these marks and brand names in connection with its goods and/or services, in the United States and other countries.

Microsoft, Internet Explorer, Microsoft.NET, Silverlight, Visual Basic, Visual Studio, and Visual Studio.NET are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries.

Itanium is a registered trademark of Intel Corporation in the United States and other countries.

All other product and brand names are the property of their respective owners.


%%ItemTitle%%

Getting Started
Send Feedback
TwainPRO 7 for .NET - User Guide > Getting Started

Glossary Item Box

This section provides information about the following:

  • Operating Requirements
  • Installing on a Development Machine


%%ItemTitle%%

Operating Requirements
See Also Send Feedback
TwainPRO 7 for .NET - User Guide > Getting Started > Operating Requirements

Glossary Item Box

Operating Systems

TwainPRO™ runs on supported Microsoft Operating Systems:

  • Windows XP, XP Professional
  • Windows Vista
  • Windows 7
  • Windows Server 2003
  • Windows Server 2008
TwainPRO runs in 64-bit, 32-bit, and AnyCPU-compiled executables.

Threading

Accusoft considers thread-safe to be when an application using this component can use multiple controls running in the same process, where they don't interfere with each other. The thread creating the control owns the control and is the only thread that can interact with it.

Development Environment

  • Microsoft .NET Framework 2.0, 3.0
  • Microsoft Visual Studio 2005
  • Microsoft Visual Studio 2008

See Also

Getting Support
Installing on a Development Machine


%%ItemTitle%%

Installing on a Development Machine
See Also Send Feedback
TwainPRO 7 for .NET - User Guide > Getting Started > Installing on a Development Machine

Glossary Item Box

To Install TwainPRO™

Run the downloaded setup program which installs the development kit on your development machine.

The downloaded development kit includes code samples for supported platforms. Samples are available through the Start | Programs | Accusoft | TwainPRO 7 menu.

By default this will register trial licensing which allows you to develop applications but not to distribute them. The trial license allows testing of all the functions and features.

Please see the section Distributing TwainPRO to understand the limits and details to convert licensing editions.
In order to distribute your finished application you must purchase and install a fully paid license from Accusoft. The paid licenses override trial licenses.

To Use TwainPRO Help Files

Once you have installed TwainPRO, you will have access to the following stand-alone help file:

  • Accusoft.TwainPro7.Net.chm

    Access the TwainPro stand-alone help through the Windows Start menu: Start | Programs | Accusoft | TwainPRO 7

In addition, you will have access to the following compiled collection help file, depending on which version of Visual Studio you have installed:

  • Accusoft.TwainPro7.Net.hxs - Help 2 collection files. If you have Visual Studio 2005 or 2008, these Help 2 files will be registered.
  • AccusoftTwainPro7_Net.cab - MHV (Microsoft Help Viewer). If you have Visual Studio 2010, these MHV files will be registered.

Plugging TwainPro Help into Visual Studio

TwainPro Help 2 files integrate within the Help system in Visual Studio .NET automatically if Visual Studio was installed prior to installing TwainPRO. To access TwainPRO Help within Visual Studio, do the following:

  • Ensure that the MSDN Library is installed in your Visual Studio environment. If it is not installed, re-install it from your VS.NET disc.
  • Ensure that MS Help Integration Kit is installed in your Visual Studio environment. If you do not have it installed:
  1. Download the Help Integration kit from MSDN.
  2. Close Visual Studio.
  • Re-open Visual Studio, select the Help Menu and the Contents submenu. Verify Help files for Accusoft controls are listed.

If Accusoft Help is not listed:

  1. Search for "VSCC" in Visual Studio Help, leaving the "Filtered by:" list box blank. Select the "Visual Studio .NET Combined Help Collection Manager" topic.
  2. Select the Help 2 collections available on your PC under the heading "Collections available for inclusion in VSCC."
  3. Take care when excluding Help collections from the default VSCC collection. These collections may be necessary to view required documentation. Instead, use the "Filtered by:" field on the Contents tab of the Help panel to focus searches on Accusoft topics. Leave the "Filtered by:" list box empty to view the entire Accusoft Help files.
  4. Select the Update VSCC button.
  5. Close all instances of Visual Studio and Microsoft Document Explorer. When you restart Visual Studio, the VSCC Help collection revises with your changes. (Note: this may take several minutes.)
  6. Check the Visual Studio Help/Contents tab again to see the Help collections available to you.
  • Select the TwainPro Help file to view Help content.

See Also

Operating Requirements
Software License Agreement
Distributing TwainPRO

Licensing
Licensing


%%ItemTitle%%

Upgrading from TwainPRO 6 to TwainPRO 7
Send Feedback
TwainPRO 7 for .NET - User Guide > Getting Started > Upgrading from TwainPRO 6 to TwainPRO 7

Glossary Item Box

This section describes how to upgrade from TwainPro 6 to TwainPro 7. While generally you'll be able to replace TwainPro 6 with TwainPro 7, there are a few important changes you may need to consider. This section provides information about those changes.

Changes and New Properties/Methods

  • The AdvancedCapabilityConstants enumeration has been split into separate enumerations such as AdvancedCapabilityLightSource, AdvancedCapabilityLightPath, AdvancedCapabilityPixelFlavor, etc. This was done because the same values were repeated for different enumerations. The way the capabilities were previously defined made it necessary to write overly complex code to use them.
  • SaveStream() of the ScannedImage class has been marked as deprecated. Users should use SaveToStream() to save the TwainPro-compressed image to a stream or SaveSourceCompressedImageToStream() to save the Source-compressed image to a stream instead.
  • SaveFile() overloads of the ScannedImage class have been marked as deprecated. User should use SaveToFile() to save the TwainPro-compressed image to a file or SaveSourceCompressedImageToFile() to save the source-compressed image to a file instead.
  • A new property DataSourceManagerVersion has been added to the TwainDevice class. The default value of LatestSupportedVersionAvailable means that TwainPro will attempt to load the latest available Twain DSM (Data Source Manager), if that fails it will load the older version automatically. Or you can specify to load only the TWAIN 2.x DSM or only the TWAIN 1.x DSM. In the prior release of Twain Pro (v6), it only loaded the TWAIN 2.x DSM and failed if not found. The TWAIN DSMcan be downloaded from http://www.twain.org.
  • A new property DataSourceManagerVersionInUse has been added to the TwainDevice class.
  • The ability to save the scanned image to the PNG format has been added along with options to the SaveOptions class.
  • A new method SaveToFile() has been added to the ScannedImage class, this allows users to save the TwainPro-compressed image to a file with or without SaveOptions, depending on the overload chosen.
  • A new method SaveToStream() has been added to the ScannedImage class, this allows the user to save the TwainPro-compressed image to a System.IO.Stream.
  • A new method SaveSourceCompressedImageToStream() has been added to the ScannedImage class, this allows users to save the Source-compressed image to a System.IO.Stream.
  • A new method SaveSourceCompressedImageToFile() has been added to the ScannedImage class, this allows users to save the Source-compressed image to a file.
  • JPEG7 added to the TiffCompression enumeration.
  • JpegSubSampling, JpegChrominance, and JpegLuminance added to the SaveOptionsTiff class.
  • A set accessor has been added to the CapabilityContainerRange class to allow the Step property to be set.
  • Added Version property to the TwainPro class.
  • Easily copy or transfer image data to other Accusoft components without having to manually work with DIBs (with the CopyTo() and TransferTo methods); or use the ToHdib() method for direct access to the DIB.
  • Added Accusoft's new licensing structure to the ImagXpress 11 Product Family. See Licensing for information about the new licensing, and Upgrading Runtime Licensing for information about updating your licensing from an earlier version of TwainPRO.

If you encounter any porting issues, please contact support@accusoft.com for assistance.


%%ItemTitle%%

Upgrading Runtime Licensing
Send Feedback
TwainPRO 7 for .NET - User Guide > Getting Started > Upgrading Runtime Licensing

Glossary Item Box

This section describes how to upgrade to Accusoft's new Runtime Licensing.

Prior to TwainPRO 7, runtime licensing was accomplished using the UnlockRuntime method.

In TwainPRO 7, the default licensing model is Automatically Reported Runtime Licensing. However, based on your contracted usage of this software, you may be eligible for Manually Reported Runtime Licensing. Your Accusoft Sales Representative (sales@accusoft.com) can help you determine which model is appropriate.

Refer to the following sections for information about upgrading to the new Runtime Licensing models:

  • Upgrading to Automatically Reported Runtime Licensing
  • Upgrading to Manually Reported Runtime Licensing

Upgrading to Automatically Reported Runtime Licensing

Automatically Reported Runtime Licensing requires a license to be installed on the end-user's machine. See the Licensing section for more information.

In your TwainPRO 6 codebase, find any existing calls to the UnlockRuntime method.

C# Copy Code
 TwainPro1.Licensing.UnlockRuntime(12345,12345,12345,12345);
VB.NET Copy Code
 TwainPro1.Licensing.UnlockRuntime(12345,12345,12345,12345)

In your TwainPRO 7 codebase, replace the UnlockRuntime method with calls to the SetSolutionName and SetSolutionKey methods.

C# Copy Code
 TwainPro1.Licensing.SetSolutionName("YourSolutionName");
 TwainPro1.Licensing.SetSolutionKey(12345,12345,12345,12345);
VB.NET Copy Code
 TwainPro1.Licensing.SetSolutionName("YourSolutionName")
 TwainPro1.Licensing.SetSolutionKey(12345,12345,12345,12345)

Upgrading to Manually Reported Runtime Licensing

In your TwainPRO 6 codebase, find any existing calls to the UnlockRuntime method.

C# Copy Code
 TwainPro1.Licensing.UnlockRuntime(12345,12345,12345,12345);
VB.NET Copy Code
 TwainPro1.Licensing.UnlockRuntime(12345,12345,12345,12345)

In your TwainPRO 7 codebase, replace the UnlockRuntime method with calls to the SetSolutionName, SetSolutionKey, and SetOEMLicenseKey methods.

C# Copy Code
 TwainPro1.Licensing.SetSolutionName("YourSolutionName");
 TwainPro1.Licensing.SetSolutionKey(12345,12345,12345,12345);
 TwainPro1.Licensing.SetOEMLicenseKey("1.0.AStringForOEMLicensing…");
VB.NET Copy Code
 TwainPro1.Licensing.SetSolutionName("YourSolutionName")
 TwainPro1.Licensing.SetSolutionKey(12345,12345,12345,12345)
 TwainPro1.Licensing.SetOEMLicenseKey("1.0.AStringForOEMLicensing…")

There is no longer a separate method for web licensing. That functionality has been integrated into the SetOEMLicenseKey method.

If you encounter any porting issues, please contact support@accusoft.com for assistance.


%%ItemTitle%%

Licensing
See Also Send Feedback
TwainPRO 7 for .NET - User Guide > Licensing

Glossary Item Box

Accusoft has introduced a new licensing structure, which provides the following benefits:

  • Toolkit Licensing (also known as Developer or SDK licensing) has been simplified, no longer requiring manual entry of license registration codes.
  • Runtime Licensing (also known as Deployment licensing) has been made more flexible, enabling support for a number of different deployment scenarios.

During evaluation of Accusoft products, Evaluation Toolkit licenses can be used to try out products. However, the product behavior is limited by trial dialog pop-ups, timeouts, or evaluation watermarks.

Accusoft requires customers to purchase licenses for both development and deployment.

  • Development/Toolkit Licensing: When you determine the product is a good fit, you can purchase a Toolkit license to eliminate trial dialog pop-ups, timeouts, and evaluation watermarks while you develop your application.
  • Deployment/Runtime Licensing: Once you have an application that is ready for distribution, you have several options for deployment. Your own deployment scenario will dictate which option is the most appropriate. There are also cost considerations for each licensing model; see the product's "pricing" page or speak with an Accusoft Sales Representative (sales@accusoft.com) for more information.
    • Manually Reported Runtime Licensing: In this model, you embed all of the licensing information directly into your application. You must manually provide royalty reporting to Accusoft for the actual licenses deployed. This model will be the best choice for you if you are not connected to the Internet at runtime, as might be the case in an defense or financial application.
    • Automatically Reported Runtime Licensing using the Server Licensing Utility (SLU): In this model, you run a small GUI tool one time on each deployment target to configure licensing. This model will be the best choice for you if you handle the deployments yourself.
    • Automatically Reported Runtime Licensing using the Licensing Development Kit (LDK): In this model, you embed function calls into your application that perform the license verification at runtime. This model will be the best choice for you if you wish to hide licensing from your end users.

See Also

Licensing Glossary


%%ItemTitle%%

Evaluation Licensing
Send Feedback
TwainPRO 7 for .NET - User Guide > Licensing > Evaluation Licensing

Glossary Item Box

During evaluation of Accusoft products, Evaluation Toolkit licenses can be used to try out products. However, the product behavior is limited by trial dialog pop-ups, timeouts, or evaluation watermarks. When you determine the product is a good fit, you can purchase a Toolkit license to eliminate trial dialog pop-ups, timeouts, and evaluation watermarks.

An evaluation dialog similar to the following is displayed when you have a valid evaluation license.

However, if you attempt to execute a function that is not licensed in the edition license you are using (e.g., if you have a paid license for ImagXpress Standard and attempt to execute a function available only in ImagXpress Professional), an evaluation dialog similar to the following is displayed.

If no license is found in the registry, a dialog similar to the following will be displayed.


%%ItemTitle%%

Toolkit Licensing
Send Feedback
TwainPRO 7 for .NET - User Guide > Licensing > Toolkit Licensing

Glossary Item Box

Accusoft requires customers who are developing code that uses Accusoft components to have a Toolkit license for each developer.

This section provides information about the following:

  • Assigned Toolkit License
  • License Manager
  • Product Editions
  • Registration
    • Registering When Connected to the Internet
    • Registering When Disconnected from the Internet
  • Developing Code


%%ItemTitle%%

Assigned Toolkit License
Send Feedback
TwainPRO 7 for .NET - User Guide > Licensing > Toolkit Licensing > Assigned Toolkit License

Glossary Item Box

When licenses are purchased for developers at an organization, a representative is designated to assign the licenses to developers at the organization. Each developer must create an account on Accusoft’s website prior to the assignment of licenses. The organization’s designated representative may request that licenses be reassigned as a result of personnel changes.


%%ItemTitle%%

License Manager
Send Feedback
TwainPRO 7 for .NET - User Guide > Licensing > Toolkit Licensing > License Manager

Glossary Item Box

The License Manager is a GUI application that is used by a developer to register and activate Toolkit licenses on their development system. When a paid Toolkit license is registered, the License Manager:

  • Communicates the developer's credentials and the hardware information for the development system to the licensing web service.
  • Installs the returned license key on that system.

Activation involves choosing a Toolkit license, either evaluation or paid, so that the license is active on the system.


%%ItemTitle%%

Product Editions
Send Feedback
TwainPRO 7 for .NET - User Guide > Licensing > Toolkit Licensing > Product Editions

Glossary Item Box

Accusoft products may have multiple editions, each of which supports different features. Products that support multiple editions are installed with multiple evaluation Toolkit licenses, one evaluation Toolkit license per edition.

Selecting An Edition (Activating a Toolkit License)

Evaluation licenses allow developers to try features in different product editions. Since each license supports only a single edition of a product, the developer can switch between editions by activating the corresponding Toolkit license, either purchased or evaluation, using the License Manager.

When a customer downloads an evaluation Toolkit, the evaluation Toolkit license for the edition with the most features is installed by default. However, the developer may run the License Manager to change the Toolkit license to a lower edition in order to determine if that edition will serve their needs.

If a customer has purchased multiple editions of the same product, they may install both editions on a development system, but only one edition may be active at a time. Once a license has been activated for a particular system, it may be deactivated (replaced by activating another edition) or reactivated at any time. Similarly, customers who own a lower featured edition may activate a higher featured edition evaluation Toolkit license and then switch back to their paid, lower-featured Toolkit edition license at any time. For example, you can go from a paid Standard edition to an evaluation Professional edition by activating the Professional edition evaluation Toolkit license.


%%ItemTitle%%

Registration
Send Feedback
TwainPRO 7 for .NET - User Guide > Licensing > Toolkit Licensing > Registration

Glossary Item Box

Registration is the process of creating a paid Toolkit license key for a particular system. Registration for Toolkit licenses is always done through the License Manager. This enables the features for the purchased edition to operate without nag dialogs or watermarks. Registration for each license is only required to be performed once per development system. After a license has been registered on a system, you can use the license without further interaction with the License Manager.

Also refer to the following sections:

  • Registering When Connected to the Internet
  • Registering When Disconnected from the Internet


%%ItemTitle%%

Registering When Connected to the Internet
Send Feedback
TwainPRO 7 for .NET - User Guide > Licensing > Toolkit Licensing > Registration > Registering When Connected to the Internet

Glossary Item Box

When the development system is connected to the Internet, registration is a fairly simple process.

  1. Start the License Manager.
  2. When prompted, enter your Accusoft login and password.

    The License Manager then displays the available evaluation and purchased licenses assigned to you.

  3. Select a toolkit and click the link to activate the license for that toolkit.

    The License Manager then requests a new license key from the licensing web service and installs it; this completes the registration process.

    If the selected license cannot be installed on the development system due to connection failures or other reasons, a temporary, 15 day "grace" license is installed so as not to interrupt development while a new license is obtained for the development system.


%%ItemTitle%%

Registering When Disconnected from the Internet
Send Feedback
TwainPRO 7 for .NET - User Guide > Licensing > Toolkit Licensing > Registration > Registering When Disconnected from the Internet

Glossary Item Box

When the development system is not connected to the Internet during registration, as is the case in some defense or financial institutions, registration is only slightly less simple.

  1. Run the License Manager and attempt to log in.
    The License Manager detects that the system is not registered and displays the following dialog:

  2. Select the Install Offline option to begin the offline registration process.

  3. Copy the URL to removable media, such as a thumb drive.

  4. Take the thumb drive to a system that is connected to the Internet.
  5. From the connected system, paste the URL into a browser, which automatically displays the toolkits available.
  6. Upon selecting a toolkit, a license is generated, which you then save to the removable media device.
  7. Return to the offline system where the new license is to be installed.
  8. Use the License Manager to browse to the file and install the Toolkit license.


%%ItemTitle%%

Developing Code
Send Feedback
TwainPRO 7 for .NET - User Guide > Licensing > Toolkit Licensing > Developing Code

Glossary Item Box

Once an evaluation or paid Toolkit license has been activated on the development system, no additional code is required to use the Accusoft products on this system. If moving the resulting executable code to a new system, you will need to install Toolkit licenses or incorporate Runtime licenses into your code.


%%ItemTitle%%

Runtime Licensing
Send Feedback
TwainPRO 7 for .NET - User Guide > Licensing > Runtime Licensing

Glossary Item Box

When an application that uses one or more Accusoft products is deployed, it requires a Runtime License for each installation. There are two main types of Runtime Licenses:

  • Automatically Reported. Distribution of Automatically Reported Runtime licenses is handled automatically through the use of licensing software components and web services.
  • Manually Reported. Manually Reported Runtime licensing requires you to provide the number of licenses distributed on a contractually agreed upon basis.

These licensing types are each described in detail in the following sections:

  • Automatically Reported Runtime (Node-Locked)
    • Licensing API
    • License Pools
    • License Configuration Files
    • LDK vs. SLU
      • Server Licensing Utility (SLU)
      • Licensing Development Kit (LDK)
    • Deployment Proxy Service (DPS)
  • Manually Reported Runtime (Non-Node-Locked)
    • Solution Name
    • Solution Key
    • OEM License Key
If you are upgrading from an earlier version of TwainPRO, please see the Upgrading Runtime Licensing section for important information.


%%ItemTitle%%

Automatically Reported Runtime (Node-Locked)
Send Feedback
TwainPRO 7 for .NET - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked)

Glossary Item Box

Automatically Reported Runtime licenses use a mechanism similar to Toolkit licensing to activate a license for a particular system. In this case, each installation has a unique license that is pulled from the pool of licenses purchased by the customer. When the license key is generated, it contains hardware information that identifies the system on which the license is to be installed.

The Licensing Development Kit component, which interacts with the licensing web service and installs the newly generated license key, may be used directly by the application or it may be used through a simple tool known as the Server Licensing Utility.

  • The Licensing Development Kit requires integration with the application or installation utility to perform license activation.
  • The Server Licensing Utility is a stand-alone application that integrates the Licensing Development Kit to perform the registration.

This topic provides information about the following:

  • Licensing API
  • License Pools
  • License Configuration Files
  • LDK vs. SLU
    • Server Licensing Utility (SLU)
    • Licensing Development Kit (LDK)
  • Deployment Proxy Service (DPS)


%%ItemTitle%%

Licensing API
Send Feedback
TwainPRO 7 for .NET - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > Licensing API

Glossary Item Box

The Licensing API is used in the developer’s code to specify Runtime Licensing deployment information. This is used to unlock the Accusoft products and enable all licensed features at runtime. Both the "Solution Name" and "Solution Key" values used in the API described below are provided by Accusoft, along with the License Configuration file, at the time of purchase of a Runtime License.

Solution Name

The solution name is the name assigned by Accusoft to the licenses purchased for runtime deployment. It is a character string that is set for a component prior to use in a deployment environment and is typically the name of the organization that purchased the runtime licenses. It is set via the SetSolutionName method of the component’s Licensing class. For example:

Copy Code
TwainPro tp = new TwainPro();
tp.Licensing.SetSolutionName("ACMEImaging");

The Solution Name must be set in order to use runtime licensing.

Solution Key

The Solution Key is a set of four numbers assigned when the licenses are purchased for runtime deployment; the Solution Key also identifies the organization that purchased the runtime licenses. The Solution Key is set via the SetSolutionKey method of the component’s Licensing class. For example:

Copy Code
TwainPro tp = new TwainPro();
tp.Licensing.SetSolutionName("ACMEImaging");
tp.Licensing.SetSolutionKey(0x1C3A023F, 0xA018F260, 0x37AF0E51, 0x557F2389);

The Solution Key must be set in order to use runtime licensing.


%%ItemTitle%%

License Pools
Send Feedback
TwainPRO 7 for .NET - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > License Pools

Glossary Item Box

When Automatically Reported Runtime licenses are purchased, they are organized into pools of a specific version and platform for a particular toolkit. For example, if a customer developed two applications using ImagXpress, one using 32-bit ActiveX and the other using .NET, they would purchase two pools of runtime licenses, one for the ActiveX platform and one for the .NET platform. At installation, a new license would be pulled from the appropriate pool, depending upon which platform the application is using.


%%ItemTitle%%

License Configuration Files
See Also Send Feedback
TwainPRO 7 for .NET - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > License Configuration Files

Glossary Item Box

When an Automatically Reported Runtime license is purchased, a License Configuration file is created and distributed to the customer along with their assigned Solution Name and Solution Key. The License Configuration file contains information about the Runtime licenses for a particular platform and version of a toolkit. It is used by the Server Licensing Utility or License Development Kit to activate licenses when the customer’s application is installed on their users' systems.

See Also

Licensing API


%%ItemTitle%%

LDK vs. SLU
Send Feedback
TwainPRO 7 for .NET - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > LDK vs. SLU

Glossary Item Box

Both the Licensing Deployment Kit and the Server Licensing Utility perform the same function of registering the Runtime license for the system on which it will be run. Both are provided in order to give you some options.

  • If you are deploying to your own systems (e.g., for enterprise IT staff), the use of an Accusoft branded Server Licensing Utility may meet your needs. Similarly, if you handle the deployment onto end users systems, you may also find the Server Licensing Utility to be sufficient.
  • If you wish to hide this licensing registration from end users, you will likely choose the Licensing Deployment Kit, which allows you to integrate the registration process into your application. The Licensing Deployment Kit also allows for the optional assignment of Access Keys to specific users, which lets you manage your licenses more directly and limits the distribution of licenses.


%%ItemTitle%%

Server Licensing Utility (SLU)
Send Feedback
TwainPRO 7 for .NET - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > LDK vs. SLU > Server Licensing Utility (SLU)

Glossary Item Box

The Server Licensing Utility is a simple Windows application that uses License Configuration Files to request a license key from the purchased Runtime licenses. The Server Licensing Utility registers that Runtime license on the system where your application will be running. This utility can be used by developers for testing, by your deployment team, or by your end users to register their Runtime license.

In the Server Licensing Utility dialog, add your License Configuration file(s) as follows:

  1. Click Add and navigate to your License Configuration file(s).
  2. Select the appropriate License Configuration file(s) and click Open.
  3. After all applicable License Configuration files have been added, click Auto Register or Manually Register, depending on whether or not you are connected to the Internet. Refer to the sections below for more information.

Auto Register Toolkit (Connected to Internet)

Automatic registration works in much the same way as connected Toolkit registration and requires an Internet connection on the system where your application software will be deployed. The license information along with the system’s hardware information is sent over the Internet to the Accusoft licensing web service. If an unused license is available, a new license key containing information for the system is generated, returned, and is then automatically installed by the Server Licensing Utility.

Manually Register Toolkit (Disconnected from Internet)

Manual registration is used when the system where your application software will be deployed is not connected to the Internet and therefore cannot be registered automatically. This operation is similar to Disconnected Registration with the License Manager.

  1. Copy the Hardware Key and URL to a removable media device, such as a thumb drive, and then take it to a system that is connected to the Internet.
  2. From the connected system, paste the URL into a browser. A page will appear that contains a field into which you enter the hardware key.
  3. After this hardware key is entered, a license file with the license key is downloaded, which you then save to the removable media device.
  4. Return to the offline system with the removable media device onto which you have saved the license file.
  5. Click Open License File and navigate to the license file. Click OK in the file selection dialog.
    Alternatively, you can open the license file with a text editor, copy the license key to the clipboard, and click Paste License Key to paste the new license key into the License Key field.
  6. Click the License button; the new license will be installed.


%%ItemTitle%%

Licensing Development Kit (LDK)
Send Feedback
TwainPRO 7 for .NET - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > LDK vs. SLU > Licensing Development Kit (LDK)

Glossary Item Box

The Licensing Development Kit is an ActiveX component that may be used instead of the Server Licensing Utility. (Actually, the Server Licensing Utility is only a user interface for the Licensing Development Kit.) The Licensing Development Kit provides an interface for a developer to set the License Configuration File path and other properties as well as initiate requests to the licensing web service to generate license keys.

This topic contains these sections:

  • AccuLicClient.DLL
  • Assigned Access Keys
  • Automatic (Connected) Mode Registration
  • Manual (Disconnected) Mode Registration
  • Evaluation
  • Licensing Development Kit Interface
  • Licensing Development Kit Properties
  • Licensing Development Kit Methods

AccuLicClient.DLL

The AccuLicClient.DLL is located with the Server Licensing Utility. It is a 32-bit ActiveX/COM DLL which is used to execute runtime licensing activation functions. The bulk of the functionality provided by the Server Licensing Utility (SLU) is contained within the AccuLicClient.DLL and can be used within your own custom applications to achieve the same thing.

Assigned Access Keys

Unlike the Server Licensing Utility, the Licensing Development Kit allows for the optional assignment of Access Keys to specific users. By doing this, you can specify which of your licenses are assigned to your users. This also limits the distribution of licenses. When Runtime licenses are purchased, a list of Access Keys is distributed to you for this use.

Automatic (Connected) Mode Registration

This mode corresponds to the Automatic (Connected) Registration section described in the Server Licensing Utility section. The process is shown in the C# sample code below:

Copy Code
// Instantiate the LDK ActiveX component
IDeploymentComponent ldk = new DeploymentComponent();

// Set the path to the configuration file provided
// when the runtime licenses were purchased.
ldk.ConfigPath = @"C:\config.txt";

// Attempt to get the next available license.
// Note that you may alternately pass an Access Key
ldk.GetLicKeyAuto("");

if (ldk.ResultCode != enumLdkErrorCodes.LDK_SUCCESS)
{
    // Automatic Registration Failed - A temporary license
    // has been installed but will expire in 15 days.
    // TODO add code to notify user of issue and 15 day expiration.

    if (ldk.ResultCode == enumLdkErrorCodes.LDK_ERR_INET_CONN_BROKEN)
    {
        // No Internet Connection – Optionally do manual registration
    }
}
else
{
    // The license has been registered and installed.
}

The registration process is then complete. If any part of the registration process fails, a temporary license key is installed and is typically valid for 15 days. During this time, you are allowed to use the product while resolving any licensing related problems.

Manual (Disconnected) Mode Registration

This mode corresponds to the Manual (Disconnected) Registration section described in the Server Licensing Utility section. The process is shown in the C# code below:

Copy Code
// Instantiate the LDK ActiveX component
IDeploymentComponent ldk = new DeploymentComponent();

// Set the path to the configuration file provided
// when the runtime licenses were purchased.
ldk.ConfigPath = @"C:\config.txt";

// Get the hardware key for the system.  Note
// that you may alternately pass an Access Key
string hardwareKey = ldk.GetHdwKey("");

// Write the hardware key to some type of removable media.
ApplicationSpecificMethodToWriteHardwareKey(hardwareKey);

At this point, you have the hardware key on some type of removable media. Take the media to a system that is connected to the Internet, acquire the license key by uploading the hardware key, write the new license key to the removable media, and then return to the disconnected system. The application then reads the license key from the removable media and installs the license key as shown below.

Copy Code
// After taking the hardware key to a system with an Internet
// connection and acquiring the license key string from the
// manual registration web site, read the key into your
// application.
string manuallyAcquiredLicenseKey = ApplicationSpecificMethodToReadLicenseKey();

// Install the license key
ldk.LicKey = manuallyAcquiredLicenseKey;

The manual license registration and installation is then complete. Like the automatic case above, if any error occurs during the setting of the license key, a temporary license is installed.

Evaluation

The Licensing Development Kit also has the ability to install an Evaluation License for purchased runtime products. This process is simply:

Copy Code
// Instantiate the LDK ActiveX component
IDeploymentComponent ldk = new DeploymentComponent();

// Set the path to the configuration file provided
// when the runtime licenses were purchased.
ldk.ConfigPath = @"C:\config.txt";

// Install an evaluation license
ldk.StartEvalPeriod();

Licensing Development Kit Interface

The interface to the Licensing Development Kit is shown below:

Copy Code
interface IDeploymentComponent : IDispatch
{
   [propget, id(1)] HRESULT LicKey([out, retval] BSTR* pVal);
   [propput, id(1)] HRESULT LicKey([in] BSTR newVal);
   [propget, id(2)] HRESULT srvURL([out, retval] BSTR* pVal);
   [propput, id(2)] HRESULT srvURL([in] BSTR newVal);
   [propget, id(3)] HRESULT ConfigPath([out, retval] BSTR* pVal);
   [propput, id(3)] HRESULT ConfigPath([in] BSTR newVal);
   [propget, id(4)] HRESULT ResultString([out, retval] BSTR* pVal);
   [propget, id(5)] HRESULT ResultCode([out, retval] enumLdkErrorCodes* pVal);
   [id(6)]           HRESULT GetLicKeyAuto([in] BSTR accKey);
   [id(7)]           HRESULT GetHdwKey([in] BSTR accKey, [out,retval] BSTR* hdwKey);
   [id(8)]           HRESULT StartEvalPeriod(void);
   [propget]         HRESULT LicenseInfo([out, retval] BSTR* pVal);
   [propput]         HRESULT LicenseInfo([in] BSTR newVal);
   [id(10)]          HRESULT GetEvalPeriod([out, retval] long* pVal);
};

Licensing Development Kit Properties

  • LicKey: Stores the License Key to the registry when it is set, and reads it from the registry during the get operation.
  • srvURL: Gets and sets the URL path to the licensing web service. The default is the URL path to Accusoft’s Deployment Licensing Service.
  • ConfigPath: Gets and sets a path to the deployment configuration file. Multiple products can be registered at one time by setting the filenames as a semicolon-delimited list: e.g., “c:\config.txt;c:\config2.txt”.
  • ResultString: Contains the string descriptions of any error that may have occurred during the last operation.
  • ResultCode: Can be used to contain any of the error codes described in Licensing Component Error Codes and Messages.
  • LicenseInfo: Used to transfer license information onto new system hardware. To transfer the license information into new system hardware, do the following:
  1. Get the LicenseInfo value and store it in a safe place.
  2. Change the system hardware.
  3. Set the LicenseInfo to the value you saved in step (1).
  4. Run the GetLicKeyAuto method (or perform its manual analog) to obtain a license for the new system hardware.

Licensing Development Kit Methods

  • GetLicKeyAuto: Obtains a License Key for the end user’s system using the automatic (or connected) scenario. It takes an Access Key as its input parameter, and stores the obtained license key in the registry. If you choose not to distribute individual Access Keys, the accKey argument should be an empty string.
  • GetHdwKey: Obtains a hardware key from the current machine and returns it (as hdwKey). If you choose not to distribute individual access keys, the accKey argument should be an empty string.
  • StartEvalPeriod: Sets an evaluation licensing mode for the product and starts an evaluation period. This method is provided so you can distribute an evaluation version of your application, without having to distribute Access Keys to people who would like to evaluate your software. Using this method you can license Accusoft components on the end user’s system for a limited time – the default is 30 days, but it can be customized per request to Accusoft. If the evaluators purchase your software, you can then issue them an access key using either the automatic or manual scenarios to obtain permanent component licenses, just as Accusoft does for its evaluators.
  • GetEvalPeriod: Obtains the remaining time on an evaluation (in days). It returns EvalPeriod < 0 if the evaluation period is expired.


%%ItemTitle%%

Deployment Proxy Service (DPS)
Send Feedback
TwainPRO 7 for .NET - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > Deployment Proxy Service (DPS)

Glossary Item Box

For systems where the deployed application will not have direct access to the Accusoft licensing web services, you can use the Deployment Proxy Service as a bridge to reroute the licensing communication. The Proxy Service will act as a trusted "go-between" for the Accusoft licensing system and the deployed application. This tool can be useful if the application will be deployed in a secured environment, where limited systems have external network access.

Additionally, the Proxy Service allows Accusoft customers to manage license registration more directly. The source for the Deployment Proxy Service is provided, allowing users to integrate the licensing process into their CRM, ERP, or other systems for tracking Automatically Reported Runtime Licenses.

For more information about the Deployment Proxy Service, please contact our Support team.


%%ItemTitle%%

Manually Reported Runtime (Non-Node-Locked)
Send Feedback
TwainPRO 7 for .NET - User Guide > Licensing > Runtime Licensing > Manually Reported Runtime (Non-Node-Locked)

Glossary Item Box

Manually Reported Runtime licensing embeds all of the licensing information directly into your application. Installation does not require any further licensing interaction. However, it is your responsibility to provide royalty reporting to Accusoft for the actual licenses deployed.

This section provides information about the following:

  • Solution Name
  • Solution Key
  • OEM License Key


%%ItemTitle%%

Solution Name
Send Feedback
TwainPRO 7 for .NET - User Guide > Licensing > Runtime Licensing > Manually Reported Runtime (Non-Node-Locked) > Solution Name

Glossary Item Box

The solution name is

  • A name assigned by Accusoft to the licenses purchased for runtime deployment.
  • A character string that is set for a component prior to use in a deployment environment.
  • Typically the name of the organization that purchased the runtime licenses.
  • Set via the SetSolutionName method of the component’s Licensing class. For example:
Copy Code
TwainPro tp = new TwainPro();
tp.Licensing.SetSolutionName("ACMEImaging");

The Solution Name must be set in order to use runtime licensing.


%%ItemTitle%%

Solution Key
Send Feedback
TwainPRO 7 for .NET - User Guide > Licensing > Runtime Licensing > Manually Reported Runtime (Non-Node-Locked) > Solution Key

Glossary Item Box

The Solution Key is

  • A set of four numbers assigned when the licenses are purchased for runtime deployment.
  • An identifier of the organization that purchased the runtime licenses.
  • Set via the SetSolutionKey method of the component’s Licensing class. For example:
Copy Code
TwainPro tp = new TwainPro();
tp.Licensing.SetSolutionName("ACMEImaging");
tp.Licensing.SetSolutionKey(0x1C3A023F, 0xA018F260, 0x37AF0E51, 0x557F2389);

The Solution Key must be set in order to use runtime licensing.


%%ItemTitle%%

OEM License Key
Send Feedback
TwainPRO 7 for .NET - User Guide > Licensing > Runtime Licensing > Manually Reported Runtime (Non-Node-Locked) > OEM License Key

Glossary Item Box

  • For use only by customers who choose to use Manually Reported Runtime licensing.
  • A unique identifier of the customer, product, version, edition, and platforms for which the license is valid.

When this key is set via the SetOEMLicenseKey method of the component’s Licensing class, the component is completely licensed and can be distributed without any further licensing operations.

Copy Code
TwainPro tp = new TwainPro();
tp.Licensing.SetSolutionName("ACMEImaging");
tp.Licensing.SetSolutionKey(0x1C3A023F, 0xA018F260, 0x37AF0E51, 0x557F2389);
tp.Licensing.SetOEMLicenseKey("1.0.GQCC0EmUgONaI4QDZ32tpGWfpGW4gtbC0iIC0iN4bigYM3m3K5b487QOsAM38O24mUp5bOpD2O240OQ32U2YsUKDKA87MYPGgGgaptMiK5Nv8AI4mYg4m3QvW52DZCPGs4p784mtP4IUgOWiIG0AQYp4052iIAWvNCZfpGWC8vQ5P4ZGKaPAWfbiYfZOI303pOZAgisiNaWA27gGsf8Ob7Zvm5IaKGI4KC8GsG2CWYpGQAg5sUmYWvZCQANig48G2ap4bG0DsO240YsUmtptNiZamCPGbYMfMO83gANAZCN52YbY8U8f8DM4m3g7MYMYWGW5Q7QGWaMiN7MtZfmtgY8AN7NDP7Z4W7sCbGKUPa0im7EDPP");

This property is not required for Automatically Reported Runtime licensing.


%%ItemTitle%%

Licensing Glossary
Send Feedback
TwainPRO 7 for .NET - User Guide > Licensing > Licensing Glossary

Glossary Item Box

The following sections each describe a licensing term:

  • Access Key
  • Accusoft Products
  • Activation
  • Assigned Access Key
  • Automatically Reported Runtime Licensing
  • Customers, Developers, and Users
  • Edition
  • Evaluation License
  • Hardware Key
  • License Configuration File
  • Licensing Development Kit (LDK)
  • License Key
  • License Manager
  • Manually Reported Runtime Licensing
  • Node-Locked Licensing
  • Non-Node-Locked Licensing
  • Paid License
  • Registration
  • Runtime (Deployment) Licensing
  • Server Licensing Utility (SLU)
  • Toolkit Licensing
  • Web Services

Access Key

All licenses are assigned a unique identifier known as an Access Key. Access Keys are associated with the organization that purchased the license.

Accusoft Products

An Accusoft product may be licensed with either a Toolkit License or a Runtime License.

Activation

Activation is the process of selecting a previously registered toolkit license. Licenses may be paid (Toolkit) or evaluation, and may be for one of many product editions, for products with multiple editions.

Assigned Access Key

An assigned Access Key is one that is assigned to a specific user or users. The assignment of Access Keys to specific users can be done using the Licensing Development Kit (LDK).

Automatically Reported Runtime Licensing

Runtimes may be licensed in one of two ways: automatic reporting or manual reporting. With automatic reporting, you do not need to worry about royalty reporting; it is handled by the licensing layer.

Customers, Developers, and Users

Customers are simply any person who has purchased an Accusoft product. Developers are customers who possess a license for an Toolkit. Users are typically the customers of Accusoft's customers who use applications built around Accusoft components and are assigned a runtime license.

Edition

Some Accusoft products have multiple editions. Editions may offer multiple levels of product speed or product features, allowing customers to find a price-performance mix that is appropriate for them. Products that support multiple editions register multiple Toolkit licenses at installation time, one Toolkit license per edition. Developers must select an edition to activate using the License Manager.

Evaluation License

An evaluation license is a Toolkit license that is unpaid. When an Accusoft Toolkit is installed, evaluation licenses for all applicable product editions are installed and registered, and the edition with the most features is activated. Evaluation Toolkit licenses can be used to try out products. However, the product behavior is limited by trial dialog pop-ups, timeouts, or evaluation watermarks. When you determine the product is a good fit, you can purchase a Toolkit license to eliminate trial dialog pop-ups, timeouts, and evaluation watermarks.

Hardware Key

When a license is activated for a product, the system information that identifies the installation hardware is contained within an encrypted string and is used to generate the license key for the product. The string containing the encrypted hardware information is known as the Hardware Key.

License Configuration File

When a Toolkit or an Automatically Reported Runtime license is purchased, a configuration file is provided that contains information about the license that was purchased. This file is used by the licensing utilities (License Manager, Server License Utility, and License Development Kit) to install a license on the system.

Licensing Development Kit (LDK)

The Licensing Development Kit (LDK) is an ActiveX component that may be used for Runtime Licensing. The LDK is one mechanism for Automatically Reported Runtime Licensing; the Server Licensing Utility (SLU) is the other.

License Key

Each product license has a unique key associated with it that uniquely identifies the customer, product, version, edition, and platforms, and, in some cases, the hardware for which the license is valid.

License Manager

The License Manager is a GUI application that is used by a developer to register and activate Toolkit licenses on their development system.

Manually Reported Runtime Licensing

Runtimes may be licensed in one of two ways: automatic reporting or manual reporting. With Manually Reported Runtime Licensing, you embed all of the licensing information directly into your application. You must manually provide royalty reporting to Accusoft for the actual licenses deployed. This model will be the best choice for you if you are not connected to the Internet at runtime, as might be the case in an defense or financial application.

Node-Locked Licensing

Another name for Automatically Reported Runtime Licensing.

Non-Node-Locked Licensing

Another name for Manually Reported Runtime Licensing.

Paid License

A paid license is a Toolkit license that you have purchased from Accusoft. It is ready to be used in production, with no trial dialog pop-ups, timeouts, or evaluation watermarks. If you wish to test other editions of the Accusoft product for which you have purchased a Paid License, you may activate an Evaluation license for that edition; a complete set of Evaluation licenses for all editions is registered at installation time.

Registration

Registration is the process of informing the License Manager about a new Toolkit license you have purchased. It uses this information to create a license key on your system; this allows you to activate the product for development with no restrictions, such as trial dialog pop-ups, timeouts, or evaluation watermarks.

Runtime (Deployment) Licensing

When deploying an application, a Runtime License is also required for each user’s installation. You must purchase runtime licenses, which are consumed as licenses are registered. There are two Runtime licensing models: Automatically Reported Runtime License; and Manually Reported Runtime License.

Server Licensing Utility (SLU)

The Server Licensing Utility (SLU) is a small GUI application that allows you to request a license key from the Runtime licenses you have purchased. The SLU is one mechanism for Automatically Reported Runtime Licensing; the Licensing Development Kit (LDK) is the other.

Toolkit Licensing

Each Toolkit is assigned to a specific developer who has a registered account with Accusoft. When the developer installs the Toolkit, it is not fully functional until they have activated the license through the use of the License Manager application. When the developer starts the License Manager, they are required to provide login credentials that identify and allow them to activate their license on a development system. See Toolkit Licensing.

Web Services

When a license is registered, information that uniquely identifies the customer’s or user’s hardware is passed along with the license information over the Internet to a web service. The web service validates the licensing request, generates a key that includes the hardware information, and returns the new license key to the application that made the licensing request. The license key is then stored on the requested system and used by the component when it is executed. It is also possible to register systems that are not directly connected to the Internet through the use of removable media and a different system that is connected to the Internet.


%%ItemTitle%%

Software License Agreement
See Also Send Feedback
TwainPRO 7 for .NET - User Guide > Licensing > Software License Agreement

Glossary Item Box

PLEASE READ THE FOLLOWING SOFTWARE LICENSE AGREEMENT WHICH GOVERNS YOUR RIGHT TO USE OF THE TOOLKIT. YOU MUST ACCEPT THESE TERMS BEFORE YOU ARE ALLOWED TO INSTALL THE TOOLKIT. YOU EXPRESSLY AGREE THAT YOU HAVE THE AUTHORITY TO CONTRACTUALLY BIND THE ORGANIZATION AGREEING TO THESE TERMS.

BY CLICKING "I ACCEPT," OR INSTALLING TOOLKIT, OR PLACING TOOLKIT IN-USE, LICENSEE IS AGREEING TO BE BOUND BY THIS AGREEMENT.

1. GRANT OF AGREEMENT

This Accusoft Corporation, ("ACCUSOFT") Software License Agreement ("AGREEMENT") grants the organization contracting under this agreement as licensee ("LICENSEE") a limited, nontransferable, nonexclusive and non-assignable license to use the trial mode version of this ACCUSOFT Development Toolkit ("TOOLKIT") on a single computer for evaluation of fitness only and not for any commercial purpose; or to use a properly purchased and registered TOOLKIT, for development purposes only on a single computer, provided the TOOLKIT is IN-USE on only one computer at any time. (However additional TOOLKIT licenses may be purchased.) TOOLKIT is "IN-USE" on a computer when it becomes loaded by any means for any purpose into temporary memory (that is, including but not limited to RAM) or when it becomes copied or installed to less temporary storage by any means for any purpose (that is, including but not limited to hard disk, CD-ROM or other removable disk or tape, USB or other flash memory drive or card, or other local, networked, or cloud storage device) when it is accessible to that computer. The TOOLKIT is explicitly not to be used on a site-wide basis, via a server or other networked connection.

2. REDISTRIBUTION OF TOOLKIT RUNTIMES

ACCUSOFT does not grant LICENSEE any rights to deploy, license, sell, reproduce, copy, install, lease, timeshare, rent, or otherwise distribute or transfer TOOLKIT or any portion of TOOLKIT ("PORTION") except as provided in Section 1. GRANT OF AGREEMENT. For licensing information about any other distribution of TOOLKIT or PORTION, please visit our web site (www.accusoft.com/licensing.htm), or contact our sales staff. LICENSEE agrees to notify ACCUSOFT immediately of any violations or changes in status regarding LICENSEE's compliance with any term of this AGREEMENT.

In the event that ACCUSOFT grants LICENSEE in a written separate runtime license agreement ("RUNTIME AGREEMENT") a right to deploy, license, sell, reproduce, copy, install, lease, timeshare, rent, or otherwise distribute or transfer PORTIONS, the RUNTIME AGREEMENT will specify what PORTIONS may be distributed ("RUNTIME"). LICENSEE agrees to acknowledge and uphold the terms and conditions of this AGREEMENT as well as the terms of the RUNTIME AGREEMENT itself, which will be provided only in writing. In such event, LICENSEE may distribute RUNTIMES as part of the LICENSEE's software application or derivative works ("PRODUCT") upon additionally agreeing to the following:

a) LICENSEE understands and acknowledges that in order to receive any discounted pricing for RUNTIME distribution licensing fees based on the type of installation, it must either: 1) prepay for a number of RUNTIME licenses that is sufficient to qualify for ACCUSOFT's then-current published quantity discount, or 2) it must pay for the licenses in accordance with a written contract between LICENSEE and ACCUSOFT.

b) LICENSEE's PRODUCT shall not compete to any degree with the TOOLKIT. Such competitive PRODUCTS are defined as software development toolkits that include similar functionality as TOOLKIT and that are intended for use by software developers and/or system integrators.

c) LICENSEE's PRODUCT must be substantially greater in scope with greater functionality and features than those of the TOOLKIT.

d) LICENSEE will not use ACCUSOFT's name, logo, or trademarks to market PRODUCT without prior written approval of ACCUSOFT except LICENSEE will include a statement substantially similar to the following within PRODUCT documentation and about box: "Portions of this product contain imaging and other technology owned by Accusoft Corporation, Tampa, FL, (www.accusoft.com). ALL RIGHTS RESERVED."

e) LICENSEE agrees to only distribute the RUNTIMES. No license or other rights are granted to LICENSEE for any distribution of the TOOLKIT or PORTIONS including, but not limited to, documentation, source code, or the RUNTIME distribution unlock codes.

g) LICENSEE will only distribute the RUNTIMES on the hardware and operating system(s) for which the RUNTIMES are intended to be used according to the RUNTIME AGREEMENT.

If ANY of the terms of this AGREEMENT are not applicable to LICENSEE'S situation, or if any of the terms of this AGREEMENT cannot be complied with, or if LICENSEE needs modifications to this AGREEMENT or the license granted for any reason, LICENSEE must contact ACCUSOFT about obtaining an expanded license from ACCUSOFT (available by phone at: 813-875-7575, x321, by e-mail at: Sales@accusoft.com or by fax at: 813-875-7705).

This AGREEMENT grants rights to LICENSEE only for the TOOLKIT and does not convey any other rights of use or distribution to ACCUSOFT technology.

3. OWNERSHIP

LICENSEE acknowledges and agrees that ACCUSOFT owns all rights, title and interest in the TOOLKIT, in all forms, including without limitation any and all worldwide proprietary rights therein, including but not limited to trademarks, copyrights, patent rights, patent continuations, trade secrets and confidential information.

LICENSEE may not remove or alter the copyright notice from any copy of the TOOLKIT or any copy of the written materials, accompanying the TOOLKIT.

LICENSEE waives its right to contest any of ACCUSOFT's patents, trademarks, service marks, trade names, copyrights, and other intellectual property and proprietary rights in and to the TOOLKIT.

LICENSEE shall not use such trademarks, service marks, and trade names except where and as permitted under this AGREEMENT without receiving ACCUSOFT's prior written approval of such use. If such approval is granted, LICENSEE’s right to use such trademarks, service marks, and trade names shall end upon the termination of this AGREEMENT.

4. RESTRICTIONS AND RESERVATIONS.

All rights and licenses not expressly granted to LICENSEE are reserved to ACCUSOFT. LICENSEE is strictly prohibited from reproducing, copying, marketing, selling, distributing, licensing, sublicensing, leasing, timesharing or renting the TOOLKIT or PORTION, and LICENSEE is strictly prohibited from any use of the TOOLKIT or PORTION except as permitted by this AGREEMENT, and such actions are expressly prohibited. LICENSEE is strictly prohibited from incorporating or including the TOOLKIT or PORTION into or as part of any PRODUCT or service of LICENSEE except as provided by this AGREEMENT, regardless of the functionality of TOOLKIT (or lack thereof) within or as part of such PRODUCT or service of LICENSEE. LICENSEE shall not for any reason disassemble, decompile, decrypt or reverse engineer the TOOLKIT or PORTION or in any manner attempt to discover or reproduce the source code or any other copyrightable, proprietary, or trade secret aspect of the TOOLKIT or PORTION. Nor shall LICENSEE use the TOOLKIT or PORTION, directly or indirectly, in developing LICENSEE's own PRODUCT with, or including, similar functionality. LICENSEE shall not make any copies of the TOOLKIT or PORTION for any purpose whatsoever except as permitted by this AGREEMENT. Source code that is provided with TOOLKIT for sample or demonstration purposes may be used directly or indirectly in developing PRODUCT, however it may not be distributed in source form in whole or in part with or as part of PRODUCT.

5. WARRANTY DISCLAIMER

LICENSEE ACKNOWLEDGES AND AGREES THAT THE TOOLKIT IS PROVIDED "AS IS." ACCUSOFT DISCLAIMS ANY AND ALL REPRESENTATIONS AND WARRANTIES OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND AGAINST INFRINGEMENT.

6. LIMITATION OF LIABILITY

ACCUSOFT SHALL HAVE NO LIABILITY TO LICENSEE, LICENSEE AFFILIATES, SUBSIDIARIES, SHAREHOLDERS, OFFICERS, DIRECTORS, EMPLOYEES, REPRESENTATIVES OR ANY THIRD PARTY, WHETHER IN CONTRACT, TORT, NEGLIGENCE OR PRODUCTS LIABILITY, FOR ANY CLAIM, LOSS OR DAMAGE, INCLUDING BUT NOT LIMITED TO, LOST PROFITS, LOSS OF USE, BUSINESS INTERRUPTION, LOST DATA, LOST FILES, OR FOR ANY DIRECT, INDIRECT, SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES OF ANY KIND OR NATURE WHATSOEVER ARISING OUT OF OR IN CONNECTION WITH USE OF OR INABILITY TO USE THE TOOLKIT, OR THE PERFORMANCE OR OPERATION OF THE TOOLKIT, EVEN IF ACCUSOFT HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

7. INDEMNIFICATION BY LICENSEE

LICENSEE SHALL INDEMNIFY, HOLD HARMLESS AND DEFEND ACCUSOFT FOR ANY LOSS, CLAIM, ACTION OR PROCEEDING THAT ARISES OR RESULTS FROM ANY ACTIONS OR OMISSIONS OF LICENSEE PERTAINING TO THE PRODUCT OR THE TOOLKIT AND FROM ANY ACTIONS OF LICENSEE THAT ARE IN VIOLATION OF THIS AGREEMENT.

8. TERM AND TERMINATION

Unless otherwise agreed to by the parties, this AGREEMENT shall become effective upon the earlier of LICENSEE's clicking of "I Accept" or LICENSEE'S installing or placing TOOLKIT IN_USE ("Effective Date") and shall continue in full force and effect until terminated in accordance with the terms set forth in this AGREEMENT.

Any material breach of this AGREEMENT shall automatically and immediately terminate this AGREEMENT. In the event that LICENSEE ceases to do business or is adjudged bankrupt or insolvent, ACCUSOFT may, at its sole option, terminate this AGREEMENT, by giving ten (10) Business Days written notice of such termination, which notice shall identify and describe the basis for such termination.

In the event of any termination of this AGREEMENT, any RUNTIME AGREEMENT is simultaneously terminated and LICENSEE shall stop using the TOOLKIT and PORTION, shall cease manufacturing the PRODUCT containing TOOLKIT or PORTION, and shall cease distributing PRODUCT containing TOOLKIT or PORTION. LICENSEE shall also require its resellers, OEMs, and other distribution channels (if any) to likewise stop manufacturing and distributing the PRODUCT containing TOOLKIT or PORTION. Within ten (10) Business Days thereafter, LICENSEE shall return or, at ACCUSOFT's option, destroy, the TOOLKIT and all PORTIONS, whether or not incorporated in or with the PRODUCT, that are within LICENSEE’s possession, custody and control, and shall certify to ACCUSOFT in writing within ten (10) Business Days after that return or destruction that it has complied with the foregoing obligation.

All Sections except Section 1. GRANT OF LICENSE shall continue in full force and effect, notwithstanding any termination of this AGREEMENT.

9. LIQUIDATED DAMAGES

In the event LICENSEE (a) copies the TOOLKIT or PORTION except as permitted by this AGREEMENT, (b) uses the TOOLKIT or PORTION for any reason other than as permitted by this AGREEMENT, (c) installs or uses the TOOLKIT or PORTION on more than a single computer, or (d) otherwise violates or breaches this Agreement, LICENSEE agrees that ACCUSOFT is entitled to obtain as liquidated damages and not as a penalty the greater of the amount of (v) the published quantity one distribution price based upon the type of distribution, or (w) $99 per each user of each PRODUCT or service of LICENSEE in which the TOOLKIT or PORTION is included, copied, incorporated, embedded or accessible; (x) $100 per copy of TOOLKIT or PORTION; (y) $100 per copy of any PRODUCT in which TOOLKIT or PORTION is included, copied, incorporated, embedded or accessible; or (z) 3% of all revenues realized by LICENSEE pertaining to any PRODUCTS or services of LICENSEE in which TOOLKIT or PORTION is included, copied, incorporated, embedded or accessible. THE LICENSEE EXPRESSLY AGREES THAT THE FOREGOING LIQUIDATED DAMAGES ARE NOT A PENALTY.

10. CONFIDENTIALITY

LICENSEE acknowledges that the TOOLKIT contains ACCUSOFT know-how, confidential and trade secret information ("PROPRIETARY INFORMATION"). LICENSEE agrees: (a) to hold the PROPRIETARY INFORMATION in the strictest confidence, (b) not to, directly or indirectly, copy, reproduce, distribute, manufacture, duplicate, reveal, report, publish, disclose, cause to be disclosed, or otherwise transfer the PROPRIETARY INFORMATION to any third party, (c) not to make use of the PROPRIETARY INFORMATION other than as permitted by this AGREEMENT, and (d) to disclose the PROPRIETARY INFORMATION only to LICENSEE's representatives requiring such material for effective performance of this AGREEMENT and who have undertaken an obligation of confidentiality and limitation of use consistent with this AGREEMENT. This obligation shall continue as long as allowed under applicable law.

11. INJUNCTIVE RELIEF

LICENSEE agrees that any violation or threat of violation of this AGREEMENT will result in irreparable harm to ACCUSOFT for which damages would be an inadequate remedy. Therefore, in addition to its rights and remedies available at law (including but not limited to the recovery of damages for breach of this AGREEMENT), ACCUSOFT shall be entitled to immediate injunctive relief to prevent any violation of ACCUSOFT's copyright, trademark, trade secret rights regarding the TOOLKIT, or to prevent any violation of this AGREEMENT, including, but not limited to, unauthorized use, copying, distribution or disclosure of or regarding the TOOLKIT or PORTION, as well as any other equitable relief as the court may deem proper under the circumstances.

12. NO REDUCED PRICING

In any determination of ACCUSOFT's damages (whether liquidated damages or actual damages), or any determination of any licensing fees or royalties due ACCUSOFT under this AGREEMENT due to a breach by LICENSEE hereunder, LICENSEE shall not be entitled to any discounts (volume or otherwise) or reduced licensing fees or royalties. The foregoing sentence shall be applicable unless LICENSEE has negotiated and entered into a written, signed agreement with ACCUSOFT for such reduced or discounted licensing fees or royalties and paid ACCUSOFT such fees or royalties in advance of any: (a) distribution of the TOOLKIT or PORTION, (b) copying of the TOOLKIT or PORTION, or (c) incorporation or use of the TOOLKIT or PORTION in or pertaining to any PRODUCT or service of LICENSEE. Further, LICENSEE agrees that it shall not be entitled to reduced licensing fees or royalties when determining ACCUSOFT's damages due to any undertaking or activity by LICENSEE regarding the TOOLKIT or PORTION outside of or exceeding the scope of permission or other terms of this AGREEMENT, or LICENSEE's actions otherwise in violation of this AGREEMENT.

13. ATTORNEYS' FEES AND COSTS

In the event of any lawsuit or other proceeding brought as a result of any actual or alleged breach of this AGREEMENT, to enforce any provisions of this AGREEMENT, or to enforce any intellectual property or other rights in or pertaining to the TOOLKIT or PORTION, the prevailing party shall be entitled to an award of its reasonable attorneys’ fees and costs, including the costs of any expert witnesses, incurred at all levels of proceedings.

14. GOVERNING LAW

This AGREEMENT shall be construed, governed and enforced in accordance with the laws of the State of Florida, without regard to any conflicts of laws rules. Any action related to or arising out of this AGREEMENT will be filed only in the Florida courts and LICENSEE consents to the exclusive jurisdiction and venue of the state and federal courts located in Tampa, Florida.

15. SEVERABILITY

If any provision of this AGREEMENT is determined to be invalid by any court of final jurisdiction, then it shall be omitted and the remainder of the AGREEMENT shall continue to be binding and enforceable. In addition, the Court is hereby authorized to enforce any provision of the AGREEMENT that the Court otherwise deems unenforceable, to whatever lesser extent the Court deems reasonable and appropriate, rather than invalidating the entire provision. Without limiting the generality of the foregoing, LICENSEE expressly agrees that should LICENSEE be found to have breached the AGREEMENT, under no circumstances shall LICENSEE be entitled to any volume or other discount, or reduced licensing fee or royalty in the determination of ACCUSOFT's damages, or otherwise in the determination of any licensing fee or royalty owed to ACCUSOFT.

16. GOVERNMENT RIGHTS

The TOOLKIT and accompanying documentation have been developed at private expense and are sold commercially. They are provided under any U.S. government contracts or subcontracts with the most restricted and the most limited rights permitted by law and regulation. Whenever so permitted, the government and any intermediaries will obtain only those rights specified in ACCUSOFT's standard commercial license. Thus, the TOOLKIT referenced herein, and the documentation provided by Accusoft hereunder, which are provided to any agency of the U.S. Government or U.S. Government contractor or subcontractor at any tier shall be subject to the maximum restrictions on use as permitted by FAR 52.227-19 (June 1987) or DFARS 227.7202-3(a) (Jan. 1, 2000) or successor regulations. Manufacturer is Accusoft Corporation, 4001 N. Riverside Drive Tampa, FL 33603.

17. ENTIRE AGREEMENT

This AGREEMENT represents the entire understanding of the parties concerning the subject matter hereof and supersedes all prior communications and agreements, whether oral or written, relating to the subject matter of this AGREEMENT. Only a writing signed by the parties may modify this AGREEMENT. In the event of any modification in writing, of this AGREEMENT, including an expanded license agreement, all sections of this Agreement survive except Section 2. Limited License.

18. CONTACT US

Should you have any questions concerning this AGREEMENT, or if you desire to contact ACCUSOFT for any reason, please contact ACCUSOFT at 1-813-875-7575.

19. OTHER RESTRICTIONS

a) This AGREEMENT shall not be amended, altered, changed or modified in any way, unless agreed to in writing by both ACCUSOFT and LICENSEE. Such writing must be executed by a duly authorized representative of ACCUSOFT and a duly authorized representative of LICENSEE.

b) This AGREEMENT is not transferable or assignable by LICENSEE under any circumstances, without the prior written consent of ACCUSOFT. ACCUSOFT will not unreasonably withhold such consent. This AGREEMENT shall be binding upon, and is made for the benefit of, each party, its successors, and permitted assignees (if any). For the purposes of this AGREEMENT, any change in control of LICENSEE shall constitute an assignment or transfer of this AGREEMENT requiring prior written consent of ACCUSOFT. As used in this section, a change in control is defined as (i) any change in ownership of more than fifty percent (50%) of the voting interest in LICENSEE, whether by merger, purchase, foreclosure of a security interest or other transaction, or (ii) a sale of all or substantially all of the assets of LICENSEE.

c) The relationship established by this AGREEMENT between LICENSEE and ACCUSOFT shall be that of Licensee and Licensor. Nothing contained in this AGREEMENT shall be construed as creating a relationship of agency, joint venture or partnership between LICENSEE and ACCUSOFT. Neither party shall have any right whatsoever to incur any liabilities or obligations on behalf of the other party.

d) ACCUSOFT's failure to perform any term or condition of this AGREEMENT as a result of conditions beyond its control such as, but not limited to, war, strikes, fires, floods, acts of God, governmental restrictions, power failures, or damage or destruction of any network facilities or servers, shall not be deemed a breach of this AGREEMENT.

e) The headings provided in this AGREEMENT are for convenience and reference purposes only. In the event of a conflict between the terms and conditions listed in this AGREEMENT, and any attached Schedules or Appendices, the terms and conditions of this AGREEMENT shall govern.

f) A waiver of a breach, violation, or default under this AGREEMENT shall not be a waiver of any subsequent breach, violation or default. Failure of either party to enforce compliance with any term or condition of this AGREEMENT shall not constitute a waiver by the party of such term or condition.

g) All notices and communications shall be in writing and shall be deemed to have been duly given the earlier of when delivered or three (3) Business Days after mailing by certified mail, return receipt requested, postage prepaid, or by international delivery service, addressed to the parties at their respective addresses set forth on the Order Form or at such other addresses as the parties may designate by written notice in accordance with this section.

Rev. 20120112

See Also

Distributing TwainPRO
Licensing


%%ItemTitle%%

Distributing Applications & Deployment
Send Feedback
TwainPRO 7 for .NET - User Guide > Distributing Applications & Deployment

Glossary Item Box

This section provides information about the following:

  • Verify You're Using the Latest Service Pack
  • Distributing TwainPRO


%%ItemTitle%%

Verify You're Using the Latest Service Pack
See Also Send Feedback
TwainPRO 7 for .NET - User Guide > Distributing Applications & Deployment > Verify You're Using the Latest Service Pack

Glossary Item Box

Service pack updates will not overwrite paid licensing. Your paid licensing will continue to work and you will not be required to re-enter your purchased registration codes. Service pack updates do not include any changes that might "break" previously developed and/or deployed code.

Verify Latest Development Components

To verify you are using the latest version of a Accusoft Development Component or Components, please refer to the currently released product build numbers at www.accusoft.com/latestbuilds.htm.

If you require further assistance or have questions or comments, please see the topic on Getting Support for more detailed information.

See Also

Getting Support
Installing on a Development Machine


%%ItemTitle%%

Distributing TwainPRO
See Also Send Feedback
TwainPRO 7 for .NET - User Guide > Distributing Applications & Deployment > Distributing TwainPRO

Glossary Item Box

DLL Files to Distribute

The following files are required to be distributed with the TwainPro .NET Windows Forms control:

  • Accusoft.TwainPro7.Net.dll - .NET Control Assembly

There is a 32-bit and 64-bit version of the following file:

  • TWAINDSM.DLL

The 32-bit version of this file is required if using the TwainPRO .NET control in a 32-bit process, and the 64-bit version of this file is required if using the TwainPRO .NET control in a 64-bit process. An AnyCPU application will require the 32-bit version of this file (if it is run on a 32-bit machine) and will require the 64-bit version of this file (if it is run on a 64-bit machine). The latest version of this DLL can be found at www.twain.org.

Note that TWAIN can only load: 32-bit scanner drivers in a 32-bit process and 64-bit scanner drivers in a 64-bit process. The TwainPRO .NET samples are set to 32-bit by default, but if they are run on a 64-bit machine, the platform configuration of the project can be changed to AnyCPU to access a 64-bit scanner driver (if a 64-bit driver is available for your scanner).

TwainPRO will give an error with the older TWAIN DLL files. Ensure you have the new TWAINDSM.DLL file.

Windows 32-bit & 64-bit Support

The following section is directly from the TWAIN_2_Errata.pdf from www.twain.org:

Windows 32-bit Support

Full TWAIN 2.0 support is not available through 16-bit TWAIN.DLL or through the 32-bit TWAIN_32.DLL file that Microsoft delivers with its supported versions of Windows. Full TWAIN 2.0 support is available using the new TWAINDSM.DLL provided by the TWAIN Working Group. This file is installed by a TWAIN application or driver in the SYSTEM32 directory on native 32-bit Windows systems, or in the SYSWOW64 directory on native 64-bit Windows systems.

Applications that use TWAINDSM.DLL are able to access 32-bit TWAIN drivers of any version, they are not limited to just TWAIN 2.0 drivers.

TWAIN drivers that access TWAIN_32.DLL do not have to be modified. TWAINDSM captures accesses to DSM_Entry through TWAIN_32.DLL, and automatically redirects them to the DSM_Entry in TWAINDSM.DLL.

Windows 64-bit Support

TWAIN supports native 64-bit for x64 platforms. The new DSM is required, and should be installed in the Windows SYSTEM32 directory.

See Also

Getting Support
Installing on a Development Machine
Software License Agreement
Verify You're Using the Latest Service Pack

Licensing
Licensing


%%ItemTitle%%

Concepts
Send Feedback
TwainPRO 7 for .NET - User Guide > Concepts

Glossary Item Box

This section provides information about the following:

  • Overview of TwainPRO
  • Overview of TWAIN
  • Supported File Formats
  • Glossary


%%ItemTitle%%

Overview of TwainPRO
Send Feedback
TwainPRO 7 for .NET - User Guide > Concepts > Overview of TwainPRO

Glossary Item Box

TwainPRO encapsulates powerful TWAIN capabilities within a set of classes, described below:

TwainPro

The TwainPro class provides methods and properties to manage licensing of the control.

TwainDevice

The TwainDevice class provides methods and properties for managing all TWAIN device interaction. Each TwainDevice class has an ApplicationIdentity and Caption which can optionally be set.

CapabilityContainer

Capability negotiation can be done after calling TwainDevice.OpenSession. The CapabilityContainer class contains all information for a capability. The classes, such as CapabilityContainerOneValueString and CapabilityContainerOneValueFloat, that are inherited from this class can be filled with information and passed to the TwainDevice.SetCapability method to set the value of a capability. The TwainDevice.GetCapability method returns an object of this type which can be casted to the appropriate child object to access the capability information.

ScannedImage

When TwainDevice.StartSession is called, for each image that is scanned the Scanned event is fired and the ScannedImage is available. The ScannedImage class provides methods and properties for accessing the scanned image and scanned image information.

The ScannedImage.SaveFile method can be used to save the scanned image to file. If SaveOptions are not specified the image will be saved using the default settings for the specified file extension.

SaveOptions

The SaveOptions class provides settings to use for saving the scanned image to file.

ExtendedImageInfoContainer

Extended image information can be obtained using the ScannedImage.GetExtendedImageInfo method. The ExtendedImageInfoContainer class contains a collection of ExtendedImageInfoContainerValues which contain the extended image information.


%%ItemTitle%%

Overview of TWAIN
Send Feedback
TwainPRO 7 for .NET - User Guide > Concepts > Overview of TWAIN

Glossary Item Box

TWAIN defines a standard software protocol and application programming interface (API) for communication between software applications and image acquisition devices.

Users need a way to get image data into their applications. Software developers need compatibility with the widest range of output devices without writing and maintaining multiple device drivers.

The solution to this situation is an open industry interface (TWAIN) that directly acquires image data from external sources while within an application.

With this, each software developer supports a standard data acquisition manager and each hardware vendor writes one driver for their device. Hardware vendors benefit because they need only provide one standard driver for their device, which can then be used by all software applications supporting the TWAIN data acquisition interface.

Three Key Elements in TWAIN

  1. The Application software — An application which has been written to use TWAIN.

  2. The Data Source Manager software — The software which manages the interaction between the application and Data Source. This manager (TWAINDSM.DLL) can be found at www.twain.org.

  3. The Data Source software — The software which controls the image acquisition device which has been written to comply with the TWAIN specifications. It is generally supplied by the acquisition device manufacturer.

TWAIN defines how application developers can acquire image data directly into their application without requiring the user to switch out of the application. To provide this feature, TWAIN requires Data Sources to provide a built-in user interface (UI) for their device. Application developers can, if they choose, disable the built-in User Interface provided by the Data Source and provide their own User Interface to control TWAIN devices.

Support for disabling the built-in User Interface must be provided by the Data Source.

New in TWAIN v2.0

The new features in TWAIN v2.0 are:

  • Full compatibility with all previous versions of TWAIN
  • Available natively on 64-bit platforms
  • New Data Source manager (DSM), Open Source with LGPL license
  • New sample application and driver code, both Open Source with BSD license
  • All capabilities using TW_BOOL now support TW_ENUMERATION, allowing them to be constrained
  • Drivers can advertise support for the following features - MICR, PDF/A, automatic image rotation, infrared pixel type, auto size images
  • Drivers can report new condition codes - interlock error, damaged corner, focus error, document too light


%%ItemTitle%%

Supported File Formats
Send Feedback
TwainPRO 7 for .NET - User Guide > Concepts > Supported File Formats

Glossary Item Box

TwainPRO™ supports the following file formats:

PDF

Portable Document Format, a file format created by Adobe® System to represent documents independently of the application software, hardware, and operating system used to create them, and independently of the output device on which they are displayed or printed.

BMP

The Microsoft Windows Bitmap file format is based on the Windows internal bitmap data structures. The BMP format is widely used and it is quick and easy to read.

JPEG

The JPEG (Joint Photographic Expert Group) standard is one of the most important image data compression standards. It is widely used in many industries and is becoming the most widely used image format for the Internet.

JPEG Compression is a lossy format that can achieve very high compression ratios. The compression level is adjustable by varying the SaveJPEGChromFactor and SaveJPEGLumFactor properties.

Progressive JPEG is a multiple-scan sequential JPEG format that is becoming popular for its ability to display images in progressively clearer segments.

ePIC

Accusoft enhanced PIC image format (.PIC). This high performance image compression combines the patented ELS arithmetic coder with the high performance Accusoft JPEG libraries. The result is a new and unbeatable compression technology. The ePIC compression has significant advantages over standard JPEG. Most importantly it produces smaller file sizes and decompresses extremely quickly. Other features include password encryption, and scaling and cropping without recompression. All Accusoft products support the ePIC file format.

TIFF

TIFF (Tag Image File Format) originally released by Aldus Corporation is a standard file format found in most print, imaging, and desktop publishing programs. TIFF is extremely powerful, flexible, and extensible.

For TIFF, the compression is selected by the SaveTIFFCompression property. For images above 1-bit, the compression will be uncompressed regardless of this property setting.


%%ItemTitle%%

Glossary
Send Feedback
TwainPRO 7 for .NET - User Guide > Concepts > Glossary

Glossary Item Box

A | B | C | D | E | F | G | H | I | J | K | L | M | N | O | P | Q | R | S | T | U | V | W | X | Y | Z

C

Capability
The options offered by a Data Source device. For example, devices may have automatic document feeders, may enable single or multiple image transfers, support color images, etc.

Capability Container

Capabilities have one of four containers, that define the structure of information. Containers include:

  • TW_ONEVALUE - a single value
  • TW_ARRAY - a rectangular array of values
  • TW_RANGE - a range of allowed values
  • TW_ENUMERATION - a list of valid values

Capability Negotiation
The application influences the data source's capability settings through capability negotiation. By determining if the source supports a capability, checking the current value of that capability, and setting the capability to the desired value, then verifying that new values have been accepted by the source.

D

Data Source (DS)
The image acquisition device, written to comply with the TWAIN specification.

Data Source Manager (DSM)
The software that manages interactions between the application and the Data Source. This code is provided in the TWAIN Developer's Toolkit and should be shipped for free with each TWAIN application and Data Source.

E

Extended Information
Information associated with the image on the page, such as a barcode.

T

Thread-safe
An application using this component can use multiple controls running in the same process, where they don't interfere with each other. The thread creating the control owns the control and is the only thread that can interact with it.

Transfer Mode
Describes how data is transferred from the Data Source to the Application. Three modes are available: native, disk file, and buffered memory.

TWAIN Identity
A unique identifier of the TWAIN application or Source.


%%ItemTitle%%

How To
Send Feedback
TwainPRO 7 for .NET - User Guide > How To

Glossary Item Box

This section provides information about the following:

  • Select the DSM Version
  • Quick Start - Acquire a TWAIN Image
  • Open a TWAIN Session
  • Negotiate Capabilities
  • Acquire Images and Image Information
  • Pass Image Data between Accusoft Components
  • End a TWAIN Session
  • Debug


%%ItemTitle%%

Select the DSM Version
Send Feedback
TwainPRO 7 for .NET - User Guide > How To > Select the DSM Version

Glossary Item Box

The DataSourceManagerVersion property allows you to set the Data Source Manager version that TwainPro will use. The DSM is a DLL provided by TWAIN that lives between the Data Source (Scanner) and the Application (TwainPro) and manages the data and communications between the two.

  • In Versions 5 and prior of TwainPro, only Version 1 was used.
  • In Version 6 of TwainPro, only Version 2 was used.
  • In Version 7 of TwainPro, we introduce a new behavior to allow the DSM version used to be set, since not all scanners support the newest version of the DSM. This provides greater flexibility for the developer to accommodate such scenarios.

When set to Version 2, the file TWAINDSM.dll is used:

  • 32-bit: On 64-bit machines running in a 32-bit context, it should be located in the SYSWOW64 directory. On 32-bit machines, it should be located in the SYSTEM32 directory. If it can’t be found, a TwainDllLoadException will be thrown indicating this.
  • 64-bit: On 64-bit machines running in a 64-bit context, it should be located in the SYSTEM32 directory. If it can’t be found, a TwainDllLoadException will be thrown indicating this.

Also, TwainPro internally identifies itself as a 2.0 TWAIN application to the Data Source.

When set to Version 1, the file twain_32.dll is used:

  • 32-bit: It should be located in the WINDOWS directory. If it can’t be found, a TwainDllLoadException will be thrown indicating this.
  • 64-bit: This is not supported, you must use Version 2. (TWAIN only support 64-bit for Twain 2.0 and above.) A TwainDllLoadException will be thrown indicating this.

Also, TwainPro internally identifies itself as a 1.9 TWAIN application to the Data Source.

When set to LatestSupportedVersionAvailable:

TwainPro attempts to use Version 2 of the DSM, if this fails it will attempt to use Version 1 of the DSM. If that fails then a TwainDllLoadException will be thrown indicating no version could be found. By default the DataSourceManagerVersion property is set to LatestSupportedVersionAvailable.

DataSourceManagerVersionInUse is a read-only property that can be queried to find out the current DSM version that's currently in use by TwainPro.


%%ItemTitle%%

Quick Start - Acquire a TWAIN Image
See Also Send Feedback
TwainPRO 7 for .NET - User Guide > How To > Quick Start - Acquire a TWAIN Image

Glossary Item Box

Your application needs only two support features for TWAIN compliance:

  • Data Source (DS) selection

  • Image acquisition through the Data Source User Interface (UI)

The two standard methods supplied within the TwainDevice class are SelectSource and StartSession.

SelectSource displays the TWAIN Data Source Manager's User Interface with the default Data Source highlighted. Select the Data Source you want to use, then click the OK or Cancel buttons.

The StartSession method displays the current or default Data Source User Interface for image acquisition. Any capabilities that you want to change will have to be changed through the Data Source User Interface.

C# Example Copy Code
// This code demonstrates how to select the Data Source UI and then acquire an image from the Data Source
private void cmdScan_Click(object sender, EventArgs e)
{
 twainDevice.SelectSource();
 twainDevice.StartSession();
}

// After the image is acquired you can place it into the windows clipboard then into other applications
// or controls.
public void twainDevice_Scanned(object sender, Accusoft.TwainProSdk.ScannedEventArgs e)
{
 try
 {
  e.ScannedImage.CutToClipboard();
 }
 catch (Accusoft.TwainProSdk.TwainProException ex)
 {
  ErrorLabel.Text = ex.Message;
 }
}

See Also

SelectSource Method
StartSession Method


%%ItemTitle%%

Open a TWAIN Session
Send Feedback
TwainPRO 7 for .NET - User Guide > How To > Open a TWAIN Session

Glossary Item Box

This section provides information about the following:

  • Set the Application's TWAIN Identity
  • Enable Extended Capabilities
  • Set the Transfer Mode
  • Enable Multi-Page Scanning
  • Select a Data Source
  • Open the TWAIN Session


%%ItemTitle%%

Set the Application's TWAIN Identity
See Also Send Feedback
TwainPRO 7 for .NET - User Guide > How To > Open a TWAIN Session > Set the Application's TWAIN Identity

Glossary Item Box

All TWAIN Data Sources and applications have a TWAIN Identity. This identity enables the TWAIN Data Source Manager (DSM) to keep track of all running TWAIN applications and Data Sources.

The application's TWAIN identity is set using the TwainDevice.ApplicationIdentity.

The ApplicationIdentity must be assigned prior to starting a TWAIN Session (OpenSession).

See Also

ApplicationIdentity Property
OpenSession Method


%%ItemTitle%%

Enable Extended Capabilities
See Also Send Feedback
TwainPRO 7 for .NET - User Guide > How To > Open a TWAIN Session > Enable Extended Capabilities

Glossary Item Box

Some non-compliant TWAIN drivers don't properly handle a query for support of extended capabilities (CAP_FEEDPAGE and CAP_CLEARPAGE).

If you do not plan to use these capabilities, set the TwainDevice.EnableExtendedCapabilities to False.

The Data Source should be set before opening a TWAIN session (TwainDevice.OpenSession).

See Also

EnableExtendedCapabilities Property
OpenSession Method


%%ItemTitle%%

Set the Transfer Mode
See Also Send Feedback
TwainPRO 7 for .NET - User Guide > How To > Open a TWAIN Session > Set the Transfer Mode

Glossary Item Box

The TwainPRO™ control now lets you determine the method of transfer you wish to use with the Data Source.

The TwainDevice.TransferMode property should be set before opening a TWAIN Session (TwainDevice.OpenSession).

Native Transfer Mode

By default, TwainPRO control uses Native transfer mode which is the simplest to use because the Data Source is responsible for providing a DIB directly to the control.

Buffered Memory Transfer

An alternative mode of transfer, buffered memory transfer, specifies that data from the Data Source is transferred in blocks of data. In buffered memory transfer mode, the TwainPRO control is responsible for converting the data received from the scanner to the proper format. Typically this would be a standard DIB. This method of transfer can be faster on computers with lesser amounts of memory or higher-end scanners.

The data can be negotiated with the Data Source through the advanced capability ICAP_COMPRESSION to be in compressed format. This results in a TIFF or JPEG file being created in memory so that less memory is used and the transfer time from the Data Source to the application is lower.

See Also

TransferMode Property
OpenSession Method


%%ItemTitle%%

Enable Multi-Page Scanning
See Also Send Feedback
TwainPRO 7 for .NET - User Guide > How To > Open a TWAIN Session > Enable Multi-Page Scanning

Glossary Item Box

The MaximumImages property is negotiated with the TWAIN Data Source during initialization (OpenSession) and should be set prior to invoking the OpenSession method.

This property is only used when the OpenSession method is invoked. To set the transfer count after calling OpenSession, use the CAP_XFERCOUNT capability.

  • A value of –1 indicates the application is willing to transfer multiple images.
  • A value of 1 indicates the application wishes to transfer only one image per session.
The Data Source should be set before opening a TWAIN session (TwainDevice.OpenSession).

See Also

MaximumImages Property
OpenSession Method


%%ItemTitle%%

Select a Data Source
See Also Send Feedback
TwainPRO 7 for .NET - User Guide > How To > Open a TWAIN Session > Select a Data Source

Glossary Item Box

The Data Source for the TWAIN session must now be identified.

The Data Source should be set before opening a TWAIN session (TwainDevice.OpenSession).

Using the Data Source Manager's User Interface (DSM UI)

To enable the application end user to select a Data Source using the Data Source Manager's User Interface, call TwainDevice.SelectSource. The DataSource Manager's UI will display with the default Data Source highlighted. The user selects the Data Source he or she wishes to use then selects the OK or Cancel buttons.

Without the TWAIN DSM UI

TwainPRO™ can retrieve the list of Data Sources (DS) on the current system and set the current Data Source, without using the DSM User Interface.

In order to obtain a list of the Data Sources you must call the OpenDataSourceManager method first. You can then create a DataSourceCollection which is filled with a list of all Data Source product names. The Count property of the DataSourceCollection can be used to get the number of Data Source product names within the DataSourceCollection. The Current property of the DataSourceCollection can be used to get or set the index of the currently selected Data Source.

See Also

OpenSession Method
SelectSource Method
OpenDataSourceManager Method
DataSourceCollection Class
Count Property
Current Property


%%ItemTitle%%

Open the TWAIN Session
See Also Send Feedback
TwainPRO 7 for .NET - User Guide > How To > Open a TWAIN Session > Open the TWAIN Session

Glossary Item Box

Prior to Opening the TWAIN Session, the following should be done:

  • Set the Application's TWAIN Identity
  • Enable Extended Capabilities (if desired)
  • Set the Transfer Mode
  • Enable Multi-page Scanning (if desired)

The application opens a TWAIN session by calling the TwainDevice.OpenSession method. Once a TWAIN Session has been initiated, the application can read and modify capabilities, and specify instructions for scanning, such as scanning DPI and layout.

See Also

Set the Application's TWAIN Identity
Enable Extended Capabilities
Set the Transfer Mode
Enable Multi-Page Scanning
OpenSession Method


%%ItemTitle%%

Negotiate Capabilities
Send Feedback
TwainPRO 7 for .NET - User Guide > How To > Negotiate Capabilities

Glossary Item Box

This section provides information about the following:

  • Check Capabilities
  • Set Capabilities
  • Set Image DPI


%%ItemTitle%%

Check Capabilities
See Also Send Feedback
TwainPRO 7 for .NET - User Guide > How To > Negotiate Capabilities > Check Capabilities

Glossary Item Box

TWAIN devices have different capabilities (e.g., levels of resolution, support of color or black and white images, automatic document feeder available, etc.). Applications can check the capabilities available for the TWAIN device, and can also set those capabilities to its desired settings.

Capabilities can be checked once a TWAIN Session has been opened (OpenSession), and before or after a scanning session has been initiated (StartSession).

Identifying Capabilities

TWAIN specifies some capabilities to be basic (Capability) and some to be advanced (AdvancedCapability). TwainPRO methods are overloaded to support both. An overload is also provided to enable the application to access a capability that is not enumerated in the TwainPRO™ interface, by specifying an integer value.

Check that the Capability is Supported by the Data Source

To determine whether the capability of interest is supported by the TWAIN device, call TwainDevice.IsCapabilitySupported.

Read the Capability Information

If the capability is supported by the TWAIN device, call TwainDevice.GetCapability. TWAIN defines four types of containers used to negotiate values between the application and the source device:

  • One Value: The current value is returned.
  • Enum: A list of legal values along with the current and default values are returned.
  • Range: A range of legal values along with the current and default values are returned.
  • Array: A list of values is returned.

The GetCapability method returns the container as a CapabilityContainer, which can then be casted to the appropriate child object (e.g. CapabilityContainerOneValue, CapabilityContainerEnum, CapabilityContainerRange, and CapabilityContainerArray) to access the capability information.

C# Example Copy Code
// This code demonstrates how to read a value
// Check for support and stop if none
if (twainDevice.IsCapabilitySupported(capability) == false)
{
 labelDefault.Text = "Not Supported";
 labelDefault.Visible = true;
 textBoxCurrent.Enabled = false;
 buttonUpdate.Enabled = false;
 return;
}
else
{
capcontainer = twainDevice.GetCapability(capability);
// What data type is the Cap?  We have to check the data type
// to know which properties are valid
switch (capcontainer.GetType().ToString())
{
 // Type ONEVALUE only returns a single value
 case "Accusoft.TwainProSdk.CapabilityContainerOneValueFloat":
 {
  Accusoft.TwainProSdk.CapabilityContainerOneValueFloat myCap = (CapabilityContainerOneValueFloat)twainDevice.GetCapability(capability);

  textBoxCurrent.Text = myCap.Value.ToString();
  textBoxCurrent.Visible = true;
  break;
 }
 case "Accusoft.TwainProSdk.CapabilityContainerOneValueString":
 {
  Accusoft.TwainProSdk.CapabilityContainerOneValueString myCap = (CapabilityContainerOneValueString)twainDevice.GetCapability(capability);

  textBoxCurrent.Text = myCap.Value;
  textBoxCurrent.Visible = true;
  break;
 }
 // Type ENUM returns a list of legal values as well as current and
 // default values.  A list of constants is returned and the CapDesc
 // property can be used to find out what the constants mean
 case "Accusoft.TwainProSdk.CapabilityContainerEnum":
 {
  Accusoft.TwainProSdk.CapabilityContainerEnum myCap = (CapabilityContainerEnum)twainDevice.GetCapability(capability);

  textBoxCurrent.Text = ((CapabilityContainerOneValueFloat)myCap.CurrentValue).Value.ToString();
  textBoxCurrent.Visible = true;

  labelDefault.Text = "Default  =  " + ((CapabilityContainerOneValueFloat)myCap.DefaultValue).Value.ToString();
  labelDefault.Visible = true;

  listBoxCaps.Items.Add("Legal Values:");

  for (int nIndex = 0; nIndex < myCap.Values.Count; nIndex++)
  {
   float fResult = ((CapabilityContainerOneValueFloat)myCap.Values[nIndex]).Value;

   string strResult = twainDevice.GetCapabilityConstantDescription(capability, nIndex);

   if (strResult == null)
   {
    strResult = "";
   }
   listBoxCaps.Items.Add(fResult.ToString() + " - " + strResult.ToString());
  }
  listBoxCaps.Visible = true;
  break;
 }
 // Type ARRAY returns a list of values, but no current or default values
 // This is a less common type that many Data Sources don't use
 case "Accusoft.TwainProSdk.CapabilityContainerArray":
 {
  Accusoft.TwainProSdk.CapabilityContainerArray myCap = (CapabilityContainerArray)twainDevice.GetCapability(capability);
  listBoxCaps.Items.Add("Legal Values:");
  for (int nIndex = 0; nIndex < myCap.Values.Count; nIndex++)
  {
   float fResult = ((CapabilityContainerOneValueFloat)myCap.Values[nIndex]).Value;
   listBoxCaps.Items.Add(fResult);
  }
  break;
 }
 // Returns a range of values as well as current and default values
 case "Accusoft.TwainProSdk.CapabilityContainerRange":
 {
  Accusoft.TwainProSdk.CapabilityContainerRange myCap = (CapabilityContainerRange)twainDevice.GetCapability(capability);
  textBoxCurrent.Text = myCap.Value.ToString();
  textBoxCurrent.Visible = true;

  labelDefault.Text = "Default  =  " + myCap.Default.ToString();
  labelDefault.Visible = true;

  labelMin.Text = "MinValue  =  " + myCap.Minimum.ToString(); ;
  labelMin.Visible = true;

  labelMax.Text = "MaxValue  =  " + myCap.Maximum.ToString();
  labelMax.Visible = true;
  break;
 }
}

See Also

OpenSession Method
StartSession Method
Capability Enumeration
AdvancedCapability Enumeration
IsCapabilitySupported Method
GetCapability Method
CapabilityContainer Class
CapabilityContainerOneValue Class
CapabilityContainerEnum Class
CapabilityContainerRange Class
CapabilityContainerArray Class


%%ItemTitle%%

Set Capabilities
See Also Send Feedback
TwainPRO 7 for .NET - User Guide > How To > Negotiate Capabilities > Set Capabilities

Glossary Item Box

Capabilities can only be modified, or set, after a TWAIN Session has been opened (OpenSession), and prior to initiating the scanning session (StartSession).

Identifying Capabilities

TWAIN specifies some capabilities to be basic (Capability) and some to be advanced (AdvancedCapability). TwainPRO™ methods are overloaded to support both. An overload is also provided to enable the application to access a capability that is not enumerated in the TwainPRO interface, by specifying an integer value.

Check that the Capability is supported by the Data Source

To determine whether the capability of interest is supported by the TWAIN device, call IsCapabilitySupported.

Set the Capability

If the capability is supported by the TWAIN device, call SetCapability. TWAIN defines four types of containers used to negotiate values between the application and the source device:

  • One Value: The current value is returned.
  • Enum: A list of legal values along with the current and default values are returned.
  • Range: A range of legal values along with the current and default values are returned.
  • Array: A list of values is returned.

The SetCapability method takes as a parameter a CapabilityContainer object. The CapabilityContainerOneValue, CapabilityContainerEnum, CapabilityContainerRange, and CapabilityContainerArray objects can be filled with information and passed to this method to set the value of the container.

C# Example Copy Code
// This code demonstrates setting a single value using the TWON_ONEVALUE container
Accusoft.TwainProSdk.CapabilityContainerOneValueFloat myCap = new CapabilityContainerOneValueFloat(Capability.TwonBitDepth);
myCap.Value = (float)CapabilityConstants.TwptBW;
twainDevice.SetCapability(myCap);

The other containers can be used to set a new range or set of legal values for a capability. These can be used to restrict the choices available to a user when the UI is presented.

C# Example Copy Code
// This code demonstrates how to request that the Data Source only allow resolutions in the range of 100 to 400 dpi (assuming the ICAP_UNITS capability is set to inches)

Accusoft.TwainProSdk.CapabilityContainerRange myCap = new CapabilityContainerRange(Capability.IcapXResolution);
myCap.Value = 100;
myCap.Minimum = 100;
myCap.Maximum = 400;
twainDevice.SetCapability(myCap);
Sources are not required to allow their values to be restricted by the application, so support of this feature varies widely. Some devices will ignore these parameters completely, while others may only allow it for certain capabilities. For instance, a device may allow ICAP_PIXELTYPE to be restricted to black and white images, but won’t allow ICAP_XRESOLUTION to be restricted to the range shown in the above example.

See Also

OpenSession Method
StartSession Method
Capability Enumeration
AdvancedCapability Enumeration
IsCapabilitySupported Method
SetCapability Method
CapabilityContainer Class
CapabilityContainerOneValue Class
CapabilityContainerEnum Class
CapabilityContainerRange Class
CapabilityContainerArray Class


%%ItemTitle%%

Set Image DPI
See Also Send Feedback
TwainPRO 7 for .NET - User Guide > How To > Negotiate Capabilities > Set Image DPI

Glossary Item Box

Image Resolution can only be modified, or set, after a TWAIN Session has been opened (OpenSession), and prior to initiating the scanning session (StartSession).

One capability that is often set by the application is the desired DPI of the scanned image. To set the DPI for scanned images, use the TWAIN capabilities: ICAP_XRESOLUTION and ICAP_YRESOLUTION.

It is important to set the ICAP_UNITS capability equal to TWUN_INCHES prior to setting the resolution capabilities.
C# Example Copy Code
// This code demonstrates how to set the DPI of scanned images to 300 DPI
Accusoft.TwainProSdk.CapabilityContainerOneValueFloat myCap = new CapabilityContainerOneValueFloat(Capability.IcapUnits);
myCap.Value = (float)Accusoft.TwainProSdk.CapabilityConstants.TwunInches;
twainDevice.SetCapability(myCap);

myCap = new CapabilityContainerOneValueFloat(Capability.IcapXResolution);
myCap.Value = 300;
twainDevice.SetCapability(myCap);

myCap = new CapabilityContainerOneValueFloat(Capability.IcapYResolution);
myCap.Value = 300;
twainDevice.SetCapability(myCap);

See Also

OpenSession Method
StartSession Method


%%ItemTitle%%

Acquire Images and Image Information
Send Feedback
TwainPRO 7 for .NET - User Guide > How To > Acquire Images and Image Information

Glossary Item Box

This section provides information about the following:

  • Define a Caption
  • Specify Image Layout
  • Initiate a Scanning Session
  • Transfer & Save Images
  • Fast Saving Multi-page TIFF Files
  • Access Extended Image Information
  • Multiple Image Acquisition


%%ItemTitle%%

Define a Caption
See Also Send Feedback
TwainPRO 7 for .NET - User Guide > How To > Acquire Images and Image Information > Define a Caption

Glossary Item Box

A caption is text that is placed on a still frame when scanning. TwainPRO™ enables the user to define a caption to be placed on all scanned images. When a caption is applied during scanning, it becomes a part of the scanned image data, and is no longer separable from the image.

To define a caption, set the TwainDevice.Caption property to specify the text, appearance, and location of the caption. During the scanning session, the caption will be applied to all acquired images.

If no caption is needed, ensure that the Caption property is set to null (the default value) prior to StartSession.

Caption can only be modified, or set, prior to initiating the scanning session (StartSession).

See Also

Caption Class
StartSession Method


%%ItemTitle%%

Specify Image Layout
See Also Send Feedback
TwainPRO 7 for .NET - User Guide > How To > Acquire Images and Image Information > Specify Image Layout

Glossary Item Box

The desired layout for scanned images can be specified prior to initiating a scanning session, by setting the TwainDevice.ImageLayout property. The ImageLayout rectangle defines what portion of the Data Source's scanning area is acquired.

It is also a good idea to set the ICAP_UNITS capability for the scanner prior to using the ImageLayout method to specify the unit of measure you'll be using.
C# Example Copy Code
// This code demonstrates how to set the Image Layout rectangle to 6.5 inches X 9 inches
twainDevice.ImageLayout = new RectangleF(1, 1, 6.5F, 9);
ImageLayout can only be modified, or set, prior to initiating the scanning session (StartSession) and after opening a session (OpenSession).

See Also

ImageLayout Property
StartSession Method


%%ItemTitle%%

Initiate a Scanning Session
See Also Send Feedback
TwainPRO 7 for .NET - User Guide > How To > Acquire Images and Image Information > Initiate a Scanning Session

Glossary Item Box

Prior to initiating a scanning session, the following should be done:

  • Open a TWAIN Session
  • Negotiate Capabilities
  • Define a Caption (if desired)
  • Specify Image Layout

Once a Scanning session has been initiated (StartSession), capabilities, caption, and layout can be checked, but can no longer be modified.

Initiate Scanning Using the Data Source UI

To enable the application end user to initiate image acquisition, ensure that the TwainDevice.ShowUserInterface property is set to True. Then call the StartSession method.

The Data Source User Interface then displays the current or default Data Source User Interface for image acquisition.

C# Example Copy Code
// This code demonstrates how to select the Data Source UI and then acquire an image from the Data Source
private void cmdScan_Click(object sender, EventArgs e)
{
 twainDevice.SelectSource();
 twainDevice.ShowUserInterface = true
 twainDevice.StartSession();
}

// After the image is acquired you can place it into the windows clipboard then into other applications
// or controls.
public void twainDevice_Scanned(object sender, Accusoft.TwainProSdk.ScannedEventArgs e)
{
 try
 {
  e.ScannedImage.CutToClipboard();
 }
 catch (Accusoft.TwainProSdk.TwainProException ex)
 {
  ErrorLabel.Text = ex.Message;
 }
}

Initiate Scanning Without Using the Data Source UI

The TwainDevice.ShowUserInterface property is used to set the Data Source User Interface visibility to True or False. To hide the Data Source's User Interface, you must use the TwainPRO session methods. The ShowUserInterface property has to be set before calling the StartSession method.

When acquiring an image without the Data Source User Interface, you must take into account that the default image size and resolution capabilities may create a very large image and your system may not have enough memory for the image transfer. Check the image height, width, and resolution settings using the ImageLayout property and ICAP_XRESOLUTION capability respectively. If these values are outside of your parameters then you can change them with the ImageLayout property and SetCapability method.

See Also

Open a TWAIN Session
Negotiate Capabilities
Define a Caption
Specify Image Layout
StartSession Method
ShowUserInterface Property
ImageLayout Property


%%ItemTitle%%

Transfer & Save Images
See Also Send Feedback
TwainPRO 7 for .NET - User Guide > How To > Acquire Images and Image Information > Transfer & Save Images

Glossary Item Box

Once a scanning session has been initiated by calling StartSession, one or more images can be scanned by the Data Source, transferred from the Data Source to the application, and saved by the application to file or memory.

Check for Pending Transfers

Prior to initiating a transfer of a scanned image from the Data Source to the application, TwainPRO™ raises a Scanning event. The PendingTransfers property will contain the number of images the Data Source has ready for transfer. If the Data Source doesn't know how many images are ready for transfer, PendingTransfers will be equal to -1. TWAIN Data Sources with Automatic Document Feeders (ADF) will return PendingTransfers equal to -1. Such devices will transfer images until the feeder is empty.

Transfer Images from Data Source to Application

Upon proceeding from the Scanning event, pending images will be transferred from the Data Source to the application.

Save Scanned Images

When the transfer of each image is complete, TwainPRO raises a Scanned event. This event is the trigger to save the image to file or memory.

During the Scanned event, the ScannedImage property contains the latest scanned image. This information will be lost once the transfer of another image is initiated. Therefore, the application must select a method for saving the scanned image prior to initiating the next scan:

  • To save this image to file or stream, first specify instructions for saving, by creating and setting a SaveOptions object. (If the target file format allows multi-page files, ensure that the MultiPage property is set as desired.) Then invoke the ScannedImage.SaveFile or SaveStream methods to save the file according to the properties set.
  • To move the data to an ImagXpress® control, assign the TwainPRO hDIB to ImagXpress hDIB, using the ToBitmap, ToHbitmap, or ToHdib methods.
  • You may also move the data to the Window's Clipboard with the CopyToClipboard or CutToClipBoard methods.

Finish Scanning

Upon exiting the Scanned event, the acquisition process continues, by triggering another Scanning event. Setting the Cancel parameter in the Scanning or Scanned events will terminate the scanning session.

C# Example Copy Code
// This code demonstrates how to save to a multi-page file
public void SaveMultipage()
{
       mySaveOptions = new Accusoft.TwainProSdk.SaveOptions();
       // Note also that PDF files can be saved as multipage files
       // and this could be done by setting mySaveOptions.Pdf.MultiPage to true
       // and setting mySaveOptions.Format to Pdf.
       mySaveOptions.Format = Accusoft.TwainProSdk.ScannedImageFormat.Tiff;
       mySaveOptions.Tiff.MultiPage = true;
       outputFile = System.IO.Path.Combine(System.Environment.CurrentDirectory, "..\\..\\multipage.tif");
       twainDevice.StartSession();
}

        public void twainDevice_Scanned(object sender, Accusoft.TwainProSdk.ScannedEventArgs e)
        {
            try
            {
                e.ScannedImage.SaveFile(outputFile, mySaveOptions);
            }
            catch (Accusoft.TwainProSdk.TwainProException ex)
            {
                MessageBox.Show(ex.Message);
            }
        }
C# Example Copy Code
private void TransferData()
        {
            // This code demonstrates how to successfully negotiate the transfer mode and to transfer data in a compressed format
            twainDevice.TransferMode = Accusoft.TwainProSdk.TransferMode.TwsxMemory;
            twainDevice.OpenSession();
            if (twainDevice.TransferMode == TransferMode.TwsxMemory)
            {
                AdvancedCapability capability = AdvancedCapability.IcapCompression;
                CapabilityContainer capcontainer = twainDevice.GetCapability(capability);
                // Only do the following if the Capability is supported and
                // there is more than one compression type to set. Otherwise,
                // the data source may say they support this capability but
                // might return an error if you try to set to TWCPNONE and
                // it is the only type. All data sources must support TWCPNONE.
                if (twainDevice.IsCapabilitySupported(capability) && comboBoxCompression.Items.Count > 1)
                {
                    CapabilityContainerOneValueFloat myCap = new CapabilityContainerOneValueFloat(capability);
                    myCap.Value = (float)AdvancedCapabilityCompression.TwcpJpeg;
                    twainDevice.SetCapability(myCap);
                    // Set the JPEG Quality factor
                    AdvancedCapability capjpeg = AdvancedCapability.IcapJpegPixelType;
                    CapabilityContainer capjpegcontainer = twainDevice.GetCapability(capjpeg);

                    // Normally then you would negotiate the ICAP_JPEGPIXELTYPE
                    // and ICAP_JPEGQUALITY capabilities.
                    // Using the defaults for both of these values.
                }
                else
                {
                 twainDevice.TransferMode = Accusoft.TwainProSdk.TransferMode.TwsxNative;
                 labelStatus.Text = "TwainPRO forced to Native Transfer Mode. Compression unavailable.";
                }
            }
            else
            {
                twainDevice.TransferMode = Accusoft.TwainProSdk.TransferMode.TwsxMemory;
                labelStatus.Text = "TwainPRO forced to Native Transfer Mode. Compression unavailable.";
            }

            twainDevice.StartSession();
        }
        // A simple typical Scanned event handler.
        public void twainDevice_Scanned(object sender, Accusoft.TwainProSdk.ScannedEventArgs e)
        {
            try
            {
                // Need to check the Compression type to see if we are transferring a DIB
                // or we are transferring compressed data.
                if (e.ScannedImage.ScannedImageData.Compression == ScannedImageCompression.TwcpNone)
                {
                    int hImage = e.ScannedImage.ToHdib().ToInt32();
                    if (hImage != 0)
                    {
                        imageXView1.Image = Accusoft.ImagXpressSdk.ImageX.FromHdib(imagXpress1,
                     (System.IntPtr)hImage);
                    }
                }
                else
                {
                    int hImage = e.ScannedImage.ToHbitmap().ToInt32();
                    if (hImage != 0)
                    {
                        imageXView1.Image = Accusoft.ImagXpressSdk.ImageX.FromHbitmap(imagXpress1,
                     (System.IntPtr)hImage);
                        GlobalFree(hImage);
                    }
                }
                e.Cancel = false;
            }
            catch (Accusoft.ImagXpressSdk.ImagXpressException ex)
            {
                MessageBox.Show(ex.Message);
            }
            catch (Accusoft.TwainProSdk.TwainProException ex)
            {
                MessageBox.Show(ex.Message);
            }
            catch (System.Exception ex)
            {
                MessageBox.Show(ex.Message);
            }
        }

See Also

StartSession Method
Scanning Event
PendingTransfers Property
Scanned Event
ScannedImage Property
SaveOptions Class
MultiPage Property
SaveFile Method
SaveStream Method
CopyToClipboard Method
CutToClipboard Method


%%ItemTitle%%

Fast Saving Multi-page TIFF Files
See Also Send Feedback
TwainPRO 7 for .NET - User Guide > How To > Acquire Images and Image Information > Fast Saving Multi-page TIFF Files

Glossary Item Box

This topic discusses the fast saving of multi-page TIFF files generally over 1000 pages.

When the UseIFDOffset property is false (default), the image is appended to the end of the multi-page TIFF. Due to the linked format of TIFF, the software must traverse all the link pointers to identify the location to which the new page will be appended. The greater the number of pages in the target TIFF file, the longer the write process takes. (Typically, if the target file has more than 1000 pages, the write speed will degrade substantially.)

Setting the UseIFDOffset property to true specifies that the control should write the image to the location stored in the IFDOffset property. This enables much faster writing of TIFF files with many pages because the software can seek to that location without traversing all previous pointer links. This process gives very predictable speeds in adding pages to a multi-page TIFF file.

If the file's IFDOffset ever became out of sync with the IFDOffset property value, file corruption could occur. To protect the application from inadvertently corrupting a saved mutli-page file, the Twain PRO 6 control takes the following measures:
  • If the application sets the UseIFDOffset property to true or false, the IFDOffset property is automatically set to zero. The application must then explicitly set the IFD Offset to be used.
  • Executing the SaveFile method will automatically set the UseIFDOffset property to false. The application must then explicitly set the value back to true as needed.
  • When the IFDOffset property is zero, a normal write (not fast TIFF write) will occur regardless of the UseIFDOffset value. The fast write will take place only when IFDOffset is set to non-zero and the UseIFDOffset is set to true.
C# Example Copy Code
// This code demonstrates how to use the UseIFDOffset and IFDOffset properties to safely enable fast TIFF writing

        private Accusoft.TwainProSdk.TwainDevice twainDevice;
        Accusoft.TwainProSdk.SaveOptions mySaveOptions;
        int myIfdOffset = 0;

        public void SaveMultipageTifUsingIfd()
        {
            try
            {
                mySaveOptions.Tiff.MultiPage = true;
                outputFile = System.IO.Path.Combine(System.Environment.CurrentDirectory, "..\\..\\ifd.tif");
                twainDevice.StartSession();
            }
            catch (Exception ex)
            {
                MessageBox.Show(ex.ToString());
            }
        }

        public void twainDevice_Scanned(object sender, Accusoft.TwainProSdk.ScannedEventArgs e)
        {
            try
            {
                mySaveOptions.Tiff.UseIFDOffset = true;
                mySaveOptions.Tiff.IFDOffset = myIfdOffset;
                e.ScannedImage.SaveFile(outputFile, mySaveOptions);
                myIfdOffset = mySaveOptions.Tiff.IFDOffset;
            }
            catch (Exception ex)
            {
                MessageBox.Show(ex.Message);
            }
        }

See Also

UseIFDOffset Property
IFDOffset Property


%%ItemTitle%%

Access Extended Image Information
See Also Send Feedback
TwainPRO 7 for .NET - User Guide > How To > Acquire Images and Image Information > Access Extended Image Information

Glossary Item Box

What is Extended Image Information?

Extended image information is used to pass information such as barcodes or patch codes found on a scanned page. See the TWAIN specification for additional information on Extended Image Information available for retrieval.

The TWAIN Data Source must be compliant with version 1.7 or higher of the TWAIN specification for accessing this extended information.

Extended Image Information

The extended image information is accessed during the Scanned event, by getting the ScannedImage, and calling the ScannedImage.GetExtendedImageInfo method. The returned ExtendedImageInfoContainer includes the extended information available for that image. To access the information within the ExtendedImageInfoContainer, the application must cast this object to the appropriate child object: ExtendedImageInfoContainerValueCollection, ExtendedImageInfoContainerValueFloat, or ExtendedImageInfoContainerValueString.

C# Example Copy Code
// This code demonstrates how to access the TWEI_BARCODEX extended image information and add all of the information for a scanned page to a list box
public void twainDevice_Scanned(object sender, Accusoft.TwainProSdk.ScannedEventArgs e)
{
 try
 {
  ExtendedImageInfoContainer extendedImageInfo = e.ScannedImage.GetExtendedImageInfo(ExtendedImageInfo.TweiBarcodeX);
  ExtendedImageInfoContainerValueCollection theValues = extendedImageInfo.Values;
  int i = 0;
  for (i = 0; i < theValues.Count; i++)
  {
   ExtendedImageInfoContainerValueFloat extendedImageInfoFloat = (ExtendedImageInfoContainerValueFloat)theValues[i];
   listBox1.Items.Add(extendedImageInfoFloat.Value.ToString());
  }
 }
 catch (Accusoft.TwainProSdk.TwainProException ex)
 {
  ErrorLabel.Text = ex.Message;
 }
}

See Also

Scanned Event
ScannedImage Property
GetExtendedImageInfo Method
ExtendedImageInfoContainer Class
ExtendedImageInfoContainerValueCollection Class
ExtendedImageInfoContainerValueFloat Class
ExtendedImageInfoContainerValueString Class


%%ItemTitle%%

Multiple Image Acquisition
See Also Send Feedback
TwainPRO 7 for .NET - User Guide > How To > Acquire Images and Image Information > Multiple Image Acquisition

Glossary Item Box

The StartSession method is all that’s needed to start a multiple image session. After calling the StartSession, the Scanning event will fire when images are ready to be transferred. The PendingTransfers property of the ScanningEventArgs will contain the number of images the Data Source has ready for transfer to TwainPRO™. When the transfer is complete, TwainPRO raises the Scanned event.

After each complete transfer, the ScannedImage property of the ScannedEventArgs contains new image data. Save the image data to a file using the SaveFile method of the ScannedImage. To move the data to an ImagXpress® control, use the ToHdib method of ScannedImage to access the handle to the DIB and pass it to the ImagXpress FromHdib method.

C# Example Copy Code
// This code demonstrates how to pass the scanned image from TwainPRO to ImagXpress

public void twainDevice_Scanned(object sender, Accusoft.TwainProSdk.ScannedEventArgs e)
{
 try
 {
  imageXView1.Image = Accusoft.ImagXpressSdk.ImageX.FromHdib(imagXpress1, e.ScannedImage.ToHdib(), true);
 }
 catch (Accusoft.TwainProSdk.TwainProException ex)
 {
  ErrorLabel.Text = ex.Message;
 }
}

You may also move the data to the Window's Clipboard with the CutToClipboard or CopyToClipboard method of the ScannedImage.
Each Scanned event will change the image data. Image data from a previous acquire will be lost after each image transfer.

Check the PendingTransfers property in the Scanning or Scanned event to see if there are more images to acquire. A value of -1 for PendingTransfers means the Data Source does not know how many images there are. TWAIN Data Sources with Automatic Document Feeders (ADF) will return PendingTransfers equal to -1. Such devices will transfer images until the feeder is empty.

You can cancel a multiple image acquire by setting the Cancel parameter to True in either the Scanning or Scanned events. This will cancel all pending transfers and end the session.

C# Example Copy Code
// This code demonstrates how to start a TWAIN session and save each scanned image until there are no pending transfers from the Data Source

private void cmdScanWith_Click(object sender, EventArgs e)
{
 scanCount = 0;
 twainDevice.StartSession();
}

public void twainDevice_Scanned(object sender, Accusoft.TwainProSdk.ScannedEventArgs e)
{
 try
 {
  pictureBox1.Image = e.ScannedImage.SaveFile("c:\\ScannedImage" + scanCount.ToString() + ".tiff");
  scanCount++;
 }
 catch (Accusoft.TwainProSdk.TwainProException ex)
 {
  ErrorLabel.Text = ex.Message;
 }
}

See Also

StartSession Method
Scanning Event
PendingTransfers Property
ScanningEventArgs Class
Scanned Event
ScannedImage Property
SaveFile Method
ToHdib Method
CutToClipboard Method
CopyToClipboard Method
Cancel Property


%%ItemTitle%%

Pass Image Data between Accusoft Components
Send Feedback
TwainPRO 7 for .NET - User Guide > How To > Pass Image Data between Accusoft Components

Glossary Item Box

Traditionally, transferring image data between Accusoft components has required passing the image data in a DIB format. But, beginning with the release of ImagXpress 11, we are adding new methods throughout our products which allow you to easily copy or transfer image data between different Accusoft objects with just a single method call.

Regardless of its product or component assembly, any Accusoft image class which supports easily sending its image data to another Accusoft object will implement two methods: CopyTo(object destination) and TransferTo(object destination). And any Accusoft image class which supports easily receiving this image data (that is, being the destination object) will be noted in its class documentation.

A CopyTo method makes a complete copy of the image data. When called, both the source and destination objects will contain their own separate copies of identical image data. A TransferTo method, on the other hand, completely transfers the image data from one object to another. When finished, the source object will no longer contain image data; the image will be owned by the destination object.

Within the ImagXpress Suite

Within the ImagXpress suite of components, there are four classes which support sending their image data via CopyTo and TransferTo methods:

  1. ImagXpress - Accusoft.ImagXpressSdk.ImageX
  2. TwainPRO - Accusoft.TwainProSdk.ScannedImage
  3. ISIS Xpress - Accusoft.ISISXpressSdk.Output
  4. ThumbnailXpress - Accusoft.ThumbnailXpressSdk.ThumbnailItem

And within the ImagXpress suite of components, there is only one class which supports receiving image data: the ImagXpress ImageX class.

Other Accusoft products may contain additional classes which can send and receive image data.

How to Transfer Image Data from TwainPRO to ImagXpress

Here's an example that scans an image with TwainPRO and then transfers the image data to ImagXpress for further processing before being saved.

C# Example Copy Code
using Accusoft.ImagXpressSdk; using Accusoft.TwainProSdk;

namespace ConsoleExample
{
    class Program
    {
        static void Main(string[] args)
        {
            using (TwainPro twainPro = new TwainPro())
            using (TwainDevice twainDevice = new TwainDevice(twainPro))
            {
                twainDevice.Scanned += new ScannedEventHandler(twainDevice_Scanned);
                twainDevice.SelectSource();
                twainDevice.StartSession();
            }
        }

        static void twainDevice_Scanned(object sender, ScannedEventArgs e)
        {
            using (ImagXpress ix = new ImagXpress())
            using (ImageX image = new ImageX(ix))
            using (Processor processor = new Processor(ix))
            {
                //Transfer the scanned image data from TwainPRO to ImagXpress
                e.ScannedImage.TransferTo(image);

                //Process and save the image with ImagXpress
                processor.Image = image;
                processor.Negate();
                image.Save("inverted-scan.bmp");
            }
        }
    }
}

In the above example, we transfer the scanned image to an ImagXpress ImageX object named image. Once that is done, we can use any of the processing features of ImagXpress to manipulate the scanned image data. In this case we simply create a color negative of the image data and then save it to disk as "inverted-scan.bmp".


%%ItemTitle%%

End a TWAIN Session
See Also Send Feedback
TwainPRO 7 for .NET - User Guide > How To > End a TWAIN Session

Glossary Item Box

The TWAIN Session can be ended at any point. The actions to be taken depend on the state of the session.

During Data Source Selection

OpenDataSourceManager or SelectSource has previously been called to open the Data Source Manager. Call CloseSession to close the Data Source Manager and terminate the TWAIN session.

During Capability Negotiation

OpenSession has previously been called to open the Data Source Manager and Data Source. Call CloseSession to close the Data Source and Data Source Manager and terminate the TWAIN session.

During a Scanning Session

StartSession has previously been called to begin a scanning session.

The TWAIN session can be terminated during the Scanning or Scanned event by setting the Cancel parameter.

See Also

OpenDataSourceManager Method
SelectSource Method
CloseSession Method
OpenSession Method
StartSession Method
Scanning Event
Scanned Event
Cancel Property


%%ItemTitle%%

Debug
See Also Send Feedback
TwainPRO 7 for .NET - User Guide > How To > Debug

Glossary Item Box

1 - I am encountering a problem with a TWAIN Device.

If you have a problem with a TWAIN device we recommend trying the following things:

  1. Get the latest version of the scanner's drivers from the manufacturer's web site and re-install them.

  2. Get the latest TWAIN Data Source Manager files from www.Twain.org and put them in your windows directory (NOT the windows\system directory). Also, make sure you don't have older versions of those DLLs or EXEs anywhere else in your path.

  3. Make sure you have the latest version of TwainPRO™.

  4. If you still have a problem with a particular scanner, let us know, but remember, not all TWAIN capabilities are supported by all devices and there are TWAIN drivers out there that have bugs in them and are not fully TWAIN compliant.

2 - It appears that setting a capability has no effect on the scanned image.

There are a couple of reasons this issue may be occurring:

Resolution 1:

Please make sure that you call OpenSession before setting the capabilities. For example:

Example Copy Code
ICAP
TwainPRO1.SelectSource
TwainPRO1.ShowUI = False
TwainPRO1.OpenSession

Resolution 2:

Not all TWAIN devices support all TWAIN capabilities. Because of this, you must check to see if a TWAIN capability is supported by your device before setting it.

To do this, TwainPRO™ provides a method called IsCapabilitySupported, which will return True if the capability is supported and False if not. Note that if a scanner supports a capability, it might only support getting it and does not necessarily support setting it.

Below is an example of how to check this property:

Example Copy Code
if (twainDevice.IsCapabilitySupported(Capability.IcapPixelType) == true)
{
// If the capability is supported this code will be executed.
}

3 - I want to drive a scanner via the Kofax VRS TWAIN driver without using the Kofax TWAIN UI.

Kofax VirtualReScan (VRS) works best with an ISIS driver and only supports some scanners with TWAIN drivers. Documentation for Kofax VRS can be found at www.kofax.com/support/IP/VRS/4.1/4.1_downloads.asp#ProductDocumentation .

Error Codes

This section includes error codes and extended error codes.

7000

TwainException

TWAIN error, check ErrorCode & ErrorString properties.

The Data Source has returned an error. Check the ErrorCode and ErrorString properties to see if the Data Source has returned an error code.

7001

TwainDllLoadException

Can't find or load TWAIN DSM (TWAINDSM.dll, Version 2).

The 32-bit version should be installed in the SYSTEM32 directory on native 32-bit Windows systems. On native 64-bit Windows systems, the 32-bit version should be installed in the SYSWOW64 directory. The latest version can be found at www.twain.org.

Possible causes:

The file is missing.

The file is in use by another application.

7002

FileOpenException

TwainPRO can’t open an existing TIF file to append pages.

Possible causes:

The file is open in another control or application.

The file is read-only

7003

OutOfMemoryException

TwainPRO was unable to allocate memory for the requested operation.

Possible causes:

The image being transferred is too large to fit in memory.

Too many applications are open.

7004

OperationCancelledException

The user cancelled the requested operation.

Possible causes:

The user clicked the cancel button on the source selection dialog invoked by the SelectSource method.

7005

FileCreateException

TwainPRO was unable to create the file specified in the SaveFile method.

Possible causes:

The drive or path specified doesn’t exist.

The file exists and is in use by another application.

No file extension or an invalid file extension was specified.

7006

FileWriteException

An error occurred while TwainPRO was attempting to save a file to the path specified in the SaveFile method.

Possible causes:

The drive or path became invalid during the write. This can occur if the drive is a network drive.

The disk is full.

7007

UnsupportedFileFormatException

A file extension for specified for a file type not supported by TwainPRO. Supported file types are: BMP,

JPEG, ePIC, and TIF.

7008

StringIsTooLongException

A string with too many characters was set to a TwainPRO property.

Possible causes:

The application identity properties can accept a maximum length of 32 characters.

The PICPassword property can accept a maximum length of 8 characters.

7009

ValueOutOfRangeException

The value is out of range. An invalid value was set to a TwainPRO property.

Possible causes:

Many TwainPRO properties can only accept values in a specified range. For example, the SaveJPEGLumFactor property must be in the range 0-255.

7010

ImageNotAvailableException

No image is available for the requested operation or an unsupported DIB format was returned in response to a StartSession.

Possible causes:

The hDIB property has already been read.

The SaveFile method was invoked after the hDIB property was read.

7011

PegasusFilesNotInstalledException

The required Accusoft dll file(s) are missing.

Possible causes:

Accusoft dll files are required when saving JPEG, ePIC, or TIF files. They are listed in the dependencies section.

7012

InternetFilesNotInstalledException

The required Internet dll file(s) are missing.

Possible causes:

The following files are not present on the system. These files are not shipped with TwainPRO and are not needed unless an FTP address is specified in the SaveFile method. These files are included with other software such as Internet Explorer, and if the machine has a TCP/IP connection, it should have these files.

wininet.dll

urlmon.dll

7013

FtpTransferException

An error occurred trying to FTP an image.

Possible causes:

The machine is not currently connected to a network. The FTPUserName and/or FTPPassword properties are not correct for the requested host specified in the SaveFile method.

The host and or path specified in the SaveFile method doesn’t exist.

The path was not specified in the SaveFile method. A fully qualified URL containing both the servername and file path must be specified. For example, "http://ftp.myserver.com/ftp/public/test.jpg" contains both the server and file information, but "http://ftp.myserver.com" does not.

7014

SequenceException

Illegal operation for current Source Manager or Source state. The requested action cannot be performed in the current state of the TWAIN session.

Possible causes:

Certain methods and properties are only valid during certain states. For example, the DataSourceList property is invalid unless the OpenDSM method was called to open the Data Source Manager.

7015

IndexOutOfRangeException

The requested index was out of range for the property array.

7016

InvalidPropertyException

A property was set or queried that was not valid for the current capability type. Please see the Capability Negotiation section for more information.

7017

ClipboardException

An error occurred trying to open the clipboard with the CopyToClipboard or CutToClipboard method.

Possible causes:

Another application has the clipboard open.

7018

InternalErrorException

Internal error.

7019

InvalidBitDepthException

Invalid image resolution for selected file format or an unsupported bits per pixel was returned from a StartSession.

Possible causes:

Tried to save a 1-bit or Black and White image to a jpg or pic file.

7020

PropertyOrMethodNotAvailableException

The property requested is not currently available.

Possible causes:

This error is returned when the CapAdvanced property is being used and the requested capability function is not available. For instance, this error will be returned when the Capability property is set to ICAP_USECAPADVANCED and the property CapDesc is accessed. The CapDesc property is only available for the enumerated Capability values. Also this error will be returned when the Capability property is set to ICAP_USECAPADVANCEDFOREXTINFO and the CapOut properties are accessed.

7021

CompressedImageNotAvailableException

No compressed image is available for the requested operation or an unsupported compressed image format was returned in response to a StartSession.

Possible causes:

The hImage property has already been read.

The SaveFile method was invoked after the hImage property was read.

7022

DataSourceInvalidOperationException

The Data Source performed an operation that caused an exception. This error is a critical error. If this error is received then the application should be terminated immediately. No other TwainPRO calls should be made after this error is received. This does give the application the chance to do any non-TWAIN clean-up processing as well as inform the user that a critical error has occurred.

Possible causes:

The Data Source TWAIN driver executed an illegal operation, such as an illegal memory access, a divide by zero, etc.

7023

InvalidLicenseException

Invalid license.

7024

TiffTagNotFoundException

TIFF tag not found.

7025

TiffTagItemNotFoundException

TIFF tag item not found.

7026

FileReadException

Error reading file.

7027

LoadSettingsException

An error occurred while initializing the settings file reader system.

7028

LoadSettingsException

An error occurred while terminating the settings file reader system.

7029

LoadSettingsException

An error occurred when opening the settings file.

7030

LoadSettingsException

The TwainDevice Name attribute was not found in the settings file.

7031

LoadSettingsException

Settings for the current scanner were not found in the settings file.

7032

LoadSettingsException

The Capability Enum attribute was not found in the settings file.

7033

LoadSettingsException

Invalid file name.

7034

FileNotFoundException

The specified file was not found for the current LoadOptions operation.

7035

LoadSettingsException

The specified path of the filename was not found.

7036

LoadSettingsException

The file is in use by another process and cannot be opened.

7037

IOExceptionException

The file close operation could not be completed.

7038

IOExceptionException

The file reset operation could not be completed.

7039

LoadSettingsException

The Capability Type attribute was not found in the settings file.

7040

CapabilityNotSupportedException

The Capability is not supported.
7101 | TwainDllLoadException | Can't find or load TWAIN DSM (twain_32.dll, Version 1) in the Windows directory. The latest version can be found at www.twain.org.
7102 | TwainDllLoadException | Can't find or load any version of the Twain Data Source Manager. The latest version can be found at www.twain.org.
7103 | TwainDllLoadException | On native 64-bit systems, Version 1 of the DSM (twain_32.dll) can't be used, you must use at least Version 2 (TWAINDSM.dll).
7104 | TwainDllLoadException | Can't find or load TWAIN DSM (TWAINDSM.dll, Version 2). The 64-bit version of TwainDSM.dll should be installed in the SYSTEM32 directory. The latest version can be found at www.twain.org.
7105 | ArgumentException | DataSourceManagerVersion can't be set to None, please choose a valid version to use.
7106 | SourceCompressedImageOnlyException | The image was compressed directly in hardware by the source and not by TwainPro, please use SaveSoureCompressedImageToFile() or SaveSourceCompressedImageToStream() to save the scanned image.
7107 | TwainProCompressedImageOnlyException | Hardware compression isn't available so only TwainPro can compress the image, please use SaveToFile() or SaveToStream() to save the scanned image.
7108 | ValueOutOfRangeException | The JPEG Luminance value is out of range. It should be within the range of 0 to 255.
7109 | ValueOutOfRangeException | The JPEG Chrominance value is out of range. It should be within the range of 0 to 255.
7110 | ValueOutOfRangeException | The JPEG Subsampling value is incorrect. It should be one of the available enumeration values: 111, 211, 411, or 211v.
7111 | ValueOutOfRangeException | The PNG Filter value is incorrect. Please check the enumeration declaration for supported values.

Extended Error Codes

The following are error codes and strings that can be returned in the ErrorCode and ErrorString properties when TwainPRO returns a TWERR_TWAIN error.

1 | TWCC_BUMMER | General failure. Unload Source immediately.
2 | TWCC_LOWMEMORY | Not enough memory to complete operation.
3 | TWCC_NODS | Source Manager unable to find the specified Source.
4 | TWCC_MAXCONNECTIONS | Source is connected to maximum supported number of applications.
5 | TWCC_OPERATIONERROR | Source or Source Manager reported an error to the user and handled the error; no application action required.
6 | TWCC_BADCAP | Capability not supported by Source.
9 | TWCC_BADPROTOCOL | Unrecognized operation triplet.
10 | TWCC_BADVALUE | Data parameter out of supported range.
11 | TWCC_SEQERROR | Illegal operation for current Source Manager or Source state.
12 | TWCC_BADDEST | Unknown destination in DSM_Entry.
13 | TWCC_CAPUNSUPPORTED | Capability not supported by Source.
14 | TWCC_CAPBADOPERATION | Operation not supported on capability.
15 | TWCC_CAPSEQERROR | Capability has dependencies on other capabilities and cannot be operated upon at this time.
16 | TWCC_DENIED | File System operation is denied (file is protected).
17 | TWCC_FILEEXISTS | Operation failed because file already exists.
18 | TWCC_FILENOTFOUND | File not found.
19 | TWCC_NOTEMPTY | Operation failed because directory is not empty.
20 | TWCC_PAPERJAM | Transfer failed because of a feeder error.
21 | TWCC_PAPERDOUBLEFEED | Transfer failed because of a feeder error.
22 | TWCC_FILEWRITEERROR | Error writing the file.
23 | TWCC_CHECKDEVICEONLINE | The device went off-line prior to or during this operation.
24 | TWCC_INTERLOCK | Operation failed because the cover or door is open.
25 | TWCC_DAMAGEDCORNER | Operation failed because the document has a damaged corner.
26 | TWCC_FOCUSERROR | Operation failed because of a focusing error during document capture.
27 | TWCC_DOCTOOLIGHT | Operation failed because the document is too light.
28 | TWCC_DOCTOODARK | Operation failed because the document is too dark.
29 | TWCC_NOMEDIA | Operation failed because no media is present for the source to capture.

See Also

OpenSession Method
IsCapabilitySupported Method


%%ItemTitle%%

TwainPRO 7 for .NET - API Reference
Send Feedback

Glossary Item Box

This API Reference provides detailed information about all TwainPRO public API members.


%%phrase%%

Accusoft.TwainPro7.Net Assembly
See Also Send Feedback

Glossary Item Box

Namespaces

Namespace | Description
Accusoft.TwainProSdk |


$$GETTING_STARTED$$ - %%projecttitle%%

Getting Started
Send Feedback

Glossary Item Box


$$INTRODUCTION$$ - %%projecttitle%%

Introduction
Send Feedback

Glossary Item Box


%%ItemTitle%%

Accusoft.TwainProSdk Namespace
See Also Inheritance Hierarchy Send Feedback

Glossary Item Box

Classes

 | Class | Description
Class | ApplicationIdentity | An object that represents the TWAIN identity of the application.
Class | CapabilityContainer | This class contains the capability information.
Class | CapabilityContainerArray | This class is an array type container for storing capability information.
Class | CapabilityContainerEnum | A class which contains enumeration capability information.
Class | CapabilityContainerFrame | This class implements a capability container for storing a frame value.
Class | CapabilityContainerOneValue | This class implements a one value type container for storing capability information.
Class | CapabilityContainerOneValueCollection | This class implements a collection of CapabilityContainerOneValue objects.
Class | CapabilityContainerOneValueFloat | This class implements a capability container for storing a float value.
Class | CapabilityContainerOneValueString | This class implements a capability container for storing a string value.
Class | CapabilityContainerRange | This class implements a range type container for storing capability information.
Class | CapabilityNotSupportedException | This exception is thrown if an operation is performed using an unsupported capability.
Class | Caption | This class implements an object that stores the settings used to place a caption on images when they are scanned.
Class | ClipboardException | This exception is thrown if an error occurs trying to open the clipboard with the CopyToClipboard or CutToClipboard method.
Class | CompressedImageNotAvailableException | This exception is thrown if no compressed image is available for the requested operation or an unsupported compressed image format was returned in response to a StartSession.
Class | DataSourceCollection | A read-only collection of Data Source product names which is set by calling the OpenDataSourceManager method.
Class | DataSourceInvalidOperationException | This exception is thrown if the Data Source performs an operation that caused an exception.
Class | ExtendedImageInfoContainer | This class implements extended image info.
Class | ExtendedImageInfoContainerValue | This class implements a single value of extended image info.
Class | ExtendedImageInfoContainerValueCollection | This class represents a collection of ExtendedImageInfoContainerValue objects.
Class | ExtendedImageInfoContainerValueFloat | This class implements a float value of extended image info.
Class | ExtendedImageInfoContainerValueString | This class implements a string value of extended image info.
Class | FileCreateException | This exception is thrown if TwainPRO is unable to create the file specified in the Save method.
Class | FileOpenException | This exception is thrown if TwainPRO is unable to open an existing file to append pages when saving a multi-page image file, or if TwainPRO is unable to open a settings file.
Class | FileReadException | This exception is thrown if TwainPRO is unable to read an existing file to append pages when saving a multi-page image file, or if TwainPRO is unable to read a settings file.
Class | FileWriteException | This exception is thrown if an error occurs while TwainPRO is attempting to save a file to the path specified in the Save method, or while TwainPRO is attempting to write a settings file.
Class | FtpOptions | This class implements properties and methods necessary for authentication and remote processing when saving an image.
Class | FtpTransferException | This exception is thrown if an error occurs trying to FTP an image.
Class | ImageNotAvailableException | This exception is thrown if no image is available for the requested operation or an unsupported DIB format was returned in response to a StartSession.
Class | IndexOutOfRangeException | This exception is thrown if the requested index was out of range for the property array.
Class | InternalErrorException | This exception is thrown if an internal failure occurs.
Class | InternetFilesNotInstalledException | This exception is thrown if the required Internet DLL file(s) are missing.
Class | InvalidBitDepthException | This exception is thrown if an invalid image resolution for the selected file format or an unsupported bits per pixel was returned from a StartSession.
Class | InvalidLicenseException | This exception is thrown if a user attempts to access functionality that is not covered under the license in effect.
Class | InvalidPropertyException | This exception is thrown if a property was set or queried that was not valid for the current capability type.
Class | Licensing | This class implements methods for setting the license information for the toolkit.
Class | LoadSettingsException | This exception is thrown if an error occurs when loading a settings file.
Class | OperationCancelledException | This exception is thrown if the user cancelled the requested operation.
Class | OutOfMemoryException | This exception is thrown if TwainPRO is unable to allocate memory for the requested operation.
Class | PegasusFilesNotInstalledException | This exception is thrown if the required Pegasus DLL file(s) are missing.
Class | PropertyOrMethodNotAvailableException | This exception is thrown if the property or method requested is not currently available.
Class | SaveOptions | This class implements file writing of image formats.
Class | SaveOptionsJpeg | Implements SaveOptions for the JPEG file format.
Class | SaveOptionsPdf | This class implements SaveOptions for the PDF file format.
Class | SaveOptionsPic | This class implements objects for saving PIC options.
Class | SaveOptionsPng | This class implements objects for saving Png options.
Class | SaveOptionsTiff | Implements SaveOptions for the TIFF file format.
Class | ScannedEventArgs | Arguments for a scanned event.
Class | ScannedImage | This class implements the scanned image and image information.
Class | ScannedImageData | This class implements objects that contain the scanned image information.
Class | ScanningEventArgs | Arguments for a scanning event.
Class | SequenceException | This exception is thrown if an illegal operation is performed for the current Source Manager or Source state.
Class | SourceCompressedImageOnlyException | This exception is thrown for trying to save the TwainPro-compressed image when hardware compression was used and only the source-compressed image is available.
Class | StringIsTooLongException | This exception is thrown if a TwainPRO property was set to a string with too many characters.
Class | TiffTagItemNotFoundException | This exception is thrown if a TIFF tag item is not found.
Class | TiffTagNotFoundException | This exception is thrown if a TIFF tag is not found.
Class | TwainDevice | This class implements methods and properties for all TWAIN device interaction.
Class | TwainDllLoadException | This exception is thrown if TwainPRO is unable to find or load TWAINDSM.dll.
Class | TwainException | This exception is thrown if a TWAIN error occurs.
Class | TwainPro | The main object for this component.
Class | TwainProCompressedImageOnlyException | This exception is thrown for trying to save the source-compressed image when no hardware compression was used and only the TwainPro-compressed image is available.
Class | TwainProException | This class implements the base class for TwainPro Exceptions.
Class | UnsupportedFileFormatException | This exception is thrown if the default file type is set and a file is saved using the extension of a file format that is not supported by TwainPRO, or if an invalid settings file is loaded. Supported file types are BMP, JPEG, ePIC, TIF, and PDF.
Class | ValueOutOfRangeException | This exception is thrown if a TwainPRO property was set to an invalid value.

Delegates

 | Delegate | Description
Delegate | ScannedEventHandler | A delegate for post-scan events.
Delegate | ScanningEventHandler | A delegate for pre-scan events.

Enumerations

 | Enumeration | Description
Enumeration | AdvancedCapability | Option values which determine the advanced TWAIN capability.
Enumeration | AdvancedCapabilityAlarm | Specifies specific audible alarms.
Enumeration | AdvancedCapabilityAudioFileFormat | The Audio File format.
Enumeration | AdvancedCapabilityAutoSize | Specifies if the output image dimensions should match either the current value of ICAP_SUPPORTEDSIZES or any of its current allowed values.
Enumeration | AdvancedCapabilityBarcodeDetectionSearchMode | Specifies how to restrict barcode searching to certain orientations, or prioritizes one orientation over another.
Enumeration | AdvancedCapabilityBitDepthReduction | Specifies the Reduction Method the Source should use to reduce the bit depth of the data.
Enumeration | AdvancedCapabilityBitOrder | Specifies how the bytes in an image are filled by the Source.
Enumeration | AdvancedCapabilityCameraSide | Specifies the camera used in a scanning device.
Enumeration | AdvancedCapabilityClearBuffers | Specifies how the Source should clear its buffers.
Enumeration | AdvancedCapabilityCompression | Specifies compression schemes the Source and Application have in common for Buffered Memory and File transfers.
Enumeration | AdvancedCapabilityDeviceEvent | Specifies events the Source reports to the Application.
Enumeration | AdvancedCapabilityFeederAlignment | Specifes the feeder alignment used when negotiating frames from the Source.
Enumeration | AdvancedCapabilityFeederOrder | Specifies which page the feeder starts with.
Enumeration | AdvancedCapabilityFeederPocket | Specifies what pockets are available as paper leaves a device.
Enumeration | AdvancedCapabilityFeederType | Specifies scan parameters depending on the type of feeder.
Enumeration | AdvancedCapabilityFileFormat | Specifies which file formats the Source can generate and which the Application can handle.
Enumeration | AdvancedCapabilityFilter | Option values which determine the TWAIN capability constants for advanced capabilities.
Enumeration | AdvancedCapabilityFlash | For devices that support flash, specifies the flash to be used.
Enumeration | AdvancedCapabilityFlipRotation | Specifies how to orient images that flip orientation every other image.
Enumeration | AdvancedCapabilityIccProfile | Specifies the ICC profile and if it can embed or link it in the current ICAP_IMAGEFILEFORMAT.
Enumeration | AdvancedCapabilityImageFilter | For devices that support image filtering, specifies the algorithm to be used.
Enumeration | AdvancedCapabilityJobControl | Specifies settings for multiple jobs in batch mode.
Enumeration | AdvancedCapabilityJpegQuality | Specifies JPEG quantization tables that tradeoff quality versus compressed image size.
Enumeration | AdvancedCapabilityLightPath | Specifies whether the image was captured transmissively or reflectively.
Enumeration | AdvancedCapabilityLightSource | Specifies the general color characteristics of the light source used to acquire the image.
Enumeration | AdvancedCapabilityNoiseFilter | For devices that support noise filtering, specifies the algorithm used to remove noise.
Enumeration | AdvancedCapabilityOverScan | Specifies the overscan which is used to scan outside the boundaries described by ICAP_FRAMES, and is used to help acquire image that may be lost because of skewing.
Enumeration | AdvancedCapabilityPixelFlavor | Specifies the sense of the pixel whose numeric value is zero (minimum data value).
Enumeration | AdvancedCapabilityPlanarChunky | Specifies which color data formats are available to the Source and Application.
Enumeration | AdvancedCapabilityPowerSupply | Specifies the kind of power available.
Enumeration | AdvancedCapabilityPrinter | Settings for available printer devices.
Enumeration | AdvancedCapabilityPrinterMode | Specifies the format of the printed text.
Enumeration | AdvancedCapabilitySegmented | Segmentation settings for captured images.
Enumeration | Capability | Option values which determine the TWAIN capability.
Enumeration | CapabilityConstants | Option values which determine the capability constants.
Enumeration | ConditionCode | Option values which determine TWAIN condition codes.
Enumeration | DataSourceManagerVersion | Specifies what version of the Data Source Manager (DSM) to use.
Enumeration | EncodeModeCompression | Option values which specify the encoding mode to use when creating a JBIG2 compressed file.
Enumeration | ErrorLevel | The error level of items to place into the debug log.
Enumeration | EvaluationMode | Option values which determine the evaluation mode of the component.
Enumeration | ExtendedImageInfo | Option values for extended image info enumeration values.
Enumeration | ExtendedImageInfoConstants | Option values for extended image info constants enumeration values.
Enumeration | FileOrganizationCompression | Option values which determine the file organization when saving a JBIG2 compressed file.
Enumeration | Filter | The filters available for PNG compression.
Enumeration | HorizontalAlignment | Option values which determine the horizontal alignment of the caption within the clipping rectangle.
Enumeration | Orientation | Option values which determine the TWAIN capability constants for the ICAP_ORIENTATION capability.
Enumeration | PdfCompression | Option values which determine the PDF compression.
Enumeration | PixelType | Option values which determine the type of pixel data that a Source is capable of acquiring (for example, black and white, gray, RGB, etc.).
Enumeration | ScannedImageCompression | Option values which determine the compression format of an acquired image.
Enumeration | ScannedImageFormat | Option values which determine the format of the saved file.
Enumeration | SubSampling | Option values which determine the subsampling type for a JPEG, ePIC, JPEG compressed TIFF, or JPEG compressed PDF file format.
Enumeration | SupportedSizes | Option values which determine the TWAIN capability sizes for the ICAP_SUPPORTEDSIZES capability.
Enumeration | TiffCompression | Option values which determine TIFF compression enumeration values.
Enumeration | TransferMode | Option values which determine transferring images from the Data Source.
Enumeration | VerticalAlignment | Option values which determine the vertical alignment of the caption within the clipping rectangle.

See Also

Reference

Accusoft.TwainPro7.Net Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Accusoft.TwainProSdk Namespace Inheritance Hierarchy
See Also Send Feedback

Glossary Item Box

Inheritance Hierarchy

System.Object
Accusoft.TwainProSdk.ApplicationIdentity
Accusoft.TwainProSdk.CapabilityContainer
Accusoft.TwainProSdk.CapabilityContainerArray
Accusoft.TwainProSdk.CapabilityContainerEnum
Accusoft.TwainProSdk.CapabilityContainerOneValue
Accusoft.TwainProSdk.CapabilityContainerFrame
Accusoft.TwainProSdk.CapabilityContainerOneValueFloat
Accusoft.TwainProSdk.CapabilityContainerOneValueString
Accusoft.TwainProSdk.CapabilityContainerRange
Accusoft.TwainProSdk.Caption
Accusoft.TwainProSdk.ExtendedImageInfoContainer
Accusoft.TwainProSdk.ExtendedImageInfoContainerValue
Accusoft.TwainProSdk.ExtendedImageInfoContainerValueFloat
Accusoft.TwainProSdk.ExtendedImageInfoContainerValueString
Accusoft.TwainProSdk.FtpOptions
Accusoft.TwainProSdk.Licensing
Accusoft.TwainProSdk.SaveOptions
Accusoft.TwainProSdk.SaveOptionsJpeg
Accusoft.TwainProSdk.SaveOptionsPdf
Accusoft.TwainProSdk.SaveOptionsPic
Accusoft.TwainProSdk.SaveOptionsPng
Accusoft.TwainProSdk.SaveOptionsTiff
Accusoft.TwainProSdk.ScannedImage
Accusoft.TwainProSdk.ScannedImageData
Accusoft.TwainProSdk.TwainDevice
System.ApplicationException
System.Exception
Accusoft.TwainProSdk.TwainProException
Accusoft.TwainProSdk.CapabilityNotSupportedException
Accusoft.TwainProSdk.ClipboardException
Accusoft.TwainProSdk.CompressedImageNotAvailableException
Accusoft.TwainProSdk.DataSourceInvalidOperationException
Accusoft.TwainProSdk.FileCreateException
Accusoft.TwainProSdk.FileOpenException
Accusoft.TwainProSdk.FileReadException
Accusoft.TwainProSdk.FileWriteException
Accusoft.TwainProSdk.FtpTransferException
Accusoft.TwainProSdk.ImageNotAvailableException
Accusoft.TwainProSdk.IndexOutOfRangeException
Accusoft.TwainProSdk.InternalErrorException
Accusoft.TwainProSdk.InternetFilesNotInstalledException
Accusoft.TwainProSdk.InvalidBitDepthException
Accusoft.TwainProSdk.InvalidLicenseException
Accusoft.TwainProSdk.InvalidPropertyException
Accusoft.TwainProSdk.LoadSettingsException
Accusoft.TwainProSdk.OperationCancelledException
Accusoft.TwainProSdk.OutOfMemoryException
Accusoft.TwainProSdk.PegasusFilesNotInstalledException
Accusoft.TwainProSdk.PropertyOrMethodNotAvailableException
Accusoft.TwainProSdk.SequenceException
Accusoft.TwainProSdk.SourceCompressedImageOnlyException
Accusoft.TwainProSdk.StringIsTooLongException
Accusoft.TwainProSdk.TiffTagItemNotFoundException
Accusoft.TwainProSdk.TiffTagNotFoundException
Accusoft.TwainProSdk.TwainDllLoadException
Accusoft.TwainProSdk.TwainException
Accusoft.TwainProSdk.TwainProCompressedImageOnlyException
Accusoft.TwainProSdk.UnsupportedFileFormatException
Accusoft.TwainProSdk.ValueOutOfRangeException
System.Collections.CollectionBase
Accusoft.TwainProSdk.CapabilityContainerOneValueCollection
Accusoft.TwainProSdk.ExtendedImageInfoContainerValueCollection
System.Collections.ReadOnlyCollectionBase
Accusoft.TwainProSdk.DataSourceCollection
System.ComponentModel.Component
System.MarshalByRefObject
Accusoft.TwainProSdk.TwainPro
System.EventArgs
Accusoft.TwainProSdk.ScannedEventArgs
Accusoft.TwainProSdk.ScanningEventArgs

See Also

Reference

Accusoft.TwainPro7.Net Assembly


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
ApplicationIdentity Class
Members See Also Send Feedback
Accusoft.TwainProSdk Namespace : ApplicationIdentity Class

Glossary Item Box

An object that represents the TWAIN identity of the application.

Object Model

ApplicationIdentity Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Class ApplicationIdentity
'Usage

Dim instance As ApplicationIdentity
public class ApplicationIdentity
public __gc class ApplicationIdentity
public ref class ApplicationIdentity

Remarks

All TWAIN Data Sources and applications have a TWAIN Identity. This enables the TWAIN Data Source Manager (DSM) to keep track of all running TWAIN applications and Data Sources.

A TWAIN Identity consists of four strings: Product Name, Product Family, Manufacturer and Version Information.

These identities can be set for TwainPRO applications using the ProductName, ProductFamily, Manufacturer and VersionInfo properties respectively.

These properties are part of TwainPRO Session Initialization so they need to be set before calling the TwainDevice.OpenSession or TwainDevice.StartSession methods.

Some Data Source User Interfaces will display a progress indicator during image transfer that displays the application's Product Name Identity.

Inheritance Hierarchy

System.Object
Accusoft.TwainProSdk.ApplicationIdentity

See Also

Reference

ApplicationIdentity Members
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.TwainPro7.Net
ApplicationIdentity Class Members
See Also Properties Methods Send Feedback
Accusoft.TwainProSdk Namespace : ApplicationIdentity Class

Glossary Item Box

The following tables list the members exposed by ApplicationIdentity.

Public Properties

 | Name | Description
Public Property | Manufacturer | Gets or sets the Manufacturer string for the application identity.
Public Property | ProductFamily | Gets or sets the Product Family string for the application identity.
Public Property | ProductName | Gets or sets the Product Name for the application identity.
Public Property | VersionInfo | Gets or sets the Version Information for the application identity.
Top

Public Methods

 | Name | Description
Public Method | Dispose | Disposes of any unused resources.
Top

See Also

Reference

ApplicationIdentity Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.TwainPro7.Net
ApplicationIdentity Class Methods
See Also Send Feedback
Accusoft.TwainProSdk Namespace : ApplicationIdentity Class

Glossary Item Box

For a list of all members of this type, see ApplicationIdentity members.

Public Methods

 | Name | Description
Public Method | Dispose | Disposes of any unused resources.
Top

See Also

Reference

ApplicationIdentity Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Dispose Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ApplicationIdentity Class : Dispose Method

Glossary Item Box

Disposes of any unused resources.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub Dispose()
'Usage

Dim instance As ApplicationIdentity

instance.Dispose()
public void Dispose()
public: void Dispose();
public:
void Dispose();

See Also

Reference

ApplicationIdentity Class
ApplicationIdentity Members


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.TwainPro7.Net
ApplicationIdentity Class Properties
See Also Send Feedback
Accusoft.TwainProSdk Namespace : ApplicationIdentity Class

Glossary Item Box

For a list of all members of this type, see ApplicationIdentity members.

Public Properties

 | Name | Description
Public Property | Manufacturer | Gets or sets the Manufacturer string for the application identity.
Public Property | ProductFamily | Gets or sets the Product Family string for the application identity.
Public Property | ProductName | Gets or sets the Product Name for the application identity.
Public Property | VersionInfo | Gets or sets the Version Information for the application identity.
Top

See Also

Reference

ApplicationIdentity Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Manufacturer Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ApplicationIdentity Class : Manufacturer Property

Glossary Item Box

Gets or sets the Manufacturer string for the application identity.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DescriptionAttribute("Gets or sets the Manufacturer string for the application identity.")>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<DefaultValueAttribute()>
Public Property Manufacturer As String
'Usage

Dim instance As ApplicationIdentity
Dim value As String

instance.Manufacturer = value

value = instance.Manufacturer
[DescriptionAttribute("Gets or sets the Manufacturer string for the application identity.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DefaultValueAttribute()]
public string Manufacturer {get; set;}
[DescriptionAttribute("Gets or sets the Manufacturer string for the application identity.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DefaultValueAttribute()]
public: __property string* get_Manufacturer();
public: __property void set_Manufacturer(
   string* value
);
[DescriptionAttribute("Gets or sets the Manufacturer string for the application identity.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DefaultValueAttribute()]
public:
property String^ Manufacturer {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value which represents the application identity.

Remarks

The default value is an empty string "".

The Manufacturer property is used to identify a company name as manufacturer of an application. This information is sent to the TWAIN Data Source Manager. The application identity consists of the Manufacturer, ProductFamily, ProductName and VersionInfo properties.

This property should be set prior to invoking the TwainDevice.OpenSession or TwainDevice.StartSession methods.

See Also

Reference

ApplicationIdentity Class
ApplicationIdentity Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
ProductFamily Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ApplicationIdentity Class : ProductFamily Property

Glossary Item Box

Gets or sets the Product Family string for the application identity.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
<DefaultValueAttribute()>
<DescriptionAttribute("Gets or sets the Product Family string for the application identity.")>
Public Property ProductFamily As String
'Usage

Dim instance As ApplicationIdentity
Dim value As String

instance.ProductFamily = value

value = instance.ProductFamily
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the Product Family string for the application identity.")]
public string ProductFamily {get; set;}
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the Product Family string for the application identity.")]
public: __property string* get_ProductFamily();
public: __property void set_ProductFamily(
   string* value
);
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the Product Family string for the application identity.")]
public:
property String^ ProductFamily {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value which represents the product family application identity.

Remarks

The default value is an empty string "".

This property is used to identify a software group that the application belongs to. This information is sent to the TWAIN Data Source Manager. The application identity consists of the Manufacturer, ProductFamily, ProductName and VersionInfo properties.

This property should be set prior to invoking the TwainDevice.OpenSession or TwainDevice.StartSession methods.

See Also

Reference

ApplicationIdentity Class
ApplicationIdentity Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
ProductName Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ApplicationIdentity Class : ProductName Property

Glossary Item Box

Gets or sets the Product Name for the application identity.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DescriptionAttribute("Gets or sets the Product Name string for the application identity.")>
<DefaultValueAttribute()>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property ProductName As String
'Usage

Dim instance As ApplicationIdentity
Dim value As String

instance.ProductName = value

value = instance.ProductName
[DescriptionAttribute("Gets or sets the Product Name string for the application identity.")]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public string ProductName {get; set;}
[DescriptionAttribute("Gets or sets the Product Name string for the application identity.")]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property string* get_ProductName();
public: __property void set_ProductName(
   string* value
);
[DescriptionAttribute("Gets or sets the Product Name string for the application identity.")]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property String^ ProductName {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value which represents the product name.

Remarks

The default value is "Product Name".

The ProductName property is used to identify an application name. This information is sent to the TWAIN Data Source Manager. The application identity consists of the Manufacturer, ProductFamily, ProductName and VersionInfo properties.

This property should be set prior to invoking the TwainDevice.OpenSession or TwainDevice.StartSession methods.

ProductName is the most common method for identifying TWAIN applications for Data Sources. Product names for applications are displayed by some Data Sources.

See Also

Reference

ApplicationIdentity Class
ApplicationIdentity Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
VersionInfo Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ApplicationIdentity Class : VersionInfo Property

Glossary Item Box

Gets or sets the Version Information for the application identity.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DescriptionAttribute("Gets or sets the Version Information string for the application identity.")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
<DefaultValueAttribute()>
Public Property VersionInfo As String
'Usage

Dim instance As ApplicationIdentity
Dim value As String

instance.VersionInfo = value

value = instance.VersionInfo
[DescriptionAttribute("Gets or sets the Version Information string for the application identity.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
public string VersionInfo {get; set;}
[DescriptionAttribute("Gets or sets the Version Information string for the application identity.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
public: __property string* get_VersionInfo();
public: __property void set_VersionInfo(
   string* value
);
[DescriptionAttribute("Gets or sets the Version Information string for the application identity.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
public:
property String^ VersionInfo {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value which represents the version information for the application.

Remarks

The default value is an empty string "".

This property is used to identify an application's version. This information is sent to the TWAIN Data Source Manager. The application identity consists of the Manufacturer, ProductFamily, ProductName and VersionInfo properties.

This property should be set prior to invoking the TwainDevice.OpenSession or TwainDevice.StartSession methods.

See Also

Reference

ApplicationIdentity Class
ApplicationIdentity Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
CapabilityContainer Class
Members See Also Send Feedback
Accusoft.TwainProSdk Namespace : CapabilityContainer Class

Glossary Item Box

This class contains the capability information.

Object Model

CapabilityContainer Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Class CapabilityContainer
'Usage

Dim instance As CapabilityContainer
public class CapabilityContainer
public __gc class CapabilityContainer
public ref class CapabilityContainer

Remarks

This object stores all the information of a capability.

The CapabilityContainerOneValue, CapabilityContainerEnum, CapabilityContainerRange, and CapabilityContainerArray objects that are inherited from this object can be filled with information and passed to the TwainDevice.SetCapability method to set the value of a capability. The TwainDevice.GetCapability method returns a CapabilityContainerOneValue, CapabilityContainerEnum, CapabilityContainerRange, or CapabilityContainerArray object of this type which can be casted to the appropriate child object to access the capability information.

Inheritance Hierarchy

System.Object
Accusoft.TwainProSdk.CapabilityContainer
Accusoft.TwainProSdk.CapabilityContainerArray
Accusoft.TwainProSdk.CapabilityContainerEnum
Accusoft.TwainProSdk.CapabilityContainerOneValue
Accusoft.TwainProSdk.CapabilityContainerRange

See Also

Reference

CapabilityContainer Members
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.TwainPro7.Net
CapabilityContainer Class Members
See Also Properties Send Feedback
Accusoft.TwainProSdk Namespace : CapabilityContainer Class

Glossary Item Box

The following tables list the members exposed by CapabilityContainer.

Public Properties

 | Name | Description
Public Property | Capability | Gets and sets which TWAIN capability to negotiate.
Top

See Also

Reference

CapabilityContainer Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.TwainPro7.Net
CapabilityContainer Class Properties
See Also Send Feedback
Accusoft.TwainProSdk Namespace : CapabilityContainer Class

Glossary Item Box

For a list of all members of this type, see CapabilityContainer members.

Public Properties

 | Name | Description
Public Property | Capability | Gets and sets which TWAIN capability to negotiate.
Top

See Also

Reference

CapabilityContainer Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Capability Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > CapabilityContainer Class : Capability Property

Glossary Item Box

Gets and sets which TWAIN capability to negotiate.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DescriptionAttribute("Specifies which TWAIN capability to negotiate.")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property Capability As Integer
'Usage

Dim instance As CapabilityContainer
Dim value As Integer

instance.Capability = value

value = instance.Capability
[BrowsableAttribute(false)]
[DescriptionAttribute("Specifies which TWAIN capability to negotiate.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public int Capability {get; set;}
[BrowsableAttribute(false)]
[DescriptionAttribute("Specifies which TWAIN capability to negotiate.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property int get_Capability();
public: __property void set_Capability(
   int value
);
[BrowsableAttribute(false)]
[DescriptionAttribute("Specifies which TWAIN capability to negotiate.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property int Capability {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the Twain capability.

Remarks

Gets or sets the value of the TWAIN Capability that is negotiated when the TwainDevice.SetCapability method is called.

See Also

Reference

CapabilityContainer Class
CapabilityContainer Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
CapabilityContainerArray Class
Members See Also Send Feedback
Accusoft.TwainProSdk Namespace : CapabilityContainerArray Class

Glossary Item Box

This class is an array type container for storing capability information.

Object Model

CapabilityContainerArray ClassCapabilityContainerOneValueCollection ClassCapabilityContainerOneValue Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Class CapabilityContainerArray
   Inherits CapabilityContainer
'Usage

Dim instance As CapabilityContainerArray
public class CapabilityContainerArray : CapabilityContainer
public __gc class CapabilityContainerArray : public CapabilityContainer
public ref class CapabilityContainerArray : public CapabilityContainer

Remarks

This object stores an array of capability values. This type is less common.

Inheritance Hierarchy

System.Object
Accusoft.TwainProSdk.CapabilityContainer
Accusoft.TwainProSdk.CapabilityContainerArray

See Also

Reference

CapabilityContainerArray Members
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.TwainPro7.Net
CapabilityContainerArray Class Members
See Also Properties Send Feedback
Accusoft.TwainProSdk Namespace : CapabilityContainerArray Class

Glossary Item Box

The following tables list the members exposed by CapabilityContainerArray.

Public Constructors

 | Name | Description
Public Constructor | CapabilityContainerArray Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Capability | Gets and sets which TWAIN capability to negotiate. (Inherited from Accusoft.TwainProSdk.CapabilityContainer)
Public Property | Values | Gets a collection of capability values.
Top

See Also

Reference

CapabilityContainerArray Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
CapabilityContainerArray Constructor
See Also Send Feedback
Accusoft.TwainProSdk Namespace > CapabilityContainerArray Class : CapabilityContainerArray Constructor

Glossary Item Box

Overload List

Overload | Description
CapabilityContainerArray Constructor(Int32) | An array container for storing capability information.
CapabilityContainerArray Constructor(Capability) | An array container for storing capability information.
CapabilityContainerArray Constructor(AdvancedCapability) | An array container for storing capability information.

See Also

Reference

CapabilityContainerArray Class
CapabilityContainerArray Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
CapabilityContainerArray Constructor(Int32)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > CapabilityContainerArray Class > CapabilityContainerArray Constructor : CapabilityContainerArray Constructor(Int32)

capability
An integer which represents a capability value.

Glossary Item Box

An array container for storing capability information.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal capability As Integer _
)
'Usage

Dim capability As Integer

Dim instance As New CapabilityContainerArray(capability)
public CapabilityContainerArray(
   int capability
)
public: CapabilityContainerArray(
   int capability
)
public:
CapabilityContainerArray(
   int capability
)

Parameters

capability
An integer which represents a capability value.

See Also

Reference

CapabilityContainerArray Class
CapabilityContainerArray Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
CapabilityContainerArray Constructor(Capability)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > CapabilityContainerArray Class > CapabilityContainerArray Constructor : CapabilityContainerArray Constructor(Capability)

capability
A capability object.

Glossary Item Box

An array container for storing capability information.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal capability As Capability _
)
'Usage

Dim capability As Capability

Dim instance As New CapabilityContainerArray(capability)
public CapabilityContainerArray(
   Capability capability
)
public: CapabilityContainerArray(
   Capability capability
)
public:
CapabilityContainerArray(
   Capability capability
)

Parameters

capability
A capability object.

See Also

Reference

CapabilityContainerArray Class
CapabilityContainerArray Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
CapabilityContainerArray Constructor(AdvancedCapability)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > CapabilityContainerArray Class > CapabilityContainerArray Constructor : CapabilityContainerArray Constructor(AdvancedCapability)

capability
A capability object.

Glossary Item Box

An array container for storing capability information.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal capability As AdvancedCapability _
)
'Usage

Dim capability As AdvancedCapability

Dim instance As New CapabilityContainerArray(capability)
public CapabilityContainerArray(
   AdvancedCapability capability
)
public: CapabilityContainerArray(
   AdvancedCapability capability
)
public:
CapabilityContainerArray(
   AdvancedCapability capability
)

Parameters

capability
A capability object.

See Also

Reference

CapabilityContainerArray Class
CapabilityContainerArray Members
Overload List


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.TwainPro7.Net
CapabilityContainerArray Class Properties
See Also Send Feedback
Accusoft.TwainProSdk Namespace : CapabilityContainerArray Class

Glossary Item Box

For a list of all members of this type, see CapabilityContainerArray members.

Public Properties

 | Name | Description
Public Property | Capability | Gets and sets which TWAIN capability to negotiate. (Inherited from Accusoft.TwainProSdk.CapabilityContainer)
Public Property | Values | Gets a collection of capability values.
Top

See Also

Reference

CapabilityContainerArray Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Values Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > CapabilityContainerArray Class : Values Property

Glossary Item Box

Gets a collection of capability values.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public ReadOnly Property Values As CapabilityContainerOneValueCollection
'Usage

Dim instance As CapabilityContainerArray
Dim value As CapabilityContainerOneValueCollection

value = instance.Values
[BrowsableAttribute(false)]
public CapabilityContainerOneValueCollection Values {get;}
[BrowsableAttribute(false)]
public: __property CapabilityContainerOneValueCollection* get_Values();
[BrowsableAttribute(false)]
public:
property CapabilityContainerOneValueCollection^ Values {
   CapabilityContainerOneValueCollection^ get();
}

Property Value

A CapabilityContainerOneValueCollection object which contains capability information.

Remarks

Returns a CapabilityContainerOneValueCollection which contains a collection of capability information that can be accessed or set with values.

See Also

Reference

CapabilityContainerArray Class
CapabilityContainerArray Members
CapabilityContainerOneValueCollection Class


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
CapabilityContainerEnum Class
Members See Also Send Feedback
Accusoft.TwainProSdk Namespace : CapabilityContainerEnum Class

Glossary Item Box

A class which contains enumeration capability information.

Object Model

CapabilityContainerEnum ClassCapabilityContainerOneValue ClassCapabilityContainerOneValue ClassCapabilityContainerOneValueCollection ClassCapabilityContainerOneValue Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Class CapabilityContainerEnum
   Inherits CapabilityContainer
'Usage

Dim instance As CapabilityContainerEnum
public class CapabilityContainerEnum : CapabilityContainer
public __gc class CapabilityContainerEnum : public CapabilityContainer
public ref class CapabilityContainerEnum : public CapabilityContainer

Remarks

This object stores a list of capability values, the current value, and the default value.

Inheritance Hierarchy

System.Object
Accusoft.TwainProSdk.CapabilityContainer
Accusoft.TwainProSdk.CapabilityContainerEnum

See Also

Reference

CapabilityContainerEnum Members
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.TwainPro7.Net
CapabilityContainerEnum Class Members
See Also Properties Send Feedback
Accusoft.TwainProSdk Namespace : CapabilityContainerEnum Class

Glossary Item Box

The following tables list the members exposed by CapabilityContainerEnum.

Public Constructors

 | Name | Description
Public Constructor | CapabilityContainerEnum Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Capability | Gets and sets which TWAIN capability to negotiate. (Inherited from Accusoft.TwainProSdk.CapabilityContainer)
Public Property | CurrentValue | Gets or sets the current capability value.
Public Property | DefaultValue | Gets the default capability value.
Public Property | Values | Gets a collection for storing capability values.
Top

See Also

Reference

CapabilityContainerEnum Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
CapabilityContainerEnum Constructor
See Also Send Feedback
Accusoft.TwainProSdk Namespace > CapabilityContainerEnum Class : CapabilityContainerEnum Constructor

Glossary Item Box

Overload List

Overload | Description
CapabilityContainerEnum Constructor(Int32) | A constructor which allows passing in a capability ID by integer.
CapabilityContainerEnum Constructor(Capability) | A constructor which allows passing in a capability by object.
CapabilityContainerEnum Constructor(AdvancedCapability) | A constructor which allows passing in an advanced capability.

See Also

Reference

CapabilityContainerEnum Class
CapabilityContainerEnum Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
CapabilityContainerEnum Constructor(Int32)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > CapabilityContainerEnum Class > CapabilityContainerEnum Constructor : CapabilityContainerEnum Constructor(Int32)

capability
An integer value which represents the capability.

Glossary Item Box

A constructor which allows passing in a capability ID by integer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal capability As Integer _
)
'Usage

Dim capability As Integer

Dim instance As New CapabilityContainerEnum(capability)
public CapabilityContainerEnum(
   int capability
)
public: CapabilityContainerEnum(
   int capability
)
public:
CapabilityContainerEnum(
   int capability
)

Parameters

capability
An integer value which represents the capability.

See Also

Reference

CapabilityContainerEnum Class
CapabilityContainerEnum Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
CapabilityContainerEnum Constructor(Capability)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > CapabilityContainerEnum Class > CapabilityContainerEnum Constructor : CapabilityContainerEnum Constructor(Capability)

capability
A Capability which contains the capability information.

Glossary Item Box

A constructor which allows passing in a capability by object.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal capability As Capability _
)
'Usage

Dim capability As Capability

Dim instance As New CapabilityContainerEnum(capability)
public CapabilityContainerEnum(
   Capability capability
)
public: CapabilityContainerEnum(
   Capability capability
)
public:
CapabilityContainerEnum(
   Capability capability
)

Parameters

capability
A Capability which contains the capability information.

See Also

Reference

CapabilityContainerEnum Class
CapabilityContainerEnum Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
CapabilityContainerEnum Constructor(AdvancedCapability)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > CapabilityContainerEnum Class > CapabilityContainerEnum Constructor : CapabilityContainerEnum Constructor(AdvancedCapability)

capability
An AdvancedCapability which represents the advanced capability information.

Glossary Item Box

A constructor which allows passing in an advanced capability.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal capability As AdvancedCapability _
)
'Usage

Dim capability As AdvancedCapability

Dim instance As New CapabilityContainerEnum(capability)
public CapabilityContainerEnum(
   AdvancedCapability capability
)
public: CapabilityContainerEnum(
   AdvancedCapability capability
)
public:
CapabilityContainerEnum(
   AdvancedCapability capability
)

Parameters

capability
An AdvancedCapability which represents the advanced capability information.

See Also

Reference

CapabilityContainerEnum Class
CapabilityContainerEnum Members
Overload List


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.TwainPro7.Net
CapabilityContainerEnum Class Properties
See Also Send Feedback
Accusoft.TwainProSdk Namespace : CapabilityContainerEnum Class

Glossary Item Box

For a list of all members of this type, see CapabilityContainerEnum members.

Public Properties

 | Name | Description
Public Property | Capability | Gets and sets which TWAIN capability to negotiate. (Inherited from Accusoft.TwainProSdk.CapabilityContainer)
Public Property | CurrentValue | Gets or sets the current capability value.
Public Property | DefaultValue | Gets the default capability value.
Public Property | Values | Gets a collection for storing capability values.
Top

See Also

Reference

CapabilityContainerEnum Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
CurrentValue Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > CapabilityContainerEnum Class : CurrentValue Property

Glossary Item Box

Gets or sets the current capability value.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DescriptionAttribute("The current capability value.")>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property CurrentValue As CapabilityContainerOneValue
'Usage

Dim instance As CapabilityContainerEnum
Dim value As CapabilityContainerOneValue

instance.CurrentValue = value

value = instance.CurrentValue
[DescriptionAttribute("The current capability value.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public CapabilityContainerOneValue CurrentValue {get; set;}
[DescriptionAttribute("The current capability value.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property CapabilityContainerOneValue* get_CurrentValue();
public: __property void set_CurrentValue(
   CapabilityContainerOneValue* value
);
[DescriptionAttribute("The current capability value.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property CapabilityContainerOneValue^ CurrentValue {
   CapabilityContainerOneValue^ get();
   void set (    CapabilityContainerOneValue^ value);
}

Property Value

A CapabilityContainerOneValue object which represents the current capability value.

Remarks

This property accesses the current value of the capability.

See Also

Reference

CapabilityContainerEnum Class
CapabilityContainerEnum Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
DefaultValue Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > CapabilityContainerEnum Class : DefaultValue Property

Glossary Item Box

Gets the default capability value.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
<DescriptionAttribute("The default capability value.")>
Public ReadOnly Property DefaultValue As CapabilityContainerOneValue
'Usage

Dim instance As CapabilityContainerEnum
Dim value As CapabilityContainerOneValue

value = instance.DefaultValue
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
[DescriptionAttribute("The default capability value.")]
public CapabilityContainerOneValue DefaultValue {get;}
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
[DescriptionAttribute("The default capability value.")]
public: __property CapabilityContainerOneValue* get_DefaultValue();
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
[DescriptionAttribute("The default capability value.")]
public:
property CapabilityContainerOneValue^ DefaultValue {
   CapabilityContainerOneValue^ get();
}

Property Value

A CapabilityContainerOneValue object which contains the default capability value.

Remarks

Gets the default CapabilityContainerOneValue of the capability.

See Also

Reference

CapabilityContainerEnum Class
CapabilityContainerEnum Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Values Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > CapabilityContainerEnum Class : Values Property

Glossary Item Box

Gets a collection for storing capability values.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public ReadOnly Property Values As CapabilityContainerOneValueCollection
'Usage

Dim instance As CapabilityContainerEnum
Dim value As CapabilityContainerOneValueCollection

value = instance.Values
[BrowsableAttribute(false)]
public CapabilityContainerOneValueCollection Values {get;}
[BrowsableAttribute(false)]
public: __property CapabilityContainerOneValueCollection* get_Values();
[BrowsableAttribute(false)]
public:
property CapabilityContainerOneValueCollection^ Values {
   CapabilityContainerOneValueCollection^ get();
}

Property Value

A CapabilityContainerOneValueCollection which contains capability values.

Remarks

Returns a collection of CapabilityOneValue objects that can be accessed or set with values.

See Also

Reference

CapabilityContainerEnum Class
CapabilityContainerEnum Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
CapabilityContainerFrame Class
Members See Also Send Feedback
Accusoft.TwainProSdk Namespace : CapabilityContainerFrame Class

Glossary Item Box

This class implements a capability container for storing a frame value.

Object Model

CapabilityContainerFrame Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Class CapabilityContainerFrame
   Inherits CapabilityContainerOneValue
'Usage

Dim instance As CapabilityContainerFrame
public class CapabilityContainerFrame : CapabilityContainerOneValue
public __gc class CapabilityContainerFrame : public CapabilityContainerOneValue
public ref class CapabilityContainerFrame : public CapabilityContainerOneValue

Remarks

This object is used to get or set a capability containing one frame value.

Inheritance Hierarchy

System.Object
Accusoft.TwainProSdk.CapabilityContainer
Accusoft.TwainProSdk.CapabilityContainerOneValue
Accusoft.TwainProSdk.CapabilityContainerFrame

See Also

Reference

CapabilityContainerFrame Members
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.TwainPro7.Net
CapabilityContainerFrame Class Members
See Also Properties Send Feedback
Accusoft.TwainProSdk Namespace : CapabilityContainerFrame Class

Glossary Item Box

The following tables list the members exposed by CapabilityContainerFrame.

Public Constructors

 | Name | Description
Public Constructor | CapabilityContainerFrame Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Capability | Gets and sets which TWAIN capability to negotiate. (Inherited from Accusoft.TwainProSdk.CapabilityContainer)
Public Property | Value | Gets and sets the specific capability frame value.
Top

See Also

Reference

CapabilityContainerFrame Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
CapabilityContainerFrame Constructor
See Also Send Feedback
Accusoft.TwainProSdk Namespace > CapabilityContainerFrame Class : CapabilityContainerFrame Constructor

Glossary Item Box

Overload List

Overload | Description
CapabilityContainerFrame Constructor(Int32) | The main constructor for this class.
CapabilityContainerFrame Constructor(Capability) | Constructor which allows passing in a capability object.
CapabilityContainerFrame Constructor(AdvancedCapability) | Constructor which allows passing in an advanced capability object.

See Also

Reference

CapabilityContainerFrame Class
CapabilityContainerFrame Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
CapabilityContainerFrame Constructor(Int32)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > CapabilityContainerFrame Class > CapabilityContainerFrame Constructor : CapabilityContainerFrame Constructor(Int32)

capability
An integer that represents a capability value.

Glossary Item Box

The main constructor for this class.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal capability As Integer _
)
'Usage

Dim capability As Integer

Dim instance As New CapabilityContainerFrame(capability)
public CapabilityContainerFrame(
   int capability
)
public: CapabilityContainerFrame(
   int capability
)
public:
CapabilityContainerFrame(
   int capability
)

Parameters

capability
An integer that represents a capability value.

See Also

Reference

CapabilityContainerFrame Class
CapabilityContainerFrame Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
CapabilityContainerFrame Constructor(Capability)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > CapabilityContainerFrame Class > CapabilityContainerFrame Constructor : CapabilityContainerFrame Constructor(Capability)

capability
A Capability object.

Glossary Item Box

Constructor which allows passing in a capability object.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal capability As Capability _
)
'Usage

Dim capability As Capability

Dim instance As New CapabilityContainerFrame(capability)
public CapabilityContainerFrame(
   Capability capability
)
public: CapabilityContainerFrame(
   Capability capability
)
public:
CapabilityContainerFrame(
   Capability capability
)

Parameters

capability
A Capability object.

See Also

Reference

CapabilityContainerFrame Class
CapabilityContainerFrame Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
CapabilityContainerFrame Constructor(AdvancedCapability)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > CapabilityContainerFrame Class > CapabilityContainerFrame Constructor : CapabilityContainerFrame Constructor(AdvancedCapability)

capability
An AdvancedCapability object.

Glossary Item Box

Constructor which allows passing in an advanced capability object.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal capability As AdvancedCapability _
)
'Usage

Dim capability As AdvancedCapability

Dim instance As New CapabilityContainerFrame(capability)
public CapabilityContainerFrame(
   AdvancedCapability capability
)
public: CapabilityContainerFrame(
   AdvancedCapability capability
)
public:
CapabilityContainerFrame(
   AdvancedCapability capability
)

Parameters

capability
An AdvancedCapability object.

See Also

Reference

CapabilityContainerFrame Class
CapabilityContainerFrame Members
Overload List


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.TwainPro7.Net
CapabilityContainerFrame Class Properties
See Also Send Feedback
Accusoft.TwainProSdk Namespace : CapabilityContainerFrame Class

Glossary Item Box

For a list of all members of this type, see CapabilityContainerFrame members.

Public Properties

 | Name | Description
Public Property | Capability | Gets and sets which TWAIN capability to negotiate. (Inherited from Accusoft.TwainProSdk.CapabilityContainer)
Public Property | Value | Gets and sets the specific capability frame value.
Top

See Also

Reference

CapabilityContainerFrame Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Value Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > CapabilityContainerFrame Class : Value Property

Glossary Item Box

Gets and sets the specific capability frame value.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DescriptionAttribute("The capability frame value.")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property Value As RectangleF
'Usage

Dim instance As CapabilityContainerFrame
Dim value As RectangleF

instance.Value = value

value = instance.Value
[BrowsableAttribute(false)]
[DescriptionAttribute("The capability frame value.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public RectangleF Value {get; set;}
[BrowsableAttribute(false)]
[DescriptionAttribute("The capability frame value.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property RectangleF get_Value();
public: __property void set_Value(
   RectangleF value
);
[BrowsableAttribute(false)]
[DescriptionAttribute("The capability frame value.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property RectangleF Value {
   RectangleF get();
   void set (    RectangleF value);
}

Property Value

A frame value which represents the capability value to get or set.

See Also

Reference

CapabilityContainerFrame Class
CapabilityContainerFrame Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
CapabilityContainerOneValue Class
Members See Also Send Feedback
Accusoft.TwainProSdk Namespace : CapabilityContainerOneValue Class

Glossary Item Box

This class implements a one value type container for storing capability information.

Object Model

CapabilityContainerOneValue Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Class CapabilityContainerOneValue
   Inherits CapabilityContainer
'Usage

Dim instance As CapabilityContainerOneValue
public class CapabilityContainerOneValue : CapabilityContainer
public __gc class CapabilityContainerOneValue : public CapabilityContainer
public ref class CapabilityContainerOneValue : public CapabilityContainer

Remarks

This object stores one capability value.

Note: You cannot create a CapabilityContainerOneValue object directly. The CapabilityContainerOneValueFloat and CapabilityContainerOneValueString objects are inherited from this object and should be used, respectively, for setting a capability containing one float value or a capability containing one string value.

Inheritance Hierarchy

System.Object
Accusoft.TwainProSdk.CapabilityContainer
Accusoft.TwainProSdk.CapabilityContainerOneValue
Accusoft.TwainProSdk.CapabilityContainerFrame
Accusoft.TwainProSdk.CapabilityContainerOneValueFloat
Accusoft.TwainProSdk.CapabilityContainerOneValueString

See Also

Reference

CapabilityContainerOneValue Members
Accusoft.TwainProSdk Namespace
CapabilityContainerOneValueFloat Class
CapabilityContainerOneValueString Class


%%PageItemTitle%% $$Members$$

[image]
Accusoft.TwainPro7.Net
CapabilityContainerOneValue Class Members
See Also Properties Send Feedback
Accusoft.TwainProSdk Namespace : CapabilityContainerOneValue Class

Glossary Item Box

The following tables list the members exposed by CapabilityContainerOneValue.

Public Properties

 | Name | Description
Public Property | Capability | Gets and sets which TWAIN capability to negotiate. (Inherited from Accusoft.TwainProSdk.CapabilityContainer)
Top

See Also

Reference

CapabilityContainerOneValue Class
Accusoft.TwainProSdk Namespace
CapabilityContainerOneValueFloat Class
CapabilityContainerOneValueString Class


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.TwainPro7.Net
CapabilityContainerOneValue Class Properties
See Also Send Feedback
Accusoft.TwainProSdk Namespace : CapabilityContainerOneValue Class

Glossary Item Box

For a list of all members of this type, see CapabilityContainerOneValue members.

Public Properties

 | Name | Description
Public Property | Capability | Gets and sets which TWAIN capability to negotiate. (Inherited from Accusoft.TwainProSdk.CapabilityContainer)
Top

See Also

Reference

CapabilityContainerOneValue Class
Accusoft.TwainProSdk Namespace
CapabilityContainerOneValueFloat Class
CapabilityContainerOneValueString Class


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
CapabilityContainerOneValueCollection Class
Members See Also Send Feedback
Accusoft.TwainProSdk Namespace : CapabilityContainerOneValueCollection Class

Glossary Item Box

This class implements a collection of CapabilityContainerOneValue objects.

Object Model

CapabilityContainerOneValueCollection ClassCapabilityContainerOneValue Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DefaultMemberAttribute("Item")>
Public Class CapabilityContainerOneValueCollection
   Inherits System.Collections.CollectionBase
'Usage

Dim instance As CapabilityContainerOneValueCollection
[DefaultMemberAttribute("Item")]
public class CapabilityContainerOneValueCollection : System.Collections.CollectionBase
[DefaultMemberAttribute("Item")]
public __gc class CapabilityContainerOneValueCollection : public System.Collections.CollectionBase
[DefaultMemberAttribute("Item")]
public ref class CapabilityContainerOneValueCollection : public System.Collections.CollectionBase

Remarks

This object is used by the CapabilityContainerArray and the CapabilityContainerEnum to store a collection of capability values.

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Accusoft.TwainProSdk.CapabilityContainerOneValueCollection

See Also

Reference

CapabilityContainerOneValueCollection Members
Accusoft.TwainProSdk Namespace
CapabilityContainerOneValue Class
CapabilityContainerEnum Class


%%PageItemTitle%% $$Members$$

[image]
Accusoft.TwainPro7.Net
CapabilityContainerOneValueCollection Class Members
See Also Properties Methods Send Feedback
Accusoft.TwainProSdk Namespace : CapabilityContainerOneValueCollection Class

Glossary Item Box

The following tables list the members exposed by CapabilityContainerOneValueCollection.

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets the element at the given index.
Top

Public Methods

 | Name | Description
Public Method | Add | Adds a CapabilityContainerOneValue to the collection.
Public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines if the specified CapabilityContainerOneValue is contained in the collection.
Public Method | CopyTo | Copies all elements of the collection to the specified array, beginning at the specified index in the array.
Public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Searches the collection for the specified CapabilityContainerOneValue and returns the index value of it.
Public Method | Insert | Inserts a CapabilityContainerOneValue into the collection at the given index.
Public Method | Remove | Removes a CapabilityContainerOneValue from the collection.
Public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

CapabilityContainerOneValueCollection Class
Accusoft.TwainProSdk Namespace
CapabilityContainerOneValue Class
CapabilityContainerEnum Class


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.TwainPro7.Net
CapabilityContainerOneValueCollection Class Methods
See Also Send Feedback
Accusoft.TwainProSdk Namespace : CapabilityContainerOneValueCollection Class

Glossary Item Box

For a list of all members of this type, see CapabilityContainerOneValueCollection members.

Public Methods

 | Name | Description
Public Method | Add | Adds a CapabilityContainerOneValue to the collection.
Public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines if the specified CapabilityContainerOneValue is contained in the collection.
Public Method | CopyTo | Copies all elements of the collection to the specified array, beginning at the specified index in the array.
Public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Searches the collection for the specified CapabilityContainerOneValue and returns the index value of it.
Public Method | Insert | Inserts a CapabilityContainerOneValue into the collection at the given index.
Public Method | Remove | Removes a CapabilityContainerOneValue from the collection.
Public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

CapabilityContainerOneValueCollection Class
Accusoft.TwainProSdk Namespace
CapabilityContainerOneValue Class
CapabilityContainerEnum Class


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Add Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > CapabilityContainerOneValueCollection Class : Add Method

value

Glossary Item Box

Adds a CapabilityContainerOneValue to the collection.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function Add( _
   ByVal value As CapabilityContainerOneValue _
) As Integer
'Usage

Dim instance As CapabilityContainerOneValueCollection
Dim value As CapabilityContainerOneValue
Dim value As Integer

value = instance.Add(value)
public int Add(
   CapabilityContainerOneValue value
)
public: int Add(
   CapabilityContainerOneValue* value
)
public:
int Add(
   CapabilityContainerOneValue^ value
)

Parameters

value

Return Value

An integer value which represents the new index value after adding the element to the collection.

Remarks

This method inserts a new CapabilityContainerOneValue object at the end of the collection. When this method is complete, the length of the collection will be one larger than it was and the element with the highest index will be the new object.

See Also

Reference

CapabilityContainerOneValueCollection Class
CapabilityContainerOneValueCollection Members
CapabilityContainerOneValue Class


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Contains Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > CapabilityContainerOneValueCollection Class : Contains Method

value

Glossary Item Box

Determines if the specified CapabilityContainerOneValue is contained in the collection.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function Contains( _
   ByVal value As CapabilityContainerOneValue _
) As Boolean
'Usage

Dim instance As CapabilityContainerOneValueCollection
Dim value As CapabilityContainerOneValue
Dim value As Boolean

value = instance.Contains(value)
public bool Contains(
   CapabilityContainerOneValue value
)
public: bool Contains(
   CapabilityContainerOneValue* value
)
public:
bool Contains(
   CapabilityContainerOneValue^ value
)

Parameters

value

Return Value

A boolean value which is True if the specified object is in the collection. Otherwise, False is returned.

Remarks

This method searches the collection for the given CapabilityContainerOneValue. If a reference to the CapabilityContainerOneValue is found, this method returns true, otherwise, false is returned.

See Also

Reference

CapabilityContainerOneValueCollection Class
CapabilityContainerOneValueCollection Members
CapabilityContainerOneValue Class


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
CopyTo Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > CapabilityContainerOneValueCollection Class : CopyTo Method

array
Contains an array that receives the elements of the collection.
index
Contains the zero-based index in array where this method starts copying the collection.

Glossary Item Box

Copies all elements of the collection to the specified array, beginning at the specified index in the array.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub CopyTo( _
   ByVal array() As CapabilityContainerOneValue, _
   ByVal index As Integer _
)
'Usage

Dim instance As CapabilityContainerOneValueCollection
Dim array() As CapabilityContainerOneValue
Dim index As Integer

instance.CopyTo(array, index)
public void CopyTo(
   CapabilityContainerOneValue[] array,
   int index
)
public: void CopyTo(
   CapabilityContainerOneValue*[]* array,
   int index
)
public:
void CopyTo(
   array<CapabilityContainerOneValue^>^ array,
   int index
)

Parameters

array
Contains an array that receives the elements of the collection.
index
Contains the zero-based index in array where this method starts copying the collection.

Remarks

This method implements a standard collection operation. It copies elements from this collection to the given array in order, starting at element 0 in this collection. It places the elements into the array starting at the given zero-based index. This method will stop copying elements when it reaches the end of the collection or the end of the array.

See Also

Reference

CapabilityContainerOneValueCollection Class
CapabilityContainerOneValueCollection Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
IndexOf Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > CapabilityContainerOneValueCollection Class : IndexOf Method

value

Glossary Item Box

Searches the collection for the specified CapabilityContainerOneValue and returns the index value of it.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function IndexOf( _
   ByVal value As CapabilityContainerOneValue _
) As Integer
'Usage

Dim instance As CapabilityContainerOneValueCollection
Dim value As CapabilityContainerOneValue
Dim value As Integer

value = instance.IndexOf(value)
public int IndexOf(
   CapabilityContainerOneValue value
)
public: int IndexOf(
   CapabilityContainerOneValue* value
)
public:
int IndexOf(
   CapabilityContainerOneValue^ value
)

Parameters

value

Return Value

An integer value which represents the zero-based index of the CapabilityContainerOneValue specified in the collection.

Remarks

This method searches the collection for a reference to the given object. If it does not find a reference to it, this method returns -1. If the object is present more than once in the collection, this method returns the lowest index of a match.

See Also

Reference

CapabilityContainerOneValueCollection Class
CapabilityContainerOneValueCollection Members
CapabilityContainerOneValue Class


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Insert Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > CapabilityContainerOneValueCollection Class : Insert Method

index
value

Glossary Item Box

Inserts a CapabilityContainerOneValue into the collection at the given index.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub Insert( _
   ByVal index As Integer, _
   ByVal value As CapabilityContainerOneValue _
)
'Usage

Dim instance As CapabilityContainerOneValueCollection
Dim index As Integer
Dim value As CapabilityContainerOneValue

instance.Insert(index, value)
public void Insert(
   int index,
   CapabilityContainerOneValue value
)
public: void Insert(
   int index,
   CapabilityContainerOneValue* value
)
public:
void Insert(
   int index,
   CapabilityContainerOneValue^ value
)

Parameters

index
value

Remarks

This method inserts the given CapabilityContainerOneValue into the collection at the given index.

See Also

Reference

CapabilityContainerOneValueCollection Class
CapabilityContainerOneValueCollection Members
CapabilityContainerOneValue Class


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Remove Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > CapabilityContainerOneValueCollection Class : Remove Method

value

Glossary Item Box

Removes a CapabilityContainerOneValue from the collection.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub Remove( _
   ByVal value As CapabilityContainerOneValue _
)
'Usage

Dim instance As CapabilityContainerOneValueCollection
Dim value As CapabilityContainerOneValue

instance.Remove(value)
public void Remove(
   CapabilityContainerOneValue value
)
public: void Remove(
   CapabilityContainerOneValue* value
)
public:
void Remove(
   CapabilityContainerOneValue^ value
)

Parameters

value

Remarks

This method searches the collection for the given CapabilityContainerOneValue and removes it. If there are no occurrences of the object, this method will do nothing.

See Also

Reference

CapabilityContainerOneValueCollection Class
CapabilityContainerOneValueCollection Members
CapabilityContainerOneValue Class


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.TwainPro7.Net
CapabilityContainerOneValueCollection Class Properties
See Also Send Feedback
Accusoft.TwainProSdk Namespace : CapabilityContainerOneValueCollection Class

Glossary Item Box

For a list of all members of this type, see CapabilityContainerOneValueCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets the element at the given index.
Top

See Also

Reference

CapabilityContainerOneValueCollection Class
Accusoft.TwainProSdk Namespace
CapabilityContainerOneValue Class
CapabilityContainerEnum Class


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Item Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > CapabilityContainerOneValueCollection Class : Item Property

index
A zero-based integer specifying the index in the collection to get or set.

Glossary Item Box

Gets or sets the element at the given index.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DescriptionAttribute("Gets or sets the element at the given index.")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Default Property Item( _
   ByVal index As Integer _
) As CapabilityContainerOneValue
'Usage

Dim instance As CapabilityContainerOneValueCollection
Dim index As Integer
Dim value As CapabilityContainerOneValue

instance.Item(index) = value

value = instance.Item(index)
[BrowsableAttribute(false)]
[DescriptionAttribute("Gets or sets the element at the given index.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public CapabilityContainerOneValue this[
   int index
]; {get; set;}
[BrowsableAttribute(false)]
[DescriptionAttribute("Gets or sets the element at the given index.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property CapabilityContainerOneValue* get_Item   int index
;
public: __property void set_Item   int index,
   CapabilityContainerOneValue* value
;
[BrowsableAttribute(false)]
[DescriptionAttribute("Gets or sets the element at the given index.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property CapabilityContainerOneValue^ default [int] {
   CapabilityContainerOneValue^ get(int index);
   void set (int index, CapabilityContainerOneValue^ value);
}

Parameters

index
A zero-based integer specifying the index in the collection to get or set.

Property Value

A CapabilityContainerOneValue object to get or set at the given index value.

Remarks

This method implements a standard collection operation. It is the principle method to use to read or change elements in the collection. You can read or modify any element in the collection with this method.

See Also

Reference

CapabilityContainerOneValueCollection Class
CapabilityContainerOneValueCollection Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
CapabilityContainerOneValueFloat Class
Members See Also Send Feedback
Accusoft.TwainProSdk Namespace : CapabilityContainerOneValueFloat Class

Glossary Item Box

This class implements a capability container for storing a float value.

Object Model

CapabilityContainerOneValueFloat Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Class CapabilityContainerOneValueFloat
   Inherits CapabilityContainerOneValue
'Usage

Dim instance As CapabilityContainerOneValueFloat
public class CapabilityContainerOneValueFloat : CapabilityContainerOneValue
public __gc class CapabilityContainerOneValueFloat : public CapabilityContainerOneValue
public ref class CapabilityContainerOneValueFloat : public CapabilityContainerOneValue

Remarks

This object is used to get or set a capability containing one float value.

Inheritance Hierarchy

System.Object
Accusoft.TwainProSdk.CapabilityContainer
Accusoft.TwainProSdk.CapabilityContainerOneValue
Accusoft.TwainProSdk.CapabilityContainerOneValueFloat

See Also

Reference

CapabilityContainerOneValueFloat Members
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.TwainPro7.Net
CapabilityContainerOneValueFloat Class Members
See Also Properties Send Feedback
Accusoft.TwainProSdk Namespace : CapabilityContainerOneValueFloat Class

Glossary Item Box

The following tables list the members exposed by CapabilityContainerOneValueFloat.

Public Constructors

 | Name | Description
Public Constructor | CapabilityContainerOneValueFloat Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Capability | Gets and sets which TWAIN capability to negotiate. (Inherited from Accusoft.TwainProSdk.CapabilityContainer)
Public Property | Value | Gets and sets the specific capability value.
Top

See Also

Reference

CapabilityContainerOneValueFloat Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
CapabilityContainerOneValueFloat Constructor
See Also Send Feedback
Accusoft.TwainProSdk Namespace > CapabilityContainerOneValueFloat Class : CapabilityContainerOneValueFloat Constructor

Glossary Item Box

Overload List

Overload | Description
CapabilityContainerOneValueFloat Constructor(Int32) | The main constructor for this class.
CapabilityContainerOneValueFloat Constructor(Capability) | Constructor which allows passing in a capability object.
CapabilityContainerOneValueFloat Constructor(AdvancedCapability) | Constructor which allows passing in an advanced capability object.

See Also

Reference

CapabilityContainerOneValueFloat Class
CapabilityContainerOneValueFloat Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
CapabilityContainerOneValueFloat Constructor(Int32)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > CapabilityContainerOneValueFloat Class > CapabilityContainerOneValueFloat Constructor : CapabilityContainerOneValueFloat Constructor(Int32)

capability
An integer which represents a capability value.

Glossary Item Box

The main constructor for this class.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal capability As Integer _
)
'Usage

Dim capability As Integer

Dim instance As New CapabilityContainerOneValueFloat(capability)
public CapabilityContainerOneValueFloat(
   int capability
)
public: CapabilityContainerOneValueFloat(
   int capability
)
public:
CapabilityContainerOneValueFloat(
   int capability
)

Parameters

capability
An integer which represents a capability value.

See Also

Reference

CapabilityContainerOneValueFloat Class
CapabilityContainerOneValueFloat Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
CapabilityContainerOneValueFloat Constructor(Capability)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > CapabilityContainerOneValueFloat Class > CapabilityContainerOneValueFloat Constructor : CapabilityContainerOneValueFloat Constructor(Capability)

capability
A Capability object.

Glossary Item Box

Constructor which allows passing in a capability object.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal capability As Capability _
)
'Usage

Dim capability As Capability

Dim instance As New CapabilityContainerOneValueFloat(capability)
public CapabilityContainerOneValueFloat(
   Capability capability
)
public: CapabilityContainerOneValueFloat(
   Capability capability
)
public:
CapabilityContainerOneValueFloat(
   Capability capability
)

Parameters

capability
A Capability object.

See Also

Reference

CapabilityContainerOneValueFloat Class
CapabilityContainerOneValueFloat Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
CapabilityContainerOneValueFloat Constructor(AdvancedCapability)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > CapabilityContainerOneValueFloat Class > CapabilityContainerOneValueFloat Constructor : CapabilityContainerOneValueFloat Constructor(AdvancedCapability)

capability
An AdvancedCapability object.

Glossary Item Box

Constructor which allows passing in an advanced capability object.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal capability As AdvancedCapability _
)
'Usage

Dim capability As AdvancedCapability

Dim instance As New CapabilityContainerOneValueFloat(capability)
public CapabilityContainerOneValueFloat(
   AdvancedCapability capability
)
public: CapabilityContainerOneValueFloat(
   AdvancedCapability capability
)
public:
CapabilityContainerOneValueFloat(
   AdvancedCapability capability
)

Parameters

capability
An AdvancedCapability object.

See Also

Reference

CapabilityContainerOneValueFloat Class
CapabilityContainerOneValueFloat Members
Overload List


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.TwainPro7.Net
CapabilityContainerOneValueFloat Class Properties
See Also Send Feedback
Accusoft.TwainProSdk Namespace : CapabilityContainerOneValueFloat Class

Glossary Item Box

For a list of all members of this type, see CapabilityContainerOneValueFloat members.

Public Properties

 | Name | Description
Public Property | Capability | Gets and sets which TWAIN capability to negotiate. (Inherited from Accusoft.TwainProSdk.CapabilityContainer)
Public Property | Value | Gets and sets the specific capability value.
Top

See Also

Reference

CapabilityContainerOneValueFloat Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Value Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > CapabilityContainerOneValueFloat Class : Value Property

Glossary Item Box

Gets and sets the specific capability value.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<DescriptionAttribute("The capability value.")>
Public Property Value As Single
'Usage

Dim instance As CapabilityContainerOneValueFloat
Dim value As Single

instance.Value = value

value = instance.Value
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DescriptionAttribute("The capability value.")]
public float Value {get; set;}
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DescriptionAttribute("The capability value.")]
public: __property float get_Value();
public: __property void set_Value(
   float value
);
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DescriptionAttribute("The capability value.")]
public:
property float Value {
   float get();
   void set (    float value);
}

Property Value

A float value which represents the capability value to get or set.

See Also

Reference

CapabilityContainerOneValueFloat Class
CapabilityContainerOneValueFloat Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
CapabilityContainerOneValueString Class
Members See Also Send Feedback
Accusoft.TwainProSdk Namespace : CapabilityContainerOneValueString Class

Glossary Item Box

This class implements a capability container for storing a string value.

Object Model

CapabilityContainerOneValueString Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Class CapabilityContainerOneValueString
   Inherits CapabilityContainerOneValue
'Usage

Dim instance As CapabilityContainerOneValueString
public class CapabilityContainerOneValueString : CapabilityContainerOneValue
public __gc class CapabilityContainerOneValueString : public CapabilityContainerOneValue
public ref class CapabilityContainerOneValueString : public CapabilityContainerOneValue

Remarks

This object is used to get or set a capability containing one string value.

Inheritance Hierarchy

System.Object
Accusoft.TwainProSdk.CapabilityContainer
Accusoft.TwainProSdk.CapabilityContainerOneValue
Accusoft.TwainProSdk.CapabilityContainerOneValueString

See Also

Reference

CapabilityContainerOneValueString Members
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.TwainPro7.Net
CapabilityContainerOneValueString Class Members
See Also Properties Send Feedback
Accusoft.TwainProSdk Namespace : CapabilityContainerOneValueString Class

Glossary Item Box

The following tables list the members exposed by CapabilityContainerOneValueString.

Public Constructors

 | Name | Description
Public Constructor | CapabilityContainerOneValueString Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Capability | Gets and sets which TWAIN capability to negotiate. (Inherited from Accusoft.TwainProSdk.CapabilityContainer)
Public Property | Value | Gets and sets the capability value.
Top

See Also

Reference

CapabilityContainerOneValueString Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
CapabilityContainerOneValueString Constructor
See Also Send Feedback
Accusoft.TwainProSdk Namespace > CapabilityContainerOneValueString Class : CapabilityContainerOneValueString Constructor

Glossary Item Box

Overload List

Overload | Description
CapabilityContainerOneValueString Constructor(Int32) | A CapabilityContainerOneValueString constructor which allows passing in a specified capability by index value.
CapabilityContainerOneValueString Constructor(Capability) | A CapabilityContainerOneValueString constructor which allows passing in a capability by Capability enumeration object.
CapabilityContainerOneValueString Constructor(AdvancedCapability) | A CapabilityContainerOneValueString constructor which allows passing in an advanced capability by AdvancedCapability object.

See Also

Reference

CapabilityContainerOneValueString Class
CapabilityContainerOneValueString Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
CapabilityContainerOneValueString Constructor(Int32)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > CapabilityContainerOneValueString Class > CapabilityContainerOneValueString Constructor : CapabilityContainerOneValueString Constructor(Int32)

capability
An integer which represents a capability value.

Glossary Item Box

A CapabilityContainerOneValueString constructor which allows passing in a specified capability by index value.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal capability As Integer _
)
'Usage

Dim capability As Integer

Dim instance As New CapabilityContainerOneValueString(capability)
public CapabilityContainerOneValueString(
   int capability
)
public: CapabilityContainerOneValueString(
   int capability
)
public:
CapabilityContainerOneValueString(
   int capability
)

Parameters

capability
An integer which represents a capability value.

See Also

Reference

CapabilityContainerOneValueString Class
CapabilityContainerOneValueString Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
CapabilityContainerOneValueString Constructor(Capability)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > CapabilityContainerOneValueString Class > CapabilityContainerOneValueString Constructor : CapabilityContainerOneValueString Constructor(Capability)

capability
A Capability object.

Glossary Item Box

A CapabilityContainerOneValueString constructor which allows passing in a capability by Capability enumeration object.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal capability As Capability _
)
'Usage

Dim capability As Capability

Dim instance As New CapabilityContainerOneValueString(capability)
public CapabilityContainerOneValueString(
   Capability capability
)
public: CapabilityContainerOneValueString(
   Capability capability
)
public:
CapabilityContainerOneValueString(
   Capability capability
)

Parameters

capability
A Capability object.

See Also

Reference

CapabilityContainerOneValueString Class
CapabilityContainerOneValueString Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
CapabilityContainerOneValueString Constructor(AdvancedCapability)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > CapabilityContainerOneValueString Class > CapabilityContainerOneValueString Constructor : CapabilityContainerOneValueString Constructor(AdvancedCapability)

capability
An AdvancedCapability object.

Glossary Item Box

A CapabilityContainerOneValueString constructor which allows passing in an advanced capability by AdvancedCapability object.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal capability As AdvancedCapability _
)
'Usage

Dim capability As AdvancedCapability

Dim instance As New CapabilityContainerOneValueString(capability)
public CapabilityContainerOneValueString(
   AdvancedCapability capability
)
public: CapabilityContainerOneValueString(
   AdvancedCapability capability
)
public:
CapabilityContainerOneValueString(
   AdvancedCapability capability
)

Parameters

capability
An AdvancedCapability object.

See Also

Reference

CapabilityContainerOneValueString Class
CapabilityContainerOneValueString Members
Overload List


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.TwainPro7.Net
CapabilityContainerOneValueString Class Properties
See Also Send Feedback
Accusoft.TwainProSdk Namespace : CapabilityContainerOneValueString Class

Glossary Item Box

For a list of all members of this type, see CapabilityContainerOneValueString members.

Public Properties

 | Name | Description
Public Property | Capability | Gets and sets which TWAIN capability to negotiate. (Inherited from Accusoft.TwainProSdk.CapabilityContainer)
Public Property | Value | Gets and sets the capability value.
Top

See Also

Reference

CapabilityContainerOneValueString Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Value Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > CapabilityContainerOneValueString Class : Value Property

Glossary Item Box

Gets and sets the capability value.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DescriptionAttribute("The capability value.")>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property Value As String
'Usage

Dim instance As CapabilityContainerOneValueString
Dim value As String

instance.Value = value

value = instance.Value
[DescriptionAttribute("The capability value.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public string Value {get; set;}
[DescriptionAttribute("The capability value.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property string* get_Value();
public: __property void set_Value(
   string* value
);
[DescriptionAttribute("The capability value.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property String^ Value {
   String^ get();
   void set (    String^ value);
}

Property Value

A string which represents the capability value.

See Also

Reference

CapabilityContainerOneValueString Class
CapabilityContainerOneValueString Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
CapabilityContainerRange Class
Members See Also Send Feedback
Accusoft.TwainProSdk Namespace : CapabilityContainerRange Class

Glossary Item Box

This class implements a range type container for storing capability information.

Object Model

CapabilityContainerRange Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Class CapabilityContainerRange
   Inherits CapabilityContainer
'Usage

Dim instance As CapabilityContainerRange
public class CapabilityContainerRange : CapabilityContainer
public __gc class CapabilityContainerRange : public CapabilityContainer
public ref class CapabilityContainerRange : public CapabilityContainer

Remarks

This object stores a range of values, a current value, and a default value.

Inheritance Hierarchy

System.Object
Accusoft.TwainProSdk.CapabilityContainer
Accusoft.TwainProSdk.CapabilityContainerRange

See Also

Reference

CapabilityContainerRange Members
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.TwainPro7.Net
CapabilityContainerRange Class Members
See Also Properties Send Feedback
Accusoft.TwainProSdk Namespace : CapabilityContainerRange Class

Glossary Item Box

The following tables list the members exposed by CapabilityContainerRange.

Public Constructors

 | Name | Description
Public Constructor | CapabilityContainerRange Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Capability | Gets and sets which TWAIN capability to negotiate. (Inherited from Accusoft.TwainProSdk.CapabilityContainer)
Public Property | Default | Gets the default capability value.
Public Property | Maximum | Gets and sets the maximum capability value.
Public Property | Minimum | Gets and sets the minimum capability value.
Public Property | Step | Gets and sets the step value in the capability range.
Public Property | Value | Gets and sets the capability value.
Top

See Also

Reference

CapabilityContainerRange Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
CapabilityContainerRange Constructor
See Also Send Feedback
Accusoft.TwainProSdk Namespace > CapabilityContainerRange Class : CapabilityContainerRange Constructor

Glossary Item Box

Overload List

Overload | Description
CapabilityContainerRange Constructor(Int32) | A CapabilityContainerRange constructor.
CapabilityContainerRange Constructor(Capability) | A CapabilityContainerRange constructor which allows passing in a capability.
CapabilityContainerRange Constructor(AdvancedCapability) | A CapabilityContainerRange constructor which allows passing in an advanced capability.

See Also

Reference

CapabilityContainerRange Class
CapabilityContainerRange Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
CapabilityContainerRange Constructor(Int32)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > CapabilityContainerRange Class > CapabilityContainerRange Constructor : CapabilityContainerRange Constructor(Int32)

capability
An integer which represents the capability value.

Glossary Item Box

A CapabilityContainerRange constructor.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal capability As Integer _
)
'Usage

Dim capability As Integer

Dim instance As New CapabilityContainerRange(capability)
public CapabilityContainerRange(
   int capability
)
public: CapabilityContainerRange(
   int capability
)
public:
CapabilityContainerRange(
   int capability
)

Parameters

capability
An integer which represents the capability value.

See Also

Reference

CapabilityContainerRange Class
CapabilityContainerRange Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
CapabilityContainerRange Constructor(Capability)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > CapabilityContainerRange Class > CapabilityContainerRange Constructor : CapabilityContainerRange Constructor(Capability)

capability
A CapabilityContainer.Capability object which represents the capability value.

Glossary Item Box

A CapabilityContainerRange constructor which allows passing in a capability.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal capability As Capability _
)
'Usage

Dim capability As Capability

Dim instance As New CapabilityContainerRange(capability)
public CapabilityContainerRange(
   Capability capability
)
public: CapabilityContainerRange(
   Capability capability
)
public:
CapabilityContainerRange(
   Capability capability
)

Parameters

capability
A CapabilityContainer.Capability object which represents the capability value.

See Also

Reference

CapabilityContainerRange Class
CapabilityContainerRange Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
CapabilityContainerRange Constructor(AdvancedCapability)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > CapabilityContainerRange Class > CapabilityContainerRange Constructor : CapabilityContainerRange Constructor(AdvancedCapability)

capability
An advanced capability value which represents the capability value.

Glossary Item Box

A CapabilityContainerRange constructor which allows passing in an advanced capability.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal capability As AdvancedCapability _
)
'Usage

Dim capability As AdvancedCapability

Dim instance As New CapabilityContainerRange(capability)
public CapabilityContainerRange(
   AdvancedCapability capability
)
public: CapabilityContainerRange(
   AdvancedCapability capability
)
public:
CapabilityContainerRange(
   AdvancedCapability capability
)

Parameters

capability
An advanced capability value which represents the capability value.

See Also

Reference

CapabilityContainerRange Class
CapabilityContainerRange Members
Overload List


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.TwainPro7.Net
CapabilityContainerRange Class Properties
See Also Send Feedback
Accusoft.TwainProSdk Namespace : CapabilityContainerRange Class

Glossary Item Box

For a list of all members of this type, see CapabilityContainerRange members.

Public Properties

 | Name | Description
Public Property | Capability | Gets and sets which TWAIN capability to negotiate. (Inherited from Accusoft.TwainProSdk.CapabilityContainer)
Public Property | Default | Gets the default capability value.
Public Property | Maximum | Gets and sets the maximum capability value.
Public Property | Minimum | Gets and sets the minimum capability value.
Public Property | Step | Gets and sets the step value in the capability range.
Public Property | Value | Gets and sets the capability value.
Top

See Also

Reference

CapabilityContainerRange Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Default Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > CapabilityContainerRange Class : Default Property

Glossary Item Box

Gets the default capability value.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DescriptionAttribute("The default capability value.")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
Public ReadOnly Property Default As Single
'Usage

Dim instance As CapabilityContainerRange
Dim value As Single

value = instance.Default
[DescriptionAttribute("The default capability value.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public float Default {get;}
[DescriptionAttribute("The default capability value.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public: __property float get_Default();
[DescriptionAttribute("The default capability value.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public:
property float Default {
   float get();
}

Property Value

A float value which represents the default capability.

Remarks

The default value is -1.

See Also

Reference

CapabilityContainerRange Class
CapabilityContainerRange Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Maximum Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > CapabilityContainerRange Class : Maximum Property

Glossary Item Box

Gets and sets the maximum capability value.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DescriptionAttribute("The maximum capability value.")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property Maximum As Single
'Usage

Dim instance As CapabilityContainerRange
Dim value As Single

instance.Maximum = value

value = instance.Maximum
[BrowsableAttribute(false)]
[DescriptionAttribute("The maximum capability value.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public float Maximum {get; set;}
[BrowsableAttribute(false)]
[DescriptionAttribute("The maximum capability value.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property float get_Maximum();
public: __property void set_Maximum(
   float value
);
[BrowsableAttribute(false)]
[DescriptionAttribute("The maximum capability value.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property float Maximum {
   float get();
   void set (    float value);
}

Property Value

A float value which represents the maximum capability value.

Remarks

The default value is -1.

See Also

Reference

CapabilityContainerRange Class
CapabilityContainerRange Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Minimum Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > CapabilityContainerRange Class : Minimum Property

Glossary Item Box

Gets and sets the minimum capability value.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DescriptionAttribute("The minimum capability value.")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
Public Property Minimum As Single
'Usage

Dim instance As CapabilityContainerRange
Dim value As Single

instance.Minimum = value

value = instance.Minimum
[DescriptionAttribute("The minimum capability value.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public float Minimum {get; set;}
[DescriptionAttribute("The minimum capability value.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public: __property float get_Minimum();
public: __property void set_Minimum(
   float value
);
[DescriptionAttribute("The minimum capability value.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public:
property float Minimum {
   float get();
   void set (    float value);
}

Property Value

A float value which represents the minimum capability value.

Remarks

The default value is -1.

See Also

Reference

CapabilityContainerRange Class
CapabilityContainerRange Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Step Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > CapabilityContainerRange Class : Step Property

Glossary Item Box

Gets and sets the step value in the capability range.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DescriptionAttribute("The step value in a range.")>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property Step As Single
'Usage

Dim instance As CapabilityContainerRange
Dim value As Single

instance.Step = value

value = instance.Step
[DescriptionAttribute("The step value in a range.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public float Step {get; set;}
[DescriptionAttribute("The step value in a range.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property float get_Step();
public: __property void set_Step(
   float value
);
[DescriptionAttribute("The step value in a range.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property float Step {
   float get();
   void set (    float value);
}

Property Value

A float value which represents the step value in a range.

Remarks

The default value is -1.

This is the increment that the TWAIN device prefers when setting a new value. For example, if Capability = ICAP_XRESOLUTION, Minimum = 100, Maximum = 600 and Step = 100, then a legal new value would be in the range of 100 - 600 in increments of 100.

See Also

Reference

CapabilityContainerRange Class
CapabilityContainerRange Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Value Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > CapabilityContainerRange Class : Value Property

Glossary Item Box

Gets and sets the capability value.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DescriptionAttribute("The capability value.")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property Value As Single
'Usage

Dim instance As CapabilityContainerRange
Dim value As Single

instance.Value = value

value = instance.Value
[BrowsableAttribute(false)]
[DescriptionAttribute("The capability value.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public float Value {get; set;}
[BrowsableAttribute(false)]
[DescriptionAttribute("The capability value.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property float get_Value();
public: __property void set_Value(
   float value
);
[BrowsableAttribute(false)]
[DescriptionAttribute("The capability value.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property float Value {
   float get();
   void set (    float value);
}

Property Value

A float value which represents the capability value.

Remarks

The default value is -1.

See Also

Reference

CapabilityContainerRange Class
CapabilityContainerRange Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
CapabilityNotSupportedException Class
Members See Also Send Feedback
Accusoft.TwainProSdk Namespace : CapabilityNotSupportedException Class

Glossary Item Box

This exception is thrown if an operation is performed using an unsupported capability.

Object Model

CapabilityNotSupportedException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class CapabilityNotSupportedException
   Inherits TwainProException
'Usage

Dim instance As CapabilityNotSupportedException
[SerializableAttribute()]
public sealed class CapabilityNotSupportedException : TwainProException
[SerializableAttribute()]
public __gc __sealed class CapabilityNotSupportedException : public TwainProException
[SerializableAttribute()]
public ref class CapabilityNotSupportedException sealed : public TwainProException

Remarks

This error might also occur if a SetCapability operation is performed before calling OpenSession.

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.TwainProSdk.TwainProException
Accusoft.TwainProSdk.CapabilityNotSupportedException

See Also

Reference

CapabilityNotSupportedException Members
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.TwainPro7.Net
CapabilityNotSupportedException Class Members
See Also Properties Methods Send Feedback
Accusoft.TwainProSdk Namespace : CapabilityNotSupportedException Class

Glossary Item Box

The following tables list the members exposed by CapabilityNotSupportedException.

Public Constructors

 | Name | Description
Public Constructor | CapabilityNotSupportedException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.TwainProSdk.TwainProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

CapabilityNotSupportedException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.TwainPro7.Net
CapabilityNotSupportedException Class Methods
See Also Send Feedback
Accusoft.TwainProSdk Namespace : CapabilityNotSupportedException Class

Glossary Item Box

For a list of all members of this type, see CapabilityNotSupportedException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

CapabilityNotSupportedException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.TwainPro7.Net
CapabilityNotSupportedException Class Properties
See Also Send Feedback
Accusoft.TwainProSdk Namespace : CapabilityNotSupportedException Class

Glossary Item Box

For a list of all members of this type, see CapabilityNotSupportedException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.TwainProSdk.TwainProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

CapabilityNotSupportedException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
CapabilityNotSupportedException Constructor
See Also Send Feedback
Accusoft.TwainProSdk Namespace > CapabilityNotSupportedException Class : CapabilityNotSupportedException Constructor

Glossary Item Box

Overload List

Overload | Description
CapabilityNotSupportedException Constructor() | An exception generated for a capability not supported error.
CapabilityNotSupportedException Constructor(Int32) | Generated exception for a capability not supported error with a given error number.
CapabilityNotSupportedException Constructor(String) | Generated exception for a capability not supported error with a given string.
CapabilityNotSupportedException Constructor(Int32,String) | Generated exception for a capability not supported error with a given error number and message.
CapabilityNotSupportedException Constructor(String,Exception) | Generated exception for a capability not supported error with a given message and inner exception.

See Also

Reference

CapabilityNotSupportedException Class
CapabilityNotSupportedException Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
CapabilityNotSupportedException Constructor()
See Also Send Feedback
Accusoft.TwainProSdk Namespace > CapabilityNotSupportedException Class > CapabilityNotSupportedException Constructor : CapabilityNotSupportedException Constructor()

Glossary Item Box

An exception generated for a capability not supported error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New CapabilityNotSupportedException()
public CapabilityNotSupportedException()
public: CapabilityNotSupportedException();
public:
CapabilityNotSupportedException();

See Also

Reference

CapabilityNotSupportedException Class
CapabilityNotSupportedException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
CapabilityNotSupportedException Constructor(Int32)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > CapabilityNotSupportedException Class > CapabilityNotSupportedException Constructor : CapabilityNotSupportedException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a capability not supported error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New CapabilityNotSupportedException(errorNumber)
public CapabilityNotSupportedException(
   int errorNumber
)
public: CapabilityNotSupportedException(
   int errorNumber
)
public:
CapabilityNotSupportedException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

CapabilityNotSupportedException Class
CapabilityNotSupportedException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
CapabilityNotSupportedException Constructor(String)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > CapabilityNotSupportedException Class > CapabilityNotSupportedException Constructor : CapabilityNotSupportedException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a capability not supported error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New CapabilityNotSupportedException(message)
public CapabilityNotSupportedException(
   string message
)
public: CapabilityNotSupportedException(
   string* message
)
public:
CapabilityNotSupportedException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

CapabilityNotSupportedException Class
CapabilityNotSupportedException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
CapabilityNotSupportedException Constructor(Int32,String)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > CapabilityNotSupportedException Class > CapabilityNotSupportedException Constructor : CapabilityNotSupportedException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a capability not supported error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New CapabilityNotSupportedException(errorNumber, message)
public CapabilityNotSupportedException(
   int errorNumber,
   string message
)
public: CapabilityNotSupportedException(
   int errorNumber,
   string* message
)
public:
CapabilityNotSupportedException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

CapabilityNotSupportedException Class
CapabilityNotSupportedException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
CapabilityNotSupportedException Constructor(String,Exception)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > CapabilityNotSupportedException Class > CapabilityNotSupportedException Constructor : CapabilityNotSupportedException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a capability not supported error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New CapabilityNotSupportedException(message, innerException)
public CapabilityNotSupportedException(
   string message,
   Exception innerException
)
public: CapabilityNotSupportedException(
   string* message,
   Exception* innerException
)
public:
CapabilityNotSupportedException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

CapabilityNotSupportedException Class
CapabilityNotSupportedException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Caption Class
Members See Also Send Feedback
Accusoft.TwainProSdk Namespace : Caption Class

Glossary Item Box

This class implements an object that stores the settings used to place a caption on images when they are scanned.

Object Model

Caption Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Class Caption
'Usage

Dim instance As Caption
public class Caption
public __gc class Caption
public ref class Caption

Inheritance Hierarchy

System.Object
Accusoft.TwainProSdk.Caption

See Also

Reference

Caption Members
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.TwainPro7.Net
Caption Class Members
See Also Properties Methods Send Feedback
Accusoft.TwainProSdk Namespace : Caption Class

Glossary Item Box

The following tables list the members exposed by Caption.

Public Properties

 | Name | Description
Public Property | Area | Gets and sets the area to write the caption to a frame during a frame capture.
Public Property | Clip | Gets and sets an indicator if the Caption is clipped by the Width and Height of the Area property or clipped using the right and bottom edges of the frame.
Public Property | Font | Gets and sets the font used to draw the Caption on the current still frame.
Public Property | ForeColor | Gets and sets the color used to draw the Caption on the current still frame.
Public Property | HorizontalAlignment | Gets and sets the horizontal alignment of the caption within the clipping rectangle.
Public Property | ShadowText | Gets and sets an indicator if a drop shadow should be placed under the caption.
Public Property | Text | Gets and sets the text that will be placed on a still frame.
Public Property | VerticalAlignment | Gets and sets the vertical alignment of the caption within the clipping rectangle.
Top

Public Methods

 | Name | Description
Public Method | Dispose | Disposes of unmanaged resources.
Top

See Also

Reference

Caption Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.TwainPro7.Net
Caption Class Methods
See Also Send Feedback
Accusoft.TwainProSdk Namespace : Caption Class

Glossary Item Box

For a list of all members of this type, see Caption members.

Public Methods

 | Name | Description
Public Method | Dispose | Disposes of unmanaged resources.
Top

See Also

Reference

Caption Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Dispose() Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > Caption Class : Dispose() Method

Glossary Item Box

Disposes of unmanaged resources.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub Dispose()
'Usage

Dim instance As Caption

instance.Dispose()
public void Dispose()
public: void Dispose();
public:
void Dispose();

Remarks

This method is part of the IDisposable interface.

See Also

Reference

Caption Class
Caption Members


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.TwainPro7.Net
Caption Class Properties
See Also Send Feedback
Accusoft.TwainProSdk Namespace : Caption Class

Glossary Item Box

For a list of all members of this type, see Caption members.

Public Properties

 | Name | Description
Public Property | Area | Gets and sets the area to write the caption to a frame during a frame capture.
Public Property | Clip | Gets and sets an indicator if the Caption is clipped by the Width and Height of the Area property or clipped using the right and bottom edges of the frame.
Public Property | Font | Gets and sets the font used to draw the Caption on the current still frame.
Public Property | ForeColor | Gets and sets the color used to draw the Caption on the current still frame.
Public Property | HorizontalAlignment | Gets and sets the horizontal alignment of the caption within the clipping rectangle.
Public Property | ShadowText | Gets and sets an indicator if a drop shadow should be placed under the caption.
Public Property | Text | Gets and sets the text that will be placed on a still frame.
Public Property | VerticalAlignment | Gets and sets the vertical alignment of the caption within the clipping rectangle.
Top

See Also

Reference

Caption Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Dispose Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > Caption Class : Dispose Method

Glossary Item Box

Disposes of unmanaged resources.

Overload List

Overload | Description
Dispose | Disposes of unmanaged resources.

See Also

Reference

Caption Class
Caption Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Area Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > Caption Class : Area Property

Glossary Item Box

Gets and sets the area to write the caption to a frame during a frame capture.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
<DescriptionAttribute("Gets or sets the area to write the caption to a frame during a frame capture.")>
Public Property Area As Rectangle
'Usage

Dim instance As Caption
Dim value As Rectangle

instance.Area = value

value = instance.Area
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
[DescriptionAttribute("Gets or sets the area to write the caption to a frame during a frame capture.")]
public Rectangle Area {get; set;}
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
[DescriptionAttribute("Gets or sets the area to write the caption to a frame during a frame capture.")]
public: __property Rectangle get_Area();
public: __property void set_Area(
   Rectangle value
);
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
[DescriptionAttribute("Gets or sets the area to write the caption to a frame during a frame capture.")]
public:
property Rectangle Area {
   Rectangle get();
   void set (    Rectangle value);
}

Property Value

A System.Drawing.Rectangle which represents the area to write the caption.

Remarks

The default value is X=0, Y=0, Width=0, Height=0

See Also

Reference

Caption Class
Caption Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Clip Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > Caption Class : Clip Property

Glossary Item Box

Gets and sets an indicator if the Caption is clipped by the Width and Height of the Area property or clipped using the right and bottom edges of the frame.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<DefaultValueAttribute()>
<DescriptionAttribute("Determines if the Caption is clipped by the Width and Height of the Area property or clipped using the right and bottom edges of the frame.")>
Public Property Clip As Boolean
'Usage

Dim instance As Caption
Dim value As Boolean

instance.Clip = value

value = instance.Clip
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DefaultValueAttribute()]
[DescriptionAttribute("Determines if the Caption is clipped by the Width and Height of the Area property or clipped using the right and bottom edges of the frame.")]
public bool Clip {get; set;}
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DefaultValueAttribute()]
[DescriptionAttribute("Determines if the Caption is clipped by the Width and Height of the Area property or clipped using the right and bottom edges of the frame.")]
public: __property bool get_Clip();
public: __property void set_Clip(
   bool value
);
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DefaultValueAttribute()]
[DescriptionAttribute("Determines if the Caption is clipped by the Width and Height of the Area property or clipped using the right and bottom edges of the frame.")]
public:
property bool Clip {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true to clip the width and height. Otherwise, false is used and the area is not clipped.

Remarks

The default value is false.

Note: This property has no effect on the Left and Top of the Area property which are always used to determine the placement of the caption.

See Also

Reference

Caption Class
Caption Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Font Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > Caption Class : Font Property

Glossary Item Box

Gets and sets the font used to draw the Caption on the current still frame.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<DescriptionAttribute("Sets the font used to draw the Caption on the current still frame.")>
Public Property Font As Font
'Usage

Dim instance As Caption
Dim value As Font

instance.Font = value

value = instance.Font
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DescriptionAttribute("Sets the font used to draw the Caption on the current still frame.")]
public Font Font {get; set;}
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DescriptionAttribute("Sets the font used to draw the Caption on the current still frame.")]
public: __property Font* get_Font();
public: __property void set_Font(
   Font* value
);
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DescriptionAttribute("Sets the font used to draw the Caption on the current still frame.")]
public:
property Font^ Font {
   Font^ get();
   void set (    Font^ value);
}

Property Value

The System.Drawing.Font value to get or set.

Remarks

The default value is 8 point MS Sans Serif.

See Also

Reference

Caption Class
Caption Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
ForeColor Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > Caption Class : ForeColor Property

Glossary Item Box

Gets and sets the color used to draw the Caption on the current still frame.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<DescriptionAttribute("Sets the color used to draw the Caption on the current still frame.")>
Public Property ForeColor As Color
'Usage

Dim instance As Caption
Dim value As Color

instance.ForeColor = value

value = instance.ForeColor
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DescriptionAttribute("Sets the color used to draw the Caption on the current still frame.")]
public Color ForeColor {get; set;}
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DescriptionAttribute("Sets the color used to draw the Caption on the current still frame.")]
public: __property Color get_ForeColor();
public: __property void set_ForeColor(
   Color value
);
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DescriptionAttribute("Sets the color used to draw the Caption on the current still frame.")]
public:
property Color ForeColor {
   Color get();
   void set (    Color value);
}

Property Value

A System.Drawing.Color value which is used to draw the color of the Caption.

Remarks

The default value is System.Drawing.Color.Black.

See Also

Reference

Caption Class
Caption Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
HorizontalAlignment Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > Caption Class : HorizontalAlignment Property

Glossary Item Box

Gets and sets the horizontal alignment of the caption within the clipping rectangle.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<DefaultValueAttribute()>
<DescriptionAttribute("Controls the horizontal alignment of the caption within the clipping rectangle.")>
<BrowsableAttribute(False)>
Public Property HorizontalAlignment As HorizontalAlignment
'Usage

Dim instance As Caption
Dim value As HorizontalAlignment

instance.HorizontalAlignment = value

value = instance.HorizontalAlignment
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DefaultValueAttribute()]
[DescriptionAttribute("Controls the horizontal alignment of the caption within the clipping rectangle.")]
[BrowsableAttribute(false)]
public HorizontalAlignment HorizontalAlignment {get; set;}
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DefaultValueAttribute()]
[DescriptionAttribute("Controls the horizontal alignment of the caption within the clipping rectangle.")]
[BrowsableAttribute(false)]
public: __property HorizontalAlignment get_HorizontalAlignment();
public: __property void set_HorizontalAlignment(
   HorizontalAlignment value
);
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DefaultValueAttribute()]
[DescriptionAttribute("Controls the horizontal alignment of the caption within the clipping rectangle.")]
[BrowsableAttribute(false)]
public:
property HorizontalAlignment HorizontalAlignment {
   HorizontalAlignment get();
   void set (    HorizontalAlignment value);
}

Property Value

A HorizontalAlignment enumeration value which contains horizontal alignment options to use for clipping the rectangle.

Remarks

The default value is HorizontalAlignment.Left.

The clipping rectangle is determined by the Clip and Area properties.

See Also

Reference

Caption Class
Caption Members
Clip Property
Area Property


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
ShadowText Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > Caption Class : ShadowText Property

Glossary Item Box

Gets and sets an indicator if a drop shadow should be placed under the caption.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DescriptionAttribute("Specifies if a drop shadow should be placed under the caption.")>
<DefaultValueAttribute()>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property ShadowText As Boolean
'Usage

Dim instance As Caption
Dim value As Boolean

instance.ShadowText = value

value = instance.ShadowText
[DescriptionAttribute("Specifies if a drop shadow should be placed under the caption.")]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public bool ShadowText {get; set;}
[DescriptionAttribute("Specifies if a drop shadow should be placed under the caption.")]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property bool get_ShadowText();
public: __property void set_ShadowText(
   bool value
);
[DescriptionAttribute("Specifies if a drop shadow should be placed under the caption.")]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property bool ShadowText {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true if a drop shadow should be placed under the caption. Otherwise, false should be used to not place a drop shadow under the caption.

Remarks

The default value is true.

The color of the drop shadow is calculated automatically from the value of the ForeColor property.

See Also

Reference

Caption Class
Caption Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Text Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > Caption Class : Text Property

Glossary Item Box

Gets and sets the text that will be placed on a still frame.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
<DefaultValueAttribute()>
<DescriptionAttribute("Gets or sets the text that will be placed on a still frame.")>
Public Property Text As String
'Usage

Dim instance As Caption
Dim value As String

instance.Text = value

value = instance.Text
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the text that will be placed on a still frame.")]
public string Text {get; set;}
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the text that will be placed on a still frame.")]
public: __property string* get_Text();
public: __property void set_Text(
   string* value
);
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the text that will be placed on a still frame.")]
public:
property String^ Text {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value which represents the text to be placed on a still frame.

Remarks

The default value is an empty string "".

To scan an image without a caption, set this property to "".

See Also

Reference

Caption Class
Caption Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
VerticalAlignment Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > Caption Class : VerticalAlignment Property

Glossary Item Box

Gets and sets the vertical alignment of the caption within the clipping rectangle.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DefaultValueAttribute()>
<DescriptionAttribute("Controls the vertical alignment of the caption within the clipping rectangle.")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
Public Property VerticalAlignment As VerticalAlignment
'Usage

Dim instance As Caption
Dim value As VerticalAlignment

instance.VerticalAlignment = value

value = instance.VerticalAlignment
[DefaultValueAttribute()]
[DescriptionAttribute("Controls the vertical alignment of the caption within the clipping rectangle.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public VerticalAlignment VerticalAlignment {get; set;}
[DefaultValueAttribute()]
[DescriptionAttribute("Controls the vertical alignment of the caption within the clipping rectangle.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public: __property VerticalAlignment get_VerticalAlignment();
public: __property void set_VerticalAlignment(
   VerticalAlignment value
);
[DefaultValueAttribute()]
[DescriptionAttribute("Controls the vertical alignment of the caption within the clipping rectangle.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public:
property VerticalAlignment VerticalAlignment {
   VerticalAlignment get();
   void set (    VerticalAlignment value);
}

Property Value

A VerticalAlignment enumeration value which determines the vertical alignment of the clipping rectangle.

Remarks

The default value is VerticalAlignment.Top.

The clipping rectangle is determined by the Clip and Area properties.

See Also

Reference

Caption Class
Caption Members
Clip Property
Area Property


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
ClipboardException Class
Members See Also Send Feedback
Accusoft.TwainProSdk Namespace : ClipboardException Class

Glossary Item Box

This exception is thrown if an error occurs trying to open the clipboard with the CopyToClipboard or CutToClipboard method.

Object Model

ClipboardException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class ClipboardException
   Inherits TwainProException
'Usage

Dim instance As ClipboardException
[SerializableAttribute()]
public sealed class ClipboardException : TwainProException
[SerializableAttribute()]
public __gc __sealed class ClipboardException : public TwainProException
[SerializableAttribute()]
public ref class ClipboardException sealed : public TwainProException

Remarks

Possible causes:

Another application has the clipboard open.

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.TwainProSdk.TwainProException
Accusoft.TwainProSdk.ClipboardException

See Also

Reference

ClipboardException Members
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.TwainPro7.Net
ClipboardException Class Members
See Also Properties Methods Send Feedback
Accusoft.TwainProSdk Namespace : ClipboardException Class

Glossary Item Box

The following tables list the members exposed by ClipboardException.

Public Constructors

 | Name | Description
Public Constructor | ClipboardException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.TwainProSdk.TwainProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ClipboardException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.TwainPro7.Net
ClipboardException Class Methods
See Also Send Feedback
Accusoft.TwainProSdk Namespace : ClipboardException Class

Glossary Item Box

For a list of all members of this type, see ClipboardException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ClipboardException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.TwainPro7.Net
ClipboardException Class Properties
See Also Send Feedback
Accusoft.TwainProSdk Namespace : ClipboardException Class

Glossary Item Box

For a list of all members of this type, see ClipboardException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.TwainProSdk.TwainProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ClipboardException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
ClipboardException Constructor
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ClipboardException Class : ClipboardException Constructor

Glossary Item Box

Overload List

Overload | Description
ClipboardException Constructor() | An exception generated for a clipboard error.
ClipboardException Constructor(Int32) | Generated exception for a clipboard error with a given error number.
ClipboardException Constructor(String) | Generated exception for a clipboard error with a given string.
ClipboardException Constructor(Int32,String) | Generated exception for a clipboard error with a given error number and message.
ClipboardException Constructor(String,Exception) | Generated exception for a clipboard error with a given message and inner exception.

See Also

Reference

ClipboardException Class
ClipboardException Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
ClipboardException Constructor()
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ClipboardException Class > ClipboardException Constructor : ClipboardException Constructor()

Glossary Item Box

An exception generated for a clipboard error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ClipboardException()
public ClipboardException()
public: ClipboardException();
public:
ClipboardException();

See Also

Reference

ClipboardException Class
ClipboardException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
ClipboardException Constructor(Int32)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ClipboardException Class > ClipboardException Constructor : ClipboardException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a clipboard error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New ClipboardException(errorNumber)
public ClipboardException(
   int errorNumber
)
public: ClipboardException(
   int errorNumber
)
public:
ClipboardException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

ClipboardException Class
ClipboardException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
ClipboardException Constructor(String)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ClipboardException Class > ClipboardException Constructor : ClipboardException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a clipboard error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New ClipboardException(message)
public ClipboardException(
   string message
)
public: ClipboardException(
   string* message
)
public:
ClipboardException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

ClipboardException Class
ClipboardException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
ClipboardException Constructor(Int32,String)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ClipboardException Class > ClipboardException Constructor : ClipboardException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a clipboard error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New ClipboardException(errorNumber, message)
public ClipboardException(
   int errorNumber,
   string message
)
public: ClipboardException(
   int errorNumber,
   string* message
)
public:
ClipboardException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

ClipboardException Class
ClipboardException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
ClipboardException Constructor(String,Exception)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ClipboardException Class > ClipboardException Constructor : ClipboardException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a clipboard error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New ClipboardException(message, innerException)
public ClipboardException(
   string message,
   Exception innerException
)
public: ClipboardException(
   string* message,
   Exception* innerException
)
public:
ClipboardException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

ClipboardException Class
ClipboardException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
CompressedImageNotAvailableException Class
Members See Also Send Feedback
Accusoft.TwainProSdk Namespace : CompressedImageNotAvailableException Class

Glossary Item Box

This exception is thrown if no compressed image is available for the requested operation or an unsupported compressed image format was returned in response to a StartSession.

Object Model

CompressedImageNotAvailableException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class CompressedImageNotAvailableException
   Inherits TwainProException
'Usage

Dim instance As CompressedImageNotAvailableException
[SerializableAttribute()]
public sealed class CompressedImageNotAvailableException : TwainProException
[SerializableAttribute()]
public __gc __sealed class CompressedImageNotAvailableException : public TwainProException
[SerializableAttribute()]
public ref class CompressedImageNotAvailableException sealed : public TwainProException

Remarks

Possible causes:

The SaveStream method was already called.

The Save method was invoked after the SaveStream method was called.

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.TwainProSdk.TwainProException
Accusoft.TwainProSdk.CompressedImageNotAvailableException

See Also

Reference

CompressedImageNotAvailableException Members
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.TwainPro7.Net
CompressedImageNotAvailableException Class Members
See Also Properties Methods Send Feedback
Accusoft.TwainProSdk Namespace : CompressedImageNotAvailableException Class

Glossary Item Box

The following tables list the members exposed by CompressedImageNotAvailableException.

Public Constructors

 | Name | Description
Public Constructor | CompressedImageNotAvailableException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.TwainProSdk.TwainProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

CompressedImageNotAvailableException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.TwainPro7.Net
CompressedImageNotAvailableException Class Methods
See Also Send Feedback
Accusoft.TwainProSdk Namespace : CompressedImageNotAvailableException Class

Glossary Item Box

For a list of all members of this type, see CompressedImageNotAvailableException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

CompressedImageNotAvailableException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.TwainPro7.Net
CompressedImageNotAvailableException Class Properties
See Also Send Feedback
Accusoft.TwainProSdk Namespace : CompressedImageNotAvailableException Class

Glossary Item Box

For a list of all members of this type, see CompressedImageNotAvailableException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.TwainProSdk.TwainProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

CompressedImageNotAvailableException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
CompressedImageNotAvailableException Constructor
See Also Send Feedback
Accusoft.TwainProSdk Namespace > CompressedImageNotAvailableException Class : CompressedImageNotAvailableException Constructor

Glossary Item Box

Overload List

Overload | Description
CompressedImageNotAvailableException Constructor() | An exception generated for a compressed image not available error.
CompressedImageNotAvailableException Constructor(Int32) | Generated exception for a compressed image not available error with a given error number.
CompressedImageNotAvailableException Constructor(String) | Generated exception for a compressed image not available error with a given string.
CompressedImageNotAvailableException Constructor(Int32,String) | Generated exception for a compressed image not available error with a given error number and message.
CompressedImageNotAvailableException Constructor(String,Exception) | Generated exception for a compressed image not available error with a given message and inner exception.

See Also

Reference

CompressedImageNotAvailableException Class
CompressedImageNotAvailableException Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
CompressedImageNotAvailableException Constructor()
See Also Send Feedback
Accusoft.TwainProSdk Namespace > CompressedImageNotAvailableException Class > CompressedImageNotAvailableException Constructor : CompressedImageNotAvailableException Constructor()

Glossary Item Box

An exception generated for a compressed image not available error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New CompressedImageNotAvailableException()
public CompressedImageNotAvailableException()
public: CompressedImageNotAvailableException();
public:
CompressedImageNotAvailableException();

See Also

Reference

CompressedImageNotAvailableException Class
CompressedImageNotAvailableException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
CompressedImageNotAvailableException Constructor(Int32)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > CompressedImageNotAvailableException Class > CompressedImageNotAvailableException Constructor : CompressedImageNotAvailableException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a compressed image not available error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New CompressedImageNotAvailableException(errorNumber)
public CompressedImageNotAvailableException(
   int errorNumber
)
public: CompressedImageNotAvailableException(
   int errorNumber
)
public:
CompressedImageNotAvailableException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

CompressedImageNotAvailableException Class
CompressedImageNotAvailableException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
CompressedImageNotAvailableException Constructor(String)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > CompressedImageNotAvailableException Class > CompressedImageNotAvailableException Constructor : CompressedImageNotAvailableException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a compressed image not available error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New CompressedImageNotAvailableException(message)
public CompressedImageNotAvailableException(
   string message
)
public: CompressedImageNotAvailableException(
   string* message
)
public:
CompressedImageNotAvailableException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

CompressedImageNotAvailableException Class
CompressedImageNotAvailableException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
CompressedImageNotAvailableException Constructor(Int32,String)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > CompressedImageNotAvailableException Class > CompressedImageNotAvailableException Constructor : CompressedImageNotAvailableException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a compressed image not available error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New CompressedImageNotAvailableException(errorNumber, message)
public CompressedImageNotAvailableException(
   int errorNumber,
   string message
)
public: CompressedImageNotAvailableException(
   int errorNumber,
   string* message
)
public:
CompressedImageNotAvailableException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

CompressedImageNotAvailableException Class
CompressedImageNotAvailableException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
CompressedImageNotAvailableException Constructor(String,Exception)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > CompressedImageNotAvailableException Class > CompressedImageNotAvailableException Constructor : CompressedImageNotAvailableException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a compressed image not available error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New CompressedImageNotAvailableException(message, innerException)
public CompressedImageNotAvailableException(
   string message,
   Exception innerException
)
public: CompressedImageNotAvailableException(
   string* message,
   Exception* innerException
)
public:
CompressedImageNotAvailableException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

CompressedImageNotAvailableException Class
CompressedImageNotAvailableException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
DataSourceCollection Class
Members See Also Send Feedback
Accusoft.TwainProSdk Namespace : DataSourceCollection Class

Glossary Item Box

A read-only collection of Data Source product names which is set by calling the OpenDataSourceManager method.

Object Model

DataSourceCollection ClassString ClassChar Structure

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DefaultMemberAttribute("Item")>
Public Class DataSourceCollection
   Inherits System.Collections.ReadOnlyCollectionBase
'Usage

Dim instance As DataSourceCollection
[DefaultMemberAttribute("Item")]
public class DataSourceCollection : System.Collections.ReadOnlyCollectionBase
[DefaultMemberAttribute("Item")]
public __gc class DataSourceCollection : public System.Collections.ReadOnlyCollectionBase
[DefaultMemberAttribute("Item")]
public ref class DataSourceCollection : public System.Collections.ReadOnlyCollectionBase

Remarks

This collection contains all of the Data Source product names installed on the current Windows system. Each string is no longer than 32 characters.

Inheritance Hierarchy

System.Object
System.Collections.ReadOnlyCollectionBase
Accusoft.TwainProSdk.DataSourceCollection

See Also

Reference

DataSourceCollection Members
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.TwainPro7.Net
DataSourceCollection Class Members
See Also Properties Methods Send Feedback
Accusoft.TwainProSdk Namespace : DataSourceCollection Class

Glossary Item Box

The following tables list the members exposed by DataSourceCollection.

Public Constructors

 | Name | Description
Public Constructor | DataSourceCollection Constructor | The main constructor for the DataSourceCollection class which allows passing in a Twain device object.
Top

Public Properties

 | Name | Description
Public Property | Count | Gets the number of elements contained in the System.Collections.ReadOnlyCollectionBase instance. (Inherited from System.Collections.ReadOnlyCollectionBase)
Public Property | Current | Gets and sets the index of the currently selected Data Source.
Public Property | Item | Gets the element at the given index.
Top

Public Methods

 | Name | Description
Public Method | Contains | Determines if the specified string is contained in the collection.
Public Method | CopyTo | Copies all elements of the collection to the specified array, beginning at the specified index in the array.
Public Method | Dispose | Disposes of unmanaged resources.
Public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.ReadOnlyCollectionBase instance. (Inherited from System.Collections.ReadOnlyCollectionBase)
Public Method | IndexOf | Determines if the specified string is in the collection and returns the corresponding index value.
Top

See Also

Reference

DataSourceCollection Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
DataSourceCollection Constructor
See Also Send Feedback
Accusoft.TwainProSdk Namespace > DataSourceCollection Class : DataSourceCollection Constructor

twainDevice
A TwainDevice object.

Glossary Item Box

The main constructor for the DataSourceCollection class which allows passing in a Twain device object.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal twainDevice As TwainDevice _
)
'Usage

Dim twainDevice As TwainDevice

Dim instance As New DataSourceCollection(twainDevice)
public DataSourceCollection(
   TwainDevice twainDevice
)
public: DataSourceCollection(
   TwainDevice* twainDevice
)
public:
DataSourceCollection(
   TwainDevice^ twainDevice
)

Parameters

twainDevice
A TwainDevice object.

See Also

Reference

DataSourceCollection Class
DataSourceCollection Members


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.TwainPro7.Net
DataSourceCollection Class Methods
See Also Send Feedback
Accusoft.TwainProSdk Namespace : DataSourceCollection Class

Glossary Item Box

For a list of all members of this type, see DataSourceCollection members.

Public Methods

 | Name | Description
Public Method | Contains | Determines if the specified string is contained in the collection.
Public Method | CopyTo | Copies all elements of the collection to the specified array, beginning at the specified index in the array.
Public Method | Dispose | Disposes of unmanaged resources.
Public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.ReadOnlyCollectionBase instance. (Inherited from System.Collections.ReadOnlyCollectionBase)
Public Method | IndexOf | Determines if the specified string is in the collection and returns the corresponding index value.
Top

See Also

Reference

DataSourceCollection Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Contains Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > DataSourceCollection Class : Contains Method

value

Glossary Item Box

Determines if the specified string is contained in the collection.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function Contains( _
   ByVal value As String _
) As Boolean
'Usage

Dim instance As DataSourceCollection
Dim value As String
Dim value As Boolean

value = instance.Contains(value)
public bool Contains(
   string value
)
public: bool Contains(
   string* value
)
public:
bool Contains(
   String^ value
)

Parameters

value

Return Value

A boolean value which is true if the specified element is found in the collection. Otherwise, false is returned.

Remarks

This method searches the collection for the given string. If a reference to the string is found, this method returns true, otherwise, false is returned.

See Also

Reference

DataSourceCollection Class
DataSourceCollection Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
CopyTo Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > DataSourceCollection Class : CopyTo Method

array
An array that receives the elements of the collection.
index
The zero-based index in array where this method starts copying the collection.

Glossary Item Box

Copies all elements of the collection to the specified array, beginning at the specified index in the array.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub CopyTo( _
   ByVal array() As String, _
   ByVal index As Integer _
)
'Usage

Dim instance As DataSourceCollection
Dim array() As String
Dim index As Integer

instance.CopyTo(array, index)
public void CopyTo(
   string[] array,
   int index
)
public: void CopyTo(
   string*[]* array,
   int index
)
public:
void CopyTo(
   array<String^>^ array,
   int index
)

Parameters

array
An array that receives the elements of the collection.
index
The zero-based index in array where this method starts copying the collection.

Remarks

This method implements a standard collection operation. It copies elements from this collection to the given array in order, starting at element 0 in this collection. It places the elements into the array starting at the given zero-based index. This method will stop copying elements when it reaches the end of the collection or the end of the array.

See Also

Reference

DataSourceCollection Class
DataSourceCollection Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Dispose Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > DataSourceCollection Class : Dispose Method

Glossary Item Box

Disposes of unmanaged resources.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub Dispose()
'Usage

Dim instance As DataSourceCollection

instance.Dispose()
public void Dispose()
public: void Dispose();
public:
void Dispose();

Remarks

This method is part of the IDisposable interface.

See Also

Reference

DataSourceCollection Class
DataSourceCollection Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
IndexOf Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > DataSourceCollection Class : IndexOf Method

value

Glossary Item Box

Determines if the specified string is in the collection and returns the corresponding index value.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function IndexOf( _
   ByVal value As String _
) As Integer
'Usage

Dim instance As DataSourceCollection
Dim value As String
Dim value As Integer

value = instance.IndexOf(value)
public int IndexOf(
   string value
)
public: int IndexOf(
   string* value
)
public:
int IndexOf(
   String^ value
)

Parameters

value

Return Value

A zero-based index value which represents where in the collection the element resides.

Remarks

This method searches the collection for a reference to the given object. If it does not find a reference to it, this method returns -1. If the object is present more than once in the collection, this method returns the lowest index of a match.

See Also

Reference

DataSourceCollection Class
DataSourceCollection Members


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.TwainPro7.Net
DataSourceCollection Class Properties
See Also Send Feedback
Accusoft.TwainProSdk Namespace : DataSourceCollection Class

Glossary Item Box

For a list of all members of this type, see DataSourceCollection members.

Public Properties

 | Name | Description
Public Property | Count | Gets the number of elements contained in the System.Collections.ReadOnlyCollectionBase instance. (Inherited from System.Collections.ReadOnlyCollectionBase)
Public Property | Current | Gets and sets the index of the currently selected Data Source.
Public Property | Item | Gets the element at the given index.
Top

See Also

Reference

DataSourceCollection Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Current Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > DataSourceCollection Class : Current Property

Glossary Item Box

Gets and sets the index of the currently selected Data Source.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DefaultValueAttribute()>
<DescriptionAttribute("Returns the index of the currently selected Data Source.")>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property Current As Integer
'Usage

Dim instance As DataSourceCollection
Dim value As Integer

instance.Current = value

value = instance.Current
[DefaultValueAttribute()]
[DescriptionAttribute("Returns the index of the currently selected Data Source.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public int Current {get; set;}
[DefaultValueAttribute()]
[DescriptionAttribute("Returns the index of the currently selected Data Source.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property int get_Current();
public: __property void set_Current(
   int value
);
[DefaultValueAttribute()]
[DescriptionAttribute("Returns the index of the currently selected Data Source.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property int Current {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the index of the currently selected data source.

See Also

Reference

DataSourceCollection Class
DataSourceCollection Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Item Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > DataSourceCollection Class : Item Property

index
A zero-based integer specifying the index in the collection to get or set.

Glossary Item Box

Gets the element at the given index.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DescriptionAttribute("Gets the element at the given index.")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As String
'Usage

Dim instance As DataSourceCollection
Dim index As Integer
Dim value As String

value = instance.Item(index)
[DescriptionAttribute("Gets the element at the given index.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public string this[
   int index
]; {get;}
[DescriptionAttribute("Gets the element at the given index.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public: __property string* get_Item   int index
;
[DescriptionAttribute("Gets the element at the given index.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public:
property String^ default [int] {
   String^ get(int index);
}

Parameters

index
A zero-based integer specifying the index in the collection to get or set.

Property Value

A String value which represents the element at the given index.

Remarks

This method implements a standard collection operation. It is the principle method you will use to read elements in the collection. You can read any element in the collection with this method.

See Also

Reference

DataSourceCollection Class
DataSourceCollection Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
DataSourceInvalidOperationException Class
Members See Also Send Feedback
Accusoft.TwainProSdk Namespace : DataSourceInvalidOperationException Class

Glossary Item Box

This exception is thrown if the Data Source performs an operation that caused an exception.

Object Model

DataSourceInvalidOperationException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class DataSourceInvalidOperationException
   Inherits TwainProException
'Usage

Dim instance As DataSourceInvalidOperationException
[SerializableAttribute()]
public sealed class DataSourceInvalidOperationException : TwainProException
[SerializableAttribute()]
public __gc __sealed class DataSourceInvalidOperationException : public TwainProException
[SerializableAttribute()]
public ref class DataSourceInvalidOperationException sealed : public TwainProException

Remarks

This error is a critical error. If this error is received then the application should be terminated immediately. No other TwainPRO calls should be made after this error is received. This does give the application the chance to do any non-TWAIN clean-up processing as well as inform the user that a critical error has occurred.

Possible causes:

The Data Source TWAIN driver executed an illegal operation, such as an illegal memory access, a divide by zero, etc.

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.TwainProSdk.TwainProException
Accusoft.TwainProSdk.DataSourceInvalidOperationException

See Also

Reference

DataSourceInvalidOperationException Members
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.TwainPro7.Net
DataSourceInvalidOperationException Class Members
See Also Properties Methods Send Feedback
Accusoft.TwainProSdk Namespace : DataSourceInvalidOperationException Class

Glossary Item Box

The following tables list the members exposed by DataSourceInvalidOperationException.

Public Constructors

 | Name | Description
Public Constructor | DataSourceInvalidOperationException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.TwainProSdk.TwainProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

DataSourceInvalidOperationException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.TwainPro7.Net
DataSourceInvalidOperationException Class Methods
See Also Send Feedback
Accusoft.TwainProSdk Namespace : DataSourceInvalidOperationException Class

Glossary Item Box

For a list of all members of this type, see DataSourceInvalidOperationException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

DataSourceInvalidOperationException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.TwainPro7.Net
DataSourceInvalidOperationException Class Properties
See Also Send Feedback
Accusoft.TwainProSdk Namespace : DataSourceInvalidOperationException Class

Glossary Item Box

For a list of all members of this type, see DataSourceInvalidOperationException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.TwainProSdk.TwainProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

DataSourceInvalidOperationException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
DataSourceInvalidOperationException Constructor
See Also Send Feedback
Accusoft.TwainProSdk Namespace > DataSourceInvalidOperationException Class : DataSourceInvalidOperationException Constructor

Glossary Item Box

Overload List

Overload | Description
DataSourceInvalidOperationException Constructor() | An exception generated for a Data Source invalid operation error.
DataSourceInvalidOperationException Constructor(Int32) | Generated exception for a Data Source invalid operation error with a given error number.
DataSourceInvalidOperationException Constructor(String) | Generated exception for a Data Source invalid operation error with a given string.
DataSourceInvalidOperationException Constructor(Int32,String) | Generated exception for a Data Source invalid operation error with a given error number and message.
DataSourceInvalidOperationException Constructor(String,Exception) | Generated exception for a Data Source invalid operation error with a given message and inner exception.

See Also

Reference

DataSourceInvalidOperationException Class
DataSourceInvalidOperationException Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
DataSourceInvalidOperationException Constructor()
See Also Send Feedback
Accusoft.TwainProSdk Namespace > DataSourceInvalidOperationException Class > DataSourceInvalidOperationException Constructor : DataSourceInvalidOperationException Constructor()

Glossary Item Box

An exception generated for a Data Source invalid operation error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New DataSourceInvalidOperationException()
public DataSourceInvalidOperationException()
public: DataSourceInvalidOperationException();
public:
DataSourceInvalidOperationException();

See Also

Reference

DataSourceInvalidOperationException Class
DataSourceInvalidOperationException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
DataSourceInvalidOperationException Constructor(Int32)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > DataSourceInvalidOperationException Class > DataSourceInvalidOperationException Constructor : DataSourceInvalidOperationException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a Data Source invalid operation error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New DataSourceInvalidOperationException(errorNumber)
public DataSourceInvalidOperationException(
   int errorNumber
)
public: DataSourceInvalidOperationException(
   int errorNumber
)
public:
DataSourceInvalidOperationException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

DataSourceInvalidOperationException Class
DataSourceInvalidOperationException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
DataSourceInvalidOperationException Constructor(String)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > DataSourceInvalidOperationException Class > DataSourceInvalidOperationException Constructor : DataSourceInvalidOperationException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a Data Source invalid operation error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New DataSourceInvalidOperationException(message)
public DataSourceInvalidOperationException(
   string message
)
public: DataSourceInvalidOperationException(
   string* message
)
public:
DataSourceInvalidOperationException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

DataSourceInvalidOperationException Class
DataSourceInvalidOperationException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
DataSourceInvalidOperationException Constructor(Int32,String)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > DataSourceInvalidOperationException Class > DataSourceInvalidOperationException Constructor : DataSourceInvalidOperationException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a Data Source invalid operation error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New DataSourceInvalidOperationException(errorNumber, message)
public DataSourceInvalidOperationException(
   int errorNumber,
   string message
)
public: DataSourceInvalidOperationException(
   int errorNumber,
   string* message
)
public:
DataSourceInvalidOperationException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

DataSourceInvalidOperationException Class
DataSourceInvalidOperationException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
DataSourceInvalidOperationException Constructor(String,Exception)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > DataSourceInvalidOperationException Class > DataSourceInvalidOperationException Constructor : DataSourceInvalidOperationException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a Data Source invalid operation error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New DataSourceInvalidOperationException(message, innerException)
public DataSourceInvalidOperationException(
   string message,
   Exception innerException
)
public: DataSourceInvalidOperationException(
   string* message,
   Exception* innerException
)
public:
DataSourceInvalidOperationException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

DataSourceInvalidOperationException Class
DataSourceInvalidOperationException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
ExtendedImageInfoContainer Class
Members See Also Send Feedback
Accusoft.TwainProSdk Namespace : ExtendedImageInfoContainer Class

Glossary Item Box

This class implements extended image info.

Object Model

ExtendedImageInfoContainer ClassExtendedImageInfoContainerValueCollection ClassExtendedImageInfoContainerValue Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Class ExtendedImageInfoContainer
'Usage

Dim instance As ExtendedImageInfoContainer
public class ExtendedImageInfoContainer
public __gc class ExtendedImageInfoContainer
public ref class ExtendedImageInfoContainer

Remarks

You cannot create an ExtendedImageInfoContainer object directly. This read-only object is returned by the ScannedImage.GetExtendedImageInfo method.

Inheritance Hierarchy

System.Object
Accusoft.TwainProSdk.ExtendedImageInfoContainer

See Also

Reference

ExtendedImageInfoContainer Members
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.TwainPro7.Net
ExtendedImageInfoContainer Class Members
See Also Properties Send Feedback
Accusoft.TwainProSdk Namespace : ExtendedImageInfoContainer Class

Glossary Item Box

The following tables list the members exposed by ExtendedImageInfoContainer.

Public Properties

 | Name | Description
Public Property | ExtendedImageInfo | Gets the extended image info identification.
Public Property | Values | Gets a collection of extended image info.
Top

See Also

Reference

ExtendedImageInfoContainer Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.TwainPro7.Net
ExtendedImageInfoContainer Class Properties
See Also Send Feedback
Accusoft.TwainProSdk Namespace : ExtendedImageInfoContainer Class

Glossary Item Box

For a list of all members of this type, see ExtendedImageInfoContainer members.

Public Properties

 | Name | Description
Public Property | ExtendedImageInfo | Gets the extended image info identification.
Public Property | Values | Gets a collection of extended image info.
Top

See Also

Reference

ExtendedImageInfoContainer Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
ExtendedImageInfo Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ExtendedImageInfoContainer Class : ExtendedImageInfo Property

Glossary Item Box

Gets the extended image info identification.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DescriptionAttribute("The extended image info identification.")>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property ExtendedImageInfo As Integer
'Usage

Dim instance As ExtendedImageInfoContainer
Dim value As Integer

value = instance.ExtendedImageInfo
[DescriptionAttribute("The extended image info identification.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public int ExtendedImageInfo {get;}
[DescriptionAttribute("The extended image info identification.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property int get_ExtendedImageInfo();
[DescriptionAttribute("The extended image info identification.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property int ExtendedImageInfo {
   int get();
}

Property Value

An integer value which represents the identity of the extended image info.

Remarks

Returns an identification of the requested value. This matches the value that was passed to the ScannedImage.GetExtendedImageInfo method to obtain this ExtendedImageInfoContainer.

See Also

Reference

ExtendedImageInfoContainer Class
ExtendedImageInfoContainer Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Values Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ExtendedImageInfoContainer Class : Values Property

Glossary Item Box

Gets a collection of extended image info.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public ReadOnly Property Values As ExtendedImageInfoContainerValueCollection
'Usage

Dim instance As ExtendedImageInfoContainer
Dim value As ExtendedImageInfoContainerValueCollection

value = instance.Values
[BrowsableAttribute(false)]
public ExtendedImageInfoContainerValueCollection Values {get;}
[BrowsableAttribute(false)]
public: __property ExtendedImageInfoContainerValueCollection* get_Values();
[BrowsableAttribute(false)]
public:
property ExtendedImageInfoContainerValueCollection^ Values {
   ExtendedImageInfoContainerValueCollection^ get();
}

Property Value

An ExtendedImageInfoContainerValueCollection which contains the extended image info.

Remarks

Returns a collection of ExtendedImageInfoContainerValue objects that contain the extended image info.

See Also

Reference

ExtendedImageInfoContainer Class
ExtendedImageInfoContainer Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
ExtendedImageInfoContainerValue Class
Members See Also Send Feedback
Accusoft.TwainProSdk Namespace : ExtendedImageInfoContainerValue Class

Glossary Item Box

This class implements a single value of extended image info.

Object Model

ExtendedImageInfoContainerValue Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Class ExtendedImageInfoContainerValue
'Usage

Dim instance As ExtendedImageInfoContainerValue
public class ExtendedImageInfoContainerValue
public __gc class ExtendedImageInfoContainerValue
public ref class ExtendedImageInfoContainerValue

Remarks

You cannot create an ExtendedImageInfoContainerValue object directly. This object is a member of the Values collection of the ExtendedImageInfoContainer object which can be obtained by calling the ScannedImage.GetExtendedImageInfo method. The ExtendedImageInfoContainerValueFloat and ExtendedImageInfoContainerValueString objects are inherited from this object, and to access the float or string value stored in this object you must cast this object to the appropriate child object.

Inheritance Hierarchy

System.Object
Accusoft.TwainProSdk.ExtendedImageInfoContainerValue
Accusoft.TwainProSdk.ExtendedImageInfoContainerValueFloat
Accusoft.TwainProSdk.ExtendedImageInfoContainerValueString

See Also

Reference

ExtendedImageInfoContainerValue Members
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.TwainPro7.Net
ExtendedImageInfoContainerValue Class Members
See Also Send Feedback
Accusoft.TwainProSdk Namespace : ExtendedImageInfoContainerValue Class

Glossary Item Box

The following tables list the members exposed by ExtendedImageInfoContainerValue.

See Also

Reference

ExtendedImageInfoContainerValue Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
ExtendedImageInfoContainerValueCollection Class
Members See Also Send Feedback
Accusoft.TwainProSdk Namespace : ExtendedImageInfoContainerValueCollection Class

Glossary Item Box

This class represents a collection of ExtendedImageInfoContainerValue objects.

Object Model

ExtendedImageInfoContainerValueCollection ClassExtendedImageInfoContainerValue Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DefaultMemberAttribute("Item")>
Public Class ExtendedImageInfoContainerValueCollection
   Inherits System.Collections.CollectionBase
'Usage

Dim instance As ExtendedImageInfoContainerValueCollection
[DefaultMemberAttribute("Item")]
public class ExtendedImageInfoContainerValueCollection : System.Collections.CollectionBase
[DefaultMemberAttribute("Item")]
public __gc class ExtendedImageInfoContainerValueCollection : public System.Collections.CollectionBase
[DefaultMemberAttribute("Item")]
public ref class ExtendedImageInfoContainerValueCollection : public System.Collections.CollectionBase

Remarks

This object is used by the ExtendedImageInfoContainer to store a collection of extended image info values.

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Accusoft.TwainProSdk.ExtendedImageInfoContainerValueCollection

See Also

Reference

ExtendedImageInfoContainerValueCollection Members
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.TwainPro7.Net
ExtendedImageInfoContainerValueCollection Class Members
See Also Properties Methods Send Feedback
Accusoft.TwainProSdk Namespace : ExtendedImageInfoContainerValueCollection Class

Glossary Item Box

The following tables list the members exposed by ExtendedImageInfoContainerValueCollection.

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets the element at the given index within the collection.
Top

Public Methods

 | Name | Description
Public Method | Add | Adds an ExtendedImageInfoContainerValue to the collection.
Public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines if the specified ExtendedImageInfoContainerValue is contained in the collection.
Public Method | CopyTo | Copies all elements of the collection to the specified array, beginning at the specified index in the array.
Public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines if the specified ExtendedImageInfoContainerValue is in the collection and returns its index value.
Public Method | Insert | Inserts an ExtendedImageInfoContainerValue into the collection at the given index.
Public Method | Remove | Removes an ExtendedImageInfoContainerValue from the collection.
Public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

ExtendedImageInfoContainerValueCollection Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.TwainPro7.Net
ExtendedImageInfoContainerValueCollection Class Methods
See Also Send Feedback
Accusoft.TwainProSdk Namespace : ExtendedImageInfoContainerValueCollection Class

Glossary Item Box

For a list of all members of this type, see ExtendedImageInfoContainerValueCollection members.

Public Methods

 | Name | Description
Public Method | Add | Adds an ExtendedImageInfoContainerValue to the collection.
Public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines if the specified ExtendedImageInfoContainerValue is contained in the collection.
Public Method | CopyTo | Copies all elements of the collection to the specified array, beginning at the specified index in the array.
Public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines if the specified ExtendedImageInfoContainerValue is in the collection and returns its index value.
Public Method | Insert | Inserts an ExtendedImageInfoContainerValue into the collection at the given index.
Public Method | Remove | Removes an ExtendedImageInfoContainerValue from the collection.
Public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

ExtendedImageInfoContainerValueCollection Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Add Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ExtendedImageInfoContainerValueCollection Class : Add Method

value

Glossary Item Box

Adds an ExtendedImageInfoContainerValue to the collection.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function Add( _
   ByVal value As ExtendedImageInfoContainerValue _
) As Integer
'Usage

Dim instance As ExtendedImageInfoContainerValueCollection
Dim value As ExtendedImageInfoContainerValue
Dim value As Integer

value = instance.Add(value)
public int Add(
   ExtendedImageInfoContainerValue value
)
public: int Add(
   ExtendedImageInfoContainerValue* value
)
public:
int Add(
   ExtendedImageInfoContainerValue^ value
)

Parameters

value

Return Value

An integer which represents the length of the collection.

Remarks

This method inserts a new ExtendedImageInfoContainerValue object at the end of the collection. When this method is complete, the length of the collection will be one larger than it was and the element with the highest index will be the new object.

See Also

Reference

ExtendedImageInfoContainerValueCollection Class
ExtendedImageInfoContainerValueCollection Members
ExtendedImageInfoContainerValue Class


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Contains Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ExtendedImageInfoContainerValueCollection Class : Contains Method

value

Glossary Item Box

Determines if the specified ExtendedImageInfoContainerValue is contained in the collection.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function Contains( _
   ByVal value As ExtendedImageInfoContainerValue _
) As Boolean
'Usage

Dim instance As ExtendedImageInfoContainerValueCollection
Dim value As ExtendedImageInfoContainerValue
Dim value As Boolean

value = instance.Contains(value)
public bool Contains(
   ExtendedImageInfoContainerValue value
)
public: bool Contains(
   ExtendedImageInfoContainerValue* value
)
public:
bool Contains(
   ExtendedImageInfoContainerValue^ value
)

Parameters

value

Return Value

A boolean value which is true if the given element is found within the collection. Otherwise, false is returned.

Remarks

This method searches the collection for the given ExtendedImageInfoContainerValue. If a reference to the ExtendedImageInfoContainerValue is found, this method returns true, otherwise, false is returned.

See Also

Reference

ExtendedImageInfoContainerValueCollection Class
ExtendedImageInfoContainerValueCollection Members
ExtendedImageInfoContainerValue Class


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
CopyTo Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ExtendedImageInfoContainerValueCollection Class : CopyTo Method

array
Contains an array that receives the elements of the collection.
index
Contains the zero-based index in array where this method starts copying the collection.

Glossary Item Box

Copies all elements of the collection to the specified array, beginning at the specified index in the array.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub CopyTo( _
   ByVal array() As ExtendedImageInfoContainerValue, _
   ByVal index As Integer _
)
'Usage

Dim instance As ExtendedImageInfoContainerValueCollection
Dim array() As ExtendedImageInfoContainerValue
Dim index As Integer

instance.CopyTo(array, index)
public void CopyTo(
   ExtendedImageInfoContainerValue[] array,
   int index
)
public: void CopyTo(
   ExtendedImageInfoContainerValue*[]* array,
   int index
)
public:
void CopyTo(
   array<ExtendedImageInfoContainerValue^>^ array,
   int index
)

Parameters

array
Contains an array that receives the elements of the collection.
index
Contains the zero-based index in array where this method starts copying the collection.

Remarks

This method implements a standard collection operation. It copies elements from this collection to the given array in order, starting at element 0 in this collection. It places the elements into the array starting at the given zero-based index. This method will stop copying elements when it reaches the end of the collection or the end of the array.

See Also

Reference

ExtendedImageInfoContainerValueCollection Class
ExtendedImageInfoContainerValueCollection Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
IndexOf Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ExtendedImageInfoContainerValueCollection Class : IndexOf Method

value

Glossary Item Box

Determines if the specified ExtendedImageInfoContainerValue is in the collection and returns its index value.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function IndexOf( _
   ByVal value As ExtendedImageInfoContainerValue _
) As Integer
'Usage

Dim instance As ExtendedImageInfoContainerValueCollection
Dim value As ExtendedImageInfoContainerValue
Dim value As Integer

value = instance.IndexOf(value)
public int IndexOf(
   ExtendedImageInfoContainerValue value
)
public: int IndexOf(
   ExtendedImageInfoContainerValue* value
)
public:
int IndexOf(
   ExtendedImageInfoContainerValue^ value
)

Parameters

value

Return Value

An integer value which represents the index of the given value within the collection.

Remarks

This method searches the collection for a reference to the given object. If it does not find a reference to it, this method returns -1. If the object is present more than once in the collection, this method returns the lowest index of a match.

See Also

Reference

ExtendedImageInfoContainerValueCollection Class
ExtendedImageInfoContainerValueCollection Members
ExtendedImageInfoContainerValue Class


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Insert Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ExtendedImageInfoContainerValueCollection Class : Insert Method

index
value

Glossary Item Box

Inserts an ExtendedImageInfoContainerValue into the collection at the given index.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub Insert( _
   ByVal index As Integer, _
   ByVal value As ExtendedImageInfoContainerValue _
)
'Usage

Dim instance As ExtendedImageInfoContainerValueCollection
Dim index As Integer
Dim value As ExtendedImageInfoContainerValue

instance.Insert(index, value)
public void Insert(
   int index,
   ExtendedImageInfoContainerValue value
)
public: void Insert(
   int index,
   ExtendedImageInfoContainerValue* value
)
public:
void Insert(
   int index,
   ExtendedImageInfoContainerValue^ value
)

Parameters

index
value

Remarks

This method inserts the given ExtendedImageInfoContainerValue into the collection at the given index.

See Also

Reference

ExtendedImageInfoContainerValueCollection Class
ExtendedImageInfoContainerValueCollection Members
ExtendedImageInfoContainerValue Class


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Remove Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ExtendedImageInfoContainerValueCollection Class : Remove Method

value

Glossary Item Box

Removes an ExtendedImageInfoContainerValue from the collection.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub Remove( _
   ByVal value As ExtendedImageInfoContainerValue _
)
'Usage

Dim instance As ExtendedImageInfoContainerValueCollection
Dim value As ExtendedImageInfoContainerValue

instance.Remove(value)
public void Remove(
   ExtendedImageInfoContainerValue value
)
public: void Remove(
   ExtendedImageInfoContainerValue* value
)
public:
void Remove(
   ExtendedImageInfoContainerValue^ value
)

Parameters

value

Remarks

This method searches the collection for the given ExtendedImageInfoContainerValue and removes it. If there are no occurrences of the object, this method will do nothing.

See Also

Reference

ExtendedImageInfoContainerValueCollection Class
ExtendedImageInfoContainerValueCollection Members
ExtendedImageInfoContainerValue Class


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.TwainPro7.Net
ExtendedImageInfoContainerValueCollection Class Properties
See Also Send Feedback
Accusoft.TwainProSdk Namespace : ExtendedImageInfoContainerValueCollection Class

Glossary Item Box

For a list of all members of this type, see ExtendedImageInfoContainerValueCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets the element at the given index within the collection.
Top

See Also

Reference

ExtendedImageInfoContainerValueCollection Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Item Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ExtendedImageInfoContainerValueCollection Class : Item Property

index
A zero-based integer specifying the index in the collection of the element to get or set.

Glossary Item Box

Gets or sets the element at the given index within the collection.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DescriptionAttribute("Gets or sets the element at the given index.")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Default Property Item( _
   ByVal index As Integer _
) As ExtendedImageInfoContainerValue
'Usage

Dim instance As ExtendedImageInfoContainerValueCollection
Dim index As Integer
Dim value As ExtendedImageInfoContainerValue

instance.Item(index) = value

value = instance.Item(index)
[BrowsableAttribute(false)]
[DescriptionAttribute("Gets or sets the element at the given index.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public ExtendedImageInfoContainerValue this[
   int index
]; {get; set;}
[BrowsableAttribute(false)]
[DescriptionAttribute("Gets or sets the element at the given index.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property ExtendedImageInfoContainerValue* get_Item   int index
;
public: __property void set_Item   int index,
   ExtendedImageInfoContainerValue* value
;
[BrowsableAttribute(false)]
[DescriptionAttribute("Gets or sets the element at the given index.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property ExtendedImageInfoContainerValue^ default [int] {
   ExtendedImageInfoContainerValue^ get(int index);
   void set (int index, ExtendedImageInfoContainerValue^ value);
}

Parameters

index
A zero-based integer specifying the index in the collection of the element to get or set.

Property Value

An ExtendedImageInfoContainerValue which represents the element to get or set at the given index within the collection.

Remarks

This method implements a standard collection operation. It is the principle method you will use to read or change elements in the collection. You can read or modify any element in the collection with this method.

See Also

Reference

ExtendedImageInfoContainerValueCollection Class
ExtendedImageInfoContainerValueCollection Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
ExtendedImageInfoContainerValueFloat Class
Members See Also Send Feedback
Accusoft.TwainProSdk Namespace : ExtendedImageInfoContainerValueFloat Class

Glossary Item Box

This class implements a float value of extended image info.

Object Model

ExtendedImageInfoContainerValueFloat Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Class ExtendedImageInfoContainerValueFloat
   Inherits ExtendedImageInfoContainerValue
'Usage

Dim instance As ExtendedImageInfoContainerValueFloat
public class ExtendedImageInfoContainerValueFloat : ExtendedImageInfoContainerValue
public __gc class ExtendedImageInfoContainerValueFloat : public ExtendedImageInfoContainerValue
public ref class ExtendedImageInfoContainerValueFloat : public ExtendedImageInfoContainerValue

Remarks

You cannot create an ExtendedImageInfoContainerValueFloat object directly. This object is inherited from ExtendedImageInfoContainerValue, which is a member of the Values collection of the ExtendedImageInfoContainer object which can be obtained by calling the ScannedImage.GetExtendedImageInfo method.

Inheritance Hierarchy

System.Object
Accusoft.TwainProSdk.ExtendedImageInfoContainerValue
Accusoft.TwainProSdk.ExtendedImageInfoContainerValueFloat

See Also

Reference

ExtendedImageInfoContainerValueFloat Members
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.TwainPro7.Net
ExtendedImageInfoContainerValueFloat Class Members
See Also Properties Send Feedback
Accusoft.TwainProSdk Namespace : ExtendedImageInfoContainerValueFloat Class

Glossary Item Box

The following tables list the members exposed by ExtendedImageInfoContainerValueFloat.

Public Properties

 | Name | Description
Public Property | Value | Gets a float value of extended image info.
Top

See Also

Reference

ExtendedImageInfoContainerValueFloat Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.TwainPro7.Net
ExtendedImageInfoContainerValueFloat Class Properties
See Also Send Feedback
Accusoft.TwainProSdk Namespace : ExtendedImageInfoContainerValueFloat Class

Glossary Item Box

For a list of all members of this type, see ExtendedImageInfoContainerValueFloat members.

Public Properties

 | Name | Description
Public Property | Value | Gets a float value of extended image info.
Top

See Also

Reference

ExtendedImageInfoContainerValueFloat Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Value Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ExtendedImageInfoContainerValueFloat Class : Value Property

Glossary Item Box

Gets a float value of extended image info.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DescriptionAttribute("A float value of extended image info.")>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property Value As Single
'Usage

Dim instance As ExtendedImageInfoContainerValueFloat
Dim value As Single

value = instance.Value
[DescriptionAttribute("A float value of extended image info.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public float Value {get;}
[DescriptionAttribute("A float value of extended image info.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property float get_Value();
[DescriptionAttribute("A float value of extended image info.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property float Value {
   float get();
}

Property Value

A float value which represents extended image info.

Remarks

The default value is -1.

See Also

Reference

ExtendedImageInfoContainerValueFloat Class
ExtendedImageInfoContainerValueFloat Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
ExtendedImageInfoContainerValueString Class
Members See Also Send Feedback
Accusoft.TwainProSdk Namespace : ExtendedImageInfoContainerValueString Class

Glossary Item Box

This class implements a string value of extended image info.

Object Model

ExtendedImageInfoContainerValueString Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Class ExtendedImageInfoContainerValueString
   Inherits ExtendedImageInfoContainerValue
'Usage

Dim instance As ExtendedImageInfoContainerValueString
public class ExtendedImageInfoContainerValueString : ExtendedImageInfoContainerValue
public __gc class ExtendedImageInfoContainerValueString : public ExtendedImageInfoContainerValue
public ref class ExtendedImageInfoContainerValueString : public ExtendedImageInfoContainerValue

Remarks

You cannot create an ExtendedImageInfoContainerValueString object directly. This object is inherited from ExtendedImageInfoContainerValue, which is a member of the Values collection of the ExtendedImageInfoContainer object which can be obtained by calling the ScannedImage.GetExtendedImageInfo method.

Inheritance Hierarchy

System.Object
Accusoft.TwainProSdk.ExtendedImageInfoContainerValue
Accusoft.TwainProSdk.ExtendedImageInfoContainerValueString

See Also

Reference

ExtendedImageInfoContainerValueString Members
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.TwainPro7.Net
ExtendedImageInfoContainerValueString Class Members
See Also Properties Send Feedback
Accusoft.TwainProSdk Namespace : ExtendedImageInfoContainerValueString Class

Glossary Item Box

The following tables list the members exposed by ExtendedImageInfoContainerValueString.

Public Properties

 | Name | Description
Public Property | Value | Gets a string value of extended image info.
Top

See Also

Reference

ExtendedImageInfoContainerValueString Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.TwainPro7.Net
ExtendedImageInfoContainerValueString Class Properties
See Also Send Feedback
Accusoft.TwainProSdk Namespace : ExtendedImageInfoContainerValueString Class

Glossary Item Box

For a list of all members of this type, see ExtendedImageInfoContainerValueString members.

Public Properties

 | Name | Description
Public Property | Value | Gets a string value of extended image info.
Top

See Also

Reference

ExtendedImageInfoContainerValueString Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Value Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ExtendedImageInfoContainerValueString Class : Value Property

Glossary Item Box

Gets a string value of extended image info.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<DescriptionAttribute("A string value of extended image info.")>
Public ReadOnly Property Value As String
'Usage

Dim instance As ExtendedImageInfoContainerValueString
Dim value As String

value = instance.Value
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DescriptionAttribute("A string value of extended image info.")]
public string Value {get;}
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DescriptionAttribute("A string value of extended image info.")]
public: __property string* get_Value();
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DescriptionAttribute("A string value of extended image info.")]
public:
property String^ Value {
   String^ get();
}

Property Value

A string value which represents the extended image info.

Remarks

The default value is -1

See Also

Reference

ExtendedImageInfoContainerValueString Class
ExtendedImageInfoContainerValueString Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
FileCreateException Class
Members See Also Send Feedback
Accusoft.TwainProSdk Namespace : FileCreateException Class

Glossary Item Box

This exception is thrown if TwainPRO is unable to create the file specified in the Save method.

Object Model

FileCreateException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class FileCreateException
   Inherits TwainProException
'Usage

Dim instance As FileCreateException
[SerializableAttribute()]
public sealed class FileCreateException : TwainProException
[SerializableAttribute()]
public __gc __sealed class FileCreateException : public TwainProException
[SerializableAttribute()]
public ref class FileCreateException sealed : public TwainProException

Remarks

Possible causes:

The drive or path specified doesn't exist.

The file exists and is in use by another application.

No file extension or an invalid file extension was specified.

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.TwainProSdk.TwainProException
Accusoft.TwainProSdk.FileCreateException

See Also

Reference

FileCreateException Members
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.TwainPro7.Net
FileCreateException Class Members
See Also Properties Methods Send Feedback
Accusoft.TwainProSdk Namespace : FileCreateException Class

Glossary Item Box

The following tables list the members exposed by FileCreateException.

Public Constructors

 | Name | Description
Public Constructor | FileCreateException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.TwainProSdk.TwainProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

FileCreateException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.TwainPro7.Net
FileCreateException Class Methods
See Also Send Feedback
Accusoft.TwainProSdk Namespace : FileCreateException Class

Glossary Item Box

For a list of all members of this type, see FileCreateException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

FileCreateException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.TwainPro7.Net
FileCreateException Class Properties
See Also Send Feedback
Accusoft.TwainProSdk Namespace : FileCreateException Class

Glossary Item Box

For a list of all members of this type, see FileCreateException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.TwainProSdk.TwainProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

FileCreateException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
FileCreateException Constructor
See Also Send Feedback
Accusoft.TwainProSdk Namespace > FileCreateException Class : FileCreateException Constructor

Glossary Item Box

Overload List

Overload | Description
FileCreateException Constructor() | An exception generated for a file create error.
FileCreateException Constructor(Int32) | Generated exception for a file create error with a given error number.
FileCreateException Constructor(String) | Generated exception for a file create error with a given string.
FileCreateException Constructor(Int32,String) | Generated exception for a file create error with a given error number and message.
FileCreateException Constructor(String,Exception) | Generated exception for a file create error with a given message and inner exception.

See Also

Reference

FileCreateException Class
FileCreateException Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
FileCreateException Constructor()
See Also Send Feedback
Accusoft.TwainProSdk Namespace > FileCreateException Class > FileCreateException Constructor : FileCreateException Constructor()

Glossary Item Box

An exception generated for a file create error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New FileCreateException()
public FileCreateException()
public: FileCreateException();
public:
FileCreateException();

See Also

Reference

FileCreateException Class
FileCreateException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
FileCreateException Constructor(Int32)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > FileCreateException Class > FileCreateException Constructor : FileCreateException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a file create error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New FileCreateException(errorNumber)
public FileCreateException(
   int errorNumber
)
public: FileCreateException(
   int errorNumber
)
public:
FileCreateException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

FileCreateException Class
FileCreateException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
FileCreateException Constructor(String)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > FileCreateException Class > FileCreateException Constructor : FileCreateException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a file create error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New FileCreateException(message)
public FileCreateException(
   string message
)
public: FileCreateException(
   string* message
)
public:
FileCreateException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

FileCreateException Class
FileCreateException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
FileCreateException Constructor(Int32,String)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > FileCreateException Class > FileCreateException Constructor : FileCreateException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a file create error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New FileCreateException(errorNumber, message)
public FileCreateException(
   int errorNumber,
   string message
)
public: FileCreateException(
   int errorNumber,
   string* message
)
public:
FileCreateException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

FileCreateException Class
FileCreateException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
FileCreateException Constructor(String,Exception)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > FileCreateException Class > FileCreateException Constructor : FileCreateException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a file create error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New FileCreateException(message, innerException)
public FileCreateException(
   string message,
   Exception innerException
)
public: FileCreateException(
   string* message,
   Exception* innerException
)
public:
FileCreateException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

FileCreateException Class
FileCreateException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
FileOpenException Class
Members See Also Send Feedback
Accusoft.TwainProSdk Namespace : FileOpenException Class

Glossary Item Box

This exception is thrown if TwainPRO is unable to open an existing file to append pages when saving a multi-page image file, or if TwainPRO is unable to open a settings file.

Object Model

FileOpenException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class FileOpenException
   Inherits TwainProException
'Usage

Dim instance As FileOpenException
[SerializableAttribute()]
public sealed class FileOpenException : TwainProException
[SerializableAttribute()]
public __gc __sealed class FileOpenException : public TwainProException
[SerializableAttribute()]
public ref class FileOpenException sealed : public TwainProException

Remarks

Possible causes:

The file is open in another control or application.

The file is read-only.

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.TwainProSdk.TwainProException
Accusoft.TwainProSdk.FileOpenException

See Also

Reference

FileOpenException Members
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.TwainPro7.Net
FileOpenException Class Members
See Also Properties Methods Send Feedback
Accusoft.TwainProSdk Namespace : FileOpenException Class

Glossary Item Box

The following tables list the members exposed by FileOpenException.

Public Constructors

 | Name | Description
Public Constructor | FileOpenException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.TwainProSdk.TwainProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

FileOpenException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.TwainPro7.Net
FileOpenException Class Methods
See Also Send Feedback
Accusoft.TwainProSdk Namespace : FileOpenException Class

Glossary Item Box

For a list of all members of this type, see FileOpenException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

FileOpenException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.TwainPro7.Net
FileOpenException Class Properties
See Also Send Feedback
Accusoft.TwainProSdk Namespace : FileOpenException Class

Glossary Item Box

For a list of all members of this type, see FileOpenException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.TwainProSdk.TwainProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

FileOpenException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
FileOpenException Constructor
See Also Send Feedback
Accusoft.TwainProSdk Namespace > FileOpenException Class : FileOpenException Constructor

Glossary Item Box

Overload List

Overload | Description
FileOpenException Constructor() | An exception generated for a file open error.
FileOpenException Constructor(Int32) | Generated exception for a file open error with a given error number.
FileOpenException Constructor(String) | Generated exception for a file open error with a given string.
FileOpenException Constructor(Int32,String) | Generated exception for a file open error with a given error number and message.
FileOpenException Constructor(String,Exception) | Generated exception for a file open error with a given message and inner exception.

See Also

Reference

FileOpenException Class
FileOpenException Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
FileOpenException Constructor()
See Also Send Feedback
Accusoft.TwainProSdk Namespace > FileOpenException Class > FileOpenException Constructor : FileOpenException Constructor()

Glossary Item Box

An exception generated for a file open error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New FileOpenException()
public FileOpenException()
public: FileOpenException();
public:
FileOpenException();

See Also

Reference

FileOpenException Class
FileOpenException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
FileOpenException Constructor(Int32)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > FileOpenException Class > FileOpenException Constructor : FileOpenException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a file open error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New FileOpenException(errorNumber)
public FileOpenException(
   int errorNumber
)
public: FileOpenException(
   int errorNumber
)
public:
FileOpenException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

FileOpenException Class
FileOpenException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
FileOpenException Constructor(String)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > FileOpenException Class > FileOpenException Constructor : FileOpenException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a file open error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New FileOpenException(message)
public FileOpenException(
   string message
)
public: FileOpenException(
   string* message
)
public:
FileOpenException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

FileOpenException Class
FileOpenException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
FileOpenException Constructor(Int32,String)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > FileOpenException Class > FileOpenException Constructor : FileOpenException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a file open error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New FileOpenException(errorNumber, message)
public FileOpenException(
   int errorNumber,
   string message
)
public: FileOpenException(
   int errorNumber,
   string* message
)
public:
FileOpenException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

FileOpenException Class
FileOpenException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
FileOpenException Constructor(String,Exception)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > FileOpenException Class > FileOpenException Constructor : FileOpenException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a file open error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New FileOpenException(message, innerException)
public FileOpenException(
   string message,
   Exception innerException
)
public: FileOpenException(
   string* message,
   Exception* innerException
)
public:
FileOpenException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

FileOpenException Class
FileOpenException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
FileReadException Class
Members See Also Send Feedback
Accusoft.TwainProSdk Namespace : FileReadException Class

Glossary Item Box

This exception is thrown if TwainPRO is unable to read an existing file to append pages when saving a multi-page image file, or if TwainPRO is unable to read a settings file.

Object Model

FileReadException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class FileReadException
   Inherits TwainProException
'Usage

Dim instance As FileReadException
[SerializableAttribute()]
public sealed class FileReadException : TwainProException
[SerializableAttribute()]
public __gc __sealed class FileReadException : public TwainProException
[SerializableAttribute()]
public ref class FileReadException sealed : public TwainProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.TwainProSdk.TwainProException
Accusoft.TwainProSdk.FileReadException

See Also

Reference

FileReadException Members
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.TwainPro7.Net
FileReadException Class Members
See Also Properties Methods Send Feedback
Accusoft.TwainProSdk Namespace : FileReadException Class

Glossary Item Box

The following tables list the members exposed by FileReadException.

Public Constructors

 | Name | Description
Public Constructor | FileReadException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.TwainProSdk.TwainProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

FileReadException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.TwainPro7.Net
FileReadException Class Methods
See Also Send Feedback
Accusoft.TwainProSdk Namespace : FileReadException Class

Glossary Item Box

For a list of all members of this type, see FileReadException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

FileReadException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.TwainPro7.Net
FileReadException Class Properties
See Also Send Feedback
Accusoft.TwainProSdk Namespace : FileReadException Class

Glossary Item Box

For a list of all members of this type, see FileReadException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.TwainProSdk.TwainProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

FileReadException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
FileReadException Constructor
See Also Send Feedback
Accusoft.TwainProSdk Namespace > FileReadException Class : FileReadException Constructor

Glossary Item Box

Overload List

Overload | Description
FileReadException Constructor() | An exception generated for a file read error.
FileReadException Constructor(Int32) | Generated exception for a file read error with a given error number.
FileReadException Constructor(String) | Generated exception for a file read error with a given string.
FileReadException Constructor(Int32,String) | Generated exception for a file read error with a given error number and message.
FileReadException Constructor(String,Exception) | Generated exception for a file read error with a given message and inner exception.

See Also

Reference

FileReadException Class
FileReadException Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
FileReadException Constructor()
See Also Send Feedback
Accusoft.TwainProSdk Namespace > FileReadException Class > FileReadException Constructor : FileReadException Constructor()

Glossary Item Box

An exception generated for a file read error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New FileReadException()
public FileReadException()
public: FileReadException();
public:
FileReadException();

See Also

Reference

FileReadException Class
FileReadException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
FileReadException Constructor(Int32)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > FileReadException Class > FileReadException Constructor : FileReadException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a file read error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New FileReadException(errorNumber)
public FileReadException(
   int errorNumber
)
public: FileReadException(
   int errorNumber
)
public:
FileReadException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

FileReadException Class
FileReadException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
FileReadException Constructor(String)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > FileReadException Class > FileReadException Constructor : FileReadException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a file read error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New FileReadException(message)
public FileReadException(
   string message
)
public: FileReadException(
   string* message
)
public:
FileReadException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

FileReadException Class
FileReadException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
FileReadException Constructor(Int32,String)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > FileReadException Class > FileReadException Constructor : FileReadException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a file read error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New FileReadException(errorNumber, message)
public FileReadException(
   int errorNumber,
   string message
)
public: FileReadException(
   int errorNumber,
   string* message
)
public:
FileReadException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

FileReadException Class
FileReadException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
FileReadException Constructor(String,Exception)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > FileReadException Class > FileReadException Constructor : FileReadException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a file read error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New FileReadException(message, innerException)
public FileReadException(
   string message,
   Exception innerException
)
public: FileReadException(
   string* message,
   Exception* innerException
)
public:
FileReadException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

FileReadException Class
FileReadException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
FileWriteException Class
Members See Also Send Feedback
Accusoft.TwainProSdk Namespace : FileWriteException Class

Glossary Item Box

This exception is thrown if an error occurs while TwainPRO is attempting to save a file to the path specified in the Save method, or while TwainPRO is attempting to write a settings file.

Object Model

FileWriteException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class FileWriteException
   Inherits TwainProException
'Usage

Dim instance As FileWriteException
[SerializableAttribute()]
public sealed class FileWriteException : TwainProException
[SerializableAttribute()]
public __gc __sealed class FileWriteException : public TwainProException
[SerializableAttribute()]
public ref class FileWriteException sealed : public TwainProException

Remarks

Possible causes:

The drive or path became invalid during the write. This can occur if the drive is a network drive.

The disk is full.

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.TwainProSdk.TwainProException
Accusoft.TwainProSdk.FileWriteException

See Also

Reference

FileWriteException Members
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.TwainPro7.Net
FileWriteException Class Members
See Also Properties Methods Send Feedback
Accusoft.TwainProSdk Namespace : FileWriteException Class

Glossary Item Box

The following tables list the members exposed by FileWriteException.

Public Constructors

 | Name | Description
Public Constructor | FileWriteException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.TwainProSdk.TwainProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

FileWriteException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.TwainPro7.Net
FileWriteException Class Methods
See Also Send Feedback
Accusoft.TwainProSdk Namespace : FileWriteException Class

Glossary Item Box

For a list of all members of this type, see FileWriteException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

FileWriteException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.TwainPro7.Net
FileWriteException Class Properties
See Also Send Feedback
Accusoft.TwainProSdk Namespace : FileWriteException Class

Glossary Item Box

For a list of all members of this type, see FileWriteException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.TwainProSdk.TwainProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

FileWriteException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
FileWriteException Constructor
See Also Send Feedback
Accusoft.TwainProSdk Namespace > FileWriteException Class : FileWriteException Constructor

Glossary Item Box

Overload List

Overload | Description
FileWriteException Constructor() | An exception generated for a file write error.
FileWriteException Constructor(Int32) | Generated exception for a file write error with a given error number.
FileWriteException Constructor(String) | Generated exception for a file write error with a given string.
FileWriteException Constructor(Int32,String) | Generated exception for a file write error with a given error number and message.
FileWriteException Constructor(String,Exception) | Generated exception for a file write error with a given message and inner exception.

See Also

Reference

FileWriteException Class
FileWriteException Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
FileWriteException Constructor()
See Also Send Feedback
Accusoft.TwainProSdk Namespace > FileWriteException Class > FileWriteException Constructor : FileWriteException Constructor()

Glossary Item Box

An exception generated for a file write error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New FileWriteException()
public FileWriteException()
public: FileWriteException();
public:
FileWriteException();

See Also

Reference

FileWriteException Class
FileWriteException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
FileWriteException Constructor(Int32)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > FileWriteException Class > FileWriteException Constructor : FileWriteException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a file write error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New FileWriteException(errorNumber)
public FileWriteException(
   int errorNumber
)
public: FileWriteException(
   int errorNumber
)
public:
FileWriteException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

FileWriteException Class
FileWriteException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
FileWriteException Constructor(String)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > FileWriteException Class > FileWriteException Constructor : FileWriteException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a file write error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New FileWriteException(message)
public FileWriteException(
   string message
)
public: FileWriteException(
   string* message
)
public:
FileWriteException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

FileWriteException Class
FileWriteException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
FileWriteException Constructor(Int32,String)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > FileWriteException Class > FileWriteException Constructor : FileWriteException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a file write error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New FileWriteException(errorNumber, message)
public FileWriteException(
   int errorNumber,
   string message
)
public: FileWriteException(
   int errorNumber,
   string* message
)
public:
FileWriteException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

FileWriteException Class
FileWriteException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
FileWriteException Constructor(String,Exception)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > FileWriteException Class > FileWriteException Constructor : FileWriteException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a file write error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New FileWriteException(message, innerException)
public FileWriteException(
   string message,
   Exception innerException
)
public: FileWriteException(
   string* message,
   Exception* innerException
)
public:
FileWriteException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

FileWriteException Class
FileWriteException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
FtpOptions Class
Members See Also Send Feedback
Accusoft.TwainProSdk Namespace : FtpOptions Class

Glossary Item Box

This class implements properties and methods necessary for authentication and remote processing when saving an image.

Object Model

FtpOptions Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Class FtpOptions
'Usage

Dim instance As FtpOptions
public class FtpOptions
public __gc class FtpOptions
public ref class FtpOptions

Inheritance Hierarchy

System.Object
Accusoft.TwainProSdk.FtpOptions

See Also

Reference

FtpOptions Members
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.TwainPro7.Net
FtpOptions Class Members
See Also Properties Send Feedback
Accusoft.TwainProSdk Namespace : FtpOptions Class

Glossary Item Box

The following tables list the members exposed by FtpOptions.

Public Properties

 | Name | Description
Public Property | NetworkCredentials | Gets and sets credentials for password based authentication.
Public Property | ProxySettings | Gets and sets the proxy server name or ID.
Top

See Also

Reference

FtpOptions Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.TwainPro7.Net
FtpOptions Class Properties
See Also Send Feedback
Accusoft.TwainProSdk Namespace : FtpOptions Class

Glossary Item Box

For a list of all members of this type, see FtpOptions members.

Public Properties

 | Name | Description
Public Property | NetworkCredentials | Gets and sets credentials for password based authentication.
Public Property | ProxySettings | Gets and sets the proxy server name or ID.
Top

See Also

Reference

FtpOptions Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
NetworkCredentials Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > FtpOptions Class : NetworkCredentials Property

Glossary Item Box

Gets and sets credentials for password based authentication.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DescriptionAttribute("Gets or sets credentials for password based authentication.")>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property NetworkCredentials As NetworkCredential
'Usage

Dim instance As FtpOptions
Dim value As NetworkCredential

instance.NetworkCredentials = value

value = instance.NetworkCredentials
[DescriptionAttribute("Gets or sets credentials for password based authentication.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public NetworkCredential NetworkCredentials {get; set;}
[DescriptionAttribute("Gets or sets credentials for password based authentication.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property NetworkCredential* get_NetworkCredentials();
public: __property void set_NetworkCredentials(
   NetworkCredential* value
);
[DescriptionAttribute("Gets or sets credentials for password based authentication.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property NetworkCredential^ NetworkCredentials {
   NetworkCredential^ get();
   void set (    NetworkCredential^ value);
}

Property Value

A System.Net.NetworkCredential value which is used for password based authentication.

See Also

Reference

FtpOptions Class
FtpOptions Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
ProxySettings Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > FtpOptions Class : ProxySettings Property

Glossary Item Box

Gets and sets the proxy server name or ID.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DescriptionAttribute("Gets or sets the proxy server name or ID.")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property ProxySettings As WebProxy
'Usage

Dim instance As FtpOptions
Dim value As WebProxy

instance.ProxySettings = value

value = instance.ProxySettings
[BrowsableAttribute(false)]
[DescriptionAttribute("Gets or sets the proxy server name or ID.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public WebProxy ProxySettings {get; set;}
[BrowsableAttribute(false)]
[DescriptionAttribute("Gets or sets the proxy server name or ID.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property WebProxy* get_ProxySettings();
public: __property void set_ProxySettings(
   WebProxy* value
);
[BrowsableAttribute(false)]
[DescriptionAttribute("Gets or sets the proxy server name or ID.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property WebProxy^ ProxySettings {
   WebProxy^ get();
   void set (    WebProxy^ value);
}

Property Value

A System.Net.WebProxy value which represents the server name.

See Also

Reference

FtpOptions Class
FtpOptions Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
FtpTransferException Class
Members See Also Send Feedback
Accusoft.TwainProSdk Namespace : FtpTransferException Class

Glossary Item Box

This exception is thrown if an error occurs trying to FTP an image.

Object Model

FtpTransferException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class FtpTransferException
   Inherits TwainProException
'Usage

Dim instance As FtpTransferException
[SerializableAttribute()]
public sealed class FtpTransferException : TwainProException
[SerializableAttribute()]
public __gc __sealed class FtpTransferException : public TwainProException
[SerializableAttribute()]
public ref class FtpTransferException sealed : public TwainProException

Remarks

Possible causes:

The machine is not currently connected to a network. The FTP UserName and/or FTP Password properties are not correct for the requested host specified in the Save method.

The host and or path specified in the Save method doesn’t exist.

The path was not specified in the Save method. A fully qualified url containing both the servername and file path must be specified. For example, "http://ftp.myserver.com/ftp/public/test.jpg" contains both the server and file information, but "http://ftp.myserver.com" does not.

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.TwainProSdk.TwainProException
Accusoft.TwainProSdk.FtpTransferException

See Also

Reference

FtpTransferException Members
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.TwainPro7.Net
FtpTransferException Class Members
See Also Properties Methods Send Feedback
Accusoft.TwainProSdk Namespace : FtpTransferException Class

Glossary Item Box

The following tables list the members exposed by FtpTransferException.

Public Constructors

 | Name | Description
Public Constructor | FtpTransferException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.TwainProSdk.TwainProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

FtpTransferException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.TwainPro7.Net
FtpTransferException Class Methods
See Also Send Feedback
Accusoft.TwainProSdk Namespace : FtpTransferException Class

Glossary Item Box

For a list of all members of this type, see FtpTransferException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

FtpTransferException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.TwainPro7.Net
FtpTransferException Class Properties
See Also Send Feedback
Accusoft.TwainProSdk Namespace : FtpTransferException Class

Glossary Item Box

For a list of all members of this type, see FtpTransferException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.TwainProSdk.TwainProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

FtpTransferException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
FtpTransferException Constructor
See Also Send Feedback
Accusoft.TwainProSdk Namespace > FtpTransferException Class : FtpTransferException Constructor

Glossary Item Box

Overload List

Overload | Description
FtpTransferException Constructor() | An exception generated for an FTP transfer error.
FtpTransferException Constructor(Int32) | Generated exception for an FTP transfer error with a given error number.
FtpTransferException Constructor(String) | Generated exception for an FTP transfer error with a given string.
FtpTransferException Constructor(Int32,String) | Generated exception for an FTP transfer error with a given error number and message.
FtpTransferException Constructor(String,Exception) | Generated exception for an FTP transfer error with a given message and inner exception.

See Also

Reference

FtpTransferException Class
FtpTransferException Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
FtpTransferException Constructor()
See Also Send Feedback
Accusoft.TwainProSdk Namespace > FtpTransferException Class > FtpTransferException Constructor : FtpTransferException Constructor()

Glossary Item Box

An exception generated for an FTP transfer error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New FtpTransferException()
public FtpTransferException()
public: FtpTransferException();
public:
FtpTransferException();

See Also

Reference

FtpTransferException Class
FtpTransferException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
FtpTransferException Constructor(Int32)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > FtpTransferException Class > FtpTransferException Constructor : FtpTransferException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for an FTP transfer error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New FtpTransferException(errorNumber)
public FtpTransferException(
   int errorNumber
)
public: FtpTransferException(
   int errorNumber
)
public:
FtpTransferException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

FtpTransferException Class
FtpTransferException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
FtpTransferException Constructor(String)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > FtpTransferException Class > FtpTransferException Constructor : FtpTransferException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for an FTP transfer error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New FtpTransferException(message)
public FtpTransferException(
   string message
)
public: FtpTransferException(
   string* message
)
public:
FtpTransferException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

FtpTransferException Class
FtpTransferException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
FtpTransferException Constructor(Int32,String)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > FtpTransferException Class > FtpTransferException Constructor : FtpTransferException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for an FTP transfer error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New FtpTransferException(errorNumber, message)
public FtpTransferException(
   int errorNumber,
   string message
)
public: FtpTransferException(
   int errorNumber,
   string* message
)
public:
FtpTransferException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

FtpTransferException Class
FtpTransferException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
FtpTransferException Constructor(String,Exception)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > FtpTransferException Class > FtpTransferException Constructor : FtpTransferException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for an FTP transfer error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New FtpTransferException(message, innerException)
public FtpTransferException(
   string message,
   Exception innerException
)
public: FtpTransferException(
   string* message,
   Exception* innerException
)
public:
FtpTransferException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

FtpTransferException Class
FtpTransferException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
ImageNotAvailableException Class
Members See Also Send Feedback
Accusoft.TwainProSdk Namespace : ImageNotAvailableException Class

Glossary Item Box

This exception is thrown if no image is available for the requested operation or an unsupported DIB format was returned in response to a StartSession.

Object Model

ImageNotAvailableException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class ImageNotAvailableException
   Inherits TwainProException
'Usage

Dim instance As ImageNotAvailableException
[SerializableAttribute()]
public sealed class ImageNotAvailableException : TwainProException
[SerializableAttribute()]
public __gc __sealed class ImageNotAvailableException : public TwainProException
[SerializableAttribute()]
public ref class ImageNotAvailableException sealed : public TwainProException

Remarks

Possible causes:

The image has already been read.

The Save method was invoked after the image was read.

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.TwainProSdk.TwainProException
Accusoft.TwainProSdk.ImageNotAvailableException

See Also

Reference

ImageNotAvailableException Members
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.TwainPro7.Net
ImageNotAvailableException Class Members
See Also Properties Methods Send Feedback
Accusoft.TwainProSdk Namespace : ImageNotAvailableException Class

Glossary Item Box

The following tables list the members exposed by ImageNotAvailableException.

Public Constructors

 | Name | Description
Public Constructor | ImageNotAvailableException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.TwainProSdk.TwainProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ImageNotAvailableException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.TwainPro7.Net
ImageNotAvailableException Class Methods
See Also Send Feedback
Accusoft.TwainProSdk Namespace : ImageNotAvailableException Class

Glossary Item Box

For a list of all members of this type, see ImageNotAvailableException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ImageNotAvailableException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.TwainPro7.Net
ImageNotAvailableException Class Properties
See Also Send Feedback
Accusoft.TwainProSdk Namespace : ImageNotAvailableException Class

Glossary Item Box

For a list of all members of this type, see ImageNotAvailableException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.TwainProSdk.TwainProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ImageNotAvailableException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
ImageNotAvailableException Constructor
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ImageNotAvailableException Class : ImageNotAvailableException Constructor

Glossary Item Box

Overload List

Overload | Description
ImageNotAvailableException Constructor() | An exception generated for an image not available error.
ImageNotAvailableException Constructor(Int32) | Generated exception for an image not available error with a given error number.
ImageNotAvailableException Constructor(String) | Generated exception for an image not available error with a given string.
ImageNotAvailableException Constructor(Int32,String) | Generated exception for an image not available error with a given error number and message.
ImageNotAvailableException Constructor(String,Exception) | Generated exception for an image not available error with a given message and inner exception.

See Also

Reference

ImageNotAvailableException Class
ImageNotAvailableException Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
ImageNotAvailableException Constructor()
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ImageNotAvailableException Class > ImageNotAvailableException Constructor : ImageNotAvailableException Constructor()

Glossary Item Box

An exception generated for an image not available error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ImageNotAvailableException()
public ImageNotAvailableException()
public: ImageNotAvailableException();
public:
ImageNotAvailableException();

See Also

Reference

ImageNotAvailableException Class
ImageNotAvailableException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
ImageNotAvailableException Constructor(Int32)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ImageNotAvailableException Class > ImageNotAvailableException Constructor : ImageNotAvailableException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for an image not available error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New ImageNotAvailableException(errorNumber)
public ImageNotAvailableException(
   int errorNumber
)
public: ImageNotAvailableException(
   int errorNumber
)
public:
ImageNotAvailableException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

ImageNotAvailableException Class
ImageNotAvailableException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
ImageNotAvailableException Constructor(String)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ImageNotAvailableException Class > ImageNotAvailableException Constructor : ImageNotAvailableException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for an image not available error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New ImageNotAvailableException(message)
public ImageNotAvailableException(
   string message
)
public: ImageNotAvailableException(
   string* message
)
public:
ImageNotAvailableException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

ImageNotAvailableException Class
ImageNotAvailableException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
ImageNotAvailableException Constructor(Int32,String)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ImageNotAvailableException Class > ImageNotAvailableException Constructor : ImageNotAvailableException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for an image not available error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New ImageNotAvailableException(errorNumber, message)
public ImageNotAvailableException(
   int errorNumber,
   string message
)
public: ImageNotAvailableException(
   int errorNumber,
   string* message
)
public:
ImageNotAvailableException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

ImageNotAvailableException Class
ImageNotAvailableException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
ImageNotAvailableException Constructor(String,Exception)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ImageNotAvailableException Class > ImageNotAvailableException Constructor : ImageNotAvailableException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for an image not available error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New ImageNotAvailableException(message, innerException)
public ImageNotAvailableException(
   string message,
   Exception innerException
)
public: ImageNotAvailableException(
   string* message,
   Exception* innerException
)
public:
ImageNotAvailableException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

ImageNotAvailableException Class
ImageNotAvailableException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
IndexOutOfRangeException Class
Members See Also Send Feedback
Accusoft.TwainProSdk Namespace : IndexOutOfRangeException Class

Glossary Item Box

This exception is thrown if the requested index was out of range for the property array.

Object Model

IndexOutOfRangeException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class IndexOutOfRangeException
   Inherits TwainProException
'Usage

Dim instance As IndexOutOfRangeException
[SerializableAttribute()]
public sealed class IndexOutOfRangeException : TwainProException
[SerializableAttribute()]
public __gc __sealed class IndexOutOfRangeException : public TwainProException
[SerializableAttribute()]
public ref class IndexOutOfRangeException sealed : public TwainProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.TwainProSdk.TwainProException
Accusoft.TwainProSdk.IndexOutOfRangeException

See Also

Reference

IndexOutOfRangeException Members
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.TwainPro7.Net
IndexOutOfRangeException Class Members
See Also Properties Methods Send Feedback
Accusoft.TwainProSdk Namespace : IndexOutOfRangeException Class

Glossary Item Box

The following tables list the members exposed by IndexOutOfRangeException.

Public Constructors

 | Name | Description
Public Constructor | IndexOutOfRangeException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.TwainProSdk.TwainProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

IndexOutOfRangeException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.TwainPro7.Net
IndexOutOfRangeException Class Methods
See Also Send Feedback
Accusoft.TwainProSdk Namespace : IndexOutOfRangeException Class

Glossary Item Box

For a list of all members of this type, see IndexOutOfRangeException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

IndexOutOfRangeException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.TwainPro7.Net
IndexOutOfRangeException Class Properties
See Also Send Feedback
Accusoft.TwainProSdk Namespace : IndexOutOfRangeException Class

Glossary Item Box

For a list of all members of this type, see IndexOutOfRangeException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.TwainProSdk.TwainProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

IndexOutOfRangeException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
IndexOutOfRangeException Constructor
See Also Send Feedback
Accusoft.TwainProSdk Namespace > IndexOutOfRangeException Class : IndexOutOfRangeException Constructor

Glossary Item Box

Overload List

Overload | Description
IndexOutOfRangeException Constructor() | An exception generated for an index out of range error.
IndexOutOfRangeException Constructor(Int32) | Generated exception for an index out of range error with a given error number.
IndexOutOfRangeException Constructor(String) | Generated exception for an index out of range error with a given string.
IndexOutOfRangeException Constructor(Int32,String) | Generated exception for an index out of range error with a given error number and message.
IndexOutOfRangeException Constructor(String,Exception) | Generated exception for an index out of range error with a given message and inner exception.

See Also

Reference

IndexOutOfRangeException Class
IndexOutOfRangeException Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
IndexOutOfRangeException Constructor()
See Also Send Feedback
Accusoft.TwainProSdk Namespace > IndexOutOfRangeException Class > IndexOutOfRangeException Constructor : IndexOutOfRangeException Constructor()

Glossary Item Box

An exception generated for an index out of range error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New IndexOutOfRangeException()
public IndexOutOfRangeException()
public: IndexOutOfRangeException();
public:
IndexOutOfRangeException();

See Also

Reference

IndexOutOfRangeException Class
IndexOutOfRangeException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
IndexOutOfRangeException Constructor(Int32)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > IndexOutOfRangeException Class > IndexOutOfRangeException Constructor : IndexOutOfRangeException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for an index out of range error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New IndexOutOfRangeException(errorNumber)
public IndexOutOfRangeException(
   int errorNumber
)
public: IndexOutOfRangeException(
   int errorNumber
)
public:
IndexOutOfRangeException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

IndexOutOfRangeException Class
IndexOutOfRangeException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
IndexOutOfRangeException Constructor(String)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > IndexOutOfRangeException Class > IndexOutOfRangeException Constructor : IndexOutOfRangeException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for an index out of range error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New IndexOutOfRangeException(message)
public IndexOutOfRangeException(
   string message
)
public: IndexOutOfRangeException(
   string* message
)
public:
IndexOutOfRangeException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

IndexOutOfRangeException Class
IndexOutOfRangeException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
IndexOutOfRangeException Constructor(Int32,String)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > IndexOutOfRangeException Class > IndexOutOfRangeException Constructor : IndexOutOfRangeException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for an index out of range error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New IndexOutOfRangeException(errorNumber, message)
public IndexOutOfRangeException(
   int errorNumber,
   string message
)
public: IndexOutOfRangeException(
   int errorNumber,
   string* message
)
public:
IndexOutOfRangeException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

IndexOutOfRangeException Class
IndexOutOfRangeException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
IndexOutOfRangeException Constructor(String,Exception)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > IndexOutOfRangeException Class > IndexOutOfRangeException Constructor : IndexOutOfRangeException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for an index out of range error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New IndexOutOfRangeException(message, innerException)
public IndexOutOfRangeException(
   string message,
   Exception innerException
)
public: IndexOutOfRangeException(
   string* message,
   Exception* innerException
)
public:
IndexOutOfRangeException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

IndexOutOfRangeException Class
IndexOutOfRangeException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
InternalErrorException Class
Members See Also Send Feedback
Accusoft.TwainProSdk Namespace : InternalErrorException Class

Glossary Item Box

This exception is thrown if an internal failure occurs.

Object Model

InternalErrorException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class InternalErrorException
   Inherits TwainProException
'Usage

Dim instance As InternalErrorException
[SerializableAttribute()]
public sealed class InternalErrorException : TwainProException
[SerializableAttribute()]
public __gc __sealed class InternalErrorException : public TwainProException
[SerializableAttribute()]
public ref class InternalErrorException sealed : public TwainProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.TwainProSdk.TwainProException
Accusoft.TwainProSdk.InternalErrorException

See Also

Reference

InternalErrorException Members
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.TwainPro7.Net
InternalErrorException Class Members
See Also Properties Methods Send Feedback
Accusoft.TwainProSdk Namespace : InternalErrorException Class

Glossary Item Box

The following tables list the members exposed by InternalErrorException.

Public Constructors

 | Name | Description
Public Constructor | InternalErrorException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.TwainProSdk.TwainProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InternalErrorException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.TwainPro7.Net
InternalErrorException Class Methods
See Also Send Feedback
Accusoft.TwainProSdk Namespace : InternalErrorException Class

Glossary Item Box

For a list of all members of this type, see InternalErrorException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InternalErrorException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.TwainPro7.Net
InternalErrorException Class Properties
See Also Send Feedback
Accusoft.TwainProSdk Namespace : InternalErrorException Class

Glossary Item Box

For a list of all members of this type, see InternalErrorException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.TwainProSdk.TwainProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InternalErrorException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
InternalErrorException Constructor
See Also Send Feedback
Accusoft.TwainProSdk Namespace > InternalErrorException Class : InternalErrorException Constructor

Glossary Item Box

Overload List

Overload | Description
InternalErrorException Constructor() | An exception generated for an internal error.
InternalErrorException Constructor(Int32) | Generated exception for an internal error with a given error number.
InternalErrorException Constructor(String) | Generated exception for an internal error with a given string.
InternalErrorException Constructor(Int32,String) | Generated exception for an internal error with a given error number and message.
InternalErrorException Constructor(String,Exception) | Generated exception for an internal error with a given message and inner exception.

See Also

Reference

InternalErrorException Class
InternalErrorException Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
InternalErrorException Constructor()
See Also Send Feedback
Accusoft.TwainProSdk Namespace > InternalErrorException Class > InternalErrorException Constructor : InternalErrorException Constructor()

Glossary Item Box

An exception generated for an internal error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New InternalErrorException()
public InternalErrorException()
public: InternalErrorException();
public:
InternalErrorException();

See Also

Reference

InternalErrorException Class
InternalErrorException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
InternalErrorException Constructor(Int32)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > InternalErrorException Class > InternalErrorException Constructor : InternalErrorException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for an internal error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New InternalErrorException(errorNumber)
public InternalErrorException(
   int errorNumber
)
public: InternalErrorException(
   int errorNumber
)
public:
InternalErrorException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

InternalErrorException Class
InternalErrorException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
InternalErrorException Constructor(String)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > InternalErrorException Class > InternalErrorException Constructor : InternalErrorException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for an internal error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New InternalErrorException(message)
public InternalErrorException(
   string message
)
public: InternalErrorException(
   string* message
)
public:
InternalErrorException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

InternalErrorException Class
InternalErrorException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
InternalErrorException Constructor(Int32,String)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > InternalErrorException Class > InternalErrorException Constructor : InternalErrorException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for an internal error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New InternalErrorException(errorNumber, message)
public InternalErrorException(
   int errorNumber,
   string message
)
public: InternalErrorException(
   int errorNumber,
   string* message
)
public:
InternalErrorException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

InternalErrorException Class
InternalErrorException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
InternalErrorException Constructor(String,Exception)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > InternalErrorException Class > InternalErrorException Constructor : InternalErrorException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for an internal error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New InternalErrorException(message, innerException)
public InternalErrorException(
   string message,
   Exception innerException
)
public: InternalErrorException(
   string* message,
   Exception* innerException
)
public:
InternalErrorException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

InternalErrorException Class
InternalErrorException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
InternetFilesNotInstalledException Class
Members See Also Send Feedback
Accusoft.TwainProSdk Namespace : InternetFilesNotInstalledException Class

Glossary Item Box

This exception is thrown if the required Internet DLL file(s) are missing.

Object Model

InternetFilesNotInstalledException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class InternetFilesNotInstalledException
   Inherits TwainProException
'Usage

Dim instance As InternetFilesNotInstalledException
[SerializableAttribute()]
public sealed class InternetFilesNotInstalledException : TwainProException
[SerializableAttribute()]
public __gc __sealed class InternetFilesNotInstalledException : public TwainProException
[SerializableAttribute()]
public ref class InternetFilesNotInstalledException sealed : public TwainProException

Remarks

Possible causes:

The following files are not present on the system. These files are not shipped with TwainPRO and are not needed unless an FTP address is specified in the Save method. These files are included with other software such as Internet Explorer, and if the machine has a TCP/IP connection, it should have these files.

wininet.dll

urlmon.dll

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.TwainProSdk.TwainProException
Accusoft.TwainProSdk.InternetFilesNotInstalledException

See Also

Reference

InternetFilesNotInstalledException Members
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.TwainPro7.Net
InternetFilesNotInstalledException Class Members
See Also Properties Methods Send Feedback
Accusoft.TwainProSdk Namespace : InternetFilesNotInstalledException Class

Glossary Item Box

The following tables list the members exposed by InternetFilesNotInstalledException.

Public Constructors

 | Name | Description
Public Constructor | InternetFilesNotInstalledException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.TwainProSdk.TwainProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InternetFilesNotInstalledException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.TwainPro7.Net
InternetFilesNotInstalledException Class Methods
See Also Send Feedback
Accusoft.TwainProSdk Namespace : InternetFilesNotInstalledException Class

Glossary Item Box

For a list of all members of this type, see InternetFilesNotInstalledException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InternetFilesNotInstalledException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.TwainPro7.Net
InternetFilesNotInstalledException Class Properties
See Also Send Feedback
Accusoft.TwainProSdk Namespace : InternetFilesNotInstalledException Class

Glossary Item Box

For a list of all members of this type, see InternetFilesNotInstalledException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.TwainProSdk.TwainProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InternetFilesNotInstalledException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
InternetFilesNotInstalledException Constructor
See Also Send Feedback
Accusoft.TwainProSdk Namespace > InternetFilesNotInstalledException Class : InternetFilesNotInstalledException Constructor

Glossary Item Box

Overload List

Overload | Description
InternetFilesNotInstalledException Constructor() | An exception generated for an Internet files not installed error.
InternetFilesNotInstalledException Constructor(Int32) | Generated exception for an Internet files not installed error with a given error number.
InternetFilesNotInstalledException Constructor(String) | Generated exception for an Internet files not installed error with a given string.
InternetFilesNotInstalledException Constructor(Int32,String) | Generated exception for an Internet files not installed error with a given error number and message.
InternetFilesNotInstalledException Constructor(String,Exception) | Generated exception for an Internet files not installed error with a given message and inner exception.

See Also

Reference

InternetFilesNotInstalledException Class
InternetFilesNotInstalledException Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
InternetFilesNotInstalledException Constructor()
See Also Send Feedback
Accusoft.TwainProSdk Namespace > InternetFilesNotInstalledException Class > InternetFilesNotInstalledException Constructor : InternetFilesNotInstalledException Constructor()

Glossary Item Box

An exception generated for an Internet files not installed error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New InternetFilesNotInstalledException()
public InternetFilesNotInstalledException()
public: InternetFilesNotInstalledException();
public:
InternetFilesNotInstalledException();

See Also

Reference

InternetFilesNotInstalledException Class
InternetFilesNotInstalledException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
InternetFilesNotInstalledException Constructor(Int32)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > InternetFilesNotInstalledException Class > InternetFilesNotInstalledException Constructor : InternetFilesNotInstalledException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for an Internet files not installed error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New InternetFilesNotInstalledException(errorNumber)
public InternetFilesNotInstalledException(
   int errorNumber
)
public: InternetFilesNotInstalledException(
   int errorNumber
)
public:
InternetFilesNotInstalledException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

InternetFilesNotInstalledException Class
InternetFilesNotInstalledException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
InternetFilesNotInstalledException Constructor(String)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > InternetFilesNotInstalledException Class > InternetFilesNotInstalledException Constructor : InternetFilesNotInstalledException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for an Internet files not installed error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New InternetFilesNotInstalledException(message)
public InternetFilesNotInstalledException(
   string message
)
public: InternetFilesNotInstalledException(
   string* message
)
public:
InternetFilesNotInstalledException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

InternetFilesNotInstalledException Class
InternetFilesNotInstalledException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
InternetFilesNotInstalledException Constructor(Int32,String)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > InternetFilesNotInstalledException Class > InternetFilesNotInstalledException Constructor : InternetFilesNotInstalledException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for an Internet files not installed error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New InternetFilesNotInstalledException(errorNumber, message)
public InternetFilesNotInstalledException(
   int errorNumber,
   string message
)
public: InternetFilesNotInstalledException(
   int errorNumber,
   string* message
)
public:
InternetFilesNotInstalledException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

InternetFilesNotInstalledException Class
InternetFilesNotInstalledException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
InternetFilesNotInstalledException Constructor(String,Exception)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > InternetFilesNotInstalledException Class > InternetFilesNotInstalledException Constructor : InternetFilesNotInstalledException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for an Internet files not installed error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New InternetFilesNotInstalledException(message, innerException)
public InternetFilesNotInstalledException(
   string message,
   Exception innerException
)
public: InternetFilesNotInstalledException(
   string* message,
   Exception* innerException
)
public:
InternetFilesNotInstalledException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

InternetFilesNotInstalledException Class
InternetFilesNotInstalledException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
InvalidBitDepthException Class
Members See Also Send Feedback
Accusoft.TwainProSdk Namespace : InvalidBitDepthException Class

Glossary Item Box

This exception is thrown if an invalid image resolution for the selected file format or an unsupported bits per pixel was returned from a StartSession.

Object Model

InvalidBitDepthException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class InvalidBitDepthException
   Inherits TwainProException
'Usage

Dim instance As InvalidBitDepthException
[SerializableAttribute()]
public sealed class InvalidBitDepthException : TwainProException
[SerializableAttribute()]
public __gc __sealed class InvalidBitDepthException : public TwainProException
[SerializableAttribute()]
public ref class InvalidBitDepthException sealed : public TwainProException

Remarks

Possible causes:

Tried to save a 1-bit or Black and White image to a jpg or pic file.

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.TwainProSdk.TwainProException
Accusoft.TwainProSdk.InvalidBitDepthException

See Also

Reference

InvalidBitDepthException Members
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.TwainPro7.Net
InvalidBitDepthException Class Members
See Also Properties Methods Send Feedback
Accusoft.TwainProSdk Namespace : InvalidBitDepthException Class

Glossary Item Box

The following tables list the members exposed by InvalidBitDepthException.

Public Constructors

 | Name | Description
Public Constructor | InvalidBitDepthException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.TwainProSdk.TwainProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidBitDepthException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.TwainPro7.Net
InvalidBitDepthException Class Methods
See Also Send Feedback
Accusoft.TwainProSdk Namespace : InvalidBitDepthException Class

Glossary Item Box

For a list of all members of this type, see InvalidBitDepthException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidBitDepthException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.TwainPro7.Net
InvalidBitDepthException Class Properties
See Also Send Feedback
Accusoft.TwainProSdk Namespace : InvalidBitDepthException Class

Glossary Item Box

For a list of all members of this type, see InvalidBitDepthException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.TwainProSdk.TwainProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidBitDepthException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
InvalidBitDepthException Constructor
See Also Send Feedback
Accusoft.TwainProSdk Namespace > InvalidBitDepthException Class : InvalidBitDepthException Constructor

Glossary Item Box

Overload List

Overload | Description
InvalidBitDepthException Constructor() | An exception generated for an invalid bit depth error.
InvalidBitDepthException Constructor(Int32) | Generated exception for an invalid bit depth error with a given error number.
InvalidBitDepthException Constructor(String) | Generated exception for an invalid bit depth error with a given string.
InvalidBitDepthException Constructor(Int32,String) | Generated exception for an invalid bit depth error with a given error number and message.
InvalidBitDepthException Constructor(String,Exception) | Generated exception for an invalid bit depth error with a given message and inner exception.

See Also

Reference

InvalidBitDepthException Class
InvalidBitDepthException Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
InvalidBitDepthException Constructor()
See Also Send Feedback
Accusoft.TwainProSdk Namespace > InvalidBitDepthException Class > InvalidBitDepthException Constructor : InvalidBitDepthException Constructor()

Glossary Item Box

An exception generated for an invalid bit depth error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New InvalidBitDepthException()
public InvalidBitDepthException()
public: InvalidBitDepthException();
public:
InvalidBitDepthException();

See Also

Reference

InvalidBitDepthException Class
InvalidBitDepthException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
InvalidBitDepthException Constructor(Int32)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > InvalidBitDepthException Class > InvalidBitDepthException Constructor : InvalidBitDepthException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for an invalid bit depth error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New InvalidBitDepthException(errorNumber)
public InvalidBitDepthException(
   int errorNumber
)
public: InvalidBitDepthException(
   int errorNumber
)
public:
InvalidBitDepthException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

InvalidBitDepthException Class
InvalidBitDepthException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
InvalidBitDepthException Constructor(String)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > InvalidBitDepthException Class > InvalidBitDepthException Constructor : InvalidBitDepthException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for an invalid bit depth error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New InvalidBitDepthException(message)
public InvalidBitDepthException(
   string message
)
public: InvalidBitDepthException(
   string* message
)
public:
InvalidBitDepthException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

InvalidBitDepthException Class
InvalidBitDepthException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
InvalidBitDepthException Constructor(Int32,String)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > InvalidBitDepthException Class > InvalidBitDepthException Constructor : InvalidBitDepthException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for an invalid bit depth error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New InvalidBitDepthException(errorNumber, message)
public InvalidBitDepthException(
   int errorNumber,
   string message
)
public: InvalidBitDepthException(
   int errorNumber,
   string* message
)
public:
InvalidBitDepthException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

InvalidBitDepthException Class
InvalidBitDepthException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
InvalidBitDepthException Constructor(String,Exception)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > InvalidBitDepthException Class > InvalidBitDepthException Constructor : InvalidBitDepthException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for an invalid bit depth error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New InvalidBitDepthException(message, innerException)
public InvalidBitDepthException(
   string message,
   Exception innerException
)
public: InvalidBitDepthException(
   string* message,
   Exception* innerException
)
public:
InvalidBitDepthException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

InvalidBitDepthException Class
InvalidBitDepthException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
InvalidLicenseException Class
Members See Also Send Feedback
Accusoft.TwainProSdk Namespace : InvalidLicenseException Class

Glossary Item Box

This exception is thrown if a user attempts to access functionality that is not covered under the license in effect.

Object Model

InvalidLicenseException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class InvalidLicenseException
   Inherits TwainProException
'Usage

Dim instance As InvalidLicenseException
[SerializableAttribute()]
public sealed class InvalidLicenseException : TwainProException
[SerializableAttribute()]
public __gc __sealed class InvalidLicenseException : public TwainProException
[SerializableAttribute()]
public ref class InvalidLicenseException sealed : public TwainProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.TwainProSdk.TwainProException
Accusoft.TwainProSdk.InvalidLicenseException

See Also

Reference

InvalidLicenseException Members
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.TwainPro7.Net
InvalidLicenseException Class Members
See Also Properties Methods Send Feedback
Accusoft.TwainProSdk Namespace : InvalidLicenseException Class

Glossary Item Box

The following tables list the members exposed by InvalidLicenseException.

Public Constructors

 | Name | Description
Public Constructor | InvalidLicenseException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.TwainProSdk.TwainProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidLicenseException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.TwainPro7.Net
InvalidLicenseException Class Methods
See Also Send Feedback
Accusoft.TwainProSdk Namespace : InvalidLicenseException Class

Glossary Item Box

For a list of all members of this type, see InvalidLicenseException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidLicenseException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.TwainPro7.Net
InvalidLicenseException Class Properties
See Also Send Feedback
Accusoft.TwainProSdk Namespace : InvalidLicenseException Class

Glossary Item Box

For a list of all members of this type, see InvalidLicenseException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.TwainProSdk.TwainProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidLicenseException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
InvalidLicenseException Constructor
See Also Send Feedback
Accusoft.TwainProSdk Namespace > InvalidLicenseException Class : InvalidLicenseException Constructor

Glossary Item Box

Overload List

Overload | Description
InvalidLicenseException Constructor() | An exception generated for an invalid license error.
InvalidLicenseException Constructor(Int32) | Generated exception for an invalid license error with a given error number.
InvalidLicenseException Constructor(String) | Generated exception for an invalid license error with a given string.
InvalidLicenseException Constructor(Int32,String) | Generated exception for an invalid license error with a given error number and message.
InvalidLicenseException Constructor(String,Exception) | Generated exception for an invalid license error with a given message and inner exception.

See Also

Reference

InvalidLicenseException Class
InvalidLicenseException Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
InvalidLicenseException Constructor()
See Also Send Feedback
Accusoft.TwainProSdk Namespace > InvalidLicenseException Class > InvalidLicenseException Constructor : InvalidLicenseException Constructor()

Glossary Item Box

An exception generated for an invalid license error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New InvalidLicenseException()
public InvalidLicenseException()
public: InvalidLicenseException();
public:
InvalidLicenseException();

See Also

Reference

InvalidLicenseException Class
InvalidLicenseException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
InvalidLicenseException Constructor(Int32)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > InvalidLicenseException Class > InvalidLicenseException Constructor : InvalidLicenseException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for an invalid license error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New InvalidLicenseException(errorNumber)
public InvalidLicenseException(
   int errorNumber
)
public: InvalidLicenseException(
   int errorNumber
)
public:
InvalidLicenseException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

InvalidLicenseException Class
InvalidLicenseException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
InvalidLicenseException Constructor(String)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > InvalidLicenseException Class > InvalidLicenseException Constructor : InvalidLicenseException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for an invalid license error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New InvalidLicenseException(message)
public InvalidLicenseException(
   string message
)
public: InvalidLicenseException(
   string* message
)
public:
InvalidLicenseException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

InvalidLicenseException Class
InvalidLicenseException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
InvalidLicenseException Constructor(Int32,String)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > InvalidLicenseException Class > InvalidLicenseException Constructor : InvalidLicenseException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for an invalid license error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New InvalidLicenseException(errorNumber, message)
public InvalidLicenseException(
   int errorNumber,
   string message
)
public: InvalidLicenseException(
   int errorNumber,
   string* message
)
public:
InvalidLicenseException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

InvalidLicenseException Class
InvalidLicenseException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
InvalidLicenseException Constructor(String,Exception)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > InvalidLicenseException Class > InvalidLicenseException Constructor : InvalidLicenseException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for an invalid license error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New InvalidLicenseException(message, innerException)
public InvalidLicenseException(
   string message,
   Exception innerException
)
public: InvalidLicenseException(
   string* message,
   Exception* innerException
)
public:
InvalidLicenseException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

InvalidLicenseException Class
InvalidLicenseException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
InvalidPropertyException Class
Members See Also Send Feedback
Accusoft.TwainProSdk Namespace : InvalidPropertyException Class

Glossary Item Box

This exception is thrown if a property was set or queried that was not valid for the current capability type.

Object Model

InvalidPropertyException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class InvalidPropertyException
   Inherits TwainProException
'Usage

Dim instance As InvalidPropertyException
[SerializableAttribute()]
public sealed class InvalidPropertyException : TwainProException
[SerializableAttribute()]
public __gc __sealed class InvalidPropertyException : public TwainProException
[SerializableAttribute()]
public ref class InvalidPropertyException sealed : public TwainProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.TwainProSdk.TwainProException
Accusoft.TwainProSdk.InvalidPropertyException

See Also

Reference

InvalidPropertyException Members
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.TwainPro7.Net
InvalidPropertyException Class Members
See Also Properties Methods Send Feedback
Accusoft.TwainProSdk Namespace : InvalidPropertyException Class

Glossary Item Box

The following tables list the members exposed by InvalidPropertyException.

Public Constructors

 | Name | Description
Public Constructor | InvalidPropertyException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.TwainProSdk.TwainProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidPropertyException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.TwainPro7.Net
InvalidPropertyException Class Methods
See Also Send Feedback
Accusoft.TwainProSdk Namespace : InvalidPropertyException Class

Glossary Item Box

For a list of all members of this type, see InvalidPropertyException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidPropertyException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.TwainPro7.Net
InvalidPropertyException Class Properties
See Also Send Feedback
Accusoft.TwainProSdk Namespace : InvalidPropertyException Class

Glossary Item Box

For a list of all members of this type, see InvalidPropertyException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.TwainProSdk.TwainProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidPropertyException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
InvalidPropertyException Constructor
See Also Send Feedback
Accusoft.TwainProSdk Namespace > InvalidPropertyException Class : InvalidPropertyException Constructor

Glossary Item Box

Overload List

Overload | Description
InvalidPropertyException Constructor() | An exception generated for an invalid property error.
InvalidPropertyException Constructor(Int32) | Generated exception for an invalid property error with a given error number.
InvalidPropertyException Constructor(String) | Generated exception for an invalid property error with a given string.
InvalidPropertyException Constructor(Int32,String) | Generated exception for an invalid property error with a given error number and message.
InvalidPropertyException Constructor(String,Exception) | Generated exception for an invalid property error with a given message and inner exception.

See Also

Reference

InvalidPropertyException Class
InvalidPropertyException Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
InvalidPropertyException Constructor()
See Also Send Feedback
Accusoft.TwainProSdk Namespace > InvalidPropertyException Class > InvalidPropertyException Constructor : InvalidPropertyException Constructor()

Glossary Item Box

An exception generated for an invalid property error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New InvalidPropertyException()
public InvalidPropertyException()
public: InvalidPropertyException();
public:
InvalidPropertyException();

See Also

Reference

InvalidPropertyException Class
InvalidPropertyException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
InvalidPropertyException Constructor(Int32)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > InvalidPropertyException Class > InvalidPropertyException Constructor : InvalidPropertyException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for an invalid property error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New InvalidPropertyException(errorNumber)
public InvalidPropertyException(
   int errorNumber
)
public: InvalidPropertyException(
   int errorNumber
)
public:
InvalidPropertyException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

InvalidPropertyException Class
InvalidPropertyException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
InvalidPropertyException Constructor(String)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > InvalidPropertyException Class > InvalidPropertyException Constructor : InvalidPropertyException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for an invalid property error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New InvalidPropertyException(message)
public InvalidPropertyException(
   string message
)
public: InvalidPropertyException(
   string* message
)
public:
InvalidPropertyException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

InvalidPropertyException Class
InvalidPropertyException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
InvalidPropertyException Constructor(Int32,String)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > InvalidPropertyException Class > InvalidPropertyException Constructor : InvalidPropertyException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for an invalid property error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New InvalidPropertyException(errorNumber, message)
public InvalidPropertyException(
   int errorNumber,
   string message
)
public: InvalidPropertyException(
   int errorNumber,
   string* message
)
public:
InvalidPropertyException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

InvalidPropertyException Class
InvalidPropertyException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
InvalidPropertyException Constructor(String,Exception)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > InvalidPropertyException Class > InvalidPropertyException Constructor : InvalidPropertyException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for an invalid property error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New InvalidPropertyException(message, innerException)
public InvalidPropertyException(
   string message,
   Exception innerException
)
public: InvalidPropertyException(
   string* message,
   Exception* innerException
)
public:
InvalidPropertyException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

InvalidPropertyException Class
InvalidPropertyException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Licensing Class
Members See Also Send Feedback
Accusoft.TwainProSdk Namespace : Licensing Class

Glossary Item Box

This class implements methods for setting the license information for the toolkit.

Object Model

Licensing Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Class Licensing
'Usage

Dim instance As Licensing
public class Licensing
public __gc class Licensing
public ref class Licensing

Remarks

This object exposes the licensing methods you need to call to license the toolkit.

Inheritance Hierarchy

System.Object
Accusoft.TwainProSdk.Licensing

See Also

Reference

Licensing Members
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.TwainPro7.Net
Licensing Class Members
See Also Properties Methods Send Feedback
Accusoft.TwainProSdk Namespace : Licensing Class

Glossary Item Box

The following tables list the members exposed by Licensing.

Public Constructors

 | Name | Description
Public Constructor | Licensing Constructor | The initial constructor for the licensing class passing in a workspace ID.
Top

Public Properties

 | Name | Description
Public Property | EvaluationMode | Gets and sets the way in which this component is limited in evaluation mode.
Top

Public Methods

 | Name | Description
Public Method | Dispose | Disposes of unmanaged resources.
Public Method | SetOEMLicenseKey | Sets the TwainPro control runtime OEM license key required for OEM licensing.
Public Method | SetSolutionKey | Sets the TwainPro control runtime license deployment key.
Public Method | SetSolutionName | Sets the TwainPro control runtime license deployment solution name.
Top

See Also

Reference

Licensing Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Licensing Constructor
See Also Send Feedback
Accusoft.TwainProSdk Namespace > Licensing Class : Licensing Constructor

pWorkId
A TwainPRO workspace ID.

Glossary Item Box

The initial constructor for the licensing class passing in a workspace ID.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal pWorkId As IntPtr _
)
'Usage

Dim pWorkId As IntPtr

Dim instance As New Licensing(pWorkId)
public Licensing(
   IntPtr pWorkId
)
public: Licensing(
   IntPtr pWorkId
)
public:
Licensing(
   IntPtr pWorkId
)

Parameters

pWorkId
A TwainPRO workspace ID.

See Also

Reference

Licensing Class
Licensing Members


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.TwainPro7.Net
Licensing Class Methods
See Also Send Feedback
Accusoft.TwainProSdk Namespace : Licensing Class

Glossary Item Box

For a list of all members of this type, see Licensing members.

Public Methods

 | Name | Description
Public Method | Dispose | Disposes of unmanaged resources.
Public Method | SetOEMLicenseKey | Sets the TwainPro control runtime OEM license key required for OEM licensing.
Public Method | SetSolutionKey | Sets the TwainPro control runtime license deployment key.
Public Method | SetSolutionName | Sets the TwainPro control runtime license deployment solution name.
Top

See Also

Reference

Licensing Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Dispose Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > Licensing Class : Dispose Method

Glossary Item Box

Disposes of unmanaged resources.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub Dispose()
'Usage

Dim instance As Licensing

instance.Dispose()
public void Dispose()
public: void Dispose();
public:
void Dispose();

Remarks

This method is part of the IDisposable interface.

See Also

Reference

Licensing Class
Licensing Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
SetOEMLicenseKey Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > Licensing Class : SetOEMLicenseKey Method

oemKey
The OEM license key required for OEM licensing.

Glossary Item Box

Sets the TwainPro control runtime OEM license key required for OEM licensing.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub SetOEMLicenseKey( _
   ByVal oemKey As String _
)
'Usage

Dim instance As Licensing
Dim oemKey As String

instance.SetOEMLicenseKey(oemKey)
public void SetOEMLicenseKey(
   string oemKey
)
public: void SetOEMLicenseKey(
   string* oemKey
)
public:
void SetOEMLicenseKey(
   String^ oemKey
)

Parameters

oemKey
The OEM license key required for OEM licensing.

Remarks

When OEM runtime licenses are purchased, the OEM license key is provided in the purchase confirmation email.

See Also

Reference

Licensing Class
Licensing Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
SetSolutionKey Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > Licensing Class : SetSolutionKey Method

key1
Unlock key 1
key2
Unlock key 2
key3
Unlock key 3
key4
Unlock key 4

Glossary Item Box

Sets the TwainPro control runtime license deployment key.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub SetSolutionKey( _
   ByVal key1 As Long, _
   ByVal key2 As Long, _
   ByVal key3 As Long, _
   ByVal key4 As Long _
)
'Usage

Dim instance As Licensing
Dim key1 As Long
Dim key2 As Long
Dim key3 As Long
Dim key4 As Long

instance.SetSolutionKey(key1, key2, key3, key4)
public void SetSolutionKey(
   long key1,
   long key2,
   long key3,
   long key4
)
public: void SetSolutionKey(
   long key1,
   long key2,
   long key3,
   long key4
)
public:
void SetSolutionKey(
   int64 key1,
   int64 key2,
   int64 key3,
   int64 key4
)

Parameters

key1
Unlock key 1
key2
Unlock key 2
key3
Unlock key 3
key4
Unlock key 4

Remarks

This is the solution key required for all runtime licensing. The four integers are provided at the time of purchase of the runtime licenses along with the solution name, which is set with the SetSolutionName method.

See Also

Reference

Licensing Class
Licensing Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
SetSolutionName Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > Licensing Class : SetSolutionName Method

solutionName
The solution name.

Glossary Item Box

Sets the TwainPro control runtime license deployment solution name.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub SetSolutionName( _
   ByVal solutionName As String _
)
'Usage

Dim instance As Licensing
Dim solutionName As String

instance.SetSolutionName(solutionName)
public void SetSolutionName(
   string solutionName
)
public: void SetSolutionName(
   string* solutionName
)
public:
void SetSolutionName(
   String^ solutionName
)

Parameters

solutionName
The solution name.

Remarks

This is the name of the runtime license solution. The solution name is provided in the purchase confirmation email when runtime licenses are purchased.

See Also

Reference

Licensing Class
Licensing Members


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.TwainPro7.Net
Licensing Class Properties
See Also Send Feedback
Accusoft.TwainProSdk Namespace : Licensing Class

Glossary Item Box

For a list of all members of this type, see Licensing members.

Public Properties

 | Name | Description
Public Property | EvaluationMode | Gets and sets the way in which this component is limited in evaluation mode.
Top

See Also

Reference

Licensing Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
EvaluationMode Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > Licensing Class : EvaluationMode Property

Glossary Item Box

Gets and sets the way in which this component is limited in evaluation mode.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DescriptionAttribute("Indicates the way in which this component is limited in evaluation mode.")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
<DefaultValueAttribute()>
Public Property EvaluationMode As EvaluationMode
'Usage

Dim instance As Licensing
Dim value As EvaluationMode

instance.EvaluationMode = value

value = instance.EvaluationMode
[DescriptionAttribute("Indicates the way in which this component is limited in evaluation mode.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
public EvaluationMode EvaluationMode {get; set;}
[DescriptionAttribute("Indicates the way in which this component is limited in evaluation mode.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
public: __property EvaluationMode get_EvaluationMode();
public: __property void set_EvaluationMode(
   EvaluationMode value
);
[DescriptionAttribute("Indicates the way in which this component is limited in evaluation mode.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
public:
property EvaluationMode EvaluationMode {
   EvaluationMode get();
   void set (    EvaluationMode value);
}

Property Value

An EvaluationMode enumeration value which determines the evaluation mode for the component.

Remarks

The default value: is Automatic.

See Also

Reference

Licensing Class
Licensing Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
LoadSettingsException Class
Members See Also Send Feedback
Accusoft.TwainProSdk Namespace : LoadSettingsException Class

Glossary Item Box

This exception is thrown if an error occurs when loading a settings file.

Object Model

LoadSettingsException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class LoadSettingsException
   Inherits TwainProException
'Usage

Dim instance As LoadSettingsException
[SerializableAttribute()]
public sealed class LoadSettingsException : TwainProException
[SerializableAttribute()]
public __gc __sealed class LoadSettingsException : public TwainProException
[SerializableAttribute()]
public ref class LoadSettingsException sealed : public TwainProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.TwainProSdk.TwainProException
Accusoft.TwainProSdk.LoadSettingsException

See Also

Reference

LoadSettingsException Members
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.TwainPro7.Net
LoadSettingsException Class Members
See Also Properties Methods Send Feedback
Accusoft.TwainProSdk Namespace : LoadSettingsException Class

Glossary Item Box

The following tables list the members exposed by LoadSettingsException.

Public Constructors

 | Name | Description
Public Constructor | LoadSettingsException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.TwainProSdk.TwainProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

LoadSettingsException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.TwainPro7.Net
LoadSettingsException Class Methods
See Also Send Feedback
Accusoft.TwainProSdk Namespace : LoadSettingsException Class

Glossary Item Box

For a list of all members of this type, see LoadSettingsException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

LoadSettingsException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.TwainPro7.Net
LoadSettingsException Class Properties
See Also Send Feedback
Accusoft.TwainProSdk Namespace : LoadSettingsException Class

Glossary Item Box

For a list of all members of this type, see LoadSettingsException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.TwainProSdk.TwainProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

LoadSettingsException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
LoadSettingsException Constructor
See Also Send Feedback
Accusoft.TwainProSdk Namespace > LoadSettingsException Class : LoadSettingsException Constructor

Glossary Item Box

Overload List

Overload | Description
LoadSettingsException Constructor() | An exception generated for a load settings error.
LoadSettingsException Constructor(Int32) | Generated exception for a load settings error with a given error number.
LoadSettingsException Constructor(String) | Generated exception for a load settings error with a given string.
LoadSettingsException Constructor(Int32,String) | Generated exception for a load settings error with a given error number and message.
LoadSettingsException Constructor(String,Exception) | Generated exception for a load settings error with a given message and inner exception.

See Also

Reference

LoadSettingsException Class
LoadSettingsException Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
LoadSettingsException Constructor()
See Also Send Feedback
Accusoft.TwainProSdk Namespace > LoadSettingsException Class > LoadSettingsException Constructor : LoadSettingsException Constructor()

Glossary Item Box

An exception generated for a load settings error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New LoadSettingsException()
public LoadSettingsException()
public: LoadSettingsException();
public:
LoadSettingsException();

See Also

Reference

LoadSettingsException Class
LoadSettingsException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
LoadSettingsException Constructor(Int32)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > LoadSettingsException Class > LoadSettingsException Constructor : LoadSettingsException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a load settings error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New LoadSettingsException(errorNumber)
public LoadSettingsException(
   int errorNumber
)
public: LoadSettingsException(
   int errorNumber
)
public:
LoadSettingsException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

LoadSettingsException Class
LoadSettingsException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
LoadSettingsException Constructor(String)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > LoadSettingsException Class > LoadSettingsException Constructor : LoadSettingsException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a load settings error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New LoadSettingsException(message)
public LoadSettingsException(
   string message
)
public: LoadSettingsException(
   string* message
)
public:
LoadSettingsException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

LoadSettingsException Class
LoadSettingsException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
LoadSettingsException Constructor(Int32,String)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > LoadSettingsException Class > LoadSettingsException Constructor : LoadSettingsException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a load settings error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New LoadSettingsException(errorNumber, message)
public LoadSettingsException(
   int errorNumber,
   string message
)
public: LoadSettingsException(
   int errorNumber,
   string* message
)
public:
LoadSettingsException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

LoadSettingsException Class
LoadSettingsException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
LoadSettingsException Constructor(String,Exception)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > LoadSettingsException Class > LoadSettingsException Constructor : LoadSettingsException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a load settings error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New LoadSettingsException(message, innerException)
public LoadSettingsException(
   string message,
   Exception innerException
)
public: LoadSettingsException(
   string* message,
   Exception* innerException
)
public:
LoadSettingsException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

LoadSettingsException Class
LoadSettingsException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
OperationCancelledException Class
Members See Also Send Feedback
Accusoft.TwainProSdk Namespace : OperationCancelledException Class

Glossary Item Box

This exception is thrown if the user cancelled the requested operation.

Object Model

OperationCancelledException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class OperationCancelledException
   Inherits TwainProException
'Usage

Dim instance As OperationCancelledException
[SerializableAttribute()]
public sealed class OperationCancelledException : TwainProException
[SerializableAttribute()]
public __gc __sealed class OperationCancelledException : public TwainProException
[SerializableAttribute()]
public ref class OperationCancelledException sealed : public TwainProException

Remarks

Possible causes:

The user clicked the cancel button on the source selection dialog invoked by the SelectSource method.

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.TwainProSdk.TwainProException
Accusoft.TwainProSdk.OperationCancelledException

See Also

Reference

OperationCancelledException Members
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.TwainPro7.Net
OperationCancelledException Class Members
See Also Properties Methods Send Feedback
Accusoft.TwainProSdk Namespace : OperationCancelledException Class

Glossary Item Box

The following tables list the members exposed by OperationCancelledException.

Public Constructors

 | Name | Description
Public Constructor | OperationCancelledException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.TwainProSdk.TwainProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

OperationCancelledException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.TwainPro7.Net
OperationCancelledException Class Methods
See Also Send Feedback
Accusoft.TwainProSdk Namespace : OperationCancelledException Class

Glossary Item Box

For a list of all members of this type, see OperationCancelledException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

OperationCancelledException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.TwainPro7.Net
OperationCancelledException Class Properties
See Also Send Feedback
Accusoft.TwainProSdk Namespace : OperationCancelledException Class

Glossary Item Box

For a list of all members of this type, see OperationCancelledException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.TwainProSdk.TwainProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

OperationCancelledException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
OperationCancelledException Constructor
See Also Send Feedback
Accusoft.TwainProSdk Namespace > OperationCancelledException Class : OperationCancelledException Constructor

Glossary Item Box

Overload List

Overload | Description
OperationCancelledException Constructor() | An exception generated for an operation cancelled error.
OperationCancelledException Constructor(Int32) | Generated exception for an operation cancelled error with a given error number.
OperationCancelledException Constructor(String) | Generated exception for an operation cancelled error with a given string.
OperationCancelledException Constructor(Int32,String) | Generated exception for an operation cancelled error with a given error number and message.
OperationCancelledException Constructor(String,Exception) | Generated exception for an operation cancelled error with a given message and inner exception.

See Also

Reference

OperationCancelledException Class
OperationCancelledException Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
OperationCancelledException Constructor()
See Also Send Feedback
Accusoft.TwainProSdk Namespace > OperationCancelledException Class > OperationCancelledException Constructor : OperationCancelledException Constructor()

Glossary Item Box

An exception generated for an operation cancelled error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New OperationCancelledException()
public OperationCancelledException()
public: OperationCancelledException();
public:
OperationCancelledException();

See Also

Reference

OperationCancelledException Class
OperationCancelledException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
OperationCancelledException Constructor(Int32)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > OperationCancelledException Class > OperationCancelledException Constructor : OperationCancelledException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for an operation cancelled error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New OperationCancelledException(errorNumber)
public OperationCancelledException(
   int errorNumber
)
public: OperationCancelledException(
   int errorNumber
)
public:
OperationCancelledException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

OperationCancelledException Class
OperationCancelledException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
OperationCancelledException Constructor(String)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > OperationCancelledException Class > OperationCancelledException Constructor : OperationCancelledException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for an operation cancelled error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New OperationCancelledException(message)
public OperationCancelledException(
   string message
)
public: OperationCancelledException(
   string* message
)
public:
OperationCancelledException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

OperationCancelledException Class
OperationCancelledException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
OperationCancelledException Constructor(Int32,String)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > OperationCancelledException Class > OperationCancelledException Constructor : OperationCancelledException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for an operation cancelled error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New OperationCancelledException(errorNumber, message)
public OperationCancelledException(
   int errorNumber,
   string message
)
public: OperationCancelledException(
   int errorNumber,
   string* message
)
public:
OperationCancelledException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

OperationCancelledException Class
OperationCancelledException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
OperationCancelledException Constructor(String,Exception)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > OperationCancelledException Class > OperationCancelledException Constructor : OperationCancelledException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for an operation cancelled error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New OperationCancelledException(message, innerException)
public OperationCancelledException(
   string message,
   Exception innerException
)
public: OperationCancelledException(
   string* message,
   Exception* innerException
)
public:
OperationCancelledException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

OperationCancelledException Class
OperationCancelledException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
OutOfMemoryException Class
Members See Also Send Feedback
Accusoft.TwainProSdk Namespace : OutOfMemoryException Class

Glossary Item Box

This exception is thrown if TwainPRO is unable to allocate memory for the requested operation.

Object Model

OutOfMemoryException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class OutOfMemoryException
   Inherits TwainProException
'Usage

Dim instance As OutOfMemoryException
[SerializableAttribute()]
public sealed class OutOfMemoryException : TwainProException
[SerializableAttribute()]
public __gc __sealed class OutOfMemoryException : public TwainProException
[SerializableAttribute()]
public ref class OutOfMemoryException sealed : public TwainProException

Remarks

Possible causes:

The image being transferred is too large to fit in memory.

Too many applications are open.

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.TwainProSdk.TwainProException
Accusoft.TwainProSdk.OutOfMemoryException

See Also

Reference

OutOfMemoryException Members
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.TwainPro7.Net
OutOfMemoryException Class Members
See Also Properties Methods Send Feedback
Accusoft.TwainProSdk Namespace : OutOfMemoryException Class

Glossary Item Box

The following tables list the members exposed by OutOfMemoryException.

Public Constructors

 | Name | Description
Public Constructor | OutOfMemoryException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.TwainProSdk.TwainProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

OutOfMemoryException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.TwainPro7.Net
OutOfMemoryException Class Methods
See Also Send Feedback
Accusoft.TwainProSdk Namespace : OutOfMemoryException Class

Glossary Item Box

For a list of all members of this type, see OutOfMemoryException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

OutOfMemoryException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.TwainPro7.Net
OutOfMemoryException Class Properties
See Also Send Feedback
Accusoft.TwainProSdk Namespace : OutOfMemoryException Class

Glossary Item Box

For a list of all members of this type, see OutOfMemoryException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.TwainProSdk.TwainProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

OutOfMemoryException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
OutOfMemoryException Constructor
See Also Send Feedback
Accusoft.TwainProSdk Namespace > OutOfMemoryException Class : OutOfMemoryException Constructor

Glossary Item Box

Overload List

Overload | Description
OutOfMemoryException Constructor() | An exception generated for an out of memory error.
OutOfMemoryException Constructor(Int32) | Generated exception for an out of memory error with a given error number.
OutOfMemoryException Constructor(String) | Generated exception for an out of memory error with a given string.
OutOfMemoryException Constructor(Int32,String) | Generated exception for an out of memory error with a given error number and message.
OutOfMemoryException Constructor(String,Exception) | Generated exception for an out of memory error with a given message and inner exception.

See Also

Reference

OutOfMemoryException Class
OutOfMemoryException Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
OutOfMemoryException Constructor()
See Also Send Feedback
Accusoft.TwainProSdk Namespace > OutOfMemoryException Class > OutOfMemoryException Constructor : OutOfMemoryException Constructor()

Glossary Item Box

An exception generated for an out of memory error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New OutOfMemoryException()
public OutOfMemoryException()
public: OutOfMemoryException();
public:
OutOfMemoryException();

See Also

Reference

OutOfMemoryException Class
OutOfMemoryException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
OutOfMemoryException Constructor(Int32)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > OutOfMemoryException Class > OutOfMemoryException Constructor : OutOfMemoryException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for an out of memory error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New OutOfMemoryException(errorNumber)
public OutOfMemoryException(
   int errorNumber
)
public: OutOfMemoryException(
   int errorNumber
)
public:
OutOfMemoryException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

OutOfMemoryException Class
OutOfMemoryException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
OutOfMemoryException Constructor(String)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > OutOfMemoryException Class > OutOfMemoryException Constructor : OutOfMemoryException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for an out of memory error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New OutOfMemoryException(message)
public OutOfMemoryException(
   string message
)
public: OutOfMemoryException(
   string* message
)
public:
OutOfMemoryException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

OutOfMemoryException Class
OutOfMemoryException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
OutOfMemoryException Constructor(Int32,String)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > OutOfMemoryException Class > OutOfMemoryException Constructor : OutOfMemoryException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for an out of memory error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New OutOfMemoryException(errorNumber, message)
public OutOfMemoryException(
   int errorNumber,
   string message
)
public: OutOfMemoryException(
   int errorNumber,
   string* message
)
public:
OutOfMemoryException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

OutOfMemoryException Class
OutOfMemoryException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
OutOfMemoryException Constructor(String,Exception)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > OutOfMemoryException Class > OutOfMemoryException Constructor : OutOfMemoryException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for an out of memory error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New OutOfMemoryException(message, innerException)
public OutOfMemoryException(
   string message,
   Exception innerException
)
public: OutOfMemoryException(
   string* message,
   Exception* innerException
)
public:
OutOfMemoryException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

OutOfMemoryException Class
OutOfMemoryException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
PegasusFilesNotInstalledException Class
Members See Also Send Feedback
Accusoft.TwainProSdk Namespace : PegasusFilesNotInstalledException Class

Glossary Item Box

This exception is thrown if the required Pegasus DLL file(s) are missing.

Object Model

PegasusFilesNotInstalledException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class PegasusFilesNotInstalledException
   Inherits TwainProException
'Usage

Dim instance As PegasusFilesNotInstalledException
[SerializableAttribute()]
public sealed class PegasusFilesNotInstalledException : TwainProException
[SerializableAttribute()]
public __gc __sealed class PegasusFilesNotInstalledException : public TwainProException
[SerializableAttribute()]
public ref class PegasusFilesNotInstalledException sealed : public TwainProException

Remarks

Possible causes:

Pegasus DLL files are required when saving JPEG, ePIC, TIF, or PDF files. They are listed in the dependencies section.

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.TwainProSdk.TwainProException
Accusoft.TwainProSdk.PegasusFilesNotInstalledException

See Also

Reference

PegasusFilesNotInstalledException Members
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.TwainPro7.Net
PegasusFilesNotInstalledException Class Members
See Also Properties Methods Send Feedback
Accusoft.TwainProSdk Namespace : PegasusFilesNotInstalledException Class

Glossary Item Box

The following tables list the members exposed by PegasusFilesNotInstalledException.

Public Constructors

 | Name | Description
Public Constructor | PegasusFilesNotInstalledException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.TwainProSdk.TwainProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

PegasusFilesNotInstalledException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.TwainPro7.Net
PegasusFilesNotInstalledException Class Methods
See Also Send Feedback
Accusoft.TwainProSdk Namespace : PegasusFilesNotInstalledException Class

Glossary Item Box

For a list of all members of this type, see PegasusFilesNotInstalledException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

PegasusFilesNotInstalledException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.TwainPro7.Net
PegasusFilesNotInstalledException Class Properties
See Also Send Feedback
Accusoft.TwainProSdk Namespace : PegasusFilesNotInstalledException Class

Glossary Item Box

For a list of all members of this type, see PegasusFilesNotInstalledException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.TwainProSdk.TwainProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

PegasusFilesNotInstalledException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
PegasusFilesNotInstalledException Constructor
See Also Send Feedback
Accusoft.TwainProSdk Namespace > PegasusFilesNotInstalledException Class : PegasusFilesNotInstalledException Constructor

Glossary Item Box

Overload List

Overload | Description
PegasusFilesNotInstalledException Constructor() | An exception generated for a Pegasus files not installed error.
PegasusFilesNotInstalledException Constructor(Int32) | Generated exception for a Pegasus files not installed error with a given error number.
PegasusFilesNotInstalledException Constructor(String) | Generated exception for a Pegasus files not installed error with a given string.
PegasusFilesNotInstalledException Constructor(Int32,String) | Generated exception for a Pegasus files not installed error with a given error number and message.
PegasusFilesNotInstalledException Constructor(String,Exception) | Generated exception for a Pegasus files not installed error with a given message and inner exception.

See Also

Reference

PegasusFilesNotInstalledException Class
PegasusFilesNotInstalledException Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
PegasusFilesNotInstalledException Constructor()
See Also Send Feedback
Accusoft.TwainProSdk Namespace > PegasusFilesNotInstalledException Class > PegasusFilesNotInstalledException Constructor : PegasusFilesNotInstalledException Constructor()

Glossary Item Box

An exception generated for a Pegasus files not installed error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PegasusFilesNotInstalledException()
public PegasusFilesNotInstalledException()
public: PegasusFilesNotInstalledException();
public:
PegasusFilesNotInstalledException();

See Also

Reference

PegasusFilesNotInstalledException Class
PegasusFilesNotInstalledException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
PegasusFilesNotInstalledException Constructor(Int32)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > PegasusFilesNotInstalledException Class > PegasusFilesNotInstalledException Constructor : PegasusFilesNotInstalledException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a Pegasus files not installed error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New PegasusFilesNotInstalledException(errorNumber)
public PegasusFilesNotInstalledException(
   int errorNumber
)
public: PegasusFilesNotInstalledException(
   int errorNumber
)
public:
PegasusFilesNotInstalledException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

PegasusFilesNotInstalledException Class
PegasusFilesNotInstalledException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
PegasusFilesNotInstalledException Constructor(String)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > PegasusFilesNotInstalledException Class > PegasusFilesNotInstalledException Constructor : PegasusFilesNotInstalledException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a Pegasus files not installed error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New PegasusFilesNotInstalledException(message)
public PegasusFilesNotInstalledException(
   string message
)
public: PegasusFilesNotInstalledException(
   string* message
)
public:
PegasusFilesNotInstalledException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

PegasusFilesNotInstalledException Class
PegasusFilesNotInstalledException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
PegasusFilesNotInstalledException Constructor(Int32,String)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > PegasusFilesNotInstalledException Class > PegasusFilesNotInstalledException Constructor : PegasusFilesNotInstalledException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a Pegasus files not installed error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New PegasusFilesNotInstalledException(errorNumber, message)
public PegasusFilesNotInstalledException(
   int errorNumber,
   string message
)
public: PegasusFilesNotInstalledException(
   int errorNumber,
   string* message
)
public:
PegasusFilesNotInstalledException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

PegasusFilesNotInstalledException Class
PegasusFilesNotInstalledException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
PegasusFilesNotInstalledException Constructor(String,Exception)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > PegasusFilesNotInstalledException Class > PegasusFilesNotInstalledException Constructor : PegasusFilesNotInstalledException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a Pegasus files not installed error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New PegasusFilesNotInstalledException(message, innerException)
public PegasusFilesNotInstalledException(
   string message,
   Exception innerException
)
public: PegasusFilesNotInstalledException(
   string* message,
   Exception* innerException
)
public:
PegasusFilesNotInstalledException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

PegasusFilesNotInstalledException Class
PegasusFilesNotInstalledException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
PropertyOrMethodNotAvailableException Class
Members See Also Send Feedback
Accusoft.TwainProSdk Namespace : PropertyOrMethodNotAvailableException Class

Glossary Item Box

This exception is thrown if the property or method requested is not currently available.

Object Model

PropertyOrMethodNotAvailableException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class PropertyOrMethodNotAvailableException
   Inherits TwainProException
'Usage

Dim instance As PropertyOrMethodNotAvailableException
[SerializableAttribute()]
public sealed class PropertyOrMethodNotAvailableException : TwainProException
[SerializableAttribute()]
public __gc __sealed class PropertyOrMethodNotAvailableException : public TwainProException
[SerializableAttribute()]
public ref class PropertyOrMethodNotAvailableException sealed : public TwainProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.TwainProSdk.TwainProException
Accusoft.TwainProSdk.PropertyOrMethodNotAvailableException

See Also

Reference

PropertyOrMethodNotAvailableException Members
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.TwainPro7.Net
PropertyOrMethodNotAvailableException Class Members
See Also Properties Methods Send Feedback
Accusoft.TwainProSdk Namespace : PropertyOrMethodNotAvailableException Class

Glossary Item Box

The following tables list the members exposed by PropertyOrMethodNotAvailableException.

Public Constructors

 | Name | Description
Public Constructor | PropertyOrMethodNotAvailableException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.TwainProSdk.TwainProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

PropertyOrMethodNotAvailableException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.TwainPro7.Net
PropertyOrMethodNotAvailableException Class Methods
See Also Send Feedback
Accusoft.TwainProSdk Namespace : PropertyOrMethodNotAvailableException Class

Glossary Item Box

For a list of all members of this type, see PropertyOrMethodNotAvailableException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

PropertyOrMethodNotAvailableException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.TwainPro7.Net
PropertyOrMethodNotAvailableException Class Properties
See Also Send Feedback
Accusoft.TwainProSdk Namespace : PropertyOrMethodNotAvailableException Class

Glossary Item Box

For a list of all members of this type, see PropertyOrMethodNotAvailableException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.TwainProSdk.TwainProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

PropertyOrMethodNotAvailableException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
PropertyOrMethodNotAvailableException Constructor
See Also Send Feedback
Accusoft.TwainProSdk Namespace > PropertyOrMethodNotAvailableException Class : PropertyOrMethodNotAvailableException Constructor

Glossary Item Box

Overload List

Overload | Description
PropertyOrMethodNotAvailableException Constructor() | An exception generated for a property or method not available error.
PropertyOrMethodNotAvailableException Constructor(Int32) | Generated exception for a property or method not available error with a given error number.
PropertyOrMethodNotAvailableException Constructor(String) | Generated exception for a property or method not available error with a given string.
PropertyOrMethodNotAvailableException Constructor(Int32,String) | Generated exception for a property or method not available error with a given error number and message.
PropertyOrMethodNotAvailableException Constructor(String,Exception) | Generated exception for a property or method not available error with a given message and inner exception.

See Also

Reference

PropertyOrMethodNotAvailableException Class
PropertyOrMethodNotAvailableException Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
PropertyOrMethodNotAvailableException Constructor()
See Also Send Feedback
Accusoft.TwainProSdk Namespace > PropertyOrMethodNotAvailableException Class > PropertyOrMethodNotAvailableException Constructor : PropertyOrMethodNotAvailableException Constructor()

Glossary Item Box

An exception generated for a property or method not available error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PropertyOrMethodNotAvailableException()
public PropertyOrMethodNotAvailableException()
public: PropertyOrMethodNotAvailableException();
public:
PropertyOrMethodNotAvailableException();

See Also

Reference

PropertyOrMethodNotAvailableException Class
PropertyOrMethodNotAvailableException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
PropertyOrMethodNotAvailableException Constructor(Int32)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > PropertyOrMethodNotAvailableException Class > PropertyOrMethodNotAvailableException Constructor : PropertyOrMethodNotAvailableException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a property or method not available error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New PropertyOrMethodNotAvailableException(errorNumber)
public PropertyOrMethodNotAvailableException(
   int errorNumber
)
public: PropertyOrMethodNotAvailableException(
   int errorNumber
)
public:
PropertyOrMethodNotAvailableException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

PropertyOrMethodNotAvailableException Class
PropertyOrMethodNotAvailableException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
PropertyOrMethodNotAvailableException Constructor(String)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > PropertyOrMethodNotAvailableException Class > PropertyOrMethodNotAvailableException Constructor : PropertyOrMethodNotAvailableException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a property or method not available error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New PropertyOrMethodNotAvailableException(message)
public PropertyOrMethodNotAvailableException(
   string message
)
public: PropertyOrMethodNotAvailableException(
   string* message
)
public:
PropertyOrMethodNotAvailableException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

PropertyOrMethodNotAvailableException Class
PropertyOrMethodNotAvailableException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
PropertyOrMethodNotAvailableException Constructor(Int32,String)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > PropertyOrMethodNotAvailableException Class > PropertyOrMethodNotAvailableException Constructor : PropertyOrMethodNotAvailableException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a property or method not available error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New PropertyOrMethodNotAvailableException(errorNumber, message)
public PropertyOrMethodNotAvailableException(
   int errorNumber,
   string message
)
public: PropertyOrMethodNotAvailableException(
   int errorNumber,
   string* message
)
public:
PropertyOrMethodNotAvailableException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

PropertyOrMethodNotAvailableException Class
PropertyOrMethodNotAvailableException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
PropertyOrMethodNotAvailableException Constructor(String,Exception)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > PropertyOrMethodNotAvailableException Class > PropertyOrMethodNotAvailableException Constructor : PropertyOrMethodNotAvailableException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a property or method not available error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New PropertyOrMethodNotAvailableException(message, innerException)
public PropertyOrMethodNotAvailableException(
   string message,
   Exception innerException
)
public: PropertyOrMethodNotAvailableException(
   string* message,
   Exception* innerException
)
public:
PropertyOrMethodNotAvailableException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

PropertyOrMethodNotAvailableException Class
PropertyOrMethodNotAvailableException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
SaveOptions Class
Members See Also Send Feedback
Accusoft.TwainProSdk Namespace : SaveOptions Class

Glossary Item Box

This class implements file writing of image formats.

Object Model

SaveOptions ClassFtpOptions ClassSaveOptionsJpeg ClassSaveOptionsPdf ClassSaveOptionsPic ClassSaveOptionsPng ClassSaveOptionsTiff Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Class SaveOptions
'Usage

Dim instance As SaveOptions
public class SaveOptions
public __gc class SaveOptions
public ref class SaveOptions

Remarks

TwainPRO saves to the following file formats: BMP, JPEG, ePIC, TIFF, and PDF.

Inheritance Hierarchy

System.Object
Accusoft.TwainProSdk.SaveOptions

See Also

Reference

SaveOptions Members
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.TwainPro7.Net
SaveOptions Class Members
See Also Properties Send Feedback
Accusoft.TwainProSdk Namespace : SaveOptions Class

Glossary Item Box

The following tables list the members exposed by SaveOptions.

Public Constructors

 | Name | Description
Public Constructor | SaveOptions Constructor | The main constructor for the SaveOptions class.
Top

Public Properties

 | Name | Description
Public Property | Format | Gets and sets the format of the saved file.
Public Property | FtpOptions | Gets the FtpOptions settings.
Public Property | Jpeg | Gets the SaveOptionsJpeg settings.
Public Property | Pdf | Gets the SaveOptionsPdf settings.
Public Property | Pic | Gets the SaveOptionsPic settings.
Public Property | Png | Gets the SaveOptionsPng settings.
Public Property | Tiff | Gets the SaveOptionsTiff settings.
Top

See Also

Reference

SaveOptions Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
SaveOptions Constructor
See Also Send Feedback
Accusoft.TwainProSdk Namespace > SaveOptions Class : SaveOptions Constructor

Glossary Item Box

The main constructor for the SaveOptions class.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New SaveOptions()
public SaveOptions()
public: SaveOptions();
public:
SaveOptions();

See Also

Reference

SaveOptions Class
SaveOptions Members


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.TwainPro7.Net
SaveOptions Class Properties
See Also Send Feedback
Accusoft.TwainProSdk Namespace : SaveOptions Class

Glossary Item Box

For a list of all members of this type, see SaveOptions members.

Public Properties

 | Name | Description
Public Property | Format | Gets and sets the format of the saved file.
Public Property | FtpOptions | Gets the FtpOptions settings.
Public Property | Jpeg | Gets the SaveOptionsJpeg settings.
Public Property | Pdf | Gets the SaveOptionsPdf settings.
Public Property | Pic | Gets the SaveOptionsPic settings.
Public Property | Png | Gets the SaveOptionsPng settings.
Public Property | Tiff | Gets the SaveOptionsTiff settings.
Top

See Also

Reference

SaveOptions Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Format Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > SaveOptions Class : Format Property

Glossary Item Box

Gets and sets the format of the saved file.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public Property Format As ScannedImageFormat
'Usage

Dim instance As SaveOptions
Dim value As ScannedImageFormat

instance.Format = value

value = instance.Format
[BrowsableAttribute(false)]
public ScannedImageFormat Format {get; set;}
[BrowsableAttribute(false)]
public: __property ScannedImageFormat get_Format();
public: __property void set_Format(
   ScannedImageFormat value
);
[BrowsableAttribute(false)]
public:
property ScannedImageFormat Format {
   ScannedImageFormat get();
   void set (    ScannedImageFormat value);
}

Property Value

A ScannedImageFormat to save the file in.

Remarks

The default value is ScannedImageFormat.Default.

See Also

Reference

SaveOptions Class
SaveOptions Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
FtpOptions Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > SaveOptions Class : FtpOptions Property

Glossary Item Box

Gets the FtpOptions settings.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public ReadOnly Property FtpOptions As FtpOptions
'Usage

Dim instance As SaveOptions
Dim value As FtpOptions

value = instance.FtpOptions
[BrowsableAttribute(false)]
public FtpOptions FtpOptions {get;}
[BrowsableAttribute(false)]
public: __property FtpOptions* get_FtpOptions();
[BrowsableAttribute(false)]
public:
property FtpOptions^ FtpOptions {
   FtpOptions^ get();
}

Property Value

A FtpOptions object value which contains the FtpOptions settings.

Remarks

The default value is null.

See Also

Reference

SaveOptions Class
SaveOptions Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Jpeg Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > SaveOptions Class : Jpeg Property

Glossary Item Box

Gets the SaveOptionsJpeg settings.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public ReadOnly Property Jpeg As SaveOptionsJpeg
'Usage

Dim instance As SaveOptions
Dim value As SaveOptionsJpeg

value = instance.Jpeg
[BrowsableAttribute(false)]
public SaveOptionsJpeg Jpeg {get;}
[BrowsableAttribute(false)]
public: __property SaveOptionsJpeg* get_Jpeg();
[BrowsableAttribute(false)]
public:
property SaveOptionsJpeg^ Jpeg {
   SaveOptionsJpeg^ get();
}

Property Value

A SaveOptionsJpeg object value which contains the SaveOptionsJpeg settings.

Remarks

The default value is null.

See Also

Reference

SaveOptions Class
SaveOptions Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Pdf Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > SaveOptions Class : Pdf Property

Glossary Item Box

Gets the SaveOptionsPdf settings.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public ReadOnly Property Pdf As SaveOptionsPdf
'Usage

Dim instance As SaveOptions
Dim value As SaveOptionsPdf

value = instance.Pdf
[BrowsableAttribute(false)]
public SaveOptionsPdf Pdf {get;}
[BrowsableAttribute(false)]
public: __property SaveOptionsPdf* get_Pdf();
[BrowsableAttribute(false)]
public:
property SaveOptionsPdf^ Pdf {
   SaveOptionsPdf^ get();
}

Property Value

A SaveOptionsPdf object value which contains the SaveOptionsPdf settings.

Remarks

The default value is null.

See Also

Reference

SaveOptions Class
SaveOptions Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Pic Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > SaveOptions Class : Pic Property

Glossary Item Box

Gets the SaveOptionsPic settings.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public ReadOnly Property Pic As SaveOptionsPic
'Usage

Dim instance As SaveOptions
Dim value As SaveOptionsPic

value = instance.Pic
[BrowsableAttribute(false)]
public SaveOptionsPic Pic {get;}
[BrowsableAttribute(false)]
public: __property SaveOptionsPic* get_Pic();
[BrowsableAttribute(false)]
public:
property SaveOptionsPic^ Pic {
   SaveOptionsPic^ get();
}

Property Value

A SaveOptionsPic object value which contains the SaveOptionsPic settings.

Remarks

The default value is null.

See Also

Reference

SaveOptions Class
SaveOptions Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Png Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > SaveOptions Class : Png Property

Glossary Item Box

Gets the SaveOptionsPng settings.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public ReadOnly Property Png As SaveOptionsPng
'Usage

Dim instance As SaveOptions
Dim value As SaveOptionsPng

value = instance.Png
[BrowsableAttribute(false)]
public SaveOptionsPng Png {get;}
[BrowsableAttribute(false)]
public: __property SaveOptionsPng* get_Png();
[BrowsableAttribute(false)]
public:
property SaveOptionsPng^ Png {
   SaveOptionsPng^ get();
}

Property Value

A SaveOptionsPng object value which contains the SaveOptionsPng settings.

Remarks

The default value is null.

See Also

Reference

SaveOptions Class
SaveOptions Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Tiff Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > SaveOptions Class : Tiff Property

Glossary Item Box

Gets the SaveOptionsTiff settings.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public ReadOnly Property Tiff As SaveOptionsTiff
'Usage

Dim instance As SaveOptions
Dim value As SaveOptionsTiff

value = instance.Tiff
[BrowsableAttribute(false)]
public SaveOptionsTiff Tiff {get;}
[BrowsableAttribute(false)]
public: __property SaveOptionsTiff* get_Tiff();
[BrowsableAttribute(false)]
public:
property SaveOptionsTiff^ Tiff {
   SaveOptionsTiff^ get();
}

Property Value

A SaveOptionsTiff object value which contains the SaveOptionsTiff settings.

Remarks

The default value is null.

See Also

Reference

SaveOptions Class
SaveOptions Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
SaveOptionsJpeg Class
Members See Also Send Feedback
Accusoft.TwainProSdk Namespace : SaveOptionsJpeg Class

Glossary Item Box

Implements SaveOptions for the JPEG file format.

Object Model

SaveOptionsJpeg Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Class SaveOptionsJpeg
'Usage

Dim instance As SaveOptionsJpeg
public class SaveOptionsJpeg
public __gc class SaveOptionsJpeg
public ref class SaveOptionsJpeg

Remarks

Writes necessary JPEG specific file information.

Inheritance Hierarchy

System.Object
Accusoft.TwainProSdk.SaveOptionsJpeg

See Also

Reference

SaveOptionsJpeg Members
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.TwainPro7.Net
SaveOptionsJpeg Class Members
See Also Properties Send Feedback
Accusoft.TwainProSdk Namespace : SaveOptionsJpeg Class

Glossary Item Box

The following tables list the members exposed by SaveOptionsJpeg.

Public Properties

 | Name | Description
Public Property | Chrominance | Gets and sets the chrominance quality setting for saving JPEG files.
Public Property | Luminance | Gets and sets the luminance quality setting for saving JPEG files.
Public Property | Progressive | Gets and sets whether JPEG files are to be saved as standard files or progressive files.
Public Property | SubSampling | Gets and sets the subsampling type for saving JPEG files.
Top

See Also

Reference

SaveOptionsJpeg Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.TwainPro7.Net
SaveOptionsJpeg Class Properties
See Also Send Feedback
Accusoft.TwainProSdk Namespace : SaveOptionsJpeg Class

Glossary Item Box

For a list of all members of this type, see SaveOptionsJpeg members.

Public Properties

 | Name | Description
Public Property | Chrominance | Gets and sets the chrominance quality setting for saving JPEG files.
Public Property | Luminance | Gets and sets the luminance quality setting for saving JPEG files.
Public Property | Progressive | Gets and sets whether JPEG files are to be saved as standard files or progressive files.
Public Property | SubSampling | Gets and sets the subsampling type for saving JPEG files.
Top

See Also

Reference

SaveOptionsJpeg Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Chrominance Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > SaveOptionsJpeg Class : Chrominance Property

Glossary Item Box

Gets and sets the chrominance quality setting for saving JPEG files.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DefaultValueAttribute()>
<DescriptionAttribute("Specifies the chrominance quality setting for saving JPEG files.")>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property Chrominance As Integer
'Usage

Dim instance As SaveOptionsJpeg
Dim value As Integer

instance.Chrominance = value

value = instance.Chrominance
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the chrominance quality setting for saving JPEG files.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public int Chrominance {get; set;}
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the chrominance quality setting for saving JPEG files.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property int get_Chrominance();
public: __property void set_Chrominance(
   int value
);
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the chrominance quality setting for saving JPEG files.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property int Chrominance {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the chrominance quality setting for saving JPEG files.

Remarks

The default value is 10. It should be within the range of 0 to 255.

JPEG and ePIC images are stored in a compressed format. Compression is lossy which means when you save a JPEG or ePIC file, there will be data loss. Data loss is the result of JPEG and ePICs ability to achieve high compression ratios. Higher quality settings result in less compression, while lower quality settings result in higher compression. Quality versus compression is a tradeoff.

The image compression ratio can be adjusted by setting the Luminance and Chrominance properties. The Luminance property adjusts the luminance or gray scale quality and the Chrominance property adjusts the chrominance or color quality. Lower settings for these properties result in higher quality images with less compression. Higher settings for these properties result in lower quality images with more compression.

For general use photographic type images, setting Luminance = 24 and Chrominance = 30 provides about a 12:1 image compression ratio with minimal data loss. Compression ratios and perceived image quality will vary depending on the image.

See Also

Reference

SaveOptionsJpeg Class
SaveOptionsJpeg Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Luminance Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > SaveOptionsJpeg Class : Luminance Property

Glossary Item Box

Gets and sets the luminance quality setting for saving JPEG files.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DefaultValueAttribute()>
<DescriptionAttribute("Specifies the luminance quality setting for saving JPEG files.")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property Luminance As Integer
'Usage

Dim instance As SaveOptionsJpeg
Dim value As Integer

instance.Luminance = value

value = instance.Luminance
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the luminance quality setting for saving JPEG files.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public int Luminance {get; set;}
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the luminance quality setting for saving JPEG files.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property int get_Luminance();
public: __property void set_Luminance(
   int value
);
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the luminance quality setting for saving JPEG files.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property int Luminance {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the luminance quality setting for saving JPEG files.

Remarks

The default value is 10. It should be within the range of 0 to 255.

JPEG and ePIC images are stored in a compressed format. Compression is lossy which means when you save a JPEG or ePIC file, there will be data loss. Data loss is the result of JPEG and ePICs ability to achieve high compression ratios. Higher quality settings result in less compression, while lower quality settings result in higher compression. Quality versus compression is a tradeoff.

The image compression ratio can be adjusted by setting the Luminance and Chrominance properties. The Luminance property adjusts the luminance or gray scale quality and the Chrominance property adjusts the chrominance or color quality. Lower settings for these properties result in higher quality images with less compression. Higher settings for these properties result in lower quality images with more compression.

For general use photographic type images, setting Luminance = 24 and Chrominance = 30 provides about a 12:1 image compression ratio with minimal data loss. Compression ratios and perceived image quality will vary depending on the image.

See Also

Reference

SaveOptionsJpeg Class
SaveOptionsJpeg Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Progressive Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > SaveOptionsJpeg Class : Progressive Property

Glossary Item Box

Gets and sets whether JPEG files are to be saved as standard files or progressive files.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DescriptionAttribute("Specifies whether JPEG files are to be saved as standard files or progressive files.")>
<DefaultValueAttribute()>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property Progressive As Boolean
'Usage

Dim instance As SaveOptionsJpeg
Dim value As Boolean

instance.Progressive = value

value = instance.Progressive
[DescriptionAttribute("Specifies whether JPEG files are to be saved as standard files or progressive files.")]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public bool Progressive {get; set;}
[DescriptionAttribute("Specifies whether JPEG files are to be saved as standard files or progressive files.")]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property bool get_Progressive();
public: __property void set_Progressive(
   bool value
);
[DescriptionAttribute("Specifies whether JPEG files are to be saved as standard files or progressive files.")]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property bool Progressive {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true to save as standard. Otherwise, false should be used to save as progressive.

Remarks

The default value is false.

See Also

Reference

SaveOptionsJpeg Class
SaveOptionsJpeg Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
SubSampling Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > SaveOptionsJpeg Class : SubSampling Property

Glossary Item Box

Gets and sets the subsampling type for saving JPEG files.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DescriptionAttribute("Specifies the subsampling type for saving JPEG files.")>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<DefaultValueAttribute()>
Public Property SubSampling As SubSampling
'Usage

Dim instance As SaveOptionsJpeg
Dim value As SubSampling

instance.SubSampling = value

value = instance.SubSampling
[DescriptionAttribute("Specifies the subsampling type for saving JPEG files.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DefaultValueAttribute()]
public SubSampling SubSampling {get; set;}
[DescriptionAttribute("Specifies the subsampling type for saving JPEG files.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DefaultValueAttribute()]
public: __property SubSampling get_SubSampling();
public: __property void set_SubSampling(
   SubSampling value
);
[DescriptionAttribute("Specifies the subsampling type for saving JPEG files.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DefaultValueAttribute()]
public:
property SubSampling SubSampling {
   SubSampling get();
   void set (    SubSampling value);
}

Property Value

A SubSampling type to save the JPEG file in.

Remarks

The default value: is SubSampling411

SS_111 provides the highest image quality with lower compression and SS_411 provides the best compression with lower image quality.

See Also

Reference

SaveOptionsJpeg Class
SaveOptionsJpeg Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
SaveOptionsPdf Class
Members See Also Send Feedback
Accusoft.TwainProSdk Namespace : SaveOptionsPdf Class

Glossary Item Box

This class implements SaveOptions for the PDF file format.

Object Model

SaveOptionsPdf Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Class SaveOptionsPdf
'Usage

Dim instance As SaveOptionsPdf
public class SaveOptionsPdf
public __gc class SaveOptionsPdf
public ref class SaveOptionsPdf

Remarks

Writes necessary PDF specific file information.

Inheritance Hierarchy

System.Object
Accusoft.TwainProSdk.SaveOptionsPdf

See Also

Reference

SaveOptionsPdf Members
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.TwainPro7.Net
SaveOptionsPdf Class Members
See Also Properties Send Feedback
Accusoft.TwainProSdk Namespace : SaveOptionsPdf Class

Glossary Item Box

The following tables list the members exposed by SaveOptionsPdf.

Public Properties

 | Name | Description
Public Property | Chrominance | Gets and sets the chrominance quality setting for saving PDF files.
Public Property | Compression | Gets or sets the compression type employed for saving a PDF file.
Public Property | EncodeModeCompression | Specifies the encoding mode to use when creating a JBIG2 compressed file.
Public Property | FileOrganizationCompression | Gets and sets the file organization when saving a JBIG2 compressed file.
Public Property | InvertedRegion | Gets and sets whether the bits should be inverted prior to symbol analysis.
Public Property | LoosenessCompression | Gets and sets how loose to be when matching symbols and compressing text using either of the lossy text region encode modes.
Public Property | Luminance | Gets and sets the luminance quality setting for saving PDF files.
Public Property | MultiPage | Gets and sets whether the image is being saved to a multi-page file.
Public Property | Progressive | Gets and sets whether JPEG compressed PDF files are to be saved as standard files or progressive files.
Public Property | SubSampling | Gets and sets the subsampling type for saving JPEG compressed PDF files.
Public Property | SwapBlackAndWhite | Gets or sets a pixel value of zero to black or white.
Top

See Also

Reference

SaveOptionsPdf Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.TwainPro7.Net
SaveOptionsPdf Class Properties
See Also Send Feedback
Accusoft.TwainProSdk Namespace : SaveOptionsPdf Class

Glossary Item Box

For a list of all members of this type, see SaveOptionsPdf members.

Public Properties

 | Name | Description
Public Property | Chrominance | Gets and sets the chrominance quality setting for saving PDF files.
Public Property | Compression | Gets or sets the compression type employed for saving a PDF file.
Public Property | EncodeModeCompression | Specifies the encoding mode to use when creating a JBIG2 compressed file.
Public Property | FileOrganizationCompression | Gets and sets the file organization when saving a JBIG2 compressed file.
Public Property | InvertedRegion | Gets and sets whether the bits should be inverted prior to symbol analysis.
Public Property | LoosenessCompression | Gets and sets how loose to be when matching symbols and compressing text using either of the lossy text region encode modes.
Public Property | Luminance | Gets and sets the luminance quality setting for saving PDF files.
Public Property | MultiPage | Gets and sets whether the image is being saved to a multi-page file.
Public Property | Progressive | Gets and sets whether JPEG compressed PDF files are to be saved as standard files or progressive files.
Public Property | SubSampling | Gets and sets the subsampling type for saving JPEG compressed PDF files.
Public Property | SwapBlackAndWhite | Gets or sets a pixel value of zero to black or white.
Top

See Also

Reference

SaveOptionsPdf Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Chrominance Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > SaveOptionsPdf Class : Chrominance Property

Glossary Item Box

Gets and sets the chrominance quality setting for saving PDF files.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DefaultValueAttribute()>
<DescriptionAttribute("Specifies the chrominance quality setting for saving PDF files.")>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property Chrominance As Integer
'Usage

Dim instance As SaveOptionsPdf
Dim value As Integer

instance.Chrominance = value

value = instance.Chrominance
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the chrominance quality setting for saving PDF files.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public int Chrominance {get; set;}
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the chrominance quality setting for saving PDF files.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property int get_Chrominance();
public: __property void set_Chrominance(
   int value
);
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the chrominance quality setting for saving PDF files.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property int Chrominance {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the chrominance quality setting for saving PDF files.

Remarks

The default value is 10.

JPEG and ePIC images are stored in a compressed format. Compression is lossy which means when you save a JPEG or ePIC file, there will be data loss. Data loss is the result of JPEG and ePICs ability to achieve high compression ratios. Higher quality settings result in less compression, while lower quality settings result in higher compression. Quality versus compression is a tradeoff.

The image compression ratio can be adjusted by setting the Luminance and Chrominance properties. The Luminance property adjusts the luminance or gray scale quality and the Chrominance property adjusts the chrominance or color quality. Lower settings for these properties result in higher quality images with less compression. Higher settings for these properties result in lower quality images with more compression.

For general use photographic type images, setting Luminance = 24 and Chrominance = 30 provides about a 12:1 image compression ratio with minimal data loss. Compression ratios and perceived image quality will vary depending on the image.

See Also

Reference

SaveOptionsPdf Class
SaveOptionsPdf Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Compression Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > SaveOptionsPdf Class : Compression Property

Glossary Item Box

Gets or sets the compression type employed for saving a PDF file.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DescriptionAttribute("Gets or sets the compression type employed for saving a PDF file.")>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<DefaultValueAttribute()>
Public Property Compression As PdfCompression
'Usage

Dim instance As SaveOptionsPdf
Dim value As PdfCompression

instance.Compression = value

value = instance.Compression
[DescriptionAttribute("Gets or sets the compression type employed for saving a PDF file.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DefaultValueAttribute()]
public PdfCompression Compression {get; set;}
[DescriptionAttribute("Gets or sets the compression type employed for saving a PDF file.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DefaultValueAttribute()]
public: __property PdfCompression get_Compression();
public: __property void set_Compression(
   PdfCompression value
);
[DescriptionAttribute("Gets or sets the compression type employed for saving a PDF file.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DefaultValueAttribute()]
public:
property PdfCompression Compression {
   PdfCompression get();
   void set (    PdfCompression value);
}

Property Value

A PdfCompression value which determines the compression type for saving a PDF file.

Remarks

The default value is NoCompression.

See Also

Reference

SaveOptionsPdf Class
SaveOptionsPdf Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
EncodeModeCompression Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > SaveOptionsPdf Class : EncodeModeCompression Property

Glossary Item Box

Specifies the encoding mode to use when creating a JBIG2 compressed file.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<DefaultValueAttribute()>
<DescriptionAttribute("Specifies the encoding mode to use when creating a JBIG2 compressed file.")>
Public Property EncodeModeCompression As EncodeModeCompression
'Usage

Dim instance As SaveOptionsPdf
Dim value As EncodeModeCompression

instance.EncodeModeCompression = value

value = instance.EncodeModeCompression
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the encoding mode to use when creating a JBIG2 compressed file.")]
public EncodeModeCompression EncodeModeCompression {get; set;}
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the encoding mode to use when creating a JBIG2 compressed file.")]
public: __property EncodeModeCompression get_EncodeModeCompression();
public: __property void set_EncodeModeCompression(
   EncodeModeCompression value
);
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the encoding mode to use when creating a JBIG2 compressed file.")]
public:
property EncodeModeCompression EncodeModeCompression {
   EncodeModeCompression get();
   void set (    EncodeModeCompression value);
}

Property Value

The EncodeModeCompression value which determines the encoding mode to use when creating a JBIG2 compressed file.

Remarks

The default value is AutoDetect.

Text regions can be encoded as lossless or as lossy according to the encoding mode specified. The lossy modes use the value in SaveOptions.Pdf.LoosenessCompression to control how loose to be when matching symbols and thereby increase compression and reduce file size. Compression means loss, however, and a consequence of higher compression is an increased risk of errors in the reconstructed image.

Specify a larger value of looseness to reduce the compressed file size; use a smaller value to reduce the errors, if any. Halftone regions can be encoded lossy by specifying one of the lossy halftone encoding modes. Alternatively, they can be encoded lossless by using the lossless generic encoding mode.

See Also

Reference

SaveOptionsPdf Class
SaveOptionsPdf Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
FileOrganizationCompression Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > SaveOptionsPdf Class : FileOrganizationCompression Property

Glossary Item Box

Gets and sets the file organization when saving a JBIG2 compressed file.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DefaultValueAttribute()>
<DescriptionAttribute("Specifies the file organization when saving a JBIG2 compressed file.")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
Public Property FileOrganizationCompression As FileOrganizationCompression
'Usage

Dim instance As SaveOptionsPdf
Dim value As FileOrganizationCompression

instance.FileOrganizationCompression = value

value = instance.FileOrganizationCompression
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the file organization when saving a JBIG2 compressed file.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public FileOrganizationCompression FileOrganizationCompression {get; set;}
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the file organization when saving a JBIG2 compressed file.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public: __property FileOrganizationCompression get_FileOrganizationCompression();
public: __property void set_FileOrganizationCompression(
   FileOrganizationCompression value
);
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the file organization when saving a JBIG2 compressed file.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public:
property FileOrganizationCompression FileOrganizationCompression {
   FileOrganizationCompression get();
   void set (    FileOrganizationCompression value);
}

Property Value

A FileOrganizationCompression value which determines the file organization when saving a JBIG2 compressed file.

Remarks

A JBIG2 compressed file may be organized in two ways: sequential or random access. Sequential organization is intended for streaming applications, where the decoder reads and decodes the file in order as the data is received. Random access organization permits the decoder to know the entire file structure, without having to read the entire file, and then uses that information to access the required data in a random-access fashion. This organization is useful for applications such as decoding only odd-number pages.

The default value is Default.

See Also

Reference

SaveOptionsPdf Class
SaveOptionsPdf Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
InvertedRegion Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > SaveOptionsPdf Class : InvertedRegion Property

Glossary Item Box

Gets and sets whether the bits should be inverted prior to symbol analysis.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DescriptionAttribute("Specifies whether the bits should be inverted prior to symbol analysis.")>
<DefaultValueAttribute()>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property InvertedRegion As Boolean
'Usage

Dim instance As SaveOptionsPdf
Dim value As Boolean

instance.InvertedRegion = value

value = instance.InvertedRegion
[DescriptionAttribute("Specifies whether the bits should be inverted prior to symbol analysis.")]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public bool InvertedRegion {get; set;}
[DescriptionAttribute("Specifies whether the bits should be inverted prior to symbol analysis.")]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property bool get_InvertedRegion();
public: __property void set_InvertedRegion(
   bool value
);
[DescriptionAttribute("Specifies whether the bits should be inverted prior to symbol analysis.")]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property bool InvertedRegion {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true to invert the bits prior to symbol analysis. Otherwise, false should be used.

Remarks

The default value is false.

Inverting the bits prior to symbol analysis may provide better compression if the text is represented as light bits against a dark background instead of the opposite. This setting is only used by the text encode modes.

See Also

Reference

SaveOptionsPdf Class
SaveOptionsPdf Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
LoosenessCompression Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > SaveOptionsPdf Class : LoosenessCompression Property

Glossary Item Box

Gets and sets how loose to be when matching symbols and compressing text using either of the lossy text region encode modes.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DescriptionAttribute("Specifies how loose to be when matching symbols and compressing text using either of the lossy text region encode modes.")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<DefaultValueAttribute()>
Public Property LoosenessCompression As Integer
'Usage

Dim instance As SaveOptionsPdf
Dim value As Integer

instance.LoosenessCompression = value

value = instance.LoosenessCompression
[BrowsableAttribute(false)]
[DescriptionAttribute("Specifies how loose to be when matching symbols and compressing text using either of the lossy text region encode modes.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DefaultValueAttribute()]
public int LoosenessCompression {get; set;}
[BrowsableAttribute(false)]
[DescriptionAttribute("Specifies how loose to be when matching symbols and compressing text using either of the lossy text region encode modes.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DefaultValueAttribute()]
public: __property int get_LoosenessCompression();
public: __property void set_LoosenessCompression(
   int value
);
[BrowsableAttribute(false)]
[DescriptionAttribute("Specifies how loose to be when matching symbols and compressing text using either of the lossy text region encode modes.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DefaultValueAttribute()]
public:
property int LoosenessCompression {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents how loose to be when matching symbols and compressing text.

Remarks

The default value is 0.

The default results in the lossless compression.

The LoosenessCompression property provides the ability to set how loose to be when matching symbols and compressing text using either of the lossy text region encoding modes. The larger the number, the greater the compression and the greater the risk of introducing errors.

Set to 50 for a reasonably small file size and low risk of error.

If set to 0, the compression is lossless.

See Also

Reference

SaveOptionsPdf Class
SaveOptionsPdf Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Luminance Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > SaveOptionsPdf Class : Luminance Property

Glossary Item Box

Gets and sets the luminance quality setting for saving PDF files.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DescriptionAttribute("Specifies the luminance quality setting for saving PDF files.")>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<DefaultValueAttribute()>
Public Property Luminance As Integer
'Usage

Dim instance As SaveOptionsPdf
Dim value As Integer

instance.Luminance = value

value = instance.Luminance
[DescriptionAttribute("Specifies the luminance quality setting for saving PDF files.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DefaultValueAttribute()]
public int Luminance {get; set;}
[DescriptionAttribute("Specifies the luminance quality setting for saving PDF files.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DefaultValueAttribute()]
public: __property int get_Luminance();
public: __property void set_Luminance(
   int value
);
[DescriptionAttribute("Specifies the luminance quality setting for saving PDF files.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DefaultValueAttribute()]
public:
property int Luminance {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the luminance quality setting for saving PDF files.

Remarks

The default value is 10.

JPEG and ePIC images are stored in a compressed format. Compression is lossy which means when you save a JPEG or ePIC file, there will be data loss. Data loss is the result of JPEG and ePICs ability to achieve high compression ratios. Higher quality settings result in less compression, while lower quality settings result in higher compression. Quality versus compression is a trade off.

The image compression ratio can be adjusted by setting the Luminance and Chrominance properties. The Luminance property adjusts the luminance or gray scale quality and the Chrominance property adjusts the chrominance or color quality. Lower settings for these properties result in higher quality images with less compression. Higher settings for these properties result in lower quality images with more compression.

For general use photographic type images, setting Luminance = 24 and Chrominance = 30 provides about a 12:1 image compression ratio with minimal data loss. Compression ratios and perceived image quality will vary depending on the image.

See Also

Reference

SaveOptionsPdf Class
SaveOptionsPdf Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
MultiPage Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > SaveOptionsPdf Class : MultiPage Property

Glossary Item Box

Gets and sets whether the image is being saved to a multi-page file.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DescriptionAttribute("Specifies whether the image is being saved to a multi-page file.")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<DefaultValueAttribute()>
Public Property MultiPage As Boolean
'Usage

Dim instance As SaveOptionsPdf
Dim value As Boolean

instance.MultiPage = value

value = instance.MultiPage
[BrowsableAttribute(false)]
[DescriptionAttribute("Specifies whether the image is being saved to a multi-page file.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DefaultValueAttribute()]
public bool MultiPage {get; set;}
[BrowsableAttribute(false)]
[DescriptionAttribute("Specifies whether the image is being saved to a multi-page file.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DefaultValueAttribute()]
public: __property bool get_MultiPage();
public: __property void set_MultiPage(
   bool value
);
[BrowsableAttribute(false)]
[DescriptionAttribute("Specifies whether the image is being saved to a multi-page file.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DefaultValueAttribute()]
public:
property bool MultiPage {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true to save the image as a multi-page file. Otherwise, false is used and the file is not saved as multi-page.

Remarks

The default value is false.

See Also

Reference

SaveOptionsPdf Class
SaveOptionsPdf Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Progressive Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > SaveOptionsPdf Class : Progressive Property

Glossary Item Box

Gets and sets whether JPEG compressed PDF files are to be saved as standard files or progressive files.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DescriptionAttribute("Specifies whether JPEG compressed PDF files are to be saved as standard files or progressive files.")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<DefaultValueAttribute()>
Public Property Progressive As Boolean
'Usage

Dim instance As SaveOptionsPdf
Dim value As Boolean

instance.Progressive = value

value = instance.Progressive
[BrowsableAttribute(false)]
[DescriptionAttribute("Specifies whether JPEG compressed PDF files are to be saved as standard files or progressive files.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DefaultValueAttribute()]
public bool Progressive {get; set;}
[BrowsableAttribute(false)]
[DescriptionAttribute("Specifies whether JPEG compressed PDF files are to be saved as standard files or progressive files.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DefaultValueAttribute()]
public: __property bool get_Progressive();
public: __property void set_Progressive(
   bool value
);
[BrowsableAttribute(false)]
[DescriptionAttribute("Specifies whether JPEG compressed PDF files are to be saved as standard files or progressive files.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DefaultValueAttribute()]
public:
property bool Progressive {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true to save as standard files. Otherwise, false should be used to save as progressive.

Remarks

The default value is false.

See Also

Reference

SaveOptionsPdf Class
SaveOptionsPdf Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
SubSampling Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > SaveOptionsPdf Class : SubSampling Property

Glossary Item Box

Gets and sets the subsampling type for saving JPEG compressed PDF files.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<DefaultValueAttribute()>
<DescriptionAttribute("Specifies the subsampling type for saving JPEG compressed PDF files.")>
<BrowsableAttribute(False)>
Public Property SubSampling As SubSampling
'Usage

Dim instance As SaveOptionsPdf
Dim value As SubSampling

instance.SubSampling = value

value = instance.SubSampling
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the subsampling type for saving JPEG compressed PDF files.")]
[BrowsableAttribute(false)]
public SubSampling SubSampling {get; set;}
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the subsampling type for saving JPEG compressed PDF files.")]
[BrowsableAttribute(false)]
public: __property SubSampling get_SubSampling();
public: __property void set_SubSampling(
   SubSampling value
);
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the subsampling type for saving JPEG compressed PDF files.")]
[BrowsableAttribute(false)]
public:
property SubSampling SubSampling {
   SubSampling get();
   void set (    SubSampling value);
}

Property Value

A SubSampling value which represents the type for saving JPEG compressed PDF files.

Remarks

The default value is SubSampling411.

SS_111 provides the highest image quality with lower compression and SS_411 provides the best compression with lower image quality.

See Also

Reference

SaveOptionsPdf Class
SaveOptionsPdf Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
SwapBlackAndWhite Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > SaveOptionsPdf Class : SwapBlackAndWhite Property

Glossary Item Box

Gets or sets a pixel value of zero to black or white.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
<DescriptionAttribute("Gets or sets a pixel value of zero to black or white.")>
<DefaultValueAttribute()>
Public Property SwapBlackAndWhite As Boolean
'Usage

Dim instance As SaveOptionsPdf
Dim value As Boolean

instance.SwapBlackAndWhite = value

value = instance.SwapBlackAndWhite
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
[DescriptionAttribute("Gets or sets a pixel value of zero to black or white.")]
[DefaultValueAttribute()]
public bool SwapBlackAndWhite {get; set;}
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
[DescriptionAttribute("Gets or sets a pixel value of zero to black or white.")]
[DefaultValueAttribute()]
public: __property bool get_SwapBlackAndWhite();
public: __property void set_SwapBlackAndWhite(
   bool value
);
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
[DescriptionAttribute("Gets or sets a pixel value of zero to black or white.")]
[DefaultValueAttribute()]
public:
property bool SwapBlackAndWhite {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true when 1 = black and 0 = white. Otherwise, false is used and 1 = white and 0 = black.

Remarks

The default value is false.

When false, the standard definition of black and white are used in the saved image: 1 = white and 0 = black. When true, the definition of black and white are reversed in the saved image: 1 = black and 0 = white.

This property pertains only to G4 Compression types.

See Also

Reference

SaveOptionsPdf Class
SaveOptionsPdf Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
SaveOptionsPic Class
Members See Also Send Feedback
Accusoft.TwainProSdk Namespace : SaveOptionsPic Class

Glossary Item Box

This class implements objects for saving PIC options.

Object Model

SaveOptionsPic Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Class SaveOptionsPic
'Usage

Dim instance As SaveOptionsPic
public class SaveOptionsPic
public __gc class SaveOptionsPic
public ref class SaveOptionsPic

Inheritance Hierarchy

System.Object
Accusoft.TwainProSdk.SaveOptionsPic

See Also

Reference

SaveOptionsPic Members
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.TwainPro7.Net
SaveOptionsPic Class Members
See Also Properties Send Feedback
Accusoft.TwainProSdk Namespace : SaveOptionsPic Class

Glossary Item Box

The following tables list the members exposed by SaveOptionsPic.

Public Properties

 | Name | Description
Public Property | Chrominance | Gets and sets the chrominance quality setting for saving ePIC files.
Public Property | Luminance | Gets and sets the luminance quality setting for saving ePIC files.
Public Property | Password | Gets and sets the password for an Encrypted Pegasus Imaging Corporation (ePIC) file format.
Public Property | Progressive | Gets and sets if ePIC files are to be saved as standard files or progressive files.
Public Property | SubSampling | Gets and sets the subsampling type for saving ePIC files.
Top

See Also

Reference

SaveOptionsPic Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.TwainPro7.Net
SaveOptionsPic Class Properties
See Also Send Feedback
Accusoft.TwainProSdk Namespace : SaveOptionsPic Class

Glossary Item Box

For a list of all members of this type, see SaveOptionsPic members.

Public Properties

 | Name | Description
Public Property | Chrominance | Gets and sets the chrominance quality setting for saving ePIC files.
Public Property | Luminance | Gets and sets the luminance quality setting for saving ePIC files.
Public Property | Password | Gets and sets the password for an Encrypted Pegasus Imaging Corporation (ePIC) file format.
Public Property | Progressive | Gets and sets if ePIC files are to be saved as standard files or progressive files.
Public Property | SubSampling | Gets and sets the subsampling type for saving ePIC files.
Top

See Also

Reference

SaveOptionsPic Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Chrominance Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > SaveOptionsPic Class : Chrominance Property

Glossary Item Box

Gets and sets the chrominance quality setting for saving ePIC files.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DescriptionAttribute("Specifies the chrominance quality setting for saving ePIC files.")>
<DefaultValueAttribute()>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property Chrominance As Integer
'Usage

Dim instance As SaveOptionsPic
Dim value As Integer

instance.Chrominance = value

value = instance.Chrominance
[DescriptionAttribute("Specifies the chrominance quality setting for saving ePIC files.")]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public int Chrominance {get; set;}
[DescriptionAttribute("Specifies the chrominance quality setting for saving ePIC files.")]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property int get_Chrominance();
public: __property void set_Chrominance(
   int value
);
[DescriptionAttribute("Specifies the chrominance quality setting for saving ePIC files.")]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property int Chrominance {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the chrominance quality setting for saving ePIC files.

Remarks

The default value is 10.

JPEG and ePIC images are stored in a compressed format. Compression is lossy which means when you save a JPEG or ePIC file, there will be data loss. Data loss is the result of JPEG and ePICs ability to achieve high compression ratios. Higher quality settings result in less compression, while lower quality settings result in higher compression. Quality versus compression is a tradeoff.

The image compression ratio can be adjusted by setting the Luminance and Chrominance properties. The Luminance property adjusts the luminance or gray scale quality and the Chrominance property adjusts the chrominance or color quality. Lower settings for these properties result in higher quality images with less compression. Higher settings for these properties result in lower quality images with more compression.

For general use photographic type images, setting Luminance = 24 and Chrominance = 30 provides about a 12:1 image compression ratio with minimal data loss. Compression ratios and perceived image quality will vary depending on the image.

See Also

Reference

SaveOptionsPic Class
SaveOptionsPic Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Luminance Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > SaveOptionsPic Class : Luminance Property

Glossary Item Box

Gets and sets the luminance quality setting for saving ePIC files.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DescriptionAttribute("Specifies the luminance quality setting for saving ePIC files.")>
<DefaultValueAttribute()>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property Luminance As Integer
'Usage

Dim instance As SaveOptionsPic
Dim value As Integer

instance.Luminance = value

value = instance.Luminance
[DescriptionAttribute("Specifies the luminance quality setting for saving ePIC files.")]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public int Luminance {get; set;}
[DescriptionAttribute("Specifies the luminance quality setting for saving ePIC files.")]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property int get_Luminance();
public: __property void set_Luminance(
   int value
);
[DescriptionAttribute("Specifies the luminance quality setting for saving ePIC files.")]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property int Luminance {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the luminance quality setting for saving ePIC files.

Remarks

The default value is 10.

JPEG and ePIC images are stored in a compressed format. Compression is lossy which means when you save a JPEG or ePIC file, there will be data loss. Data loss is the result of JPEG and ePICs ability to achieve high compression ratios. Higher quality settings result in less compression, while lower quality settings result in higher compression. Quality versus compression is a tradeoff.

The image compression ratio can be adjusted by setting the Luminance and Chrominance properties. The Luminance property adjusts the luminance or gray scale quality and the Chrominance property adjusts the chrominance or color quality. Lower settings for these properties result in higher quality images with less compression. Higher settings for these properties result in lower quality images with more compression.

For general use photographic type images, setting Luminance = 24 and Chrominance = 30 provides about a 12:1 image compression ratio with minimal data loss. Compression ratios and perceived image quality will vary depending on the image.

See Also

Reference

SaveOptionsPic Class
SaveOptionsPic Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Password Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > SaveOptionsPic Class : Password Property

Glossary Item Box

Gets and sets the password for an Encrypted Pegasus Imaging Corporation (ePIC) file format.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DefaultValueAttribute()>
<DescriptionAttribute("Gets or sets the password for an Encrypted Pegasus Imaging Corporation (ePIC) file format.")>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property Password As String
'Usage

Dim instance As SaveOptionsPic
Dim value As String

instance.Password = value

value = instance.Password
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the password for an Encrypted Pegasus Imaging Corporation (ePIC) file format.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public string Password {get; set;}
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the password for an Encrypted Pegasus Imaging Corporation (ePIC) file format.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property string* get_Password();
public: __property void set_Password(
   string* value
);
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the password for an Encrypted Pegasus Imaging Corporation (ePIC) file format.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property String^ Password {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value which represents the password.

Remarks

The default value is an empty string "".

See Also

Reference

SaveOptionsPic Class
SaveOptionsPic Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Progressive Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > SaveOptionsPic Class : Progressive Property

Glossary Item Box

Gets and sets if ePIC files are to be saved as standard files or progressive files.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<DefaultValueAttribute()>
<DescriptionAttribute("Specifies whether ePIC files are to be saved as standard files or progressive files.")>
<BrowsableAttribute(False)>
Public Property Progressive As Boolean
'Usage

Dim instance As SaveOptionsPic
Dim value As Boolean

instance.Progressive = value

value = instance.Progressive
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies whether ePIC files are to be saved as standard files or progressive files.")]
[BrowsableAttribute(false)]
public bool Progressive {get; set;}
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies whether ePIC files are to be saved as standard files or progressive files.")]
[BrowsableAttribute(false)]
public: __property bool get_Progressive();
public: __property void set_Progressive(
   bool value
);
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies whether ePIC files are to be saved as standard files or progressive files.")]
[BrowsableAttribute(false)]
public:
property bool Progressive {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true to save as standard files. Otherwise, false should be used to save as progressive.

Remarks

The default value is false.

See Also

Reference

SaveOptionsPic Class
SaveOptionsPic Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
SubSampling Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > SaveOptionsPic Class : SubSampling Property

Glossary Item Box

Gets and sets the subsampling type for saving ePIC files.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DefaultValueAttribute()>
<DescriptionAttribute("Specifies the subsampling type for saving ePIC files.")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property SubSampling As SubSampling
'Usage

Dim instance As SaveOptionsPic
Dim value As SubSampling

instance.SubSampling = value

value = instance.SubSampling
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the subsampling type for saving ePIC files.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public SubSampling SubSampling {get; set;}
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the subsampling type for saving ePIC files.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property SubSampling get_SubSampling();
public: __property void set_SubSampling(
   SubSampling value
);
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies the subsampling type for saving ePIC files.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property SubSampling SubSampling {
   SubSampling get();
   void set (    SubSampling value);
}

Property Value

A SubSampling type for saving ePIC file.

Remarks

The default value is SubSampling.SubSampling411.

The SS_111 type of subsampling provides the highest image quality with lower compression and the SS_411 type provides the best compression with lower image quality.

See Also

Reference

SaveOptionsPic Class
SaveOptionsPic Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
SaveOptionsPng Class
Members See Also Send Feedback
Accusoft.TwainProSdk Namespace : SaveOptionsPng Class

Glossary Item Box

This class implements objects for saving Png options.

Object Model

SaveOptionsPng Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Class SaveOptionsPng
'Usage

Dim instance As SaveOptionsPng
public class SaveOptionsPng
public __gc class SaveOptionsPng
public ref class SaveOptionsPng

Inheritance Hierarchy

System.Object
Accusoft.TwainProSdk.SaveOptionsPng

See Also

Reference

SaveOptionsPng Members
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.TwainPro7.Net
SaveOptionsPng Class Members
See Also Properties Send Feedback
Accusoft.TwainProSdk Namespace : SaveOptionsPng Class

Glossary Item Box

The following tables list the members exposed by SaveOptionsPng.

Public Properties

 | Name | Description
Public Property | BackgroundColor | Gets and sets the color to be used to represent background in the stored image.
Public Property | Filter | Gets and sets the filter used for PNG compression.
Public Property | Interlaced | Gets and sets if the image is saved in an interlaced or non-interlaced format.
Public Property | SwapRedAndBlue | Gets and sets if there is a palette, Red and Blue pixels are swapped.
Public Property | TransparencyColor | Gets and sets the color to be used to represent transparency in the stored image.
Public Property | UseBackgroundColor | Gets and sets if the image is saved uses a background color.
Public Property | UseTransparencyColor | Gets and sets if the image saved uses a transparent color.
Top

See Also

Reference

SaveOptionsPng Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.TwainPro7.Net
SaveOptionsPng Class Properties
See Also Send Feedback
Accusoft.TwainProSdk Namespace : SaveOptionsPng Class

Glossary Item Box

For a list of all members of this type, see SaveOptionsPng members.

Public Properties

 | Name | Description
Public Property | BackgroundColor | Gets and sets the color to be used to represent background in the stored image.
Public Property | Filter | Gets and sets the filter used for PNG compression.
Public Property | Interlaced | Gets and sets if the image is saved in an interlaced or non-interlaced format.
Public Property | SwapRedAndBlue | Gets and sets if there is a palette, Red and Blue pixels are swapped.
Public Property | TransparencyColor | Gets and sets the color to be used to represent transparency in the stored image.
Public Property | UseBackgroundColor | Gets and sets if the image is saved uses a background color.
Public Property | UseTransparencyColor | Gets and sets if the image saved uses a transparent color.
Top

See Also

Reference

SaveOptionsPng Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
BackgroundColor Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > SaveOptionsPng Class : BackgroundColor Property

Glossary Item Box

Gets and sets the color to be used to represent background in the stored image.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DescriptionAttribute("Specifies the backgroundColor color for the image.")>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<DefaultValueAttribute()>
Public Property BackgroundColor As Color
'Usage

Dim instance As SaveOptionsPng
Dim value As Color

instance.BackgroundColor = value

value = instance.BackgroundColor
[DescriptionAttribute("Specifies the backgroundColor color for the image.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DefaultValueAttribute()]
public Color BackgroundColor {get; set;}
[DescriptionAttribute("Specifies the backgroundColor color for the image.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DefaultValueAttribute()]
public: __property Color get_BackgroundColor();
public: __property void set_BackgroundColor(
   Color value
);
[DescriptionAttribute("Specifies the backgroundColor color for the image.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DefaultValueAttribute()]
public:
property Color BackgroundColor {
   Color get();
   void set (    Color value);
}

Property Value

A System.Drawing.Color value which represents what the background in the image.

See Also

Reference

SaveOptionsPng Class
SaveOptionsPng Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Filter Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > SaveOptionsPng Class : Filter Property

Glossary Item Box

Gets and sets the filter used for PNG compression.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<DescriptionAttribute("Specifies the filter used for PNG compression.")>
<BrowsableAttribute(False)>
<DefaultValueAttribute()>
Public Property Filter As Filter
'Usage

Dim instance As SaveOptionsPng
Dim value As Filter

instance.Filter = value

value = instance.Filter
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DescriptionAttribute("Specifies the filter used for PNG compression.")]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
public Filter Filter {get; set;}
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DescriptionAttribute("Specifies the filter used for PNG compression.")]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
public: __property Filter get_Filter();
public: __property void set_Filter(
   Filter value
);
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DescriptionAttribute("Specifies the filter used for PNG compression.")]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
public:
property Filter Filter {
   Filter get();
   void set (    Filter value);
}

See Also

Reference

SaveOptionsPng Class
SaveOptionsPng Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Interlaced Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > SaveOptionsPng Class : Interlaced Property

Glossary Item Box

Gets and sets if the image is saved in an interlaced or non-interlaced format.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DescriptionAttribute("Specifies if the image is saved as interlaced or not.")>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<DefaultValueAttribute()>
Public Property Interlaced As Boolean
'Usage

Dim instance As SaveOptionsPng
Dim value As Boolean

instance.Interlaced = value

value = instance.Interlaced
[DescriptionAttribute("Specifies if the image is saved as interlaced or not.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DefaultValueAttribute()]
public bool Interlaced {get; set;}
[DescriptionAttribute("Specifies if the image is saved as interlaced or not.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DefaultValueAttribute()]
public: __property bool get_Interlaced();
public: __property void set_Interlaced(
   bool value
);
[DescriptionAttribute("Specifies if the image is saved as interlaced or not.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DefaultValueAttribute()]
public:
property bool Interlaced {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true to save the image in an interlaced format. Otherwise, false is used.

See Also

Reference

SaveOptionsPng Class
SaveOptionsPng Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
SwapRedAndBlue Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > SaveOptionsPng Class : SwapRedAndBlue Property

Glossary Item Box

Gets and sets if there is a palette, Red and Blue pixels are swapped.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<DescriptionAttribute("Specifies if the image's Red and Blue pixels are swapped.")>
<BrowsableAttribute(False)>
<DefaultValueAttribute()>
Public Property SwapRedAndBlue As Boolean
'Usage

Dim instance As SaveOptionsPng
Dim value As Boolean

instance.SwapRedAndBlue = value

value = instance.SwapRedAndBlue
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DescriptionAttribute("Specifies if the image's Red and Blue pixels are swapped.")]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
public bool SwapRedAndBlue {get; set;}
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DescriptionAttribute("Specifies if the image's Red and Blue pixels are swapped.")]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
public: __property bool get_SwapRedAndBlue();
public: __property void set_SwapRedAndBlue(
   bool value
);
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DescriptionAttribute("Specifies if the image's Red and Blue pixels are swapped.")]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
public:
property bool SwapRedAndBlue {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true to swap Red and Blue pixels. Otherwise, the values aren't swapped.

See Also

Reference

SaveOptionsPng Class
SaveOptionsPng Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
TransparencyColor Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > SaveOptionsPng Class : TransparencyColor Property

Glossary Item Box

Gets and sets the color to be used to represent transparency in the stored image.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DescriptionAttribute("Specifies the transparency color for the image.")>
<DefaultValueAttribute()>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property TransparencyColor As Color
'Usage

Dim instance As SaveOptionsPng
Dim value As Color

instance.TransparencyColor = value

value = instance.TransparencyColor
[DescriptionAttribute("Specifies the transparency color for the image.")]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public Color TransparencyColor {get; set;}
[DescriptionAttribute("Specifies the transparency color for the image.")]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property Color get_TransparencyColor();
public: __property void set_TransparencyColor(
   Color value
);
[DescriptionAttribute("Specifies the transparency color for the image.")]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property Color TransparencyColor {
   Color get();
   void set (    Color value);
}

Property Value

A System.Drawing.Color value which represents what the transparency in the image.

See Also

Reference

SaveOptionsPng Class
SaveOptionsPng Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
UseBackgroundColor Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > SaveOptionsPng Class : UseBackgroundColor Property

Glossary Item Box

Gets and sets if the image is saved uses a background color.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DefaultValueAttribute()>
<DescriptionAttribute("Specifies if the image is saved with a background color.")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property UseBackgroundColor As Boolean
'Usage

Dim instance As SaveOptionsPng
Dim value As Boolean

instance.UseBackgroundColor = value

value = instance.UseBackgroundColor
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies if the image is saved with a background color.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public bool UseBackgroundColor {get; set;}
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies if the image is saved with a background color.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property bool get_UseBackgroundColor();
public: __property void set_UseBackgroundColor(
   bool value
);
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies if the image is saved with a background color.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property bool UseBackgroundColor {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true to save the image with a background color specified by setting the BackgroundColor property. Otherwise, false is used.

See Also

Reference

SaveOptionsPng Class
SaveOptionsPng Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
UseTransparencyColor Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > SaveOptionsPng Class : UseTransparencyColor Property

Glossary Item Box

Gets and sets if the image saved uses a transparent color.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DefaultValueAttribute()>
<DescriptionAttribute("Specifies if the image is saved with a transparency color or not.")>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property UseTransparencyColor As Boolean
'Usage

Dim instance As SaveOptionsPng
Dim value As Boolean

instance.UseTransparencyColor = value

value = instance.UseTransparencyColor
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies if the image is saved with a transparency color or not.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public bool UseTransparencyColor {get; set;}
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies if the image is saved with a transparency color or not.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property bool get_UseTransparencyColor();
public: __property void set_UseTransparencyColor(
   bool value
);
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies if the image is saved with a transparency color or not.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property bool UseTransparencyColor {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true to save the image with a transparency color specified by setting the TransparencyColor property. Otherwise, false is used.

See Also

Reference

SaveOptionsPng Class
SaveOptionsPng Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
SaveOptionsTiff Class
Members See Also Send Feedback
Accusoft.TwainProSdk Namespace : SaveOptionsTiff Class

Glossary Item Box

Implements SaveOptions for the TIFF file format.

Object Model

SaveOptionsTiff Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Class SaveOptionsTiff
'Usage

Dim instance As SaveOptionsTiff
public class SaveOptionsTiff
public __gc class SaveOptionsTiff
public ref class SaveOptionsTiff

Remarks

Writes necessary TIFF specific file information.

Inheritance Hierarchy

System.Object
Accusoft.TwainProSdk.SaveOptionsTiff

See Also

Reference

SaveOptionsTiff Members
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.TwainPro7.Net
SaveOptionsTiff Class Members
See Also Properties Send Feedback
Accusoft.TwainProSdk Namespace : SaveOptionsTiff Class

Glossary Item Box

The following tables list the members exposed by SaveOptionsTiff.

Public Properties

 | Name | Description
Public Property | Compression | Gets and sets the compression type employed for saving a TIFF file.
Public Property | IFDOffset | Gets and sets the location to append the next TIFF page when fast saving of multi-page TIFF files is invoked.
Public Property | JpegChrominance | Gets and sets the chrominance quality setting when using a JPEG compression type.
Public Property | JpegLuminance | Gets and sets the luminance quality setting when using a JPEG compression type.
Public Property | JpegSubSampling | Gets and sets the subsampling type when using a JPEG compression type.
Public Property | MultiPage | Gets and sets if the image is being saved to a multi-page file.
Public Property | UseIFDOffset | Gets and sets an indicator to enable fast multi-page TIFF writes.
Top

See Also

Reference

SaveOptionsTiff Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.TwainPro7.Net
SaveOptionsTiff Class Properties
See Also Send Feedback
Accusoft.TwainProSdk Namespace : SaveOptionsTiff Class

Glossary Item Box

For a list of all members of this type, see SaveOptionsTiff members.

Public Properties

 | Name | Description
Public Property | Compression | Gets and sets the compression type employed for saving a TIFF file.
Public Property | IFDOffset | Gets and sets the location to append the next TIFF page when fast saving of multi-page TIFF files is invoked.
Public Property | JpegChrominance | Gets and sets the chrominance quality setting when using a JPEG compression type.
Public Property | JpegLuminance | Gets and sets the luminance quality setting when using a JPEG compression type.
Public Property | JpegSubSampling | Gets and sets the subsampling type when using a JPEG compression type.
Public Property | MultiPage | Gets and sets if the image is being saved to a multi-page file.
Public Property | UseIFDOffset | Gets and sets an indicator to enable fast multi-page TIFF writes.
Top

See Also

Reference

SaveOptionsTiff Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Compression Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > SaveOptionsTiff Class : Compression Property

Glossary Item Box

Gets and sets the compression type employed for saving a TIFF file.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
<DescriptionAttribute("Gets or sets the compression type employed for saving a TIFF file.")>
<DefaultValueAttribute()>
Public Property Compression As TiffCompression
'Usage

Dim instance As SaveOptionsTiff
Dim value As TiffCompression

instance.Compression = value

value = instance.Compression
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
[DescriptionAttribute("Gets or sets the compression type employed for saving a TIFF file.")]
[DefaultValueAttribute()]
public TiffCompression Compression {get; set;}
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
[DescriptionAttribute("Gets or sets the compression type employed for saving a TIFF file.")]
[DefaultValueAttribute()]
public: __property TiffCompression get_Compression();
public: __property void set_Compression(
   TiffCompression value
);
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
[DescriptionAttribute("Gets or sets the compression type employed for saving a TIFF file.")]
[DefaultValueAttribute()]
public:
property TiffCompression Compression {
   TiffCompression get();
   void set (    TiffCompression value);
}

Property Value

A TiffCompression enumeration value which determines the compression type for saving a TIFF file.

Remarks

The default value is TiffCompression.NoCompression.

See Also

Reference

SaveOptionsTiff Class
SaveOptionsTiff Members
TiffCompression Enumeration


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
IFDOffset Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > SaveOptionsTiff Class : IFDOffset Property

Glossary Item Box

Gets and sets the location to append the next TIFF page when fast saving of multi-page TIFF files is invoked.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DefaultValueAttribute()>
<DescriptionAttribute("Location to append the next tiff page when fast saving of multi-page tiff files is invoked.")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
Public Property IFDOffset As Integer
'Usage

Dim instance As SaveOptionsTiff
Dim value As Integer

instance.IFDOffset = value

value = instance.IFDOffset
[DefaultValueAttribute()]
[DescriptionAttribute("Location to append the next tiff page when fast saving of multi-page tiff files is invoked.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public int IFDOffset {get; set;}
[DefaultValueAttribute()]
[DescriptionAttribute("Location to append the next tiff page when fast saving of multi-page tiff files is invoked.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public: __property int get_IFDOffset();
public: __property void set_IFDOffset(
   int value
);
[DefaultValueAttribute()]
[DescriptionAttribute("Location to append the next tiff page when fast saving of multi-page tiff files is invoked.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public:
property int IFDOffset {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the location to append the next TIFF page when fast saving of multi-page TIFF files is invoked.

Remarks

The default value is 0.

See Also

Reference

SaveOptionsTiff Class
SaveOptionsTiff Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
JpegChrominance Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > SaveOptionsTiff Class : JpegChrominance Property

Glossary Item Box

Gets and sets the chrominance quality setting when using a JPEG compression type.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DescriptionAttribute("Specifies the chrominance quality setting when using a JPEG compression type.")>
<DefaultValueAttribute()>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property JpegChrominance As Integer
'Usage

Dim instance As SaveOptionsTiff
Dim value As Integer

instance.JpegChrominance = value

value = instance.JpegChrominance
[DescriptionAttribute("Specifies the chrominance quality setting when using a JPEG compression type.")]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public int JpegChrominance {get; set;}
[DescriptionAttribute("Specifies the chrominance quality setting when using a JPEG compression type.")]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property int get_JpegChrominance();
public: __property void set_JpegChrominance(
   int value
);
[DescriptionAttribute("Specifies the chrominance quality setting when using a JPEG compression type.")]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property int JpegChrominance {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the chrominance quality setting when using a JPEG compression type.

Remarks

The default value is 10. It should be within the range of 0 to 255.

JPEG compression is lossy which means there will be data loss. Data loss is the result of JPEG's ability to achieve high compression ratios. Higher quality settings result in less compression, while lower quality settings result in higher compression. Quality versus compression is a tradeoff.

The image compression ratio can be adjusted by setting the Luminance and Chrominance properties. The Luminance property adjusts the luminance or gray scale quality and the Chrominance property adjusts the chrominance or color quality. Lower settings for these properties result in higher quality images with less compression. Higher settings for these properties result in lower quality images with more compression.

For general use photographic type images, setting Luminance = 24 and Chrominance = 30 provides about a 12:1 image compression ratio with minimal data loss. Compression ratios and perceived image quality will vary depending on the image.

See Also

Reference

SaveOptionsTiff Class
SaveOptionsTiff Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
JpegLuminance Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > SaveOptionsTiff Class : JpegLuminance Property

Glossary Item Box

Gets and sets the luminance quality setting when using a JPEG compression type.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DescriptionAttribute("Specifies the luminance quality setting when using a JPEG compression type.")>
<BrowsableAttribute(False)>
<DefaultValueAttribute()>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property JpegLuminance As Integer
'Usage

Dim instance As SaveOptionsTiff
Dim value As Integer

instance.JpegLuminance = value

value = instance.JpegLuminance
[DescriptionAttribute("Specifies the luminance quality setting when using a JPEG compression type.")]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public int JpegLuminance {get; set;}
[DescriptionAttribute("Specifies the luminance quality setting when using a JPEG compression type.")]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property int get_JpegLuminance();
public: __property void set_JpegLuminance(
   int value
);
[DescriptionAttribute("Specifies the luminance quality setting when using a JPEG compression type.")]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property int JpegLuminance {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the luminance quality setting when using a JPEG compression type.

Remarks

The default value is 10. It should be within the range of 0 to 255.

JPEG Compression is lossy which means there will be data loss. Data loss is the result of JPEG's ability to achieve high compression ratios. Higher quality settings result in less compression, while lower quality settings result in higher compression. Quality versus compression is a tradeoff.

The image compression ratio can be adjusted by setting the Luminance and Chrominance properties. The Luminance property adjusts the luminance or gray scale quality and the Chrominance property adjusts the chrominance or color quality. Lower settings for these properties result in higher quality images with less compression. Higher settings for these properties result in lower quality images with more compression.

For general use photographic type images, setting Luminance = 24 and Chrominance = 30 provides about a 12:1 image compression ratio with minimal data loss. Compression ratios and perceived image quality will vary depending on the image.

See Also

Reference

SaveOptionsTiff Class
SaveOptionsTiff Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
JpegSubSampling Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > SaveOptionsTiff Class : JpegSubSampling Property

Glossary Item Box

Gets and sets the subsampling type when using a JPEG compression type.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DescriptionAttribute("Specifies the subsampling type for saving JPEG files.")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<DefaultValueAttribute()>
Public Property JpegSubSampling As SubSampling
'Usage

Dim instance As SaveOptionsTiff
Dim value As SubSampling

instance.JpegSubSampling = value

value = instance.JpegSubSampling
[BrowsableAttribute(false)]
[DescriptionAttribute("Specifies the subsampling type for saving JPEG files.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DefaultValueAttribute()]
public SubSampling JpegSubSampling {get; set;}
[BrowsableAttribute(false)]
[DescriptionAttribute("Specifies the subsampling type for saving JPEG files.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DefaultValueAttribute()]
public: __property SubSampling get_JpegSubSampling();
public: __property void set_JpegSubSampling(
   SubSampling value
);
[BrowsableAttribute(false)]
[DescriptionAttribute("Specifies the subsampling type for saving JPEG files.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DefaultValueAttribute()]
public:
property SubSampling JpegSubSampling {
   SubSampling get();
   void set (    SubSampling value);
}

Property Value

A SubSampling type to use with the JPEG compression.

Remarks

The default value: is SubSampling411

SS_111 provides the highest image quality with lower compression and SS_411 provides the best compression with lower image quality.

See Also

Reference

SaveOptionsTiff Class
SaveOptionsTiff Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
MultiPage Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > SaveOptionsTiff Class : MultiPage Property

Glossary Item Box

Gets and sets if the image is being saved to a multi-page file.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DescriptionAttribute("Specifies whether the image is being saved to a multi-page file.")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<DefaultValueAttribute()>
Public Property MultiPage As Boolean
'Usage

Dim instance As SaveOptionsTiff
Dim value As Boolean

instance.MultiPage = value

value = instance.MultiPage
[BrowsableAttribute(false)]
[DescriptionAttribute("Specifies whether the image is being saved to a multi-page file.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DefaultValueAttribute()]
public bool MultiPage {get; set;}
[BrowsableAttribute(false)]
[DescriptionAttribute("Specifies whether the image is being saved to a multi-page file.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DefaultValueAttribute()]
public: __property bool get_MultiPage();
public: __property void set_MultiPage(
   bool value
);
[BrowsableAttribute(false)]
[DescriptionAttribute("Specifies whether the image is being saved to a multi-page file.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DefaultValueAttribute()]
public:
property bool MultiPage {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true to save as a multi-page file. Otherwise, false is used.

Remarks

The default value is false.

Note: When this property is set to true and an FTP or HTTP address location is specified in the ScannedImage.SaveFile filename parameter, a multi-page file will not be created as this property only supports saving to local files.

See Also

Reference

SaveOptionsTiff Class
SaveOptionsTiff Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
UseIFDOffset Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > SaveOptionsTiff Class : UseIFDOffset Property

Glossary Item Box

Gets and sets an indicator to enable fast multi-page TIFF writes.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<DefaultValueAttribute()>
<DescriptionAttribute("Enables or disables fast multi-page TIFF writes.")>
Public Property UseIFDOffset As Boolean
'Usage

Dim instance As SaveOptionsTiff
Dim value As Boolean

instance.UseIFDOffset = value

value = instance.UseIFDOffset
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DefaultValueAttribute()]
[DescriptionAttribute("Enables or disables fast multi-page TIFF writes.")]
public bool UseIFDOffset {get; set;}
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DefaultValueAttribute()]
[DescriptionAttribute("Enables or disables fast multi-page TIFF writes.")]
public: __property bool get_UseIFDOffset();
public: __property void set_UseIFDOffset(
   bool value
);
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DefaultValueAttribute()]
[DescriptionAttribute("Enables or disables fast multi-page TIFF writes.")]
public:
property bool UseIFDOffset {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true to enable fast multi-page TIFF writes. Otherwise, false is used.

Remarks

The default value is false.

See Also

Reference

SaveOptionsTiff Class
SaveOptionsTiff Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
ScannedEventArgs Class
Members See Also Send Feedback
Accusoft.TwainProSdk Namespace : ScannedEventArgs Class

Glossary Item Box

Arguments for a scanned event.

Object Model

ScannedEventArgs ClassScannedImage ClassExtendedImageInfoContainer ClassExtendedImageInfoContainerValueCollection ClassExtendedImageInfoContainerValue ClassScannedImageData Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Class ScannedEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As ScannedEventArgs
public class ScannedEventArgs : System.EventArgs
public __gc class ScannedEventArgs : public System.EventArgs
public ref class ScannedEventArgs : public System.EventArgs

Remarks

This class provides the communication between the object that issued a scanned event and the object that handles the event.

Inheritance Hierarchy

System.Object
System.EventArgs
Accusoft.TwainProSdk.ScannedEventArgs

See Also

Reference

ScannedEventArgs Members
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.TwainPro7.Net
ScannedEventArgs Class Members
See Also Properties Send Feedback
Accusoft.TwainProSdk Namespace : ScannedEventArgs Class

Glossary Item Box

The following tables list the members exposed by ScannedEventArgs.

Public Constructors

 | Name | Description
Public Constructor | ScannedEventArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | Cancel | Gets and sets a cancel on the session. If set to true, the session ends and the StartSession method returns control.
Public Property | PendingTransfers | Gets the number of image transfers the TWAIN Data Source is ready to supply to the TwainPRO control.
Public Property | ScannedImage | Gets and sets the scanned image and image information.
Top

See Also

Reference

ScannedEventArgs Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
ScannedEventArgs Constructor
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ScannedEventArgs Class : ScannedEventArgs Constructor

Glossary Item Box

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ScannedEventArgs()
public ScannedEventArgs()
public: ScannedEventArgs();
public:
ScannedEventArgs();

See Also

Reference

ScannedEventArgs Class
ScannedEventArgs Members


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.TwainPro7.Net
ScannedEventArgs Class Properties
See Also Send Feedback
Accusoft.TwainProSdk Namespace : ScannedEventArgs Class

Glossary Item Box

For a list of all members of this type, see ScannedEventArgs members.

Public Properties

 | Name | Description
Public Property | Cancel | Gets and sets a cancel on the session. If set to true, the session ends and the StartSession method returns control.
Public Property | PendingTransfers | Gets the number of image transfers the TWAIN Data Source is ready to supply to the TwainPRO control.
Public Property | ScannedImage | Gets and sets the scanned image and image information.
Top

See Also

Reference

ScannedEventArgs Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Cancel Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ScannedEventArgs Class : Cancel Property

Glossary Item Box

Gets and sets a cancel on the session. If set to true, the session ends and the StartSession method returns control.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property Cancel As Boolean
'Usage

Dim instance As ScannedEventArgs
Dim value As Boolean

instance.Cancel = value

value = instance.Cancel
public bool Cancel {get; set;}
public: __property bool get_Cancel();
public: __property void set_Cancel(
   bool value
);
public:
property bool Cancel {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true to cancel the session. Otherwise, false is used and the session is not canceled.

See Also

Reference

ScannedEventArgs Class
ScannedEventArgs Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
PendingTransfers Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ScannedEventArgs Class : PendingTransfers Property

Glossary Item Box

Gets the number of image transfers the TWAIN Data Source is ready to supply to the TwainPRO control.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property PendingTransfers As Integer
'Usage

Dim instance As ScannedEventArgs
Dim value As Integer

value = instance.PendingTransfers
public int PendingTransfers {get;}
public: __property int get_PendingTransfers();
public:
property int PendingTransfers {
   int get();
}

Property Value

An integer value which represents the number of image transfers the TWAIN device is ready to supply to the TwainPRO control.

Remarks

The TWAIN Data Source will return -1 if it is not sure how many transfers are pending. Scanners with Automatic Document Feeders (ADF) will typically return -1.

See Also

Reference

ScannedEventArgs Class
ScannedEventArgs Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
ScannedImage Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ScannedEventArgs Class : ScannedImage Property

Glossary Item Box

Gets and sets the scanned image and image information.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property ScannedImage As ScannedImage
'Usage

Dim instance As ScannedEventArgs
Dim value As ScannedImage

instance.ScannedImage = value

value = instance.ScannedImage
public ScannedImage ScannedImage {get; set;}
public: __property ScannedImage* get_ScannedImage();
public: __property void set_ScannedImage(
   ScannedImage* value
);
public:
property ScannedImage^ ScannedImage {
   ScannedImage^ get();
   void set (    ScannedImage^ value);
}

Property Value

A ScannedImage object which contains image information.

See Also

Reference

ScannedEventArgs Class
ScannedEventArgs Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
ScannedImage Class
Members See Also Send Feedback
Accusoft.TwainProSdk Namespace : ScannedImage Class

Glossary Item Box

This class implements the scanned image and image information.

Object Model

ScannedImage ClassExtendedImageInfoContainer ClassExtendedImageInfoContainerValueCollection ClassExtendedImageInfoContainerValue ClassScannedImageData Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Class ScannedImage
'Usage

Dim instance As ScannedImage
public class ScannedImage
public __gc class ScannedImage
public ref class ScannedImage

Remarks

Note: You cannot create a ScannedImage object directly.

The ScannedImage is accessible as a parameter of the Scanned event.

Inheritance Hierarchy

System.Object
Accusoft.TwainProSdk.ScannedImage

See Also

Reference

ScannedImage Members
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.TwainPro7.Net
ScannedImage Class Members
See Also Properties Methods Send Feedback
Accusoft.TwainProSdk Namespace : ScannedImage Class

Glossary Item Box

The following tables list the members exposed by ScannedImage.

Public Properties

 | Name | Description
Public Property | ScannedImageData | Gets the ScannedImageData properties.
Top

Public Methods

 | Name | Description
Public Method | CopyTo | Designed to make passing image data between different Accusoft components easier, this method makes a copy of this object's image data and gives the new image data to another object which can be defined in a different Accusoft assembly. When finished, both this object and the destination object will contain separate copies of the same image data.
Public Method | CopyToClipboard | Copies the image to the clipboard.
Public Method | CutToClipboard | Cuts the image to the clipboard.
Public Method | Dispose | Disposes any unused resources.
Public Method | GetExtendedImageInfo | Overloaded. Gets the specified extended image info.
Public Method | SaveFile | Overloaded. Deprecated, please use SaveToFile(System.String filename) to save the TwainPro-compressed image to file or SaveSourceCompressedImageToFile(System.String filename) to save the Source-compressed image to file instead. Saves the scanned image to file using the specified filename and default save options.
Public Method | SaveSourceCompressedImageToFile | Saves the Source-compressed image to file, the scanner (source) has directly compressed the image via the hardware.
Public Method | SaveSourceCompressedImageToStream | Saves the Source-compressed image to a stream object, the scanner (source) has directly compressed the image via the hardware.
Public Method | SaveStream | Deprecated, please use SaveToStream(System.IO.Stream stream, SaveOptions saveOptions) to save the TwainPro-compressed image to a stream or SaveSourceCompressedImageToStream(System.IO.Stream stream) to save the source-compressed image to a stream instead. Saves the image to a stream object.
Public Method | SaveToFile | Overloaded. Saves the TwainPro-compressed, scanned image to file using the specified filename and default save options.
Public Method | SaveToStream | Saves the TwainPro-compressed image to a stream object (the image has been compressed by the TwainPro software, e.g., PNG, TIFF, PDF, JPEG, etc).
Public Method | ToBitmap | Gets a System.Drawing.Bitmap object.
Public Method | ToHbitmap | Gets a handle to a bitmap.
Public Method | ToHdib | Gets a handle to a DIB.
Public Method | TransferTo | Designed to make passing image data between different Accusoft components easier, this method transfers this object's image data to another object which can be defined in a different Accusoft assembly. When finished, this object will no longer contain image data; the image data will be owned by the destination object.
Top

See Also

Reference

ScannedImage Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.TwainPro7.Net
ScannedImage Class Methods
See Also Send Feedback
Accusoft.TwainProSdk Namespace : ScannedImage Class

Glossary Item Box

For a list of all members of this type, see ScannedImage members.

Public Methods

 | Name | Description
Public Method | CopyTo | Designed to make passing image data between different Accusoft components easier, this method makes a copy of this object's image data and gives the new image data to another object which can be defined in a different Accusoft assembly. When finished, both this object and the destination object will contain separate copies of the same image data.
Public Method | CopyToClipboard | Copies the image to the clipboard.
Public Method | CutToClipboard | Cuts the image to the clipboard.
Public Method | Dispose | Disposes any unused resources.
Public Method | GetExtendedImageInfo | Overloaded. Gets the specified extended image info.
Public Method | SaveFile | Overloaded. Deprecated, please use SaveToFile(System.String filename) to save the TwainPro-compressed image to file or SaveSourceCompressedImageToFile(System.String filename) to save the Source-compressed image to file instead. Saves the scanned image to file using the specified filename and default save options.
Public Method | SaveSourceCompressedImageToFile | Saves the Source-compressed image to file, the scanner (source) has directly compressed the image via the hardware.
Public Method | SaveSourceCompressedImageToStream | Saves the Source-compressed image to a stream object, the scanner (source) has directly compressed the image via the hardware.
Public Method | SaveStream | Deprecated, please use SaveToStream(System.IO.Stream stream, SaveOptions saveOptions) to save the TwainPro-compressed image to a stream or SaveSourceCompressedImageToStream(System.IO.Stream stream) to save the source-compressed image to a stream instead. Saves the image to a stream object.
Public Method | SaveToFile | Overloaded. Saves the TwainPro-compressed, scanned image to file using the specified filename and default save options.
Public Method | SaveToStream | Saves the TwainPro-compressed image to a stream object (the image has been compressed by the TwainPro software, e.g., PNG, TIFF, PDF, JPEG, etc).
Public Method | ToBitmap | Gets a System.Drawing.Bitmap object.
Public Method | ToHbitmap | Gets a handle to a bitmap.
Public Method | ToHdib | Gets a handle to a DIB.
Public Method | TransferTo | Designed to make passing image data between different Accusoft components easier, this method transfers this object's image data to another object which can be defined in a different Accusoft assembly. When finished, this object will no longer contain image data; the image data will be owned by the destination object.
Top

See Also

Reference

ScannedImage Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
CopyTo Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ScannedImage Class : CopyTo Method

Destination
The destination object.

Glossary Item Box

Designed to make passing image data between different Accusoft components easier, this method makes a copy of this object's image data and gives the new image data to another object which can be defined in a different Accusoft assembly. When finished, both this object and the destination object will contain separate copies of the same image data.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub CopyTo( _
   ByVal Destination As Object _
)
'Usage

Dim instance As ScannedImage
Dim Destination As Object

instance.CopyTo(Destination)
public void CopyTo(
   object Destination
)
public: void CopyTo(
   Object* Destination
)
public:
void CopyTo(
   Object^ Destination
)

Parameters

Destination
The destination object.

Exceptions

Exception | Description
System.ArgumentException | Thrown when the destination object does not support being copied to.

Remarks

Not all object types are valid destinations for this method. Refer to the documentation of a particular class to see if it officially supports being the destination of a CopyTo method.

See Also

Reference

ScannedImage Class
ScannedImage Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
CopyToClipboard Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ScannedImage Class : CopyToClipboard Method

Glossary Item Box

Copies the image to the clipboard.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub CopyToClipboard()
'Usage

Dim instance As ScannedImage

instance.CopyToClipboard()
public void CopyToClipboard()
public: void CopyToClipboard();
public:
void CopyToClipboard();

Remarks

This method makes a copy of the current image and places it on the clipboard. This leaves the hDIB property valid for operations such as the SaveFile(String) method, but leaves two copies of the image in memory which could be a problem if the image is very large.

See Also

Reference

ScannedImage Class
ScannedImage Members
SaveFile(String) Method


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
CutToClipboard Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ScannedImage Class : CutToClipboard Method

Glossary Item Box

Cuts the image to the clipboard.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub CutToClipboard()
'Usage

Dim instance As ScannedImage

instance.CutToClipboard()
public void CutToClipboard()
public: void CutToClipboard();
public:
void CutToClipboard();

Remarks

This method places the current image on the clipboard. The hDIB property is not valid after this operation. If you wish to save the image to file, invoke the SaveFile(String) method prior to using the CutToClipboard method.

See Also

Reference

ScannedImage Class
ScannedImage Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Dispose Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ScannedImage Class : Dispose Method

Glossary Item Box

Disposes any unused resources.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub Dispose()
'Usage

Dim instance As ScannedImage

instance.Dispose()
public void Dispose()
public: void Dispose();
public:
void Dispose();

See Also

Reference

ScannedImage Class
ScannedImage Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
GetExtendedImageInfo Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ScannedImage Class : GetExtendedImageInfo Method

Glossary Item Box

Gets the specified extended image info.

Overload List

Overload | Description
GetExtendedImageInfo(ExtendedImageInfo) | Gets the specified extended image info.
GetExtendedImageInfo(Int32) | Gets the specified extended image info.

See Also

Reference

ScannedImage Class
ScannedImage Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
GetExtendedImageInfo(ExtendedImageInfo) Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ScannedImage Class > GetExtendedImageInfo Method : GetExtendedImageInfo(ExtendedImageInfo) Method

extendedImageInfo
An extended image info identification

Glossary Item Box

Gets the specified extended image info.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Function GetExtendedImageInfo( _
   ByVal extendedImageInfo As ExtendedImageInfo _
) As ExtendedImageInfoContainer
'Usage

Dim instance As ScannedImage
Dim extendedImageInfo As ExtendedImageInfo
Dim value As ExtendedImageInfoContainer

value = instance.GetExtendedImageInfo(extendedImageInfo)
public ExtendedImageInfoContainer GetExtendedImageInfo(
   ExtendedImageInfo extendedImageInfo
)
public: ExtendedImageInfoContainer* GetExtendedImageInfo(
   ExtendedImageInfo extendedImageInfo
)
public:
ExtendedImageInfoContainer^ GetExtendedImageInfo(
   ExtendedImageInfo extendedImageInfo
)

Parameters

extendedImageInfo
An extended image info identification

Return Value

An ExtendedImageInfoContainer object

Remarks

Returns an ExtendedImageInfoContainer with the extended image info of the specified extended image info identification.

See Also

Reference

ScannedImage Class
ScannedImage Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
GetExtendedImageInfo(Int32) Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ScannedImage Class > GetExtendedImageInfo Method : GetExtendedImageInfo(Int32) Method

extendedImageInfo
An ExtendedImageInfo enumeration value.

Glossary Item Box

Gets the specified extended image info.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Function GetExtendedImageInfo( _
   ByVal extendedImageInfo As Integer _
) As ExtendedImageInfoContainer
'Usage

Dim instance As ScannedImage
Dim extendedImageInfo As Integer
Dim value As ExtendedImageInfoContainer

value = instance.GetExtendedImageInfo(extendedImageInfo)
public ExtendedImageInfoContainer GetExtendedImageInfo(
   int extendedImageInfo
)
public: ExtendedImageInfoContainer* GetExtendedImageInfo(
   int extendedImageInfo
)
public:
ExtendedImageInfoContainer^ GetExtendedImageInfo(
   int extendedImageInfo
)

Parameters

extendedImageInfo
An ExtendedImageInfo enumeration value.

Return Value

An ExtendedImageInfoContainer object.

Remarks

Returns an ExtendedImageInfoContainer with the extended image info of the specified extended image info identification.

See Also

Reference

ScannedImage Class
ScannedImage Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
SaveFile Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ScannedImage Class : SaveFile Method

Glossary Item Box

Deprecated, please use SaveToFile(System.String filename) to save the TwainPro-compressed image to file or SaveSourceCompressedImageToFile(System.String filename) to save the Source-compressed image to file instead. Saves the scanned image to file using the specified filename and default save options.

Overload List

Overload | Description
SaveFile(String) | Deprecated, please use SaveToFile(System.String filename) to save the TwainPro-compressed image to file or SaveSourceCompressedImageToFile(System.String filename) to save the Source-compressed image to file instead. Saves the scanned image to file using the specified filename and default save options.
SaveFile(String,SaveOptions) | Deprecated, please use SaveToFile(System.String filename, SaveOptions saveOptions) to save the TwainPro-compressed image to file or SaveSourceCompressedImageToFile(System.String filename) to save the Source-compressed image to file instead. Saves the scanned image to file using the specified filename and save options.

See Also

Reference

ScannedImage Class
ScannedImage Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
SaveFile(String) Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ScannedImage Class > SaveFile Method : SaveFile(String) Method

filename
A string representation of a legal file name (path) to which the file will be saved.

Glossary Item Box

Deprecated, please use SaveToFile(System.String filename) to save the TwainPro-compressed image to file or SaveSourceCompressedImageToFile(System.String filename) to save the Source-compressed image to file instead. Saves the scanned image to file using the specified filename and default save options.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<ObsoleteAttribute("Deprecated, please use SaveToFile(System.String filename) or SaveSourceCompressedImageToFile(System.String filename) instead.")>
Public Overloads Sub SaveFile( _
   ByVal filename As String _
)
'Usage

Dim instance As ScannedImage
Dim filename As String

instance.SaveFile(filename)
[ObsoleteAttribute("Deprecated, please use SaveToFile(System.String filename) or SaveSourceCompressedImageToFile(System.String filename) instead.")]
public void SaveFile(
   string filename
)
[ObsoleteAttribute("Deprecated, please use SaveToFile(System.String filename) or SaveSourceCompressedImageToFile(System.String filename) instead.")]
public: void SaveFile(
   string* filename
)
[ObsoleteAttribute("Deprecated, please use SaveToFile(System.String filename) or SaveSourceCompressedImageToFile(System.String filename) instead.")]
public:
void SaveFile(
   String^ filename
)

Parameters

filename
A string representation of a legal file name (path) to which the file will be saved.

Remarks

The bitmap saved will be the same bits per pixel and color depth as the current DIB. Valid file extensions for this filename are .bmp, .jpg, .pic, .tif, and .pdf.

See Also

Reference

ScannedImage Class
ScannedImage Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
SaveFile(String,SaveOptions) Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ScannedImage Class > SaveFile Method : SaveFile(String,SaveOptions) Method

filename
A string representation of a legal file name (path) to which the file will be saved.
saveOptions
SaveOptions class that evaluates to the various settings for the particular file format to which the image will be saved.

Glossary Item Box

Deprecated, please use SaveToFile(System.String filename, SaveOptions saveOptions) to save the TwainPro-compressed image to file or SaveSourceCompressedImageToFile(System.String filename) to save the Source-compressed image to file instead. Saves the scanned image to file using the specified filename and save options.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<ObsoleteAttribute("Deprecated, please use SaveToFile(System.String filename, SaveOptions saveOptions) or SaveSourceCompressedImageToFile(System.String filename) instead.")>
Public Overloads Sub SaveFile( _
   ByVal filename As String, _
   ByVal saveOptions As SaveOptions _
)
'Usage

Dim instance As ScannedImage
Dim filename As String
Dim saveOptions As SaveOptions

instance.SaveFile(filename, saveOptions)
[ObsoleteAttribute("Deprecated, please use SaveToFile(System.String filename, SaveOptions saveOptions) or SaveSourceCompressedImageToFile(System.String filename) instead.")]
public void SaveFile(
   string filename,
   SaveOptions saveOptions
)
[ObsoleteAttribute("Deprecated, please use SaveToFile(System.String filename, SaveOptions saveOptions) or SaveSourceCompressedImageToFile(System.String filename) instead.")]
public: void SaveFile(
   string* filename,
   SaveOptions* saveOptions
)
[ObsoleteAttribute("Deprecated, please use SaveToFile(System.String filename, SaveOptions saveOptions) or SaveSourceCompressedImageToFile(System.String filename) instead.")]
public:
void SaveFile(
   String^ filename,
   SaveOptions^ saveOptions
)

Parameters

filename
A string representation of a legal file name (path) to which the file will be saved.
saveOptions
SaveOptions class that evaluates to the various settings for the particular file format to which the image will be saved.

Remarks

The bitmap saved will be the same bits per pixel and color depth as the current DIB. If the SaveOptions image format is set to default, one of the following valid file extensions will need to be used: .bmp, .jpg, .pic, .tif, or .pdf."

See Also

Reference

ScannedImage Class
ScannedImage Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
SaveSourceCompressedImageToFile Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ScannedImage Class : SaveSourceCompressedImageToFile Method

filename
A string representation of a legal file name (path) to which the file will be saved.

Glossary Item Box

Saves the Source-compressed image to file, the scanner (source) has directly compressed the image via the hardware.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub SaveSourceCompressedImageToFile( _
   ByVal filename As String _
)
'Usage

Dim instance As ScannedImage
Dim filename As String

instance.SaveSourceCompressedImageToFile(filename)
public void SaveSourceCompressedImageToFile(
   string filename
)
public: void SaveSourceCompressedImageToFile(
   string* filename
)
public:
void SaveSourceCompressedImageToFile(
   String^ filename
)

Parameters

filename
A string representation of a legal file name (path) to which the file will be saved.

Remarks

Note: Compression must be set for the source first by setting AdvancedCapability.IcapCompression and AdvancedCapability.IcapPixelType should also be set to a pixel type that supports the compression.
Compression Mode | Output File Type
TWCP_JPEG | JPEG
TWCP_GROUP31D | TIFF
TWCP_GROUP31DEOL | TIFF
TWCP_GROUP32D | TIFF
TWCP_GROUP4 | TIFF
TWCP_PACKBITS | TIFF

See Also

Reference

ScannedImage Class
ScannedImage Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
SaveSourceCompressedImageToStream Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ScannedImage Class : SaveSourceCompressedImageToStream Method

stream
An opened and writable System.IO.Stream derived stream object.

Glossary Item Box

Saves the Source-compressed image to a stream object, the scanner (source) has directly compressed the image via the hardware.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub SaveSourceCompressedImageToStream( _
   ByVal stream As Stream _
)
'Usage

Dim instance As ScannedImage
Dim stream As Stream

instance.SaveSourceCompressedImageToStream(stream)
public void SaveSourceCompressedImageToStream(
   Stream stream
)
public: void SaveSourceCompressedImageToStream(
   Stream* stream
)
public:
void SaveSourceCompressedImageToStream(
   Stream^ stream
)

Parameters

stream
An opened and writable System.IO.Stream derived stream object.

Remarks

The stream passed can be any stream derived System.IO.Stream. The stream should be opened by calling this method.

The stream should also allow writes.

Note: Compression must be set for the source first by setting AdvancedCapability.IcapCompression and AdvancedCapability.IcapPixelType should also be set to a pixel type that supports the compression.

Compression Mode | Output File Type
TWCP_JPEG | JPEG
TWCP_GROUP31D | TIFF
TWCP_GROUP31DEOL | TIFF
TWCP_GROUP32D | TIFF
TWCP_GROUP4 | TIFF
TWCP_PACKBITS | TIFF

See Also

Reference

ScannedImage Class
ScannedImage Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
SaveStream Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ScannedImage Class : SaveStream Method

stream
An opened and writable System.IO.Stream derived stream object.
theFormat
A ScannedImageFormat which represents the format to use to save the image.

Glossary Item Box

Deprecated, please use SaveToStream(System.IO.Stream stream, SaveOptions saveOptions) to save the TwainPro-compressed image to a stream or SaveSourceCompressedImageToStream(System.IO.Stream stream) to save the source-compressed image to a stream instead. Saves the image to a stream object.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<ObsoleteAttribute("Deprecated, please use SaveToStream(System.IO.Stream stream, SaveOptions saveOptions) or SaveSourceCompressedImageToStream(System.IO.Stream stream) instead.")>
Public Sub SaveStream( _
   ByVal stream As Stream, _
   ByVal theFormat As ScannedImageFormat _
)
'Usage

Dim instance As ScannedImage
Dim stream As Stream
Dim theFormat As ScannedImageFormat

instance.SaveStream(stream, theFormat)
[ObsoleteAttribute("Deprecated, please use SaveToStream(System.IO.Stream stream, SaveOptions saveOptions) or SaveSourceCompressedImageToStream(System.IO.Stream stream) instead.")]
public void SaveStream(
   Stream stream,
   ScannedImageFormat theFormat
)
[ObsoleteAttribute("Deprecated, please use SaveToStream(System.IO.Stream stream, SaveOptions saveOptions) or SaveSourceCompressedImageToStream(System.IO.Stream stream) instead.")]
public: void SaveStream(
   Stream* stream,
   ScannedImageFormat theFormat
)
[ObsoleteAttribute("Deprecated, please use SaveToStream(System.IO.Stream stream, SaveOptions saveOptions) or SaveSourceCompressedImageToStream(System.IO.Stream stream) instead.")]
public:
void SaveStream(
   Stream^ stream,
   ScannedImageFormat theFormat
)

Parameters

stream
An opened and writable System.IO.Stream derived stream object.
theFormat
A ScannedImageFormat which represents the format to use to save the image.

Remarks

The stream passed can be any stream derived System.IO.Stream. The stream should be opened by calling this method.

The stream should also allow writes.

See Also

Reference

ScannedImage Class
ScannedImage Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
SaveToFile Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ScannedImage Class : SaveToFile Method

Glossary Item Box

Saves the TwainPro-compressed, scanned image to file using the specified filename and default save options.

Overload List

Overload | Description
SaveToFile(String) | Saves the TwainPro-compressed, scanned image to file using the specified filename and default save options.
SaveToFile(String,SaveOptions) | Saves the TwainPro-compressed, scanned image to file using the specified filename and save options.

See Also

Reference

ScannedImage Class
ScannedImage Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
SaveToFile(String) Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ScannedImage Class > SaveToFile Method : SaveToFile(String) Method

filename
A string representation of a legal file name (path) to which the file will be saved.

Glossary Item Box

Saves the TwainPro-compressed, scanned image to file using the specified filename and default save options.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub SaveToFile( _
   ByVal filename As String _
)
'Usage

Dim instance As ScannedImage
Dim filename As String

instance.SaveToFile(filename)
public void SaveToFile(
   string filename
)
public: void SaveToFile(
   string* filename
)
public:
void SaveToFile(
   String^ filename
)

Parameters

filename
A string representation of a legal file name (path) to which the file will be saved.

Remarks

The bitmap saved will be the same bits per pixel and color depth as the current DIB. Valid file extensions for this filename are .bmp, .jpg, .pic, .tif, and .pdf.

See Also

Reference

ScannedImage Class
ScannedImage Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
SaveToFile(String,SaveOptions) Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ScannedImage Class > SaveToFile Method : SaveToFile(String,SaveOptions) Method

filename
A string representation of a legal file name (path) to which the file will be saved.
saveOptions
SaveOptions class that evaluates to the various settings for the particular file format to which the image will be saved.

Glossary Item Box

Saves the TwainPro-compressed, scanned image to file using the specified filename and save options.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub SaveToFile( _
   ByVal filename As String, _
   ByVal saveOptions As SaveOptions _
)
'Usage

Dim instance As ScannedImage
Dim filename As String
Dim saveOptions As SaveOptions

instance.SaveToFile(filename, saveOptions)
public void SaveToFile(
   string filename,
   SaveOptions saveOptions
)
public: void SaveToFile(
   string* filename,
   SaveOptions* saveOptions
)
public:
void SaveToFile(
   String^ filename,
   SaveOptions^ saveOptions
)

Parameters

filename
A string representation of a legal file name (path) to which the file will be saved.
saveOptions
SaveOptions class that evaluates to the various settings for the particular file format to which the image will be saved.

Remarks

The bitmap saved will be the same bits per pixel and color depth as the current DIB. If the SaveOptions image format is set to default, one of the following valid file extensions will need to be used: .bmp, .jpg, .pic, .tif, or .pdf."

See Also

Reference

ScannedImage Class
ScannedImage Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
SaveToStream Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ScannedImage Class : SaveToStream Method

stream
An opened and writable System.IO.Stream derived stream object.
saveOptions
A SaveOptions which represents the options to use to save the image.

Glossary Item Box

Saves the TwainPro-compressed image to a stream object (the image has been compressed by the TwainPro software, e.g., PNG, TIFF, PDF, JPEG, etc).

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub SaveToStream( _
   ByVal stream As Stream, _
   ByVal saveOptions As SaveOptions _
)
'Usage

Dim instance As ScannedImage
Dim stream As Stream
Dim saveOptions As SaveOptions

instance.SaveToStream(stream, saveOptions)
public void SaveToStream(
   Stream stream,
   SaveOptions saveOptions
)
public: void SaveToStream(
   Stream* stream,
   SaveOptions* saveOptions
)
public:
void SaveToStream(
   Stream^ stream,
   SaveOptions^ saveOptions
)

Parameters

stream
An opened and writable System.IO.Stream derived stream object.
saveOptions
A SaveOptions which represents the options to use to save the image.

Remarks

The stream passed can be any stream derived System.IO.Stream. The stream should be opened by calling this method.

The stream should also allow writes.

See Also

Reference

ScannedImage Class
ScannedImage Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
ToBitmap Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ScannedImage Class : ToBitmap Method

Glossary Item Box

Gets a System.Drawing.Bitmap object.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function ToBitmap() As Bitmap
'Usage

Dim instance As ScannedImage
Dim value As Bitmap

value = instance.ToBitmap()
public Bitmap ToBitmap()
public: Bitmap* ToBitmap();
public:
Bitmap^ ToBitmap();

Return Value

A System.Drawing.Bitmap object.

Remarks

When accessed, the image is released from the ScannedImage object.

See Also

Reference

ScannedImage Class
ScannedImage Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
ToHbitmap Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ScannedImage Class : ToHbitmap Method

Glossary Item Box

Gets a handle to a bitmap.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function ToHbitmap() As IntPtr
'Usage

Dim instance As ScannedImage
Dim value As IntPtr

value = instance.ToHbitmap()
public IntPtr ToHbitmap()
public: IntPtr ToHbitmap();
public:
IntPtr ToHbitmap();

Return Value

An HBITMAP (handle to a BITMAP).

Remarks

When accessed, the image is released from the ScannedImage object.

See Also

Reference

ScannedImage Class
ScannedImage Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
ToHdib Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ScannedImage Class : ToHdib Method

Glossary Item Box

Gets a handle to a DIB.

Overload List

Overload | Description
ToHdib | Gets a handle to a DIB.

See Also

Reference

ScannedImage Class
ScannedImage Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
ToHdib() Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ScannedImage Class : ToHdib() Method

Glossary Item Box

Gets a handle to a DIB.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function ToHdib() As IntPtr
'Usage

Dim instance As ScannedImage
Dim value As IntPtr

value = instance.ToHdib()
public IntPtr ToHdib()
public: IntPtr ToHdib();
public:
IntPtr ToHdib();

Return Value

An HDIB (handle to a DIB).

Remarks

When accessed, the image is released from the ScannedImage object.

See Also

Reference

ScannedImage Class
ScannedImage Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
TransferTo Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ScannedImage Class : TransferTo Method

Destination
The desintation object.

Glossary Item Box

Designed to make passing image data between different Accusoft components easier, this method transfers this object's image data to another object which can be defined in a different Accusoft assembly. When finished, this object will no longer contain image data; the image data will be owned by the destination object.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub TransferTo( _
   ByVal Destination As Object _
)
'Usage

Dim instance As ScannedImage
Dim Destination As Object

instance.TransferTo(Destination)
public void TransferTo(
   object Destination
)
public: void TransferTo(
   Object* Destination
)
public:
void TransferTo(
   Object^ Destination
)

Parameters

Destination
The desintation object.

Exceptions

Exception | Description
System.ArgumentException | Thrown when the destination object does not support being transferred to.

Remarks

Not all object types are valid destinations for this method. Refer to the documentation of a particular class to see if it officially supports being the destination of a TransferTo method.

See Also

Reference

ScannedImage Class
ScannedImage Members


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.TwainPro7.Net
ScannedImage Class Properties
See Also Send Feedback
Accusoft.TwainProSdk Namespace : ScannedImage Class

Glossary Item Box

For a list of all members of this type, see ScannedImage members.

Public Properties

 | Name | Description
Public Property | ScannedImageData | Gets the ScannedImageData properties.
Top

See Also

Reference

ScannedImage Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
ScannedImageData Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ScannedImage Class : ScannedImageData Property

Glossary Item Box

Gets the ScannedImageData properties.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public ReadOnly Property ScannedImageData As ScannedImageData
'Usage

Dim instance As ScannedImage
Dim value As ScannedImageData

value = instance.ScannedImageData
[BrowsableAttribute(false)]
public ScannedImageData ScannedImageData {get;}
[BrowsableAttribute(false)]
public: __property ScannedImageData* get_ScannedImageData();
[BrowsableAttribute(false)]
public:
property ScannedImageData^ ScannedImageData {
   ScannedImageData^ get();
}

Property Value

A ScannedImageData object which contains scanned image data property information.

Remarks

The default value is null.

See Also

Reference

ScannedImage Class
ScannedImage Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
ScannedImageData Class
Members See Also Send Feedback
Accusoft.TwainProSdk Namespace : ScannedImageData Class

Glossary Item Box

This class implements objects that contain the scanned image information.

Object Model

ScannedImageData Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Class ScannedImageData
'Usage

Dim instance As ScannedImageData
public class ScannedImageData
public __gc class ScannedImageData
public ref class ScannedImageData

Remarks

You cannot create a ScannedImageData object directly. The ScannedImageData is accessible as a parameter of the Scanning event or as a property of the ScannedImage which is accessible in the Scanned event.

Inheritance Hierarchy

System.Object
Accusoft.TwainProSdk.ScannedImageData

See Also

Reference

ScannedImageData Members
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.TwainPro7.Net
ScannedImageData Class Members
See Also Properties Methods Send Feedback
Accusoft.TwainProSdk Namespace : ScannedImageData Class

Glossary Item Box

The following tables list the members exposed by ScannedImageData.

Public Properties

 | Name | Description
Public Property | BitsPerPixel | Gets the bits per pixel of the image.
Public Property | Compression | Gets the compression of the image.
Public Property | Height | Gets the height of the image.
Public Property | PixelType | Gets the pixel type of the image.
Public Property | ResolutionX | Gets the X resolution of the image.
Public Property | ResolutionY | Gets the Y resolution of the image.
Public Property | Width | Gets the width of the image.
Top

Public Methods

 | Name | Description
Public Method | Dispose | Disposes of unmanaged resources.
Top

See Also

Reference

ScannedImageData Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.TwainPro7.Net
ScannedImageData Class Methods
See Also Send Feedback
Accusoft.TwainProSdk Namespace : ScannedImageData Class

Glossary Item Box

For a list of all members of this type, see ScannedImageData members.

Public Methods

 | Name | Description
Public Method | Dispose | Disposes of unmanaged resources.
Top

See Also

Reference

ScannedImageData Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Dispose Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ScannedImageData Class : Dispose Method

Glossary Item Box

Disposes of unmanaged resources.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub Dispose()
'Usage

Dim instance As ScannedImageData

instance.Dispose()
public void Dispose()
public: void Dispose();
public:
void Dispose();

Remarks

This method is part of the IDisposable interface.

See Also

Reference

ScannedImageData Class
ScannedImageData Members


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.TwainPro7.Net
ScannedImageData Class Properties
See Also Send Feedback
Accusoft.TwainProSdk Namespace : ScannedImageData Class

Glossary Item Box

For a list of all members of this type, see ScannedImageData members.

Public Properties

 | Name | Description
Public Property | BitsPerPixel | Gets the bits per pixel of the image.
Public Property | Compression | Gets the compression of the image.
Public Property | Height | Gets the height of the image.
Public Property | PixelType | Gets the pixel type of the image.
Public Property | ResolutionX | Gets the X resolution of the image.
Public Property | ResolutionY | Gets the Y resolution of the image.
Public Property | Width | Gets the width of the image.
Top

See Also

Reference

ScannedImageData Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
BitsPerPixel Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ScannedImageData Class : BitsPerPixel Property

Glossary Item Box

Gets the bits per pixel of the image.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DescriptionAttribute("Returns the bits per pixel of the image.")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
Public ReadOnly Property BitsPerPixel As Integer
'Usage

Dim instance As ScannedImageData
Dim value As Integer

value = instance.BitsPerPixel
[DescriptionAttribute("Returns the bits per pixel of the image.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public int BitsPerPixel {get;}
[DescriptionAttribute("Returns the bits per pixel of the image.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public: __property int get_BitsPerPixel();
[DescriptionAttribute("Returns the bits per pixel of the image.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public:
property int BitsPerPixel {
   int get();
}

Property Value

An integer value which represents the bits per pixel of the image.

Remarks

Note: This property is available at runtime and is read-only.

See Also

Reference

ScannedImageData Class
ScannedImageData Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Compression Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ScannedImageData Class : Compression Property

Glossary Item Box

Gets the compression of the image.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DescriptionAttribute("Returns the compression of the image.")>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property Compression As ScannedImageCompression
'Usage

Dim instance As ScannedImageData
Dim value As ScannedImageCompression

value = instance.Compression
[DescriptionAttribute("Returns the compression of the image.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public ScannedImageCompression Compression {get;}
[DescriptionAttribute("Returns the compression of the image.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property ScannedImageCompression get_Compression();
[DescriptionAttribute("Returns the compression of the image.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property ScannedImageCompression Compression {
   ScannedImageCompression get();
}

Property Value

A ScannedImageCompression enumeration value which determines the compression of the image.

Remarks

Note: This property is available at runtime and is read-only.

TwcpNone means that the image is in an uncompressed DIB format and can be accessed through the ToHdib, ToBitmap, ToHbitmap, or SaveStream methods.

TwcpJpeg means that the image is in a JPEG format and should be accessed through the SaveStream method.

All other values mean that the image is in a TIFF format and should be accessed through the SaveStream method.

See Also

Reference

ScannedImageData Class
ScannedImageData Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Height Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ScannedImageData Class : Height Property

Glossary Item Box

Gets the height of the image.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
<DescriptionAttribute("Returns the height of the image.")>
Public ReadOnly Property Height As Integer
'Usage

Dim instance As ScannedImageData
Dim value As Integer

value = instance.Height
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
[DescriptionAttribute("Returns the height of the image.")]
public int Height {get;}
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
[DescriptionAttribute("Returns the height of the image.")]
public: __property int get_Height();
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
[DescriptionAttribute("Returns the height of the image.")]
public:
property int Height {
   int get();
}

Property Value

An integer value which represents the height of the image.

Remarks

Note: Height is available at runtime and is read-only.

The Height units are determined by the ICAP_UNITS capability.

See Also

Reference

ScannedImageData Class
ScannedImageData Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
PixelType Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ScannedImageData Class : PixelType Property

Glossary Item Box

Gets the pixel type of the image.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DescriptionAttribute("Returns the pixel type of the image.")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property PixelType As PixelType
'Usage

Dim instance As ScannedImageData
Dim value As PixelType

value = instance.PixelType
[BrowsableAttribute(false)]
[DescriptionAttribute("Returns the pixel type of the image.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public PixelType PixelType {get;}
[BrowsableAttribute(false)]
[DescriptionAttribute("Returns the pixel type of the image.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property PixelType get_PixelType();
[BrowsableAttribute(false)]
[DescriptionAttribute("Returns the pixel type of the image.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property PixelType PixelType {
   PixelType get();
}

Property Value

The PixelType enumeration value which determines the pixel type of the image.

Remarks

PixelType is available at runtime and is read-only.

See Also

Reference

ScannedImageData Class
ScannedImageData Members
PixelType Enumeration


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
ResolutionX Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ScannedImageData Class : ResolutionX Property

Glossary Item Box

Gets the X resolution of the image.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DescriptionAttribute("Returns the X resolution of the image.")>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property ResolutionX As Single
'Usage

Dim instance As ScannedImageData
Dim value As Single

value = instance.ResolutionX
[DescriptionAttribute("Returns the X resolution of the image.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public float ResolutionX {get;}
[DescriptionAttribute("Returns the X resolution of the image.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property float get_ResolutionX();
[DescriptionAttribute("Returns the X resolution of the image.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property float ResolutionX {
   float get();
}

Property Value

A float value which represents the x resolution of the image.

Remarks

Note: ResolutionX is available at runtime and is read-only.

The ResolutionX units are determined by the ICAP_UNITS capability.

See Also

Reference

ScannedImageData Class
ScannedImageData Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
ResolutionY Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ScannedImageData Class : ResolutionY Property

Glossary Item Box

Gets the Y resolution of the image.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DescriptionAttribute("Returns the Y resolution of the image.")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property ResolutionY As Single
'Usage

Dim instance As ScannedImageData
Dim value As Single

value = instance.ResolutionY
[BrowsableAttribute(false)]
[DescriptionAttribute("Returns the Y resolution of the image.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public float ResolutionY {get;}
[BrowsableAttribute(false)]
[DescriptionAttribute("Returns the Y resolution of the image.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property float get_ResolutionY();
[BrowsableAttribute(false)]
[DescriptionAttribute("Returns the Y resolution of the image.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property float ResolutionY {
   float get();
}

Property Value

A float value which represents the y resolution of the image.

Remarks

Note: ResolutionY is available at runtime and is read-only.

The ResolutionY units are determined by the ICAP_UNITS capability.

See Also

Reference

ScannedImageData Class
ScannedImageData Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Width Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ScannedImageData Class : Width Property

Glossary Item Box

Gets the width of the image.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DescriptionAttribute("Returns the width of the image.")>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property Width As Integer
'Usage

Dim instance As ScannedImageData
Dim value As Integer

value = instance.Width
[DescriptionAttribute("Returns the width of the image.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public int Width {get;}
[DescriptionAttribute("Returns the width of the image.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property int get_Width();
[DescriptionAttribute("Returns the width of the image.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property int Width {
   int get();
}

Property Value

An integer value which represents the width of the image.

Remarks

Note: Width is available at runtime and is read-only.

The Width units are determined by the ICAP_UNITS capability.

See Also

Reference

ScannedImageData Class
ScannedImageData Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
ScanningEventArgs Class
Members See Also Send Feedback
Accusoft.TwainProSdk Namespace : ScanningEventArgs Class

Glossary Item Box

Arguments for a scanning event.

Object Model

ScanningEventArgs ClassScannedImageData Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Class ScanningEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As ScanningEventArgs
public class ScanningEventArgs : System.EventArgs
public __gc class ScanningEventArgs : public System.EventArgs
public ref class ScanningEventArgs : public System.EventArgs

Remarks

This class provides the communication between the object that issued a scanning event and the object that handles the event.

Inheritance Hierarchy

System.Object
System.EventArgs
Accusoft.TwainProSdk.ScanningEventArgs

See Also

Reference

ScanningEventArgs Members
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.TwainPro7.Net
ScanningEventArgs Class Members
See Also Properties Send Feedback
Accusoft.TwainProSdk Namespace : ScanningEventArgs Class

Glossary Item Box

The following tables list the members exposed by ScanningEventArgs.

Public Constructors

 | Name | Description
Public Constructor | ScanningEventArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | Cancel | Gets and sets an indicator whether to cancel the session.
Public Property | PendingTransfers | Gets the number of image transfers the TWAIN Data Source is ready to supply to the TwainPRO control.
Public Property | ScannedImageData | Gets and sets the scanned image information.
Top

See Also

Reference

ScanningEventArgs Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
ScanningEventArgs Constructor
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ScanningEventArgs Class : ScanningEventArgs Constructor

Glossary Item Box

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ScanningEventArgs()
public ScanningEventArgs()
public: ScanningEventArgs();
public:
ScanningEventArgs();

See Also

Reference

ScanningEventArgs Class
ScanningEventArgs Members


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.TwainPro7.Net
ScanningEventArgs Class Properties
See Also Send Feedback
Accusoft.TwainProSdk Namespace : ScanningEventArgs Class

Glossary Item Box

For a list of all members of this type, see ScanningEventArgs members.

Public Properties

 | Name | Description
Public Property | Cancel | Gets and sets an indicator whether to cancel the session.
Public Property | PendingTransfers | Gets the number of image transfers the TWAIN Data Source is ready to supply to the TwainPRO control.
Public Property | ScannedImageData | Gets and sets the scanned image information.
Top

See Also

Reference

ScanningEventArgs Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Cancel Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ScanningEventArgs Class : Cancel Property

Glossary Item Box

Gets and sets an indicator whether to cancel the session.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property Cancel As Boolean
'Usage

Dim instance As ScanningEventArgs
Dim value As Boolean

instance.Cancel = value

value = instance.Cancel
public bool Cancel {get; set;}
public: __property bool get_Cancel();
public: __property void set_Cancel(
   bool value
);
public:
property bool Cancel {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true to cancel the session. Otherwise, false should be used.

Remarks

If set to true, the session ends and the StartSession method returns control.

See Also

Reference

ScanningEventArgs Class
ScanningEventArgs Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
PendingTransfers Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ScanningEventArgs Class : PendingTransfers Property

Glossary Item Box

Gets the number of image transfers the TWAIN Data Source is ready to supply to the TwainPRO control.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property PendingTransfers As Integer
'Usage

Dim instance As ScanningEventArgs
Dim value As Integer

value = instance.PendingTransfers
public int PendingTransfers {get;}
public: __property int get_PendingTransfers();
public:
property int PendingTransfers {
   int get();
}

Property Value

An integer value which represents the pending transfers.

Remarks

The default value is 0.

The TWAIN Data Source will return -1 if it is not sure how many transfers are pending. Scanners with Automatic Document Feeders (ADF) will typically return -1.

See Also

Reference

ScanningEventArgs Class
ScanningEventArgs Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
ScannedImageData Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ScanningEventArgs Class : ScannedImageData Property

Glossary Item Box

Gets and sets the scanned image information.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property ScannedImageData As ScannedImageData
'Usage

Dim instance As ScanningEventArgs
Dim value As ScannedImageData

instance.ScannedImageData = value

value = instance.ScannedImageData
public ScannedImageData ScannedImageData {get; set;}
public: __property ScannedImageData* get_ScannedImageData();
public: __property void set_ScannedImageData(
   ScannedImageData* value
);
public:
property ScannedImageData^ ScannedImageData {
   ScannedImageData^ get();
   void set (    ScannedImageData^ value);
}

Property Value

A ScannedImageData object which contains image information.

Remarks

The default value is null.

See Also

Reference

ScanningEventArgs Class
ScanningEventArgs Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
SequenceException Class
Members See Also Send Feedback
Accusoft.TwainProSdk Namespace : SequenceException Class

Glossary Item Box

This exception is thrown if an illegal operation is performed for the current Source Manager or Source state.

Object Model

SequenceException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class SequenceException
   Inherits TwainProException
'Usage

Dim instance As SequenceException
[SerializableAttribute()]
public sealed class SequenceException : TwainProException
[SerializableAttribute()]
public __gc __sealed class SequenceException : public TwainProException
[SerializableAttribute()]
public ref class SequenceException sealed : public TwainProException

Remarks

The requested action cannot be performed in the current state of the TWAIN session.

Possible causes:

Certain methods and properties are only valid during certain states.

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.TwainProSdk.TwainProException
Accusoft.TwainProSdk.SequenceException

See Also

Reference

SequenceException Members
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.TwainPro7.Net
SequenceException Class Members
See Also Properties Methods Send Feedback
Accusoft.TwainProSdk Namespace : SequenceException Class

Glossary Item Box

The following tables list the members exposed by SequenceException.

Public Constructors

 | Name | Description
Public Constructor | SequenceException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.TwainProSdk.TwainProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

SequenceException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.TwainPro7.Net
SequenceException Class Methods
See Also Send Feedback
Accusoft.TwainProSdk Namespace : SequenceException Class

Glossary Item Box

For a list of all members of this type, see SequenceException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

SequenceException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.TwainPro7.Net
SequenceException Class Properties
See Also Send Feedback
Accusoft.TwainProSdk Namespace : SequenceException Class

Glossary Item Box

For a list of all members of this type, see SequenceException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.TwainProSdk.TwainProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

SequenceException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
SequenceException Constructor
See Also Send Feedback
Accusoft.TwainProSdk Namespace > SequenceException Class : SequenceException Constructor

Glossary Item Box

Overload List

Overload | Description
SequenceException Constructor() | An exception generated for a sequence error.
SequenceException Constructor(Int32) | Generated exception for a sequence error with a given error number.
SequenceException Constructor(String) | Generated exception for a sequence error with a given string.
SequenceException Constructor(Int32,String) | Generated exception for a sequence error with a given error number and message.
SequenceException Constructor(String,Exception) | Generated exception for a sequence error with a given message and inner exception.

See Also

Reference

SequenceException Class
SequenceException Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
SequenceException Constructor()
See Also Send Feedback
Accusoft.TwainProSdk Namespace > SequenceException Class > SequenceException Constructor : SequenceException Constructor()

Glossary Item Box

An exception generated for a sequence error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New SequenceException()
public SequenceException()
public: SequenceException();
public:
SequenceException();

See Also

Reference

SequenceException Class
SequenceException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
SequenceException Constructor(Int32)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > SequenceException Class > SequenceException Constructor : SequenceException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a sequence error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New SequenceException(errorNumber)
public SequenceException(
   int errorNumber
)
public: SequenceException(
   int errorNumber
)
public:
SequenceException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

SequenceException Class
SequenceException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
SequenceException Constructor(String)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > SequenceException Class > SequenceException Constructor : SequenceException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a sequence error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New SequenceException(message)
public SequenceException(
   string message
)
public: SequenceException(
   string* message
)
public:
SequenceException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

SequenceException Class
SequenceException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
SequenceException Constructor(Int32,String)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > SequenceException Class > SequenceException Constructor : SequenceException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a sequence error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New SequenceException(errorNumber, message)
public SequenceException(
   int errorNumber,
   string message
)
public: SequenceException(
   int errorNumber,
   string* message
)
public:
SequenceException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

SequenceException Class
SequenceException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
SequenceException Constructor(String,Exception)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > SequenceException Class > SequenceException Constructor : SequenceException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a sequence error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New SequenceException(message, innerException)
public SequenceException(
   string message,
   Exception innerException
)
public: SequenceException(
   string* message,
   Exception* innerException
)
public:
SequenceException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

SequenceException Class
SequenceException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
SourceCompressedImageOnlyException Class
Members See Also Send Feedback
Accusoft.TwainProSdk Namespace : SourceCompressedImageOnlyException Class

Glossary Item Box

This exception is thrown for trying to save the TwainPro-compressed image when hardware compression was used and only the source-compressed image is available.

Object Model

SourceCompressedImageOnlyException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class SourceCompressedImageOnlyException
   Inherits TwainProException
'Usage

Dim instance As SourceCompressedImageOnlyException
[SerializableAttribute()]
public sealed class SourceCompressedImageOnlyException : TwainProException
[SerializableAttribute()]
public __gc __sealed class SourceCompressedImageOnlyException : public TwainProException
[SerializableAttribute()]
public ref class SourceCompressedImageOnlyException sealed : public TwainProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.TwainProSdk.TwainProException
Accusoft.TwainProSdk.SourceCompressedImageOnlyException

See Also

Reference

SourceCompressedImageOnlyException Members
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.TwainPro7.Net
SourceCompressedImageOnlyException Class Members
See Also Properties Methods Send Feedback
Accusoft.TwainProSdk Namespace : SourceCompressedImageOnlyException Class

Glossary Item Box

The following tables list the members exposed by SourceCompressedImageOnlyException.

Public Constructors

 | Name | Description
Public Constructor | SourceCompressedImageOnlyException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.TwainProSdk.TwainProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

SourceCompressedImageOnlyException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.TwainPro7.Net
SourceCompressedImageOnlyException Class Methods
See Also Send Feedback
Accusoft.TwainProSdk Namespace : SourceCompressedImageOnlyException Class

Glossary Item Box

For a list of all members of this type, see SourceCompressedImageOnlyException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

SourceCompressedImageOnlyException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.TwainPro7.Net
SourceCompressedImageOnlyException Class Properties
See Also Send Feedback
Accusoft.TwainProSdk Namespace : SourceCompressedImageOnlyException Class

Glossary Item Box

For a list of all members of this type, see SourceCompressedImageOnlyException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.TwainProSdk.TwainProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

SourceCompressedImageOnlyException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
SourceCompressedImageOnlyException Constructor
See Also Send Feedback
Accusoft.TwainProSdk Namespace > SourceCompressedImageOnlyException Class : SourceCompressedImageOnlyException Constructor

Glossary Item Box

Overload List

Overload | Description
SourceCompressedImageOnlyException Constructor() | An exception generated for trying to save the TwainPro-compressed image when hardware compression was used and only the source-compressed image is available.
SourceCompressedImageOnlyException Constructor(Int32) | An exception generated for trying to save the TwainPro-compressed image when hardware compression was used and only the source-compressed image is available with a given error number.
SourceCompressedImageOnlyException Constructor(String) | An exception generated for trying to save the TwainPro-compressed image when hardware compression was used and only the source-compressed image is available with a given string.
SourceCompressedImageOnlyException Constructor(Int32,String) | An exception generated for trying to save the TwainPro-compressed image when hardware compression was used and only the source-compressed image is available with a given error number and message.
SourceCompressedImageOnlyException Constructor(String,Exception) | An exception generated for trying to save the TwainPro-compressed image when hardware compression was used and only the source-compressed image is available with a given message and inner exception.

See Also

Reference

SourceCompressedImageOnlyException Class
SourceCompressedImageOnlyException Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
SourceCompressedImageOnlyException Constructor()
See Also Send Feedback
Accusoft.TwainProSdk Namespace > SourceCompressedImageOnlyException Class > SourceCompressedImageOnlyException Constructor : SourceCompressedImageOnlyException Constructor()

Glossary Item Box

An exception generated for trying to save the TwainPro-compressed image when hardware compression was used and only the source-compressed image is available.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New SourceCompressedImageOnlyException()
public SourceCompressedImageOnlyException()
public: SourceCompressedImageOnlyException();
public:
SourceCompressedImageOnlyException();

See Also

Reference

SourceCompressedImageOnlyException Class
SourceCompressedImageOnlyException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
SourceCompressedImageOnlyException Constructor(Int32)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > SourceCompressedImageOnlyException Class > SourceCompressedImageOnlyException Constructor : SourceCompressedImageOnlyException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

An exception generated for trying to save the TwainPro-compressed image when hardware compression was used and only the source-compressed image is available with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New SourceCompressedImageOnlyException(errorNumber)
public SourceCompressedImageOnlyException(
   int errorNumber
)
public: SourceCompressedImageOnlyException(
   int errorNumber
)
public:
SourceCompressedImageOnlyException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

SourceCompressedImageOnlyException Class
SourceCompressedImageOnlyException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
SourceCompressedImageOnlyException Constructor(String)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > SourceCompressedImageOnlyException Class > SourceCompressedImageOnlyException Constructor : SourceCompressedImageOnlyException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

An exception generated for trying to save the TwainPro-compressed image when hardware compression was used and only the source-compressed image is available with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New SourceCompressedImageOnlyException(message)
public SourceCompressedImageOnlyException(
   string message
)
public: SourceCompressedImageOnlyException(
   string* message
)
public:
SourceCompressedImageOnlyException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

SourceCompressedImageOnlyException Class
SourceCompressedImageOnlyException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
SourceCompressedImageOnlyException Constructor(Int32,String)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > SourceCompressedImageOnlyException Class > SourceCompressedImageOnlyException Constructor : SourceCompressedImageOnlyException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

An exception generated for trying to save the TwainPro-compressed image when hardware compression was used and only the source-compressed image is available with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New SourceCompressedImageOnlyException(errorNumber, message)
public SourceCompressedImageOnlyException(
   int errorNumber,
   string message
)
public: SourceCompressedImageOnlyException(
   int errorNumber,
   string* message
)
public:
SourceCompressedImageOnlyException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

SourceCompressedImageOnlyException Class
SourceCompressedImageOnlyException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
SourceCompressedImageOnlyException Constructor(String,Exception)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > SourceCompressedImageOnlyException Class > SourceCompressedImageOnlyException Constructor : SourceCompressedImageOnlyException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

An exception generated for trying to save the TwainPro-compressed image when hardware compression was used and only the source-compressed image is available with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New SourceCompressedImageOnlyException(message, innerException)
public SourceCompressedImageOnlyException(
   string message,
   Exception innerException
)
public: SourceCompressedImageOnlyException(
   string* message,
   Exception* innerException
)
public:
SourceCompressedImageOnlyException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

SourceCompressedImageOnlyException Class
SourceCompressedImageOnlyException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
StringIsTooLongException Class
Members See Also Send Feedback
Accusoft.TwainProSdk Namespace : StringIsTooLongException Class

Glossary Item Box

This exception is thrown if a TwainPRO property was set to a string with too many characters.

Object Model

StringIsTooLongException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class StringIsTooLongException
   Inherits TwainProException
'Usage

Dim instance As StringIsTooLongException
[SerializableAttribute()]
public sealed class StringIsTooLongException : TwainProException
[SerializableAttribute()]
public __gc __sealed class StringIsTooLongException : public TwainProException
[SerializableAttribute()]
public ref class StringIsTooLongException sealed : public TwainProException

Remarks

Possible causes:

The application identity properties can accept a maximum length of 32 characters.

The SaveOptionsPic.Password property can accept a maximum length of 8 characters.

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.TwainProSdk.TwainProException
Accusoft.TwainProSdk.StringIsTooLongException

See Also

Reference

StringIsTooLongException Members
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.TwainPro7.Net
StringIsTooLongException Class Members
See Also Properties Methods Send Feedback
Accusoft.TwainProSdk Namespace : StringIsTooLongException Class

Glossary Item Box

The following tables list the members exposed by StringIsTooLongException.

Public Constructors

 | Name | Description
Public Constructor | StringIsTooLongException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.TwainProSdk.TwainProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

StringIsTooLongException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.TwainPro7.Net
StringIsTooLongException Class Methods
See Also Send Feedback
Accusoft.TwainProSdk Namespace : StringIsTooLongException Class

Glossary Item Box

For a list of all members of this type, see StringIsTooLongException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

StringIsTooLongException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.TwainPro7.Net
StringIsTooLongException Class Properties
See Also Send Feedback
Accusoft.TwainProSdk Namespace : StringIsTooLongException Class

Glossary Item Box

For a list of all members of this type, see StringIsTooLongException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.TwainProSdk.TwainProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

StringIsTooLongException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
StringIsTooLongException Constructor
See Also Send Feedback
Accusoft.TwainProSdk Namespace > StringIsTooLongException Class : StringIsTooLongException Constructor

Glossary Item Box

Overload List

Overload | Description
StringIsTooLongException Constructor() | An exception generated for a string is too long error.
StringIsTooLongException Constructor(Int32) | Generated exception for a string is too long error with a given error number.
StringIsTooLongException Constructor(String) | Generated exception for a string is too long error with a given string.
StringIsTooLongException Constructor(Int32,String) | Generated exception for a string is too long error with a given error number and message.
StringIsTooLongException Constructor(String,Exception) | Generated exception for a string is too long error with a given message and inner exception.

See Also

Reference

StringIsTooLongException Class
StringIsTooLongException Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
StringIsTooLongException Constructor()
See Also Send Feedback
Accusoft.TwainProSdk Namespace > StringIsTooLongException Class > StringIsTooLongException Constructor : StringIsTooLongException Constructor()

Glossary Item Box

An exception generated for a string is too long error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New StringIsTooLongException()
public StringIsTooLongException()
public: StringIsTooLongException();
public:
StringIsTooLongException();

See Also

Reference

StringIsTooLongException Class
StringIsTooLongException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
StringIsTooLongException Constructor(Int32)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > StringIsTooLongException Class > StringIsTooLongException Constructor : StringIsTooLongException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a string is too long error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New StringIsTooLongException(errorNumber)
public StringIsTooLongException(
   int errorNumber
)
public: StringIsTooLongException(
   int errorNumber
)
public:
StringIsTooLongException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

StringIsTooLongException Class
StringIsTooLongException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
StringIsTooLongException Constructor(String)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > StringIsTooLongException Class > StringIsTooLongException Constructor : StringIsTooLongException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a string is too long error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New StringIsTooLongException(message)
public StringIsTooLongException(
   string message
)
public: StringIsTooLongException(
   string* message
)
public:
StringIsTooLongException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

StringIsTooLongException Class
StringIsTooLongException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
StringIsTooLongException Constructor(Int32,String)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > StringIsTooLongException Class > StringIsTooLongException Constructor : StringIsTooLongException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a string is too long error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New StringIsTooLongException(errorNumber, message)
public StringIsTooLongException(
   int errorNumber,
   string message
)
public: StringIsTooLongException(
   int errorNumber,
   string* message
)
public:
StringIsTooLongException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

StringIsTooLongException Class
StringIsTooLongException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
StringIsTooLongException Constructor(String,Exception)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > StringIsTooLongException Class > StringIsTooLongException Constructor : StringIsTooLongException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a string is too long error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New StringIsTooLongException(message, innerException)
public StringIsTooLongException(
   string message,
   Exception innerException
)
public: StringIsTooLongException(
   string* message,
   Exception* innerException
)
public:
StringIsTooLongException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

StringIsTooLongException Class
StringIsTooLongException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
TiffTagItemNotFoundException Class
Members See Also Send Feedback
Accusoft.TwainProSdk Namespace : TiffTagItemNotFoundException Class

Glossary Item Box

This exception is thrown if a TIFF tag item is not found.

Object Model

TiffTagItemNotFoundException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class TiffTagItemNotFoundException
   Inherits TwainProException
'Usage

Dim instance As TiffTagItemNotFoundException
[SerializableAttribute()]
public sealed class TiffTagItemNotFoundException : TwainProException
[SerializableAttribute()]
public __gc __sealed class TiffTagItemNotFoundException : public TwainProException
[SerializableAttribute()]
public ref class TiffTagItemNotFoundException sealed : public TwainProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.TwainProSdk.TwainProException
Accusoft.TwainProSdk.TiffTagItemNotFoundException

See Also

Reference

TiffTagItemNotFoundException Members
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.TwainPro7.Net
TiffTagItemNotFoundException Class Members
See Also Properties Methods Send Feedback
Accusoft.TwainProSdk Namespace : TiffTagItemNotFoundException Class

Glossary Item Box

The following tables list the members exposed by TiffTagItemNotFoundException.

Public Constructors

 | Name | Description
Public Constructor | TiffTagItemNotFoundException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.TwainProSdk.TwainProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

TiffTagItemNotFoundException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.TwainPro7.Net
TiffTagItemNotFoundException Class Methods
See Also Send Feedback
Accusoft.TwainProSdk Namespace : TiffTagItemNotFoundException Class

Glossary Item Box

For a list of all members of this type, see TiffTagItemNotFoundException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

TiffTagItemNotFoundException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.TwainPro7.Net
TiffTagItemNotFoundException Class Properties
See Also Send Feedback
Accusoft.TwainProSdk Namespace : TiffTagItemNotFoundException Class

Glossary Item Box

For a list of all members of this type, see TiffTagItemNotFoundException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.TwainProSdk.TwainProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

TiffTagItemNotFoundException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
TiffTagItemNotFoundException Constructor
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TiffTagItemNotFoundException Class : TiffTagItemNotFoundException Constructor

Glossary Item Box

Overload List

Overload | Description
TiffTagItemNotFoundException Constructor() | An exception generated for a TIFF tag item not found error.
TiffTagItemNotFoundException Constructor(Int32) | Generated exception for a TIFF tag item not found error with a given error number.
TiffTagItemNotFoundException Constructor(String) | Generated exception for a TIFF tag item not found error with a given string.
TiffTagItemNotFoundException Constructor(Int32,String) | Generated exception for a TIFF tag item not found error with a given error number and message.
TiffTagItemNotFoundException Constructor(String,Exception) | Generated exception for a TIFF tag item not found error with a given message and inner exception.

See Also

Reference

TiffTagItemNotFoundException Class
TiffTagItemNotFoundException Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
TiffTagItemNotFoundException Constructor()
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TiffTagItemNotFoundException Class > TiffTagItemNotFoundException Constructor : TiffTagItemNotFoundException Constructor()

Glossary Item Box

An exception generated for a TIFF tag item not found error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New TiffTagItemNotFoundException()
public TiffTagItemNotFoundException()
public: TiffTagItemNotFoundException();
public:
TiffTagItemNotFoundException();

See Also

Reference

TiffTagItemNotFoundException Class
TiffTagItemNotFoundException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
TiffTagItemNotFoundException Constructor(Int32)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TiffTagItemNotFoundException Class > TiffTagItemNotFoundException Constructor : TiffTagItemNotFoundException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a TIFF tag item not found error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New TiffTagItemNotFoundException(errorNumber)
public TiffTagItemNotFoundException(
   int errorNumber
)
public: TiffTagItemNotFoundException(
   int errorNumber
)
public:
TiffTagItemNotFoundException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

TiffTagItemNotFoundException Class
TiffTagItemNotFoundException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
TiffTagItemNotFoundException Constructor(String)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TiffTagItemNotFoundException Class > TiffTagItemNotFoundException Constructor : TiffTagItemNotFoundException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a TIFF tag item not found error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New TiffTagItemNotFoundException(message)
public TiffTagItemNotFoundException(
   string message
)
public: TiffTagItemNotFoundException(
   string* message
)
public:
TiffTagItemNotFoundException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

TiffTagItemNotFoundException Class
TiffTagItemNotFoundException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
TiffTagItemNotFoundException Constructor(Int32,String)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TiffTagItemNotFoundException Class > TiffTagItemNotFoundException Constructor : TiffTagItemNotFoundException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a TIFF tag item not found error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New TiffTagItemNotFoundException(errorNumber, message)
public TiffTagItemNotFoundException(
   int errorNumber,
   string message
)
public: TiffTagItemNotFoundException(
   int errorNumber,
   string* message
)
public:
TiffTagItemNotFoundException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

TiffTagItemNotFoundException Class
TiffTagItemNotFoundException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
TiffTagItemNotFoundException Constructor(String,Exception)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TiffTagItemNotFoundException Class > TiffTagItemNotFoundException Constructor : TiffTagItemNotFoundException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a TIFF tag item not found error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New TiffTagItemNotFoundException(message, innerException)
public TiffTagItemNotFoundException(
   string message,
   Exception innerException
)
public: TiffTagItemNotFoundException(
   string* message,
   Exception* innerException
)
public:
TiffTagItemNotFoundException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

TiffTagItemNotFoundException Class
TiffTagItemNotFoundException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
TiffTagNotFoundException Class
Members See Also Send Feedback
Accusoft.TwainProSdk Namespace : TiffTagNotFoundException Class

Glossary Item Box

This exception is thrown if a TIFF tag is not found.

Object Model

TiffTagNotFoundException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class TiffTagNotFoundException
   Inherits TwainProException
'Usage

Dim instance As TiffTagNotFoundException
[SerializableAttribute()]
public sealed class TiffTagNotFoundException : TwainProException
[SerializableAttribute()]
public __gc __sealed class TiffTagNotFoundException : public TwainProException
[SerializableAttribute()]
public ref class TiffTagNotFoundException sealed : public TwainProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.TwainProSdk.TwainProException
Accusoft.TwainProSdk.TiffTagNotFoundException

See Also

Reference

TiffTagNotFoundException Members
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.TwainPro7.Net
TiffTagNotFoundException Class Members
See Also Properties Methods Send Feedback
Accusoft.TwainProSdk Namespace : TiffTagNotFoundException Class

Glossary Item Box

The following tables list the members exposed by TiffTagNotFoundException.

Public Constructors

 | Name | Description
Public Constructor | TiffTagNotFoundException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.TwainProSdk.TwainProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

TiffTagNotFoundException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.TwainPro7.Net
TiffTagNotFoundException Class Methods
See Also Send Feedback
Accusoft.TwainProSdk Namespace : TiffTagNotFoundException Class

Glossary Item Box

For a list of all members of this type, see TiffTagNotFoundException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

TiffTagNotFoundException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.TwainPro7.Net
TiffTagNotFoundException Class Properties
See Also Send Feedback
Accusoft.TwainProSdk Namespace : TiffTagNotFoundException Class

Glossary Item Box

For a list of all members of this type, see TiffTagNotFoundException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.TwainProSdk.TwainProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

TiffTagNotFoundException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
TiffTagNotFoundException Constructor
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TiffTagNotFoundException Class : TiffTagNotFoundException Constructor

Glossary Item Box

Overload List

Overload | Description
TiffTagNotFoundException Constructor() | An exception generated for a TIFF tag not found error.
TiffTagNotFoundException Constructor(Int32) | Generated exception for a TIFF tag not found error with a given error number.
TiffTagNotFoundException Constructor(String) | Generated exception for a TIFF tag not found error with a given string.
TiffTagNotFoundException Constructor(Int32,String) | Generated exception for a TIFF tag not found error with a given error number and message.
TiffTagNotFoundException Constructor(String,Exception) | Generated exception for a TIFF tag not found error with a given message and inner exception.

See Also

Reference

TiffTagNotFoundException Class
TiffTagNotFoundException Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
TiffTagNotFoundException Constructor()
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TiffTagNotFoundException Class > TiffTagNotFoundException Constructor : TiffTagNotFoundException Constructor()

Glossary Item Box

An exception generated for a TIFF tag not found error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New TiffTagNotFoundException()
public TiffTagNotFoundException()
public: TiffTagNotFoundException();
public:
TiffTagNotFoundException();

See Also

Reference

TiffTagNotFoundException Class
TiffTagNotFoundException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
TiffTagNotFoundException Constructor(Int32)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TiffTagNotFoundException Class > TiffTagNotFoundException Constructor : TiffTagNotFoundException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a TIFF tag not found error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New TiffTagNotFoundException(errorNumber)
public TiffTagNotFoundException(
   int errorNumber
)
public: TiffTagNotFoundException(
   int errorNumber
)
public:
TiffTagNotFoundException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

TiffTagNotFoundException Class
TiffTagNotFoundException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
TiffTagNotFoundException Constructor(String)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TiffTagNotFoundException Class > TiffTagNotFoundException Constructor : TiffTagNotFoundException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a TIFF tag not found error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New TiffTagNotFoundException(message)
public TiffTagNotFoundException(
   string message
)
public: TiffTagNotFoundException(
   string* message
)
public:
TiffTagNotFoundException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

TiffTagNotFoundException Class
TiffTagNotFoundException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
TiffTagNotFoundException Constructor(Int32,String)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TiffTagNotFoundException Class > TiffTagNotFoundException Constructor : TiffTagNotFoundException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a TIFF tag not found error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New TiffTagNotFoundException(errorNumber, message)
public TiffTagNotFoundException(
   int errorNumber,
   string message
)
public: TiffTagNotFoundException(
   int errorNumber,
   string* message
)
public:
TiffTagNotFoundException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

TiffTagNotFoundException Class
TiffTagNotFoundException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
TiffTagNotFoundException Constructor(String,Exception)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TiffTagNotFoundException Class > TiffTagNotFoundException Constructor : TiffTagNotFoundException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a TIFF tag not found error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New TiffTagNotFoundException(message, innerException)
public TiffTagNotFoundException(
   string message,
   Exception innerException
)
public: TiffTagNotFoundException(
   string* message,
   Exception* innerException
)
public:
TiffTagNotFoundException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

TiffTagNotFoundException Class
TiffTagNotFoundException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
TwainDevice Class
Members See Also Send Feedback
Accusoft.TwainProSdk Namespace : TwainDevice Class

Glossary Item Box

This class implements methods and properties for all TWAIN device interaction.

Object Model

TwainDevice ClassApplicationIdentity ClassCaption ClassCapabilityContainer Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Class TwainDevice
'Usage

Dim instance As TwainDevice
public class TwainDevice
public __gc class TwainDevice
public ref class TwainDevice

Remarks

Use this object to perform all of the TWAIN tasks of this component.

Inheritance Hierarchy

System.Object
Accusoft.TwainProSdk.TwainDevice

See Also

Reference

TwainDevice Members
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.TwainPro7.Net
TwainDevice Class Members
See Also Properties Methods Events Send Feedback
Accusoft.TwainProSdk Namespace : TwainDevice Class

Glossary Item Box

The following tables list the members exposed by TwainDevice.

Public Constructors

 | Name | Description
Public Constructor | TwainDevice Constructor | Initializes the TwainPro component and passes in a workspace ID.
Top

Public Properties

 | Name | Description
Public Property | ApplicationIdentity | Returns the ApplicationIdentity properties.
Public Property | Caption | Returns the Caption properties.
Public Property | CloseOnCancel | Specifies whether the TWAIN User Interface should be closed when the operation is cancelled.
Public Property | CloseSessionAfterAcquisition | "Gets or sets a value indicating whether the session with the data source and data source manager will be closed before returning from the StartSession method."
Public Property | DataSourceManagerVersion | Specifies what version of the TWAIN Data Source Manager is used, by default it is set to LatestSupportedVersionAvailable.
Public Property | DataSourceManagerVersionInUse | Specifies what version of the TWAIN Data Source Manager is currently in use.
Public Property | EnableExtendedCapabilities | Enables the extended capabilities CAP_FEEDPAGE and CAP_CLEARPAGE.
Public Property | EnableExtendedImageInfo | Enables if extended image info attributes can be retrieved from the source.
Public Property | ImageLayout | Gets or sets the Image Layout rectangle for the current Data Source.
Public Property | MaximumImages | Gets or sets the maximum number of images expected from a TWAIN Data Source that supports multiple image scanning.
Public Property | ShowUserInterface | Gets or sets the Data Source User Interface flag.
Public Property | TransferMode | Gets or sets the transfer mode for scanning.
Top

Public Methods

 | Name | Description
Public Method | CloseSession | Disables and closes the current Data Source and Data Source Manager. For every OpenSession or OpenDataSourceManager method call you need to close the TwainPRO session with CloseSession. This method will also Cancel any pending image transfers if the Data Source was in the Image Transfer state.
Public Method | DisplayUserInterface | Displays the User Interface.
Public Method | Dispose | Disposes of unmanaged resources.
Public Method | GetCapability | Overloaded. Returns a CapabilityContainer with information for the specified capability.
Public Method | GetCapabilityConstantDescription | Returns a description of a constant for the current capability. This is a runtime, read-only property.
Public Method | GetCustomDataSourceData | Gets custom data (current settings, e.g., DPI, paper size, color format) from the source to the application. The source settings will be returned in a format that is source dependent and not defined by TWAIN.
Public Method | IsCapabilitySupported | Overloaded. Determines if the current capability is supported by the TWAIN device.
Public Method | LoadSettings | Loads the scanner settings from file.
Public Method | OpenDataSourceManager | Opens the Source Manager. Use this method only to set the Data Source without using the SelectSource method.
Public Method | OpenSession | Opens the Data Source Manager and Data Source, placing TwainPRO into the Capability Negotiation state.
Public Method | SaveSettings | Saves the scanner settings to file.
Public Method | SelectSource | Displays the TWAIN Data Source Manager's Source Selection User Interface (UI) so the user can choose which Data Source is the current Source.
Public Method | SetCapability | Sets a TWAIN capability using the specified values.
Public Method | SetCustomDataSourceData | Sets custom data (current settings, e.g., DPI, paper size, color format) of the source from the application. The source settings are in a format that is source dependent and not defined by TWAIN.
Public Method | StartSession | Enables the Current Data Source and places it into the Image Transfer state. Displays the Data Source User Interface if ShowUserInterface is True. This method will return when the user closes the UI if the ShowUserInterface property is True or after the image transfer if ShowUserInterface is False.
Top

Public Events

 | Name | Description
Public Event | Scanned | Use this event to receive ScannedEventArgs information about the event.
Public Event | Scanning | Use this event to receive ScanningEventArgs information about the event.
Top

See Also

Reference

TwainDevice Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
TwainDevice Constructor
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainDevice Class : TwainDevice Constructor

workspace
A TwainPro workspace ID.

Glossary Item Box

Initializes the TwainPro component and passes in a workspace ID.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal workspace As TwainPro _
)
'Usage

Dim workspace As TwainPro

Dim instance As New TwainDevice(workspace)
public TwainDevice(
   TwainPro workspace
)
public: TwainDevice(
   TwainPro* workspace
)
public:
TwainDevice(
   TwainPro^ workspace
)

Parameters

workspace
A TwainPro workspace ID.

See Also

Reference

TwainDevice Class
TwainDevice Members


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.TwainPro7.Net
TwainDevice Class Methods
See Also Send Feedback
Accusoft.TwainProSdk Namespace : TwainDevice Class

Glossary Item Box

For a list of all members of this type, see TwainDevice members.

Public Methods

 | Name | Description
Public Method | CloseSession | Disables and closes the current Data Source and Data Source Manager. For every OpenSession or OpenDataSourceManager method call you need to close the TwainPRO session with CloseSession. This method will also Cancel any pending image transfers if the Data Source was in the Image Transfer state.
Public Method | DisplayUserInterface | Displays the User Interface.
Public Method | Dispose | Disposes of unmanaged resources.
Public Method | GetCapability | Overloaded. Returns a CapabilityContainer with information for the specified capability.
Public Method | GetCapabilityConstantDescription | Returns a description of a constant for the current capability. This is a runtime, read-only property.
Public Method | GetCustomDataSourceData | Gets custom data (current settings, e.g., DPI, paper size, color format) from the source to the application. The source settings will be returned in a format that is source dependent and not defined by TWAIN.
Public Method | IsCapabilitySupported | Overloaded. Determines if the current capability is supported by the TWAIN device.
Public Method | LoadSettings | Loads the scanner settings from file.
Public Method | OpenDataSourceManager | Opens the Source Manager. Use this method only to set the Data Source without using the SelectSource method.
Public Method | OpenSession | Opens the Data Source Manager and Data Source, placing TwainPRO into the Capability Negotiation state.
Public Method | SaveSettings | Saves the scanner settings to file.
Public Method | SelectSource | Displays the TWAIN Data Source Manager's Source Selection User Interface (UI) so the user can choose which Data Source is the current Source.
Public Method | SetCapability | Sets a TWAIN capability using the specified values.
Public Method | SetCustomDataSourceData | Sets custom data (current settings, e.g., DPI, paper size, color format) of the source from the application. The source settings are in a format that is source dependent and not defined by TWAIN.
Public Method | StartSession | Enables the Current Data Source and places it into the Image Transfer state. Displays the Data Source User Interface if ShowUserInterface is True. This method will return when the user closes the UI if the ShowUserInterface property is True or after the image transfer if ShowUserInterface is False.
Top

See Also

Reference

TwainDevice Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
CloseSession Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainDevice Class : CloseSession Method

Glossary Item Box

Disables and closes the current Data Source and Data Source Manager. For every OpenSession or OpenDataSourceManager method call you need to close the TwainPRO session with CloseSession. This method will also Cancel any pending image transfers if the Data Source was in the Image Transfer state.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub CloseSession()
'Usage

Dim instance As TwainDevice

instance.CloseSession()
public void CloseSession()
public: void CloseSession();
public:
void CloseSession();

Remarks

The StartSession() method calls CloseSession() internally before returning if the CloseSessionAfterAcquisition property is set to true (which is the default value). In this case, it is not necessary to call CloseSession() after StartSession(). If the CloseSessionAfterAcquisition property is set to false, then the session will remain open and return to the Capability Negotiation state after StartSession().

See Also

Reference

TwainDevice Class
TwainDevice Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
DisplayUserInterface Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainDevice Class : DisplayUserInterface Method

Glossary Item Box

Displays the User Interface.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub DisplayUserInterface()
'Usage

Dim instance As TwainDevice

instance.DisplayUserInterface()
public void DisplayUserInterface()
public: void DisplayUserInterface();
public:
void DisplayUserInterface();

Remarks

Displays the Data Source's User Interface so the user can manipulate scanner settings but not acquire an image at this time.

See Also

Reference

TwainDevice Class
TwainDevice Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Dispose Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainDevice Class : Dispose Method

Glossary Item Box

Disposes of unmanaged resources.

Overload List

Overload | Description
Dispose | Disposes of unmanaged resources.

See Also

Reference

TwainDevice Class
TwainDevice Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Dispose() Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainDevice Class : Dispose() Method

Glossary Item Box

Disposes of unmanaged resources.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub Dispose()
'Usage

Dim instance As TwainDevice

instance.Dispose()
public void Dispose()
public: void Dispose();
public:
void Dispose();

Remarks

This method is part of the IDisposable interface.

See Also

Reference

TwainDevice Class
TwainDevice Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
GetCapability Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainDevice Class : GetCapability Method

Glossary Item Box

Returns a CapabilityContainer with information for the specified capability.

Overload List

Overload | Description
GetCapability(Capability) | Returns a CapabilityContainer with information for the specified capability.
GetCapability(AdvancedCapability) | Returns a CapabilityContainer with information for the specified capability.
GetCapability(Int32) | Returns a CapabilityContainer with information for the specified capability.

See Also

Reference

TwainDevice Class
TwainDevice Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
GetCapability(Capability) Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainDevice Class > GetCapability Method : GetCapability(Capability) Method

capability
The capability in which to retrieve the information

Glossary Item Box

Returns a CapabilityContainer with information for the specified capability.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Function GetCapability( _
   ByVal capability As Capability _
) As CapabilityContainer
'Usage

Dim instance As TwainDevice
Dim capability As Capability
Dim value As CapabilityContainer

value = instance.GetCapability(capability)
public CapabilityContainer GetCapability(
   Capability capability
)
public: CapabilityContainer* GetCapability(
   Capability capability
)
public:
CapabilityContainer^ GetCapability(
   Capability capability
)

Parameters

capability
The capability in which to retrieve the information

Return Value

A CapabilityContainer object

Remarks

This method will return a CapabilityContainerOneValue, CapabilityContainerEnum, CapabilityContainerRange, or CapabilityContainerArray object of type CapabilityContainer which can be casted to the appropriate child object to access the capability information.

See Also

Reference

TwainDevice Class
TwainDevice Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
GetCapability(AdvancedCapability) Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainDevice Class > GetCapability Method : GetCapability(AdvancedCapability) Method

capability
The capability in which to retrieve the information

Glossary Item Box

Returns a CapabilityContainer with information for the specified capability.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Function GetCapability( _
   ByVal capability As AdvancedCapability _
) As CapabilityContainer
'Usage

Dim instance As TwainDevice
Dim capability As AdvancedCapability
Dim value As CapabilityContainer

value = instance.GetCapability(capability)
public CapabilityContainer GetCapability(
   AdvancedCapability capability
)
public: CapabilityContainer* GetCapability(
   AdvancedCapability capability
)
public:
CapabilityContainer^ GetCapability(
   AdvancedCapability capability
)

Parameters

capability
The capability in which to retrieve the information

Return Value

A CapabilityContainer object

Remarks

This method will return a CapabilityContainerOneValue, CapabilityContainerEnum, CapabilityContainerRange, or CapabilityContainerArray object of type CapabilityContainer which can be casted to the appropriate child object to access the capability information.

See Also

Reference

TwainDevice Class
TwainDevice Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
GetCapability(Int32) Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainDevice Class > GetCapability Method : GetCapability(Int32) Method

capability
The capability in which to retrieve the information

Glossary Item Box

Returns a CapabilityContainer with information for the specified capability.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Function GetCapability( _
   ByVal capability As Integer _
) As CapabilityContainer
'Usage

Dim instance As TwainDevice
Dim capability As Integer
Dim value As CapabilityContainer

value = instance.GetCapability(capability)
public CapabilityContainer GetCapability(
   int capability
)
public: CapabilityContainer* GetCapability(
   int capability
)
public:
CapabilityContainer^ GetCapability(
   int capability
)

Parameters

capability
The capability in which to retrieve the information

Return Value

A CapabilityContainer object

Remarks

This method will return a CapabilityContainerOneValue, CapabilityContainerEnum, CapabilityContainerRange, or CapabilityContainerArray object of type CapabilityContainer which can be casted to the appropriate child object to access the capability information.

See Also

Reference

TwainDevice Class
TwainDevice Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
GetCapabilityConstantDescription Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainDevice Class : GetCapabilityConstantDescription Method

capability
A Capability.
index
The index of the Capability constant.

Glossary Item Box

Returns a description of a constant for the current capability. This is a runtime, read-only property.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function GetCapabilityConstantDescription( _
   ByVal capability As Capability, _
   ByVal index As Integer _
) As String
'Usage

Dim instance As TwainDevice
Dim capability As Capability
Dim index As Integer
Dim value As String

value = instance.GetCapabilityConstantDescription(capability, index)
public string GetCapabilityConstantDescription(
   Capability capability,
   int index
)
public: string* GetCapabilityConstantDescription(
   Capability capability,
   int index
)
public:
String^ GetCapabilityConstantDescription(
   Capability capability,
   int index
)

Parameters

capability
A Capability.
index
The index of the Capability constant.

Return Value

A description of the specified Capability constant.

Remarks

When the capability type is TWCAP_ENUM, the Source may return a list of constants that signify settings.

For example, if Capability = ICAP_PIXELTYPE, and the Source returns a TWCAP_ENUM containing the constants, TwptBW (0), TwptGray (1), TwptRgb (2) a description of each may be obtained with the GetCapabilityConstantDescription method.

TwainPRO.GetCapabilityConstantDescription( Capability.IcapPixelType, (System.Int32)CapabilityConstants.TwptBW ) would return "Black and White". This can be used for filling a listbox or combobox with descriptions of available values instead of just the constants.

See Also

Reference

TwainDevice Class
TwainDevice Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
GetCustomDataSourceData Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainDevice Class : GetCustomDataSourceData Method

customDataSourceDataFileName
A string representation of a legal file name (path) to which the custom data, which has been read from the source, will be written.

Glossary Item Box

Gets custom data (current settings, e.g., DPI, paper size, color format) from the source to the application. The source settings will be returned in a format that is source dependent and not defined by TWAIN.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub GetCustomDataSourceData( _
   ByVal customDataSourceDataFileName As String _
)
'Usage

Dim instance As TwainDevice
Dim customDataSourceDataFileName As String

instance.GetCustomDataSourceData(customDataSourceDataFileName)
public void GetCustomDataSourceData(
   string customDataSourceDataFileName
)
public: void GetCustomDataSourceData(
   string* customDataSourceDataFileName
)
public:
void GetCustomDataSourceData(
   String^ customDataSourceDataFileName
)

Parameters

customDataSourceDataFileName
A string representation of a legal file name (path) to which the custom data, which has been read from the source, will be written.

See Also

Reference

TwainDevice Class
TwainDevice Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
IsCapabilitySupported Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainDevice Class : IsCapabilitySupported Method

Glossary Item Box

Determines if the current capability is supported by the TWAIN device.

Overload List

Overload | Description
IsCapabilitySupported(Capability) | Determines if the current capability is supported by the TWAIN device.
IsCapabilitySupported(AdvancedCapability) | Determines if the current capability is supported by the TWAIN device.
IsCapabilitySupported(Int32) | Determines if the current capability is supported by the TWAIN device.

See Also

Reference

TwainDevice Class
TwainDevice Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
IsCapabilitySupported(Capability) Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainDevice Class > IsCapabilitySupported Method : IsCapabilitySupported(Capability) Method

capability
A TWAIN Capability

Glossary Item Box

Determines if the current capability is supported by the TWAIN device.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Function IsCapabilitySupported( _
   ByVal capability As Capability _
) As Boolean
'Usage

Dim instance As TwainDevice
Dim capability As Capability
Dim value As Boolean

value = instance.IsCapabilitySupported(capability)
public bool IsCapabilitySupported(
   Capability capability
)
public: bool IsCapabilitySupported(
   Capability capability
)
public:
bool IsCapabilitySupported(
   Capability capability
)

Parameters

capability
A TWAIN Capability

Return Value

Whether or not the capability is supported

Remarks

This method should be checked before calling the GetCapability method. Attempting to get a capability that isn't supported will generate an error.

See Also

Reference

TwainDevice Class
TwainDevice Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
IsCapabilitySupported(AdvancedCapability) Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainDevice Class > IsCapabilitySupported Method : IsCapabilitySupported(AdvancedCapability) Method

capability
A TWAIN Capability

Glossary Item Box

Determines if the current capability is supported by the TWAIN device.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Function IsCapabilitySupported( _
   ByVal capability As AdvancedCapability _
) As Boolean
'Usage

Dim instance As TwainDevice
Dim capability As AdvancedCapability
Dim value As Boolean

value = instance.IsCapabilitySupported(capability)
public bool IsCapabilitySupported(
   AdvancedCapability capability
)
public: bool IsCapabilitySupported(
   AdvancedCapability capability
)
public:
bool IsCapabilitySupported(
   AdvancedCapability capability
)

Parameters

capability
A TWAIN Capability

Return Value

Whether or not the capability is supported

Remarks

This method should be checked before calling the GetCapability method. Attempting to get a capability that isn't supported will generate an error.

See Also

Reference

TwainDevice Class
TwainDevice Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
IsCapabilitySupported(Int32) Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainDevice Class > IsCapabilitySupported Method : IsCapabilitySupported(Int32) Method

capability
A TWAIN Capability

Glossary Item Box

Determines if the current capability is supported by the TWAIN device.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Function IsCapabilitySupported( _
   ByVal capability As Integer _
) As Boolean
'Usage

Dim instance As TwainDevice
Dim capability As Integer
Dim value As Boolean

value = instance.IsCapabilitySupported(capability)
public bool IsCapabilitySupported(
   int capability
)
public: bool IsCapabilitySupported(
   int capability
)
public:
bool IsCapabilitySupported(
   int capability
)

Parameters

capability
A TWAIN Capability

Return Value

Whether or not the capability is supported

Remarks

This method should be checked before calling the GetCapability method. Attempting to get a capability that isn't supported will generate an error.

See Also

Reference

TwainDevice Class
TwainDevice Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
LoadSettings Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainDevice Class : LoadSettings Method

filename
A string representation of a legal file name (path) from which the settings will be loaded.

Glossary Item Box

Loads the scanner settings from file.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub LoadSettings( _
   ByVal filename As String _
)
'Usage

Dim instance As TwainDevice
Dim filename As String

instance.LoadSettings(filename)
public void LoadSettings(
   string filename
)
public: void LoadSettings(
   string* filename
)
public:
void LoadSettings(
   String^ filename
)

Parameters

filename
A string representation of a legal file name (path) from which the settings will be loaded.

Remarks

Loads scanner settings that were previously saved to file using the SaveSettings method.

Note that your scanner might not support setting all of the capabilities that are saved in the settings file. If you set the Debug property to True to write a Debug Log File, then during the LoadSettings operation all unsupported capabilities will be written to the Debug Log File.

See Also

Reference

TwainDevice Class
TwainDevice Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
OpenDataSourceManager Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainDevice Class : OpenDataSourceManager Method

Glossary Item Box

Opens the Source Manager. Use this method only to set the Data Source without using the SelectSource method.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub OpenDataSourceManager()
'Usage

Dim instance As TwainDevice

instance.OpenDataSourceManager()
public void OpenDataSourceManager()
public: void OpenDataSourceManager();
public:
void OpenDataSourceManager();

Remarks

Use this method before creating a DataSourceCollection. Then set the current data source in the collection before calling OpenSession.

See Also

Reference

TwainDevice Class
TwainDevice Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
OpenSession Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainDevice Class : OpenSession Method

Glossary Item Box

Opens the Data Source Manager and Data Source, placing TwainPRO into the Capability Negotiation state.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub OpenSession()
'Usage

Dim instance As TwainDevice

instance.OpenSession()
public void OpenSession()
public: void OpenSession();
public:
void OpenSession();

Remarks

Use this method for controlling the Data Source capabilities and Data Source UI. This Method is used in conjunction with CloseSession and the capability negotiation methods.

See Also

Reference

TwainDevice Class
TwainDevice Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
SaveSettings Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainDevice Class : SaveSettings Method

filename
A string representation of a legal file name (path) to which the settings will be saved.

Glossary Item Box

Saves the scanner settings to file.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub SaveSettings( _
   ByVal filename As String _
)
'Usage

Dim instance As TwainDevice
Dim filename As String

instance.SaveSettings(filename)
public void SaveSettings(
   string filename
)
public: void SaveSettings(
   string* filename
)
public:
void SaveSettings(
   String^ filename
)

Parameters

filename
A string representation of a legal file name (path) to which the settings will be saved.

Remarks

This method will save the settings of all settable, documented capabilities to file. A settings file contains settings for one TWAIN device, and settings for other TWAIN devices will need to be saved to separate settings files.

The LoadSettings method can be used to later load the settings from file. Note that your scanner might not support setting all of the capabilities that are saved in the settings file. If you set the Debug property to True to write a Debug Log File, then during the LoadSettings operation all unsupported capabilities will be written to the Debug Log File.

See Also

Reference

TwainDevice Class
TwainDevice Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
SelectSource Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainDevice Class : SelectSource Method

Glossary Item Box

Displays the TWAIN Data Source Manager's Source Selection User Interface (UI) so the user can choose which Data Source is the current Source.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub SelectSource()
'Usage

Dim instance As TwainDevice

instance.SelectSource()
public void SelectSource()
public: void SelectSource();
public:
void SelectSource();

Remarks

This method will close any previously opened TwainPRO session.

See Also

Reference

TwainDevice Class
TwainDevice Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
SetCapability Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainDevice Class : SetCapability Method

capabilityContainer
A CapabilityContainer with the specified values.

Glossary Item Box

Sets a TWAIN capability using the specified values.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub SetCapability( _
   ByVal capabilityContainer As CapabilityContainer _
)
'Usage

Dim instance As TwainDevice
Dim capabilityContainer As CapabilityContainer

instance.SetCapability(capabilityContainer)
public void SetCapability(
   CapabilityContainer capabilityContainer
)
public: void SetCapability(
   CapabilityContainer* capabilityContainer
)
public:
void SetCapability(
   CapabilityContainer^ capabilityContainer
)

Parameters

capabilityContainer
A CapabilityContainer with the specified values.

Remarks

The CapabilityContainerOneValue, CapabilityContainerEnum, CapabilityContainerRange, and CapabilityContainerArray objects that are inherited from CapabilityContainer can be filled with information and passed to this method to set the value of a capability.

See Also

Reference

TwainDevice Class
TwainDevice Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
SetCustomDataSourceData Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainDevice Class : SetCustomDataSourceData Method

customDataSourceDataFileName
A string representation of a legal file name (path) from which the custom data will be read in order to set the custom data of the source.

Glossary Item Box

Sets custom data (current settings, e.g., DPI, paper size, color format) of the source from the application. The source settings are in a format that is source dependent and not defined by TWAIN.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub SetCustomDataSourceData( _
   ByVal customDataSourceDataFileName As String _
)
'Usage

Dim instance As TwainDevice
Dim customDataSourceDataFileName As String

instance.SetCustomDataSourceData(customDataSourceDataFileName)
public void SetCustomDataSourceData(
   string customDataSourceDataFileName
)
public: void SetCustomDataSourceData(
   string* customDataSourceDataFileName
)
public:
void SetCustomDataSourceData(
   String^ customDataSourceDataFileName
)

Parameters

customDataSourceDataFileName
A string representation of a legal file name (path) from which the custom data will be read in order to set the custom data of the source.

See Also

Reference

TwainDevice Class
TwainDevice Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
StartSession Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainDevice Class : StartSession Method

Glossary Item Box

Enables the Current Data Source and places it into the Image Transfer state. Displays the Data Source User Interface if ShowUserInterface is True. This method will return when the user closes the UI if the ShowUserInterface property is True or after the image transfer if ShowUserInterface is False.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub StartSession()
'Usage

Dim instance As TwainDevice

instance.StartSession()
public void StartSession()
public: void StartSession();
public:
void StartSession();

Remarks

It is not necessary to call OpenSession before calling this method. All Capability Negotiation methods must be called before this method.

Before returning from this method, the session will be closed if the CloseSessionAfterAcquisition property is true. If the CloseSessionAfterAcquisition property is false, the session will remain open and return to the Capability Negotiation state."

See Also

Reference

TwainDevice Class
TwainDevice Members


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.TwainPro7.Net
TwainDevice Class Properties
See Also Send Feedback
Accusoft.TwainProSdk Namespace : TwainDevice Class

Glossary Item Box

For a list of all members of this type, see TwainDevice members.

Public Properties

 | Name | Description
Public Property | ApplicationIdentity | Returns the ApplicationIdentity properties.
Public Property | Caption | Returns the Caption properties.
Public Property | CloseOnCancel | Specifies whether the TWAIN User Interface should be closed when the operation is cancelled.
Public Property | CloseSessionAfterAcquisition | "Gets or sets a value indicating whether the session with the data source and data source manager will be closed before returning from the StartSession method."
Public Property | DataSourceManagerVersion | Specifies what version of the TWAIN Data Source Manager is used, by default it is set to LatestSupportedVersionAvailable.
Public Property | DataSourceManagerVersionInUse | Specifies what version of the TWAIN Data Source Manager is currently in use.
Public Property | EnableExtendedCapabilities | Enables the extended capabilities CAP_FEEDPAGE and CAP_CLEARPAGE.
Public Property | EnableExtendedImageInfo | Enables if extended image info attributes can be retrieved from the source.
Public Property | ImageLayout | Gets or sets the Image Layout rectangle for the current Data Source.
Public Property | MaximumImages | Gets or sets the maximum number of images expected from a TWAIN Data Source that supports multiple image scanning.
Public Property | ShowUserInterface | Gets or sets the Data Source User Interface flag.
Public Property | TransferMode | Gets or sets the transfer mode for scanning.
Top

See Also

Reference

TwainDevice Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
ApplicationIdentity Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainDevice Class : ApplicationIdentity Property

Glossary Item Box

Returns the ApplicationIdentity properties.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public ReadOnly Property ApplicationIdentity As ApplicationIdentity
'Usage

Dim instance As TwainDevice
Dim value As ApplicationIdentity

value = instance.ApplicationIdentity
[BrowsableAttribute(false)]
public ApplicationIdentity ApplicationIdentity {get;}
[BrowsableAttribute(false)]
public: __property ApplicationIdentity* get_ApplicationIdentity();
[BrowsableAttribute(false)]
public:
property ApplicationIdentity^ ApplicationIdentity {
   ApplicationIdentity^ get();
}

See Also

Reference

TwainDevice Class
TwainDevice Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Caption Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainDevice Class : Caption Property

Glossary Item Box

Returns the Caption properties.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public ReadOnly Property Caption As Caption
'Usage

Dim instance As TwainDevice
Dim value As Caption

value = instance.Caption
[BrowsableAttribute(false)]
public Caption Caption {get;}
[BrowsableAttribute(false)]
public: __property Caption* get_Caption();
[BrowsableAttribute(false)]
public:
property Caption^ Caption {
   Caption^ get();
}

See Also

Reference

TwainDevice Class
TwainDevice Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
CloseOnCancel Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainDevice Class : CloseOnCancel Property

Glossary Item Box

Specifies whether the TWAIN User Interface should be closed when the operation is cancelled.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DefaultValueAttribute()>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<DescriptionAttribute("Specifies whether the TWAIN User Interface should be closed when the operation is cancelled.")>
Public Property CloseOnCancel As Boolean
'Usage

Dim instance As TwainDevice
Dim value As Boolean

instance.CloseOnCancel = value

value = instance.CloseOnCancel
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DescriptionAttribute("Specifies whether the TWAIN User Interface should be closed when the operation is cancelled.")]
public bool CloseOnCancel {get; set;}
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DescriptionAttribute("Specifies whether the TWAIN User Interface should be closed when the operation is cancelled.")]
public: __property bool get_CloseOnCancel();
public: __property void set_CloseOnCancel(
   bool value
);
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DescriptionAttribute("Specifies whether the TWAIN User Interface should be closed when the operation is cancelled.")]
public:
property bool CloseOnCancel {
   bool get();
   void set (    bool value);
}

Remarks

If the TWAIN User Interface is shown, the CloseOnCancel property determines whether the User Interface will be closed when the user issues a cancel.

Default value: false

See Also

Reference

TwainDevice Class
TwainDevice Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
CloseSessionAfterAcquisition Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainDevice Class : CloseSessionAfterAcquisition Property

Glossary Item Box

"Gets or sets a value indicating whether the session with the data source and data source manager will be closed before returning from the StartSession method."

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DescriptionAttribute("Indicates whether the session with the data source and data source manager will be closed before returning from the StartSession method.")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<DefaultValueAttribute()>
Public Property CloseSessionAfterAcquisition As Boolean
'Usage

Dim instance As TwainDevice
Dim value As Boolean

instance.CloseSessionAfterAcquisition = value

value = instance.CloseSessionAfterAcquisition
[BrowsableAttribute(false)]
[DescriptionAttribute("Indicates whether the session with the data source and data source manager will be closed before returning from the StartSession method.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DefaultValueAttribute()]
public bool CloseSessionAfterAcquisition {get; set;}
[BrowsableAttribute(false)]
[DescriptionAttribute("Indicates whether the session with the data source and data source manager will be closed before returning from the StartSession method.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DefaultValueAttribute()]
public: __property bool get_CloseSessionAfterAcquisition();
public: __property void set_CloseSessionAfterAcquisition(
   bool value
);
[BrowsableAttribute(false)]
[DescriptionAttribute("Indicates whether the session with the data source and data source manager will be closed before returning from the StartSession method.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DefaultValueAttribute()]
public:
property bool CloseSessionAfterAcquisition {
   bool get();
   void set (    bool value);
}

See Also

Reference

TwainDevice Class
TwainDevice Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
DataSourceManagerVersion Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainDevice Class : DataSourceManagerVersion Property

Glossary Item Box

Specifies what version of the TWAIN Data Source Manager is used, by default it is set to LatestSupportedVersionAvailable.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
<DescriptionAttribute("Specifies what version of the TWAIN Data Source Manager is used.")>
Public Property DataSourceManagerVersion As DataSourceManagerVersion
'Usage

Dim instance As TwainDevice
Dim value As DataSourceManagerVersion

instance.DataSourceManagerVersion = value

value = instance.DataSourceManagerVersion
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
[DescriptionAttribute("Specifies what version of the TWAIN Data Source Manager is used.")]
public DataSourceManagerVersion DataSourceManagerVersion {get; set;}
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
[DescriptionAttribute("Specifies what version of the TWAIN Data Source Manager is used.")]
public: __property DataSourceManagerVersion get_DataSourceManagerVersion();
public: __property void set_DataSourceManagerVersion(
   DataSourceManagerVersion value
);
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
[DescriptionAttribute("Specifies what version of the TWAIN Data Source Manager is used.")]
public:
property DataSourceManagerVersion DataSourceManagerVersion {
   DataSourceManagerVersion get();
   void set (    DataSourceManagerVersion value);
}

See Also

Reference

TwainDevice Class
TwainDevice Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
DataSourceManagerVersionInUse Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainDevice Class : DataSourceManagerVersionInUse Property

Glossary Item Box

Specifies what version of the TWAIN Data Source Manager is currently in use.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<DescriptionAttribute("Specifies what version of the TWAIN Data Source Manager is currently in use.")>
Public ReadOnly Property DataSourceManagerVersionInUse As DataSourceManagerVersion
'Usage

Dim instance As TwainDevice
Dim value As DataSourceManagerVersion

value = instance.DataSourceManagerVersionInUse
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DescriptionAttribute("Specifies what version of the TWAIN Data Source Manager is currently in use.")]
public DataSourceManagerVersion DataSourceManagerVersionInUse {get;}
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DescriptionAttribute("Specifies what version of the TWAIN Data Source Manager is currently in use.")]
public: __property DataSourceManagerVersion get_DataSourceManagerVersionInUse();
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DescriptionAttribute("Specifies what version of the TWAIN Data Source Manager is currently in use.")]
public:
property DataSourceManagerVersion DataSourceManagerVersionInUse {
   DataSourceManagerVersion get();
}

See Also

Reference

TwainDevice Class
TwainDevice Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
EnableExtendedCapabilities Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainDevice Class : EnableExtendedCapabilities Property

Glossary Item Box

Enables the extended capabilities CAP_FEEDPAGE and CAP_CLEARPAGE.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DescriptionAttribute("Enables the extended capabilities TWCAP_FEEDPAGE and TWCAP_CLEARPAGE.")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<DefaultValueAttribute()>
Public Property EnableExtendedCapabilities As Boolean
'Usage

Dim instance As TwainDevice
Dim value As Boolean

instance.EnableExtendedCapabilities = value

value = instance.EnableExtendedCapabilities
[BrowsableAttribute(false)]
[DescriptionAttribute("Enables the extended capabilities TWCAP_FEEDPAGE and TWCAP_CLEARPAGE.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DefaultValueAttribute()]
public bool EnableExtendedCapabilities {get; set;}
[BrowsableAttribute(false)]
[DescriptionAttribute("Enables the extended capabilities TWCAP_FEEDPAGE and TWCAP_CLEARPAGE.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DefaultValueAttribute()]
public: __property bool get_EnableExtendedCapabilities();
public: __property void set_EnableExtendedCapabilities(
   bool value
);
[BrowsableAttribute(false)]
[DescriptionAttribute("Enables the extended capabilities TWCAP_FEEDPAGE and TWCAP_CLEARPAGE.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DefaultValueAttribute()]
public:
property bool EnableExtendedCapabilities {
   bool get();
   void set (    bool value);
}

Remarks

This property was added for some non-compliant TWAIN drivers that don’t properly handle a query for support of extended capabilities. If you do not plan on using these Caps, then set this property to False.

Default value: true

See Also

Reference

TwainDevice Class
TwainDevice Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
EnableExtendedImageInfo Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainDevice Class : EnableExtendedImageInfo Property

Glossary Item Box

Enables if extended image info attributes can be retrieved from the source.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
<DescriptionAttribute("Enables if extended image info attributes can be retrieved from the source.")>
<DefaultValueAttribute()>
Public Property EnableExtendedImageInfo As Boolean
'Usage

Dim instance As TwainDevice
Dim value As Boolean

instance.EnableExtendedImageInfo = value

value = instance.EnableExtendedImageInfo
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
[DescriptionAttribute("Enables if extended image info attributes can be retrieved from the source.")]
[DefaultValueAttribute()]
public bool EnableExtendedImageInfo {get; set;}
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
[DescriptionAttribute("Enables if extended image info attributes can be retrieved from the source.")]
[DefaultValueAttribute()]
public: __property bool get_EnableExtendedImageInfo();
public: __property void set_EnableExtendedImageInfo(
   bool value
);
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
[DescriptionAttribute("Enables if extended image info attributes can be retrieved from the source.")]
[DefaultValueAttribute()]
public:
property bool EnableExtendedImageInfo {
   bool get();
   void set (    bool value);
}

See Also

Reference

TwainDevice Class
TwainDevice Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
ImageLayout Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainDevice Class : ImageLayout Property

Glossary Item Box

Gets or sets the Image Layout rectangle for the current Data Source.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DescriptionAttribute("Gets or sets the Image Layout rectangle for the current Data Source.")>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property ImageLayout As RectangleF
'Usage

Dim instance As TwainDevice
Dim value As RectangleF

instance.ImageLayout = value

value = instance.ImageLayout
[DescriptionAttribute("Gets or sets the Image Layout rectangle for the current Data Source.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public RectangleF ImageLayout {get; set;}
[DescriptionAttribute("Gets or sets the Image Layout rectangle for the current Data Source.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property RectangleF get_ImageLayout();
public: __property void set_ImageLayout(
   RectangleF value
);
[DescriptionAttribute("Gets or sets the Image Layout rectangle for the current Data Source.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property RectangleF ImageLayout {
   RectangleF get();
   void set (    RectangleF value);
}

Remarks

The Image Layout rectangle defines what portion of the Data Source's scanning area is acquired.

Call this method after OpenSession and before StartSession.

See Also

Reference

TwainDevice Class
TwainDevice Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
MaximumImages Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainDevice Class : MaximumImages Property

Glossary Item Box

Gets or sets the maximum number of images expected from a TWAIN Data Source that supports multiple image scanning.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DefaultValueAttribute()>
<DescriptionAttribute("Gets or sets the maximum number of images expected from a TWAIN Data Source that supports multiple image scanning.")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
Public Property MaximumImages As Integer
'Usage

Dim instance As TwainDevice
Dim value As Integer

instance.MaximumImages = value

value = instance.MaximumImages
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the maximum number of images expected from a TWAIN Data Source that supports multiple image scanning.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public int MaximumImages {get; set;}
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the maximum number of images expected from a TWAIN Data Source that supports multiple image scanning.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public: __property int get_MaximumImages();
public: __property void set_MaximumImages(
   int value
);
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the maximum number of images expected from a TWAIN Data Source that supports multiple image scanning.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public:
property int MaximumImages {
   int get();
   void set (    int value);
}

Remarks

The MaximumImages property is negotiated with the TWAIN Data Source during initialization (OpenSession) and should be set prior to invoking the OpenSession method.

This property is only used when the OpenSession method is invoked. To set the transfer count after calling OpenSession, use the CAP_XFERCOUNT capability.

A value of –1 indicates the application is willing to transfer multiple images.

A value of 1 indicates the application wishes to transfer only one image per session.

Default value: -1

See Also

Reference

TwainDevice Class
TwainDevice Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
ShowUserInterface Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainDevice Class : ShowUserInterface Property

Glossary Item Box

Gets or sets the Data Source User Interface flag.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<DefaultValueAttribute()>
<DescriptionAttribute("Gets or sets the Data Source User Interface flag.")>
Public Property ShowUserInterface As Boolean
'Usage

Dim instance As TwainDevice
Dim value As Boolean

instance.ShowUserInterface = value

value = instance.ShowUserInterface
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the Data Source User Interface flag.")]
public bool ShowUserInterface {get; set;}
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the Data Source User Interface flag.")]
public: __property bool get_ShowUserInterface();
public: __property void set_ShowUserInterface(
   bool value
);
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the Data Source User Interface flag.")]
public:
property bool ShowUserInterface {
   bool get();
   void set (    bool value);
}

Remarks

When ShowUserInterface is set to True the TWAIN Data Source will display its User Interface when invoking the StartSession method. If ShowUserInterface is set to False the Data Source UI will not be displayed and scanning will begin immediately using the current capability values.

Default value: true

See Also

Reference

TwainDevice Class
TwainDevice Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
TransferMode Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainDevice Class : TransferMode Property

Glossary Item Box

Gets or sets the transfer mode for scanning.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DefaultValueAttribute()>
<BrowsableAttribute(False)>
<DescriptionAttribute("Gets or sets the transfer mode for scanning.")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property TransferMode As TransferMode
'Usage

Dim instance As TwainDevice
Dim value As TransferMode

instance.TransferMode = value

value = instance.TransferMode
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
[DescriptionAttribute("Gets or sets the transfer mode for scanning.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public TransferMode TransferMode {get; set;}
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
[DescriptionAttribute("Gets or sets the transfer mode for scanning.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property TransferMode get_TransferMode();
public: __property void set_TransferMode(
   TransferMode value
);
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
[DescriptionAttribute("Gets or sets the transfer mode for scanning.")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property TransferMode TransferMode {
   TransferMode get();
   void set (    TransferMode value);
}

Remarks

The TransferMode property is used to set or obtain the current method of transferring images from the Data Source. The TransferMode should be set to the value desired prior to a call to the OpenSession or StartSession methods. The default TransferMode of the TwainPRO control is the Native transfer mode. TransferMode is available at runtime only.

NOTE: Transferring of compressed data directly from a Data Source requires that buffered memory mode, TWSX_MEMORY, be used.

Default value: TwsxNative

See Also

Reference

TwainDevice Class
TwainDevice Members


%%PageItemTitle%% $$Events$$

[image]
Accusoft.TwainPro7.Net
TwainDevice Class Events
See Also Send Feedback
Accusoft.TwainProSdk Namespace : TwainDevice Class

Glossary Item Box

For a list of all members of this type, see TwainDevice members.

Public Events

 | Name | Description
Public Event | Scanned | Use this event to receive ScannedEventArgs information about the event.
Public Event | Scanning | Use this event to receive ScanningEventArgs information about the event.
Top

See Also

Reference

TwainDevice Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Scanned Event
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainDevice Class : Scanned Event

Glossary Item Box

Use this event to receive ScannedEventArgs information about the event.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Event Scanned As ScannedEventHandler
'Usage

Dim instance As TwainDevice
Dim handler As ScannedEventHandler

AddHandler instance.Scanned, handler
public event ScannedEventHandler Scanned
public: __event ScannedEventHandler* Scanned
public:
event ScannedEventHandler^ Scanned

Event Data

The event handler receives an argument of type ScannedEventArgs containing data related to this event. The following ScannedEventArgs properties provide information specific to this event.

Property | Description
Cancel | Gets and sets a cancel on the session. If set to true, the session ends and the StartSession method returns control.
PendingTransfers | Gets the number of image transfers the TWAIN Data Source is ready to supply to the TwainPRO control.
ScannedImage | Gets and sets the scanned image and image information.

See Also

Reference

TwainDevice Class
TwainDevice Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Scanning Event
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainDevice Class : Scanning Event

Glossary Item Box

Use this event to receive ScanningEventArgs information about the event.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Event Scanning As ScanningEventHandler
'Usage

Dim instance As TwainDevice
Dim handler As ScanningEventHandler

AddHandler instance.Scanning, handler
public event ScanningEventHandler Scanning
public: __event ScanningEventHandler* Scanning
public:
event ScanningEventHandler^ Scanning

Event Data

The event handler receives an argument of type ScanningEventArgs containing data related to this event. The following ScanningEventArgs properties provide information specific to this event.

Property | Description
Cancel | Gets and sets an indicator whether to cancel the session.
PendingTransfers | Gets the number of image transfers the TWAIN Data Source is ready to supply to the TwainPRO control.
ScannedImageData | Gets and sets the scanned image information.

See Also

Reference

TwainDevice Class
TwainDevice Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
TwainDllLoadException Class
Members See Also Send Feedback
Accusoft.TwainProSdk Namespace : TwainDllLoadException Class

Glossary Item Box

This exception is thrown if TwainPRO is unable to find or load TWAINDSM.dll.

Object Model

TwainDllLoadException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class TwainDllLoadException
   Inherits TwainProException
'Usage

Dim instance As TwainDllLoadException
[SerializableAttribute()]
public sealed class TwainDllLoadException : TwainProException
[SerializableAttribute()]
public __gc __sealed class TwainDllLoadException : public TwainProException
[SerializableAttribute()]
public ref class TwainDllLoadException sealed : public TwainProException

Remarks

The 32-bit version of this file should be installed in the SYSTEM32 directory on native 32-bit Windows systems. On native 64-bit Windows systems, the 32-bit version of this file should be installed in the SYSWOW64 directory and the 64-bit version should be installed in the SYSTEM32 directory. The latest version of this file can be found at http://www.twain.org.

Possible causes:

The file is missing.

The file is in use by another application.

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.TwainProSdk.TwainProException
Accusoft.TwainProSdk.TwainDllLoadException

See Also

Reference

TwainDllLoadException Members
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.TwainPro7.Net
TwainDllLoadException Class Members
See Also Properties Methods Send Feedback
Accusoft.TwainProSdk Namespace : TwainDllLoadException Class

Glossary Item Box

The following tables list the members exposed by TwainDllLoadException.

Public Constructors

 | Name | Description
Public Constructor | TwainDllLoadException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.TwainProSdk.TwainProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

TwainDllLoadException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.TwainPro7.Net
TwainDllLoadException Class Methods
See Also Send Feedback
Accusoft.TwainProSdk Namespace : TwainDllLoadException Class

Glossary Item Box

For a list of all members of this type, see TwainDllLoadException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

TwainDllLoadException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.TwainPro7.Net
TwainDllLoadException Class Properties
See Also Send Feedback
Accusoft.TwainProSdk Namespace : TwainDllLoadException Class

Glossary Item Box

For a list of all members of this type, see TwainDllLoadException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.TwainProSdk.TwainProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

TwainDllLoadException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
TwainDllLoadException Constructor
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainDllLoadException Class : TwainDllLoadException Constructor

Glossary Item Box

Overload List

Overload | Description
TwainDllLoadException Constructor() | An exception generated for a DLL load error.
TwainDllLoadException Constructor(Int32) | Generated exception for a DLL load error with a given error number.
TwainDllLoadException Constructor(String) | Generated exception for a DLL load error with a given string.
TwainDllLoadException Constructor(Int32,String) | Generated exception for a DLL load error with a given error number and message.
TwainDllLoadException Constructor(String,Exception) | Generated exception for a DLL load error with a given message and inner exception.

See Also

Reference

TwainDllLoadException Class
TwainDllLoadException Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
TwainDllLoadException Constructor()
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainDllLoadException Class > TwainDllLoadException Constructor : TwainDllLoadException Constructor()

Glossary Item Box

An exception generated for a DLL load error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New TwainDllLoadException()
public TwainDllLoadException()
public: TwainDllLoadException();
public:
TwainDllLoadException();

See Also

Reference

TwainDllLoadException Class
TwainDllLoadException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
TwainDllLoadException Constructor(Int32)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainDllLoadException Class > TwainDllLoadException Constructor : TwainDllLoadException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a DLL load error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New TwainDllLoadException(errorNumber)
public TwainDllLoadException(
   int errorNumber
)
public: TwainDllLoadException(
   int errorNumber
)
public:
TwainDllLoadException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

TwainDllLoadException Class
TwainDllLoadException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
TwainDllLoadException Constructor(String)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainDllLoadException Class > TwainDllLoadException Constructor : TwainDllLoadException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a DLL load error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New TwainDllLoadException(message)
public TwainDllLoadException(
   string message
)
public: TwainDllLoadException(
   string* message
)
public:
TwainDllLoadException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

TwainDllLoadException Class
TwainDllLoadException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
TwainDllLoadException Constructor(Int32,String)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainDllLoadException Class > TwainDllLoadException Constructor : TwainDllLoadException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a DLL load error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New TwainDllLoadException(errorNumber, message)
public TwainDllLoadException(
   int errorNumber,
   string message
)
public: TwainDllLoadException(
   int errorNumber,
   string* message
)
public:
TwainDllLoadException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

TwainDllLoadException Class
TwainDllLoadException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
TwainDllLoadException Constructor(String,Exception)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainDllLoadException Class > TwainDllLoadException Constructor : TwainDllLoadException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a DLL load error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New TwainDllLoadException(message, innerException)
public TwainDllLoadException(
   string message,
   Exception innerException
)
public: TwainDllLoadException(
   string* message,
   Exception* innerException
)
public:
TwainDllLoadException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

TwainDllLoadException Class
TwainDllLoadException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
TwainException Class
Members See Also Send Feedback
Accusoft.TwainProSdk Namespace : TwainException Class

Glossary Item Box

This exception is thrown if a TWAIN error occurs.

Object Model

TwainException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class TwainException
   Inherits TwainProException
'Usage

Dim instance As TwainException
[SerializableAttribute()]
public sealed class TwainException : TwainProException
[SerializableAttribute()]
public __gc __sealed class TwainException : public TwainProException
[SerializableAttribute()]
public ref class TwainException sealed : public TwainProException

Remarks

The Data Source has returned an error. Check the ConditionCode and ConditionDescription properties to see if the Data Source has returned an error code.

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.TwainProSdk.TwainProException
Accusoft.TwainProSdk.TwainException

See Also

Reference

TwainException Members
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.TwainPro7.Net
TwainException Class Members
See Also Properties Methods Send Feedback
Accusoft.TwainProSdk Namespace : TwainException Class

Glossary Item Box

The following tables list the members exposed by TwainException.

Public Constructors

 | Name | Description
Public Constructor | TwainException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | ConditionCode | Gets additional TWAIN error information from the Data Source.
Public Property | ConditionDescription | Gets additional TWAIN error information from the Data Source.
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.TwainProSdk.TwainProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

TwainException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.TwainPro7.Net
TwainException Class Methods
See Also Send Feedback
Accusoft.TwainProSdk Namespace : TwainException Class

Glossary Item Box

For a list of all members of this type, see TwainException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

TwainException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
TwainException Constructor
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainException Class : TwainException Constructor

Glossary Item Box

Overload List

Overload | Description
TwainException Constructor() | An exception generated for a TWAIN error.
TwainException Constructor(Int32) | Thrown for a TWAIN error with a given error number.
TwainException Constructor(String) | Thrown for a TWAIN error with a given error message.
TwainException Constructor(Int32,String) | Generated exception for a TWAIN error with a given error number and message.
TwainException Constructor(String,Exception) | Generated exception for a TWAIN error with a given message and inner exception.

See Also

Reference

TwainException Class
TwainException Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
TwainException Constructor()
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainException Class > TwainException Constructor : TwainException Constructor()

Glossary Item Box

An exception generated for a TWAIN error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New TwainException()
public TwainException()
public: TwainException();
public:
TwainException();

See Also

Reference

TwainException Class
TwainException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
TwainException Constructor(Int32)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainException Class > TwainException Constructor : TwainException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Thrown for a TWAIN error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New TwainException(errorNumber)
public TwainException(
   int errorNumber
)
public: TwainException(
   int errorNumber
)
public:
TwainException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

TwainException Class
TwainException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
TwainException Constructor(String)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainException Class > TwainException Constructor : TwainException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Thrown for a TWAIN error with a given error message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New TwainException(message)
public TwainException(
   string message
)
public: TwainException(
   string* message
)
public:
TwainException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

TwainException Class
TwainException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
TwainException Constructor(Int32,String)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainException Class > TwainException Constructor : TwainException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a TWAIN error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New TwainException(errorNumber, message)
public TwainException(
   int errorNumber,
   string message
)
public: TwainException(
   int errorNumber,
   string* message
)
public:
TwainException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

TwainException Class
TwainException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
TwainException Constructor(String,Exception)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainException Class > TwainException Constructor : TwainException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a TWAIN error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New TwainException(message, innerException)
public TwainException(
   string message,
   Exception innerException
)
public: TwainException(
   string* message,
   Exception* innerException
)
public:
TwainException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

TwainException Class
TwainException Members
Overload List


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.TwainPro7.Net
TwainException Class Properties
See Also Send Feedback
Accusoft.TwainProSdk Namespace : TwainException Class

Glossary Item Box

For a list of all members of this type, see TwainException members.

Public Properties

 | Name | Description
Public Property | ConditionCode | Gets additional TWAIN error information from the Data Source.
Public Property | ConditionDescription | Gets additional TWAIN error information from the Data Source.
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.TwainProSdk.TwainProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

TwainException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
ConditionCode Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainException Class : ConditionCode Property

Glossary Item Box

Gets additional TWAIN error information from the Data Source.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property ConditionCode As ConditionCode
'Usage

Dim instance As TwainException
Dim value As ConditionCode

value = instance.ConditionCode
public ConditionCode ConditionCode {get;}
public: __property ConditionCode get_ConditionCode();
public:
property ConditionCode ConditionCode {
   ConditionCode get();
}

Property Value

A value which represents the condition code from the data source.

Remarks

The default value is 0.

See Also

Reference

TwainException Class
TwainException Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
ConditionDescription Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainException Class : ConditionDescription Property

Glossary Item Box

Gets additional TWAIN error information from the Data Source.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property ConditionDescription As String
'Usage

Dim instance As TwainException
Dim value As String

value = instance.ConditionDescription
public string ConditionDescription {get;}
public: __property string* get_ConditionDescription();
public:
property String^ ConditionDescription {
   String^ get();
}

Property Value

A string value which represents the condition description information from the data source.

Remarks

The default value is an empty string "".

See Also

Reference

TwainException Class
TwainException Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
TwainPro Class
Members See Also Send Feedback
Accusoft.TwainProSdk Namespace : TwainPro Class

Glossary Item Box

The main object for this component.

Object Model

TwainPro ClassLicensing Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<ToolboxBitmapAttribute()>
Public Class TwainPro
   Inherits System.ComponentModel.Component
'Usage

Dim instance As TwainPro
[ToolboxBitmapAttribute()]
public class TwainPro : System.ComponentModel.Component
[ToolboxBitmapAttribute()]
public __gc class TwainPro : public System.ComponentModel.Component
[ToolboxBitmapAttribute()]
public ref class TwainPro : public System.ComponentModel.Component

Remarks

This object is the primary place to perform component-level operations, such as setting licensing information, controlling the debug log, and displaying the toolkit about box.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Accusoft.TwainProSdk.TwainPro

See Also

Reference

TwainPro Members
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.TwainPro7.Net
TwainPro Class Members
See Also Properties Methods Events Send Feedback
Accusoft.TwainProSdk Namespace : TwainPro Class

Glossary Item Box

The following tables list the members exposed by TwainPro.

Public Constructors

 | Name | Description
Public Constructor | TwainPro Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Debug | Gets or sets an indicator which determines if the component writes information to a DebugLogFile or not.
Public Property | DebugLogFile | Gets or sets the filename of the debug log file.
Public Property | ErrorLevel | Gets or sets the error level of items that the component should write to the debug log file.
Public Property | Licensing | Gets and sets access to an object you can use to provide licensing information to the component.
Public Property | ParentWindowHandle | Gets and sets a window to the TwainPRO object.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Version | Returns the version of the TwainPro control at run-time.
Top

Public Methods

 | Name | Description
Public Method | AboutBox | Displays the toolkit about box.
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose() | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

TwainPro Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Events$$

[image]
Accusoft.TwainPro7.Net
TwainPro Class Events
See Also Send Feedback
Accusoft.TwainProSdk Namespace : TwainPro Class

Glossary Item Box

For a list of all members of this type, see TwainPro members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

TwainPro Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
TwainPro Constructor
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainPro Class : TwainPro Constructor

Glossary Item Box

Overload List

Overload | Description
TwainPro Constructor() | Initializes a new instance of the TwainPro class.
TwainPro Constructor(IContainer) | Initializes a new instance of the TwainPro class passing in a System.ComponentModel.IContainer.

See Also

Reference

TwainPro Class
TwainPro Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
TwainPro Constructor()
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainPro Class > TwainPro Constructor : TwainPro Constructor()

Glossary Item Box

Initializes a new instance of the TwainPro class.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New TwainPro()
public TwainPro()
public: TwainPro();
public:
TwainPro();

See Also

Reference

TwainPro Class
TwainPro Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
TwainPro Constructor(IContainer)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainPro Class > TwainPro Constructor : TwainPro Constructor(IContainer)

container
A container for the TwainPro data.

Glossary Item Box

Initializes a new instance of the TwainPro class passing in a System.ComponentModel.IContainer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal container As IContainer _
)
'Usage

Dim container As IContainer

Dim instance As New TwainPro(container)
public TwainPro(
   IContainer container
)
public: TwainPro(
   IContainer* container
)
public:
TwainPro(
   IContainer^ container
)

Parameters

container
A container for the TwainPro data.

See Also

Reference

TwainPro Class
TwainPro Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.TwainPro7.Net
TwainPro Class Methods
See Also Send Feedback
Accusoft.TwainProSdk Namespace : TwainPro Class

Glossary Item Box

For a list of all members of this type, see TwainPro members.

Public Methods

 | Name | Description
Public Method | AboutBox | Displays the toolkit about box.
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose() | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

TwainPro Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
AboutBox Method
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainPro Class : AboutBox Method

Glossary Item Box

Displays the toolkit about box.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub AboutBox()
'Usage

Dim instance As TwainPro

instance.AboutBox()
public void AboutBox()
public: void AboutBox();
public:
void AboutBox();

Remarks

This method displays an about box for the toolkit. It includes useful information, such as the name and version of the toolkit, copyright dates, and links to Accusoft Corporation's web site.

Example

...

// Call the AboutBox method

tp.AboutBox();

...

See Also

Reference

TwainPro Class
TwainPro Members


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.TwainPro7.Net
TwainPro Class Properties
See Also Send Feedback
Accusoft.TwainProSdk Namespace : TwainPro Class

Glossary Item Box

For a list of all members of this type, see TwainPro members.

Public Properties

 | Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Debug | Gets or sets an indicator which determines if the component writes information to a DebugLogFile or not.
Public Property | DebugLogFile | Gets or sets the filename of the debug log file.
Public Property | ErrorLevel | Gets or sets the error level of items that the component should write to the debug log file.
Public Property | Licensing | Gets and sets access to an object you can use to provide licensing information to the component.
Public Property | ParentWindowHandle | Gets and sets a window to the TwainPRO object.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Version | Returns the version of the TwainPro control at run-time.
Top

See Also

Reference

TwainPro Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Debug Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainPro Class : Debug Property

Glossary Item Box

Gets or sets an indicator which determines if the component writes information to a DebugLogFile or not.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
Public Property Debug As Boolean
'Usage

Dim instance As TwainPro
Dim value As Boolean

instance.Debug = value

value = instance.Debug
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public bool Debug {get; set;}
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public: __property bool get_Debug();
public: __property void set_Debug(
   bool value
);
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public:
property bool Debug {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true if the component writes data to a debug log file. Otherwise, false is returned.

Remarks

This property allows you to turn the debug log file on or off without changing any of the other debug settings. When this value is true, the component will write items to the debug log file, as specified by the DebugLogFile and ErrorLevel properties.

Default value: false

Example

...

// Set Debug to true for logging to be performed

tp.Debug = true;

...

See Also

Reference

TwainPro Class
TwainPro Members
DebugLogFile Property
ErrorLevel Property
DebugLogFile Property
ErrorLevel Property


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
DebugLogFile Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainPro Class : DebugLogFile Property

Glossary Item Box

Gets or sets the filename of the debug log file.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property DebugLogFile As String
'Usage

Dim instance As TwainPro
Dim value As String

instance.DebugLogFile = value

value = instance.DebugLogFile
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public string DebugLogFile {get; set;}
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property string* get_DebugLogFile();
public: __property void set_DebugLogFile(
   string* value
);
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property String^ DebugLogFile {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value which represents the full path and name of the debug log file.

Remarks

This property allows you to control the location of the debug log file.

Valid value: Any valid filename.

Default value: "Temp\TwainPro7.log"

Note: This property will have no effect if you set the Debug property to false.

Example

...

// Set the DebugLogFile path and name

tp.DebugLogFile = "c:\logFile.txt";

...

See Also

Reference

TwainPro Class
TwainPro Members
Debug Property
ErrorLevel Property


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
ErrorLevel Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainPro Class : ErrorLevel Property

Glossary Item Box

Gets or sets the error level of items that the component should write to the debug log file.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
Public Property ErrorLevel As ErrorLevel
'Usage

Dim instance As TwainPro
Dim value As ErrorLevel

instance.ErrorLevel = value

value = instance.ErrorLevel
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public ErrorLevel ErrorLevel {get; set;}
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public: __property ErrorLevel get_ErrorLevel();
public: __property void set_ErrorLevel(
   ErrorLevel value
);
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public:
property ErrorLevel ErrorLevel {
   ErrorLevel get();
   void set (    ErrorLevel value);
}

Property Value

The ErrorLevel enumeration value set.

Remarks

The default value is Production.

This property allows you to control the amount of information that the component places into the DebugLogFile. Since it is expensive to generate and write debug log items, set this property to write the least amount of information that you will find useful.

Valid values: Production, Development, and Detailed.

Note: This property will have no effect if the Debug property is set to false.

Example

...

// Set the ErrorLevel of the debugging

tp.ErrorLevel = Accusoft.TwainProSdk.ErrorLevel.Development;

...

See Also

Reference

TwainPro Class
TwainPro Members
DebugLogFile Property
Debug Property


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Licensing Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainPro Class : Licensing Property

Glossary Item Box

Gets and sets access to an object you can use to provide licensing information to the component.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public ReadOnly Property Licensing As Licensing
'Usage

Dim instance As TwainPro
Dim value As Licensing

value = instance.Licensing
[BrowsableAttribute(false)]
public Licensing Licensing {get;}
[BrowsableAttribute(false)]
public: __property Licensing* get_Licensing();
[BrowsableAttribute(false)]
public:
property Licensing^ Licensing {
   Licensing^ get();
}

Property Value

The Licensing object which contains the component licensing information.

Remarks

This property holds a reference to a Licensing object. You can use that object to send your licensing information to the component.

Example

...

// Set the License EvaluationMode

tp.Licensing.EvaluationMode = Accusoft.TwainProSdk.EvaluationMode.Automatic;

...

See Also

Reference

TwainPro Class
TwainPro Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
ParentWindowHandle Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainPro Class : ParentWindowHandle Property

Glossary Item Box

Gets and sets a window to the TwainPRO object.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
<DescriptionAttribute("Provides a window to the TwainPRO object.")>
Public Property ParentWindowHandle As IntPtr
'Usage

Dim instance As TwainPro
Dim value As IntPtr

instance.ParentWindowHandle = value

value = instance.ParentWindowHandle
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
[DescriptionAttribute("Provides a window to the TwainPRO object.")]
public IntPtr ParentWindowHandle {get; set;}
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
[DescriptionAttribute("Provides a window to the TwainPRO object.")]
public: __property IntPtr get_ParentWindowHandle();
public: __property void set_ParentWindowHandle(
   IntPtr value
);
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
[DescriptionAttribute("Provides a window to the TwainPRO object.")]
public:
property IntPtr ParentWindowHandle {
   IntPtr get();
   void set (    IntPtr value);
}

Property Value

An integer pointer which represents a handle to the parent window.

Remarks

A window is created internally when using the .NET version of TwainPRO, so it is not necessary to set this property.

Note: Set this value to the current window's handle and the Data Source Manager's dialog will be displayed modally (the Data Source Manager dialog is displayed as a result of calling SelectSource()). Otherwise the dialog is displayed modeless. This value should be set before the TwainDevice is created.

See Also

Reference

TwainPro Class
TwainPro Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Version Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainPro Class : Version Property

Glossary Item Box

Returns the version of the TwainPro control at run-time.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public ReadOnly Property Version As String
'Usage

Dim instance As TwainPro
Dim value As String

value = instance.Version
[BrowsableAttribute(false)]
public string Version {get;}
[BrowsableAttribute(false)]
public: __property string* get_Version();
[BrowsableAttribute(false)]
public:
property String^ Version {
   String^ get();
}

See Also

Reference

TwainPro Class
TwainPro Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
TwainProCompressedImageOnlyException Class
Members See Also Send Feedback
Accusoft.TwainProSdk Namespace : TwainProCompressedImageOnlyException Class

Glossary Item Box

This exception is thrown for trying to save the source-compressed image when no hardware compression was used and only the TwainPro-compressed image is available.

Object Model

TwainProCompressedImageOnlyException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class TwainProCompressedImageOnlyException
   Inherits TwainProException
'Usage

Dim instance As TwainProCompressedImageOnlyException
[SerializableAttribute()]
public sealed class TwainProCompressedImageOnlyException : TwainProException
[SerializableAttribute()]
public __gc __sealed class TwainProCompressedImageOnlyException : public TwainProException
[SerializableAttribute()]
public ref class TwainProCompressedImageOnlyException sealed : public TwainProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.TwainProSdk.TwainProException
Accusoft.TwainProSdk.TwainProCompressedImageOnlyException

See Also

Reference

TwainProCompressedImageOnlyException Members
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.TwainPro7.Net
TwainProCompressedImageOnlyException Class Members
See Also Properties Methods Send Feedback
Accusoft.TwainProSdk Namespace : TwainProCompressedImageOnlyException Class

Glossary Item Box

The following tables list the members exposed by TwainProCompressedImageOnlyException.

Public Constructors

 | Name | Description
Public Constructor | TwainProCompressedImageOnlyException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.TwainProSdk.TwainProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

TwainProCompressedImageOnlyException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.TwainPro7.Net
TwainProCompressedImageOnlyException Class Methods
See Also Send Feedback
Accusoft.TwainProSdk Namespace : TwainProCompressedImageOnlyException Class

Glossary Item Box

For a list of all members of this type, see TwainProCompressedImageOnlyException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

TwainProCompressedImageOnlyException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.TwainPro7.Net
TwainProCompressedImageOnlyException Class Properties
See Also Send Feedback
Accusoft.TwainProSdk Namespace : TwainProCompressedImageOnlyException Class

Glossary Item Box

For a list of all members of this type, see TwainProCompressedImageOnlyException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.TwainProSdk.TwainProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

TwainProCompressedImageOnlyException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
TwainProCompressedImageOnlyException Constructor
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainProCompressedImageOnlyException Class : TwainProCompressedImageOnlyException Constructor

Glossary Item Box

Overload List

Overload | Description
TwainProCompressedImageOnlyException Constructor() | This exception is thrown for trying to save the source-compressed image when no hardware compression was used and only the TwainPro-compressed image is available.
TwainProCompressedImageOnlyException Constructor(Int32) | This exception is thrown for trying to save the source-compressed image when no hardware compression was used and only the TwainPro-compressed image is available with a given error number.
TwainProCompressedImageOnlyException Constructor(String) | This exception is thrown for trying to save the source-compressed image when no hardware compression was used and only the TwainPro-compressed image is available with a given string.
TwainProCompressedImageOnlyException Constructor(Int32,String) | This exception is thrown for trying to save the source-compressed image when no hardware compression was used and only the TwainPro-compressed image is available with a given error number and message.
TwainProCompressedImageOnlyException Constructor(String,Exception) | This exception is thrown for trying to save the source-compressed image when no hardware compression was used and only the TwainPro-compressed image is available with a given message and inner exception.

See Also

Reference

TwainProCompressedImageOnlyException Class
TwainProCompressedImageOnlyException Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
TwainProCompressedImageOnlyException Constructor()
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainProCompressedImageOnlyException Class > TwainProCompressedImageOnlyException Constructor : TwainProCompressedImageOnlyException Constructor()

Glossary Item Box

This exception is thrown for trying to save the source-compressed image when no hardware compression was used and only the TwainPro-compressed image is available.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New TwainProCompressedImageOnlyException()
public TwainProCompressedImageOnlyException()
public: TwainProCompressedImageOnlyException();
public:
TwainProCompressedImageOnlyException();

See Also

Reference

TwainProCompressedImageOnlyException Class
TwainProCompressedImageOnlyException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
TwainProCompressedImageOnlyException Constructor(Int32)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainProCompressedImageOnlyException Class > TwainProCompressedImageOnlyException Constructor : TwainProCompressedImageOnlyException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

This exception is thrown for trying to save the source-compressed image when no hardware compression was used and only the TwainPro-compressed image is available with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New TwainProCompressedImageOnlyException(errorNumber)
public TwainProCompressedImageOnlyException(
   int errorNumber
)
public: TwainProCompressedImageOnlyException(
   int errorNumber
)
public:
TwainProCompressedImageOnlyException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

TwainProCompressedImageOnlyException Class
TwainProCompressedImageOnlyException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
TwainProCompressedImageOnlyException Constructor(String)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainProCompressedImageOnlyException Class > TwainProCompressedImageOnlyException Constructor : TwainProCompressedImageOnlyException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

This exception is thrown for trying to save the source-compressed image when no hardware compression was used and only the TwainPro-compressed image is available with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New TwainProCompressedImageOnlyException(message)
public TwainProCompressedImageOnlyException(
   string message
)
public: TwainProCompressedImageOnlyException(
   string* message
)
public:
TwainProCompressedImageOnlyException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

TwainProCompressedImageOnlyException Class
TwainProCompressedImageOnlyException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
TwainProCompressedImageOnlyException Constructor(Int32,String)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainProCompressedImageOnlyException Class > TwainProCompressedImageOnlyException Constructor : TwainProCompressedImageOnlyException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

This exception is thrown for trying to save the source-compressed image when no hardware compression was used and only the TwainPro-compressed image is available with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New TwainProCompressedImageOnlyException(errorNumber, message)
public TwainProCompressedImageOnlyException(
   int errorNumber,
   string message
)
public: TwainProCompressedImageOnlyException(
   int errorNumber,
   string* message
)
public:
TwainProCompressedImageOnlyException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

TwainProCompressedImageOnlyException Class
TwainProCompressedImageOnlyException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
TwainProCompressedImageOnlyException Constructor(String,Exception)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainProCompressedImageOnlyException Class > TwainProCompressedImageOnlyException Constructor : TwainProCompressedImageOnlyException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

This exception is thrown for trying to save the source-compressed image when no hardware compression was used and only the TwainPro-compressed image is available with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New TwainProCompressedImageOnlyException(message, innerException)
public TwainProCompressedImageOnlyException(
   string message,
   Exception innerException
)
public: TwainProCompressedImageOnlyException(
   string* message,
   Exception* innerException
)
public:
TwainProCompressedImageOnlyException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

TwainProCompressedImageOnlyException Class
TwainProCompressedImageOnlyException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
TwainProException Class
Members See Also Send Feedback
Accusoft.TwainProSdk Namespace : TwainProException Class

Glossary Item Box

This class implements the base class for TwainPro Exceptions.

Object Model

TwainProException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public Class TwainProException
   Inherits System.ApplicationException
'Usage

Dim instance As TwainProException
[SerializableAttribute()]
public class TwainProException : System.ApplicationException
[SerializableAttribute()]
public __gc class TwainProException : public System.ApplicationException
[SerializableAttribute()]
public ref class TwainProException : public System.ApplicationException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.TwainProSdk.TwainProException
Accusoft.TwainProSdk.CapabilityNotSupportedException
Accusoft.TwainProSdk.ClipboardException
Accusoft.TwainProSdk.CompressedImageNotAvailableException
Accusoft.TwainProSdk.DataSourceInvalidOperationException
Accusoft.TwainProSdk.FileCreateException
Accusoft.TwainProSdk.FileOpenException
Accusoft.TwainProSdk.FileReadException
Accusoft.TwainProSdk.FileWriteException
Accusoft.TwainProSdk.FtpTransferException
Accusoft.TwainProSdk.ImageNotAvailableException
Accusoft.TwainProSdk.IndexOutOfRangeException
Accusoft.TwainProSdk.InternalErrorException
Accusoft.TwainProSdk.InternetFilesNotInstalledException
Accusoft.TwainProSdk.InvalidBitDepthException
Accusoft.TwainProSdk.InvalidLicenseException
Accusoft.TwainProSdk.InvalidPropertyException
Accusoft.TwainProSdk.LoadSettingsException
Accusoft.TwainProSdk.OperationCancelledException
Accusoft.TwainProSdk.OutOfMemoryException
Accusoft.TwainProSdk.PegasusFilesNotInstalledException
Accusoft.TwainProSdk.PropertyOrMethodNotAvailableException
Accusoft.TwainProSdk.SequenceException
Accusoft.TwainProSdk.SourceCompressedImageOnlyException
Accusoft.TwainProSdk.StringIsTooLongException
Accusoft.TwainProSdk.TiffTagItemNotFoundException
Accusoft.TwainProSdk.TiffTagNotFoundException
Accusoft.TwainProSdk.TwainDllLoadException
Accusoft.TwainProSdk.TwainException
Accusoft.TwainProSdk.TwainProCompressedImageOnlyException
Accusoft.TwainProSdk.UnsupportedFileFormatException
Accusoft.TwainProSdk.ValueOutOfRangeException

See Also

Reference

TwainProException Members
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.TwainPro7.Net
TwainProException Class Members
See Also Properties Methods Send Feedback
Accusoft.TwainProSdk Namespace : TwainProException Class

Glossary Item Box

The following tables list the members exposed by TwainProException.

Public Constructors

 | Name | Description
Public Constructor | TwainProException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception.
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

TwainProException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.TwainPro7.Net
TwainProException Class Methods
See Also Send Feedback
Accusoft.TwainProSdk Namespace : TwainProException Class

Glossary Item Box

For a list of all members of this type, see TwainProException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

TwainProException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
TwainProException Constructor
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainProException Class : TwainProException Constructor

Glossary Item Box

Overload List

Overload | Description
TwainProException Constructor() | Initializes a new instance of the TwainProException class.
TwainProException Constructor(Int32,String) | Initializes a new instance of the TwainProException class allowing passing in an error number and message.
TwainProException Constructor(Int32) | Initializes a new instance of the TwainProException class allowing passing in an error number.
TwainProException Constructor(String) | Initializes a new instance of the TwainProException class allowing passing in an error message.
TwainProException Constructor(String,Exception) | Initializes a new instance of the TwainProException class allowing passing in an error message and an inner exception.

See Also

Reference

TwainProException Class
TwainProException Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
TwainProException Constructor()
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainProException Class > TwainProException Constructor : TwainProException Constructor()

Glossary Item Box

Initializes a new instance of the TwainProException class.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New TwainProException()
public TwainProException()
public: TwainProException();
public:
TwainProException();

See Also

Reference

TwainProException Class
TwainProException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
TwainProException Constructor(Int32,String)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainProException Class > TwainProException Constructor : TwainProException Constructor(Int32,String)

number
An integer value which represents the error number.
message
A string value which represents the error message.

Glossary Item Box

Initializes a new instance of the TwainProException class allowing passing in an error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal number As Integer, _
   ByVal message As String _
)
'Usage

Dim number As Integer
Dim message As String

Dim instance As New TwainProException(number, message)
public TwainProException(
   int number,
   string message
)
public: TwainProException(
   int number,
   string* message
)
public:
TwainProException(
   int number,
   String^ message
)

Parameters

number
An integer value which represents the error number.
message
A string value which represents the error message.

See Also

Reference

TwainProException Class
TwainProException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
TwainProException Constructor(Int32)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainProException Class > TwainProException Constructor : TwainProException Constructor(Int32)

number
An integer value which represents the error number.

Glossary Item Box

Initializes a new instance of the TwainProException class allowing passing in an error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal number As Integer _
)
'Usage

Dim number As Integer

Dim instance As New TwainProException(number)
public TwainProException(
   int number
)
public: TwainProException(
   int number
)
public:
TwainProException(
   int number
)

Parameters

number
An integer value which represents the error number.

See Also

Reference

TwainProException Class
TwainProException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
TwainProException Constructor(String)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainProException Class > TwainProException Constructor : TwainProException Constructor(String)

message
A string value which represents the error message.

Glossary Item Box

Initializes a new instance of the TwainProException class allowing passing in an error message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New TwainProException(message)
public TwainProException(
   string message
)
public: TwainProException(
   string* message
)
public:
TwainProException(
   String^ message
)

Parameters

message
A string value which represents the error message.

See Also

Reference

TwainProException Class
TwainProException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
TwainProException Constructor(String,Exception)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainProException Class > TwainProException Constructor : TwainProException Constructor(String,Exception)

message
A string value which represents the error message.
inner
An inner System.Exception.

Glossary Item Box

Initializes a new instance of the TwainProException class allowing passing in an error message and an inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
'Usage

Dim message As String
Dim inner As Exception

Dim instance As New TwainProException(message, inner)
public TwainProException(
   string message,
   Exception inner
)
public: TwainProException(
   string* message,
   Exception* inner
)
public:
TwainProException(
   String^ message,
   Exception^ inner
)

Parameters

message
A string value which represents the error message.
inner
An inner System.Exception.

See Also

Reference

TwainProException Class
TwainProException Members
Overload List


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.TwainPro7.Net
TwainProException Class Properties
See Also Send Feedback
Accusoft.TwainProSdk Namespace : TwainProException Class

Glossary Item Box

For a list of all members of this type, see TwainProException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception.
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

TwainProException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
ErrorNumber Property
See Also Send Feedback
Accusoft.TwainProSdk Namespace > TwainProException Class : ErrorNumber Property

Glossary Item Box

Gets the error number of the exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property ErrorNumber As Integer
'Usage

Dim instance As TwainProException
Dim value As Integer

value = instance.ErrorNumber
public int ErrorNumber {get;}
public: __property int get_ErrorNumber();
public:
property int ErrorNumber {
   int get();
}

Property Value

An integer value which represents the error number.

Remarks

This property holds an error number that you can use to determine the specific type of error that occurred.

See Also

Reference

TwainProException Class
TwainProException Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
UnsupportedFileFormatException Class
Members See Also Send Feedback
Accusoft.TwainProSdk Namespace : UnsupportedFileFormatException Class

Glossary Item Box

This exception is thrown if the default file type is set and a file is saved using the extension of a file format that is not supported by TwainPRO, or if an invalid settings file is loaded. Supported file types are BMP, JPEG, ePIC, TIF, and PDF.

Object Model

UnsupportedFileFormatException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class UnsupportedFileFormatException
   Inherits TwainProException
'Usage

Dim instance As UnsupportedFileFormatException
[SerializableAttribute()]
public sealed class UnsupportedFileFormatException : TwainProException
[SerializableAttribute()]
public __gc __sealed class UnsupportedFileFormatException : public TwainProException
[SerializableAttribute()]
public ref class UnsupportedFileFormatException sealed : public TwainProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.TwainProSdk.TwainProException
Accusoft.TwainProSdk.UnsupportedFileFormatException

See Also

Reference

UnsupportedFileFormatException Members
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.TwainPro7.Net
UnsupportedFileFormatException Class Members
See Also Properties Methods Send Feedback
Accusoft.TwainProSdk Namespace : UnsupportedFileFormatException Class

Glossary Item Box

The following tables list the members exposed by UnsupportedFileFormatException.

Public Constructors

 | Name | Description
Public Constructor | UnsupportedFileFormatException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.TwainProSdk.TwainProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

UnsupportedFileFormatException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.TwainPro7.Net
UnsupportedFileFormatException Class Methods
See Also Send Feedback
Accusoft.TwainProSdk Namespace : UnsupportedFileFormatException Class

Glossary Item Box

For a list of all members of this type, see UnsupportedFileFormatException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

UnsupportedFileFormatException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.TwainPro7.Net
UnsupportedFileFormatException Class Properties
See Also Send Feedback
Accusoft.TwainProSdk Namespace : UnsupportedFileFormatException Class

Glossary Item Box

For a list of all members of this type, see UnsupportedFileFormatException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.TwainProSdk.TwainProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

UnsupportedFileFormatException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
UnsupportedFileFormatException Constructor
See Also Send Feedback
Accusoft.TwainProSdk Namespace > UnsupportedFileFormatException Class : UnsupportedFileFormatException Constructor

Glossary Item Box

Overload List

Overload | Description
UnsupportedFileFormatException Constructor() | An exception generated for an unsupported file format error.
UnsupportedFileFormatException Constructor(Int32) | Generated exception for an unsupported file format error with a given error number.
UnsupportedFileFormatException Constructor(String) | Generated exception for an unsupported file format error with a given string.
UnsupportedFileFormatException Constructor(Int32,String) | Generated exception for an unsupported file format error with a given error number and message.
UnsupportedFileFormatException Constructor(String,Exception) | Generated exception for an unsupported file format error with a given message and inner exception.

See Also

Reference

UnsupportedFileFormatException Class
UnsupportedFileFormatException Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
UnsupportedFileFormatException Constructor()
See Also Send Feedback
Accusoft.TwainProSdk Namespace > UnsupportedFileFormatException Class > UnsupportedFileFormatException Constructor : UnsupportedFileFormatException Constructor()

Glossary Item Box

An exception generated for an unsupported file format error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New UnsupportedFileFormatException()
public UnsupportedFileFormatException()
public: UnsupportedFileFormatException();
public:
UnsupportedFileFormatException();

See Also

Reference

UnsupportedFileFormatException Class
UnsupportedFileFormatException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
UnsupportedFileFormatException Constructor(Int32)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > UnsupportedFileFormatException Class > UnsupportedFileFormatException Constructor : UnsupportedFileFormatException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for an unsupported file format error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New UnsupportedFileFormatException(errorNumber)
public UnsupportedFileFormatException(
   int errorNumber
)
public: UnsupportedFileFormatException(
   int errorNumber
)
public:
UnsupportedFileFormatException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

UnsupportedFileFormatException Class
UnsupportedFileFormatException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
UnsupportedFileFormatException Constructor(String)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > UnsupportedFileFormatException Class > UnsupportedFileFormatException Constructor : UnsupportedFileFormatException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for an unsupported file format error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New UnsupportedFileFormatException(message)
public UnsupportedFileFormatException(
   string message
)
public: UnsupportedFileFormatException(
   string* message
)
public:
UnsupportedFileFormatException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

UnsupportedFileFormatException Class
UnsupportedFileFormatException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
UnsupportedFileFormatException Constructor(Int32,String)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > UnsupportedFileFormatException Class > UnsupportedFileFormatException Constructor : UnsupportedFileFormatException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for an unsupported file format error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New UnsupportedFileFormatException(errorNumber, message)
public UnsupportedFileFormatException(
   int errorNumber,
   string message
)
public: UnsupportedFileFormatException(
   int errorNumber,
   string* message
)
public:
UnsupportedFileFormatException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

UnsupportedFileFormatException Class
UnsupportedFileFormatException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
UnsupportedFileFormatException Constructor(String,Exception)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > UnsupportedFileFormatException Class > UnsupportedFileFormatException Constructor : UnsupportedFileFormatException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for an unsupported file format error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New UnsupportedFileFormatException(message, innerException)
public UnsupportedFileFormatException(
   string message,
   Exception innerException
)
public: UnsupportedFileFormatException(
   string* message,
   Exception* innerException
)
public:
UnsupportedFileFormatException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

UnsupportedFileFormatException Class
UnsupportedFileFormatException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
ValueOutOfRangeException Class
Members See Also Send Feedback
Accusoft.TwainProSdk Namespace : ValueOutOfRangeException Class

Glossary Item Box

This exception is thrown if a TwainPRO property was set to an invalid value.

Object Model

ValueOutOfRangeException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class ValueOutOfRangeException
   Inherits TwainProException
'Usage

Dim instance As ValueOutOfRangeException
[SerializableAttribute()]
public sealed class ValueOutOfRangeException : TwainProException
[SerializableAttribute()]
public __gc __sealed class ValueOutOfRangeException : public TwainProException
[SerializableAttribute()]
public ref class ValueOutOfRangeException sealed : public TwainProException

Remarks

Possible causes:

Many TwainPRO properties can only accept values in a specified range. For example, the SaveOptionsJpeg.Luminance property must be in the range 0-255.

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.TwainProSdk.TwainProException
Accusoft.TwainProSdk.ValueOutOfRangeException

See Also

Reference

ValueOutOfRangeException Members
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.TwainPro7.Net
ValueOutOfRangeException Class Members
See Also Properties Methods Send Feedback
Accusoft.TwainProSdk Namespace : ValueOutOfRangeException Class

Glossary Item Box

The following tables list the members exposed by ValueOutOfRangeException.

Public Constructors

 | Name | Description
Public Constructor | ValueOutOfRangeException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.TwainProSdk.TwainProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ValueOutOfRangeException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.TwainPro7.Net
ValueOutOfRangeException Class Methods
See Also Send Feedback
Accusoft.TwainProSdk Namespace : ValueOutOfRangeException Class

Glossary Item Box

For a list of all members of this type, see ValueOutOfRangeException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ValueOutOfRangeException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.TwainPro7.Net
ValueOutOfRangeException Class Properties
See Also Send Feedback
Accusoft.TwainProSdk Namespace : ValueOutOfRangeException Class

Glossary Item Box

For a list of all members of this type, see ValueOutOfRangeException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.TwainProSdk.TwainProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ValueOutOfRangeException Class
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
ValueOutOfRangeException Constructor
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ValueOutOfRangeException Class : ValueOutOfRangeException Constructor

Glossary Item Box

Overload List

Overload | Description
ValueOutOfRangeException Constructor() | An exception generated for a value out of range error.
ValueOutOfRangeException Constructor(Int32) | Generated exception for a value out of range error with a given error number.
ValueOutOfRangeException Constructor(String) | Generated exception for a value out of range error with a given string.
ValueOutOfRangeException Constructor(Int32,String) | Generated exception for a value out of range error with a given error number and message.
ValueOutOfRangeException Constructor(String,Exception) | Generated exception for a value out of range error with a given message and inner exception.

See Also

Reference

ValueOutOfRangeException Class
ValueOutOfRangeException Members


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
ValueOutOfRangeException Constructor()
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ValueOutOfRangeException Class > ValueOutOfRangeException Constructor : ValueOutOfRangeException Constructor()

Glossary Item Box

An exception generated for a value out of range error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ValueOutOfRangeException()
public ValueOutOfRangeException()
public: ValueOutOfRangeException();
public:
ValueOutOfRangeException();

See Also

Reference

ValueOutOfRangeException Class
ValueOutOfRangeException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
ValueOutOfRangeException Constructor(Int32)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ValueOutOfRangeException Class > ValueOutOfRangeException Constructor : ValueOutOfRangeException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a value out of range error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New ValueOutOfRangeException(errorNumber)
public ValueOutOfRangeException(
   int errorNumber
)
public: ValueOutOfRangeException(
   int errorNumber
)
public:
ValueOutOfRangeException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

ValueOutOfRangeException Class
ValueOutOfRangeException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
ValueOutOfRangeException Constructor(String)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ValueOutOfRangeException Class > ValueOutOfRangeException Constructor : ValueOutOfRangeException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a value out of range error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New ValueOutOfRangeException(message)
public ValueOutOfRangeException(
   string message
)
public: ValueOutOfRangeException(
   string* message
)
public:
ValueOutOfRangeException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

ValueOutOfRangeException Class
ValueOutOfRangeException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
ValueOutOfRangeException Constructor(Int32,String)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ValueOutOfRangeException Class > ValueOutOfRangeException Constructor : ValueOutOfRangeException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a value out of range error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New ValueOutOfRangeException(errorNumber, message)
public ValueOutOfRangeException(
   int errorNumber,
   string message
)
public: ValueOutOfRangeException(
   int errorNumber,
   string* message
)
public:
ValueOutOfRangeException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

ValueOutOfRangeException Class
ValueOutOfRangeException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
ValueOutOfRangeException Constructor(String,Exception)
See Also Send Feedback
Accusoft.TwainProSdk Namespace > ValueOutOfRangeException Class > ValueOutOfRangeException Constructor : ValueOutOfRangeException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a value out of range error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New ValueOutOfRangeException(message, innerException)
public ValueOutOfRangeException(
   string message,
   Exception innerException
)
public: ValueOutOfRangeException(
   string* message,
   Exception* innerException
)
public:
ValueOutOfRangeException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

ValueOutOfRangeException Class
ValueOutOfRangeException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
AdvancedCapability Enumeration
See Also Send Feedback
Accusoft.TwainProSdk Namespace : AdvancedCapability Enumeration

Glossary Item Box

Option values which determine the advanced TWAIN capability.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum AdvancedCapability
   Inherits System.Enum
'Usage

Dim instance As AdvancedCapability
public enum AdvancedCapability : System.Enum
__value public enum AdvancedCapability : public System.Enum
public enum class AdvancedCapability : public System.Enum

Members

Member | Value | Description
AcapAudioFileFormat | 4609 | Audio File Format
AcapXferMech | 4610 | Transfer Mechanism
CapAlarms | 4120 | Alarms
CapAlarmVolume | 4121 | Alarm Volume
CapAuthor | 4096 | Author
CapAutoFeed | 4103 | Auto Feed
CapAutomaticCapture | 4122 | Automatic Capture
CapAutoScan | 4112 | Auto Scan
CapBatteryMinutes | 4146 | Battery Minutes
CapBatteryPercentage | 4147 | Battery Percentage
CapCameraEnabled | 4150 | Camera Enabled
CapCameraOrder | 4151 | Camera Order
CapCameraPreviewUI | 4129 | Preview User Interface
CapCameraSide | 4148 | Camera Side
CapCaption | 4097 | Caption
CapClearBuffers | 4125 | Clear Buffers
CapClearPage | 4104 | Clear Page
CapCustomDSData | 4117 | Customer Data Source Data
CapDeviceEvent | 4130 | Device Event
CapDeviceOnline | 4111 | Device Online
CapDeviceTimeDate | 4127 | Device Time Date
CapDuplex | 4114 | Duplex
CapDuplexEnabled | 4115 | Duplex Enabled
CapEnableDSUIOnly | 4116 | Data Source User Interface Only
CapEndorser | 4118 | Endorser
CapExtendedCaps | 4102 | Extended Capabilities
CapFeederAlignment | 4141 | Feeder Alignment
CapFeederEnabled | 4098 | Feeder Enabled
CapFeederLoaded | 4099 | Feeder Loaded
CapFeederOrder | 4142 | Feeder Order
CapFeederPocket | 4154 | Feeder Pocket
CapFeederPrep | 4153 | Feeder Prep
CapFeedPage | 4105 | Feed Page
CapFileSystem | 4133 | File System (deprecated in TWAIN 2.0)
CapIndicators | 4107 | Indicators
CapJobControl | 4119 | Job Control
CapLanguage | 4140 | Language
CapMaxBatchBuffers | 4126 | Maximum Match Buffers
CapMicrEnabled | 4152 | MICR Enabled
CapPageMultipleAcquire | 4131 | Page Multiple Acquire
CapPaperBinding | 4143 | Paper Binding
CapPaperDetectable | 4109 | Paper Detectable
CapPassThru | 4145 | Pass Thru
CapPowerSupply | 4128 | Power Supply
CapPrinter | 4134 | Printer
CapPrinterEnabled | 4135 | Printer Enabled
CapPrinterIndex | 4136 | Printer Index
CapPrinterMode | 4137 | Printer Mode
CapPrinterString | 4138 | Printer String
CapPrinterSuffix | 4139 | Printer Suffix
CapReacquireAllowed | 4144 | Reacquire Allowed
CapRewindPage | 4106 | Rewind Page
CapSegmented | 4149 | Segmented
CapSerialNumber | 4132 | Serial Number
CapSupportedCaps | 4101 | Supported Capabilities
CapSupportedCapsExt | 4108 | Supported Capabilities Ext (deprecated in TWAIN 2.0)
CapThumbnailsEnabled | 4113 | Thumbnails Enabled
CapTimeBeforeFirstCapture | 4123 | Time Before First Capture
CapTimeBetweenCaptures | 4124 | Time Between Captures
CapTimeDate | 4100 | Time Date
CapUIControllable | 4110 | User Interface Controllable
CapXferCount | 1 | Transfer Count
IcapAutoBright | 4352 | Auto Bright
IcapAutomaticBorderDetection | 4432 | Automatic Border Detection
IcapAutomaticDeskew | 4433 | Automatic Deskew
IcapAutomaticRotate | 4434 | Automatic Rotate
IcapAutoSize | 4438 | Auto Size
IcapBarcodeDetectionEnabled | 4407 | Barcode Detection Enabled
IcapBarcodeMaxRetries | 4412 | Barcode Maximum Retries
IcapBarcodeMaxSearchPriorities | 4409 | Barcode Maximum Search Priorities
IcapBarcodeSearchMode | 4411 | Barcode Search Mode
IcapBarcodeSearchPriorities | 4410 | Barcode Search Priorities
IcapBarcodeTimeout | 4413 | Barcode Timeout
IcapBitDepth | 4395 | Bit Depth
IcapBitDepthReduction | 4396 | Bit Depth Reduction
IcapBitOrder | 4380 | Bit Order
IcapBitOrderCodes | 4390 | Bit Order Codes
IcapBrightness | 4353 | Brightness
IcapCcittKFactor | 4381 | CCITT K Factor
IcapCompression | 256 | Compression
IcapContrast | 4355 | Contrast
IcapCustHalftone | 4356 | Custom Halftone
IcapExposureTime | 4357 | Exposure Time
IcapExtImageInfo | 4399 | Extended Image Information
IcapFeederType | 4436 | Feeder Type
IcapFilter | 4358 | Filter
IcapFlashUsed | 4359 | Flash Used
IcapFlashUsed2 | 4422 | Flash Used 2
IcapFlipRotation | 4406 | Flip Rotation
IcapFrames | 4372 | Frames
IcapGamma | 4360 | Gamma
IcapHalftones | 4361 | Halftones
IcapHighlight | 4362 | Highlight
IcapIccProfile | 4437 | ICC Profile
IcapImageDataSet | 4398 | Image Data Set
IcapImageFileFormat | 4364 | Image File Format
IcapImageFilter | 4423 | Image Filter
IcapJpegPixelType | 4392 | JPEG Pixel Type
IcapJpegQuality | 4435 | JPEG Quality
IcapLampState | 4365 | Lamp State
IcapLightPath | 4382 | Light Path
IcapLightSource | 4366 | Light Source
IcapMaxFrames | 4378 | Maximum Frames
IcapMinimumHeight | 4400 | Minimum Height
IcapMinimumWidth | 4401 | Minimum Width
IcapNoiseFilter | 4424 | Noise Filter
IcapOrientation | 4368 | Orientation
IcapOverscan | 4425 | Overscan
IcapPatchCodeDetectionEnabled | 4415 | Patch Code Detection Enabled
IcapPatchCodeMaxRetries | 4420 | Patch Code Maximum Retries
IcapPatchCodeMaxSearchPriorities | 4417 | Patch Code Maximum Search Priorities
IcapPatchCodeSearchMode | 4419 | Patch Code Search Mode
IcapPatchCodeSearchPriorities | 4418 | Patch Code Search Priorities
IcapPatchCodeTimeout | 4421 | Patch Code Timeout
IcapPhysicalHeight | 4370 | Physical Height
IcapPhysicalWidth | 4369 | Physical Width
IcapPixelFlavor | 4383 | Pixel Flavor
IcapPixelFlavorCodes | 4391 | Pixel Flavor Codes
IcapPixelType | 257 | Pixel Type
IcapPlanarChunky | 4384 | Planar Chunky
IcapRotation | 4385 | Rotation
IcapShadow | 4371 | Shadow
IcapSupportedBarcodeTypes | 4408 | Supported Barcode Types
IcapSupportedPatchCodeTypes | 4416 | Supported Patch Code Types
IcapSupportedSizes | 4386 | Supported Sizes
IcapThreshold | 4387 | Threshold
IcapTiles | 4379 | Tiles
IcapTimeFill | 4394 | Time Fill
IcapUndefinedImageSize | 4397 | Undefined Image Size
IcapUnits | 258 | Units
IcapXferMech | 259 | Transfer Mechanism
IcapXNativeResolution | 4374 | X Native Resolution
IcapXResolution | 4376 | X Resolution
IcapXScaling | 4388 | X Scaling
IcapYNativeResolution | 4375 | Y Native Resolution
IcapYResolution | 4377 | Y Resolution
IcapYScaling | 4389 | Y Scaling
IcapZoomFactor | 4414 | Zoom Factor

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.TwainProSdk.AdvancedCapability

See Also

Reference

Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
AdvancedCapabilityAlarm Enumeration
See Also Send Feedback
Accusoft.TwainProSdk Namespace : AdvancedCapabilityAlarm Enumeration

Glossary Item Box

Specifies specific audible alarms.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum AdvancedCapabilityAlarm
   Inherits System.Enum
'Usage

Dim instance As AdvancedCapabilityAlarm
public enum AdvancedCapabilityAlarm : System.Enum
__value public enum AdvancedCapabilityAlarm : public System.Enum
public enum class AdvancedCapabilityAlarm : public System.Enum

Members

Member | Value | Description
TwalAlarm | 0 | Alarm
TwalBarcode | 3 | Alarm Barcode
TwalDoubleFeed | 4 | Alarm Double Feed
TwalFeederError | 1 | Alarm Feeder Error
TwalFeederWarning | 2 | Alarm Feeder Warning
TwalJam | 5 | Alarm Jam
TwalPatchCode | 6 | Alarm Patch Code
TwalPower | 7 | Alarm Power
TwalSkew | 8 | Alarm Skew

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.TwainProSdk.AdvancedCapabilityAlarm

See Also

Reference

Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
AdvancedCapabilityAudioFileFormat Enumeration
See Also Send Feedback
Accusoft.TwainProSdk Namespace : AdvancedCapabilityAudioFileFormat Enumeration

Glossary Item Box

The Audio File format.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum AdvancedCapabilityAudioFileFormat
   Inherits System.Enum
'Usage

Dim instance As AdvancedCapabilityAudioFileFormat
public enum AdvancedCapabilityAudioFileFormat : System.Enum
__value public enum AdvancedCapabilityAudioFileFormat : public System.Enum
public enum class AdvancedCapabilityAudioFileFormat : public System.Enum

Members

Member | Value | Description
TwafAiff | 1 | Audio File Aiff
TwafAu | 3 | Audio File Au
TwafSnd | 4 | Audio File Snd
TwafWav | 0 | Audio File Wav

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.TwainProSdk.AdvancedCapabilityAudioFileFormat

See Also

Reference

Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
AdvancedCapabilityAutoSize Enumeration
See Also Send Feedback
Accusoft.TwainProSdk Namespace : AdvancedCapabilityAutoSize Enumeration

Glossary Item Box

Specifies if the output image dimensions should match either the current value of ICAP_SUPPORTEDSIZES or any of its current allowed values.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum AdvancedCapabilityAutoSize
   Inherits System.Enum
'Usage

Dim instance As AdvancedCapabilityAutoSize
public enum AdvancedCapabilityAutoSize : System.Enum
__value public enum AdvancedCapabilityAutoSize : public System.Enum
public enum class AdvancedCapabilityAutoSize : public System.Enum

Members

Member | Value | Description
TwasAuto | 1 | Auto Size Auto
TwasCurrent | 2 | Auto Size Current
TwasNone | 0 | Auto Size None

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.TwainProSdk.AdvancedCapabilityAutoSize

See Also

Reference

Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
AdvancedCapabilityBarcodeDetectionSearchMode Enumeration
See Also Send Feedback
Accusoft.TwainProSdk Namespace : AdvancedCapabilityBarcodeDetectionSearchMode Enumeration

Glossary Item Box

Specifies how to restrict barcode searching to certain orientations, or prioritizes one orientation over another.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum AdvancedCapabilityBarcodeDetectionSearchMode
   Inherits System.Enum
'Usage

Dim instance As AdvancedCapabilityBarcodeDetectionSearchMode
public enum AdvancedCapabilityBarcodeDetectionSearchMode : System.Enum
__value public enum AdvancedCapabilityBarcodeDetectionSearchMode : public System.Enum
public enum class AdvancedCapabilityBarcodeDetectionSearchMode : public System.Enum

Members

Member | Value | Description
TwbdHorz | 0 | Barcode Detection Horizontal
TwbdHorzVert | 2 | Barcode Detection Horizontal Vertical
TwbdVert | 1 | Barcode Detection Vertical
TwbdVertHorz | 3 | Barcode Detection Vertical Horizontal

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.TwainProSdk.AdvancedCapabilityBarcodeDetectionSearchMode

See Also

Reference

Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
AdvancedCapabilityBitDepthReduction Enumeration
See Also Send Feedback
Accusoft.TwainProSdk Namespace : AdvancedCapabilityBitDepthReduction Enumeration

Glossary Item Box

Specifies the Reduction Method the Source should use to reduce the bit depth of the data.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum AdvancedCapabilityBitDepthReduction
   Inherits System.Enum
'Usage

Dim instance As AdvancedCapabilityBitDepthReduction
public enum AdvancedCapabilityBitDepthReduction : System.Enum
__value public enum AdvancedCapabilityBitDepthReduction : public System.Enum
public enum class AdvancedCapabilityBitDepthReduction : public System.Enum

Members

Member | Value | Description
TwbrCustHalftone | 2 | Bit Depth Reduction Custom Halftone
TwbrDiffusion | 3 | Bit Depth Reduction Diffusion
TwbrHalftone | 1 | Bit Depth Reduction Halftone
TwbrThreshold | 0 | Bit Depth Reduction Threshold

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.TwainProSdk.AdvancedCapabilityBitDepthReduction

See Also

Reference

Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
AdvancedCapabilityBitOrder Enumeration
See Also Send Feedback
Accusoft.TwainProSdk Namespace : AdvancedCapabilityBitOrder Enumeration

Glossary Item Box

Specifies how the bytes in an image are filled by the Source.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum AdvancedCapabilityBitOrder
   Inherits System.Enum
'Usage

Dim instance As AdvancedCapabilityBitOrder
public enum AdvancedCapabilityBitOrder : System.Enum
__value public enum AdvancedCapabilityBitOrder : public System.Enum
public enum class AdvancedCapabilityBitOrder : public System.Enum

Members

Member | Value | Description
TwboLsbFirst | 0 | Bit Order Least Significant Bit First
TwboMsbFirst | 1 | Bit Order Most Significant Bit First

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.TwainProSdk.AdvancedCapabilityBitOrder

See Also

Reference

Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
AdvancedCapabilityCameraSide Enumeration
See Also Send Feedback
Accusoft.TwainProSdk Namespace : AdvancedCapabilityCameraSide Enumeration

Glossary Item Box

Specifies the camera used in a scanning device.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum AdvancedCapabilityCameraSide
   Inherits System.Enum
'Usage

Dim instance As AdvancedCapabilityCameraSide
public enum AdvancedCapabilityCameraSide : System.Enum
__value public enum AdvancedCapabilityCameraSide : public System.Enum
public enum class AdvancedCapabilityCameraSide : public System.Enum

Members

Member | Value | Description
TwcsBoth | 0 | Camera Side Both
TwcsBottom | 2 | Camera Side Bottom
TwcsTop | 1 | Camera Side Top

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.TwainProSdk.AdvancedCapabilityCameraSide

See Also

Reference

Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
AdvancedCapabilityClearBuffers Enumeration
See Also Send Feedback
Accusoft.TwainProSdk Namespace : AdvancedCapabilityClearBuffers Enumeration

Glossary Item Box

Specifies how the Source should clear its buffers.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum AdvancedCapabilityClearBuffers
   Inherits System.Enum
'Usage

Dim instance As AdvancedCapabilityClearBuffers
public enum AdvancedCapabilityClearBuffers : System.Enum
__value public enum AdvancedCapabilityClearBuffers : public System.Enum
public enum class AdvancedCapabilityClearBuffers : public System.Enum

Members

Member | Value | Description
TwcbAuto | 0 | Clear Buffers Auto
TwcbClear | 1 | Clear Buffers Clear
TwcbNoClear | 2 | Clear Buffers No Clear

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.TwainProSdk.AdvancedCapabilityClearBuffers

See Also

Reference

Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
AdvancedCapabilityCompression Enumeration
See Also Send Feedback
Accusoft.TwainProSdk Namespace : AdvancedCapabilityCompression Enumeration

Glossary Item Box

Specifies compression schemes the Source and Application have in common for Buffered Memory and File transfers.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum AdvancedCapabilityCompression
   Inherits System.Enum
'Usage

Dim instance As AdvancedCapabilityCompression
public enum AdvancedCapabilityCompression : System.Enum
__value public enum AdvancedCapabilityCompression : public System.Enum
public enum class AdvancedCapabilityCompression : public System.Enum

Members

Member | Value | Description
TwcpGroup31D | 2 | Compression Group 3 1D
TwcpGroup31DEol | 3 | Compression Group 3 1D EOL
TwcpGroup32D | 4 | Compression Group 3 2D
TwcpGroup4 | 5 | Compression Group 4
TwcpJpeg | 6 | Compression JPEG
TwcpNone | 0 | Compression None
TwcpPackbits | 1 | Compression Packbits

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.TwainProSdk.AdvancedCapabilityCompression

See Also

Reference

Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
AdvancedCapabilityDeviceEvent Enumeration
See Also Send Feedback
Accusoft.TwainProSdk Namespace : AdvancedCapabilityDeviceEvent Enumeration

Glossary Item Box

Specifies events the Source reports to the Application.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum AdvancedCapabilityDeviceEvent
   Inherits System.Enum
'Usage

Dim instance As AdvancedCapabilityDeviceEvent
public enum AdvancedCapabilityDeviceEvent : System.Enum
__value public enum AdvancedCapabilityDeviceEvent : public System.Enum
public enum class AdvancedCapabilityDeviceEvent : public System.Enum

Members

Member | Value | Description
TwdeCheckAutomaticCapture | 0 | Device Event Check Automatic Capture
TwdeCheckBattery | 1 | Device Event Check Battery
TwdeCheckDeviceOnline | 2 | Device Event Check Device Online
TwdeCheckFlash | 3 | Device Event Check Flash
TwdeCheckPowerSupply | 4 | Device Event Check Power Supply
TwdeCheckResolution | 5 | Device Event Check Resolution
TwdeDeviceAdded | 6 | Device Event Device Added
TwdeDeviceOffline | 7 | Device Event Device Offline
TwdeDeviceReady | 8 | Device Event Device Ready
TwdeDeviceRemoved | 9 | Device Event Device Removed
TwdeImageCaptured | 10 | Device Event Image Captured
TwdeImageDeleted | 11 | Device Event Image Deleted
TwdeLampFailure | 14 | Device Event Lamp Failure
TwdePaperDoubleFeed | 12 | Device Event Paper Double Feed
TwdePaperJam | 13 | Device Event Paper Jam
TwdePowerSave | 15 | Device Event Power Save
TwdePowerSaveNotify | 16 | Device Event Power Save Notify

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.TwainProSdk.AdvancedCapabilityDeviceEvent

See Also

Reference

Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
AdvancedCapabilityFeederAlignment Enumeration
See Also Send Feedback
Accusoft.TwainProSdk Namespace : AdvancedCapabilityFeederAlignment Enumeration

Glossary Item Box

Specifes the feeder alignment used when negotiating frames from the Source.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum AdvancedCapabilityFeederAlignment
   Inherits System.Enum
'Usage

Dim instance As AdvancedCapabilityFeederAlignment
public enum AdvancedCapabilityFeederAlignment : System.Enum
__value public enum AdvancedCapabilityFeederAlignment : public System.Enum
public enum class AdvancedCapabilityFeederAlignment : public System.Enum

Members

Member | Value | Description
TwfaCenter | 2 | Feeder Alignment Center
TwfaLeft | 1 | Feeder Alignment Left
TwfaNone | 0 | Feeder Alignment None
TwfaRight | 3 | Feeder Alignment Right

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.TwainProSdk.AdvancedCapabilityFeederAlignment

See Also

Reference

Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
AdvancedCapabilityFeederOrder Enumeration
See Also Send Feedback
Accusoft.TwainProSdk Namespace : AdvancedCapabilityFeederOrder Enumeration

Glossary Item Box

Specifies which page the feeder starts with.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum AdvancedCapabilityFeederOrder
   Inherits System.Enum
'Usage

Dim instance As AdvancedCapabilityFeederOrder
public enum AdvancedCapabilityFeederOrder : System.Enum
__value public enum AdvancedCapabilityFeederOrder : public System.Enum
public enum class AdvancedCapabilityFeederOrder : public System.Enum

Members

Member | Value | Description
TwfoFirstPageFirst | 0 | Feeder Order First Page First
TwfoLastPageFirst | 1 | Feeder Order Last Page First

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.TwainProSdk.AdvancedCapabilityFeederOrder

See Also

Reference

Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
AdvancedCapabilityFeederPocket Enumeration
See Also Send Feedback
Accusoft.TwainProSdk Namespace : AdvancedCapabilityFeederPocket Enumeration

Glossary Item Box

Specifies what pockets are available as paper leaves a device.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum AdvancedCapabilityFeederPocket
   Inherits System.Enum
'Usage

Dim instance As AdvancedCapabilityFeederPocket
public enum AdvancedCapabilityFeederPocket : System.Enum
__value public enum AdvancedCapabilityFeederPocket : public System.Enum
public enum class AdvancedCapabilityFeederPocket : public System.Enum

Members

Member | Value | Description
TwfpPocket1 | 1 | Feeder Pocket 1
TwfpPocket10 | 10 | Feeder Pocket 10
TwfpPocket11 | 11 | Feeder Pocket 11
TwfpPocket12 | 12 | Feeder Pocket 12
TwfpPocket13 | 13 | Feeder Pocket 13
TwfpPocket14 | 14 | Feeder Pocket 14
TwfpPocket15 | 15 | Feeder Pocket 15
TwfpPocket16 | 16 | Feeder Pocket 16
TwfpPocket2 | 2 | Feeder Pocket 2
TwfpPocket3 | 3 | Feeder Pocket 3
TwfpPocket4 | 4 | Feeder Pocket 4
TwfpPocket5 | 5 | Feeder Pocket 5
TwfpPocket6 | 6 | Feeder Pocket 6
TwfpPocket7 | 7 | Feeder Pocket 7
TwfpPocket8 | 8 | Feeder Pocket 8
TwfpPocket9 | 9 | Feeder Pocket 9
TwfpPocketError | 0 | Feeder Pocket Error

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.TwainProSdk.AdvancedCapabilityFeederPocket

See Also

Reference

Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
AdvancedCapabilityFeederType Enumeration
See Also Send Feedback
Accusoft.TwainProSdk Namespace : AdvancedCapabilityFeederType Enumeration

Glossary Item Box

Specifies scan parameters depending on the type of feeder.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum AdvancedCapabilityFeederType
   Inherits System.Enum
'Usage

Dim instance As AdvancedCapabilityFeederType
public enum AdvancedCapabilityFeederType : System.Enum
__value public enum AdvancedCapabilityFeederType : public System.Enum
public enum class AdvancedCapabilityFeederType : public System.Enum

Members

Member | Value | Description
TwfeGeneral | 0 | Feeder General
TwfePhoto | 1 | Feeder Photo

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.TwainProSdk.AdvancedCapabilityFeederType

See Also

Reference

Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
AdvancedCapabilityFileFormat Enumeration
See Also Send Feedback
Accusoft.TwainProSdk Namespace : AdvancedCapabilityFileFormat Enumeration

Glossary Item Box

Specifies which file formats the Source can generate and which the Application can handle.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum AdvancedCapabilityFileFormat
   Inherits System.Enum
'Usage

Dim instance As AdvancedCapabilityFileFormat
public enum AdvancedCapabilityFileFormat : System.Enum
__value public enum AdvancedCapabilityFileFormat : public System.Enum
public enum class AdvancedCapabilityFileFormat : public System.Enum

Members

Member | Value | Description
TwffBmp | 2 | File Format Bmp
TwffDejavu | 14 | File Format Dejavu
TwffExif | 9 | File Format Exif
TwffFpx | 5 | File Format Fpx
TwffJfif | 4 | File Format Jfif
TwffJp2 | 11 | File Format Jp2
TwffJpn | 12 | File Format Jpn
TwffJpx | 13 | File Format Jpx
TwffPdf | 10 | File Format Pdf
TwffPdfa | 15 | File Format Pdfa
TwffPict | 1 | File Format Pict
TwffPng | 7 | File Format Png
TwffSpiff | 8 | File Format Spiff
TwffTiff | 0 | File Format Tiff
TwffTiffMulti | 6 | File Format Tiff Multi
TwffXbm | 3 | File Format Xbm

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.TwainProSdk.AdvancedCapabilityFileFormat

See Also

Reference

Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
AdvancedCapabilityFilter Enumeration
See Also Send Feedback
Accusoft.TwainProSdk Namespace : AdvancedCapabilityFilter Enumeration

Glossary Item Box

Option values which determine the TWAIN capability constants for advanced capabilities.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum AdvancedCapabilityFilter
   Inherits System.Enum
'Usage

Dim instance As AdvancedCapabilityFilter
public enum AdvancedCapabilityFilter : System.Enum
__value public enum AdvancedCapabilityFilter : public System.Enum
public enum class AdvancedCapabilityFilter : public System.Enum

Members

Member | Value | Description
TwftBlack | 8 | Filter Black
TwftBlue | 2 | Filter Blue
TwftCyan | 5 | Filter Cyan
TwftGreen | 1 | Filter Green
TwftMagenta | 6 | Filter Magenta
TwftNone | 3 | Filter None
TwftRed | 0 | Filter Red
TwftWhite | 4 | Filter White
TwftYellow | 7 | Filter Yellow

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.TwainProSdk.AdvancedCapabilityFilter

See Also

Reference

Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
AdvancedCapabilityFlash Enumeration
See Also Send Feedback
Accusoft.TwainProSdk Namespace : AdvancedCapabilityFlash Enumeration

Glossary Item Box

For devices that support flash, specifies the flash to be used.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum AdvancedCapabilityFlash
   Inherits System.Enum
'Usage

Dim instance As AdvancedCapabilityFlash
public enum AdvancedCapabilityFlash : System.Enum
__value public enum AdvancedCapabilityFlash : public System.Enum
public enum class AdvancedCapabilityFlash : public System.Enum

Members

Member | Value | Description
TwflAuto | 3 | Flash Auto
TwflNone | 0 | Flash None
TwflOff | 1 | Flash Off
TwflOn | 2 | Flash On
TwflRedEye | 4 | Flash Red Eye

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.TwainProSdk.AdvancedCapabilityFlash

See Also

Reference

Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
AdvancedCapabilityFlipRotation Enumeration
See Also Send Feedback
Accusoft.TwainProSdk Namespace : AdvancedCapabilityFlipRotation Enumeration

Glossary Item Box

Specifies how to orient images that flip orientation every other image.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum AdvancedCapabilityFlipRotation
   Inherits System.Enum
'Usage

Dim instance As AdvancedCapabilityFlipRotation
public enum AdvancedCapabilityFlipRotation : System.Enum
__value public enum AdvancedCapabilityFlipRotation : public System.Enum
public enum class AdvancedCapabilityFlipRotation : public System.Enum

Members

Member | Value | Description
TwfrBook | 0 | Flip Rotation Book
TwfrFanFold | 1 | Flip Rotation Fan Fold

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.TwainProSdk.AdvancedCapabilityFlipRotation

See Also

Reference

Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
AdvancedCapabilityIccProfile Enumeration
See Also Send Feedback
Accusoft.TwainProSdk Namespace : AdvancedCapabilityIccProfile Enumeration

Glossary Item Box

Specifies the ICC profile and if it can embed or link it in the current ICAP_IMAGEFILEFORMAT.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum AdvancedCapabilityIccProfile
   Inherits System.Enum
'Usage

Dim instance As AdvancedCapabilityIccProfile
public enum AdvancedCapabilityIccProfile : System.Enum
__value public enum AdvancedCapabilityIccProfile : public System.Enum
public enum class AdvancedCapabilityIccProfile : public System.Enum

Members

Member | Value | Description
TwicEmbed | 2 | ICC Profile Embed
TwicLink | 1 | ICC Profile Link
TwicNone | 0 | ICC Profile None

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.TwainProSdk.AdvancedCapabilityIccProfile

See Also

Reference

Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
AdvancedCapabilityImageFilter Enumeration
See Also Send Feedback
Accusoft.TwainProSdk Namespace : AdvancedCapabilityImageFilter Enumeration

Glossary Item Box

For devices that support image filtering, specifies the algorithm to be used.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum AdvancedCapabilityImageFilter
   Inherits System.Enum
'Usage

Dim instance As AdvancedCapabilityImageFilter
public enum AdvancedCapabilityImageFilter : System.Enum
__value public enum AdvancedCapabilityImageFilter : public System.Enum
public enum class AdvancedCapabilityImageFilter : public System.Enum

Members

Member | Value | Description
TwifAuto | 1 | Image Filter Auto
TwifBandPass | 3 | Image Filter Band Pass
TwifFineLine | 4 | Image Filter Fine Line
TwifHighPass | 4 | Image Filter High Pass
TwifLowPass | 2 | Image Filter Low Pass
TwifNone | 0 | Image Filter None
TwifText | 3 | Image Filter Text

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.TwainProSdk.AdvancedCapabilityImageFilter

See Also

Reference

Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
AdvancedCapabilityJobControl Enumeration
See Also Send Feedback
Accusoft.TwainProSdk Namespace : AdvancedCapabilityJobControl Enumeration

Glossary Item Box

Specifies settings for multiple jobs in batch mode.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum AdvancedCapabilityJobControl
   Inherits System.Enum
'Usage

Dim instance As AdvancedCapabilityJobControl
public enum AdvancedCapabilityJobControl : System.Enum
__value public enum AdvancedCapabilityJobControl : public System.Enum
public enum class AdvancedCapabilityJobControl : public System.Enum

Members

Member | Value | Description
TwjcJsic | 1 | Job Control Detect and Include Job Separate and Continue Scanning
TwjcJsis | 2 | Job Control Detect and Include Job Separate and Stop Scanning
TwjcJsxc | 3 | Job Control Detect and Exclude Job Separate and Continue Scanning
TwjcJsxs | 4 | Job Control Detect and Exclude Job Separate and Stop Scanning
TwjcNone | 0 | Job Control None

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.TwainProSdk.AdvancedCapabilityJobControl

See Also

Reference

Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
AdvancedCapabilityJpegQuality Enumeration
See Also Send Feedback
Accusoft.TwainProSdk Namespace : AdvancedCapabilityJpegQuality Enumeration

Glossary Item Box

Specifies JPEG quantization tables that tradeoff quality versus compressed image size.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum AdvancedCapabilityJpegQuality
   Inherits System.Enum
'Usage

Dim instance As AdvancedCapabilityJpegQuality
public enum AdvancedCapabilityJpegQuality : System.Enum
__value public enum AdvancedCapabilityJpegQuality : public System.Enum
public enum class AdvancedCapabilityJpegQuality : public System.Enum

Members

Member | Value | Description
TwjqHigh | -1 | JPEG Quality High
TwjqLow | -3 | JPEG Quality Low
TwjqMedium | -2 | JPEG Quality Medium
TwjqUnknown | -4 | JPEG Quality Unknown

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.TwainProSdk.AdvancedCapabilityJpegQuality

See Also

Reference

Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
AdvancedCapabilityLightPath Enumeration
See Also Send Feedback
Accusoft.TwainProSdk Namespace : AdvancedCapabilityLightPath Enumeration

Glossary Item Box

Specifies whether the image was captured transmissively or reflectively.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum AdvancedCapabilityLightPath
   Inherits System.Enum
'Usage

Dim instance As AdvancedCapabilityLightPath
public enum AdvancedCapabilityLightPath : System.Enum
__value public enum AdvancedCapabilityLightPath : public System.Enum
public enum class AdvancedCapabilityLightPath : public System.Enum

Members

Member | Value | Description
TwlpReflective | 0 | Light Path Reflective
TwlpTransmissive | 1 | Light Path Transmissive

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.TwainProSdk.AdvancedCapabilityLightPath

See Also

Reference

Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
AdvancedCapabilityLightSource Enumeration
See Also Send Feedback
Accusoft.TwainProSdk Namespace : AdvancedCapabilityLightSource Enumeration

Glossary Item Box

Specifies the general color characteristics of the light source used to acquire the image.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum AdvancedCapabilityLightSource
   Inherits System.Enum
'Usage

Dim instance As AdvancedCapabilityLightSource
public enum AdvancedCapabilityLightSource : System.Enum
__value public enum AdvancedCapabilityLightSource : public System.Enum
public enum class AdvancedCapabilityLightSource : public System.Enum

Members

Member | Value | Description
TwlsBlue | 2 | Light Source Blue
TwlsGreen | 1 | Light Source Green
TwlsIR | 6 | Light Source Infrared
TwlsNone | 3 | Light Source None
TwlsRed | 0 | Light Source Red
TwlsUV | 5 | Light Source Ultraviolet
TwlsWhite | 4 | Light Source White

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.TwainProSdk.AdvancedCapabilityLightSource

See Also

Reference

Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
AdvancedCapabilityNoiseFilter Enumeration
See Also Send Feedback
Accusoft.TwainProSdk Namespace : AdvancedCapabilityNoiseFilter Enumeration

Glossary Item Box

For devices that support noise filtering, specifies the algorithm used to remove noise.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum AdvancedCapabilityNoiseFilter
   Inherits System.Enum
'Usage

Dim instance As AdvancedCapabilityNoiseFilter
public enum AdvancedCapabilityNoiseFilter : System.Enum
__value public enum AdvancedCapabilityNoiseFilter : public System.Enum
public enum class AdvancedCapabilityNoiseFilter : public System.Enum

Members

Member | Value | Description
TwnfAuto | 1 | Noise Filter Auto
TwnfLonePixel | 2 | Noise Filter Lone Pixel
TwnfMajorityRule | 3 | Noise Filter Majority Rule
TwnfNone | 0 | Noise Filter None

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.TwainProSdk.AdvancedCapabilityNoiseFilter

See Also

Reference

Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
AdvancedCapabilityOverScan Enumeration
See Also Send Feedback
Accusoft.TwainProSdk Namespace : AdvancedCapabilityOverScan Enumeration

Glossary Item Box

Specifies the overscan which is used to scan outside the boundaries described by ICAP_FRAMES, and is used to help acquire image that may be lost because of skewing.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum AdvancedCapabilityOverScan
   Inherits System.Enum
'Usage

Dim instance As AdvancedCapabilityOverScan
public enum AdvancedCapabilityOverScan : System.Enum
__value public enum AdvancedCapabilityOverScan : public System.Enum
public enum class AdvancedCapabilityOverScan : public System.Enum

Members

Member | Value | Description
TwovAll | 4 | Overscan All
TwovAuto | 1 | Overscan Auto
TwovLeftRight | 3 | Overscan Left Right
TwovNone | 0 | Overscan None
TwovTopBottom | 2 | Overscan Top Bottom

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.TwainProSdk.AdvancedCapabilityOverScan

See Also

Reference

Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
AdvancedCapabilityPixelFlavor Enumeration
See Also Send Feedback
Accusoft.TwainProSdk Namespace : AdvancedCapabilityPixelFlavor Enumeration

Glossary Item Box

Specifies the sense of the pixel whose numeric value is zero (minimum data value).

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum AdvancedCapabilityPixelFlavor
   Inherits System.Enum
'Usage

Dim instance As AdvancedCapabilityPixelFlavor
public enum AdvancedCapabilityPixelFlavor : System.Enum
__value public enum AdvancedCapabilityPixelFlavor : public System.Enum
public enum class AdvancedCapabilityPixelFlavor : public System.Enum

Members

Member | Value | Description
TwpfChocolate | 0 | Pixel Flavor Chocolate
TwpfVanilla | 1 | Pixel Flavor Vanilla

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.TwainProSdk.AdvancedCapabilityPixelFlavor

See Also

Reference

Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
AdvancedCapabilityPlanarChunky Enumeration
See Also Send Feedback
Accusoft.TwainProSdk Namespace : AdvancedCapabilityPlanarChunky Enumeration

Glossary Item Box

Specifies which color data formats are available to the Source and Application.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum AdvancedCapabilityPlanarChunky
   Inherits System.Enum
'Usage

Dim instance As AdvancedCapabilityPlanarChunky
public enum AdvancedCapabilityPlanarChunky : System.Enum
__value public enum AdvancedCapabilityPlanarChunky : public System.Enum
public enum class AdvancedCapabilityPlanarChunky : public System.Enum

Members

Member | Value | Description
TwpcChunky | 0 | Chunky
TwpcPlanar | 1 | Planar

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.TwainProSdk.AdvancedCapabilityPlanarChunky

See Also

Reference

Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
AdvancedCapabilityPowerSupply Enumeration
See Also Send Feedback
Accusoft.TwainProSdk Namespace : AdvancedCapabilityPowerSupply Enumeration

Glossary Item Box

Specifies the kind of power available.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum AdvancedCapabilityPowerSupply
   Inherits System.Enum
'Usage

Dim instance As AdvancedCapabilityPowerSupply
public enum AdvancedCapabilityPowerSupply : System.Enum
__value public enum AdvancedCapabilityPowerSupply : public System.Enum
public enum class AdvancedCapabilityPowerSupply : public System.Enum

Members

Member | Value | Description
TwpsBattery | 1 | Power Supply Battery
TwpsExternal | 0 | Power Supply External

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.TwainProSdk.AdvancedCapabilityPowerSupply

See Also

Reference

Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
AdvancedCapabilityPrinter Enumeration
See Also Send Feedback
Accusoft.TwainProSdk Namespace : AdvancedCapabilityPrinter Enumeration

Glossary Item Box

Settings for available printer devices.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum AdvancedCapabilityPrinter
   Inherits System.Enum
'Usage

Dim instance As AdvancedCapabilityPrinter
public enum AdvancedCapabilityPrinter : System.Enum
__value public enum AdvancedCapabilityPrinter : public System.Enum
public enum class AdvancedCapabilityPrinter : public System.Enum

Members

Member | Value | Description
TwprEndorserBottomAfter | 7 | Printer Endorser Bottom After
TwprEndorserBottomBefore | 6 | Printer Endorser Bottom Before
TwprEndorserTopAfter | 5 | Printer Endorser Top After
TwprEndorserTopBefore | 4 | Printer Endorser Top Before
TwprImprinterBottomAfter | 3 | Printer Imprinter Bottom After
TwprImprinterBottomBefore | 2 | Printer Imprinter Bottom Before
TwprImprinterTopAfter | 1 | Printer Imprinter Top After
TwprImprinterTopBefore | 0 | Printer Imprinter Top Before

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.TwainProSdk.AdvancedCapabilityPrinter

See Also

Reference

Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
AdvancedCapabilityPrinterMode Enumeration
See Also Send Feedback
Accusoft.TwainProSdk Namespace : AdvancedCapabilityPrinterMode Enumeration

Glossary Item Box

Specifies the format of the printed text.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum AdvancedCapabilityPrinterMode
   Inherits System.Enum
'Usage

Dim instance As AdvancedCapabilityPrinterMode
public enum AdvancedCapabilityPrinterMode : System.Enum
__value public enum AdvancedCapabilityPrinterMode : public System.Enum
public enum class AdvancedCapabilityPrinterMode : public System.Enum

Members

Member | Value | Description
TwpmCompoundString | 2 | Printer Mode Compound String
TwpmMultiString | 1 | Printer Mode Multi String
TwpmSingleString | 0 | Printer Mode Single String

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.TwainProSdk.AdvancedCapabilityPrinterMode

See Also

Reference

Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
AdvancedCapabilitySegmented Enumeration
See Also Send Feedback
Accusoft.TwainProSdk Namespace : AdvancedCapabilitySegmented Enumeration

Glossary Item Box

Segmentation settings for captured images.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum AdvancedCapabilitySegmented
   Inherits System.Enum
'Usage

Dim instance As AdvancedCapabilitySegmented
public enum AdvancedCapabilitySegmented : System.Enum
__value public enum AdvancedCapabilitySegmented : public System.Enum
public enum class AdvancedCapabilitySegmented : public System.Enum

Members

Member | Value | Description
TwsgAuto | 1 | Segmented Auto
TwsgNone | 0 | Segmented None

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.TwainProSdk.AdvancedCapabilitySegmented

See Also

Reference

Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Capability Enumeration
See Also Send Feedback
Accusoft.TwainProSdk Namespace : Capability Enumeration

Glossary Item Box

Option values which determine the TWAIN capability.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum Capability
   Inherits System.Enum
'Usage

Dim instance As Capability
public enum Capability : System.Enum
__value public enum Capability : public System.Enum
public enum class Capability : public System.Enum

Members

Member | Value | Description
CapAutoFeed | 4103 | Auto Feed
CapAutoScan | 4112 | Auto Scan
CapClearPage | 4104 | Clear Page
CapDeviceOnline | 4111 | Device Online
CapDuplex | 4114 | Duplex
CapDuplexEnabled | 4115 | Duplex Enabled
CapFeederEnabled | 4098 | Feeder Enabled
CapFeederLoaded | 4099 | Feeder Loaded
CapFeedPage | 4105 | Feed Page
CapIndicators | 4107 | Indicators
CapPaperDetectable | 4109 | Paper Detectable
CapUIControllable | 4110 | User Interface Controllable
CapXferCount | 1 | Transfer Count
IcapAutoBright | 4352 | Auto Bright
IcapBitDepth | 4395 | Bit Depth
IcapBrightness | 4353 | Brightness
IcapContrast | 4355 | Contrast
IcapGamma | 4360 | Gamma
IcapLampstate | 4365 | Lamp State
IcapPhysicalHeight | 4370 | Physical Height
IcapPhysicalWidth | 4369 | Physical Width
IcapPixelType | 257 | Pixel Type
IcapRotation | 4385 | Rotation
IcapSupportedSizes | 4386 | Supported Sizes
IcapUnits | 258 | Units
IcapXNativeResolution | 4374 | X Native Resolution
IcapXResolution | 4376 | X Resolution
IcapXScaling | 4388 | X Scaling
IcapYNativeResolution | 4375 | Y Native Resolution
IcapYResolution | 4377 | Y Resolution
IcapYScaling | 4389 | Y Scaling

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.TwainProSdk.Capability

See Also

Reference

Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
CapabilityConstants Enumeration
See Also Send Feedback
Accusoft.TwainProSdk Namespace : CapabilityConstants Enumeration

Glossary Item Box

Option values which determine the capability constants.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum CapabilityConstants
   Inherits System.Enum
'Usage

Dim instance As CapabilityConstants
public enum CapabilityConstants : System.Enum
__value public enum CapabilityConstants : public System.Enum
public enum class CapabilityConstants : public System.Enum

Members

Member | Value | Description
Twdx1PassDuplex | 1 | 1 Pass Duplex
Twdx2PassDuplex | 2 | 2 Pass Duplex
TwdxNone | 0 | Duplex None
TwptBW | 0 | Black and White
TwptGray | 1 | Gray
TwptPalette | 3 | Palette
TwptRgb | 2 | RGB
TwunCentimeters | 1 | Centimeters
TwunInches | 0 | Inches
TwunMillimeters | 6 | Millimeters
TwunPicas | 2 | Picas
TwunPixels | 5 | Pixels
TwunPoints | 3 | Points
TwunTwips | 4 | Twips

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.TwainProSdk.CapabilityConstants

See Also

Reference

Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
ConditionCode Enumeration
See Also Send Feedback
Accusoft.TwainProSdk Namespace : ConditionCode Enumeration

Glossary Item Box

Option values which determine TWAIN condition codes.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum ConditionCode
   Inherits System.Enum
'Usage

Dim instance As ConditionCode
public enum ConditionCode : System.Enum
__value public enum ConditionCode : public System.Enum
public enum class ConditionCode : public System.Enum

Members

Member | Value | Description
TwccBadCap | 6 | Unknown or bad capability
TwccBadDest | 12 | Bad or unknown destination source
TwccBadProtocol | 9 | Bad protocol
TwccBadValue | 10 | Bad value. Data parameter may be out of range
TwccBummer | 1 | Bummer. Failure due to unknown causes.
TwccCapBadOperation | 14 | Operation not supported by capability
TwccCapSeqError | 15 | Capability has dependancy on other capability
TwccCapUnsupported | 13 | Unsupported capability
TwccCheckDeviceOnline | 23 | Check device online as device went offline prior to or during this operation
TwccCustomBase | 32768 | Custom base
TwccDamagedCorner | 25 | Operation failed because the document has a damaged corner
TwccDenied | 16 | File system operation is denied
TwccDocTooDark | 28 | Operation failed because the document is too dark
TwccDocTooLight | 27 | Operation failed because the document is too light
TwccFileExists | 17 | Operation failed because file already exists
TwccFileNotFound | 18 | File not found
TwccFileWriteError | 22 | File write error
TwccFocusError | 26 | Operation failed because of a focusing error during document capture
TwccInterlock | 24 | Operation failed because the cover or door is open
TwccLowMemory | 2 | Low memory. Not enough memory to perform the operation
TwccMaxConnections | 4 | Max Connections. The maximum applications are connected.
TwccNods | 3 | No data source
TwccNoMedia | 29 | Source has nothing to capture for a transfer.
TwccNotEmpty | 19 | Operation failed because directory is not empty.
TwccOperationError | 5 | Operation error
TwccPaperDoubleFeed | 21 | The feeder detected multiple pages
TwccPaperJam | 20 | The feeder is jammed
TwccSeqError | 11 | Out of sequence error
TwccSuccess | 0 | Success

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.TwainProSdk.ConditionCode

See Also

Reference

Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
DataSourceManagerVersion Enumeration
See Also Send Feedback
Accusoft.TwainProSdk Namespace : DataSourceManagerVersion Enumeration

Glossary Item Box

Specifies what version of the Data Source Manager (DSM) to use.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum DataSourceManagerVersion
   Inherits System.Enum
'Usage

Dim instance As DataSourceManagerVersion
public enum DataSourceManagerVersion : System.Enum
__value public enum DataSourceManagerVersion : public System.Enum
public enum class DataSourceManagerVersion : public System.Enum

Members

Member | Value | Description
LatestSupportedVersionAvailable | 0 | Use the latest supported available DSM, otherwise default to an older version. If the TWAIN 2.x DSM can't be found, it will try to find the 1.x DSM, otherwise a TwainDllLoadException will be thrown.
None | -1 | No DSM has been selected.
Version1 | 1 | Use verion 1.x of the TWAIN DSM. If it can't be found, a TwainDllLoadException will be thrown. Note, on native 64-bit systems, Version 1 of the DSM (Data Source Manager) can't be used, you must use at least Version 2.
Version2 | 2 | Use verion 2.x of the TWAIN DSM. If it can't be found, a TwainDllLoadException will be thrown.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.TwainProSdk.DataSourceManagerVersion

See Also

Reference

Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
EncodeModeCompression Enumeration
See Also Send Feedback
Accusoft.TwainProSdk Namespace : EncodeModeCompression Enumeration

Glossary Item Box

Option values which specify the encoding mode to use when creating a JBIG2 compressed file.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum EncodeModeCompression
   Inherits System.Enum
'Usage

Dim instance As EncodeModeCompression
public enum EncodeModeCompression : System.Enum
__value public enum EncodeModeCompression : public System.Enum
public enum class EncodeModeCompression : public System.Enum

Members

Member | Value | Description
AutoDetect | 0 | Default, Lossless Generic MQ
LosslessGenericMmr | 2 | Fast, very good lossless compression, use for any content, similar to G4 coding, uses Huffman/MMR coding
LosslessGenericMq | 1 | Fast, great lossless compression, use for any content, uses MQ arithmetic coding
LosslessTextMmr | 4 | Very good lossless compression possible, use for text or symbols, uses Huffman/MMR coding
LosslessTextMq | 3 | Great lossless compression possible, use for text or symbols, uses MQ arithmetic coding
LosslessTextSpmMmr | 6 | Potentially best lossless compression for text or symbols, uses Huffman/MMR coding plus MQ arithmetic coding
LosslessTextSpmMq | 5 | Potentially best lossless compression for text or symbols, uses MQ arithmetic coding
LossyHalftoneMmr | 10 | Good lossy compression for halftones, uses Huffman/MMR coding
LossyHalftoneMq | 9 | Good lossy compression for halftones, uses MQ arithmetic coding
LossyTextMmr | 8 | Very good lossy compression for text or symbols, uses Huffman/MMR coding
LossyTextMq | 7 | Great lossy compression for text or symbols, uses MQ arithmetic coding

Remarks

Text regions can be encoded as lossless or as lossy according to the encoding mode specified. The lossy modes use the value in SaveOptionsPdf.LoosenessCompression to control how loose to be when matching symbols and thereby increase compression and reduce file size. Compression means loss, however, and a consequence of higher compression is an increased risk of errors in the reconstructed image.

Specify a larger value of looseness to reduce the compressed file size; use a smaller value to reduce the errors, if any. Halftone regions can be encoded lossy by specifying one of the lossy halftone encoding modes. Alternatively, they can be encoded lossless by using the lossless generic encoding mode.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.TwainProSdk.EncodeModeCompression

See Also

Reference

Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
ErrorLevel Enumeration
See Also Send Feedback
Accusoft.TwainProSdk Namespace : ErrorLevel Enumeration

Glossary Item Box

The error level of items to place into the debug log.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum ErrorLevel
   Inherits System.Enum
'Usage

Dim instance As ErrorLevel
public enum ErrorLevel : System.Enum
__value public enum ErrorLevel : public System.Enum
public enum class ErrorLevel : public System.Enum

Members

Member | Value | Description
Detailed | 2 | Place as much information into the debug log file as possible. You should use this option when you are tracking down a problem.
Development | 1 | Place information into the debug log file that is useful during normal development using this toolkit.
Production | 0 | Place minimal information into the debug log file.

Remarks

This enumeration allows you to specify the amount of detail to place into the debug log file.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.TwainProSdk.ErrorLevel

See Also

Reference

Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
EvaluationMode Enumeration
See Also Send Feedback
Accusoft.TwainProSdk Namespace : EvaluationMode Enumeration

Glossary Item Box

Option values which determine the evaluation mode of the component.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum EvaluationMode
   Inherits System.Enum
'Usage

Dim instance As EvaluationMode
public enum EvaluationMode : System.Enum
__value public enum EvaluationMode : public System.Enum
public enum class EvaluationMode : public System.Enum

Members

Member | Value | Description
Automatic | 0 | Automatic evaluation mode. When possible, this component will automatically detect that it is running without a user interface and switch to another evaluation mode. Otherwise, it will display the evaluation mode dialog box.
Timeout | 1 | Timeout evaluation mode. This is the appropriate evaluation mode for applications that have no user interface.

Remarks

In order to test the component in an application running as a service or other environments where the component does not have permissions to create a window, the application logic needs to set the EvaluationMode to Timeout. In this mode, the component does not attempt to create the Evaluation Mode dialog window, but will timeout after 5 minutes of operation and cease to operate.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.TwainProSdk.EvaluationMode

See Also

Reference

Accusoft.TwainProSdk Namespace
EvaluationMode Property


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
ExtendedImageInfo Enumeration
See Also Send Feedback
Accusoft.TwainProSdk Namespace : ExtendedImageInfo Enumeration

Glossary Item Box

Option values for extended image info enumeration values.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum ExtendedImageInfo
   Inherits System.Enum
'Usage

Dim instance As ExtendedImageInfo
public enum ExtendedImageInfo : System.Enum
__value public enum ExtendedImageInfo : public System.Enum
public enum class ExtendedImageInfo : public System.Enum

Members

Member | Value | Description
TweiBarcodeConfidence | 4634 | Barcode Confidence
TweiBarcodeCount | 4633 | Barcode Count
TweiBarcodeRotation | 4635 | Barcode Rotation
TweiBarcodeText | 4610 | Barcode Text
TweiBarcodeTextLength | 4636 | Barcode Text Length
TweiBarcodeType | 4611 | Barcode Type
TweiBarcodeX | 4608 | Barcode X
TweiBarcodeY | 4609 | Barcode Y
TweiBlackSpecklesRemoved | 4647 | Black Speckles Removed
TweiBookName | 4664 | Book Name
TweiCamera | 4668 | Camera
TweiChapterNumber | 4665 | Chapter Number
TweiDeshadeBlackCountNew | 4639 | Deshade Black Count New
TweiDeshadeBlackCountOld | 4638 | Deshade Black Count Old
TweiDeshadeBlackRLMax | 4641 | Deshade Black Run-Length Maximum
TweiDeshadeBlackRLMin | 4640 | Deshade Black Run-Length Minimum
TweiDeshadeCount | 4637 | Deshade Count
TweiDeshadeHeight | 4614 | Deshade Height
TweiDeshadeLeft | 4613 | Deshade Left
TweiDeshadeSize | 4616 | Deshade Size
TweiDeshadeTop | 4612 | Deshade Top
TweiDeshadeWhiteCountNew | 4643 | Deshade White Count New
TweiDeshadeWhiteCountOld | 4642 | Deshade White Count Old
TweiDeshadeWhiteRLAve | 4645 | Deshade White Run-Length Average
TweiDeshadeWhiteRLMax | 4646 | Deshade White Run-Length Maximum
TweiDeshadeWhiteRLMin | 4644 | Deshade White Run-Length Minimum
TweiDeshadeWidth | 4615 | Deshade Width
TweiDeskewStatus | 4651 | Deskew Status
TweiDocumentNumber | 4666 | Document Number
TweiEndorsedText | 4627 | Endorsed Text
TweiFileSystemSource | 4678 | File System Source
TweiFormConfidence | 4628 | Form Confidence
TweiFormHorzDocOffset | 4631 | Form Horizontal Document Offset
TweiFormTemplateMatch | 4629 | Form Template Match
TweiFormTemplatePageMatch | 4630 | Form Template Page Match
TweiFormVertDocOffset | 4632 | Form Vertical Document Offset
TweiFrame | 4670 | Frame
TweiFrameNumber | 4669 | Frame Number
TweiHorzLineCount | 4649 | Horizontal Line Count
TweiHorzLineLength | 4620 | Horizontal Line Length
TweiHorzLineThickness | 4621 | Horizontal Line Thickness
TweiHorzLineXCoord | 4618 | Horizontal Line X Coordinate
TweiHorzLineYCoord | 4619 | Horizontal Line Y Coordinate
TweiIccProfile | 4672 | ICC Profile
TweiLastSegment | 4673 | Last Segment
TweiMagData | 4675 | Magnetic Data
TweiMagType | 4676 | Magnetic Type
TweiPageNumber | 4667 | Page Number
TweiPageSide | 4677 | Page Side
TweiPatchCode | 4626 | Patch Code
TweiPixelFlavor | 4671 | Pixel Flavor
TweiSegmentNumber | 4674 | Segment Number
TweiSkewConfidence | 4654 | Skew Confidence
TweiSkewFinalAngle | 4653 | Skew Final Angle
TweiSkewOriginalAngle | 4652 | Skew Original Angle
TweiSkewWindowX1 | 4655 | Skew Window X1
TweiSkewWindowX2 | 4657 | Skew Window X2
TweiSkewWindowX3 | 4659 | Skew Window X3
TweiSkewWindowX4 | 4661 | Skew Window X4
TweiSkewWindowY1 | 4656 | Skew Window Y1
TweiSkewWindowY2 | 4658 | Skew Window Y2
TweiSkewWindowY3 | 4660 | Skew Window Y3
TweiSkewWindowY4 | 4662 | Skew Window Y4
TweiSpecklesRemoved | 4617 | Speckles Removed
TweiVertLineCount | 4650 | Vertical Line Count
TweiVertLineLength | 4624 | Vertical Line Length
TweiVertLineThickness | 4625 | Vertical Line Thickness
TweiVertLineXCoord | 4622 | Vertical Line X Coordinate
TweiVertLineYCoord | 4623 | Vertical Line Y Coordinate
TweiWhiteSpecklesRemoved | 4648 | White Speckles Removed
TwejMidSeparator | 1 | Mid Separator
TwejNone | 0 | None
TwejPatch1 | 2 | Patch 1
TwejPatch2 | 3 | Patch 2
TwejPatch3 | 4 | Patch 3
TwejPatch4 | 5 | Patch 4
TwejPatch6 | 6 | Patch 6
TwejPatchT | 7 | Patch T

Remarks

The extended info constants have the equivalent names and values as defined in the C header file, twain.h, available from the TWAIN Working Group’s web site at http://www.twain.org. The exact location of the twain.h header file is http://www.twain.org/devfiles/twain.h

Note: There may be extended info constants that are defined in the twain.h header file that are not included as a constant in the TwainPRO control.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.TwainProSdk.ExtendedImageInfo

See Also

Reference

Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
ExtendedImageInfoConstants Enumeration
See Also Send Feedback
Accusoft.TwainProSdk Namespace : ExtendedImageInfoConstants Enumeration

Glossary Item Box

Option values for extended image info constants enumeration values.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum ExtendedImageInfoConstants
   Inherits System.Enum
'Usage

Dim instance As ExtendedImageInfoConstants
public enum ExtendedImageInfoConstants : System.Enum
__value public enum ExtendedImageInfoConstants : public System.Enum
public enum class ExtendedImageInfoConstants : public System.Enum

Members

Member | Value | Description
TwbcorRot0 | 0 | Barcode Orientation Rotated 0
TwbcorRot180 | 2 | Barcode Orientation Rotated 180
TwbcorRot270 | 3 | Barcode Orientation Rotated 270
TwbcorRot90 | 1 | Barcode Orientation Rotated 90
TwbcorRotX | 4 | Barcode Orientation Not Known
Twbt2Of5DataLogic | 15 | Barcode Type 2 Of 5 Data Logic
Twbt2Of5Iata | 16 | Barcode Type 2 Of 5 IATA
Twbt2Of5Industrial | 13 | Barcode Type 2 Of 5 Industrial
Twbt2Of5Interleaved | 1 | Barcode Type 2 Of 5 Interleaved
Twbt2Of5Matrix | 14 | Barcode Type 2 Of 5 Matrix
Twbt2Of5Noninterleaved | 2 | Barcode Type 2 Of 5 Non-Interleaved
Twbt3Of9 | 0 | Barcode Type 3 Of 9
Twbt3Of9FullAscii | 17 | Barcode Type 3 Of 9 Full ASCII
TwbtCodabar | 6 | Barcode Type Codabar
TwbtCodabarWithStartStop | 18 | Barcode Type Codabar With Start Stop
TwbtCode128 | 4 | Barcode Type Code 128
TwbtCode93 | 3 | Barcode Type Code 93
TwbtEan13 | 10 | Barcode Type EAN 13
TwbtEan8 | 9 | Barcode Type EAN 8
TwbtMaxicode | 19 | Barcode Type Maxicode
TwbtPdf417 | 12 | Barcode Type PDF 417
TwbtPostNet | 11 | Barcode Type Postnet
TwbtUcc128 | 5 | Barcode Type UCC 128
TwbtUpca | 7 | Barcode Type UPCA
TwbtUpce | 8 | Barcode Type UPCE
TwdskDisabled | 3 | Deskew Status Disabled
TwdskFail | 2 | Deskew Status Fail
TwdskReportOnly | 1 | Deskew Status Report Only
TwdskSuccess | 0 | Deskew Status Success
TwmdMicr | 0 | Magnetic Data MICR
TwpchPatch1 | 0 | Patch Code Patch 1
TwpchPatch2 | 1 | Patch Code Patch 2
TwpchPatch3 | 2 | Patch Code Patch 3
TwpchPatch4 | 3 | Patch Code Patch 4
TwpchPatch6 | 4 | Patch Code Patch 6
TwpchPatchT | 5 | Patch Code Patch T

Remarks

The extended info constants have the equivalent names and values as defined in the C header file, twain.h, available from the TWAIN Working Group’s web site at http://www.twain.org. The exact location of the twain.h header file is http://www.twain.org/devfiles/twain.h

Note: There may be extended info constants that are defined in the twain.h header file that are not included as a constant in the TwainPRO control.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.TwainProSdk.ExtendedImageInfoConstants

See Also

Reference

Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
FileOrganizationCompression Enumeration
See Also Send Feedback
Accusoft.TwainProSdk Namespace : FileOrganizationCompression Enumeration

Glossary Item Box

Option values which determine the file organization when saving a JBIG2 compressed file.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum FileOrganizationCompression
   Inherits System.Enum
'Usage

Dim instance As FileOrganizationCompression
public enum FileOrganizationCompression : System.Enum
__value public enum FileOrganizationCompression : public System.Enum
public enum class FileOrganizationCompression : public System.Enum

Members

Member | Value | Description
Default | 0 | Default, sequential organization
RandomAccess | 2 | Random access organization
Sequential | 1 | Sequential organization

Remarks

A JBIG2 compressed file may be organized in two ways: sequential or random access. Sequential organization is intended for streaming applications, where the decoder reads and decodes the file in order as the data is received. Random access organization permits the decoder to know the entire file structure, without having to read the entire file, and then uses that information to access the required data in a random-access fashion. This organization is useful for applications such as decoding only odd-number pages.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.TwainProSdk.FileOrganizationCompression

See Also

Reference

Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Filter Enumeration
See Also Send Feedback
Accusoft.TwainProSdk Namespace : Filter Enumeration

Glossary Item Box

The filters available for PNG compression.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum Filter
   Inherits System.Enum
'Usage

Dim instance As Filter
public enum Filter : System.Enum
__value public enum Filter : public System.Enum
public enum class Filter : public System.Enum

Members

Member | Value | Description
Average | 3 | The Average filter uses the average of the two neighboring pixels (left and above) to predict the value of a pixel.
None | 0 | Fastest, no filter is used.
Optimal | 5 | Optimal compressed file size, at the expense of speed.
Paeth | 4 | The Paeth filter computes a simple linear function of the three neighboring pixels (left, above, upper left), then chooses as predictor the neighboring pixel closest to the computed value. This technique is due to Alan W. Paeth.
Sub | 1 | The Sub filter transmits the difference between each byte and the value of the corresponding byte of the prior pixel.
Up | 2 | The Up filter is just like the Sub filter except that the pixel immediately above the current pixel, rather than just to its left, is used as the predictor.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.TwainProSdk.Filter

See Also

Reference

Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
HorizontalAlignment Enumeration
See Also Send Feedback
Accusoft.TwainProSdk Namespace : HorizontalAlignment Enumeration

Glossary Item Box

Option values which determine the horizontal alignment of the caption within the clipping rectangle.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum HorizontalAlignment
   Inherits System.Enum
'Usage

Dim instance As HorizontalAlignment
public enum HorizontalAlignment : System.Enum
__value public enum HorizontalAlignment : public System.Enum
public enum class HorizontalAlignment : public System.Enum

Members

Member | Value | Description
Center | 2 | The text is horizontally centered.
Left | 0 | The text is left justified.
Right | 1 | The text is right justified.

Remarks

The clipping rectangle is determined by the Caption.Clip and Caption.Area properties.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.TwainProSdk.HorizontalAlignment

See Also

Reference

Accusoft.TwainProSdk Namespace
Clip Property
Area Property


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
Orientation Enumeration
See Also Send Feedback
Accusoft.TwainProSdk Namespace : Orientation Enumeration

Glossary Item Box

Option values which determine the TWAIN capability constants for the ICAP_ORIENTATION capability.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum Orientation
   Inherits System.Enum
'Usage

Dim instance As Orientation
public enum Orientation : System.Enum
__value public enum Orientation : public System.Enum
public enum class Orientation : public System.Enum

Members

Member | Value | Description
TworAuto | 4 | Auto
TworAutoPicture | 6 | Auto Picture
TworAutoText | 5 | Auto Text
TworLandscape | 3 | Landscape
TworPortrait | 0 | Portrait
TworRot0 | 0 | Rotated 0
TworRot180 | 2 | Rotated 180
TworRot270 | 3 | Rotated 270
TworRot90 | 1 | Rotated 90

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.TwainProSdk.Orientation

See Also

Reference

Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
PdfCompression Enumeration
See Also Send Feedback
Accusoft.TwainProSdk Namespace : PdfCompression Enumeration

Glossary Item Box

Option values which determine the PDF compression.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum PdfCompression
   Inherits System.Enum
'Usage

Dim instance As PdfCompression
public enum PdfCompression : System.Enum
__value public enum PdfCompression : public System.Enum
public enum class PdfCompression : public System.Enum

Members

Member | Value | Description
Default | 6 | Default compression
Group3Fax1d | 1 | CCITT Group 3 one-dimensional fax compression
Group3Fax2d | 2 | CCITT Group 3 two-dimensional fax compression
Group4 | 3 | CCITT Group 4 fax compression
Jbig2 | 4 | JBIG2 compression format
Jpeg | 5 | JPEG compression format
NoCompression | 0 | No compression

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.TwainProSdk.PdfCompression

See Also

Reference

Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
PixelType Enumeration
See Also Send Feedback
Accusoft.TwainProSdk Namespace : PixelType Enumeration

Glossary Item Box

Option values which determine the type of pixel data that a Source is capable of acquiring (for example, black and white, gray, RGB, etc.).

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum PixelType
   Inherits System.Enum
'Usage

Dim instance As PixelType
public enum PixelType : System.Enum
__value public enum PixelType : public System.Enum
public enum class PixelType : public System.Enum

Members

Member | Value | Description
TwptBW | 0 | Black and white
TwptGray | 1 | Gray
TwptPalette | 3 | Palette
TwptRgb | 2 | RGB

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.TwainProSdk.PixelType

See Also

Reference

Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
ScannedImageCompression Enumeration
See Also Send Feedback
Accusoft.TwainProSdk Namespace : ScannedImageCompression Enumeration

Glossary Item Box

Option values which determine the compression format of an acquired image.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum ScannedImageCompression
   Inherits System.Enum
'Usage

Dim instance As ScannedImageCompression
public enum ScannedImageCompression : System.Enum
__value public enum ScannedImageCompression : public System.Enum
public enum class ScannedImageCompression : public System.Enum

Members

Member | Value | Description
TwcpGroup31D | 2 | Group 3 1D, follows CCITT spec (no End Of Line)
TwcpGroup31DEol | 3 | Group 3 1D, follows CCITT spec (has End Of Line)
TwcpGroup32D | 4 | Group 3 2D, follows CCITT spec (use cap for K Factor)
TwcpGroup4 | 5 | Group 4, follows CCITT spec
TwcpJpeg | 6 | JPEG
TwcpNone | 0 | No compression
TwcpPackbits | 1 | Packbits

Remarks

TwcpNone means that the image is in an uncompressed DIB format and can be accessed through the ToHdib, ToBitmap, ToHbitmap, or SaveStream methods.

TwcpJpeg means that the image is in a JPEG format and should be accessed through the SaveStream method.

All other values mean that the image is in a TIFF format and should be accessed through the SaveStream method.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.TwainProSdk.ScannedImageCompression

See Also

Reference

Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
ScannedImageFormat Enumeration
See Also Send Feedback
Accusoft.TwainProSdk Namespace : ScannedImageFormat Enumeration

Glossary Item Box

Option values which determine the format of the saved file.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum ScannedImageFormat
   Inherits System.Enum
'Usage

Dim instance As ScannedImageFormat
public enum ScannedImageFormat : System.Enum
__value public enum ScannedImageFormat : public System.Enum
public enum class ScannedImageFormat : public System.Enum

Members

Member | Value | Description
Bmp | 2 | BMP
Default | 0 | Default
Jpeg | 3 | JPEG
Pdf | 5 | PDF
Pic | 4 | Pegasus PIC
Png | 6 | Png
Tiff | 1 | Tiff

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.TwainProSdk.ScannedImageFormat

See Also

Reference

Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
SubSampling Enumeration
See Also Send Feedback
Accusoft.TwainProSdk Namespace : SubSampling Enumeration

Glossary Item Box

Option values which determine the subsampling type for a JPEG, ePIC, JPEG compressed TIFF, or JPEG compressed PDF file format.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum SubSampling
   Inherits System.Enum
'Usage

Dim instance As SubSampling
public enum SubSampling : System.Enum
__value public enum SubSampling : public System.Enum
public enum class SubSampling : public System.Enum

Members

Member | Value | Description
SubSampling111 | 0 | No sub-sampling
SubSampling211 | 1 | Sub-sampled 2:1 horizontally
SubSampling211v | 3 | Sub-sampled 2:1 vertically
SubSampling411 | 2 | Sub-sampled 2:1 horizontally and vertically

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.TwainProSdk.SubSampling

See Also

Reference

Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
SupportedSizes Enumeration
See Also Send Feedback
Accusoft.TwainProSdk Namespace : SupportedSizes Enumeration

Glossary Item Box

Option values which determine the TWAIN capability sizes for the ICAP_SUPPORTEDSIZES capability.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum SupportedSizes
   Inherits System.Enum
'Usage

Dim instance As SupportedSizes
public enum SupportedSizes : System.Enum
__value public enum SupportedSizes : public System.Enum
public enum class SupportedSizes : public System.Enum

Members

Member | Value | Description
Twss2A0 | 18 | Supported size 2A0.
Twss4A0 | 17 | Supported size 4A0.
TwssA0 | 19 | Supported size A0.
TwssA1 | 20 | Supported size A1.
TwssA10 | 25 | Supported size A10.
TwssA2 | 21 | Supported size A2.
TwssA3 | 11 | Supported size A3.
TwssA4 | 1 | Supported size A4.
TwssA4Letter | 1 | Supported size A4 letter.
TwssA5 | 5 | Supported size A5.
TwssA6 | 13 | Supported size A6.
TwssA7 | 22 | Supported size A7.
TwssA8 | 23 | Supported size A8.
TwssA9 | 24 | Supported size A9.
TwssB3 | 12 | Supported size B3.
TwssB4 | 6 | Supported size B4.
TwssB5Letter | 2 | Supported size B5 letter.
TwssB6 | 7 | Supported size B6.
TwssBusinessCard | 53 | Supported size Business Card.
TwssC0 | 44 | Supported size C0.
TwssC1 | 45 | Supported size C1.
TwssC10 | 51 | Supported size C10.
TwssC2 | 46 | Supported size C2.
TwssC3 | 47 | Supported size C3.
TwssC4 | 14 | Supported size C4.
TwssC5 | 15 | Supported size C5.
TwssC6 | 16 | Supported size C6.
TwssC7 | 48 | Supported size C7.
TwssC8 | 49 | Supported size C8.
TwssC9 | 50 | Supported size C9.
TwssIsoB0 | 26 | Supported size ISOB0.
TwssIsoB1 | 27 | Supported size ISOB1.
TwssIsoB10 | 33 | Supported size ISOB10.
TwssIsoB2 | 28 | Supported size ISOB2.
TwssIsoB3 | 12 | Supported size ISOB3.
TwssIsoB4 | 6 | Supported size ISOB4.
TwssIsoB5 | 29 | Supported size ISOB5.
TwssIsoB6 | 7 | Supported size ISOB6.
TwssIsoB7 | 30 | Supported size ISOB7.
TwssIsoB8 | 31 | Supported size ISOB8.
TwssIsoB9 | 32 | Supported size ISOB9.
TwssJisB0 | 34 | Supported size JISB0.
TwssJisB1 | 35 | Supported size JISB1.
TwssJisB10 | 43 | Supported size JISB10.
TwssJisB2 | 36 | Supported size JISB2.
TwssJisB3 | 37 | Supported size JISB3.
TwssJisB4 | 38 | Supported size JISB4.
TwssJisB5 | 2 | Supported size JISB5.
TwssJisB6 | 39 | Supported size JISB6.
TwssJisB7 | 40 | Supported size JISB6.
TwssJisB8 | 41 | Supported size JISB8.
TwssJisB9 | 42 | Supported size JISB9.
TwssNone | 0 | Supported size none.
TwssUSExecutive | 10 | Supported size US executive.
TwssUSLedger | 9 | Supported size US ledger.
TwssUSLegal | 4 | Supported size US legal.
TwssUSLetter | 3 | Supported size US letter.
TwssUSStatement | 52 | Supported size US statement.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.TwainProSdk.SupportedSizes

See Also

Reference

Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
TiffCompression Enumeration
See Also Send Feedback
Accusoft.TwainProSdk Namespace : TiffCompression Enumeration

Glossary Item Box

Option values which determine TIFF compression enumeration values.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum TiffCompression
   Inherits System.Enum
'Usage

Dim instance As TiffCompression
public enum TiffCompression : System.Enum
__value public enum TiffCompression : public System.Enum
public enum class TiffCompression : public System.Enum

Members

Member | Value | Description
Group3Fax1d | 2 | CCITT Group 3 one-dimensional fax compression
Group3Fax2d | 3 | CCITT Group 3 two-dimensional fax compression
Group4 | 4 | CCITT Group 4 fax compression
JPEG6 | 6 | TIFF with JPEG6 (Old-style) compression
JPEG7 | 7 | TIFF with JPEG7 (New-style) compression
NoCompression | 0 | No compression
Rle | 1 | Run length encoding

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.TwainProSdk.TiffCompression

See Also

Reference

Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
TransferMode Enumeration
See Also Send Feedback
Accusoft.TwainProSdk Namespace : TransferMode Enumeration

Glossary Item Box

Option values which determine transferring images from the Data Source.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum TransferMode
   Inherits System.Enum
'Usage

Dim instance As TransferMode
public enum TransferMode : System.Enum
__value public enum TransferMode : public System.Enum
public enum class TransferMode : public System.Enum

Members

Member | Value | Description
TwsxMemory | 2 | Memory
TwsxNative | 0 | Native

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.TwainProSdk.TransferMode

See Also

Reference

Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
VerticalAlignment Enumeration
See Also Send Feedback
Accusoft.TwainProSdk Namespace : VerticalAlignment Enumeration

Glossary Item Box

Option values which determine the vertical alignment of the caption within the clipping rectangle.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum VerticalAlignment
   Inherits System.Enum
'Usage

Dim instance As VerticalAlignment
public enum VerticalAlignment : System.Enum
__value public enum VerticalAlignment : public System.Enum
public enum class VerticalAlignment : public System.Enum

Members

Member | Value | Description
Bottom | 1 | The text is bottom justified.
Center | 2 | The text is vertically centered.
Top | 0 | The text is top justified.

Remarks

The clipping rectangle is determined by the Clip and Area properties.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.TwainProSdk.VerticalAlignment

See Also

Reference

Accusoft.TwainProSdk Namespace
Clip Property
Area Property


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
ScannedEventHandler Delegate
See Also Send Feedback
Accusoft.TwainProSdk Namespace : ScannedEventHandler Delegate

sender
The object that issued the post-scan event.
e
Arguments for the scanned event. This object contains a scanned image object, a property for cancelling the scanning session, and a property indicating the number of pending transfers.

Glossary Item Box

A delegate for post-scan events.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Delegate Sub ScannedEventHandler( _
   ByVal sender As Object, _
   ByVal e As ScannedEventArgs _
)
'Usage

Dim instance As New ScannedEventHandler(AddressOf HandlerMethod)
public delegate void ScannedEventHandler(
   object sender,
   ScannedEventArgs e
)
public: __gc __delegate void ScannedEventHandler(
   Object* sender,
   ScannedEventArgs* e
)
public delegate void ScannedEventHandler(
   Object^ sender,
   ScannedEventArgs^ e
)

Parameters

sender
The object that issued the post-scan event.
e
Arguments for the scanned event. This object contains a scanned image object, a property for cancelling the scanning session, and a property indicating the number of pending transfers.

Remarks

This is the delegate for post-scan events. The TwainDevice class uses this delegate whenever a scan or transfer ends.

See Also

Reference

ScannedEventHandler Members
Accusoft.TwainProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.TwainPro7.Net
ScanningEventHandler Delegate
See Also Send Feedback
Accusoft.TwainProSdk Namespace : ScanningEventHandler Delegate

sender
The object that issued the pre-scan event.
e
Arguments for the scanning event. This object contains a scanned image data object, a property for cancelling the scanning session, and a property indicating the number of pending transfers.

Glossary Item Box

A delegate for pre-scan events.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Delegate Sub ScanningEventHandler( _
   ByVal sender As Object, _
   ByVal e As ScanningEventArgs _
)
'Usage

Dim instance As New ScanningEventHandler(AddressOf HandlerMethod)
public delegate void ScanningEventHandler(
   object sender,
   ScanningEventArgs e
)
public: __gc __delegate void ScanningEventHandler(
   Object* sender,
   ScanningEventArgs* e
)
public delegate void ScanningEventHandler(
   Object^ sender,
   ScanningEventArgs^ e
)

Parameters

sender
The object that issued the pre-scan event.
e
Arguments for the scanning event. This object contains a scanned image data object, a property for cancelling the scanning session, and a property indicating the number of pending transfers.

Remarks

This is the delegate for pre-scan events. The TwainDevice class uses this delegate whenever a scan or transfer begins.

See Also

Reference

ScanningEventHandler Members
Accusoft.TwainProSdk Namespace