%%ItemTitle%%

Accusoft.ThumbnailXpress4.Net
ThumbnailXpress User Assistance Dashboard
Send Feedback

Glossary Item Box

Welcome

  • Overview of Product Family
    • What is the ImagXpress Product Family?
  • New Features
    • What is ThumbnailXpress?

Getting Started

  • Operating Requirements & Installation
    • Operating Requirements
    • Upgrading from ThumbnailXpress 3 to ThumbnailXpress 4
    • Installing on a Development Machine
  • Licensing & Deployment
    • Licensing
    • Distributing ThumbnailXpress
    • Software License Agreement
    • Accusoft Corporation Copyrights & Trademarks

Developer's Guide

  • User Guide

    • Concepts

      • Overview of ThumbnailXpress
      • Glossary
    • How To
      • Define Cache and Threading Behavior
      • Define End-User Interface
      • Pass Image Data between Accusoft Components
      • Render Thumbnails with Annotations
      • Load and Display Thumbnails
      • Modify Thumbnails
      • Navigate Thumbnails
      • Save Thumbnails
      • Print Thumbnails
      • Debug
  • API Reference Guide
    • Accusoft.ThumbnailXpress4.Net Assembly

Additional Resources

  • White papers & Case Studies
  • FAQs, ThumbnailXpress FAQs
  • Support Overview
  • Support Plans/Agreement

Feedback

  • Tell us what you think
    • Email us
    • Take our survey

©2012. Accusoft Corporation. All Rights Reserved.


%%ItemTitle%%

ThumbnailXpress 4 for .NET - User Guide
Send Feedback

Glossary Item Box

This User Guide provides information about the following:

  • Introduction
  • Getting Started
  • Licensing
  • Distributing Applications and Deployment
  • Concepts
  • How To


%%ItemTitle%%

Introduction
Send Feedback
ThumbnailXpress 4 for .NET - User Guide > Introduction

Glossary Item Box

This section provides information about the following:

  • What is ThumbnailXpress?
  • What is the ImagXpress Product Family?
  • Getting Support
  • Accusoft Corporation Copyrights & Trademarks


%%ItemTitle%%

What is ThumbnailXpress?
See Also Send Feedback
ThumbnailXpress 4 for .NET - User Guide > Introduction > What is ThumbnailXpress?

Glossary Item Box

ThumbnailXpress™ Version 4 provides support for the generation and display of thumbnail images.

New Features in Version 4

ThumbnailXpress 4 introduces the ability to do the following:

  • Display annotations associated with the displayed image data.
  • Set the border color and/or background color on individual thumbnails.
  • Use customer provided error icons and pre-display icons.
  • Indicate whether or not to use an embedded thumbnail of a camera raw image.
  • Easily copy or transfer image data to other Accusoft components without having to manually work with DIBs.
  • Return the version/build number programmatically.
  • Use Accusoft's new licensing model.

Primary Features

  • Input single image files,folders of images, and individual pages of multi-page images
  • Generates thumbnail images of all image types supported in ImagXpress
  • Integrate seamlessly with Accusoft PDFXpress™ for displaying thumbnail images of PDF files
  • Provides fast sizing and filtering of input files
  • Provides control of display features including thumbnail size, spacing, border lines, and selection
  • Provides control over sophisticated asynchronous threading capabilities for rapid generation of thumbnail images from source images
  • Optimized thumbnail caching for fast scrolling through thumbnail lists
  • Provide custom or various 'stock' labels for thumbnail items
  • Develop powerful image thumbnailing applications for Windows

See Also

Getting Support
Software License Agreement
Operating Requirements


%%ItemTitle%%

What is the ImagXpress Product Family?
Send Feedback
ThumbnailXpress 4 for .NET - User Guide > Introduction > What is the ImagXpress Product Family?

Glossary Item Box

ImagXpress® Version 11 lets you quickly add the world's most trusted imaging functions to your Windows application. With our powerful imaging tools, you can quickly develop applications that require complex imaging tasks for document imaging, photo processing, or medical applications, while you concentrate on the unique needs of your program.

ImagXpress is the image handling engine behind most of our advanced recognition and image processing products. It's the fastest way to develop professional applications involving images.

The ImagXpress v11 Product Family includes the following Components:

  • ImagXpress v11 – image compression, decompression, viewing, and processing
  • NotateXpress™ v11 – image annotation support
  • ThumbnailXpress™ v4 – thumbnail image support
  • TwainPRO™ v7 – TWAIN image acquisition support
  • PrintPRO™ v6 – image printing support

ImagXpress Editions

The components within the ImagXpress v11 Product Family are available in two editions, designed to meet specific imaging needs:

  • Professional: includes ImagXpress, NotateXpress, TwainPRO, PrintPRO, and ThumbnailXpress
  • Standard: includes ImagXpress, TwainPRO, and ThumbnailXpress

Additional Accusoft Components

Additional components are available for purchase separately, and integrate easily to provide a comprehensive imaging solution:

  • ISIS® Xpress™ – ISIS image acquisition support; license sold separately
  • PDF Xpress™ – PDF creation, viewing, and annotating
  • OCR Xpress™ – full page OCR
  • Barcode Xpress™ – recognize barcodes
  • ScanFix Xpress™ – advanced image cleanup
  • FormFix™ – form ID, dropout, and OMR
  • SmartZone™ ICR / OCR – character recognition
  • ImageGear for .NET - Fully managed code to create cutting edge imaging applications
  • ImageGear for Silverlight - Comprehensive SDK for building Web imaging applications
  • ImageGear for .NET Compact Framework - Create reliable and secure imaging applications for mobile devices

See www.accusoft.com for product packaging and sales information.


%%ItemTitle%%

Getting Support
See Also Send Feedback
ThumbnailXpress 4 for .NET - User Guide > Introduction > Getting Support

Glossary Item Box

For information about Accusoft Support, please refer to the Software Support and Maintenance Policy on the Accusoft web site or call Accusoft at 813-875-7575.

See Also

Operating Requirements
Installing on a Development Machine


%%ItemTitle%%

Accusoft Corporation Copyrights & Trademarks
See Also Send Feedback
ThumbnailXpress 4 for .NET - User Guide > Introduction > Accusoft Corporation Copyrights & Trademarks

Glossary Item Box

©2005-2012 Accusoft Corporation. All rights reserved.

Information in this document is subject to change without notice. No part of this document may be reproduced or transmitted in any form or by any means, electronic or mechanical, for any purpose, without the express written permission of Accusoft® Corporation.

This manual and the software described in it are both products of the USA.

Accusoft Corporation
4001 North Riverside Drive
Tampa, FL 33603
Sales: 813-875-7575
www.accusoft.com

Accusoft Trademarks

The following are trademarks (™) or registered marks (®) of Accusoft Corporation:

  • Accusoft®
  • Accusoft Logo™
  • Accusoft Pegasus Logo™
  • Adeptol®
  • AIMTools™
  • Barcode Xpress™
  • CapturePro™
  • Digital Mark Recognition® (DMR)
  • FolderBots™
  • FormAssist™
  • FormDirector™
  • FormFix™
  • FormSuite™
  • ImageGear® for .NET
  • ImageGear® for .NET Compact Framework
  • ImageGear® for Silverlight
  • ImageGear® Medical
  • ImageGear® Professional
  • ImageGear®
  • ImageTransport MD™
  • ImagXpress®
  • ISIS® Xpress™
    • ISIS is a registered trademark of EMC Corporation
    • ISIS Xpress is a trademark of Accusoft Corporation
  • MICR Xpress™
  • NetVue™
  • NotateXpress™
  • PDF Xpress™
  • Pegasus®
  • PICTools™
  • PICTools™ Document
  • PICTools™ Fingerprint
  • PICTools™ Medical
  • PICTools™ Photo
  • PICVideo™ M-JPEG Codec
  • PrintPRO™
  • Prizm®
  • Prizm® Viewer
  • ScanFix® Xpress™
  • SmartZone™
  • The JPEG Wizard™
  • ThumbnailXpress™
  • TwainPRO™

Accusoft and/or its agents use these marks and brand names in connection with its goods and/or services, in the United States and other countries.

Microsoft, Internet Explorer, Microsoft.NET, Silverlight, Visual Basic, Visual Studio, and Visual Studio.NET are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries.

Itanium is a registered trademark of Intel Corporation in the United States and other countries.

All other product and brand names are the property of their respective owners.

See Also

Software License Agreement


%%ItemTitle%%

Getting Started
Send Feedback
ThumbnailXpress 4 for .NET - User Guide > Getting Started

Glossary Item Box

This section provides information about the following:

  • Operating Requirements
  • Installing on a Development Machine
  • Upgrading from ThumbnailXpress 3 to ThumbnailXpress 4


%%ItemTitle%%

Operating Requirements
See Also Send Feedback
ThumbnailXpress 4 for .NET - User Guide > Getting Started > Operating Requirements

Glossary Item Box

Operating Systems

ThumbnailXpress™ runs on supported Microsoft Operating Systems:

  • Windows XP and XP Professional
  • Windows Vista
  • Windows 7
  • Windows Server 2003
  • Windows Server 2008
ThumbnailXpress runs in 64-bit, 32-bit, and AnyCPU-compiled executables.
Although it may run, ThumbnailXpress is not supported on previous Windows versions (for example, Windows 2000).

Threading

Accusoft considers thread-safe to be when an application using this component can use multiple controls running in the same process, where they don't interfere with each other. The thread creating the control owns the control and is the only thread that can interact with it.

Development Environment

  • Microsoft .NET Framework 2.0, 3.0
  • Microsoft Visual Studio 2005
  • Microsoft Visual Studio 2008

See Also

Getting Support
Installing on a Development Machine


%%ItemTitle%%

Installing on a Development Machine
See Also Send Feedback
ThumbnailXpress 4 for .NET - User Guide > Getting Started > Installing on a Development Machine

Glossary Item Box

To Install ThumbnailXpress™ Component

Run the downloaded setup program which installs the development kit on your development machine. The downloaded development kit includes code samples for supported platforms. Samples are available through: Start | Programs | Accusoft | ThumbnailXpress 4 menu.

By default this will register trial licensing which allows you to develop applications but not to distribute them. The trial license allows testing of all the functions and features.

Please see the section Distributing ThumbnailXpress to understand the limits and details to convert licensing editions.
In order to distribute your finished application you must purchase and install a fully paid license from Accusoft. The paid licenses override trial licenses.

To Use ThumbnailXpress Help Files

Once you have installed ThumbnailXpress, you will have access to the following stand-alone help file:

  • Accusoft.ThumbnailXpress4.Net.chm

    Access the ThumbnailXpress stand-alone help through the Windows Start menu: Start | Programs | Accusoft | ThumbnailXpress 4

In addition, you will have access to the following compiled collection help file, depending on which version of Visual Studio you have installed::

  • Accusoft.ThumbnailXpress4.Net.hxs - Help 2 collection files. If you have Visual Studio 2005 or 2008, these Help 2 files will be registered.
  • AccusoftThumbnailXpress4_Net.cab - MHV (Microsoft Help Viewer). If you have Visual Studio 2010, these MHV files will be registered.

Plugging ThumbnailXpress Help into Visual Studio

ThumbnailXpress Help 2 files integrate within the Help system in Visual Studio .NET. To access ThumbnailXpress Help within Visual Studio, do the following:

  • Ensure that the MSDN Library is installed in your Visual Studio environment. If it is not installed, re-install it from your VS.NET disc.
  • Ensure that MS Help Integration Kit is installed in your Visual Studio environment. If you do not have it installed:
  1. Download the Help Integration kit from MSDN.
  2. Close Visual Studio.
  • Re-open Visual Studio, select the Help Menu and the Contents submenu. Verify Help files for Accusoft controls are listed. If Accusoft Help is not listed:
  1. Search for "VSCC" in Visual Studio Help, leaving the "Filtered by:" list box blank. Select the "Visual Studio .NET Combined Help Collection Manager" topic.
  2. Select the Help 2 collections available on your PC under the heading "Collections available for inclusion in VSCC."
  3. Take care when excluding Help collections from the default VSCC collection. These collections may be necessary to view required documentation. Instead, use the "Filtered by:" field on the Contents tab of the Help panel to focus searches on Accusoft topics. Leave the "Filtered by:" list box empty to view the entire Accusoft Help files.
  4. Select the Update VSCC button.
  5. Close all instances of Visual Studio and Microsoft Document Explorer. When you restart Visual Studio, the VSCC Help collection revises with your changes.
    This may take several minutes.
  6. Check the Visual Studio Help/Contents tab again to see the Help collections available to you.
  • Select the ThumbnailXpress Help file to view Help content.

See Also

Operating Requirements
Software License Agreement
Distributing ThumbnailXpress

Licensing
Licensing


%%ItemTitle%%

Upgrading from ThumbnailXpress 3 to ThumbnailXpress 4
Send Feedback
ThumbnailXpress 4 for .NET - User Guide > Getting Started > Upgrading from ThumbnailXpress 3 to ThumbnailXpress 4

Glossary Item Box

This section describes how to upgrade from ThumbnailXpress 3 to ThumbnailXpress 4. While generally you'll be able to replace ThumbnailXpress 3 with ThumbnailXpress 4, there are a few important changes you may need to consider. This section provides information about those changes.

Changes and New Properties/Methods

  • Loading time for CAD images has been improved for displaying from directory, and displaying from file when multi-layout expansion is disabled. This improvement in performance can be up to hundreds of milliseconds depending on the image.
  • Added a new method CreateFilterCollection() to the Accusoft.ThumbnailXpressSdk.ThumbnailXpress class to create Filter Collections.
  • Added a CellBorderColor property to the Accusoft.ThumbnailXpressSdk.ThumbnailItem class to get and set the Cell Border Color for individual Thumbnail Items.
  • Added a CellBackColor property to the Accusoft.ThumbnailXpressSdk.ThumbnailItem class to get and set the Cell Back Color for individual Thumbnail Items.
  • Added a CustomErrorIcon property to the Accusoft.ThumnbailXpressSdk.ThumbnailXpress class to allow a custom icon to be used for errors instead of the stock icon provided by ThumbnailXpress. Added a CustomGeneratingIcon property to the Accusoft.ThumnbailXpressSdk.ThumbnailXpress class to allow a custom icon to be used for pre-image generation instead of the stock icon provided by ThumbnailXpress.
  • Added a new property NotateXpressInstance to Accusoft.ThumbnailXpressSdk.ThumbnailXpress class. This property is designed to be set to the value of the Accusoft.NotateXpressSdk.HandleInstance property. It's used to enable annotation functionality for thumbnails. Note that NotateXpress is a separate control from ThumbnailXpress.
  • Added a new method LoadAnnotationsFromStream() to the Accusoft.ThumbnailXpressSdk.ThumbnailItem class. This method is designed to load annotation data from the Accusoft.NotateXpressSdk.LayerCollection.SaveToThumbnailAnnotationStream() method. Note that NotateXpress is a separate control from ThumbnailXpress.
  • Added a new property AnnotationSearchOrder to the Accusoft.ThumbnailXpressSdk.ThumbnailXpress class. This property allows the user to specify a search order to use when associating external annotation files with the item being thumbnailed.
  • Added the read-only properties AnnotationsFilename, ExternalAnnotationType, InternalAnnotationType, and HasAnnotations to the Accusoft.ThumbnailXpressSdk.ThumbnailItem class. These serve to inform the user about the annotations actually used.
  • Added a new property UseCameraRawThumbnail to the Accusoft.ThumbnailXpressSdk.ThumbnailXpress class, which indicates whether to use the embedded thumbnail of the camera raw image which typically loads faster than the full-size image.
  • Added Version property to the ThumbnailXpress class.
  • Added the ability to easily copy or transfer image data to other Accusoft components without having to manually work with DIBs. See the Pass Image Data between Accusoft Components topic, along with the TransferTo() and CopyTo() methods.
  • The Hbitmap and Hdib properties of the Accusoft.ThumbnailXpressSdk.ThumbnailItem class have been deprecated, they have been replaced with the ToHbitmap() and ToHdib() methods respectively. This change was done so that memory was not allocated during a property get, which could happen, for example, when checking the property value in a watch during debugging. The deprecated properties will be removed in version 5 of ThumbnailXpress.
  • The AccessPdfXpress3() method of the Accusoft.ThumbnailXpressSdk.Licensing class has been marked as deprecated and will be removed in version 5 of ThumbnailXpress. Users should use the AccessPdfXpress4() method. The AccessPdfXpress() and AccessPdfXpress2() methods have been removed, since they were marked deprecated in version 3 of ThumbnailXpress.
  • The CacheFile, CacheFilePath, CacheDiskLimit properties, and the CacheFlushMemory() method of the Accusoft.ThumbnailXpressSdk.ThumbnailCache class have been removed, since they were marked as deprecated in version 3 of ThumbnailXpress. The CacheMemoryLimit property and the CacheClear() method of the Accusoft.ThumbnailXpressSdk.ThumbnailCache class and the class itself have been marked as deprecated. The Accusoft.ThumbnailXpressSdk.ThumbnailXpress.ThumbnailCache property has been marked as deprecated. The deprecated items will be removed in version 5 of ThumbnailXpress.
  • Added Accusoft's new licensing structure to the ImagXpress 11 Product Family. See Licensing for information about the new licensing, and Upgrading Runtime Licensing for information about updating your licensing from an earlier version of ThumbnailXpress.

If you encounter any porting issues, please contact support@accusoft.com for assistance.


%%ItemTitle%%

Upgrading Runtime Licensing
Send Feedback
ThumbnailXpress 4 for .NET - User Guide > Getting Started > Upgrading Runtime Licensing

Glossary Item Box

This section describes how to upgrade to Accusoft's new Runtime Licensing.

Prior to ThumbnailXpress 4, runtime licensing was accomplished using the UnlockRuntime method.

In ThumbnailXpress 4, the default licensing model is Automatically Reported Runtime Licensing. However, based on your contracted usage of this software, you may be eligible for Manually Reported Runtime Licensing. Your Accusoft Sales Representative (sales@accusoft.com) can help you determine which model is appropriate.

Refer to the following sections for information about upgrading to the new Runtime Licensing models:

  • Upgrading to Automatically Reported Runtime Licensing
  • Upgrading to Manually Reported Runtime Licensing

Upgrading to Automatically Reported Runtime Licensing

Automatically Reported Runtime Licensing requires a license to be installed on the end-user's machine. See the Licensing section for more information.

In your ThumbnailXpress 3 codebase, find any existing calls to the UnlockRuntime method.

C# Copy Code
 ThumbnailXpress1.Licensing.UnlockRuntime(12345,12345,12345,12345);
VB.NET Copy Code
 ThumbnailXpress1.Licensing.UnlockRuntime(12345,12345,12345,12345)

In your ThumbnailXpress 4 codebase, replace the UnlockRuntime method with calls to the SetSolutionName and SetSolutionKey methods.

C# Copy Code
 ThumbnailXpress1.Licensing.SetSolutionName("YourSolutionName");
 ThumbnailXpress1.Licensing.SetSolutionKey(12345,12345,12345,12345);
VB.NET Copy Code
 ThumbnailXpress1.Licensing.SetSolutionName("YourSolutionName")
 ThumbnailXpress1.Licensing.SetSolutionKey(12345,12345,12345,12345)

Upgrading to Manually Reported Runtime Licensing

In your ThumbnailXpress 3 codebase, find any existing calls to the UnlockRuntime method.

C# Copy Code
 ThumbnailXpress1.Licensing.UnlockRuntime(12345,12345,12345,12345);
VB.NET Copy Code
 ThumbnailXpress1.Licensing.UnlockRuntime(12345,12345,12345,12345)

In your ThumbnailXpress 4 codebase, replace the UnlockRuntime method with calls to the SetSolutionName, SetSolutionKey, and SetOEMLicenseKey methods.

C# Copy Code
 ThumbnailXpress1.Licensing.SetSolutionName("YourSolutionName");
 ThumbnailXpress1.Licensing.SetSolutionKey(12345,12345,12345,12345);
 ThumbnailXpress1.Licensing.SetOEMLicenseKey("1.0.AStringForOEMLicensing…");
VB.NET Copy Code
 ThumbnailXpress1.Licensing.SetSolutionName("YourSolutionName")
 ThumbnailXpress1.Licensing.SetSolutionKey(12345,12345,12345,12345)
 ThumbnailXpress1.Licensing.SetOEMLicenseKey("1.0.AStringForOEMLicensing…")

There is no longer a separate method for web licensing. That functionality has been integrated into the SetOEMLicenseKey method.

If you encounter any porting issues, please contact support@accusoft.com for assistance.


%%ItemTitle%%

Licensing
See Also Send Feedback
ThumbnailXpress 4 for .NET - User Guide > Licensing

Glossary Item Box

Accusoft has introduced a new licensing structure, which provides the following benefits:

  • Toolkit Licensing (also known as Developer or SDK licensing) has been simplified, no longer requiring manual entry of license registration codes.
  • Runtime Licensing (also known as Deployment licensing) has been made more flexible, enabling support for a number of different deployment scenarios.

During evaluation of Accusoft products, Evaluation Toolkit licenses can be used to try out products. However, the product behavior is limited by trial dialog pop-ups, timeouts, or evaluation watermarks.

Accusoft requires customers to purchase licenses for both development and deployment.

  • Development/Toolkit Licensing: When you determine the product is a good fit, you can purchase a Toolkit license to eliminate trial dialog pop-ups, timeouts, and evaluation watermarks while you develop your application.
  • Deployment/Runtime Licensing: Once you have an application that is ready for distribution, you have several options for deployment. Your own deployment scenario will dictate which option is the most appropriate. There are also cost considerations for each licensing model; see the product's "pricing" page or speak with an Accusoft Sales Representative (sales@accusoft.com) for more information.
    • Manually Reported Runtime Licensing: In this model, you embed all of the licensing information directly into your application. You must manually provide royalty reporting to Accusoft for the actual licenses deployed. This model will be the best choice for you if you are not connected to the Internet at runtime, as might be the case in an defense or financial application.
    • Automatically Reported Runtime Licensing using the Server Licensing Utility (SLU): In this model, you run a small GUI tool one time on each deployment target to configure licensing. This model will be the best choice for you if you handle the deployments yourself.
    • Automatically Reported Runtime Licensing using the Licensing Development Kit (LDK): In this model, you embed function calls into your application that perform the license verification at runtime. This model will be the best choice for you if you wish to hide licensing from your end users.

See Also

Licensing Glossary


%%ItemTitle%%

Evaluation Licensing
Send Feedback
ThumbnailXpress 4 for .NET - User Guide > Licensing > Evaluation Licensing

Glossary Item Box

During evaluation of Accusoft products, Evaluation Toolkit licenses can be used to try out products. However, the product behavior is limited by trial dialog pop-ups, timeouts, or evaluation watermarks. When you determine the product is a good fit, you can purchase a Toolkit license to eliminate trial dialog pop-ups, timeouts, and evaluation watermarks.

An evaluation dialog similar to the following is displayed when you have a valid evaluation license.

However, if you attempt to execute a function that is not licensed in the edition license you are using (e.g., if you have a paid license for ImagXpress Standard and attempt to execute a function available only in ImagXpress Professional), an evaluation dialog similar to the following is displayed.

If no license is found in the registry, a dialog similar to the following will be displayed.


%%ItemTitle%%

Toolkit Licensing
Send Feedback
ThumbnailXpress 4 for .NET - User Guide > Licensing > Toolkit Licensing

Glossary Item Box

Accusoft requires customers who are developing code that uses Accusoft components to have a Toolkit license for each developer.

This section provides information about the following:

  • Assigned Toolkit License
  • License Manager
  • Product Editions
  • Registration
    • Registering When Connected to the Internet
    • Registering When Disconnected from the Internet
  • Developing Code


%%ItemTitle%%

Assigned Toolkit License
Send Feedback
ThumbnailXpress 4 for .NET - User Guide > Licensing > Toolkit Licensing > Assigned Toolkit License

Glossary Item Box

When licenses are purchased for developers at an organization, a representative is designated to assign the licenses to developers at the organization. Each developer must create an account on Accusoft’s website prior to the assignment of licenses. The organization’s designated representative may request that licenses be reassigned as a result of personnel changes.


%%ItemTitle%%

License Manager
Send Feedback
ThumbnailXpress 4 for .NET - User Guide > Licensing > Toolkit Licensing > License Manager

Glossary Item Box

The License Manager is a GUI application that is used by a developer to register and activate Toolkit licenses on their development system. When a paid Toolkit license is registered, the License Manager:

  • Communicates the developer's credentials and the hardware information for the development system to the licensing web service.
  • Installs the returned license key on that system.

Activation involves choosing a Toolkit license, either evaluation or paid, so that the license is active on the system.


%%ItemTitle%%

Product Editions
Send Feedback
ThumbnailXpress 4 for .NET - User Guide > Licensing > Toolkit Licensing > Product Editions

Glossary Item Box

Accusoft products may have multiple editions, each of which supports different features. Products that support multiple editions are installed with multiple evaluation Toolkit licenses, one evaluation Toolkit license per edition.

Selecting An Edition (Activating a Toolkit License)

Evaluation licenses allow developers to try features in different product editions. Since each license supports only a single edition of a product, the developer can switch between editions by activating the corresponding Toolkit license, either purchased or evaluation, using the License Manager.

When a customer downloads an evaluation Toolkit, the evaluation Toolkit license for the edition with the most features is installed by default. However, the developer may run the License Manager to change the Toolkit license to a lower edition in order to determine if that edition will serve their needs.

If a customer has purchased multiple editions of the same product, they may install both editions on a development system, but only one edition may be active at a time. Once a license has been activated for a particular system, it may be deactivated (replaced by activating another edition) or reactivated at any time. Similarly, customers who own a lower featured edition may activate a higher featured edition evaluation Toolkit license and then switch back to their paid, lower-featured Toolkit edition license at any time. For example, you can go from a paid Standard edition to an evaluation Professional edition by activating the Professional edition evaluation Toolkit license.


%%ItemTitle%%

Registration
Send Feedback
ThumbnailXpress 4 for .NET - User Guide > Licensing > Toolkit Licensing > Registration

Glossary Item Box

Registration is the process of creating a paid Toolkit license key for a particular system. Registration for Toolkit licenses is always done through the License Manager. This enables the features for the purchased edition to operate without nag dialogs or watermarks. Registration for each license is only required to be performed once per development system. After a license has been registered on a system, you can use the license without further interaction with the License Manager.

Also refer to the following sections:

  • Registering When Connected to the Internet
  • Registering When Disconnected from the Internet


%%ItemTitle%%

Registering When Connected to the Internet
Send Feedback
ThumbnailXpress 4 for .NET - User Guide > Licensing > Toolkit Licensing > Registration > Registering When Connected to the Internet

Glossary Item Box

When the development system is connected to the Internet, registration is a fairly simple process.

  1. Start the License Manager.
  2. When prompted, enter your Accusoft login and password.

    The License Manager then displays the available evaluation and purchased licenses assigned to you.

  3. Select a toolkit and click the link to activate the license for that toolkit.

    The License Manager then requests a new license key from the licensing web service and installs it; this completes the registration process.

    If the selected license cannot be installed on the development system due to connection failures or other reasons, a temporary, 15 day "grace" license is installed so as not to interrupt development while a new license is obtained for the development system.


%%ItemTitle%%

Registering When Disconnected from the Internet
Send Feedback
ThumbnailXpress 4 for .NET - User Guide > Licensing > Toolkit Licensing > Registration > Registering When Disconnected from the Internet

Glossary Item Box

When the development system is not connected to the Internet during registration, as is the case in some defense or financial institutions, registration is only slightly less simple.

  1. Run the License Manager and attempt to log in.
    The License Manager detects that the system is not registered and displays the following dialog:

  2. Select the Install Offline option to begin the offline registration process.

  3. Copy the URL to removable media, such as a thumb drive.

  4. Take the thumb drive to a system that is connected to the Internet.
  5. From the connected system, paste the URL into a browser, which automatically displays the toolkits available.
  6. Upon selecting a toolkit, a license is generated, which you then save to the removable media device.
  7. Return to the offline system where the new license is to be installed.
  8. Use the License Manager to browse to the file and install the Toolkit license.


%%ItemTitle%%

Developing Code
Send Feedback
ThumbnailXpress 4 for .NET - User Guide > Licensing > Toolkit Licensing > Developing Code

Glossary Item Box

Once an evaluation or paid Toolkit license has been activated on the development system, no additional code is required to use the Accusoft products on this system. If moving the resulting executable code to a new system, you will need to install Toolkit licenses or incorporate Runtime licenses into your code.


%%ItemTitle%%

Runtime Licensing
Send Feedback
ThumbnailXpress 4 for .NET - User Guide > Licensing > Runtime Licensing

Glossary Item Box

When an application that uses one or more Accusoft products is deployed, it requires a Runtime License for each installation. There are two main types of Runtime Licenses:

  • Automatically Reported. Distribution of Automatically Reported Runtime licenses is handled automatically through the use of licensing software components and web services.
  • Manually Reported. Manually Reported Runtime licensing requires you to provide the number of licenses distributed on a contractually agreed upon basis.

These licensing types are each described in detail in the following sections:

  • Automatically Reported Runtime (Node-Locked)
    • Licensing API
    • License Pools
    • License Configuration Files
    • LDK vs. SLU
      • Server Licensing Utility (SLU)
      • Licensing Development Kit (LDK)
    • Deployment Proxy Service (DPS)
  • Manually Reported Runtime (Non-Node-Locked)
    • Solution Name
    • Solution Key
    • OEM License Key


%%ItemTitle%%

Automatically Reported Runtime (Node-Locked)
Send Feedback
ThumbnailXpress 4 for .NET - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked)

Glossary Item Box

Automatically Reported Runtime licenses use a mechanism similar to Toolkit licensing to activate a license for a particular system. In this case, each installation has a unique license that is pulled from the pool of licenses purchased by the customer. When the license key is generated, it contains hardware information that identifies the system on which the license is to be installed.

The Licensing Development Kit component, which interacts with the licensing web service and installs the newly generated license key, may be used directly by the application or it may be used through a simple tool known as the Server Licensing Utility.

  • The Licensing Development Kit requires integration with the application or installation utility to perform license activation.
  • The Server Licensing Utility is a stand-alone application that integrates the Licensing Development Kit to perform the registration.

This topic provides information about the following:

  • Licensing API
  • License Pools
  • License Configuration Files
  • LDK vs. SLU
    • Server Licensing Utility (SLU)
    • Licensing Development Kit (LDK)
  • Deployment Proxy Service (DPS)


%%ItemTitle%%

Licensing API
Send Feedback
ThumbnailXpress 4 for .NET - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > Licensing API

Glossary Item Box

The Licensing API is used in the developer’s code to specify Runtime Licensing deployment information. This is used to unlock the Accusoft products and enable all licensed features at runtime. Both the "Solution Name" and "Solution Key" values used in the API described below are provided by Accusoft, along with the License Configuration file, at the time of purchase of a Runtime License.

Solution Name

The solution name is the name assigned by Accusoft to the licenses purchased for runtime deployment. It is a character string that is set for a component prior to use in a deployment environment and is typically the name of the organization that purchased the runtime licenses. It is set via the SetSolutionName method of the component’s Licensing class. For example:

Copy Code
ThumbnailXpress tx = new ThumbnailXpress();
tx.Licensing.SetSolutionName("ACMEImaging");

The Solution Name must be set in order to use runtime licensing.

Solution Key

The Solution Key is a set of four numbers assigned when the licenses are purchased for runtime deployment; the Solution Key also identifies the organization that purchased the runtime licenses. The Solution Key is set via the SetSolutionKey method of the component’s Licensing class. For example:

Copy Code
ThumbnailXpress tx = new ThumbnailXpress();
tx.Licensing.SetSolutionName("ACMEImaging");
tx.Licensing.SetSolutionKey(0x1C3A023F, 0xA018F260, 0x37AF0E51, 0x557F2389);

The Solution Key must be set in order to use runtime licensing.


%%ItemTitle%%

License Pools
Send Feedback
ThumbnailXpress 4 for .NET - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > License Pools

Glossary Item Box

When Automatically Reported Runtime licenses are purchased, they are organized into pools of a specific version and platform for a particular toolkit. For example, if a customer developed two applications using ImagXpress, one using 32-bit ActiveX and the other using .NET, they would purchase two pools of runtime licenses, one for the ActiveX platform and one for the .NET platform. At installation, a new license would be pulled from the appropriate pool, depending upon which platform the application is using.


%%ItemTitle%%

License Configuration Files
See Also Send Feedback
ThumbnailXpress 4 for .NET - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > License Configuration Files

Glossary Item Box

When an Automatically Reported Runtime license is purchased, a License Configuration file is created and distributed to the customer along with their assigned Solution Name and Solution Key. The License Configuration file contains information about the Runtime licenses for a particular platform and version of a toolkit. It is used by the Server Licensing Utility or License Development Kit to activate licenses when the customer’s application is installed on their users' systems.

See Also

Licensing API


%%ItemTitle%%

LDK vs. SLU
Send Feedback
ThumbnailXpress 4 for .NET - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > LDK vs. SLU

Glossary Item Box

Both the Licensing Deployment Kit and the Server Licensing Utility perform the same function of registering the Runtime license for the system on which it will be run. Both are provided in order to give you some options.

  • If you are deploying to your own systems (e.g., for enterprise IT staff), the use of an Accusoft branded Server Licensing Utility may meet your needs. Similarly, if you handle the deployment onto end users systems, you may also find the Server Licensing Utility to be sufficient.
  • If you wish to hide this licensing registration from end users, you will likely choose the Licensing Deployment Kit, which allows you to integrate the registration process into your application. The Licensing Deployment Kit also allows for the optional assignment of Access Keys to specific users, which lets you manage your licenses more directly and limits the distribution of licenses.


%%ItemTitle%%

Server Licensing Utility (SLU)
Send Feedback
ThumbnailXpress 4 for .NET - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > LDK vs. SLU > Server Licensing Utility (SLU)

Glossary Item Box

The Server Licensing Utility is a simple Windows application that uses License Configuration Files to request a license key from the purchased Runtime licenses. The Server Licensing Utility registers that Runtime license on the system where your application will be running. This utility can be used by developers for testing, by your deployment team, or by your end users to register their Runtime license.

In the Server Licensing Utility dialog, add your License Configuration file(s) as follows:

  1. Click Add and navigate to your License Configuration file(s).
  2. Select the appropriate License Configuration file(s) and click Open.
  3. After all applicable License Configuration files have been added, click Auto Register or Manually Register, depending on whether or not you are connected to the Internet. Refer to the sections below for more information.

Auto Register Toolkit (Connected to Internet)

Automatic registration works in much the same way as connected Toolkit registration and requires an Internet connection on the system where your application software will be deployed. The license information along with the system’s hardware information is sent over the Internet to the Accusoft licensing web service. If an unused license is available, a new license key containing information for the system is generated, returned, and is then automatically installed by the Server Licensing Utility.

Manually Register Toolkit (Disconnected from Internet)

Manual registration is used when the system where your application software will be deployed is not connected to the Internet and therefore cannot be registered automatically. This operation is similar to Disconnected Registration with the License Manager.

  1. Copy the Hardware Key and URL to a removable media device, such as a thumb drive, and then take it to a system that is connected to the Internet.
  2. From the connected system, paste the URL into a browser. A page will appear that contains a field into which you enter the hardware key.
  3. After this hardware key is entered, a license file with the license key is downloaded, which you then save to the removable media device.
  4. Return to the offline system with the removable media device onto which you have saved the license file.
  5. Click Open License File and navigate to the license file. Click OK in the file selection dialog.
    Alternatively, you can open the license file with a text editor, copy the license key to the clipboard, and click Paste License Key to paste the new license key into the License Key field.
  6. Click the License button; the new license will be installed.


%%ItemTitle%%

Licensing Development Kit (LDK)
Send Feedback
ThumbnailXpress 4 for .NET - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > LDK vs. SLU > Licensing Development Kit (LDK)

Glossary Item Box

The Licensing Development Kit is an ActiveX component that may be used instead of the Server Licensing Utility. (Actually, the Server Licensing Utility is only a user interface for the Licensing Development Kit.) The Licensing Development Kit provides an interface for a developer to set the License Configuration File path and other properties as well as initiate requests to the licensing web service to generate license keys.

This topic contains these sections:

  • AccuLicClient.DLL
  • Assigned Access Keys
  • Automatic (Connected) Mode Registration
  • Manual (Disconnected) Mode Registration
  • Evaluation
  • Licensing Development Kit Interface
  • Licensing Development Kit Properties
  • Licensing Development Kit Methods

AccuLicClient.DLL

The AccuLicClient.DLL is located with the Server Licensing Utility. It is a 32-bit ActiveX/COM DLL which is used to execute runtime licensing activation functions. The bulk of the functionality provided by the Server Licensing Utility (SLU) is contained within the AccuLicClient.DLL and can be used within your own custom applications to achieve the same thing.

Assigned Access Keys

Unlike the Server Licensing Utility, the Licensing Development Kit allows for the optional assignment of Access Keys to specific users. By doing this, you can specify which of your licenses are assigned to your users. This also limits the distribution of licenses. When Runtime licenses are purchased, a list of Access Keys is distributed to you for this use.

Automatic (Connected) Mode Registration

This mode corresponds to the Automatic (Connected) Registration section described in the Server Licensing Utility section. The process is shown in the C# sample code below:

Copy Code
// Instantiate the LDK ActiveX component
IDeploymentComponent ldk = new DeploymentComponent();

// Set the path to the configuration file provided
// when the runtime licenses were purchased.
ldk.ConfigPath = @"C:\config.txt";

// Attempt to get the next available license.
// Note that you may alternately pass an Access Key
ldk.GetLicKeyAuto("");

if (ldk.ResultCode != enumLdkErrorCodes.LDK_SUCCESS)
{
    // Automatic Registration Failed - A temporary license
    // has been installed but will expire in 15 days.
    // TODO add code to notify user of issue and 15 day expiration.

    if (ldk.ResultCode == enumLdkErrorCodes.LDK_ERR_INET_CONN_BROKEN)
    {
        // No Internet Connection – Optionally do manual registration
    }
}
else
{
    // The license has been registered and installed.
}

The registration process is then complete. If any part of the registration process fails, a temporary license key is installed and is typically valid for 15 days. During this time, you are allowed to use the product while resolving any licensing related problems.

Manual (Disconnected) Mode Registration

This mode corresponds to the Manual (Disconnected) Registration section described in the Server Licensing Utility section. The process is shown in the C# code below:

Copy Code
// Instantiate the LDK ActiveX component
IDeploymentComponent ldk = new DeploymentComponent();

// Set the path to the configuration file provided
// when the runtime licenses were purchased.
ldk.ConfigPath = @"C:\config.txt";

// Get the hardware key for the system.  Note
// that you may alternately pass an Access Key
string hardwareKey = ldk.GetHdwKey("");

// Write the hardware key to some type of removable media.
ApplicationSpecificMethodToWriteHardwareKey(hardwareKey);

At this point, you have the hardware key on some type of removable media. Take the media to a system that is connected to the Internet, acquire the license key by uploading the hardware key, write the new license key to the removable media, and then return to the disconnected system. The application then reads the license key from the removable media and installs the license key as shown below.

Copy Code
// After taking the hardware key to a system with an Internet
// connection and acquiring the license key string from the
// manual registration web site, read the key into your
// application.
string manuallyAcquiredLicenseKey = ApplicationSpecificMethodToReadLicenseKey();

// Install the license key
ldk.LicKey = manuallyAcquiredLicenseKey;

The manual license registration and installation is then complete. Like the automatic case above, if any error occurs during the setting of the license key, a temporary license is installed.

Evaluation

The Licensing Development Kit also has the ability to install an Evaluation License for purchased runtime products. This process is simply:

Copy Code
// Instantiate the LDK ActiveX component
IDeploymentComponent ldk = new DeploymentComponent();

// Set the path to the configuration file provided
// when the runtime licenses were purchased.
ldk.ConfigPath = @"C:\config.txt";

// Install an evaluation license
ldk.StartEvalPeriod();

Licensing Development Kit Interface

The interface to the Licensing Development Kit is shown below:

Copy Code
interface IDeploymentComponent : IDispatch
{
   [propget, id(1)] HRESULT LicKey([out, retval] BSTR* pVal);
   [propput, id(1)] HRESULT LicKey([in] BSTR newVal);
   [propget, id(2)] HRESULT srvURL([out, retval] BSTR* pVal);
   [propput, id(2)] HRESULT srvURL([in] BSTR newVal);
   [propget, id(3)] HRESULT ConfigPath([out, retval] BSTR* pVal);
   [propput, id(3)] HRESULT ConfigPath([in] BSTR newVal);
   [propget, id(4)] HRESULT ResultString([out, retval] BSTR* pVal);
   [propget, id(5)] HRESULT ResultCode([out, retval] enumLdkErrorCodes* pVal);
   [id(6)]           HRESULT GetLicKeyAuto([in] BSTR accKey);
   [id(7)]           HRESULT GetHdwKey([in] BSTR accKey, [out,retval] BSTR* hdwKey);
   [id(8)]           HRESULT StartEvalPeriod(void);
   [propget]         HRESULT LicenseInfo([out, retval] BSTR* pVal);
   [propput]         HRESULT LicenseInfo([in] BSTR newVal);
   [id(10)]          HRESULT GetEvalPeriod([out, retval] long* pVal);
};

Licensing Development Kit Properties

  • LicKey: Stores the License Key to the registry when it is set, and reads it from the registry during the get operation.
  • srvURL: Gets and sets the URL path to the licensing web service. The default is the URL path to Accusoft’s Deployment Licensing Service.
  • ConfigPath: Gets and sets a path to the deployment configuration file. Multiple products can be registered at one time by setting the filenames as a semicolon-delimited list: e.g., “c:\config.txt;c:\config2.txt”.
  • ResultString: Contains the string descriptions of any error that may have occurred during the last operation.
  • ResultCode: Can be used to contain any of the error codes described in Licensing Component Error Codes and Messages.
  • LicenseInfo: Used to transfer license information onto new system hardware. To transfer the license information into new system hardware, do the following:
  1. Get the LicenseInfo value and store it in a safe place.
  2. Change the system hardware.
  3. Set the LicenseInfo to the value you saved in step (1).
  4. Run the GetLicKeyAuto method (or perform its manual analog) to obtain a license for the new system hardware.

Licensing Development Kit Methods

  • GetLicKeyAuto: Obtains a License Key for the end user’s system using the automatic (or connected) scenario. It takes an Access Key as its input parameter, and stores the obtained license key in the registry. If you choose not to distribute individual Access Keys, the accKey argument should be an empty string.
  • GetHdwKey: Obtains a hardware key from the current machine and returns it (as hdwKey). If you choose not to distribute individual access keys, the accKey argument should be an empty string.
  • StartEvalPeriod: Sets an evaluation licensing mode for the product and starts an evaluation period. This method is provided so you can distribute an evaluation version of your application, without having to distribute Access Keys to people who would like to evaluate your software. Using this method you can license Accusoft components on the end user’s system for a limited time – the default is 30 days, but it can be customized per request to Accusoft. If the evaluators purchase your software, you can then issue them an access key using either the automatic or manual scenarios to obtain permanent component licenses, just as Accusoft does for its evaluators.
  • GetEvalPeriod: Obtains the remaining time on an evaluation (in days). It returns EvalPeriod < 0 if the evaluation period is expired.


%%ItemTitle%%

Deployment Proxy Service (DPS)
Send Feedback
ThumbnailXpress 4 for .NET - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > Deployment Proxy Service (DPS)

Glossary Item Box

For systems where the deployed application will not have direct access to the Accusoft licensing web services, you can use the Deployment Proxy Service as a bridge to reroute the licensing communication. The Proxy Service will act as a trusted "go-between" for the Accusoft licensing system and the deployed application. This tool can be useful if the application will be deployed in a secured environment, where limited systems have external network access.

Additionally, the Proxy Service allows Accusoft customers to manage license registration more directly. The source for the Deployment Proxy Service is provided, allowing users to integrate the licensing process into their CRM, ERP, or other systems for tracking Automatically Reported Runtime Licenses.

For more information about the Deployment Proxy Service, please contact our Support team.


%%ItemTitle%%

Manually Reported Runtime (Non-Node-Locked)
Send Feedback
ThumbnailXpress 4 for .NET - User Guide > Licensing > Runtime Licensing > Manually Reported Runtime (Non-Node-Locked)

Glossary Item Box

Manually Reported Runtime licensing embeds all of the licensing information directly into your application. Installation does not require any further licensing interaction. However, it is your responsibility to provide royalty reporting to Accusoft for the actual licenses deployed.

This section provides information about the following:

  • Solution Name
  • Solution Key
  • OEM License Key


%%ItemTitle%%

Solution Name
Send Feedback
ThumbnailXpress 4 for .NET - User Guide > Licensing > Runtime Licensing > Manually Reported Runtime (Non-Node-Locked) > Solution Name

Glossary Item Box

The solution name is

  • A name assigned by Accusoft to the licenses purchased for runtime deployment.
  • A character string that is set for a component prior to use in a deployment environment
  • Typically the name of the organization that purchased the runtime licenses.
  • Set via the SetSolutionName method of the component’s Licensing class. For example:
Copy Code
ThumbnailXpress tx = new ThumbnailXpress();
tx.Licensing.SetSolutionName("ACMEImaging");

The Solution Name must be set in order to use runtime licensing.


%%ItemTitle%%

Solution Key
Send Feedback
ThumbnailXpress 4 for .NET - User Guide > Licensing > Runtime Licensing > Manually Reported Runtime (Non-Node-Locked) > Solution Key

Glossary Item Box

The Solution Key is

  • A set of four numbers assigned when the licenses are purchased for runtime deployment
  • An identifier of the organization that purchased the runtime licenses.
  • Set via the SetSolutionKey method of the component’s Licensing class. For example:
Copy Code
ThumbnailXpress tx = new ThumbnailXpress();
tx.Licensing.SetSolutionName("ACMEImaging");
tx.Licensing.SetSolutionKey(0x1C3A023F, 0xA018F260, 0x37AF0E51, 0x557F2389);

The Solution Key must be set in order to use runtime licensing.


%%ItemTitle%%

OEM License Key
Send Feedback
ThumbnailXpress 4 for .NET - User Guide > Licensing > Runtime Licensing > Manually Reported Runtime (Non-Node-Locked) > OEM License Key

Glossary Item Box

The OEMLicense Key is

  • For use only by customers who choose to use Manually Reported Runtime licensing.
  • A unique identifier of the customer, product, version, edition, and platforms for which the license is valid.

When this key is set via the SetOEMLicenseKey method of the component’s Licensing class, the component is completely licensed and can be distributed without any further licensing operations.

Copy Code
ThumbnailXpress tx = new ThumbnailXpress();
tx.Licensing.SetSolutionName("ACMEImaging");
tx.Licensing.SetSolutionKey(0x1C3A023F, 0xA018F260, 0x37AF0E51, 0x557F2389);
tx.Licensing.SetOEMLicenseKey("1.0.GQCC0EmUgONaI4QDZ32tpGWfpGW4gtbC0iIC0iN4bigYM3m3K5b487QOsAM38O24mUp5bOpD2O240OQ32U2YsUKDKA87MYPGgGgaptMiK5Nv8AI4mYg4m3QvW52DZCPGs4p784mtP4IUgOWiIG0AQYp4052iIAWvNCZfpGWC8vQ5P4ZGKaPAWfbiYfZOI303pOZAgisiNaWA27gGsf8Ob7Zvm5IaKGI4KC8GsG2CWYpGQAg5sUmYWvZCQANig48G2ap4bG0DsO240YsUmtptNiZamCPGbYMfMO83gANAZCN52YbY8U8f8DM4m3g7MYMYWGW5Q7QGWaMiN7MtZfmtgY8AN7NDP7Z4W7sCbGKUPa0im7EDPP");

This property is not required for Automatically Reported Runtime licensing.


%%ItemTitle%%

Licensing Glossary
Send Feedback
ThumbnailXpress 4 for .NET - User Guide > Licensing > Licensing Glossary

Glossary Item Box

The following sections each describe a licensing term:

  • Access Key
  • Accusoft Products
  • Activation
  • Assigned Access Key
  • Automatically Reported Runtime Licensing
  • Customers, Developers, and Users
  • Edition
  • Evaluation License
  • Hardware Key
  • License Configuration File
  • Licensing Development Kit (LDK)
  • License Key
  • License Manager
  • Manually Reported Runtime Licensing
  • Node-Locked Licensing
  • Non-Node-Locked Licensing
  • Paid License
  • Registration
  • Runtime (Deployment) Licensing
  • Server Licensing Utility (SLU)
  • Toolkit Licensing
  • Web Services

Access Key

All licenses are assigned a unique identifier known as an Access Key. Access Keys are associated with the organization that purchased the license.

Accusoft Products

An Accusoft product may be licensed with either a Toolkit License or a Runtime License.

Activation

Activation is the process of selecting a previously registered toolkit license. Licenses may be paid (Toolkit) or evaluation, and may be for one of many product editions, for products with multiple editions.

Assigned Access Key

An assigned Access Key is one that is assigned to a specific user or users. The assignment of Access Keys to specific users can be done using the Licensing Development Kit (LDK).

Automatically Reported Runtime Licensing

Runtimes may be licensed in one of two ways: automatic reporting or manual reporting. With automatic reporting, you do not need to worry about royalty reporting; it is handled by the licensing layer.

Customers, Developers, and Users

Customers are simply any person who has purchased an Accusoft product. Developers are customers who possess a license for an Toolkit. Users are typically the customers of Accusoft's customers who use applications built around Accusoft components and are assigned a runtime license.

Edition

Some Accusoft products have multiple editions. Editions may offer multiple levels of product speed or product features, allowing customers to find a price-performance mix that is appropriate for them. Products that support multiple editions register multiple Toolkit licenses at installation time, one Toolkit license per edition. Developers must select an edition to activate using the License Manager.

Evaluation License

An evaluation license is a Toolkit license that is unpaid. When an Accusoft Toolkit is installed, evaluation licenses for all applicable product editions are installed and registered, and the edition with the most features is activated. Evaluation Toolkit licenses can be used to try out products. However, the product behavior is limited by trial dialog pop-ups, timeouts, or evaluation watermarks. When you determine the product is a good fit, you can purchase a Toolkit license to eliminate trial dialog pop-ups, timeouts, and evaluation watermarks.

Hardware Key

When a license is activated for a product, the system information that identifies the installation hardware is contained within an encrypted string and is used to generate the license key for the product. The string containing the encrypted hardware information is known as the Hardware Key.

License Configuration File

When a Toolkit or an Automatically Reported Runtime license is purchased, a configuration file is provided that contains information about the license that was purchased. This file is used by the licensing utilities (License Manager, Server License Utility, and License Development Kit) to install a license on the system.

Licensing Development Kit (LDK)

The Licensing Development Kit (LDK) is an ActiveX component that may be used for Runtime Licensing. The LDK is one mechanism for Automatically Reported Runtime Licensing; the Server Licensing Utility (SLU) is the other.

License Key

Each product license has a unique key associated with it that uniquely identifies the customer, product, version, edition, and platforms, and, in some cases, the hardware for which the license is valid.

License Manager

The License Manager is a GUI application that is used by a developer to register and activate Toolkit licenses on their development system.

Manually Reported Runtime Licensing

Runtimes may be licensed in one of two ways: automatic reporting or manual reporting. With Manually Reported Runtime Licensing, you embed all of the licensing information directly into your application. You must manually provide royalty reporting to Accusoft for the actual licenses deployed. This model will be the best choice for you if you are not connected to the Internet at runtime, as might be the case in an defense or financial application.

Node-Locked Licensing

Another name for Automatically Reported Runtime Licensing.

Non-Node-Locked Licensing

Another name for Manually Reported Runtime Licensing.

Paid License

A paid license is a Toolkit license that you have purchased from Accusoft. It is ready to be used in production, with no trial dialog pop-ups, timeouts, or evaluation watermarks. If you wish to test other editions of the Accusoft product for which you have purchased a Paid License, you may activate an Evaluation license for that edition; a complete set of Evaluation licenses for all editions is registered at installation time.

Registration

Registration is the process of informing the License Manager about a new Toolkit license you have purchased. It uses this information to create a license key on your system; this allows you to activate the product for development with no restrictions, such as trial dialog pop-ups, timeouts, or evaluation watermarks.

Runtime (Deployment) Licensing

When deploying an application, a Runtime License is also required for each user’s installation. You must purchase runtime licenses, which are consumed as licenses are registered. There are two Runtime licensing models: Automatically Reported Runtime License; and Manually Reported Runtime License.

Server Licensing Utility (SLU)

The Server Licensing Utility (SLU) is a small GUI application that allows you to request a license key from the Runtime licenses you have purchased. The SLU is one mechanism for Automatically Reported Runtime Licensing; the Licensing Development Kit (LDK) is the other.

Toolkit Licensing

Each Toolkit is assigned to a specific developer who has a registered account with Accusoft. When the developer installs the Toolkit, it is not fully functional until they have activated the license through the use of the License Manager application. When the developer starts the License Manager, they are required to provide login credentials that identify and allow them to activate their license on a development system. See Toolkit Licensing.

Web Services

When a license is registered, information that uniquely identifies the customer’s or user’s hardware is passed along with the license information over the Internet to a web service. The web service validates the licensing request, generates a key that includes the hardware information, and returns the new license key to the application that made the licensing request. The license key is then stored on the requested system and used by the component when it is executed. It is also possible to register systems that are not directly connected to the Internet through the use of removable media and a different system that is connected to the Internet.


%%ItemTitle%%

Software License Agreement
See Also Send Feedback
ThumbnailXpress 4 for .NET - User Guide > Licensing > Software License Agreement

Glossary Item Box

PLEASE READ THE FOLLOWING SOFTWARE LICENSE AGREEMENT WHICH GOVERNS YOUR RIGHT TO USE OF THE TOOLKIT. YOU MUST ACCEPT THESE TERMS BEFORE YOU ARE ALLOWED TO INSTALL THE TOOLKIT. YOU EXPRESSLY AGREE THAT YOU HAVE THE AUTHORITY TO CONTRACTUALLY BIND THE ORGANIZATION AGREEING TO THESE TERMS.

BY CLICKING "I ACCEPT," OR INSTALLING TOOLKIT, OR PLACING TOOLKIT IN-USE, LICENSEE IS AGREEING TO BE BOUND BY THIS AGREEMENT.

1. GRANT OF AGREEMENT

This Accusoft Corporation, ("ACCUSOFT") Software License Agreement ("AGREEMENT") grants the organization contracting under this agreement as licensee ("LICENSEE") a limited, nontransferable, nonexclusive and non-assignable license to use the trial mode version of this ACCUSOFT Development Toolkit ("TOOLKIT") on a single computer for evaluation of fitness only and not for any commercial purpose; or to use a properly purchased and registered TOOLKIT, for development purposes only on a single computer, provided the TOOLKIT is IN-USE on only one computer at any time. (However additional TOOLKIT licenses may be purchased.) TOOLKIT is "IN-USE" on a computer when it becomes loaded by any means for any purpose into temporary memory (that is, including but not limited to RAM) or when it becomes copied or installed to less temporary storage by any means for any purpose (that is, including but not limited to hard disk, CD-ROM or other removable disk or tape, USB or other flash memory drive or card, or other local, networked, or cloud storage device) when it is accessible to that computer. The TOOLKIT is explicitly not to be used on a site-wide basis, via a server or other networked connection.

2. REDISTRIBUTION OF TOOLKIT RUNTIMES

ACCUSOFT does not grant LICENSEE any rights to deploy, license, sell, reproduce, copy, install, lease, timeshare, rent, or otherwise distribute or transfer TOOLKIT or any portion of TOOLKIT ("PORTION") except as provided in Section 1. GRANT OF AGREEMENT. For licensing information about any other distribution of TOOLKIT or PORTION, please visit our web site (www.accusoft.com/licensing.htm), or contact our sales staff. LICENSEE agrees to notify ACCUSOFT immediately of any violations or changes in status regarding LICENSEE's compliance with any term of this AGREEMENT.

In the event that ACCUSOFT grants LICENSEE in a written separate runtime license agreement ("RUNTIME AGREEMENT") a right to deploy, license, sell, reproduce, copy, install, lease, timeshare, rent, or otherwise distribute or transfer PORTIONS, the RUNTIME AGREEMENT will specify what PORTIONS may be distributed ("RUNTIME"). LICENSEE agrees to acknowledge and uphold the terms and conditions of this AGREEMENT as well as the terms of the RUNTIME AGREEMENT itself, which will be provided only in writing. In such event, LICENSEE may distribute RUNTIMES as part of the LICENSEE's software application or derivative works ("PRODUCT") upon additionally agreeing to the following:

a) LICENSEE understands and acknowledges that in order to receive any discounted pricing for RUNTIME distribution licensing fees based on the type of installation, it must either: 1) prepay for a number of RUNTIME licenses that is sufficient to qualify for ACCUSOFT's then-current published quantity discount, or 2) it must pay for the licenses in accordance with a written contract between LICENSEE and ACCUSOFT.

b) LICENSEE's PRODUCT shall not compete to any degree with the TOOLKIT. Such competitive PRODUCTS are defined as software development toolkits that include similar functionality as TOOLKIT and that are intended for use by software developers and/or system integrators.

c) LICENSEE's PRODUCT must be substantially greater in scope with greater functionality and features than those of the TOOLKIT.

d) LICENSEE will not use ACCUSOFT's name, logo, or trademarks to market PRODUCT without prior written approval of ACCUSOFT except LICENSEE will include a statement substantially similar to the following within PRODUCT documentation and about box: "Portions of this product contain imaging and other technology owned by Accusoft Corporation, Tampa, FL, (www.accusoft.com). ALL RIGHTS RESERVED." See Section 20. THIRD PARTY NOTICES for additional requirements.

e) LICENSEE agrees to only distribute the RUNTIMES. No license or other rights are granted to LICENSEE for any distribution of the TOOLKIT or PORTIONS including, but not limited to, documentation, source code, or the RUNTIME distribution unlock codes.

g) LICENSEE will only distribute the RUNTIMES on the hardware and operating system(s) for which the RUNTIMES are intended to be used according to the RUNTIME AGREEMENT.

If ANY of the terms of this AGREEMENT are not applicable to LICENSEE'S situation, or if any of the terms of this AGREEMENT cannot be complied with, or if LICENSEE needs modifications to this AGREEMENT or the license granted for any reason, LICENSEE must contact ACCUSOFT about obtaining an expanded license from ACCUSOFT (available by phone at: 813-875-7575, x321, by e-mail at: Sales@accusoft.com or by fax at: 813-875-7705).

This AGREEMENT grants rights to LICENSEE only for the TOOLKIT and does not convey any other rights of use or distribution to ACCUSOFT technology.

3. OWNERSHIP

LICENSEE acknowledges and agrees that ACCUSOFT owns all rights, title and interest in the TOOLKIT, in all forms, including without limitation any and all worldwide proprietary rights therein, including but not limited to trademarks, copyrights, patent rights, patent continuations, trade secrets and confidential information.

LICENSEE may not remove or alter the copyright notice from any copy of the TOOLKIT or any copy of the written materials, accompanying the TOOLKIT.

LICENSEE waives its right to contest any of ACCUSOFT's patents, trademarks, service marks, trade names, copyrights, and other intellectual property and proprietary rights in and to the TOOLKIT.

LICENSEE shall not use such trademarks, service marks, and trade names except where and as permitted under this AGREEMENT without receiving ACCUSOFT's prior written approval of such use. If such approval is granted, LICENSEE’s right to use such trademarks, service marks, and trade names shall end upon the termination of this AGREEMENT.

4. RESTRICTIONS AND RESERVATIONS.

All rights and licenses not expressly granted to LICENSEE are reserved to ACCUSOFT. LICENSEE is strictly prohibited from reproducing, copying, marketing, selling, distributing, licensing, sublicensing, leasing, timesharing or renting the TOOLKIT or PORTION, and LICENSEE is strictly prohibited from any use of the TOOLKIT or PORTION except as permitted by this AGREEMENT, and such actions are expressly prohibited. LICENSEE is strictly prohibited from incorporating or including the TOOLKIT or PORTION into or as part of any PRODUCT or service of LICENSEE except as provided by this AGREEMENT, regardless of the functionality of TOOLKIT (or lack thereof) within or as part of such PRODUCT or service of LICENSEE. LICENSEE shall not for any reason disassemble, decompile, decrypt or reverse engineer the TOOLKIT or PORTION or in any manner attempt to discover or reproduce the source code or any other copyrightable, proprietary, or trade secret aspect of the TOOLKIT or PORTION. Nor shall LICENSEE use the TOOLKIT or PORTION, directly or indirectly, in developing LICENSEE's own PRODUCT with, or including, similar functionality. LICENSEE shall not make any copies of the TOOLKIT or PORTION for any purpose whatsoever except as permitted by this AGREEMENT. Source code that is provided with TOOLKIT for sample or demonstration purposes may be used directly or indirectly in developing PRODUCT, however it may not be distributed in source form in whole or in part with or as part of PRODUCT.

5. WARRANTY DISCLAIMER

LICENSEE ACKNOWLEDGES AND AGREES THAT THE TOOLKIT IS PROVIDED "AS IS." ACCUSOFT DISCLAIMS ANY AND ALL REPRESENTATIONS AND WARRANTIES OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND AGAINST INFRINGEMENT.

6. LIMITATION OF LIABILITY

ACCUSOFT SHALL HAVE NO LIABILITY TO LICENSEE, LICENSEE AFFILIATES, SUBSIDIARIES, SHAREHOLDERS, OFFICERS, DIRECTORS, EMPLOYEES, REPRESENTATIVES OR ANY THIRD PARTY, WHETHER IN CONTRACT, TORT, NEGLIGENCE OR PRODUCTS LIABILITY, FOR ANY CLAIM, LOSS OR DAMAGE, INCLUDING BUT NOT LIMITED TO, LOST PROFITS, LOSS OF USE, BUSINESS INTERRUPTION, LOST DATA, LOST FILES, OR FOR ANY DIRECT, INDIRECT, SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES OF ANY KIND OR NATURE WHATSOEVER ARISING OUT OF OR IN CONNECTION WITH USE OF OR INABILITY TO USE THE TOOLKIT, OR THE PERFORMANCE OR OPERATION OF THE TOOLKIT, EVEN IF ACCUSOFT HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

7. INDEMNIFICATION BY LICENSEE

LICENSEE SHALL INDEMNIFY, HOLD HARMLESS AND DEFEND ACCUSOFT FOR ANY LOSS, CLAIM, ACTION OR PROCEEDING THAT ARISES OR RESULTS FROM ANY ACTIONS OR OMISSIONS OF LICENSEE PERTAINING TO THE PRODUCT OR THE TOOLKIT AND FROM ANY ACTIONS OF LICENSEE THAT ARE IN VIOLATION OF THIS AGREEMENT.

8. TERM AND TERMINATION

Unless otherwise agreed to by the parties, this AGREEMENT shall become effective upon the earlier of LICENSEE's clicking of "I Accept" or LICENSEE'S installing or placing TOOLKIT IN_USE ("Effective Date") and shall continue in full force and effect until terminated in accordance with the terms set forth in this AGREEMENT.

Any material breach of this AGREEMENT shall automatically and immediately terminate this AGREEMENT. In the event that LICENSEE ceases to do business or is adjudged bankrupt or insolvent, ACCUSOFT may, at its sole option, terminate this AGREEMENT, by giving ten (10) Business Days written notice of such termination, which notice shall identify and describe the basis for such termination.

In the event of any termination of this AGREEMENT, any RUNTIME AGREEMENT is simultaneously terminated and LICENSEE shall stop using the TOOLKIT and PORTION, shall cease manufacturing the PRODUCT containing TOOLKIT or PORTION, and shall cease distributing PRODUCT containing TOOLKIT or PORTION. LICENSEE shall also require its resellers, OEMs, and other distribution channels (if any) to likewise stop manufacturing and distributing the PRODUCT containing TOOLKIT or PORTION. Within ten (10) Business Days thereafter, LICENSEE shall return or, at ACCUSOFT's option, destroy, the TOOLKIT and all PORTIONS, whether or not incorporated in or with the PRODUCT, that are within LICENSEE’s possession, custody and control, and shall certify to ACCUSOFT in writing within ten (10) Business Days after that return or destruction that it has complied with the foregoing obligation.

All Sections except Section 1. GRANT OF LICENSE shall continue in full force and effect, notwithstanding any termination of this AGREEMENT.

9. LIQUIDATED DAMAGES

In the event LICENSEE (a) copies the TOOLKIT or PORTION except as permitted by this AGREEMENT, (b) uses the TOOLKIT or PORTION for any reason other than as permitted by this AGREEMENT, (c) installs or uses the TOOLKIT or PORTION on more than a single computer, or (d) otherwise violates or breaches this Agreement, LICENSEE agrees that ACCUSOFT is entitled to obtain as liquidated damages and not as a penalty the greater of the amount of (v) the published quantity one distribution price based upon the type of distribution, or (w) $99 per each user of each PRODUCT or service of LICENSEE in which the TOOLKIT or PORTION is included, copied, incorporated, embedded or accessible; (x) $100 per copy of TOOLKIT or PORTION; (y) $100 per copy of any PRODUCT in which TOOLKIT or PORTION is included, copied, incorporated, embedded or accessible; or (z) 3% of all revenues realized by LICENSEE pertaining to any PRODUCTS or services of LICENSEE in which TOOLKIT or PORTION is included, copied, incorporated, embedded or accessible. THE LICENSEE EXPRESSLY AGREES THAT THE FOREGOING LIQUIDATED DAMAGES ARE NOT A PENALTY.

10. CONFIDENTIALITY

LICENSEE acknowledges that the TOOLKIT contains ACCUSOFT know-how, confidential and trade secret information ("PROPRIETARY INFORMATION"). LICENSEE agrees: (a) to hold the PROPRIETARY INFORMATION in the strictest confidence, (b) not to, directly or indirectly, copy, reproduce, distribute, manufacture, duplicate, reveal, report, publish, disclose, cause to be disclosed, or otherwise transfer the PROPRIETARY INFORMATION to any third party, (c) not to make use of the PROPRIETARY INFORMATION other than as permitted by this AGREEMENT, and (d) to disclose the PROPRIETARY INFORMATION only to LICENSEE's representatives requiring such material for effective performance of this AGREEMENT and who have undertaken an obligation of confidentiality and limitation of use consistent with this AGREEMENT. This obligation shall continue as long as allowed under applicable law.

11. INJUNCTIVE RELIEF

LICENSEE agrees that any violation or threat of violation of this AGREEMENT will result in irreparable harm to ACCUSOFT for which damages would be an inadequate remedy. Therefore, in addition to its rights and remedies available at law (including but not limited to the recovery of damages for breach of this AGREEMENT), ACCUSOFT shall be entitled to immediate injunctive relief to prevent any violation of ACCUSOFT's copyright, trademark, trade secret rights regarding the TOOLKIT, or to prevent any violation of this AGREEMENT, including, but not limited to, unauthorized use, copying, distribution or disclosure of or regarding the TOOLKIT or PORTION, as well as any other equitable relief as the court may deem proper under the circumstances.

12. NO REDUCED PRICING

In any determination of ACCUSOFT's damages (whether liquidated damages or actual damages), or any determination of any licensing fees or royalties due ACCUSOFT under this AGREEMENT due to a breach by LICENSEE hereunder, LICENSEE shall not be entitled to any discounts (volume or otherwise) or reduced licensing fees or royalties. The foregoing sentence shall be applicable unless LICENSEE has negotiated and entered into a written, signed agreement with ACCUSOFT for such reduced or discounted licensing fees or royalties and paid ACCUSOFT such fees or royalties in advance of any: (a) distribution of the TOOLKIT or PORTION, (b) copying of the TOOLKIT or PORTION, or (c) incorporation or use of the TOOLKIT or PORTION in or pertaining to any PRODUCT or service of LICENSEE. Further, LICENSEE agrees that it shall not be entitled to reduced licensing fees or royalties when determining ACCUSOFT's damages due to any undertaking or activity by LICENSEE regarding the TOOLKIT or PORTION outside of or exceeding the scope of permission or other terms of this AGREEMENT, or LICENSEE's actions otherwise in violation of this AGREEMENT.

13. ATTORNEYS' FEES AND COSTS

In the event of any lawsuit or other proceeding brought as a result of any actual or alleged breach of this AGREEMENT, to enforce any provisions of this AGREEMENT, or to enforce any intellectual property or other rights in or pertaining to the TOOLKIT or PORTION, the prevailing party shall be entitled to an award of its reasonable attorneys’ fees and costs, including the costs of any expert witnesses, incurred at all levels of proceedings.

14. GOVERNING LAW

This AGREEMENT shall be construed, governed and enforced in accordance with the laws of the State of Florida, without regard to any conflicts of laws rules. Any action related to or arising out of this AGREEMENT will be filed only in the Florida courts and LICENSEE consents to the exclusive jurisdiction and venue of the state and federal courts located in Tampa, Florida.

15. SEVERABILITY

If any provision of this AGREEMENT is determined to be invalid by any court of final jurisdiction, then it shall be omitted and the remainder of the AGREEMENT shall continue to be binding and enforceable. In addition, the Court is hereby authorized to enforce any provision of the AGREEMENT that the Court otherwise deems unenforceable, to whatever lesser extent the Court deems reasonable and appropriate, rather than invalidating the entire provision. Without limiting the generality of the foregoing, LICENSEE expressly agrees that should LICENSEE be found to have breached the AGREEMENT, under no circumstances shall LICENSEE be entitled to any volume or other discount, or reduced licensing fee or royalty in the determination of ACCUSOFT's damages, or otherwise in the determination of any licensing fee or royalty owed to ACCUSOFT.

16. GOVERNMENT RIGHTS

The TOOLKIT and accompanying documentation have been developed at private expense and are sold commercially. They are provided under any U.S. government contracts or subcontracts with the most restricted and the most limited rights permitted by law and regulation. Whenever so permitted, the government and any intermediaries will obtain only those rights specified in ACCUSOFT's standard commercial license. Thus, the TOOLKIT referenced herein, and the documentation provided by Accusoft hereunder, which are provided to any agency of the U.S. Government or U.S. Government contractor or subcontractor at any tier shall be subject to the maximum restrictions on use as permitted by FAR 52.227-19 (June 1987) or DFARS 227.7202-3(a) (Jan. 1, 2000) or successor regulations. Manufacturer is Accusoft Corporation, 4001 N. Riverside Drive Tampa, FL 33603.

17. ENTIRE AGREEMENT

This AGREEMENT represents the entire understanding of the parties concerning the subject matter hereof and supersedes all prior communications and agreements, whether oral or written, relating to the subject matter of this AGREEMENT. Only a writing signed by the parties may modify this AGREEMENT. In the event of any modification in writing, of this AGREEMENT, including an expanded license agreement, all sections of this Agreement survive except Section 2. Limited License.

18. CONTACT US

Should you have any questions concerning this AGREEMENT, or if you desire to contact ACCUSOFT for any reason, please contact ACCUSOFT at 1-813-875-7575.

19. OTHER RESTRICTIONS

a) This AGREEMENT shall not be amended, altered, changed or modified in any way, unless agreed to in writing by both ACCUSOFT and LICENSEE. Such writing must be executed by a duly authorized representative of ACCUSOFT and a duly authorized representative of LICENSEE.

b) This AGREEMENT is not transferable or assignable by LICENSEE under any circumstances, without the prior written consent of ACCUSOFT. ACCUSOFT will not unreasonably withhold such consent. This AGREEMENT shall be binding upon, and is made for the benefit of, each party, its successors, and permitted assignees (if any). For the purposes of this AGREEMENT, any change in control of LICENSEE shall constitute an assignment or transfer of this AGREEMENT requiring prior written consent of ACCUSOFT. As used in this section, a change in control is defined as (i) any change in ownership of more than fifty percent (50%) of the voting interest in LICENSEE, whether by merger, purchase, foreclosure of a security interest or other transaction, or (ii) a sale of all or substantially all of the assets of LICENSEE.

c) The relationship established by this AGREEMENT between LICENSEE and ACCUSOFT shall be that of Licensee and Licensor. Nothing contained in this AGREEMENT shall be construed as creating a relationship of agency, joint venture or partnership between LICENSEE and ACCUSOFT. Neither party shall have any right whatsoever to incur any liabilities or obligations on behalf of the other party.

d) ACCUSOFT's failure to perform any term or condition of this AGREEMENT as a result of conditions beyond its control such as, but not limited to, war, strikes, fires, floods, acts of God, governmental restrictions, power failures, or damage or destruction of any network facilities or servers, shall not be deemed a breach of this AGREEMENT.

e) The headings provided in this AGREEMENT are for convenience and reference purposes only. In the event of a conflict between the terms and conditions listed in this AGREEMENT, and any attached Schedules or Appendices, the terms and conditions of this AGREEMENT shall govern.

f) A waiver of a breach, violation, or default under this AGREEMENT shall not be a waiver of any subsequent breach, violation or default. Failure of either party to enforce compliance with any term or condition of this AGREEMENT shall not constitute a waiver by the party of such term or condition.

g) All notices and communications shall be in writing and shall be deemed to have been duly given the earlier of when delivered or three (3) Business Days after mailing by certified mail, return receipt requested, postage prepaid, or by international delivery service, addressed to the parties at their respective addresses set forth on the Order Form or at such other addresses as the parties may designate by written notice in accordance with this section.

20. THIRD PARTY NOTICES

a) ADOBE PDF TECHNOLOGY

Portions of the PDF functionality in the TOOLKIT include Adobe Technology ("Adobe") licensed to ACCUSOFT. The term "TOOLKIT" as defined in the Agreement includes technology from Adobe and related documentation, and any upgrades, modified versions, updates, additions, and copies thereof.

FONT LICENSE: If the TOOLKIT includes font software, LICENSEE may embed the font software, or outlines of the font software, into its Application to the extent that the font vendor copyright owner allows for such embedding. The fonts contained in this package may contain both Adobe and non-Adobe owned fonts. LICENSEE may fully embed any font owned by Adobe.

LIMITED WARRANTY

THE TERMS OF THIS AGREEMENT STATE THE SOLE AND EXCLUSIVE REMEDIES FOR ACCUSOFT’S BREACH OF WARRANTY. EXCEPT FOR THE FOREGOING LIMITED WARRANTY, ADOBE AND ITS SUPPLIERS MAKE NO WARRANTY, EXPRESS OR IMPLIED, AS TO MERCHANTABILITY, FITNESS FOR ANY PARTICULAR PURPOSE, OR NON-INFRINGEMENT. IN NO EVENT WILL ADOBE OR ITS SUPPLIERS BE LIABLE TO LICENSEE FOR ANY CONSEQUENTIAL, INCIDENTAL OR SPECIAL DAMAGES, INCLUDING ANY LOST PROFITS OR LOST SAVINGS, EVEN IF AN ADOBE REPRESENTATIVE HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES, OR FOR ANY CLAIM BY ANY THIRD PARTY. Some states or jurisdictions do not allow the exclusion or limitation of incidental, consequential or special damages, or the exclusion of implied warranties, or limitations on how long an implied warranty may last, so the above limitations may not apply to LICENSEE. In such states/countries and to the extent permissible, any implied warranties are limited to thirty (30) days.

INTELLECTUAL PROPERTY

The Adobe technology is the intellectual property of Adobe and is protected under trademarks, registered trademarks, copyrights, and/or patents in the United States and/or other countries. ALL RIGHTS RESERVED.

Rev. 20120112

See Also

Distributing ThumbnailXpress
Licensing


%%ItemTitle%%

Distributing Applications and Deployment
Send Feedback
ThumbnailXpress 4 for .NET - User Guide > Distributing Applications and Deployment

Glossary Item Box

This section provides information about the following:

  • Verify You're Using the Latest Service Pack
  • Distributing ThumbnailXpress


%%ItemTitle%%

Verify You're Using the Latest Service Pack
See Also Send Feedback
ThumbnailXpress 4 for .NET - User Guide > Distributing Applications and Deployment > Verify You're Using the Latest Service Pack

Glossary Item Box

Service pack updates will not overwrite paid licensing. Your paid licensing will continue to work and you will not be required to re-enter your purchased registration codes. Service pack updates do not include any changes that might "break" previously developed and/or deployed code.

Verify Latest Development Components

To verify you are using the latest version of an Accusoft Development Component or Components, please refer to the currently released product build numbers at www.accusoft.com/latestbuilds.htm.

If you require further assistance or have questions or comments, please see the topic on Getting Support for more detailed information.

See Also

Getting Support
Installing on a Development Machine


%%ItemTitle%%

Distributing ThumbnailXpress
See Also Send Feedback
ThumbnailXpress 4 for .NET - User Guide > Distributing Applications and Deployment > Distributing ThumbnailXpress

Glossary Item Box

DLL Files to Distribute

Required

  • Distribute the appropriate assembly DLL file with applications using the ThumbnailXpress product:

Accusoft.ThumbnailXpress4.Net.dll - .NET component - .NET Control for thumbnail creation

Optional

  • The following files are optional and are only required if you are using other Accusoft products for image processing and/or image acquisition:

Accusoft.PDFXpress4.dll - .NET component (Only required if PDF Xpress™ is used for image acquisition in your application).

See Also

Getting Support
Installing on a Development Machine
Software License Agreement
Verify You're Using the Latest Service Pack
Licensing


%%ItemTitle%%

Concepts
Send Feedback
ThumbnailXpress 4 for .NET - User Guide > Concepts

Glossary Item Box

This section provides information about the following:

  • Overview of ThumbnailXpress
  • Glossary


%%ItemTitle%%

Overview of ThumbnailXpress
Send Feedback
ThumbnailXpress 4 for .NET - User Guide > Concepts > Overview of ThumbnailXpress

Glossary Item Box

ThumbnailXpress encapsulates powerful thumbnail capabilities within a set of classes, described below:

ThumbnailXpress

The ThumbnailXpress class provides methods and properties for managing thumbnail generation and viewing, as well as licensing of the control. Each ThumbnailXpress class has two collections of ThumbnailItems (Items and SelectedItems), a ThumbnailCache, and a collection of Filters.

ThumbnailItem

The ThumbnailItem class exposes properties for accessing individual thumbnail item data, including image filename, item type, page number, bitmap, page count, and processing status.

The ThumbnailItemCollection, SelectedThumbnailItemCollection, and ThumbnailItem classes enable the application program to access and manage the thumbnail items.

ThumbnailCache

All thumbnail images are cached for rapid display access purposes. The ThumbnailCache class exposes to the user properties and methods to access the memory caching parameters for ThumbnailXpress.

Filter

The Filter class exposes methods and properties for specifying match and comparison image file criteria that may be imposed when thumbnail images are loaded from a file system directory using the ThumbnailItemCollection.AddItemsFromDirectory method.

The FilterCollection and Filter classes enable the application program to access and manage the file filters to be used when generating thumbnails from a directory.


%%ItemTitle%%

Glossary
Send Feedback
ThumbnailXpress 4 for .NET - User Guide > Concepts > Glossary

Glossary Item Box

A | B | C | D | E | F | G | H | I | J | K | L | M | N | O | P | Q | R | S | T | U | V | W | X | Y | Z

A

Aspect Ratio
There are two kinds of aspect ratio that you need to be aware of when working with 2D images; the image aspect ratio and the pixel aspect ratio.The image aspect ratio is the ratio of the width of the image to the height of the image. It's important when resizing an image to keep this ratio as close to unchanged as possible or the image may become distorted.The pixel aspect ratio is the shape of the pixels in the image. For computers this is normally square (1:1) or close to it depending on the monitor settings. For some video sources, however, the pixels may be slightly rectangular.

B

Black on Edge
The minimum or maximum number of pixels on the vertical or horizontal edge of an image or document.

BLOB
Binary Large Object.

BMP
The Microsoft Windows Bitmap file format is based on the Microsoft Windows internal bitmap data structures. The BMP format is very widely used and it is quick and easy to read. Although most BMP files are uncompressed, a type of run length encoding is supported.

BPP
Bits per pixel.

Brightness
A ThumbnailXpress method that enhances the brightness attributes of the pixels in the bitmap. Positive settings produce brighter pixels while negative settings produce darker pixels.

C

CCITT
CCITT is the most widely used compression scheme for transmitting binary (black and white) image data. CCITT was established by the International Telegraph and Telephone Consultative Committee. The Group 3 and Group 4 CCITT compression standards are widely used for transmitting fax data. CCITT compressed images are typically stored in the TIFF image format.

Container
Gets the container for the component. An object implementing the IContainer interface that represents the component's container, or a null reference (Nothing in Visual Basic) if the component does not have a site.

Contrast
A ThumbnailXpress method that enhances the contrast attributes of the pixels in the bitmap. Positive settings produce a higher contrast image while negative settings produce a lower contrast image. Images with a higher contrast have a higher frequency of pixel intensities near the ends of the intensity spectrum while images with a lower contrast have a higher frequency of pixels near the middle of the intensity spectrum.

CreateObjRef
Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.

D

DCOM
Microsoft's extension of their Component Object Model (COM) to support objects distributed across a network. DCOM is currently implemented only by Microsoft for Microsoft Windows; and by Software AG, under the name "EntireX", for Unix and IBM mainframes. DCOM serves the same purpose as IBM's DSOM protocol. DCOM is an object model, but has no provisions for inheritance.

DCX
An image format containing multiple PCX images. A DCX file can contain a maximum of 1024 images.

DDB
Microsoft Device Dependent Bitmap. The actual in-memory information used to display an image.

DEP
Data Execution Prevention (computer security).

Despeckle
A modified median filter primarily used for reducing noise in document images. Despeckling divides the image into pixel groups and uses the brightness value to adjust brightness spikes. This filter will reduce noise in a black and white document image with minimal distortion of document text.

DIB
Microsoft Device Independent Bitmap. An alternative file extension used by the Microsoft Windows Bitmap.

DICOM
Digital Imaging and Communication, a standard for handling digital medical images.

Dispose
Releases the resources used by the Component.

Disposed
Adds an event handler to listen to the Disposed event on the component. When you create a Disposed delegate, you identify the method that handles the event.

Dithering
A technique used in computer graphics to create the illusion of varying shades of gray on a monochrome display or printer, or additional colors on a color display or printer. Dithering relies on treating areas of an image as groups of dots that are colored in different patterns. Akin to the print images called halftones, dithering takes advantage of the eye’s tendency to blur spots of different colors by averaging their effects and merging them into a single perceived shade or color. Depending on the ratio of black dots to white dots within a given area, the overall effect is of a particular shade of gray. Dithering is used to add realism to computer graphics and to soften jagged edges in curves and diagonal lines at low resolutions.

E

Emboss
A ThumbnailXpress method that causes the foreground of an image to appear raised from background. Embossing gives the image a raised metallic-like look

ePIC
Accusoft enhanced PIC image format. This high performance image compression combines the patented ELS arithmetic coder with the high performance Accusoft JPEG libraries. The result is a new and unbeatable compression technology. The ePIC compression has significant advantages over standard JPEG. Most importantly it produces smaller file sizes and decompresses extremely quickly. ePIC images can be password encrypted. These images can also be 'zoomed' or scaled to larger, arbitrary sizes.

Equalize
A ThumbnailXpress method that is a point process used for adjusting the contrast of an image. A frequency histogram of the colors of the image is computed and adjusted to equalize the colors across the full spectrum of intensity values. The equalized colors are applied to each pixel in the image.

EXIF
EXchangeable Image File format (Japan Electronic Industry Development Association, JEIDA), compressed image format used in digital cameras.

F

Flate
The lossless deflate compression algorithm is based on two other compression algorithms: huffman encoding and LZ77 compression.

Float
Denotes a simple type that stores 32-bit floating-point values.

G

Gamma
A non-linear brightness transform. Gamma values greater than 0 and less that 1.0 generate exponential curves that dim and image. Gamma values greater than 1.0 generate exponential curves that brighten an image.

GDI
Acronym for Graphical Device Interface. In Windows, a graphics display system used by applications to display or print bitmapped text (TrueType fonts), images, and other graphical elements. The GDI is responsible for drawing dialog boxes, buttons, and other elements in a consistent style on screen by calling the appropriate screen drivers and passing them the information on the item to be drawn. The GDI also works with GDI printers, which have limited ability to prepare a page for printing. Instead, the GDI handles that task by calling the appropriate printer drivers and moving the image or document directly to the printer, rather than reformatting the image or document in PostScript or another printer language.

GetLifetimeService
Retrieves the current lifetime service object that controls the lifetime policy for this instance.

GIF
Graphical Interchange File, originally developed by CompuServe as a machine independent format. GIF is one of the most popular image formats for storing 8-bit digitized images. GIF files are typically smaller than uncompressed formats like BMP due to the LZW compression algorithm that GIF uses.

Grey-scale
If the pixels of a grey-scale image have N bits, they may take values from zero, representing black up to 2^N-1, representing white with intermediate values representing increasingly light shades of grey. If N=1, the image is not called grey-scale, but could be called monochrome.

H

Halftone
Pertaining to pictures in which gradation of tone in the photograph is reproduced by a graduated system of dotted and checkered spots, usually nearly invisible to the unaided eye, produced by the interposition between the camera and the object of a screen. The name alludes to the fact that this process was the first that was practically successful in reproducing the half tones of the photograph.

Hue
One of the 3 components of the HSL (Hue, Saturation and Luminance ) color space. The hue component controls the overall color space of an image. Adjusting the hue of the image adjusts the color spectrum from red through yellow, green, blue, and violet.

I

ICO
Microsoft Windows Icon file format.

Inverse
To reverse something or change it to its opposite. For example, to invert the colors on a monochrome display means to change light to dark and dark to light. In a digital electrical signal, to replace a high level by a low level and vice versa. This type of operation is the electronic equivalent of a Boolean NOT operation.

IOD
Information Object Definition.

IPTC
The International Press Telecommunications Council, not the International Petroleum Technology Conference.

J

JIF
An alternative image file extension used for a JFIF compliant JPEG file. Because many early versions of JPEG contained a JPG extension but did not adhere to the JFIF specifications, the JIF extension was created to identify JPEG files that are JFIF compliant. As the popularity of JPEG grew, JFIF compliance became synonymous with the JPG extension and thus the JIF extension is rarely used.

JPEG
The JPEG (Joint Photographic Experts Group) standard is one of the most important image data compression standards. It is widely used in many industries including graphic arts, desktop publishing, medical imaging, and many more. It is also becoming one of the most widely used image formats on the Internet. Although JPEG supports a lossless mode, it most commonly uses lossy compression. This allows JPEG to achieve very high compression ratios. JPEG compression uses several compression modes. First, an image is transformed to the frequency domain using the discrete cosine transform. The smaller valued frequency components are discarded leaving only the larger valued components. The remaining components are DPCM coded and then Huffman coded. Fortunately, ImagXpress™ handles all of this for you! The compression level is adjustable. Higher quality settings produce a larger image file size with higher image quality. Lower quality settings produce a smaller image file size with lower image quality. Typically, we have found that compression ratios of 10:1 or 15:1 (A 640x480x24-bit image is 921,600 bytes; a 15:1 compressed image would compress to only 61k) produce generally acceptable image quality for photographic type images. Images compressed at higher ratios begin to show more noticeable and sometimes objectionable artifacts and clarity loss. JPEG is a 24-bit format and works only with 24-bit images. If you compress an 8-bit image, ImagXpress™ automatically converts it to 24-bit to do the compression, however, you will obtain better quality when the source image is 24-bit because 8-bit images only contain 256 colors. JPEG works best with photographic type images. It does not work well with solid colors, 16-color images, cartoon like images, or drawings. Progressive JPEG is a multiple-scan sequential JPEG format that is becoming popular on the Internet for the ability to display images in progressively clearer segments.

L

Little-endian
Describes a computer architecture in which, within a given 16- or 32-bit word, bytes at lower addresses have lower significance (the word is stored "little-end-first"). The PDP-11/VAX families of computers, Intel microprocessors, plus a lot of communications and networking hardware are little-endian. The term is sometimes used to describe the ordering of units other than bytes; most often, bits within a byte.

Lock
A lock, represented by the Visual Basic keyword "SyncLock Statement," or the C# keyword "lock Statement", allows a single thread of execution to obtain exclusive execution rights on an object. Although using locks will guarantee that multiple threads do not simultaneously access an object, they can cause significant performance degradation.

Luminance
One of the 3 components of the HSL (Hue, Saturation and Luminance) color space. Luminance controls the overall brightness of an image.

LUT
Look Up Table.

LZW
Lempel-Ziv-Welch (algorithm).

M

Matrix
A matrix filter, also called convolution, alters each pixel's color based on its current color and the colors of any neighboring pixels. The ImagXpress™ Matrix method uses a 3x3 matrix. The numbers in the matrix are coefficients. When a pixel is processed, its color value is multiplied by the coefficient in the center of the matrix, and any pixels within the 3x3 grid are multiplied by the corresponding coefficients in the matrix. The sum of the products becomes the target pixel's new value. The Divisor is simply the coefficient denominator. The matrix method is typically used for sharpening, softening, and edge enhancement.

Mosaic
A mosaic divides the bitmap into tiles of a specified size. All of the pixels in each tile are averaged and changed to the average color.

Multithreading
Multithreading, or free threading, refers to the ability of a program to execute multiple threads of operation simultaneously. An example of a multithreaded application might be a program that receives user input on one thread, performs a variety of complex calculations on a second thread, and updates a database on a third thread. In a single-threaded application, a user might spend idle time waiting for the calculations or database updates to finish. In a multithreaded application, these processes can proceed in the background so user time is not wasted. Multithreading can be a powerful tool to use in component programming. By writing multithreaded components, you can create components that perform complex calculations in the background while leaving the user interface free to respond to user input. Although multithreading can be a powerful tool, it can also be difficult to apply correctly. Improperly implemented multithreaded code can degrade application performance, or even cause frozen applications. (See MSDN).

N

Negate
An ImagXpress™ method that creates a color negative of an image.

Noise
An ImagXpress™ method that adds random pixels to the bitmap.

O

Orthogonal
Used loosely to mean mutually independent or well separated. It describes sets of primitives or capabilities that, like linearly independent vectors in geometry, span the entire "capability space" and are in some sense non-overlapping or mutually independent. For example, in logic, the set of operators "not" and "or" is described as orthogonal, but the set "and", "or", and "not" is not (because any one of these can be expressed in terms of the others).

P

PBM
Portable bitmap image format, a very simple uncompressed 1-bit (black and white) image format.

PGM
Portable Graymap image format. PGM is a very simple uncompressed 8-bit grayscale image format.

PNG
Portable Network Graphics (pronounced "ping") provides a portable, legally unencumbered (royalty-free), well-compressed, well-specified standard for lossless bitmapped image files. The initial motivation for developing PNG was to provide a royalty-free alternative to GIF. The design retains many of the features of GIF that make it an attractive format for transmission of images, such as lossless compression and progressive display capabilities. Additionally, it provides several advantages including 24-bit image support and generally better compression, although decompression is typically somewhat slower than GIF. PNG's success will be ultimately determined by its acceptability on the Internet. At the time of this writing, however, PNG has not been incorporated as part of the major Internet browsers.

PPM
Portable Pixmap image format, a very simple uncompressed 24-bit image format.

R

RGB
Red Green Blue. Bitmapped images are most generally stored as RGB data. Each pixel or data point in a true color (24-bit) image contains 3 components, red, green and blue, that describe the color of the pixel. Each of the components can have a value between 0 and 255, 0 being the darkest shade of color and 255 being the lightest shade of color. Since each component can be stored in one byte (8-bits), the 3 components take up 3 bytes or 24-bits per pixel. 8-bit images contain one byte (8-bit) indexes for each pixel that map to a color table called a palette which contains a maximum of 256 RGB entries. Likewise, 4-bit images contain 4-bit indexes for each pixel that map to a palette which contains a maximum of 16 RGB entries. 1-bit images contain 1-bit per pixel. Each bit in a 1-bit image represents either black or white.

RLE
Run Length Encoding. It is a lossless algorithm that only offers decent compression ratios in specific types of data.

S

Saturation
One of the 3 components of the HSL (Hue, Saturation, and Luminance) color space. Saturation controls the purity of a color. Higher saturations result in richer, deeper colors. Lower saturations result in paler colors.

Scalar
In programming, any data type that stores a single value (a number or Boolean), as opposed to an aggregate data type that has many elements. A string is regarded as a scalar in some languages (PERL) and a vector of characters in others (C).

Sharpen
An ImagXpress™ method that is used to sharpen an image. The sharpen filter uses a high-pass convolution matrix filter to accentuate high frequency detail in the image.

Single
Value type represents a single-precision 32-bit number with values ranging from negative 3.402823e38 to positive 3.402823e38, as well as positive or negative zero, PositiveInfinity, NegativeInfinity, and not a number (NaN).

Soften
An ImagXpress™ method that is used to soften an image. The soften filter uses a low-pass convolution matrix filter to accentuate low frequency detail in the image.

T

TGA
Targa Image File) format was developed by TrueVision for its Targa line of products. TGA is one of the earliest image formats and was the first popular format to support 24-bit color. TGA supports uncompressed and RLE compressed formats.

Thread-safe
An application using this component can use multiple controls running in the same process, where they don't interfere with each other. The thread creating the control owns the control and is the only thread that can interact with it.

TIFF
Tag Image File Format, originally released by Aldus Corporation is a standard file format found in most paint, imaging, and desktop publishing programs. TIFF is extremely powerful, flexible, and extensible. However, because of its many nuances and its wide scope, TIFF can be a difficult format to understand as well as a difficult format to support. ImagXpress™ supports a wide range of TIFF 6.0 formats including uncompressed, CCITT RLE, CCITT Group 3 Fax, CCITT Group 4 Fax, LZW, Pack Bits, JPEG, and deflate compression types. ImagXpress™ supports black and white, RGB, and RGB palette images but it does not support transparency mask, CMYK, YCbCr, or CIELab.

twip
Twips describe the sizes of characters produced by dot matrix printers, which were constrained to multiples of either 12 or 10 dots per inch.

V

VCL
A application framework library for Microsoft Windows and Borland Software Corp.'s Delphi and C++Builder rapid application development software. VCL was originally designed for Delphi but is now also used for C++Builder. This replaces Object Windows Library (OWL) as Borland's Windows C++ framework of choice. VCL encapsulates the C-based Win32 API into a much easier to use, object-oriented form. Like its direct rival, Microsoft Foundation Class Library (MFC), VCL includes classes to create Windows programs. The VCL component class can be inherited to create new VCL components, which are the building blocks of Delphi and C++Builder applications. VCL components compete somewhat with ActiveX controls, though a VCL wrapper can be created to make an ActiveX control seem like a VCL component.

VOI
Value Of Interest

Void structure
Indicates a method that does not return a value; that is, the method has the void return type.

W

Wintel
A term describing the combination of Microsoft Windows operating system running on PCs with Intel or compatible processors. Dominance of the wintel platform began with MS-DOS on PCs with Intel's 8-bit 8088 processors in 1979.

WMF
The Microsoft Windows Metafile format is used to store vector and bitmap image data. Because of its popularity and wide use, many Windows and non-Windows applications support WMF.

WSQ
Wavelet Scalar Quantization (WSQ) Gray-Scale Fingerprint Image Compression Specification based on the results of the NIST (National Institute of Standards and Technology) review. The benefit of WSQ fingerprint-specific compression is reduced file size. A sample fingerprint with a resolution of 589 pixels by 605 pixels, 8-bit grayscale results in a file size of 325 KB when compressed with the standard lossless compression technology LZW.


%%ItemTitle%%

How To
Send Feedback
ThumbnailXpress 4 for .NET - User Guide > How To

Glossary Item Box

This section provides information about the following:

  • Define Cache and Threading Behavior
  • Define End-User Interface
  • Pass Image Data between Accusoft Components
  • Render Thumbnails with Annotations
  • Load and Display Thumbnails
  • Modify Thumbnails
  • Navigate Thumbnails
  • Save Thumbnails
  • Print Thumbnails
  • Debug


%%ItemTitle%%

Fully Unlock ThumbnailXpress
Send Feedback
ThumbnailXpress 4 for .NET - User Guide > How To > Fully Unlock ThumbnailXpress

Glossary Item Box

Enable runtime licensing by first calling the SetSolutionName() method with the name of the runtime license solution as a parameter to the method. The SetSolutionKey() method next should be called with the four integer keys as parameters. These four integer keys make up the solution key that is required for all runtime licensing. The solution name and the four integers keys are provided in the purchase confirmation email when runtime licenses are purchased. If the application is to use Automatically Reported Runtime (Node-Locked) licensing, then this is all that is required to unlock ThumbnailXpress.

If the application is to use Manually Reported Runtime (Non-Node-Locked) licensing, then an additional call to the SetOEMLicenseKey() method is required with the OEM license key as a parameter. The OEM license key is also provided in the purchase confirmation email when these types of runtime licenses are purchased.

ImagXpress is used internally to thumbnail images, therefore ImagXpress needs to be licensed by calling the corresponding run-time licensing methods for ImagXpress. All applications must first call the SetIXSolutionName() method with ImagXpress’s name of the runtime license solution as a parameter to the method. The SetIXSolutionKey() method next should be called with the four integer keys for ImagXpress run-time licensing as parameters. The solution name for ImagXpress and the four integer keys for ImagXpress are provided in the purchase confirmation email when runtime licenses are purchased for ImagXpress. If the application is to use Automatically Reported Runtime (Node-Locked) licensing, then this all that required to unlock ImagXpress for use with ThumbnailXpress.

If the application is to use Manually Reported Runtime (Non-Node-Locked) licensing, then an additional call to the SetIXOEMLicenseKey() method is required with the OEM license key for ImagXpress as a parameter. The OEM license key for ImagXpress is also provided in the purchase confirmation email when these types of runtime licenses are purchased.

To thumbnail PDFs, PDF Xpress needs to be licensed by calling UnlockPdfXpressRuntime() when the application begins and passing the 4 PDF Xpress unlock codes as parameters to the method. PDF Xpress v3 and PDF Xpress v4 use the older licensing mechanism and do not need a solution name.

An Automatically Reported Runtime (Node-Locked) Licensing Example:

ACMEImaging – Solution name for both ImagXpress and ThumbnailXpress.

0x40000001, 0x40000002, 0x40000003, 0x40000004 - ThumbnailXpress runtime license keys

0xB0000001, 0xB0000002, 0xB0000003, 0xB0000004 - ImagXpress runtime license keys

0x12345678, 0x12345678, 0x12345678, 0x12345678 - PDF Xpress runtime unlock codes

C# Example Copy Code
// Provide run-time licensing for ThumbnailXpress
thumbnailXpress1.Licensing.SetSolutionName(“ACMEImaging”);
thumbnailXpress1.Licensing.SetSolutionKey(0x40000001, 0x40000002, 0x40000003, 0x40000004);
// Next provide run-time licensing for ThumbnailXpress’s use of ImagXpress
thumbnailXpress1.Licensing.SetIXSolutionName(“ACMEImaging”);
thumbnailXpress1.Licensing.SetIXSolutionKey(0xB0000001, 0xB0000002, 0xB0000003, 0xB0000004);
// Finally provide run-time licensing for ThumbnailXpress’s use of PDFXpress
thumbnailXpress1.Licensing.UnlockPdfXpressRuntime(0x12345678, 0x12345678, 0x12345678, 0x12345678);
VB .NET Example Copy Code
‘ Provide run-time licensing for ThumbnailXpress
thumbnailXpress1.Licensing.SetSolutionName(“ACMEImaging”)
thumbnailXpress1.Licensing.SetSolutionKey(&H40000001, &H40000002, &H40000003, &H40000004)
‘ Next provide run-time licensing for ThumbnailXpress’s use of ImagXpress
thumbnailXpress1.Licensing.SetIXSolutionName(“ACMEImaging”)
thumbnailXpress1.Licensing.SetIXSolutionKey(&HB0000001, &HB0000002, &HB0000003, &HB0000004)
‘ Finally provide run-time licensing for ThumbnailXpress’s use of PDFXpress
thumbnailXpress1.Licensing.UnlockPdfXpressRuntime(&H12345678, &H12345678, &H12345678, &H12345678)

A Manually Reported Runtime (Non-Node-Locked) Licensing Example:

ACMEImaging – Solution name for both ImagXpress and ThumbnailXpress.

0x40000001, 0x40000002, 0x40000003, 0x40000004 - ThumbnailXpress runtime license keys

0xB0000001, 0xB0000002, 0xB0000003, 0xB0000004 - ImagXpress runtime license keys

0x12345678, 0x12345678, 0x12345678, 0x12345678 - PDF Xpress runtime unlock codes

ThumbnailXpress OEM License Key –“1.0.GQCC0EmUgONaI4QDZ32tpGWfpGW4gtbC0iIC0iN4bigYM3m3K5b487QOsAM38O24mUp5bOpD2O240OQ32U2YsUKDKA87MYPGgGgaptMiK5Nv8AI4mYg4m3QvW52DZCPGs4p784mtP4IUgOWiIG0AQYp4052iIAWvNCZfpGWC8vQ5P4ZGKaPAWfbiYfZOI303pOZAgisiNaWA27gGsf8Ob7Zvm5IaKGI4KC8GsG2CWYpGQAg5sUmYWvZCQANig48G2ap4bG0DsO240YsUmtptNiZamCPGbYMfMO83gANAZCN52YbY8U8f8DM4m3g7MYMYWGW5Q7QGWaMiN7MtZfmtgY8AN7NDP7Z4W7sCbGKUPa0im7EDPP"

ImagXpress OEM License Key –“1.0.WXPB1EmUgONaI4QDZ32tpGWfpGW4gtbC0iIC0iN4bigYM3m3K5b487QOsAM38O24mUp5bOpD2O240OQ32U2YsUKDKA87MYPGgGgaptMiK5Nv8AI4mYg4m3QvW52DZCPGs4p784mtP4IUgOWiIG0AQYp4052iIAWvNCZfpGWC8vQ5P4ZGKaPAWfbiYfZOI303pOZAgisiNaWA27gGsf8Ob7Zvm5IaKGI4KC8GsG2CWYpGQAg5sUmYWvZCQANig48G2ap4bG0DsO240YsUmtptNiZamCPGbYMfMO83gANAZCN52YbY8U8f8DM4m3g7MYMYWGW5Q7QGWaMiN7MtZfmtgY8AN7NDP7Z4W7sCbGKUPa0im7EDJS"

C# Example Copy Code
// Provide run-time licensing for ThumbnailXpress
thumbnailXpress1.Licensing.SetSolutionName(“ACMEImaging”);
thumbnailXpress1.Licensing.SetSolutionKey(0x40000001, 0x40000002, 0x40000003, 0x40000004);
thumbnailXpress1.Licensing.SetOEMLicenseKey(“1.0.GQCC0EmUgONaI4QDZ32tpGWfpGW4gtbC0iIC0iN4bigYM3m3K5b487QOsAM38O24mUp5bOpD2O240OQ32U2YsUKDKA87MYPGgGgaptMiK5Nv8AI4mYg4m3QvW52DZCPGs4p784mtP4IUgOWiIG0AQYp4052iIAWvNCZfpGWC8vQ5P4ZGKaPAWfbiYfZOI303pOZAgisiNaWA27gGsf8Ob7Zvm5IaKGI4KC8GsG2CWYpGQAg5sUmYWvZCQANig48G2ap4bG0DsO240YsUmtptNiZamCPGbYMfMO83gANAZCN52YbY8U8f8DM4m3g7MYMYWGW5Q7QGWaMiN7MtZfmtgY8AN7NDP7Z4W7sCbGKUPa0im7EDPP");
// Next provide run-time licensing for ThumbnailXpress’s use of ImagXpress
thumbnailXpress1.Licensing.SetIXSolutionName(“ACMEImaging”);
thumbnailXpress1.Licensing.SetIXSolutionKey(0xB0000001, 0xB0000002, 0xB0000003, 0xB0000004);
thumbnailXpress1.Licensing.SetIXOEMLicenseKey(“1.0.WXPB1EmUgONaI4QDZ32tpGWfpGW4gtbC0iIC0iN4bigYM3m3K5b487QOsAM38O24mUp5bOpD2O240OQ32U2YsUKDKA87MYPGgGgaptMiK5Nv8AI4mYg4m3QvW52DZCPGs4p784mtP4IUgOWiIG0AQYp4052iIAWvNCZfpGWC8vQ5P4ZGKaPAWfbiYfZOI303pOZAgisiNaWA27gGsf8Ob7Zvm5IaKGI4KC8GsG2CWYpGQAg5sUmYWvZCQANig48G2ap4bG0DsO240YsUmtptNiZamCPGbYMfMO83gANAZCN52YbY8U8f8DM4m3g7MYMYWGW5Q7QGWaMiN7MtZfmtgY8AN7NDP7Z4W7sCbGKUPa0im7EDJS");
// Finally provide run-time licensing for ThumbnailXpress’s use of PDFXpress
thumbnailXpress1.Licensing.UnlockPdfXpressRuntime(0x12345678, 0x12345678, 0x12345678, 0x12345678);
VB .NET Example Copy Code
‘ Provide run-time licensing for ThumbnailXpress
thumbnailXpress1.Licensing.SetSolutionName(“ACMEImaging”)
thumbnailXpress1.Licensing.SetSolutionKey(&H40000001, &H40000002, &H40000003, &H40000004)
thumbnailXpress1.Licensing.SetOEMLicenseKey(“1.0.GQCC0EmUgONaI4QDZ32tpGWfpGW4gtbC0iIC0iN4bigYM3m3K5b487QOsAM38O24mUp5bOpD2O240OQ32U2YsUKDKA87MYPGgGgaptMiK5Nv8AI4mYg4m3QvW52DZCPGs4p784mtP4IUgOWiIG0AQYp4052iIAWvNCZfpGWC8vQ5P4ZGKaPAWfbiYfZOI303pOZAgisiNaWA27gGsf8Ob7Zvm5IaKGI4KC8GsG2CWYpGQAg5sUmYWvZCQANig48G2ap4bG0DsO240YsUmtptNiZamCPGbYMfMO83gANAZCN52YbY8U8f8DM4m3g7MYMYWGW5Q7QGWaMiN7MtZfmtgY8AN7NDP7Z4W7sCbGKUPa0im7EDPP")
‘ Next provide run-time licensing for ThumbnailXpress’s use of ImagXpress
thumbnailXpress1.Licensing.SetIXSolutionName(“ACMEImaging”)
thumbnailXpress1.Licensing.SetIXSolutionKey(&HB0000001, &HB0000002, &HB0000003, &HB0000004)
thumbnailXpress1.Licensing.SetIXOEMLicenseKey(“1.0.WXPB1EmUgONaI4QDZ32tpGWfpGW4gtbC0iIC0iN4bigYM3m3K5b487QOsAM38O24mUp5bOpD2O240OQ32U2YsUKDKA87MYPGgGgaptMiK5Nv8AI4mYg4m3QvW52DZCPGs4p784mtP4IUgOWiIG0AQYp4052iIAWvNCZfpGWC8vQ5P4ZGKaPAWfbiYfZOI303pOZAgisiNaWA27gGsf8Ob7Zvm5IaKGI4KC8GsG2CWYpGQAg5sUmYWvZCQANig48G2ap4bG0DsO240YsUmtptNiZamCPGbYMfMO83gANAZCN52YbY8U8f8DM4m3g7MYMYWGW5Q7QGWaMiN7MtZfmtgY8AN7NDP7Z4W7sCbGKUPa0im7EDJS")
‘ Finally provide run-time licensing for ThumbnailXpress’s use of PDFXpress
thumbnailXpress1.Licensing.UnlockPdfXpressRuntime(&H12345678, &H12345678, &H12345678, &H12345678)


%%ItemTitle%%

Define Cache and Threading Behavior
Send Feedback
ThumbnailXpress 4 for .NET - User Guide > How To > Define Cache and Threading Behavior

Glossary Item Box

This section provides information about the following:

  • Set Cache Behavior
  • Set Threading Behavior


%%ItemTitle%%

Set Cache Behavior
See Also Send Feedback
ThumbnailXpress 4 for .NET - User Guide > How To > Define Cache and Threading Behavior > Set Cache Behavior

Glossary Item Box

All thumbnail images are generated with unique IDs and are cached for rapid display access purposes. The CacheMemoryLimit property specifies the maximum size of the cache.

  • To empty the Thumbnail Cache, call the CacheClear method.

See Also

ThumbnailCache Class


%%ItemTitle%%

Set Threading Behavior
See Also Send Feedback
ThumbnailXpress 4 for .NET - User Guide > How To > Define Cache and Threading Behavior > Set Threading Behavior

Glossary Item Box

Threading in Image Generation

ThumbnailXpress™ uses background image generation threads to improve responsiveness. At component start-up, ThumbnailXpress determines an initial count of background threads based on the host computer's capabilities. To keep operation responsive, ThumbnailXpress monitors the time consumed by a background thread and will start an additional thread when it has determined that a particular thread's image retrieval/generation time has exceeded the user settable ThreadStartThreshold property value.

By default, the value of this property is 3000 milliseconds (3 seconds). Additionally, ThumbnailXpress will abandon a thread, and free up its resources, if its retrieval/generation time has exceeded the ThreadHungThreshold property value. By default, the value of this property is 9000 milliseconds (9 seconds). As noted, when needed, ThumbnailXpress will create additional threads but will not allow the count of concurrent background threads to exceed the value specified by the MaximumThreadCount property.

The default value for the MaximumThreadCount property is 2 times the calculated initial count of background threads. The allowable value range for this property is 1 thru 32. Too many background threads quickly degrade performance and a good rule of thumb for all these threading properties is to leave them at the default values. For applications that don’t want an image loading attempt to be abandoned and want to allow, for example, the potential of very slow internet access for retrieving images, set the ThreadHungThreshold property to a higher value.

Multiple ThumbnailXpress Instances

It's important not to run one instance of the control from multiple application threads, instead, create a separate instance of the control for each application thread. For a well-presented primer on threading, see Microsoft's "What Every Dev Must Know About Multithreaded Apps" at the Visual Studio.NET Developer Center (08/05, msdn.microsoft.com/msdnmag/).

The Performance tab in the Microsoft Windows Task Manager dialog box (press CTRL, ALT and Delete keys) displays multiple CPU Usage History boxes for both logical and physical CPUs. The image below shows a single CPU with two logical CPU's.

See Also

ThreadStartThreshold Property
ThreadHungThreshold Property
MaximumThreadCount Property


%%ItemTitle%%

Define End-User Interface
Send Feedback
ThumbnailXpress 4 for .NET - User Guide > How To > Define End-User Interface

Glossary Item Box

This section provides information about the following:

  • Set Thumbnail Appearance
  • Set User Interaction Behavior


%%ItemTitle%%

Set Thumbnail Appearance
See Also Send Feedback
ThumbnailXpress 4 for .NET - User Guide > How To > Define End-User Interface > Set Thumbnail Appearance

Glossary Item Box

The application controls the appearance of thumbnails in the display using properties in ThumbnailXpress™.

ThumbnailXpress Control Window Appearance

The appearance of the ThumbnailXpress control window is controlled as follows:

  • The background color for the control (BackColor)
  • The foreground color for the control (ForeColor)
  • The style of the border of the control (BorderStyle)
  • The margins of the control (BottomMargin, TopMargin, RightMargin, LeftMargin)
  • Scrollbar visibility (ShowScrollbar)
  • The scrollbar direction (ScrollDirection)

Thumbnail Cell Appearance

The appearance of each individual thumbnail is defined using the "Cell" properties. The following can be specified:

  • The thumbnail border color and width (CellBorderColor, CellBorderWidth)
  • The dimensions of each thumbnail (CellHeight, CellWidth)
  • The spacing between each thumbnail (CellHorizontalSpacing, CellVerticalSpacing)
  • The color of the fill between thumbnails (CellSpacingColor)
  • The background color of selected thumbnails (SelectBackColor)
  • Whether a placeholder image is drawn while waiting for the thumbnail to be generated (ShowImagePlaceholders)

Thumbnail Descriptor Appearance

The appearance of each thumbnail's descriptor is specified using the "Descriptor" properties:

  • The alignment of the descriptor (DescriptorAlignment)
  • The background color of the text in the descriptor (TextBackColor)
  • The font used for the text (Font)
  • The format of the descriptor (DescriptorDisplayMethod)

Set Icon Display Appearance

ThumbnailXpress provides the application with the option to display a pre-image generation "placeholder" icon while the image is being loaded and the thumbnail generated. When ShowImagePlaceholders is set to true, a placeholder image is drawn while waiting for the thumbnail to be generated and a cancel icon is displayed if the generation is cancelled.

- The thumbnail image is being generated. Once generated, this icon is replaced with the thumbnail image.

- The thumbnail image loading was cancelled.

The application can also specify the desired action to take when an error occurs during image loading or thumbnail generation. ThumbnailXpress can either display an error icon to indicate that the thumbnail did not load, or simply abort the loading process without displaying any icon in the control window. When ErrorAction is set to UseErrorIcon, the following icons are displayed, depending on the error encountered:

- The thumbnail image was not loaded, due to an error.

- The thumbnail image was not loaded, because the required software is not licensed by the application.

If the image file type is not supported by ThumbnailXpress, then the icon that is associated with the file in Windows Explorer will be displayed.

See Also

ThumbnailXpress Class


%%ItemTitle%%

Set User Interaction Behavior
See Also Send Feedback
ThumbnailXpress 4 for .NET - User Guide > How To > Define End-User Interface > Set User Interaction Behavior

Glossary Item Box

The application end-user can navigate, select, and move thumbnails within the ThumbnailXpress™ control, between multiple ThumbnailXpress controls, and between multiple applications. The application establishes how the user will interact with the control, by setting the following ThumbnailXpress properties:

Set Selection Behavior

The SelectionMode property specifies the behavior that is desired when an end-user selects a thumbnail.

Set Drag and Drop Behavior

To enable the end-user to drag and drop thumbnails within the ThumbnailXpress component, set IntraComponentThumbnailDragDropEnabled.

To enable the end-user to drag and drop thumbnails between multiple ThumbnailXpress controls, set InterComponentThumbnailDragDropEnabled.

To enable the end-user to drag thumbnails from the ThumbnailXpress component to another application, set EnableAsDragSourceForExternalDragDrop.

To enable the end-user to drag thumbnails from other applications into the ThumbnailXpress component, set EnableAsDropTargetForExternalDragDrop.

The Shift key must be held down during a drag-and-drop operation to move multiple selected thumbnail items.

Set Directory Drill Down Behavior

If DblClickDirectoryDrillDown is enabled within the ThumbnailXpress object, then when the end-user double clicks on a folder icon in the ThumbnailXpress component, the thumbnails of images within the directory will be displayed. This enables the end user to navigate through folder structures to locate thumbnails of interest.

See Also

Enabled Property
ThumbnailXpress Class
SelectionMode Enumeration
IntraComponentThumbnailDragDropEnabled Property
InterComponentThumbnailDragDropEnabled Property
EnableAsDragSourceForExternalDragDrop Property
EnableAsDropTargetForExternalDragDrop Property
DblClickDirectoryDrillDown Property


%%ItemTitle%%

Pass Image Data between Accusoft Components
See Also Send Feedback
ThumbnailXpress 4 for .NET - User Guide > How To > Pass Image Data between Accusoft Components

Glossary Item Box

Traditionally, transferring image data between Accusoft components has required passing the image data in a DIB format. But, beginning with the release of ImagXpress 11, we are adding new methods throughout our products which allow you to easily copy or transfer image data between different Accusoft objects with just a single method call.

Regardless of its product or component assembly, any Accusoft image class which supports easily sending its image data to another Accusoft object will implement two methods: CopyTo(object destination) and TransferTo(object destination). And any Accusoft image class which supports easily receiving this image data (that is, being the destination object) will be noted in its class documentation.

A CopyTo method makes a complete copy of the image data. When called, both the source and destination objects will contain their own separate copies of identical image data. A TransferTo method, on the other hand, completely transfers the image data from one object to another. When finished, the source object will no longer contain image data; the image will be owned by the destination object.

Within the ImagXpress Suite

Within the ImagXpress suite of components, there are four classes which support sending their image data via CopyTo and TransferTo methods:

  1. ImagXpress - Accusoft.ImagXpressSdk.ImageX
  2. TwainPRO - Accusoft.TwainProSdk.ScannedImage
  3. ISIS Xpress - Accusoft.ISISXpressSdk.Output
  4. ThumbnailXpress - Accusoft.ThumbnailXpressSdk.ThumbnailItem

And within the ImagXpress suite of components, there is only one class which supports receiving image data: the ImagXpress ImageX class.

Other Accusoft products may contain additional classes which can send and receive image data.

How to Copy Image Data from ThumbnailXpress to ImagXpress

Here's an excerpt from a simple WinForms application. The main form contains a single ThumbnailXpress instance named thumbnailXpress1. When the form loads, a single thumbnail is added to the ThumbnailXpress control from an image file named "flower.jpg". After the thumbnail has been loaded, its image data is then copied to an ImagXpress ImageX object and saved to disk as "flower-thumbnail.bmp".

C# Example Copy Code
using System;
using System.Windows.Forms;
using Accusoft.ImagXpressSdk;

namespace WinFormsExample
{
    public partial class ExampleForm : Form
    {
        public ExampleForm()
        {
            InitializeComponent();
        }

        void ExampleForm_Load(object sender, EventArgs e)
        {
            thumbnailXpress1.ItemComplete += new Accusoft.ThumbnailXpressSdk.ThumbnailXpressEvents.ItemCompleteEventHandler(thumbnailXpress1_ItemComplete);

            //Asynchronously load an image into the ThumbnailXpress component when the button is clicked
            thumbnailXpress1.Items.AddItemsFromFile("flower.jpg", 0, false);
        }

        void thumbnailXpress1_ItemComplete(object sender, Accusoft.ThumbnailXpressSdk.ItemCompleteEventArgs e)
        {
            //When the image has been thumbnailed, copy it to ImagXpress and save it to disk
            using (ImagXpress ix = new ImagXpress())
            using (ImageX image = new ImageX(ix))
            {
                thumbnailXpress1.Items[0].CopyTo(image);
                image.Save("flower-thumbnail.bmp");
            }
        }
    }
}

See Also

CopyTo Method
TransferTo Method


%%ItemTitle%%

Render Thumbnails with Annotations
Send Feedback
ThumbnailXpress 4 for .NET - User Guide > How To > Render Thumbnails with Annotations

Glossary Item Box

You can easily render associated annotation data for your thumbnails by simply connecting ThumbnailXpress to an instance of NotateXpress. If an image has annotation data (such as text, lines, shapes, etc.), ThumbnailXpress will call on NotateXpress to include the annotations in the thumbnail rendering.

Connecting ThumbnailXpress to NotateXpress

The first step in rendering annotations in your thumbnails is to connect your instance of ThumbnailXpress to an instance of NotateXpress. You do this by passing the NotateXpress.InstanceHandle property to the ThumbnailXpress.NotateXpressInstance property.

For example, if you had an instance of ThumbnailXpress named thumbnailXpress, and an instance of NotateXpress named notateXpress, you would do this:

C# Example Copy Code
thumbnailXpress.NotateXpressInstance = notateXpress.InstanceHandle;

If you don't do anything else, ThumbnailXpress will automatically render internal image annotation data that NotateXpress supports (NotateXpress, Imaging for Windows, and XFDF formats).

If, however, you need to render annotations stored in external files, you'll need to teach ThumbnailXpress how to find the data using annotation search rules.

Annotation Search Rules

Instead of telling ThumbnailXpress where to find annotation data for each individual image that it needs to thumbnail, ThumbnailXpress allows you to give it a list of rules that define where it should search for annotation data. This special annotation rules list is kept in the ThumbnailXpress.AnnotationSearchOrder property.

As an image is being thumbnailed, ThumbnailXpress will iterate through its rules list to find associated annotation data. The first rule that succeeds will be used as the source of annotation data for that particular image (if no rule succeeds, then ThumbnailXpress concludes that the image does not have associated annotations and renders a thumbnail without any associated annotations). The entire process repeats when ThumbnailXpress moves on to thumbnail the next image - the search for annotations starts over, and the first rule on the list that returns annotation data "wins."

By default, any new instance of ThumbnailXpress will have pre-loaded this list with three rules:

  1. If the image being thumbnailed contains internal Imaging for Windows (WANG) annotation data, use that annotation data.
  2. If the image being thumbnailed contains internal NotateXpress annotation data, use that annotation data.
  3. If the image being thumbnailed contains internal XFDF (PDF) annotation data, use that annotation data.

This allows you to render internal annotations by simply connecting ThumbnailXpress to NotateXpress.

But if you were to clear the rules list and set it up manually yourself, here's how you would do it:

C# Example Copy Code
thumbnailXpress.AnnotationSearchOrder.Clear();
thumbnailXpress.AnnotationSearchOrder.Add(new InternalAnnotationSearchRule(InternalAnnotationType.ImagingForWindows));
thumbnailXpress.AnnotationSearchOrder.Add(new InternalAnnotationSearchRule(InternalAnnotationType.NotateXpress));
thumbnailXpress.AnnotationSearchOrder.Add(new InternalAnnotationSearchRule(InternalAnnotationType.Xfdf));

Or, if you know you only internally need annotation data of a particular type (let's say PDF), you could redefine the search rules to only look for this particular type of annotation data:

C# Example Copy Code
thumbnailXpress.AnnotationSearchOrder.Clear();
thumbnailXpress.AnnotationSearchOrder.Add(new InternalAnnotationSearchRule(InternalAnnotationType.Xfdf));

Setting Up ThumbnailXpress to Render Annotations Stored in External Files

Where the annotation search rules really become important is when your image annotation data is stored externally to the image file. In this case, you must provide a custom set of annotation search rules to ThumbnailXpress in order to teach it how to find your external annotation data.

Before explaining how you do this, it's important to understand that ThumbnailXpress does impose a few requirements on your annotation files:

  1. An external annotation file must be located in the same directory as its associated image
  2. An external annotation filename must be named similarly to its associated image (the extension may be different, or it may contain an additional name prefix or suffix, but nothing more)
  3. An external annotation file must contain annotation data of one of the following types:
    • NotateXpress
    • NotateXpress XML
    • XFDF
    • TMS Sequoia

With that in mind, you define external annotation search rules by constructing new instances of the ExternalAnnotationSearchRule class. An instance of this class must specify the external annotation type, whether the annotation file is named with a prefix or suffix, and whether the annotation file does or does not include the extension of its associated image file. The following examples illustrate how this works (consult the API documentation for details).

Example 1 - Using external annotation files using a .nxp extension

Imagine you have a variety of JPEG files with associated NotateXpress annotation data stored in a file of the same name except the ".jpg" extension has been replaced with ".nxp", like so:

  • Form1.jpg
  • Form1.nxp
  • Form2.jpg
  • Form2.nxp
  • Form3.jpg
  • Form3.nxp

You can "teach" ThumbnailXpress to use the Form1.nxp annotation data with the Form1.jpg file, the Form2.nxp annotation data with the Form2.jpg file, etc., by setting up the following annotation search rule:

C# Example Copy Code
thumbnailXpress.AnnotationSearchOrder.Add(
    new ExternalAnnotationSearchRule(
        ExternalAnnotationType.NotateXpress, //the type of annotation
        null, //no prefix is added to the annotation filename
        ".nxp", //the annotation file ends with ".nxp"
        false)); //but the annotation file does not include the original ".jpg" extension

With one line of code, you have "taught" ThumbnailXpress where it should look for external annotation data. As long as the .nxp files are present, they will be used to render the annotations.

Example 2 - Using only external annotations (ignoring internal annotations)

In the example above, we added a rule that allowed ThumbnailXpress to use annotation data stored in external .nxp files.

Now imagine that our directory contains the following files:

  • Form1.tiff - an image with internal annotations
  • Form1.nxp - a completely different set of annotations in an external file
  • Form2.jpg
  • Form2.nxp

In this case, we have a TIFF file with its own internal annotations, as well as a similarly-named external annotation file. The question is, which one will ThumbnailXpress use for its annotation data?

Since any new instance of ThumbnailXpress will automatically add internal annotation search rules to the search list by default, if we only add an external annotation rule to the list, then we have essentially told ThumbnailXpress: "I'd like you to look for annotations in this external file, but only if you don't find any internal annotations." So, in the example above, when ThumbnailXpress is rendering Form1.tiff, it will find its internal annotation data and use it; the external annotation data in Form1.nxp will not be used.

If what you really want is for ThumbnailXpress to ignore internal annotation data and always use external annotations, you should first clear the annotation search rules:

C# Example Copy Code
thumbnailXpress.AnnotationSearchOrder.Clear();
thumbnailXpress.AnnotationSearchOrder.Add(new ExternalAnnotationSearchRule(...));
...

Example 3 - A variety of annotations

Imagine you have a variety of image and annotation files, like so:

  • building.jpg
  • building.jpg.xml - external NotateXpress XML annotations for Form2.jpg
  • house.png
  • xfdf-house.png - external XFDF annotations for house.png
  • logo.gif
  • logo.annotations - external NotateXpress annotations for logo.gif
  • Form.tiff - an image with internal NXP annotations, which we want
  • WangAnnotations.tiff - a document with internal Imaging for Windows annotations
  • Example.pdf - a document with internal XFDF annotations, which we want

And let's also imagine that you do not want internal Imaging for Windows annotations to ever be rendered.

In this case, here is one way you could set up the ThumbnailXpress annotation search rules:

C# Example Copy Code
//First, clear the pre-defined internal annotation search rules
//(because, for this example, we want to be more selective with which internal
//annotation types are allowed)
thumbnailXpress.AnnotationSearchOrder.Clear();

//Allow internal NXP
thumbnailXpress.AnnotationSearchOrder.Add(new InternalAnnotationSearchRule(InternalAnnotationType.NotateXpress));

//Allow internal XFDF
thumbnailXpress.AnnotationSearchOrder.Add(new InternalAnnotationSearchRule(InternalAnnotationType.Xfdf));

//.xml for NXP XML annotation files
thumbnailXpress.AnnotationSearchOrder.Add(
    new ExternalAnnotationSearchRule(
        ExternalAnnotationType.NotateXpressXml, //the type of annotation
        null, //no prefix is added to the annotation filename
        ".xml", //the annotation file ends with ".nxp"
        true)); //the original image file extension is part of the annotation filename

//"xfdf-" prefix for XFDF annotation files
thumbnailXpress.AnnotationSearchOrder.Add(
    new ExternalAnnotationSearchRule(
        ExternalAnnotationType.Xfdf, //the type of annotation
        "xfdf-", //the annotation filename begins with an "xfdf-" prefix
        null, //no suffix is added to the annotation filename
        true)); //the original image file extension is part of the annotation filename

//.annotations for NXP annotation files
thumbnailXpress.AnnotationSearchOrder.Add(
    new ExternalAnnotationSearchRule(
        ExternalAnnotationType.NotateXpress, //the type of annotation
        null, //no prefix is added to the annotation filename
        ".annotations", //a ".annotations" suffix is added to the annotation filename
        false)); //the original image file extension is not part of the annotation filename

This effectively amounts to saying to ThumbnailXpress:

  • Don't use your default search rules, which include all internal annotation types
  • Use these instead:
    1. Try to use internal NXP annotations
    2. If you can't do that, try to use internal XFDF annotations
    3. If you can't do that, try to use external NotateXpress XML annotations stored in a file of the same name with an additional ".xml" extension
    4. If you can't do that, try to use external XFDF annotations stored in a file of the same name with an additional "xfdf-" prefix
    5. If you can't do that, try to use external NotateXpress annotations stored in a file of the same name but whose extension has been changed to ".annotations"

Summary

If you only need ThumbnailXpress to render annotation data embedded in the image file itself, you simply need to connect your instance of ThumbnailXpress to an instance of NotateXpress. But if you want more control over where ThumbnailXpress should look to find associated annotation data for an image (particularly if you are using external annotation data), you'll need to "teach" ThumbnailXpress where it should search for associated annotation data by customizing the annotation search rules.


%%ItemTitle%%

Load and Display Thumbnails
Send Feedback
ThumbnailXpress 4 for .NET - User Guide > How To > Load and Display Thumbnails

Glossary Item Box

This section provides information about the following:

  • Specify Loading and Rendering Options
  • Generate Thumbnails from File
  • Generate Thumbnails from Directory
  • Generate Thumbnails from PDF File
  • Generate Thumbnails from Stream
  • Get Thumbnail Information
  • Display Thumbnails
  • Delete Thumbnails


%%ItemTitle%%

Specify Loading and Rendering Options
See Also Send Feedback
ThumbnailXpress 4 for .NET - User Guide > How To > Load and Display Thumbnails > Specify Loading and Rendering Options

Glossary Item Box

Before loading any images, specify desired loading and rendering behavior for thumbnails as follows:

  • Set PreserveBlack, if desired, to darken lines in the thumbnail image. This is useful to improve readability/recognizability of the thumbnail image to the end-user.
  • Set CameraRaw, if desired, to specify whether the control will examine the image on loading to determine if the image data is in a camera raw format, and to identify that format. To optimize performance, CameraRaw should be set to false when not needed.
    CameraRaw is only applied when the images are loaded from a local file.

See Also

ThumbnailXpress Class
PreserveBlack Property
CameraRaw Property


%%ItemTitle%%

Generate Thumbnails from File
See Also Send Feedback
ThumbnailXpress 4 for .NET - User Guide > How To > Load and Display Thumbnails > Generate Thumbnails from File

Glossary Item Box

ThumbnailXpress™ provides the user with the ability to generate thumbnails from one or more pages of a local or remote file.

Call ThumbnailItemCollection AddItemsFromFile to load and generate thumbnails from one or more pages of a file. When the ExpandMultiPage parameter is set to true, a thumbnail will be generated for each page in a multi-page file. When the ExpandMultiPage parameter is set to false, only the first page is generated, and the thumbnail icon will show a "+" to indicate that the thumbnail is the first page of a multi-page file.

Alternatively, a thumbnail can be added or inserted into the collection by defining a ThumbnailItem, then calling a ThumbnailItemCollection Insert or Add method. If the Verify parameter is included and set to true, ThumbnailXpress will check to make sure that the local file specified in the supplied ThumbnailItem has a valid file name (e.g. it exists and can be understood by the control).

If the file name indicates a remote path, the Verify parameter is ignored.

When defining a ThumbnailItem, the application can specify the Filename, Page, and if CAD, the CadLayoutNumber to access. The application provides the Descriptor to be displayed with the thumbnail, and a UserTag to record application-specific information about the thumbnail.

C# Copy Code
// Generate a thumbnail from file.
ThumbnailXpress1.Items.AddItemsFromFile("c:\\bird.jpg", 0, true);
// Create and add a thumbnail item for page 3 of multi.tif.
ThumbnailItem item = ThumbnailXpress1.CreateThumbnailItem("c:\\multi.tif", 2, ThumbnailType.Image);
// Optionally set a custom descriptor. By default the filename will be used for the descriptor.
ThumbnailXpress1.DescriptorDisplayMethod = DescriptorDisplayMethods.Custom;
item.Descriptor = "my descriptor";
item.UserTag = "my tag"; // Optionally set a user tag.
ThumbnailXpress1.Items.Add(item);
// Create a thumbnail item for bird.jpg and insert it into the first position.
ThumbnailItem item2 = ThumbnailXpress1.CreateThumbnailItem("c:\\bird.jpg", 0, ThumbnailType.Image);
ThumbnailXpress1.Items.Insert(0, item2);

See Also

ThumbnailItemCollection Class
ThumbnailItem Class
AddItemsFromFile Method
ThumbnailItem Class
ThumbnailItemCollection Class
Insert Method
Add Method
Filename Property
Page Property
CadLayoutNumber Property
Descriptor Property
UserTag Property


%%ItemTitle%%

Generate Thumbnails from Directory
See Also Send Feedback
ThumbnailXpress 4 for .NET - User Guide > How To > Load and Display Thumbnails > Generate Thumbnails from Directory

Glossary Item Box

ThumbnailXpress™ v4 enables loading of images from a local or remote directory, based on specified filter criteria. One or more filters can be defined, enabling customized search and display of thumbnail images. ThumbnailXpress keeps a list of filters that have been defined, and applies all enabled filters when loading images from a directory.

Add or Delete a Filter

To add a filter, first define a Filter object, specifying the filter criteria. For example, directory items can be filtered based on FileSize, Type, and FileDate. The filter can be modified at any time by accessing the properties within the Filter. Next, add the filter by calling FilterCollection Add. An index is returned, uniquely identifying the filter in the list.

Generate Thumbnails from Files within a Directory

Filters are applied when loading images from a directory into the ThumbnailXpress control. All Enabled filters will be applied to determine which images to load. If no filters are enabled, then all folders and files will be loaded.

Call ThumbnailItemCollection AddItemsFromDirectory to load images and generate thumbnails from all files that meet filter criteria in the specified directory. When the control paints, the thumbnail images are displayed.

If the directory contains multi-page files, only the first page of the file is loaded. The thumbnail icon will show a "+" to indicate that the thumbnail is the first page in a multi-page file. Thumbnails of additional pages within the file can be added by calling AddItemsFromFile.
C# Copy Code
// Optionally add filters to load all files with filenames ending in .bmp
// that are smaller than 500000 bytes.
Filter filenameFilter = ThumbnailXpress1.CreateFilter("file name");
filenameFilter.Type = FilterType.Filename;
filenameFilter.FilenamePattern = "*.bmp";
ThumbnailXpress1.Filters.Add(filenameFilter);
Filter filesizeFilter = ThumbnailXpress1.CreateFilter("file size");
filesizeFilter.Type = FilterType.FileSize;
filesizeFilter.Comparison = FilterComparison.LessThan;
filesizeFilter.FileSize = 500000;
ThumbnailXpress1.Filters.Add(filesizeFilter);

// Generate thumbnails from files within the C:\\ directory.
ThumbnailXpress1.Items.AddItemsFromDirectory("C:\\", 0);

See Also

Filter Class
FilterCollection Class
ThumbnailItemCollection Class


%%ItemTitle%%

Generate Thumbnails from PDF File
See Also Send Feedback
ThumbnailXpress 4 for .NET - User Guide > How To > Load and Display Thumbnails > Generate Thumbnails from PDF File

Glossary Item Box

When PDF Xpress™ is installed, ThumbnailXpress™ can generate thumbnails from PDF files, locally stored in a file or directory. ThumbnailXpress works seamlessly with PDF Xpress v4 after calling the AccessPdfXpress4 method. When a request to generate a thumbnail is made by calling ThumbnailItemCollection methods: Add, AddItemsFromDirectory, AddItemsFromFile, or Insert, if the specified file is a PDF, then ThumbnailXpress will look for and use the most recent installed version of PDF Xpress v4 to render the PDF.

PDF files must be located in a local file or directory to enable thumbnail generation.

C# Copy Code
// Access PDF Xpress v4 to generate a thumbnail from a PDF file.
// It is only necessary to call AccessPdfXpress4 and UnlockPdfXpressRuntime once.
ThumbnailXpress1.Licensing.AccessPdfXpress4();
// The UnlockPdfXpressRuntime method unlocks PDF Xpress for use in distributed environments.
//ThumbnailXpress1.Licensing.UnlockPdfXpressRuntime(1, 2, 3, 4);
ThumbnailXpress1.Items.AddItemsFromFile("C:\\pdfxpress.pdf", 0, false);

See Also

ThumbnailItemCollection Class


%%ItemTitle%%

Generate Thumbnails from Stream
See Also Send Feedback
ThumbnailXpress 4 for .NET - User Guide > How To > Load and Display Thumbnails > Generate Thumbnails from Stream

Glossary Item Box

A thumbnail can be added or inserted into the collection by defining a ThumbnailItem, and then using the FromStream method to specify a stream from which to acquire the image data. Then call the ThumbnailItemCollection methods InsertItemFromStream or AddItemFromStream.

The ThumbnailItemCollection Add method cannot be used to add an item from stream.
C# Copy Code
// Generate a thumbnail from stream.
System.IO.FileStream theFile;
ThumbnailItem theThumbnail;
theFile = new System.IO.FileStream("c:\\bird.jpg", System.IO.FileMode.Open, System.IO.FileAccess.Read);
theThumbnail = thumbnailXpress1.CreateThumbnailItem("", 1, ThumbnailType.Image);
theFile.Seek(0, System.IO.SeekOrigin.Begin);
theThumbnail.FromStream(theFile);
theThumbnail.Descriptor = "bird.jpg";
theThumbnail.UserTag = theFile.Name;
thumbnailXpress1.Items.AddItemFromStream(theThumbnail);
theFile.Close();

See Also

ThumbnailItem Class
ThumbnailItemCollection Class


%%ItemTitle%%

Get Thumbnail Information
See Also Send Feedback
ThumbnailXpress 4 for .NET - User Guide > How To > Load and Display Thumbnails > Get Thumbnail Information

Glossary Item Box

All thumbnail images are generated with unique IDs and are cached for rapid display access purposes. Access the properties within the ThumbnailItem for information about the thumbnail, including the name of the file from which the thumbnail was generated (Filename), and the page within the file that the thumbnail represents (Page).

The thumbnail image can be acquired as an Hbitmap, Hdib, or Bitmap.

Information about the thumbnail will not be available until generation of the thumbnail is complete. Use the ItemComplete event to ensure that generation is complete prior to checking thumbnail information.
C# Copy Code
// When generation of the thumbnail item is complete, get the filename and page number of the
// thumbnail item and pass the thumbnail image to an ImagXpress ImageXView object to display it.
private void ThumbnailXpress1_ItemComplete(object sender, ItemCompleteEventArgs e)
{
  labelFilename.Text = ThumbnailXpress1.Items[e.ItemIndex].Filename;
  labelPage.Text = ThumbnailXpress1.Items[e.ItemIndex].Page.ToString();
  imageXView1.Image = ImageX.FromHdib(imagXpress1,ThumbnailXpress1.Items[e.ItemIndex].Hdib);
}

See Also

ThumbnailItem Class
Filename Property
Page Property
Hbitmap Property
Hdib Property
Bitmap Property
ItemComplete Event


%%ItemTitle%%

Display Thumbnails
See Also Send Feedback
ThumbnailXpress 4 for .NET - User Guide > How To > Load and Display Thumbnails > Display Thumbnails

Glossary Item Box

The control will update on each paint, to reflect the current state of the thumbnails. When adding multiple thumbnails, it may be beneficial to disable painting to reduce redraw flicker. To disable paint, call BeginUpdate prior to loading any images. Then, load images and generate thumbnails. You can query the status of the thumbnail by accessing the ThumbnailItem Status. When all thumbnails have been generated and are ready for display, call EndUpdate. Painting will resume, displaying all the generated thumbnails (or error icons, if generation failed).

See Also

ThumbnailXpress Class
ThumbnailItem Class


%%ItemTitle%%

Delete Thumbnails
See Also Send Feedback
ThumbnailXpress 4 for .NET - User Guide > How To > Load and Display Thumbnails > Delete Thumbnails

Glossary Item Box

A thumbnail can be removed from the ThumbnailItemCollection by calling Remove, RemoveAt, or Clear. The removed thumbnails will not be displayed on the next paint.

If the Thumbnail was generated with an Hbitmap that was obtained through Hbitmap, the application must call DisposeHbitmap to free all resources associated with the Hbitmap.
C# Copy Code
// Create and add some thumbnail items.
ThumbnailItem item1 = ThumbnailXpress1.CreateThumbnailItem("c:\\1.jpg", 0, ThumbnailType.Image);
ThumbnailXpress1.Items.Add(item1);
ThumbnailItem item2 = ThumbnailXpress1.CreateThumbnailItem("c:\\2.jpg", 0, ThumbnailType.Image);
ThumbnailXpress1.Items.Add(item2);
ThumbnailItem item3 = ThumbnailXpress1.CreateThumbnailItem("c:\\3.jpg", 0, ThumbnailType.Image);
ThumbnailXpress1.Items.Add(item3);
ThumbnailItem item4 = ThumbnailXpress1.CreateThumbnailItem("c:\\4.jpg", 0, ThumbnailType.Image);
ThumbnailXpress1.Items.Add(item4);
// Remove item2.
ThumbnailXpress1.Items.Remove(item2);
// Remove the first thumbnail item.
ThumbnailXpress1.Items.RemoveAt(0);
// Remove all thumbnail items.
ThumbnailXpress1.Items.Clear();

See Also

ThumbnailItem Class
ThumbnailItemCollection Class


%%ItemTitle%%

Modify Thumbnails
See Also Send Feedback
ThumbnailXpress 4 for .NET - User Guide > How To > Modify Thumbnails

Glossary Item Box

Modify Thumbnail Properties

A thumbnail's properties can be modified, to include a different Descriptor or UserTag.

Modify the Thumbnail Image

If the thumbnail image was loaded from file, the thumbnail image can be replaced by a different page in the file by updating the Page property of the ThumbnailItem. A new image is generated for the ThumbnailItem, and display is updated on the next paint.

If the thumbnail image was loaded from file, the thumbnail image can be replaced by a page in a different file by updating the Filename property of the ThumbnailItem. A new image is generated for the ThumbnailItem, and display is updated on the next paint.

If the thumbnail represents a page in a CAD file, the thumbnail image can be replaced by a different layout in the file by updating the CadLayoutNumber property of the ThumbnailItem. A new image is generated for the ThumbnailItem, and display is updated on the next paint.

If the thumbnail image was loaded FromStream, the thumbnail image can be replaced by an image from a different stream by calling FromStream. A new image is generated for the ThumbnailItem, and display is updated on the next paint.

See Also

ThumbnailItem Class


%%ItemTitle%%

Navigate Thumbnails
Send Feedback
ThumbnailXpress 4 for .NET - User Guide > How To > Navigate Thumbnails

Glossary Item Box

This section provides information about the following:

  • Manage End User Navigation
  • Navigate Programmatically


%%ItemTitle%%

Manage End User Navigation
See Also Send Feedback
ThumbnailXpress 4 for .NET - User Guide > How To > Navigate Thumbnails > Manage End User Navigation

Glossary Item Box

ThumbnailXpress™ v4 enables end-user navigation of thumbnails via standard Windows control events within the ThumbnailXpress object. To specify how the ThumbnailXpress control interprets end-user actions, be sure to set user interaction behavior.

End-User Scrolling

The application end-user can scroll through thumbnails in the thumbnail control window, using the supplied scrollbars. Alternatively, the end-user may use the arrow, page up/down, home, and end keys to navigate thumbnails within the control window.

End-User Selecting

The SelectionMode property specifies the behavior that is desired when an end-user selects a thumbnail. The application end-user selects thumbnail items using a combination of mouse click with control and shift keys.

End-User Drag and Drop

The application end-user can drag and drop thumbnails within the ThumbnailXpress control, between multiple ThumbnailXpress controls, and between the ThumbnailXpress control and other applications, by holding the mouse down over a thumbnail, moving the mouse, then releasing the mouse in the desired location. Set the user interaction behavior to specify desired support for these features.

End-User Directory Drill Down

If DblClickDirectoryDrillDown is enabled within the ThumbnailXpress object, then when the end-user double clicks on a folder icon in the ThumbnailXpress component, the thumbnails of images within the directory will be displayed. This enables the end user to navigate through folder structures to locate thumbnails of interest.

See Also

Filter Class
ThumbnailXpress Class


%%ItemTitle%%

Navigate Programmatically
See Also Send Feedback
ThumbnailXpress 4 for .NET - User Guide > How To > Navigate Thumbnails > Navigate Programmatically

Glossary Item Box

Scrolling

Scrolling the thumbnail control can be controlled programmatically by calling the ScrollItems method to specify the scrolling action and magnitude. The view changes to reflect the requested scrolling. Alternatively, call EnsureVisible to programmatically scroll the thumbnail control until a specified thumbnail is in view.

C# Copy Code
// Scroll forward one page.  The second parameter is not used.
ThumbnailXpress1.ScrollItems(ScrollItemsType.LargeIncrease, 0);
// Scroll backward one row or column.  The second parameter is not used.
ThumbnailXpress1.ScrollItems(ScrollItemsType.SmallDecrease, 0);
// Scroll to the ninth thumbnail item.
ThumbnailXpress1.ScrollItems(ScrollItemsType.ItemIndex, 8);
// If the scroll direction is vertical, this will scroll to the third row.
// If the scroll direction is horizontal, this will scroll to the third column.
ThumbnailXpress1.ScrollItems(ScrollItemsType.ThumbPosition, 2);
// Scroll so that the first thumbnail item is displayed.
ThumbnailXpress1.EnsureVisible(0);

Selecting

Individual thumbnails can be selected programmatically by calling the Add method of the SelectedThumbnailItemCollection and specifying the thumbnail item to select. The SelectedThumbnailItemCollection reflects the number of thumbnails that have been selected, both programmatically as well as by end-user.

C# Copy Code
// Select the first thumbnail item.
ThumbnailXpress1.SelectedItems.Add(ThumbnailXpress1.Items[0]);
// Select the second thumbnail item.
ThumbnailXpress1.SelectedItems.Add(ThumbnailXpress1.Items[1]);
// Clear the selected thumbnail items so that no thumbnail items are selected.
ThumbnailXpress1.SelectedItems.Clear();

See Also

ThumbnailXpress Class
SelectedThumbnailItemCollection Class


%%ItemTitle%%

Save Thumbnails
Send Feedback
ThumbnailXpress 4 for .NET - User Guide > How To > Save Thumbnails

Glossary Item Box

ThumbnailXpress™ has no saving capabilities; only ImagXpress® can be used to save thumbnail images.


%%ItemTitle%%

Print Thumbnails
Send Feedback
ThumbnailXpress 4 for .NET - User Guide > How To > Print Thumbnails

Glossary Item Box

ThumbnailXpress™ has no printing capabilities; only ImagXpress® and PrintPRO™ can be used to print thumbnail images.


%%ItemTitle%%

Debug
See Also Send Feedback
ThumbnailXpress 4 for .NET - User Guide > How To > Debug

Glossary Item Box

Generate a Debug Log

To generate a debug log file, set Debug to true. The log file is kept at the location specified by DebugLogFile. Set the DebugErrorLevel to Development or Detailed to indicate the level of detail to be logged.

Errors

16000 - Accusoft.ThumbnailXpressSdk.ThumbnailXpressException - No error.
16001 - Accusoft.ThumbnailXpressSdk.ThumbnailXpressException - Unknown error.
16002 - System.ArgumentException - Invalid parameter used.
16003 - System.ArgumentOutOfRangeException - The item is out of range.
16004 - System.SystemException - System error.
16005 - System.IO.IOException - File error.
16006 - Accusoft.ThumbnailXpressSdk.ThumbnailXpressException - Internal error.
16007 - Accusoft.ThumbnailXpressSdk.ThumbnailXpressException - Unsupported function.
16008 - Accusoft.ThumbnailXpressSdk.ThumbnailXpressException - Imaging error.
16009 - Accusoft.ThumbnailXpressSdk.ThumbnailXpressException - PDF error.
16010 - System.InvalidOperationException - Illegal operation.
16011 - System.InvalidOperationException - License not set.
16012 – Invalid PDF Password. (Uses the Error Event.)
16013 – Damaged PDF. (Uses the Error Event.)

See Also

Getting Support
ThumbnailXpress Class
ThumbnailXpressException Class


%%ItemTitle%%

ThumbnailXpress 4 for .NET - API Reference
Send Feedback

Glossary Item Box

This API Reference provides detailed information about all ThumbnailXpress public API members.


%%phrase%%

Accusoft.ThumbnailXpress4.Net Assembly
See Also Send Feedback

Glossary Item Box

Namespaces

Namespace | Description
Accusoft.ThumbnailXpressSdk |


$$GETTING_STARTED$$ - %%projecttitle%%

Getting Started
Send Feedback

Glossary Item Box


$$INTRODUCTION$$ - %%projecttitle%%

Introduction
Send Feedback

Glossary Item Box


%%ItemTitle%%

Accusoft.ThumbnailXpressSdk Namespace
See Also Inheritance Hierarchy Send Feedback

Glossary Item Box

Classes

 | Class | Description
Class | AnnotationSearchRule | The AnnotationSearchRule class is an abstract class to be inherited by the InternalAnnotationSearchRule and ExternalAnnotationSearchRule classes.
Class | AnnotationSearchRuleCollection<T> |
Class | ErrorEventArgs | ErrorEventArgs is the argument information for the ThumbnailXpress.Error event.
Class | ExternalAnnotationSearchRule | The ExternalAnnotationSearchRule class is used to specify the annotation type, the prefix pattern, the suffix pattern, and if the original file extension is included in the external annotation file to be searched for by ThumbnailXpress. If a file is found that matches the criterion then it will be used to draw annotations of the thumbnail.
Class | Filter | This class exposes methods and properties for specifying match and comparison image file criteria that may be imposed when thumbnail images are loaded from a file system directory using the ThumbnailItemCollection.AddItemsFromDirectory method.
Class | FilterCollection | This class provides access and manipulation functionality for one or more filter objects. Filtering criteria for all enabled filter objects in the collection are applied to all image files that are specified by a ThumbnailItemCollection.AddItemsFromDirectory method call.
Class | FilterCollectionEnumerator | The FilterCollectionEnumerator class provides a lockable IEnumerator interface for the FilterCollection class. When locked, the FilterCollectionEnumerator provides thread-safe read-only access to the FilterCollection.
Class | InternalAnnotationSearchRule | The InternalAnnotationSearchRule class is used to specify the annotation type to be searched for in the TIF or PDF file being thumbnailed by ThumbnailXpress. If such annotations are found then they will be drawn on the thumbnail.
Class | ItemCompleteEventArgs | ItemCompleteEventArgs is the argument information for the ThumbnailXpress.ItemComplete event.
Class | Licensing | The Licensing class provides ThumbnailXpress licensing methods and properties access.
Class | LoadFromStreamEventArgs | LoadFromStreamEventArgs is the argument information for the ThumbnailXpress.LoadFromStream event.
Class | SelectedThumbnailItemCollection | SelectedThumbnailItemCollection class provides selected Thumbnail Item manipulation functionality. The collection provides access to the selected thumbnail items in the list display. Adding or Removing selected items will cause the list display to update if appropriate
Class | SelectedThumbnailItemCollectionEnumerator | SelectedThumbnailItemCollectionEnumerator class provides a lockable IEnumerator interface for the SelectedThumbnailItemCollection class.
Class | ThumbnailCache | This class exposes to the user properties and methods to access the memory and file caching parameters for ThumbnailXpress.
Class | ThumbnailItem | The ThumbnailItem class exposes properties for accessing individual thumbnail item data, including image filename, item type, page number, bitmap, page count, and processing status.
Class | ThumbnailItemCollection | ThumbnailItemCollection class provides thumbnail item manipulation and image presentation functionality.
Class | ThumbnailItemCollectionEnumerator | ThumbnailItemCollectionEnumerator class provides a lockable IEnumerator interface for the ThumbnailItemCollection class.
Class | ThumbnailXpress | The Thumbnail User Control provides displaying of supported image types as thumbnails inside individual cells in a scrollable collection.
Class | ThumbnailXpressEvents | This class implements the ThumbnailXpress events.
Class | ThumbnailXpressException | Summary description for ThumbnailXpressException.

Delegates

 | Delegate | Description
Delegate | ThumbnailXpressEvents.DragDropEventHandler | Defines the event handler for the ThumbnailXpress.DragDrop event.
Delegate | ThumbnailXpressEvents.DragEnterEventHandler | Defines the event handler for the ThumbnailXpress.DragEnter event.
Delegate | ThumbnailXpressEvents.DragLeaveEventHandler | Defines the event handler for the ThumbnailXpress.DragLeave event.
Delegate | ThumbnailXpressEvents.DragOverEventHandler | Defines the event handler for the ThumbnailXpress.DragOver event.
Delegate | ThumbnailXpressEvents.ErrorEventHandler | Defines the event handler for the ThumbnailXpress.Error event.
Delegate | ThumbnailXpressEvents.GiveFeedbackEventHandler | Defines the event handler for the ThumbnailXpress.GiveFeedback event.
Delegate | ThumbnailXpressEvents.ItemCompleteEventHandler | Defines the event handler for the ThumbnailXpress.ItemComplete event.
Delegate | ThumbnailXpressEvents.LoadFromStreamEventHandler | Defines the event handler for the ThumbnailXpress.LoadFromStream event.
Delegate | ThumbnailXpressEvents.QueryContinueDragEventHandler | Defines the event handler for the ThumbnailXpress.QueryContinueDrag event.
Delegate | ThumbnailXpressEvents.SelectedIndexChangedEventHandler | Defines the event handler for the ThumbnailXpress.SelectedIndexChanged event.

Enumerations

 | Enumeration | Description
Enumeration | DebugErrorLevel | Option values which determine the amount of logging detail to be sent to the log file.
Enumeration | DescriptorAlignments | Option values which determine the alignment of the descriptor text display.
Enumeration | DescriptorDisplayMethods | Option values which determine the source of descriptor text.
Enumeration | ErrorAction | Option values which determine the action taken if thumbnail processing error are encountered.
Enumeration | EvaluationMode | Option values which determine the evaluation modes available for use.
Enumeration | ExternalAnnotationType |
Enumeration | FilterComparison | Option values which specify the desired comparison outcome for a file date or size filter.
Enumeration | FilterType | Option values which determine the thumbnail image file parameter that is to be compared or matched by a filter.
Enumeration | InternalAnnotationType | Values which determine which type of annotations that ThumbnailXpress can express.
Enumeration | ScrollDirection | Option values which determine the direction the thumbnails will scroll in the control.
Enumeration | ScrollItemsType | Option values which specify the incremental amount or whether a positional programmatic scroll operation is desired.
Enumeration | SelectionMode | Option values which determine the Thumbnail Item selection mode for the control.
Enumeration | ThumbnailStatus | Option values which determine the Thumbnail item image data validation and generation status.
Enumeration | ThumbnailType | Option values which specify the type of thumbnail (image, directory, etc.) for a thumbnail item.
Enumeration | ToHdibMethod | Specifies the method of returning the DIB.

See Also

Reference

Accusoft.ThumbnailXpress4.Net Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Accusoft.ThumbnailXpressSdk Namespace Inheritance Hierarchy
See Also Send Feedback

Glossary Item Box

Inheritance Hierarchy

System.Object
Accusoft.ThumbnailXpressSdk.AnnotationSearchRule
Accusoft.ThumbnailXpressSdk.ExternalAnnotationSearchRule
Accusoft.ThumbnailXpressSdk.InternalAnnotationSearchRule
Accusoft.ThumbnailXpressSdk.Filter
Accusoft.ThumbnailXpressSdk.FilterCollectionEnumerator
Accusoft.ThumbnailXpressSdk.Licensing
Accusoft.ThumbnailXpressSdk.SelectedThumbnailItemCollectionEnumerator
Accusoft.ThumbnailXpressSdk.ThumbnailCache
Accusoft.ThumbnailXpressSdk.ThumbnailItem
Accusoft.ThumbnailXpressSdk.ThumbnailItemCollectionEnumerator
Accusoft.ThumbnailXpressSdk.ThumbnailXpressEvents
System.Collections.CollectionBase
Accusoft.ThumbnailXpressSdk.FilterCollection
Accusoft.ThumbnailXpressSdk.SelectedThumbnailItemCollection
Accusoft.ThumbnailXpressSdk.ThumbnailItemCollection
System.Collections.ObjectModel.Collection<T>
Accusoft.ThumbnailXpressSdk.AnnotationSearchRuleCollection<T>
System.EventArgs
Accusoft.ThumbnailXpressSdk.ErrorEventArgs
Accusoft.ThumbnailXpressSdk.ItemCompleteEventArgs
Accusoft.ThumbnailXpressSdk.LoadFromStreamEventArgs
System.Exception
Accusoft.ThumbnailXpressSdk.ThumbnailXpressException
System.Windows.Forms.UserControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.ScrollableControl
System.Windows.Forms.Control
System.ComponentModel.Component
System.MarshalByRefObject
Accusoft.ThumbnailXpressSdk.ThumbnailXpress

See Also

Reference

Accusoft.ThumbnailXpress4.Net Assembly


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
AnnotationSearchRule Class
Members See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : AnnotationSearchRule Class

Glossary Item Box

The AnnotationSearchRule class is an abstract class to be inherited by the InternalAnnotationSearchRule and ExternalAnnotationSearchRule classes.

Object Model

AnnotationSearchRule Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public MustInherit Class AnnotationSearchRule
'Usage

Dim instance As AnnotationSearchRule
public abstract class AnnotationSearchRule
public __gc abstract class AnnotationSearchRule
public ref class AnnotationSearchRule abstract

Inheritance Hierarchy

System.Object
Accusoft.ThumbnailXpressSdk.AnnotationSearchRule
Accusoft.ThumbnailXpressSdk.ExternalAnnotationSearchRule
Accusoft.ThumbnailXpressSdk.InternalAnnotationSearchRule

See Also

Reference

AnnotationSearchRule Members
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.ThumbnailXpress4.Net
AnnotationSearchRule Class Members
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : AnnotationSearchRule Class

Glossary Item Box

The following tables list the members exposed by AnnotationSearchRule.

See Also

Reference

AnnotationSearchRule Class
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%%

T
[image]
Accusoft.ThumbnailXpress4.Net
AnnotationSearchRuleCollection<T> Class
Members See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : AnnotationSearchRuleCollection<T> Class

Glossary Item Box

Object Model

AnnotationSearchRuleCollection<T> ClassAnnotationSearchRule Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Class AnnotationSearchRuleCollection(Of T)
   Inherits System.Collections.ObjectModel.Collection(Of AnnotationSearchRule)
'Usage

Dim instance As AnnotationSearchRuleCollection(Of T)
public class AnnotationSearchRuleCollection<T> : System.Collections.ObjectModel.Collection<AnnotationSearchRule>
public __gc class AnnotationSearchRuleCollection<T> : public System.Collections.ObjectModel.Collection<AnnotationSearchRule>
generic<typename T>
public ref class AnnotationSearchRuleCollection : public System.Collections.ObjectModel.Collection<AnnotationSearchRule>

Type Parameters

T

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
Accusoft.ThumbnailXpressSdk.AnnotationSearchRuleCollection<T>

See Also

Reference

AnnotationSearchRuleCollection<T> Members
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.ThumbnailXpress4.Net
AnnotationSearchRuleCollection<T> Class Members
See Also Properties Methods Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : AnnotationSearchRuleCollection<T> Class

Glossary Item Box

The following tables list the members exposed by AnnotationSearchRuleCollection<T>.

Public Properties

 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<AnnotationSearchRule>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<AnnotationSearchRule>)
Top

Public Methods

 | Name | Description
Public Method | Add |
Public Method | Clear |
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<AnnotationSearchRule>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<AnnotationSearchRule>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<AnnotationSearchRule>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<AnnotationSearchRule>)
Public Method | Insert |
Public Method | Remove |
Public Method | RemoveAt |
Top

See Also

Reference

AnnotationSearchRuleCollection<T> Class
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.ThumbnailXpress4.Net
AnnotationSearchRuleCollection<T> Class Methods
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : AnnotationSearchRuleCollection<T> Class

Glossary Item Box

For a list of all members of this type, see AnnotationSearchRuleCollection<T> members.

Public Methods

 | Name | Description
Public Method | Add |
Public Method | Clear |
Public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<AnnotationSearchRule>)
Public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<AnnotationSearchRule>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<AnnotationSearchRule>)
Public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<AnnotationSearchRule>)
Public Method | Insert |
Public Method | Remove |
Public Method | RemoveAt |
Top

See Also

Reference

AnnotationSearchRuleCollection<T> Class
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.ThumbnailXpress4.Net
AnnotationSearchRuleCollection<T> Class Properties
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : AnnotationSearchRuleCollection<T> Class

Glossary Item Box

For a list of all members of this type, see AnnotationSearchRuleCollection<T> members.

Public Properties

 | Name | Description
Public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<AnnotationSearchRule>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.ObjectModel.Collection<AnnotationSearchRule>)
Top

See Also

Reference

AnnotationSearchRuleCollection<T> Class
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Add Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > AnnotationSearchRuleCollection<T> Class : Add Method

item

Glossary Item Box

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Shadows Sub Add( _
   ByVal item As AnnotationSearchRule _
)
'Usage

Dim instance As AnnotationSearchRuleCollection(Of T)
Dim item As AnnotationSearchRule

instance.Add(item)
public new void Add(
   AnnotationSearchRule item
)
public: new void Add(
   AnnotationSearchRule* item
)
public:
new void Add(
   AnnotationSearchRule^ item
)

Parameters

item

See Also

Reference

AnnotationSearchRuleCollection<T> Class
AnnotationSearchRuleCollection<T> Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Clear Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > AnnotationSearchRuleCollection<T> Class : Clear Method

Glossary Item Box

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Shadows Sub Clear()
'Usage

Dim instance As AnnotationSearchRuleCollection(Of T)

instance.Clear()
public new void Clear()
public: new void Clear();
public:
new void Clear();

See Also

Reference

AnnotationSearchRuleCollection<T> Class
AnnotationSearchRuleCollection<T> Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Insert Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > AnnotationSearchRuleCollection<T> Class : Insert Method

index
item

Glossary Item Box

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Shadows Sub Insert( _
   ByVal index As Integer, _
   ByVal item As AnnotationSearchRule _
)
'Usage

Dim instance As AnnotationSearchRuleCollection(Of T)
Dim index As Integer
Dim item As AnnotationSearchRule

instance.Insert(index, item)
public new void Insert(
   int index,
   AnnotationSearchRule item
)
public: new void Insert(
   int index,
   AnnotationSearchRule* item
)
public:
new void Insert(
   int index,
   AnnotationSearchRule^ item
)

Parameters

index
item

See Also

Reference

AnnotationSearchRuleCollection<T> Class
AnnotationSearchRuleCollection<T> Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Remove Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > AnnotationSearchRuleCollection<T> Class : Remove Method

item

Glossary Item Box

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Shadows Sub Remove( _
   ByVal item As AnnotationSearchRule _
)
'Usage

Dim instance As AnnotationSearchRuleCollection(Of T)
Dim item As AnnotationSearchRule

instance.Remove(item)
public new void Remove(
   AnnotationSearchRule item
)
public: new void Remove(
   AnnotationSearchRule* item
)
public:
new void Remove(
   AnnotationSearchRule^ item
)

Parameters

item

See Also

Reference

AnnotationSearchRuleCollection<T> Class
AnnotationSearchRuleCollection<T> Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
RemoveAt Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > AnnotationSearchRuleCollection<T> Class : RemoveAt Method

index

Glossary Item Box

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Shadows Sub RemoveAt( _
   ByVal index As Integer _
)
'Usage

Dim instance As AnnotationSearchRuleCollection(Of T)
Dim index As Integer

instance.RemoveAt(index)
public new void RemoveAt(
   int index
)
public: new void RemoveAt(
   int index
)
public:
new void RemoveAt(
   int index
)

Parameters

index

See Also

Reference

AnnotationSearchRuleCollection<T> Class
AnnotationSearchRuleCollection<T> Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
ErrorEventArgs Class
Members See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : ErrorEventArgs Class

Glossary Item Box

ErrorEventArgs is the argument information for the ThumbnailXpress.Error event.

Object Model

ErrorEventArgs Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Class ErrorEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As ErrorEventArgs
public class ErrorEventArgs : System.EventArgs
public __gc class ErrorEventArgs : public System.EventArgs
public ref class ErrorEventArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Accusoft.ThumbnailXpressSdk.ErrorEventArgs

See Also

Reference

ErrorEventArgs Members
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.ThumbnailXpress4.Net
ErrorEventArgs Class Members
See Also Properties Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : ErrorEventArgs Class

Glossary Item Box

The following tables list the members exposed by ErrorEventArgs.

Public Properties

 | Name | Description
Public Property | ItemIndex | Gets and sets the index for the Thumbnail Item collection member which incurred an error during thumbnail generation.
Public Property | Message | Gets and sets the error message for the Thumbnail item collection member which incurred an error during thumbnail generation.
Public Property | Number | Gets and sets the error number for the Thumbnail Item collection member which incurred an error during thumbnail generation.
Top

See Also

Reference

ErrorEventArgs Class
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.ThumbnailXpress4.Net
ErrorEventArgs Class Properties
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : ErrorEventArgs Class

Glossary Item Box

For a list of all members of this type, see ErrorEventArgs members.

Public Properties

 | Name | Description
Public Property | ItemIndex | Gets and sets the index for the Thumbnail Item collection member which incurred an error during thumbnail generation.
Public Property | Message | Gets and sets the error message for the Thumbnail item collection member which incurred an error during thumbnail generation.
Public Property | Number | Gets and sets the error number for the Thumbnail Item collection member which incurred an error during thumbnail generation.
Top

See Also

Reference

ErrorEventArgs Class
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
ItemIndex Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ErrorEventArgs Class : ItemIndex Property

Glossary Item Box

Gets and sets the index for the Thumbnail Item collection member which incurred an error during thumbnail generation.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property ItemIndex As Integer
'Usage

Dim instance As ErrorEventArgs
Dim value As Integer

instance.ItemIndex = value

value = instance.ItemIndex
public int ItemIndex {get; set;}
public: __property int get_ItemIndex();
public: __property void set_ItemIndex(
   int value
);
public:
property int ItemIndex {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the zero-based index of the thumbnail.

Remarks

This index is only valid if there are no additions or deletions to the thumbnail item collection prior to use of this index value.

See Also

Reference

ErrorEventArgs Class
ErrorEventArgs Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Message Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ErrorEventArgs Class : Message Property

Glossary Item Box

Gets and sets the error message for the Thumbnail item collection member which incurred an error during thumbnail generation.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property Message As String
'Usage

Dim instance As ErrorEventArgs
Dim value As String

instance.Message = value

value = instance.Message
public string Message {get; set;}
public: __property string* get_Message();
public: __property void set_Message(
   string* value
);
public:
property String^ Message {
   String^ get();
   void set (    String^ value);
}

Property Value

An integer value which represents the error message.

Remarks

This message can provide additional information about the error.

See Also

Reference

ErrorEventArgs Class
ErrorEventArgs Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Number Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ErrorEventArgs Class : Number Property

Glossary Item Box

Gets and sets the error number for the Thumbnail Item collection member which incurred an error during thumbnail generation.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property Number As Integer
'Usage

Dim instance As ErrorEventArgs
Dim value As Integer

instance.Number = value

value = instance.Number
public int Number {get; set;}
public: __property int get_Number();
public: __property void set_Number(
   int value
);
public:
property int Number {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the error number.

Remarks

This number can provide additional information about the error.

See Also

Reference

ErrorEventArgs Class
ErrorEventArgs Members
How To Debug


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
ExternalAnnotationSearchRule Class
Members See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : ExternalAnnotationSearchRule Class

Glossary Item Box

The ExternalAnnotationSearchRule class is used to specify the annotation type, the prefix pattern, the suffix pattern, and if the original file extension is included in the external annotation file to be searched for by ThumbnailXpress. If a file is found that matches the criterion then it will be used to draw annotations of the thumbnail.

Object Model

ExternalAnnotationSearchRule Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Class ExternalAnnotationSearchRule
   Inherits AnnotationSearchRule
'Usage

Dim instance As ExternalAnnotationSearchRule
public class ExternalAnnotationSearchRule : AnnotationSearchRule
public __gc class ExternalAnnotationSearchRule : public AnnotationSearchRule
public ref class ExternalAnnotationSearchRule : public AnnotationSearchRule

Remarks

For Example: If the image being thumbnailed is "House.tif", and the prefix pattern is "Annot_" and the suffix pattern is ".external", and the IncludeFileExtension flag is true then it would look for an external annotation file named: "Annot_House.tif.external" If the image being thumbnailed is "Test.jpg", and the prefix pattern is "" and the suffix pattern is ".annot", and the IncludeFileExtension flag is false then it would look for an external annotation file named: "Test.annot"

Inheritance Hierarchy

System.Object
Accusoft.ThumbnailXpressSdk.AnnotationSearchRule
Accusoft.ThumbnailXpressSdk.ExternalAnnotationSearchRule

See Also

Reference

ExternalAnnotationSearchRule Members
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.ThumbnailXpress4.Net
ExternalAnnotationSearchRule Class Members
See Also Properties Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : ExternalAnnotationSearchRule Class

Glossary Item Box

The following tables list the members exposed by ExternalAnnotationSearchRule.

Public Constructors

 | Name | Description
Public Constructor | ExternalAnnotationSearchRule Constructor | Constructor of ExternalAnnotationSearchRule class.
Top

Public Properties

 | Name | Description
Public Property | AnnotationType | The type of annotation to be searched for externally.
Public Property | IncludeOriginalFileExtension | Indicates whether or not the filename pattern includes the image being thumbnailed file's extension.
Public Property | PrefixPattern | The prefix pattern of the external annotation file. The prefix pattern followed by the filename of image being thumbnailed (with or without the extension) followed by the suffix pattern will form the external annotation filename.
Public Property | SuffixPattern | The suffix pattern of the external annotation file. The prefix pattern followed by the filename of image being thumbnailed (with or without the extension) followed by the suffix pattern will form the external annotation filename.
Top

See Also

Reference

ExternalAnnotationSearchRule Class
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
ExternalAnnotationSearchRule Constructor
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ExternalAnnotationSearchRule Class : ExternalAnnotationSearchRule Constructor

annotationType
Specifies the annotation type of the external annotation file.
prefixPattern
Specifies the prefix pattern of the external annotation file.
suffixPattern
Specifies the suffix pattern of the external annotation file.
includeOriginalFileExtension
Specifies whether or not to include the file extension in the pattern of the external annotation file.

Glossary Item Box

Constructor of ExternalAnnotationSearchRule class.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal annotationType As ExternalAnnotationType, _
   ByVal prefixPattern As String, _
   ByVal suffixPattern As String, _
   ByVal includeOriginalFileExtension As Boolean _
)
'Usage

Dim annotationType As ExternalAnnotationType
Dim prefixPattern As String
Dim suffixPattern As String
Dim includeOriginalFileExtension As Boolean

Dim instance As New ExternalAnnotationSearchRule(annotationType, prefixPattern, suffixPattern, includeOriginalFileExtension)
public ExternalAnnotationSearchRule(
   ExternalAnnotationType annotationType,
   string prefixPattern,
   string suffixPattern,
   bool includeOriginalFileExtension
)
public: ExternalAnnotationSearchRule(
   ExternalAnnotationType annotationType,
   string* prefixPattern,
   string* suffixPattern,
   bool includeOriginalFileExtension
)
public:
ExternalAnnotationSearchRule(
   ExternalAnnotationType annotationType,
   String^ prefixPattern,
   String^ suffixPattern,
   bool includeOriginalFileExtension
)

Parameters

annotationType
Specifies the annotation type of the external annotation file.
prefixPattern
Specifies the prefix pattern of the external annotation file.
suffixPattern
Specifies the suffix pattern of the external annotation file.
includeOriginalFileExtension
Specifies whether or not to include the file extension in the pattern of the external annotation file.

See Also

Reference

ExternalAnnotationSearchRule Class
ExternalAnnotationSearchRule Members


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.ThumbnailXpress4.Net
ExternalAnnotationSearchRule Class Properties
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : ExternalAnnotationSearchRule Class

Glossary Item Box

For a list of all members of this type, see ExternalAnnotationSearchRule members.

Public Properties

 | Name | Description
Public Property | AnnotationType | The type of annotation to be searched for externally.
Public Property | IncludeOriginalFileExtension | Indicates whether or not the filename pattern includes the image being thumbnailed file's extension.
Public Property | PrefixPattern | The prefix pattern of the external annotation file. The prefix pattern followed by the filename of image being thumbnailed (with or without the extension) followed by the suffix pattern will form the external annotation filename.
Public Property | SuffixPattern | The suffix pattern of the external annotation file. The prefix pattern followed by the filename of image being thumbnailed (with or without the extension) followed by the suffix pattern will form the external annotation filename.
Top

See Also

Reference

ExternalAnnotationSearchRule Class
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
ExternalAnnotationSearchRule Constructor
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ExternalAnnotationSearchRule Class : ExternalAnnotationSearchRule Constructor

Glossary Item Box

Overload List

Overload | Description
ExternalAnnotationSearchRule Constructor | Constructor of ExternalAnnotationSearchRule class.

See Also

Reference

ExternalAnnotationSearchRule Class
ExternalAnnotationSearchRule Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
AnnotationType Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ExternalAnnotationSearchRule Class : AnnotationType Property

Glossary Item Box

The type of annotation to be searched for externally.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property AnnotationType As ExternalAnnotationType
'Usage

Dim instance As ExternalAnnotationSearchRule
Dim value As ExternalAnnotationType

value = instance.AnnotationType
public ExternalAnnotationType AnnotationType {get;}
public: __property ExternalAnnotationType get_AnnotationType();
public:
property ExternalAnnotationType AnnotationType {
   ExternalAnnotationType get();
}

See Also

Reference

ExternalAnnotationSearchRule Class
ExternalAnnotationSearchRule Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
IncludeOriginalFileExtension Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ExternalAnnotationSearchRule Class : IncludeOriginalFileExtension Property

Glossary Item Box

Indicates whether or not the filename pattern includes the image being thumbnailed file's extension.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property IncludeOriginalFileExtension As Boolean
'Usage

Dim instance As ExternalAnnotationSearchRule
Dim value As Boolean

value = instance.IncludeOriginalFileExtension
public bool IncludeOriginalFileExtension {get;}
public: __property bool get_IncludeOriginalFileExtension();
public:
property bool IncludeOriginalFileExtension {
   bool get();
}

See Also

Reference

ExternalAnnotationSearchRule Class
ExternalAnnotationSearchRule Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
PrefixPattern Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ExternalAnnotationSearchRule Class : PrefixPattern Property

Glossary Item Box

The prefix pattern of the external annotation file. The prefix pattern followed by the filename of image being thumbnailed (with or without the extension) followed by the suffix pattern will form the external annotation filename.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property PrefixPattern As String
'Usage

Dim instance As ExternalAnnotationSearchRule
Dim value As String

value = instance.PrefixPattern
public string PrefixPattern {get;}
public: __property string* get_PrefixPattern();
public:
property String^ PrefixPattern {
   String^ get();
}

Remarks

Within the pattern one can specify a schema for multipage files to indicate page numbers: :$####: is the schema : indicates the start of the schema $ indicates the root, this can be whatever the user specfies, e.g., "MyPages" # indicates the page number or a placeholder : indicates the end of the schema For example, if the pattern string is "_ann.annotationfile.:pg####:" where the schema of the pattern is ":pg####:" The schema would be transformed to: "_ann.annotationfile.pg0001", "_ann.annotationfile.pg0002", "_ann.annotationfile.pg0003"

See Also

Reference

ExternalAnnotationSearchRule Class
ExternalAnnotationSearchRule Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
SuffixPattern Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ExternalAnnotationSearchRule Class : SuffixPattern Property

Glossary Item Box

The suffix pattern of the external annotation file. The prefix pattern followed by the filename of image being thumbnailed (with or without the extension) followed by the suffix pattern will form the external annotation filename.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property SuffixPattern As String
'Usage

Dim instance As ExternalAnnotationSearchRule
Dim value As String

value = instance.SuffixPattern
public string SuffixPattern {get;}
public: __property string* get_SuffixPattern();
public:
property String^ SuffixPattern {
   String^ get();
}

Remarks

Within the pattern one can specify a schema for multipage files to indicate page numbers: :$####: is the schema : indicates the start of the schema $ indicates the root, this can be whatever the user specfies, e.g., "MyPages" # indicates the page number or a placeholder : indicates the end of the schema For example, if the pattern string is "_ann.annotationfile.:pg####:" where the schema of the pattern is ":pg####:" The schema would be transformed to: "_ann.annotationfile.pg0001", "_ann.annotationfile.pg0002", "_ann.annotationfile.pg0003"

See Also

Reference

ExternalAnnotationSearchRule Class
ExternalAnnotationSearchRule Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Filter Class
Members See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : Filter Class

Glossary Item Box

This class exposes methods and properties for specifying match and comparison image file criteria that may be imposed when thumbnail images are loaded from a file system directory using the ThumbnailItemCollection.AddItemsFromDirectory method.

Object Model

Filter Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Class Filter
'Usage

Dim instance As Filter
public class Filter
public __gc class Filter
public ref class Filter

Remarks

Note: A Filter instance must be added to the FilterCollection and be enabled in order for its filtering criteria to be active.

Inheritance Hierarchy

System.Object
Accusoft.ThumbnailXpressSdk.Filter

See Also

Reference

Filter Members
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.ThumbnailXpress4.Net
Filter Class Members
See Also Properties Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : Filter Class

Glossary Item Box

The following tables list the members exposed by Filter.

Public Properties

 | Name | Description
Public Property | CaseSensitive | Gets and sets an indicator if the filter file name matching case sensitivity is enabled.
Public Property | Comparison | Gets and sets the filter comparison outcome criteria.
Public Property | Enabled | Gets and sets an indicator to enable the filter status.
Public Property | FileDate | Gets and sets the filter file date comparison value.
Public Property | FilenamePattern | Gets and sets the filter filename matching pattern.
Public Property | FileSize | Gets and sets the filter file size comparison value.
Public Property | FilterName | Gets and sets the name of the filter.
Public Property | IncludeHidden | Gets and sets the filter hidden files inclusion flag.
Public Property | IncludeParentDirectory | Gets and sets the filter parent directory inclusion flag.
Public Property | IncludeSubDirectory | Gets and sets the filter sub-directory inclusion flag.
Public Property | MatchAppliesToDirectory | Gets and sets the filters match applies to directory flag.
Public Property | Type | Gets and sets access to the filter type.
Top

See Also

Reference

Filter Class
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.ThumbnailXpress4.Net
Filter Class Properties
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : Filter Class

Glossary Item Box

For a list of all members of this type, see Filter members.

Public Properties

 | Name | Description
Public Property | CaseSensitive | Gets and sets an indicator if the filter file name matching case sensitivity is enabled.
Public Property | Comparison | Gets and sets the filter comparison outcome criteria.
Public Property | Enabled | Gets and sets an indicator to enable the filter status.
Public Property | FileDate | Gets and sets the filter file date comparison value.
Public Property | FilenamePattern | Gets and sets the filter filename matching pattern.
Public Property | FileSize | Gets and sets the filter file size comparison value.
Public Property | FilterName | Gets and sets the name of the filter.
Public Property | IncludeHidden | Gets and sets the filter hidden files inclusion flag.
Public Property | IncludeParentDirectory | Gets and sets the filter parent directory inclusion flag.
Public Property | IncludeSubDirectory | Gets and sets the filter sub-directory inclusion flag.
Public Property | MatchAppliesToDirectory | Gets and sets the filters match applies to directory flag.
Public Property | Type | Gets and sets access to the filter type.
Top

See Also

Reference

Filter Class
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
CaseSensitive Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > Filter Class : CaseSensitive Property

Glossary Item Box

Gets and sets an indicator if the filter file name matching case sensitivity is enabled.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property CaseSensitive As Boolean
'Usage

Dim instance As Filter
Dim value As Boolean

instance.CaseSensitive = value

value = instance.CaseSensitive
public bool CaseSensitive {get; set;}
public: __property bool get_CaseSensitive();
public: __property void set_CaseSensitive(
   bool value
);
public:
property bool CaseSensitive {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true if the pattern specified must match in a case sensitive manner. Otherwise, false is used.

Remarks

The default value is false.

This flag is only relevant for a filter type of: Filename.

See Also

Reference

Filter Class
Filter Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Comparison Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > Filter Class : Comparison Property

Glossary Item Box

Gets and sets the filter comparison outcome criteria.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property Comparison As FilterComparison
'Usage

Dim instance As Filter
Dim value As FilterComparison

instance.Comparison = value

value = instance.Comparison
public FilterComparison Comparison {get; set;}
public: __property FilterComparison get_Comparison();
public: __property void set_Comparison(
   FilterComparison value
);
public:
property FilterComparison Comparison {
   FilterComparison get();
   void set (    FilterComparison value);
}

Property Value

A FilterComparison enumeration value which determines the filter comparison outcome criteria.

Remarks

The default value is Equal.

This property is only relevant for filter types of: FileCreationDate, FileModificationDate, or FileSize.

See Also

Reference

Filter Class
Filter Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Enabled Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > Filter Class : Enabled Property

Glossary Item Box

Gets and sets an indicator to enable the filter status.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property Enabled As Boolean
'Usage

Dim instance As Filter
Dim value As Boolean

instance.Enabled = value

value = instance.Enabled
public bool Enabled {get; set;}
public: __property bool get_Enabled();
public: __property void set_Enabled(
   bool value
);
public:
property bool Enabled {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true to enable the filter status. Otherwise, false is used.

Remarks

The default value is true.

See Also

Reference

Filter Class
Filter Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
FileDate Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > Filter Class : FileDate Property

Glossary Item Box

Gets and sets the filter file date comparison value.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property FileDate As Date
'Usage

Dim instance As Filter
Dim value As Date

instance.FileDate = value

value = instance.FileDate
public DateTime FileDate {get; set;}
public: __property DateTime get_FileDate();
public: __property void set_FileDate(
   DateTime value
);
public:
property DateTime FileDate {
   DateTime get();
   void set (    DateTime value);
}

Property Value

A System.DateTime object value.

Remarks

The default value is the current date.

This property is only relevant for filter types of: FileCreationDate or FileModificationDate. Only the year, month and day values present in the DateTime data type are used.

See Also

Reference

Filter Class
Filter Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
FilenamePattern Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > Filter Class : FilenamePattern Property

Glossary Item Box

Gets and sets the filter filename matching pattern.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property FilenamePattern As String
'Usage

Dim instance As Filter
Dim value As String

instance.FilenamePattern = value

value = instance.FilenamePattern
public string FilenamePattern {get; set;}
public: __property string* get_FilenamePattern();
public: __property void set_FilenamePattern(
   string* value
);
public:
property String^ FilenamePattern {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value which represents the filename matching pattern.

Remarks

The default value is an empty string "".

Wildcard characters ? and * may be used in the pattern.

This property is only relevant for a filter type of: Filename.

See Also

Reference

Filter Class
Filter Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
FileSize Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > Filter Class : FileSize Property

Glossary Item Box

Gets and sets the filter file size comparison value.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property FileSize As Integer
'Usage

Dim instance As Filter
Dim value As Integer

instance.FileSize = value

value = instance.FileSize
public int FileSize {get; set;}
public: __property int get_FileSize();
public: __property void set_FileSize(
   int value
);
public:
property int FileSize {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the file size comparison value.

Remarks

The default value is 0.

This property is only relevant for a filter type of: FileSize.

See Also

Reference

Filter Class
Filter Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
FilterName Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > Filter Class : FilterName Property

Glossary Item Box

Gets and sets the name of the filter.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property FilterName As String
'Usage

Dim instance As Filter
Dim value As String

instance.FilterName = value

value = instance.FilterName
public string FilterName {get; set;}
public: __property string* get_FilterName();
public: __property void set_FilterName(
   string* value
);
public:
property String^ FilterName {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value which represents the name of the filter.

See Also

Reference

Filter Class
Filter Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
IncludeHidden Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > Filter Class : IncludeHidden Property

Glossary Item Box

Gets and sets the filter hidden files inclusion flag.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property IncludeHidden As Boolean
'Usage

Dim instance As Filter
Dim value As Boolean

instance.IncludeHidden = value

value = instance.IncludeHidden
public bool IncludeHidden {get; set;}
public: __property bool get_IncludeHidden();
public: __property void set_IncludeHidden(
   bool value
);
public:
property bool IncludeHidden {
   bool get();
   void set (    bool value);
}

Remarks

The default value is false.

This flag is only relevant for a filter type of: FileAttributes.

See Also

Reference

Filter Class
Filter Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
IncludeParentDirectory Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > Filter Class : IncludeParentDirectory Property

Glossary Item Box

Gets and sets the filter parent directory inclusion flag.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property IncludeParentDirectory As Boolean
'Usage

Dim instance As Filter
Dim value As Boolean

instance.IncludeParentDirectory = value

value = instance.IncludeParentDirectory
public bool IncludeParentDirectory {get; set;}
public: __property bool get_IncludeParentDirectory();
public: __property void set_IncludeParentDirectory(
   bool value
);
public:
property bool IncludeParentDirectory {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true to include the parent directory. Otherwise, false is used.

Remarks

The default value is false.

This flag is only relevant for a filter type of: FileAttributes.

See Also

Reference

Filter Class
Filter Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
IncludeSubDirectory Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > Filter Class : IncludeSubDirectory Property

Glossary Item Box

Gets and sets the filter sub-directory inclusion flag.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property IncludeSubDirectory As Boolean
'Usage

Dim instance As Filter
Dim value As Boolean

instance.IncludeSubDirectory = value

value = instance.IncludeSubDirectory
public bool IncludeSubDirectory {get; set;}
public: __property bool get_IncludeSubDirectory();
public: __property void set_IncludeSubDirectory(
   bool value
);
public:
property bool IncludeSubDirectory {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true to include the sub-directory. Otherwise, false is used.

Remarks

The default value is true.

This flag is only relevant for a filter type of: FileAttributes.

See Also

Reference

Filter Class
Filter Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
MatchAppliesToDirectory Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > Filter Class : MatchAppliesToDirectory Property

Glossary Item Box

Gets and sets the filters match applies to directory flag.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property MatchAppliesToDirectory As Boolean
'Usage

Dim instance As Filter
Dim value As Boolean

instance.MatchAppliesToDirectory = value

value = instance.MatchAppliesToDirectory
public bool MatchAppliesToDirectory {get; set;}
public: __property bool get_MatchAppliesToDirectory();
public: __property void set_MatchAppliesToDirectory(
   bool value
);
public:
property bool MatchAppliesToDirectory {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true to include a directory. Otherwise, false is used.

Remarks

The default value is false.

This flag is only relevant for a filter type of: Filename.

A value of true means that for a directory to be included in the collection, its name must match the pattern criteria specified in the FilenamePattern property.

See Also

Reference

Filter Class
Filter Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Type Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > Filter Class : Type Property

Glossary Item Box

Gets and sets access to the filter type.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property Type As FilterType
'Usage

Dim instance As Filter
Dim value As FilterType

instance.Type = value

value = instance.Type
public FilterType Type {get; set;}
public: __property FilterType get_Type();
public: __property void set_Type(
   FilterType value
);
public:
property FilterType Type {
   FilterType get();
   void set (    FilterType value);
}

Property Value

A FilterType object which determines the filter type.

Remarks

The default value is Filename.

See Also

Reference

Filter Class
Filter Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
FilterCollection Class
Members See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : FilterCollection Class

Glossary Item Box

This class provides access and manipulation functionality for one or more filter objects. Filtering criteria for all enabled filter objects in the collection are applied to all image files that are specified by a ThumbnailItemCollection.AddItemsFromDirectory method call.

Object Model

FilterCollection ClassFilter Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DefaultMemberAttribute("Item")>
Public Class FilterCollection
   Inherits System.Collections.CollectionBase
'Usage

Dim instance As FilterCollection
[DefaultMemberAttribute("Item")]
public class FilterCollection : System.Collections.CollectionBase
[DefaultMemberAttribute("Item")]
public __gc class FilterCollection : public System.Collections.CollectionBase
[DefaultMemberAttribute("Item")]
public ref class FilterCollection : public System.Collections.CollectionBase

Remarks

Filtering criteria for multiple enabled filters are applied in a logical manner such that an image file must meet the criteria of all the filters.

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Accusoft.ThumbnailXpressSdk.FilterCollection

See Also

Reference

FilterCollection Members
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.ThumbnailXpress4.Net
FilterCollection Class Members
See Also Properties Methods Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : FilterCollection Class

Glossary Item Box

The following tables list the members exposed by FilterCollection.

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of filters in the collection.
Public Property | IsFixedSize | Gets an indicator if the collection is a fixed size.
Public Property | IsReadOnly | Gets an indicator if the collection access is read-only.
Public Property | IsSynchronized | Gets an indicator whether synchronized (thread-safe) read-write access to the collection is available.
Public Property | Item | Gets the filter object for the given collection index.
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the collection.
Top

Public Methods

 | Name | Description
Public Method | Add | Adds the provided filter item to the end of the collection.
Public Method | Clear | This method clears all filters out of the collection.
Public Method | Contains | Provides an indication as to whether the collection contains the given filter. The matching criteria is based on the filter name.
Public Method | CopyTo | Copy the collection to an array of Filters.
Public Method | GetEnumerator | Gets an enumerator for traversing the filters collection.
Public Method | IndexOf | Returns the index of the given filter in the collection.
Public Method | Insert | Inserts the provided filter item into the collection at the given index.
Public Method | Remove | Removes the provided filter from the collection.
Public Method | RemoveAt | Removes the filter at the given location in the collection.
Top

See Also

Reference

FilterCollection Class
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.ThumbnailXpress4.Net
FilterCollection Class Methods
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : FilterCollection Class

Glossary Item Box

For a list of all members of this type, see FilterCollection members.

Public Methods

 | Name | Description
Public Method | Add | Adds the provided filter item to the end of the collection.
Public Method | Clear | This method clears all filters out of the collection.
Public Method | Contains | Provides an indication as to whether the collection contains the given filter. The matching criteria is based on the filter name.
Public Method | CopyTo | Copy the collection to an array of Filters.
Public Method | GetEnumerator | Gets an enumerator for traversing the filters collection.
Public Method | IndexOf | Returns the index of the given filter in the collection.
Public Method | Insert | Inserts the provided filter item into the collection at the given index.
Public Method | Remove | Removes the provided filter from the collection.
Public Method | RemoveAt | Removes the filter at the given location in the collection.
Top

See Also

Reference

FilterCollection Class
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Add Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > FilterCollection Class : Add Method

item
An integer which represents the filter to add.

Glossary Item Box

Adds the provided filter item to the end of the collection.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overridable Function Add( _
   ByVal item As Filter _
) As Integer
'Usage

Dim instance As FilterCollection
Dim item As Filter
Dim value As Integer

value = instance.Add(item)
public virtual int Add(
   Filter item
)
public: virtual int Add(
   Filter* item
)
public:
virtual int Add(
   Filter^ item
)

Parameters

item
An integer which represents the filter to add.

Return Value

An integer which represents the new count of total filters.

Remarks

If the filter is enabled, its criteria will be applied against subsequent calls to ThumbnailItemCollection.AddItemsFromDirectory

See Also

Reference

FilterCollection Class
FilterCollection Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Clear Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > FilterCollection Class : Clear Method

Glossary Item Box

This method clears all filters out of the collection.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Shadows Sub Clear()
'Usage

Dim instance As FilterCollection

instance.Clear()
public new void Clear()
public: new void Clear();
public:
new void Clear();

See Also

Reference

FilterCollection Class
FilterCollection Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Contains Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > FilterCollection Class : Contains Method

item
The filter to look for in the collection.

Glossary Item Box

Provides an indication as to whether the collection contains the given filter. The matching criteria is based on the filter name.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overridable Function Contains( _
   ByVal item As Filter _
) As Boolean
'Usage

Dim instance As FilterCollection
Dim item As Filter
Dim value As Boolean

value = instance.Contains(item)
public virtual bool Contains(
   Filter item
)
public: virtual bool Contains(
   Filter* item
)
public:
virtual bool Contains(
   Filter^ item
)

Parameters

item
The filter to look for in the collection.

Return Value

True if the filter exists in the collection; false if not.

See Also

Reference

FilterCollection Class
FilterCollection Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
CopyTo Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > FilterCollection Class : CopyTo Method

array
The destination array.
index
The index in the array in which to start adding the Filters.

Glossary Item Box

Copy the collection to an array of Filters.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overridable Sub CopyTo( _
   ByVal array() As Filter, _
   ByVal index As Integer _
)
'Usage

Dim instance As FilterCollection
Dim array() As Filter
Dim index As Integer

instance.CopyTo(array, index)
public virtual void CopyTo(
   Filter[] array,
   int index
)
public: virtual void CopyTo(
   Filter*[]* array,
   int index
)
public:
virtual void CopyTo(
   array<Filter^>^ array,
   int index
)

Parameters

array
The destination array.
index
The index in the array in which to start adding the Filters.

See Also

Reference

FilterCollection Class
FilterCollection Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
GetEnumerator Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > FilterCollection Class : GetEnumerator Method

Glossary Item Box

Gets an enumerator for traversing the filters collection.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overridable Shadows Function GetEnumerator() As FilterCollectionEnumerator
'Usage

Dim instance As FilterCollection
Dim value As FilterCollectionEnumerator

value = instance.GetEnumerator()
public virtual new FilterCollectionEnumerator GetEnumerator()
public: virtual new FilterCollectionEnumerator* GetEnumerator();
public:
virtual new FilterCollectionEnumerator^ GetEnumerator();

Return Value

An enumerator for traversing the filters collection.

See Also

Reference

FilterCollection Class
FilterCollection Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
IndexOf Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > FilterCollection Class : IndexOf Method

item
An integer which represents the filter item to look for in the collection.

Glossary Item Box

Returns the index of the given filter in the collection.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overridable Function IndexOf( _
   ByVal item As Filter _
) As Integer
'Usage

Dim instance As FilterCollection
Dim item As Filter
Dim value As Integer

value = instance.IndexOf(item)
public virtual int IndexOf(
   Filter item
)
public: virtual int IndexOf(
   Filter* item
)
public:
virtual int IndexOf(
   Filter^ item
)

Parameters

item
An integer which represents the filter item to look for in the collection.

Return Value

The index of the filter item or -1 if not in the collection

Remarks

The matching criteria is based on the filter name.

See Also

Reference

FilterCollection Class
FilterCollection Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Insert Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > FilterCollection Class : Insert Method

collectionIndex
The index position to add the given filter.
item
The Filter to insert into the collection.

Glossary Item Box

Inserts the provided filter item into the collection at the given index.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overridable Sub Insert( _
   ByVal collectionIndex As Integer, _
   ByVal item As Filter _
)
'Usage

Dim instance As FilterCollection
Dim collectionIndex As Integer
Dim item As Filter

instance.Insert(collectionIndex, item)
public virtual void Insert(
   int collectionIndex,
   Filter item
)
public: virtual void Insert(
   int collectionIndex,
   Filter* item
)
public:
virtual void Insert(
   int collectionIndex,
   Filter^ item
)

Parameters

collectionIndex
The index position to add the given filter.
item
The Filter to insert into the collection.

Remarks

If the filter is enabled, its criteria will be applied against subsequent calls to ThumbnailItemCollection.AddItemsFromDirectory

See Also

Reference

FilterCollection Class
FilterCollection Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Remove Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > FilterCollection Class : Remove Method

item
The Filter to remove.

Glossary Item Box

Removes the provided filter from the collection.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overridable Sub Remove( _
   ByVal item As Filter _
)
'Usage

Dim instance As FilterCollection
Dim item As Filter

instance.Remove(item)
public virtual void Remove(
   Filter item
)
public: virtual void Remove(
   Filter* item
)
public:
virtual void Remove(
   Filter^ item
)

Parameters

item
The Filter to remove.

Remarks

The matching criteria is based on the filter name.

If the filter was enabled, it will no longer be applied against subsequent calls to ThumbnailItemCollection.AddItemsFromDirectory

See Also

Reference

FilterCollection Class
FilterCollection Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
RemoveAt Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > FilterCollection Class : RemoveAt Method

collectionIndex
An integer which represents the position of the filter to remove.

Glossary Item Box

Removes the filter at the given location in the collection.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overridable Shadows Sub RemoveAt( _
   ByVal collectionIndex As Integer _
)
'Usage

Dim instance As FilterCollection
Dim collectionIndex As Integer

instance.RemoveAt(collectionIndex)
public virtual new void RemoveAt(
   int collectionIndex
)
public: virtual new void RemoveAt(
   int collectionIndex
)
public:
virtual new void RemoveAt(
   int collectionIndex
)

Parameters

collectionIndex
An integer which represents the position of the filter to remove.

Remarks

If the filter was enabled, its criteria will no longer be applied against subsequent calls to ThumbnailItemCollection.AddItemsFromDirectory

See Also

Reference

FilterCollection Class
FilterCollection Members


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.ThumbnailXpress4.Net
FilterCollection Class Properties
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : FilterCollection Class

Glossary Item Box

For a list of all members of this type, see FilterCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of filters in the collection.
Public Property | IsFixedSize | Gets an indicator if the collection is a fixed size.
Public Property | IsReadOnly | Gets an indicator if the collection access is read-only.
Public Property | IsSynchronized | Gets an indicator whether synchronized (thread-safe) read-write access to the collection is available.
Public Property | Item | Gets the filter object for the given collection index.
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the collection.
Top

See Also

Reference

FilterCollection Class
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Count Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > FilterCollection Class : Count Property

Glossary Item Box

Gets the number of filters in the collection.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Shadows ReadOnly Property Count As Integer
'Usage

Dim instance As FilterCollection
Dim value As Integer

value = instance.Count
public new int Count {get;}
public: __property new int get_Count();
public:
new property int Count {
   int get();
}

Property Value

An integer value which represents the number of filters in the collection.

See Also

Reference

FilterCollection Class
FilterCollection Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
IsFixedSize Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > FilterCollection Class : IsFixedSize Property

Glossary Item Box

Gets an indicator if the collection is a fixed size.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overridable ReadOnly Property IsFixedSize As Boolean
'Usage

Dim instance As FilterCollection
Dim value As Boolean

value = instance.IsFixedSize
public virtual bool IsFixedSize {get;}
public: __property virtual bool get_IsFixedSize();
public:
virtual property bool IsFixedSize {
   bool get();
}

Property Value

A boolean value which is true if the collection is a fixed size. Otherwise, false is returned.

See Also

Reference

FilterCollection Class
FilterCollection Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
IsReadOnly Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > FilterCollection Class : IsReadOnly Property

Glossary Item Box

Gets an indicator if the collection access is read-only.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overridable ReadOnly Property IsReadOnly As Boolean
'Usage

Dim instance As FilterCollection
Dim value As Boolean

value = instance.IsReadOnly
public virtual bool IsReadOnly {get;}
public: __property virtual bool get_IsReadOnly();
public:
virtual property bool IsReadOnly {
   bool get();
}

Property Value

A boolean value which is true if the collection access is read-only. Otherwise, false is returned.

See Also

Reference

FilterCollection Class
FilterCollection Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
IsSynchronized Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > FilterCollection Class : IsSynchronized Property

Glossary Item Box

Gets an indicator whether synchronized (thread-safe) read-write access to the collection is available.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overridable ReadOnly Property IsSynchronized As Boolean
'Usage

Dim instance As FilterCollection
Dim value As Boolean

value = instance.IsSynchronized
public virtual bool IsSynchronized {get;}
public: __property virtual bool get_IsSynchronized();
public:
virtual property bool IsSynchronized {
   bool get();
}

Remarks

Note: This property always returns false.

Use the FilterCollectionEnumerator and its FilterCollectionEnumerator.Lock method to access the FilterCollection in a read-only thread safe manner.

See Also

Reference

FilterCollection Class
FilterCollection Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Item Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > FilterCollection Class : Item Property

collectionIndex

Glossary Item Box

Gets the filter object for the given collection index.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overridable ReadOnly Default Property Item( _
   ByVal collectionIndex As Integer _
) As Filter
'Usage

Dim instance As FilterCollection
Dim collectionIndex As Integer
Dim value As Filter

value = instance.Item(collectionIndex)
public virtual Filter this[
   int collectionIndex
]; {get;}
public: __property virtual Filter* get_Item   int collectionIndex
;
public:
virtual property Filter^ default [int] {
   Filter^ get(int collectionIndex);
}

Parameters

collectionIndex

Property Value

A Filter object.

See Also

Reference

FilterCollection Class
FilterCollection Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
SyncRoot Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > FilterCollection Class : SyncRoot Property

Glossary Item Box

Gets an object that can be used to synchronize access to the collection.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overridable ReadOnly Property SyncRoot As Object
'Usage

Dim instance As FilterCollection
Dim value As Object

value = instance.SyncRoot
public virtual object SyncRoot {get;}
public: __property virtual Object* get_SyncRoot();
public:
virtual property Object^ SyncRoot {
   Object^ get();
}

Property Value

An object that can be used to synchronize access to the System.Collections.ICollection.

See Also

Reference

FilterCollection Class
FilterCollection Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
FilterCollectionEnumerator Class
Members See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : FilterCollectionEnumerator Class

Glossary Item Box

The FilterCollectionEnumerator class provides a lockable IEnumerator interface for the FilterCollection class. When locked, the FilterCollectionEnumerator provides thread-safe read-only access to the FilterCollection.

Object Model

FilterCollectionEnumerator ClassFilter Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Class FilterCollectionEnumerator
'Usage

Dim instance As FilterCollectionEnumerator
public class FilterCollectionEnumerator
public __gc class FilterCollectionEnumerator
public ref class FilterCollectionEnumerator

Inheritance Hierarchy

System.Object
Accusoft.ThumbnailXpressSdk.FilterCollectionEnumerator

See Also

Reference

FilterCollectionEnumerator Members
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.ThumbnailXpress4.Net
FilterCollectionEnumerator Class Members
See Also Properties Methods Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : FilterCollectionEnumerator Class

Glossary Item Box

The following tables list the members exposed by FilterCollectionEnumerator.

Public Properties

 | Name | Description
Public Property | Current | Gets the Filter at the current enumerator position/index.
Top

Public Methods

 | Name | Description
Public Method | Lock | Locks the collection.
Public Method | MoveNext | Moves the collection enumerator position/index by one if not at the end of the collection.
Public Method | Reset | Resets the collection enumerator position/index to before the start of the collection.
Public Method | Unlock | Unlocks the collection.
Top

See Also

Reference

FilterCollectionEnumerator Class
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.ThumbnailXpress4.Net
FilterCollectionEnumerator Class Methods
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : FilterCollectionEnumerator Class

Glossary Item Box

For a list of all members of this type, see FilterCollectionEnumerator members.

Public Methods

 | Name | Description
Public Method | Lock | Locks the collection.
Public Method | MoveNext | Moves the collection enumerator position/index by one if not at the end of the collection.
Public Method | Reset | Resets the collection enumerator position/index to before the start of the collection.
Public Method | Unlock | Unlocks the collection.
Top

See Also

Reference

FilterCollectionEnumerator Class
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Lock Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > FilterCollectionEnumerator Class : Lock Method

Glossary Item Box

Locks the collection.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub Lock()
'Usage

Dim instance As FilterCollectionEnumerator

instance.Lock()
public void Lock()
public: void Lock();
public:
void Lock();

Remarks

The collection must be locked before calling Current, MoveNext, or Reset.

See Also

Reference

FilterCollectionEnumerator Class
FilterCollectionEnumerator Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
MoveNext Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > FilterCollectionEnumerator Class : MoveNext Method

Glossary Item Box

Moves the collection enumerator position/index by one if not at the end of the collection.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function MoveNext() As Boolean
'Usage

Dim instance As FilterCollectionEnumerator
Dim value As Boolean

value = instance.MoveNext()
public bool MoveNext()
public: bool MoveNext();
public:
bool MoveNext();

Return Value

A boolean value which is true if the position is moved. Otherwise, false is returned.

Remarks

The collection must be locked before accessing this method.

See Also

Reference

FilterCollectionEnumerator Class
FilterCollectionEnumerator Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Reset Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > FilterCollectionEnumerator Class : Reset Method

Glossary Item Box

Resets the collection enumerator position/index to before the start of the collection.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub Reset()
'Usage

Dim instance As FilterCollectionEnumerator

instance.Reset()
public void Reset()
public: void Reset();
public:
void Reset();

Remarks

The collection must be locked before accessing this property.

See Also

Reference

FilterCollectionEnumerator Class
FilterCollectionEnumerator Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Unlock Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > FilterCollectionEnumerator Class : Unlock Method

Glossary Item Box

Unlocks the collection.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub Unlock()
'Usage

Dim instance As FilterCollectionEnumerator

instance.Unlock()
public void Unlock()
public: void Unlock();
public:
void Unlock();

See Also

Reference

FilterCollectionEnumerator Class
FilterCollectionEnumerator Members


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.ThumbnailXpress4.Net
FilterCollectionEnumerator Class Properties
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : FilterCollectionEnumerator Class

Glossary Item Box

For a list of all members of this type, see FilterCollectionEnumerator members.

Public Properties

 | Name | Description
Public Property | Current | Gets the Filter at the current enumerator position/index.
Top

See Also

Reference

FilterCollectionEnumerator Class
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Current Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > FilterCollectionEnumerator Class : Current Property

Glossary Item Box

Gets the Filter at the current enumerator position/index.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property Current As Filter
'Usage

Dim instance As FilterCollectionEnumerator
Dim value As Filter

value = instance.Current
public Filter Current {get;}
public: __property Filter* get_Current();
public:
property Filter^ Current {
   Filter^ get();
}

Property Value

Returns the Filter at the current enumerator position/index.

Remarks

Note: The collection must be locked before accessing this property.

Returns the Filter at the current enumerator position/index.

See Also

Reference

FilterCollectionEnumerator Class
FilterCollectionEnumerator Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
InternalAnnotationSearchRule Class
Members See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : InternalAnnotationSearchRule Class

Glossary Item Box

The InternalAnnotationSearchRule class is used to specify the annotation type to be searched for in the TIF or PDF file being thumbnailed by ThumbnailXpress. If such annotations are found then they will be drawn on the thumbnail.

Object Model

InternalAnnotationSearchRule Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Class InternalAnnotationSearchRule
   Inherits AnnotationSearchRule
'Usage

Dim instance As InternalAnnotationSearchRule
public class InternalAnnotationSearchRule : AnnotationSearchRule
public __gc class InternalAnnotationSearchRule : public AnnotationSearchRule
public ref class InternalAnnotationSearchRule : public AnnotationSearchRule

Inheritance Hierarchy

System.Object
Accusoft.ThumbnailXpressSdk.AnnotationSearchRule
Accusoft.ThumbnailXpressSdk.InternalAnnotationSearchRule

See Also

Reference

InternalAnnotationSearchRule Members
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.ThumbnailXpress4.Net
InternalAnnotationSearchRule Class Members
See Also Properties Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : InternalAnnotationSearchRule Class

Glossary Item Box

The following tables list the members exposed by InternalAnnotationSearchRule.

Public Constructors

 | Name | Description
Public Constructor | InternalAnnotationSearchRule Constructor | Constructor of InternalAnnotationSearchRule class.
Top

Public Properties

 | Name | Description
Public Property | AnnotationType | The type of annotation to be searched for internally in a TIFF or PDF file.
Top

See Also

Reference

InternalAnnotationSearchRule Class
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
InternalAnnotationSearchRule Constructor
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > InternalAnnotationSearchRule Class : InternalAnnotationSearchRule Constructor

annotationType
Specifies the annotation type of the internal annotation file.

Glossary Item Box

Constructor of InternalAnnotationSearchRule class.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal annotationType As InternalAnnotationType _
)
'Usage

Dim annotationType As InternalAnnotationType

Dim instance As New InternalAnnotationSearchRule(annotationType)
public InternalAnnotationSearchRule(
   InternalAnnotationType annotationType
)
public: InternalAnnotationSearchRule(
   InternalAnnotationType annotationType
)
public:
InternalAnnotationSearchRule(
   InternalAnnotationType annotationType
)

Parameters

annotationType
Specifies the annotation type of the internal annotation file.

See Also

Reference

InternalAnnotationSearchRule Class
InternalAnnotationSearchRule Members


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.ThumbnailXpress4.Net
InternalAnnotationSearchRule Class Properties
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : InternalAnnotationSearchRule Class

Glossary Item Box

For a list of all members of this type, see InternalAnnotationSearchRule members.

Public Properties

 | Name | Description
Public Property | AnnotationType | The type of annotation to be searched for internally in a TIFF or PDF file.
Top

See Also

Reference

InternalAnnotationSearchRule Class
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
InternalAnnotationSearchRule Constructor
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > InternalAnnotationSearchRule Class : InternalAnnotationSearchRule Constructor

Glossary Item Box

Overload List

Overload | Description
InternalAnnotationSearchRule Constructor | Constructor of InternalAnnotationSearchRule class.

See Also

Reference

InternalAnnotationSearchRule Class
InternalAnnotationSearchRule Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
AnnotationType Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > InternalAnnotationSearchRule Class : AnnotationType Property

Glossary Item Box

The type of annotation to be searched for internally in a TIFF or PDF file.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property AnnotationType As InternalAnnotationType
'Usage

Dim instance As InternalAnnotationSearchRule
Dim value As InternalAnnotationType

value = instance.AnnotationType
public InternalAnnotationType AnnotationType {get;}
public: __property InternalAnnotationType get_AnnotationType();
public:
property InternalAnnotationType AnnotationType {
   InternalAnnotationType get();
}

See Also

Reference

InternalAnnotationSearchRule Class
InternalAnnotationSearchRule Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
ItemCompleteEventArgs Class
Members See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : ItemCompleteEventArgs Class

Glossary Item Box

ItemCompleteEventArgs is the argument information for the ThumbnailXpress.ItemComplete event.

Object Model

ItemCompleteEventArgs Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Class ItemCompleteEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As ItemCompleteEventArgs
public class ItemCompleteEventArgs : System.EventArgs
public __gc class ItemCompleteEventArgs : public System.EventArgs
public ref class ItemCompleteEventArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Accusoft.ThumbnailXpressSdk.ItemCompleteEventArgs

See Also

Reference

ItemCompleteEventArgs Members
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.ThumbnailXpress4.Net
ItemCompleteEventArgs Class Members
See Also Properties Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : ItemCompleteEventArgs Class

Glossary Item Box

The following tables list the members exposed by ItemCompleteEventArgs.

Public Properties

 | Name | Description
Public Property | ItemIndex | Gets and sets the index of the ThumbnailItemCollection member for which the thumbnail image generation has just completed.
Top

See Also

Reference

ItemCompleteEventArgs Class
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.ThumbnailXpress4.Net
ItemCompleteEventArgs Class Properties
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : ItemCompleteEventArgs Class

Glossary Item Box

For a list of all members of this type, see ItemCompleteEventArgs members.

Public Properties

 | Name | Description
Public Property | ItemIndex | Gets and sets the index of the ThumbnailItemCollection member for which the thumbnail image generation has just completed.
Top

See Also

Reference

ItemCompleteEventArgs Class
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
ItemIndex Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ItemCompleteEventArgs Class : ItemIndex Property

Glossary Item Box

Gets and sets the index of the ThumbnailItemCollection member for which the thumbnail image generation has just completed.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property ItemIndex As Integer
'Usage

Dim instance As ItemCompleteEventArgs
Dim value As Integer

instance.ItemIndex = value

value = instance.ItemIndex
public int ItemIndex {get; set;}
public: __property int get_ItemIndex();
public: __property void set_ItemIndex(
   int value
);
public:
property int ItemIndex {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the index of the thumbnail.

Remarks

This index is only valid if there are no additions or deletions to the thumbnail item collection prior to use of this index value.

See Also

Reference

ItemCompleteEventArgs Class
ItemCompleteEventArgs Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Licensing Class
Members See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : Licensing Class

Glossary Item Box

The Licensing class provides ThumbnailXpress licensing methods and properties access.

Object Model

Licensing Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Class Licensing
'Usage

Dim instance As Licensing
public class Licensing
public __gc class Licensing
public ref class Licensing

Inheritance Hierarchy

System.Object
Accusoft.ThumbnailXpressSdk.Licensing

See Also

Reference

Licensing Members
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.ThumbnailXpress4.Net
Licensing Class Members
See Also Properties Methods Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : Licensing Class

Glossary Item Box

The following tables list the members exposed by Licensing.

Public Properties

 | Name | Description
Public Property | EvaluationMode | Gets and sets the licensing trial/evaluation mode behavior.
Top

Public Methods

 | Name | Description
Public Method | AccessPdfXpress3 | This method has been deprecated. Please use AccessPdfXpress4().
Public Method | AccessPdfXpress4 | Finds and loads PDF Xpress v4.x, which is used to thumbnail PDF files.
Public Method | SetIXOEMLicenseKey | Sets the ImagXpress control runtime OEM license key.
Public Method | SetIXSolutionKey | Sets the ImagXpress control runtime license deployment key.
Public Method | SetIXSolutionName | Sets the ImagXpress control runtime license deployment solution name.
Public Method | SetOEMLicenseKey | Sets the ThumbnailXpress control runtime OEM license key.
Public Method | SetSolutionKey | Sets the ThumbnailXpress control runtime license deployment key.
Public Method | SetSolutionName | Sets the ThumbnailXpress control runtime license deployment solution name.
Public Method | UnlockPdfXpressRuntime | Unlocks the license for PDF Xpress at runtime for use in distributed environments.
Top

See Also

Reference

Licensing Class
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.ThumbnailXpress4.Net
Licensing Class Methods
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : Licensing Class

Glossary Item Box

For a list of all members of this type, see Licensing members.

Public Methods

 | Name | Description
Public Method | AccessPdfXpress3 | This method has been deprecated. Please use AccessPdfXpress4().
Public Method | AccessPdfXpress4 | Finds and loads PDF Xpress v4.x, which is used to thumbnail PDF files.
Public Method | SetIXOEMLicenseKey | Sets the ImagXpress control runtime OEM license key.
Public Method | SetIXSolutionKey | Sets the ImagXpress control runtime license deployment key.
Public Method | SetIXSolutionName | Sets the ImagXpress control runtime license deployment solution name.
Public Method | SetOEMLicenseKey | Sets the ThumbnailXpress control runtime OEM license key.
Public Method | SetSolutionKey | Sets the ThumbnailXpress control runtime license deployment key.
Public Method | SetSolutionName | Sets the ThumbnailXpress control runtime license deployment solution name.
Public Method | UnlockPdfXpressRuntime | Unlocks the license for PDF Xpress at runtime for use in distributed environments.
Top

See Also

Reference

Licensing Class
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
AccessPdfXpress3 Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > Licensing Class : AccessPdfXpress3 Method

Glossary Item Box

This method has been deprecated. Please use AccessPdfXpress4().

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<ObsoleteAttribute("This method will be removed in ThumbnailXpress v5")>
Public Sub AccessPdfXpress3()
'Usage

Dim instance As Licensing

instance.AccessPdfXpress3()
[ObsoleteAttribute("This method will be removed in ThumbnailXpress v5")]
public void AccessPdfXpress3()
[ObsoleteAttribute("This method will be removed in ThumbnailXpress v5")]
public: void AccessPdfXpress3();
[ObsoleteAttribute("This method will be removed in ThumbnailXpress v5")]
public:
void AccessPdfXpress3();

See Also

Reference

Licensing Class
Licensing Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
AccessPdfXpress4 Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > Licensing Class : AccessPdfXpress4 Method

Glossary Item Box

Finds and loads PDF Xpress v4.x, which is used to thumbnail PDF files.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub AccessPdfXpress4()
'Usage

Dim instance As Licensing

instance.AccessPdfXpress4()
public void AccessPdfXpress4()
public: void AccessPdfXpress4();
public:
void AccessPdfXpress4();

Remarks

It searches for PDF Xpress using the process described in How the Runtime Locates Assemblies. A partial reference is dynamically loaded and thus only the application directory is searched for the assembly, and no other checking occurs.

See Also

Reference

Licensing Class
Licensing Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
SetIXOEMLicenseKey Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > Licensing Class : SetIXOEMLicenseKey Method

oemKey
The OEM license key for ImagXpress required for OEM licensing.

Glossary Item Box

Sets the ImagXpress control runtime OEM license key.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub SetIXOEMLicenseKey( _
   ByVal oemKey As String _
)
'Usage

Dim instance As Licensing
Dim oemKey As String

instance.SetIXOEMLicenseKey(oemKey)
public void SetIXOEMLicenseKey(
   string oemKey
)
public: void SetIXOEMLicenseKey(
   string* oemKey
)
public:
void SetIXOEMLicenseKey(
   String^ oemKey
)

Parameters

oemKey
The OEM license key for ImagXpress required for OEM licensing.

Remarks

When OEM runtime licenses are purchased, the OEM license key for ImagXpress is provided in the purchase confirmation email.

See Also

Reference

Licensing Class
Licensing Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
SetIXSolutionKey Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > Licensing Class : SetIXSolutionKey Method

key1
Unlock key 1
key2
Unlock key 2
key3
Unlock key 3
key4
Unlock key 4

Glossary Item Box

Sets the ImagXpress control runtime license deployment key.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub SetIXSolutionKey( _
   ByVal key1 As Long, _
   ByVal key2 As Long, _
   ByVal key3 As Long, _
   ByVal key4 As Long _
)
'Usage

Dim instance As Licensing
Dim key1 As Long
Dim key2 As Long
Dim key3 As Long
Dim key4 As Long

instance.SetIXSolutionKey(key1, key2, key3, key4)
public void SetIXSolutionKey(
   long key1,
   long key2,
   long key3,
   long key4
)
public: void SetIXSolutionKey(
   long key1,
   long key2,
   long key3,
   long key4
)
public:
void SetIXSolutionKey(
   int64 key1,
   int64 key2,
   int64 key3,
   int64 key4
)

Parameters

key1
Unlock key 1
key2
Unlock key 2
key3
Unlock key 3
key4
Unlock key 4

Remarks

This is the solution key for ImagXpress required for all runtime licensing. The four integers are provided at the time of purchase of the runtime licenses along with the solution name for ImagXpress, which is set with the SetIXSolutionName method.

See Also

Reference

Licensing Class
Licensing Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
SetIXSolutionName Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > Licensing Class : SetIXSolutionName Method

solutionName
The solution name.

Glossary Item Box

Sets the ImagXpress control runtime license deployment solution name.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub SetIXSolutionName( _
   ByVal solutionName As String _
)
'Usage

Dim instance As Licensing
Dim solutionName As String

instance.SetIXSolutionName(solutionName)
public void SetIXSolutionName(
   string solutionName
)
public: void SetIXSolutionName(
   string* solutionName
)
public:
void SetIXSolutionName(
   String^ solutionName
)

Parameters

solutionName
The solution name.

Remarks

This is the name of the runtime license solution for ImagXpress. The ImagXpress solution name is provided in the purchase confirmation email when runtime licenses are purchased.

See Also

Reference

Licensing Class
Licensing Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
SetOEMLicenseKey Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > Licensing Class : SetOEMLicenseKey Method

oemKey
The OEM license key required for OEM licensing.

Glossary Item Box

Sets the ThumbnailXpress control runtime OEM license key.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub SetOEMLicenseKey( _
   ByVal oemKey As String _
)
'Usage

Dim instance As Licensing
Dim oemKey As String

instance.SetOEMLicenseKey(oemKey)
public void SetOEMLicenseKey(
   string oemKey
)
public: void SetOEMLicenseKey(
   string* oemKey
)
public:
void SetOEMLicenseKey(
   String^ oemKey
)

Parameters

oemKey
The OEM license key required for OEM licensing.

Remarks

When OEM runtime licenses are purchased, the OEM license key is provided in the purchase confirmation email.

See Also

Reference

Licensing Class
Licensing Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
SetSolutionKey Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > Licensing Class : SetSolutionKey Method

key1
Unlock key 1
key2
Unlock key 2
key3
Unlock key 3
key4
Unlock key 4

Glossary Item Box

Sets the ThumbnailXpress control runtime license deployment key.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub SetSolutionKey( _
   ByVal key1 As Long, _
   ByVal key2 As Long, _
   ByVal key3 As Long, _
   ByVal key4 As Long _
)
'Usage

Dim instance As Licensing
Dim key1 As Long
Dim key2 As Long
Dim key3 As Long
Dim key4 As Long

instance.SetSolutionKey(key1, key2, key3, key4)
public void SetSolutionKey(
   long key1,
   long key2,
   long key3,
   long key4
)
public: void SetSolutionKey(
   long key1,
   long key2,
   long key3,
   long key4
)
public:
void SetSolutionKey(
   int64 key1,
   int64 key2,
   int64 key3,
   int64 key4
)

Parameters

key1
Unlock key 1
key2
Unlock key 2
key3
Unlock key 3
key4
Unlock key 4

Remarks

This is the solution key required for all runtime licensing. The four integers are provided at the time of purchase of the runtime licenses along with the solution name, which is set with the SetSolutionName method.

See Also

Reference

Licensing Class
Licensing Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
SetSolutionName Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > Licensing Class : SetSolutionName Method

solutionName
The solution name.

Glossary Item Box

Sets the ThumbnailXpress control runtime license deployment solution name.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub SetSolutionName( _
   ByVal solutionName As String _
)
'Usage

Dim instance As Licensing
Dim solutionName As String

instance.SetSolutionName(solutionName)
public void SetSolutionName(
   string solutionName
)
public: void SetSolutionName(
   string* solutionName
)
public:
void SetSolutionName(
   String^ solutionName
)

Parameters

solutionName
The solution name.

Remarks

This is the name of the runtime license solution. The solution name is provided in the purchase confirmation email when runtime licenses are purchased.

See Also

Reference

Licensing Class
Licensing Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
UnlockPdfXpressRuntime Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > Licensing Class : UnlockPdfXpressRuntime Method

code1
Unlock code 1.
code2
Unlock code 2.
code3
Unlock code 3.
code4
Unlock code 4.

Glossary Item Box

Unlocks the license for PDF Xpress at runtime for use in distributed environments.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function UnlockPdfXpressRuntime( _
   ByVal code1 As Integer, _
   ByVal code2 As Integer, _
   ByVal code3 As Integer, _
   ByVal code4 As Integer _
) As Boolean
'Usage

Dim instance As Licensing
Dim code1 As Integer
Dim code2 As Integer
Dim code3 As Integer
Dim code4 As Integer
Dim value As Boolean

value = instance.UnlockPdfXpressRuntime(code1, code2, code3, code4)
public bool UnlockPdfXpressRuntime(
   int code1,
   int code2,
   int code3,
   int code4
)
public: bool UnlockPdfXpressRuntime(
   int code1,
   int code2,
   int code3,
   int code4
)
public:
bool UnlockPdfXpressRuntime(
   int code1,
   int code2,
   int code3,
   int code4
)

Parameters

code1
Unlock code 1.
code2
Unlock code 2.
code3
Unlock code 3.
code4
Unlock code 4.

Return Value

A boolean value which is true if PDF Xpress runtime license was unlocked. Otherwise, false is returned.

Remarks

The unlock code parameters are provided by Accusoft upon purchase of a PDF Xpress license.

Note: AccessPdfXpress3 or AccessPdfXpress4 must be successfully called before calling UnlockPdfXpressRuntime.

See Also

Reference

Licensing Class
Licensing Members


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.ThumbnailXpress4.Net
Licensing Class Properties
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : Licensing Class

Glossary Item Box

For a list of all members of this type, see Licensing members.

Public Properties

 | Name | Description
Public Property | EvaluationMode | Gets and sets the licensing trial/evaluation mode behavior.
Top

See Also

Reference

Licensing Class
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
EvaluationMode Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > Licensing Class : EvaluationMode Property

Glossary Item Box

Gets and sets the licensing trial/evaluation mode behavior.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property EvaluationMode As EvaluationMode
'Usage

Dim instance As Licensing
Dim value As EvaluationMode

instance.EvaluationMode = value

value = instance.EvaluationMode
public EvaluationMode EvaluationMode {get; set;}
public: __property EvaluationMode get_EvaluationMode();
public: __property void set_EvaluationMode(
   EvaluationMode value
);
public:
property EvaluationMode EvaluationMode {
   EvaluationMode get();
   void set (    EvaluationMode value);
}

Property Value

An EvaluationMode enumeration value.

See Also

Reference

Licensing Class
Licensing Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
LoadFromStreamEventArgs Class
Members See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : LoadFromStreamEventArgs Class

Glossary Item Box

LoadFromStreamEventArgs is the argument information for the ThumbnailXpress.LoadFromStream event.

Object Model

LoadFromStreamEventArgs ClassThumbnailItem Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Class LoadFromStreamEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As LoadFromStreamEventArgs
public class LoadFromStreamEventArgs : System.EventArgs
public __gc class LoadFromStreamEventArgs : public System.EventArgs
public ref class LoadFromStreamEventArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Accusoft.ThumbnailXpressSdk.LoadFromStreamEventArgs

See Also

Reference

LoadFromStreamEventArgs Members
Accusoft.ThumbnailXpressSdk Namespace
Item Property


%%PageItemTitle%% $$Members$$

[image]
Accusoft.ThumbnailXpress4.Net
LoadFromStreamEventArgs Class Members
See Also Properties Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : LoadFromStreamEventArgs Class

Glossary Item Box

The following tables list the members exposed by LoadFromStreamEventArgs.

Public Properties

 | Name | Description
Public Property | Item | Gets the ThumbnailItem object whose image data is to be loaded using a System.IO.Stream.
Top

See Also

Reference

LoadFromStreamEventArgs Class
Accusoft.ThumbnailXpressSdk Namespace
Item Property


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.ThumbnailXpress4.Net
LoadFromStreamEventArgs Class Properties
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : LoadFromStreamEventArgs Class

Glossary Item Box

For a list of all members of this type, see LoadFromStreamEventArgs members.

Public Properties

 | Name | Description
Public Property | Item | Gets the ThumbnailItem object whose image data is to be loaded using a System.IO.Stream.
Top

See Also

Reference

LoadFromStreamEventArgs Class
Accusoft.ThumbnailXpressSdk Namespace
Item Property


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Item Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > LoadFromStreamEventArgs Class : Item Property

Glossary Item Box

Gets the ThumbnailItem object whose image data is to be loaded using a System.IO.Stream.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property Item As ThumbnailItem
'Usage

Dim instance As LoadFromStreamEventArgs
Dim value As ThumbnailItem

value = instance.Item
public ThumbnailItem Item {get;}
public: __property ThumbnailItem* get_Item();
public:
property ThumbnailItem^ Item {
   ThumbnailItem^ get();
}

Property Value

A ThumbnailItem.

Remarks

When handling the event, use the ThumbnailItem.UserTag property to identify the appropriate stream and then use the ThumbnailItem.FromStream method to associate the stream to the item.

See Also

Reference

LoadFromStreamEventArgs Class
LoadFromStreamEventArgs Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
SelectedThumbnailItemCollection Class
Members See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : SelectedThumbnailItemCollection Class

Glossary Item Box

SelectedThumbnailItemCollection class provides selected Thumbnail Item manipulation functionality. The collection provides access to the selected thumbnail items in the list display. Adding or Removing selected items will cause the list display to update if appropriate

Object Model

SelectedThumbnailItemCollection ClassThumbnailItem Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DefaultMemberAttribute("Item")>
Public Class SelectedThumbnailItemCollection
   Inherits System.Collections.CollectionBase
'Usage

Dim instance As SelectedThumbnailItemCollection
[DefaultMemberAttribute("Item")]
public class SelectedThumbnailItemCollection : System.Collections.CollectionBase
[DefaultMemberAttribute("Item")]
public __gc class SelectedThumbnailItemCollection : public System.Collections.CollectionBase
[DefaultMemberAttribute("Item")]
public ref class SelectedThumbnailItemCollection : public System.Collections.CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Accusoft.ThumbnailXpressSdk.SelectedThumbnailItemCollection

See Also

Reference

SelectedThumbnailItemCollection Members
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.ThumbnailXpress4.Net
SelectedThumbnailItemCollection Class Members
See Also Properties Methods Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : SelectedThumbnailItemCollection Class

Glossary Item Box

The following tables list the members exposed by SelectedThumbnailItemCollection.

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Read-only property returning the number of items in the selected item collection.
Public Property | IsFixedSize | Read-only property returning whether the collection is a fixed size.
Public Property | IsReadOnly | Read-only property returning whether the collection access is read-only.
Public Property | IsSynchronized | Read only property returning whether synchronized (thread-safe) read-write access to the Collection is available. Will always return false. Use the SelectedThumbnailItemCollectionEnumerator and its Lock method to access the SelectedThumbnailItemCollection in a read-only thread safe manner.
Public Property | Item | Read-only property returning the thumbnail item object from the given selected item collection index.
Public Property | SyncRoot | Read-only property returning an object that can be used to synchronize access to the collection.
Top

Public Methods

 | Name | Description
Public Method | Add | This method adds a new thumbnail item to the selected item collection. The display is updated if appropriate.
Public Method | Clear | This method clears all thumbnails out of the selected item collection. The display is updated if appropriate.
Public Method | Contains | This method provides an indication as to whether the selected item collection contains the given thumbnail. The matching criteria is based on the filename / page number information.
Public Method | CopyTo | Method to copy the selected item collection to an array of ThumbnailItems.
Public Method | GetEnumerator | This method returns an enumerator for traversing the selected item collection.
Public Method | IndexOf | This method returns the index of the given thumbnail in the selected item collection. The matching criteria is based on the filename / page number information.
Public Method | Insert | This method inserts the provided thumbnail item into the selected item collection at the given index. The display is updated if appropriate.
Public Method | Remove | This method removes the provided thumbnail from the selected item collection. The matching criteria is based on the filename / page number information. The display is updated if appropriate.
Public Method | RemoveAt | This method removes the thumbnail at the given location in the selected item collection. The display is updated if appropriate.
Top

See Also

Reference

SelectedThumbnailItemCollection Class
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.ThumbnailXpress4.Net
SelectedThumbnailItemCollection Class Methods
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : SelectedThumbnailItemCollection Class

Glossary Item Box

For a list of all members of this type, see SelectedThumbnailItemCollection members.

Public Methods

 | Name | Description
Public Method | Add | This method adds a new thumbnail item to the selected item collection. The display is updated if appropriate.
Public Method | Clear | This method clears all thumbnails out of the selected item collection. The display is updated if appropriate.
Public Method | Contains | This method provides an indication as to whether the selected item collection contains the given thumbnail. The matching criteria is based on the filename / page number information.
Public Method | CopyTo | Method to copy the selected item collection to an array of ThumbnailItems.
Public Method | GetEnumerator | This method returns an enumerator for traversing the selected item collection.
Public Method | IndexOf | This method returns the index of the given thumbnail in the selected item collection. The matching criteria is based on the filename / page number information.
Public Method | Insert | This method inserts the provided thumbnail item into the selected item collection at the given index. The display is updated if appropriate.
Public Method | Remove | This method removes the provided thumbnail from the selected item collection. The matching criteria is based on the filename / page number information. The display is updated if appropriate.
Public Method | RemoveAt | This method removes the thumbnail at the given location in the selected item collection. The display is updated if appropriate.
Top

See Also

Reference

SelectedThumbnailItemCollection Class
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Add Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > SelectedThumbnailItemCollection Class : Add Method

item
The thumbnail item to add.

Glossary Item Box

This method adds a new thumbnail item to the selected item collection. The display is updated if appropriate.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overridable Function Add( _
   ByVal item As ThumbnailItem _
) As Integer
'Usage

Dim instance As SelectedThumbnailItemCollection
Dim item As ThumbnailItem
Dim value As Integer

value = instance.Add(item)
public virtual int Add(
   ThumbnailItem item
)
public: virtual int Add(
   ThumbnailItem* item
)
public:
virtual int Add(
   ThumbnailItem^ item
)

Parameters

item
The thumbnail item to add.

Return Value

Returns the new count of total selected thumbnail items.

See Also

Reference

SelectedThumbnailItemCollection Class
SelectedThumbnailItemCollection Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Clear Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > SelectedThumbnailItemCollection Class : Clear Method

Glossary Item Box

This method clears all thumbnails out of the selected item collection. The display is updated if appropriate.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Shadows Sub Clear()
'Usage

Dim instance As SelectedThumbnailItemCollection

instance.Clear()
public new void Clear()
public: new void Clear();
public:
new void Clear();

See Also

Reference

SelectedThumbnailItemCollection Class
SelectedThumbnailItemCollection Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Contains Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > SelectedThumbnailItemCollection Class : Contains Method

item
The thumbnail to look for in the collection.

Glossary Item Box

This method provides an indication as to whether the selected item collection contains the given thumbnail. The matching criteria is based on the filename / page number information.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overridable Function Contains( _
   ByVal item As ThumbnailItem _
) As Boolean
'Usage

Dim instance As SelectedThumbnailItemCollection
Dim item As ThumbnailItem
Dim value As Boolean

value = instance.Contains(item)
public virtual bool Contains(
   ThumbnailItem item
)
public: virtual bool Contains(
   ThumbnailItem* item
)
public:
virtual bool Contains(
   ThumbnailItem^ item
)

Parameters

item
The thumbnail to look for in the collection.

Return Value

True if the thumbnail exists in the selected item collection; false if not.

See Also

Reference

SelectedThumbnailItemCollection Class
SelectedThumbnailItemCollection Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
CopyTo Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > SelectedThumbnailItemCollection Class : CopyTo Method

array
The destination ThumbnailItem array.
index
The index in the array in which to start adding the ThumbnailItems.

Glossary Item Box

Method to copy the selected item collection to an array of ThumbnailItems.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overridable Sub CopyTo( _
   ByVal array() As ThumbnailItem, _
   ByVal index As Integer _
)
'Usage

Dim instance As SelectedThumbnailItemCollection
Dim array() As ThumbnailItem
Dim index As Integer

instance.CopyTo(array, index)
public virtual void CopyTo(
   ThumbnailItem[] array,
   int index
)
public: virtual void CopyTo(
   ThumbnailItem*[]* array,
   int index
)
public:
virtual void CopyTo(
   array<ThumbnailItem^>^ array,
   int index
)

Parameters

array
The destination ThumbnailItem array.
index
The index in the array in which to start adding the ThumbnailItems.

See Also

Reference

SelectedThumbnailItemCollection Class
SelectedThumbnailItemCollection Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
GetEnumerator Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > SelectedThumbnailItemCollection Class : GetEnumerator Method

Glossary Item Box

This method returns an enumerator for traversing the selected item collection.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overridable Shadows Function GetEnumerator() As SelectedThumbnailItemCollectionEnumerator
'Usage

Dim instance As SelectedThumbnailItemCollection
Dim value As SelectedThumbnailItemCollectionEnumerator

value = instance.GetEnumerator()
public virtual new SelectedThumbnailItemCollectionEnumerator GetEnumerator()
public: virtual new SelectedThumbnailItemCollectionEnumerator* GetEnumerator();
public:
virtual new SelectedThumbnailItemCollectionEnumerator^ GetEnumerator();

See Also

Reference

SelectedThumbnailItemCollection Class
SelectedThumbnailItemCollection Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
IndexOf Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > SelectedThumbnailItemCollection Class : IndexOf Method

item
The thumbnail item to look for in the selected item collection.

Glossary Item Box

This method returns the index of the given thumbnail in the selected item collection. The matching criteria is based on the filename / page number information.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overridable Function IndexOf( _
   ByVal item As ThumbnailItem _
) As Integer
'Usage

Dim instance As SelectedThumbnailItemCollection
Dim item As ThumbnailItem
Dim value As Integer

value = instance.IndexOf(item)
public virtual int IndexOf(
   ThumbnailItem item
)
public: virtual int IndexOf(
   ThumbnailItem* item
)
public:
virtual int IndexOf(
   ThumbnailItem^ item
)

Parameters

item
The thumbnail item to look for in the selected item collection.

Return Value

The index of the thumbnail item or -1 if not in the selected item collection.

See Also

Reference

SelectedThumbnailItemCollection Class
SelectedThumbnailItemCollection Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Insert Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > SelectedThumbnailItemCollection Class : Insert Method

collectionIndex
The index position in the selected item collection to add the given thumbnail.
item
The thumbnail to add to the collection.

Glossary Item Box

This method inserts the provided thumbnail item into the selected item collection at the given index. The display is updated if appropriate.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overridable Sub Insert( _
   ByVal collectionIndex As Integer, _
   ByVal item As ThumbnailItem _
)
'Usage

Dim instance As SelectedThumbnailItemCollection
Dim collectionIndex As Integer
Dim item As ThumbnailItem

instance.Insert(collectionIndex, item)
public virtual void Insert(
   int collectionIndex,
   ThumbnailItem item
)
public: virtual void Insert(
   int collectionIndex,
   ThumbnailItem* item
)
public:
virtual void Insert(
   int collectionIndex,
   ThumbnailItem^ item
)

Parameters

collectionIndex
The index position in the selected item collection to add the given thumbnail.
item
The thumbnail to add to the collection.

See Also

Reference

SelectedThumbnailItemCollection Class
SelectedThumbnailItemCollection Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Remove Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > SelectedThumbnailItemCollection Class : Remove Method

item
The thumbnail item to remove.

Glossary Item Box

This method removes the provided thumbnail from the selected item collection. The matching criteria is based on the filename / page number information. The display is updated if appropriate.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overridable Sub Remove( _
   ByVal item As ThumbnailItem _
)
'Usage

Dim instance As SelectedThumbnailItemCollection
Dim item As ThumbnailItem

instance.Remove(item)
public virtual void Remove(
   ThumbnailItem item
)
public: virtual void Remove(
   ThumbnailItem* item
)
public:
virtual void Remove(
   ThumbnailItem^ item
)

Parameters

item
The thumbnail item to remove.

See Also

Reference

SelectedThumbnailItemCollection Class
SelectedThumbnailItemCollection Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
RemoveAt Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > SelectedThumbnailItemCollection Class : RemoveAt Method

collectionIndex
Position in the selected item collection of the thumbnail to remove.

Glossary Item Box

This method removes the thumbnail at the given location in the selected item collection. The display is updated if appropriate.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overridable Shadows Sub RemoveAt( _
   ByVal collectionIndex As Integer _
)
'Usage

Dim instance As SelectedThumbnailItemCollection
Dim collectionIndex As Integer

instance.RemoveAt(collectionIndex)
public virtual new void RemoveAt(
   int collectionIndex
)
public: virtual new void RemoveAt(
   int collectionIndex
)
public:
virtual new void RemoveAt(
   int collectionIndex
)

Parameters

collectionIndex
Position in the selected item collection of the thumbnail to remove.

See Also

Reference

SelectedThumbnailItemCollection Class
SelectedThumbnailItemCollection Members


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.ThumbnailXpress4.Net
SelectedThumbnailItemCollection Class Properties
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : SelectedThumbnailItemCollection Class

Glossary Item Box

For a list of all members of this type, see SelectedThumbnailItemCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Read-only property returning the number of items in the selected item collection.
Public Property | IsFixedSize | Read-only property returning whether the collection is a fixed size.
Public Property | IsReadOnly | Read-only property returning whether the collection access is read-only.
Public Property | IsSynchronized | Read only property returning whether synchronized (thread-safe) read-write access to the Collection is available. Will always return false. Use the SelectedThumbnailItemCollectionEnumerator and its Lock method to access the SelectedThumbnailItemCollection in a read-only thread safe manner.
Public Property | Item | Read-only property returning the thumbnail item object from the given selected item collection index.
Public Property | SyncRoot | Read-only property returning an object that can be used to synchronize access to the collection.
Top

See Also

Reference

SelectedThumbnailItemCollection Class
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Count Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > SelectedThumbnailItemCollection Class : Count Property

Glossary Item Box

Read-only property returning the number of items in the selected item collection.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Shadows ReadOnly Property Count As Integer
'Usage

Dim instance As SelectedThumbnailItemCollection
Dim value As Integer

value = instance.Count
public new int Count {get;}
public: __property new int get_Count();
public:
new property int Count {
   int get();
}

Property Value

The number of elements contained.

See Also

Reference

SelectedThumbnailItemCollection Class
SelectedThumbnailItemCollection Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
IsFixedSize Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > SelectedThumbnailItemCollection Class : IsFixedSize Property

Glossary Item Box

Read-only property returning whether the collection is a fixed size.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overridable ReadOnly Property IsFixedSize As Boolean
'Usage

Dim instance As SelectedThumbnailItemCollection
Dim value As Boolean

value = instance.IsFixedSize
public virtual bool IsFixedSize {get;}
public: __property virtual bool get_IsFixedSize();
public:
virtual property bool IsFixedSize {
   bool get();
}

See Also

Reference

SelectedThumbnailItemCollection Class
SelectedThumbnailItemCollection Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
IsReadOnly Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > SelectedThumbnailItemCollection Class : IsReadOnly Property

Glossary Item Box

Read-only property returning whether the collection access is read-only.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overridable ReadOnly Property IsReadOnly As Boolean
'Usage

Dim instance As SelectedThumbnailItemCollection
Dim value As Boolean

value = instance.IsReadOnly
public virtual bool IsReadOnly {get;}
public: __property virtual bool get_IsReadOnly();
public:
virtual property bool IsReadOnly {
   bool get();
}

See Also

Reference

SelectedThumbnailItemCollection Class
SelectedThumbnailItemCollection Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
IsSynchronized Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > SelectedThumbnailItemCollection Class : IsSynchronized Property

Glossary Item Box

Read only property returning whether synchronized (thread-safe) read-write access to the Collection is available. Will always return false. Use the SelectedThumbnailItemCollectionEnumerator and its Lock method to access the SelectedThumbnailItemCollection in a read-only thread safe manner.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overridable ReadOnly Property IsSynchronized As Boolean
'Usage

Dim instance As SelectedThumbnailItemCollection
Dim value As Boolean

value = instance.IsSynchronized
public virtual bool IsSynchronized {get;}
public: __property virtual bool get_IsSynchronized();
public:
virtual property bool IsSynchronized {
   bool get();
}

Property Value

Will always return false

See Also

Reference

SelectedThumbnailItemCollection Class
SelectedThumbnailItemCollection Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Item Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > SelectedThumbnailItemCollection Class : Item Property

collectionIndex

Glossary Item Box

Read-only property returning the thumbnail item object from the given selected item collection index.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overridable ReadOnly Default Property Item( _
   ByVal collectionIndex As Integer _
) As ThumbnailItem
'Usage

Dim instance As SelectedThumbnailItemCollection
Dim collectionIndex As Integer
Dim value As ThumbnailItem

value = instance.Item(collectionIndex)
public virtual ThumbnailItem this[
   int collectionIndex
]; {get;}
public: __property virtual ThumbnailItem* get_Item   int collectionIndex
;
public:
virtual property ThumbnailItem^ default [int] {
   ThumbnailItem^ get(int collectionIndex);
}

Parameters

collectionIndex

See Also

Reference

SelectedThumbnailItemCollection Class
SelectedThumbnailItemCollection Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
SyncRoot Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > SelectedThumbnailItemCollection Class : SyncRoot Property

Glossary Item Box

Read-only property returning an object that can be used to synchronize access to the collection.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overridable ReadOnly Property SyncRoot As Object
'Usage

Dim instance As SelectedThumbnailItemCollection
Dim value As Object

value = instance.SyncRoot
public virtual object SyncRoot {get;}
public: __property virtual Object* get_SyncRoot();
public:
virtual property Object^ SyncRoot {
   Object^ get();
}

Property Value

An object that can be used to synchronize access to the collection.

See Also

Reference

SelectedThumbnailItemCollection Class
SelectedThumbnailItemCollection Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
SelectedThumbnailItemCollectionEnumerator Class
Members See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : SelectedThumbnailItemCollectionEnumerator Class

Glossary Item Box

SelectedThumbnailItemCollectionEnumerator class provides a lockable IEnumerator interface for the SelectedThumbnailItemCollection class.

Object Model

SelectedThumbnailItemCollectionEnumerator ClassThumbnailItem Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Class SelectedThumbnailItemCollectionEnumerator
'Usage

Dim instance As SelectedThumbnailItemCollectionEnumerator
public class SelectedThumbnailItemCollectionEnumerator
public __gc class SelectedThumbnailItemCollectionEnumerator
public ref class SelectedThumbnailItemCollectionEnumerator

Remarks

The default value is false.

When locked, the SelectedThumbnailItemCollectionEnumerator provides thread-safe read-only access to the SelectedThumbnailItemCollection.

Inheritance Hierarchy

System.Object
Accusoft.ThumbnailXpressSdk.SelectedThumbnailItemCollectionEnumerator

See Also

Reference

SelectedThumbnailItemCollectionEnumerator Members
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.ThumbnailXpress4.Net
SelectedThumbnailItemCollectionEnumerator Class Members
See Also Properties Methods Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : SelectedThumbnailItemCollectionEnumerator Class

Glossary Item Box

The following tables list the members exposed by SelectedThumbnailItemCollectionEnumerator.

Public Properties

 | Name | Description
Public Property | Current | Gets the selected ThumbnailItem at the current position within the index.
Top

Public Methods

 | Name | Description
Public Method | Lock | Locks the selected item collection.
Public Method | MoveNext | Advances the selected item collection enumerator position within the index by one if not at the end of the collection.
Public Method | Reset | Resets the selected item collection position within the index to before the start of the collection.
Public Method | Unlock | This method unlocks the selected item collection.
Top

See Also

Reference

SelectedThumbnailItemCollectionEnumerator Class
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.ThumbnailXpress4.Net
SelectedThumbnailItemCollectionEnumerator Class Methods
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : SelectedThumbnailItemCollectionEnumerator Class

Glossary Item Box

For a list of all members of this type, see SelectedThumbnailItemCollectionEnumerator members.

Public Methods

 | Name | Description
Public Method | Lock | Locks the selected item collection.
Public Method | MoveNext | Advances the selected item collection enumerator position within the index by one if not at the end of the collection.
Public Method | Reset | Resets the selected item collection position within the index to before the start of the collection.
Public Method | Unlock | This method unlocks the selected item collection.
Top

See Also

Reference

SelectedThumbnailItemCollectionEnumerator Class
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Lock Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > SelectedThumbnailItemCollectionEnumerator Class : Lock Method

Glossary Item Box

Locks the selected item collection.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub Lock()
'Usage

Dim instance As SelectedThumbnailItemCollectionEnumerator

instance.Lock()
public void Lock()
public: void Lock();
public:
void Lock();

Remarks

The collection must be locked before calling Current, MoveNext, or Reset

See Also

Reference

SelectedThumbnailItemCollectionEnumerator Class
SelectedThumbnailItemCollectionEnumerator Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
MoveNext Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > SelectedThumbnailItemCollectionEnumerator Class : MoveNext Method

Glossary Item Box

Advances the selected item collection enumerator position within the index by one if not at the end of the collection.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function MoveNext() As Boolean
'Usage

Dim instance As SelectedThumbnailItemCollectionEnumerator
Dim value As Boolean

value = instance.MoveNext()
public bool MoveNext()
public: bool MoveNext();
public:
bool MoveNext();

Remarks

Note: The selected item collection must be locked before accessing this method.

See Also

Reference

SelectedThumbnailItemCollectionEnumerator Class
SelectedThumbnailItemCollectionEnumerator Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Reset Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > SelectedThumbnailItemCollectionEnumerator Class : Reset Method

Glossary Item Box

Resets the selected item collection position within the index to before the start of the collection.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub Reset()
'Usage

Dim instance As SelectedThumbnailItemCollectionEnumerator

instance.Reset()
public void Reset()
public: void Reset();
public:
void Reset();

Remarks

Note: The selected item collection must be locked before accessing this property.

See Also

Reference

SelectedThumbnailItemCollectionEnumerator Class
SelectedThumbnailItemCollectionEnumerator Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Unlock Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > SelectedThumbnailItemCollectionEnumerator Class : Unlock Method

Glossary Item Box

This method unlocks the selected item collection.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub Unlock()
'Usage

Dim instance As SelectedThumbnailItemCollectionEnumerator

instance.Unlock()
public void Unlock()
public: void Unlock();
public:
void Unlock();

See Also

Reference

SelectedThumbnailItemCollectionEnumerator Class
SelectedThumbnailItemCollectionEnumerator Members


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.ThumbnailXpress4.Net
SelectedThumbnailItemCollectionEnumerator Class Properties
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : SelectedThumbnailItemCollectionEnumerator Class

Glossary Item Box

For a list of all members of this type, see SelectedThumbnailItemCollectionEnumerator members.

Public Properties

 | Name | Description
Public Property | Current | Gets the selected ThumbnailItem at the current position within the index.
Top

See Also

Reference

SelectedThumbnailItemCollectionEnumerator Class
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Current Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > SelectedThumbnailItemCollectionEnumerator Class : Current Property

Glossary Item Box

Gets the selected ThumbnailItem at the current position within the index.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property Current As ThumbnailItem
'Usage

Dim instance As SelectedThumbnailItemCollectionEnumerator
Dim value As ThumbnailItem

value = instance.Current
public ThumbnailItem Current {get;}
public: __property ThumbnailItem* get_Current();
public:
property ThumbnailItem^ Current {
   ThumbnailItem^ get();
}

Property Value

Returns the selected ThumbnailItem at the current position within the index.

Remarks

Note: The selected item collection must be locked before accessing this property.

See Also

Reference

SelectedThumbnailItemCollectionEnumerator Class
SelectedThumbnailItemCollectionEnumerator Members
ThumbnailItem Class


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
ThumbnailCache Class
Members See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : ThumbnailCache Class

Glossary Item Box

This class exposes to the user properties and methods to access the memory and file caching parameters for ThumbnailXpress.

Object Model

ThumbnailCache Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<ObsoleteAttribute("This class will be removed in ThumbnailXpress v5")>
Public Class ThumbnailCache
'Usage

Dim instance As ThumbnailCache
[ObsoleteAttribute("This class will be removed in ThumbnailXpress v5")]
public class ThumbnailCache
[ObsoleteAttribute("This class will be removed in ThumbnailXpress v5")]
public __gc class ThumbnailCache
[ObsoleteAttribute("This class will be removed in ThumbnailXpress v5")]
public ref class ThumbnailCache

Inheritance Hierarchy

System.Object
Accusoft.ThumbnailXpressSdk.ThumbnailCache

See Also

Reference

ThumbnailCache Members
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.ThumbnailXpress4.Net
ThumbnailCache Class Members
See Also Properties Methods Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : ThumbnailCache Class

Glossary Item Box

The following tables list the members exposed by ThumbnailCache.

Public Properties

 | Name | Description
Public Property | CacheMemoryLimit | Gets or sets the memory cache limit.
Top

Public Methods

 | Name | Description
Public Method | CacheClear | Clears all items from the memory cache.
Top

See Also

Reference

ThumbnailCache Class
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.ThumbnailXpress4.Net
ThumbnailCache Class Methods
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : ThumbnailCache Class

Glossary Item Box

For a list of all members of this type, see ThumbnailCache members.

Public Methods

 | Name | Description
Public Method | CacheClear | Clears all items from the memory cache.
Top

See Also

Reference

ThumbnailCache Class
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
CacheClear Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailCache Class : CacheClear Method

Glossary Item Box

Clears all items from the memory cache.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<ObsoleteAttribute("This method will be removed in ThumbnailXpress v5")>
Public Sub CacheClear()
'Usage

Dim instance As ThumbnailCache

instance.CacheClear()
[ObsoleteAttribute("This method will be removed in ThumbnailXpress v5")]
public void CacheClear()
[ObsoleteAttribute("This method will be removed in ThumbnailXpress v5")]
public: void CacheClear();
[ObsoleteAttribute("This method will be removed in ThumbnailXpress v5")]
public:
void CacheClear();

See Also

Reference

ThumbnailCache Class
ThumbnailCache Members


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.ThumbnailXpress4.Net
ThumbnailCache Class Properties
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : ThumbnailCache Class

Glossary Item Box

For a list of all members of this type, see ThumbnailCache members.

Public Properties

 | Name | Description
Public Property | CacheMemoryLimit | Gets or sets the memory cache limit.
Top

See Also

Reference

ThumbnailCache Class
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
CacheMemoryLimit Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailCache Class : CacheMemoryLimit Property

Glossary Item Box

Gets or sets the memory cache limit.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<ObsoleteAttribute("This property will be removed in ThumbnailXpress v5")>
Public Property CacheMemoryLimit As Integer
'Usage

Dim instance As ThumbnailCache
Dim value As Integer

instance.CacheMemoryLimit = value

value = instance.CacheMemoryLimit
[ObsoleteAttribute("This property will be removed in ThumbnailXpress v5")]
public int CacheMemoryLimit {get; set;}
[ObsoleteAttribute("This property will be removed in ThumbnailXpress v5")]
public: __property int get_CacheMemoryLimit();
public: __property void set_CacheMemoryLimit(
   int value
);
[ObsoleteAttribute("This property will be removed in ThumbnailXpress v5")]
public:
property int CacheMemoryLimit {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the cache memory limit.

See Also

Reference

ThumbnailCache Class
ThumbnailCache Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
ThumbnailItem Class
Members See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : ThumbnailItem Class

Glossary Item Box

The ThumbnailItem class exposes properties for accessing individual thumbnail item data, including image filename, item type, page number, bitmap, page count, and processing status.

Object Model

ThumbnailItem Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Class ThumbnailItem
'Usage

Dim instance As ThumbnailItem
public class ThumbnailItem
public __gc class ThumbnailItem
public ref class ThumbnailItem

Inheritance Hierarchy

System.Object
Accusoft.ThumbnailXpressSdk.ThumbnailItem

See Also

Reference

ThumbnailItem Members
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.ThumbnailXpress4.Net
ThumbnailItem Class Members
See Also Properties Methods Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : ThumbnailItem Class

Glossary Item Box

The following tables list the members exposed by ThumbnailItem.

Public Properties

 | Name | Description
Public Property | AnnotationsFilename | The filename and path of the file used for the thumbnail annotations (this could be the same as the image filename itself if the annotations are internal). If no file was used for annotation data, then this would be String.Empty.
Public Property | Bitmap | Read-only property returning a System.Drawing.Bitmap object of the thumbnail image. Returns null if item is a directory.
Public Property | CadLayoutCount | Read-only property returning the number of layouts contained in a CAD image file represented by the thumbnail item.
Public Property | CadLayoutNumber | Read/Write property accessing the layout number in a CAD image file that the thumbnail item represents.
Public Property | CellBackColor | Gets and sets the background color of the cell.
Public Property | CellBorderColor | Gets and sets the border color of the cell.
Public Property | Descriptor | Read/write property accessing the descriptor text of the thumbnail item.
Public Property | ErrorDescription | Read-only property potentially containing an error descripton string that may be associated with the thumbnail item.
Public Property | ErrorNumber | Read-only property potentially returning an error number that may be associated with the thumbnail item. This value is 0 for no error.
Public Property | ExternalAnnotationType | The exernal annotation type if external annotation data is found, otherwise null.
Public Property | Filename | Read/write property accessing the file name and path or URL of the thumbnail item.
Public Property | HasAnnotations | Indicates if annotations of any type were discovered and used for this thumbnail.
Public Property | Hbitmap | This function is Obsolete, there is no value of calling it. This will be removed in ThumbnailXpress v5.
Public Property | Hdib | This function is Obsolete, there is no value of calling it. This will be removed in ThumbnailXpress v5.
Public Property | InternalAnnotationType | The internal annotation type if internal annotation data is found, otherwise null.
Public Property | MultiPage | Read-only property indicating whether the image file represented by the thumbnail item is a PDF, TIFF, ICO, Modca, or DCX image file that has been determined to contain multiple image pages.
Public Property | Page | Read/Write property accessing the page number in a multi-page image file that the thumbnail item represents.
Public Property | PageCount | Read-only property returning the number of image pages contained in the image file that the thumbnail item represents. Note that only PDF, TIFF, ICO, Modca, or DCX image files are able to have page counts greater than 1.
Public Property | PdfPassword | Read/write property accessing the PDF password of the thumbnail item.
Public Property | PdfRepair | Read/write property accessing the PDF repair flag of the thumbnail item.
Public Property | Status | Read-only property returning the status of the thumbnail item.
Public Property | Type | Read-only property returning the image type or directory folder type of the thumbnail item.
Public Property | UserTag | Read/Write property accessing an object that contains additional or associated data for this object.
Top

Public Methods

 | Name | Description
Public Method | CopyTo | Designed to make passing image data between different Accusoft components easier, this method makes a copy of this object's image data and gives the new image data to another object which can be defined in a different Accusoft assembly. When finished, both this object and the destination object will contain separate copies of the same image data.
Public Method | DisposeHbitmap | Object method for the disposal of device dependent bitmap thumbnail images
Public Method | FromStream | Object method allowing a System.IO.Stream containing image data to be associated with the thumbnail item in place of specifying a filename/path containing the image data.
Public Method | LoadAnnotationsFromStream | Loads annotations from a Stream, which is provided by the method Accusoft.NotateXpressSdk.LayerCollection.SaveToThumbnailAnnotationStream(). Note: NotateXpress is a separate control.
Public Method | ToHbitmap | This returns a handle to a device dependent bitmap copy of the thumbnail image. Returns null if item is a directory.
Public Method | ToHdib | This returns a handle to a device independent bitmap copy of the thumbnail image. Returns null if item is a directory.
Public Method | ToString | Overridden object method returning a string value for the thumbnail item in the format of "ThumbnailItem[ item.Filename : item.PageNum ]"
Public Method | TransferTo | Designed to make passing image data between different Accusoft components easier, this method transfers this object's image data to another object which can be defined in a different Accusoft assembly. When finished, this object will no longer contain image data; the image data will be owned by the destination object.
Top

See Also

Reference

ThumbnailItem Class
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.ThumbnailXpress4.Net
ThumbnailItem Class Methods
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : ThumbnailItem Class

Glossary Item Box

For a list of all members of this type, see ThumbnailItem members.

Public Methods

 | Name | Description
Public Method | CopyTo | Designed to make passing image data between different Accusoft components easier, this method makes a copy of this object's image data and gives the new image data to another object which can be defined in a different Accusoft assembly. When finished, both this object and the destination object will contain separate copies of the same image data.
Public Method | DisposeHbitmap | Object method for the disposal of device dependent bitmap thumbnail images
Public Method | FromStream | Object method allowing a System.IO.Stream containing image data to be associated with the thumbnail item in place of specifying a filename/path containing the image data.
Public Method | LoadAnnotationsFromStream | Loads annotations from a Stream, which is provided by the method Accusoft.NotateXpressSdk.LayerCollection.SaveToThumbnailAnnotationStream(). Note: NotateXpress is a separate control.
Public Method | ToHbitmap | This returns a handle to a device dependent bitmap copy of the thumbnail image. Returns null if item is a directory.
Public Method | ToHdib | This returns a handle to a device independent bitmap copy of the thumbnail image. Returns null if item is a directory.
Public Method | ToString | Overridden object method returning a string value for the thumbnail item in the format of "ThumbnailItem[ item.Filename : item.PageNum ]"
Public Method | TransferTo | Designed to make passing image data between different Accusoft components easier, this method transfers this object's image data to another object which can be defined in a different Accusoft assembly. When finished, this object will no longer contain image data; the image data will be owned by the destination object.
Top

See Also

Reference

ThumbnailItem Class
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
CopyTo Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailItem Class : CopyTo Method

Destination
The destination object.

Glossary Item Box

Designed to make passing image data between different Accusoft components easier, this method makes a copy of this object's image data and gives the new image data to another object which can be defined in a different Accusoft assembly. When finished, both this object and the destination object will contain separate copies of the same image data.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub CopyTo( _
   ByVal Destination As Object _
)
'Usage

Dim instance As ThumbnailItem
Dim Destination As Object

instance.CopyTo(Destination)
public void CopyTo(
   object Destination
)
public: void CopyTo(
   Object* Destination
)
public:
void CopyTo(
   Object^ Destination
)

Parameters

Destination
The destination object.

Exceptions

Exception | Description
System.ArgumentException | Thrown when the destination object does not support being copied to.

Remarks

Not all object types are valid destinations for this method. Refer to the documentation of a particular class to see if it officially supports being the destination of a CopyTo method.

See Also

Reference

ThumbnailItem Class
ThumbnailItem Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
DisposeHbitmap Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailItem Class : DisposeHbitmap Method

hbitmap
Handle to a device dependent bitmap obtained through Hbitmap.

Glossary Item Box

Object method for the disposal of device dependent bitmap thumbnail images

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub DisposeHbitmap( _
   ByVal hbitmap As IntPtr _
)
'Usage

Dim instance As ThumbnailItem
Dim hbitmap As IntPtr

instance.DisposeHbitmap(hbitmap)
public void DisposeHbitmap(
   IntPtr hbitmap
)
public: void DisposeHbitmap(
   IntPtr hbitmap
)
public:
void DisposeHbitmap(
   IntPtr hbitmap
)

Parameters

hbitmap
Handle to a device dependent bitmap obtained through Hbitmap.

Remarks

This helper function is provided so that the developer can free all resources associated with an Hbitmap that was obtained through Hbitmap. After disposal the HBitmap handle is invalid and must not be used again.

See Also

Reference

ThumbnailItem Class
ThumbnailItem Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
FromStream Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailItem Class : FromStream Method

stream
System.IO.Stream containing caller supplied image data.

Glossary Item Box

Object method allowing a System.IO.Stream containing image data to be associated with the thumbnail item in place of specifying a filename/path containing the image data.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub FromStream( _
   ByVal stream As Stream _
)
'Usage

Dim instance As ThumbnailItem
Dim stream As Stream

instance.FromStream(stream)
public void FromStream(
   Stream stream
)
public: void FromStream(
   Stream* stream
)
public:
void FromStream(
   Stream^ stream
)

Parameters

stream
System.IO.Stream containing caller supplied image data.

Remarks

This method must be called during the processing of the ThumbnailXpressEvents.EventType.LoadFromStream event and may optionally be called before the thumbnail item is first added to the ThumbnailItemCollection thru the ThumbnailItemCollection.AddItemFromStream or ThumbnailItemCollection.InsertItemFromStream methods

See Also

Reference

ThumbnailItem Class
ThumbnailItem Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
LoadAnnotationsFromStream Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailItem Class : LoadAnnotationsFromStream Method

stream
The stream of annotation data.

Glossary Item Box

Loads annotations from a Stream, which is provided by the method Accusoft.NotateXpressSdk.LayerCollection.SaveToThumbnailAnnotationStream(). Note: NotateXpress is a separate control.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub LoadAnnotationsFromStream( _
   ByVal stream As Stream _
)
'Usage

Dim instance As ThumbnailItem
Dim stream As Stream

instance.LoadAnnotationsFromStream(stream)
public void LoadAnnotationsFromStream(
   Stream stream
)
public: void LoadAnnotationsFromStream(
   Stream* stream
)
public:
void LoadAnnotationsFromStream(
   Stream^ stream
)

Parameters

stream
The stream of annotation data.

See Also

Reference

ThumbnailItem Class
ThumbnailItem Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
ToHbitmap Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailItem Class : ToHbitmap Method

Glossary Item Box

This returns a handle to a device dependent bitmap copy of the thumbnail image. Returns null if item is a directory.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function ToHbitmap() As IntPtr
'Usage

Dim instance As ThumbnailItem
Dim value As IntPtr

value = instance.ToHbitmap()
public IntPtr ToHbitmap()
public: IntPtr ToHbitmap();
public:
IntPtr ToHbitmap();

Return Value

The HBitmap.

Remarks

A device dependent bitmap is also referred to as a GDI bitmap in some documentation sources.

It is the caller's responsibility to free the HBitmap. The member function DisposeHbitmap has been provided for this purpose

Attempting to access this method for an item whose image is currently being generated due to the item having been added to or inserted into the ThumbnailItemCollection will invoke an System.InvalidOperationException. In this situation, use the ThumbnailXpressEvents.ItemCompleteEventHandler event to determine when an item's image has completed being generated before attempting to access its image data.

See Also

Reference

ThumbnailItem Class
ThumbnailItem Members
ToHdib(ToHdibMethod) Method
Bitmap Property


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
ToHdib Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailItem Class : ToHdib Method

Glossary Item Box

This returns a handle to a device independent bitmap copy of the thumbnail image. Returns null if item is a directory.

Overload List

Overload | Description
ToHdib | This returns a handle to a device independent bitmap copy of the thumbnail image. Returns null if item is a directory.

See Also

Reference

ThumbnailItem Class
ThumbnailItem Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
ToHdib(ToHdibMethod) Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailItem Class : ToHdib(ToHdibMethod) Method

method
The method used to return the DIB.

Glossary Item Box

This returns a handle to a device independent bitmap copy of the thumbnail image. Returns null if item is a directory.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function ToHdib( _
   ByVal method As ToHdibMethod _
) As IntPtr
'Usage

Dim instance As ThumbnailItem
Dim method As ToHdibMethod
Dim value As IntPtr

value = instance.ToHdib(method)
public IntPtr ToHdib(
   ToHdibMethod method
)
public: IntPtr ToHdib(
   ToHdibMethod method
)
public:
IntPtr ToHdib(
   ToHdibMethod method
)

Parameters

method
The method used to return the DIB.

Return Value

The hdib.

Remarks

It is the caller's responsibility to free the hDib.

Attempting to access this method for an item whose image is currently being generated due to the item having been added to or inserted into the ThumbnailItemCollection will invoke an System.InvalidOperationException. In this situation, use the ThumbnailXpressEvents.ItemCompleteEventHandler event to determine when an item's image has completed being generated before attempting to access its image data

See Also

Reference

ThumbnailItem Class
ThumbnailItem Members
Bitmap Property
ToHbitmap Method


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
ToString Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailItem Class : ToString Method

Glossary Item Box

Overridden object method returning a string value for the thumbnail item in the format of "ThumbnailItem[ item.Filename : item.PageNum ]"

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As ThumbnailItem
Dim value As String

value = instance.ToString()
public override string ToString()
public: string* ToString(); override
public:
String^ ToString(); override

Return Value

A System.String that represents the current thumbnail item.

See Also

Reference

ThumbnailItem Class
ThumbnailItem Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
TransferTo Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailItem Class : TransferTo Method

Destination
The desintation object.

Glossary Item Box

Designed to make passing image data between different Accusoft components easier, this method transfers this object's image data to another object which can be defined in a different Accusoft assembly. When finished, this object will no longer contain image data; the image data will be owned by the destination object.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub TransferTo( _
   ByVal Destination As Object _
)
'Usage

Dim instance As ThumbnailItem
Dim Destination As Object

instance.TransferTo(Destination)
public void TransferTo(
   object Destination
)
public: void TransferTo(
   Object* Destination
)
public:
void TransferTo(
   Object^ Destination
)

Parameters

Destination
The desintation object.

Exceptions

Exception | Description
System.ArgumentException | Thrown when the destination object does not support being transferred to.

Remarks

Not all object types are valid destinations for this method. Refer to the documentation of a particular class to see if it officially supports being the destination of a TransferTo method.

See Also

Reference

ThumbnailItem Class
ThumbnailItem Members


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.ThumbnailXpress4.Net
ThumbnailItem Class Properties
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : ThumbnailItem Class

Glossary Item Box

For a list of all members of this type, see ThumbnailItem members.

Public Properties

 | Name | Description
Public Property | AnnotationsFilename | The filename and path of the file used for the thumbnail annotations (this could be the same as the image filename itself if the annotations are internal). If no file was used for annotation data, then this would be String.Empty.
Public Property | Bitmap | Read-only property returning a System.Drawing.Bitmap object of the thumbnail image. Returns null if item is a directory.
Public Property | CadLayoutCount | Read-only property returning the number of layouts contained in a CAD image file represented by the thumbnail item.
Public Property | CadLayoutNumber | Read/Write property accessing the layout number in a CAD image file that the thumbnail item represents.
Public Property | CellBackColor | Gets and sets the background color of the cell.
Public Property | CellBorderColor | Gets and sets the border color of the cell.
Public Property | Descriptor | Read/write property accessing the descriptor text of the thumbnail item.
Public Property | ErrorDescription | Read-only property potentially containing an error descripton string that may be associated with the thumbnail item.
Public Property | ErrorNumber | Read-only property potentially returning an error number that may be associated with the thumbnail item. This value is 0 for no error.
Public Property | ExternalAnnotationType | The exernal annotation type if external annotation data is found, otherwise null.
Public Property | Filename | Read/write property accessing the file name and path or URL of the thumbnail item.
Public Property | HasAnnotations | Indicates if annotations of any type were discovered and used for this thumbnail.
Public Property | Hbitmap | This function is Obsolete, there is no value of calling it. This will be removed in ThumbnailXpress v5.
Public Property | Hdib | This function is Obsolete, there is no value of calling it. This will be removed in ThumbnailXpress v5.
Public Property | InternalAnnotationType | The internal annotation type if internal annotation data is found, otherwise null.
Public Property | MultiPage | Read-only property indicating whether the image file represented by the thumbnail item is a PDF, TIFF, ICO, Modca, or DCX image file that has been determined to contain multiple image pages.
Public Property | Page | Read/Write property accessing the page number in a multi-page image file that the thumbnail item represents.
Public Property | PageCount | Read-only property returning the number of image pages contained in the image file that the thumbnail item represents. Note that only PDF, TIFF, ICO, Modca, or DCX image files are able to have page counts greater than 1.
Public Property | PdfPassword | Read/write property accessing the PDF password of the thumbnail item.
Public Property | PdfRepair | Read/write property accessing the PDF repair flag of the thumbnail item.
Public Property | Status | Read-only property returning the status of the thumbnail item.
Public Property | Type | Read-only property returning the image type or directory folder type of the thumbnail item.
Public Property | UserTag | Read/Write property accessing an object that contains additional or associated data for this object.
Top

See Also

Reference

ThumbnailItem Class
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
AnnotationsFilename Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailItem Class : AnnotationsFilename Property

Glossary Item Box

The filename and path of the file used for the thumbnail annotations (this could be the same as the image filename itself if the annotations are internal). If no file was used for annotation data, then this would be String.Empty.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property AnnotationsFilename As String
'Usage

Dim instance As ThumbnailItem
Dim value As String

value = instance.AnnotationsFilename
public string AnnotationsFilename {get;}
public: __property string* get_AnnotationsFilename();
public:
property String^ AnnotationsFilename {
   String^ get();
}

See Also

Reference

ThumbnailItem Class
ThumbnailItem Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Bitmap Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailItem Class : Bitmap Property

Glossary Item Box

Read-only property returning a System.Drawing.Bitmap object of the thumbnail image. Returns null if item is a directory.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property Bitmap As Bitmap
'Usage

Dim instance As ThumbnailItem
Dim value As Bitmap

value = instance.Bitmap
public Bitmap Bitmap {get;}
public: __property Bitmap* get_Bitmap();
public:
property Bitmap^ Bitmap {
   Bitmap^ get();
}

Property Value

The bitmap.

Remarks

Attempting to access this property for an item whose image is currently being generated due to the item having been added to or inserted into the ThumbnailItemCollection will invoke an System.InvalidOperationException. In this situation, use the ThumbnailXpressEvents.ItemCompleteEventHandler event to determine when an item's image has completed being generated before attempting to access its image data

See Also

Reference

ThumbnailItem Class
ThumbnailItem Members
ToHdib(ToHdibMethod) Method
ToHbitmap Method


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
CadLayoutCount Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailItem Class : CadLayoutCount Property

Glossary Item Box

Read-only property returning the number of layouts contained in a CAD image file represented by the thumbnail item.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property CadLayoutCount As Integer
'Usage

Dim instance As ThumbnailItem
Dim value As Integer

value = instance.CadLayoutCount
public int CadLayoutCount {get;}
public: __property int get_CadLayoutCount();
public:
property int CadLayoutCount {
   int get();
}

Property Value

The cad layout count.

Remarks

A layout count of 0 means the item is not of type ThumbnailType.Cad.

See Also

Reference

ThumbnailItem Class
ThumbnailItem Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
CadLayoutNumber Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailItem Class : CadLayoutNumber Property

Glossary Item Box

Read/Write property accessing the layout number in a CAD image file that the thumbnail item represents.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property CadLayoutNumber As Integer
'Usage

Dim instance As ThumbnailItem
Dim value As Integer

instance.CadLayoutNumber = value

value = instance.CadLayoutNumber
public int CadLayoutNumber {get; set;}
public: __property int get_CadLayoutNumber();
public: __property void set_CadLayoutNumber(
   int value
);
public:
property int CadLayoutNumber {
   int get();
   void set (    int value);
}

Property Value

The cad layout number.

Remarks

Attempting to access the layout number for an item that is not of ThumbnailType.Cad invokes an System.InvalidOperationException. A layout number equal to zero denotes the default layout for the CAD image file

See Also

Reference

ThumbnailItem Class
ThumbnailItem Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
CellBackColor Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailItem Class : CellBackColor Property

Glossary Item Box

Gets and sets the background color of the cell.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property CellBackColor As Color
'Usage

Dim instance As ThumbnailItem
Dim value As Color

instance.CellBackColor = value

value = instance.CellBackColor
public Color CellBackColor {get; set;}
public: __property Color get_CellBackColor();
public: __property void set_CellBackColor(
   Color value
);
public:
property Color CellBackColor {
   Color get();
   void set (    Color value);
}

Property Value

A System.Drawing.Color value which represents the background color of the cell.

See Also

Reference

ThumbnailItem Class
ThumbnailItem Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
CellBorderColor Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailItem Class : CellBorderColor Property

Glossary Item Box

Gets and sets the border color of the cell.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property CellBorderColor As Color
'Usage

Dim instance As ThumbnailItem
Dim value As Color

instance.CellBorderColor = value

value = instance.CellBorderColor
public Color CellBorderColor {get; set;}
public: __property Color get_CellBorderColor();
public: __property void set_CellBorderColor(
   Color value
);
public:
property Color CellBorderColor {
   Color get();
   void set (    Color value);
}

Property Value

A System.Drawing.Color value which represents the border color of the cell.

See Also

Reference

ThumbnailItem Class
ThumbnailItem Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Descriptor Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailItem Class : Descriptor Property

Glossary Item Box

Read/write property accessing the descriptor text of the thumbnail item.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property Descriptor As String
'Usage

Dim instance As ThumbnailItem
Dim value As String

instance.Descriptor = value

value = instance.Descriptor
public string Descriptor {get; set;}
public: __property string* get_Descriptor();
public: __property void set_Descriptor(
   string* value
);
public:
property String^ Descriptor {
   String^ get();
   void set (    String^ value);
}

Property Value

The descriptor.

Remarks

Items of type ThumbnailType.Cad will automatically have the descriptor text set to the CAD layout name when the thumbnail image is generated if no descriptor text was specified by the user.

See Also

Reference

ThumbnailItem Class
ThumbnailItem Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
ErrorDescription Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailItem Class : ErrorDescription Property

Glossary Item Box

Read-only property potentially containing an error descripton string that may be associated with the thumbnail item.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property ErrorDescription As String
'Usage

Dim instance As ThumbnailItem
Dim value As String

value = instance.ErrorDescription
public string ErrorDescription {get;}
public: __property string* get_ErrorDescription();
public:
property String^ ErrorDescription {
   String^ get();
}

Property Value

The error description.

See Also

Reference

ThumbnailItem Class
ThumbnailItem Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
ErrorNumber Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailItem Class : ErrorNumber Property

Glossary Item Box

Read-only property potentially returning an error number that may be associated with the thumbnail item. This value is 0 for no error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property ErrorNumber As Integer
'Usage

Dim instance As ThumbnailItem
Dim value As Integer

value = instance.ErrorNumber
public int ErrorNumber {get;}
public: __property int get_ErrorNumber();
public:
property int ErrorNumber {
   int get();
}

Property Value

The error number.

See Also

Reference

ThumbnailItem Class
ThumbnailItem Members
How To Debug


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
ExternalAnnotationType Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailItem Class : ExternalAnnotationType Property

Glossary Item Box

The exernal annotation type if external annotation data is found, otherwise null.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property ExternalAnnotationType As Nullable(Of ExternalAnnotationType)
'Usage

Dim instance As ThumbnailItem
Dim value As Nullable(Of ExternalAnnotationType)

value = instance.ExternalAnnotationType
public Nullable<ExternalAnnotationType> ExternalAnnotationType {get;}
public: __property Nullable<ExternalAnnotationType> get_ExternalAnnotationType();
public:
property Nullable<ExternalAnnotationType> ExternalAnnotationType {
   Nullable<ExternalAnnotationType> get();
}

See Also

Reference

ThumbnailItem Class
ThumbnailItem Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Filename Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailItem Class : Filename Property

Glossary Item Box

Read/write property accessing the file name and path or URL of the thumbnail item.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property Filename As String
'Usage

Dim instance As ThumbnailItem
Dim value As String

instance.Filename = value

value = instance.Filename
public string Filename {get; set;}
public: __property string* get_Filename();
public: __property void set_Filename(
   string* value
);
public:
property String^ Filename {
   String^ get();
   void set (    String^ value);
}

Property Value

The filename.

Remarks

Changing the file name for an item that is resident in the ThumbnailItemCollection will cause a new image to be generated for the item and the display to be updated if appropriate.

Attempting to change the filename for an item that is currently being generated, that is having a Status of ThumbnailStatus.BeingGenerated will invoke an System.InvalidOperationException

See Also

Reference

ThumbnailItem Class
ThumbnailItem Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
HasAnnotations Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailItem Class : HasAnnotations Property

Glossary Item Box

Indicates if annotations of any type were discovered and used for this thumbnail.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property HasAnnotations As Boolean
'Usage

Dim instance As ThumbnailItem
Dim value As Boolean

value = instance.HasAnnotations
public bool HasAnnotations {get;}
public: __property bool get_HasAnnotations();
public:
property bool HasAnnotations {
   bool get();
}

See Also

Reference

ThumbnailItem Class
ThumbnailItem Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Hbitmap Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailItem Class : Hbitmap Property

Glossary Item Box

This function is Obsolete, there is no value of calling it. This will be removed in ThumbnailXpress v5.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<ObsoleteAttribute("This function will be removed in ThumbnailXpress v5")>
Public ReadOnly Property Hbitmap As IntPtr
'Usage

Dim instance As ThumbnailItem
Dim value As IntPtr

value = instance.Hbitmap
[ObsoleteAttribute("This function will be removed in ThumbnailXpress v5")]
public IntPtr Hbitmap {get;}
[ObsoleteAttribute("This function will be removed in ThumbnailXpress v5")]
public: __property IntPtr get_Hbitmap();
[ObsoleteAttribute("This function will be removed in ThumbnailXpress v5")]
public:
property IntPtr Hbitmap {
   IntPtr get();
}

See Also

Reference

ThumbnailItem Class
ThumbnailItem Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Hdib Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailItem Class : Hdib Property

Glossary Item Box

This function is Obsolete, there is no value of calling it. This will be removed in ThumbnailXpress v5.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<ObsoleteAttribute("This function will be removed in ThumbnailXpress v5")>
Public ReadOnly Property Hdib As IntPtr
'Usage

Dim instance As ThumbnailItem
Dim value As IntPtr

value = instance.Hdib
[ObsoleteAttribute("This function will be removed in ThumbnailXpress v5")]
public IntPtr Hdib {get;}
[ObsoleteAttribute("This function will be removed in ThumbnailXpress v5")]
public: __property IntPtr get_Hdib();
[ObsoleteAttribute("This function will be removed in ThumbnailXpress v5")]
public:
property IntPtr Hdib {
   IntPtr get();
}

See Also

Reference

ThumbnailItem Class
ThumbnailItem Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
InternalAnnotationType Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailItem Class : InternalAnnotationType Property

Glossary Item Box

The internal annotation type if internal annotation data is found, otherwise null.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property InternalAnnotationType As Nullable(Of InternalAnnotationType)
'Usage

Dim instance As ThumbnailItem
Dim value As Nullable(Of InternalAnnotationType)

value = instance.InternalAnnotationType
public Nullable<InternalAnnotationType> InternalAnnotationType {get;}
public: __property Nullable<InternalAnnotationType> get_InternalAnnotationType();
public:
property Nullable<InternalAnnotationType> InternalAnnotationType {
   Nullable<InternalAnnotationType> get();
}

See Also

Reference

ThumbnailItem Class
ThumbnailItem Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
MultiPage Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailItem Class : MultiPage Property

Glossary Item Box

Read-only property indicating whether the image file represented by the thumbnail item is a PDF, TIFF, ICO, Modca, or DCX image file that has been determined to contain multiple image pages.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property MultiPage As Boolean
'Usage

Dim instance As ThumbnailItem
Dim value As Boolean

value = instance.MultiPage
public bool MultiPage {get;}
public: __property bool get_MultiPage();
public:
property bool MultiPage {
   bool get();
}

Property Value

True if MultiPage otherwise, false.

See Also

Reference

ThumbnailItem Class
ThumbnailItem Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Page Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailItem Class : Page Property

Glossary Item Box

Read/Write property accessing the page number in a multi-page image file that the thumbnail item represents.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property Page As Integer
'Usage

Dim instance As ThumbnailItem
Dim value As Integer

instance.Page = value

value = instance.Page
public int Page {get; set;}
public: __property int get_Page();
public: __property void set_Page(
   int value
);
public:
property int Page {
   int get();
   void set (    int value);
}

Property Value

The page.

Remarks

Attempting to set the page number for an item that is a directory invokes an System.InvalidOperationException

The Page property is ignored for internet resident image files and only the first page image of a multi-page image file is generated for these.

See Also

Reference

ThumbnailItem Class
ThumbnailItem Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
PageCount Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailItem Class : PageCount Property

Glossary Item Box

Read-only property returning the number of image pages contained in the image file that the thumbnail item represents. Note that only PDF, TIFF, ICO, Modca, or DCX image files are able to have page counts greater than 1.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property PageCount As Integer
'Usage

Dim instance As ThumbnailItem
Dim value As Integer

value = instance.PageCount
public int PageCount {get;}
public: __property int get_PageCount();
public:
property int PageCount {
   int get();
}

Property Value

The page count.

Remarks

A directory item always reflects a page count value of 0

A page count for multi-page internet resident image files is unable to be determined. The representing thumbnail item(s) for these always reflect a page count value of 1.

See Also

Reference

ThumbnailItem Class
ThumbnailItem Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
PdfPassword Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailItem Class : PdfPassword Property

Glossary Item Box

Read/write property accessing the PDF password of the thumbnail item.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property PdfPassword As String
'Usage

Dim instance As ThumbnailItem
Dim value As String

instance.PdfPassword = value

value = instance.PdfPassword
public string PdfPassword {get; set;}
public: __property string* get_PdfPassword();
public: __property void set_PdfPassword(
   string* value
);
public:
property String^ PdfPassword {
   String^ get();
   void set (    String^ value);
}

Property Value

The PDF password.

Remarks

Changing the PDF password for an item that is resident in the ThumbnailItemCollection will cause a new image to be generated for the item and the display to be updated if appropriate.

Attempting to change the PDF password for an item that is currently being generated, that is having a Status of ThumbnailStatus.BeingGenerated will invoke an System.InvalidOperationException

See Also

Reference

ThumbnailItem Class
ThumbnailItem Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
PdfRepair Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailItem Class : PdfRepair Property

Glossary Item Box

Read/write property accessing the PDF repair flag of the thumbnail item.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property PdfRepair As Boolean
'Usage

Dim instance As ThumbnailItem
Dim value As Boolean

instance.PdfRepair = value

value = instance.PdfRepair
public bool PdfRepair {get; set;}
public: __property bool get_PdfRepair();
public: __property void set_PdfRepair(
   bool value
);
public:
property bool PdfRepair {
   bool get();
   void set (    bool value);
}

Property Value

The PDF repair flag, which is true to repair the PDF file while opening it.

Remarks

Changing the PDF repair flag for an item that is resident in the ThumbnailItemCollection will cause a new image to be generated for the item and the display to be updated, if appropriate.

Attempting to change the PDF repair flag for an item that is currently being generated, that is, having a Status of ThumbnailStatus.BeingGenerated, will invoke an System.InvalidOperationException.

See Also

Reference

ThumbnailItem Class
ThumbnailItem Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Status Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailItem Class : Status Property

Glossary Item Box

Read-only property returning the status of the thumbnail item.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property Status As ThumbnailStatus
'Usage

Dim instance As ThumbnailItem
Dim value As ThumbnailStatus

value = instance.Status
public ThumbnailStatus Status {get;}
public: __property ThumbnailStatus get_Status();
public:
property ThumbnailStatus Status {
   ThumbnailStatus get();
}

Property Value

The status.

See Also

Reference

ThumbnailItem Class
ThumbnailItem Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Type Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailItem Class : Type Property

Glossary Item Box

Read-only property returning the image type or directory folder type of the thumbnail item.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property Type As ThumbnailType
'Usage

Dim instance As ThumbnailItem
Dim value As ThumbnailType

value = instance.Type
public ThumbnailType Type {get;}
public: __property ThumbnailType get_Type();
public:
property ThumbnailType Type {
   ThumbnailType get();
}

Property Value

The Thumbnail Type.

Remarks

A type of ThumbnailType.Internet indicates the image data resides on the internet and a thumbnail image has not yet attempted to be generated for this item. Internet resident files are subject to the following restrictions: Thumbnail images for image resident PDF files cannot be generated by PDF Xpress. The image data type can not be determined until the thumbnail image is attempted to be generated. For multi-page image files, a page count is not determined and the PageCount property value is always set to 1. The Page property value is ignored and only the first page is generated.

See Also

Reference

ThumbnailItem Class
ThumbnailItem Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
UserTag Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailItem Class : UserTag Property

Glossary Item Box

Read/Write property accessing an object that contains additional or associated data for this object.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property UserTag As Object
'Usage

Dim instance As ThumbnailItem
Dim value As Object

instance.UserTag = value

value = instance.UserTag
public object UserTag {get; set;}
public: __property Object* get_UserTag();
public: __property void set_UserTag(
   Object* value
);
public:
property Object^ UserTag {
   Object^ get();
   void set (    Object^ value);
}

Property Value

The user tag.

Remarks

You can assign any System.Object derived type to this property. This component does not access it and you can use it for any purpose you see fit. It is important to note that when adding or inserting items into the ThumbnailItemCollection via a stream that the UserTag value should be used for determining the source of the stream data that you will supply

Valid value: A reference to any object. You can store values, such as integers and strings, in this property using .NET's boxing facility.

Default value: null

See Also

Reference

ThumbnailItem Class
ThumbnailItem Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
ThumbnailItemCollection Class
Members See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : ThumbnailItemCollection Class

Glossary Item Box

ThumbnailItemCollection class provides thumbnail item manipulation and image presentation functionality.

Object Model

ThumbnailItemCollection ClassThumbnailItem Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DefaultMemberAttribute("Item")>
Public Class ThumbnailItemCollection
   Inherits System.Collections.CollectionBase
'Usage

Dim instance As ThumbnailItemCollection
[DefaultMemberAttribute("Item")]
public class ThumbnailItemCollection : System.Collections.CollectionBase
[DefaultMemberAttribute("Item")]
public __gc class ThumbnailItemCollection : public System.Collections.CollectionBase
[DefaultMemberAttribute("Item")]
public ref class ThumbnailItemCollection : public System.Collections.CollectionBase

Remarks

The collection provides the access to the scrollable thumbnail list display. Adding or removing items will cause the list display to update if appropriate.

Thumbnail item images are generated when they are first brought into visible view in the display. The generated images are cached to facilitate a more responsive display. Caching parameters can be configured though the ThumbnailCache object accessed through the ThumbnailXpress.ThumbnailCache property.

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Accusoft.ThumbnailXpressSdk.ThumbnailItemCollection

See Also

Reference

ThumbnailItemCollection Members
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.ThumbnailXpress4.Net
ThumbnailItemCollection Class Members
See Also Properties Methods Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : ThumbnailItemCollection Class

Glossary Item Box

The following tables list the members exposed by ThumbnailItemCollection.

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of items in the collection.
Public Property | IsFixedSize | Read-only property returning whether the collection is a fixed size.
Public Property | IsReadOnly | Read-only property returning whether the collection access is read-only.
Public Property | IsSynchronized | Read only property returning whether synchronized (thread-safe) read-write access to the Collection is available. Will always return false. Use the ThumbnailItemCollectionEnumerator and its Lock method to access the ThumbnailItemCollection in a read-only thread safe manner.
Public Property | Item | Read-only property returning the ThumbnailItem object from the given collection index.
Public Property | SyncRoot | Read-only property returning an object that can be used to synchronize access to the collection.
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded. This method adds the provided ThumbnailItem to the end of the collection. The display is updated if appropriate. This method throws an exception if item is not a directory and item.Filename specifies an invalid, unsupported, or non-existent file.
Public Method | AddItemFromStream | Adds the provided ThumbnailItem to the end of the collection. The display is updated if appropriate. Rather than obtaining its image data from a supplied filename/path, the image data will be expected to be provided by a System.IO.Stream object.
Public Method | AddItemsFromDirectory | Adds thumbnail items to the collection from the provided directory.
Public Method | AddItemsFromFile | Adds a thumbnail item from a single-page image or optionally multiple items (one per page) from a multi-page image to the collection from the provided image file.
Public Method | Clear | This method clears all thumbnails out of the collection. The display is updated.
Public Method | Contains | This method provides an indication as to whether the collection contains the given ThumbnailItem. The matching criteria is based on the filename / page number information.
Public Method | CopyTo | Copy the collection to an array of ThumbnailItems.
Public Method | GetEnumerator | Returns an enumerator for traversing the collection.
Public Method | IndexOf | This method returns the index of the given ThumbnailItem in the collection. The matching criteria is based on the filename / page number information.
Public Method | Insert | Overloaded. This method inserts the provided ThumbnailItem into the collection at the given index. The display is updated if appropriate. This method throws an exception if item is not a directory and item.Filename specifies an invalid, unsupported, or non-existent file.
Public Method | InsertItemFromStream | This method inserts the provided ThumbnailItem into the collection at the given index. The display is updated if appropriate. Rather than obtaining its image data from a supplied filename/path, the image data will be expected to be provided by a System.IO.Stream object.
Public Method | Refresh | This method Refreshes the contents of the thumbnail collection. When the contents of a directory or multi-page image file have changed, Refresh can be used to update the items in the thumbnail collection. Refresh is limited in that it can only be used when a collection is created from a directory or a multi-page image file
Public Method | Remove | This method removes the provided ThumbnailItem from the collection. The matching criteria is based on the filename / page number information. The display is updated if appropriate
Public Method | RemoveAt | This method removes the thumbnail item at the given location in the collection. The display is updated if appropriate
Top

See Also

Reference

ThumbnailItemCollection Class
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.ThumbnailXpress4.Net
ThumbnailItemCollection Class Methods
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : ThumbnailItemCollection Class

Glossary Item Box

For a list of all members of this type, see ThumbnailItemCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. This method adds the provided ThumbnailItem to the end of the collection. The display is updated if appropriate. This method throws an exception if item is not a directory and item.Filename specifies an invalid, unsupported, or non-existent file.
Public Method | AddItemFromStream | Adds the provided ThumbnailItem to the end of the collection. The display is updated if appropriate. Rather than obtaining its image data from a supplied filename/path, the image data will be expected to be provided by a System.IO.Stream object.
Public Method | AddItemsFromDirectory | Adds thumbnail items to the collection from the provided directory.
Public Method | AddItemsFromFile | Adds a thumbnail item from a single-page image or optionally multiple items (one per page) from a multi-page image to the collection from the provided image file.
Public Method | Clear | This method clears all thumbnails out of the collection. The display is updated.
Public Method | Contains | This method provides an indication as to whether the collection contains the given ThumbnailItem. The matching criteria is based on the filename / page number information.
Public Method | CopyTo | Copy the collection to an array of ThumbnailItems.
Public Method | GetEnumerator | Returns an enumerator for traversing the collection.
Public Method | IndexOf | This method returns the index of the given ThumbnailItem in the collection. The matching criteria is based on the filename / page number information.
Public Method | Insert | Overloaded. This method inserts the provided ThumbnailItem into the collection at the given index. The display is updated if appropriate. This method throws an exception if item is not a directory and item.Filename specifies an invalid, unsupported, or non-existent file.
Public Method | InsertItemFromStream | This method inserts the provided ThumbnailItem into the collection at the given index. The display is updated if appropriate. Rather than obtaining its image data from a supplied filename/path, the image data will be expected to be provided by a System.IO.Stream object.
Public Method | Refresh | This method Refreshes the contents of the thumbnail collection. When the contents of a directory or multi-page image file have changed, Refresh can be used to update the items in the thumbnail collection. Refresh is limited in that it can only be used when a collection is created from a directory or a multi-page image file
Public Method | Remove | This method removes the provided ThumbnailItem from the collection. The matching criteria is based on the filename / page number information. The display is updated if appropriate
Public Method | RemoveAt | This method removes the thumbnail item at the given location in the collection. The display is updated if appropriate
Top

See Also

Reference

ThumbnailItemCollection Class
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Add Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailItemCollection Class : Add Method

Glossary Item Box

This method adds the provided ThumbnailItem to the end of the collection. The display is updated if appropriate. This method throws an exception if item is not a directory and item.Filename specifies an invalid, unsupported, or non-existent file.

Overload List

Overload | Description
Add(ThumbnailItem) | This method adds the provided ThumbnailItem to the end of the collection. The display is updated if appropriate. This method throws an exception if item is not a directory and item.Filename specifies an invalid, unsupported, or non-existent file.
Add(ThumbnailItem,Boolean) | This method adds the provided ThumbnailItem to the end of the collection. The display is updated if appropriate. This method throws an exception if item is not a directory and item.Filename specifies an invalid, unsupported, or non-existent file.

See Also

Reference

ThumbnailItemCollection Class
ThumbnailItemCollection Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Add(ThumbnailItem) Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailItemCollection Class > Add Method : Add(ThumbnailItem) Method

item
The thumbnail to add.

Glossary Item Box

This method adds the provided ThumbnailItem to the end of the collection. The display is updated if appropriate. This method throws an exception if item is not a directory and item.Filename specifies an invalid, unsupported, or non-existent file.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Overridable Function Add( _
   ByVal item As ThumbnailItem _
) As Integer
'Usage

Dim instance As ThumbnailItemCollection
Dim item As ThumbnailItem
Dim value As Integer

value = instance.Add(item)
public virtual int Add(
   ThumbnailItem item
)
public: virtual int Add(
   ThumbnailItem* item
)
public:
virtual int Add(
   ThumbnailItem^ item
)

Parameters

item
The thumbnail to add.

Return Value

Returns the new count of total thumbnails.

Remarks

This method does not wait for an image to be generated before returning. The thumbnail image is generated in the background. This means a thumbnail's image data (for example, its bitmap) is likely not available immediately after this method returns. Use the ThumbnailXpress.ItemComplete event to determine when an item's image has completed being generated before attempting to programmatically access its image data

See Also

Reference

ThumbnailItemCollection Class
ThumbnailItemCollection Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Add(ThumbnailItem,Boolean) Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailItemCollection Class > Add Method : Add(ThumbnailItem,Boolean) Method

item
The thumbnail to add.
verify
Validate the file name specified in item.FileName if the item is not a directory. This method throws an exception if item.Filename specifies an invalid, unsupported, or non-existent file.

Glossary Item Box

This method adds the provided ThumbnailItem to the end of the collection. The display is updated if appropriate. This method throws an exception if item is not a directory and item.Filename specifies an invalid, unsupported, or non-existent file.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Function Add( _
   ByVal item As ThumbnailItem, _
   ByVal verify As Boolean _
) As Integer
'Usage

Dim instance As ThumbnailItemCollection
Dim item As ThumbnailItem
Dim verify As Boolean
Dim value As Integer

value = instance.Add(item, verify)
public int Add(
   ThumbnailItem item,
   bool verify
)
public: int Add(
   ThumbnailItem* item,
   bool verify
)
public:
int Add(
   ThumbnailItem^ item,
   bool verify
)

Parameters

item
The thumbnail to add.
verify
Validate the file name specified in item.FileName if the item is not a directory. This method throws an exception if item.Filename specifies an invalid, unsupported, or non-existent file.

Return Value

Returns the new count of total thumbnails.

Remarks

This method does not wait for an image to be generated before returning. The thumbnail image is generated in the background. This means a thumbnail's image data (for example, its bitmap) is likely not available immediately after this method returns. Use the ThumbnailXpress.ItemComplete event to determine when an item's image has completed being generated before attempting to programmatically access its image data

See Also

Reference

ThumbnailItemCollection Class
ThumbnailItemCollection Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
AddItemFromStream Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailItemCollection Class : AddItemFromStream Method

item
The thumbnail to add.

Glossary Item Box

Adds the provided ThumbnailItem to the end of the collection. The display is updated if appropriate. Rather than obtaining its image data from a supplied filename/path, the image data will be expected to be provided by a System.IO.Stream object.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function AddItemFromStream( _
   ByVal item As ThumbnailItem _
) As Integer
'Usage

Dim instance As ThumbnailItemCollection
Dim item As ThumbnailItem
Dim value As Integer

value = instance.AddItemFromStream(item)
public int AddItemFromStream(
   ThumbnailItem item
)
public: int AddItemFromStream(
   ThumbnailItem* item
)
public:
int AddItemFromStream(
   ThumbnailItem^ item
)

Parameters

item
The thumbnail to add.

Return Value

Returns the new count of total thumbnails.

Remarks

The Stream object may optionally be associated with the ThumbnailItem using its ThumbnailItem.FromStream method before AddItemFromStream is called. However, a ThumbnailXpressEvents.LoadFromStreamEventHandler must be supplied by the application and a stream object containing the image data must be supplied during processing of the event handler. Note that the event must be handled because at any time a stream-supplied thumbnail image can be scrolled out of the ThumbnailXpress image chache, and to redisplay, the component needs to re-obtain from the application the image data stream. Additionally, the ThumbnailItem passed to AddItemFromStream must contain a valid ThumbnailItem.UserTag object that allows the application to identify the stream object that will provide the image data for the item.

This method does not wait for images to be generated before returning. The thumbnail images are generated in the background. This means a thumbnail's image data (for example, its bitmap) is likely not available immediately after this method returns. Use the ThumbnailXpress.ItemComplete event to determine when an item's image has completed being generated before attempting to programmatically access its image data

See Also

Reference

ThumbnailItemCollection Class
ThumbnailItemCollection Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
AddItemsFromDirectory Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailItemCollection Class : AddItemsFromDirectory Method

directory
A string value which represents the directory used as the source of the images.
collectionIndex
An integer value which represents the index into the collection where the item should be added. -1 indicates to append to the end of the collection.

Glossary Item Box

Adds thumbnail items to the collection from the provided directory.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function AddItemsFromDirectory( _
   ByVal directory As String, _
   ByVal collectionIndex As Integer _
) As Integer
'Usage

Dim instance As ThumbnailItemCollection
Dim directory As String
Dim collectionIndex As Integer
Dim value As Integer

value = instance.AddItemsFromDirectory(directory, collectionIndex)
public int AddItemsFromDirectory(
   string directory,
   int collectionIndex
)
public: int AddItemsFromDirectory(
   string* directory,
   int collectionIndex
)
public:
int AddItemsFromDirectory(
   String^ directory,
   int collectionIndex
)

Parameters

directory
A string value which represents the directory used as the source of the images.
collectionIndex
An integer value which represents the index into the collection where the item should be added. -1 indicates to append to the end of the collection.

Return Value

An integer which represents the number of images this method added to the collection.

Remarks

Only the first page of multi-page images are added.

This method does not wait for images to be generated before returning. The thumbnail images are generated in the background. This means a thumbnail's image data (for example, its bitmap) is likely not available immediately after this method returns. Use the ThumbnailXpress.ItemComplete event to determine when an item's image has completed being generated before attempting to programmatically access its image data.

Note: When a path is passed to this method without a final trailing slash, the parent of the path is used as the directory.

See Also

Reference

ThumbnailItemCollection Class
ThumbnailItemCollection Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
AddItemsFromFile Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailItemCollection Class : AddItemsFromFile Method

filename
The name and path of the image file. Note that the path may specify an internet address such as "http://www.somesite.com/test.jpg" or "ftp://..../test.jpg" with two limitations. PDF Xpress (if used) cannot access internet resident files and internet resident multi-page files of any type cannot be expanded
collectionIndex
The index into the collection where the item(s) should be added/inserted. -1 indicates to append to the end of the collection.
expandMultiPage
Flag indicating whether to use all pages in a multi-page image or not.

Glossary Item Box

Adds a thumbnail item from a single-page image or optionally multiple items (one per page) from a multi-page image to the collection from the provided image file.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function AddItemsFromFile( _
   ByVal filename As String, _
   ByVal collectionIndex As Integer, _
   ByVal expandMultiPage As Boolean _
) As Integer
'Usage

Dim instance As ThumbnailItemCollection
Dim filename As String
Dim collectionIndex As Integer
Dim expandMultiPage As Boolean
Dim value As Integer

value = instance.AddItemsFromFile(filename, collectionIndex, expandMultiPage)
public int AddItemsFromFile(
   string filename,
   int collectionIndex,
   bool expandMultiPage
)
public: int AddItemsFromFile(
   string* filename,
   int collectionIndex,
   bool expandMultiPage
)
public:
int AddItemsFromFile(
   String^ filename,
   int collectionIndex,
   bool expandMultiPage
)

Parameters

filename
The name and path of the image file. Note that the path may specify an internet address such as "http://www.somesite.com/test.jpg" or "ftp://..../test.jpg" with two limitations. PDF Xpress (if used) cannot access internet resident files and internet resident multi-page files of any type cannot be expanded
collectionIndex
The index into the collection where the item(s) should be added/inserted. -1 indicates to append to the end of the collection.
expandMultiPage
Flag indicating whether to use all pages in a multi-page image or not.

Return Value

The number of items this method added to the collection.

Remarks

This method does not wait for images to be generated before returning. The thumbnail images are generated in the background. This means a thumbnail's image data (for example, its bitmap) is likely not available immediately after this method returns. Use the ThumbnailXpress.ItemComplete event to determine when an item's image has completed being generated before attempting to programmatically access its image data

See Also

Reference

ThumbnailItemCollection Class
ThumbnailItemCollection Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Clear Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailItemCollection Class : Clear Method

Glossary Item Box

This method clears all thumbnails out of the collection. The display is updated.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Shadows Sub Clear()
'Usage

Dim instance As ThumbnailItemCollection

instance.Clear()
public new void Clear()
public: new void Clear();
public:
new void Clear();

See Also

Reference

ThumbnailItemCollection Class
ThumbnailItemCollection Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Contains Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailItemCollection Class : Contains Method

item
The thumbnail to look for in the collection.

Glossary Item Box

This method provides an indication as to whether the collection contains the given ThumbnailItem. The matching criteria is based on the filename / page number information.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overridable Function Contains( _
   ByVal item As ThumbnailItem _
) As Boolean
'Usage

Dim instance As ThumbnailItemCollection
Dim item As ThumbnailItem
Dim value As Boolean

value = instance.Contains(item)
public virtual bool Contains(
   ThumbnailItem item
)
public: virtual bool Contains(
   ThumbnailItem* item
)
public:
virtual bool Contains(
   ThumbnailItem^ item
)

Parameters

item
The thumbnail to look for in the collection.

Return Value

True if the thumbnail exists in the collection; false if not.

See Also

Reference

ThumbnailItemCollection Class
ThumbnailItemCollection Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
CopyTo Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailItemCollection Class : CopyTo Method

array
The destination array.
index
The index in the array in which to start adding the ThumbnailItems.

Glossary Item Box

Copy the collection to an array of ThumbnailItems.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overridable Sub CopyTo( _
   ByVal array() As ThumbnailItem, _
   ByVal index As Integer _
)
'Usage

Dim instance As ThumbnailItemCollection
Dim array() As ThumbnailItem
Dim index As Integer

instance.CopyTo(array, index)
public virtual void CopyTo(
   ThumbnailItem[] array,
   int index
)
public: virtual void CopyTo(
   ThumbnailItem*[]* array,
   int index
)
public:
virtual void CopyTo(
   array<ThumbnailItem^>^ array,
   int index
)

Parameters

array
The destination array.
index
The index in the array in which to start adding the ThumbnailItems.

See Also

Reference

ThumbnailItemCollection Class
ThumbnailItemCollection Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
GetEnumerator Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailItemCollection Class : GetEnumerator Method

Glossary Item Box

Returns an enumerator for traversing the collection.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overridable Shadows Function GetEnumerator() As ThumbnailItemCollectionEnumerator
'Usage

Dim instance As ThumbnailItemCollection
Dim value As ThumbnailItemCollectionEnumerator

value = instance.GetEnumerator()
public virtual new ThumbnailItemCollectionEnumerator GetEnumerator()
public: virtual new ThumbnailItemCollectionEnumerator* GetEnumerator();
public:
virtual new ThumbnailItemCollectionEnumerator^ GetEnumerator();

See Also

Reference

ThumbnailItemCollection Class
ThumbnailItemCollection Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
IndexOf Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailItemCollection Class : IndexOf Method

item
The thumbnail item to look for in the collection.

Glossary Item Box

This method returns the index of the given ThumbnailItem in the collection. The matching criteria is based on the filename / page number information.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overridable Function IndexOf( _
   ByVal item As ThumbnailItem _
) As Integer
'Usage

Dim instance As ThumbnailItemCollection
Dim item As ThumbnailItem
Dim value As Integer

value = instance.IndexOf(item)
public virtual int IndexOf(
   ThumbnailItem item
)
public: virtual int IndexOf(
   ThumbnailItem* item
)
public:
virtual int IndexOf(
   ThumbnailItem^ item
)

Parameters

item
The thumbnail item to look for in the collection.

Return Value

The index of the thumbnail item or -1 if not in the collection

See Also

Reference

ThumbnailItemCollection Class
ThumbnailItemCollection Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Insert Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailItemCollection Class : Insert Method

Glossary Item Box

This method inserts the provided ThumbnailItem into the collection at the given index. The display is updated if appropriate. This method throws an exception if item is not a directory and item.Filename specifies an invalid, unsupported, or non-existent file.

Overload List

Overload | Description
Insert(Int32,ThumbnailItem) | This method inserts the provided ThumbnailItem into the collection at the given index. The display is updated if appropriate. This method throws an exception if item is not a directory and item.Filename specifies an invalid, unsupported, or non-existent file.
Insert(Int32,ThumbnailItem,Boolean) | This method inserts the provided ThumbnailItem into the collection at the given index. The display is updated if appropriate

See Also

Reference

ThumbnailItemCollection Class
ThumbnailItemCollection Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Insert(Int32,ThumbnailItem) Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailItemCollection Class > Insert Method : Insert(Int32,ThumbnailItem) Method

collectionIndex
The index position to add the given thumbnail.
item
The thumbnail to insert into the collection.

Glossary Item Box

This method inserts the provided ThumbnailItem into the collection at the given index. The display is updated if appropriate. This method throws an exception if item is not a directory and item.Filename specifies an invalid, unsupported, or non-existent file.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Overridable Sub Insert( _
   ByVal collectionIndex As Integer, _
   ByVal item As ThumbnailItem _
)
'Usage

Dim instance As ThumbnailItemCollection
Dim collectionIndex As Integer
Dim item As ThumbnailItem

instance.Insert(collectionIndex, item)
public virtual void Insert(
   int collectionIndex,
   ThumbnailItem item
)
public: virtual void Insert(
   int collectionIndex,
   ThumbnailItem* item
)
public:
virtual void Insert(
   int collectionIndex,
   ThumbnailItem^ item
)

Parameters

collectionIndex
The index position to add the given thumbnail.
item
The thumbnail to insert into the collection.

Remarks

This method does not wait for an image to be generated before returning. The thumbnail image is generated in the background. This means a thumbnail's image data (for example, its bitmap) is likely not available immediately after this method returns. Use the ThumbnailXpress.ItemComplete event to determine when an item's image has completed being generated before attempting to programmatically access its image data

See Also

Reference

ThumbnailItemCollection Class
ThumbnailItemCollection Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Insert(Int32,ThumbnailItem,Boolean) Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailItemCollection Class > Insert Method : Insert(Int32,ThumbnailItem,Boolean) Method

collectionIndex
The index position to add the given thumbnail.
item
The thumbnail to insert into the collection.
verify
Validate the file name specified in item.FileName if the item is not a directory. This method throws an exception if item.Filename specifies an invalid, unsupported, or non-existent file.

Glossary Item Box

This method inserts the provided ThumbnailItem into the collection at the given index. The display is updated if appropriate

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Insert( _
   ByVal collectionIndex As Integer, _
   ByVal item As ThumbnailItem, _
   ByVal verify As Boolean _
)
'Usage

Dim instance As ThumbnailItemCollection
Dim collectionIndex As Integer
Dim item As ThumbnailItem
Dim verify As Boolean

instance.Insert(collectionIndex, item, verify)
public void Insert(
   int collectionIndex,
   ThumbnailItem item,
   bool verify
)
public: void Insert(
   int collectionIndex,
   ThumbnailItem* item,
   bool verify
)
public:
void Insert(
   int collectionIndex,
   ThumbnailItem^ item,
   bool verify
)

Parameters

collectionIndex
The index position to add the given thumbnail.
item
The thumbnail to insert into the collection.
verify
Validate the file name specified in item.FileName if the item is not a directory. This method throws an exception if item.Filename specifies an invalid, unsupported, or non-existent file.

Remarks

This method does not wait for an image to be generated before returning. The thumbnail image is generated in the background. This means a thumbnail's image data (for example, its bitmap) is likely not available immediately after this method returns. Use the ThumbnailXpress.ItemComplete event to determine when an item's image has completed being generated before attempting to programmatically access its image data

See Also

Reference

ThumbnailItemCollection Class
ThumbnailItemCollection Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
InsertItemFromStream Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailItemCollection Class : InsertItemFromStream Method

collectionIndex
The index position to add the given thumbnail.
item
The thumbnail to add.

Glossary Item Box

This method inserts the provided ThumbnailItem into the collection at the given index. The display is updated if appropriate. Rather than obtaining its image data from a supplied filename/path, the image data will be expected to be provided by a System.IO.Stream object.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub InsertItemFromStream( _
   ByVal collectionIndex As Integer, _
   ByVal item As ThumbnailItem _
)
'Usage

Dim instance As ThumbnailItemCollection
Dim collectionIndex As Integer
Dim item As ThumbnailItem

instance.InsertItemFromStream(collectionIndex, item)
public void InsertItemFromStream(
   int collectionIndex,
   ThumbnailItem item
)
public: void InsertItemFromStream(
   int collectionIndex,
   ThumbnailItem* item
)
public:
void InsertItemFromStream(
   int collectionIndex,
   ThumbnailItem^ item
)

Parameters

collectionIndex
The index position to add the given thumbnail.
item
The thumbnail to add.

Remarks

The Stream object may optionally be associated with the ThumbnailItem using its ThumbnailItem.FromStream method before InsertItemFromStream is called. However, a ThumbnailXpressEvents.LoadFromStreamEventHandler must be supplied by the application and a stream object containing the image data must be supplied during processing of the event handler. Note that the event must be handled because at any time a stream-supplied thumbnail image can be scrolled out of the ThumbnailXpress image chache, and to redisplay, the component needs to re-obtain from the application the image data stream. Additionally, the ThumbnailItem passed to InsertItemFromStream must contain a valid ThumbnailItem.UserTag object that allows the application to identify the stream object that will provide the image data for the item.

This method does not wait for images to be generated before returning. The thumbnail images are generated in the background. This means a thumbnail's image data (for example, its bitmap) is likely not available immediately after this method returns. Use the ThumbnailXpress.ItemComplete event to determine when an item's image has completed being generated before attempting to programmatically access its image data

See Also

Reference

ThumbnailItemCollection Class
ThumbnailItemCollection Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Refresh Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailItemCollection Class : Refresh Method

Glossary Item Box

This method Refreshes the contents of the thumbnail collection. When the contents of a directory or multi-page image file have changed, Refresh can be used to update the items in the thumbnail collection. Refresh is limited in that it can only be used when a collection is created from a directory or a multi-page image file

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub Refresh()
'Usage

Dim instance As ThumbnailItemCollection

instance.Refresh()
public void Refresh()
public: void Refresh();
public:
void Refresh();

See Also

Reference

ThumbnailItemCollection Class
ThumbnailItemCollection Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Remove Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailItemCollection Class : Remove Method

item
The thumbnail item to remove.

Glossary Item Box

This method removes the provided ThumbnailItem from the collection. The matching criteria is based on the filename / page number information. The display is updated if appropriate

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overridable Sub Remove( _
   ByVal item As ThumbnailItem _
)
'Usage

Dim instance As ThumbnailItemCollection
Dim item As ThumbnailItem

instance.Remove(item)
public virtual void Remove(
   ThumbnailItem item
)
public: virtual void Remove(
   ThumbnailItem* item
)
public:
virtual void Remove(
   ThumbnailItem^ item
)

Parameters

item
The thumbnail item to remove.

See Also

Reference

ThumbnailItemCollection Class
ThumbnailItemCollection Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
RemoveAt Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailItemCollection Class : RemoveAt Method

collectionIndex
Position of the thumbnail to remove.

Glossary Item Box

This method removes the thumbnail item at the given location in the collection. The display is updated if appropriate

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overridable Shadows Sub RemoveAt( _
   ByVal collectionIndex As Integer _
)
'Usage

Dim instance As ThumbnailItemCollection
Dim collectionIndex As Integer

instance.RemoveAt(collectionIndex)
public virtual new void RemoveAt(
   int collectionIndex
)
public: virtual new void RemoveAt(
   int collectionIndex
)
public:
virtual new void RemoveAt(
   int collectionIndex
)

Parameters

collectionIndex
Position of the thumbnail to remove.

See Also

Reference

ThumbnailItemCollection Class
ThumbnailItemCollection Members


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.ThumbnailXpress4.Net
ThumbnailItemCollection Class Properties
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : ThumbnailItemCollection Class

Glossary Item Box

For a list of all members of this type, see ThumbnailItemCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of items in the collection.
Public Property | IsFixedSize | Read-only property returning whether the collection is a fixed size.
Public Property | IsReadOnly | Read-only property returning whether the collection access is read-only.
Public Property | IsSynchronized | Read only property returning whether synchronized (thread-safe) read-write access to the Collection is available. Will always return false. Use the ThumbnailItemCollectionEnumerator and its Lock method to access the ThumbnailItemCollection in a read-only thread safe manner.
Public Property | Item | Read-only property returning the ThumbnailItem object from the given collection index.
Public Property | SyncRoot | Read-only property returning an object that can be used to synchronize access to the collection.
Top

See Also

Reference

ThumbnailItemCollection Class
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Count Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailItemCollection Class : Count Property

Glossary Item Box

Gets the number of items in the collection.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Shadows ReadOnly Property Count As Integer
'Usage

Dim instance As ThumbnailItemCollection
Dim value As Integer

value = instance.Count
public new int Count {get;}
public: __property new int get_Count();
public:
new property int Count {
   int get();
}

Property Value

The number of elements contained in the collection.

See Also

Reference

ThumbnailItemCollection Class
ThumbnailItemCollection Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
IsFixedSize Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailItemCollection Class : IsFixedSize Property

Glossary Item Box

Read-only property returning whether the collection is a fixed size.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overridable ReadOnly Property IsFixedSize As Boolean
'Usage

Dim instance As ThumbnailItemCollection
Dim value As Boolean

value = instance.IsFixedSize
public virtual bool IsFixedSize {get;}
public: __property virtual bool get_IsFixedSize();
public:
virtual property bool IsFixedSize {
   bool get();
}

See Also

Reference

ThumbnailItemCollection Class
ThumbnailItemCollection Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
IsReadOnly Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailItemCollection Class : IsReadOnly Property

Glossary Item Box

Read-only property returning whether the collection access is read-only.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overridable ReadOnly Property IsReadOnly As Boolean
'Usage

Dim instance As ThumbnailItemCollection
Dim value As Boolean

value = instance.IsReadOnly
public virtual bool IsReadOnly {get;}
public: __property virtual bool get_IsReadOnly();
public:
virtual property bool IsReadOnly {
   bool get();
}

See Also

Reference

ThumbnailItemCollection Class
ThumbnailItemCollection Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
IsSynchronized Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailItemCollection Class : IsSynchronized Property

Glossary Item Box

Read only property returning whether synchronized (thread-safe) read-write access to the Collection is available. Will always return false. Use the ThumbnailItemCollectionEnumerator and its Lock method to access the ThumbnailItemCollection in a read-only thread safe manner.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overridable ReadOnly Property IsSynchronized As Boolean
'Usage

Dim instance As ThumbnailItemCollection
Dim value As Boolean

value = instance.IsSynchronized
public virtual bool IsSynchronized {get;}
public: __property virtual bool get_IsSynchronized();
public:
virtual property bool IsSynchronized {
   bool get();
}

See Also

Reference

ThumbnailItemCollection Class
ThumbnailItemCollection Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Item Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailItemCollection Class : Item Property

collectionIndex

Glossary Item Box

Read-only property returning the ThumbnailItem object from the given collection index.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overridable ReadOnly Default Property Item( _
   ByVal collectionIndex As Integer _
) As ThumbnailItem
'Usage

Dim instance As ThumbnailItemCollection
Dim collectionIndex As Integer
Dim value As ThumbnailItem

value = instance.Item(collectionIndex)
public virtual ThumbnailItem this[
   int collectionIndex
]; {get;}
public: __property virtual ThumbnailItem* get_Item   int collectionIndex
;
public:
virtual property ThumbnailItem^ default [int] {
   ThumbnailItem^ get(int collectionIndex);
}

Parameters

collectionIndex

See Also

Reference

ThumbnailItemCollection Class
ThumbnailItemCollection Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
SyncRoot Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailItemCollection Class : SyncRoot Property

Glossary Item Box

Read-only property returning an object that can be used to synchronize access to the collection.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overridable ReadOnly Property SyncRoot As Object
'Usage

Dim instance As ThumbnailItemCollection
Dim value As Object

value = instance.SyncRoot
public virtual object SyncRoot {get;}
public: __property virtual Object* get_SyncRoot();
public:
virtual property Object^ SyncRoot {
   Object^ get();
}

See Also

Reference

ThumbnailItemCollection Class
ThumbnailItemCollection Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
ThumbnailItemCollectionEnumerator Class
Members See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : ThumbnailItemCollectionEnumerator Class

Glossary Item Box

ThumbnailItemCollectionEnumerator class provides a lockable IEnumerator interface for the ThumbnailItemCollection class.

Object Model

ThumbnailItemCollectionEnumerator ClassThumbnailItem Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Class ThumbnailItemCollectionEnumerator
'Usage

Dim instance As ThumbnailItemCollectionEnumerator
public class ThumbnailItemCollectionEnumerator
public __gc class ThumbnailItemCollectionEnumerator
public ref class ThumbnailItemCollectionEnumerator

Remarks

When locked, the ThumbnailItemCollectionEnumerator provides thread-safe read-only access to the ThumbnailItemCollection.

Inheritance Hierarchy

System.Object
Accusoft.ThumbnailXpressSdk.ThumbnailItemCollectionEnumerator

See Also

Reference

ThumbnailItemCollectionEnumerator Members
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.ThumbnailXpress4.Net
ThumbnailItemCollectionEnumerator Class Members
See Also Properties Methods Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : ThumbnailItemCollectionEnumerator Class

Glossary Item Box

The following tables list the members exposed by ThumbnailItemCollectionEnumerator.

Public Properties

 | Name | Description
Public Property | Current | Gets the ThumbnailItem at the current enumerator index.
Top

Public Methods

 | Name | Description
Public Method | Lock | Locks the collection.
Public Method | MoveNext | This method advances the collection enumerator position/index by one if not at the end of the collection.
Public Method | Reset | Resets the collection index to before the start of the collection.
Public Method | Unlock | Unlocks the collection.
Top

See Also

Reference

ThumbnailItemCollectionEnumerator Class
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.ThumbnailXpress4.Net
ThumbnailItemCollectionEnumerator Class Methods
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : ThumbnailItemCollectionEnumerator Class

Glossary Item Box

For a list of all members of this type, see ThumbnailItemCollectionEnumerator members.

Public Methods

 | Name | Description
Public Method | Lock | Locks the collection.
Public Method | MoveNext | This method advances the collection enumerator position/index by one if not at the end of the collection.
Public Method | Reset | Resets the collection index to before the start of the collection.
Public Method | Unlock | Unlocks the collection.
Top

See Also

Reference

ThumbnailItemCollectionEnumerator Class
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Lock Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailItemCollectionEnumerator Class : Lock Method

Glossary Item Box

Locks the collection.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub Lock()
'Usage

Dim instance As ThumbnailItemCollectionEnumerator

instance.Lock()
public void Lock()
public: void Lock();
public:
void Lock();

Remarks

The collection must be locked before calling Current, MoveNext, or Reset.

See Also

Reference

ThumbnailItemCollectionEnumerator Class
ThumbnailItemCollectionEnumerator Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
MoveNext Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailItemCollectionEnumerator Class : MoveNext Method

Glossary Item Box

This method advances the collection enumerator position/index by one if not at the end of the collection.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function MoveNext() As Boolean
'Usage

Dim instance As ThumbnailItemCollectionEnumerator
Dim value As Boolean

value = instance.MoveNext()
public bool MoveNext()
public: bool MoveNext();
public:
bool MoveNext();

Return Value

A boolean value which is true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

Remarks

The collection must be locked before accessing this method.

See Also

Reference

ThumbnailItemCollectionEnumerator Class
ThumbnailItemCollectionEnumerator Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Reset Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailItemCollectionEnumerator Class : Reset Method

Glossary Item Box

Resets the collection index to before the start of the collection.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub Reset()
'Usage

Dim instance As ThumbnailItemCollectionEnumerator

instance.Reset()
public void Reset()
public: void Reset();
public:
void Reset();

Remarks

The collection must be locked before accessing this property.

See Also

Reference

ThumbnailItemCollectionEnumerator Class
ThumbnailItemCollectionEnumerator Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Unlock Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailItemCollectionEnumerator Class : Unlock Method

Glossary Item Box

Unlocks the collection.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub Unlock()
'Usage

Dim instance As ThumbnailItemCollectionEnumerator

instance.Unlock()
public void Unlock()
public: void Unlock();
public:
void Unlock();

See Also

Reference

ThumbnailItemCollectionEnumerator Class
ThumbnailItemCollectionEnumerator Members


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.ThumbnailXpress4.Net
ThumbnailItemCollectionEnumerator Class Properties
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : ThumbnailItemCollectionEnumerator Class

Glossary Item Box

For a list of all members of this type, see ThumbnailItemCollectionEnumerator members.

Public Properties

 | Name | Description
Public Property | Current | Gets the ThumbnailItem at the current enumerator index.
Top

See Also

Reference

ThumbnailItemCollectionEnumerator Class
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Current Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailItemCollectionEnumerator Class : Current Property

Glossary Item Box

Gets the ThumbnailItem at the current enumerator index.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property Current As ThumbnailItem
'Usage

Dim instance As ThumbnailItemCollectionEnumerator
Dim value As ThumbnailItem

value = instance.Current
public ThumbnailItem Current {get;}
public: __property ThumbnailItem* get_Current();
public:
property ThumbnailItem^ Current {
   ThumbnailItem^ get();
}

Property Value

Returns the ThumbnailItem at the current enumerator index.

Remarks

The collection must be locked before accessing this property.

See Also

Reference

ThumbnailItemCollectionEnumerator Class
ThumbnailItemCollectionEnumerator Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
ThumbnailXpress Class
Members See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : ThumbnailXpress Class

Glossary Item Box

The Thumbnail User Control provides displaying of supported image types as thumbnails inside individual cells in a scrollable collection.

Object Model

ThumbnailXpress ClassFilter ClassFilterCollection ClassFilter ClassThumbnailItem ClassFilterCollection ClassFilter ClassThumbnailItem ClassThumbnailItemCollection ClassThumbnailItem ClassLicensing ClassSelectedThumbnailItemCollection ClassThumbnailItem ClassThumbnailCache ClassThumbnailItem Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<ToolboxBitmapAttribute()>
Public Class ThumbnailXpress
   Inherits System.Windows.Forms.UserControl
'Usage

Dim instance As ThumbnailXpress
[ToolboxBitmapAttribute()]
public class ThumbnailXpress : System.Windows.Forms.UserControl
[ToolboxBitmapAttribute()]
public __gc class ThumbnailXpress : public System.Windows.Forms.UserControl
[ToolboxBitmapAttribute()]
public ref class ThumbnailXpress : public System.Windows.Forms.UserControl

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
Accusoft.ThumbnailXpressSdk.ThumbnailXpress

See Also

Reference

ThumbnailXpress Members
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.ThumbnailXpress4.Net
ThumbnailXpress Class Members
See Also Properties Methods Events Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : ThumbnailXpress Class

Glossary Item Box

The following tables list the members exposed by ThumbnailXpress.

Public Constructors

 | Name | Description
Public Constructor | ThumbnailXpress Constructor | The main ThumbnailXpress constructor.
Top

Public Properties

 | Name | Description
Public Property | AccessibilityObject | Gets the System.Windows.Forms.AccessibleObject assigned to the control. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from System.Windows.Forms.Control)
Public Property | ActiveControl | Gets or sets the active control on the container control. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AllowDrop | This generic control property has been replaced by four new properties specific to ThumbnailXpress that allow a finer granularity of control over the types of drag/drop operations the control will allow. The new properties are: IntraComponentThumbnailDragDropEnabled, InterComponentThumbnailDragDropEnabled, EnableAsDragSourceForExternalDragDrop, and EnableAsDropTargetForExternalDragDrop
Public Property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | AnnotationSearchOrder | This property allows you to specify the different places, in order of importance that ThumbnailXpress should look for associated annotation data when rendering a thumbnail. For each thumbnail that is being rendered, the first rule in the list that successfully points to annotation data will be used to draw those annotations on the thumbnail.
Public Property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollOffset | Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control). (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from System.Windows.Forms.UserControl)
Public Property | BackColor | Overridden. Gets and sets the control's unselected items cell background color.
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the System.Windows.Forms.ImageLayout enumeration. (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | BorderStyle | Gets and sets the control's border style.
Public Property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | BottomMargin | Gets and sets the margin on the bottom most side of the control.
Public Property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from System.Windows.Forms.Control)
Public Property | CameraRaw | Gets and sets enabling or disabling of the camera raw image type detection algorithms during thumbnail image generation.
Public Property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from System.Windows.Forms.Control)
Public Property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from System.Windows.Forms.Control)
Public Property | CellBorderColor | Gets and sets the border color of the cells in the control.
Public Property | CellBorderWidth | Gets and sets the width of the cells in the control.
Public Property | CellHeight | Gets and sets the height of the cells in the control.
Public Property | CellHorizontalSpacing | Gets and sets the spacing between columns.
Public Property | CellSpacingColor | Gets and sets the control's cell spacing color.
Public Property | CellVerticalSpacing | Gets and sets the spacing between the rows in the control.
Public Property | CellWidth | Gets and sets the width of the cells in the control.
Public Property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control. (Inherited from System.Windows.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from System.Windows.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from System.Windows.Forms.Control)
Public Property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from System.Windows.Forms.Control)
Public Property | CustomErrorIcon | Specifies the icon to use for errors instead of the stock error icon. ErrorAction must be set to 0 - use error icon.
Public Property | CustomGeneratingIcon | Specifies the icon to use for the pre-image generation placeholder instead of the stock 'generating' icon. ShowImagePlaceholders must be set to true.
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from System.Windows.Forms.Control)
Public Property | DblClickDirectoryDrillDown | Gets and sets enabling or disabling directory navigation initiated by double-clicking on directory place holder thumbnail images.
Public Property | Debug | Gets and sets the on/off state of the logging system.
Public Property | DebugErrorLevel | Gets and sets the level of detail written to the error log.
Public Property | DebugLogFile | Gets and sets the log file location.
Public Property | DescriptorAlignment | Gets and sets the alignment of the descriptor text.
Public Property | DescriptorDisplayMethod | Gets and sets the method allowing selection of the source of the descriptor text content.
Public Property | DisplayRectangle | Overridden. Gets the current area being displayed.
Public Property | Disposing | Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing. (Inherited from System.Windows.Forms.Control)
Public Property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | EnableAsDragSourceForExternalDragDrop | Gets and sets enabling or disabling the component acting as a drag source for dragging thumbnail images to other applications. Any application that supports acting as a drop target for the CF_DIB clipboard/drag-drop format can be a thumbnail image drop recipient.
Public Property | EnableAsDropTargetForExternalDragDrop | Gets and sets enabling or disabling the component acting as a drop target for other applications to drag files onto the component to display those files as thumbnail images.
Public Property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from System.Windows.Forms.Control)
Public Property | ErrorAction | Gets and sets the type of display action taken when a thumbnail generation error occurs.
Public Property | Filters | Gets the FilterCollection object to access a collection of filters.
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from System.Windows.Forms.Control)
Public Property | Font | Overridden. Gets and sets the thumbnail descriptor font.
Public Property | ForeColor | Overridden. Gets and sets the controls foreground color.
Public Property | FtpPassword | Gets and sets the FTP password.
Public Property | FtpUserName | Gets and sets the FTP user name.
Public Property | Handle | Gets the window handle that the control is bound to. (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from System.Windows.Forms.Control)
Public Property | Height | Gets or sets the height of the control. (Inherited from System.Windows.Forms.Control)
Public Property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from System.Windows.Forms.Control)
Public Property | InterComponentThumbnailDragDropEnabled | Gets and sets enabling or disabling the component acting as a drag source or drop target for thumbnail image drag and drop operations between other instances of the ThumbnailXpress component.
Public Property | IntraComponentThumbnailDragDropEnabled | Gets and sets enabling or disabling support of drag and drop move operations amongst thumbnail images in the same instance of a ThumbnailXpress component.
Public Property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from System.Windows.Forms.Control)
Public Property | Items | Gets the ThumbnailItemCollection object to access a collection of thumbnail items.
Public Property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from System.Windows.Forms.Control)
Public Property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | LeftMargin | Gets and sets the margin on the left most side of the control.
Public Property | Licensing | Gets the Licensing object to allow user to license ThumbnailXpress.
Public Property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from System.Windows.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | MaximumThreadCount | Gets and sets the maximum number of concurrent worker threads allowed for thumbnail bitmap generation.
Public Property | MaximumThumbnailBitDepth | Gets and sets the maximum bit-depth allowed for the thumbnails.
Public Property | MinimumSize | Gets or sets the size that is the lower limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | Name | Gets or sets the name of the control. (Inherited from System.Windows.Forms.Control)
Public Property | NotateXpressInstance | The instance of NotateXpress, this should be set to the Accusoft.NotateXpressSdk.NotateXpress.InstanceHandle property. Once set annotations can be drawn on thumbnails. Note: NotateXpress is a separate control.
Public Property | Padding | Gets or sets padding within the control. (Inherited from System.Windows.Forms.Control)
Public Property | Parent | Gets or sets the parent container of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ParentForm | Gets the form that the container control is assigned to. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | PdfPassword | Gets and sets the PDF password.
Public Property | PdfRepair | Read/write property accessing the PDF repair flag.
Public Property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from System.Windows.Forms.Control)
Public Property | PreserveBlack | Gets and sets enabling or disabling the PreserveBlack algorithms during thumbnail image generation.
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | ProxyServer | Gets and sets the name or IP address of an optional proxy server.
Public Property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from System.Windows.Forms.Control)
Public Property | Region | Gets or sets the window region associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | RightMargin | Gets and sets the margin on the right most side of the control.
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from System.Windows.Forms.Control)
Public Property | ScrollDirection | Gets and sets the current direction of scrolling.
Public Property | SelectBackColor | Gets and sets the control's selected items cell background color.
Public Property | SelectedItems | Gets the SelectedThumbnailItemCollection object to access a collection of selected thumbnail items.
Public Property | SelectionMode | Gets and sets the item selection mode for the control.
Public Property | ShowHourglass | Gets and sets the displaying of an hourglass cursor when thumbnail images are being loaded from a directory or file.
Public Property | ShowImagePlaceholders | Gets and sets the display of a pre-image-generation 'placeholder' icon.
Public Property | Site | Gets or sets the site of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Size | Gets or sets the height and width of the control. (Inherited from System.Windows.Forms.Control)
Public Property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from System.Windows.Forms.Control)
Public Property | Tag | Gets or sets the object that contains data about the control. (Inherited from System.Windows.Forms.Control)
Public Property | TextBackColor | Gets and sets the control's descriptor text background color.
Public Property | ThreadHungThreshold | Gets and sets the elapsed time threshold (in milliseconds) beyond which a request to obtain a thumbnail should be abandoned.
Public Property | ThreadStartThreshold | Gets and sets the elapsed time threshold (in milliseconds) beyond which a request to obtain a thumbnail should be considered of "extended duration".
Public Property | ThumbnailCache | Gets and sets the thumbnail cache object to adjust cache settings.
Public Property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in. (Inherited from System.Windows.Forms.Control)
Public Property | TopMargin | Gets and sets the margin on the top-most side of the control.
Public Property | TopVisibleItem | Gets the thumbnail item of the top-most visible thumbnail item.
Public Property | UseCameraRawThumbnail | When CameraRaw is true, setting this property will load the embedded thumbnail of the camera raw image which typically loads faster than the full-size image.
Public Property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from System.Windows.Forms.Control)
Public Property | Version | Returns the version of the ThumbnailXpress control at run-time.
Public Property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from System.Windows.Forms.Control)
Public Property | VisibleColumnCount | Gets the number of visible thumbnail columns.
Public Property | VisibleRowCount | Gets the number of visible thumbnail rows.
Public Property | Width | Gets or sets the width of the control. (Inherited from System.Windows.Forms.Control)
Top

Public Methods

 | Name | Description
Public Method | AboutBox | Displays an AboutBox showing general information about this component.
Public Method | BeginInvoke | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
Public Method | BeginUpdate | This method disables control repainting.
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | Cancel | Cancels all pending thumbnail item image generation requests.
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from System.Windows.Forms.Control)
Public Method | CreateFilter | This is the method that a user would use to create a new uninitialized filter.
Public Method | CreateFilterCollection | This is the method that a user would use to create a new uninitialized filter collection.
Public Method | CreateGraphics | Creates the System.Drawing.Graphics for the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | CreateThumbnailItem | Creates a thumbnail and adds it to the collection of thumbnail items.
Public Method | Dispose() | (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed. (Inherited from System.Windows.Forms.Control)
Public Method | EndUpdate | Enables control repainting and is used in conjunction with the BeginUpdate method.
Public Method | EnsureVisible | Adjusts the display so that the thumbnail of the given index is visible.
Public Method | FindForm | Retrieves the form that the control is on. (Inherited from System.Windows.Forms.Control)
Public Method | Focus | Sets input focus to the control. (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetDragFileCount | Gets the number of files in a FileDrop data object.
Public Method | GetDragFilename | Gets a filename in a FileDrop data object.
Public Method | GetItemFromPoint | Overloaded. Returns the thumbnail item containing the window point provided.
Public Method | GetItemRectangle | Returns the rectangle of the Thumbnail identified by the provided index.
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from System.Windows.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
Public Method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | PerformLayout | Overloaded. Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from System.Windows.Forms.Control)
Public Method | ResetAllCanceledItems | Resets the status for all items in the thumbnail collection whose image generation requests were canceled by the user.
Public Method | ResetCanceledItem | Resets the status for an item in the thumbnail collection whose image generation request was canceled by the user.
Public Method | ResetText | Resets the System.Windows.Forms.Control.Text property to its default value. (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
Public Method | Scale | (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | ScrollItems | Provides programmatic scrolling of the display.
Public Method | Select | Activates the control. (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | Activates the next control. (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
Public Method | Show | Displays the control to the user. (Inherited from System.Windows.Forms.Control)
Public Method | ShowScrollBar | Shows or hides the scrollbar.
Public Method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from System.Windows.Forms.Control)
Public Method | Validate | Overloaded. Verifies the value of the control losing focus by causing the System.Windows.Forms.Control.Validating and System.Windows.Forms.Control.Validated events to occur, in that order. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | ValidateChildren | Overloaded. (Inherited from System.Windows.Forms.UserControl)
Top

Public Events

 | Name | Description
Public Event | AutoSizeChanged | Occurs when the System.Windows.Forms.UserControl.AutoSize property changes. (Inherited from System.Windows.Forms.UserControl)
Public Event | AutoValidateChanged | Occurs when the System.Windows.Forms.UserControl.AutoValidate property changes. (Inherited from System.Windows.Forms.UserControl)
Public Event | BackColorChanged | Occurs when the value of the System.Windows.Forms.Control.BackColor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the System.Windows.Forms.Control.BackgroundImage property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the System.Windows.Forms.Control.BackgroundImageLayout property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the System.Windows.Forms.BindingContext property changes. (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from System.Windows.Forms.Control)
Public Event | Click | Occurs when the control is clicked. (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the System.Windows.Forms.Control.Cursor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | Occurs when the value of the System.Windows.Forms.Control.Dock property changes. (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | Occurs when the control is double-clicked. (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | Event which is called when a drag-and-drop operation is completed as a result of dragging an object over the control and releasing the mouse button.
Public Event | DragEnter | Event which is called when an object is dragged into the control's bounds.
Public Event | DragLeave | Event which is called when an object is dragged out of the control's bounds.
Public Event | DragOver | Event which is called when an object is dragged over the control's bounds.
Public Event | EnabledChanged | Occurs when the System.Windows.Forms.Control.Enabled property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Enter | Occurs when the control is entered. (Inherited from System.Windows.Forms.Control)
Public Event | Error | Event which is called when an error occurs during generation or painting of a thumbnail item.
Public Event | FontChanged | Occurs when the System.Windows.Forms.Control.Font property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | Occurs when the System.Windows.Forms.Control.ForeColor property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | Event which is called when a drag-and-drop operation is started.
Public Event | GotFocus | Occurs when the control receives focus. (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | Occurs when a handle is created for the control. (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | Occurs when the System.Windows.Forms.Control.ImeMode property has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from System.Windows.Forms.Control)
Public Event | ItemComplete | Event which is called when a thumbnail item's asynchronous image generation has been completed. Review the thumbnail item collection information about how thumbnail items are added to the collection, where the items are generated asynchronously.
Public Event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Layout | Occurs when a control should reposition its child controls. (Inherited from System.Windows.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | Load | Occurs before the control becomes visible for the first time. (Inherited from System.Windows.Forms.UserControl)
Public Event | LoadFromStream | This event is called when the component requires the application to provide a System.IO.Stream object containing image data for a thumbnail item.
Public Event | LocationChanged | Occurs when the System.Windows.Forms.Control.Location property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | Occurs when the control's margin changes. (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Move | Occurs when the control is moved. (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | Occurs when the control's padding changes. (Inherited from System.Windows.Forms.Control)
Public Event | Paint | Occurs when the control is redrawn. (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | Occurs when the System.Windows.Forms.Control.Parent property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control. (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | Event which is called when there is a change in the keyboard or mouse button state during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be cancelled.
Public Event | RegionChanged | Occurs when the value of the System.Windows.Forms.Control.Region property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | Occurs when the System.Windows.Forms.Control.RightToLeft property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | SelectedIndexChanged | Event which is called when a thumbnail item is selected using the user interface.
Public Event | SizeChanged | Occurs when the System.Windows.Forms.Control.Size property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | Occurs when the control style changes. (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | Occurs when the system colors change. (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | Occurs when the System.Windows.Forms.Control.TabIndex property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | Occurs when the System.Windows.Forms.Control.TabStop property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | Validated | Occurs when the control is finished validating. (Inherited from System.Windows.Forms.Control)
Public Event | Validating | Occurs when the control is validating. (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | Occurs when the System.Windows.Forms.Control.Visible property value changes. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

ThumbnailXpress Class
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
ThumbnailXpress Constructor
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : ThumbnailXpress Constructor

Glossary Item Box

The main ThumbnailXpress constructor.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ThumbnailXpress()
public ThumbnailXpress()
public: ThumbnailXpress();
public:
ThumbnailXpress();

Remarks

Keep in mind that there can be multiple ThumbnailXpress controls instantiated in one AppDomain/Process-space. The controls can be on the same or different threads.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.ThumbnailXpress4.Net
ThumbnailXpress Class Methods
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : ThumbnailXpress Class

Glossary Item Box

For a list of all members of this type, see ThumbnailXpress members.

Public Methods

 | Name | Description
Public Method | AboutBox | Displays an AboutBox showing general information about this component.
Public Method | BeginInvoke | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
Public Method | BeginUpdate | This method disables control repainting.
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | Cancel | Cancels all pending thumbnail item image generation requests.
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from System.Windows.Forms.Control)
Public Method | CreateFilter | This is the method that a user would use to create a new uninitialized filter.
Public Method | CreateFilterCollection | This is the method that a user would use to create a new uninitialized filter collection.
Public Method | CreateGraphics | Creates the System.Drawing.Graphics for the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | CreateThumbnailItem | Creates a thumbnail and adds it to the collection of thumbnail items.
Public Method | Dispose() | (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed. (Inherited from System.Windows.Forms.Control)
Public Method | EndUpdate | Enables control repainting and is used in conjunction with the BeginUpdate method.
Public Method | EnsureVisible | Adjusts the display so that the thumbnail of the given index is visible.
Public Method | FindForm | Retrieves the form that the control is on. (Inherited from System.Windows.Forms.Control)
Public Method | Focus | Sets input focus to the control. (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetDragFileCount | Gets the number of files in a FileDrop data object.
Public Method | GetDragFilename | Gets a filename in a FileDrop data object.
Public Method | GetItemFromPoint | Overloaded. Returns the thumbnail item containing the window point provided.
Public Method | GetItemRectangle | Returns the rectangle of the Thumbnail identified by the provided index.
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from System.Windows.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
Public Method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | PerformLayout | Overloaded. Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from System.Windows.Forms.Control)
Public Method | ResetAllCanceledItems | Resets the status for all items in the thumbnail collection whose image generation requests were canceled by the user.
Public Method | ResetCanceledItem | Resets the status for an item in the thumbnail collection whose image generation request was canceled by the user.
Public Method | ResetText | Resets the System.Windows.Forms.Control.Text property to its default value. (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
Public Method | Scale | (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | ScrollItems | Provides programmatic scrolling of the display.
Public Method | Select | Activates the control. (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | Activates the next control. (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
Public Method | Show | Displays the control to the user. (Inherited from System.Windows.Forms.Control)
Public Method | ShowScrollBar | Shows or hides the scrollbar.
Public Method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from System.Windows.Forms.Control)
Public Method | Validate | Overloaded. Verifies the value of the control losing focus by causing the System.Windows.Forms.Control.Validating and System.Windows.Forms.Control.Validated events to occur, in that order. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | ValidateChildren | Overloaded. (Inherited from System.Windows.Forms.UserControl)
Top

See Also

Reference

ThumbnailXpress Class
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
AboutBox Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : AboutBox Method

Glossary Item Box

Displays an AboutBox showing general information about this component.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub AboutBox()
'Usage

Dim instance As ThumbnailXpress

instance.AboutBox()
public void AboutBox()
public: void AboutBox();
public:
void AboutBox();

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
BeginUpdate Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : BeginUpdate Method

Glossary Item Box

This method disables control repainting.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub BeginUpdate()
'Usage

Dim instance As ThumbnailXpress

instance.BeginUpdate()
public void BeginUpdate()
public: void BeginUpdate();
public:
void BeginUpdate();

Remarks

Call this method before adding multiple items to the list to reduce redraw flicker. Call the EndUpdate method to enable repainting after the items have been added.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Cancel Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : Cancel Method

Glossary Item Box

Cancels all pending thumbnail item image generation requests.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub Cancel()
'Usage

Dim instance As ThumbnailXpress

instance.Cancel()
public void Cancel()
public: void Cancel();
public:
void Cancel();

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
CreateFilter Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : CreateFilter Method

name
A string value that represents the name of the filter.

Glossary Item Box

This is the method that a user would use to create a new uninitialized filter.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function CreateFilter( _
   ByVal name As String _
) As Filter
'Usage

Dim instance As ThumbnailXpress
Dim name As String
Dim value As Filter

value = instance.CreateFilter(name)
public Filter CreateFilter(
   string name
)
public: Filter* CreateFilter(
   string* name
)
public:
Filter^ CreateFilter(
   String^ name
)

Parameters

name
A string value that represents the name of the filter.

Return Value

A Filter created.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
CreateFilterCollection Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : CreateFilterCollection Method

Glossary Item Box

This is the method that a user would use to create a new uninitialized filter collection.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function CreateFilterCollection() As FilterCollection
'Usage

Dim instance As ThumbnailXpress
Dim value As FilterCollection

value = instance.CreateFilterCollection()
public FilterCollection CreateFilterCollection()
public: FilterCollection* CreateFilterCollection();
public:
FilterCollection^ CreateFilterCollection();

Return Value

A FilterCollection created.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
CreateThumbnailItem Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : CreateThumbnailItem Method

filename
A string value which represents the file containing the thumbnail.
pageNumber
An integer value which represents the page in the image file for the current thumbnail.
type
A ThumbnailType which represents the type of thumbnail. If a parent or sub directory is specified, the PageNumber parameter is ignored and the Filename parameter should contain the directory path.

Glossary Item Box

Creates a thumbnail and adds it to the collection of thumbnail items.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function CreateThumbnailItem( _
   ByVal filename As String, _
   ByVal pageNumber As Integer, _
   ByVal type As ThumbnailType _
) As ThumbnailItem
'Usage

Dim instance As ThumbnailXpress
Dim filename As String
Dim pageNumber As Integer
Dim type As ThumbnailType
Dim value As ThumbnailItem

value = instance.CreateThumbnailItem(filename, pageNumber, type)
public ThumbnailItem CreateThumbnailItem(
   string filename,
   int pageNumber,
   ThumbnailType type
)
public: ThumbnailItem* CreateThumbnailItem(
   string* filename,
   int pageNumber,
   ThumbnailType type
)
public:
ThumbnailItem^ CreateThumbnailItem(
   String^ filename,
   int pageNumber,
   ThumbnailType type
)

Parameters

filename
A string value which represents the file containing the thumbnail.
pageNumber
An integer value which represents the page in the image file for the current thumbnail.
type
A ThumbnailType which represents the type of thumbnail. If a parent or sub directory is specified, the PageNumber parameter is ignored and the Filename parameter should contain the directory path.

Return Value

The created thumbnail item.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
EndUpdate Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : EndUpdate Method

Glossary Item Box

Enables control repainting and is used in conjunction with the BeginUpdate method.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub EndUpdate()
'Usage

Dim instance As ThumbnailXpress

instance.EndUpdate()
public void EndUpdate()
public: void EndUpdate();
public:
void EndUpdate();

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
EnsureVisible Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : EnsureVisible Method

index
An integer value which represents the zero-based index of the thumbnail the user wants to be visible.

Glossary Item Box

Adjusts the display so that the thumbnail of the given index is visible.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub EnsureVisible( _
   ByVal index As Integer _
)
'Usage

Dim instance As ThumbnailXpress
Dim index As Integer

instance.EnsureVisible(index)
public void EnsureVisible(
   int index
)
public: void EnsureVisible(
   int index
)
public:
void EnsureVisible(
   int index
)

Parameters

index
An integer value which represents the zero-based index of the thumbnail the user wants to be visible.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
GetDragFileCount Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : GetDragFileCount Method

dragData
A pointer to FileFormats.FileDrop data.

Glossary Item Box

Gets the number of files in a FileDrop data object.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function GetDragFileCount( _
   ByVal dragData As IntPtr _
) As Integer
'Usage

Dim instance As ThumbnailXpress
Dim dragData As IntPtr
Dim value As Integer

value = instance.GetDragFileCount(dragData)
public int GetDragFileCount(
   IntPtr dragData
)
public: int GetDragFileCount(
   IntPtr dragData
)
public:
int GetDragFileCount(
   IntPtr dragData
)

Parameters

dragData
A pointer to FileFormats.FileDrop data.

Return Value

The number of files in the FileDrop data.

Remarks

This can be used to access the FileDrop data that is returned by DragEventArgs.Data.GetData(DataFormats.FileDrop) when dragging an external thumbnail or thumbnails.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
GetDragFilename Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : GetDragFilename Method

dragData
A pointer to FileFormats.FileDrop data.
fileIndex
The index of the file.

Glossary Item Box

Gets a filename in a FileDrop data object.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function GetDragFilename( _
   ByVal dragData As IntPtr, _
   ByVal fileIndex As Integer _
) As String
'Usage

Dim instance As ThumbnailXpress
Dim dragData As IntPtr
Dim fileIndex As Integer
Dim value As String

value = instance.GetDragFilename(dragData, fileIndex)
public string GetDragFilename(
   IntPtr dragData,
   int fileIndex
)
public: string* GetDragFilename(
   IntPtr dragData,
   int fileIndex
)
public:
String^ GetDragFilename(
   IntPtr dragData,
   int fileIndex
)

Parameters

dragData
A pointer to FileFormats.FileDrop data.
fileIndex
The index of the file.

Return Value

The filename at the specified index in the FileDrop data.

Remarks

This can be used to access the FileDrop data that is returned by DragEventArgs.Data.GetData(DataFormats.FileDrop) when dragging an external thumbnail or thumbnails.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
GetItemFromPoint Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : GetItemFromPoint Method

Glossary Item Box

Returns the thumbnail item containing the window point provided.

Overload List

Overload | Description
GetItemFromPoint(Point) | Returns the thumbnail item containing the window point provided.
GetItemFromPoint(PointF) | Returns the thumbnail item containing the window point provided.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
GetItemFromPoint(Point) Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class > GetItemFromPoint Method : GetItemFromPoint(Point) Method

point
A System.Drawing.Point which represents the location of a point in the control. The point values should be in client coordinates.

Glossary Item Box

Returns the thumbnail item containing the window point provided.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Function GetItemFromPoint( _
   ByVal point As Point _
) As ThumbnailItem
'Usage

Dim instance As ThumbnailXpress
Dim point As Point
Dim value As ThumbnailItem

value = instance.GetItemFromPoint(point)
public ThumbnailItem GetItemFromPoint(
   Point point
)
public: ThumbnailItem* GetItemFromPoint(
   Point point
)
public:
ThumbnailItem^ GetItemFromPoint(
   Point point
)

Parameters

point
A System.Drawing.Point which represents the location of a point in the control. The point values should be in client coordinates.

Return Value

A ThumbnailItem containing the provided point. Returns null if point is not over an image.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
GetItemFromPoint(PointF) Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class > GetItemFromPoint Method : GetItemFromPoint(PointF) Method

point
A System.Drawing.PointF which represents the location of a point in the control. The point values should be in client coordinates.

Glossary Item Box

Returns the thumbnail item containing the window point provided.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Function GetItemFromPoint( _
   ByVal point As PointF _
) As ThumbnailItem
'Usage

Dim instance As ThumbnailXpress
Dim point As PointF
Dim value As ThumbnailItem

value = instance.GetItemFromPoint(point)
public ThumbnailItem GetItemFromPoint(
   PointF point
)
public: ThumbnailItem* GetItemFromPoint(
   PointF point
)
public:
ThumbnailItem^ GetItemFromPoint(
   PointF point
)

Parameters

point
A System.Drawing.PointF which represents the location of a point in the control. The point values should be in client coordinates.

Return Value

Thumbnail item containing the provided point. Returns null if point is not over an image.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
GetItemRectangle Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : GetItemRectangle Method

index
An integer value which represents the zero-based index of the thumbnail which displays the rectangle for.

Glossary Item Box

Returns the rectangle of the Thumbnail identified by the provided index.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function GetItemRectangle( _
   ByVal index As Integer _
) As Rectangle
'Usage

Dim instance As ThumbnailXpress
Dim index As Integer
Dim value As Rectangle

value = instance.GetItemRectangle(index)
public Rectangle GetItemRectangle(
   int index
)
public: Rectangle GetItemRectangle(
   int index
)
public:
Rectangle GetItemRectangle(
   int index
)

Parameters

index
An integer value which represents the zero-based index of the thumbnail which displays the rectangle for.

Return Value

A System.Drawing.Rectangle for the thumbnail identified by the given index.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
ResetAllCanceledItems Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : ResetAllCanceledItems Method

Glossary Item Box

Resets the status for all items in the thumbnail collection whose image generation requests were canceled by the user.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub ResetAllCanceledItems()
'Usage

Dim instance As ThumbnailXpress

instance.ResetAllCanceledItems()
public void ResetAllCanceledItems()
public: void ResetAllCanceledItems();
public:
void ResetAllCanceledItems();

Remarks

This allows those items' images to again be attempted to be generated.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
ResetCanceledItem Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : ResetCanceledItem Method

item
A ThumbnailItem which represents the item.

Glossary Item Box

Resets the status for an item in the thumbnail collection whose image generation request was canceled by the user.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub ResetCanceledItem( _
   ByVal item As ThumbnailItem _
)
'Usage

Dim instance As ThumbnailXpress
Dim item As ThumbnailItem

instance.ResetCanceledItem(item)
public void ResetCanceledItem(
   ThumbnailItem item
)
public: void ResetCanceledItem(
   ThumbnailItem* item
)
public:
void ResetCanceledItem(
   ThumbnailItem^ item
)

Parameters

item
A ThumbnailItem which represents the item.

Remarks

This allows the item image to again be attempted to be generated.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
ScrollItems Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : ScrollItems Method

scrollType
Specifies the incremental amount or whether a positional scroll operation is desired.
value
If ScrollType is equal to ThumbPosition, value specifies a thumb position to be scrolled to. If ScrollType is equal to ItemIndex, value specifies item index to be scrolled to.

Glossary Item Box

Provides programmatic scrolling of the display.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub ScrollItems( _
   ByVal scrollType As ScrollItemsType, _
   ByVal value As Integer _
)
'Usage

Dim instance As ThumbnailXpress
Dim scrollType As ScrollItemsType
Dim value As Integer

instance.ScrollItems(scrollType, value)
public void ScrollItems(
   ScrollItemsType scrollType,
   int value
)
public: void ScrollItems(
   ScrollItemsType scrollType,
   int value
)
public:
void ScrollItems(
   ScrollItemsType scrollType,
   int value
)

Parameters

scrollType
Specifies the incremental amount or whether a positional scroll operation is desired.
value
If ScrollType is equal to ThumbPosition, value specifies a thumb position to be scrolled to. If ScrollType is equal to ItemIndex, value specifies item index to be scrolled to.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
ShowScrollBar Method
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : ShowScrollBar Method

bShow
A boolean value which is true to show or hide the scrollbar. Otherwise, false is used.

Glossary Item Box

Shows or hides the scrollbar.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub ShowScrollBar( _
   ByVal bShow As Boolean _
)
'Usage

Dim instance As ThumbnailXpress
Dim bShow As Boolean

instance.ShowScrollBar(bShow)
public void ShowScrollBar(
   bool bShow
)
public: void ShowScrollBar(
   bool bShow
)
public:
void ShowScrollBar(
   bool bShow
)

Parameters

bShow
A boolean value which is true to show or hide the scrollbar. Otherwise, false is used.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.ThumbnailXpress4.Net
ThumbnailXpress Class Properties
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : ThumbnailXpress Class

Glossary Item Box

For a list of all members of this type, see ThumbnailXpress members.

Public Properties

 | Name | Description
Public Property | AccessibilityObject | Gets the System.Windows.Forms.AccessibleObject assigned to the control. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from System.Windows.Forms.Control)
Public Property | ActiveControl | Gets or sets the active control on the container control. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AllowDrop | This generic control property has been replaced by four new properties specific to ThumbnailXpress that allow a finer granularity of control over the types of drag/drop operations the control will allow. The new properties are: IntraComponentThumbnailDragDropEnabled, InterComponentThumbnailDragDropEnabled, EnableAsDragSourceForExternalDragDrop, and EnableAsDropTargetForExternalDragDrop
Public Property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | AnnotationSearchOrder | This property allows you to specify the different places, in order of importance that ThumbnailXpress should look for associated annotation data when rendering a thumbnail. For each thumbnail that is being rendered, the first rule in the list that successfully points to annotation data will be used to draw those annotations on the thumbnail.
Public Property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollOffset | Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control). (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from System.Windows.Forms.UserControl)
Public Property | BackColor | Overridden. Gets and sets the control's unselected items cell background color.
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the System.Windows.Forms.ImageLayout enumeration. (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | BorderStyle | Gets and sets the control's border style.
Public Property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | BottomMargin | Gets and sets the margin on the bottom most side of the control.
Public Property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from System.Windows.Forms.Control)
Public Property | CameraRaw | Gets and sets enabling or disabling of the camera raw image type detection algorithms during thumbnail image generation.
Public Property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from System.Windows.Forms.Control)
Public Property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from System.Windows.Forms.Control)
Public Property | CellBorderColor | Gets and sets the border color of the cells in the control.
Public Property | CellBorderWidth | Gets and sets the width of the cells in the control.
Public Property | CellHeight | Gets and sets the height of the cells in the control.
Public Property | CellHorizontalSpacing | Gets and sets the spacing between columns.
Public Property | CellSpacingColor | Gets and sets the control's cell spacing color.
Public Property | CellVerticalSpacing | Gets and sets the spacing between the rows in the control.
Public Property | CellWidth | Gets and sets the width of the cells in the control.
Public Property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control. (Inherited from System.Windows.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from System.Windows.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from System.Windows.Forms.Control)
Public Property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from System.Windows.Forms.Control)
Public Property | CustomErrorIcon | Specifies the icon to use for errors instead of the stock error icon. ErrorAction must be set to 0 - use error icon.
Public Property | CustomGeneratingIcon | Specifies the icon to use for the pre-image generation placeholder instead of the stock 'generating' icon. ShowImagePlaceholders must be set to true.
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from System.Windows.Forms.Control)
Public Property | DblClickDirectoryDrillDown | Gets and sets enabling or disabling directory navigation initiated by double-clicking on directory place holder thumbnail images.
Public Property | Debug | Gets and sets the on/off state of the logging system.
Public Property | DebugErrorLevel | Gets and sets the level of detail written to the error log.
Public Property | DebugLogFile | Gets and sets the log file location.
Public Property | DescriptorAlignment | Gets and sets the alignment of the descriptor text.
Public Property | DescriptorDisplayMethod | Gets and sets the method allowing selection of the source of the descriptor text content.
Public Property | DisplayRectangle | Overridden. Gets the current area being displayed.
Public Property | Disposing | Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing. (Inherited from System.Windows.Forms.Control)
Public Property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | EnableAsDragSourceForExternalDragDrop | Gets and sets enabling or disabling the component acting as a drag source for dragging thumbnail images to other applications. Any application that supports acting as a drop target for the CF_DIB clipboard/drag-drop format can be a thumbnail image drop recipient.
Public Property | EnableAsDropTargetForExternalDragDrop | Gets and sets enabling or disabling the component acting as a drop target for other applications to drag files onto the component to display those files as thumbnail images.
Public Property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from System.Windows.Forms.Control)
Public Property | ErrorAction | Gets and sets the type of display action taken when a thumbnail generation error occurs.
Public Property | Filters | Gets the FilterCollection object to access a collection of filters.
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from System.Windows.Forms.Control)
Public Property | Font | Overridden. Gets and sets the thumbnail descriptor font.
Public Property | ForeColor | Overridden. Gets and sets the controls foreground color.
Public Property | FtpPassword | Gets and sets the FTP password.
Public Property | FtpUserName | Gets and sets the FTP user name.
Public Property | Handle | Gets the window handle that the control is bound to. (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from System.Windows.Forms.Control)
Public Property | Height | Gets or sets the height of the control. (Inherited from System.Windows.Forms.Control)
Public Property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from System.Windows.Forms.Control)
Public Property | InterComponentThumbnailDragDropEnabled | Gets and sets enabling or disabling the component acting as a drag source or drop target for thumbnail image drag and drop operations between other instances of the ThumbnailXpress component.
Public Property | IntraComponentThumbnailDragDropEnabled | Gets and sets enabling or disabling support of drag and drop move operations amongst thumbnail images in the same instance of a ThumbnailXpress component.
Public Property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from System.Windows.Forms.Control)
Public Property | Items | Gets the ThumbnailItemCollection object to access a collection of thumbnail items.
Public Property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from System.Windows.Forms.Control)
Public Property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | LeftMargin | Gets and sets the margin on the left most side of the control.
Public Property | Licensing | Gets the Licensing object to allow user to license ThumbnailXpress.
Public Property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from System.Windows.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | MaximumThreadCount | Gets and sets the maximum number of concurrent worker threads allowed for thumbnail bitmap generation.
Public Property | MaximumThumbnailBitDepth | Gets and sets the maximum bit-depth allowed for the thumbnails.
Public Property | MinimumSize | Gets or sets the size that is the lower limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | Name | Gets or sets the name of the control. (Inherited from System.Windows.Forms.Control)
Public Property | NotateXpressInstance | The instance of NotateXpress, this should be set to the Accusoft.NotateXpressSdk.NotateXpress.InstanceHandle property. Once set annotations can be drawn on thumbnails. Note: NotateXpress is a separate control.
Public Property | Padding | Gets or sets padding within the control. (Inherited from System.Windows.Forms.Control)
Public Property | Parent | Gets or sets the parent container of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ParentForm | Gets the form that the container control is assigned to. (Inherited from System.Windows.Forms.ContainerControl)
Public Property | PdfPassword | Gets and sets the PDF password.
Public Property | PdfRepair | Read/write property accessing the PDF repair flag.
Public Property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from System.Windows.Forms.Control)
Public Property | PreserveBlack | Gets and sets enabling or disabling the PreserveBlack algorithms during thumbnail image generation.
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | ProxyServer | Gets and sets the name or IP address of an optional proxy server.
Public Property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from System.Windows.Forms.Control)
Public Property | Region | Gets or sets the window region associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | RightMargin | Gets and sets the margin on the right most side of the control.
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from System.Windows.Forms.Control)
Public Property | ScrollDirection | Gets and sets the current direction of scrolling.
Public Property | SelectBackColor | Gets and sets the control's selected items cell background color.
Public Property | SelectedItems | Gets the SelectedThumbnailItemCollection object to access a collection of selected thumbnail items.
Public Property | SelectionMode | Gets and sets the item selection mode for the control.
Public Property | ShowHourglass | Gets and sets the displaying of an hourglass cursor when thumbnail images are being loaded from a directory or file.
Public Property | ShowImagePlaceholders | Gets and sets the display of a pre-image-generation 'placeholder' icon.
Public Property | Site | Gets or sets the site of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Size | Gets or sets the height and width of the control. (Inherited from System.Windows.Forms.Control)
Public Property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from System.Windows.Forms.Control)
Public Property | Tag | Gets or sets the object that contains data about the control. (Inherited from System.Windows.Forms.Control)
Public Property | TextBackColor | Gets and sets the control's descriptor text background color.
Public Property | ThreadHungThreshold | Gets and sets the elapsed time threshold (in milliseconds) beyond which a request to obtain a thumbnail should be abandoned.
Public Property | ThreadStartThreshold | Gets and sets the elapsed time threshold (in milliseconds) beyond which a request to obtain a thumbnail should be considered of "extended duration".
Public Property | ThumbnailCache | Gets and sets the thumbnail cache object to adjust cache settings.
Public Property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in. (Inherited from System.Windows.Forms.Control)
Public Property | TopMargin | Gets and sets the margin on the top-most side of the control.
Public Property | TopVisibleItem | Gets the thumbnail item of the top-most visible thumbnail item.
Public Property | UseCameraRawThumbnail | When CameraRaw is true, setting this property will load the embedded thumbnail of the camera raw image which typically loads faster than the full-size image.
Public Property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from System.Windows.Forms.Control)
Public Property | Version | Returns the version of the ThumbnailXpress control at run-time.
Public Property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from System.Windows.Forms.Control)
Public Property | VisibleColumnCount | Gets the number of visible thumbnail columns.
Public Property | VisibleRowCount | Gets the number of visible thumbnail rows.
Public Property | Width | Gets or sets the width of the control. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

ThumbnailXpress Class
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
AllowDrop Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : AllowDrop Property

Glossary Item Box

This generic control property has been replaced by four new properties specific to ThumbnailXpress that allow a finer granularity of control over the types of drag/drop operations the control will allow. The new properties are: IntraComponentThumbnailDragDropEnabled, InterComponentThumbnailDragDropEnabled, EnableAsDragSourceForExternalDragDrop, and EnableAsDropTargetForExternalDragDrop

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Shadows Property AllowDrop As Boolean
'Usage

Dim instance As ThumbnailXpress
Dim value As Boolean

instance.AllowDrop = value

value = instance.AllowDrop
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public new bool AllowDrop {get; set;}
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property new bool get_AllowDrop();
public: __property new void set_AllowDrop(
   bool value
);
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
new property bool AllowDrop {
   bool get();
   void set (    bool value);
}

Property Value

True if drag-and-drop operations are allowed in the control; otherwise, false.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
AnnotationSearchOrder Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : AnnotationSearchOrder Property

Glossary Item Box

This property allows you to specify the different places, in order of importance that ThumbnailXpress should look for associated annotation data when rendering a thumbnail. For each thumbnail that is being rendered, the first rule in the list that successfully points to annotation data will be used to draw those annotations on the thumbnail.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
Public ReadOnly Property AnnotationSearchOrder As AnnotationSearchRuleCollection(Of AnnotationSearchRule)
'Usage

Dim instance As ThumbnailXpress
Dim value As AnnotationSearchRuleCollection(Of AnnotationSearchRule)

value = instance.AnnotationSearchOrder
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public AnnotationSearchRuleCollection<AnnotationSearchRule> AnnotationSearchOrder {get;}
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public: __property AnnotationSearchRuleCollection<AnnotationSearchRule*>* get_AnnotationSearchOrder();
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public:
property AnnotationSearchRuleCollection<AnnotationSearchRule^>^ AnnotationSearchOrder {
   AnnotationSearchRuleCollection<AnnotationSearchRule^>^ get();
}

Remarks

By default, this list is pre-populated to match all internal annotations. So, if you have connected ThumbnailXpress to an instance of NotateXpress, then any image files which contain embedded NotateXpress, Imaging for Windows (WANG), or XFDF (PDF) annotations will have their annotations rendered automatically. But if you have annotation data stored in external files, or if you don't want ThumbnailXpress to search for certain internal annotation data, you can customize this list. You can add both internal and external annotation search rules to the list using instances of InternalAnnotationSearchRule and ExternalAnnotationSearchRule, respectively. An internal rule specifies only the type of annotation data to search for within the image file itself, while an external rule allows you to specify both the annotation type and how the associated annotation file is named in relation to the original image file (it must be named the same as the image file and exist in the same directory but contain a different prefix or suffix, as indicated by your rule).

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
BackColor Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : BackColor Property

Glossary Item Box

Gets and sets the control's unselected items cell background color.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<CategoryAttribute("ThumbnailXpress")>
<DescriptionAttribute("Indicates the control's unselected items cell background color")>
<BrowsableAttribute(True)>
Public Overrides Property BackColor As Color
'Usage

Dim instance As ThumbnailXpress
Dim value As Color

instance.BackColor = value

value = instance.BackColor
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Indicates the control's unselected items cell background color")]
[BrowsableAttribute(true)]
public override Color BackColor {get; set;}
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Indicates the control's unselected items cell background color")]
[BrowsableAttribute(true)]
public: __property Color get_BackColor() override;
public: __property void set_BackColor(
   Color value
) override;
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Indicates the control's unselected items cell background color")]
[BrowsableAttribute(true)]
public:
property Color BackColor {
   Color get() override;
   void set (    Color value) override;
}

Property Value

The System.Drawing.Color value.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
BorderStyle Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : BorderStyle Property

Glossary Item Box

Gets and sets the control's border style.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DescriptionAttribute("Indicates whether the control should have a border.")>
<CategoryAttribute("ThumbnailXpress")>
<BrowsableAttribute(True)>
Public Shadows Property BorderStyle As BorderStyle
'Usage

Dim instance As ThumbnailXpress
Dim value As BorderStyle

instance.BorderStyle = value

value = instance.BorderStyle
[DescriptionAttribute("Indicates whether the control should have a border.")]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
public new BorderStyle BorderStyle {get; set;}
[DescriptionAttribute("Indicates whether the control should have a border.")]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
public: __property new BorderStyle get_BorderStyle();
public: __property new void set_BorderStyle(
   BorderStyle value
);
[DescriptionAttribute("Indicates whether the control should have a border.")]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
public:
new property BorderStyle BorderStyle {
   BorderStyle get();
   void set (    BorderStyle value);
}

Property Value

The border style

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
BottomMargin Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : BottomMargin Property

Glossary Item Box

Gets and sets the margin on the bottom most side of the control.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<CategoryAttribute("ThumbnailXpress")>
<BrowsableAttribute(True)>
<DescriptionAttribute("Indicates the margin on the bottom most side of the control.")>
Public Property BottomMargin As Integer
'Usage

Dim instance As ThumbnailXpress
Dim value As Integer

instance.BottomMargin = value

value = instance.BottomMargin
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
[DescriptionAttribute("Indicates the margin on the bottom most side of the control.")]
public int BottomMargin {get; set;}
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
[DescriptionAttribute("Indicates the margin on the bottom most side of the control.")]
public: __property int get_BottomMargin();
public: __property void set_BottomMargin(
   int value
);
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
[DescriptionAttribute("Indicates the margin on the bottom most side of the control.")]
public:
property int BottomMargin {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the bottom margin.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
CameraRaw Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : CameraRaw Property

Glossary Item Box

Gets and sets enabling or disabling of the camera raw image type detection algorithms during thumbnail image generation.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(True)>
<DescriptionAttribute("Indicates digital camera manufacturer proprietary raw image formats detection.")>
<CategoryAttribute("ThumbnailXpress")>
Public Property CameraRaw As Boolean
'Usage

Dim instance As ThumbnailXpress
Dim value As Boolean

instance.CameraRaw = value

value = instance.CameraRaw
[BrowsableAttribute(true)]
[DescriptionAttribute("Indicates digital camera manufacturer proprietary raw image formats detection.")]
[CategoryAttribute("ThumbnailXpress")]
public bool CameraRaw {get; set;}
[BrowsableAttribute(true)]
[DescriptionAttribute("Indicates digital camera manufacturer proprietary raw image formats detection.")]
[CategoryAttribute("ThumbnailXpress")]
public: __property bool get_CameraRaw();
public: __property void set_CameraRaw(
   bool value
);
[BrowsableAttribute(true)]
[DescriptionAttribute("Indicates digital camera manufacturer proprietary raw image formats detection.")]
[CategoryAttribute("ThumbnailXpress")]
public:
property bool CameraRaw {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true to enable camera raw support. Otherwise, false is used and camera raw is not supported.

Remarks

Note: Setting this to true will slow down thumbnail generation.

Enabling CameraRaw invokes digital camera manufacturer proprietary raw image formats detection algorithms during thumbnail image generation but at the cost of some speed.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
CellBorderColor Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : CellBorderColor Property

Glossary Item Box

Gets and sets the border color of the cells in the control.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(True)>
<DescriptionAttribute("Indicates the border color of the cells in the control.")>
<CategoryAttribute("ThumbnailXpress")>
Public Property CellBorderColor As Color
'Usage

Dim instance As ThumbnailXpress
Dim value As Color

instance.CellBorderColor = value

value = instance.CellBorderColor
[BrowsableAttribute(true)]
[DescriptionAttribute("Indicates the border color of the cells in the control.")]
[CategoryAttribute("ThumbnailXpress")]
public Color CellBorderColor {get; set;}
[BrowsableAttribute(true)]
[DescriptionAttribute("Indicates the border color of the cells in the control.")]
[CategoryAttribute("ThumbnailXpress")]
public: __property Color get_CellBorderColor();
public: __property void set_CellBorderColor(
   Color value
);
[BrowsableAttribute(true)]
[DescriptionAttribute("Indicates the border color of the cells in the control.")]
[CategoryAttribute("ThumbnailXpress")]
public:
property Color CellBorderColor {
   Color get();
   void set (    Color value);
}

Property Value

A System.Drawing.Color value which represents the border color of the cells.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
CellBorderWidth Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : CellBorderWidth Property

Glossary Item Box

Gets and sets the width of the cells in the control.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<CategoryAttribute("ThumbnailXpress")>
<BrowsableAttribute(True)>
<DescriptionAttribute("Indicates the width of the cells in the control.")>
Public Property CellBorderWidth As Integer
'Usage

Dim instance As ThumbnailXpress
Dim value As Integer

instance.CellBorderWidth = value

value = instance.CellBorderWidth
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
[DescriptionAttribute("Indicates the width of the cells in the control.")]
public int CellBorderWidth {get; set;}
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
[DescriptionAttribute("Indicates the width of the cells in the control.")]
public: __property int get_CellBorderWidth();
public: __property void set_CellBorderWidth(
   int value
);
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
[DescriptionAttribute("Indicates the width of the cells in the control.")]
public:
property int CellBorderWidth {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the cell border width.

Remarks

The default value is 1.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
CellHeight Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : CellHeight Property

Glossary Item Box

Gets and sets the height of the cells in the control.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(True)>
<DescriptionAttribute("Indicates the height of the cells in the control.")>
<CategoryAttribute("ThumbnailXpress")>
Public Property CellHeight As Integer
'Usage

Dim instance As ThumbnailXpress
Dim value As Integer

instance.CellHeight = value

value = instance.CellHeight
[BrowsableAttribute(true)]
[DescriptionAttribute("Indicates the height of the cells in the control.")]
[CategoryAttribute("ThumbnailXpress")]
public int CellHeight {get; set;}
[BrowsableAttribute(true)]
[DescriptionAttribute("Indicates the height of the cells in the control.")]
[CategoryAttribute("ThumbnailXpress")]
public: __property int get_CellHeight();
public: __property void set_CellHeight(
   int value
);
[BrowsableAttribute(true)]
[DescriptionAttribute("Indicates the height of the cells in the control.")]
[CategoryAttribute("ThumbnailXpress")]
public:
property int CellHeight {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the cell height.

Remarks

The default value is 80.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
CellHorizontalSpacing Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : CellHorizontalSpacing Property

Glossary Item Box

Gets and sets the spacing between columns.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DescriptionAttribute("Indicates the spacing between columns in the control.")>
<CategoryAttribute("ThumbnailXpress")>
<BrowsableAttribute(True)>
Public Property CellHorizontalSpacing As Integer
'Usage

Dim instance As ThumbnailXpress
Dim value As Integer

instance.CellHorizontalSpacing = value

value = instance.CellHorizontalSpacing
[DescriptionAttribute("Indicates the spacing between columns in the control.")]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
public int CellHorizontalSpacing {get; set;}
[DescriptionAttribute("Indicates the spacing between columns in the control.")]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
public: __property int get_CellHorizontalSpacing();
public: __property void set_CellHorizontalSpacing(
   int value
);
[DescriptionAttribute("Indicates the spacing between columns in the control.")]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
public:
property int CellHorizontalSpacing {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the cell horizontal spacing between columns.

Remarks

The default value is 5.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
CellSpacingColor Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : CellSpacingColor Property

Glossary Item Box

Gets and sets the control's cell spacing color.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DescriptionAttribute("Indicates the control's cell spacing color.")>
<BrowsableAttribute(True)>
<CategoryAttribute("ThumbnailXpress")>
Public Property CellSpacingColor As Color
'Usage

Dim instance As ThumbnailXpress
Dim value As Color

instance.CellSpacingColor = value

value = instance.CellSpacingColor
[DescriptionAttribute("Indicates the control's cell spacing color.")]
[BrowsableAttribute(true)]
[CategoryAttribute("ThumbnailXpress")]
public Color CellSpacingColor {get; set;}
[DescriptionAttribute("Indicates the control's cell spacing color.")]
[BrowsableAttribute(true)]
[CategoryAttribute("ThumbnailXpress")]
public: __property Color get_CellSpacingColor();
public: __property void set_CellSpacingColor(
   Color value
);
[DescriptionAttribute("Indicates the control's cell spacing color.")]
[BrowsableAttribute(true)]
[CategoryAttribute("ThumbnailXpress")]
public:
property Color CellSpacingColor {
   Color get();
   void set (    Color value);
}

Property Value

The System.Drawing.Color value.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
CellVerticalSpacing Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : CellVerticalSpacing Property

Glossary Item Box

Gets and sets the spacing between the rows in the control.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(True)>
<CategoryAttribute("ThumbnailXpress")>
<DescriptionAttribute("Indicates the spacing between the rows in the control.")>
Public Property CellVerticalSpacing As Integer
'Usage

Dim instance As ThumbnailXpress
Dim value As Integer

instance.CellVerticalSpacing = value

value = instance.CellVerticalSpacing
[BrowsableAttribute(true)]
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Indicates the spacing between the rows in the control.")]
public int CellVerticalSpacing {get; set;}
[BrowsableAttribute(true)]
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Indicates the spacing between the rows in the control.")]
public: __property int get_CellVerticalSpacing();
public: __property void set_CellVerticalSpacing(
   int value
);
[BrowsableAttribute(true)]
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Indicates the spacing between the rows in the control.")]
public:
property int CellVerticalSpacing {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the cell vertical spacing between the rows in the control.

Remarks

The default value is 5.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
CellWidth Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : CellWidth Property

Glossary Item Box

Gets and sets the width of the cells in the control.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(True)>
<CategoryAttribute("ThumbnailXpress")>
<DescriptionAttribute("Indicates the width of the cells in the control.")>
Public Property CellWidth As Integer
'Usage

Dim instance As ThumbnailXpress
Dim value As Integer

instance.CellWidth = value

value = instance.CellWidth
[BrowsableAttribute(true)]
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Indicates the width of the cells in the control.")]
public int CellWidth {get; set;}
[BrowsableAttribute(true)]
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Indicates the width of the cells in the control.")]
public: __property int get_CellWidth();
public: __property void set_CellWidth(
   int value
);
[BrowsableAttribute(true)]
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Indicates the width of the cells in the control.")]
public:
property int CellWidth {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the cell width.

Remarks

The default value is 80.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
CustomErrorIcon Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : CustomErrorIcon Property

Glossary Item Box

Specifies the icon to use for errors instead of the stock error icon. ErrorAction must be set to 0 - use error icon.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
Public Property CustomErrorIcon As Icon
'Usage

Dim instance As ThumbnailXpress
Dim value As Icon

instance.CustomErrorIcon = value

value = instance.CustomErrorIcon
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public Icon CustomErrorIcon {get; set;}
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public: __property Icon* get_CustomErrorIcon();
public: __property void set_CustomErrorIcon(
   Icon* value
);
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public:
property Icon^ CustomErrorIcon {
   Icon^ get();
   void set (    Icon^ value);
}

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
CustomGeneratingIcon Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : CustomGeneratingIcon Property

Glossary Item Box

Specifies the icon to use for the pre-image generation placeholder instead of the stock 'generating' icon. ShowImagePlaceholders must be set to true.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
Public Property CustomGeneratingIcon As Icon
'Usage

Dim instance As ThumbnailXpress
Dim value As Icon

instance.CustomGeneratingIcon = value

value = instance.CustomGeneratingIcon
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public Icon CustomGeneratingIcon {get; set;}
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public: __property Icon* get_CustomGeneratingIcon();
public: __property void set_CustomGeneratingIcon(
   Icon* value
);
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public:
property Icon^ CustomGeneratingIcon {
   Icon^ get();
   void set (    Icon^ value);
}

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
DblClickDirectoryDrillDown Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : DblClickDirectoryDrillDown Property

Glossary Item Box

Gets and sets enabling or disabling directory navigation initiated by double-clicking on directory place holder thumbnail images.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(True)>
<DescriptionAttribute("Indicates directory navigation initiated by double-clicking on directory place holder thumbnail images.")>
<CategoryAttribute("ThumbnailXpress")>
Public Property DblClickDirectoryDrillDown As Boolean
'Usage

Dim instance As ThumbnailXpress
Dim value As Boolean

instance.DblClickDirectoryDrillDown = value

value = instance.DblClickDirectoryDrillDown
[BrowsableAttribute(true)]
[DescriptionAttribute("Indicates directory navigation initiated by double-clicking on directory place holder thumbnail images.")]
[CategoryAttribute("ThumbnailXpress")]
public bool DblClickDirectoryDrillDown {get; set;}
[BrowsableAttribute(true)]
[DescriptionAttribute("Indicates directory navigation initiated by double-clicking on directory place holder thumbnail images.")]
[CategoryAttribute("ThumbnailXpress")]
public: __property bool get_DblClickDirectoryDrillDown();
public: __property void set_DblClickDirectoryDrillDown(
   bool value
);
[BrowsableAttribute(true)]
[DescriptionAttribute("Indicates directory navigation initiated by double-clicking on directory place holder thumbnail images.")]
[CategoryAttribute("ThumbnailXpress")]
public:
property bool DblClickDirectoryDrillDown {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true if double click directory drill down. Otherwise, false is used.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Debug Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : Debug Property

Glossary Item Box

Gets and sets the on/off state of the logging system.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
Public Property Debug As Boolean
'Usage

Dim instance As ThumbnailXpress
Dim value As Boolean

instance.Debug = value

value = instance.Debug
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public bool Debug {get; set;}
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public: __property bool get_Debug();
public: __property void set_Debug(
   bool value
);
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public:
property bool Debug {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true to turn on the logging system. Otherwise, false is used.

Remarks

The default value is false.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
DebugErrorLevel Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : DebugErrorLevel Property

Glossary Item Box

Gets and sets the level of detail written to the error log.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property DebugErrorLevel As DebugErrorLevel
'Usage

Dim instance As ThumbnailXpress
Dim value As DebugErrorLevel

instance.DebugErrorLevel = value

value = instance.DebugErrorLevel
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public DebugErrorLevel DebugErrorLevel {get; set;}
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property DebugErrorLevel get_DebugErrorLevel();
public: __property void set_DebugErrorLevel(
   DebugErrorLevel value
);
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property DebugErrorLevel DebugErrorLevel {
   DebugErrorLevel get();
   void set (    DebugErrorLevel value);
}

Property Value

A DebugErrorLevel enumeration value which determines the level of error logging to write to the DebugLogFile.

Remarks

The default value is Production.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
DebugLogFile Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : DebugLogFile Property

Glossary Item Box

Gets and sets the log file location.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
Public Property DebugLogFile As String
'Usage

Dim instance As ThumbnailXpress
Dim value As String

instance.DebugLogFile = value

value = instance.DebugLogFile
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public string DebugLogFile {get; set;}
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public: __property string* get_DebugLogFile();
public: __property void set_DebugLogFile(
   string* value
);
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public:
property String^ DebugLogFile {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value which represents the directory where the log file is written to.

Remarks

The default value is an empty string "".

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
DescriptorAlignment Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : DescriptorAlignment Property

Glossary Item Box

Gets and sets the alignment of the descriptor text.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(True)>
<DescriptionAttribute("Indicates the alignment of the descriptor text.")>
<CategoryAttribute("ThumbnailXpress")>
Public Property DescriptorAlignment As DescriptorAlignments
'Usage

Dim instance As ThumbnailXpress
Dim value As DescriptorAlignments

instance.DescriptorAlignment = value

value = instance.DescriptorAlignment
[BrowsableAttribute(true)]
[DescriptionAttribute("Indicates the alignment of the descriptor text.")]
[CategoryAttribute("ThumbnailXpress")]
public DescriptorAlignments DescriptorAlignment {get; set;}
[BrowsableAttribute(true)]
[DescriptionAttribute("Indicates the alignment of the descriptor text.")]
[CategoryAttribute("ThumbnailXpress")]
public: __property DescriptorAlignments get_DescriptorAlignment();
public: __property void set_DescriptorAlignment(
   DescriptorAlignments value
);
[BrowsableAttribute(true)]
[DescriptionAttribute("Indicates the alignment of the descriptor text.")]
[CategoryAttribute("ThumbnailXpress")]
public:
property DescriptorAlignments DescriptorAlignment {
   DescriptorAlignments get();
   void set (    DescriptorAlignments value);
}

Property Value

An DescriptorAlignments enumeration value.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
DescriptorDisplayMethod Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : DescriptorDisplayMethod Property

Glossary Item Box

Gets and sets the method allowing selection of the source of the descriptor text content.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DescriptionAttribute("Indicates the source of the descriptor text content.")>
<BrowsableAttribute(True)>
<CategoryAttribute("ThumbnailXpress")>
Public Property DescriptorDisplayMethod As DescriptorDisplayMethods
'Usage

Dim instance As ThumbnailXpress
Dim value As DescriptorDisplayMethods

instance.DescriptorDisplayMethod = value

value = instance.DescriptorDisplayMethod
[DescriptionAttribute("Indicates the source of the descriptor text content.")]
[BrowsableAttribute(true)]
[CategoryAttribute("ThumbnailXpress")]
public DescriptorDisplayMethods DescriptorDisplayMethod {get; set;}
[DescriptionAttribute("Indicates the source of the descriptor text content.")]
[BrowsableAttribute(true)]
[CategoryAttribute("ThumbnailXpress")]
public: __property DescriptorDisplayMethods get_DescriptorDisplayMethod();
public: __property void set_DescriptorDisplayMethod(
   DescriptorDisplayMethods value
);
[DescriptionAttribute("Indicates the source of the descriptor text content.")]
[BrowsableAttribute(true)]
[CategoryAttribute("ThumbnailXpress")]
public:
property DescriptorDisplayMethods DescriptorDisplayMethod {
   DescriptorDisplayMethods get();
   void set (    DescriptorDisplayMethods value);
}

Property Value

The DescriptorDisplayMethods which allow selection of the source of the descriptor text content.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
DisplayRectangle Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : DisplayRectangle Property

Glossary Item Box

Gets the current area being displayed.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
<EditorBrowsableAttribute()>
Public Overrides ReadOnly Property DisplayRectangle As Rectangle
'Usage

Dim instance As ThumbnailXpress
Dim value As Rectangle

value = instance.DisplayRectangle
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
[EditorBrowsableAttribute()]
public override Rectangle DisplayRectangle {get;}
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
[EditorBrowsableAttribute()]
public: __property Rectangle get_DisplayRectangle() override;
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
[EditorBrowsableAttribute()]
public:
property Rectangle DisplayRectangle {
   Rectangle get() override;
}

Property Value

A System.Drawing.Rectangle that represents the display area of the control.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
EnableAsDragSourceForExternalDragDrop Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : EnableAsDragSourceForExternalDragDrop Property

Glossary Item Box

Gets and sets enabling or disabling the component acting as a drag source for dragging thumbnail images to other applications. Any application that supports acting as a drop target for the CF_DIB clipboard/drag-drop format can be a thumbnail image drop recipient.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DescriptionAttribute("Indicates drag and drop for dragging thumbnail images to other applications.")>
<BrowsableAttribute(True)>
<CategoryAttribute("ThumbnailXpress")>
Public Property EnableAsDragSourceForExternalDragDrop As Boolean
'Usage

Dim instance As ThumbnailXpress
Dim value As Boolean

instance.EnableAsDragSourceForExternalDragDrop = value

value = instance.EnableAsDragSourceForExternalDragDrop
[DescriptionAttribute("Indicates drag and drop for dragging thumbnail images to other applications.")]
[BrowsableAttribute(true)]
[CategoryAttribute("ThumbnailXpress")]
public bool EnableAsDragSourceForExternalDragDrop {get; set;}
[DescriptionAttribute("Indicates drag and drop for dragging thumbnail images to other applications.")]
[BrowsableAttribute(true)]
[CategoryAttribute("ThumbnailXpress")]
public: __property bool get_EnableAsDragSourceForExternalDragDrop();
public: __property void set_EnableAsDragSourceForExternalDragDrop(
   bool value
);
[DescriptionAttribute("Indicates drag and drop for dragging thumbnail images to other applications.")]
[BrowsableAttribute(true)]
[CategoryAttribute("ThumbnailXpress")]
public:
property bool EnableAsDragSourceForExternalDragDrop {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true to support drag and drop as a source. Otherwise, false should be used.

Remarks

Both copy and move operations are supported.

Any applications that support drag and drop format can be a thumbnail image drag/drop recipient. Both copy and move operations are supported.

Note: According to Microsoft, for security reasons, drag/drop capabilities are disallowed between windows with different security level permissions.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
EnableAsDropTargetForExternalDragDrop Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : EnableAsDropTargetForExternalDragDrop Property

Glossary Item Box

Gets and sets enabling or disabling the component acting as a drop target for other applications to drag files onto the component to display those files as thumbnail images.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DescriptionAttribute("Indicates drop target for dragging thumbnail images to other applications.")>
<BrowsableAttribute(True)>
<CategoryAttribute("ThumbnailXpress")>
Public Property EnableAsDropTargetForExternalDragDrop As Boolean
'Usage

Dim instance As ThumbnailXpress
Dim value As Boolean

instance.EnableAsDropTargetForExternalDragDrop = value

value = instance.EnableAsDropTargetForExternalDragDrop
[DescriptionAttribute("Indicates drop target for dragging thumbnail images to other applications.")]
[BrowsableAttribute(true)]
[CategoryAttribute("ThumbnailXpress")]
public bool EnableAsDropTargetForExternalDragDrop {get; set;}
[DescriptionAttribute("Indicates drop target for dragging thumbnail images to other applications.")]
[BrowsableAttribute(true)]
[CategoryAttribute("ThumbnailXpress")]
public: __property bool get_EnableAsDropTargetForExternalDragDrop();
public: __property void set_EnableAsDropTargetForExternalDragDrop(
   bool value
);
[DescriptionAttribute("Indicates drop target for dragging thumbnail images to other applications.")]
[BrowsableAttribute(true)]
[CategoryAttribute("ThumbnailXpress")]
public:
property bool EnableAsDropTargetForExternalDragDrop {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true to support drag and drop as a target. Otherwise, false should be used.

Remarks

Both copy and move operations are supported.

Any applications that support drag and drop format can be a thumbnail image drag/drop recipient. Both copy and move operations are supported.

Note: According to Microsoft, for security reasons, drag/drop capabilities are disallowed between windows with different security level permissions.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
ErrorAction Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : ErrorAction Property

Glossary Item Box

Gets and sets the type of display action taken when a thumbnail generation error occurs.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DescriptionAttribute("Indicates the type of display action taken when a thumbnail generation error occurs.")>
<BrowsableAttribute(True)>
<CategoryAttribute("ThumbnailXpress")>
Public Property ErrorAction As ErrorAction
'Usage

Dim instance As ThumbnailXpress
Dim value As ErrorAction

instance.ErrorAction = value

value = instance.ErrorAction
[DescriptionAttribute("Indicates the type of display action taken when a thumbnail generation error occurs.")]
[BrowsableAttribute(true)]
[CategoryAttribute("ThumbnailXpress")]
public ErrorAction ErrorAction {get; set;}
[DescriptionAttribute("Indicates the type of display action taken when a thumbnail generation error occurs.")]
[BrowsableAttribute(true)]
[CategoryAttribute("ThumbnailXpress")]
public: __property ErrorAction get_ErrorAction();
public: __property void set_ErrorAction(
   ErrorAction value
);
[DescriptionAttribute("Indicates the type of display action taken when a thumbnail generation error occurs.")]
[BrowsableAttribute(true)]
[CategoryAttribute("ThumbnailXpress")]
public:
property ErrorAction ErrorAction {
   ErrorAction get();
   void set (    ErrorAction value);
}

Property Value

An ErrorAction.

Remarks

The default value is ErrorAction.UseErrorIcon.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Filters Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : Filters Property

Glossary Item Box

Gets the FilterCollection object to access a collection of filters.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property Filters As FilterCollection
'Usage

Dim instance As ThumbnailXpress
Dim value As FilterCollection

value = instance.Filters
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public FilterCollection Filters {get;}
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property FilterCollection* get_Filters();
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property FilterCollection^ Filters {
   FilterCollection^ get();
}

Property Value

The FilterCollection object.

Remarks

Note: The enumerator must be locked before the collection can be enumerated using a foreach loop by calling FilterCollectionEnumerator.Lock, otherwise an InvalidOperationException is thrown.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Font Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : Font Property

Glossary Item Box

Gets and sets the thumbnail descriptor font.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DescriptionAttribute("Indicates the control's descriptor font.")>
<CategoryAttribute("ThumbnailXpress")>
<BrowsableAttribute(True)>
Public Overrides Property Font As Font
'Usage

Dim instance As ThumbnailXpress
Dim value As Font

instance.Font = value

value = instance.Font
[DescriptionAttribute("Indicates the control's descriptor font.")]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
public override Font Font {get; set;}
[DescriptionAttribute("Indicates the control's descriptor font.")]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
public: __property Font* get_Font() override;
public: __property void set_Font(
   Font* value
) override;
[DescriptionAttribute("Indicates the control's descriptor font.")]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
public:
property Font^ Font {
   Font^ get() override;
   void set (    Font^ value) override;
}

Property Value

The System.Drawing.Font value.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
ForeColor Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : ForeColor Property

Glossary Item Box

Gets and sets the controls foreground color.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(True)>
<DescriptionAttribute("Indicates the control's color of any descriptor text")>
<CategoryAttribute("ThumbnailXpress")>
Public Overrides Property ForeColor As Color
'Usage

Dim instance As ThumbnailXpress
Dim value As Color

instance.ForeColor = value

value = instance.ForeColor
[BrowsableAttribute(true)]
[DescriptionAttribute("Indicates the control's color of any descriptor text")]
[CategoryAttribute("ThumbnailXpress")]
public override Color ForeColor {get; set;}
[BrowsableAttribute(true)]
[DescriptionAttribute("Indicates the control's color of any descriptor text")]
[CategoryAttribute("ThumbnailXpress")]
public: __property Color get_ForeColor() override;
public: __property void set_ForeColor(
   Color value
) override;
[BrowsableAttribute(true)]
[DescriptionAttribute("Indicates the control's color of any descriptor text")]
[CategoryAttribute("ThumbnailXpress")]
public:
property Color ForeColor {
   Color get() override;
   void set (    Color value) override;
}

Property Value

The System.Drawing.Color value.

Remarks

This is the color of any descriptor text.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
FtpPassword Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : FtpPassword Property

Glossary Item Box

Gets and sets the FTP password.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<CategoryAttribute("ThumbnailXpress")>
<BrowsableAttribute(True)>
<DescriptionAttribute("Indicates the password for accesing secured FTP files on the internet.")>
Public Property FtpPassword As String
'Usage

Dim instance As ThumbnailXpress
Dim value As String

instance.FtpPassword = value

value = instance.FtpPassword
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
[DescriptionAttribute("Indicates the password for accesing secured FTP files on the internet.")]
public string FtpPassword {get; set;}
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
[DescriptionAttribute("Indicates the password for accesing secured FTP files on the internet.")]
public: __property string* get_FtpPassword();
public: __property void set_FtpPassword(
   string* value
);
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
[DescriptionAttribute("Indicates the password for accesing secured FTP files on the internet.")]
public:
property String^ FtpPassword {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value which represents the FTP password.

Remarks

This operates for individual files.

The FTP password is used for accessing files on the Internet when a thumbnail item's Filename property is set to an ftp or http address.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
FtpUserName Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : FtpUserName Property

Glossary Item Box

Gets and sets the FTP user name.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<CategoryAttribute("ThumbnailXpress")>
<DescriptionAttribute("Indicates the username for accesing secured FTP files on the internet.")>
<BrowsableAttribute(True)>
Public Property FtpUserName As String
'Usage

Dim instance As ThumbnailXpress
Dim value As String

instance.FtpUserName = value

value = instance.FtpUserName
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Indicates the username for accesing secured FTP files on the internet.")]
[BrowsableAttribute(true)]
public string FtpUserName {get; set;}
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Indicates the username for accesing secured FTP files on the internet.")]
[BrowsableAttribute(true)]
public: __property string* get_FtpUserName();
public: __property void set_FtpUserName(
   string* value
);
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Indicates the username for accesing secured FTP files on the internet.")]
[BrowsableAttribute(true)]
public:
property String^ FtpUserName {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value which represents the FTP username.

Remarks

This operates for individual files

The FTP user name is used for accessing files on the Internet when a thumbnail item's Filename property is set to an ftp or http address.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
InterComponentThumbnailDragDropEnabled Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : InterComponentThumbnailDragDropEnabled Property

Glossary Item Box

Gets and sets enabling or disabling the component acting as a drag source or drop target for thumbnail image drag and drop operations between other instances of the ThumbnailXpress component.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(True)>
<DescriptionAttribute("Indicates drag and drop move operations between other instances.")>
<CategoryAttribute("ThumbnailXpress")>
Public Property InterComponentThumbnailDragDropEnabled As Boolean
'Usage

Dim instance As ThumbnailXpress
Dim value As Boolean

instance.InterComponentThumbnailDragDropEnabled = value

value = instance.InterComponentThumbnailDragDropEnabled
[BrowsableAttribute(true)]
[DescriptionAttribute("Indicates drag and drop move operations between other instances.")]
[CategoryAttribute("ThumbnailXpress")]
public bool InterComponentThumbnailDragDropEnabled {get; set;}
[BrowsableAttribute(true)]
[DescriptionAttribute("Indicates drag and drop move operations between other instances.")]
[CategoryAttribute("ThumbnailXpress")]
public: __property bool get_InterComponentThumbnailDragDropEnabled();
public: __property void set_InterComponentThumbnailDragDropEnabled(
   bool value
);
[BrowsableAttribute(true)]
[DescriptionAttribute("Indicates drag and drop move operations between other instances.")]
[CategoryAttribute("ThumbnailXpress")]
public:
property bool InterComponentThumbnailDragDropEnabled {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true to support drag and drop as a target. Otherwise, false should be used.

Remarks

Both copy and move operations are supported.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
IntraComponentThumbnailDragDropEnabled Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : IntraComponentThumbnailDragDropEnabled Property

Glossary Item Box

Gets and sets enabling or disabling support of drag and drop move operations amongst thumbnail images in the same instance of a ThumbnailXpress component.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<CategoryAttribute("ThumbnailXpress")>
<DescriptionAttribute("Indicates drag and drop move operations amongst thumbnail images in the same instance.")>
<BrowsableAttribute(True)>
Public Property IntraComponentThumbnailDragDropEnabled As Boolean
'Usage

Dim instance As ThumbnailXpress
Dim value As Boolean

instance.IntraComponentThumbnailDragDropEnabled = value

value = instance.IntraComponentThumbnailDragDropEnabled
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Indicates drag and drop move operations amongst thumbnail images in the same instance.")]
[BrowsableAttribute(true)]
public bool IntraComponentThumbnailDragDropEnabled {get; set;}
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Indicates drag and drop move operations amongst thumbnail images in the same instance.")]
[BrowsableAttribute(true)]
public: __property bool get_IntraComponentThumbnailDragDropEnabled();
public: __property void set_IntraComponentThumbnailDragDropEnabled(
   bool value
);
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Indicates drag and drop move operations amongst thumbnail images in the same instance.")]
[BrowsableAttribute(true)]
public:
property bool IntraComponentThumbnailDragDropEnabled {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true to support drag and drop within the same instance of a ThumbnailXpress component. Otherwise, false is used.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Items Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : Items Property

Glossary Item Box

Gets the ThumbnailItemCollection object to access a collection of thumbnail items.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property Items As ThumbnailItemCollection
'Usage

Dim instance As ThumbnailXpress
Dim value As ThumbnailItemCollection

value = instance.Items
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public ThumbnailItemCollection Items {get;}
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property ThumbnailItemCollection* get_Items();
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property ThumbnailItemCollection^ Items {
   ThumbnailItemCollection^ get();
}

Property Value

The ThumbnailItemCollection object which contains a collection of thumbnail items.

Remarks

Note: The enumerator must be locked before the collection can be enumerated using a foreach loop by calling ThumbnailItemCollectionEnumerator.Lock, otherwise an InvalidOperationException is thrown.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
LeftMargin Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : LeftMargin Property

Glossary Item Box

Gets and sets the margin on the left most side of the control.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DescriptionAttribute("Indicates the margin on the left most side of the control.")>
<BrowsableAttribute(True)>
<CategoryAttribute("ThumbnailXpress")>
Public Property LeftMargin As Integer
'Usage

Dim instance As ThumbnailXpress
Dim value As Integer

instance.LeftMargin = value

value = instance.LeftMargin
[DescriptionAttribute("Indicates the margin on the left most side of the control.")]
[BrowsableAttribute(true)]
[CategoryAttribute("ThumbnailXpress")]
public int LeftMargin {get; set;}
[DescriptionAttribute("Indicates the margin on the left most side of the control.")]
[BrowsableAttribute(true)]
[CategoryAttribute("ThumbnailXpress")]
public: __property int get_LeftMargin();
public: __property void set_LeftMargin(
   int value
);
[DescriptionAttribute("Indicates the margin on the left most side of the control.")]
[BrowsableAttribute(true)]
[CategoryAttribute("ThumbnailXpress")]
public:
property int LeftMargin {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the left margin.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Licensing Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : Licensing Property

Glossary Item Box

Gets the Licensing object to allow user to license ThumbnailXpress.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property Licensing As Licensing
'Usage

Dim instance As ThumbnailXpress
Dim value As Licensing

value = instance.Licensing
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public Licensing Licensing {get;}
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property Licensing* get_Licensing();
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property Licensing^ Licensing {
   Licensing^ get();
}

Property Value

The Licensing object value set.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
MaximumThreadCount Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : MaximumThreadCount Property

Glossary Item Box

Gets and sets the maximum number of concurrent worker threads allowed for thumbnail bitmap generation.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
Public Property MaximumThreadCount As Integer
'Usage

Dim instance As ThumbnailXpress
Dim value As Integer

instance.MaximumThreadCount = value

value = instance.MaximumThreadCount
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public int MaximumThreadCount {get; set;}
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public: __property int get_MaximumThreadCount();
public: __property void set_MaximumThreadCount(
   int value
);
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public:
property int MaximumThreadCount {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the maximum thread count.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
MaximumThumbnailBitDepth Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : MaximumThumbnailBitDepth Property

Glossary Item Box

Gets and sets the maximum bit-depth allowed for the thumbnails.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<CategoryAttribute("ThumbnailXpress")>
<DescriptionAttribute("Indicates the maximum bit depth allowed for the thumbnails.")>
<BrowsableAttribute(True)>
Public Property MaximumThumbnailBitDepth As Integer
'Usage

Dim instance As ThumbnailXpress
Dim value As Integer

instance.MaximumThumbnailBitDepth = value

value = instance.MaximumThumbnailBitDepth
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Indicates the maximum bit depth allowed for the thumbnails.")]
[BrowsableAttribute(true)]
public int MaximumThumbnailBitDepth {get; set;}
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Indicates the maximum bit depth allowed for the thumbnails.")]
[BrowsableAttribute(true)]
public: __property int get_MaximumThumbnailBitDepth();
public: __property void set_MaximumThumbnailBitDepth(
   int value
);
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Indicates the maximum bit depth allowed for the thumbnails.")]
[BrowsableAttribute(true)]
public:
property int MaximumThumbnailBitDepth {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the maximum thumbnail bit-depth.

Remarks

The default value is 24.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
NotateXpressInstance Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : NotateXpressInstance Property

Glossary Item Box

The instance of NotateXpress, this should be set to the Accusoft.NotateXpressSdk.NotateXpress.InstanceHandle property. Once set annotations can be drawn on thumbnails. Note: NotateXpress is a separate control.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public Property NotateXpressInstance As IntPtr
'Usage

Dim instance As ThumbnailXpress
Dim value As IntPtr

instance.NotateXpressInstance = value

value = instance.NotateXpressInstance
[BrowsableAttribute(false)]
public IntPtr NotateXpressInstance {get; set;}
[BrowsableAttribute(false)]
public: __property IntPtr get_NotateXpressInstance();
public: __property void set_NotateXpressInstance(
   IntPtr value
);
[BrowsableAttribute(false)]
public:
property IntPtr NotateXpressInstance {
   IntPtr get();
   void set (    IntPtr value);
}

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
PdfPassword Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : PdfPassword Property

Glossary Item Box

Gets and sets the PDF password.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
<CategoryAttribute("ThumbnailXpress")>
<DescriptionAttribute("Indicates the password for accesing secured PDF files.")>
Public Property PdfPassword As String
'Usage

Dim instance As ThumbnailXpress
Dim value As String

instance.PdfPassword = value

value = instance.PdfPassword
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Indicates the password for accesing secured PDF files.")]
public string PdfPassword {get; set;}
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Indicates the password for accesing secured PDF files.")]
public: __property string* get_PdfPassword();
public: __property void set_PdfPassword(
   string* value
);
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Indicates the password for accesing secured PDF files.")]
public:
property String^ PdfPassword {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value which represents the PDF password.

Remarks

This operates for individual files.

The PDF password is used for accessing single PDF files when a thumbnail item is a known PDF with a password.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
PdfRepair Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : PdfRepair Property

Glossary Item Box

Read/write property accessing the PDF repair flag.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(False)>
<CategoryAttribute("ThumbnailXpress")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<DescriptionAttribute("Indicates to repair PDF files.")>
Public Property PdfRepair As Boolean
'Usage

Dim instance As ThumbnailXpress
Dim value As Boolean

instance.PdfRepair = value

value = instance.PdfRepair
[BrowsableAttribute(false)]
[CategoryAttribute("ThumbnailXpress")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DescriptionAttribute("Indicates to repair PDF files.")]
public bool PdfRepair {get; set;}
[BrowsableAttribute(false)]
[CategoryAttribute("ThumbnailXpress")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DescriptionAttribute("Indicates to repair PDF files.")]
public: __property bool get_PdfRepair();
public: __property void set_PdfRepair(
   bool value
);
[BrowsableAttribute(false)]
[CategoryAttribute("ThumbnailXpress")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[DescriptionAttribute("Indicates to repair PDF files.")]
public:
property bool PdfRepair {
   bool get();
   void set (    bool value);
}

Property Value

The PDF repair flag, which is true to repair the PDF file while opening it.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
PreserveBlack Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : PreserveBlack Property

Glossary Item Box

Gets and sets enabling or disabling the PreserveBlack algorithms during thumbnail image generation.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(True)>
<CategoryAttribute("ThumbnailXpress")>
<DescriptionAttribute("Indicates preservation of black details (like lines) when reducing black on white images to thumbnail size.")>
Public Property PreserveBlack As Boolean
'Usage

Dim instance As ThumbnailXpress
Dim value As Boolean

instance.PreserveBlack = value

value = instance.PreserveBlack
[BrowsableAttribute(true)]
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Indicates preservation of black details (like lines) when reducing black on white images to thumbnail size.")]
public bool PreserveBlack {get; set;}
[BrowsableAttribute(true)]
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Indicates preservation of black details (like lines) when reducing black on white images to thumbnail size.")]
public: __property bool get_PreserveBlack();
public: __property void set_PreserveBlack(
   bool value
);
[BrowsableAttribute(true)]
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Indicates preservation of black details (like lines) when reducing black on white images to thumbnail size.")]
public:
property bool PreserveBlack {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true to preserve black fine lines. Otherwise, false is used and black lines are not preserved during thumbnail generation.

Remarks

Enabling this property enhances preservation of black details (like lines) when reducing black on white images to thumbnail size.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
ProxyServer Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : ProxyServer Property

Glossary Item Box

Gets and sets the name or IP address of an optional proxy server.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(True)>
<CategoryAttribute("ThumbnailXpress")>
<DescriptionAttribute("Indicates the proxy server.")>
Public Property ProxyServer As String
'Usage

Dim instance As ThumbnailXpress
Dim value As String

instance.ProxyServer = value

value = instance.ProxyServer
[BrowsableAttribute(true)]
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Indicates the proxy server.")]
public string ProxyServer {get; set;}
[BrowsableAttribute(true)]
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Indicates the proxy server.")]
public: __property string* get_ProxyServer();
public: __property void set_ProxyServer(
   string* value
);
[BrowsableAttribute(true)]
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Indicates the proxy server.")]
public:
property String^ ProxyServer {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value which represents the proxy server.

Remarks

The ProxyServer property applies only when reading image files from an http or ftp address. Many organizations use a proxy server to allow individual computers to access the Internet through their local area network (LAN). The ProxyServer property specifies the name of the proxy server, which can be a word such as "MyProxyServer," or an Internet Protocol address such as "192.68.112.56".

If the computer uses a direct connection such as Dial-Up Networking, the computer does not use a proxy server and this property should not be set.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
RightMargin Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : RightMargin Property

Glossary Item Box

Gets and sets the margin on the right most side of the control.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DescriptionAttribute("Indicates the margin on the right most side of the control.")>
<CategoryAttribute("ThumbnailXpress")>
<BrowsableAttribute(True)>
Public Property RightMargin As Integer
'Usage

Dim instance As ThumbnailXpress
Dim value As Integer

instance.RightMargin = value

value = instance.RightMargin
[DescriptionAttribute("Indicates the margin on the right most side of the control.")]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
public int RightMargin {get; set;}
[DescriptionAttribute("Indicates the margin on the right most side of the control.")]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
public: __property int get_RightMargin();
public: __property void set_RightMargin(
   int value
);
[DescriptionAttribute("Indicates the margin on the right most side of the control.")]
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
public:
property int RightMargin {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the right margin.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
ScrollDirection Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : ScrollDirection Property

Glossary Item Box

Gets and sets the current direction of scrolling.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(True)>
<CategoryAttribute("ThumbnailXpress")>
<DescriptionAttribute("Indicates the current direction of scrolling.")>
Public Property ScrollDirection As ScrollDirection
'Usage

Dim instance As ThumbnailXpress
Dim value As ScrollDirection

instance.ScrollDirection = value

value = instance.ScrollDirection
[BrowsableAttribute(true)]
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Indicates the current direction of scrolling.")]
public ScrollDirection ScrollDirection {get; set;}
[BrowsableAttribute(true)]
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Indicates the current direction of scrolling.")]
public: __property ScrollDirection get_ScrollDirection();
public: __property void set_ScrollDirection(
   ScrollDirection value
);
[BrowsableAttribute(true)]
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Indicates the current direction of scrolling.")]
public:
property ScrollDirection ScrollDirection {
   ScrollDirection get();
   void set (    ScrollDirection value);
}

Property Value

A ScrollDirection enumeration value which represents the scroll direction.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members
ScrollDirection Enumeration


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
SelectBackColor Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : SelectBackColor Property

Glossary Item Box

Gets and sets the control's selected items cell background color.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DescriptionAttribute("Indicates the control's selected items cell background color.")>
<BrowsableAttribute(True)>
<CategoryAttribute("ThumbnailXpress")>
Public Property SelectBackColor As Color
'Usage

Dim instance As ThumbnailXpress
Dim value As Color

instance.SelectBackColor = value

value = instance.SelectBackColor
[DescriptionAttribute("Indicates the control's selected items cell background color.")]
[BrowsableAttribute(true)]
[CategoryAttribute("ThumbnailXpress")]
public Color SelectBackColor {get; set;}
[DescriptionAttribute("Indicates the control's selected items cell background color.")]
[BrowsableAttribute(true)]
[CategoryAttribute("ThumbnailXpress")]
public: __property Color get_SelectBackColor();
public: __property void set_SelectBackColor(
   Color value
);
[DescriptionAttribute("Indicates the control's selected items cell background color.")]
[BrowsableAttribute(true)]
[CategoryAttribute("ThumbnailXpress")]
public:
property Color SelectBackColor {
   Color get();
   void set (    Color value);
}

Property Value

The System.Drawing.Color value.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
SelectedItems Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : SelectedItems Property

Glossary Item Box

Gets the SelectedThumbnailItemCollection object to access a collection of selected thumbnail items.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property SelectedItems As SelectedThumbnailItemCollection
'Usage

Dim instance As ThumbnailXpress
Dim value As SelectedThumbnailItemCollection

value = instance.SelectedItems
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public SelectedThumbnailItemCollection SelectedItems {get;}
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property SelectedThumbnailItemCollection* get_SelectedItems();
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property SelectedThumbnailItemCollection^ SelectedItems {
   SelectedThumbnailItemCollection^ get();
}

Property Value

The SelectedThumbnailItemCollection object.

Remarks

Note: The enumerator must be locked before the collection can be enumerated using a foreach loop by calling SelectedThumbnailItemCollectionEnumerator.Lock, otherwise an InvalidOperationException is thrown.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
SelectionMode Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : SelectionMode Property

Glossary Item Box

Gets and sets the item selection mode for the control.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<CategoryAttribute("ThumbnailXpress")>
<BrowsableAttribute(True)>
<DescriptionAttribute("Indicates the item selection mode for the control.")>
Public Property SelectionMode As SelectionMode
'Usage

Dim instance As ThumbnailXpress
Dim value As SelectionMode

instance.SelectionMode = value

value = instance.SelectionMode
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
[DescriptionAttribute("Indicates the item selection mode for the control.")]
public SelectionMode SelectionMode {get; set;}
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
[DescriptionAttribute("Indicates the item selection mode for the control.")]
public: __property SelectionMode get_SelectionMode();
public: __property void set_SelectionMode(
   SelectionMode value
);
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
[DescriptionAttribute("Indicates the item selection mode for the control.")]
public:
property SelectionMode SelectionMode {
   SelectionMode get();
   void set (    SelectionMode value);
}

Property Value

The SelectionMode enumeration value.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
ShowHourglass Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : ShowHourglass Property

Glossary Item Box

Gets and sets the displaying of an hourglass cursor when thumbnail images are being loaded from a directory or file.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(True)>
<DescriptionAttribute("Indicates the displaying of an hourglass cursor when thumbnail images are being loaded from a directory or file")>
<CategoryAttribute("ThumbnailXpress")>
Public Property ShowHourglass As Boolean
'Usage

Dim instance As ThumbnailXpress
Dim value As Boolean

instance.ShowHourglass = value

value = instance.ShowHourglass
[BrowsableAttribute(true)]
[DescriptionAttribute("Indicates the displaying of an hourglass cursor when thumbnail images are being loaded from a directory or file")]
[CategoryAttribute("ThumbnailXpress")]
public bool ShowHourglass {get; set;}
[BrowsableAttribute(true)]
[DescriptionAttribute("Indicates the displaying of an hourglass cursor when thumbnail images are being loaded from a directory or file")]
[CategoryAttribute("ThumbnailXpress")]
public: __property bool get_ShowHourglass();
public: __property void set_ShowHourglass(
   bool value
);
[BrowsableAttribute(true)]
[DescriptionAttribute("Indicates the displaying of an hourglass cursor when thumbnail images are being loaded from a directory or file")]
[CategoryAttribute("ThumbnailXpress")]
public:
property bool ShowHourglass {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true to display an hourglass when thumbnail images are being loaded. Otherwise, false should be used.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
ShowImagePlaceholders Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : ShowImagePlaceholders Property

Glossary Item Box

Gets and sets the display of a pre-image-generation 'placeholder' icon.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<CategoryAttribute("ThumbnailXpress")>
<DescriptionAttribute("Indicates the displaying of a pre-image-generation 'placeholder' icon.")>
<BrowsableAttribute(True)>
Public Property ShowImagePlaceholders As Boolean
'Usage

Dim instance As ThumbnailXpress
Dim value As Boolean

instance.ShowImagePlaceholders = value

value = instance.ShowImagePlaceholders
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Indicates the displaying of a pre-image-generation 'placeholder' icon.")]
[BrowsableAttribute(true)]
public bool ShowImagePlaceholders {get; set;}
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Indicates the displaying of a pre-image-generation 'placeholder' icon.")]
[BrowsableAttribute(true)]
public: __property bool get_ShowImagePlaceholders();
public: __property void set_ShowImagePlaceholders(
   bool value
);
[CategoryAttribute("ThumbnailXpress")]
[DescriptionAttribute("Indicates the displaying of a pre-image-generation 'placeholder' icon.")]
[BrowsableAttribute(true)]
public:
property bool ShowImagePlaceholders {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true to display placeholders. Otherwise, false is used.

Remarks

The default value is false.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
TextBackColor Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : TextBackColor Property

Glossary Item Box

Gets and sets the control's descriptor text background color.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<CategoryAttribute("ThumbnailXpress")>
<BrowsableAttribute(True)>
<DescriptionAttribute("Indicates the control's controls descriptor text background color.")>
Public Property TextBackColor As Color
'Usage

Dim instance As ThumbnailXpress
Dim value As Color

instance.TextBackColor = value

value = instance.TextBackColor
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
[DescriptionAttribute("Indicates the control's controls descriptor text background color.")]
public Color TextBackColor {get; set;}
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
[DescriptionAttribute("Indicates the control's controls descriptor text background color.")]
public: __property Color get_TextBackColor();
public: __property void set_TextBackColor(
   Color value
);
[CategoryAttribute("ThumbnailXpress")]
[BrowsableAttribute(true)]
[DescriptionAttribute("Indicates the control's controls descriptor text background color.")]
public:
property Color TextBackColor {
   Color get();
   void set (    Color value);
}

Property Value

The System.Drawing.Color value.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
ThreadHungThreshold Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : ThreadHungThreshold Property

Glossary Item Box

Gets and sets the elapsed time threshold (in milliseconds) beyond which a request to obtain a thumbnail should be abandoned.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
Public Property ThreadHungThreshold As Integer
'Usage

Dim instance As ThumbnailXpress
Dim value As Integer

instance.ThreadHungThreshold = value

value = instance.ThreadHungThreshold
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public int ThreadHungThreshold {get; set;}
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public: __property int get_ThreadHungThreshold();
public: __property void set_ThreadHungThreshold(
   int value
);
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public:
property int ThreadHungThreshold {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the thread hung threshold.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
ThreadStartThreshold Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : ThreadStartThreshold Property

Glossary Item Box

Gets and sets the elapsed time threshold (in milliseconds) beyond which a request to obtain a thumbnail should be considered of "extended duration".

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
Public Property ThreadStartThreshold As Integer
'Usage

Dim instance As ThumbnailXpress
Dim value As Integer

instance.ThreadStartThreshold = value

value = instance.ThreadStartThreshold
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public int ThreadStartThreshold {get; set;}
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public: __property int get_ThreadStartThreshold();
public: __property void set_ThreadStartThreshold(
   int value
);
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public:
property int ThreadStartThreshold {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the thread start threshold.

Remarks

ThumbnailXpress adjusts for "extended duration" requests by starting additional retrieval threads if other thumbnails were requested to attempt to keep the control display responsive.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
ThumbnailCache Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : ThumbnailCache Property

Glossary Item Box

Gets and sets the thumbnail cache object to adjust cache settings.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<ObsoleteAttribute("This property will be removed in ThumbnailXpress v5")>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
Public Property ThumbnailCache As ThumbnailCache
'Usage

Dim instance As ThumbnailXpress
Dim value As ThumbnailCache

instance.ThumbnailCache = value

value = instance.ThumbnailCache
[ObsoleteAttribute("This property will be removed in ThumbnailXpress v5")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public ThumbnailCache ThumbnailCache {get; set;}
[ObsoleteAttribute("This property will be removed in ThumbnailXpress v5")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public: __property ThumbnailCache* get_ThumbnailCache();
public: __property void set_ThumbnailCache(
   ThumbnailCache* value
);
[ObsoleteAttribute("This property will be removed in ThumbnailXpress v5")]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public:
property ThumbnailCache^ ThumbnailCache {
   ThumbnailCache^ get();
   void set (    ThumbnailCache^ value);
}

Property Value

The ThumbnailCache to adjust cache settings.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
TopMargin Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : TopMargin Property

Glossary Item Box

Gets and sets the margin on the top-most side of the control.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(True)>
<DescriptionAttribute("Indicates the margin on the top-most side of the control.")>
<CategoryAttribute("ThumbnailXpress")>
Public Property TopMargin As Integer
'Usage

Dim instance As ThumbnailXpress
Dim value As Integer

instance.TopMargin = value

value = instance.TopMargin
[BrowsableAttribute(true)]
[DescriptionAttribute("Indicates the margin on the top-most side of the control.")]
[CategoryAttribute("ThumbnailXpress")]
public int TopMargin {get; set;}
[BrowsableAttribute(true)]
[DescriptionAttribute("Indicates the margin on the top-most side of the control.")]
[CategoryAttribute("ThumbnailXpress")]
public: __property int get_TopMargin();
public: __property void set_TopMargin(
   int value
);
[BrowsableAttribute(true)]
[DescriptionAttribute("Indicates the margin on the top-most side of the control.")]
[CategoryAttribute("ThumbnailXpress")]
public:
property int TopMargin {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the top margin.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
TopVisibleItem Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : TopVisibleItem Property

Glossary Item Box

Gets the thumbnail item of the top-most visible thumbnail item.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(False)>
<EditorBrowsableAttribute()>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property TopVisibleItem As ThumbnailItem
'Usage

Dim instance As ThumbnailXpress
Dim value As ThumbnailItem

value = instance.TopVisibleItem
[BrowsableAttribute(false)]
[EditorBrowsableAttribute()]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public ThumbnailItem TopVisibleItem {get;}
[BrowsableAttribute(false)]
[EditorBrowsableAttribute()]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property ThumbnailItem* get_TopVisibleItem();
[BrowsableAttribute(false)]
[EditorBrowsableAttribute()]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property ThumbnailItem^ TopVisibleItem {
   ThumbnailItem^ get();
}

Property Value

A ThumbnailItem which represents the top-most visible item.

Remarks

If no top visible item exists this property will return null.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
UseCameraRawThumbnail Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : UseCameraRawThumbnail Property

Glossary Item Box

When CameraRaw is true, setting this property will load the embedded thumbnail of the camera raw image which typically loads faster than the full-size image.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public Property UseCameraRawThumbnail As Boolean
'Usage

Dim instance As ThumbnailXpress
Dim value As Boolean

instance.UseCameraRawThumbnail = value

value = instance.UseCameraRawThumbnail
[BrowsableAttribute(false)]
public bool UseCameraRawThumbnail {get; set;}
[BrowsableAttribute(false)]
public: __property bool get_UseCameraRawThumbnail();
public: __property void set_UseCameraRawThumbnail(
   bool value
);
[BrowsableAttribute(false)]
public:
property bool UseCameraRawThumbnail {
   bool get();
   void set (    bool value);
}

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Version Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : Version Property

Glossary Item Box

Returns the version of the ThumbnailXpress control at run-time.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public ReadOnly Property Version As String
'Usage

Dim instance As ThumbnailXpress
Dim value As String

value = instance.Version
[BrowsableAttribute(false)]
public string Version {get;}
[BrowsableAttribute(false)]
public: __property string* get_Version();
[BrowsableAttribute(false)]
public:
property String^ Version {
   String^ get();
}

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
VisibleColumnCount Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : VisibleColumnCount Property

Glossary Item Box

Gets the number of visible thumbnail columns.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<EditorBrowsableAttribute()>
Public ReadOnly Property VisibleColumnCount As Integer
'Usage

Dim instance As ThumbnailXpress
Dim value As Integer

value = instance.VisibleColumnCount
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[EditorBrowsableAttribute()]
public int VisibleColumnCount {get;}
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[EditorBrowsableAttribute()]
public: __property int get_VisibleColumnCount();
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[EditorBrowsableAttribute()]
public:
property int VisibleColumnCount {
   int get();
}

Property Value

The visible column count.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
VisibleRowCount Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : VisibleRowCount Property

Glossary Item Box

Gets the number of visible thumbnail rows.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<EditorBrowsableAttribute()>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property VisibleRowCount As Integer
'Usage

Dim instance As ThumbnailXpress
Dim value As Integer

value = instance.VisibleRowCount
[EditorBrowsableAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public int VisibleRowCount {get;}
[EditorBrowsableAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property int get_VisibleRowCount();
[EditorBrowsableAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property int VisibleRowCount {
   int get();
}

Property Value

The visible row count.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%% $$Events$$

[image]
Accusoft.ThumbnailXpress4.Net
ThumbnailXpress Class Events
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : ThumbnailXpress Class

Glossary Item Box

For a list of all members of this type, see ThumbnailXpress members.

Public Events

 | Name | Description
Public Event | AutoSizeChanged | Occurs when the System.Windows.Forms.UserControl.AutoSize property changes. (Inherited from System.Windows.Forms.UserControl)
Public Event | AutoValidateChanged | Occurs when the System.Windows.Forms.UserControl.AutoValidate property changes. (Inherited from System.Windows.Forms.UserControl)
Public Event | BackColorChanged | Occurs when the value of the System.Windows.Forms.Control.BackColor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the System.Windows.Forms.Control.BackgroundImage property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the System.Windows.Forms.Control.BackgroundImageLayout property changes. (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the System.Windows.Forms.BindingContext property changes. (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from System.Windows.Forms.Control)
Public Event | Click | Occurs when the control is clicked. (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the System.Windows.Forms.Control.Cursor property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | Occurs when the value of the System.Windows.Forms.Control.Dock property changes. (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | Occurs when the control is double-clicked. (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | Event which is called when a drag-and-drop operation is completed as a result of dragging an object over the control and releasing the mouse button.
Public Event | DragEnter | Event which is called when an object is dragged into the control's bounds.
Public Event | DragLeave | Event which is called when an object is dragged out of the control's bounds.
Public Event | DragOver | Event which is called when an object is dragged over the control's bounds.
Public Event | EnabledChanged | Occurs when the System.Windows.Forms.Control.Enabled property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Enter | Occurs when the control is entered. (Inherited from System.Windows.Forms.Control)
Public Event | Error | Event which is called when an error occurs during generation or painting of a thumbnail item.
Public Event | FontChanged | Occurs when the System.Windows.Forms.Control.Font property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | Occurs when the System.Windows.Forms.Control.ForeColor property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | Event which is called when a drag-and-drop operation is started.
Public Event | GotFocus | Occurs when the control receives focus. (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | Occurs when a handle is created for the control. (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | Occurs when the System.Windows.Forms.Control.ImeMode property has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from System.Windows.Forms.Control)
Public Event | ItemComplete | Event which is called when a thumbnail item's asynchronous image generation has been completed. Review the thumbnail item collection information about how thumbnail items are added to the collection, where the items are generated asynchronously.
Public Event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Layout | Occurs when a control should reposition its child controls. (Inherited from System.Windows.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | Load | Occurs before the control becomes visible for the first time. (Inherited from System.Windows.Forms.UserControl)
Public Event | LoadFromStream | This event is called when the component requires the application to provide a System.IO.Stream object containing image data for a thumbnail item.
Public Event | LocationChanged | Occurs when the System.Windows.Forms.Control.Location property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | Occurs when the control's margin changes. (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from System.Windows.Forms.Control)
Public Event | Move | Occurs when the control is moved. (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | Occurs when the control's padding changes. (Inherited from System.Windows.Forms.Control)
Public Event | Paint | Occurs when the control is redrawn. (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | Occurs when the System.Windows.Forms.Control.Parent property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control. (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | Event which is called when there is a change in the keyboard or mouse button state during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be cancelled.
Public Event | RegionChanged | Occurs when the value of the System.Windows.Forms.Control.Region property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | Occurs when the System.Windows.Forms.Control.RightToLeft property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | SelectedIndexChanged | Event which is called when a thumbnail item is selected using the user interface.
Public Event | SizeChanged | Occurs when the System.Windows.Forms.Control.Size property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | Occurs when the control style changes. (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | Occurs when the system colors change. (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | Occurs when the System.Windows.Forms.Control.TabIndex property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | Occurs when the System.Windows.Forms.Control.TabStop property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | Validated | Occurs when the control is finished validating. (Inherited from System.Windows.Forms.Control)
Public Event | Validating | Occurs when the control is validating. (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | Occurs when the System.Windows.Forms.Control.Visible property value changes. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

ThumbnailXpress Class
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
DragDrop Event
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : DragDrop Event

Glossary Item Box

Event which is called when a drag-and-drop operation is completed as a result of dragging an object over the control and releasing the mouse button.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Shadows Event DragDrop As ThumbnailXpressEvents.DragDropEventHandler
'Usage

Dim instance As ThumbnailXpress
Dim handler As ThumbnailXpressEvents.DragDropEventHandler

AddHandler instance.DragDrop, handler
public new event ThumbnailXpressEvents.DragDropEventHandler DragDrop
public: new __event ThumbnailXpressEvents.DragDropEventHandler* DragDrop
public:
new event ThumbnailXpressEvents.DragDropEventHandler^ DragDrop

Event Data

The event handler receives an argument of type DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
DragEnter Event
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : DragEnter Event

Glossary Item Box

Event which is called when an object is dragged into the control's bounds.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Shadows Event DragEnter As ThumbnailXpressEvents.DragEnterEventHandler
'Usage

Dim instance As ThumbnailXpress
Dim handler As ThumbnailXpressEvents.DragEnterEventHandler

AddHandler instance.DragEnter, handler
public new event ThumbnailXpressEvents.DragEnterEventHandler DragEnter
public: new __event ThumbnailXpressEvents.DragEnterEventHandler* DragEnter
public:
new event ThumbnailXpressEvents.DragEnterEventHandler^ DragEnter

Event Data

The event handler receives an argument of type DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
DragLeave Event
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : DragLeave Event

Glossary Item Box

Event which is called when an object is dragged out of the control's bounds.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Shadows Event DragLeave As ThumbnailXpressEvents.DragLeaveEventHandler
'Usage

Dim instance As ThumbnailXpress
Dim handler As ThumbnailXpressEvents.DragLeaveEventHandler

AddHandler instance.DragLeave, handler
public new event ThumbnailXpressEvents.DragLeaveEventHandler DragLeave
public: new __event ThumbnailXpressEvents.DragLeaveEventHandler* DragLeave
public:
new event ThumbnailXpressEvents.DragLeaveEventHandler^ DragLeave

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
DragOver Event
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : DragOver Event

Glossary Item Box

Event which is called when an object is dragged over the control's bounds.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Shadows Event DragOver As ThumbnailXpressEvents.DragOverEventHandler
'Usage

Dim instance As ThumbnailXpress
Dim handler As ThumbnailXpressEvents.DragOverEventHandler

AddHandler instance.DragOver, handler
public new event ThumbnailXpressEvents.DragOverEventHandler DragOver
public: new __event ThumbnailXpressEvents.DragOverEventHandler* DragOver
public:
new event ThumbnailXpressEvents.DragOverEventHandler^ DragOver

Event Data

The event handler receives an argument of type DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Error Event
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : Error Event

Glossary Item Box

Event which is called when an error occurs during generation or painting of a thumbnail item.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Event Error As ThumbnailXpressEvents.ErrorEventHandler
'Usage

Dim instance As ThumbnailXpress
Dim handler As ThumbnailXpressEvents.ErrorEventHandler

AddHandler instance.Error, handler
public event ThumbnailXpressEvents.ErrorEventHandler Error
public: __event ThumbnailXpressEvents.ErrorEventHandler* Error
public:
event ThumbnailXpressEvents.ErrorEventHandler^ Error

Event Data

The event handler receives an argument of type ErrorEventArgs containing data related to this event. The following ErrorEventArgs properties provide information specific to this event.

Property | Description
ItemIndex | Gets and sets the index for the Thumbnail Item collection member which incurred an error during thumbnail generation.
Message | Gets and sets the error message for the Thumbnail item collection member which incurred an error during thumbnail generation.
Number | Gets and sets the error number for the Thumbnail Item collection member which incurred an error during thumbnail generation.

Remarks

The error could be due to generation errors like an unsupported or corrupt file, or various painting errors.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
GiveFeedback Event
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : GiveFeedback Event

Glossary Item Box

Event which is called when a drag-and-drop operation is started.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Shadows Event GiveFeedback As ThumbnailXpressEvents.GiveFeedbackEventHandler
'Usage

Dim instance As ThumbnailXpress
Dim handler As ThumbnailXpressEvents.GiveFeedbackEventHandler

AddHandler instance.GiveFeedback, handler
public new event ThumbnailXpressEvents.GiveFeedbackEventHandler GiveFeedback
public: new __event ThumbnailXpressEvents.GiveFeedbackEventHandler* GiveFeedback
public:
new event ThumbnailXpressEvents.GiveFeedbackEventHandler^ GiveFeedback

Event Data

The event handler receives an argument of type GiveFeedbackEventArgs containing data related to this event. The following GiveFeedbackEventArgs properties provide information specific to this event.

Property | Description
Effect | Gets the drag-and-drop operation feedback that is displayed.
UseDefaultCursors | Gets or sets whether drag operation should use the default cursors that are associated with drag-drop effects.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
ItemComplete Event
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : ItemComplete Event

Glossary Item Box

Event which is called when a thumbnail item's asynchronous image generation has been completed. Review the thumbnail item collection information about how thumbnail items are added to the collection, where the items are generated asynchronously.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Event ItemComplete As ThumbnailXpressEvents.ItemCompleteEventHandler
'Usage

Dim instance As ThumbnailXpress
Dim handler As ThumbnailXpressEvents.ItemCompleteEventHandler

AddHandler instance.ItemComplete, handler
public event ThumbnailXpressEvents.ItemCompleteEventHandler ItemComplete
public: __event ThumbnailXpressEvents.ItemCompleteEventHandler* ItemComplete
public:
event ThumbnailXpressEvents.ItemCompleteEventHandler^ ItemComplete

Event Data

The event handler receives an argument of type ItemCompleteEventArgs containing data related to this event. The following ItemCompleteEventArgs properties provide information specific to this event.

Property | Description
ItemIndex | Gets and sets the index of the ThumbnailItemCollection member for which the thumbnail image generation has just completed.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
LoadFromStream Event
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : LoadFromStream Event

Glossary Item Box

This event is called when the component requires the application to provide a System.IO.Stream object containing image data for a thumbnail item.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Event LoadFromStream As ThumbnailXpressEvents.LoadFromStreamEventHandler
'Usage

Dim instance As ThumbnailXpress
Dim handler As ThumbnailXpressEvents.LoadFromStreamEventHandler

AddHandler instance.LoadFromStream, handler
public event ThumbnailXpressEvents.LoadFromStreamEventHandler LoadFromStream
public: __event ThumbnailXpressEvents.LoadFromStreamEventHandler* LoadFromStream
public:
event ThumbnailXpressEvents.LoadFromStreamEventHandler^ LoadFromStream

Event Data

The event handler receives an argument of type LoadFromStreamEventArgs containing data related to this event. The following LoadFromStreamEventArgs properties provide information specific to this event.

Property | Description
Item | Gets the ThumbnailItem object whose image data is to be loaded using a System.IO.Stream.

Remarks

A handler for this event must be supplied by the application if items are added to the ThumbnailItemCollection using the collection's ThumbnailItemCollection.InsertItemFromStream or ThumbnailItemCollection.AddItemFromStream methods.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members
LoadFromStreamEventArgs Class


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
QueryContinueDrag Event
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : QueryContinueDrag Event

Glossary Item Box

Event which is called when there is a change in the keyboard or mouse button state during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be cancelled.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Shadows Event QueryContinueDrag As ThumbnailXpressEvents.QueryContinueDragEventHandler
'Usage

Dim instance As ThumbnailXpress
Dim handler As ThumbnailXpressEvents.QueryContinueDragEventHandler

AddHandler instance.QueryContinueDrag, handler
public new event ThumbnailXpressEvents.QueryContinueDragEventHandler QueryContinueDrag
public: new __event ThumbnailXpressEvents.QueryContinueDragEventHandler* QueryContinueDrag
public:
new event ThumbnailXpressEvents.QueryContinueDragEventHandler^ QueryContinueDrag

Event Data

The event handler receives an argument of type QueryContinueDragEventArgs containing data related to this event. The following QueryContinueDragEventArgs properties provide information specific to this event.

Property | Description
Action | Gets or sets the status of a drag-and-drop operation.
EscapePressed | Gets whether the user pressed the ESC key.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys.

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
SelectedIndexChanged Event
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpress Class : SelectedIndexChanged Event

Glossary Item Box

Event which is called when a thumbnail item is selected using the user interface.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Event SelectedIndexChanged As ThumbnailXpressEvents.SelectedIndexChangedEventHandler
'Usage

Dim instance As ThumbnailXpress
Dim handler As ThumbnailXpressEvents.SelectedIndexChangedEventHandler

AddHandler instance.SelectedIndexChanged, handler
public event ThumbnailXpressEvents.SelectedIndexChangedEventHandler SelectedIndexChanged
public: __event ThumbnailXpressEvents.SelectedIndexChangedEventHandler* SelectedIndexChanged
public:
event ThumbnailXpressEvents.SelectedIndexChangedEventHandler^ SelectedIndexChanged

See Also

Reference

ThumbnailXpress Class
ThumbnailXpress Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
ThumbnailXpressEvents Class
Members See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : ThumbnailXpressEvents Class

Glossary Item Box

This class implements the ThumbnailXpress events.

Object Model

ThumbnailXpressEvents Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Class ThumbnailXpressEvents
'Usage

Dim instance As ThumbnailXpressEvents
public class ThumbnailXpressEvents
public __gc class ThumbnailXpressEvents
public ref class ThumbnailXpressEvents

Inheritance Hierarchy

System.Object
Accusoft.ThumbnailXpressSdk.ThumbnailXpressEvents

See Also

Reference

ThumbnailXpressEvents Members
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.ThumbnailXpress4.Net
ThumbnailXpressEvents Class Members
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : ThumbnailXpressEvents Class

Glossary Item Box

The following tables list the members exposed by ThumbnailXpressEvents.

See Also

Reference

ThumbnailXpressEvents Class
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
ThumbnailXpressException Class
Members See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : ThumbnailXpressException Class

Glossary Item Box

Summary description for ThumbnailXpressException.

Object Model

ThumbnailXpressException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public Class ThumbnailXpressException
   Inherits System.Exception
'Usage

Dim instance As ThumbnailXpressException
[SerializableAttribute()]
public class ThumbnailXpressException : System.Exception
[SerializableAttribute()]
public __gc class ThumbnailXpressException : public System.Exception
[SerializableAttribute()]
public ref class ThumbnailXpressException : public System.Exception

Inheritance Hierarchy

System.Object
System.Exception
Accusoft.ThumbnailXpressSdk.ThumbnailXpressException

See Also

Reference

ThumbnailXpressException Members
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.ThumbnailXpress4.Net
ThumbnailXpressException Class Members
See Also Properties Methods Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : ThumbnailXpressException Class

Glossary Item Box

The following tables list the members exposed by ThumbnailXpressException.

Public Constructors

 | Name | Description
Public Constructor | ThumbnailXpressException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the error number from the last call.
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ThumbnailXpressException Class
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.ThumbnailXpress4.Net
ThumbnailXpressException Class Methods
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : ThumbnailXpressException Class

Glossary Item Box

For a list of all members of this type, see ThumbnailXpressException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ThumbnailXpressException Class
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
ThumbnailXpressException Constructor
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpressException Class : ThumbnailXpressException Constructor

Glossary Item Box

Overload List

Overload | Description
ThumbnailXpressException Constructor() | The main constructor for the ThumbnailXpressException class.
ThumbnailXpressException Constructor(String) | Exception for ThumbnailXpress errors with an error message.
ThumbnailXpressException Constructor(String,Int32) | Exception for ThumbnailXpress errors with a message and error number.
ThumbnailXpressException Constructor(String,Exception) | Exception for ThumbnailXpress errors with a message and inner exception.

See Also

Reference

ThumbnailXpressException Class
ThumbnailXpressException Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
ThumbnailXpressException Constructor()
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpressException Class > ThumbnailXpressException Constructor : ThumbnailXpressException Constructor()

Glossary Item Box

The main constructor for the ThumbnailXpressException class.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ThumbnailXpressException()
public ThumbnailXpressException()
public: ThumbnailXpressException();
public:
ThumbnailXpressException();

See Also

Reference

ThumbnailXpressException Class
ThumbnailXpressException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
ThumbnailXpressException Constructor(String)
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpressException Class > ThumbnailXpressException Constructor : ThumbnailXpressException Constructor(String)

message
A string value which represents the error message.

Glossary Item Box

Exception for ThumbnailXpress errors with an error message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New ThumbnailXpressException(message)
public ThumbnailXpressException(
   string message
)
public: ThumbnailXpressException(
   string* message
)
public:
ThumbnailXpressException(
   String^ message
)

Parameters

message
A string value which represents the error message.

See Also

Reference

ThumbnailXpressException Class
ThumbnailXpressException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
ThumbnailXpressException Constructor(String,Int32)
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpressException Class > ThumbnailXpressException Constructor : ThumbnailXpressException Constructor(String,Int32)

message
A string value which represents the error message.
number
An integer value which represents the error number.

Glossary Item Box

Exception for ThumbnailXpress errors with a message and error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal number As Integer _
)
'Usage

Dim message As String
Dim number As Integer

Dim instance As New ThumbnailXpressException(message, number)
public ThumbnailXpressException(
   string message,
   int number
)
public: ThumbnailXpressException(
   string* message,
   int number
)
public:
ThumbnailXpressException(
   String^ message,
   int number
)

Parameters

message
A string value which represents the error message.
number
An integer value which represents the error number.

See Also

Reference

ThumbnailXpressException Class
ThumbnailXpressException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
ThumbnailXpressException Constructor(String,Exception)
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpressException Class > ThumbnailXpressException Constructor : ThumbnailXpressException Constructor(String,Exception)

message
A string value which represents the error message.
innerException
A System.Exception which represents an inner exception.

Glossary Item Box

Exception for ThumbnailXpress errors with a message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New ThumbnailXpressException(message, innerException)
public ThumbnailXpressException(
   string message,
   Exception innerException
)
public: ThumbnailXpressException(
   string* message,
   Exception* innerException
)
public:
ThumbnailXpressException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string value which represents the error message.
innerException
A System.Exception which represents an inner exception.

See Also

Reference

ThumbnailXpressException Class
ThumbnailXpressException Members
Overload List


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.ThumbnailXpress4.Net
ThumbnailXpressException Class Properties
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : ThumbnailXpressException Class

Glossary Item Box

For a list of all members of this type, see ThumbnailXpressException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the error number from the last call.
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ThumbnailXpressException Class
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
Number Property
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace > ThumbnailXpressException Class : Number Property

Glossary Item Box

Gets the error number from the last call.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property Number As Integer
'Usage

Dim instance As ThumbnailXpressException
Dim value As Integer

value = instance.Number
public int Number {get;}
public: __property int get_Number();
public:
property int Number {
   int get();
}

Property Value

An integer value which represents the error number.

See Also

Reference

ThumbnailXpressException Class
ThumbnailXpressException Members


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
DebugErrorLevel Enumeration
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : DebugErrorLevel Enumeration

Glossary Item Box

Option values which determine the amount of logging detail to be sent to the log file.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum DebugErrorLevel
   Inherits System.Enum
'Usage

Dim instance As DebugErrorLevel
public enum DebugErrorLevel : System.Enum
__value public enum DebugErrorLevel : public System.Enum
public enum class DebugErrorLevel : public System.Enum

Members

Member | Value | Description
Detailed | 2 | This value is for debugging and has the highest level of detail in the log.
Development | 1 | This value is for logging in development mode and has some additional amount of detail in the log.
Production | 0 | This value is for logging in production mode and has the least amount of detail in the log.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ThumbnailXpressSdk.DebugErrorLevel

See Also

Reference

Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
DescriptorAlignments Enumeration
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : DescriptorAlignments Enumeration

Glossary Item Box

Option values which determine the alignment of the descriptor text display.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<FlagsAttribute()>
Public Enum DescriptorAlignments
   Inherits System.Enum
'Usage

Dim instance As DescriptorAlignments
[FlagsAttribute()]
public enum DescriptorAlignments : System.Enum
[FlagsAttribute()]
__value public enum DescriptorAlignments : public System.Enum
[FlagsAttribute()]
public enum class DescriptorAlignments : public System.Enum

Members

Member | Value | Description
AlignBottom | 32 | Descriptor text is bottom justified.
AlignCenter | 1 | Descriptor text is horizontally centered.
AlignLeft | 2 | Descriptor text is left justified.
AlignRight | 4 | Descriptor text is right justified.
AlignTop | 8 | Descriptor text is top justified.
AlignVCenter | 16 | Descriptor text is vertically centered.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ThumbnailXpressSdk.DescriptorAlignments

See Also

Reference

Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
DescriptorDisplayMethods Enumeration
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : DescriptorDisplayMethods Enumeration

Glossary Item Box

Option values which determine the source of descriptor text.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<FlagsAttribute()>
Public Enum DescriptorDisplayMethods
   Inherits System.Enum
'Usage

Dim instance As DescriptorDisplayMethods
[FlagsAttribute()]
public enum DescriptorDisplayMethods : System.Enum
[FlagsAttribute()]
__value public enum DescriptorDisplayMethods : public System.Enum
[FlagsAttribute()]
public enum class DescriptorDisplayMethods : public System.Enum

Members

Member | Value | Description
Custom | 16 | Display what is in the thumbnail item descriptor property.
Default | 1 | Use the thumbnail item descriptor property if present, or short filename otherwise.
IncludePage | 8 | Include page number information when not using descriptor string.
LongFilename | 2 | Automatic; based on full filename.
None | 0 | Do not display a descriptor.
ShortFilename | 4 | Automatic; based on filename only.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ThumbnailXpressSdk.DescriptorDisplayMethods

See Also

Reference

Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
ErrorAction Enumeration
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : ErrorAction Enumeration

Glossary Item Box

Option values which determine the action taken if thumbnail processing error are encountered.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum ErrorAction
   Inherits System.Enum
'Usage

Dim instance As ErrorAction
public enum ErrorAction : System.Enum
__value public enum ErrorAction : public System.Enum
public enum class ErrorAction : public System.Enum

Members

Member | Value | Description
Abort | 1 | Stop display of thumbnails
UseErrorIcon | 0 | Default value. Display error icon when unsupported or error thumbnails encountered

Remarks

The default value is UseErrorIcon.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ThumbnailXpressSdk.ErrorAction

See Also

Reference

Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
EvaluationMode Enumeration
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : EvaluationMode Enumeration

Glossary Item Box

Option values which determine the evaluation modes available for use.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum EvaluationMode
   Inherits System.Enum
'Usage

Dim instance As EvaluationMode
public enum EvaluationMode : System.Enum
__value public enum EvaluationMode : public System.Enum
public enum class EvaluationMode : public System.Enum

Members

Member | Value | Description
TrialDialog | 0 | Default value. TrialDialog specifies that a dialog box should be used during evaluation.
Watermark | 1 | All thumbnails are permanently watermarked with 'Eval'.

Remarks

The default value is TrialDialog.

In order to test the component in an application running as a service or other environments where the component does not have permissions to create a window, the application logic needs to set the EvaluationMode to Watermark. In this mode, the component does not attempt to create the Evaluation Mode dialog window, but permanently watermarks all image data passed through it.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ThumbnailXpressSdk.EvaluationMode

See Also

Reference

Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
ExternalAnnotationType Enumeration
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : ExternalAnnotationType Enumeration

Glossary Item Box

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum ExternalAnnotationType
   Inherits System.Enum
'Usage

Dim instance As ExternalAnnotationType
public enum ExternalAnnotationType : System.Enum
__value public enum ExternalAnnotationType : public System.Enum
public enum class ExternalAnnotationType : public System.Enum

Members

Member | Value | Description
NotateXpress | 0 | Binary format produced by NotateXpress.
NotateXpressXml | 2 | NotateXpress XML format.
TMSSequoia | 1 | Legacy TMS Sequoia .ann file format.
Xfdf | 3 | Acrobat XML Forms Document File.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ThumbnailXpressSdk.ExternalAnnotationType

See Also

Reference

Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
FilterComparison Enumeration
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : FilterComparison Enumeration

Glossary Item Box

Option values which specify the desired comparison outcome for a file date or size filter.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum FilterComparison
   Inherits System.Enum
'Usage

Dim instance As FilterComparison
public enum FilterComparison : System.Enum
__value public enum FilterComparison : public System.Enum
public enum class FilterComparison : public System.Enum

Members

Member | Value | Description
Equal | 2 | Image file value equal to the value specified in the filter
GreaterThan | 4 | Image file value greater than the value specified in the filter
GreaterThanEquals | 3 | Image file value greater than or equal to the value specified in the filter
LessThan | 0 | Image file value less than the value specified in the filter
LessThanEquals | 1 | Image file value less than or equal to the value specified in the filter

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ThumbnailXpressSdk.FilterComparison

See Also

Reference

Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
FilterType Enumeration
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : FilterType Enumeration

Glossary Item Box

Option values which determine the thumbnail image file parameter that is to be compared or matched by a filter.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum FilterType
   Inherits System.Enum
'Usage

Dim instance As FilterType
public enum FilterType : System.Enum
__value public enum FilterType : public System.Enum
public enum class FilterType : public System.Enum

Members

Member | Value | Description
FileAttributes | 1 | Matching on parent directory, sub directory, and hidden file attributes
FileCreationDate | 2 | Comparison on image file creation date
FileModificationDate | 3 | Comparison on image file modification date
Filename | 0 | Matching on filename, incorporates case sensitive logic
FileSize | 4 | Comparison on image file size
SupportedFileType | 5 | Image file is supported by IX

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ThumbnailXpressSdk.FilterType

See Also

Reference

Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
InternalAnnotationType Enumeration
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : InternalAnnotationType Enumeration

Glossary Item Box

Values which determine which type of annotations that ThumbnailXpress can express.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum InternalAnnotationType
   Inherits System.Enum
'Usage

Dim instance As InternalAnnotationType
public enum InternalAnnotationType : System.Enum
__value public enum InternalAnnotationType : public System.Enum
public enum class InternalAnnotationType : public System.Enum

Members

Member | Value | Description
ImagingForWindows | 0 | Wang data embedded in TIFF tag #32932.
NotateXpress | 1 | Binary format produced by NotateXpress.
Xfdf | 2 | Acrobat XML Forms Document File.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ThumbnailXpressSdk.InternalAnnotationType

See Also

Reference

Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
ScrollDirection Enumeration
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : ScrollDirection Enumeration

Glossary Item Box

Option values which determine the direction the thumbnails will scroll in the control.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum ScrollDirection
   Inherits System.Enum
'Usage

Dim instance As ScrollDirection
public enum ScrollDirection : System.Enum
__value public enum ScrollDirection : public System.Enum
public enum class ScrollDirection : public System.Enum

Members

Member | Value | Description
Horizontal | 0 | Thumbnails scroll in a horizontal direction.
Vertical | 1 | Thumbnails scroll in a vertical direction.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ThumbnailXpressSdk.ScrollDirection

See Also

Reference

Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
ScrollItemsType Enumeration
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : ScrollItemsType Enumeration

Glossary Item Box

Option values which specify the incremental amount or whether a positional programmatic scroll operation is desired.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum ScrollItemsType
   Inherits System.Enum
'Usage

Dim instance As ScrollItemsType
public enum ScrollItemsType : System.Enum
__value public enum ScrollItemsType : public System.Enum
public enum class ScrollItemsType : public System.Enum

Members

Member | Value | Description
ItemIndex | 5 | Thumbnails are to be scrolled to a specified item index position.
LargeDecrease | 0 | Thumbnails are to be scrolled backward one page.
LargeIncrease | 2 | Thumbnails are to be scrolled forward one page.
SmallDecrease | 1 | Thumbnails are to be scrolled backward one row or column.
SmallIncrease | 3 | Thumbnails are to be scrolled forward one row or column.
ThumbPosition | 4 | Thumbnails are to be scrolled to a specified thumb position.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ThumbnailXpressSdk.ScrollItemsType

See Also

Reference

Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
SelectionMode Enumeration
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : SelectionMode Enumeration

Glossary Item Box

Option values which determine the Thumbnail Item selection mode for the control.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum SelectionMode
   Inherits System.Enum
'Usage

Dim instance As SelectionMode
public enum SelectionMode : System.Enum
__value public enum SelectionMode : public System.Enum
public enum class SelectionMode : public System.Enum

Members

Member | Value | Description
MultiExtended | 3 | Multiple Thumbnail items may be selected, the control and shift keys modify the items selected operation
MultiSimple | 2 | Multiple Thumbnail items may be selected, the control and shift keys do not modify the items selected operation
None | 0 | Thumbnail selection is not enabled.
Single | 1 | Only one Thumbnail item may be selected. If a second item is selected the selected state is removed from any previously selected item.

Remarks

The default value is MultiExtended.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ThumbnailXpressSdk.SelectionMode

See Also

Reference

Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
ThumbnailStatus Enumeration
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : ThumbnailStatus Enumeration

Glossary Item Box

Option values which determine the Thumbnail item image data validation and generation status.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum ThumbnailStatus
   Inherits System.Enum
'Usage

Dim instance As ThumbnailStatus
public enum ThumbnailStatus : System.Enum
__value public enum ThumbnailStatus : public System.Enum
public enum class ThumbnailStatus : public System.Enum

Members

Member | Value | Description
BeingGenerated | 2 | A thumbnail image is in the process of being generated from the item image data.
Canceled | 6 | The thumbnail image generation was canceled by the user before completion.
FailedWithError | 4 | Thumbnail image generation incurred an error.
FailedWithTimeout | 5 | Failed to generate a thumbnail image within time threshold limits. See the ThumbnailXpress ThreadHungThreshold property ThumbnailXpress.ThreadHungThreshold
Generated | 3 | A thumbnail image has been successfully generated for the item.
NotValidated | 0 | Item image data has not been validated and it is yet to be determined if a thumbnail image can be generated from the data.
Validated | 1 | Item image data has been validated and it is believed a thumbnail image can be generated for the item

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ThumbnailXpressSdk.ThumbnailStatus

See Also

Reference

Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
ThumbnailType Enumeration
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : ThumbnailType Enumeration

Glossary Item Box

Option values which specify the type of thumbnail (image, directory, etc.) for a thumbnail item.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum ThumbnailType
   Inherits System.Enum
'Usage

Dim instance As ThumbnailType
public enum ThumbnailType : System.Enum
__value public enum ThumbnailType : public System.Enum
public enum class ThumbnailType : public System.Enum

Members

Member | Value | Description
Cad | 5 | Supported CAD image data.
Image | 3 | Supported image data.
Internet | 1 | Similar to Unknown type except the image data resides on the internet.
ParentDirectory | 6 | Parent directory folder.
Pdf | 4 | Supported PDF image data.
SubDirectory | 7 | Sub-directory folder.
Unknown | 0 | Have not tried any operations which allow us to know the type.
Unsupported | 2 | Non-image data or unsupported image data.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ThumbnailXpressSdk.ThumbnailType

See Also

Reference

Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
ToHdibMethod Enumeration
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : ToHdibMethod Enumeration

Glossary Item Box

Specifies the method of returning the DIB.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum ToHdibMethod
   Inherits System.Enum
'Usage

Dim instance As ToHdibMethod
public enum ToHdibMethod : System.Enum
__value public enum ToHdibMethod : public System.Enum
public enum class ToHdibMethod : public System.Enum

Members

Member | Value | Description
ReturnDuplicate | 0 | Returns a copy of the DIB, you are responsible for freeing it via GlobalFree().
ReturnInternalHdib | 1 | Returns the internal DIB, you are not responsible for freeing of it. If you dispose of the DIB, ThumbnailXpress will no longer have access to it.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ThumbnailXpressSdk.ToHdibMethod

See Also

Reference

Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
ThumbnailXpressEvents.DragDropEventHandler Delegate
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : ThumbnailXpressEvents.DragDropEventHandler Delegate

sender
e

Glossary Item Box

Defines the event handler for the ThumbnailXpress.DragDrop event.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Delegate Sub ThumbnailXpressEvents.DragDropEventHandler( _
   ByVal sender As Object, _
   ByVal e As DragEventArgs _
)
'Usage

Dim instance As New ThumbnailXpressEvents.DragDropEventHandler(AddressOf HandlerMethod)
public delegate void ThumbnailXpressEvents.DragDropEventHandler(
   object sender,
   DragEventArgs e
)
public: __gc __delegate void ThumbnailXpressEvents.DragDropEventHandler(
   Object* sender,
   DragEventArgs* e
)
public delegate void ThumbnailXpressEvents.DragDropEventHandler(
   Object^ sender,
   DragEventArgs^ e
)

Parameters

sender
e

See Also

Reference

ThumbnailXpressEvents.DragDropEventHandler Members
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
ThumbnailXpressEvents.DragEnterEventHandler Delegate
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : ThumbnailXpressEvents.DragEnterEventHandler Delegate

sender
e

Glossary Item Box

Defines the event handler for the ThumbnailXpress.DragEnter event.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Delegate Sub ThumbnailXpressEvents.DragEnterEventHandler( _
   ByVal sender As Object, _
   ByVal e As DragEventArgs _
)
'Usage

Dim instance As New ThumbnailXpressEvents.DragEnterEventHandler(AddressOf HandlerMethod)
public delegate void ThumbnailXpressEvents.DragEnterEventHandler(
   object sender,
   DragEventArgs e
)
public: __gc __delegate void ThumbnailXpressEvents.DragEnterEventHandler(
   Object* sender,
   DragEventArgs* e
)
public delegate void ThumbnailXpressEvents.DragEnterEventHandler(
   Object^ sender,
   DragEventArgs^ e
)

Parameters

sender
e

See Also

Reference

ThumbnailXpressEvents.DragEnterEventHandler Members
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
ThumbnailXpressEvents.DragLeaveEventHandler Delegate
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : ThumbnailXpressEvents.DragLeaveEventHandler Delegate

sender
e

Glossary Item Box

Defines the event handler for the ThumbnailXpress.DragLeave event.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Delegate Sub ThumbnailXpressEvents.DragLeaveEventHandler( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
'Usage

Dim instance As New ThumbnailXpressEvents.DragLeaveEventHandler(AddressOf HandlerMethod)
public delegate void ThumbnailXpressEvents.DragLeaveEventHandler(
   object sender,
   EventArgs e
)
public: __gc __delegate void ThumbnailXpressEvents.DragLeaveEventHandler(
   Object* sender,
   EventArgs* e
)
public delegate void ThumbnailXpressEvents.DragLeaveEventHandler(
   Object^ sender,
   EventArgs^ e
)

Parameters

sender
e

See Also

Reference

ThumbnailXpressEvents.DragLeaveEventHandler Members
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
ThumbnailXpressEvents.DragOverEventHandler Delegate
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : ThumbnailXpressEvents.DragOverEventHandler Delegate

sender
e

Glossary Item Box

Defines the event handler for the ThumbnailXpress.DragOver event.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Delegate Sub ThumbnailXpressEvents.DragOverEventHandler( _
   ByVal sender As Object, _
   ByVal e As DragEventArgs _
)
'Usage

Dim instance As New ThumbnailXpressEvents.DragOverEventHandler(AddressOf HandlerMethod)
public delegate void ThumbnailXpressEvents.DragOverEventHandler(
   object sender,
   DragEventArgs e
)
public: __gc __delegate void ThumbnailXpressEvents.DragOverEventHandler(
   Object* sender,
   DragEventArgs* e
)
public delegate void ThumbnailXpressEvents.DragOverEventHandler(
   Object^ sender,
   DragEventArgs^ e
)

Parameters

sender
e

See Also

Reference

ThumbnailXpressEvents.DragOverEventHandler Members
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
ThumbnailXpressEvents.ErrorEventHandler Delegate
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : ThumbnailXpressEvents.ErrorEventHandler Delegate

sender
e

Glossary Item Box

Defines the event handler for the ThumbnailXpress.Error event.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Delegate Sub ThumbnailXpressEvents.ErrorEventHandler( _
   ByVal sender As Object, _
   ByVal e As ErrorEventArgs _
)
'Usage

Dim instance As New ThumbnailXpressEvents.ErrorEventHandler(AddressOf HandlerMethod)
public delegate void ThumbnailXpressEvents.ErrorEventHandler(
   object sender,
   ErrorEventArgs e
)
public: __gc __delegate void ThumbnailXpressEvents.ErrorEventHandler(
   Object* sender,
   ErrorEventArgs* e
)
public delegate void ThumbnailXpressEvents.ErrorEventHandler(
   Object^ sender,
   ErrorEventArgs^ e
)

Parameters

sender
e

See Also

Reference

ThumbnailXpressEvents.ErrorEventHandler Members
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
ThumbnailXpressEvents.GiveFeedbackEventHandler Delegate
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : ThumbnailXpressEvents.GiveFeedbackEventHandler Delegate

sender
e

Glossary Item Box

Defines the event handler for the ThumbnailXpress.GiveFeedback event.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Delegate Sub ThumbnailXpressEvents.GiveFeedbackEventHandler( _
   ByVal sender As Object, _
   ByVal e As GiveFeedbackEventArgs _
)
'Usage

Dim instance As New ThumbnailXpressEvents.GiveFeedbackEventHandler(AddressOf HandlerMethod)
public delegate void ThumbnailXpressEvents.GiveFeedbackEventHandler(
   object sender,
   GiveFeedbackEventArgs e
)
public: __gc __delegate void ThumbnailXpressEvents.GiveFeedbackEventHandler(
   Object* sender,
   GiveFeedbackEventArgs* e
)
public delegate void ThumbnailXpressEvents.GiveFeedbackEventHandler(
   Object^ sender,
   GiveFeedbackEventArgs^ e
)

Parameters

sender
e

See Also

Reference

ThumbnailXpressEvents.GiveFeedbackEventHandler Members
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
ThumbnailXpressEvents.ItemCompleteEventHandler Delegate
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : ThumbnailXpressEvents.ItemCompleteEventHandler Delegate

sender
e

Glossary Item Box

Defines the event handler for the ThumbnailXpress.ItemComplete event.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Delegate Sub ThumbnailXpressEvents.ItemCompleteEventHandler( _
   ByVal sender As Object, _
   ByVal e As ItemCompleteEventArgs _
)
'Usage

Dim instance As New ThumbnailXpressEvents.ItemCompleteEventHandler(AddressOf HandlerMethod)
public delegate void ThumbnailXpressEvents.ItemCompleteEventHandler(
   object sender,
   ItemCompleteEventArgs e
)
public: __gc __delegate void ThumbnailXpressEvents.ItemCompleteEventHandler(
   Object* sender,
   ItemCompleteEventArgs* e
)
public delegate void ThumbnailXpressEvents.ItemCompleteEventHandler(
   Object^ sender,
   ItemCompleteEventArgs^ e
)

Parameters

sender
e

See Also

Reference

ThumbnailXpressEvents.ItemCompleteEventHandler Members
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
ThumbnailXpressEvents.LoadFromStreamEventHandler Delegate
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : ThumbnailXpressEvents.LoadFromStreamEventHandler Delegate

sender
An object which contains information about the event.
e
LoadFromStreamEventArgs object which contains information about the event.

Glossary Item Box

Defines the event handler for the ThumbnailXpress.LoadFromStream event.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Delegate Sub ThumbnailXpressEvents.LoadFromStreamEventHandler( _
   ByVal sender As Object, _
   ByVal e As LoadFromStreamEventArgs _
)
'Usage

Dim instance As New ThumbnailXpressEvents.LoadFromStreamEventHandler(AddressOf HandlerMethod)
public delegate void ThumbnailXpressEvents.LoadFromStreamEventHandler(
   object sender,
   LoadFromStreamEventArgs e
)
public: __gc __delegate void ThumbnailXpressEvents.LoadFromStreamEventHandler(
   Object* sender,
   LoadFromStreamEventArgs* e
)
public delegate void ThumbnailXpressEvents.LoadFromStreamEventHandler(
   Object^ sender,
   LoadFromStreamEventArgs^ e
)

Parameters

sender
An object which contains information about the event.
e
LoadFromStreamEventArgs object which contains information about the event.

Remarks

A handler must be supplied by the application if items are added to the ThumbnailItemCollection using the collection's ThumbnailItemCollection.InsertItemFromStream or ThumbnailItemCollection.AddItemFromStream methods.

See Also

Reference

ThumbnailXpressEvents.LoadFromStreamEventHandler Members
Accusoft.ThumbnailXpressSdk Namespace
Item Property


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
ThumbnailXpressEvents.QueryContinueDragEventHandler Delegate
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : ThumbnailXpressEvents.QueryContinueDragEventHandler Delegate

sender
e

Glossary Item Box

Defines the event handler for the ThumbnailXpress.QueryContinueDrag event.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Delegate Sub ThumbnailXpressEvents.QueryContinueDragEventHandler( _
   ByVal sender As Object, _
   ByVal e As QueryContinueDragEventArgs _
)
'Usage

Dim instance As New ThumbnailXpressEvents.QueryContinueDragEventHandler(AddressOf HandlerMethod)
public delegate void ThumbnailXpressEvents.QueryContinueDragEventHandler(
   object sender,
   QueryContinueDragEventArgs e
)
public: __gc __delegate void ThumbnailXpressEvents.QueryContinueDragEventHandler(
   Object* sender,
   QueryContinueDragEventArgs* e
)
public delegate void ThumbnailXpressEvents.QueryContinueDragEventHandler(
   Object^ sender,
   QueryContinueDragEventArgs^ e
)

Parameters

sender
e

See Also

Reference

ThumbnailXpressEvents.QueryContinueDragEventHandler Members
Accusoft.ThumbnailXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ThumbnailXpress4.Net
ThumbnailXpressEvents.SelectedIndexChangedEventHandler Delegate
See Also Send Feedback
Accusoft.ThumbnailXpressSdk Namespace : ThumbnailXpressEvents.SelectedIndexChangedEventHandler Delegate

sender
e

Glossary Item Box

Defines the event handler for the ThumbnailXpress.SelectedIndexChanged event.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Delegate Sub ThumbnailXpressEvents.SelectedIndexChangedEventHandler( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
'Usage

Dim instance As New ThumbnailXpressEvents.SelectedIndexChangedEventHandler(AddressOf HandlerMethod)
public delegate void ThumbnailXpressEvents.SelectedIndexChangedEventHandler(
   object sender,
   EventArgs e
)
public: __gc __delegate void ThumbnailXpressEvents.SelectedIndexChangedEventHandler(
   Object* sender,
   EventArgs* e
)
public delegate void ThumbnailXpressEvents.SelectedIndexChangedEventHandler(
   Object^ sender,
   EventArgs^ e
)

Parameters

sender
e

See Also

Reference

ThumbnailXpressEvents.SelectedIndexChangedEventHandler Members
Accusoft.ThumbnailXpressSdk Namespace


a
about
after
against
all
along
also
although
am
among
an
and
are
as
at
be
became
because
been
being
between
but
by
can
caution
come
could
details
did
do
does
doing
done
during
each
early
far
finally
for
found
from
had
has
have
he
her
here
his
how
however
I
if
in
include
including
information
into
is
it
its
late
later
made
many
may
me
med
might
more
most
near
no
non
none
nor
not
note
of
off
on
only
or
other
over
saw
see
seen
several
she
since
so
some
such
than
that
the
their
them
then
there
these
they
this
those
through
tip
to
too
under
until
up
us
use
very
warning
was
we
were
when
where
which
while
who
with
you