%%ItemTitle%%

Accusoft.PrintPro6.Net
PrintPRO User Assistance Dashboard
Send Feedback

Glossary Item Box

Welcome

  • Overview of Product Family
    • What is the ImagXpress Product Family?
  • New Features
    • What is PrintPRO?

Getting Started

  • Operating Requirements & Installation
    • Operating Requirements
    • Upgrading from PrintPRO 5 to PrintPRO 6
    • Installing on a Development Machine
  • Licensing & Deployment
    • Licensing
    • Distributing PrintPRO
    • Software License Agreement
    • Accusoft Corporation Copyrights & Trademarks

Developer's Guide

  • User Guide

    • Concepts

      • Overview of PrintPRO
      • Introduction to Image Color Management (ICM)
      • Glossary
    • How To
      • Set Up Printer
      • Use Image Color Management (ICM)
      • Create Print Job
      • Print Preview
      • Print
      • Debug
  • API Reference Guide
    • Accusoft.PrintPro6.Net Assembly

Additional Resources

  • White papers & Case Studies
  • FAQs, PrintPRO 6 FAQs
  • Support Overview
  • Support Plans/Agreement

Feedback

  • Tell us what you think
    • Email us
    • Take our survey

©2012. Accusoft Corporation. All Rights Reserved.


%%ItemTitle%%

PrintPRO 6 for .NET - User Guide
Send Feedback

Glossary Item Box

This User Guide provides information about the following:

  • Introduction
  • Getting Started
  • Licensing
  • Distributing Applications & Deployment
  • Concepts
  • How To


%%ItemTitle%%

Introduction
Send Feedback
PrintPRO 6 for .NET - User Guide > Introduction

Glossary Item Box

This section provides information about the following:

  • What is PrintPRO?
  • What is the ImagXpress Product Family?
  • Getting Support
  • Accusoft Corporation Copyrights & Trademarks


%%ItemTitle%%

What is PrintPRO?
See Also Send Feedback
PrintPRO 6 for .NET - User Guide > Introduction > What is PrintPRO?

Glossary Item Box

PrintPRO™ Version 6 is a windowless control that enables the user to access and modify printer properties, create a print job, preview printing, and print to a device or file. PrintPRO offers the flexibility to create a custom printing UI, and may be used to interact with the printer, by-passing the print driver.

New Features in Version 6

  • We have added a feature to permit the developer to request the supported resolutions of the printer in Dots Per Inch.
  • We have added a feature to report on the version/build number of the control, e.g., 6.0.6.0. This will correlate exactly to what is listed in the About Box.
  • We have added a new licensing model.

Primary Features

  • Bypass default printing functions and add your own rich, custom interface
  • Select a Printer
  • Set Printer Properties
  • Set Print Margins and Coordinates
  • Image Color Management for Printers and Monitors
  • Change text font, alignment, rotation, background transparency and more in printed image
  • Add graphics to a printed image
  • Print collages
  • Print Preview
  • Print to Device
  • Print to File, including: TIFF, TIFF (JPEG compressed), and PDF (compressed to G3, Jbig2, JPEG)
  • Supports single and multi-page documents

See Also

Getting Support
Accusoft Corporation Copyrights & Trademarks


%%ItemTitle%%

What is the ImagXpress Product Family?
Send Feedback
PrintPRO 6 for .NET - User Guide > Introduction > What is the ImagXpress Product Family?

Glossary Item Box

ImagXpress® Version 11 lets you quickly add the world's most trusted imaging functions to your Windows application. With our powerful imaging tools, you can quickly develop applications that require complex imaging tasks for document imaging, photo processing, or medical applications, while you concentrate on the unique needs of your program.

ImagXpress is the image handling engine behind most of our advanced recognition and image processing products. It's the fastest way to develop professional applications involving images.

The ImagXpress v11 Product Family includes the following Components:

  • ImagXpress v11 – image compression, decompression, viewing, and processing
  • NotateXpress™ v11 – image annotation support
  • ThumbnailXpress™ v4 – thumbnail image support
  • TwainPRO™ v7 – TWAIN image acquisition support
  • PrintPRO™ v6 – image printing support

ImagXpress Editions

The components within the ImagXpress v11 Product Family are available in two editions, designed to meet specific imaging needs:

  • Professional: includes ImagXpress, NotateXpress, TwainPRO, PrintPRO, and ThumbnailXpress
  • Standard: includes ImagXpress, TwainPRO, and ThumbnailXpress

Additional Accusoft Components

Additional components are available for purchase separately, and integrate easily to provide a comprehensive imaging solution:

  • ISIS® Xpress™ – ISIS image acquisition support; license sold separately
  • PDF Xpress™ – PDF creation, viewing, and annotating
  • OCR Xpress™ – full page OCR
  • Barcode Xpress™ – recognize barcodes
  • ScanFix Xpress™ – advanced image cleanup
  • FormFix™ – form ID, dropout, and OMR
  • SmartZone™ ICR / OCR – character recognition
  • ImageGear for .NET - Fully managed code to create cutting edge imaging applications
  • ImageGear for Silverlight - Comprehensive SDK for building Web imaging applications
  • ImageGear for .NET Compact Framework - Create reliable and secure imaging applications for mobile devices

See www.accusoft.com for product packaging and sales information.


%%ItemTitle%%

Getting Support
Send Feedback
PrintPRO 6 for .NET - User Guide > Introduction > Getting Support

Glossary Item Box

For information about Accusoft Support, please refer to the Software Support and Maintenance Policy on the Accusoft web site or call Accusoft at 813-875-7575.


%%ItemTitle%%

Accusoft Corporation Copyrights & Trademarks
Send Feedback
PrintPRO 6 for .NET - User Guide > Introduction > Accusoft Corporation Copyrights & Trademarks

Glossary Item Box

©1997-2012 Accusoft Corporation. All rights reserved.

Information in this document is subject to change without notice. No part of this document may be reproduced or transmitted in any form or by any means, electronic or mechanical, for any purpose, without the express written permission of Accusoft® Corporation.

This manual and the software described in it are both products of the USA.

Accusoft Corporation
4001 North Riverside Drive
Tampa, FL 33603
Sales: 813-875-7575
www.accusoft.com

Accusoft Trademarks

The following are trademarks (™) or registered marks (®) of Accusoft Corporation:

  • Accusoft®
  • Accusoft Logo™
  • Accusoft Pegasus Logo™
  • Adeptol®
  • AIMTools™
  • Barcode Xpress™
  • CapturePro™
  • Digital Mark Recognition® (DMR)
  • FolderBots™
  • FormAssist™
  • FormDirector™
  • FormFix™
  • FormSuite™
  • ImageGear® for .NET
  • ImageGear® for .NET Compact Framework
  • ImageGear® for Silverlight
  • ImageGear® Medical
  • ImageGear® Professional
  • ImageGear®
  • ImageTransport MD™
  • ImagXpress®
  • ISIS® Xpress™
    • ISIS is a registered trademark of EMC Corporation
    • ISIS Xpress is a trademark of Accusoft Corporation
  • MICR Xpress™
  • NetVue™
  • NotateXpress™
  • PDF Xpress™
  • Pegasus®
  • PICTools™
  • PICTools™ Document
  • PICTools™ Fingerprint
  • PICTools™ Medical
  • PICTools™ Photo
  • PICVideo™ M-JPEG Codec
  • PrintPRO™
  • Prizm®
  • Prizm® Viewer
  • ScanFix® Xpress™
  • SmartZone™
  • The JPEG Wizard™
  • ThumbnailXpress™
  • TwainPRO™

Accusoft and/or its agents use these marks and brand names in connection with its goods and/or services, in the United States and other countries.

Microsoft, Internet Explorer, Microsoft.NET, Silverlight, Visual Basic, Visual Studio, and Visual Studio.NET are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries.

Itanium is a registered trademark of Intel Corporation in the United States and other countries.

All other product and brand names are the property of their respective owners.


%%ItemTitle%%

Getting Started
Send Feedback
PrintPRO 6 for .NET - User Guide > Getting Started

Glossary Item Box

This section provides information about the following:

  • Operating Requirements
  • Installing on a Development Machine


%%ItemTitle%%

Operating Requirements
See Also Send Feedback
PrintPRO 6 for .NET - User Guide > Getting Started > Operating Requirements

Glossary Item Box

Operating Systems

PrintPRO™ runs on supported Microsoft Operating Systems:

  • Windows XP, XP Professional
  • Windows Vista
  • Windows 7
  • Windows Server 2003
  • Windows Server 2008
PrintPRO runs in 64-bit, 32-bit, and AnyCPU-compiled executables.

Threading

Accusoft considers thread-safe to be when an application using this component can use multiple controls running in the same process, where they don't interfere with each other. The thread creating the control owns the control and is the only thread that can interact with it.

Development Environment

  • Microsoft .NET Framework 2.0, 3.0, 3.5
  • Microsoft Visual Studio 2005
  • Microsoft Visual Studio 2008

See Also

Installing on a Development Machine
Getting Support


%%ItemTitle%%

Installing on a Development Machine
See Also Send Feedback
PrintPRO 6 for .NET - User Guide > Getting Started > Installing on a Development Machine

Glossary Item Box

To Install PrintPRO™ Component

Run the downloaded setup program which installs the development kit on your development machine.

The downloaded development kit includes code samples for supported platforms. Samples are available through the Start | Programs | Accusoft | PrintPRO 6 menu.

By default this will register trial licensing which allows you to develop applications but not to distribute them. The trial license allows testing of all the functions and features.

Please see the section Distributing PrintPRO to understand the limits and details to convert licensing editions.
In order to distribute your finished application you must purchase and install a fully paid license from Accusoft. The paid licenses override trial licenses.

To Use PrintPRO Help Files

Once you have installed PrintPRO, you will have access to the following stand-alone help file:

  • Accusoft.PrintPro6.Net.chm

    Access the PrintPRO stand-alone help through the Windows Start menu: Start | Programs | Accusoft | PrintPRO 6

In addition, you will have access to the following compiled collection help file, depending on which version of Visual Studio you
have installed:

  • Accusoft.PrintPro6.Net.hxs - Help 2 collection files. If you have Visual Studio 2005 or 2008, these Help 2 files will be registered.
  • AccusoftPrintPro6_Net.cab - MHV (Microsoft Help Viewer). If you have Visual Studio 2010, these MHV files will be registered.

Plugging PrintPRO Help into Visual Studio

PrintPRO Help 2 files integrate within the Help system in Visual Studio .NET automatically if Visual Studio was installed prior to installing PrintPRO. To access PrintPRO Help within Visual Studio, do the following:

  • Ensure that the MSDN Library is installed in your Visual Studio environment. If it is not installed, re-install it from your VS.NET disc.
  • Ensure that MS Help Integration Kit is installed in your Visual Studio environment. If you do not have it installed:
  1. Download the Help Integration kit from MSDN.
  2. Close Visual Studio.
  • Re-open Visual Studio, select the Help Menu and the Contents submenu. Verify Help files for Accusoft controls are listed. If Accusoft Help is not listed:
  1. Search for "VSCC" in Visual Studio Help, leaving the "Filtered by:" list box blank. Select the "Visual Studio .NET Combined Help Collection Manager" topic.
  2. Select the Help 2 collections available on your PC under the heading "Collections available for inclusion in VSCC."
  3. Take care when excluding Help collections from the default VSCC collection. These collections may be necessary to view required documentation. Instead, use the "Filtered by:" field on the Contents tab of the Help panel to focus searches on Accusoft topics. Leave the "Filtered by:" list box empty to view the entire Accusoft Help files.
  4. Select the Update VSCC button.
  5. Close all instances of Visual Studio and Microsoft Document Explorer. When you restart Visual Studio, the VSCC Help collection revises with your changes. Note: this may take several minutes.
  6. Check the Visual Studio Help/Contents tab again to see the Help collections available to you.
  • Select the PrintPRO Help file to view Help content.

See Also

Operating Requirements
Getting Support
Distributing PrintPRO


%%ItemTitle%%

Upgrading from PrintPRO 5 to PrintPRO 6
Send Feedback
PrintPRO 6 for .NET - User Guide > Getting Started > Upgrading from PrintPRO 5 to PrintPRO 6

Glossary Item Box

This section describes how to upgrade from PrintPro 5 to PrintPro 6. While generally you'll be able to replace PrintPro 5 with PrintPro 6, there are a few important changes you may need to consider. This section provides information about those changes.

Changes and New Properties/Methods

  • Added SupportedDpis property to the Printer class.
  • Added Version property to the PrintPro class.
  • Added Accusoft's new licensing structure to the ImagXpress 11 Product Family. See Licensing for information about the new licensing, and Upgrading Runtime Licensing for information about updating your licensing from an earlier version of PrintPRO.

If you encounter any porting issues, please contact support@accusoft.com for assistance.


%%ItemTitle%%

Upgrading Runtime Licensing
Send Feedback
PrintPRO 6 for .NET - User Guide > Getting Started > Upgrading Runtime Licensing

Glossary Item Box

This section describes how to upgrade to Accusoft's new Runtime Licensing.

Prior to PrintPRO 6, runtime licensing was accomplished using the UnlockRuntime method.

In PrintPRO 6, the default licensing model is Automatically Reported Runtime Licensing. However, based on your contracted usage of this software, you may be eligible for Manually Reported Runtime Licensing. Your Accusoft Sales Representative (sales@accusoft.com) can help you determine which model is appropriate.

Refer to the following sections for information about upgrading to the new Runtime Licensing models:

  • Upgrading to Automatically Reported Runtime Licensing
  • Upgrading to Manually Reported Runtime Licensing

Upgrading to Automatically Reported Runtime Licensing

Automatically Reported Runtime Licensing requires a license to be installed on the end-user's machine. See the Licensing section for more information.

In your PrintPRO 5 codebase, find any existing calls to the UnlockRuntime method.

C# Copy Code
 PrintPro1.Licensing.UnlockRuntime(12345,12345,12345,12345);
VB.NET Copy Code
 PrintPro1.Licensing.UnlockRuntime(12345,12345,12345,12345)

In your PrintPRO 6 codebase, replace the UnlockRuntime method with calls to the SetSolutionName and SetSolutionKey methods.

C# Copy Code
 PrintPro1.Licensing.SetSolutionName("YourSolutionName");
 PrintPro1.Licensing.SetSolutionKey(12345,12345,12345,12345);
VB.NET Copy Code
 PrintPro1.Licensing.SetSolutionName("YourSolutionName")
 PrintPro1.Licensing.SetSolutionKey(12345,12345,12345,12345)

Upgrading to Manually Reported Runtime Licensing

In your PrintPRO 5 codebase, find any existing calls to the UnlockRuntime method.

C# Copy Code
 PrintPro1.Licensing.UnlockRuntime(12345,12345,12345,12345);
VB.NET Copy Code
 PrintPro1.Licensing.UnlockRuntime(12345,12345,12345,12345)

In your PrintPRO 6 codebase, replace the UnlockRuntime method with calls to the SetSolutionName, SetSolutionKey, and SetOEMLicenseKey methods.

C# Copy Code
 PrintPro1.Licensing.SetSolutionName("YourSolutionName");
 PrintPro1.Licensing.SetSolutionKey(12345,12345,12345,12345);
 PrintPro1.Licensing.SetOEMLicenseKey("1.0.AStringForOEMLicensing…");
VB.NET Copy Code
 PrintPro1.Licensing.SetSolutionName("YourSolutionName")
 PrintPro1.Licensing.SetSolutionKey(12345,12345,12345,12345)
 PrintPro1.Licensing.SetOEMLicenseKey("1.0.AStringForOEMLicensing…")

There is no longer a separate method for web licensing. That functionality has been integrated into the SetOEMLicenseKey method.

If you encounter any porting issues, please contact support@accusoft.com for assistance.


%%ItemTitle%%

Licensing
See Also Send Feedback
PrintPRO 6 for .NET - User Guide > Licensing

Glossary Item Box

Accusoft has introduced a new licensing structure, which provides the following benefits:

  • Toolkit Licensing (also known as Developer or SDK licensing) has been simplified, no longer requiring manual entry of license registration codes.
  • Runtime Licensing (also known as Deployment licensing) has been made more flexible, enabling support for a number of different deployment scenarios.

During evaluation of Accusoft products, Evaluation Toolkit licenses can be used to try out products. However, the product behavior is limited by trial dialog pop-ups, timeouts, or evaluation watermarks.

Accusoft requires customers to purchase licenses for both development and deployment.

  • Development/Toolkit Licensing: When you determine the product is a good fit, you can purchase a Toolkit license to eliminate trial dialog pop-ups, timeouts, and evaluation watermarks while you develop your application.
  • Deployment/Runtime Licensing: Once you have an application that is ready for distribution, you have several options for deployment. Your own deployment scenario will dictate which option is the most appropriate. There are also cost considerations for each licensing model; see the product's "pricing" page or speak with an Accusoft Sales Representative (sales@accusoft.com) for more information.
    • Manually Reported Runtime Licensing: In this model, you embed all of the licensing information directly into your application. You must manually provide royalty reporting to Accusoft for the actual licenses deployed. This model will be the best choice for you if you are not connected to the Internet at runtime, as might be the case in an defense or financial application.
    • Automatically Reported Runtime Licensing using the Server Licensing Utility (SLU): In this model, you run a small GUI tool one time on each deployment target to configure licensing. This model will be the best choice for you if you handle the deployments yourself.
    • Automatically Reported Runtime Licensing using the Licensing Development Kit (LDK): In this model, you embed function calls into your application that perform the license verification at runtime. This model will be the best choice for you if you wish to hide licensing from your end users.

See Also

Licensing Glossary


%%ItemTitle%%

Evaluation Licensing
Send Feedback
PrintPRO 6 for .NET - User Guide > Licensing > Evaluation Licensing

Glossary Item Box

During evaluation of Accusoft products, Evaluation Toolkit licenses can be used to try out products. However, the product behavior is limited by trial dialog pop-ups, timeouts, or evaluation watermarks. When you determine the product is a good fit, you can purchase a Toolkit license to eliminate trial dialog pop-ups, timeouts, and evaluation watermarks.

An evaluation dialog similar to the following evaluation dialog is displayed when you have a valid evaluation license.

However, if you attempt to execute a function that is not licensed in the edition license you are using (e.g., if you have a paid license for ImagXpress Standard and attempt to execute a function available only in ImagXpress Professional), an evaluation dialog similar to the following evaluation dialog is displayed.

If no license is found in the registry, a dialog similar to the following dialog will be displayed.


%%ItemTitle%%

Toolkit Licensing
Send Feedback
PrintPRO 6 for .NET - User Guide > Licensing > Toolkit Licensing

Glossary Item Box

Accusoft requires customers who are developing code that uses Accusoft components to have a Toolkit license for each developer.

This section provides information about the following:

  • Assigned Toolkit License
  • License Manager
  • Product Editions
  • Registration
    • Registering When Connected to the Internet
    • Registering When Disconnected from the Internet
  • Developing Code


%%ItemTitle%%

Assigned Toolkit License
Send Feedback
PrintPRO 6 for .NET - User Guide > Licensing > Toolkit Licensing > Assigned Toolkit License

Glossary Item Box

When licenses are purchased for developers at an organization, a representative is designated to assign the licenses to developers at the organization. Each developer must create an account on Accusoft’s website prior to the assignment of licenses. The organization’s designated representative may request that licenses be reassigned as a result of personnel changes.


%%ItemTitle%%

License Manager
Send Feedback
PrintPRO 6 for .NET - User Guide > Licensing > Toolkit Licensing > License Manager

Glossary Item Box

The License Manager is a GUI application that is used by a developer to register and activate Toolkit licenses on their development system. When a paid Toolkit license is registered, the License Manager:

  • Communicates the developer's credentials and the hardware information for the development system to the licensing web service.
  • Installs the returned license key on that system.

Activation involves choosing a Toolkit license, either evaluation or paid, so that the license is active on the system.


%%ItemTitle%%

Product Editions
Send Feedback
PrintPRO 6 for .NET - User Guide > Licensing > Toolkit Licensing > Product Editions

Glossary Item Box

Accusoft products may have multiple editions, each of which supports different features. Products that support multiple editions are installed with multiple evaluation Toolkit licenses, one evaluation Toolkit license per edition.

Selecting An Edition (Activating a Toolkit License)

Evaluation licenses allow developers to try features in different product editions. Since each license supports only a single edition of a product, the developer can switch between editions by activating the corresponding Toolkit license, either purchased or evaluation, using the License Manager.

When a customer downloads an evaluation Toolkit, the evaluation Toolkit license for the edition with the most features is installed by default. However, the developer may run the License Manager to change the Toolkit license to a lower edition in order to determine if that edition will serve their needs.

If a customer has purchased multiple editions of the same product, they may install both editions on a development system, but only one edition may be active at a time. Once a license has been activated for a particular system, it may be deactivated (replaced by activating another edition) or reactivated at any time. Similarly, customers who own a lower featured edition may activate a higher featured edition evaluation Toolkit license and then switch back to their paid, lower-featured Toolkit edition license at any time. For example, you can go from a paid Standard edition to an evaluation Professional edition by activating the Professional edition evaluation Toolkit license.


%%ItemTitle%%

Registration
Send Feedback
PrintPRO 6 for .NET - User Guide > Licensing > Toolkit Licensing > Registration

Glossary Item Box

Registration is the process of creating a paid Toolkit license key for a particular system. Registration for Toolkit licenses is always done through the License Manager. This enables the features for the purchased edition to operate without nag dialogs or watermarks. Registration for each license is only required to be performed once per development system. After a license has been registered on a system, you can use the license without further interaction with the License Manager.

Also refer to the following sections:

  • Registering When Connected to the Internet
  • Registering When Disconnected from the Internet


%%ItemTitle%%

Registering When Connected to the Internet
Send Feedback
PrintPRO 6 for .NET - User Guide > Licensing > Toolkit Licensing > Registration > Registering When Connected to the Internet

Glossary Item Box

When the development system is connected to the Internet, registration is a fairly simple process.

  1. Start the License Manager.
  2. When prompted, enter your Accusoft login and password.

    The License Manager then displays the available evaluation and purchased licenses assigned to you.

  3. Select a toolkit and click the link to activate the license for that toolkit.

    The License Manager then requests a new license key from the licensing web service and installs it; this completes the registration process.

    If the selected license cannot be installed on the development system due to connection failures or other reasons, a temporary, 15 day "grace" license is installed so as not to interrupt development while a new license is obtained for the development system.


%%ItemTitle%%

Registering When Disconnected from the Internet
Send Feedback
PrintPRO 6 for .NET - User Guide > Licensing > Toolkit Licensing > Registration > Registering When Disconnected from the Internet

Glossary Item Box

When the development system is not connected to the Internet during registration, as is the case in some defense or financial institutions, registration is only slightly less simple.

  1. Run the License Manager and attempt to log in.
    The License Manager detects that the system is not registered and displays the following dialog:

  2. Select the Install Offline option to begin the offline registration process.

  3. Copy the URL to removable media, such as a thumb drive.

  4. Take the thumb drive to a system that is connected to the Internet.
  5. From the connected system, paste the URL into a browser, which automatically displays the toolkits available.
  6. Upon selecting a toolkit, a license is generated, which you then save to the removable media device.
  7. Return to the offline system where the new license is to be installed.
  8. Use the License Manager to browse to the file and install the Toolkit license.


%%ItemTitle%%

Developing Code
Send Feedback
PrintPRO 6 for .NET - User Guide > Licensing > Toolkit Licensing > Developing Code

Glossary Item Box

Once an evaluation or paid Toolkit license has been activated on the development system, no additional code is required to use the Accusoft products on this system. If moving the resulting executable code to a new system, you will need to install Toolkit licenses or incorporate Runtime licenses into your code.


%%ItemTitle%%

Runtime Licensing
Send Feedback
PrintPRO 6 for .NET - User Guide > Licensing > Runtime Licensing

Glossary Item Box

When an application that uses one or more Accusoft products is deployed, it requires a Runtime License for each installation. There are two main types of Runtime Licenses:

  • Automatically Reported. Distribution of Automatically Reported Runtime licenses is handled automatically through the use of licensing software components and web services.
  • Manually Reported. Manually Reported Runtime licensing requires you to provide the number of licenses distributed on a contractually agreed upon basis.

These licensing types are each described in detail in the following sections:

  • Automatically Reported Runtime (Node-Locked)
    • Licensing API
    • License Pools
    • License Configuration Files
    • LDK vs. SLU
      • Server Licensing Utility (SLU)
      • Licensing Development Kit (LDK)
    • Deployment Proxy Service (DPS)
  • Manually Reported Runtime (Non-Node-Locked)
    • Solution Name
    • Solution Key
    • OEM License Key
If you are upgrading from an earlier version of PrintPRO, please see the Upgrading Runtime Licensing section for important information.


%%ItemTitle%%

Automatically Reported Runtime (Node-Locked)
Send Feedback
PrintPRO 6 for .NET - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked)

Glossary Item Box

Automatically Reported Runtime licenses use a mechanism similar to Toolkit licensing to activate a license for a particular system. In this case, each installation has a unique license that is pulled from the pool of licenses purchased by the customer. When the license key is generated, it contains hardware information that identifies the system on which the license is to be installed.

The Licensing Development Kit component, which interacts with the licensing web service and installs the newly generated license key, may be used directly by the application or it may be used through a simple tool known as the Server Licensing Utility.

  • The Licensing Development Kit requires integration with the application or installation utility to perform license activation.
  • The Server Licensing Utility is a stand-alone application that integrates the Licensing Development Kit to perform the registration.

This topic provides information about the following:

  • Licensing API
  • License Pools
  • License Configuration Files
  • LDK vs. SLU
    • Server Licensing Utility (SLU)
    • Licensing Development Kit (LDK)
  • Deployment Proxy Service (DPS)


%%ItemTitle%%

Licensing API
Send Feedback
PrintPRO 6 for .NET - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > Licensing API

Glossary Item Box

The Licensing API is used in the developer’s code to specify Runtime Licensing deployment information. This is used to unlock the Accusoft products and enable all licensed features at runtime. Both the "Solution Name" and "Solution Key" values used in the API described below are provided by Accusoft, along with the License Configuration file, at the time of purchase of a Runtime License.

Solution Name

The solution name is the name assigned by Accusoft to the licenses purchased for runtime deployment. It is a character string that is set for a component prior to use in a deployment environment and is typically the name of the organization that purchased the runtime licenses. It is set via the SetSolutionName method of the component’s Licensing class. For example:

Copy Code
PrintPro pp = new PrintPro();
pp.Licensing.SetSolutionName("ACMEImaging");

The Solution Name must be set in order to use runtime licensing.

Solution Key

The Solution Key is a set of four numbers assigned when the licenses are purchased for runtime deployment; the Solution Key also identifies the organization that purchased the runtime licenses. The Solution Key is set via the SetSolutionKey method of the component’s Licensing class. For example:

Copy Code
PrintPro pp = new PrintPro();
pp.Licensing.SetSolutionName("ACMEImaging");
pp.Licensing.SetSolutionKey(0x1C3A023F, 0xA018F260, 0x37AF0E51, 0x557F2389);

The Solution Key must be set in order to use runtime licensing.


%%ItemTitle%%

License Pools
Send Feedback
PrintPRO 6 for .NET - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > License Pools

Glossary Item Box

When Automatically Reported Runtime licenses are purchased, they are organized into pools of a specific version and platform for a particular toolkit. For example, if a customer developed two applications using ImagXpress, one using 32-bit ActiveX and the other using .NET, they would purchase two pools of runtime licenses, one for the ActiveX platform and one for the .NET platform. At installation, a new license would be pulled from the appropriate pool, depending upon which platform the application is using.


%%ItemTitle%%

License Configuration Files
See Also Send Feedback
PrintPRO 6 for .NET - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > License Configuration Files

Glossary Item Box

When an Automatically Reported Runtime license is purchased, a License Configuration file is created and distributed to the customer along with their assigned Solution Name and Solution Key. The License Configuration file contains information about the Runtime licenses for a particular platform and version of a toolkit. It is used by the Server Licensing Utility or License Development Kit to activate licenses when the customer’s application is installed on their users' systems.

See Also

Licensing API


%%ItemTitle%%

LDK vs. SLU
Send Feedback
PrintPRO 6 for .NET - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > LDK vs. SLU

Glossary Item Box

Both the Licensing Deployment Kit and the Server Licensing Utility perform the same function of registering the Runtime license for the system on which it will be run. Both are provided in order to give you some options.

  • If you are deploying to your own systems (e.g., for enterprise IT staff), the use of an Accusoft branded Server Licensing Utility may meet your needs. Similarly, if you handle the deployment onto end users systems, you may also find the Server Licensing Utility to be sufficient.
  • If you wish to hide this licensing registration from end users, you will likely choose the Licensing Deployment Kit, which allows you to integrate the registration process into your application. The Licensing Deployment Kit also allows for the optional assignment of Access Keys to specific users, which lets you manage your licenses more directly and limits the distribution of licenses.


%%ItemTitle%%

Server Licensing Utility (SLU)
Send Feedback
PrintPRO 6 for .NET - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > LDK vs. SLU > Server Licensing Utility (SLU)

Glossary Item Box

The Server Licensing Utility is a simple Windows application that uses License Configuration Files to request a license key from the purchased Runtime licenses. The Server Licensing Utility registers that Runtime license on the system where your application will be running. This utility can be used by developers for testing, by your deployment team, or by your end users to register their Runtime license.

In the Server Licensing Utility dialog, add your License Configuration file(s) as follows:

  1. Click Add and navigate to your License Configuration file(s).
  2. Select the appropriate License Configuration file(s) and click Open.
  3. After all applicable License Configuration files have been added, click Auto Register or Manually Register, depending on whether or not you are connected to the Internet. Refer to the sections below for more information.

Auto Register Toolkit (Connected to Internet)

Automatic registration works in much the same way as connected Toolkit registration and requires an Internet connection on the system where your application software will be deployed. The license information along with the system’s hardware information is sent over the Internet to the Accusoft licensing web service. If an unused license is available, a new license key containing information for the system is generated, returned, and is then automatically installed by the Server Licensing Utility.

Manually Register Toolkit (Disconnected from Internet)

Manual registration is used when the system where your application software will be deployed is not connected to the Internet and therefore cannot be registered automatically. This operation is similar to Disconnected Registration with the License Manager.

  1. Copy the Hardware Key and URL to a removable media device, such as a thumb drive, and then take it to a system that is connected to the Internet.
  2. From the connected system, paste the URL into a browser. A page will appear that contains a field into which you enter the hardware key.
  3. After this hardware key is entered, a license file with the license key is downloaded, which you then save to the removable media device.
  4. Return to the offline system with the removable media device onto which you have saved the license file.
  5. Click Open License File and navigate to the license file. Click OK in the file selection dialog.
    Alternatively, you can open the license file with a text editor, copy the license key to the clipboard, and click Paste License Key to paste the new license key into the License Key field.
  6. Click the License button; the new license will be installed.


%%ItemTitle%%

Licensing Development Kit (LDK)
Send Feedback
PrintPRO 6 for .NET - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > LDK vs. SLU > Licensing Development Kit (LDK)

Glossary Item Box

The Licensing Development Kit is an ActiveX component that may be used instead of the Server Licensing Utility. (Actually, the Server Licensing Utility is only a user interface for the Licensing Development Kit.) The Licensing Development Kit provides an interface for a developer to set the License Configuration File path and other properties as well as initiate requests to the licensing web service to generate license keys.

This topic contains these sections:

  • AccuLicClient.DLL
  • Assigned Access Keys
  • Automatic (Connected) Mode Registration
  • Manual (Disconnected) Mode Registration
  • Evaluation
  • Licensing Development Kit Interface
  • Licensing Development Kit Properties
  • Licensing Development Kit Methods

AccuLicClient.DLL

The AccuLicClient.DLL is located with the Server Licensing Utility. It is a 32-bit ActiveX/COM DLL which is used to execute runtime licensing activation functions. The bulk of the functionality provided by the Server Licensing Utility (SLU) is contained within the AccuLicClient.DLL and can be used within your own custom applications to achieve the same thing.

Assigned Access Keys

Unlike the Server Licensing Utility, the Licensing Development Kit allows for the optional assignment of Access Keys to specific users. By doing this, you can specify which of your licenses are assigned to your users. This also limits the distribution of licenses. When Runtime licenses are purchased, a list of Access Keys is distributed to you for this use.

Automatic (Connected) Mode Registration

This mode corresponds to the Automatic (Connected) Registration section described in the Server Licensing Utility section. The process is shown in the C# sample code below:

Copy Code
// Instantiate the LDK ActiveX component
IDeploymentComponent ldk = new DeploymentComponent();

// Set the path to the configuration file provided
// when the runtime licenses were purchased.
ldk.ConfigPath = @"C:\config.txt";

// Attempt to get the next available license.
// Note that you may alternately pass an Access Key
ldk.GetLicKeyAuto("");

if (ldk.ResultCode != enumLdkErrorCodes.LDK_SUCCESS)
{
    // Automatic Registration Failed - A temporary license
    // has been installed but will expire in 15 days.
    // TODO add code to notify user of issue and 15 day expiration.

    if (ldk.ResultCode == enumLdkErrorCodes.LDK_ERR_INET_CONN_BROKEN)
    {
        // No Internet Connection – Optionally do manual registration
    }
}
else
{
    // The license has been registered and installed.
}

The registration process is then complete. If any part of the registration process fails, a temporary license key is installed and is typically valid for 15 days. During this time, you are allowed to use the product while resolving any licensing related problems.

Manual (Disconnected) Mode Registration

This mode corresponds to the Manual (Disconnected) Registration section described in the Server Licensing Utility section. The process is shown in the C# code below:

Copy Code
// Instantiate the LDK ActiveX component
IDeploymentComponent ldk = new DeploymentComponent();

// Set the path to the configuration file provided
// when the runtime licenses were purchased.
ldk.ConfigPath = @"C:\config.txt";

// Get the hardware key for the system.  Note
// that you may alternately pass an Access Key
string hardwareKey = ldk.GetHdwKey("");

// Write the hardware key to some type of removable media.
ApplicationSpecificMethodToWriteHardwareKey(hardwareKey);

At this point, you have the hardware key on some type of removable media. Take the media to a system that is connected to the Internet, acquire the license key by uploading the hardware key, write the new license key to the removable media, and then return to the disconnected system. The application then reads the license key from the removable media and installs the license key as shown below.

Copy Code
// After taking the hardware key to a system with an Internet
// connection and acquiring the license key string from the
// manual registration web site, read the key into your
// application.
string manuallyAcquiredLicenseKey = ApplicationSpecificMethodToReadLicenseKey();

// Install the license key
ldk.LicKey = manuallyAcquiredLicenseKey;

The manual license registration and installation is then complete. Like the automatic case above, if any error occurs during the setting of the license key, a temporary license is installed.

Evaluation

The Licensing Development Kit also has the ability to install an Evaluation License for purchased runtime products. This process is simply:

Copy Code
// Instantiate the LDK ActiveX component
IDeploymentComponent ldk = new DeploymentComponent();

// Set the path to the configuration file provided
// when the runtime licenses were purchased.
ldk.ConfigPath = @"C:\config.txt";

// Install an evaluation license
ldk.StartEvalPeriod();

Licensing Development Kit Interface

The interface to the Licensing Development Kit is shown below:

Copy Code
interface IDeploymentComponent : IDispatch
{
   [propget, id(1)] HRESULT LicKey([out, retval] BSTR* pVal);
   [propput, id(1)] HRESULT LicKey([in] BSTR newVal);
   [propget, id(2)] HRESULT srvURL([out, retval] BSTR* pVal);
   [propput, id(2)] HRESULT srvURL([in] BSTR newVal);
   [propget, id(3)] HRESULT ConfigPath([out, retval] BSTR* pVal);
   [propput, id(3)] HRESULT ConfigPath([in] BSTR newVal);
   [propget, id(4)] HRESULT ResultString([out, retval] BSTR* pVal);
   [propget, id(5)] HRESULT ResultCode([out, retval] enumLdkErrorCodes* pVal);
   [id(6)]           HRESULT GetLicKeyAuto([in] BSTR accKey);
   [id(7)]           HRESULT GetHdwKey([in] BSTR accKey, [out,retval] BSTR* hdwKey);
   [id(8)]           HRESULT StartEvalPeriod(void);
   [propget]         HRESULT LicenseInfo([out, retval] BSTR* pVal);
   [propput]         HRESULT LicenseInfo([in] BSTR newVal);
   [id(10)]          HRESULT GetEvalPeriod([out, retval] long* pVal);
};

Licensing Development Kit Properties

  • LicKey: Stores the License Key to the registry when it is set, and reads it from the registry during the get operation.
  • srvURL: Gets and sets the URL path to the licensing web service. The default is the URL path to Accusoft’s Deployment Licensing Service.
  • ConfigPath: Gets and sets a path to the deployment configuration file. Multiple products can be registered at one time by setting the filenames as a semicolon-delimited list: e.g., “c:\config.txt;c:\config2.txt”.
  • ResultString: Contains the string descriptions of any error that may have occurred during the last operation.
  • ResultCode: Can be used to contain any of the error codes described in Licensing Component Error Codes and Messages.
  • LicenseInfo: Used to transfer license information onto new system hardware. To transfer the license information into new system hardware, do the following:
  1. Get the LicenseInfo value and store it in a safe place.
  2. Change the system hardware.
  3. Set the LicenseInfo to the value you saved in step (1).
  4. Run the GetLicKeyAuto method (or perform its manual analog) to obtain a license for the new system hardware.

Licensing Development Kit Methods

  • GetLicKeyAuto: Obtains a License Key for the end user’s system using the automatic (or connected) scenario. It takes an Access Key as its input parameter, and stores the obtained license key in the registry. If you choose not to distribute individual Access Keys, the accKey argument should be an empty string.
  • GetHdwKey: Obtains a hardware key from the current machine and returns it (as hdwKey). If you choose not to distribute individual access keys, the accKey argument should be an empty string.
  • StartEvalPeriod: Sets an evaluation licensing mode for the product and starts an evaluation period. This method is provided so you can distribute an evaluation version of your application, without having to distribute Access Keys to people who would like to evaluate your software. Using this method you can license Accusoft components on the end user’s system for a limited time – the default is 30 days, but it can be customized per request to Accusoft. If the evaluators purchase your software, you can then issue them an access key using either the automatic or manual scenarios to obtain permanent component licenses, just as Accusoft does for its evaluators.
  • GetEvalPeriod: Obtains the remaining time on an evaluation (in days). It returns EvalPeriod < 0 if the evaluation period is expired.


%%ItemTitle%%

Deployment Proxy Service (DPS)
Send Feedback
PrintPRO 6 for .NET - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > Deployment Proxy Service (DPS)

Glossary Item Box

For systems where the deployed application will not have direct access to the Accusoft licensing web services, you can use the Deployment Proxy Service as a bridge to reroute the licensing communication. The Proxy Service will act as a trusted "go-between" for the Accusoft licensing system and the deployed application. This tool can be useful if the application will be deployed in a secured environment, where limited systems have external network access.

Additionally, the Proxy Service allows Accusoft customers to manage license registration more directly. The source for the Deployment Proxy Service is provided, allowing users to integrate the licensing process into their CRM, ERP, or other systems for tracking Automatically Reported Runtime Licenses.

For more information about the Deployment Proxy Service, please contact our Support team.


%%ItemTitle%%

Manually Reported Runtime (Non-Node-Locked)
Send Feedback
PrintPRO 6 for .NET - User Guide > Licensing > Runtime Licensing > Manually Reported Runtime (Non-Node-Locked)

Glossary Item Box

Manually Reported Runtime licensing embeds all of the licensing information directly into your application. Installation does not require any further licensing interaction. However, it is your responsibility to provide royalty reporting to Accusoft for the actual licenses deployed.

This section provides information about the following:

  • Solution Name
  • Solution Key
  • OEM License Key


%%ItemTitle%%

Solution Name
Send Feedback
PrintPRO 6 for .NET - User Guide > Licensing > Runtime Licensing > Manually Reported Runtime (Non-Node-Locked) > Solution Name

Glossary Item Box

The solution name is

  • A name assigned by Accusoft to the licenses purchased for runtime deployment.
  • A character string that is set for a component prior to use in a deployment environment
  • Typically the name of the organization that purchased the runtime licenses.
  • Set via the SetSolutionName method of the component’s Licensing class. For example:
Copy Code
PrintPro pp = new PrintPro();
pp.Licensing.SetSolutionName("ACMEImaging");

The Solution Name must be set in order to use runtime licensing.


%%ItemTitle%%

Solution Key
Send Feedback
PrintPRO 6 for .NET - User Guide > Licensing > Runtime Licensing > Manually Reported Runtime (Non-Node-Locked) > Solution Key

Glossary Item Box

The Solution Key is

  • A set of four numbers assigned when the licenses are purchased for runtime deployment.
  • An identifier of the organization that purchased the runtime licenses.
  • Set via the SetSolutionKey method of the component’s Licensing class. For example:
Copy Code
PrintPro pp = new PrintPro();
pp.Licensing.SetSolutionName("ACMEImaging");
pp.Licensing.SetSolutionKey(0x1C3A023F, 0xA018F260, 0x37AF0E51, 0x557F2389);

The Solution Key must be set in order to use runtime licensing.


%%ItemTitle%%

OEM License Key
Send Feedback
PrintPRO 6 for .NET - User Guide > Licensing > Runtime Licensing > Manually Reported Runtime (Non-Node-Locked) > OEM License Key

Glossary Item Box

The OEMLicense Key is

  • For use only by customers who choose to use Manually Reported Runtime licensing.
  • A unique identifier of the customer, product, version, edition, and platforms for which the license is valid.

When this key is set via the SetOEMLicenseKey method of the component’s Licensing class, the component is completely licensed and can be distributed without any further licensing operations.

Copy Code
PrintPro pp = new PrintPro();
pp.Licensing.SetSolutionName("ACMEImaging");
pp.Licensing.SetSolutionKey(0x1C3A023F, 0xA018F260, 0x37AF0E51, 0x557F2389);
pp.Licensing.SetOEMLicenseKey("1.0.GQCC0EmUgONaI4QDZ32tpGWfpGW4gtbC0iIC0iN4bigYM3m3K5b487QOsAM38O24mUp5bOpD2O240OQ32U2YsUKDKA87MYPGgGgaptMiK5Nv8AI4mYg4m3QvW52DZCPGs4p784mtP4IUgOWiIG0AQYp4052iIAWvNCZfpGWC8vQ5P4ZGKaPAWfbiYfZOI303pOZAgisiNaWA27gGsf8Ob7Zvm5IaKGI4KC8GsG2CWYpGQAg5sUmYWvZCQANig48G2ap4bG0DsO240YsUmtptNiZamCPGbYMfMO83gANAZCN52YbY8U8f8DM4m3g7MYMYWGW5Q7QGWaMiN7MtZfmtgY8AN7NDP7Z4W7sCbGKUPa0im7EDPP");

This property is not required for Automatically Reported Runtime licensing.


%%ItemTitle%%

Licensing Glossary
Send Feedback
PrintPRO 6 for .NET - User Guide > Licensing > Licensing Glossary

Glossary Item Box

The following sections each describe a licensing term:

  • Access Key
  • Accusoft Products
  • Activation
  • Assigned Access Key
  • Automatically Reported Runtime Licensing
  • Customers, Developers, and Users
  • Edition
  • Evaluation License
  • Hardware Key
  • License Configuration File
  • Licensing Development Kit (LDK)
  • License Key
  • License Manager
  • Manually Reported Runtime Licensing
  • Node-Locked Licensing
  • Non-Node-Locked Licensing
  • Paid License
  • Registration
  • Runtime (Deployment) Licensing
  • Server Licensing Utility (SLU)
  • Toolkit Licensing
  • Web Services

Access Key

All licenses are assigned a unique identifier known as an Access Key. Access Keys are associated with the organization that purchased the license.

Accusoft Products

An Accusoft product may be licensed with either a Toolkit License or a Runtime License.

Activation

Activation is the process of selecting a previously registered toolkit license. Licenses may be paid (Toolkit) or evaluation, and may be for one of many product editions, for products with multiple editions.

Assigned Access Key

An assigned Access Key is one that is assigned to a specific user or users. The assignment of Access Keys to specific users can be done using the Licensing Development Kit (LDK).

Automatically Reported Runtime Licensing

Runtimes may be licensed in one of two ways: automatic reporting or manual reporting. With automatic reporting, you do not need to worry about royalty reporting; it is handled by the licensing layer.

Customers, Developers, and Users

Customers are simply any person who has purchased an Accusoft product. Developers are customers who possess a license for an Toolkit. Users are typically the customers of Accusoft's customers who use applications built around Accusoft components and are assigned a runtime license.

Edition

Some Accusoft products have multiple editions. Editions may offer multiple levels of product speed or product features, allowing customers to find a price-performance mix that is appropriate for them. Products that support multiple editions register multiple Toolkit licenses at installation time, one Toolkit license per edition. Developers must select an edition to activate using the License Manager.

Evaluation License

An evaluation license is a Toolkit license that is unpaid. When an Accusoft Toolkit is installed, evaluation licenses for all applicable product editions are installed and registered, and the edition with the most features is activated. Evaluation Toolkit licenses can be used to try out products. However, the product behavior is limited by trial dialog pop-ups, timeouts, or evaluation watermarks. When you determine the product is a good fit, you can purchase a Toolkit license to eliminate trial dialog pop-ups, timeouts, and evaluation watermarks.

Hardware Key

When a license is activated for a product, the system information that identifies the installation hardware is contained within an encrypted string and is used to generate the license key for the product. The string containing the encrypted hardware information is known as the Hardware Key.

License Configuration File

When a Toolkit or an Automatically Reported Runtime license is purchased, a configuration file is provided that contains information about the license that was purchased. This file is used by the licensing utilities (License Manager, Server License Utility, and License Development Kit) to install a license on the system.

Licensing Development Kit (LDK)

The Licensing Development Kit (LDK) is an ActiveX component that may be used for Runtime Licensing. The LDK is one mechanism for Automatically Reported Runtime Licensing; the Server Licensing Utility (SLU) is the other.

License Key

Each product license has a unique key associated with it that uniquely identifies the customer, product, version, edition, and platforms, and, in some cases, the hardware for which the license is valid.

License Manager

The License Manager is a GUI application that is used by a developer to register and activate Toolkit licenses on their development system.

Manually Reported Runtime Licensing

Runtimes may be licensed in one of two ways: automatic reporting or manual reporting. With Manually Reported Runtime Licensing, you embed all of the licensing information directly into your application. You must manually provide royalty reporting to Accusoft for the actual licenses deployed. This model will be the best choice for you if you are not connected to the Internet at runtime, as might be the case in an defense or financial application.

Node-Locked Licensing

Another name for Automatically Reported Runtime Licensing.

Non-Node-Locked Licensing

Another name for Manually Reported Runtime Licensing.

Paid License

A paid license is a Toolkit license that you have purchased from Accusoft. It is ready to be used in production, with no trial dialog pop-ups, timeouts, or evaluation watermarks. If you wish to test other editions of the Accusoft product for which you have purchased a Paid License, you may activate an Evaluation license for that edition; a complete set of Evaluation licenses for all editions is registered at installation time.

Registration

Registration is the process of informing the License Manager about a new Toolkit license you have purchased. It uses this information to create a license key on your system; this allows you to activate the product for development with no restrictions, such as trial dialog pop-ups, timeouts, or evaluation watermarks.

Runtime (Deployment) Licensing

When deploying an application, a Runtime License is also required for each user’s installation. You must purchase runtime licenses, which are consumed as licenses are registered. There are two Runtime licensing models: Automatically Reported Runtime License; and Manually Reported Runtime License.

Server Licensing Utility (SLU)

The Server Licensing Utility (SLU) is a small GUI application that allows you to request a license key from the Runtime licenses you have purchased. The SLU is one mechanism for Automatically Reported Runtime Licensing; the Licensing Development Kit (LDK) is the other.

Toolkit Licensing

Each Toolkit is assigned to a specific developer who has a registered account with Accusoft. When the developer installs the Toolkit, it is not fully functional until they have activated the license through the use of the License Manager application. When the developer starts the License Manager, they are required to provide login credentials that identify and allow them to activate their license on a development system. See Toolkit Licensing.

Web Services

When a license is registered, information that uniquely identifies the customer’s or user’s hardware is passed along with the license information over the Internet to a web service. The web service validates the licensing request, generates a key that includes the hardware information, and returns the new license key to the application that made the licensing request. The license key is then stored on the requested system and used by the component when it is executed. It is also possible to register systems that are not directly connected to the Internet through the use of removable media and a different system that is connected to the Internet.


%%ItemTitle%%

Software License Agreement
See Also Send Feedback
PrintPRO 6 for .NET - User Guide > Licensing > Software License Agreement

Glossary Item Box

PLEASE READ THE FOLLOWING SOFTWARE LICENSE AGREEMENT WHICH GOVERNS YOUR RIGHT TO USE OF THE TOOLKIT. YOU MUST ACCEPT THESE TERMS BEFORE YOU ARE ALLOWED TO INSTALL THE TOOLKIT. YOU EXPRESSLY AGREE THAT YOU HAVE THE AUTHORITY TO CONTRACTUALLY BIND THE ORGANIZATION AGREEING TO THESE TERMS.

BY CLICKING "I ACCEPT," OR INSTALLING TOOLKIT, OR PLACING TOOLKIT IN-USE, LICENSEE IS AGREEING TO BE BOUND BY THIS AGREEMENT.

1. GRANT OF AGREEMENT

This Accusoft Corporation, ("ACCUSOFT") Software License Agreement ("AGREEMENT") grants the organization contracting under this agreement as licensee ("LICENSEE") a limited, nontransferable, nonexclusive and non-assignable license to use the trial mode version of this ACCUSOFT Development Toolkit ("TOOLKIT") on a single computer for evaluation of fitness only and not for any commercial purpose; or to use a properly purchased and registered TOOLKIT, for development purposes only on a single computer, provided the TOOLKIT is IN-USE on only one computer at any time. (However additional TOOLKIT licenses may be purchased.) TOOLKIT is "IN-USE" on a computer when it becomes loaded by any means for any purpose into temporary memory (that is, including but not limited to RAM) or when it becomes copied or installed to less temporary storage by any means for any purpose (that is, including but not limited to hard disk, CD-ROM or other removable disk or tape, USB or other flash memory drive or card, or other local, networked, or cloud storage device) when it is accessible to that computer. The TOOLKIT is explicitly not to be used on a site-wide basis, via a server or other networked connection.

2. REDISTRIBUTION OF TOOLKIT RUNTIMES

ACCUSOFT does not grant LICENSEE any rights to deploy, license, sell, reproduce, copy, install, lease, timeshare, rent, or otherwise distribute or transfer TOOLKIT or any portion of TOOLKIT ("PORTION") except as provided in Section 1. GRANT OF AGREEMENT. For licensing information about any other distribution of TOOLKIT or PORTION, please visit our web site (www.accusoft.com/licensing.htm), or contact our sales staff. LICENSEE agrees to notify ACCUSOFT immediately of any violations or changes in status regarding LICENSEE's compliance with any term of this AGREEMENT.

In the event that ACCUSOFT grants LICENSEE in a written separate runtime license agreement ("RUNTIME AGREEMENT") a right to deploy, license, sell, reproduce, copy, install, lease, timeshare, rent, or otherwise distribute or transfer PORTIONS, the RUNTIME AGREEMENT will specify what PORTIONS may be distributed ("RUNTIME"). LICENSEE agrees to acknowledge and uphold the terms and conditions of this AGREEMENT as well as the terms of the RUNTIME AGREEMENT itself, which will be provided only in writing. In such event, LICENSEE may distribute RUNTIMES as part of the LICENSEE's software application or derivative works ("PRODUCT") upon additionally agreeing to the following:

a) LICENSEE understands and acknowledges that in order to receive any discounted pricing for RUNTIME distribution licensing fees based on the type of installation, it must either: 1) prepay for a number of RUNTIME licenses that is sufficient to qualify for ACCUSOFT's then-current published quantity discount, or 2) it must pay for the licenses in accordance with a written contract between LICENSEE and ACCUSOFT.

b) LICENSEE's PRODUCT shall not compete to any degree with the TOOLKIT. Such competitive PRODUCTS are defined as software development toolkits that include similar functionality as TOOLKIT and that are intended for use by software developers and/or system integrators.

c) LICENSEE's PRODUCT must be substantially greater in scope with greater functionality and features than those of the TOOLKIT.

d) LICENSEE will not use ACCUSOFT's name, logo, or trademarks to market PRODUCT without prior written approval of ACCUSOFT except LICENSEE will include a statement substantially similar to the following within PRODUCT documentation and about box: "Portions of this product contain imaging and other technology owned by Accusoft Corporation, Tampa, FL, (www.accusoft.com). ALL RIGHTS RESERVED."

e) LICENSEE agrees to only distribute the RUNTIMES. No license or other rights are granted to LICENSEE for any distribution of the TOOLKIT or PORTIONS including, but not limited to, documentation, source code, or the RUNTIME distribution unlock codes.

g) LICENSEE will only distribute the RUNTIMES on the hardware and operating system(s) for which the RUNTIMES are intended to be used according to the RUNTIME AGREEMENT.

If ANY of the terms of this AGREEMENT are not applicable to LICENSEE'S situation, or if any of the terms of this AGREEMENT cannot be complied with, or if LICENSEE needs modifications to this AGREEMENT or the license granted for any reason, LICENSEE must contact ACCUSOFT about obtaining an expanded license from ACCUSOFT (available by phone at: 813-875-7575, x321, by e-mail at: Sales@accusoft.com or by fax at: 813-875-7705).

This AGREEMENT grants rights to LICENSEE only for the TOOLKIT and does not convey any other rights of use or distribution to ACCUSOFT technology.

3. OWNERSHIP

LICENSEE acknowledges and agrees that ACCUSOFT owns all rights, title and interest in the TOOLKIT, in all forms, including without limitation any and all worldwide proprietary rights therein, including but not limited to trademarks, copyrights, patent rights, patent continuations, trade secrets and confidential information.

LICENSEE may not remove or alter the copyright notice from any copy of the TOOLKIT or any copy of the written materials, accompanying the TOOLKIT.

LICENSEE waives its right to contest any of ACCUSOFT's patents, trademarks, service marks, trade names, copyrights, and other intellectual property and proprietary rights in and to the TOOLKIT.

LICENSEE shall not use such trademarks, service marks, and trade names except where and as permitted under this AGREEMENT without receiving ACCUSOFT's prior written approval of such use. If such approval is granted, LICENSEE’s right to use such trademarks, service marks, and trade names shall end upon the termination of this AGREEMENT.

4. RESTRICTIONS AND RESERVATIONS.

All rights and licenses not expressly granted to LICENSEE are reserved to ACCUSOFT. LICENSEE is strictly prohibited from reproducing, copying, marketing, selling, distributing, licensing, sublicensing, leasing, timesharing or renting the TOOLKIT or PORTION, and LICENSEE is strictly prohibited from any use of the TOOLKIT or PORTION except as permitted by this AGREEMENT, and such actions are expressly prohibited. LICENSEE is strictly prohibited from incorporating or including the TOOLKIT or PORTION into or as part of any PRODUCT or service of LICENSEE except as provided by this AGREEMENT, regardless of the functionality of TOOLKIT (or lack thereof) within or as part of such PRODUCT or service of LICENSEE. LICENSEE shall not for any reason disassemble, decompile, decrypt or reverse engineer the TOOLKIT or PORTION or in any manner attempt to discover or reproduce the source code or any other copyrightable, proprietary, or trade secret aspect of the TOOLKIT or PORTION. Nor shall LICENSEE use the TOOLKIT or PORTION, directly or indirectly, in developing LICENSEE's own PRODUCT with, or including, similar functionality. LICENSEE shall not make any copies of the TOOLKIT or PORTION for any purpose whatsoever except as permitted by this AGREEMENT. Source code that is provided with TOOLKIT for sample or demonstration purposes may be used directly or indirectly in developing PRODUCT, however it may not be distributed in source form in whole or in part with or as part of PRODUCT.

5. WARRANTY DISCLAIMER

LICENSEE ACKNOWLEDGES AND AGREES THAT THE TOOLKIT IS PROVIDED "AS IS." ACCUSOFT DISCLAIMS ANY AND ALL REPRESENTATIONS AND WARRANTIES OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND AGAINST INFRINGEMENT.

6. LIMITATION OF LIABILITY

ACCUSOFT SHALL HAVE NO LIABILITY TO LICENSEE, LICENSEE AFFILIATES, SUBSIDIARIES, SHAREHOLDERS, OFFICERS, DIRECTORS, EMPLOYEES, REPRESENTATIVES OR ANY THIRD PARTY, WHETHER IN CONTRACT, TORT, NEGLIGENCE OR PRODUCTS LIABILITY, FOR ANY CLAIM, LOSS OR DAMAGE, INCLUDING BUT NOT LIMITED TO, LOST PROFITS, LOSS OF USE, BUSINESS INTERRUPTION, LOST DATA, LOST FILES, OR FOR ANY DIRECT, INDIRECT, SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES OF ANY KIND OR NATURE WHATSOEVER ARISING OUT OF OR IN CONNECTION WITH USE OF OR INABILITY TO USE THE TOOLKIT, OR THE PERFORMANCE OR OPERATION OF THE TOOLKIT, EVEN IF ACCUSOFT HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

7. INDEMNIFICATION BY LICENSEE

LICENSEE SHALL INDEMNIFY, HOLD HARMLESS AND DEFEND ACCUSOFT FOR ANY LOSS, CLAIM, ACTION OR PROCEEDING THAT ARISES OR RESULTS FROM ANY ACTIONS OR OMISSIONS OF LICENSEE PERTAINING TO THE PRODUCT OR THE TOOLKIT AND FROM ANY ACTIONS OF LICENSEE THAT ARE IN VIOLATION OF THIS AGREEMENT.

8. TERM AND TERMINATION

Unless otherwise agreed to by the parties, this AGREEMENT shall become effective upon the earlier of LICENSEE's clicking of "I Accept" or LICENSEE'S installing or placing TOOLKIT IN_USE ("Effective Date") and shall continue in full force and effect until terminated in accordance with the terms set forth in this AGREEMENT.

Any material breach of this AGREEMENT shall automatically and immediately terminate this AGREEMENT. In the event that LICENSEE ceases to do business or is adjudged bankrupt or insolvent, ACCUSOFT may, at its sole option, terminate this AGREEMENT, by giving ten (10) Business Days written notice of such termination, which notice shall identify and describe the basis for such termination.

In the event of any termination of this AGREEMENT, any RUNTIME AGREEMENT is simultaneously terminated and LICENSEE shall stop using the TOOLKIT and PORTION, shall cease manufacturing the PRODUCT containing TOOLKIT or PORTION, and shall cease distributing PRODUCT containing TOOLKIT or PORTION. LICENSEE shall also require its resellers, OEMs, and other distribution channels (if any) to likewise stop manufacturing and distributing the PRODUCT containing TOOLKIT or PORTION. Within ten (10) Business Days thereafter, LICENSEE shall return or, at ACCUSOFT's option, destroy, the TOOLKIT and all PORTIONS, whether or not incorporated in or with the PRODUCT, that are within LICENSEE’s possession, custody and control, and shall certify to ACCUSOFT in writing within ten (10) Business Days after that return or destruction that it has complied with the foregoing obligation.

All Sections except Section 1. GRANT OF LICENSE shall continue in full force and effect, notwithstanding any termination of this AGREEMENT.

9. LIQUIDATED DAMAGES

In the event LICENSEE (a) copies the TOOLKIT or PORTION except as permitted by this AGREEMENT, (b) uses the TOOLKIT or PORTION for any reason other than as permitted by this AGREEMENT, (c) installs or uses the TOOLKIT or PORTION on more than a single computer, or (d) otherwise violates or breaches this Agreement, LICENSEE agrees that ACCUSOFT is entitled to obtain as liquidated damages and not as a penalty the greater of the amount of (v) the published quantity one distribution price based upon the type of distribution, or (w) $99 per each user of each PRODUCT or service of LICENSEE in which the TOOLKIT or PORTION is included, copied, incorporated, embedded or accessible; (x) $100 per copy of TOOLKIT or PORTION; (y) $100 per copy of any PRODUCT in which TOOLKIT or PORTION is included, copied, incorporated, embedded or accessible; or (z) 3% of all revenues realized by LICENSEE pertaining to any PRODUCTS or services of LICENSEE in which TOOLKIT or PORTION is included, copied, incorporated, embedded or accessible. THE LICENSEE EXPRESSLY AGREES THAT THE FOREGOING LIQUIDATED DAMAGES ARE NOT A PENALTY.

10. CONFIDENTIALITY

LICENSEE acknowledges that the TOOLKIT contains ACCUSOFT know-how, confidential and trade secret information ("PROPRIETARY INFORMATION"). LICENSEE agrees: (a) to hold the PROPRIETARY INFORMATION in the strictest confidence, (b) not to, directly or indirectly, copy, reproduce, distribute, manufacture, duplicate, reveal, report, publish, disclose, cause to be disclosed, or otherwise transfer the PROPRIETARY INFORMATION to any third party, (c) not to make use of the PROPRIETARY INFORMATION other than as permitted by this AGREEMENT, and (d) to disclose the PROPRIETARY INFORMATION only to LICENSEE's representatives requiring such material for effective performance of this AGREEMENT and who have undertaken an obligation of confidentiality and limitation of use consistent with this AGREEMENT. This obligation shall continue as long as allowed under applicable law.

11. INJUNCTIVE RELIEF

LICENSEE agrees that any violation or threat of violation of this AGREEMENT will result in irreparable harm to ACCUSOFT for which damages would be an inadequate remedy. Therefore, in addition to its rights and remedies available at law (including but not limited to the recovery of damages for breach of this AGREEMENT), ACCUSOFT shall be entitled to immediate injunctive relief to prevent any violation of ACCUSOFT's copyright, trademark, trade secret rights regarding the TOOLKIT, or to prevent any violation of this AGREEMENT, including, but not limited to, unauthorized use, copying, distribution or disclosure of or regarding the TOOLKIT or PORTION, as well as any other equitable relief as the court may deem proper under the circumstances.

12. NO REDUCED PRICING

In any determination of ACCUSOFT's damages (whether liquidated damages or actual damages), or any determination of any licensing fees or royalties due ACCUSOFT under this AGREEMENT due to a breach by LICENSEE hereunder, LICENSEE shall not be entitled to any discounts (volume or otherwise) or reduced licensing fees or royalties. The foregoing sentence shall be applicable unless LICENSEE has negotiated and entered into a written, signed agreement with ACCUSOFT for such reduced or discounted licensing fees or royalties and paid ACCUSOFT such fees or royalties in advance of any: (a) distribution of the TOOLKIT or PORTION, (b) copying of the TOOLKIT or PORTION, or (c) incorporation or use of the TOOLKIT or PORTION in or pertaining to any PRODUCT or service of LICENSEE. Further, LICENSEE agrees that it shall not be entitled to reduced licensing fees or royalties when determining ACCUSOFT's damages due to any undertaking or activity by LICENSEE regarding the TOOLKIT or PORTION outside of or exceeding the scope of permission or other terms of this AGREEMENT, or LICENSEE's actions otherwise in violation of this AGREEMENT.

13. ATTORNEYS' FEES AND COSTS

In the event of any lawsuit or other proceeding brought as a result of any actual or alleged breach of this AGREEMENT, to enforce any provisions of this AGREEMENT, or to enforce any intellectual property or other rights in or pertaining to the TOOLKIT or PORTION, the prevailing party shall be entitled to an award of its reasonable attorneys’ fees and costs, including the costs of any expert witnesses, incurred at all levels of proceedings.

14. GOVERNING LAW

This AGREEMENT shall be construed, governed and enforced in accordance with the laws of the State of Florida, without regard to any conflicts of laws rules. Any action related to or arising out of this AGREEMENT will be filed only in the Florida courts and LICENSEE consents to the exclusive jurisdiction and venue of the state and federal courts located in Tampa, Florida.

15. SEVERABILITY

If any provision of this AGREEMENT is determined to be invalid by any court of final jurisdiction, then it shall be omitted and the remainder of the AGREEMENT shall continue to be binding and enforceable. In addition, the Court is hereby authorized to enforce any provision of the AGREEMENT that the Court otherwise deems unenforceable, to whatever lesser extent the Court deems reasonable and appropriate, rather than invalidating the entire provision. Without limiting the generality of the foregoing, LICENSEE expressly agrees that should LICENSEE be found to have breached the AGREEMENT, under no circumstances shall LICENSEE be entitled to any volume or other discount, or reduced licensing fee or royalty in the determination of ACCUSOFT's damages, or otherwise in the determination of any licensing fee or royalty owed to ACCUSOFT.

16. GOVERNMENT RIGHTS

The TOOLKIT and accompanying documentation have been developed at private expense and are sold commercially. They are provided under any U.S. government contracts or subcontracts with the most restricted and the most limited rights permitted by law and regulation. Whenever so permitted, the government and any intermediaries will obtain only those rights specified in ACCUSOFT's standard commercial license. Thus, the TOOLKIT referenced herein, and the documentation provided by Accusoft hereunder, which are provided to any agency of the U.S. Government or U.S. Government contractor or subcontractor at any tier shall be subject to the maximum restrictions on use as permitted by FAR 52.227-19 (June 1987) or DFARS 227.7202-3(a) (Jan. 1, 2000) or successor regulations. Manufacturer is Accusoft Corporation, 4001 N. Riverside Drive Tampa, FL 33603.

17. ENTIRE AGREEMENT

This AGREEMENT represents the entire understanding of the parties concerning the subject matter hereof and supersedes all prior communications and agreements, whether oral or written, relating to the subject matter of this AGREEMENT. Only a writing signed by the parties may modify this AGREEMENT. In the event of any modification in writing, of this AGREEMENT, including an expanded license agreement, all sections of this Agreement survive except Section 2. Limited License.

18. CONTACT US

Should you have any questions concerning this AGREEMENT, or if you desire to contact ACCUSOFT for any reason, please contact ACCUSOFT at 1-813-875-7575.

19. OTHER RESTRICTIONS

a) This AGREEMENT shall not be amended, altered, changed or modified in any way, unless agreed to in writing by both ACCUSOFT and LICENSEE. Such writing must be executed by a duly authorized representative of ACCUSOFT and a duly authorized representative of LICENSEE.

b) This AGREEMENT is not transferable or assignable by LICENSEE under any circumstances, without the prior written consent of ACCUSOFT. ACCUSOFT will not unreasonably withhold such consent. This AGREEMENT shall be binding upon, and is made for the benefit of, each party, its successors, and permitted assignees (if any). For the purposes of this AGREEMENT, any change in control of LICENSEE shall constitute an assignment or transfer of this AGREEMENT requiring prior written consent of ACCUSOFT. As used in this section, a change in control is defined as (i) any change in ownership of more than fifty percent (50%) of the voting interest in LICENSEE, whether by merger, purchase, foreclosure of a security interest or other transaction, or (ii) a sale of all or substantially all of the assets of LICENSEE.

c) The relationship established by this AGREEMENT between LICENSEE and ACCUSOFT shall be that of Licensee and Licensor. Nothing contained in this AGREEMENT shall be construed as creating a relationship of agency, joint venture or partnership between LICENSEE and ACCUSOFT. Neither party shall have any right whatsoever to incur any liabilities or obligations on behalf of the other party.

d) ACCUSOFT's failure to perform any term or condition of this AGREEMENT as a result of conditions beyond its control such as, but not limited to, war, strikes, fires, floods, acts of God, governmental restrictions, power failures, or damage or destruction of any network facilities or servers, shall not be deemed a breach of this AGREEMENT.

e) The headings provided in this AGREEMENT are for convenience and reference purposes only. In the event of a conflict between the terms and conditions listed in this AGREEMENT, and any attached Schedules or Appendices, the terms and conditions of this AGREEMENT shall govern.

f) A waiver of a breach, violation, or default under this AGREEMENT shall not be a waiver of any subsequent breach, violation or default. Failure of either party to enforce compliance with any term or condition of this AGREEMENT shall not constitute a waiver by the party of such term or condition.

g) All notices and communications shall be in writing and shall be deemed to have been duly given the earlier of when delivered or three (3) Business Days after mailing by certified mail, return receipt requested, postage prepaid, or by international delivery service, addressed to the parties at their respective addresses set forth on the Order Form or at such other addresses as the parties may designate by written notice in accordance with this section.

Rev. 20120112

See Also

Getting Support
Distributing PrintPRO


%%ItemTitle%%

Distributing Applications & Deployment
Send Feedback
PrintPRO 6 for .NET - User Guide > Distributing Applications & Deployment

Glossary Item Box

This section provides information about the following:

  • Verify You're Using the Latest Service Pack
  • Distributing PrintPRO


%%ItemTitle%%

Verify You're Using the Latest Service Pack
See Also Send Feedback
PrintPRO 6 for .NET - User Guide > Distributing Applications & Deployment > Verify You're Using the Latest Service Pack

Glossary Item Box

Service pack updates will not overwrite paid licensing. Your paid licensing will continue to work and you will not be required to re-enter your purchased registration codes. Service pack updates do not include any changes that might "break" previously developed and/or deployed code.

Verify Latest Development Components

To verify you are using the latest version of an Accusoft Development Component or Components, please refer to the currently released product build numbers at www.accusoft.com/latestbuilds.htm.

If you require further assistance or have questions or comments, please see the section Getting Support for more detailed information.

See Also

Getting Support


%%ItemTitle%%

Distributing PrintPRO
See Also Send Feedback
PrintPRO 6 for .NET - User Guide > Distributing Applications & Deployment > Distributing PrintPRO

Glossary Item Box

DLL Files to Distribute

Distribute the appropriate assembly DLL files with applications using the PrintPRO component.

  • Accusoft.PrintPro6.Net.dll - .NET component - .NET Control for accessing and modifying printer properties, creating print jobs, previewing printing, and printing to a device or file.

See Also

Getting Support

Licensing
Licensing


%%ItemTitle%%

Concepts
Send Feedback
PrintPRO 6 for .NET - User Guide > Concepts

Glossary Item Box

This section provides information about the following:

  • Overview of PrintPRO
  • Introduction to Image Color Management (ICM)
  • Glossary


%%ItemTitle%%

Overview of PrintPRO
See Also Send Feedback
PrintPRO 6 for .NET - User Guide > Concepts > Overview of PrintPRO

Glossary Item Box

PrintPRO enables you to create a document composed of images, text, and graphics, and print the document to a selected printer or print to file.

The process for composing and printing documents is as follows:

  1. Select a printer. PrintPRO automatically selects the system default printer but you can select any printer connected to your system. If you want to use the default printer, you can skip to step 2.
  2. Set Printer Properties. Printer properties include the paper size, print quality, orientation, etc. If you want to use the printers default properties, you can skip to step 3.
  3. Set the Use Image Color Management (ICM) as needed.
  4. When creating a PrintJob you can optionally specify the document name as a parameter of the PrintJob constructor. When the system spools your document for printing, the document name appears in the list of documents to be printed. The default document name is PrintPRO Document. If you want to use the default document name, skip to step 5.
  5. Start a document. PrintPRO's text, graphics and bitmap methods will automatically start a document if one has not been started.
  6. Place text, graphics and bitmaps on the document page. The NewPage Method lets you start a new page and the Page Property returns the current page number.
  7. Create, then print and/or display print preview page(s) if desired.
  8. Print the document. Use the Finish Method to send the document to the print spooler. If you want to stop printing the current document, use the PrintJob.Kill Method before you start a new document.

See Also

Create Print Job


%%ItemTitle%%

Introduction to Image Color Management (ICM)
See Also Send Feedback
PrintPRO 6 for .NET - User Guide > Concepts > Introduction to Image Color Management (ICM)

Glossary Item Box

The Problem

You scan a photo in order to edit it but the image on the screen doesn't look like the original. And when you print it out the colors are even less like the original! What you see is not what you get.

Information

The problem is that the different devices (scanner, monitor and printer) have different interpretations of the digital values for colors. Not only are the interpretations different from device to device but so is the “gamut”, the range of realizable colors (some devices can display/output/print colors that others can not).

Solution

Windows’ Image Color Management (ICM) system is the what-you-see-is-what-you-get solution to the color accuracy problem. PrintPRO™ allows the application programmer to enable and access ICM features.

ICM processes all images via a standardized intermediate color scheme: the Profile Connection Space (PCS). In the above example the image from the scanner would be adjusted for that particular scanner’s profile (data file) to get it into the standard color space. It would then be adjusted for that particular monitor’s profile to display or that particular printer’s profile to be printed. Each device gets its own profile and the devices must be properly calibrated to get good results.

Image Color Management is an involved subject. More information can be found at the International Color Consortium’s web site (www.color.org).

With PrintPRO there are two levels of Image Color Management: enabling the various device drivers or with Windows' ICM as specified by the ICM Method.

Color Management is designed to work with 24-bit color or 8-bit grayscale images. Color correction performed on images with less bit depth than this will result in poor quality images. PrintPRO has no native ability to promote images to higher bit depth; it is recommended that you use ImagXpress to do so.

See Also

Icm Class


%%ItemTitle%%

Glossary
Send Feedback
PrintPRO 6 for .NET - User Guide > Concepts > Glossary

Glossary Item Box

A | B | C | D | E | F | G | H | I | J | K | L | M | N | O | P | Q | R | S | T | U | V | W | X | Y | Z

T

Thread-safe
An application using this component can use multiple controls running in the same process, where they don't interfere with each other. The thread creating the control owns the control and is the only thread that can interact with it.


%%ItemTitle%%

How To
Send Feedback
PrintPRO 6 for .NET - User Guide > How To

Glossary Item Box

This section provides information about the following:

  • Set Up Printer
  • Use Image Color Management (ICM)
  • Create Print Job
  • Print Preview
  • Print
  • Debug


%%ItemTitle%%

Set Up Printer
Send Feedback
PrintPRO 6 for .NET - User Guide > How To > Set Up Printer

Glossary Item Box

This section provides information about the following:

  • Set Printer Properties
  • Set Margins
  • Set Printer Coordinates
  • Change Font


%%ItemTitle%%

Create Print Jo
Send Feedback

Glossary Item Box


%%ItemTitle%%

Set Printer Properties
See Also Send Feedback
PrintPRO 6 for .NET - User Guide > How To > Set Up Printer > Set Printer Properties

Glossary Item Box

PrintPRO™ maintains a collection of Printers. PrintPRO enables the user to change these printers' properties, either programmatically or through the printer dialog. (If the printer properties are not modified, the printer's default settings will be in effect.)

While a print job is in progress, the printer settings cannot be modified.

Set Up Printer Properties Using a Dialog

To enable an application end-user to change printer properties, call the Printer.SetupDialog method. A dialog is displayed enabling the user to change the printer's properties.

Set Up Printer Properties Programmatically

Access the properties within the Printer class to programmatically set the printer properties. If the printer does not support the feature (e.g. Duplex), then the property setting will be ignored.

See Also

Printer Class
PrinterCollection Class
SetupDialog Method


%%ItemTitle%%

Set Margins
See Also Send Feedback
PrintPRO 6 for .NET - User Guide > How To > Set Up Printer > Set Margins

Glossary Item Box

PrintPRO™ has top, left and bottom margins that can be set using the TopMargin Property, LeftMargin Property, and BottomMargin Property respectively. Margins are used set the distance between the physical page and the printable area in units of the Printer's PrintUnits.

When the LeftMargin Property is set, the CurrentX Property is automatically set to the same value. When the TopMargin Property is set, the CurrentY Property is automatically set to the same value.

The AutoMargin Property can be used to automatically set the margins to the top, left and bottom of the printer's display area.

See Also

AutoMargin Property
BottomMargin Property
TopMargin Property
LeftMargin Property
CurrentX Property
CurrentY Property


%%ItemTitle%%

Set Printer Coordinates
Send Feedback
PrintPRO 6 for .NET - User Guide > How To > Set Up Printer > Set Printer Coordinates

Glossary Item Box

Physical Area

The printer coordinate system is based on the physical dimensions of the paper in the printer. The horizontal and vertical starting position (0,0) is located at the upper left corner of the paper. Printer units are defined by the PrintUnits Property. The default PrintUnits is twips. There are 1440 twips per inch.

For example, if the printer has 8½ x 11in. paper and the orientation of the paper is portrait, the width of the printer is 12240 twips and the height is 15840 twips. You can get the physical height and width of the printer using the PaperHeight Property and PaperWidth Property.

Display Area

A printer also has a display area. The display area is located inside the physical area. The PrintPreviewScale Property can be used to get width and height of the display area. The DisplayX Property and DisplayY Property can be used to get the coordinates of the upper left corner of the display area.

Printer Resolution

The resolution of a printer is measured in dots per inch. You can get the horizontal and vertical resolution of a printer using the PrintResolution Property.

There are times when you might need to know the number of twips per printer dot (or pixel). The TwipsPerPixelX Property and TwipsPerPixelY Property can be used to get the printer's horizontal or vertical twips per pixel.

Internal Coordinates

The PrintPRO control maintains internal coordinates that are used and updated by some of the text, graphics and bitmap methods. The CurrentX Property and CurrentY Property can be used to get or set the internal horizontal and vertical coordinates.

For example, if the CurrentX and CurrentY properties are set to 1440 twips, the following code will print Hello World one inch from the top and left side of the paper since the PrintText method uses the CurrentX and CurrentY values to position the text.

Example Copy Code
printJob.Draw.CurrentX = 1440;
printJob.Draw.CurrentY = 1440;
printJob.Draw.Text("Hello World");


%%ItemTitle%%

Change Font
See Also Send Feedback
PrintPRO 6 for .NET - User Guide > How To > Set Up Printer > Change Font

Glossary Item Box

PrintPRO™ has a font object that makes it easy to change the font of printed text. In some containers, the font object is not readily available. In this case, use the following methods to change the font characteristics:

  • Set the text and font by using the Text method parameters and passing in the string and font type.
  • Get the size of the text by calling the TextHeight and TextWidth methods.
  • Align the text by using the TextAligned method to determine the specified alignment for the print.
  • Rotate the text by using the TextRotated method to specify the rotation of the text on the document.

See Also

Draw Class
Text Method
TextAligned Method
TextHeight Method
TextRotated Method
TextWidth Method


%%ItemTitle%%

Use Image Color Management (ICM)
Send Feedback
PrintPRO 6 for .NET - User Guide > How To > Use Image Color Management (ICM)

Glossary Item Box

Image Color Management may be handled by Windows, the Device Driver, the Device itself, PrintPRO™, or it may be disabled altogether. Use the ICM Method Property to specify one of these options.

If PrintPRO is to handle the Image Color Management, perform the following steps:

  1. Make sure you have the ICM Profiles appropriate to your destination device (printer or monitor).

  2. If you want to use a profile other than the default, set ICM PrinterProfile or ICM MonitorProfile to the one you do want to use.

  3. Set ICM Method to Profile.

  4. Make sure ICM RenderIntent is set other than None.

Color Management adjustments will now be made to images previewed or printed.


%%phrase%%

Accusoft.PrintPro6.Net Assembly
See Also Send Feedback

Glossary Item Box

Namespaces

Namespace | Description
Accusoft.PrintProSdk |


$$GETTING_STARTED$$ - %%projecttitle%%

Getting Started
Send Feedback

Glossary Item Box


$$INTRODUCTION$$ - %%projecttitle%%

Introduction
Send Feedback

Glossary Item Box


%%ItemTitle%%

Create Print Job
See Also Send Feedback
PrintPRO 6 for .NET - User Guide > How To > Create Print Job

Glossary Item Box

A print job provides instructions to the printer about what to print. To construct a print job,

  • Define a PrintJob object. A name for the print job can be specified as a parameter of the PrintJob constructor.
  • Set margins that will be used to define placement of the page within the printable area, by setting BottomMargin, TopMargin, LeftMargin, and UseHardwareMargins.
  • Create the pages in the print job. Call the NewPage method to define a new page in the print job. Then, populate the page using a TemplateFileName, or by adding bitmaps (PrintBitmap), DIBs (PrintDib), and images (PrintImage), and graphics. When the page has been populated, call NewPage to start another page in the print job, and repeat until the entire print job has been defined.
  • Once the print job has been created, call Finish to release the job to the print device or spooler.
The Kill method can be called at any time during the life of a print job, prior to calling Finish. Calling Kill immediately terminates the current print job.

Populating a Page Using a Template File

A collage template file is a text file, formatted to describe the image sizes and locations to be placed on the page. To use a template file in a print job, specify the TemplateFileName. Then, call the PrintTemplateBitmap, PrintTemplateDib and PrintTemplateImage methods to add the bitmap, DIB, or image to the page using the size and location information specified in the template file.

Drawing on a Page

PrintPRO enables the user to draw on the page to be printed, using PrintPRO drawing methods, or by using .NET drawing methods.

  • Using .NET Drawing Methods: Call GetGraphics to apply a .NET graphics object to the page.
  • Using PrintPRO: Use the Draw property to acquire a PrintPRO drawing object.

This section also provides information about the following:

  • Add Text
  • Add Bitmaps
  • Add Graphics

See Also

PrintJob Class
Draw Class


%%ItemTitle%%

Add Text
See Also Send Feedback
PrintPRO 6 for .NET - User Guide > How To > Create Print Job > Add Text

Glossary Item Box

PrintPRO™ gives the developer flexibility when adding text. The simplest way to add text is to use the Text Method.

Placing Text

The Text method adds text at the CurrentX Property and CurrentY Property position.

The TextHeight Method and the TextWidth Method can be used to return the height and width of a text string.

Aligning Text

If you want to align the text, use the TextAligned Method. This method automatically aligns text inside a rectangular area using the alignment style defined by the Alignment enumeration set . Text will also automatically wordwrap if the wordWrap parameter is set to True.

Rotating Text

If you want to rotate the text, use the TextRotated Method. This method lets you specify a rotation angle, pivot point and pivot mode. If the pivot point is not specified, the CurrentX Property and CurrentY Property values are used. The pivot mode specifies whether the text is left justified, right justified or center justified at the pivot point.

Setting Fonts

The Font parameters used in the Text methods let you set the printer's font name, size, and attributes (bold, underline, etc.). Use the TextHeight and TextWidth methods to return the font height and width. See the Change Font topic for more information on modifying Fonts.

Setting Background Style

The BackStyle Property lets you display text transparently or on a solid color background. The BackColor Property determines the color of the text background and the ForeColor Property determines the color of the text.

See Also

Change Font
Draw Class


%%ItemTitle%%

Add Bitmaps
See Also Send Feedback
PrintPRO 6 for .NET - User Guide > How To > Create Print Job > Add Bitmaps

Glossary Item Box

PrintPRO™ lets you print Device Independent Bitmaps (DIB), Bitmaps, and Images. Bitmaps can be printed stretched (or resized) inside a rectangular area with or without the aspect ratio being maintained. The ability to automatically maintain the bitmap's aspect ratio makes it easy to display large document images correctly on the printed page.

Adding a Bitmap

To add a Bitmap use the PrintBitmap Method to print the bitmap. The parameters set the height and width of the source and destination of the bitmap. If the aspect parameter is set to true, the destination size is adjusted to maintain the image data's aspect ratio.

Adding a DIB

To add a DIB, use the PrintDib Method to print the DIB. The parameters set the height and width of the source and destination of the DIB. If the aspect parameter is set to true, the destination size is adjusted to maintain the image data's aspect ratio.

Adding an Image

To add an Image, use the PrintImage Method to print the Image. The parameters set the height and width of the source and destination of the Image. If the aspect parameter is set to true, the destination size is adjusted to maintain the Image data's aspect ratio.

See Also

PrintBitmap Method
PrintDib Method
PrintImage Method


%%ItemTitle%%

Add Graphics
See Also Send Feedback
PrintPRO 6 for .NET - User Guide > How To > Create Print Job > Add Graphics

Glossary Item Box

PrintPRO™ supports adding the following graphic types to the document to be printed:

  • Arcs - use the Arc Method.
  • Circles and Ellipses - use the Circle Method.
  • Curves - use the Curve Method.
  • Lines, Rectangles, and Points - use the Line Method.
  • Pie Shapes - use the Pie Method.
  • Polygons - use the Polygon Method.
  • Rectangles - use the Rectangle Method.
  • Round Rectangles with rounded corners - use the RoundRectangle Method.

The method used to draw the graphic is determined by the following:

  • FillColor - use the FillColor Property to set the color to fill the graphic.
  • FillStyle - use the FillStyle Property to set the pattern to fill the graphic.
  • Draw Mode - use the Mode Property to specify how pen color and background color will be combined.
  • Draw Style - use the Style Property to determine the pattern of the line defining the graphic.
  • Draw Width - use the Width Property to set the width of the line defining the graphic.

See Also

Draw Class


%%ItemTitle%%

Print Preview
Send Feedback
PrintPRO 6 for .NET - User Guide > How To > Print Preview

Glossary Item Box

PrintPRO™ lets you create a print preview image for any document page.

1. Decide whether to Display Print Preview while Printing Document

If you plan on creating print preview images while printing a document, you need to start a print document using the CreateFilePrinter Method before initiating a print preview.

2. Initiate Print Preview

To initiate a print preview, you must call the PrintPreviewJob Method. After initiating a print preview, continue to create a print job. Use the Finish Method to end the print preview. If you are creating a multiple page document, PrintPRO will automatically create a print preview for each page.

3. View a Print Preview Page

When you want to view a print preview for a page, you first need to determine the size of the print preview image using the PrintPreviewScale Property. Next, use one of the GetPrintPreview Methods to create a bitmap, DIB or image for the page you want to view. Finally, use the PrintBitmap, PrintDib, or PrintImage methods to export the print preview image.

4. Resource Cleanup

Print preview requires system resources that PrintPRO automatically takes care of. You can, however, delete the print preview resources yourself. The Finish method releases the print preview image. You can always recreate the bitmap using the GetPrintPreview Methods, so deleting the image when it is no longer needed will conserve system resources.

The Dispose Method deletes the print preview resources for a page. If you delete the print preview resources, you cannot recreate the bitmap image for that page.

The following code creates a simple print preview of a single line of text. An ImagXpress® control is used to display the image.

Example Copy Code
/* prompt the user for the desired printer */
printer = Accusoft.PrintProSdk.Printer.SelectPrinter(pp,true);

/* create a print preview job for the above-specified printer */
job = new Accusoft.PrintProSdk.PrintPreviewJob(printer);

/* draw text */
job.Draw.Text("Print Preview Page 1");

/* Finish the print job to the end of the current page and "print" the document */
job.Finish();

/* display the generated preview image by getting a .NET Bitmap from the PrintPreviewJob
and converting it into an ImagXpress ImageX object. */
ixvPreview.Image = Accusoft.ImagXpressSdk.ImageX.FromBitmap(ix,job.GetPrintPreviewBitmap(1));


%%ItemTitle%%

Print
Send Feedback
PrintPRO 6 for .NET - User Guide > How To > Print

Glossary Item Box

This section provides information about the following:

  • Print to a File
  • Print Without ImagXpress
  • Print a Multi-page TIFF Image Using PrintPRO & ImagXpress


%%ItemTitle%%

Print to a File
Send Feedback
PrintPRO 6 for .NET - User Guide > How To > Print > Print to a File

Glossary Item Box

This sample shows that with PrintPRO printing to a file is very much the same as generating printer output but with a few properties set to the appropriate values. Any printer output, regardless of how it is generated, can be easily directed to a file.

Example Copy Code
// generic Printer object, this is a real printer or a file depending on the user's selection
Accusoft.PrintProSdk.Printer printer;
Accusoft.PrintProSdk.PrintJob job;   // object representation of a print job

// prompt the user for the desired printer
printer = Accusoft.PrintProSdk.Printer.SelectPrinter(pp, true);

string destinationFile = System.IO.Path.Combine(Application.StartupPath, "PrintToFile.tif");

// create a file printer
printer = Accusoft.PrintProSdk.Printer.CreateFilePrinter(pp, destinationFile, Accusoft.PrintProSdk.SaveFileType.Tif);

// Set the dpi so the generated file is not too large.
// The resulting image will be the selected dpi times the printable area
    // (slightly smaller than 8.5x11 because of margins).
printer.RequestedDpi = 100;

if(printer != null)
{
  // Create a PrintJob object for the above-selected Printer.
  // If the printer is not specified, PrintPRO will just use Window's default printer.
  job = new Accusoft.PrintProSdk.PrintJob(printer);
  job.Name = "Accusoft PrintPRO Demo";
  System.Drawing.Font font =
           new System.Drawing.Font("Arial",24,System.Drawing.FontStyle.Bold);
  job.Draw.TextAligned(new System.Drawing.RectangleF(1000,job.TopMargin,
           job.PaperWidth - 2000, 1100 - job.TopMargin), Hello! Check out PrintPRO!", font,
           Accusoft.PrintProSdk.Alignment.CenterJustifyMiddle);

  // Finish the print job to the end of the current page and print the document */
  job.Finish();
}


%%ItemTitle%%

Print Without ImagXpress
Send Feedback
PrintPRO 6 for .NET - User Guide > How To > Print > Print Without ImagXpress

Glossary Item Box

The following example shows how to print an image file without ImagXpress.

Example Copy Code
//generic Printer object, this is a real printer or a file depending on the user's selection
Accusoft.PrintProSdk.Printer printer;
Accusoft.PrintProSdk.PrintJob job;  // object representation of a print job

// prompt the user for the desired printer
printer = Accusoft.PrintProSdk.Printer.SelectPrinter(pp,true);

if (printer != null)
{
  // Create a PrintJob object for the above-selected Printer.
  //  If the printer is not specified, PrintPRO will use Window's default printer.
  job = new Accusoft.PrintProSdk.PrintJob(printer);
  job.Name = "Accusoft PrintPRO Demo";

  job.Printbitmap(new Bitmap("c:\\image.bmp"), job.LeftMargin, job.TopMargin,
     job.PrintWidth- job.LeftMargin, job.PrintHeight - job.TopMargin - job.BottomMargin, true);

  // Finish the print job to the end of the current page and print the document
  job.Finish();
}


%%ItemTitle%%

Print a Multi-page TIFF Image Using PrintPRO & ImagXpress
Send Feedback
PrintPRO 6 for .NET - User Guide > How To > Print > Print a Multi-page TIFF Image Using PrintPRO & ImagXpress

Glossary Item Box

This example uses an ImagXpress control to load a multi-page (TIFF, PDF, ICO, MODCA or DCX) file, PrintPRO then prints them, one page at a time.

Example Copy Code
//generic Printer object, this is a real printer or a file depending on the user's selection
Accusoft.PrintProSdk.Printer printer;
Accusoft.PrintProSdk.PrintJob job;    // object representation of a print job

/* prompt the user for the desired printer */
printer = Accusoft.PrintProSdk.Printer.SelectPrinter(pp,true);

if (printer != null)
{
  // Create a PrintJob object for the above-selected Printer.
  // If the printer is not specified, PrintPRO will use Window's default printer.
  job = new Accusoft.PrintProSdk.PrintJob(printer);
  job.Name = "Accusoft PrintPRO Demo";

  int i = 0;
  int numPages = Accusoft.ImagXpressSdk.ImageX.NumPages(ix, "c:\\multi.tif");
  for(i = 1; i <= numPages; i++)
  {
     if (i > 1)
     {
          job.NewPage();
      }
       ixvPreview.Image = Accusoft.ImagXpressSdk.ImageX.FromFile(ix, "c:\\multi.tif", i);
       job.PrintDib(ixvPreview.Image.ToHdib(false), 0,0,0,0, job.LeftMargin, job.TopMargin,
               job.PrintWidth - job.LeftMargin, job.PrintHeight - job.TopMargin - job.BottomMargin, true);
      }
  }
  // Finish the print job to the end of the current page and print the document
  job.Finish();
}


%%ItemTitle%%

Debug
Send Feedback
PrintPRO 6 for .NET - User Guide > How To > Debug

Glossary Item Box

Because debugging and writing debug information to a log file is time consuming and expensive, PrintPRO™ provides the ability to control the level of information written to the debug log as well as the ability to turn off writing to a file completely.

Use the properties and methods within the PrintPro Class below to adjust the settings of your debugging, event handling, memory and IDispose for optimal performance.

Control Debugging Information

  • Debug - Turns on or off the ability to write to the debug log file.
  • DebugLogFile - A filename which stores the debug log information.
  • DebugErrorLevel - Controls the amount of information that is written to the debug log file.
When DebugErrorLevel is set to Detailed, PrintPRO logs most of your calls to the component including the occurrence of exceptions, the result of most major operations and the operation of each event it raises.

Troubleshooting

Stop Memory Leaks

After you are done using a PrintPRO object, call the Dispose method.

Error Codes

Listed below is a cross-reference of error codes and their corresponding descriptions:

  • -5000 — No printer DC.

  • -5001 — A document has already been started.

  • -5002 — A document has not been started.

  • -5003 — Error starting document.

  • -5004 — Error starting page.

  • -5005 — Print dialog failed probably because the user clicked the Cancel button.

  • -5006 — Error ending page.

  • -5007 — Bad radius value.

  • -5008 — Bad angle value.

  • -5009 — The Windows StretchBlt function failed when printing a bitmap.

  • -5010 — Out of memory.

  • -5011 — Invalid printer number.

  • -5012 — Invalid parameter.

  • -5013 — No printer selected.

  • -5014 — Cannot open the printer.

  • -5015 — The selected printer does not support getting values for this property.

  • -5016 — The selected printer does not support setting values for this property.

  • -5017 — Invalid DIB handle.

  • -5018 — Setup dialog failed, probably because the user pressed the Cancel button.

  • -5019 — The DIB has not been set.

  • -5020 — Cannot get default printer information from the system.

  • -5021 — Cannot write to the printer.

  • -5022 — Cannot end a print job.

  • -5023 — The specified page does not exist.

  • -5024 — A print preview for the current page does not exist.

  • -5025 — Cannot get metafile DC.

  • -5026 — Cannot create overlay.

  • -5027 — Cannot open file.

  • -5028 — The DIB is invalid.

  • -5029 — Error reading file.

  • -5030 — Invalid TIFF size.

  • -5031 — Error writing file.

  • -5032 — TIFF tag not found.

  • -5033 — TIFF tag item not found.

  • -5034 — A color profile associated with the ICM object is invalid.

  • -5035 — Generic GDI.

  • -5036 — Invalid template.

  • -5037 — Invalid print preview.

  • -5038 — Invalid handle.

  • -5039 — Cannot get error message.

  • -5040 — Generic Win32 error.

  • -5041 — Printing disabled.

  • -5042 — Invalid pointer.

  • -5043 — Invalid bin ID.

  • -5044 — Invalid paper ID.

  • -5045 — Cannot create compatible device.

  • -5333 — Invalid license edition.

  • -5400 — Invalid worker object ID.

  • -5500 — Error initializing worker.

  • -5900 — Internal error.

  • -5995 — Invalid license.

  • -5996 — Invalid web code.

  • -5999 — Not licensed.


%%ItemTitle%%

PrintPRO 6 for .NET - API Reference
Send Feedback

Glossary Item Box

This API Reference provides detailed information about all PrintPRO public API members.


%%ItemTitle%%

Accusoft.PrintProSdk Namespace
See Also Inheritance Hierarchy Send Feedback

Glossary Item Box

Classes

 | Class | Description
Class | CannotCreateCompatibleDeviceException | This exception is thrown if an error occurs when creating a compatible device.
Class | CannotCreateOverlayException | This exception is thrown if an error occurs when creating the overlay.
Class | CannotGetDefaultPrinterException | This exception is thrown if an error occurs when getting the default printer information from the system.
Class | CannotGetErrorMessageException | This exception is thrown if PrintPRO is unable to get an error message.
Class | CannotGetMetafileDCException | This exception is thrown if an error occurs when getting the metafile DC.
Class | CannotGetPrinterPropertyException | This exception is thrown if the selected printer does not support getting values for this property.
Class | CannotOpenPrinterException | This exception is thrown if an error occurs when opening the printer.
Class | CannotSetPrinterPropertyException | This exception is thrown if the selected printer does not support setting values for this property.
Class | CannotWriteToPrinterException | This exception is thrown if an error occurs when writing to the printer.
Class | DocumentAlreadyStartedException | This exception is thrown if a new document is started when a document has already been started.
Class | DocumentNotStartedException | This exception is thrown if the desired action cannot be performed because a document has not been started.
Class | Draw | This class implements methods and properties for drawing.
Class | EndDocumentFailedException | This exception is thrown if an error occurs when ending a print job.
Class | EndPageFailedException | This exception is thrown if an error occurs when ending a page.
Class | FileReadException | This exception is thrown if an error occurs when reading the file.
Class | FileWriteException | This exception is thrown if an error occurs when writing the file.
Class | GenericGdiException | This exception is thrown if a generic GDI error occurs.
Class | GenericWin32Exception | This exception is thrown if a generic Win32 error occurs.
Class | Icm | Ths class implements image color matching settings.
Class | InternalErrorException | This exception is thrown if an internal error occurs.
Class | InvalidAngleException | This exception is thrown if the specified angle is invalid.
Class | InvalidBinIDException | This exception is thrown if the specified bin ID is invalid.
Class | InvalidDib | This exception is thrown if the DIB is invalid.
Class | InvalidDibHandleException | This exception is thrown if the DIB handle is invalid.
Class | InvalidHandleException | This exception is thrown if the handle is invalid.
Class | InvalidLicenseEditionException | This exception is thrown if the license edition is invalid.
Class | InvalidLicenseException | This exception is thrown if a user attempts to access functionality that is not covered under the license in effect.
Class | InvalidPageNumberException | This exception is thrown if an invalid page number was specified.
Class | InvalidPaperIDException | This exception is thrown if the specified paper ID is invalid.
Class | InvalidParameterException | This exception is thrown if an invalid parameter is specified.
Class | InvalidPointerException | This exception is thrown if a pointer is invalid.
Class | InvalidPrinterNumberException | This exception is thrown if an invalid printer number is specified.
Class | InvalidPrintPreviewException | This exception is thrown if the print preview is invalid.
Class | InvalidProfileException | This exception is thrown if a color profile associated with the ICM object is invalid.
Class | InvalidRadiusException | This exception is thrown if the specified radius is invalid.
Class | InvalidTemplateException | This exception is thrown if the template is invalid.
Class | InvalidTiffSizeException | This exception is thrown if the TIFF size is invalid.
Class | InvalidValueException | This exception is thrown if the value provided for the printer property is invalid.
Class | InvalidWebCode | This exception is thrown if the web code is invalid.
Class | InvalidWorkerObjectIDException | This exception is thrown if the worker object ID is invalid.
Class | Licensing | This class implements methods for setting the license information for the toolkit.
Class | NoDibException | This exception is thrown if an image is being printed but the DIB has not been set.
Class | NoPrinterDCException | This exception is thrown if there is no printer DC.
Class | NoPrinterSelectedException | This exception is thrown if no printer is selected.
Class | NoPrintPreviewException | This exception is thrown if a print preview for the current page does not exist.
Class | NotLicensedException | This exception is thrown if PrintPRO is not licensed to perform the desired operation.
Class | OpenFileException | This exception is thrown if an error occurs when opening the file.
Class | OutOfMemoryException | This exception is thrown if PrintPRO is unable to allocate memory for the requested operation.
Class | Paper | This class implements methods and properties to define types of paper.
Class | PaperBin | A class that implements a paper bin for a printer.
Class | PaperBinCollection | This class implements a collection of paper bin objects.
Class | PaperBinEnumerator | This class implements a paper bin enumerator.
Class | PaperCollection | This class implements methods and properties for PaperBin objects.
Class | PaperEnumerator | This class implements enumerating through paper collections.
Class | PrintDialogFailedException | This exception is thrown if the print dialog failed.
Class | Printer | This class implements available printers for printing.
Class | PrinterCollection | This class implements a collection of available printers.
Class | PrinterDriverFailureException | This exception is thrown if a printer driver failure occurs.
Class | PrinterEnumerator | This class implements an enumerator that can be used to iterate through a collection of printers.
Class | PrintingDisabledException | This exception is thrown if printing is disabled.
Class | PrintJob | This class implements a normal print job.
Class | PrintPreviewJob | This class represents a print preview job.
Class | PrintPro | This class implements the main functionality of the PrintPro component. A strongly-typed resource class, for looking up localized strings, etc.
Class | PrintProException | This class implements the base class for PrintPro Exceptions.
Class | PrintQuality | This class is used to represent the print quality.
Class | SetupDialogFailedException | This exception is thrown if the setup dialog failed.
Class | StartDocumentFailedException | This exception is thrown if an error occurs when starting a document.
Class | StartPageFailedException | This exception is thrown if an error occurs when starting a page.
Class | StretchBltFailedException | This exception is thrown if the Windows StretchBlt function failed when printing a bitmap.
Class | TiffTagItemNotFoundException | This exception is thrown if the TIFF tag item is not found.
Class | TiffTagNotFoundException | This exception is thrown if the TIFF tag is not found.
Class | UserPaper | This class implements methods and properties that are used in place of a paper class when a user paper type has been selected for a printer.
Class | WorkerInitializationException | This exception is thrown if an error occurs when initializing the PrintPRO worker.

Structures

 | Structure | Description
Structure | PrintingUnit | An object that represents units for printing. Made so that its use is similar to an Enumeration.

Enumerations

 | Enumeration | Description
Enumeration | Alignment | Option values which determine the alignment when printing.
Enumeration | BackStyle | Option values which determine the available backstyles to be used for printed text.
Enumeration | DebugErrorLevel | Option values which determine the available error levels for debugging.
Enumeration | DrawMode | Option values which determine the available drawing modes for the PrintPro native drawing routines.
Enumeration | DrawStyle | Option values which determine the available drawing styles for the PrintPro native drawing routines.
Enumeration | EvaluationMode | Option values which determine licensing evaluation modes.
Enumeration | FillStyle | Option values which determine the pattern used to fill circles, boxes, round rectangles, pie-shapes and polygons created with the native PrintPro drawing routines.
Enumeration | IcmIntent | Option values which determine the possible color management methods, or intents.
Enumeration | IcmMethod | Option values which determine the ICM method to use.
Enumeration | IcmRenderIntent | Option values which determine the purpose of the color correction.
Enumeration | MediaType | Option values which determine the type of media being printed on (if the printer supports this feature).
Enumeration | Orientation | Option values which determine whether documents are printed in portrait or landscape mode (if the printer supports this feature).
Enumeration | PrintColorMode | Option values which determine whether a color printer prints output in color or monochrome.
Enumeration | PrintDitherType | Option values which determine how dithering is to be done (if the printer supports this feature).
Enumeration | PrintDuplex | Option values which determine whether a page is printed on both sides (if the printer supports this feature).
Enumeration | PrintPreviewScale | Option values which determine the scaling size of the print preview image.
Enumeration | PrintRangeAvailable | Option values which determine the available radio buttons in the print dialog. The All value is always enabled. Using All will only enable the All radio button.
Enumeration | PrintRangeSelection | Option values which determine the Print Range selected on the Print Dialog box.
Enumeration | RotationPivotMode | Option values which determine the pivot location for Draw.TextRotated.
Enumeration | SaveFileType | Option values which determine the type of file generated when printing to file.
Enumeration | TrueTypeOption | Option values which determine the printer’s TrueType option.

See Also

Reference

Accusoft.PrintPro6.Net Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Accusoft.PrintProSdk Namespace Inheritance Hierarchy
See Also Send Feedback

Glossary Item Box

Inheritance Hierarchy

System.Object
Accusoft.PrintProSdk.Draw
Accusoft.PrintProSdk.Icm
Accusoft.PrintProSdk.Licensing
Accusoft.PrintProSdk.Paper
Accusoft.PrintProSdk.UserPaper
Accusoft.PrintProSdk.PaperBin
Accusoft.PrintProSdk.PaperBinEnumerator
Accusoft.PrintProSdk.PaperEnumerator
Accusoft.PrintProSdk.Printer
Accusoft.PrintProSdk.PrinterEnumerator
Accusoft.PrintProSdk.PrintJob
Accusoft.PrintProSdk.PrintPreviewJob
Accusoft.PrintProSdk.PrintQuality
System.ApplicationException
System.Exception
Accusoft.PrintProSdk.PrintProException
Accusoft.PrintProSdk.CannotCreateCompatibleDeviceException
Accusoft.PrintProSdk.CannotCreateOverlayException
Accusoft.PrintProSdk.CannotGetDefaultPrinterException
Accusoft.PrintProSdk.CannotGetErrorMessageException
Accusoft.PrintProSdk.CannotGetMetafileDCException
Accusoft.PrintProSdk.CannotGetPrinterPropertyException
Accusoft.PrintProSdk.CannotOpenPrinterException
Accusoft.PrintProSdk.CannotSetPrinterPropertyException
Accusoft.PrintProSdk.CannotWriteToPrinterException
Accusoft.PrintProSdk.DocumentAlreadyStartedException
Accusoft.PrintProSdk.DocumentNotStartedException
Accusoft.PrintProSdk.EndDocumentFailedException
Accusoft.PrintProSdk.EndPageFailedException
Accusoft.PrintProSdk.FileReadException
Accusoft.PrintProSdk.FileWriteException
Accusoft.PrintProSdk.GenericGdiException
Accusoft.PrintProSdk.GenericWin32Exception
Accusoft.PrintProSdk.InternalErrorException
Accusoft.PrintProSdk.InvalidAngleException
Accusoft.PrintProSdk.InvalidBinIDException
Accusoft.PrintProSdk.InvalidDib
Accusoft.PrintProSdk.InvalidDibHandleException
Accusoft.PrintProSdk.InvalidHandleException
Accusoft.PrintProSdk.InvalidLicenseEditionException
Accusoft.PrintProSdk.InvalidLicenseException
Accusoft.PrintProSdk.InvalidPageNumberException
Accusoft.PrintProSdk.InvalidPaperIDException
Accusoft.PrintProSdk.InvalidParameterException
Accusoft.PrintProSdk.InvalidPointerException
Accusoft.PrintProSdk.InvalidPrinterNumberException
Accusoft.PrintProSdk.InvalidPrintPreviewException
Accusoft.PrintProSdk.InvalidProfileException
Accusoft.PrintProSdk.InvalidRadiusException
Accusoft.PrintProSdk.InvalidTemplateException
Accusoft.PrintProSdk.InvalidTiffSizeException
Accusoft.PrintProSdk.InvalidValueException
Accusoft.PrintProSdk.InvalidWebCode
Accusoft.PrintProSdk.InvalidWorkerObjectIDException
Accusoft.PrintProSdk.NoDibException
Accusoft.PrintProSdk.NoPrinterDCException
Accusoft.PrintProSdk.NoPrinterSelectedException
Accusoft.PrintProSdk.NoPrintPreviewException
Accusoft.PrintProSdk.NotLicensedException
Accusoft.PrintProSdk.OpenFileException
Accusoft.PrintProSdk.OutOfMemoryException
Accusoft.PrintProSdk.PrintDialogFailedException
Accusoft.PrintProSdk.PrinterDriverFailureException
Accusoft.PrintProSdk.PrintingDisabledException
Accusoft.PrintProSdk.SetupDialogFailedException
Accusoft.PrintProSdk.StartDocumentFailedException
Accusoft.PrintProSdk.StartPageFailedException
Accusoft.PrintProSdk.StretchBltFailedException
Accusoft.PrintProSdk.TiffTagItemNotFoundException
Accusoft.PrintProSdk.TiffTagNotFoundException
Accusoft.PrintProSdk.WorkerInitializationException
System.Collections.ReadOnlyCollectionBase
Accusoft.PrintProSdk.PaperBinCollection
Accusoft.PrintProSdk.PaperCollection
Accusoft.PrintProSdk.PrinterCollection
System.ComponentModel.Component
System.MarshalByRefObject
Accusoft.PrintProSdk.PrintPro
System.ValueType
Accusoft.PrintProSdk.PrintingUnit

See Also

Reference

Accusoft.PrintPro6.Net Assembly


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CannotCreateCompatibleDeviceException Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : CannotCreateCompatibleDeviceException Class

Glossary Item Box

This exception is thrown if an error occurs when creating a compatible device.

Object Model

CannotCreateCompatibleDeviceException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class CannotCreateCompatibleDeviceException
   Inherits PrintProException
'Usage

Dim instance As CannotCreateCompatibleDeviceException
[SerializableAttribute()]
public sealed class CannotCreateCompatibleDeviceException : PrintProException
[SerializableAttribute()]
public __gc __sealed class CannotCreateCompatibleDeviceException : public PrintProException
[SerializableAttribute()]
public ref class CannotCreateCompatibleDeviceException sealed : public PrintProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.PrintProSdk.PrintProException
Accusoft.PrintProSdk.CannotCreateCompatibleDeviceException

See Also

Reference

CannotCreateCompatibleDeviceException Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
CannotCreateCompatibleDeviceException Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : CannotCreateCompatibleDeviceException Class

Glossary Item Box

The following tables list the members exposed by CannotCreateCompatibleDeviceException.

Public Constructors

 | Name | Description
Public Constructor | CannotCreateCompatibleDeviceException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

CannotCreateCompatibleDeviceException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
CannotCreateCompatibleDeviceException Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : CannotCreateCompatibleDeviceException Class

Glossary Item Box

For a list of all members of this type, see CannotCreateCompatibleDeviceException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

CannotCreateCompatibleDeviceException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
CannotCreateCompatibleDeviceException Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : CannotCreateCompatibleDeviceException Class

Glossary Item Box

For a list of all members of this type, see CannotCreateCompatibleDeviceException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

CannotCreateCompatibleDeviceException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CannotCreateCompatibleDeviceException Constructor
See Also Send Feedback
Accusoft.PrintProSdk Namespace > CannotCreateCompatibleDeviceException Class : CannotCreateCompatibleDeviceException Constructor

Glossary Item Box

Overload List

Overload | Description
CannotCreateCompatibleDeviceException Constructor() | An exception generated for a cannot create compatible device error.
CannotCreateCompatibleDeviceException Constructor(Int32) | Generated exception for a cannot create compatible device error with a given error number.
CannotCreateCompatibleDeviceException Constructor(String) | Generated exception for a cannot create compatible device error with a given string.
CannotCreateCompatibleDeviceException Constructor(Int32,String) | Generated exception for a cannot create compatible device error with a given error number and message.
CannotCreateCompatibleDeviceException Constructor(String,Exception) | Generated exception for a cannot create compatible device error with a given message and inner exception.

See Also

Reference

CannotCreateCompatibleDeviceException Class
CannotCreateCompatibleDeviceException Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CannotCreateCompatibleDeviceException Constructor()
See Also Send Feedback
Accusoft.PrintProSdk Namespace > CannotCreateCompatibleDeviceException Class > CannotCreateCompatibleDeviceException Constructor : CannotCreateCompatibleDeviceException Constructor()

Glossary Item Box

An exception generated for a cannot create compatible device error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New CannotCreateCompatibleDeviceException()
public CannotCreateCompatibleDeviceException()
public: CannotCreateCompatibleDeviceException();
public:
CannotCreateCompatibleDeviceException();

See Also

Reference

CannotCreateCompatibleDeviceException Class
CannotCreateCompatibleDeviceException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CannotCreateCompatibleDeviceException Constructor(Int32)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > CannotCreateCompatibleDeviceException Class > CannotCreateCompatibleDeviceException Constructor : CannotCreateCompatibleDeviceException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a cannot create compatible device error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New CannotCreateCompatibleDeviceException(errorNumber)
public CannotCreateCompatibleDeviceException(
   int errorNumber
)
public: CannotCreateCompatibleDeviceException(
   int errorNumber
)
public:
CannotCreateCompatibleDeviceException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

CannotCreateCompatibleDeviceException Class
CannotCreateCompatibleDeviceException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CannotCreateCompatibleDeviceException Constructor(String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > CannotCreateCompatibleDeviceException Class > CannotCreateCompatibleDeviceException Constructor : CannotCreateCompatibleDeviceException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a cannot create compatible device error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New CannotCreateCompatibleDeviceException(message)
public CannotCreateCompatibleDeviceException(
   string message
)
public: CannotCreateCompatibleDeviceException(
   string* message
)
public:
CannotCreateCompatibleDeviceException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

CannotCreateCompatibleDeviceException Class
CannotCreateCompatibleDeviceException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CannotCreateCompatibleDeviceException Constructor(Int32,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > CannotCreateCompatibleDeviceException Class > CannotCreateCompatibleDeviceException Constructor : CannotCreateCompatibleDeviceException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a cannot create compatible device error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New CannotCreateCompatibleDeviceException(errorNumber, message)
public CannotCreateCompatibleDeviceException(
   int errorNumber,
   string message
)
public: CannotCreateCompatibleDeviceException(
   int errorNumber,
   string* message
)
public:
CannotCreateCompatibleDeviceException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

CannotCreateCompatibleDeviceException Class
CannotCreateCompatibleDeviceException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CannotCreateCompatibleDeviceException Constructor(String,Exception)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > CannotCreateCompatibleDeviceException Class > CannotCreateCompatibleDeviceException Constructor : CannotCreateCompatibleDeviceException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a cannot create compatible device error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New CannotCreateCompatibleDeviceException(message, innerException)
public CannotCreateCompatibleDeviceException(
   string message,
   Exception innerException
)
public: CannotCreateCompatibleDeviceException(
   string* message,
   Exception* innerException
)
public:
CannotCreateCompatibleDeviceException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

CannotCreateCompatibleDeviceException Class
CannotCreateCompatibleDeviceException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CannotCreateOverlayException Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : CannotCreateOverlayException Class

Glossary Item Box

This exception is thrown if an error occurs when creating the overlay.

Object Model

CannotCreateOverlayException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class CannotCreateOverlayException
   Inherits PrintProException
'Usage

Dim instance As CannotCreateOverlayException
[SerializableAttribute()]
public sealed class CannotCreateOverlayException : PrintProException
[SerializableAttribute()]
public __gc __sealed class CannotCreateOverlayException : public PrintProException
[SerializableAttribute()]
public ref class CannotCreateOverlayException sealed : public PrintProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.PrintProSdk.PrintProException
Accusoft.PrintProSdk.CannotCreateOverlayException

See Also

Reference

CannotCreateOverlayException Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
CannotCreateOverlayException Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : CannotCreateOverlayException Class

Glossary Item Box

The following tables list the members exposed by CannotCreateOverlayException.

Public Constructors

 | Name | Description
Public Constructor | CannotCreateOverlayException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

CannotCreateOverlayException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
CannotCreateOverlayException Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : CannotCreateOverlayException Class

Glossary Item Box

For a list of all members of this type, see CannotCreateOverlayException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

CannotCreateOverlayException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
CannotCreateOverlayException Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : CannotCreateOverlayException Class

Glossary Item Box

For a list of all members of this type, see CannotCreateOverlayException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

CannotCreateOverlayException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CannotCreateOverlayException Constructor
See Also Send Feedback
Accusoft.PrintProSdk Namespace > CannotCreateOverlayException Class : CannotCreateOverlayException Constructor

Glossary Item Box

Overload List

Overload | Description
CannotCreateOverlayException Constructor() | An exception generated for a cannot create overlay error.
CannotCreateOverlayException Constructor(Int32) | Generated exception for a cannot create overlay error with a given error number.
CannotCreateOverlayException Constructor(String) | Generated exception for a cannot create overlay error with a given string.
CannotCreateOverlayException Constructor(Int32,String) | Generated exception for a cannot create overlay error with a given error number and message.
CannotCreateOverlayException Constructor(String,Exception) | Generated exception for a cannot create overlay error with a given message and inner exception.

See Also

Reference

CannotCreateOverlayException Class
CannotCreateOverlayException Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CannotCreateOverlayException Constructor()
See Also Send Feedback
Accusoft.PrintProSdk Namespace > CannotCreateOverlayException Class > CannotCreateOverlayException Constructor : CannotCreateOverlayException Constructor()

Glossary Item Box

An exception generated for a cannot create overlay error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New CannotCreateOverlayException()
public CannotCreateOverlayException()
public: CannotCreateOverlayException();
public:
CannotCreateOverlayException();

See Also

Reference

CannotCreateOverlayException Class
CannotCreateOverlayException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CannotCreateOverlayException Constructor(Int32)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > CannotCreateOverlayException Class > CannotCreateOverlayException Constructor : CannotCreateOverlayException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a cannot create overlay error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New CannotCreateOverlayException(errorNumber)
public CannotCreateOverlayException(
   int errorNumber
)
public: CannotCreateOverlayException(
   int errorNumber
)
public:
CannotCreateOverlayException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

CannotCreateOverlayException Class
CannotCreateOverlayException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CannotCreateOverlayException Constructor(String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > CannotCreateOverlayException Class > CannotCreateOverlayException Constructor : CannotCreateOverlayException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a cannot create overlay error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New CannotCreateOverlayException(message)
public CannotCreateOverlayException(
   string message
)
public: CannotCreateOverlayException(
   string* message
)
public:
CannotCreateOverlayException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

CannotCreateOverlayException Class
CannotCreateOverlayException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CannotCreateOverlayException Constructor(Int32,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > CannotCreateOverlayException Class > CannotCreateOverlayException Constructor : CannotCreateOverlayException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a cannot create overlay error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New CannotCreateOverlayException(errorNumber, message)
public CannotCreateOverlayException(
   int errorNumber,
   string message
)
public: CannotCreateOverlayException(
   int errorNumber,
   string* message
)
public:
CannotCreateOverlayException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

CannotCreateOverlayException Class
CannotCreateOverlayException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CannotCreateOverlayException Constructor(String,Exception)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > CannotCreateOverlayException Class > CannotCreateOverlayException Constructor : CannotCreateOverlayException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a cannot create overlay error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New CannotCreateOverlayException(message, innerException)
public CannotCreateOverlayException(
   string message,
   Exception innerException
)
public: CannotCreateOverlayException(
   string* message,
   Exception* innerException
)
public:
CannotCreateOverlayException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

CannotCreateOverlayException Class
CannotCreateOverlayException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CannotGetDefaultPrinterException Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : CannotGetDefaultPrinterException Class

Glossary Item Box

This exception is thrown if an error occurs when getting the default printer information from the system.

Object Model

CannotGetDefaultPrinterException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class CannotGetDefaultPrinterException
   Inherits PrintProException
'Usage

Dim instance As CannotGetDefaultPrinterException
[SerializableAttribute()]
public sealed class CannotGetDefaultPrinterException : PrintProException
[SerializableAttribute()]
public __gc __sealed class CannotGetDefaultPrinterException : public PrintProException
[SerializableAttribute()]
public ref class CannotGetDefaultPrinterException sealed : public PrintProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.PrintProSdk.PrintProException
Accusoft.PrintProSdk.CannotGetDefaultPrinterException

See Also

Reference

CannotGetDefaultPrinterException Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
CannotGetDefaultPrinterException Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : CannotGetDefaultPrinterException Class

Glossary Item Box

The following tables list the members exposed by CannotGetDefaultPrinterException.

Public Constructors

 | Name | Description
Public Constructor | CannotGetDefaultPrinterException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

CannotGetDefaultPrinterException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
CannotGetDefaultPrinterException Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : CannotGetDefaultPrinterException Class

Glossary Item Box

For a list of all members of this type, see CannotGetDefaultPrinterException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

CannotGetDefaultPrinterException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
CannotGetDefaultPrinterException Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : CannotGetDefaultPrinterException Class

Glossary Item Box

For a list of all members of this type, see CannotGetDefaultPrinterException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

CannotGetDefaultPrinterException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CannotGetDefaultPrinterException Constructor
See Also Send Feedback
Accusoft.PrintProSdk Namespace > CannotGetDefaultPrinterException Class : CannotGetDefaultPrinterException Constructor

Glossary Item Box

Overload List

Overload | Description
CannotGetDefaultPrinterException Constructor() | An exception generated for a cannot get default printer error.
CannotGetDefaultPrinterException Constructor(Int32) | Generated exception for a cannot get default printer error with a given error number.
CannotGetDefaultPrinterException Constructor(String) | Generated exception for a cannot get default printer error with a given string.
CannotGetDefaultPrinterException Constructor(Int32,String) | Generated exception for a cannot get default printer error with a given error number and message.
CannotGetDefaultPrinterException Constructor(String,Exception) | Generated exception for a cannot get default printer error with a given message and inner exception.

See Also

Reference

CannotGetDefaultPrinterException Class
CannotGetDefaultPrinterException Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CannotGetDefaultPrinterException Constructor()
See Also Send Feedback
Accusoft.PrintProSdk Namespace > CannotGetDefaultPrinterException Class > CannotGetDefaultPrinterException Constructor : CannotGetDefaultPrinterException Constructor()

Glossary Item Box

An exception generated for a cannot get default printer error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New CannotGetDefaultPrinterException()
public CannotGetDefaultPrinterException()
public: CannotGetDefaultPrinterException();
public:
CannotGetDefaultPrinterException();

See Also

Reference

CannotGetDefaultPrinterException Class
CannotGetDefaultPrinterException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CannotGetDefaultPrinterException Constructor(Int32)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > CannotGetDefaultPrinterException Class > CannotGetDefaultPrinterException Constructor : CannotGetDefaultPrinterException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a cannot get default printer error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New CannotGetDefaultPrinterException(errorNumber)
public CannotGetDefaultPrinterException(
   int errorNumber
)
public: CannotGetDefaultPrinterException(
   int errorNumber
)
public:
CannotGetDefaultPrinterException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

CannotGetDefaultPrinterException Class
CannotGetDefaultPrinterException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CannotGetDefaultPrinterException Constructor(String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > CannotGetDefaultPrinterException Class > CannotGetDefaultPrinterException Constructor : CannotGetDefaultPrinterException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a cannot get default printer error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New CannotGetDefaultPrinterException(message)
public CannotGetDefaultPrinterException(
   string message
)
public: CannotGetDefaultPrinterException(
   string* message
)
public:
CannotGetDefaultPrinterException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

CannotGetDefaultPrinterException Class
CannotGetDefaultPrinterException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CannotGetDefaultPrinterException Constructor(Int32,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > CannotGetDefaultPrinterException Class > CannotGetDefaultPrinterException Constructor : CannotGetDefaultPrinterException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a cannot get default printer error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New CannotGetDefaultPrinterException(errorNumber, message)
public CannotGetDefaultPrinterException(
   int errorNumber,
   string message
)
public: CannotGetDefaultPrinterException(
   int errorNumber,
   string* message
)
public:
CannotGetDefaultPrinterException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

CannotGetDefaultPrinterException Class
CannotGetDefaultPrinterException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CannotGetDefaultPrinterException Constructor(String,Exception)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > CannotGetDefaultPrinterException Class > CannotGetDefaultPrinterException Constructor : CannotGetDefaultPrinterException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a cannot get default printer error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New CannotGetDefaultPrinterException(message, innerException)
public CannotGetDefaultPrinterException(
   string message,
   Exception innerException
)
public: CannotGetDefaultPrinterException(
   string* message,
   Exception* innerException
)
public:
CannotGetDefaultPrinterException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

CannotGetDefaultPrinterException Class
CannotGetDefaultPrinterException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CannotGetErrorMessageException Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : CannotGetErrorMessageException Class

Glossary Item Box

This exception is thrown if PrintPRO is unable to get an error message.

Object Model

CannotGetErrorMessageException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class CannotGetErrorMessageException
   Inherits PrintProException
'Usage

Dim instance As CannotGetErrorMessageException
[SerializableAttribute()]
public sealed class CannotGetErrorMessageException : PrintProException
[SerializableAttribute()]
public __gc __sealed class CannotGetErrorMessageException : public PrintProException
[SerializableAttribute()]
public ref class CannotGetErrorMessageException sealed : public PrintProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.PrintProSdk.PrintProException
Accusoft.PrintProSdk.CannotGetErrorMessageException

See Also

Reference

CannotGetErrorMessageException Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
CannotGetErrorMessageException Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : CannotGetErrorMessageException Class

Glossary Item Box

The following tables list the members exposed by CannotGetErrorMessageException.

Public Constructors

 | Name | Description
Public Constructor | CannotGetErrorMessageException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

CannotGetErrorMessageException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
CannotGetErrorMessageException Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : CannotGetErrorMessageException Class

Glossary Item Box

For a list of all members of this type, see CannotGetErrorMessageException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

CannotGetErrorMessageException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
CannotGetErrorMessageException Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : CannotGetErrorMessageException Class

Glossary Item Box

For a list of all members of this type, see CannotGetErrorMessageException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

CannotGetErrorMessageException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CannotGetErrorMessageException Constructor
See Also Send Feedback
Accusoft.PrintProSdk Namespace > CannotGetErrorMessageException Class : CannotGetErrorMessageException Constructor

Glossary Item Box

Overload List

Overload | Description
CannotGetErrorMessageException Constructor() | An exception generated for a cannot get error message error.
CannotGetErrorMessageException Constructor(Int32) | Generated exception for a cannot get error message error with a given error number.
CannotGetErrorMessageException Constructor(String) | Generated exception for a cannot get error message error with a given string.
CannotGetErrorMessageException Constructor(Int32,String) | Generated exception for a cannot get error message error with a given error number and message.
CannotGetErrorMessageException Constructor(String,Exception) | Generated exception for a cannot get error message error with a given message and inner exception.

See Also

Reference

CannotGetErrorMessageException Class
CannotGetErrorMessageException Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CannotGetErrorMessageException Constructor()
See Also Send Feedback
Accusoft.PrintProSdk Namespace > CannotGetErrorMessageException Class > CannotGetErrorMessageException Constructor : CannotGetErrorMessageException Constructor()

Glossary Item Box

An exception generated for a cannot get error message error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New CannotGetErrorMessageException()
public CannotGetErrorMessageException()
public: CannotGetErrorMessageException();
public:
CannotGetErrorMessageException();

See Also

Reference

CannotGetErrorMessageException Class
CannotGetErrorMessageException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CannotGetErrorMessageException Constructor(Int32)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > CannotGetErrorMessageException Class > CannotGetErrorMessageException Constructor : CannotGetErrorMessageException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a cannot get error message error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New CannotGetErrorMessageException(errorNumber)
public CannotGetErrorMessageException(
   int errorNumber
)
public: CannotGetErrorMessageException(
   int errorNumber
)
public:
CannotGetErrorMessageException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

CannotGetErrorMessageException Class
CannotGetErrorMessageException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CannotGetErrorMessageException Constructor(String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > CannotGetErrorMessageException Class > CannotGetErrorMessageException Constructor : CannotGetErrorMessageException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a cannot get error message error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New CannotGetErrorMessageException(message)
public CannotGetErrorMessageException(
   string message
)
public: CannotGetErrorMessageException(
   string* message
)
public:
CannotGetErrorMessageException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

CannotGetErrorMessageException Class
CannotGetErrorMessageException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CannotGetErrorMessageException Constructor(Int32,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > CannotGetErrorMessageException Class > CannotGetErrorMessageException Constructor : CannotGetErrorMessageException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a cannot get error message error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New CannotGetErrorMessageException(errorNumber, message)
public CannotGetErrorMessageException(
   int errorNumber,
   string message
)
public: CannotGetErrorMessageException(
   int errorNumber,
   string* message
)
public:
CannotGetErrorMessageException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

CannotGetErrorMessageException Class
CannotGetErrorMessageException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CannotGetErrorMessageException Constructor(String,Exception)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > CannotGetErrorMessageException Class > CannotGetErrorMessageException Constructor : CannotGetErrorMessageException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a cannot get error message error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New CannotGetErrorMessageException(message, innerException)
public CannotGetErrorMessageException(
   string message,
   Exception innerException
)
public: CannotGetErrorMessageException(
   string* message,
   Exception* innerException
)
public:
CannotGetErrorMessageException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

CannotGetErrorMessageException Class
CannotGetErrorMessageException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CannotGetMetafileDCException Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : CannotGetMetafileDCException Class

Glossary Item Box

This exception is thrown if an error occurs when getting the metafile DC.

Object Model

CannotGetMetafileDCException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class CannotGetMetafileDCException
   Inherits PrintProException
'Usage

Dim instance As CannotGetMetafileDCException
[SerializableAttribute()]
public sealed class CannotGetMetafileDCException : PrintProException
[SerializableAttribute()]
public __gc __sealed class CannotGetMetafileDCException : public PrintProException
[SerializableAttribute()]
public ref class CannotGetMetafileDCException sealed : public PrintProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.PrintProSdk.PrintProException
Accusoft.PrintProSdk.CannotGetMetafileDCException

See Also

Reference

CannotGetMetafileDCException Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
CannotGetMetafileDCException Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : CannotGetMetafileDCException Class

Glossary Item Box

The following tables list the members exposed by CannotGetMetafileDCException.

Public Constructors

 | Name | Description
Public Constructor | CannotGetMetafileDCException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

CannotGetMetafileDCException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
CannotGetMetafileDCException Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : CannotGetMetafileDCException Class

Glossary Item Box

For a list of all members of this type, see CannotGetMetafileDCException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

CannotGetMetafileDCException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
CannotGetMetafileDCException Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : CannotGetMetafileDCException Class

Glossary Item Box

For a list of all members of this type, see CannotGetMetafileDCException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

CannotGetMetafileDCException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CannotGetMetafileDCException Constructor
See Also Send Feedback
Accusoft.PrintProSdk Namespace > CannotGetMetafileDCException Class : CannotGetMetafileDCException Constructor

Glossary Item Box

Overload List

Overload | Description
CannotGetMetafileDCException Constructor() | An exception generated for a cannot get metafile DC error.
CannotGetMetafileDCException Constructor(Int32) | Generated exception for a cannot get metafile DC error with a given error number.
CannotGetMetafileDCException Constructor(String) | Generated exception for a cannot get metafile DC error with a given string.
CannotGetMetafileDCException Constructor(Int32,String) | Generated exception for a cannot get metafile DC error with a given error number and message.
CannotGetMetafileDCException Constructor(String,Exception) | Generated exception for a cannot get metafile DC error with a given message and inner exception.

See Also

Reference

CannotGetMetafileDCException Class
CannotGetMetafileDCException Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CannotGetMetafileDCException Constructor()
See Also Send Feedback
Accusoft.PrintProSdk Namespace > CannotGetMetafileDCException Class > CannotGetMetafileDCException Constructor : CannotGetMetafileDCException Constructor()

Glossary Item Box

An exception generated for a cannot get metafile DC error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New CannotGetMetafileDCException()
public CannotGetMetafileDCException()
public: CannotGetMetafileDCException();
public:
CannotGetMetafileDCException();

See Also

Reference

CannotGetMetafileDCException Class
CannotGetMetafileDCException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CannotGetMetafileDCException Constructor(Int32)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > CannotGetMetafileDCException Class > CannotGetMetafileDCException Constructor : CannotGetMetafileDCException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a cannot get metafile DC error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New CannotGetMetafileDCException(errorNumber)
public CannotGetMetafileDCException(
   int errorNumber
)
public: CannotGetMetafileDCException(
   int errorNumber
)
public:
CannotGetMetafileDCException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

CannotGetMetafileDCException Class
CannotGetMetafileDCException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CannotGetMetafileDCException Constructor(String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > CannotGetMetafileDCException Class > CannotGetMetafileDCException Constructor : CannotGetMetafileDCException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a cannot get metafile DC error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New CannotGetMetafileDCException(message)
public CannotGetMetafileDCException(
   string message
)
public: CannotGetMetafileDCException(
   string* message
)
public:
CannotGetMetafileDCException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

CannotGetMetafileDCException Class
CannotGetMetafileDCException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CannotGetMetafileDCException Constructor(Int32,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > CannotGetMetafileDCException Class > CannotGetMetafileDCException Constructor : CannotGetMetafileDCException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a cannot get metafile DC error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New CannotGetMetafileDCException(errorNumber, message)
public CannotGetMetafileDCException(
   int errorNumber,
   string message
)
public: CannotGetMetafileDCException(
   int errorNumber,
   string* message
)
public:
CannotGetMetafileDCException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

CannotGetMetafileDCException Class
CannotGetMetafileDCException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CannotGetMetafileDCException Constructor(String,Exception)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > CannotGetMetafileDCException Class > CannotGetMetafileDCException Constructor : CannotGetMetafileDCException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a cannot get metafile DC error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New CannotGetMetafileDCException(message, innerException)
public CannotGetMetafileDCException(
   string message,
   Exception innerException
)
public: CannotGetMetafileDCException(
   string* message,
   Exception* innerException
)
public:
CannotGetMetafileDCException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

CannotGetMetafileDCException Class
CannotGetMetafileDCException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CannotGetPrinterPropertyException Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : CannotGetPrinterPropertyException Class

Glossary Item Box

This exception is thrown if the selected printer does not support getting values for this property.

Object Model

CannotGetPrinterPropertyException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class CannotGetPrinterPropertyException
   Inherits PrintProException
'Usage

Dim instance As CannotGetPrinterPropertyException
[SerializableAttribute()]
public sealed class CannotGetPrinterPropertyException : PrintProException
[SerializableAttribute()]
public __gc __sealed class CannotGetPrinterPropertyException : public PrintProException
[SerializableAttribute()]
public ref class CannotGetPrinterPropertyException sealed : public PrintProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.PrintProSdk.PrintProException
Accusoft.PrintProSdk.CannotGetPrinterPropertyException

See Also

Reference

CannotGetPrinterPropertyException Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
CannotGetPrinterPropertyException Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : CannotGetPrinterPropertyException Class

Glossary Item Box

The following tables list the members exposed by CannotGetPrinterPropertyException.

Public Constructors

 | Name | Description
Public Constructor | CannotGetPrinterPropertyException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

CannotGetPrinterPropertyException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
CannotGetPrinterPropertyException Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : CannotGetPrinterPropertyException Class

Glossary Item Box

For a list of all members of this type, see CannotGetPrinterPropertyException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

CannotGetPrinterPropertyException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
CannotGetPrinterPropertyException Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : CannotGetPrinterPropertyException Class

Glossary Item Box

For a list of all members of this type, see CannotGetPrinterPropertyException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

CannotGetPrinterPropertyException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CannotGetPrinterPropertyException Constructor
See Also Send Feedback
Accusoft.PrintProSdk Namespace > CannotGetPrinterPropertyException Class : CannotGetPrinterPropertyException Constructor

Glossary Item Box

Overload List

Overload | Description
CannotGetPrinterPropertyException Constructor() | An exception generated for a cannot get printer property error.
CannotGetPrinterPropertyException Constructor(Int32) | Generated exception for a cannot get printer property error with a given error number.
CannotGetPrinterPropertyException Constructor(String) | Generated exception for a cannot get printer property error with a given string.
CannotGetPrinterPropertyException Constructor(Int32,String) | Generated exception for a cannot get printer property error with a given error number and message.
CannotGetPrinterPropertyException Constructor(String,Exception) | Generated exception for a cannot get printer property error with a given message and inner exception.

See Also

Reference

CannotGetPrinterPropertyException Class
CannotGetPrinterPropertyException Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CannotGetPrinterPropertyException Constructor()
See Also Send Feedback
Accusoft.PrintProSdk Namespace > CannotGetPrinterPropertyException Class > CannotGetPrinterPropertyException Constructor : CannotGetPrinterPropertyException Constructor()

Glossary Item Box

An exception generated for a cannot get printer property error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New CannotGetPrinterPropertyException()
public CannotGetPrinterPropertyException()
public: CannotGetPrinterPropertyException();
public:
CannotGetPrinterPropertyException();

See Also

Reference

CannotGetPrinterPropertyException Class
CannotGetPrinterPropertyException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CannotGetPrinterPropertyException Constructor(Int32)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > CannotGetPrinterPropertyException Class > CannotGetPrinterPropertyException Constructor : CannotGetPrinterPropertyException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a cannot get printer property error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New CannotGetPrinterPropertyException(errorNumber)
public CannotGetPrinterPropertyException(
   int errorNumber
)
public: CannotGetPrinterPropertyException(
   int errorNumber
)
public:
CannotGetPrinterPropertyException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

CannotGetPrinterPropertyException Class
CannotGetPrinterPropertyException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CannotGetPrinterPropertyException Constructor(String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > CannotGetPrinterPropertyException Class > CannotGetPrinterPropertyException Constructor : CannotGetPrinterPropertyException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a cannot get printer property error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New CannotGetPrinterPropertyException(message)
public CannotGetPrinterPropertyException(
   string message
)
public: CannotGetPrinterPropertyException(
   string* message
)
public:
CannotGetPrinterPropertyException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

CannotGetPrinterPropertyException Class
CannotGetPrinterPropertyException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CannotGetPrinterPropertyException Constructor(Int32,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > CannotGetPrinterPropertyException Class > CannotGetPrinterPropertyException Constructor : CannotGetPrinterPropertyException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a cannot get printer property error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New CannotGetPrinterPropertyException(errorNumber, message)
public CannotGetPrinterPropertyException(
   int errorNumber,
   string message
)
public: CannotGetPrinterPropertyException(
   int errorNumber,
   string* message
)
public:
CannotGetPrinterPropertyException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

CannotGetPrinterPropertyException Class
CannotGetPrinterPropertyException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CannotGetPrinterPropertyException Constructor(String,Exception)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > CannotGetPrinterPropertyException Class > CannotGetPrinterPropertyException Constructor : CannotGetPrinterPropertyException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a cannot get printer property error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New CannotGetPrinterPropertyException(message, innerException)
public CannotGetPrinterPropertyException(
   string message,
   Exception innerException
)
public: CannotGetPrinterPropertyException(
   string* message,
   Exception* innerException
)
public:
CannotGetPrinterPropertyException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

CannotGetPrinterPropertyException Class
CannotGetPrinterPropertyException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CannotOpenPrinterException Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : CannotOpenPrinterException Class

Glossary Item Box

This exception is thrown if an error occurs when opening the printer.

Object Model

CannotOpenPrinterException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class CannotOpenPrinterException
   Inherits PrintProException
'Usage

Dim instance As CannotOpenPrinterException
[SerializableAttribute()]
public sealed class CannotOpenPrinterException : PrintProException
[SerializableAttribute()]
public __gc __sealed class CannotOpenPrinterException : public PrintProException
[SerializableAttribute()]
public ref class CannotOpenPrinterException sealed : public PrintProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.PrintProSdk.PrintProException
Accusoft.PrintProSdk.CannotOpenPrinterException

See Also

Reference

CannotOpenPrinterException Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
CannotOpenPrinterException Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : CannotOpenPrinterException Class

Glossary Item Box

The following tables list the members exposed by CannotOpenPrinterException.

Public Constructors

 | Name | Description
Public Constructor | CannotOpenPrinterException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

CannotOpenPrinterException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
CannotOpenPrinterException Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : CannotOpenPrinterException Class

Glossary Item Box

For a list of all members of this type, see CannotOpenPrinterException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

CannotOpenPrinterException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
CannotOpenPrinterException Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : CannotOpenPrinterException Class

Glossary Item Box

For a list of all members of this type, see CannotOpenPrinterException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

CannotOpenPrinterException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CannotOpenPrinterException Constructor
See Also Send Feedback
Accusoft.PrintProSdk Namespace > CannotOpenPrinterException Class : CannotOpenPrinterException Constructor

Glossary Item Box

Overload List

Overload | Description
CannotOpenPrinterException Constructor() | An exception generated for a cannot open printer error.
CannotOpenPrinterException Constructor(Int32) | Generated exception for a cannot open printer error with a given error number.
CannotOpenPrinterException Constructor(String) | Generated exception for a cannot open printer error with a given string.
CannotOpenPrinterException Constructor(Int32,String) | Generated exception for a cannot open printer error with a given error number and message.
CannotOpenPrinterException Constructor(String,Exception) | Generated exception for a cannot open printer error with a given message and inner exception.

See Also

Reference

CannotOpenPrinterException Class
CannotOpenPrinterException Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CannotOpenPrinterException Constructor()
See Also Send Feedback
Accusoft.PrintProSdk Namespace > CannotOpenPrinterException Class > CannotOpenPrinterException Constructor : CannotOpenPrinterException Constructor()

Glossary Item Box

An exception generated for a cannot open printer error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New CannotOpenPrinterException()
public CannotOpenPrinterException()
public: CannotOpenPrinterException();
public:
CannotOpenPrinterException();

See Also

Reference

CannotOpenPrinterException Class
CannotOpenPrinterException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CannotOpenPrinterException Constructor(Int32)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > CannotOpenPrinterException Class > CannotOpenPrinterException Constructor : CannotOpenPrinterException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a cannot open printer error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New CannotOpenPrinterException(errorNumber)
public CannotOpenPrinterException(
   int errorNumber
)
public: CannotOpenPrinterException(
   int errorNumber
)
public:
CannotOpenPrinterException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

CannotOpenPrinterException Class
CannotOpenPrinterException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CannotOpenPrinterException Constructor(String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > CannotOpenPrinterException Class > CannotOpenPrinterException Constructor : CannotOpenPrinterException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a cannot open printer error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New CannotOpenPrinterException(message)
public CannotOpenPrinterException(
   string message
)
public: CannotOpenPrinterException(
   string* message
)
public:
CannotOpenPrinterException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

CannotOpenPrinterException Class
CannotOpenPrinterException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CannotOpenPrinterException Constructor(Int32,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > CannotOpenPrinterException Class > CannotOpenPrinterException Constructor : CannotOpenPrinterException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a cannot open printer error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New CannotOpenPrinterException(errorNumber, message)
public CannotOpenPrinterException(
   int errorNumber,
   string message
)
public: CannotOpenPrinterException(
   int errorNumber,
   string* message
)
public:
CannotOpenPrinterException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

CannotOpenPrinterException Class
CannotOpenPrinterException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CannotOpenPrinterException Constructor(String,Exception)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > CannotOpenPrinterException Class > CannotOpenPrinterException Constructor : CannotOpenPrinterException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a cannot open printer error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New CannotOpenPrinterException(message, innerException)
public CannotOpenPrinterException(
   string message,
   Exception innerException
)
public: CannotOpenPrinterException(
   string* message,
   Exception* innerException
)
public:
CannotOpenPrinterException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

CannotOpenPrinterException Class
CannotOpenPrinterException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CannotSetPrinterPropertyException Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : CannotSetPrinterPropertyException Class

Glossary Item Box

This exception is thrown if the selected printer does not support setting values for this property.

Object Model

CannotSetPrinterPropertyException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class CannotSetPrinterPropertyException
   Inherits PrintProException
'Usage

Dim instance As CannotSetPrinterPropertyException
[SerializableAttribute()]
public sealed class CannotSetPrinterPropertyException : PrintProException
[SerializableAttribute()]
public __gc __sealed class CannotSetPrinterPropertyException : public PrintProException
[SerializableAttribute()]
public ref class CannotSetPrinterPropertyException sealed : public PrintProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.PrintProSdk.PrintProException
Accusoft.PrintProSdk.CannotSetPrinterPropertyException

See Also

Reference

CannotSetPrinterPropertyException Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
CannotSetPrinterPropertyException Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : CannotSetPrinterPropertyException Class

Glossary Item Box

The following tables list the members exposed by CannotSetPrinterPropertyException.

Public Constructors

 | Name | Description
Public Constructor | CannotSetPrinterPropertyException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

CannotSetPrinterPropertyException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
CannotSetPrinterPropertyException Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : CannotSetPrinterPropertyException Class

Glossary Item Box

For a list of all members of this type, see CannotSetPrinterPropertyException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

CannotSetPrinterPropertyException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
CannotSetPrinterPropertyException Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : CannotSetPrinterPropertyException Class

Glossary Item Box

For a list of all members of this type, see CannotSetPrinterPropertyException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

CannotSetPrinterPropertyException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CannotSetPrinterPropertyException Constructor
See Also Send Feedback
Accusoft.PrintProSdk Namespace > CannotSetPrinterPropertyException Class : CannotSetPrinterPropertyException Constructor

Glossary Item Box

Overload List

Overload | Description
CannotSetPrinterPropertyException Constructor() | An exception generated for a cannot set printer property error.
CannotSetPrinterPropertyException Constructor(Int32) | Generated exception for a cannot set printer property error with a given error number.
CannotSetPrinterPropertyException Constructor(String) | Generated exception for a cannot set printer property error with a given string.
CannotSetPrinterPropertyException Constructor(Int32,String) | Generated exception for a cannot set printer property error with a given error number and message.
CannotSetPrinterPropertyException Constructor(String,Exception) | Generated exception for a cannot set printer property error with a given message and inner exception.

See Also

Reference

CannotSetPrinterPropertyException Class
CannotSetPrinterPropertyException Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CannotSetPrinterPropertyException Constructor()
See Also Send Feedback
Accusoft.PrintProSdk Namespace > CannotSetPrinterPropertyException Class > CannotSetPrinterPropertyException Constructor : CannotSetPrinterPropertyException Constructor()

Glossary Item Box

An exception generated for a cannot set printer property error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New CannotSetPrinterPropertyException()
public CannotSetPrinterPropertyException()
public: CannotSetPrinterPropertyException();
public:
CannotSetPrinterPropertyException();

See Also

Reference

CannotSetPrinterPropertyException Class
CannotSetPrinterPropertyException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CannotSetPrinterPropertyException Constructor(Int32)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > CannotSetPrinterPropertyException Class > CannotSetPrinterPropertyException Constructor : CannotSetPrinterPropertyException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a cannot set printer property error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New CannotSetPrinterPropertyException(errorNumber)
public CannotSetPrinterPropertyException(
   int errorNumber
)
public: CannotSetPrinterPropertyException(
   int errorNumber
)
public:
CannotSetPrinterPropertyException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

CannotSetPrinterPropertyException Class
CannotSetPrinterPropertyException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CannotSetPrinterPropertyException Constructor(String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > CannotSetPrinterPropertyException Class > CannotSetPrinterPropertyException Constructor : CannotSetPrinterPropertyException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a cannot set printer property error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New CannotSetPrinterPropertyException(message)
public CannotSetPrinterPropertyException(
   string message
)
public: CannotSetPrinterPropertyException(
   string* message
)
public:
CannotSetPrinterPropertyException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

CannotSetPrinterPropertyException Class
CannotSetPrinterPropertyException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CannotSetPrinterPropertyException Constructor(Int32,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > CannotSetPrinterPropertyException Class > CannotSetPrinterPropertyException Constructor : CannotSetPrinterPropertyException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a cannot set printer property error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New CannotSetPrinterPropertyException(errorNumber, message)
public CannotSetPrinterPropertyException(
   int errorNumber,
   string message
)
public: CannotSetPrinterPropertyException(
   int errorNumber,
   string* message
)
public:
CannotSetPrinterPropertyException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

CannotSetPrinterPropertyException Class
CannotSetPrinterPropertyException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CannotSetPrinterPropertyException Constructor(String,Exception)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > CannotSetPrinterPropertyException Class > CannotSetPrinterPropertyException Constructor : CannotSetPrinterPropertyException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a cannot set printer property error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New CannotSetPrinterPropertyException(message, innerException)
public CannotSetPrinterPropertyException(
   string message,
   Exception innerException
)
public: CannotSetPrinterPropertyException(
   string* message,
   Exception* innerException
)
public:
CannotSetPrinterPropertyException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

CannotSetPrinterPropertyException Class
CannotSetPrinterPropertyException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CannotWriteToPrinterException Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : CannotWriteToPrinterException Class

Glossary Item Box

This exception is thrown if an error occurs when writing to the printer.

Object Model

CannotWriteToPrinterException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class CannotWriteToPrinterException
   Inherits PrintProException
'Usage

Dim instance As CannotWriteToPrinterException
[SerializableAttribute()]
public sealed class CannotWriteToPrinterException : PrintProException
[SerializableAttribute()]
public __gc __sealed class CannotWriteToPrinterException : public PrintProException
[SerializableAttribute()]
public ref class CannotWriteToPrinterException sealed : public PrintProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.PrintProSdk.PrintProException
Accusoft.PrintProSdk.CannotWriteToPrinterException

See Also

Reference

CannotWriteToPrinterException Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
CannotWriteToPrinterException Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : CannotWriteToPrinterException Class

Glossary Item Box

The following tables list the members exposed by CannotWriteToPrinterException.

Public Constructors

 | Name | Description
Public Constructor | CannotWriteToPrinterException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

CannotWriteToPrinterException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
CannotWriteToPrinterException Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : CannotWriteToPrinterException Class

Glossary Item Box

For a list of all members of this type, see CannotWriteToPrinterException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

CannotWriteToPrinterException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
CannotWriteToPrinterException Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : CannotWriteToPrinterException Class

Glossary Item Box

For a list of all members of this type, see CannotWriteToPrinterException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

CannotWriteToPrinterException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CannotWriteToPrinterException Constructor
See Also Send Feedback
Accusoft.PrintProSdk Namespace > CannotWriteToPrinterException Class : CannotWriteToPrinterException Constructor

Glossary Item Box

Overload List

Overload | Description
CannotWriteToPrinterException Constructor() | An exception generated for a cannot write to printer error.
CannotWriteToPrinterException Constructor(Int32) | Generated exception for a cannot write to printer error with a given error number.
CannotWriteToPrinterException Constructor(String) | Generated exception for a cannot write to printer error with a given string.
CannotWriteToPrinterException Constructor(Int32,String) | Generated exception for a cannot write to printer error with a given error number and message.
CannotWriteToPrinterException Constructor(String,Exception) | Generated exception for a cannot write to printer error with a given message and inner exception.

See Also

Reference

CannotWriteToPrinterException Class
CannotWriteToPrinterException Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CannotWriteToPrinterException Constructor()
See Also Send Feedback
Accusoft.PrintProSdk Namespace > CannotWriteToPrinterException Class > CannotWriteToPrinterException Constructor : CannotWriteToPrinterException Constructor()

Glossary Item Box

An exception generated for a cannot write to printer error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New CannotWriteToPrinterException()
public CannotWriteToPrinterException()
public: CannotWriteToPrinterException();
public:
CannotWriteToPrinterException();

See Also

Reference

CannotWriteToPrinterException Class
CannotWriteToPrinterException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CannotWriteToPrinterException Constructor(Int32)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > CannotWriteToPrinterException Class > CannotWriteToPrinterException Constructor : CannotWriteToPrinterException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a cannot write to printer error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New CannotWriteToPrinterException(errorNumber)
public CannotWriteToPrinterException(
   int errorNumber
)
public: CannotWriteToPrinterException(
   int errorNumber
)
public:
CannotWriteToPrinterException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

CannotWriteToPrinterException Class
CannotWriteToPrinterException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CannotWriteToPrinterException Constructor(String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > CannotWriteToPrinterException Class > CannotWriteToPrinterException Constructor : CannotWriteToPrinterException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a cannot write to printer error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New CannotWriteToPrinterException(message)
public CannotWriteToPrinterException(
   string message
)
public: CannotWriteToPrinterException(
   string* message
)
public:
CannotWriteToPrinterException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

CannotWriteToPrinterException Class
CannotWriteToPrinterException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CannotWriteToPrinterException Constructor(Int32,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > CannotWriteToPrinterException Class > CannotWriteToPrinterException Constructor : CannotWriteToPrinterException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a cannot write to printer error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New CannotWriteToPrinterException(errorNumber, message)
public CannotWriteToPrinterException(
   int errorNumber,
   string message
)
public: CannotWriteToPrinterException(
   int errorNumber,
   string* message
)
public:
CannotWriteToPrinterException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

CannotWriteToPrinterException Class
CannotWriteToPrinterException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CannotWriteToPrinterException Constructor(String,Exception)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > CannotWriteToPrinterException Class > CannotWriteToPrinterException Constructor : CannotWriteToPrinterException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a cannot write to printer error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New CannotWriteToPrinterException(message, innerException)
public CannotWriteToPrinterException(
   string message,
   Exception innerException
)
public: CannotWriteToPrinterException(
   string* message,
   Exception* innerException
)
public:
CannotWriteToPrinterException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

CannotWriteToPrinterException Class
CannotWriteToPrinterException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
DocumentAlreadyStartedException Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : DocumentAlreadyStartedException Class

Glossary Item Box

This exception is thrown if a new document is started when a document has already been started.

Object Model

DocumentAlreadyStartedException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class DocumentAlreadyStartedException
   Inherits PrintProException
'Usage

Dim instance As DocumentAlreadyStartedException
[SerializableAttribute()]
public sealed class DocumentAlreadyStartedException : PrintProException
[SerializableAttribute()]
public __gc __sealed class DocumentAlreadyStartedException : public PrintProException
[SerializableAttribute()]
public ref class DocumentAlreadyStartedException sealed : public PrintProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.PrintProSdk.PrintProException
Accusoft.PrintProSdk.DocumentAlreadyStartedException

See Also

Reference

DocumentAlreadyStartedException Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
DocumentAlreadyStartedException Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : DocumentAlreadyStartedException Class

Glossary Item Box

The following tables list the members exposed by DocumentAlreadyStartedException.

Public Constructors

 | Name | Description
Public Constructor | DocumentAlreadyStartedException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

DocumentAlreadyStartedException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
DocumentAlreadyStartedException Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : DocumentAlreadyStartedException Class

Glossary Item Box

For a list of all members of this type, see DocumentAlreadyStartedException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

DocumentAlreadyStartedException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
DocumentAlreadyStartedException Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : DocumentAlreadyStartedException Class

Glossary Item Box

For a list of all members of this type, see DocumentAlreadyStartedException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

DocumentAlreadyStartedException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
DocumentAlreadyStartedException Constructor
See Also Send Feedback
Accusoft.PrintProSdk Namespace > DocumentAlreadyStartedException Class : DocumentAlreadyStartedException Constructor

Glossary Item Box

Overload List

Overload | Description
DocumentAlreadyStartedException Constructor() | An exception generated for a document already started error.
DocumentAlreadyStartedException Constructor(Int32) | Generated exception for a document already started error with a given error number.
DocumentAlreadyStartedException Constructor(String) | Generated exception for a document already started error with a given string.
DocumentAlreadyStartedException Constructor(Int32,String) | Generated exception for a document already started error with a given error number and message.
DocumentAlreadyStartedException Constructor(String,Exception) | Generated exception for a document already started error with a given message and inner exception.

See Also

Reference

DocumentAlreadyStartedException Class
DocumentAlreadyStartedException Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
DocumentAlreadyStartedException Constructor()
See Also Send Feedback
Accusoft.PrintProSdk Namespace > DocumentAlreadyStartedException Class > DocumentAlreadyStartedException Constructor : DocumentAlreadyStartedException Constructor()

Glossary Item Box

An exception generated for a document already started error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New DocumentAlreadyStartedException()
public DocumentAlreadyStartedException()
public: DocumentAlreadyStartedException();
public:
DocumentAlreadyStartedException();

See Also

Reference

DocumentAlreadyStartedException Class
DocumentAlreadyStartedException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
DocumentAlreadyStartedException Constructor(Int32)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > DocumentAlreadyStartedException Class > DocumentAlreadyStartedException Constructor : DocumentAlreadyStartedException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a document already started error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New DocumentAlreadyStartedException(errorNumber)
public DocumentAlreadyStartedException(
   int errorNumber
)
public: DocumentAlreadyStartedException(
   int errorNumber
)
public:
DocumentAlreadyStartedException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

DocumentAlreadyStartedException Class
DocumentAlreadyStartedException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
DocumentAlreadyStartedException Constructor(String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > DocumentAlreadyStartedException Class > DocumentAlreadyStartedException Constructor : DocumentAlreadyStartedException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a document already started error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New DocumentAlreadyStartedException(message)
public DocumentAlreadyStartedException(
   string message
)
public: DocumentAlreadyStartedException(
   string* message
)
public:
DocumentAlreadyStartedException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

DocumentAlreadyStartedException Class
DocumentAlreadyStartedException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
DocumentAlreadyStartedException Constructor(Int32,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > DocumentAlreadyStartedException Class > DocumentAlreadyStartedException Constructor : DocumentAlreadyStartedException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a document already started error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New DocumentAlreadyStartedException(errorNumber, message)
public DocumentAlreadyStartedException(
   int errorNumber,
   string message
)
public: DocumentAlreadyStartedException(
   int errorNumber,
   string* message
)
public:
DocumentAlreadyStartedException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

DocumentAlreadyStartedException Class
DocumentAlreadyStartedException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
DocumentAlreadyStartedException Constructor(String,Exception)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > DocumentAlreadyStartedException Class > DocumentAlreadyStartedException Constructor : DocumentAlreadyStartedException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a document already started error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New DocumentAlreadyStartedException(message, innerException)
public DocumentAlreadyStartedException(
   string message,
   Exception innerException
)
public: DocumentAlreadyStartedException(
   string* message,
   Exception* innerException
)
public:
DocumentAlreadyStartedException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

DocumentAlreadyStartedException Class
DocumentAlreadyStartedException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
DocumentNotStartedException Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : DocumentNotStartedException Class

Glossary Item Box

This exception is thrown if the desired action cannot be performed because a document has not been started.

Object Model

DocumentNotStartedException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class DocumentNotStartedException
   Inherits PrintProException
'Usage

Dim instance As DocumentNotStartedException
[SerializableAttribute()]
public sealed class DocumentNotStartedException : PrintProException
[SerializableAttribute()]
public __gc __sealed class DocumentNotStartedException : public PrintProException
[SerializableAttribute()]
public ref class DocumentNotStartedException sealed : public PrintProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.PrintProSdk.PrintProException
Accusoft.PrintProSdk.DocumentNotStartedException

See Also

Reference

DocumentNotStartedException Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
DocumentNotStartedException Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : DocumentNotStartedException Class

Glossary Item Box

The following tables list the members exposed by DocumentNotStartedException.

Public Constructors

 | Name | Description
Public Constructor | DocumentNotStartedException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

DocumentNotStartedException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
DocumentNotStartedException Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : DocumentNotStartedException Class

Glossary Item Box

For a list of all members of this type, see DocumentNotStartedException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

DocumentNotStartedException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
DocumentNotStartedException Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : DocumentNotStartedException Class

Glossary Item Box

For a list of all members of this type, see DocumentNotStartedException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

DocumentNotStartedException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
DocumentNotStartedException Constructor
See Also Send Feedback
Accusoft.PrintProSdk Namespace > DocumentNotStartedException Class : DocumentNotStartedException Constructor

Glossary Item Box

Overload List

Overload | Description
DocumentNotStartedException Constructor() | An exception generated for a document not started error.
DocumentNotStartedException Constructor(Int32) | Generated exception for a document not started error with a given error number.
DocumentNotStartedException Constructor(String) | Generated exception for a document not started error with a given string.
DocumentNotStartedException Constructor(Int32,String) | Generated exception for a document not started error with a given error number and message.
DocumentNotStartedException Constructor(String,Exception) | Generated exception for a document not started error with a given message and inner exception.

See Also

Reference

DocumentNotStartedException Class
DocumentNotStartedException Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
DocumentNotStartedException Constructor()
See Also Send Feedback
Accusoft.PrintProSdk Namespace > DocumentNotStartedException Class > DocumentNotStartedException Constructor : DocumentNotStartedException Constructor()

Glossary Item Box

An exception generated for a document not started error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New DocumentNotStartedException()
public DocumentNotStartedException()
public: DocumentNotStartedException();
public:
DocumentNotStartedException();

See Also

Reference

DocumentNotStartedException Class
DocumentNotStartedException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
DocumentNotStartedException Constructor(Int32)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > DocumentNotStartedException Class > DocumentNotStartedException Constructor : DocumentNotStartedException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a document not started error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New DocumentNotStartedException(errorNumber)
public DocumentNotStartedException(
   int errorNumber
)
public: DocumentNotStartedException(
   int errorNumber
)
public:
DocumentNotStartedException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

DocumentNotStartedException Class
DocumentNotStartedException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
DocumentNotStartedException Constructor(String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > DocumentNotStartedException Class > DocumentNotStartedException Constructor : DocumentNotStartedException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a document not started error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New DocumentNotStartedException(message)
public DocumentNotStartedException(
   string message
)
public: DocumentNotStartedException(
   string* message
)
public:
DocumentNotStartedException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

DocumentNotStartedException Class
DocumentNotStartedException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
DocumentNotStartedException Constructor(Int32,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > DocumentNotStartedException Class > DocumentNotStartedException Constructor : DocumentNotStartedException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a document not started error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New DocumentNotStartedException(errorNumber, message)
public DocumentNotStartedException(
   int errorNumber,
   string message
)
public: DocumentNotStartedException(
   int errorNumber,
   string* message
)
public:
DocumentNotStartedException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

DocumentNotStartedException Class
DocumentNotStartedException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
DocumentNotStartedException Constructor(String,Exception)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > DocumentNotStartedException Class > DocumentNotStartedException Constructor : DocumentNotStartedException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a document not started error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New DocumentNotStartedException(message, innerException)
public DocumentNotStartedException(
   string message,
   Exception innerException
)
public: DocumentNotStartedException(
   string* message,
   Exception* innerException
)
public:
DocumentNotStartedException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

DocumentNotStartedException Class
DocumentNotStartedException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Draw Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : Draw Class

Glossary Item Box

This class implements methods and properties for drawing.

Object Model

Draw Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Class Draw
'Usage

Dim instance As Draw
public class Draw
public __gc class Draw
public ref class Draw

Inheritance Hierarchy

System.Object
Accusoft.PrintProSdk.Draw

See Also

Reference

Draw Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
Draw Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : Draw Class

Glossary Item Box

The following tables list the members exposed by Draw.

Public Properties

 | Name | Description
Public Property | BackColor | Gets and sets the background color used for drawing.
Public Property | BackStyle | Gets and sets the background style used for drawing.
Public Property | CurrentX | Gets and sets the current x (horizontal) coordinate the draw cursor is at.
Public Property | CurrentY | Gets and sets the current y (vertical) coordinate the draw cursor is at.
Public Property | FillColor | Gets and sets the fill color used for drawing.
Public Property | FillStyle | Gets and sets the FillStyle used for drawing.
Public Property | ForeColor | Gets and sets the foreground color used for drawing.
Public Property | Mode | Gets and sets the DrawMode enumeration value used for drawing.
Public Property | Style | Gets and sets the DrawStyle used for drawing.
Public Property | Width | Gets and sets the width of the pen used for drawing.
Top

Public Methods

 | Name | Description
Public Method | Arc | Overloaded. Draws an arc on a printer.
Public Method | Circle | Overloaded. Draws a circle or ellipse on a printer.
Public Method | Curve | Overloaded. Draws a cubic bezier curve on a printer.
Public Method | Line | Overloaded. Draws a line or rectangle on a printer.
Public Method | Pie | Overloaded. Draws part of a circle.
Public Method | Polygon | Overloaded. Draws a 3-6 sided polygon on a printer.
Public Method | Rectangle | Overloaded. Draws a rectangle on a printer.
Public Method | RoundRectangle | Overloaded. Draws a rectangle with rounded corners on printer.
Public Method | Text | Overloaded. Draws the specified text string.
Public Method | TextAligned | Overloaded. Draws text with the specified alignment.
Public Method | TextHeight | Overloaded. Returns the height the text would be if the output has a specified font.
Public Method | TextRotated | Overloaded. Outputs text rotated by a specified number of degrees.
Public Method | TextWidth | Overloaded. Returns the width the text would be if output with specified font.
Top

See Also

Reference

Draw Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
Draw Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : Draw Class

Glossary Item Box

For a list of all members of this type, see Draw members.

Public Methods

 | Name | Description
Public Method | Arc | Overloaded. Draws an arc on a printer.
Public Method | Circle | Overloaded. Draws a circle or ellipse on a printer.
Public Method | Curve | Overloaded. Draws a cubic bezier curve on a printer.
Public Method | Line | Overloaded. Draws a line or rectangle on a printer.
Public Method | Pie | Overloaded. Draws part of a circle.
Public Method | Polygon | Overloaded. Draws a 3-6 sided polygon on a printer.
Public Method | Rectangle | Overloaded. Draws a rectangle on a printer.
Public Method | RoundRectangle | Overloaded. Draws a rectangle with rounded corners on printer.
Public Method | Text | Overloaded. Draws the specified text string.
Public Method | TextAligned | Overloaded. Draws text with the specified alignment.
Public Method | TextHeight | Overloaded. Returns the height the text would be if the output has a specified font.
Public Method | TextRotated | Overloaded. Outputs text rotated by a specified number of degrees.
Public Method | TextWidth | Overloaded. Returns the width the text would be if output with specified font.
Top

See Also

Reference

Draw Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Arc Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class : Arc Method

Glossary Item Box

Draws an arc on a printer.

Overload List

Overload | Description
Arc(PointF,PointF,Single,Single,Color) | Draws an arc on a printer.
Arc(RectangleF,Single,Single,Color) | Draws a black arc on a printer.
Arc(PointF,Single,Single,Color) | Draws an arc on a printer from the current Draw location.
Arc(PointF,PointF,Single,Single) | Draws a black arc on a printer.
Arc(RectangleF,Single,Single) | Draws a black arc on a printer.
Arc(PointF,Single,Single) | Draws a black arc on a printer from the current draw location.
Arc(Point,Point,Single,Single,Color) | Draws an arc on a printer.
Arc(Rectangle,Single,Single,Color) | Draws a black arc on a printer.
Arc(Point,Single,Single,Color) | Draws an arc on a printer from the current Draw location.
Arc(Point,Point,Single,Single) | Draws a black arc on a printer.
Arc(Rectangle,Single,Single) | Draws a black arc on a printer.
Arc(Point,Single,Single) | Draws a black arc on a printer from the current draw location.

See Also

Reference

Draw Class
Draw Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Arc(PointF,PointF,Single,Single,Color) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Arc Method : Arc(PointF,PointF,Single,Single,Color) Method

upperLeft
A System.Drawing.PointF which represents the upper-left coordinate for the bounding rectangle.
lowerRight
A System.Drawing.PointF which represents the lower-right coordinate for the bounding rectangle.
startAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.
color
The System.Drawing.Color of the circle’s outline.

Glossary Item Box

Draws an arc on a printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Arc( _
   ByVal upperLeft As PointF, _
   ByVal lowerRight As PointF, _
   ByVal startAngle As Single, _
   ByVal endAngle As Single, _
   ByVal color As Color _
)
'Usage

Dim instance As Draw
Dim upperLeft As PointF
Dim lowerRight As PointF
Dim startAngle As Single
Dim endAngle As Single
Dim color As Color

instance.Arc(upperLeft, lowerRight, startAngle, endAngle, color)
public void Arc(
   PointF upperLeft,
   PointF lowerRight,
   float startAngle,
   float endAngle,
   Color color
)
public: void Arc(
   PointF upperLeft,
   PointF lowerRight,
   float startAngle,
   float endAngle,
   Color color
)
public:
void Arc(
   PointF upperLeft,
   PointF lowerRight,
   float startAngle,
   float endAngle,
   Color color
)

Parameters

upperLeft
A System.Drawing.PointF which represents the upper-left coordinate for the bounding rectangle.
lowerRight
A System.Drawing.PointF which represents the lower-right coordinate for the bounding rectangle.
startAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.
color
The System.Drawing.Color of the circle’s outline.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Arc(RectangleF,Single,Single,Color) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Arc Method : Arc(RectangleF,Single,Single,Color) Method

boundingBox
The bounding System.Drawing.RectangleF that specifies the size of the arc.
startAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.
color
The System.Drawing.Color of the circle’s outline.

Glossary Item Box

Draws a black arc on a printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Arc( _
   ByVal boundingBox As RectangleF, _
   ByVal startAngle As Single, _
   ByVal endAngle As Single, _
   ByVal color As Color _
)
'Usage

Dim instance As Draw
Dim boundingBox As RectangleF
Dim startAngle As Single
Dim endAngle As Single
Dim color As Color

instance.Arc(boundingBox, startAngle, endAngle, color)
public void Arc(
   RectangleF boundingBox,
   float startAngle,
   float endAngle,
   Color color
)
public: void Arc(
   RectangleF boundingBox,
   float startAngle,
   float endAngle,
   Color color
)
public:
void Arc(
   RectangleF boundingBox,
   float startAngle,
   float endAngle,
   Color color
)

Parameters

boundingBox
The bounding System.Drawing.RectangleF that specifies the size of the arc.
startAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.
color
The System.Drawing.Color of the circle’s outline.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Arc(PointF,Single,Single,Color) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Arc Method : Arc(PointF,Single,Single,Color) Method

endPoint
A System.Drawing.PointF which represents the end coordinate for the bounding rectangle.
startAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.
color
A System.Drawing.Color of the circle’s outline.

Glossary Item Box

Draws an arc on a printer from the current Draw location.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Arc( _
   ByVal endPoint As PointF, _
   ByVal startAngle As Single, _
   ByVal endAngle As Single, _
   ByVal color As Color _
)
'Usage

Dim instance As Draw
Dim endPoint As PointF
Dim startAngle As Single
Dim endAngle As Single
Dim color As Color

instance.Arc(endPoint, startAngle, endAngle, color)
public void Arc(
   PointF endPoint,
   float startAngle,
   float endAngle,
   Color color
)
public: void Arc(
   PointF endPoint,
   float startAngle,
   float endAngle,
   Color color
)
public:
void Arc(
   PointF endPoint,
   float startAngle,
   float endAngle,
   Color color
)

Parameters

endPoint
A System.Drawing.PointF which represents the end coordinate for the bounding rectangle.
startAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.
color
A System.Drawing.Color of the circle’s outline.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Arc(PointF,PointF,Single,Single) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Arc Method : Arc(PointF,PointF,Single,Single) Method

upperLeft
A System.Drawing.PointF which represents the upper-left coordinate for the bounding rectangle.
lowerRight
A System.Drawing.PointF which represents the lower-right coordinate for the bounding rectangle.
startAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.

Glossary Item Box

Draws a black arc on a printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Arc( _
   ByVal upperLeft As PointF, _
   ByVal lowerRight As PointF, _
   ByVal startAngle As Single, _
   ByVal endAngle As Single _
)
'Usage

Dim instance As Draw
Dim upperLeft As PointF
Dim lowerRight As PointF
Dim startAngle As Single
Dim endAngle As Single

instance.Arc(upperLeft, lowerRight, startAngle, endAngle)
public void Arc(
   PointF upperLeft,
   PointF lowerRight,
   float startAngle,
   float endAngle
)
public: void Arc(
   PointF upperLeft,
   PointF lowerRight,
   float startAngle,
   float endAngle
)
public:
void Arc(
   PointF upperLeft,
   PointF lowerRight,
   float startAngle,
   float endAngle
)

Parameters

upperLeft
A System.Drawing.PointF which represents the upper-left coordinate for the bounding rectangle.
lowerRight
A System.Drawing.PointF which represents the lower-right coordinate for the bounding rectangle.
startAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Arc(RectangleF,Single,Single) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Arc Method : Arc(RectangleF,Single,Single) Method

boundingBox
The bounding System.Drawing.RectangleF that specifies the size of the arc
startAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.

Glossary Item Box

Draws a black arc on a printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Arc( _
   ByVal boundingBox As RectangleF, _
   ByVal startAngle As Single, _
   ByVal endAngle As Single _
)
'Usage

Dim instance As Draw
Dim boundingBox As RectangleF
Dim startAngle As Single
Dim endAngle As Single

instance.Arc(boundingBox, startAngle, endAngle)
public void Arc(
   RectangleF boundingBox,
   float startAngle,
   float endAngle
)
public: void Arc(
   RectangleF boundingBox,
   float startAngle,
   float endAngle
)
public:
void Arc(
   RectangleF boundingBox,
   float startAngle,
   float endAngle
)

Parameters

boundingBox
The bounding System.Drawing.RectangleF that specifies the size of the arc
startAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Arc(PointF,Single,Single) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Arc Method : Arc(PointF,Single,Single) Method

endPoint
A System.Drawing.PointF which represents the end coordinate for the bounding rectangle.
startAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.

Glossary Item Box

Draws a black arc on a printer from the current draw location.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Arc( _
   ByVal endPoint As PointF, _
   ByVal startAngle As Single, _
   ByVal endAngle As Single _
)
'Usage

Dim instance As Draw
Dim endPoint As PointF
Dim startAngle As Single
Dim endAngle As Single

instance.Arc(endPoint, startAngle, endAngle)
public void Arc(
   PointF endPoint,
   float startAngle,
   float endAngle
)
public: void Arc(
   PointF endPoint,
   float startAngle,
   float endAngle
)
public:
void Arc(
   PointF endPoint,
   float startAngle,
   float endAngle
)

Parameters

endPoint
A System.Drawing.PointF which represents the end coordinate for the bounding rectangle.
startAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Arc(Point,Point,Single,Single,Color) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Arc Method : Arc(Point,Point,Single,Single,Color) Method

upperLeft
A System.Drawing.PointF which represents the upper-left coordinate for the bounding rectangle.
lowerRight
A System.Drawing.PointF which represents the lower-right coordinate for the bounding rectangle.
startAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.
color
A System.Drawing.Color of the circle’s outline.

Glossary Item Box

Draws an arc on a printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Arc( _
   ByVal upperLeft As Point, _
   ByVal lowerRight As Point, _
   ByVal startAngle As Single, _
   ByVal endAngle As Single, _
   ByVal color As Color _
)
'Usage

Dim instance As Draw
Dim upperLeft As Point
Dim lowerRight As Point
Dim startAngle As Single
Dim endAngle As Single
Dim color As Color

instance.Arc(upperLeft, lowerRight, startAngle, endAngle, color)
public void Arc(
   Point upperLeft,
   Point lowerRight,
   float startAngle,
   float endAngle,
   Color color
)
public: void Arc(
   Point upperLeft,
   Point lowerRight,
   float startAngle,
   float endAngle,
   Color color
)
public:
void Arc(
   Point upperLeft,
   Point lowerRight,
   float startAngle,
   float endAngle,
   Color color
)

Parameters

upperLeft
A System.Drawing.PointF which represents the upper-left coordinate for the bounding rectangle.
lowerRight
A System.Drawing.PointF which represents the lower-right coordinate for the bounding rectangle.
startAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.
color
A System.Drawing.Color of the circle’s outline.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Arc(Rectangle,Single,Single,Color) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Arc Method : Arc(Rectangle,Single,Single,Color) Method

boundingBox
The bounding System.Drawing.Rectangle that specifies the size of the arc.
startAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.
color
The System.Drawing.Color to draw the arc.

Glossary Item Box

Draws a black arc on a printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Arc( _
   ByVal boundingBox As Rectangle, _
   ByVal startAngle As Single, _
   ByVal endAngle As Single, _
   ByVal color As Color _
)
'Usage

Dim instance As Draw
Dim boundingBox As Rectangle
Dim startAngle As Single
Dim endAngle As Single
Dim color As Color

instance.Arc(boundingBox, startAngle, endAngle, color)
public void Arc(
   Rectangle boundingBox,
   float startAngle,
   float endAngle,
   Color color
)
public: void Arc(
   Rectangle boundingBox,
   float startAngle,
   float endAngle,
   Color color
)
public:
void Arc(
   Rectangle boundingBox,
   float startAngle,
   float endAngle,
   Color color
)

Parameters

boundingBox
The bounding System.Drawing.Rectangle that specifies the size of the arc.
startAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.
color
The System.Drawing.Color to draw the arc.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Arc(Point,Single,Single,Color) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Arc Method : Arc(Point,Single,Single,Color) Method

endPoint
A System.Drawing.Point which represents the end coordinate for the bounding rectangle.
startAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.
color
A System.Drawing.Color of the circle’s outline.

Glossary Item Box

Draws an arc on a printer from the current Draw location.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Arc( _
   ByVal endPoint As Point, _
   ByVal startAngle As Single, _
   ByVal endAngle As Single, _
   ByVal color As Color _
)
'Usage

Dim instance As Draw
Dim endPoint As Point
Dim startAngle As Single
Dim endAngle As Single
Dim color As Color

instance.Arc(endPoint, startAngle, endAngle, color)
public void Arc(
   Point endPoint,
   float startAngle,
   float endAngle,
   Color color
)
public: void Arc(
   Point endPoint,
   float startAngle,
   float endAngle,
   Color color
)
public:
void Arc(
   Point endPoint,
   float startAngle,
   float endAngle,
   Color color
)

Parameters

endPoint
A System.Drawing.Point which represents the end coordinate for the bounding rectangle.
startAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.
color
A System.Drawing.Color of the circle’s outline.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Arc(Point,Point,Single,Single) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Arc Method : Arc(Point,Point,Single,Single) Method

upperLeft
A System.Drawing.Point which represents the upper-left coordinate for the bounding rectangle.
lowerRight
A System.Drawing.Point which represents the lower-right coordinate for the bounding rectangle.
startAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.

Glossary Item Box

Draws a black arc on a printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Arc( _
   ByVal upperLeft As Point, _
   ByVal lowerRight As Point, _
   ByVal startAngle As Single, _
   ByVal endAngle As Single _
)
'Usage

Dim instance As Draw
Dim upperLeft As Point
Dim lowerRight As Point
Dim startAngle As Single
Dim endAngle As Single

instance.Arc(upperLeft, lowerRight, startAngle, endAngle)
public void Arc(
   Point upperLeft,
   Point lowerRight,
   float startAngle,
   float endAngle
)
public: void Arc(
   Point upperLeft,
   Point lowerRight,
   float startAngle,
   float endAngle
)
public:
void Arc(
   Point upperLeft,
   Point lowerRight,
   float startAngle,
   float endAngle
)

Parameters

upperLeft
A System.Drawing.Point which represents the upper-left coordinate for the bounding rectangle.
lowerRight
A System.Drawing.Point which represents the lower-right coordinate for the bounding rectangle.
startAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Arc(Rectangle,Single,Single) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Arc Method : Arc(Rectangle,Single,Single) Method

boundingBox
The bounding System.Drawing.Rectangle that specifies the size of the arc
startAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.

Glossary Item Box

Draws a black arc on a printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Arc( _
   ByVal boundingBox As Rectangle, _
   ByVal startAngle As Single, _
   ByVal endAngle As Single _
)
'Usage

Dim instance As Draw
Dim boundingBox As Rectangle
Dim startAngle As Single
Dim endAngle As Single

instance.Arc(boundingBox, startAngle, endAngle)
public void Arc(
   Rectangle boundingBox,
   float startAngle,
   float endAngle
)
public: void Arc(
   Rectangle boundingBox,
   float startAngle,
   float endAngle
)
public:
void Arc(
   Rectangle boundingBox,
   float startAngle,
   float endAngle
)

Parameters

boundingBox
The bounding System.Drawing.Rectangle that specifies the size of the arc
startAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Arc(Point,Single,Single) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Arc Method : Arc(Point,Single,Single) Method

endPoint
A System.Drawing.Point which represents the end coordinate for the bounding rectangle.
startAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.

Glossary Item Box

Draws a black arc on a printer from the current draw location.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Arc( _
   ByVal endPoint As Point, _
   ByVal startAngle As Single, _
   ByVal endAngle As Single _
)
'Usage

Dim instance As Draw
Dim endPoint As Point
Dim startAngle As Single
Dim endAngle As Single

instance.Arc(endPoint, startAngle, endAngle)
public void Arc(
   Point endPoint,
   float startAngle,
   float endAngle
)
public: void Arc(
   Point endPoint,
   float startAngle,
   float endAngle
)
public:
void Arc(
   Point endPoint,
   float startAngle,
   float endAngle
)

Parameters

endPoint
A System.Drawing.Point which represents the end coordinate for the bounding rectangle.
startAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Circle Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class : Circle Method

Glossary Item Box

Draws a circle or ellipse on a printer.

Overload List

Overload | Description
Circle(Point,Int32,Color,Single) | Draws a circle or ellipse on a printer.
Circle(Int32,Color,Single) | Draws a circle or ellipse on a printer at the current draw location.
Circle(Point,Int32,Single) | Draws a black circle or ellipse on a printer.
Circle(Int32,Single) | Draws a black circle or ellipse on a printer at the current draw location.
Circle(PointF,Single,Color,Single) | Draws a circle or ellipse on a printer.
Circle(Single,Color,Single) | Draws a circle or ellipse on a printer at the current draw location.
Circle(PointF,Single,Single) | Draws a black circle or ellipse on a printer.
Circle(Single,Single) | Draws a black circle or ellipse on a printer at the current draw location.

See Also

Reference

Draw Class
Draw Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Circle(Point,Int32,Color,Single) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Circle Method : Circle(Point,Int32,Color,Single) Method

location
The System.Drawing.Point coordinate for the center point of the circle or ellipse.
radius
An integer value which represents the radius of the circle or ellipse.
color
The System.Drawing.Color of the circle’s outline.
aspectRatio
A single value which represents the aspect ratio of the circle. The value 1.0 yields a perfect (non-elliptical) circle on any screen. A negative aspect ratio will yield a perfect circle.

Glossary Item Box

Draws a circle or ellipse on a printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Circle( _
   ByVal location As Point, _
   ByVal radius As Integer, _
   ByVal color As Color, _
   ByVal aspectRatio As Single _
)
'Usage

Dim instance As Draw
Dim location As Point
Dim radius As Integer
Dim color As Color
Dim aspectRatio As Single

instance.Circle(location, radius, color, aspectRatio)
public void Circle(
   Point location,
   int radius,
   Color color,
   float aspectRatio
)
public: void Circle(
   Point location,
   int radius,
   Color color,
   float aspectRatio
)
public:
void Circle(
   Point location,
   int radius,
   Color color,
   float aspectRatio
)

Parameters

location
The System.Drawing.Point coordinate for the center point of the circle or ellipse.
radius
An integer value which represents the radius of the circle or ellipse.
color
The System.Drawing.Color of the circle’s outline.
aspectRatio
A single value which represents the aspect ratio of the circle. The value 1.0 yields a perfect (non-elliptical) circle on any screen. A negative aspect ratio will yield a perfect circle.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Circle(Int32,Color,Single) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Circle Method : Circle(Int32,Color,Single) Method

radius
An integer value which represents the radius of the circle or ellipse.
color
The System.Drawing.Color of the circle’s outline.
aspectRatio
A single value which represents the aspect ratio of the circle. The value 1.0 yields a perfect (non-elliptical) circle on any screen. A negative aspect ratio will yield a perfect circle.

Glossary Item Box

Draws a circle or ellipse on a printer at the current draw location.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Circle( _
   ByVal radius As Integer, _
   ByVal color As Color, _
   ByVal aspectRatio As Single _
)
'Usage

Dim instance As Draw
Dim radius As Integer
Dim color As Color
Dim aspectRatio As Single

instance.Circle(radius, color, aspectRatio)
public void Circle(
   int radius,
   Color color,
   float aspectRatio
)
public: void Circle(
   int radius,
   Color color,
   float aspectRatio
)
public:
void Circle(
   int radius,
   Color color,
   float aspectRatio
)

Parameters

radius
An integer value which represents the radius of the circle or ellipse.
color
The System.Drawing.Color of the circle’s outline.
aspectRatio
A single value which represents the aspect ratio of the circle. The value 1.0 yields a perfect (non-elliptical) circle on any screen. A negative aspect ratio will yield a perfect circle.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Circle(Point,Int32,Single) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Circle Method : Circle(Point,Int32,Single) Method

location
The System.Drawing.Point coordinate for the center point of the circle or ellipse.
radius
An integer value which represents the radius of the circle or ellipse.
aspectRatio
A single value which represents the aspect ratio of the circle. The value 1.0 yields a perfect (non-elliptical) circle on any screen. A negative aspect ratio will yield a perfect circle.

Glossary Item Box

Draws a black circle or ellipse on a printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Circle( _
   ByVal location As Point, _
   ByVal radius As Integer, _
   ByVal aspectRatio As Single _
)
'Usage

Dim instance As Draw
Dim location As Point
Dim radius As Integer
Dim aspectRatio As Single

instance.Circle(location, radius, aspectRatio)
public void Circle(
   Point location,
   int radius,
   float aspectRatio
)
public: void Circle(
   Point location,
   int radius,
   float aspectRatio
)
public:
void Circle(
   Point location,
   int radius,
   float aspectRatio
)

Parameters

location
The System.Drawing.Point coordinate for the center point of the circle or ellipse.
radius
An integer value which represents the radius of the circle or ellipse.
aspectRatio
A single value which represents the aspect ratio of the circle. The value 1.0 yields a perfect (non-elliptical) circle on any screen. A negative aspect ratio will yield a perfect circle.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Circle(Int32,Single) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Circle Method : Circle(Int32,Single) Method

radius
An integer value which represents the radius of the circle or ellipse.
aspectRatio
A single value which represents the aspect ratio of the circle. The value 1.0 yields a perfect (non-elliptical) circle on any screen. A negative aspect ratio will yield a perfect circle.

Glossary Item Box

Draws a black circle or ellipse on a printer at the current draw location.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Circle( _
   ByVal radius As Integer, _
   ByVal aspectRatio As Single _
)
'Usage

Dim instance As Draw
Dim radius As Integer
Dim aspectRatio As Single

instance.Circle(radius, aspectRatio)
public void Circle(
   int radius,
   float aspectRatio
)
public: void Circle(
   int radius,
   float aspectRatio
)
public:
void Circle(
   int radius,
   float aspectRatio
)

Parameters

radius
An integer value which represents the radius of the circle or ellipse.
aspectRatio
A single value which represents the aspect ratio of the circle. The value 1.0 yields a perfect (non-elliptical) circle on any screen. A negative aspect ratio will yield a perfect circle.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Circle(PointF,Single,Color,Single) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Circle Method : Circle(PointF,Single,Color,Single) Method

location
The System.Drawing.PointF coordinate for the center point of the circle or ellipse.
radius
A single value which represents the radius of the circle or ellipse.
color
The System.Drawing.Color of the circle’s outline.
aspectRatio
A single value which represents the aspect ratio of the circle. The value 1.0 yields a perfect (non-elliptical) circle on any screen. A negative aspect ratio will yield a perfect circle.

Glossary Item Box

Draws a circle or ellipse on a printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Circle( _
   ByVal location As PointF, _
   ByVal radius As Single, _
   ByVal color As Color, _
   ByVal aspectRatio As Single _
)
'Usage

Dim instance As Draw
Dim location As PointF
Dim radius As Single
Dim color As Color
Dim aspectRatio As Single

instance.Circle(location, radius, color, aspectRatio)
public void Circle(
   PointF location,
   float radius,
   Color color,
   float aspectRatio
)
public: void Circle(
   PointF location,
   float radius,
   Color color,
   float aspectRatio
)
public:
void Circle(
   PointF location,
   float radius,
   Color color,
   float aspectRatio
)

Parameters

location
The System.Drawing.PointF coordinate for the center point of the circle or ellipse.
radius
A single value which represents the radius of the circle or ellipse.
color
The System.Drawing.Color of the circle’s outline.
aspectRatio
A single value which represents the aspect ratio of the circle. The value 1.0 yields a perfect (non-elliptical) circle on any screen. A negative aspect ratio will yield a perfect circle.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Circle(Single,Color,Single) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Circle Method : Circle(Single,Color,Single) Method

radius
A single value which represents the radius of the circle or ellipse.
color
The System.Drawing.Color of the circle’s outline.
aspectRatio
A single value which represents the aspect ratio of the circle. The value 1.0 yields a perfect (non-elliptical) circle on any screen. A negative aspect ratio will yield a perfect circle.

Glossary Item Box

Draws a circle or ellipse on a printer at the current draw location.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Circle( _
   ByVal radius As Single, _
   ByVal color As Color, _
   ByVal aspectRatio As Single _
)
'Usage

Dim instance As Draw
Dim radius As Single
Dim color As Color
Dim aspectRatio As Single

instance.Circle(radius, color, aspectRatio)
public void Circle(
   float radius,
   Color color,
   float aspectRatio
)
public: void Circle(
   float radius,
   Color color,
   float aspectRatio
)
public:
void Circle(
   float radius,
   Color color,
   float aspectRatio
)

Parameters

radius
A single value which represents the radius of the circle or ellipse.
color
The System.Drawing.Color of the circle’s outline.
aspectRatio
A single value which represents the aspect ratio of the circle. The value 1.0 yields a perfect (non-elliptical) circle on any screen. A negative aspect ratio will yield a perfect circle.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Circle(PointF,Single,Single) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Circle Method : Circle(PointF,Single,Single) Method

location
The System.Drawing.PointF coordinate for the center point of the circle or ellipse.
radius
A single value which represents the radius of the circle or ellipse.
aspectRatio
A single value which represents the aspect ratio of the circle. The value 1.0 yields a perfect (non-elliptical) circle on any screen. A negative aspect ratio will yield a perfect circle.

Glossary Item Box

Draws a black circle or ellipse on a printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Circle( _
   ByVal location As PointF, _
   ByVal radius As Single, _
   ByVal aspectRatio As Single _
)
'Usage

Dim instance As Draw
Dim location As PointF
Dim radius As Single
Dim aspectRatio As Single

instance.Circle(location, radius, aspectRatio)
public void Circle(
   PointF location,
   float radius,
   float aspectRatio
)
public: void Circle(
   PointF location,
   float radius,
   float aspectRatio
)
public:
void Circle(
   PointF location,
   float radius,
   float aspectRatio
)

Parameters

location
The System.Drawing.PointF coordinate for the center point of the circle or ellipse.
radius
A single value which represents the radius of the circle or ellipse.
aspectRatio
A single value which represents the aspect ratio of the circle. The value 1.0 yields a perfect (non-elliptical) circle on any screen. A negative aspect ratio will yield a perfect circle.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Circle(Single,Single) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Circle Method : Circle(Single,Single) Method

radius
A single value which represents the radius of the circle or ellipse.
aspectRatio
A single value which represents the aspect ratio of the circle. The value 1.0 yields a perfect (non-elliptical) circle on any screen. A negative aspect ratio will yield a perfect circle.

Glossary Item Box

Draws a black circle or ellipse on a printer at the current draw location.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Circle( _
   ByVal radius As Single, _
   ByVal aspectRatio As Single _
)
'Usage

Dim instance As Draw
Dim radius As Single
Dim aspectRatio As Single

instance.Circle(radius, aspectRatio)
public void Circle(
   float radius,
   float aspectRatio
)
public: void Circle(
   float radius,
   float aspectRatio
)
public:
void Circle(
   float radius,
   float aspectRatio
)

Parameters

radius
A single value which represents the radius of the circle or ellipse.
aspectRatio
A single value which represents the aspect ratio of the circle. The value 1.0 yields a perfect (non-elliptical) circle on any screen. A negative aspect ratio will yield a perfect circle.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Curve Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class : Curve Method

Glossary Item Box

Draws a cubic bezier curve on a printer.

Overload List

Overload | Description
Curve(PointF,PointF,PointF,PointF,Color) | Draws a cubic bezier curve on a printer.
Curve(PointF,PointF,PointF,PointF) | Draws a black cubic bezier curve on a printer.
Curve(Point,Point,Point,Point,Color) | Draws a cubic bezier curve on a printer.
Curve(Point,Point,Point,Point) | Draws a cubic bezier curve on a printer.

See Also

Reference

Draw Class
Draw Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Curve(PointF,PointF,PointF,PointF,Color) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Curve Method : Curve(PointF,PointF,PointF,PointF,Color) Method

startPoint
A System.Drawing.PointF which represents the starting point of the bezier curve.
controlPoint1
A System.Drawing.PointF which represents the first control point of the bezier curve.
controlPoint2
A System.Drawing.PointF which represents the second control point of the bezier curve.
endPoint
A System.Drawing.PointF which represents the end point of the bezier curve.
color
The System.Drawing.Color of the curve.

Glossary Item Box

Draws a cubic bezier curve on a printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Curve( _
   ByVal startPoint As PointF, _
   ByVal controlPoint1 As PointF, _
   ByVal controlPoint2 As PointF, _
   ByVal endPoint As PointF, _
   ByVal color As Color _
)
'Usage

Dim instance As Draw
Dim startPoint As PointF
Dim controlPoint1 As PointF
Dim controlPoint2 As PointF
Dim endPoint As PointF
Dim color As Color

instance.Curve(startPoint, controlPoint1, controlPoint2, endPoint, color)
public void Curve(
   PointF startPoint,
   PointF controlPoint1,
   PointF controlPoint2,
   PointF endPoint,
   Color color
)
public: void Curve(
   PointF startPoint,
   PointF controlPoint1,
   PointF controlPoint2,
   PointF endPoint,
   Color color
)
public:
void Curve(
   PointF startPoint,
   PointF controlPoint1,
   PointF controlPoint2,
   PointF endPoint,
   Color color
)

Parameters

startPoint
A System.Drawing.PointF which represents the starting point of the bezier curve.
controlPoint1
A System.Drawing.PointF which represents the first control point of the bezier curve.
controlPoint2
A System.Drawing.PointF which represents the second control point of the bezier curve.
endPoint
A System.Drawing.PointF which represents the end point of the bezier curve.
color
The System.Drawing.Color of the curve.

Remarks

The curve starts at StartPoint going toward ControlPoint1 and arrives at EndPoint coming from the direction of ControlPoint2. Usually, it will not pass through ControlPoint1 or ControlPoint2; these points are only there to provide directional information. The distance between StartPoint and ControlPoint1 determines "how long" the curve moves into direction ControlPoint2 before turning towards EndPoint.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Curve(PointF,PointF,PointF,PointF) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Curve Method : Curve(PointF,PointF,PointF,PointF) Method

startPoint
A System.Drawing.PointF which represents the starting point of the bezier curve.
controlPoint1
A System.Drawing.PointF which represents the first control point of the bezier curve.
controlPoint2
A System.Drawing.PointF which represents the second control point of the bezier curve.
endPoint
A System.Drawing.PointF which represents the end point of the bezier curve.

Glossary Item Box

Draws a black cubic bezier curve on a printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Curve( _
   ByVal startPoint As PointF, _
   ByVal controlPoint1 As PointF, _
   ByVal controlPoint2 As PointF, _
   ByVal endPoint As PointF _
)
'Usage

Dim instance As Draw
Dim startPoint As PointF
Dim controlPoint1 As PointF
Dim controlPoint2 As PointF
Dim endPoint As PointF

instance.Curve(startPoint, controlPoint1, controlPoint2, endPoint)
public void Curve(
   PointF startPoint,
   PointF controlPoint1,
   PointF controlPoint2,
   PointF endPoint
)
public: void Curve(
   PointF startPoint,
   PointF controlPoint1,
   PointF controlPoint2,
   PointF endPoint
)
public:
void Curve(
   PointF startPoint,
   PointF controlPoint1,
   PointF controlPoint2,
   PointF endPoint
)

Parameters

startPoint
A System.Drawing.PointF which represents the starting point of the bezier curve.
controlPoint1
A System.Drawing.PointF which represents the first control point of the bezier curve.
controlPoint2
A System.Drawing.PointF which represents the second control point of the bezier curve.
endPoint
A System.Drawing.PointF which represents the end point of the bezier curve.

Remarks

The curve starts at the StartPoint going toward ControlPoint1 and arrives at EndPoint coming from the direction of ControlPoint2. Usually, it will not pass through ControlPoint1 or ControlPoint2; these points are only there to provide directional information. The distance between StartPoint and ControlPoint1 determines "how long" the curve moves into direction ControlPoint2 before turning towards EndPoint.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Curve(Point,Point,Point,Point,Color) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Curve Method : Curve(Point,Point,Point,Point,Color) Method

startPoint
A System.Drawing.Point which represents the starting point of the bezier curve.
controlPoint1
A System.Drawing.Point which represents the first control point of the bezier curve.
controlPoint2
A System.Drawing.Point which represents the second control point of the bezier curve.
endPoint
A System.Drawing.Point which represents the end point of the bezier curve.
color
The System.Drawing.Color of the curve.

Glossary Item Box

Draws a cubic bezier curve on a printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Curve( _
   ByVal startPoint As Point, _
   ByVal controlPoint1 As Point, _
   ByVal controlPoint2 As Point, _
   ByVal endPoint As Point, _
   ByVal color As Color _
)
'Usage

Dim instance As Draw
Dim startPoint As Point
Dim controlPoint1 As Point
Dim controlPoint2 As Point
Dim endPoint As Point
Dim color As Color

instance.Curve(startPoint, controlPoint1, controlPoint2, endPoint, color)
public void Curve(
   Point startPoint,
   Point controlPoint1,
   Point controlPoint2,
   Point endPoint,
   Color color
)
public: void Curve(
   Point startPoint,
   Point controlPoint1,
   Point controlPoint2,
   Point endPoint,
   Color color
)
public:
void Curve(
   Point startPoint,
   Point controlPoint1,
   Point controlPoint2,
   Point endPoint,
   Color color
)

Parameters

startPoint
A System.Drawing.Point which represents the starting point of the bezier curve.
controlPoint1
A System.Drawing.Point which represents the first control point of the bezier curve.
controlPoint2
A System.Drawing.Point which represents the second control point of the bezier curve.
endPoint
A System.Drawing.Point which represents the end point of the bezier curve.
color
The System.Drawing.Color of the curve.

Remarks

The curve starts at StartPoint going toward ControlPoint1 and arrives at EndPoint coming from the direction of ControlPoint2. Usually, it will not pass through ControlPoint1 or ControlPoint2; these points are only there to provide directional information. The distance between StartPoint and ControlPoint1 determines "how long" the curve moves into direction ControlPoint2 before turning towards EndPoint.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Curve(Point,Point,Point,Point) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Curve Method : Curve(Point,Point,Point,Point) Method

startPoint
A System.Drawing.Point which represents the starting point of the bezier curve.
controlPoint1
A System.Drawing.Point which represents the first control point of the bezier curve.
controlPoint2
A System.Drawing.Point which represents the second control point of the bezier curve.
endPoint
A System.Drawing.Point which represents the end point of the bezier curve.

Glossary Item Box

Draws a cubic bezier curve on a printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Curve( _
   ByVal startPoint As Point, _
   ByVal controlPoint1 As Point, _
   ByVal controlPoint2 As Point, _
   ByVal endPoint As Point _
)
'Usage

Dim instance As Draw
Dim startPoint As Point
Dim controlPoint1 As Point
Dim controlPoint2 As Point
Dim endPoint As Point

instance.Curve(startPoint, controlPoint1, controlPoint2, endPoint)
public void Curve(
   Point startPoint,
   Point controlPoint1,
   Point controlPoint2,
   Point endPoint
)
public: void Curve(
   Point startPoint,
   Point controlPoint1,
   Point controlPoint2,
   Point endPoint
)
public:
void Curve(
   Point startPoint,
   Point controlPoint1,
   Point controlPoint2,
   Point endPoint
)

Parameters

startPoint
A System.Drawing.Point which represents the starting point of the bezier curve.
controlPoint1
A System.Drawing.Point which represents the first control point of the bezier curve.
controlPoint2
A System.Drawing.Point which represents the second control point of the bezier curve.
endPoint
A System.Drawing.Point which represents the end point of the bezier curve.

Remarks

The curve starts at StartPoint going toward ControlPoint1 and arrives at EndPoint coming from the direction of ControlPoint2. Usually, it will not pass through ControlPoint1 or ControlPoint2; these points are only there to provide directional information. The distance between StartPoint and ControlPoint1 determines "how long" the curve moves into direction ControlPoint2 before turning towards EndPoint.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Line Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class : Line Method

Glossary Item Box

Draws a line or rectangle on a printer.

Overload List

Overload | Description
Line(PointF,PointF,Color,Boolean,Boolean) | Draws a line or rectangle on a printer.
Line(PointF,PointF,Color) | Draws a line on a printer.
Line(PointF,PointF,Boolean,Boolean) | Draws a black line or rectangle on a printer.
Line(PointF,PointF) | Draws a black line.
Line(PointF,Color,Boolean,Boolean) | Draws a line or rectangle on a printer starting from the current draw location.
Line(PointF,Color) | Draws a line on a printer starting at the current draw location.
Line(PointF,Boolean,Boolean) | Draws a black line or rectangle on a printer starting at the current draw location.
Line(PointF) | Draws a black line starting at the current draw location.
Line(Point,Point,Color,Boolean,Boolean) | Draws a line or rectangle on a printer
Line(Point,Point,Color) | Draws a line on a printer
Line(Point,Point,Boolean,Boolean) | Draws a black line or rectangle on a printer
Line(Point,Point) | Draws a black line
Line(Point,Color,Boolean,Boolean) | Draws a line or rectangle on a printer starting from the current draw location
Line(Point,Color) | Draws a line on a printer starting at the current draw location.
Line(Point,Boolean,Boolean) | Draws a black line or rectangle on a printer starting at the current draw location.
Line(Point) | Draws a black line starting at the current draw location.

See Also

Reference

Draw Class
Draw Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Line(PointF,PointF,Color,Boolean,Boolean) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Line Method : Line(PointF,PointF,Color,Boolean,Boolean) Method

startPoint
A System.Drawing.PointF which represents the coordinate of the starting point for the line or rectangle.
endPoint
A System.Drawing.PointF which represents the coordinate of the end point for the line or rectangle being drawn.
color
The System.Drawing.Color used to draw the line or box.
box
A boolean value that if true, causes a box to be drawn using the coordinates to specify opposite corners of the box.
fill
A boolean value that if true and the box option is used, specifies that the box is filled with the same color used to draw the box. You cannot use fill without box. If box is used without fill, the box is filled with the current FillColor and FillStyle.

Glossary Item Box

Draws a line or rectangle on a printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Line( _
   ByVal startPoint As PointF, _
   ByVal endPoint As PointF, _
   ByVal color As Color, _
   ByVal box As Boolean, _
   ByVal fill As Boolean _
)
'Usage

Dim instance As Draw
Dim startPoint As PointF
Dim endPoint As PointF
Dim color As Color
Dim box As Boolean
Dim fill As Boolean

instance.Line(startPoint, endPoint, color, box, fill)
public void Line(
   PointF startPoint,
   PointF endPoint,
   Color color,
   bool box,
   bool fill
)
public: void Line(
   PointF startPoint,
   PointF endPoint,
   Color color,
   bool box,
   bool fill
)
public:
void Line(
   PointF startPoint,
   PointF endPoint,
   Color color,
   bool box,
   bool fill
)

Parameters

startPoint
A System.Drawing.PointF which represents the coordinate of the starting point for the line or rectangle.
endPoint
A System.Drawing.PointF which represents the coordinate of the end point for the line or rectangle being drawn.
color
The System.Drawing.Color used to draw the line or box.
box
A boolean value that if true, causes a box to be drawn using the coordinates to specify opposite corners of the box.
fill
A boolean value that if true and the box option is used, specifies that the box is filled with the same color used to draw the box. You cannot use fill without box. If box is used without fill, the box is filled with the current FillColor and FillStyle.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Line(PointF,PointF,Color) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Line Method : Line(PointF,PointF,Color) Method

startPoint
A System.Drawing.PointF which represents the coordinate of the starting point for the line.
endPoint
A System.Drawing.PointF which represents the coordinate of the end point for the line being drawn.
color
The System.Drawing.Color used to draw the line.

Glossary Item Box

Draws a line on a printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Line( _
   ByVal startPoint As PointF, _
   ByVal endPoint As PointF, _
   ByVal color As Color _
)
'Usage

Dim instance As Draw
Dim startPoint As PointF
Dim endPoint As PointF
Dim color As Color

instance.Line(startPoint, endPoint, color)
public void Line(
   PointF startPoint,
   PointF endPoint,
   Color color
)
public: void Line(
   PointF startPoint,
   PointF endPoint,
   Color color
)
public:
void Line(
   PointF startPoint,
   PointF endPoint,
   Color color
)

Parameters

startPoint
A System.Drawing.PointF which represents the coordinate of the starting point for the line.
endPoint
A System.Drawing.PointF which represents the coordinate of the end point for the line being drawn.
color
The System.Drawing.Color used to draw the line.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Line(PointF,PointF,Boolean,Boolean) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Line Method : Line(PointF,PointF,Boolean,Boolean) Method

startPoint
A System.Drawing.PointF which represents the coordinate of the starting point for the line or rectangle.
endPoint
A System.Drawing.PointF which represents the coordinate of the end point for the line or rectangle being drawn.
box
A boolean value that if true, causes a box to be drawn using the coordinates to specify opposite corners of the box.
fill
A boolean value that if true and the box option is used, specifies that the box is filled with the same color used to draw the box. You cannot use fill without box. If box is used without fill, the box is filled with the current FillColor and FillStyle.

Glossary Item Box

Draws a black line or rectangle on a printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Line( _
   ByVal startPoint As PointF, _
   ByVal endPoint As PointF, _
   ByVal box As Boolean, _
   ByVal fill As Boolean _
)
'Usage

Dim instance As Draw
Dim startPoint As PointF
Dim endPoint As PointF
Dim box As Boolean
Dim fill As Boolean

instance.Line(startPoint, endPoint, box, fill)
public void Line(
   PointF startPoint,
   PointF endPoint,
   bool box,
   bool fill
)
public: void Line(
   PointF startPoint,
   PointF endPoint,
   bool box,
   bool fill
)
public:
void Line(
   PointF startPoint,
   PointF endPoint,
   bool box,
   bool fill
)

Parameters

startPoint
A System.Drawing.PointF which represents the coordinate of the starting point for the line or rectangle.
endPoint
A System.Drawing.PointF which represents the coordinate of the end point for the line or rectangle being drawn.
box
A boolean value that if true, causes a box to be drawn using the coordinates to specify opposite corners of the box.
fill
A boolean value that if true and the box option is used, specifies that the box is filled with the same color used to draw the box. You cannot use fill without box. If box is used without fill, the box is filled with the current FillColor and FillStyle.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Line(PointF,PointF) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Line Method : Line(PointF,PointF) Method

startPoint
A System.Drawing.PointF which represents the coordinate of the starting point for the line.
endPoint
A System.Drawing.PointF which represents the coordinate of the end point for the line being drawn.

Glossary Item Box

Draws a black line.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Line( _
   ByVal startPoint As PointF, _
   ByVal endPoint As PointF _
)
'Usage

Dim instance As Draw
Dim startPoint As PointF
Dim endPoint As PointF

instance.Line(startPoint, endPoint)
public void Line(
   PointF startPoint,
   PointF endPoint
)
public: void Line(
   PointF startPoint,
   PointF endPoint
)
public:
void Line(
   PointF startPoint,
   PointF endPoint
)

Parameters

startPoint
A System.Drawing.PointF which represents the coordinate of the starting point for the line.
endPoint
A System.Drawing.PointF which represents the coordinate of the end point for the line being drawn.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Line(PointF,Color,Boolean,Boolean) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Line Method : Line(PointF,Color,Boolean,Boolean) Method

endPoint
A System.Drawing.PointF which represents the coordinate of the end point for the line or rectangle being drawn.
color
A System.Drawing.Color which is used to draw the line or box.
box
A boolean value that if true, causes a box to be drawn using the coordinates to specify opposite corners of the box.
fill
A boolean value that if true, and the box option is used, specifies that the box is filled with the same color used to draw the box. You cannot use fill without box. If box is used without fill, the box is filled with the current FillColor and FillStyle.

Glossary Item Box

Draws a line or rectangle on a printer starting from the current draw location.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Line( _
   ByVal endPoint As PointF, _
   ByVal color As Color, _
   ByVal box As Boolean, _
   ByVal fill As Boolean _
)
'Usage

Dim instance As Draw
Dim endPoint As PointF
Dim color As Color
Dim box As Boolean
Dim fill As Boolean

instance.Line(endPoint, color, box, fill)
public void Line(
   PointF endPoint,
   Color color,
   bool box,
   bool fill
)
public: void Line(
   PointF endPoint,
   Color color,
   bool box,
   bool fill
)
public:
void Line(
   PointF endPoint,
   Color color,
   bool box,
   bool fill
)

Parameters

endPoint
A System.Drawing.PointF which represents the coordinate of the end point for the line or rectangle being drawn.
color
A System.Drawing.Color which is used to draw the line or box.
box
A boolean value that if true, causes a box to be drawn using the coordinates to specify opposite corners of the box.
fill
A boolean value that if true, and the box option is used, specifies that the box is filled with the same color used to draw the box. You cannot use fill without box. If box is used without fill, the box is filled with the current FillColor and FillStyle.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Line(PointF,Color) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Line Method : Line(PointF,Color) Method

endPoint
A System.Drawing.PointF which represents the coordinate of the end point for the line being drawn.
color
The System.Drawing.Color used to draw the line.

Glossary Item Box

Draws a line on a printer starting at the current draw location.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Line( _
   ByVal endPoint As PointF, _
   ByVal color As Color _
)
'Usage

Dim instance As Draw
Dim endPoint As PointF
Dim color As Color

instance.Line(endPoint, color)
public void Line(
   PointF endPoint,
   Color color
)
public: void Line(
   PointF endPoint,
   Color color
)
public:
void Line(
   PointF endPoint,
   Color color
)

Parameters

endPoint
A System.Drawing.PointF which represents the coordinate of the end point for the line being drawn.
color
The System.Drawing.Color used to draw the line.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Line(PointF,Boolean,Boolean) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Line Method : Line(PointF,Boolean,Boolean) Method

endPoint
A System.Drawing.PointF which represents the coordinate of the end point for the line or rectangle being drawn.
box
A boolean value that if true, causes a box to be drawn using the coordinates to specify opposite corners of the box.
fill
A boolean value that if true, and the box option is used, specifies that the box is filled with the same color used to draw the box. You cannot use fill without box. If box is used without fill, the box is filled with the current FillColor and FillStyle.

Glossary Item Box

Draws a black line or rectangle on a printer starting at the current draw location.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Line( _
   ByVal endPoint As PointF, _
   ByVal box As Boolean, _
   ByVal fill As Boolean _
)
'Usage

Dim instance As Draw
Dim endPoint As PointF
Dim box As Boolean
Dim fill As Boolean

instance.Line(endPoint, box, fill)
public void Line(
   PointF endPoint,
   bool box,
   bool fill
)
public: void Line(
   PointF endPoint,
   bool box,
   bool fill
)
public:
void Line(
   PointF endPoint,
   bool box,
   bool fill
)

Parameters

endPoint
A System.Drawing.PointF which represents the coordinate of the end point for the line or rectangle being drawn.
box
A boolean value that if true, causes a box to be drawn using the coordinates to specify opposite corners of the box.
fill
A boolean value that if true, and the box option is used, specifies that the box is filled with the same color used to draw the box. You cannot use fill without box. If box is used without fill, the box is filled with the current FillColor and FillStyle.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Line(PointF) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Line Method : Line(PointF) Method

endPoint
A System.Drawing.Color which represents the coordinate of the end point for the line being drawn.

Glossary Item Box

Draws a black line starting at the current draw location.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Line( _
   ByVal endPoint As PointF _
)
'Usage

Dim instance As Draw
Dim endPoint As PointF

instance.Line(endPoint)
public void Line(
   PointF endPoint
)
public: void Line(
   PointF endPoint
)
public:
void Line(
   PointF endPoint
)

Parameters

endPoint
A System.Drawing.Color which represents the coordinate of the end point for the line being drawn.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Line(Point,Point,Color,Boolean,Boolean) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Line Method : Line(Point,Point,Color,Boolean,Boolean) Method

startPoint
The coordinate of the starting point for the line or rectangle.
endPoint
The coordinate of the end point for the line or rectangle being drawn.
color
The color used to draw the line or box
box
A boolean value that if True, causes a box to be drawn using the coordinates to specify opposite corners of the box.
fill
A boolean value that if True and the box option is used, specifies that the box is filled with the same color used to draw the box. You cannot use fill without box. If box is used without fill, the box is filled with the current FillColor and FillStyle.

Glossary Item Box

Draws a line or rectangle on a printer

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Line( _
   ByVal startPoint As Point, _
   ByVal endPoint As Point, _
   ByVal color As Color, _
   ByVal box As Boolean, _
   ByVal fill As Boolean _
)
'Usage

Dim instance As Draw
Dim startPoint As Point
Dim endPoint As Point
Dim color As Color
Dim box As Boolean
Dim fill As Boolean

instance.Line(startPoint, endPoint, color, box, fill)
public void Line(
   Point startPoint,
   Point endPoint,
   Color color,
   bool box,
   bool fill
)
public: void Line(
   Point startPoint,
   Point endPoint,
   Color color,
   bool box,
   bool fill
)
public:
void Line(
   Point startPoint,
   Point endPoint,
   Color color,
   bool box,
   bool fill
)

Parameters

startPoint
The coordinate of the starting point for the line or rectangle.
endPoint
The coordinate of the end point for the line or rectangle being drawn.
color
The color used to draw the line or box
box
A boolean value that if True, causes a box to be drawn using the coordinates to specify opposite corners of the box.
fill
A boolean value that if True and the box option is used, specifies that the box is filled with the same color used to draw the box. You cannot use fill without box. If box is used without fill, the box is filled with the current FillColor and FillStyle.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Line(Point,Point,Color) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Line Method : Line(Point,Point,Color) Method

startPoint
The coordinate of the starting point for the line.
endPoint
The coordinate of the end point for the line being drawn.
color
The color used to draw the line

Glossary Item Box

Draws a line on a printer

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Line( _
   ByVal startPoint As Point, _
   ByVal endPoint As Point, _
   ByVal color As Color _
)
'Usage

Dim instance As Draw
Dim startPoint As Point
Dim endPoint As Point
Dim color As Color

instance.Line(startPoint, endPoint, color)
public void Line(
   Point startPoint,
   Point endPoint,
   Color color
)
public: void Line(
   Point startPoint,
   Point endPoint,
   Color color
)
public:
void Line(
   Point startPoint,
   Point endPoint,
   Color color
)

Parameters

startPoint
The coordinate of the starting point for the line.
endPoint
The coordinate of the end point for the line being drawn.
color
The color used to draw the line

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Line(Point,Point,Boolean,Boolean) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Line Method : Line(Point,Point,Boolean,Boolean) Method

startPoint
The coordinate of the starting point for the line or rectangle.
endPoint
The coordinate of the end point for the line or rectangle being drawn.
box
A boolean value that if True, causes a box to be drawn using the coordinates to specify opposite corners of the box.
fill
A boolean value that if True and the box option is used, specifies that the box is filled with the same color used to draw the box. You cannot use fill without box. If box is used without fill, the box is filled with the current FillColor and FillStyle.

Glossary Item Box

Draws a black line or rectangle on a printer

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Line( _
   ByVal startPoint As Point, _
   ByVal endPoint As Point, _
   ByVal box As Boolean, _
   ByVal fill As Boolean _
)
'Usage

Dim instance As Draw
Dim startPoint As Point
Dim endPoint As Point
Dim box As Boolean
Dim fill As Boolean

instance.Line(startPoint, endPoint, box, fill)
public void Line(
   Point startPoint,
   Point endPoint,
   bool box,
   bool fill
)
public: void Line(
   Point startPoint,
   Point endPoint,
   bool box,
   bool fill
)
public:
void Line(
   Point startPoint,
   Point endPoint,
   bool box,
   bool fill
)

Parameters

startPoint
The coordinate of the starting point for the line or rectangle.
endPoint
The coordinate of the end point for the line or rectangle being drawn.
box
A boolean value that if True, causes a box to be drawn using the coordinates to specify opposite corners of the box.
fill
A boolean value that if True and the box option is used, specifies that the box is filled with the same color used to draw the box. You cannot use fill without box. If box is used without fill, the box is filled with the current FillColor and FillStyle.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Line(Point,Point) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Line Method : Line(Point,Point) Method

startPoint
The coordinate of the starting point for the line.
endPoint
The coordinate of the end point for the line being drawn.

Glossary Item Box

Draws a black line

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Line( _
   ByVal startPoint As Point, _
   ByVal endPoint As Point _
)
'Usage

Dim instance As Draw
Dim startPoint As Point
Dim endPoint As Point

instance.Line(startPoint, endPoint)
public void Line(
   Point startPoint,
   Point endPoint
)
public: void Line(
   Point startPoint,
   Point endPoint
)
public:
void Line(
   Point startPoint,
   Point endPoint
)

Parameters

startPoint
The coordinate of the starting point for the line.
endPoint
The coordinate of the end point for the line being drawn.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Line(Point,Color,Boolean,Boolean) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Line Method : Line(Point,Color,Boolean,Boolean) Method

endPoint
The coordinate of the end point for the line or rectangle being drawn.
color
The color used to draw the line or box
box
A boolean value that if True, causes a box to be drawn using the coordinates to specify opposite corners of the box.
fill
A boolean value that if True and the box option is used, specifies that the box is filled with the same color used to draw the box. You cannot use fill without box. If box is used without fill, the box is filled with the current FillColor and FillStyle.

Glossary Item Box

Draws a line or rectangle on a printer starting from the current draw location

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Line( _
   ByVal endPoint As Point, _
   ByVal color As Color, _
   ByVal box As Boolean, _
   ByVal fill As Boolean _
)
'Usage

Dim instance As Draw
Dim endPoint As Point
Dim color As Color
Dim box As Boolean
Dim fill As Boolean

instance.Line(endPoint, color, box, fill)
public void Line(
   Point endPoint,
   Color color,
   bool box,
   bool fill
)
public: void Line(
   Point endPoint,
   Color color,
   bool box,
   bool fill
)
public:
void Line(
   Point endPoint,
   Color color,
   bool box,
   bool fill
)

Parameters

endPoint
The coordinate of the end point for the line or rectangle being drawn.
color
The color used to draw the line or box
box
A boolean value that if True, causes a box to be drawn using the coordinates to specify opposite corners of the box.
fill
A boolean value that if True and the box option is used, specifies that the box is filled with the same color used to draw the box. You cannot use fill without box. If box is used without fill, the box is filled with the current FillColor and FillStyle.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Line(Point,Color) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Line Method : Line(Point,Color) Method

endPoint
A System.Drawing.Point which represents the coordinate of the end point for the line being drawn.
color
The System.Drawing.Color used to draw the line.

Glossary Item Box

Draws a line on a printer starting at the current draw location.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Line( _
   ByVal endPoint As Point, _
   ByVal color As Color _
)
'Usage

Dim instance As Draw
Dim endPoint As Point
Dim color As Color

instance.Line(endPoint, color)
public void Line(
   Point endPoint,
   Color color
)
public: void Line(
   Point endPoint,
   Color color
)
public:
void Line(
   Point endPoint,
   Color color
)

Parameters

endPoint
A System.Drawing.Point which represents the coordinate of the end point for the line being drawn.
color
The System.Drawing.Color used to draw the line.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Line(Point,Boolean,Boolean) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Line Method : Line(Point,Boolean,Boolean) Method

endPoint
A System.Drawing.Point which represents the coordinate of the end point for the line or rectangle being drawn.
box
A boolean value that if true, causes a box to be drawn using the coordinates to specify opposite corners of the box.
fill
A boolean value that if true, and the box option is used, specifies that the box is filled with the same color used to draw the box. You cannot use fill without box. If box is used without fill, the box is filled with the current FillColor and FillStyle.

Glossary Item Box

Draws a black line or rectangle on a printer starting at the current draw location.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Line( _
   ByVal endPoint As Point, _
   ByVal box As Boolean, _
   ByVal fill As Boolean _
)
'Usage

Dim instance As Draw
Dim endPoint As Point
Dim box As Boolean
Dim fill As Boolean

instance.Line(endPoint, box, fill)
public void Line(
   Point endPoint,
   bool box,
   bool fill
)
public: void Line(
   Point endPoint,
   bool box,
   bool fill
)
public:
void Line(
   Point endPoint,
   bool box,
   bool fill
)

Parameters

endPoint
A System.Drawing.Point which represents the coordinate of the end point for the line or rectangle being drawn.
box
A boolean value that if true, causes a box to be drawn using the coordinates to specify opposite corners of the box.
fill
A boolean value that if true, and the box option is used, specifies that the box is filled with the same color used to draw the box. You cannot use fill without box. If box is used without fill, the box is filled with the current FillColor and FillStyle.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Line(Point) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Line Method : Line(Point) Method

endPoint
A System.Drawing.Point which represents the coordinate of the end point for the line or rectangle being drawn.

Glossary Item Box

Draws a black line starting at the current draw location.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Line( _
   ByVal endPoint As Point _
)
'Usage

Dim instance As Draw
Dim endPoint As Point

instance.Line(endPoint)
public void Line(
   Point endPoint
)
public: void Line(
   Point endPoint
)
public:
void Line(
   Point endPoint
)

Parameters

endPoint
A System.Drawing.Point which represents the coordinate of the end point for the line or rectangle being drawn.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Pie Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class : Pie Method

Glossary Item Box

Draws part of a circle.

Overload List

Overload | Description
Pie(Rectangle,Single) | Draws part of a circle.
Pie(PointF,Single,Single,Single,Color) | Draws part of a circle.
Pie(PointF,Single,Single,Color) | Draws part of a circle.
Pie(Single,Single,Single,Color) | Draws part of a circle.
Pie(Single,Single,Color) | Draws part of a circle.
Pie(PointF,Single,Single,Single) | Draws part of a circle.
Pie(PointF,Single,Single) | Draws part of a circle.
Pie(Single,Single,Single) | Draws part of a circle.
Pie(Single,Single) | Draws part of a circle.
Pie(PointF,PointF,Single,Single,Color) | Draws a pie-shaped wedge on a printer.
Pie(RectangleF,Single,Single,Color) | Draws part of a circle.
Pie(PointF,PointF,Single,Color) | Draws a pie-shaped wedge on a printer.
Pie(RectangleF,Single,Color) | Draws part of a circle.
Pie(PointF,PointF,Single,Single) | Draws a black pie-shaped wedge on a printer.
Pie(RectangleF,Single,Single) | Draws part of a circle.
Pie(PointF,PointF,Single) | Draws a black pie-shaped wedge on a printer.
Pie(RectangleF,Single) | Draws part of a circle.
Pie(Point,Int32,Single,Single,Color) | Draws part of a circle.
Pie(Point,Int32,Single,Color) | Draws part of a circle.
Pie(Int32,Single,Single,Color) | Draws part of a circle.
Pie(Int32,Single,Color) | Draws part of a circle.
Pie(Point,Int32,Single,Single) | Draws part of a circle.
Pie(Point,Int32,Single) | Draws part of a circle.
Pie(Int32,Single,Single) | Draws part of a circle.
Pie(Int32,Single) | Draws part of a circle.
Pie(Point,Point,Single,Single,Color) | Draws a pie-shaped wedge on a printer.
Pie(Rectangle,Single,Single,Color) | Draws part of a circle.
Pie(Point,Point,Single,Color) | Draws a pie-shaped wedge on a printer.
Pie(Rectangle,Single,Color) | Draws part of a circle.
Pie(Point,Point,Single,Single) | Draws a black pie-shaped wedge on a printer.
Pie(Rectangle,Single,Single) | Draws part of a circle.
Pie(Point,Point,Single) | Draws a black pie-shaped wedge on a printer.

See Also

Reference

Draw Class
Draw Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Pie(Rectangle,Single) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Pie Method : Pie(Rectangle,Single) Method

boundingBox
The bounding A System.Drawing.Rectangle of the circle.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.

Glossary Item Box

Draws part of a circle.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Pie( _
   ByVal boundingBox As Rectangle, _
   ByVal endAngle As Single _
)
'Usage

Dim instance As Draw
Dim boundingBox As Rectangle
Dim endAngle As Single

instance.Pie(boundingBox, endAngle)
public void Pie(
   Rectangle boundingBox,
   float endAngle
)
public: void Pie(
   Rectangle boundingBox,
   float endAngle
)
public:
void Pie(
   Rectangle boundingBox,
   float endAngle
)

Parameters

boundingBox
The bounding A System.Drawing.Rectangle of the circle.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Pie(PointF,Single,Single,Single,Color) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Pie Method : Pie(PointF,Single,Single,Single,Color) Method

location
A System.Drawing.PointF which represents the location of the center of the circle of the pie slice.
radius
A single value which represents the radius of the circle. A negative radius will have the same result as its positive counterpart.
startAngle
A single value which represents the starting angle of the slice.
endAngle
A single value which represents the ending angle of the slice.
color
The System.Drawing.Color of the slice.

Glossary Item Box

Draws part of a circle.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Pie( _
   ByVal location As PointF, _
   ByVal radius As Single, _
   ByVal startAngle As Single, _
   ByVal endAngle As Single, _
   ByVal color As Color _
)
'Usage

Dim instance As Draw
Dim location As PointF
Dim radius As Single
Dim startAngle As Single
Dim endAngle As Single
Dim color As Color

instance.Pie(location, radius, startAngle, endAngle, color)
public void Pie(
   PointF location,
   float radius,
   float startAngle,
   float endAngle,
   Color color
)
public: void Pie(
   PointF location,
   float radius,
   float startAngle,
   float endAngle,
   Color color
)
public:
void Pie(
   PointF location,
   float radius,
   float startAngle,
   float endAngle,
   Color color
)

Parameters

location
A System.Drawing.PointF which represents the location of the center of the circle of the pie slice.
radius
A single value which represents the radius of the circle. A negative radius will have the same result as its positive counterpart.
startAngle
A single value which represents the starting angle of the slice.
endAngle
A single value which represents the ending angle of the slice.
color
The System.Drawing.Color of the slice.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Pie(PointF,Single,Single,Color) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Pie Method : Pie(PointF,Single,Single,Color) Method

location
A System.Drawing.PointF which represents the location of the center of the circle of the pie slice.
radius
A single value which represents the radius of the circle. A negative radius will have the same result as its positive counterpart.
endAngle
A single value which represents the ending angle of the slice.
color
The System.Drawing.Color of the slice.

Glossary Item Box

Draws part of a circle.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Pie( _
   ByVal location As PointF, _
   ByVal radius As Single, _
   ByVal endAngle As Single, _
   ByVal color As Color _
)
'Usage

Dim instance As Draw
Dim location As PointF
Dim radius As Single
Dim endAngle As Single
Dim color As Color

instance.Pie(location, radius, endAngle, color)
public void Pie(
   PointF location,
   float radius,
   float endAngle,
   Color color
)
public: void Pie(
   PointF location,
   float radius,
   float endAngle,
   Color color
)
public:
void Pie(
   PointF location,
   float radius,
   float endAngle,
   Color color
)

Parameters

location
A System.Drawing.PointF which represents the location of the center of the circle of the pie slice.
radius
A single value which represents the radius of the circle. A negative radius will have the same result as its positive counterpart.
endAngle
A single value which represents the ending angle of the slice.
color
The System.Drawing.Color of the slice.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Pie(Single,Single,Single,Color) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Pie Method : Pie(Single,Single,Single,Color) Method

radius
A single value which represents the radius of the circle. A negative radius will have the same result as its positive counterpart.
startAngle
A single value which represents the starting angle of the slice.
endAngle
A single value which represents the ending angle of the slice.
color
The System.Drawing.Color of the slice.

Glossary Item Box

Draws part of a circle.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Pie( _
   ByVal radius As Single, _
   ByVal startAngle As Single, _
   ByVal endAngle As Single, _
   ByVal color As Color _
)
'Usage

Dim instance As Draw
Dim radius As Single
Dim startAngle As Single
Dim endAngle As Single
Dim color As Color

instance.Pie(radius, startAngle, endAngle, color)
public void Pie(
   float radius,
   float startAngle,
   float endAngle,
   Color color
)
public: void Pie(
   float radius,
   float startAngle,
   float endAngle,
   Color color
)
public:
void Pie(
   float radius,
   float startAngle,
   float endAngle,
   Color color
)

Parameters

radius
A single value which represents the radius of the circle. A negative radius will have the same result as its positive counterpart.
startAngle
A single value which represents the starting angle of the slice.
endAngle
A single value which represents the ending angle of the slice.
color
The System.Drawing.Color of the slice.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Pie(Single,Single,Color) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Pie Method : Pie(Single,Single,Color) Method

radius
A single value which represents the radius of the circle. A negative radius will have the same result as its positive counterpart.
endAngle
A single value which represents the ending angle of the slice.
color
The System.Drawing.Color of the slice.

Glossary Item Box

Draws part of a circle.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Pie( _
   ByVal radius As Single, _
   ByVal endAngle As Single, _
   ByVal color As Color _
)
'Usage

Dim instance As Draw
Dim radius As Single
Dim endAngle As Single
Dim color As Color

instance.Pie(radius, endAngle, color)
public void Pie(
   float radius,
   float endAngle,
   Color color
)
public: void Pie(
   float radius,
   float endAngle,
   Color color
)
public:
void Pie(
   float radius,
   float endAngle,
   Color color
)

Parameters

radius
A single value which represents the radius of the circle. A negative radius will have the same result as its positive counterpart.
endAngle
A single value which represents the ending angle of the slice.
color
The System.Drawing.Color of the slice.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Pie(PointF,Single,Single,Single) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Pie Method : Pie(PointF,Single,Single,Single) Method

location
A System.Drawing.PointF which represents the location of the center of the circle of the pie slice.
radius
A single value which represents the radius of the circle. A negative radius will have the same result as its positive counterpart.
startAngle
A single value which represents the starting angle of the slice.
endAngle
A single value which represents the ending angle of the slice.

Glossary Item Box

Draws part of a circle.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Pie( _
   ByVal location As PointF, _
   ByVal radius As Single, _
   ByVal startAngle As Single, _
   ByVal endAngle As Single _
)
'Usage

Dim instance As Draw
Dim location As PointF
Dim radius As Single
Dim startAngle As Single
Dim endAngle As Single

instance.Pie(location, radius, startAngle, endAngle)
public void Pie(
   PointF location,
   float radius,
   float startAngle,
   float endAngle
)
public: void Pie(
   PointF location,
   float radius,
   float startAngle,
   float endAngle
)
public:
void Pie(
   PointF location,
   float radius,
   float startAngle,
   float endAngle
)

Parameters

location
A System.Drawing.PointF which represents the location of the center of the circle of the pie slice.
radius
A single value which represents the radius of the circle. A negative radius will have the same result as its positive counterpart.
startAngle
A single value which represents the starting angle of the slice.
endAngle
A single value which represents the ending angle of the slice.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Pie(PointF,Single,Single) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Pie Method : Pie(PointF,Single,Single) Method

location
A System.Drawing.PointF which represents the location of the center of the circle of the pie slice.
radius
A single value which represents the radius of the circle. A negative radius will have the same result as its positive counterpart.
endAngle
A single value which represents the ending angle of the slice.

Glossary Item Box

Draws part of a circle.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Pie( _
   ByVal location As PointF, _
   ByVal radius As Single, _
   ByVal endAngle As Single _
)
'Usage

Dim instance As Draw
Dim location As PointF
Dim radius As Single
Dim endAngle As Single

instance.Pie(location, radius, endAngle)
public void Pie(
   PointF location,
   float radius,
   float endAngle
)
public: void Pie(
   PointF location,
   float radius,
   float endAngle
)
public:
void Pie(
   PointF location,
   float radius,
   float endAngle
)

Parameters

location
A System.Drawing.PointF which represents the location of the center of the circle of the pie slice.
radius
A single value which represents the radius of the circle. A negative radius will have the same result as its positive counterpart.
endAngle
A single value which represents the ending angle of the slice.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Pie(Single,Single,Single) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Pie Method : Pie(Single,Single,Single) Method

radius
A single value which represents the radius of the circle. A negative radius will have the same result as its positive counterpart.
startAngle
A single value which represents the starting angle of the slice.
endAngle
A single value which represents the ending angle of the slice.

Glossary Item Box

Draws part of a circle.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Pie( _
   ByVal radius As Single, _
   ByVal startAngle As Single, _
   ByVal endAngle As Single _
)
'Usage

Dim instance As Draw
Dim radius As Single
Dim startAngle As Single
Dim endAngle As Single

instance.Pie(radius, startAngle, endAngle)
public void Pie(
   float radius,
   float startAngle,
   float endAngle
)
public: void Pie(
   float radius,
   float startAngle,
   float endAngle
)
public:
void Pie(
   float radius,
   float startAngle,
   float endAngle
)

Parameters

radius
A single value which represents the radius of the circle. A negative radius will have the same result as its positive counterpart.
startAngle
A single value which represents the starting angle of the slice.
endAngle
A single value which represents the ending angle of the slice.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Pie(Single,Single) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Pie Method : Pie(Single,Single) Method

radius
A single value which represents the radius of the circle. A negative radius will have the same result as its positive counterpart.
endAngle
A single value which represents the ending angle of the slice.

Glossary Item Box

Draws part of a circle.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Pie( _
   ByVal radius As Single, _
   ByVal endAngle As Single _
)
'Usage

Dim instance As Draw
Dim radius As Single
Dim endAngle As Single

instance.Pie(radius, endAngle)
public void Pie(
   float radius,
   float endAngle
)
public: void Pie(
   float radius,
   float endAngle
)
public:
void Pie(
   float radius,
   float endAngle
)

Parameters

radius
A single value which represents the radius of the circle. A negative radius will have the same result as its positive counterpart.
endAngle
A single value which represents the ending angle of the slice.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Pie(PointF,PointF,Single,Single,Color) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Pie Method : Pie(PointF,PointF,Single,Single,Color) Method

upperLeft
A System.Drawing.PointF which represents the upper-left coordinate of the bounding rectangle.
lowerRight
A System.Drawing.PointF which represents the upper-right coordinate of the bouding rectangle.
startAngle
A single value which represents the starting angle of the slice.
endAngle
A single value which represents the ending angle of the slice.
color
color of the circle’s outline.

Glossary Item Box

Draws a pie-shaped wedge on a printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Pie( _
   ByVal upperLeft As PointF, _
   ByVal lowerRight As PointF, _
   ByVal startAngle As Single, _
   ByVal endAngle As Single, _
   ByVal color As Color _
)
'Usage

Dim instance As Draw
Dim upperLeft As PointF
Dim lowerRight As PointF
Dim startAngle As Single
Dim endAngle As Single
Dim color As Color

instance.Pie(upperLeft, lowerRight, startAngle, endAngle, color)
public void Pie(
   PointF upperLeft,
   PointF lowerRight,
   float startAngle,
   float endAngle,
   Color color
)
public: void Pie(
   PointF upperLeft,
   PointF lowerRight,
   float startAngle,
   float endAngle,
   Color color
)
public:
void Pie(
   PointF upperLeft,
   PointF lowerRight,
   float startAngle,
   float endAngle,
   Color color
)

Parameters

upperLeft
A System.Drawing.PointF which represents the upper-left coordinate of the bounding rectangle.
lowerRight
A System.Drawing.PointF which represents the upper-right coordinate of the bouding rectangle.
startAngle
A single value which represents the starting angle of the slice.
endAngle
A single value which represents the ending angle of the slice.
color
color of the circle’s outline.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Pie(RectangleF,Single,Single,Color) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Pie Method : Pie(RectangleF,Single,Single,Color) Method

boundingBox
The bounding System.Drawing.RectangleF of the circle.
startAngle
A single value which represents the starting angle of the slice.
endAngle
A single value which represents the ending angle of the slice.
color
The System.Drawing.Color of the slice.

Glossary Item Box

Draws part of a circle.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Pie( _
   ByVal boundingBox As RectangleF, _
   ByVal startAngle As Single, _
   ByVal endAngle As Single, _
   ByVal color As Color _
)
'Usage

Dim instance As Draw
Dim boundingBox As RectangleF
Dim startAngle As Single
Dim endAngle As Single
Dim color As Color

instance.Pie(boundingBox, startAngle, endAngle, color)
public void Pie(
   RectangleF boundingBox,
   float startAngle,
   float endAngle,
   Color color
)
public: void Pie(
   RectangleF boundingBox,
   float startAngle,
   float endAngle,
   Color color
)
public:
void Pie(
   RectangleF boundingBox,
   float startAngle,
   float endAngle,
   Color color
)

Parameters

boundingBox
The bounding System.Drawing.RectangleF of the circle.
startAngle
A single value which represents the starting angle of the slice.
endAngle
A single value which represents the ending angle of the slice.
color
The System.Drawing.Color of the slice.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Pie(PointF,PointF,Single,Color) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Pie Method : Pie(PointF,PointF,Single,Color) Method

upperLeft
A System.Drawing.PointF which represents the upper-left coordinate of the bounding rectangle.
lowerRight
A System.Drawing.PointF which represents the upper-right coordinate of the bouding rectangle.
endAngle
Single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.
color
color of the circle’s outline.

Glossary Item Box

Draws a pie-shaped wedge on a printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Pie( _
   ByVal upperLeft As PointF, _
   ByVal lowerRight As PointF, _
   ByVal endAngle As Single, _
   ByVal color As Color _
)
'Usage

Dim instance As Draw
Dim upperLeft As PointF
Dim lowerRight As PointF
Dim endAngle As Single
Dim color As Color

instance.Pie(upperLeft, lowerRight, endAngle, color)
public void Pie(
   PointF upperLeft,
   PointF lowerRight,
   float endAngle,
   Color color
)
public: void Pie(
   PointF upperLeft,
   PointF lowerRight,
   float endAngle,
   Color color
)
public:
void Pie(
   PointF upperLeft,
   PointF lowerRight,
   float endAngle,
   Color color
)

Parameters

upperLeft
A System.Drawing.PointF which represents the upper-left coordinate of the bounding rectangle.
lowerRight
A System.Drawing.PointF which represents the upper-right coordinate of the bouding rectangle.
endAngle
Single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.
color
color of the circle’s outline.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Pie(RectangleF,Single,Color) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Pie Method : Pie(RectangleF,Single,Color) Method

boundingBox
The bounding System.Drawing.RectangleF of the circle.
endAngle
A single value which represents the ending angle of the slice.
color
The System.Drawing.Color of the circle’s outline.

Glossary Item Box

Draws part of a circle.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Pie( _
   ByVal boundingBox As RectangleF, _
   ByVal endAngle As Single, _
   ByVal color As Color _
)
'Usage

Dim instance As Draw
Dim boundingBox As RectangleF
Dim endAngle As Single
Dim color As Color

instance.Pie(boundingBox, endAngle, color)
public void Pie(
   RectangleF boundingBox,
   float endAngle,
   Color color
)
public: void Pie(
   RectangleF boundingBox,
   float endAngle,
   Color color
)
public:
void Pie(
   RectangleF boundingBox,
   float endAngle,
   Color color
)

Parameters

boundingBox
The bounding System.Drawing.RectangleF of the circle.
endAngle
A single value which represents the ending angle of the slice.
color
The System.Drawing.Color of the circle’s outline.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Pie(PointF,PointF,Single,Single) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Pie Method : Pie(PointF,PointF,Single,Single) Method

upperLeft
A System.Drawing.PointF which represents the upper-left coordinate of the bounding rectangle.
lowerRight
A System.Drawing.PointF which represents the upper-right coordinate of the bouding rectangle.
startAngle
A Single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
endAngle
A Single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.

Glossary Item Box

Draws a black pie-shaped wedge on a printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Pie( _
   ByVal upperLeft As PointF, _
   ByVal lowerRight As PointF, _
   ByVal startAngle As Single, _
   ByVal endAngle As Single _
)
'Usage

Dim instance As Draw
Dim upperLeft As PointF
Dim lowerRight As PointF
Dim startAngle As Single
Dim endAngle As Single

instance.Pie(upperLeft, lowerRight, startAngle, endAngle)
public void Pie(
   PointF upperLeft,
   PointF lowerRight,
   float startAngle,
   float endAngle
)
public: void Pie(
   PointF upperLeft,
   PointF lowerRight,
   float startAngle,
   float endAngle
)
public:
void Pie(
   PointF upperLeft,
   PointF lowerRight,
   float startAngle,
   float endAngle
)

Parameters

upperLeft
A System.Drawing.PointF which represents the upper-left coordinate of the bounding rectangle.
lowerRight
A System.Drawing.PointF which represents the upper-right coordinate of the bouding rectangle.
startAngle
A Single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
endAngle
A Single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Pie(RectangleF,Single,Single) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Pie Method : Pie(RectangleF,Single,Single) Method

boundingBox
The bounding System.Drawing.Rectangle of the circle.
startAngle
A Single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
endAngle
A Single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.

Glossary Item Box

Draws part of a circle.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Pie( _
   ByVal boundingBox As RectangleF, _
   ByVal startAngle As Single, _
   ByVal endAngle As Single _
)
'Usage

Dim instance As Draw
Dim boundingBox As RectangleF
Dim startAngle As Single
Dim endAngle As Single

instance.Pie(boundingBox, startAngle, endAngle)
public void Pie(
   RectangleF boundingBox,
   float startAngle,
   float endAngle
)
public: void Pie(
   RectangleF boundingBox,
   float startAngle,
   float endAngle
)
public:
void Pie(
   RectangleF boundingBox,
   float startAngle,
   float endAngle
)

Parameters

boundingBox
The bounding System.Drawing.Rectangle of the circle.
startAngle
A Single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
endAngle
A Single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Pie(PointF,PointF,Single) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Pie Method : Pie(PointF,PointF,Single) Method

upperLeft
A System.Drawing.PointF which represents the upper-left coordinate of the bounding rectangle.
lowerRight
A System.Drawing.PointF which represents the upper-right coordinate of the bouding rectangle.
endAngle
A Single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.

Glossary Item Box

Draws a black pie-shaped wedge on a printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Pie( _
   ByVal upperLeft As PointF, _
   ByVal lowerRight As PointF, _
   ByVal endAngle As Single _
)
'Usage

Dim instance As Draw
Dim upperLeft As PointF
Dim lowerRight As PointF
Dim endAngle As Single

instance.Pie(upperLeft, lowerRight, endAngle)
public void Pie(
   PointF upperLeft,
   PointF lowerRight,
   float endAngle
)
public: void Pie(
   PointF upperLeft,
   PointF lowerRight,
   float endAngle
)
public:
void Pie(
   PointF upperLeft,
   PointF lowerRight,
   float endAngle
)

Parameters

upperLeft
A System.Drawing.PointF which represents the upper-left coordinate of the bounding rectangle.
lowerRight
A System.Drawing.PointF which represents the upper-right coordinate of the bouding rectangle.
endAngle
A Single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Pie(RectangleF,Single) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Pie Method : Pie(RectangleF,Single) Method

boundingBox
The bounding System.Drawing.Rectangle of the circle.
endAngle
A Single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.

Glossary Item Box

Draws part of a circle.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Pie( _
   ByVal boundingBox As RectangleF, _
   ByVal endAngle As Single _
)
'Usage

Dim instance As Draw
Dim boundingBox As RectangleF
Dim endAngle As Single

instance.Pie(boundingBox, endAngle)
public void Pie(
   RectangleF boundingBox,
   float endAngle
)
public: void Pie(
   RectangleF boundingBox,
   float endAngle
)
public:
void Pie(
   RectangleF boundingBox,
   float endAngle
)

Parameters

boundingBox
The bounding System.Drawing.Rectangle of the circle.
endAngle
A Single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Pie(Point,Int32,Single,Single,Color) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Pie Method : Pie(Point,Int32,Single,Single,Color) Method

location
A System.Drawing.Point which represents the location of the center of the circle of the pie slice.
radius
An integer value which represents the radius of the circle. A negative radius will have the same result as its positive counterpart.
startAngle
A single value which represents the starting angle of the slice.
endAngle
A single value which represents the ending angle of the slice.
color
The System.Drawing.Color of the slice.

Glossary Item Box

Draws part of a circle.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Pie( _
   ByVal location As Point, _
   ByVal radius As Integer, _
   ByVal startAngle As Single, _
   ByVal endAngle As Single, _
   ByVal color As Color _
)
'Usage

Dim instance As Draw
Dim location As Point
Dim radius As Integer
Dim startAngle As Single
Dim endAngle As Single
Dim color As Color

instance.Pie(location, radius, startAngle, endAngle, color)
public void Pie(
   Point location,
   int radius,
   float startAngle,
   float endAngle,
   Color color
)
public: void Pie(
   Point location,
   int radius,
   float startAngle,
   float endAngle,
   Color color
)
public:
void Pie(
   Point location,
   int radius,
   float startAngle,
   float endAngle,
   Color color
)

Parameters

location
A System.Drawing.Point which represents the location of the center of the circle of the pie slice.
radius
An integer value which represents the radius of the circle. A negative radius will have the same result as its positive counterpart.
startAngle
A single value which represents the starting angle of the slice.
endAngle
A single value which represents the ending angle of the slice.
color
The System.Drawing.Color of the slice.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Pie(Point,Int32,Single,Color) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Pie Method : Pie(Point,Int32,Single,Color) Method

location
A System.Drawing.Point which represents the location of the center of the circle of the pie slice.
radius
An integer value which represents the radius of the circle. A negative radius will have the same result as its positive counterpart.
endAngle
A single value which represents the ending angle of the slice.
color
The System.Drawing.Color of the slice.

Glossary Item Box

Draws part of a circle.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Pie( _
   ByVal location As Point, _
   ByVal radius As Integer, _
   ByVal endAngle As Single, _
   ByVal color As Color _
)
'Usage

Dim instance As Draw
Dim location As Point
Dim radius As Integer
Dim endAngle As Single
Dim color As Color

instance.Pie(location, radius, endAngle, color)
public void Pie(
   Point location,
   int radius,
   float endAngle,
   Color color
)
public: void Pie(
   Point location,
   int radius,
   float endAngle,
   Color color
)
public:
void Pie(
   Point location,
   int radius,
   float endAngle,
   Color color
)

Parameters

location
A System.Drawing.Point which represents the location of the center of the circle of the pie slice.
radius
An integer value which represents the radius of the circle. A negative radius will have the same result as its positive counterpart.
endAngle
A single value which represents the ending angle of the slice.
color
The System.Drawing.Color of the slice.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Pie(Int32,Single,Single,Color) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Pie Method : Pie(Int32,Single,Single,Color) Method

radius
An integer value which represents the radius of the circle. A negative radius will have the same result as its positive counterpart.
startAngle
A single value which represents the starting angle of the slice.
endAngle
A single value which represents the ending angle of the slice.
color
The System.Drawing.Color of the slice.

Glossary Item Box

Draws part of a circle.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Pie( _
   ByVal radius As Integer, _
   ByVal startAngle As Single, _
   ByVal endAngle As Single, _
   ByVal color As Color _
)
'Usage

Dim instance As Draw
Dim radius As Integer
Dim startAngle As Single
Dim endAngle As Single
Dim color As Color

instance.Pie(radius, startAngle, endAngle, color)
public void Pie(
   int radius,
   float startAngle,
   float endAngle,
   Color color
)
public: void Pie(
   int radius,
   float startAngle,
   float endAngle,
   Color color
)
public:
void Pie(
   int radius,
   float startAngle,
   float endAngle,
   Color color
)

Parameters

radius
An integer value which represents the radius of the circle. A negative radius will have the same result as its positive counterpart.
startAngle
A single value which represents the starting angle of the slice.
endAngle
A single value which represents the ending angle of the slice.
color
The System.Drawing.Color of the slice.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Pie(Int32,Single,Color) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Pie Method : Pie(Int32,Single,Color) Method

radius
An integer value which represents the radius of the circle. A negative radius will have the same result as its positive counterpart.
endAngle
A single value which represents the ending angle of the slice.
color
The System.Drawing.Color of the slice.

Glossary Item Box

Draws part of a circle.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Pie( _
   ByVal radius As Integer, _
   ByVal endAngle As Single, _
   ByVal color As Color _
)
'Usage

Dim instance As Draw
Dim radius As Integer
Dim endAngle As Single
Dim color As Color

instance.Pie(radius, endAngle, color)
public void Pie(
   int radius,
   float endAngle,
   Color color
)
public: void Pie(
   int radius,
   float endAngle,
   Color color
)
public:
void Pie(
   int radius,
   float endAngle,
   Color color
)

Parameters

radius
An integer value which represents the radius of the circle. A negative radius will have the same result as its positive counterpart.
endAngle
A single value which represents the ending angle of the slice.
color
The System.Drawing.Color of the slice.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Pie(Point,Int32,Single,Single) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Pie Method : Pie(Point,Int32,Single,Single) Method

location
A System.Drawing.Point which represents the location of the center of the circle of the pie slice.
radius
An integer value which represents the radius of the circle. A negative radius will have the same result as its positive counterpart.
startAngle
A single value which represents the starting angle of the slice.
endAngle
A single value which represents the ending angle of the slice.

Glossary Item Box

Draws part of a circle.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Pie( _
   ByVal location As Point, _
   ByVal radius As Integer, _
   ByVal startAngle As Single, _
   ByVal endAngle As Single _
)
'Usage

Dim instance As Draw
Dim location As Point
Dim radius As Integer
Dim startAngle As Single
Dim endAngle As Single

instance.Pie(location, radius, startAngle, endAngle)
public void Pie(
   Point location,
   int radius,
   float startAngle,
   float endAngle
)
public: void Pie(
   Point location,
   int radius,
   float startAngle,
   float endAngle
)
public:
void Pie(
   Point location,
   int radius,
   float startAngle,
   float endAngle
)

Parameters

location
A System.Drawing.Point which represents the location of the center of the circle of the pie slice.
radius
An integer value which represents the radius of the circle. A negative radius will have the same result as its positive counterpart.
startAngle
A single value which represents the starting angle of the slice.
endAngle
A single value which represents the ending angle of the slice.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Pie(Point,Int32,Single) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Pie Method : Pie(Point,Int32,Single) Method

location
A System.Drawing.Point which represents the location of the center of the circle of the pie slice.
radius
An integer value which represents the radius of the circle. A negative radius will have the same result as its positive counterpart.
endAngle
A single value which represents the ending angle of the slice.

Glossary Item Box

Draws part of a circle.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Pie( _
   ByVal location As Point, _
   ByVal radius As Integer, _
   ByVal endAngle As Single _
)
'Usage

Dim instance As Draw
Dim location As Point
Dim radius As Integer
Dim endAngle As Single

instance.Pie(location, radius, endAngle)
public void Pie(
   Point location,
   int radius,
   float endAngle
)
public: void Pie(
   Point location,
   int radius,
   float endAngle
)
public:
void Pie(
   Point location,
   int radius,
   float endAngle
)

Parameters

location
A System.Drawing.Point which represents the location of the center of the circle of the pie slice.
radius
An integer value which represents the radius of the circle. A negative radius will have the same result as its positive counterpart.
endAngle
A single value which represents the ending angle of the slice.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Pie(Int32,Single,Single) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Pie Method : Pie(Int32,Single,Single) Method

radius
An integer value which represents the radius of the circle. A negative radius will have the same result as its positive counterpart.
startAngle
A single value which represents the starting angle of the slice.
endAngle
A single value which represents the ending angle of the slice.

Glossary Item Box

Draws part of a circle.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Pie( _
   ByVal radius As Integer, _
   ByVal startAngle As Single, _
   ByVal endAngle As Single _
)
'Usage

Dim instance As Draw
Dim radius As Integer
Dim startAngle As Single
Dim endAngle As Single

instance.Pie(radius, startAngle, endAngle)
public void Pie(
   int radius,
   float startAngle,
   float endAngle
)
public: void Pie(
   int radius,
   float startAngle,
   float endAngle
)
public:
void Pie(
   int radius,
   float startAngle,
   float endAngle
)

Parameters

radius
An integer value which represents the radius of the circle. A negative radius will have the same result as its positive counterpart.
startAngle
A single value which represents the starting angle of the slice.
endAngle
A single value which represents the ending angle of the slice.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Pie(Int32,Single) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Pie Method : Pie(Int32,Single) Method

radius
An integer value which represents the radius of the circle. A negative radius will have the same result as its positive counterpart.
endAngle
A single value which represents the ending angle of the slice.

Glossary Item Box

Draws part of a circle.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Pie( _
   ByVal radius As Integer, _
   ByVal endAngle As Single _
)
'Usage

Dim instance As Draw
Dim radius As Integer
Dim endAngle As Single

instance.Pie(radius, endAngle)
public void Pie(
   int radius,
   float endAngle
)
public: void Pie(
   int radius,
   float endAngle
)
public:
void Pie(
   int radius,
   float endAngle
)

Parameters

radius
An integer value which represents the radius of the circle. A negative radius will have the same result as its positive counterpart.
endAngle
A single value which represents the ending angle of the slice.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Pie(Point,Point,Single,Single,Color) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Pie Method : Pie(Point,Point,Single,Single,Color) Method

upperLeft
A System.Drawing.Point which represents the upper-left coordinate of the bounding rectangle.
lowerRight
A System.Drawing.Point which represents the upper-right coordinate of the bouding rectangle.
startAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.
color
The System.Drawing.Color of the circle’s outline.

Glossary Item Box

Draws a pie-shaped wedge on a printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Pie( _
   ByVal upperLeft As Point, _
   ByVal lowerRight As Point, _
   ByVal startAngle As Single, _
   ByVal endAngle As Single, _
   ByVal color As Color _
)
'Usage

Dim instance As Draw
Dim upperLeft As Point
Dim lowerRight As Point
Dim startAngle As Single
Dim endAngle As Single
Dim color As Color

instance.Pie(upperLeft, lowerRight, startAngle, endAngle, color)
public void Pie(
   Point upperLeft,
   Point lowerRight,
   float startAngle,
   float endAngle,
   Color color
)
public: void Pie(
   Point upperLeft,
   Point lowerRight,
   float startAngle,
   float endAngle,
   Color color
)
public:
void Pie(
   Point upperLeft,
   Point lowerRight,
   float startAngle,
   float endAngle,
   Color color
)

Parameters

upperLeft
A System.Drawing.Point which represents the upper-left coordinate of the bounding rectangle.
lowerRight
A System.Drawing.Point which represents the upper-right coordinate of the bouding rectangle.
startAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.
color
The System.Drawing.Color of the circle’s outline.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Pie(Rectangle,Single,Single,Color) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Pie Method : Pie(Rectangle,Single,Single,Color) Method

boundingBox
The bounding A System.Drawing.Rectangle of the circle.
startAngle
A single value which represents the starting angle of the slice.
endAngle
A single value which represents the ending angle of the slice.
color
The System.Drawing.Color of the slice.

Glossary Item Box

Draws part of a circle.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Pie( _
   ByVal boundingBox As Rectangle, _
   ByVal startAngle As Single, _
   ByVal endAngle As Single, _
   ByVal color As Color _
)
'Usage

Dim instance As Draw
Dim boundingBox As Rectangle
Dim startAngle As Single
Dim endAngle As Single
Dim color As Color

instance.Pie(boundingBox, startAngle, endAngle, color)
public void Pie(
   Rectangle boundingBox,
   float startAngle,
   float endAngle,
   Color color
)
public: void Pie(
   Rectangle boundingBox,
   float startAngle,
   float endAngle,
   Color color
)
public:
void Pie(
   Rectangle boundingBox,
   float startAngle,
   float endAngle,
   Color color
)

Parameters

boundingBox
The bounding A System.Drawing.Rectangle of the circle.
startAngle
A single value which represents the starting angle of the slice.
endAngle
A single value which represents the ending angle of the slice.
color
The System.Drawing.Color of the slice.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Pie(Point,Point,Single,Color) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Pie Method : Pie(Point,Point,Single,Color) Method

upperLeft
A System.Drawing.Point which represents the upper-left coordinate of the bounding rectangle.
lowerRight
A System.Drawing.Point which represents the upper-right coordinate of the bouding rectangle.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.
color
The System.Drawing.Color of the circle’s outline.

Glossary Item Box

Draws a pie-shaped wedge on a printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Pie( _
   ByVal upperLeft As Point, _
   ByVal lowerRight As Point, _
   ByVal endAngle As Single, _
   ByVal color As Color _
)
'Usage

Dim instance As Draw
Dim upperLeft As Point
Dim lowerRight As Point
Dim endAngle As Single
Dim color As Color

instance.Pie(upperLeft, lowerRight, endAngle, color)
public void Pie(
   Point upperLeft,
   Point lowerRight,
   float endAngle,
   Color color
)
public: void Pie(
   Point upperLeft,
   Point lowerRight,
   float endAngle,
   Color color
)
public:
void Pie(
   Point upperLeft,
   Point lowerRight,
   float endAngle,
   Color color
)

Parameters

upperLeft
A System.Drawing.Point which represents the upper-left coordinate of the bounding rectangle.
lowerRight
A System.Drawing.Point which represents the upper-right coordinate of the bouding rectangle.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.
color
The System.Drawing.Color of the circle’s outline.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Pie(Rectangle,Single,Color) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Pie Method : Pie(Rectangle,Single,Color) Method

boundingBox
The bounding A System.Drawing.Rectangle of the circle.
endAngle
A single value which represents the ending angle of the slice.
color
The System.Drawing.Color of the slice.

Glossary Item Box

Draws part of a circle.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Pie( _
   ByVal boundingBox As Rectangle, _
   ByVal endAngle As Single, _
   ByVal color As Color _
)
'Usage

Dim instance As Draw
Dim boundingBox As Rectangle
Dim endAngle As Single
Dim color As Color

instance.Pie(boundingBox, endAngle, color)
public void Pie(
   Rectangle boundingBox,
   float endAngle,
   Color color
)
public: void Pie(
   Rectangle boundingBox,
   float endAngle,
   Color color
)
public:
void Pie(
   Rectangle boundingBox,
   float endAngle,
   Color color
)

Parameters

boundingBox
The bounding A System.Drawing.Rectangle of the circle.
endAngle
A single value which represents the ending angle of the slice.
color
The System.Drawing.Color of the slice.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Pie(Point,Point,Single,Single) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Pie Method : Pie(Point,Point,Single,Single) Method

upperLeft
A System.Drawing.Point which represents the upper-left coordinate of the bounding rectangle.
lowerRight
A System.Drawing.Point which represents the upper-right coordinate of the bouding rectangle.
startAngle
A single value which represents the starting angle of the slice.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.

Glossary Item Box

Draws a black pie-shaped wedge on a printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Pie( _
   ByVal upperLeft As Point, _
   ByVal lowerRight As Point, _
   ByVal startAngle As Single, _
   ByVal endAngle As Single _
)
'Usage

Dim instance As Draw
Dim upperLeft As Point
Dim lowerRight As Point
Dim startAngle As Single
Dim endAngle As Single

instance.Pie(upperLeft, lowerRight, startAngle, endAngle)
public void Pie(
   Point upperLeft,
   Point lowerRight,
   float startAngle,
   float endAngle
)
public: void Pie(
   Point upperLeft,
   Point lowerRight,
   float startAngle,
   float endAngle
)
public:
void Pie(
   Point upperLeft,
   Point lowerRight,
   float startAngle,
   float endAngle
)

Parameters

upperLeft
A System.Drawing.Point which represents the upper-left coordinate of the bounding rectangle.
lowerRight
A System.Drawing.Point which represents the upper-right coordinate of the bouding rectangle.
startAngle
A single value which represents the starting angle of the slice.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Pie(Rectangle,Single,Single) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Pie Method : Pie(Rectangle,Single,Single) Method

boundingBox
The bounding A System.Drawing.Rectangle of the circle.
startAngle
A single value which represents the starting angle of the slice.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.

Glossary Item Box

Draws part of a circle.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Pie( _
   ByVal boundingBox As Rectangle, _
   ByVal startAngle As Single, _
   ByVal endAngle As Single _
)
'Usage

Dim instance As Draw
Dim boundingBox As Rectangle
Dim startAngle As Single
Dim endAngle As Single

instance.Pie(boundingBox, startAngle, endAngle)
public void Pie(
   Rectangle boundingBox,
   float startAngle,
   float endAngle
)
public: void Pie(
   Rectangle boundingBox,
   float startAngle,
   float endAngle
)
public:
void Pie(
   Rectangle boundingBox,
   float startAngle,
   float endAngle
)

Parameters

boundingBox
The bounding A System.Drawing.Rectangle of the circle.
startAngle
A single value which represents the starting angle of the slice.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Pie(Point,Point,Single) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Pie Method : Pie(Point,Point,Single) Method

upperLeft
A System.Drawing.Point which represents the upper-left coordinate of the bounding rectangle.
lowerRight
A System.Drawing.Point which represents the upper-right coordinate of the bouding rectangle.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.

Glossary Item Box

Draws a black pie-shaped wedge on a printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Pie( _
   ByVal upperLeft As Point, _
   ByVal lowerRight As Point, _
   ByVal endAngle As Single _
)
'Usage

Dim instance As Draw
Dim upperLeft As Point
Dim lowerRight As Point
Dim endAngle As Single

instance.Pie(upperLeft, lowerRight, endAngle)
public void Pie(
   Point upperLeft,
   Point lowerRight,
   float endAngle
)
public: void Pie(
   Point upperLeft,
   Point lowerRight,
   float endAngle
)
public:
void Pie(
   Point upperLeft,
   Point lowerRight,
   float endAngle
)

Parameters

upperLeft
A System.Drawing.Point which represents the upper-left coordinate of the bounding rectangle.
lowerRight
A System.Drawing.Point which represents the upper-right coordinate of the bouding rectangle.
endAngle
A single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Polygon Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class : Polygon Method

Glossary Item Box

Draws a 3-6 sided polygon on a printer.

Overload List

Overload | Description
Polygon(PointF[],Color) | Draws a 3-6 sided polygon on a printer.
Polygon(PointF[]) | Draws a 3-6 sided polygon on a printer.
Polygon(Point[],Color) | Draws a 3-6 sided polygon on a printer.
Polygon(Point[]) | Draws a 3-6 sided polygon on a printer.

See Also

Reference

Draw Class
Draw Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Polygon(PointF[],Color) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Polygon Method : Polygon(PointF[],Color) Method

points
A System.Drawing.PointF value which represents the coordinates for a polygon.
color
The System.Drawing.Color of the polygon’s outline.

Glossary Item Box

Draws a 3-6 sided polygon on a printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Polygon( _
   ByVal points() As PointF, _
   ByVal color As Color _
)
'Usage

Dim instance As Draw
Dim points() As PointF
Dim color As Color

instance.Polygon(points, color)
public void Polygon(
   PointF[] points,
   Color color
)
public: void Polygon(
   PointF[]* points,
   Color color
)
public:
void Polygon(
   array<PointF>^ points,
   Color color
)

Parameters

points
A System.Drawing.PointF value which represents the coordinates for a polygon.
color
The System.Drawing.Color of the polygon’s outline.

Remarks

The coordinates of the polygon must be within the physical area of the printer. To fill a polygon, set the FillColor and FillStyle properties of the object on which the polygon is drawn. Specify as many coordinates as needed to define the polygon (3 for a triangle, 4 for a square, etc.) The width of the line used to draw the rectangle depends on the setting of the Width property. The way the rectangle is drawn on the background depends on the setting of the Mode and Style properties

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Polygon(PointF[]) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Polygon Method : Polygon(PointF[]) Method

points
A System.Drawing.PointF value which represents the coordinates for a polygon.

Glossary Item Box

Draws a 3-6 sided polygon on a printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Polygon( _
   ByVal points() As PointF _
)
'Usage

Dim instance As Draw
Dim points() As PointF

instance.Polygon(points)
public void Polygon(
   PointF[] points
)
public: void Polygon(
   PointF[]* points
)
public:
void Polygon(
   array<PointF>^ points
)

Parameters

points
A System.Drawing.PointF value which represents the coordinates for a polygon.

Remarks

The coordinates of the polygon must be within the physical area of the printer. To fill a polygon, set the FillColor and FillStyle properties of the object on which the polygon is drawn. Specify as many coordinates as needed to define the polygon (3 for a triangle, 4 for a square, etc.) The width of the line used to draw the rectangle depends on the setting of the Width property. The way the rectangle is drawn on the background depends on the setting of the Mode and Style properties

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Polygon(Point[],Color) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Polygon Method : Polygon(Point[],Color) Method

points
A System.Drawing.Point value which represents the coordinates for a polygon.
color
The System.Drawing.Color of the polygon’s outline.

Glossary Item Box

Draws a 3-6 sided polygon on a printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Polygon( _
   ByVal points() As Point, _
   ByVal color As Color _
)
'Usage

Dim instance As Draw
Dim points() As Point
Dim color As Color

instance.Polygon(points, color)
public void Polygon(
   Point[] points,
   Color color
)
public: void Polygon(
   Point[]* points,
   Color color
)
public:
void Polygon(
   array<Point>^ points,
   Color color
)

Parameters

points
A System.Drawing.Point value which represents the coordinates for a polygon.
color
The System.Drawing.Color of the polygon’s outline.

Remarks

The coordinates of the polygon must be within the physical area of the printer. To fill a polygon, set the FillColor and FillStyle properties of the object on which the polygon is drawn. Specify as many coordinates as needed to define the polygon (3 for a triangle, 4 for a square, etc.) The width of the line used to draw the rectangle depends on the setting of the Width property. The way the rectangle is drawn on the background depends on the setting of the Mode and Style properties

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Polygon(Point[]) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Polygon Method : Polygon(Point[]) Method

points
A System.Drawing.Point value which represents the coordinates for a polygon.

Glossary Item Box

Draws a 3-6 sided polygon on a printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Polygon( _
   ByVal points() As Point _
)
'Usage

Dim instance As Draw
Dim points() As Point

instance.Polygon(points)
public void Polygon(
   Point[] points
)
public: void Polygon(
   Point[]* points
)
public:
void Polygon(
   array<Point>^ points
)

Parameters

points
A System.Drawing.Point value which represents the coordinates for a polygon.

Remarks

The coordinates of the polygon must be within the physical area of the printer. To fill a polygon, set the FillColor and FillStyle properties of the object on which the polygon is drawn. Specify as many coordinates as needed to define the polygon (3 for a triangle, 4 for a square, etc.) The width of the line used to draw the rectangle depends on the setting of the Width property. The way the rectangle is drawn on the background depends on the setting of the Mode and Style properties

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Rectangle Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class : Rectangle Method

Glossary Item Box

Draws a rectangle on a printer.

Overload List

Overload | Description
Rectangle(PointF,PointF,Color,Boolean) | Draws a rectangle on a printer.
Rectangle(RectangleF,Color,Boolean) | Draws a rectangle on a printer.
Rectangle(PointF,PointF,Color) | Draws a rectangle on a printer.
Rectangle(RectangleF,Color) | Draws a rectangle on a printer.
Rectangle(PointF,PointF,Boolean) | Draws a black rectangle on a printer.
Rectangle(RectangleF,Boolean) | Draws a black rectangle on a printer.
Rectangle(PointF,PointF) | Draws a black rectangle on a printer.
Rectangle(RectangleF) | Draws a black rectangle on a printer.
Rectangle(PointF,Color,Boolean) | Draws a rectangle on a printer starting at the current draw location.
Rectangle(PointF,Color) | Draws a rectangle on a printer starting at the current draw coordinate.
Rectangle(PointF,Boolean) | Draws a black rectangle on a printer starting at the current draw coordinate.
Rectangle(PointF) | Draws a black rectangle on a printer starting from the current draw coordinate.
Rectangle(Point,Point,Color,Boolean) | Draws a rectangle on a printer.
Rectangle(Rectangle,Color,Boolean) | Draws a rectangle on a printer.
Rectangle(Point,Point,Color) | Draws a rectangle on a printer.
Rectangle(Rectangle,Color) | Draws a rectangle on a printer.
Rectangle(Point,Point,Boolean) | Draws a black rectangle on a printer.
Rectangle(Rectangle,Boolean) | Draws a black rectangle on a printer.
Rectangle(Point,Point) | Draws a black rectangle on a printer.
Rectangle(Rectangle) | Draws a black rectangle on a printer.
Rectangle(Point,Color,Boolean) | Draws a rectangle on a printer starting at the current draw location.
Rectangle(Point,Color) | Draws a rectangle on a printer starting at the current draw coordinate.
Rectangle(Point,Boolean) | Draws a black rectangle on a printer starting at the current draw coordinate.
Rectangle(Point) | Draws a black rectangle on a printer starting from the current draw coordinate.

See Also

Reference

Draw Class
Draw Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Rectangle(PointF,PointF,Color,Boolean) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Rectangle Method : Rectangle(PointF,PointF,Color,Boolean) Method

startPoint
A System.Drawing.Point which represents the coordinate of the starting point for the rectangle.
endPoint
A System.Drawing.Point which represents the coordinate of the end point for the rectangle being drawn.
color
The System.Drawing.Color used to draw the rectangle.
fill
A boolean value which when true, the Color parameter is used to fill the rectangle and the FillColor and FillStyle properties are ignored.

Glossary Item Box

Draws a rectangle on a printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Rectangle( _
   ByVal startPoint As PointF, _
   ByVal endPoint As PointF, _
   ByVal color As Color, _
   ByVal fill As Boolean _
)
'Usage

Dim instance As Draw
Dim startPoint As PointF
Dim endPoint As PointF
Dim color As Color
Dim fill As Boolean

instance.Rectangle(startPoint, endPoint, color, fill)
public void Rectangle(
   PointF startPoint,
   PointF endPoint,
   Color color,
   bool fill
)
public: void Rectangle(
   PointF startPoint,
   PointF endPoint,
   Color color,
   bool fill
)
public:
void Rectangle(
   PointF startPoint,
   PointF endPoint,
   Color color,
   bool fill
)

Parameters

startPoint
A System.Drawing.Point which represents the coordinate of the starting point for the rectangle.
endPoint
A System.Drawing.Point which represents the coordinate of the end point for the rectangle being drawn.
color
The System.Drawing.Color used to draw the rectangle.
fill
A boolean value which when true, the Color parameter is used to fill the rectangle and the FillColor and FillStyle properties are ignored.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Rectangle(RectangleF,Color,Boolean) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Rectangle Method : Rectangle(RectangleF,Color,Boolean) Method

boundingBox
A System.Drawing.RectangleF which represents the coordinates used to draw the rectangle.
color
The System.Drawing.Color used to draw the rectangle.
fill
A boolean value which when true, the Color parameter is used to fill the rectangle and the FillColor and FillStyle properties are ignored.

Glossary Item Box

Draws a rectangle on a printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Rectangle( _
   ByVal boundingBox As RectangleF, _
   ByVal color As Color, _
   ByVal fill As Boolean _
)
'Usage

Dim instance As Draw
Dim boundingBox As RectangleF
Dim color As Color
Dim fill As Boolean

instance.Rectangle(boundingBox, color, fill)
public void Rectangle(
   RectangleF boundingBox,
   Color color,
   bool fill
)
public: void Rectangle(
   RectangleF boundingBox,
   Color color,
   bool fill
)
public:
void Rectangle(
   RectangleF boundingBox,
   Color color,
   bool fill
)

Parameters

boundingBox
A System.Drawing.RectangleF which represents the coordinates used to draw the rectangle.
color
The System.Drawing.Color used to draw the rectangle.
fill
A boolean value which when true, the Color parameter is used to fill the rectangle and the FillColor and FillStyle properties are ignored.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Rectangle(PointF,PointF,Color) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Rectangle Method : Rectangle(PointF,PointF,Color) Method

startPoint
A System.Drawing.PointF which represents the coordinate of the starting point for the rectangle.
endPoint
A System.Drawing.PointF which represents the coordinate of the end point for the rectangle being drawn.
color
The System.Drawing.Color used to draw the rectangle.

Glossary Item Box

Draws a rectangle on a printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Rectangle( _
   ByVal startPoint As PointF, _
   ByVal endPoint As PointF, _
   ByVal color As Color _
)
'Usage

Dim instance As Draw
Dim startPoint As PointF
Dim endPoint As PointF
Dim color As Color

instance.Rectangle(startPoint, endPoint, color)
public void Rectangle(
   PointF startPoint,
   PointF endPoint,
   Color color
)
public: void Rectangle(
   PointF startPoint,
   PointF endPoint,
   Color color
)
public:
void Rectangle(
   PointF startPoint,
   PointF endPoint,
   Color color
)

Parameters

startPoint
A System.Drawing.PointF which represents the coordinate of the starting point for the rectangle.
endPoint
A System.Drawing.PointF which represents the coordinate of the end point for the rectangle being drawn.
color
The System.Drawing.Color used to draw the rectangle.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Rectangle(RectangleF,Color) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Rectangle Method : Rectangle(RectangleF,Color) Method

boundingBox
A System.Drawing.RectangleF which represents the coordinates used to draw the rectangle.
color
The System.Drawing.Color used to draw the rectangle.

Glossary Item Box

Draws a rectangle on a printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Rectangle( _
   ByVal boundingBox As RectangleF, _
   ByVal color As Color _
)
'Usage

Dim instance As Draw
Dim boundingBox As RectangleF
Dim color As Color

instance.Rectangle(boundingBox, color)
public void Rectangle(
   RectangleF boundingBox,
   Color color
)
public: void Rectangle(
   RectangleF boundingBox,
   Color color
)
public:
void Rectangle(
   RectangleF boundingBox,
   Color color
)

Parameters

boundingBox
A System.Drawing.RectangleF which represents the coordinates used to draw the rectangle.
color
The System.Drawing.Color used to draw the rectangle.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Rectangle(PointF,PointF,Boolean) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Rectangle Method : Rectangle(PointF,PointF,Boolean) Method

startPoint
A System.Drawing.PointF which represents the coordinate of the starting point for the rectangle.
endPoint
A System.Drawing.PointF which represents the coordinate of the end point for the rectangle being drawn.
fill
A boolean value which when true, the black is used to fill the rectangle and the FillColor and FillStyle properties are ignored.

Glossary Item Box

Draws a black rectangle on a printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Rectangle( _
   ByVal startPoint As PointF, _
   ByVal endPoint As PointF, _
   ByVal fill As Boolean _
)
'Usage

Dim instance As Draw
Dim startPoint As PointF
Dim endPoint As PointF
Dim fill As Boolean

instance.Rectangle(startPoint, endPoint, fill)
public void Rectangle(
   PointF startPoint,
   PointF endPoint,
   bool fill
)
public: void Rectangle(
   PointF startPoint,
   PointF endPoint,
   bool fill
)
public:
void Rectangle(
   PointF startPoint,
   PointF endPoint,
   bool fill
)

Parameters

startPoint
A System.Drawing.PointF which represents the coordinate of the starting point for the rectangle.
endPoint
A System.Drawing.PointF which represents the coordinate of the end point for the rectangle being drawn.
fill
A boolean value which when true, the black is used to fill the rectangle and the FillColor and FillStyle properties are ignored.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Rectangle(RectangleF,Boolean) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Rectangle Method : Rectangle(RectangleF,Boolean) Method

boundingBox
A System.Drawing.RectangleF which represents the coordinates used to draw the rectangle.
fill
A boolean value which when true, the Color parameter is used to fill the rectangle and the FillColor and FillStyle properties are ignored.

Glossary Item Box

Draws a black rectangle on a printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Rectangle( _
   ByVal boundingBox As RectangleF, _
   ByVal fill As Boolean _
)
'Usage

Dim instance As Draw
Dim boundingBox As RectangleF
Dim fill As Boolean

instance.Rectangle(boundingBox, fill)
public void Rectangle(
   RectangleF boundingBox,
   bool fill
)
public: void Rectangle(
   RectangleF boundingBox,
   bool fill
)
public:
void Rectangle(
   RectangleF boundingBox,
   bool fill
)

Parameters

boundingBox
A System.Drawing.RectangleF which represents the coordinates used to draw the rectangle.
fill
A boolean value which when true, the Color parameter is used to fill the rectangle and the FillColor and FillStyle properties are ignored.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Rectangle(PointF,PointF) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Rectangle Method : Rectangle(PointF,PointF) Method

startPoint
A System.Drawing.PointF which represents the coordinate of the starting point for the rectangle.
endPoint
A System.Drawing.PointF which represents the coordinate of the end point for the rectangle being drawn.

Glossary Item Box

Draws a black rectangle on a printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Rectangle( _
   ByVal startPoint As PointF, _
   ByVal endPoint As PointF _
)
'Usage

Dim instance As Draw
Dim startPoint As PointF
Dim endPoint As PointF

instance.Rectangle(startPoint, endPoint)
public void Rectangle(
   PointF startPoint,
   PointF endPoint
)
public: void Rectangle(
   PointF startPoint,
   PointF endPoint
)
public:
void Rectangle(
   PointF startPoint,
   PointF endPoint
)

Parameters

startPoint
A System.Drawing.PointF which represents the coordinate of the starting point for the rectangle.
endPoint
A System.Drawing.PointF which represents the coordinate of the end point for the rectangle being drawn.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Rectangle(RectangleF) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Rectangle Method : Rectangle(RectangleF) Method

boundingBox
A System.Drawing.Rectangle which represents the coordinates used to draw the rectangle.

Glossary Item Box

Draws a black rectangle on a printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Rectangle( _
   ByVal boundingBox As RectangleF _
)
'Usage

Dim instance As Draw
Dim boundingBox As RectangleF

instance.Rectangle(boundingBox)
public void Rectangle(
   RectangleF boundingBox
)
public: void Rectangle(
   RectangleF boundingBox
)
public:
void Rectangle(
   RectangleF boundingBox
)

Parameters

boundingBox
A System.Drawing.Rectangle which represents the coordinates used to draw the rectangle.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Rectangle(PointF,Color,Boolean) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Rectangle Method : Rectangle(PointF,Color,Boolean) Method

endPoint
A System.Drawing.PointF which represents the coordinate of the end point for the rectangle being drawn.
color
A System.Drawing.Color which represents the color used to draw the rectangle.
fill
A boolean value which when true, the Color parameter is used to fill the rectangle and the FillColor and FillStyle properties are ignored.

Glossary Item Box

Draws a rectangle on a printer starting at the current draw location.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Rectangle( _
   ByVal endPoint As PointF, _
   ByVal color As Color, _
   ByVal fill As Boolean _
)
'Usage

Dim instance As Draw
Dim endPoint As PointF
Dim color As Color
Dim fill As Boolean

instance.Rectangle(endPoint, color, fill)
public void Rectangle(
   PointF endPoint,
   Color color,
   bool fill
)
public: void Rectangle(
   PointF endPoint,
   Color color,
   bool fill
)
public:
void Rectangle(
   PointF endPoint,
   Color color,
   bool fill
)

Parameters

endPoint
A System.Drawing.PointF which represents the coordinate of the end point for the rectangle being drawn.
color
A System.Drawing.Color which represents the color used to draw the rectangle.
fill
A boolean value which when true, the Color parameter is used to fill the rectangle and the FillColor and FillStyle properties are ignored.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Rectangle(PointF,Color) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Rectangle Method : Rectangle(PointF,Color) Method

endPoint
A System.Drawing.PointF which represents the coordinate of the end point for the rectangle being drawn.
color
A System.Drawing.Color which represents the color used to draw the rectangle.

Glossary Item Box

Draws a rectangle on a printer starting at the current draw coordinate.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Rectangle( _
   ByVal endPoint As PointF, _
   ByVal color As Color _
)
'Usage

Dim instance As Draw
Dim endPoint As PointF
Dim color As Color

instance.Rectangle(endPoint, color)
public void Rectangle(
   PointF endPoint,
   Color color
)
public: void Rectangle(
   PointF endPoint,
   Color color
)
public:
void Rectangle(
   PointF endPoint,
   Color color
)

Parameters

endPoint
A System.Drawing.PointF which represents the coordinate of the end point for the rectangle being drawn.
color
A System.Drawing.Color which represents the color used to draw the rectangle.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Rectangle(PointF,Boolean) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Rectangle Method : Rectangle(PointF,Boolean) Method

endPoint
A System.Drawing.PointF which represents the coordinate of the end point for the rectangle being drawn.
fill
A boolean value which when true, the black is used to fill the rectangle and the FillColor and FillStyle properties are ignored.

Glossary Item Box

Draws a black rectangle on a printer starting at the current draw coordinate.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Rectangle( _
   ByVal endPoint As PointF, _
   ByVal fill As Boolean _
)
'Usage

Dim instance As Draw
Dim endPoint As PointF
Dim fill As Boolean

instance.Rectangle(endPoint, fill)
public void Rectangle(
   PointF endPoint,
   bool fill
)
public: void Rectangle(
   PointF endPoint,
   bool fill
)
public:
void Rectangle(
   PointF endPoint,
   bool fill
)

Parameters

endPoint
A System.Drawing.PointF which represents the coordinate of the end point for the rectangle being drawn.
fill
A boolean value which when true, the black is used to fill the rectangle and the FillColor and FillStyle properties are ignored.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Rectangle(PointF) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Rectangle Method : Rectangle(PointF) Method

endPoint
A System.Drawing.PointF which represents the coordinate of the end point for the rectangle being drawn.

Glossary Item Box

Draws a black rectangle on a printer starting from the current draw coordinate.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Rectangle( _
   ByVal endPoint As PointF _
)
'Usage

Dim instance As Draw
Dim endPoint As PointF

instance.Rectangle(endPoint)
public void Rectangle(
   PointF endPoint
)
public: void Rectangle(
   PointF endPoint
)
public:
void Rectangle(
   PointF endPoint
)

Parameters

endPoint
A System.Drawing.PointF which represents the coordinate of the end point for the rectangle being drawn.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Rectangle(Point,Point,Color,Boolean) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Rectangle Method : Rectangle(Point,Point,Color,Boolean) Method

startPoint
A System.Drawing.PointF which represents the coordinate of the starting point for the rectangle.
endPoint
A System.Drawing.PointF which represents the coordinate of the end point for the rectangle being drawn.
color
A System.Drawing.Color which represents the color used to draw the rectangle.
fill
A boolean value which when true, the Color parameter is used to fill the rectangle and the FillColor and FillStyle properties are ignored.

Glossary Item Box

Draws a rectangle on a printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Rectangle( _
   ByVal startPoint As Point, _
   ByVal endPoint As Point, _
   ByVal color As Color, _
   ByVal fill As Boolean _
)
'Usage

Dim instance As Draw
Dim startPoint As Point
Dim endPoint As Point
Dim color As Color
Dim fill As Boolean

instance.Rectangle(startPoint, endPoint, color, fill)
public void Rectangle(
   Point startPoint,
   Point endPoint,
   Color color,
   bool fill
)
public: void Rectangle(
   Point startPoint,
   Point endPoint,
   Color color,
   bool fill
)
public:
void Rectangle(
   Point startPoint,
   Point endPoint,
   Color color,
   bool fill
)

Parameters

startPoint
A System.Drawing.PointF which represents the coordinate of the starting point for the rectangle.
endPoint
A System.Drawing.PointF which represents the coordinate of the end point for the rectangle being drawn.
color
A System.Drawing.Color which represents the color used to draw the rectangle.
fill
A boolean value which when true, the Color parameter is used to fill the rectangle and the FillColor and FillStyle properties are ignored.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Rectangle(Rectangle,Color,Boolean) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Rectangle Method : Rectangle(Rectangle,Color,Boolean) Method

boundingBox
A System.Drawing.Rectangle which represents the coordinates used to draw the rectangle.
color
A System.Drawing.Color which represents the color used to draw the rectangle.
fill
A boolean value which when true, the Color parameter is used to fill the rectangle and the FillColor and FillStyle properties are ignored.

Glossary Item Box

Draws a rectangle on a printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Rectangle( _
   ByVal boundingBox As Rectangle, _
   ByVal color As Color, _
   ByVal fill As Boolean _
)
'Usage

Dim instance As Draw
Dim boundingBox As Rectangle
Dim color As Color
Dim fill As Boolean

instance.Rectangle(boundingBox, color, fill)
public void Rectangle(
   Rectangle boundingBox,
   Color color,
   bool fill
)
public: void Rectangle(
   Rectangle boundingBox,
   Color color,
   bool fill
)
public:
void Rectangle(
   Rectangle boundingBox,
   Color color,
   bool fill
)

Parameters

boundingBox
A System.Drawing.Rectangle which represents the coordinates used to draw the rectangle.
color
A System.Drawing.Color which represents the color used to draw the rectangle.
fill
A boolean value which when true, the Color parameter is used to fill the rectangle and the FillColor and FillStyle properties are ignored.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Rectangle(Point,Point,Color) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Rectangle Method : Rectangle(Point,Point,Color) Method

startPoint
A System.Drawing.Point which represents the coordinate of the starting point for the rectangle.
endPoint
A System.Drawing.Point which represents the coordinate of the end point for the rectangle being drawn.
color
The System.Drawing.Color used to draw the rectangle.

Glossary Item Box

Draws a rectangle on a printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Rectangle( _
   ByVal startPoint As Point, _
   ByVal endPoint As Point, _
   ByVal color As Color _
)
'Usage

Dim instance As Draw
Dim startPoint As Point
Dim endPoint As Point
Dim color As Color

instance.Rectangle(startPoint, endPoint, color)
public void Rectangle(
   Point startPoint,
   Point endPoint,
   Color color
)
public: void Rectangle(
   Point startPoint,
   Point endPoint,
   Color color
)
public:
void Rectangle(
   Point startPoint,
   Point endPoint,
   Color color
)

Parameters

startPoint
A System.Drawing.Point which represents the coordinate of the starting point for the rectangle.
endPoint
A System.Drawing.Point which represents the coordinate of the end point for the rectangle being drawn.
color
The System.Drawing.Color used to draw the rectangle.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Rectangle(Rectangle,Color) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Rectangle Method : Rectangle(Rectangle,Color) Method

boundingBox
A System.Drawing.Rectangle which represents the coordinates used to draw the rectangle
color
The System.Drawing.Color used to draw the rectangle.

Glossary Item Box

Draws a rectangle on a printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Rectangle( _
   ByVal boundingBox As Rectangle, _
   ByVal color As Color _
)
'Usage

Dim instance As Draw
Dim boundingBox As Rectangle
Dim color As Color

instance.Rectangle(boundingBox, color)
public void Rectangle(
   Rectangle boundingBox,
   Color color
)
public: void Rectangle(
   Rectangle boundingBox,
   Color color
)
public:
void Rectangle(
   Rectangle boundingBox,
   Color color
)

Parameters

boundingBox
A System.Drawing.Rectangle which represents the coordinates used to draw the rectangle
color
The System.Drawing.Color used to draw the rectangle.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Rectangle(Point,Point,Boolean) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Rectangle Method : Rectangle(Point,Point,Boolean) Method

startPoint
A System.Drawing.Point which represents the coordinate of the starting point for the rectangle.
endPoint
A System.Drawing.Point which represents the coordinate of the end point for the rectangle being drawn.
fill
A boolean value which when true, the Color parameter is used to fill the rectangle and the FillColor and FillStyle properties are ignored.

Glossary Item Box

Draws a black rectangle on a printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Rectangle( _
   ByVal startPoint As Point, _
   ByVal endPoint As Point, _
   ByVal fill As Boolean _
)
'Usage

Dim instance As Draw
Dim startPoint As Point
Dim endPoint As Point
Dim fill As Boolean

instance.Rectangle(startPoint, endPoint, fill)
public void Rectangle(
   Point startPoint,
   Point endPoint,
   bool fill
)
public: void Rectangle(
   Point startPoint,
   Point endPoint,
   bool fill
)
public:
void Rectangle(
   Point startPoint,
   Point endPoint,
   bool fill
)

Parameters

startPoint
A System.Drawing.Point which represents the coordinate of the starting point for the rectangle.
endPoint
A System.Drawing.Point which represents the coordinate of the end point for the rectangle being drawn.
fill
A boolean value which when true, the Color parameter is used to fill the rectangle and the FillColor and FillStyle properties are ignored.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Rectangle(Rectangle,Boolean) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Rectangle Method : Rectangle(Rectangle,Boolean) Method

boundingBox
A System.Drawing.Rectangle which represents the coordinates used to draw the rectangle
fill
A boolean value which when true, the Color parameter is used to fill the rectangle and the FillColor and FillStyle properties are ignored.

Glossary Item Box

Draws a black rectangle on a printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Rectangle( _
   ByVal boundingBox As Rectangle, _
   ByVal fill As Boolean _
)
'Usage

Dim instance As Draw
Dim boundingBox As Rectangle
Dim fill As Boolean

instance.Rectangle(boundingBox, fill)
public void Rectangle(
   Rectangle boundingBox,
   bool fill
)
public: void Rectangle(
   Rectangle boundingBox,
   bool fill
)
public:
void Rectangle(
   Rectangle boundingBox,
   bool fill
)

Parameters

boundingBox
A System.Drawing.Rectangle which represents the coordinates used to draw the rectangle
fill
A boolean value which when true, the Color parameter is used to fill the rectangle and the FillColor and FillStyle properties are ignored.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Rectangle(Point,Point) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Rectangle Method : Rectangle(Point,Point) Method

startPoint
A System.Drawing.Point which represents the coordinate of the starting point for the rectangle.
endPoint
A System.Drawing.Point which represents the coordinate of the end point for the rectangle being drawn.

Glossary Item Box

Draws a black rectangle on a printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Rectangle( _
   ByVal startPoint As Point, _
   ByVal endPoint As Point _
)
'Usage

Dim instance As Draw
Dim startPoint As Point
Dim endPoint As Point

instance.Rectangle(startPoint, endPoint)
public void Rectangle(
   Point startPoint,
   Point endPoint
)
public: void Rectangle(
   Point startPoint,
   Point endPoint
)
public:
void Rectangle(
   Point startPoint,
   Point endPoint
)

Parameters

startPoint
A System.Drawing.Point which represents the coordinate of the starting point for the rectangle.
endPoint
A System.Drawing.Point which represents the coordinate of the end point for the rectangle being drawn.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Rectangle(Rectangle) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Rectangle Method : Rectangle(Rectangle) Method

boundingBox
A System.Drawing.Rectangle which represents the coordinates used to draw the rectangle

Glossary Item Box

Draws a black rectangle on a printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Rectangle( _
   ByVal boundingBox As Rectangle _
)
'Usage

Dim instance As Draw
Dim boundingBox As Rectangle

instance.Rectangle(boundingBox)
public void Rectangle(
   Rectangle boundingBox
)
public: void Rectangle(
   Rectangle boundingBox
)
public:
void Rectangle(
   Rectangle boundingBox
)

Parameters

boundingBox
A System.Drawing.Rectangle which represents the coordinates used to draw the rectangle

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Rectangle(Point,Color,Boolean) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Rectangle Method : Rectangle(Point,Color,Boolean) Method

endPoint
A System.Drawing.Point which represents the coordinate of the end point for the rectangle being drawn.
color
The System.Drawing.Color used to draw the rectangle.
fill
A boolean value which when true, the Color parameter is used to fill the rectangle and the FillColor and FillStyle properties are ignored.

Glossary Item Box

Draws a rectangle on a printer starting at the current draw location.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Rectangle( _
   ByVal endPoint As Point, _
   ByVal color As Color, _
   ByVal fill As Boolean _
)
'Usage

Dim instance As Draw
Dim endPoint As Point
Dim color As Color
Dim fill As Boolean

instance.Rectangle(endPoint, color, fill)
public void Rectangle(
   Point endPoint,
   Color color,
   bool fill
)
public: void Rectangle(
   Point endPoint,
   Color color,
   bool fill
)
public:
void Rectangle(
   Point endPoint,
   Color color,
   bool fill
)

Parameters

endPoint
A System.Drawing.Point which represents the coordinate of the end point for the rectangle being drawn.
color
The System.Drawing.Color used to draw the rectangle.
fill
A boolean value which when true, the Color parameter is used to fill the rectangle and the FillColor and FillStyle properties are ignored.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Rectangle(Point,Color) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Rectangle Method : Rectangle(Point,Color) Method

endPoint
A System.Drawing.Point which represents the coordinate of the end point for the rectangle being drawn.
color
The System.Drawing.Color used to draw the rectangle.

Glossary Item Box

Draws a rectangle on a printer starting at the current draw coordinate.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Rectangle( _
   ByVal endPoint As Point, _
   ByVal color As Color _
)
'Usage

Dim instance As Draw
Dim endPoint As Point
Dim color As Color

instance.Rectangle(endPoint, color)
public void Rectangle(
   Point endPoint,
   Color color
)
public: void Rectangle(
   Point endPoint,
   Color color
)
public:
void Rectangle(
   Point endPoint,
   Color color
)

Parameters

endPoint
A System.Drawing.Point which represents the coordinate of the end point for the rectangle being drawn.
color
The System.Drawing.Color used to draw the rectangle.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Rectangle(Point,Boolean) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Rectangle Method : Rectangle(Point,Boolean) Method

endPoint
A System.Drawing.Point which represents the coordinate of the end point for the rectangle being drawn.
fill
A boolean value which when true, the Color parameter is used to fill the rectangle and the FillColor and FillStyle properties are ignored.

Glossary Item Box

Draws a black rectangle on a printer starting at the current draw coordinate.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Rectangle( _
   ByVal endPoint As Point, _
   ByVal fill As Boolean _
)
'Usage

Dim instance As Draw
Dim endPoint As Point
Dim fill As Boolean

instance.Rectangle(endPoint, fill)
public void Rectangle(
   Point endPoint,
   bool fill
)
public: void Rectangle(
   Point endPoint,
   bool fill
)
public:
void Rectangle(
   Point endPoint,
   bool fill
)

Parameters

endPoint
A System.Drawing.Point which represents the coordinate of the end point for the rectangle being drawn.
fill
A boolean value which when true, the Color parameter is used to fill the rectangle and the FillColor and FillStyle properties are ignored.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Rectangle(Point) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Rectangle Method : Rectangle(Point) Method

endPoint
A System.Drawing.Point which represents the coordinate of the end point for the rectangle being drawn.

Glossary Item Box

Draws a black rectangle on a printer starting from the current draw coordinate.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Rectangle( _
   ByVal endPoint As Point _
)
'Usage

Dim instance As Draw
Dim endPoint As Point

instance.Rectangle(endPoint)
public void Rectangle(
   Point endPoint
)
public: void Rectangle(
   Point endPoint
)
public:
void Rectangle(
   Point endPoint
)

Parameters

endPoint
A System.Drawing.Point which represents the coordinate of the end point for the rectangle being drawn.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
RoundRectangle Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class : RoundRectangle Method

Glossary Item Box

Draws a rectangle with rounded corners on printer.

Overload List

Overload | Description
RoundRectangle(PointF,PointF,Single,Color) | Draws a rectangle with rounded corners on printer.
RoundRectangle(RectangleF,Single,Color) | Draws a rectangle with rounded corners on printer.
RoundRectangle(PointF,PointF,Single,Single,Color) | Draws a rectangle with rounded corners on printer.
RoundRectangle(RectangleF,Single,Single,Color) | Draws a rectangle with rounded corners on printer.
RoundRectangle(PointF,PointF,Single) | Draws a black rectangle with rounded corners on printer.
RoundRectangle(RectangleF,Single) | Draws a rectangle with rounded corners on printer.
RoundRectangle(PointF,PointF,Single,Single) | Draws a black rectangle with rounded corners on printer.
RoundRectangle(RectangleF,Single,Single) | Draws a rectangle with rounded corners on printer.
RoundRectangle(Point,Point,Int32,Color) | Draws a rectangle with rounded corners on printer The coordinates of the round rectangle must be within the physical area of the printer. To fill a rounded rectangle, set the FillColor and FillStyle properties of the object on which the rectangle is drawn. The width of the line used to draw the rectangle depends on the setting of the Width property. The way the rectangle is drawn on the background depends on the setting of the Mode and Style properties
RoundRectangle(Rectangle,Int32,Color) | Draws a rectangle with rounded corners on printer The coordinates of the round rectangle must be within the physical area of the printer. To fill a rounded rectangle, set the FillColor and FillStyle properties of the object on which the rectangle is drawn. The width of the line used to draw the rectangle depends on the setting of the Width property. The way the rectangle is drawn on the background depends on the setting of the Mode and Style properties
RoundRectangle(Point,Point,Int32,Int32,Color) | Draws a rectangle with rounded corners on printer The coordinates of the round rectangle must be within the physical area of the printer. To fill a rounded rectangle, set the FillColor and FillStyle properties of the object on which the rectangle is drawn. The width of the line used to draw the rectangle depends on the setting of the Width property. The way the rectangle is drawn on the background depends on the setting of the Mode and Style properties
RoundRectangle(Rectangle,Int32,Int32,Color) | Draws a rectangle with rounded corners on printer The coordinates of the round rectangle must be within the physical area of the printer. To fill a rounded rectangle, set the FillColor and FillStyle properties of the object on which the rectangle is drawn. The width of the line used to draw the rectangle depends on the setting of the Width property. The way the rectangle is drawn on the background depends on the setting of the Mode and Style properties
RoundRectangle(Point,Point,Int32) | Draws a black rectangle with rounded corners on printer The coordinates of the round rectangle must be within the physical area of the printer. To fill a rounded rectangle, set the FillColor and FillStyle properties of the object on which the rectangle is drawn. The width of the line used to draw the rectangle depends on the setting of the Width property. The way the rectangle is drawn on the background depends on the setting of the Mode and Style properties
RoundRectangle(Rectangle,Int32) | Draws a rectangle with rounded corners on printer The coordinates of the round rectangle must be within the physical area of the printer. To fill a rounded rectangle, set the FillColor and FillStyle properties of the object on which the rectangle is drawn. The width of the line used to draw the rectangle depends on the setting of the Width property. The way the rectangle is drawn on the background depends on the setting of the Mode and Style properties
RoundRectangle(Point,Point,Int32,Int32) | Draws a black rectangle with rounded corners on printer The coordinates of the round rectangle must be within the physical area of the printer. To fill a rounded rectangle, set the FillColor and FillStyle properties of the object on which the rectangle is drawn. The width of the line used to draw the rectangle depends on the setting of the Width property. The way the rectangle is drawn on the background depends on the setting of the Mode and Style properties
RoundRectangle(Rectangle,Int32,Int32) | Draws a rectangle with rounded corners on printer.

See Also

Reference

Draw Class
Draw Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
RoundRectangle(PointF,PointF,Single,Color) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > RoundRectangle Method : RoundRectangle(PointF,PointF,Single,Color) Method

upperLeft
A System.Drawing.PointF which represents the upper-left coordinate.
lowerRight
A System.Drawing.PointF which represents the lower-right coordinate.
roundSize
A single-precision value that specifies the width and height of the ellipse used to draw the rounded corners. A negative value has the same effect as a positive value.
color
A System.Drawing.Color of the circle’s outline.

Glossary Item Box

Draws a rectangle with rounded corners on printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub RoundRectangle( _
   ByVal upperLeft As PointF, _
   ByVal lowerRight As PointF, _
   ByVal roundSize As Single, _
   ByVal color As Color _
)
'Usage

Dim instance As Draw
Dim upperLeft As PointF
Dim lowerRight As PointF
Dim roundSize As Single
Dim color As Color

instance.RoundRectangle(upperLeft, lowerRight, roundSize, color)
public void RoundRectangle(
   PointF upperLeft,
   PointF lowerRight,
   float roundSize,
   Color color
)
public: void RoundRectangle(
   PointF upperLeft,
   PointF lowerRight,
   float roundSize,
   Color color
)
public:
void RoundRectangle(
   PointF upperLeft,
   PointF lowerRight,
   float roundSize,
   Color color
)

Parameters

upperLeft
A System.Drawing.PointF which represents the upper-left coordinate.
lowerRight
A System.Drawing.PointF which represents the lower-right coordinate.
roundSize
A single-precision value that specifies the width and height of the ellipse used to draw the rounded corners. A negative value has the same effect as a positive value.
color
A System.Drawing.Color of the circle’s outline.

Remarks

The coordinates of the round rectangle must be within the physical area of the printer. To fill a rounded rectangle, set the FillColor and FillStyle properties of the object on which the rectangle is drawn.

The width of the line used to draw the rectangle depends on the setting of the Width property. The way the rectangle is drawn on the background depends on the setting of the Mode and Style properties.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
RoundRectangle(RectangleF,Single,Color) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > RoundRectangle Method : RoundRectangle(RectangleF,Single,Color) Method

boundingBox
A System.Drawing.RectangleF which represents the location of the rectangle.
roundSize
A single-precision value that specifies the width and height of the ellipse used to draw the rounded corners. A negative value has the same effect as a positive value.
color
A System.Drawing.Color of the circle’s outline.

Glossary Item Box

Draws a rectangle with rounded corners on printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub RoundRectangle( _
   ByVal boundingBox As RectangleF, _
   ByVal roundSize As Single, _
   ByVal color As Color _
)
'Usage

Dim instance As Draw
Dim boundingBox As RectangleF
Dim roundSize As Single
Dim color As Color

instance.RoundRectangle(boundingBox, roundSize, color)
public void RoundRectangle(
   RectangleF boundingBox,
   float roundSize,
   Color color
)
public: void RoundRectangle(
   RectangleF boundingBox,
   float roundSize,
   Color color
)
public:
void RoundRectangle(
   RectangleF boundingBox,
   float roundSize,
   Color color
)

Parameters

boundingBox
A System.Drawing.RectangleF which represents the location of the rectangle.
roundSize
A single-precision value that specifies the width and height of the ellipse used to draw the rounded corners. A negative value has the same effect as a positive value.
color
A System.Drawing.Color of the circle’s outline.

Remarks

The coordinates of the round rectangle must be within the physical area of the printer. To fill a rounded rectangle, set the FillColor and FillStyle properties of the object on which the rectangle is drawn.

The width of the line used to draw the rectangle depends on the setting of the Width property. The way the rectangle is drawn on the background depends on the setting of the Mode and Style properties.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
RoundRectangle(PointF,PointF,Single,Single,Color) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > RoundRectangle Method : RoundRectangle(PointF,PointF,Single,Single,Color) Method

upperLeft
A System.Drawing.PointF which represents the upper-left coordinate.
lowerRight
A System.Drawing.PointF which represents the lower-right coordinate.
roundWidth
A single-precision value that specifies the width of the ellipse used to draw the rounded corners. A negative value has the same effect as its positive counterpart.
roundHeight
A single-precision value that specifies the height of the ellipse used to draw the rounded corners. A negative value has the same effect as its positive counterpart.
color
A System.Drawing.Color of the circle’s outline.

Glossary Item Box

Draws a rectangle with rounded corners on printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub RoundRectangle( _
   ByVal upperLeft As PointF, _
   ByVal lowerRight As PointF, _
   ByVal roundWidth As Single, _
   ByVal roundHeight As Single, _
   ByVal color As Color _
)
'Usage

Dim instance As Draw
Dim upperLeft As PointF
Dim lowerRight As PointF
Dim roundWidth As Single
Dim roundHeight As Single
Dim color As Color

instance.RoundRectangle(upperLeft, lowerRight, roundWidth, roundHeight, color)
public void RoundRectangle(
   PointF upperLeft,
   PointF lowerRight,
   float roundWidth,
   float roundHeight,
   Color color
)
public: void RoundRectangle(
   PointF upperLeft,
   PointF lowerRight,
   float roundWidth,
   float roundHeight,
   Color color
)
public:
void RoundRectangle(
   PointF upperLeft,
   PointF lowerRight,
   float roundWidth,
   float roundHeight,
   Color color
)

Parameters

upperLeft
A System.Drawing.PointF which represents the upper-left coordinate.
lowerRight
A System.Drawing.PointF which represents the lower-right coordinate.
roundWidth
A single-precision value that specifies the width of the ellipse used to draw the rounded corners. A negative value has the same effect as its positive counterpart.
roundHeight
A single-precision value that specifies the height of the ellipse used to draw the rounded corners. A negative value has the same effect as its positive counterpart.
color
A System.Drawing.Color of the circle’s outline.

Remarks

The coordinates of the round rectangle must be within the physical area of the printer. To fill a rounded rectangle, set the FillColor and FillStyle properties of the object on which the rectangle is drawn.

The width of the line used to draw the rectangle depends on the setting of the Width property. The way the rectangle is drawn on the background depends on the setting of the Mode and Style properties.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
RoundRectangle(RectangleF,Single,Single,Color) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > RoundRectangle Method : RoundRectangle(RectangleF,Single,Single,Color) Method

boundingBox
A System.Drawing.RectangleF which represents the location of the rectangle.
roundWidth
A single-precision value that specifies the width of the ellipse used to draw the rounded corners. A negative value has the same effect as its positive counterpart.
roundHeight
A single-precision value that specifies the height of the ellipse used to draw the rounded corners. A negative value has the same effect as its positive counterpart.
color
A System.Drawing.Color which represents the Color of the circle’s outline.

Glossary Item Box

Draws a rectangle with rounded corners on printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub RoundRectangle( _
   ByVal boundingBox As RectangleF, _
   ByVal roundWidth As Single, _
   ByVal roundHeight As Single, _
   ByVal color As Color _
)
'Usage

Dim instance As Draw
Dim boundingBox As RectangleF
Dim roundWidth As Single
Dim roundHeight As Single
Dim color As Color

instance.RoundRectangle(boundingBox, roundWidth, roundHeight, color)
public void RoundRectangle(
   RectangleF boundingBox,
   float roundWidth,
   float roundHeight,
   Color color
)
public: void RoundRectangle(
   RectangleF boundingBox,
   float roundWidth,
   float roundHeight,
   Color color
)
public:
void RoundRectangle(
   RectangleF boundingBox,
   float roundWidth,
   float roundHeight,
   Color color
)

Parameters

boundingBox
A System.Drawing.RectangleF which represents the location of the rectangle.
roundWidth
A single-precision value that specifies the width of the ellipse used to draw the rounded corners. A negative value has the same effect as its positive counterpart.
roundHeight
A single-precision value that specifies the height of the ellipse used to draw the rounded corners. A negative value has the same effect as its positive counterpart.
color
A System.Drawing.Color which represents the Color of the circle’s outline.

Remarks

The coordinates of the round rectangle must be within the physical area of the printer. To fill a rounded rectangle, set the FillColor and FillStyle properties of the object on which the rectangle is drawn.

The width of the line used to draw the rectangle depends on the setting of the Width property. The way the rectangle is drawn on the background depends on the setting of the Mode and Style properties.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
RoundRectangle(PointF,PointF,Single) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > RoundRectangle Method : RoundRectangle(PointF,PointF,Single) Method

upperLeft
A System.Drawing.PointF which represents the upper-left coordinate.
lowerRight
A System.Drawing.PointF which represents the lower-right coordinate.
roundSize
A single-precision value that specifies the width and height of the ellipse used to draw the rounded corners. A negative value has the same effect as a positive value.

Glossary Item Box

Draws a black rectangle with rounded corners on printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub RoundRectangle( _
   ByVal upperLeft As PointF, _
   ByVal lowerRight As PointF, _
   ByVal roundSize As Single _
)
'Usage

Dim instance As Draw
Dim upperLeft As PointF
Dim lowerRight As PointF
Dim roundSize As Single

instance.RoundRectangle(upperLeft, lowerRight, roundSize)
public void RoundRectangle(
   PointF upperLeft,
   PointF lowerRight,
   float roundSize
)
public: void RoundRectangle(
   PointF upperLeft,
   PointF lowerRight,
   float roundSize
)
public:
void RoundRectangle(
   PointF upperLeft,
   PointF lowerRight,
   float roundSize
)

Parameters

upperLeft
A System.Drawing.PointF which represents the upper-left coordinate.
lowerRight
A System.Drawing.PointF which represents the lower-right coordinate.
roundSize
A single-precision value that specifies the width and height of the ellipse used to draw the rounded corners. A negative value has the same effect as a positive value.

Remarks

The coordinates of the round rectangle must be within the physical area of the printer. To fill a rounded rectangle, set the FillColor and FillStyle properties of the object on which the rectangle is drawn.

The width of the line used to draw the rectangle depends on the setting of the Width property. The way the rectangle is drawn on the background depends on the setting of the Mode and Style properties.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
RoundRectangle(RectangleF,Single) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > RoundRectangle Method : RoundRectangle(RectangleF,Single) Method

boundingBox
A System.Drawing.RectangleF which represents the location of the rectangle.
roundSize
A single-precision value that specifies the width and height of the ellipse used to draw the rounded corners. A negative value has the same effect as a positive value.

Glossary Item Box

Draws a rectangle with rounded corners on printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub RoundRectangle( _
   ByVal boundingBox As RectangleF, _
   ByVal roundSize As Single _
)
'Usage

Dim instance As Draw
Dim boundingBox As RectangleF
Dim roundSize As Single

instance.RoundRectangle(boundingBox, roundSize)
public void RoundRectangle(
   RectangleF boundingBox,
   float roundSize
)
public: void RoundRectangle(
   RectangleF boundingBox,
   float roundSize
)
public:
void RoundRectangle(
   RectangleF boundingBox,
   float roundSize
)

Parameters

boundingBox
A System.Drawing.RectangleF which represents the location of the rectangle.
roundSize
A single-precision value that specifies the width and height of the ellipse used to draw the rounded corners. A negative value has the same effect as a positive value.

Remarks

The coordinates of the round rectangle must be within the physical area of the printer. To fill a rounded rectangle, set the FillColor and FillStyle properties of the object on which the rectangle is drawn.

The width of the line used to draw the rectangle depends on the setting of the Width property. The way the rectangle is drawn on the background depends on the setting of the Mode and Style properties.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
RoundRectangle(PointF,PointF,Single,Single) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > RoundRectangle Method : RoundRectangle(PointF,PointF,Single,Single) Method

upperLeft
A System.Drawing.PointF which represents the upper-left coordinate.
lowerRight
A System.Drawing.PointF which represents the the lower-right coordinate.
roundWidth
A single-precision value that specifies the width of the ellipse used to draw the rounded corners. A negative value has the same effect as its positive counterpart.
roundHeight
A single-precision value that specifies the height of the ellipse used to draw the rounded corners. A negative value has the same effect as its positive counterpart.

Glossary Item Box

Draws a black rectangle with rounded corners on printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub RoundRectangle( _
   ByVal upperLeft As PointF, _
   ByVal lowerRight As PointF, _
   ByVal roundWidth As Single, _
   ByVal roundHeight As Single _
)
'Usage

Dim instance As Draw
Dim upperLeft As PointF
Dim lowerRight As PointF
Dim roundWidth As Single
Dim roundHeight As Single

instance.RoundRectangle(upperLeft, lowerRight, roundWidth, roundHeight)
public void RoundRectangle(
   PointF upperLeft,
   PointF lowerRight,
   float roundWidth,
   float roundHeight
)
public: void RoundRectangle(
   PointF upperLeft,
   PointF lowerRight,
   float roundWidth,
   float roundHeight
)
public:
void RoundRectangle(
   PointF upperLeft,
   PointF lowerRight,
   float roundWidth,
   float roundHeight
)

Parameters

upperLeft
A System.Drawing.PointF which represents the upper-left coordinate.
lowerRight
A System.Drawing.PointF which represents the the lower-right coordinate.
roundWidth
A single-precision value that specifies the width of the ellipse used to draw the rounded corners. A negative value has the same effect as its positive counterpart.
roundHeight
A single-precision value that specifies the height of the ellipse used to draw the rounded corners. A negative value has the same effect as its positive counterpart.

Remarks

The coordinates of the round rectangle must be within the physical area of the printer. To fill a rounded rectangle, set the FillColor and FillStyle properties of the object on which the rectangle is drawn.

The width of the line used to draw the rectangle depends on the setting of the Width property. The way the rectangle is drawn on the background depends on the setting of the Mode and Style properties.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
RoundRectangle(RectangleF,Single,Single) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > RoundRectangle Method : RoundRectangle(RectangleF,Single,Single) Method

boundingBox
A System.Drawing.RectangleF which represents the location of the rectangle.
roundWidth
A single-precision value that specifies the width of the ellipse used to draw the rounded corners. A negative value has the same effect as its positive counterpart.
roundHeight
A single-precision value that specifies the height of the ellipse used to draw the rounded corners. A negative value has the same effect as its positive counterpart.

Glossary Item Box

Draws a rectangle with rounded corners on printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub RoundRectangle( _
   ByVal boundingBox As RectangleF, _
   ByVal roundWidth As Single, _
   ByVal roundHeight As Single _
)
'Usage

Dim instance As Draw
Dim boundingBox As RectangleF
Dim roundWidth As Single
Dim roundHeight As Single

instance.RoundRectangle(boundingBox, roundWidth, roundHeight)
public void RoundRectangle(
   RectangleF boundingBox,
   float roundWidth,
   float roundHeight
)
public: void RoundRectangle(
   RectangleF boundingBox,
   float roundWidth,
   float roundHeight
)
public:
void RoundRectangle(
   RectangleF boundingBox,
   float roundWidth,
   float roundHeight
)

Parameters

boundingBox
A System.Drawing.RectangleF which represents the location of the rectangle.
roundWidth
A single-precision value that specifies the width of the ellipse used to draw the rounded corners. A negative value has the same effect as its positive counterpart.
roundHeight
A single-precision value that specifies the height of the ellipse used to draw the rounded corners. A negative value has the same effect as its positive counterpart.

Remarks

The coordinates of the round rectangle must be within the physical area of the printer. To fill a rounded rectangle, set the FillColor and FillStyle properties of the object on which the rectangle is drawn.

The width of the line used to draw the rectangle depends on the setting of the Width property. The way the rectangle is drawn on the background depends on the setting of the Mode and Style properties.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
RoundRectangle(Point,Point,Int32,Color) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > RoundRectangle Method : RoundRectangle(Point,Point,Int32,Color) Method

upperLeft
the upper-left coordinate
lowerRight
the lower-right coordinate
roundSize
A single-precision value that specifies the width and height of the ellipse used to draw the rounded corners. A negative value has the same effect as a positive value.
color
Color of the circle’s outline

Glossary Item Box

Draws a rectangle with rounded corners on printer The coordinates of the round rectangle must be within the physical area of the printer. To fill a rounded rectangle, set the FillColor and FillStyle properties of the object on which the rectangle is drawn. The width of the line used to draw the rectangle depends on the setting of the Width property. The way the rectangle is drawn on the background depends on the setting of the Mode and Style properties

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub RoundRectangle( _
   ByVal upperLeft As Point, _
   ByVal lowerRight As Point, _
   ByVal roundSize As Integer, _
   ByVal color As Color _
)
'Usage

Dim instance As Draw
Dim upperLeft As Point
Dim lowerRight As Point
Dim roundSize As Integer
Dim color As Color

instance.RoundRectangle(upperLeft, lowerRight, roundSize, color)
public void RoundRectangle(
   Point upperLeft,
   Point lowerRight,
   int roundSize,
   Color color
)
public: void RoundRectangle(
   Point upperLeft,
   Point lowerRight,
   int roundSize,
   Color color
)
public:
void RoundRectangle(
   Point upperLeft,
   Point lowerRight,
   int roundSize,
   Color color
)

Parameters

upperLeft
the upper-left coordinate
lowerRight
the lower-right coordinate
roundSize
A single-precision value that specifies the width and height of the ellipse used to draw the rounded corners. A negative value has the same effect as a positive value.
color
Color of the circle’s outline

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
RoundRectangle(Rectangle,Int32,Color) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > RoundRectangle Method : RoundRectangle(Rectangle,Int32,Color) Method

boundingBox
The location of the rectangle
roundSize
A single-precision value that specifies the width and height of the ellipse used to draw the rounded corners. A negative value has the same effect as a positive value.
color
Color of the circle’s outline

Glossary Item Box

Draws a rectangle with rounded corners on printer The coordinates of the round rectangle must be within the physical area of the printer. To fill a rounded rectangle, set the FillColor and FillStyle properties of the object on which the rectangle is drawn. The width of the line used to draw the rectangle depends on the setting of the Width property. The way the rectangle is drawn on the background depends on the setting of the Mode and Style properties

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub RoundRectangle( _
   ByVal boundingBox As Rectangle, _
   ByVal roundSize As Integer, _
   ByVal color As Color _
)
'Usage

Dim instance As Draw
Dim boundingBox As Rectangle
Dim roundSize As Integer
Dim color As Color

instance.RoundRectangle(boundingBox, roundSize, color)
public void RoundRectangle(
   Rectangle boundingBox,
   int roundSize,
   Color color
)
public: void RoundRectangle(
   Rectangle boundingBox,
   int roundSize,
   Color color
)
public:
void RoundRectangle(
   Rectangle boundingBox,
   int roundSize,
   Color color
)

Parameters

boundingBox
The location of the rectangle
roundSize
A single-precision value that specifies the width and height of the ellipse used to draw the rounded corners. A negative value has the same effect as a positive value.
color
Color of the circle’s outline

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
RoundRectangle(Point,Point,Int32,Int32,Color) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > RoundRectangle Method : RoundRectangle(Point,Point,Int32,Int32,Color) Method

upperLeft
the upper-left coordinate
lowerRight
the lower-right coordinate
roundWidth
A single-precision value that specifies the width of the ellipse used to draw the rounded corners. A negative value has the same effect as its positive counterpart.
roundHeight
A single-precision value that specifies the height of the ellipse used to draw the rounded corners. A negative value has the same effect as its positive counterpart.
color
Color of the circle’s outline

Glossary Item Box

Draws a rectangle with rounded corners on printer The coordinates of the round rectangle must be within the physical area of the printer. To fill a rounded rectangle, set the FillColor and FillStyle properties of the object on which the rectangle is drawn. The width of the line used to draw the rectangle depends on the setting of the Width property. The way the rectangle is drawn on the background depends on the setting of the Mode and Style properties

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub RoundRectangle( _
   ByVal upperLeft As Point, _
   ByVal lowerRight As Point, _
   ByVal roundWidth As Integer, _
   ByVal roundHeight As Integer, _
   ByVal color As Color _
)
'Usage

Dim instance As Draw
Dim upperLeft As Point
Dim lowerRight As Point
Dim roundWidth As Integer
Dim roundHeight As Integer
Dim color As Color

instance.RoundRectangle(upperLeft, lowerRight, roundWidth, roundHeight, color)
public void RoundRectangle(
   Point upperLeft,
   Point lowerRight,
   int roundWidth,
   int roundHeight,
   Color color
)
public: void RoundRectangle(
   Point upperLeft,
   Point lowerRight,
   int roundWidth,
   int roundHeight,
   Color color
)
public:
void RoundRectangle(
   Point upperLeft,
   Point lowerRight,
   int roundWidth,
   int roundHeight,
   Color color
)

Parameters

upperLeft
the upper-left coordinate
lowerRight
the lower-right coordinate
roundWidth
A single-precision value that specifies the width of the ellipse used to draw the rounded corners. A negative value has the same effect as its positive counterpart.
roundHeight
A single-precision value that specifies the height of the ellipse used to draw the rounded corners. A negative value has the same effect as its positive counterpart.
color
Color of the circle’s outline

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
RoundRectangle(Rectangle,Int32,Int32,Color) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > RoundRectangle Method : RoundRectangle(Rectangle,Int32,Int32,Color) Method

boundingBox
The location of the rectangle
roundWidth
A single-precision value that specifies the width of the ellipse used to draw the rounded corners. A negative value has the same effect as its positive counterpart.
roundHeight
A single-precision value that specifies the height of the ellipse used to draw the rounded corners. A negative value has the same effect as its positive counterpart.
color
Color of the circle’s outline

Glossary Item Box

Draws a rectangle with rounded corners on printer The coordinates of the round rectangle must be within the physical area of the printer. To fill a rounded rectangle, set the FillColor and FillStyle properties of the object on which the rectangle is drawn. The width of the line used to draw the rectangle depends on the setting of the Width property. The way the rectangle is drawn on the background depends on the setting of the Mode and Style properties

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub RoundRectangle( _
   ByVal boundingBox As Rectangle, _
   ByVal roundWidth As Integer, _
   ByVal roundHeight As Integer, _
   ByVal color As Color _
)
'Usage

Dim instance As Draw
Dim boundingBox As Rectangle
Dim roundWidth As Integer
Dim roundHeight As Integer
Dim color As Color

instance.RoundRectangle(boundingBox, roundWidth, roundHeight, color)
public void RoundRectangle(
   Rectangle boundingBox,
   int roundWidth,
   int roundHeight,
   Color color
)
public: void RoundRectangle(
   Rectangle boundingBox,
   int roundWidth,
   int roundHeight,
   Color color
)
public:
void RoundRectangle(
   Rectangle boundingBox,
   int roundWidth,
   int roundHeight,
   Color color
)

Parameters

boundingBox
The location of the rectangle
roundWidth
A single-precision value that specifies the width of the ellipse used to draw the rounded corners. A negative value has the same effect as its positive counterpart.
roundHeight
A single-precision value that specifies the height of the ellipse used to draw the rounded corners. A negative value has the same effect as its positive counterpart.
color
Color of the circle’s outline

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
RoundRectangle(Point,Point,Int32) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > RoundRectangle Method : RoundRectangle(Point,Point,Int32) Method

upperLeft
the upper-left coordinate
lowerRight
the lower-right coordinate
roundSize
A single-precision value that specifies the width and height of the ellipse used to draw the rounded corners. A negative value has the same effect as a positive value.

Glossary Item Box

Draws a black rectangle with rounded corners on printer The coordinates of the round rectangle must be within the physical area of the printer. To fill a rounded rectangle, set the FillColor and FillStyle properties of the object on which the rectangle is drawn. The width of the line used to draw the rectangle depends on the setting of the Width property. The way the rectangle is drawn on the background depends on the setting of the Mode and Style properties

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub RoundRectangle( _
   ByVal upperLeft As Point, _
   ByVal lowerRight As Point, _
   ByVal roundSize As Integer _
)
'Usage

Dim instance As Draw
Dim upperLeft As Point
Dim lowerRight As Point
Dim roundSize As Integer

instance.RoundRectangle(upperLeft, lowerRight, roundSize)
public void RoundRectangle(
   Point upperLeft,
   Point lowerRight,
   int roundSize
)
public: void RoundRectangle(
   Point upperLeft,
   Point lowerRight,
   int roundSize
)
public:
void RoundRectangle(
   Point upperLeft,
   Point lowerRight,
   int roundSize
)

Parameters

upperLeft
the upper-left coordinate
lowerRight
the lower-right coordinate
roundSize
A single-precision value that specifies the width and height of the ellipse used to draw the rounded corners. A negative value has the same effect as a positive value.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
RoundRectangle(Rectangle,Int32) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > RoundRectangle Method : RoundRectangle(Rectangle,Int32) Method

boundingBox
The location of the rectangle
roundSize
A single-precision value that specifies the width and height of the ellipse used to draw the rounded corners. A negative value has the same effect as a positive value.

Glossary Item Box

Draws a rectangle with rounded corners on printer The coordinates of the round rectangle must be within the physical area of the printer. To fill a rounded rectangle, set the FillColor and FillStyle properties of the object on which the rectangle is drawn. The width of the line used to draw the rectangle depends on the setting of the Width property. The way the rectangle is drawn on the background depends on the setting of the Mode and Style properties

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub RoundRectangle( _
   ByVal boundingBox As Rectangle, _
   ByVal roundSize As Integer _
)
'Usage

Dim instance As Draw
Dim boundingBox As Rectangle
Dim roundSize As Integer

instance.RoundRectangle(boundingBox, roundSize)
public void RoundRectangle(
   Rectangle boundingBox,
   int roundSize
)
public: void RoundRectangle(
   Rectangle boundingBox,
   int roundSize
)
public:
void RoundRectangle(
   Rectangle boundingBox,
   int roundSize
)

Parameters

boundingBox
The location of the rectangle
roundSize
A single-precision value that specifies the width and height of the ellipse used to draw the rounded corners. A negative value has the same effect as a positive value.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
RoundRectangle(Point,Point,Int32,Int32) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > RoundRectangle Method : RoundRectangle(Point,Point,Int32,Int32) Method

upperLeft
the upper-left coordinate
lowerRight
the lower-right coordinate
roundWidth
A single-precision value that specifies the width of the ellipse used to draw the rounded corners. A negative value has the same effect as its positive counterpart.
roundHeight
A single-precision value that specifies the height of the ellipse used to draw the rounded corners. A negative value has the same effect as its positive counterpart.

Glossary Item Box

Draws a black rectangle with rounded corners on printer The coordinates of the round rectangle must be within the physical area of the printer. To fill a rounded rectangle, set the FillColor and FillStyle properties of the object on which the rectangle is drawn. The width of the line used to draw the rectangle depends on the setting of the Width property. The way the rectangle is drawn on the background depends on the setting of the Mode and Style properties

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub RoundRectangle( _
   ByVal upperLeft As Point, _
   ByVal lowerRight As Point, _
   ByVal roundWidth As Integer, _
   ByVal roundHeight As Integer _
)
'Usage

Dim instance As Draw
Dim upperLeft As Point
Dim lowerRight As Point
Dim roundWidth As Integer
Dim roundHeight As Integer

instance.RoundRectangle(upperLeft, lowerRight, roundWidth, roundHeight)
public void RoundRectangle(
   Point upperLeft,
   Point lowerRight,
   int roundWidth,
   int roundHeight
)
public: void RoundRectangle(
   Point upperLeft,
   Point lowerRight,
   int roundWidth,
   int roundHeight
)
public:
void RoundRectangle(
   Point upperLeft,
   Point lowerRight,
   int roundWidth,
   int roundHeight
)

Parameters

upperLeft
the upper-left coordinate
lowerRight
the lower-right coordinate
roundWidth
A single-precision value that specifies the width of the ellipse used to draw the rounded corners. A negative value has the same effect as its positive counterpart.
roundHeight
A single-precision value that specifies the height of the ellipse used to draw the rounded corners. A negative value has the same effect as its positive counterpart.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
RoundRectangle(Rectangle,Int32,Int32) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > RoundRectangle Method : RoundRectangle(Rectangle,Int32,Int32) Method

boundingBox
A System.Drawing.Rectangle which represents the location of the rectangle
roundWidth
A single-precision value that specifies the width of the ellipse used to draw the rounded corners. A negative value has the same effect as its positive counterpart.
roundHeight
A single-precision value that specifies the height of the ellipse used to draw the rounded corners. A negative value has the same effect as its positive counterpart.

Glossary Item Box

Draws a rectangle with rounded corners on printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub RoundRectangle( _
   ByVal boundingBox As Rectangle, _
   ByVal roundWidth As Integer, _
   ByVal roundHeight As Integer _
)
'Usage

Dim instance As Draw
Dim boundingBox As Rectangle
Dim roundWidth As Integer
Dim roundHeight As Integer

instance.RoundRectangle(boundingBox, roundWidth, roundHeight)
public void RoundRectangle(
   Rectangle boundingBox,
   int roundWidth,
   int roundHeight
)
public: void RoundRectangle(
   Rectangle boundingBox,
   int roundWidth,
   int roundHeight
)
public:
void RoundRectangle(
   Rectangle boundingBox,
   int roundWidth,
   int roundHeight
)

Parameters

boundingBox
A System.Drawing.Rectangle which represents the location of the rectangle
roundWidth
A single-precision value that specifies the width of the ellipse used to draw the rounded corners. A negative value has the same effect as its positive counterpart.
roundHeight
A single-precision value that specifies the height of the ellipse used to draw the rounded corners. A negative value has the same effect as its positive counterpart.

Remarks

The coordinates of the round rectangle must be within the physical area of the printer. To fill a rounded rectangle, set the FillColor and FillStyle properties of the object on which the rectangle is drawn. The width of the line used to draw the rectangle depends on the setting of the Width property. The way the rectangle is drawn on the background depends on the setting of the Mode and Style properties.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Text Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class : Text Method

Glossary Item Box

Draws the specified text string.

Overload List

Overload | Description
Text(PointF,String,Font) | Draws the specified text string.
Text(PointF,String) | Draws the specified text string.
Text(Point,String,Font) | Draws the specified text string.
Text(Point,String) | Draws the specified text string.
Text(String,Font) | Draws the specified text string.
Text(String) | Draws the specified text string.

See Also

Reference

Draw Class
Draw Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Text(PointF,String,Font) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Text Method : Text(PointF,String,Font) Method

location
A System.Drawing.PointF location value which represents the location for the string.
drawText
A string value which represents the text to output.
font
A System.Drawing.Font which represents the font to render the text in.

Glossary Item Box

Draws the specified text string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Text( _
   ByVal location As PointF, _
   ByVal drawText As String, _
   ByVal font As Font _
)
'Usage

Dim instance As Draw
Dim location As PointF
Dim drawText As String
Dim font As Font

instance.Text(location, drawText, font)
public void Text(
   PointF location,
   string drawText,
   Font font
)
public: void Text(
   PointF location,
   string* drawText,
   Font* font
)
public:
void Text(
   PointF location,
   String^ drawText,
   Font^ font
)

Parameters

location
A System.Drawing.PointF location value which represents the location for the string.
drawText
A string value which represents the text to output.
font
A System.Drawing.Font which represents the font to render the text in.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Text(PointF,String) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Text Method : Text(PointF,String) Method

location
A System.Drawing.PointF location value which represents the location for the string.
drawText
A string value which represents the text to output.

Glossary Item Box

Draws the specified text string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Text( _
   ByVal location As PointF, _
   ByVal drawText As String _
)
'Usage

Dim instance As Draw
Dim location As PointF
Dim drawText As String

instance.Text(location, drawText)
public void Text(
   PointF location,
   string drawText
)
public: void Text(
   PointF location,
   string* drawText
)
public:
void Text(
   PointF location,
   String^ drawText
)

Parameters

location
A System.Drawing.PointF location value which represents the location for the string.
drawText
A string value which represents the text to output.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Text(Point,String,Font) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Text Method : Text(Point,String,Font) Method

location
A System.Drawing.Point which represents the location for the string.
drawText
A string value which represents the text to output.
font
The System.Drawing.Font to render the text in.

Glossary Item Box

Draws the specified text string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Text( _
   ByVal location As Point, _
   ByVal drawText As String, _
   ByVal font As Font _
)
'Usage

Dim instance As Draw
Dim location As Point
Dim drawText As String
Dim font As Font

instance.Text(location, drawText, font)
public void Text(
   Point location,
   string drawText,
   Font font
)
public: void Text(
   Point location,
   string* drawText,
   Font* font
)
public:
void Text(
   Point location,
   String^ drawText,
   Font^ font
)

Parameters

location
A System.Drawing.Point which represents the location for the string.
drawText
A string value which represents the text to output.
font
The System.Drawing.Font to render the text in.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Text(Point,String) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Text Method : Text(Point,String) Method

location
A System.Drawing.Point which represents the location for the string.
drawText
A string value which represents the text to output.

Glossary Item Box

Draws the specified text string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Text( _
   ByVal location As Point, _
   ByVal drawText As String _
)
'Usage

Dim instance As Draw
Dim location As Point
Dim drawText As String

instance.Text(location, drawText)
public void Text(
   Point location,
   string drawText
)
public: void Text(
   Point location,
   string* drawText
)
public:
void Text(
   Point location,
   String^ drawText
)

Parameters

location
A System.Drawing.Point which represents the location for the string.
drawText
A string value which represents the text to output.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Text(String,Font) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Text Method : Text(String,Font) Method

drawText
A string value which represents the text to output.
font
A System.Drawing.Font which represents the font to render the text in.

Glossary Item Box

Draws the specified text string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Text( _
   ByVal drawText As String, _
   ByVal font As Font _
)
'Usage

Dim instance As Draw
Dim drawText As String
Dim font As Font

instance.Text(drawText, font)
public void Text(
   string drawText,
   Font font
)
public: void Text(
   string* drawText,
   Font* font
)
public:
void Text(
   String^ drawText,
   Font^ font
)

Parameters

drawText
A string value which represents the text to output.
font
A System.Drawing.Font which represents the font to render the text in.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Text(String) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > Text Method : Text(String) Method

drawText
A string value which represents the text to output.

Glossary Item Box

Draws the specified text string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Text( _
   ByVal drawText As String _
)
'Usage

Dim instance As Draw
Dim drawText As String

instance.Text(drawText)
public void Text(
   string drawText
)
public: void Text(
   string* drawText
)
public:
void Text(
   String^ drawText
)

Parameters

drawText
A string value which represents the text to output.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
TextAligned Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class : TextAligned Method

Glossary Item Box

Draws text with the specified alignment.

Overload List

Overload | Description
TextAligned(PointF,PointF,String,Font,Alignment,Boolean) | Draws text with the specified alignment.
TextAligned(RectangleF,String,Font,Alignment,Boolean) | Draws text with the specified alignment.
TextAligned(PointF,String,Font,Alignment,Boolean) | Draws text with the specified alignment.
TextAligned(PointF,PointF,String,Font,Alignment) | Draws text with a specified alignment.
TextAligned(RectangleF,String,Font,Alignment) | Draws text with a specified alignment.
TextAligned(PointF,String,Font,Alignment) | Draws text with a specified alignment.
TextAligned(PointF,PointF,String,Alignment,Boolean) | Outputs text with a specified alignment.
TextAligned(RectangleF,String,Alignment,Boolean) | Outputs text with a specified alignment.
TextAligned(PointF,String,Alignment,Boolean) | Outputs text with a specified alignment.
TextAligned(PointF,PointF,String,Alignment) | Outputs text with a specified alignment.
TextAligned(RectangleF,String,Alignment) | Outputs text with a specified alignment.
TextAligned(PointF,String,Alignment) | Outputs text with a specified alignment.
TextAligned(Point,Point,String,Font,Alignment,Boolean) | Outputs text with a specified alignment.
TextAligned(Rectangle,String,Font,Alignment,Boolean) | Outputs text with a specified alignment.
TextAligned(Point,String,Font,Alignment,Boolean) | Outputs text with a specified alignment
TextAligned(Point,Point,String,Font,Alignment) | Outputs text with a specified alignment.
TextAligned(Rectangle,String,Font,Alignment) | Outputs text with a specified alignment.
TextAligned(Point,String,Font,Alignment) | Outputs text with a specified alignment.
TextAligned(Point,Point,String,Alignment,Boolean) | Outputs text with a specified alignment.
TextAligned(Rectangle,String,Alignment,Boolean) | Outputs text with a specified alignment.
TextAligned(Point,String,Alignment,Boolean) | Outputs text with a specified alignment.
TextAligned(Point,Point,String,Alignment) | Outputs text with a specified alignment.
TextAligned(Rectangle,String,Alignment) | Outputs text with a specified alignment.
TextAligned(Point,String,Alignment) | Outputs text with a specified alignment.

See Also

Reference

Draw Class
Draw Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
TextAligned(PointF,PointF,String,Font,Alignment,Boolean) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > TextAligned Method : TextAligned(PointF,PointF,String,Font,Alignment,Boolean) Method

startPoint
A System.Drawing.PointF which represents the upper-left point where the text is to be aligned from.
endPoint
A System.Drawing.PointF which represents the lower-right point where the text is to be aligned from.
text
A string value which represents the text to align and output.
font
A System.Drawing.Font which represents the font the text is to be rendered in.
alignment
The Alignment of the text.
wordWrap
A boolean value which indicates whether or not word-wrapping is to occur. A value of true for word wrapping to occur and false for word wrapping not to occur.

Glossary Item Box

Draws text with the specified alignment.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub TextAligned( _
   ByVal startPoint As PointF, _
   ByVal endPoint As PointF, _
   ByVal text As String, _
   ByVal font As Font, _
   ByVal alignment As Alignment, _
   ByVal wordWrap As Boolean _
)
'Usage

Dim instance As Draw
Dim startPoint As PointF
Dim endPoint As PointF
Dim text As String
Dim font As Font
Dim alignment As Alignment
Dim wordWrap As Boolean

instance.TextAligned(startPoint, endPoint, text, font, alignment, wordWrap)
public void TextAligned(
   PointF startPoint,
   PointF endPoint,
   string text,
   Font font,
   Alignment alignment,
   bool wordWrap
)
public: void TextAligned(
   PointF startPoint,
   PointF endPoint,
   string* text,
   Font* font,
   Alignment alignment,
   bool wordWrap
)
public:
void TextAligned(
   PointF startPoint,
   PointF endPoint,
   String^ text,
   Font^ font,
   Alignment alignment,
   bool wordWrap
)

Parameters

startPoint
A System.Drawing.PointF which represents the upper-left point where the text is to be aligned from.
endPoint
A System.Drawing.PointF which represents the lower-right point where the text is to be aligned from.
text
A string value which represents the text to align and output.
font
A System.Drawing.Font which represents the font the text is to be rendered in.
alignment
The Alignment of the text.
wordWrap
A boolean value which indicates whether or not word-wrapping is to occur. A value of true for word wrapping to occur and false for word wrapping not to occur.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
TextAligned(RectangleF,String,Font,Alignment,Boolean) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > TextAligned Method : TextAligned(RectangleF,String,Font,Alignment,Boolean) Method

boundingBox
A System.Drawing.RectangleF which represents the bounding box.
text
A string value which represents the text to align and output.
font
A System.Drawing.Font which represents the font the text is to be rendered in.
alignment
The Alignment of the text.
wordWrap
A boolean value which indicates whether or not word-wrapping is to occur. A value of true for word wrapping to occur and false for word wrapping not to occur.

Glossary Item Box

Draws text with the specified alignment.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub TextAligned( _
   ByVal boundingBox As RectangleF, _
   ByVal text As String, _
   ByVal font As Font, _
   ByVal alignment As Alignment, _
   ByVal wordWrap As Boolean _
)
'Usage

Dim instance As Draw
Dim boundingBox As RectangleF
Dim text As String
Dim font As Font
Dim alignment As Alignment
Dim wordWrap As Boolean

instance.TextAligned(boundingBox, text, font, alignment, wordWrap)
public void TextAligned(
   RectangleF boundingBox,
   string text,
   Font font,
   Alignment alignment,
   bool wordWrap
)
public: void TextAligned(
   RectangleF boundingBox,
   string* text,
   Font* font,
   Alignment alignment,
   bool wordWrap
)
public:
void TextAligned(
   RectangleF boundingBox,
   String^ text,
   Font^ font,
   Alignment alignment,
   bool wordWrap
)

Parameters

boundingBox
A System.Drawing.RectangleF which represents the bounding box.
text
A string value which represents the text to align and output.
font
A System.Drawing.Font which represents the font the text is to be rendered in.
alignment
The Alignment of the text.
wordWrap
A boolean value which indicates whether or not word-wrapping is to occur. A value of true for word wrapping to occur and false for word wrapping not to occur.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
TextAligned(PointF,String,Font,Alignment,Boolean) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > TextAligned Method : TextAligned(PointF,String,Font,Alignment,Boolean) Method

endPoint
A System.Drawing.PointF which represents the lower-right point where the text is to be aligned from.
text
A string value which represents the text to align and output.
font
A System.Drawing.Font which represents the font the text is to be rendered in.
alignment
The Alignment of the text.
wordWrap
A boolean value which indicates whether or not word-wrapping is to occur. A value of true for word wrapping to occur and false for word wrapping not to occur.

Glossary Item Box

Draws text with the specified alignment.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub TextAligned( _
   ByVal endPoint As PointF, _
   ByVal text As String, _
   ByVal font As Font, _
   ByVal alignment As Alignment, _
   ByVal wordWrap As Boolean _
)
'Usage

Dim instance As Draw
Dim endPoint As PointF
Dim text As String
Dim font As Font
Dim alignment As Alignment
Dim wordWrap As Boolean

instance.TextAligned(endPoint, text, font, alignment, wordWrap)
public void TextAligned(
   PointF endPoint,
   string text,
   Font font,
   Alignment alignment,
   bool wordWrap
)
public: void TextAligned(
   PointF endPoint,
   string* text,
   Font* font,
   Alignment alignment,
   bool wordWrap
)
public:
void TextAligned(
   PointF endPoint,
   String^ text,
   Font^ font,
   Alignment alignment,
   bool wordWrap
)

Parameters

endPoint
A System.Drawing.PointF which represents the lower-right point where the text is to be aligned from.
text
A string value which represents the text to align and output.
font
A System.Drawing.Font which represents the font the text is to be rendered in.
alignment
The Alignment of the text.
wordWrap
A boolean value which indicates whether or not word-wrapping is to occur. A value of true for word wrapping to occur and false for word wrapping not to occur.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
TextAligned(PointF,PointF,String,Font,Alignment) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > TextAligned Method : TextAligned(PointF,PointF,String,Font,Alignment) Method

startPoint
A System.Drawing.PointF which represents the upper-left point where the text is to be aligned from.
endPoint
A System.Drawing.PointF which represents the lower-right point where the text is to be aligned from.
text
A string which represents the text to align and output.
font
A System.Drawing.Font which represents the font the text is to be rendered in.
alignment
The Alignment of the text.

Glossary Item Box

Draws text with a specified alignment.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub TextAligned( _
   ByVal startPoint As PointF, _
   ByVal endPoint As PointF, _
   ByVal text As String, _
   ByVal font As Font, _
   ByVal alignment As Alignment _
)
'Usage

Dim instance As Draw
Dim startPoint As PointF
Dim endPoint As PointF
Dim text As String
Dim font As Font
Dim alignment As Alignment

instance.TextAligned(startPoint, endPoint, text, font, alignment)
public void TextAligned(
   PointF startPoint,
   PointF endPoint,
   string text,
   Font font,
   Alignment alignment
)
public: void TextAligned(
   PointF startPoint,
   PointF endPoint,
   string* text,
   Font* font,
   Alignment alignment
)
public:
void TextAligned(
   PointF startPoint,
   PointF endPoint,
   String^ text,
   Font^ font,
   Alignment alignment
)

Parameters

startPoint
A System.Drawing.PointF which represents the upper-left point where the text is to be aligned from.
endPoint
A System.Drawing.PointF which represents the lower-right point where the text is to be aligned from.
text
A string which represents the text to align and output.
font
A System.Drawing.Font which represents the font the text is to be rendered in.
alignment
The Alignment of the text.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
TextAligned(RectangleF,String,Font,Alignment) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > TextAligned Method : TextAligned(RectangleF,String,Font,Alignment) Method

boundingBox
The bounding System.Drawing.RectangleF for the text.
text
A string which represents the text to align and output.
font
A System.Drawing.Font which represents the font the text is to be rendered in.
alignment
The Alignment of the text.

Glossary Item Box

Draws text with a specified alignment.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub TextAligned( _
   ByVal boundingBox As RectangleF, _
   ByVal text As String, _
   ByVal font As Font, _
   ByVal alignment As Alignment _
)
'Usage

Dim instance As Draw
Dim boundingBox As RectangleF
Dim text As String
Dim font As Font
Dim alignment As Alignment

instance.TextAligned(boundingBox, text, font, alignment)
public void TextAligned(
   RectangleF boundingBox,
   string text,
   Font font,
   Alignment alignment
)
public: void TextAligned(
   RectangleF boundingBox,
   string* text,
   Font* font,
   Alignment alignment
)
public:
void TextAligned(
   RectangleF boundingBox,
   String^ text,
   Font^ font,
   Alignment alignment
)

Parameters

boundingBox
The bounding System.Drawing.RectangleF for the text.
text
A string which represents the text to align and output.
font
A System.Drawing.Font which represents the font the text is to be rendered in.
alignment
The Alignment of the text.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
TextAligned(PointF,String,Font,Alignment) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > TextAligned Method : TextAligned(PointF,String,Font,Alignment) Method

endPoint
A System.Drawing.PointF which represents the lower-right point where the text is to be aligned from.
text
A string which represents the text to align and output.
font
A System.Drawing.Font which represents the font the text is to be rendered in.
alignment
The Alignment of the text.

Glossary Item Box

Draws text with a specified alignment.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub TextAligned( _
   ByVal endPoint As PointF, _
   ByVal text As String, _
   ByVal font As Font, _
   ByVal alignment As Alignment _
)
'Usage

Dim instance As Draw
Dim endPoint As PointF
Dim text As String
Dim font As Font
Dim alignment As Alignment

instance.TextAligned(endPoint, text, font, alignment)
public void TextAligned(
   PointF endPoint,
   string text,
   Font font,
   Alignment alignment
)
public: void TextAligned(
   PointF endPoint,
   string* text,
   Font* font,
   Alignment alignment
)
public:
void TextAligned(
   PointF endPoint,
   String^ text,
   Font^ font,
   Alignment alignment
)

Parameters

endPoint
A System.Drawing.PointF which represents the lower-right point where the text is to be aligned from.
text
A string which represents the text to align and output.
font
A System.Drawing.Font which represents the font the text is to be rendered in.
alignment
The Alignment of the text.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
TextAligned(PointF,PointF,String,Alignment,Boolean) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > TextAligned Method : TextAligned(PointF,PointF,String,Alignment,Boolean) Method

startPoint
A System.Drawing.PointF which represents the upper-left point where the text is to be aligned from.
endPoint
A System.Drawing.PointF which represents the lower-right point where the text is to be aligned from.
text
A string which represents the text to align and output.
alignment
The Alignment of the text.
wordWrap
A boolean value which indicates whether or not word-wrapping is to occur. A value of true for word wrapping to occur and false for word wrapping not to occur.

Glossary Item Box

Outputs text with a specified alignment.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub TextAligned( _
   ByVal startPoint As PointF, _
   ByVal endPoint As PointF, _
   ByVal text As String, _
   ByVal alignment As Alignment, _
   ByVal wordWrap As Boolean _
)
'Usage

Dim instance As Draw
Dim startPoint As PointF
Dim endPoint As PointF
Dim text As String
Dim alignment As Alignment
Dim wordWrap As Boolean

instance.TextAligned(startPoint, endPoint, text, alignment, wordWrap)
public void TextAligned(
   PointF startPoint,
   PointF endPoint,
   string text,
   Alignment alignment,
   bool wordWrap
)
public: void TextAligned(
   PointF startPoint,
   PointF endPoint,
   string* text,
   Alignment alignment,
   bool wordWrap
)
public:
void TextAligned(
   PointF startPoint,
   PointF endPoint,
   String^ text,
   Alignment alignment,
   bool wordWrap
)

Parameters

startPoint
A System.Drawing.PointF which represents the upper-left point where the text is to be aligned from.
endPoint
A System.Drawing.PointF which represents the lower-right point where the text is to be aligned from.
text
A string which represents the text to align and output.
alignment
The Alignment of the text.
wordWrap
A boolean value which indicates whether or not word-wrapping is to occur. A value of true for word wrapping to occur and false for word wrapping not to occur.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
TextAligned(RectangleF,String,Alignment,Boolean) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > TextAligned Method : TextAligned(RectangleF,String,Alignment,Boolean) Method

boundingBox
The bounding System.Drawing.RectangleF for the text.
text
A string which represents the text to align and output.
alignment
The Alignment of the text.
wordWrap
A boolean value which indicates whether or not word-wrapping is to occur. A value of true for word wrapping to occur and false for word wrapping not to occur.

Glossary Item Box

Outputs text with a specified alignment.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub TextAligned( _
   ByVal boundingBox As RectangleF, _
   ByVal text As String, _
   ByVal alignment As Alignment, _
   ByVal wordWrap As Boolean _
)
'Usage

Dim instance As Draw
Dim boundingBox As RectangleF
Dim text As String
Dim alignment As Alignment
Dim wordWrap As Boolean

instance.TextAligned(boundingBox, text, alignment, wordWrap)
public void TextAligned(
   RectangleF boundingBox,
   string text,
   Alignment alignment,
   bool wordWrap
)
public: void TextAligned(
   RectangleF boundingBox,
   string* text,
   Alignment alignment,
   bool wordWrap
)
public:
void TextAligned(
   RectangleF boundingBox,
   String^ text,
   Alignment alignment,
   bool wordWrap
)

Parameters

boundingBox
The bounding System.Drawing.RectangleF for the text.
text
A string which represents the text to align and output.
alignment
The Alignment of the text.
wordWrap
A boolean value which indicates whether or not word-wrapping is to occur. A value of true for word wrapping to occur and false for word wrapping not to occur.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
TextAligned(PointF,String,Alignment,Boolean) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > TextAligned Method : TextAligned(PointF,String,Alignment,Boolean) Method

endPoint
A System.Drawing.PointF which represents the lower-right where the text is to be aligned from.
text
A string value which represents the text to align and output.
alignment
The Alignment of the text.
wordWrap
A boolean value which indicates whether or not word-wrapping is to occur. A value of true for word wrapping to occur and false for word wrapping not to occur.

Glossary Item Box

Outputs text with a specified alignment.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub TextAligned( _
   ByVal endPoint As PointF, _
   ByVal text As String, _
   ByVal alignment As Alignment, _
   ByVal wordWrap As Boolean _
)
'Usage

Dim instance As Draw
Dim endPoint As PointF
Dim text As String
Dim alignment As Alignment
Dim wordWrap As Boolean

instance.TextAligned(endPoint, text, alignment, wordWrap)
public void TextAligned(
   PointF endPoint,
   string text,
   Alignment alignment,
   bool wordWrap
)
public: void TextAligned(
   PointF endPoint,
   string* text,
   Alignment alignment,
   bool wordWrap
)
public:
void TextAligned(
   PointF endPoint,
   String^ text,
   Alignment alignment,
   bool wordWrap
)

Parameters

endPoint
A System.Drawing.PointF which represents the lower-right where the text is to be aligned from.
text
A string value which represents the text to align and output.
alignment
The Alignment of the text.
wordWrap
A boolean value which indicates whether or not word-wrapping is to occur. A value of true for word wrapping to occur and false for word wrapping not to occur.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
TextAligned(PointF,PointF,String,Alignment) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > TextAligned Method : TextAligned(PointF,PointF,String,Alignment) Method

startPoint
A System.Drawing.PointF which represents the upper-left point where the text is to be aligned from.
endPoint
A System.Drawing.PointF which represents the lower-right point where the text is to be aligned from.
text
A string which represents the text to align and output.
alignment
The Alignment of the text.

Glossary Item Box

Outputs text with a specified alignment.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub TextAligned( _
   ByVal startPoint As PointF, _
   ByVal endPoint As PointF, _
   ByVal text As String, _
   ByVal alignment As Alignment _
)
'Usage

Dim instance As Draw
Dim startPoint As PointF
Dim endPoint As PointF
Dim text As String
Dim alignment As Alignment

instance.TextAligned(startPoint, endPoint, text, alignment)
public void TextAligned(
   PointF startPoint,
   PointF endPoint,
   string text,
   Alignment alignment
)
public: void TextAligned(
   PointF startPoint,
   PointF endPoint,
   string* text,
   Alignment alignment
)
public:
void TextAligned(
   PointF startPoint,
   PointF endPoint,
   String^ text,
   Alignment alignment
)

Parameters

startPoint
A System.Drawing.PointF which represents the upper-left point where the text is to be aligned from.
endPoint
A System.Drawing.PointF which represents the lower-right point where the text is to be aligned from.
text
A string which represents the text to align and output.
alignment
The Alignment of the text.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
TextAligned(RectangleF,String,Alignment) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > TextAligned Method : TextAligned(RectangleF,String,Alignment) Method

boundingBox
The bounding System.Drawing.RectangleF for the text.
text
A string value which represents the text to align and output.
alignment
The Alignment of the text.

Glossary Item Box

Outputs text with a specified alignment.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub TextAligned( _
   ByVal boundingBox As RectangleF, _
   ByVal text As String, _
   ByVal alignment As Alignment _
)
'Usage

Dim instance As Draw
Dim boundingBox As RectangleF
Dim text As String
Dim alignment As Alignment

instance.TextAligned(boundingBox, text, alignment)
public void TextAligned(
   RectangleF boundingBox,
   string text,
   Alignment alignment
)
public: void TextAligned(
   RectangleF boundingBox,
   string* text,
   Alignment alignment
)
public:
void TextAligned(
   RectangleF boundingBox,
   String^ text,
   Alignment alignment
)

Parameters

boundingBox
The bounding System.Drawing.RectangleF for the text.
text
A string value which represents the text to align and output.
alignment
The Alignment of the text.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
TextAligned(PointF,String,Alignment) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > TextAligned Method : TextAligned(PointF,String,Alignment) Method

endPoint
A System.Drawing.PointF which represents the lower-right point where the text is to be aligned from.
text
A string which represents the text to align and output.
alignment
The Alignment of the text.

Glossary Item Box

Outputs text with a specified alignment.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub TextAligned( _
   ByVal endPoint As PointF, _
   ByVal text As String, _
   ByVal alignment As Alignment _
)
'Usage

Dim instance As Draw
Dim endPoint As PointF
Dim text As String
Dim alignment As Alignment

instance.TextAligned(endPoint, text, alignment)
public void TextAligned(
   PointF endPoint,
   string text,
   Alignment alignment
)
public: void TextAligned(
   PointF endPoint,
   string* text,
   Alignment alignment
)
public:
void TextAligned(
   PointF endPoint,
   String^ text,
   Alignment alignment
)

Parameters

endPoint
A System.Drawing.PointF which represents the lower-right point where the text is to be aligned from.
text
A string which represents the text to align and output.
alignment
The Alignment of the text.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
TextAligned(Point,Point,String,Font,Alignment,Boolean) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > TextAligned Method : TextAligned(Point,Point,String,Font,Alignment,Boolean) Method

startPoint
A System.Drawing.Point which represents the upper-left point where the text is to be aligned from.
endPoint
A System.Drawing.Point which represents the lower-right point where the text is to be aligned from.
text
A string which represents the text to align and output.
font
The fSystem.Drawing.Font the text is to be rendered in.
alignment
The Alignment of the text.
wordWrap
A boolean value which indicates whether or not word-wrapping is to occur. A value of true for word wrapping to occur and false for word wrapping not to occur.

Glossary Item Box

Outputs text with a specified alignment.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub TextAligned( _
   ByVal startPoint As Point, _
   ByVal endPoint As Point, _
   ByVal text As String, _
   ByVal font As Font, _
   ByVal alignment As Alignment, _
   ByVal wordWrap As Boolean _
)
'Usage

Dim instance As Draw
Dim startPoint As Point
Dim endPoint As Point
Dim text As String
Dim font As Font
Dim alignment As Alignment
Dim wordWrap As Boolean

instance.TextAligned(startPoint, endPoint, text, font, alignment, wordWrap)
public void TextAligned(
   Point startPoint,
   Point endPoint,
   string text,
   Font font,
   Alignment alignment,
   bool wordWrap
)
public: void TextAligned(
   Point startPoint,
   Point endPoint,
   string* text,
   Font* font,
   Alignment alignment,
   bool wordWrap
)
public:
void TextAligned(
   Point startPoint,
   Point endPoint,
   String^ text,
   Font^ font,
   Alignment alignment,
   bool wordWrap
)

Parameters

startPoint
A System.Drawing.Point which represents the upper-left point where the text is to be aligned from.
endPoint
A System.Drawing.Point which represents the lower-right point where the text is to be aligned from.
text
A string which represents the text to align and output.
font
The fSystem.Drawing.Font the text is to be rendered in.
alignment
The Alignment of the text.
wordWrap
A boolean value which indicates whether or not word-wrapping is to occur. A value of true for word wrapping to occur and false for word wrapping not to occur.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
TextAligned(Rectangle,String,Font,Alignment,Boolean) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > TextAligned Method : TextAligned(Rectangle,String,Font,Alignment,Boolean) Method

boundingBox
The bounding System.Drawing.Rectangle for the text.
text
A string which represents the text to align and output.
font
The System.Drawing.Font the text is to be rendered in.
alignment
The Alignment of the text.
wordWrap
A boolean value which indicates whether or not word-wrapping is to occur. A value of true for word wrapping to occur and false for word wrapping not to occur.

Glossary Item Box

Outputs text with a specified alignment.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub TextAligned( _
   ByVal boundingBox As Rectangle, _
   ByVal text As String, _
   ByVal font As Font, _
   ByVal alignment As Alignment, _
   ByVal wordWrap As Boolean _
)
'Usage

Dim instance As Draw
Dim boundingBox As Rectangle
Dim text As String
Dim font As Font
Dim alignment As Alignment
Dim wordWrap As Boolean

instance.TextAligned(boundingBox, text, font, alignment, wordWrap)
public void TextAligned(
   Rectangle boundingBox,
   string text,
   Font font,
   Alignment alignment,
   bool wordWrap
)
public: void TextAligned(
   Rectangle boundingBox,
   string* text,
   Font* font,
   Alignment alignment,
   bool wordWrap
)
public:
void TextAligned(
   Rectangle boundingBox,
   String^ text,
   Font^ font,
   Alignment alignment,
   bool wordWrap
)

Parameters

boundingBox
The bounding System.Drawing.Rectangle for the text.
text
A string which represents the text to align and output.
font
The System.Drawing.Font the text is to be rendered in.
alignment
The Alignment of the text.
wordWrap
A boolean value which indicates whether or not word-wrapping is to occur. A value of true for word wrapping to occur and false for word wrapping not to occur.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
TextAligned(Point,String,Font,Alignment,Boolean) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > TextAligned Method : TextAligned(Point,String,Font,Alignment,Boolean) Method

endPoint
A System.Drawing.Point which represents the lower-right point where the text is to be aligned from.
text
A string which represents the text to align and output.
font
The System.Drawing.Font the text is to be rendered in.
alignment
The Alignment of the text.
wordWrap
A boolean value which indicates whether or not word-wrapping is to occur. A value of true for word wrapping to occur and false for word wrapping not to occur.

Glossary Item Box

Outputs text with a specified alignment

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub TextAligned( _
   ByVal endPoint As Point, _
   ByVal text As String, _
   ByVal font As Font, _
   ByVal alignment As Alignment, _
   ByVal wordWrap As Boolean _
)
'Usage

Dim instance As Draw
Dim endPoint As Point
Dim text As String
Dim font As Font
Dim alignment As Alignment
Dim wordWrap As Boolean

instance.TextAligned(endPoint, text, font, alignment, wordWrap)
public void TextAligned(
   Point endPoint,
   string text,
   Font font,
   Alignment alignment,
   bool wordWrap
)
public: void TextAligned(
   Point endPoint,
   string* text,
   Font* font,
   Alignment alignment,
   bool wordWrap
)
public:
void TextAligned(
   Point endPoint,
   String^ text,
   Font^ font,
   Alignment alignment,
   bool wordWrap
)

Parameters

endPoint
A System.Drawing.Point which represents the lower-right point where the text is to be aligned from.
text
A string which represents the text to align and output.
font
The System.Drawing.Font the text is to be rendered in.
alignment
The Alignment of the text.
wordWrap
A boolean value which indicates whether or not word-wrapping is to occur. A value of true for word wrapping to occur and false for word wrapping not to occur.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
TextAligned(Point,Point,String,Font,Alignment) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > TextAligned Method : TextAligned(Point,Point,String,Font,Alignment) Method

startPoint
A System.Drawing.Point which represents the upper-left point where the text is to be aligned from.
endPoint
A System.Drawing.Point which represents the lower-right point where the text is to be aligned from.
text
A string which represents the text to align and output.
font
The System.Drawing.Font the text is to be rendered in.
alignment
The Alignment of the text.

Glossary Item Box

Outputs text with a specified alignment.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub TextAligned( _
   ByVal startPoint As Point, _
   ByVal endPoint As Point, _
   ByVal text As String, _
   ByVal font As Font, _
   ByVal alignment As Alignment _
)
'Usage

Dim instance As Draw
Dim startPoint As Point
Dim endPoint As Point
Dim text As String
Dim font As Font
Dim alignment As Alignment

instance.TextAligned(startPoint, endPoint, text, font, alignment)
public void TextAligned(
   Point startPoint,
   Point endPoint,
   string text,
   Font font,
   Alignment alignment
)
public: void TextAligned(
   Point startPoint,
   Point endPoint,
   string* text,
   Font* font,
   Alignment alignment
)
public:
void TextAligned(
   Point startPoint,
   Point endPoint,
   String^ text,
   Font^ font,
   Alignment alignment
)

Parameters

startPoint
A System.Drawing.Point which represents the upper-left point where the text is to be aligned from.
endPoint
A System.Drawing.Point which represents the lower-right point where the text is to be aligned from.
text
A string which represents the text to align and output.
font
The System.Drawing.Font the text is to be rendered in.
alignment
The Alignment of the text.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
TextAligned(Rectangle,String,Font,Alignment) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > TextAligned Method : TextAligned(Rectangle,String,Font,Alignment) Method

boundingBox
The bounding System.Drawing.Rectangle for the text.
text
A string which represents the text to align and output.
font
The System.Drawing.Font the text is to be rendered in.
alignment
The Alignment of the text.

Glossary Item Box

Outputs text with a specified alignment.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub TextAligned( _
   ByVal boundingBox As Rectangle, _
   ByVal text As String, _
   ByVal font As Font, _
   ByVal alignment As Alignment _
)
'Usage

Dim instance As Draw
Dim boundingBox As Rectangle
Dim text As String
Dim font As Font
Dim alignment As Alignment

instance.TextAligned(boundingBox, text, font, alignment)
public void TextAligned(
   Rectangle boundingBox,
   string text,
   Font font,
   Alignment alignment
)
public: void TextAligned(
   Rectangle boundingBox,
   string* text,
   Font* font,
   Alignment alignment
)
public:
void TextAligned(
   Rectangle boundingBox,
   String^ text,
   Font^ font,
   Alignment alignment
)

Parameters

boundingBox
The bounding System.Drawing.Rectangle for the text.
text
A string which represents the text to align and output.
font
The System.Drawing.Font the text is to be rendered in.
alignment
The Alignment of the text.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
TextAligned(Point,String,Font,Alignment) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > TextAligned Method : TextAligned(Point,String,Font,Alignment) Method

endPoint
A System.Drawing.Point which represents the lower-right point where the text is to be aligned from.
text
A string which represents the text to align and output.
font
The System.Drawing.Font the text is to be rendered in.
alignment
The Alignment of the text.

Glossary Item Box

Outputs text with a specified alignment.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub TextAligned( _
   ByVal endPoint As Point, _
   ByVal text As String, _
   ByVal font As Font, _
   ByVal alignment As Alignment _
)
'Usage

Dim instance As Draw
Dim endPoint As Point
Dim text As String
Dim font As Font
Dim alignment As Alignment

instance.TextAligned(endPoint, text, font, alignment)
public void TextAligned(
   Point endPoint,
   string text,
   Font font,
   Alignment alignment
)
public: void TextAligned(
   Point endPoint,
   string* text,
   Font* font,
   Alignment alignment
)
public:
void TextAligned(
   Point endPoint,
   String^ text,
   Font^ font,
   Alignment alignment
)

Parameters

endPoint
A System.Drawing.Point which represents the lower-right point where the text is to be aligned from.
text
A string which represents the text to align and output.
font
The System.Drawing.Font the text is to be rendered in.
alignment
The Alignment of the text.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
TextAligned(Point,Point,String,Alignment,Boolean) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > TextAligned Method : TextAligned(Point,Point,String,Alignment,Boolean) Method

startPoint
A System.Drawing.Point which represents the upper-left point where the text is to be aligned from.
endPoint
A System.Drawing.Point which represents the lower-right point where the text is to be aligned from.
text
The text to align and output.
alignment
The Alignment of the text.
wordWrap
A boolean value which indicates whether or not word-wrapping is to occur. A value of true for word wrapping to occur and false for word wrapping not to occur.

Glossary Item Box

Outputs text with a specified alignment.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub TextAligned( _
   ByVal startPoint As Point, _
   ByVal endPoint As Point, _
   ByVal text As String, _
   ByVal alignment As Alignment, _
   ByVal wordWrap As Boolean _
)
'Usage

Dim instance As Draw
Dim startPoint As Point
Dim endPoint As Point
Dim text As String
Dim alignment As Alignment
Dim wordWrap As Boolean

instance.TextAligned(startPoint, endPoint, text, alignment, wordWrap)
public void TextAligned(
   Point startPoint,
   Point endPoint,
   string text,
   Alignment alignment,
   bool wordWrap
)
public: void TextAligned(
   Point startPoint,
   Point endPoint,
   string* text,
   Alignment alignment,
   bool wordWrap
)
public:
void TextAligned(
   Point startPoint,
   Point endPoint,
   String^ text,
   Alignment alignment,
   bool wordWrap
)

Parameters

startPoint
A System.Drawing.Point which represents the upper-left point where the text is to be aligned from.
endPoint
A System.Drawing.Point which represents the lower-right point where the text is to be aligned from.
text
The text to align and output.
alignment
The Alignment of the text.
wordWrap
A boolean value which indicates whether or not word-wrapping is to occur. A value of true for word wrapping to occur and false for word wrapping not to occur.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
TextAligned(Rectangle,String,Alignment,Boolean) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > TextAligned Method : TextAligned(Rectangle,String,Alignment,Boolean) Method

boundingBox
The bounding System.Drawing.Rectangle for the text.
text
A string which represents the text to align and output.
alignment
The Alignment of the text.
wordWrap
A boolean value which indicates whether or not word-wrapping is to occur. A value of true for word wrapping to occur and false for word wrapping not to occur.

Glossary Item Box

Outputs text with a specified alignment.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub TextAligned( _
   ByVal boundingBox As Rectangle, _
   ByVal text As String, _
   ByVal alignment As Alignment, _
   ByVal wordWrap As Boolean _
)
'Usage

Dim instance As Draw
Dim boundingBox As Rectangle
Dim text As String
Dim alignment As Alignment
Dim wordWrap As Boolean

instance.TextAligned(boundingBox, text, alignment, wordWrap)
public void TextAligned(
   Rectangle boundingBox,
   string text,
   Alignment alignment,
   bool wordWrap
)
public: void TextAligned(
   Rectangle boundingBox,
   string* text,
   Alignment alignment,
   bool wordWrap
)
public:
void TextAligned(
   Rectangle boundingBox,
   String^ text,
   Alignment alignment,
   bool wordWrap
)

Parameters

boundingBox
The bounding System.Drawing.Rectangle for the text.
text
A string which represents the text to align and output.
alignment
The Alignment of the text.
wordWrap
A boolean value which indicates whether or not word-wrapping is to occur. A value of true for word wrapping to occur and false for word wrapping not to occur.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
TextAligned(Point,String,Alignment,Boolean) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > TextAligned Method : TextAligned(Point,String,Alignment,Boolean) Method

endPoint
A System.Drawing.Point which represents the lower-right point where the text is to be aligned from.
text
A string which represents the text to align and output.
alignment
The Alignment of the text.
wordWrap
A boolean value which indicates whether or not word-wrapping is to occur. A value of true for word wrapping to occur and false for word wrapping not to occur.

Glossary Item Box

Outputs text with a specified alignment.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub TextAligned( _
   ByVal endPoint As Point, _
   ByVal text As String, _
   ByVal alignment As Alignment, _
   ByVal wordWrap As Boolean _
)
'Usage

Dim instance As Draw
Dim endPoint As Point
Dim text As String
Dim alignment As Alignment
Dim wordWrap As Boolean

instance.TextAligned(endPoint, text, alignment, wordWrap)
public void TextAligned(
   Point endPoint,
   string text,
   Alignment alignment,
   bool wordWrap
)
public: void TextAligned(
   Point endPoint,
   string* text,
   Alignment alignment,
   bool wordWrap
)
public:
void TextAligned(
   Point endPoint,
   String^ text,
   Alignment alignment,
   bool wordWrap
)

Parameters

endPoint
A System.Drawing.Point which represents the lower-right point where the text is to be aligned from.
text
A string which represents the text to align and output.
alignment
The Alignment of the text.
wordWrap
A boolean value which indicates whether or not word-wrapping is to occur. A value of true for word wrapping to occur and false for word wrapping not to occur.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
TextAligned(Point,Point,String,Alignment) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > TextAligned Method : TextAligned(Point,Point,String,Alignment) Method

startPoint
A System.Drawing.Point which represents the upper-left point where the text is to be aligned from.
endPoint
A System.Drawing.Point which represents the lower-right point where the text is to be aligned from.
text
A string which represents the text to align and output.
alignment
The Alignment of the text.

Glossary Item Box

Outputs text with a specified alignment.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub TextAligned( _
   ByVal startPoint As Point, _
   ByVal endPoint As Point, _
   ByVal text As String, _
   ByVal alignment As Alignment _
)
'Usage

Dim instance As Draw
Dim startPoint As Point
Dim endPoint As Point
Dim text As String
Dim alignment As Alignment

instance.TextAligned(startPoint, endPoint, text, alignment)
public void TextAligned(
   Point startPoint,
   Point endPoint,
   string text,
   Alignment alignment
)
public: void TextAligned(
   Point startPoint,
   Point endPoint,
   string* text,
   Alignment alignment
)
public:
void TextAligned(
   Point startPoint,
   Point endPoint,
   String^ text,
   Alignment alignment
)

Parameters

startPoint
A System.Drawing.Point which represents the upper-left point where the text is to be aligned from.
endPoint
A System.Drawing.Point which represents the lower-right point where the text is to be aligned from.
text
A string which represents the text to align and output.
alignment
The Alignment of the text.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
TextAligned(Rectangle,String,Alignment) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > TextAligned Method : TextAligned(Rectangle,String,Alignment) Method

boundingBox
The bounding System.Drawing.Rectangle for the text.
text
A string which represents the text to align and output.
alignment
The Alignment of the text.

Glossary Item Box

Outputs text with a specified alignment.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub TextAligned( _
   ByVal boundingBox As Rectangle, _
   ByVal text As String, _
   ByVal alignment As Alignment _
)
'Usage

Dim instance As Draw
Dim boundingBox As Rectangle
Dim text As String
Dim alignment As Alignment

instance.TextAligned(boundingBox, text, alignment)
public void TextAligned(
   Rectangle boundingBox,
   string text,
   Alignment alignment
)
public: void TextAligned(
   Rectangle boundingBox,
   string* text,
   Alignment alignment
)
public:
void TextAligned(
   Rectangle boundingBox,
   String^ text,
   Alignment alignment
)

Parameters

boundingBox
The bounding System.Drawing.Rectangle for the text.
text
A string which represents the text to align and output.
alignment
The Alignment of the text.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
TextAligned(Point,String,Alignment) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > TextAligned Method : TextAligned(Point,String,Alignment) Method

endPoint
A System.Drawing.Point which represents the lower-right point where the text is to be aligned from.
text
A string which represents the text to align and output.
alignment
The Alignment of the text.

Glossary Item Box

Outputs text with a specified alignment.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub TextAligned( _
   ByVal endPoint As Point, _
   ByVal text As String, _
   ByVal alignment As Alignment _
)
'Usage

Dim instance As Draw
Dim endPoint As Point
Dim text As String
Dim alignment As Alignment

instance.TextAligned(endPoint, text, alignment)
public void TextAligned(
   Point endPoint,
   string text,
   Alignment alignment
)
public: void TextAligned(
   Point endPoint,
   string* text,
   Alignment alignment
)
public:
void TextAligned(
   Point endPoint,
   String^ text,
   Alignment alignment
)

Parameters

endPoint
A System.Drawing.Point which represents the lower-right point where the text is to be aligned from.
text
A string which represents the text to align and output.
alignment
The Alignment of the text.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
TextHeight Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class : TextHeight Method

Glossary Item Box

Returns the height the text would be if the output has a specified font.

Overload List

Overload | Description
TextHeight(Font,String) | Returns the height the text would be if the output has a specified font.
TextHeight(String) | Returns the height the text would be if drawn with the given text.

See Also

Reference

Draw Class
Draw Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
TextHeight(Font,String) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > TextHeight Method : TextHeight(Font,String) Method

font
A System.Drawing.Font to use.
text
A string which represents the text to get the printed height of.

Glossary Item Box

Returns the height the text would be if the output has a specified font.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Function TextHeight( _
   ByVal font As Font, _
   ByVal text As String _
) As Single
'Usage

Dim instance As Draw
Dim font As Font
Dim text As String
Dim value As Single

value = instance.TextHeight(font, text)
public float TextHeight(
   Font font,
   string text
)
public: float TextHeight(
   Font* font,
   string* text
)
public:
float TextHeight(
   Font^ font,
   String^ text
)

Parameters

font
A System.Drawing.Font to use.
text
A string which represents the text to get the printed height of.

Return Value

A float value which represents the height of the text when printed.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
TextHeight(String) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > TextHeight Method : TextHeight(String) Method

text
A string which represents the text to get the printed height of.

Glossary Item Box

Returns the height the text would be if drawn with the given text.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Function TextHeight( _
   ByVal text As String _
) As Single
'Usage

Dim instance As Draw
Dim text As String
Dim value As Single

value = instance.TextHeight(text)
public float TextHeight(
   string text
)
public: float TextHeight(
   string* text
)
public:
float TextHeight(
   String^ text
)

Parameters

text
A string which represents the text to get the printed height of.

Return Value

A float value which represents the height of the text when printed.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
TextRotated Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class : TextRotated Method

Glossary Item Box

Outputs text rotated by a specified number of degrees.

Overload List

Overload | Description
TextRotated(PointF,Single,RotationPivotMode,String,Font) | Outputs text rotated by a specified number of degrees.
TextRotated(Single,RotationPivotMode,String,Font) | Outputs text rotated by specified number of degrees.
TextRotated(PointF,Single,RotationPivotMode,String) | Outputs text rotated by a specified number of degrees.
TextRotated(Single,RotationPivotMode,String) | Outputs text rotated by a specified number of degrees.
TextRotated(Point,Single,RotationPivotMode,String,Font) | Outputs text rotated by a specified number of degrees.
TextRotated(Point,Single,RotationPivotMode,String) | Outputs text rotated by a specified number of degrees.

See Also

Reference

Draw Class
Draw Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
TextRotated(PointF,Single,RotationPivotMode,String,Font) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > TextRotated Method : TextRotated(PointF,Single,RotationPivotMode,String,Font) Method

location
A System.Drawing.PointF which represents the location for the origin of rotation.
angle
A single value which represents the angle by which to rotate.
pivotMode
The RotationPivotMode the text is aligned to the rotation by.
text
A string which represents the text to output.
font
The System.Drawing.Font to render the text in.

Glossary Item Box

Outputs text rotated by a specified number of degrees.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub TextRotated( _
   ByVal location As PointF, _
   ByVal angle As Single, _
   ByVal pivotMode As RotationPivotMode, _
   ByVal text As String, _
   ByVal font As Font _
)
'Usage

Dim instance As Draw
Dim location As PointF
Dim angle As Single
Dim pivotMode As RotationPivotMode
Dim text As String
Dim font As Font

instance.TextRotated(location, angle, pivotMode, text, font)
public void TextRotated(
   PointF location,
   float angle,
   RotationPivotMode pivotMode,
   string text,
   Font font
)
public: void TextRotated(
   PointF location,
   float angle,
   RotationPivotMode pivotMode,
   string* text,
   Font* font
)
public:
void TextRotated(
   PointF location,
   float angle,
   RotationPivotMode pivotMode,
   String^ text,
   Font^ font
)

Parameters

location
A System.Drawing.PointF which represents the location for the origin of rotation.
angle
A single value which represents the angle by which to rotate.
pivotMode
The RotationPivotMode the text is aligned to the rotation by.
text
A string which represents the text to output.
font
The System.Drawing.Font to render the text in.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
TextRotated(Single,RotationPivotMode,String,Font) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > TextRotated Method : TextRotated(Single,RotationPivotMode,String,Font) Method

angle
A single which represents the angle by which to rotate.
pivotMode
The RotationPivotMode the text is aligned to the rotation by.
text
A string which represents the text to output.
font
The System.Drawing.Font to render the text in.

Glossary Item Box

Outputs text rotated by specified number of degrees.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub TextRotated( _
   ByVal angle As Single, _
   ByVal pivotMode As RotationPivotMode, _
   ByVal text As String, _
   ByVal font As Font _
)
'Usage

Dim instance As Draw
Dim angle As Single
Dim pivotMode As RotationPivotMode
Dim text As String
Dim font As Font

instance.TextRotated(angle, pivotMode, text, font)
public void TextRotated(
   float angle,
   RotationPivotMode pivotMode,
   string text,
   Font font
)
public: void TextRotated(
   float angle,
   RotationPivotMode pivotMode,
   string* text,
   Font* font
)
public:
void TextRotated(
   float angle,
   RotationPivotMode pivotMode,
   String^ text,
   Font^ font
)

Parameters

angle
A single which represents the angle by which to rotate.
pivotMode
The RotationPivotMode the text is aligned to the rotation by.
text
A string which represents the text to output.
font
The System.Drawing.Font to render the text in.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
TextRotated(PointF,Single,RotationPivotMode,String) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > TextRotated Method : TextRotated(PointF,Single,RotationPivotMode,String) Method

location
A System.Drawing.Point which represents the location for the origin of rotation.
angle
A single value which represents the angle by which to rotate.
pivotMode
The RotationPivotMode the text is aligned to the rotation by.
text
A string which represents the text to output.

Glossary Item Box

Outputs text rotated by a specified number of degrees.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub TextRotated( _
   ByVal location As PointF, _
   ByVal angle As Single, _
   ByVal pivotMode As RotationPivotMode, _
   ByVal text As String _
)
'Usage

Dim instance As Draw
Dim location As PointF
Dim angle As Single
Dim pivotMode As RotationPivotMode
Dim text As String

instance.TextRotated(location, angle, pivotMode, text)
public void TextRotated(
   PointF location,
   float angle,
   RotationPivotMode pivotMode,
   string text
)
public: void TextRotated(
   PointF location,
   float angle,
   RotationPivotMode pivotMode,
   string* text
)
public:
void TextRotated(
   PointF location,
   float angle,
   RotationPivotMode pivotMode,
   String^ text
)

Parameters

location
A System.Drawing.Point which represents the location for the origin of rotation.
angle
A single value which represents the angle by which to rotate.
pivotMode
The RotationPivotMode the text is aligned to the rotation by.
text
A string which represents the text to output.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
TextRotated(Single,RotationPivotMode,String) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > TextRotated Method : TextRotated(Single,RotationPivotMode,String) Method

angle
A single value which represents the angle by which to rotate.
pivotMode
The RotationPivotMode the text is aligned to the rotation by.
text
A string which represents the text to output.

Glossary Item Box

Outputs text rotated by a specified number of degrees.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub TextRotated( _
   ByVal angle As Single, _
   ByVal pivotMode As RotationPivotMode, _
   ByVal text As String _
)
'Usage

Dim instance As Draw
Dim angle As Single
Dim pivotMode As RotationPivotMode
Dim text As String

instance.TextRotated(angle, pivotMode, text)
public void TextRotated(
   float angle,
   RotationPivotMode pivotMode,
   string text
)
public: void TextRotated(
   float angle,
   RotationPivotMode pivotMode,
   string* text
)
public:
void TextRotated(
   float angle,
   RotationPivotMode pivotMode,
   String^ text
)

Parameters

angle
A single value which represents the angle by which to rotate.
pivotMode
The RotationPivotMode the text is aligned to the rotation by.
text
A string which represents the text to output.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
TextRotated(Point,Single,RotationPivotMode,String,Font) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > TextRotated Method : TextRotated(Point,Single,RotationPivotMode,String,Font) Method

location
A System.Drawing.Point which represents the location for the origin of rotation.
angle
A single value which represents the angle by which to rotate.
pivotMode
The RotationPivotMode the text is aligned to the rotation by.
text
A string which represents the text to output.
font
The System.Drawing.Font to render the text in.

Glossary Item Box

Outputs text rotated by a specified number of degrees.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub TextRotated( _
   ByVal location As Point, _
   ByVal angle As Single, _
   ByVal pivotMode As RotationPivotMode, _
   ByVal text As String, _
   ByVal font As Font _
)
'Usage

Dim instance As Draw
Dim location As Point
Dim angle As Single
Dim pivotMode As RotationPivotMode
Dim text As String
Dim font As Font

instance.TextRotated(location, angle, pivotMode, text, font)
public void TextRotated(
   Point location,
   float angle,
   RotationPivotMode pivotMode,
   string text,
   Font font
)
public: void TextRotated(
   Point location,
   float angle,
   RotationPivotMode pivotMode,
   string* text,
   Font* font
)
public:
void TextRotated(
   Point location,
   float angle,
   RotationPivotMode pivotMode,
   String^ text,
   Font^ font
)

Parameters

location
A System.Drawing.Point which represents the location for the origin of rotation.
angle
A single value which represents the angle by which to rotate.
pivotMode
The RotationPivotMode the text is aligned to the rotation by.
text
A string which represents the text to output.
font
The System.Drawing.Font to render the text in.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
TextRotated(Point,Single,RotationPivotMode,String) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > TextRotated Method : TextRotated(Point,Single,RotationPivotMode,String) Method

location
A System.Drawing.Point which represents the location for the origin of rotation.
angle
A single value which represents the angle by which to rotate.
pivotMode
The RotationPivotMode the text is aligned to the rotation by.
text
A string which represents the text to output.

Glossary Item Box

Outputs text rotated by a specified number of degrees.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub TextRotated( _
   ByVal location As Point, _
   ByVal angle As Single, _
   ByVal pivotMode As RotationPivotMode, _
   ByVal text As String _
)
'Usage

Dim instance As Draw
Dim location As Point
Dim angle As Single
Dim pivotMode As RotationPivotMode
Dim text As String

instance.TextRotated(location, angle, pivotMode, text)
public void TextRotated(
   Point location,
   float angle,
   RotationPivotMode pivotMode,
   string text
)
public: void TextRotated(
   Point location,
   float angle,
   RotationPivotMode pivotMode,
   string* text
)
public:
void TextRotated(
   Point location,
   float angle,
   RotationPivotMode pivotMode,
   String^ text
)

Parameters

location
A System.Drawing.Point which represents the location for the origin of rotation.
angle
A single value which represents the angle by which to rotate.
pivotMode
The RotationPivotMode the text is aligned to the rotation by.
text
A string which represents the text to output.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
TextWidth Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class : TextWidth Method

Glossary Item Box

Returns the width the text would be if output with specified font.

Overload List

Overload | Description
TextWidth(Font,String) | Returns the width the text would be if output with specified font.
TextWidth(String) | Returns the width the text would be if output with the given text.

See Also

Reference

Draw Class
Draw Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
TextWidth(Font,String) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > TextWidth Method : TextWidth(Font,String) Method

font
A System.Drawing.Font to use with the given text.
text
A string which represents the text to get the printed height of.

Glossary Item Box

Returns the width the text would be if output with specified font.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Function TextWidth( _
   ByVal font As Font, _
   ByVal text As String _
) As Single
'Usage

Dim instance As Draw
Dim font As Font
Dim text As String
Dim value As Single

value = instance.TextWidth(font, text)
public float TextWidth(
   Font font,
   string text
)
public: float TextWidth(
   Font* font,
   string* text
)
public:
float TextWidth(
   Font^ font,
   String^ text
)

Parameters

font
A System.Drawing.Font to use with the given text.
text
A string which represents the text to get the printed height of.

Return Value

A float value which represents the width of the text when printed.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
TextWidth(String) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class > TextWidth Method : TextWidth(String) Method

text
A string which represents the text to get the printed height of.

Glossary Item Box

Returns the width the text would be if output with the given text.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Function TextWidth( _
   ByVal text As String _
) As Single
'Usage

Dim instance As Draw
Dim text As String
Dim value As Single

value = instance.TextWidth(text)
public float TextWidth(
   string text
)
public: float TextWidth(
   string* text
)
public:
float TextWidth(
   String^ text
)

Parameters

text
A string which represents the text to get the printed height of.

Return Value

A float value which represents the width of the text when printed.

See Also

Reference

Draw Class
Draw Members
Overload List


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
Draw Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : Draw Class

Glossary Item Box

For a list of all members of this type, see Draw members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets and sets the background color used for drawing.
Public Property | BackStyle | Gets and sets the background style used for drawing.
Public Property | CurrentX | Gets and sets the current x (horizontal) coordinate the draw cursor is at.
Public Property | CurrentY | Gets and sets the current y (vertical) coordinate the draw cursor is at.
Public Property | FillColor | Gets and sets the fill color used for drawing.
Public Property | FillStyle | Gets and sets the FillStyle used for drawing.
Public Property | ForeColor | Gets and sets the foreground color used for drawing.
Public Property | Mode | Gets and sets the DrawMode enumeration value used for drawing.
Public Property | Style | Gets and sets the DrawStyle used for drawing.
Public Property | Width | Gets and sets the width of the pen used for drawing.
Top

See Also

Reference

Draw Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
BackColor Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class : BackColor Property

Glossary Item Box

Gets and sets the background color used for drawing.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property BackColor As Color
'Usage

Dim instance As Draw
Dim value As Color

instance.BackColor = value

value = instance.BackColor
public Color BackColor {get; set;}
public: __property Color get_BackColor();
public: __property void set_BackColor(
   Color value
);
public:
property Color BackColor {
   Color get();
   void set (    Color value);
}

Property Value

A System.Drawing.Color used as the background color in drawing.

See Also

Reference

Draw Class
Draw Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
BackStyle Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class : BackStyle Property

Glossary Item Box

Gets and sets the background style used for drawing.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property BackStyle As BackStyle
'Usage

Dim instance As Draw
Dim value As BackStyle

instance.BackStyle = value

value = instance.BackStyle
public BackStyle BackStyle {get; set;}
public: __property BackStyle get_BackStyle();
public: __property void set_BackStyle(
   BackStyle value
);
public:
property BackStyle BackStyle {
   BackStyle get();
   void set (    BackStyle value);
}

Property Value

A BackStyle enumeration value which determines the background style used for drawing.

Remarks

The default value is BackStyle.Transparent.

See Also

Reference

Draw Class
Draw Members
BackStyle Enumeration


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CurrentX Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class : CurrentX Property

Glossary Item Box

Gets and sets the current x (horizontal) coordinate the draw cursor is at.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property CurrentX As Single
'Usage

Dim instance As Draw
Dim value As Single

instance.CurrentX = value

value = instance.CurrentX
public float CurrentX {get; set;}
public: __property float get_CurrentX();
public: __property void set_CurrentX(
   float value
);
public:
property float CurrentX {
   float get();
   void set (    float value);
}

Property Value

A single value which represents the x coordinate.

See Also

Reference

Draw Class
Draw Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CurrentY Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class : CurrentY Property

Glossary Item Box

Gets and sets the current y (vertical) coordinate the draw cursor is at.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property CurrentY As Single
'Usage

Dim instance As Draw
Dim value As Single

instance.CurrentY = value

value = instance.CurrentY
public float CurrentY {get; set;}
public: __property float get_CurrentY();
public: __property void set_CurrentY(
   float value
);
public:
property float CurrentY {
   float get();
   void set (    float value);
}

Property Value

A single value which represents the y coordinate.

See Also

Reference

Draw Class
Draw Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
FillColor Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class : FillColor Property

Glossary Item Box

Gets and sets the fill color used for drawing.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property FillColor As Color
'Usage

Dim instance As Draw
Dim value As Color

instance.FillColor = value

value = instance.FillColor
public Color FillColor {get; set;}
public: __property Color get_FillColor();
public: __property void set_FillColor(
   Color value
);
public:
property Color FillColor {
   Color get();
   void set (    Color value);
}

Property Value

A System.Drawing.Color value used as the fill color for drawing.

See Also

Reference

Draw Class
Draw Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
FillStyle Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class : FillStyle Property

Glossary Item Box

Gets and sets the FillStyle used for drawing.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property FillStyle As FillStyle
'Usage

Dim instance As Draw
Dim value As FillStyle

instance.FillStyle = value

value = instance.FillStyle
public FillStyle FillStyle {get; set;}
public: __property FillStyle get_FillStyle();
public: __property void set_FillStyle(
   FillStyle value
);
public:
property FillStyle FillStyle {
   FillStyle get();
   void set (    FillStyle value);
}

Property Value

A FillStyle enumeration value which determines the fill style used for drawing.

Remarks

The default value is FillStyle.Transparent.

See Also

Reference

Draw Class
Draw Members
FillStyle Enumeration


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
ForeColor Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class : ForeColor Property

Glossary Item Box

Gets and sets the foreground color used for drawing.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property ForeColor As Color
'Usage

Dim instance As Draw
Dim value As Color

instance.ForeColor = value

value = instance.ForeColor
public Color ForeColor {get; set;}
public: __property Color get_ForeColor();
public: __property void set_ForeColor(
   Color value
);
public:
property Color ForeColor {
   Color get();
   void set (    Color value);
}

Property Value

A System.Drawing.Color value used for the foreground color in drawing.

See Also

Reference

Draw Class
Draw Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Mode Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class : Mode Property

Glossary Item Box

Gets and sets the DrawMode enumeration value used for drawing.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property Mode As DrawMode
'Usage

Dim instance As Draw
Dim value As DrawMode

instance.Mode = value

value = instance.Mode
public DrawMode Mode {get; set;}
public: __property DrawMode get_Mode();
public: __property void set_Mode(
   DrawMode value
);
public:
property DrawMode Mode {
   DrawMode get();
   void set (    DrawMode value);
}

Property Value

A DrawMode enumeration option value which determines the mode for drawing.

Remarks

The default value is DrawMode.CopyPen.

See Also

Reference

Draw Class
Draw Members
DrawMode Enumeration


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Style Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class : Style Property

Glossary Item Box

Gets and sets the DrawStyle used for drawing.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property Style As DrawStyle
'Usage

Dim instance As Draw
Dim value As DrawStyle

instance.Style = value

value = instance.Style
public DrawStyle Style {get; set;}
public: __property DrawStyle get_Style();
public: __property void set_Style(
   DrawStyle value
);
public:
property DrawStyle Style {
   DrawStyle get();
   void set (    DrawStyle value);
}

Property Value

A DrawStyle enumeration value which determines the style used for drawing.

Remarks

The default value is DrawStyle.Solid.

See Also

Reference

Draw Class
Draw Members
DrawStyle Enumeration


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Width Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Draw Class : Width Property

Glossary Item Box

Gets and sets the width of the pen used for drawing.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property Width As Integer
'Usage

Dim instance As Draw
Dim value As Integer

instance.Width = value

value = instance.Width
public int Width {get; set;}
public: __property int get_Width();
public: __property void set_Width(
   int value
);
public:
property int Width {
   int get();
   void set (    int value);
}

Property Value

An integer which represents the width of the pen used for drawing.

Remarks

The default value is 0.

See Also

Reference

Draw Class
Draw Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
EndDocumentFailedException Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : EndDocumentFailedException Class

Glossary Item Box

This exception is thrown if an error occurs when ending a print job.

Object Model

EndDocumentFailedException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class EndDocumentFailedException
   Inherits PrintProException
'Usage

Dim instance As EndDocumentFailedException
[SerializableAttribute()]
public sealed class EndDocumentFailedException : PrintProException
[SerializableAttribute()]
public __gc __sealed class EndDocumentFailedException : public PrintProException
[SerializableAttribute()]
public ref class EndDocumentFailedException sealed : public PrintProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.PrintProSdk.PrintProException
Accusoft.PrintProSdk.EndDocumentFailedException

See Also

Reference

EndDocumentFailedException Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
EndDocumentFailedException Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : EndDocumentFailedException Class

Glossary Item Box

The following tables list the members exposed by EndDocumentFailedException.

Public Constructors

 | Name | Description
Public Constructor | EndDocumentFailedException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

EndDocumentFailedException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
EndDocumentFailedException Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : EndDocumentFailedException Class

Glossary Item Box

For a list of all members of this type, see EndDocumentFailedException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

EndDocumentFailedException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
EndDocumentFailedException Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : EndDocumentFailedException Class

Glossary Item Box

For a list of all members of this type, see EndDocumentFailedException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

EndDocumentFailedException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
EndDocumentFailedException Constructor
See Also Send Feedback
Accusoft.PrintProSdk Namespace > EndDocumentFailedException Class : EndDocumentFailedException Constructor

Glossary Item Box

Overload List

Overload | Description
EndDocumentFailedException Constructor() | An exception generated for a end document failed error.
EndDocumentFailedException Constructor(Int32) | Generated exception for a end document failed error with a given error number.
EndDocumentFailedException Constructor(String) | Generated exception for a end document failed error with a given string.
EndDocumentFailedException Constructor(Int32,String) | Generated exception for a end document failed error with a given error number and message.
EndDocumentFailedException Constructor(String,Exception) | Generated exception for a end document failed error with a given message and inner exception.

See Also

Reference

EndDocumentFailedException Class
EndDocumentFailedException Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
EndDocumentFailedException Constructor()
See Also Send Feedback
Accusoft.PrintProSdk Namespace > EndDocumentFailedException Class > EndDocumentFailedException Constructor : EndDocumentFailedException Constructor()

Glossary Item Box

An exception generated for a end document failed error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New EndDocumentFailedException()
public EndDocumentFailedException()
public: EndDocumentFailedException();
public:
EndDocumentFailedException();

See Also

Reference

EndDocumentFailedException Class
EndDocumentFailedException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
EndDocumentFailedException Constructor(Int32)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > EndDocumentFailedException Class > EndDocumentFailedException Constructor : EndDocumentFailedException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a end document failed error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New EndDocumentFailedException(errorNumber)
public EndDocumentFailedException(
   int errorNumber
)
public: EndDocumentFailedException(
   int errorNumber
)
public:
EndDocumentFailedException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

EndDocumentFailedException Class
EndDocumentFailedException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
EndDocumentFailedException Constructor(String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > EndDocumentFailedException Class > EndDocumentFailedException Constructor : EndDocumentFailedException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a end document failed error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New EndDocumentFailedException(message)
public EndDocumentFailedException(
   string message
)
public: EndDocumentFailedException(
   string* message
)
public:
EndDocumentFailedException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

EndDocumentFailedException Class
EndDocumentFailedException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
EndDocumentFailedException Constructor(Int32,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > EndDocumentFailedException Class > EndDocumentFailedException Constructor : EndDocumentFailedException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a end document failed error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New EndDocumentFailedException(errorNumber, message)
public EndDocumentFailedException(
   int errorNumber,
   string message
)
public: EndDocumentFailedException(
   int errorNumber,
   string* message
)
public:
EndDocumentFailedException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

EndDocumentFailedException Class
EndDocumentFailedException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
EndDocumentFailedException Constructor(String,Exception)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > EndDocumentFailedException Class > EndDocumentFailedException Constructor : EndDocumentFailedException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a end document failed error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New EndDocumentFailedException(message, innerException)
public EndDocumentFailedException(
   string message,
   Exception innerException
)
public: EndDocumentFailedException(
   string* message,
   Exception* innerException
)
public:
EndDocumentFailedException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

EndDocumentFailedException Class
EndDocumentFailedException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
EndPageFailedException Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : EndPageFailedException Class

Glossary Item Box

This exception is thrown if an error occurs when ending a page.

Object Model

EndPageFailedException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class EndPageFailedException
   Inherits PrintProException
'Usage

Dim instance As EndPageFailedException
[SerializableAttribute()]
public sealed class EndPageFailedException : PrintProException
[SerializableAttribute()]
public __gc __sealed class EndPageFailedException : public PrintProException
[SerializableAttribute()]
public ref class EndPageFailedException sealed : public PrintProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.PrintProSdk.PrintProException
Accusoft.PrintProSdk.EndPageFailedException

See Also

Reference

EndPageFailedException Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
EndPageFailedException Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : EndPageFailedException Class

Glossary Item Box

The following tables list the members exposed by EndPageFailedException.

Public Constructors

 | Name | Description
Public Constructor | EndPageFailedException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

EndPageFailedException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
EndPageFailedException Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : EndPageFailedException Class

Glossary Item Box

For a list of all members of this type, see EndPageFailedException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

EndPageFailedException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
EndPageFailedException Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : EndPageFailedException Class

Glossary Item Box

For a list of all members of this type, see EndPageFailedException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

EndPageFailedException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
EndPageFailedException Constructor
See Also Send Feedback
Accusoft.PrintProSdk Namespace > EndPageFailedException Class : EndPageFailedException Constructor

Glossary Item Box

Overload List

Overload | Description
EndPageFailedException Constructor() | An exception generated for a end page failed error.
EndPageFailedException Constructor(Int32) | Generated exception for a end page failed error with a given error number.
EndPageFailedException Constructor(String) | Generated exception for a end page failed error with a given string.
EndPageFailedException Constructor(Int32,String) | Generated exception for a end page failed error with a given error number and message.
EndPageFailedException Constructor(String,Exception) | Generated exception for a end page failed error with a given message and inner exception.

See Also

Reference

EndPageFailedException Class
EndPageFailedException Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
EndPageFailedException Constructor()
See Also Send Feedback
Accusoft.PrintProSdk Namespace > EndPageFailedException Class > EndPageFailedException Constructor : EndPageFailedException Constructor()

Glossary Item Box

An exception generated for a end page failed error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New EndPageFailedException()
public EndPageFailedException()
public: EndPageFailedException();
public:
EndPageFailedException();

See Also

Reference

EndPageFailedException Class
EndPageFailedException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
EndPageFailedException Constructor(Int32)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > EndPageFailedException Class > EndPageFailedException Constructor : EndPageFailedException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a end page failed error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New EndPageFailedException(errorNumber)
public EndPageFailedException(
   int errorNumber
)
public: EndPageFailedException(
   int errorNumber
)
public:
EndPageFailedException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

EndPageFailedException Class
EndPageFailedException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
EndPageFailedException Constructor(String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > EndPageFailedException Class > EndPageFailedException Constructor : EndPageFailedException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a end page failed error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New EndPageFailedException(message)
public EndPageFailedException(
   string message
)
public: EndPageFailedException(
   string* message
)
public:
EndPageFailedException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

EndPageFailedException Class
EndPageFailedException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
EndPageFailedException Constructor(Int32,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > EndPageFailedException Class > EndPageFailedException Constructor : EndPageFailedException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a end page failed error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New EndPageFailedException(errorNumber, message)
public EndPageFailedException(
   int errorNumber,
   string message
)
public: EndPageFailedException(
   int errorNumber,
   string* message
)
public:
EndPageFailedException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

EndPageFailedException Class
EndPageFailedException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
EndPageFailedException Constructor(String,Exception)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > EndPageFailedException Class > EndPageFailedException Constructor : EndPageFailedException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a end page failed error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New EndPageFailedException(message, innerException)
public EndPageFailedException(
   string message,
   Exception innerException
)
public: EndPageFailedException(
   string* message,
   Exception* innerException
)
public:
EndPageFailedException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

EndPageFailedException Class
EndPageFailedException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
FileReadException Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : FileReadException Class

Glossary Item Box

This exception is thrown if an error occurs when reading the file.

Object Model

FileReadException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class FileReadException
   Inherits PrintProException
'Usage

Dim instance As FileReadException
[SerializableAttribute()]
public sealed class FileReadException : PrintProException
[SerializableAttribute()]
public __gc __sealed class FileReadException : public PrintProException
[SerializableAttribute()]
public ref class FileReadException sealed : public PrintProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.PrintProSdk.PrintProException
Accusoft.PrintProSdk.FileReadException

See Also

Reference

FileReadException Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
FileReadException Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : FileReadException Class

Glossary Item Box

The following tables list the members exposed by FileReadException.

Public Constructors

 | Name | Description
Public Constructor | FileReadException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

FileReadException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
FileReadException Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : FileReadException Class

Glossary Item Box

For a list of all members of this type, see FileReadException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

FileReadException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
FileReadException Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : FileReadException Class

Glossary Item Box

For a list of all members of this type, see FileReadException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

FileReadException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
FileReadException Constructor
See Also Send Feedback
Accusoft.PrintProSdk Namespace > FileReadException Class : FileReadException Constructor

Glossary Item Box

Overload List

Overload | Description
FileReadException Constructor() | An exception generated for a file read error.
FileReadException Constructor(Int32) | Generated exception for a file read error with a given error number.
FileReadException Constructor(String) | Generated exception for a file read error with a given string.
FileReadException Constructor(Int32,String) | Generated exception for a file read error with a given error number and message.
FileReadException Constructor(String,Exception) | Generated exception for a file read error with a given message and inner exception.

See Also

Reference

FileReadException Class
FileReadException Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
FileReadException Constructor()
See Also Send Feedback
Accusoft.PrintProSdk Namespace > FileReadException Class > FileReadException Constructor : FileReadException Constructor()

Glossary Item Box

An exception generated for a file read error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New FileReadException()
public FileReadException()
public: FileReadException();
public:
FileReadException();

See Also

Reference

FileReadException Class
FileReadException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
FileReadException Constructor(Int32)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > FileReadException Class > FileReadException Constructor : FileReadException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a file read error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New FileReadException(errorNumber)
public FileReadException(
   int errorNumber
)
public: FileReadException(
   int errorNumber
)
public:
FileReadException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

FileReadException Class
FileReadException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
FileReadException Constructor(String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > FileReadException Class > FileReadException Constructor : FileReadException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a file read error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New FileReadException(message)
public FileReadException(
   string message
)
public: FileReadException(
   string* message
)
public:
FileReadException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

FileReadException Class
FileReadException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
FileReadException Constructor(Int32,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > FileReadException Class > FileReadException Constructor : FileReadException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a file read error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New FileReadException(errorNumber, message)
public FileReadException(
   int errorNumber,
   string message
)
public: FileReadException(
   int errorNumber,
   string* message
)
public:
FileReadException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

FileReadException Class
FileReadException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
FileReadException Constructor(String,Exception)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > FileReadException Class > FileReadException Constructor : FileReadException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a file read error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New FileReadException(message, innerException)
public FileReadException(
   string message,
   Exception innerException
)
public: FileReadException(
   string* message,
   Exception* innerException
)
public:
FileReadException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

FileReadException Class
FileReadException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
FileWriteException Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : FileWriteException Class

Glossary Item Box

This exception is thrown if an error occurs when writing the file.

Object Model

FileWriteException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class FileWriteException
   Inherits PrintProException
'Usage

Dim instance As FileWriteException
[SerializableAttribute()]
public sealed class FileWriteException : PrintProException
[SerializableAttribute()]
public __gc __sealed class FileWriteException : public PrintProException
[SerializableAttribute()]
public ref class FileWriteException sealed : public PrintProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.PrintProSdk.PrintProException
Accusoft.PrintProSdk.FileWriteException

See Also

Reference

FileWriteException Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
FileWriteException Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : FileWriteException Class

Glossary Item Box

The following tables list the members exposed by FileWriteException.

Public Constructors

 | Name | Description
Public Constructor | FileWriteException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

FileWriteException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
FileWriteException Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : FileWriteException Class

Glossary Item Box

For a list of all members of this type, see FileWriteException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

FileWriteException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
FileWriteException Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : FileWriteException Class

Glossary Item Box

For a list of all members of this type, see FileWriteException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

FileWriteException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
FileWriteException Constructor
See Also Send Feedback
Accusoft.PrintProSdk Namespace > FileWriteException Class : FileWriteException Constructor

Glossary Item Box

Overload List

Overload | Description
FileWriteException Constructor() | An exception generated for a file write error.
FileWriteException Constructor(Int32) | Generated exception for a file write error with a given error number.
FileWriteException Constructor(String) | Generated exception for a file write error with a given string.
FileWriteException Constructor(Int32,String) | Generated exception for a file write error with a given error number and message.
FileWriteException Constructor(String,Exception) | Generated exception for a file write error with a given message and inner exception.

See Also

Reference

FileWriteException Class
FileWriteException Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
FileWriteException Constructor()
See Also Send Feedback
Accusoft.PrintProSdk Namespace > FileWriteException Class > FileWriteException Constructor : FileWriteException Constructor()

Glossary Item Box

An exception generated for a file write error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New FileWriteException()
public FileWriteException()
public: FileWriteException();
public:
FileWriteException();

See Also

Reference

FileWriteException Class
FileWriteException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
FileWriteException Constructor(Int32)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > FileWriteException Class > FileWriteException Constructor : FileWriteException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a file write error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New FileWriteException(errorNumber)
public FileWriteException(
   int errorNumber
)
public: FileWriteException(
   int errorNumber
)
public:
FileWriteException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

FileWriteException Class
FileWriteException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
FileWriteException Constructor(String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > FileWriteException Class > FileWriteException Constructor : FileWriteException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a file write error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New FileWriteException(message)
public FileWriteException(
   string message
)
public: FileWriteException(
   string* message
)
public:
FileWriteException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

FileWriteException Class
FileWriteException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
FileWriteException Constructor(Int32,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > FileWriteException Class > FileWriteException Constructor : FileWriteException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a file write error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New FileWriteException(errorNumber, message)
public FileWriteException(
   int errorNumber,
   string message
)
public: FileWriteException(
   int errorNumber,
   string* message
)
public:
FileWriteException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

FileWriteException Class
FileWriteException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
FileWriteException Constructor(String,Exception)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > FileWriteException Class > FileWriteException Constructor : FileWriteException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a file write error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New FileWriteException(message, innerException)
public FileWriteException(
   string message,
   Exception innerException
)
public: FileWriteException(
   string* message,
   Exception* innerException
)
public:
FileWriteException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

FileWriteException Class
FileWriteException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
GenericGdiException Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : GenericGdiException Class

Glossary Item Box

This exception is thrown if a generic GDI error occurs.

Object Model

GenericGdiException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class GenericGdiException
   Inherits PrintProException
'Usage

Dim instance As GenericGdiException
[SerializableAttribute()]
public sealed class GenericGdiException : PrintProException
[SerializableAttribute()]
public __gc __sealed class GenericGdiException : public PrintProException
[SerializableAttribute()]
public ref class GenericGdiException sealed : public PrintProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.PrintProSdk.PrintProException
Accusoft.PrintProSdk.GenericGdiException

See Also

Reference

GenericGdiException Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
GenericGdiException Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : GenericGdiException Class

Glossary Item Box

The following tables list the members exposed by GenericGdiException.

Public Constructors

 | Name | Description
Public Constructor | GenericGdiException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

GenericGdiException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
GenericGdiException Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : GenericGdiException Class

Glossary Item Box

For a list of all members of this type, see GenericGdiException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

GenericGdiException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
GenericGdiException Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : GenericGdiException Class

Glossary Item Box

For a list of all members of this type, see GenericGdiException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

GenericGdiException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
GenericGdiException Constructor
See Also Send Feedback
Accusoft.PrintProSdk Namespace > GenericGdiException Class : GenericGdiException Constructor

Glossary Item Box

Overload List

Overload | Description
GenericGdiException Constructor() | An exception generated for a generic GDI error.
GenericGdiException Constructor(Int32) | Generated exception for a generic GDI error with a given error number.
GenericGdiException Constructor(String) | Generated exception for a generic GDI error with a given string.
GenericGdiException Constructor(Int32,String) | Generated exception for a generic GDI error with a given error number and message.
GenericGdiException Constructor(String,Exception) | Generated exception for a generic GDI error with a given message and inner exception.

See Also

Reference

GenericGdiException Class
GenericGdiException Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
GenericGdiException Constructor()
See Also Send Feedback
Accusoft.PrintProSdk Namespace > GenericGdiException Class > GenericGdiException Constructor : GenericGdiException Constructor()

Glossary Item Box

An exception generated for a generic GDI error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New GenericGdiException()
public GenericGdiException()
public: GenericGdiException();
public:
GenericGdiException();

See Also

Reference

GenericGdiException Class
GenericGdiException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
GenericGdiException Constructor(Int32)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > GenericGdiException Class > GenericGdiException Constructor : GenericGdiException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a generic GDI error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New GenericGdiException(errorNumber)
public GenericGdiException(
   int errorNumber
)
public: GenericGdiException(
   int errorNumber
)
public:
GenericGdiException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

GenericGdiException Class
GenericGdiException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
GenericGdiException Constructor(String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > GenericGdiException Class > GenericGdiException Constructor : GenericGdiException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a generic GDI error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New GenericGdiException(message)
public GenericGdiException(
   string message
)
public: GenericGdiException(
   string* message
)
public:
GenericGdiException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

GenericGdiException Class
GenericGdiException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
GenericGdiException Constructor(Int32,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > GenericGdiException Class > GenericGdiException Constructor : GenericGdiException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a generic GDI error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New GenericGdiException(errorNumber, message)
public GenericGdiException(
   int errorNumber,
   string message
)
public: GenericGdiException(
   int errorNumber,
   string* message
)
public:
GenericGdiException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

GenericGdiException Class
GenericGdiException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
GenericGdiException Constructor(String,Exception)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > GenericGdiException Class > GenericGdiException Constructor : GenericGdiException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a generic GDI error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New GenericGdiException(message, innerException)
public GenericGdiException(
   string message,
   Exception innerException
)
public: GenericGdiException(
   string* message,
   Exception* innerException
)
public:
GenericGdiException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

GenericGdiException Class
GenericGdiException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
GenericWin32Exception Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : GenericWin32Exception Class

Glossary Item Box

This exception is thrown if a generic Win32 error occurs.

Object Model

GenericWin32Exception Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class GenericWin32Exception
   Inherits PrintProException
'Usage

Dim instance As GenericWin32Exception
[SerializableAttribute()]
public sealed class GenericWin32Exception : PrintProException
[SerializableAttribute()]
public __gc __sealed class GenericWin32Exception : public PrintProException
[SerializableAttribute()]
public ref class GenericWin32Exception sealed : public PrintProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.PrintProSdk.PrintProException
Accusoft.PrintProSdk.GenericWin32Exception

See Also

Reference

GenericWin32Exception Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
GenericWin32Exception Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : GenericWin32Exception Class

Glossary Item Box

The following tables list the members exposed by GenericWin32Exception.

Public Constructors

 | Name | Description
Public Constructor | GenericWin32Exception Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

GenericWin32Exception Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
GenericWin32Exception Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : GenericWin32Exception Class

Glossary Item Box

For a list of all members of this type, see GenericWin32Exception members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

GenericWin32Exception Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
GenericWin32Exception Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : GenericWin32Exception Class

Glossary Item Box

For a list of all members of this type, see GenericWin32Exception members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

GenericWin32Exception Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
GenericWin32Exception Constructor
See Also Send Feedback
Accusoft.PrintProSdk Namespace > GenericWin32Exception Class : GenericWin32Exception Constructor

Glossary Item Box

Overload List

Overload | Description
GenericWin32Exception Constructor() | An exception generated for a generic Win32 error.
GenericWin32Exception Constructor(Int32) | Generated exception for a generic Win32 error with a given error number.
GenericWin32Exception Constructor(String) | Generated exception for a generic Win32 error with a given string.
GenericWin32Exception Constructor(Int32,String) | Generated exception for a generic Win32 error with a given error number and message.
GenericWin32Exception Constructor(String,Exception) | Generated exception for a generic Win32 error with a given message and inner exception.

See Also

Reference

GenericWin32Exception Class
GenericWin32Exception Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
GenericWin32Exception Constructor()
See Also Send Feedback
Accusoft.PrintProSdk Namespace > GenericWin32Exception Class > GenericWin32Exception Constructor : GenericWin32Exception Constructor()

Glossary Item Box

An exception generated for a generic Win32 error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New GenericWin32Exception()
public GenericWin32Exception()
public: GenericWin32Exception();
public:
GenericWin32Exception();

See Also

Reference

GenericWin32Exception Class
GenericWin32Exception Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
GenericWin32Exception Constructor(Int32)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > GenericWin32Exception Class > GenericWin32Exception Constructor : GenericWin32Exception Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a generic Win32 error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New GenericWin32Exception(errorNumber)
public GenericWin32Exception(
   int errorNumber
)
public: GenericWin32Exception(
   int errorNumber
)
public:
GenericWin32Exception(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

GenericWin32Exception Class
GenericWin32Exception Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
GenericWin32Exception Constructor(String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > GenericWin32Exception Class > GenericWin32Exception Constructor : GenericWin32Exception Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a generic Win32 error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New GenericWin32Exception(message)
public GenericWin32Exception(
   string message
)
public: GenericWin32Exception(
   string* message
)
public:
GenericWin32Exception(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

GenericWin32Exception Class
GenericWin32Exception Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
GenericWin32Exception Constructor(Int32,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > GenericWin32Exception Class > GenericWin32Exception Constructor : GenericWin32Exception Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a generic Win32 error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New GenericWin32Exception(errorNumber, message)
public GenericWin32Exception(
   int errorNumber,
   string message
)
public: GenericWin32Exception(
   int errorNumber,
   string* message
)
public:
GenericWin32Exception(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

GenericWin32Exception Class
GenericWin32Exception Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
GenericWin32Exception Constructor(String,Exception)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > GenericWin32Exception Class > GenericWin32Exception Constructor : GenericWin32Exception Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a generic Win32 error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New GenericWin32Exception(message, innerException)
public GenericWin32Exception(
   string message,
   Exception innerException
)
public: GenericWin32Exception(
   string* message,
   Exception* innerException
)
public:
GenericWin32Exception(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

GenericWin32Exception Class
GenericWin32Exception Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Icm Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : Icm Class

Glossary Item Box

Ths class implements image color matching settings.

Object Model

Icm Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Class Icm
'Usage

Dim instance As Icm
public class Icm
public __gc class Icm
public ref class Icm

Inheritance Hierarchy

System.Object
Accusoft.PrintProSdk.Icm

See Also

Reference

Icm Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
Icm Class Members
See Also Properties Send Feedback
Accusoft.PrintProSdk Namespace : Icm Class

Glossary Item Box

The following tables list the members exposed by Icm.

Public Constructors

 | Name | Description
Public Constructor | Icm Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Intent | Gets and sets a value that specifies which of three possible color management methods, or intents, should be used by default (if the printer supports this feature).
Public Property | Method | Gets and sets a value that specifies how Image Color Management (ICM) is handled.
Public Property | MonitorProfile | Gets and sets the file name of the monitor's color management profile.
Public Property | PrinterProfile | Gets and sets the filename of the printer's color management profile.
Public Property | RenderIntent | Gets and sets the purpose of the color correction.
Public Property | WantProof | Gets and sets an indicator that proof print matching is requested.
Top

See Also

Reference

Icm Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Icm Constructor
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Icm Class : Icm Constructor

Glossary Item Box

Overload List

Overload | Description
Icm Constructor() | The main ICM (Image Color Matching) settings constructor for use in print jobs.
Icm Constructor(String,String) | Creates an ICM settings object for use in print job construction.
Icm Constructor(String,String,IcmRenderIntent) | Creates an ICM settings object for use in print job construction.

See Also

Reference

Icm Class
Icm Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Icm Constructor()
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Icm Class > Icm Constructor : Icm Constructor()

Glossary Item Box

The main ICM (Image Color Matching) settings constructor for use in print jobs.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New Icm()
public Icm()
public: Icm();
public:
Icm();

See Also

Reference

Icm Class
Icm Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Icm Constructor(String,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Icm Class > Icm Constructor : Icm Constructor(String,String)

monitorProfile
A string which represents the filename of the monitor's color management profile.
printerProfile
A string which represents the filename of the printer's color management profile.

Glossary Item Box

Creates an ICM settings object for use in print job construction.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal monitorProfile As String, _
   ByVal printerProfile As String _
)
'Usage

Dim monitorProfile As String
Dim printerProfile As String

Dim instance As New Icm(monitorProfile, printerProfile)
public Icm(
   string monitorProfile,
   string printerProfile
)
public: Icm(
   string* monitorProfile,
   string* printerProfile
)
public:
Icm(
   String^ monitorProfile,
   String^ printerProfile
)

Parameters

monitorProfile
A string which represents the filename of the monitor's color management profile.
printerProfile
A string which represents the filename of the printer's color management profile.

Remarks

It automatically sets the method used to profile, and the profiles for use to the values below.

See Also

Reference

Icm Class
Icm Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Icm Constructor(String,String,IcmRenderIntent)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Icm Class > Icm Constructor : Icm Constructor(String,String,IcmRenderIntent)

monitorProfile
A string which represents the filename of the monitor's color management profile.
printerProfile
A string which represents the filename of the printer's color management profile.
profileRenderIntent
An IcmRenderIntent enumeration value which specifies the purpose of the color correction.

Glossary Item Box

Creates an ICM settings object for use in print job construction.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal monitorProfile As String, _
   ByVal printerProfile As String, _
   ByVal profileRenderIntent As IcmRenderIntent _
)
'Usage

Dim monitorProfile As String
Dim printerProfile As String
Dim profileRenderIntent As IcmRenderIntent

Dim instance As New Icm(monitorProfile, printerProfile, profileRenderIntent)
public Icm(
   string monitorProfile,
   string printerProfile,
   IcmRenderIntent profileRenderIntent
)
public: Icm(
   string* monitorProfile,
   string* printerProfile,
   IcmRenderIntent profileRenderIntent
)
public:
Icm(
   String^ monitorProfile,
   String^ printerProfile,
   IcmRenderIntent profileRenderIntent
)

Parameters

monitorProfile
A string which represents the filename of the monitor's color management profile.
printerProfile
A string which represents the filename of the printer's color management profile.
profileRenderIntent
An IcmRenderIntent enumeration value which specifies the purpose of the color correction.

Remarks

It automatically sets the method used to profile, and the profiles for use to the values below. If the parameter ProfileRenderIntent is set to None, then Image Color Management is disabled.

See Also

Reference

Icm Class
Icm Members
Overload List


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
Icm Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : Icm Class

Glossary Item Box

For a list of all members of this type, see Icm members.

Public Properties

 | Name | Description
Public Property | Intent | Gets and sets a value that specifies which of three possible color management methods, or intents, should be used by default (if the printer supports this feature).
Public Property | Method | Gets and sets a value that specifies how Image Color Management (ICM) is handled.
Public Property | MonitorProfile | Gets and sets the file name of the monitor's color management profile.
Public Property | PrinterProfile | Gets and sets the filename of the printer's color management profile.
Public Property | RenderIntent | Gets and sets the purpose of the color correction.
Public Property | WantProof | Gets and sets an indicator that proof print matching is requested.
Top

See Also

Reference

Icm Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Intent Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Icm Class : Intent Property

Glossary Item Box

Gets and sets a value that specifies which of three possible color management methods, or intents, should be used by default (if the printer supports this feature).

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property Intent As IcmIntent
'Usage

Dim instance As Icm
Dim value As IcmIntent

instance.Intent = value

value = instance.Intent
public IcmIntent Intent {get; set;}
public: __property IcmIntent get_Intent();
public: __property void set_Intent(
   IcmIntent value
);
public:
property IcmIntent Intent {
   IcmIntent get();
   void set (    IcmIntent value);
}

Property Value

An IcmIntent enumeration value which determines the color management methods.

Remarks

The default value is IcmIntent.ColorMetric.

See Also

Reference

Icm Class
Icm Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Method Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Icm Class : Method Property

Glossary Item Box

Gets and sets a value that specifies how Image Color Management (ICM) is handled.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property Method As IcmMethod
'Usage

Dim instance As Icm
Dim value As IcmMethod

instance.Method = value

value = instance.Method
public IcmMethod Method {get; set;}
public: __property IcmMethod get_Method();
public: __property void set_Method(
   IcmMethod value
);
public:
property IcmMethod Method {
   IcmMethod get();
   void set (    IcmMethod value);
}

Property Value

An IcmMethod enumeration value which determines how ICM is handled.

Remarks

The default value is IcmMethod.System.

See Also

Reference

Icm Class
Icm Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
MonitorProfile Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Icm Class : MonitorProfile Property

Glossary Item Box

Gets and sets the file name of the monitor's color management profile.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property MonitorProfile As String
'Usage

Dim instance As Icm
Dim value As String

instance.MonitorProfile = value

value = instance.MonitorProfile
public string MonitorProfile {get; set;}
public: __property string* get_MonitorProfile();
public: __property void set_MonitorProfile(
   string* value
);
public:
property String^ MonitorProfile {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value which represents the filename of the monitor's color management profile.

Remarks

The default value is an empty string "".

See Also

Reference

Icm Class
Icm Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrinterProfile Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Icm Class : PrinterProfile Property

Glossary Item Box

Gets and sets the filename of the printer's color management profile.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property PrinterProfile As String
'Usage

Dim instance As Icm
Dim value As String

instance.PrinterProfile = value

value = instance.PrinterProfile
public string PrinterProfile {get; set;}
public: __property string* get_PrinterProfile();
public: __property void set_PrinterProfile(
   string* value
);
public:
property String^ PrinterProfile {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value which represents the filename of the printer's color management profile.

Remarks

The default value is an empty string "".

See Also

Reference

Icm Class
Icm Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
RenderIntent Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Icm Class : RenderIntent Property

Glossary Item Box

Gets and sets the purpose of the color correction.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property RenderIntent As IcmRenderIntent
'Usage

Dim instance As Icm
Dim value As IcmRenderIntent

instance.RenderIntent = value

value = instance.RenderIntent
public IcmRenderIntent RenderIntent {get; set;}
public: __property IcmRenderIntent get_RenderIntent();
public: __property void set_RenderIntent(
   IcmRenderIntent value
);
public:
property IcmRenderIntent RenderIntent {
   IcmRenderIntent get();
   void set (    IcmRenderIntent value);
}

Property Value

An IcmRenderIntent enumeration value which determines the purpose of the color correction.

Remarks

The default value is IcmRenderIntent.Images.

See Also

Reference

Icm Class
Icm Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
WantProof Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Icm Class : WantProof Property

Glossary Item Box

Gets and sets an indicator that proof print matching is requested.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property WantProof As Boolean
'Usage

Dim instance As Icm
Dim value As Boolean

instance.WantProof = value

value = instance.WantProof
public bool WantProof {get; set;}
public: __property bool get_WantProof();
public: __property void set_WantProof(
   bool value
);
public:
property bool WantProof {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true when proof print matching is requested. Otherwise, false is returned.

Remarks

The default value is false.

See Also

Reference

Icm Class
Icm Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InternalErrorException Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : InternalErrorException Class

Glossary Item Box

This exception is thrown if an internal error occurs.

Object Model

InternalErrorException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class InternalErrorException
   Inherits PrintProException
'Usage

Dim instance As InternalErrorException
[SerializableAttribute()]
public sealed class InternalErrorException : PrintProException
[SerializableAttribute()]
public __gc __sealed class InternalErrorException : public PrintProException
[SerializableAttribute()]
public ref class InternalErrorException sealed : public PrintProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.PrintProSdk.PrintProException
Accusoft.PrintProSdk.InternalErrorException

See Also

Reference

InternalErrorException Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
InternalErrorException Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : InternalErrorException Class

Glossary Item Box

The following tables list the members exposed by InternalErrorException.

Public Constructors

 | Name | Description
Public Constructor | InternalErrorException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InternalErrorException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
InternalErrorException Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : InternalErrorException Class

Glossary Item Box

For a list of all members of this type, see InternalErrorException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InternalErrorException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
InternalErrorException Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : InternalErrorException Class

Glossary Item Box

For a list of all members of this type, see InternalErrorException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InternalErrorException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InternalErrorException Constructor
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InternalErrorException Class : InternalErrorException Constructor

Glossary Item Box

Overload List

Overload | Description
InternalErrorException Constructor() | An exception generated for a internal error error.
InternalErrorException Constructor(Int32) | Generated exception for a internal error error with a given error number.
InternalErrorException Constructor(String) | Generated exception for a internal error error with a given string.
InternalErrorException Constructor(Int32,String) | Generated exception for a internal error error with a given error number and message.
InternalErrorException Constructor(String,Exception) | Generated exception for a internal error error with a given message and inner exception.

See Also

Reference

InternalErrorException Class
InternalErrorException Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InternalErrorException Constructor()
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InternalErrorException Class > InternalErrorException Constructor : InternalErrorException Constructor()

Glossary Item Box

An exception generated for a internal error error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New InternalErrorException()
public InternalErrorException()
public: InternalErrorException();
public:
InternalErrorException();

See Also

Reference

InternalErrorException Class
InternalErrorException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InternalErrorException Constructor(Int32)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InternalErrorException Class > InternalErrorException Constructor : InternalErrorException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a internal error error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New InternalErrorException(errorNumber)
public InternalErrorException(
   int errorNumber
)
public: InternalErrorException(
   int errorNumber
)
public:
InternalErrorException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

InternalErrorException Class
InternalErrorException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InternalErrorException Constructor(String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InternalErrorException Class > InternalErrorException Constructor : InternalErrorException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a internal error error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New InternalErrorException(message)
public InternalErrorException(
   string message
)
public: InternalErrorException(
   string* message
)
public:
InternalErrorException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

InternalErrorException Class
InternalErrorException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InternalErrorException Constructor(Int32,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InternalErrorException Class > InternalErrorException Constructor : InternalErrorException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a internal error error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New InternalErrorException(errorNumber, message)
public InternalErrorException(
   int errorNumber,
   string message
)
public: InternalErrorException(
   int errorNumber,
   string* message
)
public:
InternalErrorException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

InternalErrorException Class
InternalErrorException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InternalErrorException Constructor(String,Exception)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InternalErrorException Class > InternalErrorException Constructor : InternalErrorException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a internal error error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New InternalErrorException(message, innerException)
public InternalErrorException(
   string message,
   Exception innerException
)
public: InternalErrorException(
   string* message,
   Exception* innerException
)
public:
InternalErrorException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

InternalErrorException Class
InternalErrorException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidAngleException Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : InvalidAngleException Class

Glossary Item Box

This exception is thrown if the specified angle is invalid.

Object Model

InvalidAngleException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class InvalidAngleException
   Inherits PrintProException
'Usage

Dim instance As InvalidAngleException
[SerializableAttribute()]
public sealed class InvalidAngleException : PrintProException
[SerializableAttribute()]
public __gc __sealed class InvalidAngleException : public PrintProException
[SerializableAttribute()]
public ref class InvalidAngleException sealed : public PrintProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.PrintProSdk.PrintProException
Accusoft.PrintProSdk.InvalidAngleException

See Also

Reference

InvalidAngleException Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
InvalidAngleException Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : InvalidAngleException Class

Glossary Item Box

The following tables list the members exposed by InvalidAngleException.

Public Constructors

 | Name | Description
Public Constructor | InvalidAngleException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidAngleException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
InvalidAngleException Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : InvalidAngleException Class

Glossary Item Box

For a list of all members of this type, see InvalidAngleException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidAngleException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
InvalidAngleException Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : InvalidAngleException Class

Glossary Item Box

For a list of all members of this type, see InvalidAngleException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidAngleException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidAngleException Constructor
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidAngleException Class : InvalidAngleException Constructor

Glossary Item Box

Overload List

Overload | Description
InvalidAngleException Constructor() | An exception generated for a invalid angle error.
InvalidAngleException Constructor(Int32) | Generated exception for a invalid angle error with a given error number.
InvalidAngleException Constructor(String) | Generated exception for a invalid angle error with a given string.
InvalidAngleException Constructor(Int32,String) | Generated exception for a invalid angle error with a given error number and message.
InvalidAngleException Constructor(String,Exception) | Generated exception for a invalid angle error with a given message and inner exception.

See Also

Reference

InvalidAngleException Class
InvalidAngleException Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidAngleException Constructor()
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidAngleException Class > InvalidAngleException Constructor : InvalidAngleException Constructor()

Glossary Item Box

An exception generated for a invalid angle error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New InvalidAngleException()
public InvalidAngleException()
public: InvalidAngleException();
public:
InvalidAngleException();

See Also

Reference

InvalidAngleException Class
InvalidAngleException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidAngleException Constructor(Int32)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidAngleException Class > InvalidAngleException Constructor : InvalidAngleException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a invalid angle error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New InvalidAngleException(errorNumber)
public InvalidAngleException(
   int errorNumber
)
public: InvalidAngleException(
   int errorNumber
)
public:
InvalidAngleException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

InvalidAngleException Class
InvalidAngleException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidAngleException Constructor(String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidAngleException Class > InvalidAngleException Constructor : InvalidAngleException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a invalid angle error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New InvalidAngleException(message)
public InvalidAngleException(
   string message
)
public: InvalidAngleException(
   string* message
)
public:
InvalidAngleException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

InvalidAngleException Class
InvalidAngleException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidAngleException Constructor(Int32,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidAngleException Class > InvalidAngleException Constructor : InvalidAngleException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a invalid angle error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New InvalidAngleException(errorNumber, message)
public InvalidAngleException(
   int errorNumber,
   string message
)
public: InvalidAngleException(
   int errorNumber,
   string* message
)
public:
InvalidAngleException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

InvalidAngleException Class
InvalidAngleException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidAngleException Constructor(String,Exception)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidAngleException Class > InvalidAngleException Constructor : InvalidAngleException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a invalid angle error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New InvalidAngleException(message, innerException)
public InvalidAngleException(
   string message,
   Exception innerException
)
public: InvalidAngleException(
   string* message,
   Exception* innerException
)
public:
InvalidAngleException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

InvalidAngleException Class
InvalidAngleException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidBinIDException Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : InvalidBinIDException Class

Glossary Item Box

This exception is thrown if the specified bin ID is invalid.

Object Model

InvalidBinIDException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class InvalidBinIDException
   Inherits PrintProException
'Usage

Dim instance As InvalidBinIDException
[SerializableAttribute()]
public sealed class InvalidBinIDException : PrintProException
[SerializableAttribute()]
public __gc __sealed class InvalidBinIDException : public PrintProException
[SerializableAttribute()]
public ref class InvalidBinIDException sealed : public PrintProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.PrintProSdk.PrintProException
Accusoft.PrintProSdk.InvalidBinIDException

See Also

Reference

InvalidBinIDException Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
InvalidBinIDException Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : InvalidBinIDException Class

Glossary Item Box

The following tables list the members exposed by InvalidBinIDException.

Public Constructors

 | Name | Description
Public Constructor | InvalidBinIDException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidBinIDException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
InvalidBinIDException Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : InvalidBinIDException Class

Glossary Item Box

For a list of all members of this type, see InvalidBinIDException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidBinIDException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
InvalidBinIDException Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : InvalidBinIDException Class

Glossary Item Box

For a list of all members of this type, see InvalidBinIDException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidBinIDException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidBinIDException Constructor
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidBinIDException Class : InvalidBinIDException Constructor

Glossary Item Box

Overload List

Overload | Description
InvalidBinIDException Constructor() | An exception generated for a invalid bin ID error.
InvalidBinIDException Constructor(Int32) | Generated exception for a invalid bin ID error with a given error number.
InvalidBinIDException Constructor(String) | Generated exception for a invalid bin ID error with a given string.
InvalidBinIDException Constructor(Int32,String) | Generated exception for a invalid bin ID error with a given error number and message.
InvalidBinIDException Constructor(String,Exception) | Generated exception for a invalid bin ID error with a given message and inner exception.

See Also

Reference

InvalidBinIDException Class
InvalidBinIDException Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidBinIDException Constructor()
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidBinIDException Class > InvalidBinIDException Constructor : InvalidBinIDException Constructor()

Glossary Item Box

An exception generated for a invalid bin ID error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New InvalidBinIDException()
public InvalidBinIDException()
public: InvalidBinIDException();
public:
InvalidBinIDException();

See Also

Reference

InvalidBinIDException Class
InvalidBinIDException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidBinIDException Constructor(Int32)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidBinIDException Class > InvalidBinIDException Constructor : InvalidBinIDException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a invalid bin ID error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New InvalidBinIDException(errorNumber)
public InvalidBinIDException(
   int errorNumber
)
public: InvalidBinIDException(
   int errorNumber
)
public:
InvalidBinIDException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

InvalidBinIDException Class
InvalidBinIDException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidBinIDException Constructor(String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidBinIDException Class > InvalidBinIDException Constructor : InvalidBinIDException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a invalid bin ID error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New InvalidBinIDException(message)
public InvalidBinIDException(
   string message
)
public: InvalidBinIDException(
   string* message
)
public:
InvalidBinIDException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

InvalidBinIDException Class
InvalidBinIDException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidBinIDException Constructor(Int32,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidBinIDException Class > InvalidBinIDException Constructor : InvalidBinIDException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a invalid bin ID error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New InvalidBinIDException(errorNumber, message)
public InvalidBinIDException(
   int errorNumber,
   string message
)
public: InvalidBinIDException(
   int errorNumber,
   string* message
)
public:
InvalidBinIDException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

InvalidBinIDException Class
InvalidBinIDException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidBinIDException Constructor(String,Exception)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidBinIDException Class > InvalidBinIDException Constructor : InvalidBinIDException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a invalid bin ID error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New InvalidBinIDException(message, innerException)
public InvalidBinIDException(
   string message,
   Exception innerException
)
public: InvalidBinIDException(
   string* message,
   Exception* innerException
)
public:
InvalidBinIDException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

InvalidBinIDException Class
InvalidBinIDException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidDib Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : InvalidDib Class

Glossary Item Box

This exception is thrown if the DIB is invalid.

Object Model

InvalidDib Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class InvalidDib
   Inherits PrintProException
'Usage

Dim instance As InvalidDib
[SerializableAttribute()]
public sealed class InvalidDib : PrintProException
[SerializableAttribute()]
public __gc __sealed class InvalidDib : public PrintProException
[SerializableAttribute()]
public ref class InvalidDib sealed : public PrintProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.PrintProSdk.PrintProException
Accusoft.PrintProSdk.InvalidDib

See Also

Reference

InvalidDib Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
InvalidDib Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : InvalidDib Class

Glossary Item Box

The following tables list the members exposed by InvalidDib.

Public Constructors

 | Name | Description
Public Constructor | InvalidDib Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidDib Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
InvalidDib Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : InvalidDib Class

Glossary Item Box

For a list of all members of this type, see InvalidDib members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidDib Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
InvalidDib Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : InvalidDib Class

Glossary Item Box

For a list of all members of this type, see InvalidDib members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidDib Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidDib Constructor
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidDib Class : InvalidDib Constructor

Glossary Item Box

Overload List

Overload | Description
InvalidDib Constructor() | An exception generated for a invalid DIB error.
InvalidDib Constructor(Int32) | Generated exception for a invalid DIB error with a given error number.
InvalidDib Constructor(String) | Generated exception for a invalid DIB error with a given string.
InvalidDib Constructor(Int32,String) | Generated exception for a invalid DIB error with a given error number and message.
InvalidDib Constructor(String,Exception) | Generated exception for a invalid DIB error with a given message and inner exception.

See Also

Reference

InvalidDib Class
InvalidDib Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidDib Constructor()
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidDib Class > InvalidDib Constructor : InvalidDib Constructor()

Glossary Item Box

An exception generated for a invalid DIB error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New InvalidDib()
public InvalidDib()
public: InvalidDib();
public:
InvalidDib();

See Also

Reference

InvalidDib Class
InvalidDib Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidDib Constructor(Int32)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidDib Class > InvalidDib Constructor : InvalidDib Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a invalid DIB error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New InvalidDib(errorNumber)
public InvalidDib(
   int errorNumber
)
public: InvalidDib(
   int errorNumber
)
public:
InvalidDib(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

InvalidDib Class
InvalidDib Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidDib Constructor(String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidDib Class > InvalidDib Constructor : InvalidDib Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a invalid DIB error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New InvalidDib(message)
public InvalidDib(
   string message
)
public: InvalidDib(
   string* message
)
public:
InvalidDib(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

InvalidDib Class
InvalidDib Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidDib Constructor(Int32,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidDib Class > InvalidDib Constructor : InvalidDib Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a invalid DIB error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New InvalidDib(errorNumber, message)
public InvalidDib(
   int errorNumber,
   string message
)
public: InvalidDib(
   int errorNumber,
   string* message
)
public:
InvalidDib(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

InvalidDib Class
InvalidDib Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidDib Constructor(String,Exception)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidDib Class > InvalidDib Constructor : InvalidDib Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a invalid DIB error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New InvalidDib(message, innerException)
public InvalidDib(
   string message,
   Exception innerException
)
public: InvalidDib(
   string* message,
   Exception* innerException
)
public:
InvalidDib(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

InvalidDib Class
InvalidDib Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidDibHandleException Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : InvalidDibHandleException Class

Glossary Item Box

This exception is thrown if the DIB handle is invalid.

Object Model

InvalidDibHandleException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class InvalidDibHandleException
   Inherits PrintProException
'Usage

Dim instance As InvalidDibHandleException
[SerializableAttribute()]
public sealed class InvalidDibHandleException : PrintProException
[SerializableAttribute()]
public __gc __sealed class InvalidDibHandleException : public PrintProException
[SerializableAttribute()]
public ref class InvalidDibHandleException sealed : public PrintProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.PrintProSdk.PrintProException
Accusoft.PrintProSdk.InvalidDibHandleException

See Also

Reference

InvalidDibHandleException Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
InvalidDibHandleException Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : InvalidDibHandleException Class

Glossary Item Box

The following tables list the members exposed by InvalidDibHandleException.

Public Constructors

 | Name | Description
Public Constructor | InvalidDibHandleException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidDibHandleException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
InvalidDibHandleException Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : InvalidDibHandleException Class

Glossary Item Box

For a list of all members of this type, see InvalidDibHandleException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidDibHandleException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
InvalidDibHandleException Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : InvalidDibHandleException Class

Glossary Item Box

For a list of all members of this type, see InvalidDibHandleException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidDibHandleException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidDibHandleException Constructor
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidDibHandleException Class : InvalidDibHandleException Constructor

Glossary Item Box

Overload List

Overload | Description
InvalidDibHandleException Constructor() | An exception generated for a invalid DIB handle error.
InvalidDibHandleException Constructor(Int32) | Generated exception for a invalid DIB handle error with a given error number.
InvalidDibHandleException Constructor(String) | Generated exception for a invalid DIB handle error with a given string.
InvalidDibHandleException Constructor(Int32,String) | Generated exception for a invalid DIB handle error with a given error number and message.
InvalidDibHandleException Constructor(String,Exception) | Generated exception for a invalid DIB handle error with a given message and inner exception.

See Also

Reference

InvalidDibHandleException Class
InvalidDibHandleException Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidDibHandleException Constructor()
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidDibHandleException Class > InvalidDibHandleException Constructor : InvalidDibHandleException Constructor()

Glossary Item Box

An exception generated for a invalid DIB handle error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New InvalidDibHandleException()
public InvalidDibHandleException()
public: InvalidDibHandleException();
public:
InvalidDibHandleException();

See Also

Reference

InvalidDibHandleException Class
InvalidDibHandleException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidDibHandleException Constructor(Int32)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidDibHandleException Class > InvalidDibHandleException Constructor : InvalidDibHandleException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a invalid DIB handle error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New InvalidDibHandleException(errorNumber)
public InvalidDibHandleException(
   int errorNumber
)
public: InvalidDibHandleException(
   int errorNumber
)
public:
InvalidDibHandleException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

InvalidDibHandleException Class
InvalidDibHandleException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidDibHandleException Constructor(String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidDibHandleException Class > InvalidDibHandleException Constructor : InvalidDibHandleException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a invalid DIB handle error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New InvalidDibHandleException(message)
public InvalidDibHandleException(
   string message
)
public: InvalidDibHandleException(
   string* message
)
public:
InvalidDibHandleException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

InvalidDibHandleException Class
InvalidDibHandleException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidDibHandleException Constructor(Int32,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidDibHandleException Class > InvalidDibHandleException Constructor : InvalidDibHandleException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a invalid DIB handle error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New InvalidDibHandleException(errorNumber, message)
public InvalidDibHandleException(
   int errorNumber,
   string message
)
public: InvalidDibHandleException(
   int errorNumber,
   string* message
)
public:
InvalidDibHandleException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

InvalidDibHandleException Class
InvalidDibHandleException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidDibHandleException Constructor(String,Exception)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidDibHandleException Class > InvalidDibHandleException Constructor : InvalidDibHandleException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a invalid DIB handle error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New InvalidDibHandleException(message, innerException)
public InvalidDibHandleException(
   string message,
   Exception innerException
)
public: InvalidDibHandleException(
   string* message,
   Exception* innerException
)
public:
InvalidDibHandleException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

InvalidDibHandleException Class
InvalidDibHandleException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidHandleException Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : InvalidHandleException Class

Glossary Item Box

This exception is thrown if the handle is invalid.

Object Model

InvalidHandleException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class InvalidHandleException
   Inherits PrintProException
'Usage

Dim instance As InvalidHandleException
[SerializableAttribute()]
public sealed class InvalidHandleException : PrintProException
[SerializableAttribute()]
public __gc __sealed class InvalidHandleException : public PrintProException
[SerializableAttribute()]
public ref class InvalidHandleException sealed : public PrintProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.PrintProSdk.PrintProException
Accusoft.PrintProSdk.InvalidHandleException

See Also

Reference

InvalidHandleException Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
InvalidHandleException Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : InvalidHandleException Class

Glossary Item Box

The following tables list the members exposed by InvalidHandleException.

Public Constructors

 | Name | Description
Public Constructor | InvalidHandleException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidHandleException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
InvalidHandleException Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : InvalidHandleException Class

Glossary Item Box

For a list of all members of this type, see InvalidHandleException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidHandleException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
InvalidHandleException Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : InvalidHandleException Class

Glossary Item Box

For a list of all members of this type, see InvalidHandleException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidHandleException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidHandleException Constructor
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidHandleException Class : InvalidHandleException Constructor

Glossary Item Box

Overload List

Overload | Description
InvalidHandleException Constructor() | An exception generated for a invalid handle error.
InvalidHandleException Constructor(Int32) | Generated exception for a invalid handle error with a given error number.
InvalidHandleException Constructor(String) | Generated exception for a invalid handle error with a given string.
InvalidHandleException Constructor(Int32,String) | Generated exception for a invalid handle error with a given error number and message.
InvalidHandleException Constructor(String,Exception) | Generated exception for a invalid handle error with a given message and inner exception.

See Also

Reference

InvalidHandleException Class
InvalidHandleException Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidHandleException Constructor()
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidHandleException Class > InvalidHandleException Constructor : InvalidHandleException Constructor()

Glossary Item Box

An exception generated for a invalid handle error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New InvalidHandleException()
public InvalidHandleException()
public: InvalidHandleException();
public:
InvalidHandleException();

See Also

Reference

InvalidHandleException Class
InvalidHandleException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidHandleException Constructor(Int32)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidHandleException Class > InvalidHandleException Constructor : InvalidHandleException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a invalid handle error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New InvalidHandleException(errorNumber)
public InvalidHandleException(
   int errorNumber
)
public: InvalidHandleException(
   int errorNumber
)
public:
InvalidHandleException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

InvalidHandleException Class
InvalidHandleException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidHandleException Constructor(String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidHandleException Class > InvalidHandleException Constructor : InvalidHandleException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a invalid handle error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New InvalidHandleException(message)
public InvalidHandleException(
   string message
)
public: InvalidHandleException(
   string* message
)
public:
InvalidHandleException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

InvalidHandleException Class
InvalidHandleException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidHandleException Constructor(Int32,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidHandleException Class > InvalidHandleException Constructor : InvalidHandleException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a invalid handle error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New InvalidHandleException(errorNumber, message)
public InvalidHandleException(
   int errorNumber,
   string message
)
public: InvalidHandleException(
   int errorNumber,
   string* message
)
public:
InvalidHandleException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

InvalidHandleException Class
InvalidHandleException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidHandleException Constructor(String,Exception)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidHandleException Class > InvalidHandleException Constructor : InvalidHandleException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a invalid handle error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New InvalidHandleException(message, innerException)
public InvalidHandleException(
   string message,
   Exception innerException
)
public: InvalidHandleException(
   string* message,
   Exception* innerException
)
public:
InvalidHandleException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

InvalidHandleException Class
InvalidHandleException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidLicenseEditionException Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : InvalidLicenseEditionException Class

Glossary Item Box

This exception is thrown if the license edition is invalid.

Object Model

InvalidLicenseEditionException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class InvalidLicenseEditionException
   Inherits PrintProException
'Usage

Dim instance As InvalidLicenseEditionException
[SerializableAttribute()]
public sealed class InvalidLicenseEditionException : PrintProException
[SerializableAttribute()]
public __gc __sealed class InvalidLicenseEditionException : public PrintProException
[SerializableAttribute()]
public ref class InvalidLicenseEditionException sealed : public PrintProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.PrintProSdk.PrintProException
Accusoft.PrintProSdk.InvalidLicenseEditionException

See Also

Reference

InvalidLicenseEditionException Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
InvalidLicenseEditionException Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : InvalidLicenseEditionException Class

Glossary Item Box

The following tables list the members exposed by InvalidLicenseEditionException.

Public Constructors

 | Name | Description
Public Constructor | InvalidLicenseEditionException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidLicenseEditionException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
InvalidLicenseEditionException Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : InvalidLicenseEditionException Class

Glossary Item Box

For a list of all members of this type, see InvalidLicenseEditionException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidLicenseEditionException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
InvalidLicenseEditionException Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : InvalidLicenseEditionException Class

Glossary Item Box

For a list of all members of this type, see InvalidLicenseEditionException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidLicenseEditionException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidLicenseEditionException Constructor
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidLicenseEditionException Class : InvalidLicenseEditionException Constructor

Glossary Item Box

Overload List

Overload | Description
InvalidLicenseEditionException Constructor() | An exception generated for a invalid license edition error.
InvalidLicenseEditionException Constructor(Int32) | Generated exception for a invalid license edition error with a given error number.
InvalidLicenseEditionException Constructor(String) | Generated exception for a invalid license edition error with a given string.
InvalidLicenseEditionException Constructor(Int32,String) | Generated exception for a invalid license edition error with a given error number and message.
InvalidLicenseEditionException Constructor(String,Exception) | Generated exception for a invalid license edition error with a given message and inner exception.

See Also

Reference

InvalidLicenseEditionException Class
InvalidLicenseEditionException Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidLicenseEditionException Constructor()
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidLicenseEditionException Class > InvalidLicenseEditionException Constructor : InvalidLicenseEditionException Constructor()

Glossary Item Box

An exception generated for a invalid license edition error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New InvalidLicenseEditionException()
public InvalidLicenseEditionException()
public: InvalidLicenseEditionException();
public:
InvalidLicenseEditionException();

See Also

Reference

InvalidLicenseEditionException Class
InvalidLicenseEditionException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidLicenseEditionException Constructor(Int32)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidLicenseEditionException Class > InvalidLicenseEditionException Constructor : InvalidLicenseEditionException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a invalid license edition error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New InvalidLicenseEditionException(errorNumber)
public InvalidLicenseEditionException(
   int errorNumber
)
public: InvalidLicenseEditionException(
   int errorNumber
)
public:
InvalidLicenseEditionException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

InvalidLicenseEditionException Class
InvalidLicenseEditionException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidLicenseEditionException Constructor(String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidLicenseEditionException Class > InvalidLicenseEditionException Constructor : InvalidLicenseEditionException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a invalid license edition error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New InvalidLicenseEditionException(message)
public InvalidLicenseEditionException(
   string message
)
public: InvalidLicenseEditionException(
   string* message
)
public:
InvalidLicenseEditionException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

InvalidLicenseEditionException Class
InvalidLicenseEditionException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidLicenseEditionException Constructor(Int32,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidLicenseEditionException Class > InvalidLicenseEditionException Constructor : InvalidLicenseEditionException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a invalid license edition error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New InvalidLicenseEditionException(errorNumber, message)
public InvalidLicenseEditionException(
   int errorNumber,
   string message
)
public: InvalidLicenseEditionException(
   int errorNumber,
   string* message
)
public:
InvalidLicenseEditionException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

InvalidLicenseEditionException Class
InvalidLicenseEditionException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidLicenseEditionException Constructor(String,Exception)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidLicenseEditionException Class > InvalidLicenseEditionException Constructor : InvalidLicenseEditionException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a invalid license edition error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New InvalidLicenseEditionException(message, innerException)
public InvalidLicenseEditionException(
   string message,
   Exception innerException
)
public: InvalidLicenseEditionException(
   string* message,
   Exception* innerException
)
public:
InvalidLicenseEditionException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

InvalidLicenseEditionException Class
InvalidLicenseEditionException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidLicenseException Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : InvalidLicenseException Class

Glossary Item Box

This exception is thrown if a user attempts to access functionality that is not covered under the license in effect.

Object Model

InvalidLicenseException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class InvalidLicenseException
   Inherits PrintProException
'Usage

Dim instance As InvalidLicenseException
[SerializableAttribute()]
public sealed class InvalidLicenseException : PrintProException
[SerializableAttribute()]
public __gc __sealed class InvalidLicenseException : public PrintProException
[SerializableAttribute()]
public ref class InvalidLicenseException sealed : public PrintProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.PrintProSdk.PrintProException
Accusoft.PrintProSdk.InvalidLicenseException

See Also

Reference

InvalidLicenseException Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
InvalidLicenseException Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : InvalidLicenseException Class

Glossary Item Box

The following tables list the members exposed by InvalidLicenseException.

Public Constructors

 | Name | Description
Public Constructor | InvalidLicenseException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidLicenseException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
InvalidLicenseException Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : InvalidLicenseException Class

Glossary Item Box

For a list of all members of this type, see InvalidLicenseException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidLicenseException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
InvalidLicenseException Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : InvalidLicenseException Class

Glossary Item Box

For a list of all members of this type, see InvalidLicenseException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidLicenseException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidLicenseException Constructor
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidLicenseException Class : InvalidLicenseException Constructor

Glossary Item Box

Overload List

Overload | Description
InvalidLicenseException Constructor() | An exception generated for an invalid license error.
InvalidLicenseException Constructor(Int32) | Generated exception for an invalid license error with a given error number.
InvalidLicenseException Constructor(String) | Generated exception for an invalid license error with a given string.
InvalidLicenseException Constructor(Int32,String) | Generated exception for an invalid license error with a given error number and message.
InvalidLicenseException Constructor(String,Exception) | Generated exception for an invalid license error with a given message and inner exception.

See Also

Reference

InvalidLicenseException Class
InvalidLicenseException Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidLicenseException Constructor()
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidLicenseException Class > InvalidLicenseException Constructor : InvalidLicenseException Constructor()

Glossary Item Box

An exception generated for an invalid license error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New InvalidLicenseException()
public InvalidLicenseException()
public: InvalidLicenseException();
public:
InvalidLicenseException();

See Also

Reference

InvalidLicenseException Class
InvalidLicenseException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidLicenseException Constructor(Int32)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidLicenseException Class > InvalidLicenseException Constructor : InvalidLicenseException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for an invalid license error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New InvalidLicenseException(errorNumber)
public InvalidLicenseException(
   int errorNumber
)
public: InvalidLicenseException(
   int errorNumber
)
public:
InvalidLicenseException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

InvalidLicenseException Class
InvalidLicenseException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidLicenseException Constructor(String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidLicenseException Class > InvalidLicenseException Constructor : InvalidLicenseException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for an invalid license error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New InvalidLicenseException(message)
public InvalidLicenseException(
   string message
)
public: InvalidLicenseException(
   string* message
)
public:
InvalidLicenseException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

InvalidLicenseException Class
InvalidLicenseException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidLicenseException Constructor(Int32,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidLicenseException Class > InvalidLicenseException Constructor : InvalidLicenseException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for an invalid license error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New InvalidLicenseException(errorNumber, message)
public InvalidLicenseException(
   int errorNumber,
   string message
)
public: InvalidLicenseException(
   int errorNumber,
   string* message
)
public:
InvalidLicenseException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

InvalidLicenseException Class
InvalidLicenseException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidLicenseException Constructor(String,Exception)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidLicenseException Class > InvalidLicenseException Constructor : InvalidLicenseException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for an invalid license error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New InvalidLicenseException(message, innerException)
public InvalidLicenseException(
   string message,
   Exception innerException
)
public: InvalidLicenseException(
   string* message,
   Exception* innerException
)
public:
InvalidLicenseException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

InvalidLicenseException Class
InvalidLicenseException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidPageNumberException Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : InvalidPageNumberException Class

Glossary Item Box

This exception is thrown if an invalid page number was specified.

Object Model

InvalidPageNumberException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class InvalidPageNumberException
   Inherits PrintProException
'Usage

Dim instance As InvalidPageNumberException
[SerializableAttribute()]
public sealed class InvalidPageNumberException : PrintProException
[SerializableAttribute()]
public __gc __sealed class InvalidPageNumberException : public PrintProException
[SerializableAttribute()]
public ref class InvalidPageNumberException sealed : public PrintProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.PrintProSdk.PrintProException
Accusoft.PrintProSdk.InvalidPageNumberException

See Also

Reference

InvalidPageNumberException Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
InvalidPageNumberException Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : InvalidPageNumberException Class

Glossary Item Box

The following tables list the members exposed by InvalidPageNumberException.

Public Constructors

 | Name | Description
Public Constructor | InvalidPageNumberException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidPageNumberException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
InvalidPageNumberException Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : InvalidPageNumberException Class

Glossary Item Box

For a list of all members of this type, see InvalidPageNumberException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidPageNumberException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
InvalidPageNumberException Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : InvalidPageNumberException Class

Glossary Item Box

For a list of all members of this type, see InvalidPageNumberException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidPageNumberException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidPageNumberException Constructor
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidPageNumberException Class : InvalidPageNumberException Constructor

Glossary Item Box

Overload List

Overload | Description
InvalidPageNumberException Constructor() | An exception generated for a invalid page number error.
InvalidPageNumberException Constructor(Int32) | Generated exception for a invalid page number error with a given error number.
InvalidPageNumberException Constructor(String) | Generated exception for a invalid page number error with a given string.
InvalidPageNumberException Constructor(Int32,String) | Generated exception for a invalid page number error with a given error number and message.
InvalidPageNumberException Constructor(String,Exception) | Generated exception for a invalid page number error with a given message and inner exception.

See Also

Reference

InvalidPageNumberException Class
InvalidPageNumberException Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidPageNumberException Constructor()
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidPageNumberException Class > InvalidPageNumberException Constructor : InvalidPageNumberException Constructor()

Glossary Item Box

An exception generated for a invalid page number error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New InvalidPageNumberException()
public InvalidPageNumberException()
public: InvalidPageNumberException();
public:
InvalidPageNumberException();

See Also

Reference

InvalidPageNumberException Class
InvalidPageNumberException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidPageNumberException Constructor(Int32)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidPageNumberException Class > InvalidPageNumberException Constructor : InvalidPageNumberException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a invalid page number error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New InvalidPageNumberException(errorNumber)
public InvalidPageNumberException(
   int errorNumber
)
public: InvalidPageNumberException(
   int errorNumber
)
public:
InvalidPageNumberException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

InvalidPageNumberException Class
InvalidPageNumberException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidPageNumberException Constructor(String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidPageNumberException Class > InvalidPageNumberException Constructor : InvalidPageNumberException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a invalid page number error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New InvalidPageNumberException(message)
public InvalidPageNumberException(
   string message
)
public: InvalidPageNumberException(
   string* message
)
public:
InvalidPageNumberException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

InvalidPageNumberException Class
InvalidPageNumberException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidPageNumberException Constructor(Int32,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidPageNumberException Class > InvalidPageNumberException Constructor : InvalidPageNumberException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a invalid page number error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New InvalidPageNumberException(errorNumber, message)
public InvalidPageNumberException(
   int errorNumber,
   string message
)
public: InvalidPageNumberException(
   int errorNumber,
   string* message
)
public:
InvalidPageNumberException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

InvalidPageNumberException Class
InvalidPageNumberException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidPageNumberException Constructor(String,Exception)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidPageNumberException Class > InvalidPageNumberException Constructor : InvalidPageNumberException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a invalid page number error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New InvalidPageNumberException(message, innerException)
public InvalidPageNumberException(
   string message,
   Exception innerException
)
public: InvalidPageNumberException(
   string* message,
   Exception* innerException
)
public:
InvalidPageNumberException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

InvalidPageNumberException Class
InvalidPageNumberException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidPaperIDException Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : InvalidPaperIDException Class

Glossary Item Box

This exception is thrown if the specified paper ID is invalid.

Object Model

InvalidPaperIDException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class InvalidPaperIDException
   Inherits PrintProException
'Usage

Dim instance As InvalidPaperIDException
[SerializableAttribute()]
public sealed class InvalidPaperIDException : PrintProException
[SerializableAttribute()]
public __gc __sealed class InvalidPaperIDException : public PrintProException
[SerializableAttribute()]
public ref class InvalidPaperIDException sealed : public PrintProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.PrintProSdk.PrintProException
Accusoft.PrintProSdk.InvalidPaperIDException

See Also

Reference

InvalidPaperIDException Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
InvalidPaperIDException Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : InvalidPaperIDException Class

Glossary Item Box

The following tables list the members exposed by InvalidPaperIDException.

Public Constructors

 | Name | Description
Public Constructor | InvalidPaperIDException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidPaperIDException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
InvalidPaperIDException Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : InvalidPaperIDException Class

Glossary Item Box

For a list of all members of this type, see InvalidPaperIDException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidPaperIDException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
InvalidPaperIDException Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : InvalidPaperIDException Class

Glossary Item Box

For a list of all members of this type, see InvalidPaperIDException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidPaperIDException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidPaperIDException Constructor
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidPaperIDException Class : InvalidPaperIDException Constructor

Glossary Item Box

Overload List

Overload | Description
InvalidPaperIDException Constructor() | An exception generated for a invalid paper ID error.
InvalidPaperIDException Constructor(Int32) | Generated exception for a invalid paper ID error with a given error number.
InvalidPaperIDException Constructor(String) | Generated exception for a invalid paper ID error with a given string.
InvalidPaperIDException Constructor(Int32,String) | Generated exception for a invalid paper ID error with a given error number and message.
InvalidPaperIDException Constructor(String,Exception) | Generated exception for a invalid paper ID error with a given message and inner exception.

See Also

Reference

InvalidPaperIDException Class
InvalidPaperIDException Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidPaperIDException Constructor()
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidPaperIDException Class > InvalidPaperIDException Constructor : InvalidPaperIDException Constructor()

Glossary Item Box

An exception generated for a invalid paper ID error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New InvalidPaperIDException()
public InvalidPaperIDException()
public: InvalidPaperIDException();
public:
InvalidPaperIDException();

See Also

Reference

InvalidPaperIDException Class
InvalidPaperIDException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidPaperIDException Constructor(Int32)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidPaperIDException Class > InvalidPaperIDException Constructor : InvalidPaperIDException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a invalid paper ID error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New InvalidPaperIDException(errorNumber)
public InvalidPaperIDException(
   int errorNumber
)
public: InvalidPaperIDException(
   int errorNumber
)
public:
InvalidPaperIDException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

InvalidPaperIDException Class
InvalidPaperIDException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidPaperIDException Constructor(String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidPaperIDException Class > InvalidPaperIDException Constructor : InvalidPaperIDException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a invalid paper ID error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New InvalidPaperIDException(message)
public InvalidPaperIDException(
   string message
)
public: InvalidPaperIDException(
   string* message
)
public:
InvalidPaperIDException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

InvalidPaperIDException Class
InvalidPaperIDException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidPaperIDException Constructor(Int32,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidPaperIDException Class > InvalidPaperIDException Constructor : InvalidPaperIDException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a invalid paper ID error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New InvalidPaperIDException(errorNumber, message)
public InvalidPaperIDException(
   int errorNumber,
   string message
)
public: InvalidPaperIDException(
   int errorNumber,
   string* message
)
public:
InvalidPaperIDException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

InvalidPaperIDException Class
InvalidPaperIDException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidPaperIDException Constructor(String,Exception)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidPaperIDException Class > InvalidPaperIDException Constructor : InvalidPaperIDException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a invalid paper ID error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New InvalidPaperIDException(message, innerException)
public InvalidPaperIDException(
   string message,
   Exception innerException
)
public: InvalidPaperIDException(
   string* message,
   Exception* innerException
)
public:
InvalidPaperIDException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

InvalidPaperIDException Class
InvalidPaperIDException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidParameterException Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : InvalidParameterException Class

Glossary Item Box

This exception is thrown if an invalid parameter is specified.

Object Model

InvalidParameterException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class InvalidParameterException
   Inherits PrintProException
'Usage

Dim instance As InvalidParameterException
[SerializableAttribute()]
public sealed class InvalidParameterException : PrintProException
[SerializableAttribute()]
public __gc __sealed class InvalidParameterException : public PrintProException
[SerializableAttribute()]
public ref class InvalidParameterException sealed : public PrintProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.PrintProSdk.PrintProException
Accusoft.PrintProSdk.InvalidParameterException

See Also

Reference

InvalidParameterException Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
InvalidParameterException Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : InvalidParameterException Class

Glossary Item Box

The following tables list the members exposed by InvalidParameterException.

Public Constructors

 | Name | Description
Public Constructor | InvalidParameterException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidParameterException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
InvalidParameterException Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : InvalidParameterException Class

Glossary Item Box

For a list of all members of this type, see InvalidParameterException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidParameterException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
InvalidParameterException Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : InvalidParameterException Class

Glossary Item Box

For a list of all members of this type, see InvalidParameterException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidParameterException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidParameterException Constructor
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidParameterException Class : InvalidParameterException Constructor

Glossary Item Box

Overload List

Overload | Description
InvalidParameterException Constructor() | An exception generated for a invalid parameter error.
InvalidParameterException Constructor(Int32) | Generated exception for a invalid parameter error with a given error number.
InvalidParameterException Constructor(String) | Generated exception for a invalid parameter error with a given string.
InvalidParameterException Constructor(Int32,String) | Generated exception for a invalid parameter error with a given error number and message.
InvalidParameterException Constructor(String,Exception) | Generated exception for a invalid parameter error with a given message and inner exception.

See Also

Reference

InvalidParameterException Class
InvalidParameterException Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidParameterException Constructor()
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidParameterException Class > InvalidParameterException Constructor : InvalidParameterException Constructor()

Glossary Item Box

An exception generated for a invalid parameter error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New InvalidParameterException()
public InvalidParameterException()
public: InvalidParameterException();
public:
InvalidParameterException();

See Also

Reference

InvalidParameterException Class
InvalidParameterException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidParameterException Constructor(Int32)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidParameterException Class > InvalidParameterException Constructor : InvalidParameterException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a invalid parameter error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New InvalidParameterException(errorNumber)
public InvalidParameterException(
   int errorNumber
)
public: InvalidParameterException(
   int errorNumber
)
public:
InvalidParameterException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

InvalidParameterException Class
InvalidParameterException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidParameterException Constructor(String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidParameterException Class > InvalidParameterException Constructor : InvalidParameterException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a invalid parameter error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New InvalidParameterException(message)
public InvalidParameterException(
   string message
)
public: InvalidParameterException(
   string* message
)
public:
InvalidParameterException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

InvalidParameterException Class
InvalidParameterException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidParameterException Constructor(Int32,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidParameterException Class > InvalidParameterException Constructor : InvalidParameterException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a invalid parameter error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New InvalidParameterException(errorNumber, message)
public InvalidParameterException(
   int errorNumber,
   string message
)
public: InvalidParameterException(
   int errorNumber,
   string* message
)
public:
InvalidParameterException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

InvalidParameterException Class
InvalidParameterException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidParameterException Constructor(String,Exception)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidParameterException Class > InvalidParameterException Constructor : InvalidParameterException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a invalid parameter error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New InvalidParameterException(message, innerException)
public InvalidParameterException(
   string message,
   Exception innerException
)
public: InvalidParameterException(
   string* message,
   Exception* innerException
)
public:
InvalidParameterException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

InvalidParameterException Class
InvalidParameterException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidPointerException Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : InvalidPointerException Class

Glossary Item Box

This exception is thrown if a pointer is invalid.

Object Model

InvalidPointerException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class InvalidPointerException
   Inherits PrintProException
'Usage

Dim instance As InvalidPointerException
[SerializableAttribute()]
public sealed class InvalidPointerException : PrintProException
[SerializableAttribute()]
public __gc __sealed class InvalidPointerException : public PrintProException
[SerializableAttribute()]
public ref class InvalidPointerException sealed : public PrintProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.PrintProSdk.PrintProException
Accusoft.PrintProSdk.InvalidPointerException

See Also

Reference

InvalidPointerException Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
InvalidPointerException Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : InvalidPointerException Class

Glossary Item Box

The following tables list the members exposed by InvalidPointerException.

Public Constructors

 | Name | Description
Public Constructor | InvalidPointerException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidPointerException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
InvalidPointerException Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : InvalidPointerException Class

Glossary Item Box

For a list of all members of this type, see InvalidPointerException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidPointerException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
InvalidPointerException Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : InvalidPointerException Class

Glossary Item Box

For a list of all members of this type, see InvalidPointerException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidPointerException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidPointerException Constructor
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidPointerException Class : InvalidPointerException Constructor

Glossary Item Box

Overload List

Overload | Description
InvalidPointerException Constructor() | An exception generated for a invalid pointer error.
InvalidPointerException Constructor(Int32) | Generated exception for a invalid pointer error with a given error number.
InvalidPointerException Constructor(String) | Generated exception for a invalid pointer error with a given string.
InvalidPointerException Constructor(Int32,String) | Generated exception for a invalid pointer error with a given error number and message.
InvalidPointerException Constructor(String,Exception) | Generated exception for a invalid pointer error with a given message and inner exception.

See Also

Reference

InvalidPointerException Class
InvalidPointerException Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidPointerException Constructor()
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidPointerException Class > InvalidPointerException Constructor : InvalidPointerException Constructor()

Glossary Item Box

An exception generated for a invalid pointer error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New InvalidPointerException()
public InvalidPointerException()
public: InvalidPointerException();
public:
InvalidPointerException();

See Also

Reference

InvalidPointerException Class
InvalidPointerException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidPointerException Constructor(Int32)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidPointerException Class > InvalidPointerException Constructor : InvalidPointerException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a invalid pointer error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New InvalidPointerException(errorNumber)
public InvalidPointerException(
   int errorNumber
)
public: InvalidPointerException(
   int errorNumber
)
public:
InvalidPointerException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

InvalidPointerException Class
InvalidPointerException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidPointerException Constructor(String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidPointerException Class > InvalidPointerException Constructor : InvalidPointerException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a invalid pointer error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New InvalidPointerException(message)
public InvalidPointerException(
   string message
)
public: InvalidPointerException(
   string* message
)
public:
InvalidPointerException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

InvalidPointerException Class
InvalidPointerException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidPointerException Constructor(Int32,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidPointerException Class > InvalidPointerException Constructor : InvalidPointerException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a invalid pointer error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New InvalidPointerException(errorNumber, message)
public InvalidPointerException(
   int errorNumber,
   string message
)
public: InvalidPointerException(
   int errorNumber,
   string* message
)
public:
InvalidPointerException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

InvalidPointerException Class
InvalidPointerException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidPointerException Constructor(String,Exception)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidPointerException Class > InvalidPointerException Constructor : InvalidPointerException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a invalid pointer error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New InvalidPointerException(message, innerException)
public InvalidPointerException(
   string message,
   Exception innerException
)
public: InvalidPointerException(
   string* message,
   Exception* innerException
)
public:
InvalidPointerException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

InvalidPointerException Class
InvalidPointerException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidPrinterNumberException Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : InvalidPrinterNumberException Class

Glossary Item Box

This exception is thrown if an invalid printer number is specified.

Object Model

InvalidPrinterNumberException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class InvalidPrinterNumberException
   Inherits PrintProException
'Usage

Dim instance As InvalidPrinterNumberException
[SerializableAttribute()]
public sealed class InvalidPrinterNumberException : PrintProException
[SerializableAttribute()]
public __gc __sealed class InvalidPrinterNumberException : public PrintProException
[SerializableAttribute()]
public ref class InvalidPrinterNumberException sealed : public PrintProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.PrintProSdk.PrintProException
Accusoft.PrintProSdk.InvalidPrinterNumberException

See Also

Reference

InvalidPrinterNumberException Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
InvalidPrinterNumberException Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : InvalidPrinterNumberException Class

Glossary Item Box

The following tables list the members exposed by InvalidPrinterNumberException.

Public Constructors

 | Name | Description
Public Constructor | InvalidPrinterNumberException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidPrinterNumberException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
InvalidPrinterNumberException Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : InvalidPrinterNumberException Class

Glossary Item Box

For a list of all members of this type, see InvalidPrinterNumberException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidPrinterNumberException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
InvalidPrinterNumberException Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : InvalidPrinterNumberException Class

Glossary Item Box

For a list of all members of this type, see InvalidPrinterNumberException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidPrinterNumberException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidPrinterNumberException Constructor
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidPrinterNumberException Class : InvalidPrinterNumberException Constructor

Glossary Item Box

Overload List

Overload | Description
InvalidPrinterNumberException Constructor() | An exception generated for a invalid printer number error.
InvalidPrinterNumberException Constructor(Int32) | Generated exception for a invalid printer number error with a given error number.
InvalidPrinterNumberException Constructor(String) | Generated exception for a invalid printer number error with a given string.
InvalidPrinterNumberException Constructor(Int32,String) | Generated exception for a invalid printer number error with a given error number and message.
InvalidPrinterNumberException Constructor(String,Exception) | Generated exception for a invalid printer number error with a given message and inner exception.

See Also

Reference

InvalidPrinterNumberException Class
InvalidPrinterNumberException Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidPrinterNumberException Constructor()
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidPrinterNumberException Class > InvalidPrinterNumberException Constructor : InvalidPrinterNumberException Constructor()

Glossary Item Box

An exception generated for a invalid printer number error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New InvalidPrinterNumberException()
public InvalidPrinterNumberException()
public: InvalidPrinterNumberException();
public:
InvalidPrinterNumberException();

See Also

Reference

InvalidPrinterNumberException Class
InvalidPrinterNumberException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidPrinterNumberException Constructor(Int32)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidPrinterNumberException Class > InvalidPrinterNumberException Constructor : InvalidPrinterNumberException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a invalid printer number error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New InvalidPrinterNumberException(errorNumber)
public InvalidPrinterNumberException(
   int errorNumber
)
public: InvalidPrinterNumberException(
   int errorNumber
)
public:
InvalidPrinterNumberException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

InvalidPrinterNumberException Class
InvalidPrinterNumberException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidPrinterNumberException Constructor(String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidPrinterNumberException Class > InvalidPrinterNumberException Constructor : InvalidPrinterNumberException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a invalid printer number error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New InvalidPrinterNumberException(message)
public InvalidPrinterNumberException(
   string message
)
public: InvalidPrinterNumberException(
   string* message
)
public:
InvalidPrinterNumberException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

InvalidPrinterNumberException Class
InvalidPrinterNumberException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidPrinterNumberException Constructor(Int32,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidPrinterNumberException Class > InvalidPrinterNumberException Constructor : InvalidPrinterNumberException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a invalid printer number error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New InvalidPrinterNumberException(errorNumber, message)
public InvalidPrinterNumberException(
   int errorNumber,
   string message
)
public: InvalidPrinterNumberException(
   int errorNumber,
   string* message
)
public:
InvalidPrinterNumberException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

InvalidPrinterNumberException Class
InvalidPrinterNumberException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidPrinterNumberException Constructor(String,Exception)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidPrinterNumberException Class > InvalidPrinterNumberException Constructor : InvalidPrinterNumberException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a invalid printer number error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New InvalidPrinterNumberException(message, innerException)
public InvalidPrinterNumberException(
   string message,
   Exception innerException
)
public: InvalidPrinterNumberException(
   string* message,
   Exception* innerException
)
public:
InvalidPrinterNumberException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

InvalidPrinterNumberException Class
InvalidPrinterNumberException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidPrintPreviewException Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : InvalidPrintPreviewException Class

Glossary Item Box

This exception is thrown if the print preview is invalid.

Object Model

InvalidPrintPreviewException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class InvalidPrintPreviewException
   Inherits PrintProException
'Usage

Dim instance As InvalidPrintPreviewException
[SerializableAttribute()]
public sealed class InvalidPrintPreviewException : PrintProException
[SerializableAttribute()]
public __gc __sealed class InvalidPrintPreviewException : public PrintProException
[SerializableAttribute()]
public ref class InvalidPrintPreviewException sealed : public PrintProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.PrintProSdk.PrintProException
Accusoft.PrintProSdk.InvalidPrintPreviewException

See Also

Reference

InvalidPrintPreviewException Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
InvalidPrintPreviewException Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : InvalidPrintPreviewException Class

Glossary Item Box

The following tables list the members exposed by InvalidPrintPreviewException.

Public Constructors

 | Name | Description
Public Constructor | InvalidPrintPreviewException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidPrintPreviewException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
InvalidPrintPreviewException Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : InvalidPrintPreviewException Class

Glossary Item Box

For a list of all members of this type, see InvalidPrintPreviewException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidPrintPreviewException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
InvalidPrintPreviewException Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : InvalidPrintPreviewException Class

Glossary Item Box

For a list of all members of this type, see InvalidPrintPreviewException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidPrintPreviewException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidPrintPreviewException Constructor
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidPrintPreviewException Class : InvalidPrintPreviewException Constructor

Glossary Item Box

Overload List

Overload | Description
InvalidPrintPreviewException Constructor() | An exception generated for a invalid print preview error.
InvalidPrintPreviewException Constructor(Int32) | Generated exception for a invalid print preview error with a given error number.
InvalidPrintPreviewException Constructor(String) | Generated exception for a invalid print preview error with a given string.
InvalidPrintPreviewException Constructor(Int32,String) | Generated exception for a invalid print preview error with a given error number and message.
InvalidPrintPreviewException Constructor(String,Exception) | Generated exception for a invalid print preview error with a given message and inner exception.

See Also

Reference

InvalidPrintPreviewException Class
InvalidPrintPreviewException Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidPrintPreviewException Constructor()
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidPrintPreviewException Class > InvalidPrintPreviewException Constructor : InvalidPrintPreviewException Constructor()

Glossary Item Box

An exception generated for a invalid print preview error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New InvalidPrintPreviewException()
public InvalidPrintPreviewException()
public: InvalidPrintPreviewException();
public:
InvalidPrintPreviewException();

See Also

Reference

InvalidPrintPreviewException Class
InvalidPrintPreviewException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidPrintPreviewException Constructor(Int32)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidPrintPreviewException Class > InvalidPrintPreviewException Constructor : InvalidPrintPreviewException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a invalid print preview error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New InvalidPrintPreviewException(errorNumber)
public InvalidPrintPreviewException(
   int errorNumber
)
public: InvalidPrintPreviewException(
   int errorNumber
)
public:
InvalidPrintPreviewException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

InvalidPrintPreviewException Class
InvalidPrintPreviewException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidPrintPreviewException Constructor(String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidPrintPreviewException Class > InvalidPrintPreviewException Constructor : InvalidPrintPreviewException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a invalid print preview error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New InvalidPrintPreviewException(message)
public InvalidPrintPreviewException(
   string message
)
public: InvalidPrintPreviewException(
   string* message
)
public:
InvalidPrintPreviewException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

InvalidPrintPreviewException Class
InvalidPrintPreviewException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidPrintPreviewException Constructor(Int32,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidPrintPreviewException Class > InvalidPrintPreviewException Constructor : InvalidPrintPreviewException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a invalid print preview error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New InvalidPrintPreviewException(errorNumber, message)
public InvalidPrintPreviewException(
   int errorNumber,
   string message
)
public: InvalidPrintPreviewException(
   int errorNumber,
   string* message
)
public:
InvalidPrintPreviewException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

InvalidPrintPreviewException Class
InvalidPrintPreviewException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidPrintPreviewException Constructor(String,Exception)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidPrintPreviewException Class > InvalidPrintPreviewException Constructor : InvalidPrintPreviewException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a invalid print preview error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New InvalidPrintPreviewException(message, innerException)
public InvalidPrintPreviewException(
   string message,
   Exception innerException
)
public: InvalidPrintPreviewException(
   string* message,
   Exception* innerException
)
public:
InvalidPrintPreviewException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

InvalidPrintPreviewException Class
InvalidPrintPreviewException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidProfileException Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : InvalidProfileException Class

Glossary Item Box

This exception is thrown if a color profile associated with the ICM object is invalid.

Object Model

InvalidProfileException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class InvalidProfileException
   Inherits PrintProException
'Usage

Dim instance As InvalidProfileException
[SerializableAttribute()]
public sealed class InvalidProfileException : PrintProException
[SerializableAttribute()]
public __gc __sealed class InvalidProfileException : public PrintProException
[SerializableAttribute()]
public ref class InvalidProfileException sealed : public PrintProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.PrintProSdk.PrintProException
Accusoft.PrintProSdk.InvalidProfileException

See Also

Reference

InvalidProfileException Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
InvalidProfileException Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : InvalidProfileException Class

Glossary Item Box

The following tables list the members exposed by InvalidProfileException.

Public Constructors

 | Name | Description
Public Constructor | InvalidProfileException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidProfileException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
InvalidProfileException Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : InvalidProfileException Class

Glossary Item Box

For a list of all members of this type, see InvalidProfileException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidProfileException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
InvalidProfileException Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : InvalidProfileException Class

Glossary Item Box

For a list of all members of this type, see InvalidProfileException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidProfileException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidProfileException Constructor
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidProfileException Class : InvalidProfileException Constructor

Glossary Item Box

Overload List

Overload | Description
InvalidProfileException Constructor() | An exception generated for a invalid profile error.
InvalidProfileException Constructor(Int32) | Generated exception for a invalid profile error with a given error number.
InvalidProfileException Constructor(String) | Generated exception for a invalid profile error with a given string.
InvalidProfileException Constructor(Int32,String) | Generated exception for a invalid profile error with a given error number and message.
InvalidProfileException Constructor(String,Exception) | Generated exception for a invalid profile error with a given message and inner exception.

See Also

Reference

InvalidProfileException Class
InvalidProfileException Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidProfileException Constructor()
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidProfileException Class > InvalidProfileException Constructor : InvalidProfileException Constructor()

Glossary Item Box

An exception generated for a invalid profile error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New InvalidProfileException()
public InvalidProfileException()
public: InvalidProfileException();
public:
InvalidProfileException();

See Also

Reference

InvalidProfileException Class
InvalidProfileException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidProfileException Constructor(Int32)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidProfileException Class > InvalidProfileException Constructor : InvalidProfileException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a invalid profile error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New InvalidProfileException(errorNumber)
public InvalidProfileException(
   int errorNumber
)
public: InvalidProfileException(
   int errorNumber
)
public:
InvalidProfileException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

InvalidProfileException Class
InvalidProfileException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidProfileException Constructor(String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidProfileException Class > InvalidProfileException Constructor : InvalidProfileException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a invalid profile error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New InvalidProfileException(message)
public InvalidProfileException(
   string message
)
public: InvalidProfileException(
   string* message
)
public:
InvalidProfileException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

InvalidProfileException Class
InvalidProfileException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidProfileException Constructor(Int32,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidProfileException Class > InvalidProfileException Constructor : InvalidProfileException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a invalid profile error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New InvalidProfileException(errorNumber, message)
public InvalidProfileException(
   int errorNumber,
   string message
)
public: InvalidProfileException(
   int errorNumber,
   string* message
)
public:
InvalidProfileException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

InvalidProfileException Class
InvalidProfileException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidProfileException Constructor(String,Exception)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidProfileException Class > InvalidProfileException Constructor : InvalidProfileException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a invalid profile error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New InvalidProfileException(message, innerException)
public InvalidProfileException(
   string message,
   Exception innerException
)
public: InvalidProfileException(
   string* message,
   Exception* innerException
)
public:
InvalidProfileException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

InvalidProfileException Class
InvalidProfileException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidRadiusException Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : InvalidRadiusException Class

Glossary Item Box

This exception is thrown if the specified radius is invalid.

Object Model

InvalidRadiusException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class InvalidRadiusException
   Inherits PrintProException
'Usage

Dim instance As InvalidRadiusException
[SerializableAttribute()]
public sealed class InvalidRadiusException : PrintProException
[SerializableAttribute()]
public __gc __sealed class InvalidRadiusException : public PrintProException
[SerializableAttribute()]
public ref class InvalidRadiusException sealed : public PrintProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.PrintProSdk.PrintProException
Accusoft.PrintProSdk.InvalidRadiusException

See Also

Reference

InvalidRadiusException Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
InvalidRadiusException Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : InvalidRadiusException Class

Glossary Item Box

The following tables list the members exposed by InvalidRadiusException.

Public Constructors

 | Name | Description
Public Constructor | InvalidRadiusException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidRadiusException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
InvalidRadiusException Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : InvalidRadiusException Class

Glossary Item Box

For a list of all members of this type, see InvalidRadiusException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidRadiusException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
InvalidRadiusException Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : InvalidRadiusException Class

Glossary Item Box

For a list of all members of this type, see InvalidRadiusException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidRadiusException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidRadiusException Constructor
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidRadiusException Class : InvalidRadiusException Constructor

Glossary Item Box

Overload List

Overload | Description
InvalidRadiusException Constructor() | An exception generated for a invalid radius error.
InvalidRadiusException Constructor(Int32) | Generated exception for a invalid radius error with a given error number.
InvalidRadiusException Constructor(String) | Generated exception for a invalid radius error with a given string.
InvalidRadiusException Constructor(Int32,String) | Generated exception for a invalid radius error with a given error number and message.
InvalidRadiusException Constructor(String,Exception) | Generated exception for a invalid radius error with a given message and inner exception.

See Also

Reference

InvalidRadiusException Class
InvalidRadiusException Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidRadiusException Constructor()
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidRadiusException Class > InvalidRadiusException Constructor : InvalidRadiusException Constructor()

Glossary Item Box

An exception generated for a invalid radius error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New InvalidRadiusException()
public InvalidRadiusException()
public: InvalidRadiusException();
public:
InvalidRadiusException();

See Also

Reference

InvalidRadiusException Class
InvalidRadiusException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidRadiusException Constructor(Int32)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidRadiusException Class > InvalidRadiusException Constructor : InvalidRadiusException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a invalid radius error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New InvalidRadiusException(errorNumber)
public InvalidRadiusException(
   int errorNumber
)
public: InvalidRadiusException(
   int errorNumber
)
public:
InvalidRadiusException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

InvalidRadiusException Class
InvalidRadiusException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidRadiusException Constructor(String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidRadiusException Class > InvalidRadiusException Constructor : InvalidRadiusException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a invalid radius error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New InvalidRadiusException(message)
public InvalidRadiusException(
   string message
)
public: InvalidRadiusException(
   string* message
)
public:
InvalidRadiusException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

InvalidRadiusException Class
InvalidRadiusException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidRadiusException Constructor(Int32,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidRadiusException Class > InvalidRadiusException Constructor : InvalidRadiusException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a invalid radius error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New InvalidRadiusException(errorNumber, message)
public InvalidRadiusException(
   int errorNumber,
   string message
)
public: InvalidRadiusException(
   int errorNumber,
   string* message
)
public:
InvalidRadiusException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

InvalidRadiusException Class
InvalidRadiusException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidRadiusException Constructor(String,Exception)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidRadiusException Class > InvalidRadiusException Constructor : InvalidRadiusException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a invalid radius error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New InvalidRadiusException(message, innerException)
public InvalidRadiusException(
   string message,
   Exception innerException
)
public: InvalidRadiusException(
   string* message,
   Exception* innerException
)
public:
InvalidRadiusException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

InvalidRadiusException Class
InvalidRadiusException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidTemplateException Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : InvalidTemplateException Class

Glossary Item Box

This exception is thrown if the template is invalid.

Object Model

InvalidTemplateException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class InvalidTemplateException
   Inherits PrintProException
'Usage

Dim instance As InvalidTemplateException
[SerializableAttribute()]
public sealed class InvalidTemplateException : PrintProException
[SerializableAttribute()]
public __gc __sealed class InvalidTemplateException : public PrintProException
[SerializableAttribute()]
public ref class InvalidTemplateException sealed : public PrintProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.PrintProSdk.PrintProException
Accusoft.PrintProSdk.InvalidTemplateException

See Also

Reference

InvalidTemplateException Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
InvalidTemplateException Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : InvalidTemplateException Class

Glossary Item Box

The following tables list the members exposed by InvalidTemplateException.

Public Constructors

 | Name | Description
Public Constructor | InvalidTemplateException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidTemplateException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
InvalidTemplateException Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : InvalidTemplateException Class

Glossary Item Box

For a list of all members of this type, see InvalidTemplateException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidTemplateException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
InvalidTemplateException Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : InvalidTemplateException Class

Glossary Item Box

For a list of all members of this type, see InvalidTemplateException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidTemplateException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidTemplateException Constructor
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidTemplateException Class : InvalidTemplateException Constructor

Glossary Item Box

Overload List

Overload | Description
InvalidTemplateException Constructor() | An exception generated for a invalid template error.
InvalidTemplateException Constructor(Int32) | Generated exception for a invalid template error with a given error number.
InvalidTemplateException Constructor(String) | Generated exception for a invalid template error with a given string.
InvalidTemplateException Constructor(Int32,String) | Generated exception for a invalid template error with a given error number and message.
InvalidTemplateException Constructor(String,Exception) | Generated exception for a invalid template error with a given message and inner exception.

See Also

Reference

InvalidTemplateException Class
InvalidTemplateException Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidTemplateException Constructor()
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidTemplateException Class > InvalidTemplateException Constructor : InvalidTemplateException Constructor()

Glossary Item Box

An exception generated for a invalid template error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New InvalidTemplateException()
public InvalidTemplateException()
public: InvalidTemplateException();
public:
InvalidTemplateException();

See Also

Reference

InvalidTemplateException Class
InvalidTemplateException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidTemplateException Constructor(Int32)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidTemplateException Class > InvalidTemplateException Constructor : InvalidTemplateException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a invalid template error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New InvalidTemplateException(errorNumber)
public InvalidTemplateException(
   int errorNumber
)
public: InvalidTemplateException(
   int errorNumber
)
public:
InvalidTemplateException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

InvalidTemplateException Class
InvalidTemplateException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidTemplateException Constructor(String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidTemplateException Class > InvalidTemplateException Constructor : InvalidTemplateException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a invalid template error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New InvalidTemplateException(message)
public InvalidTemplateException(
   string message
)
public: InvalidTemplateException(
   string* message
)
public:
InvalidTemplateException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

InvalidTemplateException Class
InvalidTemplateException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidTemplateException Constructor(Int32,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidTemplateException Class > InvalidTemplateException Constructor : InvalidTemplateException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a invalid template error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New InvalidTemplateException(errorNumber, message)
public InvalidTemplateException(
   int errorNumber,
   string message
)
public: InvalidTemplateException(
   int errorNumber,
   string* message
)
public:
InvalidTemplateException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

InvalidTemplateException Class
InvalidTemplateException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidTemplateException Constructor(String,Exception)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidTemplateException Class > InvalidTemplateException Constructor : InvalidTemplateException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a invalid template error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New InvalidTemplateException(message, innerException)
public InvalidTemplateException(
   string message,
   Exception innerException
)
public: InvalidTemplateException(
   string* message,
   Exception* innerException
)
public:
InvalidTemplateException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

InvalidTemplateException Class
InvalidTemplateException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidTiffSizeException Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : InvalidTiffSizeException Class

Glossary Item Box

This exception is thrown if the TIFF size is invalid.

Object Model

InvalidTiffSizeException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class InvalidTiffSizeException
   Inherits PrintProException
'Usage

Dim instance As InvalidTiffSizeException
[SerializableAttribute()]
public sealed class InvalidTiffSizeException : PrintProException
[SerializableAttribute()]
public __gc __sealed class InvalidTiffSizeException : public PrintProException
[SerializableAttribute()]
public ref class InvalidTiffSizeException sealed : public PrintProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.PrintProSdk.PrintProException
Accusoft.PrintProSdk.InvalidTiffSizeException

See Also

Reference

InvalidTiffSizeException Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
InvalidTiffSizeException Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : InvalidTiffSizeException Class

Glossary Item Box

The following tables list the members exposed by InvalidTiffSizeException.

Public Constructors

 | Name | Description
Public Constructor | InvalidTiffSizeException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidTiffSizeException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
InvalidTiffSizeException Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : InvalidTiffSizeException Class

Glossary Item Box

For a list of all members of this type, see InvalidTiffSizeException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidTiffSizeException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
InvalidTiffSizeException Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : InvalidTiffSizeException Class

Glossary Item Box

For a list of all members of this type, see InvalidTiffSizeException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidTiffSizeException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidTiffSizeException Constructor
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidTiffSizeException Class : InvalidTiffSizeException Constructor

Glossary Item Box

Overload List

Overload | Description
InvalidTiffSizeException Constructor() | An exception generated for a invalid TIFF size error.
InvalidTiffSizeException Constructor(Int32) | Generated exception for a invalid TIFF size error with a given error number.
InvalidTiffSizeException Constructor(String) | Generated exception for a invalid TIFF size error with a given string.
InvalidTiffSizeException Constructor(Int32,String) | Generated exception for a invalid TIFF size error with a given error number and message.
InvalidTiffSizeException Constructor(String,Exception) | Generated exception for a invalid TIFF size error with a given message and inner exception.

See Also

Reference

InvalidTiffSizeException Class
InvalidTiffSizeException Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidTiffSizeException Constructor()
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidTiffSizeException Class > InvalidTiffSizeException Constructor : InvalidTiffSizeException Constructor()

Glossary Item Box

An exception generated for a invalid TIFF size error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New InvalidTiffSizeException()
public InvalidTiffSizeException()
public: InvalidTiffSizeException();
public:
InvalidTiffSizeException();

See Also

Reference

InvalidTiffSizeException Class
InvalidTiffSizeException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidTiffSizeException Constructor(Int32)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidTiffSizeException Class > InvalidTiffSizeException Constructor : InvalidTiffSizeException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a invalid TIFF size error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New InvalidTiffSizeException(errorNumber)
public InvalidTiffSizeException(
   int errorNumber
)
public: InvalidTiffSizeException(
   int errorNumber
)
public:
InvalidTiffSizeException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

InvalidTiffSizeException Class
InvalidTiffSizeException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidTiffSizeException Constructor(String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidTiffSizeException Class > InvalidTiffSizeException Constructor : InvalidTiffSizeException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a invalid TIFF size error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New InvalidTiffSizeException(message)
public InvalidTiffSizeException(
   string message
)
public: InvalidTiffSizeException(
   string* message
)
public:
InvalidTiffSizeException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

InvalidTiffSizeException Class
InvalidTiffSizeException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidTiffSizeException Constructor(Int32,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidTiffSizeException Class > InvalidTiffSizeException Constructor : InvalidTiffSizeException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a invalid TIFF size error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New InvalidTiffSizeException(errorNumber, message)
public InvalidTiffSizeException(
   int errorNumber,
   string message
)
public: InvalidTiffSizeException(
   int errorNumber,
   string* message
)
public:
InvalidTiffSizeException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

InvalidTiffSizeException Class
InvalidTiffSizeException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidTiffSizeException Constructor(String,Exception)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidTiffSizeException Class > InvalidTiffSizeException Constructor : InvalidTiffSizeException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a invalid TIFF size error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New InvalidTiffSizeException(message, innerException)
public InvalidTiffSizeException(
   string message,
   Exception innerException
)
public: InvalidTiffSizeException(
   string* message,
   Exception* innerException
)
public:
InvalidTiffSizeException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

InvalidTiffSizeException Class
InvalidTiffSizeException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidValueException Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : InvalidValueException Class

Glossary Item Box

This exception is thrown if the value provided for the printer property is invalid.

Object Model

InvalidValueException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class InvalidValueException
   Inherits PrintProException
'Usage

Dim instance As InvalidValueException
[SerializableAttribute()]
public sealed class InvalidValueException : PrintProException
[SerializableAttribute()]
public __gc __sealed class InvalidValueException : public PrintProException
[SerializableAttribute()]
public ref class InvalidValueException sealed : public PrintProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.PrintProSdk.PrintProException
Accusoft.PrintProSdk.InvalidValueException

See Also

Reference

InvalidValueException Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
InvalidValueException Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : InvalidValueException Class

Glossary Item Box

The following tables list the members exposed by InvalidValueException.

Public Constructors

 | Name | Description
Public Constructor | InvalidValueException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidValueException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
InvalidValueException Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : InvalidValueException Class

Glossary Item Box

For a list of all members of this type, see InvalidValueException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidValueException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
InvalidValueException Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : InvalidValueException Class

Glossary Item Box

For a list of all members of this type, see InvalidValueException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidValueException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidValueException Constructor
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidValueException Class : InvalidValueException Constructor

Glossary Item Box

Overload List

Overload | Description
InvalidValueException Constructor() | An exception generated for a invalid value error.
InvalidValueException Constructor(Int32) | Generated exception for a invalid value error with a given error number.
InvalidValueException Constructor(String) | Generated exception for a invalid value error with a given string.
InvalidValueException Constructor(Int32,String) | Generated exception for a invalid value error with a given error number and message.
InvalidValueException Constructor(String,Exception) | Generated exception for a invalid value error with a given message and inner exception.

See Also

Reference

InvalidValueException Class
InvalidValueException Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidValueException Constructor()
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidValueException Class > InvalidValueException Constructor : InvalidValueException Constructor()

Glossary Item Box

An exception generated for a invalid value error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New InvalidValueException()
public InvalidValueException()
public: InvalidValueException();
public:
InvalidValueException();

See Also

Reference

InvalidValueException Class
InvalidValueException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidValueException Constructor(Int32)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidValueException Class > InvalidValueException Constructor : InvalidValueException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a invalid value error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New InvalidValueException(errorNumber)
public InvalidValueException(
   int errorNumber
)
public: InvalidValueException(
   int errorNumber
)
public:
InvalidValueException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

InvalidValueException Class
InvalidValueException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidValueException Constructor(String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidValueException Class > InvalidValueException Constructor : InvalidValueException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a invalid value error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New InvalidValueException(message)
public InvalidValueException(
   string message
)
public: InvalidValueException(
   string* message
)
public:
InvalidValueException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

InvalidValueException Class
InvalidValueException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidValueException Constructor(Int32,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidValueException Class > InvalidValueException Constructor : InvalidValueException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a invalid value error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New InvalidValueException(errorNumber, message)
public InvalidValueException(
   int errorNumber,
   string message
)
public: InvalidValueException(
   int errorNumber,
   string* message
)
public:
InvalidValueException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

InvalidValueException Class
InvalidValueException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidValueException Constructor(String,Exception)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidValueException Class > InvalidValueException Constructor : InvalidValueException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a invalid value error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New InvalidValueException(message, innerException)
public InvalidValueException(
   string message,
   Exception innerException
)
public: InvalidValueException(
   string* message,
   Exception* innerException
)
public:
InvalidValueException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

InvalidValueException Class
InvalidValueException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidWebCode Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : InvalidWebCode Class

Glossary Item Box

This exception is thrown if the web code is invalid.

Object Model

InvalidWebCode Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class InvalidWebCode
   Inherits PrintProException
'Usage

Dim instance As InvalidWebCode
[SerializableAttribute()]
public sealed class InvalidWebCode : PrintProException
[SerializableAttribute()]
public __gc __sealed class InvalidWebCode : public PrintProException
[SerializableAttribute()]
public ref class InvalidWebCode sealed : public PrintProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.PrintProSdk.PrintProException
Accusoft.PrintProSdk.InvalidWebCode

See Also

Reference

InvalidWebCode Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
InvalidWebCode Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : InvalidWebCode Class

Glossary Item Box

The following tables list the members exposed by InvalidWebCode.

Public Constructors

 | Name | Description
Public Constructor | InvalidWebCode Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidWebCode Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
InvalidWebCode Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : InvalidWebCode Class

Glossary Item Box

For a list of all members of this type, see InvalidWebCode members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidWebCode Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
InvalidWebCode Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : InvalidWebCode Class

Glossary Item Box

For a list of all members of this type, see InvalidWebCode members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidWebCode Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidWebCode Constructor
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidWebCode Class : InvalidWebCode Constructor

Glossary Item Box

Overload List

Overload | Description
InvalidWebCode Constructor() | An exception generated for a invalid web code error.
InvalidWebCode Constructor(Int32) | Generated exception for a invalid web code error with a given error number.
InvalidWebCode Constructor(String) | Generated exception for a invalid web code error with a given string.
InvalidWebCode Constructor(Int32,String) | Generated exception for a invalid web code error with a given error number and message.
InvalidWebCode Constructor(String,Exception) | Generated exception for a invalid web code error with a given message and inner exception.

See Also

Reference

InvalidWebCode Class
InvalidWebCode Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidWebCode Constructor()
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidWebCode Class > InvalidWebCode Constructor : InvalidWebCode Constructor()

Glossary Item Box

An exception generated for a invalid web code error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New InvalidWebCode()
public InvalidWebCode()
public: InvalidWebCode();
public:
InvalidWebCode();

See Also

Reference

InvalidWebCode Class
InvalidWebCode Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidWebCode Constructor(Int32)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidWebCode Class > InvalidWebCode Constructor : InvalidWebCode Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a invalid web code error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New InvalidWebCode(errorNumber)
public InvalidWebCode(
   int errorNumber
)
public: InvalidWebCode(
   int errorNumber
)
public:
InvalidWebCode(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

InvalidWebCode Class
InvalidWebCode Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidWebCode Constructor(String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidWebCode Class > InvalidWebCode Constructor : InvalidWebCode Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a invalid web code error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New InvalidWebCode(message)
public InvalidWebCode(
   string message
)
public: InvalidWebCode(
   string* message
)
public:
InvalidWebCode(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

InvalidWebCode Class
InvalidWebCode Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidWebCode Constructor(Int32,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidWebCode Class > InvalidWebCode Constructor : InvalidWebCode Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a invalid web code error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New InvalidWebCode(errorNumber, message)
public InvalidWebCode(
   int errorNumber,
   string message
)
public: InvalidWebCode(
   int errorNumber,
   string* message
)
public:
InvalidWebCode(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

InvalidWebCode Class
InvalidWebCode Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidWebCode Constructor(String,Exception)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidWebCode Class > InvalidWebCode Constructor : InvalidWebCode Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a invalid web code error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New InvalidWebCode(message, innerException)
public InvalidWebCode(
   string message,
   Exception innerException
)
public: InvalidWebCode(
   string* message,
   Exception* innerException
)
public:
InvalidWebCode(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

InvalidWebCode Class
InvalidWebCode Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidWorkerObjectIDException Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : InvalidWorkerObjectIDException Class

Glossary Item Box

This exception is thrown if the worker object ID is invalid.

Object Model

InvalidWorkerObjectIDException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class InvalidWorkerObjectIDException
   Inherits PrintProException
'Usage

Dim instance As InvalidWorkerObjectIDException
[SerializableAttribute()]
public sealed class InvalidWorkerObjectIDException : PrintProException
[SerializableAttribute()]
public __gc __sealed class InvalidWorkerObjectIDException : public PrintProException
[SerializableAttribute()]
public ref class InvalidWorkerObjectIDException sealed : public PrintProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.PrintProSdk.PrintProException
Accusoft.PrintProSdk.InvalidWorkerObjectIDException

See Also

Reference

InvalidWorkerObjectIDException Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
InvalidWorkerObjectIDException Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : InvalidWorkerObjectIDException Class

Glossary Item Box

The following tables list the members exposed by InvalidWorkerObjectIDException.

Public Constructors

 | Name | Description
Public Constructor | InvalidWorkerObjectIDException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidWorkerObjectIDException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
InvalidWorkerObjectIDException Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : InvalidWorkerObjectIDException Class

Glossary Item Box

For a list of all members of this type, see InvalidWorkerObjectIDException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidWorkerObjectIDException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
InvalidWorkerObjectIDException Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : InvalidWorkerObjectIDException Class

Glossary Item Box

For a list of all members of this type, see InvalidWorkerObjectIDException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidWorkerObjectIDException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidWorkerObjectIDException Constructor
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidWorkerObjectIDException Class : InvalidWorkerObjectIDException Constructor

Glossary Item Box

Overload List

Overload | Description
InvalidWorkerObjectIDException Constructor() | An exception generated for a invalid worker object ID error.
InvalidWorkerObjectIDException Constructor(Int32) | Generated exception for a invalid worker object ID error with a given error number.
InvalidWorkerObjectIDException Constructor(String) | Generated exception for a invalid worker object ID error with a given string.
InvalidWorkerObjectIDException Constructor(Int32,String) | Generated exception for a invalid worker object ID error with a given error number and message.
InvalidWorkerObjectIDException Constructor(String,Exception) | Generated exception for a invalid worker object ID error with a given message and inner exception.

See Also

Reference

InvalidWorkerObjectIDException Class
InvalidWorkerObjectIDException Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidWorkerObjectIDException Constructor()
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidWorkerObjectIDException Class > InvalidWorkerObjectIDException Constructor : InvalidWorkerObjectIDException Constructor()

Glossary Item Box

An exception generated for a invalid worker object ID error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New InvalidWorkerObjectIDException()
public InvalidWorkerObjectIDException()
public: InvalidWorkerObjectIDException();
public:
InvalidWorkerObjectIDException();

See Also

Reference

InvalidWorkerObjectIDException Class
InvalidWorkerObjectIDException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidWorkerObjectIDException Constructor(Int32)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidWorkerObjectIDException Class > InvalidWorkerObjectIDException Constructor : InvalidWorkerObjectIDException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a invalid worker object ID error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New InvalidWorkerObjectIDException(errorNumber)
public InvalidWorkerObjectIDException(
   int errorNumber
)
public: InvalidWorkerObjectIDException(
   int errorNumber
)
public:
InvalidWorkerObjectIDException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

InvalidWorkerObjectIDException Class
InvalidWorkerObjectIDException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidWorkerObjectIDException Constructor(String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidWorkerObjectIDException Class > InvalidWorkerObjectIDException Constructor : InvalidWorkerObjectIDException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a invalid worker object ID error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New InvalidWorkerObjectIDException(message)
public InvalidWorkerObjectIDException(
   string message
)
public: InvalidWorkerObjectIDException(
   string* message
)
public:
InvalidWorkerObjectIDException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

InvalidWorkerObjectIDException Class
InvalidWorkerObjectIDException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidWorkerObjectIDException Constructor(Int32,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidWorkerObjectIDException Class > InvalidWorkerObjectIDException Constructor : InvalidWorkerObjectIDException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a invalid worker object ID error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New InvalidWorkerObjectIDException(errorNumber, message)
public InvalidWorkerObjectIDException(
   int errorNumber,
   string message
)
public: InvalidWorkerObjectIDException(
   int errorNumber,
   string* message
)
public:
InvalidWorkerObjectIDException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

InvalidWorkerObjectIDException Class
InvalidWorkerObjectIDException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
InvalidWorkerObjectIDException Constructor(String,Exception)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > InvalidWorkerObjectIDException Class > InvalidWorkerObjectIDException Constructor : InvalidWorkerObjectIDException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a invalid worker object ID error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New InvalidWorkerObjectIDException(message, innerException)
public InvalidWorkerObjectIDException(
   string message,
   Exception innerException
)
public: InvalidWorkerObjectIDException(
   string* message,
   Exception* innerException
)
public:
InvalidWorkerObjectIDException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

InvalidWorkerObjectIDException Class
InvalidWorkerObjectIDException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Licensing Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : Licensing Class

Glossary Item Box

This class implements methods for setting the license information for the toolkit.

Object Model

Licensing Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Class Licensing
'Usage

Dim instance As Licensing
public class Licensing
public __gc class Licensing
public ref class Licensing

Remarks

This object exposes the licensing methods you need to call to license the toolkit.

Inheritance Hierarchy

System.Object
Accusoft.PrintProSdk.Licensing

See Also

Reference

Licensing Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
Licensing Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : Licensing Class

Glossary Item Box

The following tables list the members exposed by Licensing.

Public Constructors

 | Name | Description
Public Constructor | Licensing Constructor | The initial constructor for the licensing class passing in a workspace ID.
Top

Public Properties

 | Name | Description
Public Property | EvaluationMode | Gets and sets how the control will behave when in evaluation (non-licensed) mode.
Top

Public Methods

 | Name | Description
Public Method | Dispose | Disposes of unmanaged resources.
Public Method | SetOEMLicenseKey | Sets the PrintPro control runtime OEM license key required for OEM licensing.
Public Method | SetSolutionKey | Sets the PrintPro control runtime license deployment key.
Public Method | SetSolutionName | Sets the PrintPro control runtime license deployment solution name.
Top

See Also

Reference

Licensing Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
Licensing Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : Licensing Class

Glossary Item Box

For a list of all members of this type, see Licensing members.

Public Methods

 | Name | Description
Public Method | Dispose | Disposes of unmanaged resources.
Public Method | SetOEMLicenseKey | Sets the PrintPro control runtime OEM license key required for OEM licensing.
Public Method | SetSolutionKey | Sets the PrintPro control runtime license deployment key.
Public Method | SetSolutionName | Sets the PrintPro control runtime license deployment solution name.
Top

See Also

Reference

Licensing Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Licensing Constructor
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Licensing Class : Licensing Constructor

pWorkId
A PrintPRO workspace ID.

Glossary Item Box

The initial constructor for the licensing class passing in a workspace ID.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal pWorkId As IntPtr _
)
'Usage

Dim pWorkId As IntPtr

Dim instance As New Licensing(pWorkId)
public Licensing(
   IntPtr pWorkId
)
public: Licensing(
   IntPtr pWorkId
)
public:
Licensing(
   IntPtr pWorkId
)

Parameters

pWorkId
A PrintPRO workspace ID.

See Also

Reference

Licensing Class
Licensing Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Dispose Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Licensing Class : Dispose Method

Glossary Item Box

Disposes of unmanaged resources.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub Dispose()
'Usage

Dim instance As Licensing

instance.Dispose()
public void Dispose()
public: void Dispose();
public:
void Dispose();

Remarks

This method is part of the IDisposable interface.

See Also

Reference

Licensing Class
Licensing Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
SetOEMLicenseKey Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Licensing Class : SetOEMLicenseKey Method

oemKey
The OEM license key required for OEM licensing.

Glossary Item Box

Sets the PrintPro control runtime OEM license key required for OEM licensing.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub SetOEMLicenseKey( _
   ByVal oemKey As String _
)
'Usage

Dim instance As Licensing
Dim oemKey As String

instance.SetOEMLicenseKey(oemKey)
public void SetOEMLicenseKey(
   string oemKey
)
public: void SetOEMLicenseKey(
   string* oemKey
)
public:
void SetOEMLicenseKey(
   String^ oemKey
)

Parameters

oemKey
The OEM license key required for OEM licensing.

Remarks

When OEM runtime licenses are purchased, the OEM license key is provided in the purchase confirmation email.

See Also

Reference

Licensing Class
Licensing Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
SetSolutionKey Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Licensing Class : SetSolutionKey Method

key1
Unlock key 1
key2
Unlock key 2
key3
Unlock key 3
key4
Unlock key 4

Glossary Item Box

Sets the PrintPro control runtime license deployment key.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub SetSolutionKey( _
   ByVal key1 As Long, _
   ByVal key2 As Long, _
   ByVal key3 As Long, _
   ByVal key4 As Long _
)
'Usage

Dim instance As Licensing
Dim key1 As Long
Dim key2 As Long
Dim key3 As Long
Dim key4 As Long

instance.SetSolutionKey(key1, key2, key3, key4)
public void SetSolutionKey(
   long key1,
   long key2,
   long key3,
   long key4
)
public: void SetSolutionKey(
   long key1,
   long key2,
   long key3,
   long key4
)
public:
void SetSolutionKey(
   int64 key1,
   int64 key2,
   int64 key3,
   int64 key4
)

Parameters

key1
Unlock key 1
key2
Unlock key 2
key3
Unlock key 3
key4
Unlock key 4

Remarks

This is the solution key required for all runtime licensing. The four integers are provided at the time of purchase of the runtime licenses along with the solution name, which is set with the SetSolutionName method.

See Also

Reference

Licensing Class
Licensing Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
SetSolutionName Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Licensing Class : SetSolutionName Method

solutionName
The solution name.

Glossary Item Box

Sets the PrintPro control runtime license deployment solution name.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub SetSolutionName( _
   ByVal solutionName As String _
)
'Usage

Dim instance As Licensing
Dim solutionName As String

instance.SetSolutionName(solutionName)
public void SetSolutionName(
   string solutionName
)
public: void SetSolutionName(
   string* solutionName
)
public:
void SetSolutionName(
   String^ solutionName
)

Parameters

solutionName
The solution name.

Remarks

This is the name of the runtime license solution. The solution name is provided in the purchase confirmation email when runtime licenses are purchased.

See Also

Reference

Licensing Class
Licensing Members


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
Licensing Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : Licensing Class

Glossary Item Box

For a list of all members of this type, see Licensing members.

Public Properties

 | Name | Description
Public Property | EvaluationMode | Gets and sets how the control will behave when in evaluation (non-licensed) mode.
Top

See Also

Reference

Licensing Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
EvaluationMode Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Licensing Class : EvaluationMode Property

Glossary Item Box

Gets and sets how the control will behave when in evaluation (non-licensed) mode.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property EvaluationMode As EvaluationMode
'Usage

Dim instance As Licensing
Dim value As EvaluationMode

instance.EvaluationMode = value

value = instance.EvaluationMode
public EvaluationMode EvaluationMode {get; set;}
public: __property EvaluationMode get_EvaluationMode();
public: __property void set_EvaluationMode(
   EvaluationMode value
);
public:
property EvaluationMode EvaluationMode {
   EvaluationMode get();
   void set (    EvaluationMode value);
}

Property Value

An EvaluationMode enumeration value which determines the evaluation mode behavior for the component.

See Also

Reference

Licensing Class
Licensing Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
NoDibException Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : NoDibException Class

Glossary Item Box

This exception is thrown if an image is being printed but the DIB has not been set.

Object Model

NoDibException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class NoDibException
   Inherits PrintProException
'Usage

Dim instance As NoDibException
[SerializableAttribute()]
public sealed class NoDibException : PrintProException
[SerializableAttribute()]
public __gc __sealed class NoDibException : public PrintProException
[SerializableAttribute()]
public ref class NoDibException sealed : public PrintProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.PrintProSdk.PrintProException
Accusoft.PrintProSdk.NoDibException

See Also

Reference

NoDibException Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
NoDibException Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : NoDibException Class

Glossary Item Box

The following tables list the members exposed by NoDibException.

Public Constructors

 | Name | Description
Public Constructor | NoDibException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

NoDibException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
NoDibException Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : NoDibException Class

Glossary Item Box

For a list of all members of this type, see NoDibException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

NoDibException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
NoDibException Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : NoDibException Class

Glossary Item Box

For a list of all members of this type, see NoDibException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

NoDibException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
NoDibException Constructor
See Also Send Feedback
Accusoft.PrintProSdk Namespace > NoDibException Class : NoDibException Constructor

Glossary Item Box

Overload List

Overload | Description
NoDibException Constructor() | An exception generated for a no DIB error.
NoDibException Constructor(Int32) | Generated exception for a no DIB error with a given error number.
NoDibException Constructor(String) | Generated exception for a no DIB error with a given string.
NoDibException Constructor(Int32,String) | Generated exception for a no DIB error with a given error number and message.
NoDibException Constructor(String,Exception) | Generated exception for a no DIB error with a given message and inner exception.

See Also

Reference

NoDibException Class
NoDibException Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
NoDibException Constructor()
See Also Send Feedback
Accusoft.PrintProSdk Namespace > NoDibException Class > NoDibException Constructor : NoDibException Constructor()

Glossary Item Box

An exception generated for a no DIB error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New NoDibException()
public NoDibException()
public: NoDibException();
public:
NoDibException();

See Also

Reference

NoDibException Class
NoDibException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
NoDibException Constructor(Int32)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > NoDibException Class > NoDibException Constructor : NoDibException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a no DIB error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New NoDibException(errorNumber)
public NoDibException(
   int errorNumber
)
public: NoDibException(
   int errorNumber
)
public:
NoDibException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

NoDibException Class
NoDibException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
NoDibException Constructor(String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > NoDibException Class > NoDibException Constructor : NoDibException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a no DIB error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New NoDibException(message)
public NoDibException(
   string message
)
public: NoDibException(
   string* message
)
public:
NoDibException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

NoDibException Class
NoDibException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
NoDibException Constructor(Int32,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > NoDibException Class > NoDibException Constructor : NoDibException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a no DIB error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New NoDibException(errorNumber, message)
public NoDibException(
   int errorNumber,
   string message
)
public: NoDibException(
   int errorNumber,
   string* message
)
public:
NoDibException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

NoDibException Class
NoDibException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
NoDibException Constructor(String,Exception)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > NoDibException Class > NoDibException Constructor : NoDibException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a no DIB error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New NoDibException(message, innerException)
public NoDibException(
   string message,
   Exception innerException
)
public: NoDibException(
   string* message,
   Exception* innerException
)
public:
NoDibException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

NoDibException Class
NoDibException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
NoPrinterDCException Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : NoPrinterDCException Class

Glossary Item Box

This exception is thrown if there is no printer DC.

Object Model

NoPrinterDCException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class NoPrinterDCException
   Inherits PrintProException
'Usage

Dim instance As NoPrinterDCException
[SerializableAttribute()]
public sealed class NoPrinterDCException : PrintProException
[SerializableAttribute()]
public __gc __sealed class NoPrinterDCException : public PrintProException
[SerializableAttribute()]
public ref class NoPrinterDCException sealed : public PrintProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.PrintProSdk.PrintProException
Accusoft.PrintProSdk.NoPrinterDCException

See Also

Reference

NoPrinterDCException Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
NoPrinterDCException Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : NoPrinterDCException Class

Glossary Item Box

The following tables list the members exposed by NoPrinterDCException.

Public Constructors

 | Name | Description
Public Constructor | NoPrinterDCException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

NoPrinterDCException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
NoPrinterDCException Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : NoPrinterDCException Class

Glossary Item Box

For a list of all members of this type, see NoPrinterDCException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

NoPrinterDCException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
NoPrinterDCException Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : NoPrinterDCException Class

Glossary Item Box

For a list of all members of this type, see NoPrinterDCException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

NoPrinterDCException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
NoPrinterDCException Constructor
See Also Send Feedback
Accusoft.PrintProSdk Namespace > NoPrinterDCException Class : NoPrinterDCException Constructor

Glossary Item Box

Overload List

Overload | Description
NoPrinterDCException Constructor() | An exception generated for a no printer DC error.
NoPrinterDCException Constructor(Int32) | Generated exception for a no printer DC error with a given error number.
NoPrinterDCException Constructor(String) | Generated exception for a no printer DC error with a given string.
NoPrinterDCException Constructor(Int32,String) | Generated exception for a no printer DC error with a given error number and message.
NoPrinterDCException Constructor(String,Exception) | Generated exception for a no printer DC error with a given message and inner exception.

See Also

Reference

NoPrinterDCException Class
NoPrinterDCException Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
NoPrinterDCException Constructor()
See Also Send Feedback
Accusoft.PrintProSdk Namespace > NoPrinterDCException Class > NoPrinterDCException Constructor : NoPrinterDCException Constructor()

Glossary Item Box

An exception generated for a no printer DC error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New NoPrinterDCException()
public NoPrinterDCException()
public: NoPrinterDCException();
public:
NoPrinterDCException();

See Also

Reference

NoPrinterDCException Class
NoPrinterDCException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
NoPrinterDCException Constructor(Int32)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > NoPrinterDCException Class > NoPrinterDCException Constructor : NoPrinterDCException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a no printer DC error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New NoPrinterDCException(errorNumber)
public NoPrinterDCException(
   int errorNumber
)
public: NoPrinterDCException(
   int errorNumber
)
public:
NoPrinterDCException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

NoPrinterDCException Class
NoPrinterDCException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
NoPrinterDCException Constructor(String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > NoPrinterDCException Class > NoPrinterDCException Constructor : NoPrinterDCException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a no printer DC error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New NoPrinterDCException(message)
public NoPrinterDCException(
   string message
)
public: NoPrinterDCException(
   string* message
)
public:
NoPrinterDCException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

NoPrinterDCException Class
NoPrinterDCException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
NoPrinterDCException Constructor(Int32,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > NoPrinterDCException Class > NoPrinterDCException Constructor : NoPrinterDCException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a no printer DC error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New NoPrinterDCException(errorNumber, message)
public NoPrinterDCException(
   int errorNumber,
   string message
)
public: NoPrinterDCException(
   int errorNumber,
   string* message
)
public:
NoPrinterDCException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

NoPrinterDCException Class
NoPrinterDCException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
NoPrinterDCException Constructor(String,Exception)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > NoPrinterDCException Class > NoPrinterDCException Constructor : NoPrinterDCException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a no printer DC error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New NoPrinterDCException(message, innerException)
public NoPrinterDCException(
   string message,
   Exception innerException
)
public: NoPrinterDCException(
   string* message,
   Exception* innerException
)
public:
NoPrinterDCException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

NoPrinterDCException Class
NoPrinterDCException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
NoPrinterSelectedException Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : NoPrinterSelectedException Class

Glossary Item Box

This exception is thrown if no printer is selected.

Object Model

NoPrinterSelectedException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class NoPrinterSelectedException
   Inherits PrintProException
'Usage

Dim instance As NoPrinterSelectedException
[SerializableAttribute()]
public sealed class NoPrinterSelectedException : PrintProException
[SerializableAttribute()]
public __gc __sealed class NoPrinterSelectedException : public PrintProException
[SerializableAttribute()]
public ref class NoPrinterSelectedException sealed : public PrintProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.PrintProSdk.PrintProException
Accusoft.PrintProSdk.NoPrinterSelectedException

See Also

Reference

NoPrinterSelectedException Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
NoPrinterSelectedException Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : NoPrinterSelectedException Class

Glossary Item Box

The following tables list the members exposed by NoPrinterSelectedException.

Public Constructors

 | Name | Description
Public Constructor | NoPrinterSelectedException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

NoPrinterSelectedException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
NoPrinterSelectedException Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : NoPrinterSelectedException Class

Glossary Item Box

For a list of all members of this type, see NoPrinterSelectedException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

NoPrinterSelectedException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
NoPrinterSelectedException Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : NoPrinterSelectedException Class

Glossary Item Box

For a list of all members of this type, see NoPrinterSelectedException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

NoPrinterSelectedException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
NoPrinterSelectedException Constructor
See Also Send Feedback
Accusoft.PrintProSdk Namespace > NoPrinterSelectedException Class : NoPrinterSelectedException Constructor

Glossary Item Box

Overload List

Overload | Description
NoPrinterSelectedException Constructor() | An exception generated for a no printer selected error.
NoPrinterSelectedException Constructor(Int32) | Generated exception for a no printer selected error with a given error number.
NoPrinterSelectedException Constructor(String) | Generated exception for a no printer selected error with a given string.
NoPrinterSelectedException Constructor(Int32,String) | Generated exception for a no printer selected error with a given error number and message.
NoPrinterSelectedException Constructor(String,Exception) | Generated exception for a no printer selected error with a given message and inner exception.

See Also

Reference

NoPrinterSelectedException Class
NoPrinterSelectedException Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
NoPrinterSelectedException Constructor()
See Also Send Feedback
Accusoft.PrintProSdk Namespace > NoPrinterSelectedException Class > NoPrinterSelectedException Constructor : NoPrinterSelectedException Constructor()

Glossary Item Box

An exception generated for a no printer selected error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New NoPrinterSelectedException()
public NoPrinterSelectedException()
public: NoPrinterSelectedException();
public:
NoPrinterSelectedException();

See Also

Reference

NoPrinterSelectedException Class
NoPrinterSelectedException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
NoPrinterSelectedException Constructor(Int32)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > NoPrinterSelectedException Class > NoPrinterSelectedException Constructor : NoPrinterSelectedException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a no printer selected error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New NoPrinterSelectedException(errorNumber)
public NoPrinterSelectedException(
   int errorNumber
)
public: NoPrinterSelectedException(
   int errorNumber
)
public:
NoPrinterSelectedException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

NoPrinterSelectedException Class
NoPrinterSelectedException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
NoPrinterSelectedException Constructor(String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > NoPrinterSelectedException Class > NoPrinterSelectedException Constructor : NoPrinterSelectedException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a no printer selected error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New NoPrinterSelectedException(message)
public NoPrinterSelectedException(
   string message
)
public: NoPrinterSelectedException(
   string* message
)
public:
NoPrinterSelectedException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

NoPrinterSelectedException Class
NoPrinterSelectedException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
NoPrinterSelectedException Constructor(Int32,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > NoPrinterSelectedException Class > NoPrinterSelectedException Constructor : NoPrinterSelectedException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a no printer selected error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New NoPrinterSelectedException(errorNumber, message)
public NoPrinterSelectedException(
   int errorNumber,
   string message
)
public: NoPrinterSelectedException(
   int errorNumber,
   string* message
)
public:
NoPrinterSelectedException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

NoPrinterSelectedException Class
NoPrinterSelectedException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
NoPrinterSelectedException Constructor(String,Exception)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > NoPrinterSelectedException Class > NoPrinterSelectedException Constructor : NoPrinterSelectedException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a no printer selected error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New NoPrinterSelectedException(message, innerException)
public NoPrinterSelectedException(
   string message,
   Exception innerException
)
public: NoPrinterSelectedException(
   string* message,
   Exception* innerException
)
public:
NoPrinterSelectedException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

NoPrinterSelectedException Class
NoPrinterSelectedException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
NoPrintPreviewException Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : NoPrintPreviewException Class

Glossary Item Box

This exception is thrown if a print preview for the current page does not exist.

Object Model

NoPrintPreviewException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class NoPrintPreviewException
   Inherits PrintProException
'Usage

Dim instance As NoPrintPreviewException
[SerializableAttribute()]
public sealed class NoPrintPreviewException : PrintProException
[SerializableAttribute()]
public __gc __sealed class NoPrintPreviewException : public PrintProException
[SerializableAttribute()]
public ref class NoPrintPreviewException sealed : public PrintProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.PrintProSdk.PrintProException
Accusoft.PrintProSdk.NoPrintPreviewException

See Also

Reference

NoPrintPreviewException Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
NoPrintPreviewException Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : NoPrintPreviewException Class

Glossary Item Box

The following tables list the members exposed by NoPrintPreviewException.

Public Constructors

 | Name | Description
Public Constructor | NoPrintPreviewException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

NoPrintPreviewException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
NoPrintPreviewException Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : NoPrintPreviewException Class

Glossary Item Box

For a list of all members of this type, see NoPrintPreviewException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

NoPrintPreviewException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
NoPrintPreviewException Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : NoPrintPreviewException Class

Glossary Item Box

For a list of all members of this type, see NoPrintPreviewException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

NoPrintPreviewException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
NoPrintPreviewException Constructor
See Also Send Feedback
Accusoft.PrintProSdk Namespace > NoPrintPreviewException Class : NoPrintPreviewException Constructor

Glossary Item Box

Overload List

Overload | Description
NoPrintPreviewException Constructor() | An exception generated for a no print preview error.
NoPrintPreviewException Constructor(Int32) | Generated exception for a no print preview error with a given error number.
NoPrintPreviewException Constructor(String) | Generated exception for a no print preview error with a given string.
NoPrintPreviewException Constructor(Int32,String) | Generated exception for a no print preview error with a given error number and message.
NoPrintPreviewException Constructor(String,Exception) | Generated exception for a no print preview error with a given message and inner exception.

See Also

Reference

NoPrintPreviewException Class
NoPrintPreviewException Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
NoPrintPreviewException Constructor()
See Also Send Feedback
Accusoft.PrintProSdk Namespace > NoPrintPreviewException Class > NoPrintPreviewException Constructor : NoPrintPreviewException Constructor()

Glossary Item Box

An exception generated for a no print preview error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New NoPrintPreviewException()
public NoPrintPreviewException()
public: NoPrintPreviewException();
public:
NoPrintPreviewException();

See Also

Reference

NoPrintPreviewException Class
NoPrintPreviewException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
NoPrintPreviewException Constructor(Int32)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > NoPrintPreviewException Class > NoPrintPreviewException Constructor : NoPrintPreviewException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a no print preview error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New NoPrintPreviewException(errorNumber)
public NoPrintPreviewException(
   int errorNumber
)
public: NoPrintPreviewException(
   int errorNumber
)
public:
NoPrintPreviewException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

NoPrintPreviewException Class
NoPrintPreviewException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
NoPrintPreviewException Constructor(String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > NoPrintPreviewException Class > NoPrintPreviewException Constructor : NoPrintPreviewException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a no print preview error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New NoPrintPreviewException(message)
public NoPrintPreviewException(
   string message
)
public: NoPrintPreviewException(
   string* message
)
public:
NoPrintPreviewException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

NoPrintPreviewException Class
NoPrintPreviewException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
NoPrintPreviewException Constructor(Int32,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > NoPrintPreviewException Class > NoPrintPreviewException Constructor : NoPrintPreviewException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a no print preview error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New NoPrintPreviewException(errorNumber, message)
public NoPrintPreviewException(
   int errorNumber,
   string message
)
public: NoPrintPreviewException(
   int errorNumber,
   string* message
)
public:
NoPrintPreviewException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

NoPrintPreviewException Class
NoPrintPreviewException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
NoPrintPreviewException Constructor(String,Exception)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > NoPrintPreviewException Class > NoPrintPreviewException Constructor : NoPrintPreviewException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a no print preview error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New NoPrintPreviewException(message, innerException)
public NoPrintPreviewException(
   string message,
   Exception innerException
)
public: NoPrintPreviewException(
   string* message,
   Exception* innerException
)
public:
NoPrintPreviewException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

NoPrintPreviewException Class
NoPrintPreviewException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
NotLicensedException Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : NotLicensedException Class

Glossary Item Box

This exception is thrown if PrintPRO is not licensed to perform the desired operation.

Object Model

NotLicensedException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class NotLicensedException
   Inherits PrintProException
'Usage

Dim instance As NotLicensedException
[SerializableAttribute()]
public sealed class NotLicensedException : PrintProException
[SerializableAttribute()]
public __gc __sealed class NotLicensedException : public PrintProException
[SerializableAttribute()]
public ref class NotLicensedException sealed : public PrintProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.PrintProSdk.PrintProException
Accusoft.PrintProSdk.NotLicensedException

See Also

Reference

NotLicensedException Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
NotLicensedException Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : NotLicensedException Class

Glossary Item Box

The following tables list the members exposed by NotLicensedException.

Public Constructors

 | Name | Description
Public Constructor | NotLicensedException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

NotLicensedException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
NotLicensedException Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : NotLicensedException Class

Glossary Item Box

For a list of all members of this type, see NotLicensedException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

NotLicensedException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
NotLicensedException Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : NotLicensedException Class

Glossary Item Box

For a list of all members of this type, see NotLicensedException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

NotLicensedException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
NotLicensedException Constructor
See Also Send Feedback
Accusoft.PrintProSdk Namespace > NotLicensedException Class : NotLicensedException Constructor

Glossary Item Box

Overload List

Overload | Description
NotLicensedException Constructor() | An exception generated for a not licensed error.
NotLicensedException Constructor(Int32) | Generated exception for a not licensed error with a given error number.
NotLicensedException Constructor(String) | Generated exception for a not licensed error with a given string.
NotLicensedException Constructor(Int32,String) | Generated exception for a not licensed error with a given error number and message.
NotLicensedException Constructor(String,Exception) | Generated exception for a not licensed error with a given message and inner exception.

See Also

Reference

NotLicensedException Class
NotLicensedException Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
NotLicensedException Constructor()
See Also Send Feedback
Accusoft.PrintProSdk Namespace > NotLicensedException Class > NotLicensedException Constructor : NotLicensedException Constructor()

Glossary Item Box

An exception generated for a not licensed error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New NotLicensedException()
public NotLicensedException()
public: NotLicensedException();
public:
NotLicensedException();

See Also

Reference

NotLicensedException Class
NotLicensedException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
NotLicensedException Constructor(Int32)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > NotLicensedException Class > NotLicensedException Constructor : NotLicensedException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a not licensed error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New NotLicensedException(errorNumber)
public NotLicensedException(
   int errorNumber
)
public: NotLicensedException(
   int errorNumber
)
public:
NotLicensedException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

NotLicensedException Class
NotLicensedException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
NotLicensedException Constructor(String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > NotLicensedException Class > NotLicensedException Constructor : NotLicensedException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a not licensed error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New NotLicensedException(message)
public NotLicensedException(
   string message
)
public: NotLicensedException(
   string* message
)
public:
NotLicensedException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

NotLicensedException Class
NotLicensedException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
NotLicensedException Constructor(Int32,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > NotLicensedException Class > NotLicensedException Constructor : NotLicensedException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a not licensed error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New NotLicensedException(errorNumber, message)
public NotLicensedException(
   int errorNumber,
   string message
)
public: NotLicensedException(
   int errorNumber,
   string* message
)
public:
NotLicensedException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

NotLicensedException Class
NotLicensedException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
NotLicensedException Constructor(String,Exception)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > NotLicensedException Class > NotLicensedException Constructor : NotLicensedException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a not licensed error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New NotLicensedException(message, innerException)
public NotLicensedException(
   string message,
   Exception innerException
)
public: NotLicensedException(
   string* message,
   Exception* innerException
)
public:
NotLicensedException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

NotLicensedException Class
NotLicensedException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
OpenFileException Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : OpenFileException Class

Glossary Item Box

This exception is thrown if an error occurs when opening the file.

Object Model

OpenFileException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class OpenFileException
   Inherits PrintProException
'Usage

Dim instance As OpenFileException
[SerializableAttribute()]
public sealed class OpenFileException : PrintProException
[SerializableAttribute()]
public __gc __sealed class OpenFileException : public PrintProException
[SerializableAttribute()]
public ref class OpenFileException sealed : public PrintProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.PrintProSdk.PrintProException
Accusoft.PrintProSdk.OpenFileException

See Also

Reference

OpenFileException Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
OpenFileException Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : OpenFileException Class

Glossary Item Box

The following tables list the members exposed by OpenFileException.

Public Constructors

 | Name | Description
Public Constructor | OpenFileException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

OpenFileException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
OpenFileException Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : OpenFileException Class

Glossary Item Box

For a list of all members of this type, see OpenFileException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

OpenFileException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
OpenFileException Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : OpenFileException Class

Glossary Item Box

For a list of all members of this type, see OpenFileException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

OpenFileException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
OpenFileException Constructor
See Also Send Feedback
Accusoft.PrintProSdk Namespace > OpenFileException Class : OpenFileException Constructor

Glossary Item Box

Overload List

Overload | Description
OpenFileException Constructor() | An exception generated for a open file error.
OpenFileException Constructor(Int32) | Generated exception for a open file error with a given error number.
OpenFileException Constructor(String) | Generated exception for a open file error with a given string.
OpenFileException Constructor(Int32,String) | Generated exception for a open file error with a given error number and message.
OpenFileException Constructor(String,Exception) | Generated exception for a open file error with a given message and inner exception.

See Also

Reference

OpenFileException Class
OpenFileException Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
OpenFileException Constructor()
See Also Send Feedback
Accusoft.PrintProSdk Namespace > OpenFileException Class > OpenFileException Constructor : OpenFileException Constructor()

Glossary Item Box

An exception generated for a open file error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New OpenFileException()
public OpenFileException()
public: OpenFileException();
public:
OpenFileException();

See Also

Reference

OpenFileException Class
OpenFileException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
OpenFileException Constructor(Int32)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > OpenFileException Class > OpenFileException Constructor : OpenFileException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a open file error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New OpenFileException(errorNumber)
public OpenFileException(
   int errorNumber
)
public: OpenFileException(
   int errorNumber
)
public:
OpenFileException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

OpenFileException Class
OpenFileException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
OpenFileException Constructor(String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > OpenFileException Class > OpenFileException Constructor : OpenFileException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a open file error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New OpenFileException(message)
public OpenFileException(
   string message
)
public: OpenFileException(
   string* message
)
public:
OpenFileException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

OpenFileException Class
OpenFileException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
OpenFileException Constructor(Int32,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > OpenFileException Class > OpenFileException Constructor : OpenFileException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a open file error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New OpenFileException(errorNumber, message)
public OpenFileException(
   int errorNumber,
   string message
)
public: OpenFileException(
   int errorNumber,
   string* message
)
public:
OpenFileException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

OpenFileException Class
OpenFileException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
OpenFileException Constructor(String,Exception)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > OpenFileException Class > OpenFileException Constructor : OpenFileException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a open file error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New OpenFileException(message, innerException)
public OpenFileException(
   string message,
   Exception innerException
)
public: OpenFileException(
   string* message,
   Exception* innerException
)
public:
OpenFileException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

OpenFileException Class
OpenFileException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
OutOfMemoryException Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : OutOfMemoryException Class

Glossary Item Box

This exception is thrown if PrintPRO is unable to allocate memory for the requested operation.

Object Model

OutOfMemoryException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class OutOfMemoryException
   Inherits PrintProException
'Usage

Dim instance As OutOfMemoryException
[SerializableAttribute()]
public sealed class OutOfMemoryException : PrintProException
[SerializableAttribute()]
public __gc __sealed class OutOfMemoryException : public PrintProException
[SerializableAttribute()]
public ref class OutOfMemoryException sealed : public PrintProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.PrintProSdk.PrintProException
Accusoft.PrintProSdk.OutOfMemoryException

See Also

Reference

OutOfMemoryException Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
OutOfMemoryException Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : OutOfMemoryException Class

Glossary Item Box

The following tables list the members exposed by OutOfMemoryException.

Public Constructors

 | Name | Description
Public Constructor | OutOfMemoryException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

OutOfMemoryException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
OutOfMemoryException Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : OutOfMemoryException Class

Glossary Item Box

For a list of all members of this type, see OutOfMemoryException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

OutOfMemoryException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
OutOfMemoryException Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : OutOfMemoryException Class

Glossary Item Box

For a list of all members of this type, see OutOfMemoryException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

OutOfMemoryException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
OutOfMemoryException Constructor
See Also Send Feedback
Accusoft.PrintProSdk Namespace > OutOfMemoryException Class : OutOfMemoryException Constructor

Glossary Item Box

Overload List

Overload | Description
OutOfMemoryException Constructor() | An exception generated for a out of memory error.
OutOfMemoryException Constructor(Int32) | Generated exception for a out of memory error with a given error number.
OutOfMemoryException Constructor(String) | Generated exception for a out of memory error with a given string.
OutOfMemoryException Constructor(Int32,String) | Generated exception for a out of memory error with a given error number and message.
OutOfMemoryException Constructor(String,Exception) | Generated exception for a out of memory error with a given message and inner exception.

See Also

Reference

OutOfMemoryException Class
OutOfMemoryException Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
OutOfMemoryException Constructor()
See Also Send Feedback
Accusoft.PrintProSdk Namespace > OutOfMemoryException Class > OutOfMemoryException Constructor : OutOfMemoryException Constructor()

Glossary Item Box

An exception generated for a out of memory error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New OutOfMemoryException()
public OutOfMemoryException()
public: OutOfMemoryException();
public:
OutOfMemoryException();

See Also

Reference

OutOfMemoryException Class
OutOfMemoryException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
OutOfMemoryException Constructor(Int32)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > OutOfMemoryException Class > OutOfMemoryException Constructor : OutOfMemoryException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a out of memory error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New OutOfMemoryException(errorNumber)
public OutOfMemoryException(
   int errorNumber
)
public: OutOfMemoryException(
   int errorNumber
)
public:
OutOfMemoryException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

OutOfMemoryException Class
OutOfMemoryException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
OutOfMemoryException Constructor(String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > OutOfMemoryException Class > OutOfMemoryException Constructor : OutOfMemoryException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a out of memory error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New OutOfMemoryException(message)
public OutOfMemoryException(
   string message
)
public: OutOfMemoryException(
   string* message
)
public:
OutOfMemoryException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

OutOfMemoryException Class
OutOfMemoryException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
OutOfMemoryException Constructor(Int32,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > OutOfMemoryException Class > OutOfMemoryException Constructor : OutOfMemoryException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a out of memory error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New OutOfMemoryException(errorNumber, message)
public OutOfMemoryException(
   int errorNumber,
   string message
)
public: OutOfMemoryException(
   int errorNumber,
   string* message
)
public:
OutOfMemoryException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

OutOfMemoryException Class
OutOfMemoryException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
OutOfMemoryException Constructor(String,Exception)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > OutOfMemoryException Class > OutOfMemoryException Constructor : OutOfMemoryException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a out of memory error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New OutOfMemoryException(message, innerException)
public OutOfMemoryException(
   string message,
   Exception innerException
)
public: OutOfMemoryException(
   string* message,
   Exception* innerException
)
public:
OutOfMemoryException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

OutOfMemoryException Class
OutOfMemoryException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Paper Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : Paper Class

Glossary Item Box

This class implements methods and properties to define types of paper.

Object Model

Paper Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Class Paper
'Usage

Dim instance As Paper
public class Paper
public __gc class Paper
public ref class Paper

Inheritance Hierarchy

System.Object
Accusoft.PrintProSdk.Paper
Accusoft.PrintProSdk.UserPaper

See Also

Reference

Paper Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
Paper Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : Paper Class

Glossary Item Box

The following tables list the members exposed by Paper.

Public Properties

 | Name | Description
Public Property | Id | Gets the ID of the paper.
Public Property | Name | Gets the name of the paper.
Top

Public Methods

 | Name | Description
Public Method | ToString | Creates a string and returns the paper name.
Top

See Also

Reference

Paper Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
Paper Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : Paper Class

Glossary Item Box

For a list of all members of this type, see Paper members.

Public Methods

 | Name | Description
Public Method | ToString | Creates a string and returns the paper name.
Top

See Also

Reference

Paper Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
ToString Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Paper Class : ToString Method

Glossary Item Box

Creates a string and returns the paper name.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As Paper
Dim value As String

value = instance.ToString()
public override string ToString()
public: string* ToString(); override
public:
String^ ToString(); override

Return Value

A string value which represents the paper name.

See Also

Reference

Paper Class
Paper Members


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
Paper Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : Paper Class

Glossary Item Box

For a list of all members of this type, see Paper members.

Public Properties

 | Name | Description
Public Property | Id | Gets the ID of the paper.
Public Property | Name | Gets the name of the paper.
Top

See Also

Reference

Paper Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Id Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Paper Class : Id Property

Glossary Item Box

Gets the ID of the paper.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property Id As Integer
'Usage

Dim instance As Paper
Dim value As Integer

value = instance.Id
public int Id {get;}
public: __property int get_Id();
public:
property int Id {
   int get();
}

Property Value

An integer which represents the ID of the paper.

See Also

Reference

Paper Class
Paper Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Name Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Paper Class : Name Property

Glossary Item Box

Gets the name of the paper.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overridable ReadOnly Property Name As String
'Usage

Dim instance As Paper
Dim value As String

value = instance.Name
public virtual string Name {get;}
public: __property virtual string* get_Name();
public:
virtual property String^ Name {
   String^ get();
}

Property Value

A string value which represents the paper name.

See Also

Reference

Paper Class
Paper Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PaperBin Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : PaperBin Class

Glossary Item Box

A class that implements a paper bin for a printer.

Object Model

PaperBin Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Class PaperBin
'Usage

Dim instance As PaperBin
public class PaperBin
public __gc class PaperBin
public ref class PaperBin

Inheritance Hierarchy

System.Object
Accusoft.PrintProSdk.PaperBin

See Also

Reference

PaperBin Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
PaperBin Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : PaperBin Class

Glossary Item Box

The following tables list the members exposed by PaperBin.

Public Properties

 | Name | Description
Public Property | Id | Gets the ID of the printer bin.
Public Property | Name | Gets the name of the printer bin.
Top

Public Methods

 | Name | Description
Public Method | ToString | Returns a string that reprents the current PaperBin object.
Top

See Also

Reference

PaperBin Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
PaperBin Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : PaperBin Class

Glossary Item Box

For a list of all members of this type, see PaperBin members.

Public Methods

 | Name | Description
Public Method | ToString | Returns a string that reprents the current PaperBin object.
Top

See Also

Reference

PaperBin Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
ToString Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PaperBin Class : ToString Method

Glossary Item Box

Returns a string that reprents the current PaperBin object.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As PaperBin
Dim value As String

value = instance.ToString()
public override string ToString()
public: string* ToString(); override
public:
String^ ToString(); override

See Also

Reference

PaperBin Class
PaperBin Members


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
PaperBin Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : PaperBin Class

Glossary Item Box

For a list of all members of this type, see PaperBin members.

Public Properties

 | Name | Description
Public Property | Id | Gets the ID of the printer bin.
Public Property | Name | Gets the name of the printer bin.
Top

See Also

Reference

PaperBin Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Id Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PaperBin Class : Id Property

Glossary Item Box

Gets the ID of the printer bin.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property Id As Integer
'Usage

Dim instance As PaperBin
Dim value As Integer

value = instance.Id
public int Id {get;}
public: __property int get_Id();
public:
property int Id {
   int get();
}

Property Value

An integer value which represents the ID of the printer bin.

See Also

Reference

PaperBin Class
PaperBin Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Name Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PaperBin Class : Name Property

Glossary Item Box

Gets the name of the printer bin.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property Name As String
'Usage

Dim instance As PaperBin
Dim value As String

value = instance.Name
public string Name {get;}
public: __property string* get_Name();
public:
property String^ Name {
   String^ get();
}

Property Value

A string value which represents the name of the printer bin.

Remarks

The default value is an empty string "".

See Also

Reference

PaperBin Class
PaperBin Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PaperBinCollection Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : PaperBinCollection Class

Glossary Item Box

This class implements a collection of paper bin objects.

Object Model

PaperBinCollection ClassPaperBin Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DefaultMemberAttribute("Item")>
Public Class PaperBinCollection
   Inherits System.Collections.ReadOnlyCollectionBase
'Usage

Dim instance As PaperBinCollection
[DefaultMemberAttribute("Item")]
public class PaperBinCollection : System.Collections.ReadOnlyCollectionBase
[DefaultMemberAttribute("Item")]
public __gc class PaperBinCollection : public System.Collections.ReadOnlyCollectionBase
[DefaultMemberAttribute("Item")]
public ref class PaperBinCollection : public System.Collections.ReadOnlyCollectionBase

Inheritance Hierarchy

System.Object
System.Collections.ReadOnlyCollectionBase
Accusoft.PrintProSdk.PaperBinCollection

See Also

Reference

PaperBinCollection Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
PaperBinCollection Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : PaperBinCollection Class

Glossary Item Box

The following tables list the members exposed by PaperBinCollection.

Public Properties

 | Name | Description
Public Property | Count | Overridden. Gets the number of paper bins in the collection.
Public Property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe).
Public Property | Item | Overloaded. Gets the PaperBin object at specified index within the collection.
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the collection.
Top

Public Methods

 | Name | Description
Public Method | Contains | Used to determine if the specified PaperBin object exists in the collection.
Public Method | CopyTo | Copies the elements of the collection to an array of paper bin type.
Public Method | GetEnumerator | Overridden. Returns an enumerator that can be used to iterate through all of the PaperBin objects in the collection.
Top

See Also

Reference

PaperBinCollection Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
PaperBinCollection Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : PaperBinCollection Class

Glossary Item Box

For a list of all members of this type, see PaperBinCollection members.

Public Methods

 | Name | Description
Public Method | Contains | Used to determine if the specified PaperBin object exists in the collection.
Public Method | CopyTo | Copies the elements of the collection to an array of paper bin type.
Public Method | GetEnumerator | Overridden. Returns an enumerator that can be used to iterate through all of the PaperBin objects in the collection.
Top

See Also

Reference

PaperBinCollection Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Contains Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PaperBinCollection Class : Contains Method

pb
The PaperBin to look for in the collection.

Glossary Item Box

Used to determine if the specified PaperBin object exists in the collection.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function Contains( _
   ByVal pb As PaperBin _
) As Boolean
'Usage

Dim instance As PaperBinCollection
Dim pb As PaperBin
Dim value As Boolean

value = instance.Contains(pb)
public bool Contains(
   PaperBin pb
)
public: bool Contains(
   PaperBin* pb
)
public:
bool Contains(
   PaperBin^ pb
)

Parameters

pb
The PaperBin to look for in the collection.

Return Value

A boolean value which is true if the given PaperBin is found within the collection. Otherwise, false is returned.

See Also

Reference

PaperBinCollection Class
PaperBinCollection Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CopyTo Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PaperBinCollection Class : CopyTo Method

array
The array to copy the elements to.
index
An integer which represents the index location to start copying at.

Glossary Item Box

Copies the elements of the collection to an array of paper bin type.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub CopyTo( _
   ByVal array() As PaperBin, _
   ByVal index As Integer _
)
'Usage

Dim instance As PaperBinCollection
Dim array() As PaperBin
Dim index As Integer

instance.CopyTo(array, index)
public void CopyTo(
   PaperBin[] array,
   int index
)
public: void CopyTo(
   PaperBin*[]* array,
   int index
)
public:
void CopyTo(
   array<PaperBin^>^ array,
   int index
)

Parameters

array
The array to copy the elements to.
index
An integer which represents the index location to start copying at.

See Also

Reference

PaperBinCollection Class
PaperBinCollection Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
GetEnumerator Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PaperBinCollection Class : GetEnumerator Method

Glossary Item Box

Returns an enumerator that can be used to iterate through all of the PaperBin objects in the collection.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overrides Function GetEnumerator() As IEnumerator
'Usage

Dim instance As PaperBinCollection
Dim value As IEnumerator

value = instance.GetEnumerator()
public override IEnumerator GetEnumerator()
public: IEnumerator* GetEnumerator(); override
public:
IEnumerator^ GetEnumerator(); override

Return Value

An enumerator object of type paper bin.

See Also

Reference

PaperBinCollection Class
PaperBinCollection Members


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
PaperBinCollection Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : PaperBinCollection Class

Glossary Item Box

For a list of all members of this type, see PaperBinCollection members.

Public Properties

 | Name | Description
Public Property | Count | Overridden. Gets the number of paper bins in the collection.
Public Property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe).
Public Property | Item | Overloaded. Gets the PaperBin object at specified index within the collection.
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the collection.
Top

See Also

Reference

PaperBinCollection Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Count Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PaperBinCollection Class : Count Property

Glossary Item Box

Gets the number of paper bins in the collection.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overrides ReadOnly Property Count As Integer
'Usage

Dim instance As PaperBinCollection
Dim value As Integer

value = instance.Count
public override int Count {get;}
public: __property int get_Count() override;
public:
property int Count {
   int get() override;
}

Property Value

An integer which represents the number of PaperBin objects in the collection.

See Also

Reference

PaperBinCollection Class
PaperBinCollection Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
IsSynchronized Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PaperBinCollection Class : IsSynchronized Property

Glossary Item Box

Gets a value indicating whether access to the collection is synchronized (thread safe).

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property IsSynchronized As Boolean
'Usage

Dim instance As PaperBinCollection
Dim value As Boolean

value = instance.IsSynchronized
public bool IsSynchronized {get;}
public: __property bool get_IsSynchronized();
public:
property bool IsSynchronized {
   bool get();
}

Property Value

A boolean value which is false when the collection is not synchronized.

See Also

Reference

PaperBinCollection Class
PaperBinCollection Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Item Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PaperBinCollection Class : Item Property

Glossary Item Box

Gets the PaperBin object at specified index within the collection.

Overload List

Overload | Description
Item(Int32) | Gets the PaperBin object at specified index within the collection.
Item(String) | Gets the PaperBin object with the specified name within the collection.

See Also

Reference

PaperBinCollection Class
PaperBinCollection Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Item(Int32) Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PaperBinCollection Class > Item Property : Item(Int32) Property

index
An integer which represents the index of the paper bin to retrieve.

Glossary Item Box

Gets the PaperBin object at specified index within the collection.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads ReadOnly Property Item( _
   ByVal index As Integer _
) As PaperBin
'Usage

Dim instance As PaperBinCollection
Dim index As Integer
Dim value As PaperBin

value = instance.Item(index)
public PaperBin Item(
   int index
) {get;}
public: __property PaperBin* get_Item(
   int index
);
public:
property PaperBin^ Item {
   PaperBin^ get(int index);
}

Parameters

index
An integer which represents the index of the paper bin to retrieve.

Property Value

The PaperBin object which matches the specified index within the collection.

See Also

Reference

PaperBinCollection Class
PaperBinCollection Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Item(String) Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PaperBinCollection Class > Item Property : Item(String) Property

index
An integer which represents the name of the paper bin to retrieve.

Glossary Item Box

Gets the PaperBin object with the specified name within the collection.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads ReadOnly Property Item( _
   ByVal index As String _
) As PaperBin
'Usage

Dim instance As PaperBinCollection
Dim index As String
Dim value As PaperBin

value = instance.Item(index)
public PaperBin Item(
   string index
) {get;}
public: __property PaperBin* get_Item(
   string* index
);
public:
property PaperBin^ Item {
   PaperBin^ get(String^ index);
}

Parameters

index
An integer which represents the name of the paper bin to retrieve.

Property Value

The PaperBin object with specified name within the collection.

See Also

Reference

PaperBinCollection Class
PaperBinCollection Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
SyncRoot Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PaperBinCollection Class : SyncRoot Property

Glossary Item Box

Gets an object that can be used to synchronize access to the collection.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property SyncRoot As Object
'Usage

Dim instance As PaperBinCollection
Dim value As Object

value = instance.SyncRoot
public object SyncRoot {get;}
public: __property Object* get_SyncRoot();
public:
property Object^ SyncRoot {
   Object^ get();
}

Property Value

An object which contains information to synchronize access to the collection.

See Also

Reference

PaperBinCollection Class
PaperBinCollection Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PaperBinEnumerator Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : PaperBinEnumerator Class

Glossary Item Box

This class implements a paper bin enumerator.

Object Model

PaperBinEnumerator ClassPaperBin Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Class PaperBinEnumerator
'Usage

Dim instance As PaperBinEnumerator
public class PaperBinEnumerator
public __gc class PaperBinEnumerator
public ref class PaperBinEnumerator

Inheritance Hierarchy

System.Object
Accusoft.PrintProSdk.PaperBinEnumerator

See Also

Reference

PaperBinEnumerator Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
PaperBinEnumerator Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : PaperBinEnumerator Class

Glossary Item Box

The following tables list the members exposed by PaperBinEnumerator.

Public Properties

 | Name | Description
Public Property | Current | Gets the current paper bin the enumerator is on within the collection.
Top

Public Methods

 | Name | Description
Public Method | Dispose | Disposes the paper bin enumerator.
Public Method | MoveNext | Moves the enumerator to the next paper bin within the collection.
Public Method | Reset | Resets the enumerator to right before the first element within the collection.
Top

See Also

Reference

PaperBinEnumerator Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
PaperBinEnumerator Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : PaperBinEnumerator Class

Glossary Item Box

For a list of all members of this type, see PaperBinEnumerator members.

Public Methods

 | Name | Description
Public Method | Dispose | Disposes the paper bin enumerator.
Public Method | MoveNext | Moves the enumerator to the next paper bin within the collection.
Public Method | Reset | Resets the enumerator to right before the first element within the collection.
Top

See Also

Reference

PaperBinEnumerator Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Dispose() Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PaperBinEnumerator Class : Dispose() Method

Glossary Item Box

Disposes the paper bin enumerator.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub Dispose()
'Usage

Dim instance As PaperBinEnumerator

instance.Dispose()
public void Dispose()
public: void Dispose();
public:
void Dispose();

See Also

Reference

PaperBinEnumerator Class
PaperBinEnumerator Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
MoveNext Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PaperBinEnumerator Class : MoveNext Method

Glossary Item Box

Moves the enumerator to the next paper bin within the collection.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function MoveNext() As Boolean
'Usage

Dim instance As PaperBinEnumerator
Dim value As Boolean

value = instance.MoveNext()
public bool MoveNext()
public: bool MoveNext();
public:
bool MoveNext();

Return Value

A boolean value which is true if the move was successful, false otherwise.

See Also

Reference

PaperBinEnumerator Class
PaperBinEnumerator Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Reset Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PaperBinEnumerator Class : Reset Method

Glossary Item Box

Resets the enumerator to right before the first element within the collection.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub Reset()
'Usage

Dim instance As PaperBinEnumerator

instance.Reset()
public void Reset()
public: void Reset();
public:
void Reset();

See Also

Reference

PaperBinEnumerator Class
PaperBinEnumerator Members


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
PaperBinEnumerator Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : PaperBinEnumerator Class

Glossary Item Box

For a list of all members of this type, see PaperBinEnumerator members.

Public Properties

 | Name | Description
Public Property | Current | Gets the current paper bin the enumerator is on within the collection.
Top

See Also

Reference

PaperBinEnumerator Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Dispose Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PaperBinEnumerator Class : Dispose Method

Glossary Item Box

Disposes the paper bin enumerator.

Overload List

Overload | Description
Dispose | Disposes the paper bin enumerator.

See Also

Reference

PaperBinEnumerator Class
PaperBinEnumerator Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Current Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PaperBinEnumerator Class : Current Property

Glossary Item Box

Gets the current paper bin the enumerator is on within the collection.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property Current As PaperBin
'Usage

Dim instance As PaperBinEnumerator
Dim value As PaperBin

value = instance.Current
public PaperBin Current {get;}
public: __property PaperBin* get_Current();
public:
property PaperBin^ Current {
   PaperBin^ get();
}

Property Value

The current PaperBin object the enumerator is on within the collection.

See Also

Reference

PaperBinEnumerator Class
PaperBinEnumerator Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PaperCollection Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : PaperCollection Class

Glossary Item Box

This class implements methods and properties for PaperBin objects.

Object Model

PaperCollection ClassPaper Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DefaultMemberAttribute("Item")>
Public Class PaperCollection
   Inherits System.Collections.ReadOnlyCollectionBase
'Usage

Dim instance As PaperCollection
[DefaultMemberAttribute("Item")]
public class PaperCollection : System.Collections.ReadOnlyCollectionBase
[DefaultMemberAttribute("Item")]
public __gc class PaperCollection : public System.Collections.ReadOnlyCollectionBase
[DefaultMemberAttribute("Item")]
public ref class PaperCollection : public System.Collections.ReadOnlyCollectionBase

Inheritance Hierarchy

System.Object
System.Collections.ReadOnlyCollectionBase
Accusoft.PrintProSdk.PaperCollection

See Also

Reference

PaperCollection Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
PaperCollection Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : PaperCollection Class

Glossary Item Box

The following tables list the members exposed by PaperCollection.

Public Properties

 | Name | Description
Public Property | Count | Overridden. Gets the number of paper objects in the papers collection.
Public Property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe).
Public Property | Item | Overloaded. Gets the given Paper object at the specified index within the collection.
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the collection.
Top

Public Methods

 | Name | Description
Public Method | Contains | Determines if the specified paper type exists in the collection.
Public Method | CopyTo | Copies the collection of Paper objects to an array of papers.
Public Method | GetEnumerator | Overridden. Returns an enumerator that can be used to iterate through all of the Paper objects in the collection.
Top

See Also

Reference

PaperCollection Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
PaperCollection Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : PaperCollection Class

Glossary Item Box

For a list of all members of this type, see PaperCollection members.

Public Methods

 | Name | Description
Public Method | Contains | Determines if the specified paper type exists in the collection.
Public Method | CopyTo | Copies the collection of Paper objects to an array of papers.
Public Method | GetEnumerator | Overridden. Returns an enumerator that can be used to iterate through all of the Paper objects in the collection.
Top

See Also

Reference

PaperCollection Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Contains Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PaperCollection Class : Contains Method

p
The Paper object to search for in the collection.

Glossary Item Box

Determines if the specified paper type exists in the collection.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function Contains( _
   ByVal p As Paper _
) As Boolean
'Usage

Dim instance As PaperCollection
Dim p As Paper
Dim value As Boolean

value = instance.Contains(p)
public bool Contains(
   Paper p
)
public: bool Contains(
   Paper* p
)
public:
bool Contains(
   Paper^ p
)

Parameters

p
The Paper object to search for in the collection.

Return Value

A boolean value which indicates if the given Paper object is contained within the collection.

See Also

Reference

PaperCollection Class
PaperCollection Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CopyTo Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PaperCollection Class : CopyTo Method

array
An array to copy the paper object to.
index
An integer value which represents the initial index to start copying at.

Glossary Item Box

Copies the collection of Paper objects to an array of papers.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub CopyTo( _
   ByVal array() As Paper, _
   ByVal index As Integer _
)
'Usage

Dim instance As PaperCollection
Dim array() As Paper
Dim index As Integer

instance.CopyTo(array, index)
public void CopyTo(
   Paper[] array,
   int index
)
public: void CopyTo(
   Paper*[]* array,
   int index
)
public:
void CopyTo(
   array<Paper^>^ array,
   int index
)

Parameters

array
An array to copy the paper object to.
index
An integer value which represents the initial index to start copying at.

See Also

Reference

PaperCollection Class
PaperCollection Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
GetEnumerator Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PaperCollection Class : GetEnumerator Method

Glossary Item Box

Returns an enumerator that can be used to iterate through all of the Paper objects in the collection.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overrides Function GetEnumerator() As IEnumerator
'Usage

Dim instance As PaperCollection
Dim value As IEnumerator

value = instance.GetEnumerator()
public override IEnumerator GetEnumerator()
public: IEnumerator* GetEnumerator(); override
public:
IEnumerator^ GetEnumerator(); override

Return Value

An enumerator that can be used to iterate through all of the Paper objects in the collection.

See Also

Reference

PaperCollection Class
PaperCollection Members


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
PaperCollection Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : PaperCollection Class

Glossary Item Box

For a list of all members of this type, see PaperCollection members.

Public Properties

 | Name | Description
Public Property | Count | Overridden. Gets the number of paper objects in the papers collection.
Public Property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe).
Public Property | Item | Overloaded. Gets the given Paper object at the specified index within the collection.
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the collection.
Top

See Also

Reference

PaperCollection Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Count Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PaperCollection Class : Count Property

Glossary Item Box

Gets the number of paper objects in the papers collection.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overrides ReadOnly Property Count As Integer
'Usage

Dim instance As PaperCollection
Dim value As Integer

value = instance.Count
public override int Count {get;}
public: __property int get_Count() override;
public:
property int Count {
   int get() override;
}

Property Value

An integer value which represents the number of Paper objects in the papers collection.

See Also

Reference

PaperCollection Class
PaperCollection Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
IsSynchronized Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PaperCollection Class : IsSynchronized Property

Glossary Item Box

Gets a value indicating whether access to the collection is synchronized (thread safe).

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property IsSynchronized As Boolean
'Usage

Dim instance As PaperCollection
Dim value As Boolean

value = instance.IsSynchronized
public bool IsSynchronized {get;}
public: __property bool get_IsSynchronized();
public:
property bool IsSynchronized {
   bool get();
}

Property Value

A boolean value which is true when the collection is synchronized. Otherwise, false is used.

See Also

Reference

PaperCollection Class
PaperCollection Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Item Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PaperCollection Class : Item Property

Glossary Item Box

Gets the given Paper object at the specified index within the collection.

Overload List

Overload | Description
Item(Int32) | Gets the given Paper object at the specified index within the collection.
Item(String) | Gets the Paper object with specified name within the collection.

See Also

Reference

PaperCollection Class
PaperCollection Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Item(Int32) Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PaperCollection Class > Item Property : Item(Int32) Property

index
An integer value which represents the index of the Paper object to get within the collection.

Glossary Item Box

Gets the given Paper object at the specified index within the collection.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads ReadOnly Property Item( _
   ByVal index As Integer _
) As Paper
'Usage

Dim instance As PaperCollection
Dim index As Integer
Dim value As Paper

value = instance.Item(index)
public Paper Item(
   int index
) {get;}
public: __property Paper* get_Item(
   int index
);
public:
property Paper^ Item {
   Paper^ get(int index);
}

Parameters

index
An integer value which represents the index of the Paper object to get within the collection.

Property Value

The Paper object that matches the given specified index.

See Also

Reference

PaperCollection Class
PaperCollection Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Item(String) Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PaperCollection Class > Item Property : Item(String) Property

index
A string value which represents the name of the paper to retrieve from within the colleciton.

Glossary Item Box

Gets the Paper object with specified name within the collection.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads ReadOnly Property Item( _
   ByVal index As String _
) As Paper
'Usage

Dim instance As PaperCollection
Dim index As String
Dim value As Paper

value = instance.Item(index)
public Paper Item(
   string index
) {get;}
public: __property Paper* get_Item(
   string* index
);
public:
property Paper^ Item {
   Paper^ get(String^ index);
}

Parameters

index
A string value which represents the name of the paper to retrieve from within the colleciton.

Property Value

The Paper object which matches the specified name.

See Also

Reference

PaperCollection Class
PaperCollection Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
SyncRoot Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PaperCollection Class : SyncRoot Property

Glossary Item Box

Gets an object that can be used to synchronize access to the collection.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property SyncRoot As Object
'Usage

Dim instance As PaperCollection
Dim value As Object

value = instance.SyncRoot
public object SyncRoot {get;}
public: __property Object* get_SyncRoot();
public:
property Object^ SyncRoot {
   Object^ get();
}

Property Value

An object which contains information to synchronize access to the collection.

See Also

Reference

PaperCollection Class
PaperCollection Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PaperEnumerator Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : PaperEnumerator Class

Glossary Item Box

This class implements enumerating through paper collections.

Object Model

PaperEnumerator ClassPaper Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Class PaperEnumerator
'Usage

Dim instance As PaperEnumerator
public class PaperEnumerator
public __gc class PaperEnumerator
public ref class PaperEnumerator

Inheritance Hierarchy

System.Object
Accusoft.PrintProSdk.PaperEnumerator

See Also

Reference

PaperEnumerator Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
PaperEnumerator Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : PaperEnumerator Class

Glossary Item Box

The following tables list the members exposed by PaperEnumerator.

Public Properties

 | Name | Description
Public Property | Current | Gets the current Paper object.
Top

Public Methods

 | Name | Description
Public Method | Dispose | Destroys the enumerator object.
Public Method | MoveNext | Moves the enumerator to the next Paper object in the collection.
Public Method | Reset | Resets the paper enumerator to the first paper in the collection.
Top

See Also

Reference

PaperEnumerator Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
PaperEnumerator Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : PaperEnumerator Class

Glossary Item Box

For a list of all members of this type, see PaperEnumerator members.

Public Methods

 | Name | Description
Public Method | Dispose | Destroys the enumerator object.
Public Method | MoveNext | Moves the enumerator to the next Paper object in the collection.
Public Method | Reset | Resets the paper enumerator to the first paper in the collection.
Top

See Also

Reference

PaperEnumerator Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Dispose() Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PaperEnumerator Class : Dispose() Method

Glossary Item Box

Destroys the enumerator object.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub Dispose()
'Usage

Dim instance As PaperEnumerator

instance.Dispose()
public void Dispose()
public: void Dispose();
public:
void Dispose();

See Also

Reference

PaperEnumerator Class
PaperEnumerator Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
MoveNext Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PaperEnumerator Class : MoveNext Method

Glossary Item Box

Moves the enumerator to the next Paper object in the collection.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function MoveNext() As Boolean
'Usage

Dim instance As PaperEnumerator
Dim value As Boolean

value = instance.MoveNext()
public bool MoveNext()
public: bool MoveNext();
public:
bool MoveNext();

Return Value

A boolean value which indicates if it was successful in moving and a paper existed there, false otherwise.

See Also

Reference

PaperEnumerator Class
PaperEnumerator Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Reset Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PaperEnumerator Class : Reset Method

Glossary Item Box

Resets the paper enumerator to the first paper in the collection.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub Reset()
'Usage

Dim instance As PaperEnumerator

instance.Reset()
public void Reset()
public: void Reset();
public:
void Reset();

See Also

Reference

PaperEnumerator Class
PaperEnumerator Members


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
PaperEnumerator Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : PaperEnumerator Class

Glossary Item Box

For a list of all members of this type, see PaperEnumerator members.

Public Properties

 | Name | Description
Public Property | Current | Gets the current Paper object.
Top

See Also

Reference

PaperEnumerator Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Dispose Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PaperEnumerator Class : Dispose Method

Glossary Item Box

Destroys the enumerator object.

Overload List

Overload | Description
Dispose | Destroys the enumerator object.

See Also

Reference

PaperEnumerator Class
PaperEnumerator Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Current Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PaperEnumerator Class : Current Property

Glossary Item Box

Gets the current Paper object.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property Current As Paper
'Usage

Dim instance As PaperEnumerator
Dim value As Paper

value = instance.Current
public Paper Current {get;}
public: __property Paper* get_Current();
public:
property Paper^ Current {
   Paper^ get();
}

Property Value

A Paper object.

See Also

Reference

PaperEnumerator Class
PaperEnumerator Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintDialogFailedException Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : PrintDialogFailedException Class

Glossary Item Box

This exception is thrown if the print dialog failed.

Object Model

PrintDialogFailedException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class PrintDialogFailedException
   Inherits PrintProException
'Usage

Dim instance As PrintDialogFailedException
[SerializableAttribute()]
public sealed class PrintDialogFailedException : PrintProException
[SerializableAttribute()]
public __gc __sealed class PrintDialogFailedException : public PrintProException
[SerializableAttribute()]
public ref class PrintDialogFailedException sealed : public PrintProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.PrintProSdk.PrintProException
Accusoft.PrintProSdk.PrintDialogFailedException

See Also

Reference

PrintDialogFailedException Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
PrintDialogFailedException Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : PrintDialogFailedException Class

Glossary Item Box

The following tables list the members exposed by PrintDialogFailedException.

Public Constructors

 | Name | Description
Public Constructor | PrintDialogFailedException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

PrintDialogFailedException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
PrintDialogFailedException Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : PrintDialogFailedException Class

Glossary Item Box

For a list of all members of this type, see PrintDialogFailedException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

PrintDialogFailedException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
PrintDialogFailedException Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : PrintDialogFailedException Class

Glossary Item Box

For a list of all members of this type, see PrintDialogFailedException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

PrintDialogFailedException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintDialogFailedException Constructor
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintDialogFailedException Class : PrintDialogFailedException Constructor

Glossary Item Box

Overload List

Overload | Description
PrintDialogFailedException Constructor() | An exception generated for a print dialog failed error.
PrintDialogFailedException Constructor(Int32) | Generated exception for a print dialog failed error with a given error number.
PrintDialogFailedException Constructor(String) | Generated exception for a print dialog failed error with a given string.
PrintDialogFailedException Constructor(Int32,String) | Generated exception for a print dialog failed error with a given error number and message.
PrintDialogFailedException Constructor(String,Exception) | Generated exception for a print dialog failed error with a given message and inner exception.

See Also

Reference

PrintDialogFailedException Class
PrintDialogFailedException Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintDialogFailedException Constructor()
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintDialogFailedException Class > PrintDialogFailedException Constructor : PrintDialogFailedException Constructor()

Glossary Item Box

An exception generated for a print dialog failed error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PrintDialogFailedException()
public PrintDialogFailedException()
public: PrintDialogFailedException();
public:
PrintDialogFailedException();

See Also

Reference

PrintDialogFailedException Class
PrintDialogFailedException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintDialogFailedException Constructor(Int32)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintDialogFailedException Class > PrintDialogFailedException Constructor : PrintDialogFailedException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a print dialog failed error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New PrintDialogFailedException(errorNumber)
public PrintDialogFailedException(
   int errorNumber
)
public: PrintDialogFailedException(
   int errorNumber
)
public:
PrintDialogFailedException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

PrintDialogFailedException Class
PrintDialogFailedException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintDialogFailedException Constructor(String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintDialogFailedException Class > PrintDialogFailedException Constructor : PrintDialogFailedException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a print dialog failed error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New PrintDialogFailedException(message)
public PrintDialogFailedException(
   string message
)
public: PrintDialogFailedException(
   string* message
)
public:
PrintDialogFailedException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

PrintDialogFailedException Class
PrintDialogFailedException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintDialogFailedException Constructor(Int32,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintDialogFailedException Class > PrintDialogFailedException Constructor : PrintDialogFailedException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a print dialog failed error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New PrintDialogFailedException(errorNumber, message)
public PrintDialogFailedException(
   int errorNumber,
   string message
)
public: PrintDialogFailedException(
   int errorNumber,
   string* message
)
public:
PrintDialogFailedException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

PrintDialogFailedException Class
PrintDialogFailedException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintDialogFailedException Constructor(String,Exception)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintDialogFailedException Class > PrintDialogFailedException Constructor : PrintDialogFailedException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a print dialog failed error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New PrintDialogFailedException(message, innerException)
public PrintDialogFailedException(
   string message,
   Exception innerException
)
public: PrintDialogFailedException(
   string* message,
   Exception* innerException
)
public:
PrintDialogFailedException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

PrintDialogFailedException Class
PrintDialogFailedException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Printer Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : Printer Class

Glossary Item Box

This class implements available printers for printing.

Object Model

Printer ClassPrinter ClassPrinter ClassPrinter ClassPaper ClassPaperBin ClassPaperBinCollection ClassPaperBin ClassPaperCollection ClassPaper ClassPrintQuality ClassPrintingUnit StructurePrinter ClassPaper ClassPaperBin ClassPaperBinCollection ClassPaperBin ClassPaperCollection ClassPaper ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintingUnit StructurePrinter ClassPrinter ClassPaper ClassPaperBin ClassPaperBinCollection ClassPaperBin ClassPaperCollection ClassPaper ClassPrintQuality ClassPrintingUnit StructurePrinter ClassPaper ClassPaperBin ClassPaperBinCollection ClassPaperBin ClassPaperCollection ClassPaper ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintingUnit StructurePrinter ClassPrinter ClassPrinter ClassPaper ClassPaperBin ClassPaperBinCollection ClassPaperBin ClassPaperCollection ClassPaper ClassPrintQuality ClassPrintingUnit StructurePrinter ClassPaper ClassPaperBin ClassPaperBinCollection ClassPaperBin ClassPaperCollection ClassPaper ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintingUnit StructurePrinter ClassPrinter ClassPaper ClassPaperBin ClassPaperBinCollection ClassPaperBin ClassPaperCollection ClassPaper ClassPrintQuality ClassPrintingUnit StructurePrinter Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Class Printer
'Usage

Dim instance As Printer
public class Printer
public __gc class Printer
public ref class Printer

Inheritance Hierarchy

System.Object
Accusoft.PrintProSdk.Printer

See Also

Reference

Printer Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
Printer Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : Printer Class

Glossary Item Box

The following tables list the members exposed by Printer.

Public Properties

 | Name | Description
Public Property | AutoMargin | Gets and sets an indicator which determines whether the margin values and the current print position values should automatically be set to values inside the printer's display area.
Public Property | Collate | Gets and sets an indicator which specifies whether collation should be used when printing multiple copies (if the printer supports this feature).
Public Property | ColorMode | Gets and sets an indicator which determines whether a color printer prints output in color or monochrome.
Public Property | Copies | Gets and sets the number of copies to be printed.
Public Property | Dither | Gets and sets a value that specifies how dithering is to be done (if the printer supports this feature).
Public Property | DriverName | Gets the printer driver name.
Public Property | Duplex | Gets and sets the PrintDuplex option for how a page is printed on both sides (if the printer supports this feature).
Public Property | DuplexAvailable | Gets an indicator of the level of duplex support.
Public Property | FileName | Gets the filename that the print is saved to.
Public Property | IsFilePrinter | Gets an indicator which determines if this printer object is actually a file printer.
Public Property | MaxCopies | Gets the number of copies that the printer can print.
Public Property | MaxDpi | Gets the maximum resolution available.
Public Property | MediaType | Gets and sets the type of media being printed on (if the printer supports this feature).
Public Property | Name | Gets the printer's name.
Public Property | Orientation | Gets and sets whether documents are printed in portrait or landscape mode (if the printer supports this feature).
Public Property | Paper | Gets and sets the type of paper being used for printing (if the printer supports this feature).
Public Property | PaperBin | Gets and sets the paper bin that is to be used to feed the printer paper.
Public Property | PaperBins | Gets a collection of paper bins that can be used to feed the printer paper.
Public Property | PaperHeight | Gets the physical height of the paper set up for the printing device, in units determined by the PrintUnits property.
Public Property | Papers | Gets a collection of papers that represent the different types of papers available to the user (if the printer supports this feature).
Public Property | PaperWidth | Gets the physical width of the paper set up for the printing device, in units determined by the PrintUnits property.
Public Property | PortName | Gets the name of the port through which a document is sent to a printer.
Public Property | PrintHeight | Gets the printable area height of the paper set up for the printing device, in units determined by the PrintUnits property.
Public Property | PrintQuality | Gets and sets a value indicating the printer resolution (if the printer supports this feature).
Public Property | PrintResolution | Gets the print resolution in dots per inch - horizontal and vertical.
Public Property | PrintUnits | Gets and sets the units that are used to describe measurements for printing.
Public Property | PrintWidth | Gets the printable area width of the paper set up for the printing device, in units determined by the PrintUnits property.
Public Property | RangeFrom | Gets and sets the value that was selected for the beginning of the print range via the print dialog.
Public Property | RangeSelection | Gets the value of the print range radio button from the print dialog.
Public Property | RangeTo | Gets and sets the value that was selected for the end of the print range via the print dialog.
Public Property | RequestedDpi | Gets and sets the current DPI resolution.
Public Property | SaveFileType | Gets the file type that the print is saved as.
Public Property | SupportedDpis | The resolutions supported by the printer in dots per inch.
Public Property | TrueType | Gets and sets a value indicating the printer’s TrueTypeOption enumeration option.
Public Property | TwipsPerPixelX | Gets the number of twips per pixel for a printer measured horizontally.
Public Property | TwipsPerPixelY | Gets the number of twips per pixel for a printer measured vertically.
Public Property | UserDither | Gets and sets a value which specifies how dithering is to be done (if the printer supports this feature).
Public Property | UserMediaType | Gets and sets the type of media being printed on (if the printer supports this feature).
Public Property | UserPaper | Gets and sets the type of paper being used for printing (if the printer supports this feature).
Public Property | Zoom | Gets or sets the percentage by which printed output is to be scaled up or down (if the printer supports this feature).
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CreateFilePrinter | Creates a new printer object that prints to the specified file as the specified file type.
Public Method | Dispose | Dispose method for Printer object.
static (Shared in Visual Basic) | SelectPrinter | Overloaded. Selects and returns the default printer.
Public Method | SetAsDefault | Sets the printer as the default printer.
Public Method | SetupDialog | Displays a printer setup dialog box that lets you change printer properties.
Public Method | ToFilePrinter | Takes the current printer object and converts it to print to a file.
Top

See Also

Reference

Printer Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
Printer Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : Printer Class

Glossary Item Box

For a list of all members of this type, see Printer members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CreateFilePrinter | Creates a new printer object that prints to the specified file as the specified file type.
Public Method | Dispose | Dispose method for Printer object.
static (Shared in Visual Basic) | SelectPrinter | Overloaded. Selects and returns the default printer.
Public Method | SetAsDefault | Sets the printer as the default printer.
Public Method | SetupDialog | Displays a printer setup dialog box that lets you change printer properties.
Public Method | ToFilePrinter | Takes the current printer object and converts it to print to a file.
Top

See Also

Reference

Printer Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CreateFilePrinter Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Printer Class : CreateFilePrinter Method

printProWorkspace
The PrintPro workspace instance to be used.
fileName
A string which represents the filename to save to.
saveFileType
A SaveFileType enumeration option to save to.

Glossary Item Box

Creates a new printer object that prints to the specified file as the specified file type.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Shared Function CreateFilePrinter( _
   ByVal printProWorkspace As PrintPro, _
   ByVal fileName As String, _
   ByVal saveFileType As SaveFileType _
) As Printer
'Usage

Dim printProWorkspace As PrintPro
Dim fileName As String
Dim saveFileType As SaveFileType
Dim value As Printer

value = Printer.CreateFilePrinter(printProWorkspace, fileName, saveFileType)
public static Printer CreateFilePrinter(
   PrintPro printProWorkspace,
   string fileName,
   SaveFileType saveFileType
)
public: static Printer* CreateFilePrinter(
   PrintPro* printProWorkspace,
   string* fileName,
   SaveFileType saveFileType
)
public:
static Printer^ CreateFilePrinter(
   PrintPro^ printProWorkspace,
   String^ fileName,
   SaveFileType saveFileType
)

Parameters

printProWorkspace
The PrintPro workspace instance to be used.
fileName
A string which represents the filename to save to.
saveFileType
A SaveFileType enumeration option to save to.

Return Value

A new Printer object which prints to the specified file.

See Also

Reference

Printer Class
Printer Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Dispose Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Printer Class : Dispose Method

Glossary Item Box

Dispose(bool) method for Printer object.

Overload List

Overload | Description
Dispose | Dispose method for Printer object.

See Also

Reference

Printer Class
Printer Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Dispose() Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Printer Class : Dispose() Method

Glossary Item Box

Dispose method for Printer object.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub Dispose()
'Usage

Dim instance As Printer

instance.Dispose()
public void Dispose()
public: void Dispose();
public:
void Dispose();

See Also

Reference

Printer Class
Printer Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
SelectPrinter Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Printer Class : SelectPrinter Method

Glossary Item Box

Selects and returns the default printer.

Overload List

Overload | Description
SelectPrinter(PrintPro) | Selects and returns the default printer.
SelectPrinter(PrintPro,Boolean) | Selects a printer from the PrintPro workspace using the windows select printer dialog if ShowDialog is true, otherwise it selects the default printer.
SelectPrinter(PrintPro,PrintRangeAvailable) | Selects a printer from the PrintPro workspace using the windows select printer dialog
SelectPrinter(PrintPro,PrintRangeAvailable,PrintRangeSelection) | Selects a printer from the PrintPro workspace using the windows select printer dialog
SelectPrinter(PrintPro,String) | Selects a printer from the PrintPro workspace by name.
SelectPrinter(PrintPro,Boolean,Int32,Int32) | Selects a printer from the PrintPro workspace using the windows select printer dialog and setting the minimum and maximum page range the user is allowed to choose from if ShowDialog is true.
SelectPrinter(PrintPro,Int32,Int32,PrintRangeAvailable) | Selects a printer from the PrintPro workspace using the windows select printer dialog and setting the minimum and maximum page range the user is allowed to choose from if ShowDialog is true.
SelectPrinter(PrintPro,Int32,Int32,PrintRangeAvailable,PrintRangeSelection) | Selects a printer from the PrintPro workspace using the windows select printer dialog and setting the minimum and maximum page range the user is allowed to choose from if ShowDialog is true.
SelectPrinter(PrintPro,Int32,Int32,Int32,Int32,PrintRangeAvailable) | Selects a printer from the PrintPro workspace using the windows select printer dialog and setting the minimum and maximum page range along with the default from and to values the user is allowed to choose from.
SelectPrinter(PrintPro,Int32,Int32,Int32,Int32) | Selects a printer from the PrintPro workspace using the windows select printer dialog and setting the minimum and maximum page range along with the default from and to values the user is allowed to choose from.

See Also

Reference

Printer Class
Printer Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
SelectPrinter(PrintPro) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Printer Class > SelectPrinter Method : SelectPrinter(PrintPro) Method

printProWorkspace
The PrintPro workspace to be used.

Glossary Item Box

Selects and returns the default printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Shared Function SelectPrinter( _
   ByVal printProWorkspace As PrintPro _
) As Printer
'Usage

Dim printProWorkspace As PrintPro
Dim value As Printer

value = Printer.SelectPrinter(printProWorkspace)
public static Printer SelectPrinter(
   PrintPro printProWorkspace
)
public: static Printer* SelectPrinter(
   PrintPro* printProWorkspace
)
public:
static Printer^ SelectPrinter(
   PrintPro^ printProWorkspace
)

Parameters

printProWorkspace
The PrintPro workspace to be used.

Return Value

The default printer.

See Also

Reference

Printer Class
Printer Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
SelectPrinter(PrintPro,Boolean) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Printer Class > SelectPrinter Method : SelectPrinter(PrintPro,Boolean) Method

printProWorkspace
The PrintPro workspace to be used
showDialog

Glossary Item Box

Selects a printer from the PrintPro workspace using the windows select printer dialog if ShowDialog is true, otherwise it selects the default printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Shared Function SelectPrinter( _
   ByVal printProWorkspace As PrintPro, _
   ByVal showDialog As Boolean _
) As Printer
'Usage

Dim printProWorkspace As PrintPro
Dim showDialog As Boolean
Dim value As Printer

value = Printer.SelectPrinter(printProWorkspace, showDialog)
public static Printer SelectPrinter(
   PrintPro printProWorkspace,
   bool showDialog
)
public: static Printer* SelectPrinter(
   PrintPro* printProWorkspace,
   bool showDialog
)
public:
static Printer^ SelectPrinter(
   PrintPro^ printProWorkspace,
   bool showDialog
)

Parameters

printProWorkspace
The PrintPro workspace to be used
showDialog

Return Value

the printer object that was selected

See Also

Reference

Printer Class
Printer Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
SelectPrinter(PrintPro,PrintRangeAvailable) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Printer Class > SelectPrinter Method : SelectPrinter(PrintPro,PrintRangeAvailable) Method

printProWorkspace
The PrintPro workspace to be used.
availableRange
The available range options that can be selected from the dialog box.

Glossary Item Box

Selects a printer from the PrintPro workspace using the windows select printer dialog

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Shared Function SelectPrinter( _
   ByVal printProWorkspace As PrintPro, _
   ByVal availableRange As PrintRangeAvailable _
) As Printer
'Usage

Dim printProWorkspace As PrintPro
Dim availableRange As PrintRangeAvailable
Dim value As Printer

value = Printer.SelectPrinter(printProWorkspace, availableRange)
public static Printer SelectPrinter(
   PrintPro printProWorkspace,
   PrintRangeAvailable availableRange
)
public: static Printer* SelectPrinter(
   PrintPro* printProWorkspace,
   PrintRangeAvailable availableRange
)
public:
static Printer^ SelectPrinter(
   PrintPro^ printProWorkspace,
   PrintRangeAvailable availableRange
)

Parameters

printProWorkspace
The PrintPro workspace to be used.
availableRange
The available range options that can be selected from the dialog box.

Return Value

The printer that was selected.

See Also

Reference

Printer Class
Printer Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
SelectPrinter(PrintPro,PrintRangeAvailable,PrintRangeSelection) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Printer Class > SelectPrinter Method : SelectPrinter(PrintPro,PrintRangeAvailable,PrintRangeSelection) Method

printProWorkspace
The PrintPro workspace to be used.
availableRange
The available range options that can be selected from the dialog box.
defaultRangeSelection
The default range option selection for the dialog box. Note that Pages can only be enabled via a constructor that enables you to set the min and max pages.

Glossary Item Box

Selects a printer from the PrintPro workspace using the windows select printer dialog

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Shared Function SelectPrinter( _
   ByVal printProWorkspace As PrintPro, _
   ByVal availableRange As PrintRangeAvailable, _
   ByVal defaultRangeSelection As PrintRangeSelection _
) As Printer
'Usage

Dim printProWorkspace As PrintPro
Dim availableRange As PrintRangeAvailable
Dim defaultRangeSelection As PrintRangeSelection
Dim value As Printer

value = Printer.SelectPrinter(printProWorkspace, availableRange, defaultRangeSelection)
public static Printer SelectPrinter(
   PrintPro printProWorkspace,
   PrintRangeAvailable availableRange,
   PrintRangeSelection defaultRangeSelection
)
public: static Printer* SelectPrinter(
   PrintPro* printProWorkspace,
   PrintRangeAvailable availableRange,
   PrintRangeSelection defaultRangeSelection
)
public:
static Printer^ SelectPrinter(
   PrintPro^ printProWorkspace,
   PrintRangeAvailable availableRange,
   PrintRangeSelection defaultRangeSelection
)

Parameters

printProWorkspace
The PrintPro workspace to be used.
availableRange
The available range options that can be selected from the dialog box.
defaultRangeSelection
The default range option selection for the dialog box. Note that Pages can only be enabled via a constructor that enables you to set the min and max pages.

Return Value

The printer that was selected.

See Also

Reference

Printer Class
Printer Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
SelectPrinter(PrintPro,String) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Printer Class > SelectPrinter Method : SelectPrinter(PrintPro,String) Method

printProWorkspace
PrintPro workspace instance.
name
A string which represents the name of the printer.

Glossary Item Box

Selects a printer from the PrintPro workspace by name.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Shared Function SelectPrinter( _
   ByVal printProWorkspace As PrintPro, _
   ByVal name As String _
) As Printer
'Usage

Dim printProWorkspace As PrintPro
Dim name As String
Dim value As Printer

value = Printer.SelectPrinter(printProWorkspace, name)
public static Printer SelectPrinter(
   PrintPro printProWorkspace,
   string name
)
public: static Printer* SelectPrinter(
   PrintPro* printProWorkspace,
   string* name
)
public:
static Printer^ SelectPrinter(
   PrintPro^ printProWorkspace,
   String^ name
)

Parameters

printProWorkspace
PrintPro workspace instance.
name
A string which represents the name of the printer.

Return Value

The Printer with specified name.

See Also

Reference

Printer Class
Printer Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
SelectPrinter(PrintPro,Boolean,Int32,Int32) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Printer Class > SelectPrinter Method : SelectPrinter(PrintPro,Boolean,Int32,Int32) Method

printProWorkspace
A PrintPro workspace.
showDialog
A boolean value which determines whether or not to show the select printer dialog
minPage
An integer value which represents if ShowDialog is true, this is the minimum available page range the user is allowed to select from in the print dialog. If ShowDialog is false, this is the starting page number for the printer and subsequent print jobs with it.
maxPage
If ShowDialog is true, this is the maximum available page range the user is allowed to select from in the print dialog. If ShowDialog is false, this is the ending page number for the printer and subsequent print jobs with it.

Glossary Item Box

Selects a printer from the PrintPro workspace using the windows select printer dialog and setting the minimum and maximum page range the user is allowed to choose from if ShowDialog is true.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Shared Function SelectPrinter( _
   ByVal printProWorkspace As PrintPro, _
   ByVal showDialog As Boolean, _
   ByVal minPage As Integer, _
   ByVal maxPage As Integer _
) As Printer
'Usage

Dim printProWorkspace As PrintPro
Dim showDialog As Boolean
Dim minPage As Integer
Dim maxPage As Integer
Dim value As Printer

value = Printer.SelectPrinter(printProWorkspace, showDialog, minPage, maxPage)
public static Printer SelectPrinter(
   PrintPro printProWorkspace,
   bool showDialog,
   int minPage,
   int maxPage
)
public: static Printer* SelectPrinter(
   PrintPro* printProWorkspace,
   bool showDialog,
   int minPage,
   int maxPage
)
public:
static Printer^ SelectPrinter(
   PrintPro^ printProWorkspace,
   bool showDialog,
   int minPage,
   int maxPage
)

Parameters

printProWorkspace
A PrintPro workspace.
showDialog
A boolean value which determines whether or not to show the select printer dialog
minPage
An integer value which represents if ShowDialog is true, this is the minimum available page range the user is allowed to select from in the print dialog. If ShowDialog is false, this is the starting page number for the printer and subsequent print jobs with it.
maxPage
If ShowDialog is true, this is the maximum available page range the user is allowed to select from in the print dialog. If ShowDialog is false, this is the ending page number for the printer and subsequent print jobs with it.

Return Value

The printer that was selected

Remarks

Note:If ShowDialog is false, MinPage and MaxPage are used for the print from and print to range. The dialog if shown has pages as the default range selection.

See Also

Reference

Printer Class
Printer Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
SelectPrinter(PrintPro,Int32,Int32,PrintRangeAvailable) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Printer Class > SelectPrinter Method : SelectPrinter(PrintPro,Int32,Int32,PrintRangeAvailable) Method

printProWorkspace
A PrintPro workspace.
minPage
An integer value which represents the minimum available page range the user is allowed to select from in the print dialog.
maxPage
An integer value which represents the maximum available page range the user is allowed to select from in the print dialog.
availableRange
The available range options to select from.

Glossary Item Box

Selects a printer from the PrintPro workspace using the windows select printer dialog and setting the minimum and maximum page range the user is allowed to choose from if ShowDialog is true.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Shared Function SelectPrinter( _
   ByVal printProWorkspace As PrintPro, _
   ByVal minPage As Integer, _
   ByVal maxPage As Integer, _
   ByVal availableRange As PrintRangeAvailable _
) As Printer
'Usage

Dim printProWorkspace As PrintPro
Dim minPage As Integer
Dim maxPage As Integer
Dim availableRange As PrintRangeAvailable
Dim value As Printer

value = Printer.SelectPrinter(printProWorkspace, minPage, maxPage, availableRange)
public static Printer SelectPrinter(
   PrintPro printProWorkspace,
   int minPage,
   int maxPage,
   PrintRangeAvailable availableRange
)
public: static Printer* SelectPrinter(
   PrintPro* printProWorkspace,
   int minPage,
   int maxPage,
   PrintRangeAvailable availableRange
)
public:
static Printer^ SelectPrinter(
   PrintPro^ printProWorkspace,
   int minPage,
   int maxPage,
   PrintRangeAvailable availableRange
)

Parameters

printProWorkspace
A PrintPro workspace.
minPage
An integer value which represents the minimum available page range the user is allowed to select from in the print dialog.
maxPage
An integer value which represents the maximum available page range the user is allowed to select from in the print dialog.
availableRange
The available range options to select from.

Return Value

The printer that was selected.

Remarks

Note: If ShowDialog is false, MinPage and MaxPage are used for the print from and print to range.

See Also

Reference

Printer Class
Printer Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
SelectPrinter(PrintPro,Int32,Int32,PrintRangeAvailable,PrintRangeSelection) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Printer Class > SelectPrinter Method : SelectPrinter(PrintPro,Int32,Int32,PrintRangeAvailable,PrintRangeSelection) Method

printProWorkspace
A PrintPro workspace.
minPage
An integer value which represents the minimum available page range the user is allowed to select from in the print dialog.
maxPage
An integer value which represents the maximum available page range the user is allowed to select from in the print dialog.
availableRange
A PrintRangeAvailable enumeration value which determines the available range options to select from.
defaultRangeSelection
A PrintRangeSelection enumeration value which determines the default range selection.

Glossary Item Box

Selects a printer from the PrintPro workspace using the windows select printer dialog and setting the minimum and maximum page range the user is allowed to choose from if ShowDialog is true.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Shared Function SelectPrinter( _
   ByVal printProWorkspace As PrintPro, _
   ByVal minPage As Integer, _
   ByVal maxPage As Integer, _
   ByVal availableRange As PrintRangeAvailable, _
   ByVal defaultRangeSelection As PrintRangeSelection _
) As Printer
'Usage

Dim printProWorkspace As PrintPro
Dim minPage As Integer
Dim maxPage As Integer
Dim availableRange As PrintRangeAvailable
Dim defaultRangeSelection As PrintRangeSelection
Dim value As Printer

value = Printer.SelectPrinter(printProWorkspace, minPage, maxPage, availableRange, defaultRangeSelection)
public static Printer SelectPrinter(
   PrintPro printProWorkspace,
   int minPage,
   int maxPage,
   PrintRangeAvailable availableRange,
   PrintRangeSelection defaultRangeSelection
)
public: static Printer* SelectPrinter(
   PrintPro* printProWorkspace,
   int minPage,
   int maxPage,
   PrintRangeAvailable availableRange,
   PrintRangeSelection defaultRangeSelection
)
public:
static Printer^ SelectPrinter(
   PrintPro^ printProWorkspace,
   int minPage,
   int maxPage,
   PrintRangeAvailable availableRange,
   PrintRangeSelection defaultRangeSelection
)

Parameters

printProWorkspace
A PrintPro workspace.
minPage
An integer value which represents the minimum available page range the user is allowed to select from in the print dialog.
maxPage
An integer value which represents the maximum available page range the user is allowed to select from in the print dialog.
availableRange
A PrintRangeAvailable enumeration value which determines the available range options to select from.
defaultRangeSelection
A PrintRangeSelection enumeration value which determines the default range selection.

Return Value

The printer that was selected.

Remarks

Note: If ShowDialog is false, MinPage and MaxPage are used for the print from and print to range.

See Also

Reference

Printer Class
Printer Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
SelectPrinter(PrintPro,Int32,Int32,Int32,Int32,PrintRangeAvailable) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Printer Class > SelectPrinter Method : SelectPrinter(PrintPro,Int32,Int32,Int32,Int32,PrintRangeAvailable) Method

printProWorkspace
The PrintPro workspace to use.
minPage
An integer value which represents the minimum available page range the user is allowed to select from in the print dialog.
maxPage
An integer value which represents the maximum available page range the user is allowed to select from in the print dialog.
fromPage
An integer which represents the default from page set in the page range portion of the setup dialog.
toPage
An integer which represents the default to page set in the page range portion of the setup dialog.
availableRange
The available range to select from in the select printer dialog

Glossary Item Box

Selects a printer from the PrintPro workspace using the windows select printer dialog and setting the minimum and maximum page range along with the default from and to values the user is allowed to choose from.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Shared Function SelectPrinter( _
   ByVal printProWorkspace As PrintPro, _
   ByVal minPage As Integer, _
   ByVal maxPage As Integer, _
   ByVal fromPage As Integer, _
   ByVal toPage As Integer, _
   ByVal availableRange As PrintRangeAvailable _
) As Printer
'Usage

Dim printProWorkspace As PrintPro
Dim minPage As Integer
Dim maxPage As Integer
Dim fromPage As Integer
Dim toPage As Integer
Dim availableRange As PrintRangeAvailable
Dim value As Printer

value = Printer.SelectPrinter(printProWorkspace, minPage, maxPage, fromPage, toPage, availableRange)
public static Printer SelectPrinter(
   PrintPro printProWorkspace,
   int minPage,
   int maxPage,
   int fromPage,
   int toPage,
   PrintRangeAvailable availableRange
)
public: static Printer* SelectPrinter(
   PrintPro* printProWorkspace,
   int minPage,
   int maxPage,
   int fromPage,
   int toPage,
   PrintRangeAvailable availableRange
)
public:
static Printer^ SelectPrinter(
   PrintPro^ printProWorkspace,
   int minPage,
   int maxPage,
   int fromPage,
   int toPage,
   PrintRangeAvailable availableRange
)

Parameters

printProWorkspace
The PrintPro workspace to use.
minPage
An integer value which represents the minimum available page range the user is allowed to select from in the print dialog.
maxPage
An integer value which represents the maximum available page range the user is allowed to select from in the print dialog.
fromPage
An integer which represents the default from page set in the page range portion of the setup dialog.
toPage
An integer which represents the default to page set in the page range portion of the setup dialog.
availableRange
The available range to select from in the select printer dialog

Return Value

The Printer that was selected.

Remarks

The dialog shown will have the ranges available for selection that are passed with a default selection of pages if that selection is available. If pages is not in the available selection, another constructor is likely to be more appropriate.

See Also

Reference

Printer Class
Printer Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
SelectPrinter(PrintPro,Int32,Int32,Int32,Int32) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Printer Class > SelectPrinter Method : SelectPrinter(PrintPro,Int32,Int32,Int32,Int32) Method

printProWorkspace
The PrintPro workspace to use.
minPage
An integer value which represents the minimum available page range the user is allowed to select from in the print dialog.
maxPage
An integer value which represents the maximum available page range the user is allowed to select from in the print dialog.
fromPage
An integer which represents the default from page set in the page range portion of the print setup dialog
toPage
An integer which represents the default to page set in the page range portion of the print setup dialog

Glossary Item Box

Selects a printer from the PrintPro workspace using the windows select printer dialog and setting the minimum and maximum page range along with the default from and to values the user is allowed to choose from.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Shared Function SelectPrinter( _
   ByVal printProWorkspace As PrintPro, _
   ByVal minPage As Integer, _
   ByVal maxPage As Integer, _
   ByVal fromPage As Integer, _
   ByVal toPage As Integer _
) As Printer
'Usage

Dim printProWorkspace As PrintPro
Dim minPage As Integer
Dim maxPage As Integer
Dim fromPage As Integer
Dim toPage As Integer
Dim value As Printer

value = Printer.SelectPrinter(printProWorkspace, minPage, maxPage, fromPage, toPage)
public static Printer SelectPrinter(
   PrintPro printProWorkspace,
   int minPage,
   int maxPage,
   int fromPage,
   int toPage
)
public: static Printer* SelectPrinter(
   PrintPro* printProWorkspace,
   int minPage,
   int maxPage,
   int fromPage,
   int toPage
)
public:
static Printer^ SelectPrinter(
   PrintPro^ printProWorkspace,
   int minPage,
   int maxPage,
   int fromPage,
   int toPage
)

Parameters

printProWorkspace
The PrintPro workspace to use.
minPage
An integer value which represents the minimum available page range the user is allowed to select from in the print dialog.
maxPage
An integer value which represents the maximum available page range the user is allowed to select from in the print dialog.
fromPage
An integer which represents the default from page set in the page range portion of the print setup dialog
toPage
An integer which represents the default to page set in the page range portion of the print setup dialog

Return Value

The printer that was selected.

See Also

Reference

Printer Class
Printer Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
SetAsDefault Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Printer Class : SetAsDefault Method

Glossary Item Box

Sets the printer as the default printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub SetAsDefault()
'Usage

Dim instance As Printer

instance.SetAsDefault()
public void SetAsDefault()
public: void SetAsDefault();
public:
void SetAsDefault();

See Also

Reference

Printer Class
Printer Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
SetupDialog Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Printer Class : SetupDialog Method

Glossary Item Box

Displays a printer setup dialog box that lets you change printer properties.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub SetupDialog()
'Usage

Dim instance As Printer

instance.SetupDialog()
public void SetupDialog()
public: void SetupDialog();
public:
void SetupDialog();

See Also

Reference

Printer Class
Printer Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
ToFilePrinter Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Printer Class : ToFilePrinter Method

fileName
A string which represents the filename to save to.
saveFileType
A SaveFileType enumeration value which represents the file type to save to.

Glossary Item Box

Takes the current printer object and converts it to print to a file.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub ToFilePrinter( _
   ByVal fileName As String, _
   ByVal saveFileType As SaveFileType _
)
'Usage

Dim instance As Printer
Dim fileName As String
Dim saveFileType As SaveFileType

instance.ToFilePrinter(fileName, saveFileType)
public void ToFilePrinter(
   string fileName,
   SaveFileType saveFileType
)
public: void ToFilePrinter(
   string* fileName,
   SaveFileType saveFileType
)
public:
void ToFilePrinter(
   String^ fileName,
   SaveFileType saveFileType
)

Parameters

fileName
A string which represents the filename to save to.
saveFileType
A SaveFileType enumeration value which represents the file type to save to.

Remarks

After this is done the printer object will no longer print to a printer. This cannot be done once this object has been used to start a print job.

See Also

Reference

Printer Class
Printer Members


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
Printer Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : Printer Class

Glossary Item Box

For a list of all members of this type, see Printer members.

Public Properties

 | Name | Description
Public Property | AutoMargin | Gets and sets an indicator which determines whether the margin values and the current print position values should automatically be set to values inside the printer's display area.
Public Property | Collate | Gets and sets an indicator which specifies whether collation should be used when printing multiple copies (if the printer supports this feature).
Public Property | ColorMode | Gets and sets an indicator which determines whether a color printer prints output in color or monochrome.
Public Property | Copies | Gets and sets the number of copies to be printed.
Public Property | Dither | Gets and sets a value that specifies how dithering is to be done (if the printer supports this feature).
Public Property | DriverName | Gets the printer driver name.
Public Property | Duplex | Gets and sets the PrintDuplex option for how a page is printed on both sides (if the printer supports this feature).
Public Property | DuplexAvailable | Gets an indicator of the level of duplex support.
Public Property | FileName | Gets the filename that the print is saved to.
Public Property | IsFilePrinter | Gets an indicator which determines if this printer object is actually a file printer.
Public Property | MaxCopies | Gets the number of copies that the printer can print.
Public Property | MaxDpi | Gets the maximum resolution available.
Public Property | MediaType | Gets and sets the type of media being printed on (if the printer supports this feature).
Public Property | Name | Gets the printer's name.
Public Property | Orientation | Gets and sets whether documents are printed in portrait or landscape mode (if the printer supports this feature).
Public Property | Paper | Gets and sets the type of paper being used for printing (if the printer supports this feature).
Public Property | PaperBin | Gets and sets the paper bin that is to be used to feed the printer paper.
Public Property | PaperBins | Gets a collection of paper bins that can be used to feed the printer paper.
Public Property | PaperHeight | Gets the physical height of the paper set up for the printing device, in units determined by the PrintUnits property.
Public Property | Papers | Gets a collection of papers that represent the different types of papers available to the user (if the printer supports this feature).
Public Property | PaperWidth | Gets the physical width of the paper set up for the printing device, in units determined by the PrintUnits property.
Public Property | PortName | Gets the name of the port through which a document is sent to a printer.
Public Property | PrintHeight | Gets the printable area height of the paper set up for the printing device, in units determined by the PrintUnits property.
Public Property | PrintQuality | Gets and sets a value indicating the printer resolution (if the printer supports this feature).
Public Property | PrintResolution | Gets the print resolution in dots per inch - horizontal and vertical.
Public Property | PrintUnits | Gets and sets the units that are used to describe measurements for printing.
Public Property | PrintWidth | Gets the printable area width of the paper set up for the printing device, in units determined by the PrintUnits property.
Public Property | RangeFrom | Gets and sets the value that was selected for the beginning of the print range via the print dialog.
Public Property | RangeSelection | Gets the value of the print range radio button from the print dialog.
Public Property | RangeTo | Gets and sets the value that was selected for the end of the print range via the print dialog.
Public Property | RequestedDpi | Gets and sets the current DPI resolution.
Public Property | SaveFileType | Gets the file type that the print is saved as.
Public Property | SupportedDpis | The resolutions supported by the printer in dots per inch.
Public Property | TrueType | Gets and sets a value indicating the printer’s TrueTypeOption enumeration option.
Public Property | TwipsPerPixelX | Gets the number of twips per pixel for a printer measured horizontally.
Public Property | TwipsPerPixelY | Gets the number of twips per pixel for a printer measured vertically.
Public Property | UserDither | Gets and sets a value which specifies how dithering is to be done (if the printer supports this feature).
Public Property | UserMediaType | Gets and sets the type of media being printed on (if the printer supports this feature).
Public Property | UserPaper | Gets and sets the type of paper being used for printing (if the printer supports this feature).
Public Property | Zoom | Gets or sets the percentage by which printed output is to be scaled up or down (if the printer supports this feature).
Top

See Also

Reference

Printer Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
AutoMargin Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Printer Class : AutoMargin Property

Glossary Item Box

Gets and sets an indicator which determines whether the margin values and the current print position values should automatically be set to values inside the printer's display area.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property AutoMargin As Boolean
'Usage

Dim instance As Printer
Dim value As Boolean

instance.AutoMargin = value

value = instance.AutoMargin
public bool AutoMargin {get; set;}
public: __property bool get_AutoMargin();
public: __property void set_AutoMargin(
   bool value
);
public:
property bool AutoMargin {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true to automatically set to values inside the printer's display area. Otherwise, false is used.

Remarks

The default value is false.

See Also

Reference

Printer Class
Printer Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Collate Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Printer Class : Collate Property

Glossary Item Box

Gets and sets an indicator which specifies whether collation should be used when printing multiple copies (if the printer supports this feature).

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property Collate As Boolean
'Usage

Dim instance As Printer
Dim value As Boolean

instance.Collate = value

value = instance.Collate
public bool Collate {get; set;}
public: __property bool get_Collate();
public: __property void set_Collate(
   bool value
);
public:
property bool Collate {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true when collation should be used when printing multiple copies. Otherwise, false should be used.

Remarks

The default value is false.

See Also

Reference

Printer Class
Printer Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
ColorMode Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Printer Class : ColorMode Property

Glossary Item Box

Gets and sets an indicator which determines whether a color printer prints output in color or monochrome.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property ColorMode As PrintColorMode
'Usage

Dim instance As Printer
Dim value As PrintColorMode

instance.ColorMode = value

value = instance.ColorMode
public PrintColorMode ColorMode {get; set;}
public: __property PrintColorMode get_ColorMode();
public: __property void set_ColorMode(
   PrintColorMode value
);
public:
property PrintColorMode ColorMode {
   PrintColorMode get();
   void set (    PrintColorMode value);
}

Property Value

A PrintColorMode enumeration option which determines the color mode for a printer output.

Remarks

The default value is PrintColorMode.Monochrome.

See Also

Reference

Printer Class
Printer Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Copies Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Printer Class : Copies Property

Glossary Item Box

Gets and sets the number of copies to be printed.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property Copies As Integer
'Usage

Dim instance As Printer
Dim value As Integer

instance.Copies = value

value = instance.Copies
public int Copies {get; set;}
public: __property int get_Copies();
public: __property void set_Copies(
   int value
);
public:
property int Copies {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the number of copies to be printed.

Remarks

The default value is 0.

See Also

Reference

Printer Class
Printer Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Dither Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Printer Class : Dither Property

Glossary Item Box

Gets and sets a value that specifies how dithering is to be done (if the printer supports this feature).

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property Dither As PrintDitherType
'Usage

Dim instance As Printer
Dim value As PrintDitherType

instance.Dither = value

value = instance.Dither
public PrintDitherType Dither {get; set;}
public: __property PrintDitherType get_Dither();
public: __property void set_Dither(
   PrintDitherType value
);
public:
property PrintDitherType Dither {
   PrintDitherType get();
   void set (    PrintDitherType value);
}

Property Value

A PrintDitherType enumeration value option.

See Also

Reference

Printer Class
Printer Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
DriverName Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Printer Class : DriverName Property

Glossary Item Box

Gets the printer driver name.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property DriverName As String
'Usage

Dim instance As Printer
Dim value As String

value = instance.DriverName
public string DriverName {get;}
public: __property string* get_DriverName();
public:
property String^ DriverName {
   String^ get();
}

Property Value

A string which represents the printer driver name.

Remarks

The default value is an empty string "".

See Also

Reference

Printer Class
Printer Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Duplex Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Printer Class : Duplex Property

Glossary Item Box

Gets and sets the PrintDuplex option for how a page is printed on both sides (if the printer supports this feature).

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property Duplex As PrintDuplex
'Usage

Dim instance As Printer
Dim value As PrintDuplex

instance.Duplex = value

value = instance.Duplex
public PrintDuplex Duplex {get; set;}
public: __property PrintDuplex get_Duplex();
public: __property void set_Duplex(
   PrintDuplex value
);
public:
property PrintDuplex Duplex {
   PrintDuplex get();
   void set (    PrintDuplex value);
}

Property Value

A PrintDuplex enumeration value which determines how a page is printed on both sides.

Remarks

The default value is PrintDuplex.Simplex.

See Also

Reference

Printer Class
Printer Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
DuplexAvailable Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Printer Class : DuplexAvailable Property

Glossary Item Box

Gets an indicator of the level of duplex support.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property DuplexAvailable As Boolean
'Usage

Dim instance As Printer
Dim value As Boolean

value = instance.DuplexAvailable
public bool DuplexAvailable {get;}
public: __property bool get_DuplexAvailable();
public:
property bool DuplexAvailable {
   bool get();
}

Property Value

A boolean value which is true if the printer is capable of duplex printing. Otherwise, false is returned.

Remarks

The default value is false.

Note: If DuplexAvailable returns true, the printer is capable of duplex printing.

See Also

Reference

Printer Class
Printer Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
FileName Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Printer Class : FileName Property

Glossary Item Box

Gets the filename that the print is saved to.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property FileName As String
'Usage

Dim instance As Printer
Dim value As String

value = instance.FileName
public string FileName {get;}
public: __property string* get_FileName();
public:
property String^ FileName {
   String^ get();
}

Property Value

A string value which represents the filename that the print is saved to.

Remarks

If it is not a file printer, this method throws an exception. Use the IsFilePrinter property to test if a printer object is a file printer.

See Also

Reference

Printer Class
Printer Members
IsFilePrinter Property


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
IsFilePrinter Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Printer Class : IsFilePrinter Property

Glossary Item Box

Gets an indicator which determines if this printer object is actually a file printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property IsFilePrinter As Boolean
'Usage

Dim instance As Printer
Dim value As Boolean

value = instance.IsFilePrinter
public bool IsFilePrinter {get;}
public: __property bool get_IsFilePrinter();
public:
property bool IsFilePrinter {
   bool get();
}

Property Value

A boolean value which is true if this printer object is a file printer. Otherwise, false is used.

See Also

Reference

Printer Class
Printer Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
MaxCopies Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Printer Class : MaxCopies Property

Glossary Item Box

Gets the number of copies that the printer can print.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property MaxCopies As Integer
'Usage

Dim instance As Printer
Dim value As Integer

value = instance.MaxCopies
public int MaxCopies {get;}
public: __property int get_MaxCopies();
public:
property int MaxCopies {
   int get();
}

Property Value

An integer value which represents the number of copies that the printer can print.

Remarks

The default value is 0.

See Also

Reference

Printer Class
Printer Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
MaxDpi Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Printer Class : MaxDpi Property

Glossary Item Box

Gets the maximum resolution available.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property MaxDpi As Integer
'Usage

Dim instance As Printer
Dim value As Integer

value = instance.MaxDpi
public int MaxDpi {get;}
public: __property int get_MaxDpi();
public:
property int MaxDpi {
   int get();
}

Property Value

An integer value which represents the maximum resolution available.

Remarks

The default value is 0.

See Also

Reference

Printer Class
Printer Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
MediaType Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Printer Class : MediaType Property

Glossary Item Box

Gets and sets the type of media being printed on (if the printer supports this feature).

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property MediaType As MediaType
'Usage

Dim instance As Printer
Dim value As MediaType

instance.MediaType = value

value = instance.MediaType
public MediaType MediaType {get; set;}
public: __property MediaType get_MediaType();
public: __property void set_MediaType(
   MediaType value
);
public:
property MediaType MediaType {
   MediaType get();
   void set (    MediaType value);
}

Property Value

A MediaType enumeration value option which determines the type of media being printed on.

Remarks

The effect of setting the MediaType property depends on the driver supplied by the printer manufacturer. Some property settings may have no effect.

See Also

Reference

Printer Class
Printer Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Name Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Printer Class : Name Property

Glossary Item Box

Gets the printer's name.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property Name As String
'Usage

Dim instance As Printer
Dim value As String

value = instance.Name
public string Name {get;}
public: __property string* get_Name();
public:
property String^ Name {
   String^ get();
}

Property Value

A string value which represents the printer's name.

Remarks

The default value is an empty string "".

See Also

Reference

Printer Class
Printer Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Orientation Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Printer Class : Orientation Property

Glossary Item Box

Gets and sets whether documents are printed in portrait or landscape mode (if the printer supports this feature).

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property Orientation As Orientation
'Usage

Dim instance As Printer
Dim value As Orientation

instance.Orientation = value

value = instance.Orientation
public Orientation Orientation {get; set;}
public: __property Orientation get_Orientation();
public: __property void set_Orientation(
   Orientation value
);
public:
property Orientation Orientation {
   Orientation get();
   void set (    Orientation value);
}

Property Value

An Orientation enumeration value which determines the orientation documents are printed in.

See Also

Reference

Printer Class
Printer Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Paper Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Printer Class : Paper Property

Glossary Item Box

Gets and sets the type of paper being used for printing (if the printer supports this feature).

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property Paper As Paper
'Usage

Dim instance As Printer
Dim value As Paper

instance.Paper = value

value = instance.Paper
public Paper Paper {get; set;}
public: __property Paper* get_Paper();
public: __property void set_Paper(
   Paper* value
);
public:
property Paper^ Paper {
   Paper^ get();
   void set (    Paper^ value);
}

Property Value

A Paper object which contains information about the type of paper being used.

See Also

Reference

Printer Class
Printer Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PaperBin Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Printer Class : PaperBin Property

Glossary Item Box

Gets and sets the paper bin that is to be used to feed the printer paper.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property PaperBin As PaperBin
'Usage

Dim instance As Printer
Dim value As PaperBin

instance.PaperBin = value

value = instance.PaperBin
public PaperBin PaperBin {get; set;}
public: __property PaperBin* get_PaperBin();
public: __property void set_PaperBin(
   PaperBin* value
);
public:
property PaperBin^ PaperBin {
   PaperBin^ get();
   void set (    PaperBin^ value);
}

Property Value

A PaperBin object which contains information about the paper bin used to feed the printer paper.

See Also

Reference

Printer Class
Printer Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PaperBins Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Printer Class : PaperBins Property

Glossary Item Box

Gets a collection of paper bins that can be used to feed the printer paper.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property PaperBins As PaperBinCollection
'Usage

Dim instance As Printer
Dim value As PaperBinCollection

value = instance.PaperBins
public PaperBinCollection PaperBins {get;}
public: __property PaperBinCollection* get_PaperBins();
public:
property PaperBinCollection^ PaperBins {
   PaperBinCollection^ get();
}

Property Value

A PaperBinCollection object which contains a collection of paper bins.

See Also

Reference

Printer Class
Printer Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PaperHeight Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Printer Class : PaperHeight Property

Glossary Item Box

Gets the physical height of the paper set up for the printing device, in units determined by the PrintUnits property.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property PaperHeight As Single
'Usage

Dim instance As Printer
Dim value As Single

value = instance.PaperHeight
public float PaperHeight {get;}
public: __property float get_PaperHeight();
public:
property float PaperHeight {
   float get();
}

Property Value

A single value which represents the paper height.

See Also

Reference

Printer Class
Printer Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Papers Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Printer Class : Papers Property

Glossary Item Box

Gets a collection of papers that represent the different types of papers available to the user (if the printer supports this feature).

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property Papers As PaperCollection
'Usage

Dim instance As Printer
Dim value As PaperCollection

value = instance.Papers
public PaperCollection Papers {get;}
public: __property PaperCollection* get_Papers();
public:
property PaperCollection^ Papers {
   PaperCollection^ get();
}

Property Value

A PaperCollection object which contains a collection of papers that are available to the user.

See Also

Reference

Printer Class
Printer Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PaperWidth Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Printer Class : PaperWidth Property

Glossary Item Box

Gets the physical width of the paper set up for the printing device, in units determined by the PrintUnits property.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property PaperWidth As Single
'Usage

Dim instance As Printer
Dim value As Single

value = instance.PaperWidth
public float PaperWidth {get;}
public: __property float get_PaperWidth();
public:
property float PaperWidth {
   float get();
}

Property Value

A single value which represents the width.

See Also

Reference

Printer Class
Printer Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PortName Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Printer Class : PortName Property

Glossary Item Box

Gets the name of the port through which a document is sent to a printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property PortName As String
'Usage

Dim instance As Printer
Dim value As String

value = instance.PortName
public string PortName {get;}
public: __property string* get_PortName();
public:
property String^ PortName {
   String^ get();
}

Property Value

A string value which represents the port name.

Remarks

The default value is an empty string "".

See Also

Reference

Printer Class
Printer Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintHeight Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Printer Class : PrintHeight Property

Glossary Item Box

Gets the printable area height of the paper set up for the printing device, in units determined by the PrintUnits property.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property PrintHeight As Single
'Usage

Dim instance As Printer
Dim value As Single

value = instance.PrintHeight
public float PrintHeight {get;}
public: __property float get_PrintHeight();
public:
property float PrintHeight {
   float get();
}

Property Value

A single value which represents the print height.

See Also

Reference

Printer Class
Printer Members
PrintUnits Property


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintQuality Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Printer Class : PrintQuality Property

Glossary Item Box

Gets and sets a value indicating the printer resolution (if the printer supports this feature).

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property PrintQuality As PrintQuality
'Usage

Dim instance As Printer
Dim value As PrintQuality

instance.PrintQuality = value

value = instance.PrintQuality
public PrintQuality PrintQuality {get; set;}
public: __property PrintQuality* get_PrintQuality();
public: __property void set_PrintQuality(
   PrintQuality* value
);
public:
property PrintQuality^ PrintQuality {
   PrintQuality^ get();
   void set (    PrintQuality^ value);
}

Property Value

A PrintQuality object which contains information about the print resolution.

See Also

Reference

Printer Class
Printer Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintResolution Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Printer Class : PrintResolution Property

Glossary Item Box

Gets the print resolution in dots per inch - horizontal and vertical.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property PrintResolution As Size
'Usage

Dim instance As Printer
Dim value As Size

value = instance.PrintResolution
public Size PrintResolution {get;}
public: __property Size get_PrintResolution();
public:
property Size PrintResolution {
   Size get();
}

Property Value

A System.Drawing.Size object.

See Also

Reference

Printer Class
Printer Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintUnits Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Printer Class : PrintUnits Property

Glossary Item Box

Gets and sets the units that are used to describe measurements for printing.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property PrintUnits As PrintingUnit
'Usage

Dim instance As Printer
Dim value As PrintingUnit

instance.PrintUnits = value

value = instance.PrintUnits
public PrintingUnit PrintUnits {get; set;}
public: __property PrintingUnit get_PrintUnits();
public: __property void set_PrintUnits(
   PrintingUnit value
);
public:
property PrintingUnit PrintUnits {
   PrintingUnit get();
   void set (    PrintingUnit value);
}

Property Value

A PrintingUnit object that contains information used to describe measurements for printing.

See Also

Reference

Printer Class
Printer Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintWidth Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Printer Class : PrintWidth Property

Glossary Item Box

Gets the printable area width of the paper set up for the printing device, in units determined by the PrintUnits property.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property PrintWidth As Single
'Usage

Dim instance As Printer
Dim value As Single

value = instance.PrintWidth
public float PrintWidth {get;}
public: __property float get_PrintWidth();
public:
property float PrintWidth {
   float get();
}

Property Value

A single value which represents the printable area width of the paper set up for the printing device.

See Also

Reference

Printer Class
Printer Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
RangeFrom Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Printer Class : RangeFrom Property

Glossary Item Box

Gets and sets the value that was selected for the beginning of the print range via the print dialog.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property RangeFrom As Integer
'Usage

Dim instance As Printer
Dim value As Integer

instance.RangeFrom = value

value = instance.RangeFrom
public int RangeFrom {get; set;}
public: __property int get_RangeFrom();
public: __property void set_RangeFrom(
   int value
);
public:
property int RangeFrom {
   int get();
   void set (    int value);
}

Property Value

An integer which represents the print from range.

Remarks

The default value is 0.

See Also

Reference

Printer Class
Printer Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
RangeSelection Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Printer Class : RangeSelection Property

Glossary Item Box

Gets the value of the print range radio button from the print dialog.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property RangeSelection As PrintRangeSelection
'Usage

Dim instance As Printer
Dim value As PrintRangeSelection

value = instance.RangeSelection
public PrintRangeSelection RangeSelection {get;}
public: __property PrintRangeSelection get_RangeSelection();
public:
property PrintRangeSelection RangeSelection {
   PrintRangeSelection get();
}

Property Value

A PrintRangeSelection enumeration value which determines the print range.

Remarks

The default value is PrintRangeSelection.NoSelection.

See Also

Reference

Printer Class
Printer Members
PrintRangeSelection Enumeration


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
RangeTo Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Printer Class : RangeTo Property

Glossary Item Box

Gets and sets the value that was selected for the end of the print range via the print dialog.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property RangeTo As Integer
'Usage

Dim instance As Printer
Dim value As Integer

instance.RangeTo = value

value = instance.RangeTo
public int RangeTo {get; set;}
public: __property int get_RangeTo();
public: __property void set_RangeTo(
   int value
);
public:
property int RangeTo {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the print to range.

Remarks

The default value is 0.

See Also

Reference

Printer Class
Printer Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
RequestedDpi Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Printer Class : RequestedDpi Property

Glossary Item Box

Gets and sets the current DPI resolution.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property RequestedDpi As Integer
'Usage

Dim instance As Printer
Dim value As Integer

instance.RequestedDpi = value

value = instance.RequestedDpi
public int RequestedDpi {get; set;}
public: __property int get_RequestedDpi();
public: __property void set_RequestedDpi(
   int value
);
public:
property int RequestedDpi {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the current DPI resolution.

Remarks

The quality and size of the file generated will depend upon the DPI requested.

See Also

Reference

Printer Class
Printer Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
SaveFileType Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Printer Class : SaveFileType Property

Glossary Item Box

Gets the file type that the print is saved as.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property SaveFileType As SaveFileType
'Usage

Dim instance As Printer
Dim value As SaveFileType

value = instance.SaveFileType
public SaveFileType SaveFileType {get;}
public: __property SaveFileType get_SaveFileType();
public:
property SaveFileType SaveFileType {
   SaveFileType get();
}

Property Value

A SaveFileType enumeration value which determines the file type that the print is saved as.

Remarks

If it is not a file printer, this method throws an exception. See the IsFilePrinter property to test if a printer object is a file printer.

See Also

Reference

Printer Class
Printer Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
SupportedDpis Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Printer Class : SupportedDpis Property

Glossary Item Box

The resolutions supported by the printer in dots per inch.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property SupportedDpis As ReadOnlyCollection(Of PrinterResolution)
'Usage

Dim instance As Printer
Dim value As ReadOnlyCollection(Of PrinterResolution)

value = instance.SupportedDpis
public ReadOnlyCollection<PrinterResolution> SupportedDpis {get;}
public: __property ReadOnlyCollection<PrinterResolution*>* get_SupportedDpis();
public:
property ReadOnlyCollection<PrinterResolution^>^ SupportedDpis {
   ReadOnlyCollection<PrinterResolution^>^ get();
}

See Also

Reference

Printer Class
Printer Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
TrueType Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Printer Class : TrueType Property

Glossary Item Box

Gets and sets a value indicating the printer’s TrueTypeOption enumeration option.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property TrueType As TrueTypeOption
'Usage

Dim instance As Printer
Dim value As TrueTypeOption

instance.TrueType = value

value = instance.TrueType
public TrueTypeOption TrueType {get; set;}
public: __property TrueTypeOption get_TrueType();
public: __property void set_TrueType(
   TrueTypeOption value
);
public:
property TrueTypeOption TrueType {
   TrueTypeOption get();
   void set (    TrueTypeOption value);
}

Property Value

A TrueTypeOption enumeration option value which determines the printer's true type.

Remarks

The default value is TrueTypeOption.PrintAsGraphics.

See Also

Reference

Printer Class
Printer Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
TwipsPerPixelX Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Printer Class : TwipsPerPixelX Property

Glossary Item Box

Gets the number of twips per pixel for a printer measured horizontally.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property TwipsPerPixelX As Single
'Usage

Dim instance As Printer
Dim value As Single

value = instance.TwipsPerPixelX
public float TwipsPerPixelX {get;}
public: __property float get_TwipsPerPixelX();
public:
property float TwipsPerPixelX {
   float get();
}

Property Value

A single value which represents the number of twips per pixel for a printer measured horizontally.

See Also

Reference

Printer Class
Printer Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
TwipsPerPixelY Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Printer Class : TwipsPerPixelY Property

Glossary Item Box

Gets the number of twips per pixel for a printer measured vertically.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property TwipsPerPixelY As Single
'Usage

Dim instance As Printer
Dim value As Single

value = instance.TwipsPerPixelY
public float TwipsPerPixelY {get;}
public: __property float get_TwipsPerPixelY();
public:
property float TwipsPerPixelY {
   float get();
}

Property Value

A single value which represents the number of twips per pixel for a printer measured vertically.

See Also

Reference

Printer Class
Printer Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
UserDither Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Printer Class : UserDither Property

Glossary Item Box

Gets and sets a value which specifies how dithering is to be done (if the printer supports this feature).

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property UserDither As Integer
'Usage

Dim instance As Printer
Dim value As Integer

instance.UserDither = value

value = instance.UserDither
public int UserDither {get; set;}
public: __property int get_UserDither();
public: __property void set_UserDither(
   int value
);
public:
property int UserDither {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the dithering to be performed.

Remarks

Use this property when the desired setting is manufacturer specific.

See Also

Reference

Printer Class
Printer Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
UserMediaType Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Printer Class : UserMediaType Property

Glossary Item Box

Gets and sets the type of media being printed on (if the printer supports this feature).

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property UserMediaType As Integer
'Usage

Dim instance As Printer
Dim value As Integer

instance.UserMediaType = value

value = instance.UserMediaType
public int UserMediaType {get; set;}
public: __property int get_UserMediaType();
public: __property void set_UserMediaType(
   int value
);
public:
property int UserMediaType {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the type of media being printed on.

Remarks

Use this property when the desired setting is manufacturer specific.

See Also

Reference

Printer Class
Printer Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
UserPaper Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Printer Class : UserPaper Property

Glossary Item Box

Gets and sets the type of paper being used for printing (if the printer supports this feature).

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property UserPaper As Integer
'Usage

Dim instance As Printer
Dim value As Integer

instance.UserPaper = value

value = instance.UserPaper
public int UserPaper {get; set;}
public: __property int get_UserPaper();
public: __property void set_UserPaper(
   int value
);
public:
property int UserPaper {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the type of paper used for printing.

Remarks

The default value is 0.

Use this property when the desired setting is manufacturer specific.

See Also

Reference

Printer Class
Printer Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Zoom Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > Printer Class : Zoom Property

Glossary Item Box

Gets or sets the percentage by which printed output is to be scaled up or down (if the printer supports this feature).

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property Zoom As Integer
'Usage

Dim instance As Printer
Dim value As Integer

instance.Zoom = value

value = instance.Zoom
public int Zoom {get; set;}
public: __property int get_Zoom();
public: __property void set_Zoom(
   int value
);
public:
property int Zoom {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the percentage output is scaled up or down.

See Also

Reference

Printer Class
Printer Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrinterCollection Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : PrinterCollection Class

Glossary Item Box

This class implements a collection of available printers.

Object Model

PrinterCollection ClassPrinter ClassPrinter ClassPrinter ClassPaper ClassPaperBin ClassPaperBinCollection ClassPaperBin ClassPaperCollection ClassPaper ClassPrintQuality ClassPrintingUnit StructurePrinter ClassPaper ClassPaperBin ClassPaperBinCollection ClassPaperBin ClassPaperCollection ClassPaper ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintingUnit StructurePrinter ClassPrinter ClassPaper ClassPaperBin ClassPaperBinCollection ClassPaperBin ClassPaperCollection ClassPaper ClassPrintQuality ClassPrintingUnit StructurePrinter Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DefaultMemberAttribute("Item")>
Public Class PrinterCollection
   Inherits System.Collections.ReadOnlyCollectionBase
'Usage

Dim instance As PrinterCollection
[DefaultMemberAttribute("Item")]
public class PrinterCollection : System.Collections.ReadOnlyCollectionBase
[DefaultMemberAttribute("Item")]
public __gc class PrinterCollection : public System.Collections.ReadOnlyCollectionBase
[DefaultMemberAttribute("Item")]
public ref class PrinterCollection : public System.Collections.ReadOnlyCollectionBase

Inheritance Hierarchy

System.Object
System.Collections.ReadOnlyCollectionBase
Accusoft.PrintProSdk.PrinterCollection

See Also

Reference

PrinterCollection Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
PrinterCollection Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : PrinterCollection Class

Glossary Item Box

The following tables list the members exposed by PrinterCollection.

Public Properties

 | Name | Description
Public Property | Count | Overridden. Gets the number of Printer objects in the collection.
Public Property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe).
Public Property | Item | Overloaded. Gets a Printer object which matches the given index value.
Public Property | SyncRoot | Gets an object to be used for thread synchronization.
Top

Public Methods

 | Name | Description
Public Method | Contains | Checks if the given Printer object is contained within the collection.
Public Method | CopyTo | Copies the elements of the printer collection to an array, starting at the given index location.
Public Method | GetEnumerator | Overridden. Returns an enumerator that can iterate through the printer collection.
Top

See Also

Reference

PrinterCollection Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
PrinterCollection Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : PrinterCollection Class

Glossary Item Box

For a list of all members of this type, see PrinterCollection members.

Public Methods

 | Name | Description
Public Method | Contains | Checks if the given Printer object is contained within the collection.
Public Method | CopyTo | Copies the elements of the printer collection to an array, starting at the given index location.
Public Method | GetEnumerator | Overridden. Returns an enumerator that can iterate through the printer collection.
Top

See Also

Reference

PrinterCollection Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Contains Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrinterCollection Class : Contains Method

printer
The Printer to check the specified collection for.

Glossary Item Box

Checks if the given Printer object is contained within the collection.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function Contains( _
   ByVal printer As Printer _
) As Boolean
'Usage

Dim instance As PrinterCollection
Dim printer As Printer
Dim value As Boolean

value = instance.Contains(printer)
public bool Contains(
   Printer printer
)
public: bool Contains(
   Printer* printer
)
public:
bool Contains(
   Printer^ printer
)

Parameters

printer
The Printer to check the specified collection for.

Return Value

A boolean value which is true if the specified printer exists in the collection.

See Also

Reference

PrinterCollection Class
PrinterCollection Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
CopyTo Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrinterCollection Class : CopyTo Method

array
A one-dimensional array that is the destination of the elements copied from the collection. The Array must have zero-based indexing and be of type Printer.
index
An integer value which represents the zero-based index in array at which copying begins.

Glossary Item Box

Copies the elements of the printer collection to an array, starting at the given index location.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub CopyTo( _
   ByVal array() As Printer, _
   ByVal index As Integer _
)
'Usage

Dim instance As PrinterCollection
Dim array() As Printer
Dim index As Integer

instance.CopyTo(array, index)
public void CopyTo(
   Printer[] array,
   int index
)
public: void CopyTo(
   Printer*[]* array,
   int index
)
public:
void CopyTo(
   array<Printer^>^ array,
   int index
)

Parameters

array
A one-dimensional array that is the destination of the elements copied from the collection. The Array must have zero-based indexing and be of type Printer.
index
An integer value which represents the zero-based index in array at which copying begins.

Remarks

Note: It is not recommended that this method be used.

See Also

Reference

PrinterCollection Class
PrinterCollection Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
GetEnumerator Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrinterCollection Class : GetEnumerator Method

Glossary Item Box

Returns an enumerator that can iterate through the printer collection.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overrides Function GetEnumerator() As IEnumerator
'Usage

Dim instance As PrinterCollection
Dim value As IEnumerator

value = instance.GetEnumerator()
public override IEnumerator GetEnumerator()
public: IEnumerator* GetEnumerator(); override
public:
IEnumerator^ GetEnumerator(); override

Return Value

An enumerator that can iterate through the printer collection.

See Also

Reference

PrinterCollection Class
PrinterCollection Members


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
PrinterCollection Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : PrinterCollection Class

Glossary Item Box

For a list of all members of this type, see PrinterCollection members.

Public Properties

 | Name | Description
Public Property | Count | Overridden. Gets the number of Printer objects in the collection.
Public Property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe).
Public Property | Item | Overloaded. Gets a Printer object which matches the given index value.
Public Property | SyncRoot | Gets an object to be used for thread synchronization.
Top

See Also

Reference

PrinterCollection Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Count Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrinterCollection Class : Count Property

Glossary Item Box

Gets the number of Printer objects in the collection.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overrides ReadOnly Property Count As Integer
'Usage

Dim instance As PrinterCollection
Dim value As Integer

value = instance.Count
public override int Count {get;}
public: __property int get_Count() override;
public:
property int Count {
   int get() override;
}

Property Value

An integer value which represents the number of printer objects in the collection.

Remarks

The default value is 0.

See Also

Reference

PrinterCollection Class
PrinterCollection Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
IsSynchronized Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrinterCollection Class : IsSynchronized Property

Glossary Item Box

Gets a value indicating whether access to the collection is synchronized (thread safe).

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property IsSynchronized As Boolean
'Usage

Dim instance As PrinterCollection
Dim value As Boolean

value = instance.IsSynchronized
public bool IsSynchronized {get;}
public: __property bool get_IsSynchronized();
public:
property bool IsSynchronized {
   bool get();
}

Property Value

A boolean value which is true if access to the collection is synchronized. Otherwise, false is used.

See Also

Reference

PrinterCollection Class
PrinterCollection Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Item Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrinterCollection Class : Item Property

Glossary Item Box

Gets a Printer object which matches the given index value.

Overload List

Overload | Description
Item(Int32) | Gets a Printer object which matches the given index value.
Item(String) | Gets a printer from the given name.

See Also

Reference

PrinterCollection Class
PrinterCollection Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Item(Int32) Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrinterCollection Class > Item Property : Item(Int32) Property

index
An integer value which represents the index of the printer to return from the collection.

Glossary Item Box

Gets a Printer object which matches the given index value.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads ReadOnly Property Item( _
   ByVal index As Integer _
) As Printer
'Usage

Dim instance As PrinterCollection
Dim index As Integer
Dim value As Printer

value = instance.Item(index)
public Printer Item(
   int index
) {get;}
public: __property Printer* get_Item(
   int index
);
public:
property Printer^ Item {
   Printer^ get(int index);
}

Parameters

index
An integer value which represents the index of the printer to return from the collection.

Property Value

A Printer object which matches the given index.

See Also

Reference

PrinterCollection Class
PrinterCollection Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Item(String) Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrinterCollection Class > Item Property : Item(String) Property

index
A string which represents the name of the printer.

Glossary Item Box

Gets a printer from the given name.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads ReadOnly Property Item( _
   ByVal index As String _
) As Printer
'Usage

Dim instance As PrinterCollection
Dim index As String
Dim value As Printer

value = instance.Item(index)
public Printer Item(
   string index
) {get;}
public: __property Printer* get_Item(
   string* index
);
public:
property Printer^ Item {
   Printer^ get(String^ index);
}

Parameters

index
A string which represents the name of the printer.

Property Value

A Printer which matches the given index name value.The printer at specified index.

See Also

Reference

PrinterCollection Class
PrinterCollection Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
SyncRoot Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrinterCollection Class : SyncRoot Property

Glossary Item Box

Gets an object to be used for thread synchronization.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property SyncRoot As Object
'Usage

Dim instance As PrinterCollection
Dim value As Object

value = instance.SyncRoot
public object SyncRoot {get;}
public: __property Object* get_SyncRoot();
public:
property Object^ SyncRoot {
   Object^ get();
}

Property Value

An object used for thread synchronization.

See Also

Reference

PrinterCollection Class
PrinterCollection Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrinterDriverFailureException Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : PrinterDriverFailureException Class

Glossary Item Box

This exception is thrown if a printer driver failure occurs.

Object Model

PrinterDriverFailureException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class PrinterDriverFailureException
   Inherits PrintProException
'Usage

Dim instance As PrinterDriverFailureException
[SerializableAttribute()]
public sealed class PrinterDriverFailureException : PrintProException
[SerializableAttribute()]
public __gc __sealed class PrinterDriverFailureException : public PrintProException
[SerializableAttribute()]
public ref class PrinterDriverFailureException sealed : public PrintProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.PrintProSdk.PrintProException
Accusoft.PrintProSdk.PrinterDriverFailureException

See Also

Reference

PrinterDriverFailureException Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
PrinterDriverFailureException Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : PrinterDriverFailureException Class

Glossary Item Box

The following tables list the members exposed by PrinterDriverFailureException.

Public Constructors

 | Name | Description
Public Constructor | PrinterDriverFailureException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

PrinterDriverFailureException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
PrinterDriverFailureException Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : PrinterDriverFailureException Class

Glossary Item Box

For a list of all members of this type, see PrinterDriverFailureException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

PrinterDriverFailureException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
PrinterDriverFailureException Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : PrinterDriverFailureException Class

Glossary Item Box

For a list of all members of this type, see PrinterDriverFailureException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

PrinterDriverFailureException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrinterDriverFailureException Constructor
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrinterDriverFailureException Class : PrinterDriverFailureException Constructor

Glossary Item Box

Overload List

Overload | Description
PrinterDriverFailureException Constructor() | An exception generated for a printer driver failure error.
PrinterDriverFailureException Constructor(Int32) | Generated exception for a printer driver failure error with a given error number.
PrinterDriverFailureException Constructor(String) | Generated exception for a printer driver failure error with a given string.
PrinterDriverFailureException Constructor(Int32,String) | Generated exception for a printer driver failure error with a given error number and message.
PrinterDriverFailureException Constructor(String,Exception) | Generated exception for a printer driver failure error with a given message and inner exception.

See Also

Reference

PrinterDriverFailureException Class
PrinterDriverFailureException Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrinterDriverFailureException Constructor()
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrinterDriverFailureException Class > PrinterDriverFailureException Constructor : PrinterDriverFailureException Constructor()

Glossary Item Box

An exception generated for a printer driver failure error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PrinterDriverFailureException()
public PrinterDriverFailureException()
public: PrinterDriverFailureException();
public:
PrinterDriverFailureException();

See Also

Reference

PrinterDriverFailureException Class
PrinterDriverFailureException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrinterDriverFailureException Constructor(Int32)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrinterDriverFailureException Class > PrinterDriverFailureException Constructor : PrinterDriverFailureException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a printer driver failure error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New PrinterDriverFailureException(errorNumber)
public PrinterDriverFailureException(
   int errorNumber
)
public: PrinterDriverFailureException(
   int errorNumber
)
public:
PrinterDriverFailureException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

PrinterDriverFailureException Class
PrinterDriverFailureException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrinterDriverFailureException Constructor(String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrinterDriverFailureException Class > PrinterDriverFailureException Constructor : PrinterDriverFailureException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a printer driver failure error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New PrinterDriverFailureException(message)
public PrinterDriverFailureException(
   string message
)
public: PrinterDriverFailureException(
   string* message
)
public:
PrinterDriverFailureException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

PrinterDriverFailureException Class
PrinterDriverFailureException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrinterDriverFailureException Constructor(Int32,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrinterDriverFailureException Class > PrinterDriverFailureException Constructor : PrinterDriverFailureException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a printer driver failure error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New PrinterDriverFailureException(errorNumber, message)
public PrinterDriverFailureException(
   int errorNumber,
   string message
)
public: PrinterDriverFailureException(
   int errorNumber,
   string* message
)
public:
PrinterDriverFailureException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

PrinterDriverFailureException Class
PrinterDriverFailureException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrinterDriverFailureException Constructor(String,Exception)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrinterDriverFailureException Class > PrinterDriverFailureException Constructor : PrinterDriverFailureException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a printer driver failure error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New PrinterDriverFailureException(message, innerException)
public PrinterDriverFailureException(
   string message,
   Exception innerException
)
public: PrinterDriverFailureException(
   string* message,
   Exception* innerException
)
public:
PrinterDriverFailureException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

PrinterDriverFailureException Class
PrinterDriverFailureException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrinterEnumerator Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : PrinterEnumerator Class

Glossary Item Box

This class implements an enumerator that can be used to iterate through a collection of printers.

Object Model

PrinterEnumerator ClassPrinter ClassPrinter ClassPrinter ClassPaper ClassPaperBin ClassPaperBinCollection ClassPaperBin ClassPaperCollection ClassPaper ClassPrintQuality ClassPrintingUnit StructurePrinter ClassPaper ClassPaperBin ClassPaperBinCollection ClassPaperBin ClassPaperCollection ClassPaper ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintingUnit StructurePrinter ClassPrinter ClassPaper ClassPaperBin ClassPaperBinCollection ClassPaperBin ClassPaperCollection ClassPaper ClassPrintQuality ClassPrintingUnit StructurePrinter Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Class PrinterEnumerator
'Usage

Dim instance As PrinterEnumerator
public class PrinterEnumerator
public __gc class PrinterEnumerator
public ref class PrinterEnumerator

Inheritance Hierarchy

System.Object
Accusoft.PrintProSdk.PrinterEnumerator

See Also

Reference

PrinterEnumerator Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
PrinterEnumerator Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : PrinterEnumerator Class

Glossary Item Box

The following tables list the members exposed by PrinterEnumerator.

Public Properties

 | Name | Description
Public Property | Current | Gets the current Printer the enumerator is on in the collection.
Top

Public Methods

 | Name | Description
Public Method | Dispose | Disposes of the collection object when it is done being used.
Public Method | MoveNext | Used to move to the next printer in the collection.
Public Method | Reset | Resets the collection to the first Printer in the collection.
Top

See Also

Reference

PrinterEnumerator Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
PrinterEnumerator Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : PrinterEnumerator Class

Glossary Item Box

For a list of all members of this type, see PrinterEnumerator members.

Public Methods

 | Name | Description
Public Method | Dispose | Disposes of the collection object when it is done being used.
Public Method | MoveNext | Used to move to the next printer in the collection.
Public Method | Reset | Resets the collection to the first Printer in the collection.
Top

See Also

Reference

PrinterEnumerator Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Dispose() Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrinterEnumerator Class : Dispose() Method

Glossary Item Box

Disposes of the collection object when it is done being used.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub Dispose()
'Usage

Dim instance As PrinterEnumerator

instance.Dispose()
public void Dispose()
public: void Dispose();
public:
void Dispose();

See Also

Reference

PrinterEnumerator Class
PrinterEnumerator Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
MoveNext Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrinterEnumerator Class : MoveNext Method

Glossary Item Box

Used to move to the next printer in the collection.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function MoveNext() As Boolean
'Usage

Dim instance As PrinterEnumerator
Dim value As Boolean

value = instance.MoveNext()
public bool MoveNext()
public: bool MoveNext();
public:
bool MoveNext();

Return Value

A boolean value which is true if there was another printer in the collection and the change was successful. Otherwise, false is returned.

See Also

Reference

PrinterEnumerator Class
PrinterEnumerator Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Reset Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrinterEnumerator Class : Reset Method

Glossary Item Box

Resets the collection to the first Printer in the collection.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub Reset()
'Usage

Dim instance As PrinterEnumerator

instance.Reset()
public void Reset()
public: void Reset();
public:
void Reset();

See Also

Reference

PrinterEnumerator Class
PrinterEnumerator Members


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
PrinterEnumerator Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : PrinterEnumerator Class

Glossary Item Box

For a list of all members of this type, see PrinterEnumerator members.

Public Properties

 | Name | Description
Public Property | Current | Gets the current Printer the enumerator is on in the collection.
Top

See Also

Reference

PrinterEnumerator Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Dispose Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrinterEnumerator Class : Dispose Method

Glossary Item Box

Disposes of the collection object when it is done being used.

Overload List

Overload | Description
Dispose | Disposes of the collection object when it is done being used.

See Also

Reference

PrinterEnumerator Class
PrinterEnumerator Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Current Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrinterEnumerator Class : Current Property

Glossary Item Box

Gets the current Printer the enumerator is on in the collection.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property Current As Printer
'Usage

Dim instance As PrinterEnumerator
Dim value As Printer

value = instance.Current
public Printer Current {get;}
public: __property Printer* get_Current();
public:
property Printer^ Current {
   Printer^ get();
}

Property Value

A Printer which matches the enumerator is on currently within the collection.

See Also

Reference

PrinterEnumerator Class
PrinterEnumerator Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintingDisabledException Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : PrintingDisabledException Class

Glossary Item Box

This exception is thrown if printing is disabled.

Object Model

PrintingDisabledException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class PrintingDisabledException
   Inherits PrintProException
'Usage

Dim instance As PrintingDisabledException
[SerializableAttribute()]
public sealed class PrintingDisabledException : PrintProException
[SerializableAttribute()]
public __gc __sealed class PrintingDisabledException : public PrintProException
[SerializableAttribute()]
public ref class PrintingDisabledException sealed : public PrintProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.PrintProSdk.PrintProException
Accusoft.PrintProSdk.PrintingDisabledException

See Also

Reference

PrintingDisabledException Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
PrintingDisabledException Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : PrintingDisabledException Class

Glossary Item Box

The following tables list the members exposed by PrintingDisabledException.

Public Constructors

 | Name | Description
Public Constructor | PrintingDisabledException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

PrintingDisabledException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
PrintingDisabledException Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : PrintingDisabledException Class

Glossary Item Box

For a list of all members of this type, see PrintingDisabledException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

PrintingDisabledException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
PrintingDisabledException Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : PrintingDisabledException Class

Glossary Item Box

For a list of all members of this type, see PrintingDisabledException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

PrintingDisabledException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintingDisabledException Constructor
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintingDisabledException Class : PrintingDisabledException Constructor

Glossary Item Box

Overload List

Overload | Description
PrintingDisabledException Constructor() | An exception generated for a printing disabled error.
PrintingDisabledException Constructor(Int32) | Generated exception for a printing disabled error with a given error number.
PrintingDisabledException Constructor(String) | Generated exception for a printing disabled error with a given string.
PrintingDisabledException Constructor(Int32,String) | Generated exception for a printing disabled error with a given error number and message.
PrintingDisabledException Constructor(String,Exception) | Generated exception for a printing disabled error with a given message and inner exception.

See Also

Reference

PrintingDisabledException Class
PrintingDisabledException Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintingDisabledException Constructor()
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintingDisabledException Class > PrintingDisabledException Constructor : PrintingDisabledException Constructor()

Glossary Item Box

An exception generated for a printing disabled error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PrintingDisabledException()
public PrintingDisabledException()
public: PrintingDisabledException();
public:
PrintingDisabledException();

See Also

Reference

PrintingDisabledException Class
PrintingDisabledException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintingDisabledException Constructor(Int32)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintingDisabledException Class > PrintingDisabledException Constructor : PrintingDisabledException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a printing disabled error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New PrintingDisabledException(errorNumber)
public PrintingDisabledException(
   int errorNumber
)
public: PrintingDisabledException(
   int errorNumber
)
public:
PrintingDisabledException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

PrintingDisabledException Class
PrintingDisabledException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintingDisabledException Constructor(String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintingDisabledException Class > PrintingDisabledException Constructor : PrintingDisabledException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a printing disabled error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New PrintingDisabledException(message)
public PrintingDisabledException(
   string message
)
public: PrintingDisabledException(
   string* message
)
public:
PrintingDisabledException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

PrintingDisabledException Class
PrintingDisabledException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintingDisabledException Constructor(Int32,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintingDisabledException Class > PrintingDisabledException Constructor : PrintingDisabledException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a printing disabled error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New PrintingDisabledException(errorNumber, message)
public PrintingDisabledException(
   int errorNumber,
   string message
)
public: PrintingDisabledException(
   int errorNumber,
   string* message
)
public:
PrintingDisabledException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

PrintingDisabledException Class
PrintingDisabledException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintingDisabledException Constructor(String,Exception)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintingDisabledException Class > PrintingDisabledException Constructor : PrintingDisabledException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a printing disabled error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New PrintingDisabledException(message, innerException)
public PrintingDisabledException(
   string message,
   Exception innerException
)
public: PrintingDisabledException(
   string* message,
   Exception* innerException
)
public:
PrintingDisabledException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

PrintingDisabledException Class
PrintingDisabledException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintJob Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : PrintJob Class

Glossary Item Box

This class implements a normal print job.

Object Model

PrintJob ClassDraw ClassIcm ClassPrinter ClassPrinter ClassPrinter ClassPaper ClassPaperBin ClassPaperBinCollection ClassPaperBin ClassPaperCollection ClassPaper ClassPrintQuality ClassPrintingUnit StructurePrinter ClassPaper ClassPaperBin ClassPaperBinCollection ClassPaperBin ClassPaperCollection ClassPaper ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintingUnit StructurePrinter ClassPrinter ClassPaper ClassPaperBin ClassPaperBinCollection ClassPaperBin ClassPaperCollection ClassPaper ClassPrintQuality ClassPrintingUnit StructurePrinter Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Class PrintJob
'Usage

Dim instance As PrintJob
public class PrintJob
public __gc class PrintJob
public ref class PrintJob

Inheritance Hierarchy

System.Object
Accusoft.PrintProSdk.PrintJob
Accusoft.PrintProSdk.PrintPreviewJob

See Also

Reference

PrintJob Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
PrintJob Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : PrintJob Class

Glossary Item Box

The following tables list the members exposed by PrintJob.

Public Constructors

 | Name | Description
Public Constructor | PrintJob Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | BottomMargin | Gets or sets the distance between the bottom of the physical page and the bottom of the printable area in units of the Printer's PrintUnits.
Public Property | DisplayX | Gets the horizontal coordinate of the display area in printer units defined by the PrintPreviewScale property. Not available at design time.
Public Property | DisplayY | Gets the vertical coordinate of the display area in printer units defined by the PrintPreviewScale property.
Public Property | Draw | Gets a pseudo object used to contain all of the drawing methods.
Public Property | Icm | Gets the Image Color Management values that the print job is using.
Public Property | LeftMargin | Gets or sets the distance between the left of the physical page and the left of the printable area in units of the Printer's PrintUnits.
Public Property | Name | Gets the document name for the print job. Note that setting this property will have no affect on the print job and instead the PrintJob or PrintPreviewJob constructor should be used to specify the document name. The setting of this property will be deprecated and this property will be read-only in a future version.
Public Property | Page | Gets the current page number of the document for the print job.
Public Property | PaperHeight | Gets the physical height of the paper set up for the printing device, in units determined by the PrintPreviewScale property.
Public Property | PaperWidth | Gets the physical width of the paper set up for the printing device, in units determined by the PrintPreviewScale property.
Public Property | Printer | Gets the Printer the print job is using.
Public Property | PrintHeight | Gets the printable height of the paper set up for the printing device, in units determined by the PrintPreviewScale property.
Public Property | PrintWidth | Gets the printable width of the paper set up for the printing device, in units determined by the PrintPreviewScale property.
Public Property | TemplateFileName | Gets and sets the photograph collage description filename.
Public Property | TopMargin | Gets or sets the distance between the top of the physical page and the top of the printable area in units of the Printer's PrintUnits.
Public Property | UseHardwareMargins | Gets or sets the value to determine if the printer's hardware margins are used or if the margin values are calculated from the average of the printable area subtracted from the physical area.
Top

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. Forces destruction of the print job object.
Public Method | Finish | Releases the current document to the print device or spooler.
Public Method | GetGraphics | Returns a graphics object to the current page.
Public Method | Kill | Immediately terminates the current print job cancelling any operations that have been performed on it.
Public Method | NewPage | Starts a new page for printing.
Public Method | PrintBitmap | Overloaded. Draws a Bitmap on the printer.
Public Method | PrintDib | Overloaded. Draws a DIB on the printer.
Public Method | PrintImage | Overloaded. Draws an image on the printer.
Public Method | PrintTemplateBitmap | Draws a bitmap image on a printer using details provided by the template file.
Public Method | PrintTemplateDib | Draws a DIB image on a printer using details provided by the template file.
Public Method | PrintTemplateImage | Draws an image on a printer using details provided by the template file.
Top

See Also

Reference

PrintJob Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
PrintJob Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : PrintJob Class

Glossary Item Box

For a list of all members of this type, see PrintJob members.

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. Forces destruction of the print job object.
Public Method | Finish | Releases the current document to the print device or spooler.
Public Method | GetGraphics | Returns a graphics object to the current page.
Public Method | Kill | Immediately terminates the current print job cancelling any operations that have been performed on it.
Public Method | NewPage | Starts a new page for printing.
Public Method | PrintBitmap | Overloaded. Draws a Bitmap on the printer.
Public Method | PrintDib | Overloaded. Draws a DIB on the printer.
Public Method | PrintImage | Overloaded. Draws an image on the printer.
Public Method | PrintTemplateBitmap | Draws a bitmap image on a printer using details provided by the template file.
Public Method | PrintTemplateDib | Draws a DIB image on a printer using details provided by the template file.
Public Method | PrintTemplateImage | Draws an image on a printer using details provided by the template file.
Top

See Also

Reference

PrintJob Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintJob Constructor
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintJob Class : PrintJob Constructor

Glossary Item Box

Overload List

Overload | Description
PrintJob Constructor(PrintPro) | Creates a new print job using the default printer.
PrintJob Constructor(PrintPro,Boolean) | Creates a new print job using the default printer.
PrintJob Constructor(PrintPro,Icm) | Creates a new print job using the default printer and specified image color management object for image color management settings.
PrintJob Constructor(PrintPro,String) | Creates a new print job using the default printer and the specified name.
PrintJob Constructor(PrintPro,Icm,Boolean) | Creates a new print job using the default printer and specified image color management object for image color management settings.
PrintJob Constructor(PrintPro,Icm,String) | Creates a new print job using the default printer, specified image color management object for image color management settings, and specified name.
PrintJob Constructor(PrintPro,Boolean,String) | Creates a new print job using the default printer and the specified name.
PrintJob Constructor(PrintPro,Icm,Boolean,String) | Creates a new print job using the default printer, specified image color management object for image color management settings, and specified name.
PrintJob Constructor(Printer) | Creates a new print job using the specified printer for the destination.
PrintJob Constructor(Printer,Boolean) | Creates a new print job using the specified printer for the destination.
PrintJob Constructor(Printer,Icm) | Creates a new print job using the specified printer for the destination.
PrintJob Constructor(Printer,String) | Creates a new print job using the specified printer for the destination.
PrintJob Constructor(Printer,Icm,Boolean) | Creates a new print job using the specified printer for the destination.
PrintJob Constructor(Printer,Icm,String) | Creates a new print job using the specified printer for the destination.
PrintJob Constructor(Printer,Boolean,String) | Creates a new print job using the specified printer for the destination.
PrintJob Constructor(Printer,Icm,Boolean,String) | Creates a new print job using the specified printer for the destination.
PrintJob Constructor(PrintPro,Printer) | Creates a new print job using the specified printer for the destination.
PrintJob Constructor(PrintPro,Printer,Boolean) | Creates a new print job using the specified printer for the destination.
PrintJob Constructor(PrintPro,Printer,Icm) | Creates a new print job using the specified printer for the destination.
PrintJob Constructor(PrintPro,Printer,String) | Creates a new print job using the specified printer for the destination.
PrintJob Constructor(PrintPro,Printer,Icm,Boolean) | Creates a new print job using the specified printer for the destination.
PrintJob Constructor(PrintPro,Printer,Boolean,String) | Creates a new print job using the specified printer for the destination.
PrintJob Constructor(PrintPro,Printer,Icm,String) | Creates a new print job using the specified printer for the destination.
PrintJob Constructor(PrintPro,Printer,Icm,Boolean,String) | Creates a new print job using the specified printer for the destination.

See Also

Reference

PrintJob Class
PrintJob Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintJob Constructor(PrintPro)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintJob Class > PrintJob Constructor : PrintJob Constructor(PrintPro)

printProWorkspace
The PrintPro workspace object to obtain the default printer from.

Glossary Item Box

Creates a new print job using the default printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printProWorkspace As PrintPro _
)
'Usage

Dim printProWorkspace As PrintPro

Dim instance As New PrintJob(printProWorkspace)
public PrintJob(
   PrintPro printProWorkspace
)
public: PrintJob(
   PrintPro* printProWorkspace
)
public:
PrintJob(
   PrintPro^ printProWorkspace
)

Parameters

printProWorkspace
The PrintPro workspace object to obtain the default printer from.

See Also

Reference

PrintJob Class
PrintJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintJob Constructor(PrintPro,Boolean)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintJob Class > PrintJob Constructor : PrintJob Constructor(PrintPro,Boolean)

printProWorkspace
The PrintPro workspace object to obtain the default printer from.
useHardwareMargins
A boolean value which represents the initial setting for whether or not to use hardware margins when printing.

Glossary Item Box

Creates a new print job using the default printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printProWorkspace As PrintPro, _
   ByVal useHardwareMargins As Boolean _
)
'Usage

Dim printProWorkspace As PrintPro
Dim useHardwareMargins As Boolean

Dim instance As New PrintJob(printProWorkspace, useHardwareMargins)
public PrintJob(
   PrintPro printProWorkspace,
   bool useHardwareMargins
)
public: PrintJob(
   PrintPro* printProWorkspace,
   bool useHardwareMargins
)
public:
PrintJob(
   PrintPro^ printProWorkspace,
   bool useHardwareMargins
)

Parameters

printProWorkspace
The PrintPro workspace object to obtain the default printer from.
useHardwareMargins
A boolean value which represents the initial setting for whether or not to use hardware margins when printing.

See Also

Reference

PrintJob Class
PrintJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintJob Constructor(PrintPro,Icm)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintJob Class > PrintJob Constructor : PrintJob Constructor(PrintPro,Icm)

printProWorkspace
The PrintPro workspace object to obtain the default printer from.
imageColorManagement
The Icm image color management settings to use for the print job.

Glossary Item Box

Creates a new print job using the default printer and specified image color management object for image color management settings.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printProWorkspace As PrintPro, _
   ByVal imageColorManagement As Icm _
)
'Usage

Dim printProWorkspace As PrintPro
Dim imageColorManagement As Icm

Dim instance As New PrintJob(printProWorkspace, imageColorManagement)
public PrintJob(
   PrintPro printProWorkspace,
   Icm imageColorManagement
)
public: PrintJob(
   PrintPro* printProWorkspace,
   Icm* imageColorManagement
)
public:
PrintJob(
   PrintPro^ printProWorkspace,
   Icm^ imageColorManagement
)

Parameters

printProWorkspace
The PrintPro workspace object to obtain the default printer from.
imageColorManagement
The Icm image color management settings to use for the print job.

See Also

Reference

PrintJob Class
PrintJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintJob Constructor(PrintPro,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintJob Class > PrintJob Constructor : PrintJob Constructor(PrintPro,String)

printProWorkspace
The PrintPro workspace object to obtain the default printer from.
name
The name to use for the print job.

Glossary Item Box

Creates a new print job using the default printer and the specified name.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printProWorkspace As PrintPro, _
   ByVal name As String _
)
'Usage

Dim printProWorkspace As PrintPro
Dim name As String

Dim instance As New PrintJob(printProWorkspace, name)
public PrintJob(
   PrintPro printProWorkspace,
   string name
)
public: PrintJob(
   PrintPro* printProWorkspace,
   string* name
)
public:
PrintJob(
   PrintPro^ printProWorkspace,
   String^ name
)

Parameters

printProWorkspace
The PrintPro workspace object to obtain the default printer from.
name
The name to use for the print job.

See Also

Reference

PrintJob Class
PrintJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintJob Constructor(PrintPro,Icm,Boolean)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintJob Class > PrintJob Constructor : PrintJob Constructor(PrintPro,Icm,Boolean)

printProWorkspace
The PrintPro workspace object to obtain the default printer from.
imageColorManagement
The Icm image color management settings to use for the print job.
useHardwareMargins
A boolean value which is an indicator if the initial setting whether or not to use hardware margins when printing.

Glossary Item Box

Creates a new print job using the default printer and specified image color management object for image color management settings.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printProWorkspace As PrintPro, _
   ByVal imageColorManagement As Icm, _
   ByVal useHardwareMargins As Boolean _
)
'Usage

Dim printProWorkspace As PrintPro
Dim imageColorManagement As Icm
Dim useHardwareMargins As Boolean

Dim instance As New PrintJob(printProWorkspace, imageColorManagement, useHardwareMargins)
public PrintJob(
   PrintPro printProWorkspace,
   Icm imageColorManagement,
   bool useHardwareMargins
)
public: PrintJob(
   PrintPro* printProWorkspace,
   Icm* imageColorManagement,
   bool useHardwareMargins
)
public:
PrintJob(
   PrintPro^ printProWorkspace,
   Icm^ imageColorManagement,
   bool useHardwareMargins
)

Parameters

printProWorkspace
The PrintPro workspace object to obtain the default printer from.
imageColorManagement
The Icm image color management settings to use for the print job.
useHardwareMargins
A boolean value which is an indicator if the initial setting whether or not to use hardware margins when printing.

See Also

Reference

PrintJob Class
PrintJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintJob Constructor(PrintPro,Icm,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintJob Class > PrintJob Constructor : PrintJob Constructor(PrintPro,Icm,String)

printProWorkspace
The PrintPro workspace object to obtain the default printer from.
imageColorManagement
The Icm image color management settings to use for the print job.
name
The name to use for the print job.

Glossary Item Box

Creates a new print job using the default printer, specified image color management object for image color management settings, and specified name.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printProWorkspace As PrintPro, _
   ByVal imageColorManagement As Icm, _
   ByVal name As String _
)
'Usage

Dim printProWorkspace As PrintPro
Dim imageColorManagement As Icm
Dim name As String

Dim instance As New PrintJob(printProWorkspace, imageColorManagement, name)
public PrintJob(
   PrintPro printProWorkspace,
   Icm imageColorManagement,
   string name
)
public: PrintJob(
   PrintPro* printProWorkspace,
   Icm* imageColorManagement,
   string* name
)
public:
PrintJob(
   PrintPro^ printProWorkspace,
   Icm^ imageColorManagement,
   String^ name
)

Parameters

printProWorkspace
The PrintPro workspace object to obtain the default printer from.
imageColorManagement
The Icm image color management settings to use for the print job.
name
The name to use for the print job.

See Also

Reference

PrintJob Class
PrintJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintJob Constructor(PrintPro,Boolean,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintJob Class > PrintJob Constructor : PrintJob Constructor(PrintPro,Boolean,String)

printProWorkspace
The PrintPro workspace object to obtain the default printer from.
useHardwareMargins
A boolean value which is an indicator if the initial setting whether or not to use hardware margins when printing.
name
The name to use for the print job.

Glossary Item Box

Creates a new print job using the default printer and the specified name.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printProWorkspace As PrintPro, _
   ByVal useHardwareMargins As Boolean, _
   ByVal name As String _
)
'Usage

Dim printProWorkspace As PrintPro
Dim useHardwareMargins As Boolean
Dim name As String

Dim instance As New PrintJob(printProWorkspace, useHardwareMargins, name)
public PrintJob(
   PrintPro printProWorkspace,
   bool useHardwareMargins,
   string name
)
public: PrintJob(
   PrintPro* printProWorkspace,
   bool useHardwareMargins,
   string* name
)
public:
PrintJob(
   PrintPro^ printProWorkspace,
   bool useHardwareMargins,
   String^ name
)

Parameters

printProWorkspace
The PrintPro workspace object to obtain the default printer from.
useHardwareMargins
A boolean value which is an indicator if the initial setting whether or not to use hardware margins when printing.
name
The name to use for the print job.

See Also

Reference

PrintJob Class
PrintJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintJob Constructor(PrintPro,Icm,Boolean,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintJob Class > PrintJob Constructor : PrintJob Constructor(PrintPro,Icm,Boolean,String)

printProWorkspace
The PrintPro workspace object to obtain the default printer from.
imageColorManagement
The Icm image color management settings to use for the print job.
useHardwareMargins
A boolean value which is an indicator if the initial setting whether or not to use hardware margins when printing.
name
The name to use for the print job.

Glossary Item Box

Creates a new print job using the default printer, specified image color management object for image color management settings, and specified name.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printProWorkspace As PrintPro, _
   ByVal imageColorManagement As Icm, _
   ByVal useHardwareMargins As Boolean, _
   ByVal name As String _
)
'Usage

Dim printProWorkspace As PrintPro
Dim imageColorManagement As Icm
Dim useHardwareMargins As Boolean
Dim name As String

Dim instance As New PrintJob(printProWorkspace, imageColorManagement, useHardwareMargins, name)
public PrintJob(
   PrintPro printProWorkspace,
   Icm imageColorManagement,
   bool useHardwareMargins,
   string name
)
public: PrintJob(
   PrintPro* printProWorkspace,
   Icm* imageColorManagement,
   bool useHardwareMargins,
   string* name
)
public:
PrintJob(
   PrintPro^ printProWorkspace,
   Icm^ imageColorManagement,
   bool useHardwareMargins,
   String^ name
)

Parameters

printProWorkspace
The PrintPro workspace object to obtain the default printer from.
imageColorManagement
The Icm image color management settings to use for the print job.
useHardwareMargins
A boolean value which is an indicator if the initial setting whether or not to use hardware margins when printing.
name
The name to use for the print job.

See Also

Reference

PrintJob Class
PrintJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintJob Constructor(Printer)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintJob Class > PrintJob Constructor : PrintJob Constructor(Printer)

printer
The Printer the print job is to print to.

Glossary Item Box

Creates a new print job using the specified printer for the destination.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printer As Printer _
)
'Usage

Dim printer As Printer

Dim instance As New PrintJob(printer)
public PrintJob(
   Printer printer
)
public: PrintJob(
   Printer* printer
)
public:
PrintJob(
   Printer^ printer
)

Parameters

printer
The Printer the print job is to print to.

See Also

Reference

PrintJob Class
PrintJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintJob Constructor(Printer,Boolean)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintJob Class > PrintJob Constructor : PrintJob Constructor(Printer,Boolean)

printer
The Printer the print job is to print to.
useHardwareMargins
The initial setting for whether or not to use hardware margins when printing.

Glossary Item Box

Creates a new print job using the specified printer for the destination.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printer As Printer, _
   ByVal useHardwareMargins As Boolean _
)
'Usage

Dim printer As Printer
Dim useHardwareMargins As Boolean

Dim instance As New PrintJob(printer, useHardwareMargins)
public PrintJob(
   Printer printer,
   bool useHardwareMargins
)
public: PrintJob(
   Printer* printer,
   bool useHardwareMargins
)
public:
PrintJob(
   Printer^ printer,
   bool useHardwareMargins
)

Parameters

printer
The Printer the print job is to print to.
useHardwareMargins
The initial setting for whether or not to use hardware margins when printing.

See Also

Reference

PrintJob Class
PrintJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintJob Constructor(Printer,Icm)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintJob Class > PrintJob Constructor : PrintJob Constructor(Printer,Icm)

printer
The Printer the print job is to print to.
imageColorManagement
The Icm image color management settings to use for the print job.

Glossary Item Box

Creates a new print job using the specified printer for the destination.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printer As Printer, _
   ByVal imageColorManagement As Icm _
)
'Usage

Dim printer As Printer
Dim imageColorManagement As Icm

Dim instance As New PrintJob(printer, imageColorManagement)
public PrintJob(
   Printer printer,
   Icm imageColorManagement
)
public: PrintJob(
   Printer* printer,
   Icm* imageColorManagement
)
public:
PrintJob(
   Printer^ printer,
   Icm^ imageColorManagement
)

Parameters

printer
The Printer the print job is to print to.
imageColorManagement
The Icm image color management settings to use for the print job.

See Also

Reference

PrintJob Class
PrintJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintJob Constructor(Printer,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintJob Class > PrintJob Constructor : PrintJob Constructor(Printer,String)

printer
The Printer the print job is to print to.
name
The name to use for the print job.

Glossary Item Box

Creates a new print job using the specified printer for the destination.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printer As Printer, _
   ByVal name As String _
)
'Usage

Dim printer As Printer
Dim name As String

Dim instance As New PrintJob(printer, name)
public PrintJob(
   Printer printer,
   string name
)
public: PrintJob(
   Printer* printer,
   string* name
)
public:
PrintJob(
   Printer^ printer,
   String^ name
)

Parameters

printer
The Printer the print job is to print to.
name
The name to use for the print job.

See Also

Reference

PrintJob Class
PrintJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintJob Constructor(Printer,Icm,Boolean)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintJob Class > PrintJob Constructor : PrintJob Constructor(Printer,Icm,Boolean)

printer
The Printer the print job is to print to.
imageColorManagement
The Icm image color management settings to use for the print job.
useHardwareMargins
A boolean value which determines whether or not to use hardware margins when printing.

Glossary Item Box

Creates a new print job using the specified printer for the destination.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printer As Printer, _
   ByVal imageColorManagement As Icm, _
   ByVal useHardwareMargins As Boolean _
)
'Usage

Dim printer As Printer
Dim imageColorManagement As Icm
Dim useHardwareMargins As Boolean

Dim instance As New PrintJob(printer, imageColorManagement, useHardwareMargins)
public PrintJob(
   Printer printer,
   Icm imageColorManagement,
   bool useHardwareMargins
)
public: PrintJob(
   Printer* printer,
   Icm* imageColorManagement,
   bool useHardwareMargins
)
public:
PrintJob(
   Printer^ printer,
   Icm^ imageColorManagement,
   bool useHardwareMargins
)

Parameters

printer
The Printer the print job is to print to.
imageColorManagement
The Icm image color management settings to use for the print job.
useHardwareMargins
A boolean value which determines whether or not to use hardware margins when printing.

See Also

Reference

PrintJob Class
PrintJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintJob Constructor(Printer,Icm,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintJob Class > PrintJob Constructor : PrintJob Constructor(Printer,Icm,String)

printer
The Printer the print job is to print to.
imageColorManagement
The Icm image color management settings to use for the print job.
name
The name to use for the print job.

Glossary Item Box

Creates a new print job using the specified printer for the destination.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printer As Printer, _
   ByVal imageColorManagement As Icm, _
   ByVal name As String _
)
'Usage

Dim printer As Printer
Dim imageColorManagement As Icm
Dim name As String

Dim instance As New PrintJob(printer, imageColorManagement, name)
public PrintJob(
   Printer printer,
   Icm imageColorManagement,
   string name
)
public: PrintJob(
   Printer* printer,
   Icm* imageColorManagement,
   string* name
)
public:
PrintJob(
   Printer^ printer,
   Icm^ imageColorManagement,
   String^ name
)

Parameters

printer
The Printer the print job is to print to.
imageColorManagement
The Icm image color management settings to use for the print job.
name
The name to use for the print job.

See Also

Reference

PrintJob Class
PrintJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintJob Constructor(Printer,Boolean,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintJob Class > PrintJob Constructor : PrintJob Constructor(Printer,Boolean,String)

printer
The Printer the print job is to print to.
useHardwareMargins
The initial setting for whether or not to use hardware margins when printing.
name
The name to use for the print job.

Glossary Item Box

Creates a new print job using the specified printer for the destination.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printer As Printer, _
   ByVal useHardwareMargins As Boolean, _
   ByVal name As String _
)
'Usage

Dim printer As Printer
Dim useHardwareMargins As Boolean
Dim name As String

Dim instance As New PrintJob(printer, useHardwareMargins, name)
public PrintJob(
   Printer printer,
   bool useHardwareMargins,
   string name
)
public: PrintJob(
   Printer* printer,
   bool useHardwareMargins,
   string* name
)
public:
PrintJob(
   Printer^ printer,
   bool useHardwareMargins,
   String^ name
)

Parameters

printer
The Printer the print job is to print to.
useHardwareMargins
The initial setting for whether or not to use hardware margins when printing.
name
The name to use for the print job.

See Also

Reference

PrintJob Class
PrintJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintJob Constructor(Printer,Icm,Boolean,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintJob Class > PrintJob Constructor : PrintJob Constructor(Printer,Icm,Boolean,String)

printer
The Printer the print job is to print to.
imageColorManagement
The Icm image color management settings to use for the print job.
useHardwareMargins
A boolean value which determines whether or not to use hardware margins when printing.
name
The name to use for the print job.

Glossary Item Box

Creates a new print job using the specified printer for the destination.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printer As Printer, _
   ByVal imageColorManagement As Icm, _
   ByVal useHardwareMargins As Boolean, _
   ByVal name As String _
)
'Usage

Dim printer As Printer
Dim imageColorManagement As Icm
Dim useHardwareMargins As Boolean
Dim name As String

Dim instance As New PrintJob(printer, imageColorManagement, useHardwareMargins, name)
public PrintJob(
   Printer printer,
   Icm imageColorManagement,
   bool useHardwareMargins,
   string name
)
public: PrintJob(
   Printer* printer,
   Icm* imageColorManagement,
   bool useHardwareMargins,
   string* name
)
public:
PrintJob(
   Printer^ printer,
   Icm^ imageColorManagement,
   bool useHardwareMargins,
   String^ name
)

Parameters

printer
The Printer the print job is to print to.
imageColorManagement
The Icm image color management settings to use for the print job.
useHardwareMargins
A boolean value which determines whether or not to use hardware margins when printing.
name
The name to use for the print job.

See Also

Reference

PrintJob Class
PrintJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintJob Constructor(PrintPro,Printer)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintJob Class > PrintJob Constructor : PrintJob Constructor(PrintPro,Printer)

printProWorkspace
The PrintPro workspace object to use.
printer
The Printer the print job is to print to.

Glossary Item Box

Creates a new print job using the specified printer for the destination.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printProWorkspace As PrintPro, _
   ByVal printer As Printer _
)
'Usage

Dim printProWorkspace As PrintPro
Dim printer As Printer

Dim instance As New PrintJob(printProWorkspace, printer)
public PrintJob(
   PrintPro printProWorkspace,
   Printer printer
)
public: PrintJob(
   PrintPro* printProWorkspace,
   Printer* printer
)
public:
PrintJob(
   PrintPro^ printProWorkspace,
   Printer^ printer
)

Parameters

printProWorkspace
The PrintPro workspace object to use.
printer
The Printer the print job is to print to.

See Also

Reference

PrintJob Class
PrintJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintJob Constructor(PrintPro,Printer,Boolean)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintJob Class > PrintJob Constructor : PrintJob Constructor(PrintPro,Printer,Boolean)

printProWorkspace
The PrintPro workspace object to use.
printer
The Printer the print job is to print to.
useHardwareMargins
A boolean value which determines the initial setting for whether or not to use hardware margins when printing.

Glossary Item Box

Creates a new print job using the specified printer for the destination.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printProWorkspace As PrintPro, _
   ByVal printer As Printer, _
   ByVal useHardwareMargins As Boolean _
)
'Usage

Dim printProWorkspace As PrintPro
Dim printer As Printer
Dim useHardwareMargins As Boolean

Dim instance As New PrintJob(printProWorkspace, printer, useHardwareMargins)
public PrintJob(
   PrintPro printProWorkspace,
   Printer printer,
   bool useHardwareMargins
)
public: PrintJob(
   PrintPro* printProWorkspace,
   Printer* printer,
   bool useHardwareMargins
)
public:
PrintJob(
   PrintPro^ printProWorkspace,
   Printer^ printer,
   bool useHardwareMargins
)

Parameters

printProWorkspace
The PrintPro workspace object to use.
printer
The Printer the print job is to print to.
useHardwareMargins
A boolean value which determines the initial setting for whether or not to use hardware margins when printing.

See Also

Reference

PrintJob Class
PrintJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintJob Constructor(PrintPro,Printer,Icm)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintJob Class > PrintJob Constructor : PrintJob Constructor(PrintPro,Printer,Icm)

printProWorkspace
The PrintPro workspace object to use.
printer
The Printer the print job is to print to.
imageColorManagement
The Icm image color management settings to use for the print job.

Glossary Item Box

Creates a new print job using the specified printer for the destination.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printProWorkspace As PrintPro, _
   ByVal printer As Printer, _
   ByVal imageColorManagement As Icm _
)
'Usage

Dim printProWorkspace As PrintPro
Dim printer As Printer
Dim imageColorManagement As Icm

Dim instance As New PrintJob(printProWorkspace, printer, imageColorManagement)
public PrintJob(
   PrintPro printProWorkspace,
   Printer printer,
   Icm imageColorManagement
)
public: PrintJob(
   PrintPro* printProWorkspace,
   Printer* printer,
   Icm* imageColorManagement
)
public:
PrintJob(
   PrintPro^ printProWorkspace,
   Printer^ printer,
   Icm^ imageColorManagement
)

Parameters

printProWorkspace
The PrintPro workspace object to use.
printer
The Printer the print job is to print to.
imageColorManagement
The Icm image color management settings to use for the print job.

See Also

Reference

PrintJob Class
PrintJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintJob Constructor(PrintPro,Printer,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintJob Class > PrintJob Constructor : PrintJob Constructor(PrintPro,Printer,String)

printProWorkspace
The PrintPro workspace object to use.
printer
The Printer the print job is to print to.
name
The name to use for the print job.

Glossary Item Box

Creates a new print job using the specified printer for the destination.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printProWorkspace As PrintPro, _
   ByVal printer As Printer, _
   ByVal name As String _
)
'Usage

Dim printProWorkspace As PrintPro
Dim printer As Printer
Dim name As String

Dim instance As New PrintJob(printProWorkspace, printer, name)
public PrintJob(
   PrintPro printProWorkspace,
   Printer printer,
   string name
)
public: PrintJob(
   PrintPro* printProWorkspace,
   Printer* printer,
   string* name
)
public:
PrintJob(
   PrintPro^ printProWorkspace,
   Printer^ printer,
   String^ name
)

Parameters

printProWorkspace
The PrintPro workspace object to use.
printer
The Printer the print job is to print to.
name
The name to use for the print job.

See Also

Reference

PrintJob Class
PrintJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintJob Constructor(PrintPro,Printer,Icm,Boolean)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintJob Class > PrintJob Constructor : PrintJob Constructor(PrintPro,Printer,Icm,Boolean)

printProWorkspace
The PrintPro workspace object to use.
printer
The Printer the print job is to print to.
imageColorManagement
The Icm image color management settings to use for the print job.
useHardwareMargins
The initial setting for whether or not to use hardware margins when printing.

Glossary Item Box

Creates a new print job using the specified printer for the destination.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printProWorkspace As PrintPro, _
   ByVal printer As Printer, _
   ByVal imageColorManagement As Icm, _
   ByVal useHardwareMargins As Boolean _
)
'Usage

Dim printProWorkspace As PrintPro
Dim printer As Printer
Dim imageColorManagement As Icm
Dim useHardwareMargins As Boolean

Dim instance As New PrintJob(printProWorkspace, printer, imageColorManagement, useHardwareMargins)
public PrintJob(
   PrintPro printProWorkspace,
   Printer printer,
   Icm imageColorManagement,
   bool useHardwareMargins
)
public: PrintJob(
   PrintPro* printProWorkspace,
   Printer* printer,
   Icm* imageColorManagement,
   bool useHardwareMargins
)
public:
PrintJob(
   PrintPro^ printProWorkspace,
   Printer^ printer,
   Icm^ imageColorManagement,
   bool useHardwareMargins
)

Parameters

printProWorkspace
The PrintPro workspace object to use.
printer
The Printer the print job is to print to.
imageColorManagement
The Icm image color management settings to use for the print job.
useHardwareMargins
The initial setting for whether or not to use hardware margins when printing.

See Also

Reference

PrintJob Class
PrintJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintJob Constructor(PrintPro,Printer,Boolean,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintJob Class > PrintJob Constructor : PrintJob Constructor(PrintPro,Printer,Boolean,String)

printProWorkspace
The PrintPro workspace object to use.
printer
The Printer the print job is to print to.
useHardwareMargins
A boolean value which determines the initial setting for whether or not to use hardware margins when printing.
name
The name to use for the print job.

Glossary Item Box

Creates a new print job using the specified printer for the destination.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printProWorkspace As PrintPro, _
   ByVal printer As Printer, _
   ByVal useHardwareMargins As Boolean, _
   ByVal name As String _
)
'Usage

Dim printProWorkspace As PrintPro
Dim printer As Printer
Dim useHardwareMargins As Boolean
Dim name As String

Dim instance As New PrintJob(printProWorkspace, printer, useHardwareMargins, name)
public PrintJob(
   PrintPro printProWorkspace,
   Printer printer,
   bool useHardwareMargins,
   string name
)
public: PrintJob(
   PrintPro* printProWorkspace,
   Printer* printer,
   bool useHardwareMargins,
   string* name
)
public:
PrintJob(
   PrintPro^ printProWorkspace,
   Printer^ printer,
   bool useHardwareMargins,
   String^ name
)

Parameters

printProWorkspace
The PrintPro workspace object to use.
printer
The Printer the print job is to print to.
useHardwareMargins
A boolean value which determines the initial setting for whether or not to use hardware margins when printing.
name
The name to use for the print job.

See Also

Reference

PrintJob Class
PrintJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintJob Constructor(PrintPro,Printer,Icm,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintJob Class > PrintJob Constructor : PrintJob Constructor(PrintPro,Printer,Icm,String)

printProWorkspace
The PrintPro workspace object to use.
printer
The Printer the print job is to print to.
imageColorManagement
The Icm image color management settings to use for the print job.
name
The name to use for the print job.

Glossary Item Box

Creates a new print job using the specified printer for the destination.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printProWorkspace As PrintPro, _
   ByVal printer As Printer, _
   ByVal imageColorManagement As Icm, _
   ByVal name As String _
)
'Usage

Dim printProWorkspace As PrintPro
Dim printer As Printer
Dim imageColorManagement As Icm
Dim name As String

Dim instance As New PrintJob(printProWorkspace, printer, imageColorManagement, name)
public PrintJob(
   PrintPro printProWorkspace,
   Printer printer,
   Icm imageColorManagement,
   string name
)
public: PrintJob(
   PrintPro* printProWorkspace,
   Printer* printer,
   Icm* imageColorManagement,
   string* name
)
public:
PrintJob(
   PrintPro^ printProWorkspace,
   Printer^ printer,
   Icm^ imageColorManagement,
   String^ name
)

Parameters

printProWorkspace
The PrintPro workspace object to use.
printer
The Printer the print job is to print to.
imageColorManagement
The Icm image color management settings to use for the print job.
name
The name to use for the print job.

See Also

Reference

PrintJob Class
PrintJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintJob Constructor(PrintPro,Printer,Icm,Boolean,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintJob Class > PrintJob Constructor : PrintJob Constructor(PrintPro,Printer,Icm,Boolean,String)

printProWorkspace
The PrintPro workspace object to use.
printer
The Printer the print job is to print to.
imageColorManagement
The Icm image color management settings to use for the print job.
useHardwareMargins
The initial setting for whether or not to use hardware margins when printing.
name
The name to use for the print job.

Glossary Item Box

Creates a new print job using the specified printer for the destination.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printProWorkspace As PrintPro, _
   ByVal printer As Printer, _
   ByVal imageColorManagement As Icm, _
   ByVal useHardwareMargins As Boolean, _
   ByVal name As String _
)
'Usage

Dim printProWorkspace As PrintPro
Dim printer As Printer
Dim imageColorManagement As Icm
Dim useHardwareMargins As Boolean
Dim name As String

Dim instance As New PrintJob(printProWorkspace, printer, imageColorManagement, useHardwareMargins, name)
public PrintJob(
   PrintPro printProWorkspace,
   Printer printer,
   Icm imageColorManagement,
   bool useHardwareMargins,
   string name
)
public: PrintJob(
   PrintPro* printProWorkspace,
   Printer* printer,
   Icm* imageColorManagement,
   bool useHardwareMargins,
   string* name
)
public:
PrintJob(
   PrintPro^ printProWorkspace,
   Printer^ printer,
   Icm^ imageColorManagement,
   bool useHardwareMargins,
   String^ name
)

Parameters

printProWorkspace
The PrintPro workspace object to use.
printer
The Printer the print job is to print to.
imageColorManagement
The Icm image color management settings to use for the print job.
useHardwareMargins
The initial setting for whether or not to use hardware margins when printing.
name
The name to use for the print job.

See Also

Reference

PrintJob Class
PrintJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Dispose Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintJob Class : Dispose Method

Glossary Item Box

Forces destruction of the print job object.

Overload List

Overload | Description
Dispose() | Forces destruction of the print job object.
Dispose(Boolean) | Forces destruction of the print job object.

See Also

Reference

PrintJob Class
PrintJob Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Dispose() Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintJob Class > Dispose Method : Dispose() Method

Glossary Item Box

Forces destruction of the print job object.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Dispose()
'Usage

Dim instance As PrintJob

instance.Dispose()
public void Dispose()
public: void Dispose();
public:
void Dispose();

Remarks

If Finish was not called prior to calling this, it is automatically called to finish the print job.

See Also

Reference

PrintJob Class
PrintJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Dispose(Boolean) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintJob Class > Dispose Method : Dispose(Boolean) Method

disposing
Determines whether actual disposition is done. If this value is false, Finish is not called and no changes are made.

Glossary Item Box

Forces destruction of the print job object.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Dispose( _
   ByVal disposing As Boolean _
)
'Usage

Dim instance As PrintJob
Dim disposing As Boolean

instance.Dispose(disposing)
public void Dispose(
   bool disposing
)
public: void Dispose(
   bool disposing
)
public:
void Dispose(
   bool disposing
)

Parameters

disposing
Determines whether actual disposition is done. If this value is false, Finish is not called and no changes are made.

Remarks

If Finish was not called prior to calling this, it is automatically called to finish the print job.

See Also

Reference

PrintJob Class
PrintJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Finish Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintJob Class : Finish Method

Glossary Item Box

Releases the current document to the print device or spooler.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overridable Sub Finish()
'Usage

Dim instance As PrintJob

instance.Finish()
public virtual void Finish()
public: virtual void Finish();
public:
virtual void Finish();

See Also

Reference

PrintJob Class
PrintJob Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
GetGraphics Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintJob Class : GetGraphics Method

Glossary Item Box

Returns a graphics object to the current page.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overridable Function GetGraphics() As Graphics
'Usage

Dim instance As PrintJob
Dim value As Graphics

value = instance.GetGraphics()
public virtual Graphics GetGraphics()
public: virtual Graphics* GetGraphics();
public:
virtual Graphics^ GetGraphics();

Return Value

A System.Drawing.Graphics object for the current page. You must call Dispose to release resources when drawing has finished.

Remarks

This allows for using native .NET drawing methods to print to the page.

See Also

Reference

PrintJob Class
PrintJob Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Kill Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintJob Class : Kill Method

Glossary Item Box

Immediately terminates the current print job cancelling any operations that have been performed on it.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub Kill()
'Usage

Dim instance As PrintJob

instance.Kill()
public void Kill()
public: void Kill();
public:
void Kill();

See Also

Reference

PrintJob Class
PrintJob Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
NewPage Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintJob Class : NewPage Method

Glossary Item Box

Starts a new page for printing.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub NewPage()
'Usage

Dim instance As PrintJob

instance.NewPage()
public void NewPage()
public: void NewPage();
public:
void NewPage();

See Also

Reference

PrintJob Class
PrintJob Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintBitmap Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintJob Class : PrintBitmap Method

Glossary Item Box

Draws a Bitmap on the printer.

Overload List

Overload | Description
PrintBitmap(Bitmap,PointF,SizeF,Boolean) | Draws a Bitmap on the printer.
PrintBitmap(Bitmap,PointF,SizeF,PointF,SizeF,Boolean) | Draws a Bitmap on the printer.
PrintBitmap(Bitmap,Single,Single,Single,Single,Boolean) | Draws a Bitmap on the printer.
PrintBitmap(Bitmap,Single,Single,Single,Single,Single,Single,Single,Single,Boolean) | Draws a Bitmap on the printer.

See Also

Reference

PrintJob Class
PrintJob Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintBitmap(Bitmap,PointF,SizeF,Boolean) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintJob Class > PrintBitmap Method : PrintBitmap(Bitmap,PointF,SizeF,Boolean) Method

bitmap
The bitmap object to draw.
destination
The location of the destination for the upper-left corner of the image data.
destinationSize
The destination size of the Image data.
aspect
A boolean value that when true, the destination size is adjusted to maintain the image data's aspect ratio.

Glossary Item Box

Draws a Bitmap on the printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub PrintBitmap( _
   ByVal bitmap As Bitmap, _
   ByVal destination As PointF, _
   ByVal destinationSize As SizeF, _
   ByVal aspect As Boolean _
)
'Usage

Dim instance As PrintJob
Dim bitmap As Bitmap
Dim destination As PointF
Dim destinationSize As SizeF
Dim aspect As Boolean

instance.PrintBitmap(bitmap, destination, destinationSize, aspect)
public void PrintBitmap(
   Bitmap bitmap,
   PointF destination,
   SizeF destinationSize,
   bool aspect
)
public: void PrintBitmap(
   Bitmap* bitmap,
   PointF destination,
   SizeF destinationSize,
   bool aspect
)
public:
void PrintBitmap(
   Bitmap^ bitmap,
   PointF destination,
   SizeF destinationSize,
   bool aspect
)

Parameters

bitmap
The bitmap object to draw.
destination
The location of the destination for the upper-left corner of the image data.
destinationSize
The destination size of the Image data.
aspect
A boolean value that when true, the destination size is adjusted to maintain the image data's aspect ratio.

See Also

Reference

PrintJob Class
PrintJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintBitmap(Bitmap,PointF,SizeF,PointF,SizeF,Boolean) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintJob Class > PrintBitmap Method : PrintBitmap(Bitmap,PointF,SizeF,PointF,SizeF,Boolean) Method

bitmap
The Bitmap object to draw.
source
The location in the source image of the upper-left of the source image data.
sourceSize
The source size of the image data.
destination
The location of the destination for the upper-left corner of the image data.
destinationSize
The destination size of the Image data.
aspect
A boolean value that when true, the destination size is adjusted to maintain the image data's aspect ratio.

Glossary Item Box

Draws a Bitmap on the printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub PrintBitmap( _
   ByVal bitmap As Bitmap, _
   ByVal source As PointF, _
   ByVal sourceSize As SizeF, _
   ByVal destination As PointF, _
   ByVal destinationSize As SizeF, _
   ByVal aspect As Boolean _
)
'Usage

Dim instance As PrintJob
Dim bitmap As Bitmap
Dim source As PointF
Dim sourceSize As SizeF
Dim destination As PointF
Dim destinationSize As SizeF
Dim aspect As Boolean

instance.PrintBitmap(bitmap, source, sourceSize, destination, destinationSize, aspect)
public void PrintBitmap(
   Bitmap bitmap,
   PointF source,
   SizeF sourceSize,
   PointF destination,
   SizeF destinationSize,
   bool aspect
)
public: void PrintBitmap(
   Bitmap* bitmap,
   PointF source,
   SizeF sourceSize,
   PointF destination,
   SizeF destinationSize,
   bool aspect
)
public:
void PrintBitmap(
   Bitmap^ bitmap,
   PointF source,
   SizeF sourceSize,
   PointF destination,
   SizeF destinationSize,
   bool aspect
)

Parameters

bitmap
The Bitmap object to draw.
source
The location in the source image of the upper-left of the source image data.
sourceSize
The source size of the image data.
destination
The location of the destination for the upper-left corner of the image data.
destinationSize
The destination size of the Image data.
aspect
A boolean value that when true, the destination size is adjusted to maintain the image data's aspect ratio.

See Also

Reference

PrintJob Class
PrintJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintBitmap(Bitmap,Single,Single,Single,Single,Boolean) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintJob Class > PrintBitmap Method : PrintBitmap(Bitmap,Single,Single,Single,Single,Boolean) Method

bitmap
The Bitmap object to draw.
destinationX
The X location of the destination for the upper-left corner of the image data.
destinationY
The Y location of the destination for the upper-left corner of the image data.
destinationWidth
The destination width of the Image data.
destinationHeight
The destination height of the Image data.
aspect
A boolean value that when true, the destination size is adjusted to maintain the image data's aspect ratio.

Glossary Item Box

Draws a Bitmap on the printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub PrintBitmap( _
   ByVal bitmap As Bitmap, _
   ByVal destinationX As Single, _
   ByVal destinationY As Single, _
   ByVal destinationWidth As Single, _
   ByVal destinationHeight As Single, _
   ByVal aspect As Boolean _
)
'Usage

Dim instance As PrintJob
Dim bitmap As Bitmap
Dim destinationX As Single
Dim destinationY As Single
Dim destinationWidth As Single
Dim destinationHeight As Single
Dim aspect As Boolean

instance.PrintBitmap(bitmap, destinationX, destinationY, destinationWidth, destinationHeight, aspect)
public void PrintBitmap(
   Bitmap bitmap,
   float destinationX,
   float destinationY,
   float destinationWidth,
   float destinationHeight,
   bool aspect
)
public: void PrintBitmap(
   Bitmap* bitmap,
   float destinationX,
   float destinationY,
   float destinationWidth,
   float destinationHeight,
   bool aspect
)
public:
void PrintBitmap(
   Bitmap^ bitmap,
   float destinationX,
   float destinationY,
   float destinationWidth,
   float destinationHeight,
   bool aspect
)

Parameters

bitmap
The Bitmap object to draw.
destinationX
The X location of the destination for the upper-left corner of the image data.
destinationY
The Y location of the destination for the upper-left corner of the image data.
destinationWidth
The destination width of the Image data.
destinationHeight
The destination height of the Image data.
aspect
A boolean value that when true, the destination size is adjusted to maintain the image data's aspect ratio.

See Also

Reference

PrintJob Class
PrintJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintBitmap(Bitmap,Single,Single,Single,Single,Single,Single,Single,Single,Boolean) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintJob Class > PrintBitmap Method : PrintBitmap(Bitmap,Single,Single,Single,Single,Single,Single,Single,Single,Boolean) Method

bitmap
The Bitmap object to draw.
sourceX
The X location in the source image of the upper-left of the source image data.
sourceY
The Y location in the source image of the upper-left of the source image data.
sourceWidth
The source width of the image data.
sourceHeight
The source height of the image data.
destinationX
The X location of the destination for the upper-left corner of the image data.
destinationY
The Y location of the destination for the upper-left corner of the image data.
destinationWidth
The destination width of the Image data.
destinationHeight
The destination height of the Image data.
aspect
A boolean value that when true, the destination size is adjusted to maintain the image data's aspect ratio.

Glossary Item Box

Draws a Bitmap on the printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub PrintBitmap( _
   ByVal bitmap As Bitmap, _
   ByVal sourceX As Single, _
   ByVal sourceY As Single, _
   ByVal sourceWidth As Single, _
   ByVal sourceHeight As Single, _
   ByVal destinationX As Single, _
   ByVal destinationY As Single, _
   ByVal destinationWidth As Single, _
   ByVal destinationHeight As Single, _
   ByVal aspect As Boolean _
)
'Usage

Dim instance As PrintJob
Dim bitmap As Bitmap
Dim sourceX As Single
Dim sourceY As Single
Dim sourceWidth As Single
Dim sourceHeight As Single
Dim destinationX As Single
Dim destinationY As Single
Dim destinationWidth As Single
Dim destinationHeight As Single
Dim aspect As Boolean

instance.PrintBitmap(bitmap, sourceX, sourceY, sourceWidth, sourceHeight, destinationX, destinationY, destinationWidth, destinationHeight, aspect)
public void PrintBitmap(
   Bitmap bitmap,
   float sourceX,
   float sourceY,
   float sourceWidth,
   float sourceHeight,
   float destinationX,
   float destinationY,
   float destinationWidth,
   float destinationHeight,
   bool aspect
)
public: void PrintBitmap(
   Bitmap* bitmap,
   float sourceX,
   float sourceY,
   float sourceWidth,
   float sourceHeight,
   float destinationX,
   float destinationY,
   float destinationWidth,
   float destinationHeight,
   bool aspect
)
public:
void PrintBitmap(
   Bitmap^ bitmap,
   float sourceX,
   float sourceY,
   float sourceWidth,
   float sourceHeight,
   float destinationX,
   float destinationY,
   float destinationWidth,
   float destinationHeight,
   bool aspect
)

Parameters

bitmap
The Bitmap object to draw.
sourceX
The X location in the source image of the upper-left of the source image data.
sourceY
The Y location in the source image of the upper-left of the source image data.
sourceWidth
The source width of the image data.
sourceHeight
The source height of the image data.
destinationX
The X location of the destination for the upper-left corner of the image data.
destinationY
The Y location of the destination for the upper-left corner of the image data.
destinationWidth
The destination width of the Image data.
destinationHeight
The destination height of the Image data.
aspect
A boolean value that when true, the destination size is adjusted to maintain the image data's aspect ratio.

See Also

Reference

PrintJob Class
PrintJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintDib Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintJob Class : PrintDib Method

Glossary Item Box

Draws a DIB on the printer.

Overload List

Overload | Description
PrintDib(IntPtr,PointF,SizeF,PointF,SizeF,Boolean) | Draws a DIB on the printer.
PrintDib(IntPtr,Single,Single,Single,Single,Single,Single,Single,Single,Boolean) | Draws a DIB on the printer.

See Also

Reference

PrintJob Class
PrintJob Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintDib(IntPtr,PointF,SizeF,PointF,SizeF,Boolean) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintJob Class > PrintDib Method : PrintDib(IntPtr,PointF,SizeF,PointF,SizeF,Boolean) Method

dib
A pointer which points to the dib to draw.
source
A System.Drawing.PointF which represents the source location of the DIB.
sourceSize
A System.Drawing.SizeF which represents the source size of the DIB.
destination
A System.Drawing.PointF value which represents the destination.
destinationSize
A System.Drawing.SizeF value which represents the destination size.
aspect
A boolean value that when true, the destination size is adjusted to maintain the image data's aspect ratio.

Glossary Item Box

Draws a DIB on the printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub PrintDib( _
   ByVal dib As IntPtr, _
   ByVal source As PointF, _
   ByVal sourceSize As SizeF, _
   ByVal destination As PointF, _
   ByVal destinationSize As SizeF, _
   ByVal aspect As Boolean _
)
'Usage

Dim instance As PrintJob
Dim dib As IntPtr
Dim source As PointF
Dim sourceSize As SizeF
Dim destination As PointF
Dim destinationSize As SizeF
Dim aspect As Boolean

instance.PrintDib(dib, source, sourceSize, destination, destinationSize, aspect)
public void PrintDib(
   IntPtr dib,
   PointF source,
   SizeF sourceSize,
   PointF destination,
   SizeF destinationSize,
   bool aspect
)
public: void PrintDib(
   IntPtr dib,
   PointF source,
   SizeF sourceSize,
   PointF destination,
   SizeF destinationSize,
   bool aspect
)
public:
void PrintDib(
   IntPtr dib,
   PointF source,
   SizeF sourceSize,
   PointF destination,
   SizeF destinationSize,
   bool aspect
)

Parameters

dib
A pointer which points to the dib to draw.
source
A System.Drawing.PointF which represents the source location of the DIB.
sourceSize
A System.Drawing.SizeF which represents the source size of the DIB.
destination
A System.Drawing.PointF value which represents the destination.
destinationSize
A System.Drawing.SizeF value which represents the destination size.
aspect
A boolean value that when true, the destination size is adjusted to maintain the image data's aspect ratio.

See Also

Reference

PrintJob Class
PrintJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintDib(IntPtr,Single,Single,Single,Single,Single,Single,Single,Single,Boolean) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintJob Class > PrintDib Method : PrintDib(IntPtr,Single,Single,Single,Single,Single,Single,Single,Single,Boolean) Method

dib
The DIB object to draw.
sourceX
The X location in the source image of the upper-left of the source image data.
sourceY
The Y location in the source image of the upper-left of the source image data.
sourceWidth
The source width of the image data.
sourceHeight
The source height of the image data.
destinationX
The X location of the destination for the upper-left corner of the image data.
destinationY
The Y location of the destination for the upper-left corner of the image data.
destinationWidth
The destination width of the Image data.
destinationHeight
The destination height of the Image data.
aspect
when true, the destination size is adjusted to maintain the image data's aspect ratio.

Glossary Item Box

Draws a DIB on the printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub PrintDib( _
   ByVal dib As IntPtr, _
   ByVal sourceX As Single, _
   ByVal sourceY As Single, _
   ByVal sourceWidth As Single, _
   ByVal sourceHeight As Single, _
   ByVal destinationX As Single, _
   ByVal destinationY As Single, _
   ByVal destinationWidth As Single, _
   ByVal destinationHeight As Single, _
   ByVal aspect As Boolean _
)
'Usage

Dim instance As PrintJob
Dim dib As IntPtr
Dim sourceX As Single
Dim sourceY As Single
Dim sourceWidth As Single
Dim sourceHeight As Single
Dim destinationX As Single
Dim destinationY As Single
Dim destinationWidth As Single
Dim destinationHeight As Single
Dim aspect As Boolean

instance.PrintDib(dib, sourceX, sourceY, sourceWidth, sourceHeight, destinationX, destinationY, destinationWidth, destinationHeight, aspect)
public void PrintDib(
   IntPtr dib,
   float sourceX,
   float sourceY,
   float sourceWidth,
   float sourceHeight,
   float destinationX,
   float destinationY,
   float destinationWidth,
   float destinationHeight,
   bool aspect
)
public: void PrintDib(
   IntPtr dib,
   float sourceX,
   float sourceY,
   float sourceWidth,
   float sourceHeight,
   float destinationX,
   float destinationY,
   float destinationWidth,
   float destinationHeight,
   bool aspect
)
public:
void PrintDib(
   IntPtr dib,
   float sourceX,
   float sourceY,
   float sourceWidth,
   float sourceHeight,
   float destinationX,
   float destinationY,
   float destinationWidth,
   float destinationHeight,
   bool aspect
)

Parameters

dib
The DIB object to draw.
sourceX
The X location in the source image of the upper-left of the source image data.
sourceY
The Y location in the source image of the upper-left of the source image data.
sourceWidth
The source width of the image data.
sourceHeight
The source height of the image data.
destinationX
The X location of the destination for the upper-left corner of the image data.
destinationY
The Y location of the destination for the upper-left corner of the image data.
destinationWidth
The destination width of the Image data.
destinationHeight
The destination height of the Image data.
aspect
when true, the destination size is adjusted to maintain the image data's aspect ratio.

See Also

Reference

PrintJob Class
PrintJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintImage Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintJob Class : PrintImage Method

Glossary Item Box

Draws an image on the printer.

Overload List

Overload | Description
PrintImage(Image,PointF,SizeF,Boolean) | Draws an image on the printer.
PrintImage(Image,PointF,SizeF,PointF,SizeF,Boolean) | Draws an image on the printer.
PrintImage(Image,Single,Single,Single,Single,Boolean) | Draws an image on the printer.
PrintImage(Image,Single,Single,Single,Single,Single,Single,Single,Single,Boolean) | Draws an image on the printer.

See Also

Reference

PrintJob Class
PrintJob Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintImage(Image,PointF,SizeF,Boolean) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintJob Class > PrintImage Method : PrintImage(Image,PointF,SizeF,Boolean) Method

image
The System.Drawing.Image object to draw.
destination
A System.Drawing.PointF which represents the location of the destination for the upper-left corner of the image.
destinationSize
A System.Drawing.SizeF which represents the destination size of the image.
aspect
A boolean value that when true, the destination size is adjusted to maintain the image's aspect ratio.

Glossary Item Box

Draws an image on the printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub PrintImage( _
   ByVal image As Image, _
   ByVal destination As PointF, _
   ByVal destinationSize As SizeF, _
   ByVal aspect As Boolean _
)
'Usage

Dim instance As PrintJob
Dim image As Image
Dim destination As PointF
Dim destinationSize As SizeF
Dim aspect As Boolean

instance.PrintImage(image, destination, destinationSize, aspect)
public void PrintImage(
   Image image,
   PointF destination,
   SizeF destinationSize,
   bool aspect
)
public: void PrintImage(
   Image* image,
   PointF destination,
   SizeF destinationSize,
   bool aspect
)
public:
void PrintImage(
   Image^ image,
   PointF destination,
   SizeF destinationSize,
   bool aspect
)

Parameters

image
The System.Drawing.Image object to draw.
destination
A System.Drawing.PointF which represents the location of the destination for the upper-left corner of the image.
destinationSize
A System.Drawing.SizeF which represents the destination size of the image.
aspect
A boolean value that when true, the destination size is adjusted to maintain the image's aspect ratio.

See Also

Reference

PrintJob Class
PrintJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintImage(Image,PointF,SizeF,PointF,SizeF,Boolean) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintJob Class > PrintImage Method : PrintImage(Image,PointF,SizeF,PointF,SizeF,Boolean) Method

image
The image object to draw.
source
The location in the source image of the upper-left of the source image data.
sourceSize
The source size of the image data.
destination
The location of the destination for the upper-left corner of the image data.
destinationSize
The destination size of the Image data.
aspect
when true, the destination size is adjusted to maintain the image data's aspect ratio.

Glossary Item Box

Draws an image on the printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub PrintImage( _
   ByVal image As Image, _
   ByVal source As PointF, _
   ByVal sourceSize As SizeF, _
   ByVal destination As PointF, _
   ByVal destinationSize As SizeF, _
   ByVal aspect As Boolean _
)
'Usage

Dim instance As PrintJob
Dim image As Image
Dim source As PointF
Dim sourceSize As SizeF
Dim destination As PointF
Dim destinationSize As SizeF
Dim aspect As Boolean

instance.PrintImage(image, source, sourceSize, destination, destinationSize, aspect)
public void PrintImage(
   Image image,
   PointF source,
   SizeF sourceSize,
   PointF destination,
   SizeF destinationSize,
   bool aspect
)
public: void PrintImage(
   Image* image,
   PointF source,
   SizeF sourceSize,
   PointF destination,
   SizeF destinationSize,
   bool aspect
)
public:
void PrintImage(
   Image^ image,
   PointF source,
   SizeF sourceSize,
   PointF destination,
   SizeF destinationSize,
   bool aspect
)

Parameters

image
The image object to draw.
source
The location in the source image of the upper-left of the source image data.
sourceSize
The source size of the image data.
destination
The location of the destination for the upper-left corner of the image data.
destinationSize
The destination size of the Image data.
aspect
when true, the destination size is adjusted to maintain the image data's aspect ratio.

See Also

Reference

PrintJob Class
PrintJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintImage(Image,Single,Single,Single,Single,Boolean) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintJob Class > PrintImage Method : PrintImage(Image,Single,Single,Single,Single,Boolean) Method

image
The image object to draw.
destinationX
The X location of the destination for the upper-left corner of the image data.
destinationY
The Y location of the destination for the upper-left corner of the image data.
destinationWidth
A single value which represents the destination width of the Image data.
destinationHeight
A single value which represents the destination height of the Image data.
aspect
A boolean value that when true, the destination size is adjusted to maintain the image data's aspect ratio.

Glossary Item Box

Draws an image on the printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub PrintImage( _
   ByVal image As Image, _
   ByVal destinationX As Single, _
   ByVal destinationY As Single, _
   ByVal destinationWidth As Single, _
   ByVal destinationHeight As Single, _
   ByVal aspect As Boolean _
)
'Usage

Dim instance As PrintJob
Dim image As Image
Dim destinationX As Single
Dim destinationY As Single
Dim destinationWidth As Single
Dim destinationHeight As Single
Dim aspect As Boolean

instance.PrintImage(image, destinationX, destinationY, destinationWidth, destinationHeight, aspect)
public void PrintImage(
   Image image,
   float destinationX,
   float destinationY,
   float destinationWidth,
   float destinationHeight,
   bool aspect
)
public: void PrintImage(
   Image* image,
   float destinationX,
   float destinationY,
   float destinationWidth,
   float destinationHeight,
   bool aspect
)
public:
void PrintImage(
   Image^ image,
   float destinationX,
   float destinationY,
   float destinationWidth,
   float destinationHeight,
   bool aspect
)

Parameters

image
The image object to draw.
destinationX
The X location of the destination for the upper-left corner of the image data.
destinationY
The Y location of the destination for the upper-left corner of the image data.
destinationWidth
A single value which represents the destination width of the Image data.
destinationHeight
A single value which represents the destination height of the Image data.
aspect
A boolean value that when true, the destination size is adjusted to maintain the image data's aspect ratio.

See Also

Reference

PrintJob Class
PrintJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintImage(Image,Single,Single,Single,Single,Single,Single,Single,Single,Boolean) Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintJob Class > PrintImage Method : PrintImage(Image,Single,Single,Single,Single,Single,Single,Single,Single,Boolean) Method

image
The image object to draw.
sourceX
The X location in the source image of the upper-left of the source image data.
sourceY
The Y location in the source image of the upper-left of the source image data.
sourceWidth
The source width of the image data.
sourceHeight
The source height of the image data.
destinationX
The X location of the destination for the upper-left corner of the image data.
destinationY
The Y location of the destination for the upper-left corner of the image data.
destinationWidth
The destination width of the Image data.
destinationHeight
The destination height of the Image data.
aspect
when true, the destination size is adjusted to maintain the image data's aspect ratio.

Glossary Item Box

Draws an image on the printer.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub PrintImage( _
   ByVal image As Image, _
   ByVal sourceX As Single, _
   ByVal sourceY As Single, _
   ByVal sourceWidth As Single, _
   ByVal sourceHeight As Single, _
   ByVal destinationX As Single, _
   ByVal destinationY As Single, _
   ByVal destinationWidth As Single, _
   ByVal destinationHeight As Single, _
   ByVal aspect As Boolean _
)
'Usage

Dim instance As PrintJob
Dim image As Image
Dim sourceX As Single
Dim sourceY As Single
Dim sourceWidth As Single
Dim sourceHeight As Single
Dim destinationX As Single
Dim destinationY As Single
Dim destinationWidth As Single
Dim destinationHeight As Single
Dim aspect As Boolean

instance.PrintImage(image, sourceX, sourceY, sourceWidth, sourceHeight, destinationX, destinationY, destinationWidth, destinationHeight, aspect)
public void PrintImage(
   Image image,
   float sourceX,
   float sourceY,
   float sourceWidth,
   float sourceHeight,
   float destinationX,
   float destinationY,
   float destinationWidth,
   float destinationHeight,
   bool aspect
)
public: void PrintImage(
   Image* image,
   float sourceX,
   float sourceY,
   float sourceWidth,
   float sourceHeight,
   float destinationX,
   float destinationY,
   float destinationWidth,
   float destinationHeight,
   bool aspect
)
public:
void PrintImage(
   Image^ image,
   float sourceX,
   float sourceY,
   float sourceWidth,
   float sourceHeight,
   float destinationX,
   float destinationY,
   float destinationWidth,
   float destinationHeight,
   bool aspect
)

Parameters

image
The image object to draw.
sourceX
The X location in the source image of the upper-left of the source image data.
sourceY
The Y location in the source image of the upper-left of the source image data.
sourceWidth
The source width of the image data.
sourceHeight
The source height of the image data.
destinationX
The X location of the destination for the upper-left corner of the image data.
destinationY
The Y location of the destination for the upper-left corner of the image data.
destinationWidth
The destination width of the Image data.
destinationHeight
The destination height of the Image data.
aspect
when true, the destination size is adjusted to maintain the image data's aspect ratio.

See Also

Reference

PrintJob Class
PrintJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintTemplateBitmap Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintJob Class : PrintTemplateBitmap Method

bitmap
The bitmap to draw.
line
An integer value which represents the line of the template file to use.

Glossary Item Box

Draws a bitmap image on a printer using details provided by the template file.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub PrintTemplateBitmap( _
   ByVal bitmap As Bitmap, _
   ByVal line As Integer _
)
'Usage

Dim instance As PrintJob
Dim bitmap As Bitmap
Dim line As Integer

instance.PrintTemplateBitmap(bitmap, line)
public void PrintTemplateBitmap(
   Bitmap bitmap,
   int line
)
public: void PrintTemplateBitmap(
   Bitmap* bitmap,
   int line
)
public:
void PrintTemplateBitmap(
   Bitmap^ bitmap,
   int line
)

Parameters

bitmap
The bitmap to draw.
line
An integer value which represents the line of the template file to use.

See Also

Reference

PrintJob Class
PrintJob Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintTemplateDib Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintJob Class : PrintTemplateDib Method

dib
The pointer to the dib to draw.
line
An integer value which represents the line of the template file to use.

Glossary Item Box

Draws a DIB image on a printer using details provided by the template file.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub PrintTemplateDib( _
   ByVal dib As IntPtr, _
   ByVal line As Integer _
)
'Usage

Dim instance As PrintJob
Dim dib As IntPtr
Dim line As Integer

instance.PrintTemplateDib(dib, line)
public void PrintTemplateDib(
   IntPtr dib,
   int line
)
public: void PrintTemplateDib(
   IntPtr dib,
   int line
)
public:
void PrintTemplateDib(
   IntPtr dib,
   int line
)

Parameters

dib
The pointer to the dib to draw.
line
An integer value which represents the line of the template file to use.

See Also

Reference

PrintJob Class
PrintJob Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintTemplateImage Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintJob Class : PrintTemplateImage Method

image
The System.Drawing.Image to draw.
line
An integer value which represents the line of the template file to use.

Glossary Item Box

Draws an image on a printer using details provided by the template file.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub PrintTemplateImage( _
   ByVal image As Image, _
   ByVal line As Integer _
)
'Usage

Dim instance As PrintJob
Dim image As Image
Dim line As Integer

instance.PrintTemplateImage(image, line)
public void PrintTemplateImage(
   Image image,
   int line
)
public: void PrintTemplateImage(
   Image* image,
   int line
)
public:
void PrintTemplateImage(
   Image^ image,
   int line
)

Parameters

image
The System.Drawing.Image to draw.
line
An integer value which represents the line of the template file to use.

See Also

Reference

PrintJob Class
PrintJob Members


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
PrintJob Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : PrintJob Class

Glossary Item Box

For a list of all members of this type, see PrintJob members.

Public Properties

 | Name | Description
Public Property | BottomMargin | Gets or sets the distance between the bottom of the physical page and the bottom of the printable area in units of the Printer's PrintUnits.
Public Property | DisplayX | Gets the horizontal coordinate of the display area in printer units defined by the PrintPreviewScale property. Not available at design time.
Public Property | DisplayY | Gets the vertical coordinate of the display area in printer units defined by the PrintPreviewScale property.
Public Property | Draw | Gets a pseudo object used to contain all of the drawing methods.
Public Property | Icm | Gets the Image Color Management values that the print job is using.
Public Property | LeftMargin | Gets or sets the distance between the left of the physical page and the left of the printable area in units of the Printer's PrintUnits.
Public Property | Name | Gets the document name for the print job. Note that setting this property will have no affect on the print job and instead the PrintJob or PrintPreviewJob constructor should be used to specify the document name. The setting of this property will be deprecated and this property will be read-only in a future version.
Public Property | Page | Gets the current page number of the document for the print job.
Public Property | PaperHeight | Gets the physical height of the paper set up for the printing device, in units determined by the PrintPreviewScale property.
Public Property | PaperWidth | Gets the physical width of the paper set up for the printing device, in units determined by the PrintPreviewScale property.
Public Property | Printer | Gets the Printer the print job is using.
Public Property | PrintHeight | Gets the printable height of the paper set up for the printing device, in units determined by the PrintPreviewScale property.
Public Property | PrintWidth | Gets the printable width of the paper set up for the printing device, in units determined by the PrintPreviewScale property.
Public Property | TemplateFileName | Gets and sets the photograph collage description filename.
Public Property | TopMargin | Gets or sets the distance between the top of the physical page and the top of the printable area in units of the Printer's PrintUnits.
Public Property | UseHardwareMargins | Gets or sets the value to determine if the printer's hardware margins are used or if the margin values are calculated from the average of the printable area subtracted from the physical area.
Top

See Also

Reference

PrintJob Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
BottomMargin Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintJob Class : BottomMargin Property

Glossary Item Box

Gets or sets the distance between the bottom of the physical page and the bottom of the printable area in units of the Printer's PrintUnits.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property BottomMargin As Single
'Usage

Dim instance As PrintJob
Dim value As Single

instance.BottomMargin = value

value = instance.BottomMargin
public float BottomMargin {get; set;}
public: __property float get_BottomMargin();
public: __property void set_BottomMargin(
   float value
);
public:
property float BottomMargin {
   float get();
   void set (    float value);
}

Property Value

A single value which represents the distance between the bottom of the physical page and the bottom of the printable area in the Printer's PrintUnits.

See Also

Reference

PrintJob Class
PrintJob Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
DisplayX Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintJob Class : DisplayX Property

Glossary Item Box

Gets the horizontal coordinate of the display area in printer units defined by the PrintPreviewScale property. Not available at design time.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property DisplayX As Single
'Usage

Dim instance As PrintJob
Dim value As Single

value = instance.DisplayX
public float DisplayX {get;}
public: __property float get_DisplayX();
public:
property float DisplayX {
   float get();
}

Property Value

A single value which represents the horizontal coordinate of the display area.

See Also

Reference

PrintJob Class
PrintJob Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
DisplayY Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintJob Class : DisplayY Property

Glossary Item Box

Gets the vertical coordinate of the display area in printer units defined by the PrintPreviewScale property.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property DisplayY As Single
'Usage

Dim instance As PrintJob
Dim value As Single

value = instance.DisplayY
public float DisplayY {get;}
public: __property float get_DisplayY();
public:
property float DisplayY {
   float get();
}

Property Value

A single value which represents the vertical coordinate of the display area.

See Also

Reference

PrintJob Class
PrintJob Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Draw Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintJob Class : Draw Property

Glossary Item Box

Gets a pseudo object used to contain all of the drawing methods.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property Draw As Draw
'Usage

Dim instance As PrintJob
Dim value As Draw

value = instance.Draw
public Draw Draw {get;}
public: __property Draw* get_Draw();
public:
property Draw^ Draw {
   Draw^ get();
}

Property Value

A Draw object which contains all the drawing methods for the print job.

See Also

Reference

PrintJob Class
PrintJob Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Icm Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintJob Class : Icm Property

Glossary Item Box

Gets the Image Color Management values that the print job is using.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property Icm As Icm
'Usage

Dim instance As PrintJob
Dim value As Icm

value = instance.Icm
public Icm Icm {get;}
public: __property Icm* get_Icm();
public:
property Icm^ Icm {
   Icm^ get();
}

Property Value

An Icm object which contains information about the image color management that the print job is using.

See Also

Reference

PrintJob Class
PrintJob Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
LeftMargin Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintJob Class : LeftMargin Property

Glossary Item Box

Gets or sets the distance between the left of the physical page and the left of the printable area in units of the Printer's PrintUnits.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property LeftMargin As Single
'Usage

Dim instance As PrintJob
Dim value As Single

instance.LeftMargin = value

value = instance.LeftMargin
public float LeftMargin {get; set;}
public: __property float get_LeftMargin();
public: __property void set_LeftMargin(
   float value
);
public:
property float LeftMargin {
   float get();
   void set (    float value);
}

Property Value

A single value which represents the distance between the left of the physical page and the left of the printable area in the Printer's PrintUnits.

See Also

Reference

PrintJob Class
PrintJob Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Name Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintJob Class : Name Property

Glossary Item Box

Gets the document name for the print job. Note that setting this property will have no affect on the print job and instead the PrintJob or PrintPreviewJob constructor should be used to specify the document name. The setting of this property will be deprecated and this property will be read-only in a future version.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property Name As String
'Usage

Dim instance As PrintJob
Dim value As String

value = instance.Name
public string Name {get;}
public: __property string* get_Name();
public:
property String^ Name {
   String^ get();
}

Property Value

A string value which represents the name of the document for the print job.

Remarks

The default value is an empty string "".

See Also

Reference

PrintJob Class
PrintJob Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Page Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintJob Class : Page Property

Glossary Item Box

Gets the current page number of the document for the print job.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property Page As Integer
'Usage

Dim instance As PrintJob
Dim value As Integer

value = instance.Page
public int Page {get;}
public: __property int get_Page();
public:
property int Page {
   int get();
}

Property Value

An integer value which represents the current page number of the document for the print job.

Remarks

The default value is 0.

See Also

Reference

PrintJob Class
PrintJob Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PaperHeight Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintJob Class : PaperHeight Property

Glossary Item Box

Gets the physical height of the paper set up for the printing device, in units determined by the PrintPreviewScale property.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property PaperHeight As Single
'Usage

Dim instance As PrintJob
Dim value As Single

value = instance.PaperHeight
public float PaperHeight {get;}
public: __property float get_PaperHeight();
public:
property float PaperHeight {
   float get();
}

Property Value

A single value which represents the physical height of the paper.

See Also

Reference

PrintJob Class
PrintJob Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PaperWidth Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintJob Class : PaperWidth Property

Glossary Item Box

Gets the physical width of the paper set up for the printing device, in units determined by the PrintPreviewScale property.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property PaperWidth As Single
'Usage

Dim instance As PrintJob
Dim value As Single

value = instance.PaperWidth
public float PaperWidth {get;}
public: __property float get_PaperWidth();
public:
property float PaperWidth {
   float get();
}

Property Value

A single value which represents the physical width of the paper set up for the printing device.

See Also

Reference

PrintJob Class
PrintJob Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Printer Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintJob Class : Printer Property

Glossary Item Box

Gets the Printer the print job is using.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property Printer As Printer
'Usage

Dim instance As PrintJob
Dim value As Printer

value = instance.Printer
public Printer Printer {get;}
public: __property Printer* get_Printer();
public:
property Printer^ Printer {
   Printer^ get();
}

Property Value

A Printer object which contains information about the printer.

See Also

Reference

PrintJob Class
PrintJob Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintHeight Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintJob Class : PrintHeight Property

Glossary Item Box

Gets the printable height of the paper set up for the printing device, in units determined by the PrintPreviewScale property.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property PrintHeight As Single
'Usage

Dim instance As PrintJob
Dim value As Single

value = instance.PrintHeight
public float PrintHeight {get;}
public: __property float get_PrintHeight();
public:
property float PrintHeight {
   float get();
}

Property Value

A single value which represents the printable height.

See Also

Reference

PrintJob Class
PrintJob Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintWidth Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintJob Class : PrintWidth Property

Glossary Item Box

Gets the printable width of the paper set up for the printing device, in units determined by the PrintPreviewScale property.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property PrintWidth As Single
'Usage

Dim instance As PrintJob
Dim value As Single

value = instance.PrintWidth
public float PrintWidth {get;}
public: __property float get_PrintWidth();
public:
property float PrintWidth {
   float get();
}

Property Value

A single value which represents the printable width.

See Also

Reference

PrintJob Class
PrintJob Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
TemplateFileName Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintJob Class : TemplateFileName Property

Glossary Item Box

Gets and sets the photograph collage description filename.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property TemplateFileName As String
'Usage

Dim instance As PrintJob
Dim value As String

instance.TemplateFileName = value

value = instance.TemplateFileName
public string TemplateFileName {get; set;}
public: __property string* get_TemplateFileName();
public: __property void set_TemplateFileName(
   string* value
);
public:
property String^ TemplateFileName {
   String^ get();
   void set (    String^ value);
}

Remarks

The default value is an empty string.

A collage template file is a text file of particular format that describes component image size and location. The first line is a format and version control line so that future modifications may be supported transparently and is as follows: Accusoft PrintPRO Template Version 1 Units = TW | PO | PI | CH | IN | MI | CE

Use only one of the unit indicators. They represent Twips, Point, Pixel, Character, Inches, Millimeter and Centimeter. The first two characters are sufficient for selecting the unit used to describe location and dimensions. Each subsequent line describes the location and cropping of an component image.

A line consists of a delimited (by comma, space, spaces or tab) series of values: Left, Top, Width, Height, SourceLeft, SourceTop, SourceWidth, SourceHeight and an Aspect flag. If the source parameters are omitted then the entire source image is inserted.

See Also

Reference

PrintJob Class
PrintJob Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
TopMargin Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintJob Class : TopMargin Property

Glossary Item Box

Gets or sets the distance between the top of the physical page and the top of the printable area in units of the Printer's PrintUnits.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property TopMargin As Single
'Usage

Dim instance As PrintJob
Dim value As Single

instance.TopMargin = value

value = instance.TopMargin
public float TopMargin {get; set;}
public: __property float get_TopMargin();
public: __property void set_TopMargin(
   float value
);
public:
property float TopMargin {
   float get();
   void set (    float value);
}

Property Value

A single value which represents the distance between the top of the physical page and the top of the printable area in the Printer's PrintUnits.

See Also

Reference

PrintJob Class
PrintJob Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
UseHardwareMargins Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintJob Class : UseHardwareMargins Property

Glossary Item Box

Gets or sets the value to determine if the printer's hardware margins are used or if the margin values are calculated from the average of the printable area subtracted from the physical area.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property UseHardwareMargins As Boolean
'Usage

Dim instance As PrintJob
Dim value As Boolean

instance.UseHardwareMargins = value

value = instance.UseHardwareMargins
public bool UseHardwareMargins {get; set;}
public: __property bool get_UseHardwareMargins();
public: __property void set_UseHardwareMargins(
   bool value
);
public:
property bool UseHardwareMargins {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true if the hardware margins are used. Otherwise, false is used.

See Also

Reference

PrintJob Class
PrintJob Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintPreviewJob Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : PrintPreviewJob Class

Glossary Item Box

This class represents a print preview job.

Object Model

PrintPreviewJob ClassDraw ClassIcm ClassPrinter ClassPrinter ClassPrinter ClassPaper ClassPaperBin ClassPaperBinCollection ClassPaperBin ClassPaperCollection ClassPaper ClassPrintQuality ClassPrintingUnit StructurePrinter ClassPaper ClassPaperBin ClassPaperBinCollection ClassPaperBin ClassPaperCollection ClassPaper ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintingUnit StructurePrinter ClassPrinter ClassPaper ClassPaperBin ClassPaperBinCollection ClassPaperBin ClassPaperCollection ClassPaper ClassPrintQuality ClassPrintingUnit StructurePrinter Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Class PrintPreviewJob
   Inherits PrintJob
'Usage

Dim instance As PrintPreviewJob
public class PrintPreviewJob : PrintJob
public __gc class PrintPreviewJob : public PrintJob
public ref class PrintPreviewJob : public PrintJob

Inheritance Hierarchy

System.Object
Accusoft.PrintProSdk.PrintJob
Accusoft.PrintProSdk.PrintPreviewJob

See Also

Reference

PrintPreviewJob Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
PrintPreviewJob Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : PrintPreviewJob Class

Glossary Item Box

The following tables list the members exposed by PrintPreviewJob.

Public Constructors

 | Name | Description
Public Constructor | PrintPreviewJob Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | BottomMargin | Gets or sets the distance between the bottom of the physical page and the bottom of the printable area in units of the Printer's PrintUnits. (Inherited from Accusoft.PrintProSdk.PrintJob)
Public Property | DisplayX | Gets the horizontal coordinate of the display area in printer units defined by the PrintPreviewScale property. Not available at design time. (Inherited from Accusoft.PrintProSdk.PrintJob)
Public Property | DisplayY | Gets the vertical coordinate of the display area in printer units defined by the PrintPreviewScale property. (Inherited from Accusoft.PrintProSdk.PrintJob)
Public Property | Draw | Gets a pseudo object used to contain all of the drawing methods. (Inherited from Accusoft.PrintProSdk.PrintJob)
Public Property | Icm | Gets the Image Color Management values that the print job is using. (Inherited from Accusoft.PrintProSdk.PrintJob)
Public Property | LeftMargin | Gets or sets the distance between the left of the physical page and the left of the printable area in units of the Printer's PrintUnits. (Inherited from Accusoft.PrintProSdk.PrintJob)
Public Property | Name | Gets the document name for the print job. Note that setting this property will have no affect on the print job and instead the PrintJob or PrintPreviewJob constructor should be used to specify the document name. The setting of this property will be deprecated and this property will be read-only in a future version. (Inherited from Accusoft.PrintProSdk.PrintJob)
Public Property | Page | Gets the current page number of the document for the print job. (Inherited from Accusoft.PrintProSdk.PrintJob)
Public Property | PaperHeight | Gets the physical height of the paper set up for the printing device, in units determined by the PrintPreviewScale property. (Inherited from Accusoft.PrintProSdk.PrintJob)
Public Property | PaperWidth | Gets the physical width of the paper set up for the printing device, in units determined by the PrintPreviewScale property. (Inherited from Accusoft.PrintProSdk.PrintJob)
Public Property | Printer | Gets the Printer the print job is using. (Inherited from Accusoft.PrintProSdk.PrintJob)
Public Property | PrintHeight | Gets the printable height of the paper set up for the printing device, in units determined by the PrintPreviewScale property. (Inherited from Accusoft.PrintProSdk.PrintJob)
Public Property | PrintPreviewScale | Gets or sets the size of the print preview image.
Public Property | PrintWidth | Gets the printable width of the paper set up for the printing device, in units determined by the PrintPreviewScale property. (Inherited from Accusoft.PrintProSdk.PrintJob)
Public Property | TemplateFileName | Gets and sets the photograph collage description filename. (Inherited from Accusoft.PrintProSdk.PrintJob)
Public Property | TopMargin | Gets or sets the distance between the top of the physical page and the top of the printable area in units of the Printer's PrintUnits. (Inherited from Accusoft.PrintProSdk.PrintJob)
Public Property | UseHardwareMargins | Gets or sets the value to determine if the printer's hardware margins are used or if the margin values are calculated from the average of the printable area subtracted from the physical area. (Inherited from Accusoft.PrintProSdk.PrintJob)
Top

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. Forces destruction of the print job object. (Inherited from Accusoft.PrintProSdk.PrintJob)
Public Method | Finish | Overridden. Releases the current document to the print device or spooler.
Public Method | GetGraphics | Overridden. Returns a graphics object to the current page.
Public Method | GetPrintPreviewBitmap | Obtain the print preview Bitmap for a specified page.
Public Method | GetPrintPreviewDib | Obtain the print preview dib for a specified page.
Public Method | GetPrintPreviewImage | Obtain the print preview Image for a specified page.
Public Method | Kill | Immediately terminates the current print job cancelling any operations that have been performed on it. (Inherited from Accusoft.PrintProSdk.PrintJob)
Public Method | NewPage | Starts a new page for printing. (Inherited from Accusoft.PrintProSdk.PrintJob)
Public Method | PrintBitmap | Overloaded. Draws a Bitmap on the printer. (Inherited from Accusoft.PrintProSdk.PrintJob)
Public Method | PrintDib | Overloaded. Draws a DIB on the printer. (Inherited from Accusoft.PrintProSdk.PrintJob)
Public Method | PrintImage | Overloaded. Draws an image on the printer. (Inherited from Accusoft.PrintProSdk.PrintJob)
Public Method | PrintTemplateBitmap | Draws a bitmap image on a printer using details provided by the template file. (Inherited from Accusoft.PrintProSdk.PrintJob)
Public Method | PrintTemplateDib | Draws a DIB image on a printer using details provided by the template file. (Inherited from Accusoft.PrintProSdk.PrintJob)
Public Method | PrintTemplateImage | Draws an image on a printer using details provided by the template file. (Inherited from Accusoft.PrintProSdk.PrintJob)
Top

See Also

Reference

PrintPreviewJob Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
PrintPreviewJob Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : PrintPreviewJob Class

Glossary Item Box

For a list of all members of this type, see PrintPreviewJob members.

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. Forces destruction of the print job object. (Inherited from Accusoft.PrintProSdk.PrintJob)
Public Method | Finish | Overridden. Releases the current document to the print device or spooler.
Public Method | GetGraphics | Overridden. Returns a graphics object to the current page.
Public Method | GetPrintPreviewBitmap | Obtain the print preview Bitmap for a specified page.
Public Method | GetPrintPreviewDib | Obtain the print preview dib for a specified page.
Public Method | GetPrintPreviewImage | Obtain the print preview Image for a specified page.
Public Method | Kill | Immediately terminates the current print job cancelling any operations that have been performed on it. (Inherited from Accusoft.PrintProSdk.PrintJob)
Public Method | NewPage | Starts a new page for printing. (Inherited from Accusoft.PrintProSdk.PrintJob)
Public Method | PrintBitmap | Overloaded. Draws a Bitmap on the printer. (Inherited from Accusoft.PrintProSdk.PrintJob)
Public Method | PrintDib | Overloaded. Draws a DIB on the printer. (Inherited from Accusoft.PrintProSdk.PrintJob)
Public Method | PrintImage | Overloaded. Draws an image on the printer. (Inherited from Accusoft.PrintProSdk.PrintJob)
Public Method | PrintTemplateBitmap | Draws a bitmap image on a printer using details provided by the template file. (Inherited from Accusoft.PrintProSdk.PrintJob)
Public Method | PrintTemplateDib | Draws a DIB image on a printer using details provided by the template file. (Inherited from Accusoft.PrintProSdk.PrintJob)
Public Method | PrintTemplateImage | Draws an image on a printer using details provided by the template file. (Inherited from Accusoft.PrintProSdk.PrintJob)
Top

See Also

Reference

PrintPreviewJob Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintPreviewJob Constructor
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintPreviewJob Class : PrintPreviewJob Constructor

Glossary Item Box

Overload List

Overload | Description
PrintPreviewJob Constructor(Printer) | Creates a new print preview job using the specified printer for the destination.
PrintPreviewJob Constructor(Printer,String) | Creates a new print preview job using the specified printer for the destination and the specified name.
PrintPreviewJob Constructor(Printer,Boolean) | Creates a new print preview job using the specified printer for the destination.
PrintPreviewJob Constructor(Printer,Boolean,String) | Creates a new print preview job using the specified printer for the destination and the specified name.
PrintPreviewJob Constructor(PrintPro) | Creates a new print preview job using the default printer for the destination.
PrintPreviewJob Constructor(PrintPro,String) | Creates a new print preview job using the default printer for the destination and the specified name.
PrintPreviewJob Constructor(PrintPro,Boolean) | Creates a new print preview job using the default printer for the destination.
PrintPreviewJob Constructor(PrintPro,Boolean,String) | Creates a new print preview job using the default printer for the destination and the specified name.
PrintPreviewJob Constructor(PrintPro,Printer) | Creates a new print preview job using the specified printer for the destination.
PrintPreviewJob Constructor(PrintPro,Printer,String) | Creates a new print preview job using the specified printer for the destination and the specified name.
PrintPreviewJob Constructor(PrintPro,Printer,Boolean) | Creates a new print preview job using the specified printer for the destination.
PrintPreviewJob Constructor(PrintPro,Printer,Boolean,String) | Creates a new print preview job using the specified printer for the destination and the specified name.
PrintPreviewJob Constructor(PrintPro,Icm) | Creates a new print preview job using the default printer for the destination.
PrintPreviewJob Constructor(PrintPro,Icm,String) | Creates a new print preview job using the default printer for the destination and the specified name.
PrintPreviewJob Constructor(PrintPro,Icm,Boolean) | Creates a new print preview job using the default printer for the destination.
PrintPreviewJob Constructor(PrintPro,Icm,Boolean,String) | Creates a new print preview job using the default printer for the destination and the specified name.
PrintPreviewJob Constructor(Printer,Icm) | Creates a new print preview job using the specified printer for the destination and specified image color management object for image color management settings.
PrintPreviewJob Constructor(Printer,Icm,String) | Creates a new print preview job using the specified printer for the destination, the specified image color management object for image color management settings, and the specified name.
PrintPreviewJob Constructor(Printer,Icm,Boolean) | Creates a new print preview job using the specified printer for the destination and specified image color management object for image color management settings.
PrintPreviewJob Constructor(Printer,Icm,Boolean,String) | Creates a new print preview job using the specified printer for the destination, the specified image color management object for image color management settings, and the specified name.
PrintPreviewJob Constructor(PrintPro,Printer,Icm) | Creates a new print preview job using the specified printer for the destination.
PrintPreviewJob Constructor(PrintPro,Printer,Icm,String) | Creates a new print preview job using the specified printer for the destination and the specified name.
PrintPreviewJob Constructor(PrintPro,Printer,Icm,Boolean) | Creates a new print preview job using the specified printer for the destination.
PrintPreviewJob Constructor(PrintPro,Printer,Icm,Boolean,String) | Creates a new print preview job using the specified printer for the destination and the specified name.
PrintPreviewJob Constructor(PrintPro,PrintPreviewScale) | Creates a new print job using the default printer for the destination and specified scaling
PrintPreviewJob Constructor(PrintPro,PrintPreviewScale,String) | Creates a new print job using the default printer for the destination, the specified scaling, and the specified name.
PrintPreviewJob Constructor(PrintPro,PrintPreviewScale,Boolean) | Creates a new print job using the default printer for the destination and specified scaling.
PrintPreviewJob Constructor(PrintPro,PrintPreviewScale,Boolean,String) | Creates a new print job using the default printer for the destination, the specified scaling, and the specified name.
PrintPreviewJob Constructor(PrintPro,PrintPreviewScale,Icm) | Creates a new print job using the default printer for the destination and specified scaling.
PrintPreviewJob Constructor(PrintPro,PrintPreviewScale,Icm,String) | Creates a new print job using the default printer for the destination, the specified scaling, and the specified name.
PrintPreviewJob Constructor(PrintPro,PrintPreviewScale,Icm,Boolean) | Creates a new print job using the default printer for the destination and specified scaling.
PrintPreviewJob Constructor(PrintPro,PrintPreviewScale,Icm,Boolean,String) | Creates a new print job using the default printer for the destination, the specified scaling, and the specified name.
PrintPreviewJob Constructor(PrintPro,Printer,PrintPreviewScale,Icm,Boolean) | Creates a new print job using the specified printer for the destination and specified scaling.
PrintPreviewJob Constructor(PrintPro,Printer,PrintPreviewScale,Icm,Boolean,String) | Creates a new print job using the specified printer for the destination, the specified scaling, and the specified name.
PrintPreviewJob Constructor(PrintPro,Printer,PrintPreviewScale,Boolean) | Creates a new print job using the specified printer for the destination and specified scaling.
PrintPreviewJob Constructor(PrintPro,Printer,PrintPreviewScale,Boolean,String) | Creates a new print job using the specified printer for the destination, the specified scaling, and the specified name.
PrintPreviewJob Constructor(Printer,PrintPreviewScale) | Creates a new print job using the specified printer for the destination and specified scaling.
PrintPreviewJob Constructor(Printer,PrintPreviewScale,String) | Creates a new print job using the specified printer for the destination, the specified scaling, and the specified name.
PrintPreviewJob Constructor(Printer,PrintPreviewScale,Boolean) | Creates a new print job using the specified printer for the destination and specified scaling.
PrintPreviewJob Constructor(Printer,PrintPreviewScale,Boolean,String) | Creates a new print job using the specified printer for the destination, the specified scaling, and the specified name.
PrintPreviewJob Constructor(Printer,PrintPreviewScale,Icm) | Creates a new print job using the specified printer for the destination and specified scaling.
PrintPreviewJob Constructor(Printer,PrintPreviewScale,Icm,String) | Creates a new print job using the specified printer for the destination, the specified scaling, and the specified name.
PrintPreviewJob Constructor(Printer,PrintPreviewScale,Icm,Boolean) | Creates a new print job using the specified printer for the destination and specified scaling.
PrintPreviewJob Constructor(Printer,PrintPreviewScale,Icm,Boolean,String) | Creates a new print job using the specified printer for the destination, the specified scaling, and the specified name.

See Also

Reference

PrintPreviewJob Class
PrintPreviewJob Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintPreviewJob Constructor(Printer)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(Printer)

printer
The printer the print preview job is to print to.

Glossary Item Box

Creates a new print preview job using the specified printer for the destination.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printer As Printer _
)
'Usage

Dim printer As Printer

Dim instance As New PrintPreviewJob(printer)
public PrintPreviewJob(
   Printer printer
)
public: PrintPreviewJob(
   Printer* printer
)
public:
PrintPreviewJob(
   Printer^ printer
)

Parameters

printer
The printer the print preview job is to print to.

See Also

Reference

PrintPreviewJob Class
PrintPreviewJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintPreviewJob Constructor(Printer,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(Printer,String)

printer
The printer the print preview job is to print to.
name
The name to use for the print job.

Glossary Item Box

Creates a new print preview job using the specified printer for the destination and the specified name.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printer As Printer, _
   ByVal name As String _
)
'Usage

Dim printer As Printer
Dim name As String

Dim instance As New PrintPreviewJob(printer, name)
public PrintPreviewJob(
   Printer printer,
   string name
)
public: PrintPreviewJob(
   Printer* printer,
   string* name
)
public:
PrintPreviewJob(
   Printer^ printer,
   String^ name
)

Parameters

printer
The printer the print preview job is to print to.
name
The name to use for the print job.

See Also

Reference

PrintPreviewJob Class
PrintPreviewJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintPreviewJob Constructor(Printer,Boolean)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(Printer,Boolean)

printer
The printer the print preview job is to print to.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.

Glossary Item Box

Creates a new print preview job using the specified printer for the destination.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printer As Printer, _
   ByVal useHardwareMargins As Boolean _
)
'Usage

Dim printer As Printer
Dim useHardwareMargins As Boolean

Dim instance As New PrintPreviewJob(printer, useHardwareMargins)
public PrintPreviewJob(
   Printer printer,
   bool useHardwareMargins
)
public: PrintPreviewJob(
   Printer* printer,
   bool useHardwareMargins
)
public:
PrintPreviewJob(
   Printer^ printer,
   bool useHardwareMargins
)

Parameters

printer
The printer the print preview job is to print to.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.

See Also

Reference

PrintPreviewJob Class
PrintPreviewJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintPreviewJob Constructor(Printer,Boolean,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(Printer,Boolean,String)

printer
The printer the print preview job is to print to.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.
name
The name to use for the print job.

Glossary Item Box

Creates a new print preview job using the specified printer for the destination and the specified name.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printer As Printer, _
   ByVal useHardwareMargins As Boolean, _
   ByVal name As String _
)
'Usage

Dim printer As Printer
Dim useHardwareMargins As Boolean
Dim name As String

Dim instance As New PrintPreviewJob(printer, useHardwareMargins, name)
public PrintPreviewJob(
   Printer printer,
   bool useHardwareMargins,
   string name
)
public: PrintPreviewJob(
   Printer* printer,
   bool useHardwareMargins,
   string* name
)
public:
PrintPreviewJob(
   Printer^ printer,
   bool useHardwareMargins,
   String^ name
)

Parameters

printer
The printer the print preview job is to print to.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.
name
The name to use for the print job.

See Also

Reference

PrintPreviewJob Class
PrintPreviewJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintPreviewJob Constructor(PrintPro)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(PrintPro)

printProWorkspace
The workspace object to use with the job.

Glossary Item Box

Creates a new print preview job using the default printer for the destination.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printProWorkspace As PrintPro _
)
'Usage

Dim printProWorkspace As PrintPro

Dim instance As New PrintPreviewJob(printProWorkspace)
public PrintPreviewJob(
   PrintPro printProWorkspace
)
public: PrintPreviewJob(
   PrintPro* printProWorkspace
)
public:
PrintPreviewJob(
   PrintPro^ printProWorkspace
)

Parameters

printProWorkspace
The workspace object to use with the job.

See Also

Reference

PrintPreviewJob Class
PrintPreviewJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintPreviewJob Constructor(PrintPro,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(PrintPro,String)

printProWorkspace
The workspace object to use with the job.
name
The name to use for the print job.

Glossary Item Box

Creates a new print preview job using the default printer for the destination and the specified name.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printProWorkspace As PrintPro, _
   ByVal name As String _
)
'Usage

Dim printProWorkspace As PrintPro
Dim name As String

Dim instance As New PrintPreviewJob(printProWorkspace, name)
public PrintPreviewJob(
   PrintPro printProWorkspace,
   string name
)
public: PrintPreviewJob(
   PrintPro* printProWorkspace,
   string* name
)
public:
PrintPreviewJob(
   PrintPro^ printProWorkspace,
   String^ name
)

Parameters

printProWorkspace
The workspace object to use with the job.
name
The name to use for the print job.

See Also

Reference

PrintPreviewJob Class
PrintPreviewJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintPreviewJob Constructor(PrintPro,Boolean)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(PrintPro,Boolean)

printProWorkspace
The workspace object to use with the job.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.

Glossary Item Box

Creates a new print preview job using the default printer for the destination.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printProWorkspace As PrintPro, _
   ByVal useHardwareMargins As Boolean _
)
'Usage

Dim printProWorkspace As PrintPro
Dim useHardwareMargins As Boolean

Dim instance As New PrintPreviewJob(printProWorkspace, useHardwareMargins)
public PrintPreviewJob(
   PrintPro printProWorkspace,
   bool useHardwareMargins
)
public: PrintPreviewJob(
   PrintPro* printProWorkspace,
   bool useHardwareMargins
)
public:
PrintPreviewJob(
   PrintPro^ printProWorkspace,
   bool useHardwareMargins
)

Parameters

printProWorkspace
The workspace object to use with the job.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.

See Also

Reference

PrintPreviewJob Class
PrintPreviewJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintPreviewJob Constructor(PrintPro,Boolean,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(PrintPro,Boolean,String)

printProWorkspace
The workspace object to use with the job.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.
name
The name to use for the print job.

Glossary Item Box

Creates a new print preview job using the default printer for the destination and the specified name.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printProWorkspace As PrintPro, _
   ByVal useHardwareMargins As Boolean, _
   ByVal name As String _
)
'Usage

Dim printProWorkspace As PrintPro
Dim useHardwareMargins As Boolean
Dim name As String

Dim instance As New PrintPreviewJob(printProWorkspace, useHardwareMargins, name)
public PrintPreviewJob(
   PrintPro printProWorkspace,
   bool useHardwareMargins,
   string name
)
public: PrintPreviewJob(
   PrintPro* printProWorkspace,
   bool useHardwareMargins,
   string* name
)
public:
PrintPreviewJob(
   PrintPro^ printProWorkspace,
   bool useHardwareMargins,
   String^ name
)

Parameters

printProWorkspace
The workspace object to use with the job.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.
name
The name to use for the print job.

See Also

Reference

PrintPreviewJob Class
PrintPreviewJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintPreviewJob Constructor(PrintPro,Printer)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(PrintPro,Printer)

printProWorkspace
The workspace object to use with the job.
printer
The printer the print preview job is to print to.

Glossary Item Box

Creates a new print preview job using the specified printer for the destination.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printProWorkspace As PrintPro, _
   ByVal printer As Printer _
)
'Usage

Dim printProWorkspace As PrintPro
Dim printer As Printer

Dim instance As New PrintPreviewJob(printProWorkspace, printer)
public PrintPreviewJob(
   PrintPro printProWorkspace,
   Printer printer
)
public: PrintPreviewJob(
   PrintPro* printProWorkspace,
   Printer* printer
)
public:
PrintPreviewJob(
   PrintPro^ printProWorkspace,
   Printer^ printer
)

Parameters

printProWorkspace
The workspace object to use with the job.
printer
The printer the print preview job is to print to.

See Also

Reference

PrintPreviewJob Class
PrintPreviewJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintPreviewJob Constructor(PrintPro,Printer,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(PrintPro,Printer,String)

printProWorkspace
The workspace object to use with the job.
printer
The printer the print preview job is to print to.
name
The name to use for the print job.

Glossary Item Box

Creates a new print preview job using the specified printer for the destination and the specified name.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printProWorkspace As PrintPro, _
   ByVal printer As Printer, _
   ByVal name As String _
)
'Usage

Dim printProWorkspace As PrintPro
Dim printer As Printer
Dim name As String

Dim instance As New PrintPreviewJob(printProWorkspace, printer, name)
public PrintPreviewJob(
   PrintPro printProWorkspace,
   Printer printer,
   string name
)
public: PrintPreviewJob(
   PrintPro* printProWorkspace,
   Printer* printer,
   string* name
)
public:
PrintPreviewJob(
   PrintPro^ printProWorkspace,
   Printer^ printer,
   String^ name
)

Parameters

printProWorkspace
The workspace object to use with the job.
printer
The printer the print preview job is to print to.
name
The name to use for the print job.

See Also

Reference

PrintPreviewJob Class
PrintPreviewJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintPreviewJob Constructor(PrintPro,Printer,Boolean)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(PrintPro,Printer,Boolean)

printProWorkspace
The workspace object to use with the job.
printer
The printer the print preview job is to print to.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.

Glossary Item Box

Creates a new print preview job using the specified printer for the destination.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printProWorkspace As PrintPro, _
   ByVal printer As Printer, _
   ByVal useHardwareMargins As Boolean _
)
'Usage

Dim printProWorkspace As PrintPro
Dim printer As Printer
Dim useHardwareMargins As Boolean

Dim instance As New PrintPreviewJob(printProWorkspace, printer, useHardwareMargins)
public PrintPreviewJob(
   PrintPro printProWorkspace,
   Printer printer,
   bool useHardwareMargins
)
public: PrintPreviewJob(
   PrintPro* printProWorkspace,
   Printer* printer,
   bool useHardwareMargins
)
public:
PrintPreviewJob(
   PrintPro^ printProWorkspace,
   Printer^ printer,
   bool useHardwareMargins
)

Parameters

printProWorkspace
The workspace object to use with the job.
printer
The printer the print preview job is to print to.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.

See Also

Reference

PrintPreviewJob Class
PrintPreviewJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintPreviewJob Constructor(PrintPro,Printer,Boolean,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(PrintPro,Printer,Boolean,String)

printProWorkspace
The workspace object to use with the job.
printer
The printer the print preview job is to print to.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.
name
The name to use for the print job.

Glossary Item Box

Creates a new print preview job using the specified printer for the destination and the specified name.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printProWorkspace As PrintPro, _
   ByVal printer As Printer, _
   ByVal useHardwareMargins As Boolean, _
   ByVal name As String _
)
'Usage

Dim printProWorkspace As PrintPro
Dim printer As Printer
Dim useHardwareMargins As Boolean
Dim name As String

Dim instance As New PrintPreviewJob(printProWorkspace, printer, useHardwareMargins, name)
public PrintPreviewJob(
   PrintPro printProWorkspace,
   Printer printer,
   bool useHardwareMargins,
   string name
)
public: PrintPreviewJob(
   PrintPro* printProWorkspace,
   Printer* printer,
   bool useHardwareMargins,
   string* name
)
public:
PrintPreviewJob(
   PrintPro^ printProWorkspace,
   Printer^ printer,
   bool useHardwareMargins,
   String^ name
)

Parameters

printProWorkspace
The workspace object to use with the job.
printer
The printer the print preview job is to print to.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.
name
The name to use for the print job.

See Also

Reference

PrintPreviewJob Class
PrintPreviewJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintPreviewJob Constructor(PrintPro,Icm)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(PrintPro,Icm)

printProWorkspace
The workspace object to use with the job.
imageColorManagement
The image color management settings to use for the print job.

Glossary Item Box

Creates a new print preview job using the default printer for the destination.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printProWorkspace As PrintPro, _
   ByVal imageColorManagement As Icm _
)
'Usage

Dim printProWorkspace As PrintPro
Dim imageColorManagement As Icm

Dim instance As New PrintPreviewJob(printProWorkspace, imageColorManagement)
public PrintPreviewJob(
   PrintPro printProWorkspace,
   Icm imageColorManagement
)
public: PrintPreviewJob(
   PrintPro* printProWorkspace,
   Icm* imageColorManagement
)
public:
PrintPreviewJob(
   PrintPro^ printProWorkspace,
   Icm^ imageColorManagement
)

Parameters

printProWorkspace
The workspace object to use with the job.
imageColorManagement
The image color management settings to use for the print job.

See Also

Reference

PrintPreviewJob Class
PrintPreviewJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintPreviewJob Constructor(PrintPro,Icm,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(PrintPro,Icm,String)

printProWorkspace
The workspace object to use with the job.
imageColorManagement
The image color management settings to use for the print job.
name
The name to use for the print job.

Glossary Item Box

Creates a new print preview job using the default printer for the destination and the specified name.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printProWorkspace As PrintPro, _
   ByVal imageColorManagement As Icm, _
   ByVal name As String _
)
'Usage

Dim printProWorkspace As PrintPro
Dim imageColorManagement As Icm
Dim name As String

Dim instance As New PrintPreviewJob(printProWorkspace, imageColorManagement, name)
public PrintPreviewJob(
   PrintPro printProWorkspace,
   Icm imageColorManagement,
   string name
)
public: PrintPreviewJob(
   PrintPro* printProWorkspace,
   Icm* imageColorManagement,
   string* name
)
public:
PrintPreviewJob(
   PrintPro^ printProWorkspace,
   Icm^ imageColorManagement,
   String^ name
)

Parameters

printProWorkspace
The workspace object to use with the job.
imageColorManagement
The image color management settings to use for the print job.
name
The name to use for the print job.

See Also

Reference

PrintPreviewJob Class
PrintPreviewJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintPreviewJob Constructor(PrintPro,Icm,Boolean)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(PrintPro,Icm,Boolean)

printProWorkspace
The workspace object to use with the job.
imageColorManagement
The image color management settings to use for the print job.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.

Glossary Item Box

Creates a new print preview job using the default printer for the destination.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printProWorkspace As PrintPro, _
   ByVal imageColorManagement As Icm, _
   ByVal useHardwareMargins As Boolean _
)
'Usage

Dim printProWorkspace As PrintPro
Dim imageColorManagement As Icm
Dim useHardwareMargins As Boolean

Dim instance As New PrintPreviewJob(printProWorkspace, imageColorManagement, useHardwareMargins)
public PrintPreviewJob(
   PrintPro printProWorkspace,
   Icm imageColorManagement,
   bool useHardwareMargins
)
public: PrintPreviewJob(
   PrintPro* printProWorkspace,
   Icm* imageColorManagement,
   bool useHardwareMargins
)
public:
PrintPreviewJob(
   PrintPro^ printProWorkspace,
   Icm^ imageColorManagement,
   bool useHardwareMargins
)

Parameters

printProWorkspace
The workspace object to use with the job.
imageColorManagement
The image color management settings to use for the print job.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.

See Also

Reference

PrintPreviewJob Class
PrintPreviewJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintPreviewJob Constructor(PrintPro,Icm,Boolean,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(PrintPro,Icm,Boolean,String)

printProWorkspace
The workspace object to use with the job.
imageColorManagement
The image color management settings to use for the print job.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.
name
The name to use for the print job.

Glossary Item Box

Creates a new print preview job using the default printer for the destination and the specified name.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printProWorkspace As PrintPro, _
   ByVal imageColorManagement As Icm, _
   ByVal useHardwareMargins As Boolean, _
   ByVal name As String _
)
'Usage

Dim printProWorkspace As PrintPro
Dim imageColorManagement As Icm
Dim useHardwareMargins As Boolean
Dim name As String

Dim instance As New PrintPreviewJob(printProWorkspace, imageColorManagement, useHardwareMargins, name)
public PrintPreviewJob(
   PrintPro printProWorkspace,
   Icm imageColorManagement,
   bool useHardwareMargins,
   string name
)
public: PrintPreviewJob(
   PrintPro* printProWorkspace,
   Icm* imageColorManagement,
   bool useHardwareMargins,
   string* name
)
public:
PrintPreviewJob(
   PrintPro^ printProWorkspace,
   Icm^ imageColorManagement,
   bool useHardwareMargins,
   String^ name
)

Parameters

printProWorkspace
The workspace object to use with the job.
imageColorManagement
The image color management settings to use for the print job.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.
name
The name to use for the print job.

See Also

Reference

PrintPreviewJob Class
PrintPreviewJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintPreviewJob Constructor(Printer,Icm)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(Printer,Icm)

printer
The printer the print preview job is to print to.
imageColorManagement
The image color management settings to use for the print job.

Glossary Item Box

Creates a new print preview job using the specified printer for the destination and specified image color management object for image color management settings.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printer As Printer, _
   ByVal imageColorManagement As Icm _
)
'Usage

Dim printer As Printer
Dim imageColorManagement As Icm

Dim instance As New PrintPreviewJob(printer, imageColorManagement)
public PrintPreviewJob(
   Printer printer,
   Icm imageColorManagement
)
public: PrintPreviewJob(
   Printer* printer,
   Icm* imageColorManagement
)
public:
PrintPreviewJob(
   Printer^ printer,
   Icm^ imageColorManagement
)

Parameters

printer
The printer the print preview job is to print to.
imageColorManagement
The image color management settings to use for the print job.

See Also

Reference

PrintPreviewJob Class
PrintPreviewJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintPreviewJob Constructor(Printer,Icm,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(Printer,Icm,String)

printer
The printer the print preview job is to print to.
imageColorManagement
The image color management settings to use for the print job.
name
The name to use for the print job.

Glossary Item Box

Creates a new print preview job using the specified printer for the destination, the specified image color management object for image color management settings, and the specified name.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printer As Printer, _
   ByVal imageColorManagement As Icm, _
   ByVal name As String _
)
'Usage

Dim printer As Printer
Dim imageColorManagement As Icm
Dim name As String

Dim instance As New PrintPreviewJob(printer, imageColorManagement, name)
public PrintPreviewJob(
   Printer printer,
   Icm imageColorManagement,
   string name
)
public: PrintPreviewJob(
   Printer* printer,
   Icm* imageColorManagement,
   string* name
)
public:
PrintPreviewJob(
   Printer^ printer,
   Icm^ imageColorManagement,
   String^ name
)

Parameters

printer
The printer the print preview job is to print to.
imageColorManagement
The image color management settings to use for the print job.
name
The name to use for the print job.

See Also

Reference

PrintPreviewJob Class
PrintPreviewJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintPreviewJob Constructor(Printer,Icm,Boolean)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(Printer,Icm,Boolean)

printer
The printer the print preview job is to print to.
imageColorManagement
The image color management settings to use for the print job.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.

Glossary Item Box

Creates a new print preview job using the specified printer for the destination and specified image color management object for image color management settings.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printer As Printer, _
   ByVal imageColorManagement As Icm, _
   ByVal useHardwareMargins As Boolean _
)
'Usage

Dim printer As Printer
Dim imageColorManagement As Icm
Dim useHardwareMargins As Boolean

Dim instance As New PrintPreviewJob(printer, imageColorManagement, useHardwareMargins)
public PrintPreviewJob(
   Printer printer,
   Icm imageColorManagement,
   bool useHardwareMargins
)
public: PrintPreviewJob(
   Printer* printer,
   Icm* imageColorManagement,
   bool useHardwareMargins
)
public:
PrintPreviewJob(
   Printer^ printer,
   Icm^ imageColorManagement,
   bool useHardwareMargins
)

Parameters

printer
The printer the print preview job is to print to.
imageColorManagement
The image color management settings to use for the print job.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.

See Also

Reference

PrintPreviewJob Class
PrintPreviewJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintPreviewJob Constructor(Printer,Icm,Boolean,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(Printer,Icm,Boolean,String)

printer
The printer the print preview job is to print to.
imageColorManagement
The image color management settings to use for the print job.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.
name
The name to use for the print job.

Glossary Item Box

Creates a new print preview job using the specified printer for the destination, the specified image color management object for image color management settings, and the specified name.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printer As Printer, _
   ByVal imageColorManagement As Icm, _
   ByVal useHardwareMargins As Boolean, _
   ByVal name As String _
)
'Usage

Dim printer As Printer
Dim imageColorManagement As Icm
Dim useHardwareMargins As Boolean
Dim name As String

Dim instance As New PrintPreviewJob(printer, imageColorManagement, useHardwareMargins, name)
public PrintPreviewJob(
   Printer printer,
   Icm imageColorManagement,
   bool useHardwareMargins,
   string name
)
public: PrintPreviewJob(
   Printer* printer,
   Icm* imageColorManagement,
   bool useHardwareMargins,
   string* name
)
public:
PrintPreviewJob(
   Printer^ printer,
   Icm^ imageColorManagement,
   bool useHardwareMargins,
   String^ name
)

Parameters

printer
The printer the print preview job is to print to.
imageColorManagement
The image color management settings to use for the print job.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.
name
The name to use for the print job.

See Also

Reference

PrintPreviewJob Class
PrintPreviewJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintPreviewJob Constructor(PrintPro,Printer,Icm)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(PrintPro,Printer,Icm)

printProWorkspace
The workspace object to use with the job.
printer
The printer the print preview job is to print to.
imageColorManagement
The image color management settings to use for the print job.

Glossary Item Box

Creates a new print preview job using the specified printer for the destination.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printProWorkspace As PrintPro, _
   ByVal printer As Printer, _
   ByVal imageColorManagement As Icm _
)
'Usage

Dim printProWorkspace As PrintPro
Dim printer As Printer
Dim imageColorManagement As Icm

Dim instance As New PrintPreviewJob(printProWorkspace, printer, imageColorManagement)
public PrintPreviewJob(
   PrintPro printProWorkspace,
   Printer printer,
   Icm imageColorManagement
)
public: PrintPreviewJob(
   PrintPro* printProWorkspace,
   Printer* printer,
   Icm* imageColorManagement
)
public:
PrintPreviewJob(
   PrintPro^ printProWorkspace,
   Printer^ printer,
   Icm^ imageColorManagement
)

Parameters

printProWorkspace
The workspace object to use with the job.
printer
The printer the print preview job is to print to.
imageColorManagement
The image color management settings to use for the print job.

See Also

Reference

PrintPreviewJob Class
PrintPreviewJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintPreviewJob Constructor(PrintPro,Printer,Icm,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(PrintPro,Printer,Icm,String)

printProWorkspace
The workspace object to use with the job.
printer
The printer the print preview job is to print to.
imageColorManagement
The image color management settings to use for the print job.
name
The name to use for the print job.

Glossary Item Box

Creates a new print preview job using the specified printer for the destination and the specified name.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printProWorkspace As PrintPro, _
   ByVal printer As Printer, _
   ByVal imageColorManagement As Icm, _
   ByVal name As String _
)
'Usage

Dim printProWorkspace As PrintPro
Dim printer As Printer
Dim imageColorManagement As Icm
Dim name As String

Dim instance As New PrintPreviewJob(printProWorkspace, printer, imageColorManagement, name)
public PrintPreviewJob(
   PrintPro printProWorkspace,
   Printer printer,
   Icm imageColorManagement,
   string name
)
public: PrintPreviewJob(
   PrintPro* printProWorkspace,
   Printer* printer,
   Icm* imageColorManagement,
   string* name
)
public:
PrintPreviewJob(
   PrintPro^ printProWorkspace,
   Printer^ printer,
   Icm^ imageColorManagement,
   String^ name
)

Parameters

printProWorkspace
The workspace object to use with the job.
printer
The printer the print preview job is to print to.
imageColorManagement
The image color management settings to use for the print job.
name
The name to use for the print job.

See Also

Reference

PrintPreviewJob Class
PrintPreviewJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintPreviewJob Constructor(PrintPro,Printer,Icm,Boolean)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(PrintPro,Printer,Icm,Boolean)

printProWorkspace
The workspace object to use with the job.
printer
The printer the print preview job is to print to.
imageColorManagement
The image color management settings to use for the print job.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.

Glossary Item Box

Creates a new print preview job using the specified printer for the destination.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printProWorkspace As PrintPro, _
   ByVal printer As Printer, _
   ByVal imageColorManagement As Icm, _
   ByVal useHardwareMargins As Boolean _
)
'Usage

Dim printProWorkspace As PrintPro
Dim printer As Printer
Dim imageColorManagement As Icm
Dim useHardwareMargins As Boolean

Dim instance As New PrintPreviewJob(printProWorkspace, printer, imageColorManagement, useHardwareMargins)
public PrintPreviewJob(
   PrintPro printProWorkspace,
   Printer printer,
   Icm imageColorManagement,
   bool useHardwareMargins
)
public: PrintPreviewJob(
   PrintPro* printProWorkspace,
   Printer* printer,
   Icm* imageColorManagement,
   bool useHardwareMargins
)
public:
PrintPreviewJob(
   PrintPro^ printProWorkspace,
   Printer^ printer,
   Icm^ imageColorManagement,
   bool useHardwareMargins
)

Parameters

printProWorkspace
The workspace object to use with the job.
printer
The printer the print preview job is to print to.
imageColorManagement
The image color management settings to use for the print job.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.

See Also

Reference

PrintPreviewJob Class
PrintPreviewJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintPreviewJob Constructor(PrintPro,Printer,Icm,Boolean,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(PrintPro,Printer,Icm,Boolean,String)

printProWorkspace
The workspace object to use with the job.
printer
The printer the print preview job is to print to.
imageColorManagement
The image color management settings to use for the print job.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.
name
The name to use for the print job.

Glossary Item Box

Creates a new print preview job using the specified printer for the destination and the specified name.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printProWorkspace As PrintPro, _
   ByVal printer As Printer, _
   ByVal imageColorManagement As Icm, _
   ByVal useHardwareMargins As Boolean, _
   ByVal name As String _
)
'Usage

Dim printProWorkspace As PrintPro
Dim printer As Printer
Dim imageColorManagement As Icm
Dim useHardwareMargins As Boolean
Dim name As String

Dim instance As New PrintPreviewJob(printProWorkspace, printer, imageColorManagement, useHardwareMargins, name)
public PrintPreviewJob(
   PrintPro printProWorkspace,
   Printer printer,
   Icm imageColorManagement,
   bool useHardwareMargins,
   string name
)
public: PrintPreviewJob(
   PrintPro* printProWorkspace,
   Printer* printer,
   Icm* imageColorManagement,
   bool useHardwareMargins,
   string* name
)
public:
PrintPreviewJob(
   PrintPro^ printProWorkspace,
   Printer^ printer,
   Icm^ imageColorManagement,
   bool useHardwareMargins,
   String^ name
)

Parameters

printProWorkspace
The workspace object to use with the job.
printer
The printer the print preview job is to print to.
imageColorManagement
The image color management settings to use for the print job.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.
name
The name to use for the print job.

See Also

Reference

PrintPreviewJob Class
PrintPreviewJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintPreviewJob Constructor(PrintPro,PrintPreviewScale)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(PrintPro,PrintPreviewScale)

printProWorkspace
The workspace object to use with the job.
printPreviewScale
The print preview scaling that should be used.

Glossary Item Box

Creates a new print job using the default printer for the destination and specified scaling

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printProWorkspace As PrintPro, _
   ByVal printPreviewScale As PrintPreviewScale _
)
'Usage

Dim printProWorkspace As PrintPro
Dim printPreviewScale As PrintPreviewScale

Dim instance As New PrintPreviewJob(printProWorkspace, printPreviewScale)
public PrintPreviewJob(
   PrintPro printProWorkspace,
   PrintPreviewScale printPreviewScale
)
public: PrintPreviewJob(
   PrintPro* printProWorkspace,
   PrintPreviewScale printPreviewScale
)
public:
PrintPreviewJob(
   PrintPro^ printProWorkspace,
   PrintPreviewScale printPreviewScale
)

Parameters

printProWorkspace
The workspace object to use with the job.
printPreviewScale
The print preview scaling that should be used.

See Also

Reference

PrintPreviewJob Class
PrintPreviewJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintPreviewJob Constructor(PrintPro,PrintPreviewScale,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(PrintPro,PrintPreviewScale,String)

printProWorkspace
The workspace object to use with the job.
printPreviewScale
The print preview scaling that should be used.
name
The name to use for the print job.

Glossary Item Box

Creates a new print job using the default printer for the destination, the specified scaling, and the specified name.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printProWorkspace As PrintPro, _
   ByVal printPreviewScale As PrintPreviewScale, _
   ByVal name As String _
)
'Usage

Dim printProWorkspace As PrintPro
Dim printPreviewScale As PrintPreviewScale
Dim name As String

Dim instance As New PrintPreviewJob(printProWorkspace, printPreviewScale, name)
public PrintPreviewJob(
   PrintPro printProWorkspace,
   PrintPreviewScale printPreviewScale,
   string name
)
public: PrintPreviewJob(
   PrintPro* printProWorkspace,
   PrintPreviewScale printPreviewScale,
   string* name
)
public:
PrintPreviewJob(
   PrintPro^ printProWorkspace,
   PrintPreviewScale printPreviewScale,
   String^ name
)

Parameters

printProWorkspace
The workspace object to use with the job.
printPreviewScale
The print preview scaling that should be used.
name
The name to use for the print job.

See Also

Reference

PrintPreviewJob Class
PrintPreviewJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintPreviewJob Constructor(PrintPro,PrintPreviewScale,Boolean)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(PrintPro,PrintPreviewScale,Boolean)

printProWorkspace
The workspace object to use with the job.
printPreviewScale
The print preview scaling that should be used.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.

Glossary Item Box

Creates a new print job using the default printer for the destination and specified scaling.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printProWorkspace As PrintPro, _
   ByVal printPreviewScale As PrintPreviewScale, _
   ByVal useHardwareMargins As Boolean _
)
'Usage

Dim printProWorkspace As PrintPro
Dim printPreviewScale As PrintPreviewScale
Dim useHardwareMargins As Boolean

Dim instance As New PrintPreviewJob(printProWorkspace, printPreviewScale, useHardwareMargins)
public PrintPreviewJob(
   PrintPro printProWorkspace,
   PrintPreviewScale printPreviewScale,
   bool useHardwareMargins
)
public: PrintPreviewJob(
   PrintPro* printProWorkspace,
   PrintPreviewScale printPreviewScale,
   bool useHardwareMargins
)
public:
PrintPreviewJob(
   PrintPro^ printProWorkspace,
   PrintPreviewScale printPreviewScale,
   bool useHardwareMargins
)

Parameters

printProWorkspace
The workspace object to use with the job.
printPreviewScale
The print preview scaling that should be used.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.

See Also

Reference

PrintPreviewJob Class
PrintPreviewJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintPreviewJob Constructor(PrintPro,PrintPreviewScale,Boolean,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(PrintPro,PrintPreviewScale,Boolean,String)

printProWorkspace
The workspace object to use with the job.
printPreviewScale
The print preview scaling that should be used.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.
name
The name to use for the print job.

Glossary Item Box

Creates a new print job using the default printer for the destination, the specified scaling, and the specified name.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printProWorkspace As PrintPro, _
   ByVal printPreviewScale As PrintPreviewScale, _
   ByVal useHardwareMargins As Boolean, _
   ByVal name As String _
)
'Usage

Dim printProWorkspace As PrintPro
Dim printPreviewScale As PrintPreviewScale
Dim useHardwareMargins As Boolean
Dim name As String

Dim instance As New PrintPreviewJob(printProWorkspace, printPreviewScale, useHardwareMargins, name)
public PrintPreviewJob(
   PrintPro printProWorkspace,
   PrintPreviewScale printPreviewScale,
   bool useHardwareMargins,
   string name
)
public: PrintPreviewJob(
   PrintPro* printProWorkspace,
   PrintPreviewScale printPreviewScale,
   bool useHardwareMargins,
   string* name
)
public:
PrintPreviewJob(
   PrintPro^ printProWorkspace,
   PrintPreviewScale printPreviewScale,
   bool useHardwareMargins,
   String^ name
)

Parameters

printProWorkspace
The workspace object to use with the job.
printPreviewScale
The print preview scaling that should be used.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.
name
The name to use for the print job.

See Also

Reference

PrintPreviewJob Class
PrintPreviewJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintPreviewJob Constructor(PrintPro,PrintPreviewScale,Icm)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(PrintPro,PrintPreviewScale,Icm)

printProWorkspace
The workspace object to use with the job.
printPreviewScale
The print preview scaling that should be used.
imageColorManagement
The image color management settings to use for the print job.

Glossary Item Box

Creates a new print job using the default printer for the destination and specified scaling.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printProWorkspace As PrintPro, _
   ByVal printPreviewScale As PrintPreviewScale, _
   ByVal imageColorManagement As Icm _
)
'Usage

Dim printProWorkspace As PrintPro
Dim printPreviewScale As PrintPreviewScale
Dim imageColorManagement As Icm

Dim instance As New PrintPreviewJob(printProWorkspace, printPreviewScale, imageColorManagement)
public PrintPreviewJob(
   PrintPro printProWorkspace,
   PrintPreviewScale printPreviewScale,
   Icm imageColorManagement
)
public: PrintPreviewJob(
   PrintPro* printProWorkspace,
   PrintPreviewScale printPreviewScale,
   Icm* imageColorManagement
)
public:
PrintPreviewJob(
   PrintPro^ printProWorkspace,
   PrintPreviewScale printPreviewScale,
   Icm^ imageColorManagement
)

Parameters

printProWorkspace
The workspace object to use with the job.
printPreviewScale
The print preview scaling that should be used.
imageColorManagement
The image color management settings to use for the print job.

See Also

Reference

PrintPreviewJob Class
PrintPreviewJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintPreviewJob Constructor(PrintPro,PrintPreviewScale,Icm,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(PrintPro,PrintPreviewScale,Icm,String)

printProWorkspace
The workspace object to use with the job.
printPreviewScale
The print preview scaling that should be used.
imageColorManagement
The image color management settings to use for the print job.
name
The name to use for the print job.

Glossary Item Box

Creates a new print job using the default printer for the destination, the specified scaling, and the specified name.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printProWorkspace As PrintPro, _
   ByVal printPreviewScale As PrintPreviewScale, _
   ByVal imageColorManagement As Icm, _
   ByVal name As String _
)
'Usage

Dim printProWorkspace As PrintPro
Dim printPreviewScale As PrintPreviewScale
Dim imageColorManagement As Icm
Dim name As String

Dim instance As New PrintPreviewJob(printProWorkspace, printPreviewScale, imageColorManagement, name)
public PrintPreviewJob(
   PrintPro printProWorkspace,
   PrintPreviewScale printPreviewScale,
   Icm imageColorManagement,
   string name
)
public: PrintPreviewJob(
   PrintPro* printProWorkspace,
   PrintPreviewScale printPreviewScale,
   Icm* imageColorManagement,
   string* name
)
public:
PrintPreviewJob(
   PrintPro^ printProWorkspace,
   PrintPreviewScale printPreviewScale,
   Icm^ imageColorManagement,
   String^ name
)

Parameters

printProWorkspace
The workspace object to use with the job.
printPreviewScale
The print preview scaling that should be used.
imageColorManagement
The image color management settings to use for the print job.
name
The name to use for the print job.

See Also

Reference

PrintPreviewJob Class
PrintPreviewJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintPreviewJob Constructor(PrintPro,PrintPreviewScale,Icm,Boolean)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(PrintPro,PrintPreviewScale,Icm,Boolean)

printProWorkspace
The workspace object to use with the job.
printPreviewScale
The print preview scaling that should be used.
imageColorManagement
The image color management settings to use for the print job.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.

Glossary Item Box

Creates a new print job using the default printer for the destination and specified scaling.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printProWorkspace As PrintPro, _
   ByVal printPreviewScale As PrintPreviewScale, _
   ByVal imageColorManagement As Icm, _
   ByVal useHardwareMargins As Boolean _
)
'Usage

Dim printProWorkspace As PrintPro
Dim printPreviewScale As PrintPreviewScale
Dim imageColorManagement As Icm
Dim useHardwareMargins As Boolean

Dim instance As New PrintPreviewJob(printProWorkspace, printPreviewScale, imageColorManagement, useHardwareMargins)
public PrintPreviewJob(
   PrintPro printProWorkspace,
   PrintPreviewScale printPreviewScale,
   Icm imageColorManagement,
   bool useHardwareMargins
)
public: PrintPreviewJob(
   PrintPro* printProWorkspace,
   PrintPreviewScale printPreviewScale,
   Icm* imageColorManagement,
   bool useHardwareMargins
)
public:
PrintPreviewJob(
   PrintPro^ printProWorkspace,
   PrintPreviewScale printPreviewScale,
   Icm^ imageColorManagement,
   bool useHardwareMargins
)

Parameters

printProWorkspace
The workspace object to use with the job.
printPreviewScale
The print preview scaling that should be used.
imageColorManagement
The image color management settings to use for the print job.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.

See Also

Reference

PrintPreviewJob Class
PrintPreviewJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintPreviewJob Constructor(PrintPro,PrintPreviewScale,Icm,Boolean,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(PrintPro,PrintPreviewScale,Icm,Boolean,String)

printProWorkspace
The workspace object to use with the job.
printPreviewScale
The print preview scaling that should be used.
imageColorManagement
The image color management settings to use for the print job.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.
name
The name to use for the print job.

Glossary Item Box

Creates a new print job using the default printer for the destination, the specified scaling, and the specified name.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printProWorkspace As PrintPro, _
   ByVal printPreviewScale As PrintPreviewScale, _
   ByVal imageColorManagement As Icm, _
   ByVal useHardwareMargins As Boolean, _
   ByVal name As String _
)
'Usage

Dim printProWorkspace As PrintPro
Dim printPreviewScale As PrintPreviewScale
Dim imageColorManagement As Icm
Dim useHardwareMargins As Boolean
Dim name As String

Dim instance As New PrintPreviewJob(printProWorkspace, printPreviewScale, imageColorManagement, useHardwareMargins, name)
public PrintPreviewJob(
   PrintPro printProWorkspace,
   PrintPreviewScale printPreviewScale,
   Icm imageColorManagement,
   bool useHardwareMargins,
   string name
)
public: PrintPreviewJob(
   PrintPro* printProWorkspace,
   PrintPreviewScale printPreviewScale,
   Icm* imageColorManagement,
   bool useHardwareMargins,
   string* name
)
public:
PrintPreviewJob(
   PrintPro^ printProWorkspace,
   PrintPreviewScale printPreviewScale,
   Icm^ imageColorManagement,
   bool useHardwareMargins,
   String^ name
)

Parameters

printProWorkspace
The workspace object to use with the job.
printPreviewScale
The print preview scaling that should be used.
imageColorManagement
The image color management settings to use for the print job.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.
name
The name to use for the print job.

See Also

Reference

PrintPreviewJob Class
PrintPreviewJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintPreviewJob Constructor(PrintPro,Printer,PrintPreviewScale,Icm,Boolean)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(PrintPro,Printer,PrintPreviewScale,Icm,Boolean)

printProWorkspace
The workspace object to use with the job.
printer
The printer the print preview job is to print to.
printPreviewScale
The print preview scaling that should be used.
imageColorManagement
The image color management settings to use for the print job.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.

Glossary Item Box

Creates a new print job using the specified printer for the destination and specified scaling.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printProWorkspace As PrintPro, _
   ByVal printer As Printer, _
   ByVal printPreviewScale As PrintPreviewScale, _
   ByVal imageColorManagement As Icm, _
   ByVal useHardwareMargins As Boolean _
)
'Usage

Dim printProWorkspace As PrintPro
Dim printer As Printer
Dim printPreviewScale As PrintPreviewScale
Dim imageColorManagement As Icm
Dim useHardwareMargins As Boolean

Dim instance As New PrintPreviewJob(printProWorkspace, printer, printPreviewScale, imageColorManagement, useHardwareMargins)
public PrintPreviewJob(
   PrintPro printProWorkspace,
   Printer printer,
   PrintPreviewScale printPreviewScale,
   Icm imageColorManagement,
   bool useHardwareMargins
)
public: PrintPreviewJob(
   PrintPro* printProWorkspace,
   Printer* printer,
   PrintPreviewScale printPreviewScale,
   Icm* imageColorManagement,
   bool useHardwareMargins
)
public:
PrintPreviewJob(
   PrintPro^ printProWorkspace,
   Printer^ printer,
   PrintPreviewScale printPreviewScale,
   Icm^ imageColorManagement,
   bool useHardwareMargins
)

Parameters

printProWorkspace
The workspace object to use with the job.
printer
The printer the print preview job is to print to.
printPreviewScale
The print preview scaling that should be used.
imageColorManagement
The image color management settings to use for the print job.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.

See Also

Reference

PrintPreviewJob Class
PrintPreviewJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintPreviewJob Constructor(PrintPro,Printer,PrintPreviewScale,Icm,Boolean,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(PrintPro,Printer,PrintPreviewScale,Icm,Boolean,String)

printProWorkspace
The workspace object to use with the job.
printer
The printer the print preview job is to print to.
printPreviewScale
The print preview scaling that should be used.
imageColorManagement
The image color management settings to use for the print job.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.
name
The name to use for the print job.

Glossary Item Box

Creates a new print job using the specified printer for the destination, the specified scaling, and the specified name.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printProWorkspace As PrintPro, _
   ByVal printer As Printer, _
   ByVal printPreviewScale As PrintPreviewScale, _
   ByVal imageColorManagement As Icm, _
   ByVal useHardwareMargins As Boolean, _
   ByVal name As String _
)
'Usage

Dim printProWorkspace As PrintPro
Dim printer As Printer
Dim printPreviewScale As PrintPreviewScale
Dim imageColorManagement As Icm
Dim useHardwareMargins As Boolean
Dim name As String

Dim instance As New PrintPreviewJob(printProWorkspace, printer, printPreviewScale, imageColorManagement, useHardwareMargins, name)
public PrintPreviewJob(
   PrintPro printProWorkspace,
   Printer printer,
   PrintPreviewScale printPreviewScale,
   Icm imageColorManagement,
   bool useHardwareMargins,
   string name
)
public: PrintPreviewJob(
   PrintPro* printProWorkspace,
   Printer* printer,
   PrintPreviewScale printPreviewScale,
   Icm* imageColorManagement,
   bool useHardwareMargins,
   string* name
)
public:
PrintPreviewJob(
   PrintPro^ printProWorkspace,
   Printer^ printer,
   PrintPreviewScale printPreviewScale,
   Icm^ imageColorManagement,
   bool useHardwareMargins,
   String^ name
)

Parameters

printProWorkspace
The workspace object to use with the job.
printer
The printer the print preview job is to print to.
printPreviewScale
The print preview scaling that should be used.
imageColorManagement
The image color management settings to use for the print job.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.
name
The name to use for the print job.

See Also

Reference

PrintPreviewJob Class
PrintPreviewJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintPreviewJob Constructor(PrintPro,Printer,PrintPreviewScale,Boolean)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(PrintPro,Printer,PrintPreviewScale,Boolean)

printProWorkspace
The workspace object to use with the job.
printer
The printer the print preview job is to print to.
printPreviewScale
The print preview scaling that should be used.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.

Glossary Item Box

Creates a new print job using the specified printer for the destination and specified scaling.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printProWorkspace As PrintPro, _
   ByVal printer As Printer, _
   ByVal printPreviewScale As PrintPreviewScale, _
   ByVal useHardwareMargins As Boolean _
)
'Usage

Dim printProWorkspace As PrintPro
Dim printer As Printer
Dim printPreviewScale As PrintPreviewScale
Dim useHardwareMargins As Boolean

Dim instance As New PrintPreviewJob(printProWorkspace, printer, printPreviewScale, useHardwareMargins)
public PrintPreviewJob(
   PrintPro printProWorkspace,
   Printer printer,
   PrintPreviewScale printPreviewScale,
   bool useHardwareMargins
)
public: PrintPreviewJob(
   PrintPro* printProWorkspace,
   Printer* printer,
   PrintPreviewScale printPreviewScale,
   bool useHardwareMargins
)
public:
PrintPreviewJob(
   PrintPro^ printProWorkspace,
   Printer^ printer,
   PrintPreviewScale printPreviewScale,
   bool useHardwareMargins
)

Parameters

printProWorkspace
The workspace object to use with the job.
printer
The printer the print preview job is to print to.
printPreviewScale
The print preview scaling that should be used.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.

See Also

Reference

PrintPreviewJob Class
PrintPreviewJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintPreviewJob Constructor(PrintPro,Printer,PrintPreviewScale,Boolean,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(PrintPro,Printer,PrintPreviewScale,Boolean,String)

printProWorkspace
The workspace object to use with the job.
printer
The printer the print preview job is to print to.
printPreviewScale
The print preview scaling that should be used.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.
name
The name to use for the print job.

Glossary Item Box

Creates a new print job using the specified printer for the destination, the specified scaling, and the specified name.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printProWorkspace As PrintPro, _
   ByVal printer As Printer, _
   ByVal printPreviewScale As PrintPreviewScale, _
   ByVal useHardwareMargins As Boolean, _
   ByVal name As String _
)
'Usage

Dim printProWorkspace As PrintPro
Dim printer As Printer
Dim printPreviewScale As PrintPreviewScale
Dim useHardwareMargins As Boolean
Dim name As String

Dim instance As New PrintPreviewJob(printProWorkspace, printer, printPreviewScale, useHardwareMargins, name)
public PrintPreviewJob(
   PrintPro printProWorkspace,
   Printer printer,
   PrintPreviewScale printPreviewScale,
   bool useHardwareMargins,
   string name
)
public: PrintPreviewJob(
   PrintPro* printProWorkspace,
   Printer* printer,
   PrintPreviewScale printPreviewScale,
   bool useHardwareMargins,
   string* name
)
public:
PrintPreviewJob(
   PrintPro^ printProWorkspace,
   Printer^ printer,
   PrintPreviewScale printPreviewScale,
   bool useHardwareMargins,
   String^ name
)

Parameters

printProWorkspace
The workspace object to use with the job.
printer
The printer the print preview job is to print to.
printPreviewScale
The print preview scaling that should be used.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.
name
The name to use for the print job.

See Also

Reference

PrintPreviewJob Class
PrintPreviewJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintPreviewJob Constructor(Printer,PrintPreviewScale)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(Printer,PrintPreviewScale)

printer
The printer the print preview job is to print to.
printPreviewScale
The print preview scaling that should be used.

Glossary Item Box

Creates a new print job using the specified printer for the destination and specified scaling.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printer As Printer, _
   ByVal printPreviewScale As PrintPreviewScale _
)
'Usage

Dim printer As Printer
Dim printPreviewScale As PrintPreviewScale

Dim instance As New PrintPreviewJob(printer, printPreviewScale)
public PrintPreviewJob(
   Printer printer,
   PrintPreviewScale printPreviewScale
)
public: PrintPreviewJob(
   Printer* printer,
   PrintPreviewScale printPreviewScale
)
public:
PrintPreviewJob(
   Printer^ printer,
   PrintPreviewScale printPreviewScale
)

Parameters

printer
The printer the print preview job is to print to.
printPreviewScale
The print preview scaling that should be used.

See Also

Reference

PrintPreviewJob Class
PrintPreviewJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintPreviewJob Constructor(Printer,PrintPreviewScale,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(Printer,PrintPreviewScale,String)

printer
The printer the print preview job is to print to.
printPreviewScale
The print preview scaling that should be used.
name
The name to use for the print job.

Glossary Item Box

Creates a new print job using the specified printer for the destination, the specified scaling, and the specified name.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printer As Printer, _
   ByVal printPreviewScale As PrintPreviewScale, _
   ByVal name As String _
)
'Usage

Dim printer As Printer
Dim printPreviewScale As PrintPreviewScale
Dim name As String

Dim instance As New PrintPreviewJob(printer, printPreviewScale, name)
public PrintPreviewJob(
   Printer printer,
   PrintPreviewScale printPreviewScale,
   string name
)
public: PrintPreviewJob(
   Printer* printer,
   PrintPreviewScale printPreviewScale,
   string* name
)
public:
PrintPreviewJob(
   Printer^ printer,
   PrintPreviewScale printPreviewScale,
   String^ name
)

Parameters

printer
The printer the print preview job is to print to.
printPreviewScale
The print preview scaling that should be used.
name
The name to use for the print job.

See Also

Reference

PrintPreviewJob Class
PrintPreviewJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintPreviewJob Constructor(Printer,PrintPreviewScale,Boolean)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(Printer,PrintPreviewScale,Boolean)

printer
The printer the print preview job is to print to.
printPreviewScale
The print preview scaling that should be used.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.

Glossary Item Box

Creates a new print job using the specified printer for the destination and specified scaling.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printer As Printer, _
   ByVal printPreviewScale As PrintPreviewScale, _
   ByVal useHardwareMargins As Boolean _
)
'Usage

Dim printer As Printer
Dim printPreviewScale As PrintPreviewScale
Dim useHardwareMargins As Boolean

Dim instance As New PrintPreviewJob(printer, printPreviewScale, useHardwareMargins)
public PrintPreviewJob(
   Printer printer,
   PrintPreviewScale printPreviewScale,
   bool useHardwareMargins
)
public: PrintPreviewJob(
   Printer* printer,
   PrintPreviewScale printPreviewScale,
   bool useHardwareMargins
)
public:
PrintPreviewJob(
   Printer^ printer,
   PrintPreviewScale printPreviewScale,
   bool useHardwareMargins
)

Parameters

printer
The printer the print preview job is to print to.
printPreviewScale
The print preview scaling that should be used.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.

See Also

Reference

PrintPreviewJob Class
PrintPreviewJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintPreviewJob Constructor(Printer,PrintPreviewScale,Boolean,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(Printer,PrintPreviewScale,Boolean,String)

printer
The printer the print preview job is to print to.
printPreviewScale
The print preview scaling that should be used.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.
name
The name to use for the print job.

Glossary Item Box

Creates a new print job using the specified printer for the destination, the specified scaling, and the specified name.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printer As Printer, _
   ByVal printPreviewScale As PrintPreviewScale, _
   ByVal useHardwareMargins As Boolean, _
   ByVal name As String _
)
'Usage

Dim printer As Printer
Dim printPreviewScale As PrintPreviewScale
Dim useHardwareMargins As Boolean
Dim name As String

Dim instance As New PrintPreviewJob(printer, printPreviewScale, useHardwareMargins, name)
public PrintPreviewJob(
   Printer printer,
   PrintPreviewScale printPreviewScale,
   bool useHardwareMargins,
   string name
)
public: PrintPreviewJob(
   Printer* printer,
   PrintPreviewScale printPreviewScale,
   bool useHardwareMargins,
   string* name
)
public:
PrintPreviewJob(
   Printer^ printer,
   PrintPreviewScale printPreviewScale,
   bool useHardwareMargins,
   String^ name
)

Parameters

printer
The printer the print preview job is to print to.
printPreviewScale
The print preview scaling that should be used.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.
name
The name to use for the print job.

See Also

Reference

PrintPreviewJob Class
PrintPreviewJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintPreviewJob Constructor(Printer,PrintPreviewScale,Icm)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(Printer,PrintPreviewScale,Icm)

printer
The printer the print preview job is to print to.
printPreviewScale
The print preview scaling that should be used.
imageColorManagement
The image color management settings to use for the print job.

Glossary Item Box

Creates a new print job using the specified printer for the destination and specified scaling.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printer As Printer, _
   ByVal printPreviewScale As PrintPreviewScale, _
   ByVal imageColorManagement As Icm _
)
'Usage

Dim printer As Printer
Dim printPreviewScale As PrintPreviewScale
Dim imageColorManagement As Icm

Dim instance As New PrintPreviewJob(printer, printPreviewScale, imageColorManagement)
public PrintPreviewJob(
   Printer printer,
   PrintPreviewScale printPreviewScale,
   Icm imageColorManagement
)
public: PrintPreviewJob(
   Printer* printer,
   PrintPreviewScale printPreviewScale,
   Icm* imageColorManagement
)
public:
PrintPreviewJob(
   Printer^ printer,
   PrintPreviewScale printPreviewScale,
   Icm^ imageColorManagement
)

Parameters

printer
The printer the print preview job is to print to.
printPreviewScale
The print preview scaling that should be used.
imageColorManagement
The image color management settings to use for the print job.

See Also

Reference

PrintPreviewJob Class
PrintPreviewJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintPreviewJob Constructor(Printer,PrintPreviewScale,Icm,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(Printer,PrintPreviewScale,Icm,String)

printer
The printer the print preview job is to print to.
printPreviewScale
The print preview scaling that should be used.
imageColorManagement
The image color management settings to use for the print job.
name
The name to use for the print job.

Glossary Item Box

Creates a new print job using the specified printer for the destination, the specified scaling, and the specified name.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printer As Printer, _
   ByVal printPreviewScale As PrintPreviewScale, _
   ByVal imageColorManagement As Icm, _
   ByVal name As String _
)
'Usage

Dim printer As Printer
Dim printPreviewScale As PrintPreviewScale
Dim imageColorManagement As Icm
Dim name As String

Dim instance As New PrintPreviewJob(printer, printPreviewScale, imageColorManagement, name)
public PrintPreviewJob(
   Printer printer,
   PrintPreviewScale printPreviewScale,
   Icm imageColorManagement,
   string name
)
public: PrintPreviewJob(
   Printer* printer,
   PrintPreviewScale printPreviewScale,
   Icm* imageColorManagement,
   string* name
)
public:
PrintPreviewJob(
   Printer^ printer,
   PrintPreviewScale printPreviewScale,
   Icm^ imageColorManagement,
   String^ name
)

Parameters

printer
The printer the print preview job is to print to.
printPreviewScale
The print preview scaling that should be used.
imageColorManagement
The image color management settings to use for the print job.
name
The name to use for the print job.

See Also

Reference

PrintPreviewJob Class
PrintPreviewJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintPreviewJob Constructor(Printer,PrintPreviewScale,Icm,Boolean)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(Printer,PrintPreviewScale,Icm,Boolean)

printer
The printer the print preview job is to print to.
printPreviewScale
The print preview scaling that should be used.
imageColorManagement
The image color management settings to use for the print job.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.

Glossary Item Box

Creates a new print job using the specified printer for the destination and specified scaling.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printer As Printer, _
   ByVal printPreviewScale As PrintPreviewScale, _
   ByVal imageColorManagement As Icm, _
   ByVal useHardwareMargins As Boolean _
)
'Usage

Dim printer As Printer
Dim printPreviewScale As PrintPreviewScale
Dim imageColorManagement As Icm
Dim useHardwareMargins As Boolean

Dim instance As New PrintPreviewJob(printer, printPreviewScale, imageColorManagement, useHardwareMargins)
public PrintPreviewJob(
   Printer printer,
   PrintPreviewScale printPreviewScale,
   Icm imageColorManagement,
   bool useHardwareMargins
)
public: PrintPreviewJob(
   Printer* printer,
   PrintPreviewScale printPreviewScale,
   Icm* imageColorManagement,
   bool useHardwareMargins
)
public:
PrintPreviewJob(
   Printer^ printer,
   PrintPreviewScale printPreviewScale,
   Icm^ imageColorManagement,
   bool useHardwareMargins
)

Parameters

printer
The printer the print preview job is to print to.
printPreviewScale
The print preview scaling that should be used.
imageColorManagement
The image color management settings to use for the print job.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.

See Also

Reference

PrintPreviewJob Class
PrintPreviewJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintPreviewJob Constructor(Printer,PrintPreviewScale,Icm,Boolean,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintPreviewJob Class > PrintPreviewJob Constructor : PrintPreviewJob Constructor(Printer,PrintPreviewScale,Icm,Boolean,String)

printer
The printer the print preview job is to print to.
printPreviewScale
The print preview scaling that should be used.
imageColorManagement
The image color management settings to use for the print job.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.
name
The name to use for the print job.

Glossary Item Box

Creates a new print job using the specified printer for the destination, the specified scaling, and the specified name.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal printer As Printer, _
   ByVal printPreviewScale As PrintPreviewScale, _
   ByVal imageColorManagement As Icm, _
   ByVal useHardwareMargins As Boolean, _
   ByVal name As String _
)
'Usage

Dim printer As Printer
Dim printPreviewScale As PrintPreviewScale
Dim imageColorManagement As Icm
Dim useHardwareMargins As Boolean
Dim name As String

Dim instance As New PrintPreviewJob(printer, printPreviewScale, imageColorManagement, useHardwareMargins, name)
public PrintPreviewJob(
   Printer printer,
   PrintPreviewScale printPreviewScale,
   Icm imageColorManagement,
   bool useHardwareMargins,
   string name
)
public: PrintPreviewJob(
   Printer* printer,
   PrintPreviewScale printPreviewScale,
   Icm* imageColorManagement,
   bool useHardwareMargins,
   string* name
)
public:
PrintPreviewJob(
   Printer^ printer,
   PrintPreviewScale printPreviewScale,
   Icm^ imageColorManagement,
   bool useHardwareMargins,
   String^ name
)

Parameters

printer
The printer the print preview job is to print to.
printPreviewScale
The print preview scaling that should be used.
imageColorManagement
The image color management settings to use for the print job.
useHardwareMargins
A boolean value which determines whether or not margins should be determined from the hardware settings.
name
The name to use for the print job.

See Also

Reference

PrintPreviewJob Class
PrintPreviewJob Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Finish Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintPreviewJob Class : Finish Method

Glossary Item Box

Releases the current document to the print device or spooler.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overrides Sub Finish()
'Usage

Dim instance As PrintPreviewJob

instance.Finish()
public override void Finish()
public: void Finish(); override
public:
void Finish(); override

See Also

Reference

PrintPreviewJob Class
PrintPreviewJob Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
GetGraphics Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintPreviewJob Class : GetGraphics Method

Glossary Item Box

Returns a graphics object to the current page.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overrides Function GetGraphics() As Graphics
'Usage

Dim instance As PrintPreviewJob
Dim value As Graphics

value = instance.GetGraphics()
public override Graphics GetGraphics()
public: Graphics* GetGraphics(); override
public:
Graphics^ GetGraphics(); override

Return Value

A graphics object for the current page. You must call Dispose to release resources when drawing has finished.

Remarks

This allows for using native .NET drawing methods to print to the page.

See Also

Reference

PrintPreviewJob Class
PrintPreviewJob Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
GetPrintPreviewBitmap Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintPreviewJob Class : GetPrintPreviewBitmap Method

page
The number of the page you wish to retrieve. Page numbers start with 1 and cannot exceed the current Page property setting.

Glossary Item Box

Obtain the print preview Bitmap for a specified page.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function GetPrintPreviewBitmap( _
   ByVal page As Integer _
) As Bitmap
'Usage

Dim instance As PrintPreviewJob
Dim page As Integer
Dim value As Bitmap

value = instance.GetPrintPreviewBitmap(page)
public Bitmap GetPrintPreviewBitmap(
   int page
)
public: Bitmap* GetPrintPreviewBitmap(
   int page
)
public:
Bitmap^ GetPrintPreviewBitmap(
   int page
)

Parameters

page
The number of the page you wish to retrieve. Page numbers start with 1 and cannot exceed the current Page property setting.

Return Value

An image object of the specified print preview page.

Remarks

The Bitmap returned by GetPrintPreviewBitmap is a copy of the bitmap used by the PrintPro control. GetPrintPreviewBitmap will return null if a bitmap does not exist.

See Also

Reference

PrintPreviewJob Class
PrintPreviewJob Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
GetPrintPreviewDib Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintPreviewJob Class : GetPrintPreviewDib Method

page
The number of the page you wish to retrieve. Page numbers start with 1 and cannot exceed the current Page property setting.

Glossary Item Box

Obtain the print preview dib for a specified page.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function GetPrintPreviewDib( _
   ByVal page As Integer _
) As IntPtr
'Usage

Dim instance As PrintPreviewJob
Dim page As Integer
Dim value As IntPtr

value = instance.GetPrintPreviewDib(page)
public IntPtr GetPrintPreviewDib(
   int page
)
public: IntPtr GetPrintPreviewDib(
   int page
)
public:
IntPtr GetPrintPreviewDib(
   int page
)

Parameters

page
The number of the page you wish to retrieve. Page numbers start with 1 and cannot exceed the current Page property setting.

Return Value

A handle to the print preview Device Independent Bitmap (DIB).

Remarks

The DIB returned by GetPrintPreviewDib is a copy of the bitmap used by the PrintPro control. After using the DIB, you are responsible for deleting it. GetPrintPreviewDib will return IntPtr.Zero if a bitmap does not exist.

See Also

Reference

PrintPreviewJob Class
PrintPreviewJob Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
GetPrintPreviewImage Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintPreviewJob Class : GetPrintPreviewImage Method

page
The number of the page you wish to retrieve. Page numbers start with 1 and cannot exceed the current Page property setting.

Glossary Item Box

Obtain the print preview Image for a specified page.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function GetPrintPreviewImage( _
   ByVal page As Integer _
) As Image
'Usage

Dim instance As PrintPreviewJob
Dim page As Integer
Dim value As Image

value = instance.GetPrintPreviewImage(page)
public Image GetPrintPreviewImage(
   int page
)
public: Image* GetPrintPreviewImage(
   int page
)
public:
Image^ GetPrintPreviewImage(
   int page
)

Parameters

page
The number of the page you wish to retrieve. Page numbers start with 1 and cannot exceed the current Page property setting.

Return Value

An image object of the specified print preview page.

Remarks

The Image returned by GetPrintPreviewImage is a copy of the bitmap used by the PrintPro control. GetPrintPreviewImage will return null if a bitmap does not exist.

See Also

Reference

PrintPreviewJob Class
PrintPreviewJob Members


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
PrintPreviewJob Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : PrintPreviewJob Class

Glossary Item Box

For a list of all members of this type, see PrintPreviewJob members.

Public Properties

 | Name | Description
Public Property | BottomMargin | Gets or sets the distance between the bottom of the physical page and the bottom of the printable area in units of the Printer's PrintUnits. (Inherited from Accusoft.PrintProSdk.PrintJob)
Public Property | DisplayX | Gets the horizontal coordinate of the display area in printer units defined by the PrintPreviewScale property. Not available at design time. (Inherited from Accusoft.PrintProSdk.PrintJob)
Public Property | DisplayY | Gets the vertical coordinate of the display area in printer units defined by the PrintPreviewScale property. (Inherited from Accusoft.PrintProSdk.PrintJob)
Public Property | Draw | Gets a pseudo object used to contain all of the drawing methods. (Inherited from Accusoft.PrintProSdk.PrintJob)
Public Property | Icm | Gets the Image Color Management values that the print job is using. (Inherited from Accusoft.PrintProSdk.PrintJob)
Public Property | LeftMargin | Gets or sets the distance between the left of the physical page and the left of the printable area in units of the Printer's PrintUnits. (Inherited from Accusoft.PrintProSdk.PrintJob)
Public Property | Name | Gets the document name for the print job. Note that setting this property will have no affect on the print job and instead the PrintJob or PrintPreviewJob constructor should be used to specify the document name. The setting of this property will be deprecated and this property will be read-only in a future version. (Inherited from Accusoft.PrintProSdk.PrintJob)
Public Property | Page | Gets the current page number of the document for the print job. (Inherited from Accusoft.PrintProSdk.PrintJob)
Public Property | PaperHeight | Gets the physical height of the paper set up for the printing device, in units determined by the PrintPreviewScale property. (Inherited from Accusoft.PrintProSdk.PrintJob)
Public Property | PaperWidth | Gets the physical width of the paper set up for the printing device, in units determined by the PrintPreviewScale property. (Inherited from Accusoft.PrintProSdk.PrintJob)
Public Property | Printer | Gets the Printer the print job is using. (Inherited from Accusoft.PrintProSdk.PrintJob)
Public Property | PrintHeight | Gets the printable height of the paper set up for the printing device, in units determined by the PrintPreviewScale property. (Inherited from Accusoft.PrintProSdk.PrintJob)
Public Property | PrintPreviewScale | Gets or sets the size of the print preview image.
Public Property | PrintWidth | Gets the printable width of the paper set up for the printing device, in units determined by the PrintPreviewScale property. (Inherited from Accusoft.PrintProSdk.PrintJob)
Public Property | TemplateFileName | Gets and sets the photograph collage description filename. (Inherited from Accusoft.PrintProSdk.PrintJob)
Public Property | TopMargin | Gets or sets the distance between the top of the physical page and the top of the printable area in units of the Printer's PrintUnits. (Inherited from Accusoft.PrintProSdk.PrintJob)
Public Property | UseHardwareMargins | Gets or sets the value to determine if the printer's hardware margins are used or if the margin values are calculated from the average of the printable area subtracted from the physical area. (Inherited from Accusoft.PrintProSdk.PrintJob)
Top

See Also

Reference

PrintPreviewJob Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintPreviewScale Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintPreviewJob Class : PrintPreviewScale Property

Glossary Item Box

Gets or sets the size of the print preview image.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property PrintPreviewScale As PrintPreviewScale
'Usage

Dim instance As PrintPreviewJob
Dim value As PrintPreviewScale

instance.PrintPreviewScale = value

value = instance.PrintPreviewScale
public PrintPreviewScale PrintPreviewScale {get; set;}
public: __property PrintPreviewScale get_PrintPreviewScale();
public: __property void set_PrintPreviewScale(
   PrintPreviewScale value
);
public:
property PrintPreviewScale PrintPreviewScale {
   PrintPreviewScale get();
   void set (    PrintPreviewScale value);
}

Property Value

A PrintPreviewScale value which represents the size of the print preview image.

Remarks

1:1 preview images require substantial memory depending on the paper size and color depth of your monitor. If you create many print preview images, you might run out of memory if you use the 1:1 setting.

See Also

Reference

PrintPreviewJob Class
PrintPreviewJob Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintPro Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : PrintPro Class

Glossary Item Box

This class implements the main functionality of the PrintPro component. A strongly-typed resource class, for looking up localized strings, etc.

Object Model

PrintPro ClassLicensing ClassPrinterCollection ClassPrinter ClassPrinter ClassPaper ClassPaperBin ClassPaperBinCollection ClassPaperBin ClassPaperCollection ClassPaper ClassPrintQuality ClassPrintingUnit StructurePrinter Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DebuggerNonUserCodeAttribute()>
<CompilerGeneratedAttribute()>
<ToolboxBitmapAttribute()>
<GeneratedCodeAttribute(Tool="System.Resources.Tools.StronglyTypedResourceBuilder", Version="4.0.0.0")>
Public Class PrintPro
   Inherits System.ComponentModel.Component
'Usage

Dim instance As PrintPro
[DebuggerNonUserCodeAttribute()]
[CompilerGeneratedAttribute()]
[ToolboxBitmapAttribute()]
[GeneratedCodeAttribute(Tool="System.Resources.Tools.StronglyTypedResourceBuilder", Version="4.0.0.0")]
public class PrintPro : System.ComponentModel.Component
[DebuggerNonUserCodeAttribute()]
[CompilerGeneratedAttribute()]
[ToolboxBitmapAttribute()]
[GeneratedCodeAttribute(Tool="System.Resources.Tools.StronglyTypedResourceBuilder", Version="4.0.0.0")]
public __gc class PrintPro : public System.ComponentModel.Component
[DebuggerNonUserCodeAttribute()]
[CompilerGeneratedAttribute()]
[ToolboxBitmapAttribute()]
[GeneratedCodeAttribute(Tool="System.Resources.Tools.StronglyTypedResourceBuilder", Version="4.0.0.0")]
public ref class PrintPro : public System.ComponentModel.Component

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Accusoft.PrintProSdk.PrintPro

See Also

Reference

PrintPro Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
PrintPro Class Members
See Also Properties Methods Events Send Feedback
Accusoft.PrintProSdk Namespace : PrintPro Class

Glossary Item Box

The following tables list the members exposed by PrintPro.

Public Constructors

 | Name | Description
Public Constructor | PrintPro Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Debug | A property that represents whether or not debug logging is turned on.
Public Property | DebugErrorLevel | Gets and sets a minimum error level a debug message must be for it to be logged in the log file.
Public Property | DebugLogFile | Gets and sets the filename of the debug log file.
Public Property | Licensing | Gets and sets access to an object you can use to provide licensing information to the component.
Public Property | Printers | Gets the collection of printers for printing use.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Version | Returns the version of the PrintPro control at run-time.
Top

Public Methods

 | Name | Description
Public Method | AboutBox | Displays a licensing, version and copyright information dialog box for the PrintPRO product.
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Disposes of any unused resources.
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

PrintPro Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Events$$

[image]
Accusoft.PrintPro6.Net
PrintPro Class Events
See Also Send Feedback
Accusoft.PrintProSdk Namespace : PrintPro Class

Glossary Item Box

For a list of all members of this type, see PrintPro members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

PrintPro Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
PrintPro Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : PrintPro Class

Glossary Item Box

For a list of all members of this type, see PrintPro members.

Public Methods

 | Name | Description
Public Method | AboutBox | Displays a licensing, version and copyright information dialog box for the PrintPRO product.
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Disposes of any unused resources.
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

PrintPro Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintPro Constructor
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintPro Class : PrintPro Constructor

Glossary Item Box

Overload List

Overload | Description
PrintPro Constructor() | Create an instance of the PrintPro workspace.
PrintPro Constructor(IContainer) | Creates an instance of the PrintPro workspace.

See Also

Reference

PrintPro Class
PrintPro Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintPro Constructor()
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintPro Class > PrintPro Constructor : PrintPro Constructor()

Glossary Item Box

Create an instance of the PrintPro workspace.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PrintPro()
public PrintPro()
public: PrintPro();
public:
PrintPro();

See Also

Reference

PrintPro Class
PrintPro Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintPro Constructor(IContainer)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintPro Class > PrintPro Constructor : PrintPro Constructor(IContainer)

container
A container.

Glossary Item Box

Creates an instance of the PrintPro workspace.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal container As IContainer _
)
'Usage

Dim container As IContainer

Dim instance As New PrintPro(container)
public PrintPro(
   IContainer container
)
public: PrintPro(
   IContainer* container
)
public:
PrintPro(
   IContainer^ container
)

Parameters

container
A container.

See Also

Reference

PrintPro Class
PrintPro Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
AboutBox Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintPro Class : AboutBox Method

Glossary Item Box

Displays a licensing, version and copyright information dialog box for the PrintPRO product.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub AboutBox()
'Usage

Dim instance As PrintPro

instance.AboutBox()
public void AboutBox()
public: void AboutBox();
public:
void AboutBox();

See Also

Reference

PrintPro Class
PrintPro Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Dispose Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintPro Class : Dispose Method

Glossary Item Box

Dispose(bool) method for PrintPro object.

Overload List

Overload | Description
Dispose | Disposes of any unused resources.

See Also

Reference

PrintPro Class
PrintPro Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Dispose() Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintPro Class : Dispose() Method

Glossary Item Box

Disposes of any unused resources.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Shadows Sub Dispose()
'Usage

Dim instance As PrintPro

instance.Dispose()
public new void Dispose()
public: new void Dispose();
public:
new void Dispose();

See Also

Reference

PrintPro Class
PrintPro Members


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
PrintPro Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : PrintPro Class

Glossary Item Box

For a list of all members of this type, see PrintPro members.

Public Properties

 | Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Debug | A property that represents whether or not debug logging is turned on.
Public Property | DebugErrorLevel | Gets and sets a minimum error level a debug message must be for it to be logged in the log file.
Public Property | DebugLogFile | Gets and sets the filename of the debug log file.
Public Property | Licensing | Gets and sets access to an object you can use to provide licensing information to the component.
Public Property | Printers | Gets the collection of printers for printing use.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Version | Returns the version of the PrintPro control at run-time.
Top

See Also

Reference

PrintPro Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Debug Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintPro Class : Debug Property

Glossary Item Box

A property that represents whether or not debug logging is turned on.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
Public Property Debug As Boolean
'Usage

Dim instance As PrintPro
Dim value As Boolean

instance.Debug = value

value = instance.Debug
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public bool Debug {get; set;}
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public: __property bool get_Debug();
public: __property void set_Debug(
   bool value
);
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public:
property bool Debug {
   bool get();
   void set (    bool value);
}

See Also

Reference

PrintPro Class
PrintPro Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
DebugErrorLevel Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintPro Class : DebugErrorLevel Property

Glossary Item Box

Gets and sets a minimum error level a debug message must be for it to be logged in the log file.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
Public Property DebugErrorLevel As DebugErrorLevel
'Usage

Dim instance As PrintPro
Dim value As DebugErrorLevel

instance.DebugErrorLevel = value

value = instance.DebugErrorLevel
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public DebugErrorLevel DebugErrorLevel {get; set;}
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public: __property DebugErrorLevel get_DebugErrorLevel();
public: __property void set_DebugErrorLevel(
   DebugErrorLevel value
);
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public:
property DebugErrorLevel DebugErrorLevel {
   DebugErrorLevel get();
   void set (    DebugErrorLevel value);
}

Property Value

A DebugErrorLevel enumeration value which determines the level of logging to the DebugLogFile.

Remarks

The default value is DebugErrorLevel.Normal

.

See Also

Reference

PrintPro Class
PrintPro Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
DebugLogFile Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintPro Class : DebugLogFile Property

Glossary Item Box

Gets and sets the filename of the debug log file.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
Public Property DebugLogFile As String
'Usage

Dim instance As PrintPro
Dim value As String

instance.DebugLogFile = value

value = instance.DebugLogFile
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public string DebugLogFile {get; set;}
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public: __property string* get_DebugLogFile();
public: __property void set_DebugLogFile(
   string* value
);
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public:
property String^ DebugLogFile {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value which represents the name of the Debug Log File.

Remarks

The default value is an empty string "".

See Also

Reference

PrintPro Class
PrintPro Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Licensing Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintPro Class : Licensing Property

Glossary Item Box

Gets and sets access to an object you can use to provide licensing information to the component.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public ReadOnly Property Licensing As Licensing
'Usage

Dim instance As PrintPro
Dim value As Licensing

value = instance.Licensing
[BrowsableAttribute(false)]
public Licensing Licensing {get;}
[BrowsableAttribute(false)]
public: __property Licensing* get_Licensing();
[BrowsableAttribute(false)]
public:
property Licensing^ Licensing {
   Licensing^ get();
}

Property Value

The Licensing object which contains the component licensing information.

Remarks

This property holds a reference to a Licensing object. You can use that object to send your licensing information to the component.

Example

...

// Set the License EvaluationMode

pp.Licensing.EvaluationMode = Accusoft.PrintProSdk.EvaluationMode.Automatic;

...

See Also

Reference

PrintPro Class
PrintPro Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Printers Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintPro Class : Printers Property

Glossary Item Box

Gets the collection of printers for printing use.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property Printers As PrinterCollection
'Usage

Dim instance As PrintPro
Dim value As PrinterCollection

value = instance.Printers
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public PrinterCollection Printers {get;}
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property PrinterCollection* get_Printers();
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property PrinterCollection^ Printers {
   PrinterCollection^ get();
}

Property Value

A PrinterCollection object which contains all the printers available for use.

See Also

Reference

PrintPro Class
PrintPro Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Version Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintPro Class : Version Property

Glossary Item Box

Returns the version of the PrintPro control at run-time.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public ReadOnly Property Version As String
'Usage

Dim instance As PrintPro
Dim value As String

value = instance.Version
[BrowsableAttribute(false)]
public string Version {get;}
[BrowsableAttribute(false)]
public: __property string* get_Version();
[BrowsableAttribute(false)]
public:
property String^ Version {
   String^ get();
}

See Also

Reference

PrintPro Class
PrintPro Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintProException Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : PrintProException Class

Glossary Item Box

This class implements the base class for PrintPro Exceptions.

Object Model

PrintProException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public Class PrintProException
   Inherits System.ApplicationException
'Usage

Dim instance As PrintProException
[SerializableAttribute()]
public class PrintProException : System.ApplicationException
[SerializableAttribute()]
public __gc class PrintProException : public System.ApplicationException
[SerializableAttribute()]
public ref class PrintProException : public System.ApplicationException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.PrintProSdk.PrintProException
Accusoft.PrintProSdk.CannotCreateCompatibleDeviceException
Accusoft.PrintProSdk.CannotCreateOverlayException
Accusoft.PrintProSdk.CannotGetDefaultPrinterException
Accusoft.PrintProSdk.CannotGetErrorMessageException
Accusoft.PrintProSdk.CannotGetMetafileDCException
Accusoft.PrintProSdk.CannotGetPrinterPropertyException
Accusoft.PrintProSdk.CannotOpenPrinterException
Accusoft.PrintProSdk.CannotSetPrinterPropertyException
Accusoft.PrintProSdk.CannotWriteToPrinterException
Accusoft.PrintProSdk.DocumentAlreadyStartedException
Accusoft.PrintProSdk.DocumentNotStartedException
Accusoft.PrintProSdk.EndDocumentFailedException
Accusoft.PrintProSdk.EndPageFailedException
Accusoft.PrintProSdk.FileReadException
Accusoft.PrintProSdk.FileWriteException
Accusoft.PrintProSdk.GenericGdiException
Accusoft.PrintProSdk.GenericWin32Exception
Accusoft.PrintProSdk.InternalErrorException
Accusoft.PrintProSdk.InvalidAngleException
Accusoft.PrintProSdk.InvalidBinIDException
Accusoft.PrintProSdk.InvalidDib
Accusoft.PrintProSdk.InvalidDibHandleException
Accusoft.PrintProSdk.InvalidHandleException
Accusoft.PrintProSdk.InvalidLicenseEditionException
Accusoft.PrintProSdk.InvalidLicenseException
Accusoft.PrintProSdk.InvalidPageNumberException
Accusoft.PrintProSdk.InvalidPaperIDException
Accusoft.PrintProSdk.InvalidParameterException
Accusoft.PrintProSdk.InvalidPointerException
Accusoft.PrintProSdk.InvalidPrinterNumberException
Accusoft.PrintProSdk.InvalidPrintPreviewException
Accusoft.PrintProSdk.InvalidProfileException
Accusoft.PrintProSdk.InvalidRadiusException
Accusoft.PrintProSdk.InvalidTemplateException
Accusoft.PrintProSdk.InvalidTiffSizeException
Accusoft.PrintProSdk.InvalidValueException
Accusoft.PrintProSdk.InvalidWebCode
Accusoft.PrintProSdk.InvalidWorkerObjectIDException
Accusoft.PrintProSdk.NoDibException
Accusoft.PrintProSdk.NoPrinterDCException
Accusoft.PrintProSdk.NoPrinterSelectedException
Accusoft.PrintProSdk.NoPrintPreviewException
Accusoft.PrintProSdk.NotLicensedException
Accusoft.PrintProSdk.OpenFileException
Accusoft.PrintProSdk.OutOfMemoryException
Accusoft.PrintProSdk.PrintDialogFailedException
Accusoft.PrintProSdk.PrinterDriverFailureException
Accusoft.PrintProSdk.PrintingDisabledException
Accusoft.PrintProSdk.SetupDialogFailedException
Accusoft.PrintProSdk.StartDocumentFailedException
Accusoft.PrintProSdk.StartPageFailedException
Accusoft.PrintProSdk.StretchBltFailedException
Accusoft.PrintProSdk.TiffTagItemNotFoundException
Accusoft.PrintProSdk.TiffTagNotFoundException
Accusoft.PrintProSdk.WorkerInitializationException

See Also

Reference

PrintProException Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
PrintProException Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : PrintProException Class

Glossary Item Box

The following tables list the members exposed by PrintProException.

Public Constructors

 | Name | Description
Public Constructor | PrintProException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception.
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

PrintProException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
PrintProException Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : PrintProException Class

Glossary Item Box

For a list of all members of this type, see PrintProException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

PrintProException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintProException Constructor
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintProException Class : PrintProException Constructor

Glossary Item Box

Overload List

Overload | Description
PrintProException Constructor() | Initializes a new instance of the PrintProException class.
PrintProException Constructor(Int32,String) | Initializes a new instance of the PrintProException class allowing passing in an error number and message.
PrintProException Constructor(Int32) | Initializes a new instance of the PrintProException class allowing passing in an error number.
PrintProException Constructor(String) | Initializes a new instance of the PrintProException class allowing passing in an error message.
PrintProException Constructor(String,Exception) | Initializes a new instance of the PrintProException class allowing passing in an error message and an inner exception.

See Also

Reference

PrintProException Class
PrintProException Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintProException Constructor()
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintProException Class > PrintProException Constructor : PrintProException Constructor()

Glossary Item Box

Initializes a new instance of the PrintProException class.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New PrintProException()
public PrintProException()
public: PrintProException();
public:
PrintProException();

See Also

Reference

PrintProException Class
PrintProException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintProException Constructor(Int32,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintProException Class > PrintProException Constructor : PrintProException Constructor(Int32,String)

number
An integer value which represents the error number.
message
A string value which represents the error message.

Glossary Item Box

Initializes a new instance of the PrintProException class allowing passing in an error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal number As Integer, _
   ByVal message As String _
)
'Usage

Dim number As Integer
Dim message As String

Dim instance As New PrintProException(number, message)
public PrintProException(
   int number,
   string message
)
public: PrintProException(
   int number,
   string* message
)
public:
PrintProException(
   int number,
   String^ message
)

Parameters

number
An integer value which represents the error number.
message
A string value which represents the error message.

See Also

Reference

PrintProException Class
PrintProException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintProException Constructor(Int32)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintProException Class > PrintProException Constructor : PrintProException Constructor(Int32)

number
An integer value which represents the error number.

Glossary Item Box

Initializes a new instance of the PrintProException class allowing passing in an error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal number As Integer _
)
'Usage

Dim number As Integer

Dim instance As New PrintProException(number)
public PrintProException(
   int number
)
public: PrintProException(
   int number
)
public:
PrintProException(
   int number
)

Parameters

number
An integer value which represents the error number.

See Also

Reference

PrintProException Class
PrintProException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintProException Constructor(String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintProException Class > PrintProException Constructor : PrintProException Constructor(String)

message
A string value which represents the error message.

Glossary Item Box

Initializes a new instance of the PrintProException class allowing passing in an error message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New PrintProException(message)
public PrintProException(
   string message
)
public: PrintProException(
   string* message
)
public:
PrintProException(
   String^ message
)

Parameters

message
A string value which represents the error message.

See Also

Reference

PrintProException Class
PrintProException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintProException Constructor(String,Exception)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintProException Class > PrintProException Constructor : PrintProException Constructor(String,Exception)

message
A string value which represents the error message.
inner
An inner System.Exception.

Glossary Item Box

Initializes a new instance of the PrintProException class allowing passing in an error message and an inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
'Usage

Dim message As String
Dim inner As Exception

Dim instance As New PrintProException(message, inner)
public PrintProException(
   string message,
   Exception inner
)
public: PrintProException(
   string* message,
   Exception* inner
)
public:
PrintProException(
   String^ message,
   Exception^ inner
)

Parameters

message
A string value which represents the error message.
inner
An inner System.Exception.

See Also

Reference

PrintProException Class
PrintProException Members
Overload List


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
PrintProException Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : PrintProException Class

Glossary Item Box

For a list of all members of this type, see PrintProException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception.
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

PrintProException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
ErrorNumber Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintProException Class : ErrorNumber Property

Glossary Item Box

Gets the error number of the exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property ErrorNumber As Integer
'Usage

Dim instance As PrintProException
Dim value As Integer

value = instance.ErrorNumber
public int ErrorNumber {get;}
public: __property int get_ErrorNumber();
public:
property int ErrorNumber {
   int get();
}

Property Value

An integer value which represents the error number.

Remarks

This property holds an error number that you can use to determine the specific type of error that occurred.

See Also

Reference

PrintProException Class
PrintProException Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintQuality Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : PrintQuality Class

Glossary Item Box

This class is used to represent the print quality.

Object Model

PrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality ClassPrintQuality Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Class PrintQuality
'Usage

Dim instance As PrintQuality
public class PrintQuality
public __gc class PrintQuality
public ref class PrintQuality

Remarks

Since quality can be specified by values such as high, medium, or low, and can also be specified by DPI, this object is used to encapsulate that.

Inheritance Hierarchy

System.Object
Accusoft.PrintProSdk.PrintQuality

See Also

Reference

PrintQuality Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
PrintQuality Class Members
See Also Methods Send Feedback
Accusoft.PrintProSdk Namespace : PrintQuality Class

Glossary Item Box

The following tables list the members exposed by PrintQuality.

Public Methods

 | Name | Description
Public Method | Dpi | Returns the DPI value for the print quality object.
static (Shared in Visual Basic) | Draft | A print quality object that represents a request for draft quality.
Public Method | Equals | Determines whether two object instances are equal.
static (Shared in Visual Basic) | FromDpi | Creates a print quality object that represents the specified DPI (dots per inch).
Public Method | GetHashCode | Serves as a hash function.
static (Shared in Visual Basic) | High | A print quality object that represents a request for high quality.
static (Shared in Visual Basic) | Low | A print quality object that represents a request for low quality.
static (Shared in Visual Basic) | Medium | A print quality object that represents a request for medium quality.
Top

Public Operators

public Operator Equality | Compares two print quality objects for equality.
public Operator Inequality | Compares two print quality objects for equality.
Top

See Also

Reference

PrintQuality Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
PrintQuality Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : PrintQuality Class

Glossary Item Box

For a list of all members of this type, see PrintQuality members.

Public Methods

 | Name | Description
Public Method | Dpi | Returns the DPI value for the print quality object.
static (Shared in Visual Basic) | Draft | A print quality object that represents a request for draft quality.
Public Method | Equals | Determines whether two object instances are equal.
static (Shared in Visual Basic) | FromDpi | Creates a print quality object that represents the specified DPI (dots per inch).
Public Method | GetHashCode | Serves as a hash function.
static (Shared in Visual Basic) | High | A print quality object that represents a request for high quality.
static (Shared in Visual Basic) | Low | A print quality object that represents a request for low quality.
static (Shared in Visual Basic) | Medium | A print quality object that represents a request for medium quality.
Top

See Also

Reference

PrintQuality Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Dpi Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintQuality Class : Dpi Method

Glossary Item Box

Returns the DPI value for the print quality object.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function Dpi() As Integer
'Usage

Dim instance As PrintQuality
Dim value As Integer

value = instance.Dpi()
public int Dpi()
public: int Dpi();
public:
int Dpi();

Return Value

An integer value which represents the DPI for the print quality.

See Also

Reference

PrintQuality Class
PrintQuality Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Draft Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintQuality Class : Draft Method

Glossary Item Box

A print quality object that represents a request for draft quality.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Shared Function Draft() As PrintQuality
'Usage

Dim value As PrintQuality

value = PrintQuality.Draft()
public static PrintQuality Draft()
public: static PrintQuality* Draft();
public:
static PrintQuality^ Draft();

Return Value

A print quality object that represents a request for draft quality.

See Also

Reference

PrintQuality Class
PrintQuality Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Equals Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintQuality Class : Equals Method

obj
An object to compare to.

Glossary Item Box

Determines whether two object instances are equal.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
'Usage

Dim instance As PrintQuality
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
public override bool Equals(
   object obj
)
public: bool Equals(
   Object* obj
) override
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
An object to compare to.

Return Value

A boolean value which is true if they represent the same print quality value, false otherwise

See Also

Reference

PrintQuality Class
PrintQuality Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
FromDpi Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintQuality Class : FromDpi Method

Dpi
An integer which represents the desired DPI.

Glossary Item Box

Creates a print quality object that represents the specified DPI (dots per inch).

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Shared Function FromDpi( _
   ByVal Dpi As Integer _
) As PrintQuality
'Usage

Dim Dpi As Integer
Dim value As PrintQuality

value = PrintQuality.FromDpi(Dpi)
public static PrintQuality FromDpi(
   int Dpi
)
public: static PrintQuality* FromDpi(
   int Dpi
)
public:
static PrintQuality^ FromDpi(
   int Dpi
)

Parameters

Dpi
An integer which represents the desired DPI.

Return Value

A print quality object that represents the requested DPI.

See Also

Reference

PrintQuality Class
PrintQuality Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
GetHashCode Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintQuality Class : GetHashCode Method

Glossary Item Box

Serves as a hash function.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overrides Function GetHashCode() As Integer
'Usage

Dim instance As PrintQuality
Dim value As Integer

value = instance.GetHashCode()
public override int GetHashCode()
public: int GetHashCode(); override
public:
int GetHashCode(); override

Return Value

A hash code for the current print quality object.

See Also

Reference

PrintQuality Class
PrintQuality Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
High Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintQuality Class : High Method

Glossary Item Box

A print quality object that represents a request for high quality.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Shared Function High() As PrintQuality
'Usage

Dim value As PrintQuality

value = PrintQuality.High()
public static PrintQuality High()
public: static PrintQuality* High();
public:
static PrintQuality^ High();

Return Value

A print quality object that represents a request for high quality.

See Also

Reference

PrintQuality Class
PrintQuality Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Low Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintQuality Class : Low Method

Glossary Item Box

A print quality object that represents a request for low quality.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Shared Function Low() As PrintQuality
'Usage

Dim value As PrintQuality

value = PrintQuality.Low()
public static PrintQuality Low()
public: static PrintQuality* Low();
public:
static PrintQuality^ Low();

Return Value

A print quality object that represents a request for low quality.

See Also

Reference

PrintQuality Class
PrintQuality Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Medium Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintQuality Class : Medium Method

Glossary Item Box

A print quality object that represents a request for medium quality.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Shared Function Medium() As PrintQuality
'Usage

Dim value As PrintQuality

value = PrintQuality.Medium()
public static PrintQuality Medium()
public: static PrintQuality* Medium();
public:
static PrintQuality^ Medium();

Return Value

A print quality object that represents a request for medium quality.

See Also

Reference

PrintQuality Class
PrintQuality Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Equality Operator
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintQuality Class : Equality Operator

pq1
The left side of the comparison.
pq2
The right side of the comparison.

Glossary Item Box

Compares two print quality objects for equality.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Operator =( _
   ByVal pq1 As PrintQuality, _
   ByVal pq2 As PrintQuality _
) As Boolean
'Usage

public bool operator ==(
   PrintQuality pq1,
   PrintQuality pq2
)
public: bool op_Equality(
   PrintQuality* pq1,
   PrintQuality* pq2
)
public:
bool operator ==(
   PrintQuality^ pq1,
   PrintQuality^ pq2
)

Parameters

pq1
The left side of the comparison.
pq2
The right side of the comparison.

Return Value

A boolean value that is true if they represent the same value, false otherwise.

See Also

Reference

PrintQuality Class
PrintQuality Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Inequality Operator
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintQuality Class : Inequality Operator

pq1
The left side of the comparison.
pq2
The right side of the comparison.

Glossary Item Box

Compares two print quality objects for equality.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Operator <>( _
   ByVal pq1 As PrintQuality, _
   ByVal pq2 As PrintQuality _
) As Boolean
'Usage

public bool operator !=(
   PrintQuality pq1,
   PrintQuality pq2
)
public: bool op_Inequality(
   PrintQuality* pq1,
   PrintQuality* pq2
)
public:
bool operator !=(
   PrintQuality^ pq1,
   PrintQuality^ pq2
)

Parameters

pq1
The left side of the comparison.
pq2
The right side of the comparison.

Return Value

A boolean value which is false if they represent the same value, true otherwise.

See Also

Reference

PrintQuality Class
PrintQuality Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
SetupDialogFailedException Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : SetupDialogFailedException Class

Glossary Item Box

This exception is thrown if the setup dialog failed.

Object Model

SetupDialogFailedException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class SetupDialogFailedException
   Inherits PrintProException
'Usage

Dim instance As SetupDialogFailedException
[SerializableAttribute()]
public sealed class SetupDialogFailedException : PrintProException
[SerializableAttribute()]
public __gc __sealed class SetupDialogFailedException : public PrintProException
[SerializableAttribute()]
public ref class SetupDialogFailedException sealed : public PrintProException

Remarks

This exception will occur if the Cancel button of the setup dialog is clicked.

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.PrintProSdk.PrintProException
Accusoft.PrintProSdk.SetupDialogFailedException

See Also

Reference

SetupDialogFailedException Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
SetupDialogFailedException Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : SetupDialogFailedException Class

Glossary Item Box

The following tables list the members exposed by SetupDialogFailedException.

Public Constructors

 | Name | Description
Public Constructor | SetupDialogFailedException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

SetupDialogFailedException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
SetupDialogFailedException Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : SetupDialogFailedException Class

Glossary Item Box

For a list of all members of this type, see SetupDialogFailedException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

SetupDialogFailedException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
SetupDialogFailedException Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : SetupDialogFailedException Class

Glossary Item Box

For a list of all members of this type, see SetupDialogFailedException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

SetupDialogFailedException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
SetupDialogFailedException Constructor
See Also Send Feedback
Accusoft.PrintProSdk Namespace > SetupDialogFailedException Class : SetupDialogFailedException Constructor

Glossary Item Box

Overload List

Overload | Description
SetupDialogFailedException Constructor() | An exception generated for a setup dialog failed error.
SetupDialogFailedException Constructor(Int32) | Generated exception for a setup dialog failed error with a given error number.
SetupDialogFailedException Constructor(String) | Generated exception for a setup dialog failed error with a given string.
SetupDialogFailedException Constructor(Int32,String) | Generated exception for a setup dialog failed error with a given error number and message.
SetupDialogFailedException Constructor(String,Exception) | Generated exception for a setup dialog failed error with a given message and inner exception.

See Also

Reference

SetupDialogFailedException Class
SetupDialogFailedException Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
SetupDialogFailedException Constructor()
See Also Send Feedback
Accusoft.PrintProSdk Namespace > SetupDialogFailedException Class > SetupDialogFailedException Constructor : SetupDialogFailedException Constructor()

Glossary Item Box

An exception generated for a setup dialog failed error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New SetupDialogFailedException()
public SetupDialogFailedException()
public: SetupDialogFailedException();
public:
SetupDialogFailedException();

See Also

Reference

SetupDialogFailedException Class
SetupDialogFailedException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
SetupDialogFailedException Constructor(Int32)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > SetupDialogFailedException Class > SetupDialogFailedException Constructor : SetupDialogFailedException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a setup dialog failed error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New SetupDialogFailedException(errorNumber)
public SetupDialogFailedException(
   int errorNumber
)
public: SetupDialogFailedException(
   int errorNumber
)
public:
SetupDialogFailedException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

SetupDialogFailedException Class
SetupDialogFailedException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
SetupDialogFailedException Constructor(String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > SetupDialogFailedException Class > SetupDialogFailedException Constructor : SetupDialogFailedException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a setup dialog failed error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New SetupDialogFailedException(message)
public SetupDialogFailedException(
   string message
)
public: SetupDialogFailedException(
   string* message
)
public:
SetupDialogFailedException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

SetupDialogFailedException Class
SetupDialogFailedException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
SetupDialogFailedException Constructor(Int32,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > SetupDialogFailedException Class > SetupDialogFailedException Constructor : SetupDialogFailedException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a setup dialog failed error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New SetupDialogFailedException(errorNumber, message)
public SetupDialogFailedException(
   int errorNumber,
   string message
)
public: SetupDialogFailedException(
   int errorNumber,
   string* message
)
public:
SetupDialogFailedException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

SetupDialogFailedException Class
SetupDialogFailedException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
SetupDialogFailedException Constructor(String,Exception)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > SetupDialogFailedException Class > SetupDialogFailedException Constructor : SetupDialogFailedException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a setup dialog failed error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New SetupDialogFailedException(message, innerException)
public SetupDialogFailedException(
   string message,
   Exception innerException
)
public: SetupDialogFailedException(
   string* message,
   Exception* innerException
)
public:
SetupDialogFailedException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

SetupDialogFailedException Class
SetupDialogFailedException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
StartDocumentFailedException Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : StartDocumentFailedException Class

Glossary Item Box

This exception is thrown if an error occurs when starting a document.

Object Model

StartDocumentFailedException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class StartDocumentFailedException
   Inherits PrintProException
'Usage

Dim instance As StartDocumentFailedException
[SerializableAttribute()]
public sealed class StartDocumentFailedException : PrintProException
[SerializableAttribute()]
public __gc __sealed class StartDocumentFailedException : public PrintProException
[SerializableAttribute()]
public ref class StartDocumentFailedException sealed : public PrintProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.PrintProSdk.PrintProException
Accusoft.PrintProSdk.StartDocumentFailedException

See Also

Reference

StartDocumentFailedException Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
StartDocumentFailedException Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : StartDocumentFailedException Class

Glossary Item Box

The following tables list the members exposed by StartDocumentFailedException.

Public Constructors

 | Name | Description
Public Constructor | StartDocumentFailedException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

StartDocumentFailedException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
StartDocumentFailedException Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : StartDocumentFailedException Class

Glossary Item Box

For a list of all members of this type, see StartDocumentFailedException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

StartDocumentFailedException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
StartDocumentFailedException Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : StartDocumentFailedException Class

Glossary Item Box

For a list of all members of this type, see StartDocumentFailedException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

StartDocumentFailedException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
StartDocumentFailedException Constructor
See Also Send Feedback
Accusoft.PrintProSdk Namespace > StartDocumentFailedException Class : StartDocumentFailedException Constructor

Glossary Item Box

Overload List

Overload | Description
StartDocumentFailedException Constructor() | An exception generated for a start document failed error.
StartDocumentFailedException Constructor(Int32) | Generated exception for a start document failed error with a given error number.
StartDocumentFailedException Constructor(String) | Generated exception for a start document failed error with a given string.
StartDocumentFailedException Constructor(Int32,String) | Generated exception for a start document failed error with a given error number and message.
StartDocumentFailedException Constructor(String,Exception) | Generated exception for a start document failed error with a given message and inner exception.

See Also

Reference

StartDocumentFailedException Class
StartDocumentFailedException Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
StartDocumentFailedException Constructor()
See Also Send Feedback
Accusoft.PrintProSdk Namespace > StartDocumentFailedException Class > StartDocumentFailedException Constructor : StartDocumentFailedException Constructor()

Glossary Item Box

An exception generated for a start document failed error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New StartDocumentFailedException()
public StartDocumentFailedException()
public: StartDocumentFailedException();
public:
StartDocumentFailedException();

See Also

Reference

StartDocumentFailedException Class
StartDocumentFailedException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
StartDocumentFailedException Constructor(Int32)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > StartDocumentFailedException Class > StartDocumentFailedException Constructor : StartDocumentFailedException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a start document failed error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New StartDocumentFailedException(errorNumber)
public StartDocumentFailedException(
   int errorNumber
)
public: StartDocumentFailedException(
   int errorNumber
)
public:
StartDocumentFailedException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

StartDocumentFailedException Class
StartDocumentFailedException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
StartDocumentFailedException Constructor(String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > StartDocumentFailedException Class > StartDocumentFailedException Constructor : StartDocumentFailedException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a start document failed error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New StartDocumentFailedException(message)
public StartDocumentFailedException(
   string message
)
public: StartDocumentFailedException(
   string* message
)
public:
StartDocumentFailedException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

StartDocumentFailedException Class
StartDocumentFailedException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
StartDocumentFailedException Constructor(Int32,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > StartDocumentFailedException Class > StartDocumentFailedException Constructor : StartDocumentFailedException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a start document failed error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New StartDocumentFailedException(errorNumber, message)
public StartDocumentFailedException(
   int errorNumber,
   string message
)
public: StartDocumentFailedException(
   int errorNumber,
   string* message
)
public:
StartDocumentFailedException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

StartDocumentFailedException Class
StartDocumentFailedException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
StartDocumentFailedException Constructor(String,Exception)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > StartDocumentFailedException Class > StartDocumentFailedException Constructor : StartDocumentFailedException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a start document failed error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New StartDocumentFailedException(message, innerException)
public StartDocumentFailedException(
   string message,
   Exception innerException
)
public: StartDocumentFailedException(
   string* message,
   Exception* innerException
)
public:
StartDocumentFailedException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

StartDocumentFailedException Class
StartDocumentFailedException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
StartPageFailedException Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : StartPageFailedException Class

Glossary Item Box

This exception is thrown if an error occurs when starting a page.

Object Model

StartPageFailedException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class StartPageFailedException
   Inherits PrintProException
'Usage

Dim instance As StartPageFailedException
[SerializableAttribute()]
public sealed class StartPageFailedException : PrintProException
[SerializableAttribute()]
public __gc __sealed class StartPageFailedException : public PrintProException
[SerializableAttribute()]
public ref class StartPageFailedException sealed : public PrintProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.PrintProSdk.PrintProException
Accusoft.PrintProSdk.StartPageFailedException

See Also

Reference

StartPageFailedException Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
StartPageFailedException Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : StartPageFailedException Class

Glossary Item Box

The following tables list the members exposed by StartPageFailedException.

Public Constructors

 | Name | Description
Public Constructor | StartPageFailedException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

StartPageFailedException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
StartPageFailedException Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : StartPageFailedException Class

Glossary Item Box

For a list of all members of this type, see StartPageFailedException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

StartPageFailedException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
StartPageFailedException Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : StartPageFailedException Class

Glossary Item Box

For a list of all members of this type, see StartPageFailedException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

StartPageFailedException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
StartPageFailedException Constructor
See Also Send Feedback
Accusoft.PrintProSdk Namespace > StartPageFailedException Class : StartPageFailedException Constructor

Glossary Item Box

Overload List

Overload | Description
StartPageFailedException Constructor() | An exception generated for a start page failed error.
StartPageFailedException Constructor(Int32) | Generated exception for a start page failed error with a given error number.
StartPageFailedException Constructor(String) | Generated exception for a start page failed error with a given string.
StartPageFailedException Constructor(Int32,String) | Generated exception for a start page failed error with a given error number and message.
StartPageFailedException Constructor(String,Exception) | Generated exception for a start page failed error with a given message and inner exception.

See Also

Reference

StartPageFailedException Class
StartPageFailedException Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
StartPageFailedException Constructor()
See Also Send Feedback
Accusoft.PrintProSdk Namespace > StartPageFailedException Class > StartPageFailedException Constructor : StartPageFailedException Constructor()

Glossary Item Box

An exception generated for a start page failed error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New StartPageFailedException()
public StartPageFailedException()
public: StartPageFailedException();
public:
StartPageFailedException();

See Also

Reference

StartPageFailedException Class
StartPageFailedException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
StartPageFailedException Constructor(Int32)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > StartPageFailedException Class > StartPageFailedException Constructor : StartPageFailedException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a start page failed error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New StartPageFailedException(errorNumber)
public StartPageFailedException(
   int errorNumber
)
public: StartPageFailedException(
   int errorNumber
)
public:
StartPageFailedException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

StartPageFailedException Class
StartPageFailedException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
StartPageFailedException Constructor(String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > StartPageFailedException Class > StartPageFailedException Constructor : StartPageFailedException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a start page failed error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New StartPageFailedException(message)
public StartPageFailedException(
   string message
)
public: StartPageFailedException(
   string* message
)
public:
StartPageFailedException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

StartPageFailedException Class
StartPageFailedException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
StartPageFailedException Constructor(Int32,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > StartPageFailedException Class > StartPageFailedException Constructor : StartPageFailedException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a start page failed error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New StartPageFailedException(errorNumber, message)
public StartPageFailedException(
   int errorNumber,
   string message
)
public: StartPageFailedException(
   int errorNumber,
   string* message
)
public:
StartPageFailedException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

StartPageFailedException Class
StartPageFailedException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
StartPageFailedException Constructor(String,Exception)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > StartPageFailedException Class > StartPageFailedException Constructor : StartPageFailedException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a start page failed error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New StartPageFailedException(message, innerException)
public StartPageFailedException(
   string message,
   Exception innerException
)
public: StartPageFailedException(
   string* message,
   Exception* innerException
)
public:
StartPageFailedException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

StartPageFailedException Class
StartPageFailedException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
StretchBltFailedException Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : StretchBltFailedException Class

Glossary Item Box

This exception is thrown if the Windows StretchBlt function failed when printing a bitmap.

Object Model

StretchBltFailedException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class StretchBltFailedException
   Inherits PrintProException
'Usage

Dim instance As StretchBltFailedException
[SerializableAttribute()]
public sealed class StretchBltFailedException : PrintProException
[SerializableAttribute()]
public __gc __sealed class StretchBltFailedException : public PrintProException
[SerializableAttribute()]
public ref class StretchBltFailedException sealed : public PrintProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.PrintProSdk.PrintProException
Accusoft.PrintProSdk.StretchBltFailedException

See Also

Reference

StretchBltFailedException Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
StretchBltFailedException Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : StretchBltFailedException Class

Glossary Item Box

The following tables list the members exposed by StretchBltFailedException.

Public Constructors

 | Name | Description
Public Constructor | StretchBltFailedException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

StretchBltFailedException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
StretchBltFailedException Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : StretchBltFailedException Class

Glossary Item Box

For a list of all members of this type, see StretchBltFailedException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

StretchBltFailedException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
StretchBltFailedException Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : StretchBltFailedException Class

Glossary Item Box

For a list of all members of this type, see StretchBltFailedException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

StretchBltFailedException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
StretchBltFailedException Constructor
See Also Send Feedback
Accusoft.PrintProSdk Namespace > StretchBltFailedException Class : StretchBltFailedException Constructor

Glossary Item Box

Overload List

Overload | Description
StretchBltFailedException Constructor() | An exception generated for a StretchBlt error.
StretchBltFailedException Constructor(Int32) | Generated exception for a StretchBlt error with a given error number.
StretchBltFailedException Constructor(String) | Generated exception for a StretchBlt error with a given string.
StretchBltFailedException Constructor(Int32,String) | Generated exception for a StretchBlt error with a given error number and message.
StretchBltFailedException Constructor(String,Exception) | Generated exception for a StretchBlt error with a given message and inner exception.

See Also

Reference

StretchBltFailedException Class
StretchBltFailedException Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
StretchBltFailedException Constructor()
See Also Send Feedback
Accusoft.PrintProSdk Namespace > StretchBltFailedException Class > StretchBltFailedException Constructor : StretchBltFailedException Constructor()

Glossary Item Box

An exception generated for a StretchBlt error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New StretchBltFailedException()
public StretchBltFailedException()
public: StretchBltFailedException();
public:
StretchBltFailedException();

See Also

Reference

StretchBltFailedException Class
StretchBltFailedException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
StretchBltFailedException Constructor(Int32)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > StretchBltFailedException Class > StretchBltFailedException Constructor : StretchBltFailedException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a StretchBlt error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New StretchBltFailedException(errorNumber)
public StretchBltFailedException(
   int errorNumber
)
public: StretchBltFailedException(
   int errorNumber
)
public:
StretchBltFailedException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

StretchBltFailedException Class
StretchBltFailedException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
StretchBltFailedException Constructor(String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > StretchBltFailedException Class > StretchBltFailedException Constructor : StretchBltFailedException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a StretchBlt error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New StretchBltFailedException(message)
public StretchBltFailedException(
   string message
)
public: StretchBltFailedException(
   string* message
)
public:
StretchBltFailedException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

StretchBltFailedException Class
StretchBltFailedException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
StretchBltFailedException Constructor(Int32,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > StretchBltFailedException Class > StretchBltFailedException Constructor : StretchBltFailedException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a StretchBlt error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New StretchBltFailedException(errorNumber, message)
public StretchBltFailedException(
   int errorNumber,
   string message
)
public: StretchBltFailedException(
   int errorNumber,
   string* message
)
public:
StretchBltFailedException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

StretchBltFailedException Class
StretchBltFailedException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
StretchBltFailedException Constructor(String,Exception)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > StretchBltFailedException Class > StretchBltFailedException Constructor : StretchBltFailedException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a StretchBlt error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New StretchBltFailedException(message, innerException)
public StretchBltFailedException(
   string message,
   Exception innerException
)
public: StretchBltFailedException(
   string* message,
   Exception* innerException
)
public:
StretchBltFailedException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

StretchBltFailedException Class
StretchBltFailedException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
TiffTagItemNotFoundException Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : TiffTagItemNotFoundException Class

Glossary Item Box

This exception is thrown if the TIFF tag item is not found.

Object Model

TiffTagItemNotFoundException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class TiffTagItemNotFoundException
   Inherits PrintProException
'Usage

Dim instance As TiffTagItemNotFoundException
[SerializableAttribute()]
public sealed class TiffTagItemNotFoundException : PrintProException
[SerializableAttribute()]
public __gc __sealed class TiffTagItemNotFoundException : public PrintProException
[SerializableAttribute()]
public ref class TiffTagItemNotFoundException sealed : public PrintProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.PrintProSdk.PrintProException
Accusoft.PrintProSdk.TiffTagItemNotFoundException

See Also

Reference

TiffTagItemNotFoundException Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
TiffTagItemNotFoundException Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : TiffTagItemNotFoundException Class

Glossary Item Box

The following tables list the members exposed by TiffTagItemNotFoundException.

Public Constructors

 | Name | Description
Public Constructor | TiffTagItemNotFoundException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

TiffTagItemNotFoundException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
TiffTagItemNotFoundException Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : TiffTagItemNotFoundException Class

Glossary Item Box

For a list of all members of this type, see TiffTagItemNotFoundException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

TiffTagItemNotFoundException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
TiffTagItemNotFoundException Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : TiffTagItemNotFoundException Class

Glossary Item Box

For a list of all members of this type, see TiffTagItemNotFoundException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

TiffTagItemNotFoundException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
TiffTagItemNotFoundException Constructor
See Also Send Feedback
Accusoft.PrintProSdk Namespace > TiffTagItemNotFoundException Class : TiffTagItemNotFoundException Constructor

Glossary Item Box

Overload List

Overload | Description
TiffTagItemNotFoundException Constructor() | An exception generated for a TIFF tag item not found error.
TiffTagItemNotFoundException Constructor(Int32) | Generated exception for a TIFF tag item not found error with a given error number.
TiffTagItemNotFoundException Constructor(String) | Generated exception for a TIFF tag item not found error with a given string.
TiffTagItemNotFoundException Constructor(Int32,String) | Generated exception for a TIFF tag item not found error with a given error number and message.
TiffTagItemNotFoundException Constructor(String,Exception) | Generated exception for a TIFF tag item not found error with a given message and inner exception.

See Also

Reference

TiffTagItemNotFoundException Class
TiffTagItemNotFoundException Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
TiffTagItemNotFoundException Constructor()
See Also Send Feedback
Accusoft.PrintProSdk Namespace > TiffTagItemNotFoundException Class > TiffTagItemNotFoundException Constructor : TiffTagItemNotFoundException Constructor()

Glossary Item Box

An exception generated for a TIFF tag item not found error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New TiffTagItemNotFoundException()
public TiffTagItemNotFoundException()
public: TiffTagItemNotFoundException();
public:
TiffTagItemNotFoundException();

See Also

Reference

TiffTagItemNotFoundException Class
TiffTagItemNotFoundException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
TiffTagItemNotFoundException Constructor(Int32)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > TiffTagItemNotFoundException Class > TiffTagItemNotFoundException Constructor : TiffTagItemNotFoundException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a TIFF tag item not found error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New TiffTagItemNotFoundException(errorNumber)
public TiffTagItemNotFoundException(
   int errorNumber
)
public: TiffTagItemNotFoundException(
   int errorNumber
)
public:
TiffTagItemNotFoundException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

TiffTagItemNotFoundException Class
TiffTagItemNotFoundException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
TiffTagItemNotFoundException Constructor(String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > TiffTagItemNotFoundException Class > TiffTagItemNotFoundException Constructor : TiffTagItemNotFoundException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a TIFF tag item not found error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New TiffTagItemNotFoundException(message)
public TiffTagItemNotFoundException(
   string message
)
public: TiffTagItemNotFoundException(
   string* message
)
public:
TiffTagItemNotFoundException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

TiffTagItemNotFoundException Class
TiffTagItemNotFoundException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
TiffTagItemNotFoundException Constructor(Int32,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > TiffTagItemNotFoundException Class > TiffTagItemNotFoundException Constructor : TiffTagItemNotFoundException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a TIFF tag item not found error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New TiffTagItemNotFoundException(errorNumber, message)
public TiffTagItemNotFoundException(
   int errorNumber,
   string message
)
public: TiffTagItemNotFoundException(
   int errorNumber,
   string* message
)
public:
TiffTagItemNotFoundException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

TiffTagItemNotFoundException Class
TiffTagItemNotFoundException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
TiffTagItemNotFoundException Constructor(String,Exception)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > TiffTagItemNotFoundException Class > TiffTagItemNotFoundException Constructor : TiffTagItemNotFoundException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a TIFF tag item not found error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New TiffTagItemNotFoundException(message, innerException)
public TiffTagItemNotFoundException(
   string message,
   Exception innerException
)
public: TiffTagItemNotFoundException(
   string* message,
   Exception* innerException
)
public:
TiffTagItemNotFoundException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

TiffTagItemNotFoundException Class
TiffTagItemNotFoundException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
TiffTagNotFoundException Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : TiffTagNotFoundException Class

Glossary Item Box

This exception is thrown if the TIFF tag is not found.

Object Model

TiffTagNotFoundException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class TiffTagNotFoundException
   Inherits PrintProException
'Usage

Dim instance As TiffTagNotFoundException
[SerializableAttribute()]
public sealed class TiffTagNotFoundException : PrintProException
[SerializableAttribute()]
public __gc __sealed class TiffTagNotFoundException : public PrintProException
[SerializableAttribute()]
public ref class TiffTagNotFoundException sealed : public PrintProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.PrintProSdk.PrintProException
Accusoft.PrintProSdk.TiffTagNotFoundException

See Also

Reference

TiffTagNotFoundException Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
TiffTagNotFoundException Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : TiffTagNotFoundException Class

Glossary Item Box

The following tables list the members exposed by TiffTagNotFoundException.

Public Constructors

 | Name | Description
Public Constructor | TiffTagNotFoundException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

TiffTagNotFoundException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
TiffTagNotFoundException Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : TiffTagNotFoundException Class

Glossary Item Box

For a list of all members of this type, see TiffTagNotFoundException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

TiffTagNotFoundException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
TiffTagNotFoundException Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : TiffTagNotFoundException Class

Glossary Item Box

For a list of all members of this type, see TiffTagNotFoundException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

TiffTagNotFoundException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
TiffTagNotFoundException Constructor
See Also Send Feedback
Accusoft.PrintProSdk Namespace > TiffTagNotFoundException Class : TiffTagNotFoundException Constructor

Glossary Item Box

Overload List

Overload | Description
TiffTagNotFoundException Constructor() | An exception generated for a TIFF tag not found error.
TiffTagNotFoundException Constructor(Int32) | Generated exception for a TIFF tag not found error with a given error number.
TiffTagNotFoundException Constructor(String) | Generated exception for a TIFF tag not found error with a given string.
TiffTagNotFoundException Constructor(Int32,String) | Generated exception for a TIFF tag not found error with a given error number and message.
TiffTagNotFoundException Constructor(String,Exception) | Generated exception for a TIFF tag not found error with a given message and inner exception.

See Also

Reference

TiffTagNotFoundException Class
TiffTagNotFoundException Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
TiffTagNotFoundException Constructor()
See Also Send Feedback
Accusoft.PrintProSdk Namespace > TiffTagNotFoundException Class > TiffTagNotFoundException Constructor : TiffTagNotFoundException Constructor()

Glossary Item Box

An exception generated for a TIFF tag not found error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New TiffTagNotFoundException()
public TiffTagNotFoundException()
public: TiffTagNotFoundException();
public:
TiffTagNotFoundException();

See Also

Reference

TiffTagNotFoundException Class
TiffTagNotFoundException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
TiffTagNotFoundException Constructor(Int32)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > TiffTagNotFoundException Class > TiffTagNotFoundException Constructor : TiffTagNotFoundException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a TIFF tag not found error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New TiffTagNotFoundException(errorNumber)
public TiffTagNotFoundException(
   int errorNumber
)
public: TiffTagNotFoundException(
   int errorNumber
)
public:
TiffTagNotFoundException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

TiffTagNotFoundException Class
TiffTagNotFoundException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
TiffTagNotFoundException Constructor(String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > TiffTagNotFoundException Class > TiffTagNotFoundException Constructor : TiffTagNotFoundException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a TIFF tag not found error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New TiffTagNotFoundException(message)
public TiffTagNotFoundException(
   string message
)
public: TiffTagNotFoundException(
   string* message
)
public:
TiffTagNotFoundException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

TiffTagNotFoundException Class
TiffTagNotFoundException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
TiffTagNotFoundException Constructor(Int32,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > TiffTagNotFoundException Class > TiffTagNotFoundException Constructor : TiffTagNotFoundException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a TIFF tag not found error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New TiffTagNotFoundException(errorNumber, message)
public TiffTagNotFoundException(
   int errorNumber,
   string message
)
public: TiffTagNotFoundException(
   int errorNumber,
   string* message
)
public:
TiffTagNotFoundException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

TiffTagNotFoundException Class
TiffTagNotFoundException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
TiffTagNotFoundException Constructor(String,Exception)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > TiffTagNotFoundException Class > TiffTagNotFoundException Constructor : TiffTagNotFoundException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a TIFF tag not found error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New TiffTagNotFoundException(message, innerException)
public TiffTagNotFoundException(
   string message,
   Exception innerException
)
public: TiffTagNotFoundException(
   string* message,
   Exception* innerException
)
public:
TiffTagNotFoundException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

TiffTagNotFoundException Class
TiffTagNotFoundException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
UserPaper Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : UserPaper Class

Glossary Item Box

This class implements methods and properties that are used in place of a paper class when a user paper type has been selected for a printer.

Object Model

UserPaper Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Class UserPaper
   Inherits Paper
'Usage

Dim instance As UserPaper
public class UserPaper : Paper
public __gc class UserPaper : public Paper
public ref class UserPaper : public Paper

Inheritance Hierarchy

System.Object
Accusoft.PrintProSdk.Paper
Accusoft.PrintProSdk.UserPaper

See Also

Reference

UserPaper Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
UserPaper Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : UserPaper Class

Glossary Item Box

The following tables list the members exposed by UserPaper.

Public Properties

 | Name | Description
Public Property | Id | Gets the ID of the paper. (Inherited from Accusoft.PrintProSdk.Paper)
Public Property | Name | Overridden. Gets the name of the paper.
Top

Public Methods

 | Name | Description
Public Method | ToString | Creates a string and returns the paper name. (Inherited from Accusoft.PrintProSdk.Paper)
Top

See Also

Reference

UserPaper Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
UserPaper Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : UserPaper Class

Glossary Item Box

For a list of all members of this type, see UserPaper members.

Public Methods

 | Name | Description
Public Method | ToString | Creates a string and returns the paper name. (Inherited from Accusoft.PrintProSdk.Paper)
Top

See Also

Reference

UserPaper Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
UserPaper Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : UserPaper Class

Glossary Item Box

For a list of all members of this type, see UserPaper members.

Public Properties

 | Name | Description
Public Property | Id | Gets the ID of the paper. (Inherited from Accusoft.PrintProSdk.Paper)
Public Property | Name | Overridden. Gets the name of the paper.
Top

See Also

Reference

UserPaper Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Name Property
See Also Send Feedback
Accusoft.PrintProSdk Namespace > UserPaper Class : Name Property

Glossary Item Box

Gets the name of the paper.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overrides ReadOnly Property Name As String
'Usage

Dim instance As UserPaper
Dim value As String

value = instance.Name
public override string Name {get;}
public: __property string* get_Name() override;
public:
property String^ Name {
   String^ get() override;
}

Property Value

A string which represents the name of the paper.

See Also

Reference

UserPaper Class
UserPaper Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
WorkerInitializationException Class
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : WorkerInitializationException Class

Glossary Item Box

This exception is thrown if an error occurs when initializing the PrintPRO worker.

Object Model

WorkerInitializationException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class WorkerInitializationException
   Inherits PrintProException
'Usage

Dim instance As WorkerInitializationException
[SerializableAttribute()]
public sealed class WorkerInitializationException : PrintProException
[SerializableAttribute()]
public __gc __sealed class WorkerInitializationException : public PrintProException
[SerializableAttribute()]
public ref class WorkerInitializationException sealed : public PrintProException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.PrintProSdk.PrintProException
Accusoft.PrintProSdk.WorkerInitializationException

See Also

Reference

WorkerInitializationException Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
WorkerInitializationException Class Members
See Also Properties Methods Send Feedback
Accusoft.PrintProSdk Namespace : WorkerInitializationException Class

Glossary Item Box

The following tables list the members exposed by WorkerInitializationException.

Public Constructors

 | Name | Description
Public Constructor | WorkerInitializationException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

WorkerInitializationException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
WorkerInitializationException Class Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : WorkerInitializationException Class

Glossary Item Box

For a list of all members of this type, see WorkerInitializationException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

WorkerInitializationException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.PrintPro6.Net
WorkerInitializationException Class Properties
See Also Send Feedback
Accusoft.PrintProSdk Namespace : WorkerInitializationException Class

Glossary Item Box

For a list of all members of this type, see WorkerInitializationException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorNumber | Gets the error number of the exception. (Inherited from Accusoft.PrintProSdk.PrintProException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

WorkerInitializationException Class
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
WorkerInitializationException Constructor
See Also Send Feedback
Accusoft.PrintProSdk Namespace > WorkerInitializationException Class : WorkerInitializationException Constructor

Glossary Item Box

Overload List

Overload | Description
WorkerInitializationException Constructor() | An exception generated for a worker initialization error.
WorkerInitializationException Constructor(Int32) | Generated exception for a worker initialization error with a given error number.
WorkerInitializationException Constructor(String) | Generated exception for a worker initialization error with a given string.
WorkerInitializationException Constructor(Int32,String) | Generated exception for a worker initialization error with a given error number and message.
WorkerInitializationException Constructor(String,Exception) | Generated exception for a worker initialization error with a given message and inner exception.

See Also

Reference

WorkerInitializationException Class
WorkerInitializationException Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
WorkerInitializationException Constructor()
See Also Send Feedback
Accusoft.PrintProSdk Namespace > WorkerInitializationException Class > WorkerInitializationException Constructor : WorkerInitializationException Constructor()

Glossary Item Box

An exception generated for a worker initialization error.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New WorkerInitializationException()
public WorkerInitializationException()
public: WorkerInitializationException();
public:
WorkerInitializationException();

See Also

Reference

WorkerInitializationException Class
WorkerInitializationException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
WorkerInitializationException Constructor(Int32)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > WorkerInitializationException Class > WorkerInitializationException Constructor : WorkerInitializationException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

Generated exception for a worker initialization error with a given error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New WorkerInitializationException(errorNumber)
public WorkerInitializationException(
   int errorNumber
)
public: WorkerInitializationException(
   int errorNumber
)
public:
WorkerInitializationException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

WorkerInitializationException Class
WorkerInitializationException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
WorkerInitializationException Constructor(String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > WorkerInitializationException Class > WorkerInitializationException Constructor : WorkerInitializationException Constructor(String)

message
A string which represents the error message.

Glossary Item Box

Generated exception for a worker initialization error with a given string.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New WorkerInitializationException(message)
public WorkerInitializationException(
   string message
)
public: WorkerInitializationException(
   string* message
)
public:
WorkerInitializationException(
   String^ message
)

Parameters

message
A string which represents the error message.

See Also

Reference

WorkerInitializationException Class
WorkerInitializationException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
WorkerInitializationException Constructor(Int32,String)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > WorkerInitializationException Class > WorkerInitializationException Constructor : WorkerInitializationException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string which represents the message.

Glossary Item Box

Generated exception for a worker initialization error with a given error number and message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New WorkerInitializationException(errorNumber, message)
public WorkerInitializationException(
   int errorNumber,
   string message
)
public: WorkerInitializationException(
   int errorNumber,
   string* message
)
public:
WorkerInitializationException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string which represents the message.

See Also

Reference

WorkerInitializationException Class
WorkerInitializationException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
WorkerInitializationException Constructor(String,Exception)
See Also Send Feedback
Accusoft.PrintProSdk Namespace > WorkerInitializationException Class > WorkerInitializationException Constructor : WorkerInitializationException Constructor(String,Exception)

message
A string which represents the message.
innerException
An inner exception from the base contructor.

Glossary Item Box

Generated exception for a worker initialization error with a given message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New WorkerInitializationException(message, innerException)
public WorkerInitializationException(
   string message,
   Exception innerException
)
public: WorkerInitializationException(
   string* message,
   Exception* innerException
)
public:
WorkerInitializationException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents the message.
innerException
An inner exception from the base contructor.

See Also

Reference

WorkerInitializationException Class
WorkerInitializationException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintingUnit Structure
Members See Also Send Feedback
Accusoft.PrintProSdk Namespace : PrintingUnit Structure

Glossary Item Box

An object that represents units for printing. Made so that its use is similar to an Enumeration.

Object Model

PrintingUnit Structure

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Structure PrintingUnit
   Inherits System.ValueType
'Usage

Dim instance As PrintingUnit
public struct PrintingUnit : System.ValueType
public __value struct PrintingUnit : public System.ValueType
public value class PrintingUnit : public System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
Accusoft.PrintProSdk.PrintingUnit

See Also

Reference

PrintingUnit Members
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.PrintPro6.Net
PrintingUnit Structure Members
See Also Fields Methods Send Feedback
Accusoft.PrintProSdk Namespace : PrintingUnit Structure

Glossary Item Box

The following tables list the members exposed by PrintingUnit.

Public Fields

 | Name | Description
Public Field | Centimeter | The centimeter printing unit.
Public Field | Character | The character printing unit.
Public Field | HundredthsOfAMillimeter | A printing unit of 1/100th of a millimeter.
Public Field | HundredthsOfAnInch | A printing unit of 1/100th of an inch.
Public Field | Inch | The inch printing unit.
Public Field | Millimeter | The millimeter printing unit.
Public Field | Pixel | The pixel printing unit.
Public Field | Point | The point printing unit.
Public Field | TenthsOfAMillimeter | A printing unit of 1/10th a millimeter.
Public Field | ThousandthsOfAnInch | A printing unit of 1/1000th of an inch.
Public Field | ThreeHundredthsOfAnInch | A printing unit of 1/300th of an inch.
Public Field | Twip | The twip printing unit.
Top

Public Methods

 | Name | Description
Public Method | Equals | Determines whether two object instances are equal.
Public Method | GetHashCode | Serves as a hash function for a particular type.
Top

Public Operators

public Operator Equality | Determines whether two PrintingUnits are the same printing unit.
public Operator Implicit Type Conversion | Overloaded. To implicitly convert between integer values and printing units.
public Operator Inequality | Determines whether two PrintingUnits are not the same printing unit.
Top

See Also

Reference

PrintingUnit Structure
Accusoft.PrintProSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.PrintPro6.Net
PrintingUnit Structure Methods
See Also Send Feedback
Accusoft.PrintProSdk Namespace : PrintingUnit Structure

Glossary Item Box

For a list of all members of this type, see PrintingUnit members.

Public Methods

 | Name | Description
Public Method | Equals | Determines whether two object instances are equal.
Public Method | GetHashCode | Serves as a hash function for a particular type.
Top

See Also

Reference

PrintingUnit Structure
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Equals Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintingUnit Structure : Equals Method

obj
An object to compare to.

Glossary Item Box

Determines whether two object instances are equal.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
'Usage

Dim instance As PrintingUnit
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
public override bool Equals(
   object obj
)
public: bool Equals(
   Object* obj
) override
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
An object to compare to.

Return Value

A boolean value which is true if they are equal. Otherwise, false is returned.

See Also

Reference

PrintingUnit Structure
PrintingUnit Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
GetHashCode Method
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintingUnit Structure : GetHashCode Method

Glossary Item Box

Serves as a hash function for a particular type.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overrides Function GetHashCode() As Integer
'Usage

Dim instance As PrintingUnit
Dim value As Integer

value = instance.GetHashCode()
public override int GetHashCode()
public: int GetHashCode(); override
public:
int GetHashCode(); override

Return Value

A hash code for the current unit type.

Remarks

This method is suitable for use in hashing algorithms and data structures like a hash table.

See Also

Reference

PrintingUnit Structure
PrintingUnit Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Equality Operator
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintingUnit Structure : Equality Operator

a
A PrintingUnit which represents the left side of the comparison.
b
A PrintingUnit which represents the right side of the comparison.

Glossary Item Box

Determines whether two PrintingUnits are the same printing unit.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Operator =( _
   ByVal a As PrintingUnit, _
   ByVal b As PrintingUnit _
) As Boolean
'Usage

public bool operator ==(
   PrintingUnit a,
   PrintingUnit b
)
public: bool op_Equality(
   PrintingUnit a,
   PrintingUnit b
)
public:
bool operator ==(
   PrintingUnit a,
   PrintingUnit b
)

Parameters

a
A PrintingUnit which represents the left side of the comparison.
b
A PrintingUnit which represents the right side of the comparison.

Return Value

A boolean value which is true if the units are the same. Otherwise, false is returned.

See Also

Reference

PrintingUnit Structure
PrintingUnit Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Implicit Type Conversion Operator
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintingUnit Structure : Implicit Type Conversion Operator

Glossary Item Box

To implicitly convert between integer values and printing units.

Overload List

Overload | Description
Implicit Type Conversion(PrintingUnit,Int32) | To implicitly convert between integer values and printing units.
Implicit Type Conversion(Int32,PrintingUnit) | To implicitly convert between printing unit values and integers.
Implicit Type Conversion(PrintingUnit,GraphicsUnit) | Implicit operator to obtain a PrintingUnit from a graphics unit.
Implicit Type Conversion(GraphicsUnit,PrintingUnit) | Implicit cast operator to obtain a System.Drawing.GraphicsUnit from a PrintingUnit.

See Also

Reference

PrintingUnit Structure
PrintingUnit Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Implicit Type Conversion(PrintingUnit,Int32) Operator
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintingUnit Structure > Implicit Type Conversion Operator : Implicit Type Conversion(PrintingUnit,Int32) Operator

source
An integer value which represents the source units.

Glossary Item Box

To implicitly convert between integer values and printing units.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Overloads Public Operator Widening CType( _
   ByVal source As Integer _
) As PrintingUnit
'Usage

public PrintingUnit operator implicit(
   int source
)
public: PrintingUnit op_Implicit(
   int source
)
public:
operator PrintingUnit (
   int source
)

Parameters

source
An integer value which represents the source units.

Return Value

A printing unit converted which represents the number given.

See Also

Reference

PrintingUnit Structure
PrintingUnit Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Implicit Type Conversion(Int32,PrintingUnit) Operator
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintingUnit Structure > Implicit Type Conversion Operator : Implicit Type Conversion(Int32,PrintingUnit) Operator

source
A PrintingUnit printing unit value.

Glossary Item Box

To implicitly convert between printing unit values and integers.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Overloads Public Operator Widening CType( _
   ByVal source As PrintingUnit _
) As Integer
'Usage

public int operator implicit(
   PrintingUnit source
)
public: int op_Implicit(
   PrintingUnit source
)
public:
operator int (
   PrintingUnit source
)

Parameters

source
A PrintingUnit printing unit value.

Return Value

An integer value which represents the printing unit value.

See Also

Reference

PrintingUnit Structure
PrintingUnit Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Implicit Type Conversion(PrintingUnit,GraphicsUnit) Operator
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintingUnit Structure > Implicit Type Conversion Operator : Implicit Type Conversion(PrintingUnit,GraphicsUnit) Operator

source
A System.Drawing.GraphicsUnit value which represents the source to obtain a PrintingUnit from.

Glossary Item Box

Implicit operator to obtain a PrintingUnit from a graphics unit.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Overloads Public Operator Widening CType( _
   ByVal source As GraphicsUnit _
) As PrintingUnit
'Usage

public PrintingUnit operator implicit(
   GraphicsUnit source
)
public: PrintingUnit op_Implicit(
   GraphicsUnit source
)
public:
operator PrintingUnit (
   GraphicsUnit source
)

Parameters

source
A System.Drawing.GraphicsUnit value which represents the source to obtain a PrintingUnit from.

Return Value

A PrintingUnit equivalent value based on the given GraphicsUnit.

See Also

Reference

PrintingUnit Structure
PrintingUnit Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Implicit Type Conversion(GraphicsUnit,PrintingUnit) Operator
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintingUnit Structure > Implicit Type Conversion Operator : Implicit Type Conversion(GraphicsUnit,PrintingUnit) Operator

source
A PrintingUnit to convert to a System.Drawing.GraphicsUnit.

Glossary Item Box

Implicit cast operator to obtain a System.Drawing.GraphicsUnit from a PrintingUnit.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Overloads Public Operator Widening CType( _
   ByVal source As PrintingUnit _
) As GraphicsUnit
'Usage

public GraphicsUnit operator implicit(
   PrintingUnit source
)
public: GraphicsUnit op_Implicit(
   PrintingUnit source
)
public:
operator GraphicsUnit (
   PrintingUnit source
)

Parameters

source
A PrintingUnit to convert to a System.Drawing.GraphicsUnit.

Return Value

The equivalent graphics unit. If one is not available, an invalid cast exception is thrown.

See Also

Reference

PrintingUnit Structure
PrintingUnit Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Inequality Operator
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintingUnit Structure : Inequality Operator

a
left side of the comparison
b
right side of the comparison

Glossary Item Box

Determines whether two PrintingUnits are not the same printing unit.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Operator <>( _
   ByVal a As PrintingUnit, _
   ByVal b As PrintingUnit _
) As Boolean
'Usage

public bool operator !=(
   PrintingUnit a,
   PrintingUnit b
)
public: bool op_Inequality(
   PrintingUnit a,
   PrintingUnit b
)
public:
bool operator !=(
   PrintingUnit a,
   PrintingUnit b
)

Parameters

a
left side of the comparison
b
right side of the comparison

Return Value

false if the units are the same. true otherwise

See Also

Reference

PrintingUnit Structure
PrintingUnit Members


%%PageItemTitle%% $$Fields$$

[image]
Accusoft.PrintPro6.Net
PrintingUnit Structure Fields
See Also Send Feedback
Accusoft.PrintProSdk Namespace : PrintingUnit Structure

Glossary Item Box

For a list of all members of this type, see PrintingUnit members.

Public Fields

 | Name | Description
Public Field | Centimeter | The centimeter printing unit.
Public Field | Character | The character printing unit.
Public Field | HundredthsOfAMillimeter | A printing unit of 1/100th of a millimeter.
Public Field | HundredthsOfAnInch | A printing unit of 1/100th of an inch.
Public Field | Inch | The inch printing unit.
Public Field | Millimeter | The millimeter printing unit.
Public Field | Pixel | The pixel printing unit.
Public Field | Point | The point printing unit.
Public Field | TenthsOfAMillimeter | A printing unit of 1/10th a millimeter.
Public Field | ThousandthsOfAnInch | A printing unit of 1/1000th of an inch.
Public Field | ThreeHundredthsOfAnInch | A printing unit of 1/300th of an inch.
Public Field | Twip | The twip printing unit.
Top

See Also

Reference

PrintingUnit Structure
Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Centimeter Field
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintingUnit Structure : Centimeter Field

Glossary Item Box

The centimeter printing unit.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Const Centimeter As Integer
'Usage

Dim value As Integer

value = PrintingUnit.Centimeter
public const int Centimeter
public: const int Centimeter
public:
const int Centimeter

See Also

Reference

PrintingUnit Structure
PrintingUnit Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Character Field
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintingUnit Structure : Character Field

Glossary Item Box

The character printing unit.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Const Character As Integer
'Usage

Dim value As Integer

value = PrintingUnit.Character
public const int Character
public: const int Character
public:
const int Character

See Also

Reference

PrintingUnit Structure
PrintingUnit Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
HundredthsOfAMillimeter Field
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintingUnit Structure : HundredthsOfAMillimeter Field

Glossary Item Box

A printing unit of 1/100th of a millimeter.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Const HundredthsOfAMillimeter As Integer
'Usage

Dim value As Integer

value = PrintingUnit.HundredthsOfAMillimeter
public const int HundredthsOfAMillimeter
public: const int HundredthsOfAMillimeter
public:
const int HundredthsOfAMillimeter

See Also

Reference

PrintingUnit Structure
PrintingUnit Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
HundredthsOfAnInch Field
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintingUnit Structure : HundredthsOfAnInch Field

Glossary Item Box

A printing unit of 1/100th of an inch.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Const HundredthsOfAnInch As Integer
'Usage

Dim value As Integer

value = PrintingUnit.HundredthsOfAnInch
public const int HundredthsOfAnInch
public: const int HundredthsOfAnInch
public:
const int HundredthsOfAnInch

See Also

Reference

PrintingUnit Structure
PrintingUnit Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Inch Field
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintingUnit Structure : Inch Field

Glossary Item Box

The inch printing unit.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Const Inch As Integer
'Usage

Dim value As Integer

value = PrintingUnit.Inch
public const int Inch
public: const int Inch
public:
const int Inch

See Also

Reference

PrintingUnit Structure
PrintingUnit Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Millimeter Field
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintingUnit Structure : Millimeter Field

Glossary Item Box

The millimeter printing unit.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Const Millimeter As Integer
'Usage

Dim value As Integer

value = PrintingUnit.Millimeter
public const int Millimeter
public: const int Millimeter
public:
const int Millimeter

See Also

Reference

PrintingUnit Structure
PrintingUnit Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Pixel Field
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintingUnit Structure : Pixel Field

Glossary Item Box

The pixel printing unit.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Const Pixel As Integer
'Usage

Dim value As Integer

value = PrintingUnit.Pixel
public const int Pixel
public: const int Pixel
public:
const int Pixel

See Also

Reference

PrintingUnit Structure
PrintingUnit Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Point Field
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintingUnit Structure : Point Field

Glossary Item Box

The point printing unit.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Const Point As Integer
'Usage

Dim value As Integer

value = PrintingUnit.Point
public const int Point
public: const int Point
public:
const int Point

Remarks

One point is 1/72 inch.

See Also

Reference

PrintingUnit Structure
PrintingUnit Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
TenthsOfAMillimeter Field
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintingUnit Structure : TenthsOfAMillimeter Field

Glossary Item Box

A printing unit of 1/10th a millimeter.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Const TenthsOfAMillimeter As Integer
'Usage

Dim value As Integer

value = PrintingUnit.TenthsOfAMillimeter
public const int TenthsOfAMillimeter
public: const int TenthsOfAMillimeter
public:
const int TenthsOfAMillimeter

See Also

Reference

PrintingUnit Structure
PrintingUnit Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
ThousandthsOfAnInch Field
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintingUnit Structure : ThousandthsOfAnInch Field

Glossary Item Box

A printing unit of 1/1000th of an inch.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Const ThousandthsOfAnInch As Integer
'Usage

Dim value As Integer

value = PrintingUnit.ThousandthsOfAnInch
public const int ThousandthsOfAnInch
public: const int ThousandthsOfAnInch
public:
const int ThousandthsOfAnInch

See Also

Reference

PrintingUnit Structure
PrintingUnit Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
ThreeHundredthsOfAnInch Field
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintingUnit Structure : ThreeHundredthsOfAnInch Field

Glossary Item Box

A printing unit of 1/300th of an inch.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Const ThreeHundredthsOfAnInch As Integer
'Usage

Dim value As Integer

value = PrintingUnit.ThreeHundredthsOfAnInch
public const int ThreeHundredthsOfAnInch
public: const int ThreeHundredthsOfAnInch
public:
const int ThreeHundredthsOfAnInch

See Also

Reference

PrintingUnit Structure
PrintingUnit Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Twip Field
See Also Send Feedback
Accusoft.PrintProSdk Namespace > PrintingUnit Structure : Twip Field

Glossary Item Box

The twip printing unit.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Const Twip As Integer
'Usage

Dim value As Integer

value = PrintingUnit.Twip
public const int Twip
public: const int Twip
public:
const int Twip

Remarks

One twip is 1/1440 inch.

See Also

Reference

PrintingUnit Structure
PrintingUnit Members


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Alignment Enumeration
See Also Send Feedback
Accusoft.PrintProSdk Namespace : Alignment Enumeration

Glossary Item Box

Option values which determine the alignment when printing.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum Alignment
   Inherits System.Enum
'Usage

Dim instance As Alignment
public enum Alignment : System.Enum
__value public enum Alignment : public System.Enum
public enum class Alignment : public System.Enum

Members

Member | Value | Description
CenterJustifyBottom | 8 | Center Justify Bottom
CenterJustifyMiddle | 7 | Center Justify Middle
CenterJustifyTop | 6 | Center Justify Top
LeftJustifyBottom | 2 | Left Justify Bottom
LeftJustifyMiddle | 1 | Left Justify Middle
LeftJustifyTop | 0 | Left Justify Top
RightJustifyBottom | 5 | Right Justify Bottom
RightJustifyMiddle | 4 | Right Justify Middle
RightJustifyTop | 3 | Right Justify Top

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.PrintProSdk.Alignment

See Also

Reference

Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
BackStyle Enumeration
See Also Send Feedback
Accusoft.PrintProSdk Namespace : BackStyle Enumeration

Glossary Item Box

Option values which determine the available backstyles to be used for printed text.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum BackStyle
   Inherits System.Enum
'Usage

Dim instance As BackStyle
public enum BackStyle : System.Enum
__value public enum BackStyle : public System.Enum
public enum class BackStyle : public System.Enum

Members

Member | Value | Description
Opaque | 1 | opaque/filled
Transparent | 0 | transparent

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.PrintProSdk.BackStyle

See Also

Reference

Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
DebugErrorLevel Enumeration
See Also Send Feedback
Accusoft.PrintProSdk Namespace : DebugErrorLevel Enumeration

Glossary Item Box

Option values which determine the available error levels for debugging.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum DebugErrorLevel
   Inherits System.Enum
'Usage

Dim instance As DebugErrorLevel
public enum DebugErrorLevel : System.Enum
__value public enum DebugErrorLevel : public System.Enum
public enum class DebugErrorLevel : public System.Enum

Members

Member | Value | Description
Detailed | 2 | The highest level of logging
Development | 1 | Additionally logs information that would be helpful for developers
Normal | 0 | Minimal logging would be done

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.PrintProSdk.DebugErrorLevel

See Also

Reference

Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
DrawMode Enumeration
See Also Send Feedback
Accusoft.PrintProSdk Namespace : DrawMode Enumeration

Glossary Item Box

Option values which determine the available drawing modes for the PrintPro native drawing routines.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum DrawMode
   Inherits System.Enum
'Usage

Dim instance As DrawMode
public enum DrawMode : System.Enum
__value public enum DrawMode : public System.Enum
public enum class DrawMode : public System.Enum

Members

Member | Value | Description
Blackness | 1 | Always draws black
CopyPen | 13 | Pixel is the pen color.
Invert | 6 | Pixel is the inverse of the screen color.
MaskNotPen | 3 | Pixel is a combination of the colors common to both the screen and the inverse of the pen.
MaskPen | 9 | Pixel is a combination of the colors common to both the pen and the screen.
MaskPenNot | 5 | Pixel is a combination of the colors common to both the pen and the inverse of the screen.
MergeNotPen | 12 | Pixel is a combination of the screen color and the inverse of the pen color.
MergePen | 15 | Pixel is a combination of the pen color and the screen color.
MergePenNot | 14 | Pixel is a combination of the pen color and the inverse of the screen color.
Nop | 11 | Pixel remains unchanged. (In effect, this turns drawing off)
NotCopyPen | 4 | Pixel is the inverse of the pen color.
NotMaskPen | 8 | Pixel is the inverse of the MaskPen color.
NotMergePen | 2 | Pixel is the inverse of the MergePen color
NotXorPen | 10 | Pixel is the inverse of the Xor color.
Whiteness | 16 | Always draws white
Xor | 7 | Pixel is a combination of the colors in the pen and in the screen, but not in both.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.PrintProSdk.DrawMode

See Also

Reference

Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
DrawStyle Enumeration
See Also Send Feedback
Accusoft.PrintProSdk Namespace : DrawStyle Enumeration

Glossary Item Box

Option values which determine the available drawing styles for the PrintPro native drawing routines.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum DrawStyle
   Inherits System.Enum
'Usage

Dim instance As DrawStyle
public enum DrawStyle : System.Enum
__value public enum DrawStyle : public System.Enum
public enum class DrawStyle : public System.Enum

Members

Member | Value | Description
Dash | 2 | Dashes
DashDot | 4 | Dash, Dot repeated
DashDotDot | 5 | Dash, Dot, Dot repeated
Dot | 3 | Dots
Solid | 1 | Solid
Transparent | 0 | Transparent

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.PrintProSdk.DrawStyle

See Also

Reference

Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
EvaluationMode Enumeration
See Also Send Feedback
Accusoft.PrintProSdk Namespace : EvaluationMode Enumeration

Glossary Item Box

Option values which determine licensing evaluation modes.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum EvaluationMode
   Inherits System.Enum
'Usage

Dim instance As EvaluationMode
public enum EvaluationMode : System.Enum
__value public enum EvaluationMode : public System.Enum
public enum class EvaluationMode : public System.Enum

Members

Member | Value | Description
Automatic | 0 | The trial licensing dialog box will appear at regular intervals.
Timeout | 1 | The control will stop operation after five minutes and raise an error condition.

Remarks

In order to test the component in an application running as a service or other environments where the component does not have permissions to create a window, the application logic needs to set the EvaluationMode to Timeout. In this mode, the component does not attempt to create the Evaluation Mode dialog window, but will timeout after 5 minutes of operation and cease to operate.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.PrintProSdk.EvaluationMode

See Also

Reference

Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
FillStyle Enumeration
See Also Send Feedback
Accusoft.PrintProSdk Namespace : FillStyle Enumeration

Glossary Item Box

Option values which determine the pattern used to fill circles, boxes, round rectangles, pie-shapes and polygons created with the native PrintPro drawing routines.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum FillStyle
   Inherits System.Enum
'Usage

Dim instance As FillStyle
public enum FillStyle : System.Enum
__value public enum FillStyle : public System.Enum
public enum class FillStyle : public System.Enum

Members

Member | Value | Description
Cross | 6 | Horizontal and vertical hatch fill
DiagonalCross | 7 | 45-degree crosshatch fill
DownwardDiagonal | 4 | A 45-degree downward, left-to-right line fill
HorizontalLine | 2 | Horizontal line fill
Solid | 0 | Solid fill
Transparent | 1 | Transparent fill
UpwardDiagonal | 5 | A 45-degree upward, left-to-right line fill
VerticalLine | 3 | Vertical line fill

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.PrintProSdk.FillStyle

See Also

Reference

Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
IcmIntent Enumeration
See Also Send Feedback
Accusoft.PrintProSdk Namespace : IcmIntent Enumeration

Glossary Item Box

Option values which determine the possible color management methods, or intents.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum IcmIntent
   Inherits System.Enum
'Usage

Dim instance As IcmIntent
public enum IcmIntent : System.Enum
__value public enum IcmIntent : public System.Enum
public enum class IcmIntent : public System.Enum

Members

Member | Value | Description
ColorMetric | 3 | Color matching should optimize to match the exact color requested. This value is most appropriate for use with business logos or other images when an exact color is desired.
Contrast | 2 | Color matching should optimize for color contrast. This value is the most appropriate choice for scanned or photographic images when dithering is desired.
Saturation | 1 | Color matching should optimize for color saturation. This value is the most appropriate choice for business graphs when dithering is not desired.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.PrintProSdk.IcmIntent

See Also

Reference

Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
IcmMethod Enumeration
See Also Send Feedback
Accusoft.PrintProSdk Namespace : IcmMethod Enumeration

Glossary Item Box

Option values which determine the ICM method to use.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum IcmMethod
   Inherits System.Enum
'Usage

Dim instance As IcmMethod
public enum IcmMethod : System.Enum
__value public enum IcmMethod : public System.Enum
public enum class IcmMethod : public System.Enum

Members

Member | Value | Description
Device | 4 | Specifies that ICM is handled by the device.
Disabled | 1 | Specifies that ICM is disabled.
Driver | 3 | Specifies that ICM is handled by the device driver.
Profile | 5 | Specifies that PrintPRO will apply the ICM profile associated with the destination device (printer or monitor).
System | 2 | Specifies that ICM is handled by Windows.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.PrintProSdk.IcmMethod

See Also

Reference

Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
IcmRenderIntent Enumeration
See Also Send Feedback
Accusoft.PrintProSdk Namespace : IcmRenderIntent Enumeration

Glossary Item Box

Option values which determine the purpose of the color correction.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum IcmRenderIntent
   Inherits System.Enum
'Usage

Dim instance As IcmRenderIntent
public enum IcmRenderIntent : System.Enum
__value public enum IcmRenderIntent : public System.Enum
public enum class IcmRenderIntent : public System.Enum

Members

Member | Value | Description
AbsoluteColormetric | 3 | The white point is preserved. Spatial color distance to white point changes but not the white point itself. (Absolute Colormetric)
Business | 1 | Only colors outside of gamut moved to closest inside value. White Point is not preserved. (Relative Colormetric)
Graphics | 2 | Preserve color saturation at expense of hue and lightness. Colors are vibrant but not accurate. (Saturation)
Images | 0 | Gamut of image fits (shrinks or expands) and fills the destination device gamut. Spatial distance of colors are relatively scaled for all color to fit within the gamut of the device. (Perceptual).
None | -1 | Disables Image Color Management.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.PrintProSdk.IcmRenderIntent

See Also

Reference

Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
MediaType Enumeration
See Also Send Feedback
Accusoft.PrintProSdk Namespace : MediaType Enumeration

Glossary Item Box

Option values which determine the type of media being printed on (if the printer supports this feature).

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum MediaType
   Inherits System.Enum
'Usage

Dim instance As MediaType
public enum MediaType : System.Enum
__value public enum MediaType : public System.Enum
public enum class MediaType : public System.Enum

Members

Member | Value | Description
Glossy | 3 | Glossy paper
NotSupported | 0 | Media type selection is not supported
Standard | 1 | Standard paper
Transparency | 2 | Transparancy "paper"
UserDefined | -1 | A user defined media type is selected

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.PrintProSdk.MediaType

See Also

Reference

Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
Orientation Enumeration
See Also Send Feedback
Accusoft.PrintProSdk Namespace : Orientation Enumeration

Glossary Item Box

Option values which determine whether documents are printed in portrait or landscape mode (if the printer supports this feature).

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum Orientation
   Inherits System.Enum
'Usage

Dim instance As Orientation
public enum Orientation : System.Enum
__value public enum Orientation : public System.Enum
public enum class Orientation : public System.Enum

Members

Member | Value | Description
Landscape | 2 | Documents are printed with the top at the wide side of the paper.
Portrait | 1 | Documents are printed with the top at the narrow side of the paper.
Rotate | 3 | Documents are rotated. This is rarely supported by printers.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.PrintProSdk.Orientation

See Also

Reference

Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintColorMode Enumeration
See Also Send Feedback
Accusoft.PrintProSdk Namespace : PrintColorMode Enumeration

Glossary Item Box

Option values which determine whether a color printer prints output in color or monochrome.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum PrintColorMode
   Inherits System.Enum
'Usage

Dim instance As PrintColorMode
public enum PrintColorMode : System.Enum
__value public enum PrintColorMode : public System.Enum
public enum class PrintColorMode : public System.Enum

Members

Member | Value | Description
Color | 2 | Print output in color.
Monochrome | 1 | Print output in monochrome (usually shades of black and white).

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.PrintProSdk.PrintColorMode

See Also

Reference

Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintDitherType Enumeration
See Also Send Feedback
Accusoft.PrintProSdk Namespace : PrintDitherType Enumeration

Glossary Item Box

Option values which determine how dithering is to be done (if the printer supports this feature).

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum PrintDitherType
   Inherits System.Enum
'Usage

Dim instance As PrintDitherType
public enum PrintDitherType : System.Enum
__value public enum PrintDitherType : public System.Enum
public enum class PrintDitherType : public System.Enum

Members

Member | Value | Description
CoarseDither | 2 | Dither with a coarse brush.
ErrorDiffusion | 5 | A special type of dithering in which the quantization residual is distributed to neighboring pixels which have not yet been processed. Error diffusion has the tendency to enhance edges in an image. This can make text in images more readable than in other dithering techniques.
FineDither | 3 | Dither with a fine brush.
GrayScale | 10 | Printer does grayscaling.
LineArtDither | 4 | Line art dithering, a special dithering method that produces well defined borders between black, white, and gray scaling. It is not suitable for images that include continuous gradations in intensity and hue such as scanned photographs.
NoDither | 1 | No dithering.
NotSet | -1 | Specification of the dither type is not supported
NotSupported | 0 | Specification of the dither type is not supported
UserDefined | 256 | The user has specified a printer specific dithering type.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.PrintProSdk.PrintDitherType

See Also

Reference

Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintDuplex Enumeration
See Also Send Feedback
Accusoft.PrintProSdk Namespace : PrintDuplex Enumeration

Glossary Item Box

Option values which determine whether a page is printed on both sides (if the printer supports this feature).

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum PrintDuplex
   Inherits System.Enum
'Usage

Dim instance As PrintDuplex
public enum PrintDuplex : System.Enum
__value public enum PrintDuplex : public System.Enum
public enum class PrintDuplex : public System.Enum

Members

Member | Value | Description
Horizontal | 3 | Double-sided printing using a horizontal page turn.
Simplex | 1 | Single-sided printing with the current orientation setting.
Vertical | 2 | Double-sided printing using a vertical page turn.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.PrintProSdk.PrintDuplex

See Also

Reference

Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintPreviewScale Enumeration
See Also Send Feedback
Accusoft.PrintProSdk Namespace : PrintPreviewScale Enumeration

Glossary Item Box

Option values which determine the scaling size of the print preview image.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum PrintPreviewScale
   Inherits System.Enum
'Usage

Dim instance As PrintPreviewScale
public enum PrintPreviewScale : System.Enum
__value public enum PrintPreviewScale : public System.Enum
public enum class PrintPreviewScale : public System.Enum

Members

Member | Value | Description
Scale1to1 | 1 | The image size is the same size as the printed image.
Scale1to10 | 10 | The image size is one-tenth the same size as the printed image.
Scale1to2 | 2 | The image size is one-half the same size as the printed image.
Scale1to3 | 3 | The image size is one-third the same size as the printed image.
Scale1to4 | 4 | The image size is one-fourth the same size as the printed image.
Scale1to5 | 5 | The image size is one-fifth the same size as the printed image.
Scale1to6 | 6 | The image size is one-sixth the same size as the printed image.
Scale1to7 | 7 | The image size is one-seventh the same size as the printed image.
Scale1to8 | 8 | The image size is one-eight the same size as the printed image.
Scale1to9 | 9 | The image size is one-ninth the same size as the printed image.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.PrintProSdk.PrintPreviewScale

See Also

Reference

Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintRangeAvailable Enumeration
See Also Send Feedback
Accusoft.PrintProSdk Namespace : PrintRangeAvailable Enumeration

Glossary Item Box

Option values which determine the available radio buttons in the print dialog. The All value is always enabled. Using All will only enable the All radio button.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<FlagsAttribute()>
Public Enum PrintRangeAvailable
   Inherits System.Enum
'Usage

Dim instance As PrintRangeAvailable
[FlagsAttribute()]
public enum PrintRangeAvailable : System.Enum
[FlagsAttribute()]
__value public enum PrintRangeAvailable : public System.Enum
[FlagsAttribute()]
public enum class PrintRangeAvailable : public System.Enum

Members

Member | Value | Description
All | 0 | Enable the All radio selection
Pages | 1 | Enable the Pages radio selection
Selection | 2 | Enable the Selection radio selection

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.PrintProSdk.PrintRangeAvailable

See Also

Reference

Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
PrintRangeSelection Enumeration
See Also Send Feedback
Accusoft.PrintProSdk Namespace : PrintRangeSelection Enumeration

Glossary Item Box

Option values which determine the Print Range selected on the Print Dialog box.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum PrintRangeSelection
   Inherits System.Enum
'Usage

Dim instance As PrintRangeSelection
public enum PrintRangeSelection : System.Enum
__value public enum PrintRangeSelection : public System.Enum
public enum class PrintRangeSelection : public System.Enum

Members

Member | Value | Description
All | 1 | The user selected the All radio button.
NoSelection | 0 | No selection.
Pages | 2 | The user selected the Pages radio button.
Selection | 3 | The user selected the Selection radio button.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.PrintProSdk.PrintRangeSelection

See Also

Reference

Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
RotationPivotMode Enumeration
See Also Send Feedback
Accusoft.PrintProSdk Namespace : RotationPivotMode Enumeration

Glossary Item Box

Option values which determine the pivot location for Draw.TextRotated.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum RotationPivotMode
   Inherits System.Enum
'Usage

Dim instance As RotationPivotMode
public enum RotationPivotMode : System.Enum
__value public enum RotationPivotMode : public System.Enum
public enum class RotationPivotMode : public System.Enum

Members

Member | Value | Description
CenterJustified | 2 | center justified
LeftJustified | 0 | left justified
RightJustified | 1 | right justified

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.PrintProSdk.RotationPivotMode

See Also

Reference

Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
SaveFileType Enumeration
See Also Send Feedback
Accusoft.PrintProSdk Namespace : SaveFileType Enumeration

Glossary Item Box

Option values which determine the type of file generated when printing to file.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum SaveFileType
   Inherits System.Enum
'Usage

Dim instance As SaveFileType
public enum SaveFileType : System.Enum
__value public enum SaveFileType : public System.Enum
public enum class SaveFileType : public System.Enum

Members

Member | Value | Description
Bmp | 5 | bmp output
Default | 0 | bitmap output
Emf | 6 | enhanced metafile output
PdfDefault | 8 | default compression pdf output
PdfG3 | 10 | g3 compressed pdf output
PdfG32D | 11 | g3-2d compressed pdf output
PdfG4 | 7 | g4 compressed pdf output
PdfJbig2 | 12 | jbig2 compressed pdf output
PdfNoCompress | 9 | uncompressed pdf output
PdfSeqJpeg | 13 | sequential jpeg compressed pdf output
Tif | 1 | uncompressed tiff output
TifG3 | 2 | g3 compressed tiff output
TifG32D | 3 | g3-2d compressed tiff output
TifG4 | 4 | g4 compressed tiff output
TifSeqJpeg | 14 | sequential jpeg compressed tif output

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.PrintProSdk.SaveFileType

See Also

Reference

Accusoft.PrintProSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.PrintPro6.Net
TrueTypeOption Enumeration
See Also Send Feedback
Accusoft.PrintProSdk Namespace : TrueTypeOption Enumeration

Glossary Item Box

Option values which determine the printer’s TrueType option.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum TrueTypeOption
   Inherits System.Enum
'Usage

Dim instance As TrueTypeOption
public enum TrueTypeOption : System.Enum
__value public enum TrueTypeOption : public System.Enum
public enum class TrueTypeOption : public System.Enum

Members

Member | Value | Description
DownloadFonts | 2 | Download TrueType fonts as soft fonts. This is the default for HP printers that use PCL.
DownloadOutline | 4 | Downloads TrueType fonts as outline soft fonts.
PrintAsGraphics | 1 | Print TrueType fonts as graphics. This should be used for dot matrix printers.
UseDeviceFonts | 3 | Substitute device fonts for TrueType fonts. This is the default for Postscript printers.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.PrintProSdk.TrueTypeOption

See Also

Reference

Accusoft.PrintProSdk Namespace