%%ItemTitle%%

Accusoft.ISISXpress5.Net
ISIS Xpress User Assistance Dashboard
Send Feedback

Glossary Item Box

Welcome

  • New Features
    • What is ISIS Xpress?

Getting Started

  • Operating Requirements & Installation
    • Operating Requirements
    • Upgrading from ISIS Xpress 4 to ISIS Xpress 5
    • Installing on a Development Machine
  • Licensing & Deployment
    • Licensing
    • Distributing ISIS Xpress
    • Software License Agreement
    • Accusoft Corporation Copyrights & Trademarks

Developer's Guide

  • User Guide

    • Concepts

      • Overview of ISIS Xpress
      • Glossary
  • API Reference Guide
    • Accusoft.ISISXpress5.Net Assembly

Additional Resources

  • Online Product Overview
  • Tech Specs
  • White papers & Case Studies
  • FAQs, ISIS Xpress 5 FAQs
  • Support Overview
  • Support Plans/Agreement

Feedback

  • Tell us what you think
    • Email us
    • Take our survey

©2012. Accusoft Corporation. All Rights Reserved.


%%ItemTitle%%

ISIS Xpress 5 for .NET - User Guide
Send Feedback

Glossary Item Box

The User Guide provides information about the following:

  • Introduction
  • Getting Started
  • Licensing
  • Distributing Applications and Deployment
  • Concepts


%%ItemTitle%%

Introduction
Send Feedback
ISIS Xpress 5 for .NET - User Guide > Introduction

Glossary Item Box

This section provides information about the following:

  • What is ISIS Xpress?
  • Getting Support
  • Accusoft Corporation Copyrights & Trademarks


%%ItemTitle%%

What is ISIS Xpress?
See Also Send Feedback
ISIS Xpress 5 for .NET - User Guide > Introduction > What is ISIS Xpress?

Glossary Item Box

ISIS® Xpress™ Version 5 is a powerful, complete, and low-cost software development kit (SDK) used to control high-speed ISIS scanners. ISIS® Xpress can be used as a .NET component or an ActiveX COM component. Designed for high-speed scanning of black/white, grayscale and color documents, it supports simultaneous image capture (multi-streaming), and provides access to ISIS scanner features. ISIS® is a registered trademark of EMC Corporation.

New Features in Version 5

  • Updated support of all high-speed ISIS®-driven scanners using Version 8.5 of EMC Corporation's ISIS® PixTools® library.
  • Added the ability to return the version/build number programmatically.
  • Added the ability to easily copy or transfer image data to other Accusoft components without having to manually work with DIBs.
  • Added a new licensing model.

Primary Features Included

Scanner Support

  • Provides complete control over all high-speed ISIS®-driven scanners that EMC Corporation's ISIS PixTools supports.
  • Scan directly to memory.
  • Resolution can range from 50 dots-per-inch (dpi) to 2400 dpi or more depending on scanner capability.
  • Automatic feeder, printer/endorsers, and transparency units are supported.
  • Interfaces with SCSI, USB, serial port, video, parallel port, GPIB, and proprietary interfaces.
  • Access performance scanners from Canon, Agfa, BancTec, Bell & Howell, Epson, Fujitsu, Hewlett-Packard, Inotec, Kodak, Microtek, Minolta, Panasonic, Ricoh, Sharp, and Umax.

Compression & File Formats

  • Compress to standard document image file formats:
    • TIFF (Raw, Packbits, Binary CCITT Group 3, Binary CCITT Group 3 Modified, Binary CCITT Group 4)
    • Color and grayscale JPEG (24-bit sequential and 8-bit gray sequential).
    • DCX
  • For .NET, output to:
    • Bitmap
    • HBitmap
    • HDIB
  • Add on ImagXpress™ for decompression, conversion, or display of the file formats listed above plus support for many additional file formats.
  • Add on PDF Xpress™ for PDF support.

Advanced Tags

The component supports Advanced Tags, which offers developers great flexibility in utilizing scanner specific features. These are scanner processing instructions which are provided as parameters passed as tag values to the control, and consequently passed directly through to the scanner. Assuming the correct tags are passed to the scanner, they will instruct the scanner what actions to take.

Multi-Streaming Support

  • Take full advantage of scanners supporting MultiStream technology with Duplex or Multi-Streaming:
    • Duplex - Scans both front and back simultaneously.
    • MultiStreaming - Scans two images from the same side.
    • Combine both by using duplex with multi-streaming and capture four images with two on the front and two from the back.
  • Scanning modes could include full-color, black-and-white, grayscale, binary or RGB color dropout.

Image Viewing, Annotation, & Printing

Add on ImagXpress for image viewing, thumbnail image support, document image processing and editing, TWAIN scanning, annotation, printing and more.

Bitonal Image Cleanup

Add on ScanFix Xpress® for advanced bitonal image cleanup technology such as dot shading removal, line removal, character smoothing, inverse text correction, hole punch removal, deskew, despeckle, rotate, mirror, flip and more.

Additional Accusoft Components

Additional components are available for purchase separately, and integrate easily to provide a comprehensive imaging solution:

  • PDF Xpress™ – PDF creation, viewing, and annotating
  • Barcode Xpress™ – recognize barcodes
  • ScanFix Xpress™ – advanced image cleanup
  • FormFix™ – form ID, dropout, and OMR
  • SmartZone™ ICR / OCR – character recognition
  • ImageGear for .NET - Fully managed code to create cutting edge imaging applications
  • ImageGear for Silverlight - Comprehensive SDK for building Web imaging applications
  • ImageGear for .NET Compact Framework - Create reliable and secure imaging applications for mobile devices

See www.accusoft.com for product packaging and sales information.

ISIS® is a registered trademark of EMC Corporation.

See Also

Getting Support
Software License Agreement
Operating Requirements


%%ItemTitle%%

Getting Support
See Also Send Feedback
ISIS Xpress 5 for .NET - User Guide > Introduction > Getting Support

Glossary Item Box

For information about Accusoft Support, please refer to the Software Support and Maintenance Policy on the Accusoft web site or call Accusoft at 813-875-7575.

See Also

Operating Requirements
Installing on a Development Machine


%%ItemTitle%%

Accusoft Corporation Copyrights & Trademarks
See Also Send Feedback
ISIS Xpress 5 for .NET - User Guide > Introduction > Accusoft Corporation Copyrights & Trademarks

Glossary Item Box

©1997-2012 Accusoft Corporation. All rights reserved.

Information in this document is subject to change without notice. No part of this document may be reproduced or transmitted in any form or by any means, electronic or mechanical, for any purpose, without the express written permission of Accusoft® Corporation.

This manual and the software described in it are both products of the USA.

Accusoft Corporation
4001 North Riverside Drive
Tampa, FL 33603
Sales: 813-875-7575
www.accusoft.com

Accusoft Trademarks

The following are trademarks (™) or registered marks (®) of Accusoft Corporation:

  • Accusoft®
  • Accusoft Logo™
  • Accusoft Pegasus Logo™
  • Adeptol®
  • AIMTools™
  • Barcode Xpress™
  • CapturePro™
  • Digital Mark Recognition® (DMR)
  • FolderBots™
  • FormAssist™
  • FormDirector™
  • FormFix™
  • FormSuite™
  • ImageGear® for .NET
  • ImageGear® for .NET Compact Framework
  • ImageGear® for Silverlight
  • ImageGear® Medical
  • ImageGear® Professional
  • ImageGear®
  • ImageTransport MD™
  • ImagXpress®
  • ISIS® Xpress™
    • ISIS is a registered trademark of EMC Corporation
    • ISIS Xpress is a trademark of Accusoft Corporation
  • MICR Xpress™
  • NetVue™
  • NotateXpress™
  • PDF Xpress™
  • Pegasus®
  • PICTools™
  • PICTools™ Document
  • PICTools™ Fingerprint
  • PICTools™ Medical
  • PICTools™ Photo
  • PICVideo™ M-JPEG Codec
  • PrintPRO™
  • Prizm®
  • Prizm® Viewer
  • ScanFix® Xpress™
  • SmartZone™
  • The JPEG Wizard™
  • ThumbnailXpress™
  • TwainPRO™

Accusoft and/or its agents use these marks and brand names in connection with its goods and/or services, in the United States and other countries.

Microsoft, Internet Explorer, Microsoft.NET, Silverlight, Visual Basic, Visual Studio, and Visual Studio.NET are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries.

Itanium is a registered trademark of Intel Corporation in the United States and other countries.

All other product and brand names are the property of their respective owners.

See Also

Software License Agreement


%%ItemTitle%%

Getting Started
Send Feedback
ISIS Xpress 5 for .NET - User Guide > Getting Started

Glossary Item Box

This section provides information about the following:

  • Operating Requirements
  • Installing on a Development Machine


%%ItemTitle%%

Operating Requirements
See Also Send Feedback
ISIS Xpress 5 for .NET - User Guide > Getting Started > Operating Requirements

Glossary Item Box

Operating Systems

ISIS® Xpress™ runs on the following Operating Systems:

  • Windows XP, XP Professional
  • Windows Vista
  • Windows 7
  • Windows Server 2003
  • Windows Server 2008

Development Environment

ISIS Xpress is supported on the following development environments:

  • Microsoft .NET Framework 2.0, 3.0
  • Microsoft Visual Studio 2005
  • Microsoft Visual Studio 2008

See Also

Getting Support
Installing on a Development Machine


%%ItemTitle%%

Installing on a Development Machine
See Also Send Feedback
ISIS Xpress 5 for .NET - User Guide > Getting Started > Installing on a Development Machine

Glossary Item Box

To Install ISIS® Xpress™ Component

Run the downloaded setup program which installs the development kit on your development machine.

The downloaded development kit includes code samples for supported platforms. Samples are available through the Start | Programs | Accusoft | ISISXpress menu.

By default this will register trial licensing which allows you to develop applications but not to distribute them. The trial license allows testing of all the functions and features.

Please see the section Distributing ISIS Xpress to understand the limits and details to convert licensing editions.
In order to distribute your finished application you must purchase and install a fully paid license from Accusoft. The paid licenses override trial licenses.

To Use ISIS Xpress Help Files

Once you install ISIS Xpress, you will have access to the following stand-alone help file:

  • Accusoft.ISISXpress5.Net.chm

    Access the ISIS Xpress stand-alone help through the Windows Start menu: Start | Programs | Accusoft | ISISXpress 5

In addition, you will have access to the following compiled collection help file, depending on which version of Visual Studio you have installed:

  • Accusoft.ISISXpress5.Net.hxs - Help 2 collection files. If you have Visual Studio 2005 or 2008 installed, these Help 2 files will be registered.
  • AccusoftISISXpress5_Net.cab - MHV (Microsoft Help Viewer). If you have Visual Studio 2010 installed, these MHV files will be registered.

Plugging ISIS Xpress Help into Visual Studio

ISIS Xpress Help 2 files integrate within the Help system in Visual Studio .NET automatically if Visual Studio was installed prior to installing ImagXpress. To access ImagXpress Help within Visual Studio, do the following:

  • Ensure that the MSDN Library is installed in your Visual Studio environment. If it is not installed, re-install it from your VS.NET disc.
  • Ensure that MS Help Integration Kit is installed in your Visual Studio environment. If you do not have it installed:
  1. Download the Help Integration kit from MSDN.
  2. Close Visual Studio.
  • Re-open Visual Studio, select the Help Menu and the Contents submenu. Verify Help files for Accusoft controls are listed. If Accusoft Help is not listed:
  1. Search for "VSCC" in Visual Studio Help, leaving the "Filtered by:" list box blank. Select the "Visual Studio .NET Combined Help Collection Manager" topic.
  2. Select the Help 2 collections available on your PC under the heading "Collections available for inclusion in VSCC."
  3. Take care when excluding Help collections from the default VSCC collection. These collections may be necessary to view required documentation. Instead, use the "Filtered by:" field on the Contents tab of the Help panel to focus searches on Accusoft topics. Leave the "Filtered by:" list box empty to view the entire Accusoft Help files.
  4. Select the Update VSCC button.
  5. Close all instances of Visual Studio and Microsoft Document Explorer. When you restart Visual Studio, the VSCC Help collection revises with your changes. (Note: this may take several minutes.)
  6. Check the Visual Studio Help/Contents tab again to see the Help collections available to you.
  • Select the ISIS Xpress Help file to view Help content.

See Also

Operating Requirements
Software License Agreement
Distributing ISIS Xpress
Licensing


%%ItemTitle%%

Upgrading from ISIS Xpress 4 to ISIS Xpress 5
Send Feedback
ISIS Xpress 5 for .NET - User Guide > Getting Started > Upgrading from ISIS Xpress 4 to ISIS Xpress 5

Glossary Item Box

This section describes how to upgrade from ISIS Xpress 4 to ISIS Xpress 5. While generally you'll be able to replace ISIS Xpress 4 with ISIS Xpress 5, there are a few important changes you may need to consider. This section provides information about those changes.

Changes and New Properties/Methods

ISIS Xpress 5 introduces changes to the ISIS Xpress API, as described in this section.

  • Added the Version property to the ISISXpress class, which returns the ISIS Xpress version at run-time.
  • Added the TransferTo() method to the Output class to provide the means to transfer an image to another Accusoft control without worrying about how the image is transferred.
  • Added the ability to easily copy or transfer image data to other Accusoft components without having to manually work with DIBs. Refer to the How To Pass Image Data Between Different Accusoft Components section, as well as the CopyTo() and TransferTo() methods.
  • Accusoft's new licensing structure is available in ISIS Xpress 5. See Licensing for information about the new licensing, and Upgrading Runtime Licensing for information about updating your licensing from an earlier version of ISIS Xpress.

If you encounter any porting issues, please contact support@accusoft.com for assistance.


%%ItemTitle%%

Upgrading Runtime Licensing
Send Feedback
ISIS Xpress 5 for .NET - User Guide > Getting Started > Upgrading Runtime Licensing

Glossary Item Box

This section describes how to upgrade to Accusoft's new Runtime Licensing.

Prior to ISIS Xpress 5, runtime licensing was accomplished using the UnlockRuntime method.

In ISIS Xpress 5, the default licensing model is Automatically Reported Runtime Licensing. However, based on your contracted usage of this software, you may be eligible for Manually Reported Runtime Licensing. Your Accusoft Sales Representative (sales@accusoft.com) can help you determine which model is appropriate.

Refer to the following sections for information about upgrading to the new Runtime Licensing models:

  • Upgrading to Automatically Reported Runtime Licensing
  • Upgrading to Manually Reported Runtime Licensing

Upgrading to Automatically Reported Runtime Licensing

Automatically Reported Runtime Licensing requires a license to be installed on the end-user's machine. See the Licensing section for more information.

In your ISIS Xpress 4 codebase, find any existing calls to the UnlockRuntime method.

C# Copy Code
 ISISXpress1.Licensing.UnlockRuntime(12345,12345,12345,12345);
VB.NET Copy Code
 ISISXpress1.Licensing.UnlockRuntime(12345,12345,12345,12345)

In your ISIS Xpress 5 codebase, replace the UnlockRuntime method with calls to the SetSolutionName and SetSolutionKey methods.

C# Copy Code
 ISISXpress1.Licensing.SetSolutionName("YourSolutionName");
 ISISXpress1.Licensing.SetSolutionKey(12345,12345,12345,12345);
VB.NET Copy Code
 ISISXpress1.Licensing.SetSolutionName("YourSolutionName")
 ISISXpress1.Licensing.SetSolutionKey(12345,12345,12345,12345)

Upgrading to Manually Reported Runtime Licensing

In your ISIS Xpress 4 codebase, find any existing calls to the UnlockRuntime method.

C# Copy Code
 ISISXpress1.Licensing.UnlockRuntime(12345,12345,12345,12345);
VB.NET Copy Code
 ISISXpress1.Licensing.UnlockRuntime(12345,12345,12345,12345)

In your ISIS Xpress 5 codebase, replace the UnlockRuntime method with calls to the SetSolutionName, SetSolutionKey, and SetOEMLicenseKey methods.

C# Copy Code
 ISISXpress1.Licensing.SetSolutionName("YourSolutionName");
 ISISXpress1.Licensing.SetSolutionKey(12345,12345,12345,12345);
 ISISXpress1.Licensing.SetOEMLicenseKey("1.0.AStringForOEMLicensing…");
VB.NET Copy Code
 ISISXpress1.Licensing.SetSolutionName("YourSolutionName")
 ISISXpress1.Licensing.SetSolutionKey(12345,12345,12345,12345)
 ISISXpress1.Licensing.SetOEMLicenseKey("1.0.AStringForOEMLicensing…")

There is no longer a separate method for web licensing. That functionality has been integrated into the SetOEMLicenseKey method.

If you encounter any porting issues, please contact support@accusoft.com for assistance.


%%ItemTitle%%

Licensing
See Also Send Feedback
ISIS Xpress 5 for .NET - User Guide > Licensing

Glossary Item Box

Accusoft has introduced a new licensing structure, which provides the following benefits:

  • Toolkit Licensing (also known as Developer or SDK licensing) has been simplified, no longer requiring manual entry of license registration codes.
  • Runtime Licensing (also known as Deployment licensing) has been made more flexible, enabling support for a number of different deployment scenarios.

During evaluation of Accusoft products, Evaluation Toolkit licenses can be used to try out products. However, the product behavior is limited by trial dialog pop-ups, timeouts, or evaluation watermarks.

Accusoft requires customers to purchase licenses for both development and deployment.

  • Development/Toolkit Licensing: When you determine the product is a good fit, you can purchase a Toolkit license to eliminate trial dialog pop-ups, timeouts, and evaluation watermarks while you develop your application.
  • Deployment/Runtime Licensing: Once you have an application that is ready for distribution, you have several options for deployment. Your own deployment scenario will dictate which option is the most appropriate. There are also cost considerations for each licensing model; see the product's "pricing" page or speak with an Accusoft Sales Representative (sales@accusoft.com) for more information.
    • Manually Reported Runtime Licensing: In this model, you embed all of the licensing information directly into your application. You must manually provide royalty reporting to Accusoft for the actual licenses deployed. This model will be the best choice for you if you are not connected to the Internet at runtime, as might be the case in an defense or financial application.
    • Automatically Reported Runtime Licensing using the Server Licensing Utility (SLU): In this model, you run a small GUI tool one time on each deployment target to configure licensing. This model will be the best choice for you if you handle the deployments yourself.
    • Automatically Reported Runtime Licensing using the Licensing Development Kit (LDK): In this model, you embed function calls into your application that perform the license verification at runtime. This model will be the best choice for you if you wish to hide licensing from your end users.

See Also

Licensing Glossary


%%ItemTitle%%

Evaluation Licensing
Send Feedback
ISIS Xpress 5 for .NET - User Guide > Licensing > Evaluation Licensing

Glossary Item Box

During evaluation of Accusoft products, Evaluation Toolkit licenses can be used to try out products. However, the product behavior is limited by trial dialog pop-ups, timeouts, or evaluation watermarks. When you determine the product is a good fit, you can purchase a Toolkit license to eliminate trial dialog pop-ups, timeouts, and evaluation watermarks.

An evaluation dialog similar to the following is displayed when you have a valid evaluation license.

However, if you attempt to execute a function that is not licensed in the edition license you are using (e.g., if you have a paid license for ImagXpress Standard and attempt to execute a function available only in ImagXpress Professional), an evaluation dialog similar to the following is displayed.

If no license is found in the registry, a dialog similar to the following will be displayed.


%%ItemTitle%%

Toolkit Licensing
Send Feedback
ISIS Xpress 5 for .NET - User Guide > Licensing > Toolkit Licensing

Glossary Item Box

Accusoft requires customers who are developing code that uses Accusoft components to have a Toolkit license for each developer.

This section provides information about the following:

  • Assigned Toolkit License
  • License Manager
  • Product Editions
  • Registration
    • Registering When Connected to the Internet
    • Registering When Disconnected from the Internet
  • Developing Code


%%ItemTitle%%

Assigned Toolkit License
Send Feedback
ISIS Xpress 5 for .NET - User Guide > Licensing > Toolkit Licensing > Assigned Toolkit License

Glossary Item Box

When licenses are purchased for developers at an organization, a representative is designated to assign the licenses to developers at the organization. Each developer must create an account on Accusoft’s website prior to the assignment of licenses. The organization’s designated representative may request that licenses be reassigned as a result of personnel changes.


%%ItemTitle%%

License Manager
Send Feedback
ISIS Xpress 5 for .NET - User Guide > Licensing > Toolkit Licensing > License Manager

Glossary Item Box

The License Manager is a GUI application that is used by a developer to register and activate Toolkit licenses on their development system. When a paid Toolkit license is registered, the License Manager:

  • Communicates the developer credentials and the hardware information for the development system to the licensing web service.
  • Installs the returned license key on that system.

Activation involves choosing a Toolkit license, either evaluation or paid, so that the license is active on the system.


%%ItemTitle%%

Product Editions
Send Feedback
ISIS Xpress 5 for .NET - User Guide > Licensing > Toolkit Licensing > Product Editions

Glossary Item Box

Accusoft products may have multiple editions, each of which supports different features. Products that support multiple editions are installed with multiple evaluation Toolkit licenses, one evaluation Toolkit license per edition.

Selecting An Edition (Activating a Toolkit License)

Evaluation licenses allow developers to try features in different product editions. Since each license supports only a single edition of a product, the developer can switch between editions by activating the corresponding Toolkit license, either purchased or evaluation, using the License Manager.

When a customer downloads an evaluation Toolkit, the evaluation Toolkit license for the edition with the most features is installed by default. However, the developer may run the License Manager to change the Toolkit license to a lower edition in order to determine if that edition will serve their needs.

If a customer has purchased multiple editions of the same product, they may install both editions on a development system, but only one edition may be active at a time. Once a license has been activated for a particular system, it may be deactivated (replaced by activating another edition) or reactivated at any time. Similarly, customers who own a lower featured edition may activate a higher featured edition evaluation Toolkit license and then switch back to their paid, lower-featured Toolkit edition license at any time. For example, you can go from a paid Standard edition to an evaluation Professional edition by activating the Professional edition evaluation Toolkit license.


%%ItemTitle%%

Registration
Send Feedback
ISIS Xpress 5 for .NET - User Guide > Licensing > Toolkit Licensing > Registration

Glossary Item Box

Registration is the process of creating a paid Toolkit license key for a particular system. Registration for Toolkit licenses is always done through the License Manager. This enables the features for the purchased edition to operate without nag dialogs or watermarks. Registration for each license is only required to be performed once per development system. After a license has been registered on a system, you can use the license without further interaction with the License Manager.

Also refer to the following sections:

  • Registering When Connected to the Internet
  • Registering When Disconnected from the Internet


%%ItemTitle%%

Registering When Connected to the Internet
Send Feedback
ISIS Xpress 5 for .NET - User Guide > Licensing > Toolkit Licensing > Registration > Registering When Connected to the Internet

Glossary Item Box

When the development system is connected to the Internet, registration is a fairly simple process.

  1. Start the License Manager.
  2. When prompted, enter your Accusoft login and password.

    The License Manager then displays the available evaluation and purchased licenses assigned to you.

  3. Select a toolkit and click the link to activate the license for that toolkit.

    The License Manager then requests a new license key from the licensing web service and installs it; this completes the registration process.

    If the selected license cannot be installed on the development system due to connection failures or other reasons, a temporary, 15 day "grace" license is installed so as not to interrupt development while a new license is obtained for the development system.


%%ItemTitle%%

Registering When Disconnected from the Internet
Send Feedback
ISIS Xpress 5 for .NET - User Guide > Licensing > Toolkit Licensing > Registration > Registering When Disconnected from the Internet

Glossary Item Box

When the development system is not connected to the Internet during registration, as is the case in some defense or financial institutions, registration is only slightly less simple.

  1. Run the License Manager and attempt to log in.
    The License Manager detects that the system is not registered and displays the following dialog:

  2. Select the Install Offline option to begin the offline registration process.

  3. Copy the URL to removable media, such as a thumb drive.

  4. Take the thumb drive to a system that is connected to the Internet.
  5. From the connected system, paste the URL into a browser, which automatically displays the toolkits available.
  6. Upon selecting a toolkit, a license is generated, which you then save to the removable media device.
  7. Return to the offline system where the new license is to be installed.
  8. Use the License Manager to browse to the file and install the Toolkit license.


%%ItemTitle%%

Developing Code
Send Feedback
ISIS Xpress 5 for .NET - User Guide > Licensing > Toolkit Licensing > Developing Code

Glossary Item Box

Once an evaluation or paid Toolkit license has been activated on the development system, no additional code is required to use the Accusoft products on this system. If moving the resulting executable code to a new system, you will need to install Toolkit licenses or incorporate Runtime licenses into your code.


%%ItemTitle%%

Runtime Licensing
Send Feedback
ISIS Xpress 5 for .NET - User Guide > Licensing > Runtime Licensing

Glossary Item Box

When an application that uses one or more Accusoft products is deployed, it requires a Runtime License for each installation. There are two main types of Runtime Licenses:

  • Automatically Reported. Distribution of Automatically Reported Runtime licenses is handled automatically through the use of licensing software components and web services.
  • Manually Reported. Manually Reported Runtime licensing requires you to provide the number of licenses distributed on a contractually agreed upon basis.

These licensing types are each described in detail in the following sections:

  • Automatically Reported Runtime (Node-Locked)
    • Licensing API
    • License Pools
    • License Configuration Files
    • LDK vs. SLU
      • Server Licensing Utility (SLU)
      • Licensing Development Kit (LDK)
    • Deployment Proxy Service (DPS)
  • Manually Reported Runtime (Non-Node-Locked)
    • Solution Name
    • Solution Key
    • OEM License Key
If you are upgrading from an earlier version of ISIS Xpress, please see the Upgrading Runtime Licensing section for important information.


%%ItemTitle%%

Automatically Reported Runtime (Node-Locked)
Send Feedback
ISIS Xpress 5 for .NET - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked)

Glossary Item Box

Automatically Reported Runtime licenses use a mechanism similar to Toolkit licensing to activate a license for a particular system. In this case, each installation has a unique license that is pulled from the pool of licenses purchased by the customer. When the license key is generated, it contains hardware information that identifies the system on which the license is to be installed.

The Licensing Development Kit component, which interacts with the licensing web service and installs the newly generated license key, may be used directly by the application or it may be used through a simple tool known as the Server Licensing Utility.

  • The Licensing Development Kit requires integration with the application or installation utility to perform license activation.
  • The Server Licensing Utility is a stand-alone application that integrates the Licensing Development Kit to perform the registration.

This topic provides information about the following:

  • Licensing API
  • License Pools
  • License Configuration Files
  • LDK vs. SLU
    • Server Licensing Utility (SLU)
    • Licensing Development Kit (LDK)
  • Deployment Proxy Service (DPS)


%%ItemTitle%%

Licensing API
Send Feedback
ISIS Xpress 5 for .NET - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > Licensing API

Glossary Item Box

The Licensing API is used in the developer’s code to specify Runtime Licensing deployment information. This is used to unlock the Accusoft products and enable all licensed features at runtime. Both the "Solution Name" and "Solution Key" values used in the API described below are provided by Accusoft, along with the License Configuration file, at the time of purchase of a Runtime License.

Solution Name

The solution name is the name assigned by Accusoft to the licenses purchased for runtime deployment. It is a character string that is set for a component prior to use in a deployment environment and is typically the name of the organization that purchased the runtime licenses. It is set via the SetSolutionName method of the component’s Licensing class. For example:

Copy Code
ISISXpress is = new ISISXpress();
is.Licensing.SetSolutionName("ACMEImaging");

The Solution Name must be set in order to use runtime licensing.

Solution Key

The Solution Key is a set of four numbers assigned when the licenses are purchased for runtime deployment; the Solution Key also identifies the organization that purchased the runtime licenses. The Solution Key is set via the SetSolutionKey method of the component’s Licensing class. For example:

Copy Code
ISISXpress is = new ISISXpress();
is.Licensing.SetSolutionName("ACMEImaging");
is.Licensing.SetSolutionKey(0x1C3A023F, 0xA018F260, 0x37AF0E51, 0x557F2389);

The Solution Key must be set in order to use runtime licensing.


%%ItemTitle%%

License Pools
Send Feedback
ISIS Xpress 5 for .NET - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > License Pools

Glossary Item Box

When Automatically Reported Runtime licenses are purchased, they are organized into pools of a specific version and platform for a particular toolkit. For example, if a customer developed two applications using ImagXpress, one using 32-bit ActiveX and the other using .NET, they would purchase two pools of runtime licenses, one for the ActiveX platform and one for the .NET platform. At installation, a new license would be pulled from the appropriate pool, depending upon which platform the application is using.


%%ItemTitle%%

License Configuration Files
See Also Send Feedback
ISIS Xpress 5 for .NET - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > License Configuration Files

Glossary Item Box

When an Automatically Reported Runtime license is purchased, a License Configuration file is created and distributed to the customer along with their assigned Solution Name and Solution Key. The License Configuration file contains information about the Runtime licenses for a particular platform and version of a toolkit. It is used by the Server Licensing Utility or License Development Kit to activate licenses when the customer’s application is installed on their users' systems.

See Also

Licensing API


%%ItemTitle%%

LDK vs. SLU
Send Feedback
ISIS Xpress 5 for .NET - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > LDK vs. SLU

Glossary Item Box

Both the Licensing Deployment Kit and the Server Licensing Utility perform the same function of registering the Runtime license for the system on which it will be run. Both are provided in order to give you some options.

  • If you are deploying to your own systems (e.g., for enterprise IT staff), the use of an Accusoft branded Server Licensing Utility may meet your needs. Similarly, if you handle the deployment onto end users systems, you may also find the Server Licensing Utility to be sufficient.
  • If you wish to hide this licensing registration from end users, you will likely choose the Licensing Deployment Kit, which allows you to integrate the registration process into your application. The Licensing Deployment Kit also allows for the optional assignment of Access Keys to specific users, which lets you manage your licenses more directly and limits the distribution of licenses.


%%ItemTitle%%

Server Licensing Utility (SLU)
Send Feedback
ISIS Xpress 5 for .NET - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > LDK vs. SLU > Server Licensing Utility (SLU)

Glossary Item Box

The Server Licensing Utility is a simple Windows application that uses License Configuration Files to request a license key from the purchased Runtime licenses. The Server Licensing Utility registers that Runtime license on the system where your application will be running. This utility can be used by developers for testing, by your deployment team, or by your end users to register their Runtime license.

In the Server Licensing Utility dialog, add your License Configuration file(s) as follows:

  1. Click Add and navigate to your License Configuration file(s).
  2. Select the appropriate License Configuration file(s) and click Open.
  3. After all applicable License Configuration files have been added, click Auto Register or Manually Register, depending on whether or not you are connected to the Internet. Refer to the sections below for more information.

Auto Register Toolkit (Connected to Internet)

Automatic registration works in much the same way as connected Toolkit registration and requires an Internet connection on the system where your application software will be deployed. The license information along with the system’s hardware information is sent over the Internet to the Accusoft licensing web service. If an unused license is available, a new license key containing information for the system is generated, returned, and is then automatically installed by the Server Licensing Utility.

Manually Register Toolkit (Disconnected from Internet)

Manual registration is used when the system where your application software will be deployed is not connected to the Internet and therefore cannot be registered automatically. This operation is similar to Disconnected Registration with the License Manager.

  1. Copy the Hardware Key and URL to a removable media device, such as a thumb drive, and then take it to a system that is connected to the Internet.
  2. From the connected system, paste the URL into a browser. A page will appear that contains a field into which you enter the hardware key.
  3. After this hardware key is entered, a license file with the license key is downloaded, which you then save to the removable media device.
  4. Return to the offline system with the removable media device onto which you have saved the license file.
  5. Click Open License File and navigate to the license file. Click OK in the file selection dialog.
    Alternatively, you can open the license file with a text editor, copy the license key to the clipboard, and click Paste License Key to paste the new license key into the License Key field.
  6. Click the License button; the new license will be installed.


%%ItemTitle%%

Licensing Development Kit (LDK)
Send Feedback
ISIS Xpress 5 for .NET - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > LDK vs. SLU > Licensing Development Kit (LDK)

Glossary Item Box

The Licensing Development Kit is an ActiveX component that may be used instead of the Server Licensing Utility. (Actually, the Server Licensing Utility is only a user interface for the Licensing Development Kit.) The Licensing Development Kit provides an interface for a developer to set the License Configuration File path and other properties as well as initiate requests to the licensing web service to generate license keys.

This topic contains these sections:

  • AccuLicClient.DLL
  • Assigned Access Keys
  • Automatic (Connected) Mode Registration
  • Manual (Disconnected) Mode Registration
  • Evaluation
  • Licensing Development Kit Interface
  • Licensing Development Kit Properties
  • Licensing Development Kit Methods

AccuLicClient.DLL

The AccuLicClient.DLL is located with the Server Licensing Utility. It is a 32-bit ActiveX/COM DLL which is used to execute runtime licensing activation functions. The bulk of the functionality provided by the Server Licensing Utility (SLU) is contained within the AccuLicClient.DLL and can be used within your own custom applications to achieve the same thing.

Assigned Access Keys

Unlike the Server Licensing Utility, the Licensing Development Kit allows for the optional assignment of Access Keys to specific users. By doing this, you can specify which of your licenses are assigned to your users. This also limits the distribution of licenses. When Runtime licenses are purchased, a list of Access Keys is distributed to you for this use.

Automatic (Connected) Mode Registration

This mode corresponds to the Automatic (Connected) Registration section described in the Server Licensing Utility section. The process is shown in the C# sample code below:

Copy Code
// Instantiate the LDK ActiveX component
IDeploymentComponent ldk = new DeploymentComponent();

// Set the path to the configuration file provided
// when the runtime licenses were purchased.
ldk.ConfigPath = @"C:\config.txt";

// Attempt to get the next available license.
// Note that you may alternately pass an Access Key
ldk.GetLicKeyAuto("");

if (ldk.ResultCode != enumLdkErrorCodes.LDK_SUCCESS)
{
    // Automatic Registration Failed - A temporary license
    // has been installed but will expire in 15 days.
    // TODO add code to notify user of issue and 15 day expiration.

    if (ldk.ResultCode == enumLdkErrorCodes.LDK_ERR_INET_CONN_BROKEN)
    {
        // No Internet Connection – Optionally do manual registration
    }
}
else
{
    // The license has been registered and installed.
}

The registration process is then complete. Note that if any part of the registration process fails, a temporary license key is installed and is typically valid for 15 days. During this time, you are allowed to use the product while resolving any licensing related problems.

Manual (Disconnected) Mode Registration

This mode corresponds to the Manual (Disconnected) Registration section described in the Server Licensing Utility section. The process is shown in the C# code below:

Copy Code
// Instantiate the LDK ActiveX component
IDeploymentComponent ldk = new DeploymentComponent();

// Set the path to the configuration file provided
// when the runtime licenses were purchased.
ldk.ConfigPath = @"C:\config.txt";

// Get the hardware key for the system.  Note
// that you may alternately pass an Access Key
string hardwareKey = ldk.GetHdwKey("");

// Write the hardware key to some type of removable media.
ApplicationSpecificMethodToWriteHardwareKey(hardwareKey);

At this point, you have the hardware key on some type of removable media. Take the media to a system that is connected to the Internet, acquire the license key by uploading the hardware key, write the new license key to the removable media, and then return to the disconnected system. The application then reads the license key from the removable media and installs the license key as shown below.

Copy Code
// After taking the hardware key to a system with an Internet
// connection and acquiring the license key string from the
// manual registration web site, read the key into your
// application.
string manuallyAcquiredLicenseKey = ApplicationSpecificMethodToReadLicenseKey();

// Install the license key
ldk.LicKey = manuallyAcquiredLicenseKey;

The manual license registration and installation is then complete. Note that like the automatic case above, if any error occurs during the setting of the license key, a temporary license is installed.

Evaluation

The Licensing Development Kit also has the ability to install an Evaluation License for purchased runtime products. This process is simply:

Copy Code
// Instantiate the LDK ActiveX component
IDeploymentComponent ldk = new DeploymentComponent();

// Set the path to the configuration file provided
// when the runtime licenses were purchased.
ldk.ConfigPath = @"C:\config.txt";

// Install an evaluation license
ldk.StartEvalPeriod();

Licensing Development Kit Interface

The interface to the Licensing Development Kit is shown below:

Copy Code
interface IDeploymentComponent : IDispatch
{
   [propget, id(1)] HRESULT LicKey([out, retval] BSTR* pVal);
   [propput, id(1)] HRESULT LicKey([in] BSTR newVal);
   [propget, id(2)] HRESULT srvURL([out, retval] BSTR* pVal);
   [propput, id(2)] HRESULT srvURL([in] BSTR newVal);
   [propget, id(3)] HRESULT ConfigPath([out, retval] BSTR* pVal);
   [propput, id(3)] HRESULT ConfigPath([in] BSTR newVal);
   [propget, id(4)] HRESULT ResultString([out, retval] BSTR* pVal);
   [propget, id(5)] HRESULT ResultCode([out, retval] enumLdkErrorCodes* pVal);
   [id(6)]           HRESULT GetLicKeyAuto([in] BSTR accKey);
   [id(7)]           HRESULT GetHdwKey([in] BSTR accKey, [out,retval] BSTR* hdwKey);
   [id(8)]           HRESULT StartEvalPeriod(void);
   [propget]         HRESULT LicenseInfo([out, retval] BSTR* pVal);
   [propput]         HRESULT LicenseInfo([in] BSTR newVal);
   [id(10)]          HRESULT GetEvalPeriod([out, retval] long* pVal);
};

Licensing Development Kit Properties

  • LicKey: Stores the License Key to the registry when it is set, and reads it from the registry during the get operation.
  • srvURL: Gets and sets the URL path to the licensing web service. The default is the URL path to Accusoft’s Deployment Licensing Service.
  • ConfigPath: Gets and sets a path to the deployment configuration file. Multiple products can be registered at one time by setting the filenames as a semicolon-delimited list: e.g., “c:\config.txt;c:\config2.txt”.
  • ResultString: Contains the string descriptions of any error that may have occurred during the last operation.
  • ResultCode: Can be used to contain any of the error codes described in Licensing Component Error Codes and Messages.
  • LicenseInfo: Used to transfer license information onto new system hardware. To transfer the license information into new system hardware, do the following:
  1. Get the LicenseInfo value and store it in a safe place.
  2. Change the system hardware.
  3. Set the LicenseInfo to the value you saved in step (1).
  4. Run the GetLicKeyAuto method (or perform its manual analog) to obtain a license for the new system hardware.

Licensing Development Kit Methods

  • GetLicKeyAuto: Obtains a License Key for the end user’s system using the automatic (or connected) scenario. It takes an Access Key as its input parameter, and stores the obtained license key in the registry. If you choose not to distribute individual Access Keys, the accKey argument should be an empty string.
  • GetHdwKey: Obtains a hardware key from the current machine and returns it (as hdwKey). If you choose not to distribute individual access keys, the accKey argument should be an empty string.
  • StartEvalPeriod: Sets an evaluation licensing mode for the product and starts an evaluation period. This method is provided so you can distribute an evaluation version of your application, without having to distribute Access Keys to people who would like to evaluate your software. Using this method you can license Accusoft components on the end user’s system for a limited time – the default is 30 days, but it can be customized per request to Accusoft. If the evaluators purchase your software, you can then issue them an access key using either the automatic or manual scenarios to obtain permanent component licenses, just as Accusoft does for its evaluators.
  • GetEvalPeriod: Obtains the remaining time on an evaluation (in days). It returns EvalPeriod < 0 if the evaluation period is expired.


%%ItemTitle%%

Deployment Proxy Service (DPS)
Send Feedback
ISIS Xpress 5 for .NET - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > Deployment Proxy Service (DPS)

Glossary Item Box

For systems where the deployed application will not have direct access to the Accusoft licensing web services, you can use the Deployment Proxy Service as a bridge to reroute the licensing communication. The Proxy Service will act as a trusted "go-between" for the Accusoft licensing system and the deployed application. This tool can be useful if the application will be deployed in a secured environment, where limited systems have external network access.

Additionally, the Proxy Service allows Accusoft customers to manage license registration more directly. The source for the Deployment Proxy Service is provided, allowing users to integrate the licensing process into their CRM, ERP, or other systems for tracking Automatically Reported Runtime Licenses.

For more information about the Deployment Proxy Service, please contact our Support team.


%%ItemTitle%%

Manually Reported Runtime (Non-Node-Locked)
Send Feedback
ISIS Xpress 5 for .NET - User Guide > Licensing > Runtime Licensing > Manually Reported Runtime (Non-Node-Locked)

Glossary Item Box

Manually Reported Runtime licensing embeds all of the licensing information directly into your application. Installation does not require any further licensing interaction. However, it is your responsibility to provide royalty reporting to Accusoft for the actual licenses deployed.

This section provides information about the following:

  • Solution Name
  • Solution Key
  • OEM License Key


%%ItemTitle%%

Solution Name
Send Feedback
ISIS Xpress 5 for .NET - User Guide > Licensing > Runtime Licensing > Manually Reported Runtime (Non-Node-Locked) > Solution Name

Glossary Item Box

The solution name is

  • A name assigned by Accusoft to the licenses purchased for runtime deployment.
  • A character string that is set for a component prior to use in a deployment environment
  • Typically the name of the organization that purchased the runtime licenses.
  • Set via the SetSolutionName method of the component’s Licensing class. For example:
Copy Code
ISISXpress is = new ISISXpress();
is.Licensing.SetSolutionName("ACMEImaging");

The Solution Name must be set in order to use runtime licensing.


%%ItemTitle%%

Solution Key
Send Feedback
ISIS Xpress 5 for .NET - User Guide > Licensing > Runtime Licensing > Manually Reported Runtime (Non-Node-Locked) > Solution Key

Glossary Item Box

The Solution Key is

  • A set of four numbers assigned when the licenses are purchased for runtime deployment.
  • An identifier of the organization that purchased the runtime licenses.
  • Set via the SetSolutionKey method of the component’s Licensing class. For example:
Copy Code
ISISXpress is = new ISISXpress();
is.Licensing.SetSolutionName("ACMEImaging");
is.Licensing.SetSolutionKey(0x1C3A023F, 0xA018F260, 0x37AF0E51, 0x557F2389);

The Solution Key must be set in order to use runtime licensing.


%%ItemTitle%%

OEM License Key
Send Feedback
ISIS Xpress 5 for .NET - User Guide > Licensing > Runtime Licensing > Manually Reported Runtime (Non-Node-Locked) > OEM License Key

Glossary Item Box

The OEMLicense Key is

  • For use only by customers who choose to use Manually Reported Runtime licensing.
  • A unique identifier of the customer, product, version, edition, and platforms for which the license is valid.

When this key is set via the SetOEMLicenseKey method of the component’s Licensing class, the component is completely licensed and can be distributed without any further licensing operations.

Copy Code
ISISXpress is = new ISISXpress();
is.Licensing.SetSolutionName("ACMEImaging");
is.Licensing.SetSolutionKey(0x1C3A023F, 0xA018F260, 0x37AF0E51, 0x557F2389);
is.Licensing.SetOEMLicenseKey("1.0.GQCC0EmUgONaI4QDZ32tpGWfpGW4gtbC0iIC0iN4bigYM3m3K5b487QOsAM38O24mUp5bOpD2O240OQ32U2YsUKDKA87MYPGgGgaptMiK5Nv8AI4mYg4m3QvW52DZCPGs4p784mtP4IUgOWiIG0AQYp4052iIAWvNCZfpGWC8vQ5P4ZGKaPAWfbiYfZOI303pOZAgisiNaWA27gGsf8Ob7Zvm5IaKGI4KC8GsG2CWYpGQAg5sUmYWvZCQANig48G2ap4bG0DsO240YsUmtptNiZamCPGbYMfMO83gANAZCN52YbY8U8f8DM4m3g7MYMYWGW5Q7QGWaMiN7MtZfmtgY8AN7NDP7Z4W7sCbGKUPa0im7EDPP");

This property is not required for Automatically Reported Runtime licensing.


%%ItemTitle%%

Licensing Glossary
Send Feedback
ISIS Xpress 5 for .NET - User Guide > Licensing > Licensing Glossary

Glossary Item Box

The following sections each describe a licensing term:

  • Access Key
  • Accusoft Products
  • Activation
  • Assigned Access Key
  • Automatically Reported Runtime Licensing
  • Customers, Developers, and Users
  • Edition
  • Evaluation License
  • Hardware Key
  • License Configuration File
  • Licensing Development Kit (LDK)
  • License Key
  • License Manager
  • Manually Reported Runtime Licensing
  • Node-Locked Licensing
  • Non-Node-Locked Licensing
  • Paid License
  • Registration
  • Runtime (Deployment) Licensing
  • Server Licensing Utility (SLU)
  • Toolkit Licensing
  • Web Services

Access Key

All licenses are assigned a unique identifier known as an Access Key. Access Keys are associated with the organization that purchased the license.

Accusoft Products

An Accusoft product may be licensed with either a Toolkit License or a Runtime License.

Activation

Activation is the process of selecting a previously registered toolkit license. Licenses may be paid (Toolkit) or evaluation, and may be for one of many product editions, for products with multiple editions.

Assigned Access Key

An assigned Access Key is one that is assigned to a specific user or users. The assignment of Access Keys to specific users can be done using the Licensing Development Kit (LDK).

Automatically Reported Runtime Licensing

Runtimes may be licensed in one of two ways: automatic reporting or manual reporting. With automatic reporting, you do not need to worry about royalty reporting; it is handled by the licensing layer.

Customers, Developers, and Users

Customers are simply any person who has purchased an Accusoft product. Developers are customers who possess a license for an Toolkit. Users are typically the customers of Accusoft's customers who use applications built around Accusoft components and are assigned a runtime license.

Edition

Some Accusoft products have multiple editions. Editions may offer multiple levels of product speed or product features, allowing customers to find a price-performance mix that is appropriate for them. Products that support multiple editions register multiple Toolkit licenses at installation time, one Toolkit license per edition. Developers must select an edition to activate using the License Manager.

Evaluation License

An evaluation license is a Toolkit license that is unpaid. When an Accusoft Toolkit is installed, evaluation licenses for all applicable product editions are installed and registered, and the edition with the most features is activated. Evaluation Toolkit licenses can be used to try out products. However, the product behavior is limited by trial dialog pop-ups, timeouts, or evaluation watermarks. When you determine the product is a good fit, you can purchase a Toolkit license to eliminate trial dialog pop-ups, timeouts, and evaluation watermarks.

Hardware Key

When a license is activated for a product, the system information that identifies the installation hardware is contained within an encrypted string and is used to generate the license key for the product. The string containing the encrypted hardware information is known as the Hardware Key.

License Configuration File

When a Toolkit or an Automatically Reported Runtime license is purchased, a configuration file is provided that contains information about the license that was purchased. This file is used by the licensing utilities (License Manager, Server License Utility, and License Development Kit) to install a license on the system.

Licensing Development Kit (LDK)

The Licensing Development Kit (LDK) is an ActiveX component that may be used for Runtime Licensing. The LDK is one mechanism for Automatically Reported Runtime Licensing; the Server Licensing Utility (SLU) is the other.

License Key

Each product license has a unique key associated with it that uniquely identifies the customer, product, version, edition, and platforms, and, in some cases, the hardware for which the license is valid.

License Manager

The License Manager is a GUI application that is used by a developer to register and activate Toolkit licenses on their development system.

Manually Reported Runtime Licensing

Runtimes may be licensed in one of two ways: automatic reporting or manual reporting. With Manually Reported Runtime Licensing, you embed all of the licensing information directly into your application. You must manually provide royalty reporting to Accusoft for the actual licenses deployed. This model will be the best choice for you if you are not connected to the Internet at runtime, as might be the case in an defense or financial application.

Node-Locked Licensing

Another name for Automatically Reported Runtime Licensing.

Non-Node-Locked Licensing

Another name for Manually Reported Runtime Licensing.

Paid License

A paid license is a Toolkit license that you have purchased from Accusoft. It is ready to be used in production, with no trial dialog pop-ups, timeouts, or evaluation watermarks. If you wish to test other editions of the Accusoft product for which you have purchased a Paid License, you may activate an Evaluation license for that edition; a complete set of Evaluation licenses for all editions is registered at installation time.

Registration

Registration is the process of informing the License Manager about a new Toolkit license you have purchased. It uses this information to create a license key on your system; this allows you to activate the product for development with no restrictions, such as trial dialog pop-ups, timeouts, or evaluation watermarks.

Runtime (Deployment) Licensing

When deploying an application, a Runtime License is also required for each user’s installation. You must purchase runtime licenses, which are consumed as licenses are registered. There are two Runtime licensing models: Automatically Reported Runtime License; and Manually Reported Runtime License.

Server Licensing Utility (SLU)

The Server Licensing Utility (SLU) is a small GUI application that allows you to request a license key from the Runtime licenses you have purchased. The SLU is one mechanism for Automatically Reported Runtime Licensing; the Licensing Development Kit (LDK) is the other.

Toolkit Licensing

Each Toolkit is assigned to a specific developer who has a registered account with Accusoft. When the developer installs the Toolkit, it is not fully functional until they have activated the license through the use of the License Manager application. When the developer starts the License Manager, they are required to provide login credentials that identify and allow them to activate their license on a development system. See Toolkit Licensing.

Web Services

When a license is registered, information that uniquely identifies the customer’s or user’s hardware is passed along with the license information over the Internet to a web service. The web service validates the licensing request, generates a key that includes the hardware information, and returns the new license key to the application that made the licensing request. The license key is then stored on the requested system and used by the component when it is executed. It is also possible to register systems that are not directly connected to the Internet through the use of removable media and a different system that is connected to the Internet.


%%ItemTitle%%

Software License Agreement
See Also Send Feedback
ISIS Xpress 5 for .NET - User Guide > Licensing > Software License Agreement

Glossary Item Box

PLEASE READ THE FOLLOWING SOFTWARE LICENSE AGREEMENT WHICH GOVERNS YOUR RIGHT TO USE OF THE TOOLKIT. YOU MUST ACCEPT THESE TERMS BEFORE YOU ARE ALLOWED TO INSTALL THE TOOLKIT. YOU EXPRESSLY AGREE THAT YOU HAVE THE AUTHORITY TO CONTRACTUALLY BIND THE ORGANIZATION AGREEING TO THESE TERMS.

BY CLICKING "I ACCEPT," OR INSTALLING TOOLKIT, OR PLACING TOOLKIT IN-USE, LICENSEE IS AGREEING TO BE BOUND BY THIS AGREEMENT.

1. GRANT OF AGREEMENT

This Accusoft Corporation, ("ACCUSOFT") Software License Agreement ("AGREEMENT") grants the organization contracting under this agreement as licensee ("LICENSEE") a limited, nontransferable, nonexclusive and non-assignable license to use the trial mode version of this ACCUSOFT Development Toolkit ("TOOLKIT") on a single computer for evaluation of fitness only and not for any commercial purpose; or to use a properly purchased and registered TOOLKIT, for development purposes only on a single computer, provided the TOOLKIT is IN-USE on only one computer at any time. (However additional TOOLKIT licenses may be purchased.) TOOLKIT is "IN-USE" on a computer when it becomes loaded by any means for any purpose into temporary memory (that is, including but not limited to RAM) or when it becomes copied or installed to less temporary storage by any means for any purpose (that is, including but not limited to hard disk, CD-ROM or other removable disk or tape, USB or other flash memory drive or card, or other local, networked, or cloud storage device) when it is accessible to that computer. The TOOLKIT is explicitly not to be used on a site-wide basis, via a server or other networked connection.

2. REDISTRIBUTION OF TOOLKIT RUNTIMES

ACCUSOFT does not grant LICENSEE any rights to deploy, license, sell, reproduce, copy, install, lease, timeshare, rent, or otherwise distribute or transfer TOOLKIT or any portion of TOOLKIT ("PORTION") except as provided in Section 1. GRANT OF AGREEMENT. For licensing information about any other distribution of TOOLKIT or PORTION, please visit our web site (www.accusoft.com/licensing.htm), or contact our sales staff. LICENSEE agrees to notify ACCUSOFT immediately of any violations or changes in status regarding LICENSEE's compliance with any term of this AGREEMENT.

In the event that ACCUSOFT grants LICENSEE in a written separate runtime license agreement ("RUNTIME AGREEMENT") a right to deploy, license, sell, reproduce, copy, install, lease, timeshare, rent, or otherwise distribute or transfer PORTIONS, the RUNTIME AGREEMENT will specify what PORTIONS may be distributed ("RUNTIME"). LICENSEE agrees to acknowledge and uphold the terms and conditions of this AGREEMENT as well as the terms of the RUNTIME AGREEMENT itself, which will be provided only in writing. In such event, LICENSEE may distribute RUNTIMES as part of the LICENSEE's software application or derivative works ("PRODUCT") upon additionally agreeing to the following:

a) LICENSEE understands and acknowledges that in order to receive any discounted pricing for RUNTIME distribution licensing fees based on the type of installation, it must either: 1) prepay for a number of RUNTIME licenses that is sufficient to qualify for ACCUSOFT's then-current published quantity discount, or 2) it must pay for the licenses in accordance with a written contract between LICENSEE and ACCUSOFT.

b) LICENSEE's PRODUCT shall not compete to any degree with the TOOLKIT. Such competitive PRODUCTS are defined as software development toolkits that include similar functionality as TOOLKIT and that are intended for use by software developers and/or system integrators.

c) LICENSEE's PRODUCT must be substantially greater in scope with greater functionality and features than those of the TOOLKIT.

d) LICENSEE will not use ACCUSOFT's name, logo, or trademarks to market PRODUCT without prior written approval of ACCUSOFT except LICENSEE will include a statement substantially similar to the following within PRODUCT documentation and about box: "Portions of this product contain imaging and other technology owned by Accusoft Corporation, Tampa, FL, (www.accusoft.com). ALL RIGHTS RESERVED." See Section 20. THIRD PARTY NOTICES for additional requirements.

e) LICENSEE agrees to only distribute the RUNTIMES. No license or other rights are granted to LICENSEE for any distribution of the TOOLKIT or PORTIONS including, but not limited to, documentation, source code, or the RUNTIME distribution unlock codes.

g) LICENSEE will only distribute the RUNTIMES on the hardware and operating system(s) for which the RUNTIMES are intended to be used according to the RUNTIME AGREEMENT.

If ANY of the terms of this AGREEMENT are not applicable to LICENSEE'S situation, or if any of the terms of this AGREEMENT cannot be complied with, or if LICENSEE needs modifications to this AGREEMENT or the license granted for any reason, LICENSEE must contact ACCUSOFT about obtaining an expanded license from ACCUSOFT (available by phone at: 813-875-7575, x321, by e-mail at: Sales@accusoft.com or by fax at: 813-875-7705).

This AGREEMENT grants rights to LICENSEE only for the TOOLKIT and does not convey any other rights of use or distribution to ACCUSOFT technology.

3. OWNERSHIP

LICENSEE acknowledges and agrees that ACCUSOFT owns all rights, title and interest in the TOOLKIT, in all forms, including without limitation any and all worldwide proprietary rights therein, including but not limited to trademarks, copyrights, patent rights, patent continuations, trade secrets and confidential information.

LICENSEE may not remove or alter the copyright notice from any copy of the TOOLKIT or any copy of the written materials, accompanying the TOOLKIT.

LICENSEE waives its right to contest any of ACCUSOFT's patents, trademarks, service marks, trade names, copyrights, and other intellectual property and proprietary rights in and to the TOOLKIT.

LICENSEE shall not use such trademarks, service marks, and trade names except where and as permitted under this AGREEMENT without receiving ACCUSOFT's prior written approval of such use. If such approval is granted, LICENSEE’s right to use such trademarks, service marks, and trade names shall end upon the termination of this AGREEMENT.

4. RESTRICTIONS AND RESERVATIONS.

All rights and licenses not expressly granted to LICENSEE are reserved to ACCUSOFT. LICENSEE is strictly prohibited from reproducing, copying, marketing, selling, distributing, licensing, sublicensing, leasing, timesharing or renting the TOOLKIT or PORTION, and LICENSEE is strictly prohibited from any use of the TOOLKIT or PORTION except as permitted by this AGREEMENT, and such actions are expressly prohibited. LICENSEE is strictly prohibited from incorporating or including the TOOLKIT or PORTION into or as part of any PRODUCT or service of LICENSEE except as provided by this AGREEMENT, regardless of the functionality of TOOLKIT (or lack thereof) within or as part of such PRODUCT or service of LICENSEE. LICENSEE shall not for any reason disassemble, decompile, decrypt or reverse engineer the TOOLKIT or PORTION or in any manner attempt to discover or reproduce the source code or any other copyrightable, proprietary, or trade secret aspect of the TOOLKIT or PORTION. Nor shall LICENSEE use the TOOLKIT or PORTION, directly or indirectly, in developing LICENSEE's own PRODUCT with, or including, similar functionality. LICENSEE shall not make any copies of the TOOLKIT or PORTION for any purpose whatsoever except as permitted by this AGREEMENT. Source code that is provided with TOOLKIT for sample or demonstration purposes may be used directly or indirectly in developing PRODUCT, however it may not be distributed in source form in whole or in part with or as part of PRODUCT.

5. WARRANTY DISCLAIMER

LICENSEE ACKNOWLEDGES AND AGREES THAT THE TOOLKIT IS PROVIDED "AS IS." ACCUSOFT DISCLAIMS ANY AND ALL REPRESENTATIONS AND WARRANTIES OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND AGAINST INFRINGEMENT.

6. LIMITATION OF LIABILITY

ACCUSOFT SHALL HAVE NO LIABILITY TO LICENSEE, LICENSEE AFFILIATES, SUBSIDIARIES, SHAREHOLDERS, OFFICERS, DIRECTORS, EMPLOYEES, REPRESENTATIVES OR ANY THIRD PARTY, WHETHER IN CONTRACT, TORT, NEGLIGENCE OR PRODUCTS LIABILITY, FOR ANY CLAIM, LOSS OR DAMAGE, INCLUDING BUT NOT LIMITED TO, LOST PROFITS, LOSS OF USE, BUSINESS INTERRUPTION, LOST DATA, LOST FILES, OR FOR ANY DIRECT, INDIRECT, SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES OF ANY KIND OR NATURE WHATSOEVER ARISING OUT OF OR IN CONNECTION WITH USE OF OR INABILITY TO USE THE TOOLKIT, OR THE PERFORMANCE OR OPERATION OF THE TOOLKIT, EVEN IF ACCUSOFT HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

7. INDEMNIFICATION BY LICENSEE

LICENSEE SHALL INDEMNIFY, HOLD HARMLESS AND DEFEND ACCUSOFT FOR ANY LOSS, CLAIM, ACTION OR PROCEEDING THAT ARISES OR RESULTS FROM ANY ACTIONS OR OMISSIONS OF LICENSEE PERTAINING TO THE PRODUCT OR THE TOOLKIT AND FROM ANY ACTIONS OF LICENSEE THAT ARE IN VIOLATION OF THIS AGREEMENT.

8. TERM AND TERMINATION

Unless otherwise agreed to by the parties, this AGREEMENT shall become effective upon the earlier of LICENSEE's clicking of "I Accept" or LICENSEE'S installing or placing TOOLKIT IN_USE ("Effective Date") and shall continue in full force and effect until terminated in accordance with the terms set forth in this AGREEMENT.

Any material breach of this AGREEMENT shall automatically and immediately terminate this AGREEMENT. In the event that LICENSEE ceases to do business or is adjudged bankrupt or insolvent, ACCUSOFT may, at its sole option, terminate this AGREEMENT, by giving ten (10) Business Days written notice of such termination, which notice shall identify and describe the basis for such termination.

In the event of any termination of this AGREEMENT, any RUNTIME AGREEMENT is simultaneously terminated and LICENSEE shall stop using the TOOLKIT and PORTION, shall cease manufacturing the PRODUCT containing TOOLKIT or PORTION, and shall cease distributing PRODUCT containing TOOLKIT or PORTION. LICENSEE shall also require its resellers, OEMs, and other distribution channels (if any) to likewise stop manufacturing and distributing the PRODUCT containing TOOLKIT or PORTION. Within ten (10) Business Days thereafter, LICENSEE shall return or, at ACCUSOFT's option, destroy, the TOOLKIT and all PORTIONS, whether or not incorporated in or with the PRODUCT, that are within LICENSEE’s possession, custody and control, and shall certify to ACCUSOFT in writing within ten (10) Business Days after that return or destruction that it has complied with the foregoing obligation.

All Sections except Section 1. GRANT OF LICENSE shall continue in full force and effect, notwithstanding any termination of this AGREEMENT.

9. LIQUIDATED DAMAGES

In the event LICENSEE (a) copies the TOOLKIT or PORTION except as permitted by this AGREEMENT, (b) uses the TOOLKIT or PORTION for any reason other than as permitted by this AGREEMENT, (c) installs or uses the TOOLKIT or PORTION on more than a single computer, or (d) otherwise violates or breaches this Agreement, LICENSEE agrees that ACCUSOFT is entitled to obtain as liquidated damages and not as a penalty the greater of the amount of (v) the published quantity one distribution price based upon the type of distribution, or (w) $99 per each user of each PRODUCT or service of LICENSEE in which the TOOLKIT or PORTION is included, copied, incorporated, embedded or accessible; (x) $100 per copy of TOOLKIT or PORTION; (y) $100 per copy of any PRODUCT in which TOOLKIT or PORTION is included, copied, incorporated, embedded or accessible; or (z) 3% of all revenues realized by LICENSEE pertaining to any PRODUCTS or services of LICENSEE in which TOOLKIT or PORTION is included, copied, incorporated, embedded or accessible. THE LICENSEE EXPRESSLY AGREES THAT THE FOREGOING LIQUIDATED DAMAGES ARE NOT A PENALTY.

10. CONFIDENTIALITY

LICENSEE acknowledges that the TOOLKIT contains ACCUSOFT know-how, confidential and trade secret information ("PROPRIETARY INFORMATION"). LICENSEE agrees: (a) to hold the PROPRIETARY INFORMATION in the strictest confidence, (b) not to, directly or indirectly, copy, reproduce, distribute, manufacture, duplicate, reveal, report, publish, disclose, cause to be disclosed, or otherwise transfer the PROPRIETARY INFORMATION to any third party, (c) not to make use of the PROPRIETARY INFORMATION other than as permitted by this AGREEMENT, and (d) to disclose the PROPRIETARY INFORMATION only to LICENSEE's representatives requiring such material for effective performance of this AGREEMENT and who have undertaken an obligation of confidentiality and limitation of use consistent with this AGREEMENT. This obligation shall continue as long as allowed under applicable law.

11. INJUNCTIVE RELIEF

LICENSEE agrees that any violation or threat of violation of this AGREEMENT will result in irreparable harm to ACCUSOFT for which damages would be an inadequate remedy. Therefore, in addition to its rights and remedies available at law (including but not limited to the recovery of damages for breach of this AGREEMENT), ACCUSOFT shall be entitled to immediate injunctive relief to prevent any violation of ACCUSOFT's copyright, trademark, trade secret rights regarding the TOOLKIT, or to prevent any violation of this AGREEMENT, including, but not limited to, unauthorized use, copying, distribution or disclosure of or regarding the TOOLKIT or PORTION, as well as any other equitable relief as the court may deem proper under the circumstances.

12. NO REDUCED PRICING

In any determination of ACCUSOFT's damages (whether liquidated damages or actual damages), or any determination of any licensing fees or royalties due ACCUSOFT under this AGREEMENT due to a breach by LICENSEE hereunder, LICENSEE shall not be entitled to any discounts (volume or otherwise) or reduced licensing fees or royalties. The foregoing sentence shall be applicable unless LICENSEE has negotiated and entered into a written, signed agreement with ACCUSOFT for such reduced or discounted licensing fees or royalties and paid ACCUSOFT such fees or royalties in advance of any: (a) distribution of the TOOLKIT or PORTION, (b) copying of the TOOLKIT or PORTION, or (c) incorporation or use of the TOOLKIT or PORTION in or pertaining to any PRODUCT or service of LICENSEE. Further, LICENSEE agrees that it shall not be entitled to reduced licensing fees or royalties when determining ACCUSOFT's damages due to any undertaking or activity by LICENSEE regarding the TOOLKIT or PORTION outside of or exceeding the scope of permission or other terms of this AGREEMENT, or LICENSEE's actions otherwise in violation of this AGREEMENT.

13. ATTORNEYS' FEES AND COSTS

In the event of any lawsuit or other proceeding brought as a result of any actual or alleged breach of this AGREEMENT, to enforce any provisions of this AGREEMENT, or to enforce any intellectual property or other rights in or pertaining to the TOOLKIT or PORTION, the prevailing party shall be entitled to an award of its reasonable attorneys’ fees and costs, including the costs of any expert witnesses, incurred at all levels of proceedings.

14. GOVERNING LAW

This AGREEMENT shall be construed, governed and enforced in accordance with the laws of the State of Florida, without regard to any conflicts of laws rules. Any action related to or arising out of this AGREEMENT will be filed only in the Florida courts and LICENSEE consents to the exclusive jurisdiction and venue of the state and federal courts located in Tampa, Florida.

15. SEVERABILITY

If any provision of this AGREEMENT is determined to be invalid by any court of final jurisdiction, then it shall be omitted and the remainder of the AGREEMENT shall continue to be binding and enforceable. In addition, the Court is hereby authorized to enforce any provision of the AGREEMENT that the Court otherwise deems unenforceable, to whatever lesser extent the Court deems reasonable and appropriate, rather than invalidating the entire provision. Without limiting the generality of the foregoing, LICENSEE expressly agrees that should LICENSEE be found to have breached the AGREEMENT, under no circumstances shall LICENSEE be entitled to any volume or other discount, or reduced licensing fee or royalty in the determination of ACCUSOFT's damages, or otherwise in the determination of any licensing fee or royalty owed to ACCUSOFT.

16. GOVERNMENT RIGHTS

The TOOLKIT and accompanying documentation have been developed at private expense and are sold commercially. They are provided under any U.S. government contracts or subcontracts with the most restricted and the most limited rights permitted by law and regulation. Whenever so permitted, the government and any intermediaries will obtain only those rights specified in ACCUSOFT's standard commercial license. Thus, the TOOLKIT referenced herein, and the documentation provided by Accusoft hereunder, which are provided to any agency of the U.S. Government or U.S. Government contractor or subcontractor at any tier shall be subject to the maximum restrictions on use as permitted by FAR 52.227-19 (June 1987) or DFARS 227.7202-3(a) (Jan. 1, 2000) or successor regulations. Manufacturer is Accusoft Corporation, 4001 N. Riverside Drive Tampa, FL 33603.

17. ENTIRE AGREEMENT

This AGREEMENT represents the entire understanding of the parties concerning the subject matter hereof and supersedes all prior communications and agreements, whether oral or written, relating to the subject matter of this AGREEMENT. Only a writing signed by the parties may modify this AGREEMENT. In the event of any modification in writing, of this AGREEMENT, including an expanded license agreement, all sections of this Agreement survive except Section 2. Limited License.

18. CONTACT US

Should you have any questions concerning this AGREEMENT, or if you desire to contact ACCUSOFT for any reason, please contact ACCUSOFT at 1-813-875-7575.

19. OTHER RESTRICTIONS

a) This AGREEMENT shall not be amended, altered, changed or modified in any way, unless agreed to in writing by both ACCUSOFT and LICENSEE. Such writing must be executed by a duly authorized representative of ACCUSOFT and a duly authorized representative of LICENSEE.

b) This AGREEMENT is not transferable or assignable by LICENSEE under any circumstances, without the prior written consent of ACCUSOFT. ACCUSOFT will not unreasonably withhold such consent. This AGREEMENT shall be binding upon, and is made for the benefit of, each party, its successors, and permitted assignees (if any). For the purposes of this AGREEMENT, any change in control of LICENSEE shall constitute an assignment or transfer of this AGREEMENT requiring prior written consent of ACCUSOFT. As used in this section, a change in control is defined as (i) any change in ownership of more than fifty percent (50%) of the voting interest in LICENSEE, whether by merger, purchase, foreclosure of a security interest or other transaction, or (ii) a sale of all or substantially all of the assets of LICENSEE.

c) The relationship established by this AGREEMENT between LICENSEE and ACCUSOFT shall be that of Licensee and Licensor. Nothing contained in this AGREEMENT shall be construed as creating a relationship of agency, joint venture or partnership between LICENSEE and ACCUSOFT. Neither party shall have any right whatsoever to incur any liabilities or obligations on behalf of the other party.

d) ACCUSOFT's failure to perform any term or condition of this AGREEMENT as a result of conditions beyond its control such as, but not limited to, war, strikes, fires, floods, acts of God, governmental restrictions, power failures, or damage or destruction of any network facilities or servers, shall not be deemed a breach of this AGREEMENT.

e) The headings provided in this AGREEMENT are for convenience and reference purposes only. In the event of a conflict between the terms and conditions listed in this AGREEMENT, and any attached Schedules or Appendices, the terms and conditions of this AGREEMENT shall govern.

f) A waiver of a breach, violation, or default under this AGREEMENT shall not be a waiver of any subsequent breach, violation or default. Failure of either party to enforce compliance with any term or condition of this AGREEMENT shall not constitute a waiver by the party of such term or condition.

g) All notices and communications shall be in writing and shall be deemed to have been duly given the earlier of when delivered or three (3) Business Days after mailing by certified mail, return receipt requested, postage prepaid, or by international delivery service, addressed to the parties at their respective addresses set forth on the Order Form or at such other addresses as the parties may designate by written notice in accordance with this section.

20. THIRD PARTY NOTICES

a) CAPTIVA ISIS TECHNOLOGY

ISIS functionality in the TOOLKIT is licensed to ACCUSOFT from Captiva Software, a division of EMC, Inc. The term "TOOLKIT" as defined in the Agreement includes technology from Captiva and related documentation, and any upgrades, modified versions, updates, additions, and copies thereof.

LIMITED WARRANTY

THE TERMS OF THIS AGREEMENT STATE THE SOLE AND EXCLUSIVE REMEDIES FOR ACCUSOFT'S BREACH OF WARRANTY. EXCEPT FOR THE FOREGOING LIMITED WARRANTY, CAPTIVA AND ITS SUPPLIERS MAKE NO WARRANTY, EXPRESS OR IMPLIED, AS TO MERCHANTABILITY, FITNESS FOR ANY PARTICULAR PURPOSE, OR NON-INFRINGEMENT. IN NO EVENT WILL CAPTIVA OR ITS SUPPLIERS BE LIABLE TO LICENSEE FOR ANY CONSEQUENTIAL, INCIDENTAL OR SPECIAL DAMAGES, INCLUDING ANY LOST PROFITS OR LOST SAVINGS, EVEN IF A CAPTIVA REPRESENTATIVE HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES, OR FOR ANY CLAIM BY ANY THIRD PARTY. Some states or jurisdictions do not allow the exclusion or limitation of incidental, consequential or special damages, or the exclusion of implied warranties, or limitations on how long an implied warranty may last, so the above limitations may not apply to LICENSEE. In such states/countries and to the extent permissible, any implied warranties are limited to thirty (30) days.

INTELLECTUAL PROPERTY

All ISIS technology is the intellectual property of Captiva and is protected under trademarks, registered trademarks, copyrights, and/or patents in the United States and/or other countries. ALL RIGHTS RESERVED.

Rev. 20120112

See Also

Distributing ISIS Xpress
Licensing


%%ItemTitle%%

Distributing Applications and Deployment
Send Feedback
ISIS Xpress 5 for .NET - User Guide > Distributing Applications and Deployment

Glossary Item Box

This section provides information about the following:

  • Verify You're Using the Latest Service Pack
  • Distributing ISIS Xpress


%%ItemTitle%%

Verify You're Using the Latest Service Pack
See Also Send Feedback
ISIS Xpress 5 for .NET - User Guide > Distributing Applications and Deployment > Verify You're Using the Latest Service Pack

Glossary Item Box

Service pack updates will not overwrite paid licensing. Your paid licensing will continue to work and you will not be required to re-enter your purchased registration codes. Service pack updates do not include any changes that might "break" previously developed and/or deployed code.

Verify Latest Development Components

To verify you are using the latest version of an Accusoft Development Component or Components, please refer to the currently released product build numbers at www.accusoft.com/latestbuilds.htm.

If you require further assistance or have questions or comments, please see the topic on Getting Support for more detailed information.

See Also

Getting Support
Installing on a Development Machine


%%ItemTitle%%

Distributing ISIS Xpress
See Also Send Feedback
ISIS Xpress 5 for .NET - User Guide > Distributing Applications and Deployment > Distributing ISIS Xpress

Glossary Item Box

ISIS Xpress 5 has a dependency on the C Runtime library, which must be distributed with your application in order for it to work properly. The Microsoft Visual C++ 2008 SP1 Redistributable Package (x86) can be downloaded from: http://www.microsoft.com/download/en/details.aspx?id=5582

There are a number of EMC Corporation's ISIS PixTools files that must be installed according to the target system. There is a EMC Corporation's ISIS PixTools PixTran subdirectory in the directory where ISIS Xpress was installed. The PixTran subdirectory contains two subdirectories that include all the necessary EMC Corporation's ISIS PixTools files. The directories are:

  • PixTran – Install these files to the target windows\pixtran directory.
  • Sysdir – Install these files to the target windows\system directory (windows\system32 if the target is WinNT, 2000, or XP).
The above files should be installed in the specified order.

DLL File to Distribute

The following file must be distributed with the application that uses the ISIS Xpress .NET control:

  • Accusoft.ISISXpress5.Net.dll

See Also

Getting Support
Installing on a Development Machine
Software License Agreement
Verify You're Using the Latest Service Pack
Licensing


%%ItemTitle%%

Concepts
Send Feedback
ISIS Xpress 5 for .NET - User Guide > Concepts

Glossary Item Box

This section provides information about the following:

  • Overview of ISIS Xpress
  • Glossary


%%ItemTitle%%

Overview of ISIS Xpress
Send Feedback
ISIS Xpress 5 for .NET - User Guide > Concepts > Overview of ISIS Xpress

Glossary Item Box

Basic Scanning

There are only a few steps required for basic scanning; initiating the ISIS Xpress control, creating the ISIS Xpress object, setting the output path and filename, and invoking the ScanSingle method.
IsisXpress isis = new IsisXpress();
isis.Output.Filename = "C:\temp\image.tif";
isis.Scanner.ScanSingle();

Scanner Settings

ISIS Xpress also provides properties for scanner settings and naming schemes for batch scanning.
All settings are accessed based on the value of the Setting.ScanSetting property. This property uses the ScanSettingInfo enumeration which has the following values:

XResolution = 0,
YResolution = 1,
PageSize = 2,
Brightness = 3,
Contrast = 4,
XPosition = 5,
YPosition = 6,
ImageWidth = 7,
ImageLength = 8,
ResUnit = 9,
Source = 10,
ScanAhead = 11,
ScanAheadMaxPages = 12,
ScanAheadPages = 13,
SamplesPerPixel = 14,
BitsPerSample = 15,
AdvancedTag =16

This property must be set before a scanner setting can be queried or set.
The following code could be used to set the scanner mode to 256-level gray scale.
isis.Scanner.Setting.ScanSetting = ScanSettingInfo.SamplesPerPixel;
isis.Scanner.Setting.Long = 1;
isis.Scanner.Setting.ScanSetting = ScanSettingInfo.BitsPerSample;
isis.Scanner.Setting.Long = 8;

The following code could be used to set the Brightness for the scanner.

isis.Scanner.Setting.ScanSetting = ScanSettingInfo.Brightness;
isis.Scanner.Setting.Long = 23;

Not all settings have an integer setting such as Brightness. The ScanSettingInfo.PageSize property is usually a string and must be set with the Setting.StringValue property. For Example:

isis.Scanner.Setting.ScanSetting = ScanSettingInfo.PageSize;
isis.Scanner.Setting.String = "scanner’s maximum";

The Setting.DataType property can be used to determine the setting type. This property uses the DataTypeInfo enumeration which has the following values.

RangeLong = 0,
ListLong = 1,
ListString = 2,
String = 3,
Long = 4,
Rational = 5,
ListRational = 6,
RangeRational = 7

Scanner settings can vary widely between different kinds of scanners. For this reason it is important to know what values are legal for a particular setting. ISIS® Xpress provides several properties to query the available choices for a setting.

If the Setting.DataType property equals RangeLong or RangeRational for a setting, then the following properties are used to determine what range of values is legal.

For Long values:

Setting.RangeMinimumLong
Setting.RangeMaximumLong

For Rational values:

Setting.RangeMinimumRational
Setting.RangeMaximumRational

Any value between and including the Min and Max values can be set to the Setting.LongValue or Setting.RationalValue property for this setting. A Long range of choices is the typical Setting.DataType for the following scanner settings:

ScanSettingInfo.Brightness
ScanSettingInfo.Contrast
ScanSettingInfo.XPosition
ScanSettingInfo.YPosition
ScanSettingInfo.ImageWidth
ScanSettingInfo.ImageLength
ScanSettingInfo.ScanAhead
ScanSettingInfo.ScanAheadMaxPages

If the Setting.DataType property equals DataTypeInfo.ListLong, DataTypeInfo.ListString, or DataTypeInfo.ListRational, then the possible values for the setting are contained in a list and can be queried with these properties:

Setting.ListLong
Setting.ListString
Setting.ListRational

Setting.ListLong, Setting.ListString, and Setting.ListRational are property arrays where the Index value can be from 0 to Setting.ListCount – 1. Setting.ListLong or Setting.ListString are the typical Setting.DataType for the following scanner settings:

ScanSettingInfo.XResolution
ScanSettingInfo.YResolution
ScanSettingInfo.PageSize

Advanced Tags

The component supports Advanced Tags, which offers developers great flexibility in utilizing scanner specific features. These are scanner processing instructions which are provided as parameters passed as tag values to the control, and consequently passed directly through to the scanner. Assuming the correct tags are passed to the scanner, they will instruct the scanner what actions to take.

The following methods and properties are used with advanced tags:

Methods:

LongDefault - Gets a long value at the specified index in the list of long values for the default scan setting.

RationalDefault - Gets a rational value at the specified index in the list of rational values for the default scan setting.

StringDefault - Gets a string value for the default scan setting.

Properties:

Advanced - Gets and sets the advanced tag number.

Batch Scanning

ISIS Xpress provides the Scanner.ScanBatch method for batch scanning. Scanners that have a document feeder will scan until the feeder is empty or until the Scanner.Cancel method is called. ISIS Xpress will generate a FeederEmpty event when the feeder is empty. ISIS Xpress also generates a Scanning and Scanned event for each page that is scanned. The Scanning event can be used to modify the filename before the scan takes place. Scanners without a document feeder trigger a FeederEmpty event before each page is scanned, allowing the user to cancel the operation.

After issuing the Scanner.ScanBatch method, ISIS Xpress will continue to scan images for the device until the StopScan parameter of the FeederEmpty event is set to true or the method Scanner.Cancel is called. The FeederEmpty event is the correct place to pop up a dialog or message box asking the user to load the scanner, cancel the operation, load a new batch, etc.

Naming Schemes

ISIS Xpress provides properties to generate filenames for use with batch scanning. The following properties are used:

Output.UseSchema
Output.Root
Output.Directory
Output.FileSchema

The Output.UseSchema property must be set to true before ISIS Xpress will generate filenames. Once set to true, the other properties are used to generate a file name. For example, if you want the filenames to be C:\Docs\File001.tif, C:\Docs\File002.tif, etc., these are the correct settings:

Output.Root = "File";
Output.Directory = "C:\Docs";
Output.FileSchema = "$###" ;

For the Output.FileSchema property, the "$" symbol represents the Output.Root, and the "#" represents the page number. The number of #’s used determines the number of leading 0’s to use in the filename. For example, "$##" generates File01.tif, while "$####" generates File0001.tif. Any extra $ symbols are ignored; "$###" is equivalent to "$$$###".

During batch scanning, a Scanning event is fired before each page is scanned. At this time the Output.Filename property will be equal to the filename used for that page. The user can change the Output.Filename property at this time if desired.

Memory Images

ISIS Xpress can generate a memory image at the time of scanning by setting the Output.CreateDib property to true. If this property is set to true, the image becomes valid in the Scanned event. The image can then be obtained using the ToHdib, ToHBitmap or ToBitmap methods and passed to another control such as Accusoft ImagXpress. It is possible to only use memory images by setting the image to true and the Output.CreateFiles property to false. In this case, nothing is saved to disk, only to memory. This can provide faster operation if you wish the user to be able to view and modify the image before saving. In such a case, you would pass the image to the ImagXpress control, and then the ImagXpress control would save the file after acceptance.

The image can only be read once per scan. Subsequent reads will throw a DibUnavailableException.

Dependencies

There are a number of EMC Corporation's ISIS PixTools files that must be installed according to the target system. There is a PixTran subdirectory in the directory where ISIS Xpress was installed. The PixTran subdirectory contains four subdirectories that include all the necessary EMC Corporation's ISIS PixTools files. The directories are:

PixTran – Install these files to the target windows\pixtran directory.
Sysdir – Install these files to the target windows\system directory (windows\system32 if the target is WinNT, 2000, or XP).

The above files should be installed in the specified order.


%%ItemTitle%%

Glossary
Send Feedback
ISIS Xpress 5 for .NET - User Guide > Concepts > Glossary

Glossary Item Box

A | B | C | D | E | F | G | H | I | J | K | L | M | N | O | P | Q | R | S | T | U | V | W | X | Y | Z

A

Aspect Ratio
There are two kinds of aspect ratio that you need to be aware of when working with 2D images; the image aspect ratio and the pixel aspect ratio.The image aspect ratio is the ratio of the width of the image to the height of the image. It's important when resizing an image to keep this ratio as close to unchanged as possible or the image may become distorted.The pixel aspect ratio is the shape of the pixels in the image. For computers this is normally square (1:1) or close to it depending on the monitor settings. For some video sources, however, the pixels may be slightly rectangular.

B

BMP
The Microsoft Windows Bitmap file format is based on the Microsoft Windows internal bitmap data structures. The BMP format is very widely used and it is quick and easy to read. Although most BMP files are uncompressed, a type of run length encoding is supported.

BPP
Bits per pixel.

C

CCITT
CCITT is the most widely used compression scheme for transmitting binary (black and white) image data. CCITT was established by the International Telegraph and Telephone Consultative Committee. The Group 3 and Group 4 CCITT compression standards are widely used for transmitting fax data. CCITT compressed images are typically stored in the TIFF image format.

D

DCX
An image format containing multiple PCX images. A DCX file can contain a maximum of 1024 images.

DDB
Microsoft Device Dependent Bitmap. The actual in-memory information used to display an image.

DIB
Microsoft Device Independent Bitmap. An alternative file extension used by the Microsoft Windows Bitmap.

DEP
Data Execution Prevention (computer security).

F

Float
Denotes a simple type that stores 32-bit floating-point values.

G

GIF
Graphical Interchange File, originally developed by CompuServe as a machine independent format. GIF is one of the most popular image formats for storing 8-bit digitized images. GIF files are typically smaller than uncompressed formats like BMP due to the LZW compression algorithm that GIF uses.

Grey-scale
If the pixels of a grey-scale image have N bits, they may take values from zero, representing black up to 2^N-1, representing white with intermediate values representing increasingly light shades of grey. If N=1, the image is not called grey-scale, but could be called monochrome.

H

Halftone
Pertaining to pictures in which gradation of tone in the photograph is reproduced by a graduated system of dotted and checkered spots, usually nearly invisible to the unaided eye, produced by the interposition between the camera and the object of a screen. The name alludes to the fact that this process was the first that was practically successful in reproducing the half tones of the photograph.

I

ICO
Microsoft Windows Icon file format.

Inverse
To reverse something or change it to its opposite. For example, to invert the colors on a monochrome display means to change light to dark and dark to light. In a digital electrical signal, to replace a high level by a low level and vice versa. This type of operation is the electronic equivalent of a Boolean NOT operation.

J

JIF
An alternative image file extension used for a JFIF compliant JPEG file. Because many early versions of JPEG contained a JPG extension but did not adhere to the JFIF specifications, the JIF extension was created to identify JPEG files that are JFIF compliant. As the popularity of JPEG grew, JFIF compliance became synonymous with the JPG extension and thus the JIF extension is rarely used.

JPEG
The JPEG (Joint Photographic Experts Group) standard is one of the most important image data compression standards. It is widely used in many industries including graphic arts, desktop publishing, medical imaging, and many more. It is also becoming one of the most widely used image formats on the Internet. Although JPEG supports a lossless mode, it most commonly uses lossy compression. This allows JPEG to achieve very high compression ratios. JPEG compression uses several compression modes. First, an image is transformed to the frequency domain using the discrete cosine transform. The smaller valued frequency components are discarded leaving only the larger valued components. The remaining components are DPCM coded and then Huffman coded. Fortunately, ImagXpress™ handles all of this for you! The compression level is adjustable. Higher quality settings produce a larger image file size with higher image quality. Lower quality settings produce a smaller image file size with lower image quality. Typically, we have found that compression ratios of 10:1 or 15:1 (A 640x480x24-bit image is 921,600 bytes; a 15:1 compressed image would compress to only 61k) produce generally acceptable image quality for photographic type images. Images compressed at higher ratios begin to show more noticeable and sometimes objectionable artifacts and clarity loss. JPEG is a 24-bit format and works only with 24-bit images. If you compress an 8-bit image, ImagXpress™ automatically converts it to 24-bit to do the compression, however, you will obtain better quality when the source image is 24-bit because 8-bit images only contain 256 colors. JPEG works best with photographic type images. It does not work well with solid colors, 16-color images, cartoon like images, or drawings. Progressive JPEG is a multiple-scan sequential JPEG format that is becoming popular on the Internet for the ability to display images in progressively clearer segments.

L

LZW
Lempel-Ziv-Welch (algorithm).

Little-endian
Describes a computer architecture in which, within a given 16- or 32-bit word, bytes at lower addresses have lower significance (the word is stored "little-end-first"). The PDP-11/VAX families of computers, Intel microprocessors, plus a lot of communications and networking hardware are little-endian. The term is sometimes used to describe the ordering of units other than bytes; most often, bits within a byte.

Luminance
One of the 3 components of the HSL (Hue, Saturation and Luminance) color space. Luminance controls the overall brightness of an image.

P

PBM
Portable bitmap image format, a very simple uncompressed 1-bit (black and white) image format.

PGM
Portable Graymap image format. PGM is a very simple uncompressed 8-bit grayscale image format.

PNG
Portable Network Graphics (pronounced "ping") provides a portable, legally unencumbered (royalty-free), well-compressed, well-specified standard for lossless bitmapped image files. The initial motivation for developing PNG was to provide a royalty-free alternative to GIF. The design retains many of the features of GIF that make it an attractive format for transmission of images, such as lossless compression and progressive display capabilities. Additionally, it provides several advantages including 24-bit image support and generally better compression, although decompression is typically somewhat slower than GIF. PNG's success will be ultimately determined by its acceptability on the Internet. At the time of this writing, however, PNG has not been incorporated as part of the major Internet browsers.

PPM
Portable Pixmap image format, a very simple uncompressed 24-bit image format.

R

RLE
RLE stands for Run Length Encoding. It is a lossless algorithm that only offers decent compression ratios in specific types of data.

RGB
Red Green Blue. Bitmapped images are most generally stored as RGB data. Each pixel or data point in a true color (24-bit) image contains 3 components, red, green and blue, that describe the color of the pixel. Each of the components can have a value between 0 and 255, 0 being the darkest shade of color and 255 being the lightest shade of color. Since each component can be stored in one byte (8-bits), the 3 components take up 3 bytes or 24-bits per pixel. 8-bit images contain one byte (8-bit) indexes for each pixel that map to a color table called a palette which contains a maximum of 256 RGB entries. Likewise, 4-bit images contain 4-bit indexes for each pixel that map to a palette which contains a maximum of 16 RGB entries. 1-bit images contain 1-bit per pixel. Each bit in a 1-bit image represents either black or white.

T

twip
Twips describe the sizes of characters produced by dot matrix printers, which were constrained to multiples of either 12 or 10 dots per inch.

TGA
Targa Image File) format was developed by TrueVision for its Targa line of products. TGA is one of the earliest image formats and was the first popular format to support 24-bit color. TGA supports uncompressed and RLE compressed formats.

TIFF
Tag Image File Format, originally released by Aldus Corporation is a standard file format found in most paint, imaging, and desktop publishing programs. TIFF is extremely powerful, flexible, and extensible. However, because of its many nuances and its wide scope, TIFF can be a difficult format to understand as well as a difficult format to support. ImagXpress™ supports a wide range of TIFF 6.0 formats including uncompressed, CCITT RLE, CCITT Group 3 Fax, CCITT Group 4 Fax, LZW, Pack Bits, JPEG, and deflate compression types. ImagXpress™ supports black and white, RGB, and RGB palette images but it does not support transparency mask, CMYK, YCbCr, or CIELab.

W

WMF
The Microsoft Windows Metafile format is used to store vector and bitmap image data. Because of its popularity and wide use, many Windows and non-Windows applications support WMF.

Wintel
A term describing the combination of Microsoft Windows operating system running on PCs with Intel or compatible processors. Dominance of the wintel platform began with MS-DOS on PCs with Intel's 8-bit 8088 processors in 1979.


%%ItemTitle%%

How To
Send Feedback
ISIS Xpress 5 for .NET - User Guide > How To

Glossary Item Box

This section provides information about how to perform specific tasks within ISIS Xpress.


%%ItemTitle%%

How To Pass Image Data Between Different Accusoft Components
See Also Send Feedback
ISIS Xpress 5 for .NET - User Guide > How To > How To Pass Image Data Between Different Accusoft Components

Glossary Item Box

Traditionally, transferring image data between Accusoft components has required passing the image data in a DIB format. But, beginning with the release of ImagXpress 11, we are adding new methods throughout our products which allow you to easily copy or transfer image data between different Accusoft objects with just a single method call.

Regardless of its product or component assembly, any Accusoft image class which supports easily sending its image data to another Accusoft object will implement two methods: CopyTo(object destination) and TransferTo(object destination). And any Accusoft image class which supports easily receiving this image data (that is, being the destination object) will be noted in its class documentation.

A CopyTo method makes a complete copy of the image data. When called, both the source and destination objects will contain their own separate copies of identical image data. A TransferTo method, on the other hand, completely transfers the image data from one object to another. When finished, the source object will no longer contain image data; the image will be owned by the destination object.

Within the ImagXpress Suite

Within the ImagXpress suite of components, there are four classes which support sending their image data via CopyTo and TransferTo methods:

  1. ImagXpress - Accusoft.ImagXpressSdk.ImageX
  2. TwainPRO - Accusoft.TwainProSdk.ScannedImage
  3. ISIS Xpress - Accusoft.ISISXpressSdk.Output
  4. ThumbnailXpress - Accusoft.ThumbnailXpressSdk.ThumbnailItem

And within the ImagXpress suite of components, there is only one class which supports receiving image data: the ImagXpress ImageX class.

Other Accusoft products may contain additional classes which can send and receive image data.

How to Transfer Image Data from ISIS Xpress to ImagXpress

Here's an example that scans an image with ISIS Xpress and then transfers the image data to ImagXpress for further processing before being saved.

C# Example Copy Code
using Accusoft.ImagXpressSdk; using Accusoft.ISISXpressSdk;

namespace ConsoleExample
{
    class Program
    {
        static IsisXpress isis;
        static void Main(string[] args)
        {
            isis = new IsisXpress();
            isis.Scanned += new IsisXpress.ScannedEventHandler(isis_Scanned);

            isis.Output.CreateFiles = false;
            isis.Output.CreateDib = true;
            isis.Scanner.Select();
            isis.Scanner.ScanSingle();
        }

        static void isis_Scanned(object sender, ScannedEventArgs e)
        {
            using (ImagXpress ix = new ImagXpress())
            using (ImageX image = new ImageX(ix))
            using (Processor processor = new Processor(ix))
            {
                //Transfer the scanned image data from ISIS Xpress to ImagXpress
                isis.Output.TransferTo(image);

                //Process and save the image with ImagXpress
                processor.Image = image;
                processor.Negate();
                image.Save("inverted-scan.bmp");
            }
        }
    }
}

In the above example, we transfer the scanned image to an ImagXpress ImageX object named image. Once that is done, we can use any of the processing features of ImagXpress to manipulate the scanned image data. In this case we simply create a color negative of the image data and then save it to disk as "inverted-scan.bmp".

See Also

CopyTo Method
TransferTo Method


%%ItemTitle%%

ISIS Xpress 5 for .NET - API Reference
Send Feedback

Glossary Item Box

This API Reference provides detailed information about all ISIS Xpress public API members.


%%phrase%%

Accusoft.ISISXpress5.Net Assembly
See Also Send Feedback

Glossary Item Box

Namespaces

Namespace | Description
Accusoft.ISISXpressSdk |


$$GETTING_STARTED$$ - %%projecttitle%%

Getting Started
Send Feedback

Glossary Item Box


$$INTRODUCTION$$ - %%projecttitle%%

Introduction
Send Feedback

Glossary Item Box


%%ItemTitle%%

Accusoft.ISISXpressSdk Namespace
See Also Inheritance Hierarchy Send Feedback

Glossary Item Box

Classes

 | Class | Description
Class | CancelException | This class implements the CancelExceptions to throw when a cancel is performed.
Class | ConfigFileException | This class implements the ConfigFileExceptions to throw when there is a problem with the configuration file.
Class | DibUnavailableException | This class implements the DibUnavailableExceptions to throw when the DIB (Device Independent Bitmap) is not available.
Class | DriverAndScanner | This class is the element type of the DriverAndScannerList class. It holds a DriverName and ScannerModel available for use in ISISXpress.
Class | DriverAndScannerList | This class implements a list of available ISIS drivers and scanner models.
Class | FeederEmptyEventArgs | This class implements the event arguments for the IsisXpress.FeederEmpty event.
Class | GeneralIsisException | This class implements the GeneralIsisExceptions thrown when there is a general ISIS issue.
Class | InvalidLicenseException | This class implements the InvalidLicenseExceptions thrown when the license key is invalid.
Class | InvalidSchemaException | This class implements the InvalidSchemaExceptions when the filename schema is invalid.
Class | InvalidSettingException | This class implements the InvalidSettingExceptions when there is an invalid scanner setting.
Class | IsisDriverException | This class implements ISIS driver exceptions.
Class | IsisXpress | This class is the main controller for the ISIS Xpress component.
Class | IsisXpressLibraryException | This class implements application exceptions.
Class | Licensing | This class implements the licensing for the ISIS Xpress component.
Class | OutOfMemoryException | This class implements the OutOfMemoryExceptions to be thrown when there is not enough memory available.
Class | OutOfRangeException | This class implements the OutOfRangeExceptions when a parameter or index is out of range.
Class | Output | This class implemented how scanned images are saved.
Class | ProgressEventArgs | This class implements the event arguments for the IsisXpress.Progress event.
Class | RationalType | This class implements a rational number with the numerator and denominator stored in their normal form.
Class | SaveTypeException | This class implements the SaveTypeExceptions to throw when there is a problem with the save type.
Class | ScannedEventArgs | This class implements the event arguments for the IsisXpress.Scanned event.
Class | Scanner | This class implements the specific Scanner settings, methods and properties.
Class | ScannerLoadedException | This class implements the ScannerLoadedExceptions.
Class | ScanningEventArgs | This class implements the event arguments for the IsisXpress.Scanning event.
Class | SequenceException | This class implements the SequenceExceptions to throw when there is a sequence problem.
Class | Setting | This class implements the scanner settings.
Class | SettingUnavailableException | This class implements the SettingUnavailableException to throw when the setting is not available.
Class | StringTooLongException | This class implements the StringToolLongExceptions when the string is too long.

Delegates

 | Delegate | Description
Delegate | IsisXpress.FeederEmptyEventHandler | Indicates that the scanner feeder is empty.
Delegate | IsisXpress.ProgressEventHandler | Indicates how much of the scan has completed. If the Scanner.UseCompression property is true then the Progress event is not fired during the scan.
Delegate | IsisXpress.ScannedEventHandler | Fired after a scan to allow the user to check or set the Output.ToHdib property.
Delegate | IsisXpress.ScanningEventHandler | Fired before a scan to allow the user to check or modify the Output.Filename property.

Enumerations

 | Enumeration | Description
Enumeration | DataTypeInfo | Option values for the data type the information is encoded in for the current scanner setting.
Enumeration | ErrorLevelInfo | Option values to set the error level to use.
Enumeration | EvaluationChoice | Option values for licensing the evaluation version within the component.
Enumeration | FileTypeInfo | Option values for the file format to use when saving images.
Enumeration | ScanAhead | Option values for determining the scan ahead settings.
Enumeration | ScanSettingInfo | Option values for determining which scanner setting to query or set.
Enumeration | SetupOptions | Option values to modify what is displayed by the predefined scanner settings dialog.
Enumeration | Source | Option values to set the scanning source information.

See Also

Reference

Accusoft.ISISXpress5.Net Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Accusoft.ISISXpressSdk Namespace Inheritance Hierarchy
See Also Send Feedback

Glossary Item Box

Inheritance Hierarchy

System.Object
Accusoft.ISISXpressSdk.DriverAndScanner
Accusoft.ISISXpressSdk.Licensing
Accusoft.ISISXpressSdk.Output
Accusoft.ISISXpressSdk.RationalType
Accusoft.ISISXpressSdk.Scanner
Accusoft.ISISXpressSdk.Setting
System.ApplicationException
System.Exception
Accusoft.ISISXpressSdk.IsisXpressLibraryException
Accusoft.ISISXpressSdk.CancelException
Accusoft.ISISXpressSdk.ConfigFileException
Accusoft.ISISXpressSdk.DibUnavailableException
Accusoft.ISISXpressSdk.GeneralIsisException
Accusoft.ISISXpressSdk.InvalidLicenseException
Accusoft.ISISXpressSdk.InvalidSchemaException
Accusoft.ISISXpressSdk.InvalidSettingException
Accusoft.ISISXpressSdk.IsisDriverException
Accusoft.ISISXpressSdk.OutOfMemoryException
Accusoft.ISISXpressSdk.OutOfRangeException
Accusoft.ISISXpressSdk.SaveTypeException
Accusoft.ISISXpressSdk.ScannerLoadedException
Accusoft.ISISXpressSdk.SequenceException
Accusoft.ISISXpressSdk.SettingUnavailableException
Accusoft.ISISXpressSdk.StringTooLongException
System.Collections.Generic.List<T>
Accusoft.ISISXpressSdk.DriverAndScannerList
System.ComponentModel.Component
System.MarshalByRefObject
Accusoft.ISISXpressSdk.IsisXpress
System.EventArgs
Accusoft.ISISXpressSdk.FeederEmptyEventArgs
Accusoft.ISISXpressSdk.ProgressEventArgs
Accusoft.ISISXpressSdk.ScannedEventArgs
Accusoft.ISISXpressSdk.ScanningEventArgs

See Also

Reference

Accusoft.ISISXpress5.Net Assembly


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
CancelException Class
Members See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : CancelException Class

Glossary Item Box

This class implements the CancelExceptions to throw when a cancel is performed.

Object Model

CancelException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class CancelException
   Inherits IsisXpressLibraryException
'Usage

Dim instance As CancelException
[SerializableAttribute()]
public sealed class CancelException : IsisXpressLibraryException
[SerializableAttribute()]
public __gc __sealed class CancelException : public IsisXpressLibraryException
[SerializableAttribute()]
public ref class CancelException sealed : public IsisXpressLibraryException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.ISISXpressSdk.IsisXpressLibraryException
Accusoft.ISISXpressSdk.CancelException

See Also

Reference

CancelException Members
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.ISISXpress5.Net
CancelException Class Members
See Also Properties Methods Send Feedback
Accusoft.ISISXpressSdk Namespace : CancelException Class

Glossary Item Box

The following tables list the members exposed by CancelException.

Public Constructors

 | Name | Description
Public Constructor | CancelException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the number or ID of the specific error that occurred. (Inherited from Accusoft.ISISXpressSdk.IsisXpressLibraryException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

CancelException Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.ISISXpress5.Net
CancelException Class Methods
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : CancelException Class

Glossary Item Box

For a list of all members of this type, see CancelException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

CancelException Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.ISISXpress5.Net
CancelException Class Properties
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : CancelException Class

Glossary Item Box

For a list of all members of this type, see CancelException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the number or ID of the specific error that occurred. (Inherited from Accusoft.ISISXpressSdk.IsisXpressLibraryException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Top

See Also

Reference

CancelException Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
CancelException Constructor
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > CancelException Class : CancelException Constructor

Glossary Item Box

Overload List

Overload | Description
CancelException Constructor() | The main constructor for the CancelException class to throw when a cancel is performed.
CancelException Constructor(Int32) | A CancelException which allows passing in an error number.
CancelException Constructor(String) | A CancelException which allows passing in an error message.
CancelException Constructor(Int32,String) | A CancelException which allows passing in an error number and an error message.
CancelException Constructor(String,Exception) | A CancelException which allows passing in an error message and an inner exception.

See Also

Reference

CancelException Class
CancelException Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
CancelException Constructor()
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > CancelException Class > CancelException Constructor : CancelException Constructor()

Glossary Item Box

The main constructor for the CancelException class to throw when a cancel is performed.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New CancelException()
public CancelException()
public: CancelException();
public:
CancelException();

See Also

Reference

CancelException Class
CancelException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
CancelException Constructor(Int32)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > CancelException Class > CancelException Constructor : CancelException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

A CancelException which allows passing in an error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New CancelException(errorNumber)
public CancelException(
   int errorNumber
)
public: CancelException(
   int errorNumber
)
public:
CancelException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

CancelException Class
CancelException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
CancelException Constructor(String)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > CancelException Class > CancelException Constructor : CancelException Constructor(String)

message
A string value which represents the error message.

Glossary Item Box

A CancelException which allows passing in an error message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New CancelException(message)
public CancelException(
   string message
)
public: CancelException(
   string* message
)
public:
CancelException(
   String^ message
)

Parameters

message
A string value which represents the error message.

See Also

Reference

CancelException Class
CancelException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
CancelException Constructor(Int32,String)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > CancelException Class > CancelException Constructor : CancelException Constructor(Int32,String)

errorNumber
An integer which represents the error number.
message
A string value which represents the error message.

Glossary Item Box

A CancelException which allows passing in an error number and an error message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New CancelException(errorNumber, message)
public CancelException(
   int errorNumber,
   string message
)
public: CancelException(
   int errorNumber,
   string* message
)
public:
CancelException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer which represents the error number.
message
A string value which represents the error message.

See Also

Reference

CancelException Class
CancelException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
CancelException Constructor(String,Exception)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > CancelException Class > CancelException Constructor : CancelException Constructor(String,Exception)

message
A string value which represents the error message.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

Glossary Item Box

A CancelException which allows passing in an error message and an inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New CancelException(message, innerException)
public CancelException(
   string message,
   Exception innerException
)
public: CancelException(
   string* message,
   Exception* innerException
)
public:
CancelException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string value which represents the error message.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

See Also

Reference

CancelException Class
CancelException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
ConfigFileException Class
Members See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : ConfigFileException Class

Glossary Item Box

This class implements the ConfigFileExceptions to throw when there is a problem with the configuration file.

Object Model

ConfigFileException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class ConfigFileException
   Inherits IsisXpressLibraryException
'Usage

Dim instance As ConfigFileException
[SerializableAttribute()]
public sealed class ConfigFileException : IsisXpressLibraryException
[SerializableAttribute()]
public __gc __sealed class ConfigFileException : public IsisXpressLibraryException
[SerializableAttribute()]
public ref class ConfigFileException sealed : public IsisXpressLibraryException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.ISISXpressSdk.IsisXpressLibraryException
Accusoft.ISISXpressSdk.ConfigFileException

See Also

Reference

ConfigFileException Members
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.ISISXpress5.Net
ConfigFileException Class Members
See Also Properties Methods Send Feedback
Accusoft.ISISXpressSdk Namespace : ConfigFileException Class

Glossary Item Box

The following tables list the members exposed by ConfigFileException.

Public Constructors

 | Name | Description
Public Constructor | ConfigFileException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the number or ID of the specific error that occurred. (Inherited from Accusoft.ISISXpressSdk.IsisXpressLibraryException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ConfigFileException Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.ISISXpress5.Net
ConfigFileException Class Methods
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : ConfigFileException Class

Glossary Item Box

For a list of all members of this type, see ConfigFileException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ConfigFileException Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.ISISXpress5.Net
ConfigFileException Class Properties
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : ConfigFileException Class

Glossary Item Box

For a list of all members of this type, see ConfigFileException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the number or ID of the specific error that occurred. (Inherited from Accusoft.ISISXpressSdk.IsisXpressLibraryException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Top

See Also

Reference

ConfigFileException Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
ConfigFileException Constructor
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > ConfigFileException Class : ConfigFileException Constructor

Glossary Item Box

Overload List

Overload | Description
ConfigFileException Constructor() | The main constructor for the ConfigFileException to throw when there is a problem with the configuration file.
ConfigFileException Constructor(Int32) | A ConfigFileException which allows passing in an error number.
ConfigFileException Constructor(String) | A ConfigFileException which allows passing in an error message.
ConfigFileException Constructor(Int32,String) | A ConfigFileException which allows passing in an error number and an error message.
ConfigFileException Constructor(String,Exception) | A ConfigFileException which allows passing in an error message and an inner exception.

See Also

Reference

ConfigFileException Class
ConfigFileException Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
ConfigFileException Constructor()
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > ConfigFileException Class > ConfigFileException Constructor : ConfigFileException Constructor()

Glossary Item Box

The main constructor for the ConfigFileException to throw when there is a problem with the configuration file.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ConfigFileException()
public ConfigFileException()
public: ConfigFileException();
public:
ConfigFileException();

See Also

Reference

ConfigFileException Class
ConfigFileException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
ConfigFileException Constructor(Int32)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > ConfigFileException Class > ConfigFileException Constructor : ConfigFileException Constructor(Int32)

errorNumber
An integer value which represents the error number.

Glossary Item Box

A ConfigFileException which allows passing in an error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New ConfigFileException(errorNumber)
public ConfigFileException(
   int errorNumber
)
public: ConfigFileException(
   int errorNumber
)
public:
ConfigFileException(
   int errorNumber
)

Parameters

errorNumber
An integer value which represents the error number.

See Also

Reference

ConfigFileException Class
ConfigFileException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
ConfigFileException Constructor(String)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > ConfigFileException Class > ConfigFileException Constructor : ConfigFileException Constructor(String)

message
A string value which represents an error message.

Glossary Item Box

A ConfigFileException which allows passing in an error message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New ConfigFileException(message)
public ConfigFileException(
   string message
)
public: ConfigFileException(
   string* message
)
public:
ConfigFileException(
   String^ message
)

Parameters

message
A string value which represents an error message.

See Also

Reference

ConfigFileException Class
ConfigFileException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
ConfigFileException Constructor(Int32,String)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > ConfigFileException Class > ConfigFileException Constructor : ConfigFileException Constructor(Int32,String)

errorNumber
An integer value which represents the error number.
message
A string value which represents the error message.

Glossary Item Box

A ConfigFileException which allows passing in an error number and an error message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New ConfigFileException(errorNumber, message)
public ConfigFileException(
   int errorNumber,
   string message
)
public: ConfigFileException(
   int errorNumber,
   string* message
)
public:
ConfigFileException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer value which represents the error number.
message
A string value which represents the error message.

See Also

Reference

ConfigFileException Class
ConfigFileException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
ConfigFileException Constructor(String,Exception)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > ConfigFileException Class > ConfigFileException Constructor : ConfigFileException Constructor(String,Exception)

message
A string value which represents the error message.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

Glossary Item Box

A ConfigFileException which allows passing in an error message and an inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New ConfigFileException(message, innerException)
public ConfigFileException(
   string message,
   Exception innerException
)
public: ConfigFileException(
   string* message,
   Exception* innerException
)
public:
ConfigFileException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string value which represents the error message.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

See Also

Reference

ConfigFileException Class
ConfigFileException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
DibUnavailableException Class
Members See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : DibUnavailableException Class

Glossary Item Box

This class implements the DibUnavailableExceptions to throw when the DIB (Device Independent Bitmap) is not available.

Object Model

DibUnavailableException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class DibUnavailableException
   Inherits IsisXpressLibraryException
'Usage

Dim instance As DibUnavailableException
[SerializableAttribute()]
public sealed class DibUnavailableException : IsisXpressLibraryException
[SerializableAttribute()]
public __gc __sealed class DibUnavailableException : public IsisXpressLibraryException
[SerializableAttribute()]
public ref class DibUnavailableException sealed : public IsisXpressLibraryException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.ISISXpressSdk.IsisXpressLibraryException
Accusoft.ISISXpressSdk.DibUnavailableException

See Also

Reference

DibUnavailableException Members
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.ISISXpress5.Net
DibUnavailableException Class Members
See Also Properties Methods Send Feedback
Accusoft.ISISXpressSdk Namespace : DibUnavailableException Class

Glossary Item Box

The following tables list the members exposed by DibUnavailableException.

Public Constructors

 | Name | Description
Public Constructor | DibUnavailableException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the number or ID of the specific error that occurred. (Inherited from Accusoft.ISISXpressSdk.IsisXpressLibraryException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

DibUnavailableException Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.ISISXpress5.Net
DibUnavailableException Class Methods
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : DibUnavailableException Class

Glossary Item Box

For a list of all members of this type, see DibUnavailableException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

DibUnavailableException Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.ISISXpress5.Net
DibUnavailableException Class Properties
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : DibUnavailableException Class

Glossary Item Box

For a list of all members of this type, see DibUnavailableException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the number or ID of the specific error that occurred. (Inherited from Accusoft.ISISXpressSdk.IsisXpressLibraryException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Top

See Also

Reference

DibUnavailableException Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
DibUnavailableException Constructor
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > DibUnavailableException Class : DibUnavailableException Constructor

Glossary Item Box

Overload List

Overload | Description
DibUnavailableException Constructor() | The main constructor for the DibUnavailableException class to throw when the DIB is unavailable.
DibUnavailableException Constructor(Int32) | A DibUnavailableException which allows passing in an error number.
DibUnavailableException Constructor(String) | A DibUnavailableException which allows passing in an error number.
DibUnavailableException Constructor(Int32,String) | A DibUnavailableException which allows passing in an error number and an error message.
DibUnavailableException Constructor(String,Exception) | A DibUnavailableException which allows passing in an error message and an inner exception.

See Also

Reference

DibUnavailableException Class
DibUnavailableException Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
DibUnavailableException Constructor()
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > DibUnavailableException Class > DibUnavailableException Constructor : DibUnavailableException Constructor()

Glossary Item Box

The main constructor for the DibUnavailableException class to throw when the DIB is unavailable.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New DibUnavailableException()
public DibUnavailableException()
public: DibUnavailableException();
public:
DibUnavailableException();

See Also

Reference

DibUnavailableException Class
DibUnavailableException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
DibUnavailableException Constructor(Int32)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > DibUnavailableException Class > DibUnavailableException Constructor : DibUnavailableException Constructor(Int32)

errorNumber
An integer value which represents the error number.

Glossary Item Box

A DibUnavailableException which allows passing in an error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New DibUnavailableException(errorNumber)
public DibUnavailableException(
   int errorNumber
)
public: DibUnavailableException(
   int errorNumber
)
public:
DibUnavailableException(
   int errorNumber
)

Parameters

errorNumber
An integer value which represents the error number.

See Also

Reference

DibUnavailableException Class
DibUnavailableException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
DibUnavailableException Constructor(String)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > DibUnavailableException Class > DibUnavailableException Constructor : DibUnavailableException Constructor(String)

message
A string value which represents the error message.

Glossary Item Box

A DibUnavailableException which allows passing in an error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New DibUnavailableException(message)
public DibUnavailableException(
   string message
)
public: DibUnavailableException(
   string* message
)
public:
DibUnavailableException(
   String^ message
)

Parameters

message
A string value which represents the error message.

See Also

Reference

DibUnavailableException Class
DibUnavailableException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
DibUnavailableException Constructor(Int32,String)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > DibUnavailableException Class > DibUnavailableException Constructor : DibUnavailableException Constructor(Int32,String)

errorNumber
An integer value which represents the error number
message
A string value which represents the error message.

Glossary Item Box

A DibUnavailableException which allows passing in an error number and an error message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New DibUnavailableException(errorNumber, message)
public DibUnavailableException(
   int errorNumber,
   string message
)
public: DibUnavailableException(
   int errorNumber,
   string* message
)
public:
DibUnavailableException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer value which represents the error number
message
A string value which represents the error message.

See Also

Reference

DibUnavailableException Class
DibUnavailableException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
DibUnavailableException Constructor(String,Exception)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > DibUnavailableException Class > DibUnavailableException Constructor : DibUnavailableException Constructor(String,Exception)

message
A string value which represents the error message.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

Glossary Item Box

A DibUnavailableException which allows passing in an error message and an inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New DibUnavailableException(message, innerException)
public DibUnavailableException(
   string message,
   Exception innerException
)
public: DibUnavailableException(
   string* message,
   Exception* innerException
)
public:
DibUnavailableException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string value which represents the error message.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

See Also

Reference

DibUnavailableException Class
DibUnavailableException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
DriverAndScanner Class
Members See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : DriverAndScanner Class

Glossary Item Box

This class is the element type of the DriverAndScannerList class. It holds a DriverName and ScannerModel available for use in ISISXpress.

Object Model

DriverAndScanner Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Class DriverAndScanner
'Usage

Dim instance As DriverAndScanner
public class DriverAndScanner
public __gc class DriverAndScanner
public ref class DriverAndScanner

Inheritance Hierarchy

System.Object
Accusoft.ISISXpressSdk.DriverAndScanner

See Also

Reference

DriverAndScanner Members
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.ISISXpress5.Net
DriverAndScanner Class Members
See Also Properties Send Feedback
Accusoft.ISISXpressSdk Namespace : DriverAndScanner Class

Glossary Item Box

The following tables list the members exposed by DriverAndScanner.

Public Constructors

 | Name | Description
Public Constructor | DriverAndScanner Constructor |
Top

Public Properties

 | Name | Description
Public Property | DriverName | Gets and sets the scanner driver name.
Public Property | ScannerModel | Gets and sets the scanner model name.
Top

See Also

Reference

DriverAndScanner Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
DriverAndScanner Constructor
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > DriverAndScanner Class : DriverAndScanner Constructor

Glossary Item Box

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New DriverAndScanner()
public DriverAndScanner()
public: DriverAndScanner();
public:
DriverAndScanner();

See Also

Reference

DriverAndScanner Class
DriverAndScanner Members


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.ISISXpress5.Net
DriverAndScanner Class Properties
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : DriverAndScanner Class

Glossary Item Box

For a list of all members of this type, see DriverAndScanner members.

Public Properties

 | Name | Description
Public Property | DriverName | Gets and sets the scanner driver name.
Public Property | ScannerModel | Gets and sets the scanner model name.
Top

See Also

Reference

DriverAndScanner Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
DriverName Property
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > DriverAndScanner Class : DriverName Property

Glossary Item Box

Gets and sets the scanner driver name.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property DriverName As String
'Usage

Dim instance As DriverAndScanner
Dim value As String

instance.DriverName = value

value = instance.DriverName
public string DriverName {get; set;}
public: __property string* get_DriverName();
public: __property void set_DriverName(
   string* value
);
public:
property String^ DriverName {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value which represents the name of the driver.

See Also

Reference

DriverAndScanner Class
DriverAndScanner Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
ScannerModel Property
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > DriverAndScanner Class : ScannerModel Property

Glossary Item Box

Gets and sets the scanner model name.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property ScannerModel As String
'Usage

Dim instance As DriverAndScanner
Dim value As String

instance.ScannerModel = value

value = instance.ScannerModel
public string ScannerModel {get; set;}
public: __property string* get_ScannerModel();
public: __property void set_ScannerModel(
   string* value
);
public:
property String^ ScannerModel {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value which represents the name of the scanner model.

See Also

Reference

DriverAndScanner Class
DriverAndScanner Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
DriverAndScannerList Class
Members See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : DriverAndScannerList Class

Glossary Item Box

This class implements a list of available ISIS drivers and scanner models.

Object Model

DriverAndScannerList ClassDriverAndScanner Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Class DriverAndScannerList
   Inherits System.Collections.Generic.List(Of DriverAndScanner)
'Usage

Dim instance As DriverAndScannerList
public class DriverAndScannerList : System.Collections.Generic.List<DriverAndScanner>
public __gc class DriverAndScannerList : public System.Collections.Generic.List<DriverAndScanner>
public ref class DriverAndScannerList : public System.Collections.Generic.List<DriverAndScanner>

Inheritance Hierarchy

System.Object
System.Collections.Generic.List<T>
Accusoft.ISISXpressSdk.DriverAndScannerList

See Also

Reference

DriverAndScannerList Members
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.ISISXpress5.Net
DriverAndScannerList Class Members
See Also Properties Methods Send Feedback
Accusoft.ISISXpressSdk Namespace : DriverAndScannerList Class

Glossary Item Box

The following tables list the members exposed by DriverAndScannerList.

Public Constructors

 | Name | Description
Public Constructor | DriverAndScannerList Constructor |
Top

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Property | Count | Gets the number of elements actually contained in the List. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Top

Public Methods

 | Name | Description
Public Method | Add | Adds an object to the end of the List. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | AddRange | Adds the elements of the specified collection to the end of the List. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | AsReadOnly | Returns a read-only IList wrapper for the current collection. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | Clear | Removes all elements from the List. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | Contains | Determines whether an element is in the List. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | ConvertAll | Converts the elements in the current List to another type, and returns a list containing the converted elements. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | Exists | Determines whether the List contains elements that match the conditions defined by the specified predicate. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | ForEach | Performs the specified action on each element of the List. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the List. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | GetRange | Creates a shallow copy of a range of elements in the source List. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | Insert | Inserts an element into the List at the specified index. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | InsertRange | Inserts the elements of a collection into the List at the specified index. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | Remove | Removes the first occurrence of a specific object from the List. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | RemoveRange | Removes a range of elements from the List. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | Reverse | Overloaded. Reverses the order of the elements in the entire List. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | Sort | Overloaded. Sorts the elements in the entire List using the default comparer. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | ToArray | Copies the elements of the List to a new array. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | TrimExcess | Sets the capacity to the actual number of elements in the List, if that number is less than a threshold value. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | TrueForAll | Determines whether every element in the List matches the conditions defined by the specified predicate. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Top

See Also

Reference

DriverAndScannerList Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.ISISXpress5.Net
DriverAndScannerList Class Methods
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : DriverAndScannerList Class

Glossary Item Box

For a list of all members of this type, see DriverAndScannerList members.

Public Methods

 | Name | Description
Public Method | Add | Adds an object to the end of the List. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | AddRange | Adds the elements of the specified collection to the end of the List. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | AsReadOnly | Returns a read-only IList wrapper for the current collection. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | Clear | Removes all elements from the List. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | Contains | Determines whether an element is in the List. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | ConvertAll | Converts the elements in the current List to another type, and returns a list containing the converted elements. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | Exists | Determines whether the List contains elements that match the conditions defined by the specified predicate. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | ForEach | Performs the specified action on each element of the List. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the List. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | GetRange | Creates a shallow copy of a range of elements in the source List. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | Insert | Inserts an element into the List at the specified index. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | InsertRange | Inserts the elements of a collection into the List at the specified index. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | Remove | Removes the first occurrence of a specific object from the List. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | RemoveRange | Removes a range of elements from the List. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | Reverse | Overloaded. Reverses the order of the elements in the entire List. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | Sort | Overloaded. Sorts the elements in the entire List using the default comparer. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | ToArray | Copies the elements of the List to a new array. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | TrimExcess | Sets the capacity to the actual number of elements in the List, if that number is less than a threshold value. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Method | TrueForAll | Determines whether every element in the List matches the conditions defined by the specified predicate. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Top

See Also

Reference

DriverAndScannerList Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.ISISXpress5.Net
DriverAndScannerList Class Properties
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : DriverAndScannerList Class

Glossary Item Box

For a list of all members of this type, see DriverAndScannerList members.

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Property | Count | Gets the number of elements actually contained in the List. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.Generic.List<DriverAndScanner>)
Top

See Also

Reference

DriverAndScannerList Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
DriverAndScannerList Constructor
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > DriverAndScannerList Class : DriverAndScannerList Constructor

Glossary Item Box

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New DriverAndScannerList()
public DriverAndScannerList()
public: DriverAndScannerList();
public:
DriverAndScannerList();

See Also

Reference

DriverAndScannerList Class
DriverAndScannerList Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
FeederEmptyEventArgs Class
Members See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : FeederEmptyEventArgs Class

Glossary Item Box

This class implements the event arguments for the IsisXpress.FeederEmpty event.

Object Model

FeederEmptyEventArgs Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Class FeederEmptyEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As FeederEmptyEventArgs
public class FeederEmptyEventArgs : System.EventArgs
public __gc class FeederEmptyEventArgs : public System.EventArgs
public ref class FeederEmptyEventArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Accusoft.ISISXpressSdk.FeederEmptyEventArgs

See Also

Reference

FeederEmptyEventArgs Members
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.ISISXpress5.Net
FeederEmptyEventArgs Class Members
See Also Properties Send Feedback
Accusoft.ISISXpressSdk Namespace : FeederEmptyEventArgs Class

Glossary Item Box

The following tables list the members exposed by FeederEmptyEventArgs.

Public Constructors

 | Name | Description
Public Constructor | FeederEmptyEventArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | PageNumber | Gets the page number of the scan that just completed.
Public Property | StopScan | Sets an indicator if the batch process should end.
Top

See Also

Reference

FeederEmptyEventArgs Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
FeederEmptyEventArgs Constructor
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > FeederEmptyEventArgs Class : FeederEmptyEventArgs Constructor

Glossary Item Box

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New FeederEmptyEventArgs()
public FeederEmptyEventArgs()
public: FeederEmptyEventArgs();
public:
FeederEmptyEventArgs();

See Also

Reference

FeederEmptyEventArgs Class
FeederEmptyEventArgs Members


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.ISISXpress5.Net
FeederEmptyEventArgs Class Properties
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : FeederEmptyEventArgs Class

Glossary Item Box

For a list of all members of this type, see FeederEmptyEventArgs members.

Public Properties

 | Name | Description
Public Property | PageNumber | Gets the page number of the scan that just completed.
Public Property | StopScan | Sets an indicator if the batch process should end.
Top

See Also

Reference

FeederEmptyEventArgs Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
PageNumber Property
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > FeederEmptyEventArgs Class : PageNumber Property

Glossary Item Box

Gets the page number of the scan that just completed.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property PageNumber As Integer
'Usage

Dim instance As FeederEmptyEventArgs
Dim value As Integer

instance.PageNumber = value

value = instance.PageNumber
public int PageNumber {get; set;}
public: __property int get_PageNumber();
public: __property void set_PageNumber(
   int value
);
public:
property int PageNumber {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the page number.

See Also

Reference

FeederEmptyEventArgs Class
FeederEmptyEventArgs Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
StopScan Property
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > FeederEmptyEventArgs Class : StopScan Property

Glossary Item Box

Sets an indicator if the batch process should end.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property StopScan As Boolean
'Usage

Dim instance As FeederEmptyEventArgs
Dim value As Boolean

instance.StopScan = value

value = instance.StopScan
public bool StopScan {get; set;}
public: __property bool get_StopScan();
public: __property void set_StopScan(
   bool value
);
public:
property bool StopScan {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true if the batch process should end. Otherwise, false should be returned.

Remarks

Note: The Scanner.ScanBatch method does not finish until this property is set to true and the IsisXpress.FeederEmpty event fires to indicate that the batch is complete.

When the scanner feeder is empty, a IsisXpress.FeederEmptyEventHandler event is fired. This event may fire after each scan if a scanner is being used that does not have a feeder or cannot detect paper in the feeder.

See Also

Reference

FeederEmptyEventArgs Class
FeederEmptyEventArgs Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
GeneralIsisException Class
Members See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : GeneralIsisException Class

Glossary Item Box

This class implements the GeneralIsisExceptions thrown when there is a general ISIS issue.

Object Model

GeneralIsisException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class GeneralIsisException
   Inherits IsisXpressLibraryException
'Usage

Dim instance As GeneralIsisException
[SerializableAttribute()]
public sealed class GeneralIsisException : IsisXpressLibraryException
[SerializableAttribute()]
public __gc __sealed class GeneralIsisException : public IsisXpressLibraryException
[SerializableAttribute()]
public ref class GeneralIsisException sealed : public IsisXpressLibraryException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.ISISXpressSdk.IsisXpressLibraryException
Accusoft.ISISXpressSdk.GeneralIsisException

See Also

Reference

GeneralIsisException Members
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.ISISXpress5.Net
GeneralIsisException Class Members
See Also Properties Methods Send Feedback
Accusoft.ISISXpressSdk Namespace : GeneralIsisException Class

Glossary Item Box

The following tables list the members exposed by GeneralIsisException.

Public Constructors

 | Name | Description
Public Constructor | GeneralIsisException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the number or ID of the specific error that occurred. (Inherited from Accusoft.ISISXpressSdk.IsisXpressLibraryException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

GeneralIsisException Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.ISISXpress5.Net
GeneralIsisException Class Methods
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : GeneralIsisException Class

Glossary Item Box

For a list of all members of this type, see GeneralIsisException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

GeneralIsisException Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.ISISXpress5.Net
GeneralIsisException Class Properties
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : GeneralIsisException Class

Glossary Item Box

For a list of all members of this type, see GeneralIsisException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the number or ID of the specific error that occurred. (Inherited from Accusoft.ISISXpressSdk.IsisXpressLibraryException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Top

See Also

Reference

GeneralIsisException Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
GeneralIsisException Constructor
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > GeneralIsisException Class : GeneralIsisException Constructor

Glossary Item Box

Overload List

Overload | Description
GeneralIsisException Constructor() | The main constructor for the GeneralIsisException class thrown when there is a general ISIS issue.
GeneralIsisException Constructor(Int32) | A GeneralIsisException which allows passing in an error number.
GeneralIsisException Constructor(String) | A GeneralIsisException which allows passing in an error message.
GeneralIsisException Constructor(Int32,String) | A GeneralIsisException which allows passing in an error number and an error message.
GeneralIsisException Constructor(String,Exception) | A GeneralIsisException which allows passing in an error message and an inner exception.

See Also

Reference

GeneralIsisException Class
GeneralIsisException Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
GeneralIsisException Constructor()
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > GeneralIsisException Class > GeneralIsisException Constructor : GeneralIsisException Constructor()

Glossary Item Box

The main constructor for the GeneralIsisException class thrown when there is a general ISIS issue.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New GeneralIsisException()
public GeneralIsisException()
public: GeneralIsisException();
public:
GeneralIsisException();

See Also

Reference

GeneralIsisException Class
GeneralIsisException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
GeneralIsisException Constructor(Int32)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > GeneralIsisException Class > GeneralIsisException Constructor : GeneralIsisException Constructor(Int32)

errorNumber
An integer value which represents the error number.

Glossary Item Box

A GeneralIsisException which allows passing in an error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New GeneralIsisException(errorNumber)
public GeneralIsisException(
   int errorNumber
)
public: GeneralIsisException(
   int errorNumber
)
public:
GeneralIsisException(
   int errorNumber
)

Parameters

errorNumber
An integer value which represents the error number.

See Also

Reference

GeneralIsisException Class
GeneralIsisException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
GeneralIsisException Constructor(String)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > GeneralIsisException Class > GeneralIsisException Constructor : GeneralIsisException Constructor(String)

message
A string value which represents the error message.

Glossary Item Box

A GeneralIsisException which allows passing in an error message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New GeneralIsisException(message)
public GeneralIsisException(
   string message
)
public: GeneralIsisException(
   string* message
)
public:
GeneralIsisException(
   String^ message
)

Parameters

message
A string value which represents the error message.

See Also

Reference

GeneralIsisException Class
GeneralIsisException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
GeneralIsisException Constructor(Int32,String)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > GeneralIsisException Class > GeneralIsisException Constructor : GeneralIsisException Constructor(Int32,String)

errorNumber
An integer value which represents the error number.
message
A string value which represents the error message.

Glossary Item Box

A GeneralIsisException which allows passing in an error number and an error message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New GeneralIsisException(errorNumber, message)
public GeneralIsisException(
   int errorNumber,
   string message
)
public: GeneralIsisException(
   int errorNumber,
   string* message
)
public:
GeneralIsisException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer value which represents the error number.
message
A string value which represents the error message.

See Also

Reference

GeneralIsisException Class
GeneralIsisException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
GeneralIsisException Constructor(String,Exception)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > GeneralIsisException Class > GeneralIsisException Constructor : GeneralIsisException Constructor(String,Exception)

message
A string value which represents the error message.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

Glossary Item Box

A GeneralIsisException which allows passing in an error message and an inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New GeneralIsisException(message, innerException)
public GeneralIsisException(
   string message,
   Exception innerException
)
public: GeneralIsisException(
   string* message,
   Exception* innerException
)
public:
GeneralIsisException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string value which represents the error message.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

See Also

Reference

GeneralIsisException Class
GeneralIsisException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
InvalidLicenseException Class
Members See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : InvalidLicenseException Class

Glossary Item Box

This class implements the InvalidLicenseExceptions thrown when the license key is invalid.

Object Model

InvalidLicenseException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class InvalidLicenseException
   Inherits IsisXpressLibraryException
'Usage

Dim instance As InvalidLicenseException
[SerializableAttribute()]
public sealed class InvalidLicenseException : IsisXpressLibraryException
[SerializableAttribute()]
public __gc __sealed class InvalidLicenseException : public IsisXpressLibraryException
[SerializableAttribute()]
public ref class InvalidLicenseException sealed : public IsisXpressLibraryException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.ISISXpressSdk.IsisXpressLibraryException
Accusoft.ISISXpressSdk.InvalidLicenseException

See Also

Reference

InvalidLicenseException Members
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.ISISXpress5.Net
InvalidLicenseException Class Members
See Also Properties Methods Send Feedback
Accusoft.ISISXpressSdk Namespace : InvalidLicenseException Class

Glossary Item Box

The following tables list the members exposed by InvalidLicenseException.

Public Constructors

 | Name | Description
Public Constructor | InvalidLicenseException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the number or ID of the specific error that occurred. (Inherited from Accusoft.ISISXpressSdk.IsisXpressLibraryException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidLicenseException Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.ISISXpress5.Net
InvalidLicenseException Class Methods
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : InvalidLicenseException Class

Glossary Item Box

For a list of all members of this type, see InvalidLicenseException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidLicenseException Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.ISISXpress5.Net
InvalidLicenseException Class Properties
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : InvalidLicenseException Class

Glossary Item Box

For a list of all members of this type, see InvalidLicenseException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the number or ID of the specific error that occurred. (Inherited from Accusoft.ISISXpressSdk.IsisXpressLibraryException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidLicenseException Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
InvalidLicenseException Constructor
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > InvalidLicenseException Class : InvalidLicenseException Constructor

Glossary Item Box

Overload List

Overload | Description
InvalidLicenseException Constructor() | The main constructor for the InvalidLicenseException class thrown when the license key is invalid.
InvalidLicenseException Constructor(Int32) | An InvalidLicenseException which allows passing in an error number.
InvalidLicenseException Constructor(String) | An InvalidLicenseException which allows passing in an error message.
InvalidLicenseException Constructor(Int32,String) | An InvalidLicenseException which allows passing in an error number and an error message.
InvalidLicenseException Constructor(String,Exception) | An InvalidLicenseException which allows passing in an error message and an inner exception.

See Also

Reference

InvalidLicenseException Class
InvalidLicenseException Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
InvalidLicenseException Constructor()
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > InvalidLicenseException Class > InvalidLicenseException Constructor : InvalidLicenseException Constructor()

Glossary Item Box

The main constructor for the InvalidLicenseException class thrown when the license key is invalid.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New InvalidLicenseException()
public InvalidLicenseException()
public: InvalidLicenseException();
public:
InvalidLicenseException();

See Also

Reference

InvalidLicenseException Class
InvalidLicenseException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
InvalidLicenseException Constructor(Int32)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > InvalidLicenseException Class > InvalidLicenseException Constructor : InvalidLicenseException Constructor(Int32)

errorNumber
An integer value which represents the error number.

Glossary Item Box

An InvalidLicenseException which allows passing in an error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New InvalidLicenseException(errorNumber)
public InvalidLicenseException(
   int errorNumber
)
public: InvalidLicenseException(
   int errorNumber
)
public:
InvalidLicenseException(
   int errorNumber
)

Parameters

errorNumber
An integer value which represents the error number.

See Also

Reference

InvalidLicenseException Class
InvalidLicenseException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
InvalidLicenseException Constructor(String)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > InvalidLicenseException Class > InvalidLicenseException Constructor : InvalidLicenseException Constructor(String)

message
A string value which represents the error message.

Glossary Item Box

An InvalidLicenseException which allows passing in an error message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New InvalidLicenseException(message)
public InvalidLicenseException(
   string message
)
public: InvalidLicenseException(
   string* message
)
public:
InvalidLicenseException(
   String^ message
)

Parameters

message
A string value which represents the error message.

See Also

Reference

InvalidLicenseException Class
InvalidLicenseException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
InvalidLicenseException Constructor(Int32,String)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > InvalidLicenseException Class > InvalidLicenseException Constructor : InvalidLicenseException Constructor(Int32,String)

errorNumber
An integer value which represents the error number.
message
A string value which represents the error message.

Glossary Item Box

An InvalidLicenseException which allows passing in an error number and an error message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New InvalidLicenseException(errorNumber, message)
public InvalidLicenseException(
   int errorNumber,
   string message
)
public: InvalidLicenseException(
   int errorNumber,
   string* message
)
public:
InvalidLicenseException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer value which represents the error number.
message
A string value which represents the error message.

See Also

Reference

InvalidLicenseException Class
InvalidLicenseException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
InvalidLicenseException Constructor(String,Exception)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > InvalidLicenseException Class > InvalidLicenseException Constructor : InvalidLicenseException Constructor(String,Exception)

message
A string value which represents the error message.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

Glossary Item Box

An InvalidLicenseException which allows passing in an error message and an inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New InvalidLicenseException(message, innerException)
public InvalidLicenseException(
   string message,
   Exception innerException
)
public: InvalidLicenseException(
   string* message,
   Exception* innerException
)
public:
InvalidLicenseException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string value which represents the error message.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

See Also

Reference

InvalidLicenseException Class
InvalidLicenseException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
InvalidSchemaException Class
Members See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : InvalidSchemaException Class

Glossary Item Box

This class implements the InvalidSchemaExceptions when the filename schema is invalid.

Object Model

InvalidSchemaException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class InvalidSchemaException
   Inherits IsisXpressLibraryException
'Usage

Dim instance As InvalidSchemaException
[SerializableAttribute()]
public sealed class InvalidSchemaException : IsisXpressLibraryException
[SerializableAttribute()]
public __gc __sealed class InvalidSchemaException : public IsisXpressLibraryException
[SerializableAttribute()]
public ref class InvalidSchemaException sealed : public IsisXpressLibraryException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.ISISXpressSdk.IsisXpressLibraryException
Accusoft.ISISXpressSdk.InvalidSchemaException

See Also

Reference

InvalidSchemaException Members
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.ISISXpress5.Net
InvalidSchemaException Class Members
See Also Properties Methods Send Feedback
Accusoft.ISISXpressSdk Namespace : InvalidSchemaException Class

Glossary Item Box

The following tables list the members exposed by InvalidSchemaException.

Public Constructors

 | Name | Description
Public Constructor | InvalidSchemaException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the number or ID of the specific error that occurred. (Inherited from Accusoft.ISISXpressSdk.IsisXpressLibraryException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidSchemaException Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.ISISXpress5.Net
InvalidSchemaException Class Methods
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : InvalidSchemaException Class

Glossary Item Box

For a list of all members of this type, see InvalidSchemaException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidSchemaException Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.ISISXpress5.Net
InvalidSchemaException Class Properties
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : InvalidSchemaException Class

Glossary Item Box

For a list of all members of this type, see InvalidSchemaException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the number or ID of the specific error that occurred. (Inherited from Accusoft.ISISXpressSdk.IsisXpressLibraryException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidSchemaException Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
InvalidSchemaException Constructor
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > InvalidSchemaException Class : InvalidSchemaException Constructor

Glossary Item Box

Overload List

Overload | Description
InvalidSchemaException Constructor() | The main constructor for the InvalidSchemaException class when the filename schema is invalid.
InvalidSchemaException Constructor(Int32) | An InvalidSchemaException which allows passing in an error number.
InvalidSchemaException Constructor(String) | An InvalidSchemaException which allows passing in an error message.
InvalidSchemaException Constructor(Int32,String) | An InvalidSchemaException which allows passing in an error number and an error message.
InvalidSchemaException Constructor(String,Exception) | An InvalidSchemaException which allows passing in an error message and an inner exception.

See Also

Reference

InvalidSchemaException Class
InvalidSchemaException Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
InvalidSchemaException Constructor()
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > InvalidSchemaException Class > InvalidSchemaException Constructor : InvalidSchemaException Constructor()

Glossary Item Box

The main constructor for the InvalidSchemaException class when the filename schema is invalid.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New InvalidSchemaException()
public InvalidSchemaException()
public: InvalidSchemaException();
public:
InvalidSchemaException();

See Also

Reference

InvalidSchemaException Class
InvalidSchemaException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
InvalidSchemaException Constructor(Int32)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > InvalidSchemaException Class > InvalidSchemaException Constructor : InvalidSchemaException Constructor(Int32)

errorNumber
An integer value which represents the error number.

Glossary Item Box

An InvalidSchemaException which allows passing in an error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New InvalidSchemaException(errorNumber)
public InvalidSchemaException(
   int errorNumber
)
public: InvalidSchemaException(
   int errorNumber
)
public:
InvalidSchemaException(
   int errorNumber
)

Parameters

errorNumber
An integer value which represents the error number.

See Also

Reference

InvalidSchemaException Class
InvalidSchemaException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
InvalidSchemaException Constructor(String)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > InvalidSchemaException Class > InvalidSchemaException Constructor : InvalidSchemaException Constructor(String)

message
A string value which represents the error message.

Glossary Item Box

An InvalidSchemaException which allows passing in an error message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New InvalidSchemaException(message)
public InvalidSchemaException(
   string message
)
public: InvalidSchemaException(
   string* message
)
public:
InvalidSchemaException(
   String^ message
)

Parameters

message
A string value which represents the error message.

See Also

Reference

InvalidSchemaException Class
InvalidSchemaException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
InvalidSchemaException Constructor(Int32,String)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > InvalidSchemaException Class > InvalidSchemaException Constructor : InvalidSchemaException Constructor(Int32,String)

errorNumber
An integer value which represents the error number.
message
A string value which represents the error message.

Glossary Item Box

An InvalidSchemaException which allows passing in an error number and an error message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New InvalidSchemaException(errorNumber, message)
public InvalidSchemaException(
   int errorNumber,
   string message
)
public: InvalidSchemaException(
   int errorNumber,
   string* message
)
public:
InvalidSchemaException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer value which represents the error number.
message
A string value which represents the error message.

See Also

Reference

InvalidSchemaException Class
InvalidSchemaException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
InvalidSchemaException Constructor(String,Exception)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > InvalidSchemaException Class > InvalidSchemaException Constructor : InvalidSchemaException Constructor(String,Exception)

message
A string value which represents the error message.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

Glossary Item Box

An InvalidSchemaException which allows passing in an error message and an inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New InvalidSchemaException(message, innerException)
public InvalidSchemaException(
   string message,
   Exception innerException
)
public: InvalidSchemaException(
   string* message,
   Exception* innerException
)
public:
InvalidSchemaException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string value which represents the error message.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

See Also

Reference

InvalidSchemaException Class
InvalidSchemaException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
InvalidSettingException Class
Members See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : InvalidSettingException Class

Glossary Item Box

This class implements the InvalidSettingExceptions when there is an invalid scanner setting.

Object Model

InvalidSettingException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class InvalidSettingException
   Inherits IsisXpressLibraryException
'Usage

Dim instance As InvalidSettingException
[SerializableAttribute()]
public sealed class InvalidSettingException : IsisXpressLibraryException
[SerializableAttribute()]
public __gc __sealed class InvalidSettingException : public IsisXpressLibraryException
[SerializableAttribute()]
public ref class InvalidSettingException sealed : public IsisXpressLibraryException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.ISISXpressSdk.IsisXpressLibraryException
Accusoft.ISISXpressSdk.InvalidSettingException

See Also

Reference

InvalidSettingException Members
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.ISISXpress5.Net
InvalidSettingException Class Members
See Also Properties Methods Send Feedback
Accusoft.ISISXpressSdk Namespace : InvalidSettingException Class

Glossary Item Box

The following tables list the members exposed by InvalidSettingException.

Public Constructors

 | Name | Description
Public Constructor | InvalidSettingException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the number or ID of the specific error that occurred. (Inherited from Accusoft.ISISXpressSdk.IsisXpressLibraryException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidSettingException Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.ISISXpress5.Net
InvalidSettingException Class Methods
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : InvalidSettingException Class

Glossary Item Box

For a list of all members of this type, see InvalidSettingException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidSettingException Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.ISISXpress5.Net
InvalidSettingException Class Properties
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : InvalidSettingException Class

Glossary Item Box

For a list of all members of this type, see InvalidSettingException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the number or ID of the specific error that occurred. (Inherited from Accusoft.ISISXpressSdk.IsisXpressLibraryException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidSettingException Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
InvalidSettingException Constructor
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > InvalidSettingException Class : InvalidSettingException Constructor

Glossary Item Box

Overload List

Overload | Description
InvalidSettingException Constructor() | The main constructor for the InvalidSettingException class to be thrown when there is an invalid scanner setting.
InvalidSettingException Constructor(Int32) | An InvalidSettingException which allows passing in an error number.
InvalidSettingException Constructor(String) | An InvalidSettingException which allows passing in an error message.
InvalidSettingException Constructor(Int32,String) | An InvalidSettingException which allows passing in an error number and an error message.
InvalidSettingException Constructor(String,Exception) | An InvalidSettingException which allows passing in an error message and an inner exception.

See Also

Reference

InvalidSettingException Class
InvalidSettingException Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
InvalidSettingException Constructor()
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > InvalidSettingException Class > InvalidSettingException Constructor : InvalidSettingException Constructor()

Glossary Item Box

The main constructor for the InvalidSettingException class to be thrown when there is an invalid scanner setting.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New InvalidSettingException()
public InvalidSettingException()
public: InvalidSettingException();
public:
InvalidSettingException();

See Also

Reference

InvalidSettingException Class
InvalidSettingException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
InvalidSettingException Constructor(Int32)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > InvalidSettingException Class > InvalidSettingException Constructor : InvalidSettingException Constructor(Int32)

errorNumber
An integer which represents the error number.

Glossary Item Box

An InvalidSettingException which allows passing in an error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New InvalidSettingException(errorNumber)
public InvalidSettingException(
   int errorNumber
)
public: InvalidSettingException(
   int errorNumber
)
public:
InvalidSettingException(
   int errorNumber
)

Parameters

errorNumber
An integer which represents the error number.

See Also

Reference

InvalidSettingException Class
InvalidSettingException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
InvalidSettingException Constructor(String)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > InvalidSettingException Class > InvalidSettingException Constructor : InvalidSettingException Constructor(String)

message
An integer which represents the error message.

Glossary Item Box

An InvalidSettingException which allows passing in an error message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New InvalidSettingException(message)
public InvalidSettingException(
   string message
)
public: InvalidSettingException(
   string* message
)
public:
InvalidSettingException(
   String^ message
)

Parameters

message
An integer which represents the error message.

See Also

Reference

InvalidSettingException Class
InvalidSettingException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
InvalidSettingException Constructor(Int32,String)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > InvalidSettingException Class > InvalidSettingException Constructor : InvalidSettingException Constructor(Int32,String)

errorNumber
An integer value which represents the error number.
message
A string value which represents the error message.

Glossary Item Box

An InvalidSettingException which allows passing in an error number and an error message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New InvalidSettingException(errorNumber, message)
public InvalidSettingException(
   int errorNumber,
   string message
)
public: InvalidSettingException(
   int errorNumber,
   string* message
)
public:
InvalidSettingException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer value which represents the error number.
message
A string value which represents the error message.

See Also

Reference

InvalidSettingException Class
InvalidSettingException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
InvalidSettingException Constructor(String,Exception)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > InvalidSettingException Class > InvalidSettingException Constructor : InvalidSettingException Constructor(String,Exception)

message
A string value which represents the error message.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

Glossary Item Box

An InvalidSettingException which allows passing in an error message and an inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New InvalidSettingException(message, innerException)
public InvalidSettingException(
   string message,
   Exception innerException
)
public: InvalidSettingException(
   string* message,
   Exception* innerException
)
public:
InvalidSettingException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string value which represents the error message.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

See Also

Reference

InvalidSettingException Class
InvalidSettingException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
IsisDriverException Class
Members See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : IsisDriverException Class

Glossary Item Box

This class implements ISIS driver exceptions.

Object Model

IsisDriverException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class IsisDriverException
   Inherits IsisXpressLibraryException
'Usage

Dim instance As IsisDriverException
[SerializableAttribute()]
public sealed class IsisDriverException : IsisXpressLibraryException
[SerializableAttribute()]
public __gc __sealed class IsisDriverException : public IsisXpressLibraryException
[SerializableAttribute()]
public ref class IsisDriverException sealed : public IsisXpressLibraryException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.ISISXpressSdk.IsisXpressLibraryException
Accusoft.ISISXpressSdk.IsisDriverException

See Also

Reference

IsisDriverException Members
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.ISISXpress5.Net
IsisDriverException Class Members
See Also Properties Methods Send Feedback
Accusoft.ISISXpressSdk Namespace : IsisDriverException Class

Glossary Item Box

The following tables list the members exposed by IsisDriverException.

Public Constructors

 | Name | Description
Public Constructor | IsisDriverException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the number or ID of the specific error that occurred. (Inherited from Accusoft.ISISXpressSdk.IsisXpressLibraryException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

IsisDriverException Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.ISISXpress5.Net
IsisDriverException Class Methods
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : IsisDriverException Class

Glossary Item Box

For a list of all members of this type, see IsisDriverException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

IsisDriverException Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.ISISXpress5.Net
IsisDriverException Class Properties
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : IsisDriverException Class

Glossary Item Box

For a list of all members of this type, see IsisDriverException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the number or ID of the specific error that occurred. (Inherited from Accusoft.ISISXpressSdk.IsisXpressLibraryException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Top

See Also

Reference

IsisDriverException Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
IsisDriverException Constructor
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > IsisDriverException Class : IsisDriverException Constructor

Glossary Item Box

Overload List

Overload | Description
IsisDriverException Constructor() | The main constructor to create a new instance of the IsisDriverException.
IsisDriverException Constructor(Int32) | An IsisDriverException constructor which allows passing in an error number.
IsisDriverException Constructor(String) | An IsisDriverException constructor which allows passing in an error message.
IsisDriverException Constructor(Int32,String) | An IsisDriverException constructor which allows passing in an error number and an error message.
IsisDriverException Constructor(String,Exception) | An IsisDriverException constructor which allows passing in an error message and inner exception.

See Also

Reference

IsisDriverException Class
IsisDriverException Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
IsisDriverException Constructor()
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > IsisDriverException Class > IsisDriverException Constructor : IsisDriverException Constructor()

Glossary Item Box

The main constructor to create a new instance of the IsisDriverException.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New IsisDriverException()
public IsisDriverException()
public: IsisDriverException();
public:
IsisDriverException();

See Also

Reference

IsisDriverException Class
IsisDriverException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
IsisDriverException Constructor(Int32)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > IsisDriverException Class > IsisDriverException Constructor : IsisDriverException Constructor(Int32)

errorNumber
An integer value which represents the error number.

Glossary Item Box

An IsisDriverException constructor which allows passing in an error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New IsisDriverException(errorNumber)
public IsisDriverException(
   int errorNumber
)
public: IsisDriverException(
   int errorNumber
)
public:
IsisDriverException(
   int errorNumber
)

Parameters

errorNumber
An integer value which represents the error number.

See Also

Reference

IsisDriverException Class
IsisDriverException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
IsisDriverException Constructor(String)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > IsisDriverException Class > IsisDriverException Constructor : IsisDriverException Constructor(String)

message
A string value which represents the error message.

Glossary Item Box

An IsisDriverException constructor which allows passing in an error message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New IsisDriverException(message)
public IsisDriverException(
   string message
)
public: IsisDriverException(
   string* message
)
public:
IsisDriverException(
   String^ message
)

Parameters

message
A string value which represents the error message.

See Also

Reference

IsisDriverException Class
IsisDriverException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
IsisDriverException Constructor(Int32,String)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > IsisDriverException Class > IsisDriverException Constructor : IsisDriverException Constructor(Int32,String)

errorNumber
An integer value which represents an error number.
message
A string value which represents an error message.

Glossary Item Box

An IsisDriverException constructor which allows passing in an error number and an error message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New IsisDriverException(errorNumber, message)
public IsisDriverException(
   int errorNumber,
   string message
)
public: IsisDriverException(
   int errorNumber,
   string* message
)
public:
IsisDriverException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer value which represents an error number.
message
A string value which represents an error message.

See Also

Reference

IsisDriverException Class
IsisDriverException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
IsisDriverException Constructor(String,Exception)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > IsisDriverException Class > IsisDriverException Constructor : IsisDriverException Constructor(String,Exception)

message
A string value which represents an error message.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

Glossary Item Box

An IsisDriverException constructor which allows passing in an error message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New IsisDriverException(message, innerException)
public IsisDriverException(
   string message,
   Exception innerException
)
public: IsisDriverException(
   string* message,
   Exception* innerException
)
public:
IsisDriverException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string value which represents an error message.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

See Also

Reference

IsisDriverException Class
IsisDriverException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
IsisXpress Class
Members See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : IsisXpress Class

Glossary Item Box

This class is the main controller for the ISIS Xpress component.

Object Model

IsisXpress ClassLicensing ClassOutput ClassScanner ClassSetting ClassRationalType ClassRationalType ClassRationalType ClassRationalType ClassRationalType ClassRationalType Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<ToolboxBitmapAttribute()>
<ComVisibleAttribute(True)>
Public Class IsisXpress
   Inherits System.ComponentModel.Component
'Usage

Dim instance As IsisXpress
[ToolboxBitmapAttribute()]
[ComVisibleAttribute(true)]
public class IsisXpress : System.ComponentModel.Component
[ToolboxBitmapAttribute()]
[ComVisibleAttribute(true)]
public __gc class IsisXpress : public System.ComponentModel.Component
[ToolboxBitmapAttribute()]
[ComVisibleAttribute(true)]
public ref class IsisXpress : public System.ComponentModel.Component

Remarks

This class includes basic component functions like licensing, about box, progress and scanning events.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Accusoft.ISISXpressSdk.IsisXpress

See Also

Reference

IsisXpress Members
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.ISISXpress5.Net
IsisXpress Class Members
See Also Properties Methods Events Send Feedback
Accusoft.ISISXpressSdk Namespace : IsisXpress Class

Glossary Item Box

The following tables list the members exposed by IsisXpress.

Public Constructors

 | Name | Description
Public Constructor | IsisXpress Constructor | The default constructor to instantiate a new IsisXpress instance.
Top

Public Properties

 | Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Debug | Gets and sets an indicator if debug information is generated and written to the DebugLogFile.
Public Property | DebugLogFile | Gets and sets the filename of the debug log file.
Public Property | ErrorLevel | Gets and sets the ErrorLevelInfo enumeration value for the error level of information to write to the DebugLogFile.
Public Property | Licensing | An ISIS® Xpress license object instance for setting the license information.
Public Property | Output | Gets the current instance of the Output object.
Public Property | Scanner | Gets the current instance of the Scanner object.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Version | Returns the version of the ISISXpress control at run-time.
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

Public Methods

 | Name | Description
Public Method | AboutBox | Displays a dialog window with the ISIS Xpress version number, Accusoft Corporation contact information, and general information about this component.
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. Overridden. Removes any unused resources that this object is holding.
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | Removes any unused resources that this object is holding.
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | MemberwiseClone | Overloaded. Creates a shallow copy of the current System.MarshalByRefObject object. (Inherited from System.MarshalByRefObject)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | FeederEmpty | Fired when the scanner feeder is empty.
Public Event | Progress | Fired to indicate how much of the scan has completed.
Public Event | Scanned | Fired to indicate when a scan has completed.
Public Event | Scanning | Fired to indicate a scan is starting.
Top

See Also

Reference

IsisXpress Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
IsisXpress Constructor
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > IsisXpress Class : IsisXpress Constructor

Glossary Item Box

The default constructor to instantiate a new IsisXpress instance.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New IsisXpress()
public IsisXpress()
public: IsisXpress();
public:
IsisXpress();

See Also

Reference

IsisXpress Class
IsisXpress Members


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.ISISXpress5.Net
IsisXpress Class Methods
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : IsisXpress Class

Glossary Item Box

For a list of all members of this type, see IsisXpress members.

Public Methods

 | Name | Description
Public Method | AboutBox | Displays a dialog window with the ISIS Xpress version number, Accusoft Corporation contact information, and general information about this component.
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. Overridden. Removes any unused resources that this object is holding.
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | Removes any unused resources that this object is holding.
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | MemberwiseClone | Overloaded. Creates a shallow copy of the current System.MarshalByRefObject object. (Inherited from System.MarshalByRefObject)
Top

See Also

Reference

IsisXpress Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
AboutBox Method
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > IsisXpress Class : AboutBox Method

Glossary Item Box

Displays a dialog window with the ISIS Xpress version number, Accusoft Corporation contact information, and general information about this component.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<CategoryAttribute("IsisXpress")>
Public Sub AboutBox()
'Usage

Dim instance As IsisXpress

instance.AboutBox()
[CategoryAttribute("IsisXpress")]
public void AboutBox()
[CategoryAttribute("IsisXpress")]
public: void AboutBox();
[CategoryAttribute("IsisXpress")]
public:
void AboutBox();

See Also

Reference

IsisXpress Class
IsisXpress Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
Dispose Method
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > IsisXpress Class : Dispose Method

Glossary Item Box

Removes any unused resources that this object is holding.

Overload List

Overload | Description
Dispose(Boolean) | Removes any unused resources that this object is holding.
Dispose() | (Inherited from System.ComponentModel.Component)

See Also

Reference

IsisXpress Class
IsisXpress Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
Dispose(Boolean) Method
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > IsisXpress Class > Dispose Method : Dispose(Boolean) Method

disposing

Glossary Item Box

Removes any unused resources that this object is holding.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
'Usage

Dim instance As IsisXpress
Dim disposing As Boolean

instance.Dispose(disposing)
protected override void Dispose(
   bool disposing
)
protected: void Dispose(
   bool disposing
) override
protected:
void Dispose(
   bool disposing
) override

Parameters

disposing

See Also

Reference

IsisXpress Class
IsisXpress Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
Finalize Method
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > IsisXpress Class : Finalize Method

Glossary Item Box

Removes any unused resources that this object is holding.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Protected Overrides Sub Finalize()
'Usage

Dim instance As IsisXpress

instance.Finalize()
protected override void Finalize()
protected: void Finalize(); override
protected:
void Finalize(); override

See Also

Reference

IsisXpress Class
IsisXpress Members


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.ISISXpress5.Net
IsisXpress Class Properties
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : IsisXpress Class

Glossary Item Box

For a list of all members of this type, see IsisXpress members.

Public Properties

 | Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Debug | Gets and sets an indicator if debug information is generated and written to the DebugLogFile.
Public Property | DebugLogFile | Gets and sets the filename of the debug log file.
Public Property | ErrorLevel | Gets and sets the ErrorLevelInfo enumeration value for the error level of information to write to the DebugLogFile.
Public Property | Licensing | An ISIS® Xpress license object instance for setting the license information.
Public Property | Output | Gets the current instance of the Output object.
Public Property | Scanner | Gets the current instance of the Scanner object.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Version | Returns the version of the ISISXpress control at run-time.
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

IsisXpress Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
Debug Property
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > IsisXpress Class : Debug Property

Glossary Item Box

Gets and sets an indicator if debug information is generated and written to the DebugLogFile.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
Public Property Debug As Boolean
'Usage

Dim instance As IsisXpress
Dim value As Boolean

instance.Debug = value

value = instance.Debug
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public bool Debug {get; set;}
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public: __property bool get_Debug();
public: __property void set_Debug(
   bool value
);
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public:
property bool Debug {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true to write debug information to the DebugLogFile. Otherwise, false is returned.

See Also

Reference

IsisXpress Class
IsisXpress Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
DebugLogFile Property
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > IsisXpress Class : DebugLogFile Property

Glossary Item Box

Gets and sets the filename of the debug log file.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property DebugLogFile As String
'Usage

Dim instance As IsisXpress
Dim value As String

instance.DebugLogFile = value

value = instance.DebugLogFile
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public string DebugLogFile {get; set;}
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property string* get_DebugLogFile();
public: __property void set_DebugLogFile(
   string* value
);
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property String^ DebugLogFile {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value which represents the full path and name of the debug log file.

Remarks

This property allows you to control the location of the debug log file.

Valid value: Any valid filename.

Default value: "temp\ISISXpress5.log"

Note: This property will have no effect if you set the Debug property to false.

Example

...

// Set the DebugLogFile path and name

IsisXpress.DebugLogFile = "c:\logFile.txt";

...

See Also

Reference

IsisXpress Class
IsisXpress Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
ErrorLevel Property
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > IsisXpress Class : ErrorLevel Property

Glossary Item Box

Gets and sets the ErrorLevelInfo enumeration value for the error level of information to write to the DebugLogFile.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(True)>
Public Property ErrorLevel As ErrorLevelInfo
'Usage

Dim instance As IsisXpress
Dim value As ErrorLevelInfo

instance.ErrorLevel = value

value = instance.ErrorLevel
[BrowsableAttribute(true)]
public ErrorLevelInfo ErrorLevel {get; set;}
[BrowsableAttribute(true)]
public: __property ErrorLevelInfo get_ErrorLevel();
public: __property void set_ErrorLevel(
   ErrorLevelInfo value
);
[BrowsableAttribute(true)]
public:
property ErrorLevelInfo ErrorLevel {
   ErrorLevelInfo get();
   void set (    ErrorLevelInfo value);
}

Property Value

The ErrorLevelInfo enumeration value set.

Remarks

The default value is Production.

Set this property appropriately to speed up processing when not debugging. When debugging, set this property to Detailed to obtain detailed error information.

See Also

Reference

IsisXpress Class
IsisXpress Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
Licensing Property
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > IsisXpress Class : Licensing Property

Glossary Item Box

An ISIS® Xpress license object instance for setting the license information.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public ReadOnly Property Licensing As Licensing
'Usage

Dim instance As IsisXpress
Dim value As Licensing

value = instance.Licensing
[BrowsableAttribute(false)]
public Licensing Licensing {get;}
[BrowsableAttribute(false)]
public: __property Licensing* get_Licensing();
[BrowsableAttribute(false)]
public:
property Licensing^ Licensing {
   Licensing^ get();
}

Property Value

The current Licensing object.

See Also

Reference

IsisXpress Class
IsisXpress Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
Output Property
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > IsisXpress Class : Output Property

Glossary Item Box

Gets the current instance of the Output object.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public ReadOnly Property Output As Output
'Usage

Dim instance As IsisXpress
Dim value As Output

value = instance.Output
[BrowsableAttribute(false)]
public Output Output {get;}
[BrowsableAttribute(false)]
public: __property Output* get_Output();
[BrowsableAttribute(false)]
public:
property Output^ Output {
   Output^ get();
}

Property Value

The current instance of the Output object set.

See Also

Reference

IsisXpress Class
IsisXpress Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
Scanner Property
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > IsisXpress Class : Scanner Property

Glossary Item Box

Gets the current instance of the Scanner object.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public ReadOnly Property Scanner As Scanner
'Usage

Dim instance As IsisXpress
Dim value As Scanner

value = instance.Scanner
[BrowsableAttribute(false)]
public Scanner Scanner {get;}
[BrowsableAttribute(false)]
public: __property Scanner* get_Scanner();
[BrowsableAttribute(false)]
public:
property Scanner^ Scanner {
   Scanner^ get();
}

Property Value

The instance of the Scanner object set.

See Also

Reference

IsisXpress Class
IsisXpress Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
Version Property
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > IsisXpress Class : Version Property

Glossary Item Box

Returns the version of the ISISXpress control at run-time.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public ReadOnly Property Version As String
'Usage

Dim instance As IsisXpress
Dim value As String

value = instance.Version
[BrowsableAttribute(false)]
public string Version {get;}
[BrowsableAttribute(false)]
public: __property string* get_Version();
[BrowsableAttribute(false)]
public:
property String^ Version {
   String^ get();
}

See Also

Reference

IsisXpress Class
IsisXpress Members


%%PageItemTitle%% $$Events$$

[image]
Accusoft.ISISXpress5.Net
IsisXpress Class Events
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : IsisXpress Class

Glossary Item Box

For a list of all members of this type, see IsisXpress members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | FeederEmpty | Fired when the scanner feeder is empty.
Public Event | Progress | Fired to indicate how much of the scan has completed.
Public Event | Scanned | Fired to indicate when a scan has completed.
Public Event | Scanning | Fired to indicate a scan is starting.
Top

See Also

Reference

IsisXpress Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
FeederEmpty Event
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > IsisXpress Class : FeederEmpty Event

Glossary Item Box

Fired when the scanner feeder is empty.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<CategoryAttribute("IsisXpress")>
Public Event FeederEmpty As IsisXpress.FeederEmptyEventHandler
'Usage

Dim instance As IsisXpress
Dim handler As IsisXpress.FeederEmptyEventHandler

AddHandler instance.FeederEmpty, handler
[CategoryAttribute("IsisXpress")]
public event IsisXpress.FeederEmptyEventHandler FeederEmpty
[CategoryAttribute("IsisXpress")]
public: __event IsisXpress.FeederEmptyEventHandler* FeederEmpty
[CategoryAttribute("IsisXpress")]
public:
event IsisXpress.FeederEmptyEventHandler^ FeederEmpty

Event Data

The event handler receives an argument of type FeederEmptyEventArgs containing data related to this event. The following FeederEmptyEventArgs properties provide information specific to this event.

Property | Description
PageNumber | Gets the page number of the scan that just completed.
StopScan | Sets an indicator if the batch process should end.

See Also

Reference

IsisXpress Class
IsisXpress Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
Progress Event
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > IsisXpress Class : Progress Event

Glossary Item Box

Fired to indicate how much of the scan has completed.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<CategoryAttribute("IsisXpress")>
Public Event Progress As IsisXpress.ProgressEventHandler
'Usage

Dim instance As IsisXpress
Dim handler As IsisXpress.ProgressEventHandler

AddHandler instance.Progress, handler
[CategoryAttribute("IsisXpress")]
public event IsisXpress.ProgressEventHandler Progress
[CategoryAttribute("IsisXpress")]
public: __event IsisXpress.ProgressEventHandler* Progress
[CategoryAttribute("IsisXpress")]
public:
event IsisXpress.ProgressEventHandler^ Progress

Event Data

The event handler receives an argument of type ProgressEventArgs containing data related to this event. The following ProgressEventArgs properties provide information specific to this event.

Property | Description
Percent | Gets the percentage the scan has progressed.

See Also

Reference

IsisXpress Class
IsisXpress Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
Scanned Event
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > IsisXpress Class : Scanned Event

Glossary Item Box

Fired to indicate when a scan has completed.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<CategoryAttribute("IsisXpress")>
Public Event Scanned As IsisXpress.ScannedEventHandler
'Usage

Dim instance As IsisXpress
Dim handler As IsisXpress.ScannedEventHandler

AddHandler instance.Scanned, handler
[CategoryAttribute("IsisXpress")]
public event IsisXpress.ScannedEventHandler Scanned
[CategoryAttribute("IsisXpress")]
public: __event IsisXpress.ScannedEventHandler* Scanned
[CategoryAttribute("IsisXpress")]
public:
event IsisXpress.ScannedEventHandler^ Scanned

Event Data

The event handler receives an argument of type ScannedEventArgs containing data related to this event. The following ScannedEventArgs properties provide information specific to this event.

Property | Description
PageNumber | Gets the page number of the scan that just completed.

See Also

Reference

IsisXpress Class
IsisXpress Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
Scanning Event
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > IsisXpress Class : Scanning Event

Glossary Item Box

Fired to indicate a scan is starting.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<CategoryAttribute("IsisXpress")>
Public Event Scanning As IsisXpress.ScanningEventHandler
'Usage

Dim instance As IsisXpress
Dim handler As IsisXpress.ScanningEventHandler

AddHandler instance.Scanning, handler
[CategoryAttribute("IsisXpress")]
public event IsisXpress.ScanningEventHandler Scanning
[CategoryAttribute("IsisXpress")]
public: __event IsisXpress.ScanningEventHandler* Scanning
[CategoryAttribute("IsisXpress")]
public:
event IsisXpress.ScanningEventHandler^ Scanning

Event Data

The event handler receives an argument of type ScanningEventArgs containing data related to this event. The following ScanningEventArgs properties provide information specific to this event.

Property | Description
PageNumber | Gets the page number of the scan that is starting.

See Also

Reference

IsisXpress Class
IsisXpress Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
IsisXpressLibraryException Class
Members See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : IsisXpressLibraryException Class

Glossary Item Box

This class implements application exceptions.

Object Model

IsisXpressLibraryException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public Class IsisXpressLibraryException
   Inherits System.ApplicationException
'Usage

Dim instance As IsisXpressLibraryException
[SerializableAttribute()]
public class IsisXpressLibraryException : System.ApplicationException
[SerializableAttribute()]
public __gc class IsisXpressLibraryException : public System.ApplicationException
[SerializableAttribute()]
public ref class IsisXpressLibraryException : public System.ApplicationException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.ISISXpressSdk.IsisXpressLibraryException
Accusoft.ISISXpressSdk.CancelException
Accusoft.ISISXpressSdk.ConfigFileException
Accusoft.ISISXpressSdk.DibUnavailableException
Accusoft.ISISXpressSdk.GeneralIsisException
Accusoft.ISISXpressSdk.InvalidLicenseException
Accusoft.ISISXpressSdk.InvalidSchemaException
Accusoft.ISISXpressSdk.InvalidSettingException
Accusoft.ISISXpressSdk.IsisDriverException
Accusoft.ISISXpressSdk.OutOfMemoryException
Accusoft.ISISXpressSdk.OutOfRangeException
Accusoft.ISISXpressSdk.SaveTypeException
Accusoft.ISISXpressSdk.ScannerLoadedException
Accusoft.ISISXpressSdk.SequenceException
Accusoft.ISISXpressSdk.SettingUnavailableException
Accusoft.ISISXpressSdk.StringTooLongException

See Also

Reference

IsisXpressLibraryException Members
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.ISISXpress5.Net
IsisXpressLibraryException Class Members
See Also Properties Methods Send Feedback
Accusoft.ISISXpressSdk Namespace : IsisXpressLibraryException Class

Glossary Item Box

The following tables list the members exposed by IsisXpressLibraryException.

Public Constructors

 | Name | Description
Public Constructor | IsisXpressLibraryException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the number or ID of the specific error that occurred.
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

IsisXpressLibraryException Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.ISISXpress5.Net
IsisXpressLibraryException Class Methods
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : IsisXpressLibraryException Class

Glossary Item Box

For a list of all members of this type, see IsisXpressLibraryException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

IsisXpressLibraryException Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
IsisXpressLibraryException Constructor
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > IsisXpressLibraryException Class : IsisXpressLibraryException Constructor

Glossary Item Box

Overload List

Overload | Description
IsisXpressLibraryException Constructor() | The main constructor for the ISIS Xpress component exceptions.
IsisXpressLibraryException Constructor(Int32) | An IsisXpressLibraryException constructor which allows passing in an error number.
IsisXpressLibraryException Constructor(String) | An IsisXpressLibraryException constructor which allows passing in an error message.
IsisXpressLibraryException Constructor(Int32,String) | An IsisXpressLibraryException constructor which allows passing in an error number and an error message.
IsisXpressLibraryException Constructor(String,Exception) | An IsisXpressLibraryException constructor which allows passing in an error message and an inner exception.
IsisXpressLibraryException Constructor(SerializationInfo,StreamingContext) | An IsisXpressLibraryException constructor which allows passing in info and streaming content.

See Also

Reference

IsisXpressLibraryException Class
IsisXpressLibraryException Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
IsisXpressLibraryException Constructor()
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > IsisXpressLibraryException Class > IsisXpressLibraryException Constructor : IsisXpressLibraryException Constructor()

Glossary Item Box

The main constructor for the ISIS Xpress component exceptions.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New IsisXpressLibraryException()
public IsisXpressLibraryException()
public: IsisXpressLibraryException();
public:
IsisXpressLibraryException();

See Also

Reference

IsisXpressLibraryException Class
IsisXpressLibraryException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
IsisXpressLibraryException Constructor(Int32)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > IsisXpressLibraryException Class > IsisXpressLibraryException Constructor : IsisXpressLibraryException Constructor(Int32)

errorNumber
An integer value which represents an error number.

Glossary Item Box

An IsisXpressLibraryException constructor which allows passing in an error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New IsisXpressLibraryException(errorNumber)
public IsisXpressLibraryException(
   int errorNumber
)
public: IsisXpressLibraryException(
   int errorNumber
)
public:
IsisXpressLibraryException(
   int errorNumber
)

Parameters

errorNumber
An integer value which represents an error number.

See Also

Reference

IsisXpressLibraryException Class
IsisXpressLibraryException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
IsisXpressLibraryException Constructor(String)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > IsisXpressLibraryException Class > IsisXpressLibraryException Constructor : IsisXpressLibraryException Constructor(String)

message
A string value which represents the error message.

Glossary Item Box

An IsisXpressLibraryException constructor which allows passing in an error message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New IsisXpressLibraryException(message)
public IsisXpressLibraryException(
   string message
)
public: IsisXpressLibraryException(
   string* message
)
public:
IsisXpressLibraryException(
   String^ message
)

Parameters

message
A string value which represents the error message.

See Also

Reference

IsisXpressLibraryException Class
IsisXpressLibraryException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
IsisXpressLibraryException Constructor(Int32,String)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > IsisXpressLibraryException Class > IsisXpressLibraryException Constructor : IsisXpressLibraryException Constructor(Int32,String)

errorNumber
An integer value which represents the error numbe.
message
A string value which represents the error message.

Glossary Item Box

An IsisXpressLibraryException constructor which allows passing in an error number and an error message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New IsisXpressLibraryException(errorNumber, message)
public IsisXpressLibraryException(
   int errorNumber,
   string message
)
public: IsisXpressLibraryException(
   int errorNumber,
   string* message
)
public:
IsisXpressLibraryException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer value which represents the error numbe.
message
A string value which represents the error message.

See Also

Reference

IsisXpressLibraryException Class
IsisXpressLibraryException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
IsisXpressLibraryException Constructor(String,Exception)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > IsisXpressLibraryException Class > IsisXpressLibraryException Constructor : IsisXpressLibraryException Constructor(String,Exception)

message
A string which represents an error message.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

Glossary Item Box

An IsisXpressLibraryException constructor which allows passing in an error message and an inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New IsisXpressLibraryException(message, innerException)
public IsisXpressLibraryException(
   string message,
   Exception innerException
)
public: IsisXpressLibraryException(
   string* message,
   Exception* innerException
)
public:
IsisXpressLibraryException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string which represents an error message.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

See Also

Reference

IsisXpressLibraryException Class
IsisXpressLibraryException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
IsisXpressLibraryException Constructor(SerializationInfo,StreamingContext)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > IsisXpressLibraryException Class > IsisXpressLibraryException Constructor : IsisXpressLibraryException Constructor(SerializationInfo,StreamingContext)

info
System.Runtime.Serialization.SerializationInfo which holds all the data needed to serialize or deserialize an object.
context
content which describes the source and destination of a given serialized stream.

Glossary Item Box

An IsisXpressLibraryException constructor which allows passing in info and streaming content.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Protected Function New( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
'Usage

Dim info As SerializationInfo
Dim context As StreamingContext

Dim instance As New IsisXpressLibraryException(info, context)
protected IsisXpressLibraryException(
   SerializationInfo info,
   StreamingContext context
)
protected: IsisXpressLibraryException(
   SerializationInfo* info,
   StreamingContext context
)
protected:
IsisXpressLibraryException(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
System.Runtime.Serialization.SerializationInfo which holds all the data needed to serialize or deserialize an object.
context
content which describes the source and destination of a given serialized stream.

See Also

Reference

IsisXpressLibraryException Class
IsisXpressLibraryException Members
Overload List


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.ISISXpress5.Net
IsisXpressLibraryException Class Properties
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : IsisXpressLibraryException Class

Glossary Item Box

For a list of all members of this type, see IsisXpressLibraryException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the number or ID of the specific error that occurred.
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Top

See Also

Reference

IsisXpressLibraryException Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
Number Property
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > IsisXpressLibraryException Class : Number Property

Glossary Item Box

Gets the number or ID of the specific error that occurred.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property Number As Integer
'Usage

Dim instance As IsisXpressLibraryException
Dim value As Integer

value = instance.Number
public int Number {get;}
public: __property int get_Number();
public:
property int Number {
   int get();
}

Property Value

An integer value which represents the number.

See Also

Reference

IsisXpressLibraryException Class
IsisXpressLibraryException Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
Licensing Class
Members See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : Licensing Class

Glossary Item Box

This class implements the licensing for the ISIS Xpress component.

Object Model

Licensing Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Class Licensing
'Usage

Dim instance As Licensing
public class Licensing
public __gc class Licensing
public ref class Licensing

Inheritance Hierarchy

System.Object
Accusoft.ISISXpressSdk.Licensing

See Also

Reference

Licensing Members
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.ISISXpress5.Net
Licensing Class Members
See Also Properties Methods Send Feedback
Accusoft.ISISXpressSdk Namespace : Licensing Class

Glossary Item Box

The following tables list the members exposed by Licensing.

Public Constructors

 | Name | Description
Public Constructor | Licensing Constructor | The main constructor to initialize the licensing with a given instance ID.
Top

Public Properties

 | Name | Description
Public Property | EvaluationMode | Gets and sets the EvaluationChoice enumeration value for the control.
Top

Public Methods

 | Name | Description
Public Method | SetOEMLicenseKey | Sets the ISIS Xpress control runtime OEM license key required for OEM licensing.
Public Method | SetSolutionKey | Sets the ISIS Xpress control runtime license deployment key.
Public Method | SetSolutionName | Sets the ISIS Xpress control runtime license deployment solution name.
Top

See Also

Reference

Licensing Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
Licensing Constructor
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Licensing Class : Licensing Constructor

instanceId
An integer value which represents the ISIS Xpress instance ID.

Glossary Item Box

The main constructor to initialize the licensing with a given instance ID.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal instanceId As IntPtr _
)
'Usage

Dim instanceId As IntPtr

Dim instance As New Licensing(instanceId)
public Licensing(
   IntPtr instanceId
)
public: Licensing(
   IntPtr instanceId
)
public:
Licensing(
   IntPtr instanceId
)

Parameters

instanceId
An integer value which represents the ISIS Xpress instance ID.

See Also

Reference

Licensing Class
Licensing Members


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.ISISXpress5.Net
Licensing Class Methods
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : Licensing Class

Glossary Item Box

For a list of all members of this type, see Licensing members.

Public Methods

 | Name | Description
Public Method | SetOEMLicenseKey | Sets the ISIS Xpress control runtime OEM license key required for OEM licensing.
Public Method | SetSolutionKey | Sets the ISIS Xpress control runtime license deployment key.
Public Method | SetSolutionName | Sets the ISIS Xpress control runtime license deployment solution name.
Top

See Also

Reference

Licensing Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
SetOEMLicenseKey Method
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Licensing Class : SetOEMLicenseKey Method

oemKey
The OEM license key required for OEM licensing.

Glossary Item Box

Sets the ISIS Xpress control runtime OEM license key required for OEM licensing.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub SetOEMLicenseKey( _
   ByVal oemKey As String _
)
'Usage

Dim instance As Licensing
Dim oemKey As String

instance.SetOEMLicenseKey(oemKey)
public void SetOEMLicenseKey(
   string oemKey
)
public: void SetOEMLicenseKey(
   string* oemKey
)
public:
void SetOEMLicenseKey(
   String^ oemKey
)

Parameters

oemKey
The OEM license key required for OEM licensing.

Remarks

When OEM runtime licenses are purchased, the OEM license key is provided in the purchase confirmation email.

See Also

Reference

Licensing Class
Licensing Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
SetSolutionKey Method
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Licensing Class : SetSolutionKey Method

key1
Unlock key 1
key2
Unlock key 2
key3
Unlock key 3
key4
Unlock key 4

Glossary Item Box

Sets the ISIS Xpress control runtime license deployment key.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub SetSolutionKey( _
   ByVal key1 As Long, _
   ByVal key2 As Long, _
   ByVal key3 As Long, _
   ByVal key4 As Long _
)
'Usage

Dim instance As Licensing
Dim key1 As Long
Dim key2 As Long
Dim key3 As Long
Dim key4 As Long

instance.SetSolutionKey(key1, key2, key3, key4)
public void SetSolutionKey(
   long key1,
   long key2,
   long key3,
   long key4
)
public: void SetSolutionKey(
   long key1,
   long key2,
   long key3,
   long key4
)
public:
void SetSolutionKey(
   int64 key1,
   int64 key2,
   int64 key3,
   int64 key4
)

Parameters

key1
Unlock key 1
key2
Unlock key 2
key3
Unlock key 3
key4
Unlock key 4

Remarks

This is the solution key required for all runtime licensing. The four integers are provided at the time of purchase of the runtime licenses along with the solution name, which is set with the SetSolutionName method.

See Also

Reference

Licensing Class
Licensing Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
SetSolutionName Method
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Licensing Class : SetSolutionName Method

solutionName
The solution name.

Glossary Item Box

Sets the ISIS Xpress control runtime license deployment solution name.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub SetSolutionName( _
   ByVal solutionName As String _
)
'Usage

Dim instance As Licensing
Dim solutionName As String

instance.SetSolutionName(solutionName)
public void SetSolutionName(
   string solutionName
)
public: void SetSolutionName(
   string* solutionName
)
public:
void SetSolutionName(
   String^ solutionName
)

Parameters

solutionName
The solution name.

Remarks

This is the name of the runtime license solution. The solution name is provided in the purchase confirmation email when runtime licenses are purchased.

See Also

Reference

Licensing Class
Licensing Members


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.ISISXpress5.Net
Licensing Class Properties
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : Licensing Class

Glossary Item Box

For a list of all members of this type, see Licensing members.

Public Properties

 | Name | Description
Public Property | EvaluationMode | Gets and sets the EvaluationChoice enumeration value for the control.
Top

See Also

Reference

Licensing Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
EvaluationMode Property
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Licensing Class : EvaluationMode Property

Glossary Item Box

Gets and sets the EvaluationChoice enumeration value for the control.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property EvaluationMode As EvaluationChoice
'Usage

Dim instance As Licensing
Dim value As EvaluationChoice

instance.EvaluationMode = value

value = instance.EvaluationMode
public EvaluationChoice EvaluationMode {get; set;}
public: __property EvaluationChoice get_EvaluationMode();
public: __property void set_EvaluationMode(
   EvaluationChoice value
);
public:
property EvaluationChoice EvaluationMode {
   EvaluationChoice get();
   void set (    EvaluationChoice value);
}

Property Value

The EvaluationChoice enumeration value.

See Also

Reference

Licensing Class
Licensing Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
OutOfMemoryException Class
Members See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : OutOfMemoryException Class

Glossary Item Box

This class implements the OutOfMemoryExceptions to be thrown when there is not enough memory available.

Object Model

OutOfMemoryException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class OutOfMemoryException
   Inherits IsisXpressLibraryException
'Usage

Dim instance As OutOfMemoryException
[SerializableAttribute()]
public sealed class OutOfMemoryException : IsisXpressLibraryException
[SerializableAttribute()]
public __gc __sealed class OutOfMemoryException : public IsisXpressLibraryException
[SerializableAttribute()]
public ref class OutOfMemoryException sealed : public IsisXpressLibraryException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.ISISXpressSdk.IsisXpressLibraryException
Accusoft.ISISXpressSdk.OutOfMemoryException

See Also

Reference

OutOfMemoryException Members
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.ISISXpress5.Net
OutOfMemoryException Class Members
See Also Properties Methods Send Feedback
Accusoft.ISISXpressSdk Namespace : OutOfMemoryException Class

Glossary Item Box

The following tables list the members exposed by OutOfMemoryException.

Public Constructors

 | Name | Description
Public Constructor | OutOfMemoryException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the number or ID of the specific error that occurred. (Inherited from Accusoft.ISISXpressSdk.IsisXpressLibraryException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

OutOfMemoryException Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.ISISXpress5.Net
OutOfMemoryException Class Methods
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : OutOfMemoryException Class

Glossary Item Box

For a list of all members of this type, see OutOfMemoryException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

OutOfMemoryException Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.ISISXpress5.Net
OutOfMemoryException Class Properties
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : OutOfMemoryException Class

Glossary Item Box

For a list of all members of this type, see OutOfMemoryException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the number or ID of the specific error that occurred. (Inherited from Accusoft.ISISXpressSdk.IsisXpressLibraryException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Top

See Also

Reference

OutOfMemoryException Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
OutOfMemoryException Constructor
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > OutOfMemoryException Class : OutOfMemoryException Constructor

Glossary Item Box

Overload List

Overload | Description
OutOfMemoryException Constructor() | The main constructor to thrown when there is not enough memory.
OutOfMemoryException Constructor(Int32) | An OutOfMemoryException which allows passing in an error number.
OutOfMemoryException Constructor(String) | An OutOfMemoryException which allows passing in an error message.
OutOfMemoryException Constructor(Int32,String) | An OutOfMemoryException which allows passing in an error number and an error message.
OutOfMemoryException Constructor(String,Exception) | An OutOfMemoryException which allows passing in an error message and an inner exception.

See Also

Reference

OutOfMemoryException Class
OutOfMemoryException Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
OutOfMemoryException Constructor()
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > OutOfMemoryException Class > OutOfMemoryException Constructor : OutOfMemoryException Constructor()

Glossary Item Box

The main constructor to thrown when there is not enough memory.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New OutOfMemoryException()
public OutOfMemoryException()
public: OutOfMemoryException();
public:
OutOfMemoryException();

See Also

Reference

OutOfMemoryException Class
OutOfMemoryException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
OutOfMemoryException Constructor(Int32)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > OutOfMemoryException Class > OutOfMemoryException Constructor : OutOfMemoryException Constructor(Int32)

errorNumber
An integer value which represents the error number.

Glossary Item Box

An OutOfMemoryException which allows passing in an error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New OutOfMemoryException(errorNumber)
public OutOfMemoryException(
   int errorNumber
)
public: OutOfMemoryException(
   int errorNumber
)
public:
OutOfMemoryException(
   int errorNumber
)

Parameters

errorNumber
An integer value which represents the error number.

See Also

Reference

OutOfMemoryException Class
OutOfMemoryException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
OutOfMemoryException Constructor(String)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > OutOfMemoryException Class > OutOfMemoryException Constructor : OutOfMemoryException Constructor(String)

message
A string value which represents the error message.

Glossary Item Box

An OutOfMemoryException which allows passing in an error message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New OutOfMemoryException(message)
public OutOfMemoryException(
   string message
)
public: OutOfMemoryException(
   string* message
)
public:
OutOfMemoryException(
   String^ message
)

Parameters

message
A string value which represents the error message.

See Also

Reference

OutOfMemoryException Class
OutOfMemoryException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
OutOfMemoryException Constructor(Int32,String)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > OutOfMemoryException Class > OutOfMemoryException Constructor : OutOfMemoryException Constructor(Int32,String)

errorNumber
An integer value which represents the error number.
message
A string value which represents the error message.

Glossary Item Box

An OutOfMemoryException which allows passing in an error number and an error message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New OutOfMemoryException(errorNumber, message)
public OutOfMemoryException(
   int errorNumber,
   string message
)
public: OutOfMemoryException(
   int errorNumber,
   string* message
)
public:
OutOfMemoryException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer value which represents the error number.
message
A string value which represents the error message.

See Also

Reference

OutOfMemoryException Class
OutOfMemoryException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
OutOfMemoryException Constructor(String,Exception)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > OutOfMemoryException Class > OutOfMemoryException Constructor : OutOfMemoryException Constructor(String,Exception)

message
A string value which represents the error message.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

Glossary Item Box

An OutOfMemoryException which allows passing in an error message and an inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New OutOfMemoryException(message, innerException)
public OutOfMemoryException(
   string message,
   Exception innerException
)
public: OutOfMemoryException(
   string* message,
   Exception* innerException
)
public:
OutOfMemoryException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string value which represents the error message.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

See Also

Reference

OutOfMemoryException Class
OutOfMemoryException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
OutOfRangeException Class
Members See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : OutOfRangeException Class

Glossary Item Box

This class implements the OutOfRangeExceptions when a parameter or index is out of range.

Object Model

OutOfRangeException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class OutOfRangeException
   Inherits IsisXpressLibraryException
'Usage

Dim instance As OutOfRangeException
[SerializableAttribute()]
public sealed class OutOfRangeException : IsisXpressLibraryException
[SerializableAttribute()]
public __gc __sealed class OutOfRangeException : public IsisXpressLibraryException
[SerializableAttribute()]
public ref class OutOfRangeException sealed : public IsisXpressLibraryException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.ISISXpressSdk.IsisXpressLibraryException
Accusoft.ISISXpressSdk.OutOfRangeException

See Also

Reference

OutOfRangeException Members
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.ISISXpress5.Net
OutOfRangeException Class Members
See Also Properties Methods Send Feedback
Accusoft.ISISXpressSdk Namespace : OutOfRangeException Class

Glossary Item Box

The following tables list the members exposed by OutOfRangeException.

Public Constructors

 | Name | Description
Public Constructor | OutOfRangeException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the number or ID of the specific error that occurred. (Inherited from Accusoft.ISISXpressSdk.IsisXpressLibraryException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

OutOfRangeException Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.ISISXpress5.Net
OutOfRangeException Class Methods
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : OutOfRangeException Class

Glossary Item Box

For a list of all members of this type, see OutOfRangeException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

OutOfRangeException Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.ISISXpress5.Net
OutOfRangeException Class Properties
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : OutOfRangeException Class

Glossary Item Box

For a list of all members of this type, see OutOfRangeException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the number or ID of the specific error that occurred. (Inherited from Accusoft.ISISXpressSdk.IsisXpressLibraryException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Top

See Also

Reference

OutOfRangeException Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
OutOfRangeException Constructor
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > OutOfRangeException Class : OutOfRangeException Constructor

Glossary Item Box

Overload List

Overload | Description
OutOfRangeException Constructor() | The main constructor for throwing exceptions when a parameter or index is out of range.
OutOfRangeException Constructor(Int32) | An OutOfRangeException exception which allows passing in an error number.
OutOfRangeException Constructor(String) | An OutOfRangeException which allows passing in an error message.
OutOfRangeException Constructor(Int32,String) | An OutOfRangeException exception which allows passing in an error number and an error message.
OutOfRangeException Constructor(String,Exception) | An OutOfRangeException exception which allows passing in an error message and an inner exception.

See Also

Reference

OutOfRangeException Class
OutOfRangeException Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
OutOfRangeException Constructor()
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > OutOfRangeException Class > OutOfRangeException Constructor : OutOfRangeException Constructor()

Glossary Item Box

The main constructor for throwing exceptions when a parameter or index is out of range.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New OutOfRangeException()
public OutOfRangeException()
public: OutOfRangeException();
public:
OutOfRangeException();

See Also

Reference

OutOfRangeException Class
OutOfRangeException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
OutOfRangeException Constructor(Int32)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > OutOfRangeException Class > OutOfRangeException Constructor : OutOfRangeException Constructor(Int32)

errorNumber
An integer value which represents the error number.

Glossary Item Box

An OutOfRangeException exception which allows passing in an error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New OutOfRangeException(errorNumber)
public OutOfRangeException(
   int errorNumber
)
public: OutOfRangeException(
   int errorNumber
)
public:
OutOfRangeException(
   int errorNumber
)

Parameters

errorNumber
An integer value which represents the error number.

See Also

Reference

OutOfRangeException Class
OutOfRangeException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
OutOfRangeException Constructor(String)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > OutOfRangeException Class > OutOfRangeException Constructor : OutOfRangeException Constructor(String)

message
A string value which represents an error message.

Glossary Item Box

An OutOfRangeException which allows passing in an error message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New OutOfRangeException(message)
public OutOfRangeException(
   string message
)
public: OutOfRangeException(
   string* message
)
public:
OutOfRangeException(
   String^ message
)

Parameters

message
A string value which represents an error message.

See Also

Reference

OutOfRangeException Class
OutOfRangeException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
OutOfRangeException Constructor(Int32,String)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > OutOfRangeException Class > OutOfRangeException Constructor : OutOfRangeException Constructor(Int32,String)

errorNumber
An integer value which represents the error number.
message
A string value which represents the error message.

Glossary Item Box

An OutOfRangeException exception which allows passing in an error number and an error message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New OutOfRangeException(errorNumber, message)
public OutOfRangeException(
   int errorNumber,
   string message
)
public: OutOfRangeException(
   int errorNumber,
   string* message
)
public:
OutOfRangeException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer value which represents the error number.
message
A string value which represents the error message.

See Also

Reference

OutOfRangeException Class
OutOfRangeException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
OutOfRangeException Constructor(String,Exception)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > OutOfRangeException Class > OutOfRangeException Constructor : OutOfRangeException Constructor(String,Exception)

message
A string value which represents an error message.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

Glossary Item Box

An OutOfRangeException exception which allows passing in an error message and an inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New OutOfRangeException(message, innerException)
public OutOfRangeException(
   string message,
   Exception innerException
)
public: OutOfRangeException(
   string* message,
   Exception* innerException
)
public:
OutOfRangeException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string value which represents an error message.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

See Also

Reference

OutOfRangeException Class
OutOfRangeException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
Output Class
Members See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : Output Class

Glossary Item Box

This class implemented how scanned images are saved.

Object Model

Output Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Class Output
'Usage

Dim instance As Output
public class Output
public __gc class Output
public ref class Output

Inheritance Hierarchy

System.Object
Accusoft.ISISXpressSdk.Output

See Also

Reference

Output Members
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.ISISXpress5.Net
Output Class Members
See Also Properties Methods Send Feedback
Accusoft.ISISXpressSdk Namespace : Output Class

Glossary Item Box

The following tables list the members exposed by Output.

Public Constructors

 | Name | Description
Public Constructor | Output Constructor | The main constructor for the Output class which takes in an instance ID for the ISIS Xpress component.
Top

Public Properties

 | Name | Description
Public Property | CreateDib | Gets and sets an indicator if a DIB is created while scanning so the ToHdib property is valid after each use.
Public Property | CreateFiles | Gets and sets an indicator if the scanned in data is saved to a file using the full path and filename specified in the Filename property.
Public Property | DibBitsPerPixel | Get the Bits per pixel for the current scanned image. An integer value with the current bits per pixel
Public Property | DibFlip | Gets and sets an indicator whether to flip the DIB that is stored in the ToHdib property.
Public Property | DibHeight | Gets the height of the current scanned image contained in the DIB represented by the ToHdib property.
Public Property | DibWidth | Gets the width of the current scanned image contained in the DIB represented by the ToHdib property.
Public Property | Directory | Gets and sets the base directory used for the file naming schema during batch scans when the UseSchema property is set to true.
Public Property | Filename | Gets and sets the full path and filename where the scanned image is saved.
Public Property | FileSchema | Gets and sets the file schema used to generate filenames during batch scanning.
Public Property | FileType | Gets and sets the file format to use when saving images.
Public Property | MultiplePages | Gets and sets an indicator if the TIFF file should be saved as a multi-page TIFF file.
Public Property | Root | Gets and sets the root prefix used to generate filenames during a batch scan when the UseSchema property is set to true.
Public Property | UseSchema | Gets and sets an indicator if a naming schema is used during batch scanning.
Top

Public Methods

 | Name | Description
Public Method | CopyTo | Designed to make passing image data between different Accusoft components easier, this method makes a copy of this object's image data and gives the new image data to another object which can be defined in a different Accusoft assembly. When finished, both this object and the destination object will contain separate copies of the same image data.
Public Method | ToBitmap | Gets a System.Drawing.Bitmap for the current scanned image.
Public Method | ToHBitmap | Gets a HBITMAP handle for the current scanned image.
Public Method | ToHdib | Gets a handle to an DIB (Device Independent Bitmap) for the current scanned image.
Public Method | TransferTo | Designed to make passing image data between different Accusoft components easier, this method transfers this object's image data to another object which can be defined in a different Accusoft assembly. When finished, this object will no longer contain image data; the image data will be owned by the destination object.
Top

See Also

Reference

Output Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
Output Constructor
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Output Class : Output Constructor

instanceId
An integer value which represents an ISIS Xpress instance ID.

Glossary Item Box

The main constructor for the Output class which takes in an instance ID for the ISIS Xpress component.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal instanceId As IntPtr _
)
'Usage

Dim instanceId As IntPtr

Dim instance As New Output(instanceId)
public Output(
   IntPtr instanceId
)
public: Output(
   IntPtr instanceId
)
public:
Output(
   IntPtr instanceId
)

Parameters

instanceId
An integer value which represents an ISIS Xpress instance ID.

See Also

Reference

Output Class
Output Members


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.ISISXpress5.Net
Output Class Methods
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : Output Class

Glossary Item Box

For a list of all members of this type, see Output members.

Public Methods

 | Name | Description
Public Method | CopyTo | Designed to make passing image data between different Accusoft components easier, this method makes a copy of this object's image data and gives the new image data to another object which can be defined in a different Accusoft assembly. When finished, both this object and the destination object will contain separate copies of the same image data.
Public Method | ToBitmap | Gets a System.Drawing.Bitmap for the current scanned image.
Public Method | ToHBitmap | Gets a HBITMAP handle for the current scanned image.
Public Method | ToHdib | Gets a handle to an DIB (Device Independent Bitmap) for the current scanned image.
Public Method | TransferTo | Designed to make passing image data between different Accusoft components easier, this method transfers this object's image data to another object which can be defined in a different Accusoft assembly. When finished, this object will no longer contain image data; the image data will be owned by the destination object.
Top

See Also

Reference

Output Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
CopyTo Method
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Output Class : CopyTo Method

Destination
The destination object.

Glossary Item Box

Designed to make passing image data between different Accusoft components easier, this method makes a copy of this object's image data and gives the new image data to another object which can be defined in a different Accusoft assembly. When finished, both this object and the destination object will contain separate copies of the same image data.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub CopyTo( _
   ByVal Destination As Object _
)
'Usage

Dim instance As Output
Dim Destination As Object

instance.CopyTo(Destination)
public void CopyTo(
   object Destination
)
public: void CopyTo(
   Object* Destination
)
public:
void CopyTo(
   Object^ Destination
)

Parameters

Destination
The destination object.

Exceptions

Exception | Description
System.ArgumentException | Thrown when the destination object does not support being copied to.

Remarks

Not all object types are valid destinations for this method. Refer to the documentation of a particular class to see if it officially supports being the destination of a CopyTo method.

See Also

Reference

Output Class
Output Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
ToBitmap Method
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Output Class : ToBitmap Method

Glossary Item Box

Gets a System.Drawing.Bitmap for the current scanned image.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function ToBitmap() As Bitmap
'Usage

Dim instance As Output
Dim value As Bitmap

value = instance.ToBitmap()
public Bitmap ToBitmap()
public: Bitmap* ToBitmap();
public:
Bitmap^ ToBitmap();

Return Value

A System.Drawing.Bitmap.

Remarks

The image may only be retrived once for each scanned image.

Note: This property throws a DibUnavailableException if the image is not available.

See Also

Reference

Output Class
Output Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
ToHBitmap Method
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Output Class : ToHBitmap Method

Glossary Item Box

Gets a HBITMAP handle for the current scanned image.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function ToHBitmap() As IntPtr
'Usage

Dim instance As Output
Dim value As IntPtr

value = instance.ToHBitmap()
public IntPtr ToHBitmap()
public: IntPtr ToHBitmap();
public:
IntPtr ToHBitmap();

Return Value

A HBITMAP.

Remarks

The IsisXpress object transfers ownership of the HBITMAP to the caller.

It is the callers responsiblity to free the HBITMAP.

Note: The image may only be retrived once for each scanned image.

Note: This property throws a DibUnavailableException if the image is not available.

See Also

Reference

Output Class
Output Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
ToHdib Method
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Output Class : ToHdib Method

Glossary Item Box

Gets a handle to an DIB (Device Independent Bitmap) for the current scanned image.

Overload List

Overload | Description
ToHdib | Gets a handle to an DIB (Device Independent Bitmap) for the current scanned image.

See Also

Reference

Output Class
Output Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
ToHdib() Method
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Output Class : ToHdib() Method

Glossary Item Box

Gets a handle to an DIB (Device Independent Bitmap) for the current scanned image.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function ToHdib() As IntPtr
'Usage

Dim instance As Output
Dim value As IntPtr

value = instance.ToHdib()
public IntPtr ToHdib()
public: IntPtr ToHdib();
public:
IntPtr ToHdib();

Return Value

A HDIB.

Remarks

The IsisXpress object transfers ownership of the HDIB to the caller.

It is the callers responsiblity to free the HDIB.

Note: The image may only be retrived once for each scanned image.

Note: This property throws a DibUnavailableException if the image is not available.

See Also

Reference

Output Class
Output Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
TransferTo Method
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Output Class : TransferTo Method

Destination
The desintation object.

Glossary Item Box

Designed to make passing image data between different Accusoft components easier, this method transfers this object's image data to another object which can be defined in a different Accusoft assembly. When finished, this object will no longer contain image data; the image data will be owned by the destination object.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub TransferTo( _
   ByVal Destination As Object _
)
'Usage

Dim instance As Output
Dim Destination As Object

instance.TransferTo(Destination)
public void TransferTo(
   object Destination
)
public: void TransferTo(
   Object* Destination
)
public:
void TransferTo(
   Object^ Destination
)

Parameters

Destination
The desintation object.

Exceptions

Exception | Description
System.ArgumentException | Thrown when the destination object does not support being transferred to.

Remarks

Not all object types are valid destinations for this method. Refer to the documentation of a particular class to see if it officially supports being the destination of a TransferTo method.

See Also

Reference

Output Class
Output Members


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.ISISXpress5.Net
Output Class Properties
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : Output Class

Glossary Item Box

For a list of all members of this type, see Output members.

Public Properties

 | Name | Description
Public Property | CreateDib | Gets and sets an indicator if a DIB is created while scanning so the ToHdib property is valid after each use.
Public Property | CreateFiles | Gets and sets an indicator if the scanned in data is saved to a file using the full path and filename specified in the Filename property.
Public Property | DibBitsPerPixel | Get the Bits per pixel for the current scanned image. An integer value with the current bits per pixel
Public Property | DibFlip | Gets and sets an indicator whether to flip the DIB that is stored in the ToHdib property.
Public Property | DibHeight | Gets the height of the current scanned image contained in the DIB represented by the ToHdib property.
Public Property | DibWidth | Gets the width of the current scanned image contained in the DIB represented by the ToHdib property.
Public Property | Directory | Gets and sets the base directory used for the file naming schema during batch scans when the UseSchema property is set to true.
Public Property | Filename | Gets and sets the full path and filename where the scanned image is saved.
Public Property | FileSchema | Gets and sets the file schema used to generate filenames during batch scanning.
Public Property | FileType | Gets and sets the file format to use when saving images.
Public Property | MultiplePages | Gets and sets an indicator if the TIFF file should be saved as a multi-page TIFF file.
Public Property | Root | Gets and sets the root prefix used to generate filenames during a batch scan when the UseSchema property is set to true.
Public Property | UseSchema | Gets and sets an indicator if a naming schema is used during batch scanning.
Top

See Also

Reference

Output Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
CreateDib Property
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Output Class : CreateDib Property

Glossary Item Box

Gets and sets an indicator if a DIB is created while scanning so the ToHdib property is valid after each use.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property CreateDib As Boolean
'Usage

Dim instance As Output
Dim value As Boolean

instance.CreateDib = value

value = instance.CreateDib
public bool CreateDib {get; set;}
public: __property bool get_CreateDib();
public: __property void set_CreateDib(
   bool value
);
public:
property bool CreateDib {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true if a DIB should be created or false if a DIB should not be created.

Remarks

The default value is false.

This DIB can only be created if the Scanner.UseCompression property is set to false. When hardware compression is enabled, the scanner sends compressed data to the computer and this cannot be used to construct a DIB.

See Also

Reference

Output Class
Output Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
CreateFiles Property
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Output Class : CreateFiles Property

Glossary Item Box

Gets and sets an indicator if the scanned in data is saved to a file using the full path and filename specified in the Filename property.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property CreateFiles As Boolean
'Usage

Dim instance As Output
Dim value As Boolean

instance.CreateFiles = value

value = instance.CreateFiles
public bool CreateFiles {get; set;}
public: __property bool get_CreateFiles();
public: __property void set_CreateFiles(
   bool value
);
public:
property bool CreateFiles {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true if the scanned in data is saved to a file. Otherwise, falseis returned.

Remarks

The default value is true.

Note: Set this value to false only if a DIB is desired. It is possible to set both the CreateDib and the CreateFiles properties to false but then there is no output.

See Also

Reference

Output Class
Output Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
DibBitsPerPixel Property
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Output Class : DibBitsPerPixel Property

Glossary Item Box

Get the Bits per pixel for the current scanned image. An integer value with the current bits per pixel

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property DibBitsPerPixel As Integer
'Usage

Dim instance As Output
Dim value As Integer

value = instance.DibBitsPerPixel
public int DibBitsPerPixel {get;}
public: __property int get_DibBitsPerPixel();
public:
property int DibBitsPerPixel {
   int get();
}

See Also

Reference

Output Class
Output Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
DibFlip Property
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Output Class : DibFlip Property

Glossary Item Box

Gets and sets an indicator whether to flip the DIB that is stored in the ToHdib property.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property DibFlip As Boolean
'Usage

Dim instance As Output
Dim value As Boolean

instance.DibFlip = value

value = instance.DibFlip
public bool DibFlip {get; set;}
public: __property bool get_DibFlip();
public: __property void set_DibFlip(
   bool value
);
public:
property bool DibFlip {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true to flip the DIB. Otherwise, false is returned.

Remarks

This property only affects the DIB that is stored in the ToHdib property and has no bearing on saved files.

See Also

Reference

Output Class
Output Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
DibHeight Property
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Output Class : DibHeight Property

Glossary Item Box

Gets the height of the current scanned image contained in the DIB represented by the ToHdib property.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property DibHeight As Integer
'Usage

Dim instance As Output
Dim value As Integer

value = instance.DibHeight
public int DibHeight {get;}
public: __property int get_DibHeight();
public:
property int DibHeight {
   int get();
}

Property Value

An integer value which represents the height of the current scanned image.

Remarks

This property is used to obtain the height of the current scanned image. This value may be different from the ScanSettingInfo.ImageLength scan setting if a scanner's page size detection setting is enabled. DibHeight is available at runtime in the IsisXpress.Scanned events and it is available until the ToHdib property is no longer valid.

See Also

Reference

Output Class
Output Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
DibWidth Property
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Output Class : DibWidth Property

Glossary Item Box

Gets the width of the current scanned image contained in the DIB represented by the ToHdib property.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property DibWidth As Integer
'Usage

Dim instance As Output
Dim value As Integer

value = instance.DibWidth
public int DibWidth {get;}
public: __property int get_DibWidth();
public:
property int DibWidth {
   int get();
}

Property Value

An integer value which represents the width of the current scanned image.

Remarks

This property is used to obtain the width of the current scanned image. This value may be different from the ScanSettingInfo.ImageWidth scan setting if a scanner's page size detection setting is enabled. DibWidth is available at runtime in the IsisXpress.Scanned events and it is available until the ToHdib property is no longer valid.

See Also

Reference

Output Class
Output Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
Directory Property
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Output Class : Directory Property

Glossary Item Box

Gets and sets the base directory used for the file naming schema during batch scans when the UseSchema property is set to true.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property Directory As String
'Usage

Dim instance As Output
Dim value As String

instance.Directory = value

value = instance.Directory
public string Directory {get; set;}
public: __property string* get_Directory();
public: __property void set_Directory(
   string* value
);
public:
property String^ Directory {
   String^ get();
   void set (    String^ value);
}

Property Value

A string which represents the file name for the schema.

See Also

Reference

Output Class
Output Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
Filename Property
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Output Class : Filename Property

Glossary Item Box

Gets and sets the full path and filename where the scanned image is saved.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property Filename As String
'Usage

Dim instance As Output
Dim value As String

instance.Filename = value

value = instance.Filename
public string Filename {get; set;}
public: __property string* get_Filename();
public: __property void set_Filename(
   string* value
);
public:
property String^ Filename {
   String^ get();
   void set (    String^ value);
}

Property Value

A string which represents the path and name.

Remarks

The default value is an empty string "".

If the UseSchema property is set to true, then this property is modified before each scan and can be checked or modified in the IsisXpress.Scanning event.

See Also

Reference

Output Class
Output Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
FileSchema Property
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Output Class : FileSchema Property

Glossary Item Box

Gets and sets the file schema used to generate filenames during batch scanning.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property FileSchema As String
'Usage

Dim instance As Output
Dim value As String

instance.FileSchema = value

value = instance.FileSchema
public string FileSchema {get; set;}
public: __property string* get_FileSchema();
public: __property void set_FileSchema(
   string* value
);
public:
property String^ FileSchema {
   String^ get();
   void set (    String^ value);
}

Property Value

A string which represents the file schema.

Remarks

The following symbols can be used to specify a schema:

  • $ = root
  • # = page number

The following items are example schemas and the files they would generate:

  • $## = file01, file02, etc.
  • $#### = file0001, file0002, etc.

See Also

Reference

Output Class
Output Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
FileType Property
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Output Class : FileType Property

Glossary Item Box

Gets and sets the file format to use when saving images.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property FileType As FileTypeInfo
'Usage

Dim instance As Output
Dim value As FileTypeInfo

instance.FileType = value

value = instance.FileType
public FileTypeInfo FileType {get; set;}
public: __property FileTypeInfo get_FileType();
public: __property void set_FileType(
   FileTypeInfo value
);
public:
property FileTypeInfo FileType {
   FileTypeInfo get();
   void set (    FileTypeInfo value);
}

Property Value

A FileTypeInfo enumeration value option.

Remarks

1 bit (black and white) images can be saved to any of the five TIFF file formats or to the DCX file format. 8 bit (gray scale) images can be saved to the TiffRaw, TiffPackbits or JpegGray file formats. 24 bit (color) images can be saved to the TiffRaw, TiffPackbits or JPEG file formats.

See Also

Reference

Output Class
Output Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
MultiplePages Property
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Output Class : MultiplePages Property

Glossary Item Box

Gets and sets an indicator if the TIFF file should be saved as a multi-page TIFF file.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property MultiplePages As Boolean
'Usage

Dim instance As Output
Dim value As Boolean

instance.MultiplePages = value

value = instance.MultiplePages
public bool MultiplePages {get; set;}
public: __property bool get_MultiplePages();
public: __property void set_MultiplePages(
   bool value
);
public:
property bool MultiplePages {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true to save the TIFF file as a multi-page. Otherwise, false is returned.

Remarks

The default value is false.

Note: This property and the UseSchema property cannot be used at the same time.

See Also

Reference

Output Class
Output Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
Root Property
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Output Class : Root Property

Glossary Item Box

Gets and sets the root prefix used to generate filenames during a batch scan when the UseSchema property is set to true.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property Root As String
'Usage

Dim instance As Output
Dim value As String

instance.Root = value

value = instance.Root
public string Root {get; set;}
public: __property string* get_Root();
public: __property void set_Root(
   string* value
);
public:
property String^ Root {
   String^ get();
   void set (    String^ value);
}

Property Value

A string which represents the root prefix.

Remarks

This property value is "image" if the desired filenames are image01.tif, image02.tif, and etc.

See Also

Reference

Output Class
Output Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
UseSchema Property
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Output Class : UseSchema Property

Glossary Item Box

Gets and sets an indicator if a naming schema is used during batch scanning.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property UseSchema As Boolean
'Usage

Dim instance As Output
Dim value As Boolean

instance.UseSchema = value

value = instance.UseSchema
public bool UseSchema {get; set;}
public: __property bool get_UseSchema();
public: __property void set_UseSchema(
   bool value
);
public:
property bool UseSchema {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true if a naming schema is used. Otherwise, false is returned.

Remarks

The default value is false.

The values of the Directory, Root, and FileSchema properties are used to determine the full path and filenames of the output files.

Note: The MultiplePages property and the UseSchema property cannot be used at the same time.

See Also

Reference

Output Class
Output Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
ProgressEventArgs Class
Members See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : ProgressEventArgs Class

Glossary Item Box

This class implements the event arguments for the IsisXpress.Progress event.

Object Model

ProgressEventArgs Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Class ProgressEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As ProgressEventArgs
public class ProgressEventArgs : System.EventArgs
public __gc class ProgressEventArgs : public System.EventArgs
public ref class ProgressEventArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Accusoft.ISISXpressSdk.ProgressEventArgs

See Also

Reference

ProgressEventArgs Members
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.ISISXpress5.Net
ProgressEventArgs Class Members
See Also Properties Send Feedback
Accusoft.ISISXpressSdk Namespace : ProgressEventArgs Class

Glossary Item Box

The following tables list the members exposed by ProgressEventArgs.

Public Constructors

 | Name | Description
Public Constructor | ProgressEventArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | Percent | Gets the percentage the scan has progressed.
Top

See Also

Reference

ProgressEventArgs Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
ProgressEventArgs Constructor
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > ProgressEventArgs Class : ProgressEventArgs Constructor

Glossary Item Box

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ProgressEventArgs()
public ProgressEventArgs()
public: ProgressEventArgs();
public:
ProgressEventArgs();

See Also

Reference

ProgressEventArgs Class
ProgressEventArgs Members


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.ISISXpress5.Net
ProgressEventArgs Class Properties
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : ProgressEventArgs Class

Glossary Item Box

For a list of all members of this type, see ProgressEventArgs members.

Public Properties

 | Name | Description
Public Property | Percent | Gets the percentage the scan has progressed.
Top

See Also

Reference

ProgressEventArgs Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
Percent Property
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > ProgressEventArgs Class : Percent Property

Glossary Item Box

Gets the percentage the scan has progressed.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property Percent As Integer
'Usage

Dim instance As ProgressEventArgs
Dim value As Integer

instance.Percent = value

value = instance.Percent
public int Percent {get; set;}
public: __property int get_Percent();
public: __property void set_Percent(
   int value
);
public:
property int Percent {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the percentage of completion.

See Also

Reference

ProgressEventArgs Class
ProgressEventArgs Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
RationalType Class
Members See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : RationalType Class

Glossary Item Box

This class implements a rational number with the numerator and denominator stored in their normal form.

Object Model

RationalType Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Class RationalType
'Usage

Dim instance As RationalType
public class RationalType
public __gc class RationalType
public ref class RationalType

Inheritance Hierarchy

System.Object
Accusoft.ISISXpressSdk.RationalType

See Also

Reference

RationalType Members
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.ISISXpress5.Net
RationalType Class Members
See Also Properties Send Feedback
Accusoft.ISISXpressSdk Namespace : RationalType Class

Glossary Item Box

The following tables list the members exposed by RationalType.

Public Constructors

 | Name | Description
Public Constructor | RationalType Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Denominator | Gets and sets the denominator for the rational type.
Public Property | Numerator | Gets and sets the numerator for the rational type.
Top

See Also

Reference

RationalType Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
RationalType Constructor
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > RationalType Class : RationalType Constructor

Glossary Item Box

Overload List

Overload | Description
RationalType Constructor() | The main constructor for the RationalType class.
RationalType Constructor(Int64,Int64) | A RationalType constructor which takes in a numerator and denominator for the rational type.

See Also

Reference

RationalType Class
RationalType Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
RationalType Constructor()
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > RationalType Class > RationalType Constructor : RationalType Constructor()

Glossary Item Box

The main constructor for the RationalType class.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New RationalType()
public RationalType()
public: RationalType();
public:
RationalType();

See Also

Reference

RationalType Class
RationalType Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
RationalType Constructor(Int64,Int64)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > RationalType Class > RationalType Constructor : RationalType Constructor(Int64,Int64)

numerator
An integer value which represents the numerator.
denominator
A long value which represents the denominator.

Glossary Item Box

A RationalType constructor which takes in a numerator and denominator for the rational type.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal numerator As Long, _
   ByVal denominator As Long _
)
'Usage

Dim numerator As Long
Dim denominator As Long

Dim instance As New RationalType(numerator, denominator)
public RationalType(
   long numerator,
   long denominator
)
public: RationalType(
   long numerator,
   long denominator
)
public:
RationalType(
   int64 numerator,
   int64 denominator
)

Parameters

numerator
An integer value which represents the numerator.
denominator
A long value which represents the denominator.

See Also

Reference

RationalType Class
RationalType Members
Overload List


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.ISISXpress5.Net
RationalType Class Properties
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : RationalType Class

Glossary Item Box

For a list of all members of this type, see RationalType members.

Public Properties

 | Name | Description
Public Property | Denominator | Gets and sets the denominator for the rational type.
Public Property | Numerator | Gets and sets the numerator for the rational type.
Top

See Also

Reference

RationalType Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
Denominator Property
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > RationalType Class : Denominator Property

Glossary Item Box

Gets and sets the denominator for the rational type.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property Denominator As Long
'Usage

Dim instance As RationalType
Dim value As Long

instance.Denominator = value

value = instance.Denominator
public long Denominator {get; set;}
public: __property long get_Denominator();
public: __property void set_Denominator(
   long value
);
public:
property int64 Denominator {
   int64 get();
   void set (    int64 value);
}

Property Value

A long value which represents the denominator for the rational type.

See Also

Reference

RationalType Class
RationalType Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
Numerator Property
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > RationalType Class : Numerator Property

Glossary Item Box

Gets and sets the numerator for the rational type.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property Numerator As Long
'Usage

Dim instance As RationalType
Dim value As Long

instance.Numerator = value

value = instance.Numerator
public long Numerator {get; set;}
public: __property long get_Numerator();
public: __property void set_Numerator(
   long value
);
public:
property int64 Numerator {
   int64 get();
   void set (    int64 value);
}

Property Value

A long value which represents the numerator.

See Also

Reference

RationalType Class
RationalType Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
SaveTypeException Class
Members See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : SaveTypeException Class

Glossary Item Box

This class implements the SaveTypeExceptions to throw when there is a problem with the save type.

Object Model

SaveTypeException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class SaveTypeException
   Inherits IsisXpressLibraryException
'Usage

Dim instance As SaveTypeException
[SerializableAttribute()]
public sealed class SaveTypeException : IsisXpressLibraryException
[SerializableAttribute()]
public __gc __sealed class SaveTypeException : public IsisXpressLibraryException
[SerializableAttribute()]
public ref class SaveTypeException sealed : public IsisXpressLibraryException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.ISISXpressSdk.IsisXpressLibraryException
Accusoft.ISISXpressSdk.SaveTypeException

See Also

Reference

SaveTypeException Members
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.ISISXpress5.Net
SaveTypeException Class Members
See Also Properties Methods Send Feedback
Accusoft.ISISXpressSdk Namespace : SaveTypeException Class

Glossary Item Box

The following tables list the members exposed by SaveTypeException.

Public Constructors

 | Name | Description
Public Constructor | SaveTypeException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the number or ID of the specific error that occurred. (Inherited from Accusoft.ISISXpressSdk.IsisXpressLibraryException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

SaveTypeException Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.ISISXpress5.Net
SaveTypeException Class Methods
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : SaveTypeException Class

Glossary Item Box

For a list of all members of this type, see SaveTypeException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

SaveTypeException Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.ISISXpress5.Net
SaveTypeException Class Properties
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : SaveTypeException Class

Glossary Item Box

For a list of all members of this type, see SaveTypeException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the number or ID of the specific error that occurred. (Inherited from Accusoft.ISISXpressSdk.IsisXpressLibraryException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Top

See Also

Reference

SaveTypeException Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
SaveTypeException Constructor
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > SaveTypeException Class : SaveTypeException Constructor

Glossary Item Box

Overload List

Overload | Description
SaveTypeException Constructor() | The main constructor for the SaveTypeException class to throw when there is a problem with the save type.
SaveTypeException Constructor(Int32) | A SaveTypeException which allows passing in an error number.
SaveTypeException Constructor(String) | A SaveTypeException which allows passing in an error message.
SaveTypeException Constructor(Int32,String) | A SaveTypeException which allows passing in an error number.
SaveTypeException Constructor(String,Exception) | A SaveTypeException which allows passing in an error message and an inner exception.

See Also

Reference

SaveTypeException Class
SaveTypeException Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
SaveTypeException Constructor()
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > SaveTypeException Class > SaveTypeException Constructor : SaveTypeException Constructor()

Glossary Item Box

The main constructor for the SaveTypeException class to throw when there is a problem with the save type.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New SaveTypeException()
public SaveTypeException()
public: SaveTypeException();
public:
SaveTypeException();

See Also

Reference

SaveTypeException Class
SaveTypeException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
SaveTypeException Constructor(Int32)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > SaveTypeException Class > SaveTypeException Constructor : SaveTypeException Constructor(Int32)

errorNumber
An integer value which represents the error number.

Glossary Item Box

A SaveTypeException which allows passing in an error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New SaveTypeException(errorNumber)
public SaveTypeException(
   int errorNumber
)
public: SaveTypeException(
   int errorNumber
)
public:
SaveTypeException(
   int errorNumber
)

Parameters

errorNumber
An integer value which represents the error number.

See Also

Reference

SaveTypeException Class
SaveTypeException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
SaveTypeException Constructor(String)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > SaveTypeException Class > SaveTypeException Constructor : SaveTypeException Constructor(String)

message
A string value which represents the error message.

Glossary Item Box

A SaveTypeException which allows passing in an error message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New SaveTypeException(message)
public SaveTypeException(
   string message
)
public: SaveTypeException(
   string* message
)
public:
SaveTypeException(
   String^ message
)

Parameters

message
A string value which represents the error message.

See Also

Reference

SaveTypeException Class
SaveTypeException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
SaveTypeException Constructor(Int32,String)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > SaveTypeException Class > SaveTypeException Constructor : SaveTypeException Constructor(Int32,String)

errorNumber
An integer value which represents an error number.
message
A string value which represents the error message.

Glossary Item Box

A SaveTypeException which allows passing in an error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New SaveTypeException(errorNumber, message)
public SaveTypeException(
   int errorNumber,
   string message
)
public: SaveTypeException(
   int errorNumber,
   string* message
)
public:
SaveTypeException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer value which represents an error number.
message
A string value which represents the error message.

See Also

Reference

SaveTypeException Class
SaveTypeException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
SaveTypeException Constructor(String,Exception)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > SaveTypeException Class > SaveTypeException Constructor : SaveTypeException Constructor(String,Exception)

message
A string value which represents an error message.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

Glossary Item Box

A SaveTypeException which allows passing in an error message and an inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New SaveTypeException(message, innerException)
public SaveTypeException(
   string message,
   Exception innerException
)
public: SaveTypeException(
   string* message,
   Exception* innerException
)
public:
SaveTypeException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string value which represents an error message.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

See Also

Reference

SaveTypeException Class
SaveTypeException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
ScannedEventArgs Class
Members See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : ScannedEventArgs Class

Glossary Item Box

This class implements the event arguments for the IsisXpress.Scanned event.

Object Model

ScannedEventArgs Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Class ScannedEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As ScannedEventArgs
public class ScannedEventArgs : System.EventArgs
public __gc class ScannedEventArgs : public System.EventArgs
public ref class ScannedEventArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Accusoft.ISISXpressSdk.ScannedEventArgs

See Also

Reference

ScannedEventArgs Members
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.ISISXpress5.Net
ScannedEventArgs Class Members
See Also Properties Send Feedback
Accusoft.ISISXpressSdk Namespace : ScannedEventArgs Class

Glossary Item Box

The following tables list the members exposed by ScannedEventArgs.

Public Constructors

 | Name | Description
Public Constructor | ScannedEventArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | PageNumber | Gets the page number of the scan that just completed.
Top

See Also

Reference

ScannedEventArgs Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
ScannedEventArgs Constructor
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > ScannedEventArgs Class : ScannedEventArgs Constructor

Glossary Item Box

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ScannedEventArgs()
public ScannedEventArgs()
public: ScannedEventArgs();
public:
ScannedEventArgs();

See Also

Reference

ScannedEventArgs Class
ScannedEventArgs Members


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.ISISXpress5.Net
ScannedEventArgs Class Properties
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : ScannedEventArgs Class

Glossary Item Box

For a list of all members of this type, see ScannedEventArgs members.

Public Properties

 | Name | Description
Public Property | PageNumber | Gets the page number of the scan that just completed.
Top

See Also

Reference

ScannedEventArgs Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
PageNumber Property
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > ScannedEventArgs Class : PageNumber Property

Glossary Item Box

Gets the page number of the scan that just completed.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property PageNumber As Integer
'Usage

Dim instance As ScannedEventArgs
Dim value As Integer

instance.PageNumber = value

value = instance.PageNumber
public int PageNumber {get; set;}
public: __property int get_PageNumber();
public: __property void set_PageNumber(
   int value
);
public:
property int PageNumber {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the page number.

See Also

Reference

ScannedEventArgs Class
ScannedEventArgs Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
Scanner Class
Members See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : Scanner Class

Glossary Item Box

This class implements the specific Scanner settings, methods and properties.

Object Model

Scanner ClassSetting ClassRationalType ClassRationalType ClassRationalType ClassRationalType ClassRationalType ClassRationalType Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Class Scanner
'Usage

Dim instance As Scanner
public class Scanner
public __gc class Scanner
public ref class Scanner

Inheritance Hierarchy

System.Object
Accusoft.ISISXpressSdk.Scanner

See Also

Reference

Scanner Members
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.ISISXpress5.Net
Scanner Class Members
See Also Properties Methods Send Feedback
Accusoft.ISISXpressSdk Namespace : Scanner Class

Glossary Item Box

The following tables list the members exposed by Scanner.

Public Constructors

 | Name | Description
Public Constructor | Scanner Constructor | The main constructor for the Scanner class which passes in an instance ID.
Top

Public Properties

 | Name | Description
Public Property | DriverDirectory | Gets and sets the location of the ISIS driver files.
Public Property | DriverDirectoryDefault | Gets the default location of the ISIS driver files.
Public Property | DriverLoaded | Gets an indicator if the scanner driver is loaded.
Public Property | Name | Gets and sets the name of the scanner driver.
Public Property | Setting | Gets the current scanner settings.
Public Property | UseCompression | Gets and sets an indicator to enable hardware compression if the scanner supports it.
Top

Public Methods

 | Name | Description
Public Method | Cancel | Overloaded. Cancels the scanning process.
Public Method | ClearScanAheadPages | Clears the scanner's buffers of any scanned in ahead pages.
Public Method | GetConnectedDriversAndScannerModels | Gets a list of connected ISIS drivers and scanner models and places them in the given driverAndScannerList object.
Public Method | GetDriversAndScannerModels | Gets a list of available ISIS drivers and scanner models and places them in the given driverAndScannerList object.
Public Method | LoadDriver | Preloads the ISIS drivers used for scanning and saving an image.
Public Method | LoadSettings | Loads the settings for the current scanner from an .ini file.
Public Method | SaveSettings | Saves the settings for the current scanner to an .ini file.
Public Method | ScanBatch | Starts a batch scan process.
Public Method | ScanSingle | Scans a single page and stores it in the file specified in the Filename property. A single page is a defined as one side of a page, in a single bit depth. If multi stream is enabled this call will only pull in one part of the image for each time it is called.
Public Method | Select | Overloaded. Displays a predefined dialog box that allows the user to choose a scanner, add a scanner, or configure a scanner.
Public Method | SelectConnected | Overloaded. Displays a predefined dialog box that allows the user to choose a connected scanner, add a scanner, or configure a scanner.
Public Method | Setup | Overloaded. Displays a pre-defined dialog that allows the user to change driver specific scanner settings.
Top

See Also

Reference

Scanner Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
Scanner Constructor
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Scanner Class : Scanner Constructor

instanceId
An integer value which represents the ISIS Xpress instance ID.

Glossary Item Box

The main constructor for the Scanner class which passes in an instance ID.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal instanceId As IntPtr _
)
'Usage

Dim instanceId As IntPtr

Dim instance As New Scanner(instanceId)
public Scanner(
   IntPtr instanceId
)
public: Scanner(
   IntPtr instanceId
)
public:
Scanner(
   IntPtr instanceId
)

Parameters

instanceId
An integer value which represents the ISIS Xpress instance ID.

See Also

Reference

Scanner Class
Scanner Members


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.ISISXpress5.Net
Scanner Class Methods
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : Scanner Class

Glossary Item Box

For a list of all members of this type, see Scanner members.

Public Methods

 | Name | Description
Public Method | Cancel | Overloaded. Cancels the scanning process.
Public Method | ClearScanAheadPages | Clears the scanner's buffers of any scanned in ahead pages.
Public Method | GetConnectedDriversAndScannerModels | Gets a list of connected ISIS drivers and scanner models and places them in the given driverAndScannerList object.
Public Method | GetDriversAndScannerModels | Gets a list of available ISIS drivers and scanner models and places them in the given driverAndScannerList object.
Public Method | LoadDriver | Preloads the ISIS drivers used for scanning and saving an image.
Public Method | LoadSettings | Loads the settings for the current scanner from an .ini file.
Public Method | SaveSettings | Saves the settings for the current scanner to an .ini file.
Public Method | ScanBatch | Starts a batch scan process.
Public Method | ScanSingle | Scans a single page and stores it in the file specified in the Filename property. A single page is a defined as one side of a page, in a single bit depth. If multi stream is enabled this call will only pull in one part of the image for each time it is called.
Public Method | Select | Overloaded. Displays a predefined dialog box that allows the user to choose a scanner, add a scanner, or configure a scanner.
Public Method | SelectConnected | Overloaded. Displays a predefined dialog box that allows the user to choose a connected scanner, add a scanner, or configure a scanner.
Public Method | Setup | Overloaded. Displays a pre-defined dialog that allows the user to change driver specific scanner settings.
Top

See Also

Reference

Scanner Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
Cancel Method
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Scanner Class : Cancel Method

Glossary Item Box

Cancels the scanning process.

Overload List

Overload | Description
Cancel() | Cancels the scanning process.
Cancel(Boolean) | Cancels the scanning process allowing to pass in a boolean value.

See Also

Reference

Scanner Class
Scanner Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
Cancel() Method
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Scanner Class > Cancel Method : Cancel() Method

Glossary Item Box

Cancels the scanning process.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Cancel()
'Usage

Dim instance As Scanner

instance.Cancel()
public void Cancel()
public: void Cancel();
public:
void Cancel();

Remarks

Immediately cancels the scanning process. This cancellation occurs even if ISIS Xpress is in the middle of transferring data from the scanner.

See Also

Reference

Scanner Class
Scanner Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
Cancel(Boolean) Method
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Scanner Class > Cancel Method : Cancel(Boolean) Method

immediate
A boolean value which should be set to true to immediately cancel the process. Otherwise, false should be set to wait until the current page is transferred from the scanner.

Glossary Item Box

Cancels the scanning process allowing to pass in a boolean value.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Cancel( _
   ByVal immediate As Boolean _
)
'Usage

Dim instance As Scanner
Dim immediate As Boolean

instance.Cancel(immediate)
public void Cancel(
   bool immediate
)
public: void Cancel(
   bool immediate
)
public:
void Cancel(
   bool immediate
)

Parameters

immediate
A boolean value which should be set to true to immediately cancel the process. Otherwise, false should be set to wait until the current page is transferred from the scanner.

Remarks

If the immediate parameter is false, this method causes the scanner to wait til the current page is transferred from the scanner before the scanning process is cancelled. If the ScanSettingInfo ScanAhead value is enabled and the scanner driver supports the ScanSettingInfo ScanAheadPages setting, then ISIS Xpress processes those pages that have been scanned ahead, otherwise ISIS Xpress stops processing all pages.

See Also

Reference

Scanner Class
Scanner Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
ClearScanAheadPages Method
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Scanner Class : ClearScanAheadPages Method

Glossary Item Box

Clears the scanner's buffers of any scanned in ahead pages.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub ClearScanAheadPages()
'Usage

Dim instance As Scanner

instance.ClearScanAheadPages()
public void ClearScanAheadPages()
public: void ClearScanAheadPages();
public:
void ClearScanAheadPages();

Remarks

Call this method if a Cancel method was performed while the scanner was set to scan ahead with the ScanSettingInfo scan setting set to ScanAhead.On. This flushes the scanner's buffers of any unprocessed pages.

See Also

Reference

Scanner Class
Scanner Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
GetConnectedDriversAndScannerModels Method
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Scanner Class : GetConnectedDriversAndScannerModels Method

driverAndScannerList
A DriverAndScannerList object.

Glossary Item Box

Gets a list of connected ISIS drivers and scanner models and places them in the given driverAndScannerList object.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub GetConnectedDriversAndScannerModels( _
   ByRef driverAndScannerList As DriverAndScannerList _
)
'Usage

Dim instance As Scanner
Dim driverAndScannerList As DriverAndScannerList

instance.GetConnectedDriversAndScannerModels(driverAndScannerList)
public void GetConnectedDriversAndScannerModels(
   out DriverAndScannerList driverAndScannerList
)
public: void GetConnectedDriversAndScannerModels(
   [PARAMFLAG::Out] DriverAndScannerList* driverAndScannerList
)
public:
void GetConnectedDriversAndScannerModels(
   [Out] DriverAndScannerList^ driverAndScannerList
)

Parameters

driverAndScannerList
A DriverAndScannerList object.

See Also

Reference

Scanner Class
Scanner Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
GetDriversAndScannerModels Method
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Scanner Class : GetDriversAndScannerModels Method

driverAndScannerList
A DriverAndScannerList object.

Glossary Item Box

Gets a list of available ISIS drivers and scanner models and places them in the given driverAndScannerList object.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub GetDriversAndScannerModels( _
   ByRef driverAndScannerList As DriverAndScannerList _
)
'Usage

Dim instance As Scanner
Dim driverAndScannerList As DriverAndScannerList

instance.GetDriversAndScannerModels(driverAndScannerList)
public void GetDriversAndScannerModels(
   out DriverAndScannerList driverAndScannerList
)
public: void GetDriversAndScannerModels(
   [PARAMFLAG::Out] DriverAndScannerList* driverAndScannerList
)
public:
void GetDriversAndScannerModels(
   [Out] DriverAndScannerList^ driverAndScannerList
)

Parameters

driverAndScannerList
A DriverAndScannerList object.

See Also

Reference

Scanner Class
Scanner Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
LoadDriver Method
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Scanner Class : LoadDriver Method

Glossary Item Box

Preloads the ISIS drivers used for scanning and saving an image.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub LoadDriver()
'Usage

Dim instance As Scanner

instance.LoadDriver()
public void LoadDriver()
public: void LoadDriver();
public:
void LoadDriver();

Remarks

This is an optimization method that can be used to improve performance. If this method is not called, there is a slight delay before the first scan is started because the control must first load the ISIS drivers. This method should only be called one time.

The following properties affect the ISIS drivers and can cause them to be reloaded:

  • Output.FileType property
  • CreateFiles property
  • UseCompression property

If the properties need to be changed they should be modified and then this method called so the control is ready to scan. This results in the scan starting immediately when the ScanSingle or ScanBatch methods are called since the ISIS drivers have already been preloaded.

See Also

Reference

Scanner Class
Scanner Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
LoadSettings Method
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Scanner Class : LoadSettings Method

filename
A string which represents the filename.

Glossary Item Box

Loads the settings for the current scanner from an .ini file.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub LoadSettings( _
   ByVal filename As String _
)
'Usage

Dim instance As Scanner
Dim filename As String

instance.LoadSettings(filename)
public void LoadSettings(
   string filename
)
public: void LoadSettings(
   string* filename
)
public:
void LoadSettings(
   String^ filename
)

Parameters

filename
A string which represents the filename.

Remarks

The same .ini file can be used for multiple scanners because the settings are saved under a different section for each scanner. The section name used in the .ini file is the name of the scanner driver.

See Also

Reference

Scanner Class
Scanner Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
SaveSettings Method
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Scanner Class : SaveSettings Method

filename
A string which represents the filename.

Glossary Item Box

Saves the settings for the current scanner to an .ini file.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub SaveSettings( _
   ByVal filename As String _
)
'Usage

Dim instance As Scanner
Dim filename As String

instance.SaveSettings(filename)
public void SaveSettings(
   string filename
)
public: void SaveSettings(
   string* filename
)
public:
void SaveSettings(
   String^ filename
)

Parameters

filename
A string which represents the filename.

Remarks

The same .ini file can be used for multiple scanners because the settings are saved under a different section for each scanner. The section name used in the .ini file is the name of the scanner driver.

See Also

Reference

Scanner Class
Scanner Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
ScanBatch Method
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Scanner Class : ScanBatch Method

Glossary Item Box

Starts a batch scan process.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub ScanBatch()
'Usage

Dim instance As Scanner

instance.ScanBatch()
public void ScanBatch()
public: void ScanBatch();
public:
void ScanBatch();

Remarks

During the scan process, an IsisXpress.Scanning event is fired before the scan to allow the filename to be changed. If the UseCompression property is false, then the IsisXpress.Progress events are fired during the scan. After a page has completed, the IsisXpress.Scanned event fires.

Note: If the UseSchema property is true, then ISIS Xpress generates a naming schema to use for filenames. The generated filename can be checked and changed in each IsisXpress.Scanning event.

IMPORTANT! This method does not finish until the FeederEmptyEventArgs.StopScan property is set to true in the IsisXpress.FeederEmpty event to indicate the batch is done or until the Cancel method is called.

When the scanner feeder is empty, an IsisXpress.FeederEmpty event is fired. This event may fire after each scan if you are using a scanner that does not have a feeder or a scanner that cannot detect paper in the feeder.

See Also

Reference

Scanner Class
Scanner Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
ScanSingle Method
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Scanner Class : ScanSingle Method

Glossary Item Box

Scans a single page and stores it in the file specified in the Filename property. A single page is a defined as one side of a page, in a single bit depth. If multi stream is enabled this call will only pull in one part of the image for each time it is called.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Sub ScanSingle()
'Usage

Dim instance As Scanner

instance.ScanSingle()
public void ScanSingle()
public: void ScanSingle();
public:
void ScanSingle();

See Also

Reference

Scanner Class
Scanner Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
Select Method
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Scanner Class : Select Method

Glossary Item Box

Displays a predefined dialog box that allows the user to choose a scanner, add a scanner, or configure a scanner.

Overload List

Overload | Description
Select() | Displays a predefined dialog box that allows the user to choose a scanner, add a scanner, or configure a scanner.
Select(IntPtr) | Displays a predefined dialog box that allows the user to choose a scanner, add a scanner, or configure a scanner. A valid application window handle will present this dialog as modal.

See Also

Reference

Scanner Class
Scanner Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
Select() Method
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Scanner Class > Select Method : Select() Method

Glossary Item Box

Displays a predefined dialog box that allows the user to choose a scanner, add a scanner, or configure a scanner.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Select()
'Usage

Dim instance As Scanner

instance.Select()
public void Select()
public: void Select();
public:
void Select();

See Also

Reference

Scanner Class
Scanner Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
Select(IntPtr) Method
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Scanner Class > Select Method : Select(IntPtr) Method

hWnd
A pointer to the application window handle.

Glossary Item Box

Displays a predefined dialog box that allows the user to choose a scanner, add a scanner, or configure a scanner. A valid application window handle will present this dialog as modal.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Select( _
   ByVal hWnd As IntPtr _
)
'Usage

Dim instance As Scanner
Dim hWnd As IntPtr

instance.Select(hWnd)
public void Select(
   IntPtr hWnd
)
public: void Select(
   IntPtr hWnd
)
public:
void Select(
   IntPtr hWnd
)

Parameters

hWnd
A pointer to the application window handle.

See Also

Reference

Scanner Class
Scanner Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
SelectConnected Method
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Scanner Class : SelectConnected Method

Glossary Item Box

Displays a predefined dialog box that allows the user to choose a connected scanner, add a scanner, or configure a scanner.

Overload List

Overload | Description
SelectConnected() | Displays a predefined dialog box that allows the user to choose a connected scanner, add a scanner, or configure a scanner.
SelectConnected(IntPtr) | Displays a predefined dialog box that allows the user to choose a connected scanner, add a scanner, or configure a scanner. A valid application window handle will present this dialog as modal.

See Also

Reference

Scanner Class
Scanner Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
SelectConnected() Method
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Scanner Class > SelectConnected Method : SelectConnected() Method

Glossary Item Box

Displays a predefined dialog box that allows the user to choose a connected scanner, add a scanner, or configure a scanner.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub SelectConnected()
'Usage

Dim instance As Scanner

instance.SelectConnected()
public void SelectConnected()
public: void SelectConnected();
public:
void SelectConnected();

See Also

Reference

Scanner Class
Scanner Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
SelectConnected(IntPtr) Method
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Scanner Class > SelectConnected Method : SelectConnected(IntPtr) Method

hWnd
A pointer to the application window handle.

Glossary Item Box

Displays a predefined dialog box that allows the user to choose a connected scanner, add a scanner, or configure a scanner. A valid application window handle will present this dialog as modal.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub SelectConnected( _
   ByVal hWnd As IntPtr _
)
'Usage

Dim instance As Scanner
Dim hWnd As IntPtr

instance.SelectConnected(hWnd)
public void SelectConnected(
   IntPtr hWnd
)
public: void SelectConnected(
   IntPtr hWnd
)
public:
void SelectConnected(
   IntPtr hWnd
)

Parameters

hWnd
A pointer to the application window handle.

See Also

Reference

Scanner Class
Scanner Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
Setup Method
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Scanner Class : Setup Method

Glossary Item Box

Displays a pre-defined dialog that allows the user to change driver specific scanner settings.

Overload List

Overload | Description
Setup() | Displays a pre-defined dialog that allows the user to change driver specific scanner settings.
Setup(SetupOptions) | Displays a pre-defined dialog that allows the user to change driver specific scanner settings and allows passing in a SetupOptions enumeration value parameter.
Setup(Int32,SetupOptions) | Displays a pre-defined dialog that allows the user to change driver specific scanner settings and allows passing in a SetupOptions enumeration value parameter.

See Also

Reference

Scanner Class
Scanner Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
Setup() Method
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Scanner Class > Setup Method : Setup() Method

Glossary Item Box

Displays a pre-defined dialog that allows the user to change driver specific scanner settings.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Setup()
'Usage

Dim instance As Scanner

instance.Setup()
public void Setup()
public: void Setup();
public:
void Setup();

See Also

Reference

Scanner Class
Scanner Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
Setup(SetupOptions) Method
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Scanner Class > Setup Method : Setup(SetupOptions) Method

setupOption
An SetupOptions enumeration value option.

Glossary Item Box

Displays a pre-defined dialog that allows the user to change driver specific scanner settings and allows passing in a SetupOptions enumeration value parameter.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Setup( _
   ByVal setupOption As SetupOptions _
)
'Usage

Dim instance As Scanner
Dim setupOption As SetupOptions

instance.Setup(setupOption)
public void Setup(
   SetupOptions setupOption
)
public: void Setup(
   SetupOptions setupOption
)
public:
void Setup(
   SetupOptions setupOption
)

Parameters

setupOption
An SetupOptions enumeration value option.

See Also

Reference

Scanner Class
Scanner Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
Setup(Int32,SetupOptions) Method
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Scanner Class > Setup Method : Setup(Int32,SetupOptions) Method

windowHandle
An integer value which represents the window handle.
setupOption
An SetupOptions enumeration value option.

Glossary Item Box

Displays a pre-defined dialog that allows the user to change driver specific scanner settings and allows passing in a SetupOptions enumeration value parameter.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Sub Setup( _
   ByVal windowHandle As Integer, _
   ByVal setupOption As SetupOptions _
)
'Usage

Dim instance As Scanner
Dim windowHandle As Integer
Dim setupOption As SetupOptions

instance.Setup(windowHandle, setupOption)
public void Setup(
   int windowHandle,
   SetupOptions setupOption
)
public: void Setup(
   int windowHandle,
   SetupOptions setupOption
)
public:
void Setup(
   int windowHandle,
   SetupOptions setupOption
)

Parameters

windowHandle
An integer value which represents the window handle.
setupOption
An SetupOptions enumeration value option.

See Also

Reference

Scanner Class
Scanner Members
Overload List


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.ISISXpress5.Net
Scanner Class Properties
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : Scanner Class

Glossary Item Box

For a list of all members of this type, see Scanner members.

Public Properties

 | Name | Description
Public Property | DriverDirectory | Gets and sets the location of the ISIS driver files.
Public Property | DriverDirectoryDefault | Gets the default location of the ISIS driver files.
Public Property | DriverLoaded | Gets an indicator if the scanner driver is loaded.
Public Property | Name | Gets and sets the name of the scanner driver.
Public Property | Setting | Gets the current scanner settings.
Public Property | UseCompression | Gets and sets an indicator to enable hardware compression if the scanner supports it.
Top

See Also

Reference

Scanner Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
DriverDirectory Property
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Scanner Class : DriverDirectory Property

Glossary Item Box

Gets and sets the location of the ISIS driver files.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property DriverDirectory As String
'Usage

Dim instance As Scanner
Dim value As String

instance.DriverDirectory = value

value = instance.DriverDirectory
public string DriverDirectory {get; set;}
public: __property string* get_DriverDirectory();
public: __property void set_DriverDirectory(
   string* value
);
public:
property String^ DriverDirectory {
   String^ get();
   void set (    String^ value);
}

Property Value

A string which represents the location of the ISIS driver files.

See Also

Reference

Scanner Class
Scanner Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
DriverDirectoryDefault Property
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Scanner Class : DriverDirectoryDefault Property

Glossary Item Box

Gets the default location of the ISIS driver files.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property DriverDirectoryDefault As String
'Usage

Dim instance As Scanner
Dim value As String

value = instance.DriverDirectoryDefault
public string DriverDirectoryDefault {get;}
public: __property string* get_DriverDirectoryDefault();
public:
property String^ DriverDirectoryDefault {
   String^ get();
}

Property Value

A string which represents the default location of the ISIS driver files.

See Also

Reference

Scanner Class
Scanner Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
DriverLoaded Property
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Scanner Class : DriverLoaded Property

Glossary Item Box

Gets an indicator if the scanner driver is loaded.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property DriverLoaded As Boolean
'Usage

Dim instance As Scanner
Dim value As Boolean

value = instance.DriverLoaded
public bool DriverLoaded {get;}
public: __property bool get_DriverLoaded();
public:
property bool DriverLoaded {
   bool get();
}

Property Value

A boolean value which is true if the scanner driver is loaded. Otherwise, false is returned.

See Also

Reference

Scanner Class
Scanner Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
Name Property
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Scanner Class : Name Property

Glossary Item Box

Gets and sets the name of the scanner driver.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property Name As String
'Usage

Dim instance As Scanner
Dim value As String

instance.Name = value

value = instance.Name
public string Name {get; set;}
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}

Property Value

A string which represents the name of the scanner driver.

Remarks

The default scanner is loaded at creation.

Note: This property fails if it is set with a name that is not spelled exactly correct.

See Also

Reference

Scanner Class
Scanner Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
Setting Property
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Scanner Class : Setting Property

Glossary Item Box

Gets the current scanner settings.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<BrowsableAttribute(False)>
Public ReadOnly Property Setting As Setting
'Usage

Dim instance As Scanner
Dim value As Setting

value = instance.Setting
[BrowsableAttribute(false)]
public Setting Setting {get;}
[BrowsableAttribute(false)]
public: __property Setting* get_Setting();
[BrowsableAttribute(false)]
public:
property Setting^ Setting {
   Setting^ get();
}

Property Value

A Setting object that contains the current scanner settings.

See Also

Reference

Scanner Class
Scanner Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
UseCompression Property
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Scanner Class : UseCompression Property

Glossary Item Box

Gets and sets an indicator to enable hardware compression if the scanner supports it.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property UseCompression As Boolean
'Usage

Dim instance As Scanner
Dim value As Boolean

instance.UseCompression = value

value = instance.UseCompression
public bool UseCompression {get; set;}
public: __property bool get_UseCompression();
public: __property void set_UseCompression(
   bool value
);
public:
property bool UseCompression {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value which is true to enable hardware compression. Otherwise, false is returned.

See Also

Reference

Scanner Class
Scanner Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
ScannerLoadedException Class
Members See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : ScannerLoadedException Class

Glossary Item Box

This class implements the ScannerLoadedExceptions.

Object Model

ScannerLoadedException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class ScannerLoadedException
   Inherits IsisXpressLibraryException
'Usage

Dim instance As ScannerLoadedException
[SerializableAttribute()]
public sealed class ScannerLoadedException : IsisXpressLibraryException
[SerializableAttribute()]
public __gc __sealed class ScannerLoadedException : public IsisXpressLibraryException
[SerializableAttribute()]
public ref class ScannerLoadedException sealed : public IsisXpressLibraryException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.ISISXpressSdk.IsisXpressLibraryException
Accusoft.ISISXpressSdk.ScannerLoadedException

See Also

Reference

ScannerLoadedException Members
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.ISISXpress5.Net
ScannerLoadedException Class Members
See Also Properties Methods Send Feedback
Accusoft.ISISXpressSdk Namespace : ScannerLoadedException Class

Glossary Item Box

The following tables list the members exposed by ScannerLoadedException.

Public Constructors

 | Name | Description
Public Constructor | ScannerLoadedException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the number or ID of the specific error that occurred. (Inherited from Accusoft.ISISXpressSdk.IsisXpressLibraryException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ScannerLoadedException Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.ISISXpress5.Net
ScannerLoadedException Class Methods
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : ScannerLoadedException Class

Glossary Item Box

For a list of all members of this type, see ScannerLoadedException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ScannerLoadedException Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.ISISXpress5.Net
ScannerLoadedException Class Properties
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : ScannerLoadedException Class

Glossary Item Box

For a list of all members of this type, see ScannerLoadedException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the number or ID of the specific error that occurred. (Inherited from Accusoft.ISISXpressSdk.IsisXpressLibraryException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Top

See Also

Reference

ScannerLoadedException Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
ScannerLoadedException Constructor
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > ScannerLoadedException Class : ScannerLoadedException Constructor

Glossary Item Box

Overload List

Overload | Description
ScannerLoadedException Constructor() | The main constructor for throwing errors when loading the scanner.
ScannerLoadedException Constructor(Int32) | A ScannerLoadedException constructor which allows passing in an error number.
ScannerLoadedException Constructor(String) | A ScannerLoadedException constructor which allows passing in an error message.
ScannerLoadedException Constructor(Int32,String) | A ScannerLoadedException constructor which allows passing in an error number and an error message.
ScannerLoadedException Constructor(String,Exception) | A ScannerLoadedException constructor which allows passing in an error message and an inner exception.

See Also

Reference

ScannerLoadedException Class
ScannerLoadedException Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
ScannerLoadedException Constructor()
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > ScannerLoadedException Class > ScannerLoadedException Constructor : ScannerLoadedException Constructor()

Glossary Item Box

The main constructor for throwing errors when loading the scanner.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ScannerLoadedException()
public ScannerLoadedException()
public: ScannerLoadedException();
public:
ScannerLoadedException();

See Also

Reference

ScannerLoadedException Class
ScannerLoadedException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
ScannerLoadedException Constructor(Int32)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > ScannerLoadedException Class > ScannerLoadedException Constructor : ScannerLoadedException Constructor(Int32)

errorNumber
An integer value which represents the error number.

Glossary Item Box

A ScannerLoadedException constructor which allows passing in an error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New ScannerLoadedException(errorNumber)
public ScannerLoadedException(
   int errorNumber
)
public: ScannerLoadedException(
   int errorNumber
)
public:
ScannerLoadedException(
   int errorNumber
)

Parameters

errorNumber
An integer value which represents the error number.

See Also

Reference

ScannerLoadedException Class
ScannerLoadedException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
ScannerLoadedException Constructor(String)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > ScannerLoadedException Class > ScannerLoadedException Constructor : ScannerLoadedException Constructor(String)

message
A string value which represents an error message.

Glossary Item Box

A ScannerLoadedException constructor which allows passing in an error message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New ScannerLoadedException(message)
public ScannerLoadedException(
   string message
)
public: ScannerLoadedException(
   string* message
)
public:
ScannerLoadedException(
   String^ message
)

Parameters

message
A string value which represents an error message.

See Also

Reference

ScannerLoadedException Class
ScannerLoadedException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
ScannerLoadedException Constructor(Int32,String)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > ScannerLoadedException Class > ScannerLoadedException Constructor : ScannerLoadedException Constructor(Int32,String)

errorNumber
An integer value which represents an error number.
message
A string value which represents an error message.

Glossary Item Box

A ScannerLoadedException constructor which allows passing in an error number and an error message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New ScannerLoadedException(errorNumber, message)
public ScannerLoadedException(
   int errorNumber,
   string message
)
public: ScannerLoadedException(
   int errorNumber,
   string* message
)
public:
ScannerLoadedException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer value which represents an error number.
message
A string value which represents an error message.

See Also

Reference

ScannerLoadedException Class
ScannerLoadedException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
ScannerLoadedException Constructor(String,Exception)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > ScannerLoadedException Class > ScannerLoadedException Constructor : ScannerLoadedException Constructor(String,Exception)

message
A string value which represents an error message.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

Glossary Item Box

A ScannerLoadedException constructor which allows passing in an error message and an inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New ScannerLoadedException(message, innerException)
public ScannerLoadedException(
   string message,
   Exception innerException
)
public: ScannerLoadedException(
   string* message,
   Exception* innerException
)
public:
ScannerLoadedException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string value which represents an error message.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

See Also

Reference

ScannerLoadedException Class
ScannerLoadedException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
ScanningEventArgs Class
Members See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : ScanningEventArgs Class

Glossary Item Box

This class implements the event arguments for the IsisXpress.Scanning event.

Object Model

ScanningEventArgs Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Class ScanningEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As ScanningEventArgs
public class ScanningEventArgs : System.EventArgs
public __gc class ScanningEventArgs : public System.EventArgs
public ref class ScanningEventArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Accusoft.ISISXpressSdk.ScanningEventArgs

See Also

Reference

ScanningEventArgs Members
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.ISISXpress5.Net
ScanningEventArgs Class Members
See Also Properties Send Feedback
Accusoft.ISISXpressSdk Namespace : ScanningEventArgs Class

Glossary Item Box

The following tables list the members exposed by ScanningEventArgs.

Public Constructors

 | Name | Description
Public Constructor | ScanningEventArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | PageNumber | Gets the page number of the scan that is starting.
Top

See Also

Reference

ScanningEventArgs Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
ScanningEventArgs Constructor
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > ScanningEventArgs Class : ScanningEventArgs Constructor

Glossary Item Box

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ScanningEventArgs()
public ScanningEventArgs()
public: ScanningEventArgs();
public:
ScanningEventArgs();

See Also

Reference

ScanningEventArgs Class
ScanningEventArgs Members


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.ISISXpress5.Net
ScanningEventArgs Class Properties
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : ScanningEventArgs Class

Glossary Item Box

For a list of all members of this type, see ScanningEventArgs members.

Public Properties

 | Name | Description
Public Property | PageNumber | Gets the page number of the scan that is starting.
Top

See Also

Reference

ScanningEventArgs Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
PageNumber Property
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > ScanningEventArgs Class : PageNumber Property

Glossary Item Box

Gets the page number of the scan that is starting.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property PageNumber As Integer
'Usage

Dim instance As ScanningEventArgs
Dim value As Integer

instance.PageNumber = value

value = instance.PageNumber
public int PageNumber {get; set;}
public: __property int get_PageNumber();
public: __property void set_PageNumber(
   int value
);
public:
property int PageNumber {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the page number.

See Also

Reference

ScanningEventArgs Class
ScanningEventArgs Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
SequenceException Class
Members See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : SequenceException Class

Glossary Item Box

This class implements the SequenceExceptions to throw when there is a sequence problem.

Object Model

SequenceException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class SequenceException
   Inherits IsisXpressLibraryException
'Usage

Dim instance As SequenceException
[SerializableAttribute()]
public sealed class SequenceException : IsisXpressLibraryException
[SerializableAttribute()]
public __gc __sealed class SequenceException : public IsisXpressLibraryException
[SerializableAttribute()]
public ref class SequenceException sealed : public IsisXpressLibraryException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.ISISXpressSdk.IsisXpressLibraryException
Accusoft.ISISXpressSdk.SequenceException

See Also

Reference

SequenceException Members
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.ISISXpress5.Net
SequenceException Class Members
See Also Properties Methods Send Feedback
Accusoft.ISISXpressSdk Namespace : SequenceException Class

Glossary Item Box

The following tables list the members exposed by SequenceException.

Public Constructors

 | Name | Description
Public Constructor | SequenceException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the number or ID of the specific error that occurred. (Inherited from Accusoft.ISISXpressSdk.IsisXpressLibraryException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

SequenceException Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.ISISXpress5.Net
SequenceException Class Methods
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : SequenceException Class

Glossary Item Box

For a list of all members of this type, see SequenceException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

SequenceException Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.ISISXpress5.Net
SequenceException Class Properties
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : SequenceException Class

Glossary Item Box

For a list of all members of this type, see SequenceException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the number or ID of the specific error that occurred. (Inherited from Accusoft.ISISXpressSdk.IsisXpressLibraryException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Top

See Also

Reference

SequenceException Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
SequenceException Constructor
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > SequenceException Class : SequenceException Constructor

Glossary Item Box

Overload List

Overload | Description
SequenceException Constructor() | The main constructor for the SequenceException class to throw when there is a sequence problem.
SequenceException Constructor(Int32) | A SequenceException which allows passing in an error number.
SequenceException Constructor(String) | A SequenceException which allows passing in an error message.
SequenceException Constructor(Int32,String) | A SequenceException which allows passing in an error number and an error message.
SequenceException Constructor(String,Exception) | A SequenceException which allows passing in an error message and an inner exception.

See Also

Reference

SequenceException Class
SequenceException Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
SequenceException Constructor()
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > SequenceException Class > SequenceException Constructor : SequenceException Constructor()

Glossary Item Box

The main constructor for the SequenceException class to throw when there is a sequence problem.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New SequenceException()
public SequenceException()
public: SequenceException();
public:
SequenceException();

See Also

Reference

SequenceException Class
SequenceException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
SequenceException Constructor(Int32)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > SequenceException Class > SequenceException Constructor : SequenceException Constructor(Int32)

errorNumber
An integer value which represents the error number.

Glossary Item Box

A SequenceException which allows passing in an error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New SequenceException(errorNumber)
public SequenceException(
   int errorNumber
)
public: SequenceException(
   int errorNumber
)
public:
SequenceException(
   int errorNumber
)

Parameters

errorNumber
An integer value which represents the error number.

See Also

Reference

SequenceException Class
SequenceException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
SequenceException Constructor(String)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > SequenceException Class > SequenceException Constructor : SequenceException Constructor(String)

message
A string value which represents the error message.

Glossary Item Box

A SequenceException which allows passing in an error message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New SequenceException(message)
public SequenceException(
   string message
)
public: SequenceException(
   string* message
)
public:
SequenceException(
   String^ message
)

Parameters

message
A string value which represents the error message.

See Also

Reference

SequenceException Class
SequenceException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
SequenceException Constructor(Int32,String)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > SequenceException Class > SequenceException Constructor : SequenceException Constructor(Int32,String)

errorNumber
An integer value which represents the error number.
message
A string value which represents the error message.

Glossary Item Box

A SequenceException which allows passing in an error number and an error message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New SequenceException(errorNumber, message)
public SequenceException(
   int errorNumber,
   string message
)
public: SequenceException(
   int errorNumber,
   string* message
)
public:
SequenceException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer value which represents the error number.
message
A string value which represents the error message.

See Also

Reference

SequenceException Class
SequenceException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
SequenceException Constructor(String,Exception)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > SequenceException Class > SequenceException Constructor : SequenceException Constructor(String,Exception)

message
A string value which represents the error message.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

Glossary Item Box

A SequenceException which allows passing in an error message and an inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New SequenceException(message, innerException)
public SequenceException(
   string message,
   Exception innerException
)
public: SequenceException(
   string* message,
   Exception* innerException
)
public:
SequenceException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string value which represents the error message.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

See Also

Reference

SequenceException Class
SequenceException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
Setting Class
Members See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : Setting Class

Glossary Item Box

This class implements the scanner settings.

Object Model

Setting ClassRationalType ClassRationalType ClassRationalType ClassRationalType ClassRationalType ClassRationalType Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Class Setting
'Usage

Dim instance As Setting
public class Setting
public __gc class Setting
public ref class Setting

Inheritance Hierarchy

System.Object
Accusoft.ISISXpressSdk.Setting

See Also

Reference

Setting Members
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.ISISXpress5.Net
Setting Class Members
See Also Properties Methods Send Feedback
Accusoft.ISISXpressSdk Namespace : Setting Class

Glossary Item Box

The following tables list the members exposed by Setting.

Public Constructors

 | Name | Description
Public Constructor | Setting Constructor | The main constructor that allows passing in an ISIS Xpress instance ID.
Top

Public Properties

 | Name | Description
Public Property | Advanced | Gets and sets the advanced tag number.
Public Property | DataType | Gets the data type encoded information for the current scanner setting.
Public Property | ListCount | Gets the number of available choices when the DataType property is a list for the current scan setting.
Public Property | ListIndex | Gets and sets the index for the list item to access when the DataType property is a list of the current scan setting.
Public Property | LongValue | Gets and sets a long value for the current scanner setting.
Public Property | RangeMaximumLong | Gets the highest possible long value for the current scan setting when the scan setting is a range of values.
Public Property | RangeMinimumLong | Gets the lowest possible long value for the current scan setting when the scan setting is a range of values.
Public Property | RationalValue | Gets and sets a rational for the current scanner setting.
Public Property | ScanSetting | Gets and sets the ScanSettingInfo enumeration scanner setting.
Public Property | StringValue | Gets and sets a string for the current scanner setting.
Public Property | Supported | Gets an indicator if the current scan setting is supported.
Top

Public Methods

 | Name | Description
Public Method | ListLong | Overloaded. Returns a long value when the DataType property is a long list for the current scan setting.
Public Method | ListRational | Overloaded. Returns a rational value when the DataType property is a rational list for the current scan setting. The ListIndex property must be set to the index of the rational value to retrieve from the rational list before calling this property.
Public Method | ListString | Overloaded. Returns a string value when the DataType property is a string list for the current scan setting. The ListIndex property must be set to the index of the string value to retrieve from the string list before calling this property.
Public Method | LongDefault | Overloaded. Returns a long value at the specified index from the list of values for the default scan setting.
Public Method | RangeMaximumRational | Returns the highest possible rational value for the current scan setting when the scan setting is a range of values.
Public Method | RangeMinimumRational | Returns the lowest possible rational value for the current scan setting when the scan setting is a range of values.
Public Method | RationalDefault | Overloaded. Returns a rational value at the given index in the list of rational values for the default scan setting.
Public Method | RationalStep | Returns the increment or step of rationals when changing values.
Public Method | StringDefault | Returns a string value for the default scan setting.
Top

See Also

Reference

Setting Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
Setting Constructor
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Setting Class : Setting Constructor

instanceId
The instance ID for the ISIS Xpress component.

Glossary Item Box

The main constructor that allows passing in an ISIS Xpress instance ID.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal instanceId As IntPtr _
)
'Usage

Dim instanceId As IntPtr

Dim instance As New Setting(instanceId)
public Setting(
   IntPtr instanceId
)
public: Setting(
   IntPtr instanceId
)
public:
Setting(
   IntPtr instanceId
)

Parameters

instanceId
The instance ID for the ISIS Xpress component.

See Also

Reference

Setting Class
Setting Members


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.ISISXpress5.Net
Setting Class Methods
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : Setting Class

Glossary Item Box

For a list of all members of this type, see Setting members.

Public Methods

 | Name | Description
Public Method | ListLong | Overloaded. Returns a long value when the DataType property is a long list for the current scan setting.
Public Method | ListRational | Overloaded. Returns a rational value when the DataType property is a rational list for the current scan setting. The ListIndex property must be set to the index of the rational value to retrieve from the rational list before calling this property.
Public Method | ListString | Overloaded. Returns a string value when the DataType property is a string list for the current scan setting. The ListIndex property must be set to the index of the string value to retrieve from the string list before calling this property.
Public Method | LongDefault | Overloaded. Returns a long value at the specified index from the list of values for the default scan setting.
Public Method | RangeMaximumRational | Returns the highest possible rational value for the current scan setting when the scan setting is a range of values.
Public Method | RangeMinimumRational | Returns the lowest possible rational value for the current scan setting when the scan setting is a range of values.
Public Method | RationalDefault | Overloaded. Returns a rational value at the given index in the list of rational values for the default scan setting.
Public Method | RationalStep | Returns the increment or step of rationals when changing values.
Public Method | StringDefault | Returns a string value for the default scan setting.
Top

See Also

Reference

Setting Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
ListLong Method
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Setting Class : ListLong Method

Glossary Item Box

Returns a long value when the DataType property is a long list for the current scan setting.

Overload List

Overload | Description
ListLong() | Returns a long value when the DataType property is a long list for the current scan setting.
ListLong(Int32) | Returns a long value when the DataType property is a long list for the current scan setting passing in an index value.

See Also

Reference

Setting Class
Setting Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
ListLong() Method
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Setting Class > ListLong Method : ListLong() Method

Glossary Item Box

Returns a long value when the DataType property is a long list for the current scan setting.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Function ListLong() As Integer
'Usage

Dim instance As Setting
Dim value As Integer

value = instance.ListLong()
public int ListLong()
public: int ListLong();
public:
int ListLong();

Return Value

An integer value which represents a long value when the DataType property is a long list for the current scan setting.

Remarks

The ListIndex property must be set to the index of the long value to retrieve from the long list before calling this property.

See Also

Reference

Setting Class
Setting Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
ListLong(Int32) Method
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Setting Class > ListLong Method : ListLong(Int32) Method

index
An integer value which represents the index of the long list.

Glossary Item Box

Returns a long value when the DataType property is a long list for the current scan setting passing in an index value.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Function ListLong( _
   ByVal index As Integer _
) As Integer
'Usage

Dim instance As Setting
Dim index As Integer
Dim value As Integer

value = instance.ListLong(index)
public int ListLong(
   int index
)
public: int ListLong(
   int index
)
public:
int ListLong(
   int index
)

Parameters

index
An integer value which represents the index of the long list.

Return Value

An integer value which represents a long value when the DataType property is a long list for the current scan setting.

Remarks

The ListIndex property must be set to the index of the rational value to retrieve from the rational list before calling this property.

See Also

Reference

Setting Class
Setting Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
ListRational Method
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Setting Class : ListRational Method

Glossary Item Box

Returns a rational value when the DataType property is a rational list for the current scan setting. The ListIndex property must be set to the index of the rational value to retrieve from the rational list before calling this property.

Overload List

Overload | Description
ListRational() | Returns a rational value when the DataType property is a rational list for the current scan setting. The ListIndex property must be set to the index of the rational value to retrieve from the rational list before calling this property.
ListRational(Int32) | Returns a rational value allowing passing in a given index.

See Also

Reference

Setting Class
Setting Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
ListRational() Method
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Setting Class > ListRational Method : ListRational() Method

Glossary Item Box

Returns a rational value when the DataType property is a rational list for the current scan setting. The ListIndex property must be set to the index of the rational value to retrieve from the rational list before calling this property.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Function ListRational() As RationalType
'Usage

Dim instance As Setting
Dim value As RationalType

value = instance.ListRational()
public RationalType ListRational()
public: RationalType* ListRational();
public:
RationalType^ ListRational();

Return Value

An integer value which represents a rational value when the DataType is a rational list for the current scan setting.

Remarks

The ListIndex property must be set to the index of the rational value to retrieve from the rational list before calling this property.

See Also

Reference

Setting Class
Setting Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
ListRational(Int32) Method
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Setting Class > ListRational Method : ListRational(Int32) Method

index
An integer value which represents an index value from the list of values.

Glossary Item Box

Returns a rational value allowing passing in a given index.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Function ListRational( _
   ByVal index As Integer _
) As RationalType
'Usage

Dim instance As Setting
Dim index As Integer
Dim value As RationalType

value = instance.ListRational(index)
public RationalType ListRational(
   int index
)
public: RationalType* ListRational(
   int index
)
public:
RationalType^ ListRational(
   int index
)

Parameters

index
An integer value which represents an index value from the list of values.

Return Value

An integer value which represents the rational value from the list of values.

See Also

Reference

Setting Class
Setting Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
ListString Method
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Setting Class : ListString Method

Glossary Item Box

Returns a string value when the DataType property is a string list for the current scan setting. The ListIndex property must be set to the index of the string value to retrieve from the string list before calling this property.

Overload List

Overload | Description
ListString() | Returns a string value when the DataType property is a string list for the current scan setting. The ListIndex property must be set to the index of the string value to retrieve from the string list before calling this property.
ListString(Int32) | Returns a string value when the DataType property is a string list for the current scan setting.

See Also

Reference

Setting Class
Setting Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
ListString() Method
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Setting Class > ListString Method : ListString() Method

Glossary Item Box

Returns a string value when the DataType property is a string list for the current scan setting. The ListIndex property must be set to the index of the string value to retrieve from the string list before calling this property.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Function ListString() As String
'Usage

Dim instance As Setting
Dim value As String

value = instance.ListString()
public string ListString()
public: string* ListString();
public:
String^ ListString();

Return Value

An integer value which represents a string value when the DataType property is a string list for the current scan setting.

See Also

Reference

Setting Class
Setting Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
ListString(Int32) Method
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Setting Class > ListString Method : ListString(Int32) Method

index
An integer which represents the index of the string to retrieve from the string list.

Glossary Item Box

Returns a string value when the DataType property is a string list for the current scan setting.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Function ListString( _
   ByVal index As Integer _
) As String
'Usage

Dim instance As Setting
Dim index As Integer
Dim value As String

value = instance.ListString(index)
public string ListString(
   int index
)
public: string* ListString(
   int index
)
public:
String^ ListString(
   int index
)

Parameters

index
An integer which represents the index of the string to retrieve from the string list.

Return Value

A string value which represents the current scan setting.

See Also

Reference

Setting Class
Setting Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
LongDefault Method
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Setting Class : LongDefault Method

Glossary Item Box

Returns a long value at the specified index from the list of values for the default scan setting.

Overload List

Overload | Description
LongDefault(Int32) | Returns a long value at the specified index from the list of values for the default scan setting.
LongDefault() | Returns a long value for the default scan setting.

See Also

Reference

Setting Class
Setting Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
LongDefault(Int32) Method
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Setting Class > LongDefault Method : LongDefault(Int32) Method

index
An integer which represents an index in the list of long values.

Glossary Item Box

Returns a long value at the specified index from the list of values for the default scan setting.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Function LongDefault( _
   ByVal index As Integer _
) As Integer
'Usage

Dim instance As Setting
Dim index As Integer
Dim value As Integer

value = instance.LongDefault(index)
public int LongDefault(
   int index
)
public: int LongDefault(
   int index
)
public:
int LongDefault(
   int index
)

Parameters

index
An integer which represents an index in the list of long values.

Return Value

An integer which represents a long value at the given index within the collection.

See Also

Reference

Setting Class
Setting Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
LongDefault() Method
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Setting Class > LongDefault Method : LongDefault() Method

Glossary Item Box

Returns a long value for the default scan setting.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Function LongDefault() As Integer
'Usage

Dim instance As Setting
Dim value As Integer

value = instance.LongDefault()
public int LongDefault()
public: int LongDefault();
public:
int LongDefault();

Return Value

An integer value which represents the value for the default scan setting.

Remarks

This method is only available for Advanced settings.

See Also

Reference

Setting Class
Setting Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
RangeMaximumRational Method
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Setting Class : RangeMaximumRational Method

Glossary Item Box

Returns the highest possible rational value for the current scan setting when the scan setting is a range of values.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function RangeMaximumRational() As RationalType
'Usage

Dim instance As Setting
Dim value As RationalType

value = instance.RangeMaximumRational()
public RationalType RangeMaximumRational()
public: RationalType* RangeMaximumRational();
public:
RationalType^ RangeMaximumRational();

Return Value

A RationalType object which represents the highest possible rational value for the current scan setting when the scan setting is a range of values.

Remarks

Check all values against this property before applying it because the lowest rational value can vary widely between different types of scanners.

See Also

Reference

Setting Class
Setting Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
RangeMinimumRational Method
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Setting Class : RangeMinimumRational Method

Glossary Item Box

Returns the lowest possible rational value for the current scan setting when the scan setting is a range of values.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function RangeMinimumRational() As RationalType
'Usage

Dim instance As Setting
Dim value As RationalType

value = instance.RangeMinimumRational()
public RationalType RangeMinimumRational()
public: RationalType* RangeMinimumRational();
public:
RationalType^ RangeMinimumRational();

Return Value

A RationalType object which represents the lowest possible rational value for the current scan setting when the scan setting is a range of values.

Remarks

Check all values against this property before applying it because the lowest rational value can vary widely between different types of scanners.

See Also

Reference

Setting Class
Setting Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
RationalDefault Method
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Setting Class : RationalDefault Method

Glossary Item Box

Returns a rational value at the given index in the list of rational values for the default scan setting.

Overload List

Overload | Description
RationalDefault(Int32) | Returns a rational value at the given index in the list of rational values for the default scan setting.
RationalDefault() | Returns a rational value for the default scan setting.

See Also

Reference

Setting Class
Setting Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
RationalDefault(Int32) Method
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Setting Class > RationalDefault Method : RationalDefault(Int32) Method

index
An integer which represents an index into the list of rational values.

Glossary Item Box

Returns a rational value at the given index in the list of rational values for the default scan setting.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Function RationalDefault( _
   ByVal index As Integer _
) As RationalType
'Usage

Dim instance As Setting
Dim index As Integer
Dim value As RationalType

value = instance.RationalDefault(index)
public RationalType RationalDefault(
   int index
)
public: RationalType* RationalDefault(
   int index
)
public:
RationalType^ RationalDefault(
   int index
)

Parameters

index
An integer which represents an index into the list of rational values.

Return Value

A rational value at the given index.

See Also

Reference

Setting Class
Setting Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
RationalDefault() Method
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Setting Class > RationalDefault Method : RationalDefault() Method

Glossary Item Box

Returns a rational value for the default scan setting.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Overloads Function RationalDefault() As RationalType
'Usage

Dim instance As Setting
Dim value As RationalType

value = instance.RationalDefault()
public RationalType RationalDefault()
public: RationalType* RationalDefault();
public:
RationalType^ RationalDefault();

Return Value

A RationalType object that represents the rational value for the default scan setting.

See Also

Reference

Setting Class
Setting Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
RationalStep Method
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Setting Class : RationalStep Method

Glossary Item Box

Returns the increment or step of rationals when changing values.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function RationalStep() As RationalType
'Usage

Dim instance As Setting
Dim value As RationalType

value = instance.RationalStep()
public RationalType RationalStep()
public: RationalType* RationalStep();
public:
RationalType^ RationalStep();

Return Value

A RationalType object that represents the increment or step of rationals when changing values.

See Also

Reference

Setting Class
Setting Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
StringDefault Method
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Setting Class : StringDefault Method

Glossary Item Box

Returns a string value for the default scan setting.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function StringDefault() As String
'Usage

Dim instance As Setting
Dim value As String

value = instance.StringDefault()
public string StringDefault()
public: string* StringDefault();
public:
String^ StringDefault();

Return Value

A string which represents a value for the default scan setting.

Remarks

This method is only available for Advanced settings.

See Also

Reference

Setting Class
Setting Members


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.ISISXpress5.Net
Setting Class Properties
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : Setting Class

Glossary Item Box

For a list of all members of this type, see Setting members.

Public Properties

 | Name | Description
Public Property | Advanced | Gets and sets the advanced tag number.
Public Property | DataType | Gets the data type encoded information for the current scanner setting.
Public Property | ListCount | Gets the number of available choices when the DataType property is a list for the current scan setting.
Public Property | ListIndex | Gets and sets the index for the list item to access when the DataType property is a list of the current scan setting.
Public Property | LongValue | Gets and sets a long value for the current scanner setting.
Public Property | RangeMaximumLong | Gets the highest possible long value for the current scan setting when the scan setting is a range of values.
Public Property | RangeMinimumLong | Gets the lowest possible long value for the current scan setting when the scan setting is a range of values.
Public Property | RationalValue | Gets and sets a rational for the current scanner setting.
Public Property | ScanSetting | Gets and sets the ScanSettingInfo enumeration scanner setting.
Public Property | StringValue | Gets and sets a string for the current scanner setting.
Public Property | Supported | Gets an indicator if the current scan setting is supported.
Top

See Also

Reference

Setting Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
Advanced Property
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Setting Class : Advanced Property

Glossary Item Box

Gets and sets the advanced tag number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property Advanced As Integer
'Usage

Dim instance As Setting
Dim value As Integer

instance.Advanced = value

value = instance.Advanced
public int Advanced {get; set;}
public: __property int get_Advanced();
public: __property void set_Advanced(
   int value
);
public:
property int Advanced {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the advanced tag number.

See Also

Reference

Setting Class
Setting Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
DataType Property
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Setting Class : DataType Property

Glossary Item Box

Gets the data type encoded information for the current scanner setting.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property DataType As DataTypeInfo
'Usage

Dim instance As Setting
Dim value As DataTypeInfo

value = instance.DataType
public DataTypeInfo DataType {get;}
public: __property DataTypeInfo get_DataType();
public:
property DataTypeInfo DataType {
   DataTypeInfo get();
}

Property Value

The DataTypeInfo enumeration value set.

See Also

Reference

Setting Class
Setting Members
DataTypeInfo Enumeration


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
ListCount Property
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Setting Class : ListCount Property

Glossary Item Box

Gets the number of available choices when the DataType property is a list for the current scan setting.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property ListCount As Integer
'Usage

Dim instance As Setting
Dim value As Integer

value = instance.ListCount
public int ListCount {get;}
public: __property int get_ListCount();
public:
property int ListCount {
   int get();
}

Property Value

An integer value which represents the number of choices when the DataType property is a list of the current scan setting.

Remarks

This property is used to get the maximum value that can be used to access the ListLong, ListRational, or ListString property arrays. The maximum value is ListCount property -1.

See Also

Reference

Setting Class
Setting Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
ListIndex Property
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Setting Class : ListIndex Property

Glossary Item Box

Gets and sets the index for the list item to access when the DataType property is a list of the current scan setting.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property ListIndex As Integer
'Usage

Dim instance As Setting
Dim value As Integer

instance.ListIndex = value

value = instance.ListIndex
public int ListIndex {get; set;}
public: __property int get_ListIndex();
public: __property void set_ListIndex(
   int value
);
public:
property int ListIndex {
   int get();
   void set (    int value);
}

See Also

Reference

Setting Class
Setting Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
LongValue Property
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Setting Class : LongValue Property

Glossary Item Box

Gets and sets a long value for the current scanner setting.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property LongValue As Integer
'Usage

Dim instance As Setting
Dim value As Integer

instance.LongValue = value

value = instance.LongValue
public int LongValue {get; set;}
public: __property int get_LongValue();
public: __property void set_LongValue(
   int value
);
public:
property int LongValue {
   int get();
   void set (    int value);
}

Property Value

An integer value which represents the current scanner setting.

See Also

Reference

Setting Class
Setting Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
RangeMaximumLong Property
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Setting Class : RangeMaximumLong Property

Glossary Item Box

Gets the highest possible long value for the current scan setting when the scan setting is a range of values.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property RangeMaximumLong As Integer
'Usage

Dim instance As Setting
Dim value As Integer

value = instance.RangeMaximumLong
public int RangeMaximumLong {get;}
public: __property int get_RangeMaximumLong();
public:
property int RangeMaximumLong {
   int get();
}

Property Value

An integer value which represents the highest possible long value for the current scan setting when the scan setting is a range of values.

Remarks

A value should always be checked against this property before applying it because the highest long value can vary widely between different types of scanners.

See Also

Reference

Setting Class
Setting Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
RangeMinimumLong Property
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Setting Class : RangeMinimumLong Property

Glossary Item Box

Gets the lowest possible long value for the current scan setting when the scan setting is a range of values.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property RangeMinimumLong As Integer
'Usage

Dim instance As Setting
Dim value As Integer

value = instance.RangeMinimumLong
public int RangeMinimumLong {get;}
public: __property int get_RangeMinimumLong();
public:
property int RangeMinimumLong {
   int get();
}

Property Value

An integer value which represents the lowest possible long value for the current scan setting when the scan setting is a range of values.

Remarks

A value should always be checked against this property before applying it because the lowest long value can vary widely between different types of scanners.

See Also

Reference

Setting Class
Setting Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
RationalValue Property
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Setting Class : RationalValue Property

Glossary Item Box

Gets and sets a rational for the current scanner setting.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property RationalValue As RationalType
'Usage

Dim instance As Setting
Dim value As RationalType

instance.RationalValue = value

value = instance.RationalValue
public RationalType RationalValue {get; set;}
public: __property RationalType* get_RationalValue();
public: __property void set_RationalValue(
   RationalType* value
);
public:
property RationalType^ RationalValue {
   RationalType^ get();
   void set (    RationalType^ value);
}

Property Value

A RationalType object for the current scanner setting.

See Also

Reference

Setting Class
Setting Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
ScanSetting Property
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Setting Class : ScanSetting Property

Glossary Item Box

Gets and sets the ScanSettingInfo enumeration scanner setting.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property ScanSetting As ScanSettingInfo
'Usage

Dim instance As Setting
Dim value As ScanSettingInfo

instance.ScanSetting = value

value = instance.ScanSetting
public ScanSettingInfo ScanSetting {get; set;}
public: __property ScanSettingInfo get_ScanSetting();
public: __property void set_ScanSetting(
   ScanSettingInfo value
);
public:
property ScanSettingInfo ScanSetting {
   ScanSettingInfo get();
   void set (    ScanSettingInfo value);
}

Property Value

A ScanSettingInfo enumeration value set.

Remarks

All scanner settings are modified by setting the Setting property's ScanSetting property to the appropriate setting and then using one of the setting properties such as the LongValue property or the StringValue property to set up the scanner.

Setting this property also automatically sets the Advanced property to true.

See Also

Reference

Setting Class
Setting Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
StringValue Property
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Setting Class : StringValue Property

Glossary Item Box

Gets and sets a string for the current scanner setting.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Property StringValue As String
'Usage

Dim instance As Setting
Dim value As String

instance.StringValue = value

value = instance.StringValue
public string StringValue {get; set;}
public: __property string* get_StringValue();
public: __property void set_StringValue(
   string* value
);
public:
property String^ StringValue {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value which represents the current scanner setting.

See Also

Reference

Setting Class
Setting Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
Supported Property
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > Setting Class : Supported Property

Glossary Item Box

Gets an indicator if the current scan setting is supported.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public ReadOnly Property Supported As Boolean
'Usage

Dim instance As Setting
Dim value As Boolean

value = instance.Supported
public bool Supported {get;}
public: __property bool get_Supported();
public:
property bool Supported {
   bool get();
}

Property Value

A boolean value which is true if the current scan setting is supported. Otherwise, false is returned.

See Also

Reference

Setting Class
Setting Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
SettingUnavailableException Class
Members See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : SettingUnavailableException Class

Glossary Item Box

This class implements the SettingUnavailableException to throw when the setting is not available.

Object Model

SettingUnavailableException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class SettingUnavailableException
   Inherits IsisXpressLibraryException
'Usage

Dim instance As SettingUnavailableException
[SerializableAttribute()]
public sealed class SettingUnavailableException : IsisXpressLibraryException
[SerializableAttribute()]
public __gc __sealed class SettingUnavailableException : public IsisXpressLibraryException
[SerializableAttribute()]
public ref class SettingUnavailableException sealed : public IsisXpressLibraryException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.ISISXpressSdk.IsisXpressLibraryException
Accusoft.ISISXpressSdk.SettingUnavailableException

See Also

Reference

SettingUnavailableException Members
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.ISISXpress5.Net
SettingUnavailableException Class Members
See Also Properties Methods Send Feedback
Accusoft.ISISXpressSdk Namespace : SettingUnavailableException Class

Glossary Item Box

The following tables list the members exposed by SettingUnavailableException.

Public Constructors

 | Name | Description
Public Constructor | SettingUnavailableException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the number or ID of the specific error that occurred. (Inherited from Accusoft.ISISXpressSdk.IsisXpressLibraryException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

SettingUnavailableException Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.ISISXpress5.Net
SettingUnavailableException Class Methods
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : SettingUnavailableException Class

Glossary Item Box

For a list of all members of this type, see SettingUnavailableException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

SettingUnavailableException Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.ISISXpress5.Net
SettingUnavailableException Class Properties
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : SettingUnavailableException Class

Glossary Item Box

For a list of all members of this type, see SettingUnavailableException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the number or ID of the specific error that occurred. (Inherited from Accusoft.ISISXpressSdk.IsisXpressLibraryException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Top

See Also

Reference

SettingUnavailableException Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
SettingUnavailableException Constructor
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > SettingUnavailableException Class : SettingUnavailableException Constructor

Glossary Item Box

Overload List

Overload | Description
SettingUnavailableException Constructor() | The main constructor for the SettingUnavailableException class to throw when the setting is not available.
SettingUnavailableException Constructor(Int32) | A SettingUnavailableException which allows passing in an error number.
SettingUnavailableException Constructor(String) | A SettingUnavailableException which allows passing in an error message.
SettingUnavailableException Constructor(Int32,String) | A SettingUnavailableException which allows passing in an error number and an error message.
SettingUnavailableException Constructor(String,Exception) | A SettingUnavailableException which allows passing in an error message and an inner exception.

See Also

Reference

SettingUnavailableException Class
SettingUnavailableException Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
SettingUnavailableException Constructor()
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > SettingUnavailableException Class > SettingUnavailableException Constructor : SettingUnavailableException Constructor()

Glossary Item Box

The main constructor for the SettingUnavailableException class to throw when the setting is not available.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New SettingUnavailableException()
public SettingUnavailableException()
public: SettingUnavailableException();
public:
SettingUnavailableException();

See Also

Reference

SettingUnavailableException Class
SettingUnavailableException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
SettingUnavailableException Constructor(Int32)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > SettingUnavailableException Class > SettingUnavailableException Constructor : SettingUnavailableException Constructor(Int32)

errorNumber
An integer value which represents the error number.

Glossary Item Box

A SettingUnavailableException which allows passing in an error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New SettingUnavailableException(errorNumber)
public SettingUnavailableException(
   int errorNumber
)
public: SettingUnavailableException(
   int errorNumber
)
public:
SettingUnavailableException(
   int errorNumber
)

Parameters

errorNumber
An integer value which represents the error number.

See Also

Reference

SettingUnavailableException Class
SettingUnavailableException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
SettingUnavailableException Constructor(String)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > SettingUnavailableException Class > SettingUnavailableException Constructor : SettingUnavailableException Constructor(String)

message
A string value which represents the error message.

Glossary Item Box

A SettingUnavailableException which allows passing in an error message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New SettingUnavailableException(message)
public SettingUnavailableException(
   string message
)
public: SettingUnavailableException(
   string* message
)
public:
SettingUnavailableException(
   String^ message
)

Parameters

message
A string value which represents the error message.

See Also

Reference

SettingUnavailableException Class
SettingUnavailableException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
SettingUnavailableException Constructor(Int32,String)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > SettingUnavailableException Class > SettingUnavailableException Constructor : SettingUnavailableException Constructor(Int32,String)

errorNumber
An integer value which represents the error number.
message
A string value which represents the error message.

Glossary Item Box

A SettingUnavailableException which allows passing in an error number and an error message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New SettingUnavailableException(errorNumber, message)
public SettingUnavailableException(
   int errorNumber,
   string message
)
public: SettingUnavailableException(
   int errorNumber,
   string* message
)
public:
SettingUnavailableException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer value which represents the error number.
message
A string value which represents the error message.

See Also

Reference

SettingUnavailableException Class
SettingUnavailableException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
SettingUnavailableException Constructor(String,Exception)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > SettingUnavailableException Class > SettingUnavailableException Constructor : SettingUnavailableException Constructor(String,Exception)

message
A string value which represents the error message.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

Glossary Item Box

A SettingUnavailableException which allows passing in an error message and an inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New SettingUnavailableException(message, innerException)
public SettingUnavailableException(
   string message,
   Exception innerException
)
public: SettingUnavailableException(
   string* message,
   Exception* innerException
)
public:
SettingUnavailableException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string value which represents the error message.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

See Also

Reference

SettingUnavailableException Class
SettingUnavailableException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
StringTooLongException Class
Members See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : StringTooLongException Class

Glossary Item Box

This class implements the StringToolLongExceptions when the string is too long.

Object Model

StringTooLongException Class

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<SerializableAttribute()>
Public NotInheritable Class StringTooLongException
   Inherits IsisXpressLibraryException
'Usage

Dim instance As StringTooLongException
[SerializableAttribute()]
public sealed class StringTooLongException : IsisXpressLibraryException
[SerializableAttribute()]
public __gc __sealed class StringTooLongException : public IsisXpressLibraryException
[SerializableAttribute()]
public ref class StringTooLongException sealed : public IsisXpressLibraryException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Accusoft.ISISXpressSdk.IsisXpressLibraryException
Accusoft.ISISXpressSdk.StringTooLongException

See Also

Reference

StringTooLongException Members
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%% $$Members$$

[image]
Accusoft.ISISXpress5.Net
StringTooLongException Class Members
See Also Properties Methods Send Feedback
Accusoft.ISISXpressSdk Namespace : StringTooLongException Class

Glossary Item Box

The following tables list the members exposed by StringTooLongException.

Public Constructors

 | Name | Description
Public Constructor | StringTooLongException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the number or ID of the specific error that occurred. (Inherited from Accusoft.ISISXpressSdk.IsisXpressLibraryException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

StringTooLongException Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%% $$Methods$$

[image]
Accusoft.ISISXpress5.Net
StringTooLongException Class Methods
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : StringTooLongException Class

Glossary Item Box

For a list of all members of this type, see StringTooLongException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

StringTooLongException Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%% $$Properties$$

[image]
Accusoft.ISISXpress5.Net
StringTooLongException Class Properties
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : StringTooLongException Class

Glossary Item Box

For a list of all members of this type, see StringTooLongException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Number | Gets the number or ID of the specific error that occurred. (Inherited from Accusoft.ISISXpressSdk.IsisXpressLibraryException)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Top

See Also

Reference

StringTooLongException Class
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
StringTooLongException Constructor
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > StringTooLongException Class : StringTooLongException Constructor

Glossary Item Box

Overload List

Overload | Description
StringTooLongException Constructor() | The main constructor to throw when a string is too long.
StringTooLongException Constructor(Int32) | A StringTooLongException which allows passing in an error number.
StringTooLongException Constructor(String) | A StringTooLongException which allows passing in an error message.
StringTooLongException Constructor(Int32,String) | A StringTooLongException which allows passing in an error number and an error message.
StringTooLongException Constructor(String,Exception) | A StringTooLongException which allows passing in an error message and inner exception.

See Also

Reference

StringTooLongException Class
StringTooLongException Members


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
StringTooLongException Constructor()
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > StringTooLongException Class > StringTooLongException Constructor : StringTooLongException Constructor()

Glossary Item Box

The main constructor to throw when a string is too long.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New StringTooLongException()
public StringTooLongException()
public: StringTooLongException();
public:
StringTooLongException();

See Also

Reference

StringTooLongException Class
StringTooLongException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
StringTooLongException Constructor(Int32)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > StringTooLongException Class > StringTooLongException Constructor : StringTooLongException Constructor(Int32)

errorNumber
An integer value which represents the error number.

Glossary Item Box

A StringTooLongException which allows passing in an error number.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer _
)
'Usage

Dim errorNumber As Integer

Dim instance As New StringTooLongException(errorNumber)
public StringTooLongException(
   int errorNumber
)
public: StringTooLongException(
   int errorNumber
)
public:
StringTooLongException(
   int errorNumber
)

Parameters

errorNumber
An integer value which represents the error number.

See Also

Reference

StringTooLongException Class
StringTooLongException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
StringTooLongException Constructor(String)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > StringTooLongException Class > StringTooLongException Constructor : StringTooLongException Constructor(String)

message
A string value which represents the error message.

Glossary Item Box

A StringTooLongException which allows passing in an error message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String _
)
'Usage

Dim message As String

Dim instance As New StringTooLongException(message)
public StringTooLongException(
   string message
)
public: StringTooLongException(
   string* message
)
public:
StringTooLongException(
   String^ message
)

Parameters

message
A string value which represents the error message.

See Also

Reference

StringTooLongException Class
StringTooLongException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
StringTooLongException Constructor(Int32,String)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > StringTooLongException Class > StringTooLongException Constructor : StringTooLongException Constructor(Int32,String)

errorNumber
An integer value which represents an error number.
message
A string value which represents the error message.

Glossary Item Box

A StringTooLongException which allows passing in an error number and an error message.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
'Usage

Dim errorNumber As Integer
Dim message As String

Dim instance As New StringTooLongException(errorNumber, message)
public StringTooLongException(
   int errorNumber,
   string message
)
public: StringTooLongException(
   int errorNumber,
   string* message
)
public:
StringTooLongException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
An integer value which represents an error number.
message
A string value which represents the error message.

See Also

Reference

StringTooLongException Class
StringTooLongException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
StringTooLongException Constructor(String,Exception)
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace > StringTooLongException Class > StringTooLongException Constructor : StringTooLongException Constructor(String,Exception)

message
A string value which represents the error message.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

Glossary Item Box

A StringTooLongException which allows passing in an error message and inner exception.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
'Usage

Dim message As String
Dim innerException As Exception

Dim instance As New StringTooLongException(message, innerException)
public StringTooLongException(
   string message,
   Exception innerException
)
public: StringTooLongException(
   string* message,
   Exception* innerException
)
public:
StringTooLongException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string value which represents the error message.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

See Also

Reference

StringTooLongException Class
StringTooLongException Members
Overload List


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
DataTypeInfo Enumeration
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : DataTypeInfo Enumeration

Glossary Item Box

Option values for the data type the information is encoded in for the current scanner setting.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum DataTypeInfo
   Inherits System.Enum
'Usage

Dim instance As DataTypeInfo
public enum DataTypeInfo : System.Enum
__value public enum DataTypeInfo : public System.Enum
public enum class DataTypeInfo : public System.Enum

Members

Member | Value | Description
ListLong | 1 | A list or array of longs. For example 200, 300, 400, 500.
ListRational | 6 | A list or array of rationals. For example 200/1, 300/1, 400/1, 500/1. This data type is only available for Advanced settings.
ListString | 2 | A list or array of strings. For example "8.5 x 11 letter", "8.5 x 14 legal", and etc..
Long | 4 | A long. This can also be used for a byte or a short.
RangeLong | 0 | A range of longs. For example 0 - 99.
RangeRational | 7 | A range of rationals. For example 1/1 - 1200/1. See the Setting.RationalStep method for the increment between rationals. This data type is only available for Advanced settings.
Rational | 5 | A rational. See the RationalType for more information. This data type is only available for Advanced settings.
String | 3 | A string.

Remarks

This value is set by using the Setting.DataType property.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ISISXpressSdk.DataTypeInfo

See Also

Reference

Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
ErrorLevelInfo Enumeration
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : ErrorLevelInfo Enumeration

Glossary Item Box

Option values to set the error level to use.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum ErrorLevelInfo
   Inherits System.Enum
'Usage

Dim instance As ErrorLevelInfo
public enum ErrorLevelInfo : System.Enum
__value public enum ErrorLevelInfo : public System.Enum
public enum class ErrorLevelInfo : public System.Enum

Members

Member | Value | Description
Detailed | 2 | This setting produces detailed error information useful when debugging a problem during development.
Development | 1 | This setting produces additional error information useful during development.
Production | 0 | This setting produces the minimum amount of error information.

Remarks

The default value is Production.

This value is set using the IsisXpress.ErrorLevel property which can help in debugging an application during development.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ISISXpressSdk.ErrorLevelInfo

See Also

Reference

Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
EvaluationChoice Enumeration
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : EvaluationChoice Enumeration

Glossary Item Box

Option values for licensing the evaluation version within the component.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum EvaluationChoice
   Inherits System.Enum
'Usage

Dim instance As EvaluationChoice
public enum EvaluationChoice : System.Enum
__value public enum EvaluationChoice : public System.Enum
public enum class EvaluationChoice : public System.Enum

Members

Member | Value | Description
Timeout | 1 | After the trial period has expired, the ISIS Xpress component no longer functions.
TrialDialog | 0 | After the trial period has expired, this option displays a dialog box each time the ISIS Xpess toolkit is accessed.

Remarks

These values are set by using the Licensing.EvaluationMode property.

In order to test the component in an application running as a service or other environments where the component does not have permissions to create a window, the application logic needs to set the EvaluationMode to Timeout. In this mode, the component does not attempt to create the Evaluation Mode dialog window, but will timeout after 5 minutes of operation and cease to operate.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ISISXpressSdk.EvaluationChoice

See Also

Reference

Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
FileTypeInfo Enumeration
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : FileTypeInfo Enumeration

Glossary Item Box

Option values for the file format to use when saving images.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum FileTypeInfo
   Inherits System.Enum
'Usage

Dim instance As FileTypeInfo
public enum FileTypeInfo : System.Enum
__value public enum FileTypeInfo : public System.Enum
public enum class FileTypeInfo : public System.Enum

Members

Member | Value | Description
Dcx | 7 | DCX compression.
JpegColor | 5 | JPEG color compression.
JpegGray | 6 | JPEG Gray compression.
TiffG3 | 2 | CCITT (International Telegraph and Telephone Consultative Committee) Fax Group 3 compression.
TiffG3M | 3 | CCITT Fax Modified Group 3 compression.
TiffG4 | 4 | CCITT Fax Group 4 compression.
TiffPackBits | 1 | Packbits compression.
TiffRaw | 0 | No compression.

Remarks

This value is set by using the Output.FileType property.

1 bit (black and white) images can be saved to any of the five TIFF file formats or to the DCX file format. 8 bit (Gray Scale) images can be saved to the TiffRaw, TiffPackbits or JpegGray file formats. 24 bit (color) images can be saved to the TiffRaw, TiffPackbits or JPEG file formats.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ISISXpressSdk.FileTypeInfo

See Also

Reference

Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
ScanAhead Enumeration
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : ScanAhead Enumeration

Glossary Item Box

Option values for determining the scan ahead settings.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum ScanAhead
   Inherits System.Enum
'Usage

Dim instance As ScanAhead
public enum ScanAhead : System.Enum
__value public enum ScanAhead : public System.Enum
public enum class ScanAhead : public System.Enum

Members

Member | Value | Description
Off | 0 | Scan ahead is off or disabled.
On | 1 | Scan ahead is on or enabled.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ISISXpressSdk.ScanAhead

See Also

Reference

Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
ScanSettingInfo Enumeration
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : ScanSettingInfo Enumeration

Glossary Item Box

Option values for determining which scanner setting to query or set.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum ScanSettingInfo
   Inherits System.Enum
'Usage

Dim instance As ScanSettingInfo
public enum ScanSettingInfo : System.Enum
__value public enum ScanSettingInfo : public System.Enum
public enum class ScanSettingInfo : public System.Enum

Members

Member | Value | Description
AdvancedTag | 16 | Specifies the scanner's advanced tag number.
BitsPerSample | 15 | Indicates how big a sample is. Typical values are: 1 = Binary; 4 = four-bit gray scale (16 shades of gray); 8 = eight-bit gray scale (256 shades of gray); 24 = 24-bit color.
Brightness | 3 | The scanner's brightness. If available, -3 will set to auto brightness, -2 will auto darken, and -1 will auto lighten. Values from 0 to the Setting.RangeMaximumLong property incrementally change the brightness.
Contrast | 4 | The scanner's contrast. A value of 0 means auto contrast or no contrast control is available.
ImageLength | 8 | Specifies the number of rows of pixels (height) in an image.
ImageWidth | 7 | Specifies the number of columns of pixels (width) in an image.
PageSize | 2 | The total area available to the scanner.
ResUnit 9

Specifies the unit of measurement for XResolution and YResolution. This setting is not available for all scanners and if it is not available, the units are assumed to be DPI.

1. No absolute unit of measurement. Used for images that may have a non-square aspect ratio, but no meaningful absolute dimensions.

2. Resolution is specified in dots per inch (DPI).

3. Resolution is specified in dots per centimeter.

SamplesPerPixel | 14 | Indicates how many values each pixel uses to represent the data. Possible values are: 1 sample per pixel = Binary (black/white) and gray scale images; 3 samples per pixel = RGB color images.
ScanAhead | 11 | Specifies if the scanning source has enabled the ability to continuously scan pages ahead of the current page the application is processing on those scanners that support this functionality. See the ScanAhead enumeration for more information.
ScanAheadMaxPages | 12 | If the ScanAhead is enabled, this setting specifies the maximum number of pages to scan ahead. A zero value means to scan until the feeder is empty.
ScanAheadPages | 13 | If the ScanAhead is enabled and this setting is supported, it determines how many pages have been scanned in ahead. On some scanners this value is not an accurate measurement for how many pages are scanned in ahead. Therefore, use this setting as a general indicator that there are pages waiting that have been scanned in ahead. This setting is read-only.
Source | 10 | Specifies the scanning source (flatbed, feeder, and etc.) on those scanners that support this functionality. See the Source enumeration for more information.
XPosition | 5 | Specifies the distance in pixels from the left edge of the page to the start of the image.
XResolution | 0 | The scanner's horizontal resolution in DPI (Dots Per Inch).
YPosition | 6 | Specifies the distance in pixels from the top edge of the page to the start of the image.
YResolution | 1 | The scanner's vertical resolution in DPI.

Remarks

All scanner settings are modified by setting the Setting.ScanSetting property to the appropriate setting and then using one of the setting properties such as the Setting.LongValue property or the Setting.StringValue property to set up the scanner.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ISISXpressSdk.ScanSettingInfo

See Also

Reference

Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
SetupOptions Enumeration
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : SetupOptions Enumeration

Glossary Item Box

Option values to modify what is displayed by the predefined scanner settings dialog.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

<FlagsAttribute()>
Public Enum SetupOptions
   Inherits System.Enum
'Usage

Dim instance As SetupOptions
[FlagsAttribute()]
public enum SetupOptions : System.Enum
[FlagsAttribute()]
__value public enum SetupOptions : public System.Enum
[FlagsAttribute()]
public enum class SetupOptions : public System.Enum

Members

Member | Value | Description
Area | 2 | Displays a scanner settings dialog that shows the Area button. When the Area button is clicked, and Area dialog is displayed.
AreaPreview | 8 | Displays a scanner dialog that displays the Area button. When the Area button is clicked, an Area dialog, containing a preview window is displayed.
Binary | 1 | Displays a scanner settings dialog that only allows binary modes. This prevents the user from choosing grayscale or color modes.
Normal | 0 | Displays the normal scanner settings dialog.
Return | 4 | Displays a scanner settings dialog that returns SCANERR_CANCEL if the user clicks the Cancel button. If this flag is not set, then the settings dialog is always returned with no error.

Remarks

These values are used with the Scanner.Setup methods.

This enumeration is a FlagsAttribute enumeration that can be treated as a bit field or a set of flags. The following example shows how this enumeration can be used:

ISISX.Scanner.Setup(Accusoft.ISISXpressSdk.SetupOptions.Binary | Accusoft.ISISXpressSdk.SetupOptions.Return);

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ISISXpressSdk.SetupOptions

See Also

Reference

Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
Source Enumeration
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : Source Enumeration

Glossary Item Box

Option values to set the scanning source information.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Enum Source
   Inherits System.Enum
'Usage

Dim instance As Source
public enum Source : System.Enum
__value public enum Source : public System.Enum
public enum class Source : public System.Enum

Members

Member | Value | Description
Automatic | 0 | Scan from the Automatic Document Feeder (ADF) if detected; otherwise, scan from the flatbed.
BackFront | 5 | Scan in duplex mode, but return the back side of the page first.
BackOnly | 6 | Scan only the back side of the page (duplex scanner).
Duplex | 4 | Scan in duplex mode.
Feeder | 3 | Scan from the feeder (front side only if duplex).
Flatbed | 2 | Scan from the flatbed.
Transparency | 1 | Scan from the transparency unit.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Accusoft.ISISXpressSdk.Source

See Also

Reference

Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
IsisXpress.FeederEmptyEventHandler Delegate
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : IsisXpress.FeederEmptyEventHandler Delegate

sender
An System.Object.
e
The FeederEmptyEventArgs.

Glossary Item Box

Indicates that the scanner feeder is empty.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Delegate Sub IsisXpress.FeederEmptyEventHandler( _
   ByVal sender As Object, _
   ByVal e As FeederEmptyEventArgs _
)
'Usage

Dim instance As New IsisXpress.FeederEmptyEventHandler(AddressOf HandlerMethod)
public delegate void IsisXpress.FeederEmptyEventHandler(
   object sender,
   FeederEmptyEventArgs e
)
public: __gc __delegate void IsisXpress.FeederEmptyEventHandler(
   Object* sender,
   FeederEmptyEventArgs* e
)
public delegate void IsisXpress.FeederEmptyEventHandler(
   Object^ sender,
   FeederEmptyEventArgs^ e
)

Parameters

sender
An System.Object.
e
The FeederEmptyEventArgs.

Remarks

This event is used to notify the user that the scanner feeder is empty during a batch scanning process.

See Also

Reference

IsisXpress.FeederEmptyEventHandler Members
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
IsisXpress.ProgressEventHandler Delegate
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : IsisXpress.ProgressEventHandler Delegate

sender
An System.Object.
e
The ProgressEventArgs.

Glossary Item Box

Indicates how much of the scan has completed. If the Scanner.UseCompression property is true then the Progress event is not fired during the scan.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Delegate Sub IsisXpress.ProgressEventHandler( _
   ByVal sender As Object, _
   ByVal e As ProgressEventArgs _
)
'Usage

Dim instance As New IsisXpress.ProgressEventHandler(AddressOf HandlerMethod)
public delegate void IsisXpress.ProgressEventHandler(
   object sender,
   ProgressEventArgs e
)
public: __gc __delegate void IsisXpress.ProgressEventHandler(
   Object* sender,
   ProgressEventArgs* e
)
public delegate void IsisXpress.ProgressEventHandler(
   Object^ sender,
   ProgressEventArgs^ e
)

Parameters

sender
An System.Object.
e
The ProgressEventArgs.

See Also

Reference

IsisXpress.ProgressEventHandler Members
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
IsisXpress.ScannedEventHandler Delegate
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : IsisXpress.ScannedEventHandler Delegate

sender
An System.Object.
e
The ScannedEventArgs.

Glossary Item Box

Fired after a scan to allow the user to check or set the Output.ToHdib property.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Delegate Sub IsisXpress.ScannedEventHandler( _
   ByVal sender As Object, _
   ByVal e As ScannedEventArgs _
)
'Usage

Dim instance As New IsisXpress.ScannedEventHandler(AddressOf HandlerMethod)
public delegate void IsisXpress.ScannedEventHandler(
   object sender,
   ScannedEventArgs e
)
public: __gc __delegate void IsisXpress.ScannedEventHandler(
   Object* sender,
   ScannedEventArgs* e
)
public delegate void IsisXpress.ScannedEventHandler(
   Object^ sender,
   ScannedEventArgs^ e
)

Parameters

sender
An System.Object.
e
The ScannedEventArgs.

See Also

Reference

IsisXpress.ScannedEventHandler Members
Accusoft.ISISXpressSdk Namespace


%%PageItemTitle%%

[image]
Accusoft.ISISXpress5.Net
IsisXpress.ScanningEventHandler Delegate
See Also Send Feedback
Accusoft.ISISXpressSdk Namespace : IsisXpress.ScanningEventHandler Delegate

sender
An System.Object.
e
The ScanningEventArgs.

Glossary Item Box

Fired before a scan to allow the user to check or modify the Output.Filename property.

Syntax

Visual Basic
C#
Managed Extensions for C++
C++/CLI
'Declaration

Public Delegate Sub IsisXpress.ScanningEventHandler( _
   ByVal sender As Object, _
   ByVal e As ScanningEventArgs _
)
'Usage

Dim instance As New IsisXpress.ScanningEventHandler(AddressOf HandlerMethod)
public delegate void IsisXpress.ScanningEventHandler(
   object sender,
   ScanningEventArgs e
)
public: __gc __delegate void IsisXpress.ScanningEventHandler(
   Object* sender,
   ScanningEventArgs* e
)
public delegate void IsisXpress.ScanningEventHandler(
   Object^ sender,
   ScanningEventArgs^ e
)

Parameters

sender
An System.Object.
e
The ScanningEventArgs.

See Also

Reference

IsisXpress.ScanningEventHandler Members
Accusoft.ISISXpressSdk Namespace