ThumbnailXpress User Assistance Dashboard

Accusoft.ThumbnailXpress4.ActiveX
ThumbnailXpress User Assistance Dashboard
Send Feedback

Glossary Item Box

Welcome

  • Overview of Product Family
    • What is the ImagXpress Product Family?
  • New Features
    • What is ThumbnailXpress?

Getting Started

  • Operating Requirements & Installation
    • Operating Requirements
    • Upgrading from ThumbnailXpress 3 to ThumbnailXpress 4
    • Installing on a Development Machine
  • Licensing & Deployment
    • Licensing
    • Distributing ThumbnailXpress
    • Software License Agreement
    • Accusoft Corporation Copyrights & Trademarks

Developer's Guide

  • User Guide

    • Concepts

      • Overview of ThumbnailXpress
      • Glossary
    • How To
      • Define Cache & Threading Behavior
      • Define End-User Interface
      • Render Thumbnails with Annotations
      • Load & Display Thumbnails
      • Modify Thumbnails
      • Navigate Thumbnails
      • Save Thumbnails
      • Print Thumbnails
      • Debug
  • API Reference Guide
    • Accusoft.ThumbnailXpress4.ActiveX.dll

Additional Resources

  • White papers & Case Studies
  • FAQs, ThumbnailXpress FAQs
  • Support Overview
  • Support Plans/Agreement

Feedback

  • Tell us what you think
    • Email us
    • Take our survey

©2012. Accusoft Corporation. All Rights Reserved.


ThumbnailXpress 4 for ActiveX - User Guide

Accusoft.ThumbnailXpress4.ActiveX
ThumbnailXpress 4 for ActiveX - User Guide
Send Feedback

Glossary Item Box

This User Guide provides the following information:

  • Introduction
  • Getting Started
  • Licensing
  • Distributing Applications and Deployment
  • Concepts
  • How To


Introduction

Accusoft.ThumbnailXpress4.ActiveX
Introduction
Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > Introduction

Glossary Item Box

This Introduction provides information about the following:

  • What is ThumbnailXpress?
  • What is the ImagXpress Product Family?
  • Getting Support
  • Accusoft Corporation Copyrights & Trademarks


What is ThumbnailXpress?

Accusoft.ThumbnailXpress4.ActiveX
What is ThumbnailXpress?
See Also Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > Introduction > What is ThumbnailXpress?

Glossary Item Box

ThumbnailXpress™ Version 4 provides support for the generation and display of thumbnail images.

New Features in Version 4

ThumbnailXpress 4 introduces the ability to do the following:

  • Display annotations associated with the displayed image data.
  • Set the border color and/or background color on individual thumbnails.
  • Use customer provided error icons and pre-display icons.
  • Indicate whether or not to use an embedded thumbnail of a camera raw image.
  • Return the version/build number programmatically.
  • Use Accusoft's new licensing model.

Primary Features

  • Input single image files,folders of images, and individual pages of multi-page images
  • Generates thumbnail images of all image types supported in ImagXpress
  • Integrate seamlessly with Accusoft PDFXpress™ for displaying thumbnail images of PDF files
  • Provides fast sizing and filtering of input files
  • Provides control of display features including thumbnail size, spacing, border lines, and selection
  • Provides control over sophisticated asynchronous threading capabilities for rapid generation of thumbnail images from source images
  • Optimized thumbnail caching for fast scrolling through thumbnail lists
  • Provide custom or various 'stock' labels for thumbnail items
  • Develop powerful image thumbnailing applications for Windows

See Also

Getting Support
Software License Agreement
Operating Requirements


What is the ImagXpress Product Family?

Accusoft.ThumbnailXpress4.ActiveX
What is the ImagXpress Product Family?
Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > Introduction > What is the ImagXpress Product Family?

Glossary Item Box

ImagXpress® Version 11 lets you quickly add the world's most trusted imaging functions to your Windows application. With our powerful imaging tools, you can quickly develop applications that require complex imaging tasks for document imaging, photo processing, or medical applications, while you concentrate on the unique needs of your program.

ImagXpress is the image handling engine behind most of our advanced recognition and image processing products. It's the fastest way to develop professional applications involving images.

The ImagXpress v11 Product Family includes the following Components:

  • ImagXpress v11 – image compression, decompression, viewing, and processing
  • NotateXpress™ v11 – image annotation support
  • ThumbnailXpress™ v4 – thumbnail image support
  • TwainPRO™ v7 – TWAIN image acquisition support
  • PrintPRO™ v6 – image printing support

ImagXpress Editions

The components within the ImagXpress v11 Product Family are available in two editions, designed to meet specific imaging needs:

  • Professional: includes ImagXpress, NotateXpress, TwainPRO, PrintPRO, and ThumbnailXpress
  • Standard: includes ImagXpress, TwainPRO, and ThumbnailXpress

Additional Accusoft Components

Additional components are available for purchase separately, and integrate easily to provide a comprehensive imaging solution:

  • ISIS® Xpress™ – ISIS image acquisition support; license sold separately
  • PDF Xpress™ – PDF creation, viewing, and annotating
  • OCR Xpress™ – full page OCR
  • Barcode Xpress™ – recognize barcodes
  • ScanFix Xpress™ – advanced image cleanup
  • FormFix™ – form ID, dropout, and OMR
  • SmartZone™ ICR / OCR – character recognition
  • ImageGear for .NET - Fully managed code to create cutting edge imaging applications
  • ImageGear for Silverlight - Comprehensive SDK for building Web imaging applications
  • ImageGear for .NET Compact Framework - Create reliable and secure imaging applications for mobile devices

See www.accusoft.com for product packaging and sales information.


Getting Support

Accusoft.ThumbnailXpress4.ActiveX
Getting Support
See Also Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > Introduction > Getting Support

Glossary Item Box

For information about Accusoft Support, please refer to the Software Support and Maintenance Policy on the Accusoft web site or call Accusoft at 813-875-7575.

See Also

Operating Requirements
Installing on a Development Machine


Accusoft Corporation Copyrights & Trademarks

Accusoft.ThumbnailXpress4.ActiveX
Accusoft Corporation Copyrights & Trademarks
See Also Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > Introduction > Accusoft Corporation Copyrights & Trademarks

Glossary Item Box

©2005-2012 Accusoft Corporation. All rights reserved.

Information in this document is subject to change without notice. No part of this document may be reproduced or transmitted in any form or by any means, electronic or mechanical, for any purpose, without the express written permission of Accusoft® Corporation.

This manual and the software described in it are both products of the USA.

Accusoft Corporation
4001 North Riverside Drive
Tampa, FL 33603
Sales: 813-875-7575
www.accusoft.com

Accusoft Trademarks

The following are trademarks (™) or registered marks (®) of Accusoft Corporation:

  • Accusoft®
  • Accusoft Logo™
  • Accusoft Pegasus Logo™
  • Adeptol®
  • AIMTools™
  • Barcode Xpress™
  • CapturePro™
  • Digital Mark Recognition® (DMR)
  • FolderBots™
  • FormAssist™
  • FormDirector™
  • FormFix™
  • FormSuite™
  • ImageGear® for .NET
  • ImageGear® for .NET Compact Framework
  • ImageGear® for Silverlight
  • ImageGear® Medical
  • ImageGear® Professional
  • ImageGear®
  • ImageTransport MD™
  • ImagXpress®
  • ISIS® Xpress™
    • ISIS is a registered trademark of EMC Corporation
    • ISIS Xpress is a trademark of Accusoft Corporation
  • MICR Xpress™
  • NetVue™
  • NotateXpress™
  • PDF Xpress™
  • Pegasus®
  • PICTools™
  • PICTools™ Document
  • PICTools™ Fingerprint
  • PICTools™ Medical
  • PICTools™ Photo
  • PICVideo™ M-JPEG Codec
  • PrintPRO™
  • Prizm®
  • Prizm® Viewer
  • ScanFix® Xpress™
  • SmartZone™
  • The JPEG Wizard™
  • ThumbnailXpress™
  • TwainPRO™

Accusoft and/or its agents use these marks and brand names in connection with its goods and/or services, in the United States and other countries.

Microsoft, Internet Explorer, Microsoft.NET, Silverlight, Visual Basic, Visual Studio, and Visual Studio.NET are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries.

Itanium is a registered trademark of Intel Corporation in the United States and other countries.

All other product and brand names are the property of their respective owners.

See Also

Software License Agreement


Getting Started

Accusoft.ThumbnailXpress4.ActiveX
Getting Started
Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > Getting Started

Glossary Item Box

This section provides information about the following:

  • Operating Requirements
  • Using Accusoft 64-bit ActiveX Components
  • Installing on a Development Machine
  • Import ThumbnailXpress as a COM Object
  • Use ThumbnailXpress as an ActiveX Control
  • Upgrading from ThumbnailXpress 3 to ThumbnailXpress 4


Operating Requirements

Accusoft.ThumbnailXpress4.ActiveX
Operating Requirements
See Also Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > Getting Started > Operating Requirements

Glossary Item Box

Operating Systems

ThumbnailXpress™ runs on 32-bit and 64-bit Microsoft Windows operating systems:

  • Windows XP, XP Professional
  • Windows Vista
  • Windows 7
  • Windows Server 2003
  • Windows Server 2008

ThumbnailXpress runs in 64-bit and 32-bit executables

Although it may run, it is not supported on previous Windows versions (for example, Windows 2000).

Threading

Accusoft considers thread-safe to be when an application using this component can use multiple controls running in the same process, where they don't interfere with each other. The thread creating the control owns the control and is the only thread that can interact with it.

Development Environment

  • Microsoft Visual Basic 6
  • Microsoft Visual C++ 6 or higher
  • Any other development environment that supports ActiveX/COM

See Also

Getting Support
Installing on a Development Machine


Using Accusoft 64-bit ActiveX Components

Accusoft.ThumbnailXpress4.ActiveX
Using Accusoft 64-bit ActiveX Components
Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > Getting Started > Using Accusoft 64-bit ActiveX Components

Glossary Item Box

Accusoft 64-bit ActiveX components are built for maximum compatibility with our 32-bit ActiveX counterparts, providing the customer ease of upgrading an existing 32-bit application.
The primary development platforms that we tested are Visual Studio C++, VBScript, JavaScript, C#, and VB.Net.

Upon inspection of these controls, you will notice that filenames will end in ActiveX for traditional 32-bit ActiveX controls or end in ActiveX64 for newer 64-bit ActiveX controls. If you use a tool such as OLEView, you will notice that when the control is registered they share the same GUID which allows the operating system ease of automatic selection.

Visual Studio is still a 32-bit development environment. The Accusoft installer will automatically place the 32-bit versions of the ActiveX in the toolbox. Since the components share the same interface and the same GUID, you can use all the ease of the Visual Studio development environment and still have all the power of 64-bit under the hood.

C++

When developing a C++ application you can #import in the progid, and compile targeting either Win64 or Win32. While progid is the recommended approach, if you #import by filename, we suggest you use the Sysnative redirector instead of the System32 directory as Visual Studio may get confused.

When creating a C++ dialog application, you can “Insert ActiveX Control…” onto the dialog. You will be presented with a dialog showing all the registered 32-bit controls. Select the desired ActiveX from the dialog. The second step of “Add Variable…” will automatically create accusoftcontrol1.h and accusoftcontrol1.cpp files that are compatible in both Win32 and Win64. The compiler will automatically use the correct version of the ActiveX based on the targeted platform.

Scripting

When using a scripting environment such as VBScript and JavaScript, the ActiveX controls will be able to seamlessly run under both Internet Explorer 32-bit and Internet Explorer 64-bit. Just code your HTML as you always have. Register both ActiveX and ActiveX64 on the target machine. You will be able to run under either the 32-bit or 64-bit version of Internet Explorer.

.Net

When creating a .Net AnyCPU application, you can import the ActiveX controls and have the application automatically switch if you are on a 32 or 64-bit machine. Just drag and drop the ActiveX control on your form as normal. Make sure the application is set for AnyCPU. Register both ActiveX and ActiveX64 on the target machine. The application will run as native code on any 32-bit or 64-bit machine (except Itanium).

If your application will only run on 64-bit machines, you can set the application to target x64, and only distribute the ActiveX64.

Handles

All handles are treated as 32-bit values. This creates full compatibility between all Accusoft controls, freeing the developer from worrying about what bit depth they are running in. If you use a third party control that has 64-bit handles, it is mandatory that you use the Microsoft provided LongToHandle and HandleToLong macros.


Installing on a Development Machine

Accusoft.ThumbnailXpress4.ActiveX
Installing on a Development Machine
See Also Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > Getting Started > Installing on a Development Machine

Glossary Item Box

To Install ThumbnailXpress™ Component

Run the downloaded setup program which installs the development kit on your development machine. The downloaded development kit includes code samples for supported platforms. Samples are available through: Start | Programs | Accusoft | ThumbnailXpress 4 menu.

By default, this will register trial licensing which allows you to develop applications but not to distribute them. The trial license allows testing of all the functions and features.

Please see the section Distributing ThumbnailXpress to understand the limits and details to convert licensing editions.
In order to distribute your finished application you must purchase and install a fully paid license from Accusoft. The paid licenses override trial licenses.

To Use ThumbnailXpress Help Files

Once you have installed ThumbnailXpress, you will have access to the following stand-alone help file:

  • Accusoft.ThumbnailXpress4.ActiveX.chm
    Access this stand-alone help file through the Windows Start menu: Start | Programs | Accusoft | ThumbnailXpress 4

See Also

Operating Requirements
Software License Agreement
Distributing ThumbnailXpress
Licensing


Import ThumbnailXpress as a COM Object

Accusoft.ThumbnailXpress4.ActiveX
Import ThumbnailXpress as a COM Object
Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > Getting Started > Import ThumbnailXpress as a COM Object

Glossary Item Box

1. Importing a Control into Visual C++

The #import directive line can be added to the stdafx.h file to provide the appropriate functionality to all source files in the project.

C++ Example Copy Code
// This code demonstrates the #import directive used in the stdafx.h file
#if !defined (AFX_STDAFX_H__CEEB89E9_40D9_11D3_9CFE_00400543FF49__INCLUDED_)
#define AFX_STDAFX_H__CEEB89E9_40D9_11D3_9CFE_00400543FF49__INCLUDED_
#define VC_EXTRALEAN // Exclude rarely-used stuff from Windows headers
#include <AFXWIN.H; // MFC core and standard components
#include <AFXEXT.H; // MFC extensions
#include <AFXDISP.H; // MFC OLE automation classes
#include <AFXDTCTL.H>; // MFC support for Internet Explorer 4 Common
#ifndef _AFX_NO_AFXCMN_SUPPORT
#include <AFXCMN.H> // MFC support for Windows Common Controls
#endif // _AFX_NO_AFXCMN_SUPPORT
//#import the ThumbnailXpress DLL here
#import "Accusoft.ThumbnailXpress4.ActiveX.dll"//{{AFX_INSERT_LOCATION}}
// Microsoft Developer Studio will insert additional declarations immediately before the previous line.
#endif // !defined

The #import directive simply points to the ThumbnailXpress control. When the ThumbnailXpress control is imported with the #import directive, the compiler produces 2 files – a .tli and a .tlh file – that together create the necessary COM wrapper for the control’s properties and methods. Since the directive is in your stdafx.h file, the wrappers are immediately available to your other modules. The wrapper code defines COM smart pointers to your .IDL-defined interfaces. To use this COM object, you simply create an instance of the interface you want and then call methods directly by using this instance pointer.

2. Declare a Pointer to the COM Object

After the #import directive is added, a pointer to the ThumbnailXpress COM object must be defined.

C++ Example Copy Code
using namespace AccusoftThumbnailXpress4;
#include "..\Include\ThumbnailXpress4Events.h"
class CEventDlg : public CDialog //, CThumbnailXpressEventHandler
{
public:
CThumbnailXpress *ppCThumbnailXpress1;

The ThumbnailXpress4Events.h file contains the CThumbanail class. The CThumbnail class is used to create a ThumbnailXpress COM object and handles ThumbnailXpress events.

3. Initialize COM

The COM library must be initialized before COM functions can be called and it must be closed before the program exits.

C++ Example Copy Code
// This is illustrated in the Event.cpp file as follows
BOOL CEventApp::InitInstance()
{
HRESULT hRes = CoInitialize(NULL);
AfxEnableControlContainer();
// Standard initialization
// If you are not using these features and wish to reduce the size
// of your final executable, you should remove from the following
// the specific initialization routines you do not need.
CEventDlg dlg;
m_pMainWnd = &dlg;
INT_PTR nResponse = dlg.DoModal();
if (nResponse == IDOK)
{
// TODO: Place code here to handle when the dialog is
// dismissed with OK
}
else if (nResponse == IDCANCEL)
{
// TODO: Place code here to handle when the dialog is
// dismissed with Cancel
}
// Closes the COM library on the current apartment,
// unloads all DLLs loaded by apartment,
// frees any other resources that the apartment maintains, and
// forces all RPC connections on the apartment to close.
CoUninitialize();
// Since the dialog has been closed, return FALSE so that we exit the
// application, rather than start the application's message pump.
return FALSE;
}

4. Create the ThumbnailXpress COM Object

To use ThumbnailXpress, an instance of the ThumbnailXpress COM object must be created. After the object is created, the object’s properties and methods can be used to create your scanning application. In the Event project, the COM object is created in the EventDlg.cpp file as follows:

C++ Example Copy Code
// Include the ThumbnailXpress COM initialization routines
BOOL CEventDlg::OnInitDialog()
{
CDialog::OnInitDialog();

// Add "About..." menu item to system menu.
// IDM_ABOUTBOX must be in the system command range.
ASSERT((IDM_ABOUTBOX & 0xFFF0) == IDM_ABOUTBOX);
ASSERT(IDM_ABOUTBOX < 0xF000);

CMenu* pSysMenu = GetSystemMenu(FALSE);
if (pSysMenu != NULL)
{
CString strAboutMenu;
strAboutMenu.LoadString(IDS_ABOUTBOX);
if (!strAboutMenu.IsEmpty())
{
pSysMenu->AppendMenu(MF_SEPARATOR);
pSysMenu->AppendMenu(MF_STRING, IDM_ABOUTBOX, strAboutMenu);
}
}

// Set the icon for this dialog. The framework does this automatically
// when the application's main window is not a dialog
SetIcon(m_hIcon, TRUE); // Set big icon
SetIcon(m_hIcon, FALSE); // Set small icon
ppCThumbnailXpress1 = NULL;
ppCThumbnailXpress4 = NULL; // Initialize the ThumbnailXpress COM interface. MUST be done before creating the first object.
// Create ThumbnailXpress Object 1
ppCThumbnailXpress1 = new CThumbnailXpress(this, 1, m_hWnd, 10, 120, 530, 200);
// NOTE: The run-time licensing shown below are for illustration purposes only.
// For distribution, uncomment and call the SetSolutionName and SetSolutionKey and possibly the SetOEMLicenseKey methods passing the ThumbnailXpress license solution name, solution keys and OEM license key respectively.
//ppCThumbnailXpress1->pThumbnailXpress->SetSolutionName(“ACMEImaging”);
//ppCThumbnailXpress1->pThumbnailXpress->SetSolutionKey(0x1C3A023F, 0xA018F260, 0x37AF0E51, 0x557F2389);
//The next line is only needed to be called for Manually Reported Runtime (Non-Node-Locked) licensing
//ppCThumbnailXpress1->pThumbnailXpress->SetOEMLicenseKey( “1.0.GQCC0EmUgONaI4QDZ32tpGWfpGW4gtbC0iIC0iN4bigYM3m3K5b487QOsAM38O24mUp5bOpD2O240OQ32U2YsUKDKA87MYPGgGgaptMiK5Nv8AI4mYg4m3QvW52DZCPGs4p784mtP4IUgOWiIG0AQYp4052iIAWvNCZfpGWC8vQ5P4ZGKaPAWfbiYfZOI303pOZAgisiNaWA27gGsf8Ob7Zvm5IaKGI4KC8GsG2CWYpGQAg5sUmYWvZCQANig48G2ap4bG0DsO240YsUmtptNiZamCPGbYMfMO83gANAZCN52YbY8U8f8DM4m3g7MYMYWGW5Q7QGWaMiN7MtZfmtgY8AN7NDP7Z4W7sCbGKUPa0im7EDPP");
// For distribution, uncomment and call the SetIXSolutionName, SetIXSolutionKey and possibly the SetIXOEMLicenseKey methods passing the ImagXpress license solution name, solution keys and OEM license key respectively.
//ppCThumbnailXpress1->pThumbnailXpress->SetIXSolutionName(“ACMEImaging”);
//ppCThumbnailXpress1->pThumbnailXpress->SetIXSolutionKey(0xB0000001, 0xB0000002, 0xB0000003, 0xB0000004);
//The next line is only needed to be called for Manually Reported Runtime (Non-Node-Locked) licensing
//ppCThumbnailXpress1->pThumbnailXpress->SetIXOEMLicenseKey( “1.0.WXPB1EmUgONaI4QDZ32tpGWfpGW4gtbC0iIC0iN4bigYM3m3K5b487QOsAM38O24mUp5bOpD2O240OQ32U2YsUKDKA87MYPGgGgaptMiK5Nv8AI4mYg4m3QvW52DZCPGs4p784mtP4IUgOWiIG0AQYp4052iIAWvNCZfpGWC8vQ5P4ZGKaPAWfbiYfZOI303pOZAgisiNaWA27gGsf8Ob7Zvm5IaKGI4KC8GsG2CWYpGQAg5sUmYWvZCQANig48G2ap4bG0DsO240YsUmtptNiZamCPGbYMfMO83gANAZCN52YbY8U8f8DM4m3g7MYMYWGW5Q7QGWaMiN7MtZfmtgY8AN7NDP7Z4W7sCbGKUPa0im7EDJS");
ppCThumbnailXpress1->pThumbnailXpress->ScrollDirection = TN_Horizontal;
// initialize event related parameters
ppCThumbnailXpress1->SetPaintEvent(Paint);
ppCThumbnailXpress1->SetSelectionIndexChangedEvent(SelectionIndexChanged);
ppCThumbnailXpress1->pThumbnailXpress->EnableEvent(TN_SelectedIndexChange, TRUE);
ppCThumbnailXpress1->SetErrorEvent(Error);
ppCThumbnailXpress1->pThumbnailXpress->EnableEvent(TN_Error , TRUE);
ppCThumbnailXpress1->SetItemCompleteEvent(ItemComplete);
ppCThumbnailXpress1->pThumbnailXpress->EnableEvent(TN_ItemComplete , TRUE);
ppCThumbnailXpress1->SetClickEvent(Click);
ppCThumbnailXpress1->SetDblClickEvent(DblClick);
return TRUE;
// return TRUE unless you set the focus to a control
}

5. Use the ThumbnailXpress COM Object to Set Properties and Call Methods

After an instance of the ThumbnailXpress COM object is created, the object can be used to set ThumbnailXpress properties and call its methods.

C++ Example Copy Code
// In the Event project, this is illustrated in the OnButton1() function shown below. This function is called when the user clicks the button.
void CEventDlg::OnButton1()
{
CEventDlg *p = (CEventDlg *) this;
CListBox *pL = (CListBox *)p->GetDlgItem(IDC_LIST1);
if(ppCThumbnailXpress1)
{
ppCThumbnailXpress1->pThumbnailXpress->AddDirectoryItems("..\\..\\..\\..\\..\\..\\Common\\Images\\*.tif", -1);
if(ppCThumbnailXpress1->pThumbnailXpress->ErrorCode)
pL->SetCurSel(pL->AddString( "***ERROR*** unable to load images from ..\\..\\..\\..\\..\\..\\Common\\Images - ThumbnailXpress #1"));
}
}

6. Delete the ThumbnailXpress COM Object

The ThumbnailXpress COM object must be deleted when it is no longer needed. The object is usually deleted before the application exits.

C++Example Copy Code
// In the Event project, the COM object is deleted as follows
void CEventDlg::OnDestroy(){
CDialog::OnDestroy();
// Delete our ThumbnailXpress Objects
if(ppCThumbnailXpress1)
{
delete ppCThumbnailXpress1;
}
}


Use ThumbnailXpress as an ActiveX Control

Accusoft.ThumbnailXpress4.ActiveX
Use ThumbnailXpress as an ActiveX Control
Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > Getting Started > Use ThumbnailXpress as an ActiveX Control

Glossary Item Box

The following discussion assumes that your development environment is Visual Basic.

Creating an Application with Visual Basic and ThumbnailXpress

  1. Add the ThumbnailXpress control to a project.
  2. Use the ThumbnailXpress control on a form.
  3. Write code that controls the ThumbnailXpress properties and methods.

Loading the ThumbnailXpress Control Involves Adding it to a Project

  1. Open the project that will use the ThumbnailXpress control. This can be a new or existing project.
  2. From the Project menu, choose Components. The Control window appears with a list of available controls.
  3. Select the ThumbnailXpress control (i.e. Accusoft ThumbnailXpress v4.0). Click the OK button.

Other Environments

The ThumbnailXpress control is supported by a variety of host environments. To use ThumbnailXpress in other environments, consult the development tool's documentation for information on how to use ActiveX controls. As soon as the control is loaded, the following things happen:

  1. The control becomes part of the current project.
  2. A new tool is added to the Toolbox. This tool is used to draw the ThumbnailXpress control on the form.

The new control can now be used as if it were a standard control. The ThumbnailXpress control has its own set of properties and methods which can be seen by using the Properties and Code windows.


Upgrading from ThumbnailXpress 3 to ThumbnailXpress 4

Accusoft.ThumbnailXpress4.ActiveX
Upgrading from ThumbnailXpress 3 to ThumbnailXpress 4
Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > Getting Started > Upgrading from ThumbnailXpress 3 to ThumbnailXpress 4

Glossary Item Box

This section describes how to upgrade from ThumbnailXpress 3 to ThumbnailXpress 4. While generally you'll be able to replace ThumbnailXpress 3 with ThumbnailXpress 4, there are a few important changes you may need to consider. This section provides information about those changes.

Library Name, GUID, and ProgID

  • The library name has changed from AccusoftThumbnailXpress3 to AccusoftThumbnailXpress4.
  • The GUID for the ThumbnailXpress ActiveX control has changed in ThumbnailXpress 3 from {C2C152E0-9477-4c1b-921B-E6D7410C366C} to the new value in ThumbnailXpress 4 of {4923F876-5D0D-43b0-BD64-671DA5545BAF}.
  • The ProgID has changed from ‘Accusoft.ThumbnailXpress.3’ to ‘Accusoft.ThumbnailXpress.4’ in ThumbnailXpress 4.

Changes and New Properties/Methods

  • Loading time for CAD images has been improved for displaying from directory, and displaying from file when multi-layout expansion is disabled. This improvement in performance can be up to hundreds of milliseconds, depending on the image.
  • Added GetItemCellBorderColor()/SetItemCellBorderColor() methods to get and set the Cell Border Color for individual Thumbnail Items.
  • Added GetItemCellBackColor()/SetItemCellBackColor() methods to get and set the Cell Back Color for individual Thumbnail Items.
  • Added CustomErrorIcon property to allow a custom icon to be used for errors vs. the stock icon provided by ThumbnailXpress.
  • Added CustomGeneratingIcon property to allow a custom icon to be used for pre-image generation vs. the stock icon provided by ThumbnailXpress.
  • Added a new property NotateXpressInstance. This property is designed to be set to the value of the HandleInstance property of NotateXpress. It's used to enable annotation functionality for thumbnails. Note that NotateXpress is a separate control from ThumbnailXpress.
  • Added a new method SetItemAnnotations(). This method is designed to load annotation data from the GetAnnIntoVariantForThumbnail() method of NotateXpress. Note that NotateXpress is a separate control from ThumbnailXpress.
  • Added new methods SetAnnotationSearchOrderSize(), SetAnnotationSearchOrder(), GetAnnotationSearchOrderSize, and GetAnnotationSearchOrder(). These methods allow the user to specify a search order to use when associating external annotation files with the item being thumbnailed.
  • Added the methods GetItemAnnotationsFilename(), GetItemAnnotationType(), and GetItemHasAnnotations(). These serve to inform the user about the actual annotations used.
  • Added a new property CameraRawThumbnailEnabled that indicates whether to use the embedded thumbnail of the camera raw image, which typically loads faster than the full-size image.
  • The UsePdfXpress3 property has been marked deprecated and will be removed in version 5 of ThumbnailXpress. Users should use the UsePdfXpress4 property. The UsePdfXpress() and UsePdfXpress2() properties have been removed, since they were marked deprecated inversion 3 of ThumbnailXpress.
  • The CacheFile, CacheFilePath, and CacheDiskLimit properties, and the FlushCache() method have been removed, since they were marked deprecated in version 3 of ThumbnailXpress. The CacheMemoryLimit property and the EmptyCache() method have been marked as deprecated and will be removed in version 5 of ThumbnailXpress.
  • Added Accusoft's new licensing structure to the ImagXpress 11 Product Family. See Licensing for information about the new licensing, and Upgrading Runtime Licensing for information about updating your licensing from an earlier version of ThumbnailXpress.

If you encounter any porting issues, please contact support@accusoft.com for assistance.


Upgrading Runtime Licensing

Accusoft.ThumbnailXpress4.ActiveX
Upgrading Runtime Licensing
Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > Getting Started > Upgrading Runtime Licensing

Glossary Item Box

This section describes how to upgrade to Accusoft's new Runtime Licensing.

Prior to ThumbnailXpress 4, runtime licensing was accomplished using the UnlockRuntime method.

In ThumbnailXpress 4, the default licensing model is Automatically Reported Runtime Licensing. However, based on your contracted usage of this software, you may be eligible for Manually Reported Runtime Licensing. Your Accusoft Sales Representative (sales@accusoft.com) can help you determine which model is appropriate.

Refer to the following sections for information about upgrading to the new Runtime Licensing models:

  • Upgrading to Automatically Reported Runtime Licensing
  • Upgrading to Manually Reported Runtime Licensing

Upgrading to Automatically Reported Runtime Licensing

Automatically Reported Runtime Licensing requires a license to be installed on the end-user's machine. See the Licensing section for more information.

In your ThumbnailXpress 3 codebase, find any existing calls to the UnlockRuntime or UnlockWeb method.

C++ Copy Code
 ThumbnailXpress1->UnlockRuntime(12345,12345,12345,12345);
VB6 Copy Code
 ThumbnailXpress1.UnlockRuntime 12345,12345,12345,12345
JavaScript Copy Code
ThumbnailXpress1.UnlockWeb("ServerLicenseString…");

In your ThumbnailXpress 4 codebase, replace the UnlockRuntime or UnlockWeb method with calls to the SetSolutionName and SetSolutionKey methods.

C++ Copy Code
 ThumbnailXpress1->SetSolutionName("YourSolutionName");
 ThumbnailXpress1->SetSolutionKey(12345,12345,12345,12345);
VB6 Copy Code
 ThumbnailXpress1.SetSolutionName "YourSolutionName"
 ThumbnailXpress1.SetSolutionKey 12345,12345,12345,12345
JavaScript Copy Code
ThumbnailXpress1.SetSolutionName("YourSolutionName");
ThumbnailXpress1.SetSolutionKey(12345,12345,12345,12345);

Upgrading to Manually Reported Runtime Licensing

In your ThumbnailXpress 3 codebase, find any existing calls to the UnlockRuntime or UnlockWeb method.

C++ Copy Code
 ThumbnailXpress1->UnlockRuntime(12345,12345,12345,12345);
VB6 Copy Code
 ThumbnailXpress1.UnlockRuntime 12345,12345,12345,12345
JavaScript Copy Code
ThumbnailXpress1.UnlockWeb("ServerLicenseString…");

In your ThumbnailXpress 4 codebase, replace the UnlockRuntime or UnlockWeb method with calls to the SetSolutionName, SetSolutionKey, and SetOEMLicenseKey methods.

C++ Copy Code
 ThumbnailXpress1->SetSolutionName("YourSolutionName");
 ThumbnailXpress1->SetSolutionKey(12345,12345,12345,12345);
 ThumbnailXpress1->SetOEMLicenseKey("1.0.AStringForOEMLicensing…");
VB6 Copy Code
 ThumbnailXpress1.SetSolutionName "YourSolutionName"
 ThumbnailXpress1.SetSolutionKey 12345,12345,12345,12345
 ThumbnailXpress1.SetOEMLicenseKey "1.0.AStringForOEMLicensing…"
JavaScript Copy Code
ThumbnailXpress1.SetSolutionName("YourSolutionName");
ThumbnailXpress1.SetSolutionKey(12345,12345,12345,12345);
ThumbnailXpress1.SetOEMLicenseKey("1.0.AStringForOEMLicensing…");

There is no longer a separate method for web licensing. That functionality has been integrated into the SetOEMLicenseKey method.

If you encounter any porting issues, please contact support@accusoft.com for assistance.


Licensing

Accusoft.ThumbnailXpress4.ActiveX
Licensing
See Also Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > Licensing

Glossary Item Box

Accusoft has introduced a new licensing structure, which provides the following benefits:

  • Toolkit Licensing (also known as Developer or SDK licensing) has been simplified, no longer requiring manual entry of license registration codes.
  • Runtime Licensing (also known as Deployment licensing) has been made more flexible, enabling support for a number of different deployment scenarios.

During evaluation of Accusoft products, Evaluation Toolkit licenses can be used to try out products. However, the product behavior is limited by trial dialog pop-ups, timeouts, or evaluation watermarks.

Accusoft requires customers to purchase licenses for both development and deployment.

  • Development/Toolkit Licensing: When you determine the product is a good fit, you can purchase a Toolkit license to eliminate trial dialog pop-ups, timeouts, and evaluation watermarks while you develop your application.
  • Deployment/Runtime Licensing: Once you have an application that is ready for distribution, you have several options for deployment. Your own deployment scenario will dictate which option is the most appropriate. There are also cost considerations for each licensing model; see the product's "pricing" page or speak with an Accusoft Sales Representative (sales@accusoft.com) for more information.
    • Manually Reported Runtime Licensing: In this model, you embed all of the licensing information directly into your application. You must manually provide royalty reporting to Accusoft for the actual licenses deployed. This model will be the best choice for you if you are not connected to the Internet at runtime, as might be the case in an defense or financial application.
    • Automatically Reported Runtime Licensing using the Server Licensing Utility (SLU): In this model, you run a small GUI tool one time on each deployment target to configure licensing. This model will be the best choice for you if you handle the deployments yourself.
    • Automatically Reported Runtime Licensing using the Licensing Development Kit (LDK): In this model, you embed function calls into your application that perform the license verification at runtime. This model will be the best choice for you if you wish to hide licensing from your end users.

See Also

Licensing Glossary


Evaluation Licensing

Accusoft.ThumbnailXpress4.ActiveX
Evaluation Licensing
Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > Licensing > Evaluation Licensing

Glossary Item Box

During evaluation of Accusoft products, Evaluation Toolkit licenses can be used to try out products. However, the product behavior is limited by trial dialog pop-ups, timeouts, or evaluation watermarks. When you determine the product is a good fit, you can purchase a Toolkit license to eliminate trial dialog pop-ups, timeouts, and evaluation watermarks.

An evaluation dialog similar to the following evaluation dialog is displayed when you have a valid evaluation license.

However, if you attempt to execute a function that is not licensed in the edition license you are using (e.g., if you have a paid license for ImagXpress Standard and attempt to execute a function available only in ImagXpress Professional), an evaluation dialog similar to the following is displayed.

If no license is found in the registry, a dialog similar to the following will be displayed.


Toolkit Licensing

Accusoft.ThumbnailXpress4.ActiveX
Toolkit Licensing
Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > Licensing > Toolkit Licensing

Glossary Item Box

Accusoft requires customers who are developing code that uses Accusoft components to have a Toolkit license for each developer.

This section provides information about the following:

  • Assigned Toolkit License
  • License Manager
  • Product Editions
  • Registration
    • Registering When Connected to the Internet
    • Registering When Disconnected from the Internet
  • Developing Code


Assigned Toolkit License

Accusoft.ThumbnailXpress4.ActiveX
Assigned Toolkit License
Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > Licensing > Toolkit Licensing > Assigned Toolkit License

Glossary Item Box

When licenses are purchased for developers at an organization, a representative is designated to assign the licenses to developers at the organization. Each developer must create an account on Accusoft’s website prior to the assignment of licenses. The organization’s designated representative may request that licenses be reassigned as a result of personnel changes.


License Manager

Accusoft.ThumbnailXpress4.ActiveX
License Manager
Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > Licensing > Toolkit Licensing > License Manager

Glossary Item Box

The License Manager is a GUI application that is used by a developer to register and activate Toolkit licenses on their development system. When a paid Toolkit license is registered, the License Manager:

  • Communicates the developer credentials and the hardware information for the development system to the licensing web service.
  • Installs the returned license key on that system.

Activation involves choosing a Toolkit license, either evaluation or paid, so that the license is active on the system.


Product Editions

Accusoft.ThumbnailXpress4.ActiveX
Product Editions
Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > Licensing > Toolkit Licensing > Product Editions

Glossary Item Box

Accusoft products may have multiple editions, each of which supports different features. Products that support multiple editions are installed with multiple evaluation Toolkit licenses, one evaluation Toolkit license per edition.

Selecting An Edition (Activating a Toolkit License)

Evaluation licenses allow developers to try features in different product editions. Since each license supports only a single edition of a product, the developer can switch between editions by activating the corresponding Toolkit license, either purchased or evaluation, using the License Manager.

When a customer downloads an evaluation Toolkit, the evaluation Toolkit license for the edition with the most features is installed by default. However, the developer may run the License Manager to change the Toolkit license to a lower edition in order to determine if that edition will serve their needs.

If a customer has purchased multiple editions of the same product, they may install both editions on a development system, but only one edition may be active at a time. Once a license has been activated for a particular system, it may be deactivated (replaced by activating another edition) or reactivated at any time. Similarly, customers who own a lower featured edition may activate a higher featured edition evaluation Toolkit license and then switch back to their paid, lower-featured Toolkit edition license at any time. For example, you can go from a paid Standard edition to an evaluation Professional edition by activating the Professional edition evaluation Toolkit license.


Registration

Accusoft.ThumbnailXpress4.ActiveX
Registration
Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > Licensing > Toolkit Licensing > Registration

Glossary Item Box

Registration is the process of creating a paid Toolkit license key for a particular system. Registration for Toolkit licenses is always done through the License Manager. This enables the features for the purchased edition to operate without nag dialogs or watermarks. Registration for each license is only required to be performed once per development system. After a license has been registered on a system, you can use the license without further interaction with the License Manager.

Also refer to the following sections:

  • Registering When Connected to the Internet
  • Registering When Disconnected from the Internet


Registering When Connected to the Internet

Accusoft.ThumbnailXpress4.ActiveX
Registering When Connected to the Internet
Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > Licensing > Toolkit Licensing > Registration > Registering When Connected to the Internet

Glossary Item Box

When the development system is connected to the Internet, registration is a fairly simple process.

  1. Start the License Manager.
  2. When prompted, enter your Accusoft login and password.

    The License Manager then displays the available evaluation and purchased licenses assigned to you.

  3. Select a toolkit and click the link to activate the license for that toolkit.

    The License Manager then requests a new license key from the licensing web service and installs it; this completes the registration process.

    If the selected license cannot be installed on the development system due to connection failures or other reasons, a temporary, 15 day "grace" license is installed so as not to interrupt development while a new license is obtained for the development system.


Registering When Disconnected from the Internet

Accusoft.ThumbnailXpress4.ActiveX
Registering When Disconnected from the Internet
Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > Licensing > Toolkit Licensing > Registration > Registering When Disconnected from the Internet

Glossary Item Box

When the development system is not connected to the Internet during registration, as is the case in some defense or financial institutions, registration is only slightly less simple.

  1. Run the License Manager and attempt to log in.
    The License Manager detects that the system is not registered and displays the following dialog:

  2. Select the Install Offline option to begin the offline registration process.

  3. Copy the URL to removable media, such as a thumb drive.

  4. Take the thumb drive to a system that is connected to the Internet.
  5. From the connected system, paste the URL into a browser, which automatically displays the toolkits available.
  6. Upon selecting a toolkit, a license is generated, which you then save to the removable media device.
  7. Return to the offline system where the new license is to be installed.
  8. Use the License Manager to browse to the file and install the Toolkit license.


Developing Code

Accusoft.ThumbnailXpress4.ActiveX
Developing Code
Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > Licensing > Toolkit Licensing > Developing Code

Glossary Item Box

Once an evaluation or paid Toolkit license has been activated on the development system, no additional code is required to use the Accusoft products on this system. If moving the resulting executable code to a new system, you will need to install Toolkit licenses or incorporate Runtime licenses into your code.


Runtime Licensing

Accusoft.ThumbnailXpress4.ActiveX
Runtime Licensing
Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > Licensing > Runtime Licensing

Glossary Item Box

When an application that uses one or more Accusoft products is deployed, it requires a Runtime License for each installation. There are two main types of Runtime Licenses:

  • Automatically Reported. Distribution of Automatically Reported Runtime licenses is handled automatically through the use of licensing software components and web services.
  • Manually Reported. Manually Reported Runtime licensing requires you to provide the number of licenses distributed on a contractually agreed upon basis.
  • ActiveX Website Runtime Licensing. Using an Accusoft ActiveX on a webpage is similar to Manually Reported Runtime (Non-Node-Locked), as it requires calls to SetSolutionName, SetSolutionKey, and SetOEMLicenseKey. However, the web licenses are not node-locked to particular hardware but are node-locked to a set of specific domains or sub-domains.

These licensing types are each described in detail in the following sections:

  • Automatically Reported Runtime (Node-Locked)
    • Licensing API
    • License Pools
    • License Configuration Files
    • LDK vs. SLU
      • Server Licensing Utility (SLU)
      • Licensing Development Kit (LDK)
    • Deployment Proxy Service (DPS)
  • Manually Reported Runtime (Non-Node-Locked)
    • Solution Name
    • Solution Key
    • OEM License Key
  • ActiveX Website Runtime Licensing
If you are upgrading from an earlier version of ThumbnailXpress, please see the Upgrading Runtime Licensing section for important information.


Automatically Reported Runtime (Node-Locked)

Accusoft.ThumbnailXpress4.ActiveX
Automatically Reported Runtime (Node-Locked)
Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked)

Glossary Item Box

Automatically Reported Runtime licenses use a mechanism similar to Toolkit licensing to activate a license for a particular system. In this case, each installation has a unique license that is pulled from the pool of licenses purchased by the customer. When the license key is generated, it contains hardware information that identifies the system on which the license is to be installed.

The Licensing Development Kit component, which interacts with the licensing web service and installs the newly generated license key, may be used directly by the application or it may be used through a simple tool known as the Server Licensing Utility.

  • The Licensing Development Kit requires integration with the application or installation utility to perform license activation.
  • The Server Licensing Utility is a stand-alone application that integrates the Licensing Development Kit to perform the registration.

This topic provides information about the following:

  • Licensing API
  • License Pools
  • License Configuration Files
  • LDK vs. SLU
    • Server Licensing Utility (SLU)
    • Licensing Development Kit (LDK)
  • Deployment Proxy Service (DPS)


Licensing API

Accusoft.ThumbnailXpress4.ActiveX
Licensing API
Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > Licensing API

Glossary Item Box

The Licensing API is used in the developer’s code to specify Runtime Licensing deployment information. This is used to unlock the Accusoft products and enable all licensed features at runtime. Both the "Solution Name" and "Solution Key" values used in the API described below are provided by Accusoft, along with the License Configuration file, at the time of purchase of a Runtime License.

Solution Name

The solution name is the name assigned by Accusoft to the licenses purchased for runtime deployment. It is a character string that is set for a component prior to use in a deployment environment and is typically the name of the organization that purchased the runtime licenses. It is set via the SetSolutionName method. For example:

Copy Code
ThumbnailXpress1.SetSolutionName("ACMEImaging");

The Solution Name must be set in order to use runtime licensing.

Solution Key

The Solution Key is a set of four numbers assigned when the licenses are purchased for runtime deployment; the Solution Key also identifies the organization that purchased the runtime licenses. The Solution Key is set via the SetSolutionKey method. For example:

Copy Code
ThumbnailXpress1.SetSolutionName("ACMEImaging");
ThumbnailXpress1.SetSolutionKey(0x1C3A023F, 0xA018F260, 0x37AF0E51, 0x557F2389);

The Solution Key must be set in order to use runtime licensing.


License Pools

Accusoft.ThumbnailXpress4.ActiveX
License Pools
Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > License Pools

Glossary Item Box

When Automatically Reported Runtime licenses are purchased, they are organized into pools of a specific version and platform for a particular toolkit. For example, if a customer developed two applications using ImagXpress, one using 32-bit ActiveX and the other using .NET, they would purchase two pools of runtime licenses, one for the ActiveX platform and one for the .NET platform. At installation, a new license would be pulled from the appropriate pool, depending upon which platform the application is using.


License Configuration Files

Accusoft.ThumbnailXpress4.ActiveX
License Configuration Files
See Also Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > License Configuration Files

Glossary Item Box

When an Automatically Reported Runtime license is purchased, a License Configuration file is created and distributed to the customer along with their assigned Solution Name and Solution Key. The License Configuration file contains information about the Runtime licenses for a particular platform and version of a toolkit. It is used by the Server Licensing Utility or License Development Kit to activate licenses when the customer’s application is installed on their users' systems.

See Also

Licensing API


LDK vs. SLU

Accusoft.ThumbnailXpress4.ActiveX
LDK vs. SLU
Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > LDK vs. SLU

Glossary Item Box

Both the Licensing Deployment Kit and the Server Licensing Utility perform the same function of registering the Runtime license for the system on which it will be run. Both are provided in order to give you some options.

  • If you are deploying to your own systems (e.g., for enterprise IT staff), the use of an Accusoft branded Server Licensing Utility may meet your needs. Similarly, if you handle the deployment onto end users systems, you may also find the Server Licensing Utility to be sufficient.
  • If you wish to hide this licensing registration from end users, you will likely choose the Licensing Deployment Kit, which allows you to integrate the registration process into your application. The Licensing Deployment Kit also allows for the optional assignment of Access Keys to specific users, which lets you manage your licenses more directly and limits the distribution of licenses.


Server Licensing Utility (SLU)

Accusoft.ThumbnailXpress4.ActiveX
Server Licensing Utility (SLU)
Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > LDK vs. SLU > Server Licensing Utility (SLU)

Glossary Item Box

The Server Licensing Utility is a simple Windows application that uses License Configuration Files to request a license key from the purchased Runtime licenses. The Server Licensing Utility registers that Runtime license on the system where your application will be running. This utility can be used by developers for testing, by your deployment team, or by your end users to register their Runtime license.

In the Server Licensing Utility dialog, add your License Configuration file(s) as follows:

  1. Click Add and navigate to your License Configuration file(s).
  2. Select the appropriate License Configuration file(s) and click Open.
  3. After all applicable License Configuration files have been added, click Auto Register or Manually Register, depending on whether or not you are connected to the Internet. Refer to the sections below for more information.

Auto Register Toolkit (Connected to Internet)

Automatic registration works in much the same way as connected Toolkit registration and requires an Internet connection on the system where your application software will be deployed. The license information along with the system’s hardware information is sent over the Internet to the Accusoft licensing web service. If an unused license is available, a new license key containing information for the system is generated, returned, and is then automatically installed by the Server Licensing Utility.

Manually Register Toolkit (Disconnected from Internet)

Manual registration is used when the system where your application software will be deployed is not connected to the Internet and therefore cannot be registered automatically. This operation is similar to Disconnected Registration with the License Manager.

  1. Copy the Hardware Key and URL to a removable media device, such as a thumb drive, and then take it to a system that is connected to the Internet.
  2. From the connected system, paste the URL into a browser. A page will appear that contains a field into which you enter the hardware key.
  3. After this hardware key is entered, a license file with the license key is downloaded, which you then save to the removable media device.
  4. Return to the offline system with the removable media device onto which you have saved the license file.
  5. Click Open License File and navigate to the license file. Click OK in the file selection dialog.
    Alternatively, you can open the license file with a text editor, copy the license key to the clipboard, and click Paste License Key to paste the new license key into the License Key field.
  6. Click the License button; the new license will be installed.


Licensing Development Kit (LDK)

Accusoft.ThumbnailXpress4.ActiveX
Licensing Development Kit (LDK)
Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > LDK vs. SLU > Licensing Development Kit (LDK)

Glossary Item Box

The Licensing Development Kit is an ActiveX component that may be used instead of the Server Licensing Utility. (Actually, the Server Licensing Utility is only a user interface for the Licensing Development Kit.) The Licensing Development Kit provides an interface for a developer to set the License Configuration File path and other properties as well as initiate requests to the licensing web service to generate license keys.

This topic contains these sections:

  • AccuLicClient.DLL
  • Assigned Access Keys
  • Automatic (Connected) Mode Registration
  • Manual (Disconnected) Mode Registration
  • Evaluation
  • Licensing Development Kit Interface
  • Licensing Development Kit Properties
  • Licensing Development Kit Methods

AccuLicClient.DLL

The AccuLicClient.DLL is located with the Server Licensing Utility. It is a 32-bit ActiveX/COM DLL which is used to execute runtime licensing activation functions. The bulk of the functionality provided by the Server Licensing Utility (SLU) is contained within the AccuLicClient.DLL and can be used within your own custom applications to achieve the same thing.

Assigned Access Keys

Unlike the Server Licensing Utility, the Licensing Development Kit allows for the optional assignment of Access Keys to specific users. By doing this, you can specify which of your licenses are assigned to your users. This also limits the distribution of licenses. When Runtime licenses are purchased, a list of Access Keys is distributed to you for this use.

Automatic (Connected) Mode Registration

This mode corresponds to the Automatic (Connected) Registration section described in the Server Licensing Utility section. The process is shown in the C# sample code below:

Copy Code
// Instantiate the LDK ActiveX component
IDeploymentComponent ldk = new DeploymentComponent();

// Set the path to the configuration file provided
// when the runtime licenses were purchased.
ldk.ConfigPath = @"C:\config.txt";

// Attempt to get the next available license.
// Note that you may alternately pass an Access Key
ldk.GetLicKeyAuto("");

if (ldk.ResultCode != enumLdkErrorCodes.LDK_SUCCESS)
{
    // Automatic Registration Failed - A temporary license
    // has been installed but will expire in 15 days.
    // TODO add code to notify user of issue and 15 day expiration.

    if (ldk.ResultCode == enumLdkErrorCodes.LDK_ERR_INET_CONN_BROKEN)
    {
        // No Internet Connection – Optionally do manual registration
    }
}
else
{
    // The license has been registered and installed.
}

The registration process is then complete. If any part of the registration process fails, a temporary license key is installed and is typically valid for 15 days. During this time, you are allowed to use the product while resolving any licensing related problems.

Manual (Disconnected) Mode Registration

This mode corresponds to the Manual (Disconnected) Registration section described in the Server Licensing Utility section. The process is shown in the C# code below:

Copy Code
// Instantiate the LDK ActiveX component
IDeploymentComponent ldk = new DeploymentComponent();

// Set the path to the configuration file provided
// when the runtime licenses were purchased.
ldk.ConfigPath = @"C:\config.txt";

// Get the hardware key for the system.  Note
// that you may alternately pass an Access Key
string hardwareKey = ldk.GetHdwKey("");

// Write the hardware key to some type of removable media.
ApplicationSpecificMethodToWriteHardwareKey(hardwareKey);

At this point, you have the hardware key on some type of removable media. Take the media to a system that is connected to the Internet, acquire the license key by uploading the hardware key, write the new license key to the removable media, and then return to the disconnected system. The application then reads the license key from the removable media and installs the license key as shown below.

Copy Code
// After taking the hardware key to a system with an Internet
// connection and acquiring the license key string from the
// manual registration web site, read the key into your
// application.
string manuallyAcquiredLicenseKey = ApplicationSpecificMethodToReadLicenseKey();

// Install the license key
ldk.LicKey = manuallyAcquiredLicenseKey;

The manual license registration and installation is then complete. Like the automatic case above, if any error occurs during the setting of the license key, a temporary license is installed.

Evaluation

The Licensing Development Kit also has the ability to install an Evaluation License for purchased runtime products. This process is simply:

Copy Code
// Instantiate the LDK ActiveX component
IDeploymentComponent ldk = new DeploymentComponent();

// Set the path to the configuration file provided
// when the runtime licenses were purchased.
ldk.ConfigPath = @"C:\config.txt";

// Install an evaluation license
ldk.StartEvalPeriod();

Licensing Development Kit Interface

The interface to the Licensing Development Kit is shown below:

Copy Code
interface IDeploymentComponent : IDispatch
{
   [propget, id(1)] HRESULT LicKey([out, retval] BSTR* pVal);
   [propput, id(1)] HRESULT LicKey([in] BSTR newVal);
   [propget, id(2)] HRESULT srvURL([out, retval] BSTR* pVal);
   [propput, id(2)] HRESULT srvURL([in] BSTR newVal);
   [propget, id(3)] HRESULT ConfigPath([out, retval] BSTR* pVal);
   [propput, id(3)] HRESULT ConfigPath([in] BSTR newVal);
   [propget, id(4)] HRESULT ResultString([out, retval] BSTR* pVal);
   [propget, id(5)] HRESULT ResultCode([out, retval] enumLdkErrorCodes* pVal);
   [id(6)]           HRESULT GetLicKeyAuto([in] BSTR accKey);
   [id(7)]           HRESULT GetHdwKey([in] BSTR accKey, [out,retval] BSTR* hdwKey);
   [id(8)]           HRESULT StartEvalPeriod(void);
   [propget]         HRESULT LicenseInfo([out, retval] BSTR* pVal);
   [propput]         HRESULT LicenseInfo([in] BSTR newVal);
   [id(10)]          HRESULT GetEvalPeriod([out, retval] long* pVal);
};

Licensing Development Kit Properties

  • LicKey: Stores the License Key to the registry when it is set, and reads it from the registry during the get operation.
  • srvURL: Gets and sets the URL path to the licensing web service. The default is the URL path to Accusoft’s Deployment Licensing Service.
  • ConfigPath: Gets and sets a path to the deployment configuration file. Multiple products can be registered at one time by setting the filenames as a semicolon-delimited list: e.g., “c:\config.txt;c:\config2.txt”.
  • ResultString: Contains the string descriptions of any error that may have occurred during the last operation.
  • ResultCode: Can be used to contain any of the error codes described in Licensing Component Error Codes and Messages.
  • LicenseInfo: Used to transfer license information onto new system hardware. To transfer the license information into new system hardware, do the following:
  1. Get the LicenseInfo value and store it in a safe place.
  2. Change the system hardware.
  3. Set the LicenseInfo to the value you saved in step (1).
  4. Run the GetLicKeyAuto method (or perform its manual analog) to obtain a license for the new system hardware.

Licensing Development Kit Methods

  • GetLicKeyAuto: Obtains a License Key for the end user’s system using the automatic (or connected) scenario. It takes an Access Key as its input parameter, and stores the obtained license key in the registry. If you choose not to distribute individual Access Keys, the accKey argument should be an empty string.
  • GetHdwKey: Obtains a hardware key from the current machine and returns it (as hdwKey). If you choose not to distribute individual access keys, the accKey argument should be an empty string.
  • StartEvalPeriod: Sets an evaluation licensing mode for the product and starts an evaluation period. This method is provided so you can distribute an evaluation version of your application, without having to distribute Access Keys to people who would like to evaluate your software. Using this method you can license Accusoft components on the end user’s system for a limited time – the default is 30 days, but it can be customized per request to Accusoft. If the evaluators purchase your software, you can then issue them an access key using either the automatic or manual scenarios to obtain permanent component licenses, just as Accusoft does for its evaluators.
  • GetEvalPeriod: Obtains the remaining time on an evaluation (in days). It returns EvalPeriod < 0 if the evaluation period is expired.


Deployment Proxy Service (DPS)

Accusoft.ThumbnailXpress4.ActiveX
Deployment Proxy Service (DPS)
Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > Deployment Proxy Service (DPS)

Glossary Item Box

For systems where the deployed application will not have direct access to the Accusoft licensing web services, you can use the Deployment Proxy Service as a bridge to reroute the licensing communication. The Proxy Service will act as a trusted "go-between" for the Accusoft licensing system and the deployed application. This tool can be useful if the application will be deployed in a secured environment, where limited systems have external network access.

Additionally, the Proxy Service allows Accusoft customers to manage license registration more directly. The source for the Deployment Proxy Service is provided, allowing users to integrate the licensing process into their CRM, ERP, or other systems for tracking Automatically Reported Runtime Licenses.

For more information about the Deployment Proxy Service, please contact our Support team.


Manually Reported Runtime (Non-Node-Locked)

Accusoft.ThumbnailXpress4.ActiveX
Manually Reported Runtime (Non-Node-Locked)
Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > Licensing > Runtime Licensing > Manually Reported Runtime (Non-Node-Locked)

Glossary Item Box

Manually Reported Runtime licensing embeds all of the licensing information directly into your application. Installation does not require any further licensing interaction. However, it is your responsibility to provide royalty reporting to Accusoft for the actual licenses deployed.

This section provides information about the following:

  • Solution Name
  • Solution Key
  • OEM License Key


Solution Name

Accusoft.ThumbnailXpress4.ActiveX
Solution Name
Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > Licensing > Runtime Licensing > Manually Reported Runtime (Non-Node-Locked) > Solution Name

Glossary Item Box

The solution name is

  • A name assigned by Accusoft to the licenses purchased for runtime deployment.
  • A character string that is set for a component prior to use in a deployment environment.
  • Typically the name of the organization that purchased the runtime licenses.
  • Set via the SetSolutionName method. For example:
Copy Code
ThumbnailXpress1.SetSolutionName("ACMEImaging");

The Solution Name must be set in order to use runtime licensing.


Solution Key

Accusoft.ThumbnailXpress4.ActiveX
Solution Key
Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > Licensing > Runtime Licensing > Manually Reported Runtime (Non-Node-Locked) > Solution Key

Glossary Item Box

The Solution Key is

  • A set of four numbers assigned when the licenses are purchased for runtime deployment.
  • An identifier of the organization that purchased the runtime licenses.
  • Set via the SetSolutionKey method. For example:
Copy Code
ThumbnailXpress1.SetSolutionName("ACMEImaging");
ThumbnailXpress1.SetSolutionKey(0x1C3A023F, 0xA018F260, 0x37AF0E51, 0x557F2389);

The Solution Key must be set in order to use runtime licensing.


OEM License Key

Accusoft.ThumbnailXpress4.ActiveX
OEM License Key
Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > Licensing > Runtime Licensing > Manually Reported Runtime (Non-Node-Locked) > OEM License Key

Glossary Item Box

The OEMLicense Key is

  • For use only by customers who choose to use Manually Reported Runtime licensing.
  • A unique identifier of the customer, product, version, edition, and platforms for which the license is valid.

When this key is set via the SetOEMLicenseKey method, the component is completely licensed and can be distributed without any further licensing operations.

Copy Code
ThumbnailXpress1.SetSolutionName("ACMEImaging");
ThumbnailXpress1.SetSolutionKey(0x1C3A023F, 0xA018F260, 0x37AF0E51, 0x557F2389);
ThumbnailXpress1.SetOEMLicenseKey("1.0.GQCC0EmUgONaI4QDZ32tpGWfpGW4gtbC0iIC0iN4bigYM3m3K5b487QOsAM38O24mUp5bOpD2O240OQ32U2YsUKDKA87MYPGgGgaptMiK5Nv8AI4mYg4m3QvW52DZCPGs4p784mtP4IUgOWiIG0AQYp4052iIAWvNCZfpGWC8vQ5P4ZGKaPAWfbiYfZOI303pOZAgisiNaWA27gGsf8Ob7Zvm5IaKGI4KC8GsG2CWYpGQAg5sUmYWvZCQANig48G2ap4bG0DsO240YsUmtptNiZamCPGbYMfMO83gANAZCN52YbY8U8f8DM4m3g7MYMYWGW5Q7QGWaMiN7MtZfmtgY8AN7NDP7Z4W7sCbGKUPa0im7EDPP");

This property is not required for Automatically Reported Runtime licensing.


ActiveX Website Runtime Licensing

Accusoft.ThumbnailXpress4.ActiveX
ActiveX Website Runtime Licensing
Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > Licensing > Runtime Licensing > ActiveX Website Runtime Licensing

Glossary Item Box

Using an Accusoft ActiveX on a webpage is similar to Manually Reported Runtime (Non-Node-Locked), as it requires calls to SetSolutionName, SetSolutionKey, and SetOEMLicenseKey. However, the web licenses are not node-locked to particular hardware but are node-locked to a set of specific domains or sub-domains. Sub-paths of those domains and sub-domains do not require additional licensing, thus if http://www.mysite.com is licensed, so is http://www.mysite.com/imaging.

To get an OEM license key, the developer will identify one or more domains or sub-domains to Accusoft's Licensing Center. There is an ActiveX web licensing site that contains the OEM License Generator web application. This web application is used to create an OEM license key that the developer can use along with the solution name and solution key on the webpage in the domain or sub-domain.

Example

In the following example:

  • The solution name is "ACMEImaging"
  • The solution keys are "0x1C3A023F, 0xA018F260, 0x37AF0E51, 0x557F2389"
  • The domain specified is www.mysite.com

The developer would do the following:

  1. Log into Accusoft’s Licensing Center.
  2. Use the OEM License Generator web application to retrieve an OEM license key for www.mysite.com.
  3. Use the OEM license key on a webpage in the www.mysite.com domain.
Copy Code
ThumbnailXpress1.SetSolutionName "ACMEImaging"
ThumbnailXpress1.SetSolutionKey 0x1C3A023F, 0xA018F260, 0x37AF0E51, 0x557F2389
ThumbnailXpress1.SetOEMLicenseKey
"1.0.GQCC0EmUgONaI4QDZ32tpGWfpGW4gtbC0iIC0iN4bigYM3m3K5b487QOsAM38O24mUp5bOpD2O240OQ32U2YsUKDKA87MYPGgGgaptMiK5Nv8AI4mYg4m3QvW52DZCPGs4p784mtP4IUgOWiIG0AQYp4052iIAWvNCZfpGWC8vQ5P4ZGKaPAWfbiYfZOI303pOZAgisiNaWA27gGsf8Ob7Zvm5IaKGI4KC8GsG2CWYpGQAg5sUmYWvZCQANig48G2ap4bG0DsO240YsUmtptNiZamCPGbYMfMO83gANAZCN52YbY8U8f8DM4m3g7MYMYWGW5Q7QGWaMiN7MtZfmtgY8AN7NDP7Z4W7sCbGKUPa0im7EDPP"


Licensing Glossary

Accusoft.ThumbnailXpress4.ActiveX
Licensing Glossary
Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > Licensing > Licensing Glossary

Glossary Item Box

The following sections each describe a licensing term:

  • Access Key
  • Accusoft Products
  • Activation
  • Assigned Access Key
  • Automatically Reported Runtime Licensing
  • Customers, Developers, and Users
  • Edition
  • Evaluation License
  • Hardware Key
  • License Configuration File
  • Licensing Development Kit (LDK)
  • License Key
  • License Manager
  • Manually Reported Runtime Licensing
  • Node-Locked Licensing
  • Non-Node-Locked Licensing
  • Paid License
  • Registration
  • Runtime (Deployment) Licensing
  • Server Licensing Utility (SLU)
  • Toolkit Licensing
  • Web Services

Access Key

All licenses are assigned a unique identifier known as an Access Key. Access Keys are associated with the organization that purchased the license.

Accusoft Products

An Accusoft product may be licensed with either a Toolkit License or a Runtime License.

Activation

Activation is the process of selecting a previously registered toolkit license. Licenses may be paid (Toolkit) or evaluation, and may be for one of many product editions, for products with multiple editions.

Assigned Access Key

An assigned Access Key is one that is assigned to a specific user or users. The assignment of Access Keys to specific users can be done using the Licensing Development Kit (LDK).

Automatically Reported Runtime Licensing

Runtimes may be licensed in one of two ways: automatic reporting or manual reporting. With automatic reporting, you do not need to worry about royalty reporting; it is handled by the licensing layer.

Customers, Developers, and Users

Customers are simply any person who has purchased an Accusoft product. Developers are customers who possess a license for an Toolkit. Users are typically the customers of Accusoft's customers who use applications built around Accusoft components and are assigned a runtime license.

Edition

Some Accusoft products have multiple editions. Editions may offer multiple levels of product speed or product features, allowing customers to find a price-performance mix that is appropriate for them. Products that support multiple editions register multiple Toolkit licenses at installation time, one Toolkit license per edition. Developers must select an edition to activate using the License Manager.

Evaluation License

An evaluation license is a Toolkit license that is unpaid. When an Accusoft Toolkit is installed, evaluation licenses for all applicable product editions are installed and registered, and the edition with the most features is activated. Evaluation Toolkit licenses can be used to try out products. However, the product behavior is limited by trial dialog pop-ups, timeouts, or evaluation watermarks. When you determine the product is a good fit, you can purchase a Toolkit license to eliminate trial dialog pop-ups, timeouts, and evaluation watermarks.

Hardware Key

When a license is activated for a product, the system information that identifies the installation hardware is contained within an encrypted string and is used to generate the license key for the product. The string containing the encrypted hardware information is known as the Hardware Key.

License Configuration File

When a Toolkit or an Automatically Reported Runtime license is purchased, a configuration file is provided that contains information about the license that was purchased. This file is used by the licensing utilities (License Manager, Server License Utility, and License Development Kit) to install a license on the system.

Licensing Development Kit (LDK)

The Licensing Development Kit (LDK) is an ActiveX component that may be used for Runtime Licensing. The LDK is one mechanism for Automatically Reported Runtime Licensing; the Server Licensing Utility (SLU) is the other.

License Key

Each product license has a unique key associated with it that uniquely identifies the customer, product, version, edition, and platforms, and, in some cases, the hardware for which the license is valid.

License Manager

The License Manager is a GUI application that is used by a developer to register and activate Toolkit licenses on their development system.

Manually Reported Runtime Licensing

Runtimes may be licensed in one of two ways: automatic reporting or manual reporting. With Manually Reported Runtime Licensing, you embed all of the licensing information directly into your application. You must manually provide royalty reporting to Accusoft for the actual licenses deployed. This model will be the best choice for you if you are not connected to the Internet at runtime, as might be the case in an defense or financial application.

Node-Locked Licensing

Another name for Automatically Reported Runtime Licensing.

Non-Node-Locked Licensing

Another name for Manually Reported Runtime Licensing.

Paid License

A paid license is a Toolkit license that you have purchased from Accusoft. It is ready to be used in production, with no trial dialog pop-ups, timeouts, or evaluation watermarks. If you wish to test other editions of the Accusoft product for which you have purchased a Paid License, you may activate an Evaluation license for that edition; a complete set of Evaluation licenses for all editions is registered at installation time.

Registration

Registration is the process of informing the License Manager about a new Toolkit license you have purchased. It uses this information to create a license key on your system; this allows you to activate the product for development with no restrictions, such as trial dialog pop-ups, timeouts, or evaluation watermarks.

Runtime (Deployment) Licensing

When deploying an application, a Runtime License is also required for each user’s installation. You must purchase runtime licenses, which are consumed as licenses are registered. There are two Runtime licensing models: Automatically Reported Runtime License; and Manually Reported Runtime License.

Server Licensing Utility (SLU)

The Server Licensing Utility (SLU) is a small GUI application that allows you to request a license key from the Runtime licenses you have purchased. The SLU is one mechanism for Automatically Reported Runtime Licensing; the Licensing Development Kit (LDK) is the other.

Toolkit Licensing

Each Toolkit is assigned to a specific developer who has a registered account with Accusoft. When the developer installs the Toolkit, it is not fully functional until they have activated the license through the use of the License Manager application. When the developer starts the License Manager, they are required to provide login credentials that identify and allow them to activate their license on a development system. See Toolkit Licensing.

Web Services

When a license is registered, information that uniquely identifies the customer’s or user’s hardware is passed along with the license information over the Internet to a web service. The web service validates the licensing request, generates a key that includes the hardware information, and returns the new license key to the application that made the licensing request. The license key is then stored on the requested system and used by the component when it is executed. It is also possible to register systems that are not directly connected to the Internet through the use of removable media and a different system that is connected to the Internet.


Software License Agreement

Accusoft.ThumbnailXpress4.ActiveX
Software License Agreement
See Also Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > Licensing > Software License Agreement

Glossary Item Box

PLEASE READ THE FOLLOWING SOFTWARE LICENSE AGREEMENT WHICH GOVERNS YOUR RIGHT TO USE OF THE TOOLKIT. YOU MUST ACCEPT THESE TERMS BEFORE YOU ARE ALLOWED TO INSTALL THE TOOLKIT. YOU EXPRESSLY AGREE THAT YOU HAVE THE AUTHORITY TO CONTRACTUALLY BIND THE ORGANIZATION AGREEING TO THESE TERMS.

BY CLICKING "I ACCEPT," OR INSTALLING TOOLKIT, OR PLACING TOOLKIT IN-USE, LICENSEE IS AGREEING TO BE BOUND BY THIS AGREEMENT.

1. GRANT OF AGREEMENT

This Accusoft Corporation, ("ACCUSOFT") Software License Agreement ("AGREEMENT") grants the organization contracting under this agreement as licensee ("LICENSEE") a limited, nontransferable, nonexclusive and non-assignable license to use the trial mode version of this ACCUSOFT Development Toolkit ("TOOLKIT") on a single computer for evaluation of fitness only and not for any commercial purpose; or to use a properly purchased and registered TOOLKIT, for development purposes only on a single computer, provided the TOOLKIT is IN-USE on only one computer at any time. (However additional TOOLKIT licenses may be purchased.) TOOLKIT is "IN-USE" on a computer when it becomes loaded by any means for any purpose into temporary memory (that is, including but not limited to RAM) or when it becomes copied or installed to less temporary storage by any means for any purpose (that is, including but not limited to hard disk, CD-ROM or other removable disk or tape, USB or other flash memory drive or card, or other local, networked, or cloud storage device) when it is accessible to that computer. The TOOLKIT is explicitly not to be used on a site-wide basis, via a server or other networked connection.

2. REDISTRIBUTION OF TOOLKIT RUNTIMES

ACCUSOFT does not grant LICENSEE any rights to deploy, license, sell, reproduce, copy, install, lease, timeshare, rent, or otherwise distribute or transfer TOOLKIT or any portion of TOOLKIT ("PORTION") except as provided in Section 1. GRANT OF AGREEMENT. For licensing information about any other distribution of TOOLKIT or PORTION, please visit our web site (www.accusoft.com/licensing.htm), or contact our sales staff. LICENSEE agrees to notify ACCUSOFT immediately of any violations or changes in status regarding LICENSEE's compliance with any term of this AGREEMENT.

In the event that ACCUSOFT grants LICENSEE in a written separate runtime license agreement ("RUNTIME AGREEMENT") a right to deploy, license, sell, reproduce, copy, install, lease, timeshare, rent, or otherwise distribute or transfer PORTIONS, the RUNTIME AGREEMENT will specify what PORTIONS may be distributed ("RUNTIME"). LICENSEE agrees to acknowledge and uphold the terms and conditions of this AGREEMENT as well as the terms of the RUNTIME AGREEMENT itself, which will be provided only in writing. In such event, LICENSEE may distribute RUNTIMES as part of the LICENSEE's software application or derivative works ("PRODUCT") upon additionally agreeing to the following:

a) LICENSEE understands and acknowledges that in order to receive any discounted pricing for RUNTIME distribution licensing fees based on the type of installation, it must either: 1) prepay for a number of RUNTIME licenses that is sufficient to qualify for ACCUSOFT's then-current published quantity discount, or 2) it must pay for the licenses in accordance with a written contract between LICENSEE and ACCUSOFT.

b) LICENSEE's PRODUCT shall not compete to any degree with the TOOLKIT. Such competitive PRODUCTS are defined as software development toolkits that include similar functionality as TOOLKIT and that are intended for use by software developers and/or system integrators.

c) LICENSEE's PRODUCT must be substantially greater in scope with greater functionality and features than those of the TOOLKIT.

d) LICENSEE will not use ACCUSOFT's name, logo, or trademarks to market PRODUCT without prior written approval of ACCUSOFT except LICENSEE will include a statement substantially similar to the following within PRODUCT documentation and about box: "Portions of this product contain imaging and other technology owned by Accusoft Corporation, Tampa, FL, (www.accusoft.com). ALL RIGHTS RESERVED." See Section 20. THIRD PARTY NOTICES for additional requirements.

e) LICENSEE agrees to only distribute the RUNTIMES. No license or other rights are granted to LICENSEE for any distribution of the TOOLKIT or PORTIONS including, but not limited to, documentation, source code, or the RUNTIME distribution unlock codes.

g) LICENSEE will only distribute the RUNTIMES on the hardware and operating system(s) for which the RUNTIMES are intended to be used according to the RUNTIME AGREEMENT.

If ANY of the terms of this AGREEMENT are not applicable to LICENSEE'S situation, or if any of the terms of this AGREEMENT cannot be complied with, or if LICENSEE needs modifications to this AGREEMENT or the license granted for any reason, LICENSEE must contact ACCUSOFT about obtaining an expanded license from ACCUSOFT (available by phone at: 813-875-7575, x321, by e-mail at: Sales@accusoft.com or by fax at: 813-875-7705).

This AGREEMENT grants rights to LICENSEE only for the TOOLKIT and does not convey any other rights of use or distribution to ACCUSOFT technology.

3. OWNERSHIP

LICENSEE acknowledges and agrees that ACCUSOFT owns all rights, title and interest in the TOOLKIT, in all forms, including without limitation any and all worldwide proprietary rights therein, including but not limited to trademarks, copyrights, patent rights, patent continuations, trade secrets and confidential information.

LICENSEE may not remove or alter the copyright notice from any copy of the TOOLKIT or any copy of the written materials, accompanying the TOOLKIT.

LICENSEE waives its right to contest any of ACCUSOFT's patents, trademarks, service marks, trade names, copyrights, and other intellectual property and proprietary rights in and to the TOOLKIT.

LICENSEE shall not use such trademarks, service marks, and trade names except where and as permitted under this AGREEMENT without receiving ACCUSOFT's prior written approval of such use. If such approval is granted, LICENSEE’s right to use such trademarks, service marks, and trade names shall end upon the termination of this AGREEMENT.

4. RESTRICTIONS AND RESERVATIONS.

All rights and licenses not expressly granted to LICENSEE are reserved to ACCUSOFT. LICENSEE is strictly prohibited from reproducing, copying, marketing, selling, distributing, licensing, sublicensing, leasing, timesharing or renting the TOOLKIT or PORTION, and LICENSEE is strictly prohibited from any use of the TOOLKIT or PORTION except as permitted by this AGREEMENT, and such actions are expressly prohibited. LICENSEE is strictly prohibited from incorporating or including the TOOLKIT or PORTION into or as part of any PRODUCT or service of LICENSEE except as provided by this AGREEMENT, regardless of the functionality of TOOLKIT (or lack thereof) within or as part of such PRODUCT or service of LICENSEE. LICENSEE shall not for any reason disassemble, decompile, decrypt or reverse engineer the TOOLKIT or PORTION or in any manner attempt to discover or reproduce the source code or any other copyrightable, proprietary, or trade secret aspect of the TOOLKIT or PORTION. Nor shall LICENSEE use the TOOLKIT or PORTION, directly or indirectly, in developing LICENSEE's own PRODUCT with, or including, similar functionality. LICENSEE shall not make any copies of the TOOLKIT or PORTION for any purpose whatsoever except as permitted by this AGREEMENT. Source code that is provided with TOOLKIT for sample or demonstration purposes may be used directly or indirectly in developing PRODUCT, however it may not be distributed in source form in whole or in part with or as part of PRODUCT.

5. WARRANTY DISCLAIMER

LICENSEE ACKNOWLEDGES AND AGREES THAT THE TOOLKIT IS PROVIDED "AS IS." ACCUSOFT DISCLAIMS ANY AND ALL REPRESENTATIONS AND WARRANTIES OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND AGAINST INFRINGEMENT.

6. LIMITATION OF LIABILITY

ACCUSOFT SHALL HAVE NO LIABILITY TO LICENSEE, LICENSEE AFFILIATES, SUBSIDIARIES, SHAREHOLDERS, OFFICERS, DIRECTORS, EMPLOYEES, REPRESENTATIVES OR ANY THIRD PARTY, WHETHER IN CONTRACT, TORT, NEGLIGENCE OR PRODUCTS LIABILITY, FOR ANY CLAIM, LOSS OR DAMAGE, INCLUDING BUT NOT LIMITED TO, LOST PROFITS, LOSS OF USE, BUSINESS INTERRUPTION, LOST DATA, LOST FILES, OR FOR ANY DIRECT, INDIRECT, SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES OF ANY KIND OR NATURE WHATSOEVER ARISING OUT OF OR IN CONNECTION WITH USE OF OR INABILITY TO USE THE TOOLKIT, OR THE PERFORMANCE OR OPERATION OF THE TOOLKIT, EVEN IF ACCUSOFT HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

7. INDEMNIFICATION BY LICENSEE

LICENSEE SHALL INDEMNIFY, HOLD HARMLESS AND DEFEND ACCUSOFT FOR ANY LOSS, CLAIM, ACTION OR PROCEEDING THAT ARISES OR RESULTS FROM ANY ACTIONS OR OMISSIONS OF LICENSEE PERTAINING TO THE PRODUCT OR THE TOOLKIT AND FROM ANY ACTIONS OF LICENSEE THAT ARE IN VIOLATION OF THIS AGREEMENT.

8. TERM AND TERMINATION

Unless otherwise agreed to by the parties, this AGREEMENT shall become effective upon the earlier of LICENSEE's clicking of "I Accept" or LICENSEE'S installing or placing TOOLKIT IN_USE ("Effective Date") and shall continue in full force and effect until terminated in accordance with the terms set forth in this AGREEMENT.

Any material breach of this AGREEMENT shall automatically and immediately terminate this AGREEMENT. In the event that LICENSEE ceases to do business or is adjudged bankrupt or insolvent, ACCUSOFT may, at its sole option, terminate this AGREEMENT, by giving ten (10) Business Days written notice of such termination, which notice shall identify and describe the basis for such termination.

In the event of any termination of this AGREEMENT, any RUNTIME AGREEMENT is simultaneously terminated and LICENSEE shall stop using the TOOLKIT and PORTION, shall cease manufacturing the PRODUCT containing TOOLKIT or PORTION, and shall cease distributing PRODUCT containing TOOLKIT or PORTION. LICENSEE shall also require its resellers, OEMs, and other distribution channels (if any) to likewise stop manufacturing and distributing the PRODUCT containing TOOLKIT or PORTION. Within ten (10) Business Days thereafter, LICENSEE shall return or, at ACCUSOFT's option, destroy, the TOOLKIT and all PORTIONS, whether or not incorporated in or with the PRODUCT, that are within LICENSEE’s possession, custody and control, and shall certify to ACCUSOFT in writing within ten (10) Business Days after that return or destruction that it has complied with the foregoing obligation.

All Sections except Section 1. GRANT OF LICENSE shall continue in full force and effect, notwithstanding any termination of this AGREEMENT.

9. LIQUIDATED DAMAGES

In the event LICENSEE (a) copies the TOOLKIT or PORTION except as permitted by this AGREEMENT, (b) uses the TOOLKIT or PORTION for any reason other than as permitted by this AGREEMENT, (c) installs or uses the TOOLKIT or PORTION on more than a single computer, or (d) otherwise violates or breaches this Agreement, LICENSEE agrees that ACCUSOFT is entitled to obtain as liquidated damages and not as a penalty the greater of the amount of (v) the published quantity one distribution price based upon the type of distribution, or (w) $99 per each user of each PRODUCT or service of LICENSEE in which the TOOLKIT or PORTION is included, copied, incorporated, embedded or accessible; (x) $100 per copy of TOOLKIT or PORTION; (y) $100 per copy of any PRODUCT in which TOOLKIT or PORTION is included, copied, incorporated, embedded or accessible; or (z) 3% of all revenues realized by LICENSEE pertaining to any PRODUCTS or services of LICENSEE in which TOOLKIT or PORTION is included, copied, incorporated, embedded or accessible. THE LICENSEE EXPRESSLY AGREES THAT THE FOREGOING LIQUIDATED DAMAGES ARE NOT A PENALTY.

10. CONFIDENTIALITY

LICENSEE acknowledges that the TOOLKIT contains ACCUSOFT know-how, confidential and trade secret information ("PROPRIETARY INFORMATION"). LICENSEE agrees: (a) to hold the PROPRIETARY INFORMATION in the strictest confidence, (b) not to, directly or indirectly, copy, reproduce, distribute, manufacture, duplicate, reveal, report, publish, disclose, cause to be disclosed, or otherwise transfer the PROPRIETARY INFORMATION to any third party, (c) not to make use of the PROPRIETARY INFORMATION other than as permitted by this AGREEMENT, and (d) to disclose the PROPRIETARY INFORMATION only to LICENSEE's representatives requiring such material for effective performance of this AGREEMENT and who have undertaken an obligation of confidentiality and limitation of use consistent with this AGREEMENT. This obligation shall continue as long as allowed under applicable law.

11. INJUNCTIVE RELIEF

LICENSEE agrees that any violation or threat of violation of this AGREEMENT will result in irreparable harm to ACCUSOFT for which damages would be an inadequate remedy. Therefore, in addition to its rights and remedies available at law (including but not limited to the recovery of damages for breach of this AGREEMENT), ACCUSOFT shall be entitled to immediate injunctive relief to prevent any violation of ACCUSOFT's copyright, trademark, trade secret rights regarding the TOOLKIT, or to prevent any violation of this AGREEMENT, including, but not limited to, unauthorized use, copying, distribution or disclosure of or regarding the TOOLKIT or PORTION, as well as any other equitable relief as the court may deem proper under the circumstances.

12. NO REDUCED PRICING

In any determination of ACCUSOFT's damages (whether liquidated damages or actual damages), or any determination of any licensing fees or royalties due ACCUSOFT under this AGREEMENT due to a breach by LICENSEE hereunder, LICENSEE shall not be entitled to any discounts (volume or otherwise) or reduced licensing fees or royalties. The foregoing sentence shall be applicable unless LICENSEE has negotiated and entered into a written, signed agreement with ACCUSOFT for such reduced or discounted licensing fees or royalties and paid ACCUSOFT such fees or royalties in advance of any: (a) distribution of the TOOLKIT or PORTION, (b) copying of the TOOLKIT or PORTION, or (c) incorporation or use of the TOOLKIT or PORTION in or pertaining to any PRODUCT or service of LICENSEE. Further, LICENSEE agrees that it shall not be entitled to reduced licensing fees or royalties when determining ACCUSOFT's damages due to any undertaking or activity by LICENSEE regarding the TOOLKIT or PORTION outside of or exceeding the scope of permission or other terms of this AGREEMENT, or LICENSEE's actions otherwise in violation of this AGREEMENT.

13. ATTORNEYS' FEES AND COSTS

In the event of any lawsuit or other proceeding brought as a result of any actual or alleged breach of this AGREEMENT, to enforce any provisions of this AGREEMENT, or to enforce any intellectual property or other rights in or pertaining to the TOOLKIT or PORTION, the prevailing party shall be entitled to an award of its reasonable attorneys’ fees and costs, including the costs of any expert witnesses, incurred at all levels of proceedings.

14. GOVERNING LAW

This AGREEMENT shall be construed, governed and enforced in accordance with the laws of the State of Florida, without regard to any conflicts of laws rules. Any action related to or arising out of this AGREEMENT will be filed only in the Florida courts and LICENSEE consents to the exclusive jurisdiction and venue of the state and federal courts located in Tampa, Florida.

15. SEVERABILITY

If any provision of this AGREEMENT is determined to be invalid by any court of final jurisdiction, then it shall be omitted and the remainder of the AGREEMENT shall continue to be binding and enforceable. In addition, the Court is hereby authorized to enforce any provision of the AGREEMENT that the Court otherwise deems unenforceable, to whatever lesser extent the Court deems reasonable and appropriate, rather than invalidating the entire provision. Without limiting the generality of the foregoing, LICENSEE expressly agrees that should LICENSEE be found to have breached the AGREEMENT, under no circumstances shall LICENSEE be entitled to any volume or other discount, or reduced licensing fee or royalty in the determination of ACCUSOFT's damages, or otherwise in the determination of any licensing fee or royalty owed to ACCUSOFT.

16. GOVERNMENT RIGHTS

The TOOLKIT and accompanying documentation have been developed at private expense and are sold commercially. They are provided under any U.S. government contracts or subcontracts with the most restricted and the most limited rights permitted by law and regulation. Whenever so permitted, the government and any intermediaries will obtain only those rights specified in ACCUSOFT's standard commercial license. Thus, the TOOLKIT referenced herein, and the documentation provided by Accusoft hereunder, which are provided to any agency of the U.S. Government or U.S. Government contractor or subcontractor at any tier shall be subject to the maximum restrictions on use as permitted by FAR 52.227-19 (June 1987) or DFARS 227.7202-3(a) (Jan. 1, 2000) or successor regulations. Manufacturer is Accusoft Corporation, 4001 N. Riverside Drive Tampa, FL 33603.

17. ENTIRE AGREEMENT

This AGREEMENT represents the entire understanding of the parties concerning the subject matter hereof and supersedes all prior communications and agreements, whether oral or written, relating to the subject matter of this AGREEMENT. Only a writing signed by the parties may modify this AGREEMENT. In the event of any modification in writing, of this AGREEMENT, including an expanded license agreement, all sections of this Agreement survive except Section 2. Limited License.

18. CONTACT US

Should you have any questions concerning this AGREEMENT, or if you desire to contact ACCUSOFT for any reason, please contact ACCUSOFT at 1-813-875-7575.

19. OTHER RESTRICTIONS

a) This AGREEMENT shall not be amended, altered, changed or modified in any way, unless agreed to in writing by both ACCUSOFT and LICENSEE. Such writing must be executed by a duly authorized representative of ACCUSOFT and a duly authorized representative of LICENSEE.

b) This AGREEMENT is not transferable or assignable by LICENSEE under any circumstances, without the prior written consent of ACCUSOFT. ACCUSOFT will not unreasonably withhold such consent. This AGREEMENT shall be binding upon, and is made for the benefit of, each party, its successors, and permitted assignees (if any). For the purposes of this AGREEMENT, any change in control of LICENSEE shall constitute an assignment or transfer of this AGREEMENT requiring prior written consent of ACCUSOFT. As used in this section, a change in control is defined as (i) any change in ownership of more than fifty percent (50%) of the voting interest in LICENSEE, whether by merger, purchase, foreclosure of a security interest or other transaction, or (ii) a sale of all or substantially all of the assets of LICENSEE.

c) The relationship established by this AGREEMENT between LICENSEE and ACCUSOFT shall be that of Licensee and Licensor. Nothing contained in this AGREEMENT shall be construed as creating a relationship of agency, joint venture or partnership between LICENSEE and ACCUSOFT. Neither party shall have any right whatsoever to incur any liabilities or obligations on behalf of the other party.

d) ACCUSOFT's failure to perform any term or condition of this AGREEMENT as a result of conditions beyond its control such as, but not limited to, war, strikes, fires, floods, acts of God, governmental restrictions, power failures, or damage or destruction of any network facilities or servers, shall not be deemed a breach of this AGREEMENT.

e) The headings provided in this AGREEMENT are for convenience and reference purposes only. In the event of a conflict between the terms and conditions listed in this AGREEMENT, and any attached Schedules or Appendices, the terms and conditions of this AGREEMENT shall govern.

f) A waiver of a breach, violation, or default under this AGREEMENT shall not be a waiver of any subsequent breach, violation or default. Failure of either party to enforce compliance with any term or condition of this AGREEMENT shall not constitute a waiver by the party of such term or condition.

g) All notices and communications shall be in writing and shall be deemed to have been duly given the earlier of when delivered or three (3) Business Days after mailing by certified mail, return receipt requested, postage prepaid, or by international delivery service, addressed to the parties at their respective addresses set forth on the Order Form or at such other addresses as the parties may designate by written notice in accordance with this section.

20. THIRD PARTY NOTICES

a) ADOBE PDF TECHNOLOGY

Portions of the PDF functionality in the TOOLKIT include Adobe Technology ("Adobe") licensed to ACCUSOFT. The term "TOOLKIT" as defined in the Agreement includes technology from Adobe and related documentation, and any upgrades, modified versions, updates, additions, and copies thereof.

FONT LICENSE: If the TOOLKIT includes font software, LICENSEE may embed the font software, or outlines of the font software, into its Application to the extent that the font vendor copyright owner allows for such embedding. The fonts contained in this package may contain both Adobe and non-Adobe owned fonts. LICENSEE may fully embed any font owned by Adobe.

LIMITED WARRANTY

THE TERMS OF THIS AGREEMENT STATE THE SOLE AND EXCLUSIVE REMEDIES FOR ACCUSOFT’S BREACH OF WARRANTY. EXCEPT FOR THE FOREGOING LIMITED WARRANTY, ADOBE AND ITS SUPPLIERS MAKE NO WARRANTY, EXPRESS OR IMPLIED, AS TO MERCHANTABILITY, FITNESS FOR ANY PARTICULAR PURPOSE, OR NON-INFRINGEMENT. IN NO EVENT WILL ADOBE OR ITS SUPPLIERS BE LIABLE TO LICENSEE FOR ANY CONSEQUENTIAL, INCIDENTAL OR SPECIAL DAMAGES, INCLUDING ANY LOST PROFITS OR LOST SAVINGS, EVEN IF AN ADOBE REPRESENTATIVE HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES, OR FOR ANY CLAIM BY ANY THIRD PARTY. Some states or jurisdictions do not allow the exclusion or limitation of incidental, consequential or special damages, or the exclusion of implied warranties, or limitations on how long an implied warranty may last, so the above limitations may not apply to LICENSEE. In such states/countries and to the extent permissible, any implied warranties are limited to thirty (30) days.

INTELLECTUAL PROPERTY

The Adobe technology is the intellectual property of Adobe and is protected under trademarks, registered trademarks, copyrights, and/or patents in the United States and/or other countries. ALL RIGHTS RESERVED.

Rev. 20120112

See Also

Distributing ThumbnailXpress
Licensing


Distributing Applications and Deployment

Accusoft.ThumbnailXpress4.ActiveX
Distributing Applications and Deployment
Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > Distributing Applications and Deployment

Glossary Item Box

This section provides information about the following:

  • Verify You're Using the Latest Service Pack
  • Distributing ThumbnailXpress


Verify You're Using the Latest Service Pack

Accusoft.ThumbnailXpress4.ActiveX
Verify You're Using the Latest Service Pack
See Also Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > Distributing Applications and Deployment > Verify You're Using the Latest Service Pack

Glossary Item Box

Service pack updates will not overwrite paid licensing. Your paid licensing will continue to work and you will not be required to re-enter your purchased registration codes. Service pack updates do not include any changes that might "break" previously developed and/or deployed code.

Verify Latest Development Components

To verify you are using the latest version of an Accusoft Development Component or Components, please refer to the currently released product build numbers at www.accusoft.com/latestbuilds.htm.

If you require further assistance or have questions or comments, please see the topic on Getting Support for more detailed information.

See Also

Getting Support
Installing on a Development Machine


Distributing ThumbnailXpress

Accusoft.ThumbnailXpress4.ActiveX
Distributing ThumbnailXpress
See Also Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > Distributing Applications and Deployment > Distributing ThumbnailXpress

Glossary Item Box

DLL Files to Distribute

Required

  • Distribute the appropriate assembly DLL file with applications using the ThumbnailXpress Product:

Accusoft.ThumbnailXpress4.ActiveX.dll - ActiveX component - ActiveX Control for thumbnail creation and manipulation.

Optional

  • The following files are optional and are only required if you are using other Accusoft products for image processing and/or image acquisition:

Accusoft.ActiveX.PDFXpress4.dll - ActiveX Windows Forms Control (Only required if PDF Xpress™ is used for image acquisition in your application).

See Also

Getting Support
Installing on a Development Machine
Software License Agreement
Verify You're Using the Latest Service Pack
Licensing


Concepts

Accusoft.ThumbnailXpress4.ActiveX
Concepts
Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > Concepts

Glossary Item Box

This section provides information about the following:

  • Overview of ThumbnailXpress
  • Glossary


Overview of ThumbnailXpress

Accusoft.ThumbnailXpress4.ActiveX
Overview of ThumbnailXpress
Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > Concepts > Overview of ThumbnailXpress

Glossary Item Box

ThumbnailXpress encapsulates powerful thumbnail capabilities. They are described below:

ThumbnailXpress Object

The ThumbnailXpress control enables you to manage thumbnail generation and viewing.

Thumbnail Item

Individual thumbnail item data, including image filename, item type, page number, bitmap, page count, and processing status, can be accessed.

Thumbnail Cache

All thumbnail images are cached for rapid display access purposes.

Filter

A filter can be used to specify match and comparison image file criteria that may be imposed when thumbnail images are loaded from a file system directory.


Glossary

Accusoft.ThumbnailXpress4.ActiveX
Glossary
Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > Concepts > Glossary

Glossary Item Box

A | B | C | D | E | F | G | H | I | J | K | L | M | N | O | P | Q | R | S | T | U | V | W | X | Y | Z

A

Aspect Ratio
There are two kinds of aspect ratio that you need to be aware of when working with 2D images; the image aspect ratio and the pixel aspect ratio.The image aspect ratio is the ratio of the width of the image to the height of the image. It's important when resizing an image to keep this ratio as close to unchanged as possible or the image may become distorted.The pixel aspect ratio is the shape of the pixels in the image. For computers this is normally square (1:1) or close to it depending on the monitor settings. For some video sources, however, the pixels may be slightly rectangular.

B

Black on Edge
The minimum or maximum number of pixels on the vertical or horizontal edge of an image or document.

BLOB
Binary Large Object.

BMP
The Microsoft Windows Bitmap file format is based on the Microsoft Windows internal bitmap data structures. The BMP format is very widely used and it is quick and easy to read. Although most BMP files are uncompressed, a type of run length encoding is supported.

BPP
Bits per pixel.

Brightness
A ThumbnailXpress method that enhances the brightness attributes of the pixels in the bitmap. Positive settings produce brighter pixels while negative settings produce darker pixels.

C

CCITT
CCITT is the most widely used compression scheme for transmitting binary (black and white) image data. CCITT was established by the International Telegraph and Telephone Consultative Committee. The Group 3 and Group 4 CCITT compression standards are widely used for transmitting fax data. CCITT compressed images are typically stored in the TIFF image format.

Container
Gets the container for the component. An object implementing the IContainer interface that represents the component's container, or a null reference (Nothing in Visual Basic) if the component does not have a site.

Contrast
A ThumbnailXpress method that enhances the contrast attributes of the pixels in the bitmap. Positive settings produce a higher contrast image while negative settings produce a lower contrast image. Images with a higher contrast have a higher frequency of pixel intensities near the ends of the intensity spectrum while images with a lower contrast have a higher frequency of pixels near the middle of the intensity spectrum.

CreateObjRef
Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.

D

DCOM
Microsoft's extension of their Component Object Model (COM) to support objects distributed across a network. DCOM is currently implemented only by Microsoft for Microsoft Windows; and by Software AG, under the name "EntireX", for Unix and IBM mainframes. DCOM serves the same purpose as IBM's DSOM protocol. DCOM is an object model, but has no provisions for inheritance.

DCX
An image format containing multiple PCX images. A DCX file can contain a maximum of 1024 images.

DDB
Microsoft Device Dependent Bitmap. The actual in-memory information used to display an image.

DEP
Data Execution Prevention (computer security).

Despeckle
A modified median filter primarily used for reducing noise in document images. Despeckling divides the image into pixel groups and uses the brightness value to adjust brightness spikes. This filter will reduce noise in a black and white document image with minimal distortion of document text.

DIB
Microsoft Device Independent Bitmap. An alternative file extension used by the Microsoft Windows Bitmap.

DICOM
Digital Imaging and Communication, a standard for handling digital medical images.

Dispose
Releases the resources used by the Component.

Disposed
Adds an event handler to listen to the Disposed event on the component. When you create a Disposed delegate, you identify the method that handles the event.

Dithering
A technique used in computer graphics to create the illusion of varying shades of gray on a monochrome display or printer, or additional colors on a color display or printer. Dithering relies on treating areas of an image as groups of dots that are colored in different patterns. Akin to the print images called halftones, dithering takes advantage of the eye’s tendency to blur spots of different colors by averaging their effects and merging them into a single perceived shade or color. Depending on the ratio of black dots to white dots within a given area, the overall effect is of a particular shade of gray. Dithering is used to add realism to computer graphics and to soften jagged edges in curves and diagonal lines at low resolutions.

E

Emboss
A ThumbnailXpress method that causes the foreground of an image to appear raised from background. Embossing gives the image a raised metallic-like look

ePIC
Accusoft enhanced PIC image format. This high performance image compression combines the patented ELS arithmetic coder with the high performance Accusoft JPEG libraries. The result is a new and unbeatable compression technology. The ePIC compression has significant advantages over standard JPEG. Most importantly it produces smaller file sizes and decompresses extremely quickly. ePIC images can be password encrypted. These images can also be 'zoomed' or scaled to larger, arbitrary sizes.

Equalize
A ThumbnailXpress method that is a point process used for adjusting the contrast of an image. A frequency histogram of the colors of the image is computed and adjusted to equalize the colors across the full spectrum of intensity values. The equalized colors are applied to each pixel in the image.

EXIF
EXchangeable Image File format (Japan Electronic Industry Development Association, JEIDA), compressed image format used in digital cameras.

F

Flate
The lossless deflate compression algorithm is based on two other compression algorithms: huffman encoding and LZ77 compression.

Float
Denotes a simple type that stores 32-bit floating-point values.

G

Gamma
A non-linear brightness transform. Gamma values greater than 0 and less that 1.0 generate exponential curves that dim and image. Gamma values greater than 1.0 generate exponential curves that brighten an image.

GDI
Acronym for Graphical Device Interface. In Windows, a graphics display system used by applications to display or print bitmapped text (TrueType fonts), images, and other graphical elements. The GDI is responsible for drawing dialog boxes, buttons, and other elements in a consistent style on screen by calling the appropriate screen drivers and passing them the information on the item to be drawn. The GDI also works with GDI printers, which have limited ability to prepare a page for printing. Instead, the GDI handles that task by calling the appropriate printer drivers and moving the image or document directly to the printer, rather than reformatting the image or document in PostScript or another printer language.

GetLifetimeService
Retrieves the current lifetime service object that controls the lifetime policy for this instance.

GIF
Graphical Interchange File, originally developed by CompuServe as a machine independent format. GIF is one of the most popular image formats for storing 8-bit digitized images. GIF files are typically smaller than uncompressed formats like BMP due to the LZW compression algorithm that GIF uses.

Grey-scale
If the pixels of a grey-scale image have N bits, they may take values from zero, representing black up to 2^N-1, representing white with intermediate values representing increasingly light shades of grey. If N=1, the image is not called grey-scale, but could be called monochrome.

H

Halftone
Pertaining to pictures in which gradation of tone in the photograph is reproduced by a graduated system of dotted and checkered spots, usually nearly invisible to the unaided eye, produced by the interposition between the camera and the object of a screen. The name alludes to the fact that this process was the first that was practically successful in reproducing the half tones of the photograph.

Hue
One of the 3 components of the HSL (Hue, Saturation and Luminance ) color space. The hue component controls the overall color space of an image. Adjusting the hue of the image adjusts the color spectrum from red through yellow, green, blue, and violet.

I

ICO
Microsoft Windows Icon file format.

Inverse
To reverse something or change it to its opposite. For example, to invert the colors on a monochrome display means to change light to dark and dark to light. In a digital electrical signal, to replace a high level by a low level and vice versa. This type of operation is the electronic equivalent of a Boolean NOT operation.

IOD
Information Object Definition.

IPTC
The International Press Telecommunications Council, not the International Petroleum Technology Conference.

J

JIF
An alternative image file extension used for a JFIF compliant JPEG file. Because many early versions of JPEG contained a JPG extension but did not adhere to the JFIF specifications, the JIF extension was created to identify JPEG files that are JFIF compliant. As the popularity of JPEG grew, JFIF compliance became synonymous with the JPG extension and thus the JIF extension is rarely used.

JPEG
The JPEG (Joint Photographic Experts Group) standard is one of the most important image data compression standards. It is widely used in many industries including graphic arts, desktop publishing, medical imaging, and many more. It is also becoming one of the most widely used image formats on the Internet. Although JPEG supports a lossless mode, it most commonly uses lossy compression. This allows JPEG to achieve very high compression ratios. JPEG compression uses several compression modes. First, an image is transformed to the frequency domain using the discrete cosine transform. The smaller valued frequency components are discarded leaving only the larger valued components. The remaining components are DPCM coded and then Huffman coded. Fortunately, ImagXpress™ handles all of this for you! The compression level is adjustable. Higher quality settings produce a larger image file size with higher image quality. Lower quality settings produce a smaller image file size with lower image quality. Typically, we have found that compression ratios of 10:1 or 15:1 (A 640x480x24-bit image is 921,600 bytes; a 15:1 compressed image would compress to only 61k) produce generally acceptable image quality for photographic type images. Images compressed at higher ratios begin to show more noticeable and sometimes objectionable artifacts and clarity loss. JPEG is a 24-bit format and works only with 24-bit images. If you compress an 8-bit image, ImagXpress™ automatically converts it to 24-bit to do the compression, however, you will obtain better quality when the source image is 24-bit because 8-bit images only contain 256 colors. JPEG works best with photographic type images. It does not work well with solid colors, 16-color images, cartoon like images, or drawings. Progressive JPEG is a multiple-scan sequential JPEG format that is becoming popular on the Internet for the ability to display images in progressively clearer segments.

L

Little-endian
Describes a computer architecture in which, within a given 16- or 32-bit word, bytes at lower addresses have lower significance (the word is stored "little-end-first"). The PDP-11/VAX families of computers, Intel microprocessors, plus a lot of communications and networking hardware are little-endian. The term is sometimes used to describe the ordering of units other than bytes; most often, bits within a byte.

Lock
A lock, represented by the Visual Basic keyword "SyncLock Statement," or the C# keyword "lock Statement", allows a single thread of execution to obtain exclusive execution rights on an object. Although using locks will guarantee that multiple threads do not simultaneously access an object, they can cause significant performance degradation.

Luminance
One of the 3 components of the HSL (Hue, Saturation and Luminance) color space. Luminance controls the overall brightness of an image.

LUT
Look Up Table.

LZW
Lempel-Ziv-Welch (algorithm).

M

Matrix
A matrix filter, also called convolution, alters each pixel's color based on its current color and the colors of any neighboring pixels. The ImagXpress™ Matrix method uses a 3x3 matrix. The numbers in the matrix are coefficients. When a pixel is processed, its color value is multiplied by the coefficient in the center of the matrix, and any pixels within the 3x3 grid are multiplied by the corresponding coefficients in the matrix. The sum of the products becomes the target pixel's new value. The Divisor is simply the coefficient denominator. The matrix method is typically used for sharpening, softening, and edge enhancement.

Mosaic
A mosaic divides the bitmap into tiles of a specified size. All of the pixels in each tile are averaged and changed to the average color.

Multithreading
Multithreading, or free threading, refers to the ability of a program to execute multiple threads of operation simultaneously. An example of a multithreaded application might be a program that receives user input on one thread, performs a variety of complex calculations on a second thread, and updates a database on a third thread. In a single-threaded application, a user might spend idle time waiting for the calculations or database updates to finish. In a multithreaded application, these processes can proceed in the background so user time is not wasted. Multithreading can be a powerful tool to use in component programming. By writing multithreaded components, you can create components that perform complex calculations in the background while leaving the user interface free to respond to user input. Although multithreading can be a powerful tool, it can also be difficult to apply correctly. Improperly implemented multithreaded code can degrade application performance, or even cause frozen applications. (See MSDN).

N

Negate
An ImagXpress™ method that creates a color negative of an image.

Noise
An ImagXpress™ method that adds random pixels to the bitmap.

O

Orthogonal
Used loosely to mean mutually independent or well separated. It describes sets of primitives or capabilities that, like linearly independent vectors in geometry, span the entire "capability space" and are in some sense non-overlapping or mutually independent. For example, in logic, the set of operators "not" and "or" is described as orthogonal, but the set "and", "or", and "not" is not (because any one of these can be expressed in terms of the others).

P

PBM
Portable bitmap image format, a very simple uncompressed 1-bit (black and white) image format.

PGM
Portable Graymap image format. PGM is a very simple uncompressed 8-bit grayscale image format.

PNG
Portable Network Graphics (pronounced "ping") provides a portable, legally unencumbered (royalty-free), well-compressed, well-specified standard for lossless bitmapped image files. The initial motivation for developing PNG was to provide a royalty-free alternative to GIF. The design retains many of the features of GIF that make it an attractive format for transmission of images, such as lossless compression and progressive display capabilities. Additionally, it provides several advantages including 24-bit image support and generally better compression, although decompression is typically somewhat slower than GIF. PNG's success will be ultimately determined by its acceptability on the Internet. At the time of this writing, however, PNG has not been incorporated as part of the major Internet browsers.

PPM
Portable Pixmap image format, a very simple uncompressed 24-bit image format.

R

RGB
Red Green Blue. Bitmapped images are most generally stored as RGB data. Each pixel or data point in a true color (24-bit) image contains 3 components, red, green and blue, that describe the color of the pixel. Each of the components can have a value between 0 and 255, 0 being the darkest shade of color and 255 being the lightest shade of color. Since each component can be stored in one byte (8-bits), the 3 components take up 3 bytes or 24-bits per pixel. 8-bit images contain one byte (8-bit) indexes for each pixel that map to a color table called a palette which contains a maximum of 256 RGB entries. Likewise, 4-bit images contain 4-bit indexes for each pixel that map to a palette which contains a maximum of 16 RGB entries. 1-bit images contain 1-bit per pixel. Each bit in a 1-bit image represents either black or white.

RLE
Run Length Encoding. It is a lossless algorithm that only offers decent compression ratios in specific types of data.

S

Saturation
One of the 3 components of the HSL (Hue, Saturation, and Luminance) color space. Saturation controls the purity of a color. Higher saturations result in richer, deeper colors. Lower saturations result in paler colors.

Scalar
In programming, any data type that stores a single value (a number or Boolean), as opposed to an aggregate data type that has many elements. A string is regarded as a scalar in some languages (PERL) and a vector of characters in others (C).

Sharpen
An ImagXpress™ method that is used to sharpen an image. The sharpen filter uses a high-pass convolution matrix filter to accentuate high frequency detail in the image.

Single
Value type represents a single-precision 32-bit number with values ranging from negative 3.402823e38 to positive 3.402823e38, as well as positive or negative zero, PositiveInfinity, NegativeInfinity, and not a number (NaN).

Soften
An ImagXpress™ method that is used to soften an image. The soften filter uses a low-pass convolution matrix filter to accentuate low frequency detail in the image.

T

TGA
Targa Image File) format was developed by TrueVision for its Targa line of products. TGA is one of the earliest image formats and was the first popular format to support 24-bit color. TGA supports uncompressed and RLE compressed formats.

Thread-safe
An application using this component can use multiple controls running in the same process, where they don't interfere with each other. The thread creating the control owns the control and is the only thread that can interact with it.

TIFF
Tag Image File Format, originally released by Aldus Corporation is a standard file format found in most paint, imaging, and desktop publishing programs. TIFF is extremely powerful, flexible, and extensible. However, because of its many nuances and its wide scope, TIFF can be a difficult format to understand as well as a difficult format to support. ImagXpress™ supports a wide range of TIFF 6.0 formats including uncompressed, CCITT RLE, CCITT Group 3 Fax, CCITT Group 4 Fax, LZW, Pack Bits, JPEG, and deflate compression types. ImagXpress™ supports black and white, RGB, and RGB palette images but it does not support transparency mask, CMYK, YCbCr, or CIELab.

twip
Twips describe the sizes of characters produced by dot matrix printers, which were constrained to multiples of either 12 or 10 dots per inch.

V

VCL
A application framework library for Microsoft Windows and Borland Software Corp.'s Delphi and C++Builder rapid application development software. VCL was originally designed for Delphi but is now also used for C++Builder. This replaces Object Windows Library (OWL) as Borland's Windows C++ framework of choice. VCL encapsulates the C-based Win32 API into a much easier to use, object-oriented form. Like its direct rival, Microsoft Foundation Class Library (MFC), VCL includes classes to create Windows programs. The VCL component class can be inherited to create new VCL components, which are the building blocks of Delphi and C++Builder applications. VCL components compete somewhat with ActiveX controls, though a VCL wrapper can be created to make an ActiveX control seem like a VCL component.

VOI
Value Of Interest

Void structure
Indicates a method that does not return a value; that is, the method has the void return type.

W

Wintel
A term describing the combination of Microsoft Windows operating system running on PCs with Intel or compatible processors. Dominance of the wintel platform began with MS-DOS on PCs with Intel's 8-bit 8088 processors in 1979.

WMF
The Microsoft Windows Metafile format is used to store vector and bitmap image data. Because of its popularity and wide use, many Windows and non-Windows applications support WMF.

WSQ
Wavelet Scalar Quantization (WSQ) Gray-Scale Fingerprint Image Compression Specification based on the results of the NIST (National Institute of Standards and Technology) review. The benefit of WSQ fingerprint-specific compression is reduced file size. A sample fingerprint with a resolution of 589 pixels by 605 pixels, 8-bit grayscale results in a file size of 325 KB when compressed with the standard lossless compression technology LZW.


How To

Accusoft.ThumbnailXpress4.ActiveX
How To
Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > How To

Glossary Item Box

This section provides information about how to do the following:

  • Define Cache & Threading Behavior
  • Define End-User Interface
  • Render Thumbnails with Annotations
  • Load & Display Thumbnails
  • Modify Thumbnails
  • Navigate Thumbnails
  • Save Thumbnails
  • Print Thumbnails
  • Debug


Fully Unlock ThumbnailXpress

Accusoft.ThumbnailXpress4.ActiveX
Fully Unlock ThumbnailXpress
Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > How To > Fully Unlock ThumbnailXpress

Glossary Item Box

Enable runtime licensing by first calling the SetSolutionName() method with the name of the runtime license solution as a parameter to the method. The SetSolutionKey() method next should be called with the four integer keys as parameters. These four integer keys make up the solution key that is required for all runtime licensing. The solution name and the four integers keys are provided in the purchase confirmation email when runtime licenses are purchased. If the application is to use Automatically Reported Runtime (Node-Locked) licensing, then this is all that is required to unlock ThumbnailXpress.

If the application is to use Manually Reported Runtime (Non-Node-Locked) licensing, then an additional call to the SetOEMLicenseKey() method is required with the OEM license key as a parameter. The OEM license key is also provided in the purchase confirmation email when these types of runtime licenses are purchased.

ImagXpress is used internally to thumbnail images, therefore ImagXpress needs to be licensed by calling the corresponding run-time licensing methods for ImagXpress. All applications must first call the SetIXSolutionName() method with ImagXpress’s name of the runtime license solution as a parameter to the method. The SetIXSolutionKey() method next should be called with the four integer keys for ImagXpress run-time licensing as parameters. The solution name for ImagXpress and the four integer keys for ImagXpress are provided in the purchase confirmation email when runtime licenses are purchased for ImagXpress. If the application is to use Automatically Reported Runtime (Node-Locked) licensing then this all that required to unlock ImagXpress for use with ThumbnailXpress.

If the application is to use Manually Reported Runtime (Non-Node-Locked) licensing then an additional call to the SetIXOEMLicenseKey() method is required with the OEM license key for ImagXpress as a parameter. The OEM license key for ImagXpress is also provided in the purchase confirmation email when these types of runtime licenses are purchased.

To thumbnail PDFs, PDF Xpress needs to be licensed by calling SetPDFXLicenseCodes() when the application begins and passing the 4 PDF Xpress unlock codes as parameters to the method. PDF Xpress V3 and PDF Xpress V4 use the older licensing mechanism and do not need a solution name.

An Automatically Reported Runtime (Node-Locked) Licensing Example:

ACMEImaging – Solution name for both ImagXpress and ThumbnailXpress.

0x40000001, 0x40000002, 0x40000003, 0x40000004 - ThumbnailXpress runtime license keys

0xB0000001, 0xB0000002, 0xB0000003, 0xB0000004 - ImagXpress runtime license keys

0x12345678, 0x12345678, 0x12345678, 0x12345678 - PDF Xpress runtime unlock codes

VB 6 Example Copy Code
‘ Provide run-time licensing for ThumbnailXpress
ThumbnailXpress1.SetSolutionName “ACMEImaging”
ThumbnailXpress1.SetSolutionKey &H40000001, &H40000002, &H40000003, &H40000004
‘ Next provide run-time licensing for ThumbnailXpress’s use of ImagXpress
ThumbnailXpress1.SetIXSolutionName “ACMEImaging”
ThumbnailXpress1.SetIXSolutionKey &HB0000001, &HB0000002, &HB0000003, &HB0000004
‘ Finally provide run-time licensing for ThumbnailXpress’s use of PDFXpress
ThumbnailXpress1.SetPDFXLicenseCodes &H12345678, &H12345678, &H12345678, &H12345678

A Manually Reported Runtime (Non-Node-Locked) Licensing Example:

ACMEImaging – Solution name for both ImagXpress and ThumbnailXpress.

0x40000001, 0x40000002, 0x40000003, 0x40000004 - ThumbnailXpress runtime license keys

0xB0000001, 0xB0000002, 0xB0000003, 0xB0000004 - ImagXpress runtime license keys

0x12345678, 0x12345678, 0x12345678, 0x12345678 - PDF Xpress runtime unlock codes

ThumbnailXpress OEM License Key –“1.0.GQCC0EmUgONaI4QDZ32tpGWfpGW4gtbC0iIC0iN4bigYM3m3K5b487QOsAM38O24mUp5bOpD2O240OQ32U2YsUKDKA87MYPGgGgaptMiK5Nv8AI4mYg4m3QvW52DZCPGs4p784mtP4IUgOWiIG0AQYp4052iIAWvNCZfpGWC8vQ5P4ZGKaPAWfbiYfZOI303pOZAgisiNaWA27gGsf8Ob7Zvm5IaKGI4KC8GsG2CWYpGQAg5sUmYWvZCQANig48G2ap4bG0DsO240YsUmtptNiZamCPGbYMfMO83gANAZCN52YbY8U8f8DM4m3g7MYMYWGW5Q7QGWaMiN7MtZfmtgY8AN7NDP7Z4W7sCbGKUPa0im7EDPP"

ImagXpress OEM License Key –“1.0.WXPB1EmUgONaI4QDZ32tpGWfpGW4gtbC0iIC0iN4bigYM3m3K5b487QOsAM38O24mUp5bOpD2O240OQ32U2YsUKDKA87MYPGgGgaptMiK5Nv8AI4mYg4m3QvW52DZCPGs4p784mtP4IUgOWiIG0AQYp4052iIAWvNCZfpGWC8vQ5P4ZGKaPAWfbiYfZOI303pOZAgisiNaWA27gGsf8Ob7Zvm5IaKGI4KC8GsG2CWYpGQAg5sUmYWvZCQANig48G2ap4bG0DsO240YsUmtptNiZamCPGbYMfMO83gANAZCN52YbY8U8f8DM4m3g7MYMYWGW5Q7QGWaMiN7MtZfmtgY8AN7NDP7Z4W7sCbGKUPa0im7EDJS"

VB 6 Example Copy Code
‘ Provide run-time licensing for ThumbnailXpress
ThumbnailXpress1.SetSolutionName “ACMEImaging”
ThumbnailXpress1.SetSolutionKey &H40000001, &H40000002, &H40000003, &H40000004
ThumbnailXpress1.SetOEMLicenseKey “1.0.GQCC0EmUgONaI4QDZ32tpGWfpGW4gtbC0iIC0iN4bigYM3m3K5b487QOsAM38O24mUp5bOpD2O240OQ32U2YsUKDKA87MYPGgGgaptMiK5Nv8AI4mYg4m3QvW52DZCPGs4p784mtP4IUgOWiIG0AQYp4052iIAWvNCZfpGWC8vQ5P4ZGKaPAWfbiYfZOI303pOZAgisiNaWA27gGsf8Ob7Zvm5IaKGI4KC8GsG2CWYpGQAg5sUmYWvZCQANig48G2ap4bG0DsO240YsUmtptNiZamCPGbYMfMO83gANAZCN52YbY8U8f8DM4m3g7MYMYWGW5Q7QGWaMiN7MtZfmtgY8AN7NDP7Z4W7sCbGKUPa0im7EDPP"
‘ Next provide run-time licensing for ThumbnailXpress’s use of ImagXpress
ThumbnailXpress1.SetIXSolutionName “ACMEImaging”
ThumbnailXpress1.SetIXSolutionKey &HB0000001, &HB0000002, &HB0000003, &HB0000004
ThumbnailXpress1.SetIXOEMLicenseKey “1.0.WXPB1EmUgONaI4QDZ32tpGWfpGW4gtbC0iIC0iN4bigYM3m3K5b487QOsAM38O24mUp5bOpD2O240OQ32U2YsUKDKA87MYPGgGgaptMiK5Nv8AI4mYg4m3QvW52DZCPGs4p784mtP4IUgOWiIG0AQYp4052iIAWvNCZfpGWC8vQ5P4ZGKaPAWfbiYfZOI303pOZAgisiNaWA27gGsf8Ob7Zvm5IaKGI4KC8GsG2CWYpGQAg5sUmYWvZCQANig48G2ap4bG0DsO240YsUmtptNiZamCPGbYMfMO83gANAZCN52YbY8U8f8DM4m3g7MYMYWGW5Q7QGWaMiN7MtZfmtgY8AN7NDP7Z4W7sCbGKUPa0im7EDJS”
‘ Finally provide run-time licensing for ThumbnailXpress’s use of PDFXpress
ThumbnailXpress1.SetPDFXLicenseCodes &H12345678, &H12345678, &H12345678, &H12345678


Define Cache & Threading Behavior

Accusoft.ThumbnailXpress4.ActiveX
Define Cache & Threading Behavior
Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > How To > Define Cache & Threading Behavior

Glossary Item Box

This section provides information about how to do the following:

  • Set Cache Behavior
  • Set Threading Behavior


Set Cache Behavior

Accusoft.ThumbnailXpress4.ActiveX
Set Cache Behavior
See Also Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > How To > Define Cache & Threading Behavior > Set Cache Behavior

Glossary Item Box

All thumbnail images are generated with unique IDs and are cached for rapid display access purposes. The application defines and manages desired caching behavior using the "Cache" properties:

  • The CacheMemoryLimit property specifies the maximum size of the cache.
  • To empty the Thumbnail Cache, call the EmptyCache method.

See Also

CacheMemoryLimit Property
EmptyCache Method


Set Threading Behavior

Accusoft.ThumbnailXpress4.ActiveX
Set Threading Behavior
See Also Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > How To > Define Cache & Threading Behavior > Set Threading Behavior

Glossary Item Box

Threading in Image Generation

ThumbnailXpress™ uses background image generation threads to improve responsiveness. At component start-up, ThumbnailXpress determines an initial count of background threads based on the host computer's capabilities. To keep operation responsive, ThumbnailXpress monitors the time consumed by a background thread and will start an additional thread when it has determined that a particular thread's image retrieval/generation time has exceeded the user settable ThreadStartThreshold property value.

By default, the value of this property is 3000 milliseconds (3 seconds). Additionally, ThumbnailXpress will abandon a thread, and free up its resources, if its retrieval/generation time has exceeded the ThreadHungThreshold property value. By default, the value of this property is 9000 milliseconds (9 seconds). As noted, when needed, ThumbnailXpress will create additional threads but will not allow the count of concurrent background threads to exceed the value specified by the MaximumThreadCount property.

The default value for the MaximumThreadCount property is 2 times the calculated initial count of background threads. The allowable value range for this property is 1 thru 32. Too many background threads quickly degrade performance and a good rule of thumb for all these threading properties is unless there is good reason to change, leave them at the default values. For applications that don’t desire an image loading attempt be abandoned and want to allow, for example, the potential of very slow internet access for retrieving images, set the ThreadHungThreshold property to a higher value.

Multiple ThumbnailXpress Instances

It's important not to run one instance of the control from multiple application threads, instead, create a separate instance of the control for each application thread. For a well-presented primer on threading, see Microsoft's "What Every Dev Must Know About Multithreaded Apps" at the Visual Studio.NET Developer Center (08/05, msdn.microsoft.com/msdnmag/).

The Performance tab in the Microsoft Windows Task Manager dialog box (hold Ctrl, Alt and Delete) displays multiple CPU Usage History boxes for both logical and physical CPUs. The image below shows a single CPU with two logical CPU's.

See Also

ThreadStartThreshold Property
ThreadHungThreshold Property
MaximumThreadCount Property


Define End-User Interface

Accusoft.ThumbnailXpress4.ActiveX
Define End-User Interface
Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > How To > Define End-User Interface

Glossary Item Box

This section provides information about how to do the following:

  • Set Thumbnail Appearance
  • Set User Interaction Behavior


Set Thumbnail Appearance

Accusoft.ThumbnailXpress4.ActiveX
Set Thumbnail Appearance
See Also Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > How To > Define End-User Interface > Set Thumbnail Appearance

Glossary Item Box

The application controls the appearance of thumbnails in the display using properties in ThumbnailXpress™.

ThumbnailXpress Control Window Appearance

The appearance of the ThumbnailXpress control window is controlled as follows:

  • The background color for the control (BackColor)
  • The foreground color for the control (ForeColor)
  • The style of the border of the control (BorderStyle)
  • The margins of the control (BottomMargin, TopMargin, RightMargin, LeftMargin)
  • Whether the scrollbar is visible (ShowScrollbar)
  • The scrollbar direction (ScrollDirection)

Thumbnail Cell Appearance

The appearance of each individual thumbnail is defined using the "Cell" properties. The following can be specified:

  • The thumbnail border color and width (CellBorderColor, CellBorderWidth)
  • The dimensions of each thumbnail (CellHeight, CellWidth)
  • The spacing between each thumbnail (CellHorizontalSpacing, CellVerticalSpacing)
  • The color of the fill between thumbnails (CellSpacingColor)
  • The background color of selected thumbnails (SelectBackColor)
  • Whether a placeholder image is drawn while waiting for the thumbnail to be generated (ShowImagePlaceholders)

Thumbnail Descriptor Appearance

The appearance of each thumbnail's descriptor is specified using the "Descriptor" properties:

  • The alignment of the descriptor (DescriptorHorizontalAlignment, DescriptorVerticalAlignment)
  • The background color of the text in the descriptor (TextBackColor)
  • The font used for the text (Font)
  • The format of the descriptor (DescriptorDisplayMethod)

Set Icon Display Behavior

ThumbnailXpress provides the application with the option to display a pre-image generation "placeholder" icon while the image is being loaded and the thumbnail generated. When ShowImagePlaceholders is set to true, a placeholder image is drawn while waiting for the thumbnail to be generated and a cancel icon is displayed if the generation is cancelled.

- The thumbnail image is being generated. Once generated, this icon is replaced with the thumbnail image.

- The thumbnail image loading was cancelled.

The application can also specify the desired action to take when an error occurs during image loading or thumbnail generation. ThumbnailXpress can either display an error icon to indicate that the thumbnail did not load, or simply abort the loading process without displaying any icon in the control window. When ErrorAction is set to UseErrorIcon, the following icons are displayed, depending on the error encountered:

- The thumbnail image was not loaded, due to an error.

- The thumbnail image was not loaded, because the required software is not licensed by the application.

If the image file type is not supported by ThumbnailXpress, then the icon that is associated with the file in Windows Explorer will be displayed.

See Also

ThumbnailXpress Object


Set User Interaction Behavior

Accusoft.ThumbnailXpress4.ActiveX
Set User Interaction Behavior
See Also Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > How To > Define End-User Interface > Set User Interaction Behavior

Glossary Item Box

The application end-user can navigate, select, and move thumbnails within the ThumbnailXpress™ control, between multiple ThumbnailXpress controls, and between multiple applications. The application establishes how the user will interact with the control, by setting the following ThumbnailXpress properties:

Enable User Interaction

ThumbnailXpress v4 enables end-user navigation of thumbnails via user-generated events. To enable the ThumbnailXpress control to handle user-generated events, set the Enabled property.

Set Selection Behavior

The SelectionMode property specifies the behavior that is desired when an end-user selects a thumbnail.

Set Drag and Drop Behavior

To enable the end-user to drag and drop thumbnails within the ThumbnailXpress component, set IntraComponentThumbnailDragDropEnabled.

To enable the end-user to drag and drop thumbnails between multiple ThumbnailXpress controls, set InterComponentThumbnailDragDropEnabled.

To enable the end-user to drag thumbnails from the ThumbnailXpress component to another application, set EnableAsDragSourceForExternalDragDrop.

To enable the end-user to drag thumbnails from other applications into the ThumbnailXpress component, set EnableAsDropTargetForExternalDragDrop.

The Shift key must be held down during a drag-and-drop operation to move multiple selected thumbnail items.

Set Directory Drill Down Behavior

If DblClickDirectoryDrillDown is enabled, then when the end-user double clicks on a folder icon in the ThumbnailXpress component, the thumbnails of images within the directory will be displayed. This enables the end user to navigate through folder structures to locate thumbnails of interest.

See Also

Enabled Property
SelectionMode Property
InterComponentThumbnailDragDropEnabled Property
IntraComponentThumbnailDragDropEnabled Property
EnableAsDragSourceForExternalDragDrop Property
EnableAsDropTargetForExternalDragDrop Property
DblClickDirectoryDrillDown Property


Render Thumbnails with Annotations

Accusoft.ThumbnailXpress4.ActiveX
Render Thumbnails with Annotations
Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > How To > Render Thumbnails with Annotations

Glossary Item Box

You can easily render associated annotation data for your thumbnails by simply connecting ThumbnailXpress to an instance of NotateXpress. If an image has annotation data (such as text, lines, shapes, etc.), ThumbnailXpress will call on NotateXpress to include the annotations in the thumbnail rendering.

Connecting ThumbnailXpress to NotateXpress

The first step in rendering annotations in your thumbnails is to connect your instance of ThumbnailXpress to an instance of NotateXpress. You do this by passing the NotateXpress.InstanceHandle property to the ThumbnailXpress.NotateXpressInstance property.

For example, if you had an instance of ThumbnailXpress named thumbnailXpress1 and an instance of NotateXpress named notateXpress1, you would do this:

VB Example Copy Code
thumbnailXpress1.NotateXpressInstance = notateXpress1.InstanceHandle

If you don't do anything else, ThumbnailXpress will automatically render internal image annotation data that NotateXpress supports (NotateXpress, Imaging for Windows, and XFDF formats).

If, however, you need to render annotations stored in external files, you'll need to teach ThumbnailXpress how to find the data using annotation search rules.

Annotation Search Rules

Instead of telling ThumbnailXpress where to find annotation data for each individual image it needs to thumbnail, ThumbnailXpress allows you to give it a list of rules that define where it should search for annotation data. This special annotation rules list is modified via calls to the ThumbnailXpress.SetAnnotationSearchOrderSize and ThumbnailXpress.SetAnnotationSearchOrder methods.

As an image is being thumbnailed, ThumbnailXpress will iterate through its rules list to find associated annotation data. The first rule that succeeds will be used as the source of annotation data for that particular image (if no rule succeeds, then ThumbnailXpress concludes that the image does not have associated annotations and renders a thumbnail without any associated annotations). The entire process repeats when ThumbnailXpress moves on to thumbnail the next image--the search for annotations starts over, and the first rule on the list that returns annotation data "wins."

By default, any new instance of ThumbnailXpress will have pre-loaded this list with three rules:

  1. If the image being thumbnailed contains internal Imaging for Windows (WANG) annotation data, use that annotation data.
  2. If the image being thumbnailed contains internal NotateXpress annotation data, use that annotation data.
  3. If the image being thumbnailed contains internal XFDF (PDF) annotation data, use that annotation data.

This allows you to render internal annotations by simply connecting ThumbnailXpress to NotateXpress.

But if you were to set up the rules list manually yourself, here's how you would do it:

VB Example Copy Code
'# Set the search order rule list size appropriately
thumbnailXpress1.SetAnnotationSearchOrderSize 3

'# Add the three internal search rules to the list

'For these calls, only the first and second parameters are used,
'which are simply the index in the list and the annotation type.
thumbnailXpress1.SetAnnotationSearchOrder 0, ANNOTATION_TYPE_I4W, "", "", False 'Imaging for Windows (WANG), which is an internal type
thumbnailXpress1.SetAnnotationSearchOrder 1, ANNOTATION_TYPE_INTERNAL_NXP, "", "", False 'Internal NXP
thumbnailXpress1.SetAnnotationSearchOrder 2, ANNOTATION_TYPE_INTERNAL_XFDF, "", "", False 'Internal XFDF

Or, if you know you only internal need annotation data of a particular type (let's say PDF), you could redefine the search rules to only look for this particular type of annotation data:

VB Example Copy Code
'# Set the search order rule list size appropriately
thumbnailXpress1.SetAnnotationSearchOrderSize 1

thumbnailXpress1.SetAnnotationSearchOrder 0, ANNOTATION_TYPE_INTERNAL_XFDF, "", "", False 'Internal XFDF

Setting Up ThumbnailXpress to Render Annotations Stored in External Files

Where the annotation search rules really become important is when your image annotation data is stored externally to the image file. In this case, you must provide a custom set of annotation search rules to ThumbnailXpress in order to teach it how to find your external annotation data.

Before explaining how you do this, it's important to understand that ThumbnailXpress does impose a few requirements on your annotation files:

  1. An external annotation file must be located in the same directory as its associated image
  2. An external annotation filename must be named similarly to its associated image (the extension may be different, or it may contain an additional name prefix or suffix, but nothing more)
  3. An external annotation file must contain annotation data of one of the following types:
    • NotateXpress
    • NotateXpress XML
    • XFDF
    • TMS Sequoia

With that in mind, you define annotation search rules by resizing the rules list (with a call to SetAnnotationSearchOrderSize) and then making calls to SetAnnotationSearchOrder. Each call to SetAnnotationSearchOrder defines a particular search rule by specifying the annotation type, whether the annotation file is named with a prefix or suffix, and whether the annotation file does or does not include the extension of its associated image file. You can consult the API documentation for the details, but a few examples should illustrate how this works.

Example 1 - Using external annotation files using a .nxp extension

Imagine you have a variety of JPEG files with associated NotateXpress annotation data stored in a file of the same name except the ".jpg" extension has been replaced with ".nxp", like so:

  • Form1.jpg
  • Form1.nxp
  • Form2.jpg
  • Form2.nxp
  • Form3.jpg
  • Form3.nxp

You can "teach" ThumbnailXpress to use the Form1.nxp annotation data with the Form1.jpg file, the Form2.nxp annotation data with the Form2.jpg file, etc., by setting up the following annotation search rule:

VB Example Copy Code
'Expand the current size of the search rules list by 1
Dim currentSize As Long
currentSize = thumbnailXpress1.GetAnnotationSearchOrderSize
thumbnailXpress1.SetAnnotationSearchOrderSize currentSize + 1

'Add an additional search rule for external NXP annotations
'Param 1 (3): Set the last item in the list
'Param 2 (ANNOTATION_TYPE_NXP): Setup the rule to search for external NotateXpress annotations
'Param 3 (""): No prefix is added to the annotation filename
'Param 4 (".nxp): The Annotation filename ends with ".nxp"
'Param 5 (False): But the annotation filename does not include the original ".jpg" extension of the image filename
thumbnailXpress1.SetAnnotationSearchOrder 3, ANNOTATION_TYPE_NXP, "", ".nxp", False

With one line of code, you have "taught" ThumbnailXpress where it should look for external annotation data. As long as the .nxp files are present, they will be used to render the annotations.

Example 2 - Using only external annotations (ignoring internal annotations)

In the example above, we added a rule that allowed ThumbnailXpress to use annotation data stored in external .nxp files.

Now imagine that our directory contains the following files:

  • Form1.tiff - an image with internal annotations
  • Form1.nxp - a completely different set of annotations in an external file
  • Form2.jpg
  • Form2.nxp

In this case, we have a TIFF file with its own internal annotations, as well as a similarly-named external annotation file. The question is, which one will ThumbnailXpress use for its annotation data?

Well, since any new instance of ThumbnailXpress will automatically add internal annotation search rules to the search list by default, if we only add an external annotation rule to the list, then we have essentially told ThumbnailXpress: "I'd like you to look for annotations in this external file, but only if you don't find any internal annotations." So, in the example above, when ThumbnailXpress is rendering Form1.tiff, it will find its internal annotation data and use it; the external annotation data in Form1.nxp will not be used.

If what you really want is for ThumbnailXpress to ignore internal annotation data and always use external annotations, you should resize the search rules list and define only the rules you want:

VB Example Copy Code
    'Set the search rules list size to the number of rules we want to define
    thumbnailXpress1.SetAnnotationSearchOrderSize totalNumberOfRules

    'Add the rules we care about
    thumbnailXpress1.SetAnnotationSearchOrder 3, ANNOTATION_TYPE_NXP, "", ".nxp", False
    ...

Example 3 - A variety of annotations

Imagine you have a variety of image and annotation files, like so:

  • building.jpg
  • building.jpg.xml - external NotateXpress XML annotations for Form2.jpg
  • house.png
  • xfdf-house.png - external XFDF annotations for house.png
  • logo.gif
  • logo.annotations - external NotateXpress annotations for logo.gif
  • Form.tiff - an image with internal NXP annotations which we want
  • WangAnnotations.tiff - a document with internal Imaging for Windows annotations
  • Example.pdf - a document with internal XFDF annotations which we want

And let's also imagine that you do not want internal Imaging for Windows annotations to ever be rendered.

In this case, here is one way you could set up the ThumbnailXpress annotation search rules:

VB Example Copy Code
'Set the search rules list size to the number of rules we want to define
thumbnailXpress1.SetAnnotationSearchOrderSize 5

'# Allow internal NXP
'Param 1 (0): Set the first item in the list
'Param 2 (ANNOTATION_TYPE_INTERNAL_NXP): Setup the rule to search for internal NXP annotations
'Params 3-5 are ignored since they are only relevant for external annotations
thumbnailXpress1.SetAnnotationSearchOrder 0, ANNOTATION_TYPE_INTERNAL_NXP, "", "", False

'# Allow internal XFDF
'Param 1 (1): Set the second item in the list
'Param 2 (ANNOTATION_TYPE_INTERNAL_XFDF): Setup the rule to search for internal XFDF annotations
'Params 3-5 are ignored since they are only relevant for external annotations
thumbnailXpress1.SetAnnotationSearchOrder 1, ANNOTATION_TYPE_INTERNAL_XFDF, "", "", False

'# .xml for NXP XML annotation files
'Param 1 (2): Set the third item in the list
'Param 2 (ANNOTATION_TYPE_XML): Setup the rule to search for external NotateXpress XML annotations
'Param 3 (""): No prefix is added to the annotation filename
'Param 4 (".xml"): The Annotation filename ends with ".xml"
'Param 5 (True): And the annotation filename includes the original extension of the image filename
thumbnailXpress1.SetAnnotationSearchOrder 2, ANNOTATION_TYPE_XML, "", ".xml", True

'# "xfdf-" prefix for XFDF annotation files
'Param 1 (3): Set the fourth item in the list
'Param 2 (ANNOTATION_TYPE_XFDF): Setup the rule to search for external XFDF annotations
'Param 3 ("xfdf-"): The annotation filename begins with an "xfdf-" prefix
'Param 4 (""): No suffix is part of the annotation filename
'Param 5 (True): The annotation filename includes the original extension of the image filename
thumbnailXpress1.SetAnnotationSearchOrder 3, ANNOTATION_TYPE_XFDF, "xfdf-", "", True

'# .annotations for NXP annotation files
'Param 1 (4): Set the fifth item in the list
'Param 2 (ANNOTATION_TYPE_NXP): Setup the rule to search for external NotateXpress annotations
'Param 3 (""): No prefix is added to the annotation filename
'Param 4 (".annotations"): The Annotation filename ends with ".annotations"
'Param 5 (False): The annotation filename does not include the original extension of the image filename
thumbnailXpress1.SetAnnotationSearchOrder 4, ANNOTATION_TYPE_NXP, "", ".annotations", False

This effectively amounts to saying to ThumbnailXpress:

  • Don't use your default search rules which include all internal annotation types
  • Use these instead:
    1. Try to use internal NXP annotations
    2. If you can't do that, try to use internal XFDF annotations
    3. If you can't do that, try to use external NotateXpress XML annotations stored in a file of the same name with an additional ".xml" extension
    4. If you can't do that, try to use external XFDF annotations stored in a file of the same name with an additional "xfdf-" prefix
    5. If you can't do that, try to use external NotateXpress annotations stored in a file of the same name but whose extension has been changed to ".annotations"

Summary

If you only need ThumbnailXpress to render annotation data embedded in the image file itself, you simply need to connect your instance of ThumbnailXpress to an instance of NotateXpress. But if you want more control over where ThumbnailXpress should look to find associated annotation data for an image (particularly if you are using external annotation data), you'll need to "teach" ThumbnailXpress where it should search for associated annotation data by customizing the annotation search rules.


Load & Display Thumbnails

Accusoft.ThumbnailXpress4.ActiveX
Load & Display Thumbnails
Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > How To > Load & Display Thumbnails

Glossary Item Box

This section provides information about how to do the following:

  • Specify Loading & Rendering Options
  • Generate Thumbnails from File
  • Generate Thumbnails from Directory
  • Generate Thumbnails from PDF File
  • Generate Thumbnails from Memory
  • Get Thumbnail Information
  • Display Thumbnails
  • Delete Thumbnails


Specify Loading & Rendering Options

Accusoft.ThumbnailXpress4.ActiveX
Specify Loading & Rendering Options
See Also Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > How To > Load & Display Thumbnails > Specify Loading & Rendering Options

Glossary Item Box

Before loading any images, specify desired loading and rendering behavior for thumbnails as follows:

  • Set PreserveBlackEnabled, if desired, to darken lines in the thumbnail image. This is useful to improve readability/recognizability of the thumbnail image to the end-user.
  • Set CameraRawEnabled, if desired, to specify whether the control will examine the image on loading to determine if the image data is in a camera raw format, and to identify that format. To optimize performance, CameraRawEnabled should be set to false when not needed.

    CameraRawEnabled is only applied when the images are loaded from a local file.

See Also

PreserveBlackEnabled Property
CameraRawEnabled Property


Generate Thumbnails from File

Accusoft.ThumbnailXpress4.ActiveX
Generate Thumbnails from File
See Also Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > How To > Load & Display Thumbnails > Generate Thumbnails from File

Glossary Item Box

ThumbnailXpress™ provides the user with the ability to generate thumbnails from one or more pages of a local or remote file.

Generate Thumbnails from a Multi-page File

Call AddFileItems to load images and generate thumbnails from all pages of a multipage file. When AddAllPages is set to true, all pages in the multipage file are loaded. When AddAllPages is set to false, only the first page is loaded. The thumbnail icon will show a "+", to indicate that the thumbnail is the first page in a multi-page file.

When AddFileItems is called to generate thumbnails, descriptors and user tags are not assigned. These can be specified after the thumbnail items are added to the list, by calling SetItemDescriptor and SetItemFilename.

Generate One Thumbnail from a Specified Page in a File

Call InsertItem to load an image from a specified page in a specified file, and generate the thumbnail from the image. The application can specify the location in the thumbnail list to insert the thumbnail, the descriptor to be displayed with the thumbnail, and a user tag to record application-specific information about the thumbnail.

If the file has a known status and type, the application can specify these (for example, specify ThumbnailStatus as validated and ThumbnailType as PDF). This optimizes the performance in loading the file, as ThumbnailXpress does not have to validate the file type. If the Verify parameter is set to true, ThumbnailXpress v4 will check to make sure that the specified local file has a valid file name (e.g. it exists and can be understood by the control).

If the file name indicates a remote path, the Verify parameter is ignored.

Cancel Thumbnail Generation

Calling Cancel will cancel all pending thumbnail generation requests. To restore a generation request that had been canceled, call ResetCanceledItem.

See Also

AddFileItems Method
SetItemDescriptor Method
SetItemFilename Method
InsertItem Method
Cancel Method
ResetCanceledItem Method


Generate Thumbnails from Directory

Accusoft.ThumbnailXpress4.ActiveX
Generate Thumbnails from Directory
Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > How To > Load & Display Thumbnails > Generate Thumbnails from Directory

Glossary Item Box

ThumbnailXpress™ v4 enables loading of images from a directory, based on specified filter criteria. One or more filters can be defined, enabling customized search and display of thumbnail images. ThumbnailXpress keeps a list of filters that have been defined, and applies all enabled filters when loading images from a directory.

Add or Delete a Filter

To add a filter, call AddFilterItem, specifying a name for the filter. An index is returned, uniquely identifying the filter in the list. The filter's name can be modified at any time by calling SetFilterName. The filter's index can be found at any time by calling FindFilterItemIndex and specifying the filter name. To delete all filters from the ThumbnailXpress control, call ClearFilters.

Assign Filter Criteria

To assign search criteria to a filter, first call SetFilterType to specify the type of filter being defined. Filter types include:

  • Filtering based on file name
  • Filtering based on file attributes (e.g. include hidden files, include parent directory, include subdirectories)
  • Filtering based on File creation date
  • Filtering based on File modification date
  • Filtering based on File size
  • Filtering to include only files that are supported by ThumbnailXpress

Based on the filter type, additional filter criteria will be applied.

If filtering based on file name or directory name:

  • Call SetFilterCaseSensitive to indicate whether the search should consider the font case.
  • Call SetFilterFilenamePattern to specify the name or wildcard expressions to search for. This includes specifying filename extensions, such as .jpg or .tiff.
  • Call SetFilterMatchAppliesToDirectory to specify whether the FilterFilenamePattern should apply to directory names as well.

If filtering based on file attributes:

  • Call SetFilterIncludeHidden to specify whether hidden files should be included in the search.
  • Call SetFilterIncludeParentDirectory to specify whether a file's parent directory should be included in the search.
  • Call SetFilterIncludeSubDirectory to specify whether sub-directories should be included in the search.

If filtering based on creation or modification date:

  • Call SetFilterComparison, to specify the comparison criteria for the filter (e.g. less than, greater than, equal).
  • Call SetFilterDate to specify the date to compare against.

If filtering based on file size:

  • Call SetFilterComparison, to specify the comparison criteria for the filter (e.g. less than, greater than, equal).
  • Call SetFilterSize to indicate the maximum size files to include.

Generate Thumbnails from Files Within a Directory

Filters are applied when loading images from a directory into the ThumbnailXpress control. All enabled filters will be applied to determine which images to load. Call SetFilterEnabled to indicate the filters to use. If no filters are enabled, then all folders and files will be loaded.

Call AddDirectoryItems to load images and generate thumbnails from all files in the specified directory. All enabled filters are applied, and only items that meet all filter criteria are loaded. A thumbnail image is then generated for each loaded image, and cached. When the control paints, the thumbnail images are displayed.

If the directory contains multi-page files, only the first page of the file is loaded. The thumbnail icon will show a "+" to indicate that the thumbnail is the first page in a multi-page file. Thumbnails of additional pages within the file can be added by calling AddFileItems.


Generate Thumbnails from PDF File

Accusoft.ThumbnailXpress4.ActiveX
Generate Thumbnails from PDF File
See Also Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > How To > Load & Display Thumbnails > Generate Thumbnails from PDF File

Glossary Item Box

When PDF Xpress™ is installed, ThumbnailXpress™ can generate thumbnails from PDF files, locally stored in a file or directory. ThumbnailXpress will work seamlessly with PDF Xpress v4 after setting the UsePDFXpress4 property to true. If the property is set to false, thumbnails will not be generated from PDF files.

PDF files must be located in a local file or directory to enable thumbnail generation.

See Also

UsePDFXpress3 Property


Generate Thumbnails from Memory
See Also Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > How To > Load & Display Thumbnails > Generate Thumbnails from Memory

Glossary Item Box

ThumbnailXpress™ v4 enables the application to generate thumbnails of images stored in a memory buffer or a user supplied image memory 'BLOB'.

Generate Thumbnails from Memory

Call InsertItemFromMemory to load an image from an image memory buffer, and generate the thumbnail from the image. The LoadFromMemory event may optionally be used to supply the memory buffer. The application can specify the location in the thumbnail list to insert the thumbnail, the descriptor to be displayed with the thumbnail, and a user tag to record application-specific information about the thumbnail. If the thumbnail image data has a known status and type, the application can specify these (for example, specify ThumbnailStatus as validated and ThumbnailType as PDF). This optimizes the performance in loading the file, as ThumbnailXpress does not have to validate the file type.

Generate Thumbnails from BLOB

Call InsertItemFromBlob to load an image from a user supplied image memory 'blob'. The LoadFromMemory event may optionally be used to supply the memory 'blob'. The application can specify the location in the thumbnail list to insert the thumbnail, the descriptor to be displayed with the thumbnail, and a user tag to record application-specific information about the thumbnail. If the thumbnail image data has a known status and type, the application can specify these (for example, specify ThumbnailStatus as validated and ThumbnailType as PDF). This optimizes the performance in loading the file, as ThumbnailXpress does not have to validate the file type.

See Also

InsertItemFromMemory Method
InsertItemFromBlob Method
LoadFromMemory Event


Get Thumbnail Information

Accusoft.ThumbnailXpress4.ActiveX
Get Thumbnail Information
See Also Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > How To > Load & Display Thumbnails > Get Thumbnail Information

Glossary Item Box

All thumbnail images are generated with unique IDs and are cached for rapid display access purposes. Use the "GetItem" methods to acquire information about a thumbnail, including the name of the file from which the thumbnail was generated (GetItemFilename) and the page within the file that the thumbnail represents (GetItemPage).

The thumbnail image can be acquired as an HBitmap (GetItemHBitmap), HDib (GetItemHDib), or Picture object (GetItemPicture).

Information about the thumbnail will not be available until generation of the thumbnail is complete. Use the ItemComplete event to ensure that generation is complete prior to checking thumbnail information.

See Also

GetItemFilename Method
GetItemPage Method
GetItemHBitmap Method
GetItemHDib Method
GetItemPicture Method
ItemComplete Event


Display Thumbnails

Accusoft.ThumbnailXpress4.ActiveX
Display Thumbnails
See Also Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > How To > Load & Display Thumbnails > Display Thumbnails

Glossary Item Box

The control will update on each paint, to reflect the current state of the thumbnails. When adding multiple thumbnails, it may be beneficial to disable painting to reduce redraw flicker. To disable paint, call BeginUpdate prior to loading any images. Then, load images and generate thumbnails. You can query the status of the thumbnail by calling GetItemStatus. When all thumbnails have been generated and are ready for display, call EndUpdate. Painting will resume, displaying all the generated thumbnails (or error icons, if generation failed).

See Also

BeginUpdate Method
GetItemStatus Method
EndUpdate Method


Delete Thumbnails

Accusoft.ThumbnailXpress4.ActiveX
Delete Thumbnails
See Also Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > How To > Load & Display Thumbnails > Delete Thumbnails

Glossary Item Box

A thumbnail can be removed from the thumbnail list by calling DeleteItem. Call DeleteItems to remove all thumbnails from the list. The removed thumbnails will not be displayed on the next paint.

See Also

DeleteItem Method
DeleteItems Method


Modify Thumbnails

Accusoft.ThumbnailXpress4.ActiveX
Modify Thumbnails
See Also Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > How To > Modify Thumbnails

Glossary Item Box

Modify Thumbnail Properties

A thumbnail's properties can be modified, to include a different item descriptor (SetItemDescriptor) or user information (SetItemUserTag).

Modify the Thumbnail Image

If the thumbnail image was loaded from file, the thumbnail image can be replaced by a different page in the file using the SetItemPage method. This method generates the thumbnail from the selected page in the file, then replaces the existing thumbnail with the new image.

If the thumbnail image was loaded from file, the thumbnail image can be replaced by a page in a different file using the SetItemFilename method. This method generates the thumbnail from the new file (page number remains unchanged), then replaces the existing thumbnail with the new image.

If the thumbnail represents a page in a CAD file, the thumbnail image can be replaced by a different layout in the file using the SetItemCadLayoutNumber method.

See Also

SetItemDescriptor Method
SetItemUserTag Method
SetItemPage Method
SetItemFilename Method
SetItemCadLayoutNumber Method


Navigate Thumbnails

Accusoft.ThumbnailXpress4.ActiveX
Navigate Thumbnails
Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > How To > Navigate Thumbnails

Glossary Item Box

This section provides information about how to do the following:

  • Manage End User Navigation
  • Navigate Programmatically


Manage End User Navigation

Accusoft.ThumbnailXpress4.ActiveX
Manage End User Navigation
See Also Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > How To > Navigate Thumbnails > Manage End User Navigation

Glossary Item Box

ThumbnailXpress™ v4 enables end-user navigation of thumbnails via standard Windows control events within the ThumbnailXpress object. To specify how the thumbnailXpress control interprets end-user actions, be sure to set user interaction behavior.

Verify that the Enabled property has been set, to enable the ThumbnailXpress control to handle user-generated events.

End-User Scrolling

The application end-user can scroll through thumbnails in the thumbnail control window. Scrolling behavior is defined by setting user interaction behavior. Alternatively, the end-user may use the arrow, page up/down, home, and end keys to navigate thumbnails within the control window.

End-User Selecting

The SelectionMode property specifies the behavior that is desired when an end-user selects a thumbnail. The application end-user selects thumbnail items using a combination of mouse click with control and shift keys.

End-User Drag and Drop

The application end-user can drag and drop thumbnails within the ThumbnailXpress control, between multiple ThumbnailXpress controls, and between the ThumbnailXpress control and other applications, by holding the mouse down over a thumbnail, moving the mouse, then releasing the mouse in the desired location. Set the user interaction behavior to specify desired support for these features.

End-User Directory Drill Down

If DblClickDirectoryDrillDown is enabled within the ThumbnailXpress object, then when the end-user double clicks on a folder icon in the ThumbnailXpress component, the thumbnails of images within the directory will be displayed. This enables the end user to navigate through folder structures to locate thumbnails of interest.

See Also

Enabled Property
SelectionMode Property
DblClickDirectoryDrillDown Property


Navigate Programmatically

Accusoft.ThumbnailXpress4.ActiveX
Navigate Programmatically
See Also Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > How To > Navigate Thumbnails > Navigate Programmatically

Glossary Item Box

Scrolling

Scrolling the thumbnail control can be controlled programmatically by calling the ScrollItems method to specify the scrolling action and magnitude. The view changes to reflect the requested scrolling. Alternatively, call EnsureVisible to programmatically scroll the thumbnail control until a specified thumbnail is in view.

Selecting

Individual thumbnails can be selected programmatically by calling the SelectItem method and specifying the thumbnail to select. The SelectedItemCount reflects the number of thumbnails that have been selected, both programmatically as well as by end-user. The ClearSelection method restores all thumbnails to an unselected state. DeleteSelectedItem is called to delete a selected item.

See Also

ScrollItems Method
EnsureVisible Method
SelectItem Method
SelectedItemCount Property
ClearSelection Method
DeleteSelectedItem Method


Save Thumbnails

Accusoft.ThumbnailXpress4.ActiveX
Save Thumbnails
Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > How To > Save Thumbnails

Glossary Item Box

ThumbnailXpress™ has no saving capabilities; only ImagXpress® can be used to save thumbnail images.


Print Thumbnails

Accusoft.ThumbnailXpress4.ActiveX
Print Thumbnails
Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > How To > Print Thumbnails

Glossary Item Box

ThumbnailXpress™ has no printing capabilities; only ImagXpress® or PrintPRO™ can be used to print thumbnail images.


Debug

Accusoft.ThumbnailXpress4.ActiveX
Debug
See Also Send Feedback
ThumbnailXpress 4 for ActiveX - User Guide > How To > Debug

Glossary Item Box

Generate a Debug Log

To generate a debug log file, set Debug to true. The log file is kept at the location specified by DebugLogFile. Set the DebugErrorLevel to Development or Detailed to indicate the level of detail to be logged.

Errors

The following errors can be raised or returned by ThumbnailXpress™ properties and methods:

Error Code | Description
16000 | No Error
16001 | Unknown Error
16002 | Invalid parameter used
16003 | The item is out of range
16004 | System error
16005 | File error
16006 | Internal error
16007 | Unsupported function
16008 | Imaging error
16009 | PDF error
16010 | Illegal Operation
16011 | License not set
16012 | Invalid PDF Password
16013 | Damaged PDF
16014 | Invalid External Annotation Search Rule

See Also

Getting Support
ThumbnailXpress Object


ThumbnailXpress 4 for ActiveX - API Reference

Accusoft.ThumbnailXpress4.ActiveX
ThumbnailXpress 4 for ActiveX - API Reference
Send Feedback

Glossary Item Box

This API Reference provides detailed information about all ThumbnailXpress public API members.


Project Overview

Accusoft ThumbnailXpress 4
Project Overview
Send Feedback

Glossary Item Box

Description

Accusoft ThumbnailXpress 4

Classes

Class Module | Description
ThumbnailXpress | Accusoft ThumbnailXpress Control 4.0

Public Enumerations

Enumeration | Description
TN_AnnotationType | Specifies the Annotation type used.
TN_BorderStyle | Option values which determine the border style for the perimeter of the control.
TN_DebugErrorLevel | Option values which determine the amount of logging detail to be sent to the log file.
TN_DescriptorFormat | Option values which determine the source of descriptor text.
TN_DescriptorHorizontalAlignment | Option values which determine the horizontal alignment of the descriptor text display.
TN_DescriptorVerticalAlignment | Option values which determine the vertical alignment of the descriptor text display.
TN_ErrorAction | Option values which determine the action taken when processing errors are encountered.
TN_EvaluationMode | Option values which designate evaluation modes available for use.
TN_Event | Option values which designate ThumbnailXpress Events.
TN_FilterComparison | Option values which specifiy the desired comparison outcome for a file date or size filter.
TN_FilterType | Option values which designate the Thumbnail image file property that is to be compared or matched by a filter.
TN_ScrollDirection | Option values which designate the direction thumbnails scroll in the control.
TN_ScrollItemsType | Option values which specify the incremental amount or if a positional programmatic scroll operation is desired.
TN_SelectionMode | Option values which designate the selection mode for the control.
TN_ThumbnailStatus | Item not validated at any level. Option values which designate the status of a thumbnail item.
TN_ThumbnailType | Option values which designate the type of thumbnail (image, pdf, etc.) for a thumbnail item.


ThumbnailXpress Object

ThumbnailXpress Object
See Also Members Send Feedback
AccusoftThumbnailXpress4 ActiveX DLL : ThumbnailXpress Object

Glossary Item Box

Description

Accusoft ThumbnailXpress Control 4.0

Object Model

ThumbnailXpress Object

See Also

ThumbnailXpress Members


ThumbnailXpress Object Members

ThumbnailXpress Object Members
See Also Overview Send Feedback
AccusoftThumbnailXpress4 ActiveX DLL : ThumbnailXpress Object

Glossary Item Box

Public Methods

Public Method AboutBox | Displays a dialog box with the Thumbnail version and copyright information.
Public Method AddDirectoryItems | Adds the items in the specified directory to the list of thumbnail items.
Public Method AddFileItems | Adds the items in the specified file to the list of thumbnail items.
Public Method AddFilterItem | Adds a new filter to the end of the filter list.
Public Method BeginUpdate | Disables control repainting to eliminate flicker when making multiple changes to the list of thumbnail items.
Public Method Cancel | Cancels all pending thumbnail item generation requests.
Public Method ClearFilters | Removes all existing filters from the list.
Public Method ClearSelection | Clears the current selection.
Public Method CreateCtlWindow | Provides programmatic creation of a ThumbnailXpress control window.
Public Method DeleteItem | Deletes the specified item from the list of thumbnail items.
Public Method DeleteItems | Deletes all items from the list of thumbnail items.
Public Method DeleteSelectedItem | Deletes the specified selected item from the list of thumbnail items.
Public Method DestroyCtlWindow | Provides programmatic destruction of a ThumbnailXpress control window.
Public Method EmptyCache | Clears all items from the memory cache.
Public Method EnableEvent | Enables or disables the raising of individual thumbnail custom events.
Public Method EndUpdate | Enables the control repainting after calling the BeginUpdate method.
Public Method EnsureVisible | Scrolls the list of thumbnail items if necessary to ensure the specified item is visible.
Public Method FindFilterItemIndex | Finds the list index of a filter specified by the filter name.
Public Method GetAnnotationSearchOrder | Gets the search order for ThumbnailXpress to use when associating external annotation files with the item being thumbnailed.
Public Method GetAnnotationSearchOrderSize | Gets the search order size.
Public Method GetDisplayRect | Gets the display rectangle of the control in pixels.
Public Method GetFilterCaseSensitive | Gets the filename matching case sensitivity enabled value for the specified filter.
Public Method GetFilterComparison | Gets the comparison criteria for the specified filter.
Public Method GetFilterDate | Gets the date criteria for the specified filter.
Public Method GetFilterEnabled | Gets the enabled status of the specified filter.
Public Method GetFilterFilenamePattern | Gets the filename matching pattern criteria for the specified filter.
Public Method GetFilterIncludeHidden | Gets the file attributes include hidden files enabled value for the specified filter.
Public Method GetFilterIncludeParentDirectory | Gets the file attributes include parent directory enabled value for the specified filter.
Public Method GetFilterIncludeSubDirectory | Gets the file attributes include sub directory enabled value for the specified filter.
Public Method GetFilterMatchAppliesToDirectory | Gets name pattern applies to directory enabled value for the specified filter.
Public Method GetFilterName | Gets the name for the filter at the specified filter index.
Public Method GetFilterSize | Gets the file size criteria for the specified filter.
Public Method GetFilterType | Gets the type for the specified filter.
Public Method GetIndexOfSelectedItem | Gets the index in the list of thumbnail items for the specified selected thumbnail item.
Public Method GetItemAnnotationsFilename | Gets the filename and path of the file used for the thumbnail annotations.
Public Method GetItemAnnotationType | Gets the annotation type if any annotations were used for this thumbnail.
Public Method GetItemCadLayoutCount | Gets the CAD layout count for the specified thumbnail item.
Public Method GetItemCadLayoutNumber | Gets the CAD layout number for the specified thumbnail item.
Public Method GetItemCellBackColor | Gets the Cell Back Color for the specified thumbnail item.
Public Method GetItemCellBorderColor | Gets the Cell Border Color for the specified thumbnail item.
Public Method GetItemDescriptor | Gets the descriptor for the specified thumbnail item.
Public Method GetItemErrorCode | Gets the error code for the specified thumbnail item.
Public Method GetItemErrorString | Gets the error string for the specified thumbnail item.
Public Method GetItemFilename | Gets the filename for the specified thumbnail item.
Public Method GetItemHasAnnotations | Gets if annotations of any type were discovered and used for this thumbnail.
Public Method GetItemHBitmap | Gets the HBITMAP handle for the specified thumbnail item image.
Public Method GetItemHDib | Gets the DIB handle for the specified thumbnail item image.
Public Method GetItemHDib64 | Gets the DIB handle for the specified thumbnail item image in a 64-bit environment.
Public Method GetItemIndexFromPoint | Gets the index for the thumbnail item at the specified point.
Public Method GetItemPage | Gets the page number for the specified thumbnail item.
Public Method GetItemPageCount | Gets the page count for the specified thumbnail item.
Public Method GetItemPDFPassword | Gets the PDF password for the specified thumbnail item
Public Method GetItemPDFRepair | Gets the PDF file repair for the specified thumbnail item.
Public Method GetItemPicture | Gets the Picture object for the specified thumbnail item image.
Public Method GetItemStatus | Gets the status for the specified thumbnail item.
Public Method GetItemType | Gets the type for the specified thumbnail item.
Public Method GetItemUserTag | Gets the variant user data associated with the specified thumbnail item.
Public Method InsertFilterItem | Inserts a new filter in the filter list at the specified index.
Public Method InsertItem | Inserts the specified item into the list of thumbnail items.
Public Method InsertItemFromBlob | Inserts an image into the list of thumbnail items by way of a user supplied image memory 'Blob'.
Public Method InsertItemFromMemory | Inserts an image into the list of thumbnail items by way of a user supplied image memory buffer.
Public Method MoveCtlWindow | Provides programmatic relocation or possible resizing of a ThumbnailXpress control.
Public Method Refresh | Refreshes the list of thumbnail items.
Public Method RemoveFilterItem | Removes the filter specified by the filter list name.
Public Method RemoveFilterItemByIndex | Removes the filter specified by the filter list index.
Public Method ResetCanceledItem | Resets canceled status for a single canceled item or for all canceled items, allowing them to be attempted to be re-generated.
Public Method ScrollItems | Provides programmatic scrolling of the thumbnail item list.
Public Method SelectItem | Selects (or deselects) the specified thumbnail item.
Public Method SetAnnotationSearchOrder | Sets the search order for ThumbnailXpress to use when associating external annotation files with the item being thumbnailed.
Public Method SetAnnotationSearchOrderSize | Sets the search order size.
Public Method SetFilterCaseSensitive | Sets the filename matching case sensitivity enabled value for the specified filter.
Public Method SetFilterComparison | Sets the comparison criteria for the specified filter.
Public Method SetFilterDate | Sets the date criteria for the specified filter.
Public Method SetFilterEnabled | Sets the enabled status of the specified filter.
Public Method SetFilterFilenamePattern | Sets the filename matching pattern criteria for the specified filter.
Public Method SetFilterIncludeHidden | Sets the file attributes include hidden files enabled value for the specified filter.
Public Method SetFilterIncludeParentDirectory | Sets the file attributes include parent directory enabled value for the specified filter.
Public Method SetFilterIncludeSubDirectory | Sets the file attributes include sub directory enabled value for the specified filter.
Public Method SetFilterMatchAppliesToDirectory | Sets name pattern applies to directory enabled value for the specified filter.
Public Method SetFilterName | Renames an existing filter.
Public Method SetFilterSize | Sets the file size criteria for the specified filter.
Public Method SetFilterType | Sets the type for the specified filter.
Public Method SetItemAnnotations | Sets the annotations for the specified thumbnail item.
Public Method SetItemCadLayoutNumber | Sets the CAD layout number for the specified thumbnail item.
Public Method SetItemCellBackColor | Sets the Cell Back Color for the specified thumbnail item.
Public Method SetItemCellBorderColor | Sets the Cell Border Color for the specified thumbnail item.
Public Method SetItemDescriptor | Set the descriptor text of the thumbnail item.
Public Method SetItemFilename | Sets the filename for the specified thumbnail item.
Public Method SetItemPage | Sets the page number for the specified thumbnail item.
Public Method SetItemPDFPassword | Sets the PDF password for the specified thumbnail item
Public Method SetItemPDFRepair | Sets the PDF file repair for the specified thumbnail item.
Public Method SetItemUserTag | Sets the variant user data associated with the specified thumbnail item.
Public Method SetIXOEMLicenseKey | Sets the ImagXpress runtime OEM license key.
Public Method SetIXSolutionKey | Sets the ImagXpress runtime license deployment solution key.
Public Method SetIXSolutionName | Sets the ImagXpress runtime license deployment solution name.
Public Method SetLoadFromMemoryEventItemImageBlob | Provides for supplying a Variant containing an image memory blob during an item LoadFromMemory event.
Public Method SetLoadFromMemoryEventItemImageBuffer | Provides for supplying a Variant containing an image memory buffer during an item LoadFromMemory event.
Public Method SetOEMLicenseKey | Sets the control runtime OEM license key.
Public Method SetPDFXLicenseCodes | Sets the PDFXpress license codes.
Public Method SetSolutionKey | Sets the control runtime license deployment solution key.
Public Method SetSolutionName | Sets the control runtime license deployment solution name.
Public Method ShowScrollBar | Shows or hides the scroll bar.

Public Properties

Public Property BackColor | Gets and sets the background color for the control.
Public Property BorderStyle | Gets or sets the border style.
Public Property BottomMargin | Gets or sets the bottom margin in pixels.
Public Property CacheMemoryLimit | Gets or sets access to the memory cache limit.
Public Property CameraRawEnabled | Gets or sets access to enabling or disabling CameraRaw image format support during thumbnail image generation.
Public Property CameraRawThumbnailEnabled | Returns/sets if the embedded thumbnail of the camera raw image is used or the full-size image.
Public Property CellBorderColor | Gets or sets access to the border color of the cells in the control.
Public Property CellBorderWidth | Gets or sets access to the width of the cells in the control.
Public Property CellHeight | Gets or sets access to the height of the cells in the control.
Public Property CellHorizontalSpacing | Gets or sets access to the horizontal spacing between cells.
Public Property CellSpacingColor | Gets or sets the cell spacing color.
Public Property CellVerticalSpacing | Gets or sets access to the vertical spacing between cells.
Public Property CellWidth | Gets or sets access to the width of the cells in the control.
Public Property CustomErrorIcon | Returns/sets the icon to use for errors instead of the stock error icon. ErrorAction must be set to 0 - use error icon.
Public Property CustomGeneratingIcon | Returns/sets the icon to use for the pre-image generation placeholder instead of the stock 'generating' icon. ShowImagePlaceHolders must be set to true.
Public Property DblClickDirectoryDrillDown | Gets or sets an indicator whether mouse double-clicks over directory folder icons should display the images in the clicked directory.
Public Property Debug | Gets or sets an indicator to write debug information into the DebugLogFile.
Public Property DebugErrorLevel | Gets or sets access to the level of detail written to the error log.
Public Property DebugLogFile | Gets or sets access to the log file location.
Public Property DescriptorDisplayMethod | Gets or sets access to the method allowing selection of the source of descriptor text content.
Public Property DescriptorHorizontalAlignment | Gets or sets the horizontal alignment of the descriptor text.
Public Property DescriptorVerticalAlignment | Gets or sets the vertical alignment of the descriptor text.
Public Property EnableAsDragSourceForExternalDragDrop | Gets or sets an indicator whether drag and drop source thumbnails is enabled on other applications.
Public Property EnableAsDropTargetForExternalDragDrop | Gets or sets an indicator whether drag and drop target is enabled for other applications to drag files onto those files as thumbnail images.
Public Property Enabled | Gets and sets a value that determines if ThumbnailXpress responds to user-generated events.
Public Property ErrorAction | Gets or sets the action to take on errors when adding thumbnail items.
Public Property ErrorCode | Gets the error code from the most recent call.
Public Property EvaluationMode | Gets or sets the type of evaluation mode.
Public Property Font | Gets or sets the font for the ThumbnailXpress control.
Public Property ForeColor | Gets or sets the foreground color for the ThumbnailXpress control Descriptor text.
Public Property FTPPassword | Gets or sets the FTP password that is used for accessing files on the Internet when a thumbnail item's Filename property is set to an ftp or http address.
Public Property FTPUserName | Gets or sets the FTP user name that is used for accessing files on the Internet when a thumbnail item's Filename property is set to an ftp or http address.
Public Property HWND | A stock, read-only property which is a handle to a window.
Public Property InterComponentThumbnailDragDropEnabled | Gets or sets an indicator whether inter-component thumbnail drag drop moved or copied items are enabled.
Public Property IntraComponentThumbnailDragDropEnabled | Gets or sets an indicator if intra-component thumbnail drag drop move operations are enabled.
Public Property ItemCount | Gets the number of thumbnail items from the thumbnail items list.
Public Property LeftMargin | Gets or sets the left margin in pixels.
Public Property MaximumThreadCount | Gets or sets the maximum thread count.
Public Property MaximumThumbnailBitDepth | Gets or sets the maximum thumbnail bit-depth.
Public Property NotateXpressInstance | The instance of NotateXpress, this should be set to the NotateXpress object's InstanceHandle property. Once set annotations can be drawn on thumbnails. Note: NotateXpress is a separate control.
Public Property PDFPassword | Gets and sets the password for PDF format files.
Public Property PDFRepair | Returns/sets the PDF file repair that is used for accessing single PDF files when a thumbnail item is a known PDF with errors.
Public Property PreserveBlackEnabled | Gets or sets whether preserve black is enabled.
Public Property ProxyServer | Gets or sets a proxy server name or IP address.
Public Property RaiseExceptions | The RaiseExceptions property controls how errors are reported to the application.
Public Property RightMargin | Gets or sets the right margin in pixels.
Public Property ScrollDirection | Gets or sets the scroll direction.
Public Property SelectBackColor | Gets or sets the cell background color used for selected thumbnail items.
Public Property SelectedItemCount | Gets the number of selected thumbnail items.
Public Property SelectionMode | Gets or sets the selection mode.
Public Property ShowImagePlaceholders | Gets or sets whether a placeholder image is drawn while waiting for the thumbnail to be generated.
Public Property TextBackColor | Gets or sets the descriptor text background color.
Public Property ThreadHungThreshold | Gets or sets the maximum amount of time (in milliseconds) a thread will spend generating an image representing a thumbnail item, before it should abandon the generation.
Public Property ThreadStartThreshold | Gets or sets the amount of time (in milliseconds) a thread will spend generating an image representing a thumbnail item, before it should start an additional thread generating images representing thumbnail items.
Public Property TopMargin | Gets or sets the top margin in pixels.
Public Property TopVisibleItem | Gets the thumbnail item which is visible in the top-left corner of the control window.
Public Property UsePDFXpress3 | This property has been deprecated and will be removed in the next version. Please use the UsePDFXpress4 Property instead.
Public Property UsePDFXpress4 | Returns/sets whether to use PDF Xpress™ v4.x
Public Property Version | Returns the version of the ThumbnailXpress control at run-time.
Public Property VisibleColumnCount | Gets the number of columns of cells that are viewable in the control window.
Public Property VisibleRowCount | Gets the number of rows of cells that are viewable in the control window.

Events

Public Event Click | Called when a left mouse button is pressed.
Public Event DoubleClick | Called when a left mouse button is double clicked.
Public Event Error | Called when an error occurs during generation or painting of a thumbnail item.
Public Event ItemComplete | Called when a thumbnail item's asynchronous image generation has been completed.
Public Event KeyDown | Called on a key down action.
Public Event KeyPress | Called on a key press action.
Public Event KeyUp | Called on a key up action.
Public Event LoadFromMemory | Called when loading from memory.
Public Event MouseDown | Called on a mouse down action.
Public Event MouseMove | Called on a mouse move action.
Public Event MouseUp | Called on a mouse up action.
Public Event Paint | Called when the thumbnail item is painted.
Public Event SelectionIndexChanged | Called when a thumbnail item is selected using the user interface.

See Also

ThumbnailXpress Object


AboutBox Method

AboutBox Method
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : AboutBox Method

Glossary Item Box

Description

Displays a dialog box with the Thumbnail version and copyright information.

Syntax

Visual Basic
Public Sub AboutBox()

See Also

ThumbnailXpress Object | ThumbnailXpress Members


AddDirectoryItems Method

AddDirectoryItems Method
DirectoryMask

A string value which represents the name of the directory for which to generate one or more thumbnails.

InsertIndex

A long value which represents the index at which to insert the new thumbnail.

AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : AddDirectoryItems Method

Glossary Item Box

Description

Adds the items in the specified directory to the list of thumbnail items.

Syntax

Visual Basic
Public Sub AddDirectoryItems( _
   ByVal DirectoryMask As String, _
   ByVal InsertIndex As Long _
)

Parameters

DirectoryMask

A string value which represents the name of the directory for which to generate one or more thumbnails.

InsertIndex

A long value which represents the index at which to insert the new thumbnail.

Remarks

When thumbnail items are added to the thumbnail item collection using the AddDirectoryItems method, the thumbnail item bitmaps will be generated asynchronously by one or more threads.

See Also


AddFileItems Method

AddFileItems Method
Filename

A string value which represents the name of the file for which to generate one or more thumbnails.

InsertIndex

A long value which represents the index at which to insert the new thumbnail(s).

AddAllPages

A boolean value which is True if generating multiple thumbnails, one for each page in a multi-page file. Yet has no meaning for single-page files.

AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : AddFileItems Method

Glossary Item Box

Description

Adds the items in the specified file to the list of thumbnail items.

Syntax

Visual Basic
Public Sub AddFileItems( _
   ByVal Filename As String, _
   ByVal InsertIndex As Long, _
   ByVal AddAllPages As Boolean _
)

Parameters

Filename

A string value which represents the name of the file for which to generate one or more thumbnails.

InsertIndex

A long value which represents the index at which to insert the new thumbnail(s).

AddAllPages

A boolean value which is True if generating multiple thumbnails, one for each page in a multi-page file. Yet has no meaning for single-page files.

Remarks

If the AddAllPages indicator is True, it causes the item to paint with a special bitmap overlaid on the image, indicating that the thumbnail item represents a multi-page file. For AddDirectoryItems, this value is always true, since it always adds only the first page from any file, even when there are multiple pages.

When thumbnail items add to the collection using the AddFileItems method, the thumbnail bitmaps generate asynchronously by one or more threads.

See Also


AddFilterItem Method

AddFilterItem Method
Name
A string value which represents the name to refer to this filter by.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : AddFilterItem Method

Glossary Item Box

Description

Adds a new filter to the end of the filter list.

Syntax

Visual Basic
Public Function AddFilterItem( _
   ByVal Name As String _
) As Long

Parameters

Name
A string value which represents the name to refer to this filter by.

Return Type

A long value which represents the new filter index value.

See Also


BeginUpdate Method

BeginUpdate Method
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : BeginUpdate Method

Glossary Item Box

Description

Disables control repainting to eliminate flicker when making multiple changes to the list of thumbnail items.

Syntax

Visual Basic
Public Sub BeginUpdate()

Remarks

Call EndUpdate when done making changes to enable control repainting.

See Also


Cancel Method

Cancel Method
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : Cancel Method

Glossary Item Box

Description

Cancels all pending thumbnail item generation requests.

Syntax

Visual Basic
Public Sub Cancel()

See Also


ClearFilters Method

ClearFilters Method
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : ClearFilters Method

Glossary Item Box

Description

Removes all existing filters from the list.

Syntax

Visual Basic
Public Sub ClearFilters()

See Also


ClearSelection Method

ClearSelection Method
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : ClearSelection Method

Glossary Item Box

Description

Clears the current selection.

Syntax

Visual Basic
Public Sub ClearSelection()

See Also


CreateCtlWindow Method

CreateCtlWindow Method
hParent
A long value which represents a handle to the parent object.
left
A long value which represents the left coordinate of the window to be created.
top
A long value which represents the top coordinate of the window to be created.
width
A long value which represents the width of the window to be created.
height
A long value which represents the height of the window to be created.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : CreateCtlWindow Method

Glossary Item Box

Description

Provides programmatic creation of a ThumbnailXpress control window.

Syntax

Visual Basic
Public Sub CreateCtlWindow( _
   ByVal hParent As Long, _
   ByVal left As Long, _
   ByVal top As Long, _
   ByVal width As Long, _
   ByVal height As Long _
)

Parameters

hParent
A long value which represents a handle to the parent object.
left
A long value which represents the left coordinate of the window to be created.
top
A long value which represents the top coordinate of the window to be created.
width
A long value which represents the width of the window to be created.
height
A long value which represents the height of the window to be created.

See Also


DeleteItem Method

DeleteItem Method
ItemIndex
A long value which represents a zero-based index value of the item to delete.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : DeleteItem Method

Glossary Item Box

Description

Deletes the specified item from the list of thumbnail items.

Syntax

Visual Basic
Public Sub DeleteItem( _
   ByVal ItemIndex As Long _
)

Parameters

ItemIndex
A long value which represents a zero-based index value of the item to delete.

See Also


DeleteItems Method

DeleteItems Method
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : DeleteItems Method

Glossary Item Box

Description

Deletes all items from the list of thumbnail items.

Syntax

Visual Basic
Public Sub DeleteItems()

See Also


DeleteSelectedItem Method

DeleteSelectedItem Method
SelectedItemIndex

A long value which represents the selected index of the thumbnail item to delete.

AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : DeleteSelectedItem Method

Glossary Item Box

Description

Deletes the specified selected item from the list of thumbnail items.

Syntax

Visual Basic
Public Sub DeleteSelectedItem( _
   ByVal SelectedItemIndex As Long _
)

Parameters

SelectedItemIndex

A long value which represents the selected index of the thumbnail item to delete.

See Also


DestroyCtlWindow Method

DestroyCtlWindow Method
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : DestroyCtlWindow Method

Glossary Item Box

Description

Provides programmatic destruction of a ThumbnailXpress control window.

Syntax

Visual Basic
Public Sub DestroyCtlWindow()

See Also


EmptyCache Method

EmptyCache Method
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : EmptyCache Method

Glossary Item Box

Description

Clears all items from the memory cache.

Syntax

Visual Basic
Public Sub EmptyCache()

See Also


EnableEvent Method

EnableEvent Method
eEvent
A TN_Event enumeration value to enable.
bEnabled
A boolean value which is True to enable the given event. Otherwise, False to disable the given event.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : EnableEvent Method

Glossary Item Box

Description

Enables or disables the raising of individual thumbnail custom events.

Syntax

Visual Basic
Public Sub EnableEvent( _
   ByVal eEvent As TN_Event, _
   ByVal bEnabled As Boolean _
)

Parameters

eEvent
Value | Description
TN_Error | 3 - The ThumbnailXpress Error Event
TN_ItemComplete | 2 - The ThumbnailItem ItemComplete Event.
TN_LoadFromMemoryEvent | 4 - The LoadFromMemory Event.
TN_Paint | 1 - The ThumbnailXpress Paint Event.
TN_SelectedIndexChange | 0 - The SelectedIndexChanged Event.
A TN_Event enumeration value to enable.
bEnabled
A boolean value which is True to enable the given event. Otherwise, False to disable the given event.

See Also

ThumbnailXpress Object | ThumbnailXpress Members | TN_Event Enumeration


EndUpdate Method

EndUpdate Method
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : EndUpdate Method

Glossary Item Box

Description

Enables the control repainting after calling the BeginUpdate method.

Syntax

Visual Basic
Public Sub EndUpdate()

See Also

ThumbnailXpress Object | ThumbnailXpress Members | BeginUpdate Method


EnsureVisible Method

EnsureVisible Method
ItemIndex
A long value which represents a zero-based index of the thumbnail item to make visible.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : EnsureVisible Method

Glossary Item Box

Description

Scrolls the list of thumbnail items if necessary to ensure the specified item is visible.

Syntax

Visual Basic
Public Sub EnsureVisible( _
   ByVal ItemIndex As Long _
)

Parameters

ItemIndex
A long value which represents a zero-based index of the thumbnail item to make visible.

Remarks

If the given index is not visible, it will be made visible at the topmost row.

See Also


FindFilterItemIndex Method

FindFilterItemIndex Method
Name
A string value which represents the filter name to find.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : FindFilterItemIndex Method

Glossary Item Box

Description

Finds the list index of a filter specified by the filter name.

Syntax

Visual Basic
Public Function FindFilterItemIndex( _
   ByVal Name As String _
) As Long

Parameters

Name
A string value which represents the filter name to find.

See Also


GetAnnotationSearchOrder Method

GetAnnotationSearchOrder Method
searchIndex
A Long value which represents the 0-based index in the search collection item to query.
annotationType
A TN_AnnotationType which will be set to the annotation type at the specified index.
prefixPattern
A String that will be set to the prefix pattern of the external annotation file.
suffixPattern
A String that will be set to the suffix pattern of the external annotation file.
includeFilenameExtension
A Boolean value that will be set to indicate whether or not the filename pattern includes the file extension of the image being thumbnailed.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : GetAnnotationSearchOrder Method

Glossary Item Box

Description

Gets the search order for ThumbnailXpress to use when associating external annotation files with the item being thumbnailed.

Syntax

Visual Basic
Public Sub GetAnnotationSearchOrder( _
   ByVal searchIndex As Long, _
   ByRef annotationType As TN_AnnotationType, _
   ByRef prefixPattern As String, _
   ByRef suffixPattern As String, _
   ByRef includeFilenameExtension As Boolean _
)

Parameters

searchIndex
A Long value which represents the 0-based index in the search collection item to query.
annotationType
Value | Description
ANNOTATION_TYPE_I4W | Wang data embedded in TIFF tag #32932.
ANNOTATION_TYPE_INTERNAL_NXP | Binary format produced by NotateXpress.
ANNOTATION_TYPE_INTERNAL_XFDF | Acrobat XML Forms Document File.
ANNOTATION_TYPE_NONE | None.
ANNOTATION_TYPE_NXP | Binary format produced by NotateXpress.
ANNOTATION_TYPE_TMS | Legacy TMS Sequoia .ann file format.
ANNOTATION_TYPE_XFDF | Acrobat XML Forms Document File.
ANNOTATION_TYPE_XML | NotateXpress XML format.
A TN_AnnotationType which will be set to the annotation type at the specified index.
prefixPattern
A String that will be set to the prefix pattern of the external annotation file.
suffixPattern
A String that will be set to the suffix pattern of the external annotation file.
includeFilenameExtension
A Boolean value that will be set to indicate whether or not the filename pattern includes the file extension of the image being thumbnailed.

Remarks

See Also


GetAnnotationSearchOrderSize Method

GetAnnotationSearchOrderSize Method
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : GetAnnotationSearchOrderSize Method

Glossary Item Box

Description

Gets the search order size.

Syntax

Visual Basic
Public Function GetAnnotationSearchOrderSize() As Long

Return Type

A Long value that specifies the search order size.

See Also


GetDisplayRect Method

GetDisplayRect Method
left
A long value which represents the left coordinate of display rectangle in pixels.
top

A long value which represents the top coordinate of display rectangle in pixels.

Right

A long value which represents the right coordinate of display rectangle in pixels.

Bottom

A long value which represents the bottom coordinate of display rectangle in pixels.

AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : GetDisplayRect Method

Glossary Item Box

Description

Gets the display rectangle of the control in pixels.

Syntax

Visual Basic
Public Sub GetDisplayRect( _
   ByRef left As Long, _
   ByRef top As Long, _
   ByRef Right As Long, _
   ByRef Bottom As Long _
)

Parameters

left
A long value which represents the left coordinate of display rectangle in pixels.
top

A long value which represents the top coordinate of display rectangle in pixels.

Right

A long value which represents the right coordinate of display rectangle in pixels.

Bottom

A long value which represents the bottom coordinate of display rectangle in pixels.

See Also


GetFilterCaseSensitive Method

GetFilterCaseSensitive Method
FilterName
A string value which represents the filter name.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : GetFilterCaseSensitive Method

Glossary Item Box

Description

Gets the filename matching case sensitivity enabled value for the specified filter.

Syntax

Visual Basic
Public Function GetFilterCaseSensitive( _
   ByVal FilterName As String _
) As Boolean

Parameters

FilterName
A string value which represents the filter name.

Return Type

A boolean value which designates if the given filter is case sensitive.

See Also


GetFilterComparison Method

GetFilterComparison Method
FilterName
A string value which represents the filter to get the comparison for.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : GetFilterComparison Method

Glossary Item Box

Description

Gets the comparison criteria for the specified filter.

Syntax

Visual Basic
Public Function GetFilterComparison( _
   ByVal FilterName As String _
) As TN_FilterComparison

Parameters

FilterName
A string value which represents the filter to get the comparison for.

Return Type

The TN_FilterComparison value for the given FilterName.

See Also

ThumbnailXpress Object | ThumbnailXpress Members | TN_FilterComparison Enumeration


GetFilterDate Method

GetFilterDate Method
FilterName
A string value which represents the filter to get the data for.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : GetFilterDate Method

Glossary Item Box

Description

Gets the date criteria for the specified filter.

Syntax

Visual Basic
Public Function GetFilterDate( _
   ByVal FilterName As String _
) As Variant

Parameters

FilterName
A string value which represents the filter to get the data for.

Return Type

A variant which represents the date for the filter given.

See Also


GetFilterEnabled Method

GetFilterEnabled Method
FilterName
A string value which represents the filter name.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : GetFilterEnabled Method

Glossary Item Box

Description

Gets the enabled status of the specified filter.

Syntax

Visual Basic
Public Function GetFilterEnabled( _
   ByVal FilterName As String _
) As Boolean

Parameters

FilterName
A string value which represents the filter name.

Return Type

A boolean value which is True if the given filter is enabled. Otherwise, False is returned.

See Also


GetFilterFilenamePattern Method

GetFilterFilenamePattern Method
FilterName
A string value which represents the filter name.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : GetFilterFilenamePattern Method

Glossary Item Box

Description

Gets the filename matching pattern criteria for the specified filter.

Syntax

Visual Basic
Public Function GetFilterFilenamePattern( _
   ByVal FilterName As String _
) As String

Parameters

FilterName
A string value which represents the filter name.

Return Type

A string which represents the filter's filename pattern.

Remarks

The default value is an empty string "".

Note: This pattern is only relevant for a filter type of: Filename.

See Also


GetFilterIncludeHidden Method

GetFilterIncludeHidden Method
FilterName
A string value which represents the filter name.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : GetFilterIncludeHidden Method

Glossary Item Box

Description

Gets the file attributes include hidden files enabled value for the specified filter.

Syntax

Visual Basic
Public Function GetFilterIncludeHidden( _
   ByVal FilterName As String _
) As Boolean

Parameters

FilterName
A string value which represents the filter name.

Return Type

A boolean value which is True if the given filter includes hidden files inclusion. Otherwise, False is returned.

Remarks

The default value is False.

See Also


GetFilterIncludeParentDirectory Method

GetFilterIncludeParentDirectory Method
FilterName
A string value which represents the filter name.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : GetFilterIncludeParentDirectory Method

Glossary Item Box

Description

Gets the file attributes include parent directory enabled value for the specified filter.

Syntax

Visual Basic
Public Function GetFilterIncludeParentDirectory( _
   ByVal FilterName As String _
) As Boolean

Parameters

FilterName
A string value which represents the filter name.

Return Type

A boolean value which is True if the given filter includes the filter's parent directory inclusion. Otherwise, False is returned.

Remarks

The default value is False.

See Also


GetFilterIncludeSubDirectory Method

GetFilterIncludeSubDirectory Method
FilterName
A string value which represents the filter name.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : GetFilterIncludeSubDirectory Method

Glossary Item Box

Description

Gets the file attributes include sub directory enabled value for the specified filter.

Syntax

Visual Basic
Public Function GetFilterIncludeSubDirectory( _
   ByVal FilterName As String _
) As Boolean

Parameters

FilterName
A string value which represents the filter name.

Return Type

A boolean value which is True if the given filter's sub-directory is included.

Remarks

The default value is True.

See Also


GetFilterMatchAppliesToDirectory Method

GetFilterMatchAppliesToDirectory Method
FilterName
A string value which represents the filter name.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : GetFilterMatchAppliesToDirectory Method

Glossary Item Box

Description

Gets name pattern applies to directory enabled value for the specified filter.

Syntax

Visual Basic
Public Function GetFilterMatchAppliesToDirectory( _
   ByVal FilterName As String _
) As Boolean

Parameters

FilterName
A string value which represents the filter name.

Return Type

A boolean value which is True which means for a directory to be included in the collection, the name must match the pattern criteria specified from the GetFilterFilenamePattern method. Otherwise, False is returned.

Remarks

The default value is False.

See Also


GetFilterName Method

GetFilterName Method
FilterIndex
A long value which represents the 0-based index for the filter to get the name of.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : GetFilterName Method

Glossary Item Box

Description

Gets the name for the filter at the specified filter index.

Syntax

Visual Basic
Public Function GetFilterName( _
   ByVal FilterIndex As Long _
) As String

Parameters

FilterIndex
A long value which represents the 0-based index for the filter to get the name of.

Return Type

A string value which represents the filter name.

See Also


GetFilterSize Method

GetFilterSize Method
FilterName
A string value which represents the filter name to get the file size from.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : GetFilterSize Method

Glossary Item Box

Description

Gets the file size criteria for the specified filter.

Syntax

Visual Basic
Public Function GetFilterSize( _
   ByVal FilterName As String _
) As Long

Parameters

FilterName
A string value which represents the filter name to get the file size from.

Return Type

A long value which represents the file size of the given filter.

Remarks

The default value is 0.

See Also


GetFilterType Method

GetFilterType Method
FilterName
A string value which represents the filter name.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : GetFilterType Method

Glossary Item Box

Description

Gets the type for the specified filter.

Syntax

Visual Basic
Public Function GetFilterType( _
   ByVal FilterName As String _
) As TN_FilterType

Parameters

FilterName
A string value which represents the filter name.

Return Type

The TN_FilterType enumeration value which is the type for the given filter.

See Also

ThumbnailXpress Object | ThumbnailXpress Members | TN_FilterType Enumeration


GetIndexOfSelectedItem Method

GetIndexOfSelectedItem Method
SelectedItemIndex
A long value which represents the index of the selected thumbnail item.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : GetIndexOfSelectedItem Method

Glossary Item Box

Description

Gets the index in the list of thumbnail items for the specified selected thumbnail item.

Syntax

Visual Basic
Public Function GetIndexOfSelectedItem( _
   ByVal SelectedItemIndex As Long _
) As Long

Parameters

SelectedItemIndex
A long value which represents the index of the selected thumbnail item.

See Also


GetItemAnnotationsFilename Method

GetItemAnnotationsFilename Method
ItemIndex
A long value which represents the index of the thumbnail item to query.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : GetItemAnnotationsFilename Method

Glossary Item Box

Description

Gets the filename and path of the file used for the thumbnail annotations.

Syntax

Visual Basic
Public Function GetItemAnnotationsFilename( _
   ByVal ItemIndex As Long _
) As String

Parameters

ItemIndex
A long value which represents the index of the thumbnail item to query.

Return Type

The string value that represents the filename and path of the file used for the thumbnail annotations.

See Also


GetItemAnnotationType Method

GetItemAnnotationType Method
ItemIndex
A long value which represents the index of the thumbnail item to query.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : GetItemAnnotationType Method

Glossary Item Box

Description

Gets the annotation type if any annotations were used for this thumbnail.

Syntax

Visual Basic
Public Function GetItemAnnotationType( _
   ByVal ItemIndex As Long _
) As TN_AnnotationType

Parameters

ItemIndex
A long value which represents the index of the thumbnail item to query.

Return Type

The TN_AnnotationType enumeration value that indicates the annotation type of the data.

See Also


GetItemCadLayoutCount Method

GetItemCadLayoutCount Method
ItemIndex
A long value which represents the item to get the CAD layout count on.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : GetItemCadLayoutCount Method

Glossary Item Box

Description

Gets the CAD layout count for the specified thumbnail item.

Syntax

Visual Basic
Public Function GetItemCadLayoutCount( _
   ByVal ItemIndex As Long _
) As Long

Parameters

ItemIndex
A long value which represents the item to get the CAD layout count on.

Return Type

A long value which represents the CAD layout count.

Remarks

Note: A layout count of 0 means the item is not of type CAD.

See Also


GetItemCadLayoutNumber Method

GetItemCadLayoutNumber Method
ItemIndex
A long value which represents the thumbnail item to get the CAD layout number for.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : GetItemCadLayoutNumber Method

Glossary Item Box

Description

Gets the CAD layout number for the specified thumbnail item.

Syntax

Visual Basic
Public Function GetItemCadLayoutNumber( _
   ByVal ItemIndex As Long _
) As Long

Parameters

ItemIndex
A long value which represents the thumbnail item to get the CAD layout number for.

Return Type

A long value which represents the layout number.

See Also


GetItemCellBackColor Method

GetItemCellBackColor Method
ItemIndex
The index of the thumbnail item specified.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : GetItemCellBackColor Method

Glossary Item Box

Description

Gets the Cell Back Color for the specified thumbnail item.

Syntax

Visual Basic
Public Function GetItemCellBackColor( _
   ByVal ItemIndex As Long _
) As ULong

Parameters

ItemIndex
The index of the thumbnail item specified.

Return Type

The cell back color.

See Also


GetItemCellBorderColor Method

GetItemCellBorderColor Method
ItemIndex
The index of the thumbnail item specified.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : GetItemCellBorderColor Method

Glossary Item Box

Description

Gets the Cell Border Color for the specified thumbnail item.

Syntax

Visual Basic
Public Function GetItemCellBorderColor( _
   ByVal ItemIndex As Long _
) As ULong

Parameters

ItemIndex
The index of the thumbnail item specified.

Return Type

The cell border color.

See Also


GetItemDescriptor Method

GetItemDescriptor Method
ItemIndex
Index of the thumbnail item to query.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : GetItemDescriptor Method

Glossary Item Box

Description

Gets the descriptor for the specified thumbnail item.

Syntax

Visual Basic
Public Function GetItemDescriptor( _
   ByVal ItemIndex As Long _
) As String

Parameters

ItemIndex
Index of the thumbnail item to query.

See Also


GetItemErrorCode Method

GetItemErrorCode Method
ItemIndex
A long value which represents the index of the thumbnail item to query.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : GetItemErrorCode Method

Glossary Item Box

Description

Gets the error code for the specified thumbnail item.

Syntax

Visual Basic
Public Function GetItemErrorCode( _
   ByVal ItemIndex As Long _
) As Long

Parameters

ItemIndex
A long value which represents the index of the thumbnail item to query.

Return Type

A long value which represents the error number for the given item.

See Also


GetItemErrorString Method

GetItemErrorString Method
ItemIndex
A long which represents the index of the thumbnail item to query.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : GetItemErrorString Method

Glossary Item Box

Description

Gets the error string for the specified thumbnail item.

Syntax

Visual Basic
Public Function GetItemErrorString( _
   ByVal ItemIndex As Long _
) As String

Parameters

ItemIndex
A long which represents the index of the thumbnail item to query.

See Also


GetItemFilename Method

GetItemFilename Method
ItemIndex
A long value which represents the index of the thumbnail item to query.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : GetItemFilename Method

Glossary Item Box

Description

Gets the filename for the specified thumbnail item.

Syntax

Visual Basic
Public Function GetItemFilename( _
   ByVal ItemIndex As Long _
) As String

Parameters

ItemIndex
A long value which represents the index of the thumbnail item to query.

Return Type

A string value which represents the filename of the given item.

See Also


GetItemHasAnnotations Method

GetItemHasAnnotations Method
ItemIndex
A long value which represents the index of the thumbnail item to query.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : GetItemHasAnnotations Method

Glossary Item Box

Description

Gets if annotations of any type were discovered and used for this thumbnail.

Syntax

Visual Basic
Public Function GetItemHasAnnotations( _
   ByVal ItemIndex As Long _
) As Boolean

Parameters

ItemIndex
A long value which represents the index of the thumbnail item to query.

Return Type

The Boolean value that is true if annotations of any type were discovered and used for this thumbnail; and false otherwise.

See Also


GetItemHBitmap Method

GetItemHBitmap Method
ItemIndex
A long value which represents the index of the item to get the bitmap of.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : GetItemHBitmap Method

Glossary Item Box

Description

Gets the HBITMAP handle for the specified thumbnail item image.

Syntax

Visual Basic
Public Function GetItemHBitmap( _
   ByVal ItemIndex As Long _
) As Integer

Parameters

ItemIndex
A long value which represents the index of the item to get the bitmap of.

Return Type

An integer value which represents the handle to a bitmap for the given item.

See Also


GetItemHDib Method

GetItemHDib Method
ItemIndex
Index of the thumbnail item to query.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : GetItemHDib Method

Glossary Item Box

Description

Gets the DIB handle for the specified thumbnail item image.

Syntax

Visual Basic
Public Function GetItemHDib( _
   ByVal ItemIndex As Long _
) As Long

Parameters

ItemIndex
Index of the thumbnail item to query.

Remarks

It is the caller's responsibility to free the hDIB.

See Also


GetItemHDib64 Method

GetItemHDib64 Method
ItemIndex
Index of the thumbnail item to query.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : GetItemHDib64 Method

Glossary Item Box

Description

Gets the DIB handle for the specified thumbnail item image in a 64-bit environment.

Syntax

Visual Basic
Public Function GetItemHDib64( _
   ByVal ItemIndex As Long _
) As __int64

Parameters

ItemIndex
Index of the thumbnail item to query.

Remarks

This method is intended for use in a 64-bit environment.

It is the caller's responsibility to free the hDIB.

See Also


GetItemIndexFromPoint Method

GetItemIndexFromPoint Method
PointX
Horizontal coordinate offset from left edge of control in pixels.
PointY
Vertical coordinate offset from top edge of control in pixels.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : GetItemIndexFromPoint Method

Glossary Item Box

Description

Gets the index for the thumbnail item at the specified point.

Syntax

Visual Basic
Public Function GetItemIndexFromPoint( _
   ByVal PointX As Long, _
   ByVal PointY As Long _
) As Long

Parameters

PointX
Horizontal coordinate offset from left edge of control in pixels.
PointY
Vertical coordinate offset from top edge of control in pixels.

Return Type

A long value which represents the item index for the provided point coordinates.

See Also


GetItemPage Method

GetItemPage Method
ItemIndex
A long value which represents the index of the thumbnail item to query.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : GetItemPage Method

Glossary Item Box

Description

Gets the page number for the specified thumbnail item.

Syntax

Visual Basic
Public Function GetItemPage( _
   ByVal ItemIndex As Long _
) As Long

Parameters

ItemIndex
A long value which represents the index of the thumbnail item to query.

Return Type

A long value which represents the page for the item.

Remarks

Gets the page in the image file that the thumbnail item represents.

The page number is 1-based, with the default page = 1.

Note: If you do not have an ImagXpress license which supports multi-page image files, you will not be able to display thumbnails for items where the page value is greater than 1.

Note: The Standard version of ImagXpress is the only version that does not support multi-page images.

See Also


GetItemPageCount Method

GetItemPageCount Method
ItemIndex
A long value which represents the index of the thumbnail item to query.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : GetItemPageCount Method

Glossary Item Box

Description

Gets the page count for the specified thumbnail item.

Syntax

Visual Basic
Public Function GetItemPageCount( _
   ByVal ItemIndex As Long _
) As Long

Parameters

ItemIndex
A long value which represents the index of the thumbnail item to query.

Return Type

A long value which represents the page count for the given item.

See Also


GetItemPDFPassword Method

GetItemPDFPassword Method
ItemIndex
A long value which represents the index of the thumbnail item.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : GetItemPDFPassword Method

Glossary Item Box

Description

Gets the PDF password for the specified thumbnail item

Syntax

Visual Basic
Public Function GetItemPDFPassword( _
   ByVal ItemIndex As Long _
) As String

Parameters

ItemIndex
A long value which represents the index of the thumbnail item.

Remarks

The PDF password is used for accessing single PDF files when a thumbnail item is a known PDF with a password.

See Also


GetItemPDFRepair Method

GetItemPDFRepair Method
ItemIndex
Specifies the index of the thumbnail item to query.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : GetItemPDFRepair Method

Glossary Item Box

Description

Gets the PDF file repair for the specified thumbnail item.

Syntax

Visual Basic
Public Function GetItemPDFRepair( _
   ByVal ItemIndex As Long _
) As Boolean

Parameters

ItemIndex
Specifies the index of the thumbnail item to query.

Return Type

A boolean value which is True to repair the PDF file while opening it. Otherwise, False is returned.

See Also


GetItemPicture Method

GetItemPicture Method
ItemIndex
A long value which represents the item index of the picture to get.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : GetItemPicture Method

Glossary Item Box

Description

Gets the Picture object for the specified thumbnail item image.

Syntax

Visual Basic
Public Function GetItemPicture( _
   ByVal ItemIndex As Long _
) As Picture

Parameters

ItemIndex
A long value which represents the item index of the picture to get.

Return Type

A picture object which is associated with the given thumbnail item.

See Also


GetItemStatus Method

GetItemStatus Method
ItemIndex
Index of the thumbnail item to query.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : GetItemStatus Method

Glossary Item Box

Description

Gets the status for the specified thumbnail item.

Syntax

Visual Basic
Public Function GetItemStatus( _
   ByVal ItemIndex As Long _
) As TN_ThumbnailStatus

Parameters

ItemIndex
Index of the thumbnail item to query.

Return Type

A TN_ThumbnailStatus enumeration value associated to the given item index.

See Also


GetItemType Method

GetItemType Method
ItemIndex
A long value which represents the item index to get the type for.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : GetItemType Method

Glossary Item Box

Description

Gets the type for the specified thumbnail item.

Syntax

Visual Basic
Public Function GetItemType( _
   ByVal ItemIndex As Long _
) As TN_ThumbnailType

Parameters

ItemIndex
A long value which represents the item index to get the type for.

Return Type

A TN_ThumbnailType enumeration value.

See Also


GetItemUserTag Method

GetItemUserTag Method
ItemIndex
A long value which represents the item index.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : GetItemUserTag Method

Glossary Item Box

Description

Gets the variant user data associated with the specified thumbnail item.

Syntax

Visual Basic
Public Function GetItemUserTag( _
   ByVal ItemIndex As Long _
) As Variant

Parameters

ItemIndex
A long value which represents the item index.

Return Type

A variant which represents the user tag for the item.

See Also


InsertFilterItem Method

InsertFilterItem Method
FilterIndex
A long value which represents the filter index to insert for the item.
Name
A string which represents the filter name.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : InsertFilterItem Method

Glossary Item Box

Description

Inserts a new filter in the filter list at the specified index.

Syntax

Visual Basic
Public Function InsertFilterItem( _
   ByVal FilterIndex As Long, _
   ByVal Name As String _
) As Long

Parameters

FilterIndex
A long value which represents the filter index to insert for the item.
Name
A string which represents the filter name.

See Also


InsertItem Method

InsertItem Method
Filename
A string value which represents the filename.
InsertIndex
A long value which represents the index where to insert the item.
Verify
A boolean value which should be True to verify the item is inserted.
Descriptor
A string value which represents the descriptor.
ThumbnailStatus
A TN_ThumbnailStatus enumeration value.
ThumbnailType
A TN_ThumbnailType enumeration value.
Page
A long value which represents the page.
PageCount
A long value which represents the page count.
UserTag
A variant value which represents the user tag.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : InsertItem Method

Glossary Item Box

Description

Inserts the specified item into the list of thumbnail items.

Syntax

Visual Basic
Public Sub InsertItem( _
   ByVal Filename As String, _
   ByVal InsertIndex As Long, _
   ByVal Verify As Boolean, _
   ByVal Descriptor As String, _
   ByVal ThumbnailStatus As TN_ThumbnailStatus, _
   ByVal ThumbnailType As TN_ThumbnailType, _
   ByVal Page As Long, _
   ByVal PageCount As Long, _
   ByVal UserTag As Variant _
)

Parameters

Filename
A string value which represents the filename.
InsertIndex
A long value which represents the index where to insert the item.
Verify
A boolean value which should be True to verify the item is inserted.
Descriptor
A string value which represents the descriptor.
ThumbnailStatus
Value | Description
TN_BeingGenerated

2 - Thumbnail bitmap in the process of being generated.

TN_Canceled | 6 - The thumbnail is canceled.
TN_FailedWithError

4 - ThumbnailXpress failed to generate thumbnail bitmap for the image (likely decompression error).

TN_FailedWithTimeout

5 - Failed to generate thumbnail bitmap within time limits. See ThreadHungThreshold property.

TN_Generated

3 - A thumbnail bitmap successfully generated (though it may not be in cache at this point).

TN_NotValidated | 0 - The thumbnail is not validated.
TN_Validated

1 - File validated at some level; ThumbnailXpress believes it is a supported file type.

A TN_ThumbnailStatus enumeration value.
ThumbnailType
Value Description
TN_CAD

5 - Supported CAD (Computer Aided Design) file type.

TN_Image

3 - Supported ImagXpress file type.

TN_Internet

1 - Specifies that the file is an Internet file.

TN_ParentDirectory

6 - Parent directory folder.

TN_PDF

4 - Supported PDFXpress file type.

TN_Subdirectory

7 - Sub-directory folder type.

TN_Unknown

0 - Thumbnail type is not recognized by ThumbnailXpress operations.

TN_Unsupported

2 - ImagXpress or PDF Xpress (if available) does not support the file.

A TN_ThumbnailType enumeration value.
Page
A long value which represents the page.
PageCount
A long value which represents the page count.
UserTag
A variant value which represents the user tag.

See Also


InsertItemFromBlob Method

InsertItemFromBlob Method
ImageMemoryBlob
A variant which represents an image memory blob.
BlobSize
A long value which represents the blob size.
InsertIndex
A long value which represents the index location to insert the item.
Descriptor
A string value which represents the descriptor.
ThumbnailStatus
A TN_ThumbnailStatus enumeration value.
ThumbnailType
A TN_ThumbnailType enumeration value.
Page
A long value which represents the page number.
PageCount
A long value which represents the page count.
UserTag
A variant which represents the user tag.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : InsertItemFromBlob Method

Glossary Item Box

Description

Inserts an image into the list of thumbnail items by way of a user supplied image memory 'Blob'.

Syntax

Visual Basic
Public Sub InsertItemFromBlob( _
   ByVal ImageMemoryBlob As Variant, _
   ByVal BlobSize As Long, _
   ByVal InsertIndex As Long, _
   ByVal Descriptor As String, _
   ByVal ThumbnailStatus As TN_ThumbnailStatus, _
   ByVal ThumbnailType As TN_ThumbnailType, _
   ByVal Page As Long, _
   ByVal PageCount As Long, _
   ByVal UserTag As Variant _
)

Parameters

ImageMemoryBlob
A variant which represents an image memory blob.
BlobSize
A long value which represents the blob size.
InsertIndex
A long value which represents the index location to insert the item.
Descriptor
A string value which represents the descriptor.
ThumbnailStatus
Value | Description
TN_BeingGenerated

2 - Thumbnail bitmap in the process of being generated.

TN_Canceled | 6 - The thumbnail is canceled.
TN_FailedWithError

4 - ThumbnailXpress failed to generate thumbnail bitmap for the image (likely decompression error).

TN_FailedWithTimeout

5 - Failed to generate thumbnail bitmap within time limits. See ThreadHungThreshold property.

TN_Generated

3 - A thumbnail bitmap successfully generated (though it may not be in cache at this point).

TN_NotValidated | 0 - The thumbnail is not validated.
TN_Validated

1 - File validated at some level; ThumbnailXpress believes it is a supported file type.

A TN_ThumbnailStatus enumeration value.
ThumbnailType
Value Description
TN_CAD

5 - Supported CAD (Computer Aided Design) file type.

TN_Image

3 - Supported ImagXpress file type.

TN_Internet

1 - Specifies that the file is an Internet file.

TN_ParentDirectory

6 - Parent directory folder.

TN_PDF

4 - Supported PDFXpress file type.

TN_Subdirectory

7 - Sub-directory folder type.

TN_Unknown

0 - Thumbnail type is not recognized by ThumbnailXpress operations.

TN_Unsupported

2 - ImagXpress or PDF Xpress (if available) does not support the file.

A TN_ThumbnailType enumeration value.
Page
A long value which represents the page number.
PageCount
A long value which represents the page count.
UserTag
A variant which represents the user tag.

Remarks

The LoadFromMemory event may optionally be used to supply the memory 'Blob'.

See Also


InsertItemFromMemory Method

InsertItemFromMemory Method
pImageMemoryBuffer
A byte value which represents the image from memory buffer.
MemoryBufferSize
A long value which represents the memory buffer size.
InsertIndex
A long value which represents the location to insert the item.
Descriptor
A string value which represents the description of the item to insert.
ThumbnailStatus
A TN_ThumbnailStatus enumeration value.
ThumbnailType
A TN_ThumbnailType enumeration value.
Page
A long value which represents the page.
PageCount
A long value which represents the number of pages.
UserTag
A variant which represents the user tag.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : InsertItemFromMemory Method

Glossary Item Box

Description

Inserts an image into the list of thumbnail items by way of a user supplied image memory buffer.

Syntax

Visual Basic
Public Sub InsertItemFromMemory( _
   ByRef pImageMemoryBuffer As Byte, _
   ByVal MemoryBufferSize As Long, _
   ByVal InsertIndex As Long, _
   ByVal Descriptor As String, _
   ByVal ThumbnailStatus As TN_ThumbnailStatus, _
   ByVal ThumbnailType As TN_ThumbnailType, _
   ByVal Page As Long, _
   ByVal PageCount As Long, _
   ByVal UserTag As Variant _
)

Parameters

pImageMemoryBuffer
A byte value which represents the image from memory buffer.
MemoryBufferSize
A long value which represents the memory buffer size.
InsertIndex
A long value which represents the location to insert the item.
Descriptor
A string value which represents the description of the item to insert.
ThumbnailStatus
Value | Description
TN_BeingGenerated

2 - Thumbnail bitmap in the process of being generated.

TN_Canceled | 6 - The thumbnail is canceled.
TN_FailedWithError

4 - ThumbnailXpress failed to generate thumbnail bitmap for the image (likely decompression error).

TN_FailedWithTimeout

5 - Failed to generate thumbnail bitmap within time limits. See ThreadHungThreshold property.

TN_Generated

3 - A thumbnail bitmap successfully generated (though it may not be in cache at this point).

TN_NotValidated | 0 - The thumbnail is not validated.
TN_Validated

1 - File validated at some level; ThumbnailXpress believes it is a supported file type.

A TN_ThumbnailStatus enumeration value.
ThumbnailType
Value Description
TN_CAD

5 - Supported CAD (Computer Aided Design) file type.

TN_Image

3 - Supported ImagXpress file type.

TN_Internet

1 - Specifies that the file is an Internet file.

TN_ParentDirectory

6 - Parent directory folder.

TN_PDF

4 - Supported PDFXpress file type.

TN_Subdirectory

7 - Sub-directory folder type.

TN_Unknown

0 - Thumbnail type is not recognized by ThumbnailXpress operations.

TN_Unsupported

2 - ImagXpress or PDF Xpress (if available) does not support the file.

A TN_ThumbnailType enumeration value.
Page
A long value which represents the page.
PageCount
A long value which represents the number of pages.
UserTag
A variant which represents the user tag.

Remarks

The LoadFromMemory event may optionally be used to supply the memory buffer.

See Also


MoveCtlWindow Method

MoveCtlWindow Method
left
A long value which represents the left horizontal coordinate.
top
A long value which represents the top coordinate value.
width
A long which represents the width.
height
A long which represents the height.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : MoveCtlWindow Method

Glossary Item Box

Description

Provides programmatic relocation or possible resizing of a ThumbnailXpress control.

Syntax

Visual Basic
Public Sub MoveCtlWindow( _
   ByVal left As Long, _
   ByVal top As Long, _
   ByVal width As Long, _
   ByVal height As Long _
)

Parameters

left
A long value which represents the left horizontal coordinate.
top
A long value which represents the top coordinate value.
width
A long which represents the width.
height
A long which represents the height.

See Also


Refresh Method

Refresh Method
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : Refresh Method

Glossary Item Box

Description

Refreshes the list of thumbnail items.

Syntax

Visual Basic
Public Sub Refresh()

See Also


RemoveFilterItem Method

RemoveFilterItem Method
Name
A string value which represents the filter to remove.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : RemoveFilterItem Method

Glossary Item Box

Description

Removes the filter specified by the filter list name.

Syntax

Visual Basic
Public Sub RemoveFilterItem( _
   ByVal Name As String _
)

Parameters

Name
A string value which represents the filter to remove.

See Also


RemoveFilterItemByIndex Method

RemoveFilterItemByIndex Method
FilterIndex
A long value which represents the filter.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : RemoveFilterItemByIndex Method

Glossary Item Box

Description

Removes the filter specified by the filter list index.

Syntax

Visual Basic
Public Sub RemoveFilterItemByIndex( _
   ByVal FilterIndex As Long _
)

Parameters

FilterIndex
A long value which represents the filter.

See Also


ResetCanceledItem Method

ResetCanceledItem Method
CanceledItemIndex
A long value which represents the index of the canceled item to reset.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : ResetCanceledItem Method

Glossary Item Box

Description

Resets canceled status for a single canceled item or for all canceled items, allowing them to be attempted to be re-generated.

Syntax

Visual Basic
Public Sub ResetCanceledItem( _
   ByVal CanceledItemIndex As Long _
)

Parameters

CanceledItemIndex
A long value which represents the index of the canceled item to reset.

Remarks

Note: Passing in a valid canceled item index parameter resets the item status to allow a generation attempt. Passing in -1 resets ALL canceled items.

See Also


ScrollItems Method

ScrollItems Method
ScrollType
A TN_ScrollItemsType enumeration value.
Value
If the TN_ScrollItemsType is equal to TN_ThumbPosition, this value specifies a thumb position to be scrolled to. If TN_ScrollItemsType is equal to TN_ItemIndex, this value specifies the item index to be scrolled to.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : ScrollItems Method

Glossary Item Box

Description

Provides programmatic scrolling of the thumbnail item list.

Syntax

Visual Basic
Public Sub ScrollItems( _
   ByVal ScrollType As TN_ScrollItemsType, _
   ByVal Value As Long _
)

Parameters

ScrollType
Value | Description
TN_ItemIndex | 5 - Item index.
TN_LargeDecrease | 0 - Large decrease in scroll operation.
TN_LargeIncrease | 2 - Large increase in scroll operation.
TN_SmallDecrease | 1 - Small decrease in scroll operation.
TN_SmallIncrease | 3 - Small increase in scroll operation.
TN_ThumbPosition | 4 - Thumb position.
A TN_ScrollItemsType enumeration value.
Value
If the TN_ScrollItemsType is equal to TN_ThumbPosition, this value specifies a thumb position to be scrolled to. If TN_ScrollItemsType is equal to TN_ItemIndex, this value specifies the item index to be scrolled to.

See Also


SelectItem Method

SelectItem Method
ItemIndex
A long value which represents the index value of the item to select.
Selected
A boolean value which is True when the item is selected. Otherwise, False.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : SelectItem Method

Glossary Item Box

Description

Selects (or deselects) the specified thumbnail item.

Syntax

Visual Basic
Public Sub SelectItem( _
   ByVal ItemIndex As Long, _
   ByVal Selected As Boolean _
)

Parameters

ItemIndex
A long value which represents the index value of the item to select.
Selected
A boolean value which is True when the item is selected. Otherwise, False.

See Also


SetAnnotationSearchOrder Method

SetAnnotationSearchOrder Method
searchIndex
The 0-based index of the item in the annotation search order list whose values should be changed.
annotationType
The type of annotation.
prefixPattern
The prefix pattern of the external annotation file.
suffixPattern
The suffix pattern of the external annotation file.
includeFilenameExtension
Indicates whether or not the filename pattern includes the file extension of the image being thumbnailed.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : SetAnnotationSearchOrder Method

Glossary Item Box

Description

Sets the search order for ThumbnailXpress to use when associating external annotation files with the item being thumbnailed.

Syntax

Visual Basic
Public Sub SetAnnotationSearchOrder( _
   ByVal searchIndex As Long, _
   ByVal annotationType As TN_AnnotationType, _
   ByVal prefixPattern As String, _
   ByVal suffixPattern As String, _
   ByVal includeFilenameExtension As Boolean _
)

Parameters

searchIndex
The 0-based index of the item in the annotation search order list whose values should be changed.
annotationType
Value | Description
ANNOTATION_TYPE_I4W | Wang data embedded in TIFF tag #32932.
ANNOTATION_TYPE_INTERNAL_NXP | Binary format produced by NotateXpress.
ANNOTATION_TYPE_INTERNAL_XFDF | Acrobat XML Forms Document File.
ANNOTATION_TYPE_NONE | None.
ANNOTATION_TYPE_NXP | Binary format produced by NotateXpress.
ANNOTATION_TYPE_TMS | Legacy TMS Sequoia .ann file format.
ANNOTATION_TYPE_XFDF | Acrobat XML Forms Document File.
ANNOTATION_TYPE_XML | NotateXpress XML format.
The type of annotation.
prefixPattern
The prefix pattern of the external annotation file.
suffixPattern
The suffix pattern of the external annotation file.
includeFilenameExtension
Indicates whether or not the filename pattern includes the file extension of the image being thumbnailed.

Remarks

See Also


SetAnnotationSearchOrderSize Method

SetAnnotationSearchOrderSize Method
searchSize
The size of the search order collection.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : SetAnnotationSearchOrderSize Method

Glossary Item Box

Description

Sets the search order size.

Syntax

Visual Basic
Public Sub SetAnnotationSearchOrderSize( _
   ByVal searchSize As Long _
)

Parameters

searchSize
The size of the search order collection.

Remarks

See Also


SetFilterCaseSensitive Method

SetFilterCaseSensitive Method
FilterName
A string value which represents the filter name.
FilterCaseSensitive
A boolean value to set to True to make the filter case sensitive. Set to False so the filter is not case sensitive.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : SetFilterCaseSensitive Method

Glossary Item Box

Description

Sets the filename matching case sensitivity enabled value for the specified filter.

Syntax

Visual Basic
Public Sub SetFilterCaseSensitive( _
   ByVal FilterName As String, _
   ByVal FilterCaseSensitive As Boolean _
)

Parameters

FilterName
A string value which represents the filter name.
FilterCaseSensitive
A boolean value to set to True to make the filter case sensitive. Set to False so the filter is not case sensitive.

See Also


SetFilterComparison Method

SetFilterComparison Method
FilterName
A string value which represents the filter name.
eFilterComparison
A TN_FilterComparison enumeration value.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : SetFilterComparison Method

Glossary Item Box

Description

Sets the comparison criteria for the specified filter.

Syntax

Visual Basic
Public Sub SetFilterComparison( _
   ByVal FilterName As String, _
   ByVal eFilterComparison As TN_FilterComparison _
)

Parameters

FilterName
A string value which represents the filter name.
eFilterComparison
Value | Description
TN_Equal | 2 - Use Equals
TN_GreaterThan | 4 - Use Greater Than.
TN_GreaterThanEquals | 3 - Use Greater Than or Equals.
TN_LessThan | 0 - Use Less Than
TN_LessThanEquals | 1 - Use Less Than or Equals
A TN_FilterComparison enumeration value.

See Also


SetFilterDate Method

SetFilterDate Method
FilterName
A string value which represents the filter name.
vFilterDate
A variant which represents the filter date.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : SetFilterDate Method

Glossary Item Box

Description

Sets the date criteria for the specified filter.

Syntax

Visual Basic
Public Sub SetFilterDate( _
   ByVal FilterName As String, _
   ByVal vFilterDate As Variant _
)

Parameters

FilterName
A string value which represents the filter name.
vFilterDate
A variant which represents the filter date.

See Also


SetFilterEnabled Method

SetFilterEnabled Method
FilterName
A string value which represents the filter name.
FilterEnabled
A boolean value which is True to set the filter to enabled. Otherwise, False should be set.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : SetFilterEnabled Method

Glossary Item Box

Description

Sets the enabled status of the specified filter.

Syntax

Visual Basic
Public Sub SetFilterEnabled( _
   ByVal FilterName As String, _
   ByVal FilterEnabled As Boolean _
)

Parameters

FilterName
A string value which represents the filter name.
FilterEnabled
A boolean value which is True to set the filter to enabled. Otherwise, False should be set.

See Also


SetFilterFilenamePattern Method

SetFilterFilenamePattern Method
FilterName
A string value which represents the filter name.
FilenamePattern
A string value which represents the filename pattern.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : SetFilterFilenamePattern Method

Glossary Item Box

Description

Sets the filename matching pattern criteria for the specified filter.

Syntax

Visual Basic
Public Sub SetFilterFilenamePattern( _
   ByVal FilterName As String, _
   ByVal FilenamePattern As String _
)

Parameters

FilterName
A string value which represents the filter name.
FilenamePattern
A string value which represents the filename pattern.

See Also


SetFilterIncludeHidden Method

SetFilterIncludeHidden Method
FilterName
A string value which represents the filter name.
FilterIncludeHidden
A boolean value which should be set to True to include hidden values for the filter. Otherwise, False should be set.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : SetFilterIncludeHidden Method

Glossary Item Box

Description

Sets the file attributes include hidden files enabled value for the specified filter.

Syntax

Visual Basic
Public Sub SetFilterIncludeHidden( _
   ByVal FilterName As String, _
   ByVal FilterIncludeHidden As Boolean _
)

Parameters

FilterName
A string value which represents the filter name.
FilterIncludeHidden
A boolean value which should be set to True to include hidden values for the filter. Otherwise, False should be set.

See Also


SetFilterIncludeParentDirectory Method

SetFilterIncludeParentDirectory Method
FilterName
A string value which represents the filter name.
FilterIncludeParentDirectory
A boolean value which should be set to True to include the parent directory for the given filter.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : SetFilterIncludeParentDirectory Method

Glossary Item Box

Description

Sets the file attributes include parent directory enabled value for the specified filter.

Syntax

Visual Basic
Public Sub SetFilterIncludeParentDirectory( _
   ByVal FilterName As String, _
   ByVal FilterIncludeParentDirectory As Boolean _
)

Parameters

FilterName
A string value which represents the filter name.
FilterIncludeParentDirectory
A boolean value which should be set to True to include the parent directory for the given filter.

See Also


SetFilterIncludeSubDirectory Method

SetFilterIncludeSubDirectory Method
FilterName
A string which represents the filter.
FilterIncludeSubDirectory
A boolean value which should be set to True to include the sub directory for the filter. Otherwise, False should be set.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : SetFilterIncludeSubDirectory Method

Glossary Item Box

Description

Sets the file attributes include sub directory enabled value for the specified filter.

Syntax

Visual Basic
Public Sub SetFilterIncludeSubDirectory( _
   ByVal FilterName As String, _
   ByVal FilterIncludeSubDirectory As Boolean _
)

Parameters

FilterName
A string which represents the filter.
FilterIncludeSubDirectory
A boolean value which should be set to True to include the sub directory for the filter. Otherwise, False should be set.

See Also


SetFilterMatchAppliesToDirectory Method

SetFilterMatchAppliesToDirectory Method
FilterName
A string value which represents the filter.
FilterMatchAppliesToDirectory
A boolean value which should be True to set the given filter to match applies to directory. Otherwise, False should be used.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : SetFilterMatchAppliesToDirectory Method

Glossary Item Box

Description

Sets name pattern applies to directory enabled value for the specified filter.

Syntax

Visual Basic
Public Sub SetFilterMatchAppliesToDirectory( _
   ByVal FilterName As String, _
   ByVal FilterMatchAppliesToDirectory As Boolean _
)

Parameters

FilterName
A string value which represents the filter.
FilterMatchAppliesToDirectory
A boolean value which should be True to set the given filter to match applies to directory. Otherwise, False should be used.

See Also


SetFilterName Method

SetFilterName Method
CurrentName
A string value which represents the current filter name.
NewName
A string value which represents the new filter name.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : SetFilterName Method

Glossary Item Box

Description

Renames an existing filter.

Syntax

Visual Basic
Public Sub SetFilterName( _
   ByVal CurrentName As String, _
   ByVal NewName As String _
)

Parameters

CurrentName
A string value which represents the current filter name.
NewName
A string value which represents the new filter name.

See Also


SetFilterSize Method

SetFilterSize Method
FilterName
A string value which represents the filter.
FilterSize
A long value which represents the filter size.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : SetFilterSize Method

Glossary Item Box

Description

Sets the file size criteria for the specified filter.

Syntax

Visual Basic
Public Sub SetFilterSize( _
   ByVal FilterName As String, _
   ByVal FilterSize As Long _
)

Parameters

FilterName
A string value which represents the filter.
FilterSize
A long value which represents the filter size.

See Also


SetFilterType Method

SetFilterType Method
FilterName
A string value which represents the filter name.
eFilterType
A TN_FilterType enumeration value.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : SetFilterType Method

Glossary Item Box

Description

Sets the type for the specified filter.

Syntax

Visual Basic
Public Sub SetFilterType( _
   ByVal FilterName As String, _
   ByVal eFilterType As TN_FilterType _
)

Parameters

FilterName
A string value which represents the filter name.
eFilterType
Value | Description
TN_FileAttributes | 1 - Use the source file attributes.
TN_FileCreationDate | 2 - Use the source file creation date.
TN_FileModificationDate | 3 - Use the source file modification date.
TN_Filename | 0 - Use the source filename.
TN_FileSize | 4 - Use the source file file size.
TN_SupportedFileType | 5 - Use the source file file type.
A TN_FilterType enumeration value.

See Also


SetItemAnnotations Method

SetItemAnnotations Method
ItemIndex
The thumbnail item specified.
AnnotationData
The annotation data.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : SetItemAnnotations Method

Glossary Item Box

Description

Sets the annotations for the specified thumbnail item.

Syntax

Visual Basic
Public Sub SetItemAnnotations( _
   ByVal ItemIndex As Long, _
   ByVal AnnotationData As Variant _
)

Parameters

ItemIndex
The thumbnail item specified.
AnnotationData
The annotation data.

Remarks

This method is designed to load annotation data from the GetAnnIntoVariantForThumbnail() method of
NotateXpress. Note: NotateXpress is a separate control from ThumbnailXpress.

See Also


SetItemCadLayoutNumber Method

SetItemCadLayoutNumber Method
ItemIndex
A long value which represents the index location for the item.
CadLayoutNumber
A long value which represents the CAD layout number for the item.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : SetItemCadLayoutNumber Method

Glossary Item Box

Description

Sets the CAD layout number for the specified thumbnail item.

Syntax

Visual Basic
Public Sub SetItemCadLayoutNumber( _
   ByVal ItemIndex As Long, _
   ByVal CadLayoutNumber As Long _
)

Parameters

ItemIndex
A long value which represents the index location for the item.
CadLayoutNumber
A long value which represents the CAD layout number for the item.

See Also


SetItemCellBackColor Method

SetItemCellBackColor Method
ItemIndex
The index of the thumbnail item specified.
cellBackColor
The cell back color specified.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : SetItemCellBackColor Method

Glossary Item Box

Description

Sets the Cell Back Color for the specified thumbnail item.

Syntax

Visual Basic
Public Sub SetItemCellBackColor( _
   ByVal ItemIndex As Long, _
   ByVal cellBackColor As ULong _
)

Parameters

ItemIndex
The index of the thumbnail item specified.
cellBackColor
The cell back color specified.

Remarks

See Also


SetItemCellBorderColor Method

SetItemCellBorderColor Method
ItemIndex
The index of the thumbnail item specified.
CellBorderColor
The cell border color specified.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : SetItemCellBorderColor Method

Glossary Item Box

Description

Sets the Cell Border Color for the specified thumbnail item.

Syntax

Visual Basic
Public Sub SetItemCellBorderColor( _
   ByVal ItemIndex As Long, _
   ByVal CellBorderColor As ULong _
)

Parameters

ItemIndex
The index of the thumbnail item specified.
CellBorderColor
The cell border color specified.

Remarks

See Also


SetItemDescriptor Method

SetItemDescriptor Method
ItemIndex
Index of the thumbnail item.
Descriptor
String to describe thumbnail image.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : SetItemDescriptor Method

Glossary Item Box

Description

Set the descriptor text of the thumbnail item.

Syntax

Visual Basic
Public Sub SetItemDescriptor( _
   ByVal ItemIndex As Long, _
   ByVal Descriptor As String _
)

Parameters

ItemIndex
Index of the thumbnail item.
Descriptor
String to describe thumbnail image.

Remarks

New descriptor for the specified thumbnail item.

See Also


SetItemFilename Method

SetItemFilename Method
ItemIndex
A long value which represents the index of the thumbnail item to query.
Filename
A string value which represents the new filename for the specified thumbnail item.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : SetItemFilename Method

Glossary Item Box

Description

Sets the filename for the specified thumbnail item.

Syntax

Visual Basic
Public Sub SetItemFilename( _
   ByVal ItemIndex As Long, _
   ByVal Filename As String _
)

Parameters

ItemIndex
A long value which represents the index of the thumbnail item to query.
Filename
A string value which represents the new filename for the specified thumbnail item.

Remarks

Setting an item's Filename will cause the thumbnail item to be regenerated. Setting this will impact the ability of the thumbnail item list to be refreshed.

See Also


SetItemPage Method

SetItemPage Method
ItemIndex
A long value which represents the index of the thumbnail item to query.
Page
A long value which represents the page to be represented by the specified thumbnail item.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : SetItemPage Method

Glossary Item Box

Description

Sets the page number for the specified thumbnail item.

Syntax

Visual Basic
Public Sub SetItemPage( _
   ByVal ItemIndex As Long, _
   ByVal Page As Long _
)

Parameters

ItemIndex
A long value which represents the index of the thumbnail item to query.
Page
A long value which represents the page to be represented by the specified thumbnail item.

Remarks

Sets the page in the image file that the thumbnail item is to represent. The page number is 1-based, with the default page = 1. If you do not have an ImageXpress license which supports multi-page image files, you will not be able to display thumbnails for items where the page value is greater than 1. The Standard version of ImagXpress is the only version that does not support multi-page images.

See Also


SetItemPDFPassword Method

SetItemPDFPassword Method
ItemIndex
A long value which represents the index of the thumbnail item.
PDFPassword
A string value which represents the PDF password.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : SetItemPDFPassword Method

Glossary Item Box

Description

Sets the PDF password for the specified thumbnail item

Syntax

Visual Basic
Public Sub SetItemPDFPassword( _
   ByVal ItemIndex As Long, _
   ByVal PDFPassword As String _
)

Parameters

ItemIndex
A long value which represents the index of the thumbnail item.
PDFPassword
A string value which represents the PDF password.

Remarks

The PDF password is used for accessing single PDF files when a thumbnail item is a known PDF with a password.

See Also


SetItemPDFRepair Method

SetItemPDFRepair Method
ItemIndex
Specifies the index of the thumbnail item to query.
PDFRepair
Specifies how to set the repair flag.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : SetItemPDFRepair Method

Glossary Item Box

Description

Sets the PDF file repair for the specified thumbnail item.

Syntax

Visual Basic
Public Sub SetItemPDFRepair( _
   ByVal ItemIndex As Long, _
   ByVal PDFRepair As Boolean _
)

Parameters

ItemIndex
Specifies the index of the thumbnail item to query.
PDFRepair
Specifies how to set the repair flag.

Remarks

See Also


SetItemUserTag Method

SetItemUserTag Method
ItemIndex
A long value which represents the index location for the item.
newVal
A variant value which represents the new value for the user tag.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : SetItemUserTag Method

Glossary Item Box

Description

Sets the variant user data associated with the specified thumbnail item.

Syntax

Visual Basic
Public Sub SetItemUserTag( _
   ByVal ItemIndex As Long, _
   ByVal newVal As Variant _
)

Parameters

ItemIndex
A long value which represents the index location for the item.
newVal
A variant value which represents the new value for the user tag.

See Also


SetIXOEMLicenseKey Method

SetIXOEMLicenseKey Method
newVal
The OEM license key for ImagXpress required for OEM licensing.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : SetIXOEMLicenseKey Method

Glossary Item Box

Description

Sets the ImagXpress runtime OEM license key.

Syntax

Visual Basic
Public Sub SetIXOEMLicenseKey( _
   ByVal newVal As String _
)

Parameters

newVal
The OEM license key for ImagXpress required for OEM licensing.

Remarks

When OEM runtime licenses are purchased, the OEM license key for ImagXpress is provided in the purchase confirmation email.

See Also


SetIXSolutionKey Method

SetIXSolutionKey Method
key1
Unlock key 1
key2
Unlock key 2
key3
Unlock key 3
key4
Unlock key 4
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : SetIXSolutionKey Method

Glossary Item Box

Description

Sets the ImagXpress runtime license deployment solution key.

Syntax

Visual Basic
Public Sub SetIXSolutionKey( _
   ByVal key1 As Long, _
   ByVal key2 As Long, _
   ByVal key3 As Long, _
   ByVal key4 As Long _
)

Parameters

key1
Unlock key 1
key2
Unlock key 2
key3
Unlock key 3
key4
Unlock key 4

Remarks

This is the solution key for ImagXpress required for all runtime licensing. The four integers are provided at the time of purchase of the runtime licenses along with the solution name for ImagXpress, which is set with the SetIXSolutionName method.

See Also


SetIXSolutionName Method

SetIXSolutionName Method
newVal
The solution name.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : SetIXSolutionName Method

Glossary Item Box

Description

Sets the ImagXpress runtime license deployment solution name.

Syntax

Visual Basic
Public Sub SetIXSolutionName( _
   ByVal newVal As String _
)

Parameters

newVal
The solution name.

Remarks

This is the name of the runtime license solution for ImagXpress. The ImagXpress solution name is provided in the purchase confirmation email when runtime licenses are purchased.

See Also


SetLoadFromMemoryEventItemImageBlob Method

SetLoadFromMemoryEventItemImageBlob Method
LoadFromMemoryEventItemID
A long value which represents the memory event item ID.
BlobImageData
A Variant which represents the image data blob.
BlobSize
A long value which represents the blob size.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : SetLoadFromMemoryEventItemImageBlob Method

Glossary Item Box

Description

Provides for supplying a Variant containing an image memory blob during an item LoadFromMemory event.

Syntax

Visual Basic
Public Sub SetLoadFromMemoryEventItemImageBlob( _
   ByVal LoadFromMemoryEventItemID As Long, _
   ByVal BlobImageData As Variant, _
   ByVal BlobSize As Long _
)

Parameters

LoadFromMemoryEventItemID
A long value which represents the memory event item ID.
BlobImageData
A Variant which represents the image data blob.
BlobSize
A long value which represents the blob size.

See Also

ThumbnailXpress Object | ThumbnailXpress Members | LoadFromMemory Event


SetLoadFromMemoryEventItemImageBuffer Method

SetLoadFromMemoryEventItemImageBuffer Method
LoadFromMemoryEventItemID
A long value which represents the memory event item ID.
pImageMemoryBuffer
A Variant which represents the image data buffer.
ImageBufferSize
A long value which represents the buffer size.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : SetLoadFromMemoryEventItemImageBuffer Method

Glossary Item Box

Description

Provides for supplying a Variant containing an image memory buffer during an item LoadFromMemory event.

Syntax

Visual Basic
Public Sub SetLoadFromMemoryEventItemImageBuffer( _
   ByVal LoadFromMemoryEventItemID As Long, _
   ByRef pImageMemoryBuffer As Byte, _
   ByVal ImageBufferSize As Long _
)

Parameters

LoadFromMemoryEventItemID
A long value which represents the memory event item ID.
pImageMemoryBuffer
A Variant which represents the image data buffer.
ImageBufferSize
A long value which represents the buffer size.

See Also

ThumbnailXpress Object | ThumbnailXpress Members | LoadFromMemory Event


SetOEMLicenseKey Method

SetOEMLicenseKey Method
newVal
The OEM license key required for OEM licensing.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : SetOEMLicenseKey Method

Glossary Item Box

Description

Sets the control runtime OEM license key.

Syntax

Visual Basic
Public Sub SetOEMLicenseKey( _
   ByVal newVal As String _
)

Parameters

newVal
The OEM license key required for OEM licensing.

Remarks

When OEM runtime licenses are purchased, the OEM license key is provided in the purchase confirmation email.

See Also


SetPDFXLicenseCodes Method

SetPDFXLicenseCodes Method
PW0

Unlock code 0 from the licensing information you received when you purchased a runtime license for PDFXpress.

PW1

Unlock code 1 from the licensing information you received when you purchased a runtime license for PDFXpress.

PW2

Unlock code 2 from the licensing information you received when you purchased a runtime license for PDFXpress.

PW3

Unlock code 3 from the licensing information you received when you purchased a runtime license for PDFXpress.

AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : SetPDFXLicenseCodes Method

Glossary Item Box

Description

Sets the PDFXpress license codes.

Syntax

Visual Basic
Public Sub SetPDFXLicenseCodes( _
   ByVal PW0 As Long, _
   ByVal PW1 As Long, _
   ByVal PW2 As Long, _
   ByVal PW3 As Long _
)

Parameters

PW0

Unlock code 0 from the licensing information you received when you purchased a runtime license for PDFXpress.

PW1

Unlock code 1 from the licensing information you received when you purchased a runtime license for PDFXpress.

PW2

Unlock code 2 from the licensing information you received when you purchased a runtime license for PDFXpress.

PW3

Unlock code 3 from the licensing information you received when you purchased a runtime license for PDFXpress.

Remarks

Before you can call this method to set the PDFXpress license codes, you must first tell the ThumbnailXpress component which version of PDFXpress you will be using by setting either the UsePDFXpress4 or UsePDFXpress3 property to True.

See Also


SetSolutionKey Method

SetSolutionKey Method
key1
Unlock key 1
key2
Unlock key 2
key3
Unlock key 3
key4
Unlock key 4
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : SetSolutionKey Method

Glossary Item Box

Description

Sets the control runtime license deployment solution key.

Syntax

Visual Basic
Public Sub SetSolutionKey( _
   ByVal key1 As Long, _
   ByVal key2 As Long, _
   ByVal key3 As Long, _
   ByVal key4 As Long _
)

Parameters

key1
Unlock key 1
key2
Unlock key 2
key3
Unlock key 3
key4
Unlock key 4

Remarks

This is the solution key required for all runtime licensing. The four integers are provided at the time of purchase of the runtime licenses along with the solution name, which is set with the SetSolutionName method.

See Also


SetSolutionName Method

SetSolutionName Method
newVal
The solution name.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : SetSolutionName Method

Glossary Item Box

Description

Sets the control runtime license deployment solution name.

Syntax

Visual Basic
Public Sub SetSolutionName( _
   ByVal newVal As String _
)

Parameters

newVal
The solution name.

Remarks

This is the name of the runtime license solution. The solution name is provided in the purchase confirmation email when runtime licenses are purchased.

See Also


ShowScrollBar Method

ShowScrollBar Method
Show
A boolean value which is True to display the scroll bar. Otherwise, False is used.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : ShowScrollBar Method

Glossary Item Box

Description

Shows or hides the scroll bar.

Syntax

Visual Basic
Public Sub ShowScrollBar( _
   ByVal Show As Boolean _
)

Parameters

Show
A boolean value which is True to display the scroll bar. Otherwise, False is used.

See Also


BackColor Property

BackColor Property
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : BackColor Property

Glossary Item Box

Description

Gets and sets the background color for the control.

Property Type

Read-write property

Syntax

Visual Basic
Public Property BackColor As OLE_COLOR

Return Type

A OLE_COLOR value which represents the background color.

Remarks

The default value is white (&H00FFFFFF&).

See Also


BorderStyle Property

BorderStyle Property
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : BorderStyle Property

Glossary Item Box

Description

Gets or sets the border style.

Property Type

Read-write property

Syntax

Visual Basic
Public Property BorderStyle As TN_BorderStyle

Return Type

A TN_BorderStyle enumeration value which determines the border style.

Remarks

The default value is 2 - TN_BorderFixed3D.

See Also


BottomMargin Property

BottomMargin Property
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : BottomMargin Property

Glossary Item Box

Description

Gets or sets the bottom margin in pixels.

Property Type

Read-write property

Syntax

Visual Basic
Public Property BottomMargin As Long

Return Type

A long value which represents the bottom margin in pixels.

Remarks

The default value is 5 pixels.

The LeftMargin, TopMargin, RightMargin, BottomMargin properties control how much space is reserved in the client area of the control, which will not have any thumbnail items drawn in it. The area between the edge, extending toward the center of the control by the number of units specified by this value, will always be painted using the background color, and will not have thumbnail items drawn in it.

See Also

ThumbnailXpress Object | ThumbnailXpress Members | LeftMargin Property | RightMargin Property | TopMargin Property


CacheMemoryLimit Property

CacheMemoryLimit Property
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : CacheMemoryLimit Property

Glossary Item Box

Description

Gets or sets access to the memory cache limit.

Property Type

Read-write property

Syntax

Visual Basic
Public Property CacheMemoryLimit As Long

Return Type

A long value which represents the memory cache limit.

Remarks

Changing the CacheMemoryLimit can cause the cache to be partially or entirely cleared and the cache file reconstructed.

Note: It is best to set this property when the application initializes only.

See Also

ThumbnailXpress Object | ThumbnailXpress Members | EmptyCache Method


CameraRawEnabled Property

CameraRawEnabled Property
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : CameraRawEnabled Property

Glossary Item Box

Description

Gets or sets access to enabling or disabling CameraRaw image format support during thumbnail image generation.

Property Type

Read-write property

Syntax

Visual Basic
Public Property CameraRawEnabled As Boolean

Return Type

A boolean value which is True to enable CameraRaw image format support. Otherwise, False should be used and CameraRaw image support is not enabled.

Remarks

Note: CameraRaw enablement support also requires that the ImagXpress License be set to Photo.

See Also

ThumbnailXpress Object | ThumbnailXpress Members | TN_IXLicenseEdition Enumeration


CameraRawThumbnailEnabled Property

CameraRawThumbnailEnabled Property
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : CameraRawThumbnailEnabled Property

Glossary Item Box

Description

Returns/sets if the embedded thumbnail of the camera raw image is used or the full-size image.

Property Type

Read-write property

Syntax

Visual Basic
Public Property CameraRawThumbnailEnabled As Boolean

Return Type

A Boolean value that is true when the thumbnail is used; false otherwise.

See Also


CellBorderColor Property

CellBorderColor Property
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : CellBorderColor Property

Glossary Item Box

Description

Gets or sets access to the border color of the cells in the control.

Property Type

Read-write property

Syntax

Visual Basic
Public Property CellBorderColor As OLE_COLOR

Return Type

A Ulong value which represents the border color of the cells in the control.

Remarks

The default value is black.

See Also


CellBorderWidth Property

CellBorderWidth Property
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : CellBorderWidth Property

Glossary Item Box

Description

Gets or sets access to the width of the cells in the control.

Property Type

Read-write property

Syntax

Visual Basic
Public Property CellBorderWidth As Long

Return Type

A long value which represents the width of the borders of the cells in the control.

Remarks

The default value is 1 pixel.

See Also


CellHeight Property

CellHeight Property
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : CellHeight Property

Glossary Item Box

Description

Gets or sets access to the height of the cells in the control.

Property Type

Read-write property

Syntax

Visual Basic
Public Property CellHeight As Long

Return Type

A long value which represents the height of the cells in the control.

Remarks

Thumbnail cells default to 80 by 80 pixels square.

See Also


CellHorizontalSpacing Property

CellHorizontalSpacing Property
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : CellHorizontalSpacing Property

Glossary Item Box

Description

Gets or sets access to the horizontal spacing between cells.

Property Type

Read-write property

Syntax

Visual Basic
Public Property CellHorizontalSpacing As Long

Return Type

A long value which represents the horizontal spacing between cells.

Remarks

The default value is 5 pixels.

See Also


CellSpacingColor Property

CellSpacingColor Property
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : CellSpacingColor Property

Glossary Item Box

Description

Gets or sets the cell spacing color.

Property Type

Read-write property

Syntax

Visual Basic
Public Property CellSpacingColor As OLE_COLOR

Return Type

An OLE_COLOR value which represents the cell spacing color.

See Also


CellVerticalSpacing Property

CellVerticalSpacing Property
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : CellVerticalSpacing Property

Glossary Item Box

Description

Gets or sets access to the vertical spacing between cells.

Property Type

Read-write property

Syntax

Visual Basic
Public Property CellVerticalSpacing As Long

Return Type

A long value which represents the vertical spacing between cells.

Remarks

The default value is 5 pixels.

See Also


CellWidth Property

CellWidth Property
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : CellWidth Property

Glossary Item Box

Description

Gets or sets access to the width of the cells in the control.

Property Type

Read-write property

Syntax

Visual Basic
Public Property CellWidth As Long

Return Type

A long value which represents the width of the cells in the control.

Remarks

Thumbnail cells default to 80 by 80 pixels square.

See Also


CustomErrorIcon Property

CustomErrorIcon Property
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : CustomErrorIcon Property

Glossary Item Box

Description

Returns/sets the icon to use for errors instead of the stock error icon. ErrorAction must be set to 0 - use error icon.

Property Type

Read-write property

Syntax

Visual Basic
Public Property CustomErrorIcon As Long

Return Type

The custom error icon.

See Also


CustomGeneratingIcon Property

CustomGeneratingIcon Property
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : CustomGeneratingIcon Property

Glossary Item Box

Description

Returns/sets the icon to use for the pre-image generation placeholder instead of the stock 'generating' icon. ShowImagePlaceHolders must be set to true.

Property Type

Read-write property

Syntax

Visual Basic
Public Property CustomGeneratingIcon As Long

Return Type

The custom generating icon.

See Also


DblClickDirectoryDrillDown Property

DblClickDirectoryDrillDown Property
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : DblClickDirectoryDrillDown Property

Glossary Item Box

Description

Gets or sets an indicator whether mouse double-clicks over directory folder icons should display the images in the clicked directory.

Property Type

Read-write property

Syntax

Visual Basic
Public Property DblClickDirectoryDrillDown As Boolean

Return Type

A boolean value which is True to display images based on mouse double-clicks.

See Also


Debug Property

Debug Property
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : Debug Property

Glossary Item Box

Description

Gets or sets an indicator to write debug information into the DebugLogFile.

Property Type

Read-write property

Syntax

Visual Basic
Public Property Debug As Boolean

Return Type

A boolean value which is True to write debug information to the DebugLogFile. Otherwise, False should be used and no information is written to the DebugLogFile.

Remarks

The default value is False.

See Also

ThumbnailXpress Object | ThumbnailXpress Members | DebugErrorLevel Property | DebugLogFile Property | TN_DebugErrorLevel Enumeration


DebugErrorLevel Property

DebugErrorLevel Property
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : DebugErrorLevel Property

Glossary Item Box

Description

Gets or sets access to the level of detail written to the error log.

Property Type

Read-write property

Syntax

Visual Basic
Public Property DebugErrorLevel As TN_DebugErrorLevel

Return Type

A TN_DebugErrorLevel enumeration value which determines the level of debug information written to the DebugLogFile.

Remarks

The default value is TN_Production.

See Also

ThumbnailXpress Object | ThumbnailXpress Members | Debug Property | DebugLogFile Property | TN_DebugErrorLevel Enumeration


DebugLogFile Property

DebugLogFile Property
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : DebugLogFile Property

Glossary Item Box

Description

Gets or sets access to the log file location.

Property Type

Read-write property

Syntax

Visual Basic
Public Property DebugLogFile As String

Return Type

A string value which represents the log file location and name.

See Also

ThumbnailXpress Object | ThumbnailXpress Members | Debug Property | DebugErrorLevel Property | TN_DebugErrorLevel Enumeration


DescriptorDisplayMethod Property

DescriptorDisplayMethod Property
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : DescriptorDisplayMethod Property

Glossary Item Box

Description

Gets or sets access to the method allowing selection of the source of descriptor text content.

Property Type

Read-write property

Syntax

Visual Basic
Public Property DescriptorDisplayMethod As TN_DescriptorFormat

Return Type

A TN_DescriptorFormat enumeration value which determines the descriptor format.

Remarks

The default value is to use the descriptor text applied with the SetItemDescriptor Method if it exists, or the short filename.

See Also

ThumbnailXpress Object | ThumbnailXpress Members | DescriptorVerticalAlignment Property | SetItemDescriptor Method | TN_DescriptorFormat Enumeration


DescriptorHorizontalAlignment Property

DescriptorHorizontalAlignment Property
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : DescriptorHorizontalAlignment Property

Glossary Item Box

Description

Gets or sets the horizontal alignment of the descriptor text.

Property Type

Read-write property

Syntax

Visual Basic
Public Property DescriptorHorizontalAlignment As TN_DescriptorHorizontalAlignment

Return Type

A TN_DescriptorHorizontalAlignment enumeration value which determines the horizontal alignment of the descriptor text.

Remarks

The default value is 1 - align center.

See Also

ThumbnailXpress Object | ThumbnailXpress Members | TN_DescriptorHorizontalAlignment Enumeration


DescriptorVerticalAlignment Property

DescriptorVerticalAlignment Property
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : DescriptorVerticalAlignment Property

Glossary Item Box

Description

Gets or sets the vertical alignment of the descriptor text.

Property Type

Read-write property

Syntax

Visual Basic
Public Property DescriptorVerticalAlignment As TN_DescriptorVerticalAlignment

Return Type

A TN_DescriptorVerticalAlignment enumeration value which determines the vertical alignment of the descriptor text.

Remarks

The default value is 2 - align bottom.

See Also

ThumbnailXpress Object | ThumbnailXpress Members | TN_DescriptorVerticalAlignment Enumeration | TN_DescriptorHorizontalAlignment Enumeration


EnableAsDragSourceForExternalDragDrop Property

EnableAsDragSourceForExternalDragDrop Property
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : EnableAsDragSourceForExternalDragDrop Property

Glossary Item Box

Description

Gets or sets an indicator whether drag and drop source thumbnails is enabled on other applications.

Property Type

Read-write property

Syntax

Visual Basic
Public Property EnableAsDragSourceForExternalDragDrop As Boolean

Return Type

A boolean value which is True to enable the component to drag thumbnail images to other applications. Otherwise, False is used.

Remarks

Any applications that support drag and drop format can be a thumbnail image drop recipient. Both copy and move operations are supported.

Note: According to Microsoft®, for security reasons, drag/drop capabilities are disallowed between windows with different security level permissions.

See Also


EnableAsDropTargetForExternalDragDrop Property

EnableAsDropTargetForExternalDragDrop Property
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : EnableAsDropTargetForExternalDragDrop Property

Glossary Item Box

Description

Gets or sets an indicator whether drag and drop target is enabled for other applications to drag files onto those files as thumbnail images.

Property Type

Read-write property

Syntax

Visual Basic
Public Property EnableAsDropTargetForExternalDragDrop As Boolean

Return Type

A boolean value which is True to enable the component to drag thumbnail images from other applications. Otherwise, False is used.

Remarks

Any applications that support drag and drop format can be a thumbnail image drag/drop recipient. Both copy and move operations are supported.

Note: According to Microsoft®, for security reasons, drag/drop capabilities are disallowed between windows with different security level permissions.

See Also


Enabled Property

Enabled Property
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : Enabled Property

Glossary Item Box

Description

Gets and sets a value that determines if ThumbnailXpress responds to user-generated events.

Property Type

Read-write property

Syntax

Visual Basic
Public Property Enabled As Boolean

Return Type

A boolean value which is True to enable accessing the filter status flag.

Remarks

The default value is True.

See Also


ErrorAction Property

ErrorAction Property
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : ErrorAction Property

Glossary Item Box

Description

Gets or sets the action to take on errors when adding thumbnail items.

Property Type

Read-write property

Syntax

Visual Basic
Public Property ErrorAction As TN_ErrorAction

Return Type

A TN_ErrorAction enumeration value which determines the type of display action taken when a thumbnail generation error occurs.

Remarks

The default value is 0 - use error icon.

See Also

ThumbnailXpress Object | ThumbnailXpress Members | TN_ErrorAction Enumeration


ErrorCode Property

ErrorCode Property
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : ErrorCode Property

Glossary Item Box

Description

Gets the error code from the most recent call.

Property Type

Read-write property

Syntax

Visual Basic
Public Property ErrorCode As Long

Return Type

A long value which represents the error number.

See Also

ThumbnailXpress Object | ThumbnailXpress Members | How To Debug


EvaluationMode Property

EvaluationMode Property
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : EvaluationMode Property

Glossary Item Box

Description

Gets or sets the type of evaluation mode.

Property Type

Read-write property

Syntax

Visual Basic
Public Property EvaluationMode As TN_EvaluationMode

Return Type

A TN_EvaluationMode enumeration value which determines the mode of operation during evaluation mode.

Remarks

The default value is 0 - use dialog.

In order to test the component in an application running as a service or other environments where the component does not have permissions to create a window, the application logic needs to set the EvaluationMode to Watermark. In this mode, the component does not attempt to create the Evaluation Mode dialog window, but permanently watermarks all image data passed through it.

When running your project with the ThumbnailXpress component in TN_Watermark mode under the Visual Basic 6 IDE, the component will still display the evaluation dialog box. However, setting the EvaluationMode property to TN_Watermark will allow your Visual Basic 6 compiled executable to properly watermark the image.

See Also

ThumbnailXpress Object | ThumbnailXpress Members | TN_EvaluationMode Enumeration


Font Property

Font Property
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : Font Property

Glossary Item Box

Description

Gets or sets the font for the ThumbnailXpress control.

Property Type

Read-write property

Syntax

Visual Basic
Public Property Font As Font

Remarks

The default value is MS Sans Serif.

The font property affects the display of the descriptor strings when the thumbnail items are painted in the control.

See Also


ForeColor Property

ForeColor Property
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : ForeColor Property

Glossary Item Box

Description

Gets or sets the foreground color for the ThumbnailXpress control Descriptor text.

Property Type

Read-write property

Syntax

Visual Basic
Public Property ForeColor As OLE_COLOR

Return Type

A Ulong value which represents the foreground color.

Remarks

The default value color is black.

See Also

ThumbnailXpress Object | ThumbnailXpress Members | DescriptorDisplayMethod Property


FTPPassword Property

FTPPassword Property
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : FTPPassword Property

Glossary Item Box

Description

Gets or sets the FTP password that is used for accessing files on the Internet when a thumbnail item's Filename property is set to an ftp or http address.

Property Type

Read-write property

Syntax

Visual Basic
Public Property FTPPassword As String

Return Type

A string value which represents the ftp password.

See Also


FTPUserName Property

FTPUserName Property
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : FTPUserName Property

Glossary Item Box

Description

Gets or sets the FTP user name that is used for accessing files on the Internet when a thumbnail item's Filename property is set to an ftp or http address.

Property Type

Read-write property

Syntax

Visual Basic
Public Property FTPUserName As String

Return Type

A string value which represents the ftp user name.

See Also


HWND Property

HWND Property
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : HWND Property

Glossary Item Box

Description

A stock, read-only property which is a handle to a window.

Property Type

Read-write property

Syntax

Visual Basic
Public Property HWND As Long

Return Type

A long value which represents a handle to a window.

Remarks

Returns a handle (from Microsoft Windows) to the ThumbnailXpress control's window.

See Also


InterComponentThumbnailDragDropEnabled Property

InterComponentThumbnailDragDropEnabled Property
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : InterComponentThumbnailDragDropEnabled Property

Glossary Item Box

Description

Gets or sets an indicator whether inter-component thumbnail drag drop moved or copied items are enabled.

Property Type

Read-write property

Syntax

Visual Basic
Public Property InterComponentThumbnailDragDropEnabled As Boolean

Return Type

A boolean value which is True to enable drag and drop within other instances of the component. Otherwise, False is used.

Remarks

Any applications that support drag and drop format can be a thumbnail image drag/drop recipient. Both copy and move operations are supported.

Note: According to Microsoft®, for security reasons, drag and drop capabilities are disallowed between windows with different security level permissions.

See Also


IntraComponentThumbnailDragDropEnabled Property

IntraComponentThumbnailDragDropEnabled Property
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : IntraComponentThumbnailDragDropEnabled Property

Glossary Item Box

Description

Gets or sets an indicator if intra-component thumbnail drag drop move operations are enabled.

Property Type

Read-write property

Syntax

Visual Basic
Public Property IntraComponentThumbnailDragDropEnabled As Boolean

Return Type

A boolean value which is True to enable drag and drop within the same instance of the component. Otherwise, False is used.

Remarks

Any applications that support drag and drop format can be a thumbnail image drag/drop recipient. Both copy and move operations are supported.

Note: According to Microsoft®, for security reasons, drag and drop capabilities are disallowed between windows with different security level permissions.

See Also


ItemCount Property

ItemCount Property
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : ItemCount Property

Glossary Item Box

Description

Gets the number of thumbnail items from the thumbnail items list.

Property Type

Read-write property

Syntax

Visual Basic
Public Property ItemCount As Long

Return Type

A long value which represents the number of thumbnail items.

Remarks

ItemCount reflects the number of items in the thumbnail item list, which is displayed in the thumbnail control.

See Also


LeftMargin Property

LeftMargin Property
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : LeftMargin Property

Glossary Item Box

Description

Gets or sets the left margin in pixels.

Property Type

Read-write property

Syntax

Visual Basic
Public Property LeftMargin As Long

Return Type

A long value which represents the left margin in pixels.

Remarks

The default value is 5 pixels.

The LeftMargin, TopMargin, RightMargin, BottomMargin properties control how much space is reserved in the client area of the control, which will not have any thumbnail items drawn in it. The area between the edge, extending toward the center of the control by the number of units specified by this value, will always be painted using the background color, and will not have thumbnail items drawn in it.

See Also

ThumbnailXpress Object | ThumbnailXpress Members | BottomMargin Property | TopMargin Property | RightMargin Property


MaximumThreadCount Property

MaximumThreadCount Property
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : MaximumThreadCount Property

Glossary Item Box

Description

Gets or sets the maximum thread count.

Property Type

Read-write property

Syntax

Visual Basic
Public Property MaximumThreadCount As Long

Remarks

The default value is 2.

The MaximumThreadCount property specifies the maximum number of threads that will be used to generate thumbnail items in the background, concurrent with the control window being painted. The thumbnail control will use up to this number of threads for generating thumbnail images, depending on how many processors the system has, and how much time is spent processing each thumbnail item.

See Also


MaximumThumbnailBitDepth Property

MaximumThumbnailBitDepth Property
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : MaximumThumbnailBitDepth Property

Glossary Item Box

Description

Gets or sets the maximum thumbnail bit-depth.

Property Type

Read-write property

Syntax

Visual Basic
Public Property MaximumThumbnailBitDepth As Long

Remarks

The default value is 24 bpp.

Valid values are 8 and 24.

The MaximumThumbnailBitDepth property controls the maximum color depth of the images generated to represent a thumbnail item in the control. For example, if the image is a 24-bit color image, and MaximumThumbnailBitDepth is 8, the thumbnail image that is displayed will only be an 8-bit device independent bitmap.

Reducing the bit depth conserves memory and increases the number of thumbnail items which can fit into the cache, but may produce a lower quality thumbnail bitmap.

See Also


NotateXpressInstance Property

NotateXpressInstance Property
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : NotateXpressInstance Property

Glossary Item Box

Description

The instance of NotateXpress, this should be set to the NotateXpress object's InstanceHandle property. Once set annotations can be drawn on thumbnails. Note: NotateXpress is a separate control.

Property Type

Read-write property

Syntax

Visual Basic
Public Property NotateXpressInstance As Long

Return Type

The instance of NotateXpress.

Remarks

This property is designed to be set to the value of the HandleInstance property of NotateXpress. It's used to enable annotation functionality for thumbnails. Note: NotateXpress is a separate control from ThumbnailXpress.

See Also


PDFPassword Property

PDFPassword Property
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : PDFPassword Property

Glossary Item Box

Description

Gets and sets the password for PDF format files.

Property Type

Read-write property

Syntax

Visual Basic
Public Property PDFPassword As String

Return Type

A string value which represents the password.

See Also


PDFRepair Property

PDFRepair Property
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : PDFRepair Property

Glossary Item Box

Description

Returns/sets the PDF file repair that is used for accessing single PDF files when a thumbnail item is a known PDF with errors.

Property Type

Read-write property

Syntax

Visual Basic
Public Property PDFRepair As Boolean

Return Type

A boolean value which is True to repair the PDF file while opening it. Otherwise, False is used, and the PDF file is not repaired.

See Also


PreserveBlackEnabled Property

PreserveBlackEnabled Property
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : PreserveBlackEnabled Property

Glossary Item Box

Description

Gets or sets whether preserve black is enabled.

Property Type

Read-write property

Syntax

Visual Basic
Public Property PreserveBlackEnabled As Boolean

Return Type

A boolean value which is True to preserve black in fine lines. Otherwise, False is used and black is not preserved.

Remarks

Controls the ImagXpress PreserveBlack property. Used to maintain fine lines when creating thumbnail images from black-and-white documents.

See Also


ProxyServer Property

ProxyServer Property
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : ProxyServer Property

Glossary Item Box

Description

Gets or sets a proxy server name or IP address.

Property Type

Read-write property

Syntax

Visual Basic
Public Property ProxyServer As String

Return Type

A string value which represents the name or IP address of an optional proxy server.

Remarks

A proxy server is optionally used to access internet resident image files through a local area network.

See Also


RaiseExceptions Property

RaiseExceptions Property
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : RaiseExceptions Property

Glossary Item Box

Description

The RaiseExceptions property controls how errors are reported to the application.

Property Type

Read-write property

Syntax

Visual Basic
Public Property RaiseExceptions As Boolean

Return Type

A boolean value which is True to raise exceptions. Otherwise, False should be used and exceptions are not raised.

Remarks

The default value is True.

Example

If RaiseExceptions is set to False, no exceptions are sent to the caller
via IErrorInfo; instead, the caller checks the ErrorCode property.

If RaiseExceptions is set to True, exceptions are sent via IErrorInfo
and the caller code can look like this:

Private Sub Command1_Click()
On Error Goto LocalError
ThumbnailXpress...
...
Exit Sub

LocalError:
' Do something here.
End Sub

See Also


RightMargin Property

RightMargin Property
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : RightMargin Property

Glossary Item Box

Description

Gets or sets the right margin in pixels.

Property Type

Read-write property

Syntax

Visual Basic
Public Property RightMargin As Long

Return Type

A long value which represents the right margin in pixels.

Remarks

The default value is 5 pixels.

The LeftMargin, TopMargin, RightMargin, BottomMargin properties control how much space is reserved in the client area of the control, which will not have any thumbnail items drawn in it. The area between the edge, extending toward the center of the control by the number of units specified by this value, will always be painted using the background color, and will not have thumbnail items drawn in it.

See Also

ThumbnailXpress Object | ThumbnailXpress Members | BottomMargin Property | LeftMargin Property | TopMargin Property


ScrollDirection Property

ScrollDirection Property
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : ScrollDirection Property

Glossary Item Box

Description

Gets or sets the scroll direction.

Property Type

Read-write property

Syntax

Visual Basic
Public Property ScrollDirection As TN_ScrollDirection

Return Type

A TN_ScrollDirection enumeration value which determines the scroll direction.

Remarks

The default value is vertical.

The ScrollDirection property controls how the thumbnail items are arranged in the control, which scrollbars will be displayed and how the items will be scrolled in the control window. If the ScrollDirection property is set to Vertical, the control will display a vertical scrollbar. Setting the ScrollDirection property to Horizontal will display a horizontal scrollbar. The control manages the display and updates the scrollbar so the application does not need to.

See Also

ThumbnailXpress Object | ThumbnailXpress Members | TN_ScrollDirection Enumeration


SelectBackColor Property

SelectBackColor Property
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : SelectBackColor Property

Glossary Item Box

Description

Gets or sets the cell background color used for selected thumbnail items.

Property Type

Read-write property

Syntax

Visual Basic
Public Property SelectBackColor As OLE_COLOR

Return Type

A Ulong value which represents the cell background color used for selected thumbnail items.

Remarks

Set to default Windows background color used for desktop color theme.

See Also


SelectedItemCount Property

SelectedItemCount Property
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : SelectedItemCount Property

Glossary Item Box

Description

Gets the number of selected thumbnail items.

Property Type

Read-write property

Syntax

Visual Basic
Public Property SelectedItemCount As Long

Return Type

A long value which represents the number of selected thumbnail items.

See Also

ThumbnailXpress Object | ThumbnailXpress Members | SelectionMode Property | TN_SelectionMode Enumeration


SelectionMode Property

SelectionMode Property
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : SelectionMode Property

Glossary Item Box

Description

Gets or sets the selection mode.

Property Type

Read-write property

Syntax

Visual Basic
Public Property SelectionMode As TN_SelectionMode

Return Type

A TN_SelectionMode enumeration value which determines the selection mode.

Remarks

The default value is 3: Multi-extended.

See Also

ThumbnailXpress Object | ThumbnailXpress Members | SelectedItemCount Property | TN_SelectionMode Enumeration


ShowImagePlaceholders Property

ShowImagePlaceholders Property
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : ShowImagePlaceholders Property

Glossary Item Box

Description

Gets or sets whether a placeholder image is drawn while waiting for the thumbnail to be generated.

Property Type

Read-write property

Syntax

Visual Basic
Public Property ShowImagePlaceholders As Boolean

Return Type

A boolean value which is True to draw a placeholder image while the thumbnail is generated. Otherwise, False should be used and a placeholder image is not drawn.

Remarks

The default value is False.

See Also


TextBackColor Property

TextBackColor Property
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : TextBackColor Property

Glossary Item Box

Description

Gets or sets the descriptor text background color.

Property Type

Read-write property

Syntax

Visual Basic
Public Property TextBackColor As OLE_COLOR

Return Type

A Ulong value which represents the descriptor text background color.

See Also


ThreadHungThreshold Property

ThreadHungThreshold Property
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : ThreadHungThreshold Property

Glossary Item Box

Description

Gets or sets the maximum amount of time (in milliseconds) a thread will spend generating an image representing a thumbnail item, before it should abandon the generation.

Property Type

Read-write property

Syntax

Visual Basic
Public Property ThreadHungThreshold As Long

Return Type

A long value which represents the maximum amount of time a thread spends generating an image representing a thumbnail item.

Remarks

The default value is 9 seconds.

On legacy equipment, this value may need to be increased.

The minimum value enforced to be at least twice the value of ThreadStartThreshold Property

See Also

ThumbnailXpress Object | ThumbnailXpress Members | ThreadStartThreshold Property | MaximumThreadCount Property


ThreadStartThreshold Property

ThreadStartThreshold Property
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : ThreadStartThreshold Property

Glossary Item Box

Description

Gets or sets the amount of time (in milliseconds) a thread will spend generating an image representing a thumbnail item, before it should start an additional thread generating images representing thumbnail items.

Property Type

Read-write property

Syntax

Visual Basic
Public Property ThreadStartThreshold As Long

Return Type

A long value which represents the amount of time a thread will spend generating an image for a thumbnail before it starts an additional thread.

Remarks

The default value is 3,000 milli-seconds.

The enforced value range will be 100 through 1/2 of the ThreadHungThreshold value.

A request for a thumbnail beyond the elapsed time threshold (in milliseconds) is considered "extended duration". If other thumbnails are requested, ThumbnailXpress adjusts for "extended duration" requests by starting additional thumbnail generation threads. If the additional threads also exceed the "Extended Duration" Threshold, the control continues to start new threads until the ThreadHungThreshold Property is reached.

See Also

ThumbnailXpress Object | ThumbnailXpress Members | ThreadHungThreshold Property | MaximumThreadCount Property


TopMargin Property

TopMargin Property
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : TopMargin Property

Glossary Item Box

Description

Gets or sets the top margin in pixels.

Property Type

Read-write property

Syntax

Visual Basic
Public Property TopMargin As Long

Return Type

A long value which represents the top margin in pixels.

Remarks

The default value is 5 pixels.

The LeftMargin, TopMargin, RightMargin, BottomMargin properties control how much space is reserved in the client area of the control, which will not have any thumbnail items drawn in it. The area between the edge, extending toward the center of the control by the number of units specified by this value, will always be painted using the background color, and will not have thumbnail items drawn in it.

See Also

ThumbnailXpress Object | ThumbnailXpress Members | BottomMargin Property | LeftMargin Property | RightMargin Property


TopVisibleItem Property

TopVisibleItem Property
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : TopVisibleItem Property

Glossary Item Box

Description

Gets the thumbnail item which is visible in the top-left corner of the control window.

Property Type

Read-write property

Syntax

Visual Basic
Public Property TopVisibleItem As Long

Return Type

A long value which represents the top-left corner of the control window for the thumbnail item.

See Also


UsePDFXpress3 Property

UsePDFXpress3 Property
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : UsePDFXpress3 Property

Glossary Item Box

Description

This property has been deprecated and will be removed in the next version. Please use the UsePDFXpress4 Property instead.

Property Type

Read-write property

Syntax

Visual Basic
Public Property UsePDFXpress3 As Boolean

Return Type

A boolean value which is True to use PDF Xpress 3. Otherwise, False to not use PDF Xpress 3.

Remarks

The SetPDFXLicenseCodes method can be used to unlock PDF Xpress. The UsePDFXpress3 property must be set to True before calling the SetPDFXLicenseCodes method.

See Also


UsePDFXpress4 Property

UsePDFXpress4 Property
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : UsePDFXpress4 Property

Glossary Item Box

Description

Returns/sets whether to use PDF Xpress™ v4.x

Property Type

Read-write property

Syntax

Visual Basic
Public Property UsePDFXpress4 As Boolean

Return Type

A boolean value which is True to use PDF Xpress 4. Otherwise, False to not use PDF Xpress 4.

Remarks

The SetPDFXLicenseCodes method can be used to unlock PDF Xpress. The UsePDFXpress4 property must be set to True before calling the SetPDFXLicenseCodes method.

  • For 32-bit machines, the file should be distributed to the System32 directory.
  • For 64-bit machines, running their application in a 32-bit context the file should be distributed to the SysWow64 directory.
  • For 64-bit machines, running their applications in a 64-bit context, PDF support is unavailable from PDF Xpress in this context.
  • Alternatively, the file can be distributed to the application's directory.

See Also


Version Property

Version Property
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : Version Property

Glossary Item Box

Description

Returns the version of the ThumbnailXpress control at run-time.

Property Type

Read-write property

Syntax

Visual Basic
Public Property Version As String

Return Type

A string specifying the version of the ThumbnailXpress control.

See Also


VisibleColumnCount Property

VisibleColumnCount Property
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : VisibleColumnCount Property

Glossary Item Box

Description

Gets the number of columns of cells that are viewable in the control window.

Property Type

Read-write property

Syntax

Visual Basic
Public Property VisibleColumnCount As Long

Return Type

A long value which represents the number of columns of cells which are viewable in the control window.

Remarks

The VisibleColumnCount property provides a count of the number of cell columns which are visible in the control window. If the ScrollDirection property is set to Horizontal, this might include one partially displayed column. If the ScrollDirection property is set to Vertical, this property will contain the number of fully visible columns, since partially visible columns are only displayed when scrolling horizontally.

See Also

ThumbnailXpress Object | ThumbnailXpress Members | ScrollDirection Property


VisibleRowCount Property

VisibleRowCount Property
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : VisibleRowCount Property

Glossary Item Box

Description

Gets the number of rows of cells that are viewable in the control window.

Property Type

Read-write property

Syntax

Visual Basic
Public Property VisibleRowCount As Long

Return Type

A long value which represents the number of rows of cells which are viewable in the control window.

Remarks

The VisibleRowCount property provides a count of the number of cell rows which are visible in the control window. If the ScrollDirection property is set to Vertical, this might include one partially displayed row. If the ScrollDirection property is set to Horizontal, this property will contain the number of fully visible rows, since partially visible rows are only displayed when scrolling vertically.

See Also

ThumbnailXpress Object | ThumbnailXpress Members | ScrollDirection Property


Click Event

Click Event
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : Click Event

Glossary Item Box

Description

Called when a left mouse button is pressed.

Syntax

Visual Basic
Public Event Click()

See Also


DoubleClick Event

DoubleClick Event
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : DoubleClick Event

Glossary Item Box

Description

Called when a left mouse button is double clicked.

Syntax

Visual Basic
Public Event DoubleClick()

See Also


Error Event

Error Event
ItemIndex
A long value which represents the index item. The index is only valid if there are no additions or deletions to the thumbnail item collection prior to use of this index value.
ErrorNum
A long value which represents the error number.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : Error Event

Glossary Item Box

Description

Called when an error occurs during generation or painting of a thumbnail item.

Syntax

Visual Basic
Public Event Error( _
   ByVal ItemIndex As Long, _
   ByVal ErrorNum As Long _
)

Parameters

ItemIndex
A long value which represents the index item. The index is only valid if there are no additions or deletions to the thumbnail item collection prior to use of this index value.
ErrorNum
A long value which represents the error number.

Remarks

Note: You must call the EnableEvent method to enable this event.

See Also

ThumbnailXpress Object | ThumbnailXpress Members | How To Debug


ItemComplete Event

ItemComplete Event
ItemIndex
A long value which represents the index location within the Thumbnail Item Collection for which the thumbnail image generation has just completed.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : ItemComplete Event

Glossary Item Box

Description

Called when a thumbnail item's asynchronous image generation has been completed.

Syntax

Visual Basic
Public Event ItemComplete( _
   ByVal ItemIndex As Long _
)

Parameters

ItemIndex
A long value which represents the index location within the Thumbnail Item Collection for which the thumbnail image generation has just completed.

Remarks

Note: You must call the EnableEvent method to enable this event.

See Also


KeyDown Event

KeyDown Event
KeyCode
An integer value which represents the key code.
Shift
An integer value which represents the shift.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : KeyDown Event

Glossary Item Box

Description

Called on a key down action.

Syntax

Visual Basic
Public Event KeyDown( _
   ByVal KeyCode As Integer, _
   ByVal Shift As Integer _
)

Parameters

KeyCode
An integer value which represents the key code.
Shift
An integer value which represents the shift.

See Also


KeyPress Event

KeyPress Event
KeyAscii
An integer value which represents the ascii key.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : KeyPress Event

Glossary Item Box

Description

Called on a key press action.

Syntax

Visual Basic
Public Event KeyPress( _
   ByVal KeyAscii As Integer _
)

Parameters

KeyAscii
An integer value which represents the ascii key.

See Also


KeyUp Event

KeyUp Event
KeyCode
An integer value which represents the key code.
Shift
An integer value which represents the shift.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : KeyUp Event

Glossary Item Box

Description

Called on a key up action.

Syntax

Visual Basic
Public Event KeyUp( _
   ByVal KeyCode As Integer, _
   ByVal Shift As Integer _
)

Parameters

KeyCode
An integer value which represents the key code.
Shift
An integer value which represents the shift.

See Also


LoadFromMemory Event

LoadFromMemory Event
LoadFromMemoryItemID
A long value which represents the item ID from memory to load.
UserTag
A variant value which represents the user tag.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : LoadFromMemory Event

Glossary Item Box

Description

Called when loading from memory.

Syntax

Visual Basic
Public Event LoadFromMemory( _
   ByVal LoadFromMemoryItemID As Long, _
   ByVal UserTag As Variant _
)

Parameters

LoadFromMemoryItemID
A long value which represents the item ID from memory to load.
UserTag
A variant value which represents the user tag.

Remarks

Note: You must call the EnableEvent method to enable this event.

See Also


MouseDown Event

MouseDown Event
Button
An integer which represents the mouse button.
Shift
An integer value which represents the shift.
X
A long value which represents the x (horizontal) value.
Y
A long value which represents the y (vertical) value.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : MouseDown Event

Glossary Item Box

Description

Called on a mouse down action.

Syntax

Visual Basic
Public Event MouseDown( _
   ByVal Button As Integer, _
   ByVal Shift As Integer, _
   ByVal X As Long, _
   ByVal Y As Long _
)

Parameters

Button
An integer which represents the mouse button.
Shift
An integer value which represents the shift.
X
A long value which represents the x (horizontal) value.
Y
A long value which represents the y (vertical) value.

See Also


MouseMove Event

MouseMove Event
Button
An integer which represents the mouse button.
Shift
An integer value which represents the shift.
X
A long value which represents the x (horizontal) value.
Y
A long value which represents the y (vertical) value.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : MouseMove Event

Glossary Item Box

Description

Called on a mouse move action.

Syntax

Visual Basic
Public Event MouseMove( _
   ByVal Button As Integer, _
   ByVal Shift As Integer, _
   ByVal X As Long, _
   ByVal Y As Long _
)

Parameters

Button
An integer which represents the mouse button.
Shift
An integer value which represents the shift.
X
A long value which represents the x (horizontal) value.
Y
A long value which represents the y (vertical) value.

See Also


MouseUp Event

MouseUp Event
Button
An integer value which represents the button.
Shift
An integer value which represents the shift.
X
A long value which represents the x (horizontal) value.
Y
A long value which represents the y (vertical) value.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : MouseUp Event

Glossary Item Box

Description

Called on a mouse up action.

Syntax

Visual Basic
Public Event MouseUp( _
   ByVal Button As Integer, _
   ByVal Shift As Integer, _
   ByVal X As Long, _
   ByVal Y As Long _
)

Parameters

Button
An integer value which represents the button.
Shift
An integer value which represents the shift.
X
A long value which represents the x (horizontal) value.
Y
A long value which represents the y (vertical) value.

See Also


Paint Event

Paint Event
hDC
A long value which represents a handle.
left
A long value which represents the left side of the area to paint.
top
A long value which represents the top side of the area to paint.
width
A long value which represents the width of the area to paint.
height
A long value which represents the height of the area to paint.
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : Paint Event

Glossary Item Box

Description

Called when the thumbnail item is painted.

Syntax

Visual Basic
Public Event Paint( _
   ByVal hDC As Long, _
   ByVal left As Long, _
   ByVal top As Long, _
   ByVal width As Long, _
   ByVal height As Long _
)

Parameters

hDC
A long value which represents a handle.
left
A long value which represents the left side of the area to paint.
top
A long value which represents the top side of the area to paint.
width
A long value which represents the width of the area to paint.
height
A long value which represents the height of the area to paint.

Remarks

Note: You must call the EnableEvent method to enable this event.

See Also


SelectionIndexChanged Event

SelectionIndexChanged Event
AccusoftThumbnailXpress4 ActiveX DLL > ThumbnailXpress Object : SelectionIndexChanged Event

Glossary Item Box

Description

Called when a thumbnail item is selected using the user interface.

Syntax

Visual Basic
Public Event SelectionIndexChanged()

Remarks

Note: You must call the EnableEvent method to enable this event.

See Also


TN_AnnotationType Enumeration

TN_AnnotationType Enumeration
AccusoftThumbnailXpress4 ActiveX DLL : TN_AnnotationType Enumeration

Glossary Item Box

Description

Specifies the Annotation type used.

Members

Member | Value | Description
ANNOTATION_TYPE_I4W | 0 | Wang data embedded in TIFF tag #32932.
ANNOTATION_TYPE_INTERNAL_NXP | 5 | Binary format produced by NotateXpress.
ANNOTATION_TYPE_INTERNAL_XFDF | 6 | Acrobat XML Forms Document File.
ANNOTATION_TYPE_NONE | -1 | None.
ANNOTATION_TYPE_NXP | 1 | Binary format produced by NotateXpress.
ANNOTATION_TYPE_TMS | 2 | Legacy TMS Sequoia .ann file format.
ANNOTATION_TYPE_XFDF | 4 | Acrobat XML Forms Document File.
ANNOTATION_TYPE_XML | 3 | NotateXpress XML format.

Remarks

©2012. Accusoft Corporation. All Rights Reserved.


TN_BorderStyle Enumeration

TN_BorderStyle Enumeration
AccusoftThumbnailXpress4 ActiveX DLL : TN_BorderStyle Enumeration

Glossary Item Box

Description

Option values which determine the border style for the perimeter of the control.

Members

Member | Value | Description
TN_BorderFixed3D | 2 | 2 - 3-D control border
TN_BorderFixedSingle | 1 | 1 - Single line control border
TN_BorderNone | 0 | 0 - No control border.


TN_DebugErrorLevel Enumeration

TN_DebugErrorLevel Enumeration
AccusoftThumbnailXpress4 ActiveX DLL : TN_DebugErrorLevel Enumeration

Glossary Item Box

Description

Option values which determine the amount of logging detail to be sent to the log file.

Members

Member | Value | Description
TN_Detailed | 2 | 2 - This value is for debugging and has the highest level of detail in the log.
TN_Development | 1 | 1 - This value is for logging in development mode and has some additional amount of detail in the log.
TN_Production | 0 | 0 - This value is for logging in production mode and has the least amount of detail in the log.


TN_DescriptorFormat Enumeration

TN_DescriptorFormat Enumeration
AccusoftThumbnailXpress4 ActiveX DLL : TN_DescriptorFormat Enumeration

Glossary Item Box

Description

Option values which determine the source of descriptor text.

Members

Member | Value | Description
TN_DescriptorFormatCustom | 16 | 16 - Use the thumbnail item descriptor property contents.
TN_DescriptorFormatDefault | 1 | 1 - Use the thumbnail item descriptor property if present, or short filename otherwise.
TN_DescriptorFormatLongFilename | 2 | 2 - Use The Long Filename.
TN_DescriptorFormatNone | 0 | 0 - Do not display a descriptor.
TN_DescriptorFormatPage | 8 | 8 - Use the image's page number in the multi-page file.
TN_DescriptorFormatShortFilename | 4 | 4 - Use The Short Filename.


TN_DescriptorHorizontalAlignment Enumeration

TN_DescriptorHorizontalAlignment Enumeration
AccusoftThumbnailXpress4 ActiveX DLL : TN_DescriptorHorizontalAlignment Enumeration

Glossary Item Box

Description

Option values which determine the horizontal alignment of the descriptor text display.

Members

Member | Value | Description
TN_HAlignCenter | 1 | 1 - Descriptor text is horizontally centered.
TN_HAlignLeft | 0 | 0 - Descriptor text is left justified.
TN_HAlignRight | 2 | 2 - Descriptor text is right justified.


TN_DescriptorVerticalAlignment Enumeration

TN_DescriptorVerticalAlignment Enumeration
AccusoftThumbnailXpress4 ActiveX DLL : TN_DescriptorVerticalAlignment Enumeration

Glossary Item Box

Description

Option values which determine the vertical alignment of the descriptor text display.

Members

Member | Value | Description
TN_VAlignBottom | 2 | 2 - Descriptor text is bottom justified.
TN_VAlignCenter | 1 | 1 - Descriptor text is centered vertically.
TN_VAlignTop | 0 | 0 - Descriptor text is top justified.


TN_ErrorAction Enumeration

TN_ErrorAction Enumeration
AccusoftThumbnailXpress4 ActiveX DLL : TN_ErrorAction Enumeration

Glossary Item Box

Description

Option values which determine the action taken when processing errors are encountered.

Members

Member | Value | Description
TN_Abort | 1 | 1 - Stop display of thumbnails.
TN_UseErrorIcon | 0 | 0 - Default value. Displays error icon when unsupported or error thumbnails encountered.

Remarks

The default value is TN_UseErrorIcon.


TN_EvaluationMode Enumeration

TN_EvaluationMode Enumeration
AccusoftThumbnailXpress4 ActiveX DLL : TN_EvaluationMode Enumeration

Glossary Item Box

Description

Option values which designate evaluation modes available for use.

Members

Member Value Description
TN_Dialog 0

Default value. TrialDialog specifies that a dialog box should be used during evaluation.

TN_Watermark 1

The ThumbnailXpress component uses this enumeration to specify that after a period of time (5 minutes), the control will stop processing during evaluation.

This mode can be used in scenarios - for example, running on an internet server - where the application does not have permission to create a window.

In this mode, the component will successfully process for a period of 5 minutes and then stop processing with a licensing error.

Remarks

The default value is TN_Dialog.

See Also

EvaluationMode Property


TN_Event Enumeration

TN_Event Enumeration
AccusoftThumbnailXpress4 ActiveX DLL : TN_Event Enumeration

Glossary Item Box

Description

Option values which designate ThumbnailXpress Events.

Members

Member | Value | Description
TN_Error | 3 | 3 - The ThumbnailXpress Error Event
TN_ItemComplete | 2 | 2 - The ThumbnailItem ItemComplete Event.
TN_LoadFromMemoryEvent | 4 | 4 - The LoadFromMemory Event.
TN_Paint | 1 | 1 - The ThumbnailXpress Paint Event.
TN_SelectedIndexChange | 0 | 0 - The SelectedIndexChanged Event.


TN_FilterComparison Enumeration

TN_FilterComparison Enumeration
AccusoftThumbnailXpress4 ActiveX DLL : TN_FilterComparison Enumeration

Glossary Item Box

Description

Option values which specifiy the desired comparison outcome for a file date or size filter.

Members

Member | Value | Description
TN_Equal | 2 | 2 - Use Equals
TN_GreaterThan | 4 | 4 - Use Greater Than.
TN_GreaterThanEquals | 3 | 3 - Use Greater Than or Equals.
TN_LessThan | 0 | 0 - Use Less Than
TN_LessThanEquals | 1 | 1 - Use Less Than or Equals


TN_FilterType Enumeration

TN_FilterType Enumeration
AccusoftThumbnailXpress4 ActiveX DLL : TN_FilterType Enumeration

Glossary Item Box

Description

Option values which designate the Thumbnail image file property that is to be compared or matched by a filter.

Members

Member | Value | Description
TN_FileAttributes | 1 | 1 - Use the source file attributes.
TN_FileCreationDate | 2 | 2 - Use the source file creation date.
TN_FileModificationDate | 3 | 3 - Use the source file modification date.
TN_Filename | 0 | 0 - Use the source filename.
TN_FileSize | 4 | 4 - Use the source file file size.
TN_SupportedFileType | 5 | 5 - Use the source file file type.


TN_ScrollDirection Enumeration

TN_ScrollDirection Enumeration
AccusoftThumbnailXpress4 ActiveX DLL : TN_ScrollDirection Enumeration

Glossary Item Box

Description

Option values which designate the direction thumbnails scroll in the control.

Members

Member | Value | Description
TN_Horizontal | 0 | 0 - Thumbnails scroll in a horizontal direction.
TN_Vertical | 1 | 1 - Thumbnails scroll in a vertical direction.


TN_ScrollItemsType Enumeration

TN_ScrollItemsType Enumeration
AccusoftThumbnailXpress4 ActiveX DLL : TN_ScrollItemsType Enumeration

Glossary Item Box

Description

Option values which specify the incremental amount or if a positional programmatic scroll operation is desired.

Members

Member | Value | Description
TN_ItemIndex | 5 | 5 - Item index.
TN_LargeDecrease | 0 | 0 - Large decrease in scroll operation.
TN_LargeIncrease | 2 | 2 - Large increase in scroll operation.
TN_SmallDecrease | 1 | 1 - Small decrease in scroll operation.
TN_SmallIncrease | 3 | 3 - Small increase in scroll operation.
TN_ThumbPosition | 4 | 4 - Thumb position.


TN_SelectionMode Enumeration

TN_SelectionMode Enumeration
AccusoftThumbnailXpress4 ActiveX DLL : TN_SelectionMode Enumeration

Glossary Item Box

Description

Option values which designate the selection mode for the control.

Members

Member | Value | Description
TN_MultiExtended | 3 | 3 - Default mode. Multiple Thumbnail items may be selected; the control and shift keys modify the items selected operation.
TN_MultiSimple | 2 | 2 - Multiple thumbnail items may be selected; the control and shift keys do not modify the items selected operation.
TN_None | 0 | 0 - Thumbnail Selection is not enabled.
TN_Single | 1 | 1 - Only one thumbnail item may be selected. If a second item is selected, the selected state is removed from any previously selected item.

Remarks

The default value is TN_MultiExtended.


TN_ThumbnailStatus Enumeration

TN_ThumbnailStatus Enumeration
AccusoftThumbnailXpress4 ActiveX DLL : TN_ThumbnailStatus Enumeration

Glossary Item Box

Description

Item not validated at any level.

Option values which designate the status of a thumbnail item.

Members

Member | Value | Description
TN_BeingGenerated | 2 | 2 - Thumbnail bitmap in the process of being generated.
TN_Canceled | 6 | 6 - The thumbnail is canceled.
TN_FailedWithError | 4 | 4 - ThumbnailXpress failed to generate thumbnail bitmap for the image (likely decompression error).
TN_FailedWithTimeout | 5 | 5 - Failed to generate thumbnail bitmap within time limits. See ThreadHungThreshold property.
TN_Generated | 3 | 3 - A thumbnail bitmap successfully generated (though it may not be in cache at this point).
TN_NotValidated | 0 | 0 - The thumbnail is not validated.
TN_Validated | 1 | 1 - File validated at some level; ThumbnailXpress believes it is a supported file type.

See Also

ThreadHungThreshold Property


TN_ThumbnailType Enumeration

TN_ThumbnailType Enumeration
AccusoftThumbnailXpress4 ActiveX DLL : TN_ThumbnailType Enumeration

Glossary Item Box

Description

Option values which designate the type of thumbnail (image, pdf, etc.) for a thumbnail item.

Members

Member | Value | Description
TN_CAD | 5 | 5 - Supported CAD (Computer Aided Design) file type.
TN_Image | 3 | 3 - Supported ImagXpress file type.
TN_Internet | 1 | 1 - Specifies that the file is an Internet file.
TN_ParentDirectory | 6 | 6 - Parent directory folder.
TN_PDF | 4 | 4 - Supported PDFXpress file type.
TN_Subdirectory | 7 | 7 - Sub-directory folder type.
TN_Unknown | 0 | 0 - Thumbnail type is not recognized by ThumbnailXpress operations.
TN_Unsupported | 2 | 2 - ImagXpress or PDF Xpress (if available) does not support the file.


Getting Started - Accusoft ThumbnailXpress 4

Getting Started
Send Feedback

Glossary Item Box


Getting Started - Accusoft ThumbnailXpress 4

Introduction
Send Feedback

Glossary Item Box


References

References
Send Feedback

Glossary Item Box