PrintPRO User Assistance Dashboard

Accusoft.PrintPro6.ActiveX
PrintPRO User Assistance Dashboard
Send Feedback

Glossary Item Box

Welcome

  • Overview of Product Family
    • What is the ImagXpress Product Family?
  • New Features
    • What is PrintPRO?

Getting Started

  • Operating Requirements & Installation
    • Operating Requirements
    • Upgrading from PrintPRO 5 to PrintPRO 6
    • Installing on a Development Machine
  • Licensing & Deployment
    • Licensing
    • Distributing PrintPRO
    • Software License Agreement
    • Accusoft Corporation Copyrights & Trademarks

Developer's Guide

  • User Guide

    • Concepts

      • Overview of PrintPRO
      • Introduction to Image Color Management (ICM)
      • State Diagram
      • Glossary
    • How To
      • Set Up Printer
      • Create Print Job
      • Print Preview
      • Print
      • Send Raw Data to the Printer - Bypassing the Print Driver
      • Debug Your Application
  • API Reference Guide
    • Accusoft.PrintPro6.ActiveX.dll

Additional Resources

  • White papers & Case Studies
  • FAQs, PrintPRO 6 FAQs
  • Support Overview
  • Support Plans/Agreement

Feedback

  • Tell us what you think
    • Email us
    • Take our survey

©2012. Accusoft Corporation. All Rights Reserved.


PrintPRO 6 for ActiveX - User Guide

Accusoft.PrintPro6.ActiveX
PrintPRO 6 for ActiveX - User Guide
Send Feedback

Glossary Item Box

This User Guide provides information about the following:

  • Introduction
  • Getting Started
  • Licensing
  • Distributing Applications & Deployment
  • Concepts
  • How To


Introduction

Accusoft.PrintPro6.ActiveX
Introduction
Send Feedback
PrintPRO 6 for ActiveX - User Guide > Introduction

Glossary Item Box

This Introduction provides information about the following:

  • What is PrintPRO?
  • What is the ImagXpress Product Family?
  • Getting Support
  • Accusoft Corporation Copyrights & Trademarks


What is PrintPRO?

Accusoft.PrintPro6.ActiveX
What is PrintPRO?
See Also Send Feedback
PrintPRO 6 for ActiveX - User Guide > Introduction > What is PrintPRO?

Glossary Item Box

PrintPRO™ Version 6 is a windowless control that enables the user to access and modify printer properties, create a print job, preview printing, and print to a device or file. PrintPRO offers the flexibility to create a custom printing UI, and may be used to interact with the printer, bypassing the print driver.

New Features in Version 6

  • We have added a feature to permit the developer to request the supported resolutions of the printer in Dots Per Inch.
  • We have added a feature to report on the version/build number of the control, e.g., 6.0.6.0. This will correlate exactly to what is listed in the About Box.
  • We have added a new error code -6000 to indicate if the Supported DPI’s index is invalid.
  • We have added a new licensing model.

Primary Features

  • Bypass default printing functions and add your own rich, custom interface
  • Select a Printer
  • Set Printer Properties
  • Set Print Margins and Coordinates
  • Image Color Management for Printers and Monitors
  • Change text font, alignment, rotation, background transparency and more in printed image
  • Add graphics to a printed image
  • Print collages
  • Print Preview
  • Print to Device
  • Print to File, including: TIFF, TIFF (JPEG compressed), and PDF (compressed to G3, Jbig2, JPEG)
  • Send Raw Data to the Printer, bypassing the Print Driver
  • Supports single- and multi-page documents

See Also

Getting Support
Accusoft Corporation Copyrights & Trademarks


What is the ImagXpress Product Family?

Accusoft.PrintPro6.ActiveX
What is the ImagXpress Product Family?
Send Feedback
PrintPRO 6 for ActiveX - User Guide > Introduction > What is the ImagXpress Product Family?

Glossary Item Box

ImagXpress® Version 11 lets you quickly add the world's most trusted imaging functions to your Windows application. With our powerful imaging tools, you can quickly develop applications that require complex imaging tasks for document imaging, photo processing, or medical applications, while you concentrate on the unique needs of your program.

ImagXpress is the image handling engine behind most of our advanced recognition and image processing products. It's the fastest way to develop professional applications involving images.

The ImagXpress v11 Product Family includes the following Components:

  • ImagXpress v11 – image compression, decompression, viewing, and processing
  • NotateXpress™ v11 – image annotation support
  • ThumbnailXpress™ v4 – thumbnail image support
  • TwainPRO™ v7 – TWAIN image acquisition support
  • PrintPRO™ v6 – image printing support

ImagXpress Editions

The components within the ImagXpress v11 Product Family are available in two editions, designed to meet specific imaging needs:

  • Professional: includes ImagXpress, NotateXpress, TwainPRO, PrintPRO, and ThumbnailXpress
  • Standard: includes ImagXpress, TwainPRO, and ThumbnailXpress

Additional Accusoft Components

Additional components are available for purchase separately, and integrate easily to provide a comprehensive imaging solution:

  • ISIS® Xpress™ – ISIS image acquisition support; license sold separately
  • PDF Xpress™ – PDF creation, viewing, and annotating
  • OCR Xpress™ – full page OCR
  • Barcode Xpress™ – recognize barcodes
  • ScanFix Xpress™ – advanced image cleanup
  • FormFix™ – form ID, dropout, and OMR
  • SmartZone™ ICR / OCR – character recognition
  • ImageGear for .NET - Fully managed code to create cutting edge imaging applications
  • ImageGear for Silverlight - Comprehensive SDK for building Web imaging applications
  • ImageGear for .NET Compact Framework - Create reliable and secure imaging applications for mobile devices

See www.accusoft.com for product packaging and sales information.


Getting Support

Accusoft.PrintPro6.ActiveX
Getting Support
Send Feedback
PrintPRO 6 for ActiveX - User Guide > Introduction > Getting Support

Glossary Item Box

For information about Accusoft Support, please refer to the Software Support and Maintenance Policy on the Accusoft web site or call Accusoft at 813-875-7575.


Accusoft Corporation Copyrights & Trademarks

Accusoft.PrintPro6.ActiveX
Accusoft Corporation Copyrights & Trademarks
Send Feedback
PrintPRO 6 for ActiveX - User Guide > Introduction > Accusoft Corporation Copyrights & Trademarks

Glossary Item Box

©1997-2012 Accusoft Corporation. All rights reserved.

Information in this document is subject to change without notice. No part of this document may be reproduced or transmitted in any form or by any means, electronic or mechanical, for any purpose, without the express written permission of Accusoft® Corporation.

This manual and the software described in it are both products of the USA.

Accusoft Corporation
4001 North Riverside Drive
Tampa, FL 33603
Sales: 813-875-7575
www.accusoft.com

Accusoft Trademarks

The following are trademarks (™) or registered marks (®) of Accusoft Corporation:

  • Accusoft®
  • Accusoft Logo™
  • Accusoft Pegasus Logo™
  • Adeptol®
  • AIMTools™
  • Barcode Xpress™
  • CapturePro™
  • Digital Mark Recognition® (DMR)
  • FolderBots™
  • FormAssist™
  • FormDirector™
  • FormFix™
  • FormSuite™
  • ImageGear® for .NET
  • ImageGear® for .NET Compact Framework
  • ImageGear® for Silverlight
  • ImageGear® Medical
  • ImageGear® Professional
  • ImageGear®
  • ImageTransport MD™
  • ImagXpress®
  • ISIS® Xpress™
    • ISIS is a registered trademark of EMC Corporation
    • ISIS Xpress is a trademark of Accusoft Corporation
  • MICR Xpress™
  • NetVue™
  • NotateXpress™
  • PDF Xpress™
  • Pegasus®
  • PICTools™
  • PICTools™ Document
  • PICTools™ Fingerprint
  • PICTools™ Medical
  • PICTools™ Photo
  • PICVideo™ M-JPEG Codec
  • PrintPRO™
  • Prizm®
  • Prizm® Viewer
  • ScanFix® Xpress™
  • SmartZone™
  • The JPEG Wizard™
  • ThumbnailXpress™
  • TwainPRO™

Accusoft and/or its agents use these marks and brand names in connection with its goods and/or services, in the United States and other countries.

Microsoft, Internet Explorer, Microsoft.NET, Silverlight, Visual Basic, Visual Studio, and Visual Studio.NET are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries.

Itanium is a registered trademark of Intel Corporation in the United States and other countries.

All other product and brand names are the property of their respective owners.


Getting Started

Accusoft.PrintPro6.ActiveX
Getting Started
Send Feedback
PrintPRO 6 for ActiveX - User Guide > Getting Started

Glossary Item Box

This section provides information about the following:

  • Operating Requirements
  • Using Accusoft 64-bit ActiveX Components
  • Installing on a Development Machine
  • Upgrading from PrintPRO 5 to PrintPRO 6


Operating Requirements

Accusoft.PrintPro6.ActiveX
Operating Requirements
See Also Send Feedback
PrintPRO 6 for ActiveX - User Guide > Getting Started > Operating Requirements

Glossary Item Box

Operating Systems

PrintPRO™ version 5 runs on 32-bit and 64-bit Microsoft Windows operating systems:

  • Windows XP , XP Professional
  • Windows Vista
  • Windows 7
  • Windows Server 2003
  • Windows Server 2008

PrintPRO runs in 64-bit and 32-bit executables.

Although it may run, it is not supported on previous Windows versions (for example, Windows 2000).

Threading

Accusoft considers thread-safe to be when an application using this component can use multiple controls running in the same process, where they don't interfere with each other. The thread creating the control owns the control and is the only thread that can interact with it.

Development Environment

  • Microsoft Visual Basic 6
  • Microsoft Visual C++ 6 or higher
  • Any other development environment that supports ActiveX/COM

See Also

Installing on a Development Machine
Getting Support


Using Accusoft 64-bit ActiveX Components

Accusoft.PrintPro6.ActiveX
Using Accusoft 64-bit ActiveX Components
Send Feedback
PrintPRO 6 for ActiveX - User Guide > Getting Started > Using Accusoft 64-bit ActiveX Components

Glossary Item Box

Accusoft 64-bit ActiveX components are built for maximum compatibility with our 32-bit ActiveX counterparts, providing the customer ease of upgrading an existing 32-bit application. The primary development platforms that we tested are Visual Studio C++, VBScript, JavaScript, C#, and VB.Net.

Upon inspection of these controls, you will notice that filenames will end in ActiveX for traditional 32-bit ActiveX controls or end in ActiveX64 for newer 64-bit ActiveX controls. If you use a tool such as OLEView, you will notice that when the control is registered they share the same GUID which allows the operating system ease of automatic selection.

Visual Studio is still a 32-bit development environment. The Accusoft installer will automatically place the 32-bit versions of the ActiveX in the toolbox. Since the components share the same interface and the same GUID, you can use all the ease of the Visual Studio development environment and still have all the power of 64-bit under the hood.

C++

When developing a C++ application you can #import in the progid, and compile targeting either Win64 or Win32. While progid is the recommended approach, if you #import by filename, we suggest you use the Sysnative redirector instead of the System32 directory as Visual Studio may get confused.

When creating a C++ dialog application, you can “Insert ActiveX Control…” onto the dialog. You will be presented with a dialog showing all the registered 32-bit controls. Select the desired ActiveX from the dialog. The second step of “Add Variable…” will automatically create accusoftcontrol1.h and accusoftcontrol1.cpp files that are compatible in both Win32 and Win64. The compiler will automatically use the correct version of the ActiveX based on the targeted platform.

Scripting

When using a scripting environment such as VBScript and JavaScript, the ActiveX controls will be able to seamlessly run under both Internet Explorer 32-bit and Internet Explorer 64-bit. Just code your HTML as you always have. Register both ActiveX and ActiveX64 on the target machine. You will be able to run under either the 32-bit or 64-bit version of Internet Explorer.

.Net

When creating a .Net AnyCPU application, you can import the ActiveX controls and have the application automatically switch if you are on a 32 or 64-bit machine. Just drag and drop the ActiveX control on your form as normal. Make sure the application is set for AnyCPU. Register both ActiveX and ActiveX64 on the target machine. The application will run as native code on any 32-bit or 64-bit machine (except Itanium).

If your application will only run on 64-bit machines, you can set the application to target x64, and only distribute the ActiveX64.

Handles

All handles are treated as 32-bit values. This creates full compatibility between all Accusoft controls, freeing the developer from worrying about what bit depth they are running in. If you use a third party control that has 64-bit handles, it is mandatory that you use the Microsoft provided LongToHandle and HandleToLong macros.


Installing on a Development Machine

Accusoft.PrintPro6.ActiveX
Installing on a Development Machine
See Also Send Feedback
PrintPRO 6 for ActiveX - User Guide > Getting Started > Installing on a Development Machine

Glossary Item Box

To Install PrintPRO™ Component

Run the downloaded setup program which installs the development kit on your development machine.

The downloaded development kit includes code samples for supported platforms. Samples are available through the Start | Programs | Accusoft | PrintPRO v6.0 menu.

By default this will register trial licensing which allows you to develop applications but not to distribute them. The trial license allows testing of all the functions and features.

Please see the section Distributing PrintPRO to understand the limits and details to convert licensing editions.
In order to distribute your finished application you must purchase and install a fully paid license from Accusoft. The paid licenses override trial licenses.

To Use PrintPRO Help Files

Once you have installed PrintPRO, you will have access to the following stand-alone help file:

  • Accusoft.PrintPro6.ActiveX.chm - access the PrintPro v6 stand-alone help through the Windows Start menu: Start | Programs | Accusoft | PrintPRO v6

See Also

Operating Requirements
Getting Support
Distributing PrintPRO


Upgrading from PrintPRO 5 to PrintPRO 6

Accusoft.PrintPro6.ActiveX
Upgrading from PrintPRO 5 to PrintPRO 6
Send Feedback
PrintPRO 6 for ActiveX - User Guide > Getting Started > Upgrading from PrintPRO 5 to PrintPRO 6

Glossary Item Box

This section describes how to upgrade from PrintPro 5 to PrintPro 6. While generally you'll be able to replace PrintPro 5 with PrintPro 6, there are a few important changes you may need to consider. This section provides information about those changes.

Library Name, GUID, and ProgID

  • The library name has changed from AccusoftPrintPro5 to AccusoftPrintPro6.
  • The GUID for the PrintPro ActiveX control has changed in PrintPRO 5 from {3588AB12-3E2B-4015-B2B8-B4B50DC64C31} to the new value in PrintPRO 6 of {68290206-1A39-46a9-8401-72BE8B4DA540}.
  • The ProgID has changed from ‘Accusoft.PrintPro.5’ to ‘Accusoft.PrintPro.6’ in PrintPRO 6.

Changes and New Properties/Methods

  • New method GetNumSupportedDpis() and GetSupportedDpis() have been added.
  • Added Version property.
  • Accusoft's new licensing structure is available in the ImagXpress 11 Product Family. See Licensing for information about the new licensing, and Upgrading Runtime Licensing for information about updating your licensing from an earlier version of PrintPRO.

If you encounter any porting issues, please contact support@accusoft.com for assistance.


Upgrading Runtime Licensing

Accusoft.PrintPro6.ActiveX
Upgrading Runtime Licensing
Send Feedback
PrintPRO 6 for ActiveX - User Guide > Getting Started > Upgrading Runtime Licensing

Glossary Item Box

This section describes how to upgrade to Accusoft's new Runtime Licensing.

Prior to PrintPRO 6, runtime licensing was accomplished using the UnlockRuntime method.

In PrintPRO 6, the default licensing model is Automatically Reported Runtime Licensing. However, based on your contracted usage of this software, you may be eligible for Manually Reported Runtime Licensing. Your Accusoft Sales Representative (sales@accusoft.com) can help you determine which model is appropriate.

Refer to the following sections for information about upgrading to the new Runtime Licensing models:

  • Upgrading to Automatically Reported Runtime Licensing
  • Upgrading to Manually Reported Runtime Licensing

Upgrading to Automatically Reported Runtime Licensing

Automatically Reported Runtime Licensing requires a license to be installed on the end-user's machine. See the Licensing section for more information.

In your PrintPRO 5 codebase, find any existing calls to the UnlockRuntime or UnlockWeb method.

C++ Copy Code
 PrintPro1->UnlockRuntime(12345,12345,12345,12345);
VB6 Copy Code
 PrintPro1.UnlockRuntime 12345,12345,12345,12345
JavaScript Copy Code
PrintPro1.UnlockWeb("ServerLicenseString…");

In your PrintPRO 6 codebase, replace the UnlockRuntime or UnlockWeb method with calls to the SetSolutionName and SetSolutionKey methods.

C++ Copy Code
 PrintPro1->SetSolutionName("YourSolutionName");
 PrintPro1->SetSolutionKey(12345,12345,12345,12345);
VB6 Copy Code
 PrintPro1.SetSolutionName "YourSolutionName"
 PrintPro1.SetSolutionKey 12345,12345,12345,12345
JavaScript Copy Code
PrintPro1.SetSolutionName("YourSolutionName");
PrintPro1.SetSolutionKey(12345,12345,12345,12345);

Upgrading to Manually Reported Runtime Licensing

In your PrintPRO 5 codebase, find any existing calls to the UnlockRuntime or UnlockWeb method.

C++ Copy Code
 PrintPro1->UnlockRuntime(12345,12345,12345,12345);
VB6 Copy Code
 PrintPro1.UnlockRuntime 12345,12345,12345,12345
JavaScript Copy Code
PrintPro1.UnlockWeb("ServerLicenseString…");

In your PrintPRO 6 codebase, replace the UnlockRuntime or UnlockWeb method with calls to the SetSolutionName, SetSolutionKey, and SetOEMLicenseKey methods.

C++ Copy Code
 PrintPro1->SetSolutionName("YourSolutionName");
 PrintPro1->SetSolutionKey(12345,12345,12345,12345);
 PrintPro1->SetOEMLicenseKey("1.0.AStringForOEMLicensing…");
VB6 Copy Code
 PrintPro1.SetSolutionName "YourSolutionName"
 PrintPro1.SetSolutionKey 12345,12345,12345,12345
 PrintPro1.SetOEMLicenseKey "1.0.AStringForOEMLicensing…"
JavaScript Copy Code
PrintPro1.SetSolutionName("YourSolutionName");
PrintPro1.SetSolutionKey(12345,12345,12345,12345);
PrintPro1.SetOEMLicenseKey("1.0.AStringForOEMLicensing…");

There is no longer a separate method for web licensing. That functionality has been integrated into the SetOEMLicenseKey method.

If you encounter any porting issues, please contact support@accusoft.com for assistance.


Licensing

Accusoft.PrintPro6.ActiveX
Licensing
See Also Send Feedback
PrintPRO 6 for ActiveX - User Guide > Licensing

Glossary Item Box

Accusoft has introduced a new licensing structure, which provides the following benefits:

  • Toolkit Licensing (also known as Developer or SDK licensing) has been simplified, no longer requiring manual entry of license registration codes.
  • Runtime Licensing (also known as Deployment licensing) has been made more flexible, enabling support for a number of different deployment scenarios.

During evaluation of Accusoft products, Evaluation Toolkit licenses can be used to try out products. However, the product behavior is limited by trial dialog pop-ups or timeouts.

Accusoft requires customers to purchase licenses for both development and deployment.

  • Development/Toolkit Licensing: When you determine the product is a good fit, you can purchase a Toolkit license to eliminate trial dialog pop-ups and timeouts while you develop your application.
  • Deployment/Runtime Licensing: Once you have an application that is ready for distribution, you have several options for deployment. Your own deployment scenario will dictate which option is the most appropriate. There are also cost considerations for each licensing model; see the product's "pricing" page or speak with an Accusoft Sales Representative (sales@accusoft.com) for more information.
    • Manually Reported Runtime Licensing: In this model, you embed all of the licensing information directly into your application. You must manually provide royalty reporting to Accusoft for the actual licenses deployed. This model will be the best choice for you if you are not connected to the Internet at runtime, as might be the case in an defense or financial application.
    • Automatically Reported Runtime Licensing using the Server Licensing Utility (SLU): In this model, you run a small GUI tool one time on each deployment target to configure licensing. This model will be the best choice for you if you handle the deployments yourself.
    • Automatically Reported Runtime Licensing using the Licensing Development Kit (LDK): In this model, you embed function calls into your application that perform the license verification at runtime. This model will be the best choice for you if you wish to hide licensing from your end users.

See Also

Licensing Glossary


Evaluation Licensing

Accusoft.PrintPro6.ActiveX
Evaluation Licensing
Send Feedback
PrintPRO 6 for ActiveX - User Guide > Licensing > Evaluation Licensing

Glossary Item Box

During evaluation of Accusoft products, Evaluation Toolkit licenses can be used to try out products. However, the product behavior is limited by trial dialog pop-ups or timeouts. When you determine the product is a good fit, you can purchase a Toolkit license to eliminate trial dialog pop-ups and timeouts.

An evaluation dialog similar to the following is displayed when you have a valid evaluation license.

However, if you attempt to execute a function that is not licensed in the edition license you are using (e.g., if you have a paid license for ImagXpress Standard and attempt to execute a function available only in ImagXpress Professional), an evaluation dialog similar to the following is displayed.

If no license is found in the registry, a dialog similar to the following will be displayed.


Toolkit Licensing

Accusoft.PrintPro6.ActiveX
Toolkit Licensing
Send Feedback
PrintPRO 6 for ActiveX - User Guide > Licensing > Toolkit Licensing

Glossary Item Box

Accusoft requires customers who are developing code that uses Accusoft components to have a Toolkit license for each developer.

This section provides information about the following:

  • Assigned Toolkit License
  • License Manager
  • Product Editions
  • Registration
    • Registering When Connected to the Internet
    • Registering When Disconnected from the Internet
  • Developing Code


Assigned Toolkit License

Accusoft.PrintPro6.ActiveX
Assigned Toolkit License
Send Feedback
PrintPRO 6 for ActiveX - User Guide > Licensing > Toolkit Licensing > Assigned Toolkit License

Glossary Item Box

When licenses are purchased for developers at an organization, a representative is designated to assign the licenses to developers at the organization. Each developer must create an account on Accusoft’s website prior to the assignment of licenses. The organization’s designated representative may request that licenses be reassigned as a result of personnel changes.


License Manager

Accusoft.PrintPro6.ActiveX
License Manager
Send Feedback
PrintPRO 6 for ActiveX - User Guide > Licensing > Toolkit Licensing > License Manager

Glossary Item Box

The License Manager is a GUI application that is used by a developer to register and activate Toolkit licenses on their development system. When a paid Toolkit license is registered, the License Manager:

  • Communicates the developer credentials and the hardware information for the development system to the licensing web service.
  • Installs the returned license key on that system.

Activation involves choosing a Toolkit license, either evaluation or paid, so that the license is active on the system.


Product Editions

Accusoft.PrintPro6.ActiveX
Product Editions
Send Feedback
PrintPRO 6 for ActiveX - User Guide > Licensing > Toolkit Licensing > Product Editions

Glossary Item Box

Accusoft products may have multiple editions, each of which supports different features. Products that support multiple editions are installed with multiple evaluation Toolkit licenses, one evaluation Toolkit license per edition.

Selecting An Edition (Activating a Toolkit License)

Evaluation licenses allow developers to try features in different product editions. Since each license supports only a single edition of a product, the developer can switch between editions by activating the corresponding Toolkit license, either purchased or evaluation, using the License Manager.

When a customer downloads an evaluation Toolkit, the evaluation Toolkit license for the edition with the most features is installed by default. However, the developer may run the License Manager to change the Toolkit license to a lower edition in order to determine if that edition will serve their needs.

If a customer has purchased multiple editions of the same product, they may install both editions on a development system, but only one edition may be active at a time. Once a license has been activated for a particular system, it may be deactivated (replaced by activating another edition) or reactivated at any time. Similarly, customers who own a lower featured edition may activate a higher featured edition evaluation Toolkit license and then switch back to their paid, lower-featured Toolkit edition license at any time. For example, you can go from a paid Standard edition to an evaluation Professional edition by activating the Professional edition evaluation Toolkit license.


Registration

Accusoft.PrintPro6.ActiveX
Registration
Send Feedback
PrintPRO 6 for ActiveX - User Guide > Licensing > Toolkit Licensing > Registration

Glossary Item Box

Registration is the process of creating a paid Toolkit license key for a particular system. Registration for Toolkit licenses is always done through the License Manager. This enables the features for the purchased edition to operate without nag dialogs or timeouts. Registration for each license is only required to be performed once per development system. After a license has been registered on a system, you can use the license without further interaction with the License Manager.

Also refer to the following sections:

  • Registering When Connected to the Internet
  • Registering When Disconnected from the Internet


Registering When Connected to the Internet

Accusoft.PrintPro6.ActiveX
Registering When Connected to the Internet
Send Feedback
PrintPRO 6 for ActiveX - User Guide > Licensing > Toolkit Licensing > Registration > Registering When Connected to the Internet

Glossary Item Box

When the development system is connected to the Internet, registration is a fairly simple process.

  1. Start the License Manager.
  2. When prompted, enter your Accusoft login and password.

    The License Manager then displays the available evaluation and purchased licenses assigned to you.

  3. Select a toolkit and click the link to activate the license for that toolkit.

    The License Manager then requests a new license key from the licensing web service and installs it; this completes the registration process.

    If the selected license cannot be installed on the development system due to connection failures or other reasons, a temporary, 15 day "grace" license is installed so as not to interrupt development while a new license is obtained for the development system.


Registering When Disconnected from the Internet

Accusoft.PrintPro6.ActiveX
Registering When Disconnected from the Internet
Send Feedback
PrintPRO 6 for ActiveX - User Guide > Licensing > Toolkit Licensing > Registration > Registering When Disconnected from the Internet

Glossary Item Box

When the development system is not connected to the Internet during registration, as is the case in some defense or financial institutions, registration is only slightly less simple.

  1. Run the License Manager and attempt to log in.
    The License Manager detects that the system is not registered and displays the following dialog:

  2. Select the Install Offline option to begin the offline registration process.

  3. Copy the URL to removable media, such as a thumb drive.

  4. Take the thumb drive to a system that is connected to the Internet.
  5. From the connected system, paste the URL into a browser, which automatically displays the toolkits available.
  6. Upon selecting a toolkit, a license is generated, which you then save to the removable media device.
  7. Return to the offline system where the new license is to be installed.
  8. Use the License Manager to browse to the file and install the Toolkit license.


Developing Code

Accusoft.PrintPro6.ActiveX
Developing Code
Send Feedback
PrintPRO 6 for ActiveX - User Guide > Licensing > Toolkit Licensing > Developing Code

Glossary Item Box

Once an evaluation or paid Toolkit license has been activated on the development system, no additional code is required to use the Accusoft products on this system. If moving the resulting executable code to a new system, you will need to install Toolkit licenses or incorporate Runtime licenses into your code.


Runtime Licensing

Accusoft.PrintPro6.ActiveX
Runtime Licensing
Send Feedback
PrintPRO 6 for ActiveX - User Guide > Licensing > Runtime Licensing

Glossary Item Box

When an application that uses one or more Accusoft products is deployed, it requires a Runtime License for each installation. There are two main types of Runtime Licenses:

  • Automatically Reported. Distribution of Automatically Reported Runtime licenses is handled automatically through the use of licensing software components and web services.
  • Manually Reported. Manually Reported Runtime licensing requires you to provide the number of licenses distributed on a contractually agreed upon basis.
  • ActiveX Website Runtime Licensing. Using an Accusoft ActiveX on a webpage is similar to Manually Reported Runtime (Non-Node-Locked), as it requires calls to SetSolutionName, SetSolutionKey, and SetOEMLicenseKey. However, the web licenses are not node-locked to particular hardware but are node-locked to a set of specific domains or sub-domains.

These licensing types are each described in detail in the following sections:

  • Automatically Reported Runtime (Node-Locked)
    • Licensing API
    • License Pools
    • License Configuration Files
    • LDK vs. SLU
      • Server Licensing Utility (SLU)
      • Licensing Development Kit (LDK)
    • Deployment Proxy Service (DPS)
  • Manually Reported Runtime (Non-Node-Locked)
    • Solution Name
    • Solution Key
    • OEM License Key
  • ActiveX Website Runtime Licensing
If you are upgrading from an earlier version of PrintPRO, please see the Upgrading Runtime Licensing section for important information.


Automatically Reported Runtime (Node-Locked)

Accusoft.PrintPro6.ActiveX
Automatically Reported Runtime (Node-Locked)
Send Feedback
PrintPRO 6 for ActiveX - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked)

Glossary Item Box

Automatically Reported Runtime licenses use a mechanism similar to Toolkit licensing to activate a license for a particular system. In this case, each installation has a unique license that is pulled from the pool of licenses purchased by the customer. When the license key is generated, it contains hardware information that identifies the system on which the license is to be installed.

The Licensing Development Kit component, which interacts with the licensing web service and installs the newly generated license key, may be used directly by the application or it may be used through a simple tool known as the Server Licensing Utility.

  • The Licensing Development Kit requires integration with the application or installation utility to perform license activation.
  • The Server Licensing Utility is a stand-alone application that integrates the Licensing Development Kit to perform the registration.

This topic provides information about the following:

  • Licensing API
  • License Pools
  • License Configuration Files
  • LDK vs. SLU
    • Server Licensing Utility (SLU)
    • Licensing Development Kit (LDK)
  • Deployment Proxy Service (DPS)


Licensing API

Accusoft.PrintPro6.ActiveX
Licensing API
Send Feedback
PrintPRO 6 for ActiveX - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > Licensing API

Glossary Item Box

The Licensing API is used in the developer’s code to specify Runtime Licensing deployment information. This is used to unlock the Accusoft products and enable all licensed features at runtime. Both the "Solution Name" and "Solution Key" values used in the API described below are provided by Accusoft, along with the License Configuration file, at the time of purchase of a Runtime License.

Solution Name

The solution name is the name assigned by Accusoft to the licenses purchased for runtime deployment. It is a character string that is set for a component prior to use in a deployment environment and is typically the name of the organization that purchased the runtime licenses. It is set via the SetSolutionName method. For example:

Copy Code
PrintPro1.SetSolutionName("ACMEImaging");

The Solution Name must be set in order to use runtime licensing.

Solution Key

The Solution Key is a set of four numbers assigned when the licenses are purchased for runtime deployment; the Solution Key also identifies the organization that purchased the runtime licenses. The Solution Key is set via the SetSolutionKey method. For example:

Copy Code
PrintPro1.SetSolutionName("ACMEImaging");
PrintPro1.SetSolutionKey(0x1C3A023F, 0xA018F260, 0x37AF0E51, 0x557F2389);

The Solution Key must be set in order to use runtime licensing.


License Pools

Accusoft.PrintPro6.ActiveX
License Pools
Send Feedback
PrintPRO 6 for ActiveX - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > License Pools

Glossary Item Box

When Automatically Reported Runtime licenses are purchased, they are organized into pools of a specific version and platform for a particular toolkit. For example, if a customer developed two applications using ImagXpress, one using 32-bit ActiveX and the other using .NET, they would purchase two pools of runtime licenses, one for the ActiveX platform and one for the .NET platform. At installation, a new license would be pulled from the appropriate pool, depending upon which platform the application is using.


License Configuration Files

Accusoft.PrintPro6.ActiveX
License Configuration Files
See Also Send Feedback
PrintPRO 6 for ActiveX - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > License Configuration Files

Glossary Item Box

When an Automatically Reported Runtime license is purchased, a License Configuration file is created and distributed to the customer along with their assigned Solution Name and Solution Key. The License Configuration file contains information about the Runtime licenses for a particular platform and version of a toolkit. It is used by the Server Licensing Utility or License Development Kit to activate licenses when the customer’s application is installed on their users' systems.

See Also

Licensing API


LDK vs. SLU

Accusoft.PrintPro6.ActiveX
LDK vs. SLU
Send Feedback
PrintPRO 6 for ActiveX - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > LDK vs. SLU

Glossary Item Box

Both the Licensing Deployment Kit and the Server Licensing Utility perform the same function of registering the Runtime license for the system on which it will be run. Both are provided in order to give you some options.

  • If you are deploying to your own systems (e.g., for enterprise IT staff), the use of an Accusoft branded Server Licensing Utility may meet your needs. Similarly, if you handle the deployment onto end users systems, you may also find the Server Licensing Utility to be sufficient.
  • If you wish to hide this licensing registration from end users, you will likely choose the Licensing Deployment Kit, which allows you to integrate the registration process into your application. The Licensing Deployment Kit also allows for the optional assignment of Access Keys to specific users, which lets you manage your licenses more directly and limits the distribution of licenses.


Server Licensing Utility (SLU)

Accusoft.PrintPro6.ActiveX
Server Licensing Utility (SLU)
Send Feedback
PrintPRO 6 for ActiveX - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > LDK vs. SLU > Server Licensing Utility (SLU)

Glossary Item Box

The Server Licensing Utility is a simple Windows application that uses License Configuration Files to request a license key from the purchased Runtime licenses. The Server Licensing Utility registers that Runtime license on the system where your application will be running. This utility can be used by developers for testing, by your deployment team, or by your end users to register their Runtime license.

In the Server Licensing Utility dialog, add your License Configuration file(s) as follows:

  1. Click Add and navigate to your License Configuration file(s).
  2. Select the appropriate License Configuration file(s) and click Open.
  3. After all applicable License Configuration files have been added, click Auto Register or Manually Register, depending on whether or not you are connected to the Internet. Refer to the sections below for more information.

Auto Register Toolkit (Connected to Internet)

Automatic registration works in much the same way as connected Toolkit registration and requires an Internet connection on the system where your application software will be deployed. The license information along with the system’s hardware information is sent over the Internet to the Accusoft licensing web service. If an unused license is available, a new license key containing information for the system is generated, returned, and is then automatically installed by the Server Licensing Utility.

Manually Register Toolkit (Disconnected from Internet)

Manual registration is used when the system where your application software will be deployed is not connected to the Internet and therefore cannot be registered automatically. This operation is similar to Disconnected Registration with the License Manager.

  1. Copy the Hardware Key and URL to a removable media device, such as a thumb drive, and then take it to a system that is connected to the Internet.
  2. From the connected system, paste the URL into a browser. A page will appear that contains a field into which you enter the hardware key.
  3. After this hardware key is entered, a license file with the license key is downloaded, which you then save to the removable media device.
  4. Return to the offline system with the removable media device onto which you have saved the license file.
  5. Click Open License File and navigate to the license file. Click OK in the file selection dialog.
    Alternatively, you can open the license file with a text editor, copy the license key to the clipboard, and click Paste License Key to paste the new license key into the License Key field.
  6. Click the License button; the new license will be installed.


Licensing Development Kit (LDK)

Accusoft.PrintPro6.ActiveX
Licensing Development Kit (LDK)
Send Feedback
PrintPRO 6 for ActiveX - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > LDK vs. SLU > Licensing Development Kit (LDK)

Glossary Item Box

The Licensing Development Kit is an ActiveX component that may be used instead of the Server Licensing Utility. (Actually, the Server Licensing Utility is only a user interface for the Licensing Development Kit.) The Licensing Development Kit provides an interface for a developer to set the License Configuration File path and other properties as well as initiate requests to the licensing web service to generate license keys.

This topic contains these sections:

  • AccuLicClient.DLL
  • Assigned Access Keys
  • Automatic (Connected) Mode Registration
  • Manual (Disconnected) Mode Registration
  • Evaluation
  • Licensing Development Kit Interface
  • Licensing Development Kit Properties
  • Licensing Development Kit Methods

AccuLicClient.DLL

The AccuLicClient.DLL is located with the Server Licensing Utility. It is a 32-bit ActiveX/COM DLL which is used to execute runtime licensing activation functions. The bulk of the functionality provided by the Server Licensing Utility (SLU) is contained within the AccuLicClient.DLL and can be used within your own custom applications to achieve the same thing.

Assigned Access Keys

Unlike the Server Licensing Utility, the Licensing Development Kit allows for the optional assignment of Access Keys to specific users. By doing this, you can specify which of your licenses are assigned to your users. This also limits the distribution of licenses. When Runtime licenses are purchased, a list of Access Keys is distributed to you for this use.

Automatic (Connected) Mode Registration

This mode corresponds to the Automatic (Connected) Registration section described in the Server Licensing Utility section. The process is shown in the C# sample code below:

Copy Code
// Instantiate the LDK ActiveX component
IDeploymentComponent ldk = new DeploymentComponent();

// Set the path to the configuration file provided
// when the runtime licenses were purchased.
ldk.ConfigPath = @"C:\config.txt";

// Attempt to get the next available license.
// Note that you may alternately pass an Access Key
ldk.GetLicKeyAuto("");

if (ldk.ResultCode != enumLdkErrorCodes.LDK_SUCCESS)
{
    // Automatic Registration Failed - A temporary license
    // has been installed but will expire in 15 days.
    // TODO add code to notify user of issue and 15 day expiration.

    if (ldk.ResultCode == enumLdkErrorCodes.LDK_ERR_INET_CONN_BROKEN)
    {
        // No Internet Connection – Optionally do manual registration
    }
}
else
{
    // The license has been registered and installed.
}

The registration process is then complete. If any part of the registration process fails, a temporary license key is installed and is typically valid for 15 days. During this time, you are allowed to use the product while resolving any licensing related problems.

Manual (Disconnected) Mode Registration

This mode corresponds to the Manual (Disconnected) Registration section described in the Server Licensing Utility section. The process is shown in the C# code below:

Copy Code
// Instantiate the LDK ActiveX component
IDeploymentComponent ldk = new DeploymentComponent();

// Set the path to the configuration file provided
// when the runtime licenses were purchased.
ldk.ConfigPath = @"C:\config.txt";

// Get the hardware key for the system.  Note
// that you may alternately pass an Access Key
string hardwareKey = ldk.GetHdwKey("");

// Write the hardware key to some type of removable media.
ApplicationSpecificMethodToWriteHardwareKey(hardwareKey);

At this point, you have the hardware key on some type of removable media. Take the media to a system that is connected to the Internet, acquire the license key by uploading the hardware key, write the new license key to the removable media, and then return to the disconnected system. The application then reads the license key from the removable media and installs the license key as shown below.

Copy Code
// After taking the hardware key to a system with an Internet
// connection and acquiring the license key string from the
// manual registration web site, read the key into your
// application.
string manuallyAcquiredLicenseKey = ApplicationSpecificMethodToReadLicenseKey();

// Install the license key
ldk.LicKey = manuallyAcquiredLicenseKey;

The manual license registration and installation is then complete. Like the automatic case above, if any error occurs during the setting of the license key, a temporary license is installed.

Evaluation

The Licensing Development Kit also has the ability to install an Evaluation License for purchased runtime products. This process is simply:

Copy Code
// Instantiate the LDK ActiveX component
IDeploymentComponent ldk = new DeploymentComponent();

// Set the path to the configuration file provided
// when the runtime licenses were purchased.
ldk.ConfigPath = @"C:\config.txt";

// Install an evaluation license
ldk.StartEvalPeriod();

Licensing Development Kit Interface

The interface to the Licensing Development Kit is shown below:

Copy Code
interface IDeploymentComponent : IDispatch
{
   [propget, id(1)] HRESULT LicKey([out, retval] BSTR* pVal);
   [propput, id(1)] HRESULT LicKey([in] BSTR newVal);
   [propget, id(2)] HRESULT srvURL([out, retval] BSTR* pVal);
   [propput, id(2)] HRESULT srvURL([in] BSTR newVal);
   [propget, id(3)] HRESULT ConfigPath([out, retval] BSTR* pVal);
   [propput, id(3)] HRESULT ConfigPath([in] BSTR newVal);
   [propget, id(4)] HRESULT ResultString([out, retval] BSTR* pVal);
   [propget, id(5)] HRESULT ResultCode([out, retval] enumLdkErrorCodes* pVal);
   [id(6)]           HRESULT GetLicKeyAuto([in] BSTR accKey);
   [id(7)]           HRESULT GetHdwKey([in] BSTR accKey, [out,retval] BSTR* hdwKey);
   [id(8)]           HRESULT StartEvalPeriod(void);
   [propget]         HRESULT LicenseInfo([out, retval] BSTR* pVal);
   [propput]         HRESULT LicenseInfo([in] BSTR newVal);
   [id(10)]          HRESULT GetEvalPeriod([out, retval] long* pVal);
};

Licensing Development Kit Properties

  • LicKey: Stores the License Key to the registry when it is set, and reads it from the registry during the get operation.
  • srvURL: Gets and sets the URL path to the licensing web service. The default is the URL path to Accusoft’s Deployment Licensing Service.
  • ConfigPath: Gets and sets a path to the deployment configuration file. Multiple products can be registered at one time by setting the filenames as a semicolon-delimited list: e.g., “c:\config.txt;c:\config2.txt”.
  • ResultString: Contains the string descriptions of any error that may have occurred during the last operation.
  • ResultCode: Can be used to contain any of the error codes described in Licensing Component Error Codes and Messages.
  • LicenseInfo: Used to transfer license information onto new system hardware. To transfer the license information into new system hardware, do the following:
  1. Get the LicenseInfo value and store it in a safe place.
  2. Change the system hardware.
  3. Set the LicenseInfo to the value you saved in step (1).
  4. Run the GetLicKeyAuto method (or perform its manual analog) to obtain a license for the new system hardware.

Licensing Development Kit Methods

  • GetLicKeyAuto: Obtains a License Key for the end user’s system using the automatic (or connected) scenario. It takes an Access Key as its input parameter, and stores the obtained license key in the registry. If you choose not to distribute individual Access Keys, the accKey argument should be an empty string.
  • GetHdwKey: Obtains a hardware key from the current machine and returns it (as hdwKey). If you choose not to distribute individual access keys, the accKey argument should be an empty string.
  • StartEvalPeriod: Sets an evaluation licensing mode for the product and starts an evaluation period. This method is provided so you can distribute an evaluation version of your application, without having to distribute Access Keys to people who would like to evaluate your software. Using this method you can license Accusoft components on the end user’s system for a limited time – the default is 30 days, but it can be customized per request to Accusoft. If the evaluators purchase your software, you can then issue them an access key using either the automatic or manual scenarios to obtain permanent component licenses, just as Accusoft does for its evaluators.
  • GetEvalPeriod: Obtains the remaining time on an evaluation (in days). It returns EvalPeriod < 0 if the evaluation period is expired.


Deployment Proxy Service (DPS)

Accusoft.PrintPro6.ActiveX
Deployment Proxy Service (DPS)
Send Feedback
PrintPRO 6 for ActiveX - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > Deployment Proxy Service (DPS)

Glossary Item Box

For systems where the deployed application will not have direct access to the Accusoft licensing web services, you can use the Deployment Proxy Service as a bridge to reroute the licensing communication. The Proxy Service will act as a trusted "go-between" for the Accusoft licensing system and the deployed application. This tool can be useful if the application will be deployed in a secured environment, where limited systems have external network access.

Additionally, the Proxy Service allows Accusoft customers to manage license registration more directly. The source for the Deployment Proxy Service is provided, allowing users to integrate the licensing process into their CRM, ERP, or other systems for tracking Automatically Reported Runtime Licenses.

For more information about the Deployment Proxy Service, please contact our Support team.


Manually Reported Runtime (Non-Node-Locked)

Accusoft.PrintPro6.ActiveX
Manually Reported Runtime (Non-Node-Locked)
Send Feedback
PrintPRO 6 for ActiveX - User Guide > Licensing > Runtime Licensing > Manually Reported Runtime (Non-Node-Locked)

Glossary Item Box

Manually Reported Runtime licensing embeds all of the licensing information directly into your application. Installation does not require any further licensing interaction. However, it is your responsibility to provide royalty reporting to Accusoft for the actual licenses deployed.

This section provides information about the following:

  • Solution Name
  • Solution Key
  • OEM License Key


Solution Name

Accusoft.PrintPro6.ActiveX
Solution Name
Send Feedback
PrintPRO 6 for ActiveX - User Guide > Licensing > Runtime Licensing > Manually Reported Runtime (Non-Node-Locked) > Solution Name

Glossary Item Box

The solution name

  • A name assigned by Accusoft to the licenses purchased for runtime deployment.
  • A character string that is set for a component prior to use in a deployment environment.
  • Typically the name of the organization that purchased the runtime licenses.
  • Set via the SetSolutionName method. For example:
Copy Code
PrintPro1.SetSolutionName("ACMEImaging");

The Solution Name must be set in order to use runtime licensing.


Solution Key

Accusoft.PrintPro6.ActiveX
Solution Key
Send Feedback
PrintPRO 6 for ActiveX - User Guide > Licensing > Runtime Licensing > Manually Reported Runtime (Non-Node-Locked) > Solution Key

Glossary Item Box

The Solution Key is

  • A set of four numbers assigned when the licenses are purchased for runtime deployment.
  • An identifier of the organization that purchased the runtime licenses.
  • Set via the SetSolutionKey method. For example:
Copy Code
PrintPro1.SetSolutionName("ACMEImaging");
PrintPro1.SetSolutionKey(0x1C3A023F, 0xA018F260, 0x37AF0E51, 0x557F2389);

The Solution Key must be set in order to use runtime licensing.


OEM License Key

Accusoft.PrintPro6.ActiveX
OEM License Key
Send Feedback
PrintPRO 6 for ActiveX - User Guide > Licensing > Runtime Licensing > Manually Reported Runtime (Non-Node-Locked) > OEM License Key

Glossary Item Box

The OEMLicense Key is

  • For use only by customers who choose to use Manually Reported Runtime licensing.
  • A unique identifier of the customer, product, version, edition, and platforms for which the license is valid.

When this key is set via the SetOEMLicenseKey method, the component is completely licensed and can be distributed without any further licensing operations.

Copy Code
PrintPro1.SetSolutionName("ACMEImaging");
PrintPro1.SetSolutionKey(0x1C3A023F, 0xA018F260, 0x37AF0E51, 0x557F2389);
PrintPro1.SetOEMLicenseKey("1.0.GQCC0EmUgONaI4QDZ32tpGWfpGW4gtbC0iIC0iN4bigYM3m3K5b487QOsAM38O24mUp5bOpD2O240OQ32U2YsUKDKA87MYPGgGgaptMiK5Nv8AI4mYg4m3QvW52DZCPGs4p784mtP4IUgOWiIG0AQYp4052iIAWvNCZfpGWC8vQ5P4ZGKaPAWfbiYfZOI303pOZAgisiNaWA27gGsf8Ob7Zvm5IaKGI4KC8GsG2CWYpGQAg5sUmYWvZCQANig48G2ap4bG0DsO240YsUmtptNiZamCPGbYMfMO83gANAZCN52YbY8U8f8DM4m3g7MYMYWGW5Q7QGWaMiN7MtZfmtgY8AN7NDP7Z4W7sCbGKUPa0im7EDPP");

This property is not required for Automatically Reported Runtime licensing.


ActiveX Website Runtime Licensing

Accusoft.PrintPro6.ActiveX
ActiveX Website Runtime Licensing
Send Feedback
PrintPRO 6 for ActiveX - User Guide > Licensing > Runtime Licensing > ActiveX Website Runtime Licensing

Glossary Item Box

Using an Accusoft ActiveX on a webpage is similar to Manually Reported Runtime (Non-Node-Locked), as it requires calls to SetSolutionName, SetSolutionKey, and SetOEMLicenseKey. However, the web licenses are not node-locked to particular hardware but are node-locked to a set of specific domains or sub-domains. Sub-paths of those domains and sub-domains do not require additional licensing, thus if http://www.mysite.com is licensed, so is http://www.mysite.com/imaging.

To get an OEM license key, the developer will identify one or more domains or sub-domains to Accusoft's Licensing Center. There is an ActiveX web licensing site that contains the OEM License Generator web application. This web application is used to create an OEM license key that the developer can use along with the solution name and solution key on the webpage in the domain or sub-domain.

Example

In the following example:

  • The solution name is "ACMEImaging"
  • The solution keys are "0x1C3A023F, 0xA018F260, 0x37AF0E51, 0x557F2389"
  • The domain specified is www.mysite.com

The developer would do the following:

  1. Log into Accusoft’s Licensing Center.
  2. Use the OEM License Generator web application to retrieve an OEM license key for www.mysite.com.
  3. Use the OEM license key on a webpage in the www.mysite.com domain.
Copy Code
PrintPro1.SetSolutionName "ACMEImaging"
PrintPro1.SetSolutionKey 0x1C3A023F, 0xA018F260, 0x37AF0E51, 0x557F2389
PrintPro1.SetOEMLicenseKey
"1.0.GQCC0EmUgONaI4QDZ32tpGWfpGW4gtbC0iIC0iN4bigYM3m3K5b487QOsAM38O24mUp5bOpD2O240OQ32U2YsUKDKA87MYPGgGgaptMiK5Nv8AI4mYg4m3QvW52DZCPGs4p784mtP4IUgOWiIG0AQYp4052iIAWvNCZfpGWC8vQ5P4ZGKaPAWfbiYfZOI303pOZAgisiNaWA27gGsf8Ob7Zvm5IaKGI4KC8GsG2CWYpGQAg5sUmYWvZCQANig48G2ap4bG0DsO240YsUmtptNiZamCPGbYMfMO83gANAZCN52YbY8U8f8DM4m3g7MYMYWGW5Q7QGWaMiN7MtZfmtgY8AN7NDP7Z4W7sCbGKUPa0im7EDPP"


Licensing Glossary

Accusoft.PrintPro6.ActiveX
Licensing Glossary
Send Feedback
PrintPRO 6 for ActiveX - User Guide > Licensing > Licensing Glossary

Glossary Item Box

The following sections each describe a licensing term:

  • Access Key
  • Accusoft Products
  • Activation
  • Assigned Access Key
  • Automatically Reported Runtime Licensing
  • Customers, Developers, and Users
  • Edition
  • Evaluation License
  • Hardware Key
  • License Configuration File
  • Licensing Development Kit (LDK)
  • License Key
  • License Manager
  • Manually Reported Runtime Licensing
  • Node-Locked Licensing
  • Non-Node-Locked Licensing
  • Paid License
  • Registration
  • Runtime (Deployment) Licensing
  • Server Licensing Utility (SLU)
  • Toolkit Licensing
  • Web Services

Access Key

All licenses are assigned a unique identifier known as an Access Key. Access Keys are associated with the organization that purchased the license.

Accusoft Products

An Accusoft product may be licensed with either a Toolkit License or a Runtime License.

Activation

Activation is the process of selecting a previously registered toolkit license. Licenses may be paid (Toolkit) or evaluation, and may be for one of many product editions, for products with multiple editions.

Assigned Access Key

An assigned Access Key is one that is assigned to a specific user or users. The assignment of Access Keys to specific users can be done using the Licensing Development Kit (LDK).

Automatically Reported Runtime Licensing

Runtimes may be licensed in one of two ways: automatic reporting or manual reporting. With automatic reporting, you do not need to worry about royalty reporting; it is handled by the licensing layer.

Customers, Developers, and Users

Customers are simply any person who has purchased an Accusoft product. Developers are customers who possess a license for an Toolkit. Users are typically the customers of Accusoft's customers who use applications built around Accusoft components and are assigned a runtime license.

Edition

Some Accusoft products have multiple editions. Editions may offer multiple levels of product speed or product features, allowing customers to find a price-performance mix that is appropriate for them. Products that support multiple editions register multiple Toolkit licenses at installation time, one Toolkit license per edition. Developers must select an edition to activate using the License Manager.

Evaluation License

An evaluation license is a Toolkit license that is unpaid. When an Accusoft Toolkit is installed, evaluation licenses for all applicable product editions are installed and registered, and the edition with the most features is activated. Evaluation Toolkit licenses can be used to try out products. However, the product behavior is limited by trial dialog pop-ups or timeouts. When you determine the product is a good fit, you can purchase a Toolkit license to eliminate trial dialog pop-ups and timeouts.

Hardware Key

When a license is activated for a product, the system information that identifies the installation hardware is contained within an encrypted string and is used to generate the license key for the product. The string containing the encrypted hardware information is known as the Hardware Key.

License Configuration File

When a Toolkit or an Automatically Reported Runtime license is purchased, a configuration file is provided that contains information about the license that was purchased. This file is used by the licensing utilities (License Manager, Server License Utility, and License Development Kit) to install a license on the system.

Licensing Development Kit (LDK)

The Licensing Development Kit (LDK) is an ActiveX component that may be used for Runtime Licensing. The LDK is one mechanism for Automatically Reported Runtime Licensing; the Server Licensing Utility (SLU) is the other.

License Key

Each product license has a unique key associated with it that uniquely identifies the customer, product, version, edition, and platforms, and, in some cases, the hardware for which the license is valid.

License Manager

The License Manager is a GUI application that is used by a developer to register and activate Toolkit licenses on their development system.

Manually Reported Runtime Licensing

Runtimes may be licensed in one of two ways: automatic reporting or manual reporting. With Manually Reported Runtime Licensing, you embed all of the licensing information directly into your application. You must manually provide royalty reporting to Accusoft for the actual licenses deployed. This model will be the best choice for you if you are not connected to the Internet at runtime, as might be the case in an defense or financial application.

Node-Locked Licensing

Another name for Automatically Reported Runtime Licensing.

Non-Node-Locked Licensing

Another name for Manually Reported Runtime Licensing.

Paid License

A paid license is a Toolkit license that you have purchased from Accusoft. It is ready to be used in production, with no trial dialog pop-ups, timeouts, or evaluation watermarks. If you wish to test other editions of the Accusoft product for which you have purchased a Paid License, you may activate an Evaluation license for that edition; a complete set of Evaluation licenses for all editions is registered at installation time.

Registration

Registration is the process of informing the License Manager about a new Toolkit license you have purchased. It uses this information to create a license key on your system; this allows you to activate the product for development with no restrictions, such as trial dialog pop-ups, timeouts, or evaluation watermarks.

Runtime (Deployment) Licensing

When deploying an application, a Runtime License is also required for each user’s installation. You must purchase runtime licenses, which are consumed as licenses are registered. There are two Runtime licensing models: Automatically Reported Runtime License; and Manually Reported Runtime License.

Server Licensing Utility (SLU)

The Server Licensing Utility (SLU) is a small GUI application that allows you to request a license key from the Runtime licenses you have purchased. The SLU is one mechanism for Automatically Reported Runtime Licensing; the Licensing Development Kit (LDK) is the other.

Toolkit Licensing

Each Toolkit is assigned to a specific developer who has a registered account with Accusoft. When the developer installs the Toolkit, it is not fully functional until they have activated the license through the use of the License Manager application. When the developer starts the License Manager, they are required to provide login credentials that identify and allow them to activate their license on a development system. See Toolkit Licensing.

Web Services

When a license is registered, information that uniquely identifies the customer’s or user’s hardware is passed along with the license information over the Internet to a web service. The web service validates the licensing request, generates a key that includes the hardware information, and returns the new license key to the application that made the licensing request. The license key is then stored on the requested system and used by the component when it is executed. It is also possible to register systems that are not directly connected to the Internet through the use of removable media and a different system that is connected to the Internet.


Software License Agreement

Accusoft.PrintPro6.ActiveX
Software License Agreement
See Also Send Feedback
PrintPRO 6 for ActiveX - User Guide > Licensing > Software License Agreement

Glossary Item Box

PLEASE READ THE FOLLOWING SOFTWARE LICENSE AGREEMENT WHICH GOVERNS YOUR RIGHT TO USE OF THE TOOLKIT. YOU MUST ACCEPT THESE TERMS BEFORE YOU ARE ALLOWED TO INSTALL THE TOOLKIT. YOU EXPRESSLY AGREE THAT YOU HAVE THE AUTHORITY TO CONTRACTUALLY BIND THE ORGANIZATION AGREEING TO THESE TERMS.

BY CLICKING "I ACCEPT," OR INSTALLING TOOLKIT, OR PLACING TOOLKIT IN-USE, LICENSEE IS AGREEING TO BE BOUND BY THIS AGREEMENT.

1. GRANT OF AGREEMENT

This Accusoft Corporation, ("ACCUSOFT") Software License Agreement ("AGREEMENT") grants the organization contracting under this agreement as licensee ("LICENSEE") a limited, nontransferable, nonexclusive and non-assignable license to use the trial mode version of this ACCUSOFT Development Toolkit ("TOOLKIT") on a single computer for evaluation of fitness only and not for any commercial purpose; or to use a properly purchased and registered TOOLKIT, for development purposes only on a single computer, provided the TOOLKIT is IN-USE on only one computer at any time. (However additional TOOLKIT licenses may be purchased.) TOOLKIT is "IN-USE" on a computer when it becomes loaded by any means for any purpose into temporary memory (that is, including but not limited to RAM) or when it becomes copied or installed to less temporary storage by any means for any purpose (that is, including but not limited to hard disk, CD-ROM or other removable disk or tape, USB or other flash memory drive or card, or other local, networked, or cloud storage device) when it is accessible to that computer. The TOOLKIT is explicitly not to be used on a site-wide basis, via a server or other networked connection.

2. REDISTRIBUTION OF TOOLKIT RUNTIMES

ACCUSOFT does not grant LICENSEE any rights to deploy, license, sell, reproduce, copy, install, lease, timeshare, rent, or otherwise distribute or transfer TOOLKIT or any portion of TOOLKIT ("PORTION") except as provided in Section 1. GRANT OF AGREEMENT. For licensing information about any other distribution of TOOLKIT or PORTION, please visit our web site (www.accusoft.com/licensing.htm), or contact our sales staff. LICENSEE agrees to notify ACCUSOFT immediately of any violations or changes in status regarding LICENSEE's compliance with any term of this AGREEMENT.

In the event that ACCUSOFT grants LICENSEE in a written separate runtime license agreement ("RUNTIME AGREEMENT") a right to deploy, license, sell, reproduce, copy, install, lease, timeshare, rent, or otherwise distribute or transfer PORTIONS, the RUNTIME AGREEMENT will specify what PORTIONS may be distributed ("RUNTIME"). LICENSEE agrees to acknowledge and uphold the terms and conditions of this AGREEMENT as well as the terms of the RUNTIME AGREEMENT itself, which will be provided only in writing. In such event, LICENSEE may distribute RUNTIMES as part of the LICENSEE's software application or derivative works ("PRODUCT") upon additionally agreeing to the following:

a) LICENSEE understands and acknowledges that in order to receive any discounted pricing for RUNTIME distribution licensing fees based on the type of installation, it must either: 1) prepay for a number of RUNTIME licenses that is sufficient to qualify for ACCUSOFT's then-current published quantity discount, or 2) it must pay for the licenses in accordance with a written contract between LICENSEE and ACCUSOFT.

b) LICENSEE's PRODUCT shall not compete to any degree with the TOOLKIT. Such competitive PRODUCTS are defined as software development toolkits that include similar functionality as TOOLKIT and that are intended for use by software developers and/or system integrators.

c) LICENSEE's PRODUCT must be substantially greater in scope with greater functionality and features than those of the TOOLKIT.

d) LICENSEE will not use ACCUSOFT's name, logo, or trademarks to market PRODUCT without prior written approval of ACCUSOFT except LICENSEE will include a statement substantially similar to the following within PRODUCT documentation and about box: "Portions of this product contain imaging and other technology owned by Accusoft Corporation, Tampa, FL, (www.accusoft.com). ALL RIGHTS RESERVED."

e) LICENSEE agrees to only distribute the RUNTIMES. No license or other rights are granted to LICENSEE for any distribution of the TOOLKIT or PORTIONS including, but not limited to, documentation, source code, or the RUNTIME distribution unlock codes.

g) LICENSEE will only distribute the RUNTIMES on the hardware and operating system(s) for which the RUNTIMES are intended to be used according to the RUNTIME AGREEMENT.

If ANY of the terms of this AGREEMENT are not applicable to LICENSEE'S situation, or if any of the terms of this AGREEMENT cannot be complied with, or if LICENSEE needs modifications to this AGREEMENT or the license granted for any reason, LICENSEE must contact ACCUSOFT about obtaining an expanded license from ACCUSOFT (available by phone at: 813-875-7575, x321, by e-mail at: Sales@accusoft.com or by fax at: 813-875-7705).

This AGREEMENT grants rights to LICENSEE only for the TOOLKIT and does not convey any other rights of use or distribution to ACCUSOFT technology.

3. OWNERSHIP

LICENSEE acknowledges and agrees that ACCUSOFT owns all rights, title and interest in the TOOLKIT, in all forms, including without limitation any and all worldwide proprietary rights therein, including but not limited to trademarks, copyrights, patent rights, patent continuations, trade secrets and confidential information.

LICENSEE may not remove or alter the copyright notice from any copy of the TOOLKIT or any copy of the written materials, accompanying the TOOLKIT.

LICENSEE waives its right to contest any of ACCUSOFT's patents, trademarks, service marks, trade names, copyrights, and other intellectual property and proprietary rights in and to the TOOLKIT.

LICENSEE shall not use such trademarks, service marks, and trade names except where and as permitted under this AGREEMENT without receiving ACCUSOFT's prior written approval of such use. If such approval is granted, LICENSEE’s right to use such trademarks, service marks, and trade names shall end upon the termination of this AGREEMENT.

4. RESTRICTIONS AND RESERVATIONS.

All rights and licenses not expressly granted to LICENSEE are reserved to ACCUSOFT. LICENSEE is strictly prohibited from reproducing, copying, marketing, selling, distributing, licensing, sublicensing, leasing, timesharing or renting the TOOLKIT or PORTION, and LICENSEE is strictly prohibited from any use of the TOOLKIT or PORTION except as permitted by this AGREEMENT, and such actions are expressly prohibited. LICENSEE is strictly prohibited from incorporating or including the TOOLKIT or PORTION into or as part of any PRODUCT or service of LICENSEE except as provided by this AGREEMENT, regardless of the functionality of TOOLKIT (or lack thereof) within or as part of such PRODUCT or service of LICENSEE. LICENSEE shall not for any reason disassemble, decompile, decrypt or reverse engineer the TOOLKIT or PORTION or in any manner attempt to discover or reproduce the source code or any other copyrightable, proprietary, or trade secret aspect of the TOOLKIT or PORTION. Nor shall LICENSEE use the TOOLKIT or PORTION, directly or indirectly, in developing LICENSEE's own PRODUCT with, or including, similar functionality. LICENSEE shall not make any copies of the TOOLKIT or PORTION for any purpose whatsoever except as permitted by this AGREEMENT. Source code that is provided with TOOLKIT for sample or demonstration purposes may be used directly or indirectly in developing PRODUCT, however it may not be distributed in source form in whole or in part with or as part of PRODUCT.

5. WARRANTY DISCLAIMER

LICENSEE ACKNOWLEDGES AND AGREES THAT THE TOOLKIT IS PROVIDED "AS IS." ACCUSOFT DISCLAIMS ANY AND ALL REPRESENTATIONS AND WARRANTIES OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND AGAINST INFRINGEMENT.

6. LIMITATION OF LIABILITY

ACCUSOFT SHALL HAVE NO LIABILITY TO LICENSEE, LICENSEE AFFILIATES, SUBSIDIARIES, SHAREHOLDERS, OFFICERS, DIRECTORS, EMPLOYEES, REPRESENTATIVES OR ANY THIRD PARTY, WHETHER IN CONTRACT, TORT, NEGLIGENCE OR PRODUCTS LIABILITY, FOR ANY CLAIM, LOSS OR DAMAGE, INCLUDING BUT NOT LIMITED TO, LOST PROFITS, LOSS OF USE, BUSINESS INTERRUPTION, LOST DATA, LOST FILES, OR FOR ANY DIRECT, INDIRECT, SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES OF ANY KIND OR NATURE WHATSOEVER ARISING OUT OF OR IN CONNECTION WITH USE OF OR INABILITY TO USE THE TOOLKIT, OR THE PERFORMANCE OR OPERATION OF THE TOOLKIT, EVEN IF ACCUSOFT HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

7. INDEMNIFICATION BY LICENSEE

LICENSEE SHALL INDEMNIFY, HOLD HARMLESS AND DEFEND ACCUSOFT FOR ANY LOSS, CLAIM, ACTION OR PROCEEDING THAT ARISES OR RESULTS FROM ANY ACTIONS OR OMISSIONS OF LICENSEE PERTAINING TO THE PRODUCT OR THE TOOLKIT AND FROM ANY ACTIONS OF LICENSEE THAT ARE IN VIOLATION OF THIS AGREEMENT.

8. TERM AND TERMINATION

Unless otherwise agreed to by the parties, this AGREEMENT shall become effective upon the earlier of LICENSEE's clicking of "I Accept" or LICENSEE'S installing or placing TOOLKIT IN_USE ("Effective Date") and shall continue in full force and effect until terminated in accordance with the terms set forth in this AGREEMENT.

Any material breach of this AGREEMENT shall automatically and immediately terminate this AGREEMENT. In the event that LICENSEE ceases to do business or is adjudged bankrupt or insolvent, ACCUSOFT may, at its sole option, terminate this AGREEMENT, by giving ten (10) Business Days written notice of such termination, which notice shall identify and describe the basis for such termination.

In the event of any termination of this AGREEMENT, any RUNTIME AGREEMENT is simultaneously terminated and LICENSEE shall stop using the TOOLKIT and PORTION, shall cease manufacturing the PRODUCT containing TOOLKIT or PORTION, and shall cease distributing PRODUCT containing TOOLKIT or PORTION. LICENSEE shall also require its resellers, OEMs, and other distribution channels (if any) to likewise stop manufacturing and distributing the PRODUCT containing TOOLKIT or PORTION. Within ten (10) Business Days thereafter, LICENSEE shall return or, at ACCUSOFT's option, destroy, the TOOLKIT and all PORTIONS, whether or not incorporated in or with the PRODUCT, that are within LICENSEE’s possession, custody and control, and shall certify to ACCUSOFT in writing within ten (10) Business Days after that return or destruction that it has complied with the foregoing obligation.

All Sections except Section 1. GRANT OF LICENSE shall continue in full force and effect, notwithstanding any termination of this AGREEMENT.

9. LIQUIDATED DAMAGES

In the event LICENSEE (a) copies the TOOLKIT or PORTION except as permitted by this AGREEMENT, (b) uses the TOOLKIT or PORTION for any reason other than as permitted by this AGREEMENT, (c) installs or uses the TOOLKIT or PORTION on more than a single computer, or (d) otherwise violates or breaches this Agreement, LICENSEE agrees that ACCUSOFT is entitled to obtain as liquidated damages and not as a penalty the greater of the amount of (v) the published quantity one distribution price based upon the type of distribution, or (w) $99 per each user of each PRODUCT or service of LICENSEE in which the TOOLKIT or PORTION is included, copied, incorporated, embedded or accessible; (x) $100 per copy of TOOLKIT or PORTION; (y) $100 per copy of any PRODUCT in which TOOLKIT or PORTION is included, copied, incorporated, embedded or accessible; or (z) 3% of all revenues realized by LICENSEE pertaining to any PRODUCTS or services of LICENSEE in which TOOLKIT or PORTION is included, copied, incorporated, embedded or accessible. THE LICENSEE EXPRESSLY AGREES THAT THE FOREGOING LIQUIDATED DAMAGES ARE NOT A PENALTY.

10. CONFIDENTIALITY

LICENSEE acknowledges that the TOOLKIT contains ACCUSOFT know-how, confidential and trade secret information ("PROPRIETARY INFORMATION"). LICENSEE agrees: (a) to hold the PROPRIETARY INFORMATION in the strictest confidence, (b) not to, directly or indirectly, copy, reproduce, distribute, manufacture, duplicate, reveal, report, publish, disclose, cause to be disclosed, or otherwise transfer the PROPRIETARY INFORMATION to any third party, (c) not to make use of the PROPRIETARY INFORMATION other than as permitted by this AGREEMENT, and (d) to disclose the PROPRIETARY INFORMATION only to LICENSEE's representatives requiring such material for effective performance of this AGREEMENT and who have undertaken an obligation of confidentiality and limitation of use consistent with this AGREEMENT. This obligation shall continue as long as allowed under applicable law.

11. INJUNCTIVE RELIEF

LICENSEE agrees that any violation or threat of violation of this AGREEMENT will result in irreparable harm to ACCUSOFT for which damages would be an inadequate remedy. Therefore, in addition to its rights and remedies available at law (including but not limited to the recovery of damages for breach of this AGREEMENT), ACCUSOFT shall be entitled to immediate injunctive relief to prevent any violation of ACCUSOFT's copyright, trademark, trade secret rights regarding the TOOLKIT, or to prevent any violation of this AGREEMENT, including, but not limited to, unauthorized use, copying, distribution or disclosure of or regarding the TOOLKIT or PORTION, as well as any other equitable relief as the court may deem proper under the circumstances.

12. NO REDUCED PRICING

In any determination of ACCUSOFT's damages (whether liquidated damages or actual damages), or any determination of any licensing fees or royalties due ACCUSOFT under this AGREEMENT due to a breach by LICENSEE hereunder, LICENSEE shall not be entitled to any discounts (volume or otherwise) or reduced licensing fees or royalties. The foregoing sentence shall be applicable unless LICENSEE has negotiated and entered into a written, signed agreement with ACCUSOFT for such reduced or discounted licensing fees or royalties and paid ACCUSOFT such fees or royalties in advance of any: (a) distribution of the TOOLKIT or PORTION, (b) copying of the TOOLKIT or PORTION, or (c) incorporation or use of the TOOLKIT or PORTION in or pertaining to any PRODUCT or service of LICENSEE. Further, LICENSEE agrees that it shall not be entitled to reduced licensing fees or royalties when determining ACCUSOFT's damages due to any undertaking or activity by LICENSEE regarding the TOOLKIT or PORTION outside of or exceeding the scope of permission or other terms of this AGREEMENT, or LICENSEE's actions otherwise in violation of this AGREEMENT.

13. ATTORNEYS' FEES AND COSTS

In the event of any lawsuit or other proceeding brought as a result of any actual or alleged breach of this AGREEMENT, to enforce any provisions of this AGREEMENT, or to enforce any intellectual property or other rights in or pertaining to the TOOLKIT or PORTION, the prevailing party shall be entitled to an award of its reasonable attorneys’ fees and costs, including the costs of any expert witnesses, incurred at all levels of proceedings.

14. GOVERNING LAW

This AGREEMENT shall be construed, governed and enforced in accordance with the laws of the State of Florida, without regard to any conflicts of laws rules. Any action related to or arising out of this AGREEMENT will be filed only in the Florida courts and LICENSEE consents to the exclusive jurisdiction and venue of the state and federal courts located in Tampa, Florida.

15. SEVERABILITY

If any provision of this AGREEMENT is determined to be invalid by any court of final jurisdiction, then it shall be omitted and the remainder of the AGREEMENT shall continue to be binding and enforceable. In addition, the Court is hereby authorized to enforce any provision of the AGREEMENT that the Court otherwise deems unenforceable, to whatever lesser extent the Court deems reasonable and appropriate, rather than invalidating the entire provision. Without limiting the generality of the foregoing, LICENSEE expressly agrees that should LICENSEE be found to have breached the AGREEMENT, under no circumstances shall LICENSEE be entitled to any volume or other discount, or reduced licensing fee or royalty in the determination of ACCUSOFT's damages, or otherwise in the determination of any licensing fee or royalty owed to ACCUSOFT.

16. GOVERNMENT RIGHTS

The TOOLKIT and accompanying documentation have been developed at private expense and are sold commercially. They are provided under any U.S. government contracts or subcontracts with the most restricted and the most limited rights permitted by law and regulation. Whenever so permitted, the government and any intermediaries will obtain only those rights specified in ACCUSOFT's standard commercial license. Thus, the TOOLKIT referenced herein, and the documentation provided by Accusoft hereunder, which are provided to any agency of the U.S. Government or U.S. Government contractor or subcontractor at any tier shall be subject to the maximum restrictions on use as permitted by FAR 52.227-19 (June 1987) or DFARS 227.7202-3(a) (Jan. 1, 2000) or successor regulations. Manufacturer is Accusoft Corporation, 4001 N. Riverside Drive Tampa, FL 33603.

17. ENTIRE AGREEMENT

This AGREEMENT represents the entire understanding of the parties concerning the subject matter hereof and supersedes all prior communications and agreements, whether oral or written, relating to the subject matter of this AGREEMENT. Only a writing signed by the parties may modify this AGREEMENT. In the event of any modification in writing, of this AGREEMENT, including an expanded license agreement, all sections of this Agreement survive except Section 2. Limited License.

18. CONTACT US

Should you have any questions concerning this AGREEMENT, or if you desire to contact ACCUSOFT for any reason, please contact ACCUSOFT at 1-813-875-7575.

19. OTHER RESTRICTIONS

a) This AGREEMENT shall not be amended, altered, changed or modified in any way, unless agreed to in writing by both ACCUSOFT and LICENSEE. Such writing must be executed by a duly authorized representative of ACCUSOFT and a duly authorized representative of LICENSEE.

b) This AGREEMENT is not transferable or assignable by LICENSEE under any circumstances, without the prior written consent of ACCUSOFT. ACCUSOFT will not unreasonably withhold such consent. This AGREEMENT shall be binding upon, and is made for the benefit of, each party, its successors, and permitted assignees (if any). For the purposes of this AGREEMENT, any change in control of LICENSEE shall constitute an assignment or transfer of this AGREEMENT requiring prior written consent of ACCUSOFT. As used in this section, a change in control is defined as (i) any change in ownership of more than fifty percent (50%) of the voting interest in LICENSEE, whether by merger, purchase, foreclosure of a security interest or other transaction, or (ii) a sale of all or substantially all of the assets of LICENSEE.

c) The relationship established by this AGREEMENT between LICENSEE and ACCUSOFT shall be that of Licensee and Licensor. Nothing contained in this AGREEMENT shall be construed as creating a relationship of agency, joint venture or partnership between LICENSEE and ACCUSOFT. Neither party shall have any right whatsoever to incur any liabilities or obligations on behalf of the other party.

d) ACCUSOFT's failure to perform any term or condition of this AGREEMENT as a result of conditions beyond its control such as, but not limited to, war, strikes, fires, floods, acts of God, governmental restrictions, power failures, or damage or destruction of any network facilities or servers, shall not be deemed a breach of this AGREEMENT.

e) The headings provided in this AGREEMENT are for convenience and reference purposes only. In the event of a conflict between the terms and conditions listed in this AGREEMENT, and any attached Schedules or Appendices, the terms and conditions of this AGREEMENT shall govern.

f) A waiver of a breach, violation, or default under this AGREEMENT shall not be a waiver of any subsequent breach, violation or default. Failure of either party to enforce compliance with any term or condition of this AGREEMENT shall not constitute a waiver by the party of such term or condition.

g) All notices and communications shall be in writing and shall be deemed to have been duly given the earlier of when delivered or three (3) Business Days after mailing by certified mail, return receipt requested, postage prepaid, or by international delivery service, addressed to the parties at their respective addresses set forth on the Order Form or at such other addresses as the parties may designate by written notice in accordance with this section.

Rev. 20120112

See Also

Getting Support
Distributing PrintPRO


Distributing Applications & Deployment

Accusoft.PrintPro6.ActiveX
Distributing Applications & Deployment
Send Feedback
PrintPRO 6 for ActiveX - User Guide > Distributing Applications & Deployment

Glossary Item Box

This section provides the following information:

  • Verify You're Using the Latest Service Pack
  • Distributing PrintPRO


Verify You're Using the Latest Service Pack

Accusoft.PrintPro6.ActiveX
Verify You're Using the Latest Service Pack
See Also Send Feedback
PrintPRO 6 for ActiveX - User Guide > Distributing Applications & Deployment > Verify You're Using the Latest Service Pack

Glossary Item Box

Service pack updates will not overwrite paid licensing. Your paid licensing will continue to work and you will not be required to re-enter your purchased registration codes. Service pack updates do not include any changes that might "break" previously developed and/or deployed code.

Verify Latest Development Components

To verify you are using the latest version of an Accusoft Development Component or Components, please refer to the currently released product build numbers at www.accusoft.com/latestbuilds.htm.

If you require further assistance or have questions or comments, please see the section Getting Support for more detailed information.

See Also

Getting Support


Distributing PrintPRO

Accusoft.PrintPro6.ActiveX
Distributing PrintPRO
See Also Send Feedback
PrintPRO 6 for ActiveX - User Guide > Distributing Applications & Deployment > Distributing PrintPRO

Glossary Item Box

Rebuild Executable to Register

Open your project with your development tool (Visual Basic or Delphi) and rebuild the executable .exe file. The new registration information will be automatically incorporated in the new executable.

DLL Files to Distribute

Distribute the appropriate assembly DLL files with applications using the PrintPRO component.

  • Accusoft.PrintPro6.ActiveX.dll - ActiveX component - ActiveX Control for accessing and modifying printer properties, creating print jobs, previewing printing, and printing to a device or file.
  • Oleaut32.dll - the Microsoft support DLL.
  • Stdole2.tlb - the Microsoft support file.

See Also

Getting Support
Licensing


Concepts

Accusoft.PrintPro6.ActiveX
Concepts
Send Feedback
PrintPRO 6 for ActiveX - User Guide > Concepts

Glossary Item Box

This section provides information about the following:

  • Overview of PrintPRO
  • Introduction to Image Color Management (ICM)
  • State Diagram
  • Glossary


Overview of PrintPRO

Accusoft.PrintPro6.ActiveX
Overview of PrintPRO
See Also Send Feedback
PrintPRO 6 for ActiveX - User Guide > Concepts > Overview of PrintPRO

Glossary Item Box

PrintPRO enables you to create a document composed of images, text, and graphics, and print the document to a selected printer or print to file.

The process for composing and printing documents is as follows:

  1. Select a printer. PrintPRO automatically selects the system default printer but you can select any printer connected to your system. If you want to use the default printer, you can skip to step 2.

  2. Set the printer properties. Printer properties include the paper size, print quality, orientation, etc. If you want to use the printers default properties, you can skip to step 3.

  3. Set the Image Color Management (ICM) Method and Intent as needed.

  4. Use the DocName Property to set the document name. When the system spools your document for printing, the document name appears in the list of documents to be printed. The default document name is PrintPRO Document. If you want to use the default document name, skip to step 5.

  5. Start a document. You can use the StartPrintDoc method to start a document, however, PrintPRO's text, graphics and bitmap methods will automatically start a document if one has not been started.

  6. Place text, graphics and bitmaps on the document page. The NewPage Method lets you start a new page and the Page Property returns the current page number.

  7. Create, then print and/or display print preview page(s) if desired.

  8. Print the document. Use the EndPrintDoc Method to send the document to the print spooler. If the PrintToFile Property is True, the print output is redirected to a disk file. If you want to stop printing the current document, use the KillPrintDoc Method before you start a new document.

See Also

Create Print Job


Introduction to Image Color Management (ICM)

Accusoft.PrintPro6.ActiveX
Introduction to Image Color Management (ICM)
See Also Send Feedback
PrintPRO 6 for ActiveX - User Guide > Concepts > Introduction to Image Color Management (ICM)

Glossary Item Box

The Problem

You scan a photo in order to edit it but the image on the screen doesn't look like the original. And when you print it out the colors are even less like the original! What you see is not what you get.

Information

The problem is that the different devices (scanner, monitor and printer) have different interpretations of the digital values for colors. Not only are the interpretations different from device to device but so is the “gamut”, the range of realizable colors (some devices can display/output/print colors that others can not).

Solution

Windows’ Image Color Management (ICM) system is the what-you-see-is-what-you-get solution to the color accuracy problem. PrintPRO allows the application programmer to enable and access ICM features.

ICM processes all images via a standardized intermediate color scheme: the Profile Connection Space (PCS). In the above example the image from the scanner would be adjusted for that particular scanner’s profile (data file) to get it into the standard color space. It would then be adjusted for that particular monitor’s profile to display or that particular printer’s profile to be printed. Each device gets its own profile and the devices must be properly calibrated to get good results.

Image Color Management is an involved subject. More information can be found at the International Color Consortium’s web site (www.color.org).

With PrintPRO there are two levels of Image Color Management: enabling the various device drivers or with Windows' ICM as specified by the ICM Method.

Color Management is designed to work with 24-bit color or 8-bit grayscale images. Color correction performed on images with less bit depth than this will result in poor quality images. PrintPRO has no native ability to promote images to higher bit depth; it is recommended that you use ImagXpress to do so.

See Also

PP_IcmIntent Enumeration
PP_IcmMethod Enumeration
ICMMethod Property


State Diagram

Accusoft.PrintPro6.ActiveX
State Diagram
Send Feedback
PrintPRO 6 for ActiveX - User Guide > Concepts > State Diagram

Glossary Item Box

PrintPRO™ enables the application to select a printer, perform printer set up, create a print job, preview the print job, and send the print job to the printing device. These tasks can be illustrated with a state diagram:

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

No Session in Progress

The application is free to initiate printer selection, printer set up, print job creation, or raw data transfer.

Printer Selection

Once PrintPRO has been created, the application may choose to select a printer. If no printer is selected, the default printer will be used. While a print job is in progress, the printer selection cannot be modified.

Printer SetUp

The application may chose to set up the printer, using either PrintPRO or the printer dialog. If no printer setup is conducted, the printer's default settings will be in effect. While a print job is in progress, the printer settings cannot be modified.

Send Raw Data

To bypass the print driver, the application can send raw data directly to the printer. Since the printer driver is by-passed, the data sent must be printer specific. The raw data may contain printer commands, codes and binary data. Large amounts of data may be sent to the printer using this technique.

Print Job Creation

The application calls PrintPRO methods to construct the document to be printed. Images, text, and drawings can be added to the print job.

Print Preview

At any point during job creation, the application can invoke a print preview to enable the user to view or print the page under construction.

Print Job Has Been Sent

Once the document or raw data to be sent has been finalized, the application calls EndPrintDoc or PrintRawDataEnd to send the print job to the printer spooler. PrintPRO is now done processing the job, and returns to a "No Session in Progress" state.


Glossary

Accusoft.PrintPro6.ActiveX
Glossary
Send Feedback
PrintPRO 6 for ActiveX - User Guide > Concepts > Glossary

Glossary Item Box

A | B | C | D | E | F | G | H | I | J | K | L | M | N | O | P | Q | R | S | T | U | V | W | X | Y | Z

T

Thread-safe
An application using this component can use multiple controls running in the same process, where they don't interfere with each other. The thread creating the control owns the control and is the only thread that can interact with it.


How To

Accusoft.PrintPro6.ActiveX
How To
Send Feedback
PrintPRO 6 for ActiveX - User Guide > How To

Glossary Item Box

This section provides information about how to do the following:

  • Set Up Printer
  • Create Print Job
  • Print Preview
  • Print
  • Send Raw Data to the Printer - Bypassing the Print Driver
  • Debug Your Application


Set Up Printer

Accusoft.PrintPro6.ActiveX
Set Up Printer
Send Feedback
PrintPRO 6 for ActiveX - User Guide > How To > Set Up Printer

Glossary Item Box

This section provides information about how to do the following:

  • Set Printer Properties
  • Set Margins
  • Set Printer Coordinates
  • Change Font


Set Printer Properties

Accusoft.PrintPro6.ActiveX
Set Printer Properties
Send Feedback
PrintPRO 6 for ActiveX - User Guide > How To > Set Up Printer > Set Printer Properties

Glossary Item Box

PrintPRO™ lets you set or get most printer properties. For example, you can set the orientation of the printer paper and select the paper bin without displaying a dialog box. You cannot be guaranteed that the printer driver supports the printer property you are trying to set. The ErrorCode property will be set to 5016 if a printer property cannot be set.

The following is a list of printer properties supported by PrintPRO:

  • ColorMode property — Tells the printer to print in color or black and white.

  • Collate property — Tells the printer to collate multiple copies of a document.

  • Copies property — Tells the printer how many copies to print. You can determine the number of copies that the printer can print using the NumCopies property.

  • DitherType property — Tells the printer how to dither.

  • ICMIntent property — Tells the printer which Image Color Management method to use.

  • ICMMethod property — Tells the printer how Image Color Management should be handled.

  • PaperBin property — Tells the printer what paper bin to use. If you don’t know what paper bin to select, you can use the NumBins , BinID and BinName properties to determine the bins supported by the printer.

  • PaperSize property — Sets the printers paper size. If you don’t know what paper size to select, you can use the NumPapers , PaperID and PaperName properties to determine the papers supported by the printer.

  • PrintQuality property — Sets the print quality (low, medium, high or a specific DPI).

  • Duplex property — Tells the printer how to print double sided. You can use the DuplexCap property to determine if the printer supports duplex printing.

  • Zoom property — Sets the printers scale factor. For example, setting the Zoom property to 50 tells the printer to print at 50/100 or ½ scale.


Set Margins

Accusoft.PrintPro6.ActiveX
Set Margins
Send Feedback
PrintPRO 6 for ActiveX - User Guide > How To > Set Up Printer > Set Margins

Glossary Item Box

PrintPRO™ has top, left and bottom margins that can be set using the TMargin Property, Lmargin Property, and BMargin Property respectively. Margins are used by the PrintText Method.

When the Lmargin Property is set, the CurrentX Property is automatically set to the same value. When the TMargin Property is set, the CurrentY Property is automatically set to the same value.

The AutoMargin Property can be used to automatically set the margins to the top, left and bottom of the printers display area. For example, the following code prints Hello World at the upper left corner of the display area.

Example Copy Code
Object.AutoMargin = True
Object.PrintText "Hello World"

You can also set the margins within the printers display area manually as follows:

Example Copy Code
Object.LMargin = object.DisplayX
Object.TMargin = object.DisplayY
Object.Bmargin = Object.DisplayY


Set Printer Coordinates

Accusoft.PrintPro6.ActiveX
Set Printer Coordinates
Send Feedback
PrintPRO 6 for ActiveX - User Guide > How To > Set Up Printer > Set Printer Coordinates

Glossary Item Box

Printer System

The printer coordinate system is based on the physical dimensions of the paper in the printer. The horizontal and vertical starting position (0,0) is located at the upper left corner of the paper. Printer units are defined by the ScaleMode property. The default ScaleMode is twips. If the printer has 8½ x 11in. paper and the orientation of the paper is portrait, the width of the printer is 12240 twips and the height is 15840 twips. You can get the physical height and width of the printer using the PHeight and PWidth properties.

Printer Display Area

A printer also has a display area. The display area is located inside the physical area. The ScaleWidth and ScaleHeight properties can be used to get width and height of the display area. The DisplayX and DisplayY properties can be used to get the coordinates of the upper left corner of the display area.

Printer Resolution

The resolution of a printer is measured in dots per inch. You can get the horizontal and vertical resolution of a printer using the ResX and ResY properties.

Twips

There are times when you might need to know the number of twips per printer dot (or pixel). The TwipsPerPixelX and TwipsPerPixelY properties can be used to get the printers horizontal or vertical twips per pixel.

Internal Coordinates

The PrintPRO control maintains internal coordinates that are used, and updated, by some of the text, graphics and bitmap methods. The CurrentX property can be used to get or set the internal horizontal coordinate. The CurrentY property can be used to get or set the internal vertical coordinate. For example, if the CurrentX and CurrentY properties are set to 1440 twips, the following code will print Hello World one inch from the top and left side of the paper since the PrintText method uses the CurrentX and CurrentY values to position the text.

Example Copy Code
PrintPRO1.CurrentX = 1440
PrintPRO1.CurrentY = 1440
PrintPRO1.PrintText "Hello World"


Change Font

Accusoft.PrintPro6.ActiveX
Change Font
Send Feedback
PrintPRO 6 for ActiveX - User Guide > How To > Set Up Printer > Change Font

Glossary Item Box

PrintPRO™ has a font object that makes it easy to change the font of printed text. In some containers, the font object is not readily available. In this case, use the following methods to change the font characteristics:

  • SetCtlFontSize — sets the font size.

  • SetCtlFontStyle — sets the font style.

  • SetCtlFontName — sets the font name.


Create Print Job

Accusoft.PrintPro6.ActiveX
Create Print Job
Send Feedback
PrintPRO 6 for ActiveX - User Guide > How To > Create Print Job

Glossary Item Box

PrintPRO™ enables you to create a document to print, display, or store, and include elements such as binary data, graphics, and bitmaps within the document.

To create a document:

  1. Set the Document name using the DocName Property.
  2. Start the document by selecting the StartPrintDoc Method.
  3. HINT: To ensure that the Page Property is reset after printing an image, it is critical that the SelectDefaultPrinter Method or SetDefaultPrinterW Method is used before calling the StartPrintDoc Method.

Create the Print Job by performing the following:

  1. Set Margins - set the margins on the printed page.
  2. Add Text - add text to the document to be printed.
  3. Add Binary Data - add binary data to the document to be printed.
  4. Add Bitmaps - add bitmaps to the document to be printed.
  5. Add Graphics - add graphics to the document to be printed.
  6. For multiple page documents, use the NewPage Method to advance to the next page. The Page Property returns the current page number.
  7. End the document by selecting the EndPrintDoc Method. This will result in your document being sent to the device spooler. KillPrintDoc Method can be called to immediately terminate the print job if needed.


Add Text

Accusoft.PrintPro6.ActiveX
Add Text
Send Feedback
PrintPRO 6 for ActiveX - User Guide > How To > Create Print Job > Add Text

Glossary Item Box

PrintPRO™ gives the developer flexibility when adding text. The simplest way to add text is to use the PrintText Method .

Placing Text

The PrintText method adds text at the CurrentX Property and CurrentY Property position. If the AddCR Property is set to True, PrintText Method automatically inserts a carriage return after the text is printed. The PrintText Method does not wrap text to a new line if it does not fit on the current line.

The TextHeight Method and the TextWidth Method can be used to return the height and width of a text string.

Aligning Text

If you want to align the text, use the PrintTextAligned Method . This method automatically aligns text inside a rectangular area using the alignment style defined by the Alignment Property . Text will also automatically wordwrap if the WordWrap Property is set to True.

Rotating Text

If you want to rotate the text, use the PrintTextRotated Method . This method lets you specify a rotation angle, pivot point and pivot mode. If the pivot point is not specified, the CurrentX Property and CurrentY Property values are used. The pivot mode specifies whether the text is left justified, right justified or center justified at the pivot point.

Setting Fonts

The Font object lets you set the printer's font name, size, and attributes (bold, underline, etc.). Use the Font Property to return a font object. If some containers, the font object is not readily available. In this case, use the following methods to change the font characteristics:

  • SetCtlFontSize — sets the font size.

  • SetCtlFontStyle — sets the font style.

  • SetCtlFontName — sets the font name.

Setting Background Style

The BackStyle Property lets you display text transparently or on a solid color background. The BackColor Property determines the color of the text background and the ForeColor Property determines the color of the text.


Add Binary Data

Accusoft.PrintPro6.ActiveX
Add Binary Data
Send Feedback
PrintPRO 6 for ActiveX - User Guide > How To > Create Print Job > Add Binary Data

Glossary Item Box

To add binary data stored in an array of bytes, use the PrintData Method.

To add data to print directly to the current printer, use the PrintRawData Method. Since the printer driver is by-passed by this method, the data must be printer specific. The raw data may contain printer commands, codes and binary data. Large amounts of data may be sent to the printer using this technique.


Add Bitmaps

Accusoft.PrintPro6.ActiveX
Add Bitmaps
Send Feedback
PrintPRO 6 for ActiveX - User Guide > How To > Create Print Job > Add Bitmaps

Glossary Item Box

PrintPRO™ lets you print Device Independent Bitmaps (DIB) and Device Dependent Bitmaps (DDB).

Bitmaps can be printed stretched (or resized) inside a rectangular area with or without the aspect ratio being maintained. The ability to automatically maintain the bitmap's aspect ratio makes it easy to display large document images correctly on the printed page.

Adding a DIB

To add a DIB, the hDIB Property must first be set to a valid Windows DIB handle. The ImagXpress control exports a Windows DIB handle. Next, use the PrintDIB Method to print the DIB. The DIBHeight Property and DIBWidth Property return the height and width of the DIB. If the OwnDIB Property is True, PrintPRO will delete the DIB after it is printed.

Adding a DDB

To print a DDB, the Picture Property must first be set to a valid bitmap. The ImagXpress control exports bitmaps using a Picture Property or the Picture property can be set using the LoadPicture function in Visual Basic. Next, use the PrintPicture Method to print the DDB. The PictureHeight Property and PictureWidth Property Picture return the height and width of the DDB. If you want to print a Device Dependent Bitmap using a handle to the bitmap (HBITMAP), you can first set the Picture Property using the SetPictureBMP Method then print the bitmap using the PrintPicture Method.

Adding a Transparent Bitmap

Bitmaps can be printed transparently. To print a bitmap transparently, set the PictureTransparent Property to True, then set the PictureTransparentColor Property to the color in the image that you want transparent.


Add Graphics

Accusoft.PrintPro6.ActiveX
Add Graphics
Send Feedback
PrintPRO 6 for ActiveX - User Guide > How To > Create Print Job > Add Graphics

Glossary Item Box

PrintPro™ supports adding the following graphic types to the document to be printed:

  • Arcs - use the DrawArc Method.
  • Curves - use the DrawCurve Method.
  • Lines, Rectangles, and Points - use the DrawLine Method.
  • Circles and Ellipses - use the DrawCircle Method.
  • Pie Shapes - use the DrawPie Method.
  • Polygons - use the DrawPolygon Method.

Rectangles with Rounded Corners - use the DrawRoundRect Method.

The method used to draw the graphic is determined by the following:

  • FillColor - to set the color to fill the graphic.
  • FillStyle - to set the pattern to fill the graphic.
  • DrawMode - to specify how pen color and background color will be combined.
  • DrawStyle - to determine the pattern of the line defining the graphic.
  • DrawWidth - to set the width of the line defining the graphic.


Print Preview

Accusoft.PrintPro6.ActiveX
Print Preview
Send Feedback
PrintPRO 6 for ActiveX - User Guide > How To > Print Preview

Glossary Item Box

PrintPRO™ lets you create a print preview image for any document page.

1. Decide whether to display print preview while printing document

You can create print preview images only or you can simultaneously create print preview images while printing a document. Set the PrintPreviewOnly Property to True if you only want to create print preview images. If you plan on creating print preview images while printing a document, you need to start a print document using the StartPrintDoc Method before initiating a print preview.

2. Initiate Print Preview

To initiate a print preview, you must call the StartPrintPreview Method. After initiating a print preview, continue to create the document to print. Use the EndPrintPreview Method to end the print preview. If you are creating a multiple page document, PrintPRO will automatically create a print preview for each page.

3. View a Print Preview page

When you want to view a print preview for a page, you first need to determine the size of the print preview image using the PrintPreviewScale Property. Next, use the GetPrintPreview Method to create a bitmap image for the page you want to view. Finally, use the PrintPreviewPicture Property, PrintPreviewDIB Property, or PrintPreviewDDB Property to export the print preview image.

4. Resource Cleanup

Print preview requires system resources that PrintPRO automatically takes care of. You can, however, delete the print preview resources yourself. The DelPrintPreviewPicture Method deletes the print preview bitmap image. You can always recreate the bitmap using the GetPrintPreview Method, so deleting the bitmap image when it is no longer needed will conserve system resources.

The DelPrintPreview Method deletes the print preview resources for a page. If you delete the print preview resources, you cannot recreate the bitmap image for that page.

Example Copy Code
'The following code creates a simple print preview of a single line of text. An ImagXpress® control is used to display the image.
PrintPRO1.PrintPreviewOnly = True
PrintPRO1.StartPrintPreview
PrintPRO1.PrintText "Print Preview Page 1"
PrintPRO1.EndPrintPreview
PrintPRO1.GetPrintPreview 1
ImagXpress.Picture = PrintPRO1.PrintPreviewPicture

If you want to draw directly to the print preview Device Context (DC), use the hMetaDC Property to obtain the DC.


Print

Accusoft.PrintPro6.ActiveX
Print
Send Feedback
PrintPRO 6 for ActiveX - User Guide > How To > Print

Glossary Item Box

This section provides information about how to do the following:

  • Print to a File
  • Print Using PrintPRO & ImagXpress
  • Print without ImagXpress
  • Print a Multi-Page TIFF Image Using PrintPRO & ImagXpress


Print to a File

Accusoft.PrintPro6.ActiveX
Print to a File
Send Feedback
PrintPRO 6 for ActiveX - User Guide > How To > Print > Print to a File

Glossary Item Box

This sample shows that with PrintPRO™ printing to a file is very much the same as generating printer output but with a few properties set to the appropriate values. Any printer output, regardless of how it is generated, can be easily directed to a file.

Example Copy Code
' NOTE: all of the dimensions in this demo are in twips.
' Give the document a name.The default document
' name is PrintPRO Document.
PrintPRO1.DocName = "Accusoft's PrintPRO Demo"
PrintPRO1.OutputFileName = App.Path + "\AccusoftTst.tif"

' Direct output to a file instead of a printer.
PrintPRO1.PrintToFile = True

' Specify which kind of file, could be:
' PP_TIF_G4 (B&W COMPRESSED - STANDARD)
' PP_TIF (COLOR)
' PP_TIF_G3 (B&W COMPRESSED)
' PP_TIF_G3_2D (B&W COMPRESSED)
' PP_TIF_BMP (COLOR)
' PP_EMF (ENHANCED META-FILE)
' PP_PDF_G4 (B&W COMPRESSED IMAGE FILE)
PrintPRO1.SaveFileType = PP_TIF

' Specify the density for the file.
PrintPRO1.RequestedDPI = 100

' Start a print job by starting a new page.
PrintPRO1.StartPrintDoc
PrintPRO1.PrintPreviewOnly = False

' Print the information on the page just as you would for
' creating printer output...
PrintPRO1.BackStyle = 1 'Opaque
PrintPRO1.ForeColor = RGB(255, 255, 255) 'White text
PrintPRO1.BackColor = RGB(0, 0, 0) 'Black background
PrintPRO1.Font.Name = "arial"
PrintPRO1.Font.Bold = True
PrintPRO1.Font.Size = 24
PrintPRO1.Alignment = ALIGN_CenterJustifyMiddle ' Center justify the text
prWidth = PrintPRO1.PWidth
PrintPRO1.PrintTextAligned " Hello! Check out PrintPRO 4.0 ", 1000, PrintPRO1.TMargin, prWidth - 1000, 1100

' Add a previously loaded graphic to the output.
PrintPRO1.PrintPicture 1640, 5700, 0, 0, 0, 0, 0, 0, True

' End the print job. This will end the current page and create the file.
PrintPRO1.EndPrintDoc


Print Using PrintPRO & ImagXpress

Accusoft.PrintPro6.ActiveX
Print Using PrintPRO & ImagXpress
Send Feedback
PrintPRO 6 for ActiveX - User Guide > How To > Print > Print Using PrintPRO & ImagXpress

Glossary Item Box

The following sample shows how to print using PrintPRO and ImagXpress.

Example Copy Code
' define variables
Dim a As Integer
Dim b As Integer

' set the handle to the dib and scale mode
PrintPRO1.hDib = ImagXpress1.hDib
PrintPRO1.ScaleMode = SCALE_Pixel

' start the print document
PrintPRO1.StartPrintDoc

' set the margins
a = PrintPRO1.ScaleWidth - PrintPRO1.LMargin
b = PrintPRO1.ScaleHeight - PrintPRO1.TMargin - PrintPRO1.BMargin
PrintPRO1.PrintDIB PrintPRO1.LMargin, PrintPRO1.TMargin, a, b, 0, 0, 0, 0, True

' end the print document
PrintPRO1.EndPrintDoc


Print without ImagXpress

Accusoft.PrintPro6.ActiveX
Print without ImagXpress
Send Feedback
PrintPRO 6 for ActiveX - User Guide > How To > Print > Print without ImagXpress

Glossary Item Box

To print a document, use the following steps:

  1. Select a printer. PrintPRO™ automatically selects the system default printer but you can select any printer connected to your system. If you want to use the default printer, you can skip to step 2.

  2. Set the printer properties. Printer properties include the paper size, print quality, orientation, etc. If you want to use the printers default properties, you can skip to step 3.

  3. Use the DocName property to set the document name. When the system spools your document for printing, the document name appears in the list of documents to be printed. The default document name is PrintPRO Document. If you want to use the default document name, skip to step 4.

  4. Start a document. You can use the StartPrintDoc method to start a document, however, PrintPRO's text, graphics and bitmap methods (e.g. PrintText) will automatically start a document if one has not been started.

  5. Print text, graphics and bitmaps on the document page. The NewPage method lets you start a new page and the Page property returns the current page number.

  6. Print the document. Use the EndPrintDoc method to send the document to the print spooler.

If you want to stop printing the current document, before you start a new document, use the KillPrintDoc method.

Example Copy Code
' Define variables
Dim a As Integer
Dim b As Integer
' define the image and scale mode
PrintPRO1.Picture = LoadPicture ("\MyDocuments\mypicture.bmp")
PrintPRO1.ScaleMode = SCALE_Pixel
' start the print
PrintPRO1.StartPrintDoc
' set the margins
a = PrintPRO1.ScaleWidth - PrintPRO1.LMargin
b = PrintPRO1.ScaleHeight - PrintPRO1.TMargin - PrintPRO1.BMargin
PrintPRO1.PrintDIB PrintPRO1.LMargin, PrintPRO1.TMargin, a, b, 0, 0, 0, 0, True
' end the print document
PrintPRO1.EndPrintDoc


Print a Multi-page TIFF Image Using PrintPRO & ImagXpress

Accusoft.PrintPro6.ActiveX
Print a Multi-page TIFF Image Using PrintPRO & ImagXpress
Send Feedback
PrintPRO 6 for ActiveX - User Guide > How To > Print > Print a Multi-page TIFF Image Using PrintPRO & ImagXpress

Glossary Item Box

This example uses an ImagXpress control to load a multi-page (TIFF, PDF, ICO, MODCA or DCX) file, PrintPRO then prints them, one page at a time.

Example Title Copy Code
' define the variables
Dim a As Integer
Dim b As Integer
Dim counter As Integer

' start the print document
PrintPRO1.PrintDialog
PrintPRO1.StartPrintDoc

' set the counter to go through each page of the document
For counter = 1 To ImagXpress1.NumPages(ImagXpress1.FileName)
IX1.PageNbr = counter
IX1.FileName = ImagXpress1.FileName
PrintPRO1.hDib = ImagXpress1.hDib

' set the margins
a = PrintPRO1.ScaleWidth - 1 - PrintPRO1.LMargin
b = PrintPRO1.ScaleHeight - 1 - PrintPRO1.TMargin - PrintPRO1.BMargin
PrintPRO1.PrintDIB PrintPRO1.LMargin, PrintPRO1.TMargin, a, b, 0, 0, 0, 0, True
PrintPRO1.NewPage

' iterate through each page
Next counter

' end print document when all pages are complete
PrintPRO1.EndPrintDoc


Send Raw Data to the Printer - Bypassing the Print Driver

Accusoft.PrintPro6.ActiveX
Send Raw Data to the Printer - Bypassing the Print Driver
Send Feedback
PrintPRO 6 for ActiveX - User Guide > How To > Send Raw Data to the Printer - Bypassing the Print Driver

Glossary Item Box

  1. Open a direct-to-printer print session by calling PrintRawDataStart.
  2. Specify data to be sent directly to the printer by calling PrintRawData.
  3. Send the print data, then close the direct-to-printer session by calling PrintRawDataEnd.


Debug Your Application

Accusoft.PrintPro6.ActiveX
Debug Your Application
Send Feedback
PrintPRO 6 for ActiveX - User Guide > How To > Debug Your Application

Glossary Item Box

Because debugging and writing debug information to a log file is time consuming and expensive, PrintPRO™ provides the ability to control the level of information written to the debug log as well as the ability to turn off writing to a file completely.

Use the objects below to adjust the settings of your debugging, event handling, memory and IDispose for optimal performance.

Control Debugging Information

  • Debug - Turns on or off the ability to write to the debug log file.
  • DebugLogFile - A filename which stores the debug log information.
  • ErrorLevel - Controls the amount of information that is written to the debug log file.
When ErrorLevel is set to Detailed, PrintPRO logs most of your calls to the component including the occurrence of exceptions, the result of most major operations and the operation of each event it raises.

Troubleshooting

Stop Memory Leaks

After using the PrintPRO object, call the Dispose method.

Reset the Page Property after Printing the Image

Please make sure that the SelectDefaultPrinter method or SetDefaultPrinter method is being called before using the StartPrintDoc method.

Error Codes

Listed below is a cross-reference of error codes and their corresponding descriptions.

  • -5000 — No printer DC

  • -5001 — A document has already been started

  • -5002 — A document has not been started

  • -5003 — StartPrintDoc method failed

  • -5004 — Windows StartPage function failed

  • -5005 — Print dialog failed probably because the user clicked the Cancel button

  • -5006 — EndPrintDoc failed probably because the printer reported an error

  • -5007 — Bad radius value

  • -5008 — Bad angle value

  • -5009 — The Windows StretchBlt function failed when printing a bitmap

  • -5010 — No Memory

  • -5011 — Invalid printer number

  • -5012 — Invalid parameter

  • -5013 — No printer selected

  • -5014 — Cannot open the printer

  • -5015 — Cannot get the property value

  • -5016 — Cannot set the property value

  • -5017 — Invalid DIB handle

  • -5018 — Setup dialog failed, probably because the user pressed the Cancel button

  • -5019 — The Picture property or hDIB property has not been set

  • -5020 — Cannot get default printer information from the system

  • -5021 — Cannot write to the printer

  • -5022 — Cannot end a print job

  • -5023 — Invalid print preview page number

  • -5024 — A print preview for the current page does not exist

  • -5025 — Cannot get metafile DC

  • -5026 — Cannot create overlay

  • -5027 — Cannot open file

  • -5028 — No DIB

  • -5029 — Error reading file

  • -5030 — Invalid TIFF size

  • -5031 — Error writing file

  • -5032 — TIFF tag not found

  • -5033 — TIFF tag item not found

  • -5034 — Invalid profile

  • -5035 — Generic GDI

  • -5036 — Invalid template

  • -5037 — Invalid print preview

  • -5038 — Invalid handle

  • -5039 — Cannot get error message

  • -5040 — Generic Win32 error

  • -5041 — Printing disabled

  • -5042 — Invalid pointer

  • -5043 — Invalid bin ID

  • -5044 — Invalid paper ID

  • -5045 — Cannot create compatible device

  • -5333 — Invalid license edition

  • -5400 — Invalid worker object ID

  • -5500 — Error initializing worker

  • -5900 — Printer driver failure

  • -5995 — Invalid license

  • -5996 — Invalid web code

  • -5999 — Not license


PrintPRO 6 for ActiveX - API Reference

Accusoft.PrintPro6.ActiveX
PrintPRO 6 for ActiveX - API Reference
Send Feedback

Glossary Item Box

This API Reference provides detailed information about all PrintPRO public API members.


Project Overview

Accusoft PrintPRO 6
Project Overview
Send Feedback

Glossary Item Box

Description

Accusoft PrintPRO 6

Classes

Class Module | Description
PrintPro | Accusoft PrintPRO Control 6.0

Public Enumerations

Enumeration | Description
PP_Alignment | Option values which define the possible text alignment styles.
PP_BackStyle | Option values which define the possible background styles of printed text.
PP_ColorMode | Option values which define two values: one for printing in color and one for printing in monochrome.
PP_DebugErrorLevel | Option values which determine the amount of logging to write to the debug log file.
PP_DitherType | Option values which define the possible types of dithering that can be done.
PP_DrawMode | Option values which define the possible values to determine appearance of output from graphics methods.
PP_DrawStyle | Option values which define the possible line styles for output from graphics methods.
PP_Duplex | Option values which define the possible duplexing options.
PP_EvaluationMode | Option values which defines the possible behaviors of the control when in evaluation (non-licensed) mode.
PP_FillStyle | Option values which define the possible patterns used to fill circles, boxes, round rectangles, pie-shapes and polygons created with graphics methods.
PP_FROMHDIBMETHOD | Specifies the FromHdib method type.
PP_IcmIntent | Option values which define the possible color management methods, or intents, to use by default.
PP_IcmMethod | Option values which define the possibilities for how Image Color Management (ICM) is handled.
PP_MediaType | Option values which define the possible media to print on.
PP_Orientation | Option values which define the set of possible orientations for the document.
PP_PaperSize | Option values which define possible paper sizes for printing.
PP_PreviewScale | Option values which define the possible sizes of the print preview image.
PP_PrintQuality | Option values which define the possible values for printer resolution.
PP_PrintRange | Option values which determine the print range selected on the print dialog.
PP_PrintRangeEnable | Option values which determine the available radio buttons to enable in the print dialog.
PP_RenderIntent | Option values which determine the color correction to use.
PP_SaveFileType | Option values which define the possible types of files generated.
PP_ScaleMode | Option values which define the possible units of measurement for coordinates of an object when printing or using graphics methods.
PP_SourceBin | Option values which define the possible default paper bins that can be set.
PP_TOHDIBMETHOD | Specifies the ToHdib method type.
PP_TrueTypeOption | Option values which define the possible options for printing TrueType fonts.


PrintPro Object

PrintPro Object
See Also Members Send Feedback
AccusoftPrintPro6 ActiveX DLL : PrintPro Object

Glossary Item Box

Description

Accusoft PrintPRO Control 6.0

Object Model

PrintPro Object

See Also

PrintPro Members


PrintPro Object Members

PrintPro Object Members
See Also Overview Send Feedback
AccusoftPrintPro6 ActiveX DLL : PrintPro Object

Glossary Item Box

Public Methods

Public Method AboutBox | Displays a licensing, version and copyright information dialog box for PrintPRO.
Public Method BinID | Returns the printer manufacturer's bin ID number for the specified printer bin.
Public Method BinName | Returns the name of the specified paper bin.
Public Method DelPrintPreview | Deletes the print preview resources for a specified page.
Public Method DelPrintPreviewPicture | Deletes the current print preview bitmap.
Public Method DrawArc | Creates an arc on a document to be printed.
Public Method DrawCircle | Creates a circle or ellipse on a document to be printed.
Public Method DrawCurve | Creates a Bezier curve on a document to be printed.
Public Method DrawLine | Creates lines and rectangles on a document to be printed.
Public Method DrawPie | Creates a pie-shaped wedge on a document to be printed.
Public Method DrawPolygon | Creates a three to six sided polygon on a document to be printed.
Public Method DrawRoundRect | Creates a rectangle with rounded corners on the document to be printed.
Public Method EndPrintDoc | Releases the current document to the print device or spooler.
Public Method EndPrintPreview | Creates print preview resources for the current print preview page.
Public Method FromHdib | Sets the current image to the supplied DIB (Device Independent Bitmap).
Public Method FromHdib64 | Sets the current image to the supplied DIB (Device Independent Bitmap) in 64-bit environments.
Public Method GetMaxDPI | Fetches the maximum DPI resolution available.
Public Method GetNumSupportedDpis | Gets the number of resolutions supported by the printer.
Public Method GetPrintPreview | Creates a bitmap image for a print preview page and sets the PrintPreviewPicture property.
Public Method GetSupportedDpis | Gets the resolutions supported by the printer in dots per inch.
Public Method KillPrintDoc | Call this method to allow the PrintPRO control to run on a specified web site.
Public Method NewPage | Ends the current page and advances to the next page.
Public Method PaperID | Returns the printer manufacturer's paper ID number for any supported paper.
Public Method PaperName | Returns the printer manufacturer's paper name for any supported paper.
Public Method PrintData | Places data stored in an array of bytes into the document to be printed.
Public Method PrintDialog | Displays a printer dialog box.
Public Method PrintDIB | Draws a device independent bitmap (DIB) on a document to be printed.
Public Method PrintPicture | Draws a bitmap image on a document to be printed.
Public Method PrintRawData | Outputs data directly to a printer.
Public Method PrintRawDataEnd | Closes the direct-to-printer session.
Public Method PrintRawDataStart | Opens a direct-to-printer print session.
Public Method PrintTemplateDIB | Incorporates the image currently represented by the control's hDIB member according to a line from the TemplateFile.
Public Method PrintTemplatePicture | Incorporates the image currently represented by the control's Picture member according to a line from the TemplateFile.
Public Method PrintText | Places text in the document to be printed.
Public Method PrintTextAligned | Places text on the document inside a specified rectangular area within the display area.
Public Method PrintTextRotated | Places text rotated on the document to be printed.
Public Method SelectDefaultPrinter | Selects the system default printer.
Public Method SelectPrinter | Selects one of the printers installed on the system.
Public Method SelectPrinterByName | Selects one of the printers installed on the system by the given printer name.
Public Method SetCtlFontName | Sets the font name.
Public Method SetCtlFontSize | Sets the font size.
Public Method SetCtlFontStyle | Sets the font style.
Public Method SetDefaultPrinterW | Selects the system default printer.
Public Method SetOEMLicenseKey | Sets the PrintPRO control runtime OEM license key.
Public Method SetPictureBMP | Sets the Picture property using a handle to a Device Dependent Bitmap and a handle to a palette.
Public Method SetSolutionKey | Sets the PrintPRO control runtime license deployment key.
Public Method SetSolutionName | Sets the PrintPRO control runtime license deployment solution name.
Public Method SetupDialog | Displays a printer setup dialog box that lets the user change printer properties.
Public Method StartPrintDoc | Creates a document to be composed and printed.
Public Method StartPrintPreview | Starts a print preview for the current page.
Public Method TextHeight | Calculates the height of a text string as it would be printed in the current font.
Public Method TextWidth | Calculates the width of a text string as it would be printed in the current font.
Public Method ToHdib | Returns the handle to the current DIB (Device Independent Bitmap).
Public Method ToHdib64 | Returns the handle to the current DIB (Device Independent Bitmap) in a 64-bit environment.

Public Properties

Public Property AddCR | Gets and sets the automatic carriage return flag.
Public Property Alignment | Gets and sets the text alignment style used by the PrintTextAligned method.
Public Property AlignTextHeight | Gets the line height based on the Alignment property centering in pixels.
Public Property AutoMargin | Gets or sets a value to determine if the margin values and the current print position values should automatically be set to values inside the printer's display area.
Public Property BackColor | The background color of printed text.
Public Property BackStyle | Sets the background style of printed text.
Public Property BMargin | Gets or sets the bottom margin value.
Public Property Collate | Gets or sets an indicator whether collation should be used when printing multiple copies (if the printer supports this feature).
Public Property ColorMode | Gets or sets a value that determines whether a color printer prints output in color or monochrome.
Public Property Copies | Gets or sets a value that determines the number of copies to be printed.
Public Property CurrentX | Returns or sets the horizontal coordinate for the next printing or drawing method.
Public Property CurrentY | Gets or sets the vertical coordinate for the next printing or drawing method.
Public Property Debug | A property that represents whether or not debug logging is turned on.
Public Property DebugErrorLevel | Minimum error level a debug message must be for it to be logged in the log file.
Public Property DebugLogFile | The file name and location of the debug log file.
Public Property DIBHeight | Gets the height of the bitmap defined by the hDIB property in printer units defined by the ScaleMode property.
Public Property DIBWidth | Gets the width of the bitmap defined by the hDIB property in printer units defined by the ScaleMode property. Not available at design time.
Public Property DisplayX | Gets the horizontal coordinate of the display area in printer units defined by the ScaleMode property.
Public Property DisplayY | Gets the vertical coordinate of the display area in printer units defined by the ScaleMode property.
Public Property DitherType | Gets or sets a value that specifies how dithering is to be done (if the printer supports this feature).
Public Property DocName | Gets or sets the document name.
Public Property DrawMode | Gets or sets a value that determines the appearance of output from graphics methods.
Public Property DrawStyle | Gets or sets a value that determines the line style for output from graphics methods.
Public Property DrawWidth | Gets or sets the line width for output from graphics methods.
Public Property Duplex | Gets or sets a value that determines whether a page is printed on both sides (if the printer supports this feature). Not available at design time.
Public Property DuplexCap | Gets an indicator if duplex printing is possible.
Public Property ErrorCode | Gets and sets the error code.
Public Property ErrorDescription | Gets the error description.
Public Property EvaluationMode | Gets and sets the type of evaluation operation for the component.
Public Property FillColor | Gets or sets the color used to fill in circles, boxes, round rectangles, pie-shapes and polygons created with the DrawCircle, DrawLine, DrawRoundRect, DrawPie and DrawPolygon graphics methods.
Public Property FillStyle | Gets or sets the pattern used to fill circles, boxes, round rectangles, pie-shapes and polygons created with the DrawCircle, DrawLine, DrawRoundRect, DrawPie and DrawPolygon graphics methods.
Public Property Font | Gets a Font object.
Public Property ForeColor | Gets or sets the color used to display text.
Public Property hDC | Gets a handle to the device context of a printer.
Public Property hDIB | Gets or sets a handle to a device independent bitmap image (DIB).
Public Property hDIB64 | Gets or sets a handle to a device independent bitmap image (DIB) for 64-bit environments.
Public Property hMetaDC | Gets a handle to the current print preview metafile device context (DC).
Public Property ICMIntent | Gets or sets a value that specifies which of three possible color management methods, or intents, should be used by default (if the printer supports this feature).
Public Property ICMMethod | Gets or sets a value that specifies how Image Color Management (ICM) is handled.
Public Property ICMMonitorProfileName | This is the file name of the monitor's color management profile.
Public Property ICMPrinterProfileName | This is the file name of the printer's color management profile.
Public Property ICMProfileRenderIntent | Gets and sets the purpose of the color correction.
Public Property ICMWantProof | Gets an indicator if ICM is used.
Public Property Licensed | Gets an indicator if the component is licensed.
Public Property Lmargin | Gets or sets the left margin value.
Public Property MediaType | Gets or sets a value that specifies the type of media being printed on (if the printer supports this feature).
Public Property NumBins | Gets the number of bins supported by the printer.
Public Property NumCopies | Returns the number of copies that the printer can print.
Public Property NumPapers | Gets the number of papers supported by the printer.
Public Property NumPrinters | Gets the number of printers installed on the system.
Public Property Orientation | Gets or sets a value indicating whether documents are printed in portrait or landscape mode (if the printer supports this feature).
Public Property OutputFileName | Gets or sets a string value that specifies the print output file.
Public Property OwnDIB | Gets or sets the DIB ownership flag.
Public Property Page | Gets the current page number.
Public Property PaperBin | Gets or sets a value indicating the default paper bin on the printer from which paper is fed when printing (if the printer supports this feature).
Public Property PaperSize | Gets or sets a value indicating the paper size for the current printer (if the printer supports this feature).
Public Property PdFromPage | Gets and sets the initial value for the starting page edit control in the print dialog box.
Public Property PdMaxPage | Gets or sets a value indicating the maximum page number allowed for the end page number when the user selects the Pages radio button on the Print Dialog box.
Public Property PdMinPage | Gets or sets a value indicating the minimum page number allowed for the start page number when the user selects the Pages radio button on the Print Dialog box.
Public Property PdRange | Gets a value indicating the Print Range selected on the Print Dialog box.
Public Property PdRangeEnable | Gets or sets a value indicating which Print Range radio buttons are enabled on the Print Dialog box.
Public Property PdToPage | Gets or sets a value indicating the end page number when the user selects the Pages radio button on the Print Dialog box.
Public Property PHeight | Gets the physical height of the paper set up for the printing device, in units determined by the ScaleMode property.
Public Property Picture | Gets or sets a bitmap image to load into the control.
Public Property PictureHeight | Gets the height of the bitmap defined by the Picture property in printer units defined by the ScaleMode property.
Public Property PictureTransparent | Sets or returns the transparent picture flag.
Public Property PictureTransparentColor | Sets or returns the transparent color of the image in the control.
Public Property PictureWidth | Gets the width of the bitmap defined by the Picture property in printer units defined by the ScaleMode property.
Public Property PrintEnabled | Disables or enables all printing.
Public Property PrinterDriverName | Returns the current printer driver name.
Public Property PrinterName | Returns the current printer name.
Public Property PrinterNum | Gets the index of the current printer in the printer collection.
Public Property PrinterPortName | Returns the name of the port through which a document is sent to a printer.
Public Property PrintPreviewDDB | Gets a handle to the print preview Device Dependent Bitmap (DDB).
Public Property PrintPreviewDIB | Gets a handle to the print preview Device Independent Bitmap (DIB).
Public Property PrintPreviewDIB64 | Gets a handle to the print preview Device Independent Bitmap (DIB) for 64-bit environments.
Public Property PrintPreviewOnly | Determines whether PrintPRO only generates print preview images.
Public Property PrintPreviewPicture | Gets a picture object of the print preview page.
Public Property PrintPreviewScale | Sets the size of the print preview image.
Public Property PrintQuality | Gets or sets a value indicating the printer resolution (if the printer supports this feature).
Public Property PrintRightToLeft | Gets and sets an indicator which determines if text output is printed from right-to-left.
Public Property PrintToFile | Gets and sets an indicator if the print output from printer devices to disk file is redirected.
Public Property PWidth | Gets the physical width of the paper set up for the printing device, in units determined by the ScaleMode property.
Public Property RaiseExceptions | Gets and sets an indicator whether to raise exceptions.
Public Property RequestedDPI | Gets or sets the current DPI resolution.
Public Property ResX | Gets the horizontal resolution of the printer in dots per inch (e.g. 600 DPI).
Public Property ResY | Gets the vertical resolution of the printer in dots per inch (e.g. 600 DPI).
Public Property SaveFileType | Controls the type of file generated.
Public Property ScaleHeight | Gets the number of units for the vertical measurement of the interior of a printer.
Public Property ScaleMode | Gets or sets a value indicating the unit of measurement for coordinates of an object when printing or using graphics methods.
Public Property ScaleWidth | Gets the number of units for the horizontal measurement of the interior of a printer.
Public Property TemplateFile | The photograph collage description file name.
Public Property TMargin | Gets or sets the top margin value.
Public Property TTOptions | Gets or sets a value indicating the printer’s TrueType option.
Public Property TwipsPerPixelX | Gets the number of twips per pixel for a printer measured horizontally.
Public Property TwipsPerPixelY | Gets the number of twips per pixel for a printer measured vertically.
Public Property UseDefaultPrinter | Gets and sets an indicator whether PrintPRO uses the system default printer by default.
Public Property UseHardwareMargins | Gets and sets an indicator if hardware margins are used.
Public Property Version | Returns the version of the PrintPro control at run-time.
Public Property WordWrap | Gets and sets a value to determine whether text word wraps inside the PrintText method’s print rectangle.
Public Property Zoom | Gets or sets the percentage by which printed output is to be scaled up or down (if the printer supports this feature).

See Also

PrintPro Object


AboutBox Method

AboutBox Method
See Also Send Feedback
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : AboutBox Method

Glossary Item Box

Description

Displays a licensing, version and copyright information dialog box for PrintPRO.

Syntax

Visual Basic
Public Sub AboutBox()

See Also

PrintPro Object | PrintPro Members


BinID Method

BinID Method
BinNum
Defines the printer's bin for which you want the ID. The value of number can be from 1 to the NumBins property value.
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : BinID Method

Glossary Item Box

Description

Returns the printer manufacturer's bin ID number for the specified printer bin.

Syntax

Visual Basic
Public Function BinID( _
   ByVal BinNum As Long _
) As Long

Parameters

BinNum
Defines the printer's bin for which you want the ID. The value of number can be from 1 to the NumBins property value.

Return Type

A long value which represents the printer bin using the PaperBin property.

See Also

PrintPro Object | PrintPro Members | NumBins Property


BinName Method

BinName Method
BinNum
Defines the printer's bin for which you want a name. The value of number can be from 1 to the NumBins property value.
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : BinName Method

Glossary Item Box

Description

Returns the name of the specified paper bin.

Syntax

Visual Basic
Public Function BinName( _
   ByVal BinNum As Long _
) As String

Parameters

BinNum
Defines the printer's bin for which you want a name. The value of number can be from 1 to the NumBins property value.

Return Type

A string value which represents the specified paper bin.

See Also

PrintPro Object | PrintPro Members


DelPrintPreview Method

DelPrintPreview Method
pageNum
The page number for which print preview resources are to be deleted. Page numbers start with 1.
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : DelPrintPreview Method

Glossary Item Box

Description

Deletes the print preview resources for a specified page.

Syntax

Visual Basic
Public Sub DelPrintPreview( _
   ByVal pageNum As Long _
)

Parameters

pageNum
The page number for which print preview resources are to be deleted. Page numbers start with 1.

Remarks

System resources are required whenever you create a print preview page. These resources are automatically deleted when the PrintPRO control is unloaded or when you replace a current print preview page with a new one.

You can also use this method to delete the print preview page resources when you no longer need them.

Deleting a print preview page does not delete the bitmap image associated with the print preview page, if one exists. Use the DelPrintPreviewPicture method to delete the current print preview bitmap image.

If you call this method to delete print preview resources, you cannot recreate the print preview bitmap image.

See Also

PrintPro Object | PrintPro Members | DelPrintPreviewPicture Method


DelPrintPreviewPicture Method

DelPrintPreviewPicture Method
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : DelPrintPreviewPicture Method

Glossary Item Box

Description

Deletes the current print preview bitmap.

Syntax

Visual Basic
Public Sub DelPrintPreviewPicture()

Remarks

System resources are required whenever you create a print preview page. These resources are automatically deleted when the PrintPRO control is unloaded or when you replace a current print preview page with a new one.

You can also use the DelPrintPreviewPicture method to delete the print preview bitmap image when you no longer need it.

Deleting a print preview bitmap does not delete the print preview page resources. Use the DelPrintPreview method to delete the print preview page resources.

If you call the DelPrintPreviewPicture method to delete the print preview bitmap image, you can always recreate the bitmap using the GetPrintPreview method. So Deleting the bitmap image when it is no longer needed will conserve system resources.

See Also

PrintPro Object | PrintPro Members


DrawArc Method

DrawArc Method
X1
Single-precision floating-point value indicating the upper-left x coordinate for the bounding rectangle.
Y1
Single-precision floating-point value indicating the upper-left y coordinate for the bounding rectangle
X2
Single-precision floating-point values indicating the lower-right x coordinate for the bounding rectangle
Y2
Single-precision floating-point values indicating the lower-right y coordinate for the bounding rectangle
StartAngle
Single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
EndAngle
Single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.
penColor
Long integer value indicating the RGB color of the arc. You can use the RGB function or QBColor function to specify the color.
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : DrawArc Method

Glossary Item Box

Description

Creates an arc on a document to be printed.

Syntax

Visual Basic
Public Sub DrawArc( _
   ByVal X1 As Single, _
   ByVal Y1 As Single, _
   ByVal X2 As Single, _
   ByVal Y2 As Single, _
   ByVal StartAngle As Single, _
   ByVal EndAngle As Single, _
   ByVal penColor As OLE_COLOR _
)

Parameters

X1
Single-precision floating-point value indicating the upper-left x coordinate for the bounding rectangle.
Y1
Single-precision floating-point value indicating the upper-left y coordinate for the bounding rectangle
X2
Single-precision floating-point values indicating the lower-right x coordinate for the bounding rectangle
Y2
Single-precision floating-point values indicating the lower-right y coordinate for the bounding rectangle
StartAngle
Single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
EndAngle
Single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.
penColor
Long integer value indicating the RGB color of the arc. You can use the RGB function or QBColor function to specify the color.

Remarks

Draws an elliptical arc.

The center of the arc is the center of the bounding rectangle specified by x1, y1, x2 and y2.

The bounding rectangle must be within the physical area of the printed page.

The starting and end points of the arc are determined by the StartAngle and EndAngle values. The arc is drawn in a counterclockwise direction.

The width of the line used to draw the arc depends on the setting of the DrawWidth property.

The way the arc is drawn on the background depends on the setting of the DrawMode and DrawStyle properties.

If a printer has not been selected or a document has not been started, the DrawArc method will select the default printer and start a new document.

You can omit an argument in the middle of the syntax, but you must include the argument’s comma before including the next argument. If you omit an optional argument, omit the comma following the last argument you specify.

When DrawArc executes, the CurrentX and CurrentY properties are set to X2 and Y2.

See Also

PrintPro Object | PrintPro Members


DrawCircle Method

DrawCircle Method
X
Single-precision value indicating the x coordinate for the center point of the circle or ellipse.
Y
Single-precision value indicating the y coordinate for the center point of the circle or ellipse.
Radius
Single-precision value indicating the radius of the circle or ellipse.
penColor
Long integer value indicating the RGB color of the circle’s outline. You can use the Visual Basic RGB function or QBColor function to specify the color.
Aspect
Single-precision value indicating the aspect ratio of the circle. The value 1.0 yields a perfect (non-elliptical) circle on any screen.
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : DrawCircle Method

Glossary Item Box

Description

Creates a circle or ellipse on a document to be printed.

Syntax

Visual Basic
Public Sub DrawCircle( _
   ByVal X As Single, _
   ByVal Y As Single, _
   ByVal Radius As Single, _
   ByVal penColor As OLE_COLOR, _
   ByVal Aspect As Single _
)

Parameters

X
Single-precision value indicating the x coordinate for the center point of the circle or ellipse.
Y
Single-precision value indicating the y coordinate for the center point of the circle or ellipse.
Radius
Single-precision value indicating the radius of the circle or ellipse.
penColor
Long integer value indicating the RGB color of the circle’s outline. You can use the Visual Basic RGB function or QBColor function to specify the color.
Aspect
Single-precision value indicating the aspect ratio of the circle. The value 1.0 yields a perfect (non-elliptical) circle on any screen.

Remarks

The coordinates of the center point must be within the physical area of the printed page.

To fill a circle, set the FillColor and FillStyle properties of the object on which the circle or ellipse is drawn.

The width of the line used to draw the circle or ellipse depends on the setting of the DrawWidth property.

The way the circle is drawn on the background depends on the setting of the DrawMode and DrawStyle properties.

You can omit an argument in the middle of the syntax, but you must include the argument’s comma before including the next argument. If you omit an optional argument, omit the comma following the last argument you specify.

If a printer has not been selected or a document has not been started, the DrawCircle method will select the default printer and start a new document. When DrawCircle executes, the CurrentX and CurrentY properties are set to the center point of the circle or ellipse.

See Also

PrintPro Object | PrintPro Members


DrawCurve Method

DrawCurve Method
X1
Single-precision floating-point value indicating the x coordinate for the start of the Bezier curve.
Y1
Single-precision floating-point value indicating the y coordinate for the start of the Bezier curve.
X2
Single-precision floating-point value indicating the x coordinate for the midpoint of the Bezier curve.
Y2
Single-precision floating-point values indicating the y coordinate for the midpoint of the Bezier curve.
X3
Single-precision floating-point values indicating the x coordinate of the curve point that determines the curvature of the Bezier curve.
Y3
Single-precision floating-point values indicating the y coordinate for the curve point that determines the curvature of the Bezier curve.
X4
Single-precision floating-point value indicating the x coordinate for the end point of the Bezier curve.
Y4
Single-precision floating-point value indicating the y coordinate for the end point of the Bezier curve.
penColor
A long value representing the pen color.
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : DrawCurve Method

Glossary Item Box

Description

Creates a Bezier curve on a document to be printed.

Syntax

Visual Basic
Public Sub DrawCurve( _
   ByVal X1 As Single, _
   ByVal Y1 As Single, _
   ByVal X2 As Single, _
   ByVal Y2 As Single, _
   ByVal X3 As Single, _
   ByVal Y3 As Single, _
   ByVal X4 As Single, _
   ByVal Y4 As Single, _
   ByVal penColor As OLE_COLOR _
)

Parameters

X1
Single-precision floating-point value indicating the x coordinate for the start of the Bezier curve.
Y1
Single-precision floating-point value indicating the y coordinate for the start of the Bezier curve.
X2
Single-precision floating-point value indicating the x coordinate for the midpoint of the Bezier curve.
Y2
Single-precision floating-point values indicating the y coordinate for the midpoint of the Bezier curve.
X3
Single-precision floating-point values indicating the x coordinate of the curve point that determines the curvature of the Bezier curve.
Y3
Single-precision floating-point values indicating the y coordinate for the curve point that determines the curvature of the Bezier curve.
X4
Single-precision floating-point value indicating the x coordinate for the end point of the Bezier curve.
Y4
Single-precision floating-point value indicating the y coordinate for the end point of the Bezier curve.
penColor
A long value representing the pen color.

Remarks

The coordinates of the curve, with the exception of x3 and y3, must be within the physical area of the printed page.

The width of the line used to draw the curve depends on the setting of the DrawWidth property.

The way the curve is drawn on the background depends on the setting of the DrawMode and DrawStyle properties.

If a printer has not been selected or a document has not been started, the DrawCurve method will select the default printer and start a new document.

You can omit an argument in the middle of the syntax, but you must include the argument’s comma before including the next argument. If you omit an optional argument, omit the comma following the last argument you specify.

When DrawCurve executes, the CurrentX and CurrentY properties are set to the end point specified by the x4 and y4 arguments.

See Also

PrintPro Object | PrintPro Members


DrawLine Method

DrawLine Method
X1
Single-precision floating-point value indicating the x coordinate of the starting point for the line or rectangle.
Y1
Single-precision floating-point value indicating the y coordinate of the starting point for the line or rectangle.
X2
Single-precision values indicating the x coordinate of the end point for the line being drawn, or opposite corner of a rectangle being drawn.
Y2
Single-precision values indicating the y coordinate of the end point for the line being drawn, or opposite corner of a rectangle being drawn.
penColor
Box
A Boolean value that if True, causes a box to be drawn using the coordinates to specify opposite corners of the box. If False, a line is drawn.
Fill
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : DrawLine Method

Glossary Item Box

Description

Creates lines and rectangles on a document to be printed.

Syntax

Visual Basic
Public Sub DrawLine( _
   ByVal X1 As Single, _
   ByVal Y1 As Single, _
   ByVal X2 As Single, _
   ByVal Y2 As Single, _
   ByVal penColor As OLE_COLOR, _
   ByVal Box As Boolean, _
   ByVal Fill As Boolean _
)

Parameters

X1
Single-precision floating-point value indicating the x coordinate of the starting point for the line or rectangle.
Y1
Single-precision floating-point value indicating the y coordinate of the starting point for the line or rectangle.
X2
Single-precision values indicating the x coordinate of the end point for the line being drawn, or opposite corner of a rectangle being drawn.
Y2
Single-precision values indicating the y coordinate of the end point for the line being drawn, or opposite corner of a rectangle being drawn.
penColor
Box
A Boolean value that if True, causes a box to be drawn using the coordinates to specify opposite corners of the box. If False, a line is drawn.
Fill

Remarks

The coordinates of the line must be within the physical area of the printed page.

To draw connected lines, begin a subsequent line at the end point of the previous line.

The width of the line drawn depends on the setting of the DrawWidth property.

The way a line or box is drawn on the background depends on the setting of the DrawMode and DrawStyle properties.

If a printer has not been selected or a document has not been started, the DrawLine method selects the default printer and starts a new document. You can omit an argument in the middle of the syntax, but you must include the argument’s comma before including the next argument.

When DrawLine executes, the CurrentX and CurrentY properties are set to x2 and y2.

See Also

PrintPro Object | PrintPro Members


DrawPie Method

DrawPie Method
X1
Single-precision values indicating the upper-left x coordinate for the bounding rectangle.
Y1
Single-precision values indicating the upper-left y coordinate for the bounding rectangle.
X2
Single-precision value indicating the lower-right x coordinate for the bounding rectangle.
Y2
Single-precision value indicating the lower-right y coordinate for the bounding rectangle.
StartAngle
Single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
EndAngle
Single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.
penColor
Long integer value indicating the RGB color of the circle’s outline. You can use the RGB function or QBColor function to specify the color.
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : DrawPie Method

Glossary Item Box

Description

Creates a pie-shaped wedge on a document to be printed.

Syntax

Visual Basic
Public Sub DrawPie( _
   ByVal X1 As Single, _
   ByVal Y1 As Single, _
   ByVal X2 As Single, _
   ByVal Y2 As Single, _
   ByVal StartAngle As Single, _
   ByVal EndAngle As Single, _
   ByVal penColor As OLE_COLOR _
)

Parameters

X1
Single-precision values indicating the upper-left x coordinate for the bounding rectangle.
Y1
Single-precision values indicating the upper-left y coordinate for the bounding rectangle.
X2
Single-precision value indicating the lower-right x coordinate for the bounding rectangle.
Y2
Single-precision value indicating the lower-right y coordinate for the bounding rectangle.
StartAngle
Single-precision floating-point value (in degrees, 0-360) that specifies the starting angle of the arc.
EndAngle
Single-precision floating-point value (in degrees, 0-360) that specifies the end angle of the arc.
penColor
Long integer value indicating the RGB color of the circle’s outline. You can use the RGB function or QBColor function to specify the color.

Remarks

Draws a pie-shaped wedge by drawing an elliptical arc whose center and two endpoints are joined by lines. The center of the arc is the center of the bounding rectangle specified by x1, y1, x2 and y2. The starting and end points of the arc are determined by the StartAngle and EndAngle values.

The coordinates of the pie must be within the physical area of the printed page. The arc is drawn in a counterclockwise direction.

To fill a pie, set the FillColor and FillStyle properties of the object on which the pie is drawn.

The width of the line used to draw the pie depends on the setting of the DrawWidth property.

The way the pie is drawn on the background depends on the setting of the DrawMode and DrawStyle properties.

If a printer has not been selected or a document has not been started, the DrawPie method will select the default printer and start a new document.

You can omit an argument in the middle of the syntax, but you must include the argument’s comma before including the next argument. If you omit an optional argument, omit the comma following the last argument you specify.

When DrawPie executes, the CurrentX and CurrentY properties are set to X2 and Y2.

See Also

PrintPro Object | PrintPro Members


DrawPolygon Method

DrawPolygon Method
X1
Single-precision value indicating the x coordinate for the first vertex of a polygon.
Y1
Single-precision value indicating the y coordinate for the first vertex of a polygon.
X2
Single-precision value indicating the x coordinate for the second vertex of a polygon.
Y2
Single-precision value indicating the y coordinate for the second vertex of a polygon.
X3
Single-precision value indicating the x coordinate for the third vertex of a polygon.
Y3
Single-precision value indicating the y coordinate for the third vertex of a polygon.
X4
Single-precision value indicating the x coordinate for the fourth vertex of a polygon.
Y4
Single-precision value indicating the y coordinate for the fourth vertex of a polygon.
X5
Single-precision value indicating the X coordinate for the fifth vertex of a polygon.
Y5
Single-precision value indicating the y coordinate for the fifth vertex of a polygon.
X6
Single-precision value indicating the x coordinate for the sixth vertex of a polygon.
Y6
Single-precision value indicating the y coordinate for the sixth vertex of a polygon.
penColor
Long integer value indicating the RGB color of the polygon’s outline. You can use the RGB function or QBColor function to specify the color.
numPoints
The number of valid coordinates defining the polygon.
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : DrawPolygon Method

Glossary Item Box

Description

Creates a three to six sided polygon on a document to be printed.

Syntax

Visual Basic
Public Sub DrawPolygon( _
   ByVal X1 As Single, _
   ByVal Y1 As Single, _
   ByVal X2 As Single, _
   ByVal Y2 As Single, _
   ByVal X3 As Single, _
   ByVal Y3 As Single, _
   ByVal X4 As Single, _
   ByVal Y4 As Single, _
   ByVal X5 As Single, _
   ByVal Y5 As Single, _
   ByVal X6 As Single, _
   ByVal Y6 As Single, _
   ByVal penColor As OLE_COLOR, _
   ByVal numPoints As Long _
)

Parameters

X1
Single-precision value indicating the x coordinate for the first vertex of a polygon.
Y1
Single-precision value indicating the y coordinate for the first vertex of a polygon.
X2
Single-precision value indicating the x coordinate for the second vertex of a polygon.
Y2
Single-precision value indicating the y coordinate for the second vertex of a polygon.
X3
Single-precision value indicating the x coordinate for the third vertex of a polygon.
Y3
Single-precision value indicating the y coordinate for the third vertex of a polygon.
X4
Single-precision value indicating the x coordinate for the fourth vertex of a polygon.
Y4
Single-precision value indicating the y coordinate for the fourth vertex of a polygon.
X5
Single-precision value indicating the X coordinate for the fifth vertex of a polygon.
Y5
Single-precision value indicating the y coordinate for the fifth vertex of a polygon.
X6
Single-precision value indicating the x coordinate for the sixth vertex of a polygon.
Y6
Single-precision value indicating the y coordinate for the sixth vertex of a polygon.
penColor
Long integer value indicating the RGB color of the polygon’s outline. You can use the RGB function or QBColor function to specify the color.
numPoints
The number of valid coordinates defining the polygon.

Remarks

Specify as many coordinates as needed to define the polygon (3 for a triangle, 4 for a square, etc.) and pass this number as numPoints. All six coordinates must be passed to this method but the pairs beyond numPoints are ignored.

The coordinates of the polygon must be within the physical area of the printed page.

To fill a polygon, set the FillColor and FillStyle properties of the object on which the polygon is drawn.

The width of the line used to draw the polygon depends on the setting of the DrawWidth property.

The way the polygon is drawn on the background depends on the setting of DrawMode and DrawStyle properties.

If a printer has not been selected or a document has not been started, the DrawPolygon method will select the default printer and start a new document.

You can omit an argument in the middle of the syntax, but you must include the argument’s comma before including the next argument. If you omit an optional argument, omit the comma following the last argument you specify.

When DrawPolygon executes, the CurrentX and CurrentY properties are set to the last valid vertices of the polygon.

See Also

PrintPro Object | PrintPro Members


DrawRoundRect Method

DrawRoundRect Method
X1
Single-precision value indicating the upper-left x coordinate for the bounding rectangle.
Y1
Single-precision value indicating the upper-left y coordinate for the bounding rectangle.
X2
Single-precision value indicating the lower-right x coordinate for the bounding rectangle.
Y2
Single-precision value indicating the lower-right y coordinate for the bounding rectangle.
RoundW
A single-precision value that specifies the width of the ellipse used to draw the rounded corners.
RoundH
A single-precision value that specifies the height of the ellipse used to draw the rounded corners.
penColor
Long integer value indicating the RGB color of the circle’s outline. You can use the Visual Basic RGB function or QBColor function to specify the color.
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : DrawRoundRect Method

Glossary Item Box

Description

Creates a rectangle with rounded corners on the document to be printed.

Syntax

Visual Basic
Public Sub DrawRoundRect( _
   ByVal X1 As Single, _
   ByVal Y1 As Single, _
   ByVal X2 As Single, _
   ByVal Y2 As Single, _
   ByVal RoundW As Single, _
   ByVal RoundH As Single, _
   ByVal penColor As OLE_COLOR _
)

Parameters

X1
Single-precision value indicating the upper-left x coordinate for the bounding rectangle.
Y1
Single-precision value indicating the upper-left y coordinate for the bounding rectangle.
X2
Single-precision value indicating the lower-right x coordinate for the bounding rectangle.
Y2
Single-precision value indicating the lower-right y coordinate for the bounding rectangle.
RoundW
A single-precision value that specifies the width of the ellipse used to draw the rounded corners.
RoundH
A single-precision value that specifies the height of the ellipse used to draw the rounded corners.
penColor
Long integer value indicating the RGB color of the circle’s outline. You can use the Visual Basic RGB function or QBColor function to specify the color.

Remarks

The coordinates of the round rectangle must be within the physical area of the printed page.

To fill a rounded rectangle, set the FillColor and FillStyle properties of the object on which the rectangle is drawn.

The width of the line used to draw the rectangle depends on the setting of the DrawWidth property.

The way the rectangle is drawn on the background depends on the setting of the DrawMode and DrawStyle properties.

If a printer has not been selected or a document has not been started, the DrawRoundRect method will select the default printer and start a new document.

You can omit an argument in the middle of the syntax, but you must include the argument’s comma before including the next argument. If you omit an optional argument, omit the comma following the last argument you specify.

When DrawRoundRect executes, the CurrentX and CurrentY properties are set to X2 and Y2.

See Also

PrintPro Object | PrintPro Members


EndPrintDoc Method

EndPrintDoc Method
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : EndPrintDoc Method

Glossary Item Box

Description

Releases the current document to the print device or spooler.

Syntax

Visual Basic
Public Sub EndPrintDoc()

Remarks

When EndPrintDoc executes, it sets the Page property to 0, the CurrentX property to the LMargin property value, and the CurrentY property to the TMargin property value.

See Also

PrintPro Object | PrintPro Members


EndPrintPreview Method

EndPrintPreview Method
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : EndPrintPreview Method

Glossary Item Box

Description

Creates print preview resources for the current print preview page.

Syntax

Visual Basic
Public Sub EndPrintPreview()

Remarks

Any previous resources for the current page are destroyed.

To create a print preview:

  1. Call StartPrintPreview method. If you plan on creating print preview images while printing a document, you need to start a print document using the StartPrintDoc method before calling StartPrintPreview. If you only want to create a print preview and you don't want to actually print a document, set the PrintPreviewOnly property to True before you call the StartPrintPreview method.
  2. After initiating a print preview, print to the printer in the same manner as you would if you were printing a document. When you are done printing to a page, use the EndPrintPreview method to end the print preview for that page. If you are creating a multiple page document, PrintPro automatically creates a print preview for each page.

See Also

PrintPro Object | PrintPro Members


FromHdib Method

FromHdib Method
method
newVal
The handle to the current/supplied DIB.
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : FromHdib Method

Glossary Item Box

Description

Sets the current image to the supplied DIB (Device Independent Bitmap).

Syntax

Visual Basic
Public Sub FromHdib( _
   ByVal method As PP_FROMHDIBMETHOD, _
   ByVal newVal As Long _
)

Parameters

method
Value | Description
PP_FROMHDIBMETHOD_CREATECOPY | Specifies that the DIB is to be duplicated, the user has the responsibility of calling GlobalFree() to clean up the resource.
PP_FROMHDIBMETHOD_TRANSFERINTERNALHDIB | Specifies that the internal DIB is to be used, ImagXpress handles cleaning up the resource.
newVal
The handle to the current/supplied DIB.

Remarks

This method is intended for 32-bit environments.

See Also

PrintPro Object | PrintPro Members


FromHdib64 Method

FromHdib64 Method
method
newVal
The handle to the current/supplied DIB.
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : FromHdib64 Method

Glossary Item Box

Description

Sets the current image to the supplied DIB (Device Independent Bitmap) in 64-bit environments.

Syntax

Visual Basic
Public Sub FromHdib64( _
   ByVal method As PP_FROMHDIBMETHOD, _
   ByVal newVal As __int64 _
)

Parameters

method
Value | Description
PP_FROMHDIBMETHOD_CREATECOPY | Specifies that the DIB is to be duplicated, the user has the responsibility of calling GlobalFree() to clean up the resource.
PP_FROMHDIBMETHOD_TRANSFERINTERNALHDIB | Specifies that the internal DIB is to be used, ImagXpress handles cleaning up the resource.
newVal
The handle to the current/supplied DIB.

Remarks

This method is intended for 64-bit environments.

See Also

PrintPro Object | PrintPro Members


GetMaxDPI Method

GetMaxDPI Method
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : GetMaxDPI Method

Glossary Item Box

Description

Fetches the maximum DPI resolution available.

Syntax

Visual Basic
Public Function GetMaxDPI() As Long

Remarks

The maximum Dots Per Inch (DPI) possible given the page and system memory constraints.

See Also

PrintPro Object | PrintPro Members


GetNumSupportedDpis Method

GetNumSupportedDpis Method
pVal
The number of resolutions supported by the printer.
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : GetNumSupportedDpis Method

Glossary Item Box

Description

Gets the number of resolutions supported by the printer.

Syntax

Visual Basic
Public Sub GetNumSupportedDpis( _
   ByRef pVal As Long _
)

Parameters

pVal
The number of resolutions supported by the printer.

See Also

PrintPro Object | PrintPro Members


GetPrintPreview Method

GetPrintPreview Method
pageNum
The document page number for which the print preview bitmap will be created. Page numbers start with 1 and cannot exceed the current Page property setting.
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : GetPrintPreview Method

Glossary Item Box

Description

Creates a bitmap image for a print preview page and sets the PrintPreviewPicture property.

Syntax

Visual Basic
Public Sub GetPrintPreview( _
   ByVal pageNum As Long _
)

Parameters

pageNum
The document page number for which the print preview bitmap will be created. Page numbers start with 1 and cannot exceed the current Page property setting.

Remarks

The size of the bitmap image is determined by the PrintPreviewScale property. After you create a print preview bitmap image, you can export it using the PrintPreviewPic property. You can delete the current bitmap image using the DelPrintPreviewPic method and you can delete the print preview resources for any page using the DelPrintPreview method.

See Also

PrintPro Object | PrintPro Members


GetSupportedDpis Method

GetSupportedDpis Method
lIndex
The index at which to retrieve the resolution in the collection. The size of the collection of resolutions is returned by GetNumSupportedDpis().
pXDpi
The horizontal resolution at the specified index in the collection of resolutions.
pYDpi
The vertical resolution at the specified index in the collection of resolutions.
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : GetSupportedDpis Method

Glossary Item Box

Description

Gets the resolutions supported by the printer in dots per inch.

Syntax

Visual Basic
Public Sub GetSupportedDpis( _
   ByVal lIndex As Long, _
   ByRef pXDpi As Long, _
   ByRef pYDpi As Long _
)

Parameters

lIndex
The index at which to retrieve the resolution in the collection. The size of the collection of resolutions is returned by GetNumSupportedDpis().
pXDpi
The horizontal resolution at the specified index in the collection of resolutions.
pYDpi
The vertical resolution at the specified index in the collection of resolutions.

See Also

PrintPro Object | PrintPro Members


KillPrintDoc Method

KillPrintDoc Method
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : KillPrintDoc Method

Glossary Item Box

Description

Call this method to allow the PrintPRO control to run on a specified web site.

Syntax

Visual Basic
Public Sub KillPrintDoc()

Remarks

After a document has been released to the print device or spooler, KillPrintDoc method may be called to terminate the print request.

If the operating system's Print Manager is handling the print job (the Print Manager is running and has background printing enabled), KillPrintDoc deletes the current print job and the printer receives nothing. If Print Manager isn't handling the print job (background printing isn't enabled), some or all of the data may be sent to the printer before KillPrintDoc can take effect. In this case, the printer driver resets the printer when possible and terminates the print job.

See Also

PrintPro Object | PrintPro Members


NewPage Method

NewPage Method
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : NewPage Method

Glossary Item Box

Description

Ends the current page and advances to the next page.

Syntax

Visual Basic
Public Sub NewPage()

Remarks

When NewPage executes, the Page property is incremented by 1, the CurrentX property is set to the LMargin property value, and the CurrentY property is set to 0.

See Also

PrintPro Object | PrintPro Members


PaperID Method

PaperID Method
PaperNum
The value of number can be from 1 to the NumPapers.
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : PaperID Method

Glossary Item Box

Description

Returns the printer manufacturer's paper ID number for any supported paper.

Syntax

Visual Basic
Public Function PaperID( _
   ByVal PaperNum As Long _
) As Long

Parameters

PaperNum
The value of number can be from 1 to the NumPapers.

Return Type

The value returned can be used to select the paper using the PaperSize property.

See Also

PrintPro Object | PrintPro Members


PaperName Method

PaperName Method
PaperNum
The value can be from 1 to the NumPapers property value.
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : PaperName Method

Glossary Item Box

Description

Returns the printer manufacturer's paper name for any supported paper.

Syntax

Visual Basic
Public Function PaperName( _
   ByVal PaperNum As Long _
) As String

Parameters

PaperNum
The value can be from 1 to the NumPapers property value.

Return Type

A string value which represents the printer manufacturer's paper name.

See Also

PrintPro Object | PrintPro Members


PrintData Method

PrintData Method
varData
A variant array of bytes.
Length
The number of bytes in the array. Length must be between 1 and 255.
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : PrintData Method

Glossary Item Box

Description

Places data stored in an array of bytes into the document to be printed.

Syntax

Visual Basic
Public Sub PrintData( _
   ByVal varData As Variant, _
   ByVal Length As Long _
)

Parameters

varData
A variant array of bytes.
Length
The number of bytes in the array. Length must be between 1 and 255.

Remarks

If a printer has not been selected or a document has not been started, the PrintData method will select the default printer and start a new document. The PrintData method lets you place binary data in the document to be printed. The data is placed at the CurrentX and CurrentY positions.

See Also

PrintPro Object | PrintPro Members


PrintDialog Method

PrintDialog Method
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : PrintDialog Method

Glossary Item Box

Description

Displays a printer dialog box.

Syntax

Visual Basic
Public Sub PrintDialog()

Remarks

The selected printer replaces the current printer only if a document has not been started on the current printer.

The printer dialog box can only be displayed when a printer has been selected, and no print job is in progress. When a print job is in progress, the printer dialog box will not be displayed, and an exception message appears. If the user clicks the Cancel button, the ErrorCode property is set to -5005.

See Also

PrintPro Object | PrintPro Members


PrintDIB Method

PrintDIB Method
X1
Single-precision value indicating the destination horizontal coordinate of the upper-left corner of the image. The ScaleMode property determines the unit of measure used.
Y1
Single-precision value indicating the destination vertical coordinate of the upper-left corner of the image. The ScaleMode property determines the unit of measure used.
Width1

Single-precision value indicating the destination width of the image.

The ScaleMode property of the object determines the unit of measure used.

If omitted, the width of the image will be used.

If Aspect is False and the destination width is larger or smaller than the source width (width2), the image is stretched or compressed to fit.

Height1

Single-precision value indicating the destination height of the image. The ScaleMode property determines the unit of measure used.

If omitted, the height of the image will be used.

If Aspect is False and the destination height is larger or smaller than the source height (height2), the image is stretched or compressed to fit.

X2

Single-precision value indicating the coordinate (x-axis) of a clipping region within the image. The ScaleMode property determines the unit of measure used.

If Aspect is True, 0 is assumed.

Y2

Single-precision value indicating the coordinate (y-axis) of a clipping region within the image. The ScaleMode property determines the unit of measure used.

If Aspect is True, 0 is assumed.

Width2

Single-precision value indicating the source width of a clipping region within the image. The ScaleMode property determines the unit of measure used.

If Aspect is True, the entire source width is used.

Height2

Single-precision value indicating the source height of a clipping region within the image. The ScaleMode property determines the unit of measure used.

If Aspect is True, the entire source height is used.

Aspect

Boolean value indicating whether the aspect ratio of the image should be maintained.

If Aspect is True, and the destination rectangle is larger or smaller than the source rectangle, the aspect ratio of the resized image is maintained.

If Aspect is True, the x2, y2, width2 and height2 parameters are ignored.

AccusoftPrintPro6 ActiveX DLL > PrintPro Object : PrintDIB Method

Glossary Item Box

Description

Draws a device independent bitmap (DIB) on a document to be printed.

Syntax

Visual Basic
Public Sub PrintDIB( _
   ByVal X1 As Single, _
   ByVal Y1 As Single, _
   ByVal Width1 As Single, _
   ByVal Height1 As Single, _
   ByVal X2 As Single, _
   ByVal Y2 As Single, _
   ByVal Width2 As Single, _
   ByVal Height2 As Single, _
   ByVal Aspect As Boolean _
)

Parameters

X1
Single-precision value indicating the destination horizontal coordinate of the upper-left corner of the image. The ScaleMode property determines the unit of measure used.
Y1
Single-precision value indicating the destination vertical coordinate of the upper-left corner of the image. The ScaleMode property determines the unit of measure used.
Width1

Single-precision value indicating the destination width of the image.

The ScaleMode property of the object determines the unit of measure used.

If omitted, the width of the image will be used.

If Aspect is False and the destination width is larger or smaller than the source width (width2), the image is stretched or compressed to fit.

Height1

Single-precision value indicating the destination height of the image. The ScaleMode property determines the unit of measure used.

If omitted, the height of the image will be used.

If Aspect is False and the destination height is larger or smaller than the source height (height2), the image is stretched or compressed to fit.

X2

Single-precision value indicating the coordinate (x-axis) of a clipping region within the image. The ScaleMode property determines the unit of measure used.

If Aspect is True, 0 is assumed.

Y2

Single-precision value indicating the coordinate (y-axis) of a clipping region within the image. The ScaleMode property determines the unit of measure used.

If Aspect is True, 0 is assumed.

Width2

Single-precision value indicating the source width of a clipping region within the image. The ScaleMode property determines the unit of measure used.

If Aspect is True, the entire source width is used.

Height2

Single-precision value indicating the source height of a clipping region within the image. The ScaleMode property determines the unit of measure used.

If Aspect is True, the entire source height is used.

Aspect

Boolean value indicating whether the aspect ratio of the image should be maintained.

If Aspect is True, and the destination rectangle is larger or smaller than the source rectangle, the aspect ratio of the resized image is maintained.

If Aspect is True, the x2, y2, width2 and height2 parameters are ignored.

Remarks

The DIB is defined by the hDIB property. The destination coordinates of the image must be within the physical area of the printer. If a printer has not been selected or a document has not been started, the PrintPicture method will select the default printer and start a new document. Use the EndPrintDoc method to print the document.

If the OwnDIB property is true, the PrintDIB method deletes the DIB after drawing the device independent bitmap (DIB) on a document to be printed.

See Also

PrintPro Object | PrintPro Members


PrintPicture Method

PrintPicture Method
X1
Single-precision value indicating the destination x coordinate of the upper-left corner of the image on the printer.
Y1
Single-precision value indicating the destination y coordinate of the upper-left corner of the image on the printer.
Width1

Single-precision value indicating the destination width of the image.

If omitted, the width of the image will be used. If Aspect is False and the destination width is larger or smaller than the source width (width2), the image is stretched or compressed to fit.

Height1

Single-precision value indicating the destination height of the image.

If omitted, the height of the image will be used. If Aspect is False and the destination height is larger or smaller than the source height (height2), the image is stretched or compressed to fit.

X2

Single-precision value indicating the coordinate (x-axis) of a clipping region within the image. If Aspect is True, 0 is assumed.

Y2
Single-precision value indicating the coordinate (y-axis) of a clipping region within the image. If Aspect is True, 0 is assumed.
Width2
Single-precision value indicating the width of a clipping region within the image. If Aspect is True, the entire source width is used.
Height2
Single-precision value indicating the height of a clipping region within the image. If Aspect is True, the entire source height is used.
Aspect

Boolean value indicating whether the aspect ratio of the image should be maintained.

  • If Aspect is True and the destination rectangle is larger or smaller than the source rectangle, the aspect ratio of the resized image is maintained.
  • If Aspect is True, the x2, y2, width2 and height2 parameters are ignored.
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : PrintPicture Method

Glossary Item Box

Description

Draws a bitmap image on a document to be printed.

Syntax

Visual Basic
Public Sub PrintPicture( _
   ByVal X1 As Single, _
   ByVal Y1 As Single, _
   ByVal Width1 As Single, _
   ByVal Height1 As Single, _
   ByVal X2 As Single, _
   ByVal Y2 As Single, _
   ByVal Width2 As Single, _
   ByVal Height2 As Single, _
   ByVal Aspect As Boolean _
)

Parameters

X1
Single-precision value indicating the destination x coordinate of the upper-left corner of the image on the printer.
Y1
Single-precision value indicating the destination y coordinate of the upper-left corner of the image on the printer.
Width1

Single-precision value indicating the destination width of the image.

If omitted, the width of the image will be used. If Aspect is False and the destination width is larger or smaller than the source width (width2), the image is stretched or compressed to fit.

Height1

Single-precision value indicating the destination height of the image.

If omitted, the height of the image will be used. If Aspect is False and the destination height is larger or smaller than the source height (height2), the image is stretched or compressed to fit.

X2

Single-precision value indicating the coordinate (x-axis) of a clipping region within the image. If Aspect is True, 0 is assumed.

Y2
Single-precision value indicating the coordinate (y-axis) of a clipping region within the image. If Aspect is True, 0 is assumed.
Width2
Single-precision value indicating the width of a clipping region within the image. If Aspect is True, the entire source width is used.
Height2
Single-precision value indicating the height of a clipping region within the image. If Aspect is True, the entire source height is used.
Aspect

Boolean value indicating whether the aspect ratio of the image should be maintained.

  • If Aspect is True and the destination rectangle is larger or smaller than the source rectangle, the aspect ratio of the resized image is maintained.
  • If Aspect is True, the x2, y2, width2 and height2 parameters are ignored.

Remarks

The bitmap is defined by the Picture property. The ScaleMode property determines the unit of measure used.

The destination coordinates of the image must be within the physical area of the printer. If a printer has not been selected or a document has not been started, the PrintPicture method will select the default printer and start a new document. Use the EndPrintDoc method to print the document.

If OwnDIB was set when SetPictureBMP was invoked, then the bitmap is owned by the PrintPro control, and the PrintDIB method deletes the DIB after drawing the bitmap on the document to be printed.

See Also

PrintPro Object | PrintPro Members


PrintRawData Method

PrintRawData Method
varData
A one dimension variant array containing raw printer data.
Length
The size of the array in bytes.
NewPage
When set True the raw output is directed to the next logical page depending on the printer characteristics.
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : PrintRawData Method

Glossary Item Box

Description

Outputs data directly to a printer.

Syntax

Visual Basic
Public Sub PrintRawData( _
   ByVal varData As Variant, _
   ByVal Length As Long, _
   ByVal NewPage As Boolean _
)

Parameters

varData
A one dimension variant array containing raw printer data.
Length
The size of the array in bytes.
NewPage
When set True the raw output is directed to the next logical page depending on the printer characteristics.

Remarks

The PrintRawData method lets you print data directly to the current printer. Since the printer driver is by-passed by this method the data must be printer specific. The raw data may contain printer commands, codes and binary data. Large amounts of data may be sent to the printer using this technique.

See Also

PrintPro Object | PrintPro Members


PrintRawDataEnd Method

PrintRawDataEnd Method
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : PrintRawDataEnd Method

Glossary Item Box

Description

Closes the direct-to-printer session.

Syntax

Visual Basic
Public Sub PrintRawDataEnd()

See Also

PrintPro Object | PrintPro Members


PrintRawDataStart Method

PrintRawDataStart Method
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : PrintRawDataStart Method

Glossary Item Box

Description

Opens a direct-to-printer print session.

Syntax

Visual Basic
Public Sub PrintRawDataStart()

Remarks

This procedure bypasses the print driver.

See Also

PrintPro Object | PrintPro Members


PrintTemplateDIB Method

PrintTemplateDIB Method
LineItem
Which line in the Template File to process. Zero indicates the "next line", or when at the end of the file, the first image parameter line.
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : PrintTemplateDIB Method

Glossary Item Box

Description

Incorporates the image currently represented by the control's hDIB member according to a line from the TemplateFile.

Syntax

Visual Basic
Public Sub PrintTemplateDIB( _
   ByVal LineItem As Long _
)

Parameters

LineItem
Which line in the Template File to process. Zero indicates the "next line", or when at the end of the file, the first image parameter line.

Remarks

See TemplateFile for examples of how to create collages using the TemplateFile Property and PrintTemplateDIB method.

See Also

PrintPro Object | PrintPro Members


PrintTemplatePicture Method

PrintTemplatePicture Method
LineItem
Which line in the Template File to process. Zero indicates the "next line", or when at the end of the file, the first image parameter line.
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : PrintTemplatePicture Method

Glossary Item Box

Description

Incorporates the image currently represented by the control's Picture member according to a line from the TemplateFile.

Syntax

Visual Basic
Public Sub PrintTemplatePicture( _
   ByVal LineItem As Long _
)

Parameters

LineItem
Which line in the Template File to process. Zero indicates the "next line", or when at the end of the file, the first image parameter line.

Remarks

See TemplateFile for examples of how to create collages using the TemplateFile Property and PrintTemplateDIB method.

See Also

PrintPro Object | PrintPro Members


PrintText Method

PrintText Method
prntStr
A string expression to print.
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : PrintText Method

Glossary Item Box

Description

Places text in the document to be printed.

Syntax

Visual Basic
Public Sub PrintText( _
   ByVal prntStr As String _
)

Parameters

prntStr
A string expression to print.

Remarks

The text is placed at the CurrentX and CurrentY position.

After PrintText executes, CurrentX and CurrentY are updated as follows:

  • If the AddCR property is True, CurrentY is set to the next line position, and CurrentX is set to the LMargin property value.
  • If the AddCR property is False, CurrentX is set to the next text position and CurrentY remains unchanged. The PrintText method prints embedded carriage returns.
  • If the text does not fit on a line, it does not word-wrap to the next line. If you want to word-wrap text, use the PrintTextAligned method.
  • If the text you want to print doesn't fit on the current page, a new page is automatically generated.
  • If a printer has not been selected or a document has not been started, the PrintText method will select the default printer and start a new document.

Note: If the output of a Graphics method (e.g. line, circle, etc.) doesn't fit on the page, a new page is not generated. The output is clipped to fit the page's printable area.

See Also

PrintPro Object | PrintPro Members


PrintTextAligned Method

PrintTextAligned Method
prntStr
A string expression to print.
X1
Single-precision values indicating the coordinates of the starting point for the bounding rectangle.
Y1
Single-precision values indicating the coordinates of the starting point for the bounding rectangle.
X2
Single-precision values indicating the coordinates of the end point for the bounding rectangle.
Y2
Single-precision values indicating the coordinates of the end point for the bounding rectangle.
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : PrintTextAligned Method

Glossary Item Box

Description

Places text on the document inside a specified rectangular area within the display area.

Syntax

Visual Basic
Public Sub PrintTextAligned( _
   ByVal prntStr As String, _
   ByVal X1 As Single, _
   ByVal Y1 As Single, _
   ByVal X2 As Single, _
   ByVal Y2 As Single _
)

Parameters

prntStr
A string expression to print.
X1
Single-precision values indicating the coordinates of the starting point for the bounding rectangle.
Y1
Single-precision values indicating the coordinates of the starting point for the bounding rectangle.
X2
Single-precision values indicating the coordinates of the end point for the bounding rectangle.
Y2
Single-precision values indicating the coordinates of the end point for the bounding rectangle.

Remarks

The text is placed using the current alignment style defined by the Alignment property. The text will automatically word-wrap if the WordWrap property is True. The PrintTextAligned method prints embedded carriage returns.

The CurrentX and CurrentY properties are not changed by the PrintTextAligned method. If a printer has not been selected or a document has not been started, the PrintTextAligned method will select the default printer and start a new document.

Note: When printing an ampersand (&), you must print two (&&) of them for one to print.

See Also

PrintPro Object | PrintPro Members


PrintTextRotated Method

PrintTextRotated Method
X
Single-precision value indicating the x coordinate of the rotating text pivot point.
Y
Single-precision value indicating the y coordinate of the rotating text pivot point.
prntStr
A string expression to print.
Angle
An integer value indicating the rotation angle. Valid values range from 0 to 360 degrees.
Mode

An integer value indicating the rotation pivot mode:

0 — The text is left-justified at the pivot point

1 — The text is right-justified at the pivot point

2 — The text is center-justified at the pivot point

AccusoftPrintPro6 ActiveX DLL > PrintPro Object : PrintTextRotated Method

Glossary Item Box

Description

Places text rotated on the document to be printed.

Syntax

Visual Basic
Public Sub PrintTextRotated( _
   ByVal X As Single, _
   ByVal Y As Single, _
   ByVal prntStr As String, _
   ByVal Angle As Long, _
   ByVal Mode As Long _
)

Parameters

X
Single-precision value indicating the x coordinate of the rotating text pivot point.
Y
Single-precision value indicating the y coordinate of the rotating text pivot point.
prntStr
A string expression to print.
Angle
An integer value indicating the rotation angle. Valid values range from 0 to 360 degrees.
Mode

An integer value indicating the rotation pivot mode:

0 — The text is left-justified at the pivot point

1 — The text is right-justified at the pivot point

2 — The text is center-justified at the pivot point

Remarks

The baseline of the text is positioned at the pivot point. If a printer has not been selected or a document has not been started, the PrintTextRotated method will select the default printer and start a new document.

See Also

PrintPro Object | PrintPro Members


SelectDefaultPrinter Method

SelectDefaultPrinter Method
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : SelectDefaultPrinter Method

Glossary Item Box

Description

Selects the system default printer.

Syntax

Visual Basic
Public Sub SelectDefaultPrinter()

Remarks

The default printer replaces the current printer only if a document has not been started on the current printer.

See Also

PrintPro Object | PrintPro Members


SelectPrinter Method

SelectPrinter Method
PrinterNum
A long value which represents the printer number. Valid values are 1 to NumPrinters.
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : SelectPrinter Method

Glossary Item Box

Description

Selects one of the printers installed on the system.

Syntax

Visual Basic
Public Sub SelectPrinter( _
   ByVal PrinterNum As Long _
)

Parameters

PrinterNum
A long value which represents the printer number. Valid values are 1 to NumPrinters.

Remarks

The PrintPRO control, by default, selects the system default printer. Use the SelectPrinter method to select any printer installed on the system.

See Also

PrintPro Object | PrintPro Members


SelectPrinterByName Method

SelectPrinterByName Method
PrinterName
A string value which represents the printer name.
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : SelectPrinterByName Method

Glossary Item Box

Description

Selects one of the printers installed on the system by the given printer name.

Syntax

Visual Basic
Public Sub SelectPrinterByName( _
   ByVal PrinterName As String _
)

Parameters

PrinterName
A string value which represents the printer name.

See Also

PrintPro Object | PrintPro Members


SetCtlFontName Method

SetCtlFontName Method
Name
A string value indicating the name of the font, for example "Arial" or "Times New Roman" as described in Remarks.
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : SetCtlFontName Method

Glossary Item Box

Description

Sets the font name.

Syntax

Visual Basic
Public Sub SetCtlFontName( _
   ByVal Name As String _
)

Parameters

Name
A string value indicating the name of the font, for example "Arial" or "Times New Roman" as described in Remarks.

Remarks

In containers that don’t give you direct access to PrintPRO’s Font object, like Visual C++, the SetCtlName method can be used to set the font name.

See Also

PrintPro Object | PrintPro Members


SetCtlFontSize Method

SetCtlFontSize Method
fSize
A long value indicating the size of the font, in points.
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : SetCtlFontSize Method

Glossary Item Box

Description

Sets the font size.

Syntax

Visual Basic
Public Sub SetCtlFontSize( _
   ByVal fSize As Single _
)

Parameters

fSize
A long value indicating the size of the font, in points.

Remarks

In containers that don’t give you direct access to PrintPRO’s Font object, like Visual C++, the SetCtlSize method can be used to set the font size.

See Also

PrintPro Object | PrintPro Members


SetCtlFontStyle Method

SetCtlFontStyle Method
Style

An integer value indicating the desired font style:

0 — Bold font

1 — Italic font

2 — Underline font

3 — Strikethrough font

Value
A boolean value indicating whether the style is set (True) or unset (False).
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : SetCtlFontStyle Method

Glossary Item Box

Description

Sets the font style.

Syntax

Visual Basic
Public Sub SetCtlFontStyle( _
   ByVal Style As Long, _
   ByVal Value As Boolean _
)

Parameters

Style

An integer value indicating the desired font style:

0 — Bold font

1 — Italic font

2 — Underline font

3 — Strikethrough font

Value
A boolean value indicating whether the style is set (True) or unset (False).

Remarks

In containers that don’t give you direct access to PrintPRO’s Font object, like Visual C++, the SetCtlFontStyle method can be used to set the font style.

See Also

PrintPro Object | PrintPro Members


SetDefaultPrinterW Method

SetDefaultPrinterW Method
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : SetDefaultPrinterW Method

Glossary Item Box

Description

Selects the system default printer.

Syntax

Visual Basic
Public Sub SetDefaultPrinterW()

Remarks

The default printer replaces the current printer only if a document has not been started on the current printer.

See Also

PrintPro Object | PrintPro Members


SetOEMLicenseKey Method

SetOEMLicenseKey Method
newVal
The OEM license key required for OEM licensing.
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : SetOEMLicenseKey Method

Glossary Item Box

Description

Sets the PrintPRO control runtime OEM license key.

Syntax

Visual Basic
Public Sub SetOEMLicenseKey( _
   ByVal newVal As String _
)

Parameters

newVal
The OEM license key required for OEM licensing.

Remarks

When OEM runtime licenses are purchased, the OEM license key is provided in the purchase confirmation email.

See Also

PrintPro Object | PrintPro Members


SetPictureBMP Method

SetPictureBMP Method
hBmp
Long value that specifies the handle to a Device Dependent Bitmap.
hPal
Long value that specifies the handle to a palette.
own
Boolean value specifies ownership.
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : SetPictureBMP Method

Glossary Item Box

Description

Sets the Picture property using a handle to a Device Dependent Bitmap and a handle to a palette.

Syntax

Visual Basic
Public Sub SetPictureBMP( _
   ByVal hBmp As Long, _
   ByVal hPal As Long, _
   ByVal own As Boolean _
)

Parameters

hBmp
Long value that specifies the handle to a Device Dependent Bitmap.
hPal
Long value that specifies the handle to a palette.
own
Boolean value specifies ownership.

Remarks

When own parameter is True, PrintPRO owns the bitmap and it is responsible for deleting it. If own is False, you need to delete the bitmap when it is no longer needed.

See Also

PrintPro Object | PrintPro Members


SetSolutionKey Method

SetSolutionKey Method
key1
Unlock key 1
key2
Unlock key 2
key3
Unlock key 3
key4
Unlock key 4
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : SetSolutionKey Method

Glossary Item Box

Description

Sets the PrintPRO control runtime license deployment key.

Syntax

Visual Basic
Public Sub SetSolutionKey( _
   ByVal key1 As Long, _
   ByVal key2 As Long, _
   ByVal key3 As Long, _
   ByVal key4 As Long _
)

Parameters

key1
Unlock key 1
key2
Unlock key 2
key3
Unlock key 3
key4
Unlock key 4

Remarks

This is the solution key required for all runtime licensing. The four integers are provided at the time of purchase of the runtime licenses along with the solution name, which is set with the SetSolutionName method.

See Also

PrintPro Object | PrintPro Members


SetSolutionName Method

SetSolutionName Method
newVal
The solution name.
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : SetSolutionName Method

Glossary Item Box

Description

Sets the PrintPRO control runtime license deployment solution name.

Syntax

Visual Basic
Public Sub SetSolutionName( _
   ByVal newVal As String _
)

Parameters

newVal
The solution name.

Remarks

This is the name of the runtime license solution. The solution name is provided in the purchase confirmation email when runtime licenses are purchased.

See Also

PrintPro Object | PrintPro Members


SetupDialog Method

SetupDialog Method
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : SetupDialog Method

Glossary Item Box

Description

Displays a printer setup dialog box that lets the user change printer properties.

Syntax

Visual Basic
Public Sub SetupDialog()

Remarks

If the user clicks the Cancel button, the ErrorCode property is set to -5018.

See Also

PrintPro Object | PrintPro Members | ErrorCode Property


StartPrintDoc Method

StartPrintDoc Method
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : StartPrintDoc Method

Glossary Item Box

Description

Creates a document to be composed and printed.

Syntax

Visual Basic
Public Sub StartPrintDoc()

Remarks

Prior to printing, create a document and place the desired text, graphics, and bitmaps on the document.

The text, graphics, and bitmap methods automatically start a document for you, if one is not already started.

Once a document is started, the PrintDialog, SelectDefaultPrinter, and SelectPrinter methods no longer update the current printer.

See Also

PrintPro Object | PrintPro Members


StartPrintPreview Method

StartPrintPreview Method
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : StartPrintPreview Method

Glossary Item Box

Description

Starts a print preview for the current page.

Syntax

Visual Basic
Public Sub StartPrintPreview()

Remarks

Any previous resources for the current page are destroyed. To create a print preview:

Call StartPrintPreview method. If you plan on creating print preview images while printing a document, you need to start a print document using the StartPrintDoc method before calling StartPrintPreview. If you only want to create a print preview and you don't want to actually print a document, set the PrintPreviewOnly property to True before you call the StartPrintPreview method.

After initiating a print preview, print to the printer in the same manner as if you were printing a document. When you are done printing to a page, use the EndPrintPreview method to end the print preview for that page. If you are creating a multiple page document, PrintPro automatically creates a print preview for each page.

See Also

PrintPro Object | PrintPro Members | EndPrintPreview Method


TextHeight Method

TextHeight Method
textStr

The string you want to know the height of.

AccusoftPrintPro6 ActiveX DLL > PrintPro Object : TextHeight Method

Glossary Item Box

Description

Calculates the height of a text string as it would be printed in the current font.

Syntax

Visual Basic
Public Function TextHeight( _
   ByVal textStr As String _
) As Single

Parameters

textStr

The string you want to know the height of.

Remarks

Not available at design time.

Calculates and returns the height expressed in terms of the ScaleMode property setting.

See Also

PrintPro Object | PrintPro Members | ScaleMode Property


TextWidth Method

TextWidth Method
textStr
The string you want to know the width of.
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : TextWidth Method

Glossary Item Box

Description

Calculates the width of a text string as it would be printed in the current font.

Syntax

Visual Basic
Public Function TextWidth( _
   ByVal textStr As String _
) As Single

Parameters

textStr
The string you want to know the width of.

Remarks

Not available at design time.

Calculates and returns the width expressed in terms of the ScaleMode property setting.

See Also

PrintPro Object | PrintPro Members | ScaleMode Property


ToHdib Method

ToHdib Method
method
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : ToHdib Method

Glossary Item Box

Description

Returns the handle to the current DIB (Device Independent Bitmap).

Syntax

Visual Basic
Public Function ToHdib( _
   ByVal method As PP_TOHDIBMETHOD _
) As Long

Parameters

method
Value | Description
PP_TOHDIBMETHOD_RETURNDUPLICATE | Specifies that the DIB is to be duplicated, the user has the responsibility of calling GlobalFree() to clean up the resource.
PP_TOHDIBMETHOD_TRANSFERINTERNALHDIB | Specifies that the internal DIB is to be used, ImagXpress handles cleaning up the resource.

Remarks

This method is intended for 32-bit environments.

See Also

PrintPro Object | PrintPro Members


ToHdib64 Method

ToHdib64 Method
method
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : ToHdib64 Method

Glossary Item Box

Description

Returns the handle to the current DIB (Device Independent Bitmap) in a 64-bit environment.

Syntax

Visual Basic
Public Function ToHdib64( _
   ByVal method As PP_TOHDIBMETHOD _
) As __int64

Parameters

method
Value | Description
PP_TOHDIBMETHOD_RETURNDUPLICATE | Specifies that the DIB is to be duplicated, the user has the responsibility of calling GlobalFree() to clean up the resource.
PP_TOHDIBMETHOD_TRANSFERINTERNALHDIB | Specifies that the internal DIB is to be used, ImagXpress handles cleaning up the resource.

Remarks

This method is intended for 64-bit environments.

See Also

PrintPro Object | PrintPro Members


AddCR Property

AddCR Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : AddCR Property

Glossary Item Box

Description

Gets and sets the automatic carriage return flag.

Property Type

Read-write property

Syntax

Visual Basic
Public Property AddCR As Boolean

Return Type

A boolean value which is True to set the automatic carriage return flag.

See Also

PrintPro Object | PrintPro Members


Alignment Property

Alignment Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : Alignment Property

Glossary Item Box

Description

Gets and sets the text alignment style used by the PrintTextAligned method.

Property Type

Read-write property

Syntax

Visual Basic
Public Property Alignment As PP_Alignment

Return Type

A PP_Alignment enumeration value which determines the alignment.

See Also

PrintPro Object | PrintPro Members | PP_Alignment Enumeration | PrintTextAligned Method


AlignTextHeight Property

AlignTextHeight Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : AlignTextHeight Property

Glossary Item Box

Description

Gets the line height based on the Alignment property centering in pixels.

Property Type

Read-write property

Syntax

Visual Basic
Public Property AlignTextHeight As Single

Return Type

A single value which represents the text height alignment.

Remarks

When text is aligned using the PrintTextAligned method, the text may wrap to more than one line. The AlignTextHeight property returns the height (in pixels) of this text spanning one or more lines.

See Also

PrintPro Object | PrintPro Members | Alignment Property


AutoMargin Property

AutoMargin Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : AutoMargin Property

Glossary Item Box

Description

Gets or sets a value to determine if the margin values and the current print position values should automatically be set to values inside the printer's display area.

Property Type

Read-write property

Syntax

Visual Basic
Public Property AutoMargin As Boolean

Return Type

A boolean value which is True to automatically set to values inside the printer's display area. Otherwise, False is used and margin values are not automatically set.

Remarks

Returns or sets a Boolean value that specifies whether the BMargin, LMargin, TMargin, CurrentX and CurrentY properties should automatically be set to values inside the display area.

If the AutoMargin property is set to True (Default), the BMargin, LMargin, TMargin, CurrentX and CurrentY properties are set whenever a paper size is selected as follows: The LMargin and CurrentX properties are set to the left edge of the display area. The TMargin, BMargin and CurrentY properties are set to the top edge of the display area.

Note: The coordinate system used by the PrintPRO control is based on the physical dimensions of the paper. This means that the 0,0 coordinate is the upper left corner of the printed page. The display area that is located inside the physical area. This is the area that is normally used for printing. The AutoMargin property automatically sets the margins and the CurrentX and CurrentY properties so that printed text, using the PrintText method, appears inside the display area. If you want to set the margins manually, you can use the DisplayX and DisplayY properties to get the margin values.

See Also

PrintPro Object | PrintPro Members


BackColor Property

BackColor Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : BackColor Property

Glossary Item Box

Description

The background color of printed text.

Property Type

Read-write property

Syntax

Visual Basic
Public Property BackColor As OLE_COLOR

Return Type

A Ulong value which represents the background color.

Remarks

The BackColor property determines the background color of printed text when the BackStyle property is set to Back_Opaque.

See Also

PrintPro Object | PrintPro Members


BackStyle Property

BackStyle Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : BackStyle Property

Glossary Item Box

Description

Sets the background style of printed text.

Property Type

Read-write property

Syntax

Visual Basic
Public Property BackStyle As PP_BackStyle

Return Type

A PP_BackStyle enumeration value which determines the background style of printed text.

See Also

PrintPro Object | PrintPro Members


BMargin Property

BMargin Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : BMargin Property

Glossary Item Box

Description

Gets or sets the bottom margin value.

Property Type

Read-write property

Syntax

Visual Basic
Public Property BMargin As Single

Return Type

A single value which represents the bottom margin value.

Remarks

Margin values are expressed in twips, or the current unit of measurement defined by the ScaleMode property.

See Also

PrintPro Object | PrintPro Members


Collate Property

Collate Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : Collate Property

Glossary Item Box

Description

Gets or sets an indicator whether collation should be used when printing multiple copies (if the printer supports this feature).

Property Type

Read-write property

Syntax

Visual Basic
Public Property Collate As Boolean

Return Type

A boolean value which is True if collation should be used when printing multiple copies. Otherwise, False is used and collation does not occur.

Remarks

Not available at design time.

Note: You cannot set the Collate property after a document has been started. The effect of setting the Collate property depends on the driver supplied by the printer manufacturer. Some property settings may have no effect. Settings outside the accepted range may produce an error. The ErrorCode property will be set to -5015 or -5016 if the printer does not support this property. For more information, see the manufacturer's documentation for the specific printer driver.

See Also

PrintPro Object | PrintPro Members | ErrorCode Property


ColorMode Property

ColorMode Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : ColorMode Property

Glossary Item Box

Description

Gets or sets a value that determines whether a color printer prints output in color or monochrome.

Property Type

Read-write property

Syntax

Visual Basic
Public Property ColorMode As PP_ColorMode

Remarks

Not available at design time.

The default value depends on the printer driver and the current printer settings. Monochrome printers ignore this property.

Note: You cannot set the ColorMode property after a document has been started. The effect of setting the ColorMode property depends on the driver supplied by the printer manufacturer. Some property settings may have no effect. Settings outside the accepted range may produce an error. The ErrorCode property will be set to -5015 or -5016 if the printer does not support this property. For more information, see the manufacturer's documentation for the specific printer driver.

See Also

PrintPro Object | PrintPro Members | ErrorCode Property


Copies Property

Copies Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : Copies Property

Glossary Item Box

Description

Gets or sets a value that determines the number of copies to be printed.

Property Type

Read-write property

Syntax

Visual Basic
Public Property Copies As Long

Return Type

A long value which represents the number of copies to be printed.

Remarks

Not available at design time.

You cannot set the Copies property after a document has been started. For the PrintDialog method, this property returns the number of copies entered by the user in the Copies box. Multiple copies may or may not be collated, depending on the printer driver. Multiple copies of the entire document or multiple copies of each page may be printed. For printers that don't support collating, set Copies = 1, and then use a loop in code to print multiple copies of the entire document.

Note: The effect of setting the Copies property depends on the driver supplied by the printer manufacturer. Some property settings may have no effect. Settings outside the accepted range may produce an error. The ErrorCode property will be set to -5015 or -5016 if the printer does not support this property. For more information, see the manufacturer's documentation for the specific printer driver.

See Also

PrintPro Object | PrintPro Members | PrintDialog Method | ErrorCode Property


CurrentX Property

CurrentX Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : CurrentX Property

Glossary Item Box

Description

Returns or sets the horizontal coordinate for the next printing or drawing method.

Property Type

Read-write property

Syntax

Visual Basic
Public Property CurrentX As Single

Return Type

A single value which represents the horizontal coordinate for the next printing or drawing method.

Remarks

Not available at design time. Coordinates are measured from the upper-left corner of an object. Initially, the CurrentX property setting is 0 at a printer’s left edge. Coordinates are expressed in twips, or the current unit of measurement defined by the ScaleMode property.

When you use the following text and graphics methods, the CurrentX and CurrentY settings are changed as indicated:

  • DrawArc — The end point of the arc.
  • DrawCircle — The center of the object.

  • DrawCurve — The end point of the curve.

  • DrawLine — The end point of the line.

  • EndPrintDoc — LMargin property, TMargin property.

  • NewPage — LMargin property, TMargin property.

  • PrintText — The next print position if the AddCR property is False or Margin and the next line if the AddCR property is True.

See Also

PrintPro Object | PrintPro Members


CurrentY Property

CurrentY Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : CurrentY Property

Glossary Item Box

Description

Gets or sets the vertical coordinate for the next printing or drawing method.

Property Type

Read-write property

Syntax

Visual Basic
Public Property CurrentY As Single

Return Type

A single value which represents the vertical coordinate for the next printing or drawing method.

Remarks

Not available at design time. Coordinates are measured from the upper-left corner of an object. Initially, the CurrentY property setting is 0 at its top edge. Coordinates are expressed in twips, or the current unit of measurement defined by the ScaleMode property.

When you use the following text and graphics methods, the CurrentX and CurrentY settings are changed as indicated:

  • DrawArc — The end point of the arc.
  • DrawCircle — The center of the object.
  • DrawCurve — The end point of the curve.
  • DrawLine — The end point of the line.
  • EndPrintDoc — LMargin property, TMargin property.
  • NewPage — LMargin property, TMargin property.

  • PrintText — The next print position if the AddCR property is False or Margin and the next line if the AddCR property is True.

See Also

PrintPro Object | PrintPro Members


Debug Property

Debug Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : Debug Property

Glossary Item Box

Description

A property that represents whether or not debug logging is turned on.

Property Type

Read-write property

Syntax

Visual Basic
Public Property Debug As Boolean

Return Type

A boolean value which is True to log information to the DebugLogFile. Otherwise, False should be used and no information is logged.

See Also

PrintPro Object | PrintPro Members | DebugLogFile Property


DebugErrorLevel Property

DebugErrorLevel Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : DebugErrorLevel Property

Glossary Item Box

Description

Minimum error level a debug message must be for it to be logged in the log file.

Property Type

Read-write property

Syntax

Visual Basic
Public Property DebugErrorLevel As PP_DebugErrorLevel

Return Type

A PP_DebugErrorLevel enumeration value which determines the level of logging to occur.

Remarks

Note: No error logging is written if the Debug property is set to False.

See Also

PrintPro Object | PrintPro Members | PP_DebugErrorLevel Enumeration | Debug Property


DebugLogFile Property

DebugLogFile Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : DebugLogFile Property

Glossary Item Box

Description

The file name and location of the debug log file.

Property Type

Read-write property

Syntax

Visual Basic
Public Property DebugLogFile As String

Return Type

A string value which represents the location and name of the debug log file.

See Also

PrintPro Object | PrintPro Members


DIBHeight Property

DIBHeight Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : DIBHeight Property

Glossary Item Box

Description

Gets the height of the bitmap defined by the hDIB property in printer units defined by the ScaleMode property.

Property Type

Read-write property

Syntax

Visual Basic
Public Property DIBHeight As Single

Return Type

A single value which represents the height of the bitmap defined by the hDIB.

Remarks

Not available at design time. Printer units are different than screen units. For example, an image that is 320x240 screen pixels on a 600dpi printer would be 2000x1500 printer pixels.

See Also

PrintPro Object | PrintPro Members


DIBWidth Property

DIBWidth Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : DIBWidth Property

Glossary Item Box

Description

Gets the width of the bitmap defined by the hDIB property in printer units defined by the ScaleMode property. Not available at design time.

Property Type

Read-write property

Syntax

Visual Basic
Public Property DIBWidth As Single

Return Type

A single value which represents the width of the bitmap defined by the hDIB.

Remarks

Not available at design time. Printer units are different than screen units. For example, an image that is 320x240 screen pixels on a 600dpi printer would be 2000x1500 printer pixels.

See Also

PrintPro Object | PrintPro Members


DisplayX Property

DisplayX Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : DisplayX Property

Glossary Item Box

Description

Gets the horizontal coordinate of the display area in printer units defined by the ScaleMode property.

Property Type

Read-write property

Syntax

Visual Basic
Public Property DisplayX As Single

Return Type

A single value which represents the horizontal coordinate of the display area in printer units.

Remarks

Not available at design time.

The coordinate system used by the PrintPRO control is based on the physical dimensions of the printer. This means that the 0,0 coordinate is the upper left corner of the printed page. The printer also has a display area that is located inside the physical area. This is the area that is normally used for printing. The DisplayX and DisplayY properties can be used to get the coordinates of the upper left corner of the display area.

See Also

PrintPro Object | PrintPro Members | ScaleMode Property


DisplayY Property

DisplayY Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : DisplayY Property

Glossary Item Box

Description

Gets the vertical coordinate of the display area in printer units defined by the ScaleMode property.

Property Type

Read-write property

Syntax

Visual Basic
Public Property DisplayY As Single

Return Type

A single value which represents the vertical coordinate of the display area in printer units.

Remarks

Not available at design time.

The coordinate system used by the PrintPRO control is based on the physical dimensions of the printer. This means that the 0,0 coordinate is the upper left corner of the printed page. The printer also has a display area located inside the physical area. This is the area normally used for printing. The DisplayX and DisplayY properties can be used to get the coordinates of the upper left corner of the display area.

See Also

PrintPro Object | PrintPro Members | ScaleMode Property | DisplayX Property


DitherType Property

DitherType Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : DitherType Property

Glossary Item Box

Description

Gets or sets a value that specifies how dithering is to be done (if the printer supports this feature).

Property Type

Read-write property

Syntax

Visual Basic
Public Property DitherType As PP_DitherType

Return Type

A PP_DitherType enumeration value which determines how dithering is to be done.

Remarks

Not available at design time.

Note: You cannot set the DitherType property after a document has been started. The effect of setting the DitherType property depends on the driver supplied by the printer manufacturer. Some property settings may have no effect. Settings outside the accepted range may produce an error. The ErrorCode property will be set to -5015 or -5016 if the printer does not support this property. For more information, see the manufacturer's documentation for the specific printer driver.

See Also

PrintPro Object | PrintPro Members | PP_DitherType Enumeration


DocName Property

DocName Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : DocName Property

Glossary Item Box

Description

Gets or sets the document name.

Property Type

Read-write property

Syntax

Visual Basic
Public Property DocName As String

Return Type

A string value which represents the document name.

Remarks

The document name appears in the print spooler document list when the document is printed.

See Also

PrintPro Object | PrintPro Members


DrawMode Property

DrawMode Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : DrawMode Property

Glossary Item Box

Description

Gets or sets a value that determines the appearance of output from graphics methods.

Property Type

Read-write property

Syntax

Visual Basic
Public Property DrawMode As PP_DrawMode

Return Type

A PP_DrawMode enumeration value which determines the appearance of output from graphics methods.

Remarks

Use this property to produce visual effects when drawing with the graphics methods. The printer compares each pixel in the draw pattern to the corresponding pixel in the existing background and then applies bit-wise operations. For example, setting 7 uses the operator to combine a draw pattern pixel with a background pixel.

The exact effect of a DrawMode setting depends on the way the color of a line, drawn at run time, combines with colors already on the printer. Settings 1, 6, 7, 11, 13, and 16 yield the most predictable results.

See Also

PrintPro Object | PrintPro Members | PP_DrawMode Enumeration


DrawStyle Property

DrawStyle Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : DrawStyle Property

Glossary Item Box

Description

Gets or sets a value that determines the line style for output from graphics methods.

Property Type

Read-write property

Syntax

Visual Basic
Public Property DrawStyle As PP_DrawStyle

Return Type

A PP_DrawStyle enumeration value which determines the line style.

Remarks

If the DrawWidth property is set to a value greater than 1, DrawStyle settings 1 through 5 produce a solid line (the DrawStyle property value is not changed). If DrawWidth is set to 1, DrawStyle produces the effect for each setting.

See Also

PrintPro Object | PrintPro Members | DrawWidth Property | PP_DrawStyle Enumeration


DrawWidth Property

DrawWidth Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : DrawWidth Property

Glossary Item Box

Description

Gets or sets the line width for output from graphics methods.

Property Type

Read-write property

Syntax

Visual Basic
Public Property DrawWidth As Long

Return Type

A long value which represents the line width for output.

Remarks

A numeric expression from 1 through 32,767. This value represents the width of the line in pixels (or dots).

Increase the value of this property to increase the width of the line. If the DrawWidth property setting is greater than 1, DrawStyle property settings 1 through 4 produce a solid line (the DrawStyle property value is not changed). Setting DrawWidth to 1 allows DrawStyle to produce the results shown in the DrawStyle enumeration.

See Also

PrintPro Object | PrintPro Members


Duplex Property

Duplex Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : Duplex Property

Glossary Item Box

Description

Gets or sets a value that determines whether a page is printed on both sides (if the printer supports this feature). Not available at design time.

Property Type

Read-write property

Syntax

Visual Basic
Public Property Duplex As PP_Duplex

Return Type

A PP_Duplex enumeration value which determines if a page is printed on both sides.

Remarks

You cannot set the Duplex property after a document has been started. With horizontal duplex printing, the top of both sides of the page are at the same end of the sheet. With vertical duplex printing, the bottom of one page is at the same end of the sheet as the top of the next page.

Note: The effect of setting the Duplex property depends on the driver supplied by the printer manufacturer. Some property settings may have no effect. Settings outside the accepted range may produce an error. The ErrorCode property will be set to -5015 or -5016 if the printer does not support this property. For more information, see the manufacturer's documentation for the specific printer driver.

See Also

PrintPro Object | PrintPro Members | PP_Duplex Enumeration | ErrorCode Property


DuplexCap Property

DuplexCap Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : DuplexCap Property

Glossary Item Box

Description

Gets an indicator if duplex printing is possible.

Property Type

Read-write property

Syntax

Visual Basic
Public Property DuplexCap As Boolean

Return Type

A boolean value which is True if the printer is capable of duplex printing. Otherwise, False is returned and duplex printing is not possible.

Remarks

Not available at design time.

See Also

PrintPro Object | PrintPro Members


ErrorCode Property

ErrorCode Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : ErrorCode Property

Glossary Item Box

Description

Gets and sets the error code.

Property Type

Read-write property

Syntax

Visual Basic
Public Property ErrorCode As Long

Return Type

A long value which represents the error code.

See Also

PrintPro Object | PrintPro Members


ErrorDescription Property

ErrorDescription Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : ErrorDescription Property

Glossary Item Box

Description

Gets the error description.

Property Type

Read-write property

Syntax

Visual Basic
Public Property ErrorDescription As String

Return Type

A string value which represents the error description.

Remarks

The default value is an empty string "".

See Also

PrintPro Object | PrintPro Members


EvaluationMode Property

EvaluationMode Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : EvaluationMode Property

Glossary Item Box

Description

Gets and sets the type of evaluation operation for the component.

Property Type

Read-write property

Syntax

Visual Basic
Public Property EvaluationMode As PP_EvaluationMode

Return Type

A PP_EvaluationMode enumeration value which determines the type of evaluation operation.

Remarks

In order to test the component in an application running as a service or other environments where the component does not have permissions to create a window, the application logic needs to set the EvaluationMode to Timeout. In this mode, the component does not attempt to create the Evaluation Mode dialog window, but will timeout after 5 minutes of operation and cease to operate.

When running your project with the PrintPRO component in PP_EvaluationMode_Timeout mode under the Visual Basic 6 IDE, the component will still display the evaluation dialog. However, setting the EvaluationMode property to PP_EvaluationMode_Timeout will allow your Visual Basic 6 compiled executable to properly timeout after 5 minutes of execution and not display the evaluation dialog.

Purchase and register a license to run in regular (not evaluation) mode.

See Also

PrintPro Object | PrintPro Members | PP_EvaluationMode Enumeration


FillColor Property

FillColor Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : FillColor Property

Glossary Item Box

Description

Gets or sets the color used to fill in circles, boxes, round rectangles, pie-shapes and polygons created with the DrawCircle, DrawLine, DrawRoundRect, DrawPie and DrawPolygon graphics methods.

Property Type

Read-write property

Syntax

Visual Basic
Public Property FillColor As OLE_COLOR

Return Type

A Ulong value which represents the color used to fill in shapes.

Remarks

Returns or sets the color used to fill in circles, boxes, round rectangles, pie-shapes and polygons created with the DrawCircle, DrawLine, DrawRoundRect, DrawPie and DrawPolygon graphics methods. Colors specified with the system color constants in the Visual Basic object library in the Object Browser can be used. The Microsoft Windows operating environment substitutes the user’s choices, as specified by the user’s Control Panel settings.

When the FillStyle property is set to its default, 1 (Transparent), the FillColor setting is ignored.

See Also

PrintPro Object | PrintPro Members


FillStyle Property

FillStyle Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : FillStyle Property

Glossary Item Box

Description

Gets or sets the pattern used to fill circles, boxes, round rectangles, pie-shapes and polygons created with the DrawCircle, DrawLine, DrawRoundRect, DrawPie and DrawPolygon graphics methods.

Property Type

Read-write property

Syntax

Visual Basic
Public Property FillStyle As PP_FillStyle

Return Type

A PP_FillStyle enumeration value which determines the pattern to use to fill shapes.

Remarks

Returns or sets the pattern used to fill circles, boxes, round rectangles, pie-shapes and polygons created with the DrawCircle, DrawLine, DrawRoundRect, DrawPie and DrawPolygon graphics methods.

When FillStyle is set to 1 (Transparent), the FillColor property is ignored.

See Also

PrintPro Object | PrintPro Members


Font Property

Font Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : Font Property

Glossary Item Box

Description

Gets a Font object.

Property Type

Read-write property

Syntax

Visual Basic
Public Property Font As Font

Return Type

A Font object which represents possible properties to use.

Remarks

Use the Font property of an object to identify a specific Font object whose properties you want to use.

For example, the following code changes the Bold property setting of a Font object identified by the Font property of a PrintPRO control:

PrintPRO1.Font.Bold = True

See Also

PrintPro Object | PrintPro Members


ForeColor Property

ForeColor Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : ForeColor Property

Glossary Item Box

Description

Gets or sets the color used to display text.

Property Type

Read-write property

Syntax

Visual Basic
Public Property ForeColor As OLE_COLOR

Return Type

A Ulong value which represents the color used to display text.

Remarks

The valid range for a normal RGB color is 0 to 16,777,215 (&HFFFFFF). The high byte of a number in this range equals 0; the lower three bytes, from least to most significant byte, determine the amount of red, green, and blue, respectively. The red, green, and blue components are each represented by a number between 0 and 255 (&HFF). If the high byte is not 0, system colors are used, as defined in the user's Control Panel.

See Also

PrintPro Object | PrintPro Members


hDC Property

hDC Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : hDC Property

Glossary Item Box

Description

Gets a handle to the device context of a printer.

Property Type

Read-write property

Syntax

Visual Basic
Public Property hDC As Long

Return Type

A long value which represents a handle to the device context of a printer.

Remarks

Not available at design time.

You can use the hDC property to refer to the handle for a printer device context. This provides a value you can pass to an ImagXpress control when you want to print from these controls.

Note: All printing that is done external to the PrintPRO control will not be viewable in print preview unless you also print to the print preview metafile handle using the hMetaDC property.

See Also

PrintPro Object | PrintPro Members | hMetaDC Property


hDIB Property

hDIB Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : hDIB Property

Glossary Item Box

Description

Gets or sets a handle to a device independent bitmap image (DIB).

Property Type

Read-write property

Syntax

Visual Basic
Public Property hDIB As Long

Return Type

A long value which represents a handle to a DIB.

Remarks

The DIB can be printed using the PrintDIB method.

A Windows handle to a Device Independent Bitmap (DIB). The PrintPRO control does not delete the memory occupied by the DIB. It is up to the user to manage the DIB memory. You can use the hDIB property to import a DIB from other controls including the ImagXpress control.

See Also

PrintPro Object | PrintPro Members


hDIB64 Property

hDIB64 Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : hDIB64 Property

Glossary Item Box

Description

Gets or sets a handle to a device independent bitmap image (DIB) for 64-bit environments.

Property Type

Read-write property

Syntax

Visual Basic
Public Property hDIB64 As __int64

Return Type

A long value which represents a handle to a DIB.

Remarks

This property is intended for use in 64-bit environments.

The DIB can be printed using the PrintDIB method.

A Windows handle to a Device Independent Bitmap (DIB). The PrintPRO control does not delete the memory occupied by the DIB. It is up to the user to manage the DIB memory. You can use the hDIB property to import a DIB from other controls including the ImagXpress control.

See Also

PrintPro Object | PrintPro Members


hMetaDC Property

hMetaDC Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : hMetaDC Property

Glossary Item Box

Description

Gets a handle to the current print preview metafile device context (DC).

Property Type

Read-write property

Syntax

Visual Basic
Public Property hMetaDC As Long

Return Type

A long value which represents a handle to the current print preview.

Remarks

Not available at design time.

You can use the hMetaDC property to add items to the current print preview. This gives you the flexibility to add custom items to the print preview that are not provided directly by PrintPRO.

Note: The print preview metafile handle is maintained by the PrintPRO control. You should not delete this handle.

See Also

PrintPro Object | PrintPro Members


ICMIntent Property

ICMIntent Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : ICMIntent Property

Glossary Item Box

Description

Gets or sets a value that specifies which of three possible color management methods, or intents, should be used by default (if the printer supports this feature).

Property Type

Read-write property

Syntax

Visual Basic
Public Property ICMIntent As PP_IcmIntent

Return Type

The PP_IcmIntent value set which determines the color management method to use.

Remarks

Note: You cannot set the ICMIntent property after a document has been started.

The effect of setting the ICMIntent property depends on the driver supplied by the printer manufacturer. Some property settings may have no effect. Settings outside the accepted range may produce an error. The ErrorCode property will be set to -5015 or -5016 if the printer does not support this property. For more information, see the manufacturer's documentation for the specific printer driver.

See Also

PrintPro Object | PrintPro Members | PP_IcmIntent Enumeration


ICMMethod Property

ICMMethod Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : ICMMethod Property

Glossary Item Box

Description

Gets or sets a value that specifies how Image Color Management (ICM) is handled.

Property Type

Read-write property

Syntax

Visual Basic
Public Property ICMMethod As PP_IcmMethod

Return Type

The PP_IcmMethod value set which determines how ICM is handled.

Remarks

Note: You cannot set the ICMMethod property after a document has been started.

The printer driver must provide a user interface for setting the ICM Method. Most printer drivers support only the System or Disabled value. Drivers for PostScript printers support all values.

The effect of setting this property depends on the driver supplied by the printer manufacturer. Some property settings may have no effect. Settings outside the accepted range may produce an error. The ErrorCode property will be set to -5015 or -5016 if the printer does not support this property. For more information, see the manufacturer's documentation for the specific printer driver.

Note: Color Management is designed to work with 24-bit color or 8-bit grayscale images. Color correction performed on images with less bit depth that this will result in poor quality images. PrintPRO has no native ability to promote images to higher bit depth; it is recommended that you use ImagXpress to do so.

See Also

PrintPro Object | PrintPro Members | PP_IcmMethod Enumeration | ErrorCode Property


ICMMonitorProfileName Property

ICMMonitorProfileName Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : ICMMonitorProfileName Property

Glossary Item Box

Description

This is the file name of the monitor's color management profile.

Property Type

Read-write property

Syntax

Visual Basic
Public Property ICMMonitorProfileName As String

Return Type

A string value which represents the file name of the monitor's color management profile.

Remarks

Proofing requires that PrintPreviewOnly is set true and the monitor ICMMonitorProfileName is set or the monitor has a profile associated with it already. For this value to be effective ICMMethod must be set to ICMM_Profile.

See Also

PrintPro Object | PrintPro Members


ICMPrinterProfileName Property

ICMPrinterProfileName Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : ICMPrinterProfileName Property

Glossary Item Box

Description

This is the file name of the printer's color management profile.

Property Type

Read-write property

Syntax

Visual Basic
Public Property ICMPrinterProfileName As String

Return Type

A string value which represents the file name of the printer's color management profile.

Remarks

This property is used to set the printer profile if the default printer profile is not desired or if the user wishes to print the image page against another printer profile. For this value to be effective ICMMethod must be set to Profile.

See Also

PrintPro Object | PrintPro Members | PP_IcmMethod Enumeration | ICMMethod Property


ICMProfileRenderIntent Property

ICMProfileRenderIntent Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : ICMProfileRenderIntent Property

Glossary Item Box

Description

Gets and sets the purpose of the color correction.

Property Type

Read-write property

Syntax

Visual Basic
Public Property ICMProfileRenderIntent As PP_RenderIntent

Return Type

A PP_RenderIntent enumeration value which determines the color correction.

Remarks

You must set the profile name (ICMPrinterProfileName or ICMMonitorProfileName) when ICMProfileRenderIntent is set to any value other than NONE. ICMMethod is reset to ICMM_Disabled when ICMProfileRenderIntent is set to any value other than NONE so that the device itself doesn't also correct the image.

Note: Color Management is designed to work with 24-bit color or 8-bit grayscale images. Color correction performed on images with less bit depth that this will result in poor quality images. PrintPRO has no native ability to promote images to higher bit depth; it is recommended that you use ImagXpress to do so.

See Also

PrintPro Object | PrintPro Members


ICMWantProof Property

ICMWantProof Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : ICMWantProof Property

Glossary Item Box

Description

Gets an indicator if ICM is used.

Property Type

Read-write property

Syntax

Visual Basic
Public Property ICMWantProof As Boolean

Return Type

A boolean value which is True if ICM is used. Otherwise, False is returned.

See Also

PrintPro Object | PrintPro Members


Licensed Property

Licensed Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : Licensed Property

Glossary Item Box

Description

Gets an indicator if the component is licensed.

Property Type

Read-write property

Syntax

Visual Basic
Public Property Licensed As Boolean

Return Type

A boolean value which is True if the component is licensed. Otherwise, False is returned.

See Also

PrintPro Object | PrintPro Members


Lmargin Property

Lmargin Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : Lmargin Property

Glossary Item Box

Description

Gets or sets the left margin value.

Property Type

Read-write property

Syntax

Visual Basic
Public Property Lmargin As Single

Return Type

A single value which represents the left margin value.

Remarks

When the LMargin property is set, the CurrentX property is also set to the same value. Margin values are expressed in twips, or the current unit of measurement defined by the ScaleMode property.

The following methods set the CurrentX property to the LMargin value:

  • EndPrintDoc

  • NewPage

  • PrintText, when the AddCR property is True.

See Also

PrintPro Object | PrintPro Members


MediaType Property

MediaType Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : MediaType Property

Glossary Item Box

Description

Gets or sets a value that specifies the type of media being printed on (if the printer supports this feature).

Property Type

Read-write property

Syntax

Visual Basic
Public Property MediaType As PP_MediaType

Return Type

The PP_MediaType value which determines the type of media being printed.

Remarks

Not available at design time.

Note: You cannot set the MediaType property after a document has been started.

The effect of setting the MediaType property depends on the driver supplied by the printer manufacturer. Some property settings may have no effect. Settings outside the accepted range may produce an error. The ErrorCode property will be set to -5015 or -5016 if the printer does not support this property. For more information, see the manufacturer's documentation for the specific printer driver.

See Also

PrintPro Object | PrintPro Members | PP_MediaType Enumeration


NumBins Property

NumBins Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : NumBins Property

Glossary Item Box

Description

Gets the number of bins supported by the printer.

Property Type

Read-write property

Syntax

Visual Basic
Public Property NumBins As Long

Return Type

A long value which represents the number of bins.

Remarks

Not available at design time.

See Also

PrintPro Object | PrintPro Members


NumCopies Property

NumCopies Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : NumCopies Property

Glossary Item Box

Description

Returns the number of copies that the printer can print.

Property Type

Read-write property

Syntax

Visual Basic
Public Property NumCopies As Long

Return Type

A long value which represents the number of copies the printer can print.

Remarks

Not available at design time.

See Also

PrintPro Object | PrintPro Members


NumPapers Property

NumPapers Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : NumPapers Property

Glossary Item Box

Description

Gets the number of papers supported by the printer.

Property Type

Read-write property

Syntax

Visual Basic
Public Property NumPapers As Long

Return Type

A long value which represents the number of papers supported by the printer.

Remarks

Not available at design time.

See Also

PrintPro Object | PrintPro Members


NumPrinters Property

NumPrinters Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : NumPrinters Property

Glossary Item Box

Description

Gets the number of printers installed on the system.

Property Type

Read-write property

Syntax

Visual Basic
Public Property NumPrinters As Long

Return Type

A long value which represents the number of printers installed on the system.

Remarks

If NumPrinters returns 0, the PrintPRO control could not find any printers.

Not available at design time.

See Also

PrintPro Object | PrintPro Members


Orientation Property

Orientation Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : Orientation Property

Glossary Item Box

Description

Gets or sets a value indicating whether documents are printed in portrait or landscape mode (if the printer supports this feature).

Property Type

Read-write property

Syntax

Visual Basic
Public Property Orientation As PP_Orientation

Return Type

The PP_Orientation value which determines if documents are printed in portrait or landscape mode.

Remarks

Returns or sets a value indicating whether documents are printed in portrait or landscape mode (if the printer supports this feature). Not available at design time.

Note: If you set the Orientation property after a document has been started, the new orientation will not take effect until you start a new page using the NewPage method.

The effect of setting the Orientation property depends on the driver supplied by the printer manufacturer. Some property settings may have no effect. Settings outside the accepted range may produce an error. The ErrorCode property will be set to -5015 or -5016 if the printer does not support this property. For more information, see the manufacturer's documentation for the specific printer driver.

See Also

PrintPro Object | PrintPro Members | PP_Orientation Enumeration | Orientation Property


OutputFileName Property

OutputFileName Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : OutputFileName Property

Glossary Item Box

Description

Gets or sets a string value that specifies the print output file.

Property Type

Read-write property

Syntax

Visual Basic
Public Property OutputFileName As String

Return Type

A string value which represents the print output file.

Remarks

If the OutputFileName property is set, the printed output will go to this file instead of the printer.

See Also

PrintPro Object | PrintPro Members


OwnDIB Property

OwnDIB Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : OwnDIB Property

Glossary Item Box

Description

Gets or sets the DIB ownership flag.

Property Type

Read-write property

Syntax

Visual Basic
Public Property OwnDIB As Boolean

Return Type

A boolean value which is True if the control deletes the DIB. Otherwise, False is used and the DIB is used by another control.

Remarks

  • If the OwnDIB property is True, the PrintPRO control will delete the DIB, set by the hDIB property, after printing the DIB using the PrintDIB method.
  • If the DIB is used by another control or it is maintained by another control, you should set the OwnDIB property to False (Default).

The OwnDIB property returns an integer value. If you use the ImagXpress control to set the hDIB property, the OwnDIB property should be set to False.

See Also

PrintPro Object | PrintPro Members


Page Property

Page Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : Page Property

Glossary Item Box

Description

Gets the current page number.

Property Type

Read-write property

Syntax

Visual Basic
Public Property Page As Long

Remarks

Not available at design time.

PrintPRO keeps a count of pages that have been printed since your document started or since the last time the EndPrintDoc method was used. This count starts at one and increases by one if you use the NewPage method or the PrintText method automatically starts a new page because the text won’t fit on the current page.

See Also

PrintPro Object | PrintPro Members


PaperBin Property

PaperBin Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : PaperBin Property

Glossary Item Box

Description

Gets or sets a value indicating the default paper bin on the printer from which paper is fed when printing (if the printer supports this feature).

Property Type

Read-write property

Syntax

Visual Basic
Public Property PaperBin As PP_SourceBin

Return Type

The PP_SourceBin value which determines the default paper bin.

Remarks

Not available at design time.

Note: If you set the PaperBin property after a document has been started, the new paper bin will not take effect until a new page has been started using the NewPage method.

The effect of setting the paperBin property depends on the driver supplied by the printer manufacturer. Some manufacturers have device-specific paper bin numbers that are greater than 256. You can use the NumBins, BinID and BinName properties to get a list of bin names and bin ID numbers for all bins supported by a printer. The ErrorCode property will be set to -5015 or -5016 if the printer does not support this property. For more information, see the manufacturer's documentation for the specific printer driver.

See Also

PrintPro Object | PrintPro Members | PP_SourceBin Enumeration | NewPage Method


PaperSize Property

PaperSize Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : PaperSize Property

Glossary Item Box

Description

Gets or sets a value indicating the paper size for the current printer (if the printer supports this feature).

Property Type

Read-write property

Syntax

Visual Basic
Public Property PaperSize As PP_PaperSize

Return Type

The PP_PaperSize value set.

Remarks

Not available at design time.

Note: You cannot set the PaperSize property after a document has been started.

The effect of setting the PaperSize property depends on the driver supplied by the printer manufacturer. Some property settings may have no effect. Settings outside the accepted range may produce an error. The ErrorCode property will be set to -5015 or -5016 if the printer does not support this property. For more information, see the manufacturer's documentation for the specific printer driver.

See Also

PrintPro Object | PrintPro Members | PP_PaperSize Enumeration


PdFromPage Property

PdFromPage Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : PdFromPage Property

Glossary Item Box

Description

Gets and sets the initial value for the starting page edit control in the print dialog box.

Property Type

Read-write property

Syntax

Visual Basic
Public Property PdFromPage As Long

Return Type

A long value which represents the starting page.

Remarks

The current PdFromPage value specifies the initial value for the starting page edit control in the Print Dialog box.

When the PrintDialog method returns, the PdFromPage value is updated to the value the user entered in the starting page edit control.

See Also

PrintPro Object | PrintPro Members


PdMaxPage Property

PdMaxPage Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : PdMaxPage Property

Glossary Item Box

Description

Gets or sets a value indicating the maximum page number allowed for the end page number when the user selects the Pages radio button on the Print Dialog box.

Property Type

Read-write property

Syntax

Visual Basic
Public Property PdMaxPage As Long

Return Type

A long value which represents the maximum page number allowed.

Remarks

Not available at design time.

See Also

PrintPro Object | PrintPro Members


PdMinPage Property

PdMinPage Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : PdMinPage Property

Glossary Item Box

Description

Gets or sets a value indicating the minimum page number allowed for the start page number when the user selects the Pages radio button on the Print Dialog box.

Property Type

Read-write property

Syntax

Visual Basic
Public Property PdMinPage As Long

Return Type

A long value which represents the minimum page number allowed for the start page number.

Remarks

Not available at design time.

The PrintDialog method is used to display the Print Dialog box.

See Also

PrintPro Object | PrintPro Members | PrintDialog Method


PdRange Property

PdRange Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : PdRange Property

Glossary Item Box

Description

Gets a value indicating the Print Range selected on the Print Dialog box.

Property Type

Read-write property

Syntax

Visual Basic
Public Property PdRange As PP_PrintRange

Return Type

A PP_PrintRange enumeration value which determines the print range selected.

Remarks

Not available at design time.

The PrintDialog method is used to display the Print Dialog box.

See Also

PrintPro Object | PrintPro Members


PdRangeEnable Property

PdRangeEnable Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : PdRangeEnable Property

Glossary Item Box

Description

Gets or sets a value indicating which Print Range radio buttons are enabled on the Print Dialog box.

Property Type

Read-write property

Syntax

Visual Basic
Public Property PdRangeEnable As PP_PrintRangeEnable

Return Type

A PP_PrintRangeEnable value which determines which print range radio buttons are enabled.

Remarks

The PrintDialog method is used to display the Print Dialog box.

Note: In order to get the Pages radio button to function properly, you need to make sure that the PdMaxPage property is set to a value that is greater than the pdMinPage property.

See Also

PrintPro Object | PrintPro Members


PdToPage Property

PdToPage Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : PdToPage Property

Glossary Item Box

Description

Gets or sets a value indicating the end page number when the user selects the Pages radio button on the Print Dialog box.

Property Type

Read-write property

Syntax

Visual Basic
Public Property PdToPage As Long

Return Type

A long value which represents the end page number.

Remarks

Not available at design time.

The current PdToPage value specifies the initial value for the end page edit control in the Print Dialog box. When the PrintDialog method returns, the PdToPage value is updated to the value the user entered in the end page edit control

See Also

PrintPro Object | PrintPro Members


PHeight Property

PHeight Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : PHeight Property

Glossary Item Box

Description

Gets the physical height of the paper set up for the printing device, in units determined by the ScaleMode property.

Property Type

Read-write property

Syntax

Visual Basic
Public Property PHeight As Single

Return Type

A single value which represents the height of the paper set up for the printing device.

Remarks

Not available at design time.

Use the PHeight property for operations or calculations based on the printer’s total area. Use the ScaleHeight, and ScaleWidth properties for operations or calculations based on the printer’s internal area.

See Also

PrintPro Object | PrintPro Members | ScaleMode Property | PWidth Property | ScaleWidth Property | ScaleHeight Property


Picture Property

Picture Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : Picture Property

Glossary Item Box

Description

Gets or sets a bitmap image to load into the control.

Property Type

Read-write property

Syntax

Visual Basic
Public Property Picture As Picture

Return Type

A Picture object to load into the control.

Remarks

The Picture property of PrintPRO can be set to the Picture property of a Form object, PictureBox control, Image control (Visual Basic), ImagXpress control or the Picture property of another PrintPRO control.

After an image is loaded, it can be printed using the PrintPicture method.

Example

You can use LoadPicture in Visual Basic to load a picture into the PrintPRO control:

object.Picture = LoadPicture(pathname)

See Also

PrintPro Object | PrintPro Members


PictureHeight Property

PictureHeight Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : PictureHeight Property

Glossary Item Box

Description

Gets the height of the bitmap defined by the Picture property in printer units defined by the ScaleMode property.

Property Type

Read-write property

Syntax

Visual Basic
Public Property PictureHeight As Single

Remarks

Not available at design time.

A bitmap image must be loaded into the control using the Picture property.

Printer units are different than screen units. For example, an image that is 320x240 screen pixels on a 600dpi printer would be 2000x1500 printer pixels.

Example

Not available at design time.

A bitmap image must be loaded into the control using the Picture property.

You can use the PictureHeight and PictureWidth properties to print the image using the PrintPicture method as follows:

object.ScaleMode = 1

object.PrintPicture 0, 0, object.PictureWidth, object.PictureHeight

See Also

PrintPro Object | PrintPro Members


PictureTransparent Property

PictureTransparent Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : PictureTransparent Property

Glossary Item Box

Description

Sets or returns the transparent picture flag.

Property Type

Read-write property

Syntax

Visual Basic
Public Property PictureTransparent As Boolean

Return Type

A boolean value which is True to make the background transparent. Otherwise, False should be used.

Remarks

When the PictureTransparent property is True, the background under the image will show through the image wherever the transparent color appears in the image. The transparent color is set by the PictureTransparentColor property.

Note: Some printers might not support transparent images.

See Also

PrintPro Object | PrintPro Members


PictureTransparentColor Property

PictureTransparentColor Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : PictureTransparentColor Property

Glossary Item Box

Description

Sets or returns the transparent color of the image in the control.

Property Type

Read-write property

Syntax

Visual Basic
Public Property PictureTransparentColor As OLE_COLOR

Return Type

A Ulong value which represents the transparent color of the image in the control.

Remarks

If the PictureTransparent property is True when an image is loaded into the control using the Picture or hDIB properties, the background under the image will show through the image wherever the transparent color set by the PictureTransparentColor property appears in the image when the image is printed.

Note: Some printers do not support transparent images.

See Also

PrintPro Object | PrintPro Members


PictureWidth Property

PictureWidth Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : PictureWidth Property

Glossary Item Box

Description

Gets the width of the bitmap defined by the Picture property in printer units defined by the ScaleMode property.

Property Type

Read-write property

Syntax

Visual Basic
Public Property PictureWidth As Single

Return Type

A single value which represents the width of the bitmap.

Remarks

Not available at design time.

A bitmap image must be loaded into the control using the Picture property.

Printer units are different than screen units. For example, an image that is 320x240 screen pixels on a 600dpi printer would be 2000x1500 printer pixels.

Example

Not available at design time.

A bitmap image must be loaded into the control using the Picture property

You can use the PictureHeight and PictureWidth properties to print the image using the PrintPicture method as follows:

object.ScaleMode = 1

object.PrintPicture 0, 0, object.PictureWidth, object.PictureHeight

See Also

PrintPro Object | PrintPro Members


PrintEnabled Property

PrintEnabled Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : PrintEnabled Property

Glossary Item Box

Description

Disables or enables all printing.

Property Type

Read-write property

Syntax

Visual Basic
Public Property PrintEnabled As Boolean

Return Type

A boolean value which is True to enable all printing. Otherwise, False should be used and printing is disabled.

See Also

PrintPro Object | PrintPro Members


PrinterDriverName Property

PrinterDriverName Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : PrinterDriverName Property

Glossary Item Box

Description

Returns the current printer driver name.

Property Type

Read-write property

Syntax

Visual Basic
Public Property PrinterDriverName As String

Return Type

A string value which represents the current printer driver name.

See Also

PrintPro Object | PrintPro Members


PrinterName Property

PrinterName Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : PrinterName Property

Glossary Item Box

Description

Returns the current printer name.

Property Type

Read-write property

Syntax

Visual Basic
Public Property PrinterName As String

Return Type

A string value which represents the current printer name.

See Also

PrintPro Object | PrintPro Members


PrinterNum Property

PrinterNum Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : PrinterNum Property

Glossary Item Box

Description

Gets the index of the current printer in the printer collection.

Property Type

Read-write property

Syntax

Visual Basic
Public Property PrinterNum As Long

Return Type

A long value which represents a zero-based index of the current printer in the printer collection.

Remarks

Not available at design time. PrintPRO maintains a list of available printers in an internal collection (array). The NumPrinters property can be used to determine the number of printers in the collection. The PrinterName method can be used to get the name of a printer based on its index in the collection. The SelectPrinter method can be used to select a printer based on its index in the collection. The property returns the index of the current printer.

See Also

PrintPro Object | PrintPro Members


PrinterPortName Property

PrinterPortName Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : PrinterPortName Property

Glossary Item Box

Description

Returns the name of the port through which a document is sent to a printer.

Property Type

Read-write property

Syntax

Visual Basic
Public Property PrinterPortName As String

Return Type

A string value which represents the name of the port.

See Also

PrintPro Object | PrintPro Members


PrintPreviewDDB Property

PrintPreviewDDB Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : PrintPreviewDDB Property

Glossary Item Box

Description

Gets a handle to the print preview Device Dependent Bitmap (DDB).

Property Type

Read-write property

Syntax

Visual Basic
Public Property PrintPreviewDDB As Long

Return Type

A long value which represents a handle to the print preview DDB.

Remarks

The DDB returned by the PrintPreviewDDB property is managed by the PrintPRO control. You can use the DDB to display the print preview but you cannot modify the bitmap, delete it or assign ownership to another object.

See Also

PrintPro Object | PrintPro Members


PrintPreviewDIB Property

PrintPreviewDIB Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : PrintPreviewDIB Property

Glossary Item Box

Description

Gets a handle to the print preview Device Independent Bitmap (DIB).

Property Type

Read-write property

Syntax

Visual Basic
Public Property PrintPreviewDIB As Long

Return Type

A long value which represents a handle to the print preview DDB.

Remarks

The DIB returned by the PrintPreviewDIB property is a copy of the bitmap used by the PrintPRO control. After using the DIB, you are responsible for deleting it. PrintPreviewDIB will return 0 if a bitmap does not exist.

See Also

PrintPro Object | PrintPro Members


PrintPreviewDIB64 Property

PrintPreviewDIB64 Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : PrintPreviewDIB64 Property

Glossary Item Box

Description

Gets a handle to the print preview Device Independent Bitmap (DIB) for 64-bit environments.

Property Type

Read-write property

Syntax

Visual Basic
Public Property PrintPreviewDIB64 As __int64

Return Type

A long value which represents a handle to the print preview DDB.

Remarks

This property is intended for use in 64-bit environments.

The DIB returned by the PrintPreviewDIB property is a copy of the bitmap used by the PrintPRO control. After using the DIB, you are responsible for deleting it. PrintPreviewDIB will return 0 if a bitmap does not exist.

See Also

PrintPro Object | PrintPro Members


PrintPreviewOnly Property

PrintPreviewOnly Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : PrintPreviewOnly Property

Glossary Item Box

Description

Determines whether PrintPRO only generates print preview images.

Property Type

Read-write property

Syntax

Visual Basic
Public Property PrintPreviewOnly As Boolean

Return Type

A boolean value which is True to create print preview images without actually printing to a printer. Otherwise, False should be used to create print preview images as PrintPro prints to a printer.

Remarks

Use the StartPrintPreview and EndPrintPreview properties to create print preview images. Then, use the GetPrintPreview method and the PrintPreviewPicture property to display the print preview images.

See Also

PrintPro Object | PrintPro Members


PrintPreviewPicture Property

PrintPreviewPicture Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : PrintPreviewPicture Property

Glossary Item Box

Description

Gets a picture object of the print preview page.

Property Type

Read-write property

Syntax

Visual Basic
Public Property PrintPreviewPicture As Picture

Return Type

A Picture object of the print preview page.

Remarks

The size of the image is determined by the PrintPreviewScale property. The PrintPreviewPicture property will not return a picture until you call the GetPrintPreview method.

Note: There is currently an exception thrown when attempting to assign the PrintPreviewPicture results in a C++Builder 6 environment. To work around this issue until it can be addressed, assign the PrintPreviewDIB to an ImagXpress control instance. However, note that this will create an ImagXpress dependency.

See Also

PrintPro Object | PrintPro Members


PrintPreviewScale Property

PrintPreviewScale Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : PrintPreviewScale Property

Glossary Item Box

Description

Sets the size of the print preview image.

Property Type

Read-write property

Syntax

Visual Basic
Public Property PrintPreviewScale As PP_PreviewScale

Return Type

The PP_PreviewScale value set.

Remarks

Note: One to one (1:1) preview images require substantial memory depending on the paper size and color depth of your monitor. If you create many print preview images, you might run out of memory if you use the 1:1 setting.

See Also

PrintPro Object | PrintPro Members | PP_ScaleMode Enumeration


PrintQuality Property

PrintQuality Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : PrintQuality Property

Glossary Item Box

Description

Gets or sets a value indicating the printer resolution (if the printer supports this feature).

Property Type

Read-write property

Syntax

Visual Basic
Public Property PrintQuality As PP_PrintQuality

Return Type

The PP_PrintQuality value set.

Remarks

Not available at design time.

Note: You cannot set the PrintQuality property after a document has been started.

The effect of setting the PrintQuality property depends on the driver supplied by the printer manufacturer. Some property settings may have no effect. Settings outside the accepted range may produce an error. The ErrorCode property will be set to -5015 or -5016 if the printer does not support this property. For more information, see the manufacturer's documentation for the specific printer driver.

See Also

PrintPro Object | PrintPro Members | ErrorCode Property | PP_PrintQuality Enumeration


PrintRightToLeft Property

PrintRightToLeft Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : PrintRightToLeft Property

Glossary Item Box

Description

Gets and sets an indicator which determines if text output is printed from right-to-left.

Property Type

Read-write property

Syntax

Visual Basic
Public Property PrintRightToLeft As Boolean

Return Type

A boolean value which is True to print from right to left. Otherwise, False should be used.

Remarks

The default value is False.

See Also

PrintPro Object | PrintPro Members


PrintToFile Property

PrintToFile Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : PrintToFile Property

Glossary Item Box

Description

Gets and sets an indicator if the print output from printer devices to disk file is redirected.

Property Type

Read-write property

Syntax

Visual Basic
Public Property PrintToFile As Boolean

Return Type

A boolean value which is True to redirect the print output from printer devices to disk file. Otherwise, False should be used.

Remarks

The degree or quality of color will depend on the Display color card in the machine and particular monitor driving settings. If the display is setup in 256 color mode, than an 8 bit color file is generated. If a 24 bit or higher mode is selected, the color file generated will be 24 bit (true color).

The quality or size of the file generated will depend on the dots per inch (dpi) requested.

The highest dpi is actually machine and Windows OS dependent due to memory limitations. Factors which will affect and limit the dpi resolution will be the paper size, Color (B/W or Color) and Windows operating system (see GetMaxDPI (void) to get maximum possible dpi).

Older Windows 98 machines cannot match the newer Windows operating system for dpi quality.

Use RequestedDPI to set or get the current dpi resolution. The default value is 200 dpi.

Be aware that a high DPI, especially for uncompressed color, can generate a file up to 30 megabytes (per page). Since the control will add pages to an existing file, a multi-page file using uncompressed color data will be enormous.

Compressed Black and White TIFF files can attain higher DPI resolution with less memory. The quality and size of the file generated will depend upon the DPI requested.

See Also

PrintPro Object | PrintPro Members


PWidth Property

PWidth Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : PWidth Property

Glossary Item Box

Description

Gets the physical width of the paper set up for the printing device, in units determined by the ScaleMode property.

Property Type

Read-write property

Syntax

Visual Basic
Public Property PWidth As Single

Return Type

A single value which represents the width of the paper set up for the printing device.

Remarks

Not available at design time.

Use the PWidth property for operations or calculations based on the printer’s total area. Use the ScaleHeight, and ScaleWidth properties for operations or calculations based on the printer’s internal area.

See Also

PrintPro Object | PrintPro Members | PHeight Property | ScaleMode Property | ScaleWidth Property | ScaleHeight Property


RaiseExceptions Property

RaiseExceptions Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : RaiseExceptions Property

Glossary Item Box

Description

Gets and sets an indicator whether to raise exceptions.

Property Type

Read-write property

Syntax

Visual Basic
Public Property RaiseExceptions As Boolean

Return Type

A boolean value which is True to raise exceptions. Otherwise, False should be used and no exceptions are raised.

See Also

PrintPro Object | PrintPro Members


RequestedDPI Property

RequestedDPI Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : RequestedDPI Property

Glossary Item Box

Description

Gets or sets the current DPI resolution.

Property Type

Read-write property

Syntax

Visual Basic
Public Property RequestedDPI As Long

Return Type

A long value which represents the current DPI resolution.

Remarks

The quality and size of the file generated will depend upon the DPI requested. Use GetMaxIDP to determine the upper limit for this property.

See Also

PrintPro Object | PrintPro Members


ResX Property

ResX Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : ResX Property

Glossary Item Box

Description

Gets the horizontal resolution of the printer in dots per inch (e.g. 600 DPI).

Property Type

Read-write property

Syntax

Visual Basic
Public Property ResX As Long

Return Type

A long value which represents the horizontal resolution of the print in DPI.

Remarks

Not available at design time.

See Also

PrintPro Object | PrintPro Members


ResY Property

ResY Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : ResY Property

Glossary Item Box

Description

Gets the vertical resolution of the printer in dots per inch (e.g. 600 DPI).

Property Type

Read-write property

Syntax

Visual Basic
Public Property ResY As Long

Return Type

A long value which represents the vertical resolution of the print in DPI.

Remarks

Not available at design time.

See Also

PrintPro Object | PrintPro Members


SaveFileType Property

SaveFileType Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : SaveFileType Property

Glossary Item Box

Description

Controls the type of file generated.

Property Type

Read-write property

Syntax

Visual Basic
Public Property SaveFileType As PP_SaveFileType

Return Type

The PP_SaveFileType value set.

Remarks

The PrintToFile property must be set to True for this property to have an effect.

Multi-page files may be saved as TIFF and PDF types.

See Also

PrintPro Object | PrintPro Members | PP_SaveFileType Enumeration


ScaleHeight Property

ScaleHeight Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : ScaleHeight Property

Glossary Item Box

Description

Gets the number of units for the vertical measurement of the interior of a printer.

Property Type

Read-write property

Syntax

Visual Basic
Public Property ScaleHeight As Single

Return Type

A single value which represents the number of units for the vertical measurement of the interior of a printer.

Remarks

Use the ScaleMode property to define a scale based on a standard unit of measurement, such as twips, points, pixels, characters, inches, millimeters, or centimeters.

See Also

PrintPro Object | PrintPro Members


ScaleMode Property

ScaleMode Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : ScaleMode Property

Glossary Item Box

Description

Gets or sets a value indicating the unit of measurement for coordinates of an object when printing or using graphics methods.

Property Type

Read-write property

Syntax

Visual Basic
Public Property ScaleMode As PP_ScaleMode

Return Type

The PP_ScaleMode value which determines the unit of measurement for coordinates of an object when printing or using graphics methods.

See Also

PrintPro Object | PrintPro Members | PP_ScaleMode Enumeration


ScaleWidth Property

ScaleWidth Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : ScaleWidth Property

Glossary Item Box

Description

Gets the number of units for the horizontal measurement of the interior of a printer.

Property Type

Read-write property

Syntax

Visual Basic
Public Property ScaleWidth As Single

Return Type

A single value which represents the number of units for the horizontal measurement of the interior of a printer.

Remarks

Use the ScaleMode property to define a scale based on a standard unit of measurement, such as twips, points, pixels, characters, inches, millimeters, or centimeters.

See Also

PrintPro Object | PrintPro Members


TemplateFile Property

TemplateFile Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : TemplateFile Property

Glossary Item Box

Description

The photograph collage description file name.

Property Type

Read-write property

Syntax

Visual Basic
Public Property TemplateFile As String

Return Type

A string value which represents the collage description file name.

Remarks

The use of a TemplateFile provides a simplified access to PrintPicture and PrintDIB.

A collage template file is a text file of particular format that describes component image size and location. The first line is a format and version control line so that future modifications may be supported transparently and is as follows:

Accusoft PrintPRO Template Version 1 Units = TW | PO | PI | CH | IN | MI | CE

Use only one of the unit indicators. They represent Twips, Point, Pixel, Character, Inches, Millimeter and Centimeter. The first two characters are sufficient for selecting the unit used to describe location and dimensions.

Each subsequent line describes the location and cropping of a component image. A line consists of a delimited (by comma, space, spaces or tab) series of values: Left, Top, Width, Height, SourceLeft, SourceTop, SourceWidth, SourceHeight and an Aspect flag.

Example

If the source parameters are omitted, then the entire source image is inserted. For example:

Accusoft PrintPRO Template Version 1 Units = IN

0,0,8.5,11.0, 0 ' Full size background image, stretch to fit

1.0, 1.0, 4.0, 5.0 ' Insert a 4x5 an inch in from the top left corner

4,5,4.5,6 ' Fill the bottom right corner

3, 2, 1, 1, 7, 0, 1, 1 ' Clip a 1x1 section out of the top right corner of an image and insert it

See PrintDIB for the particulars on these parameters.

The following is an example of building a collage:

Private Sub TiffPrint1_Click()

Dim BaseDir As String

BaseDir = "C:\Develop\PrintPRO\PhotoTest"

PrintPRO.SelectDefaultPrinter

' PrintPRO.PictureTransparent = True

PrintPRO.PrintToFile = True

PrintPRO.SaveFileType = PP_TIF

PrintPRO.OutputFileName = BaseDir & "\Collage.tif"

PrintPRO1.StartPrintDoc

' Page 1

Ixp.FileName = BaseDir & "\Accusoft111.jpg"

PrintPRO.hDIB = Ixp.hDIB

PrintPRO.PrintTemplateDIB 0

Ixp.FileName = BaseDir & "\exif.jpg"

PrintPRO.hDIB = Ixp.hDIB

PrintPRO.PrintTemplateDIB 0

Ixp.FileName = BaseDir & "\jeansFix.jpg"

PrintPRO.hDIB = Ixp.hDIB

PrintPRO.PrintTemplateDIB 0

Ixp.FileName = BaseDir & "\MainTest.bmp"

PrintPRO.hDIB = Ixp.hDIB

PrintPRO.PrintTemplateDIB 0

Ixp.FileName = BaseDir & "\Blue hills.bmp"

PrintPRO.hDIB = Ixp.hDIB

PrintPRO.PrintTemplateDIB 0

‘ Page 2 generated because template file wraps which is a implicit new-page

Ixp.FileName = BaseDir & "\Accusoft111.jpg"

PrintPRO.hDIB = Ixp.hDIB

PrintPRO.PrintTemplateDIB 0

Ixp.FileName = BaseDir & "\monet.jpg"

PrintPRO.hDIB = Ixp.hDIB

PrintPRO.PrintTemplateDIB 0

Ixp.FileName = BaseDir & "\jeansFix.jpg"

PrintPRO.hDIB = Ixp.hDIB

PrintPRO.PrintTemplateDIB 0

Ixp.FileName = BaseDir & "\exif.jpg"

PrintPRO.hDIB = Ixp.hDIB

PrintPRO.PrintTemplateDIB 0

Ixp.FileName = BaseDir & "\MainTest.bmp"

PrintPRO.hDIB = Ixp.hDIB

PrintPRO.PrintTemplateDIB 0

PrintPRO.EndPrintDoc

End Sub

The Template file places images only at this time. Draw text and other objects (circles, rectangles, etc.) using the appropriate Draw method.

See Also

PrintPro Object | PrintPro Members


TMargin Property

TMargin Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : TMargin Property

Glossary Item Box

Description

Gets or sets the top margin value.

Property Type

Read-write property

Syntax

Visual Basic
Public Property TMargin As Single

Return Type

A single value which represents the top margin value.

Remarks

When the TMargin property is set, the CurrentY property is also set to the same value. Margin values are expressed in twips, or the current unit of measurement defined by the ScaleMode property.

The following methods set the CurrentY property to the TMargin value:

  • EndPrintDoc

  • NewPage

See Also

PrintPro Object | PrintPro Members


TTOptions Property

TTOptions Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : TTOptions Property

Glossary Item Box

Description

Gets or sets a value indicating the printer’s TrueType option.

Property Type

Read-write property

Syntax

Visual Basic
Public Property TTOptions As PP_TrueTypeOption

Return Type

The PP_TrueTypeOption value set.

See Also

PrintPro Object | PrintPro Members


TwipsPerPixelX Property

TwipsPerPixelX Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : TwipsPerPixelX Property

Glossary Item Box

Description

Gets the number of twips per pixel for a printer measured horizontally.

Property Type

Read-write property

Syntax

Visual Basic
Public Property TwipsPerPixelX As Single

Return Type

A single value which represents the number of twips per pixel for a printer measured horizontally.

Remarks

Not available at design time.

Windows API routines generally require measurements in pixels.

You can use these properties to convert measurements quickly without changing an object's ScaleMode property setting.

See Also

PrintPro Object | PrintPro Members


TwipsPerPixelY Property

TwipsPerPixelY Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : TwipsPerPixelY Property

Glossary Item Box

Description

Gets the number of twips per pixel for a printer measured vertically.

Property Type

Read-write property

Syntax

Visual Basic
Public Property TwipsPerPixelY As Single

Return Type

A single value which represents the number of twips per pixel for a printer measured vertically.

Remarks

Not available at design time.

Windows API routines generally require measurements in pixels.

You can use these properties to convert measurements quickly without changing an object's ScaleMode property setting.

See Also

PrintPro Object | PrintPro Members


UseDefaultPrinter Property

UseDefaultPrinter Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : UseDefaultPrinter Property

Glossary Item Box

Description

Gets and sets an indicator whether PrintPRO uses the system default printer by default.

Property Type

Read-write property

Syntax

Visual Basic
Public Property UseDefaultPrinter As Boolean

Return Type

A boolean value which is True to automatically select the system default printer when the control is loaded. False should be used to not select any printer when the control is loaded.

See Also

PrintPro Object | PrintPro Members


UseHardwareMargins Property

UseHardwareMargins Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : UseHardwareMargins Property

Glossary Item Box

Description

Gets and sets an indicator if hardware margins are used.

Property Type

Read-write property

Syntax

Visual Basic
Public Property UseHardwareMargins As Boolean

Return Type

A boolean value which is True to use hardware margins. Otherwise, False should be used to not use hardware margins.

See Also

PrintPro Object | PrintPro Members


Version Property

Version Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : Version Property

Glossary Item Box

Description

Returns the version of the PrintPro control at run-time.

Property Type

Read-write property

Syntax

Visual Basic
Public Property Version As String

Return Type

A String representing the PrintPro version.

See Also

PrintPro Object | PrintPro Members


WordWrap Property

WordWrap Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : WordWrap Property

Glossary Item Box

Description

Gets and sets a value to determine whether text word wraps inside the PrintText method’s print rectangle.

Property Type

Read-write property

Syntax

Visual Basic
Public Property WordWrap As Boolean

Return Type

A boolean value which is True to wrap text inside the PrintText method's print rectangle. Otherwise, False should be used.

See Also

PrintPro Object | PrintPro Members


Zoom Property

Zoom Property
AccusoftPrintPro6 ActiveX DLL > PrintPro Object : Zoom Property

Glossary Item Box

Description

Gets or sets the percentage by which printed output is to be scaled up or down (if the printer supports this feature).

Property Type

Read-write property

Syntax

Visual Basic
Public Property Zoom As Long

Return Type

A long value which represents the percentage of printed output is to be scaled up or down.

Remarks

Not available at design time.

The Zoom property setting scales the size of the physical page up or down, by a factor of Zoom/100, to the apparent size of the printed output. For example, a letter-size page printed with Zoom set to 50 contains as much data as a page of the size 17 by 22 inches because the printed text and graphics are scaled to one-half their original height and width.

Note: The effect of setting the Zoom property depends on the driver supplied by the printer manufacturer. Some property settings may have no effect. Settings outside the accepted range may produce an error. The ErrorCode property will be set to -5015 or -5016 if the printer does not support this property. For more information, see the manufacturer's documentation for the specific printer driver.

See Also

PrintPro Object | PrintPro Members | ErrorCode Property


PP_Alignment Enumeration

PP_Alignment Enumeration
AccusoftPrintPro6 ActiveX DLL : PP_Alignment Enumeration

Glossary Item Box

Description

Option values which define the possible text alignment styles.

Members

Member | Value | Description
PP_Alignment_CenterJustifyBottom | 8 | (8) Text appears centered at the bottom of the print rectangle.
PP_Alignment_CenterJustifyMiddle | 7 | (7) Text appears centered in the middle of the print rectangle.
PP_Alignment_CenterJustifyTop | 6 | (6) Text appears centered at the top of the print rectangle.
PP_Alignment_LeftJustifyBottom | 2 | (2) Text appears left justified at the bottom of the print rectangle.
PP_Alignment_LeftJustifyMiddle | 1 | (1) Text appears left justified in the middle of the print rectangle.
PP_Alignment_LeftJustifyTop | 0 | (0) Text appears left justified at the top of the print rectangle
PP_Alignment_RightJustifyBottom | 5 | (5) Text appears right-justified at the bottom of the print rectangle.
PP_Alignment_RightJustifyMiddle | 4 | (4) Text appears right justified in the middle of the print rectangle.
PP_Alignment_RightJustifyTop | 3 | (3) Text appears right justified at the top of the print rectangle


PP_BackStyle Enumeration

PP_BackStyle Enumeration
AccusoftPrintPro6 ActiveX DLL : PP_BackStyle Enumeration

Glossary Item Box

Description

Option values which define the possible background styles of printed text.

Members

Member | Value | Description
PP_BackStyle_Opaque | 1 | (1) The text background is filled with BackColor and obscures any color or graphics behind it.
PP_BackStyle_Transparent | 0 | (0) Background color and any graphics are visible behind the text.


PP_ColorMode Enumeration

PP_ColorMode Enumeration
AccusoftPrintPro6 ActiveX DLL : PP_ColorMode Enumeration

Glossary Item Box

Description

Option values which define two values: one for printing in color and one for printing in monochrome.

Members

Member | Value | Description
PP_ColorMode_Color | 2 | (2) Print output in color.
PP_ColorMode_Monochrome | 1 | (1) Print output in monochrome (usually shades of black and white).


PP_DebugErrorLevel Enumeration

PP_DebugErrorLevel Enumeration
AccusoftPrintPro6 ActiveX DLL : PP_DebugErrorLevel Enumeration

Glossary Item Box

Description

Option values which determine the amount of logging to write to the debug log file.

Members

Member | Value | Description
PP_DebugErrorLevel_Detailed | 2 | The highest amount of logging which includes all information.
PP_DebugErrorLevel_Development | 1 | Includes any additional information that may be useful while developing.
PP_DebugErrorLevel_Normal | 0 | This is the default. The minimal amount of logging is written.


PP_DitherType Enumeration

PP_DitherType Enumeration
AccusoftPrintPro6 ActiveX DLL : PP_DitherType Enumeration

Glossary Item Box

Description

Option values which define the possible types of dithering that can be done.

Members

Member | Value | Description
PP_DitherType_CoarseDither | 2 | (2) Dither with a coarse brush.
PP_DitherType_ErrorDiffusionDither | 5 | (5) Error diffusion dithering.
PP_DitherType_FineDither | 3 | (3) Dither with a fine brush.
PP_DitherType_GrayscaleDither | 10 | (10) Device does gray scaling.
PP_DitherType_LineArtDither | 4 | (4) Line art dithering, a special dithering method that produces well defined borders between black, white, and gray scaling. It is not suitable for images that include continuous gradations in intensity and hue such as scanned photographs.
PP_DitherType_NoDither | 1 | (1) No dithering.


PP_DrawMode Enumeration

PP_DrawMode Enumeration
AccusoftPrintPro6 ActiveX DLL : PP_DrawMode Enumeration

Glossary Item Box

Description

Option values which define the possible values to determine appearance of output from graphics methods.

Members

Member | Value | Description
PP_DrawMode_Blackness | 1 | (1) Blackness.
PP_DrawMode_CopyPen | 13 | (13) Color specified by the graphic method.
PP_DrawMode_Invert | 6 | (6) Inverse of the display color.
PP_DrawMode_MaskNotPen | 3 | (3) A combination of the colors common to the background and the inverse of the pen.
PP_DrawMode_MaskPen | 9 | (9) Combination of the colors common to both the pen and the display.
PP_DrawMode_MaskPenNot | 5 | (5) Combination of the colors common to both the pen and the inverse of the display.
PP_DrawMode_MergeNotPen | 12 | (12) Combination of the display color and the inverse of the pen color.
PP_DrawMode_MergePen | 15 | (15) Combination of the pen color and the display color.
PP_DrawMode_MergePenNot | 14 | (14) Combination of the pen color and the inverse of the display color.
PP_DrawMode_Nop | 11 | (11) No operation — output remains unchanged. In effect, this setting turns drawing off.
PP_DrawMode_NotCopyPen | 4 | (4) Inverse of CopyPen.
PP_DrawMode_NotMaskPen | 8 | (8) Inverse of Mask Pen.
PP_DrawMode_NotMergePen | 2 | (2) Inverse of MergePen.(3) Combination of the colors common to the background color and the inverse of the pen.
PP_DrawMode_NotXorPen | 10 | (10) Inverse of Xor Pen.
PP_DrawMode_Whiteness | 16 | (16) Whiteness.
PP_DrawMode_Xor | 7 | (7) Combination of the colors in the pen and in the display color, but not in both.


PP_DrawStyle Enumeration

PP_DrawStyle Enumeration
AccusoftPrintPro6 ActiveX DLL : PP_DrawStyle Enumeration

Glossary Item Box

Description

Option values which define the possible line styles for output from graphics methods.

Members

Member | Value | Description
PP_DrawStyle_Dash | 2 | (2) Line comprised of dashes.
PP_DrawStyle_DashDot | 4 | (4) Line comprised of alternating dashes and dots.
PP_DrawStyle_DashDotDot | 5 | (5) Line comprised of one dash followed by two dots.
PP_DrawStyle_Dot | 3 | (3) Line comprised of dots.
PP_DrawStyle_Solid | 1 | (1) Solid line.
PP_DrawStyle_Transparent | 0 | (0) Transparent line.


PP_Duplex Enumeration

PP_Duplex Enumeration
AccusoftPrintPro6 ActiveX DLL : PP_Duplex Enumeration

Glossary Item Box

Description

Option values which define the possible duplexing options.

Members

Member | Value | Description
PP_Duplex_Horizontal | 3 | (3) Double-sided printing using a horizontal page turn.
PP_Duplex_Simplex | 1 | (1) Single-sided printing with the current orientation setting.
PP_Duplex_Vertical | 2 | (2) Double-sided printing using a vertical page turn.


PP_EvaluationMode Enumeration

PP_EvaluationMode Enumeration
AccusoftPrintPro6 ActiveX DLL : PP_EvaluationMode Enumeration

Glossary Item Box

Description

Option values which defines the possible behaviors of the control when in evaluation (non-licensed) mode.

Members

Member | Value | Description
PP_EvaluationMode_Automatic | 0 | The trial licensing dialog box will appear at regular intervals.
PP_EvaluationMode_Timeout | 1 | The control stops operation after a short period of time.


PP_FillStyle Enumeration

PP_FillStyle Enumeration
AccusoftPrintPro6 ActiveX DLL : PP_FillStyle Enumeration

Glossary Item Box

Description

Option values which define the possible patterns used to fill circles, boxes, round rectangles, pie-shapes and polygons created with graphics methods.

Members

Member | Value | Description
PP_FillStyle_Cross | 6 | (6) Cross fill.
PP_FillStyle_DiagonalCross | 7 | (7) Diagonal cross fill.
PP_FillStyle_DownwardDiagonal | 4 | (4) Downward diagonal fill.
PP_FillStyle_HorizontalLine | 2 | (2) Horizontal line fill.
PP_FillStyle_Solid | 0 | (0) Solid fill.
PP_FillStyle_Transparent | 1 | (1) Transparent fill.
PP_FillStyle_UpwardDiagonal | 5 | (5) Upward diagonal fill.
PP_FillStyle_VerticalLine | 3 | (3) Vertical line fill.


PP_FROMHDIBMETHOD Enumeration

PP_FROMHDIBMETHOD Enumeration
AccusoftPrintPro6 ActiveX DLL : PP_FROMHDIBMETHOD Enumeration

Glossary Item Box

Description

Specifies the FromHdib method type.

Members

Member | Value | Description
PP_FROMHDIBMETHOD_CREATECOPY | 0 | Specifies that the DIB is to be duplicated, the user has the responsibility of calling GlobalFree() to clean up the resource.
PP_FROMHDIBMETHOD_TRANSFERINTERNALHDIB | 1 | Specifies that the internal DIB is to be used, ImagXpress handles cleaning up the resource.


PP_IcmIntent Enumeration

PP_IcmIntent Enumeration
AccusoftPrintPro6 ActiveX DLL : PP_IcmIntent Enumeration

Glossary Item Box

Description

Option values which define the possible color management methods, or intents, to use by default.

Members

Member | Value | Description
PP_IcmIntent_ColorMetric | 3 | (3) Color matching should optimize to match the exact color requested. This value is most appropriate for use with business logos or other images when an exact color is desired.
PP_IcmIntent_Contrast | 2 | (2) Color matching should optimize for color contrast. This value is the most appropriate choice for scanned or photographic images when dithering is desired.
PP_IcmIntent_Saturation | 1 | (1) Color matching should optimize for color saturation. This value is the most appropriate choice for business graphs when dithering is not desired.


PP_IcmMethod Enumeration

PP_IcmMethod Enumeration
AccusoftPrintPro6 ActiveX DLL : PP_IcmMethod Enumeration

Glossary Item Box

Description

Option values which define the possibilities for how Image Color Management (ICM) is handled.

Members

Member | Value | Description
PP_IcmMethod_Device | 4 | (4) Specifies that ICM is handled by the device.
PP_IcmMethod_Disabled | 1 | (1) Specifies that ICM is disabled.
PP_IcmMethod_Driver | 3 | (3) Specifies that ICM is handled by the device driver.
PP_IcmMethod_Profile | 5 | (5) Specifies that PrintPRO will apply the ICM profile associated with the destination device (printer or monitor).
PP_IcmMethod_System | 2 | (2) Specifies that ICM is handled by Windows.


PP_MediaType Enumeration

PP_MediaType Enumeration
AccusoftPrintPro6 ActiveX DLL : PP_MediaType Enumeration

Glossary Item Box

Description

Option values which define the possible media to print on.

Members

Member | Value | Description
PP_MediaType_GlossyPaper | 3 | (3) Plain paper.
PP_MediaType_StandardPaper | 1 | (1) Glossy paper.
PP_MediaType_Transparency | 2 | (2) Transparent film.


PP_Orientation Enumeration

PP_Orientation Enumeration
AccusoftPrintPro6 ActiveX DLL : PP_Orientation Enumeration

Glossary Item Box

Description

Option values which define the set of possible orientations for the document.

Members

Member | Value | Description
PP_Orientation_Landscape | 2 | (2) — The top of document prints at the wide side of the paper.
PP_Orientation_Portrait | 1 | (1) — The top of the document prints at the narrow side (top) of the paper.
PP_Orientation_Rotate | 3 | (3) - The paper is rotated.


PP_PaperSize Enumeration

PP_PaperSize Enumeration
AccusoftPrintPro6 ActiveX DLL : PP_PaperSize Enumeration

Glossary Item Box

Description

Option values which define possible paper sizes for printing.

Members

Member | Value | Description
PP_PaperSize_10x11 | 45 | (45) 10 x 11 in.
PP_PaperSize_10x14 | 16 | (16) 10 x 14 in.
PP_PaperSize_11x17 | 17 | (17) 11 x 17 in.
PP_PaperSize_12x11 | 90 | (90) 12 x 11 in.
PP_PaperSize_15x11 | 46 | (46) 15 x 11 in.
PP_PaperSize_9x11 | 44 | (44) 9 x 11 in.
PP_PaperSize_A_Plus | 57 | (57) SuperA/SuperA/A4 227 x 356 mm
PP_PaperSize_A2 | 66 | (66) A2 420 x 594 mm
PP_PaperSize_A3 | 8 | (8) A3, 297 x 420 mm
PP_PaperSize_A3_Extra | 63 | (63) A3 Extra 322 x 445 mm
PP_PaperSize_A3_Extra_Transverse | 68 | (68) A3 Extra Transverse 322 x 445 mm
PP_PaperSize_A3_Rotated | 76 | (76) A3 Rotated 420 x 297 mm
PP_PaperSize_A3_Transverse | 67 | (67) A3 Transverse 297 x 420 mm
PP_PaperSize_A4 | 9 | (9) A4, 210 x 297 mm
PP_PaperSize_A4_Extra | 53 | (53) A4 Extra 9.27 x 12.69 in.
PP_PaperSize_A4_Plus | 60 | (60) A4 Plus 210 x 330 mm
PP_PaperSize_A4_Rotated | 77 | (77) A4 Rotated 297 x 210 mm
PP_PaperSize_A4_Transverse | 55 | (55) A4 Transverse 210 x 297 mm
PP_PaperSize_A4Small | 10 | (10) A4 Small, 210 x 297 mm
PP_PaperSize_A5 | 11 | (11) A5, 148 x 210 mm
PP_PaperSize_A5_Extra | 64 | (64) A5 Extra 174 x 235 mm
PP_PaperSize_A5_Rotated | 78 | (78) A5 Rotated 210 x 148 mm
PP_PaperSize_A5_Transverse | 61 | (61) A5 Transverse 148 x 210 mm
PP_PaperSize_A6 | 70 | (70) A6 105 x 148 mm
PP_PaperSize_A6_Rotated | 83 | (83) A6 Rotated 148 x 105 mm
PP_PaperSize_B_Plus | 58 | (58) SuperB/SuperB/A3 305 x 487 mm
PP_PaperSize_B4 | 12 | (12) B4, 250 x 354 mm
PP_PaperSize_B4_JIS_Rotated | 79 | (79) B4 (JIS) Rotated 364 x 257 mm
PP_PaperSize_B5 | 13 | (13) B5, 182 x 257 mm
PP_PaperSize_B5_Extra | 65 | (65) B5 (ISO) Extra 201 x 276 mm
PP_PaperSize_B5_JIS_Rotated | 80 | (80) B5 (JIS) Rotated 257 x 182 mm
PP_PaperSize_B5_Transverse | 62 | (62) B5 (JIS) Transverse 182 x 257 mm
PP_PaperSize_B6_JIS | 88 | (88) B6 (JIS) 128 x 182 mm
PP_PaperSize_B6_JIS_Rotated | 89 | (89) B6 (JIS) Rotated 182 x 128 mm
PP_PaperSize_CSheet | 24 | (24) C size sheet
PP_PaperSize_DBL_Japanese_Postcard | 69 | (69) Japanese Double Postcard 200 x 148 mm
PP_PaperSize_DBL_Japanese_Postcard_Rotated | 82 | (82) Double Japanese Postcard Rotated 148 x 200 mm
PP_PaperSize_DSheet | 25 | (25) D size sheet
PP_PaperSize_Env_Invite | 47 | (47) Envelope Invite 220 x 220 mm
PP_PaperSize_Envelope10 | 20 | (20) Envelope #10, 4 1/8 x 9 1/2 in.
PP_PaperSize_Envelope11 | 21 | (21) Envelope #11, 4 1/2 x 10 3/8 in.
PP_PaperSize_Envelope12 | 22 | (22) Envelope #12, 4 1/2 x 11 in.
PP_PaperSize_Envelope14 | 23 | (23) Envelope #14, 5 x 11 1/2 in.
PP_PaperSize_Envelope9 | 19 | (19) Envelope #9, 3 7/8 x 8 7/8 in.
PP_PaperSize_EnvelopeB4 | 33 | (33) Envelope B4, 250 x 353 mm
PP_PaperSize_EnvelopeB5 | 34 | (34) Envelope B5, 176 x 250 mm
PP_PaperSize_EnvelopeB6 | 35 | (35) Envelope B6, 176 x 125 mm
PP_PaperSize_EnvelopeC3 | 29 | (29) Envelope C3, 324 x 458 mm
PP_PaperSize_EnvelopeC4 | 30 | (30) Envelope C4, 229 x 324 mm
PP_PaperSize_EnvelopeC5 | 28 | (28) Envelope C5, 162 x 229 mm
PP_PaperSize_EnvelopeC6 | 31 | (31) Envelope C6, 114 x 162 mm
PP_PaperSize_EnvelopeC65 | 32 | (32) Envelope C65, 114 x 229 mm
PP_PaperSize_EnvelopeDL | 27 | (27) Envelope DL, 110 x 220 mm
PP_PaperSize_EnvelopeItaly | 36 | (36) Envelope, 110 x 230 mm
PP_PaperSize_EnvelopeMonarch | 37 | (37) Envelope Monarch, 3 7/8 x 7 1/2 in.
PP_PaperSize_EnvelopePersonal | 38 | (38) Envelope, 3 5/8 x 6 1/2 in.
PP_PaperSize_ESheet | 26 | (26) E size sheet
PP_PaperSize_Executive | 7 | (7) Executive, 7 1/2 x 10 1/2 in.
PP_PaperSize_FanFoldLegalGerman | 41 | (41) German Legal Fanfold, 8 1/2 x 13 in.
PP_PaperSize_FanFoldStdGerman | 40 | (40) German Standard Fanfold, 8 1/2 x 12 in.
PP_PaperSize_FanFoldUS | 39 | (39) Standard Fanfold, 14 7/8 x 11 in.
PP_PaperSize_Filio | 14 | (14) Folio, 8 1/2 x 13 in.
PP_PaperSize_ISO_B4 | 42 | (42) Japanese Postcard 100 x 148 mm
PP_PaperSize_Japanese_Postcard_Rotated | 81 | (81) Japanese Postcard Rotated 148 x 100 mm
PP_PaperSize_JEnv_CHOU3 | 73 | (73) Japanese Envelope Chou #3
PP_PaperSize_JEnv_CHOU3_Rotated | 86 | (86) Japanese Envelope Chou #3 Rotated
PP_PaperSize_JEnv_CHOU4 | 74 | (74) Japanese Envelope Chou #4
PP_PaperSize_JEnv_CHOU4_Rotated | 87 | (87) Japanese Envelope Chou #4 Rotated
PP_PaperSize_JEnv_KAKU2 | 71 | (71) Japanese Envelope Kaku #2
PP_PaperSize_JEnv_KAKU2_Rotated | 84 | (84) Japanese Envelope Kaku #2 Rotated
PP_PaperSize_JEnv_KAKU3 | 72 | (72) Japanese Envelope Kaku #3
PP_PaperSize_JEnv_KAKU3_Rotated | 85 | (85) Japanese Envelope Kaku #3 Rotated
PP_PaperSize_JEnv_YOU4 | 91 | (91) Japanese Envelope You #4
PP_PaperSize_JEnv_YOU4_Rotated | 92 | (92) Japanese Envelope You #4 Rotated
PP_PaperSize_Ledger | 4 | (4) Ledger, 17 x 11 in.
PP_PaperSize_Legal | 5 | (5) Legal, 8 1/2 x 14 in.
PP_PaperSize_LEGAL_Extra | 51 | (51) Legal Extra 9 \275 x 15 in.
PP_PaperSize_Letter | 1 | (1) Letter, 8 1/2 x 11 in.
PP_PaperSize_Letter_Extra | 50 | (50) Letter Extra 9 \275 x 12 in.
PP_PaperSize_Letter_Extra_Transverse | 56 | (56) Letter Extra Transverse 9\275 x 12 in.
PP_PaperSize_Letter_Plus | 59 | (59) Letter Plus
PP_PaperSize_Letter_Rotated | 75 | (75) Letter Rotated 11 x 8 1/2 11 in.
PP_PaperSize_Letter_Transverse | 54 | (54) Letter Transverse 8 \275 x 11 in.
PP_PaperSize_LetterSmall | 2 | (2) Letter Small, 8 1/2 x 11 in.
PP_PaperSize_Note | 18 | (18) Note, 8 1/2 x 11 in.
PP_PaperSize_P16K | 93 | (93) PRC 16K 146 x 215 mm
PP_PaperSize_P16K_Rotated | 106 | (106) PRC 16K Rotated
PP_PaperSize_P32K | 94 | (94) PRC 32K 97 x 151 mm
PP_PaperSize_P32K_Rotated | 107 | (107) PRC 32K Rotated
PP_PaperSize_P32KBig | 95 | (95) PRC 32K(Big) 97 x 151 mm
PP_PaperSize_P32KBig_Rotated | 108 | (108) PRC 32K(Big) Rotated
PP_PaperSize_PEnv_1 | 96 | (96) PRC Envelope #1 102 x 165 mm
PP_PaperSize_PEnv_1_Rotated | 109 | (109) PRC Envelope #1 Rotated 165 x 102 mm
PP_PaperSize_PEnv_10 | 105 | (105) PRC Envelope #10 324 x 458 mm
PP_PaperSize_PEnv_10_Rotated | 118 | (118) PRC Envelope #10 Rotated 458 x 324 mm
PP_PaperSize_PEnv_2 | 97 | (97) PRC Envelope #2 102 x 176 mm
PP_PaperSize_PEnv_2_Rotated | 110 | (110) PRC Envelope #2 Rotated 176 x 102 mm
PP_PaperSize_PEnv_3 | 98 | (98) PRC Envelope #3 125 x 176 mm
PP_PaperSize_PEnv_3_Rotated | 111 | (111) PRC Envelope #3 Rotated 176 x 125 mm
PP_PaperSize_PEnv_4 | 99 | (99) PRC Envelope #4 110 x 208 mm
PP_PaperSize_PEnv_4_Rotated | 112 | (112) PRC Envelope #4 Rotated 208 x 110 mm
PP_PaperSize_PEnv_5 | 100 | (100) PRC Envelope #5 110 x 220 mm
PP_PaperSize_PEnv_5_Rotated | 113 | (113) PRC Envelope #5 Rotated 220 x 110 mm
PP_PaperSize_PEnv_6 | 101 | (101) PRC Envelope #6 120 x 230 mm
PP_PaperSize_PEnv_6_Rotated | 114 | (114) PRC Envelope #6 Rotated 230 x 120 mm
PP_PaperSize_PEnv_7 | 102 | (102) PRC Envelope #7 160 x 230 mm
PP_PaperSize_PEnv_7_Rotated | 115 | (115) PRC Envelope #7 Rotated 230 x 160 mm
PP_PaperSize_PEnv_8 | 103 | (103) PRC Envelope #8 120 x 309 mm
PP_PaperSize_PEnv_8_Rotated | 116 | (116) PRC Envelope #8 Rotated 309 x 120 mm
PP_PaperSize_PEnv_9 | 104 | (104) PRC Envelope #9 229 x 324 mm
PP_PaperSize_PEnv_9_Rotated | 117 | (117) PRC Envelope #9 Rotated 324 x 229 mm
PP_PaperSize_Quarto | 15 | (15) Quarto, 215 x 275 mm
PP_PaperSize_Reserved_48 | 48 | (48) Reserved—DO NOT USE
PP_PaperSize_Reserved_49 | 49 | (49) Reserved—DO NOT USE
PP_PaperSize_Statement | 6 | (6) Statement, 5 1/2 x 8 1/2 in.
PP_PaperSize_Tabloid | 3 | (3) Tabloid, 11 x 17 in.
PP_PaperSize_TABLOID_Extra | 52 | (52) Tabloid Extra 11.69 x 18 in.


PP_PreviewScale Enumeration

PP_PreviewScale Enumeration
AccusoftPrintPro6 ActiveX DLL : PP_PreviewScale Enumeration

Glossary Item Box

Description

Option values which define the possible sizes of the print preview image.

Members

Member | Value | Description
PP_PreviewScale_1_1 | 1 | (1) 1:1 – The image size is the same size as the printed image.
PP_PreviewScale_1_10 | 10 | (10) 1:10 – The image size is one-tenth the same size as the printed image.
PP_PreviewScale_1_2 | 2 | (2) 1:2 – The image size is one-half the same size as the printed image.
PP_PreviewScale_1_3 | 3 | (3) 1:3 – The image size is one-third the same size as the printed image.
PP_PreviewScale_1_4 | 4 | (4) 1:4 – The image size is one-fourth the same size as the printed image.
PP_PreviewScale_1_5 | 5 | (5) 1:5 – The image size is one-fifth the same size as the printed image.
PP_PreviewScale_1_6 | 6 | (6) 1:6 – The image size is one-sixth the same size as the printed image.
PP_PreviewScale_1_7 | 7 | (7) 1:7 – The image size is one-seventh the same size as the printed image.
PP_PreviewScale_1_8 | 8 | (8) 1:8 – The image size is one-eight the same size as the printed image.
PP_PreviewScale_1_9 | 9 | (9) 1:9 – The image size is one-ninth the same size as the printed image.


PP_PrintQuality Enumeration

PP_PrintQuality Enumeration
AccusoftPrintPro6 ActiveX DLL : PP_PrintQuality Enumeration

Glossary Item Box

Description

Option values which define the possible values for printer resolution.

Members

Member | Value | Description
PP_PrintQuality_100 | 100 | 100 DPI
PP_PrintQuality_1000 | 1000 | 1000 DPI
PP_PrintQuality_1200 | 1200 | 1200 DPI
PP_PrintQuality_125 | 125 | 125 DPI
PP_PrintQuality_1400 | 1400 | 1400 DPI
PP_PrintQuality_150 | 150 | 150 DPI
PP_PrintQuality_1600 | 1600 | 1600 DPI
PP_PrintQuality_175 | 175 | 175 DPI
PP_PrintQuality_1800 | 1800 | 1800 DPI
PP_PrintQuality_200 | 200 | 200 DPI
PP_PrintQuality_2000 | 2000 | 2000 DPI
PP_PrintQuality_225 | 225 | 225 DPI
PP_PrintQuality_250 | 250 | 250 DPI
PP_PrintQuality_275 | 275 | 275 DPI
PP_PrintQuality_300 | 300 | 300 DPI
PP_PrintQuality_325 | 325 | 325 DPI
PP_PrintQuality_350 | 350 | 350 DPI
PP_PrintQuality_375 | 375 | 375 DPI
PP_PrintQuality_400 | 400 | 400 DPI
PP_PrintQuality_450 | 450 | 450 DPI
PP_PrintQuality_500 | 500 | 500 DPI
PP_PrintQuality_600 | 600 | 600 DPI
PP_PrintQuality_700 | 700 | 700 DPI
PP_PrintQuality_72 | 72 | 72 DPI
PP_PrintQuality_75 | 75 | 75 DPI
PP_PrintQuality_800 | 800 | 800 DPI
PP_PrintQuality_900 | 900 | 900 DPI
PP_PrintQuality_Draft | -1 | (-1) Draft Quality Resolution
PP_PrintQuality_High | -4 | (-4) High Resolution
PP_PrintQuality_Low | -2 | (-2) Low Resolution
PP_PrintQuality_Medium | -3 | (-3) Medium Resolution


PP_PrintRange Enumeration

PP_PrintRange Enumeration
AccusoftPrintPro6 ActiveX DLL : PP_PrintRange Enumeration

Glossary Item Box

Description

Option values which determine the print range selected on the print dialog.

Members

Member | Value | Description
PP_PrintRange_All | 1 | The user selected the All radio button.
PP_PrintRange_None | 0 | Enables none
PP_PrintRange_Pages | 2 | The user selected the Pages radio button.
PP_PrintRange_Selection | 3 | The user selected the Selection radio button.

Remarks

The All value is always enabled. Using All will only enable the All radio button.


PP_PrintRangeEnable Enumeration

PP_PrintRangeEnable Enumeration
AccusoftPrintPro6 ActiveX DLL : PP_PrintRangeEnable Enumeration

Glossary Item Box

Description

Option values which determine the available radio buttons to enable in the print dialog.

Members

Member | Value | Description
PP_PrintRangeEnable_All | 0 | Enable the All radio selection
PP_PrintRangeEnable_AllPages | 1 | Enable the Pages radio selection
PP_PrintRangeEnable_AllPagesSelection | 3 | Enable all pages radio selection
PP_PrintRangeEnable_AllSelection | 2 | Enable the Selection radio selection

Remarks

The All value is always enabled. Using All will only enable the All radio button.


PP_RenderIntent Enumeration

PP_RenderIntent Enumeration
AccusoftPrintPro6 ActiveX DLL : PP_RenderIntent Enumeration

Glossary Item Box

Description

Option values which determine the color correction to use.

Members

Member | Value | Description
PP_RenderIntent_AbsoluteColormetric | 3 | The white point is preserved. Spatial color distance to white point changes but not the white point itself. (Absolute Colormetric)
PP_RenderIntent_Business | 1 | Only colors outside of gamut moved to closest inside value. White Point is not preserved. (Relative Colormetric)
PP_RenderIntent_Graphics | 2 | Preserve color saturation at expense of hue and lightness. Colors are vibrant but not accurate. (Saturation)
PP_RenderIntent_Images | 0 | Gamut of image fits (shrinks or expands) and fills the destination device gamut. Spatial distance of colors are relatively scaled for all color to fit within the gamut of the device. (Perceptual).
PP_RenderIntent_None | -1 | Disables Image Color Management.


PP_SaveFileType Enumeration

PP_SaveFileType Enumeration
AccusoftPrintPro6 ActiveX DLL : PP_SaveFileType Enumeration

Glossary Item Box

Description

Option values which define the possible types of files generated.

Members

Member | Value | Description
PP_SaveFileType_Bmp | 5 | (5) Bitmap (color)
PP_SaveFileType_Default | 0 | (0) Default file and compression type.
PP_SaveFileType_Emf | 6 | (6) Enhanced MetaFile
PP_SaveFileType_PdfDefault | 8 | (8) PDF default.
PP_SaveFileType_PdfG3 | 10 | (10) PDF with CCITT G3 compression (black and white compressed).
PP_SaveFileType_PdfG32D | 11 | (11) PDF with CCITT G3 2D compression (black and white compressed).
PP_SaveFileType_PdfG4 | 7 | (7) PDF with CCITT G4 compression (black and white compressed)
PP_SaveFileType_PdfJbig2 | 12 | (12) PDF with JBig2 compression.
PP_SaveFileType_PdfNoCompress | 9 | (9) PDF with no compression.
PP_SaveFileType_PdfSeqJpeg | 13 | (13) PDF with sequential JPEG compression.
PP_SaveFileType_Tif | 1 | (1) TIFF (Color)
PP_SaveFileType_TifG3 | 2 | (2) TIFF with CCITT G3 compression (Black & white compressed)
PP_SaveFileType_TifG32D | 3 | (3) TIFF with CCITT G3 2D compression (Black & white compressed)
PP_SaveFileType_TifG4 | 4 | (4) TIFF with CCITT G4 compression (Black & white compressed)
PP_SaveFileType_TifSeqJpeg | 14 | (14) TIFF with sequential JPEG compression.

Remarks

©2012. Accusoft Corporation. All Rights Reserved.


PP_ScaleMode Enumeration

PP_ScaleMode Enumeration
AccusoftPrintPro6 ActiveX DLL : PP_ScaleMode Enumeration

Glossary Item Box

Description

Option values which define the possible units of measurement for coordinates of an object when printing or using graphics methods.

Members

Member | Value | Description
PP_ScaleMode_Centimeter | 7 | (7) Centimeter
PP_ScaleMode_Character | 4 | (4) Character (horizontal = 120 twips per unit; vertical = 240 twips per unit).
PP_ScaleMode_Inch | 5 | (5) Inch
PP_ScaleMode_Millimeter | 6 | (6) Millimeter
PP_ScaleMode_Pixel | 3 | (3) Pixel (smallest unit of printer resolution).
PP_ScaleMode_Point | 2 | (2) Point (72 points per logical inch)
PP_ScaleMode_Twip | 1 | (1) Twip (1440 twips per logical inch; 567 twips per logical centimeter)


PP_SourceBin Enumeration

PP_SourceBin Enumeration
AccusoftPrintPro6 ActiveX DLL : PP_SourceBin Enumeration

Glossary Item Box

Description

Option values which define the possible default paper bins that can be set.

Members

Member | Value | Description
PP_SourceBin_Auto | 7 | (7) Use paper from the current default bin.
PP_SourceBin_Cassette | 14 | (14) Use paper from the attached cassette cartridge.
PP_SourceBin_Envelope | 5 | (5) Use envelopes from the envelope feeder.
PP_SourceBin_FormSource | 15 | (15) Use form source.
PP_SourceBin_LargeBin | 10 | (10) Use paper from the large paper bin.
PP_SourceBin_LargeCapacity | 11 | (11) Use paper from the large capacity feeder.
PP_SourceBin_Lower | 2 | (2) Use paper from the lower bin.
PP_SourceBin_Manual | 4 | (4) Wait for manual insertion of each sheet of paper.
PP_SourceBin_ManualEnvelope | 6 | (6) Use envelopes from the envelope feeder, but wait for manual insertion.
PP_SourceBin_Middle | 3 | (3) Use paper from the middle bin.
PP_SourceBin_SmallBin | 9 | (9) Use paper from the small paper feeder.
PP_SourceBin_Tractor | 8 | (8) Use paper fed from the tractor feeder
PP_SourceBin_Upper | 1 | (1) Use paper from the upper bin.


PP_TOHDIBMETHOD Enumeration

PP_TOHDIBMETHOD Enumeration
AccusoftPrintPro6 ActiveX DLL : PP_TOHDIBMETHOD Enumeration

Glossary Item Box

Description

Specifies the ToHdib method type.

Members

Member | Value | Description
PP_TOHDIBMETHOD_RETURNDUPLICATE | 0 | Specifies that the DIB is to be duplicated, the user has the responsibility of calling GlobalFree() to clean up the resource.
PP_TOHDIBMETHOD_TRANSFERINTERNALHDIB | 1 | Specifies that the internal DIB is to be used, ImagXpress handles cleaning up the resource.


PP_TrueTypeOption Enumeration

PP_TrueTypeOption Enumeration
AccusoftPrintPro6 ActiveX DLL : PP_TrueTypeOption Enumeration

Glossary Item Box

Description

Option values which define the possible options for printing TrueType fonts.

Members

Member | Value | Description
PP_TrueTypeOption_DownloadFonts | 2 | (2) Download TrueType fonts as soft fonts. This is the default for HP printers that use PCL.
PP_TrueTypeOption_DownloadOutline | 4 | (4) Downloads TrueType fonts as outline soft fonts.
PP_TrueTypeOption_PrintAsGraphics | 1 | (1) Substitute device fonts for TrueType fonts. This is the default for Postscript printers.
PP_TrueTypeOption_UseDeviceFonts | 3 | (3) Print TrueType fonts as graphics. This should be used for dot matrix printers.


Getting Started - Accusoft PrintPRO 6

Getting Started
Send Feedback

Glossary Item Box


Getting Started - Accusoft PrintPRO 6

Introduction
Send Feedback

Glossary Item Box


References

References
Send Feedback

Glossary Item Box