ISIS Xpress User Assistance Dashboard

Accusoft.ISISXpress5.ActiveX
ISIS Xpress User Assistance Dashboard
Send Feedback

Glossary Item Box

Welcome

  • New Features
    • What is ISIS Xpress?

Getting Started

  • Operating Requirements & Installation
    • Operating Requirements
    • Upgrading from ISIS Xpress 4 to ISIS Xpress 5
    • Installing on a Development Machine
  • Licensing & Deployment
    • Licensing
    • Distributing ISIS Xpress
    • Software License Agreement
    • Accusoft Corporation Copyrights & Trademarks

Developer's Guide

  • User Guide

    • Concepts

      • Overview of ISIS Xpress
      • Glossary
  • API Reference Guide
    • Accusoft.ISISXpress5.ActiveX.dll

Additional Resources

  • Online Product Overview
  • Tech Specs
  • White papers & Case Studies
  • FAQs, ISIS Xpress 5 FAQs
  • Support Overview
  • Support Plans/Agreement

Feedback

  • Tell us what you think
    • Email us
    • Take our survey

©2012. Accusoft Corporation. All Rights Reserved.


ISIS Xpress 5 for ActiveX - User Guide

Accusoft.ISISXpress5.ActiveX
ISIS Xpress 5 for ActiveX - User Guide
Send Feedback

Glossary Item Box

The User Guide provides information about the following:

  • Introduction
  • Getting Started
  • Licensing
  • Distributing Applications & Deployment
  • Concepts


Introduction

Accusoft.ISISXpress5.ActiveX
Introduction
Send Feedback
ISIS Xpress 5 for ActiveX - User Guide > Introduction

Glossary Item Box

This introduction provides information about the following:

  • What is ISIS Xpress?
  • Getting Support
  • Accusoft Corporation Copyrights & Trademarks


What is ISIS Xpress?

Accusoft.ISISXpress5.ActiveX
What is ISIS Xpress?
See Also Send Feedback
ISIS Xpress 5 for ActiveX - User Guide > Introduction > What is ISIS Xpress?

Glossary Item Box

ISIS® Xpress™ Version 5 is a powerful, complete, and low-cost software development kit (SDK) used to control high-speed ISIS scanners. ISIS® Xpress can be used as a .NET component or an ActiveX COM component. Designed for high-speed scanning of black/white, grayscale and color documents, it supports simultaneous image capture (multi-streaming), and provides access to ISIS scanner features. ISIS® is a registered trademark of EMC Corporation.

New Features in Version 5

  • Updated support of all high-speed ISIS®-driven scanners using Version 8.5 of EMC Corporation's ISIS® PixTools® library.
  • Added the ability to return the version/build number programmatically.
  • A new licensing model.

Primary Features Included

Scanner Support

  • Provides complete control over all high-speed ISIS®-driven scanners that EMC Corporation's ISIS PixTools supports
  • Scan directly to memory
  • Resolution can range from 50 dots-per-inch (dpi) to 2400 dpi or more depending on scanner capability
  • Automatic feeder, printer/endorsers, and transparency units are supported
  • Interfaces with SCSI, USB, serial port, video, parallel port, GPIB, and proprietary interfaces
  • Access performance scanners from Canon, Agfa, BancTec, Bell & Howell, Epson, Fujitsu, Hewlett-Packard, Inotec, Kodak, Microtek, Minolta, Panasonic, Ricoh, Sharp, and Umax

Compression & File Formats

  • Compress to standard document image file formats
    • TIFF (Raw, Packbits, Binary CCITT Group 3, Binary CCITT Group 3 Modified, Binary CCITT Group 4)
    • Color and grayscale JPEG (24-bit sequential and 8-bit gray sequential)
    • DCX
  • Add on ImagXpress for decompression, conversion, or display of the file formats listed above plus support for many additional file formats.
  • Add on PDFXpress for PDF support.

Advanced Tags

The component will support Advanced Tags, which offers developers great flexibility in utilizing scanner specific features. These are scanner processing instructions which are provided as parameters passed as tag values to the control, and consequently passed directly through to the scanner. Assuming the correct tags are passed to the scanner, they will instruct the scanner what actions to take.

Multi-Streaming Support

  • Take full advantage of scanners supporting MultiStream technology with Duplex or Multi-Streaming
    • Duplex - Scans both front and back simultaneously
    • MultiStreaming - Scans two images from the same side
    • Combine both by using duplex with multi-streaming and capture four images with two on the front and two from the back.
  • Scanning modes could include full-color, black-and-white, grayscale, binary or RGB color dropout

Image Viewing, Annotation, & Printing

Add on ImagXpress for image viewing, thumbnail image support, document image processing and editing, TWAIN scanning, annotation, printing and more.

Bitonal Image Cleanup

Add on ScanFix Xpress for advanced bitonal image cleanup technology such as dot shading removal, line removal, character smoothing, inverse text correction, hole punch removal, deskew, despeckle, rotate, mirror, flip and more.

Additional Accusoft Components

Additional components are available for purchase separately, and integrate easily to provide a comprehensive imaging solution:

  • PDF Xpress™ – PDF creation, viewing, and annotating
  • OCR Xpress™ – full page OCR
  • Barcode Xpress™ – recognize barcodes
  • ScanFix Xpress™ – advanced image cleanup
  • FormFix™ – form ID, dropout, and OMR
  • SmartZone™ ICR / OCR – character recognition
  • ImageGear for .NET - Fully managed code to create cutting edge imaging applications
  • ImageGear for Silverlight - Comprehensive SDK for building Web imaging applications
  • ImageGear for .NET Compact Framework - Create reliable and secure imaging applications for mobile devices

See www.accusoft.com for product packaging and sales information.

See Also

Getting Support
Software License Agreement
Operating Requirements


Getting Support

Accusoft.ISISXpress5.ActiveX
Getting Support
See Also Send Feedback
ISIS Xpress 5 for ActiveX - User Guide > Introduction > Getting Support

Glossary Item Box

For information about Accusoft Support, please refer to the Software Support and Maintenance Policy on the Accusoft web site or call Accusoft at 813-875-7575.

See Also

Operating Requirements
Installing on a Development Machine


Accusoft Corporation Copyrights & Trademarks

Accusoft.ISISXpress5.ActiveX
Accusoft Corporation Copyrights & Trademarks
See Also Send Feedback
ISIS Xpress 5 for ActiveX - User Guide > Introduction > Accusoft Corporation Copyrights & Trademarks

Glossary Item Box

©1997-2012 Accusoft Corporation. All rights reserved.

Information in this document is subject to change without notice. No part of this document may be reproduced or transmitted in any form or by any means, electronic or mechanical, for any purpose, without the express written permission of Accusoft® Corporation.

This manual and the software described in it are both products of the USA.

Accusoft Corporation
4001 North Riverside Drive
Tampa, FL 33603
Sales: 813-875-7575
www.accusoft.com

Accusoft Trademarks

The following are trademarks (™) or registered marks (®) of Accusoft Corporation:

  • Accusoft®
  • Accusoft Logo™
  • Accusoft Pegasus Logo™
  • Adeptol®
  • AIMTools™
  • Barcode Xpress™
  • CapturePro™
  • Digital Mark Recognition® (DMR)
  • FolderBots™
  • FormAssist™
  • FormDirector™
  • FormFix™
  • FormSuite™
  • ImageGear® for .NET
  • ImageGear® for .NET Compact Framework
  • ImageGear® for Silverlight
  • ImageGear® Medical
  • ImageGear® Professional
  • ImageGear®
  • ImageTransport MD™
  • ImagXpress®
  • ISIS® Xpress™
    • ISIS is a registered trademark of EMC Corporation
    • ISIS Xpress is a trademark of Accusoft Corporation
  • MICR Xpress™
  • NetVue™
  • NotateXpress™
  • PDF Xpress™
  • Pegasus®
  • PICTools™
  • PICTools™ Document
  • PICTools™ Fingerprint
  • PICTools™ Medical
  • PICTools™ Photo
  • PICVideo™ M-JPEG Codec
  • PrintPRO™
  • Prizm®
  • Prizm® Viewer
  • ScanFix® Xpress™
  • SmartZone™
  • The JPEG Wizard™
  • ThumbnailXpress™
  • TwainPRO™

Accusoft and/or its agents use these marks and brand names in connection with its goods and/or services, in the United States and other countries.

Microsoft, Internet Explorer, Microsoft.NET, Silverlight, Visual Basic, Visual Studio, and Visual Studio.NET are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries.

Itanium is a registered trademark of Intel Corporation in the United States and other countries.

All other product and brand names are the property of their respective owners.

See Also

Software License Agreement


Getting Started

Accusoft.ISISXpress5.ActiveX
Getting Started
Send Feedback
ISIS Xpress 5 for ActiveX - User Guide > Getting Started

Glossary Item Box

This section provides information about the following:

  • Operating Requirements
  • Installing on a Development Machine
  • Import ISIS Xpress as a COM Object
  • Use ISIS Xpress as an ActiveX Control
  • Upgrading from ISIS Xpress 4 to ISIS Xpress 5


Operating Requirements

Accusoft.ISISXpress5.ActiveX
Operating Requirements
See Also Send Feedback
ISIS Xpress 5 for ActiveX - User Guide > Getting Started > Operating Requirements

Glossary Item Box

Operating Systems

ISIS® Xpress™ runs on supported Microsoft Operating Systems:

  • Windows XP, XP Professional
  • Windows Vista
  • Windows 7
  • Windows Server 2003
  • Windows Server 2008

Development Environment

ISIS Xpress is supported on most ActiveX development environments including the following:

  • Microsoft Visual Basic 6
  • Microsoft Visual C++ 6
  • Delphi 7 and 8

See Also

Getting Support
Installing on a Development Machine


Installing on a Development Machine

Accusoft.ISISXpress5.ActiveX
Installing on a Development Machine
See Also Send Feedback
ISIS Xpress 5 for ActiveX - User Guide > Getting Started > Installing on a Development Machine

Glossary Item Box

To Install ISIS® Xpress™ Component

Run the downloaded setup program which installs the development kit on your development machine.

The downloaded development kit includes code samples for supported platforms. Samples are available through: Start | Programs | Accusoft | ISISXpress menu.

By default this will register trial licensing which allows you to develop applications but not to distribute them. The trial license allows testing of all the functions and features.

Please see the section Distributing ISIS Xpress to understand the limits and details to convert licensing editions.

In order to distribute your finished application you must purchase and install a fully paid license from Accusoft. The paid licenses override trial licenses.

To Use ISIS Xpress Help Files

Once you have installed ISIS Xpress, you will have access to the following stand-alone help file:

  • Accusoft.ISISXpress5.ActiveX.chm

    Access the ISIS Xpress stand-alone help through the Windows Start menu: Start | Programs | Accusoft | ISISXpress 5

See Also

Operating Requirements
Software License Agreement
Distributing ISIS Xpress
Licensing


Import ISIS Xpress as a COM Object

Accusoft.ISISXpress5.ActiveX
Import ISIS Xpress as a COM Object
Send Feedback
ISIS Xpress 5 for ActiveX - User Guide > Getting Started > Import ISIS Xpress as a COM Object

Glossary Item Box

1. Importing a Control into Visual C++

The #import directive line can be added to the stdafx.h file to provide the appropriate functionality to all source files in the project.

C++ Example Copy Code
// This code demonstrates the #import directive used in the stdafx.h file
#if !defined(AFX_STDAFX_H__E86B75CA_B4A0_11D3_9453_00105A098C21__INCLUDED_)
#define AFX_STDAFX_H__E86B75CA_B4A0_11D3_9453_00105A098C21__INCLUDED_

#if _MSC_VER >= 1000
     #pragma once
#endif // _MSC_VER >= 1000

#define VC_EXTRALEAN          // Exclude rarely-used stuff from Windows headers

#include <AFXWIN.H>            // MFC core and standard components
#include <AFXEXT.H>            // MFC extensions
#include <AFXDISP.H>           // MFC OLE automation classes
#ifndef _AFX_NO_AFXCMN_SUPPORT
      #include <AFXCMN.H>     // MFC support for Windows Common Controls
#endif // _AFX_NO_AFXCMN_SUPPORT

//#import the ISISXpress5 DLL here
#import "Accusoft.ISISXpress5.ActiveX.dll"

//{{AFX_INSERT_LOCATION}}
// Microsoft Developer Studio will insert additional declarations immediately before the previous line.

#endif // !defined(AFX_STDAFX_H__E86B75CA_B4A0_11D3_9453_00105A098C21__INCLUDED_)
The #import directive simply points to the ISIS Xpress control. When the ISIS Xpress control is imported with the #import directive, the compiler produces 2 files – a .tli and a .tlh file – that together create the necessary COM wrapper for the control’s properties and methods. Since the directive is in your stdafx.h file, the wrappers are immediately available to your other modules. The wrapper code defines COM smart pointers to your .IDL-defined interfaces. To use this COM object, you simply create an instance of the interface you want and then call methods directly by using this instance pointer.

2. Declare a Pointer to the COM Object

After the #import directive is added, a pointer to the ISIS Xpress COM object must be defined. In the ISISXpressBasic project, the pointer is called pISISXpr and it is implemented in the ISISXpressBasicDlg.h file as follows:
C++ Example Copy Code
#if !defined(AFX_ISISXPRESSBASICDLG_H__E86B75C8_B4A0_11D3_9453_00105A098C21__INCLUDED_)
#define AFX_ISISXPRESSBASICDLG_H__E86B75C8_B4A0_11D3_9453_00105A098C21__INCLUDED_

#if _MSC_VER >= 1000
     #pragma once
#endif // _MSC_VER >= 1000

// add the ISISXpress namespace here
using namespace AccusoftISISXpress5;

#include "..\\..\\..\\..\\Components\\ActiveX-COM\\Include\\ISISXpress5Events.h"

/////////////////////////////////////////////////////////////////////////////
// CIsisXpressBasicDlg dialog

class CIsisXpressBasicDlg : public CDialog
{
     // Event Handler Prototypes
     static HRESULT FeederEmpty(DWORD instancePtr, DWORD objID, long PageNumber, VARIANT_BOOL StopScan);
     static HRESULT Progress(DWORD instancePtr, DWORD objID, long Percent);
     static HRESULT Scanning(DWORD instancePtr, DWORD objID, long PageNumber);
     static HRESULT Scanned(DWORD instancePtr, DWORD objID, long PageNumber);

// Construction
public:
     CIsisXpressBasicDlg (CWnd* pParent = NULL); // standard constructor

     CISISXpress *ppCISISXpress;      // Pointer to the CISISXpress class
     IISISXpressPtr pISISXpr;             // Pointer to the ISISXpress COM object
The ISISXpress5Events.h file contains the CISISXpress class. The CISISXpress class is used to create a ISIS Xpress COM object and it also sets up the event-handling interface. The event handler prototypes shown above must only be implemented for the events used in the application. The ISISXpressBasic project uses all of the events. Implementation of these events is covered later in this discussion.

3. Initialize COM

The COM library must be initialized before COM functions can be called and it must be closed before the program exits. This is illustrated in the ISISXpressBasic.cpp file as follows:

C++ Example Copy Code
BOOL CISISXpressBasic::InitInstance()
{
     // Initialize the COM library on the current apartment and identify
     // the currency model as single-thread apartment (STA). Applications
     // must initialize the COM
     // library before they can call COM library functions other than
     // CoGetMalloc and memory allocation functions.
     CoInitialize(NULL);

      AfxEnableControlContainer();

     // Standard initialization
     // If you are not using these features and wish to reduce the size
     // of your final executable, you should remove from the following
     // the specific initialization routines you do not need.

     #ifdef _AFXDLL
          Enable3dControls() // Call this when using MFC in a shared DLL
     #else
          Enable3dControlsStatic(); // Call this when linking to MFC statically
     #endif

     CIsisXpressBasicDlg dlg;
     m_pMainWnd = &dlg;
     int nResponse = dlg.DoModal();
     if (nResponse = = IDOK)
     {
          // TODO: Place code here to handle when the dialog is
          // dismissed with OK
     }

     // Closes the COM library on the current apartment,
     // unloads all DLLs loaded by apartment,
     // frees any other resources that the apartment maintains, and
     // forces all RPC connections on the apartment to close.
     CoUninitialize();

     // Since the dialog has been closed, return FALSE so that we exit the
     // application, rather than start the application's message pump.
     return FALSE;
}

4. Create the ISIS Xpress COM Object

To use ISIS Xpress, an instance of the ISIS Xpress COM object must be created. After the object is created, the object’s properties and methods can be used to create your scanning application. In the ISISXpressBasic project, the COM object is created in the ISISXpressBasicDlg.cpp file as follows:

C++ Example Copy Code
// The following typedef is required by ISISX3_Open.cpp unless you include
// the ISISX3_Open.h file.
typedef HRESULT (WINAPI* LPFNDLL_PSUnlock)(long, long, long, long);
// Before you distribute applications that use the ISIS Xpress COM object, you need to edit
// the ISISX2_Open.cpp file and change the integrator key passed to the PS_Unlock function.
// The integrator key is obtained from Accusoft.
// Include the ISIS Xpress COM initialization routines
#include "..\\..\\..\\..\\Components\\ActiveX-COM\\Include\\ISISX3_Open.cpp"
BOOL CIsisXpressBasicDlg ::OnInitDialog()
{
     char tempStr[100];

     CDialog::OnInitDialog();

     // Add "About..." menu item to system menu.

     // IDM_ABOUTBOX must be in the system command range.
     ASSERT((IDM_ABOUTBOX & 0xFFF0) == IDM_ABOUTBOX);
     ASSERT(IDM_ABOUTBOX < 0xF000);

     CMenu* pSysMenu = GetSystemMenu(FALSE);
     if (pSysMenu != NULL)
     {
          CString strAboutMenu;
          strAboutMenu.LoadString(IDS_ABOUTBOX);
          if (!strAboutMenu.IsEmpty())
          {
               pSysMenu->AppendMenu(MF_SEPARATOR);
               pSysMenu->AppendMenu(MF_STRING, IDM_ABOUTBOX, strAboutMenu);
          }
     }

     // Set the icon for this dialog. The framework does this automatically
     // when the application's main window is not a dialog
     SetIcon(m_hIcon, TRUE);          // Set big icon
     SetIcon(m_hIcon, FALSE);         // Set small icon

     // Initialize ISISXpress. You must call ISISX_Open before creating the first ISISXpress COM object
     HINSTANCE hDLL = ISISX_Open();

     // Create a ISISXpress class object. The ISISXpress class object
     // automatically creates a ISISXpress COM object.
     ppCISISXpress = new CISISXpress((DWORD)this, 1);
     // The second parameter (1) represents the ID of the ScanXpress COM
     // object. This ID is used to determine which COM object caused an
     // event when more than one ScanXpress COM objects are used in an application.

     // Get the pointer to the created ISISXpress COM object. This is the pointer that
     // you will use to access ISISXpress properties and methods.
     pISISXpr = ppCISISXpress->pISISXpress;

     pISISXpr->SetSolutionKey(1234,1234,1234,1234);

     // Initialize the ISISXpress event handlers
     if (ppCISISXpress)
     {
          ppCISISXpress->SetFeederEmptyEvent(FeederEmpty);
          ppCISISXpress->SetProgressEvent(Progress);
          ppCISISXpress->SetScanningEvent(Scanning);
          ppCISISXpress->SetScannedEvent(Scanned);
     }

     //****Close the ISISXpress initialization. You must call this AFTER creating the first ISISXpress COM object
     ISISX_Close(hDLL);

5. Implement the Event Handlers

An event handler must be implemented for every ISIS Xpress event used in your application. The ISISXpressBasic application uses the FeederEmpty, Progress, Scanning and Scanned events. The implementation of the Scanned event is shown below:

C++ Example Copy Code
HRESULT CIsisXpressBasicDlg::Scanned(DWORD instancePtr, DWORD objID, long PageNumber)
{
     long nElapsedSec;
     double nPagesPerMin;
     time_t nStopTime;
     char tempStr[100];
     long hDIB;

     // Get a pointer to the current application
     CIsisXpressBasicDlg *p = (CIsisXpressBasicDlg *) instancePtr;

     // Get the current time
     time(&nStopTime);
     // Determine how long it took to scan
     nElapsedSec = nStopTime - gStartTime;
     if (nElapsedSec == 0) nElapsedSec = 1;

     // Determine the pages per minute
     nPagesPerMin = (gNumPages * 60) / nElapsedSec;
     sprintf(tempStr, "%3.2f", nPagesPerMin);

     // Display the pages per minute
     p->SetDlgItemText(IDC_LBL_PAGESPERMIN, tempStr);

     // Display the scanned image
     if (p->pISISXpr->CreateDib)
     {
          hDIB = p->pISISXpr->hDib;
          p->DisplayDib(hDIB);
     }

     return S_OK;
}

The objID parameter passed into the event functions can be used to determine what COM object caused the event. The following code illustrates this:

C++ Example Copy Code
CIsisXpressBasicDlg *p = (CIsisXpressBasicDlg *) instancePtr;
 if (objID == p->ppISISXpressBasic->m_objID)
{
     // We know that the ppISISXpressBasic object caused the event
}

6. Use the ISIS Xpress COM Object to Set Properties and Call Methods

After an instance of the ISIS Xpress COM object is created, the object can be used to set ISIS Xpress properties and call ISIS® Xpress methods. In the ISISXpressBasic project, this is illustrated in the OnCmdScansingle function shown below. This function is called when the user clicks the Scan Single button.

C++ Example Copy Code
void CIsisXpressBasicDlg::OnCmdScansingle()
{
     ::SetWindowPos((HWND)m_ix.GetHWnd(), HWND_TOP, 0, 0, rImg.right, rImg.bottom, SWP_NOMOVE | SWP_SHOWWINDOW);

     try
     {
          // Update the controls in the application
          if (UpdatePrgm() == FALSE) return;

          // Enable/Disable command buttons
          ::EnableWindow(::GetDlgItem(m_hWnd, IDC_CMD_SCANBATCH), FALSE);
          ::EnableWindow(::GetDlgItem(m_hWnd, IDC_CMD_SCANSINGLE), FALSE);
          ::EnableWindow(::GetDlgItem(m_hWnd, IDC_CMD_CANCEL), TRUE);
          SetDlgItemText(IDC_LBL_PAGESPERMIN, "0.00");

          // Call the ScanSingle method in the ISIS® Xpress COM object
          pISISXpr->ScanSingle();

          // Reset the progress control
          SendDlgItemMessage(IDC_PB, PBM_SETPOS, 0, 0);

          ::EnableWindow(::GetDlgItem(m_hWnd, IDC_CMD_SCANBATCH), TRUE);
          ::EnableWindow(::GetDlgItem(m_hWnd, IDC_CMD_SCANSINGLE), TRUE);
          ::EnableWindow(::GetDlgItem(m_hWnd, IDC_CMD_CANCEL), FALSE);
     }
     catch(_com_error &e)
     {
          // Handle any exceptions caused by the ISIS® Xpress object
          ::EnableWindow(::GetDlgItem(m_hWnd, IDC_CMD_SCANBATCH), TRUE);
          ::EnableWindow(::GetDlgItem(m_hWnd, IDC_CMD_SCANSINGLE), TRUE);
          ::EnableWindow(::GetDlgItem(m_hWnd, IDC_CMD_CANCEL), FALSE); HandleError( e );
      }
}

7. Delete the ISIS Xpress COM Object

The ISIS Xpress COM object must be deleted when it is no longer needed. The ISIS Xpress COM object is usually deleted before the application exits. In the ISISXpressBasic project, the COM object is deleted in the ISISXpressBasicDlg.cpp file as follows:

C++ Example Copy Code
void CIsisXpressBasicDlg::OnDestroy()
{
      CDialog::OnDestroy();

      // Clean up the ISISXpress COM object
      pISISXpr = NULL;

      if (ppCISISXpress)
          delete ppCISISXpress;
}


Use ISIS Xpress as an ActiveX Control

Accusoft.ISISXpress5.ActiveX
Use ISIS Xpress as an ActiveX Control
Send Feedback
ISIS Xpress 5 for ActiveX - User Guide > Getting Started > Use ISIS Xpress as an ActiveX Control

Glossary Item Box

ISIS Xpress can be used as an ATL COM ActiveX control in development environments, like Visual Basic, that accept ActiveX controls. The following discussion assumes that your development environment is Visual Basic.

Creating an Application with Visual Basic and ISIS Xpress

  1. Adding the ISIS Xpress control to a project.
  2. Using the ISIS Xpress control on a form.
  3. Writing code that controls the ISIS Xpress properties and methods.

Loading the ISIS Xpress Control Involves Adding it to a Project

  1. Open the project that will use the ISIS Xpress control. This can be a new or existing project.
  2. From the Project menu, choose Components. The Control window appears with a list of available controls.
  3. Select the Accusoft control (i.e., ISISXpress). Click the OK button.

Other Environments

The ISIS Xpress control is supported by a variety of host environments. To use ISIS Xpress in other environments, consult the development tool's documentation for information on how to use ActiveX controls. As soon as the control is loaded, the following things happen:
  1. The control becomes part of the current project.
  2. A new tool is added to the Toolbox. This tool is used to draw the ISIS Xpress control on the form.
The new control can now be used as if it were a standard control. The ISIS Xpress control has its own set of properties and methods which can be seen by using the Properties and Code windows.


Upgrading from ISIS Xpress 4 to ISIS Xpress 5

Accusoft.ISISXpress5.ActiveX
Upgrading from ISIS Xpress 4 to ISIS Xpress 5
Send Feedback
ISIS Xpress 5 for ActiveX - User Guide > Getting Started > Upgrading from ISIS Xpress 4 to ISIS Xpress 5

Glossary Item Box

This section describes how to upgrade from ISIS Xpress 4 to ISIS Xpress 5. While generally you'll be able to replace ISIS Xpress 4 with ISIS Xpress 5, there are a few important changes you may need to consider. This section provides information about those changes.

Library Name, GUID, and ProgID

  • The library name has changed from AccusoftISISXpress4 to AccusoftISISXpress5.
  • The GUID for the ISISXpress ActiveX control has changed in ISIS Xpress 4 from { 4C55B887-6097-4f86-B9C4-280B8CF76E6C} to the new value in ISIS Xpress 5 of { 524C3414-F923-43d5-9E5B-2BECAF728340}.
  • The ProgID has changed from ‘Accusoft.ISISXpress.4’ to ‘Accusoft.ISISXpress.5’ in ISIS Xpress 5.

Changes and New Properties/Methods

  • Added the Version property, which provides the ability to return the version/build number programmatically.
  • Added Accusoft's new licensing structure. See Licensing for information about the new licensing, and Upgrading Runtime Licensing for information about updating your licensing from an earlier version of ISIS Xpress.

If you encounter any porting issues, please contact support@accusoft.com for assistance.


Upgrading Runtime Licensing

Accusoft.ISISXpress5.ActiveX
Upgrading Runtime Licensing
Send Feedback
ISIS Xpress 5 for ActiveX - User Guide > Getting Started > Upgrading Runtime Licensing

Glossary Item Box

This section describes how to upgrade to Accusoft's new Runtime Licensing.

Prior to ISIS Xpress 5, runtime licensing was accomplished using the UnlockRuntime method.

In ISIS Xpress 5, the default licensing model is Automatically Reported Runtime Licensing. However, based on your contracted usage of this software, you may be eligible for Manually Reported Runtime Licensing. Your Accusoft Sales Representative (sales@accusoft.com) can help you determine which model is appropriate.

Refer to the following sections for information about upgrading to the new Runtime Licensing models:

  • Upgrading to Automatically Reported Runtime Licensing
  • Upgrading to Manually Reported Runtime Licensing

Upgrading to Automatically Reported Runtime Licensing

Automatically Reported Runtime Licensing requires a license to be installed on the end-user's machine. See the Licensing section for more information.

In your ISIS Xpress 4 codebase, find any existing calls to the UnlockRuntime or UnlockWeb method.

C++ Copy Code
 IsisXpress1->UnlockRuntime(12345,12345,12345,12345);
VB6 Copy Code
 IsisXpress1.UnlockRuntime 12345,12345,12345,12345
JavaScript Copy Code
IsisXpress1.UnlockWeb("ServerLicenseString…");

In your ISIS Xpress 5 codebase, replace the UnlockRuntime or UnlockWeb method with calls to the SetSolutionName and SetSolutionKey methods.

C++ Copy Code
 IsisXpress1->SetSolutionName("YourSolutionName");
 IsisXpress1->SetSolutionKey(12345,12345,12345,12345);
VB6 Copy Code
 IsisXpress1.SetSolutionName "YourSolutionName"
 IsisXpress1.SetSolutionKey 12345,12345,12345,12345
JavaScript Copy Code
IsisXpress1.SetSolutionName("YourSolutionName");
IsisXpress1.SetSolutionKey(12345,12345,12345,12345);

Upgrading to Manually Reported Runtime Licensing

In your ISIS Xpress 4 codebase, find any existing calls to the UnlockRuntime or UnlockWeb method.

C++ Copy Code
 IsisXpress1->UnlockRuntime(12345,12345,12345,12345);
VB6 Copy Code
 IsisXpress1.UnlockRuntime 12345,12345,12345,12345
JavaScript Copy Code
IsisXpress1.UnlockWeb("ServerLicenseString…");

In your ISIS Xpress 5 codebase, replace the UnlockRuntime or UnlockWeb method with calls to the SetSolutionName, SetSolutionKey, and SetOEMLicenseKey methods.

C++ Copy Code
 IsisXpress1->SetSolutionName("YourSolutionName");
 IsisXpress1->SetSolutionKey(12345,12345,12345,12345);
 IsisXpress1->SetOEMLicenseKey("1.0.AStringForOEMLicensing…");
VB6 Copy Code
 IsisXpress1.SetSolutionName "YourSolutionName"
 IsisXpress1.SetSolutionKey 12345,12345,12345,12345
 IsisXpress1.SetOEMLicenseKey "1.0.AStringForOEMLicensing…"
JavaScript Copy Code
IsisXpress1.SetSolutionName("YourSolutionName");
IsisXpress1.SetSolutionKey(12345,12345,12345,12345);
IsisXpress1.SetOEMLicenseKey("1.0.AStringForOEMLicensing…");

There is no longer a separate method for web licensing. That functionality has been integrated into the SetOEMLicenseKey method.

If you encounter any porting issues, please contact support@accusoft.com for assistance.


Licensing

Accusoft.ISISXpress5.ActiveX
Licensing
See Also Send Feedback
ISIS Xpress 5 for ActiveX - User Guide > Licensing

Glossary Item Box

Accusoft has introduced a new licensing structure, which provides the following benefits:

  • Toolkit Licensing (also known as Developer or SDK licensing) has been simplified, no longer requiring manual entry of license registration codes.
  • Runtime Licensing (also known as Deployment licensing) has been made more flexible, enabling support for a number of different deployment scenarios.

During evaluation of Accusoft products, Evaluation Toolkit licenses can be used to try out products. However, the product behavior is limited by trial dialog pop-ups or timeouts.

Accusoft requires customers to purchase licenses for both development and deployment.

  • Development/Toolkit Licensing: When you determine the product is a good fit, you can purchase a Toolkit license to eliminate trial dialog pop-ups and timeouts while you develop your application.
  • Deployment/Runtime Licensing: Once you have an application that is ready for distribution, you have several options for deployment. Your own deployment scenario will dictate which option is the most appropriate. There are also cost considerations for each licensing model; see the product's "pricing" page or speak with an Accusoft Sales Representative (sales@accusoft.com) for more information.
    • Manually Reported Runtime Licensing: In this model, you embed all of the licensing information directly into your application. You must manually provide royalty reporting to Accusoft for the actual licenses deployed. This model will be the best choice for you if you are not connected to the Internet at runtime, as might be the case in an defense or financial application.
    • Automatically Reported Runtime Licensing using the Server Licensing Utility (SLU): In this model, you run a small GUI tool one time on each deployment target to configure licensing. This model will be the best choice for you if you handle the deployments yourself.
    • Automatically Reported Runtime Licensing using the Licensing Development Kit (LDK): In this model, you embed function calls into your application that perform the license verification at runtime. This model will be the best choice for you if you wish to hide licensing from your end users.

See Also

Licensing Glossary


Evaluation Licensing

Accusoft.ISISXpress5.ActiveX
Evaluation Licensing
Send Feedback
ISIS Xpress 5 for ActiveX - User Guide > Licensing > Evaluation Licensing

Glossary Item Box

During evaluation of Accusoft products, Evaluation Toolkit licenses can be used to try out products. However, the product behavior is limited by trial dialog pop-ups or timeouts. When you determine the product is a good fit, you can purchase a Toolkit license to eliminate trial dialog pop-ups and timeouts.

An evaluation dialog similar to the following is displayed when you have a valid evaluation license.

However, if you attempt to execute a function that is not licensed in the edition license you are using (e.g., if you have a paid license for ImagXpress Standard and attempt to execute a function available only in ImagXpress Professional), an evaluation dialog similar to the following is displayed.

If no license is found in the registry, an evaluation dialog similar to the following will be displayed.


Toolkit Licensing

Accusoft.ISISXpress5.ActiveX
Toolkit Licensing
Send Feedback
ISIS Xpress 5 for ActiveX - User Guide > Licensing > Toolkit Licensing

Glossary Item Box

Accusoft requires customers who are developing code that uses Accusoft components to have a Toolkit license for each developer.

This section provides information about the following:

  • Assigned Toolkit License
  • License Manager
  • Product Editions
  • Registration
    • Registering When Connected to the Internet
    • Registering When Disconnected from the Internet
  • Developing Code


Assigned Toolkit License

Accusoft.ISISXpress5.ActiveX
Assigned Toolkit License
Send Feedback
ISIS Xpress 5 for ActiveX - User Guide > Licensing > Toolkit Licensing > Assigned Toolkit License

Glossary Item Box

When licenses are purchased for developers at an organization, a representative is designated to assign the licenses to developers at the organization. Each developer must create an account on Accusoft’s website prior to the assignment of licenses. The organization’s designated representative may request that licenses be reassigned as a result of personnel changes.


License Manager

Accusoft.ISISXpress5.ActiveX
License Manager
Send Feedback
ISIS Xpress 5 for ActiveX - User Guide > Licensing > Toolkit Licensing > License Manager

Glossary Item Box

The License Manager is a GUI application that is used by a developer to register and activate Toolkit licenses on their development system. When a paid Toolkit license is registered, the License Manager:

  • Communicates the developer credentials and the hardware information for the development system to the licensing web service.
  • Installs the returned license key on that system.

Activation involves choosing a Toolkit license, either evaluation or paid, so that the license is active on the system.


Product Editions

Accusoft.ISISXpress5.ActiveX
Product Editions
Send Feedback
ISIS Xpress 5 for ActiveX - User Guide > Licensing > Toolkit Licensing > Product Editions

Glossary Item Box

Accusoft products may have multiple editions, each of which supports different features. Products that support multiple editions are installed with multiple evaluation Toolkit licenses, one evaluation Toolkit license per edition.

Selecting An Edition (Activating a Toolkit License)

Evaluation licenses allow developers to try features in different product editions. Since each license supports only a single edition of a product, the developer can switch between editions by activating the corresponding Toolkit license, either purchased or evaluation, using the License Manager.

When a customer downloads an evaluation Toolkit, the evaluation Toolkit license for the edition with the most features is installed by default. However, the developer may run the License Manager to change the Toolkit license to a lower edition in order to determine if that edition will serve their needs.

If a customer has purchased multiple editions of the same product, they may install both editions on a development system, but only one edition may be active at a time. Once a license has been activated for a particular system, it may be deactivated (replaced by activating another edition) or reactivated at any time. Similarly, customers who own a lower featured edition may activate a higher featured edition evaluation Toolkit license and then switch back to their paid, lower-featured Toolkit edition license at any time. For example, you can go from a paid Standard edition to an evaluation Professional edition by activating the Professional edition evaluation Toolkit license.


Registration

Accusoft.ISISXpress5.ActiveX
Registration
Send Feedback
ISIS Xpress 5 for ActiveX - User Guide > Licensing > Toolkit Licensing > Registration

Glossary Item Box

Registration is the process of creating a paid Toolkit license key for a particular system. Registration for Toolkit licenses is always done through the License Manager. This enables the features for the purchased edition to operate without nag dialogs or timeouts. Registration for each license is only required to be performed once per development system. After a license has been registered on a system, you can use the license without further interaction with the License Manager.

Also refer to the following sections:

  • Registering When Connected to the Internet
  • Registering When Disconnected from the Internet


Registering When Connected to the Internet

Accusoft.ISISXpress5.ActiveX
Registering When Connected to the Internet
Send Feedback
ISIS Xpress 5 for ActiveX - User Guide > Licensing > Toolkit Licensing > Registration > Registering When Connected to the Internet

Glossary Item Box

When the development system is connected to the Internet, registration is a fairly simple process.

  1. Start the License Manager.
  2. When prompted, enter your Accusoft login and password.

    The License Manager then displays the available evaluation and purchased licenses assigned to you.

  3. Select a toolkit and click the link to activate the license for that toolkit.

    The License Manager then requests a new license key from the licensing web service and installs it; this completes the registration process.

    If the selected license cannot be installed on the development system due to connection failures or other reasons, a temporary, 15 day "grace" license is installed so as not to interrupt development while a new license is obtained for the development system.


Registering When Disconnected from the Internet

Accusoft.ISISXpress5.ActiveX
Registering When Disconnected from the Internet
Send Feedback
ISIS Xpress 5 for ActiveX - User Guide > Licensing > Toolkit Licensing > Registration > Registering When Disconnected from the Internet

Glossary Item Box

When the development system is not connected to the Internet during registration, as is the case in some defense or financial institutions, registration is only slightly less simple.

  1. Run the License Manager and attempt to log in.
    The License Manager detects that the system is not registered and displays the following dialog:

  2. Select the Install Offline option to begin the offline registration process.

  3. Copy the URL to removable media, such as a thumb drive.

  4. Take the thumb drive to a system that is connected to the Internet.
  5. From the connected system, paste the URL into a browser, which automatically displays the toolkits available.
  6. Upon selecting a toolkit, a license is generated, which you then save to the removable media device.
  7. Return to the offline system where the new license is to be installed.
  8. Use the License Manager to browse to the file and install the Toolkit license.


Developing Code

Accusoft.ISISXpress5.ActiveX
Developing Code
Send Feedback
ISIS Xpress 5 for ActiveX - User Guide > Licensing > Toolkit Licensing > Developing Code

Glossary Item Box

Once an evaluation or paid Toolkit license has been activated on the development system, no additional code is required to use the Accusoft products on this system. If moving the resulting executable code to a new system, you will need to install Toolkit licenses or incorporate Runtime licenses into your code.


Runtime Licensing

Accusoft.ISISXpress5.ActiveX
Runtime Licensing
Send Feedback
ISIS Xpress 5 for ActiveX - User Guide > Licensing > Runtime Licensing

Glossary Item Box

When an application that uses one or more Accusoft products is deployed, it requires a Runtime License for each installation. There are two main types of Runtime Licenses:

  • Automatically Reported. Distribution of Automatically Reported Runtime licenses is handled automatically through the use of licensing software components and web services.
  • Manually Reported. Manually Reported Runtime licensing requires you to provide the number of licenses distributed on a contractually agreed upon basis.
  • ActiveX Website Runtime Licensing. Using an Accusoft ActiveX on a webpage is similar to Manually Reported Runtime (Non-Node-Locked), as it requires calls to SetSolutionName, SetSolutionKey, and SetOEMLicenseKey. However, the web licenses are not node-locked to particular hardware but are node-locked to a set of specific domains or sub-domains.

These licensing types are each described in detail in the following sections:

  • Automatically Reported Runtime (Node-Locked)
    • Licensing API
    • License Pools
    • License Configuration Files
    • LDK vs. SLU
      • Server Licensing Utility (SLU)
      • Licensing Development Kit (LDK)
    • Deployment Proxy Service (DPS)
  • Manually Reported Runtime (Non-Node-Locked)
    • Solution Name
    • Solution Key
    • OEM License Key
  • ActiveX Website Runtime Licensing
If you are upgrading from an earlier version of ISIS Xpress, please see the Upgrading Runtime Licensing section for important information.


Automatically Reported Runtime (Node-Locked)

Accusoft.ISISXpress5.ActiveX
Automatically Reported Runtime (Node-Locked)
Send Feedback
ISIS Xpress 5 for ActiveX - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked)

Glossary Item Box

Automatically Reported Runtime licenses use a mechanism similar to Toolkit licensing to activate a license for a particular system. In this case, each installation has a unique license that is pulled from the pool of licenses purchased by the customer. When the license key is generated, it contains hardware information that identifies the system on which the license is to be installed.

The Licensing Development Kit component, which interacts with the licensing web service and installs the newly generated license key, may be used directly by the application or it may be used through a simple tool known as the Server Licensing Utility.

  • The Licensing Development Kit requires integration with the application or installation utility to perform license activation.
  • The Server Licensing Utility is a stand-alone application that integrates the Licensing Development Kit to perform the registration.

This topic provides information about the following:

  • Licensing API
  • License Pools
  • License Configuration Files
  • LDK vs. SLU
    • Server Licensing Utility (SLU)
    • Licensing Development Kit (LDK)
  • Deployment Proxy Service (DPS)


Licensing API

Accusoft.ISISXpress5.ActiveX
Licensing API
Send Feedback
ISIS Xpress 5 for ActiveX - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > Licensing API

Glossary Item Box

The Licensing API is used in the developer’s code to specify Runtime Licensing deployment information. This is used to unlock the Accusoft products and enable all licensed features at runtime. Both the "Solution Name" and "Solution Key" values used in the API described below are provided by Accusoft, along with the License Configuration file, at the time of purchase of a Runtime License.

Solution Name

The solution name is the name assigned by Accusoft to the licenses purchased for runtime deployment. It is a character string that is set for a component prior to use in a deployment environment and is typically the name of the organization that purchased the runtime licenses. It is set via the SetSolutionName method. For example:

Copy Code
IsisXpress1.SetSolutionName("ACMEImaging");

The Solution Name must be set in order to use runtime licensing.

Solution Key

The Solution Key is a set of four numbers assigned when the licenses are purchased for runtime deployment; the Solution Key also identifies the organization that purchased the runtime licenses. The Solution Key is set via the SetSolutionKey method. For example:

Copy Code
IsisXpress1.SetSolutionName("ACMEImaging");
IsisXpress1.SetSolutionKey(0x1C3A023F, 0xA018F260, 0x37AF0E51, 0x557F2389);

The Solution Key must be set in order to use runtime licensing.


License Pools

Accusoft.ISISXpress5.ActiveX
License Pools
Send Feedback
ISIS Xpress 5 for ActiveX - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > License Pools

Glossary Item Box

When Automatically Reported Runtime licenses are purchased, they are organized into pools of a specific version and platform for a particular toolkit. For example, if a customer developed two applications using ImagXpress, one using 32-bit ActiveX and the other using .NET, they would purchase two pools of runtime licenses, one for the ActiveX platform and one for the .NET platform. At installation, a new license would be pulled from the appropriate pool, depending upon which platform the application is using.


License Configuration Files

Accusoft.ISISXpress5.ActiveX
License Configuration Files
See Also Send Feedback
ISIS Xpress 5 for ActiveX - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > License Configuration Files

Glossary Item Box

When an Automatically Reported Runtime license is purchased, a License Configuration file is created and distributed to the customer along with their assigned Solution Name and Solution Key. The License Configuration file contains information about the Runtime licenses for a particular platform and version of a toolkit. It is used by the Server Licensing Utility or License Development Kit to activate licenses when the customer’s application is installed on their users' systems.

See Also

Licensing API


LDK vs. SLU

Accusoft.ISISXpress5.ActiveX
LDK vs. SLU
Send Feedback
ISIS Xpress 5 for ActiveX - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > LDK vs. SLU

Glossary Item Box

Both the Licensing Deployment Kit and the Server Licensing Utility perform the same function of registering the Runtime license for the system on which it will be run. Both are provided in order to give you some options.

  • If you are deploying to your own systems (e.g., for enterprise IT staff), the use of an Accusoft branded Server Licensing Utility may meet your needs. Similarly, if you handle the deployment onto end users systems, you may also find the Server Licensing Utility to be sufficient.
  • If you wish to hide this licensing registration from end users, you will likely choose the Licensing Deployment Kit, which allows you to integrate the registration process into your application. The Licensing Deployment Kit also allows for the optional assignment of Access Keys to specific users, which lets you manage your licenses more directly and limits the distribution of licenses.


Server Licensing Utility (SLU)

Accusoft.ISISXpress5.ActiveX
Server Licensing Utility (SLU)
Send Feedback
ISIS Xpress 5 for ActiveX - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > LDK vs. SLU > Server Licensing Utility (SLU)

Glossary Item Box

The Server Licensing Utility is a simple Windows application that uses License Configuration Files to request a license key from the purchased Runtime licenses. The Server Licensing Utility registers that Runtime license on the system where your application will be running. This utility can be used by developers for testing, by your deployment team, or by your end users to register their Runtime license.

In the Server Licensing Utility dialog, add your License Configuration file(s) as follows:

  1. Click Add and navigate to your License Configuration file(s).
  2. Select the appropriate License Configuration file(s) and click Open.
  3. After all applicable License Configuration files have been added, click Auto Register or Manually Register, depending on whether or not you are connected to the Internet. Refer to the sections below for more information.

Auto Register Toolkit (Connected to Internet)

Automatic registration works in much the same way as connected Toolkit registration and requires an Internet connection on the system where your application software will be deployed. The license information along with the system’s hardware information is sent over the Internet to the Accusoft licensing web service. If an unused license is available, a new license key containing information for the system is generated, returned, and is then automatically installed by the Server Licensing Utility.

Manually Register Toolkit (Disconnected from Internet)

Manual registration is used when the system where your application software will be deployed is not connected to the Internet and therefore cannot be registered automatically. This operation is similar to Disconnected Registration with the License Manager.

  1. Copy the Hardware Key and URL to a removable media device, such as a thumb drive, and then take it to a system that is connected to the Internet.
  2. From the connected system, paste the URL into a browser. A page will appear that contains a field into which you enter the hardware key.
  3. After this hardware key is entered, a license file with the license key is downloaded, which you then save to the removable media device.
  4. Return to the offline system with the removable media device onto which you have saved the license file.
  5. Click Open License File and navigate to the license file. Click OK in the file selection dialog.
    Alternatively, you can open the license file with a text editor, copy the license key to the clipboard, and click Paste License Key to paste the new license key into the License Key field.
  6. Click the License button; the new license will be installed.


Licensing Development Kit (LDK)

Accusoft.ISISXpress5.ActiveX
Licensing Development Kit (LDK)
Send Feedback
ISIS Xpress 5 for ActiveX - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > LDK vs. SLU > Licensing Development Kit (LDK)

Glossary Item Box

The Licensing Development Kit is an ActiveX component that may be used instead of the Server Licensing Utility. (Actually, the Server Licensing Utility is only a user interface for the Licensing Development Kit.) The Licensing Development Kit provides an interface for a developer to set the License Configuration File path and other properties as well as initiate requests to the licensing web service to generate license keys.

This topic contains these sections:

  • AccuLicClient.DLL
  • Assigned Access Keys
  • Automatic (Connected) Mode Registration
  • Manual (Disconnected) Mode Registration
  • Evaluation
  • Licensing Development Kit Interface
  • Licensing Development Kit Properties
  • Licensing Development Kit Methods

AccuLicClient.DLL

The AccuLicClient.DLL is located with the Server Licensing Utility. It is a 32-bit ActiveX/COM DLL which is used to execute runtime licensing activation functions. The bulk of the functionality provided by the Server Licensing Utility (SLU) is contained within the AccuLicClient.DLL and can be used within your own custom applications to achieve the same thing.

Assigned Access Keys

Unlike the Server Licensing Utility, the Licensing Development Kit allows for the optional assignment of Access Keys to specific users. By doing this, you can specify which of your licenses are assigned to your users. This also limits the distribution of licenses. When Runtime licenses are purchased, a list of Access Keys is distributed to you for this use.

Automatic (Connected) Mode Registration

This mode corresponds to the Automatic (Connected) Registration section described in the Server Licensing Utility section. The process is shown in the C# sample code below:

Copy Code
// Instantiate the LDK ActiveX component
IDeploymentComponent ldk = new DeploymentComponent();

// Set the path to the configuration file provided
// when the runtime licenses were purchased.
ldk.ConfigPath = @"C:\config.txt";

// Attempt to get the next available license.
// Note that you may alternately pass an Access Key
ldk.GetLicKeyAuto("");

if (ldk.ResultCode != enumLdkErrorCodes.LDK_SUCCESS)
{
    // Automatic Registration Failed - A temporary license
    // has been installed but will expire in 15 days.
    // TODO add code to notify user of issue and 15 day expiration.

    if (ldk.ResultCode == enumLdkErrorCodes.LDK_ERR_INET_CONN_BROKEN)
    {
        // No Internet Connection – Optionally do manual registration
    }
}
else
{
    // The license has been registered and installed.
}

The registration process is then complete. If any part of the registration process fails, a temporary license key is installed and is typically valid for 15 days. During this time, you are allowed to use the product while resolving any licensing related problems.

Manual (Disconnected) Mode Registration

This mode corresponds to the Manual (Disconnected) Registration section described in the Server Licensing Utility section. The process is shown in the C# code below:

Copy Code
// Instantiate the LDK ActiveX component
IDeploymentComponent ldk = new DeploymentComponent();

// Set the path to the configuration file provided
// when the runtime licenses were purchased.
ldk.ConfigPath = @"C:\config.txt";

// Get the hardware key for the system.  Note
// that you may alternately pass an Access Key
string hardwareKey = ldk.GetHdwKey("");

// Write the hardware key to some type of removable media.
ApplicationSpecificMethodToWriteHardwareKey(hardwareKey);

At this point, you have the hardware key on some type of removable media. Take the media to a system that is connected to the Internet, acquire the license key by uploading the hardware key, write the new license key to the removable media, and then return to the disconnected system. The application then reads the license key from the removable media and installs the license key as shown below.

Copy Code
// After taking the hardware key to a system with an Internet
// connection and acquiring the license key string from the
// manual registration web site, read the key into your
// application.
string manuallyAcquiredLicenseKey = ApplicationSpecificMethodToReadLicenseKey();

// Install the license key
ldk.LicKey = manuallyAcquiredLicenseKey;

The manual license registration and installation is then complete. Like the automatic case above, if any error occurs during the setting of the license key, a temporary license is installed.

Evaluation

The Licensing Development Kit also has the ability to install an Evaluation License for purchased runtime products. This process is simply:

Copy Code
// Instantiate the LDK ActiveX component
IDeploymentComponent ldk = new DeploymentComponent();

// Set the path to the configuration file provided
// when the runtime licenses were purchased.
ldk.ConfigPath = @"C:\config.txt";

// Install an evaluation license
ldk.StartEvalPeriod();

Licensing Development Kit Interface

The interface to the Licensing Development Kit is shown below:

Copy Code
interface IDeploymentComponent : IDispatch
{
   [propget, id(1)] HRESULT LicKey([out, retval] BSTR* pVal);
   [propput, id(1)] HRESULT LicKey([in] BSTR newVal);
   [propget, id(2)] HRESULT srvURL([out, retval] BSTR* pVal);
   [propput, id(2)] HRESULT srvURL([in] BSTR newVal);
   [propget, id(3)] HRESULT ConfigPath([out, retval] BSTR* pVal);
   [propput, id(3)] HRESULT ConfigPath([in] BSTR newVal);
   [propget, id(4)] HRESULT ResultString([out, retval] BSTR* pVal);
   [propget, id(5)] HRESULT ResultCode([out, retval] enumLdkErrorCodes* pVal);
   [id(6)]           HRESULT GetLicKeyAuto([in] BSTR accKey);
   [id(7)]           HRESULT GetHdwKey([in] BSTR accKey, [out,retval] BSTR* hdwKey);
   [id(8)]           HRESULT StartEvalPeriod(void);
   [propget]         HRESULT LicenseInfo([out, retval] BSTR* pVal);
   [propput]         HRESULT LicenseInfo([in] BSTR newVal);
   [id(10)]          HRESULT GetEvalPeriod([out, retval] long* pVal);
};

Licensing Development Kit Properties

  • LicKey: Stores the License Key to the registry when it is set, and reads it from the registry during the get operation.
  • srvURL: Gets and sets the URL path to the licensing web service. The default is the URL path to Accusoft’s Deployment Licensing Service.
  • ConfigPath: Gets and sets a path to the deployment configuration file. Multiple products can be registered at one time by setting the filenames as a semicolon-delimited list: e.g., “c:\config.txt;c:\config2.txt”.
  • ResultString: Contains the string descriptions of any error that may have occurred during the last operation.
  • ResultCode: Can be used to contain any of the error codes described in Licensing Component Error Codes and Messages.
  • LicenseInfo: Used to transfer license information onto new system hardware. To transfer the license information into new system hardware, do the following:
  1. Get the LicenseInfo value and store it in a safe place.
  2. Change the system hardware.
  3. Set the LicenseInfo to the value you saved in step (1).
  4. Run the GetLicKeyAuto method (or perform its manual analog) to obtain a license for the new system hardware.

Licensing Development Kit Methods

  • GetLicKeyAuto: Obtains a License Key for the end user’s system using the automatic (or connected) scenario. It takes an Access Key as its input parameter, and stores the obtained license key in the registry. If you choose not to distribute individual Access Keys, the accKey argument should be an empty string.
  • GetHdwKey: Obtains a hardware key from the current machine and returns it (as hdwKey). If you choose not to distribute individual access keys, the accKey argument should be an empty string.
  • StartEvalPeriod: Sets an evaluation licensing mode for the product and starts an evaluation period. This method is provided so you can distribute an evaluation version of your application, without having to distribute Access Keys to people who would like to evaluate your software. Using this method you can license Accusoft components on the end user’s system for a limited time – the default is 30 days, but it can be customized per request to Accusoft. If the evaluators purchase your software, you can then issue them an access key using either the automatic or manual scenarios to obtain permanent component licenses, just as Accusoft does for its evaluators.
  • GetEvalPeriod: Obtains the remaining time on an evaluation (in days). It returns EvalPeriod < 0 if the evaluation period is expired.


Deployment Proxy Service (DPS)

Accusoft.ISISXpress5.ActiveX
Deployment Proxy Service (DPS)
Send Feedback
ISIS Xpress 5 for ActiveX - User Guide > Licensing > Runtime Licensing > Automatically Reported Runtime (Node-Locked) > Deployment Proxy Service (DPS)

Glossary Item Box

For systems where the deployed application will not have direct access to the Accusoft licensing web services, you can use the Deployment Proxy Service as a bridge to reroute the licensing communication. The Proxy Service will act as a trusted "go-between" for the Accusoft licensing system and the deployed application. This tool can be useful if the application will be deployed in a secured environment, where limited systems have external network access.

Additionally, the Proxy Service allows Accusoft customers to manage license registration more directly. The source for the Deployment Proxy Service is provided, allowing users to integrate the licensing process into their CRM, ERP, or other systems for tracking Automatically Reported Runtime Licenses.

For more information about the Deployment Proxy Service, please contact our Support team.


Manually Reported Runtime (Non-Node-Locked)

Accusoft.ISISXpress5.ActiveX
Manually Reported Runtime (Non-Node-Locked)
Send Feedback
ISIS Xpress 5 for ActiveX - User Guide > Licensing > Runtime Licensing > Manually Reported Runtime (Non-Node-Locked)

Glossary Item Box

Manually Reported Runtime licensing embeds all of the licensing information directly into your application. Installation does not require any further licensing interaction. However, it is your responsibility to provide royalty reporting to Accusoft for the actual licenses deployed.

This section provides information about the following:

  • Solution Name
  • Solution Key
  • OEM License Key


Solution Name

Accusoft.ISISXpress5.ActiveX
Solution Name
Send Feedback
ISIS Xpress 5 for ActiveX - User Guide > Licensing > Runtime Licensing > Manually Reported Runtime (Non-Node-Locked) > Solution Name

Glossary Item Box

The solution name is

  • A name assigned by Accusoft to the licenses purchased for runtime deployment.
  • A character string that is set for a component prior to use in a deployment environment.
  • Typically the name of the organization that purchased the runtime licenses. It is set via the SetSolutionName method. For example:
Copy Code
IsisXpress1.SetSolutionName("ACMEImaging");

The Solution Name must be set in order to use runtime licensing.


Solution Key

Accusoft.ISISXpress5.ActiveX
Solution Key
Send Feedback
ISIS Xpress 5 for ActiveX - User Guide > Licensing > Runtime Licensing > Manually Reported Runtime (Non-Node-Locked) > Solution Key

Glossary Item Box

The Solution Key is

  • A set of four numbers assigned when the licenses are purchased for runtime deployment.
  • Identifies the organization that purchased the runtime licenses.
  • Set via the SetSolutionKey method. For example:
Copy Code
IsisXpress1.SetSolutionName("ACMEImaging");
IsisXpress1.SetSolutionKey(0x1C3A023F, 0xA018F260, 0x37AF0E51, 0x557F2389);

The Solution Key must be set in order to use runtime licensing.


OEM License Key

Accusoft.ISISXpress5.ActiveX
OEM License Key
Send Feedback
ISIS Xpress 5 for ActiveX - User Guide > Licensing > Runtime Licensing > Manually Reported Runtime (Non-Node-Locked) > OEM License Key

Glossary Item Box

The OEMLicense Key is

  • For use only by customers who choose to use Manually Reported Runtime licensing.
  • A unique identifier of the customer, product, version, edition, and platforms for which the license is valid.

When this key is set via the SetOEMLicenseKey method, the component is completely licensed and can be distributed without any further licensing operations.

Copy Code
IsisXpress1.SetSolutionName("ACMEImaging");
IsisXpress1.SetSolutionKey(0x1C3A023F, 0xA018F260, 0x37AF0E51, 0x557F2389);
IsisXpress1.SetOEMLicenseKey("1.0.GQCC0EmUgONaI4QDZ32tpGWfpGW4gtbC0iIC0iN4bigYM3m3K5b487QOsAM38O24mUp5bOpD2O240OQ32U2YsUKDKA87MYPGgGgaptMiK5Nv8AI4mYg4m3QvW52DZCPGs4p784mtP4IUgOWiIG0AQYp4052iIAWvNCZfpGWC8vQ5P4ZGKaPAWfbiYfZOI303pOZAgisiNaWA27gGsf8Ob7Zvm5IaKGI4KC8GsG2CWYpGQAg5sUmYWvZCQANig48G2ap4bG0DsO240YsUmtptNiZamCPGbYMfMO83gANAZCN52YbY8U8f8DM4m3g7MYMYWGW5Q7QGWaMiN7MtZfmtgY8AN7NDP7Z4W7sCbGKUPa0im7EDPP");

This property is not required for Automatically Reported Runtime licensing.


ActiveX Website Runtime Licensing

Accusoft.ISISXpress5.ActiveX
ActiveX Website Runtime Licensing
Send Feedback
ISIS Xpress 5 for ActiveX - User Guide > Licensing > Runtime Licensing > ActiveX Website Runtime Licensing

Glossary Item Box

Using an Accusoft ActiveX on a webpage is similar to Manually Reported Runtime (Non-Node-Locked), as it requires calls to SetSolutionName, SetSolutionKey, and SetOEMLicenseKey. However, the web licenses are not node-locked to particular hardware but are node-locked to a set of specific domains or sub-domains. Sub-paths of those domains and sub-domains do not require additional licensing, thus if http://www.mysite.com is licensed, so is http://www.mysite.com/imaging.

To get an OEM license key, the developer will identify one or more domains or sub-domains to Accusoft's Licensing Center. There is an ActiveX web licensing site that contains the OEM License Generator web application. This web application is used to create an OEM license key that the developer can use along with the solution name and solution key on the webpage in the domain or sub-domain.

Example

In the following example:

  • The solution name is "ACMEImaging"
  • The solution keys are "0x1C3A023F, 0xA018F260, 0x37AF0E51, 0x557F2389"
  • The domain specified is www.mysite.com

The developer would do the following:

  1. Log into Accusoft’s Licensing Center.
  2. Use the OEM License Generator web application to retrieve an OEM license key for www.mysite.com.
  3. Use the OEM license key on a webpage in the www.mysite.com domain.
Copy Code
IsisXpress1.SetSolutionName "ACMEImaging"
IsisXpress1.SetSolutionKey 0x1C3A023F, 0xA018F260, 0x37AF0E51, 0x557F2389
IsisXpress1.SetOEMLicenseKey
"1.0.GQCC0EmUgONaI4QDZ32tpGWfpGW4gtbC0iIC0iN4bigYM3m3K5b487QOsAM38O24mUp5bOpD2O240OQ32U2YsUKDKA87MYPGgGgaptMiK5Nv8AI4mYg4m3QvW52DZCPGs4p784mtP4IUgOWiIG0AQYp4052iIAWvNCZfpGWC8vQ5P4ZGKaPAWfbiYfZOI303pOZAgisiNaWA27gGsf8Ob7Zvm5IaKGI4KC8GsG2CWYpGQAg5sUmYWvZCQANig48G2ap4bG0DsO240YsUmtptNiZamCPGbYMfMO83gANAZCN52YbY8U8f8DM4m3g7MYMYWGW5Q7QGWaMiN7MtZfmtgY8AN7NDP7Z4W7sCbGKUPa0im7EDPP"


Licensing Glossary

Accusoft.ISISXpress5.ActiveX
Licensing Glossary
Send Feedback
ISIS Xpress 5 for ActiveX - User Guide > Licensing > Licensing Glossary

Glossary Item Box

The following sections each describe a licensing term:

  • Access Key
  • Accusoft Products
  • Activation
  • Assigned Access Key
  • Automatically Reported Runtime Licensing
  • Customers, Developers, and Users
  • Edition
  • Evaluation License
  • Hardware Key
  • License Configuration File
  • Licensing Development Kit (LDK)
  • License Key
  • License Manager
  • Manually Reported Runtime Licensing
  • Node-Locked Licensing
  • Non-Node-Locked Licensing
  • Paid License
  • Registration
  • Runtime (Deployment) Licensing
  • Server Licensing Utility (SLU)
  • Toolkit Licensing
  • Web Services

Access Key

All licenses are assigned a unique identifier known as an Access Key. Access Keys are associated with the organization that purchased the license.

Accusoft Products

An Accusoft product may be licensed with either a Toolkit License or a Runtime License.

Activation

Activation is the process of selecting a previously registered toolkit license. Licenses may be paid (Toolkit) or evaluation, and may be for one of many product editions, for products with multiple editions.

Assigned Access Key

An assigned Access Key is one that is assigned to a specific user or users. The assignment of Access Keys to specific users can be done using the Licensing Development Kit (LDK).

Automatically Reported Runtime Licensing

Runtimes may be licensed in one of two ways: automatic reporting or manual reporting. With automatic reporting, you do not need to worry about royalty reporting; it is handled by the licensing layer.

Customers, Developers, and Users

Customers are simply any person who has purchased an Accusoft product. Developers are customers who possess a license for an Toolkit. Users are typically the customers of Accusoft's customers who use applications built around Accusoft components and are assigned a runtime license.

Edition

Some Accusoft products have multiple editions. Editions may offer multiple levels of product speed or product features, allowing customers to find a price-performance mix that is appropriate for them. Products that support multiple editions register multiple Toolkit licenses at installation time, one Toolkit license per edition. Developers must select an edition to activate using the License Manager.

Evaluation License

An evaluation license is a Toolkit license that is unpaid. When an Accusoft Toolkit is installed, evaluation licenses for all applicable product editions are installed and registered, and the edition with the most features is activated. Evaluation Toolkit licenses can be used to try out products. However, the product behavior is limited by trial dialog pop-ups or timeouts. When you determine the product is a good fit, you can purchase a Toolkit license to eliminate trial dialog pop-ups and timeouts.

Hardware Key

When a license is activated for a product, the system information that identifies the installation hardware is contained within an encrypted string and is used to generate the license key for the product. The string containing the encrypted hardware information is known as the Hardware Key.

License Configuration File

When a Toolkit or an Automatically Reported Runtime license is purchased, a configuration file is provided that contains information about the license that was purchased. This file is used by the licensing utilities (License Manager, Server License Utility, and License Development Kit) to install a license on the system.

Licensing Development Kit (LDK)

The Licensing Development Kit (LDK) is an ActiveX component that may be used for Runtime Licensing. The LDK is one mechanism for Automatically Reported Runtime Licensing; the Server Licensing Utility (SLU) is the other.

License Key

Each product license has a unique key associated with it that uniquely identifies the customer, product, version, edition, and platforms, and, in some cases, the hardware for which the license is valid.

License Manager

The License Manager is a GUI application that is used by a developer to register and activate Toolkit licenses on their development system.

Manually Reported Runtime Licensing

Runtimes may be licensed in one of two ways: automatic reporting or manual reporting. With Manually Reported Runtime Licensing, you embed all of the licensing information directly into your application. You must manually provide royalty reporting to Accusoft for the actual licenses deployed. This model will be the best choice for you if you are not connected to the Internet at runtime, as might be the case in an defense or financial application.

Node-Locked Licensing

Another name for Automatically Reported Runtime Licensing.

Non-Node-Locked Licensing

Another name for Manually Reported Runtime Licensing.

Paid License

A paid license is a Toolkit license that you have purchased from Accusoft. It is ready to be used in production, with no trial dialog pop-ups, timeouts, or evaluation watermarks. If you wish to test other editions of the Accusoft product for which you have purchased a Paid License, you may activate an Evaluation license for that edition; a complete set of Evaluation licenses for all editions is registered at installation time.

Registration

Registration is the process of informing the License Manager about a new Toolkit license you have purchased. It uses this information to create a license key on your system; this allows you to activate the product for development with no restrictions, such as trial dialog pop-ups, timeouts, or evaluation watermarks.

Runtime (Deployment) Licensing

When deploying an application, a Runtime License is also required for each user’s installation. You must purchase runtime licenses, which are consumed as licenses are registered. There are two Runtime licensing models: Automatically Reported Runtime License; and Manually Reported Runtime License.

Server Licensing Utility (SLU)

The Server Licensing Utility (SLU) is a small GUI application that allows you to request a license key from the Runtime licenses you have purchased. The SLU is one mechanism for Automatically Reported Runtime Licensing; the Licensing Development Kit (LDK) is the other.

Toolkit Licensing

Each Toolkit is assigned to a specific developer who has a registered account with Accusoft. When the developer installs the Toolkit, it is not fully functional until they have activated the license through the use of the License Manager application. When the developer starts the License Manager, they are required to provide login credentials that identify and allow them to activate their license on a development system. See Toolkit Licensing.

Web Services

When a license is registered, information that uniquely identifies the customer’s or user’s hardware is passed along with the license information over the Internet to a web service. The web service validates the licensing request, generates a key that includes the hardware information, and returns the new license key to the application that made the licensing request. The license key is then stored on the requested system and used by the component when it is executed. It is also possible to register systems that are not directly connected to the Internet through the use of removable media and a different system that is connected to the Internet.


Software License Agreement

Accusoft.ISISXpress5.ActiveX
Software License Agreement
See Also Send Feedback
ISIS Xpress 5 for ActiveX - User Guide > Licensing > Software License Agreement

Glossary Item Box

PLEASE READ THE FOLLOWING SOFTWARE LICENSE AGREEMENT WHICH GOVERNS YOUR RIGHT TO USE OF THE TOOLKIT. YOU MUST ACCEPT THESE TERMS BEFORE YOU ARE ALLOWED TO INSTALL THE TOOLKIT. YOU EXPRESSLY AGREE THAT YOU HAVE THE AUTHORITY TO CONTRACTUALLY BIND THE ORGANIZATION AGREEING TO THESE TERMS.

BY CLICKING "I ACCEPT," OR INSTALLING TOOLKIT, OR PLACING TOOLKIT IN-USE, LICENSEE IS AGREEING TO BE BOUND BY THIS AGREEMENT.

1. GRANT OF AGREEMENT

This Accusoft Corporation, ("ACCUSOFT") Software License Agreement ("AGREEMENT") grants the organization contracting under this agreement as licensee ("LICENSEE") a limited, nontransferable, nonexclusive and non-assignable license to use the trial mode version of this ACCUSOFT Development Toolkit ("TOOLKIT") on a single computer for evaluation of fitness only and not for any commercial purpose; or to use a properly purchased and registered TOOLKIT, for development purposes only on a single computer, provided the TOOLKIT is IN-USE on only one computer at any time. (However additional TOOLKIT licenses may be purchased.) TOOLKIT is "IN-USE" on a computer when it becomes loaded by any means for any purpose into temporary memory (that is, including but not limited to RAM) or when it becomes copied or installed to less temporary storage by any means for any purpose (that is, including but not limited to hard disk, CD-ROM or other removable disk or tape, USB or other flash memory drive or card, or other local, networked, or cloud storage device) when it is accessible to that computer. The TOOLKIT is explicitly not to be used on a site-wide basis, via a server or other networked connection.

2. REDISTRIBUTION OF TOOLKIT RUNTIMES

ACCUSOFT does not grant LICENSEE any rights to deploy, license, sell, reproduce, copy, install, lease, timeshare, rent, or otherwise distribute or transfer TOOLKIT or any portion of TOOLKIT ("PORTION") except as provided in Section 1. GRANT OF AGREEMENT. For licensing information about any other distribution of TOOLKIT or PORTION, please visit our web site (www.accusoft.com/licensing.htm), or contact our sales staff. LICENSEE agrees to notify ACCUSOFT immediately of any violations or changes in status regarding LICENSEE's compliance with any term of this AGREEMENT.

In the event that ACCUSOFT grants LICENSEE in a written separate runtime license agreement ("RUNTIME AGREEMENT") a right to deploy, license, sell, reproduce, copy, install, lease, timeshare, rent, or otherwise distribute or transfer PORTIONS, the RUNTIME AGREEMENT will specify what PORTIONS may be distributed ("RUNTIME"). LICENSEE agrees to acknowledge and uphold the terms and conditions of this AGREEMENT as well as the terms of the RUNTIME AGREEMENT itself, which will be provided only in writing. In such event, LICENSEE may distribute RUNTIMES as part of the LICENSEE's software application or derivative works ("PRODUCT") upon additionally agreeing to the following:

a) LICENSEE understands and acknowledges that in order to receive any discounted pricing for RUNTIME distribution licensing fees based on the type of installation, it must either: 1) prepay for a number of RUNTIME licenses that is sufficient to qualify for ACCUSOFT's then-current published quantity discount, or 2) it must pay for the licenses in accordance with a written contract between LICENSEE and ACCUSOFT.

b) LICENSEE's PRODUCT shall not compete to any degree with the TOOLKIT. Such competitive PRODUCTS are defined as software development toolkits that include similar functionality as TOOLKIT and that are intended for use by software developers and/or system integrators.

c) LICENSEE's PRODUCT must be substantially greater in scope with greater functionality and features than those of the TOOLKIT.

d) LICENSEE will not use ACCUSOFT's name, logo, or trademarks to market PRODUCT without prior written approval of ACCUSOFT except LICENSEE will include a statement substantially similar to the following within PRODUCT documentation and about box: "Portions of this product contain imaging and other technology owned by Accusoft Corporation, Tampa, FL, (www.accusoft.com). ALL RIGHTS RESERVED." See Section 20. THIRD PARTY NOTICES for additional requirements.

e) LICENSEE agrees to only distribute the RUNTIMES. No license or other rights are granted to LICENSEE for any distribution of the TOOLKIT or PORTIONS including, but not limited to, documentation, source code, or the RUNTIME distribution unlock codes.

g) LICENSEE will only distribute the RUNTIMES on the hardware and operating system(s) for which the RUNTIMES are intended to be used according to the RUNTIME AGREEMENT.

If ANY of the terms of this AGREEMENT are not applicable to LICENSEE'S situation, or if any of the terms of this AGREEMENT cannot be complied with, or if LICENSEE needs modifications to this AGREEMENT or the license granted for any reason, LICENSEE must contact ACCUSOFT about obtaining an expanded license from ACCUSOFT (available by phone at: 813-875-7575, x321, by e-mail at: Sales@accusoft.com or by fax at: 813-875-7705).

This AGREEMENT grants rights to LICENSEE only for the TOOLKIT and does not convey any other rights of use or distribution to ACCUSOFT technology.

3. OWNERSHIP

LICENSEE acknowledges and agrees that ACCUSOFT owns all rights, title and interest in the TOOLKIT, in all forms, including without limitation any and all worldwide proprietary rights therein, including but not limited to trademarks, copyrights, patent rights, patent continuations, trade secrets and confidential information.

LICENSEE may not remove or alter the copyright notice from any copy of the TOOLKIT or any copy of the written materials, accompanying the TOOLKIT.

LICENSEE waives its right to contest any of ACCUSOFT's patents, trademarks, service marks, trade names, copyrights, and other intellectual property and proprietary rights in and to the TOOLKIT.

LICENSEE shall not use such trademarks, service marks, and trade names except where and as permitted under this AGREEMENT without receiving ACCUSOFT's prior written approval of such use. If such approval is granted, LICENSEE’s right to use such trademarks, service marks, and trade names shall end upon the termination of this AGREEMENT.

4. RESTRICTIONS AND RESERVATIONS.

All rights and licenses not expressly granted to LICENSEE are reserved to ACCUSOFT. LICENSEE is strictly prohibited from reproducing, copying, marketing, selling, distributing, licensing, sublicensing, leasing, timesharing or renting the TOOLKIT or PORTION, and LICENSEE is strictly prohibited from any use of the TOOLKIT or PORTION except as permitted by this AGREEMENT, and such actions are expressly prohibited. LICENSEE is strictly prohibited from incorporating or including the TOOLKIT or PORTION into or as part of any PRODUCT or service of LICENSEE except as provided by this AGREEMENT, regardless of the functionality of TOOLKIT (or lack thereof) within or as part of such PRODUCT or service of LICENSEE. LICENSEE shall not for any reason disassemble, decompile, decrypt or reverse engineer the TOOLKIT or PORTION or in any manner attempt to discover or reproduce the source code or any other copyrightable, proprietary, or trade secret aspect of the TOOLKIT or PORTION. Nor shall LICENSEE use the TOOLKIT or PORTION, directly or indirectly, in developing LICENSEE's own PRODUCT with, or including, similar functionality. LICENSEE shall not make any copies of the TOOLKIT or PORTION for any purpose whatsoever except as permitted by this AGREEMENT. Source code that is provided with TOOLKIT for sample or demonstration purposes may be used directly or indirectly in developing PRODUCT, however it may not be distributed in source form in whole or in part with or as part of PRODUCT.

5. WARRANTY DISCLAIMER

LICENSEE ACKNOWLEDGES AND AGREES THAT THE TOOLKIT IS PROVIDED "AS IS." ACCUSOFT DISCLAIMS ANY AND ALL REPRESENTATIONS AND WARRANTIES OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND AGAINST INFRINGEMENT.

6. LIMITATION OF LIABILITY

ACCUSOFT SHALL HAVE NO LIABILITY TO LICENSEE, LICENSEE AFFILIATES, SUBSIDIARIES, SHAREHOLDERS, OFFICERS, DIRECTORS, EMPLOYEES, REPRESENTATIVES OR ANY THIRD PARTY, WHETHER IN CONTRACT, TORT, NEGLIGENCE OR PRODUCTS LIABILITY, FOR ANY CLAIM, LOSS OR DAMAGE, INCLUDING BUT NOT LIMITED TO, LOST PROFITS, LOSS OF USE, BUSINESS INTERRUPTION, LOST DATA, LOST FILES, OR FOR ANY DIRECT, INDIRECT, SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES OF ANY KIND OR NATURE WHATSOEVER ARISING OUT OF OR IN CONNECTION WITH USE OF OR INABILITY TO USE THE TOOLKIT, OR THE PERFORMANCE OR OPERATION OF THE TOOLKIT, EVEN IF ACCUSOFT HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

7. INDEMNIFICATION BY LICENSEE

LICENSEE SHALL INDEMNIFY, HOLD HARMLESS AND DEFEND ACCUSOFT FOR ANY LOSS, CLAIM, ACTION OR PROCEEDING THAT ARISES OR RESULTS FROM ANY ACTIONS OR OMISSIONS OF LICENSEE PERTAINING TO THE PRODUCT OR THE TOOLKIT AND FROM ANY ACTIONS OF LICENSEE THAT ARE IN VIOLATION OF THIS AGREEMENT.

8. TERM AND TERMINATION

Unless otherwise agreed to by the parties, this AGREEMENT shall become effective upon the earlier of LICENSEE's clicking of "I Accept" or LICENSEE'S installing or placing TOOLKIT IN_USE ("Effective Date") and shall continue in full force and effect until terminated in accordance with the terms set forth in this AGREEMENT.

Any material breach of this AGREEMENT shall automatically and immediately terminate this AGREEMENT. In the event that LICENSEE ceases to do business or is adjudged bankrupt or insolvent, ACCUSOFT may, at its sole option, terminate this AGREEMENT, by giving ten (10) Business Days written notice of such termination, which notice shall identify and describe the basis for such termination.

In the event of any termination of this AGREEMENT, any RUNTIME AGREEMENT is simultaneously terminated and LICENSEE shall stop using the TOOLKIT and PORTION, shall cease manufacturing the PRODUCT containing TOOLKIT or PORTION, and shall cease distributing PRODUCT containing TOOLKIT or PORTION. LICENSEE shall also require its resellers, OEMs, and other distribution channels (if any) to likewise stop manufacturing and distributing the PRODUCT containing TOOLKIT or PORTION. Within ten (10) Business Days thereafter, LICENSEE shall return or, at ACCUSOFT's option, destroy, the TOOLKIT and all PORTIONS, whether or not incorporated in or with the PRODUCT, that are within LICENSEE’s possession, custody and control, and shall certify to ACCUSOFT in writing within ten (10) Business Days after that return or destruction that it has complied with the foregoing obligation.

All Sections except Section 1. GRANT OF LICENSE shall continue in full force and effect, notwithstanding any termination of this AGREEMENT.

9. LIQUIDATED DAMAGES

In the event LICENSEE (a) copies the TOOLKIT or PORTION except as permitted by this AGREEMENT, (b) uses the TOOLKIT or PORTION for any reason other than as permitted by this AGREEMENT, (c) installs or uses the TOOLKIT or PORTION on more than a single computer, or (d) otherwise violates or breaches this Agreement, LICENSEE agrees that ACCUSOFT is entitled to obtain as liquidated damages and not as a penalty the greater of the amount of (v) the published quantity one distribution price based upon the type of distribution, or (w) $99 per each user of each PRODUCT or service of LICENSEE in which the TOOLKIT or PORTION is included, copied, incorporated, embedded or accessible; (x) $100 per copy of TOOLKIT or PORTION; (y) $100 per copy of any PRODUCT in which TOOLKIT or PORTION is included, copied, incorporated, embedded or accessible; or (z) 3% of all revenues realized by LICENSEE pertaining to any PRODUCTS or services of LICENSEE in which TOOLKIT or PORTION is included, copied, incorporated, embedded or accessible. THE LICENSEE EXPRESSLY AGREES THAT THE FOREGOING LIQUIDATED DAMAGES ARE NOT A PENALTY.

10. CONFIDENTIALITY

LICENSEE acknowledges that the TOOLKIT contains ACCUSOFT know-how, confidential and trade secret information ("PROPRIETARY INFORMATION"). LICENSEE agrees: (a) to hold the PROPRIETARY INFORMATION in the strictest confidence, (b) not to, directly or indirectly, copy, reproduce, distribute, manufacture, duplicate, reveal, report, publish, disclose, cause to be disclosed, or otherwise transfer the PROPRIETARY INFORMATION to any third party, (c) not to make use of the PROPRIETARY INFORMATION other than as permitted by this AGREEMENT, and (d) to disclose the PROPRIETARY INFORMATION only to LICENSEE's representatives requiring such material for effective performance of this AGREEMENT and who have undertaken an obligation of confidentiality and limitation of use consistent with this AGREEMENT. This obligation shall continue as long as allowed under applicable law.

11. INJUNCTIVE RELIEF

LICENSEE agrees that any violation or threat of violation of this AGREEMENT will result in irreparable harm to ACCUSOFT for which damages would be an inadequate remedy. Therefore, in addition to its rights and remedies available at law (including but not limited to the recovery of damages for breach of this AGREEMENT), ACCUSOFT shall be entitled to immediate injunctive relief to prevent any violation of ACCUSOFT's copyright, trademark, trade secret rights regarding the TOOLKIT, or to prevent any violation of this AGREEMENT, including, but not limited to, unauthorized use, copying, distribution or disclosure of or regarding the TOOLKIT or PORTION, as well as any other equitable relief as the court may deem proper under the circumstances.

12. NO REDUCED PRICING

In any determination of ACCUSOFT's damages (whether liquidated damages or actual damages), or any determination of any licensing fees or royalties due ACCUSOFT under this AGREEMENT due to a breach by LICENSEE hereunder, LICENSEE shall not be entitled to any discounts (volume or otherwise) or reduced licensing fees or royalties. The foregoing sentence shall be applicable unless LICENSEE has negotiated and entered into a written, signed agreement with ACCUSOFT for such reduced or discounted licensing fees or royalties and paid ACCUSOFT such fees or royalties in advance of any: (a) distribution of the TOOLKIT or PORTION, (b) copying of the TOOLKIT or PORTION, or (c) incorporation or use of the TOOLKIT or PORTION in or pertaining to any PRODUCT or service of LICENSEE. Further, LICENSEE agrees that it shall not be entitled to reduced licensing fees or royalties when determining ACCUSOFT's damages due to any undertaking or activity by LICENSEE regarding the TOOLKIT or PORTION outside of or exceeding the scope of permission or other terms of this AGREEMENT, or LICENSEE's actions otherwise in violation of this AGREEMENT.

13. ATTORNEYS' FEES AND COSTS

In the event of any lawsuit or other proceeding brought as a result of any actual or alleged breach of this AGREEMENT, to enforce any provisions of this AGREEMENT, or to enforce any intellectual property or other rights in or pertaining to the TOOLKIT or PORTION, the prevailing party shall be entitled to an award of its reasonable attorneys’ fees and costs, including the costs of any expert witnesses, incurred at all levels of proceedings.

14. GOVERNING LAW

This AGREEMENT shall be construed, governed and enforced in accordance with the laws of the State of Florida, without regard to any conflicts of laws rules. Any action related to or arising out of this AGREEMENT will be filed only in the Florida courts and LICENSEE consents to the exclusive jurisdiction and venue of the state and federal courts located in Tampa, Florida.

15. SEVERABILITY

If any provision of this AGREEMENT is determined to be invalid by any court of final jurisdiction, then it shall be omitted and the remainder of the AGREEMENT shall continue to be binding and enforceable. In addition, the Court is hereby authorized to enforce any provision of the AGREEMENT that the Court otherwise deems unenforceable, to whatever lesser extent the Court deems reasonable and appropriate, rather than invalidating the entire provision. Without limiting the generality of the foregoing, LICENSEE expressly agrees that should LICENSEE be found to have breached the AGREEMENT, under no circumstances shall LICENSEE be entitled to any volume or other discount, or reduced licensing fee or royalty in the determination of ACCUSOFT's damages, or otherwise in the determination of any licensing fee or royalty owed to ACCUSOFT.

16. GOVERNMENT RIGHTS

The TOOLKIT and accompanying documentation have been developed at private expense and are sold commercially. They are provided under any U.S. government contracts or subcontracts with the most restricted and the most limited rights permitted by law and regulation. Whenever so permitted, the government and any intermediaries will obtain only those rights specified in ACCUSOFT's standard commercial license. Thus, the TOOLKIT referenced herein, and the documentation provided by Accusoft hereunder, which are provided to any agency of the U.S. Government or U.S. Government contractor or subcontractor at any tier shall be subject to the maximum restrictions on use as permitted by FAR 52.227-19 (June 1987) or DFARS 227.7202-3(a) (Jan. 1, 2000) or successor regulations. Manufacturer is Accusoft Corporation, 4001 N. Riverside Drive Tampa, FL 33603.

17. ENTIRE AGREEMENT

This AGREEMENT represents the entire understanding of the parties concerning the subject matter hereof and supersedes all prior communications and agreements, whether oral or written, relating to the subject matter of this AGREEMENT. Only a writing signed by the parties may modify this AGREEMENT. In the event of any modification in writing, of this AGREEMENT, including an expanded license agreement, all sections of this Agreement survive except Section 2. Limited License.

18. CONTACT US

Should you have any questions concerning this AGREEMENT, or if you desire to contact ACCUSOFT for any reason, please contact ACCUSOFT at 1-813-875-7575.

19. OTHER RESTRICTIONS

a) This AGREEMENT shall not be amended, altered, changed or modified in any way, unless agreed to in writing by both ACCUSOFT and LICENSEE. Such writing must be executed by a duly authorized representative of ACCUSOFT and a duly authorized representative of LICENSEE.

b) This AGREEMENT is not transferable or assignable by LICENSEE under any circumstances, without the prior written consent of ACCUSOFT. ACCUSOFT will not unreasonably withhold such consent. This AGREEMENT shall be binding upon, and is made for the benefit of, each party, its successors, and permitted assignees (if any). For the purposes of this AGREEMENT, any change in control of LICENSEE shall constitute an assignment or transfer of this AGREEMENT requiring prior written consent of ACCUSOFT. As used in this section, a change in control is defined as (i) any change in ownership of more than fifty percent (50%) of the voting interest in LICENSEE, whether by merger, purchase, foreclosure of a security interest or other transaction, or (ii) a sale of all or substantially all of the assets of LICENSEE.

c) The relationship established by this AGREEMENT between LICENSEE and ACCUSOFT shall be that of Licensee and Licensor. Nothing contained in this AGREEMENT shall be construed as creating a relationship of agency, joint venture or partnership between LICENSEE and ACCUSOFT. Neither party shall have any right whatsoever to incur any liabilities or obligations on behalf of the other party.

d) ACCUSOFT's failure to perform any term or condition of this AGREEMENT as a result of conditions beyond its control such as, but not limited to, war, strikes, fires, floods, acts of God, governmental restrictions, power failures, or damage or destruction of any network facilities or servers, shall not be deemed a breach of this AGREEMENT.

e) The headings provided in this AGREEMENT are for convenience and reference purposes only. In the event of a conflict between the terms and conditions listed in this AGREEMENT, and any attached Schedules or Appendices, the terms and conditions of this AGREEMENT shall govern.

f) A waiver of a breach, violation, or default under this AGREEMENT shall not be a waiver of any subsequent breach, violation or default. Failure of either party to enforce compliance with any term or condition of this AGREEMENT shall not constitute a waiver by the party of such term or condition.

g) All notices and communications shall be in writing and shall be deemed to have been duly given the earlier of when delivered or three (3) Business Days after mailing by certified mail, return receipt requested, postage prepaid, or by international delivery service, addressed to the parties at their respective addresses set forth on the Order Form or at such other addresses as the parties may designate by written notice in accordance with this section.

20. THIRD PARTY NOTICES

a) CAPTIVA ISIS TECHNOLOGY

ISIS functionality in the TOOLKIT is licensed to ACCUSOFT from Captiva Software, a division of EMC, Inc. The term "TOOLKIT" as defined in the Agreement includes technology from Captiva and related documentation, and any upgrades, modified versions, updates, additions, and copies thereof.

LIMITED WARRANTY

THE TERMS OF THIS AGREEMENT STATE THE SOLE AND EXCLUSIVE REMEDIES FOR ACCUSOFT'S BREACH OF WARRANTY. EXCEPT FOR THE FOREGOING LIMITED WARRANTY, CAPTIVA AND ITS SUPPLIERS MAKE NO WARRANTY, EXPRESS OR IMPLIED, AS TO MERCHANTABILITY, FITNESS FOR ANY PARTICULAR PURPOSE, OR NON-INFRINGEMENT. IN NO EVENT WILL CAPTIVA OR ITS SUPPLIERS BE LIABLE TO LICENSEE FOR ANY CONSEQUENTIAL, INCIDENTAL OR SPECIAL DAMAGES, INCLUDING ANY LOST PROFITS OR LOST SAVINGS, EVEN IF A CAPTIVA REPRESENTATIVE HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES, OR FOR ANY CLAIM BY ANY THIRD PARTY. Some states or jurisdictions do not allow the exclusion or limitation of incidental, consequential or special damages, or the exclusion of implied warranties, or limitations on how long an implied warranty may last, so the above limitations may not apply to LICENSEE. In such states/countries and to the extent permissible, any implied warranties are limited to thirty (30) days.

INTELLECTUAL PROPERTY

All ISIS technology is the intellectual property of Captiva and is protected under trademarks, registered trademarks, copyrights, and/or patents in the United States and/or other countries. ALL RIGHTS RESERVED.

Rev. 20120112

See Also

Distributing ISIS Xpress
Licensing


Distributing Applications & Deployment

Accusoft.ISISXpress5.ActiveX
Distributing Applications & Deployment
Send Feedback
ISIS Xpress 5 for ActiveX - User Guide > Distributing Applications & Deployment

Glossary Item Box

This section provides information about the following:

  • Verify You're Using the Latest Service Pack
  • Distributing ISIS Xpress


Verify You're Using the Latest Service Pack

Accusoft.ISISXpress5.ActiveX
Verify You're Using the Latest Service Pack
See Also Send Feedback
ISIS Xpress 5 for ActiveX - User Guide > Distributing Applications & Deployment > Verify You're Using the Latest Service Pack

Glossary Item Box

Service pack updates will not overwrite paid licensing. Your paid licensing will continue to work and you will not be required to re-enter your purchased registration codes. Service pack updates do not include any changes that might "break" previously developed and/or deployed code.

Verify Latest Development Components

To verify you are using the latest version of an Accusoft Development Component or Components, please refer to the currently released product build numbers at www.accusoft.com/latestbuilds.htm.

If you require further assistance or have questions or comments, please see the topic on Getting Support for more detailed information.

See Also

Getting Support
Installing on a Development Machine


Distributing ISIS Xpress

Accusoft.ISISXpress5.ActiveX
Distributing ISIS Xpress
See Also Send Feedback
ISIS Xpress 5 for ActiveX - User Guide > Distributing Applications & Deployment > Distributing ISIS Xpress

Glossary Item Box

ISIS Xpress 5 has a dependency on the C Runtime library, which must be distributed with your application in order for it to work properly. The Microsoft Visual C++ 2008 SP1 Redistributable Package (x86) can be downloaded from: http://www.microsoft.com/download/en/details.aspx?id=5582

There are a number of EMC Corporation's ISIS® PixTools files that must be installed according to the target system. There is a PixTran subdirectory in the directory where ISIS Xpress was installed. The PixTran subdirectory contains two subdirectories that include all the necessary EMC Corporation's ISIS® PixTools files. The directories are:

  • PixTran – Install these files to the target windows\pixtran directory.
  • Sysdir – Install these files to the target windows\system directory (windows\system32 if the target is WinNT, 2000, or XP).
The above files should be installed in the specified order.

DLL Files to Distribute

The following file must be distributed with the application that uses the ISIS Xpress Windows Forms control:

  • Accusoft.ISISXpress5.ActiveX.dll

See Also

Getting Support
Installing on a Development Machine
Software License Agreement
Verify You're Using the Latest Service Pack
Licensing


Concepts

Accusoft.ISISXpress5.ActiveX
Concepts
Send Feedback
ISIS Xpress 5 for ActiveX - User Guide > Concepts

Glossary Item Box

This section provides information about the following:

  • Overview of ISIS Xpress
  • Glossary


Overview of ISIS Xpress

Accusoft.ISISXpress5.ActiveX
Overview of ISIS Xpress
Send Feedback
ISIS Xpress 5 for ActiveX - User Guide > Concepts > Overview of ISIS Xpress

Glossary Item Box

There are only a few steps required for basic scanning; setting the output path and filename, and invoking the ScanSingle method.
ISISXpress.FileName = "C:\temp\image.tif"
ISISXpress.ScanSingle ()

Scanner Settings

ISIS® Xpress also provides properties and methods for scanner settings and naming schemes for batch scanning.

All settings are accessed based on the value of the ScanSetting property. This property uses the ISX_ScanSetting enumeration which has the following values:

ISX_XResolution = 0,
ISX_YResolution = 1,
ISX_PageSize = 2,
ISX_Brightness = 3,
ISX_Contrast = 4,
ISX_XPosition = 5,
ISX_YPosition = 6,
ISX_ImageWidth = 7,
ISX_ImageLength = 8,
ISX_ResUnit = 9,
ISX_Type = 10,
ISX_ScanAhead = 11,
ISX_ScanAheadMaxPages = 12,
ISX_ScanAheadPages = 13,
ISX_SamplesPerPixel = 14,
ISX_BitsPerSample = 15,
ISX_AdvancedTag =16

This property must be set before a scanner setting can be queried or set.
The following code could be used to set the scanner mode to 256-level gray scale.
ISISXpress.ScanSetting = ISX_ScanSetting.ISX_SamplesPerPixel
ISISXpress.SettingLong = 1
ISISXpress.ScanSetting = ISX_ScanSetting.ISX_BitsPerSample
ISISXpress.SettingLong = 8

The following code could be used to set the Brightness for the scanner.

ISISXpress.ScanSetting = ISX_ScanSetting.ISX_Brightness
ISISXpress.SettingLong = 23

Not all settings have an integer setting such as Brightness. The ISX_ScanSetting.ISX_PageSize property is usually a string and must be set with the SettingString property. For Example:

ISISXpress.ScanSetting = ISX_ScanSetting.ISX_PageSize
ISISXpress.SettingString = "scanner’s maximum"

The DataType property can be used to determine the setting type. This property uses the ISX_DataTypeInfo enumeration which has the following values.

ISX_RangeLong = 0,
ISX_ListLong = 1,
ISX_ListString = 2,
ISX_String = 3,
ISX_Long = 4,
ISX_Rational = 5,
ISX_ListRational = 6,
ISX_RangeRational = 7

Scanner settings can vary widely between different kinds of scanners. For this reason it is important to know what values are legal for a particular setting. ISIS® Xpress provides several properties to query the available choices for a setting.

If the DataType property equals ISX_RangeLong or ISX_RangeRational for a setting, then the following properties and methods are used to determine what range of values is legal.

The properties for Long values:

RangeMinimumLong
RangeMaximumLong

The methods for Rational values:

RangeMinimumRational
RangeMaximumRational

Any value between and including the minimum and maximum values can be set to the SettingLong property or SettingRationalSet method for this setting. A Long range of choices is the typical DataType for the following scanner settings:

ISX_ScanSetting.ISX_Brightness
ISX_ScanSetting.ISX_Contrast
ISX_ScanSetting.ISX_XPosition
ISX_ScanSetting.ISX_YPosition
ISX_ScanSetting.ISX_ImageWidth
ISX_ScanSetting.ISX_ImageLength
ISX_ScanSetting.ISX_ScanAhead
ISX_ScanSetting.ISX_ScanAheadMaxPages

If the DataType property equals ISX_DataTypeInfo.ISX_ListLong, ISX_DataTypeInfo.ISX_ListString, or ISX_DataTypeInfo.ISX_ListRational, then the possible values for the setting are contained in a list and can be queried with these methods:

ListLong
ListString
ListRational

ListLong, ListString, and ListRational are property arrays where the Index value can be from 0 to ListCount – 1. ListLong or ListString are the typical DataType for the following scanner settings:

ISX_ScanSetting.ISX_XResolution
ISX_ScanSetting.ISX_YResolution
ISX_ScanSetting.ISX_PageSize

Advanced Tags

The component supports Advanced Tags, which offers developers great flexibility in utilizing scanner specific features. These are scanner processing instructions which are provided as parameters passed as tag values to the control, and consequently passed directly through to the scanner. Assuming the correct tags are passed to the scanner, they will instruct the scanner what actions to take.

The following methods and properties are used with advanced tags:

Methods:

LongDefault - Gets a long value at the specified index in the list of long values for the default scan setting.

RationalDefault - Gets a rational value at the specified index in the list of rational values for the default scan setting.

StringDefault - Gets a string value for the default scan setting.

Properties:

Advanced - Gets and sets the advanced tag number.

Batch Scanning

ISIS® Xpress provides the ScanBatch method for batch scanning. Scanners that have a document feeder will scan until the feeder is empty or until the Cancel method is called. ISIS® Xpress will generate a FeederEmpty event when the feeder is empty. ISIS® Xpress also generates a Scanning and Scanned event for each page that is scanned. The Scanning event can be used to modify the filename before the scan takes place. Scanners without a document feeder trigger a FeederEmpty event before each page is scanned, allowing the user to cancel the operation.

After issuing the ScanBatch method, ISIS® Xpress will continue to scan images for the device until the StopScan parameter of the FeederEmpty event is set to true or the Cancel method is called. The FeederEmpty event is the correct place to pop up a dialog or message box asking the user to load the scanner, cancel the operation, load a new batch, etc.

Naming Schemes

ISIS® Xpress provides properties to generate filenames for use with batch scanning. The following properties are used:

UseSchema- Gets and set a naming schema for batch scanning.
Root - Gets and sets the root prefix used to generate filenames during a batch scan.
Directory - Gets and sets the base directory used for the file naming schema during batch scans.
FileSchema - Gets and sets the file schema used to generate filenames during batch scanning.

The UseSchema property must be set to true before ISIS® Xpress will generate filenames. Once set to true, the other properties are used to generate a file name. For example, if you want the filenames to be C:\Docs\File001.tif, C:\Docs\File002.tif, etc., these are the correct settings:

ISISXpress.Root = "File";
ISISXpress.Directory = "C:\Docs";
ISISXpress.FileSchema = "$###" ;

For the FileSchema property, the "$" symbol represents the Root, and the "#" represents the page number. The number of #’s used determines the number of leading 0’s to use in the filename. For example, "$##" generates File01.tif, while "$####" generates File0001.tif. Any extra $ symbols are ignored; "$###" is equivalent to "$$$###".

During batch scanning, a Scanning event is fired before each page is scanned. At this time the Filename property will be equal to the filename used for that page. The user can change the Filename property at this time if desired.

Memory Images

ISIS Xpress can generate a memory image at the time of scanning by setting the CreateDib property to true. If this property is set to true, the hDib property becomes valid in the Scanned event. The hDib property can then be passed on to another control such as Accusoft ImagXpress. It is possible to only use memory images by setting the CreateDib property to true and the CreateFiles property to false. In this case, nothing is saved to disk, only to memory. This can provide faster operation if you wish the user to be able to view and modify the image before saving. In such a case, you would pass the hDib property to the ImagXpress control, and then the ImagXpress control would save the file after acceptance.

The hDib property can only be read once per scan. Subsequent reads will return a 0. If you wish to check this property before setting it, load it into a temporary variable first.

For example:

Long Temp = ISISXpress.hDib;
if (Temp != 0)
{
ImagXpress.hDib = Temp;
}

Dependencies

There are a number of EMC Corporation's ISIS PixTools files that must be installed according to the target system. There is a PixTran subdirectory in the directory where ISIS Xpress was installed. The PixTran subdirectory contains four subdirectories that include all the necessary EMC Corporation's ISIS PixTools files. The directories are:

  • PixTran – Install these files to the target windows\pixtran directory.
  • Sysdir – Install these files to the target windows\system directory (windows\system32 if the target is WinNT, 2000, or XP).
The above files should be installed in the specified order.


Glossary

Accusoft.ISISXpress5.ActiveX
Glossary
Send Feedback
ISIS Xpress 5 for ActiveX - User Guide > Concepts > Glossary

Glossary Item Box

A | B | C | D | E | F | G | H | I | J | K | L | M | N | O | P | Q | R | S | T | U | V | W | X | Y | Z

A

Aspect Ratio
There are two kinds of aspect ratio that you need to be aware of when working with 2D images; the image aspect ratio and the pixel aspect ratio.The image aspect ratio is the ratio of the width of the image to the height of the image. It's important when resizing an image to keep this ratio as close to unchanged as possible or the image may become distorted.The pixel aspect ratio is the shape of the pixels in the image. For computers this is normally square (1:1) or close to it depending on the monitor settings. For some video sources, however, the pixels may be slightly rectangular.

B

BMP
The Microsoft Windows Bitmap file format is based on the Microsoft Windows internal bitmap data structures. The BMP format is very widely used and it is quick and easy to read. Although most BMP files are uncompressed, a type of run length encoding is supported.

BPP
Bits per pixel.

C

CCITT
CCITT is the most widely used compression scheme for transmitting binary (black and white) image data. CCITT was established by the International Telegraph and Telephone Consultative Committee. The Group 3 and Group 4 CCITT compression standards are widely used for transmitting fax data. CCITT compressed images are typically stored in the TIFF image format.

D

DCX
An image format containing multiple PCX images. A DCX file can contain a maximum of 1024 images.

DDB
Microsoft Device Dependent Bitmap. The actual in-memory information used to display an image.

DIB
Microsoft Device Independent Bitmap. An alternative file extension used by the Microsoft Windows Bitmap.

DEP
Data Execution Prevention (computer security).

F

Float
Denotes a simple type that stores 32-bit floating-point values.

G

GIF
Graphical Interchange File, originally developed by CompuServe as a machine independent format. GIF is one of the most popular image formats for storing 8-bit digitized images. GIF files are typically smaller than uncompressed formats like BMP due to the LZW compression algorithm that GIF uses.

Grey-scale
If the pixels of a grey-scale image have N bits, they may take values from zero, representing black up to 2^N-1, representing white with intermediate values representing increasingly light shades of grey. If N=1, the image is not called grey-scale, but could be called monochrome.

H

Halftone
Pertaining to pictures in which gradation of tone in the photograph is reproduced by a graduated system of dotted and checkered spots, usually nearly invisible to the unaided eye, produced by the interposition between the camera and the object of a screen. The name alludes to the fact that this process was the first that was practically successful in reproducing the half tones of the photograph.

I

ICO
Microsoft Windows Icon file format.

Inverse
To reverse something or change it to its opposite. For example, to invert the colors on a monochrome display means to change light to dark and dark to light. In a digital electrical signal, to replace a high level by a low level and vice versa. This type of operation is the electronic equivalent of a Boolean NOT operation.

J

JIF
An alternative image file extension used for a JFIF compliant JPEG file. Because many early versions of JPEG contained a JPG extension but did not adhere to the JFIF specifications, the JIF extension was created to identify JPEG files that are JFIF compliant. As the popularity of JPEG grew, JFIF compliance became synonymous with the JPG extension and thus the JIF extension is rarely used.

JPEG
The JPEG (Joint Photographic Experts Group) standard is one of the most important image data compression standards. It is widely used in many industries including graphic arts, desktop publishing, medical imaging, and many more. It is also becoming one of the most widely used image formats on the Internet. Although JPEG supports a lossless mode, it most commonly uses lossy compression. This allows JPEG to achieve very high compression ratios. JPEG compression uses several compression modes. First, an image is transformed to the frequency domain using the discrete cosine transform. The smaller valued frequency components are discarded leaving only the larger valued components. The remaining components are DPCM coded and then Huffman coded. Fortunately, ImagXpress™ handles all of this for you! The compression level is adjustable. Higher quality settings produce a larger image file size with higher image quality. Lower quality settings produce a smaller image file size with lower image quality. Typically, we have found that compression ratios of 10:1 or 15:1 (A 640x480x24-bit image is 921,600 bytes; a 15:1 compressed image would compress to only 61k) produce generally acceptable image quality for photographic type images. Images compressed at higher ratios begin to show more noticeable and sometimes objectionable artifacts and clarity loss. JPEG is a 24-bit format and works only with 24-bit images. If you compress an 8-bit image, ImagXpress™ automatically converts it to 24-bit to do the compression, however, you will obtain better quality when the source image is 24-bit because 8-bit images only contain 256 colors. JPEG works best with photographic type images. It does not work well with solid colors, 16-color images, cartoon like images, or drawings. Progressive JPEG is a multiple-scan sequential JPEG format that is becoming popular on the Internet for the ability to display images in progressively clearer segments.

L

LZW
Lempel-Ziv-Welch (algorithm).

Little-endian
Describes a computer architecture in which, within a given 16- or 32-bit word, bytes at lower addresses have lower significance (the word is stored "little-end-first"). The PDP-11/VAX families of computers, Intel microprocessors, plus a lot of communications and networking hardware are little-endian. The term is sometimes used to describe the ordering of units other than bytes; most often, bits within a byte.

Luminance
One of the 3 components of the HSL (Hue, Saturation and Luminance) color space. Luminance controls the overall brightness of an image.

P

PBM
Portable bitmap image format, a very simple uncompressed 1-bit (black and white) image format.

PGM
Portable Graymap image format. PGM is a very simple uncompressed 8-bit grayscale image format.

PNG
Portable Network Graphics (pronounced "ping") provides a portable, legally unencumbered (royalty-free), well-compressed, well-specified standard for lossless bitmapped image files. The initial motivation for developing PNG was to provide a royalty-free alternative to GIF. The design retains many of the features of GIF that make it an attractive format for transmission of images, such as lossless compression and progressive display capabilities. Additionally, it provides several advantages including 24-bit image support and generally better compression, although decompression is typically somewhat slower than GIF. PNG's success will be ultimately determined by its acceptability on the Internet. At the time of this writing, however, PNG has not been incorporated as part of the major Internet browsers.

PPM
Portable Pixmap image format, a very simple uncompressed 24-bit image format.

R

RLE
RLE stands for Run Length Encoding. It is a lossless algorithm that only offers decent compression ratios in specific types of data.

RGB
Red Green Blue. Bitmapped images are most generally stored as RGB data. Each pixel or data point in a true color (24-bit) image contains 3 components, red, green and blue, that describe the color of the pixel. Each of the components can have a value between 0 and 255, 0 being the darkest shade of color and 255 being the lightest shade of color. Since each component can be stored in one byte (8-bits), the 3 components take up 3 bytes or 24-bits per pixel. 8-bit images contain one byte (8-bit) indexes for each pixel that map to a color table called a palette which contains a maximum of 256 RGB entries. Likewise, 4-bit images contain 4-bit indexes for each pixel that map to a palette which contains a maximum of 16 RGB entries. 1-bit images contain 1-bit per pixel. Each bit in a 1-bit image represents either black or white.

T

twip
Twips describe the sizes of characters produced by dot matrix printers, which were constrained to multiples of either 12 or 10 dots per inch.

TGA
Targa Image File) format was developed by TrueVision for its Targa line of products. TGA is one of the earliest image formats and was the first popular format to support 24-bit color. TGA supports uncompressed and RLE compressed formats.

TIFF
Tag Image File Format, originally released by Aldus Corporation is a standard file format found in most paint, imaging, and desktop publishing programs. TIFF is extremely powerful, flexible, and extensible. However, because of its many nuances and its wide scope, TIFF can be a difficult format to understand as well as a difficult format to support. ImagXpress™ supports a wide range of TIFF 6.0 formats including uncompressed, CCITT RLE, CCITT Group 3 Fax, CCITT Group 4 Fax, LZW, Pack Bits, JPEG, and deflate compression types. ImagXpress™ supports black and white, RGB, and RGB palette images but it does not support transparency mask, CMYK, YCbCr, or CIELab.

W

WMF
The Microsoft Windows Metafile format is used to store vector and bitmap image data. Because of its popularity and wide use, many Windows and non-Windows applications support WMF.

Wintel
A term describing the combination of Microsoft Windows operating system running on PCs with Intel or compatible processors. Dominance of the wintel platform began with MS-DOS on PCs with Intel's 8-bit 8088 processors in 1979.


ISIS Xpress 5 for ActiveX - API Reference

Accusoft.ISISXpress5.ActiveX
ISIS Xpress 5 for ActiveX - API Reference
Send Feedback

Glossary Item Box

This API Reference provides detailed information about all ISIS Xpress public API members.


ISISXpress Object

Accusoft ISIS Xpress 5
ISISXpress Object
See Also Members Send comments on this topic.
AccusoftISISXpress5 ActiveX DLL : ISISXpress Object

Glossary Item Box

Description

The ISISXpress Object is the main controller component of the ISIS Xpress toolkit.

Object Model

ISISXpress Object

See Also

ISISXpress Members


ISISXpress Object Members

ISISXpress Object Members
See Also Overview Send comments on this topic.
AccusoftISISXpress5 ActiveX DLL : ISISXpress Object

Glossary Item Box

Public Methods

Public Method AboutBox | Displays the about box showing the ISIS Xpress version number, Accusoft contact information, and general information about this component.
Public Method Cancel | Cancels the scanning process immediately or waits until the current page is transferred from the scanner before the scanning process is cancelled.
Public Method CancelImmediate | Immediately cancels the scanning process.
Public Method ClearScanAheadPages | Clears the scanners buffers of any scanned in ahead pages.
Public Method GetFirstConnectedDriverAndScanner | Get the first connected driver name and scanner model.
Public Method GetFirstDriverAndScanner | Get the first driver name and scanner model.
Public Method GetNextConnectedDriverAndScanner | Get the next connected driver name and scanner model.
Public Method GetNextDriverAndScanner | Get the next driver name and scanner model.
Public Method ListLong | The method to get a long value when the DataType Property is a long list for the current scan setting.
Public Method ListRational | The method to get a rational value when the DataType Property is a rational list for the current scan setting.
Public Method ListString | The method to get a string value when the DataType Property is a string list for the current scan setting.
Public Method LoadDriver | Preloads the ISIS drivers used for scanning and saving an image.
Public Method LoadSettings | Loads the settings for the current scanner from an .ini file.
Public Method LongDefault | The method to get a long value at the specified index in the list of long values for the default scan setting.
Public Method RangeMaximumRational | The method to get the highest possible rational value for the current scan setting when the scan setting is a range of values.
Public Method RangeMinimumRational | The method to get the lowest possible rational value for the current scan setting when the scan setting is a range of values.
Public Method RationalDefault | The method to get a rational value at the specified index in the list of rational values for the default scan setting.
Public Method RationalStep | The method to get the increment or step of rationals when changing values.
Public Method SaveSettings | Saves the settings for the current scanner to an .ini file.
Public Method ScanBatch | Starts a batch scan process.
Public Method ScanSingle | Scans a single page and stores it in the file specified by the FileName Property.
Public Method Select | Displays a predefined dialog box that allows the user to choose a scanner, add a scanner, or configure a scanner.
Public Method SelectConnected | Displays a dialog box that allows the user to choose a connected scanner, add a scanner, or configure a scanner.
Public Method SetOEMLicenseKey | Sets the control runtime OEM license key.
Public Method SetSolutionKey | Sets the control runtime license deployment solution key.
Public Method SetSolutionName | Sets the control runtime license deployment solution name.
Public Method SettingRationalGet | The method to get a rational for the current scanner setting.
Public Method SettingRationalSet | The method to set a rational for the current scanner setting.
Public Method Setup | This method displays a predefined dialog that allows the user to change driver specific scanner settings.
Public Method StringDefault | The method to get a string value for the default scan setting.

Public Properties

Public Property Advanced | Gets and sets the advanced tag number.
Public Property CreateDib | Gets and sets an indicator whether a DIB is created while scanning so the hDib property is valid after each scan.
Public Property CreateFiles | Gets and sets whether the scanned in data is saved to a file using the full path and filename specified by the FileName property.
Public Property DataType | Gets the data type the information is encoded in for the current scanner setting.
Public Property Debug | Indicates whether debug information is generated and written to the debug log file.
Public Property DebugErrorLevel | Determines the level of messages to return.
Public Property DebugLogFile | Contains the full path name of the log file.
Public Property DibBitsPerPixel | Current Dib bits per pixel.
Public Property DibFlip | Gets and sets whether the DIB that is stored in the hDib property is flipped.
Public Property DibHeight | Gets the height of the current scanned image contained in the DIB represented by the hDib property.
Public Property DibWidth | Gets the width of the current scanned image contained in the DIB represented by the hDib Property.
Public Property Directory | Gets and sets the base directory used for the file naming schema during batch scans when the UseSchema Property is set to true.
Public Property DriverDirectory | The location of the ISIS driver files.
Public Property DriverDirectoryDefault | The default location of the ISIS driver files.
Public Property DriverLoaded | Gets an indicator value if the scanner driver is loaded.
Public Property ErrorCode | Returns error codes from ISIS driver.
Public Property ErrorDescription | Gets the error description.
Public Property EvaluationMode | Indicates the License evaluation mode to use for the control.
Public Property FileName | Gets and sets the full path and filename where the scanned image is saved.
Public Property FileSchema | Gets and sets the file schema used to generate filenames during batch scanning.
Public Property hDib | Gets the handle to a DIB for the current scanned image. After each scan, this value will be a handle to a DIB if the CreateDib Property is true and the UseCompression Property is false.
Public Property ListCount | Gets the number of available choices when the DataType Property is a list for the current scan setting.
Public Property ListIndex | Sets the index for the list item to access when the DataType Property is a list for the current scan setting.
Public Property MultiplePages | Gets and sets an indicator if the TIFF file should be saved as a multi-page TIFF file.
Public Property RaiseExceptions | Gets and sets if exceptions should be raised by the ISIS Xpress ActiveX control.
Public Property RangeMaximumLong | Gets the highest possible long value for the current scan setting when the scan setting is a range of values.
Public Property RangeMinimumLong | Gets the lowest possible long value for the current scan setting when the scan setting is a range of values.
Public Property Root | The property to get or set the root prefix used to generate filenames during a batch scan when the UseSchema Property is set to true.
Public Property SaveFileType | Gets and sets the file format to use when saving images. ISIS Xpress supports five different types of TIFF compression, JPEG Color, JPEG Gray, and DCX.
Public Property ScannerName | Gets and sets the name of the scanner driver.
Public Property ScanSetting | Gets and sets the scanner setting that is to be retrieved or set.
Public Property SettingLong | Gets and sets a long for the current scanner setting.
Public Property SettingString | Gets and sets a string for the current scanner setting.
Public Property Supported | Gets an indicator if the current scan setting is supported.
Public Property UseCompression | Gets and sets a value used to enable or disable hardware compression if the scanner supports it.
Public Property UseSchema | Gets and sets an indicator whether a naming schema is used during batch scanning.
Public Property Version | Returns the version of the ISISXpress control at run-time.

Events

Public Event FeederEmpty | An event indicating that the scanner feeder is empty.
Public Event Progress | An event indicating how much of the scan has completed.
Public Event Scanned | An event indicating a scan has completed.
Public Event Scanning | An event indicating a scan is starting.

See Also

ISISXpress Object


Advanced Property

Advanced Property
See Also Send comments on this topic.
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : Advanced Property

Glossary Item Box

Description

Gets and sets the advanced tag number.

Property Type

Read-write property

Syntax

Visual Basic
Public Property Advanced As Long

Return Type

A long that represents the advanced tag number.

Remarks

See the Overview topic which includes a summary on Advanced Settings and how to use them.

See Also

ISISXpress Object | ISISXpress Members | Overview


CreateDib Property

CreateDib Property
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : CreateDib Property

Glossary Item Box

Description

Gets and sets an indicator whether a DIB is created while scanning so the hDib property is valid after each scan.

Property Type

Read-write property

Syntax

Visual Basic
Public Property CreateDib As Boolean

Return Type

A boolean that indicates whether a DIB will be created. true if a DIB should be created or false if a DIB should not be created.

Remarks

The default setting is false.

This DIB can only be created if the UseCompression property is set to false. When hardware compression is enabled, the scanner sends compressed data to the computer and this cannot be used to construct a DIB.

It is possible to set both CreateDib and CreateFiles to false but then there will be no output.

See Also

ISISXpress Object | ISISXpress Members | UseCompression Property | CreateDib Property | CreateFiles Property


CreateFiles Property

CreateFiles Property
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : CreateFiles Property

Glossary Item Box

Description

Gets and sets whether the scanned in data is saved to a file using the full path and filename specified by the FileName property.

Property Type

Read-write property

Syntax

Visual Basic
Public Property CreateFiles As Boolean

Return Type

A boolean which is true if the scanned in data is saved to a file or false if the scanned in data is not saved to a file.

Remarks

The default value is true.

This setting can be set to false if only a DIB is desired. It is possible to set both CreateDib and CreateFiles to false but then there will be no output.

See Also

ISISXpress Object | ISISXpress Members | FileName Property


DataType Property

DataType Property
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : DataType Property

Glossary Item Box

Description

Gets the data type the information is encoded in for the current scanner setting.

Property Type

Read-only property

Syntax

Visual Basic
Public Property DataType As ISX_DataTypeInfo

Return Type

A ISX_DataTypeInfo enumeration representing the data type the information is encoded in for the current scanner setting.

Remarks

See the ISX_DataTypeInfo enumeration for more information.

See Also

ISISXpress Object | ISISXpress Members | ISX_DataTypeInfo Enumeration


Debug Property

Debug Property
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : Debug Property

Glossary Item Box

Description

Indicates whether debug information is generated and written to the debug log file.

Property Type

Read-write property

Syntax

Visual Basic
Public Property Debug As Boolean

Return Type

A boolean value which is true if debug information is generated and written to the log file; otherwise, false.

Remarks

This setting is used to help debug an application during development.

To define the level of debug information use the DebugErrorLevel property.

See Also

ISISXpress Object | ISISXpress Members | DebugErrorLevel Property | DebugLogFile Property


DebugErrorLevel Property

DebugErrorLevel Property
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : DebugErrorLevel Property

Glossary Item Box

Description

Determines the level of messages to return.

Property Type

Read-write property

Syntax

Visual Basic
Public Property DebugErrorLevel As ISX_ErrorLevels

Return Type

The ISX_ErrorLevels enumeration value set.

Remarks

The default value is ISX_ErrorLevels Production.

Set this property appropriately to speed up processing when not debugging. When debugging, set this property to Detailed to obtain detailed error information.

See Also

ISISXpress Object | ISISXpress Members | ISX_ErrorLevels Enumeration | ISX_ErrorLevels Enumeration | Debug Property | DebugErrorLevel Property


DebugLogFile Property

DebugLogFile Property
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : DebugLogFile Property

Glossary Item Box

Description

Contains the full path name of the log file.

Property Type

Read-write property

Syntax

Visual Basic
Public Property DebugLogFile As String

Remarks

The default value is "temp\ISISXpress5.log".

Valid values are any valid filename.

This property allows you to control the location of the debug log file.

Note: This property will have no effect if you set the Debug property to false.

See Also

ISISXpress Object | ISISXpress Members | Debug Property


DibBitsPerPixel Property

DibBitsPerPixel Property
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : DibBitsPerPixel Property

Glossary Item Box

Description

Current Dib bits per pixel.

Property Type

Read-write property

Syntax

Visual Basic
Public Property DibBitsPerPixel As Long

Return Type

A long value which represents the bits per pixel.

Remarks

This is a read-only property which throws an exception if an attempt to set it is made.

See Also

ISISXpress Object | ISISXpress Members


DibFlip Property

DibFlip Property
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : DibFlip Property

Glossary Item Box

Description

Gets and sets whether the DIB that is stored in the hDib property is flipped.

Property Type

Read-write property

Syntax

Visual Basic
Public Property DibFlip As Boolean

Return Type

A boolean value which is true if the DIB should be flipped or false if the DIB should not be flipped.

Remarks

Note: This property must be set before starting a scan.

This property only affects the DIB that is stored in the hDib property and has no bearing on saved files.

See Also

ISISXpress Object | ISISXpress Members | hDib Property


DibHeight Property

DibHeight Property
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : DibHeight Property

Glossary Item Box

Description

Gets the height of the current scanned image contained in the DIB represented by the hDib property.

Property Type

Read-only property

Syntax

Visual Basic
Public Property DibHeight As Long

Return Type

A long that represents the height of the current scanned image contained in the DIB represented by the hDib property.

Remarks

The DibHeight property is used to obtain the height of the current scanned image. This value may be different from the ISX_ScanSetting.ISX_ImageLength scan setting if a scanners page size detection setting is enabled. DibHeight is available at runtime in the Scanned event and it is available until the hDib property is no longer valid.

See Also

ISISXpress Object | ISISXpress Members | ISX_ScanSetting Enumeration | Scanned Event | hDib Property


DibWidth Property

DibWidth Property
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : DibWidth Property

Glossary Item Box

Description

Gets the width of the current scanned image contained in the DIB represented by the hDib Property.

Property Type

Read-only property

Syntax

Visual Basic
Public Property DibWidth As Long

Return Type

A long that represents the width of the current scanned image contained in the DIB represented by the hDib Property.

Remarks

The DibWidth property is used to obtain the width of the current scanned image. This value may be different from the ISX_ScanSetting.ISX_ImageWidth scan setting if a scanners page size detection setting is enabled. DibWidth is available at runtime in the Scanned Event and it is available until the hDib Property is no longer valid.

See Also

ISISXpress Object | ISISXpress Members | ISX_ScanSetting Enumeration | Scanned Event | hDib Property


Directory Property

Directory Property
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : Directory Property

Glossary Item Box

Description

Gets and sets the base directory used for the file naming schema during batch scans when the UseSchema Property is set to true.

Property Type

Read-write property

Syntax

Visual Basic
Public Property Directory As String

Return Type

Value
A string representing the base directory used for the file naming schema during batch scans.

See Also

ISISXpress Object | ISISXpress Members | UseSchema Property


DriverDirectory Property

DriverDirectory Property
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : DriverDirectory Property

Glossary Item Box

Description

The location of the ISIS driver files.

Property Type

Read-write property

Syntax

Visual Basic
Public Property DriverDirectory As String

Return Type

A string that returns the location of the ISIS driver files.

See Also

ISISXpress Object | ISISXpress Members


DriverDirectoryDefault Property

DriverDirectoryDefault Property
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : DriverDirectoryDefault Property

Glossary Item Box

Description

The default location of the ISIS driver files.

Property Type

Read-only property

Syntax

Visual Basic
Public Property DriverDirectoryDefault As String

Return Type

A string that returns the default location of the ISIS driver files.

See Also

ISISXpress Object | ISISXpress Members


DriverLoaded Property

DriverLoaded Property
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : DriverLoaded Property

Glossary Item Box

Description

Gets an indicator value if the scanner driver is loaded.

Property Type

Read-only property

Syntax

Visual Basic
Public Property DriverLoaded As Boolean

Return Type

A boolean value which is true if the scanner driver is loaded or false if the scanner driver is not loaded.

See Also

ISISXpress Object | ISISXpress Members


ErrorCode Property

ErrorCode Property
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : ErrorCode Property

Glossary Item Box

Description

Returns error codes from ISIS driver.

Property Type

Read-write property

Syntax

Visual Basic
Public Property ErrorCode As Long

Return Type

A long value which represents the error number.

Remarks

During the development cycle, the Debug Property can be used to obtain more detailed information about the specific error.

See Also

ISISXpress Object | ISISXpress Members | Debug Property | Debug Property | ErrorCode Property


ErrorDescription Property

ErrorDescription Property
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : ErrorDescription Property

Glossary Item Box

Description

Gets the error description.

Property Type

Read-only property

Syntax

Visual Basic
Public Property ErrorDescription As String

Return Type

A string that describes the error.

Remarks

During the development cycle, the Debug Property can be used to obtain more detailed information about the specific error.

See Also

ISISXpress Object | ISISXpress Members | Debug Property | ErrorNumber Property


EvaluationMode Property

EvaluationMode Property
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : EvaluationMode Property

Glossary Item Box

Description

Indicates the License evaluation mode to use for the control.

Property Type

Read-write property

Syntax

Visual Basic
Public Property EvaluationMode As ISX_Evaluation

Return Type

The ISX_Evaluation Enumeration setting representing the current Licensing evaluation mode.

Remarks

In order to test the component in an application running as a service or other environments where the component does not have permissions to create a window, the application logic needs to set the EvaluationMode to Timeout. In this mode, the component does not attempt to create the Evaluation Mode dialog window, but will timeout after 5 minutes of operation and cease to operate.

When running your project with the ISIS Xpress component in ISX_Timeout mode under the Visual Basic 6 IDE, the component will still display the evaluation dialog. However, setting the EvaluationMode property to ISX_Timeout will allow your Visual Basic 6 compiled executable to properly timeout after 5 minutes of execution and not display the evaluation dialog.

See Also

ISISXpress Object | ISISXpress Members | ISX_Evaluation Enumeration


FileName Property

FileName Property
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : FileName Property

Glossary Item Box

Description

Gets and sets the full path and filename where the scanned image is saved.

Property Type

Read-write property

Syntax

Visual Basic
Public Property FileName As String

Return Type

A string representing the full path and filename where the scanned image is saved.

Remarks

If the UseSchema Property is set to true, then this property is modified before each scan and can be checked or modified in the Scanning Event.

See Also

ISISXpress Object | ISISXpress Members | UseSchema Property | Scanning Event


FileSchema Property

FileSchema Property
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : FileSchema Property

Glossary Item Box

Description

Gets and sets the file schema used to generate filenames during batch scanning.

Property Type

Read-write property

Syntax

Visual Basic
Public Property FileSchema As String

Return Type

A string representing the file schema used to generate filenames during batch scanning.

Remarks

The following symbols can be used to specify a schema:

$ = root
# = page number

The following items are example schemas and the files they would generate:

$## = file01, file02, etc;
$#### = file0001, file0002, etc.

See Also

ISISXpress Object | ISISXpress Members


hDib Property

hDib Property
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : hDib Property

Glossary Item Box

Description

Gets the handle to a DIB for the current scanned image. After each scan, this value will be a handle to a DIB if the CreateDib Property is true and the UseCompression Property is false.

Property Type

Read-only property

Syntax

Visual Basic
Public Property hDib As Long

Return Type

A long representing the handle to a DIB for the current scanned image.

Remarks

This value can then be set to the hDib property of another control such as ImagXpress.

This property becomes valid during the Scanned Event and will remain valid until a subsequent Scanning Event.

This property can only be queried once after each scan. To check the hDib property for a non-zero value, set it to a variable first!

See Also

ISISXpress Object | ISISXpress Members | hDib Property | Scanned Event | Scanning Event


ListCount Property

ListCount Property
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : ListCount Property

Glossary Item Box

Description

Gets the number of available choices when the DataType Property is a list for the current scan setting.

Property Type

Read-only property

Syntax

Visual Basic
Public Property ListCount As Long

Return Type

A long representing the number of available choices when the DataType Property is a list for the current scan setting.

Remarks

This property is used to get the maximum value that can be used to access the ListLong Method, ListRational Method or ListString Method property arrays. The maximum value is ListCount Property - 1.

See Also

ISISXpress Object | ISISXpress Members | DataType Property | ListLong Method | ListRational Method | ListString Method | ListCount Property


ListIndex Property

ListIndex Property
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : ListIndex Property

Glossary Item Box

Description

Sets the index for the list item to access when the DataType Property is a list for the current scan setting.

Property Type

Read-write property

Syntax

Visual Basic
Public Property ListIndex As Long

Return Type

There is no return type for this property.

See Also

ISISXpress Object | ISISXpress Members


MultiplePages Property

MultiplePages Property
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : MultiplePages Property

Glossary Item Box

Description

Gets and sets an indicator if the TIFF file should be saved as a multi-page TIFF file.

Property Type

Read-write property

Syntax

Visual Basic
Public Property MultiplePages As Boolean

Return Type

A boolean value which is true if the TIFF file should be saved as a multi-page TIFF file or false if the TIFF file should not be saved as a multi-page TIFF file.

Remarks

The default value is false.

The MultiplePages Property and the UseSchema Property cannot be used at the same time.

See Also

ISISXpress Object | ISISXpress Members | MultiplePages Property | UseSchema Property


RaiseExceptions Property

RaiseExceptions Property
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : RaiseExceptions Property

Glossary Item Box

Description

Gets and sets if exceptions should be raised by the ISIS Xpress ActiveX control.

Property Type

Read-write property

Syntax

Visual Basic
Public Property RaiseExceptions As Boolean

Return Type

A boolean value which is true specifies that the ISIS Xpress ActiveX control will raise exceptions and false specifies that the ISIS Xpress ActiveX control will not raise exceptions.

Remarks

If the RaiseExceptions property is true, additional information can sometimes be obtained by checking the values of the ErrorCode Property and the ErrorDescription Property.

During the development cycle, the Debug Property can be used to obtain more detailed information about the specific error.

See Also

ISISXpress Object | ISISXpress Members | ErrorNumber Property | ErrorDescription Property | Debug Property


RangeMaximumLong Property

RangeMaximumLong Property
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : RangeMaximumLong Property

Glossary Item Box

Description

Gets the highest possible long value for the current scan setting when the scan setting is a range of values.

Property Type

Read-only property

Syntax

Visual Basic
Public Property RangeMaximumLong As Long

Return Type

A long representing the highest possible long value for the current scan setting when the scan setting is a range of values.

Remarks

A value should always be checked against this property before applying it because the highest long value can vary widely between different types of scanners.

See Also

ISISXpress Object | ISISXpress Members


RangeMinimumLong Property

RangeMinimumLong Property
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : RangeMinimumLong Property

Glossary Item Box

Description

Gets the lowest possible long value for the current scan setting when the scan setting is a range of values.

Property Type

Read-only property

Syntax

Visual Basic
Public Property RangeMinimumLong As Long

Return Type

A long representing the lowest possible long value for the current scan setting when the scan setting is a range of values.

Remarks

A value should always be checked against this property before applying it because the lowest long value can vary widely between different types of scanners.

See Also

ISISXpress Object | ISISXpress Members


Root Property

Root Property
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : Root Property

Glossary Item Box

Description

The property to get or set the root prefix used to generate filenames during a batch scan when the UseSchema Property is set to true.

Property Type

Read-write property

Syntax

Visual Basic
Public Property Root As String

Return Type

A string representing the root prefix used to generate filenames during a batch scan.

Remarks

The Root property would be "image" if the desired filenames are image01.tif, image02.tif, and etc.

See Also

ISISXpress Object | ISISXpress Members


SaveFileType Property

SaveFileType Property
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : SaveFileType Property

Glossary Item Box

Description

Gets and sets the file format to use when saving images. ISIS Xpress supports five different types of TIFF compression, JPEG Color, JPEG Gray, and DCX.

Property Type

Read-write property

Syntax

Visual Basic
Public Property SaveFileType As ISX_SaveFileType

Return Type

A ISX_SaveFileType Enumeration representing the file format to use when saving images.

Remarks

See the ISX_SaveFileType Enumeration for more information.

1 bit (Black and White) images can be saved to any of the five TIFF file formats or to the DCX file format. 8 bit (Gray Scale) images can be saved to the TiffRaw,TiffPackbits or JpegGray file formats. 24 bit (Color) images can be saved to the TiffRaw,TiffPackbits or JPEG file formats.

See Also

ISISXpress Object | ISISXpress Members | ISX_SaveFileType Enumeration


ScannerName Property

ScannerName Property
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : ScannerName Property

Glossary Item Box

Description

Gets and sets the name of the scanner driver.

Property Type

Read-write property

Syntax

Visual Basic
Public Property ScannerName As String

Return Type

A string representing the name of the scanner driver.

Remarks

The default scanner is loaded at creation.

This property will fail if it is set with a name that is not spelled exactly correct.

See Also

ISISXpress Object | ISISXpress Members


ScanSetting Property

ScanSetting Property
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : ScanSetting Property

Glossary Item Box

Description

Gets and sets the scanner setting that is to be retrieved or set.

Property Type

Read-write property

Syntax

Visual Basic
Public Property ScanSetting As ISX_ScanSetting

Return Type

A ISX_ScanSetting Enumeration representing the scanner setting that is to be retrieved or set.

Remarks

All scanner settings are modified by setting the ScanSetting Property to the appropriate setting and then using one of the setting properties such as the SettingLong Property or the SettingString Property to set up the scanner.

Setting this property will also automatically set the Advanced Property to true.

See Also

ISISXpress Object | ISISXpress Members | ISX_ScanSetting Enumeration | SettingLong Property | SettingString Property | Advanced Property


SettingLong Property

SettingLong Property
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : SettingLong Property

Glossary Item Box

Description

Gets and sets a long for the current scanner setting.

Property Type

Read-write property

Syntax

Visual Basic
Public Property SettingLong As Long

Return Type

A long representing the current scanner setting.

See Also

ISISXpress Object | ISISXpress Members


SettingString Property

SettingString Property
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : SettingString Property

Glossary Item Box

Description

Gets and sets a string for the current scanner setting.

Property Type

Read-write property

Syntax

Visual Basic
Public Property SettingString As String

Return Type

A string representing the current scanner setting.

See Also

ISISXpress Object | ISISXpress Members


Supported Property

Supported Property
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : Supported Property

Glossary Item Box

Description

Gets an indicator if the current scan setting is supported.

Property Type

Read-only property

Syntax

Visual Basic
Public Property Supported As Boolean

Return Type

A boolean value which is true if the current scan setting is supported or false if the current scan setting is not supported.

See Also

ISISXpress Object | ISISXpress Members


UseCompression Property

UseCompression Property
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : UseCompression Property

Glossary Item Box

Description

Gets and sets a value used to enable or disable hardware compression if the scanner supports it.

Property Type

Read-write property

Syntax

Visual Basic
Public Property UseCompression As Boolean

Return Type

A boolean value which is true to enable hardware compression or false to disable hardware compression.

See Also

ISISXpress Object | ISISXpress Members


UseSchema Property

UseSchema Property
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : UseSchema Property

Glossary Item Box

Description

Gets and sets an indicator whether a naming schema is used during batch scanning.

Property Type

Read-write property

Syntax

Visual Basic
Public Property UseSchema As Boolean

Return Type

A boolean indicating whether a naming schema is used during batch scanning.

Remarks

The default value is false.

The values of the Directory Property, Root Property, and FileSchema Property are used to determine the full path and filenames of the output files.

The MultiplePages Property and the UseSchema Property cannot be used at the same time.

See Also

ISISXpress Object | ISISXpress Members | Directory Property | MultiplePages Property | Root Property | FileSchema Property | UseSchema Property


Version Property

Version Property
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : Version Property

Glossary Item Box

Description

Returns the version of the ISISXpress control at run-time.

Property Type

Read-write property

Syntax

Visual Basic
Public Property Version As String

Return Type

A string specifying the version of the ISISXpress control.

See Also

ISISXpress Object | ISISXpress Members


AboutBox Method

AboutBox Method
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : AboutBox Method

Glossary Item Box

Description

Displays the about box showing the ISIS Xpress version number, Accusoft contact information, and general information about this component.

Syntax

Visual Basic
Public Sub AboutBox()

See Also

ISISXpress Object | ISISXpress Members


Cancel Method

Cancel Method
bImmediate
A boolean value which is true to immediately cancel the scanning process or false to wait until the current page is transferred from the scanner before the scanning process is cancelled.
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : Cancel Method

Glossary Item Box

Description

Cancels the scanning process immediately or waits until the current page is transferred from the scanner before the scanning process is cancelled.

Syntax

Visual Basic
Public Sub Cancel( _
   Optional ByVal bImmediate As Boolean = True _
)

Parameters

bImmediate
A boolean value which is true to immediately cancel the scanning process or false to wait until the current page is transferred from the scanner before the scanning process is cancelled.

Remarks

If the immediate parameter is true, the Cancel method will immediately cancel the scanning process. This cancellation will occur even if ISIS Xpress is in the middle of transferring data from the scanner.

If the immediate parameter is false, the Cancel method will cause the scanner to wait until the current page is transferred from the scanner before the scanning process is cancelled. If ISX_ScanSetting.ISX_ScanAhead is enabled and the scanner driver supports the ISX_ScanSetting.ISX_ScanAheadPages setting then ISIS Xpress will process those pages that have been scanned ahead, otherwise ISIS Xpress will stop processing all pages.

See Also

ISISXpress Object | ISISXpress Members | ISX_ScanSetting Enumeration


CancelImmediate Method

CancelImmediate Method
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : CancelImmediate Method

Glossary Item Box

Description

Immediately cancels the scanning process.

Syntax

Visual Basic
Public Sub CancelImmediate()

Remarks

The Cancel method will immediately cancel the scanning process. This cancellation will occur even if ISIS Xpress is in the middle of transferring data from the scanner.

See Also

ISISXpress Object | ISISXpress Members | Cancel Method


ClearScanAheadPages Method

ClearScanAheadPages Method
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : ClearScanAheadPages Method

Glossary Item Box

Description

Clears the scanners buffers of any scanned in ahead pages.

Syntax

Visual Basic
Public Function ClearScanAheadPages() As Long

Remarks

This method should be called if a Cancel Method was performed while the scanner was set to scan ahead with the ISX_ScanSetting.ISX_ScanAhead scan setting set to ISX_ScanAheadChoice.On. This will flush the scanners buffers of any unprocessed pages.

See Also

ISISXpress Object | ISISXpress Members | ISX_ScanSetting Enumeration | ISX_ScanAheadChoice Enumeration | Cancel Method


GetFirstConnectedDriverAndScanner Method

GetFirstConnectedDriverAndScanner Method
DriverName
A string value which represents the driver name to get.
ScannerModel
A string value which represents the scanner model to get.
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : GetFirstConnectedDriverAndScanner Method

Glossary Item Box

Description

Get the first connected driver name and scanner model.

Syntax

Visual Basic
Public Sub GetFirstConnectedDriverAndScanner( _
   ByRef DriverName As String, _
   ByRef ScannerModel As String _
)

Parameters

DriverName
A string value which represents the driver name to get.
ScannerModel
A string value which represents the scanner model to get.

Remarks

Note: When the list has been completed, both DriverName and ScannerModel are NULL pointers.

See Also

ISISXpress Object | ISISXpress Members


GetFirstDriverAndScanner Method

GetFirstDriverAndScanner Method
DriverName
A string value which represents the driver name to get.
ScannerModel
A string value which represents the scanner model to get.
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : GetFirstDriverAndScanner Method

Glossary Item Box

Description

Get the first driver name and scanner model.

Syntax

Visual Basic
Public Sub GetFirstDriverAndScanner( _
   ByRef DriverName As String, _
   ByRef ScannerModel As String _
)

Parameters

DriverName
A string value which represents the driver name to get.
ScannerModel
A string value which represents the scanner model to get.

Remarks

Note: When the list has been completed, both DriverName and ScannerModel are NULL pointers.

See Also

ISISXpress Object | ISISXpress Members


GetNextConnectedDriverAndScanner Method

GetNextConnectedDriverAndScanner Method
DriverName
A string value which represents the driver name.
ScannerModel
A string value which represents the scanner model.
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : GetNextConnectedDriverAndScanner Method

Glossary Item Box

Description

Get the next connected driver name and scanner model.

Syntax

Visual Basic
Public Sub GetNextConnectedDriverAndScanner( _
   ByRef DriverName As String, _
   ByRef ScannerModel As String _
)

Parameters

DriverName
A string value which represents the driver name.
ScannerModel
A string value which represents the scanner model.

Remarks

Note: When the list has been completed, both DriverName and ScannerModel are NULL pointers.

See Also

ISISXpress Object | ISISXpress Members


GetNextDriverAndScanner Method

GetNextDriverAndScanner Method
DriverName
A string value which represents the driver name.
ScannerModel
A string value which represents the scanner model.
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : GetNextDriverAndScanner Method

Glossary Item Box

Description

Get the next driver name and scanner model.

Syntax

Visual Basic
Public Sub GetNextDriverAndScanner( _
   ByRef DriverName As String, _
   ByRef ScannerModel As String _
)

Parameters

DriverName
A string value which represents the driver name.
ScannerModel
A string value which represents the scanner model.

Remarks

Note: When the list has been completed, both DriverName and ScannerModel are NULL pointers.

See Also

ISISXpress Object | ISISXpress Members


ListLong Method

ListLong Method
Index
The index of the long value to retrieve from the long list.
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : ListLong Method

Glossary Item Box

Description

The method to get a long value when the DataType Property is a long list for the current scan setting.

Syntax

Visual Basic
Public Function ListLong( _
   Optional ByVal Index As Variant _
) As Long

Parameters

Index
The index of the long value to retrieve from the long list.

Return Type

A long representing a long value when the DataType Property is a long list for the current scan setting.

Remarks

The index parameter is the index of the long value to retrieve from the long list.

See Also

ISISXpress Object | ISISXpress Members | DataType Property


ListRational Method

ListRational Method
Numer
A long value which represents the numerator for the rational type.
Denom
A long value which represents the denominator for the rational type.
Index
The index of the rational value to retrieve from the rational list.
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : ListRational Method

Glossary Item Box

Description

The method to get a rational value when the DataType Property is a rational list for the current scan setting.

Syntax

Visual Basic
Public Sub ListRational( _
   ByRef Numer As Long, _
   ByRef Denom As Long, _
   Optional ByVal Index As Variant _
)

Parameters

Numer
A long value which represents the numerator for the rational type.
Denom
A long value which represents the denominator for the rational type.
Index
The index of the rational value to retrieve from the rational list.

Remarks

The index parameter is the index of the rational value to retrieve from the rational list.

See Also

ISISXpress Object | ISISXpress Members


ListString Method

ListString Method
Index
The index of the string value to retrieve from the string list.
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : ListString Method

Glossary Item Box

Description

The method to get a string value when the DataType Property is a string list for the current scan setting.

Syntax

Visual Basic
Public Function ListString( _
   Optional ByVal Index As Variant _
) As String

Parameters

Index
The index of the string value to retrieve from the string list.

Return Type

A string representing a string value when the DataType Property is a string list for the current scan setting.

Remarks

The index parameter is the index of the string value to retrieve from the string list.

See Also

ISISXpress Object | ISISXpress Members | DataType Property


LoadDriver Method

LoadDriver Method
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : LoadDriver Method

Glossary Item Box

Description

Preloads the ISIS drivers used for scanning and saving an image.

Syntax

Visual Basic
Public Sub LoadDriver()

Remarks

This is an optimization method that can be used to improve performance. If this method is not called, there is a slight delay before the first scan is started because the control must first load the ISIS drivers. This method should only be called one time.

The following properties affect the ISIS drivers and can cause them to be reloaded:

SaveFileType Property
CreateFiles Property
UseCompression Property

If the properties need to be changed they should be modified and then LoadDriver should be called so the control is ready to scan. This will result in the scan starting immediately when the ScanSingle Method or ScanBatch Method method is called since the ISIS drivers have already been preloaded.

See Also

ISISXpress Object | ISISXpress Members | SaveFileType Property | UseCompression Property | CreateFiles Property


LoadSettings Method

LoadSettings Method
FileName
The full path and filename of the .ini file which contains the scanner settings to load.
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : LoadSettings Method

Glossary Item Box

Description

Loads the settings for the current scanner from an .ini file.

Syntax

Visual Basic
Public Sub LoadSettings( _
   ByVal FileName As String _
)

Parameters

FileName
The full path and filename of the .ini file which contains the scanner settings to load.

Remarks

The same .ini file can be used for multiple scanners because the settings are saved under a different section for each scanner. The section name used in the .ini file is the name of the scanner driver.

See Also

ISISXpress Object | ISISXpress Members


LongDefault Method

LongDefault Method
Index
An index into the list of long values.
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : LongDefault Method

Glossary Item Box

Description

The method to get a long value at the specified index in the list of long values for the default scan setting.

Syntax

Visual Basic
Public Function LongDefault( _
   Optional ByVal Index As Variant _
) As Long

Parameters

Index
An index into the list of long values.

Return Type

This property is only available for Advanced settings.

A long representing the long value at the specified index in the list of long values for the default scan setting.

See Also

ISISXpress Object | ISISXpress Members | Overview


RangeMaximumRational Method

RangeMaximumRational Method
Numer
A long value which represents the numerator for the rational type.
Denom
A long value which represents the denominator for the rational type.
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : RangeMaximumRational Method

Glossary Item Box

Description

The method to get the highest possible rational value for the current scan setting when the scan setting is a range of values.

Syntax

Visual Basic
Public Sub RangeMaximumRational( _
   ByRef Numer As Long, _
   ByRef Denom As Long _
)

Parameters

Numer
A long value which represents the numerator for the rational type.
Denom
A long value which represents the denominator for the rational type.

Remarks

A value should always be checked against this property before applying it because the highest rational value can vary widely between different types of scanners.

See Also

ISISXpress Object | ISISXpress Members


RangeMinimumRational Method

RangeMinimumRational Method
Numer
The numerator for the rational type.
Denom
The denominator for the rational type.
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : RangeMinimumRational Method

Glossary Item Box

Description

The method to get the lowest possible rational value for the current scan setting when the scan setting is a range of values.

Syntax

Visual Basic
Public Sub RangeMinimumRational( _
   ByRef Numer As Long, _
   ByRef Denom As Long _
)

Parameters

Numer
The numerator for the rational type.
Denom
The denominator for the rational type.

Remarks

A value should always be checked against this property before applying it because the lowest rational value can vary widely between different types of scanners.

See Also

ISISXpress Object | ISISXpress Members


RationalDefault Method

RationalDefault Method
Numer
The numerator for the rational type.
Denom
The denominator for the rational type.
Index
An index into the list of rational values.
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : RationalDefault Method

Glossary Item Box

Description

The method to get a rational value at the specified index in the list of rational values for the default scan setting.

Syntax

Visual Basic
Public Sub RationalDefault( _
   ByRef Numer As Long, _
   ByRef Denom As Long, _
   Optional ByVal Index As Variant _
)

Parameters

Numer
The numerator for the rational type.
Denom
The denominator for the rational type.
Index
An index into the list of rational values.

Remarks

This method is only available for Advanced settings.

See Also

ISISXpress Object | ISISXpress Members


RationalStep Method

RationalStep Method
Numer
The numerator for the rational type.
Denom
The denominator for the rational type.
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : RationalStep Method

Glossary Item Box

Description

The method to get the increment or step of rationals when changing values.

Syntax

Visual Basic
Public Sub RationalStep( _
   ByRef Numer As Long, _
   ByRef Denom As Long _
)

Parameters

Numer
The numerator for the rational type.
Denom
The denominator for the rational type.

See Also

ISISXpress Object | ISISXpress Members


SaveSettings Method

SaveSettings Method
FileName
The full path and filename of the .ini file where the scanner settings are saved.
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : SaveSettings Method

Glossary Item Box

Description

Saves the settings for the current scanner to an .ini file.

Syntax

Visual Basic
Public Sub SaveSettings( _
   ByVal FileName As String _
)

Parameters

FileName
The full path and filename of the .ini file where the scanner settings are saved.

Remarks

The same .ini file can be used for multiple scanners because the settings are saved under a different section for each scanner. The section name used in the .ini file is the name of the scanner driver.

See Also

ISISXpress Object | ISISXpress Members


ScanBatch Method

ScanBatch Method
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : ScanBatch Method

Glossary Item Box

Description

Starts a batch scan process.

Syntax

Visual Basic
Public Sub ScanBatch()

Remarks

During the scan process a Scanning Event is fired before the scan to allow the filename to be changed. If the UseCompression Property is false then Progress Events will be fired during the scan. After a page has completed, the Scanned Event will fire.

If the UseSchema Property is true, then ISIS Xpress will generate a naming schema to use for filenames. The generated filename can be checked and changed in each Scanning Event.

IMPORTANT! The ScanBatch method will not finish until the FeederEmpty Event StopScan Parameter is set to true in the FeederEmpty Event to indicate the batch is done or until the Cancel Method is called.

When the scanner feeder is empty, a FeederEmpty Event is fired. This event may fire after each scan if you are using a scanner that does not have a feeder or a scanner that cannot detect paper in the feeder.

See Also

ISISXpress Object | ISISXpress Members | FeederEmpty Event | Cancel Method | Scanning Event | Progress Event | UseCompression Property | UseSchema Property | Scanned Event


ScanSingle Method

ScanSingle Method
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : ScanSingle Method

Glossary Item Box

Description

Scans a single page and stores it in the file specified by the FileName Property.

Syntax

Visual Basic
Public Sub ScanSingle()

See Also

ISISXpress Object | ISISXpress Members | FileName Property


Select Method

Select Method
hWnd
A valid window handle.
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : Select Method

Glossary Item Box

Description

Displays a predefined dialog box that allows the user to choose a scanner, add a scanner, or configure a scanner.

Syntax

Visual Basic
Public Sub Select( _
   Optional ByVal hWnd As Variant _
)

Parameters

hWnd
A valid window handle.

Remarks

The dialog box will be modal if the forms window handle is passed in.

See Also

ISISXpress Object | ISISXpress Members


SelectConnected Method

SelectConnected Method
hWnd
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : SelectConnected Method

Glossary Item Box

Description

Displays a dialog box that allows the user to choose a connected scanner, add a scanner, or configure a scanner.

Syntax

Visual Basic
Public Sub SelectConnected( _
   Optional ByVal hWnd As Variant _
)

Parameters

hWnd

See Also

ISISXpress Object | ISISXpress Members


SetOEMLicenseKey Method

SetOEMLicenseKey Method
newVal
The OEM license key required for OEM licensing.
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : SetOEMLicenseKey Method

Glossary Item Box

Description

Sets the control runtime OEM license key.

Syntax

Visual Basic
Public Sub SetOEMLicenseKey( _
   ByVal newVal As String _
)

Parameters

newVal
The OEM license key required for OEM licensing.

Remarks

When OEM runtime licenses are purchased, the OEM license key is provided in the purchase confirmation email.

See Also

ISISXpress Object | ISISXpress Members


SetSolutionKey Method

SetSolutionKey Method
key1
Unlock key 1
key2
Unlock key 2
key3
Unlock key 3
key4
Unlock key 4
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : SetSolutionKey Method

Glossary Item Box

Description

Sets the control runtime license deployment solution key.

Syntax

Visual Basic
Public Sub SetSolutionKey( _
   ByVal key1 As Long, _
   ByVal key2 As Long, _
   ByVal key3 As Long, _
   ByVal key4 As Long _
)

Parameters

key1
Unlock key 1
key2
Unlock key 2
key3
Unlock key 3
key4
Unlock key 4

Remarks

This is the solution key required for all runtime licensing. The four integers are provided at the time of purchase of the runtime licenses along with the solution name, which is set with the SetSolutionName method.

See Also

ISISXpress Object | ISISXpress Members


SetSolutionName Method

SetSolutionName Method
newVal
The solution name.
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : SetSolutionName Method

Glossary Item Box

Description

Sets the control runtime license deployment solution name.

Syntax

Visual Basic
Public Sub SetSolutionName( _
   ByVal newVal As String _
)

Parameters

newVal
The solution name.

Remarks

This is the name of the runtime license solution. The solution name is provided in the purchase confirmation email when runtime licenses are purchased.

See Also

ISISXpress Object | ISISXpress Members


SettingRationalGet Method

SettingRationalGet Method
Numer
The numerator for the rational type.
Denom
The denominator for the rational type.
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : SettingRationalGet Method

Glossary Item Box

Description

The method to get a rational for the current scanner setting.

Syntax

Visual Basic
Public Sub SettingRationalGet( _
   ByRef Numer As Long, _
   ByRef Denom As Long _
)

Parameters

Numer
The numerator for the rational type.
Denom
The denominator for the rational type.

See Also

ISISXpress Object | ISISXpress Members


SettingRationalSet Method

SettingRationalSet Method
Numer
The numerator for the rational type.
Denom
The denominator for the rational type.
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : SettingRationalSet Method

Glossary Item Box

Description

The method to set a rational for the current scanner setting.

Syntax

Visual Basic
Public Sub SettingRationalSet( _
   ByVal Numer As Long, _
   ByVal Denom As Long _
)

Parameters

Numer
The numerator for the rational type.
Denom
The denominator for the rational type.

See Also

ISISXpress Object | ISISXpress Members


Setup Method

Setup Method
hWnd
The parent window handle.
dwFlags
The options used to modify what is displayed by the predefined scanner settings dialog. See the ISX_SetupOptions enumeration for additional details.
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : Setup Method

Glossary Item Box

Description

This method displays a predefined dialog that allows the user to change driver specific scanner settings.

Syntax

Visual Basic
Public Sub Setup( _
   Optional ByVal hWnd As Variant, _
   Optional ByVal dwFlags As Variant _
)

Parameters

hWnd
The parent window handle.
dwFlags
The options used to modify what is displayed by the predefined scanner settings dialog. See the ISX_SetupOptions enumeration for additional details.

Remarks

The predefined dialog can only be modified by using the dwFlags parameter.

See Also

ISISXpress Object | ISISXpress Members


StringDefault Method

StringDefault Method
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : StringDefault Method

Glossary Item Box

Description

The method to get a string value for the default scan setting.

Syntax

Visual Basic
Public Function StringDefault() As String

Return Type

A string that represents the string value for the default scan setting.

Remarks

This property is only available for Advanced settings.

See Also

ISISXpress Object | ISISXpress Members | Overview


FeederEmpty Event

FeederEmpty Event
PageNumber
The page number of the scan that just completed.
StopScan
A boolean set by the user to indicate the batch process should end.
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : FeederEmpty Event

Glossary Item Box

Description

An event indicating that the scanner feeder is empty.

Syntax

Visual Basic
Public Event FeederEmpty( _
   ByVal PageNumber As Long, _
   ByRef StopScan As Boolean _
)

Parameters

PageNumber
The page number of the scan that just completed.
StopScan
A boolean set by the user to indicate the batch process should end.

Remarks

This event can be used to notify the user that the scanner feeder is empty during a batch scanning process.

See Also

ISISXpress Object | ISISXpress Members


Progress Event

Progress Event
Percent
A long indicating how much of the scan has completed.
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : Progress Event

Glossary Item Box

Description

An event indicating how much of the scan has completed.

Syntax

Visual Basic
Public Event Progress( _
   ByVal Percent As Long _
)

Parameters

Percent
A long indicating how much of the scan has completed.

Remarks

If the UseCompression Property is true then Progress Events will not be fired during the scan.

See Also

ISISXpress Object | ISISXpress Members | UseCompression Property


Scanned Event

Scanned Event
PageNumber
The page number of the scan that just completed.
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : Scanned Event

Glossary Item Box

Description

An event indicating a scan has completed.

Syntax

Visual Basic
Public Event Scanned( _
   ByVal PageNumber As Long _
)

Parameters

PageNumber
The page number of the scan that just completed.

Remarks

This event is fired after a scan to allow the user to check or set the hDib Property.

See Also

ISISXpress Object | ISISXpress Members


Scanning Event

Scanning Event
PageNumber
The page number of the scan that is starting.
AccusoftISISXpress5 ActiveX DLL > ISISXpress Object : Scanning Event

Glossary Item Box

Description

An event indicating a scan is starting.

Syntax

Visual Basic
Public Event Scanning( _
   ByVal PageNumber As Long _
)

Parameters

PageNumber
The page number of the scan that is starting.

Remarks

This event is fired before a scan to allow the user to check or modify the FileName Property.

See Also

ISISXpress Object | ISISXpress Members


ISX_DataTypeInfo Enumeration

ISX_DataTypeInfo Enumeration
AccusoftISISXpress5 ActiveX DLL : ISX_DataTypeInfo Enumeration

Glossary Item Box

Description

Option values for the data type the information is encoded in for the current scanner setting.

Members

Member | Value | Description
ISX_ListLong | 1 | A list or array of longs. For example 200, 300, 400, 500.
ISX_ListRational | 6 | A list or array of rationals. For example 200/1, 300/1, 400/1, 500/1. This data type is only available for Advanced settings.
ISX_ListString | 2 | A list or array of strings. For example "8.5 x 11 letter", "8.5 x 14 legal, and etc..
ISX_Long | 4 | A long. This can also be used for a byte or a short.
ISX_RangeLong | 0 | A range of longs. For example 0 - 99.
ISX_RangeRational | 7 | A range of rationals. For example 1/1 - 1200/1. See the RationalStep Method for the increment between rationals. This data type is only available for Advanced settings.
ISX_Rational | 5 | A rational. See the SettingRationalGet and the SettingRationalSet methods for more information. This data type is only available for Advanced settings.
ISX_String | 3 | A string.

Remarks

This value is set by using the DataType Property.

See Also

DataType Property | SettingRationalGet Method | SettingRationalSet Method | RationalStep Method


ISX_ErrorLevels Enumeration

ISX_ErrorLevels Enumeration
AccusoftISISXpress5 ActiveX DLL : ISX_ErrorLevels Enumeration

Glossary Item Box

Description

Option values for the error level to use for the ISIS Xpress control.

Members

Member | Value | Description
ISX_Detailed | 2 | This setting will produce detailed error information that is useful when debugging a problem during the development process.
ISX_Development | 1 | This setting will produce additional error information that is useful during the development process.
ISX_Production | 0 | The default error level. This setting will produce the minimum amount of error information.

Remarks

The default value is ISX_Production.

This value is set by using the DebugErrorLevel Property and is used to help debug an application during development.

See Also

DebugErrorLevel Property


ISX_Errors Enumeration

ISX_Errors Enumeration
AccusoftISISXpress5 ActiveX DLL : ISX_Errors Enumeration

Glossary Item Box

Description

Option value for error numbers and error descriptions for the various errors that can occur.

Members

Member | Value | Description
ISX_SCANERR_BADINDEX | 10002 | Index out of range. An invalid index was used with the SettingLong or SettingString property arrays. The index parameter must be in the range of 0 to ListCount 1.
ISX_SCANERR_BADLENGTH | 10003 | String too long. An invalid scanner name was assigned to the ScannerName property.
ISX_SCANERR_BADSCHEMA | 10006 | Invalid filename schema. An invalid schema was set for the FileSchema property.
ISX_SCANERR_BADVALUE | 10005 | Invalid scanner setting value. An invalid value was assigned to a scanner setting. Every scanner has a different set of legal values for its setting. These values, or choices, can be queried using the appropriate choice properties to insure that a value is legal before it is assigned.
ISX_SCANERR_CANCEL | 10009 | Cancel performed. The cancel method was called to stop scanning.
ISX_SCANERR_GENERAL | 10100 | Generic ISIS Error. A nonspecific error occurred.
ISX_SCANERR_INI | 10008 | Ini File error. An error occurred either reading or writing the current settings to an ini file.
ISX_SCANERR_NODIB | 10010 | No DIB available. There was no DIB currently created and available.
ISX_SCANERR_NOLICENSE | 10016 | No License. No valid license was found for ISIS Xpress.
ISX_SCANERR_NOSCANNER | 10001 | No scanner is loaded. No scanner driver is currently loaded. Many ISIS Xpress properties and methods require a scanner to be loaded before they can be used. ISIS Xpress tries to load the default scanner when the control is first loaded, and will load a new driver when the ScannerName or ScannerSelect property is set.
ISX_SCANERR_NOTAVAIL | 10007 | Setting not available. A property was queried or set that is not available for a particular setting. For example, if the ScanSetting property is set to ISX_PageSize, the RangeMinimumLong property will return this error. For this property, the SettingString property must be used.
ISX_SCANERR_OUTOFMEMORY | 10004 | Out of memory. ISIS Xpress could not allocate enough memory to perform the desired operation.
ISX_SCANERR_PIX | 10000 | ISIS driver error. An error occurred when communicating with the ISIS scanner driver. If the RaiseError property is false, check the ErrorNumber and ErrorDescription properties for extended information that may be returned from the driver.
ISX_SCANERR_SAVETYPE | 10015 | Save Type. There was a problem with the save type.
ISX_SCANERR_SEQ | 10014 | Sequence Error. An action was performed that is invalid at this time. For instance, calling ScanBatch or ScanSingle methods while the scanner is already scanning.
ISX_SCANERR_WIN95 | 10017 | Will not run on Windows 95. ISIS Xpress will not run on Windows 95.

Remarks

If the RaiseExceptions Property is set to true, ISIS Xpress will throw COM Exceptions which contain the error code and error description. If the RaiseExceptions Property is set to false, ISIS Xpress will provide error codes through the ErrorCode Property and the error description through the ErrorDescription Property.


ISX_Evaluation Enumeration

ISX_Evaluation Enumeration
AccusoftISISXpress5 ActiveX DLL : ISX_Evaluation Enumeration

Glossary Item Box

Description

Option values for the licensing evaluation choices that are available with ISIS Xpress.

Members

Member | Value | Description
ISX_Timeout | 1 | After the trial period has expired the ISIS Xpress toolkit will no longer function.
ISX_TrialDialog | 0 | After the trial period has expired a dialog is displayed each time the ISIS Xpress toolkit is accessed.

Remarks

The default value is ISX_TrialDialog.

This value is set by using the EvaluationMode Property of the ISISXpress Object.

See Also

EvaluationMode Property | ISISXpress Object


ISX_SaveFileType Enumeration

ISX_SaveFileType Enumeration
AccusoftISISXpress5 ActiveX DLL : ISX_SaveFileType Enumeration

Glossary Item Box

Description

Option values for the file format to use when saving images.

Members

Member | Value | Description
ISX_DCX | 7 | DCX compression.
ISX_JPEG_Color | 5 | JPEG Color compression.
ISX_JPEG_Gray | 6 | JPEG Gray compression.
ISX_TIFF_G3 | 2 | CCITT Fax Group 3 compression.
ISX_TIFF_G3M | 3 | CCITT Fax Modified Group 3 compression.
ISX_TIFF_G4 | 4 | CCITT Fax Group 4 compression.
ISX_TIFF_PackBits | 1 | Packbits compression.
ISX_TIFF_Raw | 0 | No compression.

Remarks

This value is set by using the SaveFileType Property.

1 bit (Black and White) images can be saved to any of the five TIFF file formats or to the DCX file format. 8 bit (Gray Scale) images can be saved to the TiffRaw,TiffPackbits or JpegGray file formats. 24 bit (Color) images can be saved to the TiffRaw,TiffPackbits or JPEG file formats.

See Also

SaveFileType Property


ISX_ScanAheadChoice Enumeration

ISX_ScanAheadChoice Enumeration
AccusoftISISXpress5 ActiveX DLL : ISX_ScanAheadChoice Enumeration

Glossary Item Box

Description

Option values for the ISX_ScanSetting.ISX_ScanAhead setting.

Members

Member | Value | Description
ISX_Off | 0 | Scan ahead is off or disabled.
ISX_On | 1 | Scan ahead is on or enabled.

Remarks

These options allow you to turn on or off the scan ahead option.


ISX_ScanSetting Enumeration

ISX_ScanSetting Enumeration
AccusoftISISXpress5 ActiveX DLL : ISX_ScanSetting Enumeration

Glossary Item Box

Description

Option values for determining which scanner setting to query or set.

Members

Member | Value | Description
ISX_AdvancedTag | 16 | Specifies the scanner's advanced tag number.
ISX_BitsPerSample | 15 | Indicates how big a sample is. Typical values are: 1 = Binary; 4 = four-bit gray scale (16 shades of gray); 8 = eight-bit gray scale (256 shades of gray); 24 = 24-bit color.
ISX_Brightness | 3 | The scanner's brightness. If available, -3 will set to auto brightness, -2 will auto darken, and -1 will auto lighten. Values from 0 to RangeMaximumLong Property will incrementally change the brightness.
ISX_Contrast | 4 | The scanner's contrast. A value of 0 means auto contrast or no contrast control is available.
ISX_ImageLength | 8 | Specifies the number of rows of pixels (height) in an image.
ISX_ImageWidth | 7 | Specifies the number of columns of pixels (width) in an image.
ISX_PageSize | 2 | The total area available to the scanner.
ISX_ResUnit | 9 | Specifies the unit of measurement for XResolution and YResolution. This setting is not available for all scanners and if it is not available the units are assumed to be DPI. 1. No absolute unit of measurement. Used for images that may have a non-square aspect ratio, but no meaningful absolute dimensions. 2. Resolution is specified in dots per inch. 3. Resolution is specified in dots per centimeter.
ISX_SamplesPerPixel | 14 | Indicates how many values each pixel uses to represent its data. Possible values are: 1 sample per pixel = Binary black/white) and gray scale images; 3 samples per pixel = RGB color images.
ISX_ScanAhead | 11 | Specifies if the scanning source should enable the ability to continuously scan pages ahead of the current page the application is processing on those scanners that support this functionality. See the ISX_ScanAheadChoice Enumeration for more information.
ISX_ScanAheadMaxPages | 12 | If ScanAhead is enabled, this setting specifies the maximum number of pages to scan ahead. A zero value means to scan until the feeder is empty.
ISX_ScanAheadPages | 13 | If ScanAhead is enabled and this setting is supported, it will determine how many pages have been scanned in ahead. On some scanners this value will not be an accurate measurement for how many pages are scanned in ahead. Therefore, use this setting as a general indicator that there are pages waiting that have been scanned in ahead. This setting is read-only.
ISX_Type | 10 | Specifies the scanning source (flatbed, feeder, and etc.) on those scanners that support this functionality. See the ISX_Source Enumeration more information.
ISX_XPosition | 5 | Specifies the distance in pixels from the left edge of the page to the start of the image.
ISX_XResolution | 0 | The scanner's horizontal resolution in DPI.
ISX_YPosition | 6 | Specifies the distance in pixels from the top edge of the page to the start of the image.
ISX_YResolution | 1 | The scanner's vertical resolution in DPI.

Remarks

All scanner settings are modified by setting the ScanSetting Property to the appropriate setting and then using one of the setting properties such as the SettingLong Property or the SettingString Property to set up the scanner.

Before modifying a setting, the setting should be checked to see if it is supported and the choices for a setting should be queried to make sure the desired value is legal for the particular scanner.

The following table illustrates how to set a scanner mode. This information assumes that the scanner is capable of each mode.

Mode SamplesPerPixel BitsPerSample
Black/White 1 1
16 Level Gray 1 4
256 Level Gray 1 8
24-bit Color 3 8

Note: Palletized color images are not supported.

See the Overview topic for more information on Scanner Settings and examples.

Example

The following code could be used to set the scanner mode to 256-level gray scale.
ISISXpress.ScanSetting = ISX_ScanSetting.ISX_SamplesPerPixel
ISISXpress.SettingLong = 1
ISISXpress.ScanSetting = ISX_ScanSetting.ISX_BitsPerSample
ISISXpress.SettingLong = 8

The following code could be used to set the Brightness for the scanner.

ISISXpress.ScanSetting = ISX_ScanSetting.ISX_Brightness
ISISXpress.SettingLong = 23

Not all settings have an integer setting such as Brightness. The ISX_ScanSetting.ISX_PageSize property is usually a string and must be set with the SettingString property. For Example:

ISISXpress.ScanSetting = ISX_ScanSetting.ISX_PageSize
ISISXpress.SettingString = "scanners maximum"

See Also

ScanSetting Property | SettingLong Property | SettingString Property | Overview


ISX_SetupOptions Enumeration

ISX_SetupOptions Enumeration
AccusoftISISXpress5 ActiveX DLL : ISX_SetupOptions Enumeration

Glossary Item Box

Description

Option values for the Setup Method to modify what is displayed by the predefined scanner settings dialog.

Members

Member | Value | Description
ISX_Area | 2 | Displays a scanner settings dialog that shows the Area button. When the Area button is clicked, an Area dialog will be displayed.
ISX_AreaPreview | 8 | Displays a scanner settings dialog that shows the Area button. When the Area button is clicked, an Area dialog, containing a preview window, will be displayed.
ISX_Binary | 1 | Displays a scanner settings dialog that only allows binary modes. This prevents the user from choosing grayscale or color modes.
ISX_Normal | 0 | Displays the normal scanner settings dialog.
ISX_Return | 4 | Displays a scanner settings dialog that will return SCANERR_CANCEL if the user clicks the Cancel button. If this flag is not set, then the settings dialog will always return with no error.

Remarks

The predefined scanner settings dialog allows the user to change driver specific scanner settings.

ISX_SetupOptions is a flag enumeration that can be treated as a bit field or a set of flags. The following example shows how this enumeration can be used:

Setup (hWnd, ISX_SetupOptions.ISX_Binary | ISX_SetupOptions.ISX_Return);

See Also

Setup Method


ISX_Source Enumeration

ISX_Source Enumeration
AccusoftISISXpress5 ActiveX DLL : ISX_Source Enumeration

Glossary Item Box

Description

Option values for the ISX_ScanSetting.ISX_Type setting.

Members

Member | Value | Description
ISX_Automatic | 0 | Scan from the Automatic Document Feeder (ADF) if detected; otherwise, scan from the flatbed.
ISX_BackFront | 5 | Scan in duplex mode, but return the back side of the page first.
ISX_BackOnly | 6 | Scan only the back side of the page (duplex scanner).
ISX_Duplex | 4 | Scan in duplex mode.
ISX_Feeder | 3 | Scan from the feeder (front side only if duplex).
ISX_Flatbed | 2 | Scan from the flatbed.
ISX_Transparency | 1 | Scan from the transparency unit.


Empty Index Entry
Send Feedback

Glossary Item Box

Empty Index Entry

The index entry you selected has no target topics associated with it.

If you have chosen a parent entry, please select a child entry.


Topic Not Found
Send Feedback

Glossary Item Box

Topic Not Found

The link you just clicked was not able to connect to the target page.

Some possible reasons and remedies are as follows:

Reason | Remedy
Destination topic is not part of the area you specified in the Filtered by field. | Either select another filter or select (no filter).
The URL of the destination topic is incorrect or has changed. | Use the index or the search function instead.
Problems with the help installation. | Rerun Setup for the product this help is related to and select the 'Repair' option.

Additional help is available for filters, search, and the index.

Click Back to return to the page you were on.

The target parameters are:

Keyword:
Index Moniker:
URL:


Getting Started - Accusoft ISIS Xpress 5

Getting Started
Send comments on this topic.

Glossary Item Box


Getting Started - Accusoft ISIS Xpress 5

Introduction
Send comments on this topic.

Glossary Item Box


Project Overview

Project Overview
Send comments on this topic.

Glossary Item Box

Description

Accusoft ISIS Xpress 5

Classes

Class Module | Description
ISISXpress | The ISISXpress Object is the main controller component of the ISIS Xpress toolkit.

Public Enumerations

Enumeration | Description
ISX_DataTypeInfo | Option values for the data type the information is encoded in for the current scanner setting.
ISX_ErrorLevels | Option values for the error level to use for the ISIS Xpress control.
ISX_Errors | Option value for error numbers and error descriptions for the various errors that can occur.
ISX_Evaluation | Option values for the licensing evaluation choices that are available with ISIS Xpress.
ISX_SaveFileType | Option values for the file format to use when saving images.
ISX_ScanAheadChoice | Option values for the ISX_ScanSetting.ISX_ScanAhead setting.
ISX_ScanSetting | Option values for determining which scanner setting to query or set.
ISX_SetupOptions | Option values for the Setup Method to modify what is displayed by the predefined scanner settings dialog.
ISX_Source | Option values for the ISX_ScanSetting.ISX_Type setting.


References

References
Send comments on this topic.

Glossary Item Box


a
about
after
against
all
along
also
although
am
among
an
and
are
as
at
be
became
because
been
being
between
but
by
can
caution
come
could
details
did
do
does
doing
done
during
each
early
far
finally
for
found
from
had
has
have
he
her
here
his
how
however
I
if
in
include
including
information
into
is
it
its
late
later
made
many
may
me
med
might
more
most
near
no
non
none
nor
not
note
of
off
on
only
or
other
over
saw
see
seen
several
she
since
so
some
such
than
that
the
their
them
then
there
these
they
this
those
through
tip
to
too
under
until
up
us
use
very
warning
was
we
were
when
where
which
while
who
with
you