Glossary Item Box

PegasusImaging.WinForms.OcrXpress1

 Send comments on this topic.

What is OCR Xpress

OCR Xpress™, Version 1 is a powerful full-page Optical Character Recognition (OCR) product. It supports creation of searchable documents for distribution to end users, opening images, deskew, automatic binarization, automatic image rotation, segmentation into image and text elements, text recognition (OCR), and output to various text or text plus image formats, including Microsoft® Word®-compatible RTF files and standard Adobe® PDF files. The OCR Xpress component is based on the technology in the Open RTK SDK v7 from ExperVision, Inc.

Primary Features Include:

  • Text recognition (OCR)
  • Multiple language recognition
  • Text correction capability
  • Perform operations on bitonal and color images, including the ability to export the original color images to a searchable document.
  • Image pre-processing
    • Binarization
    • Deskew
    • AutoRotate
  • Automatic image and text segmentation
  • Export to various document formats

OCR Xpress Editions:

OCR Xpress version 1 is offered in two editions, Standard and Professional, as listed below. OCR Xpress Professional is the default edition which has the maximum functionality available.

  • OCR Xpress Standard: includes ImagXpress™ Document, ThumbnailXpress™, NotateXpress™, TwainPRO™, PrintPRO™ and an edition of OCR Xpress with output in all formats except searchable PDF.
  • OCR Xpress Professional: includes ImagXpress Document, ThumbnailXpress, NotateXpress, TwainPRO, PrintPRO and an edition of OCR Xpress with output in all formats including image-only PDF, searchable PDF (normal), and PDF (image over text).

Additional Pegasus Imaging components in OCR Xpress™ include:

  • ImagXpress™ for image import from various formats and advanced image enhancement and clean up.
  • NotateXpress™ for adding image annotations.
  • PrintPRO™ for printing.
  • ThumbnailXpress™ to view thumbnail images.
  • TwainPRO™ to acquire images from TWAIN devices.

Note: The input image can be color or grayscale and OCR Xpress will automatically create a bitonal copy before any auto rotation, deskew, location, or recognition is performed. Conversion from color or grayscale images is also available by using the included ImagXpress component.

For information on how to register and license all your Pegasus Imaging components, see Licensing.

© 1997 - 2007, Pegasus Imaging Corporation, All Rights Reserved.


Glossary Item Box

License Agreement

See Also

PegasusImaging.WinForms.OcrXpress1

 Send comments on this topic.

Getting Support and Samples

Benefits of Registering your Pegasus Development Kit

Purchasers of development kits need to register with Pegasus in order to be notified of updates and receive support now or in the future. Registration is automatic when purchased directly from the Pegasus web site. If purchased through a Pegasus re-seller, please register your purchase by filling out the form at PegasusImaging.com/registration.htm.

Vehicles for Support

Samples

Samples are included in the downloaded installation.

The product installation program installs a common sample folder accessible via the Start Menu.

Samples for the .NET framework:

  • Microsoft VisualBasic.Net
  • Microsoft C#

Access the samples

  • Through the Windows Start menu: Start | Programs | Pegasus Imaging | OCRXpress| Samples
  • Sample image files included

Sample Code Newsgroups

Customers create samples of great benefit to other developers, so we created a Sample Code Newsgroup. This is a newsgroup for our customers and potential customers. They post and receive sample code from our development team and other developers to expedite their development. Go online at:

http://www.PegasusImaging.com/samplecode.htm

Web Support

Visit the Pegasus Imaging web site frequently asked questions page ( PegasusImaging.com/faq.htm ) for the fastest answers to common questions. The web site also provides other support options that are accessible at PegasusImaging.com/supportagree.htm.

E-mail Support

Both pre-sale and post-sale e-mail support is offered free of charge. Questions are answered on a First-Come-First-Served basis. Support@JPG.com responds instantly to e-mail received with a helpful set of locations to find additional information on Pegasus products including FAQ's, sample code, newsgroup locations and other current information pertaining to the use of the products. The support request is then added to the queue of outstanding requests. The goal of the support team to respond to each e-mail within 1 business day.

The sales team is always available as a backup to the support team. If you feel you have an urgent support or sales issue please contact Sales@JPG.com . They will assist you promptly.

Newsgroup Support

The Publicly accessible NNTP news groups located at News.PegasusImaging.com are available for each of the Controls as well as advanced imaging technology and a sample code group. We expect that the development community will freely access and search these newsgroups to find common questions and answers regarding specific uses of the controls.

On-Demand Phone Support

On-demand priority phone support can be purchased in 15 minute increments with a credit card via the Pegasus Imaging Corporation web site Support, General Info page. If you decide to purchase "on-demand" phone support, instructions will immediately be e-mailed upon receipt of your purchase.

Additionally, Pegasus offers three support plans for those customers whose commercial products or projects are sensitive or critical in nature, where immediate response and 'latest release' code are important.

1. Chariot Support

All Pegasus Imaging customers are given the opportunity to purchase a Chariot Support agreement. This is a maintenance and upgrade agreement that entitles customers to priority e-mail service, direct phone support from the support and development staff and free product upgrades for the covered products. Since upgrades are included for Chariot customers at no additional charge, Chariot customers can frequently save money, plus obtain the benefits of phone and expedited support. Pegasus Imaging reserves the right to change the terms of this service at any renewal period. Send e-mail to Sales@JPG.com for more information.

2. Galleon Support

Customers are given the opportunity to purchase Galleon Support for Pegasus Imaging products that are applications and for products that require runtime licensing. Galleon Support includes licensing of product upgrades for deployed installations at no additional license fee cost.Pegasus Imaging reserves the right to change the terms of this service at any renewal period. Send e-mail to Sales@JPG.com for more information.

3. Atlas Support

All Pegasus Imaging customers are given the opportunity to purchase an Atlas Support agreement on currently supported products. This is an agreement that entitles customers to priority e-mail service and direct phone support from the support and development staff. It differs from Chariot Support in that it does not include version upgrades free of charge. Pegasus Imaging reserves the right to change the terms of this service at any renewal period. E-mail Sales@JPG.com for more information.

To determine if you have the latest version of a Pegasus Imaging development toolkit, please download the PegConnect utility program. Please note that a Help File for each product may be found on the Start bar under Pegasus or in C:\Windows\Help.

For the latest and most up-to-date support information, access PegasusImaging.com/contactsupport.htm

See Also

License Agreement


Glossary Item Box

PegasusImaging.WinForms.OcrXpress1

 Send comments on this topic.

Pegasus Imaging Corporation

Pegasus Imaging is uniquely positioned to serve as your leading imaging technology supplier. A full suite of document imaging toolkits, forms processing technology, medical image compression SDKs, photo editing and compression libraries, browser-based image viewers, and video codecs provide advanced technology designed to enhance imaging software solutions. Fully functional trial downloads and customer-acclaimed support allow you to be certain your requirements will be met before purchase. Work with the best. Choose Pegasus Imaging for all your imaging needs.

Visit www.pegasusimaging.com for full product descriptions, FAQ's, downloads, demos, and contact information.

Pegasus Imaging

4001 North Riverside Drive

Tampa, FL 33603Frame

Sales: 813-875-7575

Fax: 813-875-7705

Copyrights & Trademarks

Pegasus and the Pegasus Horse Logo are registered marks (®) of Pegasus Imaging Corporation.

Barcode Xpress, CapturePRO, FilePrinter, FormAssist, FormDirector, FormSuite, ImagXpress, ISIS Xpress, The JPEG Wizard, MedXpress, NotateXpress, OCR Xpress, PDF Xpress, PICTools, ePIC, PICVideo, PrintPRO, SmartScan Xpress, SmartZone, ThumbnailXpress, and TwainPRO are trademarks (™) of Pegasus Imaging Corporation.

FormFix, ScanFix, Prizm, ColorDrop, ColorEnhance, ColorFind, ColorForms, CompressDirector, Digital Mark Recognition (DMR), Image Detergent, ViewDirector and Virtual Scoring Center (VSC) by assignment are trademarks (™) or registered trademarks (®) of Pegasus Imaging Corporation.

Pegasus Imaging and/or its agents use these marks and brand names in connection with its goods and/or services, in the United States and other countries. Information in this document is subject to change without notice. No part of this document may be reproduced or transmitted in any form or by any means, electronic or mechanical, for any purpose, without the express written permission of Pegasus Imaging Corporation.

Microsoft, Microsoft.NET, Visual Basic, Visual Studio and Visual Studio.NET are trademarks of Microsoft Corporation in the USA and/or other countries. All other product and brand names are the property of their respective owners.


Glossary Item Box

Getting Support and Samples

PegasusImaging.WinForms.OcrXpress1

 Send comments on this topic.

Operating Requirements

OCR Xpress Operating Requirements

Operating Systems

OCR Xpress runs on 32-bit Microsoft Windows operating systems: 2000 Professional and Server, XP Home and Professional and Server 2003. It works with 32-bit Windows versions running on 32 and 64-bit processors. It runs in 32-bit executables running under 64-bit Windows 2000 Server and 2003 Server. Although it may run, it is not supported on previous Windows versions (for example, Windows 95 and Windows 98).

Threading

Pegasus considers thread-safe to be when an application using this component can use multiple controls running in the same process, where they don't interfere with each other. The thread creating the control owns the control and is the only thread that can interact with it.

Development environment

Microsoft .NET Framework 1.1, 2.0

Microsoft Visual Studio .NET 2003

Microsoft Visual Studio 2005

Caching Data and Memory Usage

During normal operation OCR Xpress caches data to temporary files on the hard drive. The size of the image and the amount of text on an image dictate how much hard drive space each page uses. Each page added to a document also increases the amount of hard drive space needed. To ensure effective operation, there should be 7 to 8 MB of hard drive space for each 8 1/2 by 11 inch 300dpi 24bpp page of full text at 12pt font size.

See Also

Getting Support and Samples


Glossary Item Box

PegasusImaging.WinForms.OcrXpress1

 Send comments on this topic.

Installing on a Development Machine

To Install OCR Xpress Component

Run the downloaded setup program which installs the development kit on your development machine.

The downloaded development kit includes code samples for supported platforms. Samples are available through the Start|Programs|Pegasus Imaging|OCRXpress menu.

By default this will register trial licensing which allows you to develop applications but not to distribute them. The trial license allows testing of all the functions and features.

Please see the topic 'Distributing with Your .NET Application' to understand the limits and details to converting licensing editions.
In order to distribute your finished application you must purchase and install a fully paid license from Pegasus Imaging Corporation. The paid licenses override trial licenses.

To Use OCR Xpress Help Files

Stand-alone Help file "PegasusImaging.WinForms.OcrXpress1.chm"

Access the OCR Xpress stand-alone help through the Windows Start menu: Start | Programs | Pegasus Imaging | OCRXpress

The stand-alone complied Help chm file is created with MS Help system version 1. To view Help 1 files, you must have:

  • Windows 2000 (to view the file via the Windows HTML Help Viewer)
  • Internet Explorer 4 or higher
  • MS HTML Help Viewer

From within your Visual Studio Development Environment, compiled collection help file "PegasusImaging.WinForms.OcrXpress1.hxs"

Help 2 collection files install into Visual Studio.NET (VS). To view Help 2 files, you must have:

  • Windows 2000 or higher
  • Internet Explorer 6 or higher
  • Visual Studio .NET 2002 or higher
  • MS Help version 2

When OCR Xpress installs, if the system installation requirements for Help 2 files are met, the Help 2 file is included on the Start shortcut menu. If the installation requirements for Help 2 files are not met, then the Help 1 file installs on the Start shortcut.

Plugging OCR Xpress Help into Visual Studio

OCR Xpress Help 2 files integrate within the Help system in Visual Studio .NET. To access OCR Xpress Help within Visual Studio, do the following:

  • Ensure that the MSDN Library is installed in your Visual Studio environment. If it is not installed, re-install it from your VS.NET disc.
  • Ensure that MS Help Integration Kit is installed in your Visual Studio environment. If you do not have it installed:

1. Download the Help Integration kit from MSDN

2. Close Visual Studio.

  • Re-open Visual Studio, select the Help Menu and the Contents submenu. Verify Help files for Pegasus Imaging controls are listed.

If Pegasus Help is not listed:

  1. Search for "VSCC" in Visual Studio Help, leaving the "Filtered by:" list box blank. Select the "Visual Studio .NET Combined Help Collection Manager" topic.
  2. Select the Help 2 collections available on your PC under the heading "Collections available for inclusion in VSCC."
  3. Take care when excluding Help collections from the default VSCC collection. These collections may be necessary to view required documentation. Instead, use the "Filtered by:" field on the Contents tab of the Help panel to focus searches on Pegasus Imaging topics. Leave the "Filtered by:" list box empty to view the entire Pegasus Imaging Help files.
  4. Select the Update VSCC button.
  5. Close all instances of Visual Studio and Microsoft Document Explorer. When you restart Visual Studio, the VSCC Help collection revises with your changes. (Note: this may take several minutes.)
  6. Check the Visual Studio Help/Contents tab again to see the Help collections available to you.
  • Select the OCRXpress Help file to view Help content.


Glossary Item Box

EvaluationMode Property | License Property | LicenseEdition

PegasusImaging.WinForms.OcrXpress1

 Send comments on this topic.

Trial Mode

Default Installation

The default installation installs Trial Mode licensing. This allows you to test features and functions and develop applications but not distribute them. Installing OCR Xpress in trial mode provides you with access to all features and functionality of the OCR Xpress product. E-mail support is available with the trial license.

When using the trial version of OCR Xpress, an evaluation dialog box displays periodically. In addition, while using the trial version, OCR Xpress will randomly replace portions of text in the output with www.PegasusImaing.com. Applications built with a trial license can only be run on a computer that has OCR Xpress Licensing installed on it.

Changing Trial Mode Behavior

You have the flexibility to change the behavior of OCR Xpress in evaluation mode as follows:

  • To facilitate server/service mode evaluations, you can choose to halt the component processing after 5 minutes in lieu of displaying an evaluation dialog box periodically. This is the TimeOut setting for the License.EvaluationMode property.

Changing OCR Xpress Edition

Installing OCR Xpress in trial mode enables you to try out all the editions and add ons associated with OCR Xpress, by setting the License.LicenseEdition property. Any edition for which you do not have paid licensing will display the evaluation dialog box or timeout. For example, if you have paid licensing for the OCR Xpress Standard and you would like to evaluate OCR Xpress Professional, you can change License.LicenseEdition property from Standard to Professional and use the functionality of Professional with evaluation dialog boxes displayed periodically.

See Also

EvaluationMode Property | License Property | LicenseEdition


Glossary Item Box

Trial Mode | License Agreement | Getting Support and Samples

PegasusImaging.WinForms.OcrXpress1

 Send comments on this topic.

Development Mode

To suppress the evaluation dialog box and deploy your application, or attain technical support (beyond e-mail), as well as future product updates and upgrade notifications, you must update from a trial version to a paid version of the OCR Xpress development kit.

1. Purchase Development Kit(s)

To purchase licensing of the OCR Xpress development kit, use one of the following options:

  • Purchase online at http://www.PegasusImaging.com/. Contact Sales@PegasusImaging.com.
  • Contact a Pegasus Imaging Corporation reseller.

When the development kit is purchased, we e-mail a serial number & registration code to you. You need these codes to upgrade from trial to paid licensing.

2. Register the OCR Xpress Product

When you purchase OCR Xpress online or through Sales@JPG.com, your product ownership is automatically registered.

To register products purchased through a reseller, use the form found at http://www.PegasusImaging.com/registration.htm.

If your registration information should change, visit http://www.PegasusImaging.com/contact.htm for forms to update registration information.

3. Update Your OCR Xpress product version from trial to paid licensing

Updating your OCR Xpress from trial to paid licensing will suppress the evaluation dialog box or timeout. This must be done for each component within the OCR Xpress toolkit that you are using (for example, OCR Xpress, ImagXpress, NotateXpress or other included components). The email you receive when you purchase the product will include entries for each component.

To update components from trial to paid licensing

  • Enter your new license codes using one of the following options:
    • Enter licensing information (serial number, registration code and personal registration information) during component installation while downloading the latest release from www.PegasusImaging.com (the recommended approach).
    • Alternatively, licensing information (serial number, registration code and personal registration information) can be entered through the Visual Development Environment in response to the dialog display.
  • Rebuild any applications that used the components with trial licensing

To distribute OCR Xpress in an application, you must acquire runtime unlock codes (See Distributing with Your .NET Application).

See Also

Trial Mode | License Agreement | Getting Support and Samples


Glossary Item Box

PegasusImaging.WinForms.OcrXpress1

 Send comments on this topic.

Runtime Licensing

Runtime & Deployment Licensing

All copyrights to Pegasus Imaging development kits and software are retained by Pegasus Imaging Corporation. ALL RIGHTS RESERVED. Your use of any of Pegasus Imaging software or run-times created with Pegasus Imaging software is allowed under license terms granted by Pegasus Imaging. It is the Licensee's responsibility to honor the terms of such license grants.

Locking Mechanism

OCR Xpress contains a locking mechanism that does not permit you to distribute applications created with evaluation versions of OCR Xpress. Prior to distributing an application that utilizes OCR Xpress, you must purchase and enable run-time licensing. If the application will be delivered on the web, you must also purchase and enable web application licensing.

Obtaining Appropriate Licensing

The Licensee is required to purchase one copy of our development kit(s) for each developer in addition to obtaining the appropriate license agreement prior to deploying applications which contain Pegasus code.

Pegasus Imaging software applications and development tools are limited for use on a single CPU. Any runtimes or copies created must be granted by a direct license from Pegasus Imaging Corporation. These "end user" licenses provide the terms and limits of number and usage.

All prospective customers have every opportunity to evaluate Pegasus Imaging's products prior to purchasing. Product licensing is priced to cover what is considered to be normal (and even high) use. In addition, Pegasus Imaging fully supports and warrants its code and pricing reflects those costs as well. The larger and more valuable an application deployment is, the higher the support and warranty risk is for Pegasus.

Review the licensing categories, and select the one that matches your deployment. Special circumstances should be discussed with a Pegasus Imaging representative.

For more information on Runtime licensing, see the Pegasus Imaging website for more detailed information regarding Runtimes and Deployment Licensing.


Glossary Item Box

PegasusImaging.WinForms.OcrXpress1

 Send comments on this topic.

License Agreement

Pegasus Imaging Corporation

SOFTWARE LICENSE AGREEMENT

GRANT OF LICENSE

This Pegasus Imaging Corporation ("PEGASUS") Agreement ("License") permits Licensee ("LICENSEE") the right to use one copy of a properly registered Pegasus Development Toolkit ("TOOLKIT") for development purposes on any single computer, provided the TOOLKIT is in use on only one computer at any time. TOOLKIT is "in-use" on a computer when it loads into temporary memory (that is, RAM) or installed into the permanent memory (that is, hard disk, CD-ROM, or other storage device) of that computer.

REDISTRIBUTION OF THE TOOLKIT RUNTIMES

PEGASUS does not grant any runtime licenses with the TOOLKIT purchase, except by specific exemptions described on our licensing web pages. For Runtime Licensing information, please visit our web site (http://www.PegasusImaging.com/licensing.htm), or contact our sales staff. Any rights to distribute TOOLKIT run times as part of the LICENSEE's software application or derivative works ("PRODUCT"), require you to acknowledge and uphold this License Agreement and agree to notify PEGASUS immediately of any changes in status or violations. In cases where PEGASUS grants the LICENSEE a right to use, reproduce, display or otherwise distribute or transfer copies of TOOLKIT run times, LICENSEE agrees and affirms the following:

a) LICENSEE is not using PEGASUS' name, logo, or trademarks to market PRODUCT without prior written approval of PEGASUS.

b) LICENSEE agrees to indemnify, hold harmless and defend PEGASUS from and against any claims or lawsuits, including attorney's fees, that arise or result from the use or distribution of PRODUCT.

c) Only the TOOLKIT run times can be distributed. Distribution of the TOOLKIT development kit, documentation, source code, or the distribution unlock codes, is a violation of this agreement.

d) LICENSEE includes a statement substantially similar to the following within derivative work's documentation and about box: "This product contains portions of imaging code owned by Pegasus Imaging Corporation, Tampa, FL, (www.PegasusImaging.com). ALL RIGHTS RESERVED."

If ANY of the above terms are not applicable to LICENSEE'S situation, or any of the above cannot be complied with, or LICENSEE needs modifications to this license, for any reason; then LICENSEE shall obtain an expanded direct license from PEGASUS for derivative works, (available by phone at: 813-875-7575, x321, by e-mail at: Sales@jpg.com or by fax at: 813-875-7705).

PEGASUS reserves the right to charge the LICENSEE up to ten times the normal license price for the use of each unlicensed copy of PRODUCT. The license granted herein and all of your rights to use or maintain possession of TOOLKIT shall terminate immediately upon breach of any material provisions of this Agreement.

This license grants rights to LICENSEE for only the PEGASUS code (TOOLKIT) mentioned above and does not convey any other rights of use or distribution to PEGASUS technology.

COPYRIGHT

The Software is owned by PEGASUS or Pegasus Imaging Corporation and is protected by United States copyright laws and international treaty provisions. LICENSEE may not remove or alter the copyright notice from any copy of the Software or any copy of the written materials, accompanying the Software.

OTHER RESTRICTIONS

This PEGASUS License Agreement is LICENSEE's proof of license to exercise the rights granted herein and must be retained by LICENSEE. LICENSEE may not rent, lease or transfer TOOLKIT or parts thereof. LICENSEE may not reverse engineer, decompile or disassemble TOOLKIT.

NO WARRANTY

ANY USE BY LICENSEE OF THE SOFTWARE IS AT THE LICENSEE'S OWN RISK. THE SOFTWARE IS PROVIDED FOR USE ONLY WITH WINDOWS PRODUCTS AND RELATED APPLICATION SOFTWARE AND/OR HARDWARE PRODUCTS. THE SOFTWARE IS PROVIDED FOR USE "AS IS" WITHOUT WARRANTY OF ANY KIND. TO THE MAXIMUM EXTENT PERMITTED BY LAW, PEGASUS DISCLAIMS ALL WARRANTIES OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, WITHOUT LIMITATION, IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. PEGASUS IS NOT OBVLIGATED TO PROVIDE ANY UPDATES TO THE SOFTWARE.

NO LIABILITY FOR CONSEQUENTIAL DAMAGES

In no event shall PEGASUS be liable for any damages whatsoever (including, without limitation, incidental, direct, indirect and consequential damages, damages for loss of business profits, business interruption, loss of business information, or other pecuniary loss) arising out of the use or inability to use this PEGASUS product, even if PEGASUS has been advised of the possibility of such damages. Because some states/countries do not allow the exclusion or limitation of liability for consequential or incidental damages, the above limitation may not apply to LICENSEE.

INDEMNIFICATION BY LICENSEE

If LICENSEE distributes TOOLKIT in violation of this Agreement, LICENSEE agrees to indemnify, hold harmless and defend PEGASUS and its suppliers from and against any claims or lawsuits, including attorney's fees that arise or result from the use or distribution of TOOLKIT in violation of this Agreement.

This Agreement is governed by the laws of the State of Florida. The program and data contained in this TOOLKIT Product are provided with Restricted Rights. Use, duplication, or disclosure by the U.S. Government is subject to restrictions as set forth in FAR 52.227-14 (Alternate III) or subparagraph (c)(1)(II) of the rights in technical data and computer software clause at 252.227-7013. Manufacturer is Pegasus Imaging Corporation, 4001 Riverside Drive, Tampa, FL, 33603.

For questions concerning this Agreement, or to contact PEGASUS for any reason, please contact Pegasus Imaging Corporation by phone at 1-813-875-7575 x321 or email Sales@JPG.com.


Glossary Item Box

Getting Support and Samples | License Agreement

PegasusImaging.WinForms.OcrXpress1

 Send comments on this topic.

Verify You Are Using the Latest Service Pack

Verify Latest Development Components

To verify you are using the latest version of a Pegasus Imaging Development Component or Components, please use the PegConnect utility program. Please note that a Help File for each product may be found on the Start Bar under Pegasus, or in C:\Windows\Help.

PegConnect is installed by all component product installers and is accessible through the Windows Start menu:

Start | Programs | Pegasus Imaging | Common | Utilities

PegConnect allows you to:

1) Check with Pegasus Imaging via online connection and verify that the installed version of the component includes all the most recent updates

2) Update to the latest version automatically with your permission

3) Determine if a control is registered or unregistered on the machine

4) Easily change the registration status from registered to non-registered, or non-registered to registered

Alternatively, you can see the currently released product build numbers at http://www.PegasusImaging.com/latestbuilds.htm.

If you require further assistance or have questions or comments, please see the topic on Getting Support for more detailed information.

See Also

Getting Support and Samples | License Agreement


Glossary Item Box

Trial Mode | Runtime Licensing | Verify You Are Using the Latest Service Pack

See Also

PegasusImaging.WinForms.OcrXpress1

 Send comments on this topic.

Distributing with Your .NET Application

Distributing OCR Xpress

Check for Proper Licensing and Unlock Codes

OCR Xpress contains a locking mechanism that does not permit you to distribute applications created with evaluation versions of OCR Xpress. Prior to distributing an application that utilizes OCR Xpress, you must purchase and enable run-time licensing. If the application will be delivered on the web, you must also enable web application licensing.

DLL Files to Distribute

Distribute the appropriate assembly DLL files with applications using the OCR Xpress Product.

PegasusImaging.WinForms.OcrXpress1.dll - .NET component - Needed for full-page OCR, text and image creation with export to multiple formats including PDF and RTF.

See Also

Trial Mode | Runtime Licensing | Verify You Are Using the Latest Service Pack


Glossary Item Box

PegasusImaging.WinForms.OcrXpress1

 Send comments on this topic.

Definitions, Acronyms and Abbreviations

Pegasus Imaging Definitions:

PIC: Pegasus Imaging Corporation

Region: an area defined by rectangular coordinates on a page.

Segmentation: partitioning of an image into regions.

Style Run: - identifies a particular font mapping, character style and point size for a specified number of characters within each recognized text line.

Suspect Character: a character which was recognized with a low confidence level.

Thread-safe: an application using this component can use multiple controls running in the same process, where they don't interfere with each other. The thread creating the control owns the control and is the only thread that can interact with it.

Industry Terms:

Bitonal: 1 bit per pixel black and white image.

Binarize: the process of creating a bitonal image from a color or grayscale image.

BPP: Bits Per Pixel

Deskew: a process to adjust the angle of an image so that it is straight (no longer skewed).

Electronic Document: a document that has been scanned, or was originally created on a computer.

Forms Processing: an imaging application for handling printed forms. Forms processing systems often use OCR engines and data validation routines to extract hand-written or printed information from forms that go into a database.

Noise: irrelevant or meaningless data

OCR (Optical Character Recognition): reading text from paper and translating the images into a form that the computer can manipulate.

PDF: the standard PDF format that contains text and images. The appearance may differ slightly from the original image.

PDF Image Only: a PDF format that contains the original image only. The text is not searchable.

PDF Image with Text: a PDF format that contains a bitmap image of the original image plus hidden, searchable text.

RTF: Rich Text Format. Allows import into word processors such as Microsoft Word.

Unicode: a character set that can support a wide range of international characters. Unicode requires 16-bits to encode a character, unlike ASCII, which requires only 8 but supports only a small subset of characters beyond latin.

UI (User Interface): the controls or API provided for user interaction with an application or component.


Glossary Item Box

Supported Languages and User Dictionary | OcrXpress Class | Document Class | Page Class | RegionCollection Class | Results | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also

PegasusImaging.WinForms.OcrXpress1

 Send comments on this topic.

Overview

Because businesses today are standardizing portions of their workflow by using PDF documents as an important information-distribution medium, conversion of images obtained by FAX or scanners to searchable PDF text documents is very valuable. OCR Xpress adds this full page OCR and export capability to Pegasus Imaging's suite of document processing solutions. OCR Xpress allows customers to rapidly build and deploy applications that can create searchable or editable documents such as RTF or searchable PDF files from images such as TIFFs.

In addition to using OCR Xpress in an end-to-end product solution for converting full page images into searchable text, there are several other uses in which customers may apply OCR Xpress functionality. OCR Xpress has a very fast automatic rotation feature that returns the amount of rotation applied. This applied rotation information could be used in other document processing applications to correctly orient images that contain text. The results from OCR Xpress recognition can also be used as a secondary OCR voting engine in conjunction with another OCR engine, such as the Pegasus component, SmartZone™, to help improve OCR results.

The OCR Xpress toolkit provides support in the following areas:

  • Opening images using ImagXpress or accepting images though memory transfer.
  • Automatic binarization of 8-bit grayscale images or 24-bit color images.
  • Auto-rotation of images that are turned 90, 180 or 270 degrees.
  • Deskew of images that are skewed due to scanning issues.
  • Auto-location of picture regions and text regions.
  • Numerous languages supported for text recognition (OCR).
  • Access text results programmatically.
  • Export to various text or text plus image formats, including Microsoft Word-compatible RTF files and standard Adobe PDF file formats.
  • Text proofing and character replacement is supported by identification of suspect characters.

OCR Xpress supports recognition of text in the languages of English, French, German, Italian, Spanish, Portuguese, Danish, Dutch, Swedish, Norwegian, Hungarian, Polish, and Finnish. All languages ship and install with all editions of OCR Xpress. Users specify one language prior to performing recognition on the image.

The OCR Xpress component is composed of several objects, listed below, to easily facilitate the conversion of images into text or text and image documents.

OcrXpress Class

The OcrXpress object is the main object to manage component level operations, such as licensing, debug logs and the about box. It also contains the Document property which is an instance of the Document class.

Document Class

OCR Xpress uses the concept of a Document object where a document contains one or more pages. The Document object is used to represent the final output at the time of Export. In addition, a number of properties that apply across all pages in the document are maintained at the document level. Many of these methods and properties affect location, recognition and export processes.

Page Class

The Page object is where an image that represents a single page is stored. When using color or grayscale images, the page maintains two versions of the image: the original color or grayscale; and a 1-bit black and white image (bitonal). If a bitonal image is used as input, only the bitonal image will be maintained in the page. The majority of the processing is performed on the bitonal image. The Page object also contains regions for recognition and the results after recognition.

Region Classes

Regions are used to direct the recognition process on where to look for text and when to ignore pictures. Accordingly, there are two types of regions: TextRegion; and PictureRegion. The picture regions are used during export to reconstruct the page with the original images (full color, grayscale, or bitonal) for export formats that use pictures and text. Text regions are used during recognition and during export to place the text in the appropriate location. Regions can be defined manually through the page methods, or can be identified automatically through the Document.Locate method. Manually defined regions and automatically located regions can be edited prior to recognition. The recognition process may adjust regions in order to improve the recognition process.

Results Classes

If it is necessary to access the results of the recognition process prior to export, for correction of text, or to use the result in another fashion, you can get the results objects through the Page object. The results are hierarchical. The TextBlockResult contains all of the recognized text for a text region. Within a TextBlockResult are TextLineResults that contain the actual text, information about the font styles, the location of the text from the original image, and a list of suspect characters.

See Also

Supported Languages and User Dictionary | OcrXpress Class | Document Class | Page Class | RegionCollection Class | Results | PegasusImaging.WinForms.OcrXpress1 Namespace


Glossary Item Box

Getting Support and Samples

PegasusImaging.WinForms.OcrXpress1

 Send comments on this topic.

Interaction with Other Pegasus Components

Although you can use OCR Xpress on its own, its ease of use can be greatly improved when used in conjunction with other Pegasus Imaging components as explained below.

ImagXpress

Included in the OCR Xpress package is ImagXpress. Use ImagXpress to perform image clean up for improved recognition and to easily import various formats into memory for use by OCR Xpress.

ScanFix® Xpress

For extreme cases of poorly captured images, Pegasus' ScanFix component can be used for additional clean up in order to improve the OCR Xpress recognition process. ScanFix is sold separately.

PDFXpress™

If you have PDF image files that you want to add searchable text to, you can use the Pegasus' PDF Xpress component to input PDF image files into OCR Xpress. PDF Xpress is sold separately.

FormSuite™

OCR Xpress can also be used with the FormSuite™ as a secondary OCR engine or to process form fields that are in a language other than English.

At no time does OCR Xpress automatically and directly interact with other Pegasus Imaging Corporation components. You must always manage that interaction. While this seems a little less convenient, it allows Pegasus Imaging to deliver flexible and quality components while allowing the freedom to mix and match component versions and vendors to create the best possible solution for your product.

Sample code for all interaction between our components and knowledgeable technical support are provided in case you have issues of any kind.

See Also

Getting Support and Samples


Glossary Item Box

ExportFormat | Export Method | MultipageExport Property | MultipageExport

See Also

PegasusImaging.WinForms.OcrXpress1

 Send comments on this topic.

File Output Formats

OCR Xpress writes directly from the component to output file formats

  • Use the Export method to define the ExportFormat options needed.
  • Use the MultipageExport to define the MultipageExport for how to break up the pages.

The available export formats are listed below for each edition:

Standard Edition

  • ASCII with no line breaks
  • ASCII with line breaks
  • ASCII with smart formatting (positioned with spaces)
  • ASCII, comma-delimited (one line per field)
  • ASCII, tab-delimited
  • Excel v2.x (Note: This format is compatible with a subset of later versions)
  • HTML, with a sub-folder of the same name containing images
  • PDF - Image only, PDF version 1.4 file
  • RTF - Used for import to Word, WordPerfect, etc.
  • WordPerfect 5.0, WordPerfect 5.1

Professional Edition

  • ASCII with no line breaks
  • ASCII with line breaks
  • ASCII with smart formatting (positioned with spaces)
  • ASCII, comma-delimited (one line per field)
  • ASCII, tab-delimited
  • Excel v2.x (Note: This format is compatible with a subset of later versions)
  • HTML, with a sub-folder of the same name containing images
  • PDF - Image only, PDF version 1.4 file
  • PDF - Normal, PDF version 1.4 file
  • PDF - Image with Hidden Text PDF version 1.4 file
  • RTF - Used for import to Word, WordPerfect, etc.
  • WordPerfect 5.0, WordPerfect 5.1

To modify editions, see the Trial Mode topic for more information.

See Also

ExportFormat | Export Method | MultipageExport Property | MultipageExport


Glossary Item Box

Basic Usage | Results | Font Maps

PegasusImaging.WinForms.OcrXpress1

 Send comments on this topic.

Workflow

Typical Workflow

OCR Xpress allows you to configure the workflow as you see fit. A typical workflow is shown in the image below. However, you may decided to include text proofing or character replacement between the Recognize and Export steps. You may also prefer to skip the export step all together and move the recognized text straight into a database.

Image Input

To input an image, call the AddPage method. Input to OCR Xpress is bitonal, gray and color images that may be candidates for OCR. For gray and color images to be used as input, a bitonal version of these images may be passed in, or one will be automatically created by this component. All image cleanup, region location and recognition processes use the bitonal image to improve processing. OCR Xpress only accepts images through in-memory transfer. Images are not opened from disk by the OCR Xpress component itself.

The supported formats include:

  • Win32 HDIB
  • HBITMAP
  • System.Drawing.Bitmap

Input Image Quality

The input quality of images may vary. You can improve the recognition if you set the image quality property to match the quality of the image. Define the various quality options through the Document.ImageQuality property using the appropriate ImageQuality enumeration

Image Pre-processing

OCR Xpress uses the bitonal image to perform optional pre-processing on the image, which may include AutoRotate and Deskew. The outputs of these methods are the 'corrected" color or grayscale images and "corrected" bitonal images.

Regions and Locate

Region Area

Regions define rectangular blocks within the pages' image where text and pictures exist. The recognition process will attempt to read text within the defined text regions.

Text Regions

Text regions are used during the recognition process. The text regions are also used during export to place the text in the correct order and location on the resulting document.

Picture Regions

The picture regions are used by the Document.Export method when an export format is used that supports embedded images. In this case, the original images (full color, grayscale or bitonal) are copied and arranged in the export file to reconstruct the original image layout.

Add Regions

Regions can be added manually through Page.SetRegions or automatically through the Document.Locate method, and edited as needed.

For more information on Regions, see Define and Use Regions topic in the How To section.

Recognize

OCR Xpress uses the bitonal image to perform OCR on the machine printed text within all automatically located text regions and user supplied text regions. To envoke this functionality, use the Recognize method on a particular Page. The output from this process is the recognized text as strings. In addition, the recognition process creates font maps that describe the formatting for the recognized text and suspect characters for the text that was difficult to recognize. During the recognition process, the regions may be updated to eliminate overlap and adjust the size of the regions for optimum performance. The results of recognition are used during the export process to create the output document. You can also use or edit the results yourself in other applications. See Results in the How To section for further details.

Export

The Export method creates a document that can contain unformatted text, formatted text or formatted text plus image data, in a variety of different file formats. To set the export format, pass in the format using the ExportFormat enumeration. Output text is delivered in a font that is closest in form to the recognized FontMap in a normal, bold, italic, or bold italic style, and scaled over a wide range of font sizes.

You can specify if multiple pages should be exported to one or many files, and with multiple files, where the split between files should occur. Set the MultipageExport property with the appropriate MultipageExport enumeration to define how multiple recognized pages are exported.

See Also

Basic Usage | Results | Font Maps


Glossary Item Box

Language | Language Property | UserDictionary Property

PegasusImaging.WinForms.OcrXpress1

 Send comments on this topic.

Supported Languages and User Dictionary

Supported Languages

OCR Xpress uses dictionaries to help improve its recognition process. OCR Xpress supports many languages by having dictionaries that are specific to those languages.

The Document.Language property allows you to get and set the language to perform recognition on. Within this property you'll set one of the supported languages from the Language enumeration.

Example to set a language:

// set the language to English

OcrX.Document.Language = PegasusImaging.WinForms.OcrXpress1.Language.English;

Note: The language must be set prior to recognition, and only one language may be used per recognition process.

User Dictionary

In addition to language dictionaries, you can create a user dictionary to add words to OCR Xpress’s vocabulary. For example, you may want to add proper names to a user dictionary to reduce recognition errors on those names. A user dictionary is a simple text file of words separated by carriage returns.

A valid word consists of the following characters:

  • A..Z
  • a..z
  • .(dot)
  • - (hyphen)
  • & (ampersand)
  • " (double quotes)
  • ' (single quote)

Plus several extended characters for international languages:

  • ANSI0192 - ANSI0207
  • ANSI0209 - ANSI0214
  • ANSI0216 - ANSI0220
  • ANSI0223 - ANSI0239
  • ANSI0241 - ANSI0246
  • ANSI0248 - ANSI0252

A User Dictionary may look something like this:

Once you have created the user dictionary, you only have to tell OCR Xpress where it is:

// set the user dictionary

ocrX.Document.UserDictionary = @"C:\myDictionary.txt";

Note: To turn off the user dictionary, set the UserDictionary property value to an empty string, “”.

See Also

Language | Language Property | UserDictionary Property


Glossary Item Box

Bonus Features

PegasusImaging.WinForms.OcrXpress1

 Send comments on this topic.

Basic Usage

OCR Xpress makes it very easy to create a full page OCR application. For the basics, there are only a few steps required to produce searchable text documents from images:

1. Create an Image Xpress ImageX object

PegasusImaging.WinForms.ImagXpress8.ImageX theSourceImage = null;

2. Load the image using ImageXpress

//Open the source file into an ImageX object for passing to OCR Xpress

   theSourceImage = PegasusImaging.WinForms.ImagXpress8.ImageX.FromFile(“MyFileName.tif”);

3. Create OCR Xpress object

//Create our OCR Xpress object for processing of the image data

PegasusImaging.WinForms.OcrXpress1.OcrXpress ocrx =

new PegasusImaging.WinForms.OcrXpress1.OcrXpress();

4. Add the page to the OCR Xpress Document

//Add the image to our OCR document.

using (System.Drawing.Bitmap theImage = theSourceImage.ToBitmap(false))

{

PegasusImaging.WinForms.OcrXpress1.Page thePage =

ocrx.Document.AddPage(theImage);

}

5. Recognize the page

//OCR the image to obtain results for exporting

ocrx.Document.Recognize(thePage);

6. Export

//Export the finished document to a PDF file

ocrx.Document.Export(PegasusImaging.WinForms.OcrXpress1.ExportFormat.PdfImageWithText , “MyFileName.pdf”);

See Also

Bonus Features


Glossary Item Box

PegasusImaging.WinForms.OcrXpress1

 Send comments on this topic.

Bonus Features

There are some other processing steps that may be useful, depending on the type of application you are building. AutoRotate and Deskew are also very easy to implement. To evaluate or manipulate the regions prior to recognition, you can manually call the Locate method to have access to the regions. If you don’t call the Locate method or manually specify the regions (see Regions under Workflow), the Recognize method will call the Locate method automatically.

1. Create an ImagXpress object

2. Load the image using ImagXpress

3. Create an OCR Xpress object

4. Add the page to the OCR Xpress Document

5. AutoRotate

//Correct the rotation of the page

rotationAngle = ocrx.Document.AutoRotate(ocrx.Document.GetPage(curPage));

6. Deskew

//Correct the rotation of the page

ocrx.Document.Deskew(ocrx.Document.GetPage(curPage));

7. Locate

//Locate the text and picture regions on the image

ocrx.Document.Locate(ocrx.Document.GetPage(curPage));

8. Recognize

9. Export


Glossary Item Box

PegasusImaging.WinForms.OcrXpress1

 Send comments on this topic.

Font Maps

FontMaps contain information about the font style of the Text and are used at export. As seen in the graphic below, a single line can have multiple FontMaps associated with it. The FontMap contains the StartPosition and the RunLength of the font style.

Note: In your application you cannot change the FontMap values.


Glossary Item Box

TextBlockResult Class | TextLineResult Class | PageResult Class | CharacterResult Class

See Also

PegasusImaging.WinForms.OcrXpress1

 Send comments on this topic.

Results

If you wish to do more with the results than simply export them to a searchable text document, access the results from the recognition process through the OCR Xpress interface.

In order to access the results, it helps to understand the relationship between TextRegions and TextBlockResults. During the region locate process, OCR Xpress identifies rectangular text regions and picture regions. The recognition process will attempt to read text within the defined TextRegion objects. The PictureRegion objects are used by the Export method when an export format is used that supports embedded images.

During the recognition process, OCR Xpress may adjust the TextRegions if they are overlapping or are not a perfect fit. After recognition, the TextRegion objects in the RegionCollection returned from the GetRegions method will correspond to the TextBlockResult objects returned by the GetTextBlockResult method from the PageResult class.

In addition, the hierarchy of the results can be seen in the object model diagrams under the Page class and the PageResult class.

Given this information, the steps to getting the results from a page are as follows:

  • Call the GetResult method from the Page object, which returns a PageResult object.
  • Loop for TextBlockCount iterations
    • Call the GetTextBlockResult method passing in the TextBlock index which returns a TextBlockResult
    • Loop for TextLineCount iterations
      • Call the GetTextLineResult method passing in the TextLine index which returns a TextLineResult
      • Loop for FontMapCount iterations
        • Call the GetFontMap method passing in the FontMap index which returns a FontMap object
      • Loop for SuspectCharacterCount iterations
        • Call the GetSuspectCharacter method passing in the SuspectCharacter index which returns a CharacterResult

See Also

TextBlockResult Class | TextLineResult Class | PageResult Class | CharacterResult Class


Glossary Item Box

TextLineResult Class | CharacterResult Class

PegasusImaging.WinForms.OcrXpress1

 Send comments on this topic.

Text and Text Correction

Text

The actual text is stored in the TextLineResult as a string Text. In your application you can correct or update this string as needed.

Note: If you drastically change the text by adding or deleting many characters, the text may not align well in some export formats.

Text Correction

Even in the best of circumstances, OCR Xpress will occasionally have difficulty recognizing certain characters. As image quality is reduced, the probability of poor recognition is increased. OCR Xpress provides an interface to identify low confidence characters and two methods for correcting text as described below.

Suspect Characters

OCR Xpress identifies low confidence characters as suspect characters. The number of suspect characters is given in the TextLineResult through the SuspectCharacterCount property. Get the CharacterResult for a suspect character by calling GetSuspectCharacter and passing in the index value of the suspect character. The CharacterResult contains the character that was recognized, but is suspect, in the Text property. The CharacterResult object also contains the Confidence of the character. If the confidence is too low, the text is replaced with the RejectionCharacter defined and the IsRejectionCharacter property is set to true.

1. Modify the CharacterResult.Text property

One way to correct a suspect character is to set the Text property of the CharacterResult. If an extra character is incorrectly added, you can set the Text property to an empty string, "", to delete the suspect character. If two characters were combined into one, for example "rn" was turned into an "m", the single character can be replaced with the string of multiple characters. Once you set the Text property, that suspect character is considered fixed and is no longer suspect. As a result, the SuspectCharacterCount is decremented by one and that CharacterResult will not be returned by GetSuspectCharacter.

Note: The CharacterResult being removed and the resulting change in SuspectCharacterCount can cause problems when iterating through the suspect characters. Code with caution.

// loop for as many TextBlockResults as there are

for (int i = currentReplaceBlock; i<pageRes.TextBlockCount; i++)

{

      // get a TextBlockResult

      PegasusImaging.WinForms.OcrXpress1.TextBlockResult textRes =

            pageRes.GetTextBlockResult(i);

      // loop through the lines in this text block

      for(int j = 0; j<textRes.TextLineCount; j++)

      {

            // get a TextLineResult

            PegasusImaging.WinForms.OcrXpress1.TextLineResult lineRes =

                  textRes.GetTextLineResult(j);

            // determine if you want to replace the character

            bool replace = true;

            // loop through the characters on the current line

            for(int k = 0; k<lineRes.SuspectCharacterCount;k++)

            {

                  // determine if you want to replace the character

//(good place for user interaction)

                  if(replace)

                  {

                        // replace the character with a string

//(another good place for user interaction)

    lineRes.GetSuspectCharacter(k).Text = @"?";

                        // decrement the index for suspect characters

// because the above line actually

                        // deletes the suspect character and updates the SuspectCharacterCount

                        k--;

                  }

                  // do any additional processing you need to

            }

      }

}

2. Modify the TextLineResult.Text property

The other option to correct text is to loop through the suspect characters, and use the TextLinePosition in the CharacterResult of the suspect character to index into the TextLineResult.Text property. Make as many corrections to the string as needed prior to setting the Text. Once you set the Text, all suspect characters are treated as corrected or accepted, and the SuspectCharacterCount is set to zero.

// get an editable copy of the string

System.Text.StringBuilder myText = new System.Text.StringBuilder(lineRes.Text);

// loop through the suspect characters

for (int q=0;q<lineRes.SuspectCharacterCount;q++)

{

      // replace the suspect character or edit the string at this position

      myText[lineRes.GetSuspectCharacter(q).TextLinePosition] = '?';

}

// set the line text to the edited text

// note, this clears the suspect characters and sets the

// suspect character count to zero for this text line

lineRes.Text = myText.ToString();

Note: If you correct a suspect character, the SuspectCharacterCount changes and the corrected character is no longer a suspect character and is removed from the array.

See Also

TextLineResult Class | CharacterResult Class


Glossary Item Box

Locate Method | GetRegions Method | Recognize Method | SetRegions Method | RegionCollection Class | PictureIdentification Property | ClearRegions Method

See Also

PegasusImaging.WinForms.OcrXpress1

 Send comments on this topic.

Define and Use Regions

Set Up Regions

Automatically set up regions by calling the Document.Locate method on a Page. OCR Xpress uses the supplied or automatically created bitonal image to locate regions of text and pictures on a page.

Automatic Regions

If Document.Locate was called on a page, it is not required that you specify any regions manually. The regions identified by the automatic location process are available by calling Page.GetRegions after the location process completes.

If automatic location was skipped for a page, you can manually specify the text regions using the Page.SetRegions method.

Note: If no regions have been defined when Document.Recognize is called, the Document.Locate method will be called internally before recognition is started. It is acceptable to omit the call to Document.Locate, and only call the Document.Recognize method to simplify your code.

How to Define and Use Regions

Regions can be added manually through Page.SetRegions or automatically through the Document.Locate method, and edited as needed. The following methods and properties can be used to add, delete and get regions.

  • Document.PictureIdentification - A boolean property to identify picture regions or not during the Locate process. If this is set to false, picture regions will not be identified during the locate process.
  • Document.Locate - Automatically locates the text and picture regions for a given page. If PictureIdentification is set to false, picture regions will not be identified.
  • Page.ClearRegions - Removes all of the regions on a page.
  • Page.GetRegions - Returns a collection of the regions for the page.
  • Page.SetRegions - Sets a collection of the regions for the page.

Within the RegionCollection, the user can use a number of methods to add, remove, clear, get the index of, copy, insert, get the count of regions and check if the collection contains a particular region.

See Also

Locate Method | GetRegions Method | Recognize Method | SetRegions Method | RegionCollection Class | PictureIdentification Property | ClearRegions Method


Glossary Item Box

Getting Support and Samples | OcrXpress Class

PegasusImaging.WinForms.OcrXpress1

 Send comments on this topic.

Debug Your Application

Because debugging and writting debug information to a log file is time consuming and expensive, OCR Xpress provides the ability to control the level of information written to the debug log as well as the ability to turn off writing to a file completely.

Use the objects below to adjust the settings of your debugging, event handling, memory and IDispose for optimal performance.

Control Debugging Information

  • Debug - Turns on or off the ability to write to the debug log file.
  • DebugLogFile - A filename which stores the debug log information.
  • ErrorLevel - Controls the amount of information that is written to the debug log file.

Note: When ErrorLevel is set to Detailed, OCR Xpress will log most of your calls to the component including the occurrence of exceptions, the result of most major operations and the operation of each event it raises.

Event Handling

OCR Xpress may throw a number of exceptions if it comes across errors or events that need to be handled by the application. These exceptions are listed below:

  • BitonalImageNotNeededException - Thrown when an attempt is made to assign a bitonal image copy to a page whose primary image is already bitonal.
  • FileExportException - Thrown if the String argument of the Export method contains an invalid path, or the file already exists and is in use by another process.
  • FileInUseException - Thrown whenever you try to open a file that already in use.
  • ImageNotAvailableException - Thrown when an image is not available.
  • ImageNullException - Thrown whenever the input image to any of the image properties is null.
  • InternalErrorException - Thrown for internal errors.
  • InvalidAreaException - Thrown for invalid areas.
  • InvalidBitonalImageException - Thrown when you try to assign a color or grayscale image to the bitonal image properties.
  • InvalidIndexException - Thrown if an invalid index is provided.
  • InvalidLicenseException - Thrown if an invalid license is supplied for specific functionality.
  • InvalidParameterException - Thrown for invalid parameters used.
  • NullPageImageException - Thrown when a Page object is used that does not contain a valid image.
  • NullPageRegionsException - Thrown if a Page object with no text or pictures regions are used with a method that requires them.
  • OcrXpressException - An error thrown by the component which may contain an error number.
  • PageCountException - Thrown when an AddPage call is made when 999 pages are already contained in the Document.
  • ParameterOutOfRangeException - Thrown if the parameters are out of range.
  • PathNotFoundException - Thrown when the path given for the file does not exist.
  • RecognitionNotPerformedException - Thrown when an attempt is made to Export before calling Recognize.
  • RelativePathException - Thrown when a relative path given as input cannot e resolved.
  • TextToolLongException - Thrown if the input text to replace an existing text line result is longer than 1024 characters.
  • TimeoutErrorException - Thrown for timeout errors.
  • UnsupportedImageFormatException - Thrown when you try to pass in an image with a bit count that this component does not support.

Error Codes

Listed below is a cross reference of error codes and their corresponding descriptions.

Error Codes | Error | Description
19000 | OutOfMemoryException | There is not enough memory to continue the operation.
19001 | NullReferenceException | A null reference was used for the current operation.
19002 | InvalidParameterException | Invalid Parameter.
19003 | ParameterOutOfRangeException | Parameter out of range.
19004 | InvalidIndexException | Invalid index.
19005 | InvalidLicenseException | Invalid license.
19007 | InternalErrorException | Internal Error.
19008 | InvalidAreaException | The Region area is outside the bounds of the image.
19009 | OcrXpressException | An unhandled exception occurred in the OCR engine.
19020 | OcrXpressException | The OCR dictionary directory could not be created in ''All Users\Application Data\Pegasus Imaging\''.
19021 | OcrXpressException | The OCR temporary directory could not be created in :My Documents\Local Settings\Temp\''.
19040 | System.IO.FileNotFoundException | The specified file could not be found.
19041 | PathNotFoundException | The specified path does not exist.
19042 | FileInUseException | The file is in use by another process, and cannot be opened.
19043 | System.IO.IOException | The file open operation could not be completed.
19044 | RelativePathException | The relative path for the current operation could not be resolved.
19050 | ImageNotAvailableException | Image not available.
19051 | ImageNullException | The input HDIB or HBITMAP handle is null.
19052 | UnsupportedImageFormatException | The OcrXpress component only allows 1, 8 and 24 bit per pixel images.
19054 | InvalidBitonalImageException | Assigning a color or grayscale image to the bitonal image properties is not permitted.
19070 | RecognitionNotPerformedException | Recognize must be called before Export.
19071 | TextTooLongException | The corrected text line is greater than 1024 characters.
19072 | System.NullReferenceException | The new text line is null.
19073 | BitonalImageNotNeededException | This page does not require a bitonal image copy since the primary image is bitonal.
19074 | PageCountException | The maximum 999 pages have already been added to this document.
19441 | OcrXpressException | An invalid Document was used.
19442 | OcrXpressException | An invalid CodePage was specified.
19443 | OcrXpressException | An invalid Image was used.
19444 | OcrXpressException | The specified index was out of bounds.
19445 | OcrXpressException | An invalid Locate Option was specified.
19446 | OcrXpressException | An invalid Result was used.
19447 | OcrXpressException | An invalid Page was used.
19450 | OcrXpressException | An invalid Recognition Option was specified.
19451 | OcrXpressException | An invalid Rectangle was used.
19452 | OcrXpressException | An invalid Region was used.
19453 | OcrXpressException | An invalid export file type was specified.
19454 | FileExportException | A problem occurred during Export. Please make sure the filename is not in use, and contains a valid path.
19455 | OcrXpressException | The specified file could not be found.
19456 | OcrXpressException | The image is not 1 bit-per-pixel.
19457 | OcrXpressException | The image uses a compression that is not supported by this component.
19458 | OcrXpressException | The image file format is not supported by this component.
19459 | OcrXpressException | The image failed to load.
19460 | OcrXpressException | The OCR Engine was unable to initialize.
19461 | OcrXpressException | The user recognition dictionary could not be loaded.
19462 | OcrXpressException | The Locate process is in progress.
19463 | OcrXpressException | The Locate process is done.
19464 | OcrXpressException | The specified Page does not contain an image to Locate.
19465 | OcrXpressException | The component is out of memory.
19466 | OcrXpressException | The specified Page does not contain any recognition text results.
19468 | OcrXpressException | The Recognition process is done.
19469 | OcrXpressException | The OCR Engine was unable to terminate.
19471 | OcrXpressException | The Locate process failed because the input image was too wide.
19472 | OcrXpressException | The Locate process failed because the input image was too narrow.
19473 | OcrXpressException | The Locate process failed because the input image was too short.
19474 | OcrXpressException | The Image is locked and could not be discarded.
19475 | OcrXpressException | The Image is not locked and could not be processed.
19476 | OcrXpressException | The Page is not locked and could not be processed.
19477 | OcrXpressException | The Image has already been discarded and could not be processed.
19478 | OcrXpressException | The component cannot create more than one Document.
19479 | OcrXpressException | The Page is locked.
19480 | NullPageImageException | An Image does not exist for processing.
19481 | OcrXpressException | The component cannot locate the OCR Engine's database.
19482 | OcrXpressException | The component cannot locate the OCR Engine's language dictionaries.
19483 | OcrXpressException | The width of the image is out of range.
19484 | OcrXpressException | The height of the Image is out of range.
19485 | OcrXpressException | The Recognize process is in progress.
19486 | NullPageRegionsException | The specified Page does not contain any Regions to process.
19488 | NullPageImageException | The specified Page does not contain an image to Deskew.
19489 | OcrXpressException | The Deskew process is done.
19490 | OcrXpressException | The page number of the specified file is out of range.
19491 | OcrXpressException | A temporary file could not be created because the disk is full.
19493 | OcrXpressException | There is not enough memory to restore the picture region.
19496 | OcrXpressException | The AutoRotate process is done.
19497 | OcrXpressException | An invalid customer ID was specified.
19504 | OcrXpressException | An invalid Export option was specified.
19505 | OcrXpressException | The Binarize process is in progress.
19506 | OcrXpressException | The Binarize process is done.
19700 | OcrXpressException | A File operation failed. Please make sure the hard disk is not full.

See Also

Getting Support and Samples | OcrXpress Class


%%ItemTitle%%

PegasusImaging.WinForms.OcrXpress1 Assembly

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

PegasusImaging.WinForms.OcrXpress1 Namespace

Inheritance Hierarchy

Classes

Class | Description
BitonalImageNotNeededException | An exception object that the Page object will throw when an attempt is made to assign a bitonal image copy to a page whose primary image is already bitonal.
CharacterResult | An object that represents a single character within the TextLineResult.Text string of a parent TextLineResult.
DeskewStatus | The results from the Deskew process.
Document | An object that performs all of the OCR tasks of this component.
FileExportException | An exception object that the Document object will throw if the filename argument of the Export method contains an invalid path, or the file already exists and is in use by another process.
FileInUseException | An exception object that this component will throw whenever you try to open a file that is already in use.
FontMap | An object that defines the font information for a group of characters within the recognition text results.
ImageNotAvailableException | An exception object that this component will throw whenever there is no image available for an operation that requires one.
ImageNullException | An exception object that the Page object will throw whenever the input image to any of the image properties is null.
InternalErrorException | An exception object that this component will throw whenever an unhandled exception is encountered.
InvalidAreaException | An exception object that this component will throw whenever a Region object contains an area that is outside the bounds of the image.
InvalidBitonalImageException | An exception object that the Page object will throw whenever you try to assign a a color or grayscale image to the bitonal image properties.
InvalidIndexException | An exception object that this component will throw whenever an invalid index is used.
InvalidLicenseException | An exception object that this component will throw whenever an operation is attemted with an invalid or insufficient license.
InvalidParameterException | An exception object that this component will throw whenever a parameter is not valid.
Licensing | Provides methods for setting the license information for the toolkit.
NullPageImageException | An exception object that the Document object will throw if a Page object is used that does not contain a valid image.
NullPageRegionsException | An exception object that the Document object will throw if a Page object with no Text or Picture Regions is used with a method that requires them.
OcrXpress | The main object for this toolkit.
OcrXpressException | The base class for OcrXpress exceptions.
Page | An object that stores a single image to process.
PageCountException | An exception object that the Document object will throw if more than 999 pages are added.
PageResult | An object that provides access to all the text results for a Page.
ParameterOutOfRangeException | An exception object that this component will throw whenever a parameter is out of the valid range.
PathNotFoundException | An exception object that this component throws whenever the path given for the file does not exist.
PictureRegion | This object defines a rectangular area of a page's image as a picture region.
RecognitionNotPerformedException | An exception object that the Document object will throw when an attempt is made to Export before Recognize is called.
Region | The Region object is the base class for all the region objects.
RegionCollection | Represents a collection of TextRegion and PictureRegion objects.
RelativePathException | An exception object that this component will throw whenever a relative path given as input cannot be resolved.
TextBlockResult | An object that contains the area of a recognized text block (paragraph) and also provides access to the text lines within the text block.
TextLineResult | An object that contains the recognition results for a single text line. Multiple text lines can be contained in a TextBlockResult.
TextRegion | This object defines a rectangular area of a page's image as a text region.
TextTooLongException | An exception object that the TextLineResult object will throw if the input text to replace an existing text line result is longer than 1024 characters.
TimeoutErrorException | An exception object that this component will throw whenever the OcrXpress instance has timed out for current trial period.
UnsupportedImageFormatException | An exception object that the Page object will throw whenever you try to pass in an image with a bit count that this component does not support.

Enumerations

Enumeration | Description
ErrorLevel | The error level of items to place into the debug log.
EvaluationMode | The evaluation mode of the component.
ExportFormat | The available file formats to which recognition results can be exported.
ImageQuality | The settings to specify the quality of the image to the recognition process.
Language | The languages supported by this component for recognition.
LicenseEditionType | The supported License Edition types.
MultipageExport | The settings to specify how multiple pages are handled during Export.
RejectionCharacter | The allowable set of rejection characters.
TextBoundary | The settings to specify what the automatic region location process considers a text region.

See Also

PegasusImaging.WinForms.OcrXpress1 Assembly


%%PageItemTitle%%

BitonalImageNotNeededException Members | PegasusImaging.WinForms.OcrXpress1 Namespace

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

BitonalImageNotNeededException Class

PegasusImaging.WinForms.OcrXpress1 Namespace : BitonalImageNotNeededException Class

An exception object that the Page object will throw when an attempt is made to assign a bitonal image copy to a page whose primary image is already bitonal.

For a list of all members of this type, see BitonalImageNotNeededException members.

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.OcrXpress1.OcrXpressException
PegasusImaging.WinForms.OcrXpress1.BitonalImageNotNeededException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class BitonalImageNotNeededException
   Inherits OcrXpressException
[C#]
[SerializableAttribute()]
public sealed class BitonalImageNotNeededException : OcrXpressException
[C++]
[SerializableAttribute()]
public __gc __sealed class BitonalImageNotNeededException : public OcrXpressException
[C++/CLI]
[SerializableAttribute()]
public ref class BitonalImageNotNeededException sealed : public OcrXpressException

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

See Also

BitonalImageNotNeededException Members | PegasusImaging.WinForms.OcrXpress1 Namespace

© 1997 - 2007, Pegasus Imaging Corporation, All Rights Reserved.

Last Modified:


%%PageItemTitle%% $$Members$$

BitonalImageNotNeededException Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

BitonalImageNotNeededException Class Members

PegasusImaging.WinForms.OcrXpress1 Namespace : BitonalImageNotNeededException Class

BitonalImageNotNeededException overview

Public Constructors

Public Constructor BitonalImageNotNeededException Constructor Overloaded. Initializes a new instance of the BitonalImageNotNeededException class.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from OcrXpressException) | The number of the error.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

BitonalImageNotNeededException Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%%

BitonalImageNotNeededException Class | BitonalImageNotNeededException Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

BitonalImageNotNeededException Constructor

PegasusImaging.WinForms.OcrXpress1 Namespace > BitonalImageNotNeededException Class : BitonalImageNotNeededException Constructor (BitonalImageNotNeededException)

Initializes a new instance of the BitonalImageNotNeededException class.

Overload List

Initializes a new instance of the BitonalImageNotNeededException class.

[Visual Basic] Public Sub New()

[C#] public BitonalImageNotNeededException();

[C++] public BitonalImageNotNeededException();

[C++/CLI] public BitonalImageNotNeededException();

Initializes a new instance of the BitonalImageNotNeededException class.

[Visual Basic] Public Sub New(Integer)

[C#] public BitonalImageNotNeededException(int);

[C++] public BitonalImageNotNeededException(int);

[C++/CLI] public BitonalImageNotNeededException(int);

Initializes a new instance of the BitonalImageNotNeededException class.

[Visual Basic] Public Sub New(String)

[C#] public BitonalImageNotNeededException(string);

[C++] public BitonalImageNotNeededException(string*);

[C++/CLI] public BitonalImageNotNeededException(String^);

Initializes a new instance of the BitonalImageNotNeededException class.

[Visual Basic] Public Sub New(Integer,String)

[C#] public BitonalImageNotNeededException(int,string);

[C++] public BitonalImageNotNeededException(int,string*);

[C++/CLI] public BitonalImageNotNeededException(int,String^);

Initializes a new instance of the BitonalImageNotNeededException class.

[Visual Basic] Public Sub New(String,Exception)

[C#] public BitonalImageNotNeededException(string,Exception);

[C++] public BitonalImageNotNeededException(string*,Exception*);

[C++/CLI] public BitonalImageNotNeededException(String^,Exception^);

Requirements

Platforms: See Getting Started section

See Also

BitonalImageNotNeededException Class | BitonalImageNotNeededException Members


%%PageItemTitle%%

BitonalImageNotNeededException Class | BitonalImageNotNeededException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

BitonalImageNotNeededException Constructor()

PegasusImaging.WinForms.OcrXpress1 Namespace > BitonalImageNotNeededException Class > BitonalImageNotNeededException Constructor : BitonalImageNotNeededException Constructor()

Initializes a new instance of the BitonalImageNotNeededException class.

[Visual Basic]
Public Function New()
[C#]
public BitonalImageNotNeededException();
[C++]
public: BitonalImageNotNeededException();
[C++/CLI]
public:
BitonalImageNotNeededException();

Requirements

Platforms: See Getting Started section

See Also

BitonalImageNotNeededException Class | BitonalImageNotNeededException Members | Overload List


%%PageItemTitle%%

BitonalImageNotNeededException Class | BitonalImageNotNeededException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
A number that represents the reason you are creating this exception object.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

BitonalImageNotNeededException Constructor(Int32)

PegasusImaging.WinForms.OcrXpress1 Namespace > BitonalImageNotNeededException Class > BitonalImageNotNeededException Constructor : BitonalImageNotNeededException Constructor(Int32)

Initializes a new instance of the BitonalImageNotNeededException class.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public BitonalImageNotNeededException(
   int errorNumber
);
[C++]
public: BitonalImageNotNeededException(
   int errorNumber
)
[C++/CLI]
public:
BitonalImageNotNeededException(
   int errorNumber
)

Parameters

errorNumber
A number that represents the reason you are creating this exception object.

Requirements

Platforms: See Getting Started section

See Also

BitonalImageNotNeededException Class | BitonalImageNotNeededException Members | Overload List


%%PageItemTitle%%

BitonalImageNotNeededException Class | BitonalImageNotNeededException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
A number that represents the reason you are creating this exception object.
message
A string that describes the reason you are creating this exception object.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

BitonalImageNotNeededException Constructor(Int32,String)

PegasusImaging.WinForms.OcrXpress1 Namespace > BitonalImageNotNeededException Class > BitonalImageNotNeededException Constructor : BitonalImageNotNeededException Constructor(Int32,String)

Initializes a new instance of the BitonalImageNotNeededException class.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public BitonalImageNotNeededException(
   int errorNumber,
   string message
);
[C++]
public: BitonalImageNotNeededException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
BitonalImageNotNeededException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
A number that represents the reason you are creating this exception object.
message
A string that describes the reason you are creating this exception object.

Requirements

Platforms: See Getting Started section

See Also

BitonalImageNotNeededException Class | BitonalImageNotNeededException Members | Overload List


%%PageItemTitle%%

BitonalImageNotNeededException Class | BitonalImageNotNeededException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string that describes the reason you are creating this exception object.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

BitonalImageNotNeededException Constructor(String)

PegasusImaging.WinForms.OcrXpress1 Namespace > BitonalImageNotNeededException Class > BitonalImageNotNeededException Constructor : BitonalImageNotNeededException Constructor(String)

Initializes a new instance of the BitonalImageNotNeededException class.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public BitonalImageNotNeededException(
   string message
);
[C++]
public: BitonalImageNotNeededException(
   string* message
)
[C++/CLI]
public:
BitonalImageNotNeededException(
   String^ message
)

Parameters

message
A string that describes the reason you are creating this exception object.

Requirements

Platforms: See Getting Started section

See Also

BitonalImageNotNeededException Class | BitonalImageNotNeededException Members | Overload List


%%PageItemTitle%%

BitonalImageNotNeededException Class | BitonalImageNotNeededException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string that describes the reason you are creating this exception object.
innerException
The original exception that caused you to create this exception object.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

BitonalImageNotNeededException Constructor(String,Exception)

PegasusImaging.WinForms.OcrXpress1 Namespace > BitonalImageNotNeededException Class > BitonalImageNotNeededException Constructor : BitonalImageNotNeededException Constructor(String,Exception)

Initializes a new instance of the BitonalImageNotNeededException class.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public BitonalImageNotNeededException(
   string message,
   Exception innerException
);
[C++]
public: BitonalImageNotNeededException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
BitonalImageNotNeededException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string that describes the reason you are creating this exception object.
innerException
The original exception that caused you to create this exception object.

Requirements

Platforms: See Getting Started section

See Also

BitonalImageNotNeededException Class | BitonalImageNotNeededException Members | Overload List


%%PageItemTitle%%

CharacterResult Members | PegasusImaging.WinForms.OcrXpress1 Namespace

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

CharacterResult Class

PegasusImaging.WinForms.OcrXpress1 Namespace : CharacterResult Class

An object that represents a single character within the TextLineResult.Text string of a parent TextLineResult.

For a list of all members of this type, see CharacterResult members.

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.OcrXpress1.CharacterResult

Syntax

[Visual Basic]
Public Class CharacterResult
[C#]
public class CharacterResult
[C++]
public __gc class CharacterResult
[C++/CLI]
public ref class CharacterResult

Remarks

This object is used to access individual characters within a text line. The calling application may also replace the character that this object represents by setting the Text property.

Note: In the current version of this component, a CharacterResult object can only be obtained for suspect characters from the GetSuspectCharacter method of the TextLineResult object.

Note: Once you set the Text property, that suspect character is considered fixed and is no longer suspect. As a result, the !:SuspectCharacterCount is decremented by one and the CharacterResult will not be returned by the !:GetSuspectCharacter method.

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

See Also

CharacterResult Members | PegasusImaging.WinForms.OcrXpress1 Namespace

© 1997 - 2007, Pegasus Imaging Corporation, All Rights Reserved.

Last Modified:


%%PageItemTitle%% $$Members$$

CharacterResult Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

CharacterResult Class Members

PegasusImaging.WinForms.OcrXpress1 Namespace : CharacterResult Class

CharacterResult overview

Public Properties

Public Property Area | Gets the location of the character within the image, in pixels, measured from the top left corner.
Public Property Confidence | Gets the confidence value that this character was recognized with.
Public Property IsRejectionCharacter | Gets a value which indicates if this character was unreadable, and replaced with the specified RejectionCharacter.
Public Property Text | Gets and sets the string value this CharacterResult object represents.
Public Property TextLinePosition | Gets the zero-based position of the character within the TextLineResult.Text string of a parent TextLineResult.

See Also

CharacterResult Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%% $$Properties$$

CharacterResult Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

CharacterResult Class Properties

PegasusImaging.WinForms.OcrXpress1 Namespace : CharacterResult Class

For a list of all members of this type, see CharacterResult members.

Public Properties

Public Property Area | Gets the location of the character within the image, in pixels, measured from the top left corner.
Public Property Confidence | Gets the confidence value that this character was recognized with.
Public Property IsRejectionCharacter | Gets a value which indicates if this character was unreadable, and replaced with the specified RejectionCharacter.
Public Property Text | Gets and sets the string value this CharacterResult object represents.
Public Property TextLinePosition | Gets the zero-based position of the character within the TextLineResult.Text string of a parent TextLineResult.

See Also

CharacterResult Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%%

CharacterResult Class | CharacterResult Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

Area Property

PegasusImaging.WinForms.OcrXpress1 Namespace > CharacterResult Class : Area Property (CharacterResult)

Gets the location of the character within the image, in pixels, measured from the top left corner.

[Visual Basic]
Public ReadOnly Property Area As Rectangle
[C#]
public Rectangle Area {get;}
[C++]
public: __property Rectangle get_Area();
[C++/CLI]
public:
property Rectangle Area {
   Rectangle get();
}

Return Type

A Rectangle object which contains the area coordinates.

Remarks

This property contains the location of the suspect character. The pixel at the top left corner of the image is at (0, 0). Values of X increase as you move to the right on the image and values of Y increase as you move down the image.

Requirements

Platforms: See Getting Started section

See Also

CharacterResult Class | CharacterResult Members


%%PageItemTitle%%

CharacterResult Class | CharacterResult Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

Confidence Property

PegasusImaging.WinForms.OcrXpress1 Namespace > CharacterResult Class : Confidence Property

Gets the confidence value that this character was recognized with.

[Visual Basic]
Public ReadOnly Property Confidence As Integer
[C#]
public int Confidence {get;}
[C++]
public: __property int get_Confidence();
[C++/CLI]
public:
property int Confidence {
   int get();
}

Return Type

An integer which represents the confidence value of the character.

Remarks

This property returns the confidence value of the character within the character result.

A confidence value of 0 signifies that this suspect character was unreadable and replaced with the RejectionCharacter in the results.

Valid values: 0 - 100

Requirements

Platforms: See Getting Started section

See Also

CharacterResult Class | CharacterResult Members


%%PageItemTitle%%

CharacterResult Class | CharacterResult Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

IsRejectionCharacter Property

PegasusImaging.WinForms.OcrXpress1 Namespace > CharacterResult Class : IsRejectionCharacter Property

Gets a value which indicates if this character was unreadable, and replaced with the specified RejectionCharacter.

[Visual Basic]
Public ReadOnly Property IsRejectionCharacter As Boolean
[C#]
public bool IsRejectionCharacter {get;}
[C++]
public: __property bool get_IsRejectionCharacter();
[C++/CLI]
public:
property bool IsRejectionCharacter {
   bool get();
}

Return Type

A boolean value which is true when the chracter was replaced with a RejectionCharacter. Otherwise, false is returned.

Remarks

When this property is true this suspect character has been replaced with the RejectionCharacter.

When this property is false this character contains a character match, which was determined with the specified Confidence.

Requirements

Platforms: See Getting Started section

See Also

CharacterResult Class | CharacterResult Members


%%PageItemTitle%%

CharacterResult Class | CharacterResult Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

Text Property

PegasusImaging.WinForms.OcrXpress1 Namespace > CharacterResult Class : Text Property (CharacterResult)

Gets and sets the string value this CharacterResult object represents.

[Visual Basic]
Public Property Text As String
[C#]
public string Text {get; set;}
[C++]
public: __property string* get_Text();
public: __property void set_Text(
   string* value
);
[C++/CLI]
public:
property String^ Text {
   String^ get();
   void set (String^ value);
}

Return Type

A string value which represents the character for the result.

Remarks

This property will return the character represented by a CharacterResult object.

Setting this property to a string with a single character will simply replace the identified character. Setting this property to an empty string ("") will delete the suspect character from the line. If the set string contains multiple characters, the suspect character is deleted, and the new string is inserted into its position. Care should be used in this case, as increasing the line length significantly may alter the appearance of the line when exported to certain formats. The corrected text will be used if the results are exported with Export.

Note: This property may only be set a single time, since once this property is set, the SuspectCharacter will be considered corrected, and removed from the suspect character list. The TextLineResult.SuspectCharacterCount will be decremented by 1.

If the IsRejectionCharacter is true, the Confidence will be 0, and this property will return the character specified by the Document.RejectionCharacter.

Requirements

Platforms: See Getting Started section

See Also

CharacterResult Class | CharacterResult Members


%%PageItemTitle%%

CharacterResult Class | CharacterResult Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

TextLinePosition Property

PegasusImaging.WinForms.OcrXpress1 Namespace > CharacterResult Class : TextLinePosition Property

Gets the zero-based position of the character within the TextLineResult.Text string of a parent TextLineResult.

[Visual Basic]
Public ReadOnly Property TextLinePosition As Integer
[C#]
public int TextLinePosition {get;}
[C++]
public: __property int get_TextLinePosition();
[C++/CLI]
public:
property int TextLinePosition {
   int get();
}

Return Type

An integer which represents the position of the character within its parent TextLineResult.

Remarks

This position is in relation to the text of the parent TextLineResult which returned this character from GetSuspectCharacter.

Requirements

Platforms: See Getting Started section

See Also

CharacterResult Class | CharacterResult Members


%%PageItemTitle%%

DeskewStatus Members | PegasusImaging.WinForms.OcrXpress1 Namespace

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

DeskewStatus Class

PegasusImaging.WinForms.OcrXpress1 Namespace : DeskewStatus Class

The results from the Deskew process.

For a list of all members of this type, see DeskewStatus members.

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.OcrXpress1.DeskewStatus

Syntax

[Visual Basic]
Public Class DeskewStatus
[C#]
public class DeskewStatus
[C++]
public __gc class DeskewStatus
[C++/CLI]
public ref class DeskewStatus

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

See Also

DeskewStatus Members | PegasusImaging.WinForms.OcrXpress1 Namespace

© 1997 - 2007, Pegasus Imaging Corporation, All Rights Reserved.

Last Modified:


%%PageItemTitle%% $$Members$$

DeskewStatus Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

DeskewStatus Class Members

PegasusImaging.WinForms.OcrXpress1 Namespace : DeskewStatus Class

DeskewStatus overview

Public Properties

Public Property Angle | The angle, in degrees, the image was skewed.
Public Property OriginalHeight | The height of the original image.
Public Property Sangle | A variation of the skew angle.
Public Property Xedge | The shifting bytes after deskew.
Public Property Xshift | The X-axis shifting bits of rotation center.
Public Property Yshift | The Y-axis shifting bits of rotation center.

See Also

DeskewStatus Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%% $$Properties$$

DeskewStatus Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

DeskewStatus Class Properties

PegasusImaging.WinForms.OcrXpress1 Namespace : DeskewStatus Class

For a list of all members of this type, see DeskewStatus members.

Public Properties

Public Property Angle | The angle, in degrees, the image was skewed.
Public Property OriginalHeight | The height of the original image.
Public Property Sangle | A variation of the skew angle.
Public Property Xedge | The shifting bytes after deskew.
Public Property Xshift | The X-axis shifting bits of rotation center.
Public Property Yshift | The Y-axis shifting bits of rotation center.

See Also

DeskewStatus Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%%

DeskewStatus Class | DeskewStatus Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

Angle Property

PegasusImaging.WinForms.OcrXpress1 Namespace > DeskewStatus Class : Angle Property

The angle, in degrees, the image was skewed.

[Visual Basic]
Public Property Angle As Double
[C#]
public double Angle {get; set;}
[C++]
public: __property double get_Angle();
public: __property void set_Angle(
   double value
);
[C++/CLI]
public:
property double Angle {
   double get();
   void set (double value);
}

Requirements

Platforms: See Getting Started section

See Also

DeskewStatus Class | DeskewStatus Members


%%PageItemTitle%%

DeskewStatus Class | DeskewStatus Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

OriginalHeight Property

PegasusImaging.WinForms.OcrXpress1 Namespace > DeskewStatus Class : OriginalHeight Property

The height of the original image.

[Visual Basic]
Public Property OriginalHeight As Integer
[C#]
public int OriginalHeight {get; set;}
[C++]
public: __property int get_OriginalHeight();
public: __property void set_OriginalHeight(
   int value
);
[C++/CLI]
public:
property int OriginalHeight {
   int get();
   void set (int value);
}

Requirements

Platforms: See Getting Started section

See Also

DeskewStatus Class | DeskewStatus Members


%%PageItemTitle%%

DeskewStatus Class | DeskewStatus Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

Sangle Property

PegasusImaging.WinForms.OcrXpress1 Namespace > DeskewStatus Class : Sangle Property

A variation of the skew angle.

[Visual Basic]
Public Property Sangle As Integer
[C#]
public int Sangle {get; set;}
[C++]
public: __property int get_Sangle();
public: __property void set_Sangle(
   int value
);
[C++/CLI]
public:
property int Sangle {
   int get();
   void set (int value);
}

Requirements

Platforms: See Getting Started section

See Also

DeskewStatus Class | DeskewStatus Members


%%PageItemTitle%%

DeskewStatus Class | DeskewStatus Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

Xedge Property

PegasusImaging.WinForms.OcrXpress1 Namespace > DeskewStatus Class : Xedge Property

The shifting bytes after deskew.

[Visual Basic]
Public Property Xedge As Integer
[C#]
public int Xedge {get; set;}
[C++]
public: __property int get_Xedge();
public: __property void set_Xedge(
   int value
);
[C++/CLI]
public:
property int Xedge {
   int get();
   void set (int value);
}

Requirements

Platforms: See Getting Started section

See Also

DeskewStatus Class | DeskewStatus Members


%%PageItemTitle%%

DeskewStatus Class | DeskewStatus Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

Xshift Property

PegasusImaging.WinForms.OcrXpress1 Namespace > DeskewStatus Class : Xshift Property

The X-axis shifting bits of rotation center.

[Visual Basic]
Public Property Xshift As Integer
[C#]
public int Xshift {get; set;}
[C++]
public: __property int get_Xshift();
public: __property void set_Xshift(
   int value
);
[C++/CLI]
public:
property int Xshift {
   int get();
   void set (int value);
}

Requirements

Platforms: See Getting Started section

See Also

DeskewStatus Class | DeskewStatus Members


%%PageItemTitle%%

DeskewStatus Class | DeskewStatus Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

Yshift Property

PegasusImaging.WinForms.OcrXpress1 Namespace > DeskewStatus Class : Yshift Property

The Y-axis shifting bits of rotation center.

[Visual Basic]
Public Property Yshift As Integer
[C#]
public int Yshift {get; set;}
[C++]
public: __property int get_Yshift();
public: __property void set_Yshift(
   int value
);
[C++/CLI]
public:
property int Yshift {
   int get();
   void set (int value);
}

Requirements

Platforms: See Getting Started section

See Also

DeskewStatus Class | DeskewStatus Members


%%PageItemTitle%%

Document Members | PegasusImaging.WinForms.OcrXpress1 Namespace

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

Document Class

PegasusImaging.WinForms.OcrXpress1 Namespace : Document Class (PegasusImaging.WinForms.OcrXpress1)

An object that performs all of the OCR tasks of this component.

For a list of all members of this type, see Document members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.OcrXpress1.Document

Syntax

[Visual Basic]
Public Class Document
[C#]
public class Document
[C++]
public __gc class Document
[C++/CLI]
public ref class Document

Remarks

This is the main object of this component. It contains all of the image and OCR processing methods, as well as manages all of the pages to be processed.

While you cannot create this object directly, a Document object is created for you, and accessible from the Document property.

There may only ever be one Document object per OcrXpress object. If multiple documents are needed for simultaneous processing, an OcrXpress object must be created for each one.

Conceptually, this object is comparable to the basic idea of a document. It can contain one to many pages, with each page referring to a single image. Each page of the document is represented by a single Page object. Page objects (and their underlying images) are added one at a time to the document with the AddPage method. The input images are not required to originate from the same file, and can consist of many different images. Once added however, each page is considered part of the parent Document. This means that when Export is called, all pages currently in the Document will be written to the exported file.

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

See Also

Document Members | PegasusImaging.WinForms.OcrXpress1 Namespace

© 1997 - 2007, Pegasus Imaging Corporation, All Rights Reserved.

Last Modified:


%%PageItemTitle%% $$Members$$

Document Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

Document Class Members

PegasusImaging.WinForms.OcrXpress1 Namespace : Document Class (PegasusImaging.WinForms.OcrXpress1)

Document overview

Public Properties

Public Property ImageQuality | Gets and sets the quality of the images used by the pages of this Document.
Public Property Language | Gets and sets the language used during text recognition.
Public Property MultipageExport | Gets and sets the way multiple pages are grouped during Export.
Public Property PageCount | Gets the number of pages in the document.
Public Property PictureIdentification | Sets whether pictures or graphics embedded in an image are identified by the automatic location process.
Public Property RejectionCharacter | Gets and sets the character used in the recognition results that represents an unrecognized character.
Public Property TextBoundary | Gets and sets how text regions should be defined by the Locate method.
Public Property UserDictionary | Gets and sets the fully qualified path and filename of the user-supplemented recognition dictionary.

Public Methods

Public Method AddPage | Overloaded.
Public Method AutoRotate | Detects the orientation of the image of a Page, and automatically rotates it if necessary.
Public Method ClearPages | Removes all Page objects from the document.
Public Method Deskew | Detects any skew in the image of a Page, and automatically corrects it if necessary.
Public Method Export | Writes the recognition results of all pages to a file with the specified format and name.
Public Method GetPage | Gets the Page object at the given index.
Public Method Locate | Performs automatic location to identify regions of text and pictures (optional) for a Page.
Public Method MovePage | Moves a Page object from one index to another.
Public Method Recognize | Performs recognition on a Page.
Public Method RemovePage | Removes a Page object from the document.

See Also

Document Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%%

Document Class | Document Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

AddPage Method

PegasusImaging.WinForms.OcrXpress1 Namespace > Document Class : AddPage Method

Overload List

Append a new page to the end of the list, and sets the image.

[Visual Basic] Overloads Public Function AddPage(IntPtr) As Page

[C#] public Page AddPage(IntPtr);

[C++] public Page* AddPage(IntPtr);

[C++/CLI] public Page^ AddPage(IntPtr);

Append a new page to the end of the list, and sets the image.

[Visual Basic] Overloads Public Function AddPage(Bitmap) As Page

[C#] public Page AddPage(Bitmap);

[C++] public Page* AddPage(Bitmap);

[C++/CLI] public Page^ AddPage(Bitmap);

Example

[C#]

...
    // create ImagXpress object
    PegasusImaging.WinForms.ImagXpress8.ImagXpress myIx = new PegasusImaging.WinForms.ImagXpress8.ImagXpress();
    // create ImagXpress image object
    PegasusImaging.WinForms.ImagXpress8.ImageX myImage = new PegasusImaging.WinForms.ImagXpress8.ImageX();
    // set the file suspect.tif into the image object
    myImage = PegasusImaging.WinForms.ImagXpress8.ImageX.FromFile(@"..\..\..\TestData\InputImages\suspect.tif");
    // pass the image created into the AddPage method
    Page thePage = ocrX.Document.AddPage(myImage.ToHdib(false));

    ...

Requirements

Platforms: See Getting Started section

See Also

Document Class | Document Members


%%PageItemTitle%%

Document Class | Document Members | Overload List | AddPage(Bitmap) Method

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

image
The HDIB or HBITMAP to copy to this component.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

AddPage(IntPtr) Method

PegasusImaging.WinForms.OcrXpress1 Namespace > Document Class > AddPage Method : AddPage(IntPtr) Method

Append a new page to the end of the list, and sets the image.

[Visual Basic]
Overloads Public Function AddPage( _
   ByVal image As IntPtr _
) As Page
[C#]
public Page AddPage(
   IntPtr image
);
[C++]
public: Page* AddPage(
   IntPtr image
)
[C++/CLI]
public:
Page^ AddPage(
   IntPtr image
)

Parameters

image
The HDIB or HBITMAP to copy to this component.

Return Type

A reference to the new Page object.

Remarks

This method provides a way for you to create a new page and set the image for it. This method accepts WIN32 HDIB or HBITMAP handles. Similar methods of this object accept the same image in other forms.

Images must be 1, 8 or 24 bits-per-pixel.

Note: If you add a page using this method, this object will not keep a reference to your image. You must ensure the image passed into this method is disposed of properly after it is no longer needed.

Note: The HBITMAP is an object of the device context and does not have a defined resolution. Because this component will perform its best during segmentation and recognition on images with resolution values, you should avoid using this method of importing an image if possible. The use of HDIB's are encouraged as the fastest method for passing images between OcrXpress, ImagXpress, and other Pegasus Imaging components.

Requirements

Platforms: See Getting Started section

See Also

Document Class | Document Members | Overload List | AddPage(Bitmap) Method


%%PageItemTitle%%

Document Class | Document Members | Overload List | AddPage(IntPtr) Method

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

image
The Bitmap object to copy to this component.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

AddPage(Bitmap) Method

PegasusImaging.WinForms.OcrXpress1 Namespace > Document Class > AddPage Method : AddPage(Bitmap) Method

Append a new page to the end of the list, and sets the image.

[Visual Basic]
Overloads Public Function AddPage( _
   ByVal image As Bitmap _
) As Page
[C#]
public Page AddPage(
   Bitmap image
);
[C++]
public: Page* AddPage(
   Bitmap image
)
[C++/CLI]
public:
Page^ AddPage(
   Bitmap image
)

Parameters

image
The Bitmap object to copy to this component.

Return Type

A reference to the new Page object.

Remarks

This method provides a way for you to create a new page and set the image for it. This method accepts .NET Bitmap objects. Similar methods of this object accept the same image in other forms.

Images must be 1, 8 or 24 bits-per-pixel.

Note: If you add a page using this method, this object will not keep a reference to your image. You must ensure the image passed into this method is disposed of properly after it is no longer needed.

Requirements

Platforms: See Getting Started section

See Also

Document Class | Document Members | Overload List | AddPage(IntPtr) Method


%%PageItemTitle%%

Document Class | Document Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

page
The Page to auto rotate.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

AutoRotate Method

PegasusImaging.WinForms.OcrXpress1 Namespace > Document Class : AutoRotate Method

Detects the orientation of the image of a Page, and automatically rotates it if necessary.

[Visual Basic]
Public Function AutoRotate( _
   ByVal page As Page _
) As Integer
[C#]
public int AutoRotate(
   Page page
);
[C++]
public: int AutoRotate(
   Page* page
)
[C++/CLI]
public:
int AutoRotate(
   Page^ page
)

Parameters

page
The Page to auto rotate.

Return Type

The number of degrees which the image of the specified page was rotated. Will be either 0, 90, 180 or 270.

Remarks

This method should be called before any text regions have been set, and recognition is performed, as it deletes all existing text regions and recognition results for the Page.

Example

...

// Automatically rotate the image if needed

ocrX.Document.AutoRotate(page);

...

Requirements

Platforms: See Getting Started section

See Also

Document Class | Document Members


%%PageItemTitle%%

Document Class | Document Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

ClearPages Method

PegasusImaging.WinForms.OcrXpress1 Namespace > Document Class : ClearPages Method

Removes all Page objects from the document.

[Visual Basic]
Public Sub ClearPages()
[C#]
public void ClearPages();
[C++]
public: void ClearPages();
[C++/CLI]
public:
void ClearPages();

Remarks

This method will set the PageCount to 0.

Example

...

// Removes all page objects from the document

ocrX.Document.ClearPages();

...

Requirements

Platforms: See Getting Started section

See Also

Document Class | Document Members


%%PageItemTitle%%

Document Class | Document Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

page
The Page to de-skew.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

Deskew Method

PegasusImaging.WinForms.OcrXpress1 Namespace > Document Class : Deskew Method

Detects any skew in the image of a Page, and automatically corrects it if necessary.

[Visual Basic]
Public Function Deskew( _
   ByVal page As Page _
) As DeskewStatus
[C#]
public DeskewStatus Deskew(
   Page page
);
[C++]
public: DeskewStatus* Deskew(
   Page* page
)
[C++/CLI]
public:
DeskewStatus^ Deskew(
   Page^ page
)

Parameters

page
The Page to de-skew.

Return Type

The results of the Deskew process.

Remarks

This method can correct skewed images that are rotated up to 15 degrees, clockwise or counter-clockwise, off the vertical axis.

Call this method before any text regions have been set or recognition is performed, as it deletes all existing text regions and recognition results for the Page.

Example

...

// Deskew the passed in page as needed

ocrX.Document.Deskew(myPage);

...

Requirements

Platforms: See Getting Started section

See Also

Document Class | Document Members


%%PageItemTitle%%

Document Class | Document Members | MultipageExport Property | MultipageExport Enumeration

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

format
The format of the file to export to.
filename
The name of the file to export to.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

Export Method

PegasusImaging.WinForms.OcrXpress1 Namespace > Document Class : Export Method

Writes the recognition results of all pages to a file with the specified format and name.

[Visual Basic]
Public Sub Export( _
   ByVal format As ExportFormat, _
   ByVal filename As String _
)
[C#]
public void Export(
   ExportFormat format,
   string filename
);
[C++]
public: void Export(
   ExportFormat format,
   string* filename
)
[C++/CLI]
public:
void Export(
   ExportFormat format,
   String^ filename
)

Parameters

format
The format of the file to export to.
filename
The name of the file to export to.

Remarks

This function exports the recognition results of all the pages in the document to the specified file format.

If multiple pages have been loaded into the document, the MultipageExport property controls how the pages are grouped in the export file(s).

Example

...

// Call the Export method passing in the export format and name

ocrX.Document.Export(PegasusImaging.WinForms.OcrXpress1.ExportFormat.Pdf, @"..\..\HelloFile.pdf");

...

Requirements

Platforms: See Getting Started section

See Also

Document Class | Document Members | MultipageExport Property | MultipageExport Enumeration


%%PageItemTitle%%

Document Class | Document Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

index
The zero-based index of the requested page.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

GetPage Method

PegasusImaging.WinForms.OcrXpress1 Namespace > Document Class : GetPage Method

Gets the Page object at the given index.

[Visual Basic]
Public Function GetPage( _
   ByVal index As Integer _
) As Page
[C#]
public Page GetPage(
   int index
);
[C++]
public: Page* GetPage(
   int index
)
[C++/CLI]
public:
Page^ GetPage(
   int index
)

Parameters

index
The zero-based index of the requested page.

Return Type

A reference to the Page object.

Remarks

This method will return a reference to the requested Page.

Use this method to adjust any settings of an existing page.

Example

...

// Call the GetPage method passing in the index of the page to retrieve

ocrX.Document.GetPage(1);

...

Requirements

Platforms: See Getting Started section

See Also

Document Class | Document Members


%%PageItemTitle%%

Document Class | Document Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

page
The Page on which to perform automatic location.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

Locate Method

PegasusImaging.WinForms.OcrXpress1 Namespace > Document Class : Locate Method

Performs automatic location to identify regions of text and pictures (optional) for a Page.

[Visual Basic]
Public Sub Locate( _
   ByVal page As Page _
)
[C#]
public void Locate(
   Page page
);
[C++]
public: void Locate(
   Page* page
)
[C++/CLI]
public:
void Locate(
   Page^ page
)

Parameters

page
The Page on which to perform automatic location.

Remarks

The regions located by this method are used by the recognition process to know where in the image to perform OCR. A Page object must have 1 or more regions defined before recognition is performed on it.

If no regions have been defined when Recognize is called, the Locate method will be called internally before recognition is started. It is acceptable to omit the call to Locate, and only call Recognize to simplify your code.

The located regions resulting from this method can be obtained from the GetRegions method of the given Page object. The RegionCollection returned from GetTextRegions can be edited and passed back into SetRegions if adjustments to the automatic location process are needed.

This method is the recommended way to locate and define regions for a page, although it is not required. If this method is not desired, you will need to define text regions manually using the SetRegions method of each Page object before any recognition is performed on it.

Call this method before any text regions have been set as it deletes all existing text regions of the given page.

Example

...

// Call the Locate method passing in the page

ocrX.Document.Locate(myPage);

...

Requirements

Platforms: See Getting Started section

See Also

Document Class | Document Members


%%PageItemTitle%%

Document Class | Document Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

fromIndex
The zero-based index of the Page to move.
toIndex
The new zero-based index of the Page.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

MovePage Method

PegasusImaging.WinForms.OcrXpress1 Namespace > Document Class : MovePage Method

Moves a Page object from one index to another.

[Visual Basic]
Public Sub MovePage( _
   ByVal fromIndex As Integer, _
   ByVal toIndex As Integer _
)
[C#]
public void MovePage(
   int fromIndex,
   int toIndex
);
[C++]
public: void MovePage(
   int fromIndex,
   int toIndex
)
[C++/CLI]
public:
void MovePage(
   int fromIndex,
   int toIndex
)

Parameters

fromIndex
The zero-based index of the Page to move.
toIndex
The new zero-based index of the Page.

Remarks

This method moves the requested Page object to a new index location.

The page being moved is inserted at the new index given. The elements that follow the insertion point move down to accomodate the moved element.

Example

...

// Call the MovePage method passing in the from index and the to index

ocrX.Document.MovePage(0,4);

...

Requirements

Platforms: See Getting Started section

See Also

Document Class | Document Members


%%PageItemTitle%%

Document Class | Document Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

page
The Page on which to perform automatic location.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

Recognize Method

PegasusImaging.WinForms.OcrXpress1 Namespace > Document Class : Recognize Method

Performs recognition on a Page.

[Visual Basic]
Public Sub Recognize( _
   ByVal page As Page _
)
[C#]
public void Recognize(
   Page page
);
[C++]
public: void Recognize(
   Page* page
)
[C++/CLI]
public:
void Recognize(
   Page^ page
)

Parameters

page
The Page on which to perform automatic location.

Remarks

The Page object passed to this method must already have one or more regions defined or this method will throw an exception.

Access the results of this method for each page from GetResult.

This method deletes all existing recognition results for the Page, and replaces it with the results from the current recognition process. The Page's RegionCollection may also be modified based on more detailed information about the image gained from the recognition process.

Example

...

// Call the Recognize method passing in the page

ocrX.Document.Recognize(myPage);

...

Requirements

Platforms: See Getting Started section

See Also

Document Class | Document Members


%%PageItemTitle%%

Document Class | Document Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

page
The Page to remove.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

RemovePage Method

PegasusImaging.WinForms.OcrXpress1 Namespace > Document Class : RemovePage Method

Removes a Page object from the document.

[Visual Basic]
Public Sub RemovePage( _
   ByVal page As Page _
)
[C#]
public void RemovePage(
   Page page
);
[C++]
public: void RemovePage(
   Page* page
)
[C++/CLI]
public:
void RemovePage(
   Page^ page
)

Parameters

page
The Page to remove.

Remarks

The pages that follow the removed page move up to occupy the vacated spot.

Example

...

// Call the RemovePage method passing in the page

ocrX.Document.RemovePage(thePage);

...

Requirements

Platforms: See Getting Started section

See Also

Document Class | Document Members


%%PageItemTitle%% $$Properties$$

Document Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

Document Class Properties

PegasusImaging.WinForms.OcrXpress1 Namespace : Document Class (PegasusImaging.WinForms.OcrXpress1)

For a list of all members of this type, see Document members.

Public Properties

Public Property ImageQuality | Gets and sets the quality of the images used by the pages of this Document.
Public Property Language | Gets and sets the language used during text recognition.
Public Property MultipageExport | Gets and sets the way multiple pages are grouped during Export.
Public Property PageCount | Gets the number of pages in the document.
Public Property PictureIdentification | Sets whether pictures or graphics embedded in an image are identified by the automatic location process.
Public Property RejectionCharacter | Gets and sets the character used in the recognition results that represents an unrecognized character.
Public Property TextBoundary | Gets and sets how text regions should be defined by the Locate method.
Public Property UserDictionary | Gets and sets the fully qualified path and filename of the user-supplemented recognition dictionary.

See Also

Document Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%%

Document Class | Document Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

ImageQuality Property

PegasusImaging.WinForms.OcrXpress1 Namespace > Document Class : ImageQuality Property (Document)

Gets and sets the quality of the images used by the pages of this Document.

[Visual Basic]
Public Property ImageQuality As ImageQuality
[C#]
public ImageQuality ImageQuality {get; set;}
[C++]
public: __property ImageQuality get_ImageQuality();
public: __property void set_ImageQuality(
   ImageQuality value
);
[C++/CLI]
public:
property ImageQuality ImageQuality {
   ImageQuality get();
   void set (ImageQuality value);
}

Remarks

This value is used by Recognize to determine the process it uses to scan the image. The NormalDegraded and DotMatrix settings should be used with care, as they will increase the processing time. In most cases, set this property to Normal.

It is very important that the DotMatrix setting be used only on images that are derived from the output of 9-pin dot matrix printers running in draft mode. This implies that the dots that make up the characters (in the original) can be individually seen. If the image to be recognized does not consist of these kinds of characters, then it is best not to use the DotMatrix settings.

Default Value: Normal

Example

...

// Set the ImageQuality to the Normal from the ImageQuality enum options

ocrX.Document.ImageQuality = PegasusImaging.WinForms.OcrXpress1.ImageQuality.Normal;

...

Requirements

Platforms: See Getting Started section

See Also

Document Class | Document Members


%%PageItemTitle%%

Document Class | Document Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

Language Property

PegasusImaging.WinForms.OcrXpress1 Namespace > Document Class : Language Property (Document)

Gets and sets the language used during text recognition.

[Visual Basic]
Public Property Language As Language
[C#]
public Language Language {get; set;}
[C++]
public: __property Language get_Language();
public: __property void set_Language(
   Language value
);
[C++/CLI]
public:
property Language Language {
   Language get();
   void set (Language value);
}

Remarks

Set the language prior to calling the Recognize method.

Default Value: English

Example

...

// Set the Language to French from English. Options are from the Language enum

ocrX.Document.Language = PegasusImaging.WinForms.OcrXpress1.Language.French;

...

Requirements

Platforms: See Getting Started section

See Also

Document Class | Document Members


%%PageItemTitle%%

Document Class | Document Members | Export Method

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

MultipageExport Property

PegasusImaging.WinForms.OcrXpress1 Namespace > Document Class : MultipageExport Property (Document)

Gets and sets the way multiple pages are grouped during Export.

[Visual Basic]
Public Property MultipageExport As MultipageExport
[C#]
public MultipageExport MultipageExport {get; set;}
[C++]
public: __property MultipageExport get_MultipageExport();
public: __property void set_MultipageExport(
   MultipageExport value
);
[C++/CLI]
public:
property MultipageExport MultipageExport {
   MultipageExport get();
   void set (MultipageExport value);
}

Remarks

This property allows you to control how multiple pages are grouped during Export.

This property has no effect if there is only 1 page in the Document.

Set this property prior to calling the Export method.

Default Value: NoSplit.

Example

...

// Set the value of the MultipageExport to no split

ocrX.Document.MultipageExport = ocrX.MultipageExport.NoSplit;

...

Requirements

Platforms: See Getting Started section

See Also

Document Class | Document Members | Export Method


%%PageItemTitle%%

Document Class | Document Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

PageCount Property

PegasusImaging.WinForms.OcrXpress1 Namespace > Document Class : PageCount Property

Gets the number of pages in the document.

[Visual Basic]
Public ReadOnly Property PageCount As Integer
[C#]
public int PageCount {get;}
[C++]
public: __property int get_PageCount();
[C++/CLI]
public:
property int PageCount {
   int get();
}

Example

...

// Get the number of pages in the document

ocrX.Document.GetPage(1);

...

Requirements

Platforms: See Getting Started section

See Also

Document Class | Document Members


%%PageItemTitle%%

Document Class | Document Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

PictureIdentification Property

PegasusImaging.WinForms.OcrXpress1 Namespace > Document Class : PictureIdentification Property

Sets whether pictures or graphics embedded in an image are identified by the automatic location process.

[Visual Basic]
Public Property PictureIdentification As Boolean
[C#]
public bool PictureIdentification {get; set;}
[C++]
public: __property bool get_PictureIdentification();
public: __property void set_PictureIdentification(
   bool value
);
[C++/CLI]
public:
property bool PictureIdentification {
   bool get();
   void set (bool value);
}

Remarks

If this property is true, pictures are identified and ordered along with any other text regions. The identified regions that contain pictures will be available as a PictureRegion object in the RegionCollection returned from Page.GetRegions. Any picture regions are used strictly by Export and ignored by the recognition process.

Default Value: true.

Example

...

// Set the PictureIdentification value

ocrX.Document.PictureIdentification = true;

...

Requirements

Platforms: See Getting Started section

See Also

Document Class | Document Members


%%PageItemTitle%%

Document Class | Document Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

RejectionCharacter Property

PegasusImaging.WinForms.OcrXpress1 Namespace > Document Class : RejectionCharacter Property (Document)

Gets and sets the character used in the recognition results that represents an unrecognized character.

[Visual Basic]
Public Property RejectionCharacter As RejectionCharacter
[C#]
public RejectionCharacter RejectionCharacter {get; set;}
[C++]
public: __property RejectionCharacter get_RejectionCharacter();
public: __property void set_RejectionCharacter(
   RejectionCharacter value
);
[C++/CLI]
public:
property RejectionCharacter RejectionCharacter {
   RejectionCharacter get();
   void set (RejectionCharacter value);
}

Return Type

The RejectionCharacter set.

Remarks

This property controls which character is used in the result text when recognition is unable to determine a value.

Default value: Tilde ('~')

Example

...

// Set the RejectionCharacter to the tilde from the RejectionCharacter enum options

ocrX.Document.RejectionCharacter = PegasusImaging.WinForms.OcrXpress1.RejectionCharacter.Tilde;

...

Requirements

Platforms: See Getting Started section

See Also

Document Class | Document Members


%%PageItemTitle%%

Document Class | Document Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

TextBoundary Property

PegasusImaging.WinForms.OcrXpress1 Namespace > Document Class : TextBoundary Property (Document)

Gets and sets how text regions should be defined by the Locate method.

[Visual Basic]
Public Property TextBoundary As TextBoundary
[C#]
public TextBoundary TextBoundary {get; set;}
[C++]
public: __property TextBoundary get_TextBoundary();
public: __property void set_TextBoundary(
   TextBoundary value
);
[C++/CLI]
public:
property TextBoundary TextBoundary {
   TextBoundary get();
   void set (TextBoundary value);
}

Remarks

In general, when you use the Normal setting, text regions are defined along paragraph and column boundaries.

When you use SingleColumn, this component ignores column and paragraph boundaries and defines text regions that go from the left margin to the right margin of the page.

Default Value: Normal

Example

...

// Set the TextBoundary to SingleColumn from the TextBoundary enum options

ocrX.Document.TextBoundary = PegasusImaging.WinForms.OcrXpress1.TextBoundary.Normal;

...

Requirements

Platforms: See Getting Started section

See Also

Document Class | Document Members


%%PageItemTitle%%

Document Class | Document Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

UserDictionary Property

PegasusImaging.WinForms.OcrXpress1 Namespace > Document Class : UserDictionary Property

Gets and sets the fully qualified path and filename of the user-supplemented recognition dictionary.

[Visual Basic]
Public Property UserDictionary As String
[C#]
public string UserDictionary {get; set;}
[C++]
public: __property string* get_UserDictionary();
public: __property void set_UserDictionary(
   string* value
);
[C++/CLI]
public:
property String^ UserDictionary {
   String^ get();
   void set (String^ value);
}

Remarks

If no user dictionary is needed, set this property to "" (Default).

A user dictionary is a simple text file of words separated by carriage returns. It is only used if the recognition process encounters a word that does not exist in any of its internal dictionaries, in which case it will search the user dictionary for a match.

A valid word consists of the following characters:

  • A..Z
  • a..z
  • .(dot)
  • -(hyphen)
  • &(ampersand)
  • "(double quotes)
  • '(single quote)

Plus several extended characters for international languages:

  • ANSI0192 - ANSI0207
  • ANSI0209 - ANSI0214
  • ANSI0216 - ANSI0220
  • ANSI0223 - ANSI0239
  • ANSI0241 - ANSI0246
  • ANSI0248 - ANSI0252

The user dictionary uses the ANSI codepage.

Default Value: ""

Example

...

// Set the file and path for the user dictionary to use

ocrX.Document.UserDictionary = "..\..\UserDictionary.txt";

...

Requirements

Platforms: See Getting Started section

See Also

Document Class | Document Members


%%PageItemTitle%%

FileExportException Members | PegasusImaging.WinForms.OcrXpress1 Namespace | Export Method

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

FileExportException Class

PegasusImaging.WinForms.OcrXpress1 Namespace : FileExportException Class

An exception object that the Document object will throw if the filename argument of the Export method contains an invalid path, or the file already exists and is in use by another process.

For a list of all members of this type, see FileExportException members.

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.OcrXpress1.OcrXpressException
PegasusImaging.WinForms.OcrXpress1.FileExportException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class FileExportException
   Inherits OcrXpressException
[C#]
[SerializableAttribute()]
public sealed class FileExportException : OcrXpressException
[C++]
[SerializableAttribute()]
public __gc __sealed class FileExportException : public OcrXpressException
[C++/CLI]
[SerializableAttribute()]
public ref class FileExportException sealed : public OcrXpressException

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

See Also

FileExportException Members | PegasusImaging.WinForms.OcrXpress1 Namespace | Export Method

© 1997 - 2007, Pegasus Imaging Corporation, All Rights Reserved.

Last Modified:


%%PageItemTitle%% $$Members$$

FileExportException Class | PegasusImaging.WinForms.OcrXpress1 Namespace | Export Method

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

FileExportException Class Members

PegasusImaging.WinForms.OcrXpress1 Namespace : FileExportException Class

FileExportException overview

Public Constructors

Public Constructor FileExportException Constructor Overloaded. Initializes a new instance of the FileExportException class.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from OcrXpressException) | The number of the error.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

FileExportException Class | PegasusImaging.WinForms.OcrXpress1 Namespace | Export Method


%%PageItemTitle%%

FileExportException Class | FileExportException Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

FileExportException Constructor

PegasusImaging.WinForms.OcrXpress1 Namespace > FileExportException Class : FileExportException Constructor (FileExportException)

Initializes a new instance of the FileExportException class.

Overload List

Initializes a new instance of the FileExportException class.

[Visual Basic] Public Sub New()

[C#] public FileExportException();

[C++] public FileExportException();

[C++/CLI] public FileExportException();

Initializes a new instance of the FileExportException class.

[Visual Basic] Public Sub New(Integer)

[C#] public FileExportException(int);

[C++] public FileExportException(int);

[C++/CLI] public FileExportException(int);

Initializes a new instance of the FileExportException class.

[Visual Basic] Public Sub New(String)

[C#] public FileExportException(string);

[C++] public FileExportException(string*);

[C++/CLI] public FileExportException(String^);

Initializes a new instance of the FileExportException class.

[Visual Basic] Public Sub New(Integer,String)

[C#] public FileExportException(int,string);

[C++] public FileExportException(int,string*);

[C++/CLI] public FileExportException(int,String^);

Initializes a new instance of the FileExportException class.

[Visual Basic] Public Sub New(String,Exception)

[C#] public FileExportException(string,Exception);

[C++] public FileExportException(string*,Exception*);

[C++/CLI] public FileExportException(String^,Exception^);

Requirements

Platforms: See Getting Started section

See Also

FileExportException Class | FileExportException Members


%%PageItemTitle%%

FileExportException Class | FileExportException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

FileExportException Constructor()

PegasusImaging.WinForms.OcrXpress1 Namespace > FileExportException Class > FileExportException Constructor : FileExportException Constructor()

Initializes a new instance of the FileExportException class.

[Visual Basic]
Public Function New()
[C#]
public FileExportException();
[C++]
public: FileExportException();
[C++/CLI]
public:
FileExportException();

Requirements

Platforms: See Getting Started section

See Also

FileExportException Class | FileExportException Members | Overload List


%%PageItemTitle%%

FileExportException Class | FileExportException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
A number that represents the reason you are creating this exception object.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

FileExportException Constructor(Int32)

PegasusImaging.WinForms.OcrXpress1 Namespace > FileExportException Class > FileExportException Constructor : FileExportException Constructor(Int32)

Initializes a new instance of the FileExportException class.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public FileExportException(
   int errorNumber
);
[C++]
public: FileExportException(
   int errorNumber
)
[C++/CLI]
public:
FileExportException(
   int errorNumber
)

Parameters

errorNumber
A number that represents the reason you are creating this exception object.

Requirements

Platforms: See Getting Started section

See Also

FileExportException Class | FileExportException Members | Overload List


%%PageItemTitle%%

FileExportException Class | FileExportException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
A number that represents the reason you are creating this exception object.
message
A string that describes the reason you are creating this exception object.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

FileExportException Constructor(Int32,String)

PegasusImaging.WinForms.OcrXpress1 Namespace > FileExportException Class > FileExportException Constructor : FileExportException Constructor(Int32,String)

Initializes a new instance of the FileExportException class.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public FileExportException(
   int errorNumber,
   string message
);
[C++]
public: FileExportException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
FileExportException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
A number that represents the reason you are creating this exception object.
message
A string that describes the reason you are creating this exception object.

Requirements

Platforms: See Getting Started section

See Also

FileExportException Class | FileExportException Members | Overload List


%%PageItemTitle%%

FileExportException Class | FileExportException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string that describes the reason you are creating this exception object.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

FileExportException Constructor(String)

PegasusImaging.WinForms.OcrXpress1 Namespace > FileExportException Class > FileExportException Constructor : FileExportException Constructor(String)

Initializes a new instance of the FileExportException class.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public FileExportException(
   string message
);
[C++]
public: FileExportException(
   string* message
)
[C++/CLI]
public:
FileExportException(
   String^ message
)

Parameters

message
A string that describes the reason you are creating this exception object.

Requirements

Platforms: See Getting Started section

See Also

FileExportException Class | FileExportException Members | Overload List


%%PageItemTitle%%

FileExportException Class | FileExportException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string that describes the reason you are creating this exception object.
innerException
The original exception that caused you to create this exception object.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

FileExportException Constructor(String,Exception)

PegasusImaging.WinForms.OcrXpress1 Namespace > FileExportException Class > FileExportException Constructor : FileExportException Constructor(String,Exception)

Initializes a new instance of the FileExportException class.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public FileExportException(
   string message,
   Exception innerException
);
[C++]
public: FileExportException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
FileExportException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string that describes the reason you are creating this exception object.
innerException
The original exception that caused you to create this exception object.

Requirements

Platforms: See Getting Started section

See Also

FileExportException Class | FileExportException Members | Overload List


%%PageItemTitle%%

FileInUseException Members | PegasusImaging.WinForms.OcrXpress1 Namespace

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

FileInUseException Class

PegasusImaging.WinForms.OcrXpress1 Namespace : FileInUseException Class

An exception object that this component will throw whenever you try to open a file that is already in use.

For a list of all members of this type, see FileInUseException members.

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.OcrXpress1.OcrXpressException
PegasusImaging.WinForms.OcrXpress1.FileInUseException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class FileInUseException
   Inherits OcrXpressException
[C#]
[SerializableAttribute()]
public sealed class FileInUseException : OcrXpressException
[C++]
[SerializableAttribute()]
public __gc __sealed class FileInUseException : public OcrXpressException
[C++/CLI]
[SerializableAttribute()]
public ref class FileInUseException sealed : public OcrXpressException

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

See Also

FileInUseException Members | PegasusImaging.WinForms.OcrXpress1 Namespace

© 1997 - 2007, Pegasus Imaging Corporation, All Rights Reserved.

Last Modified:


%%PageItemTitle%% $$Members$$

FileInUseException Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

FileInUseException Class Members

PegasusImaging.WinForms.OcrXpress1 Namespace : FileInUseException Class

FileInUseException overview

Public Constructors

Public Constructor FileInUseException Constructor Overloaded. Initializes a new instance of the FileInUseException class.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from OcrXpressException) | The number of the error.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

FileInUseException Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%%

FileInUseException Class | FileInUseException Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

FileInUseException Constructor

PegasusImaging.WinForms.OcrXpress1 Namespace > FileInUseException Class : FileInUseException Constructor (FileInUseException)

Initializes a new instance of the FileInUseException class.

Overload List

Initializes a new instance of the FileInUseException class.

[Visual Basic] Public Sub New()

[C#] public FileInUseException();

[C++] public FileInUseException();

[C++/CLI] public FileInUseException();

Initializes a new instance of the FileInUseException class.

[Visual Basic] Public Sub New(Integer)

[C#] public FileInUseException(int);

[C++] public FileInUseException(int);

[C++/CLI] public FileInUseException(int);

Initializes a new instance of the FileInUseException class.

[Visual Basic] Public Sub New(String)

[C#] public FileInUseException(string);

[C++] public FileInUseException(string*);

[C++/CLI] public FileInUseException(String^);

Initializes a new instance of the FileInUseException class.

[Visual Basic] Public Sub New(Integer,String)

[C#] public FileInUseException(int,string);

[C++] public FileInUseException(int,string*);

[C++/CLI] public FileInUseException(int,String^);

Initializes a new instance of the FileInUseException class.

[Visual Basic] Public Sub New(String,Exception)

[C#] public FileInUseException(string,Exception);

[C++] public FileInUseException(string*,Exception*);

[C++/CLI] public FileInUseException(String^,Exception^);

Requirements

Platforms: See Getting Started section

See Also

FileInUseException Class | FileInUseException Members


%%PageItemTitle%%

FileInUseException Class | FileInUseException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

FileInUseException Constructor()

PegasusImaging.WinForms.OcrXpress1 Namespace > FileInUseException Class > FileInUseException Constructor : FileInUseException Constructor()

Initializes a new instance of the FileInUseException class.

[Visual Basic]
Public Function New()
[C#]
public FileInUseException();
[C++]
public: FileInUseException();
[C++/CLI]
public:
FileInUseException();

Requirements

Platforms: See Getting Started section

See Also

FileInUseException Class | FileInUseException Members | Overload List


%%PageItemTitle%%

FileInUseException Class | FileInUseException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
A number that represents the reason you are creating this exception object.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

FileInUseException Constructor(Int32)

PegasusImaging.WinForms.OcrXpress1 Namespace > FileInUseException Class > FileInUseException Constructor : FileInUseException Constructor(Int32)

Initializes a new instance of the FileInUseException class.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public FileInUseException(
   int errorNumber
);
[C++]
public: FileInUseException(
   int errorNumber
)
[C++/CLI]
public:
FileInUseException(
   int errorNumber
)

Parameters

errorNumber
A number that represents the reason you are creating this exception object.

Requirements

Platforms: See Getting Started section

See Also

FileInUseException Class | FileInUseException Members | Overload List


%%PageItemTitle%%

FileInUseException Class | FileInUseException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
A number that represents the reason you are creating this exception object.
message
A string that describes the reason you are creating this exception object.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

FileInUseException Constructor(Int32,String)

PegasusImaging.WinForms.OcrXpress1 Namespace > FileInUseException Class > FileInUseException Constructor : FileInUseException Constructor(Int32,String)

Initializes a new instance of the FileInUseException class.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public FileInUseException(
   int errorNumber,
   string message
);
[C++]
public: FileInUseException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
FileInUseException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
A number that represents the reason you are creating this exception object.
message
A string that describes the reason you are creating this exception object.

Requirements

Platforms: See Getting Started section

See Also

FileInUseException Class | FileInUseException Members | Overload List


%%PageItemTitle%%

FileInUseException Class | FileInUseException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string that describes the reason you are creating this exception object.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

FileInUseException Constructor(String)

PegasusImaging.WinForms.OcrXpress1 Namespace > FileInUseException Class > FileInUseException Constructor : FileInUseException Constructor(String)

Initializes a new instance of the FileInUseException class.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public FileInUseException(
   string message
);
[C++]
public: FileInUseException(
   string* message
)
[C++/CLI]
public:
FileInUseException(
   String^ message
)

Parameters

message
A string that describes the reason you are creating this exception object.

Requirements

Platforms: See Getting Started section

See Also

FileInUseException Class | FileInUseException Members | Overload List


%%PageItemTitle%%

FileInUseException Class | FileInUseException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string that describes the reason you are creating this exception object.
innerException
The original exception that caused you to create this exception object.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

FileInUseException Constructor(String,Exception)

PegasusImaging.WinForms.OcrXpress1 Namespace > FileInUseException Class > FileInUseException Constructor : FileInUseException Constructor(String,Exception)

Initializes a new instance of the FileInUseException class.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public FileInUseException(
   string message,
   Exception innerException
);
[C++]
public: FileInUseException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
FileInUseException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string that describes the reason you are creating this exception object.
innerException
The original exception that caused you to create this exception object.

Requirements

Platforms: See Getting Started section

See Also

FileInUseException Class | FileInUseException Members | Overload List


%%PageItemTitle%%

FontMap Members | PegasusImaging.WinForms.OcrXpress1 Namespace | Font Maps

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

FontMap Class

PegasusImaging.WinForms.OcrXpress1 Namespace : FontMap Class

An object that defines the font information for a group of characters within the recognition text results.

For a list of all members of this type, see FontMap members.

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.OcrXpress1.FontMap

Syntax

[Visual Basic]
Public Class FontMap
[C#]
public class FontMap
[C++]
public __gc class FontMap
[C++/CLI]
public ref class FontMap

Remarks

There can be one to many FontMaps defined for a single TextLineResult. Each FontMap points to a specific run of characters within the text line result.

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

See Also

FontMap Members | PegasusImaging.WinForms.OcrXpress1 Namespace | Font Maps

© 1997 - 2007, Pegasus Imaging Corporation, All Rights Reserved.

Last Modified:


%%PageItemTitle%% $$Members$$

FontMap Class | PegasusImaging.WinForms.OcrXpress1 Namespace | Font Maps

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

FontMap Class Members

PegasusImaging.WinForms.OcrXpress1 Namespace : FontMap Class

FontMap overview

Public Properties

Public Property Bold | Gets a value indicating whether this FontMap object describes bold text.
Public Property FontFamily | Gets the FontFamily type of the text described by this FontMap object.
Public Property Italic | Gets a value indicating whether this FontMap object describes italic text.
Public Property RunLength | Gets the number of characters within the parent TextLineResult that have this font mapping.
Public Property SizeInPoints | Gets the size, in points, of the text described by this FontMap object.
Public Property StartPosition | Gets the zero-based start position of the characters within the parent TextLineResult that have this font mapping.
Public Property Subscript | Gets a value indicating whether this FontMap object describes subscript text.
Public Property Superscript | Gets a value indicating whether this FontMap object describes superscript text.
Public Property Underline | Gets a value indicating whether this FontMap object describes underlined text.

See Also

FontMap Class | PegasusImaging.WinForms.OcrXpress1 Namespace | Font Maps


%%PageItemTitle%% $$Properties$$

FontMap Class | PegasusImaging.WinForms.OcrXpress1 Namespace | Font Maps

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

FontMap Class Properties

PegasusImaging.WinForms.OcrXpress1 Namespace : FontMap Class

For a list of all members of this type, see FontMap members.

Public Properties

Public Property Bold | Gets a value indicating whether this FontMap object describes bold text.
Public Property FontFamily | Gets the FontFamily type of the text described by this FontMap object.
Public Property Italic | Gets a value indicating whether this FontMap object describes italic text.
Public Property RunLength | Gets the number of characters within the parent TextLineResult that have this font mapping.
Public Property SizeInPoints | Gets the size, in points, of the text described by this FontMap object.
Public Property StartPosition | Gets the zero-based start position of the characters within the parent TextLineResult that have this font mapping.
Public Property Subscript | Gets a value indicating whether this FontMap object describes subscript text.
Public Property Superscript | Gets a value indicating whether this FontMap object describes superscript text.
Public Property Underline | Gets a value indicating whether this FontMap object describes underlined text.

See Also

FontMap Class | PegasusImaging.WinForms.OcrXpress1 Namespace | Font Maps


%%PageItemTitle%%

FontMap Class | FontMap Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

Bold Property

PegasusImaging.WinForms.OcrXpress1 Namespace > FontMap Class : Bold Property

Gets a value indicating whether this FontMap object describes bold text.

[Visual Basic]
Public ReadOnly Property Bold As Boolean
[C#]
public bool Bold {get;}
[C++]
public: __property bool get_Bold();
[C++/CLI]
public:
property bool Bold {
   bool get();
}

Return Type

A boolean value which returns true if this FontMap object is bold; otherwise, false.

Requirements

Platforms: See Getting Started section

See Also

FontMap Class | FontMap Members


%%PageItemTitle%%

FontMap Class | FontMap Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

FontFamily Property

PegasusImaging.WinForms.OcrXpress1 Namespace > FontMap Class : FontFamily Property

Gets the FontFamily type of the text described by this FontMap object.

[Visual Basic]
Public ReadOnly Property FontFamily As GenericFontFamilies
[C#]
public GenericFontFamilies FontFamily {get;}
[C++]
public: __property GenericFontFamilies get_FontFamily();
[C++/CLI]
public:
property GenericFontFamilies FontFamily {
   GenericFontFamilies get();
}

Return Type

The FontFamily type of this FontMap object.

Requirements

Platforms: See Getting Started section

See Also

FontMap Class | FontMap Members


%%PageItemTitle%%

FontMap Class | FontMap Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

Italic Property

PegasusImaging.WinForms.OcrXpress1 Namespace > FontMap Class : Italic Property

Gets a value indicating whether this FontMap object describes italic text.

[Visual Basic]
Public ReadOnly Property Italic As Boolean
[C#]
public bool Italic {get;}
[C++]
public: __property bool get_Italic();
[C++/CLI]
public:
property bool Italic {
   bool get();
}

Return Type

A boolean value which returns true if this FontMap object is italic; otherwise, false.

Requirements

Platforms: See Getting Started section

See Also

FontMap Class | FontMap Members


%%PageItemTitle%%

FontMap Class | FontMap Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

RunLength Property

PegasusImaging.WinForms.OcrXpress1 Namespace > FontMap Class : RunLength Property

Gets the number of characters within the parent TextLineResult that have this font mapping.

[Visual Basic]
Public ReadOnly Property RunLength As Integer
[C#]
public int RunLength {get;}
[C++]
public: __property int get_RunLength();
[C++/CLI]
public:
property int RunLength {
   int get();
}

Return Type

An integer which represents the run length of the font map.

Remarks

This property gets the number of characters from the StartPosition that are represented by this FontMap.

Requirements

Platforms: See Getting Started section

See Also

FontMap Class | FontMap Members


%%PageItemTitle%%

FontMap Class | FontMap Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

SizeInPoints Property

PegasusImaging.WinForms.OcrXpress1 Namespace > FontMap Class : SizeInPoints Property

Gets the size, in points, of the text described by this FontMap object.

[Visual Basic]
Public ReadOnly Property SizeInPoints As Integer
[C#]
public int SizeInPoints {get;}
[C++]
public: __property int get_SizeInPoints();
[C++/CLI]
public:
property int SizeInPoints {
   int get();
}

Return Type

An integer which represents the size, in points, of this FontMap object.

Requirements

Platforms: See Getting Started section

See Also

FontMap Class | FontMap Members


%%PageItemTitle%%

FontMap Class | FontMap Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

StartPosition Property

PegasusImaging.WinForms.OcrXpress1 Namespace > FontMap Class : StartPosition Property

Gets the zero-based start position of the characters within the parent TextLineResult that have this font mapping.

[Visual Basic]
Public ReadOnly Property StartPosition As Integer
[C#]
public int StartPosition {get;}
[C++]
public: __property int get_StartPosition();
[C++/CLI]
public:
property int StartPosition {
   int get();
}

Return Type

An integer which represents the starting position of the font map.

Requirements

Platforms: See Getting Started section

See Also

FontMap Class | FontMap Members


%%PageItemTitle%%

FontMap Class | FontMap Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

Subscript Property

PegasusImaging.WinForms.OcrXpress1 Namespace > FontMap Class : Subscript Property

Gets a value indicating whether this FontMap object describes subscript text.

[Visual Basic]
Public ReadOnly Property Subscript As Boolean
[C#]
public bool Subscript {get;}
[C++]
public: __property bool get_Subscript();
[C++/CLI]
public:
property bool Subscript {
   bool get();
}

Return Type

A boolean value which returns true if this FontMap object is subscript; otherwise, false.

Remarks

This property is mutually exclusive of the Bold, Italic, Underline and Superscript properties. If true, all of the above listed properties will be false.

Requirements

Platforms: See Getting Started section

See Also

FontMap Class | FontMap Members


%%PageItemTitle%%

FontMap Class | FontMap Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

Superscript Property

PegasusImaging.WinForms.OcrXpress1 Namespace > FontMap Class : Superscript Property

Gets a value indicating whether this FontMap object describes superscript text.

[Visual Basic]
Public ReadOnly Property Superscript As Boolean
[C#]
public bool Superscript {get;}
[C++]
public: __property bool get_Superscript();
[C++/CLI]
public:
property bool Superscript {
   bool get();
}

Return Type

A boolean value which returns true if this FontMap object is superscript; otherwise, false.

Remarks

This property is mutually exclusive of the Bold, Italic, Underline and Subscript properties. If true, all of the above listed properties will be false.

Requirements

Platforms: See Getting Started section

See Also

FontMap Class | FontMap Members


%%PageItemTitle%%

FontMap Class | FontMap Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

Underline Property

PegasusImaging.WinForms.OcrXpress1 Namespace > FontMap Class : Underline Property

Gets a value indicating whether this FontMap object describes underlined text.

[Visual Basic]
Public ReadOnly Property Underline As Boolean
[C#]
public bool Underline {get;}
[C++]
public: __property bool get_Underline();
[C++/CLI]
public:
property bool Underline {
   bool get();
}

Return Type

A boolean value which returns true if this FontMap object is underlined; otherwise, false.

Requirements

Platforms: See Getting Started section

See Also

FontMap Class | FontMap Members


%%PageItemTitle%%

ImageNotAvailableException Members | PegasusImaging.WinForms.OcrXpress1 Namespace

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

ImageNotAvailableException Class

PegasusImaging.WinForms.OcrXpress1 Namespace : ImageNotAvailableException Class

An exception object that this component will throw whenever there is no image available for an operation that requires one.

For a list of all members of this type, see ImageNotAvailableException members.

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.OcrXpress1.OcrXpressException
PegasusImaging.WinForms.OcrXpress1.ImageNotAvailableException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class ImageNotAvailableException
   Inherits OcrXpressException
[C#]
[SerializableAttribute()]
public sealed class ImageNotAvailableException : OcrXpressException
[C++]
[SerializableAttribute()]
public __gc __sealed class ImageNotAvailableException : public OcrXpressException
[C++/CLI]
[SerializableAttribute()]
public ref class ImageNotAvailableException sealed : public OcrXpressException

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

See Also

ImageNotAvailableException Members | PegasusImaging.WinForms.OcrXpress1 Namespace

© 1997 - 2007, Pegasus Imaging Corporation, All Rights Reserved.

Last Modified:


%%PageItemTitle%% $$Members$$

ImageNotAvailableException Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

ImageNotAvailableException Class Members

PegasusImaging.WinForms.OcrXpress1 Namespace : ImageNotAvailableException Class

ImageNotAvailableException overview

Public Constructors

Public Constructor ImageNotAvailableException Constructor Overloaded. Initializes a new instance of the ImageNotAvailableException class.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from OcrXpressException) | The number of the error.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

ImageNotAvailableException Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%%

ImageNotAvailableException Class | ImageNotAvailableException Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

ImageNotAvailableException Constructor

PegasusImaging.WinForms.OcrXpress1 Namespace > ImageNotAvailableException Class : ImageNotAvailableException Constructor (ImageNotAvailableException)

Initializes a new instance of the ImageNotAvailableException class.

Overload List

Initializes a new instance of the ImageNotAvailableException class.

[Visual Basic] Public Sub New()

[C#] public ImageNotAvailableException();

[C++] public ImageNotAvailableException();

[C++/CLI] public ImageNotAvailableException();

Initializes a new instance of the ImageNotAvailableException class.

[Visual Basic] Public Sub New(Integer)

[C#] public ImageNotAvailableException(int);

[C++] public ImageNotAvailableException(int);

[C++/CLI] public ImageNotAvailableException(int);

Initializes a new instance of the ImageNotAvailableException class.

[Visual Basic] Public Sub New(String)

[C#] public ImageNotAvailableException(string);

[C++] public ImageNotAvailableException(string*);

[C++/CLI] public ImageNotAvailableException(String^);

Initializes a new instance of the ImageNotAvailableException class.

[Visual Basic] Public Sub New(Integer,String)

[C#] public ImageNotAvailableException(int,string);

[C++] public ImageNotAvailableException(int,string*);

[C++/CLI] public ImageNotAvailableException(int,String^);

Initializes a new instance of the ImageNotAvailableException class.

[Visual Basic] Public Sub New(String,Exception)

[C#] public ImageNotAvailableException(string,Exception);

[C++] public ImageNotAvailableException(string*,Exception*);

[C++/CLI] public ImageNotAvailableException(String^,Exception^);

Requirements

Platforms: See Getting Started section

See Also

ImageNotAvailableException Class | ImageNotAvailableException Members


%%PageItemTitle%%

ImageNotAvailableException Class | ImageNotAvailableException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

ImageNotAvailableException Constructor()

PegasusImaging.WinForms.OcrXpress1 Namespace > ImageNotAvailableException Class > ImageNotAvailableException Constructor : ImageNotAvailableException Constructor()

Initializes a new instance of the ImageNotAvailableException class.

[Visual Basic]
Public Function New()
[C#]
public ImageNotAvailableException();
[C++]
public: ImageNotAvailableException();
[C++/CLI]
public:
ImageNotAvailableException();

Requirements

Platforms: See Getting Started section

See Also

ImageNotAvailableException Class | ImageNotAvailableException Members | Overload List


%%PageItemTitle%%

ImageNotAvailableException Class | ImageNotAvailableException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

ImageNotAvailableException Constructor(Int32)

PegasusImaging.WinForms.OcrXpress1 Namespace > ImageNotAvailableException Class > ImageNotAvailableException Constructor : ImageNotAvailableException Constructor(Int32)

Initializes a new instance of the ImageNotAvailableException class.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public ImageNotAvailableException(
   int errorNumber
);
[C++]
public: ImageNotAvailableException(
   int errorNumber
)
[C++/CLI]
public:
ImageNotAvailableException(
   int errorNumber
)

Parameters

errorNumber

Requirements

Platforms: See Getting Started section

See Also

ImageNotAvailableException Class | ImageNotAvailableException Members | Overload List


%%PageItemTitle%%

ImageNotAvailableException Class | ImageNotAvailableException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
message
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

ImageNotAvailableException Constructor(Int32,String)

PegasusImaging.WinForms.OcrXpress1 Namespace > ImageNotAvailableException Class > ImageNotAvailableException Constructor : ImageNotAvailableException Constructor(Int32,String)

Initializes a new instance of the ImageNotAvailableException class.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public ImageNotAvailableException(
   int errorNumber,
   string message
);
[C++]
public: ImageNotAvailableException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
ImageNotAvailableException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
message

Requirements

Platforms: See Getting Started section

See Also

ImageNotAvailableException Class | ImageNotAvailableException Members | Overload List


%%PageItemTitle%%

ImageNotAvailableException Class | ImageNotAvailableException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

ImageNotAvailableException Constructor(String)

PegasusImaging.WinForms.OcrXpress1 Namespace > ImageNotAvailableException Class > ImageNotAvailableException Constructor : ImageNotAvailableException Constructor(String)

Initializes a new instance of the ImageNotAvailableException class.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public ImageNotAvailableException(
   string message
);
[C++]
public: ImageNotAvailableException(
   string* message
)
[C++/CLI]
public:
ImageNotAvailableException(
   String^ message
)

Parameters

message

Requirements

Platforms: See Getting Started section

See Also

ImageNotAvailableException Class | ImageNotAvailableException Members | Overload List


%%PageItemTitle%%

ImageNotAvailableException Class | ImageNotAvailableException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
innerException
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

ImageNotAvailableException Constructor(String,Exception)

PegasusImaging.WinForms.OcrXpress1 Namespace > ImageNotAvailableException Class > ImageNotAvailableException Constructor : ImageNotAvailableException Constructor(String,Exception)

Initializes a new instance of the ImageNotAvailableException class.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public ImageNotAvailableException(
   string message,
   Exception innerException
);
[C++]
public: ImageNotAvailableException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
ImageNotAvailableException(
   String^ message,
   Exception^ innerException
)

Parameters

message
innerException

Requirements

Platforms: See Getting Started section

See Also

ImageNotAvailableException Class | ImageNotAvailableException Members | Overload List


%%PageItemTitle%%

ImageNullException Members | PegasusImaging.WinForms.OcrXpress1 Namespace

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

ImageNullException Class

PegasusImaging.WinForms.OcrXpress1 Namespace : ImageNullException Class

An exception object that the Page object will throw whenever the input image to any of the image properties is null.

For a list of all members of this type, see ImageNullException members.

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.OcrXpress1.OcrXpressException
PegasusImaging.WinForms.OcrXpress1.ImageNullException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class ImageNullException
   Inherits OcrXpressException
[C#]
[SerializableAttribute()]
public sealed class ImageNullException : OcrXpressException
[C++]
[SerializableAttribute()]
public __gc __sealed class ImageNullException : public OcrXpressException
[C++/CLI]
[SerializableAttribute()]
public ref class ImageNullException sealed : public OcrXpressException

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

See Also

ImageNullException Members | PegasusImaging.WinForms.OcrXpress1 Namespace

© 1997 - 2007, Pegasus Imaging Corporation, All Rights Reserved.

Last Modified:


%%PageItemTitle%% $$Members$$

ImageNullException Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

ImageNullException Class Members

PegasusImaging.WinForms.OcrXpress1 Namespace : ImageNullException Class

ImageNullException overview

Public Constructors

Public Constructor ImageNullException Constructor Overloaded. Initializes a new instance of the ImageNullException class.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from OcrXpressException) | The number of the error.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

ImageNullException Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%%

ImageNullException Class | ImageNullException Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

ImageNullException Constructor

PegasusImaging.WinForms.OcrXpress1 Namespace > ImageNullException Class : ImageNullException Constructor (ImageNullException)

Initializes a new instance of the ImageNullException class.

Overload List

Initializes a new instance of the ImageNullException class.

[Visual Basic] Public Sub New()

[C#] public ImageNullException();

[C++] public ImageNullException();

[C++/CLI] public ImageNullException();

Initializes a new instance of the ImageNullException class.

[Visual Basic] Public Sub New(Integer)

[C#] public ImageNullException(int);

[C++] public ImageNullException(int);

[C++/CLI] public ImageNullException(int);

Initializes a new instance of the ImageNullException class.

[Visual Basic] Public Sub New(String)

[C#] public ImageNullException(string);

[C++] public ImageNullException(string*);

[C++/CLI] public ImageNullException(String^);

Initializes a new instance of the ImageNullException class.

[Visual Basic] Public Sub New(Integer,String)

[C#] public ImageNullException(int,string);

[C++] public ImageNullException(int,string*);

[C++/CLI] public ImageNullException(int,String^);

Initializes a new instance of the ImageNullException class.

[Visual Basic] Public Sub New(String,Exception)

[C#] public ImageNullException(string,Exception);

[C++] public ImageNullException(string*,Exception*);

[C++/CLI] public ImageNullException(String^,Exception^);

Requirements

Platforms: See Getting Started section

See Also

ImageNullException Class | ImageNullException Members


%%PageItemTitle%%

ImageNullException Class | ImageNullException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

ImageNullException Constructor()

PegasusImaging.WinForms.OcrXpress1 Namespace > ImageNullException Class > ImageNullException Constructor : ImageNullException Constructor()

Initializes a new instance of the ImageNullException class.

[Visual Basic]
Public Function New()
[C#]
public ImageNullException();
[C++]
public: ImageNullException();
[C++/CLI]
public:
ImageNullException();

Requirements

Platforms: See Getting Started section

See Also

ImageNullException Class | ImageNullException Members | Overload List


%%PageItemTitle%%

ImageNullException Class | ImageNullException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
A number that represents the reason you are creating this exception object.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

ImageNullException Constructor(Int32)

PegasusImaging.WinForms.OcrXpress1 Namespace > ImageNullException Class > ImageNullException Constructor : ImageNullException Constructor(Int32)

Initializes a new instance of the ImageNullException class.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public ImageNullException(
   int errorNumber
);
[C++]
public: ImageNullException(
   int errorNumber
)
[C++/CLI]
public:
ImageNullException(
   int errorNumber
)

Parameters

errorNumber
A number that represents the reason you are creating this exception object.

Requirements

Platforms: See Getting Started section

See Also

ImageNullException Class | ImageNullException Members | Overload List


%%PageItemTitle%%

ImageNullException Class | ImageNullException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
A number that represents the reason you are creating this exception object.
message
A string that describes the reason you are creating this exception object.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

ImageNullException Constructor(Int32,String)

PegasusImaging.WinForms.OcrXpress1 Namespace > ImageNullException Class > ImageNullException Constructor : ImageNullException Constructor(Int32,String)

Initializes a new instance of the ImageNullException class.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public ImageNullException(
   int errorNumber,
   string message
);
[C++]
public: ImageNullException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
ImageNullException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
A number that represents the reason you are creating this exception object.
message
A string that describes the reason you are creating this exception object.

Requirements

Platforms: See Getting Started section

See Also

ImageNullException Class | ImageNullException Members | Overload List


%%PageItemTitle%%

ImageNullException Class | ImageNullException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string that describes the reason you are creating this exception object.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

ImageNullException Constructor(String)

PegasusImaging.WinForms.OcrXpress1 Namespace > ImageNullException Class > ImageNullException Constructor : ImageNullException Constructor(String)

Initializes a new instance of the ImageNullException class.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public ImageNullException(
   string message
);
[C++]
public: ImageNullException(
   string* message
)
[C++/CLI]
public:
ImageNullException(
   String^ message
)

Parameters

message
A string that describes the reason you are creating this exception object.

Requirements

Platforms: See Getting Started section

See Also

ImageNullException Class | ImageNullException Members | Overload List


%%PageItemTitle%%

ImageNullException Class | ImageNullException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string that describes the reason you are creating this exception object.
innerException
The original exception that caused you to create this exception object.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

ImageNullException Constructor(String,Exception)

PegasusImaging.WinForms.OcrXpress1 Namespace > ImageNullException Class > ImageNullException Constructor : ImageNullException Constructor(String,Exception)

Initializes a new instance of the ImageNullException class.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public ImageNullException(
   string message,
   Exception innerException
);
[C++]
public: ImageNullException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
ImageNullException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string that describes the reason you are creating this exception object.
innerException
The original exception that caused you to create this exception object.

Requirements

Platforms: See Getting Started section

See Also

ImageNullException Class | ImageNullException Members | Overload List


%%PageItemTitle%%

InternalErrorException Members | PegasusImaging.WinForms.OcrXpress1 Namespace

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

InternalErrorException Class

PegasusImaging.WinForms.OcrXpress1 Namespace : InternalErrorException Class

An exception object that this component will throw whenever an unhandled exception is encountered.

For a list of all members of this type, see InternalErrorException members.

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.OcrXpress1.OcrXpressException
PegasusImaging.WinForms.OcrXpress1.InternalErrorException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class InternalErrorException
   Inherits OcrXpressException
[C#]
[SerializableAttribute()]
public sealed class InternalErrorException : OcrXpressException
[C++]
[SerializableAttribute()]
public __gc __sealed class InternalErrorException : public OcrXpressException
[C++/CLI]
[SerializableAttribute()]
public ref class InternalErrorException sealed : public OcrXpressException

Remarks

This exception is thrown generally to catch unhandled exceptions from other sources or methods. See the DebugLogFile for additional information.

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

See Also

InternalErrorException Members | PegasusImaging.WinForms.OcrXpress1 Namespace

© 1997 - 2007, Pegasus Imaging Corporation, All Rights Reserved.

Last Modified:


%%PageItemTitle%% $$Members$$

InternalErrorException Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

InternalErrorException Class Members

PegasusImaging.WinForms.OcrXpress1 Namespace : InternalErrorException Class

InternalErrorException overview

Public Constructors

Public Constructor InternalErrorException Constructor Overloaded. Initializes a new instance of the InternalErrorException class.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from OcrXpressException) | The number of the error.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InternalErrorException Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%%

InternalErrorException Class | InternalErrorException Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

InternalErrorException Constructor

PegasusImaging.WinForms.OcrXpress1 Namespace > InternalErrorException Class : InternalErrorException Constructor (InternalErrorException)

Initializes a new instance of the InternalErrorException class.

Overload List

Initializes a new instance of the InternalErrorException class.

[Visual Basic] Public Sub New()

[C#] public InternalErrorException();

[C++] public InternalErrorException();

[C++/CLI] public InternalErrorException();

Initializes a new instance of the InternalErrorException class.

[Visual Basic] Public Sub New(Integer)

[C#] public InternalErrorException(int);

[C++] public InternalErrorException(int);

[C++/CLI] public InternalErrorException(int);

Initializes a new instance of the InternalErrorException class.

[Visual Basic] Public Sub New(String)

[C#] public InternalErrorException(string);

[C++] public InternalErrorException(string*);

[C++/CLI] public InternalErrorException(String^);

Initializes a new instance of the InternalErrorException class.

[Visual Basic] Public Sub New(Integer,String)

[C#] public InternalErrorException(int,string);

[C++] public InternalErrorException(int,string*);

[C++/CLI] public InternalErrorException(int,String^);

Initializes a new instance of the InternalErrorException class.

[Visual Basic] Public Sub New(String,Exception)

[C#] public InternalErrorException(string,Exception);

[C++] public InternalErrorException(string*,Exception*);

[C++/CLI] public InternalErrorException(String^,Exception^);

Requirements

Platforms: See Getting Started section

See Also

InternalErrorException Class | InternalErrorException Members


%%PageItemTitle%%

InternalErrorException Class | InternalErrorException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

InternalErrorException Constructor()

PegasusImaging.WinForms.OcrXpress1 Namespace > InternalErrorException Class > InternalErrorException Constructor : InternalErrorException Constructor()

Initializes a new instance of the InternalErrorException class.

[Visual Basic]
Public Function New()
[C#]
public InternalErrorException();
[C++]
public: InternalErrorException();
[C++/CLI]
public:
InternalErrorException();

Requirements

Platforms: See Getting Started section

See Also

InternalErrorException Class | InternalErrorException Members | Overload List


%%PageItemTitle%%

InternalErrorException Class | InternalErrorException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

InternalErrorException Constructor(Int32)

PegasusImaging.WinForms.OcrXpress1 Namespace > InternalErrorException Class > InternalErrorException Constructor : InternalErrorException Constructor(Int32)

Initializes a new instance of the InternalErrorException class.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public InternalErrorException(
   int errorNumber
);
[C++]
public: InternalErrorException(
   int errorNumber
)
[C++/CLI]
public:
InternalErrorException(
   int errorNumber
)

Parameters

errorNumber

Requirements

Platforms: See Getting Started section

See Also

InternalErrorException Class | InternalErrorException Members | Overload List


%%PageItemTitle%%

InternalErrorException Class | InternalErrorException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
message
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

InternalErrorException Constructor(Int32,String)

PegasusImaging.WinForms.OcrXpress1 Namespace > InternalErrorException Class > InternalErrorException Constructor : InternalErrorException Constructor(Int32,String)

Initializes a new instance of the InternalErrorException class.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public InternalErrorException(
   int errorNumber,
   string message
);
[C++]
public: InternalErrorException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
InternalErrorException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
message

Requirements

Platforms: See Getting Started section

See Also

InternalErrorException Class | InternalErrorException Members | Overload List


%%PageItemTitle%%

InternalErrorException Class | InternalErrorException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

InternalErrorException Constructor(String)

PegasusImaging.WinForms.OcrXpress1 Namespace > InternalErrorException Class > InternalErrorException Constructor : InternalErrorException Constructor(String)

Initializes a new instance of the InternalErrorException class.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public InternalErrorException(
   string message
);
[C++]
public: InternalErrorException(
   string* message
)
[C++/CLI]
public:
InternalErrorException(
   String^ message
)

Parameters

message

Requirements

Platforms: See Getting Started section

See Also

InternalErrorException Class | InternalErrorException Members | Overload List


%%PageItemTitle%%

InternalErrorException Class | InternalErrorException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
innerException
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

InternalErrorException Constructor(String,Exception)

PegasusImaging.WinForms.OcrXpress1 Namespace > InternalErrorException Class > InternalErrorException Constructor : InternalErrorException Constructor(String,Exception)

Initializes a new instance of the InternalErrorException class.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public InternalErrorException(
   string message,
   Exception innerException
);
[C++]
public: InternalErrorException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
InternalErrorException(
   String^ message,
   Exception^ innerException
)

Parameters

message
innerException

Requirements

Platforms: See Getting Started section

See Also

InternalErrorException Class | InternalErrorException Members | Overload List


%%PageItemTitle%%

InvalidAreaException Members | PegasusImaging.WinForms.OcrXpress1 Namespace

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

InvalidAreaException Class

PegasusImaging.WinForms.OcrXpress1 Namespace : InvalidAreaException Class

An exception object that this component will throw whenever a Region object contains an area that is outside the bounds of the image.

For a list of all members of this type, see InvalidAreaException members.

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.OcrXpress1.OcrXpressException
PegasusImaging.WinForms.OcrXpress1.InvalidAreaException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class InvalidAreaException
   Inherits OcrXpressException
[C#]
[SerializableAttribute()]
public sealed class InvalidAreaException : OcrXpressException
[C++]
[SerializableAttribute()]
public __gc __sealed class InvalidAreaException : public OcrXpressException
[C++/CLI]
[SerializableAttribute()]
public ref class InvalidAreaException sealed : public OcrXpressException

Remarks

This exception is thrown if applicable, when the SetRegions method is called.

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

See Also

InvalidAreaException Members | PegasusImaging.WinForms.OcrXpress1 Namespace

© 1997 - 2007, Pegasus Imaging Corporation, All Rights Reserved.

Last Modified:


%%PageItemTitle%% $$Members$$

InvalidAreaException Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

InvalidAreaException Class Members

PegasusImaging.WinForms.OcrXpress1 Namespace : InvalidAreaException Class

InvalidAreaException overview

Public Constructors

Public Constructor InvalidAreaException Constructor Overloaded. Initializes a new instance of the InvalidAreaException class.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from OcrXpressException) | The number of the error.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InvalidAreaException Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%%

InvalidAreaException Class | InvalidAreaException Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

InvalidAreaException Constructor

PegasusImaging.WinForms.OcrXpress1 Namespace > InvalidAreaException Class : InvalidAreaException Constructor (InvalidAreaException)

Initializes a new instance of the InvalidAreaException class.

Overload List

Initializes a new instance of the InvalidAreaException class.

[Visual Basic] Public Sub New()

[C#] public InvalidAreaException();

[C++] public InvalidAreaException();

[C++/CLI] public InvalidAreaException();

Initializes a new instance of the InvalidAreaException class.

[Visual Basic] Public Sub New(Integer)

[C#] public InvalidAreaException(int);

[C++] public InvalidAreaException(int);

[C++/CLI] public InvalidAreaException(int);

Initializes a new instance of the InvalidAreaException class.

[Visual Basic] Public Sub New(String)

[C#] public InvalidAreaException(string);

[C++] public InvalidAreaException(string*);

[C++/CLI] public InvalidAreaException(String^);

Initializes a new instance of the InvalidAreaException class.

[Visual Basic] Public Sub New(Integer,String)

[C#] public InvalidAreaException(int,string);

[C++] public InvalidAreaException(int,string*);

[C++/CLI] public InvalidAreaException(int,String^);

Initializes a new instance of the InvalidAreaException class.

[Visual Basic] Public Sub New(String,Exception)

[C#] public InvalidAreaException(string,Exception);

[C++] public InvalidAreaException(string*,Exception*);

[C++/CLI] public InvalidAreaException(String^,Exception^);

Requirements

Platforms: See Getting Started section

See Also

InvalidAreaException Class | InvalidAreaException Members


%%PageItemTitle%%

InvalidAreaException Class | InvalidAreaException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

InvalidAreaException Constructor()

PegasusImaging.WinForms.OcrXpress1 Namespace > InvalidAreaException Class > InvalidAreaException Constructor : InvalidAreaException Constructor()

Initializes a new instance of the InvalidAreaException class.

[Visual Basic]
Public Function New()
[C#]
public InvalidAreaException();
[C++]
public: InvalidAreaException();
[C++/CLI]
public:
InvalidAreaException();

Requirements

Platforms: See Getting Started section

See Also

InvalidAreaException Class | InvalidAreaException Members | Overload List


%%PageItemTitle%%

InvalidAreaException Class | InvalidAreaException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

InvalidAreaException Constructor(Int32)

PegasusImaging.WinForms.OcrXpress1 Namespace > InvalidAreaException Class > InvalidAreaException Constructor : InvalidAreaException Constructor(Int32)

Initializes a new instance of the InvalidAreaException class.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public InvalidAreaException(
   int errorNumber
);
[C++]
public: InvalidAreaException(
   int errorNumber
)
[C++/CLI]
public:
InvalidAreaException(
   int errorNumber
)

Parameters

errorNumber

Requirements

Platforms: See Getting Started section

See Also

InvalidAreaException Class | InvalidAreaException Members | Overload List


%%PageItemTitle%%

InvalidAreaException Class | InvalidAreaException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
message
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

InvalidAreaException Constructor(Int32,String)

PegasusImaging.WinForms.OcrXpress1 Namespace > InvalidAreaException Class > InvalidAreaException Constructor : InvalidAreaException Constructor(Int32,String)

Initializes a new instance of the InvalidAreaException class.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public InvalidAreaException(
   int errorNumber,
   string message
);
[C++]
public: InvalidAreaException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
InvalidAreaException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
message

Requirements

Platforms: See Getting Started section

See Also

InvalidAreaException Class | InvalidAreaException Members | Overload List


%%PageItemTitle%%

InvalidAreaException Class | InvalidAreaException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

InvalidAreaException Constructor(String)

PegasusImaging.WinForms.OcrXpress1 Namespace > InvalidAreaException Class > InvalidAreaException Constructor : InvalidAreaException Constructor(String)

Initializes a new instance of the InvalidAreaException class.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public InvalidAreaException(
   string message
);
[C++]
public: InvalidAreaException(
   string* message
)
[C++/CLI]
public:
InvalidAreaException(
   String^ message
)

Parameters

message

Requirements

Platforms: See Getting Started section

See Also

InvalidAreaException Class | InvalidAreaException Members | Overload List


%%PageItemTitle%%

InvalidAreaException Class | InvalidAreaException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
innerException
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

InvalidAreaException Constructor(String,Exception)

PegasusImaging.WinForms.OcrXpress1 Namespace > InvalidAreaException Class > InvalidAreaException Constructor : InvalidAreaException Constructor(String,Exception)

Initializes a new instance of the InvalidAreaException class.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public InvalidAreaException(
   string message,
   Exception innerException
);
[C++]
public: InvalidAreaException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
InvalidAreaException(
   String^ message,
   Exception^ innerException
)

Parameters

message
innerException

Requirements

Platforms: See Getting Started section

See Also

InvalidAreaException Class | InvalidAreaException Members | Overload List


%%PageItemTitle%%

InvalidBitonalImageException Members | PegasusImaging.WinForms.OcrXpress1 Namespace

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

InvalidBitonalImageException Class

PegasusImaging.WinForms.OcrXpress1 Namespace : InvalidBitonalImageException Class

An exception object that the Page object will throw whenever you try to assign a a color or grayscale image to the bitonal image properties.

For a list of all members of this type, see InvalidBitonalImageException members.

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.OcrXpress1.OcrXpressException
PegasusImaging.WinForms.OcrXpress1.InvalidBitonalImageException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class InvalidBitonalImageException
   Inherits OcrXpressException
[C#]
[SerializableAttribute()]
public sealed class InvalidBitonalImageException : OcrXpressException
[C++]
[SerializableAttribute()]
public __gc __sealed class InvalidBitonalImageException : public OcrXpressException
[C++/CLI]
[SerializableAttribute()]
public ref class InvalidBitonalImageException sealed : public OcrXpressException

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

See Also

InvalidBitonalImageException Members | PegasusImaging.WinForms.OcrXpress1 Namespace

© 1997 - 2007, Pegasus Imaging Corporation, All Rights Reserved.

Last Modified:


%%PageItemTitle%% $$Members$$

InvalidBitonalImageException Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

InvalidBitonalImageException Class Members

PegasusImaging.WinForms.OcrXpress1 Namespace : InvalidBitonalImageException Class

InvalidBitonalImageException overview

Public Constructors

Public Constructor InvalidBitonalImageException Constructor Overloaded. Initializes a new instance of the InvalidBitonalImageException class.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from OcrXpressException) | The number of the error.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InvalidBitonalImageException Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%%

InvalidBitonalImageException Class | InvalidBitonalImageException Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

InvalidBitonalImageException Constructor

PegasusImaging.WinForms.OcrXpress1 Namespace > InvalidBitonalImageException Class : InvalidBitonalImageException Constructor (InvalidBitonalImageException)

Initializes a new instance of the InvalidBitonalImageException class.

Overload List

Initializes a new instance of the InvalidBitonalImageException class.

[Visual Basic] Public Sub New()

[C#] public InvalidBitonalImageException();

[C++] public InvalidBitonalImageException();

[C++/CLI] public InvalidBitonalImageException();

Initializes a new instance of the InvalidBitonalImageException class.

[Visual Basic] Public Sub New(Integer)

[C#] public InvalidBitonalImageException(int);

[C++] public InvalidBitonalImageException(int);

[C++/CLI] public InvalidBitonalImageException(int);

Initializes a new instance of the InvalidBitonalImageException class.

[Visual Basic] Public Sub New(String)

[C#] public InvalidBitonalImageException(string);

[C++] public InvalidBitonalImageException(string*);

[C++/CLI] public InvalidBitonalImageException(String^);

Initializes a new instance of the InvalidBitonalImageException class.

[Visual Basic] Public Sub New(Integer,String)

[C#] public InvalidBitonalImageException(int,string);

[C++] public InvalidBitonalImageException(int,string*);

[C++/CLI] public InvalidBitonalImageException(int,String^);

Initializes a new instance of the InvalidBitonalImageException class.

[Visual Basic] Public Sub New(String,Exception)

[C#] public InvalidBitonalImageException(string,Exception);

[C++] public InvalidBitonalImageException(string*,Exception*);

[C++/CLI] public InvalidBitonalImageException(String^,Exception^);

Requirements

Platforms: See Getting Started section

See Also

InvalidBitonalImageException Class | InvalidBitonalImageException Members


%%PageItemTitle%%

InvalidBitonalImageException Class | InvalidBitonalImageException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

InvalidBitonalImageException Constructor()

PegasusImaging.WinForms.OcrXpress1 Namespace > InvalidBitonalImageException Class > InvalidBitonalImageException Constructor : InvalidBitonalImageException Constructor()

Initializes a new instance of the InvalidBitonalImageException class.

[Visual Basic]
Public Function New()
[C#]
public InvalidBitonalImageException();
[C++]
public: InvalidBitonalImageException();
[C++/CLI]
public:
InvalidBitonalImageException();

Requirements

Platforms: See Getting Started section

See Also

InvalidBitonalImageException Class | InvalidBitonalImageException Members | Overload List


%%PageItemTitle%%

InvalidBitonalImageException Class | InvalidBitonalImageException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
A number that represents the reason you are creating this exception object.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

InvalidBitonalImageException Constructor(Int32)

PegasusImaging.WinForms.OcrXpress1 Namespace > InvalidBitonalImageException Class > InvalidBitonalImageException Constructor : InvalidBitonalImageException Constructor(Int32)

Initializes a new instance of the InvalidBitonalImageException class.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public InvalidBitonalImageException(
   int errorNumber
);
[C++]
public: InvalidBitonalImageException(
   int errorNumber
)
[C++/CLI]
public:
InvalidBitonalImageException(
   int errorNumber
)

Parameters

errorNumber
A number that represents the reason you are creating this exception object.

Requirements

Platforms: See Getting Started section

See Also

InvalidBitonalImageException Class | InvalidBitonalImageException Members | Overload List


%%PageItemTitle%%

InvalidBitonalImageException Class | InvalidBitonalImageException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
A number that represents the reason you are creating this exception object.
message
A string that describes the reason you are creating this exception object.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

InvalidBitonalImageException Constructor(Int32,String)

PegasusImaging.WinForms.OcrXpress1 Namespace > InvalidBitonalImageException Class > InvalidBitonalImageException Constructor : InvalidBitonalImageException Constructor(Int32,String)

Initializes a new instance of the InvalidBitonalImageException class.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public InvalidBitonalImageException(
   int errorNumber,
   string message
);
[C++]
public: InvalidBitonalImageException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
InvalidBitonalImageException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
A number that represents the reason you are creating this exception object.
message
A string that describes the reason you are creating this exception object.

Requirements

Platforms: See Getting Started section

See Also

InvalidBitonalImageException Class | InvalidBitonalImageException Members | Overload List


%%PageItemTitle%%

InvalidBitonalImageException Class | InvalidBitonalImageException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string that describes the reason you are creating this exception object.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

InvalidBitonalImageException Constructor(String)

PegasusImaging.WinForms.OcrXpress1 Namespace > InvalidBitonalImageException Class > InvalidBitonalImageException Constructor : InvalidBitonalImageException Constructor(String)

Initializes a new instance of the InvalidBitonalImageException class.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public InvalidBitonalImageException(
   string message
);
[C++]
public: InvalidBitonalImageException(
   string* message
)
[C++/CLI]
public:
InvalidBitonalImageException(
   String^ message
)

Parameters

message
A string that describes the reason you are creating this exception object.

Requirements

Platforms: See Getting Started section

See Also

InvalidBitonalImageException Class | InvalidBitonalImageException Members | Overload List


%%PageItemTitle%%

InvalidBitonalImageException Class | InvalidBitonalImageException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string that describes the reason you are creating this exception object.
innerException
The original exception that caused you to create this exception object.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

InvalidBitonalImageException Constructor(String,Exception)

PegasusImaging.WinForms.OcrXpress1 Namespace > InvalidBitonalImageException Class > InvalidBitonalImageException Constructor : InvalidBitonalImageException Constructor(String,Exception)

Initializes a new instance of the InvalidBitonalImageException class.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public InvalidBitonalImageException(
   string message,
   Exception innerException
);
[C++]
public: InvalidBitonalImageException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
InvalidBitonalImageException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string that describes the reason you are creating this exception object.
innerException
The original exception that caused you to create this exception object.

Requirements

Platforms: See Getting Started section

See Also

InvalidBitonalImageException Class | InvalidBitonalImageException Members | Overload List


%%PageItemTitle%%

InvalidIndexException Members | PegasusImaging.WinForms.OcrXpress1 Namespace

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

InvalidIndexException Class

PegasusImaging.WinForms.OcrXpress1 Namespace : InvalidIndexException Class

An exception object that this component will throw whenever an invalid index is used.

For a list of all members of this type, see InvalidIndexException members.

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.OcrXpress1.OcrXpressException
PegasusImaging.WinForms.OcrXpress1.InvalidIndexException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class InvalidIndexException
   Inherits OcrXpressException
[C#]
[SerializableAttribute()]
public sealed class InvalidIndexException : OcrXpressException
[C++]
[SerializableAttribute()]
public __gc __sealed class InvalidIndexException : public OcrXpressException
[C++/CLI]
[SerializableAttribute()]
public ref class InvalidIndexException sealed : public OcrXpressException

Remarks

This exception is thrown if applicable, calling the GetTextBlockResult, GetTextLineResult, GetSuspectCharacter and GetFontMap.

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

See Also

InvalidIndexException Members | PegasusImaging.WinForms.OcrXpress1 Namespace

© 1997 - 2007, Pegasus Imaging Corporation, All Rights Reserved.

Last Modified:


%%PageItemTitle%% $$Members$$

InvalidIndexException Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

InvalidIndexException Class Members

PegasusImaging.WinForms.OcrXpress1 Namespace : InvalidIndexException Class

InvalidIndexException overview

Public Constructors

Public Constructor InvalidIndexException Constructor Overloaded. Initializes a new instance of the InvalidIndexException class.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from OcrXpressException) | The number of the error.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InvalidIndexException Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%%

InvalidIndexException Class | InvalidIndexException Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

InvalidIndexException Constructor

PegasusImaging.WinForms.OcrXpress1 Namespace > InvalidIndexException Class : InvalidIndexException Constructor (InvalidIndexException)

Initializes a new instance of the InvalidIndexException class.

Overload List

Initializes a new instance of the InvalidIndexException class.

[Visual Basic] Public Sub New()

[C#] public InvalidIndexException();

[C++] public InvalidIndexException();

[C++/CLI] public InvalidIndexException();

Initializes a new instance of the InvalidIndexException class.

[Visual Basic] Public Sub New(Integer)

[C#] public InvalidIndexException(int);

[C++] public InvalidIndexException(int);

[C++/CLI] public InvalidIndexException(int);

Initializes a new instance of the InvalidIndexException class.

[Visual Basic] Public Sub New(String)

[C#] public InvalidIndexException(string);

[C++] public InvalidIndexException(string*);

[C++/CLI] public InvalidIndexException(String^);

Initializes a new instance of the InvalidIndexException class.

[Visual Basic] Public Sub New(Integer,String)

[C#] public InvalidIndexException(int,string);

[C++] public InvalidIndexException(int,string*);

[C++/CLI] public InvalidIndexException(int,String^);

Initializes a new instance of the InvalidIndexException class.

[Visual Basic] Public Sub New(String,Exception)

[C#] public InvalidIndexException(string,Exception);

[C++] public InvalidIndexException(string*,Exception*);

[C++/CLI] public InvalidIndexException(String^,Exception^);

Requirements

Platforms: See Getting Started section

See Also

InvalidIndexException Class | InvalidIndexException Members


%%PageItemTitle%%

InvalidIndexException Class | InvalidIndexException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

InvalidIndexException Constructor()

PegasusImaging.WinForms.OcrXpress1 Namespace > InvalidIndexException Class > InvalidIndexException Constructor : InvalidIndexException Constructor()

Initializes a new instance of the InvalidIndexException class.

[Visual Basic]
Public Function New()
[C#]
public InvalidIndexException();
[C++]
public: InvalidIndexException();
[C++/CLI]
public:
InvalidIndexException();

Requirements

Platforms: See Getting Started section

See Also

InvalidIndexException Class | InvalidIndexException Members | Overload List


%%PageItemTitle%%

InvalidIndexException Class | InvalidIndexException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

InvalidIndexException Constructor(Int32)

PegasusImaging.WinForms.OcrXpress1 Namespace > InvalidIndexException Class > InvalidIndexException Constructor : InvalidIndexException Constructor(Int32)

Initializes a new instance of the InvalidIndexException class.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public InvalidIndexException(
   int errorNumber
);
[C++]
public: InvalidIndexException(
   int errorNumber
)
[C++/CLI]
public:
InvalidIndexException(
   int errorNumber
)

Parameters

errorNumber

Requirements

Platforms: See Getting Started section

See Also

InvalidIndexException Class | InvalidIndexException Members | Overload List


%%PageItemTitle%%

InvalidIndexException Class | InvalidIndexException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
message
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

InvalidIndexException Constructor(Int32,String)

PegasusImaging.WinForms.OcrXpress1 Namespace > InvalidIndexException Class > InvalidIndexException Constructor : InvalidIndexException Constructor(Int32,String)

Initializes a new instance of the InvalidIndexException class.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public InvalidIndexException(
   int errorNumber,
   string message
);
[C++]
public: InvalidIndexException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
InvalidIndexException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
message

Requirements

Platforms: See Getting Started section

See Also

InvalidIndexException Class | InvalidIndexException Members | Overload List


%%PageItemTitle%%

InvalidIndexException Class | InvalidIndexException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

InvalidIndexException Constructor(String)

PegasusImaging.WinForms.OcrXpress1 Namespace > InvalidIndexException Class > InvalidIndexException Constructor : InvalidIndexException Constructor(String)

Initializes a new instance of the InvalidIndexException class.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public InvalidIndexException(
   string message
);
[C++]
public: InvalidIndexException(
   string* message
)
[C++/CLI]
public:
InvalidIndexException(
   String^ message
)

Parameters

message

Requirements

Platforms: See Getting Started section

See Also

InvalidIndexException Class | InvalidIndexException Members | Overload List


%%PageItemTitle%%

InvalidIndexException Class | InvalidIndexException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
innerException
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

InvalidIndexException Constructor(String,Exception)

PegasusImaging.WinForms.OcrXpress1 Namespace > InvalidIndexException Class > InvalidIndexException Constructor : InvalidIndexException Constructor(String,Exception)

Initializes a new instance of the InvalidIndexException class.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public InvalidIndexException(
   string message,
   Exception innerException
);
[C++]
public: InvalidIndexException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
InvalidIndexException(
   String^ message,
   Exception^ innerException
)

Parameters

message
innerException

Requirements

Platforms: See Getting Started section

See Also

InvalidIndexException Class | InvalidIndexException Members | Overload List


%%PageItemTitle%%

InvalidLicenseException Members | PegasusImaging.WinForms.OcrXpress1 Namespace

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

InvalidLicenseException Class

PegasusImaging.WinForms.OcrXpress1 Namespace : InvalidLicenseException Class

An exception object that this component will throw whenever an operation is attemted with an invalid or insufficient license.

For a list of all members of this type, see InvalidLicenseException members.

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.OcrXpress1.OcrXpressException
PegasusImaging.WinForms.OcrXpress1.InvalidLicenseException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class InvalidLicenseException
   Inherits OcrXpressException
[C#]
[SerializableAttribute()]
public sealed class InvalidLicenseException : OcrXpressException
[C++]
[SerializableAttribute()]
public __gc __sealed class InvalidLicenseException : public OcrXpressException
[C++/CLI]
[SerializableAttribute()]
public ref class InvalidLicenseException sealed : public OcrXpressException

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

See Also

InvalidLicenseException Members | PegasusImaging.WinForms.OcrXpress1 Namespace

© 1997 - 2007, Pegasus Imaging Corporation, All Rights Reserved.

Last Modified:


%%PageItemTitle%% $$Members$$

InvalidLicenseException Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

InvalidLicenseException Class Members

PegasusImaging.WinForms.OcrXpress1 Namespace : InvalidLicenseException Class

InvalidLicenseException overview

Public Constructors

Public Constructor InvalidLicenseException Constructor Overloaded. Initializes a new instance of the InvalidLicenseException class.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from OcrXpressException) | The number of the error.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InvalidLicenseException Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%%

InvalidLicenseException Class | InvalidLicenseException Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

InvalidLicenseException Constructor

PegasusImaging.WinForms.OcrXpress1 Namespace > InvalidLicenseException Class : InvalidLicenseException Constructor (InvalidLicenseException)

Initializes a new instance of the InvalidLicenseException class.

Overload List

Initializes a new instance of the InvalidLicenseException class.

[Visual Basic] Public Sub New()

[C#] public InvalidLicenseException();

[C++] public InvalidLicenseException();

[C++/CLI] public InvalidLicenseException();

Initializes a new instance of the InvalidLicenseException class.

[Visual Basic] Public Sub New(Integer)

[C#] public InvalidLicenseException(int);

[C++] public InvalidLicenseException(int);

[C++/CLI] public InvalidLicenseException(int);

Initializes a new instance of the InvalidLicenseException class.

[Visual Basic] Public Sub New(String)

[C#] public InvalidLicenseException(string);

[C++] public InvalidLicenseException(string*);

[C++/CLI] public InvalidLicenseException(String^);

Initializes a new instance of the InvalidLicenseException class.

[Visual Basic] Public Sub New(Integer,String)

[C#] public InvalidLicenseException(int,string);

[C++] public InvalidLicenseException(int,string*);

[C++/CLI] public InvalidLicenseException(int,String^);

Initializes a new instance of the InvalidLicenseException class.

[Visual Basic] Public Sub New(String,Exception)

[C#] public InvalidLicenseException(string,Exception);

[C++] public InvalidLicenseException(string*,Exception*);

[C++/CLI] public InvalidLicenseException(String^,Exception^);

Requirements

Platforms: See Getting Started section

See Also

InvalidLicenseException Class | InvalidLicenseException Members


%%PageItemTitle%%

InvalidLicenseException Class | InvalidLicenseException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

InvalidLicenseException Constructor()

PegasusImaging.WinForms.OcrXpress1 Namespace > InvalidLicenseException Class > InvalidLicenseException Constructor : InvalidLicenseException Constructor()

Initializes a new instance of the InvalidLicenseException class.

[Visual Basic]
Public Function New()
[C#]
public InvalidLicenseException();
[C++]
public: InvalidLicenseException();
[C++/CLI]
public:
InvalidLicenseException();

Requirements

Platforms: See Getting Started section

See Also

InvalidLicenseException Class | InvalidLicenseException Members | Overload List


%%PageItemTitle%%

InvalidLicenseException Class | InvalidLicenseException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

InvalidLicenseException Constructor(Int32)

PegasusImaging.WinForms.OcrXpress1 Namespace > InvalidLicenseException Class > InvalidLicenseException Constructor : InvalidLicenseException Constructor(Int32)

Initializes a new instance of the InvalidLicenseException class.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public InvalidLicenseException(
   int errorNumber
);
[C++]
public: InvalidLicenseException(
   int errorNumber
)
[C++/CLI]
public:
InvalidLicenseException(
   int errorNumber
)

Parameters

errorNumber

Requirements

Platforms: See Getting Started section

See Also

InvalidLicenseException Class | InvalidLicenseException Members | Overload List


%%PageItemTitle%%

InvalidLicenseException Class | InvalidLicenseException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
message
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

InvalidLicenseException Constructor(Int32,String)

PegasusImaging.WinForms.OcrXpress1 Namespace > InvalidLicenseException Class > InvalidLicenseException Constructor : InvalidLicenseException Constructor(Int32,String)

Initializes a new instance of the InvalidLicenseException class.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public InvalidLicenseException(
   int errorNumber,
   string message
);
[C++]
public: InvalidLicenseException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
InvalidLicenseException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
message

Requirements

Platforms: See Getting Started section

See Also

InvalidLicenseException Class | InvalidLicenseException Members | Overload List


%%PageItemTitle%%

InvalidLicenseException Class | InvalidLicenseException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

InvalidLicenseException Constructor(String)

PegasusImaging.WinForms.OcrXpress1 Namespace > InvalidLicenseException Class > InvalidLicenseException Constructor : InvalidLicenseException Constructor(String)

Initializes a new instance of the InvalidLicenseException class.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public InvalidLicenseException(
   string message
);
[C++]
public: InvalidLicenseException(
   string* message
)
[C++/CLI]
public:
InvalidLicenseException(
   String^ message
)

Parameters

message

Requirements

Platforms: See Getting Started section

See Also

InvalidLicenseException Class | InvalidLicenseException Members | Overload List


%%PageItemTitle%%

InvalidLicenseException Class | InvalidLicenseException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
innerException
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

InvalidLicenseException Constructor(String,Exception)

PegasusImaging.WinForms.OcrXpress1 Namespace > InvalidLicenseException Class > InvalidLicenseException Constructor : InvalidLicenseException Constructor(String,Exception)

Initializes a new instance of the InvalidLicenseException class.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public InvalidLicenseException(
   string message,
   Exception innerException
);
[C++]
public: InvalidLicenseException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
InvalidLicenseException(
   String^ message,
   Exception^ innerException
)

Parameters

message
innerException

Requirements

Platforms: See Getting Started section

See Also

InvalidLicenseException Class | InvalidLicenseException Members | Overload List


%%PageItemTitle%%

InvalidParameterException Members | PegasusImaging.WinForms.OcrXpress1 Namespace

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

InvalidParameterException Class

PegasusImaging.WinForms.OcrXpress1 Namespace : InvalidParameterException Class

An exception object that this component will throw whenever a parameter is not valid.

For a list of all members of this type, see InvalidParameterException members.

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.OcrXpress1.OcrXpressException
PegasusImaging.WinForms.OcrXpress1.InvalidParameterException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class InvalidParameterException
   Inherits OcrXpressException
[C#]
[SerializableAttribute()]
public sealed class InvalidParameterException : OcrXpressException
[C++]
[SerializableAttribute()]
public __gc __sealed class InvalidParameterException : public OcrXpressException
[C++/CLI]
[SerializableAttribute()]
public ref class InvalidParameterException sealed : public OcrXpressException

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

See Also

InvalidParameterException Members | PegasusImaging.WinForms.OcrXpress1 Namespace

© 1997 - 2007, Pegasus Imaging Corporation, All Rights Reserved.

Last Modified:


%%PageItemTitle%% $$Members$$

InvalidParameterException Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

InvalidParameterException Class Members

PegasusImaging.WinForms.OcrXpress1 Namespace : InvalidParameterException Class

InvalidParameterException overview

Public Constructors

Public Constructor InvalidParameterException Constructor Overloaded. Initializes a new instance of the InvalidParameterException class.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from OcrXpressException) | The number of the error.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InvalidParameterException Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%%

InvalidParameterException Class | InvalidParameterException Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

InvalidParameterException Constructor

PegasusImaging.WinForms.OcrXpress1 Namespace > InvalidParameterException Class : InvalidParameterException Constructor (InvalidParameterException)

Initializes a new instance of the InvalidParameterException class.

Overload List

Initializes a new instance of the InvalidParameterException class.

[Visual Basic] Public Sub New()

[C#] public InvalidParameterException();

[C++] public InvalidParameterException();

[C++/CLI] public InvalidParameterException();

Initializes a new instance of the InvalidParameterException class.

[Visual Basic] Public Sub New(Integer)

[C#] public InvalidParameterException(int);

[C++] public InvalidParameterException(int);

[C++/CLI] public InvalidParameterException(int);

Initializes a new instance of the InvalidParameterException class.

[Visual Basic] Public Sub New(String)

[C#] public InvalidParameterException(string);

[C++] public InvalidParameterException(string*);

[C++/CLI] public InvalidParameterException(String^);

Initializes a new instance of the InvalidParameterException class.

[Visual Basic] Public Sub New(Integer,String)

[C#] public InvalidParameterException(int,string);

[C++] public InvalidParameterException(int,string*);

[C++/CLI] public InvalidParameterException(int,String^);

Initializes a new instance of the InvalidParameterException class.

[Visual Basic] Public Sub New(String,Exception)

[C#] public InvalidParameterException(string,Exception);

[C++] public InvalidParameterException(string*,Exception*);

[C++/CLI] public InvalidParameterException(String^,Exception^);

Requirements

Platforms: See Getting Started section

See Also

InvalidParameterException Class | InvalidParameterException Members


%%PageItemTitle%%

InvalidParameterException Class | InvalidParameterException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

InvalidParameterException Constructor()

PegasusImaging.WinForms.OcrXpress1 Namespace > InvalidParameterException Class > InvalidParameterException Constructor : InvalidParameterException Constructor()

Initializes a new instance of the InvalidParameterException class.

[Visual Basic]
Public Function New()
[C#]
public InvalidParameterException();
[C++]
public: InvalidParameterException();
[C++/CLI]
public:
InvalidParameterException();

Requirements

Platforms: See Getting Started section

See Also

InvalidParameterException Class | InvalidParameterException Members | Overload List


%%PageItemTitle%%

InvalidParameterException Class | InvalidParameterException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

InvalidParameterException Constructor(Int32)

PegasusImaging.WinForms.OcrXpress1 Namespace > InvalidParameterException Class > InvalidParameterException Constructor : InvalidParameterException Constructor(Int32)

Initializes a new instance of the InvalidParameterException class.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public InvalidParameterException(
   int errorNumber
);
[C++]
public: InvalidParameterException(
   int errorNumber
)
[C++/CLI]
public:
InvalidParameterException(
   int errorNumber
)

Parameters

errorNumber

Requirements

Platforms: See Getting Started section

See Also

InvalidParameterException Class | InvalidParameterException Members | Overload List


%%PageItemTitle%%

InvalidParameterException Class | InvalidParameterException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
message
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

InvalidParameterException Constructor(Int32,String)

PegasusImaging.WinForms.OcrXpress1 Namespace > InvalidParameterException Class > InvalidParameterException Constructor : InvalidParameterException Constructor(Int32,String)

Initializes a new instance of the InvalidParameterException class.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public InvalidParameterException(
   int errorNumber,
   string message
);
[C++]
public: InvalidParameterException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
InvalidParameterException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
message

Requirements

Platforms: See Getting Started section

See Also

InvalidParameterException Class | InvalidParameterException Members | Overload List


%%PageItemTitle%%

InvalidParameterException Class | InvalidParameterException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

InvalidParameterException Constructor(String)

PegasusImaging.WinForms.OcrXpress1 Namespace > InvalidParameterException Class > InvalidParameterException Constructor : InvalidParameterException Constructor(String)

Initializes a new instance of the InvalidParameterException class.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public InvalidParameterException(
   string message
);
[C++]
public: InvalidParameterException(
   string* message
)
[C++/CLI]
public:
InvalidParameterException(
   String^ message
)

Parameters

message

Requirements

Platforms: See Getting Started section

See Also

InvalidParameterException Class | InvalidParameterException Members | Overload List


%%PageItemTitle%%

InvalidParameterException Class | InvalidParameterException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
innerException
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

InvalidParameterException Constructor(String,Exception)

PegasusImaging.WinForms.OcrXpress1 Namespace > InvalidParameterException Class > InvalidParameterException Constructor : InvalidParameterException Constructor(String,Exception)

Initializes a new instance of the InvalidParameterException class.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public InvalidParameterException(
   string message,
   Exception innerException
);
[C++]
public: InvalidParameterException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
InvalidParameterException(
   String^ message,
   Exception^ innerException
)

Parameters

message
innerException

Requirements

Platforms: See Getting Started section

See Also

InvalidParameterException Class | InvalidParameterException Members | Overload List


%%PageItemTitle%%

Licensing Members | PegasusImaging.WinForms.OcrXpress1 Namespace

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

Licensing Class

PegasusImaging.WinForms.OcrXpress1 Namespace : Licensing Class

Provides methods for setting the license information for the toolkit.

For a list of all members of this type, see Licensing members.

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.OcrXpress1.Licensing

Syntax

[Visual Basic]
Public Class Licensing
[C#]
public class Licensing
[C++]
public __gc class Licensing
[C++/CLI]
public ref class Licensing

Remarks

This object exposes the licensing methods you need to call to license the toolkit.

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

See Also

Licensing Members | PegasusImaging.WinForms.OcrXpress1 Namespace

© 1997 - 2007, Pegasus Imaging Corporation, All Rights Reserved.

Last Modified:


%%PageItemTitle%% $$Members$$

Licensing Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

Licensing Class Members

PegasusImaging.WinForms.OcrXpress1 Namespace : Licensing Class

Licensing overview

Public Constructors

Public Constructor Licensing Constructor Initializes a new instance of the class.

Public Properties

Public Property EvaluationMode | Indicates the way in which this component is limited in evaluation mode.
Public Property LicenseEdition | Indicates the License Edition for the component.

Public Methods

Public Method UnlockRuntime | Unlocks the component for use in runtime environments.
Public Method UnlockWeb | Unlocks the component for use in web servers.

See Also

Licensing Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%%

Licensing Class | Licensing Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

workspace
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

Licensing Constructor

PegasusImaging.WinForms.OcrXpress1 Namespace > Licensing Class : Licensing Constructor (Licensing)

Initializes a new instance of the class.

[Visual Basic]
Public Function New( _
   ByVal workspace As OcrXpress _
)
[C#]
public Licensing(
   OcrXpress workspace
);
[C++]
public: Licensing(
   OcrXpress* workspace
)
[C++/CLI]
public:
Licensing(
   OcrXpress^ workspace
)

Parameters

workspace

Requirements

Platforms: See Getting Started section

See Also

Licensing Class | Licensing Members


%%PageItemTitle%%

Licensing Class | Licensing Members | UnlockWeb Method

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

code1

One of the unlock codes.

code2

One of the unlock codes.

code3

One of the unlock codes.

code4

One of the unlock codes.

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

UnlockRuntime Method

PegasusImaging.WinForms.OcrXpress1 Namespace > Licensing Class : UnlockRuntime Method

Unlocks the component for use in runtime environments.

[Visual Basic]
Public Sub UnlockRuntime( _
   ByVal code1 As Integer, _
   ByVal code2 As Integer, _
   ByVal code3 As Integer, _
   ByVal code4 As Integer _
)
[C#]
public void UnlockRuntime(
   int code1,
   int code2,
   int code3,
   int code4
);
[C++]
public: void UnlockRuntime(
   int code1,
   int code2,
   int code3,
   int code4
)
[C++/CLI]
public:
void UnlockRuntime(
   int code1,
   int code2,
   int code3,
   int code4
)

Parameters

code1

One of the unlock codes.

code2

One of the unlock codes.

code3

One of the unlock codes.

code4

One of the unlock codes.

Remarks

You must call this method before your application uses this component. It unlocks the component for your use, according to the license that you have purchased. If you do not call this function, your application will only work on a machine with the component development environment installed on it.

If you lose your unlock codes, you can retrieve them on our website: http://www.pegasusimaging.com/lostcodes.htm

Requirements

Platforms: See Getting Started section

See Also

Licensing Class | Licensing Members | UnlockWeb Method


%%PageItemTitle%%

Licensing Class | Licensing Members | UnlockRuntime Method

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

code
The unlock web string.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

UnlockWeb Method

PegasusImaging.WinForms.OcrXpress1 Namespace > Licensing Class : UnlockWeb Method

Unlocks the component for use in web servers.

[Visual Basic]
Public Sub UnlockWeb( _
   ByVal code As String _
)
[C#]
public void UnlockWeb(
   string code
);
[C++]
public: void UnlockWeb(
   string* code
)
[C++/CLI]
public:
void UnlockWeb(
   String^ code
)

Parameters

code
The unlock web string.

Remarks

You must call this method before your application uses this component. It unlocks the component for your use, according to the license that you have purchased. If you do not call this function, your application will only work on a machine with the component development environment installed on it.

If you lose your unlock string, you can retrieve it on our website: http://www.pegasusimaging.com/lostcodes.htm

Requirements

Platforms: See Getting Started section

See Also

Licensing Class | Licensing Members | UnlockRuntime Method


%%PageItemTitle%% $$Properties$$

Licensing Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

Licensing Class Properties

PegasusImaging.WinForms.OcrXpress1 Namespace : Licensing Class

For a list of all members of this type, see Licensing members.

Public Properties

Public Property EvaluationMode | Indicates the way in which this component is limited in evaluation mode.
Public Property LicenseEdition | Indicates the License Edition for the component.

See Also

Licensing Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%%

Licensing Class | Licensing Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

EvaluationMode Property

PegasusImaging.WinForms.OcrXpress1 Namespace > Licensing Class : EvaluationMode Property (Licensing)

Indicates the way in which this component is limited in evaluation mode.

[Visual Basic]
Public Property EvaluationMode As EvaluationMode
[C#]
public EvaluationMode EvaluationMode {get; set;}
[C++]
public: __property EvaluationMode get_EvaluationMode();
public: __property void set_EvaluationMode(
   EvaluationMode value
);
[C++/CLI]
public:
property EvaluationMode EvaluationMode {
   EvaluationMode get();
   void set (EvaluationMode value);
}

Requirements

Platforms: See Getting Started section

See Also

Licensing Class | Licensing Members


%%PageItemTitle%%

Licensing Class | Licensing Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

LicenseEdition Property

PegasusImaging.WinForms.OcrXpress1 Namespace > Licensing Class : LicenseEdition Property

Indicates the License Edition for the component.

[Visual Basic]
Public Property LicenseEdition As LicenseEditionType
[C#]
public LicenseEditionType LicenseEdition {get; set;}
[C++]
public: __property LicenseEditionType get_LicenseEdition();
public: __property void set_LicenseEdition(
   LicenseEditionType value
);
[C++/CLI]
public:
property LicenseEditionType LicenseEdition {
   LicenseEditionType get();
   void set (LicenseEditionType value);
}

Requirements

Platforms: See Getting Started section

See Also

Licensing Class | Licensing Members


%%PageItemTitle%%

NullPageImageException Members | PegasusImaging.WinForms.OcrXpress1 Namespace

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

NullPageImageException Class

PegasusImaging.WinForms.OcrXpress1 Namespace : NullPageImageException Class

An exception object that the Document object will throw if a Page object is used that does not contain a valid image.

For a list of all members of this type, see NullPageImageException members.

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.OcrXpress1.OcrXpressException
PegasusImaging.WinForms.OcrXpress1.NullPageImageException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class NullPageImageException
   Inherits OcrXpressException
[C#]
[SerializableAttribute()]
public sealed class NullPageImageException : OcrXpressException
[C++]
[SerializableAttribute()]
public __gc __sealed class NullPageImageException : public OcrXpressException
[C++/CLI]
[SerializableAttribute()]
public ref class NullPageImageException sealed : public OcrXpressException

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

See Also

NullPageImageException Members | PegasusImaging.WinForms.OcrXpress1 Namespace

© 1997 - 2007, Pegasus Imaging Corporation, All Rights Reserved.

Last Modified:


%%PageItemTitle%% $$Members$$

NullPageImageException Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

NullPageImageException Class Members

PegasusImaging.WinForms.OcrXpress1 Namespace : NullPageImageException Class

NullPageImageException overview

Public Constructors

Public Constructor NullPageImageException Constructor Overloaded. Initializes a new instance of the NullPageImageException class.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from OcrXpressException) | The number of the error.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

NullPageImageException Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%%

NullPageImageException Class | NullPageImageException Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

NullPageImageException Constructor

PegasusImaging.WinForms.OcrXpress1 Namespace > NullPageImageException Class : NullPageImageException Constructor (NullPageImageException)

Initializes a new instance of the NullPageImageException class.

Overload List

Initializes a new instance of the NullPageImageException class.

[Visual Basic] Public Sub New()

[C#] public NullPageImageException();

[C++] public NullPageImageException();

[C++/CLI] public NullPageImageException();

Initializes a new instance of the NullPageImageException class.

[Visual Basic] Public Sub New(Integer)

[C#] public NullPageImageException(int);

[C++] public NullPageImageException(int);

[C++/CLI] public NullPageImageException(int);

Initializes a new instance of the NullPageImageException class.

[Visual Basic] Public Sub New(String)

[C#] public NullPageImageException(string);

[C++] public NullPageImageException(string*);

[C++/CLI] public NullPageImageException(String^);

Initializes a new instance of the NullPageImageException class.

[Visual Basic] Public Sub New(Integer,String)

[C#] public NullPageImageException(int,string);

[C++] public NullPageImageException(int,string*);

[C++/CLI] public NullPageImageException(int,String^);

Initializes a new instance of the NullPageImageException class.

[Visual Basic] Public Sub New(String,Exception)

[C#] public NullPageImageException(string,Exception);

[C++] public NullPageImageException(string*,Exception*);

[C++/CLI] public NullPageImageException(String^,Exception^);

Requirements

Platforms: See Getting Started section

See Also

NullPageImageException Class | NullPageImageException Members


%%PageItemTitle%%

NullPageImageException Class | NullPageImageException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

NullPageImageException Constructor()

PegasusImaging.WinForms.OcrXpress1 Namespace > NullPageImageException Class > NullPageImageException Constructor : NullPageImageException Constructor()

Initializes a new instance of the NullPageImageException class.

[Visual Basic]
Public Function New()
[C#]
public NullPageImageException();
[C++]
public: NullPageImageException();
[C++/CLI]
public:
NullPageImageException();

Requirements

Platforms: See Getting Started section

See Also

NullPageImageException Class | NullPageImageException Members | Overload List


%%PageItemTitle%%

NullPageImageException Class | NullPageImageException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
A number that represents the reason you are creating this exception object.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

NullPageImageException Constructor(Int32)

PegasusImaging.WinForms.OcrXpress1 Namespace > NullPageImageException Class > NullPageImageException Constructor : NullPageImageException Constructor(Int32)

Initializes a new instance of the NullPageImageException class.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public NullPageImageException(
   int errorNumber
);
[C++]
public: NullPageImageException(
   int errorNumber
)
[C++/CLI]
public:
NullPageImageException(
   int errorNumber
)

Parameters

errorNumber
A number that represents the reason you are creating this exception object.

Requirements

Platforms: See Getting Started section

See Also

NullPageImageException Class | NullPageImageException Members | Overload List


%%PageItemTitle%%

NullPageImageException Class | NullPageImageException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
A number that represents the reason you are creating this exception object.
message
A string that describes the reason you are creating this exception object.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

NullPageImageException Constructor(Int32,String)

PegasusImaging.WinForms.OcrXpress1 Namespace > NullPageImageException Class > NullPageImageException Constructor : NullPageImageException Constructor(Int32,String)

Initializes a new instance of the NullPageImageException class.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public NullPageImageException(
   int errorNumber,
   string message
);
[C++]
public: NullPageImageException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
NullPageImageException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
A number that represents the reason you are creating this exception object.
message
A string that describes the reason you are creating this exception object.

Requirements

Platforms: See Getting Started section

See Also

NullPageImageException Class | NullPageImageException Members | Overload List


%%PageItemTitle%%

NullPageImageException Class | NullPageImageException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string that describes the reason you are creating this exception object.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

NullPageImageException Constructor(String)

PegasusImaging.WinForms.OcrXpress1 Namespace > NullPageImageException Class > NullPageImageException Constructor : NullPageImageException Constructor(String)

Initializes a new instance of the NullPageImageException class.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public NullPageImageException(
   string message
);
[C++]
public: NullPageImageException(
   string* message
)
[C++/CLI]
public:
NullPageImageException(
   String^ message
)

Parameters

message
A string that describes the reason you are creating this exception object.

Requirements

Platforms: See Getting Started section

See Also

NullPageImageException Class | NullPageImageException Members | Overload List


%%PageItemTitle%%

NullPageImageException Class | NullPageImageException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string that describes the reason you are creating this exception object.
innerException
The original exception that caused you to create this exception object.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

NullPageImageException Constructor(String,Exception)

PegasusImaging.WinForms.OcrXpress1 Namespace > NullPageImageException Class > NullPageImageException Constructor : NullPageImageException Constructor(String,Exception)

Initializes a new instance of the NullPageImageException class.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public NullPageImageException(
   string message,
   Exception innerException
);
[C++]
public: NullPageImageException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
NullPageImageException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string that describes the reason you are creating this exception object.
innerException
The original exception that caused you to create this exception object.

Requirements

Platforms: See Getting Started section

See Also

NullPageImageException Class | NullPageImageException Members | Overload List


%%PageItemTitle%%

NullPageRegionsException Members | PegasusImaging.WinForms.OcrXpress1 Namespace

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

NullPageRegionsException Class

PegasusImaging.WinForms.OcrXpress1 Namespace : NullPageRegionsException Class

An exception object that the Document object will throw if a Page object with no Text or Picture Regions is used with a method that requires them.

For a list of all members of this type, see NullPageRegionsException members.

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.OcrXpress1.OcrXpressException
PegasusImaging.WinForms.OcrXpress1.NullPageRegionsException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class NullPageRegionsException
   Inherits OcrXpressException
[C#]
[SerializableAttribute()]
public sealed class NullPageRegionsException : OcrXpressException
[C++]
[SerializableAttribute()]
public __gc __sealed class NullPageRegionsException : public OcrXpressException
[C++/CLI]
[SerializableAttribute()]
public ref class NullPageRegionsException sealed : public OcrXpressException

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

See Also

NullPageRegionsException Members | PegasusImaging.WinForms.OcrXpress1 Namespace

© 1997 - 2007, Pegasus Imaging Corporation, All Rights Reserved.

Last Modified:


%%PageItemTitle%% $$Members$$

NullPageRegionsException Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

NullPageRegionsException Class Members

PegasusImaging.WinForms.OcrXpress1 Namespace : NullPageRegionsException Class

NullPageRegionsException overview

Public Constructors

Public Constructor NullPageRegionsException Constructor Overloaded. Initializes a new instance of the NullPageRegionsException class.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from OcrXpressException) | The number of the error.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

NullPageRegionsException Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%%

NullPageRegionsException Class | NullPageRegionsException Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

NullPageRegionsException Constructor

PegasusImaging.WinForms.OcrXpress1 Namespace > NullPageRegionsException Class : NullPageRegionsException Constructor (NullPageRegionsException)

Initializes a new instance of the NullPageRegionsException class.

Overload List

Initializes a new instance of the NullPageRegionsException class.

[Visual Basic] Public Sub New()

[C#] public NullPageRegionsException();

[C++] public NullPageRegionsException();

[C++/CLI] public NullPageRegionsException();

Initializes a new instance of the NullPageRegionsException class.

[Visual Basic] Public Sub New(Integer)

[C#] public NullPageRegionsException(int);

[C++] public NullPageRegionsException(int);

[C++/CLI] public NullPageRegionsException(int);

Initializes a new instance of the NullPageRegionsException class.

[Visual Basic] Public Sub New(String)

[C#] public NullPageRegionsException(string);

[C++] public NullPageRegionsException(string*);

[C++/CLI] public NullPageRegionsException(String^);

Initializes a new instance of the NullPageRegionsException class.

[Visual Basic] Public Sub New(Integer,String)

[C#] public NullPageRegionsException(int,string);

[C++] public NullPageRegionsException(int,string*);

[C++/CLI] public NullPageRegionsException(int,String^);

Initializes a new instance of the NullPageRegionsException class.

[Visual Basic] Public Sub New(String,Exception)

[C#] public NullPageRegionsException(string,Exception);

[C++] public NullPageRegionsException(string*,Exception*);

[C++/CLI] public NullPageRegionsException(String^,Exception^);

Requirements

Platforms: See Getting Started section

See Also

NullPageRegionsException Class | NullPageRegionsException Members


%%PageItemTitle%%

NullPageRegionsException Class | NullPageRegionsException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

NullPageRegionsException Constructor()

PegasusImaging.WinForms.OcrXpress1 Namespace > NullPageRegionsException Class > NullPageRegionsException Constructor : NullPageRegionsException Constructor()

Initializes a new instance of the NullPageRegionsException class.

[Visual Basic]
Public Function New()
[C#]
public NullPageRegionsException();
[C++]
public: NullPageRegionsException();
[C++/CLI]
public:
NullPageRegionsException();

Requirements

Platforms: See Getting Started section

See Also

NullPageRegionsException Class | NullPageRegionsException Members | Overload List


%%PageItemTitle%%

NullPageRegionsException Class | NullPageRegionsException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
A number that represents the reason you are creating this exception object.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

NullPageRegionsException Constructor(Int32)

PegasusImaging.WinForms.OcrXpress1 Namespace > NullPageRegionsException Class > NullPageRegionsException Constructor : NullPageRegionsException Constructor(Int32)

Initializes a new instance of the NullPageRegionsException class.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public NullPageRegionsException(
   int errorNumber
);
[C++]
public: NullPageRegionsException(
   int errorNumber
)
[C++/CLI]
public:
NullPageRegionsException(
   int errorNumber
)

Parameters

errorNumber
A number that represents the reason you are creating this exception object.

Requirements

Platforms: See Getting Started section

See Also

NullPageRegionsException Class | NullPageRegionsException Members | Overload List


%%PageItemTitle%%

NullPageRegionsException Class | NullPageRegionsException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
A number that represents the reason you are creating this exception object.
message
A string that describes the reason you are creating this exception object.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

NullPageRegionsException Constructor(Int32,String)

PegasusImaging.WinForms.OcrXpress1 Namespace > NullPageRegionsException Class > NullPageRegionsException Constructor : NullPageRegionsException Constructor(Int32,String)

Initializes a new instance of the NullPageRegionsException class.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public NullPageRegionsException(
   int errorNumber,
   string message
);
[C++]
public: NullPageRegionsException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
NullPageRegionsException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
A number that represents the reason you are creating this exception object.
message
A string that describes the reason you are creating this exception object.

Requirements

Platforms: See Getting Started section

See Also

NullPageRegionsException Class | NullPageRegionsException Members | Overload List


%%PageItemTitle%%

NullPageRegionsException Class | NullPageRegionsException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string that describes the reason you are creating this exception object.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

NullPageRegionsException Constructor(String)

PegasusImaging.WinForms.OcrXpress1 Namespace > NullPageRegionsException Class > NullPageRegionsException Constructor : NullPageRegionsException Constructor(String)

Initializes a new instance of the NullPageRegionsException class.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public NullPageRegionsException(
   string message
);
[C++]
public: NullPageRegionsException(
   string* message
)
[C++/CLI]
public:
NullPageRegionsException(
   String^ message
)

Parameters

message
A string that describes the reason you are creating this exception object.

Requirements

Platforms: See Getting Started section

See Also

NullPageRegionsException Class | NullPageRegionsException Members | Overload List


%%PageItemTitle%%

NullPageRegionsException Class | NullPageRegionsException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string that describes the reason you are creating this exception object.
innerException
The original exception that caused you to create this exception object.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

NullPageRegionsException Constructor(String,Exception)

PegasusImaging.WinForms.OcrXpress1 Namespace > NullPageRegionsException Class > NullPageRegionsException Constructor : NullPageRegionsException Constructor(String,Exception)

Initializes a new instance of the NullPageRegionsException class.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public NullPageRegionsException(
   string message,
   Exception innerException
);
[C++]
public: NullPageRegionsException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
NullPageRegionsException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string that describes the reason you are creating this exception object.
innerException
The original exception that caused you to create this exception object.

Requirements

Platforms: See Getting Started section

See Also

NullPageRegionsException Class | NullPageRegionsException Members | Overload List


%%PageItemTitle%%

OcrXpress Members | PegasusImaging.WinForms.OcrXpress1 Namespace

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

OcrXpress Class

PegasusImaging.WinForms.OcrXpress1 Namespace : OcrXpress Class

The main object for this toolkit.

For a list of all members of this type, see OcrXpress members.

Object Model

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
PegasusImaging.WinForms.OcrXpress1.OcrXpress

Syntax

[Visual Basic]
<ToolboxBitmapAttribute()>
Public Class OcrXpress
   Inherits Component
[C#]
[ToolboxBitmapAttribute()]
public class OcrXpress : Component
[C++]
[ToolboxBitmapAttribute()]
public __gc class OcrXpress : public Component
[C++/CLI]
[ToolboxBitmapAttribute()]
public ref class OcrXpress : public Component

Remarks

This object is the primary place to perform toolkit-level operations, such as setting licensing information, controlling the debug log, and displaying the toolkit about box.

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

See Also

OcrXpress Members | PegasusImaging.WinForms.OcrXpress1 Namespace

© 1997 - 2007, Pegasus Imaging Corporation, All Rights Reserved.

Last Modified:


%%PageItemTitle%% $$Members$$

OcrXpress Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

OcrXpress Class Members

PegasusImaging.WinForms.OcrXpress1 Namespace : OcrXpress Class

OcrXpress overview

Public Constructors

Public Constructor OcrXpress Constructor Overloaded. Initializes a new instance of the class.

Public Properties

Public Property Container (Inherited from System.ComponentModel.Component) | Gets the IContainer that contains the Component.
Public Property Debug | Gets and sets an indicator which determines if the component writes information to a DebugLogFile or not.
Public Property DebugLogFile | Gets and sets the filename of the debug log file.
Public Property Document | Gets the main Document object.
Public Property ErrorLevel | Gets and sets the error level of items that the component should write to the debug log file.
Public Property FastLoading | Gets and sets a value indicating whether this component will leave the OCR dictionaries that are written to disk when it's destroyed.
Public Property License | Provides access to an object you can use to provide licensing information to the toolkit.
Public Property Site (Inherited from System.ComponentModel.Component) | Gets or sets the ISite of the Component.

Public Methods

Public Method AboutBox | Displays the toolkit about box.
Public Method CreateObjRef (Inherited from System.MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Public Method Dispose (Inherited from System.ComponentModel.Component) | Deletes the image contained within this object. Releases all resources used by the Component.
Public Method GetLifetimeService (Inherited from System.MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
Public Method InitializeLifetimeService (Inherited from System.MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Public Method ToString (Inherited from System.ComponentModel.Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.

Public Events

Public Event Disposed (Inherited from System.ComponentModel.Component) Adds an event handler to listen to the Disposed event on the component.

See Also

OcrXpress Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%%

OcrXpress Class | OcrXpress Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

OcrXpress Constructor

PegasusImaging.WinForms.OcrXpress1 Namespace > OcrXpress Class : OcrXpress Constructor (OcrXpress)

Initializes a new instance of the class.

Overload List

Initializes a new instance of the class.

[Visual Basic] Public Sub New()

[C#] public OcrXpress();

[C++] public OcrXpress();

[C++/CLI] public OcrXpress();

Initializes a new instance of the class.

[Visual Basic] Public Sub New(IContainer)

[C#] public OcrXpress(IContainer);

[C++] public OcrXpress(IContainer);

[C++/CLI] public OcrXpress(IContainer);

Requirements

Platforms: See Getting Started section

See Also

OcrXpress Class | OcrXpress Members


%%PageItemTitle%%

OcrXpress Class | OcrXpress Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

OcrXpress Constructor()

PegasusImaging.WinForms.OcrXpress1 Namespace > OcrXpress Class > OcrXpress Constructor : OcrXpress Constructor()

Initializes a new instance of the class.

[Visual Basic]
Public Function New()
[C#]
public OcrXpress();
[C++]
public: OcrXpress();
[C++/CLI]
public:
OcrXpress();

Requirements

Platforms: See Getting Started section

See Also

OcrXpress Class | OcrXpress Members | Overload List


%%PageItemTitle%%

OcrXpress Class | OcrXpress Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

container
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

OcrXpress Constructor(IContainer)

PegasusImaging.WinForms.OcrXpress1 Namespace > OcrXpress Class > OcrXpress Constructor : OcrXpress Constructor(IContainer)

Initializes a new instance of the class.

[Visual Basic]
Public Function New( _
   ByVal container As IContainer _
)
[C#]
public OcrXpress(
   IContainer container
);
[C++]
public: OcrXpress(
   IContainer container
)
[C++/CLI]
public:
OcrXpress(
   IContainer container
)

Parameters

container

Requirements

Platforms: See Getting Started section

See Also

OcrXpress Class | OcrXpress Members | Overload List


%%PageItemTitle%%

OcrXpress Class | OcrXpress Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

AboutBox Method

PegasusImaging.WinForms.OcrXpress1 Namespace > OcrXpress Class : AboutBox Method

Displays the toolkit about box.

[Visual Basic]
<CategoryAttribute("OcrXpress")>
Public Sub AboutBox()
[C#]
[CategoryAttribute("OcrXpress")]
public void AboutBox();
[C++]
[CategoryAttribute("OcrXpress")]
public: void AboutBox();
[C++/CLI]
[CategoryAttribute("OcrXpress")]
public:
void AboutBox();

Remarks

This method displays an about box for the toolkit. It includes useful information, such as the name and version of the toolkit, copyright dates, and links to Pegasus Imaging Corporation's web site.

Example

...

// Call the AboutBox method

ocrX.AboutBox();

...

Requirements

Platforms: See Getting Started section

See Also

OcrXpress Class | OcrXpress Members


%%PageItemTitle%% $$Properties$$

OcrXpress Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

OcrXpress Class Properties

PegasusImaging.WinForms.OcrXpress1 Namespace : OcrXpress Class

For a list of all members of this type, see OcrXpress members.

Public Properties

Public Property Container (Inherited from System.ComponentModel.Component) | Gets the IContainer that contains the Component.
Public Property Debug | Gets and sets an indicator which determines if the component writes information to a DebugLogFile or not.
Public Property DebugLogFile | Gets and sets the filename of the debug log file.
Public Property Document | Gets the main Document object.
Public Property ErrorLevel | Gets and sets the error level of items that the component should write to the debug log file.
Public Property FastLoading | Gets and sets a value indicating whether this component will leave the OCR dictionaries that are written to disk when it's destroyed.
Public Property License | Provides access to an object you can use to provide licensing information to the toolkit.
Public Property Site (Inherited from System.ComponentModel.Component) | Gets or sets the ISite of the Component.

See Also

OcrXpress Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%%

OcrXpress Class | OcrXpress Members | DebugLogFile Property | ErrorLevel Property

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

Debug Property

PegasusImaging.WinForms.OcrXpress1 Namespace > OcrXpress Class : Debug Property

Gets and sets an indicator which determines if the component writes information to a DebugLogFile or not.

[Visual Basic]
<CategoryAttribute("Debugging")>
<DescriptionAttribute("Indicates if a debug log is written.")>
<BrowsableAttribute(True)>
Public Property Debug As Boolean
[C#]
[CategoryAttribute("Debugging")]
[DescriptionAttribute("Indicates if a debug log is written.")]
[BrowsableAttribute(true)]
public bool Debug {get; set;}
[C++]
[CategoryAttribute("Debugging")]
[DescriptionAttribute("Indicates if a debug log is written.")]
[BrowsableAttribute(true)]
public: __property bool get_Debug();
public: __property void set_Debug(
   bool value
);
[C++/CLI]
[CategoryAttribute("Debugging")]
[DescriptionAttribute("Indicates if a debug log is written.")]
[BrowsableAttribute(true)]
public:
property bool Debug {
   bool get();
   void set (bool value);
}

Return Type

A boolean value which is true if the component writes data to a debug log file. Otherwise, false is returned.

Remarks

This property allows you to turn the debug log file on or off without changing any of the other debug settings. When this value is true, the component will write items to the debug log file, as specified by the DebugLogFile and ErrorLevel properties.

Default value: false

Example

...

// Set Debug to true for logging to be performed

ocrX.Debug = true;

...

Requirements

Platforms: See Getting Started section

See Also

OcrXpress Class | OcrXpress Members | DebugLogFile Property | ErrorLevel Property


%%PageItemTitle%%

OcrXpress Class | OcrXpress Members | Debug Property | ErrorLevel Property

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

DebugLogFile Property

PegasusImaging.WinForms.OcrXpress1 Namespace > OcrXpress Class : DebugLogFile Property

Gets and sets the filename of the debug log file.

[Visual Basic]
<DescriptionAttribute("Indicates the filename of the debug log.")>
<CategoryAttribute("Debugging")>
<BrowsableAttribute(True)>
Public Property DebugLogFile As String
[C#]
[DescriptionAttribute("Indicates the filename of the debug log.")]
[CategoryAttribute("Debugging")]
[BrowsableAttribute(true)]
public string DebugLogFile {get; set;}
[C++]
[DescriptionAttribute("Indicates the filename of the debug log.")]
[CategoryAttribute("Debugging")]
[BrowsableAttribute(true)]
public: __property string* get_DebugLogFile();
public: __property void set_DebugLogFile(
   string* value
);
[C++/CLI]
[DescriptionAttribute("Indicates the filename of the debug log.")]
[CategoryAttribute("Debugging")]
[BrowsableAttribute(true)]
public:
property String^ DebugLogFile {
   String^ get();
   void set (String^ value);
}

Return Type

A string value which represents the full path and name of the debug log file.

Remarks

This property allows you to control the location of the debug log file.

Valid value: Any valid filename.

Default value: "My Documents\OCRXpress1.log"

Note: This property will have no effect if you set the Debug property to false.

Example

...

// Set the DebugLogFile path and name

ocrX.DebugLogFile = "c:\logFile.txt";

...

Requirements

Platforms: See Getting Started section

See Also

OcrXpress Class | OcrXpress Members | Debug Property | ErrorLevel Property


%%PageItemTitle%%

OcrXpress Class | OcrXpress Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

Document Property

PegasusImaging.WinForms.OcrXpress1 Namespace > OcrXpress Class : Document Property (OcrXpress)

Gets the main Document object.

[Visual Basic]
<BrowsableAttribute(False)>
Public ReadOnly Property Document As Document
[C#]
[BrowsableAttribute(false)]
public Document Document {get;}
[C++]
[BrowsableAttribute(false)]
public: __property Document* get_Document();
[C++/CLI]
[BrowsableAttribute(false)]
public:
property Document^ Document {
   Document^ get();
}

Remarks

This property returns a reference to the Document object. You can use this object to perform all of the OCR tasks of this component.

Requirements

Platforms: See Getting Started section

See Also

OcrXpress Class | OcrXpress Members


%%PageItemTitle%%

OcrXpress Class | OcrXpress Members | DebugLogFile Property | Debug Property

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

ErrorLevel Property

PegasusImaging.WinForms.OcrXpress1 Namespace > OcrXpress Class : ErrorLevel Property (OcrXpress)

Gets and sets the error level of items that the component should write to the debug log file.

[Visual Basic]
<CategoryAttribute("Debugging")>
<DescriptionAttribute("Indicates the level of debug information written.")>
<BrowsableAttribute(True)>
Public Property ErrorLevel As ErrorLevel
[C#]
[CategoryAttribute("Debugging")]
[DescriptionAttribute("Indicates the level of debug information written.")]
[BrowsableAttribute(true)]
public ErrorLevel ErrorLevel {get; set;}
[C++]
[CategoryAttribute("Debugging")]
[DescriptionAttribute("Indicates the level of debug information written.")]
[BrowsableAttribute(true)]
public: __property ErrorLevel get_ErrorLevel();
public: __property void set_ErrorLevel(
   ErrorLevel value
);
[C++/CLI]
[CategoryAttribute("Debugging")]
[DescriptionAttribute("Indicates the level of debug information written.")]
[BrowsableAttribute(true)]
public:
property ErrorLevel ErrorLevel {
   ErrorLevel get();
   void set (ErrorLevel value);
}

Return Type

The ErrorLevel enumeration value set.

Remarks

This property allows you to control the amount of information that the component places into the DebugLogFile. Since it is expensive to generate and write debug log items, set this property to write the least amount of information that you will find useful.

Valid values: Production, Development, and Detailed.

Default value: Production

Note: This property will have no effect if the Debug property to false.

Example

...

// Set the ErrorLevel of the debugging

ocrX.ErrorLevel = PegasusImaging.WinForms.OcrXpress1.ErrorLevel.Development;

...

Requirements

Platforms: See Getting Started section

See Also

OcrXpress Class | OcrXpress Members | DebugLogFile Property | Debug Property


%%PageItemTitle%%

OcrXpress Class | OcrXpress Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

FastLoading Property

PegasusImaging.WinForms.OcrXpress1 Namespace > OcrXpress Class : FastLoading Property

Gets and sets a value indicating whether this component will leave the OCR dictionaries that are written to disk when it's destroyed.

[Visual Basic]
<BrowsableAttribute(True)>
<CategoryAttribute("Optimization")>
<DescriptionAttribute("Indicates if OcrXpress will not remove the OCR dictionaries that it writes to disk so subsequent OcrXpress objects will have a faster load time.")>
Public Property FastLoading As Boolean
[C#]
[BrowsableAttribute(true)]
[CategoryAttribute("Optimization")]
[DescriptionAttribute("Indicates if OcrXpress will not remove the OCR dictionaries that it writes to disk so subsequent OcrXpress objects will have a faster load time.")]
public bool FastLoading {get; set;}
[C++]
[BrowsableAttribute(true)]
[CategoryAttribute("Optimization")]
[DescriptionAttribute("Indicates if OcrXpress will not remove the OCR dictionaries that it writes to disk so subsequent OcrXpress objects will have a faster load time.")]
public: __property bool get_FastLoading();
public: __property void set_FastLoading(
   bool value
);
[C++/CLI]
[BrowsableAttribute(true)]
[CategoryAttribute("Optimization")]
[DescriptionAttribute("Indicates if OcrXpress will not remove the OCR dictionaries that it writes to disk so subsequent OcrXpress objects will have a faster load time.")]
public:
property bool FastLoading {
   bool get();
   void set (bool value);
}

Return Type

A boolean value which is true if the OCR dictionaries are not destroyed with the OcrXpress object. Otherwise, false is returned.

Remarks

The OcrXpress component relies on a database file and several language dictionaries to perform its recognition processing. By default, these files, totaling about 13 Megabytes, are written to disk when the OcrXpress component is created, and removed when it is destroyed. This property can be used to save the time required to write and delete these files.

When this property is set to its default value of false, the OCR files are written to disk when the OcrXpress component is created, and removed when it is destroyed.

When this property is true, the OcrXpress component will not delete the OCR files when it is destroyed. This will allow the next OcrXpress component that is created, to skip writing the files.

Default value: false

Requirements

Platforms: See Getting Started section

See Also

OcrXpress Class | OcrXpress Members


%%PageItemTitle%%

OcrXpress Class | OcrXpress Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

License Property

PegasusImaging.WinForms.OcrXpress1 Namespace > OcrXpress Class : License Property

Provides access to an object you can use to provide licensing information to the toolkit.

[Visual Basic]
<BrowsableAttribute(False)>
Public ReadOnly Property License As Licensing
[C#]
[BrowsableAttribute(false)]
public Licensing License {get;}
[C++]
[BrowsableAttribute(false)]
public: __property Licensing* get_License();
[C++/CLI]
[BrowsableAttribute(false)]
public:
property Licensing^ License {
   Licensing^ get();
}

Return Type

The Licensing value set.

Remarks

This property holds a reference to a Licensing object. You can use that object to send your licensing information to the toolkit.

Example

...

// Set the Licence EvaluationMode

ocrX.License.EvaluationMode = PegasusImaging.WinForms.OcrXpress1.EvaluationMode.Automatic;

// Set the LicenceEdition

ocrX.License.LicenseEdition = PegasusImaging.WinForms.OcrXpress1.LicenseEditionType.Professional;

...

Requirements

Platforms: See Getting Started section

See Also

OcrXpress Class | OcrXpress Members


%%PageItemTitle%%

OcrXpressException Members | PegasusImaging.WinForms.OcrXpress1 Namespace

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

OcrXpressException Class

PegasusImaging.WinForms.OcrXpress1 Namespace : OcrXpressException Class

The base class for OcrXpress exceptions.

For a list of all members of this type, see OcrXpressException members.

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.OcrXpress1.OcrXpressException
PegasusImaging.WinForms.OcrXpress1.UnsupportedImageFormatException
PegasusImaging.WinForms.OcrXpress1.TimeoutErrorException
PegasusImaging.WinForms.OcrXpress1.TextTooLongException
PegasusImaging.WinForms.OcrXpress1.RelativePathException
PegasusImaging.WinForms.OcrXpress1.RecognitionNotPerformedException
PegasusImaging.WinForms.OcrXpress1.PathNotFoundException
PegasusImaging.WinForms.OcrXpress1.ParameterOutOfRangeException
PegasusImaging.WinForms.OcrXpress1.PageCountException
PegasusImaging.WinForms.OcrXpress1.NullPageRegionsException
PegasusImaging.WinForms.OcrXpress1.NullPageImageException
PegasusImaging.WinForms.OcrXpress1.InvalidParameterException
PegasusImaging.WinForms.OcrXpress1.InvalidLicenseException
PegasusImaging.WinForms.OcrXpress1.InvalidIndexException
PegasusImaging.WinForms.OcrXpress1.InvalidBitonalImageException
PegasusImaging.WinForms.OcrXpress1.InvalidAreaException
PegasusImaging.WinForms.OcrXpress1.InternalErrorException
PegasusImaging.WinForms.OcrXpress1.ImageNullException
PegasusImaging.WinForms.OcrXpress1.ImageNotAvailableException
PegasusImaging.WinForms.OcrXpress1.FileInUseException
PegasusImaging.WinForms.OcrXpress1.FileExportException
PegasusImaging.WinForms.OcrXpress1.BitonalImageNotNeededException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public Class OcrXpressException
   Inherits ApplicationException
[C#]
[SerializableAttribute()]
public class OcrXpressException : ApplicationException
[C++]
[SerializableAttribute()]
public __gc class OcrXpressException : public ApplicationException
[C++/CLI]
[SerializableAttribute()]
public ref class OcrXpressException : public ApplicationException

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

See Also

OcrXpressException Members | PegasusImaging.WinForms.OcrXpress1 Namespace

© 1997 - 2007, Pegasus Imaging Corporation, All Rights Reserved.

Last Modified:


%%PageItemTitle%% $$Members$$

OcrXpressException Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

OcrXpressException Class Members

PegasusImaging.WinForms.OcrXpress1 Namespace : OcrXpressException Class

OcrXpressException overview

Public Constructors

Public Constructor OcrXpressException Constructor Overloaded. Initializes a new instance of the OcrXpressException class.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber | The number of the error.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

OcrXpressException Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%%

OcrXpressException Class | OcrXpressException Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

OcrXpressException Constructor

PegasusImaging.WinForms.OcrXpress1 Namespace > OcrXpressException Class : OcrXpressException Constructor (OcrXpressException)

Initializes a new instance of the OcrXpressException class.

Overload List

Initializes a new instance of the OcrXpressException class.

[Visual Basic] Public Sub New()

[C#] public OcrXpressException();

[C++] public OcrXpressException();

[C++/CLI] public OcrXpressException();

Initializes a new instance of the OcrXpressException class.

[Visual Basic] Public Sub New(Integer,String)

[C#] public OcrXpressException(int,string);

[C++] public OcrXpressException(int,string*);

[C++/CLI] public OcrXpressException(int,String^);

Initializes a new instance of the OcrXpressException class.

[Visual Basic] Public Sub New(Integer)

[C#] public OcrXpressException(int);

[C++] public OcrXpressException(int);

[C++/CLI] public OcrXpressException(int);

Initializes a new instance of the OcrXpressException class.

[Visual Basic] Public Sub New(String)

[C#] public OcrXpressException(string);

[C++] public OcrXpressException(string*);

[C++/CLI] public OcrXpressException(String^);

Initializes a new instance of the OcrXpressException class.

[Visual Basic] Public Sub New(String,Exception)

[C#] public OcrXpressException(string,Exception);

[C++] public OcrXpressException(string*,Exception*);

[C++/CLI] public OcrXpressException(String^,Exception^);

Requirements

Platforms: See Getting Started section

See Also

OcrXpressException Class | OcrXpressException Members


%%PageItemTitle%%

OcrXpressException Class | OcrXpressException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

OcrXpressException Constructor()

PegasusImaging.WinForms.OcrXpress1 Namespace > OcrXpressException Class > OcrXpressException Constructor : OcrXpressException Constructor()

Initializes a new instance of the OcrXpressException class.

[Visual Basic]
Public Function New()
[C#]
public OcrXpressException();
[C++]
public: OcrXpressException();
[C++/CLI]
public:
OcrXpressException();

Requirements

Platforms: See Getting Started section

See Also

OcrXpressException Class | OcrXpressException Members | Overload List


%%PageItemTitle%%

OcrXpressException Class | OcrXpressException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

number
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

OcrXpressException Constructor(Int32)

PegasusImaging.WinForms.OcrXpress1 Namespace > OcrXpressException Class > OcrXpressException Constructor : OcrXpressException Constructor(Int32)

Initializes a new instance of the OcrXpressException class.

[Visual Basic]
Public Function New( _
   ByVal number As Integer _
)
[C#]
public OcrXpressException(
   int number
);
[C++]
public: OcrXpressException(
   int number
)
[C++/CLI]
public:
OcrXpressException(
   int number
)

Parameters

number

Requirements

Platforms: See Getting Started section

See Also

OcrXpressException Class | OcrXpressException Members | Overload List


%%PageItemTitle%%

OcrXpressException Class | OcrXpressException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

number
message
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

OcrXpressException Constructor(Int32,String)

PegasusImaging.WinForms.OcrXpress1 Namespace > OcrXpressException Class > OcrXpressException Constructor : OcrXpressException Constructor(Int32,String)

Initializes a new instance of the OcrXpressException class.

[Visual Basic]
Public Function New( _
   ByVal number As Integer, _
   ByVal message As String _
)
[C#]
public OcrXpressException(
   int number,
   string message
);
[C++]
public: OcrXpressException(
   int number,
   string* message
)
[C++/CLI]
public:
OcrXpressException(
   int number,
   String^ message
)

Parameters

number
message

Requirements

Platforms: See Getting Started section

See Also

OcrXpressException Class | OcrXpressException Members | Overload List


%%PageItemTitle%%

OcrXpressException Class | OcrXpressException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

OcrXpressException Constructor(String)

PegasusImaging.WinForms.OcrXpress1 Namespace > OcrXpressException Class > OcrXpressException Constructor : OcrXpressException Constructor(String)

Initializes a new instance of the OcrXpressException class.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public OcrXpressException(
   string message
);
[C++]
public: OcrXpressException(
   string* message
)
[C++/CLI]
public:
OcrXpressException(
   String^ message
)

Parameters

message

Requirements

Platforms: See Getting Started section

See Also

OcrXpressException Class | OcrXpressException Members | Overload List


%%PageItemTitle%%

OcrXpressException Class | OcrXpressException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
inner
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

OcrXpressException Constructor(String,Exception)

PegasusImaging.WinForms.OcrXpress1 Namespace > OcrXpressException Class > OcrXpressException Constructor : OcrXpressException Constructor(String,Exception)

Initializes a new instance of the OcrXpressException class.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal inner As Exception _
)
[C#]
public OcrXpressException(
   string message,
   Exception inner
);
[C++]
public: OcrXpressException(
   string* message,
   Exception* inner
)
[C++/CLI]
public:
OcrXpressException(
   String^ message,
   Exception^ inner
)

Parameters

message
inner

Requirements

Platforms: See Getting Started section

See Also

OcrXpressException Class | OcrXpressException Members | Overload List


%%PageItemTitle%% $$Properties$$

OcrXpressException Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

OcrXpressException Class Properties

PegasusImaging.WinForms.OcrXpress1 Namespace : OcrXpressException Class

For a list of all members of this type, see OcrXpressException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber | The number of the error.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

OcrXpressException Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%%

OcrXpressException Class | OcrXpressException Members | Debug Your Application

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

ErrorNumber Property

PegasusImaging.WinForms.OcrXpress1 Namespace > OcrXpressException Class : ErrorNumber Property

The number of the error.

[Visual Basic]
Public ReadOnly Property ErrorNumber As Integer
[C#]
public int ErrorNumber {get;}
[C++]
public: __property int get_ErrorNumber();
[C++/CLI]
public:
property int ErrorNumber {
   int get();
}

Return Type

An integer which represents the number of the error.

Remarks

This property holds an error number that you can use to determine the specific type of error that occurred.

Requirements

Platforms: See Getting Started section

See Also

OcrXpressException Class | OcrXpressException Members | Debug Your Application


%%PageItemTitle%%

Page Members | PegasusImaging.WinForms.OcrXpress1 Namespace

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

Page Class

PegasusImaging.WinForms.OcrXpress1 Namespace : Page Class

An object that stores a single image to process.

For a list of all members of this type, see Page members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.OcrXpress1.Page

Syntax

[Visual Basic]
Public Class Page
[C#]
public class Page
[C++]
public __gc class Page
[C++/CLI]
public ref class Page

Remarks

This object is used to store a single image to process. Additionally, all the settings for processing the image, and text recognition results are stored in this object.

This component works primarily with bitonal images, but color and grayscale images can be used as input. If the image stored in a Page object is a color or grayscale image, a separate bitonal copy of this image is also created and kept by this object. This bitonal copy is created automatically for you when a color or grayscale image is assigned to either the Bitmap, Hdib, or Hbitmap property. If one exists, the bitonal copy can be accessed from the BitonalBitmap, BitonalHdib, or BitonalHbitmap property. You can replace the bitonal image copy with one of your own by setting it to any of the Bitonal properties.

Image processing, region location and text recognition all use the bitonal image as input. A color or grayscale image will only come into play when Export is called. The export process will extract pictures from the color or grayscale image that are needed to reconstruct the original layout in the export file, if an export format that supports embedded images is used.

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

See Also

Page Members | PegasusImaging.WinForms.OcrXpress1 Namespace

© 1997 - 2007, Pegasus Imaging Corporation, All Rights Reserved.

Last Modified:


%%PageItemTitle%% $$Members$$

Page Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

Page Class Members

PegasusImaging.WinForms.OcrXpress1 Namespace : Page Class

Page overview

Public Properties

Public Property Bitmap | Gets and sets the primary image for this object.
Public Property BitonalBitmap | Gets and sets a bitonal copy of the primary image.
Public Property BitonalHbitmap | Gets and sets a bitonal copy of the primary image.
Public Property BitonalHdib | Gets and sets a bitonal copy of the primary image.
Public Property Hbitmap | Gets and sets the primary image for this object.
Public Property Hdib | Gets and sets the primary image for this object.

Public Methods

Public Method ClearRegions | Removes all the regions on the page.
Public Method GetRegions | Gets the regions of a Page object.
Public Method GetResult | Returns a PageResult object containing all of the text recognition results for a Page.
Public Method SetRegions | Sets the regions of a Page object.

See Also

Page Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%%

Page Class | Page Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

ClearRegions Method

PegasusImaging.WinForms.OcrXpress1 Namespace > Page Class : ClearRegions Method

Removes all the regions on the page.

[Visual Basic]
Public Sub ClearRegions()
[C#]
public void ClearRegions();
[C++]
public: void ClearRegions();
[C++/CLI]
public:
void ClearRegions();

Remarks

Use this method to remove all the currently defined regions on the page.

Example

...

// Call the ClearRegions method

ocrXpage.ClearRegions();

...

Requirements

Platforms: See Getting Started section

See Also

Page Class | Page Members


%%PageItemTitle%%

Page Class | Page Members | SetRegions Method

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

GetRegions Method

PegasusImaging.WinForms.OcrXpress1 Namespace > Page Class : GetRegions Method

Gets the regions of a Page object.

[Visual Basic]
Public Function GetRegions() As RegionCollection
[C#]
public RegionCollection GetRegions();
[C++]
public: RegionCollection* GetRegions();
[C++/CLI]
public:
RegionCollection^ GetRegions();

Return Type

The identified regions of the specified page, if any.

Remarks

Regions define rectangular blocks within the page's image where text and pictures exist. The recognition process will attempt to read text within the defined TextRegion objects. The PictureRegion objects are used by Export when an export format is used that supports embedded images. In this case, the pictures are copied and arranged in the export file to reconstruct the original image layout.

If automatic location was used for a Page object, this method will return the results of that process. The returned RegionCollection can be edited and passed back into SetRegions if adjustments are needed.

If automatic location was skipped for a Page object, this method will return null and you will need to manually specify the text regions using SetRegions.

Requirements

Platforms: See Getting Started section

See Also

Page Class | Page Members | SetRegions Method


%%PageItemTitle%%

Page Class | Page Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

GetResult Method

PegasusImaging.WinForms.OcrXpress1 Namespace > Page Class : GetResult Method

Returns a PageResult object containing all of the text recognition results for a Page.

[Visual Basic]
Public Function GetResult() As PageResult
[C#]
public PageResult GetResult();
[C++]
public: PageResult* GetResult();
[C++/CLI]
public:
PageResult^ GetResult();

Remarks

You must perform recognition by calling Recognize on the Page before this method is called. Prior to recognition, this method will return null.

Example

...

// Call the GetResult method

ocrXpage.GetResult();

...

Requirements

Platforms: See Getting Started section

See Also

Page Class | Page Members


%%PageItemTitle%%

Page Class | Page Members | GetRegions Method

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

regions
The new regions for of the Page.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

SetRegions Method

PegasusImaging.WinForms.OcrXpress1 Namespace > Page Class : SetRegions Method

Sets the regions of a Page object.

[Visual Basic]
Public Sub SetRegions( _
   ByVal regions As RegionCollection _
)
[C#]
public void SetRegions(
   RegionCollection regions
);
[C++]
public: void SetRegions(
   RegionCollection* regions
)
[C++/CLI]
public:
void SetRegions(
   RegionCollection^ regions
)

Parameters

regions
The new regions for of the Page.

Remarks

Regions define rectangular blocks within the page's image where text and pictures exist. The recognition process will attempt to read text within the defined TextRegion objects. The PictureRegion objects are used by Export when an export format is used that supports embedded images. In this case, the pictures are copied and arranged in the export file to reconstruct the original image layout.

If automatic location was used for a Page object, it is not required that you specify any regions manually. The regions identified by the automatic location process are available by calling GetRegions after the location process completes.

If automatic location was skipped for a Page object, you can manually specify the text regions using this method.

If no regions have been defined when Recognize is called, the Locate method will be called internally before recognition is started. It is acceptable to omit the call to Locate, and only call Recognize to simplify your code.

The example below demonstrates how to manually create and set text regions of a Page object.

RegionCollection regions = new RegionCollection();
regions.Add(new TextRegion(new System.Drawing.Rectangle(10, 25, 300, 200), true, false));
regions.Add(new TextRegion(new System.Drawing.Rectangle(355, 600, 400, 400), false, false));
regions.Add(new PictureRegion(new System.Drawing.Rectangle(130, 1245, 555, 200)));
myPage1.SetTextRegions(regions);

Requirements

Platforms: See Getting Started section

See Also

Page Class | Page Members | GetRegions Method


%%PageItemTitle%% $$Properties$$

Page Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

Page Class Properties

PegasusImaging.WinForms.OcrXpress1 Namespace : Page Class

For a list of all members of this type, see Page members.

Public Properties

Public Property Bitmap | Gets and sets the primary image for this object.
Public Property BitonalBitmap | Gets and sets a bitonal copy of the primary image.
Public Property BitonalHbitmap | Gets and sets a bitonal copy of the primary image.
Public Property BitonalHdib | Gets and sets a bitonal copy of the primary image.
Public Property Hbitmap | Gets and sets the primary image for this object.
Public Property Hdib | Gets and sets the primary image for this object.

See Also

Page Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%%

Page Class | Page Members | Hdib Property | Hbitmap Property | BitonalBitmap Property | BitonalHdib Property | BitonalHbitmap Property

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

Bitmap Property

PegasusImaging.WinForms.OcrXpress1 Namespace > Page Class : Bitmap Property

Gets and sets the primary image for this object.

[Visual Basic]
Public Property Bitmap As Bitmap
[C#]
public Bitmap Bitmap {get; set;}
[C++]
public: __property Bitmap get_Bitmap();
public: __property void set_Bitmap(
   Bitmap value
);
[C++/CLI]
public:
property Bitmap Bitmap {
   Bitmap get();
   void set (Bitmap value);
}

Remarks

This property provides a way for you to read and write the Page image. This property accepts and returns .NET Bitmap objects. See the See Also section for similar properties of this object that accept and return the same image in other forms.

If you set the Page image using this property, this object will not keep a reference to your image. If you get the Page image using this property, this object will not keep a reference to the image that it returns. When you are finished with an image that this property returns, you should call the Dispose function of the Bitmap object to release it.

Page images can be 1, 8 or 24 bits per pixel. However, a 1 bit-per-pixel image is required for Deskew, AutoRotate, Locate and Recognize. If you pass an 8 or 24 BPP image into this property, a bitonal copy will automatically be created for you. This new bitonal image will be accessible from the Bitonal properties of this object.

Valid values: Any 1, 8 or 24 bit-per-pixel image.

Default value: null

Requirements

Platforms: See Getting Started section

See Also

Page Class | Page Members | Hdib Property | Hbitmap Property | BitonalBitmap Property | BitonalHdib Property | BitonalHbitmap Property


%%PageItemTitle%%

Page Class | Page Members | BitonalHbitmap Property | BitonalHdib Property

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

BitonalBitmap Property

PegasusImaging.WinForms.OcrXpress1 Namespace > Page Class : BitonalBitmap Property

Gets and sets a bitonal copy of the primary image.

[Visual Basic]
Public Property BitonalBitmap As Bitmap
[C#]
public Bitmap BitonalBitmap {get; set;}
[C++]
public: __property Bitmap get_BitonalBitmap();
public: __property void set_BitonalBitmap(
   Bitmap value
);
[C++/CLI]
public:
property Bitmap BitonalBitmap {
   Bitmap get();
   void set (Bitmap value);
}

Remarks

You will only need to use this property if you set the primary Page image to a grayscale or color image. This is because OcrXpress needs a 1 bit-per-pixel image to perform Deskew, AutoRotate, Locate and Recognize.

This property accepts and returns .NET Bitmap objects. Similar properties of this object accept and return the same image in other forms.

If you set the Page image using this property, this object will not keep a reference to your image. If you get the Page image using this property, this object will not keep a reference to the image that it returns. When you are finished with an image that this property returns, you should call the Dispose function of the Bitmap object to release it.

Valid values: Any 1 bit-per-pixel image.

Default value: null

Requirements

Platforms: See Getting Started section

See Also

Page Class | Page Members | BitonalHbitmap Property | BitonalHdib Property


%%PageItemTitle%%

Page Class | Page Members | BitonalBitmap Property | BitonalHdib Property

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

BitonalHbitmap Property

PegasusImaging.WinForms.OcrXpress1 Namespace > Page Class : BitonalHbitmap Property

Gets and sets a bitonal copy of the primary image.

[Visual Basic]
Public Property BitonalHbitmap As IntPtr
[C#]
public IntPtr BitonalHbitmap {get; set;}
[C++]
public: __property IntPtr get_BitonalHbitmap();
public: __property void set_BitonalHbitmap(
   IntPtr value
);
[C++/CLI]
public:
property IntPtr BitonalHbitmap {
   IntPtr get();
   void set (IntPtr value);
}

Remarks

You will only need to use this property if you set the primary Page image to a grayscale or color image. This is because OcrXpress needs a 1 bit-per-pixel image to perform Deskew, AutoRotate, Locate and Recognize.

This property accepts and returns WIN32 HBITMAP handles. Similar properties of this object accept and return the same image in other forms.

If you set the Page image using this property, this object will not keep a reference to your image. If you get the Page image using this property, this object will not keep a reference to the image that it returns. When you are finished with an image that this property returns, you must call the WIN32 DeleteObject() function to release it.

Note: The HBITMAP is an object of the device context and does not have a defined resolution. Because this component will perform its best during segmentation and recognition on images with resolution values, you should avoid using this method of importing an image if possible. The use of HDIB's are encouraged as the fastest method for passing images between OcrXpress, ImagXpress, and other Pegasus Imaging components.

Valid values: Any HBITMAP that contains a 1 bit-per-pixel image.

Default value: 0

Requirements

Platforms: See Getting Started section

See Also

Page Class | Page Members | BitonalBitmap Property | BitonalHdib Property


%%PageItemTitle%%

Page Class | Page Members | BitonalBitmap Property | BitonalHbitmap Property

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

BitonalHdib Property

PegasusImaging.WinForms.OcrXpress1 Namespace > Page Class : BitonalHdib Property

Gets and sets a bitonal copy of the primary image.

[Visual Basic]
Public Property BitonalHdib As IntPtr
[C#]
public IntPtr BitonalHdib {get; set;}
[C++]
public: __property IntPtr get_BitonalHdib();
public: __property void set_BitonalHdib(
   IntPtr value
);
[C++/CLI]
public:
property IntPtr BitonalHdib {
   IntPtr get();
   void set (IntPtr value);
}

Remarks

You will only need to use this property if you set the primary Page image to a grayscale or color image. This is because OcrXpress needs a 1 bit-per-pixel image to perform Deskew, AutoRotate, Locate and Recognize.

This property accepts and returns WIN32 HDIB handles. Similar properties of this object accept and return the same image in other forms.

If you set the Page image using this property, this object will not keep a reference to your image. If you get the Page image using this property, this object will not keep a reference to the image that it returns. When you are finished with an image that this property returns, you must call the WIN32 GlobalFree() function to release it.

Valid values: Any HDIB that contains a 1 bit-per-pixel image.

Default value: 0

Requirements

Platforms: See Getting Started section

See Also

Page Class | Page Members | BitonalBitmap Property | BitonalHbitmap Property


%%PageItemTitle%%

Page Class | Page Members | Bitmap Property | Hdib Property | BitonalBitmap Property | BitonalHdib Property | BitonalHbitmap Property

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

Hbitmap Property

PegasusImaging.WinForms.OcrXpress1 Namespace > Page Class : Hbitmap Property

Gets and sets the primary image for this object.

[Visual Basic]
Public Property Hbitmap As IntPtr
[C#]
public IntPtr Hbitmap {get; set;}
[C++]
public: __property IntPtr get_Hbitmap();
public: __property void set_Hbitmap(
   IntPtr value
);
[C++/CLI]
public:
property IntPtr Hbitmap {
   IntPtr get();
   void set (IntPtr value);
}

Remarks

This property provides a way for you to read and write the Page image. This property accepts and returns WIN32 HBITMAP handles. See the See Also section for similar properties of this object that accept and return the same image in other forms.

If you set the Page image using this property, this object will not keep a reference to your image. If you get the Page image using this property, this object will not keep a reference to the image that it returns. When you are finished with an image that this property returns, you must call the WIN32 DeleteObject() function to release it.

Page images can be 1, 8 or 24 bits per pixel. However, a 1 bit-per-pixel image is required for Deskew, AutoRotate, Locate and Recognize. If you pass an 8 or 24 BPP image into this property, a bitonal copy will automatically be created for you. This new bitonal image will be accessible from the Bitonal properties of this object.

Note: The HBITMAP is an object of the device context and does not have a defined resolution. Because this component will perform its best during segmentation and recognition on images with resolution values, you should avoid using this method of importing an image if possible. The use of HDIB's are encouraged as the fastest method for passing images between OcrXpress, ImagXpress, and other Pegasus Imaging components.

Valid values: Any HBITMAP that contains a 1, 8 or 24 bits-per-pixel image.

Default value: 0

Requirements

Platforms: See Getting Started section

See Also

Page Class | Page Members | Bitmap Property | Hdib Property | BitonalBitmap Property | BitonalHdib Property | BitonalHbitmap Property


%%PageItemTitle%%

Page Class | Page Members | Bitmap Property | Hbitmap Property | BitonalBitmap Property | BitonalHdib Property | BitonalHbitmap Property

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

Hdib Property

PegasusImaging.WinForms.OcrXpress1 Namespace > Page Class : Hdib Property

Gets and sets the primary image for this object.

[Visual Basic]
Public Property Hdib As IntPtr
[C#]
public IntPtr Hdib {get; set;}
[C++]
public: __property IntPtr get_Hdib();
public: __property void set_Hdib(
   IntPtr value
);
[C++/CLI]
public:
property IntPtr Hdib {
   IntPtr get();
   void set (IntPtr value);
}

Remarks

This property provides a way for you to read and write the Page image. This property accepts and returns WIN32 HDIB handles. See the See Also section for similar properties of this object that accept and return the same image in other forms.

If you set the Page image using this property, this object will not keep a reference to your image. If you get the Page image using this property, this object will not keep a reference to the image that it returns. When you are finished with an image that this property returns, you must call the WIN32 GlobalFree() function to release it.

Page images can be 1, 8 or 24 bits per pixel. However, a 1 bit-per-pixel image is required for Deskew, AutoRotate, Locate and Recognize. If you pass an 8 or 24 BPP image into this property, a bitonal copy will automatically be created for you. This new bitonal image will be accessible from the Bitonal properties of this object.

Valid values: Any HDIB that contains a 1, 8 or 24 bits-per-pixel image.

Default value: 0

Requirements

Platforms: See Getting Started section

See Also

Page Class | Page Members | Bitmap Property | Hbitmap Property | BitonalBitmap Property | BitonalHdib Property | BitonalHbitmap Property


%%PageItemTitle%%

PageCountException Members | PegasusImaging.WinForms.OcrXpress1 Namespace | Export Method

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

PageCountException Class

PegasusImaging.WinForms.OcrXpress1 Namespace : PageCountException Class

An exception object that the Document object will throw if more than 999 pages are added.

For a list of all members of this type, see PageCountException members.

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.OcrXpress1.OcrXpressException
PegasusImaging.WinForms.OcrXpress1.PageCountException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class PageCountException
   Inherits OcrXpressException
[C#]
[SerializableAttribute()]
public sealed class PageCountException : OcrXpressException
[C++]
[SerializableAttribute()]
public __gc __sealed class PageCountException : public OcrXpressException
[C++/CLI]
[SerializableAttribute()]
public ref class PageCountException sealed : public OcrXpressException

Remarks

If the document already contains 999 pages, this exception will be thrown when the AddPage method is called.

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

See Also

PageCountException Members | PegasusImaging.WinForms.OcrXpress1 Namespace | Export Method

© 1997 - 2007, Pegasus Imaging Corporation, All Rights Reserved.

Last Modified:


%%PageItemTitle%% $$Members$$

PageCountException Class | PegasusImaging.WinForms.OcrXpress1 Namespace | Export Method

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

PageCountException Class Members

PegasusImaging.WinForms.OcrXpress1 Namespace : PageCountException Class

PageCountException overview

Public Constructors

Public Constructor PageCountException Constructor Overloaded. Initializes a new instance of the PageCountException class.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from OcrXpressException) | The number of the error.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

PageCountException Class | PegasusImaging.WinForms.OcrXpress1 Namespace | Export Method


%%PageItemTitle%%

PageCountException Class | PageCountException Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

PageCountException Constructor

PegasusImaging.WinForms.OcrXpress1 Namespace > PageCountException Class : PageCountException Constructor (PageCountException)

Initializes a new instance of the PageCountException class.

Overload List

Initializes a new instance of the PageCountException class.

[Visual Basic] Public Sub New()

[C#] public PageCountException();

[C++] public PageCountException();

[C++/CLI] public PageCountException();

Initializes a new instance of the PageCountException class.

[Visual Basic] Public Sub New(Integer)

[C#] public PageCountException(int);

[C++] public PageCountException(int);

[C++/CLI] public PageCountException(int);

Initializes a new instance of the PageCountException class.

[Visual Basic] Public Sub New(String)

[C#] public PageCountException(string);

[C++] public PageCountException(string*);

[C++/CLI] public PageCountException(String^);

Initializes a new instance of the PageCountException class.

[Visual Basic] Public Sub New(Integer,String)

[C#] public PageCountException(int,string);

[C++] public PageCountException(int,string*);

[C++/CLI] public PageCountException(int,String^);

Initializes a new instance of the PageCountException class.

[Visual Basic] Public Sub New(String,Exception)

[C#] public PageCountException(string,Exception);

[C++] public PageCountException(string*,Exception*);

[C++/CLI] public PageCountException(String^,Exception^);

Requirements

Platforms: See Getting Started section

See Also

PageCountException Class | PageCountException Members


%%PageItemTitle%%

PageCountException Class | PageCountException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

PageCountException Constructor()

PegasusImaging.WinForms.OcrXpress1 Namespace > PageCountException Class > PageCountException Constructor : PageCountException Constructor()

Initializes a new instance of the PageCountException class.

[Visual Basic]
Public Function New()
[C#]
public PageCountException();
[C++]
public: PageCountException();
[C++/CLI]
public:
PageCountException();

Requirements

Platforms: See Getting Started section

See Also

PageCountException Class | PageCountException Members | Overload List


%%PageItemTitle%%

PageCountException Class | PageCountException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
A number that represents the reason you are creating this exception object.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

PageCountException Constructor(Int32)

PegasusImaging.WinForms.OcrXpress1 Namespace > PageCountException Class > PageCountException Constructor : PageCountException Constructor(Int32)

Initializes a new instance of the PageCountException class.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public PageCountException(
   int errorNumber
);
[C++]
public: PageCountException(
   int errorNumber
)
[C++/CLI]
public:
PageCountException(
   int errorNumber
)

Parameters

errorNumber
A number that represents the reason you are creating this exception object.

Requirements

Platforms: See Getting Started section

See Also

PageCountException Class | PageCountException Members | Overload List


%%PageItemTitle%%

PageCountException Class | PageCountException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
A number that represents the reason you are creating this exception object.
message
A string that describes the reason you are creating this exception object.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

PageCountException Constructor(Int32,String)

PegasusImaging.WinForms.OcrXpress1 Namespace > PageCountException Class > PageCountException Constructor : PageCountException Constructor(Int32,String)

Initializes a new instance of the PageCountException class.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public PageCountException(
   int errorNumber,
   string message
);
[C++]
public: PageCountException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
PageCountException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
A number that represents the reason you are creating this exception object.
message
A string that describes the reason you are creating this exception object.

Requirements

Platforms: See Getting Started section

See Also

PageCountException Class | PageCountException Members | Overload List


%%PageItemTitle%%

PageCountException Class | PageCountException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string that describes the reason you are creating this exception object.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

PageCountException Constructor(String)

PegasusImaging.WinForms.OcrXpress1 Namespace > PageCountException Class > PageCountException Constructor : PageCountException Constructor(String)

Initializes a new instance of the PageCountException class.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public PageCountException(
   string message
);
[C++]
public: PageCountException(
   string* message
)
[C++/CLI]
public:
PageCountException(
   String^ message
)

Parameters

message
A string that describes the reason you are creating this exception object.

Requirements

Platforms: See Getting Started section

See Also

PageCountException Class | PageCountException Members | Overload List


%%PageItemTitle%%

PageCountException Class | PageCountException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string that describes the reason you are creating this exception object.
innerException
The original exception that caused you to create this exception object.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

PageCountException Constructor(String,Exception)

PegasusImaging.WinForms.OcrXpress1 Namespace > PageCountException Class > PageCountException Constructor : PageCountException Constructor(String,Exception)

Initializes a new instance of the PageCountException class.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public PageCountException(
   string message,
   Exception innerException
);
[C++]
public: PageCountException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
PageCountException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string that describes the reason you are creating this exception object.
innerException
The original exception that caused you to create this exception object.

Requirements

Platforms: See Getting Started section

See Also

PageCountException Class | PageCountException Members | Overload List


%%PageItemTitle%%

PageResult Members | PegasusImaging.WinForms.OcrXpress1 Namespace

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

PageResult Class

PegasusImaging.WinForms.OcrXpress1 Namespace : PageResult Class

An object that provides access to all the text results for a Page.

For a list of all members of this type, see PageResult members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.OcrXpress1.PageResult

Syntax

[Visual Basic]
Public Class PageResult
[C#]
public class PageResult
[C++]
public __gc class PageResult
[C++/CLI]
public ref class PageResult

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

See Also

PageResult Members | PegasusImaging.WinForms.OcrXpress1 Namespace

© 1997 - 2007, Pegasus Imaging Corporation, All Rights Reserved.

Last Modified:


%%PageItemTitle%% $$Members$$

PageResult Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

PageResult Class Members

PegasusImaging.WinForms.OcrXpress1 Namespace : PageResult Class

PageResult overview

Public Properties

Public Property TextBlockCount Gets the number of text blocks in the PageResult.

Public Methods

Public Method GetTextBlockResult Gets a TextBlockResult from the PageResult at the specified index.

See Also

PageResult Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%%

PageResult Class | PageResult Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

index
The zero based index for the TextBlockResult. An InvalidIndexException will occur if the index is less than 0 or greater or equal to the TextBlockCount.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

GetTextBlockResult Method

PegasusImaging.WinForms.OcrXpress1 Namespace > PageResult Class : GetTextBlockResult Method

Gets a TextBlockResult from the PageResult at the specified index.

[Visual Basic]
Public Function GetTextBlockResult( _
   ByVal index As Integer _
) As TextBlockResult
[C#]
public TextBlockResult GetTextBlockResult(
   int index
);
[C++]
public: TextBlockResult* GetTextBlockResult(
   int index
)
[C++/CLI]
public:
TextBlockResult^ GetTextBlockResult(
   int index
)

Parameters

index
The zero based index for the TextBlockResult. An InvalidIndexException will occur if the index is less than 0 or greater or equal to the TextBlockCount.

Remarks

This method allows you access to a TextBlockResult. A TextBlockResult object contains lines of text, which you can access individually.

Example

...

// Set the PageResult and get the text block result at index 0

PegasusImaging.WinForms.OcrXpress1.TextBlockResult textResult = theResult.GetTextBlockResult(0);

...

Requirements

Platforms: See Getting Started section

See Also

PageResult Class | PageResult Members


%%PageItemTitle%% $$Properties$$

PageResult Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

PageResult Class Properties

PegasusImaging.WinForms.OcrXpress1 Namespace : PageResult Class

For a list of all members of this type, see PageResult members.

Public Properties

Public Property TextBlockCount Gets the number of text blocks in the PageResult.

See Also

PageResult Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%%

PageResult Class | PageResult Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

TextBlockCount Property

PegasusImaging.WinForms.OcrXpress1 Namespace > PageResult Class : TextBlockCount Property

Gets the number of text blocks in the PageResult.

[Visual Basic]
Public ReadOnly Property TextBlockCount As Integer
[C#]
public int TextBlockCount {get;}
[C++]
public: __property int get_TextBlockCount();
[C++/CLI]
public:
property int TextBlockCount {
   int get();
}

Remarks

This read only property contains the number of text blocks in the PageResult.

Example

...

// Set the PageResult

PegasusImaging.WinForms.OcrXpress1.PageResult theResults = thePage.GetResult();

// Get the TextBlockCount

int tbCnt = theResults.TextBlockCount;

...

Requirements

Platforms: See Getting Started section

See Also

PageResult Class | PageResult Members


%%PageItemTitle%%

ParameterOutOfRangeException Members | PegasusImaging.WinForms.OcrXpress1 Namespace

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

ParameterOutOfRangeException Class

PegasusImaging.WinForms.OcrXpress1 Namespace : ParameterOutOfRangeException Class

An exception object that this component will throw whenever a parameter is out of the valid range.

For a list of all members of this type, see ParameterOutOfRangeException members.

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.OcrXpress1.OcrXpressException
PegasusImaging.WinForms.OcrXpress1.ParameterOutOfRangeException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class ParameterOutOfRangeException
   Inherits OcrXpressException
[C#]
[SerializableAttribute()]
public sealed class ParameterOutOfRangeException : OcrXpressException
[C++]
[SerializableAttribute()]
public __gc __sealed class ParameterOutOfRangeException : public OcrXpressException
[C++/CLI]
[SerializableAttribute()]
public ref class ParameterOutOfRangeException sealed : public OcrXpressException

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

See Also

ParameterOutOfRangeException Members | PegasusImaging.WinForms.OcrXpress1 Namespace

© 1997 - 2007, Pegasus Imaging Corporation, All Rights Reserved.

Last Modified:


%%PageItemTitle%% $$Members$$

ParameterOutOfRangeException Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

ParameterOutOfRangeException Class Members

PegasusImaging.WinForms.OcrXpress1 Namespace : ParameterOutOfRangeException Class

ParameterOutOfRangeException overview

Public Constructors

Public Constructor ParameterOutOfRangeException Constructor Overloaded. Initializes a new instance of the ParameterOutOfRangeException class.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from OcrXpressException) | The number of the error.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

ParameterOutOfRangeException Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%%

ParameterOutOfRangeException Class | ParameterOutOfRangeException Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

ParameterOutOfRangeException Constructor

PegasusImaging.WinForms.OcrXpress1 Namespace > ParameterOutOfRangeException Class : ParameterOutOfRangeException Constructor (ParameterOutOfRangeException)

Initializes a new instance of the ParameterOutOfRangeException class.

Overload List

Initializes a new instance of the ParameterOutOfRangeException class.

[Visual Basic] Public Sub New()

[C#] public ParameterOutOfRangeException();

[C++] public ParameterOutOfRangeException();

[C++/CLI] public ParameterOutOfRangeException();

Initializes a new instance of the ParameterOutOfRangeException class.

[Visual Basic] Public Sub New(Integer)

[C#] public ParameterOutOfRangeException(int);

[C++] public ParameterOutOfRangeException(int);

[C++/CLI] public ParameterOutOfRangeException(int);

Initializes a new instance of the ParameterOutOfRangeException class.

[Visual Basic] Public Sub New(String)

[C#] public ParameterOutOfRangeException(string);

[C++] public ParameterOutOfRangeException(string*);

[C++/CLI] public ParameterOutOfRangeException(String^);

Initializes a new instance of the ParameterOutOfRangeException class.

[Visual Basic] Public Sub New(Integer,String)

[C#] public ParameterOutOfRangeException(int,string);

[C++] public ParameterOutOfRangeException(int,string*);

[C++/CLI] public ParameterOutOfRangeException(int,String^);

Initializes a new instance of the ParameterOutOfRangeException class.

[Visual Basic] Public Sub New(String,Exception)

[C#] public ParameterOutOfRangeException(string,Exception);

[C++] public ParameterOutOfRangeException(string*,Exception*);

[C++/CLI] public ParameterOutOfRangeException(String^,Exception^);

Requirements

Platforms: See Getting Started section

See Also

ParameterOutOfRangeException Class | ParameterOutOfRangeException Members


%%PageItemTitle%%

ParameterOutOfRangeException Class | ParameterOutOfRangeException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

ParameterOutOfRangeException Constructor()

PegasusImaging.WinForms.OcrXpress1 Namespace > ParameterOutOfRangeException Class > ParameterOutOfRangeException Constructor : ParameterOutOfRangeException Constructor()

Initializes a new instance of the ParameterOutOfRangeException class.

[Visual Basic]
Public Function New()
[C#]
public ParameterOutOfRangeException();
[C++]
public: ParameterOutOfRangeException();
[C++/CLI]
public:
ParameterOutOfRangeException();

Requirements

Platforms: See Getting Started section

See Also

ParameterOutOfRangeException Class | ParameterOutOfRangeException Members | Overload List


%%PageItemTitle%%

ParameterOutOfRangeException Class | ParameterOutOfRangeException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

ParameterOutOfRangeException Constructor(Int32)

PegasusImaging.WinForms.OcrXpress1 Namespace > ParameterOutOfRangeException Class > ParameterOutOfRangeException Constructor : ParameterOutOfRangeException Constructor(Int32)

Initializes a new instance of the ParameterOutOfRangeException class.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public ParameterOutOfRangeException(
   int errorNumber
);
[C++]
public: ParameterOutOfRangeException(
   int errorNumber
)
[C++/CLI]
public:
ParameterOutOfRangeException(
   int errorNumber
)

Parameters

errorNumber

Requirements

Platforms: See Getting Started section

See Also

ParameterOutOfRangeException Class | ParameterOutOfRangeException Members | Overload List


%%PageItemTitle%%

ParameterOutOfRangeException Class | ParameterOutOfRangeException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
message
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

ParameterOutOfRangeException Constructor(Int32,String)

PegasusImaging.WinForms.OcrXpress1 Namespace > ParameterOutOfRangeException Class > ParameterOutOfRangeException Constructor : ParameterOutOfRangeException Constructor(Int32,String)

Initializes a new instance of the ParameterOutOfRangeException class.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public ParameterOutOfRangeException(
   int errorNumber,
   string message
);
[C++]
public: ParameterOutOfRangeException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
ParameterOutOfRangeException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
message

Requirements

Platforms: See Getting Started section

See Also

ParameterOutOfRangeException Class | ParameterOutOfRangeException Members | Overload List


%%PageItemTitle%%

ParameterOutOfRangeException Class | ParameterOutOfRangeException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

ParameterOutOfRangeException Constructor(String)

PegasusImaging.WinForms.OcrXpress1 Namespace > ParameterOutOfRangeException Class > ParameterOutOfRangeException Constructor : ParameterOutOfRangeException Constructor(String)

Initializes a new instance of the ParameterOutOfRangeException class.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public ParameterOutOfRangeException(
   string message
);
[C++]
public: ParameterOutOfRangeException(
   string* message
)
[C++/CLI]
public:
ParameterOutOfRangeException(
   String^ message
)

Parameters

message

Requirements

Platforms: See Getting Started section

See Also

ParameterOutOfRangeException Class | ParameterOutOfRangeException Members | Overload List


%%PageItemTitle%%

ParameterOutOfRangeException Class | ParameterOutOfRangeException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
innerException
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

ParameterOutOfRangeException Constructor(String,Exception)

PegasusImaging.WinForms.OcrXpress1 Namespace > ParameterOutOfRangeException Class > ParameterOutOfRangeException Constructor : ParameterOutOfRangeException Constructor(String,Exception)

Initializes a new instance of the ParameterOutOfRangeException class.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public ParameterOutOfRangeException(
   string message,
   Exception innerException
);
[C++]
public: ParameterOutOfRangeException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
ParameterOutOfRangeException(
   String^ message,
   Exception^ innerException
)

Parameters

message
innerException

Requirements

Platforms: See Getting Started section

See Also

ParameterOutOfRangeException Class | ParameterOutOfRangeException Members | Overload List


%%PageItemTitle%%

PathNotFoundException Members | PegasusImaging.WinForms.OcrXpress1 Namespace

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

PathNotFoundException Class

PegasusImaging.WinForms.OcrXpress1 Namespace : PathNotFoundException Class

An exception object that this component throws whenever the path given for the file does not exist.

For a list of all members of this type, see PathNotFoundException members.

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.OcrXpress1.OcrXpressException
PegasusImaging.WinForms.OcrXpress1.PathNotFoundException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class PathNotFoundException
   Inherits OcrXpressException
[C#]
[SerializableAttribute()]
public sealed class PathNotFoundException : OcrXpressException
[C++]
[SerializableAttribute()]
public __gc __sealed class PathNotFoundException : public OcrXpressException
[C++/CLI]
[SerializableAttribute()]
public ref class PathNotFoundException sealed : public OcrXpressException

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

See Also

PathNotFoundException Members | PegasusImaging.WinForms.OcrXpress1 Namespace

© 1997 - 2007, Pegasus Imaging Corporation, All Rights Reserved.

Last Modified:


%%PageItemTitle%% $$Members$$

PathNotFoundException Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

PathNotFoundException Class Members

PegasusImaging.WinForms.OcrXpress1 Namespace : PathNotFoundException Class

PathNotFoundException overview

Public Constructors

Public Constructor PathNotFoundException Constructor Overloaded. Initializes a new instance of the PathNotFoundException class.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from OcrXpressException) | The number of the error.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

PathNotFoundException Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%%

PathNotFoundException Class | PathNotFoundException Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

PathNotFoundException Constructor

PegasusImaging.WinForms.OcrXpress1 Namespace > PathNotFoundException Class : PathNotFoundException Constructor (PathNotFoundException)

Initializes a new instance of the PathNotFoundException class.

Overload List

Initializes a new instance of the PathNotFoundException class.

[Visual Basic] Public Sub New()

[C#] public PathNotFoundException();

[C++] public PathNotFoundException();

[C++/CLI] public PathNotFoundException();

Initializes a new instance of the PathNotFoundException class.

[Visual Basic] Public Sub New(Integer)

[C#] public PathNotFoundException(int);

[C++] public PathNotFoundException(int);

[C++/CLI] public PathNotFoundException(int);

Initializes a new instance of the PathNotFoundException class.

[Visual Basic] Public Sub New(String)

[C#] public PathNotFoundException(string);

[C++] public PathNotFoundException(string*);

[C++/CLI] public PathNotFoundException(String^);

Initializes a new instance of the PathNotFoundException class.

[Visual Basic] Public Sub New(Integer,String)

[C#] public PathNotFoundException(int,string);

[C++] public PathNotFoundException(int,string*);

[C++/CLI] public PathNotFoundException(int,String^);

Initializes a new instance of the PathNotFoundException class.

[Visual Basic] Public Sub New(String,Exception)

[C#] public PathNotFoundException(string,Exception);

[C++] public PathNotFoundException(string*,Exception*);

[C++/CLI] public PathNotFoundException(String^,Exception^);

Requirements

Platforms: See Getting Started section

See Also

PathNotFoundException Class | PathNotFoundException Members


%%PageItemTitle%%

PathNotFoundException Class | PathNotFoundException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

PathNotFoundException Constructor()

PegasusImaging.WinForms.OcrXpress1 Namespace > PathNotFoundException Class > PathNotFoundException Constructor : PathNotFoundException Constructor()

Initializes a new instance of the PathNotFoundException class.

[Visual Basic]
Public Function New()
[C#]
public PathNotFoundException();
[C++]
public: PathNotFoundException();
[C++/CLI]
public:
PathNotFoundException();

Requirements

Platforms: See Getting Started section

See Also

PathNotFoundException Class | PathNotFoundException Members | Overload List


%%PageItemTitle%%

PathNotFoundException Class | PathNotFoundException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
A number that represents the reason you are creating this exception object.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

PathNotFoundException Constructor(Int32)

PegasusImaging.WinForms.OcrXpress1 Namespace > PathNotFoundException Class > PathNotFoundException Constructor : PathNotFoundException Constructor(Int32)

Initializes a new instance of the PathNotFoundException class.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public PathNotFoundException(
   int errorNumber
);
[C++]
public: PathNotFoundException(
   int errorNumber
)
[C++/CLI]
public:
PathNotFoundException(
   int errorNumber
)

Parameters

errorNumber
A number that represents the reason you are creating this exception object.

Requirements

Platforms: See Getting Started section

See Also

PathNotFoundException Class | PathNotFoundException Members | Overload List


%%PageItemTitle%%

PathNotFoundException Class | PathNotFoundException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
A number that represents the reason you are creating this exception object.
message
A string that describes the reason you are creating this exception object.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

PathNotFoundException Constructor(Int32,String)

PegasusImaging.WinForms.OcrXpress1 Namespace > PathNotFoundException Class > PathNotFoundException Constructor : PathNotFoundException Constructor(Int32,String)

Initializes a new instance of the PathNotFoundException class.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public PathNotFoundException(
   int errorNumber,
   string message
);
[C++]
public: PathNotFoundException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
PathNotFoundException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
A number that represents the reason you are creating this exception object.
message
A string that describes the reason you are creating this exception object.

Requirements

Platforms: See Getting Started section

See Also

PathNotFoundException Class | PathNotFoundException Members | Overload List


%%PageItemTitle%%

PathNotFoundException Class | PathNotFoundException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string that describes the reason you are creating this exception object.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

PathNotFoundException Constructor(String)

PegasusImaging.WinForms.OcrXpress1 Namespace > PathNotFoundException Class > PathNotFoundException Constructor : PathNotFoundException Constructor(String)

Initializes a new instance of the PathNotFoundException class.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public PathNotFoundException(
   string message
);
[C++]
public: PathNotFoundException(
   string* message
)
[C++/CLI]
public:
PathNotFoundException(
   String^ message
)

Parameters

message
A string that describes the reason you are creating this exception object.

Requirements

Platforms: See Getting Started section

See Also

PathNotFoundException Class | PathNotFoundException Members | Overload List


%%PageItemTitle%%

PathNotFoundException Class | PathNotFoundException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string that describes the reason you are creating this exception object.
innerException
The original exception that caused you to create this exception object.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

PathNotFoundException Constructor(String,Exception)

PegasusImaging.WinForms.OcrXpress1 Namespace > PathNotFoundException Class > PathNotFoundException Constructor : PathNotFoundException Constructor(String,Exception)

Initializes a new instance of the PathNotFoundException class.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public PathNotFoundException(
   string message,
   Exception innerException
);
[C++]
public: PathNotFoundException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
PathNotFoundException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string that describes the reason you are creating this exception object.
innerException
The original exception that caused you to create this exception object.

Requirements

Platforms: See Getting Started section

See Also

PathNotFoundException Class | PathNotFoundException Members | Overload List


%%PageItemTitle%%

PictureRegion Members | PegasusImaging.WinForms.OcrXpress1 Namespace

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

PictureRegion Class

PegasusImaging.WinForms.OcrXpress1 Namespace : PictureRegion Class

This object defines a rectangular area of a page's image as a picture region.

For a list of all members of this type, see PictureRegion members.

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.OcrXpress1.Region
PegasusImaging.WinForms.OcrXpress1.PictureRegion

Syntax

[Visual Basic]
Public Class PictureRegion
   Inherits Region
[C#]
public class PictureRegion : Region
[C++]
public __gc class PictureRegion : public Region
[C++/CLI]
public ref class PictureRegion : public Region

Remarks

A picture region simply defines where embedded pictures or graphics exist. Picture regions are ignored by the recognition process, and are identified solely for use during Export if an export format is selected that supports embedded images. In this case, any defined picture regions will be extracted from the original image, and embedded into the export file.

There can be zero to many picture regions defined for a single page. Ocr Xpress can automatically detect picture regions for a page using the Locate method. You can also modify and add regions yourself by using the SetRegions method.

Example

...

// Set the PictureRegion object

PegasusImaging.WinForms.OcrXpress1.PictureRegion ocrXpicReg = new PictureRegion();

...

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

See Also

PictureRegion Members | PegasusImaging.WinForms.OcrXpress1 Namespace

© 1997 - 2007, Pegasus Imaging Corporation, All Rights Reserved.

Last Modified:


%%PageItemTitle%% $$Members$$

PictureRegion Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

PictureRegion Class Members

PegasusImaging.WinForms.OcrXpress1 Namespace : PictureRegion Class

PictureRegion overview

Public Constructors

Public Constructor PictureRegion Constructor Overloaded. Defines a region that contains pictures or graphics within the image.

Public Properties

Public Property Area (Inherited from Region) The image area of the region (in pixels measured from the top left corner.)

See Also

PictureRegion Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%%

PictureRegion Class | PictureRegion Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

PictureRegion Constructor

PegasusImaging.WinForms.OcrXpress1 Namespace > PictureRegion Class : PictureRegion Constructor (PictureRegion)

Defines a region that contains pictures or graphics within the image.

Overload List

Defines a region that contains pictures or graphics within the image.

[Visual Basic] Public Sub New()

[C#] public PictureRegion();

[C++] public PictureRegion();

[C++/CLI] public PictureRegion();

Defines a region that contains pictures or graphics within the image.

[Visual Basic] Public Sub New(Rectangle)

[C#] public PictureRegion(Rectangle);

[C++] public PictureRegion(Rectangle);

[C++/CLI] public PictureRegion(Rectangle);

Remarks

If the default constructor is used to create a PictureRegion object, the Area property must be set prior to calling SetRegions, else an invalid area exception will be thrown.

Requirements

Platforms: See Getting Started section

See Also

PictureRegion Class | PictureRegion Members


%%PageItemTitle%%

PictureRegion Class | PictureRegion Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

PictureRegion Constructor()

PegasusImaging.WinForms.OcrXpress1 Namespace > PictureRegion Class > PictureRegion Constructor : PictureRegion Constructor()

Defines a region that contains pictures or graphics within the image.

[Visual Basic]
Public Function New()
[C#]
public PictureRegion();
[C++]
public: PictureRegion();
[C++/CLI]
public:
PictureRegion();

Remarks

If the default constructor is used to create a PictureRegion object, the Area property must be set prior to calling SetRegions, else an invalid area exception will be thrown.

Requirements

Platforms: See Getting Started section

See Also

PictureRegion Class | PictureRegion Members | Overload List


%%PageItemTitle%%

PictureRegion Class | PictureRegion Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

regionArea
The image area coordinates where this picture region is located.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

PictureRegion Constructor(Rectangle)

PegasusImaging.WinForms.OcrXpress1 Namespace > PictureRegion Class > PictureRegion Constructor : PictureRegion Constructor(Rectangle)

Defines a region that contains pictures or graphics within the image.

[Visual Basic]
Public Function New( _
   ByVal regionArea As Rectangle _
)
[C#]
public PictureRegion(
   Rectangle regionArea
);
[C++]
public: PictureRegion(
   Rectangle regionArea
)
[C++/CLI]
public:
PictureRegion(
   Rectangle regionArea
)

Parameters

regionArea
The image area coordinates where this picture region is located.

Remarks

This overloaded constructor will set the Area of the picture region.

Requirements

Platforms: See Getting Started section

See Also

PictureRegion Class | PictureRegion Members | Overload List


%%PageItemTitle%%

RecognitionNotPerformedException Members | PegasusImaging.WinForms.OcrXpress1 Namespace

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

RecognitionNotPerformedException Class

PegasusImaging.WinForms.OcrXpress1 Namespace : RecognitionNotPerformedException Class

An exception object that the Document object will throw when an attempt is made to Export before Recognize is called.

For a list of all members of this type, see RecognitionNotPerformedException members.

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.OcrXpress1.OcrXpressException
PegasusImaging.WinForms.OcrXpress1.RecognitionNotPerformedException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class RecognitionNotPerformedException
   Inherits OcrXpressException
[C#]
[SerializableAttribute()]
public sealed class RecognitionNotPerformedException : OcrXpressException
[C++]
[SerializableAttribute()]
public __gc __sealed class RecognitionNotPerformedException : public OcrXpressException
[C++/CLI]
[SerializableAttribute()]
public ref class RecognitionNotPerformedException sealed : public OcrXpressException

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

See Also

RecognitionNotPerformedException Members | PegasusImaging.WinForms.OcrXpress1 Namespace

© 1997 - 2007, Pegasus Imaging Corporation, All Rights Reserved.

Last Modified:


%%PageItemTitle%% $$Members$$

RecognitionNotPerformedException Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

RecognitionNotPerformedException Class Members

PegasusImaging.WinForms.OcrXpress1 Namespace : RecognitionNotPerformedException Class

RecognitionNotPerformedException overview

Public Constructors

Public Constructor RecognitionNotPerformedException Constructor Overloaded. Initializes a new instance of the RecognitionNotPerformedException class.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from OcrXpressException) | The number of the error.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

RecognitionNotPerformedException Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%%

RecognitionNotPerformedException Class | RecognitionNotPerformedException Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

RecognitionNotPerformedException Constructor

PegasusImaging.WinForms.OcrXpress1 Namespace > RecognitionNotPerformedException Class : RecognitionNotPerformedException Constructor (RecognitionNotPerformedException)

Initializes a new instance of the RecognitionNotPerformedException class.

Overload List

Initializes a new instance of the RecognitionNotPerformedException class.

[Visual Basic] Public Sub New()

[C#] public RecognitionNotPerformedException();

[C++] public RecognitionNotPerformedException();

[C++/CLI] public RecognitionNotPerformedException();

Initializes a new instance of the RecognitionNotPerformedException class.

[Visual Basic] Public Sub New(Integer)

[C#] public RecognitionNotPerformedException(int);

[C++] public RecognitionNotPerformedException(int);

[C++/CLI] public RecognitionNotPerformedException(int);

Initializes a new instance of the RecognitionNotPerformedException class.

[Visual Basic] Public Sub New(String)

[C#] public RecognitionNotPerformedException(string);

[C++] public RecognitionNotPerformedException(string*);

[C++/CLI] public RecognitionNotPerformedException(String^);

Initializes a new instance of the RecognitionNotPerformedException class.

[Visual Basic] Public Sub New(Integer,String)

[C#] public RecognitionNotPerformedException(int,string);

[C++] public RecognitionNotPerformedException(int,string*);

[C++/CLI] public RecognitionNotPerformedException(int,String^);

Initializes a new instance of the RecognitionNotPerformedException class.

[Visual Basic] Public Sub New(String,Exception)

[C#] public RecognitionNotPerformedException(string,Exception);

[C++] public RecognitionNotPerformedException(string*,Exception*);

[C++/CLI] public RecognitionNotPerformedException(String^,Exception^);

Requirements

Platforms: See Getting Started section

See Also

RecognitionNotPerformedException Class | RecognitionNotPerformedException Members


%%PageItemTitle%%

RecognitionNotPerformedException Class | RecognitionNotPerformedException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

RecognitionNotPerformedException Constructor()

PegasusImaging.WinForms.OcrXpress1 Namespace > RecognitionNotPerformedException Class > RecognitionNotPerformedException Constructor : RecognitionNotPerformedException Constructor()

Initializes a new instance of the RecognitionNotPerformedException class.

[Visual Basic]
Public Function New()
[C#]
public RecognitionNotPerformedException();
[C++]
public: RecognitionNotPerformedException();
[C++/CLI]
public:
RecognitionNotPerformedException();

Requirements

Platforms: See Getting Started section

See Also

RecognitionNotPerformedException Class | RecognitionNotPerformedException Members | Overload List


%%PageItemTitle%%

RecognitionNotPerformedException Class | RecognitionNotPerformedException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
A number that represents the reason you are creating this exception object.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

RecognitionNotPerformedException Constructor(Int32)

PegasusImaging.WinForms.OcrXpress1 Namespace > RecognitionNotPerformedException Class > RecognitionNotPerformedException Constructor : RecognitionNotPerformedException Constructor(Int32)

Initializes a new instance of the RecognitionNotPerformedException class.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public RecognitionNotPerformedException(
   int errorNumber
);
[C++]
public: RecognitionNotPerformedException(
   int errorNumber
)
[C++/CLI]
public:
RecognitionNotPerformedException(
   int errorNumber
)

Parameters

errorNumber
A number that represents the reason you are creating this exception object.

Requirements

Platforms: See Getting Started section

See Also

RecognitionNotPerformedException Class | RecognitionNotPerformedException Members | Overload List


%%PageItemTitle%%

RecognitionNotPerformedException Class | RecognitionNotPerformedException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
A number that represents the reason you are creating this exception object.
message
A string that describes the reason you are creating this exception object.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

RecognitionNotPerformedException Constructor(Int32,String)

PegasusImaging.WinForms.OcrXpress1 Namespace > RecognitionNotPerformedException Class > RecognitionNotPerformedException Constructor : RecognitionNotPerformedException Constructor(Int32,String)

Initializes a new instance of the RecognitionNotPerformedException class.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public RecognitionNotPerformedException(
   int errorNumber,
   string message
);
[C++]
public: RecognitionNotPerformedException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
RecognitionNotPerformedException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
A number that represents the reason you are creating this exception object.
message
A string that describes the reason you are creating this exception object.

Requirements

Platforms: See Getting Started section

See Also

RecognitionNotPerformedException Class | RecognitionNotPerformedException Members | Overload List


%%PageItemTitle%%

RecognitionNotPerformedException Class | RecognitionNotPerformedException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string that describes the reason you are creating this exception object.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

RecognitionNotPerformedException Constructor(String)

PegasusImaging.WinForms.OcrXpress1 Namespace > RecognitionNotPerformedException Class > RecognitionNotPerformedException Constructor : RecognitionNotPerformedException Constructor(String)

Initializes a new instance of the RecognitionNotPerformedException class.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public RecognitionNotPerformedException(
   string message
);
[C++]
public: RecognitionNotPerformedException(
   string* message
)
[C++/CLI]
public:
RecognitionNotPerformedException(
   String^ message
)

Parameters

message
A string that describes the reason you are creating this exception object.

Requirements

Platforms: See Getting Started section

See Also

RecognitionNotPerformedException Class | RecognitionNotPerformedException Members | Overload List


%%PageItemTitle%%

RecognitionNotPerformedException Class | RecognitionNotPerformedException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string that describes the reason you are creating this exception object.
innerException
The original exception that caused you to create this exception object.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

RecognitionNotPerformedException Constructor(String,Exception)

PegasusImaging.WinForms.OcrXpress1 Namespace > RecognitionNotPerformedException Class > RecognitionNotPerformedException Constructor : RecognitionNotPerformedException Constructor(String,Exception)

Initializes a new instance of the RecognitionNotPerformedException class.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public RecognitionNotPerformedException(
   string message,
   Exception innerException
);
[C++]
public: RecognitionNotPerformedException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
RecognitionNotPerformedException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string that describes the reason you are creating this exception object.
innerException
The original exception that caused you to create this exception object.

Requirements

Platforms: See Getting Started section

See Also

RecognitionNotPerformedException Class | RecognitionNotPerformedException Members | Overload List


%%PageItemTitle%%

Region Members | PegasusImaging.WinForms.OcrXpress1 Namespace | TextRegion Class | PictureRegion Class

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

Region Class

PegasusImaging.WinForms.OcrXpress1 Namespace : Region Class

The Region object is the base class for all the region objects.

For a list of all members of this type, see Region members.

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.OcrXpress1.Region
PegasusImaging.WinForms.OcrXpress1.TextRegion
PegasusImaging.WinForms.OcrXpress1.PictureRegion

Syntax

[Visual Basic]
Public Class Region
[C#]
public class Region
[C++]
public __gc class Region
[C++/CLI]
public ref class Region

Remarks

You cannot create a Region object directly. Instead, you must create TextRegion and PictureRegion objects, which are both derived from this class.

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

See Also

Region Members | PegasusImaging.WinForms.OcrXpress1 Namespace | TextRegion Class | PictureRegion Class

© 1997 - 2007, Pegasus Imaging Corporation, All Rights Reserved.

Last Modified:


%%PageItemTitle%% $$Members$$

Region Class | PegasusImaging.WinForms.OcrXpress1 Namespace | TextRegion Class | PictureRegion Class

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

Region Class Members

PegasusImaging.WinForms.OcrXpress1 Namespace : Region Class

Region overview

Public Properties

Public Property Area The image area of the region (in pixels measured from the top left corner.)

See Also

Region Class | PegasusImaging.WinForms.OcrXpress1 Namespace | TextRegion Class | PictureRegion Class


%%PageItemTitle%% $$Properties$$

Region Class | PegasusImaging.WinForms.OcrXpress1 Namespace | TextRegion Class | PictureRegion Class

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

Region Class Properties

PegasusImaging.WinForms.OcrXpress1 Namespace : Region Class

For a list of all members of this type, see Region members.

Public Properties

Public Property Area The image area of the region (in pixels measured from the top left corner.)

See Also

Region Class | PegasusImaging.WinForms.OcrXpress1 Namespace | TextRegion Class | PictureRegion Class


%%PageItemTitle%%

Region Class | Region Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

Area Property

PegasusImaging.WinForms.OcrXpress1 Namespace > Region Class : Area Property (Region)

The image area of the region (in pixels measured from the top left corner.)

[Visual Basic]
Public Overridable Property Area As Rectangle
[C#]
public virtual Rectangle Area {get; set;}
[C++]
public: __property virtual Rectangle get_Area();
public: __property virtual void set_Area(
   Rectangle value
);
[C++/CLI]
public:
virtual property Rectangle Area {
   Rectangle get();
   void set (Rectangle value);
}

Remarks

This property contains the area of the region. The pixel at the top left corner of the image is at (0, 0). Values of X increase as you move to the right on the image and values of Y increase as you move down the image. Every pixel within the rectangle that this parameter defines is considered to be within the region and every other pixel is considered to be outside the region.

Valid value: Any rectangle that lies wholly within the image of the page.

Default value: X=0, Y=0, Width=0, Height=0

Requirements

Platforms: See Getting Started section

See Also

Region Class | Region Members


%%PageItemTitle%%

RegionCollection Members | PegasusImaging.WinForms.OcrXpress1 Namespace

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

RegionCollection Class

PegasusImaging.WinForms.OcrXpress1 Namespace : RegionCollection Class

Represents a collection of TextRegion and PictureRegion objects.

For a list of all members of this type, see RegionCollection members.

Object Model

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
PegasusImaging.WinForms.OcrXpress1.RegionCollection

Syntax

[Visual Basic]
<DefaultMemberAttribute("Item")>
Public Class RegionCollection
   Inherits CollectionBase
[C#]
[DefaultMemberAttribute("Item")]
public class RegionCollection : CollectionBase
[C++]
[DefaultMemberAttribute("Item")]
public __gc class RegionCollection : public CollectionBase
[C++/CLI]
[DefaultMemberAttribute("Item")]
public ref class RegionCollection : public CollectionBase

Remarks

A RegionCollection object lets you maintain a list of TextRegion and PictureRegion objects. You can easily add, remove, and find these objects in the list.

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

See Also

RegionCollection Members | PegasusImaging.WinForms.OcrXpress1 Namespace

© 1997 - 2007, Pegasus Imaging Corporation, All Rights Reserved.

Last Modified:


%%PageItemTitle%% $$Members$$

RegionCollection Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

RegionCollection Class Members

PegasusImaging.WinForms.OcrXpress1 Namespace : RegionCollection Class

RegionCollection overview

Public Constructors

Public Constructor RegionCollection Constructor

Public Properties

Public Property Capacity (Inherited from System.Collections.CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Public Property Count (Inherited from System.Collections.CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
Public Property Item | Gets or sets the element at the given index.

Public Methods

Public Method Add | Adds a Region to the collection.
Public Method Clear (Inherited from System.Collections.CollectionBase) | Removes all objects from the CollectionBase instance.
Public Method Contains | Determines if the specified Region is contained in the collection.
Public Method CopyTo | Copies a RegionCollection to a new collection.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) | Returns an enumerator that iterates through the CollectionBase instance.
Public Method IndexOf | Determines if the specified Region is in the collection and returns it's index.
Public Method Insert | Inserts a Region into the collection at the given index.
Public Method Remove | Removes a Region from the collection.
Public Method RemoveAt (Inherited from System.Collections.CollectionBase) | Removes the element at the specified index of the CollectionBase instance.

See Also

RegionCollection Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%%

RegionCollection Class | RegionCollection Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

RegionCollection Constructor

PegasusImaging.WinForms.OcrXpress1 Namespace > RegionCollection Class : RegionCollection Constructor (RegionCollection)
[Visual Basic]
Public Function New()
[C#]
public RegionCollection();
[C++]
public: RegionCollection();
[C++/CLI]
public:
RegionCollection();

Requirements

Platforms: See Getting Started section

See Also

RegionCollection Class | RegionCollection Members


%%PageItemTitle%%

RegionCollection Class | RegionCollection Members | Region Class

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

value
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

Add Method

PegasusImaging.WinForms.OcrXpress1 Namespace > RegionCollection Class : Add Method

Adds a Region to the collection.

[Visual Basic]
Public Function Add( _
   ByVal value As Region _
) As Integer
[C#]
public int Add(
   Region value
);
[C++]
public: int Add(
   Region* value
)
[C++/CLI]
public:
int Add(
   Region^ value
)

Parameters

value

Remarks

This method inserts a new Region object at the end of the collection. When this method is complete, the length of the collection will be one larger than it was and the element with the highest index will be the new object.

Example

...

// set the region collection

PegasusImaging.WinForms.OcrXpress1.RegionCollection myRegions = new PegasusImaging.WinForms.OcrXpress1.RegionCollection;

// Add regions to the collection

myRegions.Add(firstRegion); myRegions.Add(secondRegion);

...

Requirements

Platforms: See Getting Started section

See Also

RegionCollection Class | RegionCollection Members | Region Class


%%PageItemTitle%%

RegionCollection Class | RegionCollection Members | Region Class

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

value
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

Contains Method

PegasusImaging.WinForms.OcrXpress1 Namespace > RegionCollection Class : Contains Method

Determines if the specified Region is contained in the collection.

[Visual Basic]
Public Function Contains( _
   ByVal value As Region _
) As Boolean
[C#]
public bool Contains(
   Region value
);
[C++]
public: bool Contains(
   Region* value
)
[C++/CLI]
public:
bool Contains(
   Region^ value
)

Parameters

value

Remarks

This method searches the collection for the given Region. If a reference to the region is found, this method returns true, otherwise, false is returned.

Example

...

// set the region collection

PegasusImaging.WinForms.OcrXpress1.RegionCollection myRegions = new PegasusImaging.WinForms.OcrXpress1.RegionCollection;

// Get the value if the specified region is in the collection

bool containsRegion = myRegions.Contains(firstRegion);

...

Requirements

Platforms: See Getting Started section

See Also

RegionCollection Class | RegionCollection Members | Region Class


%%PageItemTitle%%

RegionCollection Class | RegionCollection Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

array
Contains an array that receives the elements of the collection.
index
Contains the zero-based index in array where this method starts copying the collection.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

CopyTo Method

PegasusImaging.WinForms.OcrXpress1 Namespace > RegionCollection Class : CopyTo Method

Copies a RegionCollection to a new collection.

[Visual Basic]
Public Sub CopyTo( _
   ByVal array() As Region, _
   ByVal index As Integer _
)
[C#]
public void CopyTo(
   Region[] array,
   int index
);
[C++]
public: void CopyTo(
   Region*[] array,
   int index
)
[C++/CLI]
public:
void CopyTo(
   Region^array<array> array,
   int index
)

Parameters

array
Contains an array that receives the elements of the collection.
index
Contains the zero-based index in array where this method starts copying the collection.

Remarks

This method implements a standard collection operation. It copies elements from this collection to the given array in order, starting at element 0 in this collection. It places the elements into the array starting at the given zero-based index. This method will stop copying elements when it reaches the end of the collection or the end of the array.

Example

[C#]

...
    // Set the RegionCollection and copy from one region collection to an index value
    PegasusImaging.WinForms.OcrXpress1.RegionCollection myRegions = ocrX.Document.GetPage(i).GetRegions();
    myRegions.CopyTo(myOtherRegion, 2);
    ...

Requirements

Platforms: See Getting Started section

See Also

RegionCollection Class | RegionCollection Members


%%PageItemTitle%%

RegionCollection Class | RegionCollection Members | Region Class

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

value
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

IndexOf Method

PegasusImaging.WinForms.OcrXpress1 Namespace > RegionCollection Class : IndexOf Method

Determines if the specified Region is in the collection and returns it's index.

[Visual Basic]
Public Function IndexOf( _
   ByVal value As Region _
) As Integer
[C#]
public int IndexOf(
   Region value
);
[C++]
public: int IndexOf(
   Region* value
)
[C++/CLI]
public:
int IndexOf(
   Region^ value
)

Parameters

value

Remarks

This method searches the collection for a reference to the given object. If it finds a reference to it, this method returns -1. If the object is present more than once in the collection, this method returns the lowest index of a match.

Requirements

Platforms: See Getting Started section

See Also

RegionCollection Class | RegionCollection Members | Region Class


%%PageItemTitle%%

RegionCollection Class | RegionCollection Members | Region Class

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

index
value
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

Insert Method

PegasusImaging.WinForms.OcrXpress1 Namespace > RegionCollection Class : Insert Method

Inserts a Region into the collection at the given index.

[Visual Basic]
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal value As Region _
)
[C#]
public void Insert(
   int index,
   Region value
);
[C++]
public: void Insert(
   int index,
   Region* value
)
[C++/CLI]
public:
void Insert(
   int index,
   Region^ value
)

Parameters

index
value

Remarks

This method inserts the given Region into the collection at the given index.

Example

...

// set the region collection

PegasusImaging.WinForms.OcrXpress1.RegionCollection myRegions = new PegasusImaging.WinForms.OcrXpress1.RegionCollection;

// Insert at 0 index the secondRegion value

secondRegion = Page.GetRegion(); myRegions.insert(0, secondRegion);

...

Requirements

Platforms: See Getting Started section

See Also

RegionCollection Class | RegionCollection Members | Region Class


%%PageItemTitle%%

RegionCollection Class | RegionCollection Members | Region Class

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

value
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

Remove Method

PegasusImaging.WinForms.OcrXpress1 Namespace > RegionCollection Class : Remove Method

Removes a Region from the collection.

[Visual Basic]
Public Sub Remove( _
   ByVal value As Region _
)
[C#]
public void Remove(
   Region value
);
[C++]
public: void Remove(
   Region* value
)
[C++/CLI]
public:
void Remove(
   Region^ value
)

Parameters

value

Remarks

This method searches the collection for the given Region and removes it. If there are no occurrences of the object, this method will do nothing.

Example

...

// set the region collection

PegasusImaging.WinForms.OcrXpress1.RegionCollection myRegions = new PegasusImaging.WinForms.OcrXpress1.RegionCollection;

// Remove the secondRegion value

myRegions.Remove(secondRegion);

...

Requirements

Platforms: See Getting Started section

See Also

RegionCollection Class | RegionCollection Members | Region Class


%%PageItemTitle%% $$Properties$$

RegionCollection Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

RegionCollection Class Properties

PegasusImaging.WinForms.OcrXpress1 Namespace : RegionCollection Class

For a list of all members of this type, see RegionCollection members.

Public Properties

Public Property Capacity (Inherited from System.Collections.CollectionBase) | Gets or sets the number of elements that the CollectionBase can contain.
Public Property Count (Inherited from System.Collections.CollectionBase) | Gets the number of elements contained in the CollectionBase instance.
Public Property Item | Gets or sets the element at the given index.

See Also

RegionCollection Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%%

RegionCollection Class | RegionCollection Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

index
A zero-based integer specifying the index in the collection to get or set.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

Item Property

PegasusImaging.WinForms.OcrXpress1 Namespace > RegionCollection Class : Item Property

Gets or sets the element at the given index.

[Visual Basic]
Public Default Property Item( _
   ByVal index As Integer _
) As Region
[C#]
public Region this[
   int index
]; {get; set;}
[C++]
public: __property Region* get_Item(
   int index
);
public: __property void set_Item(
   int index,
   Region* value
);
[C++/CLI]
public:
 property Region^ default [int] {
   Region^ get(int index);
   void set (int index, Region^ value);
}

Parameters

index
A zero-based integer specifying the index in the collection to get or set.

Remarks

This method implements a standard collection operation. It is the principle method you will use to read or change elements in the collection. You can read or modify any element in the collection with this method.

Requirements

Platforms: See Getting Started section

See Also

RegionCollection Class | RegionCollection Members


%%PageItemTitle%%

RelativePathException Members | PegasusImaging.WinForms.OcrXpress1 Namespace

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

RelativePathException Class

PegasusImaging.WinForms.OcrXpress1 Namespace : RelativePathException Class

An exception object that this component will throw whenever a relative path given as input cannot be resolved.

For a list of all members of this type, see RelativePathException members.

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.OcrXpress1.OcrXpressException
PegasusImaging.WinForms.OcrXpress1.RelativePathException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class RelativePathException
   Inherits OcrXpressException
[C#]
[SerializableAttribute()]
public sealed class RelativePathException : OcrXpressException
[C++]
[SerializableAttribute()]
public __gc __sealed class RelativePathException : public OcrXpressException
[C++/CLI]
[SerializableAttribute()]
public ref class RelativePathException sealed : public OcrXpressException

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

See Also

RelativePathException Members | PegasusImaging.WinForms.OcrXpress1 Namespace

© 1997 - 2007, Pegasus Imaging Corporation, All Rights Reserved.

Last Modified:


%%PageItemTitle%% $$Members$$

RelativePathException Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

RelativePathException Class Members

PegasusImaging.WinForms.OcrXpress1 Namespace : RelativePathException Class

RelativePathException overview

Public Constructors

Public Constructor RelativePathException Constructor Overloaded. Initializes a new instance of the RelativePathException class.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from OcrXpressException) | The number of the error.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

RelativePathException Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%%

RelativePathException Class | RelativePathException Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

RelativePathException Constructor

PegasusImaging.WinForms.OcrXpress1 Namespace > RelativePathException Class : RelativePathException Constructor (RelativePathException)

Initializes a new instance of the RelativePathException class.

Overload List

Initializes a new instance of the RelativePathException class.

[Visual Basic] Public Sub New()

[C#] public RelativePathException();

[C++] public RelativePathException();

[C++/CLI] public RelativePathException();

Initializes a new instance of the RelativePathException class.

[Visual Basic] Public Sub New(Integer)

[C#] public RelativePathException(int);

[C++] public RelativePathException(int);

[C++/CLI] public RelativePathException(int);

Initializes a new instance of the RelativePathException class.

[Visual Basic] Public Sub New(String)

[C#] public RelativePathException(string);

[C++] public RelativePathException(string*);

[C++/CLI] public RelativePathException(String^);

Initializes a new instance of the RelativePathException class.

[Visual Basic] Public Sub New(Integer,String)

[C#] public RelativePathException(int,string);

[C++] public RelativePathException(int,string*);

[C++/CLI] public RelativePathException(int,String^);

Initializes a new instance of the RelativePathException class.

[Visual Basic] Public Sub New(String,Exception)

[C#] public RelativePathException(string,Exception);

[C++] public RelativePathException(string*,Exception*);

[C++/CLI] public RelativePathException(String^,Exception^);

Requirements

Platforms: See Getting Started section

See Also

RelativePathException Class | RelativePathException Members


%%PageItemTitle%%

RelativePathException Class | RelativePathException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

RelativePathException Constructor()

PegasusImaging.WinForms.OcrXpress1 Namespace > RelativePathException Class > RelativePathException Constructor : RelativePathException Constructor()

Initializes a new instance of the RelativePathException class.

[Visual Basic]
Public Function New()
[C#]
public RelativePathException();
[C++]
public: RelativePathException();
[C++/CLI]
public:
RelativePathException();

Requirements

Platforms: See Getting Started section

See Also

RelativePathException Class | RelativePathException Members | Overload List


%%PageItemTitle%%

RelativePathException Class | RelativePathException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
A number that represents the reason you are creating this exception object.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

RelativePathException Constructor(Int32)

PegasusImaging.WinForms.OcrXpress1 Namespace > RelativePathException Class > RelativePathException Constructor : RelativePathException Constructor(Int32)

Initializes a new instance of the RelativePathException class.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public RelativePathException(
   int errorNumber
);
[C++]
public: RelativePathException(
   int errorNumber
)
[C++/CLI]
public:
RelativePathException(
   int errorNumber
)

Parameters

errorNumber
A number that represents the reason you are creating this exception object.

Requirements

Platforms: See Getting Started section

See Also

RelativePathException Class | RelativePathException Members | Overload List


%%PageItemTitle%%

RelativePathException Class | RelativePathException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
A number that represents the reason you are creating this exception object.
message
A string that describes the reason you are creating this exception object.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

RelativePathException Constructor(Int32,String)

PegasusImaging.WinForms.OcrXpress1 Namespace > RelativePathException Class > RelativePathException Constructor : RelativePathException Constructor(Int32,String)

Initializes a new instance of the RelativePathException class.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public RelativePathException(
   int errorNumber,
   string message
);
[C++]
public: RelativePathException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
RelativePathException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
A number that represents the reason you are creating this exception object.
message
A string that describes the reason you are creating this exception object.

Requirements

Platforms: See Getting Started section

See Also

RelativePathException Class | RelativePathException Members | Overload List


%%PageItemTitle%%

RelativePathException Class | RelativePathException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string that describes the reason you are creating this exception object.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

RelativePathException Constructor(String)

PegasusImaging.WinForms.OcrXpress1 Namespace > RelativePathException Class > RelativePathException Constructor : RelativePathException Constructor(String)

Initializes a new instance of the RelativePathException class.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public RelativePathException(
   string message
);
[C++]
public: RelativePathException(
   string* message
)
[C++/CLI]
public:
RelativePathException(
   String^ message
)

Parameters

message
A string that describes the reason you are creating this exception object.

Requirements

Platforms: See Getting Started section

See Also

RelativePathException Class | RelativePathException Members | Overload List


%%PageItemTitle%%

RelativePathException Class | RelativePathException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string that describes the reason you are creating this exception object.
innerException
The original exception that caused you to create this exception object.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

RelativePathException Constructor(String,Exception)

PegasusImaging.WinForms.OcrXpress1 Namespace > RelativePathException Class > RelativePathException Constructor : RelativePathException Constructor(String,Exception)

Initializes a new instance of the RelativePathException class.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public RelativePathException(
   string message,
   Exception innerException
);
[C++]
public: RelativePathException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
RelativePathException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string that describes the reason you are creating this exception object.
innerException
The original exception that caused you to create this exception object.

Requirements

Platforms: See Getting Started section

See Also

RelativePathException Class | RelativePathException Members | Overload List


%%PageItemTitle%%

TextBlockResult Members | PegasusImaging.WinForms.OcrXpress1 Namespace

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

TextBlockResult Class

PegasusImaging.WinForms.OcrXpress1 Namespace : TextBlockResult Class

An object that contains the area of a recognized text block (paragraph) and also provides access to the text lines within the text block.

For a list of all members of this type, see TextBlockResult members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.OcrXpress1.TextBlockResult

Syntax

[Visual Basic]
Public Class TextBlockResult
[C#]
public class TextBlockResult
[C++]
public __gc class TextBlockResult
[C++/CLI]
public ref class TextBlockResult

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

See Also

TextBlockResult Members | PegasusImaging.WinForms.OcrXpress1 Namespace

© 1997 - 2007, Pegasus Imaging Corporation, All Rights Reserved.

Last Modified:


%%PageItemTitle%% $$Members$$

TextBlockResult Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

TextBlockResult Class Members

PegasusImaging.WinForms.OcrXpress1 Namespace : TextBlockResult Class

TextBlockResult overview

Public Properties

Public Property Area | Gets the location of the result block within the image, in pixels, measured from the top left corner.
Public Property TextLineCount | Gets the number of text lines in the TextBlockResult.

Public Methods

Public Method GetTextLineResult Returns the TextLineResult at the index within its parent TextBlockResult.

See Also

TextBlockResult Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%%

TextBlockResult Class | TextBlockResult Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

index
The zero-based index for the TextLineResult. An InvalidIndexException will occur if the index less than 0 or greater or equal to the TextLineCount.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

GetTextLineResult Method

PegasusImaging.WinForms.OcrXpress1 Namespace > TextBlockResult Class : GetTextLineResult Method

Returns the TextLineResult at the index within its parent TextBlockResult.

[Visual Basic]
Public Function GetTextLineResult( _
   ByVal index As Integer _
) As TextLineResult
[C#]
public TextLineResult GetTextLineResult(
   int index
);
[C++]
public: TextLineResult* GetTextLineResult(
   int index
)
[C++/CLI]
public:
TextLineResult^ GetTextLineResult(
   int index
)

Parameters

index
The zero-based index for the TextLineResult. An InvalidIndexException will occur if the index less than 0 or greater or equal to the TextLineCount.

Return Type

The TextLineResult object at the specified index.

Remarks

This method allows you access to a TextLineResult, which provides the text and other detailed information about each result line.

Example

...

// Get text block result from the result object

PegasusImaging.WinForms.OcrXpress1.TextBlockResult aResult = result.GetTextBlockResult(i);

// Get the TextLineCount from the TextBlockResult and loop through to get the text line results

PegasusImaging.WinForms.OcrXpress1.TextLineResult lineResult = aResult.GetTextLineResult(j);

...

Requirements

Platforms: See Getting Started section

See Also

TextBlockResult Class | TextBlockResult Members


%%PageItemTitle%% $$Properties$$

TextBlockResult Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

TextBlockResult Class Properties

PegasusImaging.WinForms.OcrXpress1 Namespace : TextBlockResult Class

For a list of all members of this type, see TextBlockResult members.

Public Properties

Public Property Area | Gets the location of the result block within the image, in pixels, measured from the top left corner.
Public Property TextLineCount | Gets the number of text lines in the TextBlockResult.

See Also

TextBlockResult Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%%

TextBlockResult Class | TextBlockResult Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

Area Property

PegasusImaging.WinForms.OcrXpress1 Namespace > TextBlockResult Class : Area Property (TextBlockResult)

Gets the location of the result block within the image, in pixels, measured from the top left corner.

[Visual Basic]
Public ReadOnly Property Area As Rectangle
[C#]
public Rectangle Area {get;}
[C++]
public: __property Rectangle get_Area();
[C++/CLI]
public:
property Rectangle Area {
   Rectangle get();
}

Return Type

A Rectangle object which contains the area coordinates.

Remarks

This property contains the location of the result block. The pixel at the top left corner of the image is at (0, 0). Values of X increase as you move to the right on the image and values of Y increase as you move down the image.

Requirements

Platforms: See Getting Started section

See Also

TextBlockResult Class | TextBlockResult Members


%%PageItemTitle%%

TextBlockResult Class | TextBlockResult Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

TextLineCount Property

PegasusImaging.WinForms.OcrXpress1 Namespace > TextBlockResult Class : TextLineCount Property

Gets the number of text lines in the TextBlockResult.

[Visual Basic]
Public ReadOnly Property TextLineCount As Integer
[C#]
public int TextLineCount {get;}
[C++]
public: __property int get_TextLineCount();
[C++/CLI]
public:
property int TextLineCount {
   int get();
}

Remarks

This read-only property contains the number of text lines in the current TextBlockResult.

Example

...

// Get the TextBlockResult from the Result object

PegasusImaging.WinForms.OcrXpress1.TextBlockResult aResult = result.GetTextBlockResult(i);

// Get the TextLineCount from the TextBlockResult

int tlCnt = aResult.TextLineCount;

...

Requirements

Platforms: See Getting Started section

See Also

TextBlockResult Class | TextBlockResult Members


%%PageItemTitle%%

TextLineResult Members | PegasusImaging.WinForms.OcrXpress1 Namespace

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

TextLineResult Class

PegasusImaging.WinForms.OcrXpress1 Namespace : TextLineResult Class

An object that contains the recognition results for a single text line. Multiple text lines can be contained in a TextBlockResult.

For a list of all members of this type, see TextLineResult members.

Object Model

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.OcrXpress1.TextLineResult

Syntax

[Visual Basic]
Public Class TextLineResult
[C#]
public class TextLineResult
[C++]
public __gc class TextLineResult
[C++/CLI]
public ref class TextLineResult

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

See Also

TextLineResult Members | PegasusImaging.WinForms.OcrXpress1 Namespace

© 1997 - 2007, Pegasus Imaging Corporation, All Rights Reserved.

Last Modified:


%%PageItemTitle%% $$Members$$

TextLineResult Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

TextLineResult Class Members

PegasusImaging.WinForms.OcrXpress1 Namespace : TextLineResult Class

TextLineResult overview

Public Properties

Public Property Area | Gets the location of the result line within the image, in pixels, measured from the top left corner.
Public Property FontMapCount | The number of FontMap objects in this TextLineResult.
Public Property SuspectCharacterCount | The number of suspect characters in this TextLineResult.
Public Property Text | Gets and sets the string value this TextLineResult object represents.

Public Methods

Public Method GetFontMap | The FontMap at the given index.
Public Method GetSuspectCharacter | The CharacterResult at the given index.

See Also

TextLineResult Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%%

TextLineResult Class | TextLineResult Members | FontMapCount Property

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

index
The zero-based index of the FontMap being requested.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

GetFontMap Method

PegasusImaging.WinForms.OcrXpress1 Namespace > TextLineResult Class : GetFontMap Method

The FontMap at the given index.

[Visual Basic]
Public Function GetFontMap( _
   ByVal index As Integer _
) As FontMap
[C#]
public FontMap GetFontMap(
   int index
);
[C++]
public: FontMap* GetFontMap(
   int index
)
[C++/CLI]
public:
FontMap^ GetFontMap(
   int index
)

Parameters

index
The zero-based index of the FontMap being requested.

Return Type

The FontMap at the given index.

Remarks

A FontMap describes the size, style and family of the font used by a specific run of characters in a text line result.

Example

...

// Get the TextLineResult from the TextBlockResult object

PegasusImaging.WinForms.OcrXpress1.TextLineResult tlResult = tblkResult.GetTextLineResult(i);

// Get the Font Map from the TextLineResult passing in the index

PegasusImaging.WinForms.OcrXpress1.FontMap fontMap = tlResult.GetFontMap(k);

...

Requirements

Platforms: See Getting Started section

See Also

TextLineResult Class | TextLineResult Members | FontMapCount Property


%%PageItemTitle%%

TextLineResult Class | TextLineResult Members | SuspectCharacterCount Property

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

index
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

GetSuspectCharacter Method

PegasusImaging.WinForms.OcrXpress1 Namespace > TextLineResult Class : GetSuspectCharacter Method

The CharacterResult at the given index.

[Visual Basic]
Public Function GetSuspectCharacter( _
   ByVal index As Integer _
) As CharacterResult
[C#]
public CharacterResult GetSuspectCharacter(
   int index
);
[C++]
public: CharacterResult* GetSuspectCharacter(
   int index
)
[C++/CLI]
public:
CharacterResult^ GetSuspectCharacter(
   int index
)

Parameters

index

Remarks

A CharacterResult object identifies a single character that recognition was unable to read, or which it read with low confidence.

This property allows you to access any suspect character within a TextLineResult and optionally replace it with a new string by setting the CharacterResult.Text property of the CharacterResult object returned by this method.

Example

...

// Get the TextLineResult from the TextBlockResult object

PegasusImaging.WinForms.OcrXpress1.TextLineResult tlResult = tblkResult.GetTextLineResult(i);

// Get the SuspectCharacter from the TextLineResult passing in the index

PegasusImaging.WinForms.OcrXpress1.SuspectCharacter susChar = tlResult.GetSuspectCharacter(k);

...

Requirements

Platforms: See Getting Started section

See Also

TextLineResult Class | TextLineResult Members | SuspectCharacterCount Property


%%PageItemTitle%% $$Properties$$

TextLineResult Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

TextLineResult Class Properties

PegasusImaging.WinForms.OcrXpress1 Namespace : TextLineResult Class

For a list of all members of this type, see TextLineResult members.

Public Properties

Public Property Area | Gets the location of the result line within the image, in pixels, measured from the top left corner.
Public Property FontMapCount | The number of FontMap objects in this TextLineResult.
Public Property SuspectCharacterCount | The number of suspect characters in this TextLineResult.
Public Property Text | Gets and sets the string value this TextLineResult object represents.

See Also

TextLineResult Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%%

TextLineResult Class | TextLineResult Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

Area Property

PegasusImaging.WinForms.OcrXpress1 Namespace > TextLineResult Class : Area Property (TextLineResult)

Gets the location of the result line within the image, in pixels, measured from the top left corner.

[Visual Basic]
Public ReadOnly Property Area As Rectangle
[C#]
public Rectangle Area {get;}
[C++]
public: __property Rectangle get_Area();
[C++/CLI]
public:
property Rectangle Area {
   Rectangle get();
}

Return Type

A Rectangle object which contains the area coordinates.

Remarks

This property contains the location of the result line. The pixel at the top left corner of the image is at (0, 0). Values of X increase as you move to the right on the image and values of Y increase as you move down the image.

Example

...

// Get the TextLineResult from the TextBlockResult object

PegasusImaging.WinForms.OcrXpress1.TextLineResult tlResult = tblkResult.GetTextLineResult(i);

// Get the Text from the TextLineResult

tlResult.Text;

...

Requirements

Platforms: See Getting Started section

See Also

TextLineResult Class | TextLineResult Members


%%PageItemTitle%%

TextLineResult Class | TextLineResult Members | FontMap Class

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

FontMapCount Property

PegasusImaging.WinForms.OcrXpress1 Namespace > TextLineResult Class : FontMapCount Property

The number of FontMap objects in this TextLineResult.

[Visual Basic]
Public ReadOnly Property FontMapCount As Integer
[C#]
public int FontMapCount {get;}
[C++]
public: __property int get_FontMapCount();
[C++/CLI]
public:
property int FontMapCount {
   int get();
}

Remarks

A FontMap describes the size, style and family of the font used by a specific run of characters in a text line result.

Example

...

// Get the TextLineResult from the TextBlockResult object

PegasusImaging.WinForms.OcrXpress1.TextLineResult tlResult = tblkResult.GetTextLineResult(i);

// Get the FontMapCount from the TextLineResult

int fmCnt = tlResult.FontMapCount;

...

Requirements

Platforms: See Getting Started section

See Also

TextLineResult Class | TextLineResult Members | FontMap Class


%%PageItemTitle%%

TextLineResult Class | TextLineResult Members | CharacterResult Class

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

SuspectCharacterCount Property

PegasusImaging.WinForms.OcrXpress1 Namespace > TextLineResult Class : SuspectCharacterCount Property

The number of suspect characters in this TextLineResult.

[Visual Basic]
Public ReadOnly Property SuspectCharacterCount As Integer
[C#]
public int SuspectCharacterCount {get;}
[C++]
public: __property int get_SuspectCharacterCount();
[C++/CLI]
public:
property int SuspectCharacterCount {
   int get();
}

Remarks

A suspect character is a single character that recognition was unable to read, or which it read with low confidence.

Example

...

// Get the TextLineResult from the TextBlockResult object

PegasusImaging.WinForms.OcrXpress1.TextLineResult tlResult = tblkResult.GetTextLineResult(i);

// Get the SuspectCharacterCount from the TextLineResult

int susCharCnt = tlResult.SuspectCharacterCount;

...

Requirements

Platforms: See Getting Started section

See Also

TextLineResult Class | TextLineResult Members | CharacterResult Class


%%PageItemTitle%%

TextLineResult Class | TextLineResult Members | Text Property | SuspectCharacterCount Property

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

Text Property

PegasusImaging.WinForms.OcrXpress1 Namespace > TextLineResult Class : Text Property (TextLineResult)

Gets and sets the string value this TextLineResult object represents.

[Visual Basic]
Public Property Text As String
[C#]
public string Text {get; set;}
[C++]
public: __property string* get_Text();
public: __property void set_Text(
   string* value
);
[C++/CLI]
public:
property String^ Text {
   String^ get();
   void set (String^ value);
}

Return Type

A string value which represents the text line result.

Remarks

This property will return the string represented by this TextLineResult object.

Setting this property will replace the existing text line. As a result, all suspect character information will be deleted and SuspectCharacterCount will be set to 0.

Care should be used when setting this property, as changing the line length significantly may alter the appearance of the line when exported to certain formats. The corrected text will be used if the results are exported with Export.

Requirements

Platforms: See Getting Started section

See Also

TextLineResult Class | TextLineResult Members | Text Property | SuspectCharacterCount Property


%%PageItemTitle%%

TextRegion Members | PegasusImaging.WinForms.OcrXpress1 Namespace

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

TextRegion Class

PegasusImaging.WinForms.OcrXpress1 Namespace : TextRegion Class

This object defines a rectangular area of a page's image as a text region.

For a list of all members of this type, see TextRegion members.

Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.OcrXpress1.Region
PegasusImaging.WinForms.OcrXpress1.TextRegion

Syntax

[Visual Basic]
Public Class TextRegion
   Inherits Region
[C#]
public class TextRegion : Region
[C++]
public __gc class TextRegion : public Region
[C++/CLI]
public ref class TextRegion : public Region

Remarks

A text region simply defines where the recognition engine will attempt to read text. There can be one to many text regions defined for a single page.

OcrXpress can automatically detect regions of text for a page using the Locate method. You can also modify and add regions yourself by using the SetRegions method.

If no text regions exist for a page that is passed to Recognize, the Locate method will be called internally before recognition is started. It is acceptable to omit the call to Locate, and only call Recognize to simplify your code.

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

See Also

TextRegion Members | PegasusImaging.WinForms.OcrXpress1 Namespace

© 1997 - 2007, Pegasus Imaging Corporation, All Rights Reserved.

Last Modified:


%%PageItemTitle%% $$Members$$

TextRegion Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

TextRegion Class Members

PegasusImaging.WinForms.OcrXpress1 Namespace : TextRegion Class

TextRegion overview

Public Constructors

Public Constructor TextRegion Constructor Overloaded. Defines a region of text within the image.

Public Properties

Public Property Area (Inherited from Region) | The image area of the region (in pixels measured from the top left corner.)
Public Property InverseText | Gets and sets a value indicating whether this TextRegion contains inverse (white on black) text.
Public Property IsNumeric | Gets and sets a value indicating whether the preference of this text region is numeric.

See Also

TextRegion Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%%

TextRegion Class | TextRegion Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

TextRegion Constructor

PegasusImaging.WinForms.OcrXpress1 Namespace > TextRegion Class : TextRegion Constructor (TextRegion)

Defines a region of text within the image.

Overload List

Defines a region of text within the image.

[Visual Basic] Public Sub New()

[C#] public TextRegion();

[C++] public TextRegion();

[C++/CLI] public TextRegion();

Defines a region of text within the image.

[Visual Basic] Public Sub New(Rectangle)

[C#] public TextRegion(Rectangle);

[C++] public TextRegion(Rectangle);

[C++/CLI] public TextRegion(Rectangle);

Defines a region of text within the image.

[Visual Basic] Public Sub New(Rectangle,Boolean,Boolean)

[C#] public TextRegion(Rectangle,bool,bool);

[C++] public TextRegion(Rectangle,bool,bool);

[C++/CLI] public TextRegion(Rectangle,bool,bool);

Remarks

If the default constructor is used to create a TextRegion object, the Area property must be set prior to calling SetRegions, else an invalid area exception will be thrown.

Requirements

Platforms: See Getting Started section

See Also

TextRegion Class | TextRegion Members


%%PageItemTitle%%

TextRegion Class | TextRegion Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

TextRegion Constructor()

PegasusImaging.WinForms.OcrXpress1 Namespace > TextRegion Class > TextRegion Constructor : TextRegion Constructor()

Defines a region of text within the image.

[Visual Basic]
Public Function New()
[C#]
public TextRegion();
[C++]
public: TextRegion();
[C++/CLI]
public:
TextRegion();

Remarks

If the default constructor is used to create a TextRegion object, the Area property must be set prior to calling SetRegions, else an invalid area exception will be thrown.

Requirements

Platforms: See Getting Started section

See Also

TextRegion Class | TextRegion Members | Overload List


%%PageItemTitle%%

TextRegion Class | TextRegion Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

regionArea
The coordinates of the text region within the image.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

TextRegion Constructor(Rectangle)

PegasusImaging.WinForms.OcrXpress1 Namespace > TextRegion Class > TextRegion Constructor : TextRegion Constructor(Rectangle)

Defines a region of text within the image.

[Visual Basic]
Public Function New( _
   ByVal regionArea As Rectangle _
)
[C#]
public TextRegion(
   Rectangle regionArea
);
[C++]
public: TextRegion(
   Rectangle regionArea
)
[C++/CLI]
public:
TextRegion(
   Rectangle regionArea
)

Parameters

regionArea
The coordinates of the text region within the image.

Remarks

This overloaded constructor will set the Area of the text region.

Example

[C#]

...
    // get the region collection
    PegasusImaging.WinForms.OcrXpress1.RegionCollection myRegions = Page.GetRegions();

    // add a text region to the collection passing in the rectangular area coordinates
        myRegions.Add(
            new PegasusImaging.WinForms.OcrXpress1.TextRegion(
                new System.Drawing.Rectangle(290,1300,1660,50)
                    )

                    ...

Requirements

Platforms: See Getting Started section

See Also

TextRegion Class | TextRegion Members | Overload List


%%PageItemTitle%%

TextRegion Class | TextRegion Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

regionArea
The coordinates of the text region within the image.
isNumeric
Gives the text region a numeric preference.
inverseText
Indicates the text region contains inverse (white on black) text.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

TextRegion Constructor(Rectangle,Boolean,Boolean)

PegasusImaging.WinForms.OcrXpress1 Namespace > TextRegion Class > TextRegion Constructor : TextRegion Constructor(Rectangle,Boolean,Boolean)

Defines a region of text within the image.

[Visual Basic]
Public Function New( _
   ByVal regionArea As Rectangle, _
   ByVal isNumeric As Boolean, _
   ByVal inverseText As Boolean _
)
[C#]
public TextRegion(
   Rectangle regionArea,
   bool isNumeric,
   bool inverseText
);
[C++]
public: TextRegion(
   Rectangle regionArea,
   bool isNumeric,
   bool inverseText
)
[C++/CLI]
public:
TextRegion(
   Rectangle regionArea,
   bool isNumeric,
   bool inverseText
)

Parameters

regionArea
The coordinates of the text region within the image.
isNumeric
Gives the text region a numeric preference.
inverseText
Indicates the text region contains inverse (white on black) text.

Remarks

This overloaded constructor will set the Area of the text region, as well as the IsNumeric and InverseText properties.

Example

[C#]

...
    // get the region collection
    PegasusImaging.WinForms.OcrXpress1.RegionCollection myRegions = Page.GetRegions();

    // add a text region to the collection passing in the rectangular area coordinates
        myRegions.Add(
            new PegasusImaging.WinForms.OcrXpress1.TextRegion(
                new System.Drawing.Rectangle(290,1300,1660,50), true, false
                    )

                    ...

Requirements

Platforms: See Getting Started section

See Also

TextRegion Class | TextRegion Members | Overload List


%%PageItemTitle%% $$Properties$$

TextRegion Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

TextRegion Class Properties

PegasusImaging.WinForms.OcrXpress1 Namespace : TextRegion Class

For a list of all members of this type, see TextRegion members.

Public Properties

Public Property Area (Inherited from Region) | The image area of the region (in pixels measured from the top left corner.)
Public Property InverseText | Gets and sets a value indicating whether this TextRegion contains inverse (white on black) text.
Public Property IsNumeric | Gets and sets a value indicating whether the preference of this text region is numeric.

See Also

TextRegion Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%%

TextRegion Class | TextRegion Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

InverseText Property

PegasusImaging.WinForms.OcrXpress1 Namespace > TextRegion Class : InverseText Property

Gets and sets a value indicating whether this TextRegion contains inverse (white on black) text.

[Visual Basic]
Public Property InverseText As Boolean
[C#]
public bool InverseText {get; set;}
[C++]
public: __property bool get_InverseText();
public: __property void set_InverseText(
   bool value
);
[C++/CLI]
public:
property bool InverseText {
   bool get();
   void set (bool value);
}

Remarks

When this property is true, the TextRegion is identified as having white text on a black background. For this type of TextRegion, the recognition engine will invert (correct) this region prior to reading.

If false, the TextRegion contains normal (black on white) text.

If this TextRegion was returned as a result Locate method, this property will be set automatically to the correct value.

Default Value: false

Requirements

Platforms: See Getting Started section

See Also

TextRegion Class | TextRegion Members


%%PageItemTitle%%

TextRegion Class | TextRegion Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

IsNumeric Property

PegasusImaging.WinForms.OcrXpress1 Namespace > TextRegion Class : IsNumeric Property

Gets and sets a value indicating whether the preference of this text region is numeric.

[Visual Basic]
Public Property IsNumeric As Boolean
[C#]
public bool IsNumeric {get; set;}
[C++]
public: __property bool get_IsNumeric();
public: __property void set_IsNumeric(
   bool value
);
[C++/CLI]
public:
property bool IsNumeric {
   bool get();
   void set (bool value);
}

Remarks

When this property is true, the recognition process will attempt to convert any words not recognized, to a number value if possible. For example, "LGO" would be recognized as "160".

This property does not gaurantee that the recognition results of this text region will be numeric. However, if you know in advance a text region will only contain numbers, you should set this property to true for that text region.

If a region may contain both letters and numbers, you should set this property to false.

Default Value: false

Requirements

Platforms: See Getting Started section

See Also

TextRegion Class | TextRegion Members


%%PageItemTitle%%

TextTooLongException Members | PegasusImaging.WinForms.OcrXpress1 Namespace

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

TextTooLongException Class

PegasusImaging.WinForms.OcrXpress1 Namespace : TextTooLongException Class

An exception object that the TextLineResult object will throw if the input text to replace an existing text line result is longer than 1024 characters.

For a list of all members of this type, see TextTooLongException members.

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.OcrXpress1.OcrXpressException
PegasusImaging.WinForms.OcrXpress1.TextTooLongException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class TextTooLongException
   Inherits OcrXpressException
[C#]
[SerializableAttribute()]
public sealed class TextTooLongException : OcrXpressException
[C++]
[SerializableAttribute()]
public __gc __sealed class TextTooLongException : public OcrXpressException
[C++/CLI]
[SerializableAttribute()]
public ref class TextTooLongException sealed : public OcrXpressException

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

See Also

TextTooLongException Members | PegasusImaging.WinForms.OcrXpress1 Namespace

© 1997 - 2007, Pegasus Imaging Corporation, All Rights Reserved.

Last Modified:


%%PageItemTitle%% $$Members$$

TextTooLongException Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

TextTooLongException Class Members

PegasusImaging.WinForms.OcrXpress1 Namespace : TextTooLongException Class

TextTooLongException overview

Public Constructors

Public Constructor TextTooLongException Constructor Overloaded. Initializes a new instance of the TextTooLongException class.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from OcrXpressException) | The number of the error.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

TextTooLongException Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%%

TextTooLongException Class | TextTooLongException Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

TextTooLongException Constructor

PegasusImaging.WinForms.OcrXpress1 Namespace > TextTooLongException Class : TextTooLongException Constructor (TextTooLongException)

Initializes a new instance of the TextTooLongException class.

Overload List

Initializes a new instance of the TextTooLongException class.

[Visual Basic] Public Sub New()

[C#] public TextTooLongException();

[C++] public TextTooLongException();

[C++/CLI] public TextTooLongException();

Initializes a new instance of the TextTooLongException class.

[Visual Basic] Public Sub New(Integer)

[C#] public TextTooLongException(int);

[C++] public TextTooLongException(int);

[C++/CLI] public TextTooLongException(int);

Initializes a new instance of the TextTooLongException class.

[Visual Basic] Public Sub New(String)

[C#] public TextTooLongException(string);

[C++] public TextTooLongException(string*);

[C++/CLI] public TextTooLongException(String^);

Initializes a new instance of the TextTooLongException class.

[Visual Basic] Public Sub New(Integer,String)

[C#] public TextTooLongException(int,string);

[C++] public TextTooLongException(int,string*);

[C++/CLI] public TextTooLongException(int,String^);

Initializes a new instance of the TextTooLongException class.

[Visual Basic] Public Sub New(String,Exception)

[C#] public TextTooLongException(string,Exception);

[C++] public TextTooLongException(string*,Exception*);

[C++/CLI] public TextTooLongException(String^,Exception^);

Requirements

Platforms: See Getting Started section

See Also

TextTooLongException Class | TextTooLongException Members


%%PageItemTitle%%

TextTooLongException Class | TextTooLongException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

TextTooLongException Constructor()

PegasusImaging.WinForms.OcrXpress1 Namespace > TextTooLongException Class > TextTooLongException Constructor : TextTooLongException Constructor()

Initializes a new instance of the TextTooLongException class.

[Visual Basic]
Public Function New()
[C#]
public TextTooLongException();
[C++]
public: TextTooLongException();
[C++/CLI]
public:
TextTooLongException();

Requirements

Platforms: See Getting Started section

See Also

TextTooLongException Class | TextTooLongException Members | Overload List


%%PageItemTitle%%

TextTooLongException Class | TextTooLongException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
A number that represents the reason you are creating this exception object.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

TextTooLongException Constructor(Int32)

PegasusImaging.WinForms.OcrXpress1 Namespace > TextTooLongException Class > TextTooLongException Constructor : TextTooLongException Constructor(Int32)

Initializes a new instance of the TextTooLongException class.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public TextTooLongException(
   int errorNumber
);
[C++]
public: TextTooLongException(
   int errorNumber
)
[C++/CLI]
public:
TextTooLongException(
   int errorNumber
)

Parameters

errorNumber
A number that represents the reason you are creating this exception object.

Requirements

Platforms: See Getting Started section

See Also

TextTooLongException Class | TextTooLongException Members | Overload List


%%PageItemTitle%%

TextTooLongException Class | TextTooLongException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
A number that represents the reason you are creating this exception object.
message
A string that describes the reason you are creating this exception object.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

TextTooLongException Constructor(Int32,String)

PegasusImaging.WinForms.OcrXpress1 Namespace > TextTooLongException Class > TextTooLongException Constructor : TextTooLongException Constructor(Int32,String)

Initializes a new instance of the TextTooLongException class.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public TextTooLongException(
   int errorNumber,
   string message
);
[C++]
public: TextTooLongException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
TextTooLongException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
A number that represents the reason you are creating this exception object.
message
A string that describes the reason you are creating this exception object.

Requirements

Platforms: See Getting Started section

See Also

TextTooLongException Class | TextTooLongException Members | Overload List


%%PageItemTitle%%

TextTooLongException Class | TextTooLongException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string that describes the reason you are creating this exception object.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

TextTooLongException Constructor(String)

PegasusImaging.WinForms.OcrXpress1 Namespace > TextTooLongException Class > TextTooLongException Constructor : TextTooLongException Constructor(String)

Initializes a new instance of the TextTooLongException class.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public TextTooLongException(
   string message
);
[C++]
public: TextTooLongException(
   string* message
)
[C++/CLI]
public:
TextTooLongException(
   String^ message
)

Parameters

message
A string that describes the reason you are creating this exception object.

Requirements

Platforms: See Getting Started section

See Also

TextTooLongException Class | TextTooLongException Members | Overload List


%%PageItemTitle%%

TextTooLongException Class | TextTooLongException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string that describes the reason you are creating this exception object.
innerException
The original exception that caused you to create this exception object.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

TextTooLongException Constructor(String,Exception)

PegasusImaging.WinForms.OcrXpress1 Namespace > TextTooLongException Class > TextTooLongException Constructor : TextTooLongException Constructor(String,Exception)

Initializes a new instance of the TextTooLongException class.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public TextTooLongException(
   string message,
   Exception innerException
);
[C++]
public: TextTooLongException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
TextTooLongException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string that describes the reason you are creating this exception object.
innerException
The original exception that caused you to create this exception object.

Requirements

Platforms: See Getting Started section

See Also

TextTooLongException Class | TextTooLongException Members | Overload List


%%PageItemTitle%%

TimeoutErrorException Members | PegasusImaging.WinForms.OcrXpress1 Namespace

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

TimeoutErrorException Class

PegasusImaging.WinForms.OcrXpress1 Namespace : TimeoutErrorException Class

An exception object that this component will throw whenever the OcrXpress instance has timed out for current trial period.

For a list of all members of this type, see TimeoutErrorException members.

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.OcrXpress1.OcrXpressException
PegasusImaging.WinForms.OcrXpress1.TimeoutErrorException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class TimeoutErrorException
   Inherits OcrXpressException
[C#]
[SerializableAttribute()]
public sealed class TimeoutErrorException : OcrXpressException
[C++]
[SerializableAttribute()]
public __gc __sealed class TimeoutErrorException : public OcrXpressException
[C++/CLI]
[SerializableAttribute()]
public ref class TimeoutErrorException sealed : public OcrXpressException

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

See Also

TimeoutErrorException Members | PegasusImaging.WinForms.OcrXpress1 Namespace

© 1997 - 2007, Pegasus Imaging Corporation, All Rights Reserved.

Last Modified:


%%PageItemTitle%% $$Members$$

TimeoutErrorException Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

TimeoutErrorException Class Members

PegasusImaging.WinForms.OcrXpress1 Namespace : TimeoutErrorException Class

TimeoutErrorException overview

Public Constructors

Public Constructor TimeoutErrorException Constructor Overloaded. Initializes a new instance of the TimeoutErrorException class.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from OcrXpressException) | The number of the error.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

TimeoutErrorException Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%%

TimeoutErrorException Class | TimeoutErrorException Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

TimeoutErrorException Constructor

PegasusImaging.WinForms.OcrXpress1 Namespace > TimeoutErrorException Class : TimeoutErrorException Constructor (TimeoutErrorException)

Initializes a new instance of the TimeoutErrorException class.

Overload List

Initializes a new instance of the TimeoutErrorException class.

[Visual Basic] Public Sub New()

[C#] public TimeoutErrorException();

[C++] public TimeoutErrorException();

[C++/CLI] public TimeoutErrorException();

Initializes a new instance of the TimeoutErrorException class.

[Visual Basic] Public Sub New(Integer)

[C#] public TimeoutErrorException(int);

[C++] public TimeoutErrorException(int);

[C++/CLI] public TimeoutErrorException(int);

Initializes a new instance of the TimeoutErrorException class.

[Visual Basic] Public Sub New(String)

[C#] public TimeoutErrorException(string);

[C++] public TimeoutErrorException(string*);

[C++/CLI] public TimeoutErrorException(String^);

Initializes a new instance of the TimeoutErrorException class.

[Visual Basic] Public Sub New(Integer,String)

[C#] public TimeoutErrorException(int,string);

[C++] public TimeoutErrorException(int,string*);

[C++/CLI] public TimeoutErrorException(int,String^);

Initializes a new instance of the TimeoutErrorException class.

[Visual Basic] Public Sub New(String,Exception)

[C#] public TimeoutErrorException(string,Exception);

[C++] public TimeoutErrorException(string*,Exception*);

[C++/CLI] public TimeoutErrorException(String^,Exception^);

Requirements

Platforms: See Getting Started section

See Also

TimeoutErrorException Class | TimeoutErrorException Members


%%PageItemTitle%%

TimeoutErrorException Class | TimeoutErrorException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

TimeoutErrorException Constructor()

PegasusImaging.WinForms.OcrXpress1 Namespace > TimeoutErrorException Class > TimeoutErrorException Constructor : TimeoutErrorException Constructor()

Initializes a new instance of the TimeoutErrorException class.

[Visual Basic]
Public Function New()
[C#]
public TimeoutErrorException();
[C++]
public: TimeoutErrorException();
[C++/CLI]
public:
TimeoutErrorException();

Requirements

Platforms: See Getting Started section

See Also

TimeoutErrorException Class | TimeoutErrorException Members | Overload List


%%PageItemTitle%%

TimeoutErrorException Class | TimeoutErrorException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

TimeoutErrorException Constructor(Int32)

PegasusImaging.WinForms.OcrXpress1 Namespace > TimeoutErrorException Class > TimeoutErrorException Constructor : TimeoutErrorException Constructor(Int32)

Initializes a new instance of the TimeoutErrorException class.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public TimeoutErrorException(
   int errorNumber
);
[C++]
public: TimeoutErrorException(
   int errorNumber
)
[C++/CLI]
public:
TimeoutErrorException(
   int errorNumber
)

Parameters

errorNumber

Requirements

Platforms: See Getting Started section

See Also

TimeoutErrorException Class | TimeoutErrorException Members | Overload List


%%PageItemTitle%%

TimeoutErrorException Class | TimeoutErrorException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
message
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

TimeoutErrorException Constructor(Int32,String)

PegasusImaging.WinForms.OcrXpress1 Namespace > TimeoutErrorException Class > TimeoutErrorException Constructor : TimeoutErrorException Constructor(Int32,String)

Initializes a new instance of the TimeoutErrorException class.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public TimeoutErrorException(
   int errorNumber,
   string message
);
[C++]
public: TimeoutErrorException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
TimeoutErrorException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
message

Requirements

Platforms: See Getting Started section

See Also

TimeoutErrorException Class | TimeoutErrorException Members | Overload List


%%PageItemTitle%%

TimeoutErrorException Class | TimeoutErrorException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

TimeoutErrorException Constructor(String)

PegasusImaging.WinForms.OcrXpress1 Namespace > TimeoutErrorException Class > TimeoutErrorException Constructor : TimeoutErrorException Constructor(String)

Initializes a new instance of the TimeoutErrorException class.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public TimeoutErrorException(
   string message
);
[C++]
public: TimeoutErrorException(
   string* message
)
[C++/CLI]
public:
TimeoutErrorException(
   String^ message
)

Parameters

message

Requirements

Platforms: See Getting Started section

See Also

TimeoutErrorException Class | TimeoutErrorException Members | Overload List


%%PageItemTitle%%

TimeoutErrorException Class | TimeoutErrorException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
innerException
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

TimeoutErrorException Constructor(String,Exception)

PegasusImaging.WinForms.OcrXpress1 Namespace > TimeoutErrorException Class > TimeoutErrorException Constructor : TimeoutErrorException Constructor(String,Exception)

Initializes a new instance of the TimeoutErrorException class.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public TimeoutErrorException(
   string message,
   Exception innerException
);
[C++]
public: TimeoutErrorException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
TimeoutErrorException(
   String^ message,
   Exception^ innerException
)

Parameters

message
innerException

Requirements

Platforms: See Getting Started section

See Also

TimeoutErrorException Class | TimeoutErrorException Members | Overload List


%%PageItemTitle%%

UnsupportedImageFormatException Members | PegasusImaging.WinForms.OcrXpress1 Namespace

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Requirements Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

UnsupportedImageFormatException Class

PegasusImaging.WinForms.OcrXpress1 Namespace : UnsupportedImageFormatException Class

An exception object that the Page object will throw whenever you try to pass in an image with a bit count that this component does not support.

For a list of all members of this type, see UnsupportedImageFormatException members.

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
PegasusImaging.WinForms.OcrXpress1.OcrXpressException
PegasusImaging.WinForms.OcrXpress1.UnsupportedImageFormatException

Syntax

[Visual Basic]
<SerializableAttribute()>
Public NotInheritable Class UnsupportedImageFormatException
   Inherits OcrXpressException
[C#]
[SerializableAttribute()]
public sealed class UnsupportedImageFormatException : OcrXpressException
[C++]
[SerializableAttribute()]
public __gc __sealed class UnsupportedImageFormatException : public OcrXpressException
[C++/CLI]
[SerializableAttribute()]
public ref class UnsupportedImageFormatException sealed : public OcrXpressException

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

See Also

UnsupportedImageFormatException Members | PegasusImaging.WinForms.OcrXpress1 Namespace

© 1997 - 2007, Pegasus Imaging Corporation, All Rights Reserved.

Last Modified:


%%PageItemTitle%% $$Members$$

UnsupportedImageFormatException Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

UnsupportedImageFormatException Class Members

PegasusImaging.WinForms.OcrXpress1 Namespace : UnsupportedImageFormatException Class

UnsupportedImageFormatException overview

Public Constructors

Public Constructor UnsupportedImageFormatException Constructor Overloaded. Initializes a new instance of the UnsupportedImageFormatException class.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from OcrXpressException) | The number of the error.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

UnsupportedImageFormatException Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%%

UnsupportedImageFormatException Class | UnsupportedImageFormatException Members

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

UnsupportedImageFormatException Constructor

PegasusImaging.WinForms.OcrXpress1 Namespace > UnsupportedImageFormatException Class : UnsupportedImageFormatException Constructor (UnsupportedImageFormatException)

Initializes a new instance of the UnsupportedImageFormatException class.

Overload List

Initializes a new instance of the UnsupportedImageFormatException class.

[Visual Basic] Public Sub New()

[C#] public UnsupportedImageFormatException();

[C++] public UnsupportedImageFormatException();

[C++/CLI] public UnsupportedImageFormatException();

Initializes a new instance of the UnsupportedImageFormatException class.

[Visual Basic] Public Sub New(Integer)

[C#] public UnsupportedImageFormatException(int);

[C++] public UnsupportedImageFormatException(int);

[C++/CLI] public UnsupportedImageFormatException(int);

Initializes a new instance of the UnsupportedImageFormatException class.

[Visual Basic] Public Sub New(String)

[C#] public UnsupportedImageFormatException(string);

[C++] public UnsupportedImageFormatException(string*);

[C++/CLI] public UnsupportedImageFormatException(String^);

Initializes a new instance of the UnsupportedImageFormatException class.

[Visual Basic] Public Sub New(Integer,String)

[C#] public UnsupportedImageFormatException(int,string);

[C++] public UnsupportedImageFormatException(int,string*);

[C++/CLI] public UnsupportedImageFormatException(int,String^);

Initializes a new instance of the UnsupportedImageFormatException class.

[Visual Basic] Public Sub New(String,Exception)

[C#] public UnsupportedImageFormatException(string,Exception);

[C++] public UnsupportedImageFormatException(string*,Exception*);

[C++/CLI] public UnsupportedImageFormatException(String^,Exception^);

Requirements

Platforms: See Getting Started section

See Also

UnsupportedImageFormatException Class | UnsupportedImageFormatException Members


%%PageItemTitle%%

UnsupportedImageFormatException Class | UnsupportedImageFormatException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

UnsupportedImageFormatException Constructor()

PegasusImaging.WinForms.OcrXpress1 Namespace > UnsupportedImageFormatException Class > UnsupportedImageFormatException Constructor : UnsupportedImageFormatException Constructor()

Initializes a new instance of the UnsupportedImageFormatException class.

[Visual Basic]
Public Function New()
[C#]
public UnsupportedImageFormatException();
[C++]
public: UnsupportedImageFormatException();
[C++/CLI]
public:
UnsupportedImageFormatException();

Requirements

Platforms: See Getting Started section

See Also

UnsupportedImageFormatException Class | UnsupportedImageFormatException Members | Overload List


%%PageItemTitle%%

UnsupportedImageFormatException Class | UnsupportedImageFormatException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
A number that represents the reason you are creating this exception object.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

UnsupportedImageFormatException Constructor(Int32)

PegasusImaging.WinForms.OcrXpress1 Namespace > UnsupportedImageFormatException Class > UnsupportedImageFormatException Constructor : UnsupportedImageFormatException Constructor(Int32)

Initializes a new instance of the UnsupportedImageFormatException class.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer _
)
[C#]
public UnsupportedImageFormatException(
   int errorNumber
);
[C++]
public: UnsupportedImageFormatException(
   int errorNumber
)
[C++/CLI]
public:
UnsupportedImageFormatException(
   int errorNumber
)

Parameters

errorNumber
A number that represents the reason you are creating this exception object.

Requirements

Platforms: See Getting Started section

See Also

UnsupportedImageFormatException Class | UnsupportedImageFormatException Members | Overload List


%%PageItemTitle%%

UnsupportedImageFormatException Class | UnsupportedImageFormatException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

errorNumber
A number that represents the reason you are creating this exception object.
message
A string that describes the reason you are creating this exception object.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

UnsupportedImageFormatException Constructor(Int32,String)

PegasusImaging.WinForms.OcrXpress1 Namespace > UnsupportedImageFormatException Class > UnsupportedImageFormatException Constructor : UnsupportedImageFormatException Constructor(Int32,String)

Initializes a new instance of the UnsupportedImageFormatException class.

[Visual Basic]
Public Function New( _
   ByVal errorNumber As Integer, _
   ByVal message As String _
)
[C#]
public UnsupportedImageFormatException(
   int errorNumber,
   string message
);
[C++]
public: UnsupportedImageFormatException(
   int errorNumber,
   string* message
)
[C++/CLI]
public:
UnsupportedImageFormatException(
   int errorNumber,
   String^ message
)

Parameters

errorNumber
A number that represents the reason you are creating this exception object.
message
A string that describes the reason you are creating this exception object.

Requirements

Platforms: See Getting Started section

See Also

UnsupportedImageFormatException Class | UnsupportedImageFormatException Members | Overload List


%%PageItemTitle%%

UnsupportedImageFormatException Class | UnsupportedImageFormatException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string that describes the reason you are creating this exception object.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

UnsupportedImageFormatException Constructor(String)

PegasusImaging.WinForms.OcrXpress1 Namespace > UnsupportedImageFormatException Class > UnsupportedImageFormatException Constructor : UnsupportedImageFormatException Constructor(String)

Initializes a new instance of the UnsupportedImageFormatException class.

[Visual Basic]
Public Function New( _
   ByVal message As String _
)
[C#]
public UnsupportedImageFormatException(
   string message
);
[C++]
public: UnsupportedImageFormatException(
   string* message
)
[C++/CLI]
public:
UnsupportedImageFormatException(
   String^ message
)

Parameters

message
A string that describes the reason you are creating this exception object.

Requirements

Platforms: See Getting Started section

See Also

UnsupportedImageFormatException Class | UnsupportedImageFormatException Members | Overload List


%%PageItemTitle%%

UnsupportedImageFormatException Class | UnsupportedImageFormatException Members | Overload List

Requirements

Platforms: See Getting Started section

Language

Visual Basic

C#

C++

C++/CLI

Show All

message
A string that describes the reason you are creating this exception object.
innerException
The original exception that caused you to create this exception object.
See Also Languages PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

UnsupportedImageFormatException Constructor(String,Exception)

PegasusImaging.WinForms.OcrXpress1 Namespace > UnsupportedImageFormatException Class > UnsupportedImageFormatException Constructor : UnsupportedImageFormatException Constructor(String,Exception)

Initializes a new instance of the UnsupportedImageFormatException class.

[Visual Basic]
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
[C#]
public UnsupportedImageFormatException(
   string message,
   Exception innerException
);
[C++]
public: UnsupportedImageFormatException(
   string* message,
   Exception* innerException
)
[C++/CLI]
public:
UnsupportedImageFormatException(
   String^ message,
   Exception^ innerException
)

Parameters

message
A string that describes the reason you are creating this exception object.
innerException
The original exception that caused you to create this exception object.

Requirements

Platforms: See Getting Started section

See Also

UnsupportedImageFormatException Class | UnsupportedImageFormatException Members | Overload List


%%PageItemTitle%%

PegasusImaging.WinForms.OcrXpress1 Namespace | ErrorLevel Property | DebugLogFile Property

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

ErrorLevel Enumeration

PegasusImaging.WinForms.OcrXpress1 Namespace : ErrorLevel Enumeration (PegasusImaging.WinForms.OcrXpress1)

The error level of items to place into the debug log.

Members

Member | Description
Production | Place minimal information into the debug log file.
Development | Place information into the debug log file that is useful during normal development using this toolkit.
Detailed | Place as much information into the debug log file as possible. You should use this option when you are tracking down a problem.

Remarks

This enumeration allows you to specify the amount of detail to place into the debug log file and can be set by the ErrorLevel property.

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

See Also

PegasusImaging.WinForms.OcrXpress1 Namespace | ErrorLevel Property | DebugLogFile Property


%%PageItemTitle%%

PegasusImaging.WinForms.OcrXpress1 Namespace | EvaluationMode Property

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

EvaluationMode Enumeration

PegasusImaging.WinForms.OcrXpress1 Namespace : EvaluationMode Enumeration (PegasusImaging.WinForms.OcrXpress1)

The evaluation mode of the component.

Members

Member | Description
Automatic | Automatic evaluation mode. When possible, this component will automatically detect that it is running without a user interface and switch to another evaluation mode. Otherwise, it will display the evaluation mode dialog box.
Timeout | Timeout evaluation mode. When running in evaluation mode, this component will timeout after 5 minutes instead of displaying the evaluation mode dialog box. This is the appropriate evaluation mode for applications that have no user interface.

Remarks

To simplify your evaluation of this component, Pegasus Imaging Corporation has implemented an evaluation mode. Normally, this mode will display a dialog box reminding you that you are using evaluation mode. In certain environments with no user interface, such as services, displaying a dialog box will cause the application to stop and you must change the evaluation mode to avoid that problem.

Note: In addition to a dialog box displaying while using the trial version, OCR Xpress will randomly replace portions of text in the output with "www.PegasusImaging.com".

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

See Also

PegasusImaging.WinForms.OcrXpress1 Namespace | EvaluationMode Property


%%PageItemTitle%%

PegasusImaging.WinForms.OcrXpress1 Namespace

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

ExportFormat Enumeration

PegasusImaging.WinForms.OcrXpress1 Namespace : ExportFormat Enumeration

The available file formats to which recognition results can be exported.

Members

Member | Description
AsciiNoLineBreaks | An Ascii format with no line breaks.
Ascii | An Ascii format.
AsciiSmartFormatting | An Ascii format with smart formatting.
AsciiCommaDelimited | An Ascii format which is comma delimited.
AsciiTabDelimited | An Ascii format which is tab delimited.
Excel | An Excel format.
Html | A HTML format.
PdfImageOnly | A PDF image only format.
Pdf | A PDF format.
PdfImageWithText | A PDF image with text format.
Rtf | A RTF format.
Word | A Word format.
WordPefect | A WordPerfect format.

Remarks

The export format must be set prior to calling Export.

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

See Also

PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%%

PegasusImaging.WinForms.OcrXpress1 Namespace

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

ImageQuality Enumeration

PegasusImaging.WinForms.OcrXpress1 Namespace : ImageQuality Enumeration (PegasusImaging.WinForms.OcrXpress1)

The settings to specify the quality of the image to the recognition process.

Members

Member | Description
Normal | The image contains normal printed characters.
DotMatrix | The image contains draft quality dot matrix characters.
NormalDegraded | The image contains normal printed characters, and has degraded quality.

Remarks

The image quality must be set prior to calling Recognize.

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

See Also

PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%%

PegasusImaging.WinForms.OcrXpress1 Namespace

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

Language Enumeration

PegasusImaging.WinForms.OcrXpress1 Namespace : Language Enumeration (PegasusImaging.WinForms.OcrXpress1)

The languages supported by this component for recognition.

Members

Member | Description
English | Sets the recognition language to English.
French | Sets the recognition language to French.
German | Sets the recognition language to German.
Italian | Sets the recognition language to Italian.
Spanish | Sets the recognition language to Spanish.
Portuguese | Sets the recognition language to Portuguese.
Danish | Sets the recognition language to Danish.
Dutch | Sets the recognition language to Dutch.
Swedish | Sets the recognition language to Swedish.
Norwegian | Sets the recognition language to Norwegian.
Polish | Sets the recognition language to Polish.
Hungarian | Sets the recognition language to Hungarian.
Finnish | Sets the recognition language to Finnish.

Remarks

The desired language must be set prior to calling Recognize for it to be used.

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

See Also

PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%%

PegasusImaging.WinForms.OcrXpress1 Namespace | LicenseEdition Property | LicenseEdition Property

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

LicenseEditionType Enumeration

PegasusImaging.WinForms.OcrXpress1 Namespace : LicenseEditionType Enumeration

The supported License Edition types.

Members

Member | Description
Standard | Unlocks all functionality of the OCR Xpress component but does not include exporting results to all PDF formats.
Professional | Unlocks all functionality of the OCR Xpress component and includes exporting results to all PDF formats.

Remarks

This component can run in different modes, depending on which edition you purchase.

This enumeration can be set within the LicenseEdition property.

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

See Also

PegasusImaging.WinForms.OcrXpress1 Namespace | LicenseEdition Property | LicenseEdition Property


%%PageItemTitle%%

PegasusImaging.WinForms.OcrXpress1 Namespace | MultipageExport Property | Export Method

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

MultipageExport Enumeration

PegasusImaging.WinForms.OcrXpress1 Namespace : MultipageExport Enumeration (PegasusImaging.WinForms.OcrXpress1)

The settings to specify how multiple pages are handled during Export.

Members

Member | Description
NoSplit | All pages in the document will be exported to a single file. The filename is set by the filename argument of the Export method.
SplitOnBlankPage | Each group of pages separated by a blank page is written to a new file, using the name you provide, followed by a sequential three-digit number and the appropriate extension.
SplitOnEachPage | Each page of the document is written to a new file, using the name you provide, followed by a sequential three-digit number and the appropriate extension.

Remarks

The multi-page export option must be set prior to calling Recognize.

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

See Also

PegasusImaging.WinForms.OcrXpress1 Namespace | MultipageExport Property | Export Method


%%PageItemTitle%%

PegasusImaging.WinForms.OcrXpress1 Namespace

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

RejectionCharacter Enumeration

PegasusImaging.WinForms.OcrXpress1 Namespace : RejectionCharacter Enumeration (PegasusImaging.WinForms.OcrXpress1)

The allowable set of rejection characters.

Members

Member | Description
Tilde | Sets the '~' as the rejection character.
At | Sets the '@' as the rejection character.
Caret | Sets the '^' as the rejection character.
Pound | Sets the '#' as the rejection character.
Asterisk | Sets the '*' as the rejection character.
Ascii127 | Sets the '\127' as the rejection character. This is a non-printable ascii value.

Remarks

Use a rejection character in the recognition results, in place of a character that is either unreadable or recognized with an extremely low confidence.

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

See Also

PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%%

PegasusImaging.WinForms.OcrXpress1 Namespace

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

Language

Visual Basic

C#

C++

C++/CLI

Show All

See Also Languages Requirements PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

TextBoundary Enumeration

PegasusImaging.WinForms.OcrXpress1 Namespace : TextBoundary Enumeration (PegasusImaging.WinForms.OcrXpress1)

The settings to specify what the automatic region location process considers a text region.

Members

Member | Description
Normal | This setting is suitable for identifying text regions in most cases. Use Normal on pages with ordinary paragraphs, pages with mixed text and graphics, and on multi-column pages of text such as in newspapers and magazines. The Normal setting also works on most pages that have tables or tabular data.
SingleColumn | Use SingleColumn on pages that have side-by-side blocks of text that you want read from left to right across the page. When you use SingleColumn, this component always creates text regions that go from the left margin to the right margin of the page, regardless of the spacing between groups of words.

Remarks

The desired boundary must be set prior to calling Locate. for it to be used.

Requirements

Namespace: PegasusImaging.WinForms.OcrXpress1

Assembly: PegasusImaging.WinForms.OcrXpress1 (in PegasusImaging.WinForms.OcrXpress1.dll)

See Also

PegasusImaging.WinForms.OcrXpress1 Namespace


Glossary Item Box

PegasusImaging.WinForms.OcrXpress1

 Send comments on this topic.

Empty Index Entry

Empty Index Entry

The index entry you selected has no target topics associated with it.

If you have chosen a parent entry, please select a child entry.


Glossary Item Box

PegasusImaging.WinForms.OcrXpress1

 Send comments on this topic.

Topic Not Found

Topic Not Found

The link you just clicked was not able to connect to the target page.

Some possible reasons and remedies are as follows:

Reason | Remedy
Destination topic is not part of the area you specified in the Filtered by field. | Either select another filter or select (no filter).
The URL of the destination topic is incorrect or has changed. | Use the index or the search function instead.
Problems with the help installation. | Rerun Setup for the product this help is related to and select the 'Repair' option.

Additional help is available for filters, search, and the index.

Click Back to return to the page you were on.

The target parameters are:

Keyword:
Index Moniker:
URL:


%%Variable%%

Glossary Item Box

PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

Glossary

A | B | C | D | E | F | G | H | I | J | K | L | M | N | O | P | Q | R | S | T | U | V | W | X | Y | Z


%%phrase%%

PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

Assembly Overview

Namespaces

Namespace | Description
PegasusImaging.WinForms.OcrXpress1 |


$$GETTING_STARTED$$ - %%projecttitle%%

PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

Getting Started

© 1997 - 2007, Pegasus Imaging Corporation, All Rights Reserved.


$$INTRODUCTION$$ - %%projecttitle%%

PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

Introduction

© 1997 - 2007, Pegasus Imaging Corporation, All Rights Reserved.


%%PageItemTitle%% $$Methods$$

BitonalImageNotNeededException Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

BitonalImageNotNeededException Class Methods

PegasusImaging.WinForms.OcrXpress1 Namespace : BitonalImageNotNeededException Class

For a list of all members of this type, see BitonalImageNotNeededException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

BitonalImageNotNeededException Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%% $$Properties$$

BitonalImageNotNeededException Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

BitonalImageNotNeededException Class Properties

PegasusImaging.WinForms.OcrXpress1 Namespace : BitonalImageNotNeededException Class

For a list of all members of this type, see BitonalImageNotNeededException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from OcrXpressException) | The number of the error.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

BitonalImageNotNeededException Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%% $$Methods$$

Document Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

Document Class Methods

PegasusImaging.WinForms.OcrXpress1 Namespace : Document Class (PegasusImaging.WinForms.OcrXpress1)

For a list of all members of this type, see Document members.

Public Methods

Public Method AddPage | Overloaded.
Public Method AutoRotate | Detects the orientation of the image of a Page, and automatically rotates it if necessary.
Public Method ClearPages | Removes all Page objects from the document.
Public Method Deskew | Detects any skew in the image of a Page, and automatically corrects it if necessary.
Public Method Export | Writes the recognition results of all pages to a file with the specified format and name.
Public Method GetPage | Gets the Page object at the given index.
Public Method Locate | Performs automatic location to identify regions of text and pictures (optional) for a Page.
Public Method MovePage | Moves a Page object from one index to another.
Public Method Recognize | Performs recognition on a Page.
Public Method RemovePage | Removes a Page object from the document.

See Also

Document Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%% $$Methods$$

FileExportException Class | PegasusImaging.WinForms.OcrXpress1 Namespace | Export Method

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

FileExportException Class Methods

PegasusImaging.WinForms.OcrXpress1 Namespace : FileExportException Class

For a list of all members of this type, see FileExportException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

FileExportException Class | PegasusImaging.WinForms.OcrXpress1 Namespace | Export Method


%%PageItemTitle%% $$Properties$$

FileExportException Class | PegasusImaging.WinForms.OcrXpress1 Namespace | Export Method

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

FileExportException Class Properties

PegasusImaging.WinForms.OcrXpress1 Namespace : FileExportException Class

For a list of all members of this type, see FileExportException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from OcrXpressException) | The number of the error.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

FileExportException Class | PegasusImaging.WinForms.OcrXpress1 Namespace | Export Method


%%PageItemTitle%% $$Methods$$

FileInUseException Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

FileInUseException Class Methods

PegasusImaging.WinForms.OcrXpress1 Namespace : FileInUseException Class

For a list of all members of this type, see FileInUseException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

FileInUseException Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%% $$Properties$$

FileInUseException Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

FileInUseException Class Properties

PegasusImaging.WinForms.OcrXpress1 Namespace : FileInUseException Class

For a list of all members of this type, see FileInUseException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from OcrXpressException) | The number of the error.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

FileInUseException Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%% $$Methods$$

ImageNotAvailableException Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

ImageNotAvailableException Class Methods

PegasusImaging.WinForms.OcrXpress1 Namespace : ImageNotAvailableException Class

For a list of all members of this type, see ImageNotAvailableException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

ImageNotAvailableException Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%% $$Properties$$

ImageNotAvailableException Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

ImageNotAvailableException Class Properties

PegasusImaging.WinForms.OcrXpress1 Namespace : ImageNotAvailableException Class

For a list of all members of this type, see ImageNotAvailableException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from OcrXpressException) | The number of the error.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

ImageNotAvailableException Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%% $$Methods$$

ImageNullException Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

ImageNullException Class Methods

PegasusImaging.WinForms.OcrXpress1 Namespace : ImageNullException Class

For a list of all members of this type, see ImageNullException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

ImageNullException Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%% $$Properties$$

ImageNullException Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

ImageNullException Class Properties

PegasusImaging.WinForms.OcrXpress1 Namespace : ImageNullException Class

For a list of all members of this type, see ImageNullException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from OcrXpressException) | The number of the error.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

ImageNullException Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%% $$Methods$$

InternalErrorException Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

InternalErrorException Class Methods

PegasusImaging.WinForms.OcrXpress1 Namespace : InternalErrorException Class

For a list of all members of this type, see InternalErrorException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InternalErrorException Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%% $$Properties$$

InternalErrorException Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

InternalErrorException Class Properties

PegasusImaging.WinForms.OcrXpress1 Namespace : InternalErrorException Class

For a list of all members of this type, see InternalErrorException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from OcrXpressException) | The number of the error.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

InternalErrorException Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%% $$Methods$$

InvalidAreaException Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

InvalidAreaException Class Methods

PegasusImaging.WinForms.OcrXpress1 Namespace : InvalidAreaException Class

For a list of all members of this type, see InvalidAreaException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InvalidAreaException Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%% $$Properties$$

InvalidAreaException Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

InvalidAreaException Class Properties

PegasusImaging.WinForms.OcrXpress1 Namespace : InvalidAreaException Class

For a list of all members of this type, see InvalidAreaException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from OcrXpressException) | The number of the error.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

InvalidAreaException Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%% $$Methods$$

InvalidBitonalImageException Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

InvalidBitonalImageException Class Methods

PegasusImaging.WinForms.OcrXpress1 Namespace : InvalidBitonalImageException Class

For a list of all members of this type, see InvalidBitonalImageException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InvalidBitonalImageException Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%% $$Properties$$

InvalidBitonalImageException Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

InvalidBitonalImageException Class Properties

PegasusImaging.WinForms.OcrXpress1 Namespace : InvalidBitonalImageException Class

For a list of all members of this type, see InvalidBitonalImageException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from OcrXpressException) | The number of the error.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

InvalidBitonalImageException Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%% $$Methods$$

InvalidIndexException Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

InvalidIndexException Class Methods

PegasusImaging.WinForms.OcrXpress1 Namespace : InvalidIndexException Class

For a list of all members of this type, see InvalidIndexException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InvalidIndexException Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%% $$Properties$$

InvalidIndexException Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

InvalidIndexException Class Properties

PegasusImaging.WinForms.OcrXpress1 Namespace : InvalidIndexException Class

For a list of all members of this type, see InvalidIndexException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from OcrXpressException) | The number of the error.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

InvalidIndexException Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%% $$Methods$$

InvalidLicenseException Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

InvalidLicenseException Class Methods

PegasusImaging.WinForms.OcrXpress1 Namespace : InvalidLicenseException Class

For a list of all members of this type, see InvalidLicenseException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InvalidLicenseException Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%% $$Properties$$

InvalidLicenseException Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

InvalidLicenseException Class Properties

PegasusImaging.WinForms.OcrXpress1 Namespace : InvalidLicenseException Class

For a list of all members of this type, see InvalidLicenseException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from OcrXpressException) | The number of the error.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

InvalidLicenseException Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%% $$Methods$$

InvalidParameterException Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

InvalidParameterException Class Methods

PegasusImaging.WinForms.OcrXpress1 Namespace : InvalidParameterException Class

For a list of all members of this type, see InvalidParameterException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

InvalidParameterException Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%% $$Properties$$

InvalidParameterException Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

InvalidParameterException Class Properties

PegasusImaging.WinForms.OcrXpress1 Namespace : InvalidParameterException Class

For a list of all members of this type, see InvalidParameterException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from OcrXpressException) | The number of the error.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

InvalidParameterException Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%% $$Methods$$

Licensing Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

Licensing Class Methods

PegasusImaging.WinForms.OcrXpress1 Namespace : Licensing Class

For a list of all members of this type, see Licensing members.

Public Methods

Public Method UnlockRuntime | Unlocks the component for use in runtime environments.
Public Method UnlockWeb | Unlocks the component for use in web servers.

See Also

Licensing Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%% $$Methods$$

NullPageImageException Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

NullPageImageException Class Methods

PegasusImaging.WinForms.OcrXpress1 Namespace : NullPageImageException Class

For a list of all members of this type, see NullPageImageException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

NullPageImageException Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%% $$Properties$$

NullPageImageException Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

NullPageImageException Class Properties

PegasusImaging.WinForms.OcrXpress1 Namespace : NullPageImageException Class

For a list of all members of this type, see NullPageImageException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from OcrXpressException) | The number of the error.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

NullPageImageException Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%% $$Methods$$

NullPageRegionsException Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

NullPageRegionsException Class Methods

PegasusImaging.WinForms.OcrXpress1 Namespace : NullPageRegionsException Class

For a list of all members of this type, see NullPageRegionsException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

NullPageRegionsException Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%% $$Properties$$

NullPageRegionsException Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

NullPageRegionsException Class Properties

PegasusImaging.WinForms.OcrXpress1 Namespace : NullPageRegionsException Class

For a list of all members of this type, see NullPageRegionsException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from OcrXpressException) | The number of the error.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

NullPageRegionsException Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%% $$Events$$

OcrXpress Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

OcrXpress Class Events

PegasusImaging.WinForms.OcrXpress1 Namespace : OcrXpress Class

For a list of all members of this type, see OcrXpress members.

Public Events

Public Event Disposed (Inherited from System.ComponentModel.Component) Adds an event handler to listen to the Disposed event on the component.

See Also

OcrXpress Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%% $$Methods$$

OcrXpress Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

OcrXpress Class Methods

PegasusImaging.WinForms.OcrXpress1 Namespace : OcrXpress Class

For a list of all members of this type, see OcrXpress members.

Public Methods

Public Method AboutBox | Displays the toolkit about box.
Public Method CreateObjRef (Inherited from System.MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Public Method Dispose (Inherited from System.ComponentModel.Component) | Deletes the image contained within this object. Releases all resources used by the Component.
Public Method GetLifetimeService (Inherited from System.MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
Public Method InitializeLifetimeService (Inherited from System.MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Public Method ToString (Inherited from System.ComponentModel.Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.

See Also

OcrXpress Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%% $$Methods$$

OcrXpressException Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

OcrXpressException Class Methods

PegasusImaging.WinForms.OcrXpress1 Namespace : OcrXpressException Class

For a list of all members of this type, see OcrXpressException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

OcrXpressException Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%% $$Methods$$

Page Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

Page Class Methods

PegasusImaging.WinForms.OcrXpress1 Namespace : Page Class

For a list of all members of this type, see Page members.

Public Methods

Public Method ClearRegions | Removes all the regions on the page.
Public Method GetRegions | Gets the regions of a Page object.
Public Method GetResult | Returns a PageResult object containing all of the text recognition results for a Page.
Public Method SetRegions | Sets the regions of a Page object.

See Also

Page Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%% $$Methods$$

PageCountException Class | PegasusImaging.WinForms.OcrXpress1 Namespace | Export Method

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

PageCountException Class Methods

PegasusImaging.WinForms.OcrXpress1 Namespace : PageCountException Class

For a list of all members of this type, see PageCountException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

PageCountException Class | PegasusImaging.WinForms.OcrXpress1 Namespace | Export Method


%%PageItemTitle%% $$Properties$$

PageCountException Class | PegasusImaging.WinForms.OcrXpress1 Namespace | Export Method

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

PageCountException Class Properties

PegasusImaging.WinForms.OcrXpress1 Namespace : PageCountException Class

For a list of all members of this type, see PageCountException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from OcrXpressException) | The number of the error.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

PageCountException Class | PegasusImaging.WinForms.OcrXpress1 Namespace | Export Method


%%PageItemTitle%% $$Methods$$

PageResult Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

PageResult Class Methods

PegasusImaging.WinForms.OcrXpress1 Namespace : PageResult Class

For a list of all members of this type, see PageResult members.

Public Methods

Public Method GetTextBlockResult Gets a TextBlockResult from the PageResult at the specified index.

See Also

PageResult Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%% $$Methods$$

ParameterOutOfRangeException Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

ParameterOutOfRangeException Class Methods

PegasusImaging.WinForms.OcrXpress1 Namespace : ParameterOutOfRangeException Class

For a list of all members of this type, see ParameterOutOfRangeException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

ParameterOutOfRangeException Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%% $$Properties$$

ParameterOutOfRangeException Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

ParameterOutOfRangeException Class Properties

PegasusImaging.WinForms.OcrXpress1 Namespace : ParameterOutOfRangeException Class

For a list of all members of this type, see ParameterOutOfRangeException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from OcrXpressException) | The number of the error.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

ParameterOutOfRangeException Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%% $$Methods$$

PathNotFoundException Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

PathNotFoundException Class Methods

PegasusImaging.WinForms.OcrXpress1 Namespace : PathNotFoundException Class

For a list of all members of this type, see PathNotFoundException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

PathNotFoundException Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%% $$Properties$$

PathNotFoundException Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

PathNotFoundException Class Properties

PegasusImaging.WinForms.OcrXpress1 Namespace : PathNotFoundException Class

For a list of all members of this type, see PathNotFoundException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from OcrXpressException) | The number of the error.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

PathNotFoundException Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%% $$Properties$$

PictureRegion Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

PictureRegion Class Properties

PegasusImaging.WinForms.OcrXpress1 Namespace : PictureRegion Class

For a list of all members of this type, see PictureRegion members.

Public Properties

Public Property Area (Inherited from Region) The image area of the region (in pixels measured from the top left corner.)

See Also

PictureRegion Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%% $$Methods$$

RecognitionNotPerformedException Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

RecognitionNotPerformedException Class Methods

PegasusImaging.WinForms.OcrXpress1 Namespace : RecognitionNotPerformedException Class

For a list of all members of this type, see RecognitionNotPerformedException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

RecognitionNotPerformedException Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%% $$Properties$$

RecognitionNotPerformedException Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

RecognitionNotPerformedException Class Properties

PegasusImaging.WinForms.OcrXpress1 Namespace : RecognitionNotPerformedException Class

For a list of all members of this type, see RecognitionNotPerformedException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from OcrXpressException) | The number of the error.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

RecognitionNotPerformedException Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%% $$Methods$$

RegionCollection Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

RegionCollection Class Methods

PegasusImaging.WinForms.OcrXpress1 Namespace : RegionCollection Class

For a list of all members of this type, see RegionCollection members.

Public Methods

Public Method Add | Adds a Region to the collection.
Public Method Clear (Inherited from System.Collections.CollectionBase) | Removes all objects from the CollectionBase instance.
Public Method Contains | Determines if the specified Region is contained in the collection.
Public Method CopyTo | Copies a RegionCollection to a new collection.
Public Method GetEnumerator (Inherited from System.Collections.CollectionBase) | Returns an enumerator that iterates through the CollectionBase instance.
Public Method IndexOf | Determines if the specified Region is in the collection and returns it's index.
Public Method Insert | Inserts a Region into the collection at the given index.
Public Method Remove | Removes a Region from the collection.
Public Method RemoveAt (Inherited from System.Collections.CollectionBase) | Removes the element at the specified index of the CollectionBase instance.

See Also

RegionCollection Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%% $$Methods$$

RelativePathException Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

RelativePathException Class Methods

PegasusImaging.WinForms.OcrXpress1 Namespace : RelativePathException Class

For a list of all members of this type, see RelativePathException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

RelativePathException Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%% $$Properties$$

RelativePathException Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

RelativePathException Class Properties

PegasusImaging.WinForms.OcrXpress1 Namespace : RelativePathException Class

For a list of all members of this type, see RelativePathException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from OcrXpressException) | The number of the error.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

RelativePathException Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%% $$Methods$$

TextBlockResult Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

TextBlockResult Class Methods

PegasusImaging.WinForms.OcrXpress1 Namespace : TextBlockResult Class

For a list of all members of this type, see TextBlockResult members.

Public Methods

Public Method GetTextLineResult Returns the TextLineResult at the index within its parent TextBlockResult.

See Also

TextBlockResult Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%% $$Methods$$

TextLineResult Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

TextLineResult Class Methods

PegasusImaging.WinForms.OcrXpress1 Namespace : TextLineResult Class

For a list of all members of this type, see TextLineResult members.

Public Methods

Public Method GetFontMap | The FontMap at the given index.
Public Method GetSuspectCharacter | The CharacterResult at the given index.

See Also

TextLineResult Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%% $$Methods$$

TextTooLongException Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

TextTooLongException Class Methods

PegasusImaging.WinForms.OcrXpress1 Namespace : TextTooLongException Class

For a list of all members of this type, see TextTooLongException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

TextTooLongException Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%% $$Properties$$

TextTooLongException Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

TextTooLongException Class Properties

PegasusImaging.WinForms.OcrXpress1 Namespace : TextTooLongException Class

For a list of all members of this type, see TextTooLongException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from OcrXpressException) | The number of the error.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

TextTooLongException Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%% $$Methods$$

TimeoutErrorException Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

TimeoutErrorException Class Methods

PegasusImaging.WinForms.OcrXpress1 Namespace : TimeoutErrorException Class

For a list of all members of this type, see TimeoutErrorException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

TimeoutErrorException Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%% $$Properties$$

TimeoutErrorException Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

TimeoutErrorException Class Properties

PegasusImaging.WinForms.OcrXpress1 Namespace : TimeoutErrorException Class

For a list of all members of this type, see TimeoutErrorException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from OcrXpressException) | The number of the error.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

TimeoutErrorException Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%% $$Methods$$

UnsupportedImageFormatException Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

UnsupportedImageFormatException Class Methods

PegasusImaging.WinForms.OcrXpress1 Namespace : UnsupportedImageFormatException Class

For a list of all members of this type, see UnsupportedImageFormatException members.

Public Methods

Public Method GetBaseException (Inherited from System.Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
Public Method GetObjectData (Inherited from System.Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
Public Method GetType (Inherited from System.Exception) | Gets the runtime type of the current instance.
Public Method ToString (Inherited from System.Exception) | Creates and returns a string representation of the current exception.

See Also

UnsupportedImageFormatException Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%PageItemTitle%% $$Properties$$

UnsupportedImageFormatException Class | PegasusImaging.WinForms.OcrXpress1 Namespace

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

UnsupportedImageFormatException Class Properties

PegasusImaging.WinForms.OcrXpress1 Namespace : UnsupportedImageFormatException Class

For a list of all members of this type, see UnsupportedImageFormatException members.

Public Properties

Public Property Data (Inherited from System.Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
Public Property ErrorNumber (Inherited from OcrXpressException) | The number of the error.
Public Property HelpLink (Inherited from System.Exception) | Gets or sets a link to the help file associated with this exception.
Public Property InnerException (Inherited from System.Exception) | Gets the Exception instance that caused the current exception.
Public Property Message (Inherited from System.Exception) | Gets a message that describes the current exception.
Public Property Source (Inherited from System.Exception) | Gets or sets the name of the application or the object that causes the error.
Public Property StackTrace (Inherited from System.Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
Public Property TargetSite (Inherited from System.Exception) | Gets the method that throws the current exception.

See Also

UnsupportedImageFormatException Class | PegasusImaging.WinForms.OcrXpress1 Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

PegasusImaging.WinForms.OcrXpress1 Assembly

See Also PegasusImaging.WinForms.OcrXpress1 Send comments on this topic.

PegasusImaging.WinForms.OcrXpress1 Namespace Inheritance Hierarchy

System.Object
PegasusImaging.WinForms.OcrXpress1.CharacterResult
PegasusImaging.WinForms.OcrXpress1.DeskewStatus
PegasusImaging.WinForms.OcrXpress1.Document
PegasusImaging.WinForms.OcrXpress1.FontMap
PegasusImaging.WinForms.OcrXpress1.Licensing
PegasusImaging.WinForms.OcrXpress1.Page
PegasusImaging.WinForms.OcrXpress1.PageResult
PegasusImaging.WinForms.OcrXpress1.Region
PegasusImaging.WinForms.OcrXpress1.PictureRegion
PegasusImaging.WinForms.OcrXpress1.TextRegion
PegasusImaging.WinForms.OcrXpress1.TextBlockResult
PegasusImaging.WinForms.OcrXpress1.TextLineResult
System.Collections.CollectionBase
PegasusImaging.WinForms.OcrXpress1.RegionCollection
System.Exception
System.ApplicationException
PegasusImaging.WinForms.OcrXpress1.OcrXpressException
PegasusImaging.WinForms.OcrXpress1.BitonalImageNotNeededException
PegasusImaging.WinForms.OcrXpress1.FileExportException
PegasusImaging.WinForms.OcrXpress1.FileInUseException
PegasusImaging.WinForms.OcrXpress1.ImageNotAvailableException
PegasusImaging.WinForms.OcrXpress1.ImageNullException
PegasusImaging.WinForms.OcrXpress1.InternalErrorException
PegasusImaging.WinForms.OcrXpress1.InvalidAreaException
PegasusImaging.WinForms.OcrXpress1.InvalidBitonalImageException
PegasusImaging.WinForms.OcrXpress1.InvalidIndexException
PegasusImaging.WinForms.OcrXpress1.InvalidLicenseException
PegasusImaging.WinForms.OcrXpress1.InvalidParameterException
PegasusImaging.WinForms.OcrXpress1.NullPageImageException
PegasusImaging.WinForms.OcrXpress1.NullPageRegionsException
PegasusImaging.WinForms.OcrXpress1.PageCountException
PegasusImaging.WinForms.OcrXpress1.ParameterOutOfRangeException
PegasusImaging.WinForms.OcrXpress1.PathNotFoundException
PegasusImaging.WinForms.OcrXpress1.RecognitionNotPerformedException
PegasusImaging.WinForms.OcrXpress1.RelativePathException
PegasusImaging.WinForms.OcrXpress1.TextTooLongException
PegasusImaging.WinForms.OcrXpress1.TimeoutErrorException
PegasusImaging.WinForms.OcrXpress1.UnsupportedImageFormatException
System.MarshalByRefObject
System.ComponentModel.Component
PegasusImaging.WinForms.OcrXpress1.OcrXpress

See Also

PegasusImaging.WinForms.OcrXpress1 Namespace | PegasusImaging.WinForms.OcrXpress1 Assembly